 CompanyManager オブジェクト

CompanyManagerオブジェクト。

会社や組織に関連する情報の参照、更新を行うマネージャオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
CompanyManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addCompany (CompanyDetailInfo company) 会社を登録します。
ResultInfo | addDepartment (DepartmentDetailInfo department) 組織を登録します。
ResultInfo | addPost (PostDetailInfo post) 役職を登録します。
ResultInfo | addVersion (CompanyVersionInfo version) 会社構成バージョンを登録します。
ResultInfo | copyVersion (String company ,String srcVersion ,String destVersion ,Date startDate ,Date endDate) 登録済の会社構成バージョンの内容をコピーします。
ResultInfo | deleteCompany (CompanyDetailInfo company) 登録済の会社を削除します。
ResultInfo | deleteDepartment (DepartmentDetailInfo department) 登録済の組織情報を削除します。
ResultInfo | deleteMember (DepartmentAttachInfo departmentAttach) 組織から人員をはずします。
ResultInfo | deletePost (PostDetailInfo post) 登録済の役職情報を削除します。
ResultInfo | deleteVersion (CompanyVersionInfo version) 登録済の会社構成バージョンを削除します。
ResultInfo | getAttachedDepartments (String userCode [,Date date]) ユーザが所属する組織の一覧を取得します。
ResultInfo | getDepartment (String companyCode ,String departmentCode) 組織の詳細情報を取得します。
ResultInfo | getDepartmentAttach (String userCode ,String companyCode ,String departmentCode) ユーザの組織への所属情報を取得します。
ResultInfo | getDepartmentMain (String userCode) ユーザの主所属情報を取得します。
ResultInfo | getDepartmentStructs (String company ,String department ,Date date ,String locale) 組織の階層構造を取得します。
ResultInfo | getMember (String companyCode ,String departmentCode [,Date date]) 組織に所属する人員の一覧を取得します。
ResultInfo | getPostsInCompany (String company [,Date date] [,String locale]) 会社に登録されている役職の一覧を取得します。
ResultInfo | getPostsOfUser (String company ,String user [,Date date] [,String locale]) ユーザに対して設定されている役職の一覧を取得します。
ResultInfo | getVersion (String companyCode [,Date date]) 会社構成バージョン情報を取得します。
ResultInfo | joinDepartment (String company ,String parentDepartment ,String department ,String version) 組織構成に組織を登録します。
ResultInfo | leaveDepartment (String company ,String department ,String version) 組織構成から組織情報を離脱させます。
ResultInfo | moveDepartment (String company ,String parentDepartment ,String department ,String version) 組織構成に登録済の組織情報を移動します。
ResultInfo | removeCategoryDetail (CompanyCategoryInfo category) 組織に対して指定された分類区分情報を削除します。
ResultInfo | removeMain (DepartmentMainInfo main) 指定されたユーザの主所属を削除します。
ResultInfo | setCategoryDetail (CompanyCategoryInfo category) 組織に対して指定された分類区分情報を設定します。
ResultInfo | setMain (DepartmentMainInfo main) ユーザが主所属する組織を設定します。
ResultInfo | setMember (DepartmentAttachInfo departmentAttach) 組織に人員を割り当てます。
ResultInfo | updateDepartment (DepartmentDetailInfo department) 登録済の組織情報を更新します。
ResultInfo | updatePost (PostDetailInfo post) 登録済の役職情報を更新します。
ResultInfo | updateVersion (CompanyVersionInfo version) 登録済の会社構成バージョンを更新します。
コンストラクタの詳細
CompanyManager

CompanyManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addCompany

ResultInfo addCompany (CompanyDetailInfo company)

会社を登録します。

このメソッドを実行すると下記のような動作が行われます。
  1. 会社を新規登録する。
  2. 会社に対応する組織を新規登録する。
パラメータ
company CompanyDetailInfo 会社詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
addDepartment

ResultInfo addDepartment (DepartmentDetailInfo department)

組織を登録します。

このメソッドを実行しただけではまだ会社の組織構成には追加されていません。
組織構成に追加したい場合はjoinDepartment(String, String, String, String) を使用してください。
パラメータ
department DepartmentDetailInfo 組織詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
addPost

ResultInfo addPost (PostDetailInfo post)

役職を登録します。

パラメータ
post PostDetailInfo 役職詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
addVersion

ResultInfo addVersion (CompanyVersionInfo version)

会社構成バージョンを登録します。

追加された構成バージョンのトップレベルには、会社に該当する組織が自動的に追加されます。
パラメータ
version CompanyVersionInfo 会社構成バージョン情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
copyVersion

ResultInfo copyVersion (String company ,String srcVersion ,String destVersion ,Date startDate ,Date endDate)

登録済の会社構成バージョンの内容をコピーします。

コピー元の会社構成バージョンに関連する、
全ての組織内包がコピー先の会社構成バージョンに関連づくようにコピーされます。
コピー元のバージョンコードは登録済みのものを選択してください。
コピー先のバージョンコードは登録されていないものを選択してください。
パラメータ
company | String | コピー元、コピー先の会社構成バージョンの会社コード
srcVersion | String | コピー元の会社構成バージョンのバージョンコード
destVersion | String | コピー先の会社構成バージョンのバージョンコード
startDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間開始日時
endDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間終了日時
返却値
ResultInfo 処理結果オブジェクト
deleteCompany

ResultInfo deleteCompany (CompanyDetailInfo company)

登録済の会社を削除します。

このメソッドを実行すると指定された会社に関連する全ての情報が削除されます。
指定された会社の情報が存在しない場合は処理失敗となります。
パラメータ
company CompanyDetailInfo 会社詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteDepartment

ResultInfo deleteDepartment (DepartmentDetailInfo department)

登録済の組織情報を削除します。

指定された組織情報が存在しない場合は処理失敗となります。
パラメータ
department DepartmentDetailInfo 組織詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteMember

ResultInfo deleteMember (DepartmentAttachInfo departmentAttach)

組織から人員をはずします。

指定された人員の情報が存在しない場合は処理失敗となります。
パラメータ
departmentAttach DepartmentAttachInfo 組織から外す人員の情報
返却値
ResultInfo 処理結果オブジェクト
deletePost

ResultInfo deletePost (PostDetailInfo post)

登録済の役職情報を削除します。

指定された役職情報が存在しない場合は処理失敗となります。
パラメータ
post PostDetailInfo 役職詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteVersion

ResultInfo deleteVersion (CompanyVersionInfo version)

登録済の会社構成バージョンを削除します。

指定された会社構成バージョンの情報が存在しない場合は処理失敗となります。
パラメータ
version CompanyVersionInfo 会社構成バージョン情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getAttachedDepartments

ResultInfo getAttachedDepartments (String userCode [,Date date])

ユーザが所属する組織の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。

検索結果は、処理結果オブジェクトの data属性に組織詳細情報オブジェクトの配列 (Array) として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パラメータ
userCode | String | ユーザコード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：5.1
getDepartment

ResultInfo getDepartment (String companyCode ,String departmentCode)

組織の詳細情報を取得します。

検索結果は、処理結果オブジェクトの data属性に組織詳細情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。

パラメータ
companyCode | String | 会社コード
departmentCode | String | 組織コード
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：5.1
getDepartmentAttach

ResultInfo getDepartmentAttach (String userCode ,String companyCode ,String departmentCode)

ユーザの組織への所属情報を取得します。

検索結果は処理結果オブジェクトの data属性に組織所属情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。

パラメータ
userCode | String | ユーザコード
companyCode | String | 会社コード
departmentCode | String | 組織コード
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：5.1
getDepartmentMain

ResultInfo getDepartmentMain (String userCode)

ユーザの主所属情報を取得します。

検索結果は、処理結果オブジェクトの data属性に主所属情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。

パラメータ
userCode String ユーザコード
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：5.1
getDepartmentStructs

ResultInfo getDepartmentStructs (String company ,String department ,Date date ,String locale)

組織の階層構造を取得します。

検索結果は、処理結果オブジェクトの data属性に組織階層情報オブジェクトの配列 として設定されます。

指定された日付に該当する会社構成バージョンが存在しない場合は、エラーとなります。
また、会社構成バージョンは存在するが該当する組織情報が存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パラメータ
company | String | 会社コード
department | String | 組織コード
date | Date | 日付
locale | String | 言語
返却値
ResultInfo 処理結果オブジェクト
getMember

ResultInfo getMember (String companyCode ,String departmentCode [,Date date])

組織に所属する人員の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。

検索結果は、処理結果オブジェクトの data属性にユーザ情報オブジェクトの配列 (Array) として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

ユーザ情報オブジェクトに設定される期間化情報は、検索で使用された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。
パラメータ
companyCode | String | 会社コード
departmentCode | String | 組織コード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：5.1
getPostsInCompany

ResultInfo getPostsInCompany (String company [,Date date] [,String locale])

会社に登録されている役職の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。
また言語が指定されない場合は、ログインユーザのデフォルト言語の情報が取得されます。

検索結果は、処理結果オブジェクトの data属性に非構造化役職オブジェクトの配列として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パラメータ
company | String | 会社コード
date | Date | 日付 (省略可能)
locale | String | 言語 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
getPostsOfUser

ResultInfo getPostsOfUser (String company ,String user [,Date date] [,String locale])

ユーザに対して設定されている役職の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。
また言語が指定されない場合は、ログインユーザのデフォルト言語の情報が取得されます。

検索結果は、処理結果オブジェクトの data属性に非構造化役職オブジェクトの配列として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パラメータ
company | String | 会社コード
user | String | ユーザコード
date | Date | 日付 (省略可能)
locale | String | 言語 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
getVersion

ResultInfo getVersion (String companyCode [,Date date])

会社構成バージョン情報を取得します。

日付が指定されない場合は、システム日付を含む期間のバージョン情報を取得します。

検索結果は、処理結果オブジェクトの data属性に会社構成バージョン情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。

パラメータ
companyCode | String | 会社コード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
導入されたバージョン：5.1
joinDepartment

ResultInfo joinDepartment (String company ,String parentDepartment ,String department ,String version)

組織構成に組織を登録します。

新しく親となる組織と登録対象の組織は同一の会社に所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。

指定された組織が対象のバージョンにおいて既に登録されているときはこのメソッドは使用できません。
パラメータ
company | String | 会社コード
parentDepartment | String | 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department | String | 新規登録する組織の組織コード（会社に該当する組織は指定できない）
version | String | バージョンコード
返却値
ResultInfo 処理結果オブジェクト
leaveDepartment

ResultInfo leaveDepartment (String company ,String department ,String version)

組織構成から組織情報を離脱させます。

このメソッドを実行すると、指定された組織を指定されたバージョンから削除します。
指定された組織が子組織を持っていた場合、それらの組織も再帰的にこのバージョンから削除されます。
このメソッドを実行しても組織情報そのものは残ります。
指定された組織が組織構成に登録されていない場合は処理失敗となります。
パラメータ
company | String | 会社コード
department | String | 離脱させる組織の組織コード（会社に該当する組織は指定できない）
version | String | バージョンコード
返却値
ResultInfo 処理結果オブジェクト
moveDepartment

ResultInfo moveDepartment (String company ,String parentDepartment ,String department ,String version)

組織構成に登録済の組織情報を移動します。

新しく上位となる組織と移動対象の組織は同一の会社に所属している必要があります。
また、組織構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります
パラメータ
company | String | 上位組織と移動対象の組織画所属する会社の会社コード
parentDepartment | String | 上位組織の組織コード（または会社の会社コード）
department | String | 移動する組織の組織コード（会社に該当する組織は指定できない）
version | String | バージョンコード
返却値
ResultInfo 処理結果オブジェクト
removeCategoryDetail

ResultInfo removeCategoryDetail (CompanyCategoryInfo category)

組織に対して指定された分類区分情報を削除します。

パラメータ
category CompanyCategoryInfo 会社分類区分情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
removeMain

ResultInfo removeMain (DepartmentMainInfo main)

指定されたユーザの主所属を削除します。

パラメータ
main DepartmentMainInfo 主所属情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setCategoryDetail

ResultInfo setCategoryDetail (CompanyCategoryInfo category)

組織に対して指定された分類区分情報を設定します。

パラメータ
category CompanyCategoryInfo 会社分類区分情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setMain

ResultInfo setMain (DepartmentMainInfo main)

ユーザが主所属する組織を設定します。

既存の主所属情報は新しい情報で上書きされます。
パラメータ
main DepartmentMainInfo 主所属情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setMember

ResultInfo setMember (DepartmentAttachInfo departmentAttach)

組織に人員を割り当てます。

人員の割当情報がすでに設定されている場合は、パラメータで渡された情報で完全に上書きされます。
パラメータ
departmentAttach DepartmentAttachInfo 割当人員の情報
返却値
ResultInfo 処理結果オブジェクト
updateDepartment

ResultInfo updateDepartment (DepartmentDetailInfo department)

登録済の組織情報を更新します。

パラメータ
department DepartmentDetailInfo 組織詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
updatePost

ResultInfo updatePost (PostDetailInfo post)

登録済の役職情報を更新します。

パラメータ
post PostDetailInfo 役職詳細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
updateVersion

ResultInfo updateVersion (CompanyVersionInfo version)

登録済の会社構成バージョンを更新します。

パラメータ
version CompanyVersionInfo 会社構成バージョン情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 CompanyVersionInfo オブジェクト

会社構成バージョン情報オブジェクト。

会社構成バージョン情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
Date | endDate 有効期間終了日時。 | 通常
String | notes 備考。 | 通常
Date | startDate 有効期間開始日時。 | 通常
String | versionCode バージョンコード。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
endDate

Date endDate

有効期間終了日時。
notes

String notes

備考。
startDate

Date startDate

有効期間開始日時。
versionCode

String versionCode

バージョンコード。


 Constant オブジェクト

定数値管理オブジェクト。

定数値を管理するＡＰＩです。
メソッド define()で設定された値は、Constant オブジェクトのプロパティ値としてプロセス内のすべてのファンクション・コンテナから変更不能な定数値として参照することができます。
このＡＰＩの設定値は、Application Runtime の動作しているサーバ・プロセスをスコープとして管理されます。他のサーバ・プロセスから参照(値の共有)をすることはできません。
また、プロセスが終了するまで値の参照は保証されます(プロセスが終了した場合は、値も破棄されます)。

このオブジェクトの同一プロパティ(key)に対して定数値の二重定義はできません。
バージョン：1.0
導入されたバージョン：2.11
メソッドの概要
static void | define (String key ,String value) 定数値を設定します。
static void | load (String src) 定数値設定ファイルを読込ます。
メソッドの詳細
define

static void define (String key ,String value)

定数値を設定します。

システムで共通の定数値を設定します。
引数 key で指定した文字列が Constant オブジェクトのプロパティとなり、設定後は Constant オブジェクトを介して key で指定されたプロパティにより定数値 value を参照できるようになります。

Constant.key == value

例:
Constant.define("product_name", "intra-mart");
Debug.browse(Constant.product_name);

画面には、変数の内容として intra-mart が表示されます。
パラメータ
key | String | 定数値参照名称
value | String | 定数値
返却値
void
load

static void load (String src)

定数値設定ファイルを読込ます。

指定ファイル内に定義されたシステムで共通の定数値を設定します。
引数には、ファイルのラベル名称を指定して下さい。
設定ファイル内には、通常のファンクション・コンテナを作成する要領で、グローバル変数を定義して下さい。
グローバル変数の宣言は初期化（初期値代入）を伴うように記述して下さい。グローバル変数に対して初期値が設定されていない場合、正しく定数値を設定することができません。

定義ファイルが読み込まれた後は、定義ファイル内のグローバル変数名が Constant オブジェクトのプロパティ名称となり、グローバル変数値が定数値として設定されます。

Constant.変数名 == 変数値

例:
定義ファイル（test.js）
var SUN = 0;
var MON = 1;
var TUE = 2;
var WED = 3;
var THU = 4;
var FRI = 5;
var SAT = 6;
ファンクション・コンテナ

Constant.load("test");
Debug.browse(Constant.WED);

画面には、変数の内容として 3 が表示されます。
パラメータ
src String 定数値設定ファイル名称（拡張子なし）
返却値
void


 Content オブジェクト

コンテンツクラス。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
Content (String srcPath)
コンストラクタ。
メソッドの概要
String | execute (Object value) コンテンツの実行と生成をします。
static Object | executeFunction (String path ,String functionName [,Object arg] [,... ...]) 指定されたページのファンクションコンテナ内に定義されている関数を実行します。
Function | getFunction (String functionName) コンストラクタで指定したページのファンクションコンテナ内に定義されている関数を取得します。
Boolean | isError () コンテンツが実行可能かどうかチェックします。
String | toString () オブジェクトの文字列表現を返却します。
コンストラクタの詳細
Content

Content (String srcPath)
コンストラクタ。

ソースパスは サーバディレクトリ/pagesからの相対指定で拡張子なしの形式の文字列を指定します。
該当する .html ファイルと .js ファイルを読込＆解析し、実行可能オブジェクトを構築します。
パラメータ
srcPath String ソースパス
メソッドの詳細
execute

String execute (Object value)

コンテンツの実行と生成をします。
パラメータ
value Object ファンクションコンテナ内 init() への引数
返却値
String 実行結果HTMLソース
executeFunction

static Object executeFunction (String path ,String functionName [,Object arg] [,... ...])

指定されたページのファンクションコンテナ内に定義されている関数を実行します。
パラメータ
path | String | ページパス（拡張子なし）
functionName | String | 実行関数名
arg | Object | 関数への引数（任意）
... ... 複数指定する場合は、カンマの後に続けて指定します。
返却値
Object 関数実行結果オブジェクト
導入されたバージョン：6.1
getFunction

Function getFunction (String functionName)

コンストラクタで指定したページのファンクションコンテナ内に定義されている関数を取得します。 引数で指定した関数が存在しない場合は、nullを返却します。
パラメータ
functionName String 関数名
返却値
Function 関数
導入されたバージョン：6.1
isError

Boolean isError ()

コンテンツが実行可能かどうかチェックします。
ＨＴＭＬファイルが見つからなかった場合 true を返却します。
返却値
Boolean true ： 実行不可能状態 / false ： 実行可能
toString

String toString ()

オブジェクトの文字列表現を返却します。
返却値
String このインスタンスの文字列表現


 CurrencyManager オブジェクト

CurrencyManagerオブジェクト
通貨に関連する情報の参照を行うマネージャオブジェクトです。
バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
CurrencyManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | getCurrencyCodes () 通貨コードの一覧を返します。
ResultInfo | getCurrencyName (String currencyCode [,String locale]) 通貨コードに対する名称を返します。
ResultInfo | getSystemCurrencyCode () システム通貨コードを返します。
コンストラクタの詳細
CurrencyManager

CurrencyManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
getCurrencyCodes

ResultInfo getCurrencyCodes ()

通貨コードの一覧を返します。
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に通貨コード(String) の一覧 (Array)が設定されます。
getCurrencyName

ResultInfo getCurrencyName (String currencyCode [,String locale])

通貨コードに対する名称を返します。

通貨コードが存在しない場合は、処理失敗となります。
パラメータ
currencyCode | String | 通貨情報を指定する通貨コード
locale | String | 通貨名を指定するロケール
返却値
ResultInfo 処理結果オブジェクト

引数にロケールの指定をしなかった場合
通貨処理結果オブジェクトの属性data[ロケール]の値が通貨名（String）となります。

引数にロケールの指定をした場合
の処理結果オブジェクトの構成は以下のとおりです。
通貨処理結果オブジェクトの属性dataの値が通貨名（String）となります。
getSystemCurrencyCode

ResultInfo getSystemCurrencyCode ()

システム通貨コードを返します。
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性にシステム通貨コード(String)が設定されます。


 CSVParser オブジェクト

CSV解析オブジェクト。

CSV形式で書かれている文字列から２次元配列を作成します。
バージョン：1.0
導入されたバージョン：2.11
メソッドの概要
static Array parse (String csvtext ,String delimita)
CSV形式の文字列の解析を行います。
メソッドの詳細
parse

static Array parse (String csvtext ,String delimita)

CSV形式の文字列の解析を行います。

CSV形式のデータが保管されている文字列を２次元配列データに変換します。
パラメータ
csvtext | String | CSV形式の文字列
delimita | String | CSV形式の区切り文字（" ","\t","," など１文字で指定）
返却値
Array 文字列の２次元配列データ


 DatabaseManager オブジェクト

データベースマネージャ。

データベースに対する操作を行うマネージャです。

各メソッドの引数に、”接続名”とありますが、この引数を指定した場合は、指定した引数値と同じ接続名のシステムデータベースへ接続されます。
これを指定しなかった場合、現在ログインしているログイングループのログイングループのデータベースへ接続されます。
システムデータベースとは、ServerManager/conf/data-source.xml内で<system-data-source>タグで設定されているデータベースです。
ログイングループのデータベースとは、ServerManager/conf/data-source.xml内で<group-data-source>タグで設定されているデータベースです。
DBから取得するカラムの型変換は以下の通りです。
Javaでの型 | JavaScriptでの型 | 注意事項
String String ---
int Number ---
short Number ---
float Number ---
double Number ---
Date Date ---
Timestamp DateまたはString ---
Time Date ---
Clob | String | DB2の場合、fetchメソッドで取得する場合は、「高速フェッチモード」である必要があります。
Blob(バイナリ系カラム) --- 取得、更新ともに取り扱うことができません
null null ---
その他 StringまたはJavaオブジェクト ---

【注意】Microsoft SQL Serverでnchar,nvarcharなどUnicode対応されたカラムを利用する場合の注意点
SQL文でnvarcharのカラムに対して、リテラル文字列を利用して比較(WHERE句)および代入（SET句）を行う場合は
以下のように記述する必要があります。
update table_name set name = N'名前' where name = N'姓名'
リテラル文字列の前にNを付加します。
Nを付加しない場合、文字化けや条件にマッチしないことがあります。
バインド変数'?'を用いる場合は、この問題は発生しません
【PreparedStatement更新モード】の有効/無効オプション
    DatabaseManager#updateおよびinsertを用いた場合に内部でのSQL文の作成方式を変更するオプションです。

    設定値 | 動作
    有効(true) | PreparedStatementを用いたSQL文の作成方式（新仕様）
    無効(false) | 文字列連結によるSQL文の作成方式（旧仕様）
  • 設定方法 <prepared-modify>タグ
      imart.xmlに以下のタグ内に<prepared-modify>タグを追加し、<prepared-modify>タグ内にtrue/falseを設定します。

      intra-mart/platform/service/application/database

      設定を省略した場合のデフォルトはfalseとなります。

      この修正によりPostgreSQLでは、数値型カラムに文字列型で更新、挿入できない不具合が確認されておりますので
      このオプションの設定にかかわらず、必ず文字列連結によるSQL文の作成方式（旧仕様）を用います。

  • trueを設定した場合の改善点および注意点
    • PreparedStatementを用いたSQL文の作成方式を用います。（新仕様）
      updateのset句、およびinsertのvalues句のみ対応
      updateのwhere句については、互換性維持のため未対応となっています。
      (全DB)

    • nvarchar系に対するUTF-8の文字での更新、挿入が可能になります。
      （Microsoft SQL Server）

  • falseを設定した場合の問題点
    • nvarchar系に対するUTF-8の文字での更新、挿入で文字化けが発生します。
      （Microsoft SQL Server）
【高速フェッチ】の有効/無効オプション
    DatabaseManager#fetchを用いた場合に内部でのSQL文の作成方式を変更するオプションです。

    設定値 | 動作
    有効(true) | DBに問い合わせるSQL文を加工し、対象行のみを取得（新仕様）
    無効(false) | DBに問い合わせるSQL文を加工せず、DBカーソルをスキップして対象行を取得（旧仕様）
  • 設定方法 <fast-fetch>タグ
      imart.xmlに以下のタグ内に<fast-fetch>タグを追加し、<fast-fetch>タグ内にtrue/falseを設定します。

      intra-mart/platform/service/application/database

      なお、設定を省略した場合のデフォルトはfalseとなります。

  • trueを設定した場合の改善点
    • 大量データに対する取得の場合、JDBC内でメモリーリークが発生しないようになります。
      （Oracle, PostgreSQL）
    • 大量データに対するフェッチのパフォーマンスが改善します。
      （全DB）
    • データベースのLOB系(BLOB,CLOB)のカラム情報が取得できるようになります。
      （DB2）

  • trueを設定した場合の問題点
    • selectカラムで別テーブルの同じカラム名をエイリアスを利用しないで、同時に取得するとSQLエラーになります。
      （例） select a.name,b.name from a,b where a.id = b.id
      （Oracle, Microsoft SQL Server）

      なお、falseを設定した場合、この事象は発生しません。

  • falseを設定した場合の問題点
    • 量データに対するフェッチの場合、JDBC内でメモリーリークが発生し、OutOfMemoryが発生します。
      （Oracle, PostgreSQL）
    • データベースのLOB系のカラム情報が取得できない。
      （DB2）
    • ・大量データに対するフェッチが遅い。
      （全DB）
【SqlServer2000】の有効/無効オプション
    【高速フェッチ】は Microsoft SQL Server 2005から追加されたSQL関数を利用しているため、
    Microsoft SQL Server 2000では利用できないため、これを判別するためのオプションです。

    設定値 | 動作
    有効(true) | 対象DBがSQL Serverの場合、【高速フェッチ】のオプション設定は必ずfalseとして扱います。
    無効(false) | 対象DBがSQL Serverの場合、【高速フェッチ】のオプション設定に従って、動作します。
  • 設定方法 <sql-server2000>タグ
      imart.xmlに以下のタグ内に<sql-server2000>タグを追加し、<sql-server2000>タグ内にtrue/falseを設定します。
      intra-mart/platform/service/application/database

      設定を省略した場合のデフォルトはtrueとなります。

  • trueを設定した場合の問題点
    • 大量データに対するフェッチが遅い
      （Microsoft SQL Server）

  • falseを設定した場合の改善点
    • 大量データに対するフェッチのパフォーマンスが改善します。
      （Microsoft SQL Server）

  • falseを設定した場合の問題点
    • Microsoft SQL Server 2000ではSQLエラーとなるため、Microsoft SQL Server 2000では利用できません。
      （Microsoft SQL Server）

【各オプションのデフォルトについて】
    オプションを省略した場合のデフォルト値は以下の通りです。

    オプション デフォルト値
    <sql-server2000>
    true
    <fast-fetch>
    false
    <prepared-modify>
    false

【各オプションの関連について】
    オプションの状態 実際のモード
    <sql-server2000> <fast-fetch> <prepared-modify> 高速フェッチ
    モード     		PreparedStatement
    更新モード
    true
    true
    true
    true(*2)
    true(*1)
    true
    true
    false
    true(*2)
    false
    true
    false
    true
    false
    true(*1)
    true
    false
    false
    false
    false
    false
    true
    true
    true
    true(*1)
    false
    true
    false
    true
    false
    false
    false
    true
    false
    true(*1)
    false
    false
    false
    false
    false
    (*1) : 対象がPostgreSQLのみfalse
    (*2) : 対象がSQL Serverのみfalse

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static DatabaseResult | beginTransaction () データベーストランザクションを開始します。
static DatabaseResult | commit () データベーストランザクションをコミットします。
static String | dateToString (Date date) 日付型変数から日付文字列を取得します。
static String | dateToString (Number year ,Number month ,Number day ,Number hour ,Number minute ,Number second) 日付情報から日付文字列を取得します。
static DatabaseResult | execStoredFunc (String functionName ,Number type ,Array arg ,String connectId ,Boolean isGroup) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc (String functionName ,Number type ,Array arg ,String connectId) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc (String functionName ,Number type ,Array arg) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc (String functionName ,Number type ,String connectId ,Boolean isGroup) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc (String functionName ,Number type ,String connectId) ストアドファンクションを実行します。
static DatabaseResult | execStoredFunc (String functionName ,Number type) ストアドファンクションを実行します。
static DatabaseResult | execStoredProc (String functionName ,Array arg ,String connectId ,Boolean isGroup) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc (String functionName ,Array arg ,String connectId) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc (String functionName ,Array arg) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc (String functionName ,String connectId ,Boolean isGroup) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc (String functionName ,String connectId) ストアドプロシジャを実行します。
static DatabaseResult | execStoredProc (String functionName) ストアドプロシジャを実行します。
static DatabaseResult | execute (String sql ,Array params ,String connectId ,Boolean isGroup) 任意のSQL文を実行します。
static DatabaseResult | execute (String sql ,Array params ,String connectId) 任意のSQL文を実行します。
static DatabaseResult | execute (String sql ,Array params) 任意のSQL文を実行します。
static DatabaseResult | execute (String sql ,String connectId ,Boolean isGroup) 任意のSQL文を実行します。
static DatabaseResult | execute (String sql ,String connectId) 任意のSQL文を実行します。
static DatabaseResult | execute (String sql) 任意のSQL文を実行します。
static DatabaseResult | fetch (String sql ,Number stratRow ,Number length ,Array params ,String connectId ,Boolean isGroup) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch (String sql ,Number stratRow ,Number length ,Array params ,String connectId) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch (String sql ,Number stratRow ,Number length ,Array params) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch (String sql ,Number stratRow ,Number length ,String connectId ,Boolean isGroup) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch (String sql ,Number stratRow ,Number length ,String connectId) SELECT文を発行後、取得データをフェッチして取得します。
static DatabaseResult | fetch (String sql ,Number stratRow ,Number length) SELECT文を発行後、取得データをフェッチして取得します。
static Array | getConnectIdsBySystem () システム接続名の一覧を取得します。
static Number | getCount (String tableName [,String condition] ,String connectId ,Boolean isGroup) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static Number | getCount (String tableName ,String condition ,String connectId) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static Number | getCount (String tableName ,String condition) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static Number | getCount (String tableName) 指定されたテーブルと検索条件に一致したレコード数を取得します。
static String | getDataSourceNameByLoginGroup (groupId String) ログイングループIDからデータソース参照名を取得します。
static String | getDataSourceNameBySystem (String connectId) システム接続名からデータソース参照名を取得します。
static String | getDbName (String connectId ,Boolean isGroup) データベースの名称を取得します。
static String | getDbName (String connectId) データベースの名称を取得します。
static String | getDbName () データベースの名称を取得します。
static String | getDbVersion (String connectId ,Boolean isGroup) データベースのバージョンを取得します。
static String | getDbVersion (String connectId) データベースのバージョンを取得します。
static String | getDbVersion () データベースのバージョンを取得します。
static String | getEscape (String connectId ,Boolean isGroup) ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
static String | getEscape (String connectId) ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
static String | getEscape () ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
static String | getGroupDatabaseType (String groupId) ログイングループデータソースおけるデータベースの種類を取得する。
static Object | getMax (String columnName ,String tableName ,String condition ,String connectId ,Boolean isGroup) テーブル内の指定列の最大値を取得します。
static Object | getMax (String columnName ,String tableName ,String condition ,String connectId) テーブル内の指定列の最大値を取得します。
static Object | getMax (String columnName ,String tableName ,String condition) テーブル内の指定列の最大値を取得します。
static Object | getMax (String columnName ,String tableName) テーブル内の指定列の最大値を取得します。
static Object | getMin (String columnName ,String tableName [,String condition] ,String connectId ,Boolean isGroup) テーブル内の指定列の最小値を取得します。
static Object | getMin (String columnName ,String tableName ,String condition ,String connectId) テーブル内の指定列の最小値を取得します。
static Object | getMin (String columnName ,String tableName ,String condition) テーブル内の指定列の最小値を取得します。
static Object | getMin (String columnName ,String tableName) テーブル内の指定列の最小値を取得します。
static DbStoredProcArg | getStoredArg () ストアドプロシジャーの引数オブジェクトを取得する。
static String | getSystemDatabaseType (String connectId) システムデータソースにおけるデータベースの種類を取得する。
static DatabaseResult | insert (String tableName ,Object insertData ,String connectId ,Boolean isGroup) 指定されたテーブルにデータを挿入します。
static DatabaseResult | insert (String tableName ,Object insertData ,String connectId) 指定されたテーブルにデータを挿入します。
static DatabaseResult | insert (String tableName ,Object insertData) 指定されたテーブルにデータを挿入します。
static Boolean | isColumn (String columnName ,String tableName ,String connectId ,Boolean isGroup) 指定された名前の列がテーブルに存在するかどうかを調べます。
static Boolean | isColumn (String columnName ,String tableName ,String connectId) 指定された名前の列がテーブルに存在するかどうかを調べます。
static Boolean | isColumn (String columnName ,String tableName) 指定された名前の列がテーブルに存在するかどうかを調べます。
static Boolean | isConnect (String connectId ,Boolean isGroup) データベース接続の確認を行います。
static Boolean | isConnect (String connectId) データベース接続の確認を行います。
static Boolean | isConnect () データベース接続の確認を行います。
static Boolean | isTransaction () データベースアクセスのトランザクション状態を取得します。
static DatabaseResult | remove (String tableName ,String condition ,String connectId ,Boolean isGroup) レコードを削除します。
static DatabaseResult | remove (String tableName ,String condition ,String connectId) レコードを削除します。
static DatabaseResult | remove (String tableName ,String condition) レコードを削除します。
static DatabaseResult | rollback () データベーストランザクションをロールバックします。
static DatabaseResult | select (String sql ,Array params ,Number length ,String connectId ,Boolean isGroup) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql ,Array params ,Number length ,String connectId) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql ,Array params ,Number length) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql ,Array params) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql ,Number length ,String connectId ,Boolean isGroup) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql ,Number length ,String connectId) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql ,Number length) SELECT文を発行してデータを取得します。
static DatabaseResult | select (String sql) SELECT文を発行してデータを取得します。
static Date | stringToDate (String date) 文字列から日付型変数を取得します。
static DatabaseResult | update (String tableName ,String condition ,Object updateData ,String connectId ,Boolean isGroup) データベースのデータを更新します。
static DatabaseResult | update (String tableName ,String condition ,Object updateData ,String connectId) データベースのデータを更新します。
static DatabaseResult | update (String tableName ,String condition ,Object updateData) データベースのデータを更新します。
メソッドの詳細
beginTransaction

static DatabaseResult beginTransaction ()

データベーストランザクションを開始します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
commit

static DatabaseResult commit ()

データベーストランザクションをコミットします。
返却値
DatabaseResult データベースアクセス結果オブジェクト
dateToString

static String dateToString (Date date)

日付型変数から日付文字列を取得します。

日付を表わす日付型変数から日付をあらわす文字列を生成します。
引数が不正の場合、nullを返却します。

例:DatabaseManager.dateToString(new Date());
パラメータ
date Date 日付
返却値
String 日付を表わす文字列(yyyy/MM/dd|hh:mm:ss)
dateToString

static String dateToString (Number year ,Number month ,Number day ,Number hour ,Number minute ,Number second)

日付情報から日付文字列を取得します。

日付情報から日付をあらわす文字列を生成します。
引数が不正の場合、nullを返却します。

例：DatabaseManager.dateToString(2000,1,1,10,10,10);
パラメータ
year | Number | 年
month | Number | 月
day | Number | 日
hour | Number | 時
minute | Number | 分
second | Number | 秒
返却値
String 日付を表わす文字列(yyyy/MM/dd|hh:mm:ss)
execStoredFunc

static DatabaseResult execStoredFunc (String functionName ,Number type ,Array arg ,String connectId ,Boolean isGroup)

ストアドファンクションを実行します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc (String functionName ,Number type ,Array arg ,String connectId)

ストアドファンクションを実行します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc (String functionName ,Number type ,Array arg)

ストアドファンクションを実行します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
arg | Array | 引数オブジェクト(DbStoredProcArg)の配列
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc (String functionName ,Number type ,String connectId ,Boolean isGroup)

ストアドファンクションを実行します。

引数オブジェクトの配列を使用しません。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc (String functionName ,Number type ,String connectId)

ストアドファンクションを実行します。

引数オブジェクトの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredFunc

static DatabaseResult execStoredFunc (String functionName ,Number type)

ストアドファンクションを実行します。

引数オブジェクトの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName | String | storedFunction名
type | Number | 返却値の型 (1:文字列型 2:数値型 3:日付型)
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc (String functionName ,Array arg ,String connectId ,Boolean isGroup)

ストアドプロシジャを実行します。
パラメータ
functionName | String | storedFunction名
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc (String functionName ,Array arg ,String connectId)

ストアドプロシジャを実行します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc (String functionName ,Array arg)

ストアドプロシジャを実行します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName | String | storedFunction名
arg | Array | 引数オブジェクト(DbStoredProcArgの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc (String functionName ,String connectId ,Boolean isGroup)

ストアドプロシジャを実行します。

引数オブジェクトの配列を使用しません。
パラメータ
functionName | String | storedFunction名
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc (String functionName ,String connectId)

ストアドプロシジャを実行します。

引数オブジェクトの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
functionName | String | storedFunction名
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execStoredProc

static DatabaseResult execStoredProc (String functionName)

ストアドプロシジャを実行します。

引数オブジェクトの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
functionName String storedFunction名
返却値
DatabaseResult データベースアクセス結果オブジェクト。
execute

static DatabaseResult execute (String sql ,Array params ,String connectId ,Boolean isGroup)

任意のSQL文を実行します。
パラメータ
sql | String | SQL文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute (String sql ,Array params ,String connectId)

任意のSQL文を実行します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql | String | SQL文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute (String sql ,Array params)

任意のSQL文を実行します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SQL文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute (String sql ,String connectId ,Boolean isGroup)

任意のSQL文を実行します。

パラメータの配列を使用しません。
パラメータ
sql String SQL文
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute (String sql ,String connectId)

任意のSQL文を実行します。

パラメータの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql String SQL文
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
execute

static DatabaseResult execute (String sql)

任意のSQL文を実行します。

パラメータの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql String SQL文
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch (String sql ,Number stratRow ,Number length ,Array params ,String connectId ,Boolean isGroup)

SELECT文を発行後、取得データをフェッチして取得します。

（注意）Microsoft SQL Serverに対してこのメソッドを利用する場合、以下の制約があります。
SQL Server2005以降 フェッチのパフォーマンスを向上させるために、このメソッド内でSQL文を加工して、SQLを発行します。
そのため、select文に対してTOP句が利用できません。
ただし、サブクエリに対してはSQL Serverの制約に準じます。

select文にてTOP句を利用したい場合または、SQL構文エラーなどが発生する場合は
SQL Server 2000モードで動作させてください。
SQL Server2000 SQL Server 2000モードで動作させてください。
SQL Server 2000モードへの変更方法は、各ApplicationRuntime/conf/imart.xmlに以下のタグを追加します。
      <intra-mart>
        ・・・・
        <platform>
          ・・・・
          <service>
            ・・・・
            <application>
              ・・・・
              <database>
                 <sql-server2000>true</sql-server2000>
                 ・・・・・・
SQL Server 2000モードで動作させた場合は、select文に制約はありません。

パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
length | Number | 取得するデータの最大レコード数(1以上)
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult 参照系データベースアクセス結果オブジェクト。
fetch

static DatabaseResult fetch (String sql ,Number stratRow ,Number length ,Array params ,String connectId)

SELECT文を発行後、取得データをフェッチして取得します。

引数の接続名を利用してシステムデータベースに接続します。

（注意）Microsoft SQL Serverに対してこのメソッドを利用する場合、以下の制約があります。
SQL Server2005以降 フェッチのパフォーマンスを向上させるために、このメソッド内でSQL文を加工して、SQLを発行します。
そのため、select文に対してTOP句が利用できません。
ただし、サブクエリに対してはSQL Serverの制約に準じます。

select文にてTOP句を利用したい場合または、SQL構文エラーなどが発生する場合は
SQL Server 2000モードで動作させてください。
SQL Server2000 SQL Server 2000モードで動作させてください。
SQL Server 2000モードへの変更方法は、各ApplicationRuntime/conf/imart.xmlに以下のタグを追加します。
      <intra-mart>
        ・・・・
        <platform>
          ・・・・
          <service>
            ・・・・
            <application>
              ・・・・
              <database>
                 <sql-server2000>true</sql-server2000>
                 ・・・・・・
SQL Server 2000モードで動作させた場合は、select文に制約はありません。

パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
length | Number | 取得するデータの最大レコード数(1以上)
params Array SQL文に渡すパラメータの配列(DbParameterの配列)
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch (String sql ,Number stratRow ,Number length ,Array params)

SELECT文を発行後、取得データをフェッチして取得します。

現在ログインしているログイングループのデータベースに接続します。

（注意）Microsoft SQL Serverに対してこのメソッドを利用する場合、以下の制約があります。
SQL Server2005以降 フェッチのパフォーマンスを向上させるために、このメソッド内でSQL文を加工して、SQLを発行します。
そのため、select文に対してTOP句が利用できません。
ただし、サブクエリに対してはSQL Serverの制約に準じます。

select文にてTOP句を利用したい場合または、SQL構文エラーなどが発生する場合は
SQL Server 2000モードで動作させてください。
SQL Server2000 SQL Server 2000モードで動作させてください。
SQL Server 2000モードへの変更方法は、各ApplicationRuntime/conf/imart.xmlに以下のタグを追加します。
      <intra-mart>
        ・・・・
        <platform>
          ・・・・
          <service>
            ・・・・
            <application>
              ・・・・
              <database>
                 <sql-server2000>true</sql-server2000>
                 ・・・・・・
SQL Server 2000モードで動作させた場合は、select文に制約はありません。

パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
length | Number | 取得するデータの最大レコード数(1以上)
params Array SQL文に渡すパラメータの配列(DbParameterの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch (String sql ,Number stratRow ,Number length ,String connectId ,Boolean isGroup)

SELECT文を発行後、取得データをフェッチして取得します。

パラメータの配列を使用しません。

（注意）Microsoft SQL Serverに対してこのメソッドを利用する場合、以下の制約があります。
SQL Server2005以降 フェッチのパフォーマンスを向上させるために、このメソッド内でSQL文を加工して、SQLを発行します。
そのため、select文に対してTOP句が利用できません。
ただし、サブクエリに対してはSQL Serverの制約に準じます。

select文にてTOP句を利用したい場合または、SQL構文エラーなどが発生する場合は
SQL Server 2000モードで動作させてください。
SQL Server2000 SQL Server 2000モードで動作させてください。
SQL Server 2000モードへの変更方法は、各ApplicationRuntime/conf/imart.xmlに以下のタグを追加します。
      <intra-mart>
        ・・・・
        <platform>
          ・・・・
          <service>
            ・・・・
            <application>
              ・・・・
              <database>
                 <sql-server2000>true</sql-server2000>
                 ・・・・・・
SQL Server 2000モードで動作させた場合は、select文に制約はありません。

パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
length | Number | 取得するデータの最大レコード数(1以上)
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch (String sql ,Number stratRow ,Number length ,String connectId)

SELECT文を発行後、取得データをフェッチして取得します。

パラメータの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。

（注意）Microsoft SQL Serverに対してこのメソッドを利用する場合、以下の制約があります。
SQL Server2005以降 フェッチのパフォーマンスを向上させるために、このメソッド内でSQL文を加工して、SQLを発行します。
そのため、select文に対してTOP句が利用できません。
ただし、サブクエリに対してはSQL Serverの制約に準じます。

select文にてTOP句を利用したい場合または、SQL構文エラーなどが発生する場合は
SQL Server 2000モードで動作させてください。
SQL Server2000 SQL Server 2000モードで動作させてください。
SQL Server 2000モードへの変更方法は、各ApplicationRuntime/conf/imart.xmlに以下のタグを追加します。
      <intra-mart>
        ・・・・
        <platform>
          ・・・・
          <service>
            ・・・・
            <application>
              ・・・・
              <database>
                 <sql-server2000>true</sql-server2000>
                 ・・・・・・
SQL Server 2000モードで動作させた場合は、select文に制約はありません。

パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
length | Number | 取得するデータの最大レコード数(1以上)
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
fetch

static DatabaseResult fetch (String sql ,Number stratRow ,Number length)

SELECT文を発行後、取得データをフェッチして取得します。

パラメータの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。

（注意）Microsoft SQL Serverに対してこのメソッドを利用する場合、以下の制約があります。
SQL Server2005以降 フェッチのパフォーマンスを向上させるために、このメソッド内でSQL文を加工して、SQLを発行します。
そのため、select文に対してTOP句が利用できません。
ただし、サブクエリに対してはSQL Serverの制約に準じます。

select文にてTOP句を利用したい場合または、SQL構文エラーなどが発生する場合は
SQL Server 2000モードで動作させてください。
SQL Server2000 SQL Server 2000モードで動作させてください。
SQL Server 2000モードへの変更方法は、各ApplicationRuntime/conf/imart.xmlに以下のタグを追加します。
      <intra-mart>
        ・・・・
        <platform>
          ・・・・
          <service>
            ・・・・
            <application>
              ・・・・
              <database>
                 <sql-server2000>true</sql-server2000>
                 ・・・・・・
SQL Server 2000モードで動作させた場合は、select文に制約はありません。

パラメータ
sql | String | SQL(SELECT文)
stratRow | Number | 取得するデータの開始レコード位置(1以上)
length | Number | 取得するデータの最大レコード数(1以上)
返却値
DatabaseResult データベースアクセス結果オブジェクト
getConnectIdsBySystem

static Array getConnectIdsBySystem ()

システム接続名の一覧を取得します。

返却値
Array 接続名の配列
getCount

static Number getCount (String tableName [,String condition] ,String connectId ,Boolean isGroup)

指定されたテーブルと検索条件に一致したレコード数を取得します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Number レコード件数
getCount

static Number getCount (String tableName ,String condition ,String connectId)

指定されたテーブルと検索条件に一致したレコード数を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
返却値
Number レコード件数
getCount

static Number getCount (String tableName ,String condition)

指定されたテーブルと検索条件に一致したレコード数を取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
Number レコード件数
getCount

static Number getCount (String tableName)

指定されたテーブルと検索条件に一致したレコード数を取得します。

現在ログインしているログイングループのデータベースに接続します。
条件句を指定しません。
パラメータ
tableName String テーブル名
返却値
Number レコード件数
getDataSourceNameByLoginGroup

static String getDataSourceNameByLoginGroup (groupId String)

ログイングループIDからデータソース参照名を取得します。

ログイングループIDに紐付くデータソース参照名が存在しない場合はnullを返却します。
パラメータ
String groupId ログイングループID
返却値
String データソース参照名
getDataSourceNameBySystem

static String getDataSourceNameBySystem (String connectId)

システム接続名からデータソース参照名を取得します。

システム接続名に紐付くデータソース参照名が存在しない場合はnullを返却します。
パラメータ
connectId String システム接続名
返却値
String データソース参照名
getDbName

static String getDbName (String connectId ,Boolean isGroup)

データベースの名称を取得します。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
String データベースの名称
getDbName

static String getDbName (String connectId)

データベースの名称を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
String データベースの名称
getDbName

static String getDbName ()

データベースの名称を取得します。

現在ログインしているログイングループのデータベースに接続します。
返却値
String データベースの名称
getDbVersion

static String getDbVersion (String connectId ,Boolean isGroup)

データベースのバージョンを取得します。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
String データベースのバージョン
getDbVersion

static String getDbVersion (String connectId)

データベースのバージョンを取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
String データベースのバージョン
getDbVersion

static String getDbVersion ()

データベースのバージョンを取得します。

現在ログインしているログイングループのデータベースに接続します。
返却値
String データベースのバージョン
getEscape

static String getEscape (String connectId ,Boolean isGroup)

ワイルドカード文字をエスケープするのに使用できる文字列を取得します。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
String ワイルドカード文字をエスケープするのに使用できる文字列
getEscape

static String getEscape (String connectId)

ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
String ワイルドカード文字をエスケープするのに使用できる文字列
getEscape

static String getEscape ()

ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

現在ログインしているログイングループのデータベースに接続します。
返却値
String ワイルドカード文字をエスケープするのに使用できる文字列
getGroupDatabaseType

static String getGroupDatabaseType (String groupId)

ログイングループデータソースおけるデータベースの種類を取得する。
指定されたログイングループIDに一致する、データベースの種類を取得する。
ログイングループが存在しない、またはログイングループにデータソースがマッピングされていない場合はnullが返される。
パラメータ
groupId String ログイングループID
返却値
String データベースの種類
データベースの種類 | 返却文字列
Oracle | Oracle
IBM DB2 UDB | DB2
PostgreSQL | PostgreSQL
Microsoft SQL Server | SQLServer
My SQL | MySQL
その他 | Other
導入されたバージョン：6.1.11
getMax

static Object getMax (String columnName ,String tableName ,String condition ,String connectId ,Boolean isGroup)

テーブル内の指定列の最大値を取得します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Object DBデータ型のオブジェクト
getMax

static Object getMax (String columnName ,String tableName ,String condition ,String connectId)

テーブル内の指定列の最大値を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
返却値
Object DBデータ型のオブジェクト
getMax

static Object getMax (String columnName ,String tableName ,String condition)

テーブル内の指定列の最大値を取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
Object DBデータ型のオブジェクト
getMax

static Object getMax (String columnName ,String tableName)

テーブル内の指定列の最大値を取得します。

現在ログインしているログイングループのデータベースに接続します。
条件句を指定しません。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin (String columnName ,String tableName [,String condition] ,String connectId ,Boolean isGroup)

テーブル内の指定列の最小値を取得します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin (String columnName ,String tableName ,String condition ,String connectId)

テーブル内の指定列の最小値を取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
検索条件が必要ない場合でかつ接続名を指定する場合はnullを指定してください。
connectId | String | 接続名
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin (String columnName ,String tableName ,String condition)

テーブル内の指定列の最小値を取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
Object DBデータ型のオブジェクト
getMin

static Object getMin (String columnName ,String tableName)

テーブル内の指定列の最小値を取得します。

現在ログインしているログイングループのデータベースに接続します。
条件句を指定しません。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
返却値
Object DBデータ型のオブジェクト
getStoredArg

static DbStoredProcArg getStoredArg ()

ストアドプロシジャーの引数オブジェクトを取得する。
返却値
DbStoredProcArg ストアドプロシジャーの引数オブジェクト
getSystemDatabaseType

static String getSystemDatabaseType (String connectId)

システムデータソースにおけるデータベースの種類を取得する。
指定された接続参照名に一致する、データベースの種類を取得する。
システムデータベースが存在しない、またはシステムデータベースにデータソースがマッピングされていない場合はnullが返される。
パラメータ
connectId String 接続参照名
返却値
String データベースの種類
データベースの種類 | 返却文字列
Oracle | Oracle
IBM DB2 UDB | DB2
PostgreSQL | PostgreSQL
Microsoft SQL Server | SQLServer
My SQL | MySQL
その他 | Other
導入されたバージョン：6.1.11
insert

static DatabaseResult insert (String tableName ,Object insertData ,String connectId ,Boolean isGroup)

指定されたテーブルにデータを挿入します。
パラメータ
tableName | String | テーブル名
insertData Object 挿入データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
設定された値は、内容を文字列に変換してから挿入されます。
特にDate型の値をDATE型系のカラムに挿入する場合は、DBに対応した文字列形式に変換してから、設定されることをお勧めします。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
insert

static DatabaseResult insert (String tableName ,Object insertData ,String connectId)

指定されたテーブルにデータを挿入します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | テーブル名
insertData Object 挿入データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
設定された値は、内容を文字列に変換してから挿入されます。
特にDate型の値をDATE型系のカラムに挿入する場合は、DBに対応した文字列形式に変換してから、設定されることをお勧めします。
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
insert

static DatabaseResult insert (String tableName ,Object insertData)

指定されたテーブルにデータを挿入します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String テーブル名
insertData Object 挿入データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。 設定された値は、内容を文字列に変換してから挿入されます。
特にDate型の値をDATE型系のカラムに挿入する場合は、DBに対応した文字列形式に変換してから、設定されることをお勧めします。
返却値
DatabaseResult データベースアクセス結果オブジェクト
isColumn

static Boolean isColumn (String columnName ,String tableName ,String connectId ,Boolean isGroup)

指定された名前の列がテーブルに存在するかどうかを調べます。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Boolean true : 存在する / false : 存在しない
isColumn

static Boolean isColumn (String columnName ,String tableName ,String connectId)

指定された名前の列がテーブルに存在するかどうかを調べます。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
connectId | String | 接続名
返却値
Boolean true : 存在する / false : 存在しない
isColumn

static Boolean isColumn (String columnName ,String tableName)

指定された名前の列がテーブルに存在するかどうかを調べます。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
columnName | String | 列名
tableName | String | テーブル名
返却値
Boolean true : 存在する / false : 存在しない
isConnect

static Boolean isConnect (String connectId ,Boolean isGroup)

データベース接続の確認を行います。
パラメータ
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
Boolean true : 成功 / false : 失敗
isConnect

static Boolean isConnect (String connectId)

データベース接続の確認を行います。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
connectId String 接続名
返却値
Boolean true : 成功 / false : 失敗
isConnect

static Boolean isConnect ()

データベース接続の確認を行います。

現在ログインしているログイングループのデータベースに接続します。
返却値
Boolean true : 成功 / false : 失敗
isTransaction

static Boolean isTransaction ()

データベースアクセスのトランザクション状態を取得します。

返却値
Boolean true : トランザクション中 / false : トランザクション外 / null : エラー
remove

static DatabaseResult remove (String tableName ,String condition ,String connectId ,Boolean isGroup)

レコードを削除します。
パラメータ
tableName | String | 対象テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
remove

static DatabaseResult remove (String tableName ,String condition ,String connectId)

レコードを削除します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | 対象テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
remove

static DatabaseResult remove (String tableName ,String condition)

レコードを削除します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String 対象テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
返却値
DatabaseResult データベースアクセス結果オブジェクト
rollback

static DatabaseResult rollback ()

データベーストランザクションをロールバックします。

返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql ,Array params ,Number length ,String connectId ,Boolean isGroup)

SELECT文を発行してデータを取得します。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
length Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult 参照系データベースアクセス結果オブジェクト。
select

static DatabaseResult select (String sql ,Array params ,Number length ,String connectId)

SELECT文を発行してデータを取得します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
length Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql ,Array params ,Number length)

SELECT文を発行してデータを取得します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
length | Number | 最大取得行数
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql ,Array params)

SELECT文を発行してデータを取得します。

現在ログインしているログイングループのデータベースに接続します。
最大取得行数を指定しません。
パラメータ
sql | String | SELECT文
params | Array | SQL文に渡すパラメータの配列(DbParameterの配列)
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql ,Number length ,String connectId ,Boolean isGroup)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
パラメータ
sql String SQL文
length Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId String 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql ,Number length ,String connectId)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
引数の接続名を利用してシステムデータベースに接続します。
パラメータ
sql String SQL文
length Number 最大取得行数
最大取得行数を指定しない場合で、かつ接続名指定する場合は0を指定してください。
connectId String 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql ,Number length)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql | String | SQL文
length | Number | 最大取得行数
返却値
DatabaseResult データベースアクセス結果オブジェクト
select

static DatabaseResult select (String sql)

SELECT文を発行してデータを取得します。

パラメータの配列を使用しません。
最大取得行数を指定しません。
現在ログインしているログイングループのデータベースに接続します。
パラメータ
sql String SQL文
返却値
DatabaseResult データベースアクセス結果オブジェクト
stringToDate

static Date stringToDate (String date)

文字列から日付型変数を取得します。

引数が不正の場合、nullを返却します。
パラメータ
date String 日付を表わす文字列(yyyy/MM/dd|hh:mm:ss)
返却値
Date 変換後の日付
update

static DatabaseResult update (String tableName ,String condition ,Object updateData ,String connectId ,Boolean isGroup)

データベースのデータを更新します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
updateData Object 更新データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
設定された値は、内容を文字列に変換してから更新されます。
特にDate型の値でDATE型系のカラムを更新する場合は、DBに対応した文字列形式に変換してから、設定されることをお勧めします。
connectId | String | 接続名
isGroup Boolean
true | 引数の接続名をログイングループIDとしてログイングループのデータベースに接続します。
false | 引数の接続名を利用してシステムデータベースに接続します。
返却値
DatabaseResult データベースアクセス結果オブジェクト
update

static DatabaseResult update (String tableName ,String condition ,Object updateData ,String connectId)

データベースのデータを更新します。

引数の接続名を利用してシステムデータベースに接続します。
パラメータ
tableName | String | テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
updateData Object 更新データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
設定された値は、内容を文字列に変換してから更新されます。
特にDate型の値でDATE型系のカラムを更新する場合は、DBに対応した文字列形式に変換してから、設定されることをお勧めします。
connectId | String | 接続名
返却値
DatabaseResult データベースアクセス結果オブジェクト
update

static DatabaseResult update (String tableName ,String condition ,Object updateData)

データベースのデータを更新します。

現在ログインしているログイングループのデータベースに接続します。
パラメータ
tableName String テーブル名
condition String 検索条件(WHERE句)
where句 以降を設定してください。
updateData Object 更新データ
カラム名をプロパティとして、設定する値をプロパティの値として指定してください。
設定された値は、内容を文字列に変換してから更新されます。
特にDate型の値でDATE型系のカラムを更新する場合は、DBに対応した文字列形式に変換してから、設定されることをお勧めします。
返却値
DatabaseResult データベースアクセス結果オブジェクト


 DatabaseResult オブジェクト

データベースアクセス処理結果オブジェクト。

データベースアクセス処理結果を格納するオブジェクトです。

データベースアクセス処理結果オブジェクトは値を参照することのみ許可されています

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Number | countRow 取得行数 または 実行行数。 | 読込み専用
Array | data 取得情報。 | 読込み専用
Boolean | error エラー判定。 | 読込み専用
Number | errorCode エラーコード。 | 読込み専用
String | errorMessage エラーメッセージ。 | 読込み専用
Number | maxRow 最大取得行数。 | 読込み専用
Array | params パラメータ。 | 読込み専用
Boolean | select 実行SQLのタイプ。 | 読込み専用
String | sql SQL文。 | 読込み専用
String | sqlState SQL STATE。 | 読込み専用
メソッドの概要
String | getMessage () メッセージを取得します。
Boolean | isSuccess () データベースアクセスが成功したかどうかを取得します。
プロパティの詳細
countRow

Number countRow (読込み専用プロパティ)

取得行数 または 実行行数。
data

Array data (読込み専用プロパティ)

取得情報。
配列の要素は、１レコードデータのオブジェクトです。
要素.カラム名で値を取得できます。
カラム名はすべて小文字で表現されます。
error

Boolean error (読込み専用プロパティ)

エラー判定。
errorCode

Number errorCode (読込み専用プロパティ)

エラーコード。
errorMessage

String errorMessage (読込み専用プロパティ)

エラーメッセージ。
maxRow

Number maxRow (読込み専用プロパティ)

最大取得行数。

取得データの開始レコード位置から指定した件数分レコードを取得する際の、最大レコード位置を意味します。
params

Array params (読込み専用プロパティ)

パラメータ。
ストアドプロシージャ（ファンクション）に設定したパラメータの値が取得できます。
select

Boolean select (読込み専用プロパティ)

実行SQLのタイプ。

参照系SQLの場合はtrue。
sql

String sql (読込み専用プロパティ)

SQL文。
sqlState

String sqlState (読込み専用プロパティ)

SQL STATE。
メソッドの詳細
getMessage

String getMessage ()

メッセージを取得します。

返却値
String メッセージ
isSuccess

Boolean isSuccess ()

データベースアクセスが成功したかどうかを取得します。

返却値
Boolean true : 成功 / false ： 失敗


 DataForAccount オブジェクト

推奨されていません。代替えのオブジェクトはありません。
ログインユーザ情報オブジェクト。

ログインユーザ情報を保持するオブジェクトです。
バージョン：1.0
導入されたバージョン：2.1
メソッドの概要
Object | getAttr () 推奨されていません。AccountManagerおよびProfileManagerの各メソッドに置き換えられました。
String | getGroupId () 推奨されていません。代替えのメソッドはありません。
String | getId () 推奨されていません。代替えのメソッドはありません。
String | getMblPswd () 推奨されていません。AccountManager.getAccount()に置き換えられました。
String | getPswd () 推奨されていません。AccountManager.getAccount()に置き換えられました。
Array | getRoles () 推奨されていません。AccountManager.getAccountRoleIds()に置き換えられました。
Boolean | isLicense () 推奨されていません。LicenseManager.isRegisteredAccountLicense()に置き換えられました。
メソッドの詳細
getAttr

Object getAttr ()

推奨されていません。AccountManagerおよびProfileManagerの各メソッドに置き換えられました。
属性情報を取得します。

データがない場合はnull を返却します。
返却値
Object 属性情報オブジェクト
属性情報オブジェクト
(Object)
name
ユーザ名(String)
madrs
メールアドレス(String)
mbladrs
モバイル用メールアドレス(String)
explan
説明(String)
vldDate
有効期限(Number(ミリ秒))
apps
アプリケーションロール(Array) （V4.0.0以上）
favorite
マイメニュー（Object）（V4.1.0以上） 		メニューID
(プロパティ) 		sort_no
ソート番号(Number)
alias
表示名
getGroupId

String getGroupId ()

推奨されていません。代替えのメソッドはありません。
ログイングループIDを取得します。

返却値
String ログイングループID
getId

String getId ()

推奨されていません。代替えのメソッドはありません。
ユーザIDを取得します。

返却値
String ユーザID
getMblPswd

String getMblPswd ()

推奨されていません。AccountManager.getAccount()に置き換えられました。
モバイル用パスワードを取得します。

返却値
String モバイル用パスワード
getPswd

String getPswd ()

推奨されていません。AccountManager.getAccount()に置き換えられました。
パスワードを取得します。

返却値
String パスワード
getRoles

Array getRoles ()

推奨されていません。AccountManager.getAccountRoleIds()に置き換えられました。
ロールの一覧を取得します。

返却値
Array ロールIDの配列
isLicense

Boolean isLicense ()

推奨されていません。LicenseManager.isRegisteredAccountLicense()に置き換えられました。
ライセンスのチェックを行います。

返却値
Boolean true : あり / false : なし


 DataForDatabase オブジェクト

推奨されていません。DatabaseResultに置き換えられました。
参照系データベースアクセス結果オブジェクト。

参照系SQL処理結果を格納するオブジェクトです。

参照系データベースアクセス結果オブジェクト の構成は以下の通りです。
参照系データベースアクセス
結果オブジェクト (Object)
error
エラー判定 (Boolean)
majorErrorCode
メジャーエラーコード (Number)
majorErrorMessage
メジャーエラーメッセージ (String)
minorErrorCode
マイナーエラーコード (Number)
minorErrorMessage
マイナーエラーメッセージ (String)
errorMessage
エラーメッセージ (String)
maxRow
最大取得行数 (Number)
countRow
取得行数 (Number)
sql
実行SQL (String)
data
取得情報 (Array)
カラム名 (プロパティ)
カラム名はすべて小文字で表現されます。
各プロパティの値に取得されたデータが格納されます。
バージョン：1.0
導入されたバージョン：4.3
プロパティの概要
Number | countRow 取得行数 。 | 通常
Array | data 取得情報。 | 通常
Boolean | error エラー判定。 | 通常
String | errorMessage エラーメッセージ。 | 通常
Number | majorErrorCode メジャーエラーコード 。 | 通常
String | majorErrorMessage メジャーエラーメッセージ 。 | 通常
Number | maxRow 最大取得行数 。 | 通常
Number | minorErrorCode マイナーエラーコード 。 | 通常
String | minorErrorMessage マイナーエラーメッセージ 。 | 通常
String | sql 実行SQL 。 | 通常
コンストラクタの概要
DataForDatabase (処理結果オブジェクト result)
コンストラクタ。
プロパティの詳細
countRow

Number countRow

取得行数 。
data

Array data

取得情報。
配列の要素は、１レコードデータのオブジェクトです。
要素.カラム名で値を取得できます。
error

Boolean error

エラー判定。
errorMessage

String errorMessage

エラーメッセージ。
majorErrorCode

Number majorErrorCode

メジャーエラーコード 。
majorErrorMessage

String majorErrorMessage

メジャーエラーメッセージ 。
maxRow

Number maxRow

最大取得行数 。
minorErrorCode

Number minorErrorCode

マイナーエラーコード 。
minorErrorMessage

String minorErrorMessage

マイナーエラーメッセージ 。
sql

String sql

実行SQL 。
コンストラクタの詳細
DataForDatabase

DataForDatabase (処理結果オブジェクト result)
コンストラクタ。

パラメータ
result 処理結果オブジェクト


 DataForRole オブジェクト

推奨されていません。代替えのオブジェクトはありません。
ロール情報オブジェクト。

ロール情報を保持するオブジェクトです。
バージョン：1.0
導入されたバージョン：2.1
メソッドの概要
Object | getAttr () 推奨されていません。RoleManager.getRole()に置き換えられました。
String | getGroupId () 推奨されていません。代替えのメソッドはありません。
String | getId () 推奨されていません。代替えのメソッドはありません。
Array | getRoles () 推奨されていません。RoleManager.getSubRole()に置き換えられました。
メソッドの詳細
getAttr

Object getAttr ()

推奨されていません。RoleManager.getRole()に置き換えられました。
属性オブジェクトの取得をします。

返却値
Object 属性情報オブジェクト
属性情報オブジェクト
(Object)
name
ロール名(String)
explan
表示名(String)
detail
説明(String)
getGroupId

String getGroupId ()

推奨されていません。代替えのメソッドはありません。
ログイングループIDを取得します。

返却値
String ログイングループID
getId

String getId ()

推奨されていません。代替えのメソッドはありません。
ロールIDを取得します。

返却値
String ロールID
getRoles

Array getRoles ()

推奨されていません。RoleManager.getSubRole()に置き換えられました。
サブロールID配列を取得します。

返却値
Array サブロールIDの配列


 DataForStoredProc オブジェクト

推奨されていません。DatabaseResultに置き換えられました。
ストアドプロシージャ(ファンクション)実行結果オブジェクト。

ストアドプロシージャ(ファンクション)実行結果の情報を保管するオブジェクトです。

ストアドプロシージャ(ファンクション)の構成は以下の通りです。
ストアドプロシージャ(ファンクション)
実行結果オブジェクト(Object)
error
エラー判定 (Boolean)
majorErrorCode
メジャーエラーコード (Number)
majorErrorMessage
メジャーエラーメッセージ (String)
minorErrorCode
マイナーエラーコード (Number)
minorErrorMessage
マイナーエラーメッセージ (String)
errorMessage
エラーメッセージ (String)
countRow
取得行数 (Number)
funcName
実行SQL (String)
data
取得情報 (Array)
カラム名 (プロパティ)
カラム名はすべて小文字で表現されます。
各プロパティの値に取得されたデータが格納されます。
バージョン：1.0
導入されたバージョン：4.3
プロパティの概要
Number | countRow 取得行数 。 | 通常
Array | data 取得情報。 | 通常
Boolean | error エラー判定。 | 通常
String | errorMessage エラーメッセージ。 | 通常
String | funcName 実行SQL 。 | 通常
Number | majorErrorCode メジャーエラーコード 。 | 通常
String | majorErrorMessage メジャーエラーメッセージ 。 | 通常
Number | minorErrorCode マイナーエラーコード 。 | 通常
String | minorErrorMessage マイナーエラーメッセージ 。 | 通常
メソッドの概要
String | getDate (Number order) ストアドプロシージャ(ファンクション)のパラメータ値を日付型で取得します。
String | getNumber (Number order) ストアドプロシージャ(ファンクション)のパラメータ値を数値型で取得します。
String/Number/Date | getResult (String type) ストアドファンクションの返却値を指定した型で取得します。
String | getString (Number order) ストアドプロシージャ(ファンクション)のパラメータ値を文字列型で取得します。
Boolean | isSuccess () ストアドプロシージャ(ファンクション)の実行が成功したかどうかを取得します。
プロパティの詳細
countRow

Number countRow

取得行数 。
data

Array data

取得情報。
配列の要素は、１レコードデータのオブジェクトです。
要素.カラム名で値を取得できます。
error

Boolean error

エラー判定。
errorMessage

String errorMessage

エラーメッセージ。
funcName

String funcName

実行SQL 。
majorErrorCode

Number majorErrorCode

メジャーエラーコード 。
majorErrorMessage

String majorErrorMessage

メジャーエラーメッセージ 。
minorErrorCode

Number minorErrorCode

マイナーエラーコード 。
minorErrorMessage

String minorErrorMessage

マイナーエラーメッセージ 。
メソッドの詳細
getDate

String getDate (Number order)

ストアドプロシージャ(ファンクション)のパラメータ値を日付型で取得します。

パラメータ
order Number パラメータインデックス（1以上を指定します。）
返却値
String パラメータの値
インデックスが不正か、日付に変換できなかった場合は、nullを返却します。
getNumber

String getNumber (Number order)

ストアドプロシージャ(ファンクション)のパラメータ値を数値型で取得します。

パラメータ
order Number パラメータインデックス（1以上を指定します。）
返却値
String パラメータの値
インデックスが不正か、数値に変換できなかった場合は、nullを返却します。
getResult

String/Number/Date getResult (String type)

ストアドファンクションの返却値を指定した型で取得します。

パラメータ
type String 取得する型("String","Number","Date"のいずれか)
返却値
String/Number/Date ストアドプロシージャの返却値（指定した型で返却）
指定した型に変換できなかった場合またはストアドファンクションから作成されたオブジェクトでない場合は、nullを返却します。
getString

String getString (Number order)

ストアドプロシージャ(ファンクション)のパラメータ値を文字列型で取得します。

パラメータ
order Number パラメータインデックス（1以上を指定します。）
返却値
String パラメータの値
インデックスが不正か、文字列に変換できなかった場合は、nullを返却します。
isSuccess

Boolean isSuccess ()

ストアドプロシージャ(ファンクション)の実行が成功したかどうかを取得します。

返却値
Boolean true : 成功 / false : 失敗


 DbParameter オブジェクト

SQLパラメータオブジェクト。

SQLのパラメータを保管するオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static Number | TYPE_DATE 引数のタイプ（日付）。
static Number | TYPE_NUMBER 引数のタイプ（数値）。
static Number | TYPE_STRING 引数のタイプ（文字列）。
static Number | TYPE_TIMESTAMP 引数のタイプ（タイムスタンプ）。
コンストラクタの概要
DbParameter (Object data ,Number type)
コンストラクタ。
定数の詳細
TYPE_DATE

static Number TYPE_DATE

引数のタイプ（日付）。
定数値 ： 91
TYPE_NUMBER

static Number TYPE_NUMBER

引数のタイプ（数値）。
定数値 ： 3
TYPE_STRING

static Number TYPE_STRING

引数のタイプ（文字列）。
定数値 ： 12
TYPE_TIMESTAMP

static Number TYPE_TIMESTAMP

引数のタイプ（タイムスタンプ）。
定数値 ： 93
コンストラクタの詳細
DbParameter

DbParameter (Object data ,Number type)
コンストラクタ。

パラメータ値に渡せる値は文字列型(String),数値型(Number),日付型(Date)のいずれかです。
パラメータの型は、データベースのカラムの型と同じものを指定してください。
パラメータ
data Object パラメータ値
type Number パラメータの型

DB型 | パラメータの型 | パラメータ値
文字列型 | DbParameter.TYPE_STRING | 文字列 または null
数値型 | DbParameter.TYPE_NUMBER | 数値 または null
日付型 | DbParameter.TYPE_DATE | 日付 または null
タイムスタンプ型 | DbParameter.TYPE_TIMESTAMP | 日付 または null


 DbResultObject オブジェクト

推奨されていません。DatabaseResultに置き換えられました。
データベースアクセス結果オブジェクト。

更新系SQLおよびトランザクション処理結果を格納するオブジェクトです。

データベースアクセス結果オブジェクトの構成は以下の通りです。
データベースアクセス
結果オブジェクト (Object)
error
エラー判定 (Boolean)
majorErrorCode
メジャーエラーコード (Number)
majorErrorMessage
メジャーエラーメッセージ (String)
minorErrorCode
マイナーエラーコード (Number)
minorErrorMessage
マイナーエラーメッセージ (String)
errorMessage
エラーメッセージ (String)
execRow
実行行数 (Number)
sql
実行SQL (String)
バージョン：1.0
導入されたバージョン：4.3
プロパティの概要
Boolean | error エラー判定。 | 通常
String | errorMessage エラーメッセージ。 | 通常
Number | execRow 実行行数 。 | 通常
Number | majorErrorCode メジャーエラーコード 。 | 通常
String | majorErrorMessage メジャーエラーメッセージ 。 | 通常
Number | minorErrorCode マイナーエラーコード 。 | 通常
String | minorErrorMessage マイナーエラーメッセージ 。 | 通常
String | sql 実行SQL 。 | 通常
メソッドの概要
String | getMessage () メッセージを取得します。
Boolean | isSuccess () データベースアクセスが成功したかどうかを取得します。
プロパティの詳細
error

Boolean error

エラー判定。
errorMessage

String errorMessage

エラーメッセージ。
execRow

Number execRow

実行行数 。
majorErrorCode

Number majorErrorCode

メジャーエラーコード 。
majorErrorMessage

String majorErrorMessage

メジャーエラーメッセージ 。
minorErrorCode

Number minorErrorCode

マイナーエラーコード 。
minorErrorMessage

String minorErrorMessage

マイナーエラーメッセージ 。
sql

String sql

実行SQL 。
メソッドの詳細
getMessage

String getMessage ()

メッセージを取得します。

返却値
String メッセージ
isSuccess

Boolean isSuccess ()

データベースアクセスが成功したかどうかを取得します。

返却値
Boolean true : 成功 / false ： 失敗


 DbStoredProcArg オブジェクト

ストアドプロシージャ、ファンクション引数オブジェクト。

ストアドプロシージャ、ファンクション引数を保管するオブジェクトです。
バージョン：1.0
導入されたバージョン：4.0
定数の概要
static Number | TYPE_IN 引数のタイプ（入力）。
static Number | TYPE_IN_OUT 引数のタイプ（入出力）。
static Number | TYPE_OUT 引数のタイプ（出力）。
メソッドの概要
Boolean | isDate () 引数が日付タイプかどうか判定します。
Boolean | isIn () 引数が入力タイプかどうか判定します。
Boolean | isInOut () 引数が入出力タイプかどうか判定します。
Boolean | isNumber () 引数が数値タイプかどうか判定します。
Boolean | isOut () 引数が出力タイプかどうか判定します。
Boolean | isString () 引数が文字列タイプかどうか判定します。
Boolean | setDate (Date data ,Object type) 日付型の引数を設定します。
Boolean | setNumber (Number data ,Object type) 数値型の引数を設定します。
Boolean | setString (String data ,Object type) 文字型の引数を設定します。
Boolean | setTimestamp (Date data ,Object type) タイムスタンプ型の引数を設定します。
定数の詳細
TYPE_IN

static Number TYPE_IN

引数のタイプ（入力）。
定数値 ： 1
TYPE_IN_OUT

static Number TYPE_IN_OUT

引数のタイプ（入出力）。
定数値 ： 3
TYPE_OUT

static Number TYPE_OUT

引数のタイプ（出力）。
定数値 ： 2
メソッドの詳細
isDate

Boolean isDate ()

引数が日付タイプかどうか判定します。

返却値
Boolean true : 日付タイプの引数 / false ： 日付タイプの引数ではない
isIn

Boolean isIn ()

引数が入力タイプかどうか判定します。

返却値
Boolean true : 入力タイプの引数 / false ： 入力タイプの引数ではない
isInOut

Boolean isInOut ()

引数が入出力タイプかどうか判定します。

返却値
Boolean true : 入出力タイプの引数 / false ： 入出力タイプの引数ではない
isNumber

Boolean isNumber ()

引数が数値タイプかどうか判定します。

返却値
Boolean true : 数値タイプの引数 / false ： 数値タイプの引数ではない
isOut

Boolean isOut ()

引数が出力タイプかどうか判定します。

返却値
Boolean true : 出力タイプの引数 / false ： 出力タイプの引数ではない
isString

Boolean isString ()

引数が文字列タイプかどうか判定します。

返却値
Boolean true : 文字列タイプの引数 / false ： 文字列タイプの引数ではない
setDate

Boolean setDate (Date data ,Object type)

日付型の引数を設定します。

パラメータ
data Date データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗
setNumber

Boolean setNumber (Number data ,Object type)

数値型の引数を設定します。

パラメータ
data Number データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗
setString

Boolean setString (String data ,Object type)

文字型の引数を設定します。

パラメータ
data String データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗
setTimestamp

Boolean setTimestamp (Date data ,Object type)

タイムスタンプ型の引数を設定します。

パラメータ
data Date データ
type Object データタイプ
入力引数 | DbStoredProcArg.TYPE_IN
出力引数 | DbStoredProcArg.TYPE_OUT
入出力引数 | DbStoredProcArg.TYPE_IN_OUT
返却値
Boolean true ： 成功 / false : 失敗


 DealInfo オブジェクト

取扱情報オブジェクト。
取扱に関連する情報を操作する場合に用いる 取扱情報オブジェクトの構成は以下の通りです。

なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、
「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。

取扱情報オブジェクト
取扱情報
オブジェクト
(Object)
customerDepartmentCode 取引先組織コード (String)
dealCode 取扱コード (String)
dealName 取扱名 (String)
dealType 取扱種別 (String)
currencyCode 通貨コード (String)
notes 備考 (String)
terms[0..*] 期間化情報の配列 (Array) | startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
unitPrice 単価 (Number)
dealDetail 取扱詳細情報 (Object) | itemCode 商品コード (String)
unitCode 単位コード (String)
amount 数量 (String)
unitPrice 単価 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | currencyCode 通貨コード。 | 通常
String | customerDepartmentCode 取引先組織コード。 | 通常
String | dealCode 取扱コード。 | 通常
String | dealName 取扱名。 | 通常
String | dealType 取扱種別。 | 通常
String | notes 備考。 | 通常
Array | terms 期間化情報の配列。 | 通常
Object | terms[0..*].dealDetail 取扱詳細情報。 | 通常
String | terms[0..*].dealDetail.amount 数量。 | 通常
String | terms[0..*].dealDetail.itemCode 商品コード。 | 通常
String | terms[0..*].dealDetail.unitCode 単位コード。 | 通常
String | terms[0..*].dealDetail.unitPrice 単価。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
Number | terms[0..*].unitPrice 単価。 | 通常
プロパティの詳細
currencyCode

String currencyCode

通貨コード。
customerDepartmentCode

String customerDepartmentCode

取引先組織コード。
dealCode

String dealCode

取扱コード。
dealName

String dealName

取扱名。
dealType

String dealType

取扱種別。
notes

String notes

備考。
terms

Array terms

期間化情報の配列。
terms[0..*].dealDetail

Object terms[0..*].dealDetail

取扱詳細情報。
terms[0..*].dealDetail.amount

String terms[0..*].dealDetail.amount

数量。
terms[0..*].dealDetail.itemCode

String terms[0..*].dealDetail.itemCode

商品コード。
terms[0..*].dealDetail.unitCode

String terms[0..*].dealDetail.unitCode

単位コード。
terms[0..*].dealDetail.unitPrice

String terms[0..*].dealDetail.unitPrice

単価。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
terms[0..*].unitPrice

Number terms[0..*].unitPrice

単価。


 DealManager オブジェクト

DealManagerオブジェクト
取扱に関連する情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
DealManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addDeal (DealInfo deal) 取扱情報を新規登録します。
ResultInfo | deleteDeal (DealInfo deal) 取扱情報を削除します。
ResultInfo | getDeal (String customerCompanyCode ,String customerDepartmentCode ,String dealCode) 指定された取扱情報を返します。
ResultInfo | getDeals (Date date) 存在する取扱情報を返します。
ResultInfo | getDealsByKey (String itemCode ,String departmentCode ,Date date) 存在する取扱情報の中で、商品と取引先から特定されるものを返します。
ResultInfo | getUsersDeals (String userCode ,Date date) ユーザがアクセスできる取扱情報を返します。
ResultInfo | getUsersDealsByKey (String userCode ,String itemCode ,String departmentCode ,Date date) 存在する取扱情報の中で、商品と取引先から特定されるものを返します。
ResultInfo | updateDeal (DealInfo deal) 取扱情報を更新します。
コンストラクタの詳細
DealManager

DealManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addDeal

ResultInfo addDeal (DealInfo deal)

取扱情報を新規登録します。
パラメータ
deal DealInfo 取扱情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteDeal

ResultInfo deleteDeal (DealInfo deal)

取扱情報を削除します。
指定された取扱情報が存在しない場合は 処理失敗 となります。
パラメータ
deal DealInfo 取扱情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getDeal

ResultInfo getDeal (String customerCompanyCode ,String customerDepartmentCode ,String dealCode)

指定された取扱情報を返します。
パラメータ
customerCompanyCode | String | 取引先会社コード
customerDepartmentCode | String | 取引先組織コード
dealCode | String | 取扱コード
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に取扱情報オブジェクトが設定されます。
(該当データが存在しない場合はnullが設定されます。)
getDeals

ResultInfo getDeals (Date date)

存在する取扱情報を返します。
パラメータ
date Date 取扱情報を指定する日付（省略可能）
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に取扱情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が設定されます。)
getDealsByKey

ResultInfo getDealsByKey (String itemCode ,String departmentCode ,Date date)

存在する取扱情報の中で、商品と取引先から特定されるものを返します。
パラメータ
itemCode | String | 商品コード
departmentCode | String | 組織コード
date | Date | 取扱情報を指定する日付（省略可能）
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に取扱情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が設定されます。)
getUsersDeals

ResultInfo getUsersDeals (String userCode ,Date date)

ユーザがアクセスできる取扱情報を返します。
パラメータ
userCode | String | ユーザコード
date | Date | 取扱情報を指定する日付（省略可能）
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に取扱情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が設定されます。)
getUsersDealsByKey

ResultInfo getUsersDealsByKey (String userCode ,String itemCode ,String departmentCode ,Date date)

存在する取扱情報の中で、商品と取引先から特定されるものを返します。
パラメータ
userCode | String | ユーザコード
itemCode | String | 商品コード
departmentCode | String | 組織コード
date | Date | 取扱情報を指定する日付（省略可能）
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に取扱情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が設定されます。)
updateDeal

ResultInfo updateDeal (DealInfo deal)

取扱情報を更新します。
パラメータ
deal DealInfo 取扱情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 DealPermissionManager オブジェクト

DealPermissionManagerオブジェクト
取扱情報に対するアクセス権情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
DealPermissionManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | getDepartments (DealInfo deal) 取扱情報を保有するアクセス権をもつ組織を返します。
ResultInfo | getPublicGroups (DealInfo deal) 取扱情報を保有するアクセス権をもつパブリックグループを返します。
ResultInfo | getRoles (DealInfo deal) 取扱情報を保有するアクセス権をもつロールを返します。
ResultInfo | removePermissionFromDepartment (DepartmentDealPermissionInfo dealer) 組織取扱アクセス権を削除します。
ResultInfo | removePermissionFromPublicGroup (GroupDealPermissionInfo dealer) パブリックグループ取扱アクセス権を削除します。
ResultInfo | removePermissionFromRole (RoleDealPermissionInfo dealer) ロール取扱アクセス権を削除します。
ResultInfo | setPermissionToDepartment (DepartmentDealPermissionInfo dealer) 組織に対する取扱アクセス権を設定します。
ResultInfo | setPermissionToPublicGroup (GroupDealPermissionInfo dealer) パブリックグループに対する取扱アクセス権を設定します。
ResultInfo | setPermissionToRole (RoleDealPermissionInfo dealer) ロールに対する取扱アクセス権を設定します。
コンストラクタの詳細
DealPermissionManager

DealPermissionManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
getDepartments

ResultInfo getDepartments (DealInfo deal)

取扱情報を保有するアクセス権をもつ組織を返します。
パラメータ
deal DealInfo 取扱情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に組織詳細情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getPublicGroups

ResultInfo getPublicGroups (DealInfo deal)

取扱情報を保有するアクセス権をもつパブリックグループを返します。
パラメータ
deal DealInfo 取扱情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性にパブリックグループ詳細情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getRoles

ResultInfo getRoles (DealInfo deal)

取扱情報を保有するアクセス権をもつロールを返します。
パラメータ
deal DealInfo 取扱情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性にロール情報オブジェクトの配列が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
removePermissionFromDepartment

ResultInfo removePermissionFromDepartment (DepartmentDealPermissionInfo dealer)

組織取扱アクセス権を削除します。
パラメータ
dealer DepartmentDealPermissionInfo 組織取扱アクセス権情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
removePermissionFromPublicGroup

ResultInfo removePermissionFromPublicGroup (GroupDealPermissionInfo dealer)

パブリックグループ取扱アクセス権を削除します。
パラメータ
dealer GroupDealPermissionInfo パブリックグループ取扱アクセス権情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
removePermissionFromRole

ResultInfo removePermissionFromRole (RoleDealPermissionInfo dealer)

ロール取扱アクセス権を削除します。
パラメータ
dealer RoleDealPermissionInfo ロール取扱アクセス権情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setPermissionToDepartment

ResultInfo setPermissionToDepartment (DepartmentDealPermissionInfo dealer)

組織に対する取扱アクセス権を設定します。
パラメータ
dealer DepartmentDealPermissionInfo 組織取扱アクセス権情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setPermissionToPublicGroup

ResultInfo setPermissionToPublicGroup (GroupDealPermissionInfo dealer)

パブリックグループに対する取扱アクセス権を設定します。
パラメータ
dealer GroupDealPermissionInfo パブリックグループ取扱アクセス権情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setPermissionToRole

ResultInfo setPermissionToRole (RoleDealPermissionInfo dealer)

ロールに対する取扱アクセス権を設定します。
パラメータ
dealer RoleDealPermissionInfo ロール取扱アクセス権情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 Debug オブジェクト

デバッグ情報を表示するオブジェクト。

開発中のデバッグ時に利用するＡＰＩが含まれるオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static void | browse (Object arg [,... ...]) ブラウザへの変数情報を表示します。
static void | console (Object arg [,... ...]) オブジェクトの内容をコンソール上に表示します。
static void | print (String msg) コンソールへメッセージを出力します。
static void | write (String msg) ファイルへメッセージを出力します。
メソッドの詳細
browse

static void browse (Object arg [,... ...])

ブラウザへの変数情報を表示します。

指定の変数の情報をブラウザ画面上に表示します。
いかなる JavaScript 変数型の変数も表示対象として指定可能です。
表示対象とする変数の引数への指定個数は任意個（無限）指定可能です。
このＡＰＩが実行されると、このＡＰＩ以降のプログラムは実行されません。
本メソッドは、try...catch 文では使用できません。
パラメータ
arg Object 表示対象となる変数
... ... 複数指定する場合は、カンマの後に続けて変数を指定します。
返却値
void
console

static void console (Object arg [,... ...])

オブジェクトの内容をコンソール上に表示します。

表示される内容は JSON 形式の文字列です。
そのため、本メソッドの出力内容を JavaScriptソースにコピーすることで、
JavaScriptオブジェクトに戻すことが出来ます。

サンプルコード
ファンクションコンテナ（.js）
 var obj =
 // Debug.console()の結果 ここから
 /* Object */
 {
     /* String */
     "prop1" : "文字列1",

     /* Date */  // Fri May 25 2007 16:50:16 GMT+0900 (JST)
     "prop2" : new Date(1180079416500),

     /* Number */
     "prop3" : 256
 }
 // Debug.console()の結果 ここまで

このメソッドは、
ImJson#toJSONString()
を利用しています。
そのため、JSON文字列として正しくないプロパティは表示されません。
(例えば、Array型のオブジェクトに設定されたプロパティは、表示されません)

JSON (JavaScript Object Notation)は、軽量のデータ交換フォーマットです。
JSON については、JSON の紹介 を参照してください。
パラメータ
arg Object 表示対象となる変数
... ... 複数指定する場合は、カンマの後に続けて変数を指定します。
返却値
void
バージョン：1.0
導入されたバージョン：6.1
print

static void print (String msg)

コンソールへメッセージを出力します。

パラメータ
msg String メッセージ
返却値
void
write

static void write (String msg)

ファイルへメッセージを出力します。

指定の文字列をファイル内へ出力します。
出力ファイルはインストールディレクトリ直下の debug.txt という名前のファイルです。
メソッドの呼び出しが複数回にわたる場合、ファイルへは追記モードで全てのメッセージが出力されます。
パラメータ
msg String メッセージ
返却値
void


 DepartmentAttachInfo オブジェクト

組織所属情報オブジェクト。
組織所属情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

組織所属情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
組織所属情報オブジェクト
組織所属情報
オブジェクト
(Object)
userCode ユーザコード (String)
companyCode 会社コード (String)
departmentCode 組織コード (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
postCode 役職コード (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
String | departmentCode 組織コード。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
String | terms[0..*].postCode 役職コード。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
String | userCode ユーザコード。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
departmentCode

String departmentCode

組織コード。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].postCode

String terms[0..*].postCode

役職コード。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
userCode

String userCode

ユーザコード。


 DepartmentDealPermissionInfo オブジェクト

組織取扱アクセス権情報オブジェクト。
組織取扱アクセス権情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
String | customerCompanyCode 取引先会社コード。 | 通常
String | customerDepartmentCode 取引先組織コード。 | 通常
String | dealCode 取扱コード。 | 通常
String | departmentCode 組織コード。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
customerCompanyCode

String customerCompanyCode

取引先会社コード。
customerDepartmentCode

String customerDepartmentCode

取引先組織コード。
dealCode

String dealCode

取扱コード。
departmentCode

String departmentCode

組織コード。


 DepartmentDetailInfo オブジェクト

組織詳細情報オブジェクト。
組織詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

組織詳細情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
組織詳細情報オブジェクト
組織情報
オブジェクト
(Object)
companyCode 会社コード (String)
departmentCode 組織コード (String)
notes 備考 (String)
sortKey ソートキー (Number)
extended 拡張情報 (拡張マップオブジェクト ExtendedMap)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
telephoneNumber 電話番号 (String)
faxNumber FAX番号 (String)
extensionNumber 内線番号 (String)
extensionFaxNumber 内線FAX番号 (String)
countryCode 国コード (String)
zipCode 郵便番号 (String)
emailAddress1 メールアドレス１ (String)
emailAddress2 メールアドレス２ (String)
url URL (String)
extended 拡張情報 (拡張マップオブジェクト ExtendedMap)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 組織名 (String)
nameSyllabary 組織名カナ (String)
nameEnglish 組織名英字 (String)
address1 住所１ (String)
address2 住所２ (String)
extended 拡張情報 (拡張マップオブジェクト ExtendedMap)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
String | departmentCode 組織コード。 | 通常
ExtendedMap | extended 拡張情報。 | 通常
String | notes 備考。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
String | terms[0..*].countryCode 国コード。 | 通常
String | terms[0..*].emailAddress1 メールアドレス１。 | 通常
String | terms[0..*].emailAddress2 メールアドレス２。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
ExtendedMap | terms[0..*].extended 拡張情報。 | 通常
String | terms[0..*].extensionFaxNumber 内線FAX番号。 | 通常
String | terms[0..*].extensionNumber 内線番号。 | 通常
String | terms[0..*].faxNumber FAX番号。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].address1 住所１。 | 通常
String | terms[0..*].locales[ロケール].address2 住所２。 | 通常
ExtendedMap | terms[0..*].locales[ロケール].extended 拡張情報。 | 通常
String | terms[0..*].locales[ロケール].name 組織名。 | 通常
String | terms[0..*].locales[ロケール].nameEnglish 組織名英字。 | 通常
String | terms[0..*].locales[ロケール].nameSyllabary 組織名カナ。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
String | terms[0..*].telephoneNumber 電話番号。 | 通常
String | terms[0..*].url URL。 | 通常
String | terms[0..*].zipCode 郵便番号。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
departmentCode

String departmentCode

組織コード。
extended

ExtendedMap extended

拡張情報。
notes

String notes

備考。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].countryCode

String terms[0..*].countryCode

国コード。
terms[0..*].emailAddress1

String terms[0..*].emailAddress1

メールアドレス１。
terms[0..*].emailAddress2

String terms[0..*].emailAddress2

メールアドレス２。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].extended

ExtendedMap terms[0..*].extended

拡張情報。
terms[0..*].extensionFaxNumber

String terms[0..*].extensionFaxNumber

内線FAX番号。
terms[0..*].extensionNumber

String terms[0..*].extensionNumber

内線番号。
terms[0..*].faxNumber

String terms[0..*].faxNumber

FAX番号。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].address1

String terms[0..*].locales[ロケール].address1

住所１。
terms[0..*].locales[ロケール].address2

String terms[0..*].locales[ロケール].address2

住所２。
terms[0..*].locales[ロケール].extended

ExtendedMap terms[0..*].locales[ロケール].extended

拡張情報。
terms[0..*].locales[ロケール].name

String terms[0..*].locales[ロケール].name

組織名。
terms[0..*].locales[ロケール].nameEnglish

String terms[0..*].locales[ロケール].nameEnglish

組織名英字。
terms[0..*].locales[ロケール].nameSyllabary

String terms[0..*].locales[ロケール].nameSyllabary

組織名カナ。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
terms[0..*].telephoneNumber

String terms[0..*].telephoneNumber

電話番号。
terms[0..*].url

String terms[0..*].url

URL。
terms[0..*].zipCode

String terms[0..*].zipCode

郵便番号。


 DepartmentInfo オブジェクト

組織情報オブジェクト。

組織情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.companyCode = "";
   obj.departmentCode = "";
オブジェクト作成方法(JSON方式)
   {
     "companyCode"       : "",
     "departmentCode"    : ""
   }

プロパティの概要
String | companyCode [必須] 会社コード 。 | 通常
String | departmentCode [必須] 組織コード 。 | 通常
プロパティの詳細
companyCode

String companyCode

[必須] 会社コード 。
departmentCode

String departmentCode

[必須] 組織コード 。


 DepartmentMainInfo オブジェクト

主所属情報オブジェクト。
主所属情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

主所属情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
主所属情報オブジェクト
主所属情報
オブジェクト
(Object)
userCode ユーザコード (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
companyCode 会社コード (String)
departmentCode 組織コード (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Array | terms 期間化情報の配列。 | 通常
String | terms[0..*].companyCode 会社コード。 | 通常
String | terms[0..*].departmentCode 組織コード。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
String | userCode ユーザコード。 | 通常
プロパティの詳細
terms

Array terms

期間化情報の配列。
terms[0..*].companyCode

String terms[0..*].companyCode

会社コード。
terms[0..*].departmentCode

String terms[0..*].departmentCode

組織コード。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
userCode

String userCode

ユーザコード。


 DepartmentStructInfo オブジェクト

組織階層情報オブジェクト。
組織階層情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
String | departmentCode 組織コード。 | 通常
String | name 会社名または組織名。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
departmentCode

String departmentCode

組織コード。
name

String name

会社名または組織名。


 Drawer オブジェクト

画像描画オブジェクト。

画像ファイルを描画、生成するＡＰＩを持つオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
コンストラクタの概要
Drawer (Number imageWidth ,Number imageHeight)
コンストラクタ。
メソッドの概要
void | clearClip () クリッピング領域を解除します。
void | copyArea (Number x ,Number y ,Number width ,Number height ,Number dx ,Number dy) コンポーネント領域を複写します。
void | draw3DRect (Number x ,Number y ,Number width ,Number height ,Boolean raised) 指定された矩形を３Ｄ強調表示にします。
void | drawArc (Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle) 円弧または楕円弧の輪郭を描画します。
void | drawLine (Number x1 ,Number y1 ,Number x2 ,Number y2) 線を描画します。
void | drawOval (Number x ,Number y ,Number width ,Number height) 楕円の輪郭を描画します。
void | drawPolygon (Array xPoints ,Array yPoints) 多角形を描画します。
void | drawRect (Number x ,Number y ,Number width ,Number height) 矩形の輪郭を描画します。
void | drawRoundRect (Number x ,Number y ,Number width ,Number height ,Number arcwidth ,Number archeight) 丸いコーナー付きの矩形を描画します。
void | drawString (String string ,Number x ,Number y ,String xPosition ,String yPosition) 文字列を描画します。
void | fill3DRect (Number x ,Number y ,Number width ,Number height ,Boolean raised) 塗りつぶし矩形を３Ｄ強調表示で描画します。
void | fillArc (Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle) 円弧または楕円弧を塗りつぶして描画します。
void | fillOval (Number x ,Number y ,Number width ,Number height) 楕円形を塗りつぶして描画します。
void | fillPolygon (Array xPoints ,Array yPoints) 多角形を塗りつぶして描画します。
void | fillRect (Number x ,Number y ,Number width ,Number height) 塗りつぶし矩形を描画します。
void | fillRoundRect (Number x ,Number y ,Number width ,Number height ,Number arcWidth ,Number arcHeight) 丸いコーナー付きの矩形を塗りつぶして描画します。
String | getColor () 現在の色を取得します。
String | getFontName () 現在のフォント名を取得します。
String | getFontSize () 現在のフォントサイズを取得します。
String | getFontStyle () 現在のフォントスタイルを取得します。
Number | getLineSize () 現在の線幅を取得します。
Array | getLineStyle () 現在の破線スタイルを取得します。
String | putImage (String imageType) 画像ファイルのバイナリデータを取得します。
void | setClipArc (Number x ,Number x ,Number width ,Number height ,Number start ,Number extent) 円弧または楕円弧のクリッピング領域を構築します。
void | setClipPolygon (Array xPoints ,Array yPoints) 多角形のクリッピング領域を構築します。
void | setClipRect (Number x ,Number y ,Number width ,Number height) 矩形のクリッピング領域を構築します。
void | setColor (Object color) 描画する色を設定します。
void | setFontName (String font) 描画するフォントを設定します。
void | setFontSize (Number size) 描画するフォントサイズを設定します。
void | setFontStyle (String style) 描画するフォントスタイルを設定。
void | setLineSize (Number lineSize) 描画する線幅を設定します。
void | setLineStyle (Array lineStyle) 描画する線のスタイルを設定します。
コンストラクタの詳細
Drawer

Drawer (Number imageWidth ,Number imageHeight)
コンストラクタ。

指定された幅・高さで画像ファイルを作成し、グラフの描画を実行するためのインスタンスを生成します。
パラメータ
imageWidth | Number | 画像ファイルの幅
imageHeight | Number | 画像ファイルの高さ
メソッドの詳細
clearClip

void clearClip ()

クリッピング領域を解除します。

現在、設定されているクリッピング領域が解除されます。
返却値
void
copyArea

void copyArea (Number x ,Number y ,Number width ,Number height ,Number dx ,Number dy)

コンポーネント領域を複写します。

コンポーネントの領域を、dx と dy で指定された距離でコピーします。
このメソッドは x と y で指定された座標から、コンポーネントの下方向や右方向の領域をコピーします。
コンポーネントの左方向や上方向の領域をコピーするには、dx と dy に負の値を指定します。
ソースの矩形のある部分がコンポーネントの境界外にある場合や、別のコンポーネントやウィンドウで隠されている場合は、copyArea は対応しているピクセルをコピーできません。
隠された領域は、そのコンポーネントの paint メソッドを呼び出すことにより修復されます。
パラメータ
x | Number | 元の矩形の ｘ座標
y | Number | 元の矩形の ｙ座標
width | Number | 元の矩形の幅
height | Number | 元の矩形の高さ
dx | Number | ピクセルをコピーする水平距離
dy | Number | ピクセルをコピーする垂直距離
返却値
void
draw3DRect

void draw3DRect (Number x ,Number y ,Number width ,Number height ,Boolean raised)

指定された矩形を３Ｄ強調表示にします。

指定された矩形の輪郭を ３Ｄ で強調表示して描画します。
矩形の端は、傾斜し、左上隅から光を当てたように強調表示されます。
強調表示効果に使われる色は、現在の色に基づいて指定されます。
描画された矩形は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
raised に true を指定すると、矩形が表面から浮き出たように表示され、 false を指定すると、表面に彫り込まれたように表示されます。
パラメータ
x | Number | 描画される矩形の ｘ座標
y | Number | 描画される矩形の ｙ座標
width | Number | 描画される矩形の幅
height | Number | 描画される矩形の高さ
raised | Boolean | 矩形の３Ｄ強調表示方法を指定する
返却値
void
drawArc

void drawArc (Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle)

円弧または楕円弧の輪郭を描画します。

指定された矩形をカバーする円弧または楕円弧の輪郭を描きます。
startAngle から始まって arcAngle の角度で展開された弧が、現在の色を使って描かれます。
角度は 3 時の位置を 0 度として変換され、正の値は反時計方向、負の値は時計方向の回転を示します。

弧の中心は、原点が (x, y) で、サイズが width 引数と height 引数で指定される矩形の中心となります。
描かれる弧は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。

角度の広がりは、直角でない、境界の矩形を基準に指定し、楕円の中心から境界の矩形の右上隅までを結ぶ線が常に 45 度になるようにします。
境界の矩形の軸の長さがかなり違う場合には、弧セグメントの開始角度と終了角度は境界の長軸にそってさらに傾斜します。
パラメータ
x | Number | 描画される弧の左上隅の ｘ座標
y | Number | 描画される弧の左上隅の ｙ座標
width | Number | 描画される弧の幅
height | Number | 描画される弧の高さ
startAngle | Number | 開始角度
arcAngle | Number | 開始角度に対する弧の展開角度
返却値
void
drawLine

void drawLine (Number x1 ,Number y1 ,Number x2 ,Number y2)

線を描画します。

このグラフィックスコンテキストの座標体系の座標 (x1, y1) と座標 (x2, y2) との間に現在の色を使って線を描きます。
パラメータ
x1 | Number | 描画する線の始点 ｘ座標
y1 | Number | 描画する線の始点 ｙ座標
x2 | Number | 描画する線の終点 ｘ座標
y2 | Number | 描画する線の終点 ｙ座標
返却値
void
drawOval

void drawOval (Number x ,Number y ,Number width ,Number height)

楕円の輪郭を描画します。

楕円の輪郭を描きます。
引数の x、y、width、height で指定される矩形内に収まる円または楕円が描かれます。
楕円は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
パラメータ
x | Number | 描画される楕円の左上隅の ｘ座標
y | Number | 描画される楕円の左上隅の ｙ座標
width | Number | 描画される楕円の幅
height | Number | 描画される楕円の高さ
返却値
void
drawPolygon

void drawPolygon (Array xPoints ,Array yPoints)

多角形を描画します。

x 座標と y 座標の配列で定義された閉じた多角形を描きます。

座標 (x, y) の各ペアは点を定義します。
ｘ座標の配列数とｙ座標の配列数が一致しない場合、少ないほうの配列数を多角形の座標点数とします。
最後の点と最初の点が一致しない場合、それらを接続するラインを描画すれば図は自動的に閉じます。
パラメータ
xPoints | Array | ｘ座標の配列(Numberの配列)
yPoints | Array | ｙ座標の配列(Numberの配列)
返却値
void
drawRect

void drawRect (Number x ,Number y ,Number width ,Number height)

矩形の輪郭を描画します。

指定された矩形の輪郭を描きます。
矩形は、左端と右端がそれぞれ x と x + width、上端と下端がそれぞれ y と y + height で指定されます。
矩形は、グラフィックスコンテキストの現在の色を使って描画されます。
パラメータ
x | Number | 描画される矩形の ｘ座標
y | Number | 描画される矩形の ｙ座標
width | Number | 描画される矩形の幅
height | Number | 描画される矩形の高さ
返却値
void
drawRoundRect

void drawRoundRect (Number x ,Number y ,Number width ,Number height ,Number arcwidth ,Number archeight)

丸いコーナー付きの矩形を描画します。

丸いコーナー付きの矩形を、このグラフィックスコンテキストの現在の色を使用して描きます。
描かれる矩形は、左端と右端がそれぞれ x と x + width、上端と下端がそれぞれ y と y + height で指定されます。
パラメータ
x | Number | 描画される矩形の ｘ座標
y | Number | 描画される矩形の ｙ座標
width | Number | 描画される矩形の幅
height | Number | 描画される矩形の高さ
arcwidth | Number | ４隅の弧の水平方向の直径
archeight | Number | ４隅の弧の垂直方向の直径
返却値
void
drawString

void drawString (String string ,Number x ,Number y ,String xPosition ,String yPosition)

文字列を描画します。

グラフィックスコンテキストの現在の色とフォントを使用して、指定された文字列を描きます。
座標点（x, y）に対して、文字列をどの位置に表示するかを xPosition および yPosition で指定することができます。
xPosition には "right"（右側）／ "center"（中央）／ "left"（左側）を指定してください。
yPosition には "top"（上側）／ "middle"（中央）／ "bottom"（下側）を指定してください。
パラメータ
string | String | 描画する文字列
x | Number | 文字列が描画される ｘ座標
y | Number | 文字列が描画される ｙ座標
xPosition | String | ｘ座標点に対して 文字列をどの位置に表示するか指定
yPosition | String | ｙ座標点に対して 文字列をどの位置に表示するか指定
返却値
void
fill3DRect

void fill3DRect (Number x ,Number y ,Number width ,Number height ,Boolean raised)

塗りつぶし矩形を３Ｄ強調表示で描画します。

現在の色で塗りつぶされている、３Ｄ で強調表示された矩形を描画します。
矩形の端は、傾斜し、左上隅から光を当てたように強調表示されます。
強調表示効果および塗りつぶしに使われる色は、現在の Color によって指定されます。 raised に true を指定すると、矩形が表面から浮き出たように表示され、 false を指定すると、表面に彫り込まれたように表示されます。
パラメータ
x | Number | 塗りつぶされる矩形の ｘ座標
y | Number | 塗りつぶされる矩形の ｙ座標
width | Number | 塗りつぶされる矩形の幅
height | Number | 塗りつぶされる矩形の高さ
raised | Boolean | 矩形の３Ｄ強調表示方法を指定する
返却値
void
fillArc

void fillArc (Number x ,Number y ,Number width ,Number height ,Number startAngle ,Number arcAngle)

円弧または楕円弧を塗りつぶして描画します。

指定された矩形をカバーする円弧または楕円弧を塗りつぶします。

startAngle から始まって arcAngle の角度で展開された弧が描かれます。
角度は 3 時の位置を 0 度として変換され、正の値は反時計方向、負の値は時計方向の回転を示します。
弧の中心は、原点が (x, y) で、サイズが width 引数と height 引数で指定される矩形の中心となります。
描かれる弧は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
角度の広がりは、直角でない、境界の矩形を基準に指定し、楕円の中心から境界の矩形の右上隅までを結ぶ線が常に 45 度になるようにします。
境界の矩形の軸の長さがかなり違う場合には、弧セグメントの開始角度と終了角度は境界の長軸にそってさらに傾斜します。
パラメータ
x | Number | 塗りつぶされる弧の左上隅の ｘ座標
y | Number | 塗りつぶされる弧の左上隅の ｙ座標
width | Number | 塗りつぶされる弧の幅
height | Number | 塗りつぶされる弧の高さ
startAngle | Number | 開始角度
arcAngle | Number | 開始角度に対する弧の展開角度
返却値
void
fillOval

void fillOval (Number x ,Number y ,Number width ,Number height)

楕円形を塗りつぶして描画します。

楕円形を現在の色で塗りつぶします。
引数の x、y、width、height で指定される矩形内に収まる円または楕円形が塗りつぶされて描かれます。
楕円は、幅 width + 1 ピクセル、高さ height + 1 ピクセルの領域をカバーします。
パラメータ
x | Number | 塗りつぶされる楕円の左上隅の ｘ座標
y | Number | 塗りつぶされる楕円の左上隅の ｙ座標
width | Number | 塗りつぶされる楕円の幅
height | Number | 塗りつぶされる楕円の高さ
返却値
void
fillPolygon

void fillPolygon (Array xPoints ,Array yPoints)

多角形を塗りつぶして描画します。

x 座標と y 座標の配列で定義される閉じた多角形を塗りつぶします。

座標 (x, y) の各ペアは点を定義します。
ｘ座標の配列数とｙ座標の配列数が一致しない場合、少ないほうの配列数を多角形の座標点数とします。
最後の点と最初の点が一致しない場合、それらを接続するラインを描画すれば図は自動的に閉じます。
パラメータ
xPoints | Array | ｘ座標の配列(Numberの配列)
yPoints | Array | ｙ座標の配列(Numberの配列)
返却値
void
fillRect

void fillRect (Number x ,Number y ,Number width ,Number height)

塗りつぶし矩形を描画します。

指定された矩形を塗りつぶします。
矩形の左端と右端はそれぞれ x と x + width - 1 で、上端と下端はそれぞれ y と y + height - 1 です。
これで指定される矩形は、幅 width ピクセル、高さ height ピクセルの領域です。
矩形は、グラフィックスコンテキストの現在の色を使って塗りつぶされます。
パラメータ
x | Number | 塗りつぶされる矩形の ｘ座標
y | Number | 塗りつぶされる矩形の ｙ座標
width | Number | 塗りつぶされる矩形の幅
height | Number | 塗りつぶされる矩形の高さ
返却値
void
fillRoundRect

void fillRoundRect (Number x ,Number y ,Number width ,Number height ,Number arcWidth ,Number arcHeight)

丸いコーナー付きの矩形を塗りつぶして描画します。

指定された丸いコーナー付きの矩形を現在の色で塗りつぶします。
矩形は、左端と右端がそれぞれ x と x + width - 1、上端と下端がそれぞれ y と y + height - 1 で指定されます。
パラメータ
x | Number | 塗りつぶされる矩形の ｘ座標
y | Number | 塗りつぶされる矩形の ｙ座標
width | Number | 塗りつぶされる矩形の幅
height | Number | 塗りつぶされる矩形の高さ
arcWidth | Number | ４隅の弧の水平方向の直径
arcHeight | Number | ４隅の弧の垂直方向の直径
返却値
void
getColor

String getColor ()

現在の色を取得します。

グラフィックスコンテキストの現在の色を返却します。
返却値は色のRGB値（文字列）です。
返却値
String 現在の色のRGB値
getFontName

String getFontName ()

現在のフォント名を取得します。

現在のフォント名を返却します。
返却値
String 現在のフォント名
getFontSize

String getFontSize ()

現在のフォントサイズを取得します。

整数に丸められた、現在のフォントのポイントサイズを返却します。
返却値
String 現在のフォントサイズ
getFontStyle

String getFontStyle ()

現在のフォントスタイルを取得します。

現在のフォントのスタイルを返却します。
返却値は、PLAIN、BOLD、ITALIC、または ITALIC_BOLD のいずれかです。
返却値
String 現在のフォントのスタイル
getLineSize

Number getLineSize ()

現在の線幅を取得します。

現在の線幅を返却します。
返却値
Number 現在の線幅
getLineStyle

Array getLineStyle ()

現在の破線スタイルを取得します。

破線セグメントの長さを表す配列を返却します。
配列内のエントリが、破線の非透明の部分と透明の部分の長さを交互に表しています。
現在の線の形状が実線の場合、null が返ります。
返却値
Array 破線のパターン配列(Numberの配列)
putImage

String putImage (String imageType)

画像ファイルのバイナリデータを取得します。

指定した形式の、画像ファイルのバイナリを返却します。
引数の imageType には、"png" または "jpeg" を指定して下さい。
パラメータ
imageType String 画像ファイル形式
返却値
String 画像ファイルのバイナリデータ
setClipArc

void setClipArc (Number x ,Number x ,Number width ,Number height ,Number start ,Number extent)

円弧または楕円弧のクリッピング領域を構築します。

指定された位置、サイズ、角の大きさにより、新しい円弧または楕円弧のクリッピング領域を構築します。
パラメータ
x | Number | 弧の左上隅の ｘ座標
x | Number | 弧の左上隅の ｙ座標
width | Number | この弧が一部を構成する楕円の幅
height | Number | この弧が一部を構成する楕円の高さ
start | Number | 弧の始角（度単位）
extent | Number | 弧の角の大きさ
返却値
void
setClipPolygon

void setClipPolygon (Array xPoints ,Array yPoints)

多角形のクリッピング領域を構築します。

x 座標と y 座標の配列で定義された閉じた多角形により、新しいクリッピング領域を構築します。
パラメータ
xPoints | Array | ｘ座標の配列(Numberの配列)
yPoints | Array | ｙ座標の配列(Numberの配列)
返却値
void
setClipRect

void setClipRect (Number x ,Number y ,Number width ,Number height)

矩形のクリッピング領域を構築します。

指定された矩形により、新しいクリッピング領域を構築します。
パラメータ
x | Number | 矩形の ｘ座標
y | Number | 矩形の ｙ座標
width | Number | 矩形の幅
height | Number | 矩形の高さ
返却値
void
setColor

void setColor (Object color)

描画する色を設定します。

グラフィックスコンテキストの現在の色を、指定された色に設定します。 このグラフィックスコンテキストを使うこれ以降のレンダリング操作は、ここで指定された色を使用します。 引数の color にはカラーチャートのカラー名を指定して下さい。
パラメータ
color Object カラー名（String または Number)
返却値
void
setFontName

void setFontName (String font)

描画するフォントを設定します。

グラフィックスコンテキストのフォント名を、指定されたフォント名に設定します。
このグラフィックスコンテキストを使用する、それ以降のテキスト描画操作は、このフォント名を使用します。
パラメータ
font String フォント名
返却値
void
setFontSize

void setFontSize (Number size)

描画するフォントサイズを設定します。

グラフィックスコンテキストのフォントサイズを、指定されたフォントサイズに設定します。
このグラフィックスコンテキストを使用する、それ以降のテキスト描画操作は、このフォントサイズを使用します。
パラメータ
size Number フォントサイズ
返却値
void
setFontStyle

void setFontStyle (String style)

描画するフォントスタイルを設定。

グラフィックスコンテキストのフォントスタイルを、指定されたフォントスタイルに設定します。
このグラフィックスコンテキストを使用する、それ以降のテキスト描画操作は、このフォントスタイルを使用します。
引数の style には、"plain"、"bold"、"italic" または "italic_bold" のいずれかを指定して下さい。
パラメータ
style String フォントスタイル
返却値
void
setLineSize

void setLineSize (Number lineSize)

描画する線幅を設定します。

指定された値で、線幅を設定します。
パラメータ
lineSize Number 線幅
返却値
void
setLineStyle

void setLineStyle (Array lineStyle)

描画する線のスタイルを設定します。

線のスタイルを設定します。 引数の lineStyle には、破線のパターンの配列を指定して下さい。
配列内のエントリに、破線の非透明の部分と透明の部分の長さを交互に指定します。
引数の lineStyle が null の場合、線のスタイルは実線になります。
パラメータ
lineStyle Array 線のスタイル(Numberの配列)
返却値
void


 DuplicateLoginManager オブジェクト

重複ログイン管理マネージャクラス。

重複ログインを管理するためのクラス。
バージョン：1.0
導入されたバージョン：6.1
コンストラクタの概要
DuplicateLoginManager ()
コンストラクタ。
メソッドの概要
String | getInvalidateOtherSessionsAttributeName () 現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。
String | getRequestedPageAttributeName () リクエストされたページURLを保持するために使用する属性名を取得します。
Boolean | isDetectEnable (String loginGroup ,String loginType) 検出処理が有効かどうか取得します。
Boolean | isDuplicateLogined (String loginGroup ,String loginType ,String userId ,String sessionId) 引数で指定されたユーザが重複してログインしているかどうか判別します。
Boolean | isInvalidatableByUser (String loginGroup ,String loginType) ユーザ自身のセッションの無効化が可能か取得します。
コンストラクタの詳細
DuplicateLoginManager

DuplicateLoginManager ()
コンストラクタ。

重複ログイン管理マネージャオブジェクトを生成します。
導入されたバージョン：6.1
メソッドの詳細
getInvalidateOtherSessionsAttributeName

String getInvalidateOtherSessionsAttributeName ()

現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名を取得します。
返却値
String 現在のセッション以外のアクティブなセッション情報を削除するために使用する属性名
導入されたバージョン：6.1
getRequestedPageAttributeName

String getRequestedPageAttributeName ()

リクエストされたページURLを保持するために使用する属性名を取得します。
返却値
String リクエストされたページURLを保持するために使用する属性名
導入されたバージョン：6.1
isDetectEnable

Boolean isDetectEnable (String loginGroup ,String loginType)

検出処理が有効かどうか取得します。
パラメータ
loginGroup | String | ログイングループ
loginType | String | ログインタイプ
返却値
Boolean true : 検出処理が有効 / false : 無効
導入されたバージョン：6.1
isDuplicateLogined

Boolean isDuplicateLogined (String loginGroup ,String loginType ,String userId ,String sessionId)

引数で指定されたユーザが重複してログインしているかどうか判別します。
パラメータ
loginGroup | String | ログイングループ
loginType | String | ログインタイプ
userId | String | ユーザID
sessionId | String | セッションID
返却値
Boolean true : 重複ログインしている / false : していない、または情報取得に失敗した場合
導入されたバージョン：6.1
isInvalidatableByUser

Boolean isInvalidatableByUser (String loginGroup ,String loginType)

ユーザ自身のセッションの無効化が可能か取得します。
パラメータ
loginGroup | String | ログイングループ
loginType | String | ログインタイプ
返却値
Boolean true : ユーザ自身のセッションの無効化が可能 / false : 無効
導入されたバージョン：6.1


 DOMAttribute オブジェクト

ノードの属性オブジェクト。

ノードの属性情報を保持するオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
String | getName () 属性名を取得します。
DOMNode | getParentNode () 親ノードを取得します。
String | getValue () 属性値を取得します。
メソッドの詳細
getName

String getName ()

属性名を取得します。

返却値
String 属性名
getParentNode

DOMNode getParentNode ()

親ノードを取得します。

親ノードを持たない場合は null を返します。
返却値
DOMNode 親ノードのオブジェクト
getValue

String getValue ()

属性値を取得します。

返却値
String 属性値


 DOMDocument オブジェクト

XML 文書全体を表す DOM Document オブジェクト。

このオブジェクトでは、XML の各タグをノードとして管理します。
各ノードは､属性と子供ノードを持ちます。
属性と子供ノードは複数持つ事ができ、子供ノードは更に属性と子供ノードを持つ事が出来ます。 すべてのノードの頂点となる親ノード（ドキュメントノード）は、XML ソース中の最も外側のタグであり、getDocumentElement() によって取得する事が出来ます。

XMLを解析してDOMツリーを作成するには、XMLParserオブジェクトのparse()メソッド、または、parseString()メソッドを使います。
（ドキュメントノードが複数存在する場合は、XML 解析エラーとなりますのでご注意下さい。）

例えば、以下のようなＸＭＬ
 <A>
   <B>Ｂタグの中のテキスト</B>
   <C>Ｃタグの中のテキスト</C>
 </A>
から、<C> タグに囲まれたテキスト値を取得する場合は以下のようにプログラムします。

 var xmlString = "<A><B>Ｂタグの中のテキスト</B><C>Ｃタグの中のテキスト</C></A>";

 var parser = new XMLParser();
 var dom = parser.parseString(xmlString);

 if(!parser.isError()){
     var elms = dom.getElementsByTagName("C");
     var elm = elms[0];
     var childs = elm.getChildNodes();
     var data = childs[0].getValue();

     Debug.print("C's text: " + data);
 }
 else {
     Debug.print("Error occured ! : " + parser.getErrorMessage() );
 }
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
DOMNode | createElement (String tagName) 新しいノードを作成します。
DOMNode | createTextNode (String data) 新しいテキストノードを作成します。
DOMDocumentType | getDoctype () ドキュメントタイプを取得します。
DOMNode | getDocumentElement () Documentノードを取得します。
DOMNode | getElementById (String elementId) 識別子に該当するノードを取得します。
Array | getElementsByTagName (String tagname) 指定のタグにマッチするエレメントを取得します。
String | getErrorMessage () エラーメッセージの取得を行います。
Boolean | isError () エラー発生のチェックを行います。
メソッドの詳細
createElement

DOMNode createElement (String tagName)

新しいノードを作成します。

パラメータ
tagName String タグ名
返却値
DOMNode 新しいノードオブジェクト
createTextNode

DOMNode createTextNode (String data)

新しいテキストノードを作成します。

パラメータ
data String テキスト
返却値
DOMNode 新しいノードオブジェクト
getDoctype

DOMDocumentType getDoctype ()

ドキュメントタイプを取得します。

返却値
DOMDocumentType ドキュメントタイプオブジェクト
getDocumentElement

DOMNode getDocumentElement ()

Documentノードを取得します。

返却値
DOMNode ドキュメントを示すノード
getElementById

DOMNode getElementById (String elementId)

識別子に該当するノードを取得します。

指定の識別子にマッチしたノードを返します。
指定の識別子を持つノードが存在しなかった場合 null を返します。
パラメータ
elementId String ノード識別子
返却値
DOMNode ノードオブジェクト
getElementsByTagName

Array getElementsByTagName (String tagname)

指定のタグにマッチするエレメントを取得します。

XML ソース中から指定のタグに該当するエンティティを返します。
返却値は、DOMNode オブジェクトを要素に持つ配列です。
パラメータ
tagname String タグ名
返却値
Array ノードオブジェクト(DOMNode)の配列
getErrorMessage

String getErrorMessage ()

エラーメッセージの取得を行います。

新しいノード作成時にエラーが発生していた場合、そのエラーメッセージを返します。
返却値
String エラーメッセージ
isError

Boolean isError ()

エラー発生のチェックを行います。

新しいノード作成時にエラーが発生していた場合 true を返します。
返却値
Boolean true : エラーあり / false : エラーなし


 DOMDocumentType オブジェクト

ドキュメントタイプオブジェクト。

ドキュメントタイプを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
Array | getEntities () エンティティを取得します。
String | getInternalSubset () インターナルサブセットを取得します。
String | getName () ノードの名称を取得します。
Array | getNotations () ノーテーションを取得します。
String | getPublicId () パブリックIDを取得します。
String | getSystemId () システムIDを取得します。
メソッドの詳細
getEntities

Array getEntities ()

エンティティを取得します。

このオブジェクトから取得できるエンティティをすべて取得します。
配列の要素は、DOMEntity オブジェクトです。
返却値
Array このオブジェクトから取得できるエンティティ(DOMEntity)を要素に持つ配列
getInternalSubset

String getInternalSubset ()

インターナルサブセットを取得します。

返却値
String インターナルサブセット
getName

String getName ()

ノードの名称を取得します。

返却値
String ノードの名称
getNotations

Array getNotations ()

ノーテーションを取得します。

このオブジェクトから取得できるノーテーションをすべて取得します。
配列の要素は、DOMNotation オブジェクトです。
返却値
Array このオブジェクトから取得できるノーテーション(DOMNotation)を要素に持つ配列
getPublicId

String getPublicId ()

パブリックIDを取得します。

返却値
String パブリックID
getSystemId

String getSystemId ()

システムIDを取得します。

返却値
String システムID


 DOMEntity オブジェクト

エンティティオブジェクト。

エンティティを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
String | getPublicId () パブリックIDを取得します。
String | getSystemId () システムIDを取得します。
メソッドの詳細
getPublicId

String getPublicId ()

パブリックIDを取得します。

返却値
String パブリックID
getSystemId

String getSystemId ()

システムIDを取得します。

返却値
String システムID


 DOMNode オブジェクト

DOM ツリーのノードオブジェクトです。

DOM ツリーのノードを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
定数の概要
static Number | ATTRIBUTE_NODE 属性ノード（ノード種別）。
static Number | CDATA_SECTION_NODE CDDATAセクションノード（ノード種別）。
static Number | COMMENT_NODE コメントノード（ノード種別）。
static Number | DOCUMENT_FRAGMENT_NODE ドキュメントフラグメントノード（ノード種別）。
static Number | DOCUMENT_NODE ドキュメントノード（ノード種別）。
static Number | DOCUMENT_TYPE_NODE ドキュメントタイプノード（ノード種別）。
static Number | ELEMENT_NODE エレメントノード（ノード種別）。
static Number | ENTITY_NODE エンティティノード（ノード種別）。
static Number | ENTITY_REFERENCE_NODE エンティティリファレンスノード（ノード種別）。
static Number | NOTATION_NODE ノーテーションノード（ノード種別）。
static Number | PROCESSING_INSTRUCTION_NODE PROCESSING INSTRUCTION ノード（ノード種別）。
static Number | TEXT_NODE テキストノード（ノード種別）。
メソッドの概要
Boolean | appendChild (DOMNode newChild) このノードに子ノードを追加します。
DOMNode | cloneNode (Boolean deep) ノードのコピーを作成します。
String | getAttribute (String name) 属性値を取得します。
Array | getAttributes () 属性情報の一覧を取得します。
Array | getChildNodes () 子ノードの一覧を取得します。
String | getName () ノード名を取得します。
Number | getNodeType () ノードの種別を取得します。
DOMNode | getParentNode () 親ノードを取得します。
タグ名 | getTagName () タグ名を取得します。
String | getValue () ノードの値を取得します。
Boolean | hasAttribute (String name) 指定の属性名が存在するかどうか判定します。
Boolean | hasAttributes () このノードが属性を持っているかどうか判定します。
Boolean | hasChildNodes () このノードが子ノードを持っているかどうか判定します。
Boolean | insertBefore (DOMNode newChild ,DOMNode refChild) 新しい子ノードを追加します。
void | normalize () 子ノードを統合します。
void | removeAttribute (String name) 属性を削除します。
Boolean | removeChild (DOMNode oldChild) 子ノードを削除します。
Boolean | replaceChild (DOMNode newChild ,DOMNode oldChild) 子ノードの置き換えます。
void | setAttribute (String name ,String value) 属性を設定します。
定数の詳細
ATTRIBUTE_NODE

static Number ATTRIBUTE_NODE

属性ノード（ノード種別）。
定数値 ： 2
CDATA_SECTION_NODE

static Number CDATA_SECTION_NODE

CDDATAセクションノード（ノード種別）。
定数値 ： 4
COMMENT_NODE

static Number COMMENT_NODE

コメントノード（ノード種別）。
定数値 ： 8
DOCUMENT_FRAGMENT_NODE

static Number DOCUMENT_FRAGMENT_NODE

ドキュメントフラグメントノード（ノード種別）。
定数値 ： 11
DOCUMENT_NODE

static Number DOCUMENT_NODE

ドキュメントノード（ノード種別）。
定数値 ： 9
DOCUMENT_TYPE_NODE

static Number DOCUMENT_TYPE_NODE

ドキュメントタイプノード（ノード種別）。
定数値 ： 10
ELEMENT_NODE

static Number ELEMENT_NODE

エレメントノード（ノード種別）。
定数値 ： 1
ENTITY_NODE

static Number ENTITY_NODE

エンティティノード（ノード種別）。
定数値 ： 6
ENTITY_REFERENCE_NODE

static Number ENTITY_REFERENCE_NODE

エンティティリファレンスノード（ノード種別）。
定数値 ： 5
NOTATION_NODE

static Number NOTATION_NODE

ノーテーションノード（ノード種別）。
定数値 ： 12
PROCESSING_INSTRUCTION_NODE

static Number PROCESSING_INSTRUCTION_NODE

PROCESSING INSTRUCTION ノード（ノード種別）。
定数値 ： 7
TEXT_NODE

static Number TEXT_NODE

テキストノード（ノード種別）。
定数値 ： 3
メソッドの詳細
appendChild

Boolean appendChild (DOMNode newChild)

このノードに子ノードを追加します。

このノードの子供として、子供ノード列の最後に newChild を追加します。
追加する子ノードは、 DOMDocument.createElement() から作成します。
パラメータ
newChild DOMNode 新しいノード
返却値
Boolean ノードの追加に成功した場合 true、そうでない場合 false
cloneNode

DOMNode cloneNode (Boolean deep)

ノードのコピーを作成します。

deep が true の場合、このノードの持つ子供もすべてコピーし、 そうでない場合、このノードのみをコピーします。
パラメータ
deep Boolean コピーレベルを指定する真偽値
返却値
DOMNode コピーによって新しく作成されたノード
getAttribute

String getAttribute (String name)

属性値を取得します。

このノードの属性の中から、name にマップされている値を返します。
name にマップされた値が存在しない場合 null を返します。
また、このノードが属性を持つ要素ではない場合 null を返します。
パラメータ
name String 属性名
返却値
String 属性値
getAttributes

Array getAttributes ()

属性情報の一覧を取得します。

このノードが持つすべての属性を配列で返します。
このノードが属性を１つも持たない場合、空の配列が返されます。
返される配列の各要素は、DOMAttribute オブジェクトです。
返却値
Array このノードが持つすべての属性(DOMAttribute)の配列
getChildNodes

Array getChildNodes ()

子ノードの一覧を取得します。

このノードが持つすべての子供ノードを配列で返します。
このノードが子供を１つも持たない場合、空の配列が返されます。
返される配列の各要素は、DOMNode オブジェクトです。
返却値
Array このノードが持つすべてのノード(DOMNode)の配列
getName

String getName ()

ノード名を取得します。

返却値
String ノード名
getNodeType

Number getNodeType ()

ノードの種別を取得します。

返却値
Number ノード種別
getParentNode

DOMNode getParentNode ()

親ノードを取得します。

このノードの親にあたるノードを返します。
このノードが親を持たない場合は null を返します。
返却値
DOMNode 親ノード
getTagName

タグ名 getTagName ()

タグ名を取得します。

このノードの示すタグ名を返します。
このノードがタグを示す要素でない場合 null を返します。
返却値
タグ名
getValue

String getValue ()

ノードの値を取得します。

返却値
String ノードの値
hasAttribute

Boolean hasAttribute (String name)

指定の属性名が存在するかどうか判定します。

このノードが属性を持つ要素ではない場合 false を返します。
パラメータ
name String 属性名
返却値
Boolean true : 存在する / false : 存在しない
hasAttributes

Boolean hasAttributes ()

このノードが属性を持っているかどうか判定します。

このノードが１つ以上の属性を持っている場合 true を返します。
返却値
Boolean true : 属性が存在する / false : 属性が存在しない
hasChildNodes

Boolean hasChildNodes ()

このノードが子ノードを持っているかどうか判定します。

このノードが１つ以上の子供ノードを持っている場合 true を返します。
返却値
Boolean true : 子ノードが存在する / false : 子ノードが存在しない
insertBefore

Boolean insertBefore (DOMNode newChild ,DOMNode refChild)

新しい子ノードを追加します。

このノードの子供ノード refChild の位置に、新しいノード newChild を追加します。
追加する子ノードは、 DOMDocument.createElement() から作成します。
パラメータ
newChild | DOMNode | 新しく追加するノード
refChild | DOMNode | 追加すべきノードの位置
返却値
Boolean ノードの追加に成功した場合 true、そうでない場合 false
normalize

void normalize ()

子ノードを統合します。

このノードの持つ子供ノードのうち隣接しているテキストノード同士を統合します。 このメソッド実行後は、テキストノードと他のテキストノードが隣り合った状態はなくなります。
返却値
void
removeAttribute

void removeAttribute (String name)

属性を削除します。

このノードのnameで指定された属性を削除します。
パラメータ
name String 属性名
返却値
void
removeChild

Boolean removeChild (DOMNode oldChild)

子ノードを削除します。

このノードのoldChildで指定された子ノードを削除します。
パラメータ
oldChild DOMNode 削除する子ノード
返却値
Boolean true : 削除成功 / false : 削除失敗
replaceChild

Boolean replaceChild (DOMNode newChild ,DOMNode oldChild)

子ノードの置き換えます。

このノードの子供の中から oldChile を削除して、oldChild の保存されていた位置に newChild を挿入します。
パラメータ
newChild | DOMNode | 新しく追加するノード
oldChild | DOMNode | 追加するノードの位置
返却値
Boolean ノードの置換に成功した場合 true、そうでない場合 false
setAttribute

void setAttribute (String name ,String value)

属性を設定します。

このノードに属性を設定します。
パラメータ
name | String | 属性名
value | String | 属性値
返却値
void


 DOMNotation オブジェクト

ノーテーションオブジェクト。

ノーテーションを示すオブジェクトです。
バージョン：1.0
導入されたバージョン：3.0
メソッドの概要
String | getPublicId () パブリックIDを取得します。
String | getSystemId () システムIDを取得します。
メソッドの詳細
getPublicId

String getPublicId ()

パブリックIDを取得します。

返却値
String パブリックID
getSystemId

String getSystemId ()

システムIDを取得します。

返却値
String システムID


 EventNavigatorManager オブジェクト

イベントナビゲータ管理オブジェクト。

イベントナビゲータ情報の参照、更新を行うマネージャオブジェクトです。

  • イベントナビゲータ管理のイベントナビゲータを編集する場合に用いるイベントフローオブジェクトの構成は以下の通りです。
    • イベントフローオブジェクト
    イベントフロー
    オブジェクト
    (Object)
            id イベントフローID (String)
    open 公開フラグ (String)
    startEventItem スタートイベント (Object)
    sortNumber ソート番号 (Number)
    titleInfo タイトル情報 (Object)
    accessInfo アクセス権 (Object)

  • イベントナビゲータ管理の質問内容を編集する場合に用いるイベントアイテムオブジェクトの構成は以下の通りです。
    • イベントアイテムオブジェクト
    イベントアイテム
    オブジェクト
    (Object)
            selectItem 選択アイテム のリスト (Array)
    titleInfo タイトル情報 (Object)

  • イベントナビゲータ管理の回答を編集する場合に用いる選択アイテムオブジェクトの構成は以下の通りです。
    • 選択アイテムオブジェクト
    選択アイテム
    オブジェクト
    (Object)
            nextEventItem 遷移先イベントアイテム (Object)
    nextEventResultItem 遷移先ナビゲート結果 (Object)
    nextType 遷移先タイプ (String)
    titleInfo タイトル情報 (Object)
    accessInfo アクセス権 (Object)

  • イベントナビゲータ管理のナビゲート結果を編集する場合に用いるナビゲート結果オブジェクトの構成は以下の通りです。
    • ナビゲート結果オブジェクト
    ナビゲート結果
    オブジェクト
    (Object)
            pageItem 結果ページ のリスト (Array)
    titleInfo タイトル情報 (Object)

  • イベントナビゲータ管理のリンクを編集する場合に用いる結果ページオブジェクトの構成は以下の通りです。
    • 結果ページオブジェクト
    結果ページ
    オブジェクト
    (Object)
            linkPageInfo リンク情報 (Object)
    titleInfo タイトル情報 (Object)
    accessInfo アクセス権 (Object)

  • イベントナビゲータ管理のリンクを編集する場合に用いるリンク情報オブジェクトの構成は以下の通りです。
    • リンク情報オブジェクト
    リンク情報
    オブジェクト
    (Object)
            url URL (String)
    param
    パラメータ
    (Object)     		パラメータキー パラメータ値 (String)
    ： （パラメータの数分繰り返し）

  • イベントナビゲータ管理のタイトル情報を編集する場合に用いるタイトル情報オブジェクトの構成は以下の通りです。
    • タイトル情報オブジェクト
    タイトル情報
    オブジェクト
    (Object)
    ロケール
    (String)
            title タイトル (String)
    comment コメント (String)
    ： （ロケールの数分繰り返し）

  • イベントナビゲータ管理のアクセス権を編集する場合に用いるアクセス権情報オブジェクトの構成は以下の通りです。
    • アクセス権情報オブジェクト
    アクセス権情報
    オブジェクト
    (Object)
            role ロール (Array)
    department
    組織情報
    オブジェクト (Array)
            companyCd 会社コード (String)
    departmentCd 組織コード (String)
    post
    役職情報
    オブジェクト (Array)
            companyCd 会社コード (String)
    postCd 役職コード (String)
    publicGroup
    パブリックグループ
    情報オブジェクト (Array)
            groupSetCd グループセットコード (String)
    groupCd グループコード (String)

  • イベントナビゲータ管理のイベントナビゲータの表示順を設定する場合に用いるイベントフロー情報オブジェクトの構成は以下の通りです。
    • イベントフロー情報オブジェクト
    イベントフロー情報
    オブジェクト(Object)
             title タイトル (String)
    comment コメント (String)
    id イベントフローID (String)
    open 公開フラグ (String)
    startEventId スタートイベントID (String)
    permissionCheck パーミッションチェックフラグ (Boolean)

  • 質問画面に出力する場合に用いるイベントアイテム情報オブジェクトの構成は以下の通りです。
    • イベントアイテム情報オブジェクト
    イベントアイテム情報
    オブジェクト(Object)
             title タイトル (String)
    comment コメント (String)
    id イベントアイテムID (String)
    selectItemInfo 選択アイテム情報リスト (Array)
    eventHistory イベント履歴情報リスト (Array)

  • 質問画面に回答一覧を出力する場合に用いる選択アイテム情報オブジェクトの構成は以下の通りです。
    • 選択アイテム情報オブジェクト
    選択アイテム情報
    オブジェクト(Object)
             title タイトル (String)
    comment コメント (String)
    id 選択アイテムID (String)
    nextItemId 遷移先アイテムID (String)
    nextType 遷移先タイプ (String)
    permissionCheck パーミッションチェックフラグ (Boolean)

  • 質問画面に履歴一覧を出力する場合に用いるイベント履歴情報オブジェクトの構成は以下の通りです。
    • イベント履歴情報オブジェクト
    イベント履歴情報
    オブジェクト(Object)
             id イベントアイテムID (String)
    question 質問 (String)
    answer 回答 (String)

  • ナビゲート結果画面に出力する場合に用いるナビゲート結果情報オブジェクトの構成は以下の通りです。
    • ナビゲート結果情報オブジェクト
    ナビゲート結果情報
    オブジェクト(Object)
             title タイトル (String)
    comment コメント (String)
    id ナビゲート結果ID (String)
    resultPageItemInfo 結果ページ のリスト (Array)
    eventHistory イベント履歴情報 リスト (Array)

  • ナビゲート結果の履歴画面に出力する場合に用いる保存ナビゲート結果情報オブジェクトの構成は以下の通りです。
    • 保存ナビゲート結果情報オブジェクト
    保存ナビゲート結果情報
    オブジェクト(Object)
             title タイトル (String)
    comment コメント (String)
    id 結果ページID (String)
    saveDate 保存日時 (Date)
    strSaveDate 表示保存日時 (String)
    resultPageItemInfo 結果ページ のリスト (Array)
    eventHistory イベント履歴情報 リスト (Array)

  • ナビゲート結果画面から結果ページを表示する場合に用いる結果ページ情報オブジェクトの構成は以下の通りです。
    • 結果ページ情報オブジェクト
    結果ページ情報
    オブジェクト(Object)
             title タイトル (String)
    comment コメント (String)
    id 結果ページID (String)
    permissionCheck パーミッションチェックフラグ (Boolean)

バージョン：1.0
導入されたバージョン：6.1
定数の概要
static String | OPEN_FLG_CLOSE 公開フラグ：非公開。
static String | OPEN_FLG_EDIT 公開フラグ：編集中。
static String | OPEN_FLG_OPEN 公開フラグ：公開。
static String | TYPE_EVENT 遷移先タイプ：イベントアイテム。
static String | TYPE_RESULT 遷移先タイプ：ナビゲート結果。
コンストラクタの概要
EventNavigatorManager (String groupId ,String localeId)
コンストラクタ。
メソッドの概要
String | addEventResultItemInfo (String userId ,String eventFlowId ,Object object) 保存ナビゲート結果情報の登録（履歴）。
Boolean | addFavoriteSaveEventResultItemInfo (String userId ,String resultItemId) 保存ナビゲート結果情報お気に入りへ追加。
Boolean | copyEventFlow (String eventFlowId) イベントフローのコピー。
Boolean | deleteEventFlow (String eventFlowId) イベントフローの削除。
String | exportData (String category) エクスポート処理。
String | getConfigPageCount (String userId) 履歴表示件数を取得します。
Object | getEventFlow (String eventFlowId) イベントフローの取得。
Object | getEventFlowInfos (String searchTitle ,Boolean permissionCheck ,Number currentPage) イベントフロー情報一覧（検索タイトル）の取得。
Object | getEventItemInfo (String eventFlowId ,String eventItemId) イベントアイテム情報の取得。
Object | getEventResultItemInfo (String eventFlowId ,String resultItemId) ナビゲート結果情報の取得。
Object | getLinkPageInfo (String eventFlowId ,String eventResultId ,String resultPageId) 結果ページ情報のリンク情報を取得します。
Object | getSaveEventResultItemInfo (String userId ,String resultPageId) 保存ナビゲート結果情報の取得。
Array | getSaveEventResultItemInfos (String searchTitle ,String userId ,String sortKey ,String order ,Number currentPage) 保存ナビゲート結果情報一覧（ユーザ）の取得。
Array | getSaveEventResultItemInfosHistory (String userId) 保存ナビゲート結果情報一覧（履歴）の取得。
Object | getSaveLinkPageInfo (String userId ,String eventResultId ,String resultPageId) 保存結果ページ情報のリンク情報を取得します。
Boolean | importData (String category ,String inputString) インポート処理。
Boolean | registEventFlow (Object object) イベントフローの登録。
Boolean | removeSaveEventResultItemInfo (String userId ,String resultItemId) 保存ナビゲート結果情報削除。
Boolean | setConfigPageCount (String userId ,Number iCount) 履歴表示件数を設定します。
Boolean | setOrderSortNum (Array objectArray) 表示順設定。
Boolean | setViewOpen (String eventFlowId ,Boolean open) 公開フラグ設定。
Boolean | updateEventFlow (String eventFlowId ,Object eventFlow) イベントフローの更新。
Boolean | updateEventResultItemInfo (String userId ,Object object) 保存ナビゲート結果情報の更新（ユーザ）。
Boolean | updateEventResultItemInfoTitle (String userId ,Object object) 保存ナビゲート結果情報のタイトル更新（ユーザ）。
定数の詳細
OPEN_FLG_CLOSE

static String OPEN_FLG_CLOSE

公開フラグ：非公開。
OPEN_FLG_EDIT

static String OPEN_FLG_EDIT

公開フラグ：編集中。
OPEN_FLG_OPEN

static String OPEN_FLG_OPEN

公開フラグ：公開。
TYPE_EVENT

static String TYPE_EVENT

遷移先タイプ：イベントアイテム。
TYPE_RESULT

static String TYPE_RESULT

遷移先タイプ：ナビゲート結果。
コンストラクタの詳細
EventNavigatorManager

EventNavigatorManager (String groupId ,String localeId)
コンストラクタ。

イベントナビゲータ管理オブジェクトを生成します。
パラメータ
groupId | String | ログイングループID
localeId | String | ロケールID
導入されたバージョン：6.1
メソッドの詳細
addEventResultItemInfo

String addEventResultItemInfo (String userId ,String eventFlowId ,Object object)

保存ナビゲート結果情報の登録（履歴）。
パラメータ
userId | String | ユーザID
eventFlowId | String | イベントフローID
object | Object | 保存ナビゲート結果情報
返却値
String 保存ナビゲート結果ID（登録に失敗した場合はnullを返します）
導入されたバージョン：6.1
addFavoriteSaveEventResultItemInfo

Boolean addFavoriteSaveEventResultItemInfo (String userId ,String resultItemId)

保存ナビゲート結果情報お気に入りへ追加。
パラメータ
userId | String | ユーザID
resultItemId | String | 保存ナビゲート結果ID
返却値
Boolean 保存ナビゲート結果情報のお気に入りへ追加に成功(true) / 保存ナビゲート結果情報のお気に入りへ追加に失敗(false)
導入されたバージョン：6.1
copyEventFlow

Boolean copyEventFlow (String eventFlowId)

イベントフローのコピー。
パラメータ
eventFlowId String イベントフローID
返却値
Boolean イベントフローのコピーに成功(true) / イベントフローのコピーに失敗(false)
導入されたバージョン：6.1
deleteEventFlow

Boolean deleteEventFlow (String eventFlowId)

イベントフローの削除。
パラメータ
eventFlowId String イベントフローID
返却値
Boolean イベントフローの削除に成功(true) / イベントフローの削除に失敗(false)
導入されたバージョン：6.1
exportData

String exportData (String category)

エクスポート処理。
パラメータ
category String カテゴリ
返却値
String エクスポートデータ（エクスポート処理に失敗した場合はnullを返します）
導入されたバージョン：6.1
getConfigPageCount

String getConfigPageCount (String userId)

履歴表示件数を取得します。
パラメータ
userId String ユーザID
返却値
String 履歴表示件数（履歴表示件数の取得に失敗した場合はnullを返します）
導入されたバージョン：6.1
getEventFlow

Object getEventFlow (String eventFlowId)

イベントフローの取得。
パラメータ
eventFlowId String イベントフローID
返却値
Object イベントフローオブジェクト（データがない場合はnullを返します）
導入されたバージョン：6.1
getEventFlowInfos

Object getEventFlowInfos (String searchTitle ,Boolean permissionCheck ,Number currentPage)

イベントフロー情報一覧（検索タイトル）の取得。
パラメータ
searchTitle | String | 検索タイトル
permissionCheck | Boolean | 権限チェック要否
currentPage | Number | ページ番号
返却値
Object イベントフローオブジェクトの配列（データがない場合は空の配列を返します）
導入されたバージョン：6.1
getEventItemInfo

Object getEventItemInfo (String eventFlowId ,String eventItemId)

イベントアイテム情報の取得。
パラメータ
eventFlowId | String | イベントフローID
eventItemId | String | イベントアイテムID
返却値
Object イベントアイテム情報オブジェクト （データがない場合はnullを返します）
導入されたバージョン：6.1
getEventResultItemInfo

Object getEventResultItemInfo (String eventFlowId ,String resultItemId)

ナビゲート結果情報の取得。
パラメータ
eventFlowId | String | イベントフローID
resultItemId | String | 結果ページID
返却値
Object ナビゲート結果情報オブジェクト （データがない場合はnullを返します）
導入されたバージョン：6.1
getLinkPageInfo

Object getLinkPageInfo (String eventFlowId ,String eventResultId ,String resultPageId)

結果ページ情報のリンク情報を取得します。
パラメータ
eventFlowId | String | イベントフローID
eventResultId | String | ナビゲート結果ID
resultPageId | String | 結果ページID
返却値
Object 結果ページ情報のリンク情報 （リンク情報の取得に失敗した場合はnullを返します）
導入されたバージョン：6.1
getSaveEventResultItemInfo

Object getSaveEventResultItemInfo (String userId ,String resultPageId)

保存ナビゲート結果情報の取得。
パラメータ
userId | String | ユーザID
resultPageId | String | 結果ページID
返却値
Object 保存ナビゲート結果情報 （データがない場合はnullを返します）
導入されたバージョン：6.1
getSaveEventResultItemInfos

Array getSaveEventResultItemInfos (String searchTitle ,String userId ,String sortKey ,String order ,Number currentPage)

保存ナビゲート結果情報一覧（ユーザ）の取得。
パラメータ
searchTitle | String | 検索タイトル
userId | String | ユーザID
sortKey | String | ソートキー
order | String | ソート順
currentPage | Number | ページ番号
返却値
Array 保存ナビゲート結果情報 の配列（データがない場合は空の配列を返します）
導入されたバージョン：6.1
getSaveEventResultItemInfosHistory

Array getSaveEventResultItemInfosHistory (String userId)

保存ナビゲート結果情報一覧（履歴）の取得。
パラメータ
userId String ユーザID
返却値
Array 保存ナビゲート結果情報 の配列（データがない場合は空の配列を返します）
導入されたバージョン：6.1
getSaveLinkPageInfo

Object getSaveLinkPageInfo (String userId ,String eventResultId ,String resultPageId)

保存結果ページ情報のリンク情報を取得します。
パラメータ
userId | String | ユーザID
eventResultId | String | ナビゲート結果ID
resultPageId | String | 結果ページID
返却値
Object 保存結果ページ情報のリンク情報 （リンク情報の取得に失敗した場合はnullを返します）
導入されたバージョン：6.1
importData

Boolean importData (String category ,String inputString)

インポート処理。
パラメータ
category | String | カテゴリ
inputString | String | インポートデータ
返却値
Boolean インポート処理に成功(true) / インポート処理に失敗(false)
導入されたバージョン：6.1
registEventFlow

Boolean registEventFlow (Object object)

イベントフローの登録。
パラメータ
object Object イベントフローオブジェクト
返却値
Boolean イベントフローの登録に成功(true) / イベントフローの登録に失敗(false)
導入されたバージョン：6.1
removeSaveEventResultItemInfo

Boolean removeSaveEventResultItemInfo (String userId ,String resultItemId)

保存ナビゲート結果情報削除。
パラメータ
userId | String | ユーザID
resultItemId | String | 保存ナビゲート結果ID
返却値
Boolean 保存ナビゲート結果情報の削除に成功(true) / 保存ナビゲート結果情報の削除に失敗(false)
導入されたバージョン：6.1
setConfigPageCount

Boolean setConfigPageCount (String userId ,Number iCount)

履歴表示件数を設定します。
パラメータ
userId | String | ユーザID
iCount | Number | 履歴表示件数
返却値
Boolean 履歴表示件数の設定に成功(true) / 履歴表示件数の設定に失敗(false)
導入されたバージョン：6.1
setOrderSortNum

Boolean setOrderSortNum (Array objectArray)

表示順設定。
パラメータ
objectArray Array 更新対象の イベントフロー情報 の配列
返却値
Boolean 表示順の設定に成功(true) / 表示順の設定に失敗(false)
導入されたバージョン：6.1
setViewOpen

Boolean setViewOpen (String eventFlowId ,Boolean open)

公開フラグ設定。
パラメータ
eventFlowId | String | イベントフローID
open | Boolean | 公開フラグ
返却値
Boolean 公開フラグの設定に成功(true) / 公開フラグの設定に失敗(false)
導入されたバージョン：6.1
updateEventFlow

Boolean updateEventFlow (String eventFlowId ,Object eventFlow)

イベントフローの更新。
パラメータ
eventFlowId | String | イベントフローID
eventFlow | Object | イベントフロー
返却値
Boolean イベントフローの更新に成功(true) / イベントフローの更新に失敗(false)
導入されたバージョン：6.1
updateEventResultItemInfo

Boolean updateEventResultItemInfo (String userId ,Object object)

保存ナビゲート結果情報の更新（ユーザ）。
パラメータ
userId | String | ユーザID
object | Object | 保存ナビゲート結果情報
返却値
Boolean 保存ナビゲート結果情報の更新に成功(true) / 保存ナビゲート結果情報の更新に失敗(false)
導入されたバージョン：6.1
updateEventResultItemInfoTitle

Boolean updateEventResultItemInfoTitle (String userId ,Object object)

保存ナビゲート結果情報のタイトル更新（ユーザ）。
パラメータ
userId | String | ユーザID
object | Object | 保存ナビゲート結果情報
返却値
Boolean 保存ナビゲート結果情報のタイトル更新に成功(true) / 保存ナビゲート結果情報のタイトル更新に失敗(false)
導入されたバージョン：6.1


 ExtendedMap オブジェクト

拡張情報を格納するマップです。

アプリケーション共通マスタで定義された拡張情報を扱うオブジェクトです。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
ExtendedMap ()
コンストラクタ
メソッドの概要
Object | get (String name) 指定された拡張名に一致する拡張情報オブジェクトを取得します。
Array | names () すでに設定された拡張名の一覧を取得します。
Boolean | put (String name ,Object object) 指定された拡張名で拡張情報を設定します。
コンストラクタの詳細
ExtendedMap

ExtendedMap ()
コンストラクタ
メソッドの詳細
get

Object get (String name)

指定された拡張名に一致する拡張情報オブジェクトを取得します。

指定された拡張名に対する拡張情報オブジェクトが存在しない場合は、nullを返却します。
パラメータ
name String 拡張名
返却値
Object 拡張情報オブジェクト
names

Array names ()

すでに設定された拡張名の一覧を取得します。

拡張情報が一つも設定されていない場合は、空の配列を返却します。
返却値
Array 拡張名の一覧
put

Boolean put (String name ,Object object)

指定された拡張名で拡張情報を設定します。

拡張情報の設定に成功した場合はtrue、失敗した場合はfalseを返します。
拡張情報の設定に失敗するのは、拡張名または拡張情報オブジェクトがnullまたは不正な型のオブジェクトの場合です。
パラメータ
name | String | 拡張名
object | Object | 拡張情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 ExtendsImportManager オブジェクト

拡張インポートマネージャクラス。

拡張インポート処理を実行するマネージャクラスです。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static Boolean doImport (String groupId ,String module)
拡張インポート処理を実行します。
メソッドの詳細
doImport

static Boolean doImport (String groupId ,String module)

拡張インポート処理を実行します。

引数moduleには、クラスまたはJSのパスを指定できます。
クラスを指定する場合は、ExtendsImportを継承したクラスのフルパッケージ名を指定してください。

JSのパスを指定する場合は、指定するJSファイルに記述されている"doImport""関数をコールします。
"doImport""関数の第一引数にログイングループIDを引き渡します。
パスの指定は、pagesからの相対パスで、最後に".js"を含んだものである必要があります。
例：
function doImport(group){
......

}
パラメータ
groupId | String | ログイングループID
module | String | 拡張インポート処理を行うクラス名またはJSのパス
返却値
Boolean true : 成功 / false : 失敗


 FavoriteMenuInfo オブジェクト

マイメニュー情報オブジェクト。

マイメニュー情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.name = "マイメニュー１";
   obj.menuId = "menu1";
   obj.imagePath = "";
   obj.sortNum = 0;
オブジェクト作成方法(JSON方式)
   {
     "name" : "マイメニュー１",
     "menuId"  : "menu1",
     "imagePath"  : "",
     "sortNum"  : 0
   }

プロパティの概要
String | imagePath マイメニューのイメージパス。 | 通常
String | menuId メニューID。 | 通常
String | name マイメニューの表示名。 | 通常
Number | sortNum マイメニューのソート番号。 | 通常
プロパティの詳細
imagePath

String imagePath

マイメニューのイメージパス。
menuId

String menuId

メニューID。
name

String name

マイメニューの表示名。
sortNum

Number sortNum

マイメニューのソート番号。


 File オブジェクト

ファイル操作オブジェクト。

Application Runtime 環境のファイルを操作するＡＰＩを持つオブジェクトです。
このＡＰＩは、Application Runtime の動作しているマシンを対象としてファイル操作を行いますので、Application Runtime を分散構築にて複数のコンピュータで運用しているしている場合には、ファイルを共有する事ができません。
各リクエスト、また各クライアント、また各プログラム間で、ファイルおよびディレクトリ名が重複しないように工夫する必要があります。
バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
File (String path)
コンストラクタ。
File (String parent ,String child)
コンストラクタ。
メソッドの概要
Boolean | append (String strm) テキストのファイルへ追記を行います。
Array | directories () ディレクトリ一覧を取得します。
Boolean | exist () ファイル(ディレクトリ)の存在確認を行います。
Array | files () ファイル一覧を取得します。
Boolean | isDirectory () ディレクトリの存在確認を行います。
Boolean | isFile () ファイルの存在確認を行います。
Number | lastModified () ファイルの最終更新日付を取得します。
String | load () ファイルの内容を取得します。
Boolean | makeDirectories () ディレクトリを作成します。
Boolean | move (String newFile) ファイル名を変更します。
String | path () パス名を取得します。
String | read () テキストファイル内容を取得します。
Boolean | remove () ファイルまたはディレクトリを削除します。
Boolean | save (String strm) ファイルへのデータ出力を行います。
Number | size () ファイルサイズを取得します。
Boolean | write (String strm) テキストファイルの出力を行います。
コンストラクタの詳細
File

File (String path)
コンストラクタ。

指定のパスに対するファイル(ディレクトリ)操作を行うためのインスタンスを生成します。
このコンストラクタで生成されたインスタンスが、実際に操作する対象は、Application Runtime が動作している環境のファイルになります。
パスが相対パス形式で指定された場合、このコンストラクタは Application Runtime をインストールしたディレクトリ内にある work/ ディレクトリを親として絶対パスを解決します。
パラメータ
path String ファイルパス
File

File (String parent ,String child)
コンストラクタ。

指定のパスに対するファイル(ディレクトリ)操作を行うためのインスタンスを生成します。
実際にアクセスするファイルは、parent + child が表すファイルまたはディレクトリになります。
このコンストラクタで生成されたインスタンスが、実際に操作する対象は、Application Runtime が動作している環境のファイルになります。
パラメータ
parent | String | 親ディレクトリパス
child | String | ファイルパス
メソッドの詳細
append

Boolean append (String strm)

テキストのファイルへ追記を行います。

ファイルに対して指定のテキストデータを追記します。
引数 strm へは Unicode 体系のテキストデータを渡して下さい。
ファイルへの出力時に、Application Runtime の サーバ文字エンコーディング設定で解決される文字コードへ変換をしてファイルに出力します。
ファイルが存在しない場合には、新規にファイルを作成してデータ出力を行います。
パラメータ
strm String テキストデータ
返却値
Boolean true : 成功 / false : 失敗
directories

Array directories ()

ディレクトリ一覧を取得します。

コンストラクタで指定されたディレクトリ・パスに含まれる全てのディレクトリ名称を返却します。
コンストラクタで指定されたパスが存在するディレクトリではなかった場合の動作は保証されません。
返却値
Array ディレクトリ一覧（配列型）
exist

Boolean exist ()

ファイル(ディレクトリ)の存在確認を行います。

コンストラクタで指定されたパスが存在しているかどうかをチェックした結果を返却します。
返却値
Boolean true : 存在する / false : 存在しない
files

Array files ()

ファイル一覧を取得します。

コンストラクタで指定されたディレクトリ・パスに含まれる全てのファイル名称を返却します。
コンストラクタで指定されたパスが存在するディレクトリではなかった場合の動作は保証されません。
返却値
Array ファイル一覧（配列型）
isDirectory

Boolean isDirectory ()

ディレクトリの存在確認を行います。

コンストラクタで指定されたパスがディレクトリとして存在しているかどうかをチェックした結果を返却します。
返却値
Boolean true : 存在する / false : 存在しない
isFile

Boolean isFile ()

ファイルの存在確認を行います。

コンストラクタで指定されたパスがファイルとして存在しているかどうかをチェックした結果を返却します。
返却値
Boolean true : 存在する / false : 存在しない
lastModified

Number lastModified ()

ファイルの最終更新日付を取得します。

コンストラクタで指定されたパスの最終更新時刻を返却します。
返却値は、1970/01/01からのミリ秒で返す。
返却値
Number 最終更新日付（ミリ秒）
load

String load ()

ファイルの内容を取得します。

コンストラクタで指定されたファイル内のデータをストリームとして返します。
ファイルの内容はバイナリとして扱われます。
返却値
String ファイルの内容
makeDirectories

Boolean makeDirectories ()

ディレクトリを作成します。

コンストラクタで指定されたパスをディレクトリとして新規作成します。
存在していないが必要な親ディレクトリも一緒に作成されます。
このオペレーションが失敗した場合でも、いくつかの必要な親ディレクトリの作成には成功した場合があります。
返却値
Boolean true : 成功 / false : 失敗
move

Boolean move (String newFile)

ファイル名を変更します。

コンストラクタで指定されたパスを引数 newPath に変更します。
引数 newFile には、File ＡＰＩのインスタンスを渡して下さい。
パラメータ
newFile String 新しいパス名
返却値
Boolean true : 成功 / false : 失敗
path

String path ()

パス名を取得します。

このインスタンスの示すパス名を返却します。
返却値
String パス名
read

String read ()

テキストファイル内容を取得します。

このインスタンスの示すファイルの内容を返却します。
ファイルデータはテキストとして扱われます。
ファイルデータは、読込後、自動的に Unicode に変換されます。
返却値
String ファイルの内容
remove

Boolean remove ()

ファイルまたはディレクトリを削除します。

このインスタンスの示すパスを削除します。
返却値
Boolean true : 成功 / false : 失敗
save

Boolean save (String strm)

ファイルへのデータ出力を行います。

このインスタンスの示すファイル・パスに対して引数に指定されたデータを書き出します。
データはバイナリとして扱われます。
パラメータ
strm String データ
返却値
Boolean true : 成功 / false : 失敗
size

Number size ()

ファイルサイズを取得します。

このインスタンスの示すファイル・パスのファイルの大きさを返却します。
返却値の単位は、バイトです。
このインスタンスの示すファイルパスが存在しない場合の動作は未定義です。
返却値
Number ファイルサイズ(バイト数)
write

Boolean write (String strm)

テキストファイルの出力を行います。

このインスタンスの示すファイル・パスに対して引数に指定されたデータを書き出します。
データはテキストとして扱われます。
引数 strm には Unicode のデータを渡して下さい。
ファイルに対して出力する際には、自動的にサーバ文字エンコーディング設定の文字コードに変換されます。
パラメータ
strm String テキストデータ
返却値
Boolean true : 成功 / false : 失敗


 Format オブジェクト

文字列変換オブジェクト。

文字列変換を行うＡＰＩを持つオブジェクトです。

使用例:
ファンクション・コンテナ

var objFormat = new Object();

objFormat.testS =
 Format.get("文字列の変換を「%4s」行います。","intra-mart");
objFormat.testN = Format.get("数値データを４進数に変換「%4n」します。",20);
objFormat.testD =
 Format.get("数値データを１０進数に変換「%7.3d」します。",1234567.89123);
objFormat.testX = Format.get("数値データを１６進数に変換「%3x」します。",55);
objFormat.testB = Format.get("数値データを２進数に変換「%4b」します。",12);
objFormat.testM =
 Format.get("数値データを３桁カンマ区切り数字列に変換「%m」します。",333444555666);
objFormat.testT = Format.get("今日の日付を日付文字列（フォーマット固定）に変換「%t」します。",new
 Date());
objFormat.test = Format.get("％文字を表示「%%」します。");

2001年2月13日というデータを表示する場合、月のデータは0 - 11で表現される(1月=0)ため、(月-1)したデータを new Date
 関数の第2引数に指定する。

objFormat.testDate = Format.fromDate("yyyy/MM/dd", new Date(2001,1,
 13));

Debug.browse(objFormat);
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static String | fromDate (String format ,Date date) フォーマット指定に沿った形に日付を文字列に変換します。
static String | fromNumber (String format ,Number value) フォーマット指定に沿った形に数値を文字列に変換します。
static String | get (String format ,Object arg [,... ...]) 引数値をformatにあわせて文字列に変換します。
static Date | toDate (String format ,String src) フォーマット指定に沿った日付文字列データをDate型オブジェクトへ変換します。
static String | toMoney (Number value) ３桁ずつのカンマ区切り数字列を生成します。
メソッドの詳細
fromDate

static String fromDate (String format ,Date date)

フォーマット指定に沿った形に日付を文字列に変換します。

フォーマット指定文字
記号 | 意味
y | 年
M | 月
d | 日
h | 午前/午後の時 (1 - 12)
H | 一日における時 (0 - 23)
k | 一日における時 (1 - 24)
m | 分
s | 秒
S | ミリ秒
a | 午前/午後
E | 曜日
' テキスト用エスケープ
'' 単一引用符
パラメータ
format | String | フォーマット指定文字列
date | Date | 日付データ
返却値
String 変換後の文字列
fromNumber

static String fromNumber (String format ,Number value)

フォーマット指定に沿った形に数値を文字列に変換します。

フォーマット指定文字
0 - 数字
# - 数字。ゼロだと表示されない
. - 数値桁区切り文字の位置
, - グループ区切り文字位置
パラメータ
format | String | フォーマット指定文字列
value | Number | 数値データ
返却値
String 変換後の文字列
get

static String get (String format ,Object arg [,... ...])

引数値をformatにあわせて文字列に変換します。

フォーマット指定文字
%s → 文字列の変換 (%3s で後方３バイトのみ変換、指定文字列が３バイトより短い場合、前方に空白を追加)
%n → 数値変換 (%4n で４進数に変換)
%d → 10進数変換 (%8.3d で整数8桁＆小数＆桁変換)
%x → 16進数変換 (%4x で４桁 "0" マスク変換)
%b → 2進数変換 (%8b で８桁 "0" マスク変換)
%m → 数値まはた数字の３桁カンマ区切り数字列への変換
%t → DATE変数変換
%% → "%" 文字へ変換
パラメータ
format | String | フォーマット指定文字列
arg | Object | データ
... ... 複数指定する場合は、カンマの後に続けて指定します。(データは16個までです)
返却値
String 変換後の文字列
toDate

static Date toDate (String format ,String src)

フォーマット指定に沿った日付文字列データをDate型オブジェクトへ変換します。
変換に失敗した場合は、nullを返却します。
パラメータ
format | String | フォーマット指定文字列
src | String | 日付文字列データ
返却値
Date 変換後のDate型オブジェクト
toMoney

static String toMoney (Number value)

３桁ずつのカンマ区切り数字列を生成します。

少数部分の値は２桁までの表示となります。
パラメータ
value Number 数値データ
返却値
String 変換された文字列


 グローバル関数

グローバル関数。

バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
Object | duplicate (Object object) 推奨されていません。代替えメソッドはありません。
void | echo (String message) メッセージをシステム出力に出力します。
Object | execute (String command) システムコールを行います。
void | forward (String prgram_name ,Object argument) 現在のプログラム実行を中断して別プログラムを実行します。
void | garbageCollector () ガーベージコレクションの実行を行います。
Object | include (String path [,... ...]) JSファイルをロードして実行します。
Boolean | isArray (Object object) 指定の値の型が配列型であるかどうか判別します。
Boolean | isBlank (Object object) 空文字列であるか判別します。
Boolean | isBoolean (Object object) 指定の値の型が真偽値型であるかどうか判別します。
Boolean | isDate (Object object) 指定の値の型がDate型であるかどうか判別します。
Boolean | isEqual (Object value_a ,Object value_b) 引数に指定された２つの値が等しいかどうか判別します。
Boolean | isFalse (Object object) 指定の値が偽値であるかどうか判別します。
Boolean | isFunction (Object object) 指定の値の型が関数型であるかどうか判別します。
Boolean | isNull (Object object) 指定の値が null であるかどうか判別します。
Boolean | isNumber (Object object) 指定の値の型が数値型であるかどうか判別します。
Boolean | isObject (Object object) 指定の値の型がObject型であるかどうか判別します。
Boolean | isString (Object object) 指定の値の型が文字列型であるかどうか判別します。
Boolean | isTrue (Object object) 指定の値が真値であるかどうか判別します。
Boolean | isUndefined (Object object) 指定の値が undefined であるかどうか判別します。
String | mdv (String value) 文字列の暗号化を行います。
void | redirect (String url) 指定ＵＲＬへリダイレクトを行います。
void | secureRedirect (String url ,Object args) 呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。
void | transmission (String stream) 現在処理中のプログラム実行を中断して、指定のソースを送信します。
メソッドの詳細
duplicate

Object duplicate (Object object)

推奨されていません。代替えメソッドはありません。
オブジェクトのコピーを作成します。

引数のオブジェクトのコピーを生成して返却します。
ただし、prototype オブジェクトや、変数の持つスコープ情報など、
一部の情報に関しては完全には引き継がれない場合があります。
パラメータ
object Object コピーを作成するオブジェクト。
返却値
Object 引数のオブジェクトのコピー
echo

void echo (String message)

メッセージをシステム出力に出力します。

与えられたメッセージ message をシステム出力に出力します。
初期設定では、システムログと標準出力に出力されます。
メッセージの出力先に関しては、システムログの設定に依存します。
パラメータ
message String 出力するメッセージ
返却値
void
execute

Object execute (String command)

システムコールを行います。

指定された文字列 command を、コマンド・プロセッサによって実行されるホスト環境へ渡して、独立した新しいプロセスとして実行します。
この関数は、実行したプロセスが終了するまで待機状態になります。
返却値はオブジェクト型で以下の形式になります。

・実行したプロセスが正常終了した場合

          return_object
              ├ output // プロセスからの標準出力ストリーム(String)
              ├ error // プロセスからのエラー出力ストリーム(String)
              └ exit // プロセスの終了コード

・実行したプロセスが正常終了しなかった場合

          return_object
              ├ error // エラー内容(String)
              └ exit // プロセスの終了コード

・プロセス実行時にランタイム内でエラーが発生した場合

          return_object
              └ exception // エラー内容(String)
プロセスの終了コードは、0 の場合正常終了となります。
上記は一例です。環境により上記プロパティの組合わせが異なる場合があります。

留意点

execute()関数は、複数のリクエストで同時に実行する事は出来ません。
（現在実行中のexecute()関数の処理が終了するまで、他のexecute()関数は実行できません。待ちが発生します。）
複数のリクエストで同時にexecute()関数を実行できるようにするには、%ServerManager%/conf/parameter.xmlに以下のように追記してください。
  <param>
    <param-name>jssp.global_function.#execute.execute_monitor_mode</param-name>
    <param-value>SIMULTANEOUS</param-value>
  </param>
なお、デフォルトの動作に戻したい場合は、追記した部分を削除する、もしくはparam-valueにSYNCHRONIZATIONを指定してください。
パラメータ
command String 実行するシステムコマンド
返却値
Object 結果オブジェクト
forward

void forward (String prgram_name ,Object argument)

現在のプログラム実行を中断して別プログラムを実行します。

現在処理中のプログラム実行を中断して、別プログラムの実行を開始します。
第２引数 argument に渡された値は、リダイレクト実行先ファンクションコンテナ内 init() 関数の引数になります。
実行先プログラムの init() 関数に渡す引数データとして argument に対して request オブジェクトを指定した場合、実行先プログラムの思わぬ誤動作をすることがあります。
request オブジェクトを引数としてプログラムを呼び出す場合は、動作の仕組を十分に考慮してプログラムする必要があります。
本メソッドは、try...catch 文では使用できません。
パラメータ
prgram_name | String | リダイレクト先ＵＲＬ
argument | Object | 引数オブジェクト
返却値
void
garbageCollector

void garbageCollector ()

ガーベージコレクションの実行を行います。

返却値
void
include

Object include (String path [,... ...])

JSファイルをロードして実行します。

JSファイルをロードして、その中に定義されている init() 関数を実行目的のプログラム内の init() 関数には引数として arg_1[, ..., arg_n]が渡されます。
パラメータ
path String ロードするＪＳファイルパス(拡張子なし)
... ... JSファイルの init() 関数へ渡す引数群
複数ある場合は、カンマ区切りで続けて設定します。
返却値
Object 指定したJSファイルの init() 関数の返却値
isArray

Boolean isArray (Object object)

指定の値の型が配列型であるかどうか判別します。

指定値の型が配列型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
配列型 | : true
上記以外 | : false
isBlank

Boolean isBlank (Object object)

空文字列であるか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
空文字列 | : true
null | : true
false | : true
true | : false
undefined | : true
上記以外 | : false
isBoolean

Boolean isBoolean (Object object)

指定の値の型が真偽値型であるかどうか判別します。

指定値の型が真偽値型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
真偽値型 | : true
上記以外 | : false
isDate

Boolean isDate (Object object)

指定の値の型がDate型であるかどうか判別します。

指定値の型がDate型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
Date型 | : true
上記以外 | : false
isEqual

Boolean isEqual (Object value_a ,Object value_b)

引数に指定された２つの値が等しいかどうか判別します。

指定の値の内部構造の等価判定をした結果を返却します。
参照判定ではないので、別インスタンス同志の値の比較が可能です。
パラメータ
value_a | Object | 等価判定対象の値
value_b | Object | 等価判定対象の値
返却値
Boolean 判別結果
等しい | : true
上記以外 | : false
isFalse

Boolean isFalse (Object object)

指定の値が偽値であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
真偽値型であり false | : true
上記以外 | : false
isFunction

Boolean isFunction (Object object)

指定の値の型が関数型であるかどうか判別します。

指定値の型が関数型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
関数型 | : true
上記以外 | : false
isNull

Boolean isNull (Object object)

指定の値が null であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
null | : true
上記以外 | : false
isNumber

Boolean isNumber (Object object)

指定の値の型が数値型であるかどうか判別します。

指定値の型が数値型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
数値型 | : true
上記以外 | : false
isObject

Boolean isObject (Object object)

指定の値の型がObject型であるかどうか判別します。

指定値が null ではなく、指定値の型が Object 型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
Object 型 | : true
上記以外 | : false
isString

Boolean isString (Object object)

指定の値の型が文字列型であるかどうか判別します。

指定値の型が文字列型である場合にのみ真値を返却します。
パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
文字列型 | : true
上記以外 | : false
isTrue

Boolean isTrue (Object object)

指定の値が真値であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
真偽値型であり true | : true
上記以外 | : false
isUndefined

Boolean isUndefined (Object object)

指定の値が undefined であるかどうか判別します。

パラメータ
object Object 判別する変数
返却値
Boolean 判別結果
undefined | : true
上記以外 | : false
mdv

String mdv (String value)

文字列の暗号化を行います。

引数に指定された文字列データを MD5 により暗号化します。
暗号化対象データ内に ASCII 以外の文字を含む場合には、ローカルの文字コード体系に変換したものを引数に指定してください。
パラメータ
value String 暗号化対象文字列
返却値
String 暗号化された文字列
redirect

void redirect (String url)

指定ＵＲＬへリダイレクトを行います。
本メソッドは、try...catch 文では使用できません。
パラメータ
url String リダイレクト先ＵＲＬ
返却値
void
secureRedirect

void secureRedirect (String url ,Object args)

呼び出元のプロトコルを維持した状態で、指定ページにリダイレクトを行います。

外部のURLの場合は、プロトコルから指定します。

内部のURLの場合は以下の通りです。
スクリプト開発モデルプログラムのパスにリダイレクトする場合は、最後に拡張子".jssp"が必要です。
その他のパスにダイレクトする場合は、コンテキストパスからの相対URLとなります。
パラメータ
url | String | リダイレクト先ＵＲＬ
args | Object | リダイレクト引数
返却値
void
transmission

void transmission (String stream)

現在処理中のプログラム実行を中断して、指定のソースを送信します。

指定されたソースは、バイナリデータ（指定されたまま）として扱われます。
（文字コードは自動的に変換されません）

送信ソースには、ＨＴＴＰレスポンスヘッダを含める必要があります。
(このＡＰＩを利用した場合、ランタイムは指定ソースに対する一切の情報操作をおこないません。)
ＨＴＴＰレスポンスヘッダの作成方法に関しては、一般的なＣＧＩプログラムの作成方法を参考にして下さい。

このＡＰＩにより送信されたソースは、セッション管理対象外となります。
request オブジェクトを引数としてプログラムを呼び出す場合は、動作の仕組を十分に考慮してプログラムする必要があります。

本メソッドは、try...catch 文では使用できません。
本メソッドは、レスポンスがコミットされている場合、何も行わずにプログラムの実行を終了します。
パラメータ
stream String ブラウザへの送信ソース
返却値
void


 GroupDealPermissionInfo オブジェクト

パブリックグループ取扱アクセス権情報オブジェクト。
パブリックグループ取扱アクセス権情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | customerCompanyCode 取引先会社コード。 | 通常
String | customerDepartmentCode 取引先組織コード。 | 通常
String | dealCode 取扱コード。 | 通常
String | publicGroupCode パブリックグループコード。 | 通常
String | publicGroupSetCode パブリックグループセットコード。 | 通常
プロパティの詳細
customerCompanyCode

String customerCompanyCode

取引先会社コード。
customerDepartmentCode

String customerDepartmentCode

取引先組織コード。
dealCode

String dealCode

取扱コード。
publicGroupCode

String publicGroupCode

パブリックグループコード。
publicGroupSetCode

String publicGroupSetCode

パブリックグループセットコード。


 HTTPResponse オブジェクト

HTTPレスポンスオブジェクト。

クライアントへ応答を送信する際の処理を支援するオブジェクトです。
Web.getHTTPResponseメソッドにて取得可能です。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
void | sendMessageBody (String strm) 指定のデータを送信します。
void | sendMessageBodyString (String str) 指定のデータを送信します。
void | setContentLength (Number len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType (String type) レスポンスの Content-Type を設定します。
void | setHeader (String name ,String value) 指定された名前と値を持つレスポンスヘッダを設定します このヘッダが既に設定されている場合は上書きされます。
メソッドの詳細
sendMessageBody

void sendMessageBody (String strm)

指定のデータを送信します。
JavaScript の現在の実行は中断します。再開する事はありません。
本メソッドは、try...catch 文では使用できません。
パラメータ
strm String 送信データ
返却値
void
sendMessageBodyString

void sendMessageBodyString (String str)

指定のデータを送信します。
JavaScript の現在の実行は中断します。再開する事はありません。
送信データは文字列として扱われ、ServletResponse#getWriter() が 返す Writer によって出力されます。したがって、文字コードは自動的に 自動的に変換されます。
本メソッドは、try...catch 文では使用できません。
パラメータ
str String 送信データ
返却値
void
setContentLength

void setContentLength (Number len)

レスポンスのメッセージボディ部分の長さをセットします。
HTTP Servlet ではこのメソッドは HTTP ヘッダの
Content-Length フィールドにセットします。
パラメータ
len Number クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値
返却値
void
setContentType

void setContentType (String type)

レスポンスの Content-Type を設定します。
パラメータ
type String コンテントタイプを指定する String
返却値
void
setHeader

void setHeader (String name ,String value)

指定された名前と値を持つレスポンスヘッダを設定します
このヘッダが既に設定されている場合は上書きされます。
パラメータ
name | String | ヘッダの名称
value | String | ヘッダの値
返却値
void


 Identifier オブジェクト

ユニークなＩＤを自動生成するオブジェクト。

ユニークなＩＤを自動生成するＡＰＩを持つオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static String get ()
ユニークなIDを作成します。
メソッドの詳細
get

static String get ()

ユニークなIDを作成します。

ユニークＩＤを生成して返却します。
生成されるＩＤは 15 [byte] 文字列です。
生成されるＩＤは、時間に対してユニークです。
生成されるＩＤは、１つのシステムに対してユニークです。
返却値
String ユニークなID


 ImageIconInfo オブジェクト

イメージアイコン情報オブジェクト。

イメージアイコン情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | imageIconCd イメージアイコンコード。 | 通常
Number | sortKey ソートキー。 | 通常
String | src イメージアイコンURL。 | 通常
プロパティの詳細
imageIconCd

String imageIconCd

イメージアイコンコード。
sortKey

Number sortKey

ソートキー。
src

String src

イメージアイコンURL。


 ImageIconManager オブジェクト

イメージアイコンマネージャオブジェクト

イメージアイコン情報の参照、更新を行うマネージャオブジェクトです。
バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
ImageIconManager (String groupId)
コンストラクタ。
メソッドの概要
void | addGroupImageIcon (ImageIconInfo object) グループのイメージアイコン情報を新規登録します。
void | addUserImageIcon (ImageIconInfo object ,String userCd) ユーザのイメージアイコン情報を新規登録します。
Boolean | deleteGroupImageIcons () グループのイメージアイコン情報をすべて削除します。
Boolean | deleteImageIcon (String imageIconCd) イメージアイコン情報を削除します。
Boolean | deleteUserImageIcons (String userCd) ユーザのイメージアイコン情報をすべて削除します。
Boolean | existGroupImageIconBySrc (String src) URLをもつグループイメージアイコンの存在チェックをします。
Boolean | existGroupImageIcons () グループイメージアイコンの存在チェックをします。
Boolean | existImageIcon (String imageIconCd) イメージアイコンの存在チェックをします。
Boolean | existUserImageIconBySrc (String userCd ,String src) URLをもつユーザイメージアイコンの存在チェックをします。
Boolean | existUserImageIcons (String userCd) ユーザイメージアイコンの存在チェックをします。
Array | getGroupImageIcons () すべてのグループイメージアイコンを取得します。
ImageIconInfo | getImageIcon (String imageIconCd) イメージアイコン情報を取得します。
Array | getUserImageIcons (String userCd) すべてのユーザイメージアイコンを取得します。
Boolean | isDuplicateSrc () イメージアイコンのURLの重複チェックの有効/無効を取得します。
void | setDuplicateSrc (Boolean duplicateSrc) イメージアイコンのURLの重複チェックの有効/無効を設定します。
Boolean | updateGroupImageIcon (ImageIconInfo object) グループのイメージアイコン情報を更新します。
Boolean | updateUserImageIcon (ImageIconInfo object ,String userCd) ユーザのイメージアイコン情報を更新します。
コンストラクタの詳細
ImageIconManager

ImageIconManager (String groupId)
コンストラクタ。

指定したログイングループのイメージアイコンマネージャオブジェクトを生成します。
パラメータ
groupId String ログイングループID
導入されたバージョン：6.0
メソッドの詳細
addGroupImageIcon

void addGroupImageIcon (ImageIconInfo object)

グループのイメージアイコン情報を新規登録します。

イメージアイコンコードが指定されていない場合、Identifer#get()で生成されたキーで登録します。
パラメータ
object ImageIconInfo イメージアイコン情報オブジェクト
返却値
void
導入されたバージョン：6.0
addUserImageIcon

void addUserImageIcon (ImageIconInfo object ,String userCd)

ユーザのイメージアイコン情報を新規登録します。

イメージアイコンコードが指定されていない場合、Identifer#get()で生成されたキーで登録します。
パラメータ
object | ImageIconInfo | イメージアイコン情報オブジェクト
userCd | String | ユーザコード
返却値
void
導入されたバージョン：6.0
deleteGroupImageIcons

Boolean deleteGroupImageIcons ()

グループのイメージアイコン情報をすべて削除します。

返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.0
deleteImageIcon

Boolean deleteImageIcon (String imageIconCd)

イメージアイコン情報を削除します。
引数で指定したイメージアイコン情報を削除します。
パラメータ
imageIconCd String イメージアイコンコード
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.0
deleteUserImageIcons

Boolean deleteUserImageIcons (String userCd)

ユーザのイメージアイコン情報をすべて削除します。

パラメータ
userCd String ユーザコード
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.0
existGroupImageIconBySrc

Boolean existGroupImageIconBySrc (String src)

URLをもつグループイメージアイコンの存在チェックをします。

引数のイメージアイコンURLからなるグループイメージアイコンの存在チェックをします。
  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない
パラメータ
src String イメージアイコンURL
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合
導入されたバージョン：6.0
existGroupImageIcons

Boolean existGroupImageIcons ()

グループイメージアイコンの存在チェックをします。

  • true: グループイメージアイコンが存在している
  • false: グループイメージアイコンが存在していない
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合
導入されたバージョン：6.0
existImageIcon

Boolean existImageIcon (String imageIconCd)

イメージアイコンの存在チェックをします。

  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない
パラメータ
imageIconCd String イメージアイコンコード
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合
導入されたバージョン：6.0
existUserImageIconBySrc

Boolean existUserImageIconBySrc (String userCd ,String src)

URLをもつユーザイメージアイコンの存在チェックをします。

引数のイメージアイコンURLからなるユーザイメージアイコンの存在チェックをします。
  • true: イメージアイコンが存在している
  • false: イメージアイコンが存在していない
パラメータ
userCd | String | ユーザコード
src | String | イメージアイコンURL
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合
導入されたバージョン：6.0
existUserImageIcons

Boolean existUserImageIcons (String userCd)

ユーザイメージアイコンの存在チェックをします。

  • true: ユーザイメージアイコンが存在している
  • false: ユーザイメージアイコンが存在していない
パラメータ
userCd String ユーザコード
返却値
Boolean true : 存在する / false : 存在しない、または情報取得に失敗した場合
導入されたバージョン：6.0
getGroupImageIcons

Array getGroupImageIcons ()

すべてのグループイメージアイコンを取得します。

取得に失敗した場合は、nullを返却します。
すべてのグループイメージアイコンを取得します。
Array 要素の順番はソートキーの昇順となります。
返却値
Array イメージアイコン情報オブジェクトの配列
（データがない場合は空の配列を返します）
導入されたバージョン：6.0
getImageIcon

ImageIconInfo getImageIcon (String imageIconCd)

イメージアイコン情報を取得します。

引数のイメージアイコンコードからイメージアイコンを取得します。
存在しなかった、または取得に失敗した場合は、nullを返却します。
パラメータ
imageIconCd String イメージアイコンコード
返却値
ImageIconInfo イメージアイコン情報オブジェクト
導入されたバージョン：6.0
getUserImageIcons

Array getUserImageIcons (String userCd)

すべてのユーザイメージアイコンを取得します。

取得に失敗した場合は、nullを返却します。
すべてのユーザイメージアイコンを取得します。
Array 要素の順番はソートキーの昇順となります。
パラメータ
userCd String ユーザコード
返却値
Array イメージアイコン情報オブジェクトの配列
（データがない場合は空の配列を返します）
導入されたバージョン：6.0
isDuplicateSrc

Boolean isDuplicateSrc ()

イメージアイコンのURLの重複チェックの有効/無効を取得します。

  • true: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行います。
  • false: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行いません。
  • デフォルト: 無効(false)
返却値
Boolean イメージアイコンのURLの重複チェックの有効/無効
導入されたバージョン：6.0
setDuplicateSrc

void setDuplicateSrc (Boolean duplicateSrc)

イメージアイコンのURLの重複チェックの有効/無効を設定します。

  • true: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行います。
  • false: 登録/更新時にイメージアイコンのURLがすでに登録済かどうかのチェックを行いません。
  • デフォルト: 無効(false)
パラメータ
duplicateSrc Boolean イメージアイコンのURLの重複チェックの有効/無効
返却値
void
導入されたバージョン：6.0
updateGroupImageIcon

Boolean updateGroupImageIcon (ImageIconInfo object)

グループのイメージアイコン情報を更新します。

パラメータ
object ImageIconInfo イメージアイコン情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.0
updateUserImageIcon

Boolean updateUserImageIcon (ImageIconInfo object ,String userCd)

ユーザのイメージアイコン情報を更新します。

パラメータ
object | ImageIconInfo | イメージアイコン情報オブジェクト
userCd | String | ユーザコード
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：6.0


 Imart オブジェクト

IMARTタグ管理オブジェクト。

プレゼンテーション・ページと連携するためのＡＰＩを持つオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static InnerText | compile (String src) ＨＴＭＬソースのコンパイルを行います。
static void | defineAttribute (String name ,Object value) <IMART> タグ内の属性値に対する定数を定義します。
static void | defineType (String name ,Function func) <IMART> タグの実行関数を定義します。
static String | execute (String name ,Object oAttr ,InnerText oInner) 推奨されていません。代替えのメソッドはありません。
static Boolean | isType (String name) <IMART> タグ定義の存在チェックを行います。
メソッドの詳細
compile

static InnerText compile (String src)

ＨＴＭＬソースのコンパイルを行います。

引数のＨＴＭＬソース文字列を解析してコンパイルします。
返却値は InnerText のインスタンスです。これは、ＨＴＭＬ生成のための実行可能オブジェクトです。
この InnerTextのインスタンスでは、InnerText.execute() メソッドを実行する事により、解析された <IMART> が順次実行されます。
InnerText.execute() メソッドの実行結果として、生成されたＨＴＭＬソースが文字列として返されます。
引数に文字列以外の値を指定した場合の動作は保証外です。
パラメータ
src String 解析対象ＨＴＭＬソース
返却値
InnerText 実行可能オブジェクト
defineAttribute

static void defineAttribute (String name ,Object value)

<IMART> タグ内の属性値に対する定数を定義します。

<IMART> タグ内で使用される属性値に対する定数定義をします。
<IMART> タグ内で宣言される各属性に対する属性値のうち、ダブルクォートで囲まれている定数値に対して適応されます。
<IMART> タグ内で宣言されたダブルクォートで囲まれた定数属性値が定義名称と一致する場合、実行時に自動的に実行時値が適応されます。
パラメータ
name | String | 定義名称
value | Object | 実行時値
返却値
void
defineType

static void defineType (String name ,Function func)

<IMART> タグの実行関数を定義します。

引数 name で指定した定義名称が <IMART> タグの type 属性での指定名称になります。
第２引数には、<IMART> タグの type 属性により定義名称でコールされた際に実行する関数を指定します。
関数内では、実行時に２つの引数を取ります。

function my_tag(oAttr, oInner){ ... }

実行関数内の第１引数 oAttr は、<IMART> タグにより指定された引数群になります。
第２引数 oInner は、<IMART> と </IMART> に挟まれた内部ソース（実行オブジェクト形式）になります。
引数が不適切であった場合の動作は保証外です。
パラメータ
name | String | 定義名称
func | Function | 実行関数
返却値
void
execute

static String execute (String name ,Object oAttr ,InnerText oInner)

推奨されていません。代替えのメソッドはありません。
任意の <IMART> タグ定義関数を実行します。

現在定義されている <IMART> タグの任意の定義関数を実行します。
第１引数 name には、<IMART> タグの type 属性に定義されている定義名称を指定します。
第２引数 oAttr は、そのタグ関数の実行に必要なタグ引数をオブジェクトの形式で渡します。
タグ引数オブジェクトは、タグ属性名をプロパティ名として、対応する属性値をプロパティ値としたオブジェクトです。
第３引数 oInner は、<IMART> および </IMART> に挟まれた部分の実行可能オブジェクトになります。
パラメータ
name | String | <IMART> タグ定義名称
oAttr | Object | タグ引数
oInner | InnerText | 実行可能オブジェクト
返却値
String 実行結果ＨＴＭＬソース
isType

static Boolean isType (String name)

<IMART> タグ定義の存在チェックを行います。

指定の定義名称が <IMART> タグの type 属性に定義されているかどうかを判定します。
（Imart.defineType()を利用して定義された <IMART> タグを判定対象とします）
指定の定義名称が <IMART> タグの type 属性に対して定義済みである場合、その定義名称で <IMART> を利用可能である事を示します。
パラメータ
name String 定義名称
返却値
Boolean true : 存在する / false : 存在しない


 ImAjaxUtil オブジェクト

CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティオブジェクトです。

バージョン：1.0
導入されたバージョン：6.1
定数の概要
static String | IM_AJAX_USER_AGENT_FIREFOX 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox
static String | IM_AJAX_USER_AGENT_IE 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer
static String | IM_AJAX_USER_AGENT_NETSCAPE 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape
static String | IM_AJAX_USER_AGENT_OPERA 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera
static String | IM_AJAX_USER_AGENT_SAFARI 「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari
static String | REQUEST_HEADER_NAME_IM_AJAX_REQUEST ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。
static String | REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。
static String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。
static String | RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。
メソッドの概要
static void setErrorResponseHeaders (String errorCode [,String ...])
レスポンスヘッダにエラーコードとエラーメッセージを設定します。
定数の詳細
IM_AJAX_USER_AGENT_FIREFOX

static String IM_AJAX_USER_AGENT_FIREFOX

「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Firefox
定数値 ： "Firefox"
IM_AJAX_USER_AGENT_IE

static String IM_AJAX_USER_AGENT_IE

「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Internet Explorer
定数値 ： "IE"
IM_AJAX_USER_AGENT_NETSCAPE

static String IM_AJAX_USER_AGENT_NETSCAPE

「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Netscape
定数値 ： "Netscape"
IM_AJAX_USER_AGENT_OPERA

static String IM_AJAX_USER_AGENT_OPERA

「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Opera
定数値 ： "Opera"
IM_AJAX_USER_AGENT_SAFARI

static String IM_AJAX_USER_AGENT_SAFARI

「x-jp-co-intra-mart-ajax-user-agent」の設定値 : Safari
定数値 ： "Safari"
REQUEST_HEADER_NAME_IM_AJAX_REQUEST

static String REQUEST_HEADER_NAME_IM_AJAX_REQUEST

ImAjaxからの通信だということを判定可能にするためのリクエスト・ヘッダ名。
定数値 ： "x-jp-co-intra-mart-ajax-request"
REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT

static String REQUEST_HEADER_NAME_IM_AJAX_USER_AGENT

ブラウザの種類を判定可能にするためのリクエスト・ヘッダ名。
定数値 ： "x-jp-co-intra-mart-ajax-user-agent"
RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE

static String RESPONSE_HEADER_NAME_IM_AJAX_ERROR_CODE

ImAjaxへエラーコードを通知するためのレスポンス・ヘッダ名。
定数値 ： "x-jp-co-intra-mart-ajax-error-code"
RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE

static String RESPONSE_HEADER_NAME_IM_AJAX_ERROR_MESSAGE

ImAjaxへエラーメッセージを通知するためのレスポンス・ヘッダ名。
定数値 ： "x-jp-co-intra-mart-ajax-error-message"
メソッドの詳細
setErrorResponseHeaders

static void setErrorResponseHeaders (String errorCode [,String ...])

レスポンスヘッダにエラーコードとエラーメッセージを設定します。
現在ログインしているユーザのロケールでメッセージを設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

設定される、レスポンスヘッダのフォーマットは以下の通りです。
ヘッダー名 | ヘッダー値
x-jp-co-intra-mart-ajax-error-code | エラーコード
x-jp-co-intra-mart-ajax-error-message エラーコードに紐づくエラーメッセージ。

エラーメッセージは、JavaScript(＝EcmaScript) のencodeURIComponent()を利用して、 自動的にエンコードされます。
（エンコード処理は、ResponseCharacterEncodingFilter 内で実行されます）
パラメータ
errorCode String エラーコード
... String メッセージ引数（複数設定可能）
返却値
void


 ImJson オブジェクト

JSON 関連のライブラリです。

JSON (JavaScript Object Notation)は、軽量のデータ交換フォーマットです。
JSON については、JSON の紹介 を参照してください。
バージョン：1.0
導入されたバージョン：6.1
定数の概要
static String | INDENT_STRING インデント文字列
static String | PARSE_JSON_ERROR_MESSAGE JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられる例外のメッセージです。
static String | TYPE_ARRAY 「Array」型 を表す定数
static String | TYPE_BOOLEAN 「Boolean」型 を表す定数
static String | TYPE_DATE 「Date」型 を表す定数
static String | TYPE_FUNCTION 「Function」型 を表す定数
static String | TYPE_JAVA 「Java」型を表す定数
static String | TYPE_NULL 「null」型 を表す定数
static String | TYPE_NUMBER 「Number」型 を表す定数
static String | TYPE_OBJECT 「Object」型 を表す定数
static String | TYPE_STRING 「String」型 を表す定数
static String | TYPE_UNDEFINED 「Undefined」型 を表す定数
static String | TYPE_UNKNOWN 型が特定できない場合を表す定数
static String | TYPE_XML 「XML」型 を表す定数
メソッドの概要
static Boolean | checkJSONString (String jsonString) JSON 文字列の妥当性をチェックします。
static Object | parseJSON (String jsonString) JSON 文字列からJavaScriptオブジェクトに変換します。
static String | toJSONString (Object value [,Boolean debugFlg]) JSON 文字列に変換します。
定数の詳細
INDENT_STRING

static String INDENT_STRING

インデント文字列
定数値 ： " "
PARSE_JSON_ERROR_MESSAGE

static String PARSE_JSON_ERROR_MESSAGE

JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられる例外のメッセージです。
定数値 ： "parseJSON Error"
TYPE_ARRAY

static String TYPE_ARRAY

「Array」型 を表す定数
定数値 ： "/* Array */"
TYPE_BOOLEAN

static String TYPE_BOOLEAN

「Boolean」型 を表す定数
定数値 ： "/* Boolean */"
TYPE_DATE

static String TYPE_DATE

「Date」型 を表す定数
定数値 ： "/* Date */"
TYPE_FUNCTION

static String TYPE_FUNCTION

「Function」型 を表す定数
定数値 ： "/* Function */"
TYPE_JAVA

static String TYPE_JAVA

「Java」型を表す定数
定数値 ： "/* Java */"
TYPE_NULL

static String TYPE_NULL

「null」型 を表す定数
定数値 ： "/* Null */"
TYPE_NUMBER

static String TYPE_NUMBER

「Number」型 を表す定数
定数値 ： "/* Number */"
TYPE_OBJECT

static String TYPE_OBJECT

「Object」型 を表す定数
定数値 ： "/* Object */"
TYPE_STRING

static String TYPE_STRING

「String」型 を表す定数
定数値 ： "/* String */"
TYPE_UNDEFINED

static String TYPE_UNDEFINED

「Undefined」型 を表す定数
定数値 ： "/* Undefined */"
TYPE_UNKNOWN

static String TYPE_UNKNOWN

型が特定できない場合を表す定数
定数値 ： "/* Unknown */"
TYPE_XML

static String TYPE_XML

「XML」型 を表す定数
定数値 ： "/* XML */"
メソッドの詳細
checkJSONString

static Boolean checkJSONString (String jsonString)

JSON 文字列の妥当性をチェックします。

パラメータ
jsonString String JSON 文字列
返却値
Boolean 正当なJSON 文字列の場合は true、不正なJSON 文字列の場合は false を返却します。
parseJSON

static Object parseJSON (String jsonString)

JSON 文字列からJavaScriptオブジェクトに変換します。

変換に失敗した場合、SyntaxError が投げられます。
SyntaxError のメッセージは、ImJson.PARSE_JSON_ERROR_MESSAGE が設定されます。
パラメータ
jsonString String JSON 文字列
返却値
Object JavaScriptオブジェクト
toJSONString

static String toJSONString (Object value [,Boolean debugFlg])

JSON 文字列に変換します。

引数「debugFlg」が true の場合、JSON 文字列のインデント化、および、型名の付与を行います。
その際、変換対象オブジェクト（内部のプロパティも含む）が 以下の型の場合、特別な動作をします。

Date 型 | 型名の右側に、日付の文字列表現がJavaScriptのコメントとして出力されます。
Function 型 | "THIS_IS_FUNCTION" として表現します。

なお、引数「debugFlg」が true 時の本メソッドの返却値には型名が付与されているため、
checkJSONString() でのチェックには失敗します。
パラメータ
value Object 変換対象オブジェクト
debugFlg Boolean JSON 文字列のインデント化、および、型名の付与を行う場合は trueを設定してください。
省略時のデフォルトは false。
返却値
String JSON 文字列


 InnerText オブジェクト

IMARTタグ引数情報オブジェクト。

タグ関数の引数に渡されるオブジェクトです。
拡張 <IMART> タグ用の関数を定義した時に、関数の第２引数として実行エンジンから実行時に受け取るオブジェクトで、<IMART> タグおよび対応する </IMART> タグに挟まれた範囲のスクリプト情報を保持しています。
このオブジェクトにより、タグに挟まれた範囲のスクリプトを実行する事が出来ます(タグのネストを有効にすることができます)。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
String execute ()
オブジェクトの実行を行います。
メソッドの詳細
execute

String execute ()

オブジェクトの実行を行います。

このオブジェクトの示すスクリプトを実行します。
スクリプト中に <IMART> タグの記述があった場合、これを順次実行します。
すべての実行が終了した結果のソースを文字列として返します。
返却値
String 実行結果のソース


 ItemAttachInfo オブジェクト

商品分類情報オブジェクト。
商品分類情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | itemCategoryCode 商品カテゴリコード。 | 通常
String | itemCategoryTypeCode 商品カテゴリ種別コード。 | 通常
String | itemCode 商品コード。 | 通常
プロパティの詳細
itemCategoryCode

String itemCategoryCode

商品カテゴリコード。
itemCategoryTypeCode

String itemCategoryTypeCode

商品カテゴリ種別コード。
itemCode

String itemCode

商品コード。


 ItemAttrInfo オブジェクト

商品属性情報オブジェクト。
商品属性情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

商品属性情報オブジェクトの構成は以下の通りです。
商品属性情報オブジェクト
商品属性情報
オブジェクト
(Object)
itemCode 商品コード (String)
templateCode テンプレートコード (String)
templateDetailCode テンプレート明細コード (String)
numberValue 属性数値 (Number)
locales 国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		stringValue 属性文字列 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | itemCode 商品コード。 | 通常
Object | locales 属性数値。 | 通常
String | locales[ロケール].stringValue 属性文字列。 | 通常
Number | numberValue 販売単価。 | 通常
String | templateCode テンプレートコード。 | 通常
String | templateDetailCode テンプレート明細コード 。 | 通常
プロパティの詳細
itemCode

String itemCode

商品コード。
locales

Object locales

属性数値。
locales[ロケール].stringValue

String locales[ロケール].stringValue

属性文字列。
numberValue

Number numberValue

販売単価。
templateCode

String templateCode

テンプレートコード。
templateDetailCode

String templateDetailCode

テンプレート明細コード 。


 ItemCatalogueInfo オブジェクト

商品カタログ情報オブジェクト。
商品カタログ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | itemCatalogueCode 商品カタログコード。 | 通常
String | itemCode 商品コード。 | 通常
String | media 媒体。 | 通常
Number | mediaCls 媒体種類。 | 通常
String | notes 備考。 | 通常
Number | sortKey ソートキー。 | 通常
プロパティの詳細
itemCatalogueCode

String itemCatalogueCode

商品カタログコード。
itemCode

String itemCode

商品コード。
media

String media

媒体。
mediaCls

Number mediaCls

媒体種類。
notes

String notes

備考。
sortKey

Number sortKey

ソートキー。


 ItemCategoryInfo オブジェクト

商品カテゴリ情報オブジェクト。
商品カテゴリ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

商品カテゴリ情報オブジェクトの構成は以下の通りです。
商品カテゴリ情報オブジェクト
商品カテゴリ情報
オブジェクト
(Object)
itemCategoryTypeCode 商品カテゴリ種別コード (String)
itemCategoryCode 商品カテゴリコード (String)
parentItemCategoryCode 親商品カテゴリコード (String)
notes 備考 (String)
sortKey ソートキー (Number)
locales 国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		itemCategoryName 商品カテゴリ名 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | itemCategoryCode 商品カテゴリコード。 | 通常
String | itemCategoryTypeCode 商品カテゴリ種別コード。 | 通常
Object | locales 国際化情報。 | 通常
String | locales[ロケール].itemCategoryName 商品カテゴリ名。 | 通常
String | notes 備考。 | 通常
String | parentItemCategoryCode 親商品カテゴリコード。 | 通常
Number | sortKey ソートキー。 | 通常
プロパティの詳細
itemCategoryCode

String itemCategoryCode

商品カテゴリコード。
itemCategoryTypeCode

String itemCategoryTypeCode

商品カテゴリ種別コード。
locales

Object locales

国際化情報。
locales[ロケール].itemCategoryName

String locales[ロケール].itemCategoryName

商品カテゴリ名。
notes

String notes

備考。
parentItemCategoryCode

String parentItemCategoryCode

親商品カテゴリコード。
sortKey

Number sortKey

ソートキー。


 ItemCategoryManager オブジェクト

ItemCategoryManagerオブジェクト
商品カテゴリに関連する情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
ItemCategoryManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addCategory (ItemCategoryInfo category) 商品カテゴリを新規登録します。
ResultInfo | deleteCategory (ItemCategoryInfo category) 商品カテゴリを削除します。
ResultInfo | getAllCategorizedItems (String categoryTypeCode ,String categoryCode) 商品カテゴリに分類されているすべての商品の情報を返します。
ResultInfo | getCategorizedItems (String categoryTypeCode ,String categoryCode) 商品カテゴリに分類されている商品の情報を返します。
ResultInfo | getCategory (String categoryTypeCode ,String categoryCode) 指定されたカテゴリコードに対する商品カテゴリの情報を返します。
ResultInfo | getCategoryStruct (String categoryTypeCode) 指定された商品カテゴリ種別のカテゴリ階層を取得します。
ResultInfo | getCategoryTypes () 登録済の商品カテゴリ種別の一覧を返します。
ResultInfo | isEndCategory (String categoryTypeCode ,String categoryCode) 指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
ResultInfo | removeItem (ItemAttachInfo attach) 商品カテゴリから商品を外します。
ResultInfo | setItem (ItemAttachInfo attach) 商品カテゴリに商品を設定します。
ResultInfo | updateCategory (ItemCategoryInfo category) 商品カテゴリを更新します。
コンストラクタの詳細
ItemCategoryManager

ItemCategoryManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addCategory

ResultInfo addCategory (ItemCategoryInfo category)

商品カテゴリを新規登録します。

ルートとなる商品カテゴリを登録するときは、商品カテゴリ種別コードと商品カテゴリコードに同じ値を設定してください。
ルートとなる商品カテゴリが、商品種別となります。
また、ルートの商品カテゴリ登録時は、親商品カテゴリコードに必ずnullが設定されます。

ルートではない商品カテゴリを登録するときは、親商品カテゴリコードを必ず設定してください。
親カテゴリコードが設定されていないときは、処理例外となります。
パラメータ
category ItemCategoryInfo 追加する商品カテゴリ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteCategory

ResultInfo deleteCategory (ItemCategoryInfo category)

商品カテゴリを削除します。
指定された商品カテゴリが存在しない場合は 処理例外となります。
パラメータ
category ItemCategoryInfo 削除する商品カテゴリ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getAllCategorizedItems

ResultInfo getAllCategorizedItems (String categoryTypeCode ,String categoryCode)

商品カテゴリに分類されているすべての商品の情報を返します。
指定された商品カテゴリがカテゴリ階層の末端のカテゴリでない場合、指定されたカテゴリ以下のすべてのカテゴリに分類されている商品情報を返します。
パラメータ
categoryTypeCode | String | 商品カテゴリを指定するカテゴリ種別コード
categoryCode | String | 商品カテゴリを指定するカテゴリコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性にカテゴリ種別となっている商品情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getCategorizedItems

ResultInfo getCategorizedItems (String categoryTypeCode ,String categoryCode)

商品カテゴリに分類されている商品の情報を返します。返される商品情報は、現在存在するもののみです。

指定された商品カテゴリがカテゴリ階層の末端のカテゴリでない場合、指定されたカテゴリ以下のすべてのカテゴリに分類されている商品情報を返します。
パラメータ
categoryTypeCode | String | 商品カテゴリを指定するカテゴリ種別コード
categoryCode | String | 商品カテゴリを指定するカテゴリコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性にカテゴリ種別となっている商品情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getCategory

ResultInfo getCategory (String categoryTypeCode ,String categoryCode)

指定されたカテゴリコードに対する商品カテゴリの情報を返します。
パラメータ
categoryTypeCode | String | 商品カテゴリを指定するカテゴリ種別コード
categoryCode | String | 商品カテゴリを指定するカテゴリコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品カテゴリ情報オブジェクトが設定されます。
(該当データが存在しない場合は null が返却されます。)
getCategoryStruct

ResultInfo getCategoryStruct (String categoryTypeCode)

指定された商品カテゴリ種別のカテゴリ階層を取得します。
パラメータ
categoryTypeCode String 商品カテゴリ種別を指定するカテゴリ種別コード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品カテゴリ構成情報オブジェクトが設定されます。
(該当データが存在しない場合は null が返却されます。)
getCategoryTypes

ResultInfo getCategoryTypes ()

登録済の商品カテゴリ種別の一覧を返します。
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性にカテゴリ種別となっている商品カテゴリ情報オブジェクト の一覧 (Array)が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
isEndCategory

ResultInfo isEndCategory (String categoryTypeCode ,String categoryCode)

指定されたカテゴリコードに対する商品カテゴリが末端のカテゴリか調べます。
パラメータ
categoryTypeCode | String | 商品カテゴリを指定するカテゴリ種別コード
categoryCode | String | 商品カテゴリを指定するカテゴリコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に結果(指定されたカテゴリが末端の時はtrue、それ以外はfalse)が設定されます。
removeItem

ResultInfo removeItem (ItemAttachInfo attach)

商品カテゴリから商品を外します。
指定された商品設定情報が存在しない場合は 処理例外となります。
パラメータ
attach ItemAttachInfo 削除する商品分類情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setItem

ResultInfo setItem (ItemAttachInfo attach)

商品カテゴリに商品を設定します。

商品が設定できるのは、商品カテゴリ階層の末端のカテゴリだけです。 それ以外の商品カテゴリに商品を設定した場合は、処理例外となります。
パラメータ
attach ItemAttachInfo 設定する商品分類情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
updateCategory

ResultInfo updateCategory (ItemCategoryInfo category)

商品カテゴリを更新します。

商品カテゴリの属性情報および商品カテゴリの階層構造を更新する場合に、このメソッドを使用します。
商品カテゴリの階層構造の更新時に、階層構造が循環するような設定が行われた場合は、処理例外となります。
パラメータ
category ItemCategoryInfo 更新する商品カテゴリ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 ItemCategoryStructInfo オブジェクト

商品カテゴリ構成情報オブジェクト。
商品カテゴリ構成情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Array | children 子供の商品カテゴリ構成情報オブジェクトの一覧。 | 通常
ItemCategoryInfo | itemCategory 商品カテゴリ情報。 | 通常
プロパティの詳細
children

Array children

子供の商品カテゴリ構成情報オブジェクトの一覧。
itemCategory

ItemCategoryInfo itemCategory

商品カテゴリ情報。


 ItemInfo オブジェクト

商品情報オブジェクト。
商品情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

商品に関連する情報を操作する場合に用いる 商品情報オブジェクトの構成は以下の通りです。

なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、
「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。

商品情報オブジェクト
商品情報
オブジェクト
(Object)
itemCode 商品コード (String)
productModelCode 製品型番 (String)
notes 備考 (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
salesUnitPrice 販売単価 (Number)
purchaseUnitPrice 仕入単価 (Number)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		itemName 商品名 (String)
itemCaption 商品通称 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | itemCode 商品コード。 | 通常
String | notes 備考。 | 通常
String | productModelCode 製品型番。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].itemCaption 商品通称。 | 通常
String | terms[0..*].locales[ロケール].itemName 商品名。 | 通常
Number | terms[0..*].purchaseUnitPrice 仕入単価。 | 通常
Number | terms[0..*].salesUnitPrice 販売単価。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
プロパティの詳細
itemCode

String itemCode

商品コード。
notes

String notes

備考。
productModelCode

String productModelCode

製品型番。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].itemCaption

String terms[0..*].locales[ロケール].itemCaption

商品通称。
terms[0..*].locales[ロケール].itemName

String terms[0..*].locales[ロケール].itemName

商品名。
terms[0..*].purchaseUnitPrice

Number terms[0..*].purchaseUnitPrice

仕入単価。
terms[0..*].salesUnitPrice

Number terms[0..*].salesUnitPrice

販売単価。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。


 ItemManager オブジェクト

ItemManagerオブジェクト
商品に関連する情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
ItemManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addItem (ItemInfo item) 商品情報を新規登録します。
ResultInfo | deleteCatalogue (ItemCatalogueInfo catalogue) 商品カタログ情報を削除します。
ResultInfo | deleteItem (ItemInfo item) 商品情報を削除します。
ResultInfo | getAttributes (String itemCode) 指定された商品の属性情報を取得します。
ResultInfo | getCatalogue (String itemCode ,String catalogueCode) 指定されたカタログ情報を返します。
ResultInfo | getCatalogueMediaFileName (ItemCatalogueInfo catalogue) 商品カタログの媒体が保存されてるファイルパスを取得します。
ResultInfo | getCatalogues (String itemCode) 指定された商品のカタログ情報を返します。
ResultInfo | getItem (String itemCode) 指定された商品コードに対する商品の情報を返します。
ResultInfo | getItems ([Date date]) 存在する商品の情報を返します。
ResultInfo | getItemsByKey (String code ,String name [,Date date]) 条件に合致する商品の情報を返します。
ResultInfo | removeAttribute (ItemInfo attribute) 指定された商品属性情報を削除します。
ResultInfo | setAttribute (ItemAttrInfo attribute) 商品属性情報を設定します。
ResultInfo | setCatalogue (ItemCatalogueInfo catalogue [,String data]) 商品カタログ情報を設定します。
ResultInfo | updateItem (ItemInfo item) 商品情報を更新します。
コンストラクタの詳細
ItemManager

ItemManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addItem

ResultInfo addItem (ItemInfo item)

商品情報を新規登録します。
商品情報には、期間情報と期間国際化情報を設定してください。
もし設定されてないものがある場合は、 処理失敗となります。

商品の期間は、途切れることができません。
期間に途切れがある場合は、 処理失敗となります。
パラメータ
item ItemInfo 商品情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteCatalogue

ResultInfo deleteCatalogue (ItemCatalogueInfo catalogue)

商品カタログ情報を削除します。
指定されたカタログ情報が存在しない場合は 処理失敗となります。
パラメータ
catalogue ItemCatalogueInfo 商品カタログ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteItem

ResultInfo deleteItem (ItemInfo item)

商品情報を削除します。
指定された商品情報が存在しない場合は 処理失敗となります。
パラメータ
item ItemInfo 商品情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getAttributes

ResultInfo getAttributes (String itemCode)

指定された商品の属性情報を取得します。
パラメータ
itemCode String 商品コード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品属性情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getCatalogue

ResultInfo getCatalogue (String itemCode ,String catalogueCode)

指定されたカタログ情報を返します。
パラメータ
itemCode | String | カタログ情報を指定する商品コード
catalogueCode | String | カタログ情報を指定するカタログコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品カタログ情報オブジェクトが設定されます。
(該当データが存在しない場合はnull が返却されます。)
getCatalogueMediaFileName

ResultInfo getCatalogueMediaFileName (ItemCatalogueInfo catalogue)

商品カタログの媒体が保存されてるファイルパスを取得します。

商品カタログの媒体種類がファイルの時のみ有効です。
ファイルパスの区切りは'/'です。
媒体種類がファイル以外の時はnullを返します。
パラメータ
catalogue ItemCatalogueInfo 商品カタログ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品カタログの媒体が保存されているファイルパス(String)が設定されます。
媒体種類がファイル以外の時はnullを返します。
getCatalogues

ResultInfo getCatalogues (String itemCode)

指定された商品のカタログ情報を返します。
パラメータ
itemCode String 商品カタログ情報の一覧を指定する商品コード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品カタログ情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getItem

ResultInfo getItem (String itemCode)

指定された商品コードに対する商品の情報を返します。
パラメータ
itemCode String 商品情報を指定する商品コード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品情報オブジェクトが設定されます。
(該当データが存在しない場合はnull が返却されます。)
getItems

ResultInfo getItems ([Date date])

存在する商品の情報を返します。
パラメータ
date Date 商品情報を指定する日付（省略可能）
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
getItemsByKey

ResultInfo getItemsByKey (String code ,String name [,Date date])

条件に合致する商品の情報を返します。

検索キーは、コードは商品コード、製品型番に対して使用されます。名称は商品名、商品略称に対して使用されます。
パラメータ
code | String | 商品コード、製品コードを指定する検索キー
name | String | 商品名、商品通称を指定する検索キー
date | Date | 商品情報を指定する日付（省略可能）
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
removeAttribute

ResultInfo removeAttribute (ItemInfo attribute)

指定された商品属性情報を削除します。
指定された属性情報が存在しない場合は 処理失敗となります。
パラメータ
attribute ItemInfo 商品属性情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setAttribute

ResultInfo setAttribute (ItemAttrInfo attribute)

商品属性情報を設定します。

指定された商品属性情報が存在しない場合は新規登録します。商品属性情報すでに存在する場合は更新を行います。

このメソッドでは、複数の商品属性テンプレートの属性情報を設定することはできません。 もし登録済みのものとは異なる商品属性テンプレートの属性情報が指定された場合は、 処理失敗となります。
パラメータ
attribute ItemAttrInfo 商品属性情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setCatalogue

ResultInfo setCatalogue (ItemCatalogueInfo catalogue [,String data])

商品カタログ情報を設定します。
パラメータ
catalogue | ItemCatalogueInfo | 商品カタログ情報オブジェクト
data | String | 商品カタログのファイルの内容(省略可能)
返却値
ResultInfo 処理結果オブジェクト
updateItem

ResultInfo updateItem (ItemInfo item)

商品情報を更新します。
商品情報には、期間情報と期間国際化情報を設定してください。
もし設定されてないものがある場合は、 処理失敗となります。

商品の期間は、途切れることができません。
期間に途切れがある場合は、処理失敗となります。
パラメータ
item ItemInfo 商品情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 ItemTemplateDetailInfo オブジェクト

商品属性テンプレート明細情報オブジェクト。
商品属性テンプレート明細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

商品属性テンプレート明細に関連する情報を操作する場合に用いる 商品属性テンプレート明細情報オブジェクトの構成は以下の通りです。
商品属性テンプレート明細情報オブジェクト
商品属性
テンプレート
明細情報
オブジェクト
(Object)
templateCode テンプレートコード (String)
templateDetailCode テンプレート明細コード (String)
dataType データ型 (Number)
sortKey ソートキー (Number)
notes 備考 (String)
locales 国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		templateDetailName テンプレート明細名 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Number | dataType データ型。 | 通常
Object | locales 国際化情報。 | 通常
String | locales[ロケール].templateDetailName テンプレート明細名。 | 通常
String | notes 備考。 | 通常
Number | sortKey ソートキー。 | 通常
String | templateCode テンプレートコード。 | 通常
String | templateDetailCode テンプレート明細コード。 | 通常
プロパティの詳細
dataType

Number dataType

データ型。
locales

Object locales

国際化情報。
locales[ロケール].templateDetailName

String locales[ロケール].templateDetailName

テンプレート明細名。
notes

String notes

備考。
sortKey

Number sortKey

ソートキー。
templateCode

String templateCode

テンプレートコード。
templateDetailCode

String templateDetailCode

テンプレート明細コード。


 ItemTemplateInfo オブジェクト

商品属性テンプレート情報オブジェクト。
商品属性テンプレート情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | notes 備考。 | 通常
String | templateCode テンプレートコード。 | 通常
String | templateName テンプレート名。 | 通常
プロパティの詳細
notes

String notes

備考。
templateCode

String templateCode

テンプレートコード。
templateName

String templateName

テンプレート名。


 ItemTemplateManager オブジェクト

ItemTemplateManagerオブジェクト
商品属性テンプレートに関連する情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
ItemTemplateManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addTemplate (ItemTemplateInfo itemTemplate) 商品属性テンプレートを追加します。
ResultInfo | deleteTemplate (ItemTemplateInfo itemTemplate) 指定された商品属性テンプレート情報を削除します。
ResultInfo | deleteTemplateDetail (ItemTemplateDetailInfo detail) 指定された商品属性テンプレート明細を削除します。
ResultInfo | getTemplate (String templateCode) 指定された商品属性テンプレート情報を返します。
ResultInfo | getTemplateDetail (String templateCode) 指定された商品属性テンプレートの明細情報を返します。
ResultInfo | getTemplates (String key) 指定された検索条件に該当する商品属性テンプレート情報を返します。
ResultInfo | setTemplateDetail (ItemTemplateDetailInfo detail) 商品属性テンプレート明細を設定します。
ResultInfo | updateTemplate (ItemTemplateInfo itemTemplate) 商品属性テンプレート情報を更新します。
コンストラクタの詳細
ItemTemplateManager

ItemTemplateManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addTemplate

ResultInfo addTemplate (ItemTemplateInfo itemTemplate)

商品属性テンプレートを追加します。
パラメータ
itemTemplate ItemTemplateInfo 商品属性テンプレート情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteTemplate

ResultInfo deleteTemplate (ItemTemplateInfo itemTemplate)

指定された商品属性テンプレート情報を削除します。

指定された商品属性テンプレート情報が存在しない場合は 処理例外となります。
パラメータ
itemTemplate ItemTemplateInfo 商品属性テンプレート情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteTemplateDetail

ResultInfo deleteTemplateDetail (ItemTemplateDetailInfo detail)

指定された商品属性テンプレート明細を削除します。

指定された商品属性テンプレート明細情報が存在しない場合は 処理例外となります。
パラメータ
detail ItemTemplateDetailInfo 商品属性テンプレート明細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getTemplate

ResultInfo getTemplate (String templateCode)

指定された商品属性テンプレート情報を返します。

指定された商品属性テンプレートの情報が存在しない場合はnullを返却します。
パラメータ
templateCode String 商品属性テンプレートコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品属性テンプレート情報オブジェクトが設定されます。
(該当データが存在しない場合はnull が返却されます。)
getTemplateDetail

ResultInfo getTemplateDetail (String templateCode)

指定された商品属性テンプレートの明細情報を返します。

指定された商品属性テンプレート明細情報が存在しない場合は
nullを返却します。
パラメータ
templateCode String 商品属性テンプレートコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品属性テンプレート明細情報オブジェクトが設定されます。
(該当データが存在しない場合はnull が返却されます。)
getTemplates

ResultInfo getTemplates (String key)

指定された検索条件に該当する商品属性テンプレート情報を返します。
パラメータ
key String 検索条件（商品属性テンプレートコードまたは商品属性テンプレート名）
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトのdata属性に商品属性テンプレート情報オブジェクトの一覧が設定されます。
(該当データが存在しない場合は要素数 0 の Array が返却されます。)
setTemplateDetail

ResultInfo setTemplateDetail (ItemTemplateDetailInfo detail)

商品属性テンプレート明細を設定します。
パラメータ
detail ItemTemplateDetailInfo 商品属性テンプレート明細情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
updateTemplate

ResultInfo updateTemplate (ItemTemplateInfo itemTemplate)

商品属性テンプレート情報を更新します。
パラメータ
itemTemplate ItemTemplateInfo 商品属性テンプレート情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 ItemUnitManager オブジェクト

ItemUnitManagerオブジェクト
単位に関連する情報の参照を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
コンストラクタの概要
ItemUnitManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addUnit (String unitCode ,String unitName) 単位を追加します。
ResultInfo | deleteUnit (String unitCode) 単位を削除します。
ResultInfo | getUnitCode (String unitCode) 単位名に対する単位コードを取得します。
ResultInfo | getUnitName (String unitCode) 単位コードに対する名称を返します。
ResultInfo | getUnits () 単位の一覧を取得します。
ResultInfo | updateUnit (String unitCode ,String unitName) 単位を更新します。
コンストラクタの詳細
ItemUnitManager

ItemUnitManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addUnit

ResultInfo addUnit (String unitCode ,String unitName)

単位を追加します。

すでに同一の単位名のものが存在している場合は、登録を行いません。
パラメータ
unitCode | String | 追加する単位情報の単位コード
unitName | String | 追加する単位情報の単位名
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性にtrue(登録を行った場合) or false(登録を行わなかった場合）が設定されます。
deleteUnit

ResultInfo deleteUnit (String unitCode)

単位を削除します。
指定された単位情報が存在しない場合は 処理例外となります。
パラメータ
unitCode String 削除する単位情報の単位コード
返却値
ResultInfo 処理結果オブジェクト
getUnitCode

ResultInfo getUnitCode (String unitCode)

単位名に対する単位コードを取得します。
パラメータ
unitCode String 通貨コードを指定する通貨名
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に通貨コード（String）が設定されます。
（該当データが存在しないときは nullを返します。）
getUnitName

ResultInfo getUnitName (String unitCode)

単位コードに対する名称を返します。
パラメータ
unitCode String 通貨名を指定する通貨コード
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性に通貨名が設定されます。
（該当データが存在しないときは nullを返します。）
getUnits

ResultInfo getUnits ()

単位の一覧を取得します。
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性にキーが通貨コード、値が通貨名からなるオブジェクト (Object)が設定されます。
updateUnit

ResultInfo updateUnit (String unitCode ,String unitName)

単位を更新します。 すでに同一の単位名のものが存在している場合は、更新を行いません。
パラメータ
unitCode | String | 更新する単位情報の単位コード
unitName | String | 更新する単位情報の新たな単位名
返却値
ResultInfo 処理結果オブジェクト

処理結果オブジェクトのdata属性にtrue(更新を行った場合) or false(更新を行わなかった場合）が設定されます。


JavaScript API リスト概要

 JavaScript API リスト 概要

スクリプト開発モデルで利用可能なJavaScript API の概要です。

グローバル関数の概要
グローバル関数 グローバル関数。

オブジェクトの概要
AccessControllerManager | アクセスコントローラマネージャオブジェクト。
AccessSecurityManager | セキュリティマネージャオブジェクト。
AccountManager | アカウントマネージャオブジェクト アカウント情報の参照、更新を行うマネージャオブジェクトです。
ActiveSessionManager | アクティブセッション管理マネージャクラス。
AdminMenuManager | 管理メニューマネージャクラス。
BatchManager | バッチマネージャオブジェクト。
BatchServer | バッチサーバーオブジェクト。
CSVParser | CSV解析オブジェクト。
CalendarManager | カレンダーマネージャオブジェクト。
CategoryManager | CategoryManagerオブジェクト。
Client | セッション情報を取得するオブジェクト。
CompanyManager | CompanyManagerオブジェクト。
Constant | 定数値管理オブジェクト。
Content | コンテンツクラス。
CurrencyManager | CurrencyManagerオブジェクト 通貨に関連する情報の参照を行うマネージャオブジェクトです。
DOMAttribute | ノードの属性オブジェクト。
DOMDocument | XML 文書全体を表す DOM Document オブジェクト。
DOMDocumentType | ドキュメントタイプオブジェクト。
DOMEntity | エンティティオブジェクト。
DOMNode | DOM ツリーのノードオブジェクトです。
DOMNotation | ノーテーションオブジェクト。
DatabaseManager | データベースマネージャ。
DbParameter | SQLパラメータオブジェクト。
DbStoredProcArg | ストアドプロシージャ、ファンクション引数オブジェクト。
DealManager | DealManagerオブジェクト 取扱に関連する情報の参照、更新を行うマネージャオブジェクトです。
DealPermissionManager | DealPermissionManagerオブジェクト 取扱情報に対するアクセス権情報の参照、更新を行うマネージャオブジェクトです。
Debug | デバッグ情報を表示するオブジェクト。
Drawer | 画像描画オブジェクト。
DuplicateLoginManager | 重複ログイン管理マネージャクラス。
EventNavigatorManager | イベントナビゲータ管理オブジェクト。
ExtendedMap | 拡張情報を格納するマップです。
ExtendsImportManager | 拡張インポートマネージャクラス。
File | ファイル操作オブジェクト。
Format | 文字列変換オブジェクト。
HTTPResponse | HTTPレスポンスオブジェクト。
Identifier | ユニークなＩＤを自動生成するオブジェクト。
ImAjaxUtil | CSJSライブラリ「ImAjax」で通信を行う際に有用なサーバサイドのユーティリティオブジェクトです。
ImJson | JSON 関連のライブラリです。
ImageIconManager | イメージアイコンマネージャオブジェクト イメージアイコン情報の参照、更新を行うマネージャオブジェクトです。
Imart | IMARTタグ管理オブジェクト。
InnerText | IMARTタグ引数情報オブジェクト。
ItemCategoryManager | ItemCategoryManagerオブジェクト 商品カテゴリに関連する情報の参照、更新を行うマネージャオブジェクトです。
ItemManager | ItemManagerオブジェクト 商品に関連する情報の参照、更新を行うマネージャオブジェクトです。
ItemTemplateManager | ItemTemplateManagerオブジェクト 商品属性テンプレートに関連する情報の参照、更新を行うマネージャオブジェクトです。
ItemUnitManager | ItemUnitManagerオブジェクト 単位に関連する情報の参照を行うマネージャオブジェクトです。
JsTestSuite | im-JsUnitのテストスイートオブジェクト。
JsUnit | im-JsUnit オブジェクト。
LicenseManager | ライセンスマネージャクラス。
Lock | アプリケーション・ロック管理オブジェクト。
LogConstraint | ログ用定数オブジェクト。
LoginGroupManager | ログイングループマネージャオブジェクト。
MailSender | メールを送信するオブジェクトです。
MenuManager | メニューマネージャオブジェクト。
MessageManager | メッセージマネージャオブジェクト。
ParameterManager | ParameterManagerオブジェクト。
PasswordHistoryManager | パスワード履歴管理情報オブジェクト。
Permanent | 永続情報操作オブジェクト。
PermissionManager | パーミッションマネージャクラス。
PortletManager | PortletManagerオブジェクト。
PrivateGroupManager | PrivateGroupManagerオブジェクト。
Procedure | プロシージャクラス。
PublicGroupManager | PublicGroupManagerオブジェクト。
RCV | RC-5 暗号・復号化オブジェクト。
Request | リクエストオブジェクト。
RequestParameter | リクエストパラメータ情報オブジェクト。
RoleManager | ロールマネージャオブジェクト。
SecurityConst | アクセスセキュリティ定数オブジェクト。
ShortCutManager | ショートカット情報オブジェクト。
System | システムマネージャオブジェクト。
TermManager | TermManagerオブジェクト 期間に関する情報を扱うマネージャオブジェクトです。
URL | URL操作クラス。
Unicode | Unicodeクラス。
UpdateManager | 情報更新管理マネージャオブジェクト。
UserManager | UserManagerオブジェクト。
VirtualFile | VirtualFile操作クラス。
Web | Webクラス。
XMLDocument | XMLを解析するパーサーオブジェクト。
XMLParser | XMLを解析するパーサーオブジェクト。
Batch | 推奨されません。BatchManagerに置き替えられました。
Mail | 推奨されません。MailSenderに置き換えられました。

Moduleオブジェクトの概要
Module.alert | 警告画面オブジェクト 警告画面を表示します。
Module.array | 配列データを扱うためのオブジェクト。
Module.calendar | 日本の元号を扱うオブジェクト。
Module.client | ログインしているカレント・ユーザー情報に関するオブジェクト。
Module.data | JavaScript の各種データを扱うオブジェクト。
Module.date | 日付データの日情報に対して指定増分を加算するオブジェクト。
Module.download | データのダウンロード機能を提供するオブジェクト。
Module.external | 各リクエスト間、各クライアント間、および各サーバ間で共有の値を操作するオブジェクト。
Module.formatfile | データをフォーマットされた形式のファイルとして出力するオブジェクト。
Module.ldap | LDAPサーバにアクセスするオブジェクト。
Module.mailpool | メール・プール機能を提供するオブジェクト。
Module.mobile | モバイル用画面開発時に必要になる各種機能を提供するオブジェクト。
Module.number | 数値データを扱うメソッドを提供するオブジェクト。
Module.string | 文字列データを扱うメソッドを提供するオブジェクト。
Module.access | 推奨されません。アクセスセキュリティの各Managerオブジェクトのメソッドに置き換えられました。
Module.almanac | 推奨されません。CalendarManagerに置き換えられました。
Module.database | 推奨されません。DatabaseManagerに置き換えられました。
Module.logingp | 推奨されません。LoginGroupManagerに置き換えられました。
Module.message | 推奨されません。MessageManagerに置き換えられました。

Procedureオブジェクトの概要
Procedure.AppCommonUtil | アプリケーション共通マスタで使用する共通関数です。
Procedure.SearchCommonUtil | ユーザ検索で使用する共通関数です。
Procedure.RealNumber | 推奨されません。代替オブジェクトはありません。
Procedure.age | 推奨されません。代替オブジェクトはありません。
Procedure.imode | 推奨されません。代替オブジェクトはありません。
Procedure.upload | 推奨されません。代替のオブジェクトはありません。

情報オブジェクトの概要
AccessControllerInfo | アクセスコントローラ情報オブジェクト。
AccountInfo | アカウント情報オブジェクト。
AccountRoleInfo | アカウントロール情報オブジェクト。
ActiveSessionInfo | アクティブセッション情報オブジェクト。
ApplicationInfo | アプリケーション情報オブジェクト。
BatchInfo | バッチ情報オブジェクト。
CalendarDayInfo | カレンダ日付情報オブジェクト。
CalendarInfo | カレンダデータオブジェクト。
CategoryInfo | カテゴリ詳細情報オブジェクト。
ClientTypeInfo | クライアントタイプ情報オブジェクト。
ColorPatternInfo | カラーパターン情報オブジェクト。
CompanyCategoryInfo | 会社組織分類区分情報オブジェクト。
CompanyDetailInfo | 会社詳細情報オブジェクト。
CompanyVersionInfo | 会社構成バージョン情報オブジェクト。
DatabaseResult | データベースアクセス処理結果オブジェクト。
DealInfo | 取扱情報オブジェクト。
DepartmentAttachInfo | 組織所属情報オブジェクト。
DepartmentDealPermissionInfo | 組織取扱アクセス権情報オブジェクト。
DepartmentDetailInfo | 組織詳細情報オブジェクト。
DepartmentInfo | 組織情報オブジェクト。
DepartmentMainInfo | 主所属情報オブジェクト。
DepartmentStructInfo | 組織階層情報オブジェクト。
FavoriteMenuInfo | マイメニュー情報オブジェクト。
GroupDealPermissionInfo | パブリックグループ取扱アクセス権情報オブジェクト。
ImageIconInfo | イメージアイコン情報オブジェクト。
ItemAttachInfo | 商品分類情報オブジェクト。
ItemAttrInfo | 商品属性情報オブジェクト。
ItemCatalogueInfo | 商品カタログ情報オブジェクト。
ItemCategoryInfo | 商品カテゴリ情報オブジェクト。
ItemCategoryStructInfo | 商品カテゴリ構成情報オブジェクト。
ItemInfo | 商品情報オブジェクト。
ItemTemplateDetailInfo | 商品属性テンプレート明細情報オブジェクト。
ItemTemplateInfo | 商品属性テンプレート情報オブジェクト。
LocaleInfo | ロケール情報オブジェクト。
LoginGroupInfo | ログイングループ情報オブジェクト。
MainPagePatternInfo | メインページパターン情報オブジェクト。
MenuInclusionInfo | メニュー内包情報オブジェクト。
MenuInfo | メニュー情報オブジェクト。
MenuTreeInfo | メニューツリー情報オブジェクト。
PasswordHistoryInfo | パスワード履歴管理情報オブジェクト。
PasswordHistoryResultInfo | パスワード履歴チェック結果オブジェクト。
PlainPostDetailInfo | 非構造化役職詳細情報オブジェクト。
PostDetailInfo | 役職詳細情報オブジェクト。
PostInfo | 役職情報オブジェクト。
PrivateGroupAttachInfo | プライベートグループ所属情報オブジェクト。
PrivateGroupInfo | プライベートグループ情報オブジェクト。
PublicGroupAttachInfo | パブリックグループ所属情報オブジェクト。
PublicGroupCategoryInfo | パブリックグループ分類区分情報オブジェクト。
PublicGroupDetailInfo | パブリックグループ詳細情報オブジェクト。
PublicGroupInfo | パブリックグループ情報オブジェクト。
PublicGroupSetDetailInfo | パブリックグループセット詳細情報オブジェクト。
PublicGroupStructInfo | パブリックグループ階層情報オブジェクト。
PublicGroupVersionInfo | パブリックグループ構成バージョン情報オブジェクト。
ResultInfo | 処理結果オブジェクト。
RoleDealPermissionInfo | ロール取扱アクセス権情報オブジェクト。
RoleInfo | ロール情報オブジェクト。
SessionConfigInfo | セキュリティ設定情報オブジェクト。
SessionInfo | セッション情報オブジェクト。
ShortCutInfo | ショートカット情報オブジェクト。
SuperUserInfo | 管理者情報オブジェクト。
SystemMenuInfo | システムメニュー情報オブジェクト。
TermInfo | 期間情報オブジェクト。
TermResultInfo | 期間処理結果オブジェクト。
UserInfo | ユーザ情報オブジェクト。
DataForAccount | 推奨されません。代替えのオブジェクトはありません。
DataForDatabase | 推奨されません。DatabaseResultに置き換えられました。
DataForRole | 推奨されません。代替えのオブジェクトはありません。
DataForStoredProc | 推奨されません。DatabaseResultに置き換えられました。
DbResultObject | 推奨されません。DatabaseResultに置き換えられました。


JavaScript API リスト

グローバル関数
オブジェクト
AccessControllerManager
AccessSecurityManager
AccountManager
ActiveSessionManager
AdminMenuManager
BatchManager
BatchServer
CSVParser
CalendarManager
CategoryManager
Client
CompanyManager
Constant
Content
CurrencyManager
DOMAttribute
DOMDocument
DOMDocumentType
DOMEntity
DOMNode
DOMNotation
DatabaseManager
DbParameter
DbStoredProcArg
DealManager
DealPermissionManager
Debug
Drawer
DuplicateLoginManager
EventNavigatorManager
ExtendedMap
ExtendsImportManager
File
Format
HTTPResponse
Identifier
ImAjaxUtil
ImJson
ImageIconManager
Imart
InnerText
ItemCategoryManager
ItemManager
ItemTemplateManager
ItemUnitManager
JsTestSuite
JsUnit
LicenseManager
Lock
LogConstraint
LoginGroupManager
MailSender
MenuManager
MessageManager
ParameterManager
PasswordHistoryManager
Permanent
PermissionManager
PortletManager
PrivateGroupManager
Procedure
PublicGroupManager
RCV
Request
RequestParameter
RoleManager
SecurityConst
ShortCutManager
System
TermManager
URL
Unicode
UpdateManager
UserManager
VirtualFile
Web
XMLDocument
XMLParser

Batch 非推奨
Mail 非推奨
Moduleオブジェクト
Module.alert
Module.array
Module.calendar
Module.client
Module.data
Module.date
Module.download
Module.external
Module.formatfile
Module.ldap
Module.mailpool
Module.mobile
Module.number
Module.string

Module.access 非推奨
Module.almanac 非推奨
Module.database 非推奨
Module.logingp 非推奨
Module.message 非推奨
Procedureオブジェクト
Procedure.AppCommonUtil
Procedure.SearchCommonUtil

Procedure.RealNumber 非推奨
Procedure.age 非推奨
Procedure.imode 非推奨
Procedure.upload 非推奨
情報オブジェクト
AccessControllerInfo
AccountInfo
AccountRoleInfo
ActiveSessionInfo
ApplicationInfo
BatchInfo
CalendarDayInfo
CalendarInfo
CategoryInfo
ClientTypeInfo
ColorPatternInfo
CompanyCategoryInfo
CompanyDetailInfo
CompanyVersionInfo
DatabaseResult
DealInfo
DepartmentAttachInfo
DepartmentDealPermissionInfo
DepartmentDetailInfo
DepartmentInfo
DepartmentMainInfo
DepartmentStructInfo
FavoriteMenuInfo
GroupDealPermissionInfo
ImageIconInfo
ItemAttachInfo
ItemAttrInfo
ItemCatalogueInfo
ItemCategoryInfo
ItemCategoryStructInfo
ItemInfo
ItemTemplateDetailInfo
ItemTemplateInfo
LocaleInfo
LoginGroupInfo
MainPagePatternInfo
MenuInclusionInfo
MenuInfo
MenuTreeInfo
PasswordHistoryInfo
PasswordHistoryResultInfo
PlainPostDetailInfo
PostDetailInfo
PostInfo
PrivateGroupAttachInfo
PrivateGroupInfo
PublicGroupAttachInfo
PublicGroupCategoryInfo
PublicGroupDetailInfo
PublicGroupInfo
PublicGroupSetDetailInfo
PublicGroupStructInfo
PublicGroupVersionInfo
ResultInfo
RoleDealPermissionInfo
RoleInfo
SessionConfigInfo
SessionInfo
ShortCutInfo
SuperUserInfo
SystemMenuInfo
TermInfo
TermResultInfo
UserInfo

DataForAccount 非推奨
DataForDatabase 非推奨
DataForRole 非推奨
DataForStoredProc 非推奨
DbResultObject 非推奨


 JsTestSuite オブジェクト

im-JsUnitのテストスイートオブジェクト。
JavaScriptのユニットテスト環境でテストケースを集約するオブジェクトです。

テストスイートは、defineTestSuite関数内で使用します。
 function defineTestSuite() {

     var suite = new JsTestSuite("テストの集まり");
     suite.addTest("１つ目のテストです。","test2");
     suite.addTest("２つ目のテストです。","test3");
     suite.addTest("３つ目のテストです。","test_suite2");
     return suite;
 }
コンストラクタの概要
JsTestSuite (String comment)
コンストラクタ。
メソッドの概要
void addTest ([String comment] ,Object test)
テストを追加します。
コンストラクタの詳細
JsTestSuite

JsTestSuite (String comment)
コンストラクタ。

パラメータ
comment String コメント
メソッドの詳細
addTest

void addTest ([String comment] ,Object test)

テストを追加します。
パラメータ
comment | String | テストのコメント
test | Object | テストパスまたはJsTestSuit
返却値
void


 JsUnit オブジェクト

im-JsUnit オブジェクト。 JavaScriptのユニットテスト環境を提供するオブジェクトです。
メソッドの概要
static void | assert ([String comment] ,Boolean value) 評価値がTrueであることをチェックします。
static void | assertEquals ([String comment] ,Object value1 ,Object value2) 評価値と期待値が同じであることをチェックします。
static void | assertFalse ([String comment] ,Boolean value) 評価値がFalseであることをチェックします。
static void | assertNaN ([String comment] ,Number value) 評価値がNaNであることをチェックします。
static void | assertNotEquals ([String comment] ,Object value1 ,Object value2) 評価値と期待値が同じでないことをチェックします。
static void | assertNotNaN ([String comment] ,Number value) 評価値がNaNでないことをチェックします。
static void | assertNotNull ([String comment] ,Object value) 評価値がNullでないことをチェックします。
static void | assertNotUndefined ([String comment] ,Object value) 評価値がUndefinedでないことをチェックします。
static void | assertNull ([String comment] ,Object value) 評価値がNullであることをチェックします。
static void | assertTrue ([String comment] ,Boolean value) 評価値がTrueであることをチェックします。
static void | assertUndefined ([String comment] ,Object value) 評価値がUndefinedであることをチェックします。
static String | execute (String src [,String xsl]) テストを実行します。
static Object | loadScriptModule (String src) JavaScriptのモジュールを取得します。
メソッドの詳細
assert

static void assert ([String comment] ,Boolean value)

評価値がTrueであることをチェックします。

パラメータ
comment | String | テストのコメント
value | Boolean | 評価値
返却値
void
assertEquals

static void assertEquals ([String comment] ,Object value1 ,Object value2)

評価値と期待値が同じであることをチェックします。

パラメータ
comment | String | テストのコメント
value1 | Object | 期待値
value2 | Object | 評価値
返却値
void
assertFalse

static void assertFalse ([String comment] ,Boolean value)

評価値がFalseであることをチェックします。

パラメータ
comment | String | テストのコメント
value | Boolean | 評価値
返却値
void
assertNaN

static void assertNaN ([String comment] ,Number value)

評価値がNaNであることをチェックします。

パラメータ
comment | String | テストのコメント
value | Number | 評価値
返却値
void
assertNotEquals

static void assertNotEquals ([String comment] ,Object value1 ,Object value2)

評価値と期待値が同じでないことをチェックします。

パラメータ
comment | String | テストのコメント
value1 | Object | 期待値
value2 | Object | 評価値
返却値
void
assertNotNaN

static void assertNotNaN ([String comment] ,Number value)

評価値がNaNでないことをチェックします。

パラメータ
comment | String | テストのコメント
value | Number | 評価値
返却値
void
assertNotNull

static void assertNotNull ([String comment] ,Object value)

評価値がNullでないことをチェックします。

パラメータ
comment | String | テストのコメント
value | Object | 評価値
返却値
void
assertNotUndefined

static void assertNotUndefined ([String comment] ,Object value)

評価値がUndefinedでないことをチェックします。

パラメータ
comment | String | テストのコメント
value | Object | 評価値
返却値
void
assertNull

static void assertNull ([String comment] ,Object value)

評価値がNullであることをチェックします。

パラメータ
comment | String | テストのコメント
value | Object | 評価値
返却値
void
assertTrue

static void assertTrue ([String comment] ,Boolean value)

評価値がTrueであることをチェックします。

パラメータ
comment | String | テストのコメント
value | Boolean | 評価値
返却値
void
assertUndefined

static void assertUndefined ([String comment] ,Object value)

評価値がUndefinedであることをチェックします。

パラメータ
comment | String | テストのコメント
value | Object | 評価値
返却値
void
execute

static String execute (String src [,String xsl])

テストを実行します。

テストファイルの実行に失敗した場合（ファイルが存在しない場合など）は、nullを返却します。

引数のソースパスには、テストケースを記述したファイルのパスを指定します。
拡張子(jssp)は付けません。

例 system/test.jsを指定する場合
system/test
パラメータ
src | String | ソースパス
xsl | String | xslスタイルシートパス
返却値
String テスト結果情報(xml)
loadScriptModule

static Object loadScriptModule (String src)

JavaScriptのモジュールを取得します。
取得したモジュールより各関数を実行することが可能です。
テスト対象のモジュールを取得する場合に用います。

取得に失敗した場合は、nullを返却します。

引数のソースパスには、テスト対象のファイルのパスを指定します。
拡張子(jssp)は付けません。

例 system/source.jsを指定する場合
system/source
パラメータ
src String ソースパス
返却値
Object JSファイルのオブジェクト


 LicenseManager オブジェクト

ライセンスマネージャクラス。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
LicenseManager (String groupId)
コンストラクタ。
メソッドの概要
boolean | deleteAccountLicense (String userId) 指定されたユーザのライセンスを削除する。
boolean | deleteApplicationLicenseFromAccount (String userId ,String applicationId) アプリケーションライセンスをアカウントから削除する。
static ApplicationInfo | getApplication (String applicaionId) アプリケーション情報を取得します。
static Number | getApplicationLicense (String applicaionId) アプリケーションの登録ユーザ数を取得します。
static Array | getApplications () アプリケーション情報の一覧を取得する。
Number | getLicense () グループ内で登録されているライセンス数を取得する。
Number | getMaxLicense () ログイングループ内の最大登録可能ライセンス数を取得します。
static ApplicationInfo | getProduct () システム情報を取得します。
Array | getRegisteredAccountLicenses () ログイングループにライセンス登録されているすべてのユーザIDを返します。
Array | getRegisteredApplicationLicensesToAccount (String userId) アカウントに登録されているアプリケーションライセンスの一覧を取得する。
static Number | getSystemLicense () システム全体の登録ライセンス数。
static Number | getSystemMaxLicense () システム全体のライセンス数。
Boolean | isRegisteredAccountLicense (String userId) 指定されたユーザがライセンスに登録されているかどうかをチェックします。
Boolean | isRegisteredApplicationLicenseToAccount (String userId ,String applicationId) アカウントにアプリケーションライセンスが登録されてるか検証する。
Boolean | registerAccountLicense (String userId) ライセンス登録する。
Boolean | registerApplicationLicenseToAccount (String userId ,String applicationId) アプリケーションライセンスをアカウントに登録する。
Boolean | setMaxLicense (Number maxLicense) ログイングループ内の最大登録可能ライセンス数を設定します。
コンストラクタの詳細
LicenseManager

LicenseManager (String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
deleteAccountLicense

boolean deleteAccountLicense (String userId)

指定されたユーザのライセンスを削除する。

パラメータ
userId String ユーザID
返却値
boolean true：処理成功 / false：処理失敗（ログを参照してください）
deleteApplicationLicenseFromAccount

boolean deleteApplicationLicenseFromAccount (String userId ,String applicationId)

アプリケーションライセンスをアカウントから削除する。

パラメータ
userId | String | ユーザID
applicationId | String | アプリケーションID
返却値
boolean true：処理成功 / false：処理失敗（ログを参照してください）
getApplication

static ApplicationInfo getApplication (String applicaionId)

アプリケーション情報を取得します。

引数に指定されたアプリケーションの情報を取得します。

パラメータ
applicaionId String アプリケーションID
返却値
ApplicationInfo アプリケーション情報
指定したアプリケーションが存在しない場合はnull
getApplicationLicense

static Number getApplicationLicense (String applicaionId)

アプリケーションの登録ユーザ数を取得します。

引数に指定されたアプリケーションIDを持つユーザの数を取得します。

パラメータ
applicaionId String アプリケーションID
返却値
Number アプリケーションIDを持つユーザの数
指定したアプリケーションが存在しない場合は0
getApplications

static Array getApplications ()

アプリケーション情報の一覧を取得する。

取得に失敗した場合は、nullを返却します。
返却値
Array ApplicationInfoの配列
getLicense

Number getLicense ()

グループ内で登録されているライセンス数を取得する。

取得に失敗した場合は、-1を返却します。
返却値
Number 登録ライセンス数
getMaxLicense

Number getMaxLicense ()

ログイングループ内の最大登録可能ライセンス数を取得します。

無制限の場合は Number.POSITIVE_INFINITY を返します。
取得に失敗した場合は、-1を返却します。

返却値
Number 最大登録可能ライセンス数
getProduct

static ApplicationInfo getProduct ()

システム情報を取得します。

返却値
ApplicationInfo システム情報
システム情報の取得に失敗した場合はnull
getRegisteredAccountLicenses

Array getRegisteredAccountLicenses ()

ログイングループにライセンス登録されているすべてのユーザIDを返します。

返却値
Array ユーザIDの配列
getRegisteredApplicationLicensesToAccount

Array getRegisteredApplicationLicensesToAccount (String userId)

アカウントに登録されているアプリケーションライセンスの一覧を取得する。

取得に失敗した場合は、nullを返却します。
パラメータ
userId String ユーザID
返却値
Array アカウントに登録されているアプリケーションライセンス(ID)の配列
getSystemLicense

static Number getSystemLicense ()

システム全体の登録ライセンス数。

取得に失敗した場合は、-1を返却します。
返却値
Number システム全体の登録ライセンス数
getSystemMaxLicense

static Number getSystemMaxLicense ()

システム全体のライセンス数。

無制限の場合は Number.POSITIVE_INFINITY を返します。

取得に失敗した場合は、-1を返却します。

返却値
Number システム全体のライセンス数
isRegisteredAccountLicense

Boolean isRegisteredAccountLicense (String userId)

指定されたユーザがライセンスに登録されているかどうかをチェックします。

パラメータ
userId String ユーザID
返却値
Boolean true : 登録されている / false : 登録されていない
isRegisteredApplicationLicenseToAccount

Boolean isRegisteredApplicationLicenseToAccount (String userId ,String applicationId)

アカウントにアプリケーションライセンスが登録されてるか検証する。

パラメータ
userId | String | ユーザID
applicationId | String | アプリケーションID
返却値
Boolean true : 登録されている / false : 登録されていない
registerAccountLicense

Boolean registerAccountLicense (String userId)

ライセンス登録する。

指定されたユーザIDとコンストラクタで指定したログイングループIDでライセンス登録をします。
最大登録可能ライセンス数とログイングループ内最大登録可能ライセンス数を調査して
これを超えた場合はエラーとする。

パラメータ
userId String ユーザID
返却値
Boolean true：成功 / false：失敗
registerApplicationLicenseToAccount

Boolean registerApplicationLicenseToAccount (String userId ,String applicationId)

アプリケーションライセンスをアカウントに登録する。

すでに登録されているアプリケーション最大登録可能ライセンス数と合わせて
最大登録可能ライセンス数を超えた場合はエラーとする。

パラメータ
userId | String | ユーザID
applicationId | String | アプリケーションID
返却値
Boolean true：成功 / false：失敗
setMaxLicense

Boolean setMaxLicense (Number maxLicense)

ログイングループ内の最大登録可能ライセンス数を設定します。

すでに登録されているログイングループ内最大登録可能ライセンス数の合計と合わせて
最大登録可能ライセンス数を超えた場合はエラーとする。

パラメータ
maxLicense Number 最大登録可能ライセンス数
返却値
Boolean true：成功 / false：失敗


 LocaleInfo オブジェクト

ロケール情報オブジェクト。

ロケール情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | displayName ロケール表示名。 | 読込み専用
String | encoding エンコーディング。 | 読込み専用
Array | encodings 対応エンコーディング配列。 | 読込み専用
String | encodings[0..*] 対応エンコーディング。 | 読込み専用
String | locale ロケール。 | 読込み専用
プロパティの詳細
displayName

String displayName (読込み専用プロパティ)

ロケール表示名。
encoding

String encoding (読込み専用プロパティ)

エンコーディング。
このロケールに対応したデフォルトのエンコーディングです。
encodings

Array encodings (読込み専用プロパティ)

対応エンコーディング配列。
encodings[0..*]

String encodings[0..*] (読込み専用プロパティ)

対応エンコーディング。
このロケールに対応したエンコーディングの一覧です。
locale

String locale (読込み専用プロパティ)

ロケール。


 Lock オブジェクト

アプリケーション・ロック管理オブジェクト。

アプリケーション・ロックの制御を行うオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
static Boolean | begin (String name [,Number timeout]) アプリケーションロックを開始します。
static Boolean | beginRequestScope (String name [,Number timeout]) アプリケーションロックを開始します。
static Boolean | end (String name) アプリケーションロックを開放します。
static Boolean | isLocked (String name) アプリケーションロックが開始されているかどうか判定します。
メソッドの詳細
begin

static Boolean begin (String name [,Number timeout])

アプリケーションロックを開始します。

指定のカテゴリキーワードにてロックを開始します。
第２引数 timeout を設定することで、他のプロセスによって ロック中であった場合のロックの開放待ちまでの時間を指定可能です。
引数の指定は自然数で、単位は秒です。
第２引数 timeout を省略した場合、または 0(ゼロ)を指定した場合、 このメソッドが実行された時に、他のプロセスによってロック中で あった場合、このカテゴリキーワードで指定されるロックが開放される まで永久的に待機状態になります。
このメソッドでロックが開始されると、ロックのセッションが同時に 開始され設定されているタイムアウト([install_directory]/conf/imart.xml で設定)の期間をセッション保持されます。
このメソッドが実行されてからセッションタイムアウトの期間中に end() メソッドにてロックの開放が行われなかった場合、自動的に ロックが開放されます。
パラメータ
name | String | 開始するロックカテゴリキーワード
timeout | Number | ロック開始までの待ち時間
返却値
Boolean true : ロック開始成功 / false : ロック開始失敗
beginRequestScope

static Boolean beginRequestScope (String name [,Number timeout])

アプリケーションロックを開始します。

このメソッドは、begin()と同様の機能を提供しますが、 現在のリクエストが終了する際（＝レスポンスを返却する際）に、ロックの解除が自動的に行われる点が異なります。
自動的なロックの解除は、jp.co.intra_mart.system.servlet.filter.RequestScopeLockReleaseFilter にて行われます。
パラメータ
name | String | 開始するロックカテゴリキーワード
timeout | Number | ロック開始までの待ち時間（単位は秒）
返却値
Boolean true : ロック開始成功 / false : ロック開始失敗
導入されたバージョン：6.1.7
end

static Boolean end (String name)

アプリケーションロックを開放します。

指定のカテゴリキーワードにてロックの開放処理をします。
指定のカテゴリキーワードがロック中である場合も、ロック中でない 場合もロック開放処理を行います。
パラメータ
name String ロックカテゴリキーワード
返却値
Boolean true : ロック解放成功 / false : ロック解放失敗
isLocked

static Boolean isLocked (String name)

アプリケーションロックが開始されているかどうか判定します。

指定のカテゴリキーワードがロック中であるかどうかをチェックします。
パラメータ
name String ロックカテゴリキーワード
返却値
Boolean true : ロック中 / false : 未ロック


 LoginGroupInfo オブジェクト

ログイングループ情報オブジェクト。

ログイングループ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | colorPatternId カラーパターンID。 | 通常
String | encoding エンコーディング。 | 通常
String | id [必須]ログイングループID。 | 通常
String | locale ロケール。 | 通常
Number | lockCount アカウントロックを行うログイン失敗回数。 | 通常
Number | lockTerm アカウントをロックする期間。 | 通常
プロパティの詳細
colorPatternId

String colorPatternId

カラーパターンID。
ログイングループでのデフォルトのカラーパターンIDです。
このログイイングループに属するアカウントにこの設定がされていない場合に、アカウントのカラーパターンIDとして使用されます。
encoding

String encoding

エンコーディング。
ログイングループでのデフォルトのエンコーディングです。
このログイイングループに属するアカウントにこの設定がされていない場合に、アカウントのエンコーディングとして使用されます。
id

String id

[必須]ログイングループID。
locale

String locale

ロケール。
ログイングループでのデフォルトのロケールです。
このログイイングループに属するアカウントにこの設定がされていない場合に、アカウントのロケールとして使用されます。
lockCount

Number lockCount

アカウントロックを行うログイン失敗回数。
0が設定された場合はアカウントロックを行ないません。
lockTerm

Number lockTerm

アカウントをロックする期間。
アカウントがロックされた場合の、ロック解除までの時間を分単位で設定します。
0が設定された場合は、自動的にアカウントロックは解除されません。


 LoginGroupManager オブジェクト

ログイングループマネージャオブジェクト。

ログイングループ情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static Boolean | addLoginGroup (LoginGroupInfo loginGroup) ログイングループを新規追加します。
static Boolean | addMainPagePattern (String groupId ,MainPagePatternInfo mainPagePattern) メインページパターンを新規追加します。
static Boolean | addSuperUser (String groupId ,SuperUserInfo superUser) グループ管理者情報を作成します。
static Number | countLoginGroup () ログイングループ数を取得します。
static Boolean | deleteLoginGroup (String groupId) ログイングループを削除します。
static Boolean | deleteMainPagePattern (String groupId ,String mainPagePatternId) メインページパターンを削除します。
static Boolean | deleteMainPagePatterns (String groupId) メインページパターンをすべて削除します。
static Boolean | deleteSuperUser (String groupId) グループ管理者情報を削除します。
static LoginGroupInfo | getLoginGroup (String groupId) ログイングループを取得します。
static Array | getLoginGroupIds () ログイングループIDの一覧を取得します。
static Array | getLoginGroups () ログイングループの一覧を取得します。
static MainPagePatternInfo | getMainPagePattern (String groupId ,String mainPagePatternId) メインページパターンを取得します。
static Array | getMainPagePatternIds (String groupId) メインページパターンIDの一覧を取得します。
static Array | getMainPagePatterns (String groupId) メインページパターンの一覧を取得します。
static SuperUserInfo | getSuperUser (String groupId) グループ管理者情報を取得します。
static Boolean | updateLoginGroup (LoginGroupInfo loginGroup) ログイングループを更新します。
static Boolean | updateMainPagePattern (String groupId ,MainPagePatternInfo mainPagePattern) メインページパターンを更新します。
static Boolean | updateSuperUser (String groupId ,SuperUserInfo superUser) グループ管理者情報を更新します。
メソッドの詳細
addLoginGroup

static Boolean addLoginGroup (LoginGroupInfo loginGroup)

ログイングループを新規追加します。

パラメータ
loginGroup LoginGroupInfo ログイングループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMainPagePattern

static Boolean addMainPagePattern (String groupId ,MainPagePatternInfo mainPagePattern)

メインページパターンを新規追加します。

パラメータ
groupId String ログイングループID
mainPagePattern MainPagePatternInfo メインページパターン情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addSuperUser

static Boolean addSuperUser (String groupId ,SuperUserInfo superUser)

グループ管理者情報を作成します。

パラメータ
groupId | String | ログイングループのグループID
superUser | SuperUserInfo | グループ管理者オブジェクト
返却値
Boolean true : 成功 / false : 失敗
countLoginGroup

static Number countLoginGroup ()

ログイングループ数を取得します。

返却値
Number 登録ログイングループ数
取得に失敗した場合は（-1）が返却されます。
deleteLoginGroup

static Boolean deleteLoginGroup (String groupId)

ログイングループを削除します。

パラメータ
groupId String 削除するログイングループのグループID
返却値
Boolean true : 成功 / false : 失敗
deleteMainPagePattern

static Boolean deleteMainPagePattern (String groupId ,String mainPagePatternId)

メインページパターンを削除します。

パラメータ
groupId | String | ログイングループID
mainPagePatternId | String | メインページパターンID
返却値
Boolean true : 成功 / false : 失敗
deleteMainPagePatterns

static Boolean deleteMainPagePatterns (String groupId)

メインページパターンをすべて削除します。

パラメータ
groupId String ログイングループID
返却値
Boolean true : 成功 / false : 失敗
deleteSuperUser

static Boolean deleteSuperUser (String groupId)

グループ管理者情報を削除します。

パラメータ
groupId String ログイングループID
返却値
Boolean true : 成功 / false : 失敗
getLoginGroup

static LoginGroupInfo getLoginGroup (String groupId)

ログイングループを取得します。

存在しなかった場合および取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
LoginGroupInfo ログイングループオブジェクト
getLoginGroupIds

static Array getLoginGroupIds ()

ログイングループIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ログイングループIDの配列
getLoginGroups

static Array getLoginGroups ()

ログイングループの一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ログイングループ情報オブジェクトの配列
getMainPagePattern

static MainPagePatternInfo getMainPagePattern (String groupId ,String mainPagePatternId)

メインページパターンを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId | String | ログイングループID
mainPagePatternId | String | メインページパターンID
返却値
MainPagePatternInfo メインページパターン情報オブジェクト
getMainPagePatternIds

static Array getMainPagePatternIds (String groupId)

メインページパターンIDの一覧を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
Array メインページパターンIDの配列
getMainPagePatterns

static Array getMainPagePatterns (String groupId)

メインページパターンの一覧を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループID
返却値
Array メインページパターン情報オブジェクトの配列
getSuperUser

static SuperUserInfo getSuperUser (String groupId)

グループ管理者情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
groupId String ログイングループのグループID
返却値
SuperUserInfo グループ管理者オブジェクト
updateLoginGroup

static Boolean updateLoginGroup (LoginGroupInfo loginGroup)

ログイングループを更新します。

パラメータ
loginGroup LoginGroupInfo ログイングループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateMainPagePattern

static Boolean updateMainPagePattern (String groupId ,MainPagePatternInfo mainPagePattern)

メインページパターンを更新します。

パラメータ
groupId | String | ログイングループID
mainPagePattern | MainPagePatternInfo | メインページパターン情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateSuperUser

static Boolean updateSuperUser (String groupId ,SuperUserInfo superUser)

グループ管理者情報を更新します。

パラメータ
groupId | String | ログイングループのグループID
superUser | SuperUserInfo | グループ管理者オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 LogConstraint オブジェクト

ログ用定数オブジェクト。
バージョン：1.0
導入されたバージョン：6.1
定数の概要
static String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE
遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。
定数の詳細
RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE

static String RESPONSE_HEADER_NAME_NEXT_PAGE_TITLE

遷移先画面タイトルをレスポンスヘッダに登録するためのレスポンスヘッダ名。
定数値 ： "x-jp-co-intra-mart-log-next-page-title"


 Mail オブジェクト

推奨されていません。MailSenderに置き換えられました。
メール送信オブジェクト。

メール送信を行うオブジェクトです。
バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
Mail ([String smtpServer])
推奨されていません。MailSenderに置き換えられました。
メソッドの概要
Boolean | attachFile (String sName ,String sContents) 推奨されていません。MailSenderのメソッドに置き換えられました。
Number | getErrCode () 推奨されていません。MailSenderのメソッドに置き換えられました。
String | getErrMessage () 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | send () 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setAttachment (String rPath [,String fPath]) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setBcc (String bcc) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setBody (String body) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setCc (String cc) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setFrom (String from [,String name]) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setHeader (String key ,String value) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setReplyTo (String reply) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setSubject (String title) 推奨されていません。MailSenderのメソッドに置き換えられました。
Boolean | setTo (String to) 推奨されていません。MailSenderのメソッドに置き換えられました。
コンストラクタの詳細
Mail

Mail ([String smtpServer])
推奨されていません。MailSenderに置き換えられました。
コンストラクタ。

引数を省略した場合は [install_directory]/conf/imart.xml の <smtp-server> で指定した SMTPサーバに接続します。
パラメータ
smtpServer String SMTPサーバのアドレス
メソッドの詳細
attachFile

Boolean attachFile (String sName ,String sContents)

推奨されていません。MailSenderのメソッドに置き換えられました。
メールへファイルを添付します。

第二引数（sContents）には、(new VirtualFile(FILE_PATH)).load()メソッドなどで 取得したバイナリ形式の文字列や、Unicode.to(STRING)メソッドで変換された 文字列を指定します。
このメソッドを複数回実行することで、複数ファイルをメールに 添付することがきます。
パラメータ
sName | String | ファイル名称
sContents | String | ファイルの内容(バイナリ形式)
返却値
Boolean true : 成功 / false : 失敗
導入されたバージョン：2.0.2
getErrCode

Number getErrCode ()

推奨されていません。MailSenderのメソッドに置き換えられました。
メール送信時のエラーコートを取得します。

send()メソッド発行後の状態を調べるときに使います。

エラーコードの内容は以下のとおり。

1 ：メールサーバが設定されていません。
2 ：指定の メールサーバがダウンしているか、または存在しません。
3 ：メールの送信先が全て不正です。
4 ：送信者アドレスが不正です。
5 ：メールサーバに接続できませんでした。
その他はRFC821に準拠。
返却値
Number -1 :エラーコードの取得に失敗、またはシステムエラー
0 ：正常終了
1 - 5 ：エラー終了
その他
getErrMessage

String getErrMessage ()

推奨されていません。MailSenderのメソッドに置き換えられました。
メール送信時のエラーメッセージを取得取得します。

send()メソッド発行後の状態を調べるときに利用します。
返却値
String エラーメッセージ
send

Boolean send ()

推奨されていません。MailSenderのメソッドに置き換えられました。
指定されたSMTPサーバへメールを送信します。

他のメソッドで設定した情報をもとにメールを送信します。
最低限必要な設定は宛先と送信者。（setTo(),setFrom()メソッドで設定します。）
返却値
Boolean true : 送信成功 / false : 送信失敗
setAttachment

Boolean setAttachment (String rPath [,String fPath])

推奨されていません。MailSenderのメソッドに置き換えられました。
メールへファイルを添付します。

第二引数（ファイルへの絶対パス）が指定されている場合には、『ファイルへの絶対パス ＋ ファイル名称』で 表わされるファイルを対象します。
※操作対象のファイルはApplicationRuntimeまたはBatchService上のファイルになります。
このメソッドを複数回実行することで、複数ファイルをメールに 添付することがきます。
パラメータ
rPath String ファイル名(拡張子付き)
第2引数(fPath)を指定しない場合：システムルートからの相対パス + ファイル名。
第2引数(fPath)を指定した場合：ファイル名。
fPath String ファイルのルートからのパス
返却値
Boolean true : 成功 / false : 失敗
setBcc

Boolean setBcc (String bcc)

推奨されていません。MailSenderのメソッドに置き換えられました。
bccを設定します。

このメソッドを複数回実行することで、複数bccをメールに設定することがきます。
パラメータ
bcc String bccに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗
setBody

Boolean setBody (String body)

推奨されていません。MailSenderのメソッドに置き換えられました。
メール本文を設定します。

パラメータ
body String メール本文
返却値
Boolean true : 成功 / false : 失敗
setCc

Boolean setCc (String cc)

推奨されていません。MailSenderのメソッドに置き換えられました。
ccを設定します。

このメソッドを複数回実行することで、複数ccをメールに設定することがきます。
パラメータ
cc String ccに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗
setFrom

Boolean setFrom (String from [,String name])

推奨されていません。MailSenderのメソッドに置き換えられました。
fromを設定します。

パラメータ
from | String | fromにセットするメールアドレス
name | String | fromのニックネーム
返却値
Boolean true : 成功 / false : 失敗
setHeader

Boolean setHeader (String key ,String value)

推奨されていません。MailSenderのメソッドに置き換えられました。
メールヘッダを設定します。

送信するメールヘッダ情報を設定します。
設定可能なメールヘッダの種類は以下の通り。
Sender : 送った人のメールアドレス
Reply-To: 返信先メールアドレス
(その他にも任意にヘッダ情報を追加できますが、任意のヘッダを追加した場合の動作は 未検証です。)
パラメータ
key | String | 設定するメールヘッダの種類
value | String | メールヘッダへの情報
返却値
Boolean true : 成功 / false : 失敗
setReplyTo

Boolean setReplyTo (String reply)

推奨されていません。MailSenderのメソッドに置き換えられました。
reply-toを設定します。

このメソッドを複数回実行することで、複数reply-toをメールに セットすることがきます。
パラメータ
reply String reply-toに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗
setSubject

Boolean setSubject (String title)

推奨されていません。MailSenderのメソッドに置き換えられました。
メールのタイトルを設定します。

パラメータ
title String メールのタイトル
返却値
Boolean true : 成功 / false : 失敗
setTo

Boolean setTo (String to)

推奨されていません。MailSenderのメソッドに置き換えられました。
toを設定します。

このメソッドを複数回実行することで、複数toをメールに セットすることがきます。
パラメータ
to String toに設定するメールアドレス
返却値
Boolean true : 成功 / false : 失敗


 MailSender オブジェクト

メールを送信するオブジェクトです。

  • キャラクターセット、エンコード
    このオブジェクトが保持するメールのキャラクターセット、エンコディングの設定は ロケールに依存します。ロケール毎の設定は定義ファイルをにより決定されます。
    ServerManager上に /conf/mail/encode.properties として、定義ファイルを配置してください。

    指定可能なキーの一覧
    charset | キャラクターセット
    mimeEncoding | MIMEエンコード (B or Q)
    contentTransferEncoding | ボディのエンコード

  • SMTP Authentication
    MailSenderオブジェクトは SMTP Authentication に対応しています。有効にする場合は ServerManager 上の /conf/mail/smtpAuth.properties を編集してください。

    enable SMTP Authの有効
    (true or false)
    user | ユーザID
    password | パスワード

  • メール送信リスナ
    MailSenderオブジェクトはリスナを実装することで、メール送信前に任意の処理を実行することが可能です。
    リスナでは送信メールの情報を参照したり、送信を中止することも可能です。

    リスナはJavaのクラスを実装する必要があります。 詳しい実装方法はMailSendListenerインタフェースを参照してください。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
MailSender (String locale)
コンストラクタ
メソッドの概要
void | addAttachment (String filename ,String file) 添付ファイルを追加します。
void | addBcc (String address ,String personal) Bccを追加します。
void | addCc (String address ,String personal) Ccを追加します。
void | addHeader (String name ,String value) メールヘッダーを追加します。
void | addReplyTo (String replyto) ReplyToを追加します。
void | addTo (String address ,String personal) Toを追加します。
String | getErrorMessage () メール送信エラー時のメッセージを返します。
Boolean | send () メールを送信します。
void | setFrom (String address ,String personal) Fromを設定します。
void | setSubject (String subject) Subjectを設定します。
void | setText (String text) 本文を設定します。
コンストラクタの詳細
MailSender

MailSender (String locale)
コンストラクタ
パラメータ
locale String ロケール名
メソッドの詳細
addAttachment

void addAttachment (String filename ,String file)

添付ファイルを追加します。
パラメータ
filename | String | 添付ファイル名
file | String | ファイルの内容
返却値
void
addBcc

void addBcc (String address ,String personal)

Bccを追加します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
addCc

void addCc (String address ,String personal)

Ccを追加します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
addHeader

void addHeader (String name ,String value)

メールヘッダーを追加します。
パラメータ
name | String | ヘッダーの名前
value | String | ヘッダーの値
返却値
void
addReplyTo

void addReplyTo (String replyto)

ReplyToを追加します。
パラメータ
replyto String ReplyToに追加するメールアドレス
返却値
void
addTo

void addTo (String address ,String personal)

Toを追加します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
getErrorMessage

String getErrorMessage ()

メール送信エラー時のメッセージを返します。
返却値
String 送信エラーのメッセージ
send

Boolean send ()

メールを送信します。
返却値
Boolean true 送信成功 / false 送信失敗
setFrom

void setFrom (String address ,String personal)

Fromを設定します。
パラメータ
address | String | メールアドレス
personal | String | 名前
返却値
void
setSubject

void setSubject (String subject)

Subjectを設定します。
パラメータ
subject String Subject
返却値
void
setText

void setText (String text)

本文を設定します。
パラメータ
text String 本文
返却値
void


 MainPagePatternInfo オブジェクト

メインページパターン情報オブジェクト。

メインページパターン情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | id メインページパターンID。 | 通常
String | imageUrl メインページパターンイメージURL。 | 通常
String | url メインページパターンURL。 | 通常
プロパティの詳細
id

String id

メインページパターンID。
imageUrl

String imageUrl

メインページパターンイメージURL。
コンテキストパスからの相対でパスで指定します。
先頭は'/'から始めます。
url

String url

メインページパターンURL。
コンテキストパスまたはpagesからの相対でパスで指定します。
先頭は'/'から始めます。


 MenuInclusionInfo オブジェクト

メニュー内包情報オブジェクト。
メニューの親子関係を表す情報オブジェクトです。

メニュー内包情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.parentMenuId  = "parentId";
   obj.childMenuId  = "childId";
オブジェクト作成方法(JSON方式)
   {
     "parentMenuId "  : "parentId",
     "childMenuId"    : "childId"
   }

プロパティの概要
String | childMenuId 子メニューID。 | 通常
String | parentMenuId 親メニューID。 | 通常
プロパティの詳細
childMenuId

String childMenuId

子メニューID。
parentMenuId

String parentMenuId

親メニューID。


 MenuInfo オブジェクト

メニュー情報オブジェクト。

メニュー情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.type = AdminMenuManager.MENU_TYPE_ITEM;
   obj.description = "";
   obj.clientType = "pc";
   obj.contents = AdminMenuManager.CONTENT_TYPE_IN;
   obj.url = "sample.jssp";
   obj.argument = new Object();
   obj.argument.arg1 = "sample1";
   obj.argument.arg2 = "sample2";
   obj.id = "menuId1";
   obj.displayName = new Object();
   obj.displayName["ja"] = "メニュー１";
   obj.displayName["en"] = "Menu1";
   obj.imagePath = "";
   obj.sortNumber = 0;
オブジェクト作成方法(JSON方式)
    {
      "type" :  AdminMenuManager.MENU_TYPE_ITEM,
      "description"  : "",
      "clientType"  : "pc",
      "contents"  : dminMenuManager.CONTENT_TYPE_IN,
      "url"  : "sample.jssp",
      "argument"  : {
          "arg1" : "sample1",
          "arg2" : "sample2"
        },
      "id"  : "menuId1",
      "displayName" : {
          "ja" : "メニュー１",
          "en" : "Menu1"
        },
      "imagePath"  : "",
      "sortNumber"  : 0
    }

プロパティの概要
Object | argument 引数。 | 通常
String | clientType クライアントタイプ。 | 通常
String | contents コンテンツの種類。 | 通常
String | description 説明。 | 通常
Object | displayNamedisplayName 国際化情報。 | 通常
String | displayNamedisplayName[ロケール] メニュー名。 | 通常
String | id メニューID。 | 通常
String | imagePath メニューイメージパス。 | 通常
Number | sortNumber ソート番号。 | 通常
String | type ノードタイプ。 | 通常
String | url URL。 | 通常
プロパティの詳細
argument

Object argument

引数。

argument.パラメータキーでパラメータの値を取得できます。
clientType

String clientType

クライアントタイプ。
contents

String contents

コンテンツの種類。

AdminMenuManager.CONTENT_TYPE_IN： 内部URL
AdminMenuManager.CONTENT_TYPE_OUT：外部URL
description

String description

説明。
displayNamedisplayName

Object displayNamedisplayName

国際化情報。
displayNamedisplayName[ロケール]

String displayNamedisplayName[ロケール]

メニュー名。
id

String id

メニューID。
imagePath

String imagePath

メニューイメージパス。

メニューのアイコンイメージパスを指定します。
sortNumber

Number sortNumber

ソート番号。
type

String type

ノードタイプ。

AdminMenuManager.MENU_TYPE_FOLDER：フォルダ
AdminMenuManager.MENU_TYPE_ITEM ：アイテム
url

String url

URL。


 MenuManager オブジェクト

メニューマネージャオブジェクト。

メニュー・モデルの参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | CONTENT_TYPE_IN メニューコンテンツの種類（内部URL）。
static String | CONTENT_TYPE_OUT メニューコンテンツの種類（外部URL）。
static String | MENU_TYPE_FOLDER メニュータイプ（フォルダ）。
static String | MENU_TYPE_ITEM メニュータイプ（アイテム）。
コンストラクタの概要
MenuManager (String groupId)
JSコンストラクタ。
メソッドの概要
Boolean | addMenuDepartment (String menuId ,DepartmentInfo object) 組織情報を新規追加します。
Boolean | addMenuItem (String parentMenuId ,MenuInfo object) メニューを新規追加します。
Boolean | addMenuPost (String menuId ,PostInfo object) 役職情報を新規追加します。
Boolean | addMenuPublicGroup (String menuId ,PublicGroupInfo object) メニューパブリックグループを新規追加します。
Boolean | addMenuRole (String menuId ,String roleId) メニューロールを新規追加します。
Boolean | deleteMenuDepartment (String menuId ,DepartmentInfo object) 指定した組織情報を削除します。
Boolean | deleteMenuDepartments (String menuId) 組織情報を削除します。
Boolean | deleteMenuItem (String menuId) 指定したメニューを削除します。
Boolean | deleteMenuItems () メニューを削除します。
Boolean | deleteMenuPost (String menuId ,PostInfo object) 役職情報を削除します。
Boolean | deleteMenuPosts (String menuId) 役職情報をすべて削除します。
Boolean | deleteMenuPublicGroup (String menuId ,PublicGroupInfo object) 指定したメニューパブリックグループを削除します。
Boolean | deleteMenuPublicGroups (String menuId) メニューパブリックグループを削除します。
Boolean | deleteMenuRole (String menuId ,String roleId) 指定したメニューロールを削除します。
Boolean | deleteMenuRoles (String menuId) メニューロールを削除します。
String | exportData (String category) メニューのエクスポートを行います。
Array | getAccountMenuTree (String userId ,String clientType) 指定されたユーザIDおよび指定されたクライアントタイプのみのメニュー構成を取得します。
Array | getChildMenuIds (String menuId) 子メニューIDを取得します。
Array | getExportCategories () メニューエクスポート用のカテゴリの一覧を取得します。
Array | getFirstMenuIds () メニューのルート（第一階層）に設定されてるメニューIDをすべて取得します。
Array | getImportCategories () メニューインポート用のカテゴリの一覧を取得します。
String | getLoginGroupId () ログイングループIDを取得します。
Array | getMenuDepartments (String menuId) 組織情報をすべて取得します。
Array | getMenuIds () すべてのメニューIDを取得します。
Array | getMenuIdsByDepartment (Array departments) 指定された組織を持つメニューIDをすべて取得します。
Array | getMenuIdsByPost (Array posts) 指定された役職を持つメニューIDをすべて取得します。
Array | getMenuIdsByPublicGroup (Array publicGroups) 指定されたパブリックグループを持つメニューIDをすべて取得します。
Array | getMenuIdsByRole (Array roleIds) 指定されたロールIDを持つメニューIDをすべて取得します。
MenuInfo | getMenuItem (String menuId) 指定されたメニューIDに対応するメニューを取得します。
Array | getMenuItems () すべてのメニューを取得します。
Array | getMenuItemsByIds (Array userIds) 引数のメニューIDのメニューをすべて取得します。
Array | getMenuPosts (String menuId) 役職情報を取得します。
Array | getMenuPublicGroups (String menuId) パブリックグループ情報を取得します。
Array | getMenuRoles (String menuId) メニューロールを取得します。
Array | getMenuTree () メニュー構成を取得します。
String | getParentMenuId (String menuId) 指定されたメニューの親メニューを取得します。
Boolean | importData (String category ,String inputString) メニューのインポートを行います。
boolean | isUpdate (Date date) メニュー情報が指定された日付よりも後に更新されたかチェックします。
Boolean | moveMenuItem (MenuInclusionInfo object) メニューを移動します。
Boolean | updateMenuItem (MenuInfo object) メニューを更新します。
定数の詳細
CONTENT_TYPE_IN

static String CONTENT_TYPE_IN

メニューコンテンツの種類（内部URL）。
定数値 ： "in"
CONTENT_TYPE_OUT

static String CONTENT_TYPE_OUT

メニューコンテンツの種類（外部URL）。
定数値 ： "out"
MENU_TYPE_FOLDER

static String MENU_TYPE_FOLDER

メニュータイプ（フォルダ）。
定数値 ： "folder"
MENU_TYPE_ITEM

static String MENU_TYPE_ITEM

メニュータイプ（アイテム）。
定数値 ： "item"
コンストラクタの詳細
MenuManager

MenuManager (String groupId)
JSコンストラクタ。
パラメータ
groupId String ログイングループID
メソッドの詳細
addMenuDepartment

Boolean addMenuDepartment (String menuId ,DepartmentInfo object)

組織情報を新規追加します。
パラメータ
menuId | String | メニューID
object | DepartmentInfo | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuItem

Boolean addMenuItem (String parentMenuId ,MenuInfo object)

メニューを新規追加します。
パラメータ
parentMenuId | String | 親メニューID
object | MenuInfo | メニュー情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuPost

Boolean addMenuPost (String menuId ,PostInfo object)

役職情報を新規追加します。
パラメータ
menuId | String | メニューID
object | PostInfo | 役職情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuPublicGroup

Boolean addMenuPublicGroup (String menuId ,PublicGroupInfo object)

メニューパブリックグループを新規追加します。
パラメータ
menuId | String | メニューID
object | PublicGroupInfo | パブリックグループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addMenuRole

Boolean addMenuRole (String menuId ,String roleId)

メニューロールを新規追加します。
パラメータ
menuId | String | メニューID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuDepartment

Boolean deleteMenuDepartment (String menuId ,DepartmentInfo object)

指定した組織情報を削除します。
パラメータ
menuId | String | メニューID
object | DepartmentInfo | 組織情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuDepartments

Boolean deleteMenuDepartments (String menuId)

組織情報を削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItem

Boolean deleteMenuItem (String menuId)

指定したメニューを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuItems

Boolean deleteMenuItems ()

メニューを削除します。
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPost

Boolean deleteMenuPost (String menuId ,PostInfo object)

役職情報を削除します。
パラメータ
menuId | String | メニューID
object | PostInfo | 役職情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPosts

Boolean deleteMenuPosts (String menuId)

役職情報をすべて削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPublicGroup

Boolean deleteMenuPublicGroup (String menuId ,PublicGroupInfo object)

指定したメニューパブリックグループを削除します。
パラメータ
menuId | String | メニューID
object | PublicGroupInfo | パブリックグループ情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
deleteMenuPublicGroups

Boolean deleteMenuPublicGroups (String menuId)

メニューパブリックグループを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuRole

Boolean deleteMenuRole (String menuId ,String roleId)

指定したメニューロールを削除します。
パラメータ
menuId | String | メニューID
roleId | String | ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteMenuRoles

Boolean deleteMenuRoles (String menuId)

メニューロールを削除します。
パラメータ
menuId String メニューID
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData (String category)

メニューのエクスポートを行います。

パラメータ
category String カテゴリ名
返却値
String String 出力情報
エクスポートに失敗した場合は、nullを返却します。
getAccountMenuTree

Array getAccountMenuTree (String userId ,String clientType)

指定されたユーザIDおよび指定されたクライアントタイプのみのメニュー構成を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userId | String | ユーザID
clientType | String | クライアントタイプ
返却値
Array メニュー構成オブジェクトの配列
getChildMenuIds

Array getChildMenuIds (String menuId)

子メニューIDを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 子メニューIDの配列
getExportCategories

Array getExportCategories ()

メニューエクスポート用のカテゴリの一覧を取得します。

返却値
Array メニューエクスポート用カテゴリの一覧
メニューエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getFirstMenuIds

Array getFirstMenuIds ()

メニューのルート（第一階層）に設定されてるメニューIDをすべて取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューIDの配列
getImportCategories

Array getImportCategories ()

メニューインポート用のカテゴリの一覧を取得します。

返却値
Array メニューインポート用カテゴリの一覧
メニューインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getLoginGroupId

String getLoginGroupId ()

ログイングループIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String ログイングループID
getMenuDepartments

Array getMenuDepartments (String menuId)

組織情報をすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 組織情報オブジェクトの配列
getMenuIds

Array getMenuIds ()

すべてのメニューIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニューIDの配列
getMenuIdsByDepartment

Array getMenuIdsByDepartment (Array departments)

指定された組織を持つメニューIDをすべて取得します。
パラメータ
departments Array 組織情報オブジェクトの配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuIdsByPost

Array getMenuIdsByPost (Array posts)

指定された役職を持つメニューIDをすべて取得します。
パラメータ
posts Array 役職情報オブジェクトの配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuIdsByPublicGroup

Array getMenuIdsByPublicGroup (Array publicGroups)

指定されたパブリックグループを持つメニューIDをすべて取得します。
パラメータ
publicGroups Array パブリックグループ情報オブジェクトの配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuIdsByRole

Array getMenuIdsByRole (Array roleIds)

指定されたロールIDを持つメニューIDをすべて取得します。
パラメータ
roleIds Array ロールIDの配列
返却値
Array メニューIDの配列
すべて存在しない場合は、空文字列を返却します。
getMenuItem

MenuInfo getMenuItem (String menuId)

指定されたメニューIDに対応するメニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
MenuInfo メニュー情報オブジェクト
getMenuItems

Array getMenuItems ()

すべてのメニューを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニュー情報オブジェクトの配列
getMenuItemsByIds

Array getMenuItemsByIds (Array userIds)

引数のメニューIDのメニューをすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
userIds Array メニューIDの配列
返却値
Array メニュー情報オブジェクトの配列。
（データがない場合は空の配列を返します）
getMenuPosts

Array getMenuPosts (String menuId)

役職情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array 役職情報オブジェクトの配列
getMenuPublicGroups

Array getMenuPublicGroups (String menuId)

パブリックグループ情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array パブリックグループ情報オブジェクトの配列
getMenuRoles

Array getMenuRoles (String menuId)

メニューロールを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
Array ロールIDの配列
getMenuTree

Array getMenuTree ()

メニュー構成を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array メニュー構成オブジェクトの配列
getParentMenuId

String getParentMenuId (String menuId)

指定されたメニューの親メニューを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
menuId String メニューID
返却値
String 親メニュー
importData

Boolean importData (String category ,String inputString)

メニューのインポートを行います。

パラメータ
category | String | カテゴリ名
inputString | String | 入力情報
返却値
Boolean true : 成功 / false : 失敗
isUpdate

boolean isUpdate (Date date)

メニュー情報が指定された日付よりも後に更新されたかチェックします。
パラメータ
date Date チェック日付
返却値
boolean 判定結果　更新された : true / 更新されていない ： false
moveMenuItem

Boolean moveMenuItem (MenuInclusionInfo object)

メニューを移動します。
パラメータ
object MenuInclusionInfo メニュー内包情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
updateMenuItem

Boolean updateMenuItem (MenuInfo object)

メニューを更新します。
パラメータ
object MenuInfo メニュー情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 MenuTreeInfo オブジェクト

メニューツリー情報オブジェクト。
メニューのツリー形式を表す情報オブジェクトです。

メニューツリー情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

メニューツリー設定情報オブジェクトは値を参照することのみ許可されています

プロパティの概要
Array | children 子供のメニューツリー情報オブジェクトの配列。 | 読込み専用
MenuInfo | menuItem メニュー情報オブジェクト。 | 読込み専用
プロパティの詳細
children

Array children (読込み専用プロパティ)

子供のメニューツリー情報オブジェクトの配列。
menuItem

MenuInfo menuItem (読込み専用プロパティ)

メニュー情報オブジェクト。


 MessageManager オブジェクト

メッセージマネージャオブジェクト。

メッセージIDからメッセージ文字列を取得するオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | getLocaleMessage (String locale ,String key ,String ....) 国際化されたメッセージを取得します。
static String | getMessage (String key ,String ....) メッセージを取得します。
メソッドの詳細
getLocaleMessage

static String getLocaleMessage (String locale ,String key ,String ....)

国際化されたメッセージを取得します。

引数に指定したロケールでメッセージを取得します。
指定したロケールが不正の場合は、システムのデフォルトロケールで取得します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、『 #メッセージＩＤ[指定ロケール] 』形式の文字列を返却します。
メッセージの取得に失敗した場合は、null を返却します。

置換文字列(メッセージ引数)の挿入は MessageFormat#format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージIDにより取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列(メッセージ引数)を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

メッセージ引数を指定しなかった場合、MessageFormat#format関数を利用しませんので、取得したメッセージを変換せずにそのまま返却します。
パラメータ
locale | String | ロケール文字列
key | String | メッセージＩＤ
.... String メッセージ引数（複数設定可能）
返却値
String メッセージ文字列
導入されたバージョン：5.1
getMessage

static String getMessage (String key ,String ....)

メッセージを取得します。

現在ログインしているユーザのロケールでメッセージを取得します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
メッセージの取得に失敗した場合は、null を返却します。

置換文字列(メッセージ引数)の挿入は MessageFormat#format(java.lang.String, java.lang.Object[])に準じます。
よってメッセージIDにより取得されるメッセージの内容を上記メソッドの第1引数に渡して処理しますので、
対応するメッセージの内容（propertiesファイルの内容）は、MessageFormatのpattern文字列に沿ったメッセージを記述してください。

置換文字列(メッセージ引数)を利用した場合,取得結果に対して
"'"を表現するには"''"
"{"を表現するには"'{"
を対象のメッセージに記述してください。

メッセージ引数を指定しなかった場合、MessageFormat#format関数を利用しませんので、取得したメッセージを変換せずにそのまま返却します。
パラメータ
key String メッセージＩＤ
.... String メッセージ引数（複数設定可能）
返却値
String メッセージ文字列


 Module.access オブジェクト

推奨されていません。アクセスセキュリティの各Managerオブジェクトのメソッドに置き換えられました。
セキュリティ情報を操作するオブジェクト。

ロール、メニュー、アカウント、バッチ 情報のインポート／エクスポート／削除を行います。

メソッドの概要
static Number | delAccount (String groupId ,String userId) 推奨されていません。AccountManager.deleteAccount()に置き換えられました。
static Number | delAllAccount (String groupId) 推奨されていません。AccountManager.deleteAccounts()に置き換えられました。
static Number | delAllMenu (String groupId) 推奨されていません。MenuManager.deleteMenuItems()に置き換えられました。
static Number | delAllRole (String groupId) 推奨されていません。RoleManager.deleteRoles()に置き換えられました。
static Number | delAllSchedule (String groupId) 推奨されていません。BatchManager.deleteBatches()に置き換えられました。
static Number | getAccount (String groupId ,String path) 推奨されていません。AccountManager.exportData()に置き換えられました。
static Number | getMenu (String groupId ,String path) 推奨されていません。MenuManager.exportData()に置き換えられました。
static Number | getRole (String groupId ,String path) 推奨されていません。RoleManager.exportData()に置き換えられました。
static Number | getSchedule (String groupId ,String path) 推奨されていません。BatchManager.exportData()に置き換えられました。
static Number | setAccount (String groupId ,String path) 推奨されていません。AccountManager.importData()に置き換えられました。
static Number | setMenu (String groupId ,String path) 推奨されていません。MenuManager.importData()に置き換えられました。
static Number | setRole (String groupId ,String path) 推奨されていません。RoleManager.importData()に置き換えられました。
static Number | setSchedule (String groupId ,String path) 推奨されていません。BatchManager.importData()に置き換えられました。
メソッドの詳細
delAccount

static Number delAccount (String groupId ,String userId)

推奨されていません。AccountManager.deleteAccount()に置き換えられました。
アカウント情報を削除します。

指定のログイングループ内の指定のアカウント情報を削除します。
パラメータ
groupId | String | ログイングループID
userId | String | ユーザーCD
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllAccount

static Number delAllAccount (String groupId)

推奨されていません。AccountManager.deleteAccounts()に置き換えられました。
アカウント情報を全て削除します。

指定のログイングループ内のアカウント情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllMenu

static Number delAllMenu (String groupId)

推奨されていません。MenuManager.deleteMenuItems()に置き換えられました。
メニュー情報を全て削除します。

指定のログイングループ内のメニュー情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllRole

static Number delAllRole (String groupId)

推奨されていません。RoleManager.deleteRoles()に置き換えられました。
ロール情報を全て削除します。

指定のログイングループ内のロール情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
delAllSchedule

static Number delAllSchedule (String groupId)

推奨されていません。BatchManager.deleteBatches()に置き換えられました。
バッチ情報を全て削除します。

指定のログイングループ内のバッチ情報を全て削除します。 現在ログインしてるグループのデータは全削除できません。
パラメータ
groupId String
返却値
Number
0：終了
1：現在ログインしてるグループを削除しようとした
2：引数が不正
3：削除失敗
getAccount

static Number getAccount (String groupId ,String path)

推奨されていません。AccountManager.exportData()に置き換えられました。
アカウント情報をエクスポートします。

指定のログイングループ内のアカウント情報を ファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
getMenu

static Number getMenu (String groupId ,String path)

推奨されていません。MenuManager.exportData()に置き換えられました。
メニュー情報をエクスポートします。

指定のログイングループ内のメニュー情報を ファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
getRole

static Number getRole (String groupId ,String path)

推奨されていません。RoleManager.exportData()に置き換えられました。
ロール情報をエクスポートします。

指定のログイングループ内のロール情報を ファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
getSchedule

static Number getSchedule (String groupId ,String path)

推奨されていません。BatchManager.exportData()に置き換えられました。
バッチ情報をエクスポートします。

指定のログイングループ内のバッチ情報をファイルへ出力します。 ファイルは Storage Service 上に出力されます。あらかじめ保存ディレクトリを作成しておく必要があります。 第2引数の出力ファイルパスはStorage Serviceルート/storageからの相対パスを指定します。 既に指定のファイルが存在する場合、上書きは行いません。
パラメータ
groupId | String
path | String
返却値
Number
0：エクスポート成功
1：既に指定のファイルが存在する
2：指定のディレクトリは存在しない
4：ファイルへの書き込みに失敗
5：引数が不正
setAccount

static Number setAccount (String groupId ,String path)

推奨されていません。AccountManager.importData()に置き換えられました。
アカウント情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のアカウントIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー
setMenu

static Number setMenu (String groupId ,String path)

推奨されていません。MenuManager.importData()に置き換えられました。
メニュー情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のメニューIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー
setRole

static Number setRole (String groupId ,String path)

推奨されていません。RoleManager.importData()に置き換えられました。
ロール情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のロールIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー
setSchedule

static Number setSchedule (String groupId ,String path)

推奨されていません。BatchManager.importData()に置き換えられました。
バッチ情報をインポートします。

第2引数のファイルパスはStorageServiceルート/storageからの相対パスを指定します。 データ形式が不正なレコードは登録せず、ログ（stderr.log）に出力されます。 既に同一のバッチIDがシステムに登録されている場合、上書きされます。
パラメータ
groupId | String | ログイングループID
path | String | ファイルパス
返却値
Number
0：インポート成功
1：指定のファイルが存在しない
2：引数が不正
3：エラー


 Module.alert オブジェクト

警告画面オブジェクト

警告画面を表示します。

メソッドの概要
static void | back (String messageId ,String detail) 警告画面表示後、前表示ページへ戻る機能を持つ警告画面を表示します。
static void | link (String messageId ,String detail ,String path ,Object arg) 警告画面表示後、任意のページの再表示機能を持つ警告画面を表示します。
static void | reload (String messageId ,String detail ,Object arg) 警告画面表示後、前表示ページの再表示機能を持つ警告画面を表示します。
static void | write (String messageId ,String detail) 警告画面の表示を表示します。
メソッドの詳細
back

static void back (String messageId ,String detail)

警告画面表示後、前表示ページへ戻る機能を持つ警告画面を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、 『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。 このメソッドで表示される警告画面上には、ボタンが表示され、この ボタンをクリックする事で、ブラウザのキャッシュ機能を利用して 直前まで表示されていた画面を再表示します。 キャッシュを利用しないように設定されているブラウザ上では、 期待通りの動作をしない場合が有ります。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
返却値
void
link

static void link (String messageId ,String detail ,String path ,Object arg)

警告画面表示後、任意のページの再表示機能を持つ警告画面を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、 『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。
このメソッドで表示された警告画面上のボタンをクリックする事で、 引数 path で指定した任意のページプログラムをリクエストして、 表示させる事ができます。 引数 arg には、再表示リクエスト時のプログラムへのＵＲＬ引数を 定義する事ができます。オブジェクト arg の内容が、そのままリクエスト されたファンクションコンテナの init() 関数への引数 request として渡されます。 リンク先プログラムの init() 関数に渡す引数データとして arg に対して request オブジェクトを指定すると 正常に動作しないことがあります。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
path | String | 先ページプログラムパス(拡張子なし)
arg | Object | 画面プログラムへの引数群
返却値
void
reload

static void reload (String messageId ,String detail ,Object arg)

警告画面表示後、前表示ページの再表示機能を持つ警告画面を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、 『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。
このメソッドで表示された警告画面上のボタンをクリックする事で、 直前に表示していたページプログラムを再度リクエストして、 再表示させる事ができます。 引数 arg には、再表示リクエスト時のプログラムへのＵＲＬ引数を 定義する事ができます。オブジェクト arg の内容が、そのままリクエスト されたファンクションコンテナの init() 関数への引数 request として渡されます。 リロード時の init() 関数に渡す引数データとして arg に対して request オブジェクトを指定すると正常に動作しないことがあります。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
arg | Object | 画面プログラムへの引数群
返却値
void
write

static void write (String messageId ,String detail)

警告画面の表示を表示します。

現在ログインしているユーザのロケールのメッセージＩＤに該当するメッセージを表示します。
引数に指定したメッセージＩＤで取得可能なメッセージが存在しない場合、 『 #メッセージＩＤ[ユーザのロケール] 』形式の文字列を返却します。
また、第２引数 detail に渡された文字列を詳細メッセージとして 警告画面上に表示します。

このAPIは、try...catch 文では使用できません。
パラメータ
messageId | String | メッセージID
detail | String | 画面に表示する詳細メッセージ文字列
返却値
void


 Module.almanac オブジェクト

推奨されていません。CalendarManagerに置き換えられました。
暦オブジェクト。

暦を扱います。
警告画面を表示します。

メソッドの概要
static void | definePlugin (String key ,String name ,Function plugin) 推奨されていません。代替えメソッドはありません。
static void | extinction (String group) 推奨されていません。calendarManager.deleteCalendar()に置き換えられました。
static Array | getConfig (String id) 推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Object | getDate (Date target ,String group) 推奨されていません。calendarManager.getDayInfo()に置き換えられました。
static Object | getGroup (String id) 推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Array | getHoliday (String id) 推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Array | getMonth (Number year ,Number month ,String id) 推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static Object | getPlugin () 推奨されていません。calendarManager.getPluginIds()に置き換えられました。
static Array | getWeekday (String id) 推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
static void | insert (String group ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption) 推奨されていません。calendarManager.addCalendarInfo()に置き換えられました。
static Boolean | isHoliday (Date target ,String id) 推奨されていません。calendarManager.isHoliday()に置き換えられました。
static Boolean | isWeekday (Date target ,String id) 推奨されていません。CalendarManager.isWeekday()に置き換えられました。
static void | remove (group String ,String id) 推奨されていません。CalendarManager.deleteCalendarInfo(String ,String)に置き換えられました。
static Object | update (String group ,String id ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption) 推奨されていません。calendarManager.updateCalendarInfo()に置き換えられました。
メソッドの詳細
definePlugin

static void definePlugin (String key ,String name ,Function plugin)

推奨されていません。代替えメソッドはありません。
休日・非休日判定用プラグイン関数の登録をします。

この関数は何も処理を行いません。 プラグイン関数の登録は、設定ファイル(サーバマネージャのインストールディレクトリ/conf/access-security.xml)で行います。
設定ファイルにて登録する方式に変更されました。
サーバマネージャ/conf/access-security.xmlファイル。
access-config/calendar/pluginタグにて設定します。
パラメータ
key | String | プラグイン設定キー
name | String | マスタメンテ画面での表示名称
plugin | Function | 実行関数
返却値
void
extinction

static void extinction (String group)

推奨されていません。calendarManager.deleteCalendar()に置き換えられました。
設定カテゴリを削除します。

指定のカテゴリを削除します。 指定のカテゴリ内に保存されていたデータはすべて破棄されます。
パラメータ
group String カテゴリID
返却値
void
getConfig

static Array getConfig (String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内名称設定データ一覧を取得します。

 指定のカテゴリに対する名称設定情報を取得します。
 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの
 動作が不安定になる場合が有ります。
 返却オブジェクトは、以下の構造を持つオブジェクトになります。
 return_object
      ├ [0]
      │ ・
      │ ・
      │ ・
      └ [n]
          ├ id          設定ＩＤ
          ├ year        年設定
          ├ month       月設定
          ├ date        日設定
          ├ day         曜日設定
          ├ times       第何何曜日設定
          ├ week        第何週設定
          ├ start       有効開始年
          ├ end         有効終了年
          ├ expression  備考データ
          └ plugin      プラグイン関数への参照名
パラメータ
id String カテゴリID
返却値
Array 名称設定データ一覧配列
getDate

static Object getDate (Date target ,String group)

推奨されていません。calendarManager.getDayInfo()に置き換えられました。
指定日付の暦情報を取得します。

 返却されるオブジェクトの構造は以下のようになっています。
 return_object
 ├ date 日付データ（ＤＡＴＥ型）
 ├ data[] 備考データ
 │ ├ 0
 │ │ ・
 │ └ n
 ├ match 休日または非休日設定で該当した設定項目数
 ├ color 最高優先度項目の設定表示色
 ├ holiday 休日フラグ（真偽値）
 └ weekday 平日フラグ（真偽値）
 返却オブジェクトのプロパティ match は、休日判定の場合、該当した
 休日設定項目の数が保存されます。
 また、該当日付が非休日判定の場合には、該当した非休日設定項目の
 数が保存されます。
パラメータ
target | Date | チェック対象日付データ
group | String | カテゴリID
返却値
Object 該当日付の暦データオブジェクト
getGroup

static Object getGroup (String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内設定データ一覧を取得します。

 指定のカテゴリに対する設定情報をすべて取得します。
 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの
 動作が不安定になる場合が有ります。
 返却オブジェクトは、以下の構造を持つオブジェクトになります。

 return_object
  ├ name           グループ名称
  ├ holiday[]      休日設定(自動ＩＤ割付)
  ├ weekday[]      非休日設定(自動ＩＤ割付)
  └ config[]       特定日設定(自動ＩＤ割付)
       ├ id           割付ユニーク・データＩＤ
       ├ pattern      チェックパターン文字列
       ├ expression   備考（名称など）
       ├ color        表示色
       ├ point        有効得点（データの優先度）
       ├ year         年
       ├ month        月
       ├ date         日
       ├ day          曜日
       ├ times        その月の第何回目の曜日
       ├ week         その月の第何週
       ├ start        データの有効開始年
       ├ end          データの有効終了年
       └ plugin       プラグイン関数
パラメータ
id String カテゴリID
返却値
Object 設定データオブジェクト
getHoliday

static Array getHoliday (String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内休日設定データ一覧を取得します。

 指定のカテゴリに対する休日設定情報を取得します。
 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの
 動作が不安定になる場合が有ります。
 返却オブジェクトは、以下の構造を持つオブジェクトになります。

 return_object
      ├ [0]
      │ ・
      │ ・
      │ ・
      └ [n]
          ├ id          設定ＩＤ
          ├ year        年設定
          ├ month       月設定
          ├ date        日設定
          ├ day         曜日設定
          ├ times       第何何曜日設定
          ├ week        第何週設定
          ├ start       有効開始年
          ├ end         有効終了年
          ├ expression  備考データ
          └ plugin      プラグイン関数への参照名
パラメータ
id String カテゴリID
返却値
Array 休日設定データ一覧配列
getMonth

static Array getMonth (Number year ,Number month ,String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
１ヶ月分の暦情報を取得します。

指定年月の１ヶ月分の休日・非休日の暦情報を作成して返却します。 返却する配列の要素番号は 1 から始まる連想配列になります。 各要素番号が指定年月の日に該当します。
例）要素番号 10 には、その月の 10 日の情報が格納されています。 返却する配列の各要素はオブジェクトになっていて、その構造は、 getDate() メソッドの返却値と同様になっています。
パラメータ
year | Number | 年
month | Number | 月
id | String | カテゴリID
返却値
Array 指定年月の暦情報を持つ配列
getPlugin

static Object getPlugin ()

推奨されていません。calendarManager.getPluginIds()に置き換えられました。
プラグイン関数情報を取得します。

登録されているプラグイン関数に関する情報を返します。 返却値は、プラグイン設定キーをプロパティ名に、 該当するプラグイン名称を値とするオブジェクト型データになります。
返却値
Object 登録されているプラグインのキーと名称
getWeekday

static Array getWeekday (String id)

推奨されていません。calendarManager.getCalendarInfos()に置き換えられました。
指定カテゴリ内非休日設定データ一覧を取得します。

指定のカテゴリに対する非休日設定情報を取得します。 このメソッドの返却オブジェクトを無闇に変更すると暦モジュールの 動作が不安定になる場合が有ります。 返却オブジェクトは、以下の構造を持つオブジェクトになります。
 return_object
      ├ [0]
      │ ・
      │ ・
      │ ・
      └ [n]
          ├ id          設定ＩＤ
          ├ year        年設定
          ├ month       月設定
          ├ date        日設定
          ├ day         曜日設定
          ├ times       第何何曜日設定
          ├ week        第何週設定
          ├ start       有効開始年
          ├ end         有効終了年
          ├ expression  備考データ
          └ plugin      プラグイン関数への参照名
パラメータ
id String カテゴリID
返却値
Array 非休日設定データ一覧配列
insert

static void insert (String group ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption)

推奨されていません。calendarManager.addCalendarInfo()に置き換えられました。
設定データを登録します。

パラメータ
group | String | カテゴリID
year | Number | 年情報（数値）
month | Number | 月情報（数値）
date | Number | 日情報（数値）
day | Number | 曜日情報（数値）
times | Number | その月の何回目の曜日かの情報（数値）
week | Number | 第何週かの情報（数値）
begin | Number | 設定の有効開始年（数値）
terminate | Number | 設定の有効終了年（数値）
plugin | String | プラグイン関数への参照名（文字列）
exp | String | データへの備考（文字列）
color | String | データの表示色（文字列）
type | String | データの種別（キーワード）
caption | String | データ名称
返却値
void
isHoliday

static Boolean isHoliday (Date target ,String id)

推奨されていません。calendarManager.isHoliday()に置き換えられました。
指定日付が休日かをチェックします。

暦マスタの設定情報と照合して、指定の日付が休日判定なら true を 返却して、非休日判定なら false を返却します。
パラメータ
target | Date | チェック対象日付データ
id | String | カテゴリＩＤ
返却値
Boolean
真値：指定日付が休日設定
偽値：指定日付は非休日設定
isWeekday

static Boolean isWeekday (Date target ,String id)

推奨されていません。CalendarManager.isWeekday()に置き換えられました。
指定日付が非休日かをチェックします。

暦マスタの設定情報と照合して、指定の日付が非休日判定なら true を 返却して、休日判定なら false を返却します。
パラメータ
target | Date | チェック対象日付データ
id | String | カテゴリID
返却値
Boolean
真値：指定日付が非休日設定
偽値：指定日付は休日設定
remove

static void remove (group String ,String id)

推奨されていません。CalendarManager.deleteCalendarInfo(String ,String)に置き換えられました。
設定データを削除します。

パラメータ
String | group | カテゴリID
id | String | 設定データID
返却値
void
update

static Object update (String group ,String id ,Number year ,Number month ,Number date ,Number day ,Number times ,Number week ,Number begin ,Number terminate ,String plugin ,String exp ,String color ,String type ,String caption)

推奨されていません。calendarManager.updateCalendarInfo()に置き換えられました。
設定データの更新をします。
パラメータ
group | String | カテゴリID
id | String | 設定データID
year | Number | 年情報（数値）
month | Number | 月情報（数値）
date | Number | 日情報（数値）
day | Number | 曜日情報（数値）
times | Number | その月の何回目の曜日かの情報（数値）
week | Number | 第何週かの情報（数値）
begin | Number | 設定の有効開始年（数値）
terminate | Number | 設定の有効終了年（数値）
plugin | String | プラグイン関数への参照名（文字列）
exp | String | データへの備考（文字列）
color | String | データの表示色（文字列）
type | String | データの種別（キーワード）
caption | String | データ名称
返却値
Object 更新前データ


 Module.array オブジェクト

配列データを扱うためのオブジェクト。

メソッドの概要
static Array | add (Array head ,Array tail) ２つの配列データを連結します。
static Array | insert (Array target ,Object item ,Number index) 配列データへ要素を追加します。
static Array | remove (Array target ,Number index) 配列データ内の要素を削除します。
static Array | sort (Array target) 配列内のデータをソートします。
static Object | toList (Object src ,String key ,String data) データベースアクセス結果オブジェクトからオブジェクトを生成します。
メソッドの詳細
add

static Array add (Array head ,Array tail)

２つの配列データを連結します。

指定の２つの配列の全ての要素を持つ新しい配列を作成します。 作成される新しい配列は、0 ? head.length-1 までが head の各要素 であり、head.length ? (head.length + tail.length - 1) までが tail の各要素となります。
このメソッドは、元のデータに影響を与えません。 指定の配列データの指定の位置に指定のデータを挿入します。 このメソッドは、元のデータに影響を与えません。
パラメータ
head | Array | 連結されるデータ
tail | Array | 連結されるデータ
返却値
Array 連結された新しい配列データ
insert

static Array insert (Array target ,Object item ,Number index)

配列データへ要素を追加します。

指定の配列データの指定の位置に指定のデータを挿入します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target | Array | 配列データ
item | Object | 配列への追加データ
index | Number | データを追加する配列内のインデックス
返却値
Array データを追加された新しい配列データ
remove

static Array remove (Array target ,Number index)

配列データ内の要素を削除します。

指定の配列データの指定の位置のデータを削除します。 削除されたデータ以降のデータは、要素番号が１つずつ詰められます。 このメソッドは、元のデータに影響を与えません。
パラメータ
target | Array | 配列データ
index | Number | 削除する配列内のインデックス
返却値
Array データを削除された新しい配列データ
sort

static Array sort (Array target)

配列内のデータをソートします。

指定の配列データの各要素をソートして返します。 ソートは、昇順で行われます。 ソート対象の配列内データは、すべての要素が同一の型でなくては なりません。 このメソッドは、元のデータに影響を与えません。
パラメータ
target Array 配列データ
返却値
Array ソートされた結果の新しい配列データ
toList

static Object toList (Object src ,String key ,String data)

データベースアクセス結果オブジェクトからオブジェクトを生成します。

第１引数にデータベースアクセス結果オブジェクトを指定します。
第２引数に与えたプロパティ名のデータがプロパティの名称になります。
第３引数に与えたプロパティ名のデータがプロパティの値になります。
第３引数にプロパティ名を指定しない場合には、空のオブジェクトが返されます。

例えば、以下のような場合

# select * from user_table;
user_cd | user_name | user_name_kana | user_name_eng
aoyagi | 青柳辰巳 | アオヤギ　タツミ | aoyagi tatsumi
hayashi | 林政義 | ハヤシ　マサヨシ | hayashi masayoshi
maruyama | 円山益男 | マルヤマ　マスオ | maruyama masuo
ueda | 上田辰男 | ウエダ　タツオ | ueda tatsuo

以下のようにプログラムします。

var dbRessult = DatabaseManager.select("select * from user_table");
var result = Module.array.toList(dbRessult, "user_cd", "user_name_kana");

# 生成されたオブジェクト
aoyagi | アオヤギ　タツミ
hayashi | ハヤシ　マサヨシ
maruyama | マルヤマ　マスオ
ueda | ウエダ　タツオ

パラメータ
src | Object | データベースアクセス結果オブジェクト
key | String | キーになるプロパティ名
data | String | データになるプロパティ名
返却値
Object 生成されたオブジェクト


 Module.calendar オブジェクト

日本の元号を扱うオブジェクト。

メソッドの概要
static String | getName (Date target) 指定日付の年号を取得します。
static Object | getObject () 年号の設定データ情報を取得します。
static Number | getYear (Date target) 指定日付の該当年号内での年数を取得します。
static void | set (String name ,String key ,Number year ,Number month ,Number day) カテゴリ内の指定保存キーで指定データを保存します。
static Number | toADYear (String key ,Number year) 年号および年号年数より西暦年への変換をします。
メソッドの詳細
getName

static String getName (Date target)

指定日付の年号を取得します。

指定日付データの該当する年号名称を返却します。
パラメータ
target Date 日付データ
返却値
String 年号名称文字列
getObject

static Object getObject ()

年号の設定データ情報を取得します。

設定データの key をプロパティ、name を値とするオブジェクトを生成して返却します。
返却値
Object 全保存データ群
getYear

static Number getYear (Date target)

指定日付の該当年号内での年数を取得します。

指定日付データの該当する年号での年数を返却します。
パラメータ
target Date 日付データ
返却値
Number 暦年数を返却
set

static void set (String name ,String key ,Number year ,Number month ,Number day)

カテゴリ内の指定保存キーで指定データを保存します。

指定のデータで年号情報を設定します。
パラメータ
name | String | 年号名称
key | String | 設定キー
year | Number | 年号の開始年
month | Number | 年号の開始月
day | Number | 年号の開始日
返却値
void
toADYear

static Number toADYear (String key ,Number year)

年号および年号年数より西暦年への変換をします。

年号および年数より、西暦年を算出して返却します。
パラメータ
key | String | 設定キー
year | Number | 年号年数
返却値
Number 指定データより求められる西暦年


 Module.client オブジェクト

ログインしているカレント・ユーザー情報に関するオブジェクト。

バージョン：1.0
導入されたバージョン：2.0
メソッドの概要
String get (String key)
ログインユーザ情報を取得します。
メソッドの詳細
get

String get (String key)

ログインユーザ情報を取得します。

ユーザ情報取得用パラメータの詳細は以下の通り
パラメータ | 取得情報id | 導入バージョン
id | ログインユーザーコード | 2.0
name | ログインユーザー名 | 2.0
group | ログイングループID | 2.0
locale | ログインロケール | 5.0
encoding | ログインエンコーディング | 5.0
colorPatternId | カラーパターンID | 5.0
mail | ログインユーザーメールアドレス | 2.0
mblmail | ログインユーザーモバイル用メールアドレス | 2.0
パラメータ
key String ユーザ情報取得用パラメータ
返却値
String 引数指定のログインユーザ情報


 Module.data オブジェクト

JavaScript の各種データを扱うオブジェクト。

メソッドの概要
static String varType (Object target)
変数データの型をチェックします。
メソッドの詳細
varType

static String varType (Object target)

変数データの型をチェックします。

 指定データの変数型をチェックして、型を示すキーワードを返却します。
 返却されるキーワードは以下のようになります。
 string : 文字列
 number : 数値
 boolean : 真偽値
 undefined : 未定義
 object : オブジェクト
 array : 配列
 date : 日付
 null : NULL
 function : 関数
パラメータ
target Object チェック対象データ
返却値
String 型を示すキーワード文字列


 Module.database オブジェクト

推奨されていません。DatabaseManagerに置き換えられました。
データベースにアクセスするためのオブジェクト。

各メソッドの引数に、”接続データベースの参照名”とありますが、この引数を指定した場合は、指定した引数値と同じ接続名のシステムデータベースへ接続されます。
これを指定しなかった場合、現在ログインしているログイングループIDと同じ接続名のシステムデータベースへ接続されます。
システムデータベースとは、ServerManager/conf/data-source.xml内で<system-data-source>タグで設定されているデータベースです。

このオブジェクトのメソッドでは、ログイングループのデータベースに接続されません。
ログイングループのデータベースに接続する場合は DatabaseManager を利用してください。
ログイングループのデータベースとは、ServerManager/conf/data-source.xml内で<group-data-source>タグで設定されているデータベースです。

メソッドの概要
static Object | commit () 推奨されていません。DatabaseManager.commitに置き換えられました。
static Object | commit (String name) 推奨されていません。DatabaseManager.commitに置き換えられました。
static Boolean | contact () 推奨されていません。代替えメソッドはありません。
static Boolean | contact (String name) 推奨されていません。代替えメソッドはありません。
static Boolean | contact (Object info) 推奨されていません。代替えメソッドはありません。
static Number | count (String tableName ,String where ,String name) 推奨されていません。DatabaseManager.getCount()に置き換えられました。
static Number | count (String tableName ,String where) 推奨されていません。DatabaseManager.getCount()に置き換えられました。
static Number | count (String tableName) 推奨されていません。DatabaseManager.getCount()に置き換えられました。
static String | dateToString (Date date) 推奨されていません。DatabaseManager.dateToString()に置き換えられました。
static String | dateToString (String year ,String month ,String date ,String hour ,String minute ,String second) 推奨されていません。DatabaseManager.dateToString()に置き換えられました。
static DataForStoredProc | execStoredFunc (String functionName ,String returnType ,Array arrayArg ,String connectId) 推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
static DataForStoredProc | execStoredFunc (String functionName ,String returnType ,Array arrayArg) 推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
static DataForStoredProc | execStoredProc (String functionName ,Array arrayArg ,String connectId) 推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
static DataForStoredProc | execStoredProc (String functionName ,Array arrayArg) 推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
static DbResultObject | execute (String sql ,String connectId) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static DbResultObject | execute (String sql) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object | fetch (String sql ,Number start ,Number length ,String name) 推奨されていません。DatabaseManager.fetch()に置き換えられました。
static Object | fetch (String sql ,Number start ,Number length) 推奨されていません。DatabaseManager.fetch()に置き換えられました。
static String | getDbName (String name) 推奨されていません。DatabaseManager.getDbName()に置き換えられました。
static String | getDbName () 推奨されていません。DatabaseManager.getDbName()に置き換えられました。
static String | getDbVersion (String name) 推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
static String | getDbVersion () 推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
static Boolean | getEscape (String name) 推奨されていません。DatabaseManager.getEscape()に置き換えられました。
static Boolean | getEscape () 推奨されていません。DatabaseManager.getEscape()に置き換えられました。
static Array | getReference () 推奨されていません。DatabaseManager.getConnectIdsBySystem()に置き換えられました。
static Object | getStoredArg () 推奨されていません。DatabaseManager.getStoredArg()に置き換えられました。
static DbResultObject | insert (String tableName ,Object value ,String refName) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static DbResultObject | insert (String tableName ,Object value) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static Boolean | isColumn (String columnName ,String tableName ,String refName) 推奨されていません。DatabaseManager.isColumn()に置き換えられました。
static Boolean | isColumn (String columnName ,String tableName) 推奨されていません。DatabaseManager.isColumn()に置き換えられました。
static Boolean | isConnect (String refName) 推奨されていません。DatabaseManager.isConnect()に置き換えられました。
static Boolean | isConnect () 推奨されていません。DatabaseManager.isConnect()に置き換えられました。
static Object | max (String columnName ,String tableName ,String where ,String refName) 推奨されていません。DatabaseManager.getMax()に置き換えられました。
static Object | max (String columnName ,String tableName ,String where) 推奨されていません。DatabaseManager.getMax()に置き換えられました。
static Object | max (String columnName ,String tableName) 推奨されていません。DatabaseManager.getMax() に置き換えられました。
static Object | min (String columnName ,String tableName ,String where ,String refName) 推奨されていません。DatabaseManager.getMin()に置き換えられました。
static Object | min (String columnName ,String tableName ,String where) 推奨されていません。DatabaseManager.getMin()に置き換えられました。
static Object | min (String columnName ,String tableName) 推奨されていません。DatabaseManager.getMin()に置き換えられました。
static Object | mkConfData (String databaseType ,String prop ,Object refNamae) 推奨されていません。代替えメソッドはありません。
static Object | remove (String tableName ,String where ,String refName) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object | remove (String tableName ,String where) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object | rollback (String refName) 推奨されていません。DatabaseManager.rollback()に置き換えられました。
static Object | rollback () 推奨されていません。DatabaseManager.rollback()に置き換えられました。
static Object | select (String sql ,String refName ,String max) 推奨されていません。DatabaseManager.select()に置き換えられました。
static Object | select (String sql ,String refName) 推奨されていません。DatabaseManager.select()に置き換えられました。
static Object | select (String sql) 推奨されていません。DatabaseManager.select()に置き換えられました。
static Boolean | setDeleteSQL (Function func ,String refName) 推奨されていません。代替えメソッドはありません。
static Boolean | setDeleteSQL (Function func) 推奨されていません。代替えメソッドはありません。
static Boolean | setInsertSQL (Function func ,String refName) 推奨されていません。代替えメソッドはありません。
static Boolean | setInsertSQL (Function func) 推奨されていません。代替えメソッドはありません。
static Boolean | setUpdateSQL (Function func ,String refName) 推奨されていません。代替えメソッドはありません。
static Boolean | setUpdateSQL (Function func) 推奨されていません。代替えメソッドはありません。
static Date | toDate (String date) 推奨されていません。DatabaseManager.stringToDate()に置き換えられました。
static Object | toList (Array src ,String key ,String data) 推奨されていません。Module.array.toList()に置き換えられました。
static Object | transaction (String refName) 推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
static Object | transaction () 推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
static Object | update (String tableName ,String where ,Object value ,String refName) 推奨されていません。DatabaseManager.execute()に置き換えられました。
static Object | update (String tableName ,String where ,Object value) 推奨されていません。DatabaseManager.execute()に置き換えられました。
メソッドの詳細
commit

static Object commit ()

推奨されていません。DatabaseManager.commitに置き換えられました。
データベースアクセスの確定処理をします。

トランザクションの確定処理を行います。 トランザクションが開始されていない場合には働きません。
返却値
Object DbResultObjectオブジェクト
commit

static Object commit (String name)

推奨されていません。DatabaseManager.commitに置き換えられました。
データベースアクセスの確定処理をします。

トランザクションの確定処理を行います。 トランザクションが開始されていない場合には働きません。
パラメータ
name String 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
contact

static Boolean contact ()

推奨されていません。代替えメソッドはありません。
データベース接続をします。

第1引数を指定しなかった場合は、現在ログインしているログイングループが デフォルトで使用するDBに接続を試みます。
返却値
Boolean
真値： 接続成功
偽値： 接続失敗
contact

static Boolean contact (String name)

推奨されていません。代替えメソッドはありません。
データベース接続をします。

第1引数に接続情報オブジェクトを渡すと、 [システム設定]-[データベース]、 [システム設定]-[マルチデータベース]画面でDB接続情報を登録しなくても、 接続情報オブジェクトの情報によってDBに接続することができます。
この方法で接続したDBにModule.database.select()などを行うときは、 必ずModule.database.select()などの引数に接続参照名を渡して下さい。
接続情報オブジェクトは、Module.database.mkConfData() Module.database.mkConfData() メソッドを使って取得します。
パラメータ
name String 接続データベースの参照名
返却値
Boolean
真値： 接続成功
偽値： 接続失敗
contact

static Boolean contact (Object info)

推奨されていません。代替えメソッドはありません。
データベース接続をします。

パラメータ
info Object 接続情報オブジェクト
返却値
Boolean
真値： 接続成功
偽値： 接続失敗
count

static Number count (String tableName ,String where ,String name)

推奨されていません。DatabaseManager.getCount()に置き換えられました。
指定条件に該当する表内のデータ件数を取得します。

パラメータ
tableName | String | テーブル名
where | String | "WHERE"を除いたWHERE句 (WHERE句なしで第3引数を指定するときはnullを入れます。)
name | String | 接続データベースの参照名
返却値
Number
成功： 件数
失敗： null
count

static Number count (String tableName ,String where)

推奨されていません。DatabaseManager.getCount()に置き換えられました。
指定条件に該当する表内のデータ件数を取得します。

パラメータ
tableName | String | テーブル名
where | String | "WHERE"を除いたWHERE句
返却値
Number
成功： 件数
失敗： null
count

static Number count (String tableName)

推奨されていません。DatabaseManager.getCount()に置き換えられました。
指定条件に該当する表内のデータ件数を取得します。

パラメータ
tableName String テーブル名
返却値
Number
成功： 件数
失敗： null
dateToString

static String dateToString (Date date)

推奨されていません。DatabaseManager.dateToString()に置き換えられました。
日付型変数から日付文字列を取得します。

日付を表わす日付型変数から日付をあらわす文字列を生成します。
引数が適正ではない場合の動作は未定義です。
日付型文字列は以下の形式に準拠する。
YYYY/MM/DD|hh:mm:ss
パラメータ
date Date 日付型変数
返却値
String 指定日付データを表わす文字列
dateToString

static String dateToString (String year ,String month ,String date ,String hour ,String minute ,String second)

推奨されていません。DatabaseManager.dateToString()に置き換えられました。
日付情報から日付文字列を取得します。

日付情報から日付をあらわす文字列を生成します。
引数が適正ではない場合の動作は未定義です。
日付型文字列は以下の形式に準拠します。
YYYY/MM/DD|hh:mm:ss
パラメータ
year | String | 年
month | String | 月
date | String | 日
hour | String | 時間
minute | String | 分
second | String | 秒
返却値
String 指定日付データを表わす文字列
execStoredFunc

static DataForStoredProc execStoredFunc (String functionName ,String returnType ,Array arrayArg ,String connectId)

推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
ストアドファンクションを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
returnType | String | 返値の型（1-3を指定(1:String,2:Number,3:Date)
arrayArg | Array | 引数オブジェクト配列
connectId | String | DB接続参照名
返却値
DataForStoredProc DataForStoredProcオブジェクト
execStoredFunc

static DataForStoredProc execStoredFunc (String functionName ,String returnType ,Array arrayArg)

推奨されていません。DatabaseManager.execStoredFunc()に置き換えられました。
ストアドファンクションを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
returnType | String | 返値の型（1-3を指定(1:String,2:Number,3:Date)
arrayArg | Array | 引数オブジェクト配列
返却値
DataForStoredProc DataForStoredProcオブジェクト
execStoredProc

static DataForStoredProc execStoredProc (String functionName ,Array arrayArg ,String connectId)

推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
ストアドプロシジャーを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
arrayArg | Array | 引数オブジェクト配列(配列の要素は実際の引数の順番とします。)
connectId | String | DB接続参照名
返却値
DataForStoredProc DataForStoredProcオブジェクト
execStoredProc

static DataForStoredProc execStoredProc (String functionName ,Array arrayArg)

推奨されていません。DatabaseManager.execStoredProc()に置き換えられました。
ストアドプロシジャーを実行します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
このメソッドの返却値であるDataForStoredProcは必ず受け取り、 必要な 操作の後、必ずDataForStoredProcのclose()メソッドを呼び出して下さい。
パラメータ
functionName | String | storedFunction名
arrayArg | Array | 引数オブジェクト配列(配列の要素は実際の引数の順番とします。)
返却値
DataForStoredProc DataForStoredProcオブジェクト
execute

static DbResultObject execute (String sql ,String connectId)

推奨されていません。DatabaseManager.execute()に置き換えられました。
任意のＳＱＬ文をデータベースに対してリクエストします。

引数に指定されたＳＱＬ文をデータベースに対して発行する。 SQL文の最後には文末文字（";","/"など）をいれないで下さい。
パラメータ
sql | String | SQL名
connectId | String | 接続データベースの参照名
返却値
DbResultObject エラー・オブジェクト
execute

static DbResultObject execute (String sql)

推奨されていません。DatabaseManager.execute()に置き換えられました。
任意のＳＱＬ文をデータベースに対してリクエストします。

引数に指定されたＳＱＬ文をデータベースに対して発行する。 SQL文の最後には文末文字（";","/"など）をいれないで下さい。
パラメータ
sql String SQL名
返却値
DbResultObject エラー・オブジェクト
fetch

static Object fetch (String sql ,Number start ,Number length ,String name)

推奨されていません。DatabaseManager.fetch()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
nStart, nLength には、それぞれ数値（自然数）で 与えてください。（１?）
例）１０件目から２０件目までのデータが欲しい場合
Module.database.fetch(SQL, 10, 11);
引数 nStart を数値指定しなかった場合の初期値は 1 である。
引数 nLength を数値で指定しなかった場合の初期値は long の 最大値（0x7fffffff == 2147483647）である。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。 数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql | String | カーソルを当てるべき SQL 文を指定
start | Number | 取得するデータの開始レコード位置
length | Number | 取得するデータの最大レコード
name | String | 接続データベースの参照名
返却値
Object DataForDatabase型オブジェクト
fetch

static Object fetch (String sql ,Number start ,Number length)

推奨されていません。DatabaseManager.fetch()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
nStart, nLength には、それぞれ数値（自然数）で 与えてください。（１?）
例）１０件目から２０件目までのデータが欲しい場合
Module.database.fetch(SQL, 10, 11);
引数 nStart を数値指定しなかった場合の初期値は 1 である。
引数 nLength を数値で指定しなかった場合の初期値は long の 最大値（0x7fffffff == 2147483647）である。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。 数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql | String | カーソルを当てるべき SQL 文を指定
start | Number | 取得するデータの開始レコード位置
length | Number | 取得するデータの最大レコード
返却値
Object DataForDatabase型オブジェクト
getDbName

static String getDbName (String name)

推奨されていません。DatabaseManager.getDbName()に置き換えられました。
接続データベース名を取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返します。 戻り値はデータベースに依存します。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
name String 複数ＤＢを使用する場合のＤＢ別名
返却値
String
成功： データベース名
失敗： null
getDbName

static String getDbName ()

推奨されていません。DatabaseManager.getDbName()に置き換えられました。
接続データベース名を取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返します。 戻り値はデータベースに依存します。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
返却値
String
成功： データベース名
失敗： null
getDbVersion

static String getDbVersion (String name)

推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
接続データベースのバージョンを取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返す。 戻り値はデータベースに依存します。
パラメータ
name String 複数ＤＢを使用する場合のＤＢ別名
返却値
String
成功： データベース名
失敗： null
getDbVersion

static String getDbVersion ()

推奨されていません。DatabaseManager.getDbVersion()に置き換えられました。
接続データベースのバージョンを取得します。

[システム設定]のデータベース設定画面で指定されたＤＢのバージョンを返す。 戻り値はデータベースに依存します。
返却値
String
成功： データベース名
失敗： null
getEscape

static Boolean getEscape (String name)

推奨されていません。DatabaseManager.getEscape()に置き換えられました。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

パラメータ
name String 接続データベースの参照名
返却値
Boolean
成功： ワイルドカード文字をエスケープするのに使用できる文字列
失敗： null
getEscape

static Boolean getEscape ()

推奨されていません。DatabaseManager.getEscape()に置き換えられました。
ワイルドカード文字をエスケープするのに使用できる文字列を取得します。

返却値
Boolean
成功： ワイルドカード文字をエスケープするのに使用できる文字列
失敗： null
getReference

static Array getReference ()

推奨されていません。DatabaseManager.getConnectIdsBySystem()に置き換えられました。
データベース接続設定参照名配列を取得します。

返却値
Array 参照名あり：参照名配列 / 参照名なし：null
参照名あり： 参照名配列
参照名なし： null
getStoredArg

static Object getStoredArg ()

推奨されていません。DatabaseManager.getStoredArg()に置き換えられました。
execStoredFunc(),execStoredProcに渡す引数作成オブジェクトを取得します。

引数オブジェクトとはgetStoredArg()メソッドで取得したオブジェクトです。
返却値
Object DbStoredProcArgオブジェクト
insert

static DbResultObject insert (String tableName ,Object value ,String refName)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースにデータを追加挿入します。

データベースにインサート処理をします。
挿入データはオブジェクト形式のデータをセットします。
なお、オブジェクトのプロパティ名称は、挿入したいデータベース のカラム名称に等しく作成し、そのプロパティに対して挿入したい データをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
value | Object | 挿入データ
refName | String | 接続データベースの参照名
返却値
DbResultObject DbResultObjectオブジェクト
insert

static DbResultObject insert (String tableName ,Object value)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースにデータを追加挿入します。

データベースにインサート処理をします。
挿入データはオブジェクト形式のデータをセットします。
なお、オブジェクトのプロパティ名称は、挿入したいデータベース のカラム名称に等しく作成し、そのプロパティに対して挿入したい データをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
value | Object | 挿入データ
返却値
DbResultObject DbResultObjectオブジェクト
isColumn

static Boolean isColumn (String columnName ,String tableName ,String refName)

推奨されていません。DatabaseManager.isColumn()に置き換えられました。
データベースの表内の定義情報をチェックします。

データベースの表内に指定カラムが存在するか調べます。
パラメータ
columnName | String | 処理対象のデータベース表名
tableName | String | 挿入データ
refName | String | 接続データベースの参照名
返却値
Boolean
真値： 指定のカラムは存在する
偽値： 指定のカラムは存在しない
isColumn

static Boolean isColumn (String columnName ,String tableName)

推奨されていません。DatabaseManager.isColumn()に置き換えられました。
データベースの表内の定義情報をチェックします。

データベースの表内に指定カラムが存在するか調べます。
パラメータ
columnName | String | 処理対象のデータベース表名
tableName | String | 挿入データ
返却値
Boolean
真値： 指定のカラムは存在する
偽値： 指定のカラムは存在しない
isConnect

static Boolean isConnect (String refName)

推奨されていません。DatabaseManager.isConnect()に置き換えられました。
データベース接続の状態を確認します。

指定された設定で現在接続が確立されているかをチェックする。
動的コネクション数変更機能を使用している場合は、実際に 接続されているかどうかではなく、接続できる状態にあるかどうかを 返す。
一度データベースと接続されると、trueを返しつづけます。 (途中でデータベースがダウンした場合もtrueを返します。)
パラメータ
refName String 接続データベースの参照名
返却値
Boolean
真値： 接続されている
偽値： 接続されていない
isConnect

static Boolean isConnect ()

推奨されていません。DatabaseManager.isConnect()に置き換えられました。
データベース接続の状態を確認します。

指定された設定で現在接続が確立されているかをチェックする。
動的コネクション数変更機能を使用している場合は、実際に 接続されているかどうかではなく、接続できる状態にあるかどうかを 返す。

一度データベースと接続されると、trueを返しつづけます。 (途中でデータベースがダウンした場合もtrueを返します。)
返却値
Boolean
真値： 接続されている
偽値： 接続されていない
max

static Object max (String columnName ,String tableName ,String where ,String refName)

推奨されていません。DatabaseManager.getMax()に置き換えられました。
テーブル内の指定カラムの最大値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句(WHERE句なしで第4引数を指定するときはnullを入れます。)
refName | String | 接続データベースの参照名
返却値
Object
成功： DBのデータ型Object
失敗： null
max

static Object max (String columnName ,String tableName ,String where)

推奨されていません。DatabaseManager.getMax()に置き換えられました。
テーブル内の指定カラムの最大値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句
返却値
Object
成功： DBのデータ型Object
失敗： null
max

static Object max (String columnName ,String tableName)

推奨されていません。DatabaseManager.getMax() に置き換えられました。
テーブル内の指定カラムの最大値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
返却値
Object
成功： DBのデータ型Object
失敗： null
min

static Object min (String columnName ,String tableName ,String where ,String refName)

推奨されていません。DatabaseManager.getMin()に置き換えられました。
テーブル内の指定カラムの最小値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句(WHERE句なしで第4引数を指定するときはnullを入れます。)
refName | String | 接続データベースの参照名
返却値
Object
成功： DBのデータ型Object
失敗： null
min

static Object min (String columnName ,String tableName ,String where)

推奨されていません。DatabaseManager.getMin()に置き換えられました。
テーブル内の指定カラムの最小値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
where | String | WHERE句
返却値
Object 成功：DBのデータ型Object / 失敗：null
min

static Object min (String columnName ,String tableName)

推奨されていません。DatabaseManager.getMin()に置き換えられました。
テーブル内の指定カラムの最小値を取得します。

パラメータ
columnName | String | カラム名
tableName | String | テーブル名
返却値
Object
成功： DBのデータ型Object
失敗： null
mkConfData

static Object mkConfData (String databaseType ,String prop ,Object refNamae)

推奨されていません。代替えメソッドはありません。
Module.database.contact()メソッドの引数に使用するデータベース接続情報オブジェクトを取得します。

接続参照名が第3引数の接続情報オブジェクトを取得します。
 第1引数には、以下の文字列を渡します。
 "DS"
 第2引数には、以下のようなオブジェクトを渡します。
 Object
 └ ds_ref_name    DataSourceへの参照名
パラメータ
databaseType | String | 接続データベースタイプ
prop | String | 接続情報
refNamae | Object | 接続データベースの参照名
返却値
Object 接続情報オブジェクト
remove

static Object remove (String tableName ,String where ,String refName)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを削除します。

データベースのデータを削除します。 条件を設定すると、条件に合致したすべてのレコードを削除します。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 削除レコード検索条件(WHERE 句)
refName | String | 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
remove

static Object remove (String tableName ,String where)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを削除します。

データベースのデータを削除します。 条件を設定すると、条件に合致したすべてのレコードを削除します。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 削除レコード検索条件(WHERE 句)
返却値
Object DbResultObjectオブジェクト
rollback

static Object rollback (String refName)

推奨されていません。DatabaseManager.rollback()に置き換えられました。
データベースアクセスのトランザクションを取り消します。

トランザクションの取り消し処理を行います。 トランザクションが開始されていない場合には働きません。
パラメータ
refName String 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
rollback

static Object rollback ()

推奨されていません。DatabaseManager.rollback()に置き換えられました。
データベースアクセスのトランザクションを取り消します。

トランザクションの取り消し処理を行います。 トランザクションが開始されていない場合には働きません。
返却値
Object DbResultObjectオブジェクト
select

static Object select (String sql ,String refName ,String max)

推奨されていません。DatabaseManager.select()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、 トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
第3引数には数値型を指定して下さい。変数ではなく、直接数値を指定する場合は、parseInt,parseFloatなどを使用して 明示的に数値型にする必要があります。
例）Module.database.select(SQL,GROUP,parseInt(3));
パラメータ
sql | String | SQL文を指定します。(SELECT *** )
refName | String | 接続データベースの参照名
max | String | 最大取得行数 0は無制限
返却値
Object DataForDatabase型オブジェクト
select

static Object select (String sql ,String refName)

推奨されていません。DatabaseManager.select()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql | String | SQL文を指定します。(SELECT *** )
refName | String | 接続データベースの参照名
返却値
Object DataForDatabase型オブジェクト
select

static Object select (String sql)

推奨されていません。DatabaseManager.select()に置き換えられました。
SELECT文を発行してデータベースからデータを取得します。

条件に合致するデータをＤＢから取得します。
カラム名は、強制的にすべて小文字になります。
SELECT文の最後には文末文字（";","/"など）をいれないで下さい。
ORACLEのSELECT FOR UPDATEなどレコードをロックするSQL文を発行する場合は、トランザクションを開始してから行って下さい。
数値型カラムの値がNULLだったとき、０（ゼロ）ではなくNULLを返します。
パラメータ
sql String SQL文を指定します。(SELECT *** )
返却値
Object DataForDatabase型オブジェクト
setDeleteSQL

static Boolean setDeleteSQL (Function func ,String refName)

推奨されていません。代替えメソッドはありません。
delete 文を作成する関数を登録します。

Module.database.remove(),Module.database.deleteData() 関数を実行した時にDBに対して実際に実行 されるSQL(DELETE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
第二引数を省略すると、Module.database.remove(),Module.database.deleteData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func | Function | 関数
refName | String | DB接続参照名
返却値
Boolean
成功： true
失敗： false
setDeleteSQL

static Boolean setDeleteSQL (Function func)

推奨されていません。代替えメソッドはありません。
delete 文を作成する関数を登録します。

Module.database.remove(),Module.database.deleteData() 関数を実行した時にDBに対して実際に実行 されるSQL(DELETE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
第二引数を省略すると、Module.database.remove(),Module.database.deleteData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func Function 関数
返却値
Boolean
成功： true
失敗： false
setInsertSQL

static Boolean setInsertSQL (Function func ,String refName)

推奨されていません。代替えメソッドはありません。
Insert 文を作成する関数を登録します。

Module.database.insert(),Module.database.insertData() 関数を実行した時にDBに対して実際に実行 されるSQL(INSERT文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用する。
第二引数を省略すると、Module.database.insert(),Module.database.insertData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func | Function | 関数
refName | String | DB接続参照名
返却値
Boolean
成功： true
失敗： false
setInsertSQL

static Boolean setInsertSQL (Function func)

推奨されていません。代替えメソッドはありません。
Insert 文を作成する関数を登録します。

Module.database.insert(),Module.database.insertData() 関数を実行した時にDBに対して実際に実行 されるSQL(INSERT文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用する。
第二引数を省略すると、Module.database.insert(),Module.database.insertData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func Function 関数
返却値
Boolean
成功： true
失敗： false
setUpdateSQL

static Boolean setUpdateSQL (Function func ,String refName)

推奨されていません。代替えメソッドはありません。
update 文を作成する関数を登録します。

Module.database.update(),Module.database.updateData() 関数を実行した時にDBに対して実際に実行 されるSQL(UPDATE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用します。
第二引数を省略すると、Module.database.update(),Module.database.updateData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func | Function | 関数
refName | String | DB接続参照名
返却値
Boolean
成功： true
失敗： false
setUpdateSQL

static Boolean setUpdateSQL (Function func)

推奨されていません。代替えメソッドはありません。
update 文を作成する関数を登録します。

Module.database.update(),Module.database.updateData() 関数を実行した時にDBに対して実際に実行 されるSQL(UPDATE文)を生成するためのJS関数をフレームワークに対して登録するためのAPIです。
  使用目的としては、JavaScriptの日付型のデータをDBの日付型データに変換する時 などに利用します。
第二引数を省略すると、Module.database.update(),Module.database.updateData()関数において DB接続参照名引数が省略された場合のデフォルト設定になります。
引数が不正の場合はfalseを返します。
上記関数の使用方法に関しましては、Infomationサーバルート/ library/im_default_sql.js ファイルをご参照ください。
パラメータ
func Function 関数
返却値
Boolean
成功： true
失敗： false
toDate

static Date toDate (String date)

推奨されていません。DatabaseManager.stringToDate()に置き換えられました。
字列から日付型変数を取得します。

日付を表わす文字列から日付型変数を生成します。
引数が適正ではない場合の動作は、未定義です。
日付型文字列は以下の形式に準拠します。
YYYY/MM/DD|hh:mm:ss
パラメータ
date String 日付を表わす文字列
返却値
Date 指定日付データを持つ日付型変数
toList

static Object toList (Array src ,String key ,String data)

推奨されていません。Module.array.toList()に置き換えられました。
オブジェクト型の配列データからオブジェクトを生成します。

プロパティ名を渡すと、そのオブジェクト内のプロパティのデータをプロパティ名にして、そのオブジェクトを返します。
第２引数に与えたプロパティ名のデータがプロパティの名称になります。
第３引数に与えたプロパティ名のデータがプロパティの値になります。
引数がない場合には、空のオブジェクトが返されます。
パラメータ
src | Array | オブジェクト型の配列
key | String | キーになるプロパティ名
data | String | データになるプロパティ名
返却値
Object 生成されたオブジェクト
transaction

static Object transaction (String refName)

推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
データベースアクセスのトランザクションを開始します。

このメソッドを発行した後は、必ず以下のいづれかのメソッドを発行しなければならない。
Module.database.commit()
Module.database.rollback()

パラメータ
refName String 接続データベースの参照名
返却値
Object DbResultObject型オブジェクト
transaction

static Object transaction ()

推奨されていません。DatabaseManager.beginTransaction()に置き換えられました。
データベースアクセスのトランザクションを開始します。

このメソッドを発行した後は、必ず以下のいづれかのメソッドを発行しなければならない。
Module.database.commit()
Module.database.rollback()

返却値
Object DbResultObject型オブジェクト
update

static Object update (String tableName ,String where ,Object value ,String refName)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを更新します。

データベースのデータを更新(アップデート)します。
更新データは、オブジェクト形式でセットします。
なお、オブジェクトのプロパティ名称は、更新したいデータベースのカラム名称に等しく作成し、 そのプロパティに対して更新したいデータをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 更新部分検索条件(WHERE 句)
value | Object | 更新データ
refName | String | 接続データベースの参照名
返却値
Object DbResultObjectオブジェクト
update

static Object update (String tableName ,String where ,Object value)

推奨されていません。DatabaseManager.execute()に置き換えられました。
データベースのデータを更新します。

データベースのデータを更新(アップデート)します。
更新データは、オブジェクト形式でセットします。
なお、オブジェクトのプロパティ名称は、更新したいデータベースのカラム名称に等しく作成し、 そのプロパティに対して更新したいデータをセットします。
パラメータ
tableName | String | 処理対象のデータベース表名
where | String | 更新部分検索条件(WHERE 句)
value | Object | 更新データ
返却値
Object DbResultObjectオブジェクト


 Module.date オブジェクト

日付データの日情報に対して指定増分を加算するオブジェクト。

メソッドの概要
static Date | addDay (Date date ,Number plus) 日付データの日情報に対して指定増分を加算します。
static Date | addHour (Date date ,Number plus) 日付データの時間情報に対して指定増分を加算します。
static Date | addMinute (Date date ,Number plus) 日付データの分情報に対して指定増分を加算します。
static Date | addMonth (Date date ,Number plus) 日付データの月情報に対して指定増分を加算します。
static Date | addSecond (Date date ,Number plus) 日付データの秒情報に対して指定増分を加算します。
static Date | addYear (Date date ,Number plus) 日付データの年情報に対して指定増分を加算します。
static String | dayName (Date date) 曜日を表す文字列を取得します。
static Date | get (number year ,number month ,number day ,number hour ,number minute ,numbe second) 変数データの型をチェックします。
static Date | getFuture (Date target_a ,Date target_b) 未来を表す日付データを取得します。
static Date | getFuture (Date target_a) 未来を表す日付データを取得します。
static Date | getPast (Date target_a ,Date target_b) 過去を表す日付データを取得します。
static Date | getPast (Date target_a) 過去を表す日付データを取得します。
static Number | getYear (Date date) 西暦年を取得します。
static Number | interval (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalDay (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalHour (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalMinute (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalMonth (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalSecond (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Number | intervalYear (Date target_a ,Date target_b) ２つの日付データの時間間隔を取得します。
static Boolean | isBetween (Date left ,String l_op ,Date target ,String r_op ,Date right) 日付情報の範囲をチェックします。
static Boolean | isBetween (Date left ,String l_op ,Date target) 日付情報の範囲をチェックします。
static Boolean | isFuture (Date target) 日付データが未来を示すかどうかをチェックします。
static Boolean | isLeapYear (Date target) 閏年チェックをします。
static Boolean | isPast (Date target) 日付データが過去を示すかどうかをチェックします。
static Boolean | isValid (Number year ,Number month ,Number day) 日付データとしての正当性をチェックします 。
static String | monthName (Date target) 月を表す文字列を取得します。
static Date | today () “今日”という日付を表す日付オブジェクトを取得します。
メソッドの詳細
addDay

static Date addDay (Date date ,Number plus)

日付データの日情報に対して指定増分を加算します。

指定日付データの日情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addHour

static Date addHour (Date date ,Number plus)

日付データの時間情報に対して指定増分を加算します。

指定日付データの時間情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addMinute

static Date addMinute (Date date ,Number plus)

日付データの分情報に対して指定増分を加算します。

指定日付データの分情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addMonth

static Date addMonth (Date date ,Number plus)

日付データの月情報に対して指定増分を加算します。

指定日付データの月情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addSecond

static Date addSecond (Date date ,Number plus)

日付データの秒情報に対して指定増分を加算します。

指定日付データの秒情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
addYear

static Date addYear (Date date ,Number plus)

日付データの年情報に対して指定増分を加算します。

指定日付データの年情報に対して、 指定増分値を加算した結果の日付データを返却します。
パラメータ
date | Date | 対象データ
plus | Number | 増加分
返却値
Date 指定増分を加算した結果の日付データ
dayName

static String dayName (Date date)

曜日を表す文字列を取得します。

以下の曜日を表すキーワード文字列を返却します。 Sunday : 日曜日 Monday : 月曜日 Tuesday : 火曜日 Wednesday: 水曜日 Thursday : 木曜日 Friday : 金曜日 Saturday : 土曜日
パラメータ
date Date 対象データ
返却値
String 指定の日付データが表す曜日を示すキーワード文字列
get

static Date get (number year ,number month ,number day ,number hour ,number minute ,numbe second)

変数データの型をチェックします。

指定された日付情報を表す日付型オブジェクトを生成して返却します。 引数 hour, minute, second を省略した場合、0 が適応されます。
パラメータ
year | number | 年（数字）
month | number | 月（数字）
day | number | 日（数字）
hour | number | 時（数字）
minute | number | 分（数字）
second | numbe | 秒（数字）
返却値
Date 指定日付を表す日付型オブジェクト
getFuture

static Date getFuture (Date target_a ,Date target_b)

未来を表す日付データを取得します。

引数に与えられた２つの日付データのうち、より未来を示す日付データを 返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Date ２つの日付データのうち未来を示す方の日付データ
getFuture

static Date getFuture (Date target_a)

未来を表す日付データを取得します。

このメソッドの実行時の“現在”を 表す日付データと引数 target_a との比較が行われ、 より未来を示す日付データを返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a Date チェック対象データa
返却値
Date メソッド実行時の“現在”を表す日付データと引数 target_aのうち未来を示す方の日付データ
getPast

static Date getPast (Date target_a ,Date target_b)

過去を表す日付データを取得します。

引数に与えられた２つの日付データのうち、より過去を示す日付データを 返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Date ２つの日付データのうち過去を示す方の日付データ
getPast

static Date getPast (Date target_a)

過去を表す日付データを取得します。

このメソッドの実行時の“現在”を 表す日付データと引数 target_a との比較が行われ、 より過去を示す日付データを返却します。 このメソッドは、元のデータに影響を与えません。
パラメータ
target_a Date チェック対象データa
返却値
Date メソッド実行時の“現在”を表す日付データと引数 target_aのうち過去を示す方の日付データ
getYear

static Number getYear (Date date)

西暦年を取得します。

指定の日付データの表す年情報を４桁で返却します。 このメソッドでは西暦 0 〜 1000 年の間のデータを扱う事はできません。
パラメータ
date Date 対象データ
返却値
Number 指定日付データの表す西暦年
interval

static Number interval (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“年”です。 返却データは、浮動小数点形式で表され、小数点以下は１２進法で 表されます。 例）23ヶ月→1.11年
パラメータ
target_a | Date | チェック対象データ a
target_b | Date | チェック対象データ b
返却値
Number ２つの日付データの時間的差分
intervalDay

static Number intervalDay (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“日”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalHour

static Number intervalHour (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“時間”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalMinute

static Number intervalMinute (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“分”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalMonth

static Number intervalMonth (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“月”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalSecond

static Number intervalSecond (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“秒”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
intervalYear

static Number intervalYear (Date target_a ,Date target_b)

２つの日付データの時間間隔を取得します。

指定の２つの日付データの時間間隔を計算して返却します。 返却するデータの単位は“年”です。
パラメータ
target_a | Date | チェック対象データa
target_b | Date | チェック対象データb
返却値
Number ２つの日付データの時間的差分
isBetween

static Boolean isBetween (Date left ,String l_op ,Date target ,String r_op ,Date right)

日付情報の範囲をチェックします。

チェック対象日付データを左辺および右辺の両境界における範囲チェック を指定のオペレーションでおこないます。
 チェックオペレータは、以下のキーワードにより指定します。
 "<" or ">"  ：大小比較１（同値は含まない）
 "<=" or ">="：大小比較２（同値も真とする）
 "= ="       ：同値比較（同値の場合を真とする）
 "<>" or "!="：異値比較（値が異なる場合を真とする）

 例）var datA = Module.date.get(2000, 1, 1);
     var datB = Module.date.get(2001, 1, 1);
     var datNow = Module.date.getToday();

 Module.date.isBetween(datA, "<=", datNow, "<", datB);
 この返却値で、“今日”が2000年であるかを判定できる。
 注意）このメソッドのチェックは、ミリ秒単位にて判定します。
 Module.date.isBetween(new Date() , "= =", new Date());
 これは、偽値(false)になる可能性があります。

パラメータ
left | Date | 左辺境界を表す日付データ
l_op | String | 左辺チェックオペレータ
target | Date | チェック対象日付データ
r_op | String | 右辺チェックオペレータ
right | Date | 右辺境界を表す日付データ
返却値
Boolean
真値：対象日付データは指定の範囲に合致
偽値：対象日付データは指定の範囲外を表します。
isBetween

static Boolean isBetween (Date left ,String l_op ,Date target)

日付情報の範囲をチェックします。

チェック対象日付データを左辺および右辺の両境界における範囲チェック を指定のオペレーションでおこないます。
 チェックオペレータは、以下のキーワードにより指定します。
 "<" or ">"  ：大小比較１（同値は含まない）
 "<=" or ">="：大小比較２（同値も真とする）
 "= ="       ：同値比較（同値の場合を真とする）
 "<>" or "!="：異値比較（値が異なる場合を真とする）

 例）var datA = Module.date.get(2000, 1, 1);
     var datB = Module.date.get(2001, 1, 1);
     var datNow = Module.date.getToday();

 Module.date.isBetween(datA, "<=", datNow, "<", datB);
 この返却値で、“今日”が2000年であるかを判定できる。
 注意）このメソッドのチェックは、ミリ秒単位にて判定します。
 Module.date.isBetween(new Date() , "= =", new Date());
 これは、偽値(false)になる可能性があります。

パラメータ
left | Date | 左辺境界を表す日付データ
l_op | String | 左辺チェックオペレータ
target | Date | チェック対象日付データ
返却値
Boolean
真値：対象日付データは指定の範囲に合致
偽値：対象日付データは指定の範囲外を表します。
isFuture

static Boolean isFuture (Date target)

日付データが未来を示すかどうかをチェックします。

指定の日付データが、このメソッド実行時における“現在”時間よりも 未来である場合 true を返却し、過去である場合 false を返却します。 指定の日付データが、このメソッド実行時における“現在”時間と 等しい場合には、false が返却されます。
パラメータ
target Date チェック対象データ
返却値
Boolean
真値：指定の日付データは、現在よりも未来
偽値：指定日付データは、現在よりも過去
isLeapYear

static Boolean isLeapYear (Date target)

閏年チェックをします。

指定日付の年が閏年に該当しているかをチェックしています。 太陽暦（グレゴリオ歴）を基本として計算されています。
パラメータ
target Date チェック対象データ
返却値
Boolean
真値：指定年は閏年
偽値：指定年は閏年ではない
isPast

static Boolean isPast (Date target)

日付データが過去を示すかどうかをチェックします。

指定の日付データが、このメソッド実行時における“現在”時間よりも 過去である場合 true を返却し、未来である場合 false を返却します。 指定の日付データが、このメソッド実行時における“現在”時間と 等しい場合には、false が返却されます。
パラメータ
target Date チェック対象データ
返却値
Boolean
真値：指定の日付データは、現在よりも過去
偽値：指定日付データは、現在よりも未来
isValid

static Boolean isValid (Number year ,Number month ,Number day)

日付データとしての正当性をチェックします 。

指定年月日情報が日付データとして正しい値である事をチェックします。
パラメータ
year | Number | チェック対象年
month | Number | チェック対象月
day | Number | チェック対象日
返却値
Boolean
真値：指定データは日付として正しい値を示している
偽値：指定データは日付データとして正しくない
monthName

static String monthName (Date target)

月を表す文字列を取得します。

以下の月を表すキーワード文字列を返却します。
January | : １月
February | : ２月
March | : ３月
April | : ４月
May | : ５月
June | : ６月
July | : ７月
August | : ８月
September | : ９月
October | : １０月
November | : １１月
December | : １２月

パラメータ
target Date チェック対象データ
返却値
String 指定日付データの表す月を示すキーワード文字列
today

static Date today ()

“今日”という日付を表す日付オブジェクトを取得します。

実行時の日にちを表す日付型データを生成して返却します。
生成された日付型データの表す年月日情報は、メソッド実行時の日付を 表し、時間は 00:00:00:000 を表します。
返却値
Date “今日”を表す日付オブジェクト


 Module.download オブジェクト

データのダウンロード機能を提供するオブジェクト。

ファイルダウンロード・モジュールは、サーバーからクライアントに対してファイルを送信するための機能です。
ダウンロードには、HTTP プロトコルを利用します。

ファイル拡張子とＭＩＭＥタイプ
ダウンロード時には、ファイルの拡張子によって自動的にＭＩＭＥタイプが決定されます。
ファイル拡張子とＭＩＭＥの関係は、以下の表を参考にして下さい。

.pdf | application/pdf
.gif | image/gif
.html
.htm 		text/html
.jar | application/java-archive
.js | application/x-javascript
.jpeg
.jpg 		image/jpeg
.xls | application/vnd.ms-excel
.ppt | application/vnd.ms-powerpoint
.mp2 | audio/x-mpeg
.mpeg
.mpg 		video/mpeg
.txt
.text 		text/plain
.doc | application/msword

上記表でＭＩＭＥタイプを決定できない場合は、application/octet-stream が適応されます。

また、ダウンロードＡＰＩへの引数の与え方により、ダウンロードＡＰＩを利用するプログラム側で任意にＭＩＭＥタイプを指定することもできます。

注意事項
ファイルダウンロード・モジュールは、ブラウザへデータを送信するための機能です。

ダウンロードＡＰＩは、クライアントへのデータの送信時に文字コード変換を行いません。クライアントが受信する文字コード形式への適切な変換は、ダウンロードＡＰＩへデータを渡す前に、ダウンロードＡＰＩを利用するプログラム側で行うようにしてください。
メソッドの概要
static void | send (String stream ,String name ,String mime) 現在実行中のプログラムを中断して、指定データを送信します。
static void | send (String stream ,String name) 現在実行中のプログラムを中断して、指定データを送信します。
static void | send (String stream) 現在実行中のプログラムを中断して、指定データを送信します。
メソッドの詳細
send

static void send (String stream ,String name ,String mime)

現在実行中のプログラムを中断して、指定データを送信します。 （ブラウザ側では、指定されたデータのダウンロードになります。）

送信データはバイナリとして扱われます。テキストデータを送信する場合には、 このＡＰＩをコールする前に送信する対象となるテキストデータのローカル文字コード体系への明示的な変換をしておく必要があります。
引数 name に対して文字列を指定すると、ブラウザでデータをダウンロードした際のファイル名となります。
引数 mime に対して任意の MIME 形式を指定可能です。

このAPIは、try...catch 文では使用できません。
パラメータ
stream | String | 送信データ
name | String | ダウンロード時のファイル名
mime | String | ダウンロードデータの MIME タイプ
返却値
void
send

static void send (String stream ,String name)

現在実行中のプログラムを中断して、指定データを送信します。 （ブラウザ側では、指定されたデータのダウンロードになります。）

送信データはバイナリとして扱われます。テキストデータを送信する場合には、 このＡＰＩをコールする前に送信する対象となるテキストデータのローカル文字コード体系への明示的な変換をしておく必要があります。
ファイル名の拡張子によって自動的にMIMEタイプが決定されます。 (MIMEタイプを特定できなかった場合には application/octet-stream になります) ファイル名の拡張子とMIMEタイプの関係はこちらを参照してください。

このAPIは、try...catch 文では使用できません。
パラメータ
stream | String | 送信データ
name | String | ダウンロード時のファイル名
返却値
void
send

static void send (String stream)

現在実行中のプログラムを中断して、指定データを送信します。 （ブラウザ側では、指定されたデータのダウンロードになります。）

送信データはバイナリとして扱われます。テキストデータを送信する場合には、 このＡＰＩをコールする前に送信する対象となるテキストデータのローカル文字コード体系への明示的な変換をしておく必要があります。
ダウンロード時のファイル名は、適当なファイル名になります。（ブラウザの動作に依存します。）
MIMEタイプは、application/octet-stream が設定されます。

このAPIは、try...catch 文では使用できません。
パラメータ
stream String 送信データ
返却値
void


 Module.external オブジェクト

各リクエスト間、各クライアント間、および各サーバ間で共有の値を操作するオブジェクト。

詳細

値は Shared Memory Service にて一元的に管理されます。 したがって、システム内のすべてのプログラムから値を共有することが可能です。
セッションタイムアウトによって値が破棄されることはありません。
値の保存はメモリ内で行われるので、すべての Shared Memory Service が再起動すると値は失われます。
共有データは、ログイングループ内でユニークになります (ログイングループが異なると共有空間も別になります)。
メソッドの概要
static Object | elements () カテゴリ内のすべての設定済みデータを取得します。
static String | get (String key) カテゴリ内の指定保存キーにマップされているデータを取得します。
static Array | keys () カテゴリ内の保存キー一覧を取得します。
static void | remove (String key) カテゴリ内の指定保存キーとマップされているデータを削除します。
static void | set (String key ,Object value) カテゴリ内の指定保存キーで指定データを保存します。
メソッドの詳細
elements

static Object elements ()

カテゴリ内のすべての設定済みデータを取得します。

ログイングループ内共有データ群に対してすべての設定済みの データを返却します。
返却オブジェクトは、保存キーがプロパティ名称で保存キーにマップ されているデータが該当するプロパティの値として保存されます。
返却値
Object 全保存データ群
get

static String get (String key)

カテゴリ内の指定保存キーにマップされているデータを取得します。

ログイングループ内共有データ群において指定保存キーに マップされているデータを取得します。
指定保存キーに対応するキーが存在しない場合は null を返却します。
パラメータ
key String 値へのキーコード
返却値
String 保存キーにマップされているデータ
keys

static Array keys ()

カテゴリ内の保存キー一覧を取得します。

ログイングループ内共有データ群に対してすべての設定済みの 保存キーを返却します。
保存キーの設定順と配列内の保存キーの格納順は保証されません。
返却値
Array 全保存キー一覧（配列型）
remove

static void remove (String key)

カテゴリ内の指定保存キーとマップされているデータを削除します。

ログイングループ内共有データ群において指定保存キーに マップされているデータと指定保存キーを削除します。
指定保存キーにマップされたデータが存在しない場合は null を返却します。
パラメータ
key String 値へのキーコード
返却値
void
set

static void set (String key ,Object value)

カテゴリ内の指定保存キーで指定データを保存します。

ログイングループ内共有データ群に対して指定保存キーを 指定データにマップする形で保存します。
保存対象データは null や undefined 以外の Java Script の変数型なら いかなるものでも保存対象として適応可能です。
ただし、プロトタイプオブジェクトにより保持されている情報に関しては、 保存対象外となります。
パラメータ
key | String | 保存キー
value | Object | 保存データ
返却値
void


 Module.formatfile オブジェクト

データをフォーマットされた形式のファイルとして出力するオブジェクト。

詳細

フォーマットされたデータファイルの出力先は Storage Service になります。 このため、分散システムを構築している場合においても、 データファイルの共有が可能であり、また環境に依存する事なくデータファイルを 操作する事が可能となります。
このＡＰＩでは、テキスト形式を前提としているため、 バイナリやサポート対象外の文字コード体系データを出力した場合、 データが破壊される可能性があります。
また、分散システムを構築している場合、Storage Service へデータを転送するため、 処理に時間がかかる場合があります。
メソッドの概要
static Boolean | append (String style ,String file ,Object data) フォーマットされたデータをファイルに追記します。
static Boolean | write (String style ,String file ,Object data) フォーマットされたデータをファイルに出力します。
メソッドの詳細
append

static Boolean append (String style ,String file ,Object data)

フォーマットされたデータをファイルに追記します。

指定フォーマットで指定ファイルへデータを書き出します。 ファイルは、Storage Service に出力されます。
指定されたファイルが存在しない場合はファイルが新規作成され、存在する場合は既存ファイルに追記されます。
(指定されたファイルを格納するディレクトリはあらかじめ作成しておく必要があります)
出力ファイルパスは、Storage Service のインストールディレクトリ直下 storage/ ディレクトリからの相対になります。

このAPIは、引数 data に指定された値を「"pages/platform/src/template/" ＋ 引数 style」に該当するプログラムに渡し、
その実行結果を Storage Service に出力しています。

フォーマットを表すキーワードは、標準で「style/csv」に対応しています。
この場合、引数 data は二次元配列で指定してください。

Module.formatfile.write() に 本関数を利用した場合とほぼ同様のサンプルプログラムが記載されています。(違いは追記するか、上書きするかです。)
あわせてご参照ください。
パラメータ
style | String | フォーマットを表すキーワード
file | String | 出力ファイルパス
data | Object | 出力データ
返却値
Boolean 真値：ファイルの追記に成功 / 偽値：ファイルの追記に失敗
write

static Boolean write (String style ,String file ,Object data)

フォーマットされたデータをファイルに出力します。

指定フォーマットで指定ファイルへデータを書き出します。 ファイルは、Storage Service に出力されます。
指定されたファイルが存在しない場合はファイルが新規作成され、存在する場合は既存ファイルに上書きされます。
(指定されたファイルを格納するディレクトリはあらかじめ作成しておく必要があります)
出力ファイルパスは、Storage Service のインストールディレクトリ直下 storage/ ディレクトリからの相対になります。

このAPIは、引数 data に指定された値を「"pages/platform/src/template/" ＋ 引数 style」に該当するプログラムに渡し、
その実行結果を Storage Service に出力しています。

フォーマットを表すキーワードは、標準で「style/csv」に対応しています。
この場合、引数 data は二次元配列で指定してください。以下に、サンプルプログラムを示します。

サンプルプログラム
 var style = "style/csv";
 var file = "temp/out.csv";
 var data = new Array();

 data[0] = new Array();
 data[0][0] = "0-0";
 data[0][1] = "0-1";
 data[0][2] = "0-2";

 data[1] = new Array();
 data[1][0] = "1-0";
 data[1][1] = "1-1";
 data[1][2] = "1-2";

 data[2] = new Array();
 data[2][0] = "2-0";
 data[2][1] = "2-1";
 data[2][2] = "2-2";

 var result = Module.formatfile.write(style, file, data);
出力結果
 0-0,0-1,0-2
 1-0,1-1,1-2
 2-0,2-1,2-2

パラメータ
style | String | フォーマットを表すキーワード
file | String | 出力ファイルパス
data | Object | 出力データ
返却値
Boolean 真値：ファイルの出力に成功 / 偽値：ファイルの出力に失敗


 Module.ldap オブジェクト

LDAPサーバにアクセスするオブジェクト。

メソッドの概要
static Object | add (String dn ,String name ,String value ,Object env) 属性値を追加します。
static Object | del (String dn ,String name ,String value ,Object env) 属性値を削除します。
static Object | get (String DN ,Object env) 属性値を検索します。
static Object | modify (String DN ,String id ,String new_val ,String old_val ,Object env) 属性値の変更をします。
static Object | search (String DN ,String filter ,Object env) 属性値を検索します。
メソッドの詳細
add

static Object add (String dn ,String name ,String value ,Object env)

属性値を追加します。

第4引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 env.dn = "uid=ldap1,ou=People, o=intra.intra-mart.com";
 env.pwd = "ldap1";
 var ret = Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-789",env);
 Debug.browse(ret,Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env));
パラメータ
dn | String | 識別名
name | String | 属性名
value | String | 属性値（Stringのみ）
env | Object | 接続情報
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
del

static Object del (String dn ,String name ,String value ,Object env)

属性値を削除します。

第2引数に指定した属性の中で、第3引数にマッチした値を削除します。
第3引数を指定したくない場合は、undefinedを指定して下さい。
第4引数にLDAP接続情報オブジェクトを指定します。
オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 env.dn = "uid=ldap1,ou=People, o=intra.intra-mart.com";
 env.pwd = "ldap1";
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7890",env);
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7891",env);
 var ret1 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 var ret2 = Module.ldap.del("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7890",env);
 var ret3 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 Debug.browse(ret1,ret2,ret3);
パラメータ
dn | String | 識別名
name | String | 属性名
value | String | 属性値
env | Object | 接続情報
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
get

static Object get (String DN ,Object env)

属性値を検索します。

第1引数にマッチした属性値を取得します。
第2引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 var ret = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 Debug.browse(ret);
パラメータ
DN | String | 識別名
env | Object | 接続情報Object
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
data 取得データObject(検索結果がない場合は空Object)
属性名=属性値の配列(属性値が一つの場合も配列形式)
modify

static Object modify (String DN ,String id ,String new_val ,String old_val ,Object env)

属性値の変更をします。

第2引数に指定した属性の中で、第4引数にマッチした値を第3引数の値に置き換えます。
第4引数を指定しない場合は、属性名に関連する値は全て第3引数の値になります。
第4引数を指定したくない場合は、undefinedを指定して下さい。
第5引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 env.dn = "uid=ldap1,ou=People, o=intra.intra-mart.com";
 env.pwd = "ldap1";
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7890",env);
 Module.ldap.add("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-7891",env);
 var ret1 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 var ret2 = Module.ldap.modify("uid=ldap1,ou=People,o=intra.intra-mart.com","facsimiletelephonenumber","5123-78900","5123-7890",env);
 var ret3 = Module.ldap.get("uid=ldap1,ou=People,o=intra.intra-mart.com",env);
 Debug.browse(ret1,ret2,ret3);
パラメータ
DN | String | 識別名
id | String | 属性名
new_val | String | 変更後の属性値（Stringのみ）
old_val | String | 変更前の属性値（Stringのみ。）
env | Object | 接続情報Object
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
data 取得データObject(検索結果がない場合は空Object)
属性名=属性値の配列(属性値が一つの場合も配列形式)
search

static Object search (String DN ,String filter ,Object env)

属性値を検索します。

第2引数にマッチした属性値を取得します。 第2引数の検索フィルターの詳細は RFC 2254 を参照して下さい。 第3引数にLDAP接続情報オブジェクトを指定します。
LDAP接続情報オブジェクトは、以下のような形式で指定して下さい。
 Object
   ├url(必須)   LDAPのURLです。
   ├factory(任意) INITIAL_CONTEXT_FACTORY。指定しない場合、
   ｜              "com.sun.jndi.ldap.LdapCtxFactory"を使用する。
   ├dn(任意)     この操作に認証が必要な場合に指定する。
   ├pwd(任意)    dnのパスワード

 （実行例）
 var env = new Object();
 env.factory = "com.sun.jndi.ldap.LdapCtxFactory";
 env.url = "ldap://localhost:389/";
 var ret = Module.ldap.search("ou=People,o=intra.intra-mart.com","(&(uid=ld*)(objectclass=*)",env);
 Debug.browse(ret);

パラメータ
DN | String | 識別名
filter | String | 検索フィルター(フィルターの解釈は、RFC 2254 に基づいています。)
env | Object | 接続情報Object
返却値
Object 返却オブジェクト
error | エラーなし false / エラーあり true
message | エラーメッセージ
data 取得データObject(検索結果がない場合は空Object)
属性名=属性値の配列(属性値が一つの場合も配列形式)


 Module.logingp オブジェクト

推奨されていません。LoginGroupManagerに置き換えられました。
ログイングループ情報を操作するオブジェクト。

メソッドの概要
static Number | count () 推奨されていません。LoginGroupManager.countLoginGroup()に置き換えられました。
static Boolean | del (String key ,String groupId) ログイングループ付随情報を削除します。
static Array | entries () 推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
static Object | get (String key ,String groupId) ログイングループ付随情報を取得します。
static Boolean | isGroup (String groupId) 推奨されていません。LoginGroupManager.getLoginGroupに置き換えられました。
static Boolean | remove (String groupId) 推奨されていません。LoginGroupManager.deleteLoginGroup()に置き換えられました。
static Boolean | set (String key ,Object data ,String groupId) ログイングループ付随情報をセットします。
メソッドの詳細
count

static Number count ()

推奨されていません。LoginGroupManager.countLoginGroup()に置き換えられました。
登録されているログイングループ数を返します。

返却値
Number ログイングループ数
del

static Boolean del (String key ,String groupId)

ログイングループ付随情報を削除します。

set()メソッドで登録した値を削除します。
パラメータ
key | String | データのキー
groupId | String | ログイングループID
返却値
Boolean 真値：成功 偽値：失敗
entries

static Array entries ()

推奨されていません。LoginGroupManager.getLoginGroupIds()に置き換えられました。
登録されているログイングループIDの配列を取得します。

返却値
Array 成功：ログイングループIDの配列 / 値がないとき：null
get

static Object get (String key ,String groupId)

ログイングループ付随情報を取得します。

パラメータ
key | String | データのキー
groupId | String | ログイングループID
返却値
Object set()メソッドで登録した値 / ない場合: null
isGroup

static Boolean isGroup (String groupId)

推奨されていません。LoginGroupManager.getLoginGroupに置き換えられました。
指定のログイングループの存在チェックをします。

パラメータ
groupId String ログイングループID
返却値
Boolean 真値：ある / 偽値：ない
remove

static Boolean remove (String groupId)

推奨されていません。LoginGroupManager.deleteLoginGroup()に置き換えられました。
指定のログイングループ情報を全て削除します。

指定のログイングループに関する情報 （ロール、ユーザ、メニュー、 リンク、データベース接続参照名、カレンダー、バッチ処理、メッセージ） をすべて削除します。 現在ログインしているグループは削除しません。
パラメータ
groupId String ログイングループID
返却値
Boolean 真値：成功 / 偽値：失敗(現在ログイン中のグループが指定されたため。)
set

static Boolean set (String key ,Object data ,String groupId)

ログイングループ付随情報をセットします。

指定のログイングループに関連するデータを登録します。 第1引数：データのキーのprefixに"IM_"は使用できません。システムが 使用します。
パラメータ
key | String | データのキー
data | Object | (String、Numberのみ)
groupId | String | ログイングループID
返却値
Boolean 真値：成功 / 偽値：失敗(現在ログイン中のグループが指定されたため。)


 Module.mailpool オブジェクト

メール・プール機能を提供するオブジェクト。

このＡＰＩを利用する事で、何らかの送信に失敗したメールを再送する事ができます。
この機能では、メールの送信通知と送信処理の２つの機能を有しており、 メールの送信通知においては、送信するメールの情報を貯える処理を行い、 実際にメールが送信されるのは、メールの送信処理時になります。
よって、メール送信通知とメール送信の間に、若干の時間的誤差が生じる事になります。

メソッドの概要
static Number | delivery () メールの配信処理を行います。
static Boolean | post (Array to ,Array cc ,Array bcc ,String from ,String subject ,String body ,Object header ,Array attachment) メールの送信設定を行います。
メソッドの詳細
delivery

static Number delivery ()

メールの配信処理を行います。

送信通知されているメールを配信します。
このＡＰＩが実行された時点でプールされているメール情報すべてが、 配信対象となります。
プールされている量が多い場合、処理に時間がかかる事があります。
このＡＰＩは、プールされているすべてのメールを配信対象とするため、 実行時のボトルネックとなる可能性があります。
このＡＰＩを利用したメール配信専用バッチスクリプトが用意されています。
バッチ設定画面にて適切に設定した上で、ご利用ください。
このＡＰＩは、マルチ・グループに対応していません。

返却値
Number ログイングループ数
post

static Boolean post (Array to ,Array cc ,Array bcc ,String from ,String subject ,String body ,Object header ,Array attachment)

メールの送信設定を行います。

メールの送信設定を行います。 この時点では、メールは送信されません。
ここで設定したメールは delivery() ＡＰＩが実行された時に送信されます。
必須指定の引数を適切に設定しなかった場合には、メールを正しく送信できない場合があります。
また、任意指定の引数は、不要な場合には、null 値を指定して下さい。
引数 to, cc, bcc に対しては、送信先メールアドレスを必要な個数分だけ配列として指定します。
この時、配列の個数は送信先の数に等しくなるようにします。
引数 to, cc, bcc, from には、メールアドレスのみを指定するようにしてください。
メールアドレス以外の文字が含まれている場合、メール送信時にエラーとなる場合があります。
引数 header には、メールヘッダに含める情報を任意に指定できます。
引数 header はオブジェクト形式であり、オブジェクトのプロパティ名がヘッダ名称となり プロパティ値がそのメールヘッダ名に対応する値となるようにデータオブジェクトを作成して下さい。
引数 attachment に指定するファイルは、intra-mart File Server が対象となります。
このＡＰＩは、マルチ・グループに対応していません。
パラメータ
to | Array | 宛先(必須)
cc | Array | 宛先(任意)
bcc | Array | 宛先(任意)
from | String | 差出人(必須)
subject | String | メールタイトル(必須)
body | String | メールの本文(必須)
header | Object | 任意のメールヘッダ内容(任意)
attachment | Array | 添付ファイル名称(任意)
返却値
Boolean 真値：設定に成功 / 偽値：設定時に何らかのエラーが発生


 Module.message オブジェクト

推奨されていません。MessageManagerに置き換えられました。
メッセージマスタの設定情報を扱うオブジェクト。

メソッドの概要
static String get (String id)
推奨されていません。MessageManager.getMessage()に置き換えられました。
メソッドの詳細
get

static String get (String id)

推奨されていません。MessageManager.getMessage()に置き換えられました。
指定のメッセージを取得します。

メッセージマスタに登録されている指定の保存キーに該当する メッセージ文字列を返却します。
パラメータ
id String メッセージ保存キー
返却値
String 保存キーに該当するメッセージ


 Module.mobile オブジェクト

モバイル用画面開発時に必要になる各種機能を提供するオブジェクト。

メソッドの概要
static void alert (String id ,String detail ,String path ,String args)
警告画面を表示します。
メソッドの詳細
alert

static void alert (String id ,String detail ,String path ,String args)

警告画面を表示します。

メッセージマスタに登録されている指定の保存キーに該当する メッセージ文字列を警告画面として表示します。
このＡＰＩを実行すると、以降のプログラムは実行が中断されて、強制的に警告画面が表示されます。
引数 detail に渡した文字列を警告メッセージとは別に同じ画面内に詳細メッセージとして表示します。
引数 path には、警告画面の次に表示するページパスを指定します。
ページパスは、システムルートからの相対形式で拡張子を省略した形で指定します。
引数 args に対してオブジェクトを指定すると、遷移先ページ(path) の init() 関数で request オブジェクトとしてデータを渡す事ができます。

このAPIは、try...catch 文では使用できません。
パラメータ
id | String | メッセージID
detail | String | 詳細メッセージ
path | String | 遷移先ページ
args | String | 遷移先ページへの引数データ
返却値
void


 Module.number オブジェクト

数値データを扱うメソッドを提供するオブジェクト。

メソッドの概要
static Array | getArray (Number min ,Number max ,Number step) 配列を作成します。
static Number | round (Number target ,Number point) 数値の四捨五入をします。
static Number | toFloat (Object target) データの実数変換を行います。
static Number | toInt (Object target) データの整数変換を行います。
メソッドの詳細
getArray

static Array getArray (Number min ,Number max ,Number step)

配列を作成します。

要素 min で始まり step ずつ増加する max までの要素を持つ配列データ を作成して返却します。
引数 step を省略した場合の増分は 1 になります。
パラメータ
min | Number | 要素開始番号
max | Number | 要素終了番号
step | Number | 要素番号の増分
返却値
Array 作成された配列
round

static Number round (Number target ,Number point)

数値の四捨五入をします。

指定の数値を指定の桁で四捨五入した結果を返却します。
パラメータ
target | Number | チェック対象データ
point | Number | 四捨五入結果の数値
返却値
Number 数値配列
toFloat

static Number toFloat (Object target)

データの実数変換を行います。

引数 target を実数値に変換します。 変換対象データが文字列の場合は、parsefloat() と同様の振る舞いを します。 変換結果が非数(NaN)になった場合は、0 を返却します。
パラメータ
target Object 対象データ
返却値
Number 数値変換されたデータ
toInt

static Number toInt (Object target)

データの整数変換を行います。

引数 target を数値に変換します。 変換対象データが小数であった場合、整数に丸め込まれます。 変換対象データが文字列の場合は、parseInt() と同様の振る舞いを します。 変換結果が非数(NaN)になった場合は、0 を返却します。
パラメータ
target Object 対象データ
返却値
Number 数値変換されたデータ


 Module.string オブジェクト

文字列データを扱うメソッドを提供するオブジェクト。

メソッドの概要
static String | browse (String target [,String exclusion]) ＨＴＭＬ特殊文字を変換します。
static Array | chars (String target) 文字配列を取得します。
static String | from (Object target) 文字列を取得します。
static Boolean | isASCII (String target) ＡＳＣＩＩコードチェックをします。
static Number | quantity (String target ,String searchWord) 部分文字列の個数を取得します。
static Number | refer (String target ,String piece ,String condition) キーワードの個数の取得をします。
static Number | size (String target) 文字列長を取得します。
メソッドの詳細
browse

static String browse (String target [,String exclusion])

ＨＴＭＬ特殊文字を変換します。

ＨＴＭＬ形式でブラウザに表示するための特殊文字の変換をします。 変換される文字は以下の通りです。
 < → &lt;
 > → &gt;
 & → &amp;
 " → &quot;
 半角スペース → &nbsp;
 改行・復帰 → <BR>
特定の文字を変換対象から除去したい場合は、除去対象の文字列を引数 exclusion に指定して下さい。
たとえば、半角スペースと『"』を変換しないようにする場合は以下のように指定します。
       Module.string.browse(targetString, " \"");
パラメータ
target | String | 対象データ
exclusion | String | 変換対象から除外する文字列 (省略可能)
返却値
String 変換結果文字列
chars

static Array chars (String target)

文字配列を取得します。

引数で指定された文字列内の各文字が要素となる配列を生成して 返却します。
返却される配列の要素数は、引数で指定された文字列内の文字数に 等しくなります。
パラメータ
target String 文字列データ
返却値
Array 文字配列
from

static String from (Object target)

文字列を取得します。

指定のデータを文字列に変換して返却します。
文字列および数値データは文字列変換して返却します。
それ以外の型のデータである場合、長さが 0 の文字列を返却します。

パラメータ
target Object 対象データ
返却値
String 変換結果文字列
isASCII

static Boolean isASCII (String target)

ＡＳＣＩＩコードチェックをします。

指定の文字列が ASCII コードのみで構成されているかどうかを チェックして結果を返却します。
返却値が false であった場合、指定の文字列ないにはダブルバイト文字 が含まれている可能性があります。
パラメータ
target String 対象データ
返却値
Boolean 真値：ASCII コードのみで構成されている / 偽値：ASCII コード以外の文字データが含まれている
quantity

static Number quantity (String target ,String searchWord)

部分文字列の個数を取得します。

指定文字列(target)内の部分文字列(piece)の個数を返します。
返却値は、0 以上の正整数になります。
指定文字列内に部分文字列が１つも検索できなかった場合には、0 を 返します。

パラメータ
target | String | 文字列データ
searchWord | String | 検索キーワード
返却値
Number 個数
refer

static Number refer (String target ,String piece ,String condition)

キーワードの個数の取得をします。

文字列から指定キーワードの個数を条件検索します。
検索キーワードは複数指定可能です。その場合、各キーワード を半角スペースで区切って指定してください。
引数 condition には、文字列定数として "AND" または "OR" を指定してください(大文字小文字は問いません)。 "AND" を指定した場合には、AND 条件でキーワード検索します。
"OR" を指定した場合には、OR 条件でキーワード検索します。
指定が正しくない場合には、デフォルトで AND 条件が適応されます。
返却値は、0 以上の正整数になります。
指定文字列内に部分文字列が１つも検索できなかった場合には、0 を返します。
パラメータ
target | String | 文字列データ
piece | String | 検索する部分文字列群
condition | String | パターンマッチ条件キーワード("AND" or "OR")
返却値
Number 個数
size

static Number size (String target)

文字列長を取得します。

Unicode で扱われている文字列を [install_directory]/conf/imart.xml の server-charset で指定されているローカルの文字コード体系に変換した結果の文字列長を 返却します。
パラメータ
target String 文字列データ
返却値
Number 文字列のバイト数(単位は byte)


 ParameterManager オブジェクト

ParameterManagerオブジェクト。

システム共通パラメータ情報の取得を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.1
メソッドの概要
static String | getParameter (String paramName) パラメータの値を取得します。
static String[] | getParameterNames () パラメータ名の一覧を取得します。
メソッドの詳細
getParameter

static String getParameter (String paramName)

パラメータの値を取得します。

指定されたパラメータ名に一致するパラメータが存在しない場合は、null を返します。
パラメータ
paramName String パラメータ名
返却値
String パラメータの値
getParameterNames

static String[] getParameterNames ()

パラメータ名の一覧を取得します。

パラメータが定義されていない場合は空の配列を返します。
返却値
String[] パラメータ名の一覧


 PasswordHistoryInfo オブジェクト

パスワード履歴管理情報オブジェクト。

パスワード履歴管理情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
Date | date 更新日付。 | 通常
String | password パスワード。 | 通常
プロパティの詳細
date

Date date

更新日付。
password

String password

パスワード。


 PasswordHistoryManager オブジェクト

パスワード履歴管理情報オブジェクト。

パスワード履歴管理情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PasswordHistoryManager (String groupId)
コンストラクタ。
メソッドの概要
Boolean | addPasswordHistory (String userId ,String password) パスワード履歴の追加。
PasswordHistoryResultInfo | checkPasswordHistory (String userId ,String password) パスワードの入力チェック。
Boolean | clearPasswordHistories () パスワード履歴の消去。
Boolean | clearPasswordHistory (String userId) 指定ユーザのパスワード履歴の消去。
String | createPassword (String count) パスワードをランダムに生成。
PasswordHistoryInfo | getLatestPasswordHistory (String userId) 最新のパスワードと更新日付を取得。
Number | getPasswordExpireLimit () 設定したパスワードの有効期限を取得。
Array | getPasswordHistories (String userId) パスワード履歴を取得。
Number | getPasswordHistoryCount (String groupId ,String userId) パスワード履歴数を取得。
Number | getPasswordHistoryManagedCount () 世代管理数を取得。
String | getPasswordPage () パスワード変更画面のＵＲＬを取得。
Boolean | isForwardInitialPage () パスワード変更後の画面遷移。
Boolean | isPasswordExpired (String userId ,String clientType ,Date date) パスワード有効期限切れかどうかの判定。
Boolean | isPasswordHistoryManaged () 履歴管理の有無。
Boolean | verifyPasswordHistory (String userId ,Number remain) ユーザのパスワードを消去。
コンストラクタの詳細
PasswordHistoryManager

PasswordHistoryManager (String groupId)
コンストラクタ。

パスワード履歴管理オブジェクトを生成します。
パラメータ
groupId String ログイングループID
導入されたバージョン：6.0
メソッドの詳細
addPasswordHistory

Boolean addPasswordHistory (String userId ,String password)

パスワード履歴の追加。

指定ユーザの入力パスワードをデータベースに追加します。
パラメータ
userId | String | ユーザID
password | String | パスワード
返却値
Boolean 履歴の追加に成功(true) / 履歴の追加に失敗(false)
導入されたバージョン：6.0
checkPasswordHistory

PasswordHistoryResultInfo checkPasswordHistory (String userId ,String password)

パスワードの入力チェック。

パスワードの入力チェックを行います。
パラメータ
userId | String | ユーザID
password | String | パスワード
返却値
PasswordHistoryResultInfo パスワード履歴チェック結果オブジェクト
導入されたバージョン：6.0
clearPasswordHistories

Boolean clearPasswordHistories ()

パスワード履歴の消去。

引数のログイングループのパスワード履歴をすべて消去します。
返却値
Boolean 履歴の消去に成功(true) / 履歴の消去に失敗(false)
導入されたバージョン：6.0
clearPasswordHistory

Boolean clearPasswordHistory (String userId)

指定ユーザのパスワード履歴の消去。

引数のユーザのパスワード履歴を消去します。
パラメータ
userId String ユーザID
返却値
Boolean 履歴の消去に成功(true) / 履歴の消去に失敗(false)
導入されたバージョン：6.0
createPassword

String createPassword (String count)

パスワードをランダムに生成。

引数の値の長さのパスワードをランダムに生成します。
呼出し毎に異なるパスワードを生成します。
パラメータ
count String パスワードの長さ
返却値
String 生成されたパスワード
導入されたバージョン：6.0
getLatestPasswordHistory

PasswordHistoryInfo getLatestPasswordHistory (String userId)

最新のパスワードと更新日付を取得。

指定ユーザの最新パスワードと更新日付を取得します。
パラメータ
userId String ユーザID
返却値
PasswordHistoryInfo パスワード履歴情報オブジェクト
エラー発生時はNULLを返します。
導入されたバージョン：6.0
getPasswordExpireLimit

Number getPasswordExpireLimit ()

設定したパスワードの有効期限を取得。

パラメータで設定したパスワードの有効期限日数を取得します。
取得に失敗した場合は（-1）が返却されます。
返却値
Number パスワード有効期限日数
導入されたバージョン：6.0
getPasswordHistories

Array getPasswordHistories (String userId)

パスワード履歴を取得。

指定ユーザのパスワード履歴を取得します。
パラメータ
userId String ユーザID
返却値
Array 指定ユーザのパスワード履歴情報オブジェクトの一覧
  エラー発生時はNULLを返します。
導入されたバージョン：6.0
getPasswordHistoryCount

Number getPasswordHistoryCount (String groupId ,String userId)

パスワード履歴数を取得。

指定ユーザのパスワード履歴数を取得します。
取得に失敗した場合は（-1）が返却されます。
パラメータ
groupId | String | グループID
userId | String | ユーザID
返却値
Number パスワード履歴数
導入されたバージョン：6.0
getPasswordHistoryManagedCount

Number getPasswordHistoryManagedCount ()

世代管理数を取得。

パスワードの世代管理数を取得します。
取得に失敗した場合は（-1）が返却されます。
返却値
Number パスワード世代管理数
導入されたバージョン：6.0
getPasswordPage

String getPasswordPage ()

パスワード変更画面のＵＲＬを取得。

パスワード変更画面のＵＲＬを取得します。
返却値
String パスワード変更画面のＵＲＬ
導入されたバージョン：6.0
isForwardInitialPage

Boolean isForwardInitialPage ()

パスワード変更後の画面遷移。

パスワードの有効期限切れによるパスワード再設定後、ログイン画面に戻るか、ログイン処理を継続してログインするかを判定します。
返却値
Boolean true：ログイン画面に戻る / false：ログイン処理を継続してログインする
導入されたバージョン：6.0
isPasswordExpired

Boolean isPasswordExpired (String userId ,String clientType ,Date date)

パスワード有効期限切れかどうかの判定。

パスワード有効期限を判定します。

パラメータ
userId | String | ユーザID
clientType | String | クライアントタイプ
date | Date | パスワードのチェックの基準となる日付。省略された場合、現在日付が利用されます。
返却値
Boolean true : パスワード有効期限切れ / false : パスワード有効期限内
導入されたバージョン：6.0
isPasswordHistoryManaged

Boolean isPasswordHistoryManaged ()

履歴管理の有無。

履歴管理を行うかどうか判定します。
返却値
Boolean ture：履歴管理を行う / false：履歴管理を行わない
導入されたバージョン：6.0
verifyPasswordHistory

Boolean verifyPasswordHistory (String userId ,Number remain)

ユーザのパスワードを消去。

引数 remain の値分残してユーザの履歴を消去します。
引数 remain が0以下の場合、履歴をすべて消去します。
パラメータ
userId | String | ユーザID
remain | Number | 残す履歴の数
返却値
Boolean 履歴の消去に成功(true / 履歴の消去に失敗(false)
導入されたバージョン：6.0


 PasswordHistoryResultInfo オブジェクト

パスワード履歴チェック結果オブジェクト。

パスワード履歴チェック結果オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | detail 詳細メッセージ。 | 通常
String | message メッセージ。 | 通常
Boolean | success パスワードチェックフラグ。 | 通常
プロパティの詳細
detail

String detail

詳細メッセージ。
message

String message

メッセージ。
success

Boolean success

パスワードチェックフラグ。


 Permanent オブジェクト

永続情報操作オブジェクト。

各リクエスト間、各クライアント間、および各サーバ間で共有の値を操作するＡＰＩを持つオブジェクトです。
値は Permanent Data Service で保管されるため、 システム内のすべてのプログラムにおいて値を共有可能です。
値にはセッションタイムアウトが存在しないので、永続的に保存されるます。
また、値の保存はファイルで行われるので、明示的な削除が行われない限り永久的に保存されます。
バージョン：1.0
導入されたバージョン：2.0
コンストラクタの概要
Permanent (String domain ,String group)
コンストラクタ。
メソッドの概要
Object | elements () カテゴリ内のすべての設定済みデータを取得します。
static Array | entries (String domain) カテゴリ・キーの一覧を取得します。
Object | extinction () カテゴリ・データを削除します。
Object | get (String key) カテゴリ内の指定保存キーにマップされているデータを取得します。
Array | keys () カテゴリ内の保存キーの一覧を取得します。
Object | remove (String key) カテゴリ内の指定保存キーとマップされているデータを削除します。
Object | set (String key ,Object value) カテゴリ内の指定保存キーで指定データを保存します。
コンストラクタの詳細
Permanent

Permanent (String domain ,String group)
コンストラクタ。

domain および group で解決される一意のカテゴリに対するデータ操作オブジェクトを提供します。
引数 domain は、データファイルの保存先ディレクトリ名称として利用されるので、ＯＳ環境に依存したファイル命名規則に準じた文字列を指定する必要があります。
domain がファイル命名規則に違反した場合は、正しくデータを入出力できません。
このインスタンスで操作されるデータは、Permanent Data Service の インストールディレクトリ/treasure/box/articles/ 以下に保存されます。
パラメータ
domain | String | 保存先ディレクトリ名
group | String | カテゴリ名称
メソッドの詳細
elements

Object elements ()

カテゴリ内のすべての設定済みデータを取得します。

コンストラクタで指定されたカテゴリに対して設定済みのすべてのデータを返却します。
返却オブジェクトは、保存キーがプロパティ名称で保存キーにマップされているデータが該当するプロパティの値として保存されます。
返却値
Object カテゴリ内の保存データ群
entries

static Array entries (String domain)

カテゴリ・キーの一覧を取得します。

domain に含まれる設定済みのカテゴリ・キーの一覧を返却します。
カテゴリの設定順と配列内のキーの格納順は保証されません。
パラメータ
domain String 保存先ディレクトリ名称
返却値
Array カテゴリ・キーの一覧（Stringの配列）
extinction

Object extinction ()

カテゴリ・データを削除します。

コンストラクタで指定されたカテゴリに対して設定済みのすべてのデータを削除すると共にカテゴリ自身を削除します。
削除に成功した場合は、削除されたカテゴリ内データ群を返却します。
削除できなかった場合は、空のオブジェクトを返却します。
返却オブジェクトは、保存キーがプロパティ名称で保存キーにマップされているデータが該当するプロパティの値として保存されます。
返却値
Object 削除したカテゴリ・データ群
get

Object get (String key)

カテゴリ内の指定保存キーにマップされているデータを取得します。

コンストラクタで指定されたカテゴリ内において指定保存キーにマップされているデータを取得します。
指定保存キーに対応するキーが存在しない場合 null を返却します。
パラメータ
key String 値へのキーコード
返却値
Object 保存キーにマップされているデータ
keys

Array keys ()

カテゴリ内の保存キーの一覧を取得します。

コンストラクタで指定されたカテゴリに対してすべての設定済みの保存キーを返却します。
保存キーの設定順と配列内の保存キーの格納順は保証されません。
返却値
Array カテゴリ内の保存キー一覧（Stringの配列）
remove

Object remove (String key)

カテゴリ内の指定保存キーとマップされているデータを削除します。

コンストラクタで指定されたカテゴリ内において指定保存キーにマップされているデータと指定保存キーを削除します。
返却値は削除されたデータを返却します。
指定保存キーにマップされたデータが存在しない場合は null を返却します。
パラメータ
key String 値へのキーコード
返却値
Object 保存キーにマップされていた値
set

Object set (String key ,Object value)

カテゴリ内の指定保存キーで指定データを保存します。

コンストラクタで指定されたカテゴリに対して指定保存キーを指定データにマップする形で保存します。
パラメータ
key | String | 保存キー
value | Object | 保存対象データ
返却値
Object 指定されたキーに関連した以前の値。キーが新しいものの場合は null。


 PermissionManager オブジェクト

パーミッションマネージャクラス。

パーミッションを生成するためのマネージャクラスです。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
PermissionManager (String groupId)
コンストラクタ。
メソッドの概要
Array | doSelection (Object category ,Object infos) 選択用情報を利用して選別された情報のリストを返却します。
Array | getCategories () 設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
コンストラクタの詳細
PermissionManager

PermissionManager (String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
doSelection

Array doSelection (Object category ,Object infos)

選択用情報を利用して選別された情報のリストを返却します。
返却される情報のリストの各要素はJavaBeansの規格に準ずるオブジェクトです。
パラメータ
category Object カテゴリ
設定XMLファイルで定義されています。
infos Object 選択用情報
この情報を利用して、選別された情報のリストを作成して返却します。
文字列(String)または文字列の配列(Array)を指定します。
返却値
Array 選別された情報リスト
カテゴリが存在しなかった場合は、nullを返却します。
getCategories

Array getCategories ()

設定XMLファイルで定義されているすべてのカテゴリ名を返却します。
返却値
Array カテゴリ名配列
導入されたバージョン：5.0


 PlainPostDetailInfo オブジェクト

非構造化役職詳細情報オブジェクト。
非構造化役職詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

非構造化役職詳細情報オブジェクトは１つのオブジェクトの中で、役職についての期間および言語に関する情報を扱います。
バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
Date | endDate 有効期間終了日時。 | 通常
String | locale 役職名に対する言語(ja, en等のロケールID)。 | 通常
String | notes 備考。 | 通常
String | postCode 役職コード。 | 通常
String | postName 役職名。 | 通常
Number | sortKey ソートキー。 | 通常
Date | startDate 有効期間開始日時。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
endDate

Date endDate

有効期間終了日時。
locale

String locale

役職名に対する言語(ja, en等のロケールID)。
notes

String notes

備考。
postCode

String postCode

役職コード。
postName

String postName

役職名。
sortKey

Number sortKey

ソートキー。
startDate

Date startDate

有効期間開始日時。


 PortletManager オブジェクト

PortletManagerオブジェクト。

ポートレットに関連する情報の参照、更新を行うマネージャオブジェクトです。

ポートレット情報を操作するオブジェクトの構成は以下の通りです。
ポートレット情報オブジェクト
ポートレット情報
オブジェクト
(Object)
portletCode [必須] ポートレットコード (String)
application アプリケーション名 (String)
portletName [必須] ポートレット名 (String)
pageKind [必須] ページ種別 (String)
指定できるページ種別の値は以下のいずれか
・pagebase ：プレゼンテーションページ
・jsp ：Servlet/JSP
・internet ：インターネット
・framework ：im-J2EE Service Framework
・menu ：メニューリンク
・rss ：RSS
ページ種別で
固有の属性 		pagebase
jsp
internet 		url [必須] ページURL(String)
argument ページ引数 (String)
framework | applicationId [必須] アプリケーションID (String)
serviceId [必須] サービスID (String)
argument ページ引数 (String)
menu | menuLinkSetCode [必須] メニューリンクセットコード (String)
rss | rssUrl [必須] RSSのURL (String)
parserKey [必須] RSS解析バージョンのキー情報 (String)
%StrageService%/portal/rss.xmlに定義された
RSS解析パーサーのIDを指定する。
具体的には、parser-config/parser/idの要素を指定する。
インストール時の定義は、rss10またはrss20。
proxyHost プロキシサーバのホスト名 (String)
proxyPort プロキシサーバのポート番号 (Number)
設定されていない場合、-1を返却します。
titleBar タイトルバーを表示するかどうか (Boolean)
デフォルト値は true (タイトルバーを表示する)
cacheTime キャッシュ時間 (Number)
デフォルト値は 0 (キャッシュ設定なし)
explain 説明 (String)
unit 表示単位 (String)
指定できる値は以下のいずれか
・null ：表示単位の指定なし (デフォルト値)
・c ：パーセント
・p ：ピクセル
width 表示単位に対する幅 (Number)
デフォルト値は 0
height 表示単位に対する高さ (Number)
デフォルト値は 0
recordUserCode 最終更新ユーザコード (String)
recordDate 最終更新日 (Date)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクトの data 属性は検索処理が成功 (error ステータスが false) の場合にのみ定義されます。
data属性には、呼び出されたメソッドの結果に応じたオブジェクトが設定されます。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)
data 任意のオブジェクト　(検索処理の成功時のみ)

バージョン：1.0
導入されたバージョン：6.0
コンストラクタの概要
PortletManager (String groupId)
コンストラクタ
メソッドの概要
Boolean | deletePortlet (Object portlet) ポートレット情報を削除します。
Object | getPortlet (String portletCode ,String pageKind) すでに登録済のポートレット情報を取得します。
Object | getPortlets () すでに登録されているポートレット情報の一覧を取得します。
Boolean | setPortlet (Object portlet) ポートレット情報を登録します。
コンストラクタの詳細
PortletManager

PortletManager (String groupId)
コンストラクタ
パラメータ
groupId String ログイングループID
メソッドの詳細
deletePortlet

Boolean deletePortlet (Object portlet)

ポートレット情報を削除します。

パラメータ
portlet Object ポートレット情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
getPortlet

Object getPortlet (String portletCode ,String pageKind)

すでに登録済のポートレット情報を取得します。
検索結果は、処理結果オブジェクトのdata属性にポートレット情報オブジェクトが設定されます。
指定されたポートレット情報が存在しない場合は、data属性に null が設定されます。
パラメータ
portletCode | String | ポートレットコード
pageKind | String | ページ種別
返却値
Object 処理結果オブジェクト
getPortlets

Object getPortlets ()

すでに登録されているポートレット情報の一覧を取得します。

検索結果は、処理結果オブジェクトのdata属性にポートレット情報オブジェクトの配列 (Array) が設定されます。
ポートレット情報を1件も取得できなかった場合は、data属性に要素数が 0 の配列 (Array) が設定されます。
返却値
Object 処理結果オブジェクト
setPortlet

Boolean setPortlet (Object portlet)

ポートレット情報を登録します。

指定されたポートレット情報が存在ない場合は新規登録します。
すでに存在する場合は更新を行います。
パラメータ
portlet Object ポートレット情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 PostDetailInfo オブジェクト

役職詳細情報オブジェクト。
役職詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

役職詳細情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
役職詳細情報オブジェクト
役職情報
オブジェクト
(Object)
companyCode 会社コード (String)
postCode 役職コード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name 役職名 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | companyCode 会社コード。 | 通常
String | notes 備考。 | 通常
String | postCode 役職コード。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].name 役職名。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
プロパティの詳細
companyCode

String companyCode

会社コード。
notes

String notes

備考。
postCode

String postCode

役職コード。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].name

String terms[0..*].locales[ロケール].name

役職名。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。


 PostInfo オブジェクト

役職情報オブジェクト。

役職情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.companyCode = "";
   obj.postCode = "";
オブジェクト作成方法(JSON方式)
   {
     "companyCode" : "",
     "postCode"    : ""
   }

プロパティの概要
String | companyCode [必須]会社コード 。 | 通常
String | postCode [必須]役職コード 。 | 通常
プロパティの詳細
companyCode

String companyCode

[必須]会社コード 。
postCode

String postCode

[必須]役職コード 。


 PrivateGroupAttachInfo オブジェクト

プライベートグループ所属情報オブジェクト。
プライベートグループ所属情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | ownerCode 所有者コード。 | 通常
String | privateGroupCode プライベートグループコード。 | 通常
Number | sortKey ソートキー。 | 通常
String | userCode ユーザコード。 | 通常
プロパティの詳細
ownerCode

String ownerCode

所有者コード。
privateGroupCode

String privateGroupCode

プライベートグループコード。
sortKey

Number sortKey

ソートキー。
userCode

String userCode

ユーザコード。


 PrivateGroupInfo オブジェクト

プライベートグループ情報オブジェクト。
プライベートグループ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | name プライベートグループ名。 | 通常
String | nameEnglish プライベートクループ名英字。 | 通常
String | nameSyllabary プライベートグループ名カナ。 | 通常
String | notes 備考。 | 通常
String | ownerCode 所有者コード。 | 通常
String | privateGroupCode プライベートグループコード。 | 通常
Number | sortKey ソートキー。 | 通常
プロパティの詳細
name

String name

プライベートグループ名。
nameEnglish

String nameEnglish

プライベートクループ名英字。
nameSyllabary

String nameSyllabary

プライベートグループ名カナ。
notes

String notes

備考。
ownerCode

String ownerCode

所有者コード。
privateGroupCode

String privateGroupCode

プライベートグループコード。
sortKey

Number sortKey

ソートキー。


 PrivateGroupManager オブジェクト

PrivateGroupManagerオブジェクト。

プライベートグループ情報の更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
PrivateGroupManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addPrivateGroup (PrivateGroupInfo group) プライベートグループを登録します。
ResultInfo | deleteMember (PrivateGroupAttachInfo groupAttach) プライベートグループから人員をはずします。
ResultInfo | deletePrivateGroup (PrivateGroupInfo group) 登録済のプライベートグループ情報を削除します。
ResultInfo | getMember (String ownerCode ,String privateGroupCode [,Date date]) 指定されたプライベートグループに所属する人員を取得します。
ResultInfo | getPrivateGroup (String ownerCode ,String privateGroupCode) プライベートグループの詳細情報を取得します。
ResultInfo | getPrivateGroups (String ownerCode) 指定されたユーザが持つプライベートグループをすべて取得します。
ResultInfo | setMember (PrivateGroupAttachInfo groupAttach) プライベートグループに人員を割り当てます。
ResultInfo | updatePrivateGroup (PrivateGroupInfo group) 登録済のプライベートグループ情報を更新します。
コンストラクタの詳細
PrivateGroupManager

PrivateGroupManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addPrivateGroup

ResultInfo addPrivateGroup (PrivateGroupInfo group)

プライベートグループを登録します。

パラメータ
group PrivateGroupInfo プライベートグループ情報
返却値
ResultInfo 処理結果オブジェクト
deleteMember

ResultInfo deleteMember (PrivateGroupAttachInfo groupAttach)

プライベートグループから人員をはずします。

指定された人員の情報が存在しない場合は処理失敗となります。
パラメータ
groupAttach PrivateGroupAttachInfo プライベートグループ所属情報
返却値
ResultInfo 処理結果オブジェクト
deletePrivateGroup

ResultInfo deletePrivateGroup (PrivateGroupInfo group)

登録済のプライベートグループ情報を削除します。

指定されたプライベートグループの情報が存在しない場合は処理失敗となります。
パラメータ
group PrivateGroupInfo プライベートグループ情報
返却値
ResultInfo 処理結果オブジェクト
getMember

ResultInfo getMember (String ownerCode ,String privateGroupCode [,Date date])

指定されたプライベートグループに所属する人員を取得します。

ユーザ情報は指定された日付で有効なユーザのみを取得します。
日付が指定されない場合は、システム日付で有効なユーザを取得します。
パラメータ
ownerCode | String | 所有者ユーザコード
privateGroupCode | String | プライベートグループコード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクトの data属性にユーザ情報オブジェクトの配列が設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。
導入されたバージョン：6.1
getPrivateGroup

ResultInfo getPrivateGroup (String ownerCode ,String privateGroupCode)

プライベートグループの詳細情報を取得します。

パラメータ
ownerCode | String | 所有者ユーザコード
privateGroupCode | String | プライベートグループコード
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクトの data属性にプライベートグループ情報オブジェクトが設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。
導入されたバージョン：6.1
getPrivateGroups

ResultInfo getPrivateGroups (String ownerCode)

指定されたユーザが持つプライベートグループをすべて取得します。
パラメータ
ownerCode String 所有者ユーザコード
返却値
ResultInfo 処理結果オブジェクト。
検索結果は、処理結果オブジェクトの data属性にプライベートグループ情報オブジェクトの配列が設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。
導入されたバージョン：6.1
setMember

ResultInfo setMember (PrivateGroupAttachInfo groupAttach)

プライベートグループに人員を割り当てます。

パラメータ
groupAttach PrivateGroupAttachInfo プライベートグループ所属情報
返却値
ResultInfo 処理結果オブジェクト
updatePrivateGroup

ResultInfo updatePrivateGroup (PrivateGroupInfo group)

登録済のプライベートグループ情報を更新します。

パラメータ
group PrivateGroupInfo プライベートグループ情報
返却値
ResultInfo 処理結果オブジェクト


 Procedure オブジェクト

プロシージャクラス。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static void define (String name ,Object func)
ＪＳ関数（オブジェクト等）を設定します。
メソッドの詳細
define

static void define (String name ,Object func)

ＪＳ関数（オブジェクト等）を設定します。
関数を登録。以後 Procedure.name() で利用可能。
関数以外も登録可能（オブジェクトなど）。
パラメータ
name | String | 設定プロパティ名称（文字列）
func | Object | JS関数
返却値
void


 Procedure.age オブジェクト

推奨されていません。代替オブジェクトはありません。
年齢計算をするライブラリです。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static Number | get (Date datBirthday) 推奨されていません。代替メソッドはありません。
static Number | getReal (Date datBirthday) 推奨されていません。代替メソッドはありません。
メソッドの詳細
get

static Number get (Date datBirthday)

推奨されていません。代替メソッドはありません。
満年齢を計算します。
誕生日を渡すと満年齢を求めて返します。
返却値である満年齢は、年月の小数型で、小数点以下は１２進法 の形で返されます。
例）14ヶ月 → 1.02年
23ヶ月 → 1.11年

パラメータ
datBirthday Date 誕生日
返却値
Number 年齢
getReal

static Number getReal (Date datBirthday)

推奨されていません。代替メソッドはありません。
実年齢を計算します。
返却値である実年齢は年月の小数型で、小数点以下は１２進法の形で返します。
例）14ヶ月 → 1.02年
23ヶ月 → 1.11年
実年齢とは、４月になると年を一つカウントする方式。
パラメータ
datBirthday Date 誕生日
返却値
Number 年齢


 Procedure.imode オブジェクト

推奨されていません。代替オブジェクトはありません。
i-modeオブジェクト。
i-modeアプリで使用する関数です。
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static Number | checkAbsence (String user_cd) 推奨されていません。代替メソッドはありません。
static Boolean | isDoCoMo () 推奨されていません。代替メソッドはありません。
static Object | sendMail (Object userObj ,Object cc ,String subject ,String body ,Object header) 推奨されていません。代替メソッドはありません。
メソッドの詳細
checkAbsence

static Number checkAbsence (String user_cd)

推奨されていません。代替メソッドはありません。
ユーザーの状態(会社内/外出)を取得する。
パラメータ
user_cd String 送り先のユーザーコード
返却値
Number 0:会社内 / 1:外出中 / -1:未設定
isDoCoMo

static Boolean isDoCoMo ()

推奨されていません。代替メソッドはありません。
ユーザーエージェントがi-modeであるかを判定します。
i-modeであれば「真」を、
それ以外(NetscapeNavigatorやInternetExplorerなど) であれば「偽」を返す。
返却値
Boolean 真:i-mode/偽：i-mode以外
sendMail

static Object sendMail (Object userObj ,Object cc ,String subject ,String body ,Object header)

推奨されていません。代替メソッドはありません。
送り先のユーザーの状態(会社内/外出)によって送るアドレスを切り替えて
(通常のアドレス/ i-mode用アドレス)送信する。
パラメータ
userObj Object オブジェクト型配列
├ user:ユーザーコード
└ type:送信方法(0:通常アドレス 1:i-modeアドレス 2:外出設定による)
cc | Object | userObjと同じ
subject | String | メールの題目
body | String | 本文
header | Object | メールヘッダ情報（任意）
返却値
Object エラー・オブジェクト
├ Success: メール送信の成否(真値:正常終了 偽値:エラー終了)
├ ErrCode: エラーコード(APIリスト メール連携モジュール参照)
└ ErrMessage:エラーメッセージ


 Procedure.upload オブジェクト

推奨されていません。代替のオブジェクトはありません。
ファイルアップロードオブジェクト。

機能概要

ファイルアップロード・モジュールは、クライアントにあるファイルを サーバーに対して送信するための機能です。
アップロードには、HTTP プロトコルを利用します。

プレゼンテーションページとの連携

プレゼンテーション・ページでは、以下のようにフォームを構築します。
<IMART type='form' method='POST' enctype='multipart/form-data'>
    <INPUT type='file'>
    <INPUT type='submit'>
</IMART>

情報の取得方法

通常のリンクやフォームと同様に、ファンクションコンテナ内において request オブジェクトにてフォームの内容を取得できます。

注意事項

ファイルアップロード・モジュールは、ブラウザからアップロードされたファイルの内容をデータとして取得するための機能です。
アップロードされたファイルがサーバー上に保存されるわけではありません。
ファイルアップロード用のフォームからのデータは、文字コード変換が一切おこりません。
ファイルの内容や、それに付随する他のコントロールからのデータも、すべてローカルの文字コード体系(SYSTEM_CLIENT_CHARSET)となっています。
これらのデータをファンクション・コンテナ内で扱う場合には、Unicode 体系への明示的な文字コード変換が必要です
(Unicode への変換には Unicode API を利用して下さい)。
バージョン：1.0
導入されたバージョン：2.1
メソッドの概要
static String getPath (String query ,String name)
推奨されていません。RequestParameter#getFileName()に置換えられました。
メソッドの詳細
getPath

static String getPath (String query ,String name)

推奨されていません。RequestParameter#getFileName()に置換えられました。
アップロードファイル名を取得します。
ファイルアップロード時の受信（アップロード）したファイルのファイル名を取得します。
引数 query には、request.query() の返却値を渡してください。
引数 name には、ファイルアップロードのフォーム内にある <INPUT type='file'>
のコントロール名称（name 属性値）を指定して下さい。
指定されたコントロール名称に該当するファイル名を返却します。
指定のコントロール名称が間違っている場合の動作は未定義です。
また、アップロードされたファイルのパスに空白文字が含まれている場合
ファイル名を正しく取得する事ができません。
パラメータ
query | String | ファイルアップロード時のＵＲＬクエリー
name | String | ファイルアップロードコントロールのコントロール名称
返却値
String ファイル名


 Procedure.AppCommonUtil オブジェクト

アプリケーション共通マスタで使用する共通関数です。
※注意 このクラスのメソッドはアプリケーション開発で使う必要はありません。

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | addTime (String dateString) YYYY/MM/DD形式の文字列に時刻(00:00:00)を付加します。
static String | formatDate (String dateString) 日付型文字列をイントラマートで定義された日付フォーマットに変換します。
static String | formatMsg (String msg) 終了日付を修正し、メッセージの体裁を整えます。
static String | getLoginGroup () ログイングループIDを取得します。
static String | getOffsetDate (String strDate ,Number nOffset) 引数strDateにstrOffsetの日数分、日付をずらします。
static String | getString (String value ,String substitute) 文字列のチェックをします。
static String | getSystemDate () システム日付を文字列型で返します。
static Object | getTransactionError () トランザクション処理失敗時の汎用的なエラー情報を返します。
static String | getUser () ログインユーザIDを取得します。
static String | getUserLocale () ユーザロケールを取得します。
static String | removeTime (String dateString) YYYY/MM/DD|hh:mm:ss形式の文字列から時刻(00:00:00)を除去します。
static String | setLineFeedCode (String string) 改行文字を改行コードに変換します。
static Array | split (String string ,String sep) 文字列を分割して配列に格納して返します。
static Date | stringToDate (String dateString) YYYY/MM/DD形式の文字列をDate型オブジェクトに変換します。
static Object | validateTerms (Object terms) 期間の整合性をチェックします。
メソッドの詳細
addTime

static String addTime (String dateString)

YYYY/MM/DD形式の文字列に時刻(00:00:00)を付加します。

パラメータ
dateString String 日付を表す文字列
返却値
String 日付を表す文字列
formatDate

static String formatDate (String dateString)

日付型文字列をイントラマートで定義された日付フォーマットに変換します。

パラメータ
dateString String 日時を表す文字列
返却値
String 日時を表す文字列
formatMsg

static String formatMsg (String msg)

終了日付を修正し、メッセージの体裁を整えます。

パラメータ
msg String 終了日付を含んだメッセージ
返却値
String 終了日付を修正したメッセージ
getLoginGroup

static String getLoginGroup ()

ログイングループIDを取得します。
返却値
String ログイングループID
getOffsetDate

static String getOffsetDate (String strDate ,Number nOffset)

引数strDateにstrOffsetの日数分、日付をずらします。

パラメータ
strDate | String | 日付を表す文字列
nOffset | Number | オフセット日数
返却値
String オフセット後の日付を表す文字列
getString

static String getString (String value ,String substitute)

文字列のチェックをします。
第一引数で指定された文字列がNullまたは定義されていない場合に
第二引数で指定された文字列を返します。

パラメータ
value | String | チェック対象の文字列
substitute | String | 置換される文字列
返却値
String 文字列
getSystemDate

static String getSystemDate ()

システム日付を文字列型で返します。

返却値
String 日時を表す文字列
getTransactionError

static Object getTransactionError ()

トランザクション処理失敗時の汎用的なエラー情報を返します。

返却値
Object トランザクション処理失敗時のエラー情報
getUser

static String getUser ()

ログインユーザIDを取得します。
返却値
String ログインユーザID
getUserLocale

static String getUserLocale ()

ユーザロケールを取得します。
返却値
String ユーザロケール
removeTime

static String removeTime (String dateString)

YYYY/MM/DD|hh:mm:ss形式の文字列から時刻(00:00:00)を除去します。

パラメータ
dateString String 日時を表す文字列
返却値
String 日時を表す文字列
setLineFeedCode

static String setLineFeedCode (String string)

改行文字を改行コードに変換します。

パラメータ
string String 置換対象の文字列
返却値
String 改行コードに置換された文字列
split

static Array split (String string ,String sep)

文字列を分割して配列に格納して返します。

パラメータ
string | String | 文字列
sep | String | 区切り文字
返却値
Array 文字列を分割した配列
stringToDate

static Date stringToDate (String dateString)

YYYY/MM/DD形式の文字列をDate型オブジェクトに変換します。

パラメータ
dateString String 日時を表す文字列
返却値
Date Date型オブジェクト
validateTerms

static Object validateTerms (Object terms)

期間の整合性をチェックします。

パラメータ
terms Object 期間オブジェクト
返却値
Object チェック結果


 Procedure.RealNumber オブジェクト

推奨されていません。代替オブジェクトはありません。
小数演算を可能にするオブジェクトです。

使用例
ファンクションコンテナで
//変数 oRN を 2.1 で初期化
var oRN = new Procedure.RealNumber( 2.1 );
//減算 oRN - 0.9 を実行し、その数値データ(Number)を取得する。
var nAns = oRN.getSub(0.9).get();
//変数 oRN を 2.1 で初期化
var oRN = new Procedure.RealNumber( 2.1 );
//加算 oRN + 0.9 を実行し、その数字データ(String)を取得する。
var nAns = oRN.getAdd(0.9).toString();
バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static RealNumber | RealNumber (Number nTarget) 推奨されていません。代替メソッドはありません。
Number | get () 推奨されていません。代替メソッドはありません。
RealNumber | getAdd (Number nTarget) 推奨されていません。代替メソッドはありません。
RealNumber | getDiv (Number nTarget) 推奨されていません。代替メソッドはありません。
RealNumber | getMlt (Number nTarget) 推奨されていません。代替メソッドはありません。
RealNumber | getSub (Number nTarget) 推奨されていません。代替メソッドはありません。
String | toString () 推奨されていません。代替メソッドはありません。
メソッドの詳細
RealNumber

static RealNumber RealNumber (Number nTarget)

推奨されていません。代替メソッドはありません。
コンストラクタ・メソッド。
引数に指定した数値を表す実数オブジェクトのインスタンスを生成します。

パラメータ
nTarget Number 数値
返却値
RealNumber RealNumberオブジェクト
get

Number get ()

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データを取得します。
このオブジェクトのもつ数値情報を返します。

返却値
Number 数値データ
getAdd

RealNumber getAdd (Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと加法演算します。
このオブジェクトのもつ数値と足し算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
getDiv

RealNumber getDiv (Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと除法演算します。
このオブジェクトのもつ数値と割り算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
getMlt

RealNumber getMlt (Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと乗法演算します。
このオブジェクトのもつ数値と掛け算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
getSub

RealNumber getSub (Number nTarget)

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データと減法演算します。
このオブジェクトのもつ数値と引き算をします。
返却値は新たなインスタンスを生成して返すので、
もとの オブジェクト自体の値は変化しません。

パラメータ
nTarget Number 演算数値
返却値
RealNumber RealNumberオブジェクト
toString

String toString ()

推奨されていません。代替メソッドはありません。
オブジェクトの持つ数値データを文字列として取得します。
このオブジェクトのもつ数値情報を文字列で返します。

返却値
String 数値データ（文字列）


 Procedure.SearchCommonUtil オブジェクト

ユーザ検索で使用する共通関数です。
※注意 このクラスのメソッドはアプリケーション開発で使う必要はありません。

バージョン：1.0
導入されたバージョン：5.1
メソッドの概要
static Object | getAllDepartment (Object parameter) 指定された条件に一致する組織情報を取得します。
static Object | getAllPrivateGroup (Object parameter) 指定された条件に一致するプライベートグループ情報を取得します。
static Object | getAllPublicGroup (Object parameter) 指定された条件に一致するパブリックグループ情報を取得します。
static Object | getDepartmentStruct (Object parameter) 指定された組織から会社までの階層リストを返します。
static Object | getKeyList () 「あかさたな検索」で使用する検索キー情報を取得します。
static Object | getPublicGroupStruct (Object parameter) 指定されたグループからグループセットまでの階層リストを返します。
static Object | getRoleList (Object parameter) ロールの一覧を返します。
static Object | getSubordinateDepartment (Object parameter) 指定された組織の下位組織の一覧を取得します。
static Object | getSubordinatePublicGroup (Object parameter) 指定されたパブリックグループの下位グループの一覧を取得します。
static Object | getUser (Object parameter) 指定された条件に一致するユーザ一覧を取得します。
static Object | getUserFromDepartment (Object parameter) 組織に所属するユーザの一覧を取得します。
static Object | getUserFromPrivateGroup (Object parameter) プライベートグループに所属するユーザの一覧を取得します。
static Object | getUserFromPublicGroup (Object parameter) パブリックグループに所属するユーザの一覧を取得します。
static Object | getUserFromRole (Object parameter) ロールを保有するユーザの一覧を取得します。
static Object | getUserSearchDiscription (Object parameter) 検索画面に表示する条件(文字列)を返します。
メソッドの詳細
getAllDepartment

static Object getAllDepartment (Object parameter)

指定された条件に一致する組織情報を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object 組織情報を格納した配列
getAllPrivateGroup

static Object getAllPrivateGroup (Object parameter)

指定された条件に一致するプライベートグループ情報を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object プライベートグループ情報を格納した配列
getAllPublicGroup

static Object getAllPublicGroup (Object parameter)

指定された条件に一致するパブリックグループ情報を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object パブリックグループ情報を格納した配列
getDepartmentStruct

static Object getDepartmentStruct (Object parameter)

指定された組織から会社までの階層リストを返します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object 組織情報を格納した配列
getKeyList

static Object getKeyList ()

「あかさたな検索」で使用する検索キー情報を取得します。

返却値
Object 検索キー情報
getPublicGroupStruct

static Object getPublicGroupStruct (Object parameter)

指定されたグループからグループセットまでの階層リストを返します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object パブリックグループ情報を格納した配列
getRoleList

static Object getRoleList (Object parameter)

ロールの一覧を返します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ロール情報を格納した配列
getSubordinateDepartment

static Object getSubordinateDepartment (Object parameter)

指定された組織の下位組織の一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object 組織情報を格納した配列
getSubordinatePublicGroup

static Object getSubordinatePublicGroup (Object parameter)

指定されたパブリックグループの下位グループの一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object パブリックグループ情報を格納した配列
getUser

static Object getUser (Object parameter)

指定された条件に一致するユーザ一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ユーザ情報を格納した配列
getUserFromDepartment

static Object getUserFromDepartment (Object parameter)

組織に所属するユーザの一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ユーザ情報を格納した配列
getUserFromPrivateGroup

static Object getUserFromPrivateGroup (Object parameter)

プライベートグループに所属するユーザの一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ユーザ情報を格納した配列
getUserFromPublicGroup

static Object getUserFromPublicGroup (Object parameter)

パブリックグループに所属するユーザの一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ユーザ情報を格納した配列
getUserFromRole

static Object getUserFromRole (Object parameter)

ロールを保有するユーザの一覧を取得します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ユーザ情報を格納した配列
getUserSearchDiscription

static Object getUserSearchDiscription (Object parameter)

検索画面に表示する条件(文字列)を返します。

パラメータ
parameter Object 検索画面で設定されたパラメータ群
返却値
Object ロール情報を格納した配列


 PublicGroupAttachInfo オブジェクト

パブリックグループ所属情報オブジェクト。
パブリックグループ所属情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

パブリックグループ所属情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ所属情報オブジェクト
パブリックグループへの
所属情報
オブジェクト
(Object)
userCode ユーザコード (String)
publicGroupSetCode グループセットコード (String)
publicGroupCode グループコード (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | publicGroupCode グループコード。 | 通常
String | publicGroupSetCode グループセットコード。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
String | userCode ユーザコード。 | 通常
プロパティの詳細
publicGroupCode

String publicGroupCode

グループコード。
publicGroupSetCode

String publicGroupSetCode

グループセットコード。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
userCode

String userCode

ユーザコード。


 PublicGroupCategoryInfo オブジェクト

パブリックグループ分類区分情報オブジェクト。
パブリックグループ分類区分情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

パブリックグループ分類区分情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ分類区分情報オブジェクト
パブリックグループ
分類区分情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
publicGroupCode グループコード (String)
categoryClassCode 分類区分コード (String)
categoryCode 分類コード (String)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | categoryClassCode 分類区分コード。 | 通常
String | categoryCode 分類コード。 | 通常
String | publicGroupCode グループコード。 | 通常
String | publicGroupSetCode グループセットコード。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
プロパティの詳細
categoryClassCode

String categoryClassCode

分類区分コード。
categoryCode

String categoryCode

分類コード。
publicGroupCode

String publicGroupCode

グループコード。
publicGroupSetCode

String publicGroupSetCode

グループセットコード。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。


 PublicGroupDetailInfo オブジェクト

パブリックグループ詳細情報オブジェクト。
パブリックグループ詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

パブリックグループ詳細情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ詳細情報オブジェクト
パブリックグループ情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
publicGroupCode グループコード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name パブリックグループ名 (String)
nameSyllabary パブリックグループ名カナ (String)
nameEnglish パブリックグループ名英字 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | notes 備考。 | 通常
String | publicGroupCode グループコード。 | 通常
String | publicGroupSetCode グループセットコード。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].name パブリックグループ名。 | 通常
String | terms[0..*].locales[ロケール].nameEnglish パブリックグループ名英字。 | 通常
String | terms[0..*].locales[ロケール].nameSyllabary パブリックグループ名カナ。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
プロパティの詳細
notes

String notes

備考。
publicGroupCode

String publicGroupCode

グループコード。
publicGroupSetCode

String publicGroupSetCode

グループセットコード。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].name

String terms[0..*].locales[ロケール].name

パブリックグループ名。
terms[0..*].locales[ロケール].nameEnglish

String terms[0..*].locales[ロケール].nameEnglish

パブリックグループ名英字。
terms[0..*].locales[ロケール].nameSyllabary

String terms[0..*].locales[ロケール].nameSyllabary

パブリックグループ名カナ。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。


 PublicGroupInfo オブジェクト

パブリックグループ情報オブジェクト。

パブリックグループ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

オブジェクト作成方法
   var obj = new Object();
   obj.groupSetCode = "";
   obj.groupCode = "";
オブジェクト作成方法(JSON方式)
   {
     "groupSetCode" : "",
     "groupCode"    : ""
   }

プロパティの概要
String | groupCode [必須]グループコード 。 | 通常
String | groupSetCode [必須]グループセットコード 。 | 通常
プロパティの詳細
groupCode

String groupCode

[必須]グループコード 。
groupSetCode

String groupSetCode

[必須]グループセットコード 。


 PublicGroupManager オブジェクト

PublicGroupManagerオブジェクト。
パブリックグループに関連する情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
PublicGroupManager (String user ,String group)
コンストラクタ
メソッドの概要
ResultInfo | addGroupSet (PublicGroupSetDetailInfo groupSet) パブリックグループセットを登録します。
ResultInfo | addPublicGroup (PublicGroupDetailInfo publicGroup) パブリックグループを登録します。
ResultInfo | addVersion (PublicGroupVersionInfo version) パブリックグループセット構成バージョンを新規に登録します。
ResultInfo | copyVersion (String groupSet ,String srcVersion ,String destVersion ,Date startDate ,Date endDate) 登録済のパブリックグループセット構成バージョンの内容をコピーします。
ResultInfo | deleteGroupSet (PublicGroupSetDetailInfo groupSet) 登録済のパブリックグループセットを削除します。
ResultInfo | deleteMember (PublicGroupAttachInfo publicGroupAttach) パブリックグループから人員をはずします。
ResultInfo | deletePublicGroup (PubliGroupDetailInfo publicGroup) 登録済のパブリックグループ情報を削除します。
ResultInfo | deleteVersion (PublicGroupVersionInfo version) 登録済のパブリックグループセット構成バージョンを削除します。
ResultInfo | getAttachedPublicGroups (String userCode [,Date date]) ユーザが所属するパブリックグループの一覧を取得します。
ResultInfo | getMember (String publicGroupSetCode ,String publicGroupCode [,Date date]) パブリックグループに所属する人員の一覧を取得します。
ResultInfo | getPublicGroup (String publicGroupSetCode ,String publicGroupCode) パブリックグループの詳細情報を取得します。
ResultInfo | getPublicGroupAttach (String userCode ,String publicGroupSetCode ,String publicGroupCode) ユーザのパブリックグループへの所属情報を取得します。
ResultInfo | getPublicGroupStructs (String groupSet ,String publicGroup ,Date date ,String locale) パブリックグループの階層構造を取得します。
ResultInfo | getVersion (String publicGroupSetCode [,Date date]) パブリックグループセット構成バージョン情報を取得します。
ResultInfo | joinPublicGroup (String groupSet ,String parentGroup ,String publicGroup ,String version) パブリックグループ構成にパブリックグループを登録します。
ResultInfo | leavePublicGroup (String groupSet ,String publicGroup ,String version) パブリックグループ構成からパブリックグループ情報を離脱させます。
ResultInfo | movePublicGroup (String groupSet ,String parentGroup ,String publicGroup ,String version) パブリックグループ構成に登録済のパブリックグループ情報を移動します。
ResultInfo | removeCategoryDetail (PublicGroupCategoryInfo category) パブリックグループに対して指定された分類区分情報を削除します。
ResultInfo | setCategoryDetail (PublicGroupCategoryInfo category) パブリックグループに対して指定された分類区分情報を設定します。
ResultInfo | setMember (PublicGroupAttachInfo publicGroupAttach) パブリックグループに人員を割り当てます。
ResultInfo | updatePublicGroup (PublicGroupDetailInfo publicGroup) 登録済のパブリックグループ情報を更新します。
ResultInfo | updateVersion (PublicGroupVersionInfo version) 登録済のパブリックグループセット構成バージョンを更新します。
コンストラクタの詳細
PublicGroupManager

PublicGroupManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addGroupSet

ResultInfo addGroupSet (PublicGroupSetDetailInfo groupSet)

パブリックグループセットを登録します。

このメソッドを実行すると下記のような動作が行われます。
  1. パブリックグループセットを新規登録する。
  2. パブリックグループセットに対応するパブリックグループを新規登録する。
パラメータ
groupSet PublicGroupSetDetailInfo パブリックグループセット情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
addPublicGroup

ResultInfo addPublicGroup (PublicGroupDetailInfo publicGroup)

パブリックグループを登録します。

このメソッドを実行しただけではまだパブリックグループセットの パブリックグループ構成には追加されていません。
パブリックグループ構成に追加したい場合は、 joinPublicGroup(String, String, String, String)
を使用してください。
パラメータ
publicGroup PublicGroupDetailInfo パブリックグループ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
addVersion

ResultInfo addVersion (PublicGroupVersionInfo version)

パブリックグループセット構成バージョンを新規に登録します。

追加された構成バージョンのトップレベルには、パブリックグループセットが自動的に追加されます。
パラメータ
version PublicGroupVersionInfo パブリックグループ構成バージョン情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
copyVersion

ResultInfo copyVersion (String groupSet ,String srcVersion ,String destVersion ,Date startDate ,Date endDate)

登録済のパブリックグループセット構成バージョンの内容をコピーします。

コピー元のバージョンコードは登録済みのものを選択してください。
コピー先のバージョンコードは登録されていないものを選択してください。
パラメータ
groupSet | String | コピー元、コピー先のパブリックグループセット構成バージョンのグループセットコード
srcVersion | String | コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion | String | コピー先のパブリックグループセット構成バージョンのバージョンコード
startDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間開始日時
endDate | Date | コピー先のパブリックグループセット構成バージョンの有効期間終了日時
返却値
ResultInfo 処理結果オブジェクト
deleteGroupSet

ResultInfo deleteGroupSet (PublicGroupSetDetailInfo groupSet)

登録済のパブリックグループセットを削除します。

このメソッドを実行すると 指定されたパブリックグループセットに関連する全ての情報が削除されます。
パラメータ
groupSet PublicGroupSetDetailInfo パブリックグループセット情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteMember

ResultInfo deleteMember (PublicGroupAttachInfo publicGroupAttach)

パブリックグループから人員をはずします。
パラメータ
publicGroupAttach PublicGroupAttachInfo パブリックグループから外す人員の情報
返却値
ResultInfo 処理結果オブジェクト
deletePublicGroup

ResultInfo deletePublicGroup (PubliGroupDetailInfo publicGroup)

登録済のパブリックグループ情報を削除します。
パラメータ
publicGroup PubliGroupDetailInfo パブリックグループ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteVersion

ResultInfo deleteVersion (PublicGroupVersionInfo version)

登録済のパブリックグループセット構成バージョンを削除します。
指定されたパブリックグループセット構成バージョンが存在しない場合は処理失敗となります。
パラメータ
version PublicGroupVersionInfo パブリックグループ構成バージョン情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getAttachedPublicGroups

ResultInfo getAttachedPublicGroups (String userCode [,Date date])

ユーザが所属するパブリックグループの一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。
パラメータ
userCode | String | ユーザコード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクト の data属性にパブリックグループ情報オブジェクトの配列 (Array) として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

パブリックグループ情報オブジェクトに設定される期間化情報は、検索で使用された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。
導入されたバージョン：6.1
getMember

ResultInfo getMember (String publicGroupSetCode ,String publicGroupCode [,Date date])

パブリックグループに所属する人員の一覧を取得します。

日付が指定されない場合は、システム日付を含む期間の情報を取得します。
パラメータ
publicGroupSetCode | String | パブリックグループセットコード
publicGroupCode | String | パブリックグループコード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクト の data属性にユーザ情報オブジェクトの配列 (Array) として設定されます。
検索条件に一致するデータが存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

ユーザ情報オブジェクトに設定される期間化情報は、検索で使用された日付を含む期間の情報のみが設定されます。
また期間国際化情報には、ログインユーザのデフォルト言語の情報のみが設定されます。
導入されたバージョン：6.1
getPublicGroup

ResultInfo getPublicGroup (String publicGroupSetCode ,String publicGroupCode)

パブリックグループの詳細情報を取得します。
パラメータ
publicGroupSetCode | String | パブリックグループセットコード
publicGroupCode | String | パブリックグループコード
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクト の data属性にパブリックグループ情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。
導入されたバージョン：6.1
getPublicGroupAttach

ResultInfo getPublicGroupAttach (String userCode ,String publicGroupSetCode ,String publicGroupCode)

ユーザのパブリックグループへの所属情報を取得します。
パラメータ
userCode | String | ユーザコード
publicGroupSetCode | String | パブリックグループセットコード
publicGroupCode | String | パブリックグループコード
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクトの data属性にパブリックグループ所属情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。
導入されたバージョン：6.1
getPublicGroupStructs

ResultInfo getPublicGroupStructs (String groupSet ,String publicGroup ,Date date ,String locale)

パブリックグループの階層構造を取得します。

パラメータ
groupSet | String | グループセットコード
publicGroup | String | グループコード
date | Date | 日付
locale | String | 言語
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクトの data属性にパブリックグループの階層情報オブジェクトの配列 (Array) として設定されます。

指定された日付に該当するパブリックグループ構成バージョンがない時はエラーとなります。
また、パブリックグループ構成バージョンは存在するが該当するパブリックグループ情報が存在しない場合は、data属性に要素数が 0 の配列 (Array) が設定されます。
getVersion

ResultInfo getVersion (String publicGroupSetCode [,Date date])

パブリックグループセット構成バージョン情報を取得します。

日付が指定されない場合は、システム日付を含む期間のバージョン情報を取得します。
パラメータ
publicGroupSetCode | String | パブリックグループセットコード
date | Date | 日付 (省略可能)
返却値
ResultInfo 処理結果オブジェクト
検索結果は、処理結果オブジェクト の data属性にパブリックグループセット構成バージョン情報オブジェクトとして設定されます。
検索条件に一致するデータが存在しない場合は、data属性に null が設定されます。
導入されたバージョン：6.1
joinPublicGroup

ResultInfo joinPublicGroup (String groupSet ,String parentGroup ,String publicGroup ,String version)

パブリックグループ構成にパブリックグループを登録します。

新しく親となるパブリックグループと登録対象のパブリックグループは同一の
パブリックグループセットに所属している必要があります。
バージョンコードは登録済みのものを指定する必要があります。
親となるパブリックグループは、パブリックグループ内包に登録済みのものを指定する必要があります。

指定されたパブリックグループが対象のバージョンにおいて既に登録されているときは
このメソッドは使用できません。
パラメータ
groupSet | String | 上位パブリックグループと 新規登録されるパブリックグループが所属する パブリックグループセットのグループセットコード
parentGroup | String | 新規登録するパブリックグループの 上位となるパブリックグループのグループコード （またはパブリックグループセットのグループセットコード）
publicGroup | String | パブリックグループ情報 （パブリックグループセットに該当するパブリックグループは指定できない）
version | String | バージョンコード
返却値
ResultInfo 処理結果オブジェクト
leavePublicGroup

ResultInfo leavePublicGroup (String groupSet ,String publicGroup ,String version)

パブリックグループ構成からパブリックグループ情報を離脱させます。

このメソッドを実行すると、指定されたパブリックグループを 指定されたバージョンから削除します。
指定されたパブリックグループが子パブリックグループを持っていた場合、それらのパブリックグループも
再帰的にこのバージョンから削除されます。
このメソッドを実行してもパブリックグループ情報そのものは残ります。
指定されたパブリックグループがグループ構成に登録されていない場合は処理失敗となります。
パラメータ
groupSet | String | グループセットコード
publicGroup | String | 離脱させるパブリックグループのグループコード （パブリックグループセットに該当するパブリックグループは指定できない）
version | String | バージョンコード
返却値
ResultInfo 処理結果オブジェクト
movePublicGroup

ResultInfo movePublicGroup (String groupSet ,String parentGroup ,String publicGroup ,String version)

パブリックグループ構成に登録済のパブリックグループ情報を移動します。

新しく上位となるパブリックグループと移動対象のパブリックグループは同一のパブリックグループセットに
所属している必要があります。
また、パブリックグループ構成が循環するような移動はできません。
バージョンコードは登録済みのものを指定する必要があります。
パラメータ
groupSet | String | 上位パブリックグループと移動対象の パブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup | String | 上位パブリックグループのグループコード （またはパブリックグループセットのグループセットコード）
publicGroup | String | 移動するパブリックグループのグループコード （パブリックグループセットに該当するパブリックグループは指定できない）
version | String | バージョンコード
返却値
ResultInfo 処理結果オブジェクト
removeCategoryDetail

ResultInfo removeCategoryDetail (PublicGroupCategoryInfo category)

パブリックグループに対して指定された分類区分情報を削除します。

パラメータ
category PublicGroupCategoryInfo 削除するパブリックグループ分類区分情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setCategoryDetail

ResultInfo setCategoryDetail (PublicGroupCategoryInfo category)

パブリックグループに対して指定された分類区分情報を設定します。
パラメータ
category PublicGroupCategoryInfo 設定するパブリックグループ分類区分情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
setMember

ResultInfo setMember (PublicGroupAttachInfo publicGroupAttach)

パブリックグループに人員を割り当てます。

人員の割当情報がすでに設定されている場合は、パラメータで渡された情報で完全に上書きされます。
パラメータ
publicGroupAttach PublicGroupAttachInfo 割当人員の情報
返却値
ResultInfo 処理結果オブジェクト
updatePublicGroup

ResultInfo updatePublicGroup (PublicGroupDetailInfo publicGroup)

登録済のパブリックグループ情報を更新します。
パラメータ
publicGroup PublicGroupDetailInfo パブリックグループ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
updateVersion

ResultInfo updateVersion (PublicGroupVersionInfo version)

登録済のパブリックグループセット構成バージョンを更新します。
パラメータ
version PublicGroupVersionInfo パブリックグループ構成バージョン情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 PublicGroupSetDetailInfo オブジェクト

パブリックグループセット詳細情報オブジェクト。
パブリックグループセット詳細情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

パブリックグループセット詳細情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループセット詳細情報オブジェクト
パブリックグループセット情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
notes 備考 (String)
sortKey ソートキー (Number)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name パブリックグループセット名 (String)
nameSyllabary パブリックグループセット名カナ (String)
nameEnglish パブリックグループセット名英字 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | notes 備考。 | 通常
String | publicGroupSetCode グループセットコード。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].name パブリックグループセット名。 | 通常
String | terms[0..*].locales[ロケール].nameEnglish パブリックグループセット名英字。 | 通常
String | terms[0..*].locales[ロケール].nameSyllabary パブリックグループセット名カナ。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
プロパティの詳細
notes

String notes

備考。
publicGroupSetCode

String publicGroupSetCode

グループセットコード。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].name

String terms[0..*].locales[ロケール].name

パブリックグループセット名。
terms[0..*].locales[ロケール].nameEnglish

String terms[0..*].locales[ロケール].nameEnglish

パブリックグループセット名英字。
terms[0..*].locales[ロケール].nameSyllabary

String terms[0..*].locales[ロケール].nameSyllabary

パブリックグループセット名カナ。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。


 PublicGroupStructInfo オブジェクト

パブリックグループ階層情報オブジェクト。
パブリックグループ階層情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | name パブリックグループセット名 またはパブリックグループ名。 | 通常
String | publicGroupCode グループコード。 | 通常
String | publicGroupSetCode グループセットコード。 | 通常
プロパティの詳細
name

String name

パブリックグループセット名
またはパブリックグループ名。
publicGroupCode

String publicGroupCode

グループコード。
publicGroupSetCode

String publicGroupSetCode

グループセットコード。


 PublicGroupVersionInfo オブジェクト

パブリックグループ構成バージョン情報オブジェクト。

パブリックグループ構成バージョン情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

パブリックグループ構成バージョン情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
パブリックグループ構成バージョン情報オブジェクト
パブリックグループ
構成バージョン情報
オブジェクト
(Object)
publicGroupSetCode グループセットコード (String)
versionCode バージョンコード (String)
startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
notes 備考 (String)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Date | endDate 有効期間終了日時。 | 通常
String | notes 備考。 | 通常
String | publicGroupSetCode 会社コード。 | 通常
Date | startDate 有効期間開始日時。 | 通常
String | versionCode グループセットコード。 | 通常
プロパティの詳細
endDate

Date endDate

有効期間終了日時。
notes

String notes

備考。
publicGroupSetCode

String publicGroupSetCode

会社コード。
startDate

Date startDate

有効期間開始日時。
versionCode

String versionCode

グループセットコード。


 Request オブジェクト

リクエストオブジェクト。

クライアントからのリクエスト情報を保持するオブジェクトです。
このオブジェクトは、ブラウザからの要求があるたびに生成され、ファンクション・コンテナの init() 関数や action に対するバインド関数の実行時に関数引数として渡されます。

URL引数を取得する場合は、request.URL引数名で取得できます。
(request.getParameterValue(String name)と動作は同じです。)
バージョン：2.0
導入されたバージョン：2.0
メソッドの概要
Array | get (String key) 推奨されていません。Request.getParameterValues()に置き換えられました。
Object | getAttribute (String name) 指定された名前の属性値を返します。
Array | getAttributeNames () このリクエストで利用可能な属性名を含む配列型のオブジェクトを返します。
Number | getContentLength () リクエストコンテンツの長さを取得します。
String | getContentType () リクエストコンテンツタイプを取得します。
String | getCookie (String name) 指定の名前を持つクッキーの値を返します。
Array | getCookieNames () すべてのクッキーの名前の配列を返します。
Array | getCookies (String name) 指定の名前を持つすべてのクッキーの値の配列を返します。
String | getHeader (String name) 指定されたリクエストヘッダの値をStringとして返します。
Array | getHeaderNames () このリクエストに含まれる全てのヘッダ名の配列を返します。
Array | getHeaders (String name) 指定されたリクエストヘッダの全ての値をStringの配列として返します。
String | getMessageBody (String enc) メッセージボディに含まれているバイナリデータをStringとして返します。
String | getMessageBodyAsStream () メッセージボディに含まれているバイナリデータをStringとして返します。
String | getMessageBodyAsString () メッセージボディに含まれているデータをStringとして返します。
String | getMethod () このリクエストを生成したHTTPメソッドの名前を返します。
RequestParameter | getParameter (String name) 指定の名前をもつリクエストパラメータを返します。
Array | getParameterNames () すべてのリクエストパラメータ名を返します。
String | getParameterValue (String key) 指定のキーに該当する URL 引数データを返却します。
Array | getParameterValues (String key) 指定のキーに該当する URL 引数データ群を返却します。
String | getQueryString () リクエストされたURLのパスの後ろに含まれているクエリ文字列を返します。
String | query () 推奨されていません。Request.getMessageBodyAsStream()およびgetQueryString()に置き換えられました。
void | removeAttribute (String name) このリクエストから属性を削除します。
void | setAttribute (String name ,Object object) このリクエストに属性をセットします。
メソッドの詳細
get

Array get (String key)

推奨されていません。Request.getParameterValues()に置き換えられました。
指定のキーに該当する URL 引数データ群を返却します。

キーは、フォームのコントロール名称(name 属性)を指定します。
返却値は指定キーに該当するデータ(文字列)の個数と同等の要素を持つ配列です。
指定キーに該当する URL 引数が１つも存在しない場合は空の配列を返却します。
パラメータ
key String URL 引数設定名称
返却値
Array URL 引数データの配列
導入されたバージョン：2.0
getAttribute

Object getAttribute (String name)

指定された名前の属性値を返します。

指定された名前が存在しない場合は、null を返します。
パラメータ
name String 属性の名前を指定する String
返却値
Object 属性の値が含まれている Object。 指定された名前の属性が無い場合は null
導入されたバージョン：5.0
getAttributeNames

Array getAttributeNames ()

このリクエストで利用可能な属性名を含む配列型のオブジェクトを返します。

返却値
Array リクエストに付随する属性名を含む文字列からなる配列
導入されたバージョン：5.0
getContentLength

Number getContentLength ()

リクエストコンテンツの長さを取得します。

リクエストのメッセージボディ、あるいは、入力ストリームから読み込めるバイト長を返しますが、長さがわからない場合は -1 を返します。
HTTP Servlet では CGI 環境変数 CONTENT_LENGTH の値に相当します。
返却値
Number リクエストのメッセージボディの長さを表す整数値
導入されたバージョン：5.0
getContentType

String getContentType ()

リクエストコンテンツタイプを取得します。

リクエストに含まれるメッセージボディの MIME タイプを返しますが、タイプがわからない場合は null を返します。
HTTP Servlet では CGI 環境変数の CONTENT_TYPE の値に相当します。
返却値
String リクエストの MIME タイプの名前を含む String
導入されたバージョン：5.0
getCookie

String getCookie (String name)

指定の名前を持つクッキーの値を返します。

指定の名前を持つクッキーの値が複数あった場合、その中のどれかが返されます。
指定の名前をもつクッキーの値が存在しない場合、nullを返します。
リクエストに Cookie が付加されていない場合も null を返します。
パラメータ
name String クッキーの名前を表すString
返却値
String 指定された名前をもつ値を表すString
導入されたバージョン：5.0
getCookieNames

Array getCookieNames ()

すべてのクッキーの名前の配列を返します。

クッキーが一つも存在しない場合、空の配列を返します。
リクエストに Cookie が付加されていない場合は null を返します。
返却値
Array 指定された名前をもつ値の配列
導入されたバージョン：5.0
getCookies

Array getCookies (String name)

指定の名前を持つすべてのクッキーの値の配列を返します。

指定の名前をもつクッキーの値が存在しない場合、空の配列を返します。
リクエストに Cookie が付加されていない場合は null を返します。
パラメータ
name String クッキーの名前を表すString
返却値
Array 指定された名前をもつ値の配列
導入されたバージョン：5.0
getHeader

String getHeader (String name)

指定されたリクエストヘッダの値をStringとして返します。

指定した名前を持つヘッダが複数ある場合は、先頭のヘッダを返却します。
指定した名前を持つヘッダが存在しない場合はnullを返却します。
パラメータ
name String ヘッダ名を表すString
返却値
String 要求したヘッダの値を持つString
導入されたバージョン：5.0
getHeaderNames

Array getHeaderNames ()

このリクエストに含まれる全てのヘッダ名の配列を返します。

リクエストがヘッダを1つも持たない場合は空の配列を返します。
Servletがこのメソッドを用いることを Servletコンテナが禁止している場合はnullを返却します。
返却値
Array このリクエストとともに送信された全てのヘッダの名前の配列
導入されたバージョン：5.0
getHeaders

Array getHeaders (String name)

指定されたリクエストヘッダの全ての値をStringの配列として返します。

このリクエストが指定された名前のヘッダを持たない場合、 空の配列を返します。
コンテナがヘッダ情報へのアクセスを禁止している場合、 nullを返します。
パラメータ
name String ヘッダ名を表すString
返却値
Array リクエストヘッダの値を持つ配列
導入されたバージョン：5.0
getMessageBody

String getMessageBody (String enc)

メッセージボディに含まれているバイナリデータをStringとして返します。

返されるデータは、指定の文字エンコーディング名によってUnicode に変換されています。
パラメータ
enc String エンコーディング名
返却値
String メッセージボディ部を表すString
導入されたバージョン：5.0
getMessageBodyAsStream

String getMessageBodyAsStream ()

メッセージボディに含まれているバイナリデータをStringとして返します。

文字コード変換されません。バイナリデータ１バイトが１文字となります。
返却値
String メッセージボディ部を表すString
導入されたバージョン：5.0
getMessageBodyAsString

String getMessageBodyAsString ()

メッセージボディに含まれているデータをStringとして返します。

データは、ServletRequest のエンコーディング名によって Unicode に変換します。
返却値
String メッセージボディ部を表すString
導入されたバージョン：5.0
getMethod

String getMethod ()

このリクエストを生成したHTTPメソッドの名前を返します。

例えばGET、POST、PUTのような、HTTPメソッドの名前です。
返却値
String このリクエストを生成したメソッドの名前を表すString
導入されたバージョン：5.0
getParameter

RequestParameter getParameter (String name)

指定の名前をもつリクエストパラメータを返します。
パラメータが存在しない場合は、null を返します。

パラメータ
name String パラメータ名
返却値
RequestParameter パラメータ情報をもつオブジェクト
導入されたバージョン：5.0
getParameterNames

Array getParameterNames ()

すべてのリクエストパラメータ名を返します。

配列の各要素は、パラメータ名を表す String です。
返却値
Array パラメータ名の配列
導入されたバージョン：5.0
getParameterValue

String getParameterValue (String key)

指定のキーに該当する URL 引数データを返却します。

キーは、フォームのコントロール名称(name 属性)を指定します。
返却値は指定キーに該当するデータ(文字列)です。
該当するデータが配列の場合は、先頭のデータを返却します。
指定キーに該当する URL 引数が１つも存在しない場合はnullを返却します。
パラメータ
key String URL 引数設定名称
返却値
String URL 引数データ
導入されたバージョン：5.0
getParameterValues

Array getParameterValues (String key)

指定のキーに該当する URL 引数データ群を返却します。

キーは、フォームのコントロール名称(name 属性)を指定します。
返却値は指定キーに該当するデータ(文字列)の個数と同等の要素を持つ配列です。
指定キーに該当する URL 引数が１つも存在しない場合は空の配列を返却します。
パラメータ
key String URL 引数設定名称
返却値
Array URL 引数データの配列
導入されたバージョン：5.0
getQueryString

String getQueryString ()

リクエストされたURLのパスの後ろに含まれているクエリ文字列を返します。

URLがクエリ文字列を持っていない場合はnullを返します。
値はコンテナによってデコードされません。
この値はCGI変数のQUERY_STRINGの値と同じです。
返却値
String クエリ文字列を表すString
導入されたバージョン：5.0
query

String query ()

推奨されていません。Request.getMessageBodyAsStream()およびgetQueryString()に置き換えられました。
URL 引数文字列の取得します。

返却値はクライアントより受信した状態の URL 引数文字列です。
POST or GET どちらのリクエストでも引数を受け取る事が可能です
返却値
String クライアントから受け取った URL 引数文字列
導入されたバージョン：2.0
removeAttribute

void removeAttribute (String name)

このリクエストから属性を削除します。

属性はリクエストがコンテナ内で処理されている間だけ維持されるにすぎないので、 通常、このメソッドは必要ありません。
パラメータ
name String 削除する属性の名前を示す String
返却値
void
導入されたバージョン：5.0
setAttribute

void setAttribute (String name ,Object object)

このリクエストに属性をセットします。

パラメータ
name | String | 属性名を示す String
object | Object | セットするObject
返却値
void
導入されたバージョン：5.0


 RequestParameter オブジェクト

リクエストパラメータ情報オブジェクト。

リクエストパラメータの情報を保持します。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
String | getFileName () アップロードされたファイルのファイル名を取得します。
String | getHeader (String name) 指定のヘッダ名をもつ値を返します。
Array | getHeaderNames () ヘッダ名称一覧を返します。
Number | getLength () データ長を返します。
String | getName () このオブジェクトのパラメータ名を取得します。
String | getValue () 現在のパラメータ値を返します。
String | getValueAsStream () 現在のパラメータ値を返します。
メソッドの詳細
getFileName

String getFileName ()

アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う
返却値
String ファイル名
導入されたバージョン：5.0
getHeader

String getHeader (String name)

指定のヘッダ名をもつ値を返します。

パラメータ
name String ヘッダ名
返却値
String ヘッダの値
導入されたバージョン：5.0
getHeaderNames

Array getHeaderNames ()

ヘッダ名称一覧を返します。

このエンティティのもつヘッダ情報の名称一覧を返します。
ヘッダ情報がない場合、このメソッドは null を返します。
返却値
Array ヘッダ名称の配列
導入されたバージョン：5.0
getLength

Number getLength ()

データ長を返します。

返却値
Number データ長（単位はバイト）
導入されたバージョン：5.0
getName

String getName ()

このオブジェクトのパラメータ名を取得します。

返却値
String パラメータ名
導入されたバージョン：5.0
getValue

String getValue ()

現在のパラメータ値を返します。

パラメータ値は、リクエストの文字エンコーディングから文字コード変換されています。
返却値
String パラメータ値
導入されたバージョン：5.0
getValueAsStream

String getValueAsStream ()

現在のパラメータ値を返します。

パラメータ値は、文字コード変換されません。
パラメータ値の各バイトがそれぞれ String の１文字に対応します。
つまり、パラメータ値のバイト数は、そのまま String の文字数に等しくなります。
返却値
String パラメータ値
導入されたバージョン：5.0


 ResultInfo オブジェクト

処理結果オブジェクト。
任意の処理結果を表すオブジェクトです。

処理結果オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Number | code 処理結果コード。 | 読込み専用
Object | data 任意のオブジェクト(利用されるＡＰＩにより任意に設定されます）。 | 読込み専用
Boolean | error エラーフラグ。 | 読込み専用
String | message エラー発生時のメッセージ。 | 読込み専用
プロパティの詳細
code

Number code (読込み専用プロパティ)

処理結果コード。
0 | 成功
-1 | 失敗
-2 | 引数オブジェクト不正
data

Object data (読込み専用プロパティ)

任意のオブジェクト(利用されるＡＰＩにより任意に設定されます）。
error

Boolean error (読込み専用プロパティ)

エラーフラグ。
true(失敗) or false(成功)。
message

String message (読込み専用プロパティ)

エラー発生時のメッセージ。


 RoleDealPermissionInfo オブジェクト

ロール取扱アクセス権情報オブジェクト。
ロール取扱アクセス権情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | customerCompanyCode 取引先会社コード。 | 通常
String | customerDepartmentCode 取引先組織コード。 | 通常
String | dealCode 取扱コード。 | 通常
String | roleId ロールID。 | 通常
プロパティの詳細
customerCompanyCode

String customerCompanyCode

取引先会社コード。
customerDepartmentCode

String customerDepartmentCode

取引先組織コード。
dealCode

String dealCode

取扱コード。
roleId

String roleId

ロールID。


 RoleInfo オブジェクト

ロール情報オブジェクト。

ロール情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | category ロールカテゴリ。 | 通常
String | description ロールの詳細。 | 通常
Object | displayName 国際化情報。 | 通常
String | displayName[ロケール] ロール表示名。 | 通常
String | roleId ロールID。 | 通常
String | roleName ロール名。 | 通常
プロパティの詳細
category

String category

ロールカテゴリ。
description

String description

ロールの詳細。
displayName

Object displayName

国際化情報。
displayName[ロケール]

String displayName[ロケール]

ロール表示名。
roleId

String roleId

ロールID。
roleName

String roleName

ロール名。


 RoleManager オブジェクト

ロールマネージャオブジェクト。

ロール情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
RoleManager (String loginGroupId)
コンストラクタ。
メソッドの概要
Boolean | addRole (RoleInfo role) ロール情報を新規登録します。
Boolean | addSubRole (String roleId ,String subRoleId) サブロールIDを追加します。
Boolean | certify (Array users ,Array roles) ロール認証を行います。
Boolean | contains (String roleId) ロールの存在チェックを行います。
Boolean | containsCategory (String category) カテゴリーの登録チェックを行います。
Number | count () ロール数を取得します。
Number | countByCategory (String category) カテゴリーに属するロール数を取得します。
Object | del (String roleId [,Array funcs] [,Boolean isTransaction]) 推奨されていません。RoleManager.deleteRole(String roleId) に置き換えられました。
Boolean | deleteCategories () カテゴリーを全件削除します。
Boolean | deleteCategory (String category) カテゴリーを削除します。
Boolean | deleteRole (String roleId) ロールを削除します。
Boolean | deleteRoles () ロールを全削除します。
Boolean | deleteSubRole (String roleId ,String subRoleId) 指定したサブロールIDを削除します。
Boolean | deleteSubRoles (String roleId) 全てのサブロールIDを削除します。
String | exportData (String category) ロールのエクスポートを行います。
DataForRole | get (String roleId) 推奨されていません。RoleManager.getRole(String roleId) に置き換えられました。
Array | getAllParentRoleIds (String roleId) 全ての親ロールIDを取得します。
Array | getAllSubRoleIds (String roleId) 指定したロールIDのサブロールサマリを取得します。
Array | getCategories () カテゴリー一覧を取得します。
Array | getExportCategories () ロールエクスポート用のカテゴリの一覧を取得します。
String | getIdByName (String name) 推奨されていません。代替えメソッドはありません。
Array | getImportCategories () ロールインポート用のカテゴリの一覧を取得します。
Array | getKeys () 推奨されていません。RoleManager.getRoleIds() に置き換えられました。
Array | getList (String roleId) 推奨されていません。RoleManager.getAllSubRoleIds(String) に置き換えられました。
String | getLoginGroupId () ログイングループIDを取得します。
Array | getParentRoleIds (String roleId) 親ロール(一階層上のみ)を取得します。
Array | getParents (String roleId) 推奨されていません。RoleManager.getParentIds(Object String) に置き換えられました。
RoleInfo | getRole (String roleId) ロール情報を取得します。
Array | getRoleIds () すべてのロールIDを取得します。
Array | getRoles () ロール情報を全取得します。
Array | getRolesByCategory (String category) カテゴリーで検索を行い、ロールを取得します。
Array | getRolesByIds (Array roleIds) 引数のロールIDのロールをすべて取得します。
Array | getSubRole (String roleId) サブロール(一階層のみ)を取得します。
Boolean | importData (String category ,String str) ロールのインポートを行います。
boolean | isUpdate (Date date) ロール情報が指定された日付よりも後に更新されたかチェックします。
Boolean | moveCategory (String oldCategory ,String newCategory) カテゴリーを更新します。
Array | searchRolesById (String key) ロールID検索によりロールを取得します。
Array | searchRolesByName (String name) ロール名称検索でロールを取得します。
ReturnObject | set (Object request [,Array funcs] [,Boolean isTransaction]) 推奨されていません。RoleManager.addRole(Object role) および RoleManager.updateRole(Object role)に置き換えられました。
Boolean | updateRole (RoleInfo role) ロール情報を更新します。
コンストラクタの詳細
RoleManager

RoleManager (String loginGroupId)
コンストラクタ。

パラメータ
loginGroupId String ログイングループID
メソッドの詳細
addRole

Boolean addRole (RoleInfo role)

ロール情報を新規登録します。

パラメータ
role RoleInfo ロール情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗
addSubRole

Boolean addSubRole (String roleId ,String subRoleId)

サブロールIDを追加します。

パラメータ
roleId | String | ロールID
subRoleId | String | サブロールID
返却値
Boolean true : 成功 / false : 失敗
certify

Boolean certify (Array users ,Array roles)

ロール認証を行います。

パラメータ
users | Array | userDataのロールID(String)の配列
roles | Array | その他のオブジェクトのロールID(String)の配列
返却値
Boolean true : 成功 / false : 失敗
contains

Boolean contains (String roleId)

ロールの存在チェックを行います。

パラメータ
roleId String ロールID
返却値
Boolean true:存在する false:存在しない
containsCategory

Boolean containsCategory (String category)

カテゴリーの登録チェックを行います。

パラメータ
category String カテゴリ名
返却値
Boolean true:登録有り false:登録なし または エラー発生
count

Number count ()

ロール数を取得します。

返却値
Number ロールの数（エラーの場合は-1を返します）
countByCategory

Number countByCategory (String category)

カテゴリーに属するロール数を取得します。

パラメータ
category String カテゴリ
返却値
Number カテゴリーに属するロール数（エラーの場合は-1を返します）
del

Object del (String roleId [,Array funcs] [,Boolean isTransaction])

推奨されていません。RoleManager.deleteRole(String roleId) に置き換えられました。
ロールデータを削除します。

パラメータ
roleId | String | ロールID
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡す（任意）
isTransaction Boolean DBトランザクションフラグ(任意)
（true このメソッドの中でDBトランザクションを張ります。／false このメソッドの中でDBトランザクションを張りません。デフォルトはtrueです。）
返却値
Object 結果オブジェクトまたは、引数が不正の場合、falseを返却します。
結果オブジェクト
(Object) 		getCode() エラーコード
-1 実行エラー
0 成功
その他 各アプリに依存します。
getMessage() エラーメッセージ
deleteCategories

Boolean deleteCategories ()

カテゴリーを全件削除します。

返却値
Boolean true : 成功 / false : 失敗
deleteCategory

Boolean deleteCategory (String category)

カテゴリーを削除します。

パラメータ
category String カテゴリ名
返却値
Boolean true : 成功 / false : 失敗
deleteRole

Boolean deleteRole (String roleId)

ロールを削除します。

パラメータ
roleId String ロールID
返却値
Boolean true : 成功 / false : 失敗
deleteRoles

Boolean deleteRoles ()

ロールを全削除します。

返却値
Boolean true : 成功 / false : 失敗
deleteSubRole

Boolean deleteSubRole (String roleId ,String subRoleId)

指定したサブロールIDを削除します。

パラメータ
roleId | String | ロールID
subRoleId | String | サブロールID
返却値
Boolean true : 成功 / false : 失敗
deleteSubRoles

Boolean deleteSubRoles (String roleId)

全てのサブロールIDを削除します。

パラメータ
roleId String ロールID
返却値
Boolean true : 成功 / false : 失敗
exportData

String exportData (String category)

ロールのエクスポートを行います。

パラメータ
category String カテゴリ
返却値
String 出力情報
エクスポートに失敗した場合は、nullを返却します。
get

DataForRole get (String roleId)

推奨されていません。RoleManager.getRole(String roleId) に置き換えられました。
ロールデータを取得します。

パラメータ
roleId String ロールID
返却値
DataForRole ロールデータ
存在しない場合はnullを返却します。
getAllParentRoleIds

Array getAllParentRoleIds (String roleId)

全ての親ロールIDを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array 全ての親ロールIDの配列
getAllSubRoleIds

Array getAllSubRoleIds (String roleId)

指定したロールIDのサブロールサマリを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array 指定されたロールIDのサブロールの配列（エラーの場合はnullを返します。）
getCategories

Array getCategories ()

カテゴリー一覧を取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array カテゴリの配列（エラーの場合はnullを返します。）
getExportCategories

Array getExportCategories ()

ロールエクスポート用のカテゴリの一覧を取得します。

返却値
Array ロールエクスポート用カテゴリの一覧
ロールエクスポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getIdByName

String getIdByName (String name)

推奨されていません。代替えメソッドはありません。
ロール名からロールIDを取得します。

パラメータ
name String ロール名
返却値
String ロールID 存在しない場合はnullを返却します。
getImportCategories

Array getImportCategories ()

ロールインポート用のカテゴリの一覧を取得します。

返却値
Array ロールインポート用カテゴリの一覧
ロールインポート用のカテゴリの取得に失敗した場合は、空文字列を返却します。
getKeys

Array getKeys ()

推奨されていません。RoleManager.getRoleIds() に置き換えられました。
ロールIDを全て取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array 成功：ロールIDの配列(データがない場合は空の配列)
getList

Array getList (String roleId)

推奨されていません。RoleManager.getAllSubRoleIds(String) に置き換えられました。
サブロールデータを取得します。
(子ロールも含めたロールデータをすべて取得します。)

パラメータ
roleId String ロールID
返却値
Array サブロールIDの配列
getLoginGroupId

String getLoginGroupId ()

ログイングループIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
String ログイングループID
getParentRoleIds

Array getParentRoleIds (String roleId)

親ロール(一階層上のみ)を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array 親ロールIDの配列
getParents

Array getParents (String roleId)

推奨されていません。RoleManager.getParentIds(Object String) に置き換えられました。
直接の親（一階層上）ロールIDを取得します。

パラメータ
roleId String ロールID
返却値
Array ロールIDの配列(データがない場合はnullを返却します。)
getRole

RoleInfo getRole (String roleId)

ロール情報を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
RoleInfo ロール情報オブジェクト
getRoleIds

Array getRoleIds ()

すべてのロールIDを取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ロールIDの配列
getRoles

Array getRoles ()

ロール情報を全取得します。

取得に失敗した場合は、nullを返却します。
返却値
Array ロール情報オブジェクトの配列
getRolesByCategory

Array getRolesByCategory (String category)

カテゴリーで検索を行い、ロールを取得します。

指定したカテゴリーに属するロール情報を全て取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
category String カテゴリ名
返却値
Array 指定されたカテゴリに属するロール情報オブジェクトの配列
getRolesByIds

Array getRolesByIds (Array roleIds)

引数のロールIDのロールをすべて取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleIds Array ロールIDの配列
返却値
Array ロール情報オブジェクトの配列（データがない場合は空の配列を返します）
getSubRole

Array getSubRole (String roleId)

サブロール(一階層のみ)を取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
roleId String ロールID
返却値
Array サブロールIDの配列
importData

Boolean importData (String category ,String str)

ロールのインポートを行います。

パラメータ
category | String | カテゴリ
str | String | ストリーム
返却値
Boolean true : 成功 / false : 失敗
isUpdate

boolean isUpdate (Date date)

ロール情報が指定された日付よりも後に更新されたかチェックします。
パラメータ
date Date チェック日付
返却値
boolean 判定結果　更新された : true / 更新されていない ： false
moveCategory

Boolean moveCategory (String oldCategory ,String newCategory)

カテゴリーを更新します。

パラメータ
oldCategory | String | 変更前のカテゴリ名
newCategory | String | 変更後のカテゴリ名
返却値
Boolean true : 成功 / false : 失敗
searchRolesById

Array searchRolesById (String key)

ロールID検索によりロールを取得します。

引数に類似(前方一致)するロールIDを持つロール情報を全て取得します。
取得に失敗した場合は、nullを返却します。
パラメータ
key String 検索ロールID
返却値
Array ロール情報オブジェクトの配列
(検索にヒットしない場合は空の配列。)
searchRolesByName

Array searchRolesByName (String name)

ロール名称検索でロールを取得します。

取得に失敗した場合は、nullを返却します。
パラメータ
name String ロールの名称
返却値
Array ロール情報オブジェクトの配列
set

ReturnObject set (Object request [,Array funcs] [,Boolean isTransaction])

推奨されていません。RoleManager.addRole(Object role) および RoleManager.updateRole(Object role)に置き換えられました。
ロールデータを登録します。

引数に指定したユーザIDが既に存在していた場合、上書きします。
request
リクエストオブジェクト 		id ロールID(String)
name ロール名(String)
explan 説明(ロケール表示名)(String)
detail 詳細(String)
roles サブロールIDの配列(Array)
attr その他、IMISにのみ登録する属性(Object)
(((new RoleManager(gId)).get(uId)).getAttr()で取得できる値)
その他 各アプリに依存
パラメータ
request | Object | 登録画面からのリクエスト
funcs | Array | 動かしたい関数があれば、パスを配列にいれて渡す（任意）
isTransaction Boolean DBトランザクションフラグ(任意) （true このメソッドの中でDBトランザクションを張ります。／false このメソッドの中でDBトランザクションを張りません。デフォルトはtrueです。）
返却値
ReturnObject true / false
updateRole

Boolean updateRole (RoleInfo role)

ロール情報を更新します。
パラメータ
role RoleInfo ロール情報オブジェクト
返却値
Boolean true : 成功 / false : 失敗


 RCV オブジェクト

RC-5 暗号・復号化オブジェクト。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
RCV (String keytext ,String ivtext ,Number rounds)
RC-5 暗号化・復号化オブジェクトを生成します。
メソッドの概要
String | decrypt (String ciphertext ,String enctype) 指定文字列をRC-5で復号化します。
String | decryptStream (String ciphertext) 指定文字列をRC-5で復号化します。
String | decryptString (String ciphertext) 指定文字列をRC-5で復号化します。
String | encrypt (String plaintext ,String enctype) 文字列情報を暗号化します。
String | encryptStream (String plaintext) 文字列情報を暗号化します。
String | encryptString (String plaintext) 文字列情報を暗号化します。
Boolean | isError () 暗号化・復号化の可・否を判定します。
コンストラクタの詳細
RCV

RCV (String keytext ,String ivtext ,Number rounds)
RC-5 暗号化・復号化オブジェクトを生成します。
ivtext は、暗号化・復号化時の鍵になります。
keytext, rounds は鍵拡張アルゴリズムとして使われます。
rounds を省略した場合 RC5_ROUNDS_MIN が適応されます。
パラメータ
keytext | String | 鍵文字列(必須)
ivtext | String | イニシャライズベクタ(必須)
rounds | Number | ラウンド数(任意)
メソッドの詳細
decrypt

String decrypt (String ciphertext ,String enctype)

指定文字列をRC-5で復号化します。
復号化できなかった場合には null を返却します。
このメソッドでは、暗号化された文字列を復号化した結果を 指定の文字エンコードで文字コード変換した結果の文字列を返します。
パラメータ
ciphertext | String | 復号化対象文字列
enctype | String | 文字エンコード
返却値
String 復号化された結果の文字列
decryptStream

String decryptStream (String ciphertext)

指定文字列をRC-5で復号化します。
復号化できなかった場合には null を返却します。
このメソッドでは、暗号化された文字列を復号化した結果をストリームとして扱います。
jsFunction_encryptStream() と対で利用してください。
パラメータ
ciphertext String 復号化対象文字列
返却値
String 復号化された結果の文字列
decryptString

String decryptString (String ciphertext)

指定文字列をRC-5で復号化します。
復号化できなかった場合には null を返却します。
このメソッドでは、暗号化された文字列を復号化した結果をUNICODE として扱います。
jsFunction_encryptString() と対で利用してください。
パラメータ
ciphertext String 復号化対象文字列
返却値
String 復号化された結果の文字列
encrypt

String encrypt (String plaintext ,String enctype)

文字列情報を暗号化します。
指定文字列を RC-5 で暗号化します。
このメソッドでは、指定の値を指定のエンコードで変換した結果に対して暗号化を行います。
暗号化できなかった場合には null を返却します。
パラメータ
plaintext | String | 暗号化対象文字列
enctype | String | 文字エンコード
返却値
String 暗号化された結果の文字列
encryptStream

String encryptStream (String plaintext)

文字列情報を暗号化します。
指定文字列を RC-5 で暗号化します。
このメソッドでは、指定の値をストリームとして扱います。
暗号化できなかった場合には null を返却します。
jsFunction_decryptStream() と対で利用してください。
パラメータ
plaintext String 暗号化対象文字列
返却値
String 暗号化された結果の文字列
encryptString

String encryptString (String plaintext)

文字列情報を暗号化します。
指定文字列を RC-5 で暗号化します。
このメソッドでは、指定の値を UNICODE として扱います。
暗号化できなかった場合には null を返却します。
jsFunction_decryptString() と対で利用してください。
パラメータ
plaintext String 暗号化対象文字列
返却値
String 暗号化された結果の文字列
isError

Boolean isError ()

暗号化・復号化の可・否を判定します。
このインスタンスが暗号化や復号化ができる状態かを判定します。

返却値
Boolean 真値：暗号化・復号化可能/偽値：オプション指定が無効


 SecurityConst オブジェクト

アクセスセキュリティ定数オブジェクト。
バージョン：1.0
導入されたバージョン：5.0
定数の概要
static String | CP_COOKIE セッション情報をクッキーに保管するパラメータ名。
static Number | CR_ERROR 認証処理エラーの返却値。
static Number | CR_LOCKED アカウントロック状態の返却値。
static Number | CR_NG ログインエラーの返却値。
static Number | CR_NO_GROUP ログイングループ未登録状態の返却値。
static Number | CR_NO_LICENSE ライセンスなし、または有効期間外状態の返却値。
static Number | CR_NO_PERMISSION 無許可ページへのアクセスの返却値。
static Number | CR_NO_USER ユーザ未登録状態の返却値。
static Number | CR_OK 認証成功の返却値。
static Number | CR_SESSION_INITIAL セッション初期状態の返却値。
static Number | CR_SESSION_LOGON セッションログオン状態の返却値。
static Number | CR_SESSION_TIMEOUT セッションタイムアウト状態の返却値。
static Number | CR_SESSION_UNMATCH セッション不整合状態の返却値。
static String | LT_GROUP グループマネージャー（ログインタイプ）。
static String | LT_SUPER スーパーユーザ（ログインタイプ）。
static String | LT_USER ユーザ（ログインタイプ）。
static String | RP_CLIENT_TYPE クライアントタイプのデフォルトＵＲＬ引数名。
static String | RP_ENCODING ログインエンコーディングのデフォルトＵＲＬ引数名。
static String | RP_INITIAL_URL 初期ＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_LOCALE ログインロケールのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_GROUP ログイングループIDのデフォルトＵＲＬ引数名。
static String | RP_LOGIN_TYPE ログインタイプのデフォルトＵＲＬ引数名。
static String | RP_PASSWORD パスワードのデフォルトＵＲＬ引数名。
static String | RP_URL ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
static String | RP_URL_SIGN ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
static String | RP_USER ログインユーザＩＤのデフォルトＵＲＬ引数名。
static String | SP_CLIENT_TYPE クライアントタイプをセッションに保管するパラメータ名。
static String | SP_COLOR_PATTERN_ID カラーパターンIDをセッションに保管するパラメータ名。
static String | SP_ENCODING ログインエンコーディングをセッションに保管するパラメータ名。
static String | SP_INITIAL_URL 初期ページURLを属性に保管するパラメータ名。
static String | SP_LOCALE ログインロケールをセッションに保管するパラメータ名。
static String | SP_LOGIN_GROUP ログイングループIDをセッションに保管するパラメータ名。
static String | SP_LOGIN_TIME ログインした時間をセッションに保管するパラメータ名。
static String | SP_LOGIN_TYPE ログインタイプをセッションに保管するパラメータ名。
static String | SP_SIGNATURE ログイン署名をセッションに保管するパラメータ名。
static String | SP_URL 認証後表示するメインページをセッションに保管するパラメータ名。
static String | SP_URL_SIGN ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
static String | SP_USER ログインユーザＩＤをセッションに保管するパラメータ名。
定数の詳細
CP_COOKIE

static String CP_COOKIE

セッション情報をクッキーに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.cookie"
CR_ERROR

static Number CR_ERROR

認証処理エラーの返却値。
定数値 ： -7
CR_LOCKED

static Number CR_LOCKED

アカウントロック状態の返却値。
定数値 ： -3
CR_NG

static Number CR_NG

ログインエラーの返却値。
定数値 ： 0
CR_NO_GROUP

static Number CR_NO_GROUP

ログイングループ未登録状態の返却値。
定数値 ： -2
CR_NO_LICENSE

static Number CR_NO_LICENSE

ライセンスなし、または有効期間外状態の返却値。
定数値 ： -1
CR_NO_PERMISSION

static Number CR_NO_PERMISSION

無許可ページへのアクセスの返却値。
定数値 ： -6
CR_NO_USER

static Number CR_NO_USER

ユーザ未登録状態の返却値。
定数値 ： 2
CR_OK

static Number CR_OK

認証成功の返却値。
定数値 ： 1
CR_SESSION_INITIAL

static Number CR_SESSION_INITIAL

セッション初期状態の返却値。
定数値 ： 2
CR_SESSION_LOGON

static Number CR_SESSION_LOGON

セッションログオン状態の返却値。
定数値 ： 3
CR_SESSION_TIMEOUT

static Number CR_SESSION_TIMEOUT

セッションタイムアウト状態の返却値。
定数値 ： -5
CR_SESSION_UNMATCH

static Number CR_SESSION_UNMATCH

セッション不整合状態の返却値。
定数値 ： -4
LT_GROUP

static String LT_GROUP

グループマネージャー（ログインタイプ）。
定数値 ： "group"
LT_SUPER

static String LT_SUPER

スーパーユーザ（ログインタイプ）。
定数値 ： "super"
LT_USER

static String LT_USER

ユーザ（ログインタイプ）。
定数値 ： "user"
RP_CLIENT_TYPE

static String RP_CLIENT_TYPE

クライアントタイプのデフォルトＵＲＬ引数名。
定数値 ： "im_client_type"
RP_ENCODING

static String RP_ENCODING

ログインエンコーディングのデフォルトＵＲＬ引数名。
定数値 ： "im_encoding"
RP_INITIAL_URL

static String RP_INITIAL_URL

初期ＵＲＬのデフォルトＵＲＬ引数名。
定数値 ： "im_initial_url"
RP_LOCALE

static String RP_LOCALE

ログインロケールのデフォルトＵＲＬ引数名。
定数値 ： "im_locale"
RP_LOGIN_GROUP

static String RP_LOGIN_GROUP

ログイングループIDのデフォルトＵＲＬ引数名。
定数値 ： "im_login_group"
RP_LOGIN_TYPE

static String RP_LOGIN_TYPE

ログインタイプのデフォルトＵＲＬ引数名。
定数値 ： "im_login_type"
RP_PASSWORD

static String RP_PASSWORD

パスワードのデフォルトＵＲＬ引数名。
定数値 ： "im_password"
RP_URL

static String RP_URL

ダイレクトＵＲＬのデフォルトＵＲＬ引数名。
定数値 ： "im_url"
RP_URL_SIGN

static String RP_URL_SIGN

ダイレクトＵＲＬ署名のデフォルトＵＲＬ引数名。
定数値 ： "im_url_sign"
RP_USER

static String RP_USER

ログインユーザＩＤのデフォルトＵＲＬ引数名。
定数値 ： "im_user"
SP_CLIENT_TYPE

static String SP_CLIENT_TYPE

クライアントタイプをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.client_type"
SP_COLOR_PATTERN_ID

static String SP_COLOR_PATTERN_ID

カラーパターンIDをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.color_pattern_id"
SP_ENCODING

static String SP_ENCODING

ログインエンコーディングをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.encoding"
SP_INITIAL_URL

static String SP_INITIAL_URL

初期ページURLを属性に保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.initial.url"
SP_LOCALE

static String SP_LOCALE

ログインロケールをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.locale"
SP_LOGIN_GROUP

static String SP_LOGIN_GROUP

ログイングループIDをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.group"
SP_LOGIN_TIME

static String SP_LOGIN_TIME

ログインした時間をセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.login_time"
SP_LOGIN_TYPE

static String SP_LOGIN_TYPE

ログインタイプをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.login_type"
SP_SIGNATURE

static String SP_SIGNATURE

ログイン署名をセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.signature"
SP_URL

static String SP_URL

認証後表示するメインページをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.url"
SP_URL_SIGN

static String SP_URL_SIGN

ダイレクトＵＲＬの署名をセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.url.signature"
SP_USER

static String SP_USER

ログインユーザＩＤをセッションに保管するパラメータ名。
定数値 ： "jp.co.intra_mart.session.user"


 SessionConfigInfo オブジェクト

セキュリティ設定情報オブジェクト。

セキュリティ情報をセッションに格納するパラメータ名（キー）の一覧を提供するオブジェクトです。
セキュリティ設定情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

セキュリティ設定情報オブジェクトは値を参照することのみ許可されています

プロパティの概要
String | clientTypeName クライアントタイプをセッションに保管するためのパラメータ名 。 | 読込み専用
String | colorPatternIdName カラーパターンIDをセッションに保管するためのパラメータ名。 | 読込み専用
String | encodingName エンコーディングをセッションに保管するためのパラメータ名。 | 読込み専用
String | initialUrlName 初期ページURLをセッションに保管するためのパラメータ名。 | 読込み専用
String | localeName ロケールをセッションに保管するためのパラメータ名。 | 読込み専用
String | loginGroupName ログイングループをセッションに保管するためのパラメータ名。 | 読込み専用
String | loginTimeName ログイン時間をセッションに保管するためのパラメータ名。 | 読込み専用
String | loginTypeName ログインタイプをセッションに保管するためのパラメータ名。 | 読込み専用
String | sessionCookieName クッキーにセッション情報を保管するためパラメータ名。 | 読込み専用
String | shortcutName ショートカットＩＤをセッションに保管するためのパラメータ名。 | 読込み専用
String | signatureName ログイン署名をセッションに保管するためのパラメータ名。 | 読込み専用
String | urlName ダイレクトＵＲＬをセッションに保管するためパラメータ名。 | 読込み専用
String | urlSignatureName ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名。 | 読込み専用
String | userName ユーザＩＤをセッションに保管するためのパラメータ名。 | 読込み専用
プロパティの詳細
clientTypeName

String clientTypeName (読込み専用プロパティ)

クライアントタイプをセッションに保管するためのパラメータ名 。
colorPatternIdName

String colorPatternIdName (読込み専用プロパティ)

カラーパターンIDをセッションに保管するためのパラメータ名。
encodingName

String encodingName (読込み専用プロパティ)

エンコーディングをセッションに保管するためのパラメータ名。
initialUrlName

String initialUrlName (読込み専用プロパティ)

初期ページURLをセッションに保管するためのパラメータ名。
localeName

String localeName (読込み専用プロパティ)

ロケールをセッションに保管するためのパラメータ名。
loginGroupName

String loginGroupName (読込み専用プロパティ)

ログイングループをセッションに保管するためのパラメータ名。
loginTimeName

String loginTimeName (読込み専用プロパティ)

ログイン時間をセッションに保管するためのパラメータ名。
loginTypeName

String loginTypeName (読込み専用プロパティ)

ログインタイプをセッションに保管するためのパラメータ名。
sessionCookieName

String sessionCookieName (読込み専用プロパティ)

クッキーにセッション情報を保管するためパラメータ名。
shortcutName

String shortcutName (読込み専用プロパティ)

ショートカットＩＤをセッションに保管するためのパラメータ名。
signatureName

String signatureName (読込み専用プロパティ)

ログイン署名をセッションに保管するためのパラメータ名。
urlName

String urlName (読込み専用プロパティ)

ダイレクトＵＲＬをセッションに保管するためパラメータ名。
urlSignatureName

String urlSignatureName (読込み専用プロパティ)

ダイレクトＵＲＬ署名をセッションに保管するためパラメータ名。
userName

String userName (読込み専用プロパティ)

ユーザＩＤをセッションに保管するためのパラメータ名。


 SessionInfo オブジェクト

セッション情報オブジェクト。

セッションに保管されているセキュリティ情報の一覧を提供するオブジェクトです。
セッション情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

セッション情報オブジェクトは値を参照することのみ許可されています

導入されたバージョン：5.0
プロパティの概要
String | clientType クライアントタイプ。 | 読込み専用
String | colorPatternId カラーパターンID。 | 読込み専用
String | encoding エンコーディング。 | 読込み専用
String | initialUrl 初期ページURL。 | 読込み専用
String | locale ロケール。 | 読込み専用
String | loginGroup ログイングループ。 | 読込み専用
Date | loginTime ログイン時間。 | 読込み専用
String | loginType ログインタイプ。 | 読込み専用
String | signature 署名。 | 読込み専用
String | url URL。 | 読込み専用
String | urlSignature URL署名。 | 読込み専用
String | user ユーザＩＤ。 | 読込み専用
メソッドの概要
Object | getAttribute (key String) セッションから指定した属性の値を取得します。
Object | removeAttribute (String key) セッションから指定された属性を削除します。
Object | setAttribute (key String ,value Object) セッションから指定した属性に値を保管します。
プロパティの詳細
clientType

String clientType (読込み専用プロパティ)

クライアントタイプ。
colorPatternId

String colorPatternId (読込み専用プロパティ)

カラーパターンID。
encoding

String encoding (読込み専用プロパティ)

エンコーディング。
initialUrl

String initialUrl (読込み専用プロパティ)

初期ページURL。
locale

String locale (読込み専用プロパティ)

ロケール。
loginGroup

String loginGroup (読込み専用プロパティ)

ログイングループ。
loginTime

Date loginTime (読込み専用プロパティ)

ログイン時間。
loginType

String loginType (読込み専用プロパティ)

ログインタイプ。
signature

String signature (読込み専用プロパティ)

署名。
url

String url (読込み専用プロパティ)

URL。
urlSignature

String urlSignature (読込み専用プロパティ)

URL署名。
user

String user (読込み専用プロパティ)

ユーザＩＤ。
メソッドの詳細
getAttribute

Object getAttribute (key String)

セッションから指定した属性の値を取得します。
パラメータ
String key 属性名
返却値
Object 属性値
導入されたバージョン：6.1
removeAttribute

Object removeAttribute (String key)

セッションから指定された属性を削除します。
パラメータ
key String 属性名
返却値
Object 削除された属性値
導入されたバージョン：6.1
setAttribute

Object setAttribute (key String ,value Object)

セッションから指定した属性に値を保管します。
パラメータ
String | key | 属性名
Object | value | 属性値
返却値
Object 保管されていた属性値
導入されたバージョン：6.1


 ShortCutInfo オブジェクト

ショートカット情報オブジェクト。

ショートカット情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
Array | allowUsers[0..*] 許可ユーザID。 | 通常
String | isAuth 認証フラグ。 | 通常
String | url 表示させるURL。 | 通常
Object | urlParams URL引数オブジェクト。 | 通常
String | urlParams[キー] URL引数値。 | 通常
Date | validEndDate 有効終了日。 | 通常
プロパティの詳細
allowUsers[0..*]

Array allowUsers[0..*]

許可ユーザID。
isAuth

String isAuth

認証フラグ。
ユーザ認証が必要な場合trueを設定します。
falseに設定する場合は、許可ユーザは1名でなければなりません。
url

String url

表示させるURL。
必ず拡張子まで必要です。
スクリプト開発モデルでは ****.jssp 形式で指定します。
urlParams

Object urlParams

URL引数オブジェクト。
urlParams[キー]

String urlParams[キー]

URL引数値。
validEndDate

Date validEndDate

有効終了日。

設定できる最大日付は9999/12/31です。
nullを指定した場合は、SYSTEM日付として扱います。


 ShortCutManager オブジェクト

ショートカット情報オブジェクト。

ショートカット情報の参照、更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：6.1
コンストラクタの概要
ShortCutManager (String groupId)
コンストラクタ。
メソッドの概要
Date | addValidEndDate (指定日数 countDays) 指定日付加算。
String | createShortCut (ShortCutInfo shortCutInfo) ショートカットＩＤの作成。
Boolean | deleteShortCut (ショートカットＩＤ shortCutId) ショートカットＩＤ削除。
String | getErrorPage () ショートカットエラーページ取得。
String | getMainPage () ショートカットメインページ取得。
ShortCutInfo | getShortCutInfo (ショートカットＩＤ shortCutId) ショートカット情報取得。
Number | verifyShortCut (Date verifyDate) ショートカット情報を検証し、無効なショートカット情報の削除数を取得。
コンストラクタの詳細
ShortCutManager

ShortCutManager (String groupId)
コンストラクタ。

ショートカット情報オブジェクトを生成します。
パラメータ
groupId String ログイングループID
導入されたバージョン：6.1
メソッドの詳細
addValidEndDate

Date addValidEndDate (指定日数 countDays)

指定日付加算。

SYSTEM日付に指定された日数を加えた日付を取得します。
パラメータ
countDays 指定日数
返却値
Date 指定日付
エラー発生時はNULLを返します。
導入されたバージョン：6.1
createShortCut

String createShortCut (ShortCutInfo shortCutInfo)

ショートカットＩＤの作成。

ショートカット情報を元に固有のＩＤをキーとしてショートカット情報を登録します。
パラメータ
shortCutInfo ShortCutInfo ショートカット情報オブジェクト
返却値
String 作成されたショートカットID
導入されたバージョン：6.1
deleteShortCut

Boolean deleteShortCut (ショートカットＩＤ shortCutId)

ショートカットＩＤ削除。

ショートカットＩＤを元にショートカット情報を削除します。
パラメータ
shortCutId ショートカットＩＤ
返却値
Boolean ショートカットＩＤの削除に成功(true) / ショートカットＩＤの削除に失敗(false)
導入されたバージョン：6.1
getErrorPage

String getErrorPage ()

ショートカットエラーページ取得。

ショートカットが表示できない場合のエラーページパスを取得します。
返却値
String エラーページパス　エラー発生時はNULLを返します。
導入されたバージョン：6.1
getMainPage

String getMainPage ()

ショートカットメインページ取得。

ショートカット表示用のメインページパスを取得します。
返却値
String メインページパス　エラー発生時はNULLを返します。
導入されたバージョン：6.1
getShortCutInfo

ShortCutInfo getShortCutInfo (ショートカットＩＤ shortCutId)

ショートカット情報取得。

指定されたショートカットＩＤからショートカット情報を取得します。
パラメータ
shortCutId ショートカットＩＤ
返却値
ShortCutInfo ショートカット情報オブジェクト
存在しない場合およびエラー発生時はNULLを返します。
導入されたバージョン：6.1
verifyShortCut

Number verifyShortCut (Date verifyDate)

ショートカット情報を検証し、無効なショートカット情報の削除数を取得。

指定された日付において無効なショートカット情報を削除し、削除件数を返却します。
取得に失敗した場合は（-1）が返却されます。
パラメータ
verifyDate Date 検証日付
返却値
Number 削除件数
導入されたバージョン：6.1


 SuperUserInfo オブジェクト

管理者情報オブジェクト。

管理者情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | encoding エンコーディング。 | 通常
String | locale ロケール。 | 通常
String | mailAddress メールアドレス。 | 通常
String | password パスワード。 | 通常
String | telNo 電話番号。 | 通常
String | userId ユーザID。 | 通常
プロパティの詳細
encoding

String encoding

エンコーディング。
locale

String locale

ロケール。
mailAddress

String mailAddress

メールアドレス。
password

String password

パスワード。
telNo

String telNo

電話番号。
userId

String userId

ユーザID。


 System オブジェクト

システムマネージャオブジェクト。

システム設定情報を取得することができます。
通常 [install_directory]/conf/imart.xml が読み込まれた状態になっていますが、
任意の *.iniファイルを読み込んで値を定義する事も可能です。
複数の *.ini ファイルを読み込む場合、同じキーを定義しないように注意する必要があります。

システムで有効な、クライアントタイプ、ロケール、カラーパターンの情報を取得することができます。
上記の情報は、サーバマネージャの[install_directory]/conf/system.xmlで定義することが可能です。

バージョン：1.0
導入されたバージョン：4.3
メソッドの概要
static Boolean | addSuperUser (SuperUserInfo superUser) システム管理者を作成します。
static void | defineProperty (String key ,String value) システム設定情報を設定します。
static ClientTypeInfo | getClientType (String locale ,String clientType) システムで有効なクライアントタイプ情報を取得します。
static Array | getClientTypes (String locale) システムで有効なクライアントタイプ情報の一覧を取得します。
static ColorPatternInfo | getColorPattern (String reqLocale ,String colorId) システムで有効なカラーパターン情報を取得します。
static Array | getColorPatterns (String locale) システムで有効なカラーパターン情報の一覧を取得する。
static String | getDefaultClientType () デフォルトクライアントタイプを取得します。
static String | getDefaultColorPatternId () デフォルトカラーパターンIDを取得します。
static String | getDefaultLocale () デフォルトロケールを取得します。
static Number | getFloat (String key ,Number def) システム設定情報を取得します。
static Number | getInteger (String key ,Number def) システム設定情報を取得します。
static LocaleInfo | getLocale (String regLocale ,String locale) システムで有効なロケール情報を取得します。
static Array | getLocales (String locale) システムで有効なロケール情報の一覧を取得します。
static SuperUserInfo | getSuperUser () システム管理者を取得します。
Date | getSystemMaxDate () 最大の未来日を取得します。
static Array | getSystemMenu () システムメニューを取得します。
Date | getSystemMinDate () 最大の過去日を取得します。
static Object | getValue (String key ,Object def) システム設定情報を取得します。
static Boolean | isFalse (String key) システム設定情報を真偽値としてチェックします。
static Boolean | isTrue (String key) システム設定情報を真偽値としてチェックします。
static Boolean | isValid (String key) システム設定情報をチェックします。
static Boolean | read (String file_name) iniファイルを読込みます。
static Boolean | updateSuperUser (SuperUserInfo superUser) システム管理者を更新します。
メソッドの詳細
addSuperUser

static Boolean addSuperUser (SuperUserInfo superUser)

システム管理者を作成します。
パラメータ
superUser SuperUserInfo システム管理者オブジェクト
返却値
Boolean 成功/失敗(true/false)
defineProperty

static void defineProperty (String key ,String value)

システム設定情報を設定します。

このメソッドはスレッドセーフではありません。
パラメータ
key | String | キー
value | String | キーに対応する値
返却値
void
getClientType

static ClientTypeInfo getClientType (String locale ,String clientType)

システムで有効なクライアントタイプ情報を取得します。
存在しない指定ロケールおよびクライアントタイプが指定された場合はデフォルトのクライアントタイプ情報を返却します。
パラメータ
locale | String | ロケール
clientType | String | クライアントタイプ
返却値
ClientTypeInfo クライアントタイプ情報オブジェクト
getClientTypes

static Array getClientTypes (String locale)

システムで有効なクライアントタイプ情報の一覧を取得します。
指定したロケールのクライアントタイプオブジェクトの一覧を取得します。
クライアントタイプが一件も存在しない場合は、空の配列を返却します。
パラメータ
locale String ロケール
返却値
Array クライアントタイプ情報オブジェクトの配列
getColorPattern

static ColorPatternInfo getColorPattern (String reqLocale ,String colorId)

システムで有効なカラーパターン情報を取得します。

存在しない指定ロケールおよびカラーパターンIDが指定された場合はデフォルトのカラーパターン情報を返却します。
パラメータ
reqLocale | String | 指定ロケール
colorId | String | カラーパターンID
返却値
ColorPatternInfo カラーパターン情報オブジェクト
getColorPatterns

static Array getColorPatterns (String locale)

システムで有効なカラーパターン情報の一覧を取得する。

指定したロケールのカラーパターンオブジェクトの一覧を取得します。
カラーパターン情報が一件も存在しない場合は空の配列を返却します。
パラメータ
locale String 指定ロケール
返却値
Array カラーパターン情報オブジェクトの配列
getDefaultClientType

static String getDefaultClientType ()

デフォルトクライアントタイプを取得します。

デフォルトクライアントタイプが存在しない場合はnullが返却されます。
返却値
String デフォルトクライアントタイプ
getDefaultColorPatternId

static String getDefaultColorPatternId ()

デフォルトカラーパターンIDを取得します。

デフォルトカラーパターンIDが存在しない場合はnullが返却されます。
返却値
String デフォルトカラーパターンID
getDefaultLocale

static String getDefaultLocale ()

デフォルトロケールを取得します。

デフォルトロケールが存在しない場合はnullが返却されます。
返却値
String デフォルトロケール
getFloat

static Number getFloat (String key ,Number def)

システム設定情報を取得します。

指定したキーに対応するシステム設定情報を数値型で取得します。 指定キーが未定義の場合は null を返却します。 引数にて未定義時デフォルト値を指定の場合は、指定データを返却します。
パラメータ
key | String | 取得キー
def | Number | 指定キーが未定義の場合の返却値（浮動小数点型）
返却値
Number 取得情報（浮動小数点型）
getInteger

static Number getInteger (String key ,Number def)

システム設定情報を取得します。

指定したキーに対応するシステム設定情報を数値型で取得します。 指定キーが未定義の場合は null を返却します。 引数にて未定義時デフォルト値を指定の場合は、指定データを返却します。
パラメータ
key | String | 取得キー
def | Number | 指定キーが未定義の場合の返却値（整数型）
返却値
Number 取得情報（整数型）
getLocale

static LocaleInfo getLocale (String regLocale ,String locale)

システムで有効なロケール情報を取得します。

存在しない指定ロケールおよび取得ロケールが指定された場合はデフォルトのロケール情報を返却します。
パラメータ
regLocale | String | 指定ロケール
locale | String | ロケール
返却値
LocaleInfo ロケール情報オブジェクト
getLocales

static Array getLocales (String locale)

システムで有効なロケール情報の一覧を取得します。

指定したロケールのロケールオブジェクトの一覧を取得します。
ロケール情報が一件も存在しない場合は空の配列を返却します。
パラメータ
locale String 要求元ロケール
返却値
Array ロケール情報オブジェクトの配列
getSuperUser

static SuperUserInfo getSuperUser ()

システム管理者を取得します。
返却値
SuperUserInfo システム管理者オブジェクト
getSystemMaxDate

Date getSystemMaxDate ()

最大の未来日を取得します。

システムで取り扱う最大未来日を返却します。
取得に失敗した場合は、nullを返却します。
返却値
Date システムで取り扱う最大未来日
getSystemMenu

static Array getSystemMenu ()

システムメニューを取得します。
返却値
Array システムメニュー情報オブジェクトの配列
getSystemMinDate

Date getSystemMinDate ()

最大の過去日を取得します。

システムで取り扱う最大過去日を返却します。
取得に失敗した場合は、nullを返却します。
返却値
Date システムで取り扱う最大過去日
getValue

static Object getValue (String key ,Object def)

システム設定情報を取得します。

指定したキーに対応するシステム設定情報を取得します。 指定キーが未定義の場合は null を返却します。 引数にて未定義時デフォルト値を指定の場合は、指定データを返却します。
パラメータ
key | String | 取得キー
def | Object | 指定キーが未定義の場合の返却値（任意指定）
返却値
Object 取得情報
isFalse

static Boolean isFalse (String key)

システム設定情報を真偽値としてチェックします。

指定したキーに対応するシステム設定情報が OFF または FALSE かどうかチェックします。
OFF または FALSE は大文字小文字も厳密に区別します。
パラメータ
key String 取得キー
返却値
Boolean OFF または FALSE の場合は、true
isTrue

static Boolean isTrue (String key)

システム設定情報を真偽値としてチェックします。

指定したキーに対応するシステム設定情報が ON または TRUE かどうかチェックします。
ON または TRUE は大文字小文字も厳密に区別します。
パラメータ
key String 取得キー
返却値
Boolean ON または TRUE の場合は、true
isValid

static Boolean isValid (String key)

システム設定情報をチェックします。

指定したキーがシステム設定情報として存在するかどうかチェックします。
パラメータ
key String 取得キー
返却値
Boolean 存在する場合は、true
read

static Boolean read (String file_name)

iniファイルを読込みます。

iniファイルを読み込んでシステム設定情報に設定します。
ファイル名は拡張子なしのファイルラベル名のみ指定します。
(自動で .ini を付加してファイル検索します。)
パラメータ
file_name String ファイル名(拡張子省略形式)
返却値
Boolean true ：ini ファイルの読込と設定が成功終了 false：ini ファイルの読込または設定に失敗
updateSuperUser

static Boolean updateSuperUser (SuperUserInfo superUser)

システム管理者を更新します。
パラメータ
superUser SuperUserInfo システム管理者オブジェクト
返却値
Boolean 成功/失敗(true/false)


 SystemMenuInfo オブジェクト

システムメニュー情報オブジェクト。

システムメニュー情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | contents コンテンツの種類。 | 読込み専用
Object | displayNamedisplayName 国際化情報。 | 読込み専用
String | displayNamedisplayName[ロケール] メニュー名。 | 読込み専用
String | id メニューID。 | 読込み専用
String | imagePath メニューイメージパス。 | 読込み専用
String | url URL。 | 読込み専用
プロパティの詳細
contents

String contents (読込み専用プロパティ)

コンテンツの種類。

AdminMenuManager.CONTENT_TYPE_IN： 内部URL
AdminMenuManager.CONTENT_TYPE_OUT：外部URL
displayNamedisplayName

Object displayNamedisplayName (読込み専用プロパティ)

国際化情報。
displayNamedisplayName[ロケール]

String displayNamedisplayName[ロケール] (読込み専用プロパティ)

メニュー名。
id

String id (読込み専用プロパティ)

メニューID。
imagePath

String imagePath (読込み専用プロパティ)

メニューイメージパス。

メニューのアイコンイメージパスを指定します。
url

String url (読込み専用プロパティ)

URL。


 TermInfo オブジェクト

期間情報オブジェクト。
期間情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

ここで有効開始日時と有効終了日時は常に次の関係である必要があります。

有効開始日時 < 有効終了日時
また、設定された有効開始日時および有効終了日時の時刻は、00:00:00 に切り捨てられます。
ただし、有効最大日時が設定された場合はその限りではありません。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Date | endDate 有効終了日時。 | 通常
Date | startDate 有効開始日時。 | 通常
プロパティの詳細
endDate

Date endDate

有効終了日時。
startDate

Date startDate

有効開始日時。


 TermManager オブジェクト

TermManagerオブジェクト
期間に関する情報を扱うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static Date | getMaxDate () システムで設定できる期間の最大日時を取得します。
static Date | getMinDate () システムで設定できる期間の最小日時を取得します。
static TermResultInfo | getOverlap (Array terms1 ,Array terms2) 2つの期間配列 term1 と term2 で重なっている期間を返します。
static TermResultInfo | subtract (Array terms1 ,Array terms2) 期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
static TermResultInfo | validateTerm (Date startDate ,Date endDate) 指定された2つの日時が有効な期間を構成するかどうか調べます。
static TermResultInfo | validateTerms (Array terms) 指定された期間配列が有効かどうかを調べます。
メソッドの詳細
getMaxDate

static Date getMaxDate ()

システムで設定できる期間の最大日時を取得します。
返却値
Date 期間の最大日時
getMinDate

static Date getMinDate ()

システムで設定できる期間の最小日時を取得します。

返却値
Date 期間の最小日時
getOverlap

static TermResultInfo getOverlap (Array terms1 ,Array terms2)

2つの期間配列 term1 と term2 で重なっている期間を返します。
期間に重なりが存在しない場合は、処理結果オブジェクトの期間配列に空の配列を設定します。
期間配列 term1 または term2 が null の場合も、空の配列を設定します。
パラメータ
terms1 | Array | 期間情報オブジェクトの配列
terms2 | Array | 期間情報オブジェクトの配列
返却値
TermResultInfo 期間処理結果オブジェクト
subtract

static TermResultInfo subtract (Array terms1 ,Array terms2)

期間配列 term1 から 期間配列 term2 を差し引いた期間を返します。
差し引かれる期間が存在しない場合は、処理結果オブジェクトの期間配列に空の配列を設定します。
期間配列 term1 または term2 が null の場合も、空の配列を設定します。
パラメータ
terms1 | Array | 期間情報オブジェクトの配列
terms2 | Array | 期間情報オブジェクトの配列
返却値
TermResultInfo 期間処理結果オブジェクト
validateTerm

static TermResultInfo validateTerm (Date startDate ,Date endDate)

指定された2つの日時が有効な期間を構成するかどうか調べます。
指定された日時が有効な期間を構成する場合は、処理結果オブジェクトの error に false を設定します。
そうでない場合は error に true、message に有効な期間を構成しないと判定した理由を設定します。
パラメータ
startDate | Date | 有効開始日時
endDate | Date | 有効終了日時
返却値
TermResultInfo 期間処理結果オブジェクト
validateTerms

static TermResultInfo validateTerms (Array terms)

指定された期間配列が有効かどうかを調べます。
指定された期間配列が有効である場合は、期間処理結果オブジェクトの error に false を設定します。
そうでない場合は error に true、message に期間配列が有効でないと判定した理由を設定します。
期間配列は以下の場合に有効でないと判定されます。

  ・期間配列にnullの要素が含まれている場合
  ・互いに重なる要素が含まれている場合
パラメータ
terms Array 期間情報オブジェクトの配列
返却値
TermResultInfo 期間処理結果オブジェクト


 TermResultInfo オブジェクト

期間処理結果オブジェクト。
期間処理結果オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
Boolean | error true(失敗) or false(成功)。 | 読込み専用
String | message エラー発生時のメッセージ。 | 読込み専用
Array | message 期間配列。 | 読込み専用
プロパティの詳細
error

Boolean error (読込み専用プロパティ)

true(失敗) or false(成功)。
message

String message (読込み専用プロパティ)

エラー発生時のメッセージ。
message

Array message (読込み専用プロパティ)

期間配列。
期間情報オブジェクトの配列


 Unicode オブジェクト

Unicodeクラス。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | from (String target ,String code) 文字列を Unicode コード体系に変換します。
static String | to (String target ,String code) 文字列を他の文字コード体系に変換します。
メソッドの詳細
from

static String from (String target ,String code)

文字列を Unicode コード体系に変換します。
引数 code が未指定の場合、conf/imart.xml の intra-mart/server-charset の設定値をデフォルト値として適応します。
引数 codeには、java.io API と java.lang API でサポートされる文字エンコーディング名を指定できます。詳しくは以下を参照してください。
http://java.sun.com/j2se/1.4/ja/docs/ja/guide/intl/encoding.doc.html
引数不正時の動作については、未定義（保証外）。
パラメータ
target | String | 変換対象となる文字列(必須)
code | String | 変換対象となる文字列の現在の文字コード体系(任意)
返却値
String 変換結果文字列
to

static String to (String target ,String code)

文字列を他の文字コード体系に変換します。
引数 code が未指定の場合、conf/imart.xml の intra-mart/server-charset の設定値をデフォルト値として適応します。
引数 codeには、java.io API と java.lang API でサポートされる文字エンコーディング名を指定できます。詳しくは以下を参照してください。
http://java.sun.com/j2se/1.4/ja/docs/ja/guide/intl/encoding.doc.html
引数不正時の動作については、未定義（保証外）。
パラメータ
target | String | 変換対象文字列
code | String | 変換対象後の文字コード体系
返却値
String 変換結果文字列


 UpdateManager オブジェクト

情報更新管理マネージャオブジェクト。

マスタデータなどの最終更新操作の日付を管理します。
マスタデータをメモリ上でプールする場合、
マスタデータの更新と同時にmodifyメソッドを利用して、更新管理を行っておくことにより、
getLastModifiedメソッドを用いて効果的にメモリ上にプールされているデータを更新できます。
データの種類によってユニークな更新管理キーを用いて管理できます。

なお、更新管理キーが 'im_' から始まるキーは、システム用として予約されています。
上記のキーを用いての更新系API（modfiy,remove など)を使用しないでください。
バージョン：1.0
導入されたバージョン：6.1
コンストラクタの概要
UpdateManager (String groupId)
コンストラクタ。
メソッドの概要
Array | getKeys () 保存されている更新管理キーの一覧を取得します。
Date | getLastModified (String key) 更新日付を取得します。
Boolean | isUpDate (String key ,String now) 更新管理キーの更新日付が検証日付より新しいか検証します。
Date | modify (String key) 対象となる更新管理キーの更新日付を更新します。
Boolean | remove (String key) 更新管理キーを削除します。
Boolean | removeAll () すべての更新管理キーを削除します。
コンストラクタの詳細
UpdateManager

UpdateManager (String groupId)
コンストラクタ。

パラメータ
groupId String ログイングループID
メソッドの詳細
getKeys

Array getKeys ()

保存されている更新管理キーの一覧を取得します。
返却値
Array 更新管理キーの一覧(文字列の配列)
取得に失敗した場合はnullを返却します。
getLastModified

Date getLastModified (String key)

更新日付を取得します。
パラメータ
key String 対象となる更新管理キー
返却値
Date 更新日付
更新管理キーが存在しない場合はnullを返却します。
また、取得に失敗した場合はnullを返却します。
isUpDate

Boolean isUpDate (String key ,String now)

更新管理キーの更新日付が検証日付より新しいか検証します。
パラメータ
key | String | 対象となる更新管理キー
now | String | 検証する日付
返却値
Boolean 検証日付以降更新されていない：false
検証日付以降更新された：true
更新管理キーが存在しない場合： true
取得に失敗した場合：true
modify

Date modify (String key)

対象となる更新管理キーの更新日付を更新します。

更新日付にはこのメソッドが呼び出された時の日付が自動的に設定されます。
更新管理キーが存在しない場合は、新規に設定します。
パラメータ
key String 対象となる更新管理キー
返却値
Date 設定された更新日付
取得に失敗した場合はnullを返却します。
remove

Boolean remove (String key)

更新管理キーを削除します。
パラメータ
key String 削除対象の更新管理キー
返却値
Boolean 成功：true / 失敗：false
removeAll

Boolean removeAll ()

すべての更新管理キーを削除します。
返却値
Boolean 成功：true / 失敗：false


 UserInfo オブジェクト

ユーザ情報オブジェクト。
ユーザ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

ユーザ情報オブジェクトの構成は以下の通りです。
（なお、有効期間開始日時と有効期間終了日時をともに設定する場合は、 「有効期間開始日時 < 有効期間終了日時」を満たす必要があります。）
ユーザ情報オブジェクト
ユーザ情報オブジェクト
(Object)
userCode ユーザコード (String)
accountFlag アカウントフラグ (String)
本プロパティはシステム内で利用されます。値を設定しても無視されます。
notes 備考 (String)
sortKey ソートキー (Number)
extended 拡張情報 (拡張マップオブジェクト ExtendedMap)
terms[0..*] 期間化情報の配列 (Array) startDate 有効期間開始日時 (Date)
endDate 有効期間終了日時 (Date)
telephoneNumber 電話番号 (String)
mobileNumber 携帯電話番号 (String)
faxNumber FAX番号 (String)
extensionNumber 内線番号 (String)
extensionFaxNumber 内線FAX番号 (String)
countryCode 国コード (String)
zipCode 郵便番号 (String)
emailAddress1 メールアドレス１ (String)
emailAddress2 メールアドレス２ (String)
mobileEmailAddress 携帯用メール (String)
url URL (String)
extended 拡張情報 (拡張マップオブジェクト ExtendedMap)
locales 期間国際化情報 (Object) Locale ID
(ja, en等のロケールID)
(Object) 		name ユーザ名 (String)
nameSyllabary ユーザ名カナ (String)
nameEnglish ユーザ名英字 (String)
address 住所 (String)
extended 拡張情報 (拡張マップオブジェクト ExtendedMap)

バージョン：1.0
導入されたバージョン：5.0
プロパティの概要
String | accountFlag アカウントフラグ。 | 読込み専用
ExtendedMap | extended 拡張情報。 | 通常
String | notes 備考。 | 通常
Number | sortKey ソートキー。 | 通常
Array | terms 期間化情報の配列。 | 通常
String | terms[0..*].countryCode 国コード。 | 通常
String | terms[0..*].emailAddress1 メールアドレス１。 | 通常
String | terms[0..*].emailAddress2 メールアドレス２。 | 通常
Date | terms[0..*].endDate 有効期間終了日時。 | 通常
ExtendedMap | terms[0..*].extended 拡張情報。 | 通常
String | terms[0..*].extensionFaxNumber 内線FAX番号。 | 通常
String | terms[0..*].extensionNumber 内線番号。 | 通常
String | terms[0..*].faxNumber FAX番号。 | 通常
Object | terms[0..*].locales 期間国際化情報。 | 通常
String | terms[0..*].locales[ロケール].address 住所。 | 通常
ExtendedMap | terms[0..*].locales[ロケール].extended 拡張情報。 | 通常
String | terms[0..*].locales[ロケール].name ユーザ名。 | 通常
String | terms[0..*].locales[ロケール].nameEnglish ユーザ名英字。 | 通常
String | terms[0..*].locales[ロケール].nameSyllabary ユーザ名カナ。 | 通常
String | terms[0..*].mobileEmailAddress モバイルメールアドレス。 | 通常
String | terms[0..*].mobileNumber 携帯電話番号。 | 通常
Date | terms[0..*].startDate 有効期間開始日時。 | 通常
String | terms[0..*].telephoneNumber 電話番号。 | 通常
String | terms[0..*].url URL。 | 通常
String | terms[0..*].zipCode 郵便番号。 | 通常
String | userCode ユーザコード。 | 通常
プロパティの詳細
accountFlag

String accountFlag (読込み専用プロパティ)

アカウントフラグ。
本プロパティはシステム内で利用されます。値を設定しても無視されます。
extended

ExtendedMap extended

拡張情報。
notes

String notes

備考。
sortKey

Number sortKey

ソートキー。
terms

Array terms

期間化情報の配列。
terms[0..*].countryCode

String terms[0..*].countryCode

国コード。
terms[0..*].emailAddress1

String terms[0..*].emailAddress1

メールアドレス１。
terms[0..*].emailAddress2

String terms[0..*].emailAddress2

メールアドレス２。
terms[0..*].endDate

Date terms[0..*].endDate

有効期間終了日時。
terms[0..*].extended

ExtendedMap terms[0..*].extended

拡張情報。
terms[0..*].extensionFaxNumber

String terms[0..*].extensionFaxNumber

内線FAX番号。
terms[0..*].extensionNumber

String terms[0..*].extensionNumber

内線番号。
terms[0..*].faxNumber

String terms[0..*].faxNumber

FAX番号。
terms[0..*].locales

Object terms[0..*].locales

期間国際化情報。
terms[0..*].locales[ロケール].address

String terms[0..*].locales[ロケール].address

住所。
terms[0..*].locales[ロケール].extended

ExtendedMap terms[0..*].locales[ロケール].extended

拡張情報。
terms[0..*].locales[ロケール].name

String terms[0..*].locales[ロケール].name

ユーザ名。
terms[0..*].locales[ロケール].nameEnglish

String terms[0..*].locales[ロケール].nameEnglish

ユーザ名英字。
terms[0..*].locales[ロケール].nameSyllabary

String terms[0..*].locales[ロケール].nameSyllabary

ユーザ名カナ。
terms[0..*].mobileEmailAddress

String terms[0..*].mobileEmailAddress

モバイルメールアドレス。
terms[0..*].mobileNumber

String terms[0..*].mobileNumber

携帯電話番号。
terms[0..*].startDate

Date terms[0..*].startDate

有効期間開始日時。
terms[0..*].telephoneNumber

String terms[0..*].telephoneNumber

電話番号。
terms[0..*].url

String terms[0..*].url

URL。
terms[0..*].zipCode

String terms[0..*].zipCode

郵便番号。
userCode

String userCode

ユーザコード。


 UserManager オブジェクト

UserManagerオブジェクト。

ユーザに関連する情報の更新を行うマネージャオブジェクトです。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
UserManager (String user ,String group)
コンストラクタ

メソッドの概要
ResultInfo | addUser (UserInfo user) ユーザを登録します。
ResultInfo | deleteUser (UserInfo user) 登録済のユーザを削除します。
ResultInfo | getUser (String userCode) 登録済のユーザ情報を取得します。
ResultInfo | updateUser (UserInfo user) 登録済のユーザを更新します。
コンストラクタの詳細
UserManager

UserManager (String user ,String group)
コンストラクタ
パラメータ
user | String | ログインユーザ
group | String | ログイングループ
メソッドの詳細
addUser

ResultInfo addUser (UserInfo user)

ユーザを登録します。

パラメータ
user UserInfo ユーザ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
deleteUser

ResultInfo deleteUser (UserInfo user)

登録済のユーザを削除します。

指定されたユーザの情報が存在しない場合は処理失敗となります。
パラメータ
user UserInfo ユーザ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト
getUser

ResultInfo getUser (String userCode)

登録済のユーザ情報を取得します。

パラメータ
userCode String ユーザコード
返却値
ResultInfo 処理結果オブジェクト
処理結果オブジェクトの data 属性にユーザ情報オブジェクトが設定されます。
指定されたユーザ情報が存在しない場合は、data 属性に null が設定されます。
導入されたバージョン：5.1
updateUser

ResultInfo updateUser (UserInfo user)

登録済のユーザを更新します。

パラメータ
user UserInfo ユーザ情報オブジェクト
返却値
ResultInfo 処理結果オブジェクト


 URL オブジェクト

URL操作クラス。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
URL (String page_path)
コンストラクタ。
メソッドの概要
String | absoluteLocation () ＵＲＬ（絶対パス）を取得します。
static String | createSessionURL (String url) 指定のＵＲＬに現在のセッションを維持するための情報を付加した ＵＲＬを作成して返します。
static String | decode (String target [,String enc]) ＵＲＬデコードを行います。
static String | encode (String target [,String enc]) ＵＲＬエンコードを行います。
String | getArgument () ＵＲＬ引数を取得します。
String | location () ＵＲＬを取得します。
void | setAction (String func_name) リクエスト時起動関数引数を設定します。
void | setArgument (String name ,String value) ＵＲＬ引数を設定します。
void | setLabel (String name) ラベルを設定します。
コンストラクタの詳細
URL

URL (String page_path)
コンストラクタ。
パラメータ
page_path String プログラムのページパス
メソッドの詳細
absoluteLocation

String absoluteLocation ()

ＵＲＬ（絶対パス）を取得します。
返却値
String ＵＲＬ文字列（完全体）
createSessionURL

static String createSessionURL (String url)

指定のＵＲＬに現在のセッションを維持するための情報を付加した ＵＲＬを作成して返します。
パラメータ
url String ＵＲＬ
返却値
String セッションを維持したまま遷移するためのＵＲＬ
decode

static String decode (String target [,String enc])

ＵＲＬデコードを行います。

引数 enc には、ＵＲＬエンコード時に利用した文字エンコーディング名を指定します。
引数 enc には、Java-VM が解釈できる文字エンコーディング名を指定します。
引数 enc を省略した場合は、Application Runtime が稼動しているJava-VMのデフォルト文字エンコーディングが指定されます。
パラメータ
target | String | デコード対象文字列
enc | String | ＵＲＬエンコード時に利用した文字エンコーディング名（任意）。省略した場合、Application Runtimeが稼動しているJavaVMのデフォルト文字エンコーディングが指定されます。
返却値
String ＵＲＬデコード結果文字列
encode

static String encode (String target [,String enc])

ＵＲＬエンコードを行います。

引数 enc には、ＵＲＬエンコード後の文字エンコーディング名を指定します。
引数 enc には、Java-VM が解釈できる文字エンコーディング名を指定します。
引数 enc を省略した場合は、Application Runtime が稼動しているJava-VMのデフォルト文字エンコーディングが指定されます。
パラメータ
target | String | エンコード対象文字列
enc | String | エンコード後の文字エンコーディング（任意）。省略した場合、Application Runtimeが稼動しているJavaVMのデフォルト文字エンコーディングが指定されます。
返却値
String ＵＲＬエンコード結果文字列
getArgument

String getArgument ()

ＵＲＬ引数を取得します。
name=value&name=value形式の文字列です。
返却値
String ＵＲＬ引数文字列
location

String location ()

ＵＲＬを取得します。
返却値
String ＵＲＬ文字列
setAction

void setAction (String func_name)

リクエスト時起動関数引数を設定します。
パラメータ
func_name String JavaScript関数名
返却値
void
setArgument

void setArgument (String name ,String value)

ＵＲＬ引数を設定します。
パラメータ
name | String | キー
value | String | 値
返却値
void
setLabel

void setLabel (String name)

ラベルを設定します。
パラメータ
name String ラベル名
返却値
void


 VirtualFile オブジェクト

VirtualFile操作クラス。
バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
VirtualFile (Strig fileName)
ファイルオブジェクトを生成します。
メソッドの概要
Boolean | append (String strm) ファイルへのデータ追記出力します。
Array | directories () ディレクトリの一覧を取得します。
Boolean | exist () ファイルまたはディレクトリの存在をチェックします。
Array | files () ファイルの一覧を取得します。
Boolean | isDirectory () ディレクトリの存在をチェックします。
Boolean | isFile () ファイルの存在をチェックします。
Number | lastModified () 最終更新時刻の取得をします。
Array | lists () ディレクトリ中のファイルの一覧を取得します。
String | load () ファイルの内容を取得します。
Boolean | makeDirectories () ディレクトリを新規作成します。
Boolean | move (String newFile) ファイル名を変更します。
String | path () ファイルまたはディレクトリの名前を取得します。
String | read () ファイルの内容を取得します。
Boolean | remove () ファイルまたはディレクトリを削除します。
Boolean | save (String strm) ファイルへのデータ出力します。
Number | size () ファイルサイズを取得します。
Boolean | write (String strm) ファイルへデータ出力します。
コンストラクタの詳細
VirtualFile

VirtualFile (Strig fileName)
ファイルオブジェクトを生成します。
new VirtualFile(file_name) file_name: ファイル名(必須)
パラメータ
fileName Strig ファイル名
メソッドの詳細
append

Boolean append (String strm)

ファイルへのデータ追記出力します。

コンストラクタで指定されたファイルパスにアクセスします。
出力データは Unicode とみなしてローカルの文字コードに変換した結果を出力します。
パラメータ
strm String ファイルへ書き込むデータ（テキスト）
返却値
Boolean 真値：成功/偽値：失敗
directories

Array directories ()

ディレクトリの一覧を取得します。

このオブジェクトが示すディレクトリ下のディレクトリを検索します。
返却は、ＪＳの配列データ。各要素は、ディレクトリ名称。
返却値
Array 一覧配列
exist

Boolean exist ()

ファイルまたはディレクトリの存在をチェックします。
返却値
Boolean 真値：存在を確認/偽値：存在しない
files

Array files ()

ファイルの一覧を取得します。

このオブジェクトが示すディレクトリ下のファイルを検索
返却は、ＪＳの配列データ。各要素は、ファイル名称。
返却値
Array 一覧配列
isDirectory

Boolean isDirectory ()

ディレクトリの存在をチェックします。
返却値
Boolean 真値：ディレクトリとしての存在を確認/偽値：ディレクトリとして存在しない
isFile

Boolean isFile ()

ファイルの存在をチェックします。
返却値
Boolean 真値：ファイルとしての存在を確認/偽値：ファイルとして存在しない
lastModified

Number lastModified ()

最終更新時刻の取得をします。
返却値
Number ファイルが最後に変更された時刻をあらわす数値。
00:00:00 GMT. January 1, 1970 からのミリ秒
ファイルが存在しないか、入出力エラーの場合 0L
lists

Array lists ()

ディレクトリ中のファイルの一覧を取得します。

ディレクトリに含まれるすべてのファイルを検索します。
ファイル名の取得対象は、サブディレクトリに存在するファイルも含まれます。
ディレクトリは取得対象ではありません。
Arrayの各要素は String です。
返却値
Array ファイル名の配列
load

String load ()

ファイルの内容を取得します。

ファイルデータはバイナリ形式で取得されます。

以下の場合は、空の配列が返却されます。
・対象パスのファイルの内容が空

また,以下の場合は、nullが返却されます。
・対象パスのファイルが存在しない
・対象パスがディレクトリ
・対象パスに使用できない文字が使用されていた場合
・入出力エラーが発生した場合
返却値
String ファイルの内容（バイナリ）
makeDirectories

Boolean makeDirectories ()

ディレクトリを新規作成します。

存在していない必要な親ディレクトリも同時に作成します。
返却値
Boolean 真値：生成成功/偽値：生成失敗
move

Boolean move (String newFile)

ファイル名を変更します。
パラメータ
newFile String 新しいファイル名
返却値
Boolean 真値：名称変更に成功/偽値：名称変更に失敗
path

String path ()

ファイルまたはディレクトリの名前を取得します。
返却値
String ファイルまたはディレクトリ名
read

String read ()

ファイルの内容を取得します。

ファイル内のテキストを Unicode に変換して返します。
テキストは、Storage Service の動作している Service Platform のサーバ側文字コードに設定されている文字コードで あるものとして読み込みます。

以下の場合は、空文字列が返却されます。
・対象パスのファイルが存在しない
・対象パスがディレクトリ
・対象パスのファイルの内容が空

また、以下の場合は、nullが返却されます。
・対象パスに使用できない文字が使用されていた場合 ・入出力エラーが発生した場合
返却値
String ファイルの内容（テキスト）
remove

Boolean remove ()

ファイルまたはディレクトリを削除します。

ディレクトリが削除されるためには空である必要があります。
返却値
Boolean 真値：ファイルまたはディレクトリが正常の削除された/偽値：削除失敗
save

Boolean save (String strm)

ファイルへのデータ出力します。

コンストラクタで指定されたファイルパスにアクセスします。
パラメータ
strm String ファイルへ書き込むデータ（バイナリ）
返却値
Boolean 真値：成功/偽値：失敗
size

Number size ()

ファイルサイズを取得します。
返却値
Number ファイルサイズ(バイト単位)/ファイルが存在しない場合 0L
write

Boolean write (String strm)

ファイルへデータ出力します。

コンストラクタで指定されたファイルパスにアクセスします。
出力データは Unicode とみなしてローカルの文字コードに変換した結果を出力します。
パラメータ
strm String ファイルへ書き込むデータ（テキスト）
返却値
Boolean 真値：成功/偽値：失敗


 Web オブジェクト

Webクラス。
バージョン：1.0
導入されたバージョン：5.0
メソッドの概要
static String | base () WebサーバのベースURLを取得します。
static String | current () 現在処理中ページパスを取得します。
static String | encodeRedirectURL (String url) グローバル関数「redirect()」の中で使えるように、 指定されたURLをエンコードします。
static String | encodeURL (String url) 指定されたURLがセッションIDを含むようにエンコードします。
static String | getContextPath () リクエストされたURIのうち、 リクエストのコンテキストを指す部分を返します。
static HTTPResponse | getHTTPResponse () レスポンスオブジェクトを返します。
static String | getHTTPResponseHeader (String name) 推奨されていません。代替えメソッドはありません。
static String | getProtocol () リクエストのプロトコル名とバージョンを HTTP/1.1 のように プロトコル名/メジャーバージョン番号.マイナーバージョン番号 の形式で返します。
static String | getRemoteAddr () リクエストを送ってきたクライアントの IP(Internet Protocol) アドレスを返します。
static String | getRemoteHost () リクエストを送ってきたクライアントの FQDN(Fully Qualified Domain Name: 完全修飾ドメイン名)を返します。
static Request | getRequest () リクエストオブジェクトを返します。
static String | getScheme () 例えば http や https, ftp のようなリクエストのスキームを返します。
static String | getServerName () リクエストを受け取ったサーバのホスト名を返します。
static int | getServerPort () このリクエストを受け取るのに使われたポート番号を返します。
static String | getenv (String ref_name) CGI 環境変数データを取得します。
static String | host () Ｗｅｂサーバ名を取得します。
static Boolean | isSecure () このリクエストが HTTPS のようなセキュアなチャネルを使って 送られたものかどうかを示す boolean を返します。
static String | location () リクエストURLを取得します。
static int | port () ＷｅｂサーバのＨＴＴＰポートを取得します。
static String | protocol () Ｗｅｂサーバのプロトコルを取得します。
static String | referer () リクエストを要求したページパスを取得します。
static String | referrer () 推奨されていません。Web.refererに置き換えられました。
static String | removeHTTPResponseHeader (String name) 推奨されていません。代替えメソッドはありません。
static String | script () Ｗｅｂサーバスクリプト名を取得します。
static void | setHTTPResponseHeader (String name ,String value) HTTP ヘッダを設定します。
メソッドの詳細
base

static String base ()

WebサーバのベースURLを取得します。
"http://server:port/path" を返却します。
返却値
String ベースURL
current

static String current ()

現在処理中ページパスを取得します。
返却値
String 処理中のページパス
encodeRedirectURL

static String encodeRedirectURL (String url)

グローバル関数「redirect()」の中で使えるように、 指定されたURLをエンコードします。
エンコードが不要である場合は指定されたURLをそのまま返します。 このメソッドの実装はセッションIDを URLにエンコードするかどうかを決定するためのロジックを含みます。
このメソッドがencodeURLメソッドとは別になっているのは、 この決定をするための規則が通常のリンクをエンコードするかどうかを 決定する規則と異なることがあるからです。
グローバル関数「redirect()」に送られる全てのURLは このメソッドを通すべきです。
そうでなければ、Cookieをサポートしないブラウザでは URLの書き換えによるセッション管理を使用する事はできません。
パラメータ
url String エンコードするURL
返却値
String エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
encodeURL

static String encodeURL (String url)

指定されたURLがセッションIDを含むようにエンコードします。
パラメータ
url String エンコードするURL
返却値
String エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
getContextPath

static String getContextPath ()

リクエストされたURIのうち、 リクエストのコンテキストを指す部分を返します。
コンテキストパスは通常リクエストURIの最初に来ます。 コンテキストパスは "/" から始まりますが、"/" では終わりません。
デフォルト（ルート）のコンテキストに属するServletの場合、 このメソッドは "" を返します。
コンテナはこの文字列をデコードしません。
返却値
String リクエストされたURIのうち、 リクエストのコンテキストを指す部分のString
getHTTPResponse

static HTTPResponse getHTTPResponse ()

レスポンスオブジェクトを返します。
返却値
HTTPResponse レスポンス
getHTTPResponseHeader

static String getHTTPResponseHeader (String name)

推奨されていません。代替えメソッドはありません。
HTTP ヘッダを取得します。
パラメータ
name String HTTPヘッダの名称（文字列）
返却値
String 常にnullを返します。
getProtocol

static String getProtocol ()

リクエストのプロトコル名とバージョンを HTTP/1.1 のように プロトコル名/メジャーバージョン番号.マイナーバージョン番号 の形式で返します。
HTTP Servlet ではこのメソッドで取得できる値は CGI で使用する環境変数の SERVER_PROTOCOL と同等です。
返却値
String プロトコル名とバージョンを示す
getRemoteAddr

static String getRemoteAddr ()

リクエストを送ってきたクライアントの IP(Internet Protocol) アドレスを返します。
HTTP Servlet では CGI で使用される環境変数の REMOTE_ADDR と同等です。
返却値
String リクエストを送ってきたクライアントの IP アドレスを示す文字列
getRemoteHost

static String getRemoteHost ()

リクエストを送ってきたクライアントの FQDN(Fully Qualified Domain Name: 完全修飾ドメイン名)を返します。
コンテナがホスト名を解決できないか、 (パフォーマンスを上げるため)解決しないように設定されている場合は IP アドレスをピリオドで区切った形式にして返します。
HTTP Servlet では CGI で使用される環境変数の REMOTE_HOST と同等です。
返却値
String クライアントの FQDN(Fullu Qualified Domain Name) を示す String
getRequest

static Request getRequest ()

リクエストオブジェクトを返します。
返却値
Request リクエストオブジェクト
導入されたバージョン：6.1
getScheme

static String getScheme ()

例えば http や https, ftp のようなリクエストのスキームを返します。
RFC1738 で詳説されているように、スキームが違うと URL の形式も 違ってきます。
返却値
String このリクエストに使われたスキームを示す文字列
getServerName

static String getServerName ()

リクエストを受け取ったサーバのホスト名を返します。
HTTP Servlet では CGI で使用する環境変数の SERVER_NAME と同等です。
返却値
String リクエストが送り込まれたサーバの名前を示す
getServerPort

static int getServerPort ()

このリクエストを受け取るのに使われたポート番号を返します。
HTTP Servlet では CGI で使用される環境変数の SERVER_PORT と同等です。
返却値
int ポート番号を示す整数値
getenv

static String getenv (String ref_name)

CGI 環境変数データを取得します。
ＣＧＩ環境変数引数を取得
指定キーに該当するＣＧＩ環境変数が存在しない場合は null
パラメータ
ref_name String CGI 環境変数参照名称
返却値
String 環境変数データ
host

static String host ()

Ｗｅｂサーバ名を取得します。
返却値
String Ｗｅｂサーバ名
isSecure

static Boolean isSecure ()

このリクエストが HTTPS のようなセキュアなチャネルを使って 送られたものかどうかを示す boolean を返します。
返却値
Boolean リクエストがセキュアなチャネルを使って送られたものかどうかを示す boolean
location

static String location ()

リクエストURLを取得します。
返却値
String リクエストURL
port

static int port ()

ＷｅｂサーバのＨＴＴＰポートを取得します。
返却値
int ＷｅｂサーバのＨＴＴＰ待ち受けポート
protocol

static String protocol ()

Ｗｅｂサーバのプロトコルを取得します。
返却値
String Ｗｅｂサーバのプロトコル
referer

static String referer ()

リクエストを要求したページパスを取得します。
返却値
String リクエストを要求したページパス
referrer

static String referrer ()

推奨されていません。Web.refererに置き換えられました。
リクエストを要求したページパスを取得します。
返却値
String リクエストを要求したページパス
removeHTTPResponseHeader

static String removeHTTPResponseHeader (String name)

推奨されていません。代替えメソッドはありません。
HTTPヘッダ情報を削除します。
パラメータ
name String HTTPヘッダの名称（文字列）
返却値
String 常にnullを返します。
script

static String script ()

Ｗｅｂサーバスクリプト名を取得します。
返却値
String Ｗｅｂスクリプトファイル名
setHTTPResponseHeader

static void setHTTPResponseHeader (String name ,String value)

HTTP ヘッダを設定します。
パラメータ
name | String | HTTPヘッダの名称（文字列）
value | String | 値（文字列）
返却値
void


 XMLDocument オブジェクト

XMLを解析するパーサーオブジェクト。

XML を解析するパーサーを提供します。
このオブジェクトでは、XML の各タグをノードとして管理します。
各ノードは､属性と子供ノードを持ちます。
属性と子供ノードは複数持つ事ができ、子供ノードは更に属性と子供ノードを持つ事が出来ます。 すべてのノードの頂点となる親ノード（ドキュメントノード）は、XML ソース中の最も外側のタグであり、getDocumentElement() によって取得する事が出来ます。
ドキュメントノードが複数存在する場合は、XML 解析エラーとなりますのでご注意下さい。

XMLを解析してDOMツリーを作成するには、コンストラクタを使います。

例えば、以下のようなＸＭＬ
<A>
<B>Ｂタグの中のテキスト</B>
<C>Ｃタグの中のテキスト</C>
</A>

から、<C> タグに囲まれたテキスト値を取得する場合は以下のようにプログラムします。
var xml = "<A><B>Ｂタグの中のテキスト</B><C>Ｃタグの中のテキスト</C></A>";
var dom = new XMLDocument(xml);
var elms = dom.getElementsByTagName("C");
var elm = elms[0];
var childs = elm.getChildNodes();
var data = childs[0].getValue();
Debug.print("C's text: " + data);
バージョン：1.0
導入されたバージョン：3.0
コンストラクタの概要
XMLDocument (String src)
コンストラクタ。
メソッドの概要
DOMNode | createElement (String tagName) 新しいノードを作成します。
DOMNode | createTextNode (String data) 新しいテキストノードを作成します。
DOMDocumentType | getDoctype () ドキュメントタイプを取得します。
DOMNode | getDocumentElement () Documentノードを取得します。
DOMNode | getElementById (String elementId) 識別子に該当するノードを取得します。
Array | getElementsByTagName (String tagname) 指定のタグにマッチするエレメントを取得します。
String | getXmlString () XMLの文字列を取得します。
Boolean | isError () エラー発生のチェックを行います。
コンストラクタの詳細
XMLDocument

XMLDocument (String src)
コンストラクタ。

XML ソースを解析して各エンティティを操作するためのオブジェクトを構築します。
パラメータ
src String XML ソース
メソッドの詳細
createElement

DOMNode createElement (String tagName)

新しいノードを作成します。

パラメータ
tagName String タグ名
返却値
DOMNode 新しいノードオブジェクト
createTextNode

DOMNode createTextNode (String data)

新しいテキストノードを作成します。

パラメータ
data String テキスト
返却値
DOMNode 新しいノードオブジェクト
getDoctype

DOMDocumentType getDoctype ()

ドキュメントタイプを取得します。

返却値
DOMDocumentType ドキュメントタイプオブジェクト
getDocumentElement

DOMNode getDocumentElement ()

Documentノードを取得します。

返却値
DOMNode ドキュメントを示すノード
getElementById

DOMNode getElementById (String elementId)

識別子に該当するノードを取得します。

指定の識別子にマッチしたノードを返します。
指定の識別子を持つノードが存在しなかった場合 null を返します。
パラメータ
elementId String ノード識別子
返却値
DOMNode ノードオブジェクト
getElementsByTagName

Array getElementsByTagName (String tagname)

指定のタグにマッチするエレメントを取得します。

XML ソース中から指定のタグに該当するエンティティを返します。
返却値は、DOMNode オブジェクトを要素に持つ配列です。
不整合が発生してデータが取得できなかった場合 null が返ります。
パラメータ
tagname String タグ名
返却値
Array ノードオブジェクト(DOMNode)の配列
getXmlString

String getXmlString ()

XMLの文字列を取得します。

返却値
String XML文字列
導入されたバージョン：5.0
isError

Boolean isError ()

エラー発生のチェックを行います。

XML ソースを解析中にエラーが発生していた場合 true を返します。
返却値
Boolean true : エラーあり / false : エラーなし


 XMLParser オブジェクト

XMLを解析するパーサーオブジェクト。

XML を解析するパーサーを提供します。
ドキュメントノードが複数存在する場合は、XML 解析エラーとなりますのでご注意下さい。

バージョン：1.0
導入されたバージョン：5.0
コンストラクタの概要
XMLParser ()
コンストラクタ。
メソッドの概要
String | getErrorMessage () エラーメッセージの取得を行います。
Boolean | isError () エラー発生のチェックを行います。
DOMDocument | parse (String path) Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
DOMDocument | parse (File file) Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
DOMDocument | parse (VirtualFile virtualFile) Storage Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
DOMDocument | parseString (String src) 引数で与えられた文字列を XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。
コンストラクタの詳細
XMLParser

XMLParser ()
コンストラクタ。

XMLを解析するパーサーオブジェクトを構築します。
メソッドの詳細
getErrorMessage

String getErrorMessage ()

エラーメッセージの取得を行います。

XML ソースを解析中にエラーが発生していた場合、そのエラーメッセージを返します。
返却値
String エラーメッセージ
isError

Boolean isError ()

エラー発生のチェックを行います。

XML ソースを解析中にエラーが発生していた場合 true を返します。
返却値
Boolean true : エラーあり / false : エラーなし
parse

DOMDocument parse (String path)

Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

パラメータ
path String Application Runtime 環境のファイル・パス (Application Runtimeが稼動しているマシン上での絶対パス、または、 システムプロパティ user.dir で指定されるディレクトリからの相対パス)
返却値
DOMDocument DOMDocumentオブジェクト
parse

DOMDocument parse (File file)

Application Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

パラメータ
file File ファイル操作オブジェクト
返却値
DOMDocument DOMDocumentオブジェクト
parse

DOMDocument parse (VirtualFile virtualFile)

Storage Runtime 環境のファイルコンテンツを XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

パラメータ
virtualFile VirtualFile VirtualFile操作クラス
返却値
DOMDocument DOMDocumentオブジェクト
parseString

DOMDocument parseString (String src)

引数で与えられた文字列を XML ドキュメントとして構文解析し、 新しい DOMDocument オブジェクトを返します。

例えば、以下のようなＸＭＬ
 <A>
   <B>Ｂタグの中のテキスト</B>
   <C>Ｃタグの中のテキスト</C>
 </A>
から、<C> タグに囲まれたテキスト値を取得する場合は以下のようにプログラムします。

 var xmlString = "<A><B>Ｂタグの中のテキスト</B><C>Ｃタグの中のテキスト</C></A>";

 var parser = new XMLParser();
 var dom = parser.parseString(xmlString);

 if(!parser.isError()){
     var elms = dom.getElementsByTagName("C");
     var elm = elms[0];
     var childs = elm.getChildNodes();
     var data = childs[0].getValue();

     Debug.print("C's text: " + data);
 }
 else {
     Debug.print("Error occured ! : " + parser.getErrorMessage() );
 }
パラメータ
src String XML形式の文字列
返却値
DOMDocument DOMDocumentオブジェクト


クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の使用

AccountSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での AccountSecurityHTTPActionEventFilterHandler のサブクラス
 class PasswordSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の使用

GroupSecurityHTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での GroupSecurityHTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent の使用

HTTPActionEventContent を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.core |

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventContent の使用

HTTPActionEventContent を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventContent HTTPActionEventURL.getContent()
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。

jp.co.intra_mart.foundation.service.client.application.core での HTTPActionEventContent の使用

HTTPActionEventContent を実装している jp.co.intra_mart.foundation.service.client.application.core のクラス
 class HTTPActionEventContentImpl
サーバからのＵＲＬ情報を取得するための便利オブジェクト。

HTTPActionEventContent を返す jp.co.intra_mart.foundation.service.client.application.core のメソッド
 HTTPActionEventContent HTTPActionEventURLImpl.getContent()
HTTPActionEventURLImpl.getURL() によって表されるコンテンツのソースを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler の使用

HTTPActionEventEntityHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventEntityHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventEntityHandler のサブクラス
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler の使用

HTTPActionEventFilterHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventFilterHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventFilterHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler の使用

HTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandler のサブクラス
class | AccountSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ConcreteHTTPActionEventHandler 任意の HTTPActionEvent を実行するためのハンドラです。
class | GroupSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | HTTPActionEventEntityHandler jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
class | HTTPActionEventFilterHandler HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
class | LimitedSessionHTTPActionEventFilterHandler セッションを一時利用のみに限定するためのフィルタです。
class | PasswordSecurityHTTPActionEventFilterHandler ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。
class | WebApplicationHTTPActionEventHandler フレームワークを実行するためのイベントハンドラの抽象実装です。

HTTPActionEventHandler を返す jp.co.intra_mart.foundation.service.client.application のメソッド
 HTTPActionEventHandler HTTPActionEventFilterHandler.getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandler のサブクラス
class | AccessibleLinkHTTPActionEventFilterHandler 再接続の為のＵＲＬを制御するフィルタ実装です。
class | ActivityFrameworkHTTPActionEventFilterHandler 推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

HTTPActionEventHandler 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application.content のコンストラクタ
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException の使用

HTTPActionEventHandlerException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerException のサブクラス
 class HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

HTTPActionEventHandlerException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application のメソッド
protected abstract Properties | WebApplicationHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ServletHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected abstract Properties | HTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
protected Properties | HTTPActionEventFilterHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | HTTPActionEventEntityHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | ActivityHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

jp.co.intra_mart.foundation.service.client.application.content での HTTPActionEventHandlerParameterException の使用

HTTPActionEventHandlerParameterException をスローする jp.co.intra_mart.foundation.service.client.application.content のメソッド
protected Properties | ServiceFrameworkHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected Properties | PresentationPageHTTPActionEventHandler.getEventRequestParameterMap() イベントに対するパラメータのマップを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult の使用

HTTPActionEventResult を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.core |

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult の使用

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventResult のサブインタフェース
interface | HTTPActionEventContent Web コンテンツを取得するための共通インターフェースです。
interface | HTTPActionEventURL Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

HTTPActionEventResult を実装している jp.co.intra_mart.foundation.service.client.application のクラス
 class HTTPActionEventResultWrapper
HTTPActionEventResult のラッパーオブジェクトです。

HTTPActionEventResult を返す jp.co.intra_mart.foundation.service.client.application のメソッド
protected HTTPActionEventResult | HTTPActionEventResultWrapper.getParent() ラップしている親オブジェクトを返します。
HTTPActionEventResult | HTTPActionEventHandler.execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | HTTPActionEventHandler.execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

HTTPActionEventResult 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application のコンストラクタ
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

jp.co.intra_mart.foundation.service.client.application.core での HTTPActionEventResult の使用

HTTPActionEventResult を実装している jp.co.intra_mart.foundation.service.client.application.core のクラス
class | HTTPActionEventContentImpl サーバからのＵＲＬ情報を取得するための便利オブジェクト。
class | HTTPActionEventResultImpl HTTPActionEvent 実行要求の結果に関する共通インターフェースの実装です。
class | HTTPActionEventURLImpl サーバからのＵＲＬ情報を取得するための便利オブジェクト。

HTTPActionEventResult 型のパラメータを持つ jp.co.intra_mart.foundation.service.client.application.core のコンストラクタ
HTTPActionEventURLImpl(HTTPActionEventResult result)
新しいＵＲＬ取得オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper の使用

HTTPActionEventResultWrapper を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application.core

jp.co.intra_mart.foundation.service.client.application.core での HTTPActionEventResultWrapper の使用

jp.co.intra_mart.foundation.service.client.application.core での HTTPActionEventResultWrapper のサブクラス
class | HTTPActionEventContentImpl サーバからのＵＲＬ情報を取得するための便利オブジェクト。
class | HTTPActionEventURLImpl サーバからのＵＲＬ情報を取得するための便利オブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL の使用

HTTPActionEventURL を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.core |

jp.co.intra_mart.foundation.service.client.application での HTTPActionEventURL の使用

HTTPActionEventURL を返す jp.co.intra_mart.foundation.service.client.application のメソッド
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | WebApplicationHTTPActionEventHandler.getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

jp.co.intra_mart.foundation.service.client.application.core での HTTPActionEventURL の使用

HTTPActionEventURL を実装している jp.co.intra_mart.foundation.service.client.application.core のクラス
 class HTTPActionEventURLImpl
サーバからのＵＲＬ情報を取得するための便利オブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler の使用

ServletHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での ServletHTTPActionEventHandler のサブクラス
 class ActivityHTTPActionEventHandler
持続したセッションを確立するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の使用

WebApplicationHTTPActionEventHandler を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application での WebApplicationHTTPActionEventHandler のサブクラス
class | ActivityHTTPActionEventHandler 持続したセッションを確立するためのハンドラです。
class | ServletHTTPActionEventHandler Web-Application を実行するためのイベントハンドラです。

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content での WebApplicationHTTPActionEventHandler のサブクラス
class | PresentationPageHTTPActionEventHandler スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
class | ServiceFrameworkHTTPActionEventHandler im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler の使用

jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessibleLinkHTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス AccessibleLinkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
public class AccessibleLinkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

再接続の為のＵＲＬを制御するフィルタ実装です。

このフィルタを利用する事で、同じセッション内でのその他のリクエストにおいて、 AbsoluteLinkFilter を経由した場合、全ての再接続リクエストのためのＵＲＬが 絶対形式の表現となります。
つまり、返される画面ソース(HTML)内の、 <FORM> の action 属性や、<A> の href 属性に指定する URL が、プロトコルおよびサーバアドレス等を含む絶対形式となります (javax.servlet.HttpServletResponse#encodeURL(java.lang.String) を利用して URL をエンコードしなかった場合は除く)。

これにより、例えばポータルサーバが別サイトとして運用されている場合においても、 各ポートレット内に配置されたリンクやフォームからシステムに直接アクセス できるようになります。

このフィルタは、サーバでの処理実行時に HttpSession が開始されていなかった場合、 HttpSession を新しく開始するように働きます。 それでもセッションを取得できなかった場合、将来の予期せぬエラーを防ぐため、 例外をスローしてサーバ処理をエラー終了します。 結果として、ハンドラの #execute() メソッドは、エラーを示す結果オブジェクトを 返す事になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessibleLinkHTTPActionEventFilterHandler

public AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityFrameworkHTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ActivityFrameworkHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

public class ActivityFrameworkHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

サービスフレームワークおよびプレゼンテーションフレームワークの実行環境を作成するためのフィルタ実装です。

このフィルタを利用する場合、事前にログイン環境を作成しておく必要があります。 したがって、AccountSecurityHTTPActionEventFilterHandler も 併用するようにしてください。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
推奨されていません。 フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityFrameworkHTTPActionEventFilterHandler

public ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
推奨されていません。
フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
推奨されていません。
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application.content (imaca_client 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application.content
クラス
AccessibleLinkHTTPActionEventFilterHandler
ActivityFrameworkHTTPActionEventFilterHandler
PresentationPageHTTPActionEventHandler
ServiceFrameworkHTTPActionEventHandler


jp.co.intra_mart.foundation.service.client.application.content (imaca_client 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

参照:
説明

クラスの概要
AccessibleLinkHTTPActionEventFilterHandler | 再接続の為のＵＲＬを制御するフィルタ実装です。
ActivityFrameworkHTTPActionEventFilterHandler | 推奨されていません。 このフィルタは、何もしません。
PresentationPageHTTPActionEventHandler | スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler | im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

パッケージ jp.co.intra_mart.foundation.service.client.application.content の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。

導入されたバージョン:
version 4.0


jp.co.intra_mart.foundation.service.client.application.content クラス階層 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.content の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler


パッケージ jp.co.intra_mart.foundation.service.client.application.content の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application.content の使用

jp.co.intra_mart.foundation.service.client.application.content はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PresentationPageHTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス PresentationPageHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
public class PresentationPageHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。

このハンドラを利用する事により、指定のプレゼンテーションページを実行して、 画面ソースを取得する事ができます。
主にポータルサーバなどと連携してスクリプト開発モデルによる画面を １つのポートレットとして表示する場合に利用できます。 なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | PresentationPageHTTPActionEventHandler() ハンドラを作成します。
 | PresentationPageHTTPActionEventHandler(String path) ハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getPagePath() 設定されているページパスを返します。
protected void | setPagePath(String url) 実行するスクリプト開発モデルのページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PresentationPageHTTPActionEventHandler

protected PresentationPageHTTPActionEventHandler()
ハンドラを作成します。
このコンストラクタでは、必要な情報が設定されません。

実行するプレゼンテーションページのパスは、 setPagePath(String) で設定してください。

PresentationPageHTTPActionEventHandler

public PresentationPageHTTPActionEventHandler(String path)
ハンドラを作成します。
引数 path には、実行するプレゼンテーションページのパスを設定してください。

パラメータ:
path - スクリプト開発モデルのプログラムパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setPagePath

protected void setPagePath(String url)
実行するスクリプト開発モデルのページパスを設定します。

ページパスは、Resource Service のスクリプト開発モデルの プログラムルート（標準では pages/）からの相対パス指定になります。

パラメータ:
url - 接続ＵＲＬ

getPagePath

public String getPagePath()
設定されているページパスを返します。

戻り値:
ページパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceFrameworkHTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.content
クラス ServiceFrameworkHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
public class ServiceFrameworkHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。

このハンドラを利用する事により、指定のサービスフレームワークを実行して、 画面のソースを取得する事ができます。
主にポータルサーバなどと連携してサービスフレームワークによる画面を １つのポートレットとして表示する場合に利用できます。

なお、 セッションタイムアウト後の 取得した画面ソース内のリンクやフォームによるリクエストは 無効となりますので注意してください。

このクラスは、プレゼンテーションフレームワークに必要な各引数値に関する 共通インターフェースを提供しているだけの抽象実装です。 したがって、このクラスを単独で使用しても正しい結果を得る事はできません。 サブクラスを作成して、適切な実装を追加しなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServiceFrameworkHTTPActionEventHandler() サービスフレームワークを実行するためのハンドラを作成します。
 | ServiceFrameworkHTTPActionEventHandler(String application, String service) サービスフレームワークを実行するためのハンドラを作成します。
メソッドの概要
String | getApplication() 設定されているアプリケーションＩＤを返します。
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
String | getService() 設定されているサービスＩＤを返します。
protected void | setApplication(String id) 実行するフレームワークのアプリケーションＩＤを設定します。
protected void | setService(String id) 実行するフレームワークのサービスＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceFrameworkHTTPActionEventHandler

protected ServiceFrameworkHTTPActionEventHandler()
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

ServiceFrameworkHTTPActionEventHandler

public ServiceFrameworkHTTPActionEventHandler(String application,
                                              String service)
サービスフレームワークを実行するためのハンドラを作成します。

このコンストラクタでは、特に設定を行いません。 イベント実行要求前に、必要な情報の設定を行ってください。

パラメータ:
application - アプリケーションＩＤ
service - サービスＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setApplication

protected void setApplication(String id)
実行するフレームワークのアプリケーションＩＤを設定します。

パラメータ:
id - アプリケーションＩＤ
例外:
NullPointerException - 引数が null の場合

getApplication

public String getApplication()
設定されているアプリケーションＩＤを返します。

戻り値:
アプリケーションＩＤ

setService

protected void setService(String id)
実行するフレームワークのサービスＩＤを設定します。

パラメータ:
id - サービスＩＤ
例外:
NullPointerException - 引数が null の場合

getService

public String getService()
設定されているサービスＩＤを返します。

戻り値:
サービスＩＤ

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl の使用

jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder の使用

jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl の使用

jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl の使用

jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HTTPActionEventContentImpl (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.core
クラス HTTPActionEventContentImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper
        拡張 jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl
すべての実装インタフェース:
HTTPActionEventContent, HTTPActionEventResult
public class HTTPActionEventContentImpl
extends HTTPActionEventResultWrapper
implements HTTPActionEventContent

サーバからのＵＲＬ情報を取得するための便利オブジェクト。

コンストラクタの概要
HTTPActionEventContentImpl(HttpURLConnection connection)
新しいＵＲＬ取得オブジェクトを作成します。
メソッドの概要
byte[] | getBytes() サーバからレスポンスされたコンテンツのソースをバイト列として返します。
URL | getRequestURL() このコンテンツを取得するために使用した URL を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper から継承したメソッド
getConnection, getInputStream, getParent, getResponseCode, getResponseMessage, isError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

コンストラクタの詳細

HTTPActionEventContentImpl

public HTTPActionEventContentImpl(HttpURLConnection connection)
                           throws IOException
新しいＵＲＬ取得オブジェクトを作成します。

メソッドの詳細

getRequestURL

public URL getRequestURL()
このコンテンツを取得するために使用した URL を返します。

定義:
インタフェース HTTPActionEventContent 内の getRequestURL
戻り値:
URL

getBytes

public byte[] getBytes()
                throws IOException
サーバからレスポンスされたコンテンツのソースをバイト列として返します。

何らかのエラーによりソースを受信できなかった場合、 このメソッドは null を返します。

定義:
インタフェース HTTPActionEventContent 内の getBytes
戻り値:
コンテンツソースのバイト列。または null。
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventQueryBuilder (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.core
クラス HTTPActionEventQueryBuilder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
public class HTTPActionEventQueryBuilder
extends Object

HTTPActionEvent 関連のビルダです。

導入されたバージョン:
version 4.3

フィールドの概要
static String | ID_EVENT_NAME サーバにイベント名を送信する時のパラメータ名です。
static String | ID_EVENT_PARAMETER サーバにイベントパラメータを送信する時のパラメータ名です。
static String | ID_EVENT_PARAMETER_CHARSET イベントのパラメータのエンコーディング名を送信するときのパラメータ名です。
static String | ID_EVENT_REQUEST_TIME イベントの実行を要求した時刻を送信するときのパラメータ名です。
コンストラクタの概要
HTTPActionEventQueryBuilder()
イベントビルダを新しく作成します。
メソッドの概要
Properties | decodeParameter(String value) イベントへのパラメータ情報をデコードします。
String | encodeParameter(Properties params) イベントへのパラメータ情報をエンコードします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_EVENT_REQUEST_TIME

public static final String ID_EVENT_REQUEST_TIME
イベントの実行を要求した時刻を送信するときのパラメータ名です。

関連項目:
定数フィールド値

ID_EVENT_NAME

public static final String ID_EVENT_NAME
サーバにイベント名を送信する時のパラメータ名です。

関連項目:
定数フィールド値

ID_EVENT_PARAMETER

public static final String ID_EVENT_PARAMETER
サーバにイベントパラメータを送信する時のパラメータ名です。

関連項目:
定数フィールド値

ID_EVENT_PARAMETER_CHARSET

public static final String ID_EVENT_PARAMETER_CHARSET
イベントのパラメータのエンコーディング名を送信するときのパラメータ名です。

関連項目:
定数フィールド値
コンストラクタの詳細

HTTPActionEventQueryBuilder

public HTTPActionEventQueryBuilder()
イベントビルダを新しく作成します。

メソッドの詳細

encodeParameter

public String encodeParameter(Properties params)
                       throws IOException
イベントへのパラメータ情報をエンコードします。 エンコードされた文字列は、サーバへの送信用に利用します。

パラメータ:
params - パラメータ
戻り値:
エンコードされた文字列
例外:
IOException

decodeParameter

public Properties decodeParameter(String value)
                           throws IOException
イベントへのパラメータ情報をデコードします。

パラメータ:
value - パラメータをエンコードした文字列
戻り値:
復元した Properties
例外:
IOException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResultImpl (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.core
クラス HTTPActionEventResultImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl
すべての実装インタフェース:
HTTPActionEventResult
public class HTTPActionEventResultImpl
extends Object
implements HTTPActionEventResult

HTTPActionEvent 実行要求の結果に関する共通インターフェースの実装です。

導入されたバージョン:
version 4.3

コンストラクタの概要
HTTPActionEventResultImpl(HttpURLConnection connection)
HTTP レスポンスを操作するオブジェクトを作成します。
メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
Throwable | getLastException() 実行要求処理中に発生した例外のうち、最後にスローされたものを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventResultImpl

public HTTPActionEventResultImpl(HttpURLConnection connection)
HTTP レスポンスを操作するオブジェクトを作成します。

パラメータ:
connection - 送信処理済で受信待ち状態のコネクション
メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

定義:
インタフェース HTTPActionEventResult 内の getConnection
戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 HttpURLConnection の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

定義:
インタフェース HTTPActionEventResult 内の getResponseCode
戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

定義:
インタフェース HTTPActionEventResult 内の getResponseMessage
戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

定義:
インタフェース HTTPActionEventResult 内の getInputStream
戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

このメソッドでは、HTTP のレスポンスコードが 200 かどうかで、 判定しています。

定義:
インタフェース HTTPActionEventResult 内の isError
戻り値:
エラーなく処理終了しなかった場合 true。

getLastException

public Throwable getLastException()
実行要求処理中に発生した例外のうち、最後にスローされたものを返します。 例外が１つもスローされずに実行要求処理を終了した場合は、 null を返します。

戻り値:
実行要求処理中に発生した例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventURLImpl (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application.core
クラス HTTPActionEventURLImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper
        拡張 jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl
すべての実装インタフェース:
HTTPActionEventResult, HTTPActionEventURL
public class HTTPActionEventURLImpl
extends HTTPActionEventResultWrapper
implements HTTPActionEventURL

サーバからのＵＲＬ情報を取得するための便利オブジェクト。

コンストラクタの概要
HTTPActionEventURLImpl(HTTPActionEventResult result)
新しいＵＲＬ取得オブジェクトを作成します。
メソッドの概要
 HTTPActionEventContent getContent()
getURL() によって表されるコンテンツのソースを取得します。
 String getURL()
サーバから返されたＵＲＬを返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper から継承したメソッド
getConnection, getInputStream, getParent, getResponseCode, getResponseMessage, isError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

コンストラクタの詳細

HTTPActionEventURLImpl

public HTTPActionEventURLImpl(HTTPActionEventResult result)
新しいＵＲＬ取得オブジェクトを作成します。

パラメータ:
result - サーバからの応答オブジェクト
メソッドの詳細

getURL

public String getURL()
              throws IOException
サーバから返されたＵＲＬを返します。

定義:
インタフェース HTTPActionEventURL 内の getURL
戻り値:
ＵＲＬ
例外:
IOException - 入出力エラー

getContent

public HTTPActionEventContent getContent()
                                  throws MalformedURLException,
                                         IOException
getURL() によって表されるコンテンツのソースを取得します。

定義:
インタフェース HTTPActionEventURL 内の getContent
戻り値:
サーバからの応答オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application.core (imaca_client 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application.core
クラス
HTTPActionEventContentImpl
HTTPActionEventQueryBuilder
HTTPActionEventResultImpl
HTTPActionEventURLImpl


jp.co.intra_mart.foundation.service.client.application.core (imaca_client 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.core

クラスの概要
HTTPActionEventContentImpl | サーバからのＵＲＬ情報を取得するための便利オブジェクト。
HTTPActionEventQueryBuilder | HTTPActionEvent 関連のビルダです。
HTTPActionEventResultImpl | HTTPActionEvent 実行要求の結果に関する共通インターフェースの実装です。
HTTPActionEventURLImpl | サーバからのＵＲＬ情報を取得するための便利オブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.application.core クラス階層 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application.core の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
    • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
      • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent)
      • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.client.application.core の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application.core の使用

jp.co.intra_mart.foundation.service.client.application.core はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccountSecurityHTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス AccountSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
PasswordSecurityHTTPActionEventFilterHandler
public class AccountSecurityHTTPActionEventFilterHandler
extends GroupSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getAccount() 設定されているアカウントＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setAccount(String accountId) アカウントＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_ACCOUNT

protected static final String ID_SECURITY_ACCOUNT
関連項目:
定数フィールド値
コンストラクタの詳細

AccountSecurityHTTPActionEventFilterHandler

public AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                   String groupId,
                                                   String accountId)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス GroupSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setAccount

protected void setAccount(String accountId)
アカウントＩＤを設定します。

パラメータ:
accountId - アカウントＩＤ

getAccount

public String getAccount()
設定されているアカウントＩＤを返します。

戻り値:
アカウントＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityHTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ActivityHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
public class ActivityHTTPActionEventHandler
extends ServletHTTPActionEventHandler

持続したセッションを確立するためのハンドラです。

このハンドラを利用すると、結果として同一のセッションを維持したまま 他のハンドラでサーバに再接続するためのＵＲＬを取得する事ができます。
セッションとは、HTTP セッションであり、 セッションを維持する事によりイベントは javax.servlet.http.HttpSession を 通してセッションデータを共有する事ができます。

複数のハンドラを利用して、同一のセッションでいくつかのイベントを 実行する必要がある場合、まずこのハンドラを利用して セッションを維持しながらイベント実行を要求できるＵＲＬを 取得してください。

このハンドラは、セッションを維持する事を目的としているため、 LimitedSessionHTTPActionEventFilterHandler と併用しても 意味がありません。
また、取得されたＵＲＬを利用する事により維持されたセッションに アクセスする事になるため、毎回ログインセッション環境を作る事も 意味を持ちません。ログインセッション環境を利用する場合は、 このハンドラを実行するときに AccountSecurityHTTPActionEventFilterHandler と併用して環境を作成してしまう方法が最も効率的です。 一度ログインセッション環境を作成してしまえば、以後の呼び出しでは ログイン環境を作成するためのフィルタを利用する必要はありません。

導入されたバージョン:
version 4.3

コンストラクタの概要
ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getName() イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler から継承したメソッド
getLocation, setLocation
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler()
新しいイベントハンドラを作成します。

このコンストラクタを利用して作成されたハンドラでは、 再接続ＵＲＬはサーバ内で自動解決されます。 明示的にＵＲＬを指定したい場合は、 ServletHTTPActionEventHandler.setLocation(java.lang.String) メソッドを利用して 再接続 URL を設定してください。

ActivityHTTPActionEventHandler

public ActivityHTTPActionEventHandler(String url)
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。

引数 url には、HTTPActionEvent のリスナーとなっている サーブレットへアクセスするためのＵＲＬを指定してください。

パラメータ:
url - URL
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.client.application.HTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

オーバーライド:
クラス ServletHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConcreteHTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ConcreteHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
public class ConcreteHTTPActionEventHandler
extends HTTPActionEventEntityHandler

任意の HTTPActionEvent を実行するためのハンドラです。

このハンドラを利用する事により、作成したイベントに 対応するハンドラを特別に作成することなく、 任意のイベントを実行する事ができます。
このハンドラは、jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の汎用ハンドラのため、 jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent 呼び出し時のパラメータを隠蔽化したい場合などは、 独自のハンドラを定義する必要がありますが、通常はこのハンドラで ほとんどの要件を満たせると思われます。

導入されたバージョン:
version 4.3

コンストラクタの概要
ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。
メソッドの概要
 String getName()
イベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getEventRequestParameterMap, getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConcreteHTTPActionEventHandler

public ConcreteHTTPActionEventHandler(String name)
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

パラメータ:
name - イベント名
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityHTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス GroupSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
直系の既知のサブクラス:
AccountSecurityHTTPActionEventFilterHandler
public class GroupSecurityHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループによる ログインセッション環境を作る事ができます。 このフィルタを利用する事により、 イベントプログラム中でログイングループを自動解決するＡＰＩを 利用可能になります。

実在しないグループを指定した場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_GROUP
コンストラクタの概要
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getGroup() 設定されているグループＩＤを返します。
String | getName() フィルタイベント名を返します。
protected void | setGroup(String groupId) グループＩＤを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_GROUP

protected static final String ID_SECURITY_GROUP
関連項目:
定数フィールド値
コンストラクタの詳細

GroupSecurityHTTPActionEventFilterHandler

public GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                 String groupId)
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setGroup

protected void setGroup(String groupId)
グループＩＤを設定します。

パラメータ:
groupId - グループＩＤ

getGroup

public String getGroup()
設定されているグループＩＤを返します。

戻り値:
グループＩＤ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContent (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventContent

すべてのスーパーインタフェース:
HTTPActionEventResult
既知の実装クラスの一覧:
HTTPActionEventContentImpl
public interface HTTPActionEventContent
extends HTTPActionEventResult

Web コンテンツを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
byte[] | getBytes() サーバからレスポンスされたコンテンツのソースをバイト列として返します。
URL | getRequestURL() このコンテンツを取得するために使用した URL を返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getRequestURL

public URL getRequestURL()
このコンテンツを取得するために使用した URL を返します。

戻り値:
URL

getBytes

public byte[] getBytes()
                throws IOException
サーバからレスポンスされたコンテンツのソースをバイト列として返します。

何らかのエラーによりソースを受信できなかった場合、 このメソッドは null を返します。

戻り値:
コンテンツソースのバイト列。または null。
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventEntityHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventEntityHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
直系の既知のサブクラス:
ConcreteHTTPActionEventHandler, WebApplicationHTTPActionEventHandler
public abstract class HTTPActionEventEntityHandler
extends HTTPActionEventHandler

jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
void | removeParameter(String key) 指定のキーのマップを削除します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventEntityHandler

protected HTTPActionEventEntityHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
直系の既知のサブクラス:
AccessibleLinkHTTPActionEventFilterHandler, ActivityFrameworkHTTPActionEventFilterHandler, GroupSecurityHTTPActionEventFilterHandler, LimitedSessionHTTPActionEventFilterHandler
public abstract class HTTPActionEventFilterHandler
extends HTTPActionEventHandler

HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。

HTTPActionEventHandler をフィルタリングする HTTPActionEventHandler は、 このクラスをスーパークラスとして実装する事を推奨します。

ユーザプログラムでは、フィルタリングしたいハンドラを基礎ハンドラとして フィルタハンドラを作成し、フィルタハンドラの HTTPActionEventHandler.execute(java.net.HttpURLConnection) を呼び出すことで、 Application Runtime でフィルタされた効果を得ながら 基礎ハンドラが指定するイベントを実行する事ができます。
なお、このハンドラを利用して呼び出すフィルターイベントは、 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を実装しているクラスでなければいけません。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
protected String | getFilterParameter(String key) このフィルタのパラメータを返します。
protected Properties | getFilterParameterMap() このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
abstract String | getName() フィルタイベント名を返します。
String | getParameter(String key) 設定したパラメータ値を取得します。
Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
HTTPActionEventHandler | getParent() このオブジェクトがフィルタリングしているハンドラを返します。
boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
protected String | removeFilterParameter(String key) このフィルタのパラメータを削除します。
void | removeParameter(String key) 指定のキーのマップを削除します。
protected void | setFilterParameter(String key, String value) このフィルタのパラメータを設定します。
void | setParameter(String key, String value) イベントへのパラメータを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventFilterHandler

protected HTTPActionEventFilterHandler(HTTPActionEventHandler handler)
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getParent

public HTTPActionEventHandler getParent()
このオブジェクトがフィルタリングしているハンドラを返します。

戻り値:
ハンドラ

getName

public abstract String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventHandler 内の getName
戻り値:
イベント名

setParameter

public void setParameter(String key,
                         String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String, String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の setParameter
パラメータ:
key - キー
value - 値

getParameter

public String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameter
パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

このメソッドは、単純のラップしている親ハンドラの #hasParameter(String) を呼び出します。

定義:
クラス HTTPActionEventHandler 内の hasParameter
パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterKeySet() を呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterKeySet
戻り値:
キーのセット

removeParameter

public void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

このメソッドは、単純のラップしている親ハンドラの #removeParameter(String) を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の removeParameter
パラメータ:
key - キー

getParameterMap

public Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

このメソッドは、単純のラップしている親ハンドラの #getParameterMap() を 呼び出します。

定義:
クラス HTTPActionEventHandler 内の getParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

setFilterParameter

protected void setFilterParameter(String key,
                                  String value)
このフィルタのパラメータを設定します。

パラメータ:
key - パラメータ名
value - パラメータの値

getFilterParameter

protected String getFilterParameter(String key)
このフィルタのパラメータを返します。

パラメータ:
key - パラメータ名
戻り値:
パラメータの値

removeFilterParameter

protected String removeFilterParameter(String key)
このフィルタのパラメータを削除します。

パラメータ:
key - パラメータ名
戻り値:
設定されていたパラメータの値

getFilterParameterMap

protected Properties getFilterParameterMap()
                                    throws HTTPActionEventHandlerParameterException
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected final Properties getEventRequestParameterMap()
                                                throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

定義:
クラス HTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
直系の既知のサブクラス:
HTTPActionEventEntityHandler, HTTPActionEventFilterHandler
public abstract class HTTPActionEventHandler
extends Object

jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。

この抽象実装は、すべての HTTPActionEvent ハンドラの スーパークラスになります。

ハンドラを作成してイベント実行を要求する場合、execute(String) または execute(java.net.URL) を利用します。 execute(java.net.HttpURLConnection) も利用できますが、 通常はこの方法を使わない方が良いと思われます。

イベント実行を要求するＵＲＬは、 HTTPActionEventListener へ接続できるものを指定します。 標準では、下記のようになります。
http://<サーバアドレス>[:<ポート番号>]/imart/HTTPActionEventListener

外部ソフトウェア接続モジュールでは、HTTPS プロトコルを利用した通信が可能です。
以下に、簡単にHTTPSプロトコルを利用した通信を行う方法を記します。

  1. 証明書の追加

    2. JDK 付属のツール keytool の -import コマンドを使って、信頼できる証明書をリストに追加します。
    例えば、サーバ証明書「C:¥temp¥server.crt」を、 別名「sample_alias」でキーストアエントリに格納するには、以下のコマンドを実行します。
     >keytool -import -alias sample_alias -file C:¥temp¥server.crt
    上記コマンドを実行すると、ユーザのホームディレクトリの「.keystore」ファイルに、キーストアが作成されます。
    （keytoolの詳細は、 keytool - 鍵と証明書の管理ツール を参照してください）

  2. キーストアを指定して、クライアントを実行

    3. 外部ソフトウェア接続モジュールのクライアントが、証明書ファイルを利用できる状態に設定します。
    java コマンドを実行する際、次のオプションをコマンド行に追加し、手順1 で追加したキーストアを指定します。
    ここでは、ユーザのホームディレクトリを「 /home/user_name 」とします。
    -Djavax.net.ssl.trustStore=/home/user_name/.keystore

    Windows環境の例 （ホームディレクトリが「 C:¥Documents and Settings¥user_name 」の場合）
    -Djavax.net.ssl.trustStore="C:¥¥Documents and Settings¥¥user_name¥¥.keystore"
簡単にHTTPSプロトコルを利用した通信を行う方法は 以上です。

外部ソフトウェア接続モジュールは、HTTPS プロトコルを利用した通信を行う際に、 HttpsURLConnection を利用して通信を行います。
そのため、デフォルト動作をオーバライドしたい場合、以下の二つを設定する必要があります。

  • javax.net.ssl.HostnameVerifier

    • 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を setHostnameVerifier(HostnameVerifier) メソッドで設定します。
    （この HostnameVerifier は、URL ホスト名のデフォルトの検証規則が失敗した場合に使用されます）
    HostnameVerifier が設定されていない場合、
    ホスト名が認証方式に準拠しているかどうかに関わらず、接続を許可します。

  • javax.net.ssl.SSLContext

    • 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを、setSSLContext(SSLContext) メソッドで設定します。
    SSLContext が設定されていない場合、
    HttpsURLConnection に対して SSLSocketFactory の設定を行いません。
HTTPS プロトコルを利用した通信を行うには、Java Secure Socket Extension (JSSE) の知識が必要です。
詳しくは、 Java Secure Socket Extension (JSSE) リファレンスガイド を参照してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。
メソッドの概要
HTTPActionEventResult | execute(HttpURLConnection connection) 指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。
HTTPActionEventResult | execute(String url) 指定された URL に接続して、 イベントの実行を要求します。
HTTPActionEventResult | execute(URL url) 指定された URL に接続して、 イベントの実行を要求します。
String | getCharacterEncoding() パラメータを符号化するためのエンコーディング名を返します。
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
abstract String | getParameter(String key) 設定したパラメータ値を取得します。
abstract Set | getParameterKeySet() 現在、パラメータとして設定されているキーの一覧を返します。
abstract Properties | getParameterMap() 設定済みパラメータのマップのコピーを返します。
abstract boolean | hasParameter(String key) 設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
abstract void | removeParameter(String key) 指定のキーのマップを削除します。
void | setCharacterEncoding(String enc) パラメータを符号化するためのエンコーディング名を指定します。
void | setHostnameVerifier(HostnameVerifier hostnameVerifier) 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
abstract void | setParameter(String key, String value) イベントへのパラメータを設定します。
void | setSSLContext(SSLContext sslContext) 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandler

protected HTTPActionEventHandler()
新しいイベントハンドラを作成します。

メソッドの詳細

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

戻り値:
イベント名

setParameter

public abstract void setParameter(String key,
                                  String value)
イベントへのパラメータを設定します。 ここで設定した値は、Application Runtime で実行されるイベントにて、 通常のＵＲＬ引数として受け取ることができます。 値を取得するには、サーブレットプログラムにおいてＵＲＬパラメータを 取得する一般的な方法と同様に、HttpServletRequest#getParameter(String) を利用してください。

パラメータ:
key - キー
value - 値

getParameter

public abstract String getParameter(String key)
設定したパラメータ値を取得します。 指定のキーにマップされている値が存在しない場合、null を返します。

パラメータ:
key - キー
戻り値:
キーにマップされているパラメータ値

hasParameter

public abstract boolean hasParameter(String key)
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

パラメータ:
key - キー
戻り値:
キーにパラメータ値がマップされている場合 true。

getParameterKeySet

public abstract Set getParameterKeySet()
現在、パラメータとして設定されているキーの一覧を返します。

戻り値:
キーのセット

removeParameter

public abstract void removeParameter(String key)
指定のキーのマップを削除します。 削除されたキーおよびそのキーにマップされた値は、Application Runtime に送信されなくなります。

パラメータ:
key - キー

getParameterMap

public abstract Properties getParameterMap()
設定済みパラメータのマップのコピーを返します。 パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getCharacterEncoding

public String getCharacterEncoding()
パラメータを符号化するためのエンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

public void setCharacterEncoding(String enc)
                          throws UnsupportedEncodingException
パラメータを符号化するためのエンコーディング名を指定します。

デフォルトでは UTF-8 を用いてパラメータを符号化します。 また、イベントへの各パラメータ値は Unicode のまま扱われますので、 通常は文字エンコーディングを変更する必要はありません。

パラメータ:
enc - 文字エンコーディング名
例外:
UnsupportedEncodingException - 指定のエンコーディング名がサポートされない場合

execute

public HTTPActionEventResult execute(String url)
                              throws MalformedURLException,
                                     IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の URL 文字列から java.net.URL のインスタンスを 作成して execute(java.net.URL) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
MalformedURLException
IOException

execute

public HTTPActionEventResult execute(URL url)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL に接続して、 イベントの実行を要求します。

このメソッドは、指定の java.net.URL から java.net.HttpURLConnection を取得して execute(java.net.HttpURLConnection) メソッドを呼び出します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
HTTPActionEventHandlerException - 実行時エラー
IOException

execute

public HTTPActionEventResult execute(HttpURLConnection connection)
                              throws IOException,
                                     HTTPActionEventHandlerException
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

このメソッドは、 getParameterMap() の返り値をイベントの引数として サーバに対して getName() が表すイベントの 実行を要求します。

パラメータ:
connection - コネクション
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

setHostnameVerifier

public void setHostnameVerifier(HostnameVerifier hostnameVerifier)
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
（このHostnameVerifierは、URL ホスト名のデフォルトの検証規則が失敗した場合に使用されます）

HostnameVerifier が設定されていない場合、
ホスト名が認証方式に準拠しているかどうかに関わらず、接続を許可します。

パラメータ:
hostnameVerifier - 外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier
導入されたバージョン:
version 6.1

setSSLContext

public void setSSLContext(SSLContext sslContext)
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
SSLContext が設定されていない場合、
HttpsURLConnection に対して SSLSocketFactory の設定を行いません。

デフォルト動作をオーバライドする場合を除き、 SSLContext オブジェクトを直接作成したり初期化したりする必要はありません。

パラメータ:
sslContext - SSLContext
導入されたバージョン:
version 6.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerException (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
HTTPActionEventHandlerParameterException
public class HTTPActionEventHandlerException
extends Exception

HTTPActionEventHandler 内で発生したエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerException

public HTTPActionEventHandlerException(String msg,
                                       Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventHandlerParameterException (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventHandlerParameterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
                拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException
すべての実装インタフェース:
Serializable
public class HTTPActionEventHandlerParameterException
extends HTTPActionEventHandlerException

HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventHandlerParameterException

public HTTPActionEventHandlerParameterException(String msg,
                                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResult (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventResult

既知のサブインタフェースの一覧:
HTTPActionEventContent, HTTPActionEventURL
既知の実装クラスの一覧:
HTTPActionEventContentImpl, HTTPActionEventResultImpl, HTTPActionEventResultWrapper, HTTPActionEventURLImpl
public interface HTTPActionEventResult

HTTPActionEvent 実行要求の結果に関する共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。

メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 HttpURLConnection の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

このメソッドでは、HTTP のレスポンスコードが 200 かどうかで、 判定しています。

戻り値:
エラーなく処理終了しなかった場合 true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventResultWrapper (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス HTTPActionEventResultWrapper

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper
すべての実装インタフェース:
HTTPActionEventResult
直系の既知のサブクラス:
HTTPActionEventContentImpl, HTTPActionEventURLImpl
public class HTTPActionEventResultWrapper
extends Object
implements HTTPActionEventResult

HTTPActionEventResult のラッパーオブジェクトです。
このクラスでは、基本的にラップしているオブジェクトからの 返り値をそのままリターンします。 必要に応じてサブクラスを作成し、サブクラス側で必要な処理を メソッドをオーバーライドすることにより実装してください。

導入されたバージョン:
version 4.3

コンストラクタの概要
HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
メソッドの概要
HttpURLConnection | getConnection() 接続に利用したコネクションを返します。
InputStream | getInputStream() サーバからの入力を受け付ける入力ストリームを返します。
protected HTTPActionEventResult | getParent() ラップしている親オブジェクトを返します。
int | getResponseCode() サーバからのHTTPレスポンスコードを返します。
String | getResponseMessage() サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
boolean | isError() 処理要求が成功したかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventResultWrapper

public HTTPActionEventResultWrapper(HTTPActionEventResult parent)
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。

パラメータ:
parent - ラップする結果オブジェクト
メソッドの詳細

getConnection

public HttpURLConnection getConnection()
接続に利用したコネクションを返します。

定義:
インタフェース HTTPActionEventResult 内の getConnection
戻り値:
コネクション

getResponseCode

public int getResponseCode()
                    throws IOException
サーバからのHTTPレスポンスコードを返します。

返されるレスポンスコードについては、 javax.servlet.http.HttpURLConnection#getResponseCode() の 仕様に準じます。

接続そのものに失敗した場合など、サーバから HTTP レスポンスコードを 受け取れなかった場合、 このメソッドは java.io.IOException をスローします。

定義:
インタフェース HTTPActionEventResult 内の getResponseCode
戻り値:
レスポンスコード
例外:
IOException - 入出力エラーが発生した場合

getResponseMessage

public String getResponseMessage()
                          throws IOException
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。

このメソッドは、java.net.HttpURLConnection の #getResponseMessage() メソッドの仕様に準じます。

定義:
インタフェース HTTPActionEventResult 内の getResponseMessage
戻り値:
HTTP 応答メッセージまたは null
例外:
IOException - サーバへの接続でエラーが発生した場合

getInputStream

public InputStream getInputStream()
                           throws IOException
サーバからの入力を受け付ける入力ストリームを返します。 この入力ストリームによりレスポンスデータを得る事ができます。

定義:
インタフェース HTTPActionEventResult 内の getInputStream
戻り値:
入力ストリーム
例外:
IOException - 入力ストリームの作成中に入出力エラーが発生した場合
UnknownServiceException - プロトコルが入力をサポートしていない場合

isError

public boolean isError()
処理要求が成功したかどうかを判定します。

定義:
インタフェース HTTPActionEventResult 内の isError
戻り値:
エラーなく処理終了した場合 false。

getParent

protected HTTPActionEventResult getParent()
ラップしている親オブジェクトを返します。

戻り値:
ラップしている結果オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventURL (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
インタフェース HTTPActionEventURL

すべてのスーパーインタフェース:
HTTPActionEventResult
既知の実装クラスの一覧:
HTTPActionEventURLImpl
public interface HTTPActionEventURL
extends HTTPActionEventResult

Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
 HTTPActionEventContent getContent()
getURL() によって表されるコンテンツのソースを取得します。
 String getURL()
サーバから返されたＵＲＬを返します。
インタフェース jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult から継承したメソッド
getConnection, getInputStream, getResponseCode, getResponseMessage, isError

メソッドの詳細

getURL

public String getURL()
              throws IOException
サーバから返されたＵＲＬを返します。

戻り値:
ＵＲＬ
例外:
IOException - 入出力エラー

getContent

public HTTPActionEventContent getContent()
                                  throws MalformedURLException,
                                         IOException
getURL() によって表されるコンテンツのソースを取得します。

戻り値:
サーバからの応答オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LimitedSessionHTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス LimitedSessionHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
public class LimitedSessionHTTPActionEventFilterHandler
extends HTTPActionEventFilterHandler

セッションを一時利用のみに限定するためのフィルタです。

イベント HTTPActionEvent では、セッション情報を扱う場合 javax.servlet.http.HttpSession を利用します。 したがって、明示的にセッション(javax.servlet.http.HttpSession)を破棄しない場合、 セッションのタイムアウトが発生するまで、サーバのメモリリソースを 消費したままの状態が維持されてしまいます。
このフィルタは、イベント処理終了時に javax.servlet.http.HttpSession#invalidate() を 実行してセッションを明示的に破棄します。 セッションを維持する必要のないイベント実行では、 このフィルタを利用することにより、サーバリソースの無駄な利用を 回避する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。
メソッドの概要
 String getName()
フィルタイベント名を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LimitedSessionHTTPActionEventFilterHandler

public LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler handler)
セッションを一時利用に限定するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventFilterHandler 内の getName
戻り値:
イベント名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.client.application (imaca_client 6.1.14 API)

 jp.co.intra_mart.foundation.service.client.application
インタフェース
HTTPActionEventContent
HTTPActionEventResult
HTTPActionEventURL
クラス
AccountSecurityHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
ConcreteHTTPActionEventHandler
GroupSecurityHTTPActionEventFilterHandler
HTTPActionEventEntityHandler
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventResultWrapper
LimitedSessionHTTPActionEventFilterHandler
PasswordSecurityHTTPActionEventFilterHandler
ServletHTTPActionEventHandler
WebApplicationHTTPActionEventHandler
例外
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException


jp.co.intra_mart.foundation.service.client.application (imaca_client 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。

参照:
説明

インタフェースの概要
HTTPActionEventContent | Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventResult | HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL | Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

クラスの概要
AccountSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ActivityHTTPActionEventHandler | 持続したセッションを確立するためのハンドラです。
ConcreteHTTPActionEventHandler | 任意の HTTPActionEvent を実行するためのハンドラです。
GroupSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventEntityHandler | jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler | HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler | jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventResultWrapper | HTTPActionEventResult のラッパーオブジェクトです。
LimitedSessionHTTPActionEventFilterHandler | セッションを一時利用のみに限定するためのフィルタです。
PasswordSecurityHTTPActionEventFilterHandler | ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
ServletHTTPActionEventHandler | Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler | フレームワークを実行するためのイベントハンドラの抽象実装です。

例外の概要
HTTPActionEventHandlerException | HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException | HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.client.application の説明

このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
このパッケージを利用することにより、intra-mart ではない環境から intra-mart 内のプログラム実行を行うことができるようになりますので、例えばユーザ情報の同期など、様々なことを実現することができます。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.client.application クラス階層 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.client.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.client.application の使用 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.client.application の使用

jp.co.intra_mart.foundation.service.client.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.core |

jp.co.intra_mart.foundation.service.client.application により使用される jp.co.intra_mart.foundation.service.client.application のクラス
AccountSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
HTTPActionEventContent
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventEntityHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerException
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventResult
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventURL
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
ServletHTTPActionEventHandler
Web-Application を実行するためのイベントハンドラです。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.content により使用される jp.co.intra_mart.foundation.service.client.application のクラス
HTTPActionEventEntityHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventFilterHandler
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventHandler
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandlerParameterException
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
WebApplicationHTTPActionEventHandler
フレームワークを実行するためのイベントハンドラの抽象実装です。

jp.co.intra_mart.foundation.service.client.application.core により使用される jp.co.intra_mart.foundation.service.client.application のクラス
HTTPActionEventContent
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventResult
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultWrapper
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventURL
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PasswordSecurityHTTPActionEventFilterHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス PasswordSecurityHTTPActionEventFilterHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
                    拡張 jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
public class PasswordSecurityHTTPActionEventFilterHandler
extends AccountSecurityHTTPActionEventFilterHandler

ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。

このフィルタを利用する事により、任意のログイングループ内の任意のアカウントで ログインした状態の環境を作る事ができます。 ログイン環境でイベントを動作させる事により、 イベントプログラム中でログインセッションを必要とするＡＰＩを 利用可能になります。

このフィルタは、AccountSecurityHTTPActionEventFilterHandler の機能に加えて パスワード認証も行います。したがって、AccountSecurityHTTPActionEventFilterHandler よりも 高度なセキュリティを実現しながらイベントを実行する事が可能となります。

このフィルタを利用する場合は、 必ずログイン環境を作れるアカウントを作成しておく必要があります。 実在しないアカウントを指定したりパスワードが正しくない場合、 未来の予測できないエラーを回避するために、 フィルタ処理の途中で即座に例外がスローされてます。 結果として、イベント実行はエラー終了します。
フィルタがエラー終了した場合、セキュリティホールとならないために セッションを破棄(javax.servlet.http.HttpSession#invalidate())します。 したがって、認証前にセッションに保存した情報にはアクセスできなくなります。 認証エラー後にセッション内の情報が必要な場合は、 事前に取得して別な場所へ保管するなどの対策が必要です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_PASSWORD
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_ACCOUNT
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler, String groupId, String accountId, String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
メソッドの概要
String | getName() フィルタイベント名を返します。
String | getPassword() 設定されているパスワードを返します。
protected void | setPassword(String password) パスワードを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler から継承したメソッド
getAccount, setAccount
クラス jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler から継承したメソッド
getGroup, setGroup
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler から継承したメソッド
getEventRequestParameterMap, getFilterParameter, getFilterParameterMap, getParameter, getParameterKeySet, getParameterMap, getParent, hasParameter, removeFilterParameter, removeParameter, setFilterParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_PASSWORD

protected static final String ID_SECURITY_PASSWORD
関連項目:
定数フィールド値
コンストラクタの詳細

PasswordSecurityHTTPActionEventFilterHandler

public PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler handler,
                                                    String groupId,
                                                    String accountId,
                                                    String password)
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。

パラメータ:
handler - フィルタリングするハンドラ
groupId - グループＩＤ
accountId - アカウントＩＤ
password - パスワード
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
フィルタイベント名を返します。

実際には、Application Runtime で実行される jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent を 実装したクラスのクラス名を返します。

オーバーライド:
クラス AccountSecurityHTTPActionEventFilterHandler 内の getName
戻り値:
イベント名

setPassword

protected void setPassword(String password)
パスワードを設定します。

パラメータ:
password - パスワード

getPassword

public String getPassword()
設定されているパスワードを返します。

戻り値:
パスワード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServletHTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス ServletHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
                拡張 jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
直系の既知のサブクラス:
ActivityHTTPActionEventHandler
public class ServletHTTPActionEventHandler
extends WebApplicationHTTPActionEventHandler

Web-Application を実行するためのイベントハンドラです。

このハンドラは、指定の Web-Application を実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected | ServletHTTPActionEventHandler() Web-Application をイベント実行するためのハンドラを作成します。
 | ServletHTTPActionEventHandler(String location) 指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
String | getLocation() 設定されている遷移先パスを返します。
String | getName() イベント名を返します。
protected void | setLocation(String location) 遷移先のページパスを設定します。
クラス jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler から継承したメソッド
getQueryString, getURL, getURL, getURL, getURL, getURL, getURL
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServletHTTPActionEventHandler

protected ServletHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで setLocation(String) を利用して 画面パスを設定しなければいけません。

ServletHTTPActionEventHandler

public ServletHTTPActionEventHandler(String location)
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。

パラメータ:
location - Web-Application のパス
例外:
NullPointerException - 引数が null の場合
メソッドの詳細

getName

public String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getName
戻り値:
イベント名

setLocation

protected void setLocation(String location)
遷移先のページパスを設定します。

パラメータ:
location - ページパス
例外:
NullPointerException - 引数が null の場合

getLocation

public String getLocation()
設定されている遷移先パスを返します。

戻り値:
遷移先を表すパス

getEventRequestParameterMap

protected Properties getEventRequestParameterMap()
                                          throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。
パラメータ名をキーとしてパラメータ値がマッピングされている java.util.Properties を返します。 イベントでは、javax.servlet.ServletRequest からリクエストパラメータとして、 #getParameter(String) メソッドなどにより取得できます。

このメソッドが返す値は、イベントに対するパラメータであって、 getLocation() によって表される画面プログラムに対する リクエストパラメータではない点に注意してください。 getLocation() によって表される画面プログラムに対する リクエストパラメータに関しては、HTTPActionEventEntityHandler.getParameterMap() によって 取得できます。

定義:
クラス WebApplicationHTTPActionEventHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WebApplicationHTTPActionEventHandler (imaca_client 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.client.application
クラス WebApplicationHTTPActionEventHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
        拡張 jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
            拡張 jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
直系の既知のサブクラス:
PresentationPageHTTPActionEventHandler, ServiceFrameworkHTTPActionEventHandler, ServletHTTPActionEventHandler
public abstract class WebApplicationHTTPActionEventHandler
extends HTTPActionEventEntityHandler

フレームワークを実行するためのイベントハンドラの抽象実装です。

このハンドラは、指定のフレームワークを実行するための URL を作成して 返します。 ユーザプログラムでは、このハンドラを利用して取得した URL を用いて、 サーバにリクエストすることにより目的のコンテンツのソースを 取得する事ができます。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
メソッドの概要
protected abstract Properties | getEventRequestParameterMap() イベントに対するパラメータのマップを返します。
abstract String | getName() イベント名を返します。
protected String | getQueryString() 設定されているパラメータ情報からクエリ文字列を作成して返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
static HTTPActionEventURL | getURL(HTTPActionEventHandler handler, URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(HttpURLConnection connection) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(String url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
HTTPActionEventURL | getURL(URL url) 指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler から継承したメソッド
getParameter, getParameterKeySet, getParameterMap, hasParameter, removeParameter, setParameter
クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler から継承したメソッド
execute, execute, execute, getCharacterEncoding, setCharacterEncoding, setHostnameVerifier, setSSLContext
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WebApplicationHTTPActionEventHandler

protected WebApplicationHTTPActionEventHandler()
Web-Application をイベント実行するためのハンドラを作成します。
このコンストラクタでは表示する画面のパスが設定されません。 サブクラスで #setLocation(String) を利用して 画面パスを設定しなければいけません。

メソッドの詳細

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        String url)
                                 throws MalformedURLException,
                                        IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        URL url)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public static HTTPActionEventURL getURL(HTTPActionEventHandler handler,
                                        HttpURLConnection connection)
                                 throws IOException,
                                        HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

引数 handler には、このクラスと代入互換のあるオブジェクトまたは、 代入互換のあるオブジェクトをラップしているフィルタハンドラを 指定してください。他のハンドラを指定した場合、正しく結果を得られません。

パラメータ:
handler - ハンドラ
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getName

public abstract String getName()
イベント名を返します。

実際には、Application Runtime で実行される HTTPActionEvent を 実装したクラスのクラス名を返します。

定義:
クラス HTTPActionEventEntityHandler 内の getName
戻り値:
イベント名

getEventRequestParameterMap

protected abstract Properties getEventRequestParameterMap()
                                                   throws HTTPActionEventHandlerParameterException
イベントに対するパラメータのマップを返します。

オーバーライド:
クラス HTTPActionEventEntityHandler 内の getEventRequestParameterMap
戻り値:
パラメータマップ
例外:
HTTPActionEventHandlerParameterException - パラメータに異常がある場合

getQueryString

protected String getQueryString()
                         throws UnsupportedEncodingException
設定されているパラメータ情報からクエリ文字列を作成して返します。

戻り値:
クエリ。パラメータが設定されていない場合は null。
例外:
UnsupportedEncodingException - 設定されている文字エンコーディング名がサポート外

getURL

public HTTPActionEventURL getURL(String url)
                          throws MalformedURLException,
                                 IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(String) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
MalformedURLException - URL のフォーマットエラー
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(URL url)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(URL) の結果を HTTPActionEventURL インターフェースでラップして返します。

パラメータ:
url - 接続 URL
戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー

getURL

public HTTPActionEventURL getURL(HttpURLConnection connection)
                          throws IOException,
                                 HTTPActionEventHandlerException
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。

このメソッドは、HTTPActionEventHandler.execute(HttpURLConnection) の結果を HTTPActionEventURL インターフェースでラップして返します。

戻り値:
実行結果オブジェクト
例外:
IOException - 入出力エラー
HTTPActionEventHandlerException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (imaca_client 6.1.14 API)

 すべてのクラス
AccessibleLinkHTTPActionEventFilterHandler
AccountSecurityHTTPActionEventFilterHandler
ActivityFrameworkHTTPActionEventFilterHandler
ActivityHTTPActionEventHandler
ConcreteHTTPActionEventHandler
GroupSecurityHTTPActionEventFilterHandler
HTTPActionEventContent
HTTPActionEventContentImpl
HTTPActionEventEntityHandler
HTTPActionEventFilterHandler
HTTPActionEventHandler
HTTPActionEventHandlerException
HTTPActionEventHandlerParameterException
HTTPActionEventQueryBuilder
HTTPActionEventResult
HTTPActionEventResultImpl
HTTPActionEventResultWrapper
HTTPActionEventURL
HTTPActionEventURLImpl
LimitedSessionHTTPActionEventFilterHandler
PasswordSecurityHTTPActionEventFilterHandler
PresentationPageHTTPActionEventHandler
ServiceFrameworkHTTPActionEventHandler
ServletHTTPActionEventHandler
WebApplicationHTTPActionEventHandler


定数フィールド値 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_ACCOUNT "filter-security-account"

jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
public static final String | ID_EVENT_NAME | "event-name"
public static final String | ID_EVENT_PARAMETER | "event-parameter"
public static final String | ID_EVENT_PARAMETER_CHARSET | "event-parameter-encoding"
public static final String | ID_EVENT_REQUEST_TIME | "event-request-time"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし
A C D E G H I J L P R S W

A

AccessibleLinkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler.
再接続の為のＵＲＬを制御するフィルタ実装です。
AccessibleLinkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のコンストラクタ
ＵＲＬを絶対形式に変換するためのフィルタハンドラを作成します。
AccountSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
AccountSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
ActivityFrameworkHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler.
推奨されていません。 このフィルタは、何もしません。仕様変更に伴い、このフィルタを使う必要がなくなりました。
ActivityFrameworkHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のコンストラクタ
推奨されていません。 フレームワークのセッション環境を作成するためのフィルタハンドラを作成します。
ActivityHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler.
持続したセッションを確立するためのハンドラです。
ActivityHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
ActivityHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のコンストラクタ
指定のＵＲＬに再接続するための新しいイベントハンドラを作成します。

C

ConcreteHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler.
任意の HTTPActionEvent を実行するためのハンドラです。
ConcreteHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のコンストラクタ
指定のイベント名で表されるイベントを実行するためのハンドラを作成します。

D

decodeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder のメソッド
イベントへのパラメータ情報をデコードします。

E

encodeParameter(Properties) - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder のメソッド
イベントへのパラメータ情報をエンコードします。
execute(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(URL) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL に接続して、 イベントの実行を要求します。
execute(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定された URL コネクションを利用してにサーバに接続し、 イベントの実行を要求します。

G

GroupSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
GroupSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のコンストラクタ
ログイングループセッション環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
getAccount() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
設定されているアカウントＩＤを返します。
getApplication() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているアプリケーションＩＤを返します。
getBytes() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getBytes() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl のメソッド
サーバからレスポンスされたコンテンツのソースをバイト列として返します。
getCharacterEncoding() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を返します。
getConnection() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
接続に利用したコネクションを返します。
getConnection() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のメソッド
接続に利用したコネクションを返します。
getContent() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
HTTPActionEventURL.getURL() によって表されるコンテンツのソースを取得します。
getContent() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl のメソッド
HTTPActionEventURLImpl.getURL() によって表されるコンテンツのソースを取得します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getEventRequestParameterMap() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベントに対するパラメータのマップを返します。
getFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを返します。
getFilterParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このハンドラによって実行されるフィルタイベントに対する 設定済みパラメータのマップを返します。
getGroup() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
設定されているグループＩＤを返します。
getInputStream() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のメソッド
サーバからの入力を受け付ける入力ストリームを返します。
getLastException() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のメソッド
実行要求処理中に発生した例外のうち、最後にスローされたものを返します。
getLocation() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
設定されている遷移先パスを返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler のメソッド
フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler のメソッド
推奨されていません。 フィルタイベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
イベント名を返します。
getName() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
イベント名を返します。
getPagePath() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
設定されているページパスを返します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ値を取得します。
getParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ値を取得します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterKeySet() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
現在、パラメータとして設定されているキーの一覧を返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParameterMap() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定済みパラメータのマップのコピーを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このオブジェクトがフィルタリングしているハンドラを返します。
getParent() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
ラップしている親オブジェクトを返します。
getPassword() - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
設定されているパスワードを返します。
getQueryString() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
設定されているパラメータ情報からクエリ文字列を作成して返します。
getRequestURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent のメソッド
このコンテンツを取得するために使用した URL を返します。
getRequestURL() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl のメソッド
このコンテンツを取得するために使用した URL を返します。
getResponseCode() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseCode() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のメソッド
サーバからのHTTPレスポンスコードを返します。
getResponseMessage() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getResponseMessage() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のメソッド
サーバからの応答コードに HTTP 応答メッセージが含まれている場合、これを返します。
getService() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
設定されているサービスＩＤを返します。
getURL() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL のメソッド
サーバから返されたＵＲＬを返します。
getURL(HTTPActionEventHandler, String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HTTPActionEventHandler, HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler の static メソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(String) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(URL) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のメソッド
指定された URL に接続して、 目的の Web コンテンツにアクセスするためのＵＲＬ情報を返します。
getURL() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl のメソッド
サーバから返されたＵＲＬを返します。

H

HTTPActionEventContent - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent.
Web コンテンツを取得するための共通インターフェースです。
HTTPActionEventContentImpl - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl.
サーバからのＵＲＬ情報を取得するための便利オブジェクト。
HTTPActionEventContentImpl(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl のコンストラクタ
新しいＵＲＬ取得オブジェクトを作成します。
HTTPActionEventEntityHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler.
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventEntityHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler.
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラの抽象実装です。
HTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のコンストラクタ
HTTPActionEvent の呼び出しをフィルタリングするためのハンドラを作成します。
HTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler.
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の 実行をサーバに要求するためのハンドラの抽象実装です。
HTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のコンストラクタ
新しいイベントハンドラを作成します。
HTTPActionEventHandlerException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException.
HTTPActionEventHandler 内で発生したエラーを通知するための例外です。
HTTPActionEventHandlerException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException - exception jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException.
HTTPActionEventHandler がイベントに渡すパラメータに関して エラーが発生あることを通知するための例外です。
HTTPActionEventHandlerParameterException(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventHandlerParameterException(String, Throwable) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventQueryBuilder - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder.
HTTPActionEvent 関連のビルダです。
HTTPActionEventQueryBuilder() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder のコンストラクタ
イベントビルダを新しく作成します。
HTTPActionEventResult - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult.
HTTPActionEvent 実行要求の結果に関する共通インターフェースです。
HTTPActionEventResultImpl - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl.
HTTPActionEvent 実行要求の結果に関する共通インターフェースの実装です。
HTTPActionEventResultImpl(HttpURLConnection) - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のコンストラクタ
HTTP レスポンスを操作するオブジェクトを作成します。
HTTPActionEventResultWrapper - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper.
HTTPActionEventResult のラッパーオブジェクトです。
HTTPActionEventResultWrapper(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のコンストラクタ
指定の結果オブジェクトをラップする新しい結果オブジェクトを作成します。
HTTPActionEventURL - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL.
Web コンテンツへのアクセスＵＲＬを取得するための共通インターフェースです。
HTTPActionEventURLImpl - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl.
サーバからのＵＲＬ情報を取得するための便利オブジェクト。
HTTPActionEventURLImpl(HTTPActionEventResult) - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl のコンストラクタ
新しいＵＲＬ取得オブジェクトを作成します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。
hasParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
設定したパラメータ名にパラメータがマッピングされているかどうか検査します。

I

ID_EVENT_NAME - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder の static 変数
サーバにイベント名を送信する時のパラメータ名です。
ID_EVENT_PARAMETER - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder の static 変数
サーバにイベントパラメータを送信する時のパラメータ名です。
ID_EVENT_PARAMETER_CHARSET - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder の static 変数
イベントのパラメータのエンコーディング名を送信するときのパラメータ名です。
ID_EVENT_REQUEST_TIME - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder の static 変数
イベントの実行を要求した時刻を送信するときのパラメータ名です。
ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler の static 変数
ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler の static 変数
ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler の static 変数
isError() - interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper のメソッド
処理要求が成功したかどうかを判定します。
isError() - class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl のメソッド
処理要求が成功したかどうかを判定します。

J

jp.co.intra_mart.foundation.service.client.application - package jp.co.intra_mart.foundation.service.client.application
このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content - package jp.co.intra_mart.foundation.service.client.application.content
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.core - package jp.co.intra_mart.foundation.service.client.application.core

L

LimitedSessionHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler.
セッションを一時利用のみに限定するためのフィルタです。
LimitedSessionHTTPActionEventFilterHandler(HTTPActionEventHandler) - class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler のコンストラクタ
セッションを一時利用に限定するためのフィルタハンドラを作成します。

P

PasswordSecurityHTTPActionEventFilterHandler - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler.
ログイン認証を行って、ログインセッション環境でイベントを実行するためのフィルタ実装です。
PasswordSecurityHTTPActionEventFilterHandler(HTTPActionEventHandler, String, String, String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のコンストラクタ
アカウントによるログイン環境下で HTTPActionEvent を実行するためのフィルタハンドラを作成します。
PresentationPageHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler.
スクリプト開発モデルのプレゼンテーションページを実行するためのハンドラです。
PresentationPageHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。
PresentationPageHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のコンストラクタ
ハンドラを作成します。

R

removeFilterParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
指定のキーのマップを削除します。
removeParameter(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
指定のキーのマップを削除します。

S

ServiceFrameworkHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler.
im-J2EE Framework のサービスフレームワークを実行するためのハンドラです。
ServiceFrameworkHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServiceFrameworkHTTPActionEventHandler(String, String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のコンストラクタ
サービスフレームワークを実行するためのハンドラを作成します。
ServletHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler.
Web-Application を実行するためのイベントハンドラです。
ServletHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
ServletHTTPActionEventHandler(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のコンストラクタ
指定のパスで表される Web-Application をイベント実行するためのハンドラを作成します。
setAccount(String) - class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler のメソッド
アカウントＩＤを設定します。
setApplication(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのアプリケーションＩＤを設定します。
setCharacterEncoding(String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
パラメータを符号化するためのエンコーディング名を指定します。
setFilterParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
このフィルタのパラメータを設定します。
setGroup(String) - class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler のメソッド
グループＩＤを設定します。
setHostnameVerifier(HostnameVerifier) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の HostnameVerifier を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler のメソッド
遷移先のページパスを設定します。
setPagePath(String) - class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler のメソッド
実行するスクリプト開発モデルのページパスを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler のメソッド
イベントへのパラメータを設定します。
setParameter(String, String) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
イベントへのパラメータを設定します。
setPassword(String) - class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler のメソッド
パスワードを設定します。
setSSLContext(SSLContext) - class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler のメソッド
外部ソフトウェア接続モジュールを利用して HTTPS 通信を行う際の SSLSocketFactory を生成する SSLContextを設定します。
setService(String) - class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler のメソッド
実行するフレームワークのサービスＩＤを設定します。

W

WebApplicationHTTPActionEventHandler - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler.
フレームワークを実行するためのイベントハンドラの抽象実装です。
WebApplicationHTTPActionEventHandler() - class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler のコンストラクタ
Web-Application をイベント実行するためのハンドラを作成します。
A C D E G H I J L P R S W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


imaca_client 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (imaca_client 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.service.client.application
jp.co.intra_mart.foundation.service.client.application.content
jp.co.intra_mart.foundation.service.client.application.core


概要 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 imaca_client API Specifications

パッケージ
jp.co.intra_mart.foundation.service.client.application | このパッケージには、任意の Java 実行環境から Application Runtime にプログラム実行を依頼して処理を行うためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.content | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用して、各開発モデルのコンテンツを取得するためのクラスが含まれています。
jp.co.intra_mart.foundation.service.client.application.core |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.service.client.application, jp.co.intra_mart.foundation.service.client.application.content, jp.co.intra_mart.foundation.service.client.application.core

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventEntityHandler
        • class jp.co.intra_mart.foundation.service.client.application.ConcreteHTTPActionEventHandler
        • class jp.co.intra_mart.foundation.service.client.application.WebApplicationHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.PresentationPageHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.content.ServiceFrameworkHTTPActionEventHandler
          • class jp.co.intra_mart.foundation.service.client.application.ServletHTTPActionEventHandler
            • class jp.co.intra_mart.foundation.service.client.application.ActivityHTTPActionEventHandler
      • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.AccessibleLinkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.content.ActivityFrameworkHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.GroupSecurityHTTPActionEventFilterHandler
          • class jp.co.intra_mart.foundation.service.client.application.AccountSecurityHTTPActionEventFilterHandler
            • class jp.co.intra_mart.foundation.service.client.application.PasswordSecurityHTTPActionEventFilterHandler
        • class jp.co.intra_mart.foundation.service.client.application.LimitedSessionHTTPActionEventFilterHandler
    • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
    • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventResultImpl (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
    • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResultWrapper (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult)
      • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventContentImpl (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent)
      • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventURLImpl (implements jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException
          • class jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventResult
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventContent
    • interface jp.co.intra_mart.foundation.service.client.application.HTTPActionEventURL
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(imaca_client 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (imaca_client 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.service.client.application

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.client.application.HTTPActionEventHandlerParameterException は HTTPActionEventHandlerException を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent の使用

FilterHTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での FilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core での FilterHTTPActionEvent のサブクラス
class | AccessibleLinkFilterHTTPActionEvent フレームワークの実行環境作成のためのフィルタの抽象実装です。
class | AccountSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。
class | ActivityFrameworkFilterHTTPActionEvent フレームワークの実行環境作成のためのフィルタの抽象実装です。
class | GroupSecurityFilterHTTPActionEvent グループセキュリティ認証のためのフィルタの抽象実装です。
class | PasswordSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。
class | SecurityFilterHTTPActionEvent セキュリティ認証のためのフィルタの抽象実装です。
class | TemporaryFilterHTTPActionEvent ワンタイムセッションのためのフィルタの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.application.core |

jp.co.intra_mart.foundation.service.provider.application での FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
protected abstract  void FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。

jp.co.intra_mart.foundation.service.provider.application.core での FilterHTTPActionEventChain の使用

FilterHTTPActionEventChain 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application.core のメソッド
protected void | TemporaryFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
protected void | SecurityFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
protected void | ActivityFrameworkFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
protected void | AccessibleLinkFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent の使用

HTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.application.core |

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEvent の使用

HTTPActionEvent を実装している jp.co.intra_mart.foundation.service.provider.application のクラス
 class FilterHTTPActionEvent
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

jp.co.intra_mart.foundation.service.provider.application.core での HTTPActionEvent の使用

HTTPActionEvent を実装している jp.co.intra_mart.foundation.service.provider.application.core のクラス
class | AccessibleLinkFilterHTTPActionEvent フレームワークの実行環境作成のためのフィルタの抽象実装です。
class | AccountSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。
class | ActivityFrameworkFilterHTTPActionEvent フレームワークの実行環境作成のためのフィルタの抽象実装です。
class | GroupSecurityFilterHTTPActionEvent グループセキュリティ認証のためのフィルタの抽象実装です。
class | PasswordSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。
class | PresentationPageHTTPActionEvent Application Runtime で実行されるイベントのためのインターフェースです。
class | SecurityFilterHTTPActionEvent セキュリティ認証のためのフィルタの抽象実装です。
class | ServiceFrameworkHTTPActionEvent Application Runtime で実行されるイベントのためのインターフェースです。
class | SessionBuilderHTTPActionEvent HttpSession を確立するためのイベント。
class | TemporaryFilterHTTPActionEvent ワンタイムセッションのためのフィルタの抽象実装です。
class | WebApplicationHTTPActionEvent Application Runtime で実行されるイベントのためのインターフェースです。

HTTPActionEvent を返す jp.co.intra_mart.foundation.service.provider.application.core のメソッド
 HTTPActionEvent HTTPActionEventBuilder.createHTTPActionEvent(String name)
指定の名前のイベントオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext の使用

HTTPActionEventClientContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventClientContext の使用

HTTPActionEventClientContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventClientContext HTTPActionEventContext.getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext の使用

HTTPActionEventContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.application.core |

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventContext の使用

HTTPActionEventContext 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application のメソッド
void | HTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | FilterHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | FilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

jp.co.intra_mart.foundation.service.provider.application.core での HTTPActionEventContext の使用

HTTPActionEventContext 型のパラメータを持つ jp.co.intra_mart.foundation.service.provider.application.core のメソッド
void | WebApplicationHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected void | TemporaryFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
void | SessionBuilderHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | ServiceFrameworkHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected void | SecurityFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
void | PresentationPageHTTPActionEvent.action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
void | HTTPActionEventController.execute(String name, HTTPActionEventContext context, Properties params, HttpServletRequest request, HttpServletResponse response) イベントを実行します。
protected void | ActivityFrameworkFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
protected void | AccessibleLinkFilterHTTPActionEvent.doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException の使用

HTTPActionEventException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventException の使用

HTTPActionEventException をスローする jp.co.intra_mart.foundation.service.provider.application のメソッド
 long HTTPActionEventContext.getRequestTime()
イベントの実行を要求した時刻を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

jp.co.intra_mart.foundation.service.provider.application での HTTPActionEventListenerContext の使用

HTTPActionEventListenerContext を返す jp.co.intra_mart.foundation.service.provider.application のメソッド
 HTTPActionEventListenerContext HTTPActionEventContext.getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException の使用

AccountSecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での AccountSecurityException の使用

jp.co.intra_mart.foundation.service.provider.application.core での AccountSecurityException のサブクラス
 class PasswordSecurityException
パスワードセキュリティ例外です。

AccountSecurityException をスローする jp.co.intra_mart.foundation.service.provider.application.core のメソッド
protected  jp.co.intra_mart.foundation.security.account.Account AccountSecurityFilterHTTPActionEvent.getAccount(String groupId, String accountId)
指定のアカウント情報オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent の使用

AccountSecurityFilterHTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での AccountSecurityFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core での AccountSecurityFilterHTTPActionEvent のサブクラス
 class PasswordSecurityFilterHTTPActionEvent
アカウントセキュリティ認証のためのフィルタの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException の使用

GroupSecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での GroupSecurityException の使用

jp.co.intra_mart.foundation.service.provider.application.core での GroupSecurityException のサブクラス
class | AccountSecurityException アカウントセキュリティ例外です。
class | PasswordSecurityException パスワードセキュリティ例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent の使用

GroupSecurityFilterHTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での GroupSecurityFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core での GroupSecurityFilterHTTPActionEvent のサブクラス
class | AccountSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。
class | PasswordSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder の使用

HTTPActionEventBuilder を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での HTTPActionEventBuilder の使用

jp.co.intra_mart.foundation.service.provider.application.core での HTTPActionEventBuilder のサブクラス
 class HTTPActionEventController
HTTPActionEvent 関連のビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の使用

jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException の使用

jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.SecurityException の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.SecurityException の使用

SecurityException を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での SecurityException の使用

jp.co.intra_mart.foundation.service.provider.application.core での SecurityException のサブクラス
class | AccountSecurityException アカウントセキュリティ例外です。
class | GroupSecurityException グループセキュリティ例外です。
class | PasswordSecurityException パスワードセキュリティ例外です。

SecurityException をスローする jp.co.intra_mart.foundation.service.provider.application.core のメソッド
protected abstract void | SecurityFilterHTTPActionEvent.certify(HttpServletRequest request) 認証します。
protected void | PasswordSecurityFilterHTTPActionEvent.certify(String groupId, String accountId, String pwd) ログインアカウント認証を行います。
protected void | PasswordSecurityFilterHTTPActionEvent.certify(HttpServletRequest request) 認証します。
protected void | GroupSecurityFilterHTTPActionEvent.certify(String groupId) ログイングループ認証を行います。
protected void | GroupSecurityFilterHTTPActionEvent.certify(HttpServletRequest request) 認証します。
protected jp.co.intra_mart.foundation.security.group.LoginGroup | GroupSecurityFilterHTTPActionEvent.getLoginGroup(String groupId) 指定のログイングループの情報オブジェクトを返します。
protected void | AccountSecurityFilterHTTPActionEvent.certify(String groupId, String accountId) ログインアカウント認証を行います。
protected void | AccountSecurityFilterHTTPActionEvent.certify(HttpServletRequest request) 認証します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent の使用

SecurityFilterHTTPActionEvent を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core での SecurityFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core での SecurityFilterHTTPActionEvent のサブクラス
class | AccountSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。
class | GroupSecurityFilterHTTPActionEvent グループセキュリティ認証のためのフィルタの抽象実装です。
class | PasswordSecurityFilterHTTPActionEvent アカウントセキュリティ認証のためのフィルタの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent の使用

jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccessibleLinkFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス AccessibleLinkFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class AccessibleLinkFilterHTTPActionEvent
extends FilterHTTPActionEvent

フレームワークの実行環境作成のためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected AccessibleLinkFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected  void doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccessibleLinkFilterHTTPActionEvent

protected AccessibleLinkFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

doFilter

protected void doFilter(HTTPActionEventContext context,
                        HttpServletRequest request,
                        HttpServletResponse response,
                        FilterHTTPActionEventChain chain)
                 throws ServletException
イベントのフィルタ処理です。

定義:
クラス FilterHTTPActionEvent 内の doFilter
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountSecurityException (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス AccountSecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityException
                拡張 jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException
                    拡張 jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PasswordSecurityException
public class AccountSecurityException
extends GroupSecurityException

アカウントセキュリティ例外です。 存在しないアカウントにアクセスした場合などにスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
AccountSecurityException(String groupId, String accountId)
セキュリティ例外オブジェクトを作成します。
AccountSecurityException(String groupId, String accountId, String msg)
セキュリティ例外オブジェクトを作成します。
AccountSecurityException(String groupId, String accountId, String msg, Throwable t)
セキュリティ例外オブジェクトを作成します。
AccountSecurityException(String groupId, String accountId, Throwable t)
セキュリティ例外オブジェクトを作成します。
メソッドの概要
 String getAccountId()
この例外が発生したアカウントＩＤです。
クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException から継承したメソッド
getGroupId
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountSecurityException

public AccountSecurityException(String groupId,
                                String accountId)
セキュリティ例外オブジェクトを作成します。 このコンストラクタの場合、例外メッセージは 「Account is not found: accountId in groupId」 となります。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ

AccountSecurityException

public AccountSecurityException(String groupId,
                                String accountId,
                                Throwable t)
セキュリティ例外オブジェクトを作成します。 このコンストラクタの場合、例外メッセージは 「Account is not found: accountId in groupId」 となります。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ

AccountSecurityException

public AccountSecurityException(String groupId,
                                String accountId,
                                String msg)
セキュリティ例外オブジェクトを作成します。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
msg - 例外メッセージ

AccountSecurityException

public AccountSecurityException(String groupId,
                                String accountId,
                                String msg,
                                Throwable t)
セキュリティ例外オブジェクトを作成します。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
msg - 例外メッセージ
メソッドの詳細

getAccountId

public String getAccountId()
この例外が発生したアカウントＩＤです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountSecurityFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス AccountSecurityFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent
                拡張 jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
直系の既知のサブクラス:
PasswordSecurityFilterHTTPActionEvent
public class AccountSecurityFilterHTTPActionEvent
extends GroupSecurityFilterHTTPActionEvent

アカウントセキュリティ認証のためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String | ID_SECURITY_ACCOUNT
protected static String | ID_SECURITY_SESSION_ACCOUNT
クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
protected AccountSecurityFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected void | certify(HttpServletRequest request) 認証します。
protected void | certify(String groupId, String accountId) ログインアカウント認証を行います。
protected jp.co.intra_mart.foundation.security.account.Account | getAccount(String groupId, String accountId) 指定のアカウント情報オブジェクトを返します。
クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent から継承したメソッド
certify, getLoginGroup
クラス jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent から継承したメソッド
doFilter
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_ACCOUNT

protected static final String ID_SECURITY_ACCOUNT
関連項目:
定数フィールド値

ID_SECURITY_SESSION_ACCOUNT

protected static final String ID_SECURITY_SESSION_ACCOUNT
関連項目:
定数フィールド値
コンストラクタの詳細

AccountSecurityFilterHTTPActionEvent

protected AccountSecurityFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

certify

protected void certify(String groupId,
                       String accountId)
                throws SecurityException
ログインアカウント認証を行います。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
例外:
SecurityException

certify

protected void certify(HttpServletRequest request)
                throws SecurityException
認証します。

オーバーライド:
クラス GroupSecurityFilterHTTPActionEvent 内の certify
例外:
SecurityException - 認証の結果、許可されない場合にスローされます。

getAccount

protected jp.co.intra_mart.foundation.security.account.Account getAccount(String groupId,
                                                                          String accountId)
                                                                   throws jp.co.intra_mart.foundation.security.exception.AccessSecurityException,
                                                                          AccountSecurityException
指定のアカウント情報オブジェクトを返します。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
戻り値:
アカウント情報オブジェクト
例外:
jp.co.intra_mart.foundation.security.exception.AccessSecurityException
AccountSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ActivityFrameworkFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス ActivityFrameworkFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class ActivityFrameworkFilterHTTPActionEvent
extends FilterHTTPActionEvent

フレームワークの実行環境作成のためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected ActivityFrameworkFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected  void doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ActivityFrameworkFilterHTTPActionEvent

protected ActivityFrameworkFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

doFilter

protected void doFilter(HTTPActionEventContext context,
                        HttpServletRequest request,
                        HttpServletResponse response,
                        FilterHTTPActionEventChain chain)
                 throws ServletException
イベントのフィルタ処理です。

定義:
クラス FilterHTTPActionEvent 内の doFilter
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityException (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス GroupSecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityException
                拡張 jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccountSecurityException
public class GroupSecurityException
extends SecurityException

グループセキュリティ例外です。 存在しないログイングループにアクセスした場合などにスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
GroupSecurityException(String groupId)
セキュリティ例外オブジェクトを作成します。
GroupSecurityException(String groupId, String msg)
セキュリティ例外オブジェクトを作成します。
GroupSecurityException(String groupId, String msg, Throwable t)
セキュリティ例外オブジェクトを作成します。
GroupSecurityException(String groupId, Throwable t)
セキュリティ例外オブジェクトを作成します。
メソッドの概要
 String getGroupId()
この例外が発生したグループＩＤです。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GroupSecurityException

public GroupSecurityException(String groupId,
                              Throwable t)
セキュリティ例外オブジェクトを作成します。 このコンストラクタの場合、例外メッセージは 「Group is not found: groupId」となります。

パラメータ:
groupId - グループＩＤ

GroupSecurityException

public GroupSecurityException(String groupId)
セキュリティ例外オブジェクトを作成します。 このコンストラクタの場合、例外メッセージは 「Group is not found: groupId」となります。

パラメータ:
groupId - グループＩＤ

GroupSecurityException

public GroupSecurityException(String groupId,
                              String msg)
セキュリティ例外オブジェクトを作成します。

パラメータ:
groupId - グループＩＤ

GroupSecurityException

public GroupSecurityException(String groupId,
                              String msg,
                              Throwable t)
セキュリティ例外オブジェクトを作成します。

パラメータ:
groupId - グループＩＤ
メソッドの詳細

getGroupId

public String getGroupId()
この例外が発生したグループＩＤです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GroupSecurityFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス GroupSecurityFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
直系の既知のサブクラス:
AccountSecurityFilterHTTPActionEvent
public class GroupSecurityFilterHTTPActionEvent
extends SecurityFilterHTTPActionEvent

グループセキュリティ認証のためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_GROUP
コンストラクタの概要
protected GroupSecurityFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected void | certify(HttpServletRequest request) 認証します。
protected void | certify(String groupId) ログイングループ認証を行います。
protected jp.co.intra_mart.foundation.security.group.LoginGroup | getLoginGroup(String groupId) 指定のログイングループの情報オブジェクトを返します。
クラス jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent から継承したメソッド
doFilter
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_GROUP

protected static final String ID_SECURITY_GROUP
関連項目:
定数フィールド値
コンストラクタの詳細

GroupSecurityFilterHTTPActionEvent

protected GroupSecurityFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

certify

protected void certify(String groupId)
                throws SecurityException
ログイングループ認証を行います。

パラメータ:
groupId - グループＩＤ
例外:
SecurityException

certify

protected void certify(HttpServletRequest request)
                throws SecurityException
認証します。

定義:
クラス SecurityFilterHTTPActionEvent 内の certify
例外:
SecurityException - 認証の結果、許可されない場合にスローされます。

getLoginGroup

protected jp.co.intra_mart.foundation.security.group.LoginGroup getLoginGroup(String groupId)
                                                                       throws SecurityException,
                                                                              jp.co.intra_mart.foundation.security.exception.AccessSecurityException
指定のログイングループの情報オブジェクトを返します。

戻り値:
ログイングループ情報オブジェクト
例外:
SecurityException - ログイングループが実在しなかった場合
jp.co.intra_mart.foundation.security.exception.AccessSecurityException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventBuilder (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス HTTPActionEventBuilder

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder
直系の既知のサブクラス:
HTTPActionEventController
public class HTTPActionEventBuilder
extends jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder

HTTPActionEvent 関連のビルダです。

導入されたバージョン:
version 4.3

フィールドの概要
クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder から継承したフィールド
ID_EVENT_NAME, ID_EVENT_PARAMETER, ID_EVENT_PARAMETER_CHARSET, ID_EVENT_REQUEST_TIME
コンストラクタの概要
HTTPActionEventBuilder()
イベントビルダを新しく作成します。
メソッドの概要
HTTPActionEvent | createHTTPActionEvent(String name) 指定の名前のイベントオブジェクトを作成します。
protected Class | findClass(String name) 指定の名称を持つクラスを返します。
クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder から継承したメソッド
decodeParameter, encodeParameter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPActionEventBuilder

public HTTPActionEventBuilder()
イベントビルダを新しく作成します。

メソッドの詳細

createHTTPActionEvent

public HTTPActionEvent createHTTPActionEvent(String name)
                                      throws ClassNotFoundException,
                                             InstantiationException,
                                             IllegalAccessException
指定の名前のイベントオブジェクトを作成します。
名前は、イベントのクラス名としてクラスを検索します。 クラスの検索は、findClass(String) を呼び出します。 クラスが見つかると、そのクラスのゼロパラメータコンストラクタを 呼び出してインスタンス化します。 インスタンス化されたオブジェクトは、HTTPActionEvent 型に キャストされて返されます。

パラメータ:
name - イベント名（クラス名）
戻り値:
イベントオブジェクト
例外:
ClassNotFoundException
InstantiationException
IllegalAccessException

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
指定の名称を持つクラスを返します。
このメソッドは、このクラスがロードされたクラスローダから クラスを検索します。 クラスが見つからなかった場合、更にスレッドのコンテキストクラスローダを 利用してクラスを再検索します。

パラメータ:
name - クラス名
戻り値:
クラス
例外:
ClassNotFoundException - クラスのロードに失敗
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventController (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス HTTPActionEventController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController
public class HTTPActionEventController
extends HTTPActionEventBuilder

HTTPActionEvent 関連のビルダです。

導入されたバージョン:
version 4.3

フィールドの概要
static String | ID_URI_FRAMEWORK_PRESENTATION_PREFIX プレゼンテーションフレームワークのＵＲＩの接頭部を取得するためのパラメータ名
static String | ID_URI_FRAMEWORK_PRESENTATION_SEPARATOR プレゼンテーションフレームワークのＵＲＩのセパレータを取得するためのパラメータ名
static String | ID_URI_FRAMEWORK_PRESENTATION_SUFFIX プレゼンテーションフレームワークのＵＲＩの接尾部を取得するためのパラメータ名
static String | ID_URI_FRAMEWORK_SERVICE_PREFIX サービスフレームワークのＵＲＩの接頭部を取得するためのパラメータ名
static String | ID_URI_JSSP_SERVICE_PREFIX スクリプト開発モデルのＵＲＩの接頭部を取得するためのパラメータ名
クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder から継承したフィールド
ID_EVENT_NAME, ID_EVENT_PARAMETER, ID_EVENT_PARAMETER_CHARSET, ID_EVENT_REQUEST_TIME
コンストラクタの概要
HTTPActionEventController()
イベントコントローラを新しく作成します。
メソッドの概要
String | createEventURL(HttpServletRequest request, HttpServletResponse response, String location, String query) 指定のＵＲＬに対して指定のクエリによるセッションを維持したリクエストを するためのＵＲＬを作成して返します。
HttpServletRequest | createHttpServletRequest(Properties params, HttpServletRequest request) 指定パラメータを優先的に処理するリクエストを作成します。
void | execute(String name, HTTPActionEventContext context, Properties params, HttpServletRequest request, HttpServletResponse response) イベントを実行します。
String | toAbsoluteURL(HttpServletRequest request, String url) 指定ＵＲＬを絶対形式に変換します。
クラス jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder から継承したメソッド
createHTTPActionEvent, findClass
クラス jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder から継承したメソッド
decodeParameter, encodeParameter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_URI_JSSP_SERVICE_PREFIX

public static final String ID_URI_JSSP_SERVICE_PREFIX
スクリプト開発モデルのＵＲＩの接頭部を取得するためのパラメータ名

関連項目:
定数フィールド値

ID_URI_FRAMEWORK_SERVICE_PREFIX

public static final String ID_URI_FRAMEWORK_SERVICE_PREFIX
サービスフレームワークのＵＲＩの接頭部を取得するためのパラメータ名

関連項目:
定数フィールド値

ID_URI_FRAMEWORK_PRESENTATION_PREFIX

public static final String ID_URI_FRAMEWORK_PRESENTATION_PREFIX
プレゼンテーションフレームワークのＵＲＩの接頭部を取得するためのパラメータ名

関連項目:
定数フィールド値

ID_URI_FRAMEWORK_PRESENTATION_SUFFIX

public static final String ID_URI_FRAMEWORK_PRESENTATION_SUFFIX
プレゼンテーションフレームワークのＵＲＩの接尾部を取得するためのパラメータ名

関連項目:
定数フィールド値

ID_URI_FRAMEWORK_PRESENTATION_SEPARATOR

public static final String ID_URI_FRAMEWORK_PRESENTATION_SEPARATOR
プレゼンテーションフレームワークのＵＲＩのセパレータを取得するためのパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

HTTPActionEventController

public HTTPActionEventController()
イベントコントローラを新しく作成します。

メソッドの詳細

execute

public void execute(String name,
                    HTTPActionEventContext context,
                    Properties params,
                    HttpServletRequest request,
                    HttpServletResponse response)
             throws ClassNotFoundException,
                    InstantiationException,
                    IllegalAccessException,
                    ServletException
イベントを実行します。

パラメータ:
name - イベント名
context - イベントに関する情報
params - イベントへのパラメータ
request - リクエスト
response - レスポンス
例外:
ClassNotFoundException - イベントのクラスが見つからなかった
InstantiationException - イベントをインスタンス化できなかった
IllegalAccessException - イベントのコンストラクタを実行できなかった
ServletException - 実行時エラー

createHttpServletRequest

public HttpServletRequest createHttpServletRequest(Properties params,
                                                   HttpServletRequest request)
指定パラメータを優先的に処理するリクエストを作成します。

パラメータ:
params - イベントへのパラメータ
request - 基礎リクエスト
戻り値:
ラップされた新しいリクエスト

toAbsoluteURL

public String toAbsoluteURL(HttpServletRequest request,
                            String url)
                     throws MalformedURLException
指定ＵＲＬを絶対形式に変換します。

パラメータ:
request - リクエスト
url - URL の文字列表現
戻り値:
ＵＲＬの絶対表現
例外:
MalformedURLException

createEventURL

public String createEventURL(HttpServletRequest request,
                             HttpServletResponse response,
                             String location,
                             String query)
指定のＵＲＬに対して指定のクエリによるセッションを維持したリクエストを するためのＵＲＬを作成して返します。

パラメータ:
request - リクエスト
response - レスポンス
location - 元となるＵＲＬ
query - ＵＲＬに対するクエリ
戻り値:
ＵＲＬ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider.application.core (imaca_provider 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.application.core
クラス
AccessibleLinkFilterHTTPActionEvent
AccountSecurityFilterHTTPActionEvent
ActivityFrameworkFilterHTTPActionEvent
GroupSecurityFilterHTTPActionEvent
HTTPActionEventBuilder
HTTPActionEventController
PasswordSecurityFilterHTTPActionEvent
PresentationPageHTTPActionEvent
SecurityFilterHTTPActionEvent
ServiceFrameworkHTTPActionEvent
SessionBuilderHTTPActionEvent
TemporaryFilterHTTPActionEvent
WebApplicationHTTPActionEvent
例外
AccountSecurityException
GroupSecurityException
PasswordSecurityException
SecurityException


jp.co.intra_mart.foundation.service.provider.application.core (imaca_provider 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application.core

クラスの概要
AccessibleLinkFilterHTTPActionEvent | フレームワークの実行環境作成のためのフィルタの抽象実装です。
AccountSecurityFilterHTTPActionEvent | アカウントセキュリティ認証のためのフィルタの抽象実装です。
ActivityFrameworkFilterHTTPActionEvent | フレームワークの実行環境作成のためのフィルタの抽象実装です。
GroupSecurityFilterHTTPActionEvent | グループセキュリティ認証のためのフィルタの抽象実装です。
HTTPActionEventBuilder | HTTPActionEvent 関連のビルダです。
HTTPActionEventController | HTTPActionEvent 関連のビルダです。
PasswordSecurityFilterHTTPActionEvent | アカウントセキュリティ認証のためのフィルタの抽象実装です。
PresentationPageHTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
SecurityFilterHTTPActionEvent | セキュリティ認証のためのフィルタの抽象実装です。
ServiceFrameworkHTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
SessionBuilderHTTPActionEvent | HttpSession を確立するためのイベント。
TemporaryFilterHTTPActionEvent | ワンタイムセッションのためのフィルタの抽象実装です。
WebApplicationHTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。

例外の概要
AccountSecurityException | アカウントセキュリティ例外です。
GroupSecurityException | グループセキュリティ例外です。
PasswordSecurityException | パスワードセキュリティ例外です。
SecurityException | セキュリティ例外が発生した場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.application.core クラス階層 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application.core の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
      • class jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent
      • class jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent
      • class jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent
        • class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent
          • class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent
            • class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent
      • class jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent
    • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
      • class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder
        • class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController
    • class jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.core.SecurityException
          • class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException
            • class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException
              • class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException
    • class jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.provider.application.core の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.application.core の使用

jp.co.intra_mart.foundation.service.provider.application.core を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application.core

jp.co.intra_mart.foundation.service.provider.application.core により使用される jp.co.intra_mart.foundation.service.provider.application.core のクラス
AccountSecurityException
アカウントセキュリティ例外です。
AccountSecurityFilterHTTPActionEvent
アカウントセキュリティ認証のためのフィルタの抽象実装です。
GroupSecurityException
グループセキュリティ例外です。
GroupSecurityFilterHTTPActionEvent
グループセキュリティ認証のためのフィルタの抽象実装です。
HTTPActionEventBuilder
HTTPActionEvent 関連のビルダです。
SecurityException
セキュリティ例外が発生した場合にスローされます。
SecurityFilterHTTPActionEvent
セキュリティ認証のためのフィルタの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PasswordSecurityException (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス PasswordSecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityException
                拡張 jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException
                    拡張 jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException
                        拡張 jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException
すべての実装インタフェース:
Serializable
public class PasswordSecurityException
extends AccountSecurityException

パスワードセキュリティ例外です。 入力したパスワードが設定と異なる場合などにスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
PasswordSecurityException(String groupId, String accountId)
セキュリティ例外オブジェクトを作成します。
PasswordSecurityException(String groupId, String accountId, String msg)
セキュリティ例外オブジェクトを作成します。
PasswordSecurityException(String groupId, String accountId, String msg, Throwable t)
セキュリティ例外オブジェクトを作成します。
PasswordSecurityException(String groupId, String accountId, Throwable t)
セキュリティ例外オブジェクトを作成します。
クラス jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException から継承したメソッド
getAccountId
クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException から継承したメソッド
getGroupId
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PasswordSecurityException

public PasswordSecurityException(String groupId,
                                 String accountId)
セキュリティ例外オブジェクトを作成します。 このコンストラクタの場合、例外メッセージは 「The password is different: accountId in groupId」 となります。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ

PasswordSecurityException

public PasswordSecurityException(String groupId,
                                 String accountId,
                                 Throwable t)
セキュリティ例外オブジェクトを作成します。 このコンストラクタの場合、例外メッセージは 「The password is different: accountId in groupId」 となります。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ

PasswordSecurityException

public PasswordSecurityException(String groupId,
                                 String accountId,
                                 String msg)
セキュリティ例外オブジェクトを作成します。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
msg - 例外メッセージ

PasswordSecurityException

public PasswordSecurityException(String groupId,
                                 String accountId,
                                 String msg,
                                 Throwable t)
セキュリティ例外オブジェクトを作成します。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
msg - 例外メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PasswordSecurityFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス PasswordSecurityFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent
                拡張 jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent
                    拡張 jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class PasswordSecurityFilterHTTPActionEvent
extends AccountSecurityFilterHTTPActionEvent

アカウントセキュリティ認証のためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_SECURITY_PASSWORD
クラス jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent から継承したフィールド
ID_SECURITY_ACCOUNT, ID_SECURITY_SESSION_ACCOUNT
クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent から継承したフィールド
ID_SECURITY_GROUP
コンストラクタの概要
protected PasswordSecurityFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected void | certify(HttpServletRequest request) 認証します。
protected void | certify(String groupId, String accountId, String pwd) ログインアカウント認証を行います。
クラス jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent から継承したメソッド
certify, getAccount
クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent から継承したメソッド
certify, getLoginGroup
クラス jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent から継承したメソッド
doFilter
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_SECURITY_PASSWORD

protected static final String ID_SECURITY_PASSWORD
関連項目:
定数フィールド値
コンストラクタの詳細

PasswordSecurityFilterHTTPActionEvent

protected PasswordSecurityFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

certify

protected void certify(String groupId,
                       String accountId,
                       String pwd)
                throws SecurityException
ログインアカウント認証を行います。

パラメータ:
groupId - グループＩＤ
accountId - アカウントＩＤ
pwd - パスワード
例外:
SecurityException

certify

protected void certify(HttpServletRequest request)
                throws SecurityException
認証します。

オーバーライド:
クラス AccountSecurityFilterHTTPActionEvent 内の certify
例外:
SecurityException - 認証の結果、許可されない場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PresentationPageHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス PresentationPageHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class PresentationPageHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

フィールドの概要
protected static String ID_PAGE_PATH
実行するプレゼンテーションページのパス
コンストラクタの概要
PresentationPageHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ID_PAGE_PATH

protected static final String ID_PAGE_PATH
実行するプレゼンテーションページのパス

関連項目:
定数フィールド値
コンストラクタの詳細

PresentationPageHTTPActionEvent

public PresentationPageHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SecurityException (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス SecurityException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GroupSecurityException
public class SecurityException
extends Exception

セキュリティ例外が発生した場合にスローされます。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
SecurityException()
セキュリティ例外オブジェクトを作成します。
SecurityException(String msg)
セキュリティ例外オブジェクトを作成します。
SecurityException(String msg, Throwable t)
セキュリティ例外オブジェクトを作成します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SecurityException

public SecurityException()
セキュリティ例外オブジェクトを作成します。

SecurityException

public SecurityException(String msg)
セキュリティ例外オブジェクトを作成します。

パラメータ:
msg - 例外メッセージ

SecurityException

public SecurityException(String msg,
                         Throwable t)
セキュリティ例外オブジェクトを作成します。

パラメータ:
msg - 例外メッセージ
t - 原因となった例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SecurityFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス SecurityFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
直系の既知のサブクラス:
GroupSecurityFilterHTTPActionEvent
public abstract class SecurityFilterHTTPActionEvent
extends FilterHTTPActionEvent

セキュリティ認証のためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected SecurityFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected abstract void | certify(HttpServletRequest request) 認証します。
protected void | doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SecurityFilterHTTPActionEvent

protected SecurityFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

certify

protected abstract void certify(HttpServletRequest request)
                         throws SecurityException
認証します。

例外:
SecurityException - 認証の結果、許可されない場合にスローされます。

doFilter

protected void doFilter(HTTPActionEventContext context,
                        HttpServletRequest request,
                        HttpServletResponse response,
                        FilterHTTPActionEventChain chain)
                 throws ServletException
イベントのフィルタ処理です。

定義:
クラス FilterHTTPActionEvent 内の doFilter
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceFrameworkHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス ServiceFrameworkHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class ServiceFrameworkHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
ServiceFrameworkHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceFrameworkHTTPActionEvent

public ServiceFrameworkHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SessionBuilderHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス SessionBuilderHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class SessionBuilderHTTPActionEvent
extends Object
implements HTTPActionEvent

HttpSession を確立するためのイベント。 結果として、再接続の為のＵＲＬ（セッション情報付）を返します。

導入されたバージョン:
version 4.3

コンストラクタの概要
SessionBuilderHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SessionBuilderHTTPActionEvent

public SessionBuilderHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TemporaryFilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス TemporaryFilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
        拡張 jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class TemporaryFilterHTTPActionEvent
extends FilterHTTPActionEvent

ワンタイムセッションのためのフィルタの抽象実装です。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected TemporaryFilterHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
protected  void doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain)
イベントのフィルタ処理です。
クラス jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent から継承したメソッド
action
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TemporaryFilterHTTPActionEvent

protected TemporaryFilterHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

doFilter

protected void doFilter(HTTPActionEventContext context,
                        HttpServletRequest request,
                        HttpServletResponse response,
                        FilterHTTPActionEventChain chain)
                 throws ServletException
イベントのフィルタ処理です。

定義:
クラス FilterHTTPActionEvent 内の doFilter
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WebApplicationHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application.core
クラス WebApplicationHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
public class WebApplicationHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

コンストラクタの概要
WebApplicationHTTPActionEvent()
唯一のコンストラクタ
メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WebApplicationHTTPActionEvent

public WebApplicationHTTPActionEvent()
唯一のコンストラクタ

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterHTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス FilterHTTPActionEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent
すべての実装インタフェース:
HTTPActionEvent
直系の既知のサブクラス:
AccessibleLinkFilterHTTPActionEvent, ActivityFrameworkFilterHTTPActionEvent, SecurityFilterHTTPActionEvent, TemporaryFilterHTTPActionEvent
public abstract class FilterHTTPActionEvent
extends Object
implements HTTPActionEvent

Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
実際のイベントをフィルタリングしてラップする場合に利用します。

フィルターイベントを作成する場合は、この抽象実装をスーパークラスとして サブクラスを作成します。 その際、引数を１つも持たない public なコンストラクタを持つ必要があります。

導入されたバージョン:
version 4.3

コンストラクタの概要
protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。
メソッドの概要
void | action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response) イベント処理メソッドです。
protected abstract void | doFilter(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response, FilterHTTPActionEventChain chain) イベントのフィルタ処理です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterHTTPActionEvent

protected FilterHTTPActionEvent()
指定のイベントをラップするためのフィルターを作成します。

メソッドの詳細

action

public final void action(HTTPActionEventContext context,
                         HttpServletRequest request,
                         HttpServletResponse response)
                  throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

このメソッドは、リクエストを適切に処理した後に、 doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) を呼び出します。 サブクラスは、doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) をオーバーライドして、 フィルタとして処理したい内容を実装してください。

定義:
インタフェース HTTPActionEvent 内の action
パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー

doFilter

protected abstract void doFilter(HTTPActionEventContext context,
                                 HttpServletRequest request,
                                 HttpServletResponse response,
                                 FilterHTTPActionEventChain chain)
                          throws ServletException
イベントのフィルタ処理です。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
chain - チェーン内の次のエンティティ
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterHTTPActionEventChain (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース FilterHTTPActionEventChain

public interface FilterHTTPActionEventChain

FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
FilterHTTPActionEvent は、チェーン内の次のフィルタを呼び出す時、 あるいは FilterHTTPActionEvent がチェーン内の最後のフィルタの場合は イベント(HTTPActionEvent)を呼び出す時に、 FilterHTTPActionEventChain を利用します。

導入されたバージョン:
version 4.3

メソッドの概要
void | doChain() チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
void | doChain(HttpServletRequest request, HttpServletResponse response) チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
HttpServletRequest | getRequest() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
HttpServletResponse | getResponse() チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

メソッドの詳細

getRequest

public HttpServletRequest getRequest()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。

戻り値:
リクエスト

doChain

public void doChain()
             throws ServletException
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
このメソッドの呼び出しは、以下の呼び出しと同様です。

doChain(getRequest(), getResponse())

例外:
ServletException - 実行時エラー

doChain

public void doChain(HttpServletRequest request,
                    HttpServletResponse response)
             throws ServletException
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。

パラメータ:
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEvent (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEvent

既知の実装クラスの一覧:
FilterHTTPActionEvent, PresentationPageHTTPActionEvent, ServiceFrameworkHTTPActionEvent, SessionBuilderHTTPActionEvent, WebApplicationHTTPActionEvent
public interface HTTPActionEvent

Application Runtime で実行されるイベントのためのインターフェースです。
このインターフェースを実装したクラスは、 Application Runtime でインスタンス化されます。 したがって、通常は WEB-INF 内にクラスを配置する事になります。

また、イベントはイベントリスナーにより引数を持たないコンストラクタを 利用してインスタンス化されます。 したがって、このインターフェースを実装するクラスは、 引数を持たない public なコンストラクタが必要になります。

導入されたバージョン:
version 4.3

メソッドの概要
 void action(HTTPActionEventContext context, HttpServletRequest request, HttpServletResponse response)
イベント処理メソッドです。

メソッドの詳細

action

public void action(HTTPActionEventContext context,
                   HttpServletRequest request,
                   HttpServletResponse response)
            throws ServletException
イベント処理メソッドです。

Application Runtime で HTTPActionEventListenerServlet により 実行されます。 このメソッドは、Application Runtime 内で実行されるため、 このメソッド内で使用するすべてのクラスは、Application Runtime の 動作する環境内においてアクセスできる必要があります。

パラメータ:
context - イベントに関する情報
request - HTTPリクエストオブジェクト
response - HTTPレスポンスオブジェクト
例外:
ServletException - 実行時エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventClientContext (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventClientContext

public interface HTTPActionEventClientContext

Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
String | getRemoteHostAddress() イベント実行要求をしたクライアントのアドレスを返します。
String | getRemoteHostName() イベント実行要求をしたクライアントのホスト名を返します。
String | getSystemProperty(String name) クライアントの Java 実行環境のシステムプロパティの値を返します。
Set | getSystemPropertyNameSet() クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。

メソッドの詳細

getRemoteHostAddress

public String getRemoteHostAddress()
イベント実行要求をしたクライアントのアドレスを返します。

戻り値:
アドレスを表す文字列

getRemoteHostName

public String getRemoteHostName()
イベント実行要求をしたクライアントのホスト名を返します。

戻り値:
ホスト名

getSystemProperty

public String getSystemProperty(String name)
クライアントの Java 実行環境のシステムプロパティの値を返します。

パラメータ:
name - プロパティ名
戻り値:
プロパティ名に対する値。指定のプロパティ名に関する定義値が見つからない場合は null。

getSystemPropertyNameSet

public Set getSystemPropertyNameSet()
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。 セットの各要素はプロパティ名を表す java.lang.String 型の値です。

戻り値:
プロパティ名のセット
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventContext (imaca_provider 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventContext

public interface HTTPActionEventContext

Application Runtime で実行されるイベントに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
long | getAcceptTime() イベント実行要求を受け付けたおよその時刻を返します。
String | getCharacterEncoding() リクエストパラメータの文字エンコーディングを返します。
HTTPActionEventClientContext | getClientContext() イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
HttpServletRequest | getHttpServletRequest() 現在のイベントを要求したリクエストを返します。
HTTPActionEventListenerContext | getListenerContext() イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
long | getRequestTime() イベントの実行を要求した時刻を返します。

メソッドの詳細

getAcceptTime

public long getAcceptTime()
イベント実行要求を受け付けたおよその時刻を返します。
Servlet コンテナによって、リスナーとなっている Servlet が実行される 以前に javax.servlet.Filter 等が実行されたりします。 したがって、このメソッドの返す値はサーバがリクエストを受け付けた時刻と 一致するとは限りません。

返す時刻の単位はミリ秒で、java.lang.System#currentTimeMillis() の仕様に 準じます。

戻り値:
時刻を表すミリ秒

getCharacterEncoding

public String getCharacterEncoding()
リクエストパラメータの文字エンコーディングを返します。

戻り値:
文字エンコーディング名

getRequestTime

public long getRequestTime()
                    throws HTTPActionEventException
イベントの実行を要求した時刻を返します。 このメソッドの返す時刻は、 1970/1/1 を基準から現在までのミリ秒です。

戻り値:
1970/1/1 を基準から現在までのミリ秒
例外:
HTTPActionEventException - 要求時刻が不明な場合

getHttpServletRequest

public HttpServletRequest getHttpServletRequest()
現在のイベントを要求したリクエストを返します。

戻り値:
リクエスト

getClientContext

public HTTPActionEventClientContext getClientContext()
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。

戻り値:
クライアント情報オブジェクト

getListenerContext

public HTTPActionEventListenerContext getListenerContext()
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。

戻り値:
リスナー情報オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventException (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
クラス HTTPActionEventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
すべての実装インタフェース:
Serializable
public class HTTPActionEventException
extends Exception

HTTPActionEvent に関するエラーを通知するための例外です。

導入されたバージョン:
version 4.3
関連項目:
直列化された形式

コンストラクタの概要
HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HTTPActionEventException

public HTTPActionEventException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

HTTPActionEventException

public HTTPActionEventException(String msg,
                                Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPActionEventListenerContext (imaca_provider 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.service.provider.application
インタフェース HTTPActionEventListenerContext

public interface HTTPActionEventListenerContext

Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

導入されたバージョン:
version 4.3

メソッドの概要
Class | getListenerClass() リスナーとなっている Servlet の実行時クラスを返します。
ServletConfig | getServletConfig() イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

メソッドの詳細

getServletConfig

public ServletConfig getServletConfig()
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。

戻り値:
Servlet 設定情報を含んでいる ServletConfig オブジェクト

getListenerClass

public Class getListenerClass()
リスナーとなっている Servlet の実行時クラスを返します。

戻り値:
java.lang.Class 型オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.service.provider.application (imaca_provider 6.1.14 API)

 jp.co.intra_mart.foundation.service.provider.application
インタフェース
FilterHTTPActionEventChain
HTTPActionEvent
HTTPActionEventClientContext
HTTPActionEventContext
HTTPActionEventListenerContext
クラス
FilterHTTPActionEvent
例外
HTTPActionEventException


jp.co.intra_mart.foundation.service.provider.application (imaca_provider 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

参照:
説明

インタフェースの概要
FilterHTTPActionEventChain | FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent | Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext | Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext | Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventListenerContext | Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

クラスの概要
FilterHTTPActionEvent Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。

例外の概要
HTTPActionEventException HTTPActionEvent に関するエラーを通知するための例外です。

パッケージ jp.co.intra_mart.foundation.service.provider.application の説明

このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。

導入されたバージョン:
version 4.0
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.service.provider.application クラス階層 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.service.provider.application の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.service.provider.application の使用 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.service.provider.application の使用

jp.co.intra_mart.foundation.service.provider.application を使用しているパッケージ
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.application.core |

jp.co.intra_mart.foundation.service.provider.application により使用される jp.co.intra_mart.foundation.service.provider.application のクラス
FilterHTTPActionEventChain
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventClientContext
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventException
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventListenerContext
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

jp.co.intra_mart.foundation.service.provider.application.core により使用される jp.co.intra_mart.foundation.service.provider.application のクラス
FilterHTTPActionEvent
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEventChain
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
HTTPActionEvent
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventContext
Application Runtime で実行されるイベントに関する情報インターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


すべてのクラス (imaca_provider 6.1.14 API)

 すべてのクラス
AccessibleLinkFilterHTTPActionEvent
AccountSecurityException
AccountSecurityFilterHTTPActionEvent
ActivityFrameworkFilterHTTPActionEvent
FilterHTTPActionEvent
FilterHTTPActionEventChain
GroupSecurityException
GroupSecurityFilterHTTPActionEvent
HTTPActionEvent
HTTPActionEventBuilder
HTTPActionEventClientContext
HTTPActionEventContext
HTTPActionEventController
HTTPActionEventException
HTTPActionEventListenerContext
PasswordSecurityException
PasswordSecurityFilterHTTPActionEvent
PresentationPageHTTPActionEvent
SecurityException
SecurityFilterHTTPActionEvent
ServiceFrameworkHTTPActionEvent
SessionBuilderHTTPActionEvent
TemporaryFilterHTTPActionEvent
WebApplicationHTTPActionEvent


定数フィールド値 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent
protected static final String | ID_SECURITY_ACCOUNT | "filter-security-account"
protected static final String | ID_SECURITY_SESSION_ACCOUNT | "user"

jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent
protected static final String ID_SECURITY_GROUP "filter-security-group"

jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController
public static final String | ID_URI_FRAMEWORK_PRESENTATION_PREFIX | "framework.presentation.uri.prefix"
public static final String | ID_URI_FRAMEWORK_PRESENTATION_SEPARATOR | "framework.presentation.uri.separator"
public static final String | ID_URI_FRAMEWORK_PRESENTATION_SUFFIX | "framework.presentation.uri.suffix"
public static final String | ID_URI_FRAMEWORK_SERVICE_PREFIX | "framework.service.uri.prefix"
public static final String | ID_URI_JSSP_SERVICE_PREFIX | "jssp.uri.prefix"

jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent
protected static final String ID_SECURITY_PASSWORD "filter-security-password"

jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent
protected static final String ID_PAGE_PATH "event-presentationpage-path"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし
A C D E F G H I J P S T W

A

AccessibleLinkFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent.
フレームワークの実行環境作成のためのフィルタの抽象実装です。
AccessibleLinkFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
AccountSecurityException - exception jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException.
アカウントセキュリティ例外です。
AccountSecurityException(String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
AccountSecurityException(String, String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
AccountSecurityException(String, String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
AccountSecurityException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
AccountSecurityFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent.
アカウントセキュリティ認証のためのフィルタの抽象実装です。
AccountSecurityFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
ActivityFrameworkFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent.
フレームワークの実行環境作成のためのフィルタの抽象実装です。
ActivityFrameworkFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent のメソッド
イベント処理メソッドです。
action(HTTPActionEventContext, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent のメソッド
イベント処理メソッドです。

C

certify(String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent のメソッド
ログインアカウント認証を行います。
certify(HttpServletRequest) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent のメソッド
認証します。
certify(String) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent のメソッド
ログイングループ認証を行います。
certify(HttpServletRequest) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent のメソッド
認証します。
certify(String, String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent のメソッド
ログインアカウント認証を行います。
certify(HttpServletRequest) - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent のメソッド
認証します。
certify(HttpServletRequest) - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent のメソッド
認証します。
createEventURL(HttpServletRequest, HttpServletResponse, String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController のメソッド
指定のＵＲＬに対して指定のクエリによるセッションを維持したリクエストを するためのＵＲＬを作成して返します。
createHTTPActionEvent(String) - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder のメソッド
指定の名前のイベントオブジェクトを作成します。
createHttpServletRequest(Properties, HttpServletRequest) - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController のメソッド
指定パラメータを優先的に処理するリクエストを作成します。

D

doChain() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを デフォルトのリクエストとレスポンスを利用して呼び出します。
doChain(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを 指定のリクエストとレスポンスを利用して呼び出します。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。
doFilter(HTTPActionEventContext, HttpServletRequest, HttpServletResponse, FilterHTTPActionEventChain) - class jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent のメソッド
イベントのフィルタ処理です。

E

execute(String, HTTPActionEventContext, Properties, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController のメソッド
イベントを実行します。

F

FilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent.
Application Runtime で実行されるイベントのための フィルターイベントの抽象実装です。
FilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent のコンストラクタ
指定のイベントをラップするためのフィルターを作成します。
FilterHTTPActionEventChain - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain.
FilterHTTPActionEventChain は、FilterHTTPActionEvent によって提供され、 FilterHTTPActionEvent へのフィルタリングされた要求のチェーンに対する ビューを提供します。
findClass(String) - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder のメソッド
指定の名称を持つクラスを返します。

G

GroupSecurityException - exception jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException.
グループセキュリティ例外です。
GroupSecurityException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
GroupSecurityException(String) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
GroupSecurityException(String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
GroupSecurityException(String, String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
GroupSecurityFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent.
グループセキュリティ認証のためのフィルタの抽象実装です。
GroupSecurityFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
getAcceptTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベント実行要求を受け付けたおよその時刻を返します。
getAccount(String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent のメソッド
指定のアカウント情報オブジェクトを返します。
getAccountId() - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException のメソッド
この例外が発生したアカウントＩＤです。
getCharacterEncoding() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
リクエストパラメータの文字エンコーディングを返します。
getClientContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求したクライアントに関する情報オブジェクトを返します。
getGroupId() - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException のメソッド
この例外が発生したグループＩＤです。
getHttpServletRequest() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
現在のイベントを要求したリクエストを返します。
getListenerClass() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
リスナーとなっている Servlet の実行時クラスを返します。
getListenerContext() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行要求を受け付けたリスナーに関する情報オブジェクトを返します。
getLoginGroup(String) - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent のメソッド
指定のログイングループの情報オブジェクトを返します。
getRemoteHostAddress() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのアドレスを返します。
getRemoteHostName() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
イベント実行要求をしたクライアントのホスト名を返します。
getRequest() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのリクエストを 返します。
getRequestTime() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext のメソッド
イベントの実行を要求した時刻を返します。
getResponse() - interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain のメソッド
チェーン内の次のフィルタまたはイベントを呼び出す時に利用する事を 目的としてイベントコントローラが用意したデフォルトのレスポンスを 返します。
getServletConfig() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext のメソッド
イベントを制御したリスナー となっている Servlet が初期化された時に Servlet コンテナから渡された設定オブジェクトが返されます。
getSystemProperty(String) - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの値を返します。
getSystemPropertyNameSet() - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext のメソッド
クライアントの Java 実行環境のシステムプロパティの名前のセットを返します。

H

HTTPActionEvent - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
HTTPActionEventBuilder - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder.
HTTPActionEvent 関連のビルダです。
HTTPActionEventBuilder() - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder のコンストラクタ
イベントビルダを新しく作成します。
HTTPActionEventClientContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext.
Application Runtime で実行されるイベントの実行を要求した クライアントに関する情報インターフェースです。
HTTPActionEventContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext.
Application Runtime で実行されるイベントに関する情報インターフェースです。
HTTPActionEventController - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController.
HTTPActionEvent 関連のビルダです。
HTTPActionEventController() - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController のコンストラクタ
イベントコントローラを新しく作成します。
HTTPActionEventException - exception jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException.
HTTPActionEvent に関するエラーを通知するための例外です。
HTTPActionEventException(String) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
HTTPActionEventException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
HTTPActionEventListenerContext - interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext.
Application Runtime でイベントの実行制御を行うリスナーに関する情報インターフェースです。

I

ID_PAGE_PATH - class jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent の static 変数
実行するプレゼンテーションページのパス
ID_SECURITY_ACCOUNT - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent の static 変数
ID_SECURITY_GROUP - class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent の static 変数
ID_SECURITY_PASSWORD - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent の static 変数
ID_SECURITY_SESSION_ACCOUNT - class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent の static 変数
ID_URI_FRAMEWORK_PRESENTATION_PREFIX - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の static 変数
プレゼンテーションフレームワークのＵＲＩの接頭部を取得するためのパラメータ名
ID_URI_FRAMEWORK_PRESENTATION_SEPARATOR - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の static 変数
プレゼンテーションフレームワークのＵＲＩのセパレータを取得するためのパラメータ名
ID_URI_FRAMEWORK_PRESENTATION_SUFFIX - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の static 変数
プレゼンテーションフレームワークのＵＲＩの接尾部を取得するためのパラメータ名
ID_URI_FRAMEWORK_SERVICE_PREFIX - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の static 変数
サービスフレームワークのＵＲＩの接頭部を取得するためのパラメータ名
ID_URI_JSSP_SERVICE_PREFIX - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController の static 変数
スクリプト開発モデルのＵＲＩの接頭部を取得するためのパラメータ名

J

jp.co.intra_mart.foundation.service.provider.application - package jp.co.intra_mart.foundation.service.provider.application
このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.application.core - package jp.co.intra_mart.foundation.service.provider.application.core

P

PasswordSecurityException - exception jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException.
パスワードセキュリティ例外です。
PasswordSecurityException(String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
PasswordSecurityException(String, String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
PasswordSecurityException(String, String, String) - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
PasswordSecurityException(String, String, String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
PasswordSecurityFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent.
アカウントセキュリティ認証のためのフィルタの抽象実装です。
PasswordSecurityFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
PresentationPageHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
PresentationPageHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent のコンストラクタ
唯一のコンストラクタ

S

SecurityException - exception jp.co.intra_mart.foundation.service.provider.application.core.SecurityException.
セキュリティ例外が発生した場合にスローされます。
SecurityException() - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
SecurityException(String) - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
SecurityException(String, Throwable) - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityException のコンストラクタ
セキュリティ例外オブジェクトを作成します。
SecurityFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent.
セキュリティ認証のためのフィルタの抽象実装です。
SecurityFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
ServiceFrameworkHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
ServiceFrameworkHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
SessionBuilderHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent.
HttpSession を確立するためのイベント。
SessionBuilderHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent のコンストラクタ
唯一のコンストラクタ

T

TemporaryFilterHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent.
ワンタイムセッションのためのフィルタの抽象実装です。
TemporaryFilterHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
toAbsoluteURL(HttpServletRequest, String) - class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController のメソッド
指定ＵＲＬを絶対形式に変換します。

W

WebApplicationHTTPActionEvent - class jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent.
Application Runtime で実行されるイベントのためのインターフェースです。
WebApplicationHTTPActionEvent() - class jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent のコンストラクタ
唯一のコンストラクタ
A C D E F G H I J P S T W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


imaca_provider 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (imaca_provider 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.service.provider.application
jp.co.intra_mart.foundation.service.provider.application.core


概要 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 imaca_provider API Specifications

パッケージ
jp.co.intra_mart.foundation.service.provider.application | このパッケージには、jp.co.intra_mart.foundation.service.client.application パッケージのクラスを利用した時の、サーバ側のインターフェースまたは実装が含まれています。
jp.co.intra_mart.foundation.service.provider.application.core |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.service.provider.application, jp.co.intra_mart.foundation.service.provider.application.core

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
      • class jp.co.intra_mart.foundation.service.provider.application.core.AccessibleLinkFilterHTTPActionEvent
      • class jp.co.intra_mart.foundation.service.provider.application.core.ActivityFrameworkFilterHTTPActionEvent
      • class jp.co.intra_mart.foundation.service.provider.application.core.SecurityFilterHTTPActionEvent
        • class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityFilterHTTPActionEvent
          • class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityFilterHTTPActionEvent
            • class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityFilterHTTPActionEvent
      • class jp.co.intra_mart.foundation.service.provider.application.core.TemporaryFilterHTTPActionEvent
    • class jp.co.intra_mart.foundation.service.client.application.core.HTTPActionEventQueryBuilder
      • class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventBuilder
        • class jp.co.intra_mart.foundation.service.provider.application.core.HTTPActionEventController
    • class jp.co.intra_mart.foundation.service.provider.application.core.PresentationPageHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.foundation.service.provider.application.core.ServiceFrameworkHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class jp.co.intra_mart.foundation.service.provider.application.core.SessionBuilderHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException
        • class jp.co.intra_mart.foundation.service.provider.application.core.SecurityException
          • class jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException
            • class jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException
              • class jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException
    • class jp.co.intra_mart.foundation.service.provider.application.core.WebApplicationHTTPActionEvent (implements jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent)

インタフェース階層

  • interface jp.co.intra_mart.foundation.service.provider.application.FilterHTTPActionEventChain
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEvent
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventClientContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventContext
  • interface jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventListenerContext
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(imaca_provider 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (imaca_provider 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.service.provider.application.core

クラス jp.co.intra_mart.foundation.service.provider.application.core.AccountSecurityException は GroupSecurityException を拡張し、Serializable を実装しています

直列化されたフィールド

accountId

String accountId

クラス jp.co.intra_mart.foundation.service.provider.application.core.GroupSecurityException は SecurityException を拡張し、Serializable を実装しています

直列化されたフィールド

groupId

String groupId

クラス jp.co.intra_mart.foundation.service.provider.application.core.PasswordSecurityException は AccountSecurityException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.service.provider.application.core.SecurityException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.service.provider.application

クラス jp.co.intra_mart.foundation.service.provider.application.HTTPActionEventException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController の使用

jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer の使用

jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.data (imart_seasar2 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.data
クラス
S2DataAccessController
S2DataContainer


jp.co.intra_mart.framework.extension.seasar.data (imart_seasar2 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.data

クラスの概要
S2DataAccessController | S2DataAccessControllerはSeasar2 と連携しdaoを生成します。
S2DataContainer | S2DataContainer は Seasar2 と連携するためのDataContainer実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.data クラス階層 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.base.data.DataAccessController
      • class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController
    • class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.framework.extension.seasar.data の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.data の使用

jp.co.intra_mart.framework.extension.seasar.data はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


S2DataAccessController (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.data
クラス S2DataAccessController

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.data.DataAccessController
        拡張 jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController
public class S2DataAccessController
extends jp.co.intra_mart.framework.base.data.DataAccessController

S2DataAccessControllerはSeasar2　と連携しdaoを生成します。
S2DataAccessControllerは要求されたdaoオブジェクトをS2Containerから取得し、未登録のdaoは自動的に登録します。
このときS2Containerから返されるdaoオブジェクトは全て新規に生成されたものです。

また、要求されたdaoがインターフェースの場合、S2Containarが保持するコンポーネントとみなし、S2Containarから直接コンポーネントを取得します。

導入されたバージョン:
6.0

コンストラクタの概要
S2DataAccessController(jp.co.intra_mart.framework.base.data.DataPropertyHandler handler)
データアクセスコントローラを生成します。
メソッドの概要
 Object getDAO(String application, String key, String connect)
DAOを取得します。
クラス jp.co.intra_mart.framework.base.data.DataAccessController から継承したメソッド
commit, getDataConnectors, getDataPropertyHandler, release, rollback
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2DataAccessController

public S2DataAccessController(jp.co.intra_mart.framework.base.data.DataPropertyHandler handler)
データアクセスコントローラを生成します。

パラメータ:
handler - データプロパティハンドラ
メソッドの詳細

getDAO

public Object getDAO(String application,
                     String key,
                     String connect)
              throws jp.co.intra_mart.framework.base.data.DataPropertyException,
                     jp.co.intra_mart.framework.base.data.DataConnectorException,
                     jp.co.intra_mart.framework.base.data.DAOException,
                     jp.co.intra_mart.framework.base.data.DataConnectException
DAOを取得します。 キーと接続情報で指定されたDAOを取得します。

指定されたDAOがインターフェースの場合S2Containerからコンポーネントを取得します。
この場合、diconファイルへの定義、dao.dicon等の設定が必要です。
S2Containerからコンポーネントを取得する場合接続情報を指定する必要はありません。 接続先データベースの解決はdiconファイルのデータソース設定に依存するため、 AutoDetectedDataSource等をデータソースに設定してください。

パラメータ:
application - アプリケーションID
key - DAOのキー
connect - 接続情報
戻り値:
DAOまたはS2Containerから取得したオブジェクト
例外:
jp.co.intra_mart.framework.base.data.DataPropertyException - プロパティの取得に失敗
jp.co.intra_mart.framework.base.data.DataConnectorException - データコネクタの取得に失敗
jp.co.intra_mart.framework.base.data.DAOException - DAOの取得に失敗
jp.co.intra_mart.framework.base.data.DataConnectException - データリソースとの接続に失敗
関連項目:
AutoDetectedDataSource, LoginGroupDataSource, SystemDataSource
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


S2DataContainer (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.data
クラス S2DataContainer

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer
すべての実装インタフェース:
jp.co.intra_mart.framework.base.data.container.DataContainer, jp.co.intra_mart.framework.system.container.IMContainer
public class S2DataContainer
extends Object
implements jp.co.intra_mart.framework.base.data.container.DataContainer

S2DataContainer　は　Seasar2　と連携するためのDataContainer実装です。
実際の連携はS2DataContainerが保持するS2DataAccessControllerが行います。

導入されたバージョン:
6.0
関連項目:
S2DataAccessController

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer から継承したフィールド
DATA_PROPERTY_HANDLER_KEY
コンストラクタの概要
S2DataContainer()
S2DataContainerを生成します。
メソッドの概要
jp.co.intra_mart.framework.base.data.DataAccessController | getDataAccessController() データアクセスコントローラを取得します。
jp.co.intra_mart.framework.base.data.DataPropertyHandler | getDataPropertyHandler() データプロパティハンドラを取得します。
void | init() DataContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2DataContainer

public S2DataContainer()
S2DataContainerを生成します。

メソッドの詳細

init

public void init()
          throws jp.co.intra_mart.framework.system.exception.IMContainerException
DataContainerを初期化します。

定義:
インタフェース jp.co.intra_mart.framework.system.container.IMContainer 内の init
例外:
jp.co.intra_mart.framework.system.exception.IMContainerException

getDataPropertyHandler

public jp.co.intra_mart.framework.base.data.DataPropertyHandler getDataPropertyHandler()
データプロパティハンドラを取得します。

定義:
インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer 内の getDataPropertyHandler
戻り値:
データプロパティハンドラ

getDataAccessController

public jp.co.intra_mart.framework.base.data.DataAccessController getDataAccessController()
データアクセスコントローラを取得します。

定義:
インタフェース jp.co.intra_mart.framework.base.data.container.DataContainer 内の getDataAccessController
戻り値:
データアクセスコントローラ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer の使用

jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory の使用

jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.event (imart_seasar2 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.event
クラス
S2EventContainer
S2EventListenerFactory


jp.co.intra_mart.framework.extension.seasar.event (imart_seasar2 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.event

クラスの概要
S2EventContainer | S2EventContainer は Seasar2 と連携しオブジェクトを生成します。
S2EventListenerFactory | S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。


jp.co.intra_mart.framework.extension.seasar.event クラス階層 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.event の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)


パッケージ jp.co.intra_mart.framework.extension.seasar.event の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.event の使用

jp.co.intra_mart.framework.extension.seasar.event はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


S2EventContainer (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.event
クラス S2EventContainer

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer
すべての実装インタフェース:
jp.co.intra_mart.framework.base.event.container.EventContainer, jp.co.intra_mart.framework.system.container.IMContainer
public class S2EventContainer
extends Object
implements jp.co.intra_mart.framework.base.event.container.EventContainer

S2EventContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2EventContainerは要求されたEventオブジェクトをS2Containerから取得し、未登録のEventオブジェクトは自動的に登録します。
このときS2Containerから返されるEventオブジェクトは全て新規に生成されたものです。

導入されたバージョン:
6.0

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer から継承したフィールド
EVENT_PROPERTY_HANDLER_KEY
コンストラクタの概要
S2EventContainer()
メソッドの概要
jp.co.intra_mart.framework.base.event.Event | createEvent(String application, String key)
jp.co.intra_mart.framework.base.event.EventResult | dispatch(jp.co.intra_mart.framework.base.event.Event event, boolean transaction)
jp.co.intra_mart.framework.base.event.EventPropertyHandler | getEventPropertyHandler()
void | init()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2EventContainer

public S2EventContainer()
メソッドの詳細

createEvent

public jp.co.intra_mart.framework.base.event.Event createEvent(String application,
                                                               String key)
                                                        throws jp.co.intra_mart.framework.base.event.EventPropertyException,
                                                               jp.co.intra_mart.framework.base.event.EventException
定義:
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer 内の createEvent
例外:
jp.co.intra_mart.framework.base.event.EventPropertyException
jp.co.intra_mart.framework.base.event.EventException

dispatch

public jp.co.intra_mart.framework.base.event.EventResult dispatch(jp.co.intra_mart.framework.base.event.Event event,
                                                                  boolean transaction)
                                                           throws jp.co.intra_mart.framework.base.event.EventException,
                                                                  jp.co.intra_mart.framework.system.exception.SystemException,
                                                                  jp.co.intra_mart.framework.system.exception.ApplicationException
定義:
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer 内の dispatch
例外:
jp.co.intra_mart.framework.base.event.EventException
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

getEventPropertyHandler

public jp.co.intra_mart.framework.base.event.EventPropertyHandler getEventPropertyHandler()
定義:
インタフェース jp.co.intra_mart.framework.base.event.container.EventContainer 内の getEventPropertyHandler

init

public void init()
          throws jp.co.intra_mart.framework.system.exception.IMContainerException
定義:
インタフェース jp.co.intra_mart.framework.system.container.IMContainer 内の init
例外:
jp.co.intra_mart.framework.system.exception.IMContainerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


S2EventListenerFactory (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.event
クラス S2EventListenerFactory

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory
すべての実装インタフェース:
jp.co.intra_mart.framework.base.event.EventListenerFactory
public class S2EventListenerFactory
extends Object
implements jp.co.intra_mart.framework.base.event.EventListenerFactory

S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。
EventListenerがS2Containerに登録されていない場合EventListenerを自動的に登録し、 他のコンポーネントとバインドされたEventListenerを返します。
このファクトリで指定できる初期パラメータは以下のとおりです。

パラメータ名 | 値
listener | 生成するイベントリスナ

導入されたバージョン:
6.0

コンストラクタの概要
S2EventListenerFactory()
S2EventListenerFactoryを新規に生成します。
メソッドの概要
jp.co.intra_mart.framework.base.event.EventListener | create(jp.co.intra_mart.framework.base.event.Event event) イベントリスナを生成します。
void | initParam(String name, String value) 初期パラメータを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2EventListenerFactory

public S2EventListenerFactory()
S2EventListenerFactoryを新規に生成します。

メソッドの詳細

create

public jp.co.intra_mart.framework.base.event.EventListener create(jp.co.intra_mart.framework.base.event.Event event)
                                                           throws jp.co.intra_mart.framework.base.event.EventListenerException
イベントリスナを生成します。 初期パラメータで指定されたクラスをイベントリスナとして生成します。 初期パラメータで指定されたクラスはStandardEventListenerを継承している必要があります。

定義:
インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory 内の create
パラメータ:
event - イベント
戻り値:
イベントリスナ
例外:
jp.co.intra_mart.framework.base.event.EventListenerException - イベントリスナの生成に失敗

initParam

public void initParam(String name,
                      String value)
               throws jp.co.intra_mart.framework.base.event.EventListenerException
初期パラメータを設定します。 複数のパラメータが設定される場合、その順番は保証されません。

定義:
インタフェース jp.co.intra_mart.framework.base.event.EventListenerFactory 内の initParam
パラメータ:
name - パラメータ名
value - パラメータの値
例外:
jp.co.intra_mart.framework.base.event.EventListenerException - パラメータの設定時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager の使用

jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction の使用

jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


LoggingTransactionManager (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.jta
クラス LoggingTransactionManager

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager
すべての実装インタフェース:
TransactionManager
public class LoggingTransactionManager
extends Object
implements TransactionManager

TransactionManagerをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。

・begin
・commit
・rollback

コンストラクタの概要
LoggingTransactionManager()
LoggingTransactionManager(TransactionManager tm)
TransactionManagerをラップし、新規にDBLogTransactionManagerを生成します。
メソッドの概要
void | begin() ラップしたTransactionManagerのbeginを呼び出します。
void | commit() ラップしたTransactionManagerのcommitを呼び出します。
int | getStatus() ラップしたTransactionManagerのgetStatusを呼び出します。
Transaction | getTransaction() ラップしたTransactionManagerのgetTransactionを呼び出します。
void | resume(Transaction transaction) ラップしたTransactionManagerのresumeを呼び出します。
void | rollback() ラップしたTransactionManagerのrollbackを呼び出します。
void | setRollbackOnly() ラップしたTransactionManagerのsetRollbackOnlyを呼び出します。
void | setTransactionTimeout(int time) ラップしたTransactionManagerのsetTransactionTimeoutを呼び出します。
Transaction | suspend() ラップしたTransactionManagerのsuspendを呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoggingTransactionManager

public LoggingTransactionManager()

LoggingTransactionManager

public LoggingTransactionManager(TransactionManager tm)
TransactionManagerをラップし、新規にDBLogTransactionManagerを生成します。

パラメータ:
tm - TransactionManagerのインスタンス
メソッドの詳細

begin

public void begin()
           throws NotSupportedException,
                  SystemException
ラップしたTransactionManagerのbeginを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース TransactionManager 内の begin
例外:
NotSupportedException
SystemException

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
ラップしたTransactionManagerのcommitを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース TransactionManager 内の commit
例外:
RollbackException
HeuristicMixedException
HeuristicRollbackException
SecurityException
IllegalStateException
SystemException

getStatus

public int getStatus()
              throws SystemException
ラップしたTransactionManagerのgetStatusを呼び出します。

定義:
インタフェース TransactionManager 内の getStatus
例外:
SystemException

getTransaction

public Transaction getTransaction()
                           throws SystemException
ラップしたTransactionManagerのgetTransactionを呼び出します。

定義:
インタフェース TransactionManager 内の getTransaction
例外:
SystemException

resume

public void resume(Transaction transaction)
            throws InvalidTransactionException,
                   IllegalStateException,
                   SystemException
ラップしたTransactionManagerのresumeを呼び出します。

定義:
インタフェース TransactionManager 内の resume
例外:
InvalidTransactionException
IllegalStateException
SystemException

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
ラップしたTransactionManagerのrollbackを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース TransactionManager 内の rollback
例外:
IllegalStateException
SecurityException
SystemException

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
ラップしたTransactionManagerのsetRollbackOnlyを呼び出します。

定義:
インタフェース TransactionManager 内の setRollbackOnly
例外:
IllegalStateException
SystemException

setTransactionTimeout

public void setTransactionTimeout(int time)
                           throws SystemException
ラップしたTransactionManagerのsetTransactionTimeoutを呼び出します。

定義:
インタフェース TransactionManager 内の setTransactionTimeout
例外:
SystemException

suspend

public Transaction suspend()
                    throws SystemException
ラップしたTransactionManagerのsuspendを呼び出します。

定義:
インタフェース TransactionManager 内の suspend
例外:
SystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LoggingUserTransaction (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.jta
クラス LoggingUserTransaction

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction
すべての実装インタフェース:
UserTransaction
public class LoggingUserTransaction
extends Object
implements UserTransaction

UserTransactionをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。

・begin
・commit
・rollback

コンストラクタの概要
LoggingUserTransaction()
LoggingUserTransaction(UserTransaction ut)
UserTransactionをラップし、新規にDBLogUserTransactionを生成します。
メソッドの概要
void | begin() ラップしたUserTransactionのbeginを呼び出します。
void | commit() ラップしたUserTransactionのcommitを呼び出します。
int | getStatus() ラップしたUserTransactionのgeｔStatusを呼び出します。
void | rollback() ラップしたUserTransactionのrollbackを呼び出します。
void | setRollbackOnly() ラップしたUserTransactionのsetRollbackOnlyを呼び出します。
void | setTransactionTimeout(int time) ラップしたUserTransactionのsetTransactionTimeoutを呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoggingUserTransaction

public LoggingUserTransaction()

LoggingUserTransaction

public LoggingUserTransaction(UserTransaction ut)
UserTransactionをラップし、新規にDBLogUserTransactionを生成します。

パラメータ:
ut - UserTransactionのインスタンス
メソッドの詳細

begin

public void begin()
           throws NotSupportedException,
                  SystemException
ラップしたUserTransactionのbeginを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース UserTransaction 内の begin
例外:
NotSupportedException
SystemException

commit

public void commit()
            throws RollbackException,
                   HeuristicMixedException,
                   HeuristicRollbackException,
                   SecurityException,
                   IllegalStateException,
                   SystemException
ラップしたUserTransactionのcommitを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース UserTransaction 内の commit
例外:
RollbackException
HeuristicMixedException
HeuristicRollbackException
SecurityException
IllegalStateException
SystemException

getStatus

public int getStatus()
              throws SystemException
ラップしたUserTransactionのgeｔStatusを呼び出します。

定義:
インタフェース UserTransaction 内の getStatus
例外:
SystemException

rollback

public void rollback()
              throws IllegalStateException,
                     SecurityException,
                     SystemException
ラップしたUserTransactionのrollbackを呼び出します。
呼出し後にデータベースログを出力します。

定義:
インタフェース UserTransaction 内の rollback
例外:
IllegalStateException
SecurityException
SystemException

setRollbackOnly

public void setRollbackOnly()
                     throws IllegalStateException,
                            SystemException
ラップしたUserTransactionのsetRollbackOnlyを呼び出します。

定義:
インタフェース UserTransaction 内の setRollbackOnly
例外:
IllegalStateException
SystemException

setTransactionTimeout

public void setTransactionTimeout(int time)
                           throws SystemException
ラップしたUserTransactionのsetTransactionTimeoutを呼び出します。

定義:
インタフェース UserTransaction 内の setTransactionTimeout
例外:
SystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.seasar.jta (imart_seasar2 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.jta
クラス
LoggingTransactionManager
LoggingUserTransaction


jp.co.intra_mart.framework.extension.seasar.jta (imart_seasar2 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.jta

クラスの概要
LoggingTransactionManager | TransactionManagerをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。
LoggingUserTransaction | UserTransactionをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。


jp.co.intra_mart.framework.extension.seasar.jta クラス階層 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.jta の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager (implements javax.transaction.TransactionManager)
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction (implements javax.transaction.UserTransaction)


パッケージ jp.co.intra_mart.framework.extension.seasar.jta の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.jta の使用

jp.co.intra_mart.framework.extension.seasar.jta はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer の使用

jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.service (imart_seasar2 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.service
クラス
S2ServiceContainer


jp.co.intra_mart.framework.extension.seasar.service (imart_seasar2 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.service

クラスの概要
S2ServiceContainer S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。


jp.co.intra_mart.framework.extension.seasar.service クラス階層 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)


パッケージ jp.co.intra_mart.framework.extension.seasar.service の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.service の使用

jp.co.intra_mart.framework.extension.seasar.service はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


S2ServiceContainer (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.service
クラス S2ServiceContainer

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer
すべての実装インタフェース:
jp.co.intra_mart.framework.system.container.IMContainer, jp.co.intra_mart.framework.base.service.container.ServiceContainer
public class S2ServiceContainer
extends Object
implements jp.co.intra_mart.framework.base.service.container.ServiceContainer

S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2ServiceContainerはオブジェクト生成時にS2Containerから取得します。 コンポーネントが登録されていない場合コンポーネントを自動的に登録し、 他のコンポーネントとバインドされたオブジェクトを返します。
自動的にS2Containerに登録されるオブジェクトは以下の通りです。

ServiceController
Transition

これらのオブジェクトは全て新規に生成されたものです。

導入されたバージョン:
6.0

フィールドの概要
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer から継承したフィールド
SERVICE_PROPERTY_HANDLER_KEY
コンストラクタの概要
S2ServiceContainer()
S2ServiceContainerを生成します。
メソッドの概要
jp.co.intra_mart.framework.base.service.ServiceController | getServiceController(String application, String service, Locale locale)
jp.co.intra_mart.framework.base.service.ServicePropertyHandler | getServicePropertyHandler()
jp.co.intra_mart.framework.base.service.Transition | getTransition(String application, String service, Locale locale)
void | init() ServiceContainerを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

S2ServiceContainer

public S2ServiceContainer()
S2ServiceContainerを生成します。

メソッドの詳細

init

public void init()
          throws jp.co.intra_mart.framework.system.exception.IMContainerException
ServiceContainerを初期化します。

定義:
インタフェース jp.co.intra_mart.framework.system.container.IMContainer 内の init
例外:
jp.co.intra_mart.framework.system.exception.IMContainerException

getServiceController

public jp.co.intra_mart.framework.base.service.ServiceController getServiceController(String application,
                                                                                String service,
                                                                                Locale locale)
                                                                               throws jp.co.intra_mart.framework.base.service.ServicePropertyException,
                                                                                jp.co.intra_mart.framework.base.service.ServiceControllerException
定義:
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer 内の getServiceController
例外:
jp.co.intra_mart.framework.base.service.ServicePropertyException
jp.co.intra_mart.framework.base.service.ServiceControllerException

getServicePropertyHandler

public jp.co.intra_mart.framework.base.service.ServicePropertyHandler getServicePropertyHandler()
定義:
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer 内の getServicePropertyHandler

getTransition

public jp.co.intra_mart.framework.base.service.Transition getTransition(String application,
                                                                        String service,
                                                                        Locale locale)
                                                                 throws jp.co.intra_mart.framework.base.service.ServicePropertyException,
                                                                        jp.co.intra_mart.framework.base.service.TransitionException
定義:
インタフェース jp.co.intra_mart.framework.base.service.container.ServiceContainer 内の getTransition
例外:
jp.co.intra_mart.framework.base.service.ServicePropertyException
jp.co.intra_mart.framework.base.service.TransitionException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource の使用

jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo の使用

jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の使用

jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil の使用

jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource の使用

LoginGroupDataSource を使用しているパッケージ
jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.seasar.util での LoginGroupDataSource の使用

jp.co.intra_mart.framework.extension.seasar.util での LoginGroupDataSource のサブクラス
 class AutoDetectedDataSource
セッション情報からログイングループに設定されているデータソースを取得しラップします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource の使用

jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AutoDetectedDataSource (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス AutoDetectedDataSource

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource
        拡張 jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource
すべての実装インタフェース:
DataSource
public class AutoDetectedDataSource
extends LoginGroupDataSource

セッション情報からログイングループに設定されているデータソースを取得しラップします。
この機能を利用するためには、S2ContainerFilterをweb.xmlに設定し、URLにマッピングする必要があります。

導入されたバージョン:
6.0

コンストラクタの概要
protected | AutoDetectedDataSource()
 | AutoDetectedDataSource(InitialContext ctx) AutoDetectedDataSourceを新規に生成します。
メソッドの概要
protected DataSource | findLoginGroupDataSource() セッション情報からログイングループに設定されているデータソースを取得します。
String | getLoginGroupId() ログイングループIDを取得します。
クラス jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource から継承したメソッド
getConnection, getConnection, getLoginTimeout, getLogWriter, setLoginTimeout, setLogWriter
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AutoDetectedDataSource

protected AutoDetectedDataSource()

AutoDetectedDataSource

public AutoDetectedDataSource(InitialContext ctx)
AutoDetectedDataSourceを新規に生成します。

パラメータ:
ctx - 初期コンテキスト
メソッドの詳細

findLoginGroupDataSource

protected DataSource findLoginGroupDataSource()
                                       throws jp.co.intra_mart.framework.base.data.DataAccessException
セッション情報からログイングループに設定されているデータソースを取得します。

オーバーライド:
クラス LoginGroupDataSource 内の findLoginGroupDataSource
戻り値:
データソース
例外:
jp.co.intra_mart.framework.base.data.DataAccessException - データソース取得時にエラーが発生

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

オーバーライド:
クラス LoginGroupDataSource 内の getLoginGroupId
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AutoDetectedUserInfo (imart_seasar2 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス AutoDetectedUserInfo

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.util.UserInfoWrapper
        拡張 jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo
すべての実装インタフェース:
Serializable, jp.co.intra_mart.framework.base.util.UserInfo
public class AutoDetectedUserInfo
extends jp.co.intra_mart.framework.base.util.UserInfoWrapper

セッションからログイン情報を取得するUserInfoのラッパークラスです。 この機能を利用するためには、S2ContainerFilterをweb.xmlに設定し、URLにマッピングする必要があります。

導入されたバージョン:
6.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper から継承したフィールド
BLANK_USER_INFO
コンストラクタの概要
AutoDetectedUserInfo()
AutoDetectedUserInfoを新規に生成します。
メソッドの概要
protected  jp.co.intra_mart.framework.base.util.UserInfo getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。
クラス jp.co.intra_mart.framework.base.util.UserInfoWrapper から継承したメソッド
getClientType, getColorPatternID, getEncoding, getLocale, getLoginGroupID, getLoginTime, getLoginType, getUserID, setRealUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AutoDetectedUserInfo

public AutoDetectedUserInfo()
AutoDetectedUserInfoを新規に生成します。

メソッドの詳細

getRealUserInfo

protected jp.co.intra_mart.framework.base.util.UserInfo getRealUserInfo()
このオブジェクトがラップしているUserInfoの実装を返します。

戻り値:
UserInfoオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ComponentNameCreator (imart_seasar2 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス ComponentNameCreator

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator
public class ComponentNameCreator
extends Object

導入されたバージョン:
6.0

フィールドの概要
static String | CONTROLLER_SUFFIX
static String | DAO_SUFFIX
static String | EVENT_LISTENER_SUFFIX
static String | EVENT_OBJECT_SUFFIX
static String | TRANSITION_SUFFIX
コンストラクタの概要
ComponentNameCreator()
メソッドの概要
static String | createControllerName(String application, String service) サービスコントローラのコンポーネント名を返します。
static String | createDaoName(String application, String daoKey) daoのコンポーネント名を返します。
static String | createEventListenerName(String application, String eventKey) イベントリスナのコンポーネント名を返します。
static String | createEventName(String application, String eventKey) イベントオブジェクトのコンポーネント名を返します。
static String | createTransitionName(String application, String service) トランジションのコンポーネント名を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONTROLLER_SUFFIX

public static String CONTROLLER_SUFFIX

TRANSITION_SUFFIX

public static String TRANSITION_SUFFIX

EVENT_OBJECT_SUFFIX

public static String EVENT_OBJECT_SUFFIX

EVENT_LISTENER_SUFFIX

public static String EVENT_LISTENER_SUFFIX

DAO_SUFFIX

public static String DAO_SUFFIX
コンストラクタの詳細

ComponentNameCreator

public ComponentNameCreator()
メソッドの詳細

createControllerName

public static String createControllerName(String application,
                                          String service)
サービスコントローラのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
コンポーネント名

createTransitionName

public static String createTransitionName(String application,
                                          String service)
トランジションのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
service - サービスID
戻り値:
コンポーネント名

createEventName

public static String createEventName(String application,
                                     String eventKey)
イベントオブジェクトのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
eventKey - イベントキー
戻り値:
コンポーネント名

createEventListenerName

public static String createEventListenerName(String application,
                                             String eventKey)
イベントリスナのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
eventKey - イベントキー
戻り値:
コンポーネント名

createDaoName

public static String createDaoName(String application,
                                   String daoKey)
daoのコンポーネント名を返します。

パラメータ:
application - アプリケーションID
daoKey - daoキー
戻り値:
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ComponentUtil (imart_seasar2 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス ComponentUtil

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil
public class ComponentUtil
extends Object

イントラマート、Seasar2連携のユーティリティクラスです。

導入されたバージョン:
6.0

メソッドの概要
static void register(org.seasar.framework.container.S2Container container, Class component, String componentKey, org.seasar.framework.container.InstanceDef instanceType)
指定したキーでS2Containerにコンポーネントを登録します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

register

public static void register(org.seasar.framework.container.S2Container container,
                            Class component,
                            String componentKey,
                            org.seasar.framework.container.InstanceDef instanceType)
指定したキーでS2Containerにコンポーネントを登録します。 既にキーが登録されている場合は登録しません。

パラメータ:
container - S2Container
component - S2Containerに登録するクラス
componentKey - コンポーネントキー
instanceType - インスタンス属性
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LoginGroupDataSource (imart_seasar2 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス LoginGroupDataSource

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource
すべての実装インタフェース:
DataSource
直系の既知のサブクラス:
AutoDetectedDataSource
public class LoginGroupDataSource
extends Object
implements DataSource

ログイングループに設定されたデータソースをラップします。 このデータソースの動作はラップされたデータソースと同じです。

導入されたバージョン:
6.0

コンストラクタの概要
protected | LoginGroupDataSource()
 | LoginGroupDataSource(InitialContext ctx, String loginGroupId) 指定したログイングループに設定されたデータソースをラップします。
メソッドの概要
protected DataSource | findLoginGroupDataSource() このオブジェクトがラップするデータソースを返します。
Connection | getConnection() ラップされたデータソースのgetConnection()を呼び出します。
Connection | getConnection(String username, String password) ラップされたデータソースのgetConnection(String, String)を呼び出します。
String | getLoginGroupId() ログイングループIDを取得します。
int | getLoginTimeout() ラップされたデータソースのgetLoginTimeout()を呼び出します。
PrintWriter | getLogWriter() ラップされたデータソースのgetLogWriter()を呼び出します。
void | setLoginTimeout(int seconds) ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
void | setLogWriter(PrintWriter out) ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LoginGroupDataSource

protected LoginGroupDataSource()

LoginGroupDataSource

public LoginGroupDataSource(InitialContext ctx,
                            String loginGroupId)
指定したログイングループに設定されたデータソースをラップします。

パラメータ:
ctx - 初期コンテキスト
loginGroupId - ログイングループID
メソッドの詳細

getConnection

public Connection getConnection()
                         throws SQLException
ラップされたデータソースのgetConnection()を呼び出します。

定義:
インタフェース DataSource 内の getConnection
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getConnection

public Connection getConnection(String username,
                                String password)
                         throws SQLException
ラップされたデータソースのgetConnection(String, String)を呼び出します。

定義:
インタフェース DataSource 内の getConnection
パラメータ:
username - データベースユーザ
password - ユーザのパスワード
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getLogWriter

public PrintWriter getLogWriter()
                         throws SQLException
ラップされたデータソースのgetLogWriter()を呼び出します。

定義:
インタフェース DataSource 内の getLogWriter
戻り値:
データソースのログライター
例外:
SQLException - データベースエラーが発生

getLoginTimeout

public int getLoginTimeout()
                    throws SQLException
ラップされたデータソースのgetLoginTimeout()を呼び出します。

定義:
インタフェース DataSource 内の getLoginTimeout
戻り値:
データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

setLogWriter

public void setLogWriter(PrintWriter out)
                  throws SQLException
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。

定義:
インタフェース DataSource 内の setLogWriter
パラメータ:
out - 新しいログライター
例外:
SQLException - データベースエラーが発生

setLoginTimeout

public void setLoginTimeout(int seconds)
                     throws SQLException
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。

定義:
インタフェース DataSource 内の setLoginTimeout
パラメータ:
seconds - データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

findLoginGroupDataSource

protected DataSource findLoginGroupDataSource()
                                       throws jp.co.intra_mart.framework.base.data.DataAccessException
このオブジェクトがラップするデータソースを返します。

戻り値:
データソース
例外:
jp.co.intra_mart.framework.base.data.DataAccessException - データベースエラーが発生

getLoginGroupId

public String getLoginGroupId()
ログイングループIDを取得します。

戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.seasar.util (imart_seasar2 6.1.14 API)

 jp.co.intra_mart.framework.extension.seasar.util
クラス
AutoDetectedDataSource
AutoDetectedUserInfo
ComponentNameCreator
ComponentUtil
LoginGroupDataSource
SystemDataSource


jp.co.intra_mart.framework.extension.seasar.util (imart_seasar2 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.util

クラスの概要
AutoDetectedDataSource | セッション情報からログイングループに設定されているデータソースを取得しラップします。
AutoDetectedUserInfo | セッションからログイン情報を取得するUserInfoのラッパークラスです。
ComponentNameCreator |
ComponentUtil | イントラマート、Seasar2連携のユーティリティクラスです。
LoginGroupDataSource | ログイングループに設定されたデータソースをラップします。
SystemDataSource | システムに設定されたデータソースをラップします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.framework.extension.seasar.util クラス階層 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.seasar.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil
    • class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource (implements javax.sql.DataSource)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource
    • class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource (implements javax.sql.DataSource)
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.framework.extension.seasar.util の使用 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.seasar.util の使用

jp.co.intra_mart.framework.extension.seasar.util を使用しているパッケージ
jp.co.intra_mart.framework.extension.seasar.util

jp.co.intra_mart.framework.extension.seasar.util により使用される jp.co.intra_mart.framework.extension.seasar.util のクラス
LoginGroupDataSource
ログイングループに設定されたデータソースをラップします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SystemDataSource (imart_seasar2 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.seasar.util
クラス SystemDataSource

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource
すべての実装インタフェース:
DataSource
public class SystemDataSource
extends Object
implements DataSource

システムに設定されたデータソースをラップします。 このデータソースの動作はラップされたデータソースと同じです。

導入されたバージョン:
6.0

コンストラクタの概要
protected | SystemDataSource()
 | SystemDataSource(InitialContext ctx, String connectId) 指定した識別子に設定されたデータソースをラップします。
メソッドの概要
String | getConnectId() システムデータソースの識別子を取得します。
Connection | getConnection() ラップされたデータソースのgetConnection()を呼び出します。
Connection | getConnection(String username, String password) ラップされたデータソースのgetConnection(String, String)を呼び出します。
int | getLoginTimeout() ラップされたデータソースのgetLoginTimeout()を呼び出します。
PrintWriter | getLogWriter() ラップされたデータソースのgetLogWriter()を呼び出します。
void | setLoginTimeout(int seconds) ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
void | setLogWriter(PrintWriter out) ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SystemDataSource

protected SystemDataSource()

SystemDataSource

public SystemDataSource(InitialContext ctx,
                        String connectId)
指定した識別子に設定されたデータソースをラップします。

パラメータ:
ctx - 初期コンテキスト
メソッドの詳細

getConnection

public Connection getConnection()
                         throws SQLException
ラップされたデータソースのgetConnection()を呼び出します。

定義:
インタフェース DataSource 内の getConnection
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getConnection

public Connection getConnection(String username,
                                String password)
                         throws SQLException
ラップされたデータソースのgetConnection(String, String)を呼び出します。

定義:
インタフェース DataSource 内の getConnection
パラメータ:
username - データベースユーザ
password - ユーザのパスワード
戻り値:
コネクション
例外:
SQLException - データベースエラーが発生

getLogWriter

public PrintWriter getLogWriter()
                         throws SQLException
ラップされたデータソースのgetLogWriter()を呼び出します。

定義:
インタフェース DataSource 内の getLogWriter
戻り値:
データソースのログライター
例外:
SQLException - データベースエラーが発生

getLoginTimeout

public int getLoginTimeout()
                    throws SQLException
ラップされたデータソースのgetLoginTimeout()を呼び出します。

定義:
インタフェース DataSource 内の getLoginTimeout
戻り値:
データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

setLogWriter

public void setLogWriter(PrintWriter out)
                  throws SQLException
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。

定義:
インタフェース DataSource 内の setLogWriter
パラメータ:
out - 新しいログライター
例外:
SQLException - データベースエラーが発生

setLoginTimeout

public void setLoginTimeout(int seconds)
                     throws SQLException
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。

定義:
インタフェース DataSource 内の setLoginTimeout
パラメータ:
seconds - データソースのログイン制限時間
例外:
SQLException - データベースエラーが発生

getConnectId

public String getConnectId()
システムデータソースの識別子を取得します。

戻り値:
システムデータソースの識別子
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (imart_seasar2 6.1.14 API)

 すべてのクラス
AutoDetectedDataSource
AutoDetectedUserInfo
ComponentNameCreator
ComponentUtil
LoggingTransactionManager
LoggingUserTransaction
LoginGroupDataSource
S2DataAccessController
S2DataContainer
S2EventContainer
S2EventListenerFactory
S2ServiceContainer
SystemDataSource


定数フィールド値 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし
A B C D E F G I J L R S T

A

AutoDetectedDataSource - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource.
セッション情報からログイングループに設定されているデータソースを取得しラップします。
AutoDetectedDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のコンストラクタ
AutoDetectedDataSource(InitialContext) - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のコンストラクタ
AutoDetectedDataSourceを新規に生成します。
AutoDetectedUserInfo - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo.
セッションからログイン情報を取得するUserInfoのラッパークラスです。
AutoDetectedUserInfo() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo のコンストラクタ
AutoDetectedUserInfoを新規に生成します。

B

begin() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのbeginを呼び出します。
begin() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのbeginを呼び出します。

C

CONTROLLER_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数
ComponentNameCreator - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator.
ComponentNameCreator() - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator のコンストラクタ
ComponentUtil - class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil.
イントラマート、Seasar2連携のユーティリティクラスです。
commit() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのcommitを呼び出します。
commit() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのcommitを呼び出します。
create(Event) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory のメソッド
イベントリスナを生成します。
createControllerName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
サービスコントローラのコンポーネント名を返します。
createDaoName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
daoのコンポーネント名を返します。
createEvent(String, String) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド
createEventListenerName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
イベントリスナのコンポーネント名を返します。
createEventName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
イベントオブジェクトのコンポーネント名を返します。
createTransitionName(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static メソッド
トランジションのコンポーネント名を返します。

D

DAO_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数
dispatch(Event, boolean) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド

E

EVENT_LISTENER_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数
EVENT_OBJECT_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数

F

findLoginGroupDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のメソッド
セッション情報からログイングループに設定されているデータソースを取得します。
findLoginGroupDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
このオブジェクトがラップするデータソースを返します。

G

getConnectId() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
システムデータソースの識別子を取得します。
getConnection() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetConnection()を呼び出します。
getConnection(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetConnection(String, String)を呼び出します。
getConnection() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetConnection()を呼び出します。
getConnection(String, String) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetConnection(String, String)を呼び出します。
getDAO(String, String, String) - class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController のメソッド
DAOを取得します。
getDataAccessController() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のメソッド
データアクセスコントローラを取得します。
getDataPropertyHandler() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のメソッド
データプロパティハンドラを取得します。
getEventPropertyHandler() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド
getLogWriter() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetLogWriter()を呼び出します。
getLogWriter() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetLogWriter()を呼び出します。
getLoginGroupId() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource のメソッド
ログイングループIDを取得します。
getLoginGroupId() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ログイングループIDを取得します。
getLoginTimeout() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのgetLoginTimeout()を呼び出します。
getLoginTimeout() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのgetLoginTimeout()を呼び出します。
getRealUserInfo() - class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo のメソッド
このオブジェクトがラップしているUserInfoの実装を返します。
getServiceController(String, String, Locale) - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド
getServicePropertyHandler() - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド
getStatus() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのgetStatusを呼び出します。
getStatus() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのgeｔStatusを呼び出します。
getTransaction() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのgetTransactionを呼び出します。
getTransition(String, String, Locale) - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド

I

init() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のメソッド
DataContainerを初期化します。
init() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のメソッド
init() - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のメソッド
ServiceContainerを初期化します。
initParam(String, String) - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory のメソッド
初期パラメータを設定します。

J

jp.co.intra_mart.framework.extension.seasar.data - package jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event - package jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.jta - package jp.co.intra_mart.framework.extension.seasar.jta
jp.co.intra_mart.framework.extension.seasar.service - package jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.extension.seasar.util - package jp.co.intra_mart.framework.extension.seasar.util

L

LoggingTransactionManager - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager.
TransactionManagerをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。
LoggingTransactionManager() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のコンストラクタ
LoggingTransactionManager(TransactionManager) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のコンストラクタ
TransactionManagerをラップし、新規にDBLogTransactionManagerを生成します。
LoggingUserTransaction - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction.
UserTransactionをラップし、以下のメソッドの呼び出し時にintra-mart データベースログを出力します。
LoggingUserTransaction() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のコンストラクタ
LoggingUserTransaction(UserTransaction) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のコンストラクタ
UserTransactionをラップし、新規にDBLogUserTransactionを生成します。
LoginGroupDataSource - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource.
ログイングループに設定されたデータソースをラップします。
LoginGroupDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のコンストラクタ
LoginGroupDataSource(InitialContext, String) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のコンストラクタ
指定したログイングループに設定されたデータソースをラップします。

R

register(S2Container, Class, String, InstanceDef) - class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil の static メソッド
指定したキーでS2Containerにコンポーネントを登録します。
resume(Transaction) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのresumeを呼び出します。
rollback() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのrollbackを呼び出します。
rollback() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのrollbackを呼び出します。

S

S2DataAccessController - class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController.
S2DataAccessControllerはSeasar2　と連携しdaoを生成します。
S2DataAccessController(DataPropertyHandler) - class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController のコンストラクタ
データアクセスコントローラを生成します。
S2DataContainer - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer.
S2DataContainer　は　Seasar2　と連携するためのDataContainer実装です。
S2DataContainer() - class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer のコンストラクタ
S2DataContainerを生成します。
S2EventContainer - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer.
S2EventContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2EventContainer() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer のコンストラクタ
S2EventListenerFactory - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory.
S2EventListenerFactoryはEventListener生成時にS2Containerから取得します。
S2EventListenerFactory() - class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory のコンストラクタ
S2EventListenerFactoryを新規に生成します。
S2ServiceContainer - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer.
S2ServiceContainer　は　Seasar2　と連携しオブジェクトを生成します。
S2ServiceContainer() - class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer のコンストラクタ
S2ServiceContainerを生成します。
SystemDataSource - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource.
システムに設定されたデータソースをラップします。
SystemDataSource() - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のコンストラクタ
SystemDataSource(InitialContext, String) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のコンストラクタ
指定した識別子に設定されたデータソースをラップします。
setLogWriter(PrintWriter) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
setLogWriter(PrintWriter) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのsetLogWriter(PrintWriter)を呼び出します。
setLoginTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource のメソッド
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
setLoginTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource のメソッド
ラップされたデータソースのsetLoginTimeout(int)を呼び出します。
setRollbackOnly() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのsetRollbackOnlyを呼び出します。
setRollbackOnly() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのsetRollbackOnlyを呼び出します。
setTransactionTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのsetTransactionTimeoutを呼び出します。
setTransactionTimeout(int) - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction のメソッド
ラップしたUserTransactionのsetTransactionTimeoutを呼び出します。
suspend() - class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager のメソッド
ラップしたTransactionManagerのsuspendを呼び出します。

T

TRANSITION_SUFFIX - class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator の static 変数
A B C D E F G I J L R S T
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


imart_seasar2 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (imart_seasar2 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.jta
jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.extension.seasar.util


概要 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 imart_seasar2 API Specifications

パッケージ
jp.co.intra_mart.framework.extension.seasar.data
jp.co.intra_mart.framework.extension.seasar.event
jp.co.intra_mart.framework.extension.seasar.jta
jp.co.intra_mart.framework.extension.seasar.service
jp.co.intra_mart.framework.extension.seasar.util

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.framework.extension.seasar.data, jp.co.intra_mart.framework.extension.seasar.event, jp.co.intra_mart.framework.extension.seasar.jta, jp.co.intra_mart.framework.extension.seasar.service, jp.co.intra_mart.framework.extension.seasar.util

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentNameCreator
    • class jp.co.intra_mart.framework.extension.seasar.util.ComponentUtil
    • class jp.co.intra_mart.framework.base.data.DataAccessController
      • class jp.co.intra_mart.framework.extension.seasar.data.S2DataAccessController
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingTransactionManager (implements javax.transaction.TransactionManager)
    • class jp.co.intra_mart.framework.extension.seasar.jta.LoggingUserTransaction (implements javax.transaction.UserTransaction)
    • class jp.co.intra_mart.framework.extension.seasar.util.LoginGroupDataSource (implements javax.sql.DataSource)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedDataSource
    • class jp.co.intra_mart.framework.extension.seasar.data.S2DataContainer (implements jp.co.intra_mart.framework.base.data.container.DataContainer)
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventContainer (implements jp.co.intra_mart.framework.base.event.container.EventContainer)
    • class jp.co.intra_mart.framework.extension.seasar.event.S2EventListenerFactory (implements jp.co.intra_mart.framework.base.event.EventListenerFactory)
    • class jp.co.intra_mart.framework.extension.seasar.service.S2ServiceContainer (implements jp.co.intra_mart.framework.base.service.container.ServiceContainer)
    • class jp.co.intra_mart.framework.extension.seasar.util.SystemDataSource (implements javax.sql.DataSource)
    • class jp.co.intra_mart.framework.base.util.UserInfoWrapper (implements jp.co.intra_mart.framework.base.util.UserInfo)
      • class jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(imart_seasar2 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (imart_seasar2 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.framework.extension.seasar.util

クラス jp.co.intra_mart.framework.extension.seasar.util.AutoDetectedUserInfo は jp.co.intra_mart.framework.base.util.UserInfoWrapper を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.common.util.ServiceUtils の使用

jp.co.intra_mart.framework.extension.common.util.ServiceUtils はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.framework.extension.common.util (imart_struts 6.1.14 API)

 jp.co.intra_mart.framework.extension.common.util
クラス
ServiceUtils


jp.co.intra_mart.framework.extension.common.util (imart_struts 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util

im-J2EE Frameworkに連携するためのユーティリティです。

参照:
説明

クラスの概要
ServiceUtils im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

パッケージ jp.co.intra_mart.framework.extension.common.util の説明

im-J2EE Frameworkに連携するためのユーティリティです。 im-J2EE Framework以外のコンポーネントからim-J2EE Frameworkにアクセスできます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.framework.extension.common.util クラス階層 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.common.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.framework.extension.common.util の使用 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.common.util の使用

jp.co.intra_mart.framework.extension.common.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ServiceUtils (imart_struts 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.common.util
クラス ServiceUtils

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.common.util.ServiceUtils
public class ServiceUtils
extends Object

im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。

コンストラクタの概要
ServiceUtils()
メソッドの概要
static jp.co.intra_mart.framework.base.event.Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
static jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
イベントを実行します。
static String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
static jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ServiceUtils

public ServiceUtils()
メソッドの詳細

getLoginUserID

public static String getLoginUserID(HttpServletRequest request,
                                    HttpServletResponse response)
                             throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

public static String getLoginGroupID(HttpServletRequest request,
                                     HttpServletResponse response)
                              throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログイングループID取得時に例外が発生

getUserInfo

public static jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request,
                                                                        HttpServletResponse response)
                                                                 throws jp.co.intra_mart.framework.system.exception.SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ユーザ情報取得時に例外が発生

createEvent

public static jp.co.intra_mart.framework.base.event.Event createEvent(String application,
                                                                      String key,
                                                                      HttpServletRequest request,
                                                                      HttpServletResponse response)
                                                               throws jp.co.intra_mart.framework.system.exception.SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
jp.co.intra_mart.framework.system.exception.SystemException - イベント取得時に例外が発生

dispatchEvent

public static jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
                                                                       throws jp.co.intra_mart.framework.base.event.EventManagerException,
                                                                              jp.co.intra_mart.framework.base.event.EventException,
                                                                              jp.co.intra_mart.framework.system.exception.ApplicationException,
                                                                              jp.co.intra_mart.framework.system.exception.SystemException
イベントを実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
jp.co.intra_mart.framework.base.event.EventManagerException - イベントマネージャの生成に失敗
jp.co.intra_mart.framework.base.event.EventException - イベント処理実行に失敗
jp.co.intra_mart.framework.system.exception.ApplicationException - イベント処理時にアプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - イベント処理時にシステム例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.IntramartAction の使用

jp.co.intra_mart.framework.extension.struts.action.IntramartAction はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter の使用

jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IntramartAction (imart_struts 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス IntramartAction

java.lang.Object
    拡張 org.apache.struts.action.Action
        拡張 jp.co.intra_mart.framework.extension.struts.action.IntramartAction
public class IntramartAction
extends org.apache.struts.action.Action

jp.co.intra_mart.framework.base.service.ServiceControllerAdapterと似たメソッドを持つActionクラスです。 いくつかのメソッドはHttpServletRequestと HttpServletResponseを必要とする点が jp.co.intra_mart.framework.base.service.ServiceControllerAdapter と異なります。

関連項目:
jp.co.intra_mart.framework.base.service.ServiceControllerAdapter

フィールドの概要
クラス org.apache.struts.action.Action から継承したフィールド
servlet
コンストラクタの概要
IntramartAction()
メソッドの概要
protected  jp.co.intra_mart.framework.base.event.Event createEvent(String application, String key, HttpServletRequest request, HttpServletResponse response)
アプリケーションIDとキーに対応するイベントを取得します。
protected  jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
イベント処理を実行します。
protected  String getLoginGroupID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  String getLoginUserID(HttpServletRequest request, HttpServletResponse response)
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
protected  jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request, HttpServletResponse response)
ユーザ情報を取得します。
クラス org.apache.struts.action.Action から継承したメソッド
addErrors, addMessages, execute, execute, generateToken, getErrors, getLocale, getMessages, getResources, getResources, getServlet, isCancelled, isTokenValid, isTokenValid, resetToken, saveErrors, saveErrors, saveMessages, saveMessages, saveToken, setLocale, setServlet
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IntramartAction

public IntramartAction()
メソッドの詳細

getLoginUserID

protected String getLoginUserID(HttpServletRequest request,
                                HttpServletResponse response)
                         throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログインユーザIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログインユーザID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログインユーザID取得時に例外が発生

getLoginGroupID

protected String getLoginGroupID(HttpServletRequest request,
                                 HttpServletResponse response)
                          throws jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。

ログイングループIDを取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ログイングループID
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ログイングループID取得時に例外が発生

getUserInfo

protected jp.co.intra_mart.framework.base.util.UserInfo getUserInfo(HttpServletRequest request,
                                                                    HttpServletResponse response)
                                                             throws jp.co.intra_mart.framework.system.exception.SystemException
ユーザ情報を取得します。

パラメータ:
request - リクエスト
response - レスポンス
戻り値:
ユーザ情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - ユーザ情報取得時に例外が発生

createEvent

protected jp.co.intra_mart.framework.base.event.Event createEvent(String application,
                                                                  String key,
                                                                  HttpServletRequest request,
                                                                  HttpServletResponse response)
                                                           throws jp.co.intra_mart.framework.system.exception.SystemException
アプリケーションIDとキーに対応するイベントを取得します。 イベントにはログイン時のログイングループIDが自動的に登録されます。

パラメータ:
application - アプリケーションID
key - キー
request - リクエスト
response - レスポンス
戻り値:
イベント
例外:
jp.co.intra_mart.framework.system.exception.SystemException - イベント取得時に例外が発生

dispatchEvent

protected jp.co.intra_mart.framework.base.event.EventResult dispatchEvent(jp.co.intra_mart.framework.base.event.Event event)
                                                                   throws jp.co.intra_mart.framework.base.event.EventManagerException,
                                                                          jp.co.intra_mart.framework.base.event.EventException,
                                                                          jp.co.intra_mart.framework.system.exception.SystemException,
                                                                          jp.co.intra_mart.framework.system.exception.ApplicationException
イベント処理を実行します。

パラメータ:
event - イベント
戻り値:
イベント処理結果
例外:
jp.co.intra_mart.framework.base.event.EventManagerException - イベントマネージャの生成に失敗
jp.co.intra_mart.framework.base.event.EventException - イベント処理実行に失敗
jp.co.intra_mart.framework.system.exception.SystemException - イベント処理時にシステム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - イベント処理時にアプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.framework.extension.struts.action (imart_struts 6.1.14 API)

 jp.co.intra_mart.framework.extension.struts.action
クラス
IntramartAction
StrutsConnectFilter


jp.co.intra_mart.framework.extension.struts.action (imart_struts 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

参照:
説明

クラスの概要
IntramartAction | jp.co.intra_mart.framework.base.service.ServiceControllerAdapterと似たメソッドを持つActionクラスです。
StrutsConnectFilter | intra-martのメニューからStrutsに接続するフィルターです。

パッケージ jp.co.intra_mart.framework.extension.struts.action の説明

im-J2EE FrameworkとStrutsを連携するためのユーティリティです。 Strutsからim-J2EE Frameworkにアクセスできます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.framework.extension.struts.action クラス階層 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.framework.extension.struts.action の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.framework.extension.struts.action の使用 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.framework.extension.struts.action の使用

jp.co.intra_mart.framework.extension.struts.action はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StrutsConnectFilter (imart_struts 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.framework.extension.struts.action
クラス StrutsConnectFilter

java.lang.Object
    拡張 jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter
すべての実装インタフェース:
Filter
public class StrutsConnectFilter
extends Object
implements Filter

intra-martのメニューからStrutsに接続するフィルターです。 Struts用のロケールをセッションに登録します。

コンストラクタの概要
StrutsConnectFilter()
メソッドの概要
void | destroy() フィルタを破棄します。
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) ロケールをセッションに登録し、次のフィルタに処理を移します。
void | init(FilterConfig filterConfig) フィルタを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StrutsConnectFilter

public StrutsConnectFilter()
メソッドの詳細

init

public void init(FilterConfig filterConfig)
          throws ServletException
フィルタを初期化します。

定義:
インタフェース Filter 内の init
パラメータ:
filterConfig - FilterConfig
例外:
ServletException - フィルタ内で例外が発生

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws IOException,
                     ServletException
ロケールをセッションに登録し、次のフィルタに処理を移します。

定義:
インタフェース Filter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生

destroy

public void destroy()
フィルタを破棄します。

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (imart_struts 6.1.14 API)

 すべてのクラス
IntramartAction
ServiceUtils
StrutsConnectFilter


定数フィールド値 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないメソッド
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginGroupID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.common.util.ServiceUtils.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。
jp.co.intra_mart.framework.extension.struts.action.IntramartAction.getLoginUserID(HttpServletRequest, HttpServletResponse)
このメソッドではなく#getUserInfo()を使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし
C D G I J S

C

createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
アプリケーションIDとキーに対応するイベントを取得します。
createEvent(String, String, HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
アプリケーションIDとキーに対応するイベントを取得します。

D

destroy() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを破棄します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
イベントを実行します。
dispatchEvent(Event) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
イベント処理を実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
ロケールをセッションに登録し、次のフィルタに処理を移します。

G

getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginGroupID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getLoginUserID(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
推奨されていません。 このメソッドではなく#getUserInfo()を使用してください。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils の static メソッド
ユーザ情報を取得します。
getUserInfo(HttpServletRequest, HttpServletResponse) - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のメソッド
ユーザ情報を取得します。

I

IntramartAction - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction.
jp.co.intra_mart.framework.base.service.ServiceControllerAdapterと似たメソッドを持つActionクラスです。
IntramartAction() - class jp.co.intra_mart.framework.extension.struts.action.IntramartAction のコンストラクタ
init(FilterConfig) - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のメソッド
フィルタを初期化します。

J

jp.co.intra_mart.framework.extension.common.util - package jp.co.intra_mart.framework.extension.common.util
im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action - package jp.co.intra_mart.framework.extension.struts.action
im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

S

ServiceUtils - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils.
im-J2EE Frameworkのサービスフレームワークに連携するためのユーティリティです。
ServiceUtils() - class jp.co.intra_mart.framework.extension.common.util.ServiceUtils のコンストラクタ
StrutsConnectFilter - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter.
intra-martのメニューからStrutsに接続するフィルターです。
StrutsConnectFilter() - class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter のコンストラクタ
C D G I J S
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


imart_struts 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (imart_struts 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.framework.extension.common.util
jp.co.intra_mart.framework.extension.struts.action


概要 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 imart_struts API Specifications

パッケージ
jp.co.intra_mart.framework.extension.common.util | im-J2EE Frameworkに連携するためのユーティリティです。
jp.co.intra_mart.framework.extension.struts.action | im-J2EE FrameworkとStrutsを連携するためのユーティリティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (imart_struts 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.framework.extension.common.util, jp.co.intra_mart.framework.extension.struts.action

クラス階層

  • class java.lang.Object
    • class org.apache.struts.action.Action
      • class jp.co.intra_mart.framework.extension.struts.action.IntramartAction
    • class jp.co.intra_mart.framework.extension.common.util.ServiceUtils
    • class jp.co.intra_mart.framework.extension.struts.action.StrutsConnectFilter (implements javax.servlet.Filter)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(imart_struts 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


 IMART タグ リスト

画面デザイン共通モジュール利用時の注意点
1. | 画面デザイン共通モジュールを使用する際は、必ず各画面を構成しているHTMLの<HEAD>タグ内に、 デザインスタイルシートの宣言（＝<IMART type="imDesignCss">）を行ってください。
2. | <IMART> タグは、必ず </IMART> と１対１の関係になるように記述しなければなりません（ </IMART> を未記述時の動作は未定義）。
3. | <IMART> タグ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
4. | <IMART> タグ内に定義する各属性名、および属性値は、大文字・小文字を厳密に判定します。
5. <IMART> タグ内に定義する属性値は、" (ダブルクォート)で囲む事で定数値として扱われます。
(定数値バインド機能(アプリケーション共通モジュール Imart.defineAttribute() を参照)を利用している場合には、定数値バインド機能で定義されている値への変換対象としてみなされます。)

逆に、" (ダブルクォート)で囲まない場合には、対応するファンクション・コンテナ内に宣言された変数、または関数へのバインド対象として実行されます。
6. <IMART> タグ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
7. プレゼンテーション・ページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内の <IMART> は実行されません。)


IMART タグ リスト

 IMART タグ

表示系タグ
imDesignCss
imIcon
imInputTd
imItemName
imListControl
imListHeader
imSelectTd
imTitleBar
imToolbarFrame
imToolbarLeft
imToolbarRight

制御系タグ

リクエスト系タグ

レスポンス系タグ

コントロール系タグ

グラフ描画系タグ

モバイル系タグ


 imDesignCss タグ

<IMART type="imDesignCss"> タグ。

デザインスタイルシートの宣言を行います。
<IMART type="imDesignCss"> タグを利用することで、
ServerManager 配下の conf/system.xml ファイルの system/color-config/color-pattern タグ内で 設定したＣＳＳファイルが利用可能になります。
system/color-config/color-pattern に複数のＣＳＳファイルを設定することも可能です。
内部タグ:
なし
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
      ：
      ：
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imIcon タグ

<IMART type="imIcon"> タグ。

ツールバー内に「処理リンク」を表示させたいときに使用します。
<IMART type="imIcon"> … </IMART> タグにより、「アイコン＋処理名」の処理リンクが表示できます。
「アイコン」のみ、または「処理名」のみの表示も可能です。
属性 icon により、表示するアイコンを指定できます。
属性 name により、表示する処理名を指定できます。
処理を選択された時のリンク先として、js の関数名や URL 、リンク先の表示ウィンドウを指定できます。
本タグを <IMART type="imToolbarLeft"> タグに挟まれた範囲に記述すると、ツールバー内で左寄せに表示されます。
本タグを <IMART type="imToolbarRight"> タグに挟まれた範囲に記述すると、ツールバー内で右寄せに表示されます。
本タグを記述した順番に、ツールバーの左から「処理リンク」が配置されます。

制約
属性 href を指定した場合、<A> タグとして作成されます。
属性 その他 を指定する場合、属性 href が設定されている必要があります。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
name | false | 処理名
icon | false | アイコンのファイル名 (ドキュメントルートからの相対パス)
href | false | 処理選択時のジャンプ先 (js 実行関数名や、URL など)
target | false | 表示ウィンドウ (指定値は、HTML の target 属性)
alt | false | 画像の変わりに表示される文字列
その他 | false | <A> タグに設定する各属性値
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>

        <!-- 「アイコン＋処理名」表示 -->
        <IMART type = "imIcon"
               name = "新規登録"
               icon = "images/standard/new.gif"
               href = "javascript:onAddAction();" >
        </IMART>

        <!-- 「処理名」表示 -->
        <IMART type = "imIcon"
               name = "最新情報"
               href = "http://www.intra-mart.co.jp/" target="top">
        </IMART>

    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imInputTd タグ

<IMART type="imInputTd"> タグ。

入力項目の入力フィールドを表示します。
登録系画面や更新・削除系画面で、入力項目の入力フィールドを記述する際に使用します。
属性 style に指定した値によって、異なる入力フィールドを表示することができます。
属性 style="text" を指定した場合は、テキスト入力フィールドが表示されます。
属性 style="password" を指定した場合は、パスワード入力フィールドが表示されます。
属性 style="file" を指定した場合は、ファイル入力フィールドが表示されます。
属性 style="checkbox" を指定した場合は、チェックボックスが表示されます。
属性 style="radio" を指定した場合は、ラジオボタンが表示されます。
属性 style="textarea" を指定した場合は、テキストエリア入力フィールドが表示されます。(HTML の <TEXTAREA> タグとして作成)
属性 style="textarea" 以外は、HTML の <INPUT> タグとして作成されます。

制約
HTML の <TD> タグとして作成されるため、<TABLE><TR> 〜 </TR></TABLE> 内に記述してください。
また、デザインを統一するために本タグを使用する際には、必ずに使用例に示す <TABLE><TR> 〜 </TR></TABLE>の中に記述してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
style | true | 部品の種類 ・ text：テキスト入力フィールド ・ password：パスワード入力フィールド ・ file：ファイル入力フィールド ・ checkbox：チェックボックス ・ radio：ラジオボタン ・ textarea：テキストエリア入力フィールド
name | true | 名前
colspan | false | <TD> タグの colspan 属性
rowspan | false | <TD> タグの rowspan 属性
align | false | <TD> タグの align 属性 (横方向表示位置) ・ canter：中央表示 ・ right ：右寄せ ・ left ：左寄せ
tdclass | false | <TD> タグの class 属性
class | false | <INPUT> タグ、<TEXTAREA> タグの class 属性
size | false | 入力フィールドの大きさ
value | false | 初期値
readonly | false | 入力不可の指定
caption | false | 部品の名称 (style="checkbox"/type="radio" の場合)
checked | false | チェック状態の指定 (<INPUT> タグの checked 属性)
cols | false | テキストエリアの横幅 (<TEXTAREA> の cols 属性)
rows | false | テキストエリアの縦幅(行数) (<TEXTAREA> の rows 属性)
その他 | false | <TD> タグに設定する各属性値
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
        <TABLE class="edit">
            <TR>
                <IMART type="imInputTd" style="text"
                       name="userId" size="30" value="User00011" readonly>
                </IMART>
            </TR>
            <TR>
                <IMART type="imInputTd" style="password"
                       name="passWord" size="50" value="Pass00011">
                </IMART>
            </TR>
            <TR>
                <IMART type="imInputTd" style="file" name="forward_file" size="50"></IMART>
            </TR>
            <TR>
                <IMART type="imInputTd" style="checkbox" name="check1" checked ></IMART>
            </TR>
            <TR>
                <IMART type="imInputTd" style="radio" name="radio1" caption="R1"></IMART>
            </TR>
            <TR>
                <IMART type="imInputTd" style="textarea"
                       name="comment" cols="40" rows="5" value="コメント欄">
                </IMART>
            </TR>
        </TABLE>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imItemName タグ

<IMART type="imItemName"> タグ。

入力項目の「項目名称」を表示します。
登録系画面や更新・削除系画面で、入力項目の項目名称を記述する際に使用します。
属性 name に指定した値が、項目名称として表示されます。
属性 require を指定すると、「必須項目」として表示されます。
「必須項目」の場合は、項目名称が太字で表示され、赤色で「（必須）」の文字が記述されます。
属性 require が未指定の場合は、「通常項目」として表示されます。

制約
HTML の <TD> タグとして作成されるため、<TABLE><TR> 〜 </TR></TABLE> 内に記述してください。
また、デザインを統一するために本タグを使用する際には、必ずに使用例に示す <TABLE><TR> 〜 </TR></TABLE>の中に記述してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
name | true | 項目名称
require | false | 必須項目の指定
その他 | false | <TD> タグに設定する各属性値
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>

        <TABLE class="edit">
            <TR>
                <!-- 通常表示 -->
                <IMART type="imItemName" name="ユーザID" width="150"></IMART>
            </TR>
            <TR>
                <!-- 必須表示 -->
                <IMART type="imItemName" name="ユーザ名" require></IMART>
            </TR>
        </TABLE>

    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imListControl タグ

<IMART type="imListControl"> タグ。

各種一覧に対する ソート切り替えコントロールと、ページ切り替えコントロールを表示します。
ソート および、ページ切り替えコントロールはリンク表示となっています。
各コントロールのリンクがクリックされると、JavaScript 関数が呼び出されるため、本タグを使用した場合は、各コントロールに対して JavaScript 関数の処理を記述する必要があります。
(詳細は デフォルトの必須 JavaScript 関数 を参照)
ソート切り替えコントロールには、昇順ソート(有効／無効)、 降順ソート(有効／無効)の矢印リンクが用意されています。
ソート切り替えコントロールは、属性の指定により、表示、および非表示を設定できます。
一覧で表示しているページによって、矢印アイコンの表示、および非表示を切り替えることができます。
一覧の表示件数が［全件数 < １ページの表示数］の場合は、ページ切り替えコントロールは表示されません。(ページ件数のみ表示)

制約
本タグは、HTML の <TABLE> タグとして作成されます。

デフォルトの必須 JavaScript 関数

ソート切り替えコントロール、ページ切り替えコントロールのリンクをクリックした際に呼び出される、デフォルト JavaScript 関数の詳細を以下に示します。
本タグを使用する際に、下記の属性を未指定にした場合は、各自で必ずデフォルト JavaScript 関数の処理を記述してください。

  ・ 属性 prevPageFunc
  ・ 属性 nextPageFunc
  ・ 属性 firstPageFunc
  ・ 属性 lastPageFunc
  ・ 属性 ascSortFunc
  ・ 属性 descSortFunc

必須の JavaScript 関数を記述しない場合の動作については、保証外とします。
コーディング方法などの詳細については、使用例を参照してください。
上記の属性を指定した場合は、デフォルト JavaScript 関数の処理を記述する必要はありません。

ソート切り替え
属性 ascSortFunc および属性 descSortFunc のいずれかを未指定にした場合、
ソート切り替えコントロールで 「昇順」および「降順」のリンクをクリックすると、JavaScript 関数の onSortLinkFunc() が呼び出されます。

■関数名
  onSortLinkFunc(mode)

■概要
  ソート切り替えコントロール(昇順／降順) がクリックされた際に、呼び出される関数です。
  引数 mode の値により、昇順／降順のどちらが選択されたかの情報を取得することができます。

■引数
変数 | 内容 | 値 | 条件
mode | ソート基準方向 | asc | 「昇順」リンクが選択された場合
desc | 「降順」リンクが選択された場合

ページ切り替え
属性 prevPageFunc、nextPageFunc、firstPageFunc、lastPageFunc のいずれかを未指定にした場合、
ページ切り替えコントロールで各矢印のリンクがクリックされると、JavaScript 関数の onPageLinkFunc() が呼び出されます。

■関数名
  onPageLinkFunc(num)

■概要
  ページ切り替えコントロールの各矢印リンクがクリックされた際に、呼び出される関数です。
  引数 num の値により、次に表示するページ番号の情報を取得することができます。

■引数
変数 | 内容 | 値 | 条件
num | ページ番号 | 1 〜 n | 各矢印リンクが選択された場合
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
maxRecord | true | 全件数
currentPage | false | 表示するページ番号 (未指定の場合：1)
pageLine | false | 1 ページの表示数 (未指定の場合：10)
sortDisplay | false | 「昇順／降順」の有無 (true：表示／false：非表示)
sortOrder | false | ソート基準方向 (asc：昇順／desc：降順)
prevPageFunc | false | 前ページ選択時の js 関数
nextPageFunc | false | 次ページ選択時の js 関数
firstPageFunc | false | 最初ページ選択時の js 関数
lastPageFunc | false | 最終ページ選択時の js 関数
ascSortFunc | false | 昇順ソート選択時の js 関数
descSortFunc | false | 降順ソート選択時の js 関数
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>

        <SCRIPT LANGUAGE="JavaScript">
            // ページ切り替え＜＞がクリックされた時の処理
            function onPageLinkFunc(num)
            {
                    :
                // 各自で処理を記述
                    :
            }
            // 昇順／降順（ソート条件）をクリックした時の処理
            function onSortLinkFunc(mode)
            {
                    :
                // 各自で処理を記述
                    :
            }
        </SCRIPT>

    </HEAD>
    <BODY>
        <TABLE width="100%">
            <TR>
                <TD>
                    <!-- リストコントロール表示 -->
                    <IMART type="imListControl"
                           maxRecord="20"
                           currentPage="1"
                           pageLine="5"
                           sortOrder="asc">
                    </IMART>
                </TD>
            </TR>
        </TABLE>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imListHeader タグ

<IMART type="imListHeader"> タグ。

各種一覧(リスト)に対するヘッダを表示します。

<IMART type="imListHeader"> により、各種一覧(リスト)に対するヘッダを表示します。
本タグで生成された一覧のヘッダ項目名は、リンク表示となっています。
各項目のリンクがクリックされると、JavaScript 関数が呼び出されるため、本タグを使用した場合は、各項目リンクに対して JavaScript 関数の処理を記述する必要があります。
（詳細は 必須の JavaScript 関数 を参照)
ヘッダの項目名は、属性の指定によりリンク表示と、通常表示 (ただの文字列) を設定できます。
ソートキーになっている項目は、ヘッダ項目名を強調して表示します。
ヘッダ情報 (項目名など) は、ファンクション・コンテナ (.js ファイル)で設定してください。

制約
本タグは HTML の <TR> タグとして作成されるため、<TABLE> 〜 </TABLE> 内に記述してください。
その際、<TABLE> タグには class="list_border_bg" または class="table_border_bg" を指定してください。

表全体の枠 (横幅100%固定) | <TABLE class="list_border_bg">
表全体の枠 (横幅任意指定) | <TABLE class="table_border_bg">

ヘッダ情報オブジェクト
<IMART type="imListHeader"> を使用してリストヘッダを作成する際に、属性 headerData に指定するオブジェクトです。

ヘッダ情報オブジェクト構成
プロパティ 設定内容 説明
name 項目名 ヘッダに表示する項目名
未指定の場合は、空のヘッダが表示されます。
項目ID = "checkbox" の場合は、
<INPUT type="checkbox"> タグの name 属性となります。
key 項目ID 項目ID
現在のソートキー項目を判定するための ID となるので、他項目との重複は不可。
"checkbox" を指定した場合、ヘッダ内にチェックボックスが表示されます。
sortEnable ソート表示状態 項目名の表示状態
  ・ true ： リンク表示(未指定の場合)
  ・ false： 通常表示
項目ID = "checkbox" の場合は、false が設定されます。
href 項目名選択時の js 関数 項目名がリンク表示の場合、リンクが選択された時のjs関数を指定
未指定の場合、onSortHeadClick(項目ID); が設定され、
項目ID = "checkbox" の場合は、「onClock イベントハンドラ」に設定する js 関数を指定します。
status 現在のソートキー 項目名の表示位置
  ・ true ： ソートキー
  ・ false： ソートキーでない(未指定の場合)
Align 表示位置 項目名の表示位置
  ・ center： 中央表示(未指定の場合)
  ・ left　 ： 左寄せ
  ・ right　： 右寄せ
その他 任意属性の設定値 項目に設定する任意の属性(項目の<TD>タグの属性値)
複数の任意の属性を指定することも可能。

デフォルトの必須 JavaScript 関数
リストヘッダの項目名リンクがクリックされた際に呼び出される、デフォルトの JavaScript 関数の詳細を以下に示します。
本タグを使用する場合は、各自で必ず JavaScript 関数の処理を記述してください。
必須の JavaScript 関数を記述しない場合の動作については、保証外とします。
コーディング方法などの詳細については、サンプルを参照してください。

ソートの項目切り替え
リストヘッダの項目名リンクがクリックされた場合、JavaScript 関数の onSortHeadClick() が呼び出されます。

■関数名
  onSortHeadClick(key)

■概要
  リストヘッダの項目名リンクがクリックされた際に、呼び出される関数です。
  引数 key の値により、どのヘッダ項目が選択されたかの情報を取得することができます。

■引数
変数 | 内容 | 値 | 条件
key | ヘッダの項目ID | (例) userName | リストヘッダの項目名リンクが選択された場合
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
headerData | true | ヘッダ情報オブジェクト
使用例;
■js
// バインド変数宣言
var aHeader; // ヘッダ項目情報

// ページの初期化関数
function init() {
    aHeader = new Array();

    aHeader[0] = new Object();
    aHeader[0].name = "checkCtrl";
    aHeader[0].key = "checkbox";
    aHeader[0].href = "onCheckBox();";

    aHeader[1] = new Object();
    aHeader[1].name = "ユーザコード";
    aHeader[1].key = "user_cd";
    aHeader[1].status = true;
    aHeader[1].href = "func1();";

    aHeader[2] = new Object();
    aHeader[2].name = "ユーザ名";
    aHeader[2].key = "name_kana";

    aHeader[3] = new Object();
    aHeader[3].name = "会社／組織";
    aHeader[3].key = "division";
    aHeader[3].sortEnable = false;
    aHeader[3].align = "left";
    aHeader[3].width = "200";
}

■html
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>

        <SCRIPT LANGUAGE="JavaScript">
            // 一覧の項目名リンクがクリックされた時の処理
            function onSortHeadClick(key)
            {
                    :
                // 各自で処理を記述
                    :
            }
            // 指定したJavaScript 関数の処理
            function onCheckBox()
            {
                    :
                // 各自で処理を記述
                    :
            }
        </SCRIPT>

    </HEAD>
    <BODY>
        <TABLE class="table_border_bg">
            <!-- リストヘッダ表示 -->
            <IMART type="imListHeader" headerData=aHeader></IMART>
        </TABLE>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imSelectTd タグ

<IMART type="imSelectTd"> タグ。

入力項目の選択ボックスを表示します。
登録系画面や更新・削除系画面で、入力項目の選択ボックスを記述する際に使用します。
属性 style に指定した値によって、異なる入力フィールドを表示することができます。

既存の画面共通モジュール <IMART type="select"> とほぼ同じ機能であり、画面デザインを統一するためにデザインが変更されています。

制約
HTML の <TD> タグとして作成されるため、<TABLE><TR> 〜 </TR></TABLE> 内に記述してください。
また、デザインを統一するために本タグを使用する際には、必ずに使用例に示す <TABLE><TR> 〜 </TR></TABLE>の中に記述してください。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
list | true | 表示リスト
selected | false | 初期選択値の設定
blank | false | 空データを表示する位置 ・ top ：先頭位置に空データ ・ bottom：最後尾位置に空データ
name | false | 名前
size | false | 表示する行数 (未指定の場合：1)
multiple | false | 複数行選択の可否 (<SELECT> タグの multiple 属性)
その他 | false | <TD> タグに設定する各属性値
使用例;
■js
// バインド変数宣言
var listData; // 選択ボックスの表示データ

// ページの初期化関数
function init() {
    listData = new Object();

    listData["tokyo"] = "東京都";          // または listData.tokyo = "東京都";
    listData["kanagawa"] = "神奈川県";     // または listData.kanagawa = "神奈川県";
    listData["saitama"] = "埼玉県";        // または listData.saitama = "埼玉県";
    listData["chiba"] = "千葉県";          // または listData.chiba = "千葉県";
}

■html
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
        <!-- 入力項目表示 -->
        <TABLE class="edit">
            <TR>
                <IMART type="imItemName" name="出身地"></IMART>
                <IMART type="imSelectTd" list=listData name="hometown" size="1"></IMART>
            </TR>
        </TABLE>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imTitleBar タグ

<IMART type="imTitleBar"> タグ。

タイトルバーを表示します。
タイトルバーには、「アイコン」 と 「ページタイトル名」 を指定して表示することができます。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
title | true | ページタイトル名
icon | false | アイコンのファイル名 （ドキュメントルートからの相対パス） デフォルト値は「list.gif」です。
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
        <!-- タイトルバー表示 -->
        <IMART type="imTitleBar"
               title="新規登録"
               icon="images/standard/title.gif">
        </IMART>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imToolbarFrame タグ

<IMART type="imToolbarFrame"> タグ。

ツールバーの外枠を表示します。
ツールバーの表示色は、テーマによって自動に設定されます。
内部タグ:
IMARTタグおよびHTML
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
        <!-- ツールバー表示 -->
        <IMART type = "imToolbarFrame">

            <IMART type = "imToolbarLeft">
                <IMART type = "imIcon"
                       name = "新規登録"
                       icon = "images/standard/new.gif"
                       href = "javascript:onAddAction();">
                </IMART>
                <IMART type = "imIcon"
                       name = "検索条件"
                       icon = "images/standard/search.gif"
                       href = "javascript:onSearchAction();">
                </IMART>
            </IMART>
            <IMART type = "imToolbarRight">
                <IMART type = "imIcon"
                       name = "戻る"
                       icon = "images/standard/arrow_left.gif"
                       href = "javascript:onBackAction();">
                </IMART>
                <IMART type = "imIcon"
                       name = "最新情報"
                       icon = "images/standard/refresh.gif"
                       href = "javascript:onReloadAction();">
                </IMART>
            </IMART>

        </IMART> <!-- ツールバー表示 -->
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imToolbarLeft タグ

<IMART type="imToolbarLeft"> タグ。

ツールバー内の 左側 に「処理リンク」を表示させたいときに使用します。
ツールバーの左側に表示する「処理リンク」がないときは、省略可能です。
<IMART type="imToolbarLeft"> ･･･ </IMART> に挟まれた範囲に記述された「処理リンク」は、ツールバー内で左寄せに表示されます。
本タグに挟まれた範囲には、複数の 「処理リンク」 を記述することができます。
「処理リンク」には、<IMART type="imIcon"> タグ（詳細は <IMART type="imIcon"> を参照）だけでなく、通常のHTMLタグ <A href="XXXX"></A> や、<IMART type="link"> なども記述することが可能です。

制約
本タグを単独で利用することはできません。
<IMART type="imToolbarFrame"> タグの内部タグとして利用してください。
本タグは <IMART type="imToolbarRight"> ･･･ </IMART> タグの前に記述してください。
内部タグ:
IMARTタグおよびHTML
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
        <IMART type = "imToolbarFrame">

            <!-- 左ツールバー -->
            <IMART type = "imToolbarLeft">
                <IMART type = "imIcon"
                       name = "新規登録"
                       icon = "images/standard/new.gif"
                       href = "javascript:onAddAction();">
                </IMART>
                <IMART type = "imIcon"
                       name = "検索条件"
                       icon = "images/standard/search.gif"
                       href = "javascript:onSearchAction();">
                </IMART>
            </IMART>

            <!-- 右ツールバー記述 -->

        </IMART>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 imToolbarRight タグ

<IMART type="imToolbarRight"> タグ。

ツールバー内の 右側 に「処理リンク」を表示させたいときに使用します。
ツールバーの右側に表示する「処理リンク」がないときは、省略可能です。
<IMART type="imToolbarRight"> ･･･ </IMART> に挟まれた範囲に記述された「処理リンク」は、ツールバー内で右寄せに表示されます。
本タグに挟まれた範囲には、複数の 「処理リンク」 を記述することができます。
「処理リンク」には、<IMART type="imIcon"> タグ（詳細は <IMART type="imIcon"> を参照）だけでなく、通常のHTMLタグ <A href="XXXX"></A> や、<IMART type="link"> なども記述することが可能です。

制約
本タグを単独で利用することはできません。
<IMART type="imToolbarFrame"> タグの内部タグとして利用してください。
本タグは<IMART type="imToolbarLeft"> ･･･ </IMART> タグの後に記述してください。
内部タグ:
IMARTタグおよびHTML
使用例;
<HTML>
    <HEAD>
        <IMART type="imDesignCss"></IMART>
    </HEAD>
    <BODY>
        <IMART type = "imToolbarFrame">

            <!-- 左ツールバー記述 -->

            <!-- 右ツールバー -->
            <IMART type = "imToolbarRight">
                <IMART type = "imIcon"
                       name = "戻る"
                       icon = "images/standard/arrow_left.gif"
                       href = "javascript:onBackAction();">
                </IMART>
                <IMART type = "imIcon"
                       name = "最新情報"
                       icon = "images/standard/refresh.gif"
                       href = "javascript:onReloadAction();">
                </IMART>
            </IMART>

        </IMART>
    </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：5.0


 accessCtrl タグ

<IMART type="accessCtrl"> タグ。

タグに挟まれている範囲内のソースを権限に表示/非表示の制御を行います。
権限の設定は、アクセスコントローラ管理にて設定します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
controller | true | アクセスコントローラID
defaultShow | false | 対象のアクセスコントローラIDに権限が設定されていない場合の動作を設定します。 trueを指定した場合は、表示を行います。 falseを指定した場合は、表示を行いません。 省略した場合は、trueが設定された場合と同じ動作となります。
使用例;
<IMART type="accessCtrl" controller="controller-id">
ログインユーザとアクセスコントローラIDの権限が一致した場合に表示されます。
アクセスコントローラIDに権限がない場合も表示されます。
</IMART>
<IMART type="accessCtrl" controller="controller-id" defaultShow="false">
ログインユーザとアクセスコントローラIDの権限が一致した場合のみ表示されます。
アクセスコントローラIDに権限がない場合は表示されません。
</IMART>
バージョン：1.0
導入されたバージョン：6.1


 backToMenu タグ

<IMART type="backToMenu"> タグ。

アンカータグ(<A>)によるリンクを生成します。
このタグは、モバイル用画面作成時専用ＡＰＩです。
内部タグ:
IMARTタグおよびHTML
使用例;
<IMART type="backToMenu">[MENU]</IMART>
画面上には「[MENU]」というリンクが表示されます。
このリンクをクリックしたら、メニュー画面が表示されます。
バージョン：1.0
導入されたバージョン：5.0


 barGraph タグ

<IMART type="barGraph"> タグ。

棒グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 dataMax および 属性 dataMin に対しては、負数の値を指定することも出来ます。
必ず　（属性dataMin の値）＜（属性 dataMax の値）　となるように指定して下さい。
属性 dataMax および 属性 dataMin を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
dataMin | true | 目盛りの最小値
dataMax | true | 目盛りの最大値
scaleCount | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="bar_graph"
       data=oData
       imageWidth="300"
       imageHeight="300"
       dataMin="-10"
       dataMax="50"
       scaleCount="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色
oData.aData[2] = new Object();                                       // データ３
oData.aData[2].aData = new Array(20, 30, 50, 25, 45);                //     グラフデータ値
oData.aData[2].sColor = "green";                                     //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               └ (String) sColor           // グラフの色（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColorプロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：5.0


 calendar タグ

<IMART type="calendar"> タグ。

カレンダー画面ＨＴＭＬソースを作成します。
group にはカレンダーＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式

click_action 属性は必ず“正しく”指定します。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキックされた時にコールされる。
その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報(1 - 12)
第6引数 | Number | クリックされた日情報

注意事項：
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
初期データインポートで設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。

なお、カレンダー画面の表示は、<IMART type="link"> タグを利用する方法もあります。
詳しくは、APIリスト [スクリプト開発モデル]-[ユニット]-[カレンダー表示モジュール] を参照してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
year | true | 作成するカレンダーの年
month | true | 作成するカレンダーの月(1 - 12)
group | false | カレンダー作成時に利用するカレンダーID
format | false | 使用するフォーマットファイルの指定
click_action | false | 日リンクのクリック時に実行する関数名
weekCaption | false | 曜日のキャプション（文字列の配列） 日曜 - 土曜までのキャプションを配列で指定します。 未指定の場合は、デフォルト値{"S","M","T","W","T","F","S"} になります。
使用例;
１９９９年５月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<IMART type="calendar" year="1999"
month="5"
click_action="click_date">
</IMART>
バージョン：1.0
導入されたバージョン：5.0


 circleGraph タグ

<IMART type="circleGraph"> タグ。

円グラフの描画を行います。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
属性 marginCaption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 marginCaption には、グラフの中心点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
marginCaption | false | キャプションの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="circleGraph"
       data=oData
       imageWidth="300"
       imageHeight="300"
       marginCaption="60">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nData      = 500;               //     グラフデータ値
oData[0].sColor     = "red";             //     グラフの色
oData[0].sCaption   = "自動車";          //     キャプション文字列
oData[0].sFontColor = "pink";            //     キャプション文字色
oData[0].nFontSize  = 15;                //     キャプション文字サイズ
oData[1] = new Object();                 // データ２
oData[1].nData      = 400;               //     グラフデータ値
oData[1].sColor     = "blue";            //     グラフの色
oData[1].sCaption   = "工業機械"         //     キャプション文字列
oData[1].sFontColor = "skyblue";         //     キャプション文字色
oData[1].nFontSize  = 15;                //     キャプション文字サイズ
oData[2] = new Object();                 // データ３
oData[2].nData      = 300;               //     グラフデータ値
oData[2].sColor     = "green";           //     グラフの色
oData[2].sCaption   = "精密機械"         //     キャプション文字列
oData[2].nFontSize  = 15;                //     キャプション文字サイズ
oData[3] = new Object();                 // データ４
oData[3].nData      = 250;               //     グラフデータ値
oData[3].sColor     = "yellow";          //     グラフの色
oData[3].sCaption   = "家電"             //     キャプション文字列
oData[3].nFontSize  = 15;                //     キャプション文字サイズ

[data属性の構造]
    円グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nData                  // グラフ値
         ├ (String) sColor                 // グラフの色
         ├ (String) sCaption               // 項目に表示するキャプションの文字列
         ├ (String) sFontColor             // キャプションの文字色（任意）
         └ (number) nFontSize              // キャプションの文字サイズ（任意）

    sColor プロパティが未設定のとき、該当するデータのグラフ色は無色で表示されます。
    sFontColor プロパティが未設定のとき、キャプション文字色にはデフォルト値（黒）が設定されます。
    nFontSize プロパティが未設定のとき、キャプション文字サイズにはデフォルト値（15）が設定されます。

    sColor または sFontColor プロパティには カラーチャートのカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 condition タグ

<IMART type="condition"> タグ。

タグに挟まれた範囲内の部分の実行を制御します。
属性 validity に対して true 値を指定した場合は内部の処理を実行し、false 値を指定した場合は内部の処理を無視します。
属性 negative に対して true 値を指定した場合、 属性 validity に対して指定した値を逆解釈して処理します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
validity | true | 有効・無効フラグ
negative | false | 条件反転判定
使用例;
<IMART type="condition" validity=flg>
真値
</IMART>
<IMART type="condition" validity=flg negative>
偽値
</IMART>
ファンクション・コンテナ側から変数 flg によりバインドされた真偽値により表示文字を動的選択します。
変数 flg の値が true であった場合は「真値」と表示され、false であった場合には「偽値」と表示されます。
バージョン：1.0
導入されたバージョン：2.0


 Content-Type タグ

<IMART type="Content-Type"> タグ。

クライアントへ送信される応答のコンテンツ形式を設定します。
属性 value に指定したコンテンツ形式が、応答ヘッダ Content-type の値になります。
コンテンツ形式には、たとえば text/html; charset=Shift_JIS のように、
使用される文字エンコーディングのタイプを含めることができます。

内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | コンテンツの MIME タイプを指定する文字列
使用例;
<IMART type="Content-Type" value="text/html; charset=Shift_JIS"></IMART>
応答ヘッダ Content-type が text/html; charset=Shift_JIS に設定されます。
バージョン：1.0
導入されたバージョン：5.0


 date タグ

<IMART type="date"> タグ。

タグの指定された場所に、指定された日付データを文字列として挿入します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | 挿入する日付データ(Date型)
format | true | 表現フォーマット指定文字列
使用例;
<IMART type="date" value=dNow format="yyyy/MM/dd"></IMART>
このタグの位置に「2000/11/26」という形式で日付情報を表示します。
表示値は、ファンクション・コンテナから変数のバインドによって動的に指定します(バインド変数 dNow に対して)。
バージョン：1.0
導入されたバージョン：2.0


 decision タグ

<IMART type="decision"> タグ。

タグに挟まれた部分の実行の条件分岐を行います。
属性 value に与えられた値が、属性 case に与えられた値に等しい場合のみタグに挟まれた範囲内の実行を行います。
value または case 属性に対しては null および undefined 値以外の値を指定するようにして下さい。
上記の各属性に対して null および undefined 値を指定した場合の動作は保証外です。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
value | true | チェック対象の値
case | true | チェック値
使用例;
<IMART type="decision" case="OK" value=check>
該当
</IMART>
ファンクション・コンテナ側から変数 value によりバインドされた値がcase 属性に指定された値(この場合は "OK" という文字列)と等しい場合に内容を処理します。
変数 check の値が "OK" であった場合「該当」と表示されます。
バージョン：1.0
導入されたバージョン：2.0


 event タグ

<IMART type="event"> タグ。

ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。
このタグは、Client Side Java Script を利用して実現されています。
また、値のブリッジには、ブラウザのクッキーを利用しています。
(クッキーを利用しているので別ウィンドウ同士の通信にも利用できます。)
そのため、クッキーの容量制限を越える量の値をやり取り(監視や受取)は できません。
また、このタグではクッキーを保存する際、クッキーの path 属性を 「/」として値を保存しています。
セキュリティ的に問題と なる場合には、この機能を利用しないで下さい。
属性 name には、動作する際のイベント名称(キーコード)を指定します。 この name 属性に指定したコードが等しい <IMART type="event"> 同士が連携して動作します。
属性 focus には、監視対象となる Client Side Java Script の変数名称を 文字列として指定して下さい。 focus 属性で指定された変数の内容が送信される事になります。
属性 receive には、監視対象値を受け取るための Client Side Java Script の変数名称を文字列として指定して下さい。 ここで指定した変数によって focus で監視している変数の値を受信する事が できます。
属性 init には、動作前にクッキーを初期化する必要がある場合、 その初期値を文字列として指定する事ができます。
属性 onChange には、focus 属性で指定された変数内の値が変化した際に 実行される Client Side Java Script のソースコードを文字列として指定します。
属性 time には、監視のタイミングをミリ秒で指定します。 focus 属性で指定された変数やクッキー内の情報は、タイマー機能を利用して 一定時間毎の監視を行っています。 デフォルトでは 250 ミリ秒毎に監視していますが、連動のタイミングをより リアルタイムにしたい場合は、この値を小さく設定し、ブラウザ処理の負荷が 高く動作が重い場合には、この値を大きく設定する事で任意に調整して下さい。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | カテゴリ名称
focus | true | 監視対象ＣＳＪＳ変数名称
receive | true | 監視変数内データの受け入れＣＳＪＳ変数名称
init | true | クッキー内初期値
onChange | true | データ変更時の実行スクリプト
time | true | クッキー監視間隔時間（ミリ秒）
使用例;
<FORM name="form_a">
<INPUT type="text" name="a_text">
</FORM>
<IMART type="event" name="text_copy" focus="document.form_a.a_text.value">
</IMART>
<FORM name="form_b">
<INPUT type="text" name="b_text">
</FORM>
<IMART type="event" name="text_copy" receive="document.form_b.b_text.value">
</IMART>
画面には二つのテキストフィールドが表示されます。
上のテキストフィールドに文字を記入すると、下のテキストフィールド内に上のテキストフィールドに入力した内容と同じものが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 floatingCalendar タグ

<IMART type="floatingCalendar"> タグ。

ドラッグ＆ドロップで移動可能なカレンダーをフレーム上に表示します

表示されたカレンダーの日付をクリックすると、 引数「element」で指定された要素に、選択された日付の文字列を反映します。 （日付文字列の形式は、引数「format」で指定可能です。）
カレンダーは、「カレンダー表示基準年月」を元に表示します。
（カレンダー表示基準年月は、引数「year」「month」を元に算出されます）

引数「year」および「month」が正しい年月に変換できない場合（未指定時含む）、 カレンダー表示基準年月はシステム日付の「年月」となります。
引数「year」が2桁の場合、「00から49」は 2000年代、「50から99」は 1900年代として処理されます。
引数「year」および「month」にて生成される年月は、1582年10月以降である必要があります。（1582年10月以前の動作は未定義）

引数「addMonth」が未設定の場合、「カレンダー表示基準年月」のカレンダーを表示します。
引数「addMonth」が設定された場合、「カレンダー表示基準年月 + (addMonth)ヶ月」のカレンダーを表示します。

[リロード]ボタン押下時、システム日付の「年月」のカレンダーを表示します。
ただし、引数「element」で指定された要素の値が、日付フォーマット形式に合致している場合、 その要素の値から算出される年月のカレンダーを表示します。

注意事項：
HTMLファイルの <HEAD> タグ内に、必ずデザインスタイルシートタグ（imDesignCss タグ）および、
< SCRIPT src=" < %web_path% > /csjs/im_floating_calendar.js" > を記述してください。
（ < %web_path% > はWeb Server Connectorをインストールしたディレクトリ）

なお、 < %web_path% > /csjs/im_floating_calendar.jsは、URLの関係で呼び出し時のソースパスは変わります。
スクリプト開発モデルの場合は、csjs/im_floating_calendar.js でリンクできます。

引数「position」に「event」を指定し、マウスクリック以外でカレンダーを表示すると、 IEの場合、マウスポインタがフレームから外れていると、カレンダーはフレームの外に表示されます。 NNの場合、フレームの左上（「left：0, top：0」）にカレンダーが表示されます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
element | true | 選択した日付の文字列表現を反映する要素
year | false | カレンダー表示基準年（デフォルトは システム日付の「年」)
month | false | カレンダー表示基準月 [1-12]（デフォルトは システム日付の「月」)
addMonth | false | カレンダー表示基準年月からの移動量 [月単位で数値指定]（デフォルトは「0」）
calendarId false カレンダーID（デフォルトは「ログイングループのデフォルトカレンダーID」）
指定されたカレンダーIDが存在しない場合は、デフォルトカレンダーIDのカレンダーを表示します。
position false カレンダー表示位置 [event | 'left,top']（デフォルトは「event」)
event | マウスカーソルのそばに表示
'left,top' | 指定位置に表示(ピクセル指定)
format false 日付フォーマット（デフォルトは「yyyy/MM/dd」）
フォーマット指定文字（Format.fromDate()のフォーマット指定文字に準拠）
y | 年
M | 月
d | 日
E | 曜日
weekCaptions false カレンダーに表示する曜日のキャプション。（デフォルトは、"Su,Mo,Tu,We,Th,Fr,Sa"）
カンマ区切りでキャプションを7つ指定します。（例."日,月,火,水,木,金,土"）
キャプション数が7つではない場合、デフォルト値を表示します。
callback false カレンダーの日付をクリックした際に呼び出されるJavascript関数名。（デフォルトは、"callBackFloatingCalendar"）
指定された関数には、「引数「element」で指定された要素」、「選択された日付の文字列」が引数として渡されます。 （サンプルコード参照）
isUseElementMonth false trueが指定された場合、elementで指定された要素の値をカレンダー表示基準年月とします。
（ただし、elementで指定された要素の値が日付フォーマット形式でない場合、falseが指定されたことになります）
falseが指定された場合、引数「year」および「month」を元にカレンダー表示基準年月を算出します。
（デフォルトは「true」）
使用例;
●今月のカレンダーを表示するHTML
  ・テキストフィールド「document.floatingCalendarForm.date」にカレンダーで選択した日付を反映します。

<HTML>
  <HEAD>
    <IMART type="imDesignCss"></IMART>
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <IMART type="floatingCalendar" element="document.floatingCalendarForm.date">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </IMART>
    </FORM>
  </BODY>
</HTML>

●以下の条件を満たしたカレンダーを表示するHTML
  ・2006年10月（＝2006年8月の2ヵ月後）のカレンダーを表示
  ・フレーム左上から、右に100px、下に200pxの位置にカレンダーを表示
  ・日付選択時に反映される文字列のフォーマットが「yyyy/MM/dd (E)」形式
  ・カレンダーID「sample」のカレンダーデータを表示
  ・表示カレンダーのキャプションを「日,月,火,水,木,金,土」で表示
  ・カレンダーの日付をクリックした際にJavascript関数「sampleCallBack」を呼び出す

<HTML>
  <HEAD>
    <IMART type="imDesignCss"></IMART>
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
    <SCRIPT type="text/javascript">
        function sampleCallBack(element, value){

            alert("sampleCallBack");
            alert("element.value = " + element.value);
            alert("value = " + value);

            element.value = value;
        }
    </SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <IMART type="floatingCalendar"
             element="document.floatingCalendarForm.date"
             year         = "2006"
             month        = "8"
             addMonth     = "2"
             position     = "100,200"
             format       = "yyyy/MM/dd (E)"
             calendarId   = "sample"
             weekCaptions = "日,月,火,水,木,金,土"
             callback     = "sampleCallBack">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </IMART>
    </FORM>
  </BODY>
</HTML>
バージョン：1.0
導入されたバージョン：6.0


 form タグ

<IMART type="form"> タグ。

スクリプト開発モデルのプログラムと連携するためのフォームを生成します。
フォームタグ(<FORM>)を生成します。
このタグを利用する事で intra-mart のセッションを維持しながら プログラムを動作させる事ができます。

属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定することで、ページ遷移をさせることができます。
ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。

属性 label は、遷移ページ内の任意のアンカータグ(<A name="*">)の位置を初期表示位置として指定する事ができます。
この指定はブラウザの機能を利用しているため、ブラウザ製品により期待通りに動作しない場合があります。

属性 action は、このリンクにより intra-mart がコールされた際に、同ページのファンクション・コンテナ内に定義されている関数をリクエスト時に起動するための指定で、起動させたい関数名称を指定する事で可能になります。
action 関数の実行は、次に表示するべきページの作成処理(該当ページのファンクション・コンテナ内 init() 関数)よりも先に動作します。

上記以外の属性と属性値は、そのまま <FORM> タグの属性となります。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
page | false | 表示ページパス
label | false | リンクラベル
action | false | コール時起動関数(同ページ js 内)
その他 | false | タグ属性と属性値
使用例;
<IMART type="form" page="sample/next" action="chkValue">
<INPUT type="submit">
</IMART>
画面上にはサブミットボタンが表示されます。
このボタンをクリックしたら、このページのファンクション・コンテナ内に定義されているchkValue() 関数を起動した後に sample/next ページを読込＆実行して画面上には sample/next ページが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 frame タグ

<IMART type="frame"> タグ。

スクリプト開発モデルプログラムと連携するためのフレームを生成
フレームタグ(<FRAME>)を生成します。
このタグを利用する事で intra-mart のセッションを維持しながら プログラムを動作させる事が出来ます。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、ページを表示させることができます。
ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。
属性 label は、遷移ページ内の任意のアンカータグ(<A name="*">)の位置を初期表示位置として指定する事ができます。
この指定はブラウザの機能を利用しているため、ブラウザ製品により期待通りに動作しない場合があります。
その他、表示ページ(属性 page に指定しているプログラム)に対して引き渡す ＵＲＬ引数を、任意の個数だけ指定可能です。
page に指定されたページの ファンクション・コンテナ内 init() 関数では、指定されたＵＲＬ引数を関数引数 request で受け取る事ができます。
その際、属性名称が引数 request オブジェクトのプロパティ名となり、 属性値が引数 request オブジェクトの該当プロパティに格納されます。
また <FRAME> タグに指定可能なオプション属性を任意に指定する事が出来ます。
<FRAME> タグの動作仕様に関しては、市販の HTML リファレンスを参照してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | true | 表示ページパス
label | false | リンクラベル
その他 | false | 表示ページへ渡すＵＲＬ引数および <FRAME> タグの各オプション属性
使用例;
<FRAMESET rows="50%,*">
<IMART type="frame" page="sample/top"></IMART>
<IMART type="frame" page="sample/bottom"></IMART>
</FRAMESET>
フレームを上下２つに分けて、それぞれ別なページをフレーム内に表示することができます（これはＨＴＭＬの機能です）。
この時、上のフレーム内にはページ sample/top が表示され、下のフレーム内にはページ sample/bottom が表示されます。
ページ sample/top と smple/bottom のリクエスト順と動作順は非同期であり保証される事はありません（ブラウザの制約です）。
バージョン：1.0
導入されたバージョン：2.0


 hidden タグ

<IMART type="hidden"> タグ。

フォームサブミット時のリクエスト引数となる隠しフィールドを作成します。
属性名がＵＲＬ引数の名称となり、属性値がＵＲＬ引数名称にマップされる値となります。
ブラウザからの受取時は、request.属性名 で取得可能です。
(request は、ファンクション・コンテナ実行時の関数引数です。)
ここでの指定は、ＵＲＬ引数となるため、属性名および属性値には定数または文字列型の値を指定するようにしてください。
(文字列以外の値が指定された場合の動作に関しては保証外。)
属性名と属性値は、複数個の同時指定が可能です。
(指定する属性値が１組の場合は、 <IMART type="input" style="hidden"> を利用して指定することもできます。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
その他 | false | hidden タグ名称と値
使用例;
<IMART type="form" action="form_action" page="sample/form_next">
<IMART type="hidden" arg_a="A" arg_b="B"></IMART>
</IMART>
このフォームをサブミットすると、該当するファンクション・コンテナ内に 定義されている form_action() 関数が起動されます。
この関数に引き渡される request オブジェクトを利用して hidden に指定した 値を受け取る事が出来ます。
また、この関数の実行終了後、sample/form_next ページの作成に入りますが、 この時、上記ページのファンクション・コンテナ内に定義されている init() 関数が起動されます。
この init() 関数でも request オブジェクトが引き渡されて、hidden の 値を受け取る事が出来ます。
受け取る request の構造は、以下のような形になります。
        request ┬ arg_a = "A"
                └ arg_b = "B"
バージョン：1.0
導入されたバージョン：2.0


 HTTP-EQUIV タグ

<IMART type="HTTP-EQUIV"> タグ。

指定された名前と値を持つ応答ヘッダを設定します。
属性 name にはヘッダの名前、属性 value にはヘッダの値を設定します。
ヘッダがすでに設定されていた場合は、新しい値が以前の値を上書きします。

内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
name | true | ヘッダの名前
value | true | ヘッダの値
使用例;
<IMART type="HTTP-EQUIV" name="AAA" value="BBB"></IMART>
<IMART type="HTTP-EQUIV" name="CCC" value="DDD"></IMART>
以下の応答ヘッダが設定されます。

AAA: BBB
CCC: DDD
バージョン：1.0
導入されたバージョン：5.0


 IMART タグ リスト

このページでは、プレゼンテーション・ページで利用する各ＡＰＩに関して、プログラム・インターフェースの詳細仕様を記載しています。

<IMART> タグＡＰＩ仕様
1. | <IMART> タグは、必ず </IMART> と１対１の関係になるように記述しなければなりません（ </IMART> を未記述時の動作は未定義）。
2. | <IMART> タグ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
3. | <IMART> タグ内に定義する各属性名、および属性値は、大文字・小文字を厳密に判定します。
4. <IMART> タグ内に定義する属性値は、" (ダブルクォート)で囲む事で定数値として扱われます。
(定数値バインド機能(アプリケーション共通モジュール Imart.defineAttribute() を参照)を利用している場合には、定数値バインド機能で定義されている値への変換対象としてみなされます。)

逆に、" (ダブルクォート)で囲まない場合には、対応するファンクション・コンテナ内に宣言された変数、または関数へのバインド対象として実行されます。
5. <IMART> タグ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
6. プレゼンテーション・ページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内の <IMART> は実行されません。)


IMART タグ リスト

 IMART タグ

表示系タグ
calendar
date
floatingCalendar
frame
include
loginUser
message
number
picture
string
tag
cal_view 非推奨

制御系タグ
accessCtrl
condition
decision
event
loop
repeat

リクエスト系タグ
form
jsspRpc
link
submit

レスポンス系タグ
Content-Type
HTTP-EQUIV

コントロール系タグ
hidden
input
richtextarea
select
textarea

グラフ描画系タグ
barGraph
circleGraph
lineGraph
portFolio
radarChart
bar_graph 非推奨
circle_graph 非推奨
line_graph 非推奨
port_folio 非推奨
radar_chart 非推奨

モバイル系タグ
backToMenu
back_to_menu 非推奨


 include タグ

<IMART type="include"> タグ。

任意のスクリプト開発モデルプログラムをコールして部分ページソースを挿入します。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、部分ページを表示させることができます。
ここで指定するパスは、 インストールディレクトリ/pages/ からの相対パス形式になります。
その他、表示ページ(属性 page に指定しているプログラム)に対して引き渡す 引数を、任意の個数だけ指定可能です。
page に指定されたページの ファンクション・コンテナ内 init() 関数では、引数 argV で受け取る事ができます。
その際、属性名称が引数 argV オブジェクトのプロパティ名となり、属性値が引数 argV オブジェクトの該当プロパティに格納されます。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | true | 実行対象ページソースパス
その他 | false | 実行ページへ渡す引数
使用例;
<IMART type="include" page="sample/sub"></IMART>
このタグの位置にページ sample/sub を実行した結果のソースを挿入します。
ページ sample/sub のファンクション・コンテナ内 init() 関数では、以下のように宣言する事で引数を受け取る事が出来ます。
function init(argV){ ・・・ }
バージョン：1.0
導入されたバージョン：2.0


 input タグ

<IMART type="input"> タグ。

任意のフォームコントロールを挿入します。
ＨＴＭＬの <INPUT> タグを生成します（ＨＴＭＬリファレンスを参照）。
属性 style に指定した文字列が <INPUT> タグの type 属性となります。
その他の属性と属性値は、そのまま <INPUT> タグの属性となります。
属性 style に対して有効な指定値には以下のものがあります。
text | テキストフィールド
password | パスワードフィールド
radio | ラジオボタン
checkbox | チェックボックス
hidden | 隠しフィールド
button | ボタン

<INPUT> タグの type 属性および各種設定可能な属性とその動作に関しては、ＨＴＭＬリファレンスをご参照下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
style | true | <INPUT> の type 属性名
その他 | false | タグ属性と属性値
使用例;
<IMART type="input" style="text" name="test1" value="default"></IMART>
フォームコントロールの一つであるテキストフィールドを表示します。
表示されたテキストフィールド内には「default」と初期表示されます。
出力されるＨＴＭＬソースは以下のようになります。
<INPUT type="text" name="test1" value="default">
属性 value などは、ファンクション・コンテナの変数をバインドする事によって動的な指定が可能です。

<IMART type="input" style="checkbox" checked=enable></IMART>
バインド変数がboolean型の場合は、以下の例のように出力されます。

バインド変数enableがtrueの場合は属性名のみ出力されます。
値は出力されません。
<INPUT type="checkbox" checked>

falseの場合は属性名、値ともに出力されません。
<INPUT type="checkbox">
バージョン：1.0
導入されたバージョン：2.0


 jsspRpc タグ

<IMART type="jsspRpc"> タグ。

このタグを利用すると、JavaScriptで記述されたサーバサイドのロジックを、 クライアントサイドJavaScript（以下 CSJS）からシームレスに呼び出すことが可能となります。

属性 name には、CSJS内でサーバロジックを参照する際のオブジェクト名を指定します。

属性 page には、サーバロジックが記述されているページパス（拡張子なし）を指定します。
ここで指定するパスは、スクリプト開発モデルプログラムのソースディレクトリからの相対パス形式になります。 （デフォルトはインストールディレクトリ/pages/src からの相対パス形式になります）

サーバサイドの処理結果を非同期で受け取りたい場合は、属性 callback を指定します。
属性 callback には、CSJS関数名を指定します。 属性 callback が指定されている場合、サーバサイドの処理結果が 属性 callback で指定されたCSJS関数の引数に渡されます。

属性 onErrorCallback には、非同期通信時にエラーが発生した場合に呼び出される関数名を指定します。
属性 onErrorCallback で指定された関数の引数には、 JSSP-RPC 通信エラーオブジェクトが渡されます。

例：
サーバサイドに「sample/test1.js」が存在し、 そのJSファイル内に「testFunction()」という関数が定義されている場合、 以下を行うことによって、CSJSから上記関数を実行することができます。
  1. HTMLファイル内に<IMART type="jsspRpc"> タグを以下のように記述します。
    2. <IMART type="jsspRpc" name="serverLogic" page="sample/test1" >
  2. CSJS内に以下を記述することで、サーバサイドのロジックを実行します。
    3. serverLogic.testFunction();

JSSP-RPC 通信エラーに関して
<IMART type="jsspRpc"> タグを利用したサーバサイドとの通信でエラーが発生した際、 そのエラー内容を格納したオブジェクトが伝達されます。

通信エラーが発生するのは以下の場合です。
  • レスポンスのHTTPステータスコードが「200」以外の場合 （サーバサイドで実行時エラーが発生した場合を含みます）
  • セッションタイムアウトが発生した場合
  • Debug.browse()を実行した場合

JSSP-RPCの通信方式（同期通信 または 非同期通信）によって、エラーオブジェクトの伝達方法が異なります。

同期通信の場合（＝属性 callback が未指定の場合）、
通信エラーの内容が例外として投げられます。
その為、同期通信を行う場合は、サーバサイドとの通信部分を try / catchで囲み、例外処理を記述してください。
投げられる例外オブジェクトの構成は、JSSP-RPC 通信エラーオブジェクトと同一です。

非同期通信の場合（＝属性 callback が指定されている場合）、
属性 onErrorCallback で指定された関数の引数に、 JSSP-RPC 通信エラーオブジェクトが渡されます。
属性 onErrorCallback が未指定の場合は、関数「ImJsspRpc.defaultOnErrorCallback() 」が実行されます。

JSSP-RPC 通信エラー オブジェクト
JSSP-RPC 通信エラー
オブジェクト (Object)
httpStatus HTTPステータスコード (Number)
code エラーコード (String)
message エラーメッセージ (String)
contentType レスポンスデータのコンテントタイプ (String)
data レスポンスデータ（JavaScriptオブジェクト、XMLオブジェクト、または、テキスト）

注意事項：
  • <IMART type="jsspRpc"> タグでは、 ブラウザとサーバ間の通信に XMLHttpRequest を利用しています。
  • ブラウザとサーバ間通信のデータ形式は JSON です。
  • 本タグで指定されたサーバロジック内では、以下の関数を利用することは出来ません。
    • forward()
    • redirect()
    • secureRedirect()
    • transmission()
    • HTTPResponse#sendMessageBody()
    • HTTPResponse#sendMessageBodyString()
  • <IMART type="jsspRpc"> タグでは、 プレゼンテーションページ(=HTMLファイル)とファンクションコンテナ(=JSファイル)が対になっている必要はありません。
    任意のプレゼンテーションページ内で、任意のファンクションコンテナを呼び出すことが可能です。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
name | true | CSJS内でサーバロジックを参照する際のオブジェクト名
page | true | サーバロジックが記述されているページパス（拡張子なし）
callback | false | サーバサイドの処理結果を非同期で受け取る際のコールバック関数名（CSJS関数名） 省略した場合は、同期通信を行い、サーバサイドから結果が返却されるまで待ちます。
onErrorCallback | false | 非同期通信時にエラーが発生した場合に呼び出される関数名（CSJS関数名） 省略した場合は、関数「ImJsspRpc#defaultOnErrorCallback() 」が実行されます。 (ImJsspRpc#defaultOnErrorCallback()は、csjs/im_jssp_rpc.js 内に定義されています) なお、同期通信の場合（＝属性 callback が未指定の場合）は、 属性 onErrorCallback に指定された関数は無視されます。
使用例;
  • サーバサイドの「jssp_rpc_test/sample1.js」に定義されている 「getNow()」関数を実行後、
    「Now = （現在日付）」をアラート表示します。
クライアントサイドのHTMLソース
<html>
    <head>
        <IMART type="jsspRpc"
               name="jsSample"
               page="jssp_rpc_test/sample1">
        </IMART>

        <script language="JavaScript">
            /**
             * 「jssp_rpc_test/sample1.js」の関数「getNow()」を実行します。
             */
            function execute(){
                try{
                    var result = jsSample.getNow("Now = ");
                    alert(result);
                }
                catch(ex){
                    alert(ex.message);
                    return;
                }
            }
        </script>
    <head>

    <body>
        <input type="button" value="実行（同期）" onclick="execute();">
    </body>
</html>

サーバサイドの「jssp_rpc_test/sample1.js」
function getNow( args ){
    return args + (new Date()).toString();
}

  • サーバサイドの「jssp_rpc_test/sample2.js」に定義されている 「getObject()」関数を実行し、
    その結果オブジェクトをコールバック関数「callBackFunction」にて取得します。
クライアントサイドのHTMLソース
<html>
    <head>
        <IMART type     = "jsspRpc"
               name     = "jsSample"
               page     = "jssp_rpc_test/sample2"
               callback = "callBackFunction">
        </IMART>

        <script language="JavaScript">
            /**
             * 「jssp_rpc_test/sample2.js」の関数「getObject()」を実行します。
             */
            function execute(){
                // 引数作成
                var obj = new Object();
                    obj.stringProp   = "value1";
                    obj.booleanProp  = true;
                    obj.numberProp   = -15;
                    obj.arrayProp    = new Array();
                    obj.arrayProp[0] = "ary0";
                    obj.arrayProp[1] = "ary1";
                    obj.arrayProp[2] = "ary2";
                    obj.dateProp     = new Date();

                // 内容を確認
                var str  = "";
                    str += "コールバック関数を確認するために"       + "\n";
                    str += "サーバサイドで５秒間スリープします。"   + "\n";
                    str +=                                            "\n";
                    str += "実行前"                                 + "\n";
                    str += "--------------------------------------" + "\n";
                    str += "obj.stringProp   = " + obj.stringProp   + "\n";
                    str += "obj.booleanProp  = " + obj.booleanProp  + "\n";
                    str += "obj.numberProp   = " + obj.numberProp   + "\n";
                    str += "obj.arrayProp[0] = " + obj.arrayProp[0] + "\n";
                    str += "obj.arrayProp[1] = " + obj.arrayProp[1] + "\n";
                    str += "obj.arrayProp[2] = " + obj.arrayProp[2] + "\n";
                    str += "obj.dateProp     = " + obj.dateProp     + "\n";
                    str += "--------------------------------------" + "\n";

                alert(str);

                // サーバロジック実行
                jsSample.getObject(obj);
            }

            /**
             * コールバック関数
             */
            function callBackFunction( result ){

                // 内容を確認
                var str  = "";
                    str += "実行後"                                       + "\n";
                    str += "--------------------------------------------" + "\n";
                    str += "result.stringProp   = " + result.stringProp   + "\n";
                    str += "result.booleanProp  = " + result.booleanProp  + "\n";
                    str += "result.numberProp   = " + result.numberProp   + "\n";
                    str += "result.arrayProp[0] = " + result.arrayProp[0] + "\n";
                    str += "result.arrayProp[1] = " + result.arrayProp[1] + "\n";
                    str += "result.arrayProp[2] = " + result.arrayProp[2] + "\n";
                    str += "result.dateProp     = " + result.dateProp     + "\n";
                    str += "--------------------------------------------" + "\n";

                alert(str);
            }

        </script>
    <head>

    <body>
        <input type="button" value="実行（非同期）" onclick="execute();">
    </body>
</html>

サーバサイドの「jssp_rpc_test/sample2.js」
function getObject( args ){

    // 受け取ったオブジェクトの内容を表示
    for(var prop in args){
        if (args.hasOwnProperty(prop)) {
            Debug.print(prop + " : " + args[prop] + " [" + typeof args[prop] + "]")
        }
    }

    // コールバック関数を確認するために遅延処理を入れています。（５秒間）
    Client.sleep(5 * 1000);

    // 受け取ったオブジェクトの内容を加工
    args.stringProp   = args.stringProp + " (modified !)";
    args.booleanProp  = false;
    args.numberProp   = args.numberProp + 10000;
    args.arrayProp[0] = args.arrayProp[0] + " (modified !)";
    args.arrayProp[1] = args.arrayProp[1] + " (modified !)";
    args.arrayProp[2] = args.arrayProp[2] + " (modified !)";
    args.dateProp.setFullYear(2100);
    args.dateProp     = args.dateProp;

    // 結果を返却
    return args;
}
バージョン：1.0
導入されたバージョン：6.1


 lineGraph タグ

<IMART type="lineGraph"> タグ。

折れ線グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 dataMax および 属性 dataMin に対しては、負数の値を指定することも出来ます。
必ず、（属性dataMin の値）＜（属性 dataMax の値）　となるように指定して下さい。
属性 dataMax および 属性 dataMin を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
dataMin | true | 目盛りの最小値
dataMax | true | 目盛りの最大値
scaleCount | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="lineGraph"
       data=oData
       imageWidth="300"
       imageHeight="300"
       dataMin="-10"
       dataMax="50"
       scaleCount="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     線の色
oData.aData[0].nWidth = 2;                                           //     線の幅
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     線の色
oData.aData[1].nStyle = new Array(10, 5);                            //     線の形状

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // 線の色（任意）
               ├ (number) nWidth           // 線の幅（任意）
               └ (number) nStyle[0...n]    // 線の形状（任意）［配列］

    sColor プロパティが未設定のとき、線の色にはデフォルト値（黒）が設定されます。
    nWidth プロパティが未設定のとき、線の幅にはデフォルト値（1）が設定されます。
    nStyle プロパティが未設定のとき、線の形状にはデフォルト値（実線）が設定されます。

    sColorプロパティには カラーチャート のカラー名を指定して下さい。

    nStyle プロパティは破線を引く時に使用します。
    破線のパターンを配列で指定することで、非透明の部分と透明の部分の長さを設定することができます。

    例１)
         oData.aData[0].nStyle[0] = 10;
         と指定した場合、破線パターンの指定が１つしかありませんので、
         表示される部分と表示されない部分がそれぞれ 10 のパターンが繰り返されます。

    例２)
         oData.aData[0].nStyle[0] = 10;
         oData.aData[0].nStyle[1] = 5;
         と指定した場合、破線パターンの指定が２つのため、
         表示される部分が 10 で、表示されない部分が 5 のパターンが繰り返されます。
バージョン：1.0
導入されたバージョン：5.0


 link タグ

<IMART type="link"> タグ。

アンカータグ(<A>)を生成します。
このタグを利用する事で intra-mart のセッションを維持しながらプログラムを 動作させる事が出来ます。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、ページ遷移をさせることができます。ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。
属性 label は、遷移ページ内の任意のアンカータグ(<A name="*">)の位置を初期表示位置として指定する事ができます。この指定はブラウザの機能を利用しているため、ブラウザ製品により期待通りに動作しない場合があります。
属性 action に関数名称を指定すると、このリンクにより intra-mart がコールされた際に、同ページの ファンクション・コンテナ内に定義されている関数をリクエスト時に起動します。
属性 action で指定された関数は、次に表示するべきページの作成処理(該当ページの ファンクション・コンテナ内 init() 関数)よりも先に動作します。
リンクの画面表示名称は、このタグに挟まれた範囲内の文字列になります。
その他、表示ページ(属性 page に指定しているプログラム)に対して引き渡す ＵＲＬ引数を、任意の個数だけ指定可能です。属性 page に指定されたページの ファンクション・コンテナ内 init() 関数または、属性 action で指定された関数では、関数引数として request を受け取る事が できます。その際、属性名称が引数 request オブジェクトのプロパティ名となり、 属性値が引数 request オブジェクトの該当プロパティに格納されます。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | true | 表示ページパス
label | false | リンクラベル
action | false | コール時起動関数(同ページ js 内)
その他 | false | 表示ページへ渡すＵＲＬ引数
使用例;
<IMART type="link" page="sample/next" action="chkValue">
次ページ
</IMART>
画面上には「次ページ」というリンクが表示されます。
このリンクをクリックしたら、このページのファンクション・コンテナ内に定義されている chkValue() 関数を起動した後に sample/next ページを読込＆実行して画面上には sample/next ページが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 loginUser タグ

<IMART type="loginUser"> タグ。

ログインしているユーザの情報を表示します。
表示できる情報は、ユーザID、ユーザ名、ユーザカナ表記、主所属です。
ユーザ名、ユーザカナ表記、主所属は属性(locale)にロケールを指定することで、指定したロケールで表示することができます。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
style | true | 表示タイプ。 （"name":ユーザ名） （"code":ユーザID） （"kana":ユーザカナ表記） （"attach":主所属）
locale | false | 表示ロケール。(String) 省略した場合は、ログインしているロケールが設定されます。 この属性は表示する情報が、ユーザ名、ユーザカナ表記、主所属の場合は、有効となります。
date | false | 情報を取得する対象の日付。(Date) 省略した場合は、現在の日付が設定されます。 この属性は表示する情報が、ユーザ名、ユーザカナ表記、主所属の場合は、有効となります。
separator | false | 主所属情報の区切り文字。(String) この属性は表示する情報が主所属の場合、有効となります。 省略した場合は、"/"が設定されます。
cache | false | 取得した情報をセッションに保管します。("true" または "false") ２回目以降セッションより情報を取得するようになります。 省略した場合は、"false"が設定されます。
使用例;
<IMART type="loginUser" style="name"></IMART>
このタグの位置にログインしているユーザのユーザ名を表示します。
<IMART type="loginUser" style="code"></IMART>
このタグの位置にログインしているユーザのユーザIDを表示します。
<IMART type="loginUser" style="kana"></IMART>
このタグの位置にログインしているユーザのカナ表記を表示します。
<IMART type="loginUser" style="attach"></IMART>
このタグの位置にログインしているユーザの主所属を表示します。
バージョン：1.0
導入されたバージョン：6.1


 loop タグ

<IMART type="loop"> タグ。

タグに挟まれている範囲内のソースを繰り返し処理します。
繰り返し処理は、属性 count に指定されている回数だけ行います。 (属性 count に、整数字列以外の指定がされた場合の動作は保証外。)
属性 index に、ファンクション・コンテナ内で定義してある変数名称を 指定する事で、何回目の繰り返しかを表す数値を受け取る事が出来ます。
(周回数は、0 から始まる整数値で、周回ごとに 1 ずつインクリメントされます。)
属性 action に対して、対応するファンクション・コンテナ内に定義されている 関数名称を文字列として指定すると、繰り返し処理毎に実行されます。
実行タイミングは、繰り返し処理の最初(タグに挟まれた範囲内の実行前)です。
指定関数は、繰り返し処理の開始から終了までに、繰り返し回数に 等しい回数だけ実行されます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
count | true | 繰り返し回数
index | true | 周回番号の通知先変数名
action | true | 繰り返し毎に動作する関数
使用例;
<IMART type="loop" count="5" index="loop_number">
<IMART type="string" value=loop_number></IMART> 回目<BR>
</IMART>
画面には、以下のように出力されます。
0 回目
1 回目
2 回目
3 回目
4 回目
この場合は、必ず５回の繰り返し処理が行われます。
繰り返し毎に、属性 index で指定したファンクション・コンテナ内の変数に対して、繰り返し回数 - 1 の値が設定されます。
上記例では、ファンクション・コンテナ内に定義されている loop_number という変数を通して <IMART type="string"> タグを用いて、動的に回数を表示しています。
バージョン：1.0
導入されたバージョン：2.0


 message タグ

<IMART type="message"> タグ。

タグの指定されている個所にメッセージIDで指定された文字列を挿入します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
id | true | メッセージID
locale | false | ロケール 指定したロケールのメッセージを取得します。 省略した場合は、ログインしているロケールが使用されます。
args | false | メッセージ引数 メッセージに置換用の定義がある場合、この引数の値に置換します。 文字列の配列で指定します。
使用例;
<IMART type="message" id="message-id"></IMART>
<IMART type="message" id="message-id" args=aryArgs ></IMART>
<IMART type="message" id="message-id" locale="ja"></IMART>
<IMART type="message" id="message-id" locale="ja" args=aryArgs ></IMART>
メッセージIDに紐付けられているメッセージを表示します。
バージョン：1.0
導入されたバージョン：6.1


 number タグ

<IMART type="number"> タグ。

タグの指定されている個所に指定の数値データを文字列として挿入します。
（実際には、タグ部分が指定文字列で置換されるように動作します。）
フォーマット文字列は ###,### のように指定して下さい。
format 属性指定時の仕様に関しては、intra-mart Function Container APIの Format.fromNumber() メソッドに準拠します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | 挿入する数値データ
format | true | 表現フォーマット指定文字列
使用例;
<IMART type="number" value=nMoney format="###,###"></IMART>
このタグの位置に「12,345」という形式で数値情報を表示します。
表示値は、ファンクション・コンテナから変数のバインドによって動的に指定します。
(バインド変数 nMoney に対して)
バージョン：1.0
導入されたバージョン：2.0


 picture タグ

<IMART type="picture"> タグ。

指定の画像ファイルを画面上に表示します。
表示するための画像ファイルは Storage Server に保存されている 必要があり、属性 src に対しては、Storage Server の storage/(標準) からの 相対でパス形式で指定します。 画像ファイルパスは拡張子まで完全な形で指定してください。
このタグでは、ファイルダウンロード機能を利用しています。ファイルダウンロード機能のＭＩＭＥ設定を適切におこなってください。
(標準で *.jpg, *.jpeg, *.gif ファイルに対応しています)
属性 src 以外は、<IMG> タグで利用可能な属性を任意に指定可能です。
(<IMG> タグの属性に関しては市販のＨＴＭＬリファレンスを参考にして下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
src | true | 画像ファイルのパス
その他 | false | <IMG> タグで指定可能な属性(複数指定可能)
使用例;
<IMART type="picture" src="picture/my_img.jpg" width="100%" height="100%"></IMART>
このタグの位置に Storage Server に保存されている画像ファイル storage/picture/my_img.jpg が表示されます。
属性 width および height を指定している事により、画像は縦横がフレームと同サイズで表示されます。
バージョン：1.0
導入されたバージョン：2.0


 portFolio タグ

<IMART type="portFolio"> タグ。

ポートフォリオ・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

属性 xDataSize には、横軸の中心値からのデータサイズを指定して下さい。
属性 yDataSize には、縦軸の中心値からのデータサイズを指定して下さい。
属性 xDataSize および yDataSize には負の値が指定されても、正の値として扱われます。

属性 scalePosition には、目盛りの表示位置を "center" か "side" で指定します。
未指定のときは、デフォルト位置（center:グラフの中心）に表示されます。

      center： グラフの中心（縦横軸に沿って）に表示
      side ： グラフの外枠に表示
その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
xCenterPoint | true | 横軸の中心値
xDataSize | true | 横軸の中心値からのデータサイズ
xScaleCount | true | 横軸１目盛りあたりの数
yCenterPoint | true | 縦軸の中心値
yDataSize | true | 縦軸の中心値からのデータサイズ
yScaleCount | true | 縦軸１目盛りあたりの数
scalePosition | false | 目盛りの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="portFolio"
       data=oData
       imageWidth="300"
       imageHeight="300"
       xCenterPoint="10"
       xDataSize="-10"
       xScaleCount="5"
       yCenterPoint="0"
       yDataSize="50"
       yScaleCount="10">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nXData = 5;                     //     グラフ横軸データ値
oData[0].nYData = -30;                   //     グラフ縦軸データ値
oData[0].sColor = "red";                 //     点の色
oData[0].nSize  = 10;                    //     点のサイズ

oData[1] = new Object();                 // データ２
oData[1].nXData = 15;                    //     グラフの横軸データ値
oData[1].nYData = 20;                    //     グラフの縦軸データ値
oData[1].sColor = "blue";                //     点の色
oData[1].nSize  = 10;                    //     点のサイズ

oData[2] = new Object();                 // データ３
oData[2].nXData = 18;                    //     グラフの横軸データ値
oData[2].nYData = -20;                   //     グラフの縦軸データ値

[data属性の構造]
    グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nXData                 // グラフ横軸値
         ├ (number) nYData                 // グラフ縦軸値
         ├ (String) sColor                 // 点の色（任意）
         └ (number) nSize                  // 点のサイズ（任意）

    sColor プロパティが未設定のとき、点の色にはデフォルト値（黒）が設定されます。
    nSize プロパティが未設定のとき、点のサイズにはデフォルト値（5）が設定されます。

    sColor プロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：5.0


 radarChart タグ

<IMART type="radarChart"> タグ。

レーダーチャート・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 dataMax および 属性 dataMin に対しては、負数の値を指定することも出来ます。
必ず　（属性dataMin の値）＜（属性 dataMax の値）　となるように指定して下さい。
属性 dataMax および 属性 dataMin を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)

属性 marginCaption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 marginCaption には、グラフの外枠点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
imageWidth | true | グラフ画像の幅
imageHeight | true | グラフ画像の高さ
dataMin | true | 目盛りの最小値
dataMax | true | 目盛りの最大値
marginCaption | false | キャプションの表示位置
scaleCount | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="radarChart"
       data=oData
       imageWidth="300"
       imageHeight="300"
       dataMin="-10"
       dataMax="50"
       marginCaption="120"
       scaleCount="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[0].bFill = true;                                         //     塗りつぶし可否
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // グラフの色（任意）
               └ (boolean) bFill           // 塗りつぶしの可否（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColor プロパティには カラーチャート のカラー名を指定して下さい。

    bFill プロパティはグラフの塗りつぶし可否を指定する時に使用します。
    bFill プロパティに対して true 値を指定したときは、グラフのデータ内部が塗りつぶされて表示され、
    false 値を指定したときは、グラフのデータ内部は塗りつぶされずに線のみで表示されます。
    bFill プロパティが未設定のとき、塗りつぶしの可否にはデフォルト値（false）が設定されます。
バージョン：1.0
導入されたバージョン：5.0


 repeat タグ

<IMART type="repeat"> タグ。

タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。
属性 list に指定されたオブジェクト(or 配列)の要素数に 等しい回数だけ繰り返し処理を実行します。
属性 item に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得したデータを代入します。
属性 index に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得したプロパティ名称(or 要素番号)を代入します。
属性 min に動作開始インデックスを指定した場合、それ以前に取得できた値は 無視されて、指定インデックス以降のデータのみを繰り返し処理の対象とします。
属性 min を未指定にした場合のデフォルト動作は、0 を指定した場合と同様です。
属性 max に動作終了インデックスを指定した場合、それ以後に取得できた値は 無視されて、指定インデックス以前のデータのみを繰り返し処理の対象とします。
属性 max を未指定にした場合のデフォルト動作は、list に渡されたオブジェクト内に格納されているデータのうち、順次取得可能な最終データまでが処理対象となります。
属性 action に対して、対応するファンクション・コンテナ内に定義されている関数名称を文字列として指定すると、繰り返し処理毎に実行されます。
関数の実行タイミングは、繰り返し処理の最初(タグに挟まれた範囲内の実行前)です。
指定関数は、繰り返し処理の開始から終了までに、繰り返し回数に 等しい回数だけ実行されます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
list | true | 繰り返し処理をするオブジェクト（または、配列）
item | true | 繰り返し処理中のオブジェクトの該当プロパティ値（または、繰り返し処理中の配列の該当要素）取得変数名
index | false | 繰り返し処理中のオブジェクトの該当プロパティ名称（または、繰り返し処理中の配列の該当要素番号）取得変数名
min | false | 繰り返し処理対象の最小要素番号
max | false | 繰り返し処理対象の最大要素番号
action | false | 繰り返し毎に動作する関数
使用例;
<IMART type="repeat" list=listObject item="record" index="idx">
<IMART type="string" value=idx></IMART> :
<IMART type="string" value=record></IMART><BR>
</IMART>
ファンクション・コンテナ側から変数 listObject によりバインドされたオブジェクトの中身を表示します。
画面上ではオブジェクト listObject の持つデータが『プロパティ名称 : 値』という組み合わせでオブジェクトの持つプロパティの数に等しい行数が表示されます。
バージョン：1.0
導入されたバージョン：2.0


 richtextarea タグ

<IMART type="richtextarea"> タグ。

フォーム内にリッチテキストエリアを表示します。
このタグはInternet Explorer6.0以降のみ動作します。
タグに挟まれた範囲内の文字列を初期表示文字列とします。

また、リッチテキストエリアの状態や表示内容は
JavaScript（クライアントサイド）を使用して操作することが出来ます。
JavaScriptメソッド一覧
void clearLocal(key)
指定されたキーでローカルに保存されているデータを消去します。
Boolean getEnabled()
リッチテキストエリアの有効/無効を取得します。
String getHTMLText()
リッチテキストエリアから文字装飾タグ付きのテキストを取得します。
String getLocalKeys()
ローカルに保存されているデータのキー一覧を取得します。
String getRestrict()
リッチテキストエリアに入力可能な文字列を取得します。
String getText()
リッチテキストエリアから文字装飾タグ無しのプレーンテキストを取得します。
void loadFromLocal(key)
指定されたキーでローカルに保存されているデータをリッチテキストエリアに読み込みます。
void saveToLocal(key)
リッチテキストエリアの入力内容を、指定されたキーでローカルに保存します。
void setBackGroundColor(color)
リッチテキストエリアの背景色を設定します。
void setEnabled(flg)
リッチテキストエリアの有効/無効を設定します。
void setHTMLText(value)
リッチテキストエリアに装飾付き文字列を表示します。
void setRestrict(value)
リッチテキストエリアに入力可能な文字列を設定します。
void setText(value)
リッチテキストエリアにプレーン文字列を表示します。
内部タグ:
テキストエリアに表示する文字列。
文字列は、以下のタグを使用して装飾することができます。

richtextareaで使用可能な文字装飾タグは一般的なHTMLタグと完全に互換性のあるものではありません。
richtextareaから生成した装飾つきの文字列を、そのままWebページに記述することは、サイズの違いや段落等がrichtextareaの表示と異なる場合があるため推奨されません。
タグ名 属性 説明
<a>
ハイパーリンクを作成します

href 読み込みを行うページのURLを指定します。（最大128文字）

target 読み込みを行うターゲットウィンドウを指定します。
<b>
テキストを太字で表示します。
<br>
改行を挿入します。
<font>
テキストのフォントやカラーおよびサイズを指定します。

color 16進数のカラーのみを指定します。

face 使用するフォントのフォント名を指定します。

size テキストのサイズを指定します。
<img>

画像(jpegのみ)またはムービー(swf)を埋め込みます。

src jpegまたはswfファイルのパスを指定します。

width 画像のピクセル単位の幅を指定します。

height 画像のピクセル単位の高さを指定します。

align 水平方向に対する表示位置を指定します。デフォルトはleftです。

hspace 画像の周囲の水平方向に対する余白を指定します。デフォルトは8です。

vspace 画像の周囲の垂直方向に対する余白を指定します。デフォルトは8です。
<i>
テキストを斜体で表示します。
<li>
テキストをリストで表示します。
<p>
段落を挿入します。
<textformat>
段落のフォーマットを指定します。

blockindent

段落の最初の行のインデントをピクセル単位で指定します。

indent 段落全体のインデントをピクセル単位で指定します。

leading 行間を大きさを指定します。

leftmargin 左側の余白をピクセル単位で指定します。

rigntmargin 右側の余白をピクセル単位で指定します。

tabstops タブの間隔をピクセル単位で指定します。
<u>
下線付きのテキストを表示します。
属性一覧
属性名 | 必須 | 説明
name | true | リッチテキストエリアの名前
width | false | リッチテキストエリアの幅(※280以上を推奨)
height | false | リッチテキストエリアの高さ(※135以上を推奨)
toolbarcolor | false | ツールバー領域の背景色 デフォルトは白(#FFFFFF)
disabled | false | リッチテキストエリアの有効(false)/無効(true) デフォルトは有効(true)
restrict | false | リッチテキストエリアに入力可能な文字列。指定された文字列以外の入力ができなくなります。 この属性で指定された値は、内部的にFlashのコンポーネントに渡されます。 指定方法の詳細は、次のリンクを参照してください。 http://livedocs.adobe.com/flash/9.0_jp/ActionScriptLangRefV3/flash/text/TextField.html#restrict
backgroundColor | false | テキストエリア領域の背景色 デフォルトは白(#FFFFFF)
使用例;
<IMART type="form" name="frm">
<IMART type="richtextarea" name="tarea" width="400" height="300" restrict="A-Za-z0-9\\-" >
<a href="http://www.intra-mart.jp">intra-mart</a><br>
<font color="#FF00FF" size="18">intra-mart</font><br>
<b>intra-mart</b><br>
</IMART>
</IMART>
<script language="javascript">
function sampleFunc() {
document.frm.tarea.setHTMLText('<i>SAMPLE</i>');
}
</script>
画面上に幅400、高さ300のリッチテキストエリアを１つ表示します。
name属性を"tarea"に設定し、半角英数字と半角ハイフン以外の入力を受け付けないようにします。
ハイパーリンク、カラーとサイズ、ボールドをそれぞれ指定した文字列を初期表示します。
定義されたメソッド(sampleFunc)を実行すると、リッチテキストエリア(tarea)に斜体の文字列が表示されます。
バージョン：1.0
導入されたバージョン：6.0


 select タグ

<IMART type="select"> タグ。

フォーム内にコンボボックス（またはリストボックス）を表示します。
属性 list に対しては、オブジェクトを指定して下さい。
属性 list に指定したオブジェクトに格納されているすべての値が、コンボボックス内の表示要素になります。
属性 list に指定されたオブジェクトのプロパティ名がコンボボックス内の各要素(<OPTION> タグ)の value 値になり、該当するプロパティに格納されている値がコンボボックス内の要素の画面上での表示名になります。
(オブジェクトに格納されている値が文字列以外の場合の動作は保証外。)
属性 selected には、コンボボックスの初期選択(初期表示)値を指定します。
初期選択状態にする値のキー(属性 list に指定したオブジェクトの該当するプロパティ名)を指定することで、初期選択状態にすることができます。
属性 select に指定した値に該当するキーが属性 list に指定したオブジェクトのプロパティとして存在しない場合は、どの値も選択状態にはなりません。
(ただし、コンボボックスの初期選択指定が存在しない場合は、ブラウザの仕様で自動的にコンボボックス内の先頭の要素が初期選択状態として表示されます。)
また、初期選択状態とするキーを同時に複数個指定する場合は、属性 selected に対して配列を指定する事で可能になります。
その際、配列内の各要素の値として、初期選択状態にするキー(属性 list に指定したオブジェクトの該当するプロパティ名)を格納してください。
属性 blank は、コンボボックス内の任意の位置に空データを表示させるための属性指定になります。
値としてキーワード "top" を指定するとボックス内の先頭位置に空データが表示され、
キーワード "bottom" を指定するとボックス内の最後尾位置に空データが表示されます。
上記以外の属性を指定した場合、それらは <SELECT> タグの各属性として出力されます。
(<SELECT> タグの仕様に関しては市販のＨＴＭＬリファレンスを参照して下さい)。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
list | true | 表示リストの配列
selected | false | 初期選択値の設定
blank | false | キーワードの示す位置へブランクデータを挿入
その他 | false | <SELECT>タグ内に指定する各属性値
使用例;
<IMART type="form">
<IMART type="select" list=list_object></IMART>
<IMART type="select" list=list_object size="4"></IMART>
</IMART>
画面には、コンボボックスとリストボックスが表示されます。
ボックス内には、ファンクション・コンテナ内で作成された変数 list_objectオブジェクト内のデータが表示されます。
バージョン：1.0
導入されたバージョン：2.0


 string タグ

<IMART type="string"> タグ。

タグの指定されている個所に指定のデータを文字列として挿入 （実際には、タグ部分が指定文字列で置換されるように動作）します。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
value | true | 挿入データ
使用例;
<IMART type="string" value="ABC"></IMART>
このタグの位置に「ABC」と表示します。
表示値は、ファンクション・コンテナから変数のバインドによって動的な指定も可能です。
バージョン：1.0
導入されたバージョン：2.0


 submit タグ

<IMART type="submit"> タグ。

サブミットボタンを表示します。
属性 page に対して次に表示させたいプログラムパス（拡張子なし）を指定する ことで、ページを表示させることができます。
ここで指定するパスは、インストールディレクトリ/pages/ からの相対パス形式になります。
また、<IMART type="form"> にて page 属性が指定されていて遷移ページ先の 指定要求が重複した場合、<IMART type="submit"> で指定した page 指定が 優先され、<IMART type="form"> で指定した page 指定は無視されます。
属性 action は、このリンクにより intra-mart がコールされた際に、同ページの ファンクション・コンテナ内に定義されている関数をリクエスト時に起動するため の指定で、起動させたい関数名称を指定する事で可能になります。
action 関数の実行は、次に表示するべきページの作成処理(該当ページの ファンクション・コンテナ内 init() 関数)よりも先に動作します。
また、<IMART type="form"> にて action 属性が指定されていて関数実行要求が 重複した場合、<IMART type="submit"> で指定した action 関数が優先的に 実行され、<IMART type="form"> で指定した action 関数の実行要求は無視されます。
この <IMART type="submit"> は、１つのフォーム内に複数の配置が可能であり、 その際に指定した page および action 指定は、クリックされたサブミットボタン に対して個々に指定可能で、独立した動作をします。
なお、このタグは HTML の <INPUT type="submit"> の name 属性を利用して制御を行っています。 したがって、任意属性として name を記述した場合、 画面遷移や関数実行指定等が正常に動作しなくなります。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
page | false | リクエスト後の遷移先ページパス
action | false | リクエスト時の起動関数名
その他 | false | タグ属性と属性値
使用例;
<IMART type="form" action="form_action" page="sample/form_next">
<INPUT type="submit" value="submit_0">
<IMART type="submit" value="submit_1"></IMART>
<IMART type="submit" value="submit_2" action="sub_action_2"></IMART>
<IMART type="submit" value="submit_3" action="sub_action_3" page="sample/sub_next"></IMART>
</IMART>
画面には「submit_0」「submit_1」「submit_2」および「submit_3」という表示名称のサブミットボタンが４つ表示されます。
「submit_0」をクリックした場合は、ファンクション・コンテナ内のform_action() 関数を実行した後に sample/form_next というページを表示します。
「submit_1」をクリックした場合は、「submit_0」をクリックした場合と同様の動作をします。 「submit_2」をクリックした場合は、ファンクション・コンテナ内のsub_action_2() 関数を実行した後に sample/form_next というページを表示します。
「submit_3」をクリックした場合は、ファンクション・コンテナ内のsub_action_3() 関数を実行した後に sample/sub_next というページを表示します。
バージョン：1.0
導入されたバージョン：2.0


 tag タグ

<IMART type="tag"> タグ。

任意のタグを生成します。
属性 name には、目的のタグ名称を文字列として指定します。
(属性 name に対して、文字列型以外の値が指定された場合の動作は保証外。)
その他の属性は、そのまま、生成される任意タグの属性値となります。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | タグ名称
その他 | false | タグ属性と属性値
使用例;
<IMART type="tag" name="FONT" color="red">赤い文字</IMART>
画面には「赤い文字」という文字列が赤色で表示されます。
上記スクリプトで生成されるＨＴＭＬソースは以下のようになります。
<FONT color="red">赤い文字</FONT>
バージョン：1.0
導入されたバージョン：2.0


 textarea タグ

<IMART type="textarea"> タグ。

フォーム内にテキストエリアを表示します。 属性 value に対して指定した文字列を初期表示文字列とします。
(属性 value に対して文字列以外の値を指定した場合の動作は保証外。)
その他のタグ属性は、そのまま <TEXTAREA> タグの属性として指定されます。
(<TEXTAREA> タグの仕様に関しては、ＨＴＭＬリファレンスを参照下さい。)
タグに挟まれた範囲内に文字列を指定すると、テキストエリアの初期表示値とすることができます。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
value | true | テキストエリアに対する初期表示値(文字列)
その他 | false | タグ属性と属性値
使用例;
<IMART type="form">
<IMART type="textarea" value="バインド値"></IMART>
<IMART type="textarea">定数値</IMART>
</IMART>
画面には、２つのテキストエリアが表示されます。
一つは、テキストエリア内に「バインド値」という文字列が初期表示されます。
もう一つは、「定数値」という文字列が初期表示されます。
バージョン：1.0
導入されたバージョン：2.0


 back_to_menu タグ

奨励されていません。backToMenu タグに置き換えられました。
<IMART type="back_to_menu"> タグ。

アンカータグ(<A>)によるリンクを生成します。
このタグは、モバイル用画面作成時専用ＡＰＩです。
内部タグ:
IMARTタグおよびHTML
使用例;
<IMART type="back_to_menu">[MENU]</IMART>
画面上には「[MENU]」というリンクが表示されます。
このリンクをクリックしたら、メニュー画面が表示されます。
バージョン：1.0
導入されたバージョン：2.0


 bar_graph タグ

奨励されていません。barGraph タグに置き換えられました。
<IMART type="bar_graph"> タグ。

棒グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 data_max および 属性 data_min に対しては、負数の値を指定することも出来ます。
必ず　（属性data_min の値）＜（属性 data_max の値）　となるように指定して下さい。
属性 data_max および 属性 data_min を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
data_min | true | 目盛りの最小値
data_max | true | 目盛りの最大値
scale_count | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="bar_graph"
       data=oData
       image_width="300"
       image_height="300"
       data_min="-10"
       data_max="50"
       scale_count="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色
oData.aData[2] = new Object();                                       // データ３
oData.aData[2].aData = new Array(20, 30, 50, 25, 45);                //     グラフデータ値
oData.aData[2].sColor = "green";                                     //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               └ (String) sColor           // グラフの色（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColorプロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 cal_view タグ

奨励されていません。calendar タグに置き換えられました。
<IMART type="cal_view"> タグ。

カレンダー画面ＨＴＭＬソースを作成します。
group にはデータカテゴリＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式

click_action 属性は必ず“正しく”指定します。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキックされた時にコールされる。
その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報(1 - 12)
第6引数 | Number | クリックされた日情報

注意事項：
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
初期データインポートで設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。

なお、カレンダー画面の表示は、<IMART type="link"> タグを利用する方法もあります。
詳しくは、APIリスト [ページベース開発モデル]-[ユニット]-[カレンダー表示モジュール] を参照してください。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
year | true | 作成するカレンダーの年
month | true | 作成するカレンダーの月(1 - 12)
group | false | カレンダー作成時に利用するデータカテゴリ
format | false | 使用するフォーマットファイルの指定
click_action | false | 日リンクのクリック時に実行する関数名
使用例;
１９９９年５月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<IMART type="cal_view" year="1999"
month="5"
click_action="click_date">
</IMART>
バージョン：1.0
導入されたバージョン：2.0


 circle_graph タグ

奨励されていません。circleGraph タグに置き換えられました。
<IMART type="circle_graph"> タグ。

円グラフの描画を行います。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
属性 margin_caption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 margin_caption には、グラフの中心点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
margin_caption | false | キャプションの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="circle_graph"
       data=oData
       image_width="300"
       image_height="300"
       margin_caption="60">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nData      = 500;               //     グラフデータ値
oData[0].sColor     = "red";             //     グラフの色
oData[0].sCaption   = "自動車";          //     キャプション文字列
oData[0].sFontColor = "pink";            //     キャプション文字色
oData[0].nFontSize  = 15;                //     キャプション文字サイズ
oData[1] = new Object();                 // データ２
oData[1].nData      = 400;               //     グラフデータ値
oData[1].sColor     = "blue";            //     グラフの色
oData[1].sCaption   = "工業機械"         //     キャプション文字列
oData[1].sFontColor = "skyblue";         //     キャプション文字色
oData[1].nFontSize  = 15;                //     キャプション文字サイズ
oData[2] = new Object();                 // データ３
oData[2].nData      = 300;               //     グラフデータ値
oData[2].sColor     = "green";           //     グラフの色
oData[2].sCaption   = "精密機械"         //     キャプション文字列
oData[2].nFontSize  = 15;                //     キャプション文字サイズ
oData[3] = new Object();                 // データ４
oData[3].nData      = 250;               //     グラフデータ値
oData[3].sColor     = "yellow";          //     グラフの色
oData[3].sCaption   = "家電"             //     キャプション文字列
oData[3].nFontSize  = 15;                //     キャプション文字サイズ

[data属性の構造]
    円グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nData                  // グラフ値
         ├ (String) sColor                 // グラフの色
         ├ (String) sCaption               // 項目に表示するキャプションの文字列
         ├ (String) sFontColor             // キャプションの文字色（任意）
         └ (number) nFontSize              // キャプションの文字サイズ（任意）

    sColor プロパティが未設定のとき、該当するデータのグラフ色は無色で表示されます。
    sFontColor プロパティが未設定のとき、キャプション文字色にはデフォルト値（黒）が設定されます。
    nFontSize プロパティが未設定のとき、キャプション文字サイズにはデフォルト値（15）が設定されます。

    sColor または sFontColor プロパティには カラーチャートのカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 line_graph タグ

奨励されていません。lineGraph タグに置き換えられました。
<IMART type="line_graph"> タグ。

折れ線グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 data_max および 属性 data_min に対しては、負数の値を指定することも出来ます。
必ず、（属性data_min の値）＜（属性 data_max の値）　となるように指定して下さい。
属性 data_max および 属性 data_min を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
data_min | true | 目盛りの最小値
data_max | true | 目盛りの最大値
scale_count | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="line_graph"
       data=oData
       image_width="300"
       image_height="300"
       data_min="-10"
       data_max="50"
       scale_count="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     線の色
oData.aData[0].nWidth = 2;                                           //     線の幅
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     線の色
oData.aData[1].nStyle = new Array(10, 5);                            //     線の形状

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // 線の色（任意）
               ├ (number) nWidth           // 線の幅（任意）
               └ (number) nStyle[0...n]    // 線の形状（任意）［配列］

    sColor プロパティが未設定のとき、線の色にはデフォルト値（黒）が設定されます。
    nWidth プロパティが未設定のとき、線の幅にはデフォルト値（1）が設定されます。
    nStyle プロパティが未設定のとき、線の形状にはデフォルト値（実線）が設定されます。

    sColorプロパティには カラーチャート のカラー名を指定して下さい。

    nStyle プロパティは破線を引く時に使用します。
    破線のパターンを配列で指定することで、非透明の部分と透明の部分の長さを設定することができます。

    例１)
         oData.aData[0].nStyle[0] = 10;
         と指定した場合、破線パターンの指定が１つしかありませんので、
         表示される部分と表示されない部分がそれぞれ 10 のパターンが繰り返されます。

    例２)
         oData.aData[0].nStyle[0] = 10;
         oData.aData[0].nStyle[1] = 5;
         と指定した場合、破線パターンの指定が２つのため、
         表示される部分が 10 で、表示されない部分が 5 のパターンが繰り返されます。
バージョン：1.0
導入されたバージョン：4.0


 port_folio タグ

奨励されていません。portFolio タグに置き換えられました。
<IMART type="port_folio"> タグ。

ポートフォリオ・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）

属性 x_data_size には、横軸の中心値からのデータサイズを指定して下さい。
属性 y_data_size には、縦軸の中心値からのデータサイズを指定して下さい。
属性 x_data_size および y_data_size には負の値が指定されても、正の値として扱われます。

属性 scale_position には、目盛りの表示位置を "center" か "side" で指定します。
未指定のときは、デフォルト位置（center:グラフの中心）に表示されます。

      center： グラフの中心（縦横軸に沿って）に表示
      side ： グラフの外枠に表示
その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
x_center_point | true | 横軸の中心値
x_data_size | true | 横軸の中心値からのデータサイズ
x_scale_count | true | 横軸１目盛りあたりの数
y_center_point | true | 縦軸の中心値
y_data_size | true | 縦軸の中心値からのデータサイズ
y_scale_count | true | 縦軸１目盛りあたりの数
scale_position | false | 目盛りの表示位置
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="port_folio"
       data=oData
       image_width="300"
       image_height="300"
       x_center_point="10"
       x_data_size="-10"
       x_scale_count="5"
       y_center_point="0"
       y_data_size="50"
       y_scale_count="10">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();

oData = new Array();
oData[0] = new Object();                 // データ１
oData[0].nXData = 5;                     //     グラフ横軸データ値
oData[0].nYData = -30;                   //     グラフ縦軸データ値
oData[0].sColor = "red";                 //     点の色
oData[0].nSize  = 10;                    //     点のサイズ

oData[1] = new Object();                 // データ２
oData[1].nXData = 15;                    //     グラフの横軸データ値
oData[1].nYData = 20;                    //     グラフの縦軸データ値
oData[1].sColor = "blue";                //     点の色
oData[1].nSize  = 10;                    //     点のサイズ

oData[2] = new Object();                 // データ３
oData[2].nXData = 18;                    //     グラフの横軸データ値
oData[2].nYData = -20;                   //     グラフの縦軸データ値

[data属性の構造]
    グラフのデータ数分、data属性のObjectを配列（0 - n）で指定します。

      data属性 Object[]
         ├ (number) nXData                 // グラフ横軸値
         ├ (number) nYData                 // グラフ縦軸値
         ├ (String) sColor                 // 点の色（任意）
         └ (number) nSize                  // 点のサイズ（任意）

    sColor プロパティが未設定のとき、点の色にはデフォルト値（黒）が設定されます。
    nSize プロパティが未設定のとき、点のサイズにはデフォルト値（5）が設定されます。

    sColor プロパティには カラーチャート のカラー名を指定して下さい。
バージョン：1.0
導入されたバージョン：4.0


 radar_chart タグ

奨励されていません。radarChart タグに置き換えられました。
<IMART type="radar_chart"> タグ。

レーダーチャート・グラフ画像を表示します。
属性 data に指定したデータを利用してグラフをブラウザ上に描画します。
属性 data には、オブジェクトデータを指定して下さい。
（属性 data の設定方法に関しては、下記の使用例を参照して下さい。）
属性 data_max および 属性 data_min に対しては、負数の値を指定することも出来ます。
必ず　（属性data_min の値）＜（属性 data_max の値）　となるように指定して下さい。
属性 data_max および 属性 data_min を未指定にすると、グラフ結果が正しく表示されません。

その他の属性には、 <IMG> タグに指定可能なオプション属性を任意に指定する事が出来ます。
(<IMG> タグの仕様に関しては、市販のＨＴＭＬリファレンスを参照下さい。)

属性 margin_caption を指定すると、キャプションの表示位置を変更することが出来ます。
属性 margin_caption には、グラフの外枠点からのマージンを指定して下さい。
内部タグ:
なし
属性一覧
属性名 | 必須 | 説明
data | true | グラフの各種値 -- 詳細は［使用例］を参照
image_width | true | グラフ画像の幅
image_height | true | グラフ画像の高さ
data_min | true | 目盛りの最小値
data_max | true | 目盛りの最大値
margin_caption | false | キャプションの表示位置
scale_count | true | １目盛りあたりの数
marginTop | false | グラフ上部のマージン
marginRight | false | グラフ右側のマージン
marginBottom | false | グラフ下部のマージン
marginLeft | false | グラフ左側のマージン
その他 | false | <IMG> タグで指定可能な各オプション属性(複数指定可)
使用例;
<IMART type="radar_chart"
       data=oData
       image_width="300"
       image_height="300"
       data_min="-10"
       data_max="50"
       margin_caption="120"
       scale_count="20">
</IMART>

ファンクションコンテナからバインドされたオブジェクトデータ oData により
グラフをブラウザ画面上に描画します。
グラフのデータは、ファンクションコンテナ内で以下のようにして作成します。

var oData = new Object();
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月");  // キャプション値
oData.aData = new Array();
oData.aData[0] = new Object();                                       // データ１
oData.aData[0].aData = new Array(10, 20, 30, 45, 40);                //     グラフデータ値
oData.aData[0].sColor = "red";                                       //     グラフの色
oData.aData[0].bFill = true;                                         //     塗りつぶし可否
oData.aData[1] = new Object();                                       // データ２
oData.aData[1].aData = new Array(5, -5, 10, 15, 10);                 //     グラフデータ値
oData.aData[1].sColor = "blue";                                      //     グラフの色

[data属性の構造]
      data属性 Object
         ├ (String) aCaption[0...n]        // 各値に対応するキャプション［配列］
         └ (Object) aData[0...n]           // グラフ情報Object［配列］
               ├ (number) aData[0...n]     // グラフ値［配列］
               ├ (String) sColor           // グラフの色（任意）
               └ (boolean) bFill           // 塗りつぶしの可否（任意）

    sColor プロパティが未設定のとき、グラフの色にはデフォルト値（黒）が設定されます。
    sColor プロパティには カラーチャート のカラー名を指定して下さい。

    bFill プロパティはグラフの塗りつぶし可否を指定する時に使用します。
    bFill プロパティに対して true 値を指定したときは、グラフのデータ内部が塗りつぶされて表示され、
    false 値を指定したときは、グラフのデータ内部は塗りつぶされずに線のみで表示されます。
    bFill プロパティが未設定のとき、塗りつぶしの可否にはデフォルト値（false）が設定されます。
バージョン：1.0
導入されたバージョン：4.0


 approve タグ

<IMART type="approve"> タグ。

ワークフロー標準の審議画面へ遷移するためのフォームタグ（<FORM>）を生成します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | HTMLにおけるFORMタグのname属性
method | false | HTMLにおけるFORMタグのmethod属性
target | false | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | プロセス定義コード(必須)
bpw_version_cd | true | バージョンコード(必須)
bpw_process_cd | true | プロセスコード(必須)
bpw_activity_cd | true | アクティビティコード(必須)
bpw_app_type | false | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | 代理元ユーザコード(任意)
callBackApplicationId | false | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | 審議時に実行するプログラムパス(任意)
refreshFlg | false | 審議画面を初期化するフラグ(任意) "true"が指定された場合に、審議画面の項目の値を初期化して表示します。
attr | false | <Form>タグに指定する属性(任意)
使用例;
画面上にはサブミットボタンが表示されます。
このボタンをクリックしたら、ワークフロー標準の申請画面に遷移します。
バージョン：1.0
導入されたバージョン：6.1


 draft タグ

<IMART type="draft"> タグ。

ワークフロー標準の申請画面へ遷移するためのフォームタグ（<FORM>）を生成します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | HTMLにおけるFORMタグのname属性
method | false | HTMLにおけるFORMタグのmethod属性
target | false | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | プロセス定義コード(必須)
bpw_version_cd | true | バージョンコード(必須)
bpw_activity_cd | true | アクティビティコード(必須)
bpw_app_type | false | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | 代理元ユーザコード(任意)
bpw_parameter_cds | true | ユーザアプリケーションキー(必須)
bpw_draft_appoint_date | false | 起票指定日(任意：未指定時は起票日と同日)
locale | false | ロケール(任意：未指定はデフォルトロケールを使用)
callBackApplicationId | false | 遷移画面からの戻り先アプリケーションID(任意)
callBackServiceId | false | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | 申請処理時に実行するプログラムパス(任意)
refreshFlg | false | 申請画面を初期化するフラグ(任意) "true"が指定された場合に、申請画面の項目の値を初期化して表示します。
attr | false | <Form>タグに指定する属性(任意)
使用例;
画面上にはサブミットボタンが表示されます。
このボタンをクリックしたら、ワークフロー標準の申請画面に遷移します。
バージョン：1.0
導入されたバージョン：6.1


 IMART タグ リスト

<IMART> タグＡＰＩ仕様
1. | <IMART> タグは、必ず </IMART> と１対１の関係になるように記述しなければなりません（ </IMART> を未記述時の動作は未定義）。
2. | <IMART> タグ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
3. | <IMART> タグ内に定義する各属性名、および属性値は、大文字・小文字を厳密に判定します。
4. <IMART> タグ内に定義する属性値は、" (ダブルクォート)で囲む事で定数値として扱われます。
(定数値バインド機能(アプリケーション共通モジュール Imart.defineAttribute() を参照)を利用している場合には、定数値バインド機能で定義されている値への変換対象としてみなされます。)

逆に、" (ダブルクォート)で囲まない場合には、対応するファンクション・コンテナ内に宣言された変数、または関数へのバインド対象として実行されます。
5. <IMART> タグ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
6. プレゼンテーション・ページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内の <IMART> は実行されません。)


IMART タグ リスト

 IMART タグ

表示系タグ

制御系タグ

リクエスト系タグ
approve
draft
retry
subDraft

レスポンス系タグ

コントロール系タグ

グラフ描画系タグ

モバイル系タグ


 retry タグ

<IMART type="retry"> タグ。

ワークフロー標準の再申請画面へ遷移するためのフォームタグ（<FORM>）を生成します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | HTMLにおけるFORMタグのname属性
method | false | HTMLにおけるFORMタグのmethod属性
target | false | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | プロセス定義コード(必須)
bpw_version_cd | true | バージョンコード(必須)
bpw_process_cd | true | プロセスコード(必須)
bpw_activity_cd | true | アクティビティコード(必須)
bpw_app_type | false | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | 代理元ユーザコード(任意)
bpw_parameter_cds | true | ユーザアプリケーションキー(必須)
locale | false | ロケール(任意：未指定はデフォルトロケールを使用)
callBackApplicationId | false | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | 再申請処理時に実行するプログラムパス(任意)
refreshFlg | false | 再申請画面を初期化するフラグ(任意) "true"が指定された場合に、再申請画面の項目の値を初期化して表示します。
attr | false | <Form>タグに指定する属性(任意)
使用例;
画面上にはサブミットボタンが表示されます。
このボタンをクリックしたら、ワークフロー標準の再申請画面に遷移します。
バージョン：1.0
導入されたバージョン：6.1


 subDraft タグ

<IMART type="subDraft"> タグ。

ワークフロー標準のサブプロセス申請画面へ遷移するためのフォームタグ（<FORM>）を生成します。
内部タグ:
IMARTタグおよびHTML
属性一覧
属性名 | 必須 | 説明
name | true | HTMLにおけるFORMタグのname属性
method | false | HTMLにおけるFORMタグのmethod属性
target | false | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | プロセス定義コード(必須)
bpw_version_cd | true | バージョンコード(必須)
bpw_process_cd | true | プロセスコード(必須)
bpw_activity_cd | true | アクティビティコード(必須)
bpw_app_type | false | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | 代理元ユーザコード(任意)
bpw_parameter_cds | true | ユーザアプリケーションキー(必須)
callBackApplicationId | false | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | サブプロセスの申請時に実行するプログラムパス(任意)
refreshFlg | false | サブプロセスの申請画面を初期化するフラグ(任意) "true"が指定された場合に、サブプロセスの申請画面の項目の値を初期化して表示します。
attr | false | <Form>タグに指定する属性(任意)
使用例;
画面上にはサブミットボタンが表示されます。
このボタンをクリックしたら、ワークフロー標準のサブプロセス申請画面に遷移します。
バージョン：1.0
導入されたバージョン：6.1


クラス jp.co.intra_mart.common.platform.util.DateUtil の使用 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.util.DateUtil の使用

jp.co.intra_mart.common.platform.util.DateUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.platform.util.NameUtil の使用 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.util.NameUtil の使用

jp.co.intra_mart.common.platform.util.NameUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DateUtil (im_commons 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.util
クラス DateUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.util.DateUtil
public class DateUtil
extends Object

日付操作ユーティリティクラスです。

日付に関する操作をするためのユーティリティクラスです。
このクラスのメソッドはすべてstaticメソッドとなっています。
このクラスのインスタンスを生成することはできません。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static Date | convertOnlyDate(Date date) 日付のみのjava.util.Dateに変換します。
static Date | convertOnlyDate(long date) 日付のみのjava.util.Dateに変換します。
static Date | convertOnlyDateTime(Date date) 日付と時刻のみのjava.util.Dateに変換します。
static Date | convertOnlyDateTime(long date) 日付と時刻のみのjava.util.Dateに変換します。
static String | dateToString(Date date) データベース登録用文字列を取得します。
static Date | getMaxDate() システムで許可されている最大日時を取得します。
static Date | getMinDate() システムで許可されている最小日時を取得します。
static Date | stringToDate(String dateString) データベース登録用文字列からjava.util.Dateを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

dateToString

public static String dateToString(Date date)
データベース登録用文字列を取得します。

パラメータ:
date - 変換元のDateオブジェクト
戻り値:
データベース登録用文字列(YYYY/MM/DD|hh:mm:ss)

stringToDate

public static Date stringToDate(String dateString)
データベース登録用文字列からjava.util.Dateを取得します。

パラメータ:
dateString - 変換元のデータベース登録用文字列(YYYY/MM/DD|hh:mm:ss)
年月日のみ(YYYY/MM/DD形式)で指定した場合、YYYY/MM/DD|00:00:00として変換します。
戻り値:
Dateオブジェクト

convertOnlyDate

public static Date convertOnlyDate(long date)
日付のみのjava.util.Dateに変換します。

時刻は、00:00:00.000に設定されます。

パラメータ:
date - 1970 年 1 月 1 日 00:00:00 GMT からのミリ秒数
戻り値:
日付のみのjava.util.Date

convertOnlyDate

public static Date convertOnlyDate(Date date)
日付のみのjava.util.Dateに変換します。

時刻は、00:00:00.000に設定されます。

パラメータ:
date - 日付
戻り値:
日付のみのjava.util.Date

convertOnlyDateTime

public static Date convertOnlyDateTime(long date)
日付と時刻のみのjava.util.Dateに変換します。

ミリ秒の単位は 0 に設定されます。

パラメータ:
date - 1970 年 1 月 1 日 00:00:00 GMT からのミリ秒数
戻り値:
日付と時刻のみのjava.util.Date

convertOnlyDateTime

public static Date convertOnlyDateTime(Date date)
日付と時刻のみのjava.util.Dateに変換します。

ミリ秒の単位は 0 に設定されます。

パラメータ:
date - 日付
戻り値:
日付と時刻のみのjava.util.Date

getMinDate

public static Date getMinDate()
システムで許可されている最小日時を取得します。

戻り値:
システムで許可されている最小日時

getMaxDate

public static Date getMaxDate()
システムで許可されている最大日時を取得します。

戻り値:
システムで許可されている最大日時
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NameUtil (im_commons 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.util
クラス NameUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.util.NameUtil
public class NameUtil
extends Object

名前に関連するユーティリティです。

導入されたバージョン:
5.0

コンストラクタの概要
NameUtil()
メソッドの概要
static boolean | isNameChar(char chr) 指定された文字が英数字またはアンダーバーまたはピリオドであるかどうかを判断します。
static boolean | isValidApplicationName(String name) 指定された文字列がアプリケーション名として正しいかどうかを判定します。
static boolean | isValidName(String name) 指定された文字列が名前として妥当かどうか判定します。
static boolean | isValidPath(String path) 指定された文字列がパスとして妥当かどうか判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NameUtil

public NameUtil()
メソッドの詳細

isValidApplicationName

public static boolean isValidApplicationName(String name)
指定された文字列がアプリケーション名として正しいかどうかを判定します。

パラメータ:
name - 判定対象の文字列
戻り値:
判定結果

isNameChar

public static boolean isNameChar(char chr)
指定された文字が英数字またはアンダーバーまたはピリオドであるかどうかを判断します。

パラメータ:
chr - 判定対象の文字
戻り値:
英数字またはアンダーバーの場合true、その他の場合はfalse

isValidName

public static boolean isValidName(String name)
指定された文字列が名前として妥当かどうか判定します。 以下の文字列のみを含むもの名前として妥当であると判断されます。
  • 英数字
  • アンダーバー（"_"）

パラメータ:
name - 文字列
戻り値:
文字列が名前として妥当な場合true、それ以外の場合はfalse

isValidPath

public static boolean isValidPath(String path)
指定された文字列がパスとして妥当かどうか判定します。 以下の条件をすべて満たす場合、パスとして妥当であると判断されます。
  • スラッシュ（"/"）から始まる
  • isValidName(String)を満たす文字列で終了する、またはスラッシュ一文字のみである
  • スラッシュとスラッシュの間の文字列はisValidName(String)を満たす

パラメータ:
path - 文字列
戻り値:
文字列がパスとして妥当な場合true、それ以外の場合はfalse
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.platform.util (im_commons 6.1.14 API)

 jp.co.intra_mart.common.platform.util
クラス
DateUtil
NameUtil


jp.co.intra_mart.common.platform.util (im_commons 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

参照:
説明

クラスの概要
DateUtil | 日付操作ユーティリティクラスです。
NameUtil | 名前に関連するユーティリティです。

パッケージ jp.co.intra_mart.common.platform.util の説明

このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.platform.util クラス階層 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.util.DateUtil
    • class jp.co.intra_mart.common.platform.util.NameUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.platform.util の使用 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.platform.util の使用

jp.co.intra_mart.common.platform.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.platform.vm.CommandLineArgument の使用 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.platform.vm.CommandLineArgument の使用

jp.co.intra_mart.common.platform.vm.CommandLineArgument はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CommandLineArgument (im_commons 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.platform.vm
クラス CommandLineArgument

java.lang.Object
    拡張 jp.co.intra_mart.common.platform.vm.CommandLineArgument
public class CommandLineArgument
extends Object

このクラスはコマンド実引数を解釈するための共通実装です。

このクラスは、インスタンス生成時にコマンドライン引数を解析し、 オプションと引数に選別します。 コマンド [-オプション名 [値]] [引数] オプションは "-" から始まる名称文字列と値から成り立ちます。 最後尾のオプション指定以降のトークンを引数として解釈します。 オプションはオプション名("-" から始まるトークン)をキーとして 値がマッピングされます。

コンストラクタの概要
CommandLineArgument(String[] args)
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
メソッドの概要
String | getArgument(int index) 指定されたすべてのコマンドライン引数の引数を返します。
String[] | getArguments() 指定されたすべてのコマンドライン引数の引数を返します。
String | getOption(String name) オプションの値を返します。
String | getOption(String name, String def) オプションの値を返します。
Set | getOptionNames() 指定されたすべてのオプションの名前を返します。
String[] | getOptions(String name) オプションの値を返します。
String[] | getQuery() 引数情報を取得します。
boolean | hasArguments() コマンドライン引数があるかどうか判定します。
boolean | hasOption(String name) オプションが指定されているかどうか判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CommandLineArgument

public CommandLineArgument(String[] args)
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。

実引数(command-line-arguments)の格納されている配列の構造は変化しません。
コマンド [-オプション名 [値]] [引数] オプションと引数を分割します。 オプションは、値のない単独指定も可能です。

パラメータ:
args - コマンド実行時のコマンドライン引数(main メソッドの引数)
例外:
IllegalArgumentException - 引数が null の場合
メソッドの詳細

getQuery

public String[] getQuery()
引数情報を取得します。 このメソッドは、このインスタンス生成時にコンストラクタに指定した 値を返します。

戻り値:
引数情報

hasOption

public boolean hasOption(String name)
オプションが指定されているかどうか判定します。

パラメータ:
name - オプション名
戻り値:
オプションが指定されている場合 true、そうでない場合 false。

getOption

public String getOption(String name)
                 throws IllegalArgumentException
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。

パラメータ:
name - オプション名
戻り値:
オプションの値
例外:
IllegalArgumentException - 指定のオプション名が定義されていない場合

getOption

public String getOption(String name,
                        String def)
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。 また、指定のオプション名が未定義だった場合、デフォルト値 def を 返します。

パラメータ:
name - オプション名
def - オプションが未指定だった場合のデフォルト値
戻り値:
オプションの値

getOptions

public String[] getOptions(String name)
                    throws IllegalArgumentException
オプションの値を返します。 オプション name が値を持たない単独指定の場合、null を返します。

パラメータ:
name - オプション名
戻り値:
オプションの値
例外:
IllegalArgumentException - 指定のオプション名が定義されていない場合

getOptionNames

public Set getOptionNames()
指定されたすべてのオプションの名前を返します。 返却値のセットの各要素は String インスタンスです。

戻り値:
オプション名一覧のセット

getArguments

public String[] getArguments()
指定されたすべてのコマンドライン引数の引数を返します。 ここで返される引数は、コマンドライン引数のうちの オプション指定ではない引数です。 返却値のセットの各要素は String インスタンスです。

戻り値:
引数のセット

getArgument

public String getArgument(int index)
                   throws ArrayIndexOutOfBoundsException
指定されたすべてのコマンドライン引数の引数を返します。 ここで返される引数は、コマンドライン引数のうちの オプション指定ではない引数です。 返却値のセットの各要素は String インスタンスです。

戻り値:
引数のセット
例外:
ArrayIndexOutOfBoundsException - インデックスが範囲外の場合（引数の個数以上、または負数）

hasArguments

public boolean hasArguments()
コマンドライン引数があるかどうか判定します。 ここでチェックされる引数は、コマンドライン引数のうちの オプション指定ではない引数です。

戻り値:
オプションではない引数がある場合 true、そうでない場合 false。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.platform.vm (im_commons 6.1.14 API)

 jp.co.intra_mart.common.platform.vm
クラス
CommandLineArgument


jp.co.intra_mart.common.platform.vm (im_commons 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

参照:
説明

クラスの概要
CommandLineArgument このクラスはコマンド実引数を解釈するための共通実装です。

パッケージ jp.co.intra_mart.common.platform.vm の説明

このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.platform.vm クラス階層 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.platform.vm の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.platform.vm の使用 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.platform.vm の使用

jp.co.intra_mart.common.platform.vm はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


すべてのクラス (im_commons 6.1.14 API)

 すべてのクラス
CommandLineArgument
DateUtil
NameUtil


定数フィールド値 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし
C D G H I J N S

C

CommandLineArgument - class jp.co.intra_mart.common.platform.vm.CommandLineArgument.
このクラスはコマンド実引数を解釈するための共通実装です。
CommandLineArgument(String[]) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のコンストラクタ
Java-VM から最初に実行される public かつ static な void main(String[]) メソッドの引数を受け取り解析します。
convertOnlyDate(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDate(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付のみのjava.util.Dateに変換します。
convertOnlyDateTime(long) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。
convertOnlyDateTime(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
日付と時刻のみのjava.util.Dateに変換します。

D

DateUtil - class jp.co.intra_mart.common.platform.util.DateUtil.
日付操作ユーティリティクラスです。
dateToString(Date) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列を取得します。

G

getArgument(int) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのコマンドライン引数の引数を返します。
getMaxDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最大日時を取得します。
getMinDate() - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
システムで許可されている最小日時を取得します。
getOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOption(String, String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getOptionNames() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
指定されたすべてのオプションの名前を返します。
getOptions(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションの値を返します。
getQuery() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
引数情報を取得します。

H

hasArguments() - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
コマンドライン引数があるかどうか判定します。
hasOption(String) - class jp.co.intra_mart.common.platform.vm.CommandLineArgument のメソッド
オプションが指定されているかどうか判定します。

I

isNameChar(char) - class jp.co.intra_mart.common.platform.util.NameUtil の static メソッド
指定された文字が英数字またはアンダーバーまたはピリオドであるかどうかを判断します。
isValidApplicationName(String) - class jp.co.intra_mart.common.platform.util.NameUtil の static メソッド
指定された文字列がアプリケーション名として正しいかどうかを判定します。
isValidName(String) - class jp.co.intra_mart.common.platform.util.NameUtil の static メソッド
指定された文字列が名前として妥当かどうか判定します。
isValidPath(String) - class jp.co.intra_mart.common.platform.util.NameUtil の static メソッド
指定された文字列がパスとして妥当かどうか判定します。

J

jp.co.intra_mart.common.platform.util - package jp.co.intra_mart.common.platform.util
このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm - package jp.co.intra_mart.common.platform.vm
このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

N

NameUtil - class jp.co.intra_mart.common.platform.util.NameUtil.
名前に関連するユーティリティです。
NameUtil() - class jp.co.intra_mart.common.platform.util.NameUtil のコンストラクタ

S

stringToDate(String) - class jp.co.intra_mart.common.platform.util.DateUtil の static メソッド
データベース登録用文字列からjava.util.Dateを取得します。
C D G H I J N S
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_commons 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_commons 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.common.platform.util
jp.co.intra_mart.common.platform.vm


概要 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_commons API Specifications

パッケージ
jp.co.intra_mart.common.platform.util | このパッケージには、プラットフォームを利用する際に 便利なユーティリティクラスが含まれています。
jp.co.intra_mart.common.platform.vm | このパッケージには、コマンド実引数を解釈するための共通クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_commons 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.platform.util, jp.co.intra_mart.common.platform.vm

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.platform.vm.CommandLineArgument
    • class jp.co.intra_mart.common.platform.util.DateUtil
    • class jp.co.intra_mart.common.platform.util.NameUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_commons 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


All Classes
GLOBALS
ImAjax
ImHeaderColumnResizer
ImJson
ImSortableTable
ImSortableTableCell
ImSortableTableCell4Checkbox
ImSortableTableCell4Image
ImSortableTableCell4Number
ImSortableTableCell4Radio
ImSortableTableCell4Text
ImXPath
RealNumber


intra-mart 6.1.14 Client Side JavaScript 全てのクラス

intra-mart 6.1.14 Client Side JavaScript

全てのクラス
GLOBALS
ImAjax
ImHeaderColumnResizer
ImJson
ImSortableTable
ImSortableTableCell
ImSortableTableCell4Checkbox
ImSortableTableCell4Image
ImSortableTableCell4Number
ImSortableTableCell4Radio
ImSortableTableCell4Text
ImXPath
RealNumber


intra-mart 6.1.14 Client Side JavaScript Constant Values

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

定数 フィールド値

  • ImAjax
  • ImJson
  • ImXPath
ImAjax
AJAX_COMPLETE | "AJAX_COMPLETE"
AJAX_PARSE_JSON_ERR | "AJAX_PARSE_JSON_ERR"
AJAX_TIMEOUT | "IM-SECURITY-00001"
CONTENT_TYPE_IS_NOT_SPECIFIED | "CONTENT_TYPE_IS_NOT_SPECIFIED"
RES_HEADER_ERROR_CODE | "x-jp-co-intra-mart-ajax-error-code"
RES_HEADER_ERROR_MESSAGE | "x-jp-co-intra-mart-ajax-error-message"
CONTENT_TYPE_JSON | "application/json"
CONTENT_TYPE_XML | "text/xml"
CONTENT_TYPE_TEXT | "text/plain"
CHARSET_UTF8 | "charset=utf-8"

ImJson
PARSE_JSON_ERROR_MESSAGE | "parseJSON Error"
INDENT_STRING | " "
NAME_VALUE_SEPARATER | ", "
TYPE_NULL | "/* Null */"
TYPE_UNDEFINED | "/* Undefined */"
TYPE_STRING | "/* String */"
TYPE_DATE | "/* Date */"
TYPE_ARRAY | "/* Array */"
TYPE_OBJECT | "/* Object */"
TYPE_FUNCTION | "/* Function */"
TYPE_NUMBER | "/* Number */"
TYPE_BOOLEAN | "/* Boolean */"
TYPE_XML | "/* XML */"
TYPE_UNKNOWN | "/* Unknown */"

ImXPath
NODE | 1
STRING | 2
NUMBER | 3
BOOLEAN | 4

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


GLOBALS

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス | フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

クラス GLOBALS

Object
   |
   +--GLOBALS
class GLOBALS
メソッドの概要
<static> String | getCookie(<String> sName) クッキーの値を取得します。
<static> Boolean | isDateData(<Number> nYear, <Number> nMonth, <Number> nDay, <Number> nHour, <Number> nMinutes, <Number> nSecond) 日付として正しいかどうか判定します。
<static> Boolean | isLeapYear(<Number> nYear) 指定の年が閏年かどうか判定します。
<static> Window | openNewWindow(<String> name, <String> status) 新しいウィンドウを開きます。
<static> void | removeCookie(<String> sName) クッキーの値を消去します。
<static> void | setCookie(<String> sName, <String> sValue, <Date> dExpires, <String> sDomain, <String> sPath, <Boolean> bSecure) 指定のデータをクッキーに保存します。

メソッドの詳細

getCookie

<static> String getCookie(<String> sName)
    クッキーの値を取得します。

    指定参照名称に該当するクッキー内に保存された値を返却します。
    指定参照名称で値を取得できなかった場合には、null 値が返されます。
    Parameters:
      sName - 参照名称
    Returns:
      参照名称に対応した値

isDateData

<static> Boolean isDateData(<Number> nYear, <Number> nMonth, <Number> nDay, <Number> nHour, <Number> nMinutes, <Number> nSecond)
    日付として正しいかどうか判定します。

    与えられた数値の組合わせが日付（および時間）を表す情報として正しいかどうかを判定します。
    この関数は、閏年の判定も行っているので、２月２９日に関しても正しく判定することができます。
    Parameters:
      nYear - 年
      nMonth - 月
      nDay - 日
      nHour - [option] 時間 (省略可能)
      nMinutes - [option] 分 (省略可能)
      nSecond - [option] 秒 (省略可能)
    Returns:
      指定の数値データが日付として正しい場合 true、そうでない場合false。

isLeapYear

<static> Boolean isLeapYear(<Number> nYear)
    指定の年が閏年かどうか判定します。

    与えられた数値を西暦年として閏年計算をします。
    Parameters:
      nYear - 年
    Returns:
      指定の年が閏年の場合 true、そうでない場合false。

openNewWindow

<static> Window openNewWindow(<String> name, <String> status)
    新しいウィンドウを開きます。

    指定された条件で新しいウィンドウを開きます。

    この関数は、window.open() と同等の振る舞いをします。 引数 status には、window.open() ＡＰＩの第３引数に与える引数と同様の文字列データ (詳細は、JavaScript のリファレンスを参照して下さい)を渡して下さい。
    この関数は、JavaScript の window.open() と等しい値を返します。
    指定された参照名で、すでにウィンドウが開かれている場合、新規ウィンドウが開かれない場合があります。
    この関数を利用して開いたウィンドウには、『Please wait...』という画面が表示されます。
    Parameters:
      name - ウィンドウ参照名称
      status - ウィンドウ・ステータス
    Returns:
      新規に開いたウィンドウのハンドル (Window オブジェクト)

removeCookie

<static> void removeCookie(<String> sName)
    クッキーの値を消去します。

    クッキー内に保存されているデータのうち、指定の参照名に該当するデータを消去します。
    実際には、クッキーの有効期限を過去に設定し直す事によって、 その値自体を無効とし、表面上見えない状態にしているだけです。
    Parameters:
      sName - 参照名称

setCookie

<static> void setCookie(<String> sName, <String> sValue, <Date> dExpires, <String> sDomain, <String> sPath, <Boolean> bSecure)
    指定のデータをクッキーに保存します。

    Parameters:
      sName - 参照名称
      sValue - 値
      dExpires - [option] 利用期限 (省略可能)
      sDomain - [option] 有効ドメイン (省略可能)
      sPath - [option] 設定可能階層 (省略可能)
      bSecure - [option] セキュリティの有無 (省略可能)
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス | フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript API Help

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

APIドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

クラス

各クラスは個別のページを持ちます。各ページには次のように、クラス説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • クラスの宣言
  • クラスの記述

  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要項目には、その項目の詳細説明の中から 1 行目の文が表示されます。

階層ツリー (クラス階層)

全てのクラスにはクラス階層 ページがあります。 各階層ページは、クラスのリストを含みます。 クラスはObjectを開始点とする継承構造で編成されます。

非推奨

非推奨API ページは、すべての推奨されていない API のリストを表示します。非推奨 API とは、機能改善などによって使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 索引 には、すべてのクラス、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/後

これらのリンクにより、前または次のクラス、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImAjax

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス | フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

クラス ImAjax

Object
   |
   +--ImAjax
class ImAjax

XMLHttpRequest 通信を簡単に行うことができるオブジェクトです。

ImAjax オブジェクトの利用方法、およびサンプルコードは、 こちら を参照してください。

Version: 1.0

Author: INTRAMART
Defined in im_ajax_request.js

フィールドの概要
<static> <final> String | AJAX_COMPLETE エラーコード：通信完了
<static> <final> String | AJAX_PARSE_JSON_ERR エラーコード：JSON文字列からJavaScriptオブジェクトへの変換失敗
<static> <final> String | AJAX_TIMEOUT エラーコード：セッションタイムアウト
<static> <final> Boolean | Browser ブラウザ判定用変数。
<static> <final> String | CONTENT_TYPE_IS_NOT_SPECIFIED エラーコード：レスポンスヘッダ「Content-Type」が特定できない場合
コンストラクタの概要
ImAjax()
XMLHttpRequest 通信を簡単に行うためのメソッドを提供します。
メソッドの概要
<static> String | getBrowserName() 利用しているブラウザを判定します。
<static> void | requestAsyncSend(<String> url, <Object> data, <Function> callback, <String> method) 非同期通信を行います。
<static> void | requestSend(<String> url, <Object> data, <Function> callback, <String> method) 同期通信を行います。

フィールドの詳細

AJAX_COMPLETE

<static> <final> String AJAX_COMPLETE
    エラーコード：通信完了

    See Also:
    Constant Field Values

AJAX_PARSE_JSON_ERR

<static> <final> String AJAX_PARSE_JSON_ERR
    エラーコード：JSON文字列からJavaScriptオブジェクトへの変換失敗

    See Also:
    Constant Field Values

AJAX_TIMEOUT

<static> <final> String AJAX_TIMEOUT
    エラーコード：セッションタイムアウト

    See Also:
    Constant Field Values

Browser

<static> <final> Boolean Browser
    ブラウザ判定用変数。
    利用しているブラウザを判定するための変数です。「ImAjax.Browser.XXXX」形式で変数を参照可能です。
    例：Firefoxを利用している場合、変数「ImAjax.Browser.Firefox」は true を保持しています。

    利用しているブラウザ | 変数
Internet Explorer | ImAjax.Browser.IE
Netscape | ImAjax.Browser.Netscape
FireFox | ImAjax.Browser.Firefox
Opera | ImAjax.Browser.Opera
Safari | ImAjax.Browser.Safari

CONTENT_TYPE_IS_NOT_SPECIFIED

<static> <final> String CONTENT_TYPE_IS_NOT_SPECIFIED
    エラーコード：レスポンスヘッダ「Content-Type」が特定できない場合

    See Also:
    Constant Field Values
コンストラクタの詳細

ImAjax

ImAjax()
    XMLHttpRequest 通信を簡単に行うためのメソッドを提供します。
    Version: 1.0

    Author: INTRAMART
メソッドの詳細

getBrowserName

<static> String getBrowserName()
    利用しているブラウザを判定します。

    ブラウザ | 返却値
Internet Explorer | IE
Netscape | Netscape
FireFox | Firefox
Opera | Opera
Safari | Safari
    Returns:
      利用しているブラウザをあらわす文字列

requestAsyncSend

<static> void requestAsyncSend(<String> url, <Object> data, <Function> callback, <String> method)
    非同期通信を行います。
    Parameters:
      url - 送信先URL
      data - 送信データ
      callback - コールバック関数
      method - [option] サーバにデータを送る形式を get または post で指定します。デフォルトは"post"。

requestSend

<static> void requestSend(<String> url, <Object> data, <Function> callback, <String> method)
    同期通信を行います。
    Parameters:
      url - 送信先URL
      data - 送信データ
      callback - コールバック関数
      method - [option] サーバにデータを送る形式を get または post で指定します。デフォルトは"post"。
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス | フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImHeaderColumnResizer

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImHeaderColumnResizer

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImHeaderColumnResizer
class ImHeaderColumnResizer
extends ImAbstractSelfEventHandler

＜TABLE＞タグ要素の列幅をリサイズ可能にする CSJS オブジェクト。

ImHeaderColumnResizerオブジェクトの利用方法、およびサンプルコードは、 こちらを参照してください。

Defined in im_header_column_resizer.js

コンストラクタの概要
ImHeaderColumnResizer(<String> tableElemId4Header, <String> tableElemId4Data, <Number> width, <Number> height)
ヘッダーの列幅をリサイズ可能にするオブジェクトを生成します。
メソッドの概要
void | initializeTable() ヘッダ部の<TABLE>、および、データ部の<TABLE>を初期化します。
void | setResizable(<Boolean> resizable) リサイズの可否を設定します。
void | setResizableCheckFunc(<Function> resizableCheckFunc) リサイズ可否判定関数を設定します。

コンストラクタの詳細

ImHeaderColumnResizer

ImHeaderColumnResizer(<String> tableElemId4Header, <String> tableElemId4Data, <Number> width, <Number> height)
    ヘッダーの列幅をリサイズ可能にするオブジェクトを生成します。
    Parameters:
      tableElemId4Header - ヘッダ部の<TABLE>タグのid
      tableElemId4Data - データ部の<TABLE>タグのid
      width - [option] 幅 (任意)
      height - [option] 高さ (任意)
    Returns:
      ImHeaderColumnResizerオブジェクト
メソッドの詳細

initializeTable

void initializeTable()
    ヘッダ部の<TABLE>、および、データ部の<TABLE>を初期化します。
    データ部の列幅を、ヘッダ部の列幅に合わせます。

setResizable

void setResizable(<Boolean> resizable)
    リサイズの可否を設定します。
    Parameters:
      resizable - 列幅のリサイズを行う場合は true、 列幅のリサイズを行わない場合は false。

setResizableCheckFunc

void setResizableCheckFunc(<Function> resizableCheckFunc)
    リサイズ可否判定関数を設定します。
    ImHeaderColumnResizerオブジェクトは、引数 resizableCheckFunc で指定された関数の実行結果を判定し、 リサイズを行うかどうかを決定します。

    引数 resizableCheckFunc で指定する関数の実行結果が true の場合は リサイズを行い、 false の場合は リサイズを行いません。

    なお、setResizable(Boolean resizable)で false が設定されている場合は、 この関数を用いたリサイズ可否判定処理は行いません。
    Parameters:
      resizableCheckFunc - リサイズ可否判定関数。（この関数の返却値の型は Boolean）
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImJson

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImJson

Object
   |
   +--ImJson
class ImJson

JSON 関連のライブラリです。

JSON (JavaScript Object Notation)は、軽量のデータ交換フォーマットです。
JSON については、JSON の紹介 を参照してください。
Version: 1.0

Author: INTRAMART
Defined in im_json.js

フィールドの概要
<static> <final> String | INDENT_STRING インデント文字列
<static> <final> String | PARSE_JSON_ERROR_MESSAGE JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられる例外のメッセージです。
<static> <final> String | TYPE_ARRAY 「Array」型 を表す定数
<static> <final> String | TYPE_BOOLEAN 「Boolean」型 を表す定数
<static> <final> String | TYPE_DATE 「Date」型 を表す定数
<static> <final> String | TYPE_FUNCTION 「Function」型 を表す定数
<static> <final> String | TYPE_NULL 「null」型 を表す定数
<static> <final> String | TYPE_NUMBER 「Number」型 を表す定数
<static> <final> String | TYPE_OBJECT 「Object」型 を表す定数
<static> <final> String | TYPE_STRING 「String」型 を表す定数
<static> <final> String | TYPE_UNDEFINED 「Undefined」型 を表す定数
<static> <final> String | TYPE_UNKNOWN 型が特定できない場合を表す定数
<static> <final> String | TYPE_XML 「XML」型 を表す定数
コンストラクタの概要
ImJson()
JSON 関連のメソッドを提供します。
メソッドの概要
<static> Boolean | checkJSONString(<String> jsonString) JSON 文字列の妥当性をチェックします。
<static> Object | parseJSON(<String> jsonString) JSON 文字列からJavaScriptオブジェクトに変換します。
<static> String | toJSONString(<Object> value, <Boolean> debugFlg) JSON 文字列に変換します。

フィールドの詳細

INDENT_STRING

<static> <final> String INDENT_STRING
    インデント文字列

    See Also:
    Constant Field Values

PARSE_JSON_ERROR_MESSAGE

<static> <final> String PARSE_JSON_ERROR_MESSAGE
    JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられる例外のメッセージです。

    See Also:
    Constant Field Values

TYPE_ARRAY

<static> <final> String TYPE_ARRAY
    「Array」型 を表す定数

    See Also:
    Constant Field Values

TYPE_BOOLEAN

<static> <final> String TYPE_BOOLEAN
    「Boolean」型 を表す定数

    See Also:
    Constant Field Values

TYPE_DATE

<static> <final> String TYPE_DATE
    「Date」型 を表す定数

    See Also:
    Constant Field Values

TYPE_FUNCTION

<static> <final> String TYPE_FUNCTION
    「Function」型 を表す定数

    See Also:
    Constant Field Values

TYPE_NULL

<static> <final> String TYPE_NULL
    「null」型 を表す定数

    See Also:
    Constant Field Values

TYPE_NUMBER

<static> <final> String TYPE_NUMBER
    「Number」型 を表す定数

    See Also:
    Constant Field Values

TYPE_OBJECT

<static> <final> String TYPE_OBJECT
    「Object」型 を表す定数

    See Also:
    Constant Field Values

TYPE_STRING

<static> <final> String TYPE_STRING
    「String」型 を表す定数

    See Also:
    Constant Field Values

TYPE_UNDEFINED

<static> <final> String TYPE_UNDEFINED
    「Undefined」型 を表す定数

    See Also:
    Constant Field Values

TYPE_UNKNOWN

<static> <final> String TYPE_UNKNOWN
    型が特定できない場合を表す定数

    See Also:
    Constant Field Values

TYPE_XML

<static> <final> String TYPE_XML
    「XML」型 を表す定数

    See Also:
    Constant Field Values
コンストラクタの詳細

ImJson

ImJson()
    JSON 関連のメソッドを提供します。
    Version: 1.0

    Author: INTRAMART
メソッドの詳細

checkJSONString

<static> Boolean checkJSONString(<String> jsonString)
    JSON 文字列の妥当性をチェックします。
    Parameters:
      jsonString - JSON 文字列
    Returns:
      正当なJSON 文字列の場合は true、不正なJSON 文字列の場合は false を返却します。

parseJSON

<static> Object parseJSON(<String> jsonString)
    JSON 文字列からJavaScriptオブジェクトに変換します。

    Parameters:
      jsonString - JSON 文字列
    Returns:
      JavaScriptオブジェクト
    Throws:
      - SyntaxError JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられます。 （例外のメッセージは、ImJson.PARSE_JSON_ERROR_MESSAGEに設定されます）

toJSONString

<static> String toJSONString(<Object> value, <Boolean> debugFlg)
    JSON 文字列に変換します。

    引数「debugFlg」が true の場合、JSON 文字列のインデント化、および、型名の付与を行います。
    その際、変換対象オブジェクト（内部のプロパティも含む）が 以下の型の場合、特別な動作をします。

    Date 型 | 型名の右側に、日付の文字列表現がJavaScriptのコメントとして出力されます。
Function 型 | "THIS_IS_FUNCTION" として表現します。

    なお、引数「debugFlg」が true 時の本メソッドの返却値には型名が付与されているため、
    ImJson.checkJSONString()でのチェックには失敗します。
    Parameters:
      value - 変換対象
      debugFlg - [option] JSON 文字列のインデント化、および、型名の付与を行う場合は trueを設定してください。 省略時のデフォルトは false。
    Returns:
      JSON 文字列
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTable

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTable

Object
   |
   +--ImSortableTable
class ImSortableTable

ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクト。
ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Version: 1.0

Author: INTRAMART
Defined in im_sortable_table.js

コンストラクタの概要
ImSortableTable(<String> id, <Number> width, <Number> height)
コンストラクタ。
メソッドの概要
void | addRowData(<Object> rowData, <Number> insertRowIdx) データを一行 挿入します。
void | display() Sortableテーブルを表示します。
Object | getCellObject(<Number> row, <Number> col) 引数で指定された位置のセルオブジェクトを取得します。
Array | getConfigs() コンフィグオブジェクトが格納された配列を取得します。
Array | getData() データオブジェクトが格納された配列を取得します。
void | removeRowData(<Number> removeRowIdx) データを一行 削除します。
void | setCheckedRadioPosition(<Object> position) ラジオボタンをチェック状態にします。
void | setConfigs(<Array> configs) コンフィグオブジェクトを格納した配列を設定します。
void | setData(<Array> data) データオブジェクトを格納した配列を設定します。
void | setDataTableClassName(<String> dataTableClassName) データ部の<table>タグのCSSクラス名を設定します。
void | setHeaderTableClassName(<String> headerTableClassName) ヘッダ部の<table>タグのCSSクラス名を設定します。
void | setRedrawHeader() 次回のdisplay()実行時、ヘッダー部分も再描画します。
void | setRowSelector(rowSelector) セルクリック時の表示形式の変更範囲を設定します。
void | sort(<Number> colIdx, <String> sortDirection) ソートを実行します。
<static> ImSortableTable | getCachedInstance(<String> id) キャッシュされた ImSortableTable のインスタンスを取得します。
<static> String | getContextPath() コンテキストパスを取得します。

コンストラクタの詳細

ImSortableTable

ImSortableTable(<String> id, <Number> width, <Number> height)
    コンストラクタ。

    ImSortableTableオブジェクトは、HTMLページ内のDIV要素を操作し、Sortableテーブルを作成・表示します。
    表示対象のDIV要素は、引数「id」で指定します。

    このコンストラクタの実行後に、生成したインスタンスを取得するには、 getCachedInstance(String)を利用します。
    Parameters:
      id - 表示対象のDIV要素のID
      width - [option] 幅
      height - [option] 高さ
    Version: 1.0

    Author: INTRAMART
メソッドの詳細

addRowData

void addRowData(<Object> rowData, <Number> insertRowIdx)
    データを一行 挿入します。

    データオブジェクトのプロパティ名は、 コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）で設定した値です。
    Parameters:
      rowData - データオブジェクト
      insertRowIdx - [option] 挿入位置の行番号（先頭は 0 行目）。(省略可能)
      未指定の場合は末尾に追加されます。

display

void display()
    Sortableテーブルを表示します。

    現在設定されているコンフィグ および データを元にSortableテーブルを表示します。

getCellObject

Object getCellObject(<Number> row, <Number> col)
    引数で指定された位置のセルオブジェクトを取得します。

    セルオブジェクトとは、ImSortableTableCell4XXXXのインスタンスです。
    （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Textのインスタンス））
    Parameters:
      row - 行番号（先頭は 0 行目）
      col - 列番号（先頭は 0 列目）
    Returns:
      セルオブジェクト

getConfigs

Array getConfigs()
    コンフィグオブジェクトが格納された配列を取得します。
    Returns:
      コンフィグオブジェクトを格納した配列

getData

Array getData()
    データオブジェクトが格納された配列を取得します。

    データオブジェクトのプロパティ名は、 コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）で設定した値です。
    Returns:
      データオブジェクトを格納した配列

removeRowData

void removeRowData(<Number> removeRowIdx)
    データを一行 削除します。
    Parameters:
      removeRowIdx - 削除する行番号（先頭は 0 行目）

setCheckedRadioPosition

void setCheckedRadioPosition(<Object> position)
    ラジオボタンをチェック状態にします。

    引数で指定された位置に表示されているラジオボタンをチェック状態にします。
    該当セルのフォーマットタイプがラジオボタンではない場合、このメソッドは何も行いません。

    ポジションオブジェクトの構成は以下の通りです。
    プロパティ (型) | 説明
row (Number) | セルの行番号（先頭は 0 行目）
col (Number) | セルの列番号（先頭は 0 列目）
    Parameters:
      position - チェック状態にするラジオボタンの位置情報を格納したポジションオブジェクト

setConfigs

void setConfigs(<Array> configs)
    コンフィグオブジェクトを格納した配列を設定します。
    Parameters:
      configs - コンフィグオブジェクトを格納した配列

setData

void setData(<Array> data)
    データオブジェクトを格納した配列を設定します。

    データオブジェクトのプロパティ名は、 コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）で設定した値です。
    Parameters:
      data - データオブジェクトを格納した配列

setDataTableClassName

void setDataTableClassName(<String> dataTableClassName)
    データ部の<table>タグのCSSクラス名を設定します。

    このメソッドを使用しなかった場合、データ部の<table>タグのCSSクラス名は 「im_sortable_table_data_table」が使用されます。
    Parameters:
      dataTableClassName - <table>タグ（データ部）のCSSクラス名

setHeaderTableClassName

void setHeaderTableClassName(<String> headerTableClassName)
    ヘッダ部の<table>タグのCSSクラス名を設定します。

    このメソッドを使用しなかった場合、ヘッダ部の<table>タグのCSSクラス名は 「im_sortable_table_header_table」が使用されます。
    Parameters:
      headerTableClassName - <table>タグ（ヘッダ部）のCSSクラス名

setRedrawHeader

void setRedrawHeader()
    次回のdisplay()実行時、ヘッダー部分も再描画します。

setRowSelector

void setRowSelector(rowSelector)
    セルクリック時の表示形式の変更範囲を設定します。

    指定可能な範囲は、行単位、または、セル単位です。
    このメソッドを使用しなかった場合、セルクリック時の表示形式は セル単位 で変更されます。
    Parameters:
      rowSelectState - セルクリック時の表示形式の変更を 行単位 で行う場合は true、
      セルクリック時の表示形式の変更を セル単位 で行う場合は false。

sort

void sort(<Number> colIdx, <String> sortDirection)
    ソートを実行します。

    一度に実行可能なソートは一つだけです。 （他の列のソートが行われている場合、この関数で指定した列のソートを行うことは出来ません。
    Parameters:
      colIdx - ソートを実行する列番号（先頭は 0 列目）
      sortDirection - [option] ソート方向。（省略した場合は、colIdxで指定された列に設定されているソート方向）
      昇順の場合：IM_STBL_CONFIG_KEY.ASC
      降順の場合：IM_STBL_CONFIG_KEY.DESC

getCachedInstance

<static> ImSortableTable getCachedInstance(<String> id)
    キャッシュされた ImSortableTable のインスタンスを取得します。

    Parameters:
      id - コンストラクタで指定したid
    Returns:
      ImSortableTableのインスタンス。引数「id」に紐づくImSortableTableオブジェクトが作成されていない場合は、null。

getContextPath

<static> String getContextPath()
    コンテキストパスを取得します。
    Returns:
      コンテキストパス
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTableCell

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTableCell

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImSortableTableCell
Direct Known Subclasses:
ImSortableTableCell4Radio, ImSortableTableCell4Image, ImSortableTableCell4Number, ImSortableTableCell4Checkbox, ImSortableTableCell4Text
class ImSortableTableCell
extends ImAbstractSelfEventHandler

ImSortableTableのセルオブジェクトです。

セルのフォーマット毎に具象オブジェクトが用意されています。
詳しくは、サブクラスの説明を参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Defined in im_sortable_table_cell.js

コンストラクタの概要
ImSortableTableCell()
コンストラクタ。
メソッドの概要
Object | getCellData() セルの値を取得します。
Object | getConfig() セルのコンフィグオブジェクトを取得します。
ImSortableTable | getObserver() ImSortableTableのインスタンスを取得します。
Object | getPosition() セルの位置情報を格納したポジションオブジェクトを取得します。
Object | overrideProperty(<Object> superObject, <Object> overrideObject) 引数「superObject」のプロパティを、引数「overrideObject」のプロパティで上書きます。
void | setConfig(<Object> config) セルのコンフィグオブジェクトを設定します。
void | updateCellData(<Object> data) セルデータを更新します。

コンストラクタの詳細

ImSortableTableCell

ImSortableTableCell()
    コンストラクタ。

    開発者が明示的にこのコンストラクタを利用する必要はありません。
メソッドの詳細

getCellData

Object getCellData()
    セルの値を取得します。

    セルのフォーマットによって、返却される値が異なります。
    フォーマット | 返却値の型 | 説明
テキスト | String | このメソッドで取得した値と、セルに表示されている値は異なる場合があります。 このメソッドで取得した値は、 テキスト用コンフィグオブジェクトの 「formatter」関数を実行する前の値です。
数値 | Number | このメソッドで取得した値と、セルに表示されている値は異なる場合があります。 このメソッドで取得した値は、 数値用コンフィグオブジェクトの 「formatter」関数を実行する前の値です。
チェックボックス | Boolean | チェック状態の場合は true、非チェック状態の場合は false。
ラジオボタン | Boolean | チェック状態の場合は true、非チェック状態の場合は false。
イメージ | Object | このセルの値。
    Returns:
      セルの値

getConfig

Object getConfig()
    セルのコンフィグオブジェクトを取得します。
    Returns:
      ImSortableTableCell4XXXXのコンフィグオブジェクト
      （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Text））

      コンフィグオブジェクトの構成は、セルのフォーマットによって異なります。
      フォーマット | コンフィグオブジェクトの構成
テキスト | ImSortableTableCell4Textオブジェクト を参照
数値 | ImSortableTableCell4Numberオブジェクト を参照
チェックボックス | ImSortableTableCell4Checkboxオブジェクト を参照
ラジオボタン | ImSortableTableCell4Radioオブジェクト を参照
イメージ | ImSortableTableCell4Imageオブジェクト を参照

getObserver

ImSortableTable getObserver()
    ImSortableTableのインスタンスを取得します。
    Returns:
      ImSortableTableのインスタンス

getPosition

Object getPosition()
    セルの位置情報を格納したポジションオブジェクトを取得します。

    ポジションオブジェクトの構成は以下の通りです。
    プロパティ (型) | 説明
row (Number) | セルの行番号（先頭は 0 行目）
col (Number) | セルの列番号（先頭は 0 列目）
    Returns:
      セルの位置情報を格納したポジションオブジェクト

overrideProperty

Object overrideProperty(<Object> superObject, <Object> overrideObject)
    引数「superObject」のプロパティを、引数「overrideObject」のプロパティで上書きます。

    プロパティ値がObjectの場合、このメソッドが再帰的に呼び出されます。
    プロパティ値が配列の場合、配列の先頭要素から順番に上書きされます。
    Parameters:
      superObject - 上書き対象オブジェクト
      overrideObject - 上書きするプロパティを保持したオブジェクト
    Returns:
      上書き後のオブジェクト

setConfig

void setConfig(<Object> config)
    セルのコンフィグオブジェクトを設定します。
    Parameters:
      config - ImSortableTableCell4XXXXのコンフィグオブジェクト
      （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Text））

      コンフィグオブジェクトの構成は、セルのフォーマットによって異なります。
      フォーマット | コンフィグオブジェクトの構成
テキスト | ImSortableTableCell4Textオブジェクト を参照
数値 | ImSortableTableCell4Numberオブジェクト を参照
チェックボックス | ImSortableTableCell4Checkboxオブジェクト を参照
ラジオボタン | ImSortableTableCell4Radioオブジェクト を参照
イメージ | ImSortableTableCell4Imageオブジェクト を参照

updateCellData

void updateCellData(<Object> data)
    セルデータを更新します。

    このメソッドは、このインスタンスが保持しているデータと、 ImSortableTableオブジェクトで保持しているデータを更新します。

    以下のフォーマットの場合、このメソッド利用する際に注意が必要です。
    フォーマット | 注意点
チェックボックス | 表示されているチェックボックスのチェック状態を変更するには、 ImSortableTableCell4Checkbox#revreseCheckedStatus() または、 ImSortableTableCell4Checkbox#updateCheckedStatus(Boolean checkedStatus) を利用してください。
ラジオボタン | 表示されているラジオボタンのチェック状態を変更するには、 ImSortableTable#setCheckedRadioPosition(Object position) を利用してください。
    Parameters:
      data - データ
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTableCell4Checkbox

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTableCell4Checkbox

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImSortableTableCell
               |
               +--ImSortableTableCell4Checkbox
class ImSortableTableCell4Checkbox
extends ImSortableTableCell

ImSortableTableのチェックボックス用セルオブジェクト。
チェックボックス用セルオブジェクトの詳しい説明は、こちらを参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Defined in im_sortable_table_cell_checkbox.js

コンストラクタの概要
ImSortableTableCell4Checkbox(observer, htmlElement, position, config, data)
コンストラクタ。
メソッドの概要
void | revreseCheckedStatus() チェックボックスの値を反転させます。
void | updateCheckedStatus(<Boolean> checkedStatus) チェックボックスの値を変更します。
<static> Object | createDefaultConfig(<String> argId, <String> argName, <Number> argWidth) ImSortableTableのデフォルトコンフィグオブジェクトを生成します（チェックボックス用）。
クラスから継承されたフィールドImSortableTableCell
getObserver, getPosition, getConfig, getCellData, setConfig, updateCellData, overrideProperty

コンストラクタの詳細

ImSortableTableCell4Checkbox

ImSortableTableCell4Checkbox(observer, htmlElement, position, config, data)
    コンストラクタ。

    開発者が明示的にこのコンストラクタを利用する必要はありません。
メソッドの詳細

revreseCheckedStatus

void revreseCheckedStatus()
    チェックボックスの値を反転させます。

updateCheckedStatus

void updateCheckedStatus(<Boolean> checkedStatus)
    チェックボックスの値を変更します。
    Parameters:
      checkedStatus - チェック状態に変更する場合は true、非チェック状態に変更する場合は false。

createDefaultConfig

<static> Object createDefaultConfig(<String> argId, <String> argName, <Number> argWidth)
    ImSortableTableのデフォルトコンフィグオブジェクトを生成します（チェックボックス用）。
    Parameters:
      argId - 列を識別するためのID
      argName - [option] ヘッダに表示される文字列（使用されません）（任意）
      argWidth - [option] 列の幅（任意）
    Returns:
      デフォルト値を格納したImSortableTableのチェックボックス用コンフィグオブジェクト
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTableCell4Image

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTableCell4Image

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImSortableTableCell
               |
               +--ImSortableTableCell4Image
class ImSortableTableCell4Image
extends ImSortableTableCell

ImSortableTableのイメージ用セルオブジェクト。
イメージ用セルオブジェクトの詳しい説明は、こちらを参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Defined in im_sortable_table_cell_image.js

コンストラクタの概要
ImSortableTableCell4Image(observer, htmlElement, position, config, data)
コンストラクタ。
メソッドの概要
<static> Object createDefaultConfig(<String> argId, <String> argName, <Number> argWidth)
ImSortableTableのデフォルトコンフィグオブジェクトを生成します（イメージ用）。
クラスから継承されたフィールドImSortableTableCell
getObserver, getPosition, getConfig, getCellData, setConfig, updateCellData, overrideProperty

コンストラクタの詳細

ImSortableTableCell4Image

ImSortableTableCell4Image(observer, htmlElement, position, config, data)
    コンストラクタ。

    開発者が明示的にこのコンストラクタを利用する必要はありません。
メソッドの詳細

createDefaultConfig

<static> Object createDefaultConfig(<String> argId, <String> argName, <Number> argWidth)
    ImSortableTableのデフォルトコンフィグオブジェクトを生成します（イメージ用）。
    Parameters:
      argId - 列を識別するためのID
      argName - [option] ヘッダに表示される文字列（任意）
      argWidth - [option] 列の幅（任意）
    Returns:
      デフォルト値を格納したImSortableTableのイメージ用コンフィグオブジェクト
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTableCell4Number

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTableCell4Number

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImSortableTableCell
               |
               +--ImSortableTableCell4Number
class ImSortableTableCell4Number
extends ImSortableTableCell

ImSortableTableの数値用セルオブジェクト。
数値用セルオブジェクトの詳しい説明は、こちらを参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Defined in im_sortable_table_cell_number.js

コンストラクタの概要
ImSortableTableCell4Number(observer, htmlElement, position, config, data)
コンストラクタ。
メソッドの概要
<static> Object createDefaultConfig(<String> argId, <String> argName, <Number> argWidth)
ImSortableTableのデフォルトコンフィグオブジェクトを生成します（数値用）。
クラスから継承されたフィールドImSortableTableCell
getObserver, getPosition, getConfig, getCellData, setConfig, updateCellData, overrideProperty

コンストラクタの詳細

ImSortableTableCell4Number

ImSortableTableCell4Number(observer, htmlElement, position, config, data)
    コンストラクタ。

    開発者が明示的にこのコンストラクタを利用する必要はありません。
メソッドの詳細

createDefaultConfig

<static> Object createDefaultConfig(<String> argId, <String> argName, <Number> argWidth)
    ImSortableTableのデフォルトコンフィグオブジェクトを生成します（数値用）。
    Parameters:
      argId - 列を識別するためのID
      argName - [option] ヘッダに表示される文字列（任意）
      argWidth - [option] 列の幅（任意）
    Returns:
      デフォルト値を格納したImSortableTableの数値用コンフィグオブジェクト
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTableCell4Radio

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTableCell4Radio

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImSortableTableCell
               |
               +--ImSortableTableCell4Radio
class ImSortableTableCell4Radio
extends ImSortableTableCell

ImSortableTableのラジオボタン用セルオブジェクト。
ラジオボタン用セルオブジェクトの詳しい説明は、こちらを参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

表示されているラジオボタンのチェック状態を変更するには、 ImSortableTable#setCheckedRadioPosition(Object position) を利用してください。

Defined in im_sortable_table_cell_radio.js

コンストラクタの概要
ImSortableTableCell4Radio(observer, htmlElement, position, config, data)
コンストラクタ。
メソッドの概要
<static> Object createDefaultConfig(argId, argName, argWidth)
ImSortableTableのデフォルトコンフィグオブジェクトを生成します（ラジオボタン用）。
クラスから継承されたフィールドImSortableTableCell
getObserver, getPosition, getConfig, getCellData, setConfig, updateCellData, overrideProperty

コンストラクタの詳細

ImSortableTableCell4Radio

ImSortableTableCell4Radio(observer, htmlElement, position, config, data)
    コンストラクタ。

    開発者が明示的にこのコンストラクタを利用する必要はありません。
メソッドの詳細

createDefaultConfig

<static> Object createDefaultConfig(argId, argName, argWidth)
    ImSortableTableのデフォルトコンフィグオブジェクトを生成します（ラジオボタン用）。
    Parameters:
      id - 列を識別するためのID
      name - [option] ヘッダに表示される文字列（任意）
      width - [option] 列の幅（任意）
    Returns:
      デフォルト値を格納したImSortableTableのラジオボタン用コンフィグオブジェクト
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTableCell4Text

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImSortableTableCell4Text

Object
   |
   +--ImAbstractSelfEventHandler
         |
         +--ImSortableTableCell
               |
               +--ImSortableTableCell4Text
class ImSortableTableCell4Text
extends ImSortableTableCell

ImSortableTableのテキスト用セルオブジェクト。
テキスト用セルオブジェクトの詳しい説明は、こちらを参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Defined in im_sortable_table_cell_text.js

コンストラクタの概要
ImSortableTableCell4Text(observer, htmlElement, position, config, data)
コンストラクタ。
メソッドの概要
 Object getTextElement()
編集中の<input type="text">エレメントを取得します。
<static> Object createDefaultConfig(argId, argName, argWidth)
ImSortableTableのデフォルトコンフィグオブジェクトを生成します（テキスト用）。
クラスから継承されたフィールドImSortableTableCell
getObserver, getPosition, getConfig, getCellData, setConfig, updateCellData, overrideProperty

コンストラクタの詳細

ImSortableTableCell4Text

ImSortableTableCell4Text(observer, htmlElement, position, config, data)
    コンストラクタ。

    開発者が明示的にこのコンストラクタを利用する必要はありません。
メソッドの詳細

getTextElement

Object getTextElement()
    編集中の<input type="text">エレメントを取得します。
    このセルが編集中ではない場合、nullが返却されます。
    Returns:
      このセルが編集中の場合、編集中の<input type="text">エレメント。 このセルが編集中ではない場合、null。

createDefaultConfig

<static> Object createDefaultConfig(argId, argName, argWidth)
    ImSortableTableのデフォルトコンフィグオブジェクトを生成します（テキスト用）。
    Parameters:
      id - 列を識別するためのID
      name - [option] ヘッダに表示される文字列（任意）
      width - [option] 列の幅（任意）
    Returns:
      デフォルト値を格納したImSortableTableのテキスト用コンフィグオブジェクト
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


ImSortableTable オブジェクト

ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクトです。
  • 説明
  • トリガーオブジェクトについて
  • サンプルコード

説明

ImSortableTableオブジェクトを利用してソート可能なテーブル（以下、Sortableテーブル）
を表示させる手順は以下の通りです。
  1. ImSortableTableオブジェクトの生成 ・・・ コンストラクタ
  2. コンフィグの設定 ・・・ setConfigs()
  3. データの設定 ・・・ setData()
  4. Sortableテーブルの表示 ・・・ display()

Sortableテーブルに表示されているデータを取得するには、getData() を実行します。

1. ImSortableTableオブジェクトの生成

ImSortableTableオブジェクトは、HTMLページ内のDIV要素を操作し、Sortableテーブルを作成・表示します。
表示対象のDIV要素は、ImSortableTableオブジェクトのコンストラクタにて指定します。

2. コンフィグの設定

Sortableテーブルのソート方法、表示形式、列幅等の各種設定は、
各フォーマット用コンフィグオブジェクトを ImSortableTableオブジェクトに設定することで行います。
（具体的には、コンフィグオブジェクトを格納した配列を setConfigs() にて設定します）
フォーマットの指定は列単位で行います。（同じ列に異なるフォーマットを指定することは出来ません）

Sortableテーブルのセルには、以下のフォーマットが指定可能です。
フォーマット | コンフィグオブジェクトの構成
テキスト | ImSortableTableCell4Textオブジェクト を参照
数値 | ImSortableTableCell4Numberオブジェクト を参照
チェックボックス | ImSortableTableCell4Checkboxオブジェクト を参照
ラジオボタン | ImSortableTableCell4Radioオブジェクト を参照
イメージ | ImSortableTableCell4Imageオブジェクト を参照

具体的なコンフィグオブジェクトの生成 および 設定方法は、サンプルコードを参照してください。

3. データの設定

表示するデータは、setData()で設定します。
コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）が、 データ設定時のオブジェクトのプロパティ名となります。

id="prop0" | id="prop1" | id="prop2"
value0-0 | value0-1 | value0-2
value1-0 | value1-1 | value1-2

例えば、上記のようなテーブルを表示したい場合、 setData()の引数に渡すデータオブジェクトは以下のようになります。
データオブジェクトのサンプル
var datas = new Array();
    datas[0] = new Object();
    datas[0].prop0 = "value0-0";
    datas[0].prop1 = "value0-1";
    datas[0].prop2 = "value0-2";

    datas[1] = new Object();
    datas[1].prop0 = "value1-0";
    datas[1].prop1 = "value1-1";
    datas[1].prop2 = "value1-2";

// データを設定
imSortableTable.setData(datas);

具体的なデータの設定方法は、サンプルコードを参照してください。

4. Sortableテーブルの表示

ImSortableTableオブジェクトの生成、 コンフィグの設定、 データの設定を行うことによって、Sortableテーブルの表示準備が整いました。
Sortableテーブルを表示するには、display()メソッドを実行します。
display()メソッドは、現在設定されているコンフィグ および データの表示を行います。

トリガーオブジェクトについて

トリガーオブジェクトとは、セル上で何らかのイベントが発生した際、 そのイベントに対応する処理が発生する前または後に実行される関数を格納したオブジェクトです。
トリガーオブジェクトがコンフィグオブジェクトの「beforeTriggers」プロパティに格納されている場合は、 イベントに対応する処理が発生する前にトリガーが実行されます（ビフォア・トリガー）。
トリガーオブジェクトがコンフィグオブジェクトの「afterTriggers」プロパティに格納されている場合は、 イベントに対応する処理が発生した後にトリガーが実行されます（アフター・トリガー）。

トリガーオブジェクトの構成は以下の通りです。
プロパティ名(型) 説明
セルの状態を表すプロパティ名
(Object) 		イベントタイプ名
(Function) 		トリガーとして実行する関数。
この関数には以下の引数が渡されます。
パラメータ(型) | 説明
event (Object) | イベント発生時のイベントオブジェクト
targetCell (Object) | イベントが発生したセルのImSortableTableCell4XXXXのインスタンス。 （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Textのインスタンス））

※ 各セルフォーマットの「状態」と「イベントタイプ」の関係は以下を参照してください。
フォーマット | 「状態」と「イベントタイプ」の関係
テキスト | ImSortableTableCell4Textオブジェクト を参照
数値 | ImSortableTableCell4Numberオブジェクト を参照
チェックボックス | ImSortableTableCell4Checkboxオブジェクト を参照
ラジオボタン | ImSortableTableCell4Radioオブジェクト を参照
イメージ | ImSortableTableCell4Imageオブジェクト を参照

ビフォア・トリガーを利用することで、セルの編集確定処理をキャンセルすることが出来ます。 （フォーマットが「テキスト」または「数値」の場合）

セルのフォーマットが「テキスト」または 「数値」の場合、
編集が確定する際に「Edit状態（＝編集中状態）」の「completeEditイベント（＝編集確定イベント）」が発生します。
この状態とイベントに対して設定したビフォア・トリガーで false を返却すると、
イベントに対応する処理、つまり、編集の確定を行いません。（イベント処理の中止）

なお、イベント処理の中止を行うことが出来るビフォア・トリガーは以下の状態に限られます。
（下記以外のビフォア・トリガーでは false を返却しないでください）
フォーマットタイプ | 状態 | イベント | 説明
テキスト | Edit | completeEdit | 編集の確定
 |  | cancelEdit | 編集のキャンセル
数値 | Edit | completeEdit | 編集の確定
 |  | cancelEdit | 編集のキャンセル

以下に、トリガーオブジェクトのサンプルを示します。
ビフォア・トリガーオブジェクトのサンプル（テキスト用）
var trigger = {
      Unselect : {
          click : function(event, targetCell){
            var pos = targetCell.getPosition();
            alert(pos.row + " : " + pos.col + "がクリックされました");
          },
          mouseover : function(event, targetCell){
            // 処理を記述
          }
      },
      Edit : {
          completeEdit : function(event, targetCell){
            var elem = targetCell.getTextElement();

            if(!elem.value || elem.value.length < 5){
              elem.focus();
              alert("5桁以上の値を入力してください。");
              return false;
            }
          }
      }
}

// コンフィグオブジェクトの「beforeTriggers」配列の要素として追加します。
sampleConfigObject.beforeTriggers.push(trigger);
トリガーのサンプルコードもあわせてご参照ください。

サンプルコード

※以下のサンプルコード内で使用されているJavascriptソースや画像のURLを適宜変更してください。
サンプル（.html ファイル）
<html>
<head>
  <title>ImSortableTable サンプル</title>

  <link rel="stylesheet" type="text/css" href="../css/im_sortable_table.css"/>

  <script type="text/javascript" src="../csjs/prototype.js"></script>
  <script type="text/javascript" src="../csjs/im_abstract_self_event_handler.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_sortable_table.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_sortable_table_cell.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_header_column_resizer.js"></script>

  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_header.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_header_checkbox.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_text.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_number.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_checkbox.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_radio.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_image.js"></script>

  <script language="javascript">

    var targetDivId = "IM_STBL_SAMPLE";  // Sortableテーブル表示対象DIV要素のID

    /**
     * Sortableテーブルを表示します。
     */
    function show(){

      // 1. ImSortableTableオブジェクトの生成
      var sortTable = new ImSortableTable(targetDivId, 600, 300);

      // 2. コンフィグの設定
      var configs = createConfigs();
      sortTable.setConfigs(configs);

      // 3. データの設定
      var data = createData("サンプル", 15);
      sortTable.setData(data);

      // 4. Sortableテーブルの表示
      sortTable.display();
    }

    /**
     * コンフィグオブジェクトを格納した配列を作成します。
     */
    function createConfigs(){

      // デフォルトコンフィグオブジェクトを作成
      var configs = new Array();
      configs[0] = ImSortableTableCell4Number.createDefaultConfig  ("numberProp",   "(A) ナンバー", 100);
      configs[1] = ImSortableTableCell4Text.createDefaultConfig    ("textProp",     "(B) テキスト", 150);
      configs[2] = ImSortableTableCell4Checkbox.createDefaultConfig("checkboxProp", "(C) チェック",  30);
      configs[3] = ImSortableTableCell4Radio.createDefaultConfig   ("radioProp1",   "(D) ラジオ１", 100);
      configs[4] = ImSortableTableCell4Radio.createDefaultConfig   ("radioProp2",   "(E) ラジオ２", 100);
      configs[5] = ImSortableTableCell4Image.createDefaultConfig   ("imageProp",    "(F) イメージ", 100);

      // (A) ナンバー：インライン編集可能 (入力可能桁数10桁)
      configs[0].editable = true;
      configs[0].maxlength = 10;

      // (B) テキスト：インライン編集可能
      configs[1].editable = true;

      // (F) イメージ：クリック時に一行削除
      configs[5].defaultImageURL   = IM_STBL_CONTEXT_PATH + "/images/sortable_table/delete_ghost.gif";
      configs[5].mouseOverImageURL = IM_STBL_CONTEXT_PATH + "/images/sortable_table/delete_mouseover.gif";
      configs[5].activeImageURL    = IM_STBL_CONTEXT_PATH + "/images/sortable_table/delete_active.gif";
      configs[5].imageTitle        = "削除";
      configs[5].imageWidth        = 13;
      configs[5].imageHeight       = 13;
      configs[5].onClickFunction   = function(event, targetCell){
                                         // クリックされた行番号を取得
                                         var targetRow = targetCell.getPosition().row;

                                         // ImSortableTableのインスタンスを取得
                                         var sortableTable = targetCell.getObserver();

                                         // 行を削除
                                         sortableTable.removeRowData(targetRow);
                                     };
      return configs;
    }

    /**
     * （サンプル用）
     * データオブジェクトを格納した配列を作成します。
     */
    function createData(str, max){

      var data = new Array();

      for(var idx = 0 ; idx < max ; idx++){
        data[idx] = new Object();

        // (A) ナンバー
        data[idx].numberProp = idx * 1000;

        // (B) テキスト
        data[idx].textProp = str + "テキスト" + idx;

        // (C) チェック（偶数行をチェック状態にしています）
        data[idx].checkboxProp = (idx % 2 == 0) ? true : false;

        // (D) ラジオ１（先頭行をチェック状態にしています）
        data[idx].radioProp1 = (idx == 0) ? true : false;

        // (E) ラジオ２（最終行をチェック状態にしています）
        data[idx].radioProp2 = (idx == max - 1) ? true : false;

        // (F) イメージ
        data[idx].imageProp = str + "イメージ" + idx;
      }

      return data;

    }

    /**
     * 行データを追加します。
     */
    function addRowData(){

      // データ挿入位置を取得
      var insertRowIdx = parseInt(document.getElementById("addRowDataIndex").value, 10);

      // サンプルデータを一行分作成
      var data = createData("新規追加", 1);

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // データを「insertRowIdx」行目に追加します。
      sortTable.addRowData(data[0], insertRowIdx);
    }

    /**
     * 「(C) チェック」がチェック状態になっている行を削除します。
     */
    function onClickDeleteSelectedItem(){

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // データを取得
      var data = sortTable.getData();

      // 「(C) チェック」がチェック状態となっていないデータを保持
      var notDeletedArray = new Array();
      for(var rowIdx = 0, maxRow = data.length ; rowIdx < maxRow ; rowIdx++){
        if(data[rowIdx].checkboxProp != true){
          notDeletedArray.push(data[rowIdx]);
        }
      }

      // 削除対象以外のデータで再表示
      sortTable.setData(notDeletedArray);
      sortTable.display();
    }

    /**
     * 全データを削除します。
     */
    function onClickDeleteAllItem(){

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // 全データを削除
      sortTable.setData(null);

      // 再表示
      sortTable.display();
    }

    /**
     * ソートします。
     */
    function sort(sortDirection){

      // データ挿入位置を取得
      var sortIdx = parseInt(document.getElementById("sortIndex").value, 10);

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // ソート
      sortTable.sort(sortIdx, sortDirection);
    }

    /**
     * 現在のデータを表示します。
     */
    function outputData(){

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // データを取得
      var data = sortTable.getData();

      // alert()にデータ表示
      var debugStr = "";
      for(var idx in data){
        if(data.hasOwnProperty(idx)){
          for(var propName in data[idx]){
            if(data[idx].hasOwnProperty(propName)){
              debugStr += "data[" + idx + "]." + propName + " = "
                          + data[idx][propName] + " [" + typeof(data[idx][propName]) + "]\n";
            }
          }
          debugStr += "------------\n";
        }
      }

      alert(debugStr);
    }
  </script>

</head>

<!-- onload 時にSortableテーブル表示処理を実行 -->
<body onload="show();">
  <!--
  ################################################
    このDIV要素に Sortableテーブル を表示します。
  ################################################
  -->
  <div id="IM_STBL_SAMPLE"></div>

  <br>

  <!-- 以下、Sortableテーブルを操作するための処理です -->

  <hr>
  <input type="text" id="addRowDataIndex" value="0" size="3">
  <input type="button" value="行目に新規追加" onclick="addRowData();">

  <hr>
  <input type="button" value="データを表示" onclick="outputData();">

  <hr>
  <input type="text" id="sortIndex" value="0" size="3">
  <input type="button" value="列目を昇順ソート" onclick="sort(IM_STBL_CONFIG_KEY.ASC);">
  <input type="button" value="列目を降順ソート" onclick="sort(IM_STBL_CONFIG_KEY.DESC);">

  <hr>
  <input type="button" value="チェックボックスで選択されているデータを削除" onclick="onClickDeleteSelectedItem();">
  <input type="button" value="全データを削除" onclick="onClickDeleteAllItem();">
</body>
</html>

チェックボックス的機能を画像実現するサンプル（.html ファイル）
<html>
<head>
  <title>ImSortableTable サンプル (チェックボックス的機能を画像で実現します)</title>

  <link rel="stylesheet" type="text/css" href="../css/im_sortable_table.css"/>

  <script type="text/javascript" src="../csjs/prototype.js"></script>
  <script type="text/javascript" src="../csjs/im_abstract_self_event_handler.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_sortable_table.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_sortable_table_cell.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_header_column_resizer.js"></script>

  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_header.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_text.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_image.js"></script>

  <script language="javascript">

    var targetDivId = "IM_STBL_SAMPLE";  // Sortableテーブル表示対象DIV要素のID

    /**
     * Sortableテーブルを表示します。
     */
    function show(){

      // 1. ImSortableTableオブジェクトの生成
      var sortTable = new ImSortableTable(targetDivId, 400, 200);

      // 2. コンフィグの設定
      var configs = createConfigs();
      sortTable.setConfigs(configs);

      // 3. データの設定
      var data = createData("サンプル", 5);
      sortTable.setData(data);

      // 4. Sortableテーブルの表示
      sortTable.display();
    }

    /**
     * コンフィグオブジェクトを格納した配列を作成します。
     */
    function createConfigs(){

      var configs = new Array();
      configs[0] = ImSortableTableCell4Image.createDefaultConfig("imageProp", "(A) ピン",      60);
      configs[1] = ImSortableTableCell4Text.createDefaultConfig ("textProp",  "(B) テキスト", 250);

      configs[0].sortable = true; // (A) イメージ：ソート可能
      configs[1].editable = true; // (B) テキスト：インライン編集可能

      return configs;
    }

    /**
     * （サンプル用）
     * データオブジェクトを格納した配列を作成します。
     */
    function createData(str, max){

      var data = new Array();

      for(var idx = 0 ; idx < max ; idx++){

        data[idx] = new Object();

        // ******************
        // **** (A) ピン ****（チェックボックス的機能を画像で実現します）
        // ******************
        // クリックされた時に実行される関数を定義
        function reverseImageProp(event, targetCell){

          // データを反転させる
          var dataObject = (targetCell.data.value == "off") ? imageDataObject4On : imageDataObject4Off;

          // コンフィグを更新（イメージを反映させるため）
          var overriddenConfig = targetCell.overrideProperty(targetCell.getConfig(), dataObject);
          targetCell.setConfig(overriddenConfig);

          // データを更新
          targetCell.updateCellData(dataObject);

          // mouseoutイベント発生時の動作を行う（イメージを初期化するため）
          targetCell.doActionTransition("Unselect", "mouseout", event);
        };

        // 非表示状態のデータオブジェクト
        var imageDataObject4Off = {
          value             : "off",

          defaultImageURL   : IM_STBL_CONTEXT_PATH + "/images/sortable_table/blank.gif",
          mouseOverImageURL : IM_STBL_CONTEXT_PATH + "/images/sortable_table/pin_white.gif",
          activeImageURL    : IM_STBL_CONTEXT_PATH + "/images/sortable_table/pin_gray.gif",
          onClickFunction   : reverseImageProp,
          imageWidth        : 16,
          imageHeight       : 16,
          imageTitle        : "クリックでピンを刺します",
          imageBorder       : 0,
          imageTabIndex     : -1
        };

        // 表示状態のデータオブジェクト
        var imageDataObject4On = {
          value             : "on",

          defaultImageURL   : IM_STBL_CONTEXT_PATH + "/images/sortable_table/pin_gray.gif",
          mouseOverImageURL : IM_STBL_CONTEXT_PATH + "/images/sortable_table/pin_gray.gif",
          activeImageURL    : IM_STBL_CONTEXT_PATH + "/images/sortable_table/pin_gray.gif",
          onClickFunction   : reverseImageProp,
          imageWidth        : 16,
          imageHeight       : 16,
          imageTitle        : "クリックでピンを抜きます",
          imageBorder       : 0,
          imageTabIndex     : -1
        };

        // (A) ピンのデータオブジェクトを設定
        data[idx].imageProp = imageDataObject4Off;

        // **********************
        // **** (B) テキスト ****
        // **********************
        data[idx].textProp   = str + "テキスト" + idx;
      }

      return data;
    }

    /**
     * 現在のデータを表示します。
     */
    function outputData(){

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // データを取得
      var data = sortTable.getData();

      // alert()にデータ表示
      var debugStr = "";
      for(var idx in data){
        if(data.hasOwnProperty(idx)){
          for(var propName in data[idx]){
            if(data[idx].hasOwnProperty(propName)){
              if(propName == "imageProp"){
                debugStr += "data[" + idx + "].imageProp.value" + " = "
                            + data[idx].imageProp.value + " [" + typeof(data[idx].imageProp.value) + "]\n";
              }
              else{
                debugStr += "data[" + idx + "]." + propName + " = "
                            + data[idx][propName] + " [" + typeof(data[idx][propName]) + "]\n";
              }
            }
          }
          debugStr += "------------\n";
        }
      }

      alert(debugStr);
    }
  </script>

</head>

<!-- onload 時にSortableテーブル表示処理を実行 -->
<body onload="show();">
  <!--
  ################################################
    このDIV要素に Sortableテーブル を表示します。
  ################################################
  -->
  <div id="IM_STBL_SAMPLE"></div>

  <br>

  <!-- 以下、Sortableテーブルを操作するための処理です -->

  <hr>
  <input type="button" value="データを表示" onclick="outputData();">

</body>
</html>

トリガーのサンプル（.html ファイル）
<html>
<head>
  <title>ImSortableTable サンプル (トリガー)</title>

  <link rel="stylesheet" type="text/css" href="../css/im_sortable_table.css"/>

  <script type="text/javascript" src="../csjs/prototype.js"></script>
  <script type="text/javascript" src="../csjs/im_abstract_self_event_handler.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_sortable_table.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_sortable_table_cell.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_header_column_resizer.js"></script>

  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_header.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/parts/im_sortable_table_cell_text.js"></script>

  <script language="javascript">

    var targetDivId = "IM_STBL_SAMPLE";  // Sortableテーブル表示対象DIV要素のID

    /**
     * Sortableテーブルを表示します。
     */
    function show(){

      // 1. ImSortableTableオブジェクトの生成
      var sortTable = new ImSortableTable(targetDivId, 400, 200);

      // 2. コンフィグの設定
      var configs = createConfigs();
      sortTable.setConfigs(configs);

      // 3. データの設定
      var data = createData("サンプル", 5);
      sortTable.setData(data);

      // 4. Sortableテーブルの表示
      sortTable.display();
    }

    /**
     * コンフィグオブジェクトを格納した配列を作成します。
     */
    function createConfigs(){

      // 「(A) テキスト」のビフォア・トリガーオブジェクト
      var beforeTrigger4TextPropA = {
        Edit : {
          completeEdit : function(event, targetCell){
            var elem = targetCell.getTextElement();

            if(elem.value.length < 5){
              elem.focus();
              alert("5桁以上の値を入力してください。");
              return false;  // 編集確定をキャンセル
            }
          }
        }
      }

      // 「(B) テキスト」のアフター・トリガーオブジェクト
      var afterTrigger4TextPropB = {
        Unselect : {
          click : function(event, targetCell){
            var pos = targetCell.getPosition();
            alert(pos.row + " : " + pos.col + "がクリックされました");
          }
        },
        Edit : {
          completeEdit : function(event, targetCell){
            var pos = targetCell.getPosition();
            var cellData = targetCell.getCellData();
            alert(pos.row + " : " + pos.col + "に「" + cellData + "」が入力されました。");
          }
        }
      }

      // デフォルトコンフィグ作成
      var configs = new Array();
      configs[0] = ImSortableTableCell4Text.createDefaultConfig("textPropA", "(A) テキスト", 150);
      configs[1] = ImSortableTableCell4Text.createDefaultConfig("textPropB", "(B) テキスト", 150);

      configs[0].editable = true; // (A) テキスト：インライン編集可能
      configs[1].editable = true; // (B) テキスト：インライン編集可能

      configs[0].beforeTriggers.push(beforeTrigger4TextPropA); // (A) テキスト：ビフォア・トリガー
      configs[1].afterTriggers.push(afterTrigger4TextPropB);   // (B) テキスト：アフター・トリガー

      return configs;
    }

    /**
     * （サンプル用）
     * データオブジェクトを格納した配列を作成します。
     */
    function createData(str, max){

      var data = new Array();

      for(var idx = 0 ; idx < max ; idx++){

        data[idx] = new Object();

        // (A) テキスト
        data[idx].textPropA = "A" + idx;

        // (B) テキスト
        data[idx].textPropB = str + "テキストB" + idx;
      }

      return data;
    }

    /**
     * 現在のデータを表示します。
     */
    function outputData(){

      // ImSortableTableオブジェクトのキャッシュを取得
      var sortTable = ImSortableTable.getCachedInstance(targetDivId);

      // データを取得
      var data = sortTable.getData();

      // alert()にデータ表示
      var debugStr = "";
      for(var idx in data){
        if(data.hasOwnProperty(idx)){
          for(var propName in data[idx]){
            if(data[idx].hasOwnProperty(propName)){
              debugStr += "data[" + idx + "]." + propName + " = "
                          + data[idx][propName] + " [" + typeof(data[idx][propName]) + "]\n";
            }
          }
          debugStr += "------------\n";
        }
      }

      alert(debugStr);
    }
  </script>

</head>

<!-- onload 時にSortableテーブル表示処理を実行 -->
<body onload="show();">
  <!--
  ################################################
    このDIV要素に Sortableテーブル を表示します。
  ################################################
  -->
  <div id="IM_STBL_SAMPLE"></div>

  <br>

  <!-- 以下、Sortableテーブルを操作するための処理です -->

  <hr>
  <input type="button" value="データを表示" onclick="outputData();">
</body>
</html>


ImXPath

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

クラス ImXPath

Object
   |
   +--ImXPath
class ImXPath

XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
ImXPathオブジェクトの利用およびサンプルコードは こちら を参照してください。

ロケーションパスについて

ImXPathの各メソッドで指定可能な「ロケーションパス」で使用可能な構文は以下になります。
以下の構文を"/"（半角スラッシュ）でつないだものがロケーションパスになります。

構文 | 内容
TagName | TagNameノードが選択されます
text() | 1テキストノードが選択されます
@name | name属性が選択されます
TagName[1] | TagNameノードのうち１番目の要素が選択されます
TagName[last()] | TagNameノードのうち最後の要素が選択されます
TagName[@name=value] | TagNameノードのうち、 name属性がvalueの要素が選択されます

例) rootノードの子要素sampleノードの内、id属性が"001"のノードのテキストノードを選択する例です。
/root/sample[@id=001]/text()

Version: 1.0

Author: INTRAMART
Defined in im_xpath.js

フィールドの概要
<static> <final> Number | BOOLEAN 戻り値の型（真偽値）
<static> <final> Number | NODE 戻り値の型（ノード）
<static> <final> Number | NUMBER 戻り値の型（数値）
<static> <final> Number | STRING 戻り値の型（文字列）
コンストラクタの概要
ImXPath()
XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
メソッドの概要
<static> void | add(<Object> doc, <String> path, <String> value) XMLを解析して値を追加します。
<static> Object | createXmlDocument() 新しいXMLドキュメントを生成します。
<static> Object | evaluate(<Object> doc, <String> path, <Boolean> isArray, <Number> type) XMLドキュメントオブジェクトから、ロケーションパス で選択された値を取得します。
<static> Boolean | remove(<Object> doc, <String> path) XMLを解析して値やノードを削除します。
<static> void | replace(<Object> doc, <String> path, <String> value) XMLを解析して値を置き換えます。

フィールドの詳細

BOOLEAN

<static> <final> Number BOOLEAN
    戻り値の型（真偽値）

    See Also:
    Constant Field Values

NODE

<static> <final> Number NODE
    戻り値の型（ノード）

    See Also:
    Constant Field Values

NUMBER

<static> <final> Number NUMBER
    戻り値の型（数値）

    See Also:
    Constant Field Values

STRING

<static> <final> Number STRING
    戻り値の型（文字列）

    See Also:
    Constant Field Values
コンストラクタの詳細

ImXPath

ImXPath()
    XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
    Version: 1.0

    Author: INTRAMART
メソッドの詳細

add

<static> void add(<Object> doc, <String> path, <String> value)
    XMLを解析して値を追加します。
    指定されたXMLドキュメント内にロケーションパス のノードが既に存在しているかどうかに関わらず、新しいノードを作成します。
    ロケーションパスで、属性値が選択された場合は値を置き換えます。
    Parameters:
      doc - XMLドキュメント
      path - ロケーションパス
      value - 追加する値

createXmlDocument

<static> Object createXmlDocument()
    新しいXMLドキュメントを生成します。
    Returns:
      XMLドキュメント

evaluate

<static> Object evaluate(<Object> doc, <String> path, <Boolean> isArray, <Number> type)
    XMLドキュメントオブジェクトから、ロケーションパス で選択された値を取得します。
    取得された値は、typeで指定された型で返却します。
    Parameters:
      doc - 解析を行うXMLドキュメント
      path - ロケーションパス
      isArray - [option]返却値を配列で受け取るかどうか

      選択された値が複数存在する場合に、配列で返すかどうかを指定します。
      falseが指定され、かつ複数の値が選択された場合は最初の要素の値が返却されます。
      省略された場合は複数の値が選択された場合のみ、配列で返却されます。

      type - [option]返却値の型

      以下を指定できます。
      設定値 | 型 | 説明
ImXPath.NODE | ノード | 選択されたノードを返却します。 ロケーションパスで属性値が選択された場合は、その属性値を持つノードを返却します。 typeの指定が省略された場合は、ノードで返されます。
ImXPath.STRING | 文字列 | 選択された値を文字列として返します。
ImXPath.NUMBER | 数値 | 選択された値を数値として返します。 数値にできない値が選択された場合は、NaNを返します。
ImXPath.BOOLEAN | 真偽値 | 選択された値が"true"（大文字、小文字は区別しない） の場合はtrueを返します。それ以外の場合はfalseを返します。
    Returns:
      解析結果

remove

<static> Boolean remove(<Object> doc, <String> path)
    XMLを解析して値やノードを削除します。
    Parameters:
      doc - XMLドキュメント
      path - ロケーションパス
    Returns:
      削除成功/失敗

replace

<static> void replace(<Object> doc, <String> path, <String> value)
    XMLを解析して値を置き換えます。
    指定されたXMLドキュメント内でロケーションパス の値が既に存在していた場合は、その値を置き換えます。
    存在しない場合は、新しくノードや属性を作成します。
    Parameters:
      doc - XMLドキュメント
      path - ロケーションパス
      value - 置き換える値
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


Index ()

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
A B C D E G I N O P R S T U

A

add(doc, path, value) - Class method in class ImXPath
addRowData(rowData, insertRowIdx) - Instance method in class ImSortableTable
AJAX_COMPLETE - Class field in class ImAjax
AJAX_PARSE_JSON_ERR - Class field in class ImAjax
AJAX_TIMEOUT - Class field in class ImAjax

B

BOOLEAN - Class field in class ImXPath
Browser - Class field in class ImAjax

C

checkJSONString(jsonString) - Class method in class ImJson
CONTENT_TYPE_IS_NOT_SPECIFIED - Class field in class ImAjax
createDefaultConfig(argId, argName, argWidth) - Class method in class ImSortableTableCell4Checkbox
createDefaultConfig(argId, argName, argWidth) - Class method in class ImSortableTableCell4Image
createDefaultConfig(argId, argName, argWidth) - Class method in class ImSortableTableCell4Number
createDefaultConfig(argId, argName, argWidth) - Class method in class ImSortableTableCell4Radio
createDefaultConfig(argId, argName, argWidth) - Class method in class ImSortableTableCell4Text
createXmlDocument() - Class method in class ImXPath

D

display() - Instance method in class ImSortableTable

E

evaluate(doc, path, isArray, type) - Class method in class ImXPath

G

getAdd(nTarget) - Instance method in class RealNumber
getBrowserName() - Class method in class ImAjax
getCachedInstance(id) - Class method in class ImSortableTable
getCellData() - Instance method in class ImSortableTableCell
getCellObject(row, col) - Instance method in class ImSortableTable
getConfig() - Instance method in class ImSortableTableCell
getConfigs() - Instance method in class ImSortableTable
getContextPath() - Class method in class ImSortableTable
getCookie(sName) - Class method in class GLOBALS
getData() - Instance method in class ImSortableTable
getDiv(nTarget) - Instance method in class RealNumber
getMlt(nTarget) - Instance method in class RealNumber
getObserver() - Instance method in class ImSortableTableCell
getPosition() - Instance method in class ImSortableTableCell
getSub(nTarget) - Instance method in class RealNumber
getTextElement() - Instance method in class ImSortableTableCell4Text
getValue() - Instance method in class RealNumber
GLOBALS - class GLOBALS

I

ImAjax - class ImAjax
ImAjax() - Constructor in class ImAjax
ImHeaderColumnResizer - class ImHeaderColumnResizer
ImHeaderColumnResizer(tableElemId4Header, tableElemId4Data, width, height) - Constructor in class ImHeaderColumnResizer
ImJson - class ImJson
ImJson() - Constructor in class ImJson
ImSortableTable - class ImSortableTable
ImSortableTable(id, width, height) - Constructor in class ImSortableTable
ImSortableTableCell - class ImSortableTableCell
ImSortableTableCell() - Constructor in class ImSortableTableCell
ImSortableTableCell4Checkbox - class ImSortableTableCell4Checkbox
ImSortableTableCell4Checkbox(observer, htmlElement, position, config, data) - Constructor in class ImSortableTableCell4Checkbox
ImSortableTableCell4Image - class ImSortableTableCell4Image
ImSortableTableCell4Image(observer, htmlElement, position, config, data) - Constructor in class ImSortableTableCell4Image
ImSortableTableCell4Number - class ImSortableTableCell4Number
ImSortableTableCell4Number(observer, htmlElement, position, config, data) - Constructor in class ImSortableTableCell4Number
ImSortableTableCell4Radio - class ImSortableTableCell4Radio
ImSortableTableCell4Radio(observer, htmlElement, position, config, data) - Constructor in class ImSortableTableCell4Radio
ImSortableTableCell4Text - class ImSortableTableCell4Text
ImSortableTableCell4Text(observer, htmlElement, position, config, data) - Constructor in class ImSortableTableCell4Text
ImXPath - class ImXPath
ImXPath() - Constructor in class ImXPath
INDENT_STRING - Class field in class ImJson
initializeTable() - Instance method in class ImHeaderColumnResizer
isDateData(nYear, nMonth, nDay, nHour, nMinutes, nSecond) - Class method in class GLOBALS
isLeapYear(nYear) - Class method in class GLOBALS

N

NODE - Class field in class ImXPath
NUMBER - Class field in class ImXPath

O

openNewWindow(name, status) - Class method in class GLOBALS
overrideProperty(superObject, overrideObject) - Instance method in class ImSortableTableCell

P

PARSE_JSON_ERROR_MESSAGE - Class field in class ImJson
parseJSON(jsonString) - Class method in class ImJson

R

RealNumber - class RealNumber
RealNumber(nNumber) - Constructor in class RealNumber
remove(doc, path) - Class method in class ImXPath
removeCookie(sName) - Class method in class GLOBALS
removeRowData(removeRowIdx) - Instance method in class ImSortableTable
replace(doc, path, value) - Class method in class ImXPath
requestAsyncSend(url, data, callback, method) - Class method in class ImAjax
requestSend(url, data, callback, method) - Class method in class ImAjax
revreseCheckedStatus() - Instance method in class ImSortableTableCell4Checkbox

S

setCheckedRadioPosition(position) - Instance method in class ImSortableTable
setConfig(config) - Instance method in class ImSortableTableCell
setConfigs(configs) - Instance method in class ImSortableTable
setCookie(sName, sValue, dExpires, sDomain, sPath, bSecure) - Class method in class GLOBALS
setData(data) - Instance method in class ImSortableTable
setDataTableClassName(dataTableClassName) - Instance method in class ImSortableTable
setHeaderTableClassName(headerTableClassName) - Instance method in class ImSortableTable
setRedrawHeader() - Instance method in class ImSortableTable
setResizable(resizable) - Instance method in class ImHeaderColumnResizer
setResizableCheckFunc(resizableCheckFunc) - Instance method in class ImHeaderColumnResizer
setRowSelector(rowSelector) - Instance method in class ImSortableTable
sort(colIdx, sortDirection) - Instance method in class ImSortableTable
STRING - Class field in class ImXPath

T

toJSONString(value, debugFlg) - Class method in class ImJson
toString() - Instance method in class RealNumber
TYPE_ARRAY - Class field in class ImJson
TYPE_BOOLEAN - Class field in class ImJson
TYPE_DATE - Class field in class ImJson
TYPE_FUNCTION - Class field in class ImJson
TYPE_NULL - Class field in class ImJson
TYPE_NUMBER - Class field in class ImJson
TYPE_OBJECT - Class field in class ImJson
TYPE_STRING - Class field in class ImJson
TYPE_UNDEFINED - Class field in class ImJson
TYPE_UNKNOWN - Class field in class ImJson
TYPE_XML - Class field in class ImJson

U

updateCellData(data) - Instance method in class ImSortableTableCell
updateCheckedStatus(checkedStatus) - Instance method in class ImSortableTableCell4Checkbox
A B C D E G I N O P R S T U
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


Generated Javascript Documentation

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


Overview ()

intra-mart 6.1.14 Client Side JavaScript

全てのクラス

Files
im_ajax_request.js
im_cookie.js
im_date.js
im_header_column_resizer.js
im_json.js
im_realnumber.js
im_sortable_table.js
im_sortable_table_cell.js
im_sortable_table_cell_checkbox.js
im_sortable_table_cell_image.js
im_sortable_table_cell_number.js
im_sortable_table_cell_radio.js
im_sortable_table_cell_text.js
im_window.js
im_xpath.js


im_ajax_request.js
ImAjax


im_cookie.js


im_date.js


im_header_column_resizer.js
ImHeaderColumnResizer


im_json.js
ImJson


im_realnumber.js
RealNumber


im_sortable_table.js
ImSortableTable


im_sortable_table_cell.js
ImSortableTableCell


im_sortable_table_cell_checkbox.js
ImSortableTableCell4Checkbox


im_sortable_table_cell_image.js
ImSortableTableCell4Image


im_sortable_table_cell_number.js
ImSortableTableCell4Number


im_sortable_table_cell_radio.js
ImSortableTableCell4Radio


im_sortable_table_cell_text.js
ImSortableTableCell4Text


im_window.js


im_xpath.js
ImXPath


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_ajax_request.js

概要

XMLHttpRequest 通信を簡単に行うことができるオブジェクトです。
ImAjax オブジェクトを利用することによって、 XMLHttpRequest による通信を簡単に実装することができます。

必要なファイル

  • im_json.js

リクエストデータについて

ImAjax オブジェクトを利用した通信のリクエストデータは、 指定された送信データの形式によって自動的に変換されます。

例えば、送信データにJavaScriptオブジェクトを指定した場合、 リクエストデータは、自動的にJSON形式の文字列に変換されます。
リクエストデータを受け取ったサーバサイドでは、 JSON形式の文字列 から JavaScriptオブジェクト へ変換を行うことでリクエストデータを処理します。
また、送信データにXMLオブジェクトを指定した場合、 リクエストデータは、自動的にXML形式の文字列に変換されます。
リクエストデータを受け取ったサーバサイドでは、 XML形式の文字列 から XMLオブジェクト へ変換することでリクエストデータを処理します。
（スクリプト開発モデルの場合、 Request オブジェクトのgetParameter()、および、getParameterValue()メソッドを利用することで、 XML形式データの値を参照することもできます）

レスポンスデータについて

ImAjax オブジェクトを利用した通信のレスポンスは、通信結果オブジェクトとしてまとめられます。
通信結果オブジェクトには、エラーの有無、HTTPステータスコード、レスポンスデータ など が格納されます。
（詳しくは「通信結果オブジェクトの構成」を参照してください）

通信結果オブジェクトの「data」プロパティは、レスポンスのコンテントタイプに応じて自動的に変換されます。

例えば、コンテントタイプが「application/json」を含む場合、すなわち、レスポンスのボディがJSON形式の文字列である場合、
data プロパティには JavaScriptオブジェクト が格納されます。
また、コンテントタイプが「text/xml」を含む場合、すなわち、レスポンスのボディがXML形式の文字列である場合、
data プロパティには XMLオブジェクト が格納されます。

通信結果オブジェクトは、コールバック関数の引数として渡されます。
コールバック関数は、ImAjax.requestAsyncSend() または ImAjax.requestSend()の第三引数に指定します。

このように ImAjaxを利用することによって、クライアント と サーバ間で、 JavaScriptオブジェクト、または、XMLによるデータの受け渡しを実現することが出来ます。

通信結果オブジェクト

通信結果オブジェクトの構成は以下の通りです。
通信結果オブジェクト(Object)
 error エラー判定 (Boolean)
httpStatus HTTPステータスコード (Number)
code エラーコード (String)

error プロパティが false の場合、ImAjax.AJAX_COMPLETE (通信完了) が設定されます。

error プロパティが true の場合、以下の値が設定されます。
現象 | コード値
JSON文字列からJavaScriptオブジェクトへの変換失敗した場合 | ImAjax.AJAX_PARSE_JSON_ERR
セッションタイムアウトが発生した場合 | ImAjax.AJAX_TIMEOUT
レスポンスヘッダ「Content-Type」が特定できない場合 | ImAjax.CONTENT_TYPE_IS_NOT_SPECIFIED
上記以外 | レスポンスヘッダ名「x-jp-co-intra-mart-ajax-error-code（=ImAjax#RES_HEADER_ERROR_CODE）」に指定されている値
message code プロパティに対応したエラーメッセージ (String)
contentType レスポンスデータのコンテントタイプ (String)
data レスポンスデータ (JavaScriptオブジェクト、XMLオブジェクト、または、テキスト)

サンプルコード

クライアント（client_sample.html ファイル）
<html>
  <head>
    <title>ImAjaxオブジェクトのサンプル</title>

    <script type="text/javascript" src="csjs/im_json.js"></script>
    <script type="text/javascript" src="csjs/im_ajax_request.js"></script>

    <script language="javascript">
      // 送信先 URL
      var url = '<imart type="string" value=url></imart>';

      /**
       * 非同期通信を行います。
       */
      function async() {
        var sendData = new Object();
            sendData.clientSideText = document.form1.text1.value;

        // リクエスト送信（非同期通信）
        ImAjax.requestAsyncSend(url, sendData, callBackTest);

        alert("リクエストを非同期通信で送信しました。");
      }

      /**
       * 同期通信を行います。
       */
      function sync() {
        var sendData = new Object();
            sendData.clientSideText = document.form1.text1.value;

        // リクエスト送信（同期通信）
        ImAjax.requestSend(url, sendData, callBackTest);

        alert("リクエストを同期通信で送信しました。");
      }

      /**
       * コールバック関数
       */
      function callBackTest(result) {
        if(result.error == true){
          alert(result.message);
        }
        else {
          var alertMsg  = "========== callBackTest() で結果を受信しました。========== \n\n";
              alertMsg += result.data.serverSideText;

          alert(alertMsg);
        }
      }

    </script>
  </head>

  <body>
    <form name="form1">
      <input type="text" name="text1" size="50" value="テストです。"><br>
      <input type="button" value="リクエスト送信(非同期)" onclick="async()">
      <input type="button" value="リクエスト送信(同期)"   onclick="sync()">
    </form>
  </body>
</html>

クライアント（client_sample.js ファイル）
var url;
function init(request){
  url = Web.getContextPath() + "/" + new URL("server_sample").location();
}

サーバサイド（server_sample.js ファイル）
function init(request) {

  // JSON形式の文字列からJavaScriptオブジェクトに変換
  var messageBody = request.getMessageBody("UTF-8");
  var receiveData = ImJson.parseJSON(messageBody);

  // クライアントからのリクエストデータを表示
  Debug.console(receiveData);

  // 3秒間 スリープ（非同期通信 と 同期通信の違いを分かるようにするため）
  Debug.print("3秒間 スリープします。。。");
  Client.sleep(3000);

  // レスポンスデータを作成
  var responseData = new Object();
      responseData.serverSideText = receiveData.clientSideText + "（" + new Date() + "に受け取りました。）";

  // クライアントにデータを返却
  var jsonString = ImJson.toJSONString(responseData);
  var response = Web.getHTTPResponse();
  response.setContentType("application/json; charset=UTF-8");
  response.sendMessageBodyString(jsonString);
}

Version: 1.0

Author: INTRAMART

クラスの概要
ImAjax XMLHttpRequest 通信を簡単に行うことができるオブジェクトです。
/**
 * XMLHttpRequest 通信を簡単に行うためのメソッドを提供します。
 *
 * @fileoverview XMLHttpRequest 通信を簡単に行うことができるオブジェクトです。<br/>
 * ImAjax オブジェクトを利用することによって、
 * XMLHttpRequest による通信を簡単に実装することができます。<br/>
 *
 * <p/>
 * <h4><a name='requireSourceFile'>必要なファイル</a></h4>
 * 	<ul>
 * 		<li>im_json.js</li>
 * 	</ul>
 *
 * <p/>
 * <h4><a name='aboutRequestData'>リクエストデータについて</a></h4>
 * ImAjax オブジェクトを利用した通信のリクエストデータは、
 * 指定された送信データの形式によって自動的に変換されます。<br/>
 * <br/>
 * 例えば、送信データにJavaScriptオブジェクトを指定した場合、
 * リクエストデータは、自動的にJSON形式の文字列に変換されます。<br/>
 * リクエストデータを受け取ったサーバサイドでは、
 * JSON形式の文字列 から JavaScriptオブジェクト へ変換を行うことでリクエストデータを処理します。<br/>
 *
 * また、送信データにXMLオブジェクトを指定した場合、
 * リクエストデータは、自動的にXML形式の文字列に変換されます。<br/>
 * リクエストデータを受け取ったサーバサイドでは、
 * XML形式の文字列 から XMLオブジェクト へ変換することでリクエストデータを処理します。<br/>
 *
 * （スクリプト開発モデルの場合、
 *  Request オブジェクトのgetParameter()、および、getParameterValue()メソッドを利用することで、
 *  XML形式データの値を参照することもできます）<br/>
 * <br/>
 *
 * <p/>
 * <h4><a name='aboutResponseData'>レスポンスデータについて</a></h4>
 * ImAjax オブジェクトを利用した通信のレスポンスは、通信結果オブジェクトとしてまとめられます。<br/>
 * 通信結果オブジェクトには、エラーの有無、HTTPステータスコード、レスポンスデータ など が格納されます。<br/>
 * （詳しくは<a href="#aboutResultObject">「通信結果オブジェクトの構成」</a>を参照してください）<br/>
 * <br/>
 * 通信結果オブジェクトの「data」プロパティは、レスポンスのコンテントタイプに応じて自動的に変換されます。<br/>
 * <br/>
 * 例えば、コンテントタイプが「application/json」を含む場合、すなわち、レスポンスのボディがJSON形式の文字列である場合、<br/>
 * data プロパティには JavaScriptオブジェクト が格納されます。<br/>
 *
 * また、コンテントタイプが「text/xml」を含む場合、すなわち、レスポンスのボディがXML形式の文字列である場合、<br/>
 * data プロパティには XMLオブジェクト が格納されます。<br/>
 * <br/>
 * 通信結果オブジェクトは、コールバック関数の引数として渡されます。<br/>
 * コールバック関数は、{@link ImAjax#requestAsyncSend} または {@link ImAjax#requestSend}の第三引数に指定します。<br/>
 * <br/>
 * このように ImAjaxを利用することによって、クライアント と サーバ間で、
 * JavaScriptオブジェクト、または、XMLによるデータの受け渡しを実現することが出来ます。<br/>
 * <br/>
 *
 * <p/>
 * <h4><a name='aboutResultObject'>通信結果オブジェクト</a></h4>
 * 通信結果オブジェクトの構成は以下の通りです。 <br>
 * 	<table border="1" cellpadding="2" cellspacing="1">
 * 		<tr>
 * 			<td rowspan="10">
 * 				<div align="center">通信結果オブジェクト(Object)</div>
 * 			</td>
 * 			<td colspan="2">
 * 				<strong>error</strong>
 * 				エラー判定 (Boolean)<br/>
 * 			</td>
 * 		</tr>
 * 		<tr>
 * 			<td colspan="2">
 * 				<strong>httpStatus</strong>
 * 				HTTPステータスコード (Number)<br/>
 * 			</td>
 * 		</tr>
 * 		<tr>
 * 			<td colspan="2">
 * 				<strong>code</strong>
 * 				エラーコード (String)<br/>
 * 				<br/>
 * 				error プロパティが false の場合、{@link ImAjax#AJAX_COMPLETE} (通信完了) が設定されます。<br/>
 * 				<br/>
 * 				error プロパティが true の場合、以下の値が設定されます。<br/>
 * 				<table border="1" cellpadding="2" cellspacing="1">
 * 					<tr>
 * 						<th>現象</th>
 * 						<th>コード値</th>
 * 					</tr>
 * 					<tr>
 * 						<td>JSON文字列からJavaScriptオブジェクトへの変換失敗した場合</td>
 * 						<td>{@link ImAjax#AJAX_PARSE_JSON_ERR}</td>
 * 					</tr>
 * 					<tr>
 * 						<td>セッションタイムアウトが発生した場合</td>
 * 						<td>{@link ImAjax#AJAX_TIMEOUT}</td>
 * 					</tr>
 * 					<tr>
 * 						<td>レスポンスヘッダ「Content-Type」が特定できない場合</td>
 * 						<td>{@link ImAjax#CONTENT_TYPE_IS_NOT_SPECIFIED}</td>
 * 					</tr>
 * 					<tr>
 * 						<td>上記以外</td>
 * 						<td>レスポンスヘッダ名「x-jp-co-intra-mart-ajax-error-code（=ImAjax#RES_HEADER_ERROR_CODE）」に指定されている値</td>
 * 					</tr>
 * 				</table>
 * 			</td>
 * 		</tr>
 * 		<tr>
 * 			<td colspan="2">
 * 				<strong>message</strong>
 * 				code プロパティに対応したエラーメッセージ (String)<br/>
 * 			</td>
 * 		</tr>
 * 		<tr>
 * 			<td colspan="2">
 * 				<strong>contentType</strong>
 * 				レスポンスデータのコンテントタイプ (String)<br/>
 * 			</td>
 * 		</tr>
 * 		<tr>
 * 			<td colspan="2">
 * 				<strong>data</strong>
 * 				レスポンスデータ (JavaScriptオブジェクト、XMLオブジェクト、または、テキスト)<br/>
 * 			</td>
 * 		</tr>
 * 	</table>
 *
 * <p/>
 * <h4><a name='sampleCode'>サンプルコード</a></h4>
 * 	<table border="1">
 * 		<tr>
 * 			<th>
 * 				クライアント（client_sample.html ファイル）
 * 			</th>
 * 		</tr>
 * 		<tr>
 * 			<td>
 * 				<font size="-1.5">
 * <pre>
&lt;html&gt;
  &lt;head&gt;
    &lt;title&gt;ImAjaxオブジェクトのサンプル&lt;/title&gt;

    &lt;script type="text/javascript" src="csjs/im_json.js"&gt;&lt;/script&gt;
    &lt;script type="text/javascript" src="csjs/im_ajax_request.js"&gt;&lt;/script&gt;

    &lt;script language="javascript"&gt;
      // 送信先 URL
      var url = '&lt;imart type="string" value=url&gt;&lt;/imart&gt;';

      /&#42;&#42;
       &#42; 非同期通信を行います。
       &#42;/
      function async() {
        var sendData = new Object();
            sendData.<b><font color="fuchsia">clientSideText</font></b> = document.form1.text1.value;

        // リクエスト送信（非同期通信）
        ImAjax.requestAsyncSend(url, sendData, <b><font color="lime">callBackTest</font></b>);

        alert("リクエストを非同期通信で送信しました。");
      }

      /&#42;&#42;
       &#42; 同期通信を行います。
       &#42;/
      function sync() {
        var sendData = new Object();
            sendData.<b><font color="fuchsia">clientSideText</font></b> = document.form1.text1.value;

        // リクエスト送信（同期通信）
        ImAjax.requestSend(url, sendData, <b><font color="lime">callBackTest</font></b>);

        alert("リクエストを同期通信で送信しました。");
      }

      /&#42;&#42;
       &#42; コールバック関数
       &#42;/
      function <b><font color="lime">callBackTest</font></b>(result) {
        if(result.error == true){
          alert(result.message);
        }
        else {
          var alertMsg  = "========== callBackTest() で結果を受信しました。========== \n\n";
              alertMsg += result.data.<b><font color="red">serverSideText</font></b>;

          alert(alertMsg);
        }
      }

    &lt;/script&gt;
  &lt;/head&gt;

  &lt;body&gt;
    &lt;form name="form1"&gt;
      &lt;input type="text" name="text1" size="50" value="テストです。"&gt;&lt;br&gt;
      &lt;input type="button" value="リクエスト送信(非同期)" onclick="async()"&gt;
      &lt;input type="button" value="リクエスト送信(同期)"   onclick="sync()"&gt;
    &lt;/form&gt;
  &lt;/body&gt;
&lt;/html&gt;
 * </pre>
 * 				</font>
 * 			</td>
 * 		</tr>
 * 	</table>
 * <br/>
 *
 * 	<table border="1">
 * 		<tr>
 * 			<th>
 * 				クライアント（client_sample.js ファイル）
 * 			</th>
 * 		</tr>
 * 		<tr>
 * 			<td>
 * 				<font size="-1.5">
 * <pre>
var url;
function init(request){
  url = Web.getContextPath() + "/" + new URL("<b><font color="blue">server_sample</font></b>").location();
}
 * </pre>
 * 				</font>
 * 			</td>
 * 		</tr>
 * 	</table>
 * <br/>
 *
 * 	<table border="1">
 * 		<tr>
 * 			<th>
 * 				サーバサイド（<b><font color="blue">server_sample</font></b>.js ファイル）
 * 			</th>
 * 		</tr>
 * 		<tr>
 * 			<td>
 * 				<font size="-1.5">
 * <pre>
function init(request) {

  // JSON形式の文字列からJavaScriptオブジェクトに変換
  var messageBody = request.getMessageBody("UTF-8");
  var receiveData = ImJson.parseJSON(messageBody);

  // クライアントからのリクエストデータを表示
  Debug.console(receiveData);

  // 3秒間 スリープ（非同期通信 と 同期通信の違いを分かるようにするため）
  Debug.print("3秒間 スリープします。。。");
  Client.sleep(3000);

  // レスポンスデータを作成
  var responseData = new Object();
      responseData.<b><font color="red">serverSideText</font></b> = receiveData.<b><font color="fuchsia">clientSideText</font></b> + "（" + new Date() + "に受け取りました。）";

  // クライアントにデータを返却
  var jsonString = ImJson.toJSONString(responseData);
  var response = Web.getHTTPResponse();
  response.setContentType("application/json; charset=UTF-8");
  response.sendMessageBodyString(jsonString);
}
 * </pre>
 * 				</font>
 * 			</td>
 * 		</tr>
 * 	</table>
 * <br/>
 *
 * @class XMLHttpRequest 通信を簡単に行うことができるオブジェクトです。<br/>
 * <br/>
 * ImAjax オブジェクトの利用方法、およびサンプルコードは、
 * <a href="overview-summary-im_ajax_request.js.html">こちら</a> を参照してください。<br/>
 *
 * @constructor XMLHttpRequest 通信を行うメソッドを提供します。
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */
function ImAjax(){}

/**
 * エラーコード：通信完了
 * @final
 * @type String
 */
ImAjax.AJAX_COMPLETE = "AJAX_COMPLETE";

/**
 * エラーコード：JSON文字列からJavaScriptオブジェクトへの変換失敗
 * @final
 * @type String
 */
ImAjax.AJAX_PARSE_JSON_ERR = "AJAX_PARSE_JSON_ERR";

/**
 * エラーコード：セッションタイムアウト
 * @final
 * @type String
 */
ImAjax.AJAX_TIMEOUT  = "IM-SECURITY-00001";

/**
 * エラーコード：レスポンスヘッダ「Content-Type」が特定できない場合
 * @final
 * @type String
 */
ImAjax.CONTENT_TYPE_IS_NOT_SPECIFIED = "CONTENT_TYPE_IS_NOT_SPECIFIED";

/**
 * @private
 * ImAjaxを利用した通信が、非同期通信であることを示す定数。
 * @final
 * @type Boolean
 */
ImAjax.COMM_ASYNC = true;

/**
 * @private
 * ImAjaxを利用した通信が、同期通信であることを示す定数。
 * @final
 * @type Boolean
 */
ImAjax.COMM_SYNC = false;

/**
 * @private
 * リクエストヘッダ名：ユーザエージェント
 * @type String
 */
ImAjax.REQ_HEADER_USER_AGENT = "x-jp-co-intra-mart-ajax-user-agent";

/**
 * @private
 * リクエストヘッダ名：Ajaxリクエスト
 * @type String
 */
ImAjax.REQ_HEADER_AJAX_REQUEST = "x-jp-co-intra-mart-ajax-request";

/**
 * @private
 * レスポンスヘッダ名：エラーコード<BR>
 * このヘッダが指定されている場合、ImAjaxはエラーが発生したと判定します。
 * @final
 * @type String
 */
ImAjax.RES_HEADER_ERROR_CODE = "x-jp-co-intra-mart-ajax-error-code";

/**
 * @private
 * レスポンスヘッダ名：エラーメッセージ
 * このレスポンスヘッダの値は、
 * {@link ImAjax#RES_HEADER_ERROR_CODE} で指定されたコードに対応したメッセージが設定されます。<br/>
 * (このレスポンスヘッダの値は、encodeURIComponent()されている必要があります)
 * @final
 * @type String
 */
ImAjax.RES_HEADER_ERROR_MESSAGE = "x-jp-co-intra-mart-ajax-error-message";

/**
 * @private
 * ContentType文字列：JSON形式
 * @final
 * @type String
 */
ImAjax.CONTENT_TYPE_JSON = "application/json";

/**
 * @private
 * ContentType文字列：XML形式
 * @final
 * @type String
 */
ImAjax.CONTENT_TYPE_XML  = "text/xml";

/**
 * @private
 * ContentType文字列：TEXT形式
 * @final
 * @type String
 */
ImAjax.CONTENT_TYPE_TEXT = "text/plain";

/**
 * @private
 * CharSet文字列 : UTF-8
 * @final
 * @type String
 */
ImAjax.CHARSET_UTF8 = "charset=utf-8";

/**
 * ブラウザ判定用変数。<br/>
 * 利用しているブラウザを判定するための変数です。「ImAjax.Browser.XXXX」形式で変数を参照可能です。<br/>
 * 例：Firefoxを利用している場合、変数「ImAjax.Browser.Firefox」は true を保持しています。<br/>
 * <br/>
 *  <table border="1">
 *  	<tr>
 *  		<th>利用しているブラウザ</th>
 *  		<th>変数</th>
 *  	</tr>
 *  	<tr>
 *  		<td>Internet Explorer</td>
 *  		<td>ImAjax.Browser.IE</td>
 *  	</tr>
 *  	<tr>
 *  		<td>Netscape</td>
 *  		<td>ImAjax.Browser.Netscape</td>
 *  	</tr>
 *  	<tr>
 *  		<td>FireFox</td>
 *  		<td>ImAjax.Browser.Firefox</td>
 *  	</tr>
 *  	<tr>
 *  		<td>Opera</td>
 *  		<td>ImAjax.Browser.Opera</td>
 *  	</tr>
 *  	<tr>
 *  		<td>Safari</td>
 *  		<td>ImAjax.Browser.Safari</td>
 *  	</tr>
 *  </table>
 * @final
 * @type Boolean
 */
ImAjax.Browser = new Object();
ImAjax.Browser.IE       = !!(window.attachEvent && !window.opera);
ImAjax.Browser.Opera    = !!window.opera;
ImAjax.Browser.WebKit   = !window.attachEvent && !window.opera && (navigator.userAgent.indexOf('AppleWebKit/') > -1);
ImAjax.Browser.Gecko    = !window.attachEvent && !window.opera && (navigator.userAgent.indexOf('Gecko') > -1) && (navigator.userAgent.indexOf('KHTML') == -1);
ImAjax.Browser.Firefox  = !window.attachEvent && !window.opera && (navigator.userAgent.indexOf('Firefox')  > -1);
ImAjax.Browser.Netscape = !window.attachEvent && !window.opera && (navigator.userAgent.indexOf('Netscape') > -1);
ImAjax.Browser.Safari   = !window.attachEvent && !window.opera && (navigator.userAgent.indexOf('AppleWebKit/') > -1) && (navigator.userAgent.indexOf('Safari') > -1);

/**
 * 非同期通信を行います。
 * @param {String}   url      送信先URL
 * @param {Object}   data     送信データ
 * @param {Function} callback コールバック関数
 * @param {String}   method   [option] サーバにデータを送る形式を get または post で指定します。デフォルトは"post"。
 */
ImAjax.requestAsyncSend = function(url, data, callback, method) {
    ImAjax.requestExecute(url, data, callback, method, ImAjax.COMM_ASYNC);
}

/**
 * 同期通信を行います。
 * @param {String}   url      送信先URL
 * @param {Object}   data     送信データ
 * @param {Function} callback コールバック関数
 * @param {String}   method   [option] サーバにデータを送る形式を get または post で指定します。デフォルトは"post"。
 */
ImAjax.requestSend = function(url, data, callback, method) {
    ImAjax.requestExecute(url, data, callback, method, ImAjax.COMM_SYNC);
}

/**
 * @private
 * Ajax通信処理
 *
 * @param {String}   url      送信先URL
 * @param {Object}   data     送信データ
 * @param {Function} callback コールバック関数
 * @param {String}   method   [option] "get"/"post" デフォルトは"post"
 * @param {Boolean}  isAsync  [option] ImAjax.COMM_ASYNC/ImAjax.COMM_SYNC。 デフォルトはImAjax.COMM_ASYNC
 */
ImAjax.requestExecute = function(url, data, callback, method, isAsync) {

    method  = (method  == undefined) ? "post" : method;
    isAsync = (isAsync == undefined) ? ImAjax.COMM_ASYNC : isAsync;

    //====================================
    // Create XMLHttpRequest(=xhr)
    //====================================
    var xhr = ImAjax.createXMLHttpRequest();

    //====================================
    // Set callback function
    //====================================
    if(window.ActiveXObject){
        xhr.onreadystatechange = function () {
            if (xhr.readyState == 4) {
                var result = ImAjax.createResultObject(xhr);
                callback(result);
            }
        };
    }
    else {
        xhr.onload = function () {
                var result = ImAjax.createResultObject(xhr);
                callback(result);
        };
    }

    //====================================
    // Convert Request Data & Define Content-Type
    //====================================
    var requestData = ImAjax.convertRequestData(data);

    //====================================
    // Send Request
    //====================================
    xhr.open(method, url, isAsync);
    xhr = ImAjax.setContentTypeAndReqHeaders(xhr, requestData.contentType);
    xhr.send(requestData.data);
}

/**
 * @private
 * JavaScriptオブジェクト（XML or Object or String）を、サーバに送信可能なリクエストデータに変換します。
 * あわせて、Content-Typeの判定も行います。
 *
 * @param {Object} data リクエストデータ。JavaScriptオブジェクト（XML or Object or String）を指定します。
 *
 * @return requestData 変換後のリクエストデータ。形式は{ data : "変換後のリクエストデータ", contentType : "コンテントタイプ"}
 * @type  Object
*/
ImAjax.convertRequestData = function(data){

    var requestData = {
        data        : undefined,
        contentType : ""
    }

    try {
        // XMLデータでは無い場合、下記の例外でキャッチ
        data.createElement("dummy");

        //  XMLデータの場合
        requestData.data        = ImAjax.domToXMLString(data);
        requestData.contentType = ImAjax.CONTENT_TYPE_XML + "; " + ImAjax.CHARSET_UTF8;
    }
    catch(e) {
        // JSONの場合
        if(typeof(data) == "object") {
            requestData.data        = ImJson.toJSONString(data);
            requestData.contentType = ImAjax.CONTENT_TYPE_JSON + "; " + ImAjax.CHARSET_UTF8;
        }
        // 上記以外
        else {
            requestData.data        = ImJson.escapeData( new String(data) );
            requestData.contentType = ImAjax.CONTENT_TYPE_TEXT + "; " + ImAjax.CHARSET_UTF8;
        }
    }

    return requestData;
}

/**
 * @private
 * DOMよりXML文字列を取得します
 *
 * @return XML文字列
 * @type String
 */
ImAjax.domToXMLString = function(dom){
    var xmlString = "";

    if(ImAjax.Browser.IE){
        xmlString = dom.xml;
    }
    else {
        var serial = new XMLSerializer();
        xmlString = serial.serializeToString(dom);
    }

    return xmlString;
}

/**
 * @private
 * Create XMLHttpRequest
 */
ImAjax.createXMLHttpRequest = function(){
    var msxmlNames =
            new Array("MSXML2.XMLHTTP.5.0", "MSXML2.XMLHTTP.4.0", "MSXML2.XMLHTTP.3.0", "MSXML2.XMLHTTP", "Microsoft.XMLHTTP");

    /* Mozilla XMLHttpRequest */
    try {
        return new XMLHttpRequest();
    } catch(e) {}

    /* Microsoft MSXML ActiveX */
    for (var i=0;i < msxmlNames.length; i++) {
        try {
            return new ActiveXObject(msxmlNames[i]);
        } catch (e) {}
    }
}

/**
 * @private
 * Set Content-Type & Request Headers
 */
ImAjax.setContentTypeAndReqHeaders = function(xhr, contentType){
    var userAgent = ImAjax.getBrowserName();

    if(!window.opera){
        xhr.setRequestHeader('Content-Type', contentType);
        xhr.setRequestHeader(ImAjax.REQ_HEADER_AJAX_REQUEST, "true");
        xhr.setRequestHeader(ImAjax.REQ_HEADER_USER_AGENT, userAgent);
    }
    else {
        if((typeof xhr.setRequestHeader) == 'function'){
            xhr.setRequestHeader('Content-Type', contentType);
            xhr.setRequestHeader(ImAjax.REQ_HEADER_AJAX_REQUEST, "true");
            xhr.setRequestHeader(ImAjax.REQ_HEADER_USER_AGENT, userAgent);
        }
    }

    return xhr;
}

/**
 * @private
 * Ajax通信結果オブジェクト作成
 *
 * @param {Object} xhr XMLHttpRequest
 *
 * @return objResult {Object} Ajax通信結果オブジェクト
 * @type Object
*/
ImAjax.createResultObject = function(xhr) {
    var parseJsonErrorFlg = false;

    /* ==================================== */
    /*  Create result object template       */
    /* ==================================== */
    var objResult = {
        error       : undefined,
        httpStatus  : xhr.status,
        code        : undefined,
        message     : undefined,
        contentType : undefined,
        data        : undefined
    };

    /* ====================================*/
    /*  Get value : IM_AJAX_ERROR_CODE and IM_AJAX_ERROR_MESSAGE*/
    /* ====================================*/
    var ajaxErrorCode    = undefined;
    var ajaxErrorMessage = undefined;

    var aryResHeaders = xhr.getAllResponseHeaders().split("\n");

    for(var idx = 0, max = aryResHeaders.length; idx < max; idx++){
        if(aryResHeaders[idx].toLowerCase().match("Content-Type".toLowerCase()) != null){
            var contentTypeHeaderName = aryResHeaders[idx].substring(0, "Content-Type".length);
            objResult.contentType = xhr.getResponseHeader(contentTypeHeaderName);
        }
        else if(aryResHeaders[idx].match(ImAjax.RES_HEADER_ERROR_CODE) != null){
            ajaxErrorCode = xhr.getResponseHeader(ImAjax.RES_HEADER_ERROR_CODE);
        }
        else if(aryResHeaders[idx].match(ImAjax.RES_HEADER_ERROR_MESSAGE) != null){
            ajaxErrorMessage = xhr.getResponseHeader(ImAjax.RES_HEADER_ERROR_MESSAGE);

            /*  Unescape Error Message */
            try{
                ajaxErrorMessage = decodeURIComponent(ajaxErrorMessage);
            }
            catch(ex){
                // PLEASE SET ENGLISH MESSAGE. (or create original decoding function)
                // Because decodeURIComponent() is not defined. (ex IE5, NN4)
                ajaxErrorMessage = ajaxErrorMessage;
            }
        }
    }

    /* ==================================== */
    /*  Get value : "data"                  */
    /* ==================================== */
    var lowerCaseContentType = (typeof(objResult.contentType) == "string") ? objResult.contentType.toLowerCase() : "unknown";

    if (lowerCaseContentType.indexOf(ImAjax.CONTENT_TYPE_JSON) != -1) {
        try{
            objResult.data = ImJson.parseJSON(xhr.responseText);
        }
        /*  **** Detect parse JSON Error **** */
        catch(ex){
            parseJsonErrorFlg = true;

            objResult.message = ex.name + ": " + ex.message;
            objResult.data    = xhr.responseText;
        }
    }
    else if(lowerCaseContentType.indexOf(ImAjax.CONTENT_TYPE_XML) != -1) {
        objResult.data = xhr.responseXML;
    }
    else{
        objResult.data = xhr.responseText;
    }

    /* ====================================*/
    /*  Set result object property         */
    /* ====================================*/
    if( (xhr.status == 200) && (parseJsonErrorFlg == false) && (ajaxErrorCode == undefined) ){
        objResult.error = false;
        objResult.code  = ImAjax.AJAX_COMPLETE;
    }
    else{
        /* HTTP error */
        if(xhr.status != 200){
            objResult.error   = true;
            objResult.code    = ajaxErrorCode;
            objResult.message = xhr.statusText;
        }
        /* parse JSON Error */
        else if(parseJsonErrorFlg == true){
            objResult.error   = true;
            objResult.code    = ImAjax.AJAX_PARSE_JSON_ERR;
        }
        /* Session timeout */
        else if(ajaxErrorCode == ImAjax.AJAX_TIMEOUT){
            objResult.error   = true;
            objResult.code    = ImAjax.AJAX_TIMEOUT;
            objResult.message = (ajaxErrorMessage) ? ajaxErrorMessage : "Session timeout.";
        }
        /* Content-Type is not specified */
        else if(lowerCaseContentType == "unknown"){
            objResult.error   = true;
            objResult.code    = ImAjax.CONTENT_TYPE_IS_NOT_SPECIFIED;
            objResult.message = "Content-Type is not specified.";
        }
        /* Other Error */
        else{
            objResult.error   = true;
            objResult.code    = ajaxErrorCode;
            objResult.message = ajaxErrorMessage;
        }
    }

    return objResult;
}

/**
 * 利用しているブラウザを判定します。<br/>
 * <br/>
 *  <table border="1">
 *  	<tr>
 *  		<th>ブラウザ</th>
 *  		<th>返却値</th>
 *  	</tr>
 *  	<tr>
 *  		<td>Internet Explorer</td>
 *  		<td>IE</td>
 *  	</tr>
 *  	<tr>
 *  		<td>Netscape</td>
 *  		<td>Netscape</td>
 *  	</tr>
 *  	<tr>
 *  		<td>FireFox</td>
 *  		<td>Firefox</td>
 *  	</tr>
 *  	<tr>
 *  		<td>Opera</td>
 *  		<td>Opera</td>
 *  	</tr>
 *  	<tr>
 *  		<td>Safari</td>
 *  		<td>Safari</td>
 *  	</tr>
 *  </table>
 *
 * @return 利用しているブラウザをあらわす文字列
 * @type String
 */
ImAjax.getBrowserName = function(){

    if(ImAjax.Browser.IE){
        return "IE";
    }
    else if(ImAjax.Browser.Opera){
        return "Opera";
    }
    else if(ImAjax.Browser.Firefox){
        return "Firefox";
    }
    else if(ImAjax.Browser.Netscape){
        return "Netscape";
    }
    else if(ImAjax.Browser.Safari){
        return "Safari";
    }
    else if(ImAjax.Browser.WebKit){
        return "WebKit";
    }
    else if(ImAjax.Browser.Gecko){
        return "Gecko";
    }
    else {
        return "UnKnown";
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_cookie.js

概要

クッキーに対するアクセス関数群。

サンプルコード

サンプル（.htmlファイル）
  ・
  ・
  ・
  <script src="csjs/im_cookie.js"></script>

  <script language="javascript">
    // クッキーに "ABC" というキーで "XYZ" というデータを保存
    setCookie("ABC", "XYZ");

    // クッキーから "ABC" というキーに該当するデータを取得
    var sABC = getCookie("ABC");

    // クッキーから "ABC" というキーに該当するデータを削除
    removeCookie("ABC");
  </script>
  ・
  ・
  ・

Version: 1.0

Author: INTRAMART

メソッドの概要
static String | getCookie(<String> sName) クッキーの値を取得します。
static void | removeCookie(<String> sName) クッキーの値を消去します。
static void | setCookie(<String> sName, <String> sValue, <Date> dExpires, <String> sDomain, <String> sPath, <Boolean> bSecure) 指定のデータをクッキーに保存します。

/**
 * @fileoverview クッキーに対するアクセス関数群。<br/>
 * <br/>
 * <strong>サンプルコード</strong> </a><br/>
 * <br/>
 * <table border="1">
 *   <tr>
 *     <th>
 *       サンプル（.htmlファイル）
 *     </th>
 *   </tr>
 *   <tr>
 *     <td>
 *       <font size="-1">
<pre>
  ・
  ・
  ・
  &lt;script src=&quot;csjs/im_cookie.js&quot;&gt;&lt;/script&gt;

  &lt;script language=&quot;javascript&quot;&gt;
    // クッキーに &quot;ABC&quot; というキーで &quot;XYZ&quot; というデータを保存
    setCookie(&quot;ABC&quot;, &quot;XYZ&quot;);

    // クッキーから &quot;ABC&quot; というキーに該当するデータを取得
    var sABC = getCookie(&quot;ABC&quot;);

    // クッキーから &quot;ABC&quot; というキーに該当するデータを削除
    removeCookie(&quot;ABC&quot;);
  &lt;/script&gt;
  ・
  ・
  ・
</pre>
 *       </font>
 *     </td>
 *   </tr>
 * </table>
 *
 * @version 1.0
 * @since 3.0
 * @author INTRAMART
 */

/**
 * 指定のデータをクッキーに保存します。<br/>
 * <br/>
 *
 * @param {String} sName 参照名称
 * @param {String} sValue 値
 * @param {Date} dExpires [option] 利用期限 (省略可能)
 * @param {String} sDomain [option] 有効ドメイン (省略可能)
 * @param {String} sPath [option] 設定可能階層 (省略可能)
 * @param {Boolean} bSecure [option] セキュリティの有無 (省略可能)
 */
function setCookie(sName, sValue, dExpires, sDomain, sPath, bSecure) {
    var sStr = "";

    /* cock */
    sStr += sName;
    sStr += "=";
    sStr += escape(sValue);
    if(dExpires != null){ sStr += "; expires=" + dExpires.toGMTString(); }
    if(sDomain != null){ sStr += "; domain=" + sDomain; }
    if(sPath != null){ sStr += "; path=" + sPath; }
    if(bSecure == true){ sStr += "; secure"; }

    /* bake */
    document.cookie = sStr;
}

/**
 * クッキーの値を取得します。<br/>
 * <br/>
 * 指定参照名称に該当するクッキー内に保存された値を返却します。<br/>
 * 指定参照名称で値を取得できなかった場合には、null 値が返されます。<br/>
 *
 * @param {String} sName 参照名称
 * @return 参照名称に対応した値
 * @type String
 */
function getCookie(sName) {
    var nLen = ("" + sName).length + 2;
    var sCookie = " " + document.cookie;
    var nStart = sCookie.indexOf(" " + sName + "=");
    var nEnd = sCookie.indexOf(";", nStart + nLen);

    /* name is nothing */
    if(nStart == -1){ return null; }

    /* search end point */
    if(nEnd == -1){ nEnd = sCookie.length; }

    /* eat and return */
    return unescape(sCookie.substring(nStart + nLen, nEnd));
}

/**
 *  クッキーの値を消去します。<br/>
 * <br/>
 * クッキー内に保存されているデータのうち、指定の参照名に該当するデータを消去します。<br/>
 * 実際には、クッキーの有効期限を過去に設定し直す事によって、
 * その値自体を無効とし、表面上見えない状態にしているだけです。
 *
 * @param {String} sName 参照名称
 */
function removeCookie(sName) {
    var dExpires = new Date();
    var sValue = getCookie(sName);

    // HTTP protocol judgment!!
    var bSecure = false;
    if (window.location.protocol.indexOf( "https") != -1){
        bSecure = true;
    }

    /* set expire to past */
    if(sValue != null){ setCookie(sName, sValue, dExpires,null,null,bSecure); }
}

/**
 * @private
 * return names.
 *  [Output] nothing
 *  [detail] get a collection(Array).
 *           A element is cookie-id in collection.
 */
function getCookieNames(){
    var sCookie = " " + document.cookie;

    if(sCookie.length > 2){
        var array = new Array();
        var startPoint = 0;
        while(true){
            var headPoint = sCookie.indexOf(" ", startPoint);
            if(headPoint == -1){ break; }
            var tailPoint = sCookie.indexOf("=", headPoint);
            var name = sCookie.substring(headPoint + 1, tailPoint);
            array[array.length] = name;
            startPoint = sCookie.indexOf(";", tailPoint);
            if(startPoint == -1){ break; }
        }
        return array;
    }
    else{
        return new Array();
    }
}

/* End of File */
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_date.js

概要

日付（時間）データ操作関数群。

サンプルコード

サンプル（.htmlファイル）
  ・
  ・
  ・
  <script src="csjs/im_date.js"></script>
  ・
  ・
    <!-- ボタンを押すと、2002年02年29日が日付として正しいかどうか判定します -->
    <input type="button" onClick="alert(isDateData(2002, 02, 02));">
  ・
  ・
  ・

Version: 1.0

Author: INTRAMART

メソッドの概要
static Boolean | isDateData(<Number> nYear, <Number> nMonth, <Number> nDay, <Number> nHour, <Number> nMinutes, <Number> nSecond) 日付として正しいかどうか判定します。
static Boolean | isLeapYear(<Number> nYear) 指定の年が閏年かどうか判定します。

/**
 * @fileoverview 日付（時間）データ操作関数群。<br/>
 * <br/>
 * <strong>サンプルコード</strong> </a><br/>
 * <br/>
 * <table border="1">
 *   <tr>
 *     <th>
 *       サンプル（.htmlファイル）
 *     </th>
 *   </tr>
 *   <tr>
 *     <td>
 *       <font size="-1">
<pre>
  ・
  ・
  ・
  &lt;script src=&quot;csjs/im_date.js&quot;&gt;&lt;/script&gt;
  ・
  ・
    &lt;!-- ボタンを押すと、2002年02年29日が日付として正しいかどうか判定します --&gt;
    &lt;input type=&quot;button&quot; onClick=&quot;alert(isDateData(2002, 02, 02));&quot;&gt;
  ・
  ・
  ・
</pre>
 *       </font>
 *     </td>
 *   </tr>
 * </table>
 *
 * @version 1.0
 * @since 3.1
 * @author INTRAMART
 */

/**
 * 日付として正しいかどうか判定します。<br/>
 * <br/>
 * 与えられた数値の組合わせが日付（および時間）を表す情報として正しいかどうかを判定します。<br/>
 * この関数は、閏年の判定も行っているので、２月２９日に関しても正しく判定することができます。<br/>
 *
 * @param {Number} nYear 年
 * @param {Number} nMonth 月
 * @param {Number} nDay 日
 * @param {Number} nHour [option] 時間 (省略可能)
 * @param {Number} nMinutes [option] 分 (省略可能)
 * @param {Number} nSecond [option] 秒 (省略可能)
 * @return 指定の数値データが日付として正しい場合 true、そうでない場合false。
 * @type Boolean
 */
function isDateData(nYear, nMonth, nDay, nHour, nMinutes, nSecond){
    /* check the arguments(all value to integer) */
    nYear    = parseFloat(nYear);    if(isNaN(nYear))   { nYear    = 0; }
    nMonth   = parseFloat(nMonth);   if(isNaN(nMonth))  { nMonth   = 0; }
    nDay     = parseFloat(nDay);     if(isNaN(nDay))    { nDay     = 1; }
    nHour    = parseFloat(nHour);    if(isNaN(nHour))   { nHour    = 0; }
    nMinutes = parseFloat(nMinutes); if(isNaN(nMinutes)){ nMinutes = 0; }
    nSecond  = parseFloat(nSecond);  if(isNaN(nSecond)) { nSecond  = 0; }

    /* make the month's index */
    var nMonth_ID = parseFloat(nMonth) -1;
    /* make the target date variable */
    var dDate = new Date(nYear, nMonth_ID, nDay, nHour, nMinutes, nSecond);

    /* compareation date data */
    return ((dDate.getMonth() == nMonth_ID) && (dDate.getDate() == nDay) && (dDate.getHours() == nHour) && (dDate.getMinutes() == nMinutes) && (dDate.getSeconds() == nSecond));
}

/**
 * 指定の年が閏年かどうか判定します。<br/>
 * <br/>
 * 与えられた数値を西暦年として閏年計算をします。
 *
 * @param {Number} nYear 年
 * @return 指定の年が閏年の場合 true、そうでない場合false。
 * @type Boolean
 */
function isLeapYear(nYear){
    return ((nYear % 4 == 0) && (nYear % 100 != 0)) || (nYear % 400 == 0)
}

/* End of File */
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_header_column_resizer.js

概要

＜TABLE＞タグ要素の列幅をリサイズ可能にする CSJS オブジェクトです。

ImHeaderColumnResizerオブジェクトを利用することで以下が可能となります。

  • 列幅のリサイズ（ヘッダ部の列の端をマウスでドラッグします）
  • データ部の垂直方向スクロール（ヘッダ部が隠れることなくスクロール可能です）
  • ヘッダ部とデータ部を水平方向に連結スクロール

必要なファイル

  • prototype.js

  • im_abstract_self_event_handler.js
  • im_header_column_resizer.js

説明

ImHeaderColumnResizerオブジェクトは、以下の「A (ヘッダ部)」と「B (データ部)」を結合させ 「C」のように表示します。
（「C」のヘッダ部のセルとセルの間をマウスでドラッグすることで列幅が変更可能となります）
  • A: ヘッダ部のテーブル要素（id="ヘッダ部"）
    • ヘッダ０ ヘッダ１ ヘッダ２

  • B: データのテーブル要素（id="データ部"）
    • データ０ - ０ | データ０ - １ | データ０ - ２
データ１ - ０ | データ１ - １ | データ１ - ２

  • C: ImHeaderColumnResizerオブジェクトを利用した際の表示イメージ
    • ヘッダ０ | ヘッダ１ | ヘッダ２
データ０ - ０ | データ０ - １ | データ０ - ２
データ１ - ０ | データ１ - １ | データ１ - ２

ImHeaderColumnResizerオブジェクトは、「C」の表示領域を指定することが可能です。
（表示領域は、ヘッダ部とデータ部をあわせた「幅」と「高さ」で指定します）

指定された「幅」と「高さ」に表示しきれない内容は、データ部をスクロールさせることで参照可能となります。
データ部を水平方向にスクロールさせると、ヘッダ部も合わせてスクロールします。
加えて、データ部を垂直方向にスクロールさせても、ヘッダ部は固定されたままとなります。

制限事項

  • 「ヘッダ部の<TABLE>タグ」と「データ部の<TABLE>タグ」には id 属性が設定されている必要があります。
  • ImHeaderColumnResizerオブジェクト生成時に、データ部の列幅がヘッダ部の列幅に統一されます。

サンプルコード

サンプル（.html ファイル）
<html>
  <head>
  <script type="text/javascript" src="../csjs/prototype.js"></script>
  <script type="text/javascript" src="../csjs/im_abstract_self_event_handler.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_header_column_resizer.js"></script>

    <script language="javascript">

      /**
       * id="HEADER_TABLE" と id="DATA_TABLE"で指定されたテーブルをリサイズ可能にします。
       */
      function startResize() {

        var tableElemId4Header = "HEADER_TABLE"; // ヘッダ部の<TABLE>タグのid
        var tableElemId4Data   = "DATA_TABLE";   // データ部の<TABLE>タグのid

        var width  = 500; // 幅
        var height = 300; // 高さ

        // リサイズ開始
        new ImHeaderColumnResizer(tableElemId4Header, tableElemId4Data, width, height);
      }

    </script>

  </head>

  <!-- onload時にリサイズを可能にします -->
  <body onload="startResize();">

    <!-- ***** ヘッダ部の<TABLE>タグ ***** -->
    <table id="HEADER_TABLE" border="1">
      <tr>
        <td width="100">列0</td>
        <td width="100">列1</td>
        <td width="150">列2</td>
        <td width="200">列3</td>
      </tr>
    </table>

    <!-- ***** データ部の<TABLE>タグ ***** -->
    <table id="DATA_TABLE" border="1">
      <tr>
        <td>
          データ0-0
        </td>
        <td>
          データ0-1
        </td>
        <td>
          データ0-2
        </td>
        <td>
          データ0-3
        </td>
      </tr>
      <tr>
        <td>データ1-0</td>
        <td>データ1-1</td>
        <td>データ1-2</td>
        <td>データ1-3</td>
      </tr>
    </table>

  </body>

</html>

リサイズ時にデータの内容を改行しないようにするサンプル（.html ファイル）
<html>
  <head>
  <script type="text/javascript" src="../csjs/prototype.js"></script>
  <script type="text/javascript" src="../csjs/im_abstract_self_event_handler.js"></script>
  <script type="text/javascript" src="../csjs/sortable_table/im_header_column_resizer.js"></script>

    <script language="javascript">

      /**
       * id="HEADER_TABLE" と id="DATA_TABLE"で指定されたテーブルをリサイズ可能にします。
       */
      function startResize() {

        var tableElemId4Header = "HEADER_TABLE"; // ヘッダ部の<TABLE>タグのid
        var tableElemId4Data   = "DATA_TABLE";   // データ部の<TABLE>タグのid

        var width  = 500; // 幅
        var height = 300; // 高さ

        // リサイズ開始
        new ImHeaderColumnResizer(tableElemId4Header, tableElemId4Data, width, height);
      }

    </script>

  </head>

  <!-- onload時にリサイズを可能にします -->
  <body onload="startResize();">

    <!-- ***** ヘッダ部の<TABLE>タグ ***** -->
    <table id="HEADER_TABLE" border="1">
      <tr>
        <td width="100">
          <div style="overflow: hidden; white-space: noWrap">改行しない列0</div>
        </td>
        <td width="100">
          <div style="overflow: hidden; white-space: noWrap">改行しない列1</div>
        </td>
        <td width="150">
          <div style="overflow: hidden; white-space: noWrap">改行しない列2</div>
        </td>
        <td width="200">
          <div style="overflow: hidden; white-space: noWrap">改行しない列3</div>
        </td>
      </tr>
    </table>

    <!-- ***** データ部の<TABLE>タグ ***** -->
    <table id="DATA_TABLE" border="1">
      <tr>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ0-0</div>
        </td>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ0-1</div>
        </td>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ0-2</div>
        </td>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ0-3</div>
        </td>
      </tr>
      <tr>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ1-0</div>
        </td>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ1-1</div>
        </td>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ1-2</div>
        </td>
        <td>
          <div style="overflow: hidden; white-space: noWrap">改行しないデータ1-3</div>
        </td>
      </tr>
    </table>

  </body>

</html>

Version: 1.0

Author: INTRAMART

クラスの概要
ImHeaderColumnResizer ＜TABLE＞タグ要素の列幅をリサイズ可能にする CSJS オブジェクト。
/**
 * @fileoverview ＜TABLE＞タグ要素の列幅をリサイズ可能にする CSJS オブジェクトです。<br/>
 * <br/>
 *
 * ImHeaderColumnResizerオブジェクトを利用することで以下が可能となります。<br/>
 * 	<ul>
 * 		<li>列幅のリサイズ（ヘッダ部の列の端をマウスでドラッグします）</li>
 * 		<li>データ部の垂直方向スクロール（ヘッダ部が隠れることなくスクロール可能です）</li>
 * 		<li>ヘッダ部とデータ部を水平方向に連結スクロール</li>
 * 	</ul>
 *
 * <p/>
 * <h4><a name='requireSourceFile'>必要なファイル</a></h4>
 * 	<ul>
 * 		<li>prototype.js</li>
 *		<br/>
 * 		<li>im_abstract_self_event_handler.js</li>
 * 		<li>im_header_column_resizer.js</li>
 * 	</ul>
 *
 * <p/>
 * <h4><a name='description'>説明</a></h4>
 *
 * ImHeaderColumnResizerオブジェクトは、以下の<b>「A (ヘッダ部)」</b>と<b>「B (データ部)」</b>を結合させ
 * <b>「C」</b>のように表示します。<br/>
 * （<b>「C」</b>のヘッダ部のセルとセルの間をマウスでドラッグすることで列幅が変更可能となります）
 *
 * 	<ul>
 *  	<li><b>A:</b> ヘッダ部のテーブル要素（id="ヘッダ部"）</li>
 *  	<table border="1" id="ヘッダ部">
 * 			<tr>
 * 				<td bgcolor="lightgrey"><b>ヘッダ０</b></td>
 * 				<td bgcolor="lightgrey"><b>ヘッダ１</b></td>
 * 				<td bgcolor="lightgrey"><b>ヘッダ２</b></td>
 * 			</tr>
 *  	</table>
 *
 *  	<br/>
 *
 *  	<li><b>B:</b> データのテーブル要素（id="データ部"）</li>
 *  	<table border="1" id="データ部">
 * 			<tr>
 * 				<td>データ０ - ０</td>
 * 				<td>データ０ - １</td>
 * 				<td>データ０ - ２</td>
 * 			</tr>
 * 			<tr>
 * 				<td>データ１ - ０</td>
 * 				<td>データ１ - １</td>
 * 				<td>データ１ - ２</td>
 * 			</tr>
 *  	</table>
 *
 *  	<br/>
 *
 *  	<li><b>C:</b> ImHeaderColumnResizerオブジェクトを利用した際の表示イメージ</li>
 *  	<table border="1" id="データ部">
 * 			<tr>
 * 				<td bgcolor="lightgrey"><b>ヘッダ０</b></td>
 * 				<td bgcolor="lightgrey"><b>ヘッダ１</b></td>
 * 				<td bgcolor="lightgrey"><b>ヘッダ２</b></td>
 * 			</tr>
 * 			<tr>
 * 				<td>データ０ - ０</td>
 * 				<td>データ０ - １</td>
 * 				<td>データ０ - ２</td>
 * 			</tr>
 * 			<tr>
 * 				<td>データ１ - ０</td>
 * 				<td>データ１ - １</td>
 * 				<td>データ１ - ２</td>
 * 			</tr>
 *  	</table>
 * 	</ul>
 * <br/>
 *
 * ImHeaderColumnResizerオブジェクトは、<b>「C」</b>の表示領域を指定することが可能です。<br/>
 * （表示領域は、ヘッダ部とデータ部をあわせた「幅」と「高さ」で指定します）<br/>
 * <br/>
 * 指定された「幅」と「高さ」に表示しきれない内容は、データ部をスクロールさせることで参照可能となります。<br/>
 * データ部を水平方向にスクロールさせると、ヘッダ部も合わせてスクロールします。<br/>
 * 加えて、データ部を垂直方向にスクロールさせても、ヘッダ部は固定されたままとなります。<br/>
 *
 * <p/>
 * <h4><a name='limitations'>制限事項</a></h4>
 * 	<ul>
 * 		<li>「ヘッダ部の&lt;TABLE&gt;タグ」と「データ部の&lt;TABLE&gt;タグ」には id 属性が設定されている必要があります。</li>
 * 		<li>ImHeaderColumnResizerオブジェクト生成時に、データ部の列幅がヘッダ部の列幅に統一されます。</li>
 * 	</ul>
 *
 * <p/>
 * <h4><a name='sampleCode'>サンプルコード</a></h4>
 * 	<table border="1">
 * 		<tr>
 * 			<th>
 * 				サンプル（.html ファイル）
 * 			</th>
 * 		</tr>
 * 		<tr>
 * 			<td>
 * 				<font size="-1.5">
<pre>
&lt;html&gt;
  &lt;head&gt;
  &lt;script type=&quot;text/javascript&quot; src=&quot;../csjs/prototype.js&quot;&gt;&lt;/script&gt;
  &lt;script type=&quot;text/javascript&quot; src=&quot;../csjs/im_abstract_self_event_handler.js&quot;&gt;&lt;/script&gt;
  &lt;script type=&quot;text/javascript&quot; src=&quot;../csjs/sortable_table/im_header_column_resizer.js&quot;&gt;&lt;/script&gt;

    &lt;script language=&quot;javascript&quot;&gt;

      /&#42;&#42;
       &#42; id=&quot;HEADER_TABLE&quot; と id=&quot;DATA_TABLE&quot;で指定されたテーブルをリサイズ可能にします。
       &#42;/
      &#102;unction startResize() {

        var tableElemId4Header = &quot;HEADER_TABLE&quot;; // ヘッダ部の&lt;TABLE&gt;タグのid
        var tableElemId4Data   = &quot;DATA_TABLE&quot;;   // データ部の&lt;TABLE&gt;タグのid

        var width  = 500; // 幅
        var height = 300; // 高さ

        // リサイズ開始
        new ImHeaderColumnResizer(tableElemId4Header, tableElemId4Data, width, height);
      }

    &lt;/script&gt;

  &lt;/head&gt;

  &lt;!-- onload時にリサイズを可能にします --&gt;
  &lt;body onload=&quot;startResize();&quot;&gt;

    &lt;!-- ***** ヘッダ部の&lt;TABLE&gt;タグ ***** --&gt;
    &lt;table id=&quot;HEADER_TABLE&quot; border=&quot;1&quot;&gt;
      &lt;tr&gt;
        &lt;td width=&quot;100&quot;&gt;列0&lt;/td&gt;
        &lt;td width=&quot;100&quot;&gt;列1&lt;/td&gt;
        &lt;td width=&quot;150&quot;&gt;列2&lt;/td&gt;
        &lt;td width=&quot;200&quot;&gt;列3&lt;/td&gt;
      &lt;/tr&gt;
    &lt;/table&gt;

    &lt;!-- ***** データ部の&lt;TABLE&gt;タグ ***** --&gt;
    &lt;table id=&quot;DATA_TABLE&quot; border=&quot;1&quot;&gt;
      &lt;tr&gt;
        &lt;td&gt;
          データ0-0
        &lt;/td&gt;
        &lt;td&gt;
          データ0-1
        &lt;/td&gt;
        &lt;td&gt;
          データ0-2
        &lt;/td&gt;
        &lt;td&gt;
          データ0-3
        &lt;/td&gt;
      &lt;/tr&gt;
      &lt;tr&gt;
        &lt;td&gt;データ1-0&lt;/td&gt;
        &lt;td&gt;データ1-1&lt;/td&gt;
        &lt;td&gt;データ1-2&lt;/td&gt;
        &lt;td&gt;データ1-3&lt;/td&gt;
      &lt;/tr&gt;
    &lt;/table&gt;

  &lt;/body&gt;

&lt;/html&gt;
</pre>
 * 				</font>
 * 			</td>
 * 		</tr>
 * 	</table>
 *
 * <br/>
 * <br/>
 *
 * 	<table border="1">
 * 		<tr>
 * 			<th>
 * 				リサイズ時にデータの内容を改行しないようにするサンプル（.html ファイル）
 * 			</th>
 * 		</tr>
 * 		<tr>
 * 			<td>
 * 				<font size="-1.5">
<pre>
&lt;html&gt;
  &lt;head&gt;
  &lt;script type=&quot;text/javascript&quot; src=&quot;../csjs/prototype.js&quot;&gt;&lt;/script&gt;
  &lt;script type=&quot;text/javascript&quot; src=&quot;../csjs/im_abstract_self_event_handler.js&quot;&gt;&lt;/script&gt;
  &lt;script type=&quot;text/javascript&quot; src=&quot;../csjs/sortable_table/im_header_column_resizer.js&quot;&gt;&lt;/script&gt;

    &lt;script language=&quot;javascript&quot;&gt;

      /&#42;&#42;
       &#42; id=&quot;HEADER_TABLE&quot; と id=&quot;DATA_TABLE&quot;で指定されたテーブルをリサイズ可能にします。
       &#42;/
      &#102;unction startResize() {

        var tableElemId4Header = &quot;HEADER_TABLE&quot;; // ヘッダ部の&lt;TABLE&gt;タグのid
        var tableElemId4Data   = &quot;DATA_TABLE&quot;;   // データ部の&lt;TABLE&gt;タグのid

        var width  = 500; // 幅
        var height = 300; // 高さ

        // リサイズ開始
        new ImHeaderColumnResizer(tableElemId4Header, tableElemId4Data, width, height);
      }

    &lt;/script&gt;

  &lt;/head&gt;

  &lt;!-- onload時にリサイズを可能にします --&gt;
  &lt;body onload=&quot;startResize();&quot;&gt;

    &lt;!-- ***** ヘッダ部の&lt;TABLE&gt;タグ ***** --&gt;
    &lt;table id=&quot;HEADER_TABLE&quot; border=&quot;1&quot;&gt;
      &lt;tr&gt;
        &lt;td width=&quot;100&quot;&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しない列0&lt;/div&gt;
        &lt;/td&gt;
        &lt;td width=&quot;100&quot;&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しない列1&lt;/div&gt;
        &lt;/td&gt;
        &lt;td width=&quot;150&quot;&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しない列2&lt;/div&gt;
        &lt;/td&gt;
        &lt;td width=&quot;200&quot;&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しない列3&lt;/div&gt;
        &lt;/td&gt;
      &lt;/tr&gt;
    &lt;/table&gt;

    &lt;!-- ***** データ部の&lt;TABLE&gt;タグ ***** --&gt;
    &lt;table id=&quot;DATA_TABLE&quot; border=&quot;1&quot;&gt;
      &lt;tr&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ0-0&lt;/div&gt;
        &lt;/td&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ0-1&lt;/div&gt;
        &lt;/td&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ0-2&lt;/div&gt;
        &lt;/td&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ0-3&lt;/div&gt;
        &lt;/td&gt;
      &lt;/tr&gt;
      &lt;tr&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ1-0&lt;/div&gt;
        &lt;/td&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ1-1&lt;/div&gt;
        &lt;/td&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ1-2&lt;/div&gt;
        &lt;/td&gt;
        &lt;td&gt;
          &lt;div style=&quot;overflow: hidden; white-space: noWrap&quot;&gt;改行しないデータ1-3&lt;/div&gt;
        &lt;/td&gt;
      &lt;/tr&gt;
    &lt;/table&gt;

  &lt;/body&gt;

&lt;/html&gt;
</pre>
 * 				</font>
 * 			</td>
 * 		</tr>
 * 	</table>
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */

var IM_STBL_HEAD_RESIZER_CONST = new Object();
    IM_STBL_HEAD_RESIZER_CONST.STATE = new Object();
    IM_STBL_HEAD_RESIZER_CONST.STATE.UN_RESIZABLE = "Unresizable";
    IM_STBL_HEAD_RESIZER_CONST.STATE.RESIZABLE    = "Resizable";

    IM_STBL_HEAD_RESIZER_CONST.RESIZE_CURSOR_MARGIN_WIDTH = 10;

    IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_OUTER_ID = "_RESIZER_HEADER_LAYER_OUTER";
    IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_INNER_ID = "_RESIZER_HEADER_LAYER_INNER";
    IM_STBL_HEAD_RESIZER_CONST.DATA_LAYER_ID         = "_RESIZER_DATA_LAYER";

    IM_STBL_HEAD_RESIZER_CONST.BROWSER_SCROLL_BAR_WIDTH = "17";

ImHeaderColumnResizer.prototype = new ImAbstractSelfEventHandler();

/**
 * ヘッダーの列幅をリサイズ可能にするオブジェクトを生成します。
 *
 * @class ＜TABLE＞タグ要素の列幅をリサイズ可能にする CSJS オブジェクト。<br/>
 * <br/>
 * ImHeaderColumnResizerオブジェクトの利用方法、およびサンプルコードは、
 * <a href="overview-summary-im_header_column_resizer.js.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 * @param {String} tableElemId4Header ヘッダ部の&lt;TABLE&gt;タグのid
 * @param {String} tableElemId4Data データ部の&lt;TABLE&gt;タグのid
 * @param {Number} width [option] 幅 (任意)
 * @param {Number} height [option] 高さ (任意)
 *
 * @return ImHeaderColumnResizerオブジェクト
 * @type ImHeaderColumnResizer
 */
function ImHeaderColumnResizer(tableElemId4Header, tableElemId4Data, width, height) {

    /**
     * @private
     *
     * CONSTRUCTOR
     */
    this.constructor = function(tableElemId4Header, tableElemId4Data, width, height){

        this.controlType  = "HeaderColumnResizer";
        this.initialState = IM_STBL_HEAD_RESIZER_CONST.STATE.UN_RESIZABLE;
        this.currentState = this.initialState;

        this.htmlElement      = document;
        this.tableElem4Header = document.getElementById(tableElemId4Header);
        this.tableElem4Data   = document.getElementById(tableElemId4Data);

        this.width  = width;
        this.height = height;

        this.resizable = true;
        this.resizableCheckFunc = null;

        this.resizeCellIdx = null;

        this.addCachedSelfListenersForceUseEventObserve("mousedown", "mouseup", "mousemove");

        // Initialize Table
        this.initializeTable();

        // Append DIV Tag (For 'HeaderLayer' scrolls when 'DataLayer' scrolls.)
        this._appendSyncScrollDiv();
    }

    /**
     * @private
     * @override
     */
    this.unloadChildElements = function(){
        this.resizeCellIdx = null;

        this.resizableCheckFunc = null;
        this.resizable          = null;

        this.height = null;
        this.width  = null;

        this.tableElem4Data   = null;
        this.tableElem4Header = null;
        this.htmlElement      = null;

        this.currentState = null;
        this.initialState = null;
        this.controlType  = null;
    }

    /**
     * リサイズの可否を設定します。
     *
     * @param {Boolean} resizable 列幅のリサイズを行う場合は true、
     * 							 列幅のリサイズを行わない場合は false。
     */
    this.setResizable = function(resizable){
        this.resizable = resizable;
    }

    /**
     * リサイズ可否判定関数を設定します。<br/>
     * ImHeaderColumnResizerオブジェクトは、引数 resizableCheckFunc で指定された関数の実行結果を判定し、
     * リサイズを行うかどうかを決定します。<br/>
     * <br/>
     * 引数 resizableCheckFunc で指定する関数の実行結果が true の場合は リサイズを行い、
     * false の場合は リサイズを行いません。<br/>
     * <br/>
     * なお、<a href='#setResizable'>setResizable(Boolean resizable)</a>で false が設定されている場合は、
     * この関数を用いたリサイズ可否判定処理は行いません。
     *
     * @param {Function} resizableCheckFunc リサイズ可否判定関数。（この関数の返却値の型は Boolean）
     */
    this.setResizableCheckFunc = function(resizableCheckFunc){
        this.resizableCheckFunc = resizableCheckFunc;
    }

    /**
     * @private
     * @override
     */
    this.actionTransitionFunctions = {
        Unresizable : {
            mousedown : function(event){
                var cellIdxInfo = this.getCellIdxInfoUnderPointer(event);
                this.resizeCellIdx = cellIdxInfo.resizeCellIdx;
                if(this.resizeCellIdx == null){
                    return this.currentState;
                }
                else{
                    return IM_STBL_HEAD_RESIZER_CONST.STATE.RESIZABLE;
                }
            },

            mouseup : function(event){
                return this.currentState;
            },

            mousemove : function(event){
                this.changeCursorStyle(event);
                return this.currentState;
            }
        },

        Resizable : {
            mousedown : function(event){
                return this.doActionTransition(IM_STBL_HEAD_RESIZER_CONST.STATE.RESIZABLE, "mouseup", event);
            },

            mouseup : function(event){
                this.resizeCellIdx = null;
                return IM_STBL_HEAD_RESIZER_CONST.STATE.UN_RESIZABLE;
            },

            mousemove : function(event){
                this.resizeHeader(event);
                return this.currentState;
            }

        }
    }

    /**
     * @private
     */
    this.getCellIdxInfoUnderPointer = function(event){

        var cellIdxInfo = new CellIdxInfo();

        if(!this.isResizable()) {
            return cellIdxInfo;
        }

        var clientX = event.clientX;
        var clientY = event.clientY;

        var headerRow = this.tableElem4Header.rows[0];
        var headerRowTop = this.getElemPosition(headerRow).top - document.body.scrollTop;
        var headerRowBottom = headerRowTop + headerRow.cells[0].offsetHeight;

        if(clientY < headerRowTop || headerRowBottom < clientY){
            return cellIdxInfo;
        }

        var headerLen = headerRow.cells.length;
        for(var idx = 0 ; idx < headerLen ; idx++){

            var headerCell = headerRow.cells[idx];
            var headerCellLeft = this.getElemPosition(headerCell).left;
            var headerCellRight = headerCellLeft + headerCell.offsetWidth - document.body.scrollLeft;

            var limitLeft  = headerCellRight - IM_STBL_HEAD_RESIZER_CONST.RESIZE_CURSOR_MARGIN_WIDTH;
            var limitRight = headerCellRight + IM_STBL_HEAD_RESIZER_CONST.RESIZE_CURSOR_MARGIN_WIDTH;

            if(headerCellLeft < clientX && clientX < headerCellRight){
                cellIdxInfo.targetCellIdx = idx;
            }

            if(limitLeft < clientX && clientX < limitRight){
                cellIdxInfo.resizeCellIdx = idx;
                return cellIdxInfo;
            }
            else{
                continue;
            }

        }

        return cellIdxInfo;

        function CellIdxInfo(){
            this.resizeCellIdx = null;
            this.targetCellIdx = null;
        }
    }

    /**
     * @private
     */
    this.resizeHeader = function(event){

        var resizeCell4Header = this.tableElem4Header.rows[0].cells[this.resizeCellIdx];
        var widthAfterResize = (document.body.scrollLeft + event.clientX) - this.getElemPosition(resizeCell4Header).left;

        if(widthAfterResize < IM_STBL_HEAD_RESIZER_CONST.RESIZE_CURSOR_MARGIN_WIDTH * 2){
            return;
        }

        var widthBeforeResize = parseInt(resizeCell4Header.style.width, 10);
        var delta = widthBeforeResize - widthAfterResize;

        resizeCell4Header.style.width = widthAfterResize;
        this.tableElem4Header.style.width = parseInt(this.tableElem4Header.style.width, 10) - delta;

        if(this.tableElem4Data.rows[0]){
            var resizeCell4Data   = this.tableElem4Data.rows[0].cells[this.resizeCellIdx];
            resizeCell4Data.style.width = widthAfterResize;
        }
        this.tableElem4Data.style.width = parseInt(this.tableElem4Data.style.width, 10) - delta;

        var headerLayerOuter = document.getElementById(this.tableElem4Header.id + IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_OUTER_ID);
        var dataLayer        = document.getElementById(this.tableElem4Data.id   + IM_STBL_HEAD_RESIZER_CONST.DATA_LAYER_ID);

        headerLayerOuter.style.width = dataLayer.offsetWidth - IM_STBL_HEAD_RESIZER_CONST.BROWSER_SCROLL_BAR_WIDTH;

        // If resize target cell is last element in cellsArray, adjust headerLayer of inner.
        // (Because, the position where the row of 'HEADER' and the row of 'DATA' are displayed illegal. [only IE])
        if(window.navigator.userAgent.indexOf("MSIE") != -1){
            var headerLayerInner = document.getElementById(this.tableElem4Header.id + IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_INNER_ID);
            headerLayerInner.style.left = (dataLayer.scrollLeft * (-1));
        }
    }

    /**
     * @private
     */
    this.updateHeaderWidth = function(colIdx, width){

        var resizeCell4Header = this.tableElem4Header.rows[0].cells[colIdx];

        var widthBeforeResize = parseInt(resizeCell4Header.style.width, 10);
        var delta = widthBeforeResize - width;

        resizeCell4Header.style.width = width;
        this.tableElem4Header.style.width = parseInt(this.tableElem4Header.style.width, 10) - delta;

        if(this.tableElem4Data.rows[0]){
            var resizeCell4Data   = this.tableElem4Data.rows[0].cells[colIdx];
            resizeCell4Data.style.width = width;
        }
        this.tableElem4Data.style.width = parseInt(this.tableElem4Data.style.width, 10) - delta;

        var headerLayerOuter = $(this.tableElem4Header.id + IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_OUTER_ID);
        var dataLayer        = $(this.tableElem4Data.id   + IM_STBL_HEAD_RESIZER_CONST.DATA_LAYER_ID);

        headerLayerOuter.style.width = dataLayer.offsetWidth - IM_STBL_HEAD_RESIZER_CONST.BROWSER_SCROLL_BAR_WIDTH;

        // If resize target cell is last element in cellsArray, adjust headerLayer of inner.
        // (Because, the position where the row of 'HEADER' and the row of 'DATA' are displayed illegal. [only IE])
        if(window.navigator.userAgent.indexOf("MSIE") != -1){
            var headerLayerInner = $(this.tableElem4Header.id + IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_INNER_ID);
            headerLayerInner.style.left = (dataLayer.scrollLeft * (-1));
        }

        return widthBeforeResize;
    }

    /**
     * @private
     */
    this.changeCursorStyle = function(event){

        if(!this.isResizable()) {
            return;
        }

        var cellIdxInfo = this.getCellIdxInfoUnderPointer(event);

        if(cellIdxInfo.resizeCellIdx != null){
            var targetResizeCell = this.tableElem4Header.rows[0].cells[cellIdxInfo.resizeCellIdx];
            if(window.navigator.userAgent.toUpperCase().indexOf("MSIE") != -1
               ||
               window.navigator.userAgent.toUpperCase().indexOf("FIREFOX") != -1){
                targetResizeCell.style.cursor = "col-resize";
            }
            else{
                targetResizeCell.style.cursor = "e-resize";
            }
        }
        else if(cellIdxInfo.targetCellIdx != null){
            var targetCell = this.tableElem4Header.rows[0].cells[cellIdxInfo.targetCellIdx];
            targetCell.style.cursor = "auto";
        }
    }

    /**
     * @private
     */
    this.isResizable = function(){

        if(this.resizable == false){
            return false;
        }

        if(this.resizableCheckFunc == null || this.resizableCheckFunc == undefined){
            return true;
        }

        return this.resizableCheckFunc();
    }

    // Construct instance
    this.constructor(tableElemId4Header, tableElemId4Data, width, height);

}

/**
 * ヘッダ部の&lt;TABLE&gt;、および、データ部の&lt;TABLE&gt;を初期化します。<br/>
 * データ部の列幅を、ヘッダ部の列幅に合わせます。
 */
ImHeaderColumnResizer.prototype.initializeTable = function(){

    if(this.tableElem4Data.rows[0]){

        var headerCells = this.tableElem4Header.rows[0].cells;
        var dataCells = this.tableElem4Data.rows[0].cells;

        for(var idx = 0; idx < headerCells.length; idx ++){
            if(!headerCells[idx].style.width){
                // !!!!! IT IS NECESSARY TO BE EXECUTED IN THE FOLLOWING ORDER. !!!!!
                // (Otherwise, the column width of 'Header' and 'Data' division is different.)
                var tempOffsetWidth = headerCells[idx].offsetWidth;
                headerCells[idx].style.width = tempOffsetWidth;
                dataCells[idx].style.width   = tempOffsetWidth;
            }
            else {
                dataCells[idx].style.width = headerCells[idx].style.width;
            }
        }
    }

    this.tableElem4Header.style.width = this.tableElem4Header.offsetWidth;
    this.tableElem4Data.style.width   = this.tableElem4Header.offsetWidth;

    this.tableElem4Header.style.tableLayout = "fixed";
    this.tableElem4Data.style.tableLayout   = "fixed";
}

/**
 * @private
 */
ImHeaderColumnResizer.prototype._appendSyncScrollDiv = function(){

    var id4headerLayerOuter = this.tableElem4Header.id + IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_OUTER_ID;
    var id4headerLayerInner = this.tableElem4Header.id + IM_STBL_HEAD_RESIZER_CONST.HEADER_LAYER_INNER_ID;
    var id4dataLayer        = this.tableElem4Data.id   + IM_STBL_HEAD_RESIZER_CONST.DATA_LAYER_ID;

    var headerLayerOuter = document.createElement("div");
    var headerLayerInner = document.createElement("div");
    var dataLayer        = document.createElement("div");

    headerLayerOuter.id = id4headerLayerOuter;
    headerLayerInner.id = id4headerLayerInner;
    dataLayer.id        = id4dataLayer;

    var replaced = document.createElement("replaced");
    // ==============================================
    // **** BEFORE ****
    //     <TABLE id="HEADER"/>
    //     <TABLE id="DATA"/>
    //
    // **** AFTER  ****
    //     <div id="headerLayerOuter">
    //         <div id="headerLayerInner">
    //             <TABLE id="HEADER"/>
    //         </div>
    //      </div>
    //      <div id="dataLayer">
    //          <TABLE id="DATA"/>
    //      </div>
    // ==============================================
    var parentNode4Header= this.tableElem4Header.parentNode;
    parentNode4Header.insertBefore(headerLayerOuter, this.tableElem4Header);
    headerLayerOuter.appendChild(headerLayerInner);
    headerLayerInner.appendChild(replaced);
    headerLayerInner.replaceChild(this.tableElem4Header, replaced);

    var parentNode4Data = this.tableElem4Data.parentNode;
    parentNode4Data.insertBefore(dataLayer, this.tableElem4Data);
    dataLayer.appendChild(replaced);
    dataLayer.replaceChild(this.tableElem4Data, replaced);

    replaced = null;

    // STYLE !!!!! It is necessary to set STYLE before WIDTH is set. !!!!!
    // (Otherwise, 'Header' will not hidden. [only IE])
    headerLayerOuter.style.overflow = "hidden";
    headerLayerInner.style.position = "relative";
    dataLayer.style.overflow = "scroll";

    // WIDTH
    if(this.width){
        dataLayer.style.width = this.width;
        headerLayerOuter.style.width = this.width - IM_STBL_HEAD_RESIZER_CONST.BROWSER_SCROLL_BAR_WIDTH;
    }
    else {
        dataLayer.style.width = "100%";
        headerLayerOuter.style.width = dataLayer.offsetWidth - IM_STBL_HEAD_RESIZER_CONST.BROWSER_SCROLL_BAR_WIDTH;
    }

    // HEIGHT
    if(this.height){
        dataLayer.style.height = this.height - headerLayerOuter.offsetHeight;
    }
    else {
        dataLayer.style.height = "100%";
    }

    // LISTENER
    Event.observe(dataLayer,
                  "scroll",
                  function(){
                      var headerLayerInner = $(id4headerLayerInner);
                      var dataLayer        = $(id4dataLayer);
                      headerLayerInner.style.left = dataLayer.scrollLeft * (-1);
                  },
                  false);

    Event.observe(window,
                  "resize",
                  function(){
                      var haderLayerOuter = $(id4headerLayerOuter);
                      var dataLayer       = $(id4dataLayer);
                      var resizedWidth = dataLayer.offsetWidth - IM_STBL_HEAD_RESIZER_CONST.BROWSER_SCROLL_BAR_WIDTH;
                      if(resizedWidth >= 0){
                          haderLayerOuter.style.width = resizedWidth;
                      }
                  },
                  false);
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_json.js

概要

JSON 関連のライブラリです。

Version: 1.0

Author: INTRAMART

クラスの概要
ImJson JSON 関連のライブラリです。
/**
 * JSON 関連のメソッドを提供します。
 * @fileoverview JSON 関連のライブラリです。
 * @class JSON 関連のライブラリです。<br/>
 * 		  <br/>
 * 		  JSON (JavaScript Object Notation)は、軽量のデータ交換フォーマットです。<br/>
 * 		  JSON については、<a href="http://www.json.org/json-ja.html">JSON の紹介</a> を参照してください。
 * @constructor
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */
function ImJson(){}

/**
 * JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられる例外のメッセージです。
 * @final
 * @type String
 */
ImJson.PARSE_JSON_ERROR_MESSAGE = "parseJSON Error";

/**
 * @private
 * インデント用文字列のキャッシュ
 */
ImJson.indentStringCache = new Array();

/**
 * インデント文字列
 * @final
 * @type String
 */
ImJson.INDENT_STRING = "    ";

/**
 * @private
 * Name/Valueのセパレータ文字列
 * @final
 * @type String
 */
ImJson.NAME_VALUE_SEPARATER = ", ";

/**
 * 「null」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_NULL = "/* Null */";

/**
 * 「Undefined」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_UNDEFINED = "/* Undefined */";

/**
 * 「String」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_STRING = "/* String */";

/**
 * 「Date」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_DATE = "/* Date */";

/**
 * 「Array」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_ARRAY = "/* Array */";

/**
 * 「Object」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_OBJECT = "/* Object */";

/**
 * 「Function」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_FUNCTION = "/* Function */";

/**
 * 「Number」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_NUMBER = "/* Number */";

/**
 * 「Boolean」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_BOOLEAN = "/* Boolean */";

/**
 * 「XML」型 を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_XML = "/* XML */";

/**
 * 型が特定できない場合を表す定数
 * @final
 * @type String
 */
ImJson.TYPE_UNKNOWN = "/* Unknown */";

/**
 * JSON 文字列からJavaScriptオブジェクトに変換します。<br/>
 * <br/>
 *
 * @param {String} jsonString JSON 文字列
 * @return JavaScriptオブジェクト
 * @type Object
 * @throws SyntaxError JSON 文字列からJavaScriptオブジェクトへの変換に失敗した場合に投げられます。
 *						（例外のメッセージは、{@link ImJson#PARSE_JSON_ERROR_MESSAGE}に設定されます）
 */
ImJson.parseJSON = function(jsonString) {

    if(false == ImJson.checkJSONString(jsonString)){
        throw new SyntaxError(ImJson.PARSE_JSON_ERROR_MESSAGE);
    }

    try{
        var newObject;

        newObject = eval('('+jsonString+')');
        return newObject;
    } catch(e){
        throw new SyntaxError(ImJson.PARSE_JSON_ERROR_MESSAGE);
    }
}

/**
 * JSON 文字列に変換します。<br/>
 * <br/>
 * 引数「debugFlg」が true の場合、JSON 文字列のインデント化、および、型名の付与を行います。<br/>
 * その際、変換対象オブジェクト（内部のプロパティも含む）が 以下の型の場合、特別な動作をします。<br/>
 *
 * <br/>
 * <table border="1">
 * 	<tr>
 * 		<td bgcolor="lightgrey">Date 型</td>
 * 		<td>型名の右側に、日付の文字列表現がJavaScriptのコメントとして出力されます。</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">Function 型</td>
 * 		<td><b>"THIS_IS_FUNCTION"</b> として表現します。</td>
 * 	</tr>
 * </table>
 * <br/>
 * なお、引数「debugFlg」が true 時の本メソッドの返却値には型名が付与されているため、<br/>
 * {@link ImJson#checkJSONString}でのチェックには失敗します。<br/>
 *
 * @param {Object} value 変換対象
 * @param {Boolean} debugFlg [option] JSON 文字列のインデント化、および、型名の付与を行う場合は trueを設定してください。
 * 									  省略時のデフォルトは false。
 * @return JSON 文字列
 * @type String
 */
ImJson.toJSONString = function(value, debugFlg){

    /**
     * @private
     * 引数で与えられた値の型を判定します。
     *
     * @param {Object} value 判定対象オブジェクト
     * @return 型を表す文字列
     * @type String
     */
    function getTypeName(value){
        if( value === null ) {
            return ImJson.TYPE_NULL;
        }
        else if( typeof(value) == "undefined" ) {
            return ImJson.TYPE_UNDEFINED;
        }
        else if( typeof(value) == "string" ) {
            return ImJson.TYPE_STRING;
        }
        else if( typeof(value) == "number" ) {
            return ImJson.TYPE_NUMBER;
        }
        else if( typeof(value) == "boolean" ) {
            return ImJson.TYPE_BOOLEAN;
        }
        else if( typeof(value) == "object" && typeof(value.push) == "function" ) {
            return ImJson.TYPE_ARRAY;
        }
        else if( typeof(value) == "object" && typeof(value.getFullYear) == "function" ) {
            return ImJson.TYPE_DATE;
        }
        else if ("innerHTML"  in value            && typeof(value.innerHTML)         == "string" &&
                 "tagName"    in value            && typeof(value.tagName)           == "string" &&
                 "attributes" in value            && typeof(value.attributes)        == "object" &&
                 "length"     in value.attributes && typeof(value.attributes.length) == "number") {
            return ImJson.TYPE_XML;
        }
        else if( typeof(value) == "function" ) {
            return ImJson.TYPE_FUNCTION;
        }
        else if( typeof(value) == "object" ) {
            return ImJson.TYPE_OBJECT;
        }
        else {
            return ImJson.TYPE_UNKNOWN;
        }
    }

    /**
     * @private
     * JSON 文字列への変換（Object用）
     *
     * @param {Object} objectData 変換対象オブジェクト
     * @param {String} indent インデント
     * @return JSON 文字列
     * @type String
     */
    function toJSONString4Object(objectData, indentDepth){
        var array = new Array();

        for(var prop in objectData){
            if( typeof(objectData.hasOwnProperty) != "function"
                ||
                objectData.hasOwnProperty(prop)) {

                var tempStr  = '"' + ImJson.escapeData(prop) + '" : ';
                var typeName = getTypeName(objectData[prop]);

                switch(typeName){
                    case ImJson.TYPE_NULL :
                    case ImJson.TYPE_UNDEFINED :
                        tempStr += new String(objectData[prop]);
                        break;

                    case ImJson.TYPE_NUMBER :
                    case ImJson.TYPE_BOOLEAN :
                        tempStr += objectData[prop];
                        break;

                    case ImJson.TYPE_DATE :
                        typeName += "  // " + objectData[prop].toString();  /* ← 型名の横にDateの文字列表現 */
                        tempStr += ImJson.dateToSrcString(objectData[prop]);
                        break;

                    case ImJson.TYPE_ARRAY :
                        tempStr += toJSONString4Array(objectData[prop], indentDepth + 1);
                        break;

                    case ImJson.TYPE_OBJECT :
                        tempStr += toJSONString4Object(objectData[prop], indentDepth + 1);
                        break;

                    case ImJson.TYPE_FUNCTION :
                        /* FunctionはJSON 文字列化しない */
                        if(debugFlg == true){
                            tempStr += '\"THIS_IS_FUNCTION\"';
                            array[array.length] = concatTypeName(tempStr, typeName, indentDepth);
                        }
                        continue;
                        break;

                    case ImJson.TYPE_XML :
                        tempStr += '"<' + objectData[prop].tagName + ' id=\'' + objectData[prop].id + '\'>"';
                        break;

                    case ImJson.TYPE_STRING :
                    case ImJson.TYPE_UNKNOWN :
                    default :
                        tempStr += '"' + ImJson.escapeData( new String(objectData[prop]) ) + '"';
                        break;
                }

                /* 型の名称を付与 */
                if(debugFlg == true){
                    tempStr = concatTypeName(tempStr, typeName, indentDepth);
                }

                array[array.length] = tempStr;
            }
        }

        var str = "{";

        if(debugFlg == true){
            str += concatIndent(array, indentDepth);
        }
        else {
            str += array.join(ImJson.NAME_VALUE_SEPARATER);
        }

        str += "}";
        return str;
    }

    /**
     * @private
     * JSON 文字列への変換（Array用）<br/>
     *
     * @param {Array} arrayData 配列
     * @param {Number} indentDepth インデントの深さ
     * @return JSON 文字列
     * @type String
     */
    function toJSONString4Array(arrayData, indentDepth){
        var array = new Array();

        for(var idx = 0, max = arrayData.length;  idx < max; idx++){
            var typeName = getTypeName(arrayData[idx]);
            var insertIdx = array.length;

            switch(typeName){
                case ImJson.TYPE_NULL :
                case ImJson.TYPE_UNDEFINED :
                    array[insertIdx] = new String(arrayData[idx]);
                    break;

                case ImJson.TYPE_NUMBER :
                case ImJson.TYPE_BOOLEAN :
                    array[insertIdx] = arrayData[idx];
                    break;

                case ImJson.TYPE_DATE :
                    typeName += "  // " + arrayData[idx].toString();  /* ← 型名の横にDateの文字列表現 */
                    array[insertIdx] = ImJson.dateToSrcString(arrayData[idx]);
                    break;

                case ImJson.TYPE_ARRAY :
                    array[insertIdx] = toJSONString4Array(arrayData[idx], indentDepth + 1);
                    break;

                case ImJson.TYPE_OBJECT :
                    array[insertIdx] = toJSONString4Object(arrayData[idx], indentDepth + 1);
                    break;

                case ImJson.TYPE_FUNCTION :
                    /* FunctionはJSON 文字列化しない */
                    if(debugFlg == true){
                        array[insertIdx] = concatTypeName('\"THIS_IS_FUNCTION\"', typeName, indentDepth);
                    }
                    continue;
                    break;

                case ImJson.TYPE_XML :
                    array[insertIdx] = '"<' + arrayData[idx].tagName + ' id=\'' + arrayData[idx].id + '\'>"';
                    break;

                case ImJson.TYPE_STRING :
                case ImJson.TYPE_UNKNOWN :
                default :
                    array[insertIdx] = '"' + ImJson.escapeData( new String(arrayData[idx]) ) + '"';
                    break;
            }

            /* 型の名称を付与 */
            if(debugFlg == true){
                array[insertIdx] = concatTypeName(array[insertIdx], typeName, indentDepth);
            }
        }

        var str = "[";

        if(debugFlg == true){
            str += concatIndent(array, indentDepth);
        }
        else {
            str += array.join(ImJson.NAME_VALUE_SEPARATER);
        }

        str += "]";
        return str;
    }

    /**
     * @private
     * インデント文字列を 引数「depth」個分連結した文字列返却します。<br/>
     * <br/>
     *
     * @param {Number} depth インデントの深さ
     * @return インデント文字列
     * @type String
     */
    function getIndentString(depth){
        var indentString = ImJson.indentStringCache[depth];

        if(!indentString){
            indentString = "";
            for(var idx = 0; idx < depth; idx++){
                indentString += ImJson.INDENT_STRING;
            }
            ImJson.indentStringCache[depth] = indentString;
        }
        return indentString;
    }

    /**
     * @private
     * 引数「value」に型の名称を付加した文字列を返却します。<br/>
     * <br/>
     * 引数「depth」で指定された値を元に、インデント処理を行います。
     *
     * @param {String} value 文字列
     * @param {String} typeName 型の名称
     * @param {Number} depth インデントの深さ
     * @return 引数「value」に型の名称を付加した文字列
     * @type String
     */
    function concatTypeName(value, typeName, depth){
        depth = (depth) ? depth : 0;
        return typeName + "\n" + getIndentString(depth) + value;
    }

    /**
     * @private
     * Name/Valueのセパレータ文字列で配列を連結します。<br/>
     * <br/>
     * 引数「depth」で指定された値を元に、インデント処理を行います。
     *
     * @param {Array} array 連結を行う配列
     * @param {Number} depth インデントの深さ
     * @return 連結後の文字列
     * @type String
     */
    function concatIndent(array, depth){
        var str = "";

        str += "\n" + getIndentString(depth);
        str += array.join(ImJson.NAME_VALUE_SEPARATER + "\n\n" + getIndentString(depth));
        str += "\n" + getIndentString(depth - 1);

        return str;
    }

    /**
     * @private
     * ImJsonのtoJSONString() 処理本体
     */
    {
        debugFlg = (debugFlg) ? debugFlg : false;

        var jsonString = "";
        var typeName = getTypeName(value);

        switch(typeName){
            case ImJson.TYPE_NULL :
            case ImJson.TYPE_UNDEFINED :
                jsonString = new String(value);
                break;

            case ImJson.TYPE_NUMBER :
            case ImJson.TYPE_BOOLEAN :
                jsonString = value;
                break;

            case ImJson.TYPE_DATE :
                typeName += "  // " + value.toString();  /* ← 型名の横にDateの文字列表現 */
                jsonString = ImJson.dateToSrcString(value);
                break;

            case ImJson.TYPE_ARRAY :
                jsonString = toJSONString4Array(value, 1);
                break;

            case ImJson.TYPE_OBJECT :
                jsonString = toJSONString4Object(value, 1);
                break;

            case ImJson.TYPE_FUNCTION :
                /* FunctionはJSON 文字列化しない */
                if(debugFlg == true){
                    jsonString = '\"THIS_IS_FUNCTION\"';
                }
                break;

            case ImJson.TYPE_XML :
                jsonString = '"<' + value.tagName + ' id=\'' + value.id + '\'>"';
                break;

            case ImJson.TYPE_STRING :
            case ImJson.TYPE_UNKNOWN :
            default :
                jsonString = '"' + ImJson.escapeData(new String(value) ) + '"';
                break;
        }

        /* 型の名称を付与 */
        if(debugFlg == true){
            jsonString = concatTypeName(jsonString, typeName, 0);
        }

        return String(jsonString);
    }
}

/**
 * @private
 * 文字列をエスケープします。
 *
 * @param {String} targetData エスケープ対象文字列
 * @return エスケープ後の文字列
 * @type String
 */
ImJson.escapeData = function(targetData) {
    var returnData;
    var convTbl = {
        '\b': '\\b',
        '\t': '\\t',
        '\n': '\\n',
        '\f': '\\f',
        '\r': '\\r',
        '"' : '\\"'
    };

    returnData = targetData.replace(/\\/g, "\\\\");
    returnData = returnData.replace(/\"/g, "\\\"");

    returnData = returnData.replace(/([\x08-\x0D])/g,function(pc,nc){
                    var convChar = convTbl[pc];
                    if (convChar) {
                        return convChar;
                    }
                    return pc;
                 })

    /* 改行コードの変換 */
    returnData = returnData.split("\r\n").join("\\n");
    returnData = returnData.split("\r").join("\\r");
    returnData = returnData.split("\n").join("\\n");

    return returnData;
}

/**
 * JSON 文字列の妥当性をチェックします。
 *
 * @param {String} jsonString JSON 文字列
 * @return 正当なJSON 文字列の場合は true、不正なJSON 文字列の場合は false を返却します。
 * @type Boolean
 */
ImJson.checkJSONString = function(jsonString){

    /* Netscapeの場合、trueを返却 */
    /* ∵Netscapeでは、以下の正規表現によるJSON文字列チェックで false が返却されるため */
    try{
        if(!window.attachEvent && !window.opera && (navigator.userAgent.indexOf('Netscape') > -1)){
            return true;
        }
    }
    catch(e){
        /* サーバサイドでは 常にJSON 文字列のチェックを行う */
    }

    /* チェック！ */
    if (/^("(\\.|[^"\\\n\r])*?"|[,:{}\[\]0-9.\-+Eaeflnr-u \n\r\t]|new Date\(\-?[0-9]*\)|undefined|NaN|Infinity|\-Infinity)+?$/.
              test(jsonString)) {
        return true;
    } else {
        return false;
    }
}

/**
 * @private
 * Date型のオブジェクトをJSON 文字列化します。
 *
 * @parama {Date} date Date型のオブジェクト
 * @return Date型オブジェクトを変換したJSON 文字列
 * @type String
 */
ImJson.dateToSrcString = function(date) {
    var src = "new Date(" +
        date.getTime() + ")";
    return src;
}

/**
 * @private
 * Function : /intra-mart/jssp-rpc/marshller/function-name/marshall
 */
var imJsonMarshall = function (obj, debugFlg) {
    return ImJson.toJSONString(obj, debugFlg);
}

/**
 * @private
 * Function : /intra-mart/jssp-rpc/marshller/function-name/unmarshall
 */
var imJsonUnmarshall = function (jsonString) {
    return ImJson.parseJSON(jsonString);
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_realnumber.js

概要

小数演算を可能にするオブジェクト。

サンプルコード

サンプル（.htmlファイル）
  ・
  ・
  ・
  <script src="csjs/im_realnumber.js"></script>

  <script language="javascript">
    //変数 oRN を 2.1 で初期化
    var oRN = new RealNumber( 2.1 );

    //加算 oRN + 0.9 を実行し、その数字データ(String)を取得する。
    var nAns = oRN.getAdd(0.9).toString();
  </script>
  ・
  ・
  ・

Version: 1.0

Author: INTRAMART

クラスの概要
RealNumber 小数演算を可能にするオブジェクト。
/**
 * @fileoverview 小数演算を可能にするオブジェクト。<br/>
 * <br/>
 * <strong>サンプルコード</strong> </a><br/>
 * <br/>
 * <table border="1">
 *   <tr>
 *     <th>
 *       サンプル（.htmlファイル）
 *     </th>
 *   </tr>
 *   <tr>
 *     <td>
 *       <font size="-1">
<pre>
  ・
  ・
  ・
  &lt;script src=&quot;csjs/im_realnumber.js&quot;&gt;&lt;/script&gt;

  &lt;script language=&quot;javascript&quot;&gt;
    //変数 oRN を 2.1 で初期化
    var oRN = new RealNumber( 2.1 );

    //加算 oRN + 0.9 を実行し、その数字データ(String)を取得する。
    var nAns = oRN.getAdd(0.9).toString();
  &lt;/script&gt;
  ・
  ・
  ・
</pre>
 *       </font>
 *     </td>
 *   </tr>
 * </table>
 *
 *
 * @version 1.0
 * @since 1.3
 * @author INTRAMART
 */

/**
 * 引数に指定した数値を表す実数オブジェクトのインスタンスを生成します。<br/>
 * <br/>
 *
 * @class 小数演算を可能にするオブジェクト。
 * @constructor
 * @param {Number} nNumber 数値
 *
 * @version 1.0
 * @since 1.3
 * @author INTRAMART
 */
function RealNumber(nNumber) {
    var nReal = parseFloat(nNumber);
    var nABS;
    var aNumber;

    /* check the argument */
    if(isNaN(nReal)){ nReal = 0; }

    /* get absolute number */
    nABS = Math.abs(nReal);

    /* a number to integer and decimal */
    aNumber = nABS.toString().split(".");
    if(aNumber.length == 1){ aNumber[1] = ""; }

    /** @private */
    this.real = nReal;                              /* real number */

    /** @private */
    this.positive = nABS == nReal;                  /* positive flag */

    /** @private */
    this.integral = parseFloat(aNumber[0]);         /* integer place */

    /** @private */
    this.decimal = parseFloat("0" + aNumber[1]);    /* decimal place */

    /** @private */
    this.exp = aNumber[1].length;                   /* length of decimal */

    /** @private */
    this.daughter = RealNumberPrivate;      /* this */

    /** @private */
    this.valueOf = getRealNumberPrivate;    /* changed number return method */

    this.toString = getRealString;          /* changed string return method */
    this.getValue = getRealNumber;          /* return method */
    this.getAdd = getAddNumber;             /* add */
    this.getSub = getSubNumber;             /* subtraction */
    this.getMlt = getMultiplicationNumber;  /* multiplication */
    this.getDiv = getDivisionNumber;        /* division */
}

/**
 * APIリスト整形用
 * @private
 */
var RealNumberPrivate = RealNumber;

/**
 * オブジェクトの持つ数値データを取得します。<br/>
 *
 * @return 数値データ
 * @type Number
 */
function getRealNumber() {
    return this.real;
}

/**
 * APIリスト整形用
 * @private
 */
var getRealNumberPrivate = getRealNumber;

/**
 * オブジェクトの持つ数値データを文字列として取得します。<br/>
 *
 * @return 数値データ（文字列）
 * @type String
 */
function getRealString() {
    return this.real.toString();
}

/**
 * オブジェクトの持つ数値データと加法演算します。<br/>
 * <br/>
 * このオブジェクトのもつ数値と足し算を行います。
 * 返却値は新たなインスタンスを生成して返すので、もとのオブジェクト自体の値は変化しません。
 *
 * @param {Number} nTarget 演算数値
 * @return RealNumber
 * @type RealNumber
 */
function getAddNumber(nTarget) {
    /* make a RealNumber object */
    var rTarget = new this.daughter(nTarget);
    /* decimal check */
    var nExp = Math.pow(10, Math.max(this.exp, rTarget.exp));

    /* add and result return */
    return new this.daughter((Math.round(this.real * nExp) + Math.round(rTarget.real * nExp)) / nExp);
}

/**
 * オブジェクトの持つ数値データと減法演算します。<br/>
 * <br/>
 * このオブジェクトのもつ数値と引き算を行います。
 * 返却値は新たなインスタンスを生成して返すので、もとのオブジェクト自体の値は変化しません。
 *
 * @param {Number} nTarget 演算数値
 * @return RealNumber
 * @type RealNumber
 */
function getSubNumber(nTarget) {
    /* make a RealNumber object */
    var rTarget = new this.daughter(nTarget);
    /* decimal check */
    var nExp = Math.pow(10, Math.max(this.exp, rTarget.exp));

    /* subtraction and result return */
    return new this.daughter((Math.round(this.real * nExp) - Math.round(rTarget.real * nExp)) / nExp);
}

/**
 * オブジェクトの持つ数値データと乗法演算します。<br/>
 * <br/>
 * このオブジェクトのもつ数値と掛け算を行います。
 * 返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しません。
 *
 * @param {Number} nTarget 演算数値
 * @return RealNumber
 * @type RealNumber
 */
function getMultiplicationNumber(nTarget) {
    /* make a RealNumber object */
    var rTarget = new this.daughter(nTarget);
    /* decimal check */
    var nThisExp = Math.pow(10, this.exp)
    var nTargetExp = Math.pow(10, rTarget.exp);

    /* multiplication and result return */
    return new this.daughter((Math.round(this.real * nThisExp) * Math.round(rTarget.real * nTargetExp)) / (nThisExp * nTargetExp));
}

/**
 * オブジェクトの持つ数値データと除法演算します。<br/>
 * <br/>
 * このオブジェクトのもつ数値と割り算を行います。
 * 返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しません。
 *
 * @param {Number} nTarget 演算数値
 * @return RealNumber
 * @type RealNumber
 */
function getDivisionNumber(nTarget) {
    /* make a RealNumber object */
    var rTarget = new this.daughter(nTarget);
    /* decimal check */
    var nExp = Math.pow(10, Math.max(this.exp, rTarget.exp));

    /* division and result return */
    return new this.daughter(Math.round(this.real * nExp) / Math.round(rTarget.real * nExp));
}

/* End of File */
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table.js

概要

ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクトです。

ImSortableTableオブジェクトを利用することで以下が可能となります。

  • Javascriptオブジェクトのデータをテーブル形式で表現可能
  • ソート
  • 行の追加・削除
  • セルのフォーマット指定
  • セルのインライン編集
  • セルの表示書式設定
  • 列幅のリサイズ（ヘッダ部の列の端をマウスでドラッグします） ※１
  • データ部の垂直方向スクロール（ヘッダ部が隠れることなくスクロール可能です） ※１
  • ヘッダ部とデータ部を水平方向に連結スクロール ※１

    • ※１:ImHeaderColumnResizerオブジェクトを利用しています。

    コンストラクタ、および、メソッドの概要は こちら です。
    サンプルコードもご参照ください。

必要なファイル

  • prototype.js

  • im_abstract_self_event_handler.js
  • im_sortable_table.js
  • im_sortable_table_cell.js
  • im_header_column_resizer.js

  • im_sortable_table_cell_header.js
  • im_sortable_table_cell_header_checkbox.js
  • im_sortable_table_cell_text.js
  • im_sortable_table_cell_number.js
  • im_sortable_table_cell_checkbox.js
  • im_sortable_table_cell_radio.js
  • im_sortable_table_cell_image.js

説明

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

Version: 1.0

Author: INTRAMART

クラスの概要
ImSortableTable ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクト。
/**
 * @fileoverview ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクトです。<br/>
 * <br/>
 *
 * ImSortableTableオブジェクトを利用することで以下が可能となります。<br/>
 * 	<ul>
 * 		<li>Javascriptオブジェクトのデータをテーブル形式で表現可能</li>
 * 		<li>ソート</li>
 * 		<li>行の追加・削除</li>
 * 		<li>セルのフォーマット指定</li>
 * 		<li>セルのインライン編集</li>
 * 		<li>セルの表示書式設定</li>
 * 		<li>列幅のリサイズ（ヘッダ部の列の端をマウスでドラッグします）                 <font size="-1"><a href="#notes_1">※１</a></font></li>
 * 		<li>データ部の垂直方向スクロール（ヘッダ部が隠れることなくスクロール可能です） <font size="-1"><a href="#notes_1">※１</a></font></li>
 * 		<li>ヘッダ部とデータ部を水平方向に連結スクロール                               <font size="-1"><a href="#notes_1">※１</a></font></li>
 * 		<br/>
 * 		<font size="-1"><a name='notes_1'>※１:</a><a href="ImHeaderColumnResizer.html">ImHeaderColumnResizerオブジェクト</a>を利用しています。</font>
 * 		<br/>
 * 		<br/>
 * 		コンストラクタ、および、メソッドの概要は<a href="ImSortableTable.html"> <b>こちら</b> </a>です。<br/>
 * 		<a href="ImSortableTable_SUMMARY.html#sampleCode">サンプルコード</a>もご参照ください。
 * 	</ul>
 *
 *
 * <p/>
 * <h4><a name='requireSourceFile'>必要なファイル</a></h4>
 * 	<ul>
 * 		<li>prototype.js</li>
 *		<br/>
 * 		<li>im_abstract_self_event_handler.js</li>
 * 		<li>im_sortable_table.js</li>
 * 		<li>im_sortable_table_cell.js</li>
 * 		<li>im_header_column_resizer.js</li>
 *		<br/>
 * 		<li>im_sortable_table_cell_header.js</li>
 * 		<li>im_sortable_table_cell_header_checkbox.js</li>
 * 		<li>im_sortable_table_cell_text.js</li>
 * 		<li>im_sortable_table_cell_number.js</li>
 * 		<li>im_sortable_table_cell_checkbox.js</li>
 * 		<li>im_sortable_table_cell_radio.js</li>
 * 		<li>im_sortable_table_cell_image.js</li>
 * 	</ul>
 *
 * <p/>
 * <h4><a name='description'>説明</a></h4>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 *
 * <a name="APIListStart"/>
 *
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */

var IM_STBL_CONFIG_KEY = new Object();
    IM_STBL_CONFIG_KEY.ASC  = "ASC";
    IM_STBL_CONFIG_KEY.DESC = "DESC";

var IM_STBL_CONTEXT_PATH;
var IM_STBL_SORT_TARGET_IDX = 0;

var _ImSortableTableBox = new Object();

/**
 * コンストラクタ。<br/>
 * <br/>
 * ImSortableTableオブジェクトは、HTMLページ内のDIV要素を操作し、Sortableテーブルを作成・表示します。<br/>
 * 表示対象のDIV要素は、引数「id」で指定します。<br/>
 * <br/>
 * このコンストラクタの実行後に、生成したインスタンスを取得するには、
 * <a href="#!s!getCachedInstance">getCachedInstance(String)</a>を利用します。
 *
 * @class ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクト。<br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 * @param {String} id  表示対象のDIV要素のID
 * @param {Number} width [option] 幅
 * @param {Number} height [option]  高さ
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */
function ImSortableTable(id, width, height) {

    /**
     * @private
     *
     * CONSTRUCTOR
     */
    this.constructor = function(id, width, height){

        this.firstDispFlg = true;

        this.id        = id;
        this.width     = width;
        this.height    = height;
        this.resizer   = null;

        this.currentPosition = new this.Position(0, 0);

        this.rowSelector = false;
        this.headerTableClassName = "im_sortable_table_header_table";
        this.dataTableClassName   = "im_sortable_table_data_table";

        this.configs = new Array();     // 1 Dimention Array
        this.imSortTableCellBox4Header; // 1 Dimention Array

        this.dataArray = new Array();   // 2 Dimention Array
        this.imSortTableCellBox4Data;   // 2 Dimention Array

        this.isEditing = false;

        _ImSortableTableBox[this.id] = this;

        // prevent memory leaks in IE
        var selfInstance = this;
        Event.observe(window,
                      'unload',
                      function(){
                            var thisObj = selfInstance;
                            var unloadFunc4Header  = thisObj.unloadImSortTableCellBox4Header;
                            var unloadFunc4Data    = thisObj.unloadImSortTableCellBox4Data;
                            var unloadFunc4Resizer = thisObj.unloadImHeaderColumnResizer;

                            unloadFunc4Header.apply(thisObj);
                            unloadFunc4Data.apply(thisObj);
                            unloadFunc4Resizer.apply(thisObj);

                            selfInstance = null;
                            thisObj      = null;
                      },
                      false);

    }

    /**
     * セルクリック時の表示形式の変更範囲を設定します。<br/>
     * <br/>
     * 指定可能な範囲は、行単位、または、セル単位です。<br/>
     * このメソッドを使用しなかった場合、セルクリック時の表示形式は <b>セル単位</b> で変更されます。
     *
     * @param {oolean} rowSelectState セルクリック時の表示形式の変更を <b>行単位</b> で行う場合は true、<br/>
     * 								  セルクリック時の表示形式の変更を <b>セル単位</b> で行う場合は false。
     */
    this.setRowSelector = function(rowSelector){
        this.rowSelector = rowSelector;
    }

    /**
     * @private
     *
     * Setter : RESIZABLE
     */
     this.setResizable = function(isResizable){
         if(this.resizer != undefined && this.resizer != null){
             this.resizer.setResizable(isResizable);
         }
     }

    /**
     * ヘッダ部の&lt;table&gt;タグのCSSクラス名を設定します。<br/>
     * <br/>
     * このメソッドを使用しなかった場合、ヘッダ部の&lt;table&gt;タグのCSSクラス名は
     * 「im_sortable_table_header_table」が使用されます。
     *
     * @param {String} headerTableClassName &lt;table&gt;タグ（ヘッダ部）のCSSクラス名
     */
    this.setHeaderTableClassName = function(headerTableClassName){
        this.headerTableClassName = headerTableClassName;
    }

    /**
     * データ部の&lt;table&gt;タグのCSSクラス名を設定します。<br/>
     * <br/>
     * このメソッドを使用しなかった場合、データ部の&lt;table&gt;タグのCSSクラス名は
     * 「im_sortable_table_data_table」が使用されます。
     *
     * @param {String} dataTableClassName &lt;table&gt;タグ（データ部）のCSSクラス名
     */
    this.setDataTableClassName = function(dataTableClassName){
        this.dataTableClassName = dataTableClassName;
    }

    /**
     * コンフィグオブジェクトを格納した配列を設定します。
     *
     * @param {Array} configs <a href="ImSortableTable_SUMMARY.html#aboutSetConfig">コンフィグオブジェクト</a>を格納した配列
     */
    this.setConfigs = function(configs){
        this.configs = configs;
    }

    /**
     * コンフィグオブジェクトが格納された配列を取得します。
     *
     * @return <a href="ImSortableTable_SUMMARY.html#aboutSetConfig">コンフィグオブジェクト</a>を格納した配列
     * @type Array
     */
    this.getConfigs = function(){
        return this.configs;
    }

    /**
     * @private
     *
     * 2次元配列形式のデータを設定します。<br/>
     * <br/>
     * 「dataArray[行番号][列番号] = オブジェクト」形式の2次元配列で設定します。
     *
     * @param {Array} dataArray 2次元配列形式のデータ
     */
    this.setDataArray = function(dataArray){
        this.dataArray = dataArray;
    }

    /**
     * @private
     *
     * Getter : DATA (ARRAY)
     */
    this.getDataArray = function(){
        return this.dataArray;
    }

    /**
     * データオブジェクトを格納した配列を設定します。<br/>
     * <br/>
     * データオブジェクトのプロパティ名は、
     * コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）で設定した値です。
     *
     * @param {Array} data データオブジェクトを格納した配列
     */
    this.setData = function(data){
        if(!data){
            data = new Array();
        }

        var dataArray = new Array(); // 2 Dimention Array

        var maxRow = data.length;
        for(var rowIdx = 0 ; rowIdx < maxRow ; rowIdx++){

            dataArray[rowIdx] = new Array();

            var maxCol = this.configs.length;
            for(var colIdx = 0 ; colIdx < maxCol ; colIdx++){
                dataArray[rowIdx][colIdx] = data[rowIdx][this.configs[colIdx].id];
            }
        }

        this.dataArray = dataArray;
    }

    /**
     * データオブジェクトが格納された配列を取得します。<br/>
     * <br/>
     * データオブジェクトのプロパティ名は、
     * コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）で設定した値です。
     *
     * @return データオブジェクトを格納した配列
     * @type Array
     */
    this.getData = function(){

        var data = new Array();

        var maxRow = this.dataArray.length;
        for(var rowIdx = 0; rowIdx < maxRow ; rowIdx++){

            data[rowIdx] = new Object();

            var maxCol = this.dataArray[rowIdx].length;
            for(var colIdx = 0 ; colIdx < maxCol ; colIdx++){
                data[rowIdx][this.configs[colIdx].id] = this.dataArray[rowIdx][colIdx];
            }
        }

        return data;
    }

    /**
     * @private
     *
     * 一行分の2次元配列形式データを挿入します。<br/>
     * <br/>
     * 「rowDataArray[行番号][列番号] = オブジェクト」形式の2次元配列で設定します。
     *
     * @param {Array} rowDataArray
     * @param {Number} insertRowIdx [option] 挿入位置の行番号（先頭は 0 行目）。<br/>
     * 								未指定の場合は末尾に追加されます。
     */
    this.addRowDataArray = function(rowDataArray, insertRowIdx){

        if((insertRowIdx != 0)
            &&
            ( !insertRowIdx || insertRowIdx > this.dataArray.length )){
            insertRowIdx = this.dataArray.length;
        }
        else if(insertRowIdx < 0){
            insertRowIdx = 0;
        }

        // Add row data
        this.dataArray.splice(insertRowIdx, 0, rowDataArray);

        // Append new <tr> Node
        this.appendRowElement(insertRowIdx);

        // Initialize header resiser
        this.resizer.initializeTable();
    }

    /**
     * データを一行 挿入します。<br/>
     * <br/>
     * データオブジェクトのプロパティ名は、
     * コンフィグオブジェクトの「id」プロパティ（＝列を識別するためのID）で設定した値です。
     *
     * @param {Object} rowData データオブジェクト
     * @param {Number} insertRowIdx [option] 挿入位置の行番号（先頭は 0 行目）。(省略可能)<br/>
     * 								未指定の場合は末尾に追加されます。
     */
    this.addRowData = function(rowData, insertRowIdx){

        var rowDataArray = new Array();

        var maxCol = this.configs.length;
        for(var colIdx = 0 ; colIdx < maxCol ; colIdx++){
            rowDataArray[colIdx] = rowData[this.configs[colIdx].id];
        }

        this.addRowDataArray(rowDataArray, insertRowIdx);
    }

    /**
     * データを一行 削除します。<br/>
     *
     * @param {Number} removeRowIdx 削除する行番号（先頭は 0 行目）
     */
    this.removeRowData = function(removeRowIdx){
        if(removeRowIdx == undefined || removeRowIdx < 0 || this.dataArray.length - 1 < removeRowIdx ){
            return;
        }
        else {
            // Move position for imSortTableCell instance
            this.movePositionValueForImSortTableCellBox(removeRowIdx, -1, 0);

            // Remove <tr> Node
            var tbodyElem4Data = document.getElementById( ImSortableTable.getID4DataTbody(this.id) );
            var trElem4Data    = this.imSortTableCellBox4Data[removeRowIdx][0].htmlElement.parentNode;
            tbodyElem4Data.removeChild(trElem4Data);

            // Unload imSortTableCell's Element
            for(var colIdx = 0, colMax = this.imSortTableCellBox4Data[removeRowIdx].length; colIdx < colMax; colIdx++){
                var targetCell = this.imSortTableCellBox4Data[removeRowIdx][colIdx];
                if(targetCell){
                    targetCell.unloadChildElements();
                }
            }

            // Remove row data
            this.imSortTableCellBox4Data.splice(removeRowIdx, 1);
            this.dataArray.splice(removeRowIdx, 1);

            // Initialize header resiser
            this.resizer.initializeTable();
        }
    }

    /**
     * 引数で指定された位置のセルオブジェクトを取得します。<br/>
     * <br/>
     * セルオブジェクトとは、ImSortableTableCell4XXXXのインスタンスです。<br/>
     * （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Textのインスタンス））
     *
     * @param {Number} row 行番号（先頭は 0 行目）
     * @param {Number} col 列番号（先頭は 0 列目）
     * @return セルオブジェクト
     * @type Object
     */
    this.getCellObject = function(row, col){
        if(row < 0 || (this.dataArray.length - 1) < row
           ||
           col < 0 || (this.configs.length - 1) < col){

           return null;
        }

        return this.imSortTableCellBox4Data[row][col];
    }

    /**
     * @private
     *
     * Update colmun width
     */
    this.updateColmunWidth = function(colIdx, width){
        return this.resizer.updateHeaderWidth(colIdx, width);
    }

    /**
     * ソートを実行します。<br/>
     * <br/>
     * 一度に実行可能なソートは一つだけです。
     * （他の列のソートが行われている場合、この関数で指定した列のソートを行うことは出来ません。
     *
     * @param {Number} colIdx ソートを実行する列番号（先頭は 0 列目）
     * @param {String} sortDirection [option] ソート方向。（省略した場合は、colIdxで指定された列に設定されているソート方向）<br/>
     * 									昇順の場合：IM_STBL_CONFIG_KEY.ASC  <br/>
     * 									降順の場合：IM_STBL_CONFIG_KEY.DESC <br/>
     */
    this.sort = function(colIdx, sortDirection){
        if(colIdx < 0 || (this.configs.length - 1) < colIdx
          ||
          this.configs[colIdx].visible == false || this.configs[colIdx].sortable == false ){
           return;
        }

        // processing sort now?
        if(this.isSorting == true){
            return;
        }

        var backupSortDirection;
        var targetHeader = this.imSortTableCellBox4Header[colIdx];

        if(sortDirection == IM_STBL_CONFIG_KEY.ASC || sortDirection == IM_STBL_CONFIG_KEY.DESC){
            backupSortDirection = targetHeader.config.sorter.sortDirection;

            // Set sort direction for target header.
            targetHeader.config.sorter.sortDirection = sortDirection;
        }

        // Get sort function
        var sortFunction;
        if(targetHeader.config.sorter.sortDirection == IM_STBL_CONFIG_KEY.ASC){
            sortFunction = targetHeader.config.sorter.ascFunction;
        }
        else{
            sortFunction = targetHeader.config.sorter.descFunction;
        }

        // (Unsupported)
        if(typeof(sortFunction) != "function"){
            targetHeader.config.sorter.sortDirection = backupSortDirection;
            return;
        }

        // ==== START ====
        this.isSorting = true;

        // Set sort target colmun index
        IM_STBL_SORT_TARGET_IDX = colIdx;

        // Sorting!
        this.dataArray.sort(sortFunction);
        this.display();

        // ====  END  ====
        this.resetHeaderSortImg(colIdx);
        targetHeader.reverseSortDirection();
        this.isSorting = false;

        return;
    }
    /** @private */
    this.isSorting = false; // processing sort flag

    /**
     * 次回の<a href="#display">display()</a>実行時、ヘッダー部分も再描画します。
     */
    this.setRedrawHeader = function(){
        this.firstDispFlg = true;
    }

    /**
     * Sortableテーブルを表示します。<br/>
     * <br/>
     * 現在設定されているコンフィグ および データを元にSortableテーブルを表示します。
     */
    this.display = function(){

        if(this.firstDispFlg == true){

            // UNLOAD imSortTableCellBox4Header PROPERTY
            this.unloadImSortTableCellBox4Header();

            // Prevent not to scroll when redrawing sortable table.
            var divElement = document.getElementById(this.id);
            var preventScrollDivElem = document.createElement("div");
            preventScrollDivElem.style.width  = divElement.offsetWidth;
            preventScrollDivElem.style.height = divElement.offsetHeight;
            divElement.appendChild(preventScrollDivElem);

            // INITIALIZE TARGET DIV ELEMENT
            while(divElement.hasChildNodes() && (divElement.firstChild != preventScrollDivElem) ){
                divElement.removeChild(divElement.firstChild);
            }

            // CREATE TABLE ELEMENT
            this.createTableElememt4Header();
            this.createTableElement4Data();
        }

        // HIDE TBODY (for DATA)
        var tbodyElem4Data = $(ImSortableTable.getID4DataTbody(this.id));
        tbodyElem4Data.hide();

        // UNLOAD imSortTableCellBox4Data PROPERTY
        this.unloadImSortTableCellBox4Data();

        // INITIALIZE TBODY (for DATA)
        while(tbodyElem4Data.hasChildNodes()){
            tbodyElem4Data.removeChild(tbodyElem4Data.firstChild);
        }

        // CREATE DATA CELL
        this.imSortTableCellBox4Data = new Array();

        for(var rowIdx = 0, maxRow = this.dataArray.length; rowIdx < maxRow ; rowIdx++){

            // Append new <tr> element
            var trElem4Data = document.createElement("tr");
            // trElem4Data.id = ImSortableTable.getID4DataRow(this.id, rowIdx);  // Comment out (for performance improvement)
            tbodyElem4Data.appendChild(trElem4Data);

            // Create cell
            this.imSortTableCellBox4Data[rowIdx] = new Array();
            this.createTdElements4Data(rowIdx, trElem4Data);

        }

        // SHOW TBODY (for DATA)
        tbodyElem4Data.show();

        if(this.firstDispFlg == true){

            // SET RESIZER
            this.resizer = new ImHeaderColumnResizer(ImSortableTable.getID4HeaderTable(this.id),
                                                    ImSortableTable.getID4DataTable(this.id),
                                                    this.width,
                                                    this.height);
            // Toggle firstDispFlg
            this.firstDispFlg = false;
        }
        else{
            this.resizer.initializeTable();
            this.resetHeaderSortImg(-1);
        }

        // Remove preventScrollDivElem
        if(divElement && preventScrollDivElem){
            divElement.removeChild(preventScrollDivElem);
        }
    }

    /**
     * @private
     *
     * CREATE TABLE ELEMENT (for HEADER)
     * This function must be execute after setConfigs().
     */
    this.createTableElememt4Header = function(){

        if(!this.configs[0]){
            throw new Error("ImSortableTable.createTableElememt4Header() must be execute after setConfigs().");
        }

        var rowIdx = 0;

        // =======================
        // HEADER
        // =======================
        var tableElem4Header = document.createElement("table");
        tableElem4Header.id = ImSortableTable.getID4HeaderTable(this.id);
        tableElem4Header.className = this.headerTableClassName;

        var tbodyElem4Header = document.createElement("tbody");
        tbodyElem4Header.id = ImSortableTable.getID4HeaderTbody(this.id);

        var trElem4Header = document.createElement("tr");
        trElem4Header.id = ImSortableTable.getID4HeaderRow(this.id, rowIdx);

        var divElement = document.getElementById(this.id);
        divElement.appendChild(tableElem4Header);
        tableElem4Header.appendChild(tbodyElem4Header);
        tbodyElem4Header.appendChild(trElem4Header);

        this.imSortTableCellBox4Header = new Array();
        for(var colIdx = 0, colMax = this.configs.length; colIdx < colMax; colIdx++){

            if(this.configs[colIdx].visible == false){
                continue;
            }
            else{
                var tdElem4Header = document.createElement("td");
                tdElem4Header.id = ImSortableTable.getID4HeaderCell(this.id, rowIdx, colIdx);
                tdElem4Header.className = this.configs[colIdx].header.className;
                tdElem4Header.setAttribute("width",   this.configs[colIdx].width);
                tdElem4Header.setAttribute("height",  this.configs[colIdx].header.height);

                // Create Header Cell
                this.imSortTableCellBox4Header[colIdx] = this.createImSortTableCell4Header(rowIdx, colIdx, tdElem4Header);
                trElem4Header.appendChild(tdElem4Header);
                this.imSortTableCellBox4Header[colIdx].appendChildElements();
            }

        }
    }

    /**
     * @private
     *
     * CREATE TABLE ELEMENT (for DATA)
     * This function must be execute after setConfigs().
     */
    this.createTableElement4Data = function(){
        // =======================
        // DATA
        // =======================
        var tableElem4Data = document.createElement("table");
        tableElem4Data.id = ImSortableTable.getID4DataTable(this.id);
        tableElem4Data.className = this.dataTableClassName;

        var tbodyElem4Data = document.createElement("tbody");
        tbodyElem4Data.id = ImSortableTable.getID4DataTbody(this.id);

        var divElement = document.getElementById(this.id);
        divElement.appendChild(tableElem4Data);
        tableElem4Data.appendChild(tbodyElem4Data);
    }

    /**
     * @private
     *
     * CREATE TD ELEMENT (for DATA)
     */
    this.createTdElements4Data = function(rowIdx, trElememnt){
        for(var colIdx = 0, maxCol = this.dataArray[rowIdx].length; colIdx < maxCol; colIdx++){

            if(this.configs[colIdx].visible == false){
                continue;
            }
            else {
                var tdElem4Data;
                var elemId        = ImSortableTable.getID4DataCell(this.id, rowIdx, colIdx);
                var elemHeight    = this.configs[colIdx].data.height;
                var elemClassName = (rowIdx % 2 == 0) ? this.configs[colIdx].data.evenClassName
                                                      : this.configs[colIdx].data.oddClassName;

                if(ImSortableTable.Browser.IE){
                    tdElem4Data = document.createElement('<td id="'     + elemId        + '" ' +
                                                             'class="'  + elemClassName + '" ' +
                                                             'height="' + elemHeight    + '">');
                }
                else{
                    // Append new <td> element
                    tdElem4Data = document.createElement("td");
                    tdElem4Data.id        = elemId;
                    tdElem4Data.height    = elemHeight;
                    tdElem4Data.className = elemClassName;
                }

                // Create Data Cell
                this.imSortTableCellBox4Data[rowIdx][colIdx] = this.createImSortTableCell4Data(rowIdx, colIdx, tdElem4Data);
                trElememnt.appendChild(tdElem4Data);
                this.imSortTableCellBox4Data[rowIdx][colIdx].appendChildElements();
            }
        }
    }

    /**
     * @private
     *
     * Append new RowData
     */
    this.appendRowElement = function(insertRowIdx){

        // Move position for imSortTableCell (in ImSortTableCellBox)
        this.movePositionValueForImSortTableCellBox(insertRowIdx, 1, 0);

        // Append new <tr> element
        var newTrElem = document.createElement("tr");
        // newTrElem.id = ImSortableTable.getID4DataRow(this.id, insertRowIdx);   // Comment out (for performance improvement)

        var tbodyElem4Data = document.getElementById(ImSortableTable.getID4DataTbody(this.id));

        if(insertRowIdx < this.imSortTableCellBox4Data.length){
            var trElem4DataRefChild = this.imSortTableCellBox4Data[insertRowIdx][0].htmlElement.parentNode;
            tbodyElem4Data.insertBefore(newTrElem, trElem4DataRefChild);
        }
        else{
            tbodyElem4Data.appendChild(newTrElem);
        }

        // Add row data
        this.imSortTableCellBox4Data.splice(insertRowIdx, 0, new Array());
        this.createTdElements4Data(insertRowIdx, newTrElem);
    }

    /**
     * @private
     *
     * Move position for imSortTableCell instance
     */
    this.movePositionValueForImSortTableCellBox = function(startRowIdx, rowDelta, colDelta){
        var maxRow = this.imSortTableCellBox4Data.length;
        for(var rowIdx = startRowIdx ; rowIdx < maxRow; rowIdx++){

            // var trElem4Data;            // Comment out (for performance improvement)
            // var trElem4DataRowPosition; // Comment out (for performance improvement)

            var maxCol = this.imSortTableCellBox4Data[rowIdx].length;
            for(var colIdx = 0 ; colIdx < maxCol; colIdx++){

                var imSortTableCell = this.imSortTableCellBox4Data[rowIdx][colIdx];
                if(imSortTableCell != null && imSortTableCell != undefined){

                    // Move position
                    imSortTableCell.movePosition(rowDelta, colDelta);

                    // trElem4Data            = imSortTableCell.htmlElement.parentNode;  // Comment out (for performance improvement)
                    // trElem4DataRowPosition = imSortTableCell.position.row;            // Comment out (for performance improvement)
                }

            }

            // // Refresh ID for <tr> element.
            // trElem4Data.id = ImSortableTable.getID4DataRow(this.id, trElem4DataRowPosition + rowDelta); // Comment out (for performance improvement)
        }
    }

    /**
     * @private
     *
     * CREATE CELL (for HEADER)
     */
    this.createImSortTableCell4Header = function(rowIdx, colIdx, htmlElement){
        var instance = null;

        var observer = this;
        var position = new this.Position(rowIdx, colIdx);
        var config   = this.configs[colIdx];

        switch(this.configs[colIdx].type){
            case "checkbox":
                instance = new ImSortableTableCell4HeaderCheckbox(observer, htmlElement, position, config);
                break;

            default :
                instance = new ImSortableTableCell4Header        (observer, htmlElement, position, config);
                break;
        }

        return instance;

    }

    /**
     * @private
     *
     * CREATE CELL (for DATA)
     */
    this.createImSortTableCell4Data = function(rowIdx, colIdx, htmlElement){

        var instance = null;

        var observer = this;
        var position = new this.Position(rowIdx, colIdx);
        var config   = this.configs[colIdx];
        var data     = this.dataArray[rowIdx][colIdx];

        switch(this.configs[colIdx].type){
            case "checkbox":
                instance = new ImSortableTableCell4Checkbox(observer, htmlElement, position, config, data);
                break;

            case "radio":
                instance = new ImSortableTableCell4Radio   (observer, htmlElement, position, config, data);
                break;

            case "image":
                instance = new ImSortableTableCell4Image   (observer, htmlElement, position, config, data);
                break;

            case "text":
                instance = new ImSortableTableCell4Text    (observer, htmlElement, position, config, data);
                break;

            case "number":
                instance = new ImSortableTableCell4Number  (observer, htmlElement, position, config, data);
                break;

            default:
                break;
        }

        return instance;
    }

    /**
     * @private
     *
     */
    this.resetHeaderSortImg = function(exceptColIdx){
        for(var idx = 0, maxCol = this.imSortTableCellBox4Header.length ; idx < maxCol ; idx++){
            if(idx != exceptColIdx
               &&
               this.configs[idx].visible == true
               &&
               this.configs[idx].sortable == true){

                this.imSortTableCellBox4Header[idx].changeDefaultSortImage();
            }
        }
    }

    /**
     * @private
     *
     * (This function is used by ImSortableTableCell class and sub classes.)
     */
    this.setCurrentPosition = function(event, position){
        var previousPosition = this.currentPosition;
        this.currentPosition = position;

        // mouseout event
        if(this.imSortTableCellBox4Data[previousPosition.row]){
            var targetCell = this.imSortTableCellBox4Data[previousPosition.row][previousPosition.col];
            var func = targetCell.handleEventSpecifiedEventType;
            func.call(targetCell, event, "mouseout");
        }
    }

    /**
     * @private
     *
     * (This function is used by ImSortableTableCell class and sub classes.)
     */
    this.updateCellData = function(position, data){
        this.dataArray[position.row][position.col] = data;
    }

    /**
     * ラジオボタンをチェック状態にします。<br/>
     * <br/>
     * 引数で指定された位置に表示されているラジオボタンをチェック状態にします。<br/>
     * 該当セルのフォーマットタイプがラジオボタンではない場合、このメソッドは何も行いません。<br/>
     * <br/>
     * ポジションオブジェクトの構成は以下の通りです。
     * <table border="1">
     * 	<tr>
     * 		<th>プロパティ (型)</th><th>説明</th>
     * 	</tr>
     * 	<tr>
     * 		<td><b>row</b> <br/> (Number)</td><td>セルの行番号（先頭は 0 行目）</td>
     * 	</tr>
     * 	<tr>
     * 		<td><b>col</b> <br/> (Number)</td><td>セルの列番号（先頭は 0 列目）</td>
     * 	</tr>
     * </table>
     *
     * @param {Object} position チェック状態にするラジオボタンの位置情報を格納したポジションオブジェクト
     */
    this.setCheckedRadioPosition = function(position){
        var onChangeRowIdx = position.row;
        var onChangeColIdx = position.col;

        var maxRow = this.imSortTableCellBox4Data.length;
        for(var rowIdx = 0; rowIdx < maxRow ; rowIdx++){

            var targetCell = this.imSortTableCellBox4Data[rowIdx][onChangeColIdx];

            // first access
            if(!targetCell){
                continue;
            }

            if(targetCell.controlType != "radio"){
                return;
            }

            var func = targetCell.updateCheckedStatus;

            if(func && ( typeof(func) == "function") ){
                if(rowIdx == onChangeRowIdx){
                    func.call(targetCell, true);
                }
                else{
                    func.call(targetCell, false);
                }
            }
        }
    }

    /**
     * @private
     *
     * (This function is only used by ControlType "headerCheckbox" Cell.)
     */
    this.setCheckedStatusToSameAsHeader = function(position, checkedValue){

        var colIdx = position.col;
        var maxRow = this.imSortTableCellBox4Data.length;

        for(var rowIdx = 0 ; rowIdx < maxRow ; rowIdx++){
            var targetCell = this.imSortTableCellBox4Data[rowIdx][colIdx];
            var func = targetCell.updateCheckedStatus;
            func.call(targetCell, checkedValue);
        }

    }

    /**
     * @private
     *
     * (This function is used by ImSortableTableCell class and sub classes.)
     */
    this.isSelectedPosition = function(position){
        return this.currentPosition.equals(position);
    }

    /**
     * @private
     *
     * ポジションオブジェクト
     */
    this.Position = function(row, col){
        this.row = row;
        this.col = col;

        this.equals = function(position){
            if(this.row == position.row && this.col == position.col) {
                return true;
            }
            else {
                return false;
            }
        }
    }

    /**
     * @private
     *
     * UNLOAD imSortTableCellBox4Header PROPERTY
     */
    this.unloadImSortTableCellBox4Header = function(){
        if(this.imSortTableCellBox4Header){
            for(var rowIdx = 0, maxRow = this.imSortTableCellBox4Header.length; rowIdx < maxRow ; rowIdx++){
                if(this.imSortTableCellBox4Header[rowIdx]){
                    this.imSortTableCellBox4Header[rowIdx].unloadChildElements();
                    this.imSortTableCellBox4Header[rowIdx] = null;
                }
            }
            this.imSortTableCellBox4Header = null;
        }
    }

    /**
     * @private
     *
     * UNLOAD imSortTableCellBox4Data PROPERTY
     */
    this.unloadImSortTableCellBox4Data = function(){
        if(this.imSortTableCellBox4Data){
            for(var rowIdx = 0, maxRow = this.imSortTableCellBox4Data.length; rowIdx < maxRow ; rowIdx++){
                for(var colIdx = 0, maxCol = this.imSortTableCellBox4Data[rowIdx].length; colIdx < maxCol; colIdx++){
                    if(this.imSortTableCellBox4Data[rowIdx][colIdx]){
                        this.imSortTableCellBox4Data[rowIdx][colIdx].unloadChildElements();
                        this.imSortTableCellBox4Data[rowIdx][colIdx] = null;
                    }
                }
            }
            this.imSortTableCellBox4Data = null;
        }
    }

    /**
     * @private
     *
     * UNLOAD ImHeaderColumnResizer PROPERTY
     */
    this.unloadImHeaderColumnResizer = function(){
        if(this.resizer){
            this.resizer.unloadChildElements();
            this.resizer = null;
        }
    }

    // Construct instance
    this.constructor(id, width, height);

}

/**
 * キャッシュされた ImSortableTable のインスタンスを取得します。<br/>
 * <br/>
 *
 * @param {String} id <a href="#ImSortableTable()">コンストラクタ</a>で指定したid
 * @return ImSortableTableのインスタンス。引数「id」に紐づくImSortableTableオブジェクトが作成されていない場合は、null。
 * @type ImSortableTable
 */
ImSortableTable.getCachedInstance = function(id) {
    var cachedInstance = _ImSortableTableBox[id];
    return typeof(cachedInstance) == "undefined" ? null : cachedInstance;
}

/**
 * コンテキストパスを取得します。
 *
 * @return コンテキストパス
 * @type String
 */
ImSortableTable.getContextPath = function(){
    var url = document.URL;
    var domain = document.domain;

    var strUrlMinusDomain = url.substring(url.indexOf(domain) + domain.length);

    var firstSlashIdx = strUrlMinusDomain.indexOf("/");
    var secondSlashIdx = strUrlMinusDomain.indexOf("/", firstSlashIdx + 1);

    if(firstSlashIdx == -1){
        return "";
    }
    else if(secondSlashIdx == -1){
        return strUrlMinusDomain.substring(firstSlashIdx);
    }
    else{
        return strUrlMinusDomain.substring(firstSlashIdx, secondSlashIdx);
    }
}
IM_STBL_CONTEXT_PATH = ImSortableTable.getContextPath(); // Set Context Path

/**
 * @private
 */
ImSortableTable.Browser = {
    IE:     !!(window.attachEvent && !window.opera)
}

/**
 * @private
 */
ImSortableTable.getID4HeaderTable = function(id){
    return id + "_TABLE_4_HEADER";
}

/**
 * @private
 */
ImSortableTable.getID4HeaderTbody = function(id){
    return id + "_TBODY_4_HEADER";
}

/**
 * @private
 */
ImSortableTable.getID4HeaderRow = function(id, row){
    return id + "_HEADER_ROW" + "__" + row + "__";
}

/**
 * @private
 */
ImSortableTable.getID4HeaderCell = function(id, row, col){
    return id + "_HEADER_CELL" + "__" + row + "_" + col + "__";
}

/**
 * @private
 */
ImSortableTable.getID4DataTable = function(id){
    return id + "_TABLE_4_DATA";
}

/**
 * @private
 */
ImSortableTable.getID4DataTbody = function(id){
    return id + "_TBODY_4_DATA";
}

/**
 * @private
 */
ImSortableTable.getID4DataRow = function(id, row){
    return id + "_DATA_ROW" + "__" + row + "__";
}

/**
 * @private
 */
ImSortableTable.getID4DataCell = function(id, row, col){
    return id + "_DATA_CELL" + "__" + row + "_" + col + "__";
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table_cell.js

概要

ImSortableTableのセルオブジェクトです。

セルのフォーマット毎に具象オブジェクトが用意されています。
詳しくは、サブクラスの説明を参照してください。

ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、こちらを参照してください。

クラスの概要
ImSortableTableCell ImSortableTableのセルオブジェクトです。
/**
 * @fileoverview ImSortableTableのセルオブジェクトです。<br/>
 * <br/>
 * セルのフォーマット毎に具象オブジェクトが用意されています。<br/>
 * 詳しくは、サブクラスの説明を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 */

var IM_STBL_CELL_STATE = new Object();
    IM_STBL_CELL_STATE.UN_SELECT = "Unselect";
    IM_STBL_CELL_STATE.SELECT    = "Select";
    IM_STBL_CELL_STATE.EDIT      = "Edit";

var IM_STBL_CELL_HEADER_DEFAULT_IMG = IM_STBL_CONTEXT_PATH + "/images/sortable_table/blank.gif";
var IM_STBL_CELL_SORT_ASC_IMG       = IM_STBL_CONTEXT_PATH + "/images/sortable_table/up.gif";
var IM_STBL_CELL_SORT_DESC_IMG      = IM_STBL_CONTEXT_PATH + "/images/sortable_table/down.gif";
var IM_STBL_CELL_SORT_DEFAULT_IMG   = IM_STBL_CONTEXT_PATH + "/images/sortable_table/blank.gif";

ImSortableTableCell.prototype = new ImAbstractSelfEventHandler();

/**
 * コンストラクタ。<br/>
 * <br/>
 * <i>開発者が明示的にこのコンストラクタを利用する必要はありません。</i>
 *
 * @class ImSortableTableのセルオブジェクトです。<br/>
 * <br/>
 * セルのフォーマット毎に具象オブジェクトが用意されています。<br/>
 * 詳しくは、サブクラスの説明を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 */
function ImSortableTableCell() {

    /** @private */
    this.initialState = IM_STBL_CELL_STATE.UN_SELECT;

    this.observer;    //@abstract
    this.htmlElement; //@abstract
    this.position;    //@abstract
    this.config;      //@abstract
    this.data;        //@abstract

    this.beforeTriggers; //@abstract
    this.afterTriggers;  //@abstract

    /**
     * @private
     * @abstract
     */
    this.appendChildElements = function(){
        return false;
    }

    /**
     * @private
     * @abstract
     * (prevent memory leaks in IE)
     */
    this.unloadChildElements = function(){
        return false;
    }

    /**
     * ImSortableTableのインスタンスを取得します。
     *
     * @return ImSortableTableのインスタンス
     * @type ImSortableTable
     */
    this.getObserver = function(){
        return this.observer;
    }

    /**
     * セルの位置情報を格納したポジションオブジェクトを取得します。<br/>
     * <br/>
     * ポジションオブジェクトの構成は以下の通りです。
     * <table border="1">
     * 	<tr>
     * 		<th>プロパティ (型)</th><th>説明</th>
     * 	</tr>
     * 	<tr>
     * 		<td><b>row</b> <br/> (Number)</td><td>セルの行番号（先頭は 0 行目）</td>
     * 	</tr>
     * 	<tr>
     * 		<td><b>col</b> <br/> (Number)</td><td>セルの列番号（先頭は 0 列目）</td>
     * 	</tr>
     * </table>
     *
     * @return セルの位置情報を格納したポジションオブジェクト
     * @type Object
     */
    this.getPosition = function(){
        return this.position;
    }

    /**
     * セルのコンフィグオブジェクトを取得します。<br/>
     *
     * @return ImSortableTableCell4XXXXのコンフィグオブジェクト<br/>
     * （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Text））<br/>
     * <br/>
     * コンフィグオブジェクトの構成は、セルのフォーマットによって異なります。<br/>
     * <table border="1">
     * 	<tr>
     * 		<th>フォーマット</th>
     * 		<th>コンフィグオブジェクトの構成</th>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">テキスト</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_text.js.html#ConfigObject">ImSortableTableCell4Textオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">数値</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_number.js.html#ConfigObject">ImSortableTableCell4Numberオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">チェックボックス</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_checkbox.js.html#ConfigObject">ImSortableTableCell4Checkboxオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">ラジオボタン</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_radio.js.html#ConfigObject">ImSortableTableCell4Radioオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">イメージ</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_image.js.html#ConfigObject">ImSortableTableCell4Imageオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * </table>
     *
     * @type Object
     */
    this.getConfig = function(){
        return this.config;
    }

    /**
     * セルの値を取得します。<br/>
     * <br/>
     * セルのフォーマットによって、返却される値が異なります。
     * <table border="1">
     * 	<tr>
     * 		<th>フォーマット</th>
     * 		<th>返却値の型</th>
     * 		<th>説明</th>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">テキスト</td>
     * 		<td>String</td>
     * 		<td>
     * 			このメソッドで取得した値と、セルに表示されている値は異なる場合があります。<br/>
     * 			このメソッドで取得した値は、
     * 			<a href="overview-summary-im_sortable_table_cell_text.js.html#ConfigObject">テキスト用コンフィグオブジェクト</a>の
     * 			「formatter」関数を実行する前の値です。
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">数値</td>
     * 		<td>Number</td>
     * 		<td>
     * 			このメソッドで取得した値と、セルに表示されている値は異なる場合があります。<br/>
     * 			このメソッドで取得した値は、
     * 			<a href="overview-summary-im_sortable_table_cell_number.js.html#ConfigObject">数値用コンフィグオブジェクト</a>の
     * 			「formatter」関数を実行する前の値です。
     *		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">チェックボックス</td>
     * 		<td>Boolean</td>
     * 		<td>チェック状態の場合は true、非チェック状態の場合は false。</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">ラジオボタン</td>
     * 		<td>Boolean</td>
     * 		<td>チェック状態の場合は true、非チェック状態の場合は false。 </td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">イメージ</td>
     * 		<td>Object</td>
     * 		<td>このセルの値。</td>
     * 	</tr>
     * </table>
     *
     * @return セルの値
     * @type Object
     */
    this.getCellData = function(){
        return this.data;
    }

    /**
     * セルのコンフィグオブジェクトを設定します。<br/>
     *
     * @param {Object} config ImSortableTableCell4XXXXのコンフィグオブジェクト<br/>
     * （「XXXX」は、セルのフォーマットタイプです。（例.ImSortableTableCell4Text））<br/>
     * <br/>
     * コンフィグオブジェクトの構成は、セルのフォーマットによって異なります。<br/>
     * <table border="1">
     * 	<tr>
     * 		<th>フォーマット</th>
     * 		<th>コンフィグオブジェクトの構成</th>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">テキスト</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_text.js.html#ConfigObject">ImSortableTableCell4Textオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">数値</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_number.js.html#ConfigObject">ImSortableTableCell4Numberオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">チェックボックス</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_checkbox.js.html#ConfigObject">ImSortableTableCell4Checkboxオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">ラジオボタン</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_radio.js.html#ConfigObject">ImSortableTableCell4Radioオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">イメージ</td>
     * 		<td>
     *			<a href="overview-summary-im_sortable_table_cell_image.js.html#ConfigObject">ImSortableTableCell4Imageオブジェクト</a>
     * 			を参照
     * 		</td>
     * 	</tr>
     * </table>
     */
    this.setConfig = function(config){
        this.config = config;
    }

    /**
     * セルデータを更新します。<br/>
     * <br/>
     * このメソッドは、このインスタンスが保持しているデータと、
     * ImSortableTableオブジェクトで保持しているデータを更新します。<br/>
     * <br/>
     * 以下のフォーマットの場合、このメソッド利用する際に注意が必要です。
     * <table border="1">
     * 	<tr>
     * 		<th>フォーマット</th>
     * 		<th>注意点</th>
     * 	</tr>
     *  <!--
     * 		<tr>
     * 			<td align="center">テキスト</td>
     * 			<td></td>
     * 		</tr>
     * 		<tr>
     * 			<td align="center">数値</td>
     * 			<td></td>
     * 		</tr>
     *  -->
     * 	<tr>
     * 		<td align="center">チェックボックス</td>
     * 		<td>
     * 			表示されているチェックボックスのチェック状態を変更するには、
     * 			<a href="ImSortableTableCell4Checkbox.html#revreseCheckedStatus">ImSortableTableCell4Checkbox#revreseCheckedStatus()</a> または、
     * 			<a href="ImSortableTableCell4Checkbox.html#updateCheckedStatus">ImSortableTableCell4Checkbox#updateCheckedStatus(Boolean checkedStatus)</a>
     * 			を利用してください。
     *      </td>
     * 	</tr>
     * 	<tr>
     * 		<td align="center">ラジオボタン</td>
     * 		<td>
     * 			表示されているラジオボタンのチェック状態を変更するには、
     * 			<a href="ImSortableTable.html#setCheckedRadioPosition">ImSortableTable#setCheckedRadioPosition(Object position)</a>
     * 			を利用してください。
     * 		</td>
     * 	</tr>
     *  <!--
     * 		<tr>
     * 			<td align="center">イメージ</td>
     * 			<td></td>
     * 		</tr>
     *  -->
     * </table>
     *
     * @param {Object} data データ
     */
    this.updateCellData = function(data){
        this.data = data;
        this.observer.updateCellData(this.position, this.data);
    }

    /**
     * 引数「superObject」のプロパティを、引数「overrideObject」のプロパティで上書きます。<br/>
     * <br/>
     * プロパティ値がObjectの場合、このメソッドが再帰的に呼び出されます。<br/>
     * プロパティ値が配列の場合、配列の先頭要素から順番に上書きされます。<br/>
     *
     * @param {Object} superObject 上書き対象オブジェクト
     * @param {Object} overrideObject 上書きするプロパティを保持したオブジェクト
     * @return 上書き後のオブジェクト
     * @type Object
     */
    this.overrideProperty = function(superObject, overrideObject){
        for(var prop in overrideObject){
            if(overrideObject.hasOwnProperty(prop)){
                if(superObject[prop] && overrideObject[prop] && typeof(overrideObject[prop]) == "object"){
                    superObject[prop] = this.overrideProperty(superObject[prop], overrideObject[prop]);
                }
                else{
                    superObject[prop] = overrideObject[prop];
                }
            }
        }
        return superObject;
    }

    /**
     * @private
     * @override
     */
    this.isHandleEventAvailable = function(event, eventType){

        var flg = true;

        if( this.observer.isEditing == true
            &&
            !this.observer.isSelectedPosition(this.position) ) {

            if(eventType == "click"){
                var currentPos = this.observer.currentPosition;
                var targetCell = this.observer.imSortTableCellBox4Data[currentPos.row][currentPos.col];
                targetCell.handleEventSpecifiedEventType(event, "completeEdit");
            }

            flg = false;
        }

        return flg;
    }

    /**
     * @private
     */
    this.movePosition = function(rowDelta, colDelta){

        rowDelta = (!rowDelta) ? 0 : rowDelta;
        colDelta = (!colDelta) ? 0 : colDelta;

        // Change position
        this.position.row = this.position.row + rowDelta;
        this.position.col = this.position.col + colDelta;

        // Change id for element
        this.htmlElement.id = ImSortableTable.getID4DataCell(this.observer.id, this.position.row, this.position.col);

        // Change id for child element
        var childElem = this.htmlElement.firstChild;
        if(childElem){
            childElem.id  = this.htmlElement.id + this.controlType;
        }

        // Set Zebra Color ClassName
        this.setZebraColorClassName(this.htmlElement, this.config);

    }

    /**
     * @private
     */
    this.changeStyle2Selected = function(event){
        if(this.observer.rowSelector == false){
            this.htmlElement.className = this.config.data.selectedClassName;
        }
        else{
            var cellBox = this.observer.imSortTableCellBox4Data[this.position.row];
            var maxCol = cellBox.length;
            for(var colIdx = 0 ; colIdx < maxCol ; colIdx++){
                var targetCell = cellBox[colIdx];
                if(targetCell){
                    targetCell.htmlElement.className = targetCell.config.data.selectedClassName;
                }
            }
        }
    }

    /**
     * @private
     */
    this.changeStyle2Unselected = function(event){
        if(this.observer.rowSelector == false){
            this.setZebraColorClassName(this.htmlElement, this.config);
        }
        else{
            var cellBox = this.observer.imSortTableCellBox4Data[this.position.row];
            var maxCol = cellBox.length;
            for(var colIdx = 0 ; colIdx < maxCol ; colIdx++){
                var targetCell = cellBox[colIdx];
                if(targetCell){
                    this.setZebraColorClassName(targetCell.htmlElement, targetCell.config);
                }
            }
        }
    }

    /**
     * @private
     */
    this.setZebraColorClassName = function(element, config){
        if(this.position.row % 2 == 0){
            element.className = config.data.evenClassName;
        }
        else{
            element.className = config.data.oddClassName;
        }
    }

}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table_cell_checkbox.js

概要

ImSortableTableのチェックボックス用セルオブジェクトです。

  • コンフィグオブジェクトの構成
  • 「状態」と「イベントタイプ」の関係
  • メソッドの概要

コンフィグオブジェクトの構成

ImSortableTableのコンフィグオブジェクト（チェックボックス用）の構成は以下の通りです。
プロパティ (型) |  | 説明 | 必須
type (String) |  | 列のフォーマットタイプ。 チェックボックスの場合は、文字列「checkbox」固定です。 | Yes (文字列「checkbox」を指定してください)
id (String) |  | 列を識別するためのID。 このIDが、データセット時のオブジェクトのプロパティ名となります。 | Yes
name (String) |  | 使用されません。 チェックボックスの場合、ヘッダにはチェックボックスが表示されます。 ヘッダに表示されるチェックボックスをクリックすると、 クリック後のチェック状態が同じ列のチェックボックスに反映されます。 | -
width (Number) |  | 列の幅 | No デフォルトは 未設定
visible (Boolean) |  | 列の表示・非表示。 trueの場合 ：列を表示 falseの場合：列を非表示 なお、列を非表示にした場合でも、データの取得は可能です。 例えば、「コード」と「名前」を保持するオブジェクトに関して、 「名前」だけを表示するSortableテーブルを作成した際、 ImSortableTable#getData()で取得できるデータには、非表示である「コード」も含まれます。 | No デフォルトは true
sortable (Boolean) |  | ソートの可・不可。 trueの場合 ：ソート可能 falseの場合：ソート不可 | No デフォルトは true
sorter (Object) | sortDirection (String) | ヘッダの初回クリック時のソート方向。 （ヘッダをクリックするごとに、この値は反転します） この値は以下の定数で指定してください。 昇順の場合：IM_STBL_CONFIG_KEY.ASC 降順の場合：IM_STBL_CONFIG_KEY.DESC | No デフォルトは IM_STBL_CONFIG_KEY.ASC
 | ascFunction (Function) | 昇順ソート時のソート関数 | No デフォルトは 真偽値の昇順ソート関数
 | descFunction (Function) | 降順ソート時のソート関数 | No デフォルトは 真偽値の降順ソート関数
 | ascImage (String) | 昇順ソート後、ヘッダに表示される画像のURL | No デフォルトは 上向き矢印画像のURL
 | descImage (String) | 降順ソート後、ヘッダに表示される画像のURL | No デフォルトは 下向き矢印画像のURL
 | defaultImage (String) | ヘッダの初回クリック前、および、他のヘッダクリック時に ヘッダに表示される画像のURL | No デフォルトは ブランク画像のURL
header (Object) | height (Number) | ヘッダの高さ | No デフォルトは 未設定
 | className (String) | ヘッダのCSSクラス名 | No デフォルトは im_sortable_table_header_cell
mousedownClassName (String) | ヘッダのCSSクラス名（マウスダウン時） | No デフォルトは im_sortable_table_header_cell_mousedown
data (Object) | height (Number) | セルの高さ | No デフォルトは 未設定
 | evenClassName (String) | セルのCSSクラス名（偶数行） | No デフォルトは im_sortable_table_data_cell_even
 | oddClassName (String) | セルのCSSクラス名（奇数行） | No デフォルトは im_sortable_table_data_cell_odd
 | selectedClassName (String) | セルのCSSクラス名（選択時） | No デフォルトは im_sortable_table_data_cell_selected
beforeTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の前に実行されます。 | No デフォルトは 未設定
afterTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の後に実行されます。 | No デフォルトは 未設定

「状態」と「イベントタイプ」の関係

「状態」と「イベントタイプ」の関係（チェックボックス用）は以下の通りです。

 状態
Unselect Select
イベントタイプ click
  • チェックボックスの値を反転
  • このセルを現在選択中のポジションに変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
  • チェックボックスの値を反転
  • 状態は変化無し
keydown -
(何も行いません) 		[Space]キーが押下された場合
  • チェックボックスの値を反転
  • 状態は変化無し
上記以外
  • 何も行いません。
mouseover
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
mouseout -
(何も行いません) 		このセルが選択されている場合
  • 何も行いません。
このセルが選択されていない場合（=このセル以外のセルが選択された場合）
  • 現在のセルの表示形式を未選択形式に変更
  • 次の状態はUnselect

Version: 1.0

Author: INTRAMART

クラスの概要
ImSortableTableCell4Checkbox ImSortableTableのチェックボックス用セルオブジェクト。
/**
 * @fileoverview ImSortableTableのチェックボックス用セルオブジェクトです。<br/>
 * <br/>
 * <ul>
 * 	<li><a href="#ConfigObject">コンフィグオブジェクトの構成</a></li>
 * 	<li><a href="#StateDiagram">「状態」と「イベントタイプ」の関係</a></li>
 * 	<li><a href="ImSortableTableCell4Checkbox.html">メソッドの概要</a></li>
 * </ul>
 *
 * <h2><a name="ConfigObject">コンフィグオブジェクトの構成</a></h2>
 *
 * <a name="ConfigObject"/>
 * ImSortableTableのコンフィグオブジェクト（チェックボックス用）の構成は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<th colspan="2">プロパティ (型)</th>
 * 		<th>説明</th>
 * 		<th>必須</th>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>type</b> <br/> (String)</td>
 * 		<td>
 * 			列のフォーマットタイプ。<br/>
 * 			チェックボックスの場合は、文字列「checkbox」固定です。
 *		</td>
 * 		<td>Yes<br/>(文字列「checkbox」を指定してください)</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>id</b> <br/> (String)</td>
 * 		<td>
 * 			列を識別するためのID。<br/>
 * 			このIDが、データセット時のオブジェクトのプロパティ名となります。
 *		</td>
 * 		<td>Yes</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>name</b> <br/> (String)</td>
 * 		<td>
 * 			使用されません。<br/>
 * 			<br/>
 * 			チェックボックスの場合、ヘッダにはチェックボックスが表示されます。<br/>
 * 			ヘッダに表示されるチェックボックスをクリックすると、
 * 			クリック後のチェック状態が同じ列のチェックボックスに反映されます。
 *		</td>
 * 		<td> - </td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>width</b> <br/> (Number)</td>
 * 		<td>
 * 			列の幅<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>visible</b> <br/> (Boolean)</td>
 * 		<td>
 * 			列の表示・非表示。<br/>
 * 			<br/>
 * 			trueの場合 ：列を表示<br/>
 * 			falseの場合：列を非表示<br/>
 * 			<br/>
 * 			なお、列を非表示にした場合でも、データの取得は可能です。<br/>
 * 			例えば、「コード」と「名前」を保持するオブジェクトに関して、
 * 			「名前」だけを表示するSortableテーブルを作成した際、
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得できるデータには、非表示である「コード」も含まれます。
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>sortable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			ソートの可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：ソート可能<br/>
 * 			falseの場合：ソート不可<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="6"><b>sorter</b> <br/> (Object)</td>
 * 		<td><b>sortDirection</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック時のソート方向。<br/>
 * 			（ヘッダをクリックするごとに、この値は反転します）<br/>
 * 			この値は以下の定数で指定してください。<br/>
 * 			<br/>
 * 			昇順の場合：<b>IM_STBL_CONFIG_KEY.ASC </b><br/>
 * 			降順の場合：<b>IM_STBL_CONFIG_KEY.DESC</b><br/>
 *		</td>
 * 		<td>No<br/>デフォルトは IM_STBL_CONFIG_KEY.ASC</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			昇順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは 真偽値の昇順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			降順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは 真偽値の降順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascImage</b> <br/> (String)</td>
 * 		<td>
 * 			昇順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 上向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descImage</b> <br/> (String)</td>
 * 		<td>
 * 			降順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 下向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>defaultImage</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック前、および、他のヘッダクリック時に
 * 			ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは ブランク画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="2"><b>header</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			ヘッダの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>className</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>mousedownClassName</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名（マウスダウン時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell_mousedown</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="4"><b>data</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			セルの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>evenClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（偶数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_even</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>oddClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（奇数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_odd</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>selectedClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（選択時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_selected</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>beforeTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>前</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>afterTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>後</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * </table>
 *
 * <br/>
 * <br/>
 *
 * <h2><a name="StateDiagram">「状態」と「イベントタイプ」の関係</a></h2>
 *
 * 「状態」と「イベントタイプ」の関係（チェックボックス用）は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<td bgcolor="lightgrey" colspan="2" rowspan="2"><br/></td>
 * 		<td bgcolor="lightgrey" colspan="3" align="center">状態</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" align="center">Unselect</td>
 * 		<td bgcolor="lightgrey" align="center">Select</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" rowspan="8">イベントタイプ</td>
 * 		<td bgcolor="lightgrey">click</td>
 * 		<td>
 * 			<ul>
 * 				<li>チェックボックスの値を反転</li>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>チェックボックスの値を反転</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">keydown</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			[Space]キーが押下された場合<br/>
 * 			<ul>
 * 				<li>チェックボックスの値を反転</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 			上記以外<br/>
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseover</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseout</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			このセルが選択されている場合
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 *
 * 			このセルが選択されていない場合（=このセル以外のセルが選択された場合）
 * 			<ul>
 * 				<li>現在のセルの表示形式を未選択形式に変更</li>
 * 				<li>次の状態は<b>Unselect</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * </table>
 *
 * <a name="APIListStart"/>
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */

var IM_STBL_CELL_CHECKBOX_ON_IMG  = IM_STBL_CONTEXT_PATH + "/images/sortable_table/checkbox_on.gif";
var IM_STBL_CELL_CHECKBOX_OFF_IMG = IM_STBL_CONTEXT_PATH + "/images/sortable_table/checkbox_off.gif";

ImSortableTableCell4Checkbox.prototype = new ImSortableTableCell();

/**
 * コンストラクタ。<br/>
 * <br/>
 * <i>開発者が明示的にこのコンストラクタを利用する必要はありません。</i>
 *
 * @class ImSortableTableのチェックボックス用セルオブジェクト。<br/>
 * チェックボックス用セルオブジェクトの詳しい説明は、<a href="overview-summary-im_sortable_table_cell_checkbox.js.html">こちら</a>を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 */
function ImSortableTableCell4Checkbox(observer, htmlElement, position, config, data) {

    /**
     * @private
     */
    this.constructor = function(observer, htmlElement, position, config, data){

        this.controlType = "checkbox";
        this.currentState = this.initialState;

        this.observer    = observer;
        this.htmlElement = htmlElement;
        this.position    = position;
        this.config      = config;
        this.data        = data;

        this.beforeTriggers = this.config.beforeTriggers;
        this.afterTriggers  = this.config.afterTriggers;
    }

    /**
     * @private
     * @override
     */
    this.appendChildElements = function(){
        this.addCachedSelfListeners("click", "keydown", "mouseover", "mouseout");
        this.createChildElement();
    }

    /**
     * @private
     * @override
     */
    this.unloadChildElements = function(){
        this.removeCachedSelfListeners();

        this.checkboxImgElement = null;

        this.afterTriggers  = null;
        this.beforeTriggers = null;

        this.data         = null;
        this.config       = null;
        this.position     = null;
        this.htmlElement  = null;
        this.observer     = null;

        this.currentState = null;
        this.controlType  = null;
    }

    /**
     * @private
     */
    this.createChildElement = function(){
        var imgElem;

        var elemId  = this.htmlElement.id + this.controlType;
        var elemSrc = (this.data == true) ? IM_STBL_CELL_CHECKBOX_ON_IMG : IM_STBL_CELL_CHECKBOX_OFF_IMG;

        if(ImSortableTable.Browser.IE){
            imgElem = document.createElement('<img id="'  + elemId  + '" ' +
                                                  'src="' + elemSrc + '">');
        }
        else{
            imgElem = document.createElement("img");
            imgElem.id = elemId;
            imgElem.setAttribute("src", elemSrc);
        }

        this.checkboxImgElement = imgElem;
        this.htmlElement.appendChild(this.checkboxImgElement);

    }

    /**
     * @private
     * @override
     */
    this.actionTransitionFunctions = {
        Unselect : {
            click : function(event){
                if(this.isSameThisAndEventTarget(event)){
                    return this.currentState;
                }
                else{
                    this.revreseCheckedStatus();
                    this.observer.setCurrentPosition(event, this.position);
                    this.changeStyle2Selected(event);
                    return IM_STBL_CELL_STATE.SELECT;
                }
            },

            keydown : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                return this.currentState;
            }

        },

        Select : {
            click : function(event){
                this.revreseCheckedStatus();
                return this.currentState;
            },

            keydown : function(event){
                // [Space]
                if(event.keyCode == 32){
                    this.revreseCheckedStatus();
                }
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                if(this.observer.isSelectedPosition(this.position)){
                    return this.currentState;
                }
                else{
                    this.changeStyle2Unselected(event);
                    return IM_STBL_CELL_STATE.UN_SELECT;
                }
            }
        }
    }

    /**
     * @private
     */
    this.isSameThisAndEventTarget = function(event) {
        var target = (event.srcElement||event.target);

        if(this.htmlElement.id == target.id){
            return true;
        }
        else{
            return false;
        }
    }

    /**
     * チェックボックスの値を変更します。<br/>
     *
     * @param {Boolean} checkedStatus チェック状態に変更する場合は true、非チェック状態に変更する場合は false。
     */
    this.updateCheckedStatus = function(checkedStatus){
        if(checkedStatus == true){
            this.checkboxImgElement.src = IM_STBL_CELL_CHECKBOX_ON_IMG;
            this.updateCellData(true);
        }
        else{
            this.checkboxImgElement.src = IM_STBL_CELL_CHECKBOX_OFF_IMG;
            this.updateCellData(false);
        }
    }

    /**
     * チェックボックスの値を反転させます。<br/>
     */
    this.revreseCheckedStatus = function(){
        if(this.data == true){
            this.checkboxImgElement.src = IM_STBL_CELL_CHECKBOX_OFF_IMG;
            this.updateCellData(false);
        }
        else{
            this.checkboxImgElement.src = IM_STBL_CELL_CHECKBOX_ON_IMG;
            this.updateCellData(true);
        }
    }

    // Construct instance
    this.constructor(observer, htmlElement, position, config, data);
}

/**
 * ImSortableTableのデフォルトコンフィグオブジェクトを生成します（チェックボックス用）。
 *
 * @param {String} argId 列を識別するためのID
 * @param {String} argName [option] ヘッダに表示される文字列（使用されません）（任意）
 * @param {Number} argWidth [option] 列の幅（任意）
 * @return デフォルト値を格納したImSortableTableの<a href="overview-summary-im_sortable_table_cell_checkbox.js.html#ConfigObject">チェックボックス用コンフィグオブジェクト</a>
 * @type Object
 */
ImSortableTableCell4Checkbox.createDefaultConfig = function(argId, argName, argWidth){

    var defaultConfig = {
        type           : "checkbox",
        id             : (argId    != null && argId    != undefined) ? argId    : null,
        name           : (argName  != null && argName  != undefined) ? argName  : "",
        width          : (argWidth != null && argWidth != undefined) ? argWidth : "",
        visible        : true,
        sortable       : true,
        sorter         : {
                            sortDirection : IM_STBL_CONFIG_KEY.ASC,
                            ascFunction   : ImSortableTableCell4Checkbox.defaultAscFunction,
                            descFunction  : ImSortableTableCell4Checkbox.defaultDescFunction,
                            ascImage      : IM_STBL_CELL_SORT_ASC_IMG,
                            descImage     : IM_STBL_CELL_SORT_DESC_IMG,
                            defaultImage  : IM_STBL_CELL_SORT_DEFAULT_IMG
                         },
        header         : {
                            height             : "",
                            className          : "im_sortable_table_header_cell",
                            mousedownClassName : "im_sortable_table_header_cell_mousedown"
                         },
        data           : {
                            height            : "",
                            evenClassName     : "im_sortable_table_data_cell_even",
                            oddClassName      : "im_sortable_table_data_cell_odd",
                            selectedClassName : "im_sortable_table_data_cell_selected"
                         },
        beforeTriggers : [],
        afterTriggers  : []
    };

    return defaultConfig;

}

/**
 * @private
 */
ImSortableTableCell4Checkbox.defaultAscFunction = function(a, b){
    var aCol = a[IM_STBL_SORT_TARGET_IDX];
    var bCol = b[IM_STBL_SORT_TARGET_IDX];

    if(aCol == bCol){
        return 0;
    }
    else if(aCol > bCol){
        return 1;
    }
    else{
        return -1;
    }
}

/**
 * @private
 */
ImSortableTableCell4Checkbox.defaultDescFunction = function(a, b){
    var bCol = b[IM_STBL_SORT_TARGET_IDX];
    var aCol = a[IM_STBL_SORT_TARGET_IDX];

    if(bCol == aCol){
        return 0;
    }
    else if(bCol > aCol){
        return 1;
    }
    else{
        return -1;
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table_cell_image.js

概要

ImSortableTableのイメージ用セルオブジェクトです。

  • コンフィグオブジェクトの構成
  • 「状態」と「イベントタイプ」の関係
  • メソッドの概要

コンフィグオブジェクトの構成

ImSortableTableのコンフィグオブジェクト（イメージ用）の構成は以下の通りです。
プロパティ (型) 説明 必須
type
(String) 		列のフォーマットタイプ。
イメージの場合は、文字列「image」固定です。 		Yes
(文字列「image」を指定してください)
id
(String) 		列を識別するためのID。
このIDが、データセット時のオブジェクトのプロパティ名となります。 		Yes
name
(String) 		ヘッダに表示される文字列
 No
デフォルトは 空文字
width
(Number) 		列の幅
 No
デフォルトは 未設定
visible
(Boolean) 		列の表示・非表示。

trueの場合 ：列を表示
falseの場合：列を非表示

なお、列を非表示にした場合でも、データの取得は可能です。
例えば、「コード」と「名前」を保持するオブジェクトに関して、 「名前」だけを表示するSortableテーブルを作成した際、 ImSortableTable#getData()で取得できるデータには、非表示である「コード」も含まれます。 		No
デフォルトは true
sortable
(Boolean) 		ソートの可・不可。

trueの場合 ：ソート可能
falseの場合：ソート不可
 No
デフォルトは false
sorter
(Object) 		sortDirection
(String) 		ヘッダの初回クリック時のソート方向。
（ヘッダをクリックするごとに、この値は反転します）
この値は以下の定数で指定してください。

昇順の場合：IM_STBL_CONFIG_KEY.ASC
降順の場合：IM_STBL_CONFIG_KEY.DESC
 No
デフォルトは IM_STBL_CONFIG_KEY.ASC
ascFunction
(Function) 		昇順ソート時のソート関数
 No
デフォルトは データに格納されているオブジェクトの「value」プロパティを対象にした昇順ソート関数
descFunction
(Function) 		降順ソート時のソート関数
 No
デフォルトは データに格納されているオブジェクトの「value」プロパティを対象にした降順ソート関数
ascImage
(String) 		昇順ソート後、ヘッダに表示される画像のURL
 No
デフォルトは 上向き矢印画像のURL
descImage
(String) 		降順ソート後、ヘッダに表示される画像のURL
 No
デフォルトは 下向き矢印画像のURL
defaultImage
(String) 		ヘッダの初回クリック前、および、他のヘッダクリック時に ヘッダに表示される画像のURL
 No
デフォルトは ブランク画像のURL
header
(Object) 		height
(Number) 		ヘッダの高さ
 No
デフォルトは 未設定
className
(String) 		ヘッダのCSSクラス名 No
デフォルトは im_sortable_table_header_cell
mousedownClassName
(String) 		ヘッダのCSSクラス名（マウスダウン時） No
デフォルトは im_sortable_table_header_cell_mousedown
data
(Object) 		height
(Number) 		セルの高さ
 No
デフォルトは 未設定
evenClassName
(String) 		セルのCSSクラス名（偶数行） No
デフォルトは im_sortable_table_data_cell_even
oddClassName
(String) 		セルのCSSクラス名（奇数行） No
デフォルトは im_sortable_table_data_cell_odd
selectedClassName
(String) 		セルのCSSクラス名（選択時） No
デフォルトは im_sortable_table_data_cell_selected
beforeTriggers
(Array) 		トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の前に実行されます。 No
デフォルトは 未設定
afterTriggers
(Array) 		トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の後に実行されます。 No
デフォルトは 未設定
defaultImageURL
(String) 		セルに表示される画像のURL（デフォルト） No
処理を行う意味のアイコン画像
mouseOverImageURL
(String) 		セルに表示される画像のURL（マウスオーバ時） No
デフォルトは undefined
（セル生成時、このプロパティ値が undefined ならば「defaultImageURL」と同値が設定されます）
activeImageURL
(String) 		セルに表示される画像のURL（マウスクリック時） No
デフォルトは undefined
（セル生成時、このプロパティ値が undefined ならば「mouseOverImageURL」と同値が設定されます）
onClickFunction
(Function) 		画像クリック時に実行される関数。

この関数には以下の引数が渡されます。
パラメータ(型) | 説明
event (Object) | クリック時のイベントオブジェクト
targetCell (Object) | クリックされたセルのImSortableTableCell4Imageのインスタンス
 No
デフォルトは undefined　（画像クリック時には何も処理を行いません）
imageWidth
(Number) 		セルに表示される画像の幅 No
デフォルトは 11
imageHeight
(Number) 		セルに表示される画像の高さ No
デフォルトは 11
imageTitle
(String) 		画像の title 属性
（<img>タグの title 属性です）
 No
デフォルトは 空文字
imageBorder
(Number) 		画像の周りの枠線の太さ
 No
デフォルトは 0
imageTabIndex
(Number) 		タブ順序制御
（<img>タグの tabIndex 属性です）
 No
デフォルトは 0

「状態」と「イベントタイプ」の関係

「状態」と「イベントタイプ」の関係（イメージ用）は以下の通りです。

 状態
Unselect Select
イベントタイプ click
  • コンフィグオブジェクトの「onClickFunction」に登録された関数を実行
  • このセルを現在選択中のポジションに変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
  • コンフィグオブジェクトの「onClickFunction」に登録された関数を実行
  • 状態は変化無し
mouseover
  • マウスオーバ時の画像に変更
  • 状態は変化無し
    • ※コンフィグオブジェクトの「onClickFunction」が設定されている場合のみ、 カーソルスタイルを「pointer」に変更
  • マウスオーバ時の画像に変更
  • 状態は変化無し
    • ※コンフィグオブジェクトの「onClickFunction」が設定されている場合のみ、 カーソルスタイルを「pointer」に変更
mouseout
  • デフォルト時の画像に変更
  • 状態は変化無し
 このセルが選択されている場合
  • デフォルト時の画像に変更
  • 状態は変化無し
このセルが選択されていない場合（=このセル以外のセルが選択された場合）
  • デフォルト時の画像に変更
  • 現在のセルの表示形式を未選択形式に変更
  • 次の状態はUnselect
mousedown
  • マウスクリック時の画像に変更
  • 状態は変化無し
  • マウスクリック時の画像に変更
  • 状態は変化無し
mouseup
  • デフォルト時の画像に変更
  • 状態は変化無し
  • デフォルト時の画像に変更
  • 状態は変化無し

Version: 1.0

Author: INTRAMART

クラスの概要
ImSortableTableCell4Image ImSortableTableのイメージ用セルオブジェクト。
/**
 * @fileoverview ImSortableTableのイメージ用セルオブジェクトです。<br/>
 * <br/>
 *
 * <ul>
 * 	<li><a href="#ConfigObject">コンフィグオブジェクトの構成</a></li>
 * 	<li><a href="#StateDiagram">「状態」と「イベントタイプ」の関係</a></li>
 * 	<li><a href="ImSortableTableCell4Image.html">メソッドの概要</a></li>
 * </ul>
 *
 * <h2><a name="ConfigObject">コンフィグオブジェクトの構成</a></h2>
 *
 * ImSortableTableのコンフィグオブジェクト（イメージ用）の構成は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<th colspan="2">プロパティ (型)</th>
 * 		<th>説明</th>
 * 		<th>必須</th>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>type</b> <br/> (String)</td>
 * 		<td>
 * 			列のフォーマットタイプ。<br/>
 * 			イメージの場合は、文字列「image」固定です。
 *		</td>
 * 		<td>Yes<br/>(文字列「image」を指定してください)</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>id</b> <br/> (String)</td>
 * 		<td>
 * 			列を識別するためのID。<br/>
 * 			このIDが、データセット時のオブジェクトのプロパティ名となります。
 *		</td>
 * 		<td>Yes</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>name</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダに表示される文字列<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 空文字</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>width</b> <br/> (Number)</td>
 * 		<td>
 * 			列の幅<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>visible</b> <br/> (Boolean)</td>
 * 		<td>
 * 			列の表示・非表示。<br/>
 * 			<br/>
 * 			trueの場合 ：列を表示<br/>
 * 			falseの場合：列を非表示<br/>
 * 			<br/>
 * 			なお、列を非表示にした場合でも、データの取得は可能です。<br/>
 * 			例えば、「コード」と「名前」を保持するオブジェクトに関して、
 * 			「名前」だけを表示するSortableテーブルを作成した際、
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得できるデータには、非表示である「コード」も含まれます。
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>sortable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			ソートの可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：ソート可能<br/>
 * 			falseの場合：ソート不可<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは <b>false</b></td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="6"><b>sorter</b> <br/> (Object)</td>
 * 		<td><b>sortDirection</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック時のソート方向。<br/>
 * 			（ヘッダをクリックするごとに、この値は反転します）<br/>
 * 			この値は以下の定数で指定してください。<br/>
 * 			<br/>
 * 			昇順の場合：<b>IM_STBL_CONFIG_KEY.ASC </b><br/>
 * 			降順の場合：<b>IM_STBL_CONFIG_KEY.DESC</b><br/>
 *		</td>
 * 		<td>No<br/>デフォルトは IM_STBL_CONFIG_KEY.ASC</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			昇順ソート時のソート関数<br/>
 *		</td>
 * 		<td>
 * 			No<br/>
 * 			デフォルトは データに格納されているオブジェクトの「value」プロパティを対象にした昇順ソート関数
 *		</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			降順ソート時のソート関数<br/>
 *		</td>
 * 		<td>
 * 			No<br/>
 * 			デフォルトは データに格納されているオブジェクトの「value」プロパティを対象にした降順ソート関数
 *		</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascImage</b> <br/> (String)</td>
 * 		<td>
 * 			昇順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 上向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descImage</b> <br/> (String)</td>
 * 		<td>
 * 			降順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 下向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>defaultImage</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック前、および、他のヘッダクリック時に
 * 			ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは ブランク画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="2"><b>header</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			ヘッダの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>className</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>mousedownClassName</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名（マウスダウン時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell_mousedown</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="4"><b>data</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			セルの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>evenClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（偶数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_even</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>oddClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（奇数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_odd</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>selectedClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（選択時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_selected</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>beforeTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>前</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>afterTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>後</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>defaultImageURL</b> <br/> (String)</td>
 * 		<td>
 * 			セルに表示される画像のURL（デフォルト）
 *		</td>
 * 		<td>No<br/>処理を行う意味のアイコン画像</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>mouseOverImageURL</b> <br/> (String)</td>
 * 		<td>
 * 			セルに表示される画像のURL（マウスオーバ時）
 *		</td>
 * 		<td>No<br/>デフォルトは undefined <br/>
 * 			（セル生成時、このプロパティ値が undefined ならば「defaultImageURL」と同値が設定されます）</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>activeImageURL</b> <br/> (String)</td>
 * 		<td>
 * 			セルに表示される画像のURL（マウスクリック時）
 *		</td>
 * 		<td>No<br/>デフォルトは undefined <br/>
 * 			（セル生成時、このプロパティ値が undefined ならば「mouseOverImageURL」と同値が設定されます）</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>onClickFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			画像クリック時に実行される関数。<br/>
 * 			<br/>
 * 			この関数には以下の引数が渡されます。<br/>
 * 			<table border="1">
 * 				<tr>
 * 					<th>パラメータ(型)</th>
 * 					<th>説明</th>
 * 				</tr>
 * 				<tr>
 * 					<td>event　(Object)</td>
 * 					<td>クリック時のイベントオブジェクト</td>
 * 				</tr>
 * 				<tr>
 * 					<td>targetCell (Object)</td>
 * 					<td>クリックされたセルのImSortableTableCell4Imageのインスタンス</td>
 * 				</tr>
 * 			</table>
 *		</td>
 * 		<td>No<br/>デフォルトは undefined　（画像クリック時には何も処理を行いません）</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>imageWidth</b> <br/> (Number)</td>
 * 		<td>
 * 			セルに表示される画像の幅
 *		</td>
 * 		<td>No<br/>デフォルトは 11</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>imageHeight</b> <br/> (Number)</td>
 * 		<td>
 * 			セルに表示される画像の高さ
 *		</td>
 * 		<td>No<br/>デフォルトは 11</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>imageTitle</b> <br/> (String)</td>
 * 		<td>
 * 			画像の title 属性<br/>
 *			（&lt;img&gt;タグの title 属性です）<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 空文字</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>imageBorder</b> <br/> (Number)</td>
 * 		<td>
 * 			画像の周りの枠線の太さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 0</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>imageTabIndex</b> <br/> (Number)</td>
 * 		<td>
 * 			タブ順序制御<br/>
 *			（&lt;img&gt;タグの tabIndex 属性です）<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 0</td>
 * 	</tr>
 * </table>
 *
 *
 * <br/>
 * <br/>
 *
 * <h2><a name="StateDiagram">「状態」と「イベントタイプ」の関係</a></h2>
 *
 * 「状態」と「イベントタイプ」の関係（イメージ用）は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<td bgcolor="lightgrey" colspan="2" rowspan="2"><br/></td>
 * 		<td bgcolor="lightgrey" colspan="3" align="center">状態</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" align="center">Unselect</td>
 * 		<td bgcolor="lightgrey" align="center">Select</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" rowspan="8">イベントタイプ</td>
 * 		<td bgcolor="lightgrey">click</td>
 * 		<td>
 * 			<ul>
 * 				<li>コンフィグオブジェクトの「onClickFunction」に登録された関数を実行</li>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>コンフィグオブジェクトの「onClickFunction」に登録された関数を実行</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseover</td>
 * 		<td>
 * 			<ul>
 * 				<li>マウスオーバ時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 				※コンフィグオブジェクトの「onClickFunction」が設定されている場合のみ、
 * 				カーソルスタイルを「pointer」に変更
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>マウスオーバ時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 				※コンフィグオブジェクトの「onClickFunction」が設定されている場合のみ、
 * 				カーソルスタイルを「pointer」に変更
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseout</td>
 * 		<td>
 * 			<ul>
 * 				<li>デフォルト時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			このセルが選択されている場合
 * 			<ul>
 * 				<li>デフォルト時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 *
 * 			このセルが選択されていない場合（=このセル以外のセルが選択された場合）
 * 			<ul>
 * 				<li>デフォルト時の画像に変更</li>
 * 				<li>現在のセルの表示形式を未選択形式に変更</li>
 * 				<li>次の状態は<b>Unselect</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mousedown</td>
 * 		<td>
 * 			<ul>
 * 				<li>マウスクリック時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>マウスクリック時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseup</td>
 * 		<td>
 * 			<ul>
 * 				<li>デフォルト時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>デフォルト時の画像に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * </table>
 *
 * <a name="APIListStart"/>
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */

ImSortableTableCell4Image.prototype = new ImSortableTableCell();

/**
 * コンストラクタ。<br/>
 * <br/>
 * <i>開発者が明示的にこのコンストラクタを利用する必要はありません。</i>
 *
 * @class ImSortableTableのイメージ用セルオブジェクト。<br/>
 * イメージ用セルオブジェクトの詳しい説明は、<a href="overview-summary-im_sortable_table_cell_image.js.html">こちら</a>を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 */
function ImSortableTableCell4Image(observer, htmlElement, position, config, data) {

    /**
     * @private
     */
    this.constructor = function(observer, htmlElement, position, config, data){

        this.controlType = "image";
        this.currentState = this.initialState;

        this.observer    = observer;
        this.htmlElement = htmlElement;
        this.position    = position;
        this.config      = this.overrideProperty({}, config);
        this.config      = this.overrideProperty(this.config, data);
        this.data        = data;

        this.beforeTriggers = this.config.beforeTriggers;
        this.afterTriggers  = this.config.afterTriggers;

        // Image : default > mouseOver > active
        if( this.config.mouseOverImageURL == undefined ) {
            this.config.mouseOverImageURL = this.config.defaultImageURL;
        }
        if( this.config.activeImageURL == undefined ) {
            this.config.activeImageURL = this.config.mouseOverImageURL;
        }
    }

    /**
     * @private
     * @override
     */
    this.appendChildElements = function(){
        this.addCachedSelfListeners("click", "mouseover", "mouseout", "mousedown", "mouseup");
        this.createChildElement();
    }

    /**
     * @private
     * @override
     */
    this.unloadChildElements = function(){
        this.removeCachedSelfListeners();

        this.imgElement = null;

        this.afterTriggers  = null;
        this.beforeTriggers = null;

        this.data         = null;
        this.config       = null;
        this.position     = null;
        this.htmlElement  = null;
        this.observer     = null;

        this.currentState = null;
        this.controlType  = null;
    }

    /**
     * @private
     */
    this.createChildElement = function(){
        var imgElem;

        var elemId       = this.htmlElement.id + this.controlType;
        var elemSrc      = this.config.defaultImageURL;
        var elemWidth    = this.config.imageWidth;
        var elemHeight   = this.config.imageHeight;
        var elemTitle    = this.config.imageTitle;
        var elemBorder   = this.config.imageBorder;
        var elemTabIndex = this.config.imageTabIndex;

        if(ImSortableTable.Browser.IE){
            imgElem = document.createElement('<img id="'       + elemId       + '" ' +
                                                  'src="'      + elemSrc      + '" ' +
                                                  'width="'    + elemWidth    + '" ' +
                                                  'height="'   + elemHeight   + '" ' +
                                                  'title="'    + elemTitle    + '" ' +
                                                  'border="'   + elemBorder   + '" ' +
                                                  'tabIndex="' + elemTabIndex + '">');
        }
        else{
            imgElem = document.createElement("img");
            imgElem.id = elemId;
            imgElem.setAttribute("src",      elemSrc);
            imgElem.setAttribute("width",    elemWidth);
            imgElem.setAttribute("height",   elemHeight);
            imgElem.setAttribute("title",    elemTitle);
            imgElem.setAttribute("border",   elemBorder);
            imgElem.setAttribute("tabIndex", elemTabIndex);
        }

        this.imgElement = imgElem;
        this.htmlElement.appendChild(this.imgElement);
    }

    /**
     * @private
     * @override
     */
    this.actionTransitionFunctions = {
        Unselect : {
            click : function(event){
                this.observer.setCurrentPosition(event, this.position);
                this.changeStyle2Selected(event);
                this.executeOnClickFunction(event);
                return IM_STBL_CELL_STATE.SELECT;
            },

            mouseover : function(event){
                if(this.config.onClickFunction){
                    this.htmlElement.style.cursor = "pointer";
                }
                this.replaceToMouseOverImage();
                return this.currentState;
            },

            mouseout : function(event){
                this.replaceToDefaultImage();
                return this.currentState;
            },

            mousedown : function(event){
                this.replaceToActiveImage();
                return this.currentState;
            },

            mouseup : function(event){
                this.replaceToDefaultImage();
                return this.currentState;
            }
        },

        Select : {
            click : function(event){
                this.executeOnClickFunction(event);
                return this.currentState;
            },

            mouseover : function(event){
                if(this.config.onClickFunction){
                    this.htmlElement.style.cursor = "pointer";
                }
                this.replaceToMouseOverImage();
                return this.currentState;
            },

            mouseout : function(event){
                if(this.observer.isSelectedPosition(this.position)){
                    this.replaceToDefaultImage();
                    return this.currentState;
                }
                else{
                    this.replaceToDefaultImage();
                    this.changeStyle2Unselected(event);
                    return IM_STBL_CELL_STATE.UN_SELECT;
                }
            },

            mousedown : function(event){
                this.replaceToActiveImage();
                return this.currentState;
            },

            mouseup : function(event){
                this.replaceToDefaultImage();
                return this.currentState;
            }
        }

    }

    /**
     * @private
     */
    this.executeOnClickFunction = function(event){
        if(this.config.onClickFunction){
            this.config.onClickFunction(event, this);
        }
    }

    /**
     * @private
     */
    this.replaceToDefaultImage = function(){
        this.imgElement.src      = this.config.defaultImageURL;
        this.imgElement.width    = this.config.imageWidth;
        this.imgElement.height   = this.config.imageHeight;
        this.imgElement.title    = this.config.imageTitle;
        this.imgElement.border   = this.config.imageBorder;
        this.imgElement.tabIndex = this.config.imageTabIndex;
    }

    /**
     * @private
     */
    this.replaceToMouseOverImage = function(){
        this.imgElement.src      = this.config.mouseOverImageURL;
        this.imgElement.width    = this.config.imageWidth;
        this.imgElement.height   = this.config.imageHeight;
        this.imgElement.title    = this.config.imageTitle;
        this.imgElement.border   = this.config.imageBorder;
        this.imgElement.tabIndex = this.config.imageTabIndex;
    }

    /**
     * @private
     */
    this.replaceToActiveImage = function(){
        this.imgElement.src      = this.config.activeImageURL;
        this.imgElement.width    = this.config.imageWidth;
        this.imgElement.height   = this.config.imageHeight;
        this.imgElement.title    = this.config.imageTitle;
        this.imgElement.border   = this.config.imageBorder;
        this.imgElement.tabIndex = this.config.imageTabIndex;
    }

    // Construct instance
    this.constructor(observer, htmlElement, position, config, data);
}

/**
 * ImSortableTableのデフォルトコンフィグオブジェクトを生成します（イメージ用）。
 *
 * @param {String} argId 列を識別するためのID
 * @param {String} argName [option] ヘッダに表示される文字列（任意）
 * @param {Number} argWidth [option] 列の幅（任意）
 * @return デフォルト値を格納したImSortableTableの<a href="overview-summary-im_sortable_table_cell_image.js.html#ConfigObject">イメージ用コンフィグオブジェクト</a>
 * @type Object
 */
ImSortableTableCell4Image.createDefaultConfig = function(argId, argName, argWidth){

    var defaultImageUrl = IM_STBL_CONTEXT_PATH + "/csjs/sortable_table/parts/gear.gif";

    var defaultConfig = {
        type           : "image",
        id             : (argId    != null && argId    != undefined) ? argId    : null,
        name           : (argName  != null && argName  != undefined) ? argName  : "",
        width          : (argWidth != null && argWidth != undefined) ? argWidth : "",
        visible        : true,
        sortable       : false,
        sorter         : {
                            sortDirection : IM_STBL_CONFIG_KEY.ASC,
                            ascFunction   : ImSortableTableCell4Image.defaultAscFunction4Value,
                            descFunction  : ImSortableTableCell4Image.defaultDescFunction4Value,
                            ascImage      : IM_STBL_CELL_SORT_ASC_IMG,
                            descImage     : IM_STBL_CELL_SORT_DESC_IMG,
                            defaultImage  : IM_STBL_CELL_SORT_DEFAULT_IMG
                         },
        header         : {
                            height             : "",
                            className          : "im_sortable_table_header_cell",
                            mousedownClassName : "im_sortable_table_header_cell_mousedown"
                         },
        data           : {
                            height            : "",
                            evenClassName     : "im_sortable_table_data_cell_even",
                            oddClassName      : "im_sortable_table_data_cell_odd",
                            selectedClassName : "im_sortable_table_data_cell_selected"
                         },
        beforeTriggers : [],
        afterTriggers  : [],

        // OTHER CONFIG
        defaultImageURL   : defaultImageUrl, // Default image URL
        mouseOverImageURL : undefined,       // Image URL for MouseOver
        activeImageURL    : undefined,       // Image URL for Active
        onClickFunction   : undefined,       // This function is Executed when onClick Event occur
        imageWidth        : 11,              // "width"    attribute for IMG tag
        imageHeight       : 11,              // "height"   attribute for IMG tag
        imageTitle        : "",              // "title"    attribute for IMG tag
        imageBorder       : 0,               // "border"   attribute for IMG tag
        imageTabIndex     : 0                // "tabIndex" attribute for IMG tag
    };

    return defaultConfig;

}

/**
 * @private
 */
ImSortableTableCell4Image.defaultAscFunction4Value = function(a, b){
    var aCol = a[IM_STBL_SORT_TARGET_IDX].value;
    var bCol = b[IM_STBL_SORT_TARGET_IDX].value;

    if(aCol == bCol){
        return 0;
    }
    else if(aCol > bCol){
        return 1;
    }
    else{
        return -1;
    }
}

/**
 * @private
 */
ImSortableTableCell4Image.defaultDescFunction4Value = function(a, b){
    var bCol = b[IM_STBL_SORT_TARGET_IDX].value;
    var aCol = a[IM_STBL_SORT_TARGET_IDX].value;

    if(bCol == aCol){
        return 0;
    }
    else if(bCol > aCol){
        return 1;
    }
    else{
        return -1;
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table_cell_number.js

概要

ImSortableTableの数値用セルオブジェクトです。

  • コンフィグオブジェクトの構成
  • 「状態」と「イベントタイプ」の関係
  • メソッドの概要

コンフィグオブジェクトの構成

ImSortableTableのコンフィグオブジェクト（数値用）の構成は以下の通りです。
プロパティ (型) |  | 説明 | 必須
type (String) |  | 列のフォーマットタイプ。 数値の場合は、文字列「number」固定です。 | Yes (文字列「number」を指定してください)
id (String) |  | 列を識別するためのID。 このIDが、データセット時のオブジェクトのプロパティ名となります。 | Yes
name (String) |  | ヘッダに表示される文字列 | No デフォルトは 空文字
width (Number) |  | 列の幅 | No デフォルトは 未設定
visible (Boolean) |  | 列の表示・非表示。 trueの場合 ：列を表示 falseの場合：列を非表示 なお、列を非表示にした場合でも、データの取得は可能です。 例えば、「コード」と「名前」を保持するオブジェクトに関して、 「名前」だけを表示するSortableテーブルを作成した際、 ImSortableTable#getData()で取得できるデータには、非表示である「コード」も含まれます。 | No デフォルトは true
sortable (Boolean) |  | ソートの可・不可。 trueの場合 ：ソート可能 falseの場合：ソート不可 | No デフォルトは true
sorter (Object) | sortDirection (String) | ヘッダの初回クリック時のソート方向。 （ヘッダをクリックするごとに、この値は反転します） この値は以下の定数で指定してください。 昇順の場合：IM_STBL_CONFIG_KEY.ASC 降順の場合：IM_STBL_CONFIG_KEY.DESC | No デフォルトは IM_STBL_CONFIG_KEY.ASC
 | ascFunction (Function) | 昇順ソート時のソート関数 | No デフォルトは 数値の昇順ソート関数
 | descFunction (Function) | 降順ソート時のソート関数 | No デフォルトは 数値の降順ソート関数
 | ascImage (String) | 昇順ソート後、ヘッダに表示される画像のURL | No デフォルトは 上向き矢印画像のURL
 | descImage (String) | 降順ソート後、ヘッダに表示される画像のURL | No デフォルトは 下向き矢印画像のURL
 | defaultImage (String) | ヘッダの初回クリック前、および、他のヘッダクリック時に ヘッダに表示される画像のURL | No デフォルトは ブランク画像のURL
header (Object) | height (Number) | ヘッダの高さ | No デフォルトは 未設定
 | className (String) | ヘッダのCSSクラス名 | No デフォルトは im_sortable_table_header_cell
mousedownClassName (String) | ヘッダのCSSクラス名（マウスダウン時） | No デフォルトは im_sortable_table_header_cell_mousedown
data (Object) | height (Number) | セルの高さ | No デフォルトは 未設定
 | evenClassName (String) | セルのCSSクラス名（偶数行） | No デフォルトは im_sortable_table_data_cell_number_even
 | oddClassName (String) | セルのCSSクラス名（奇数行） | No デフォルトは im_sortable_table_data_cell_number_odd
 | selectedClassName (String) | セルのCSSクラス名（選択時） | No デフォルトは im_sortable_table_data_cell_number_selected
beforeTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の前に実行されます。 | No デフォルトは 未設定
afterTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の後に実行されます。 | No デフォルトは 未設定
editable (Boolean) |  | セルの編集可・不可。 trueの場合 ：セルの編集可能 falseの場合：セルの編集不可 セルをダブルクリックすると、セルの内部がテキストフィールドに切り替わり、編集可能となります。 編集を確定するには Enter キーを押下するか、他のセルをクリックします。 編集をキャンセルするには Esc キーを押下します。 | No デフォルトは false
maxlength (Number) |  | 編集時の入力可能最大桁数 | No デフォルトは 入力桁数の制限なし
formatter (Function) |  | 編集の確定処理時に実行される関数。 コンフィグオブジェクト「editable」プロパティで true が指定されている場合にセルをダブルクリックすると、 セルの内部がテキストフィールドに切り替わり、編集可能となります。 編集中にEnterキーを押下すると編集の確定処理に移行します。 編集の確定処理時には、「formatter」で指定した関数が実行され、 その実行結果がセルに表示されます。 「formatter」関数の引数には、編集された内容をparseFloat()で数値変換した値が渡されます。 （編集の確定処理は、編集中に他のセルをクリックした際にも発生します） 編集キャンセル時には「formatter」で指定した関数は実行されません。 【注意】 「formatter」の実行結果は、表示内容にのみ影響をあたえます。 つまり、ImSortableTable#getData()で取得するデータには反映されません。 ImSortableTable#getData()で取得するデータには、 編集したデータをparseFloat()で数値変換した値が格納されています。 | No デフォルトは 引数に渡された数値を3桁毎にカンマ区切りした文字列を返却する関数

「状態」と「イベントタイプ」の関係

「状態」と「イベントタイプ」の関係（数値用）は以下の通りです。

 状態
Unselect Select Edit
イベントタイプ click
  • このセルを現在選択中のポジションに変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
 -
(何も行いません) 		-
(何も行いません)
dblclick 編集可能の場合
  • このセルを現在選択中のポジションに変更
  • テキストフィールドを表示
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はEdit
編集不可の場合
  • このセルを現在選択中のポジションに変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
 編集可能の場合
  • テキストフィールドを表示
  • 次の状態はEdit
編集不可の場合
  • 何も行いません。
 -
(何も行いません)
keydown -
(何も行いません) 		-
(何も行いません) 		[Enter]キーが押下された場合
  • 編集の確定処理を実行。
    • 具体的には、「Edit」状態の「completeEdit」イベントを起動し、 その戻り値を次の状態とします。
[Esc]キーが押下された場合
  • 編集のキャンセル処理を実行。
    • 具体的には、「Edit」状態の「cancelEdit」イベントを起動し、 その戻り値を次の状態とします。
上記以外
  • 何も行いません。
keyup -
(何も行いません) 		-
(何も行いません) 		-
(何も行いません)
mouseover
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
  • カーソルスタイルを「text」に変更
  • 状態は変化無し
mouseout -
(何も行いません) 		このセルが選択されている場合
  • 何も行いません。
このセルが選択されていない場合（=このセル以外のセルが選択された場合）
  • 現在のセルの表示形式を未選択形式に変更
  • 次の状態はUnselect
 -
(何も行いません)
completeEdit ×
（このイベントは発生しません） 		×
（このイベントは発生しません）
  • 編集の確定処理を実行
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
cancelEdit ×
（このイベントは発生しません） 		×
（このイベントは発生しません）
  • 編集の確定処理を実行
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect

Version: 1.0

Author: INTRAMART

クラスの概要
ImSortableTableCell4Number ImSortableTableの数値用セルオブジェクト。
/**
 * @fileoverview ImSortableTableの数値用セルオブジェクトです。<br/>
 * <br/>
 *
 * <ul>
 * 	<li><a href="#ConfigObject">コンフィグオブジェクトの構成</a></li>
 * 	<li><a href="#StateDiagram">「状態」と「イベントタイプ」の関係</a></li>
 * 	<li><a href="ImSortableTableCell4Number.html">メソッドの概要</a></li>
 * </ul>
 *
 * <h2><a name="ConfigObject">コンフィグオブジェクトの構成</a></h2>
 *
 * ImSortableTableのコンフィグオブジェクト（数値用）の構成は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<th colspan="2">プロパティ (型)</th>
 * 		<th>説明</th>
 * 		<th>必須</th>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>type</b> <br/> (String)</td>
 * 		<td>
 * 			列のフォーマットタイプ。<br/>
 * 			数値の場合は、文字列「number」固定です。
 *		</td>
 * 		<td>Yes<br/>(文字列「number」を指定してください)</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>id</b> <br/> (String)</td>
 * 		<td>
 * 			列を識別するためのID。<br/>
 * 			このIDが、データセット時のオブジェクトのプロパティ名となります。
 *		</td>
 * 		<td>Yes</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>name</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダに表示される文字列<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 空文字</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>width</b> <br/> (Number)</td>
 * 		<td>
 * 			列の幅<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>visible</b> <br/> (Boolean)</td>
 * 		<td>
 * 			列の表示・非表示。<br/>
 * 			<br/>
 * 			trueの場合 ：列を表示<br/>
 * 			falseの場合：列を非表示<br/>
 * 			<br/>
 * 			なお、列を非表示にした場合でも、データの取得は可能です。<br/>
 * 			例えば、「コード」と「名前」を保持するオブジェクトに関して、
 * 			「名前」だけを表示するSortableテーブルを作成した際、
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得できるデータには、非表示である「コード」も含まれます。
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>sortable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			ソートの可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：ソート可能<br/>
 * 			falseの場合：ソート不可<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="6"><b>sorter</b> <br/> (Object)</td>
 * 		<td><b>sortDirection</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック時のソート方向。<br/>
 * 			（ヘッダをクリックするごとに、この値は反転します）<br/>
 * 			この値は以下の定数で指定してください。<br/>
 * 			<br/>
 * 			昇順の場合：<b>IM_STBL_CONFIG_KEY.ASC </b><br/>
 * 			降順の場合：<b>IM_STBL_CONFIG_KEY.DESC</b><br/>
 *		</td>
 * 		<td>No<br/>デフォルトは IM_STBL_CONFIG_KEY.ASC</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			昇順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは 数値の昇順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			降順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは 数値の降順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascImage</b> <br/> (String)</td>
 * 		<td>
 * 			昇順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 上向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descImage</b> <br/> (String)</td>
 * 		<td>
 * 			降順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 下向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>defaultImage</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック前、および、他のヘッダクリック時に
 * 			ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは ブランク画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="2"><b>header</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			ヘッダの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>className</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>mousedownClassName</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名（マウスダウン時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell_mousedown</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="4"><b>data</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			セルの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>evenClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（偶数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_number_even</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>oddClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（奇数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_number_odd</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>selectedClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（選択時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_number_selected</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>beforeTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>前</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>afterTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>後</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>editable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			セルの編集可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：セルの編集可能<br/>
 * 			falseの場合：セルの編集不可<br/>
 * 			<br/>
 * 			セルをダブルクリックすると、セルの内部がテキストフィールドに切り替わり、編集可能となります。<br/>
 * 			<br/>
 * 			編集を確定するには Enter キーを押下するか、他のセルをクリックします。<br/>
 * 			編集をキャンセルするには Esc キーを押下します。
 *		</td>
 * 		<td>No<br/>デフォルトは false</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>maxlength</b> <br/> (Number)</td>
 * 		<td>
 * 			編集時の入力可能最大桁数<br/>
 * 			<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 入力桁数の制限なし</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>formatter</b> <br/> (Function)</td>
 * 		<td>
 * 			編集の確定処理時に実行される関数。<br/>
 * 			<br/>
 * 			コンフィグオブジェクト<b>「editable」</b>プロパティで
 * 			true が指定されている場合にセルをダブルクリックすると、
 * 			セルの内部がテキストフィールドに切り替わり、編集可能となります。<br/>
 * 			<br/>
 * 			編集中にEnterキーを押下すると編集の確定処理に移行します。<br/>
 * 			<br/>
 * 			編集の確定処理時には、<b>「formatter」</b>で指定した関数が実行され、
 * 			その実行結果がセルに表示されます。<br/>
 * 			「formatter」関数の引数には、編集された内容をparseFloat()で数値変換した値が渡されます。<br/>
 * 			（編集の確定処理は、編集中に他のセルをクリックした際にも発生します）<br/>
 * 			<br/>
 * 			編集キャンセル時には<b>「formatter」</b>で指定した関数は実行され<b>ません</b>。<br/>
 * 			<br/>
 * 			<font color="red"><b>【注意】</b></font>
 * 			<br/>
 * 			<b>「formatter」</b>の実行結果は、表示内容にのみ影響をあたえます。
 * 			つまり、<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得するデータには反映されません。<br/>
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得するデータには、
 * 			編集したデータをparseFloat()で数値変換した値が格納されています。<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 引数に渡された数値を3桁毎にカンマ区切りした文字列を返却する関数</td>
 * 	</tr>
 * </table>
 *
 * <br/>
 * <br/>
 *
 * <h2><a name="StateDiagram">「状態」と「イベントタイプ」の関係</a></h2>
 *
 * 「状態」と「イベントタイプ」の関係（数値用）は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<td bgcolor="lightgrey" colspan="2" rowspan="2"><br/></td>
 * 		<td bgcolor="lightgrey" colspan="3" align="center">状態</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" align="center">Unselect</td>
 * 		<td bgcolor="lightgrey" align="center">Select</td>
 * 		<td bgcolor="lightgrey" align="center">Edit</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" rowspan="8">イベントタイプ</td>
 * 		<td bgcolor="lightgrey">click</td>
 * 		<td>
 * 			<ul>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">dblclick</td>
 * 		<td>
 * 			編集可能の場合
 * 			<ul>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>テキストフィールドを表示</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Edit</b></li>
 * 			</ul>
 * 			編集不可の場合
 * 			<ul>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			編集可能の場合
 * 			<ul>
 * 				<li>テキストフィールドを表示</li>
 * 				<li>次の状態は<b>Edit</b></li>
 * 			</ul>
 * 			編集不可の場合
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 * 		</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">keydown</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			[Enter]キーが押下された場合<br/>
 * 			<ul>
 * 				<li>編集の確定処理を実行。</li>
 * 				具体的には、「Edit」状態の「completeEdit」イベントを起動し、
 * 				その戻り値を次の状態とします。<br/>
 * 			</ul>
 * 			[Esc]キーが押下された場合<br/>
 * 			<ul>
 * 				<li>編集のキャンセル処理を実行。</li>
 * 				具体的には、「Edit」状態の「cancelEdit」イベントを起動し、
 * 				その戻り値を次の状態とします。<br/>
 * 			</ul>
 * 			上記以外<br/>
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">keyup</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseover</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「text」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseout</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			このセルが選択されている場合
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 *
 * 			このセルが選択されていない場合（=このセル以外のセルが選択された場合）
 * 			<ul>
 * 				<li>現在のセルの表示形式を未選択形式に変更</li>
 * 				<li>次の状態は<b>Unselect</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">completeEdit</td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>
 * 			<ul>
 * 				<li>編集の確定処理を実行</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">cancelEdit</td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>
 * 			<ul>
 * 				<li>編集の確定処理を実行</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * </table>
 *
 * <a name="APIListStart"/>
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */

ImSortableTableCell4Number.prototype = new ImSortableTableCell();

/**
 * コンストラクタ。<br/>
 * <br/>
 * <i>開発者が明示的にこのコンストラクタを利用する必要はありません。</i>
 *
 * @class ImSortableTableの数値用セルオブジェクト。<br/>
 * 数値用セルオブジェクトの詳しい説明は、<a href="overview-summary-im_sortable_table_cell_number.js.html">こちら</a>を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 */
function ImSortableTableCell4Number(observer, htmlElement, position, config, data) {

    /**
     * @private
     */
    this.constructor = function(observer, htmlElement, position, config, data){

        this.controlType = "number";
        this.currentState = this.initialState;

        this.observer     = observer;
        this.htmlElement  = htmlElement;
        this.position     = position;
        this.config       = config;
        this.data         = parseFloat(data);

        this.beforeTriggers = this.config.beforeTriggers;
        this.afterTriggers  = this.config.afterTriggers;
    }

    /**
     * @private
     * @override
     */
    this.appendChildElements = function(){
        this.addCachedSelfListeners("click", "dblclick", "keydown", "keyup", "mouseover", "mouseout");
        this.createChildElement();
    }

    /**
     * @private
     * @override
     */
    this.unloadChildElements = function(){
        this.removeCachedSelfListeners();

        this.textElement  = null;
        this.TextNode     = null;
        this.childElement = null;

        this.afterTriggers  = null;
        this.beforeTriggers = null;

        this.data         = null;
        this.config       = null;
        this.position     = null;
        this.htmlElement  = null;
        this.observer     = null;

        this.currentState = null;
        this.controlType  = null;
    }

    /**
     * @private
     */
    this.getTextElement = function(){
        return this.textElement;
    }

    /**
     * @private
     */
    this.createChildElement = function(){

        var formattedData = this.config.formatter(this.data);

        var divElem = document.createElement("div");
        divElem.title = formattedData;
        divElem.style.overflow   = "hidden";
        divElem.style.whiteSpace = "noWrap";

        var textNode = document.createTextNode(formattedData);

        this.childElement = divElem;
        this.TextNode     = textNode;

        this.htmlElement.appendChild(this.childElement);
        this.childElement.appendChild(this.TextNode);

        this.textElement = null;
    }

    /**
     * @private
     * @override
     */
    this.actionTransitionFunctions = {
        Unselect : {
            click : function(event){
                this.observer.setCurrentPosition(event, this.position);
                this.changeStyle2Selected(event);
                return IM_STBL_CELL_STATE.SELECT;
            },

            dblclick : function(event){
                if(this.config.editable == true){
                    this.observer.setCurrentPosition(event, this.position);
                    this.observer.isEditing = true;
                    this.changeControlType2Editable();
                    this.changeStyle2Selected(event);
                    return IM_STBL_CELL_STATE.EDIT;
                }
                else{
                    this.observer.setCurrentPosition(event, this.position);
                    this.changeStyle2Selected(event);
                    return IM_STBL_CELL_STATE.SELECT;
                }
            },

            keydown : function(event){
                return this.currentState;
            },

            keyup : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                return this.currentState;
            },

            completeEdit : function(event){
                return this.currentState;
            },

            cancelEdit : function(event){
                return this.currentState;
            }
        },

        Select : {
            click : function(event){
                return this.currentState;
            },

            dblclick : function(event){
                if(this.config.editable == true){
                    this.observer.isEditing = true;
                    this.changeControlType2Editable();
                    return IM_STBL_CELL_STATE.EDIT;
                }
                else{
                    return this.currentState;
                }
            },

            keydown : function(event){
                return this.currentState;
            },

            keyup : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                if(this.observer.isSelectedPosition(this.position)){
                    return this.currentState;
                }
                else{
                    this.changeStyle2Unselected(event);
                    return IM_STBL_CELL_STATE.UN_SELECT;
                }
            },

            completeEdit : function(event){
                return this.currentState;
            },

            cancelEdit : function(event){
                return this.currentState;
            }
        },

        Edit : {
            click : function(event){
                return this.currentState;
            },

            dblclick : function(event){
                return this.currentState;
            },

            keydown : function(event){
                // [Enter]
                if(event.keyCode == 13){
                    return this.doActionTransition(IM_STBL_CELL_STATE.EDIT, "completeEdit", event);
                }
                // [Esc]
                if(event.keyCode == 27){
                    return this.doActionTransition(IM_STBL_CELL_STATE.EDIT, "cancelEdit", event);
                }
                else{
                    return this.currentState;
                }

            },

            keyup : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "text";
                return this.currentState;
            },

            mouseout : function(event){
                return this.currentState;
            },

            completeEdit : function(event){
                this.completeEditAction();
                this.observer.isEditing = false;
                this.changeStyle2Selected(event);
                return IM_STBL_CELL_STATE.SELECT;
            },

            cancelEdit : function(event){
                this.cancelEditAction();
                this.observer.isEditing = false;
                this.changeStyle2Selected(event);
                return IM_STBL_CELL_STATE.SELECT;
                }
            }
        }

    /**
     * @private
     */
    this.changeControlType2Editable = function(){
        var elementId = this.htmlElement.id + this.controlType + "INPUT_ELEMENT";

        while(this.childElement.hasChildNodes()){
            this.childElement.removeChild(this.childElement.firstChild);
        }

        var textElem = document.createElement("input");
        textElem.id = elementId;
        textElem.setAttribute("type", "text");
        textElem.setAttribute("value", this.data);
        textElem.style.width = "100%";

        if(this.config.maxlength != null && this.config.maxlength != undefined){
            textElem.setAttribute("maxlength", this.config.maxlength);
        }

        this.childElement.appendChild(textElem);
        textElem.focus();

        this.textElement = textElem;
    }

    /**
     * @private
     *
     * Example :
     * +------------+------------+---------------+
     * | Edited     | this.data  |   Display     |
     * |    Value   |            |       Value   |
     * +------------+------------+---------------+
     * | NaN        | NaN        | NaN           |
     * | 123        | 123        | 123           |
     * | 12345      | 12345      | 12,345        |
     * | -123456    | -123456    | -123,456      |
     * | 1.23       | 1.23       | 1.23          |
     * | 1234.5678  | 1234.5678  | 1,234.5678    |
     * | 1.23e6     | 1230000    | 1,230,000     |
     * | 1.23E6     | 1230000    | 1,230,000     |
     * | 1234.5e6   | 1234500000 | 1,234,500,000 |
     * +------------+------------+---------------+
     *
     * Illegal case
     * +------------+------------+---------------+
     * | Edited     | this.data  |   Display     |
     * |    Value   |            |       Value   |
     * +------------+------------+---------------+
     * | 07777      | 7777       | 7,777         |
     * | -07777     | -7777      | -7,777        |
     * | 0x8888     | 0          | 0             |
     * | 1a.2       | 1          | 1             |
     * | a1.2       | NaN        | NaN           |
     * | -1234,5678 | -1234      | -1,234        |
     * +------------+------------+---------------+
     * (It doesn't correspond to the character string that shows the constant. (ex. Number.MAX_VALUE))
     */
    this.completeEditAction = function(){
        var elementId = this.htmlElement.id + this.controlType + "INPUT_ELEMENT";

        var elem = document.getElementById(elementId);
        this.updateCellData(parseFloat(elem.value)); // CONVERT INTO NUMBER

        this.htmlElement.removeChild(this.childElement);
        this.childElement = null;

        this.createChildElement();
    }

    /**
     * @private
     */
    this.cancelEditAction = function(){
        this.htmlElement.removeChild(this.childElement);
        this.childElement = null;

        this.createChildElement();
    }

    // Construct instance
    this.constructor(observer, htmlElement, position, config, data);

}

/**
 * ImSortableTableのデフォルトコンフィグオブジェクトを生成します（数値用）。
 *
 * @param {String} argId 列を識別するためのID
 * @param {String} argName [option] ヘッダに表示される文字列（任意）
 * @param {Number} argWidth [option] 列の幅（任意）
 * @return デフォルト値を格納したImSortableTableの<a href="overview-summary-im_sortable_table_cell_number.js.html#ConfigObject">数値用コンフィグオブジェクト</a>
 * @type Object
 */
ImSortableTableCell4Number.createDefaultConfig = function(argId, argName, argWidth){

    var defaultConfig = {
        type           : "number",
        id             : (argId    != null && argId    != undefined) ? argId    : null,
        name           : (argName  != null && argName  != undefined) ? argName  : "",
        width          : (argWidth != null && argWidth != undefined) ? argWidth : "",
        visible        : true,
        sortable       : true,
        sorter         : {
                            sortDirection : IM_STBL_CONFIG_KEY.ASC,
                            ascFunction   : ImSortableTableCell4Text.defaultAscFunction,
                            descFunction  : ImSortableTableCell4Text.defaultDescFunction,
                            ascImage      : IM_STBL_CELL_SORT_ASC_IMG,
                            descImage     : IM_STBL_CELL_SORT_DESC_IMG,
                            defaultImage  : IM_STBL_CELL_SORT_DEFAULT_IMG
                         },
        header         : {
                            height             : "",
                            className          : "im_sortable_table_header_cell",
                            mousedownClassName : "im_sortable_table_header_cell_mousedown"
                         },
        data           : {
                            height            : "",
                            evenClassName     : "im_sortable_table_data_cell_number_even",
                            oddClassName      : "im_sortable_table_data_cell_number_odd",
                            selectedClassName : "im_sortable_table_data_cell_number_selected"
                         },
        beforeTriggers : [],
        afterTriggers  : [],

        // OTHER CONFIG
        editable  : false,                                      // true = editable, false = uneditable
        maxlength : null,                                       // maxlength
        formatter : ImSortableTableCell4Number.defaultFormatter // Formatter Function

    };

    return defaultConfig;

}

/**
 * @private
 *
 * This function delimits the character string by the comma every three digits.
 *
 * Example :
 * +-----------+------------+
 * |   Input   |   Output   |
 * +-----------+------------+
 * | NaN       | NaN        |
 * | 123       | 123        |
 * | 12345     | 12,345     |
 * | -123456   | -123,456   |
 * | 1.23      | 1.23       |
 * | 1234.5678 | 1,234.5678 |
 * | 1.23e6    | 1.23e6     |
 * | 1.23E6    | 1.23E6     |
 * | 1234.5e6  | 1,234.5e6  |
 * | 07777     | 07777      |
 * | -07777    | -07777     |
 * | 0x8888    | 0x8888     |
 * +-----------+------------+
 *
 * Illegal case
 * +------------+-------------+
 * |   Input    |    Output   |
 * +------------+-------------+
 * | 1a.2       | 1a.2        |
 * | a1.2       | a1.2        |
 * | -1234,5678 | -12,345,678 |
 * +------------+-------------+
 */
ImSortableTableCell4Number.defaultFormatter = function(editedValue){
    var num = new String(editedValue).replace(/,/g, "");
    if( ( num.length > 0 )
        &&
        ( num.indexOf("0") != 0 )
        &&
        (num.indexOf("-0") != 0 ) ){
        while( num != (num = num.replace(/^(-?\d+)(\d{3})/, "$1,$2")) );
    }
    return num;
}

/**
 * @private
 */
ImSortableTableCell4Number.defaultAscFunction = function(a, b){
    var aCol = a[IM_STBL_SORT_TARGET_IDX] - 0;
    var bCol = b[IM_STBL_SORT_TARGET_IDX] - 0;

    if(aCol == bCol){
        return 0;
    }
    else if(aCol > bCol){
        return 1;
    }
    else{
        return -1;
    }
}

/**
 * @private
 */
ImSortableTableCell4Number.defaultDescFunction = function(a, b){
    var bCol = b[IM_STBL_SORT_TARGET_IDX] - 0;
    var aCol = a[IM_STBL_SORT_TARGET_IDX] - 0;

    if(bCol == aCol){
        return 0;
    }
    else if(bCol > aCol){
        return 1;
    }
    else{
        return -1;
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table_cell_radio.js

概要

ImSortableTableのラジオボタン用セルオブジェクトです。

  • コンフィグオブジェクトの構成
  • 「状態」と「イベントタイプ」の関係
  • メソッドの概要

コンフィグオブジェクトの構成

ImSortableTableのコンフィグオブジェクト（ラジオボタン用）の構成は以下の通りです。
プロパティ (型) |  | 説明 | 必須
type (String) |  | 列のフォーマットタイプ。 ラジオボタンの場合は、文字列「radio」固定です。 | Yes (文字列「radio」を指定してください)
id (String) |  | 列を識別するためのID。 このIDが、データセット時のオブジェクトのプロパティ名となります。 | Yes
name (String) |  | ヘッダに表示される文字列 | No デフォルトは 空文字
width (Number) |  | 列の幅 | No デフォルトは 未設定
visible (Boolean) |  | 列の表示・非表示。 trueの場合 ：列を表示 falseの場合：列を非表示 なお、列を非表示にした場合でも、データの取得は可能です。 例えば、「コード」と「名前」を保持するオブジェクトに関して、 「名前」だけを表示するSortableテーブルを作成した際、 ImSortableTable#getData()で取得できるデータには、非表示である「コード」も含まれます。 | No デフォルトは true
sortable (Boolean) |  | ソートの可・不可。 trueの場合 ：ソート可能 falseの場合：ソート不可 | No デフォルトは true
sorter (Object) | sortDirection (String) | ヘッダの初回クリック時のソート方向。 （ヘッダをクリックするごとに、この値は反転します） この値は以下の定数で指定してください。 昇順の場合：IM_STBL_CONFIG_KEY.ASC 降順の場合：IM_STBL_CONFIG_KEY.DESC | No デフォルトは IM_STBL_CONFIG_KEY.ASC
 | ascFunction (Function) | 昇順ソート時のソート関数 | No デフォルトは Booleanの昇順ソート関数
 | descFunction (Function) | 降順ソート時のソート関数 | No デフォルトは Booleanの降順ソート関数
 | ascImage (String) | 昇順ソート後、ヘッダに表示される画像のURL | No デフォルトは 上向き矢印画像のURL
 | descImage (String) | 降順ソート後、ヘッダに表示される画像のURL | No デフォルトは 下向き矢印画像のURL
 | defaultImage (String) | ヘッダの初回クリック前、および、他のヘッダクリック時に ヘッダに表示される画像のURL | No デフォルトは ブランク画像のURL
header (Object) | height (Number) | ヘッダの高さ | No デフォルトは 未設定
 | className (String) | ヘッダのCSSクラス名 | No デフォルトは im_sortable_table_header_cell
mousedownClassName (String) | ヘッダのCSSクラス名（マウスダウン時） | No デフォルトは im_sortable_table_header_cell_mousedown
data (Object) | height (Number) | セルの高さ | No デフォルトは 未設定
 | evenClassName (String) | セルのCSSクラス名（偶数行） | No デフォルトは im_sortable_table_data_cell_even
 | oddClassName (String) | セルのCSSクラス名（奇数行） | No デフォルトは im_sortable_table_data_cell_odd
 | selectedClassName (String) | セルのCSSクラス名（選択時） | No デフォルトは im_sortable_table_data_cell_selected
beforeTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の前に実行されます。 | No デフォルトは 未設定
afterTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の後に実行されます。 | No デフォルトは 未設定

「状態」と「イベントタイプ」の関係

「状態」と「イベントタイプ」の関係（ラジオボタン用）は以下の通りです。

 状態
Unselect Select
イベントタイプ click
  • ラジオボタンをチェックする
  • このセルを現在選択中のポジションに変更
  • このセル以外のラジオボタンを非チェック状態に変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
  • ラジオボタンをチェックする
  • このセル以外のラジオボタンを非チェック状態に変更
  • 次の状態はSelect
keydown -
(何も行いません) 		[Space]キーが押下された場合
  • ラジオボタンをチェックする
  • このセル以外のラジオボタンを非チェック状態に変更
  • 状態は変化無し
上記以外
  • 何も行いません。
mouseover
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
mouseout -
(何も行いません) 		このセルが選択されている場合
  • 何も行いません。
このセルが選択されていない場合（=このセル以外のセルが選択された場合）
  • 現在のセルの表示形式を未選択形式に変更
  • 次の状態はUnselect

Version: 1.0

Author: INTRAMART

クラスの概要
ImSortableTableCell4Radio ImSortableTableのラジオボタン用セルオブジェクト。
/**
 * @fileoverview ImSortableTableのラジオボタン用セルオブジェクトです。<br/>
 * <br/>
 *
 * <ul>
 * 	<li><a href="#ConfigObject">コンフィグオブジェクトの構成</a></li>
 * 	<li><a href="#StateDiagram">「状態」と「イベントタイプ」の関係</a></li>
 * 	<li><a href="ImSortableTableCell4Radio.html">メソッドの概要</a></li>
 * </ul>
 *
 * <h2><a name="ConfigObject">コンフィグオブジェクトの構成</a></h2>
 *
 * ImSortableTableのコンフィグオブジェクト（ラジオボタン用）の構成は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<th colspan="2">プロパティ (型)</th>
 * 		<th>説明</th>
 * 		<th>必須</th>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>type</b> <br/> (String)</td>
 * 		<td>
 * 			列のフォーマットタイプ。<br/>
 * 			ラジオボタンの場合は、文字列「radio」固定です。
 *		</td>
 * 		<td>Yes<br/>(文字列「radio」を指定してください)</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>id</b> <br/> (String)</td>
 * 		<td>
 * 			列を識別するためのID。<br/>
 * 			このIDが、データセット時のオブジェクトのプロパティ名となります。
 *		</td>
 * 		<td>Yes</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>name</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダに表示される文字列<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 空文字</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>width</b> <br/> (Number)</td>
 * 		<td>
 * 			列の幅<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>visible</b> <br/> (Boolean)</td>
 * 		<td>
 * 			列の表示・非表示。<br/>
 * 			<br/>
 * 			trueの場合 ：列を表示<br/>
 * 			falseの場合：列を非表示<br/>
 * 			<br/>
 * 			なお、列を非表示にした場合でも、データの取得は可能です。<br/>
 * 			例えば、「コード」と「名前」を保持するオブジェクトに関して、
 * 			「名前」だけを表示するSortableテーブルを作成した際、
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得できるデータには、非表示である「コード」も含まれます。
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>sortable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			ソートの可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：ソート可能<br/>
 * 			falseの場合：ソート不可<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="6"><b>sorter</b> <br/> (Object)</td>
 * 		<td><b>sortDirection</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック時のソート方向。<br/>
 * 			（ヘッダをクリックするごとに、この値は反転します）<br/>
 * 			この値は以下の定数で指定してください。<br/>
 * 			<br/>
 * 			昇順の場合：<b>IM_STBL_CONFIG_KEY.ASC </b><br/>
 * 			降順の場合：<b>IM_STBL_CONFIG_KEY.DESC</b><br/>
 *		</td>
 * 		<td>No<br/>デフォルトは IM_STBL_CONFIG_KEY.ASC</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			昇順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは Booleanの昇順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			降順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは Booleanの降順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascImage</b> <br/> (String)</td>
 * 		<td>
 * 			昇順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 上向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descImage</b> <br/> (String)</td>
 * 		<td>
 * 			降順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 下向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>defaultImage</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック前、および、他のヘッダクリック時に
 * 			ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは ブランク画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="2"><b>header</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			ヘッダの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>className</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>mousedownClassName</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名（マウスダウン時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell_mousedown</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="4"><b>data</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			セルの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>evenClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（偶数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_even</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>oddClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（奇数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_odd</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>selectedClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（選択時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_selected</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>beforeTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>前</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>afterTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>後</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * </table>
 *
 *
 * <br/>
 * <br/>
 *
 * <h2><a name="StateDiagram">「状態」と「イベントタイプ」の関係</a></h2>
 * 「状態」と「イベントタイプ」の関係（ラジオボタン用）は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<td bgcolor="lightgrey" colspan="2" rowspan="2"><br/></td>
 * 		<td bgcolor="lightgrey" colspan="3" align="center">状態</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" align="center">Unselect</td>
 * 		<td bgcolor="lightgrey" align="center">Select</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" rowspan="8">イベントタイプ</td>
 * 		<td bgcolor="lightgrey">click</td>
 * 		<td>
 * 			<ul>
 * 				<li>ラジオボタンをチェックする</li>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>このセル以外のラジオボタンを非チェック状態に変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>ラジオボタンをチェックする</li>
 * 				<li>このセル以外のラジオボタンを非チェック状態に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">keydown</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			[Space]キーが押下された場合<br/>
 * 			<ul>
 * 				<li>ラジオボタンをチェックする</li>
 * 				<li>このセル以外のラジオボタンを非チェック状態に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 			上記以外<br/>
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseover</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseout</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			このセルが選択されている場合
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 *
 * 			このセルが選択されていない場合（=このセル以外のセルが選択された場合）
 * 			<ul>
 * 				<li>現在のセルの表示形式を未選択形式に変更</li>
 * 				<li>次の状態は<b>Unselect</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * </table>
 *
 * <a name="APIListStart"/>
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */
var IM_STBL_CELL_RADIO_ON_IMG  = IM_STBL_CONTEXT_PATH + "/images/sortable_table/radio_on.gif";
var IM_STBL_CELL_RADIO_OFF_IMG = IM_STBL_CONTEXT_PATH + "/images/sortable_table/radio_off.gif";

ImSortableTableCell4Radio.prototype = new ImSortableTableCell();

/**
 * コンストラクタ。<br/>
 * <br/>
 * <i>開発者が明示的にこのコンストラクタを利用する必要はありません。</i>
 *
 * @class ImSortableTableのラジオボタン用セルオブジェクト。<br/>
 * ラジオボタン用セルオブジェクトの詳しい説明は、<a href="overview-summary-im_sortable_table_cell_radio.js.html">こちら</a>を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 * <br/>
 * 表示されているラジオボタンのチェック状態を変更するには、
 * <a href="ImSortableTable.html#setCheckedRadioPosition">ImSortableTable#setCheckedRadioPosition(Object position)</a>
 * を利用してください。<br/>
 *
 * @constructor
 */
function ImSortableTableCell4Radio(observer, htmlElement, position, config, data) {

    /**
     * @private
     */
    this.constructor = function(observer, htmlElement, position, config, data){

        this.controlType = "radio";
        this.currentState = this.initialState;

        this.observer    = observer;
        this.htmlElement = htmlElement;
        this.position    = position;
        this.config      = config;
        this.data        = data;

        this.beforeTriggers = this.config.beforeTriggers;
        this.afterTriggers  = this.config.afterTriggers;
    }

    /**
     * @private
     * @override
     */
    this.appendChildElements = function(){
        this.addCachedSelfListeners("click", "keydown", "mouseover", "mouseout");
        this.createChildElement();

        if(this.data == true){
            this.observer.setCheckedRadioPosition(this.position);
        }
    }

    /**
     * @private
     * @override
     */
    this.unloadChildElements = function(){
        this.removeCachedSelfListeners();

        this.radioImgElement = null;

        this.afterTriggers  = null;
        this.beforeTriggers = null;

        this.data         = null;
        this.config       = null;
        this.position     = null;
        this.htmlElement  = null;
        this.observer     = null;

        this.currentState = null;
        this.controlType  = null;
    }

    /**
     * @private
     */
    this.createChildElement = function(){
        var imgElem;

        var elemId  = this.htmlElement.id + this.controlType;
        var elemSrc = (this.data == true) ? IM_STBL_CELL_RADIO_ON_IMG : IM_STBL_CELL_RADIO_OFF_IMG;

        if(ImSortableTable.Browser.IE){
            imgElem = document.createElement('<img id="'  + elemId  + '" ' +
                                                  'src="' + elemSrc + '">');
        }
        else{
            imgElem = document.createElement("img");
            imgElem.id = elemId;
            imgElem.setAttribute("src", elemSrc);
        }

        this.radioImgElement = imgElem;
        this.htmlElement.appendChild(this.radioImgElement);
    }

    /**
     * @private
     * @override
     */
    this.actionTransitionFunctions = {
        Unselect : {
            click : function(event){
                if(this.isSameThisAndEventTarget(event)){
                    return this.currentState;
                }
                else{
                    this.observer.setCurrentPosition(event, this.position);
                    this.observer.setCheckedRadioPosition(this.position);
                    this.changeStyle2Selected(event);
                    return IM_STBL_CELL_STATE.SELECT;
                }
            },

            keydown : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                return this.currentState;
            }

        },

        Select : {
            click : function(event){
                if(this.isSameThisAndEventTarget(event)){
                    return this.currentState;
                }
                else{
                    this.observer.setCheckedRadioPosition(this.position);
                    return this.currentState;
                }
            },

            keydown : function(event){
                // [Space]
                if(event.keyCode == 32){
                    this.observer.setCheckedRadioPosition(this.position);
                }
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                if(this.observer.isSelectedPosition(this.position)){
                    return this.currentState;
                }
                else{
                    this.changeStyle2Unselected(event);
                    return IM_STBL_CELL_STATE.UN_SELECT;
                }
            }

        }
    }

    /**
     * @private
     */
    this.isSameThisAndEventTarget = function(event) {
        var target = (event.srcElement||event.target);

        if(this.htmlElement.id == target.id){
            return true;
        }
        else{
            return false;
        }
    }

    /**
     * @private
     */
    this.revreseCheckedStatus = function() {
        if(this.data == true){
            this.radioImgElement.src = IM_STBL_CELL_RADIO_OFF_IMG;
            this.updateCellData(false);
        }
        else{
            this.radioImgElement.src = IM_STBL_CELL_RADIO_ON_IMG;
            this.updateCellData(true);
        }
    }

    /**
     * @private
     */
    this.updateCheckedStatus = function(checkedStatus){
        if(checkedStatus == true){
            this.radioImgElement.src = IM_STBL_CELL_RADIO_ON_IMG;
            this.updateCellData(true);
        }
        else{
            this.radioImgElement.src = IM_STBL_CELL_RADIO_OFF_IMG;
            this.updateCellData(false);
        }
    }

    // Construct instance
    this.constructor(observer, htmlElement, position, config, data);
}

/**
 * ImSortableTableのデフォルトコンフィグオブジェクトを生成します（ラジオボタン用）。
 *
 * @param {String} id 列を識別するためのID
 * @param {String} name [option] ヘッダに表示される文字列（任意）
 * @param {Number} width [option] 列の幅（任意）
 * @return デフォルト値を格納したImSortableTableの<a href="overview-summary-im_sortable_table_cell_radio.js.html#ConfigObject">ラジオボタン用コンフィグオブジェクト</a>
 * @type Object
 */
ImSortableTableCell4Radio.createDefaultConfig = function(argId, argName, argWidth){

    var defaultConfig = {
        type           : "radio",
        id             : (argId    != null && argId    != undefined) ? argId    : null,
        name           : (argName  != null && argName  != undefined) ? argName  : "",
        width          : (argWidth != null && argWidth != undefined) ? argWidth : "",
        visible        : true,
        sortable       : true,
        sorter         : {
                            sortDirection : IM_STBL_CONFIG_KEY.ASC,
                            ascFunction   : ImSortableTableCell4Radio.defaultAscFunction,
                            descFunction  : ImSortableTableCell4Radio.defaultDescFunction,
                            ascImage      : IM_STBL_CELL_SORT_ASC_IMG,
                            descImage     : IM_STBL_CELL_SORT_DESC_IMG,
                            defaultImage  : IM_STBL_CELL_SORT_DEFAULT_IMG
                         },
        header         : {
                            height             : "",
                            className          : "im_sortable_table_header_cell",
                            mousedownClassName : "im_sortable_table_header_cell_mousedown"
                         },
        data           : {
                            height            : "",
                            evenClassName     : "im_sortable_table_data_cell_even",
                            oddClassName      : "im_sortable_table_data_cell_odd",
                            selectedClassName : "im_sortable_table_data_cell_selected"
                         },
        beforeTriggers : [],
        afterTriggers  : []
    };

    return defaultConfig;

}

/**
 * @private
 */
ImSortableTableCell4Radio.defaultAscFunction = function(a, b){
    var aCol = a[IM_STBL_SORT_TARGET_IDX];
    var bCol = b[IM_STBL_SORT_TARGET_IDX];

    if(aCol == bCol){
        return 0;
    }
    else if(aCol > bCol){
        return 1;
    }
    else{
        return -1;
    }
}

/**
 * @private
 */
ImSortableTableCell4Radio.defaultDescFunction = function(a, b){
    var bCol = b[IM_STBL_SORT_TARGET_IDX];
    var aCol = a[IM_STBL_SORT_TARGET_IDX];

    if(bCol == aCol){
        return 0;
    }
    else if(bCol > aCol){
        return 1;
    }
    else{
        return -1;
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_sortable_table_cell_text.js

概要

ImSortableTableのテキスト用セルオブジェクトです。

  • コンフィグオブジェクトの構成
  • 「状態」と「イベントタイプ」の関係
  • メソッドの概要

コンフィグオブジェクトの構成

ImSortableTableのコンフィグオブジェクト（テキスト用）の構成は以下の通りです。
プロパティ (型) |  | 説明 | 必須
type (String) |  | 列のフォーマットタイプ。 テキストの場合は、文字列「text」固定です。 | Yes (文字列「text」を指定してください)
id (String) |  | 列を識別するためのID。 このIDが、データセット時のオブジェクトのプロパティ名となります。 | Yes
name (String) |  | ヘッダに表示される文字列 | No デフォルトは 空文字
width (Number) |  | 列の幅 | No デフォルトは 未設定
visible (Boolean) |  | 列の表示・非表示。 trueの場合 ：列を表示 falseの場合：列を非表示 なお、列を非表示にした場合でも、データの取得は可能です。 例えば、「コード」と「名前」を保持するオブジェクトに関して、 「名前」だけを表示するSortableテーブルを作成した際、 ImSortableTable#getData()で取得できるデータには、非表示である「コード」も含まれます。 | No デフォルトは true
sortable (Boolean) |  | ソートの可・不可。 trueの場合 ：ソート可能 falseの場合：ソート不可 | No デフォルトは true
sorter (Object) | sortDirection (String) | ヘッダの初回クリック時のソート方向。 （ヘッダをクリックするごとに、この値は反転します） この値は以下の定数で指定してください。 昇順の場合：IM_STBL_CONFIG_KEY.ASC 降順の場合：IM_STBL_CONFIG_KEY.DESC | No デフォルトは IM_STBL_CONFIG_KEY.ASC
 | ascFunction (Function) | 昇順ソート時のソート関数 | No デフォルトは 文字列の昇順ソート関数
 | descFunction (Function) | 降順ソート時のソート関数 | No デフォルトは 文字列の降順ソート関数
 | ascImage (String) | 昇順ソート後、ヘッダに表示される画像のURL | No デフォルトは 上向き矢印画像のURL
 | descImage (String) | 降順ソート後、ヘッダに表示される画像のURL | No デフォルトは 下向き矢印画像のURL
 | defaultImage (String) | ヘッダの初回クリック前、および、他のヘッダクリック時に ヘッダに表示される画像のURL | No デフォルトは ブランク画像のURL
header (Object) | height (Number) | ヘッダの高さ | No デフォルトは 未設定
 | className (String) | ヘッダのCSSクラス名 | No デフォルトは im_sortable_table_header_cell
mousedownClassName (String) | ヘッダのCSSクラス名（マウスダウン時） | No デフォルトは im_sortable_table_header_cell_mousedown
data (Object) | height (Number) | セルの高さ | No デフォルトは 未設定
 | evenClassName (String) | セルのCSSクラス名（偶数行） | No デフォルトは im_sortable_table_data_cell_text_even
 | oddClassName (String) | セルのCSSクラス名（奇数行） | No デフォルトは im_sortable_table_data_cell_text_odd
 | selectedClassName (String) | セルのCSSクラス名（選択時） | No デフォルトは im_sortable_table_data_cell_text_selected
beforeTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の前に実行されます。 | No デフォルトは 未設定
afterTriggers (Array) |  | トリガーオブジェクトを格納した配列。 ここで登録されたトリガーは、イベント処理の後に実行されます。 | No デフォルトは 未設定
editable (Boolean) |  | セルの編集可・不可。 trueの場合 ：セルの編集可能 falseの場合：セルの編集不可 セルをダブルクリックすると、セルの内部がテキストフィールドに切り替わり、編集可能となります。 編集を確定するには Enter キーを押下するか、他のセルをクリックします。 編集をキャンセルするには Esc キーを押下します。 | No デフォルトは false
maxlength (Number) |  | 編集時の入力可能最大文字数 | No デフォルトは 入力文字数の制限なし
formatter (Function) |  | 編集の確定処理時に実行される関数。 コンフィグオブジェクト「editable」プロパティで true が指定されている場合にセルをダブルクリックすると、 セルの内部がテキストフィールドに切り替わり、編集可能となります。 編集中にEnterキーを押下すると編集の確定処理に移行します。 編集の確定処理時には、「formatter」で指定した関数が実行され、 その実行結果がセルに表示されます。 「formatter」関数の引数には、編集されたテキストの内容が渡されます。 （編集の確定処理は、編集中に他のセルをクリックした際にも発生します） 編集キャンセル時には「formatter」で指定した関数は実行されません。 【注意】 「formatter」の実行結果は、表示内容にのみ影響をあたえます。 つまり、ImSortableTable#getData()で取得するデータには反映されません。 ImSortableTable#getData()で取得するデータには、編集したデータがそのまま格納されています。 （なお、ImSortableTable#getData()で取得したデータをそのまま利用する場合は、 セキュリティ上の危険があることに留意してください。 このデータをそのままinnerHTMLに設定する、または、eval()を実行する等を行う場合は、 データ内に不正な記述が含まれていないかのチェックや、データのエスケープ処理の実施をお勧めします） | No デフォルトは 編集されたテキストの内容をそのまま返却する関数

「状態」と「イベントタイプ」の関係

「状態」と「イベントタイプ」の関係（テキスト用）は以下の通りです。

 状態
Unselect Select Edit
イベントタイプ click
  • このセルを現在選択中のポジションに変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
 -
(何も行いません) 		-
(何も行いません)
dblclick 編集可能の場合
  • このセルを現在選択中のポジションに変更
  • テキストフィールドを表示
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はEdit
編集不可の場合
  • このセルを現在選択中のポジションに変更
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
 編集可能の場合
  • テキストフィールドを表示
  • 次の状態はEdit
編集不可の場合
  • 何も行いません。
 -
(何も行いません)
keydown -
(何も行いません) 		-
(何も行いません) 		[Enter]キーが押下された場合
  • 編集の確定処理を実行。
    • 具体的には、「Edit」状態の「completeEdit」イベントを起動し、 その戻り値を次の状態とします。
[Esc]キーが押下された場合
  • 編集のキャンセル処理を実行。
    • 具体的には、「Edit」状態の「cancelEdit」イベントを起動し、 その戻り値を次の状態とします。
上記以外
  • 何も行いません。
keyup -
(何も行いません) 		-
(何も行いません) 		-
(何も行いません)
mouseover
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
  • カーソルスタイルを「default」に変更
  • 状態は変化無し
  • カーソルスタイルを「text」に変更
  • 状態は変化無し
mouseout -
(何も行いません) 		このセルが選択されている場合
  • 何も行いません。
このセルが選択されていない場合（=このセル以外のセルが選択された場合）
  • 現在のセルの表示形式を未選択形式に変更
  • 次の状態はUnselect
 -
(何も行いません)
completeEdit ×
（このイベントは発生しません） 		×
（このイベントは発生しません）
  • 編集の確定処理を実行
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect
cancelEdit ×
（このイベントは発生しません） 		×
（このイベントは発生しません）
  • 編集の確定処理を実行
  • 現在のセルの表示形式を選択中形式に変更
  • 次の状態はSelect

Version: 1.0

Author: INTRAMART

クラスの概要
ImSortableTableCell4Text ImSortableTableのテキスト用セルオブジェクト。
/**
 * @fileoverview ImSortableTableのテキスト用セルオブジェクトです。<br/>
 * <br/>
 *
 * <ul>
 * 	<li><a href="#ConfigObject">コンフィグオブジェクトの構成</a></li>
 * 	<li><a href="#StateDiagram">「状態」と「イベントタイプ」の関係</a></li>
 * 	<li><a href="ImSortableTableCell4Text.html">メソッドの概要</a></li>
 * </ul>
 *
 * <h2><a name="ConfigObject">コンフィグオブジェクトの構成</a></h2>
 *
 * ImSortableTableのコンフィグオブジェクト（テキスト用）の構成は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<th colspan="2">プロパティ (型)</th>
 * 		<th>説明</th>
 * 		<th>必須</th>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>type</b> <br/> (String)</td>
 * 		<td>
 * 			列のフォーマットタイプ。<br/>
 * 			テキストの場合は、文字列「text」固定です。
 *		</td>
 * 		<td>Yes<br/>(文字列「text」を指定してください)</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>id</b> <br/> (String)</td>
 * 		<td>
 * 			列を識別するためのID。<br/>
 * 			このIDが、データセット時のオブジェクトのプロパティ名となります。
 *		</td>
 * 		<td>Yes</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>name</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダに表示される文字列<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 空文字</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>width</b> <br/> (Number)</td>
 * 		<td>
 * 			列の幅<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>visible</b> <br/> (Boolean)</td>
 * 		<td>
 * 			列の表示・非表示。<br/>
 * 			<br/>
 * 			trueの場合 ：列を表示<br/>
 * 			falseの場合：列を非表示<br/>
 * 			<br/>
 * 			なお、列を非表示にした場合でも、データの取得は可能です。<br/>
 * 			例えば、「コード」と「名前」を保持するオブジェクトに関して、
 * 			「名前」だけを表示するSortableテーブルを作成した際、
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得できるデータには、非表示である「コード」も含まれます。
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>sortable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			ソートの可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：ソート可能<br/>
 * 			falseの場合：ソート不可<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは true</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="6"><b>sorter</b> <br/> (Object)</td>
 * 		<td><b>sortDirection</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック時のソート方向。<br/>
 * 			（ヘッダをクリックするごとに、この値は反転します）<br/>
 * 			この値は以下の定数で指定してください。<br/>
 * 			<br/>
 * 			昇順の場合：<b>IM_STBL_CONFIG_KEY.ASC </b><br/>
 * 			降順の場合：<b>IM_STBL_CONFIG_KEY.DESC</b><br/>
 *		</td>
 * 		<td>No<br/>デフォルトは IM_STBL_CONFIG_KEY.ASC</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			昇順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは 文字列の昇順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descFunction</b> <br/> (Function)</td>
 * 		<td>
 * 			降順ソート時のソート関数<br/>
 *		</td>
 * 		<td>No<br/> デフォルトは 文字列の降順ソート関数</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>ascImage</b> <br/> (String)</td>
 * 		<td>
 * 			昇順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 上向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>descImage</b> <br/> (String)</td>
 * 		<td>
 * 			降順ソート後、ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 下向き矢印画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>defaultImage</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダの初回クリック前、および、他のヘッダクリック時に
 * 			ヘッダに表示される画像のURL<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは ブランク画像のURL</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="2"><b>header</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			ヘッダの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>className</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>mousedownClassName</b> <br/> (String)</td>
 * 		<td>
 * 			ヘッダのCSSクラス名（マウスダウン時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_header_cell_mousedown</td>
 * 	</tr>
 * 	<tr>
 * 		<td rowspan="4"><b>data</b> <br/> (Object)</td>
 * 		<td><b>height</b> <br/> (Number)</td>
 * 		<td>
 * 			セルの高さ<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>evenClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（偶数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_text_even</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>oddClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（奇数行）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_text_odd</td>
 * 	</tr>
 * 	<tr>
 * 		<td><b>selectedClassName</b> <br/> (String)</td>
 * 		<td>
 * 			セルのCSSクラス名（選択時）
 *		</td>
 * 		<td>No<br/>デフォルトは im_sortable_table_data_cell_text_selected</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>beforeTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>前</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>afterTriggers</b> <br/> (Array)</td>
 * 		<td>
 * 			<a href="ImSortableTable_SUMMARY.html#TriggerObject">トリガーオブジェクト</a>を格納した配列。
 * 			ここで登録されたトリガーは、イベント処理の<b>後</b>に実行されます。
 *		</td>
 * 		<td>No<br/>デフォルトは 未設定</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>editable</b> <br/> (Boolean)</td>
 * 		<td>
 * 			セルの編集可・不可。<br/>
 * 			<br/>
 * 			trueの場合 ：セルの編集可能<br/>
 * 			falseの場合：セルの編集不可<br/>
 * 			<br/>
 * 			セルをダブルクリックすると、セルの内部がテキストフィールドに切り替わり、編集可能となります。<br/>
 * 			<br/>
 * 			編集を確定するには Enter キーを押下するか、他のセルをクリックします。<br/>
 * 			編集をキャンセルするには Esc キーを押下します。
 *		</td>
 * 		<td>No<br/>デフォルトは false</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>maxlength</b> <br/> (Number)</td>
 * 		<td>
 * 			編集時の入力可能最大文字数<br/>
 * 			<br/>
 *		</td>
 * 		<td>No<br/>デフォルトは 入力文字数の制限なし</td>
 * 	</tr>
 * 	<tr>
 * 		<td colspan="2"><b>formatter</b> <br/> (Function)</td>
 * 		<td>
 * 			編集の確定処理時に実行される関数。<br/>
 * 			<br/>
 * 			コンフィグオブジェクト<b>「editable」</b>プロパティで
 * 			true が指定されている場合にセルをダブルクリックすると、
 * 			セルの内部がテキストフィールドに切り替わり、編集可能となります。<br/>
 * 			<br/>
 * 			編集中にEnterキーを押下すると編集の確定処理に移行します。<br/>
 * 			<br/>
 * 			編集の確定処理時には、<b>「formatter」</b>で指定した関数が実行され、
 * 			その実行結果がセルに表示されます。<br/>
 * 			「formatter」関数の引数には、編集されたテキストの内容が渡されます。<br/>
 * 			（編集の確定処理は、編集中に他のセルをクリックした際にも発生します）<br/>
 * 			<br/>
 * 			編集キャンセル時には<b>「formatter」</b>で指定した関数は実行され<b>ません</b>。<br/>
 * 			<br/>
 * 			<font color="red"><b>【注意】</b></font>
 * 			<br/>
 * 			<b>「formatter」</b>の実行結果は、表示内容にのみ影響をあたえます。
 * 			つまり、<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得するデータには反映されません。<br/>
 * 			<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得するデータには、編集したデータが<b>そのまま</b>格納されています。<br/>
 * 			<br/>
 * 			（なお、<a href="ImSortableTable.html#getData">ImSortableTable#getData()</a>で取得したデータを<b>そのまま</b>利用する場合は、
 * 			セキュリティ上の危険があることに留意してください。
 * 			このデータを<b>そのまま</b>innerHTMLに設定する、または、eval()を実行する等を行う場合は、
 * 			データ内に不正な記述が含まれていないかのチェックや、データのエスケープ処理の実施をお勧めします）
 *		</td>
 * 		<td>No<br/>デフォルトは 編集されたテキストの内容をそのまま返却する関数</td>
 * 	</tr>
 * </table>
 *
 * <br/>
 * <br/>
 *
 * <h2><a name="StateDiagram">「状態」と「イベントタイプ」の関係</a></h2>
 * 「状態」と「イベントタイプ」の関係（テキスト用）は以下の通りです。<br/>
 *
 * <table border="1">
 * 	<tr>
 * 		<td bgcolor="lightgrey" colspan="2" rowspan="2"><br/></td>
 * 		<td bgcolor="lightgrey" colspan="3" align="center">状態</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" align="center">Unselect</td>
 * 		<td bgcolor="lightgrey" align="center">Select</td>
 * 		<td bgcolor="lightgrey" align="center">Edit</td>
 * 	</tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey" rowspan="8">イベントタイプ</td>
 * 		<td bgcolor="lightgrey">click</td>
 * 		<td>
 * 			<ul>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">dblclick</td>
 * 		<td>
 * 			編集可能の場合
 * 			<ul>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>テキストフィールドを表示</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Edit</b></li>
 * 			</ul>
 * 			編集不可の場合
 * 			<ul>
 * 				<li>このセルを現在選択中のポジションに変更</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			編集可能の場合
 * 			<ul>
 * 				<li>テキストフィールドを表示</li>
 * 				<li>次の状態は<b>Edit</b></li>
 * 			</ul>
 * 			編集不可の場合
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 * 		</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">keydown</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			[Enter]キーが押下された場合<br/>
 * 			<ul>
 * 				<li>編集の確定処理を実行。</li>
 * 				具体的には、「Edit」状態の「completeEdit」イベントを起動し、
 * 				その戻り値を次の状態とします。<br/>
 * 			</ul>
 * 			[Esc]キーが押下された場合<br/>
 * 			<ul>
 * 				<li>編集のキャンセル処理を実行。</li>
 * 				具体的には、「Edit」状態の「cancelEdit」イベントを起動し、
 * 				その戻り値を次の状態とします。<br/>
 * 			</ul>
 * 			上記以外<br/>
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">keyup</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseover</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「default」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>
 * 			<ul>
 * 				<li>カーソルスタイルを「text」に変更</li>
 * 				<li>状態は<b>変化無し</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">mouseout</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 * 		<td>
 * 			このセルが選択されている場合
 * 			<ul>
 * 				<li>何も行いません。</li>
 * 			</ul>
 *
 * 			このセルが選択されていない場合（=このセル以外のセルが選択された場合）
 * 			<ul>
 * 				<li>現在のセルの表示形式を未選択形式に変更</li>
 * 				<li>次の状態は<b>Unselect</b></li>
 * 			</ul>
 * 		</td>
 * 		<td>-<br/><i>(何も行いません)</i></td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">completeEdit</td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>
 * 			<ul>
 * 				<li>編集の確定処理を実行</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * 	<tr>
 * 		<td bgcolor="lightgrey">cancelEdit</td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>×<br/><i>（このイベントは発生しません）</i></td>
 * 		<td>
 * 			<ul>
 * 				<li>編集の確定処理を実行</li>
 * 				<li>現在のセルの表示形式を選択中形式に変更</li>
 * 				<li>次の状態は<b>Select</b></li>
 * 			</ul>
 * 		</td>
 *  </tr>
 * </table>
 *
 * <a name="APIListStart"/>
 *
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */

ImSortableTableCell4Text.prototype = new ImSortableTableCell();

/**
 * コンストラクタ。<br/>
 * <br/>
 * <i>開発者が明示的にこのコンストラクタを利用する必要はありません。</i>
 *
 * @class ImSortableTableのテキスト用セルオブジェクト。<br/>
 * テキスト用セルオブジェクトの詳しい説明は、<a href="overview-summary-im_sortable_table_cell_text.js.html">こちら</a>を参照してください。<br/>
 * <br/>
 * ImSortableTableオブジェクトの詳しい説明や、サンプルコード等は、<a href="ImSortableTable_SUMMARY.html">こちら</a>を参照してください。<br/>
 *
 * @constructor
 */
function ImSortableTableCell4Text(observer, htmlElement, position, config, data) {

    /**
     * @private
     */
    this.constructor = function(observer, htmlElement, position, config, data){

        this.controlType = "text";
        this.currentState = this.initialState;

        this.observer     = observer;
        this.htmlElement  = htmlElement;
        this.position     = position;
        this.config       = config;
        this.data         = data;

        this.beforeTriggers = this.config.beforeTriggers;
        this.afterTriggers  = this.config.afterTriggers;
    }

    /**
     * @private
     * @override
     */
    this.appendChildElements = function(){
        this.addCachedSelfListeners("click", "dblclick", "keydown", "keyup", "mouseover", "mouseout");
        this.createChildElement();
    }

    /**
     * @private
     * @override
     */
    this.unloadChildElements = function(){
        this.removeCachedSelfListeners();

        this.textElement  = null;
        this.TextNode     = null;
        this.childElement = null;

        this.afterTriggers  = null;
        this.beforeTriggers = null;

        this.data         = null;
        this.config       = null;
        this.position     = null;
        this.htmlElement  = null;
        this.observer     = null;

        this.currentState = null;
        this.controlType  = null;
    }

    /**
     * 編集中の&lt;input type=&quot;text&quot;&gt;エレメントを取得します。<br/>
     * このセルが編集中ではない場合、nullが返却されます。
     *
     * @return このセルが編集中の場合、編集中の&lt;input type=&quot;text&quot;&gt;エレメント。
     * 			このセルが編集中ではない場合、null。
     * @type Object
     */
    this.getTextElement = function(){
        return this.textElement;
    }

    /**
     * @private
     */
    this.createChildElement = function(){

        var formattedData = this.config.formatter(this.data);

        var divElem = document.createElement("div");
        divElem.title = formattedData;
        divElem.style.overflow   = "hidden";
        divElem.style.whiteSpace = "noWrap";

        var textNode = document.createTextNode(formattedData);

        this.childElement = divElem;
        this.TextNode     = textNode;

        this.htmlElement.appendChild(this.childElement);
        this.childElement.appendChild(this.TextNode);

        this.textElement = null;
    }

    /**
     * @private
     * @override
     */
    this.actionTransitionFunctions = {
        Unselect : {
            click : function(event){
                this.observer.setCurrentPosition(event, this.position);
                this.changeStyle2Selected(event);
                return IM_STBL_CELL_STATE.SELECT;
            },

            dblclick : function(event){
                if(this.config.editable == true){
                    this.observer.setCurrentPosition(event, this.position);
                    this.observer.isEditing = true;
                    this.changeControlType2Editable();
                    this.changeStyle2Selected(event);
                    return IM_STBL_CELL_STATE.EDIT;
                }
                else{
                    this.observer.setCurrentPosition(event, this.position);
                    this.changeStyle2Selected(event);
                    return IM_STBL_CELL_STATE.SELECT;
                }
            },

            keydown : function(event){
                return this.currentState;
            },

            keyup : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                return this.currentState;
            },

            completeEdit : function(event){
                return this.currentState;
            },

            cancelEdit : function(event){
                return this.currentState;
            }
        },

        Select : {
            click : function(event){
                return this.currentState;
            },

            dblclick : function(event){
                if(this.config.editable == true){
                    this.observer.isEditing = true;
                    this.changeControlType2Editable();
                    return IM_STBL_CELL_STATE.EDIT;
                }
                else{
                    return this.currentState;
                }
            },

            keydown : function(event){
                return this.currentState;
            },

            keyup : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "default";
                return this.currentState;
            },

            mouseout : function(event){
                if(this.observer.isSelectedPosition(this.position)){
                    return this.currentState;
                }
                else{
                    this.changeStyle2Unselected(event);
                    return IM_STBL_CELL_STATE.UN_SELECT;
                }
            },

            completeEdit : function(event){
                return this.currentState;
            },

            cancelEdit : function(event){
                return this.currentState;
            }
        },

        Edit : {
            click : function(event){
                return this.currentState;
            },

            dblclick : function(event){
                return this.currentState;
            },

            keydown : function(event){
                // [Enter]
                if(event.keyCode == 13){
                    return this.doActionTransition(IM_STBL_CELL_STATE.EDIT, "completeEdit", event);
                }
                // [Esc]
                if(event.keyCode == 27){
                    return this.doActionTransition(IM_STBL_CELL_STATE.EDIT, "cancelEdit", event);
                }
                else{
                    return this.currentState;
                }

            },

            keyup : function(event){
                return this.currentState;
            },

            mouseover : function(event){
                this.htmlElement.style.cursor = "text";
                return this.currentState;
            },

            mouseout : function(event){
                return this.currentState;
            },

            completeEdit : function(event){
                this.completeEditAction();
                this.observer.isEditing = false;
                this.changeStyle2Selected(event);
                return IM_STBL_CELL_STATE.SELECT;
            },

            cancelEdit : function(event){
                this.cancelEditAction();
                this.observer.isEditing = false;
                this.changeStyle2Selected(event);
                return IM_STBL_CELL_STATE.SELECT;
            }
        }
    }

    /**
     * @private
     */
    this.changeControlType2Editable = function(){
        var elementId = this.htmlElement.id + this.controlType + "INPUT_ELEMENT";

        while(this.childElement.hasChildNodes()){
            this.childElement.removeChild(this.childElement.firstChild);
        }

        var textElem = document.createElement("input");
        textElem.id = elementId;
        textElem.setAttribute("type", "text");
        textElem.setAttribute("value", this.data);
        textElem.style.width = "100%";

        if(this.config.maxlength != null && this.config.maxlength != undefined){
            textElem.setAttribute("maxlength", this.config.maxlength);
        }

        this.childElement.appendChild(textElem);
        textElem.focus();

        this.textElement = textElem;
    }

    /**
     * @private
     */
    this.completeEditAction = function(){
        var elementId = this.htmlElement.id + this.controlType + "INPUT_ELEMENT";

        var elem = document.getElementById(elementId);
        this.updateCellData(elem.value);

        this.htmlElement.removeChild(this.childElement);
        this.childElement = null;

        this.createChildElement();
    }

    /**
     * @private
     */
    this.cancelEditAction = function(){
        this.htmlElement.removeChild(this.childElement);
        this.childElement = null;

        this.createChildElement();
    }

    // Construct instance
    this.constructor(observer, htmlElement, position, config, data);
}

/**
 * ImSortableTableのデフォルトコンフィグオブジェクトを生成します（テキスト用）。
 *
 * @param {String} id 列を識別するためのID
 * @param {String} name [option] ヘッダに表示される文字列（任意）
 * @param {Number} width [option] 列の幅（任意）
 * @return デフォルト値を格納したImSortableTableの<a href="overview-summary-im_sortable_table_cell_text.js.html#ConfigObject">テキスト用コンフィグオブジェクト</a>
 * @type Object
 */
ImSortableTableCell4Text.createDefaultConfig = function(argId, argName, argWidth){

    var defaultConfig = {
        type           : "text",
        id             : (argId    != null && argId    != undefined) ? argId    : null,
        name           : (argName  != null && argName  != undefined) ? argName  : "",
        width          : (argWidth != null && argWidth != undefined) ? argWidth : "",
        visible        : true,
        sortable       : true,
        sorter         : {
                            sortDirection : IM_STBL_CONFIG_KEY.ASC,
                            ascFunction   : ImSortableTableCell4Text.defaultAscFunction,
                            descFunction  : ImSortableTableCell4Text.defaultDescFunction,
                            ascImage      : IM_STBL_CELL_SORT_ASC_IMG,
                            descImage     : IM_STBL_CELL_SORT_DESC_IMG,
                            defaultImage  : IM_STBL_CELL_SORT_DEFAULT_IMG
                         },
        header         : {
                            height             : "",
                            className          : "im_sortable_table_header_cell",
                            mousedownClassName : "im_sortable_table_header_cell_mousedown"
                         },
        data           : {
                            height            : "",
                            evenClassName     : "im_sortable_table_data_cell_text_even",
                            oddClassName      : "im_sortable_table_data_cell_text_odd",
                            selectedClassName : "im_sortable_table_data_cell_text_selected"
                         },
        beforeTriggers : [],
        afterTriggers  : [],

        // OTHER CONFIG
        editable  : false,                                       // true = editable, false = uneditable
        maxlength : null,                                        // maxlength
        formatter : function(editedValue){ return editedValue; } // Formatter Function
    };

    return defaultConfig;

}

/**
 * @private
 */
ImSortableTableCell4Text.defaultAscFunction = function(a, b){
    var aCol = a[IM_STBL_SORT_TARGET_IDX];
    var bCol = b[IM_STBL_SORT_TARGET_IDX];

    if(aCol == bCol){
        return 0;
    }
    else if(aCol > bCol){
        return 1;
    }
    else{
        return -1;
    }
}

/**
 * @private
 */
ImSortableTableCell4Text.defaultDescFunction = function(a, b){
    var bCol = b[IM_STBL_SORT_TARGET_IDX];
    var aCol = a[IM_STBL_SORT_TARGET_IDX];

    if(bCol == aCol){
        return 0;
    }
    else if(bCol > aCol){
        return 1;
    }
    else{
        return -1;
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_window.js

概要

ウィンドウ操作関数群。

サンプルコード

サンプル（.htmlファイル）
  ・
  ・
  ・
  <script src="csjs/im_window.js"></script>

  <script language="javascript">

    // 名称が "MY_WIN" というウィンドウを新規に立ちあげる
    openNewWindow("MY_WIN", "status=yes,resizable=yes");

  </script>
  ・
  ・
  ・

Version: 1.0

Author: INTRAMART

メソッドの概要
static Window openNewWindow(<String> name, <String> status)
新しいウィンドウを開きます。

/**
 * @fileoverview ウィンドウ操作関数群。<br/>
 * <br/>
 * <strong>サンプルコード</strong> </a><br/>
 * <br/>
 * <table border="1">
 *   <tr>
 *     <th>
 *       サンプル（.htmlファイル）
 *     </th>
 *   </tr>
 *   <tr>
 *     <td>
 *       <font size="-1">
<pre>
  ・
  ・
  ・
  &lt;script src=&quot;csjs/im_window.js&quot;&gt;&lt;/script&gt;

  &lt;script language=&quot;javascript&quot;&gt;

    // 名称が &quot;MY_WIN&quot; というウィンドウを新規に立ちあげる
    openNewWindow(&quot;MY_WIN&quot;, &quot;status=yes,resizable=yes&quot;);

  &lt;/script&gt;
  ・
  ・
  ・
</pre>
 *       </font>
 *     </td>
 *   </tr>
 * </table>
 *
 * @version 1.0
 * @since 3.0
 * @author INTRAMART
 */

/**
 * 新しいウィンドウを開きます。<br/>
 * <br/>
 * 指定された条件で新しいウィンドウを開きます。<br/>
 * <br/>
 * この関数は、window.open() と同等の振る舞いをします。
 * 引数 status には、window.open() ＡＰＩの第３引数に与える引数と同様の文字列データ
 * (<font size="1">詳細は、JavaScript のリファレンスを参照して下さい</font>)を渡して下さい。<br/>
 * この関数は、JavaScript の window.open() と等しい値を返します。<br/>
 * 指定された参照名で、すでにウィンドウが開かれている場合、新規ウィンドウが開かれない場合があります。<br/>
 * この関数を利用して開いたウィンドウには、『Please wait...』という画面が表示されます。<br/>
 *
 * @param {String} name ウィンドウ参照名称
 * @param {String} status ウィンドウ・ステータス
 * @return 新規に開いたウィンドウのハンドル (Window オブジェクト)
 * @type Window
 */
function openNewWindow(name, status){
    var url_href = location.href;
    var url_path = location.pathname;
    var url_site = url_href.substring(0, url_href.indexOf(url_path)) + url_path.substring(0, url_path.lastIndexOf("/"));
    return window.open(url_site + "/alert/newwindow_home.html", name, status);
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

im_xpath.js

概要

XMLオブジェクトの生成や解析をサポートするメソッドを提供します。

サンプルコード

ImXPathオブジェクトを使用して、XMLドキュメントの作成と
データを取得する例を示します。
<html>
<head>
<script src="csjs/im_xpath.js"></script>
<script language="javascript">

    // ■1.次の構造のXMLを作成します
    // <root>
    //    <fruit-list>
    //       <fruit>りんご</fruit>
    //       <fruit>みかん</fruit>
    //    </fruit-list>
    //    <vegetable-list>
    //       <vegetable>にんじん</vegetable>
    //       <vegetable code="001">きゅうり</vegetable>
    //    </vegetable-list>
    // </root>

    // XMLドキュメントオブジェクトを生成する
    var doc = ImXPath.createXmlDocument();

    // ノードの追加
    ImXPath.add(doc, "/root/fruit-list/fruit", "りんご");
    ImXPath.add(doc, "/root/fruit-list/fruit", "みかん");

    ImXPath.add(doc, "/root/vegetable-list/vegetable", "にんじん");

    ImXPath.add(doc, "/root/vegetable-list/vegetable/@code", "001");
    ImXPath.replace(doc, "/root/vegetable-list/vegetable[@code=001]", "きゅうり");

    // ■2.作成されたXMLから値を検索する

    // 2.1.ノードオブジェクトで取得する
    var sampleNode1 = ImXPath.evaluate(doc, "/root/vegetable-list/vegetable[@code=001]", false, ImXPath.NODE);
    alert(sampleNode1.firstChild.nodeValue);	// "きゅうり"が表示される
    alert(sampleNode1.getAttribute("code"));	// "001"が表示される

    // 2.2.テキストノードを取得する
    var sampleValue2 = ImXPath.evaluate(doc, "/root/vegetable-list/vegetable[@code=001]/text()", false, ImXPath.STRING);
    alert(sampleValue2);	// "きゅうり"が表示される

    // 2.3.ノードの配列を取得する
    var sampleNodeArray3 = ImXPath.evaluate(doc, "/root/fruit-list/fruit", true, ImXPath.NODE);
    for (var i = 0; i < sampleNodeArray3.length; i++) {
        alert(sampleNodeArray3[i].firstChild.nodeValue);	// "りんご"、"みかん"の順に表示される
    }

    // 2.4.属性値の配列を取得する
    var sampleAttributeArray4 = ImXPath.evaluate(doc, "/root/vegetable-list/vegetable/@code", true, ImXPath.NUMBER);
    for (var i = 0; i < sampleAttributeArray4.length; i++) {
        alert(sampleAttributeArray4[i]);	// NaN、1 の順に表示される
    }

    // ■3.ノードの追加と更新をする

    // 3.1."vegetable"ノードのcode="001"のテキストノードの値を、"きゅうり"から"なす"に変更します
    ImXPath.add(doc, "/root/vegetable-list/vegetable[@code=001]/text()", "なす");
    alert(ImXPath.evaluate(doc, "/root/vegetable-list/vegetable[@code=001]/text()", false, ImXPath.STRING));	// "かぼちゃ"が表示される

    // 3.2.テキストノードに"キャベツ"を持つ、新しい"vegetable"ノードを追加します
    ImXPath.add(doc, "/root/vegetable-list/vegetable", "キャベツ");

    // 3.実行結果(docの中身)
    // <root>
    //    <fruit-list>
    //       <fruit>りんご</fruit>
    //       <fruit>みかん</fruit>
    //    </fruit-list>
    //    <vegetable-list>
    //       <vegetable>にんじん</vegetable>
    //       <vegetable code="001">なす</vegetable>
    //       <vegetable>キャベツ</vegetable>
    //    </vegetable-list>
    // </root>

    // ■4.ノードを削除する

    // 4.1."fruit-list"ノードを削除します
    var rs = ImXPath.remove(doc, "/root/fruit-list");

    // 4.実行結果(docの中身)
    // <root>
    //    <vegetable-list>
    //       <vegetable>にんじん</vegetable>
    //       <vegetable code="001">なす</vegetable>
    //       <vegetable>キャベツ</vegetable>
    //    </vegetable-list>
    // </root>
</script>
</head>
<body>
</body>
</html>

Version: 1.0

Author: INTRAMART

クラスの概要
ImXPath XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
/**
 * XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
 * @fileoverview XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
 * <h3>サンプルコード</h3>
 * ImXPathオブジェクトを使用して、XMLドキュメントの作成と<br/>
 * データを取得する例を示します。<br/>
 * <pre>
&lt;html&gt;
&lt;head&gt;
&lt;script src="csjs/im_xpath.js"&gt;&lt;/script&gt;
&lt;script language="javascript"&gt;

    // ■1.次の構造のXMLを作成します
    // &lt;root&gt;
    //    &lt;fruit-list&gt;
    //       &lt;fruit&gt;りんご&lt;/fruit&gt;
    //       &lt;fruit&gt;みかん&lt;/fruit&gt;
    //    &lt;/fruit-list&gt;
    //    &lt;vegetable-list&gt;
    //       &lt;vegetable&gt;にんじん&lt;/vegetable&gt;
    //       &lt;vegetable code="001"&gt;きゅうり&lt;/vegetable&gt;
    //    &lt;/vegetable-list&gt;
    // &lt;/root&gt;

    // XMLドキュメントオブジェクトを生成する
    var doc = ImXPath.createXmlDocument();

    // ノードの追加
    ImXPath.add(doc, "/root/fruit-list/fruit", "りんご");
    ImXPath.add(doc, "/root/fruit-list/fruit", "みかん");

    ImXPath.add(doc, "/root/vegetable-list/vegetable", "にんじん");

    ImXPath.add(doc, "/root/vegetable-list/vegetable/&#64;code", "001");
    ImXPath.replace(doc, "/root/vegetable-list/vegetable[&#64;code=001]", "きゅうり");

    // ■2.作成されたXMLから値を検索する

    // 2.1.ノードオブジェクトで取得する
    var sampleNode1 = ImXPath.evaluate(doc, "/root/vegetable-list/vegetable[&#64;code=001]", false, ImXPath.NODE);
    alert(sampleNode1.firstChild.nodeValue);	// "きゅうり"が表示される
    alert(sampleNode1.getAttribute("code"));	// "001"が表示される

    // 2.2.テキストノードを取得する
    var sampleValue2 = ImXPath.evaluate(doc, "/root/vegetable-list/vegetable[&#64;code=001]/text()", false, ImXPath.STRING);
    alert(sampleValue2);	// "きゅうり"が表示される

    // 2.3.ノードの配列を取得する
    var sampleNodeArray3 = ImXPath.evaluate(doc, "/root/fruit-list/fruit", true, ImXPath.NODE);
    for (var i = 0; i &lt; sampleNodeArray3.length; i++) {
        alert(sampleNodeArray3[i].firstChild.nodeValue);	// "りんご"、"みかん"の順に表示される
    }

    // 2.4.属性値の配列を取得する
    var sampleAttributeArray4 = ImXPath.evaluate(doc, "/root/vegetable-list/vegetable/&#64;code", true, ImXPath.NUMBER);
    for (var i = 0; i &lt; sampleAttributeArray4.length; i++) {
        alert(sampleAttributeArray4[i]);	// NaN、1 の順に表示される
    }

    // ■3.ノードの追加と更新をする

    // 3.1."vegetable"ノードのcode="001"のテキストノードの値を、"きゅうり"から"なす"に変更します
    ImXPath.add(doc, "/root/vegetable-list/vegetable[&#64;code=001]/text()", "なす");
    alert(ImXPath.evaluate(doc, "/root/vegetable-list/vegetable[&#64;code=001]/text()", false, ImXPath.STRING));	// "かぼちゃ"が表示される

    // 3.2.テキストノードに"キャベツ"を持つ、新しい"vegetable"ノードを追加します
    ImXPath.add(doc, "/root/vegetable-list/vegetable", "キャベツ");

    // 3.実行結果(docの中身)
    // &lt;root&gt;
    //    &lt;fruit-list&gt;
    //       &lt;fruit&gt;りんご&lt;/fruit&gt;
    //       &lt;fruit&gt;みかん&lt;/fruit&gt;
    //    &lt;/fruit-list&gt;
    //    &lt;vegetable-list&gt;
    //       &lt;vegetable&gt;にんじん&lt;/vegetable&gt;
    //       &lt;vegetable code="001"&gt;なす&lt;/vegetable&gt;
    //       &lt;vegetable&gt;キャベツ&lt;/vegetable&gt;
    //    &lt;/vegetable-list&gt;
    // &lt;/root&gt;

    // ■4.ノードを削除する

    // 4.1."fruit-list"ノードを削除します
    var rs = ImXPath.remove(doc, "/root/fruit-list");

    // 4.実行結果(docの中身)
    // &lt;root&gt;
    //    &lt;vegetable-list&gt;
    //       &lt;vegetable&gt;にんじん&lt;/vegetable&gt;
    //       &lt;vegetable code="001"&gt;なす&lt;/vegetable&gt;
    //       &lt;vegetable&gt;キャベツ&lt;/vegetable&gt;
    //    &lt;/vegetable-list&gt;
    // &lt;/root&gt;
&lt;/script&gt;
&lt;/head&gt;
&lt;body&gt;
&lt;/body&gt;
&lt;/html&gt;
 * </pre>
 * @class XMLオブジェクトの生成や解析をサポートするメソッドを提供します。<br/>
 * ImXPathオブジェクトの利用およびサンプルコードは
 * <a href="overview-summary-im_xpath.js.html">こちら</a> を参照してください。<br/>
 *
 * <h3><a name="location_path_detail">ロケーションパスについて</a></h3>
 * ImXPathの各メソッドで指定可能な「ロケーションパス」で使用可能な構文は以下になります。<br/>
 * 以下の構文を"/"（半角スラッシュ）でつないだものがロケーションパスになります。
 *
 * <p/>
 * <table border="1">
 *    <tr>
 *       <th>構文</th><th>内容</th>
 *    </tr>
 *    <tr>
 *       <td><i>TagName</i></td><td><i>TagName</i>ノードが選択されます</td>
 *    </tr>
 *    <tr>
 *       <td>text()</td><td>1テキストノードが選択されます</td>
 *    </tr>
 *    <tr>
 *       <td>&#64;<i>name</i></td><td><i>name属性</i>が選択されます</td>
 *    </tr>
 *    <tr>
 *       <td><i>TagName</i>[1]</td><td><i>TagName</i>ノードのうち１番目の要素が選択されます</td>
 *    </tr>
 *    <tr>
 *       <td><i>TagName</i>[last()]</td><td><i>TagName</i>ノードのうち最後の要素が選択されます</td>
 *    </tr>
 *    <tr>
 *       <td><i>TagName</i>[&#64;<i>name</i>=<i>value</i>]</td><td><i>TagName</i>ノードのうち、
 *          <i>name</i>属性が<i>value</i>の要素が選択されます
 *       </td>
 *    </tr>
 * </table>
 * <br/>
 * 例)
 * rootノードの子要素sampleノードの内、id属性が"001"のノードのテキストノードを選択する例です。<br/>
 * /root/sample[&#64;id=001]/text()<br/>
 * @constructor
 * @version 1.0
 * @since 6.1
 * @author INTRAMART
 */
function ImXPath(){}

/**
 * @private
 * 内部配列
 */
ImXPath.tmpArray;

/**
 * 戻り値の型（ノード）
 * @final
 * @type Number
 */
ImXPath.NODE = 1;

/**
 * 戻り値の型（文字列）
 * @final
 * @type Number
 */
ImXPath.STRING = 2;

/**
 * 戻り値の型（数値）
 * @final
 * @type Number
 */
ImXPath.NUMBER = 3;

/**
 * 戻り値の型（真偽値）
 * @final
 * @type Number
 */
ImXPath.BOOLEAN = 4;

/**
 * 新しいXMLドキュメントを生成します。
 * @type Object
 * @return XMLドキュメント
 */
ImXPath.createXmlDocument = function() {
    try {
        return document.implementation.createDocument("", "", null);
    } catch(e) {

    }

    try {
        return new ActiveXObject("Msxml2.DOMDocument.3.0");
    } catch(e) {

    }

    try {
        return new ActiveXObject("Microsoft.XMLDOM");
    } catch(e) {

    }

    return null;
}

/**
 * XMLドキュメントオブジェクトから、<a href="#location_path_detail">ロケーションパス</a>
 * で選択された値を取得します。<br/>
 * 取得された値は、typeで指定された型で返却します。<br/>
 * @param {Object} doc 解析を行うXMLドキュメント
 * @param {String} path <a href="#location_path_detail">ロケーションパス</a>
 * @param {Boolean} isArray [option]返却値を配列で受け取るかどうか<br/><br/>
 * 選択された値が複数存在する場合に、配列で返すかどうかを指定します。<br/>
 * falseが指定され、かつ複数の値が選択された場合は最初の要素の値が返却されます。<br/>
 * 省略された場合は複数の値が選択された場合のみ、配列で返却されます。<br/><br/>
 * @param {Number} type [option]返却値の型<br/><br/>
 * 以下を指定できます。<br/>
 * <table border="1">
 *    <tr>
 *       <th>設定値</th><th>型</th><th>説明</th>
 *    </tr>
 *    <tr>
 *       <td>ImXPath.NODE</td><td>ノード</td><td>選択されたノードを返却します。<br/>
 *           <a href="#location_path_detail">ロケーションパス</a>で属性値が選択された場合は、その属性値を持つノードを返却します。<br/>
 *           typeの指定が省略された場合は、ノードで返されます。
 *       </td>
 *    </tr>
 *    <tr>
 *       <td>ImXPath.STRING</td><td>文字列</td><td>選択された値を文字列として返します。</td>
 *    </tr>
 *    <tr>
 *       <td>ImXPath.NUMBER</td><td>数値</td><td>選択された値を数値として返します。
 *           数値にできない値が選択された場合は、NaNを返します。</td>
 *    </tr>
 *    <tr>
 *       <td>ImXPath.BOOLEAN</td><td>真偽値</td><td>選択された値が"true"（大文字、小文字は区別しない）
 *           の場合はtrueを返します。それ以外の場合はfalseを返します。</td>
 *    </tr>
 * </table>
 * @type Object
 * @return 解析結果
 */
ImXPath.evaluate = function(doc, path, isArray, type) {

    var nodes = ImXPath.getNodesByKey(doc, path, false);
    var result;

    if (type == undefined || type == ImXPath.NODE) {
        result = nodes;
    } else {
        var lastSyntax = ImXPath.getLastSyntax(path);
        result = new Array();

        for(var i = 0; i < nodes.length; i++) {

            var node = nodes[i];
            var val;

            if (lastSyntax.attributeKey != undefined) {
                val = node.getAttribute(lastSyntax.attributeKey);
            } else if (node.nodeType == 3 && lastSyntax.funcKey == "text()") {
                val = node.nodeValue;
            } else {
                val = node;
            }

            switch (type) {
                case ImXPath.STRING:
                    result.push(val);
                break;

                case ImXPath.NUMBER:
                    result.push(parseFloat(val));
                break;

                case ImXPath.BOOLEAN:
                    if (val == null || val == undefined) {
                        result.push(false);
                    } else if (val.toUpperCase() == "TRUE") {
                        result.push(true);
                    } else {
                        result.push(false);
                    }
                break;
            }
        }
    }

    // 返却
    if (isArray == undefined) {
        if (result.length == 1) {
            return result[0];
        } else {
            return result;
        }
    } else if (isArray == true) {
        return result;
    } else if (isArray == false) {
        return result[0];
    } else {
        return result;
    }
}

/**
 * XMLを解析して値を置き換えます。<br/>
 * 指定されたXMLドキュメント内で<a href="#location_path_detail">ロケーションパス</a>
 * の値が既に存在していた場合は、その値を置き換えます。<br/>
 * 存在しない場合は、新しくノードや属性を作成します。
 * @param {Object} doc XMLドキュメント
 * @param {String} path <a href="#location_path_detail">ロケーションパス</a>
 * @param {String} value 置き換える値
 */
ImXPath.replace = function(doc, path, value) {
    ImXPath.setData(doc, path, value, false);
}

/**
 * XMLを解析して値を追加します。<br/>
 * 指定されたXMLドキュメント内に<a href="#location_path_detail">ロケーションパス</a>
 * のノードが既に存在しているかどうかに関わらず、新しいノードを作成します。<br/>
 * <a href="#location_path_detail">ロケーションパス</a>で、属性値が選択された場合は値を置き換えます。
 * @param {Object} doc XMLドキュメント
 * @param {String} path <a href="#location_path_detail">ロケーションパス</a>
 * @param {String} value 追加する値
 */
ImXPath.add = function(doc, path, value) {
    ImXPath.setData(doc, path, value, true);
}

/**
 * XMLを解析して値やノードを削除します。
 * @param {Object} doc XMLドキュメント
 * @param {String} path <a href="#location_path_detail">ロケーションパス</a>
 * @type Boolean
 * @return 削除成功/失敗
 */
ImXPath.remove = function(doc, path) {
    var nodes = ImXPath.getNodesByKey(doc, path, false);
    var lastSyntax = ImXPath.getLastSyntax(path);
    var result = false;

    try {
        for (var i = 0; i < nodes.length; i++) {
            if (lastSyntax.attributeKey == undefined) {
                nodes[i].parentNode.removeChild(nodes[i]);
                result = true;
            } else {
                // 属性が指定されている場合
                nodes[i].removeAttribute(lastSyntax.attributeKey);
                result = true;
            }
        }
    } finally {
        return result;
    }
}

/**
 * XMLを解析して値をセットします。
 *@private
 */
ImXPath.setData = function(doc, path, value, mode) {

    var nodes = ImXPath.getNodesByKey(doc, path, true, mode);
    var lastSyntax = ImXPath.getLastSyntax(path);

    for (var i = 0; i < nodes.length; i++) {

        if (lastSyntax.attributeKey == undefined) {

            // 属性が指定されていない場合
            var targetNode;
            if (nodes[i].nodeType == 3) {
                // テキストノードの場合
                targetNode = nodes[i].parentNode;
                if (nodes[i].nodeValue == "") {
                    targetNode.removeChild(nodes[i]);
                }
            } else {
                targetNode = nodes[i];
            }

            if (mode == false) {
                // replaceのとき
                while (true) {
                    var child = targetNode.childNodes[0];
                    if (child == undefined || child == null) {
                        break;
                    }
                    targetNode.removeChild(child);
                }
            }

            var type = typeof(value);
            if (type == "string" || type == "number" || type == "boolean") {
                targetNode.appendChild(doc.createTextNode(String(value)));
            } else {
                targetNode.appendChild(value);
            }

        } else {
            // 属性が指定されている場合
            nodes[i].setAttribute(lastSyntax.attributeKey, String(value));
        }
    }
}

/**
 * 指定されたキーから、ノード名の配列を取得します
 * @private
 */
ImXPath.getKeys = function(path) {

    var keys = path.split("/");
    var lastSyntax = keys[keys.length - 1];

    if (keys[0] == "") {
        // 先頭に"/"が付いていた場合
        keys.shift();
    }

    if (lastSyntax.indexOf("@") == 0) {
        // 属性指定の場合は除く
        keys.pop();
    }

    return keys;
}

/**
 * 指定されたキーから最後の構文を取得します
 * @private
 */
ImXPath.getLastSyntax = function(path) {
    var keys = path.split("/");

    var result = new Object();
    var lastSyntax = keys[keys.length -1];

    if (lastSyntax.indexOf("@") == 0) {
        result.attributeKey = lastSyntax.split("@")[1];
    } else {
        result.funcKey = lastSyntax;
    }
    return result;
}

/**
 * 指定されたキーにマッチするノードの配列を取得します
 * @private
 */
ImXPath.getNodesByKey = function(doc, path, notExistNodeCreate, mode) {

    var nodes = doc.childNodes;

    /*  // 初期化  */
    ImXPath.tmpArray = new Array();
    /*  // 検索  */
    var arykeys = ImXPath.getKeys(path);

    ImXPath.searchNodes(doc, doc.firstChild, nodes, arykeys, 0, notExistNodeCreate, mode);
    return ImXPath.tmpArray;
}

/**
 * ノードを検索します
 * @private
 */
ImXPath.searchNodes = function(doc, parentNode, nodes, keys, count, notExistNodeCreate, mode) {
    var isTargetExist = false;
    var key = String(keys[count]);
    count++;

    var nodeName;
    var predicate;
    var attributeKey;
    var attributeValue;
    var indexValue;

    if (key.indexOf("[") != -1 && key.indexOf("]") != -1) {
        nodeName = key.split("[")[0];

        predicate = key.split("[")[1].split("]")[0];	// 述部取得

        if (predicate.indexOf("@") == 0 && predicate.indexOf("=") >= 1) {
            // 属性値指定の場合
            attributeKey = predicate.split("=")[0].split("@")[1];
            attributeValue = predicate.split("=")[1];
        } else if (!isNaN(predicate)) {
            indexValue = parseInt(predicate);
        } else if(predicate == "last()") {
            indexValue = nodes.length;
        } else {
            ImXPath.tmpArray = new Array();
            return;
        }
    } else {
        nodeName = key;
    }

    for(var k = 0; k < nodes.length; k++) {

        if (nodeName == "text()" && nodes[k].nodeType == 3) {
            ImXPath.tmpArray.push(nodes[k]);
            continue;
        }

        if(nodes[k].tagName == nodeName || "*" == nodeName) {

            isTargetExist = true;

            if (attributeKey != undefined) {
                if (nodes[k].getAttribute(attributeKey) != attributeValue) {
                    continue;
                }
            }

            if (indexValue != undefined) {
                if (indexValue != k + 1) {
                    continue;
                }
            }

            if (keys.length == count) {
                ImXPath.tmpArray.push(nodes[k]);
            } else {
                ImXPath.searchNodes(doc, nodes[k], nodes[k].childNodes,
                                        keys, count, notExistNodeCreate, mode);
            }
        }
    }

    /*  // ノードが見つからなかった場合  */
    if ((isTargetExist == false && notExistNodeCreate == true) ||
        (mode == true && keys.length == count)) {

        if (predicate == undefined) {
            count--;
            ImXPath.tmpArray = new Array();
            ImXPath.createNewChildNode(doc, parentNode, keys, count);
        }
    }
}

/**
 * 新しいノードを作成します
 * @private
 */
ImXPath.createNewChildNode = function(doc, parentNode, keys, count) {

    var key = String(keys[count]);
    if(key == ""){ return }

    var newElement;
    if (key == "text()") {
        newElement = doc.createTextNode("");
    } else {
        newElement = doc.createElement(key);
    }

    if (parentNode == undefined || parentNode == null) {
        parentNode = doc;
    }

    parentNode.appendChild(newElement);
    count++;

    if (keys.length == count) {
        ImXPath.tmpArray.push(newElement);
    } else {
        ImXPath.createNewChildNode(doc, newElement, keys, count);
    }
}
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript 概要

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

intra-mart 6.1.14 Client Side JavaScript

このドキュメントは intra-mart 6.1.14 Client Side JavaScript のAPIです。

概要

クライアントサイドJavaScriptで利用可能なAPI群です。
（以下のリンクをクリックすると、ソースコードを参照することが可能です）

ファイルの概要
im_ajax_request.js | XMLHttpRequest 通信を簡単に行うことができるオブジェクトです。
im_cookie.js | クッキーに対するアクセス関数群。
im_date.js | 日付（時間）データ操作関数群。
im_header_column_resizer.js | ＜TABLE＞タグ要素の列幅をリサイズ可能にする CSJS オブジェクトです。
im_json.js | JSON 関連のライブラリです。
im_realnumber.js | 小数演算を可能にするオブジェクト。
im_sortable_table.js | ソート可能なExcel風のグリッドインターフェースを提供するCSJSオブジェクトです。
im_sortable_table_cell.js | ImSortableTableのセルオブジェクトです。
im_sortable_table_cell_checkbox.js | ImSortableTableのチェックボックス用セルオブジェクトです。
im_sortable_table_cell_image.js | ImSortableTableのイメージ用セルオブジェクトです。
im_sortable_table_cell_number.js | ImSortableTableの数値用セルオブジェクトです。
im_sortable_table_cell_radio.js | ImSortableTableのラジオボタン用セルオブジェクトです。
im_sortable_table_cell_text.js | ImSortableTableのテキスト用セルオブジェクトです。
im_window.js | ウィンドウ操作関数群。
im_xpath.js | XMLオブジェクトの生成や解析をサポートするメソッドを提供します。
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


intra-mart 6.1.14 Client Side JavaScript クラスの階層

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし

クラスの階層

  • Object
    • ImAbstractSelfEventHandler
      • ImHeaderColumnResizer
      • ImSortableTableCell
        • ImSortableTableCell4Checkbox
        • ImSortableTableCell4Image
        • ImSortableTableCell4Number
        • ImSortableTableCell4Radio
        • ImSortableTableCell4Text
    • ImAjax
    • ImJson
    • ImSortableTable
    • ImXPath
    • RealNumber
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前 次 フレームあり フレームなし
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


RealNumber

概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス | フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

クラス RealNumber

Object
   |
   +--RealNumber
class RealNumber

小数演算を可能にするオブジェクト。
Version: 1.0

Author: INTRAMART
Defined in im_realnumber.js

コンストラクタの概要
RealNumber(<Number> nNumber)
引数に指定した数値を表す実数オブジェクトのインスタンスを生成します。
メソッドの概要
RealNumber | getAdd(<Number> nTarget) オブジェクトの持つ数値データと加法演算します。
RealNumber | getDiv(<Number> nTarget) オブジェクトの持つ数値データと除法演算します。
RealNumber | getMlt(<Number> nTarget) オブジェクトの持つ数値データと乗法演算します。
RealNumber | getSub(<Number> nTarget) オブジェクトの持つ数値データと減法演算します。
Number | getValue() オブジェクトの持つ数値データを取得します。
String | toString() オブジェクトの持つ数値データを文字列として取得します。

コンストラクタの詳細

RealNumber

RealNumber(<Number> nNumber)
    引数に指定した数値を表す実数オブジェクトのインスタンスを生成します。

    Parameters:
      nNumber - 数値
    Version: 1.0

    Author: INTRAMART
メソッドの詳細

getAdd

RealNumber getAdd(<Number> nTarget)
    オブジェクトの持つ数値データと加法演算します。

    このオブジェクトのもつ数値と足し算を行います。 返却値は新たなインスタンスを生成して返すので、もとのオブジェクト自体の値は変化しません。
    Parameters:
      nTarget - 演算数値
    Returns:
      RealNumber

getDiv

RealNumber getDiv(<Number> nTarget)
    オブジェクトの持つ数値データと除法演算します。

    このオブジェクトのもつ数値と割り算を行います。 返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しません。
    Parameters:
      nTarget - 演算数値
    Returns:
      RealNumber

getMlt

RealNumber getMlt(<Number> nTarget)
    オブジェクトの持つ数値データと乗法演算します。

    このオブジェクトのもつ数値と掛け算を行います。 返却値は新たなインスタンスを生成して返すので、もとの オブジェクト自体の値は変化しません。
    Parameters:
      nTarget - 演算数値
    Returns:
      RealNumber

getSub

RealNumber getSub(<Number> nTarget)
    オブジェクトの持つ数値データと減法演算します。

    このオブジェクトのもつ数値と引き算を行います。 返却値は新たなインスタンスを生成して返すので、もとのオブジェクト自体の値は変化しません。
    Parameters:
      nTarget - 演算数値
    Returns:
      RealNumber

getValue

Number getValue()
    オブジェクトの持つ数値データを取得します。
    Returns:
      数値データ

toString

String toString()
    オブジェクトの持つ数値データを文字列として取得します。
    Returns:
      数値データ（文字列）
概要 ファイル クラス 階層ツリー 索引 ヘルプ
intra-mart 6.1.14 Client Side JavaScript
前のクラス 次のクラス | フレームあり フレームなし
概要: フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド
このドキュメントはJSDoc によって Tue Oct 19 23:06:18 2010に作成されました。


クラス jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlFieldBean の使用

CurlFieldBean を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl | intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.system.javascript.im_curl |

jp.co.intra_mart.foundation.im_curl での CurlFieldBean の使用

CurlFieldBean 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

jp.co.intra_mart.system.javascript.im_curl での CurlFieldBean の使用

CurlFieldBean を返す jp.co.intra_mart.system.javascript.im_curl のメソッド
protected  CurlFieldBean CurlFieldBeanObject.getCurlFieldBean()
セットされたCurlFieldBeanを返します。

CurlFieldBean 型のパラメータを持つ jp.co.intra_mart.system.javascript.im_curl のコンストラクタ
CurlFieldBeanObject(CurlFieldBean curlFieldBean)
引数ありコンストラクタ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF の使用

CurlRecordBeanIF を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

jp.co.intra_mart.foundation.im_curl での CurlRecordBeanIF の使用

CurlRecordBeanIF 型のパラメータを持つ jp.co.intra_mart.foundation.im_curl のメソッド
 void CurlXMLComposer.addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLComposer の使用

CurlXMLComposer を使用しているパッケージ
jp.co.intra_mart.system.javascript.im_curl

jp.co.intra_mart.system.javascript.im_curl での CurlXMLComposer の使用

CurlXMLComposer 型のパラメータを持つ jp.co.intra_mart.system.javascript.im_curl のコンストラクタ
CurlXMLComposerObject(CurlXMLComposer curlXMLComposer)
引数ありコンストラクタ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.im_curl.CurlXMLParser の使用

jp.co.intra_mart.foundation.im_curl.CurlXMLParser はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CurlFieldBean (im_curl 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlFieldBean

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlFieldBean
public class CurlFieldBean
extends Object

CurlフィールドBeanクラス
機能は以下の通り

  • CurlのRecordFieldクラスの属性情報を格納するBean

コンストラクタの概要
CurlFieldBean()
メソッドの概要
String | getCaption() キャプションを返します。
String | getDefault_value() デフォルト値を返します。
String | getDomain() ドメインを返します。
String | getIndex_type() インデックスタイプを返します。
String | getModifiable() 変更可能の可否を返します。
String | getName() 名前を返します。
String | getNullable() Null受付の可否を返します。
String | getRequired() フォーカスの要求の有無を返します。
void | setCaption(String string) キャプションを格納します。
void | setDefault_value(String string) デフォルト値を格納します。
void | setDomain(String string) ドメインを格納します。
void | setIndex_type(String string) インデックスタイプを格納します。
void | setModifiable(String string) 変更可能の可否を格納します。
void | setName(String string) 名前を格納します。
void | setNullable(String string) Null受付の可否を格納します。
void | setRequired(String string) フォーカスの要求の有無を格納します。
String | toString() オブジェクトを文字列に変換します。
String | toXMLNode() このインスタンスのXMLノードとしての文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurlFieldBean

public CurlFieldBean()
メソッドの詳細

getCaption

public String getCaption()
キャプションを返します。

戻り値:
キャプション

getDefault_value

public String getDefault_value()
デフォルト値を返します。

戻り値:
デフォルト値

getDomain

public String getDomain()
ドメインを返します。

戻り値:
ドメイン

getIndex_type

public String getIndex_type()
インデックスタイプを返します。

戻り値:
インデックスタイプ

getModifiable

public String getModifiable()
変更可能の可否を返します。

戻り値:
変更可能の可否

getName

public String getName()
名前を返します。

戻り値:
名前

getNullable

public String getNullable()
Null受付の可否を返します。

戻り値:
Null受付の可否

getRequired

public String getRequired()
フォーカスの要求の有無を返します。

戻り値:
フォーカスの要求の有無

setCaption

public void setCaption(String string)
キャプションを格納します。

パラメータ:
string - キャプション

setDefault_value

public void setDefault_value(String string)
デフォルト値を格納します。

パラメータ:
string - デフォルト値

setDomain

public void setDomain(String string)
ドメインを格納します。

パラメータ:
string - ドメイン

setIndex_type

public void setIndex_type(String string)
インデックスタイプを格納します。

パラメータ:
string - インデックスタイプ

setModifiable

public void setModifiable(String string)
変更可能の可否を格納します。

パラメータ:
string - 変更可能の可否

setName

public void setName(String string)
名前を格納します。

パラメータ:
string - 名前

setNullable

public void setNullable(String string)
Null受付の可否を格納します。

パラメータ:
string - Null受付の可否

setRequired

public void setRequired(String string)
フォーカスの要求の有無を格納します。

パラメータ:
string - フォーカスの要求の有無

toString

public String toString()
オブジェクトを文字列に変換します。

戻り値:
このオブジェクトの文字列表現

toXMLNode

public String toXMLNode()
このインスタンスのXMLノードとしての文字列を返します。

戻り値:
XMLノードへ変換した文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlRecordBeanIF (im_curl 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
インタフェース CurlRecordBeanIF

public interface CurlRecordBeanIF

CurlレコードBeanインタフェース
機能は以下の通り

  • CurlのRecordクラスの属性を格納するBean用のインタフェース

メソッドの概要
 String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

メソッドの詳細

toXMLNode

public String toXMLNode()
保持しているデータをXMLノードの文字列に変換します。

戻り値:
XMLノード文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlXMLComposer (im_curl 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLComposer

java.lang.Object
    拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
public class CurlXMLComposer
extends Object

CurlXML生成クラス
機能は以下の通り

  • Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。

コンストラクタの概要
CurlXMLComposer()
メソッドの概要
void | addField(CurlFieldBean field) フィールド一覧リストにフィールドを追加します。
void | addRecord(CurlRecordBeanIF record) レコード一覧リストにレコードを追加します。
void | setFieldList(ArrayList fieldList) フィールド一覧リストをセットします。
void | setRecordList(ArrayList recordList) レコード一覧リストをセットします。
String | toXML() 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurlXMLComposer

public CurlXMLComposer()
メソッドの詳細

addField

public void addField(CurlFieldBean field)
フィールド一覧リストにフィールドを追加します。

パラメータ:
field - フィールド定義クラスのインスタンス

setFieldList

public void setFieldList(ArrayList fieldList)
フィールド一覧リストをセットします。

パラメータ:
fieldList - フィールド一覧リスト

addRecord

public void addRecord(CurlRecordBeanIF record)
レコード一覧リストにレコードを追加します。

パラメータ:
record - レコードクラスのインスタンス

setRecordList

public void setRecordList(ArrayList recordList)
レコード一覧リストをセットします。

パラメータ:
recordList - レコード一覧リスト

toXML

public String toXML()
             throws Exception
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。

戻り値:
Curlで入力可能なXMLの文字列
例外:
Exception
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurlXMLParser (im_curl 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.im_curl
クラス CurlXMLParser

java.lang.Object
    拡張 org.xml.sax.helpers.DefaultHandler
        拡張 jp.co.intra_mart.foundation.im_curl.CurlXMLParser
すべての実装インタフェース:
ContentHandler, DTDHandler, EntityResolver, ErrorHandler
public class CurlXMLParser
extends DefaultHandler

CurlXMLパーサクラス
機能は以下の通り

  • Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

フィールドの概要
protected Object | field に対応するCurlFieldBean
protected ArrayList | fieldsList に対応するCurlFieldBeanクラスのインスタンス格納用リスト
protected Object | instance に対応するJavaBeans
protected ArrayList | recordList に対応するクラスのインスタンス格納用リスト
コンストラクタの概要
CurlXMLParser(InputStream stream, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurlXMLParser(String path, String beanClassName)
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
メソッドの概要
protected void | createField(Attributes atts) qNameがFieldの場合のパーサの動作を定義します。
protected void | createRecord(Attributes atts) qNameがRecordの場合のパーサの動作を定義します。
void | endElement(String uri, String localName, String qName) DefaultHandlerのabstractメソッドをオーバーライドします。
ArrayList | getFieldsList() パースした結果のフィールド一覧リストを返します。
ArrayList | getRecordList() パースした結果のレコード一覧リストを返します。
void | startElement(String uri, String localName, String qName, Attributes atts) DefaultHandlerのabstractメソッドをオーバーライドします。
クラス org.xml.sax.helpers.DefaultHandler から継承したメソッド
characters, endDocument, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, resolveEntity, setDocumentLocator, skippedEntity, startDocument, startPrefixMapping, unparsedEntityDecl, warning
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

fieldsList

protected ArrayList fieldsList
に対応するCurlFieldBeanクラスのインスタンス格納用リスト

recordList

protected ArrayList recordList
に対応するクラスのインスタンス格納用リスト

field

protected Object field
に対応するCurlFieldBean

instance

protected Object instance
に対応するJavaBeans

コンストラクタの詳細

CurlXMLParser

public CurlXMLParser(String path,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。

パラメータ:
path - パース対象のXMLファイルのパス
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException

CurlXMLParser

public CurlXMLParser(InputStream stream,
                     String beanClassName)
              throws SAXException
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。

パラメータ:
stream - パース対象のXMLを読み込むストリーム
beanClassName - パース対象のXMLのRecordタグに対応するJavaBeansクラス名
例外:
SAXException
メソッドの詳細

getRecordList

public ArrayList getRecordList()
パースした結果のレコード一覧リストを返します。

戻り値:
レコード一覧

getFieldsList

public ArrayList getFieldsList()
パースした結果のフィールド一覧リストを返します。

戻り値:
フィールド一覧

startElement

public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。
Curlで出力されたXML(elaborate-recordsetでの出力)をパースし、 FieldタグをCurlFieldBeanクラスのリストに、Recordタグを指定したJavaBeans クラスのリストに変換します。処理の詳細は次の通りです。
  1. Fieldタグをパースし、フィールド一覧リストに格納する。
  2. Recordタグのパース
    1. 指定されたJavaBeansクラスのインスタンス生成
    2. Recordタグの属性名、属性値を取得
    3. フィールド一覧リスト内のフィールド名を取得
    4. 指定されたJavaBeansクラスのメソッド一覧を検索しRecordタグの 属性のセッターが存在すればセッターを呼び出し属性値をセットする。 存在の有無は"set"+属性値をすべて小文字に変換した文字列がJavaBeans クラスのメソッド一覧内に存在するかで判断する。

例外:
SAXException

createField

protected void createField(Attributes atts)
qNameがFieldの場合のパーサの動作を定義します。 RecordSetのフィールドを解析する部分になります。

パラメータ:
atts -

createRecord

protected void createRecord(Attributes atts)
                     throws SAXException
qNameがRecordの場合のパーサの動作を定義します。 RecordSetのレコードを解析する部分になります。

パラメータ:
atts -
例外:
SAXException

endElement

public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
DefaultHandlerのabstractメソッドをオーバーライドします。

例外:
SAXException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.im_curl (im_curl 6.1.14 API)

 jp.co.intra_mart.foundation.im_curl
インタフェース
CurlRecordBeanIF
クラス
CurlFieldBean
CurlXMLComposer
CurlXMLParser


jp.co.intra_mart.foundation.im_curl (im_curl 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

参照:
説明

インタフェースの概要
CurlRecordBeanIF CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

クラスの概要
CurlFieldBean | CurlフィールドBeanクラス 機能は以下の通り CurlのRecordFieldクラスの属性情報を格納するBean
CurlXMLComposer | CurlXML生成クラス 機能は以下の通り Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLParser | CurlXMLパーサクラス 機能は以下の通り Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。

パッケージ jp.co.intra_mart.foundation.im_curl の説明

intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.im_curl クラス階層 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.im_curl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser

インタフェース階層

  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.im_curl の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.im_curl の使用

jp.co.intra_mart.foundation.im_curl を使用しているパッケージ
jp.co.intra_mart.foundation.im_curl | intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.system.javascript.im_curl |

jp.co.intra_mart.foundation.im_curl により使用される jp.co.intra_mart.foundation.im_curl のクラス
CurlFieldBean
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlRecordBeanIF
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース

jp.co.intra_mart.system.javascript.im_curl により使用される jp.co.intra_mart.foundation.im_curl のクラス
CurlFieldBean
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlXMLComposer
CurlXML生成クラス
機能は以下の通り
Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject の使用

jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject の使用

jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject の使用

jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


CurlFieldBeanObject (im_curl 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.javascript.im_curl
クラス CurlFieldBeanObject

java.lang.Object
    拡張 jp.co.intra_mart.system.javascript.ScriptableObject
        拡張 jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, Serializable
public class CurlFieldBeanObject
extends jp.co.intra_mart.system.javascript.ScriptableObject
implements Serializable

CurlFieldBeanオブジェクト。
CurlのRecordFieldクラスの属性情報を格納するオブジェクトです。
設定できる属性情報は以下の通りです。なお、各項目の詳細はCurlのドキュメントを参照してください。

CurlFieldBeanオブジェクト

name | [必須] | 名前 (String)
caption | － | キャプション (String)
domain | － | ドメイン (String)
modifiable | － | 編集可否フラグ (String)
nullable | － | Null許容可否フラグ (String)
default-value | － | デフォルト値 (String)
index-type | － | インデックスタイプ (String)
required | － | 明示的設定の可否フラグ (String)

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したフィールド
DONTENUM, EMPTY, PERMANENT, READONLY
インタフェース jp.co.intra_mart.system.javascript.Scriptable から継承したフィールド
NOT_FOUND
コンストラクタの概要
CurlFieldBeanObject()
引数なしコンストラクタ
CurlFieldBeanObject(CurlFieldBean curlFieldBean)
引数ありコンストラクタ
メソッドの概要
String | getCaption()
String | getClassName()
protected CurlFieldBean | getCurlFieldBean() セットされたCurlFieldBeanを返します。
String | getDefault_value()
String | getDomain()
String | getIndex_type()
String | getModifiable()
String | getName()
String | getNullable()
String | getRequired()
static Object | jsConstructor(jp.co.intra_mart.system.javascript.Context cx, Object[] args, jp.co.intra_mart.system.javascript.Function ctorObj, boolean inNewExpr) コンストラクタ。
String | jsFunction_getCaption() キャプションを取得します。
String | jsFunction_getDefault_value() デフォルト値を取得します。
String | jsFunction_getDomain() ドメインを取得します。
String | jsFunction_getIndex_type() インデックスタイプを取得します。
String | jsFunction_getModifiable() 編集可能フラグを取得します。
String | jsFunction_getName() 名前を取得します。
String | jsFunction_getNullable() Null許容フラグを取得します。
String | jsFunction_getRequired() 必須フラグを取得します。
void | jsFunction_setCaption(String value) キャプションを設定します。
void | jsFunction_setDefault_value(String value) デフォルト値を設定します。
void | jsFunction_setDomain(String value) ドメインを設定します。
void | jsFunction_setIndex_type(String value) インデックスタイプを設定します。
void | jsFunction_setModifiable(String value) 編集可能フラグを設定します。
void | jsFunction_setName(String value) 名前を設定します。
void | jsFunction_setNullable(String value) Null許容フラグを設定します。
void | jsFunction_setRequired(String value) 必須フラグを設定します。
String | jsFunction_toString() 設定されたCurlFieldBeanの文字列表現を返します。
void | setCaption(String str)
void | setDefault_value(String str)
void | setDomain(String str)
void | setIndex_type(String str)
void | setModifiable(String str)
void | setName(String str)
void | setNullable(String str)
void | setRequired(String str)
String | toString()
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したメソッド
associateValue, callMethod, callMethod, defineClass, defineClass, defineClass, defineFunctionProperties, defineProperty, defineProperty, defineProperty, defineProperty, delete, delete, deleteProperty, deleteProperty, equivalentValues, get, get, getAllIds, getAssociatedValue, getAttributes, getAttributes, getAttributes, getAttributes, getClassPrototype, getDefaultValue, getFunctionPrototype, getIds, getObjectPrototype, getParentScope, getProperty, getProperty, getPropertyIds, getPrototype, getTopLevelScope, getTopScopeValue, has, has, hasInstance, hasProperty, hasProperty, isSealed, put, put, putProperty, putProperty, sealObject, setAttributes, setAttributes, setAttributes, setAttributes, setParentScope, setPrototype, toDate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurlFieldBeanObject

public CurlFieldBeanObject()
引数なしコンストラクタ

CurlFieldBeanObject

public CurlFieldBeanObject(CurlFieldBean curlFieldBean)
引数ありコンストラクタ

メソッドの詳細

toString

public String toString()

getClassName

public String getClassName()
定義:
インタフェース jp.co.intra_mart.system.javascript.Scriptable 内の getClassName

getCurlFieldBean

protected CurlFieldBean getCurlFieldBean()
セットされたCurlFieldBeanを返します。

戻り値:
CurlFieldBean。セットされていない場合はNullを返します。

jsFunction_getCaption

public String jsFunction_getCaption()
キャプションを取得します。

戻り値:
String キャプション

jsFunction_getDefault_value

public String jsFunction_getDefault_value()
デフォルト値を取得します。

戻り値:
String デフォルト値

jsFunction_getDomain

public String jsFunction_getDomain()
ドメインを取得します。

戻り値:
String ドメイン

jsFunction_getIndex_type

public String jsFunction_getIndex_type()
インデックスタイプを取得します。

戻り値:
String インデックスタイプ

jsFunction_getModifiable

public String jsFunction_getModifiable()
編集可能フラグを取得します。

戻り値:
String 編集可能フラグ(true/false)

jsFunction_getName

public String jsFunction_getName()
名前を取得します。

戻り値:
String 名前

jsFunction_getNullable

public String jsFunction_getNullable()
Null許容フラグを取得します。

戻り値:
String Null許容フラグ(true/false)

jsFunction_getRequired

public String jsFunction_getRequired()
必須フラグを取得します。

戻り値:
String 必須フラグ(true/false)

jsFunction_setCaption

public void jsFunction_setCaption(String value)
キャプションを設定します。

パラメータ:
value - String キャプション

jsFunction_setDefault_value

public void jsFunction_setDefault_value(String value)
デフォルト値を設定します。

パラメータ:
value - String デフォルト値

jsFunction_setDomain

public void jsFunction_setDomain(String value)
ドメインを設定します。

パラメータ:
value - String ドメイン

jsFunction_setIndex_type

public void jsFunction_setIndex_type(String value)
インデックスタイプを設定します。

パラメータ:
value - String インデックスタイプ

jsFunction_setModifiable

public void jsFunction_setModifiable(String value)
編集可能フラグを設定します。

パラメータ:
value - String 編集可能フラグ(true/false)

jsFunction_setName

public void jsFunction_setName(String value)
名前を設定します。

パラメータ:
value - String 名前

jsFunction_setNullable

public void jsFunction_setNullable(String value)
Null許容フラグを設定します。

パラメータ:
value - String Null許容フラグ(true/false)

jsFunction_setRequired

public void jsFunction_setRequired(String value)
必須フラグを設定します。

パラメータ:
value - String 必須フラグ(true/false)

jsFunction_toString

public String jsFunction_toString()
設定されたCurlFieldBeanの文字列表現を返します。

戻り値:
CurlFieldBean.toStringの結果

getCaption

public String getCaption()

getDefault_value

public String getDefault_value()

getDomain

public String getDomain()

getIndex_type

public String getIndex_type()

getModifiable

public String getModifiable()

getName

public String getName()

getNullable

public String getNullable()

getRequired

public String getRequired()

setCaption

public void setCaption(String str)

setDefault_value

public void setDefault_value(String str)

setDomain

public void setDomain(String str)

setIndex_type

public void setIndex_type(String str)

setModifiable

public void setModifiable(String str)

setName

public void setName(String str)

setNullable

public void setNullable(String str)

setRequired

public void setRequired(String str)

jsConstructor

public static Object jsConstructor(jp.co.intra_mart.system.javascript.Context cx,
                                   Object[] args,
                                   jp.co.intra_mart.system.javascript.Function ctorObj,
                                   boolean inNewExpr)
コンストラクタ。

CurlFieldBeanオブジェクトを生成します。

戻り値:
Object CurlFieldBeanオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CurlXMLComposerObject (im_curl 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.javascript.im_curl
クラス CurlXMLComposerObject

java.lang.Object
    拡張 jp.co.intra_mart.system.javascript.ScriptableObject
        拡張 jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, Serializable
public class CurlXMLComposerObject
extends jp.co.intra_mart.system.javascript.ScriptableObject
implements Serializable

CurlXMLComposerオブジェクト。
Curlのelaborate-recordsetで解釈可能なXMLを生成するオブジェクトです。
このオブジェクトに対して、CurlFieldBeanオブジェクトとそれに対応するレコード情報を セットしたオブジェクトをセットすることでCurlのRecordSetに変換可能なXMLデータを 生成します。

CurlFieldBeanオブジェクトとレコード情報をセットしたオブジェクトを結びつけるためには、 CurlFieldBeanオブジェクトのsetName()で指定した文字列をオブジェクトのプロパティ名に 指定する必要があります。

 var curlFieldBean = new CurlFieldBean();
 curlFieldBean.setName("fieldName");
 ...
 var record = new Object();
 record.fieldName = "value";
 ...
 var curlXMLComposer = new CurlXMLComposer();
 curlXMLComposer.addField(curlFieldBean);
 curlXMLComposer.addRecord(record);

 xmlString = curlXMLComposer.toXML();
この実行結果(xmlString)の内容は次のようになります。
 <RecordSet>
 <Fields>
 <Field name="fieldName" ...>
 </Fields>
 <Record fieldName="value">
 </RecordSet>

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したフィールド
DONTENUM, EMPTY, PERMANENT, READONLY
インタフェース jp.co.intra_mart.system.javascript.Scriptable から継承したフィールド
NOT_FOUND
コンストラクタの概要
CurlXMLComposerObject()
引数なしコンストラクタ
CurlXMLComposerObject(CurlXMLComposer curlXMLComposer)
引数ありコンストラクタ
メソッドの概要
String | getClassName()
static Object | jsConstructor(jp.co.intra_mart.system.javascript.Context cx, Object[] args, jp.co.intra_mart.system.javascript.Function ctorObj, boolean inNewExpr) コンストラクタ。
void | jsFunction_addField(Object obj) CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。
void | jsFunction_addRecord(Object obj) レコード一覧リストにレコードを追加します。
void | jsFunction_setFieldList(Object obj) フィールド一覧リストをセットします。
void | jsFunction_setRecordList(Object obj) レコード一覧リストをセットします。
String | jsFunction_toXML() 指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したメソッド
associateValue, callMethod, callMethod, defineClass, defineClass, defineClass, defineFunctionProperties, defineProperty, defineProperty, defineProperty, defineProperty, delete, delete, deleteProperty, deleteProperty, equivalentValues, get, get, getAllIds, getAssociatedValue, getAttributes, getAttributes, getAttributes, getAttributes, getClassPrototype, getDefaultValue, getFunctionPrototype, getIds, getObjectPrototype, getParentScope, getProperty, getProperty, getPropertyIds, getPrototype, getTopLevelScope, getTopScopeValue, has, has, hasInstance, hasProperty, hasProperty, isSealed, put, put, putProperty, putProperty, sealObject, setAttributes, setAttributes, setAttributes, setAttributes, setParentScope, setPrototype, toDate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CurlXMLComposerObject

public CurlXMLComposerObject()
引数なしコンストラクタ

CurlXMLComposerObject

public CurlXMLComposerObject(CurlXMLComposer curlXMLComposer)
引数ありコンストラクタ

メソッドの詳細

getClassName

public String getClassName()
定義:
インタフェース jp.co.intra_mart.system.javascript.Scriptable 内の getClassName

jsFunction_addField

public void jsFunction_addField(Object obj)
CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。

パラメータ:
obj - Object CurlFieldBeanObject

jsFunction_addRecord

public void jsFunction_addRecord(Object obj)
レコード一覧リストにレコードを追加します。

パラメータ:
obj - Object レコード

jsFunction_setFieldList

public void jsFunction_setFieldList(Object obj)
フィールド一覧リストをセットします。
主にCurlXMLParser.getFieldsList()の結果を使用したい場合に使用します。

パラメータ:
obj - Object フィールド一覧リスト

jsFunction_setRecordList

public void jsFunction_setRecordList(Object obj)
レコード一覧リストをセットします。
主にCurlXMLParser.getRecordList()の結果を使用したい場合に使用します。

パラメータ:
obj - Object レコード一覧リスト

jsFunction_toXML

public String jsFunction_toXML()
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
通常、このメソッドの結果をHTMLへ引き渡し、Curlアプレットへの入力とします。

戻り値:
String Curlのelaborate-xmlで解釈可能なXML

jsConstructor

public static Object jsConstructor(jp.co.intra_mart.system.javascript.Context cx,
                                   Object[] args,
                                   jp.co.intra_mart.system.javascript.Function ctorObj,
                                   boolean inNewExpr)
コンストラクタ。

CurlXMLComposerオブジェクトを生成します。

戻り値:
Object CurlXMLComposerオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurlXMLParserObject (im_curl 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.javascript.im_curl
クラス CurlXMLParserObject

java.lang.Object
    拡張 jp.co.intra_mart.system.javascript.ScriptableObject
        拡張 jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, Serializable
public class CurlXMLParserObject
extends jp.co.intra_mart.system.javascript.ScriptableObject
implements Serializable

CurlXMLParserオブジェクト。
Curlで出力されたXML(recordset-to-xmlでの出力)を解釈し、CurlFieldBeanおよびレコード情報を 含むオブジェクトを生成します。
Curlアプレットから送信されたRecordSetの情報を取得するには、このオブジェクトの生成時に パラメータとして送信された文字列を与え、生成されたオブジェクトからgetRecordList()、 getFieldList()を呼び出します。
それぞれのメソッドの返り値はObject、CurlFieldBeanが格納されたArrayとなっています。

導入されたバージョン:
5.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したフィールド
DONTENUM, EMPTY, PERMANENT, READONLY
インタフェース jp.co.intra_mart.system.javascript.Scriptable から継承したフィールド
NOT_FOUND
コンストラクタの概要
CurlXMLParserObject()
引数なしコンストラクタ
CurlXMLParserObject(jp.co.intra_mart.system.javascript.im_curl.CurlXMLParser xmlParser)
引数ありコンストラクタ
メソッドの概要
String | getClassName()
static Object | jsConstructor(jp.co.intra_mart.system.javascript.Context cx, Object[] args, jp.co.intra_mart.system.javascript.Function ctorObj, boolean inNewExpr) コンストラクタ。
jp.co.intra_mart.system.javascript.Scriptable | jsFunction_getFieldList() パースした結果のフィールド一覧リストを返します。
jp.co.intra_mart.system.javascript.Scriptable | jsFunction_getRecordList() パースした結果のレコード一覧リストを返します。
String | toString()
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したメソッド
associateValue, callMethod, callMethod, defineClass, defineClass, defineClass, defineFunctionProperties, defineProperty, defineProperty, defineProperty, defineProperty, delete, delete, deleteProperty, deleteProperty, equivalentValues, get, get, getAllIds, getAssociatedValue, getAttributes, getAttributes, getAttributes, getAttributes, getClassPrototype, getDefaultValue, getFunctionPrototype, getIds, getObjectPrototype, getParentScope, getProperty, getProperty, getPropertyIds, getPrototype, getTopLevelScope, getTopScopeValue, has, has, hasInstance, hasProperty, hasProperty, isSealed, put, put, putProperty, putProperty, sealObject, setAttributes, setAttributes, setAttributes, setAttributes, setParentScope, setPrototype, toDate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurlXMLParserObject

public CurlXMLParserObject()
引数なしコンストラクタ

CurlXMLParserObject

public CurlXMLParserObject(jp.co.intra_mart.system.javascript.im_curl.CurlXMLParser xmlParser)
引数ありコンストラクタ

メソッドの詳細

toString

public String toString()

getClassName

public String getClassName()
定義:
インタフェース jp.co.intra_mart.system.javascript.Scriptable 内の getClassName

jsFunction_getRecordList

public jp.co.intra_mart.system.javascript.Scriptable jsFunction_getRecordList()
パースした結果のレコード一覧リストを返します。

次のようなXMLをコンストラクタのパラメータに指定した場合
 <RecordSet>
 <Fields>
 <Field name="fieldName" ...>
 </Fields>
 <Record fieldName="value">
 </RecordSet>

getRecordListの結果、および内容は次のようになります。
 var curlXMLParser = new CurlXMLParser(xmlString);
 var recordList = curlXMLParser.getRecordList();

 var record = recordList[0];
 var value = record.fieldName; // valueの内容は"value"
 var length = record.length;  // length(配列の要素数)は1

戻り値:
Array Objectの配列

jsFunction_getFieldList

public jp.co.intra_mart.system.javascript.Scriptable jsFunction_getFieldList()
パースした結果のフィールド一覧リストを返します。

戻り値:
Array CurlFieldBeanの配列

jsConstructor

public static Object jsConstructor(jp.co.intra_mart.system.javascript.Context cx,
                                   Object[] args,
                                   jp.co.intra_mart.system.javascript.Function ctorObj,
                                   boolean inNewExpr)
コンストラクタ。

RecordSetから変換されたXMLを解釈した結果を持つオブジェクトを生成します。
生成に失敗した場合は、nullを返却します。

戻り値:
Object CurlXMLParserオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.system.javascript.im_curl (im_curl 6.1.14 API)

 jp.co.intra_mart.system.javascript.im_curl
クラス
CurlFieldBeanObject
CurlXMLComposerObject
CurlXMLParserObject


jp.co.intra_mart.system.javascript.im_curl (im_curl 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.system.javascript.im_curl

クラスの概要
CurlFieldBeanObject | CurlFieldBeanオブジェクト。
CurlXMLComposerObject | CurlXMLComposerオブジェクト。
CurlXMLParserObject | CurlXMLParserオブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.system.javascript.im_curl クラス階層 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.system.javascript.im_curl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.javascript.ScriptableObject (implements jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject (implements java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject (implements java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.system.javascript.im_curl の使用 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.system.javascript.im_curl の使用

jp.co.intra_mart.system.javascript.im_curl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


すべてのクラス (im_curl 6.1.14 API)

 すべてのクラス
CurlFieldBean
CurlFieldBeanObject
CurlRecordBeanIF
CurlXMLComposer
CurlXMLComposerObject
CurlXMLParser
CurlXMLParserObject


定数フィールド値 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし
A C E F G I J R S T

A

addField(CurlFieldBean) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストにフィールドを追加します。
addRecord(CurlRecordBeanIF) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストにレコードを追加します。

C

CurlFieldBean - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean.
CurlフィールドBeanクラス
機能は以下の通り
CurlのRecordFieldクラスの属性情報を格納するBean
CurlFieldBean() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のコンストラクタ
CurlFieldBeanObject - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject.
CurlFieldBeanオブジェクト。
CurlFieldBeanObject() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のコンストラクタ
引数なしコンストラクタ
CurlFieldBeanObject(CurlFieldBean) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のコンストラクタ
引数ありコンストラクタ
CurlRecordBeanIF - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF.
CurlレコードBeanインタフェース
機能は以下の通り
CurlのRecordクラスの属性を格納するBean用のインタフェース
CurlXMLComposer - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer.
CurlXML生成クラス
機能は以下の通り
Curlで入力可能なXML(elaborate-recordsetで入力可能)を生成します。
CurlXMLComposer() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のコンストラクタ
CurlXMLComposerObject - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject.
CurlXMLComposerオブジェクト。
CurlXMLComposerObject() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のコンストラクタ
引数なしコンストラクタ
CurlXMLComposerObject(CurlXMLComposer) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のコンストラクタ
引数ありコンストラクタ
CurlXMLParser - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser.
CurlXMLパーサクラス
機能は以下の通り
Curlで出力されたXML(recordset-to-xmlでの出力)をパースします。
CurlXMLParser(String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたpathのXMLを パースします。
CurlXMLParser(InputStream, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のコンストラクタ
このクラス自身をハンドラとしたSAXパーサを作成し、指定されたInputStreamから取得したXMLを パースします。
CurlXMLParserObject - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject.
CurlXMLParserオブジェクト。
CurlXMLParserObject() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject のコンストラクタ
引数なしコンストラクタ
CurlXMLParserObject(CurlXMLParser) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject のコンストラクタ
引数ありコンストラクタ
createField(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがFieldの場合のパーサの動作を定義します。
createRecord(Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
qNameがRecordの場合のパーサの動作を定義します。

E

endElement(String, String, String) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。

F

field - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBean
fieldsList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するCurlFieldBeanクラスのインスタンス格納用リスト

G

getCaption() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを返します。
getCaption() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getClassName() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getClassName() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のメソッド
getClassName() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject のメソッド
getCurlFieldBean() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
セットされたCurlFieldBeanを返します。
getDefault_value() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を返します。
getDefault_value() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getDomain() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを返します。
getDomain() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getFieldsList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のフィールド一覧リストを返します。
getIndex_type() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを返します。
getIndex_type() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getModifiable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を返します。
getModifiable() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getName() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を返します。
getName() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getNullable() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を返します。
getNullable() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
getRecordList() - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
パースした結果のレコード一覧リストを返します。
getRequired() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を返します。
getRequired() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド

I

instance - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するJavaBeans

J

jp.co.intra_mart.foundation.im_curl - package jp.co.intra_mart.foundation.im_curl
intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.system.javascript.im_curl - package jp.co.intra_mart.system.javascript.im_curl
jsConstructor(Context, Object[], Function, boolean) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject の static メソッド
コンストラクタ。
jsConstructor(Context, Object[], Function, boolean) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject の static メソッド
コンストラクタ。
jsConstructor(Context, Object[], Function, boolean) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject の static メソッド
コンストラクタ。
jsFunction_addField(Object) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のメソッド
CurlFieldBeanをパラメータとして指定した場合、 フィールド一覧リストにフィールドとして追加します。
jsFunction_addRecord(Object) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のメソッド
レコード一覧リストにレコードを追加します。
jsFunction_getCaption() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
キャプションを取得します。
jsFunction_getDefault_value() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
デフォルト値を取得します。
jsFunction_getDomain() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
ドメインを取得します。
jsFunction_getFieldList() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject のメソッド
パースした結果のフィールド一覧リストを返します。
jsFunction_getIndex_type() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
インデックスタイプを取得します。
jsFunction_getModifiable() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
編集可能フラグを取得します。
jsFunction_getName() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
名前を取得します。
jsFunction_getNullable() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
Null許容フラグを取得します。
jsFunction_getRecordList() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject のメソッド
パースした結果のレコード一覧リストを返します。
jsFunction_getRequired() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
必須フラグを取得します。
jsFunction_setCaption(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
キャプションを設定します。
jsFunction_setDefault_value(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
デフォルト値を設定します。
jsFunction_setDomain(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
ドメインを設定します。
jsFunction_setFieldList(Object) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のメソッド
フィールド一覧リストをセットします。
jsFunction_setIndex_type(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
インデックスタイプを設定します。
jsFunction_setModifiable(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
編集可能フラグを設定します。
jsFunction_setName(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
名前を設定します。
jsFunction_setNullable(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
Null許容フラグを設定します。
jsFunction_setRecordList(Object) - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のメソッド
レコード一覧リストをセットします。
jsFunction_setRequired(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
必須フラグを設定します。
jsFunction_toString() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
設定されたCurlFieldBeanの文字列表現を返します。
jsFunction_toXML() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject のメソッド
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。

R

recordList - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser の変数
に対応するクラスのインスタンス格納用リスト

S

setCaption(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
キャプションを格納します。
setCaption(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setDefault_value(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
デフォルト値を格納します。
setDefault_value(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setDomain(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
ドメインを格納します。
setDomain(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setFieldList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
フィールド一覧リストをセットします。
setIndex_type(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
インデックスタイプを格納します。
setIndex_type(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setModifiable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
変更可能の可否を格納します。
setModifiable(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setName(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
名前を格納します。
setName(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setNullable(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
Null受付の可否を格納します。
setNullable(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
setRecordList(ArrayList) - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
レコード一覧リストをセットします。
setRequired(String) - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
フォーカスの要求の有無を格納します。
setRequired(String) - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
startElement(String, String, String, Attributes) - class jp.co.intra_mart.foundation.im_curl.CurlXMLParser のメソッド
DefaultHandlerのabstractメソッドをオーバーライドします。

T

toString() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
オブジェクトを文字列に変換します。
toString() - class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject のメソッド
toString() - class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject のメソッド
toXML() - class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer のメソッド
指定されたフィールド定義、レコードからCurlで入力可能なXML(elaborate-xmlで 入力可能)を生成します。
toXMLNode() - class jp.co.intra_mart.foundation.im_curl.CurlFieldBean のメソッド
このインスタンスのXMLノードとしての文字列を返します。
toXMLNode() - interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF のメソッド
保持しているデータをXMLノードの文字列に変換します。
A C E F G I J R S T
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_curl 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_curl 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.im_curl
jp.co.intra_mart.system.javascript.im_curl


概要 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_curl API Specifications

パッケージ
jp.co.intra_mart.foundation.im_curl | intra-martとCurlとの通信時に使用するXMLデータを扱うクラスのパッケージです。
jp.co.intra_mart.system.javascript.im_curl |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.im_curl, jp.co.intra_mart.system.javascript.im_curl

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.im_curl.CurlFieldBean
    • class jp.co.intra_mart.foundation.im_curl.CurlXMLComposer
    • class org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • class jp.co.intra_mart.foundation.im_curl.CurlXMLParser
    • class jp.co.intra_mart.system.javascript.ScriptableObject (implements jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject (implements java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject (implements java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.foundation.im_curl.CurlRecordBeanIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_curl 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_curl 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.system.javascript.im_curl

クラス jp.co.intra_mart.system.javascript.im_curl.CurlFieldBeanObject は jp.co.intra_mart.system.javascript.ScriptableObject を拡張し、Serializable を実装しています

直列化されたフィールド

curlFieldBean

CurlFieldBean curlFieldBean

クラス jp.co.intra_mart.system.javascript.im_curl.CurlXMLComposerObject は jp.co.intra_mart.system.javascript.ScriptableObject を拡張し、Serializable を実装しています

直列化されたフィールド

curlXMLComposer

CurlXMLComposer curlXMLComposer

fieldList

ArrayList fieldList

recordList

ArrayList recordList

クラス jp.co.intra_mart.system.javascript.im_curl.CurlXMLParserObject は jp.co.intra_mart.system.javascript.ScriptableObject を拡張し、Serializable を実装しています

直列化されたフィールド

xmlParser

CurlXMLParser xmlParser

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.JavaMailSender の使用

jp.co.intra_mart.foundation.mail.javamail.JavaMailSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.StandardMail の使用

StandardMail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |

jp.co.intra_mart.foundation.mail.javamail での StandardMail の使用

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail のコンストラクタ
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

jp.co.intra_mart.foundation.mail.javamail.listener での StandardMail の使用

StandardMail を返す jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 StandardMail MailSendEvent.getMail()
メールの属性を取得します。

StandardMail 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 void MailSendEvent.setMail(StandardMail mail)
メールの属性を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent の使用

MailSendEvent を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener での MailSendEvent の使用

MailSendEvent 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener のメソッド
 int MailSendListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSendEvent の使用

MailSendEvent 型のパラメータを持つ jp.co.intra_mart.foundation.mail.javamail.listener.impl のメソッド
 int HalfKanaTransrateListener.onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の使用

MailSendListener を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener.impl での MailSendListener の使用

MailSendListener を実装している jp.co.intra_mart.foundation.mail.javamail.listener.impl のクラス
 class HalfKanaTransrateListener
送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MailSendEvent (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener
クラス MailSendEvent

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent
public class MailSendEvent
extends Object

メール送信イベントです。

導入されたバージョン:
6.1.8

コンストラクタの概要
MailSendEvent()
SendMailEventを新規に生成します。
メソッドの概要
StandardMail | getMail() メールの属性を取得します。
Session | getSession() メール送信のセッションを取得します。
void | setMail(StandardMail mail) メールの属性を設定します。
void | setSession(Session session) メール送信のセッションを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MailSendEvent

public MailSendEvent()
SendMailEventを新規に生成します。

メソッドの詳細

getMail

public StandardMail getMail()
メールの属性を取得します。

戻り値:
メールの属性

setMail

public void setMail(StandardMail mail)
メールの属性を設定します。

パラメータ:
mail - メールの属性

getSession

public Session getSession()
メール送信のセッションを取得します。

戻り値:
セッション

setSession

public void setSession(Session session)
メール送信のセッションを設定します。

パラメータ:
session - セッション
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailSendListener (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener
インタフェース MailSendListener

既知の実装クラスの一覧:
HalfKanaTransrateListener
public interface MailSendListener

メール送信イベントのListenerインタフェースです。

リスナを利用するには、MailSendListenerの実装クラスを作成し、 onSendMail(MailSendEvent)メソッドを実装してください。 そのクラス名をServerManager上の /conf/mail/mailSendListener.xmlに記述してください。以下はその記述例です。

 <listener-config>
   <listener>
     <listener-class>foo.TestListener1</listener-class>
   </listener>
   <listener>
     <listener-class>foo.TestListener2</listener-class>
   </listener>
 </listener-config>

リスナはメール送信時に、記述されている順に実行されます。 また、リスナのスキップや送信の中止も可能です。 通常onSendMail(MailSendEvent)メソッドの戻り値はCONTINUEです。 リスナ実行中に以降のリスナをスキップする場合はSKIP_LISTENERを返却してください。 メール送信を行わない場合はSTOP_MAILSENDを返却してください。

導入されたバージョン:
6.1.8

フィールドの概要
static int | CONTINUE リスナー処理を続行し、メール送信を行います。
static int | SKIP_LISTENER リスナー処理を中止し、メール送信を行います。
static int | STOP_MAILSEND リスナー処理を中止し、メール送信を中止します。
メソッドの概要
 int onSendMail(MailSendEvent event)
メール送信が行われたことを通知します。

フィールドの詳細

CONTINUE

public static final int CONTINUE
リスナー処理を続行し、メール送信を行います。

関連項目:
定数フィールド値

SKIP_LISTENER

public static final int SKIP_LISTENER
リスナー処理を中止し、メール送信を行います。

関連項目:
定数フィールド値

STOP_MAILSEND

public static final int STOP_MAILSEND
リスナー処理を中止し、メール送信を中止します。

関連項目:
定数フィールド値
メソッドの詳細

onSendMail

public int onSendMail(MailSendEvent event)
               throws jp.co.intra_mart.foundation.mail.MailSenderException
メール送信が行われたことを通知します。
メール送信イベントを受け取り、次のリスナーに処理を移します。

パラメータ:
event - メール送信イベント
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - リスナーで例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.listener (im_javamail 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.listener
インタフェース
MailSendListener
クラス
MailSendEvent


jp.co.intra_mart.foundation.mail.javamail.listener (im_javamail 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener

インタフェースの概要
MailSendListener メール送信イベントのListenerインタフェースです。

クラスの概要
MailSendEvent メール送信イベントです。


jp.co.intra_mart.foundation.mail.javamail.listener クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener


パッケージ jp.co.intra_mart.foundation.mail.javamail.listener の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.listener の使用

jp.co.intra_mart.foundation.mail.javamail.listener を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail.javamail.listener のクラス
MailSendEvent
メール送信イベントです。

jp.co.intra_mart.foundation.mail.javamail.listener.impl により使用される jp.co.intra_mart.foundation.mail.javamail.listener のクラス
MailSendEvent
メール送信イベントです。
MailSendListener
メール送信イベントのListenerインタフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile の使用

jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.mail.javamail.model.MailAddress の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.mail.javamail.model.MailAddress の使用

MailAddress を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail での MailAddress の使用

MailAddress を返す jp.co.intra_mart.foundation.mail.javamail のメソッド
 MailAddress StandardMail.getFrom()
Fromを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AttachmentFile (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.model
インタフェース AttachmentFile

public interface AttachmentFile

添付ファイルのモデルです。

導入されたバージョン:
6.1.8

メソッドの概要
String | getFile() 添付ファイルを取得します。
String | getName() 添付ファイルのファイル名を取得します。

メソッドの詳細

getName

public String getName()
添付ファイルのファイル名を取得します。

戻り値:
ファイル名

getFile

public String getFile()
添付ファイルを取得します。

戻り値:
添付ファイル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MailAddress (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.model
インタフェース MailAddress

public interface MailAddress

メールアドレスのモデルです。

導入されたバージョン:
6.1.8

メソッドの概要
String | getAddress() メールアドレスを取得します。
String | getPersonal() 名前を取得します。

メソッドの詳細

getPersonal

public String getPersonal()
名前を取得します。

戻り値:
名前

getAddress

public String getAddress()
メールアドレスを取得します。

戻り値:
メールアドレス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.model (im_javamail 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.model
インタフェース
AttachmentFile
MailAddress


jp.co.intra_mart.foundation.mail.javamail.model (im_javamail 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.model

インタフェースの概要
AttachmentFile | 添付ファイルのモデルです。
MailAddress | メールアドレスのモデルです。


jp.co.intra_mart.foundation.mail.javamail.model クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.model の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile
  • interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress


パッケージ jp.co.intra_mart.foundation.mail.javamail.model の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.model の使用

jp.co.intra_mart.foundation.mail.javamail.model を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail メール送信クラスを提供します。

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail.model のクラス
MailAddress
メールアドレスのモデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException の使用

JavaMailPropertyException を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyException の使用

JavaMailPropertyException をスローする jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の使用

JavaMailPropertyHandler を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property での JavaMailPropertyHandler の使用

JavaMailPropertyHandler を返す jp.co.intra_mart.foundation.mail.javamail.property のメソッド
static JavaMailPropertyHandler JavaMailPropertyHandler.getInstance()
JavaMailPropertyHandlerのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl の使用

jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


JavaMailPropertyException (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException
すべての実装インタフェース:
Serializable
public class JavaMailPropertyException
extends Exception

JavaMailSenderの設定に関する情報を提供する例外です。

導入されたバージョン:
5.0
関連項目:
直列化された形式

コンストラクタの概要
JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyException

public JavaMailPropertyException()
JavaMailPropertyExceptionを構築します。

JavaMailPropertyException

public JavaMailPropertyException(String message)
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -

JavaMailPropertyException

public JavaMailPropertyException(String message,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
message -
cause -

JavaMailPropertyException

public JavaMailPropertyException(Throwable cause)
指定された原因を使用してJavaMailPropertyExceptionを構築します。

パラメータ:
cause -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandler (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
public class JavaMailPropertyHandler
extends Object

JavaMailSenderの設定を保持します。

導入されたバージョン:
5.0.2

メソッドの概要
String | getCharset(Locale locale) キャラクターセットを取得します。
String | getContentTransferEncoding(Locale locale) Content-Transfer-Encodingを取得します。
String | getContentType(String ext) コンテントタイプを取得します。
boolean | getDebugOption() JavaMailに設定するデバック設定の有無を取得します。
static JavaMailPropertyHandler | getInstance() JavaMailPropertyHandlerのインスタンスを取得します。
Collection | getListeners() メール送信リスナを取得します。
String | getMimeEncoding(Locale locale) MIMEエンコードを取得します。
int | getSMTPConnectionTimeout() SMTPサーバへのコネクションタイムアウト時間を取得します。
String | getSMTPPassword() SMTP認証のパスワードを取得します
int | getSMTPTimeout() SMTPサーバとの入出力タイムアウト時間を取得します。
String | getSMTPUser() SMTP認証のユーザを取得します
String | getXMailerHeader() 送信メールに付加するX-Mailerヘッダを取得します。
boolean | isEnableSMTPAuth() SMTP認証の有効/無効を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInstance

public static JavaMailPropertyHandler getInstance()
                                           throws JavaMailPropertyException
JavaMailPropertyHandlerのインスタンスを取得します。

戻り値:
JavaMailPropertyHandlerのインスタンス
例外:
JavaMailPropertyException

getContentType

public String getContentType(String ext)
コンテントタイプを取得します。

パラメータ:
ext - ドットを含む拡張子
戻り値:
コンテントタイプ

getXMailerHeader

public String getXMailerHeader()
送信メールに付加するX-Mailerヘッダを取得します。

戻り値:
X-Mailerヘッダ

getDebugOption

public boolean getDebugOption()
JavaMailに設定するデバック設定の有無を取得します。

戻り値:
デバック設定

getSMTPConnectionTimeout

public int getSMTPConnectionTimeout()
SMTPサーバへのコネクションタイムアウト時間を取得します。

戻り値:
タイムアウト時間

getSMTPTimeout

public int getSMTPTimeout()
SMTPサーバとの入出力タイムアウト時間を取得します。

戻り値:
タイムアウト時間

isEnableSMTPAuth

public boolean isEnableSMTPAuth()
SMTP認証の有効/無効を取得します。

戻り値:
SMTPの有効/無効
導入されたバージョン:
7.0.2

getSMTPUser

public String getSMTPUser()
SMTP認証のユーザを取得します

戻り値:
ユーザ
導入されたバージョン:
7.0.2

getSMTPPassword

public String getSMTPPassword()
SMTP認証のパスワードを取得します

戻り値:
パスワード
導入されたバージョン:
7.0.2

getCharset

public String getCharset(Locale locale)
キャラクターセットを取得します。

パラメータ:
locale - ロケール
戻り値:
キャラクターセット

getMimeEncoding

public String getMimeEncoding(Locale locale)
MIMEエンコードを取得します。

パラメータ:
locale - ロケール
戻り値:
エンコード

getContentTransferEncoding

public String getContentTransferEncoding(Locale locale)
Content-Transfer-Encodingを取得します。

パラメータ:
locale - ロケール
戻り値:
Content-Transfer-Encoding

getListeners

public Collection getListeners()
メール送信リスナを取得します。
コレクションの要素はMailSendListenerのインスタンスです。

戻り値:
メール送信リスナ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


JavaMailPropertyHandlerInitializerImpl (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.property
クラス JavaMailPropertyHandlerInitializerImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl
すべての実装インタフェース:
jp.co.intra_mart.system.service.ApplicationInitializer
public class JavaMailPropertyHandlerInitializerImpl
extends Object
implements jp.co.intra_mart.system.service.ApplicationInitializer

JavaMailPropertyHandlerの初期化クラス。

JavaMailSenderの設定を保持するJavaMailPropertyHandlerの初期化を行います。 アプリケーションライタイム起動時に呼ばれます。

導入されたバージョン:
6.0.2

コンストラクタの概要
JavaMailPropertyHandlerInitializerImpl()
メソッドの概要
 void initialize()
初期化処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailPropertyHandlerInitializerImpl

public JavaMailPropertyHandlerInitializerImpl()
メソッドの詳細

initialize

public void initialize()
初期化処理を行います。

定義:
インタフェース jp.co.intra_mart.system.service.ApplicationInitializer 内の initialize
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.property (im_javamail 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.property
クラス
JavaMailPropertyHandler
JavaMailPropertyHandlerInitializerImpl
例外
JavaMailPropertyException


jp.co.intra_mart.foundation.mail.javamail.property (im_javamail 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラスの概要
JavaMailPropertyHandler | JavaMailSenderの設定を保持します。
JavaMailPropertyHandlerInitializerImpl | JavaMailPropertyHandlerの初期化クラス。

例外の概要
JavaMailPropertyException JavaMailSenderの設定に関する情報を提供する例外です。


jp.co.intra_mart.foundation.mail.javamail.property クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.property の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException


パッケージ jp.co.intra_mart.foundation.mail.javamail.property の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.property の使用

jp.co.intra_mart.foundation.mail.javamail.property を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail.property

jp.co.intra_mart.foundation.mail.javamail.property により使用される jp.co.intra_mart.foundation.mail.javamail.property のクラス
JavaMailPropertyException
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyHandler
JavaMailSenderの設定を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


JavaMailSender (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス JavaMailSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.JavaMailSender
すべての実装インタフェース:
jp.co.intra_mart.foundation.mail.MailSender
public class JavaMailSender
extends Object
implements jp.co.intra_mart.foundation.mail.MailSender

JavaMailをラップしたメール送信オブジェクトです。
メールの送信情報はStandardMailのインスタンスにより 決定されます。

JavaMailSenderはリスナを実装することで、メール送信前に任意の処理を実行することが可能です。
リスナでは送信メールの情報を参照したり、送信を中止することも可能です。 リスナの詳しい説明についてはMailSendListener を参照してください。

導入されたバージョン:
5.0
関連項目:
StandardMail

コンストラクタの概要
JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。
メソッドの概要
 void send()
メールを送信します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

JavaMailSender

public JavaMailSender(StandardMail mail)
JavaMailSenderを新規に作成します。

パラメータ:
mail - 送信メール
メソッドの詳細

send

public void send()
          throws jp.co.intra_mart.foundation.mail.MailSenderException
メールを送信します。

定義:
インタフェース jp.co.intra_mart.foundation.mail.MailSender 内の send
例外:
jp.co.intra_mart.foundation.mail.MailSenderException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail (im_javamail 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail
クラス
JavaMailSender
StandardMail


jp.co.intra_mart.foundation.mail.javamail (im_javamail 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail

メール送信クラスを提供します。

参照:
説明

クラスの概要
JavaMailSender | JavaMailをラップしたメール送信オブジェクトです。
StandardMail | 送信するメールの属性を保管します。

パッケージ jp.co.intra_mart.foundation.mail.javamail の説明

メール送信クラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.mail.javamail クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.mail.javamail の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail の使用

jp.co.intra_mart.foundation.mail.javamail を使用しているパッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |

jp.co.intra_mart.foundation.mail.javamail により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

jp.co.intra_mart.foundation.mail.javamail.listener により使用される jp.co.intra_mart.foundation.mail.javamail のクラス
StandardMail
送信するメールの属性を保管します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StandardMail (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail
クラス StandardMail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.StandardMail
public class StandardMail
extends Object

送信するメールの属性を保管します。

  • キャラクターセット、エンコード
    このオブジェクトが保持するメールのキャラクターセット、エンコディングの設定は ロケールに依存します。ロケール毎の設定は定義ファイルをにより決定されます。
    ServerManager上に /conf/mail/encode.properties として、定義ファイルを配置してください。

    指定可能なキーの一覧
    charset | キャラクターセット
    mimeEncoding | MIMEエンコード (B or Q)
    contentTransferEncoding | ボディのエンコード

  • SMTP Authentication
    StandardMail は SMTP Authentication に対応しています。有効にする場合は ServerManager 上の /conf/mail/smtpAuth.properties を編集してください。

    enable SMTP Authの有効
    (true or false)
    user | ユーザID
    password | パスワード

導入されたバージョン:
5.0
関連項目:
JavaMailSender

コンストラクタの概要
StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。
メソッドの概要
void | addAttachment(String filename, String file) 添付ファイルを追加します。
void | addBcc(String address) Bccを追加します。
void | addBcc(String address, String personal) Bccを追加します。
void | addCc(String address) Ccを追加します。
void | addCc(String address, String personal) Ccを追加します。
void | addHeader(String name, String value) ヘッダーを追加します。
void | addReplyTo(String replyto) ReplyToを追加します。
void | addTo(String address) Toを追加します。
void | addTo(String address, String personal) Toを追加します。
protected Session | createSession(Properties prop) SMTPセッションを構築します。
Collection | getAttachment() 添付ファイルを取得します。
Collection | getBcc() Bccの一覧を取得します。
Collection | getCc() Ccの一覧を取得します。
MailAddress | getFrom() Fromを取得します。
Locale | getLocale() ロケールを取得します。
protected Properties | getProperties() JavaMailのSMTPセッションに渡す属性を初期化します。
String | getSubject() Subjectを取得します。
String | getText() 本文を取得します。
Collection | getTo() Toの一覧を取得します。
protected void | init() StandardMailオブジェクトを初期化します。
protected void | prepareMimeMessage(MimeMessage message) MIMEメッセージに対して操作を行います。
protected void | prepareSession(Session session) SMTPセッションに対して操作を行います。
void | setFrom(String address) Fromを設定します。
void | setFrom(String address, String personal) Fromを設定します。
void | setSubject(String subject) Subjectを設定します。
void | setText(String text) 本文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardMail

public StandardMail()
システムのロケールからメール属性オブジェクトを新規に作成します。

StandardMail

public StandardMail(Locale locale)
ロケールを指定してメール属性オブジェクトを新規に作成します。

パラメータ:
locale - 送信先ロケール
メソッドの詳細

init

protected void init()
             throws jp.co.intra_mart.foundation.mail.MailSenderException
StandardMailオブジェクトを初期化します。 このメソッドはJavaMailSender.send()から呼ばれます。

例外:
jp.co.intra_mart.foundation.mail.MailSenderException - StandardMailオブジェクトを初期化時に例外が発生。

getLocale

public Locale getLocale()
ロケールを取得します。

戻り値:
ロケール

getProperties

protected Properties getProperties()
                            throws jp.co.intra_mart.foundation.mail.MailSenderException
JavaMailのSMTPセッションに渡す属性を初期化します。

ここではSMTPサーバのホスト及びポートを設定します。
このメソッドはJavaMailSender.send()から呼ばれます。

戻り値:
属性
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - 属性設定時に例外が発生。

createSession

protected Session createSession(Properties prop)
                         throws jp.co.intra_mart.foundation.mail.MailSenderException
SMTPセッションを構築します。 SMTP認証が有効の場合は、認証情報が含まれたセッションを構築します。

パラメータ:
prop - 属性
戻り値:
SMTPセッション
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - SMTPセッション構築時に例外が発生
導入されたバージョン:
7.0.2

prepareSession

protected void prepareSession(Session session)
                       throws jp.co.intra_mart.foundation.mail.MailSenderException
SMTPセッションに対して操作を行います。

ここでは、JavaMailにデバックオプションを設定します。 設定値は"conf/mail/javaMail.properties"の設定値が有効となります。
このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
session - SMTPセッション
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - セッション操作中に例外が発生。

prepareMimeMessage

protected void prepareMimeMessage(MimeMessage message)
                           throws jp.co.intra_mart.foundation.mail.MailSenderException
MIMEメッセージに対して操作を行います。 このメソッドはJavaMailSender.send()から呼ばれます。

パラメータ:
message - メッセージ
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - メッセージ操作中に例外が発生。

addHeader

public void addHeader(String name,
                      String value)
ヘッダーを追加します。

パラメータ:
name - ヘッダーの名前
value - ヘッダーの値

addReplyTo

public void addReplyTo(String replyto)
ReplyToを追加します。

パラメータ:
replyto - ReplyToに追加するメールアドレス

setFrom

public void setFrom(String address)
Fromを設定します。

パラメータ:
address - メールアドレス

setFrom

public void setFrom(String address,
                    String personal)
Fromを設定します。

パラメータ:
address - メールアドレス
personal - 名前

setSubject

public void setSubject(String subject)
Subjectを設定します。

パラメータ:
subject - Subject

addTo

public void addTo(String address)
Toを追加します。

パラメータ:
address - メールアドレス

addTo

public void addTo(String address,
                  String personal)
Toを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addCc

public void addCc(String address)
Ccを追加します。

パラメータ:
address - メールアドレス

addCc

public void addCc(String address,
                  String personal)
Ccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

addBcc

public void addBcc(String address)
Bccを追加します。

パラメータ:
address - メールアドレス

addBcc

public void addBcc(String address,
                   String personal)
Bccを追加します。

パラメータ:
address - メールアドレス
personal - 名前

setText

public void setText(String text)
本文を設定します。

パラメータ:
text - 本文

addAttachment

public void addAttachment(String filename,
                          String file)
添付ファイルを追加します。

パラメータ:
filename - 添付ファイル名
file - ファイル

getAttachment

public Collection getAttachment()
添付ファイルを取得します。
コレクションの要素はAttachmentFileのインスタンスです。

戻り値:
添付ファイル

getSubject

public String getSubject()
Subjectを取得します。

戻り値:
Subject

getText

public String getText()
本文を取得します。

戻り値:
本文

getFrom

public MailAddress getFrom()
Fromを取得します。

戻り値:
from

getTo

public Collection getTo()
Toの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:

getCc

public Collection getCc()
Ccの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:

getBcc

public Collection getBcc()
Bccの一覧を取得します。
コレクションの要素はMailAddressのインスタンスです。

戻り値:
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (im_javamail 6.1.14 API)

 すべてのクラス
AttachmentFile
HalfKanaTransrateListener
HalfKanaTransrator
JavaMailPropertyException
JavaMailPropertyHandler
JavaMailPropertyHandlerInitializerImpl
JavaMailSender
MailAddress
MailSendEvent
MailSendListener
StandardMail


定数フィールド値 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener
public static final int | CONTINUE | 0
public static final int | SKIP_LISTENER | 1
public static final int | STOP_MAILSEND | 2

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし
A C G H I J M O P S T

A

AttachmentFile - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile.
添付ファイルのモデルです。
addAttachment(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを追加します。
addBcc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addBcc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccを追加します。
addCc(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addCc(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccを追加します。
addHeader(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ヘッダーを追加します。
addReplyTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ReplyToを追加します。
addTo(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。
addTo(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toを追加します。

C

CONTINUE - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を続行し、メール送信を行います。
createSession(Properties) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションを構築します。

G

getAddress() - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress のメソッド
メールアドレスを取得します。
getAttachment() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
添付ファイルを取得します。
getBcc() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Bccの一覧を取得します。
getCc() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Ccの一覧を取得します。
getCharset(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
キャラクターセットを取得します。
getContentTransferEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
Content-Transfer-Encodingを取得します。
getContentType(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
コンテントタイプを取得します。
getDebugOption() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
JavaMailに設定するデバック設定の有無を取得します。
getFile() - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile のメソッド
添付ファイルを取得します。
getFrom() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを取得します。
getInstance() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler の static メソッド
JavaMailPropertyHandlerのインスタンスを取得します。
getListeners() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
メール送信リスナを取得します。
getLocale() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
ロケールを取得します。
getMail() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メールの属性を取得します。
getMimeEncoding(Locale) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
MIMEエンコードを取得します。
getName() - interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile のメソッド
添付ファイルのファイル名を取得します。
getPersonal() - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress のメソッド
名前を取得します。
getProperties() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
JavaMailのSMTPセッションに渡す属性を初期化します。
getSMTPConnectionTimeout() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTPサーバへのコネクションタイムアウト時間を取得します。
getSMTPPassword() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証のパスワードを取得します
getSMTPTimeout() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTPサーバとの入出力タイムアウト時間を取得します。
getSMTPUser() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証のユーザを取得します
getSession() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メール送信のセッションを取得します。
getSubject() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを取得します。
getText() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を取得します。
getTo() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Toの一覧を取得します。
getXMailerHeader() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
送信メールに付加するX-Mailerヘッダを取得します。

H

HalfKanaTransrateListener - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener.
送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。
HalfKanaTransrateListener() - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のコンストラクタ
HalfKanaTransrateListenerを新規に生成します。
HalfKanaTransrator - class jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator.
半角カナ文字を全角カナ文字に変換します。

I

init() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
StandardMailオブジェクトを初期化します。
initialize() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl のメソッド
初期化処理を行います。
isEnableSMTPAuth() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler のメソッド
SMTP認証の有効/無効を取得します。

J

JavaMailPropertyException - exception jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException.
JavaMailSenderの設定に関する情報を提供する例外です。
JavaMailPropertyException() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
JavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージを使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(String, Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された詳細メッセージおよび原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyException(Throwable) - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException のコンストラクタ
指定された原因を使用してJavaMailPropertyExceptionを構築します。
JavaMailPropertyHandler - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler.
JavaMailSenderの設定を保持します。
JavaMailPropertyHandlerInitializerImpl - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl.
JavaMailPropertyHandlerの初期化クラス。
JavaMailPropertyHandlerInitializerImpl() - class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl のコンストラクタ
JavaMailSender - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender.
JavaMailをラップしたメール送信オブジェクトです。
JavaMailSender(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のコンストラクタ
JavaMailSenderを新規に作成します。
jp.co.intra_mart.foundation.mail.javamail - package jp.co.intra_mart.foundation.mail.javamail
メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener - package jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl - package jp.co.intra_mart.foundation.mail.javamail.listener.impl
jp.co.intra_mart.foundation.mail.javamail.model - package jp.co.intra_mart.foundation.mail.javamail.model
jp.co.intra_mart.foundation.mail.javamail.property - package jp.co.intra_mart.foundation.mail.javamail.property
jp.co.intra_mart.foundation.mail.util - package jp.co.intra_mart.foundation.mail.util

M

MailAddress - interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress.
メールアドレスのモデルです。
MailSendEvent - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent.
メール送信イベントです。
MailSendEvent() - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のコンストラクタ
SendMailEventを新規に生成します。
MailSendListener - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener.
メール送信イベントのListenerインタフェースです。

O

onSendMail(MailSendEvent) - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener のメソッド
メール送信が行われたことを通知します。
onSendMail(MailSendEvent) - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のメソッド
メール送信が行われたことを通知します。

P

prepareMimeMessage(MimeMessage) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
MIMEメッセージに対して操作を行います。
prepareSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
SMTPセッションに対して操作を行います。

S

SKIP_LISTENER - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を中止し、メール送信を行います。
STOP_MAILSEND - interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener の static 変数
リスナー処理を中止し、メール送信を中止します。
StandardMail - class jp.co.intra_mart.foundation.mail.javamail.StandardMail.
送信するメールの属性を保管します。
StandardMail() - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
システムのロケールからメール属性オブジェクトを新規に作成します。
StandardMail(Locale) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のコンストラクタ
ロケールを指定してメール属性オブジェクトを新規に作成します。
send() - class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender のメソッド
メールを送信します。
setFrom(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setFrom(String, String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Fromを設定します。
setMail(StandardMail) - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メールの属性を設定します。
setSession(Session) - class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent のメソッド
メール送信のセッションを設定します。
setSubject(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
Subjectを設定します。
setText(String) - class jp.co.intra_mart.foundation.mail.javamail.StandardMail のメソッド
本文を設定します。

T

translate(String) - class jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator の static メソッド
文字列を変換します。
transliterate(String) - class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener のメソッド
指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。
A C G H I J M O P S T
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_javamail 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_javamail 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.mail.javamail
jp.co.intra_mart.foundation.mail.javamail.listener
jp.co.intra_mart.foundation.mail.javamail.listener.impl
jp.co.intra_mart.foundation.mail.javamail.model
jp.co.intra_mart.foundation.mail.javamail.property
jp.co.intra_mart.foundation.mail.util


概要 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_javamail API Specifications

パッケージ
jp.co.intra_mart.foundation.mail.javamail | メール送信クラスを提供します。
jp.co.intra_mart.foundation.mail.javamail.listener |
jp.co.intra_mart.foundation.mail.javamail.listener.impl |
jp.co.intra_mart.foundation.mail.javamail.model |
jp.co.intra_mart.foundation.mail.javamail.property |
jp.co.intra_mart.foundation.mail.util |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.mail.javamail, jp.co.intra_mart.foundation.mail.javamail.listener, jp.co.intra_mart.foundation.mail.javamail.listener.impl, jp.co.intra_mart.foundation.mail.javamail.model, jp.co.intra_mart.foundation.mail.javamail.property, jp.co.intra_mart.foundation.mail.util

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener (implements jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener)
    • class jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandler
    • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyHandlerInitializerImpl (implements jp.co.intra_mart.system.service.ApplicationInitializer)
    • class jp.co.intra_mart.foundation.mail.javamail.JavaMailSender (implements jp.co.intra_mart.foundation.mail.MailSender)
    • class jp.co.intra_mart.foundation.mail.javamail.listener.MailSendEvent
    • class jp.co.intra_mart.foundation.mail.javamail.StandardMail
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException

インタフェース階層

  • interface jp.co.intra_mart.foundation.mail.javamail.model.AttachmentFile
  • interface jp.co.intra_mart.foundation.mail.javamail.model.MailAddress
  • interface jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_javamail 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.mail.javamail.property

クラス jp.co.intra_mart.foundation.mail.javamail.property.JavaMailPropertyException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream の使用

ExtendedInputStream を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedInputStream の使用

ExtendedInputStream を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 ExtendedInputStream ExtendedSocket.getInputStream()
入力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の使用

ExtendedOutputStream を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedOutputStream の使用

ExtendedOutputStream を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 ExtendedOutputStream ExtendedSocket.getOutputStream()
出力ストリームの取得。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.FileUtil の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.FileUtil の使用

jp.co.intra_mart.common.aid.jdk.java.io.FileUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter の使用

jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader の使用

jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter の使用

jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream の使用

jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.Directory の使用

Directory を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での Directory の使用

jp.co.intra_mart.common.aid.jdk.java.io.file での Directory のサブクラス
 class ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory の使用

ExtendedDirectory を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での ExtendedDirectory の使用

ExtendedDirectory を返す jp.co.intra_mart.common.aid.jdk.java.io.file のメソッド
ExtendedDirectory | ExtendedDirectory.childDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedDirectory | ExtendedDirectory.findDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile の使用

ExtendedFile を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file での ExtendedFile の使用

ExtendedFile を返す jp.co.intra_mart.common.aid.jdk.java.io.file のメソッド
ExtendedFile | ExtendedDirectory.childFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected ExtendedFile | ExtendedDirectory.findFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Directory (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス Directory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
すべての実装インタフェース:
Comparable, Serializable
直系の既知のサブクラス:
ExtendedDirectory
public class Directory
extends File

このクラスは、ディレクトリを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ディレクトリである場合に利用することができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
Directory(File parent, String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(String parent, String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
Collection | childDirectories() この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
Collection | childFiles() この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
boolean | deleteAll() このディレクトリパスを削除します。
void | deleteChilds() このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
Collection | files(int depth) この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
Collection | paths(int depth) この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Directory

public Directory(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(File parent,
                 String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)

Directory

public Directory(String parent,
                 String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

childDirectories

public Collection childDirectories()
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ディレクトリを表す java.io.File クラスのインスタンスです。

戻り値:
ディレクトリパスを繰り返し処理する反復子

childFiles

public Collection childFiles()
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

戻り値:
ファイルパスを繰り返し処理する反復子

deleteAll

public boolean deleteAll()
                  throws IOException
このディレクトリパスを削除します。 このディレクトリがファイルまたはサブディレクトリを持つ場合、 それらもすべて削除します。

このメソッドは複数のパスを削除しますが、すべてのパスを削除したか、 またはしないことを保証するものではありません。 このディレクトリパスの削除に失敗した場合でも、 このディレクトリに含まれるいくつかのパスが削除される場合があります。

戻り値:
このディレクトリパスの削除に成功した場合 true。それ以外の場合 false。
例外:
IOException - このディレクトリパスに含まれるいずれかのパスの削除に失敗した場合。

deleteChilds

public void deleteChilds()
                  throws IOException
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。 このサブディレクトリに含まれるファイルやサブディレクトリも 再帰的に検索し、すべて削除します。

このメソッドが false を返した場合でも、 いくつかのパスが削除される場合があります。

例外:
IOException - このディレクトリパスに含まれるいずれかのパスの削除に失敗した場合。

paths

public Collection paths(int depth)
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルまたはディレクトリを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合

files

public Collection files(int depth)
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。 反復子が返す各要素は、ファイルを表す java.io.File クラスのインスタンスです。

パラメータ:
depth - 検索をするサブディレクトリの深さ
戻り値:
ファイルパスを繰り返し処理する反復子
例外:
IllegalArgumentException - depth 引数が 1 よりも小さい場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedDirectory (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス ExtendedDirectory

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
すべての実装インタフェース:
Comparable, Serializable
public class ExtendedDirectory
extends Directory

File インスタンスを作成するためのファクトリクラスです。

このクラスは、指定のディレクトリを親とすして、相対パスにより解決される 抽象パスを表す File インスタンスを生成する機能を提供します。 生成された File インスタンスは、オブジェクト内にプールされるため、 同じパスを繰り返し利用ようなプログラムで利用することにより、 メモリリソースを節約することができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedDirectory(File parent, String path, int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(String pathname, int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
メソッドの概要
void | archive(File f) このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(File f, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
void | archive(OutputStream out) このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(OutputStream out, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out) このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
void | archive(ZipOutputStream out, FileFilter filter) このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
ExtendedDirectory | childDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
ExtendedFile | childFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
File | childPath(String path) このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
protected ExtendedDirectory | findDirectory(String path) このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
protected ExtendedFile | findFile(String path) このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
protected File | findPath(String path) このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
void | reset() キャッシュ領域をクリアします。
クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory から継承したメソッド
childDirectories, childFiles, deleteAll, deleteChilds, files, paths
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedDirectory

public ExtendedDirectory(String pathname,
                         int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
pathname - ディレクトリパス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合

ExtendedDirectory

public ExtendedDirectory(File parent,
                         String path,
                         int size)
File オブジェクトを作成するためのファクトリオブジェクトを作成します。

このオブジェクトは、File インスタンスのプール機能を実装しています。 このオブジェクトのパスは、parent を親ディレクトリとした 子抽象パス path により解決されます。
引数 size はプールのサイズを指定して下さい。プールは、最大で size 個のインスタンスをキャッシュするように動作します。

パラメータ:
parent - 親ディレクトリ
path - パス
size - キャッシュサイズ
例外:
NullPointerException - 引数 parent が null の場合
IllegalArgumentException - 引数 size が 1 よりも小さい場合
メソッドの詳細

childFile

public ExtendedFile childFile(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

findFile

protected ExtendedFile findFile(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。

このメソッドは、childFile メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合

childDirectory

public ExtendedDirectory childDirectory(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。 このメソッドは、このオブジェクトのプール許容値と等しい プール許容値を持つ ExtendedDirectory のインスタンスを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

findDirectory

protected ExtendedDirectory findDirectory(String path)
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。

このメソッドは、childDirectory メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合
IllegalArgumentException - 指定の抽象パスがファイルとして存在している場合

childPath

public File childPath(String path)
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

findPath

protected File findPath(String path)
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。

このメソッドは、childPath メソッドが要求されたファイルオブジェクトを プールしていなかった場合に、新しいファイルオブジェクトを作成するために 呼び出します。 サブクラスは、このメソッドをオーバーライドすることにより、 ファイルインスタンスを任意に作成することができます。

このメソッドは、単純にこのオブジェクトを親ディレクトリとして 引数 path を解決したファイルオブジェクトを作成して返します。

パラメータ:
path - 子パス名文字列
戻り値:
path から作成される File インスタンス
例外:
NullPointerException - path が null の場合

reset

public void reset()
キャッシュ領域をクリアします。

archive

public void archive(File f)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(File f,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。 作成されるファイルは、ZIP ファイル形式となります。 ファイルに出力されるファイルは、フィルタの基準を満たす必要があります。 圧縮されるファイルは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
f - 出力ファイルパス
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(OutputStream out,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

パラメータ:
out - 出力ストリーム
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合

archive

public void archive(ZipOutputStream out,
                    FileFilter filter)
             throws IOException
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。 ストリームに出力されるファイルは、フィルタの基準を満たす必要があります。 ストリームにファイルの内容が出力されるのは、 FileFilter.accept(java.io.File) メソッドが呼び出されたときに true が返される場合だけです。

パラメータ:
out - 出力ストリーム
filter - ファイル名フィルタ
例外:
IOException - 入出力エラー
NullPointerException - 引数が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedFile (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io.file
クラス ExtendedFile

java.lang.Object
    拡張 java.io.File
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
すべての実装インタフェース:
Comparable, Serializable
public class ExtendedFile
extends File

このクラスは、ファイルを扱う時に便利な機能を提供します。

このクラスは java.io.File クラスをベースに、オブジェクトが表す抽象パスが ファイルである場合に利用することができます。

導入されたバージョン:
version 5.0
関連項目:
File, ExtendedDirectory, 直列化された形式

フィールドの概要
クラス java.io.File から継承したフィールド
pathSeparator, pathSeparatorChar, separator, separatorChar
コンストラクタの概要
ExtendedFile(File parent, String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(String parent, String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
メソッドの概要
void | append(byte[] b) 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | append(String str) デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | append(String str, String enc) 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
byte[] | getBytes() この抽象パスが表すファイルからデータを読み込みます。
Iterator | readLines() ファイルの行を繰り返し処理する反復子を作成します。
Iterator | readLines(String enc) ファイルの行を繰り返し処理する反復子を作成します。
String | readString() このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
String | readString(String enc) このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
void | write(byte[] b) 指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
void | write(String str) デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
void | write(String str, String enc) 指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
クラス java.io.File から継承したメソッド
canRead, canWrite, compareTo, compareTo, createNewFile, createTempFile, createTempFile, delete, deleteOnExit, equals, exists, getAbsoluteFile, getAbsolutePath, getCanonicalFile, getCanonicalPath, getName, getParent, getParentFile, getPath, hashCode, isAbsolute, isDirectory, isFile, isHidden, lastModified, length, list, list, listFiles, listFiles, listFiles, listRoots, mkdir, mkdirs, renameTo, setLastModified, setReadOnly, toString, toURI, toURL
クラス java.lang.Object から継承したメソッド
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedFile

public ExtendedFile(String pathname)
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。 指定された文字列が空の文字列の場合、結果は空の抽象パス名になります。

パラメータ:
pathname - パス名文字列
例外:
NullPointerException - pathname 引数が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(File parent,
                    String child)
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。

そうでない場合、parent 抽象パス名はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の抽象パス名の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、その結果をシステムに依存する デフォルトディレクトリを基準に解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親抽象パス名
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)

ExtendedFile

public ExtendedFile(String parent,
                    String child)
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。

parent が null の場合、新しい File のインスタンスは、 指定された child パス名文字列で単一引数の File コンストラクタを 呼び出したように生成されます。 そうでない場合、parent パス名文字列はディレクトリを示し、 child パス名文字列はディレクトリまたはファイルを示します。 child パス名文字列が絶対の場合、 それはシステムに依存する方法で相対パス名に変換されます。 parent が空の文字列の場合、新しい File のインスタンスは、 child を抽象パス名に変換し、 その結果をシステムに依存するデフォルトディレクトリを基準に 解決することで生成されます。 そうでない場合、各パス名文字列は抽象パス名に変換され、 子抽象パス名は親を基準に解決されます。

パラメータ:
parent - 親パス名文字列
child - 子パス名文字列
例外:
NullPointerException - child が null の場合
IllegalArgumentException - 指定の抽象パスがディレクトリとして存在している場合
関連項目:
File.File(File, String)
メソッドの詳細

getBytes

public byte[] getBytes()
                throws FileNotFoundException,
                       IOException
この抽象パスが表すファイルからデータを読み込みます。

戻り値:
ファイルの内容
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString()
                  throws FileNotFoundException,
                         IOException
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、デフォルトの文字エンコーディングから Unicode に変換して返します。

戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readString

public String readString(String enc)
                  throws FileNotFoundException,
                         UnsupportedEncodingException,
                         IOException
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。

データはテキストとして扱い、指定の文字エンコーディングから Unicode に変換して返します。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルのデータ
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines()
                   throws FileNotFoundException,
                          IOException
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、デフォルトの文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
IOException - 入出力エラーが発生した場合

readLines

public Iterator readLines(String enc)
                   throws FileNotFoundException,
                          UnsupportedEncodingException,
                          IOException
ファイルの行を繰り返し処理する反復子を作成します。

データはテキストとして扱い、指定の文字エンコーディングを使って Unicode に変換されます。 反復子が返す各要素は、ファイル内の 1 行のテキストです。 1 つの行は、改行 ('\n')、復帰 ('\r')、 または復帰とその直後に続く改行のどれかにより終了したと見なされます。

パラメータ:
enc - 文字エンコーディング名
戻り値:
ファイルの行を繰り返し処理する反復子
例外:
FileNotFoundException - ファイルが存在しないか、普通のファイルではなくディレクトリであるか、またはなんらかの理由で読み込みのために開くことができない場合
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

write

public void write(String str)
           throws IOException
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  String enc)
           throws UnsupportedEncodingException,
                  IOException
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(String str)
            throws IOException
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
例外:
IOException - 入出力エラーが発生した場合

append

public void append(String str,
                   String enc)
            throws UnsupportedEncodingException,
                   IOException
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。

文字列は、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対して文字列を追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成して文字列をファイルの先頭に書き込みます。

パラメータ:
str - 書き込む文字列
enc - 使用するエンコーディングの名前
例外:
UnsupportedEncodingException - 指定の文字のエンコーディングがサポートされていない場合
IOException - 入出力エラーが発生した場合

append

public void append(byte[] b)
            throws IOException
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

バイトは、ファイルの先頭ではなくファイルの最後に書き込まれます。 したがって、すでに存在するファイルに対してバイトを追記する場合に、 このメソッドを利用します。 このメソッドは、ファイルが存在しなかった場合、新しくファイルを 作成してバイトをファイルの先頭に書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合

write

public void write(byte[] b)
           throws IOException
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。

パラメータ:
b - データ
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.io.file (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.io.file
クラス
Directory
ExtendedDirectory
ExtendedFile


jp.co.intra_mart.common.aid.jdk.java.io.file (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

参照:
説明

クラスの概要
Directory | このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory | File インスタンスを作成するためのファクトリクラスです。
ExtendedFile | このクラスは、ファイルを扱う時に便利な機能を提供します。

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.java.io.file クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile


パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file の使用

jp.co.intra_mart.common.aid.jdk.java.io.file を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io.file このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io.file により使用される jp.co.intra_mart.common.aid.jdk.java.io.file のクラス
Directory
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
ExtendedDirectory
File インスタンスを作成するためのファクトリクラスです。
ExtendedFile
このクラスは、ファイルを扱う時に便利な機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BASE64DecodeInputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64DecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
public class BASE64DecodeInputStream
extends FilterInputStream

このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、BASE64 デコードされ read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
BASE64DecodeInputStream(InputStream in)
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeInputStream

public BASE64DecodeInputStream(InputStream in)
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BASE64DecodeOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64DecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
public class BASE64DecodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 デコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64DecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64DecodeOutputStream

public BASE64DecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が ASCII 文字の範囲に含まれない場合（ASCII のコントロールコードの場合も含む）や不正なコードが指定された場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BASE64EncodeOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス BASE64EncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
public class BASE64EncodeOutputStream
extends FilterOutputStream

このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、BASE64 エンコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
BASE64EncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream out, boolean isAppnendReturnCodePer76chars)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
メソッドの概要
void | close() ストリームを閉じます。
void | finish() 出力ストリームへのエンコードデータの書き込みを終了します。
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム

BASE64EncodeOutputStream

public BASE64EncodeOutputStream(OutputStream out,
                                boolean isAppnendReturnCodePer76chars)
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

パラメータ:
out - 出力ストリーム
isAppnendReturnCodePer76chars - 76文字ごとに改行コード(=LF)を追加する場合は true、 改行コードを追加しない場合は、 falseを指定してください。
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、3 バイトのデータを受け取るとエンコードされたバイトを 出力ストリームに書き込みます。入力されたバイトが 3 バイトに満たない 場合は、入力されたバイトが合計で 3 バイトになるまでバッファに 溜め込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

finish

public void finish()
            throws IOException
出力ストリームへのエンコードデータの書き込みを終了します。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。 もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。
このメソッドは、finish メソッドを呼び出した後、 スーパークラス(java.io.FilterOutputStream)の close メソッドを呼び出します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedInputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ExtendedInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
public class ExtendedInputStream
extends InputStream

このクラスは、標準の入力ストリームを拡張した機能を提供します。

このクラスは、jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream により 書き出されたストリームを読み込むための実装を提供します。
このクラスの各メソッドは、データをストリームから読み込むときに、 java.io.DataInputStream または java.io.ObjectInputStream の 適切なメソッドを使います。

データをストリームに書き出したときに使ったメソッドに対応した 適切なメソッドを利用することにより、データを読み込むことができます。

このクラスを jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream と対で使うことにより、 データをファイルに保存したり、ネットワークにより他のプロセスへ データを転送することができます。

jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream の writeObject メソッドにより 書き出されたオブジェクトは、readObject メソッドにより インスタンス化することができます。 この時、インスタンスに必要なクラスが存在している必要があります。

導入されたバージョン:
version 5.0

コンストラクタの概要
ExtendedInputStream(InputStream in)
入力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
入力ストリームを構築します。
メソッドの概要
void | close() 入出力ストリームおよびソケットを閉じます。
boolean | isClosed() この入出力ストリームが閉じられているかチェックします。
int | read() データ取得。
int | read(byte[] b, int off, int len) データ取得。
boolean | readBoolean() boolean 型データ取得。
int | readInt() int 型データ取得。
long | readLong() long 型データ取得。
Object | readObject() Object の取得。
String | readString() 文字列の取得。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedInputStream

public ExtendedInputStream(InputStream in)
                    throws IOException
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedInputStream

public ExtendedInputStream(InputStream in,
                           ErrorEventListener listener)
                    throws IOException
入力ストリームを構築します。

パラメータ:
in - 基礎入力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

read

public int read()
         throws IOException
データ取得。

入力ストリームから次のバイトのデータを取得します。

戻り値:
取得したバイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(), ExtendedOutputStream.write(int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
データ取得。

入力ストリームから len バイトまでのデータをバイト配列に 読み込みます。

パラメータ:
b - バイト配列
off - データの開始オフセット
len - 読み込むバイト数
戻り値:
取得したバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
InputStream.read(byte[], int, int), ExtendedOutputStream.write(int)

readInt

public int readInt()
            throws IOException
int 型データ取得。

基本データ型の整数データを読み込みます。

戻り値:
int 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readInt(), ExtendedOutputStream.writeInt(int)

readLong

public long readLong()
              throws IOException
long 型データ取得。

基本データ型の長整数データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readLong(), ExtendedOutputStream.writeLong(long)

readBoolean

public boolean readBoolean()
                    throws IOException
boolean 型データ取得。

基本データ型の真偽値データを読み込みます。

戻り値:
long 型数値データ
例外:
EOFException - データ受信完了前にストリームの終わりに達した場合
IOException - 入出力エラーが発生した場合
関連項目:
DataInputStream.readBoolean(), ExtendedOutputStream.writeBoolean(boolean)

readObject

public Object readObject()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
Object の取得。

戻り値:
入力して復元したオブジェクト
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ObjectInputStream.readObject(), ExtendedOutputStream.writeObject(Object)

readString

public String readString()
                  throws OptionalDataException,
                         ClassNotFoundException,
                         IOException
文字列の取得。

このメソッドは、jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream クラスの writeString メソッドを使って書き込んだデータを読み込むための メソッドです。他の方法で書き込んだデータを読み込むことはできません。

戻り値:
入力した文字列
例外:
ClassNotFoundException - 直列化されたオブジェクトのクラスが見つからなかった場合
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
StreamCorruptedException - ストリームの制御情報に一貫性がない場合
OptionalDataException - プリミティブデータが、オブジェクトではなくストリームに見つかった場合
IOException - 通常の入出力関連の例外
関連項目:
ExtendedOutputStream.writeString(String)

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ExtendedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
public class ExtendedOutputStream
extends OutputStream

このクラスは、標準の出力ストリームを拡張した機能を提供します。

このクラスの各メソッドは、データをストリームに書き出すときに、 java.io.DataOutputStream または java.io.ObjectOutputStream の 適切なメソッドを使います。
writeObject メソッドを使ってオブジェクトをストリームに書き出す 場合、ストリームに書き込めるのは java.io.Serializable インタフェースを サポートするオブジェクトに限ります。それ以外のオブジェクトを ストリームに書き込もうとした場合、例外がスローされます。

この出力ストリームに書き込んだデータを入力する場合、 jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream を利用する必要があります。 他の入力ストリームから読み込んだ場合例外がスローされることがあります。

導入されたバージョン:
version 5.0
関連項目:
ExtendedInputStream

コンストラクタの概要
ExtendedOutputStream(OutputStream out)
出力ストリームを構築します。
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
出力ストリームを構築します。
メソッドの概要
void | close() 入出力ストリームおよびソケットを閉じます。
void | flush() 書き出しストリーム内のデータをすべて出力。
boolean | isClosed() この入出力ストリームが閉じられているかチェックします。
void | write(byte[] b, int off, int len) オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
void | write(int data) 指定されたバイトを書き込みます。
void | writeBoolean(boolean data) boolean 型データの送信。
void | writeInt(int data) int 型データの送信。
void | writeLong(long data) long 型データの送信。
void | writeObject(Object data) オブジェクトの送信。
void | writeString(String data) 文字列の送信。
クラス java.io.OutputStream から継承したメソッド
write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out)
                     throws IOException
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedOutputStream

public ExtendedOutputStream(OutputStream out,
                            ErrorEventListener listener)
                     throws IOException
出力ストリームを構築します。

パラメータ:
out - 基礎出力ストリーム
listener - エラーイベントのリスナーオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

write

public void write(int data)
           throws IOException
指定されたバイトを書き込みます。

パラメータ:
data - バイトデータ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(int), ExtendedInputStream.read()

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合
関連項目:
OutputStream.write(byte[],int,int), ExtendedInputStream.read()

writeInt

public void writeInt(int data)
              throws IOException
int 型データの送信。
基本データ型の整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeInt(int), ExtendedInputStream.readInt()

writeLong

public void writeLong(long data)
               throws IOException
long 型データの送信。
基本データ型の長整数データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeLong(long), ExtendedInputStream.readLong()

writeBoolean

public void writeBoolean(boolean data)
                  throws IOException
boolean 型データの送信。
基本データ型の真偽値データを基礎出力ストリームに書き込みます。

パラメータ:
data - データ
例外:
IOException - 入出力エラーが発生した場合
関連項目:
DataOutputStream.writeBoolean(boolean), ExtendedInputStream.readBoolean()

writeObject

public void writeObject(Object data)
                 throws IOException
オブジェクトの送信。

java.io.Serializable インタフェースを実装している オブジェクトを基礎出力ストリームに書き込みます。
このメソッドはオブジェクトをストリームに書き込む際に、 java.io.ObjectOutputStream の writeObject メソッドを使います。

パラメータ:
data - オブジェクト
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
ObjectOutputStream.writeObject(Object), Serializable, ExtendedInputStream.readObject()

writeString

public void writeString(String data)
                 throws IOException
文字列の送信。
このメソッドは、writeObject() メソッドを使い文字列をストリームに 書き込みます。 java.io.DataOutputStream や java.io.ObjectOutputStream の writeUTF メソッドとの違いは、ストリームに書き込める文字列の 長さに制約がないことです。

パラメータ:
data - ストリームに書き込む文字列
例外:
InvalidClassException - 直列化で使用されるクラスになんらかの不具合があった場合
NotSerializableException - 直列化の対象が java.io.Serializable インタフェースを実装していない場合
IOException - 基礎の OutputStream に例外が発生した場合
関連項目:
DataOutputStream.writeUTF(String),
ObjectOutputStream.writeUTF(String),
ExtendedInputStream.readString()

flush

public void flush()
           throws IOException
書き出しストリーム内のデータをすべて出力。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
この入出力ストリームが閉じられているかチェックします。

戻り値:
すでに閉じられている場合 true、そうでない場合 false。
関連項目:
close()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileUtil (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス FileUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.io.FileUtil
public class FileUtil
extends Object

Fileユーティリティクラス。

Fileに関する実用的な関数および定数値を提供するクラス。

導入されたバージョン:
5.1
バージョン:
1.0

メソッドの概要
static long getOldestLastModifiedInDir(File dir)
指定ディレクトリ直下のファイル群の中で一番古い更新日付を返却します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getOldestLastModifiedInDir

public static long getOldestLastModifiedInDir(File dir)
指定ディレクトリ直下のファイル群の中で一番古い更新日付を返却します。

パラメータ:
dir - 指定ディレクトリ
戻り値:
指定ディレクトリ直下のファイル群の中で一番古い更新日付を返却します。
引数 dir がディレクトリを示さない場合は、現在日付を返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexInputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス HexInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
public class HexInputStream
extends InputStream

このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、16進数表現からバイトに変換され read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
protected  InputStream in
フィルタ処理される入力ストリームです。
コンストラクタの概要
HexInputStream(InputStream in)
指定された InputStream から読み込む HexInputStream を作成します。
メソッドの概要
void | close() ストリームを閉じます。
int | read() デコードデータのバイトを読み込みます。
クラス java.io.InputStream から継承したメソッド
available, mark, markSupported, read, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

in

protected InputStream in
フィルタ処理される入力ストリームです。

コンストラクタの詳細

HexInputStream

public HexInputStream(InputStream in)
指定された InputStream から読み込む HexInputStream を作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

close

public void close()
           throws IOException
ストリームを閉じます。

入力ストリームを閉じ、これに関連するすべての システムリソースを解放します。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HexOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス HexOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
public class HexOutputStream
extends OutputStream

このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、16進数表現され 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 [0-9a-f] の範囲のキャラクタで構成されます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
protected  OutputStream out
フィルタ処理される基礎出力ストリームです。
コンストラクタの概要
HexOutputStream(OutputStream out)
指定された OutputStream に書き込む HexOutputStream を作成します。
メソッドの概要
void | close() ストリームを閉じます。
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.OutputStream から継承したメソッド
flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected OutputStream out
フィルタ処理される基礎出力ストリームです。

コンストラクタの詳細

HexOutputStream

public HexOutputStream(OutputStream out)
指定された OutputStream に書き込む HexOutputStream を作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

このメソッドは、バイトを上位４ビットと下位ビットに分け、 それぞれ16進数表現されたキャラクターコードに置き換えて、 計２バイトのデータを基礎ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

close

public void close()
           throws IOException
ストリームを閉じます。

ストリームを閉じ、これに関連するすべての システムリソースを解放します。
もし、このストリームがバッファ内に出力バイトを保持している場合、 それらを終端処理をして出力ストリームに強制的に書き込みます。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipleOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス MultipleOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
public class MultipleOutputStream
extends OutputStream

複数の出力ストリームにバイトを書き出すためのフィルタ実装です。

このフィルタを利用する事によって、 同じバイト情報を全く異なる複数の出力先へ、同時に書き出すことができます。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultipleOutputStream()
唯一のコンストラクタ
メソッドの概要
void | addOutputStream(OutputStream output) メッセージの出力先を追加します。
void | close() このストリームを閉じます。
protected void | finalize() このオブジェクトをクリーンアップします。
void | flush() この出力ストリームをフラッシュします。
boolean | removeOutputStream(OutputStream output) メッセージの出力先を削除します。
void | write(byte[] b) 指定のバイトを 設定されている各出力先へ書き出します。
void | write(byte[] b, int off, int len) 指定のバイトを 設定されている各出力先へ書き出します。
void | write(int b) 指定のバイトを 設定されている各出力先へ書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultipleOutputStream

public MultipleOutputStream()
唯一のコンストラクタ

メソッドの詳細

addOutputStream

public void addOutputStream(OutputStream output)
メッセージの出力先を追加します。

パラメータ:
output - 出力ストリーム

removeOutputStream

public boolean removeOutputStream(OutputStream output)
メッセージの出力先を削除します。

パラメータ:
output - 出力ストリーム
戻り値:
削除に成功した場合は true。

write

public void write(int b)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b)
           throws IOException
指定のバイトを 設定されている各出力先へ書き出します。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
この出力ストリームをフラッシュします。

まず、この出力ストリーム内のデータをフラッシュします。 その後、設定されている各出力先の OutputStream.flush() メソッドを 順に呼び出します。

例外:
IOException - 入出力エラー

close

public void close()
           throws IOException
このストリームを閉じます。

このメソッドは、自分をクローズ処理すると同時に基礎ストリームも閉じます。 設定されている各出力先の OutputStream.close() メソッドを 順に呼び出します。

例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
このオブジェクトをクリーンアップします。 このオブジェクトへの参照はもうないとガベージコレクションによって 判断されたときに、ガベージコレクタによって呼び出されます。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.io (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.io
クラス
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
ExtendedInputStream
ExtendedOutputStream
FileUtil
HexInputStream
HexOutputStream
MultipleOutputStream
ReplaceWriter
TrimmedFilterReader
TrimmedFilterWriter
UnlimitedBufferedOutputStream
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
XORInputStream
XOROutputStream


jp.co.intra_mart.common.aid.jdk.java.io (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

参照:
説明

クラスの概要
BASE64DecodeInputStream | このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream | このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream | このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
ExtendedInputStream | このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedOutputStream | このクラスは、標準の出力ストリームを拡張した機能を提供します。
FileUtil | Fileユーティリティクラス。
HexInputStream | このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexOutputStream | このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
MultipleOutputStream | 複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
ReplaceWriter | このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
TrimmedFilterReader | このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter | このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
UnlimitedBufferedOutputStream | 出力データを一時的にバッファリングする出力ストリームの実装です。
URLDecodeInputStream | このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeOutputStream | このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream | このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
XORInputStream | このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XOROutputStream | このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。

パッケージ jp.co.intra_mart.common.aid.jdk.java.io の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
このパッケージには、java.io パッケージに含まれるクラスを拡張したものが多く含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jdk.java.io クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.io の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.io.FileUtil
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.jdk.java.io の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io の使用

jp.co.intra_mart.common.aid.jdk.java.io を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net により使用される jp.co.intra_mart.common.aid.jdk.java.io のクラス
ExtendedInputStream
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedOutputStream
このクラスは、標準の出力ストリームを拡張した機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReplaceWriter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス ReplaceWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
public class ReplaceWriter
extends Writer

このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
置換対象となる部分文字列と置換する文字列の長さは同じ必要はありません。 置換対象となる文字データと異なる長さの文字データを置換後のデータとして 指定することも可能です。この場合、 このクラスによって基礎ストリームに書き込まれるデータ量は、 元のデータ量と変化します。

   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("abc");
   String result = sw.toString();
文字データ "abc" は、"xyz" に変化します。この場合、以下のように 記述しても同様の結果が得られます。
   java.io.StringWriter sw = new java.io.StringWriter();

   ReplaceWriter rw = new ReplaceWriter(sw, "abc", "xyz");

   rw.write("a");
   rw.write("b");
   rw.write("c");
   String result = sw.toString();

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReplaceWriter(Writer out, char[] oldChars)
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, char[] oldChars, char[] newChars)
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString)
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer out, String oldString, String newString)
文字列置換のためのストリームフィルタを作成します。
メソッドの概要
void | close() ストリームを閉じてフラッシュします。
void | finish() バッファに保存してあるデータを書き出します。
void | flush() ストリームをフラッシュします。
void | write(char[] cbuf, int off, int len) 文字列の一部を基礎ストリームに書き込みます。
void | write(int c) 単一文字を書き込みます。
クラス java.io.Writer から継承したメソッド
write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars)
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 削除対象となる文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString)
文字列削除のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは部分文字列の削除を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldString - 削除対象となる文字列

ReplaceWriter

public ReplaceWriter(Writer out,
                     char[] oldChars,
                     char[] newChars)
文字列置換のためのストリームフィルタを作成します。
このインスタンスに書き込まれた文字データは適切な置換を行いながら 基礎ストリームに書き込まれます。

パラメータ:
out - 基礎ストリーム
oldChars - 置換対象となる文字の配列
newChars - 置換する文字の配列

ReplaceWriter

public ReplaceWriter(Writer out,
                     String oldString,
                     String newString)
文字列置換のためのストリームフィルタを作成します。

パラメータ:
out - 基礎ストリーム
oldString - 置換対象となる文字列
newString - 置換する文字列
メソッドの詳細

write

public void write(int c)
           throws IOException
単一文字を書き込みます。 書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字列の一部を基礎ストリームに書き込みます。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

finish

public void finish()
            throws IOException
バッファに保存してあるデータを書き出します。

ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字を基礎ストリームへただちに 書き込みます。
このメソッドは、このストリームの持つ置換対象データと比較中の 文字データを含むすべてのバッファを基礎ストリームに書き込みます。 このメソッドを呼び出し後は、write() メソッドによって与えられる データを改めて検索し直します。この機能のより、このストリームフィルタの 複数のストリームでの再利用が可能となります。

このときストリームは閉じられません。 複数のフィルタを同じ出力ストリームに連続して適用するときに このメソッドを使用します。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

現在バッファに保存されているデータが置換対象の文字データと 比較途中である場合、比較中のデータはフラッシュされません。 このストリームの持つすべてのバッファをフラッシュするためには、 finish() メソッドを呼び出したあとにこのメソッドを呼び出して下さい。
宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream のすべてのバッファを フラッシュします。

例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrimmedFilterReader (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス TrimmedFilterReader

java.lang.Object
    拡張 java.io.Reader
        拡張 java.io.FilterReader
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
public class TrimmedFilterReader
extends FilterReader

このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。

フィルタ処理として、 文字入力ストリームから Java の基準に従った空白文字ではない文字を読み込みます。

導入されたバージョン:
Version 5.0

フィールドの概要
クラス java.io.FilterReader から継承したフィールド
in
クラス java.io.Reader から継承したフィールド
lock
コンストラクタの概要
TrimmedFilterReader(Reader in)
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
メソッドの概要
int | read() 単一の文字を読み込みます。
int | read(char[] cbuf, int off, int len) 配列の一部に文字を読み込みます。
クラス java.io.FilterReader から継承したメソッド
close, mark, markSupported, ready, reset, skip
クラス java.io.Reader から継承したメソッド
read
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TrimmedFilterReader

public TrimmedFilterReader(Reader in)
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。

パラメータ:
in - 基本となるストリームを提供する Reader オブジェクト
メソッドの詳細

read

public int read()
         throws IOException
単一の文字を読み込みます。

文字入力ストリームから読み込んだ文字が Java の基準に従った空白文字である場合に、 次の文字を読み込みを行います。

文字の値は 0 ～ 65535 (0x00-0xffff) の範囲の値をとる int として返されます。 ストリームの終わりに達して読み込むデータがない場合は -1 を返します。

このメソッドは、入力データが読み込めるようになるか、 ストリームの終わりが検出されるか、 または例外がスローされるまでブロックします。

戻り値:
0 ～ 65535 (0x00-0xffff) の範囲の整数としての、読み込まれた文字。ストリームの終わりに達した場合は -1
例外:
IOException - 入出力エラーが発生した場合
関連項目:
java.io.Reader#read()

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException,
                NullPointerException
配列の一部に文字を読み込みます。

入力ストリームから len 文字数分の文字を指定された文字の配列に格納します。 実際に読み込まれた文字数は整数として返されます。

このメソッドは、入力データが読み込めるようになるか、 ファイルの終わりが検出されるか、 あるいは例外がスローされるまでブロックします。

文字の配列 cbuf が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 cbuf の長さより大きい場合は、 IndexOutOfBoundsException がスローされます。

len が 0 の場合は、文字が読み込まれず、0 が返されます。 そうでない場合は、Java の基準に従った空白文字でない 1 文字以上の読み込み処理が行われます。 ストリームがファイルの終わりに達しているために読み込む文字がない場合は、 値 -1 が返されます。 そうでない場合は、Java の基準に従った空白文字でない len 文字数分の文字が読み込まれ、 文字の配列 cbuf に格納されます。

すべての場合において、文字 cbuf[0] ～ cbuf[off] および文字 cbuf[off+len] ～ cbuf[b.length-1] は影響を受けません。

ファイルの終わりに達している以外の理由で最初のバイトが読み込めない場合は、 IOException がスローされます。 特に、入力ストリームが閉じている場合には IOException がスローされます。

このメソッドは、単純に read() メソッドを繰り返し呼び出します。 最初の呼び出しが IOException になる場合、 その例外は呼び出し側から read(cbuf, off, len) メソッドに返されます。 read() の以降の呼び出しが IOException になった場合、 その例外はファイルの終わりが検出された場合と同じようにキャッチおよび処理されます。 つまり、その時点までに読み込まれた文字は cbuf に格納され、 例外が発生するまでに読み込まれた文字数が返されます。

パラメータ:
cbuf - 転送先バッファ
off - 文字の格納開始オフセット
len - 読み込む文字の最大数
戻り値:
読み込まれた文字数。
例外:
IOException
NullPointerException
関連項目:
Reader.read(char[], int, int)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrimmedFilterWriter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス TrimmedFilterWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
public class TrimmedFilterWriter
extends FilterWriter

このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。

フィルタ処理として、 Java の基準に従った空白ではない文字を文字出力ストリームに書き込みます。

導入されたバージョン:
Version 5.0

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
TrimmedFilterWriter(Writer writer)
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
メソッドの概要
void | write(char[] cbuf, int off, int len) 文字の配列の一部を書き込みます。
void | write(int c) 指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
void | write(String str, int off, int len) 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TrimmedFilterWriter

public TrimmedFilterWriter(Writer writer)
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。

パラメータ:
writer - 基本となる文字出力ストリームを提供する java.io.Writer オブジェクト
メソッドの詳細

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
文字列の一部を書き込みます。 オフセット off から始まる指定の文字列 str から、 len 文字分を文字出力ストリームに書き込みます。
この処理は、

char[] strToCharArray = str.toCharArray(); 上の式のように文字列 str を新しい文字の配列 strToCharArray に変換して write(strToCharArray, off, len) を呼び出す場合とまったく同じです。

指定した文字の配列 str が null の場合は、NullPointerException がスローされます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字の配列の一部を書き込みます。

オフセット off から始まる指定の文字の配列 cbuf から、 len 文字分を文字出力ストリームに書き込みます。
この処理で最初に書き込まれる文字は要素 b[off] で、 最後に書き込まれる文字は要素 cbuf[off+len-1] です。

この処理では、書き込む文字ごとに write(int) のメソッドを呼び出します。 指定した文字の配列 cbuf が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 cbuf の長さより大きい場合は、 IndexOutOfBoundsException がスローされます。

パラメータ:
cbuf - 書き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。

書き込まれる文字は、指定された整数値の下位 16 ビットに格納されます。 上位 16 ビットは無視されます。

パラメータ:
c - 文字
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnlimitedBufferedOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス UnlimitedBufferedOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
public class UnlimitedBufferedOutputStream
extends FilterOutputStream

出力データを一時的にバッファリングする出力ストリームの実装です。

このクラスは、 BufferedOutputStream と異なり、 flush() メソッドが呼び出されるまで、 すべてのバイトをメモリ中にバッファリングします。 したがって、明示的にフラッシュしなければ、データが出力される事は ありません。 逆に言うと、明示的にフラッシュするまですべてのデータをメモリ中に 保存する事になるため、大きなデータを扱う場合には十分な注意が必要です。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
UnlimitedBufferedOutputStream(OutputStream out)
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
メソッドの概要
void | flush() この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
void | write(byte[] b) b.length バイトのデータを出力ストリームに書き込みます。
void | write(byte[] b, int off, int len) 指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
void | write(int b) 指定のバイトを出力します。
クラス java.io.FilterOutputStream から継承したメソッド
close
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

UnlimitedBufferedOutputStream

public UnlimitedBufferedOutputStream(OutputStream out)
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。

パラメータ:
out - 出力先ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
指定のバイトを出力します。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - バイト
例外:
IOException - 入出力エラー

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラー

write

public void write(byte[] b)
           throws IOException
b.length バイトのデータを出力ストリームに書き込みます。

バイトは、flush()メソッドが呼び出されるまで、 オブジェクト内部のバッファに溜め込まれます。 バイトを基本となるストリームに書き込むためには、flush()メソッドを呼び出してください。

パラメータ:
b - データ
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeInputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLDecodeInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
public class URLDecodeInputStream
extends FilterInputStream

このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
この入力ストリームに読み込まれたバイトは、URL デコードされ 基礎入力ストリームに読み込まれます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
URLDecodeInputStream(InputStream in)
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeInputStream

public URLDecodeInputStream(InputStream in)
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

read

public int read()
         throws IOException
デコードデータのバイトを読み込みます。

このメソッドは、BASE64 のデコードに十分な入力が利用できるようになるまで ブロックします。

戻り値:
読み込まれたバイト。圧縮された入力の最後に達した場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。 このメソッドは入力データが読み込み可能になるまでブロックします。

パラメータ:
b - データが読み込まれるバッファ
off - データの開始オフセット
len - 読み込むバイトの最大値
戻り値:
バッファに読み込まれたバイト数。ストリームの終わりに達して読み込むデータがない場合は -1
例外:
EOFException - デコード途中で入力が終了した場合
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLDecodeOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLDecodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
public class URLDecodeOutputStream
extends FilterOutputStream

このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL デコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLDecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む URLデコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLDecodeOutputStream

public URLDecodeOutputStream(OutputStream out)
指定された OutputStream に書き込む URLデコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


URLEncodeOutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス URLEncodeOutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
public class URLEncodeOutputStream
extends FilterOutputStream

このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、URL エンコードされ 基礎出力ストリームに書き込まれます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
URLEncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをデコードして出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLEncodeOutputStream

public URLEncodeOutputStream(OutputStream out)
指定された OutputStream に書き込む BASE64デコーダーを作成します。

パラメータ:
out - 出力ストリーム
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをデコードして出力ストリームに書き込みます。

このメソッドは、デコード結果が出力可能な 1 バイトのデータになるまで、 バッファに溜め込みます。 バッファに溜め込まれたデータは、flush メソッドや close メソッドを 実行しても基礎出力ストリームに書き出されることはありません。 バッファにデータが溜まった状態で、flush メソッドや close メソッドを 実行した場合、バッファ内のデータは破棄されます。

パラメータ:
b - 書き込まれるバイト
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。
このメソッドは、配列 b 内の off から len バイトについて、 int 型引数をひとつだけとる write メソッドを呼び出します。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
ArithmeticException - デコード中に計算結果がオーバーフローしてしまった場合
IllegalArgumentException - バイト b が 0 より小さいか 0x3f よりも大きい場合
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XORInputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス XORInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 java.io.FilterInputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
public class XORInputStream
extends FilterInputStream

このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
入力ストリームより読み込まれたバイトは、 指定されたバイトデータとの排他論理和を計算した結果として read() メソッドにより返されます。

導入されたバージョン:
version 5.0
関連項目:
InputStream

フィールドの概要
クラス java.io.FilterInputStream から継承したフィールド
in
コンストラクタの概要
XORInputStream(InputStream in, int b)
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
メソッドの概要
int | read() デコードデータのバイトを読み込みます。
int | read(byte[] b, int off, int len) 入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
クラス java.io.FilterInputStream から継承したメソッド
available, close, mark, markSupported, read, reset, skip
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XORInputStream

public XORInputStream(InputStream in,
                      int b)
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。

パラメータ:
in - 入力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

read

public int read()
         throws IOException,
                NumberFormatException
デコードデータのバイトを読み込みます。

２バイトの 16進数表現されたキャラクタデータを 読み込んで１バイトの数値として返します。 このメソッドは、２バイトの入力があるまでブロックします。

戻り値:
読み込まれたバイト。
例外:
IOException - 入出力エラーが発生した場合
NumberFormatException - 16進数として有効ではない文字を読み込んだ場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。このメソッドは、入力が可能になるまでブロックします。

パラメータ:
b - データの読み込み先のバッファ
off - データの開始オフセット
len - 読み込まれる最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XOROutputStream (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.io
クラス XOROutputStream

java.lang.Object
    拡張 java.io.OutputStream
        拡張 java.io.FilterOutputStream
            拡張 jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
public class XOROutputStream
extends FilterOutputStream

このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
この出力ストリームに書き込まれたバイトは、指定のバイトデータとの 排他論理和を計算して、その結果のバイトデータが 基礎出力ストリームに書き込まれます。
フィルタリングされた結果、基礎ストリームに書き込まれるデータは、 同じバイトデータによって排他論理和を取ることにより、 もとのバイトデータに戻すことができます。

導入されたバージョン:
version 5.0
関連項目:
OutputStream

フィールドの概要
クラス java.io.FilterOutputStream から継承したフィールド
out
コンストラクタの概要
XOROutputStream(OutputStream out, int b)
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
メソッドの概要
void | write(byte[] b, int off, int len) バイト列をエンコード出力ストリームに書き込みます。
void | write(int b) バイトをエンコード出力ストリームに書き込みます。
クラス java.io.FilterOutputStream から継承したメソッド
close, flush, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XOROutputStream

public XOROutputStream(OutputStream out,
                       int b)
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。

パラメータ:
out - 出力ストリーム
b - 排他論理和を取るためのバイト
メソッドの詳細

write

public void write(int b)
           throws IOException
バイトをエンコード出力ストリームに書き込みます。

パラメータ:
b - 書き込まれるバイト
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
バイト列をエンコード出力ストリームに書き込みます。

オフセット off から始まる指定のバイト配列からこの出力ストリームに len バイトを書き込みます。配列 b 内の一定のバイトが出力ストリームに 順番に書き込まれます。この処理で最初に書き込まれるバイトは要素 b[off]、 最後に書き込まれるバイトは要素 b[off+len-1] です。

b が null の場合は、NullPointerException がスローされます。

off が負の場合、len が負の場合、あるいは off+len が配列 b の長さより 大きい場合は、IndexOutOfBoundsException がスローされます。

パラメータ:
b - データ
off - データの開始オフセット
len - 書き込むバイト数
例外:
IOException - 入出力エラーが発生した場合。 特に、出力ストリームが閉じられている場合に IOException がスローされる
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader の使用

ExtendedClassLoader を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ExtendedClassLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang での ExtendedClassLoader のサブクラス
class | LuxuryClassLoader このクラスは、拡張されたクラスローダーです。
class | SearchableClassLoader ユーティリティ的な実装を提供するクラスローダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil の使用

jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader の使用

ResourceLoader を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ResourceLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang での ResourceLoader のサブクラス
class | ExtendedClassLoader このクラスは、拡張されたクラスローダーです。
class | LuxuryClassLoader このクラスは、拡張されたクラスローダーです。
class | SearchableClassLoader ユーティリティ的な実装を提供するクラスローダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader の使用

jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の使用

jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener の使用

ShutdownListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ShutdownListener の使用

ShutdownListener を返す jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static ShutdownListener[] ShutdownEventController.getShutdownListeners()
現在登録されているリスナを返します。

ShutdownListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static void | ShutdownEventController.addListener(ShutdownListener listener) シャットダウンリスナーを登録します。
static boolean | ShutdownEventController.removeListener(ShutdownListener listener) シャットダウンリスナーを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StdErr はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StdOut はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil の使用

jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener の使用

ThreadStopListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ThreadStopListener の使用

ThreadStopListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
 void ExtendedThread.addThreadStopListener(ThreadStopListener listener)
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener の使用

ThrowablePrintListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang での ThrowablePrintListener の使用

ThrowablePrintListener を返す jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static ThrowablePrintListener StdErr.getThrowablePrintListener()
現在の例外出力リスナを返します。

ThrowablePrintListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.lang のメソッド
static void StdErr.setThrowablePrintListener(ThrowablePrintListener listener)
指定の例外出力リスナを割り当て直します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtendedClassLoader (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ExtendedClassLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
            拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
直系の既知のサブクラス:
LuxuryClassLoader, SearchableClassLoader
public class ExtendedClassLoader
extends ResourceLoader

このクラスは、拡張されたクラスローダーです。

このクラスローダーは、リソースを検索するパスを任意に追加することが できます。

導入されたバージョン:
version 5.0

コンストラクタの概要
ExtendedClassLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addNativePath(File path) クラスパスを追加します。
protected Class | findClass(String name) 指定されたクラスを探します。
protected String | findLibrary(String libname) ネイティブライブラリの絶対パス名を返します。
File[] | getNativePaths() このクラスローダーに設定されているネイティブライブラリパスを返します。
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader から継承したメソッド
addClassArchive, addClassArchiveLibrary, addClassPath, findResource, findResources, getClassArchives, getClassPaths
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedClassLoader

public ExtendedClassLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。

ExtendedClassLoader

public ExtendedClassLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親クラスローダー
メソッドの詳細

addNativePath

public void addNativePath(File path)
クラスパスを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に ネイティブリソースを検索していきます。 path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

getNativePaths

public File[] getNativePaths()
このクラスローダーに設定されているネイティブライブラリパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からネイティブライブラリを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addNativePath(File), File

findLibrary

protected String findLibrary(String libname)
ネイティブライブラリの絶対パス名を返します。
VM はこのメソッドを呼び出して、このクラスローダでロードされたクラスに 属するネイティブライブラリを見つけます。 このメソッドが null を返す場合、VM は java.library.path プロパティで 指定されたパスにしたがってライブラリを検索します。

パラメータ:
libname - ライブラリ名
戻り値:
ネイティブライブラリの絶対パス

findClass

protected Class findClass(String name)
                   throws ClassNotFoundException
指定されたクラスを探します。
このメソッドは、クラスをロードするための新しい委譲モデルに準拠する クラスローダ実装によってオーバーライドされ、必要なクラスの 親クラスローダのチェック後に loadClass メソッドによって呼び出されます。 デフォルトの実装は ClassNotFoundException をスローします。

パラメータ:
name - クラス名
戻り値:
結果の Class オブジェクト
例外:
ClassNotFoundException - クラスが見つからなかった場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedThread (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ExtendedThread

java.lang.Object
    拡張 java.lang.Thread
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
すべての実装インタフェース:
Runnable
public class ExtendedThread
extends Thread

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.lang.Thread から継承したフィールド
MAX_PRIORITY, MIN_PRIORITY, NORM_PRIORITY
コンストラクタの概要
ExtendedThread()
Constructor for ExtendedThread.
ExtendedThread(Runnable target)
Constructor for ExtendedThread.
ExtendedThread(Runnable target, String name)
Constructor for ExtendedThread.
ExtendedThread(String name)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, Runnable target, String name)
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup group, String name)
Constructor for ExtendedThread.
メソッドの概要
void | addThreadStopListener(ThreadStopListener listener) このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
void | fire() スレッド実行されるロジック。
void | run() このオブジェクトのスレッド実行ロジックです。
クラス java.lang.Thread から継承したメソッド
activeCount, checkAccess, countStackFrames, currentThread, destroy, dumpStack, enumerate, getContextClassLoader, getName, getPriority, getThreadGroup, holdsLock, interrupt, interrupted, isAlive, isDaemon, isInterrupted, join, join, join, resume, setContextClassLoader, setDaemon, setName, setPriority, sleep, sleep, start, stop, stop, suspend, toString, yield
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedThread

public ExtendedThread()
Constructor for ExtendedThread.

ExtendedThread

public ExtendedThread(Runnable target)
Constructor for ExtendedThread.

パラメータ:
target -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target)
Constructor for ExtendedThread.

パラメータ:
group -
target -

ExtendedThread

public ExtendedThread(String name)
Constructor for ExtendedThread.

パラメータ:
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      String name)
Constructor for ExtendedThread.

パラメータ:
group -
name -

ExtendedThread

public ExtendedThread(Runnable target,
                      String name)
Constructor for ExtendedThread.

パラメータ:
target -
name -

ExtendedThread

public ExtendedThread(ThreadGroup group,
                      Runnable target,
                      String name)
Constructor for ExtendedThread.

パラメータ:
group -
target -
name -
メソッドの詳細

run

public final void run()
このオブジェクトのスレッド実行ロジックです。 このメソッドをサブクラスがオーバーライドすることはできません。 サブクラスがスレッド実行ロジックを定義するためには、fireメソッドを オーバーライドしてください。

fire

public void fire()
スレッド実行されるロジック。 Thread クラスを継承したサブクラスにおいて、通常 run メソッドに 記述する内容をこのメソッドに定義してください。

addThreadStopListener

public void addThreadStopListener(ThreadStopListener listener)
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。

パラメータ:
listener - スレッド終了イベントリスナー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LuxuryClassLoader (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス LuxuryClassLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
            拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
                拡張 jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader
public class LuxuryClassLoader
extends ExtendedClassLoader

このクラスは、拡張されたクラスローダーです。

このクラスローダーは、システムのホームディレクトリおよび 現在のカレントディレクトリを各リソースの検索パスとします。 また検索パスがディレクトリであった場合、そのディレクトリ内にある jar または zip ファイル内もリソース検索の対象とします。
jar または zip 内を検索する場合、そのアーカイブ内の jar または zip 内も リソースファイルの検索対象としますので、複数の jar アーカイブを 一つの zip ファイルにまとめておくこともできます。

導入されたバージョン:
version 5.0

コンストラクタの概要
LuxuryClassLoader(ClassLoader parent, File path)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
LuxuryClassLoader(File path)
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
メソッドの概要
 void addClassArchive(File path)
クラスパスに指定のアーカイブファイルを追加します。
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader から継承したメソッド
addNativePath, findClass, findLibrary, getNativePaths
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader から継承したメソッド
addClassArchiveLibrary, addClassPath, findResource, findResources, getClassArchives, getClassPaths
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LuxuryClassLoader

public LuxuryClassLoader(File path)
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
指定されたパス名をクラスパスとして追加されたアーカイブファイルを 操作するための一時領域として使用します。

パラメータ:
path - テンポラリとして利用するディレクトリパス

LuxuryClassLoader

public LuxuryClassLoader(ClassLoader parent,
                         File path)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
指定されたパス名をクラスパスとして追加されたアーカイブファイルを 操作するための一時領域として使用します。

パラメータ:
parent - 親クラスローダー
path - アーカイブ(jar or zip)を展開するためのディレクトリ
メソッドの詳細

addClassArchive

public void addClassArchive(File path)
クラスパスに指定のアーカイブファイルを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も最近に追加されたパスから順に クラスを検索していきます。

オーバーライド:
クラス ResourceLoader 内の addClassArchive
パラメータ:
path - 追加するパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NumberUtil (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス NumberUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil
public class NumberUtil
extends Object

数値型に関するユーティリティクラス。

数値型に関するユーティリティクラス

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
protected NumberUtil()
コンストラクタ。
メソッドの概要
static double | toDouble(Object object, double def) オブジェクトを倍精度実数に変換します。
static int | toInt(Object object, int def) オブジェクトを整数に変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NumberUtil

protected NumberUtil()
コンストラクタ。

メソッドの詳細

toInt

public static int toInt(Object object,
                        int def)
オブジェクトを整数に変換します。

数値に変換できなかった場合は、デフォルト値を返却します。

パラメータ:
object - 変換元オブジェクト
def - デフォルト値
戻り値:
変換後の整数

toDouble

public static double toDouble(Object object,
                              double def)
オブジェクトを倍精度実数に変換します。

数値に変換できなかった場合は、デフォルト値を返却します。

パラメータ:
object - 変換元オブジェクト
def - デフォルト値
戻り値:
変換後の倍精度実数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.lang (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース
ShutdownListener
ThreadStopListener
ThrowablePrintListener
クラス
ExtendedClassLoader
ExtendedThread
LuxuryClassLoader
NumberUtil
ResourceLoader
SearchableClassLoader
ShutdownEventController
StdErr
StdOut
StringUtil


jp.co.intra_mart.common.aid.jdk.java.lang (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang

このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ShutdownListener | シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
ThreadStopListener | To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener | このインタフェースは、例外情報を出力するためのものです。

クラスの概要
ExtendedClassLoader | このクラスは、拡張されたクラスローダーです。
ExtendedThread | To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
LuxuryClassLoader | このクラスは、拡張されたクラスローダーです。
NumberUtil | 数値型に関するユーティリティクラス。
ResourceLoader | このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
SearchableClassLoader | ユーティリティ的な実装を提供するクラスローダです。
ShutdownEventController | このクラスは、サーバプロセスの基礎ロジック。
StdErr | このクラスは、エラーメッセージ出力用です。
StdOut | このクラスは、システムメッセージ出力用です。
StringUtil | 文字列ユーティリティクラス。

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.java.lang クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
          • class jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader
          • class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader
    • class jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener


パッケージ jp.co.intra_mart.common.aid.jdk.java.lang の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.lang の使用

jp.co.intra_mart.common.aid.jdk.java.lang を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.lang このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.lang により使用される jp.co.intra_mart.common.aid.jdk.java.lang のクラス
ExtendedClassLoader
このクラスは、拡張されたクラスローダーです。
ResourceLoader
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ShutdownListener
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
ThreadStopListener
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener
このインタフェースは、例外情報を出力するためのものです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceLoader (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ResourceLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
直系の既知のサブクラス:
ExtendedClassLoader
public class ResourceLoader
extends ClassLoader

このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。

このクラスローダーは、リソースを検索するパスを任意に追加することが できます。

導入されたバージョン:
version 5.0

コンストラクタの概要
ResourceLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addClassArchive(File path) クラスパスに指定のアーカイブファイルを追加します。
void | addClassArchiveLibrary(File path) クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
void | addClassPath(File path) クラスパスを追加します。
protected URL | findResource(String name) 指定された名前を持つリソースを探します。
protected Enumeration | findResources(String name) 指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
File[] | getClassArchives() このクラスローダーに設定されているクラスアーカイブパスを返します。
File[] | getClassPaths() このクラスローダーに設定されているクラスパスを返します。
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResourceLoader

public ResourceLoader()
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。

ResourceLoader

public ResourceLoader(ClassLoader parent)
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親クラスローダー
メソッドの詳細

addClassPath

public void addClassPath(File path)
クラスパスを追加します。

ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に クラスを検索していきます。
path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

addClassArchive

public void addClassArchive(File path)
クラスパスに指定のアーカイブファイルを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
クラスローダーは、最も過去に追加されたパスから順に クラスを検索していきます。 path が既に追加済みである場合、このメソッドは何も行いません。

パラメータ:
path - 追加するパス

addClassArchiveLibrary

public void addClassArchiveLibrary(File path)
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。 ここで追加されるクラスパスは、このクラスローダー内でのみ有効です。
このメソッドは、path に含まれる jar または zip ファイルを検索し、 addClassArchive(File) を呼び出して このクラスローダの検索パスに追加します。

パラメータ:
path - 追加するパス

getClassPaths

public File[] getClassPaths()
このクラスローダーに設定されているクラスパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からクラスを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addClassPath(File), File

getClassArchives

public File[] getClassArchives()
このクラスローダーに設定されているクラスアーカイブパスを返します。
このクラスローダーでは、このメソッドにより返されるパスと このクラスローダーの動作している環境からクラスを検索しています。 このメソッドで返されるパスは、このクラスローダー固有に設定されている パスに限られます。

戻り値:
クラスパス
関連項目:
addClassArchive(File), File

findResources

protected Enumeration findResources(String name)
                             throws IOException
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。

パラメータ:
name - リソース名
戻り値:
リソースの URL の Enumeration
例外:
IOException

findResource

protected URL findResource(String name)
指定された名前を持つリソースを探します。

パラメータ:
name - リソース名
戻り値:
リソースを読み込むための URL。リソースが見つからなかった場合は null
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SearchableClassLoader (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス SearchableClassLoader

java.lang.Object
    拡張 java.lang.ClassLoader
        拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
            拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
                拡張 jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader
public class SearchableClassLoader
extends ExtendedClassLoader

ユーティリティ的な実装を提供するクラスローダです。 通常のクラスローダとしても利用可能です。

コンストラクタの概要
SearchableClassLoader()
新しいクラスローダを生成します。
SearchableClassLoader(ClassLoader parent)
指定された親クラスローダを使って、委譲のために新しいクラスローダを作成します。
メソッドの概要
void | addSearchPath(File file) 指定されたパスがファイルを表している場合、jar または zip を指定されたと判断して、 ResourceLoader.addClassArchive(File)を呼び出します。
Class[] | getImplementedClasses(Class clazz) 指定されたクラスと代入互換のあるインスタンスを生成できるクラスを検索します。
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader から継承したメソッド
addNativePath, findClass, findLibrary, getNativePaths
クラス jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader から継承したメソッド
addClassArchive, addClassArchiveLibrary, addClassPath, findResource, findResources, getClassArchives, getClassPaths
クラス java.lang.ClassLoader から継承したメソッド
clearAssertionStatus, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SearchableClassLoader

public SearchableClassLoader()
新しいクラスローダを生成します。 このコンストラクタは、スーパークラスのデフォルトコンストラクタを呼び出します。

例外:
SecurityException - セキュリティマネージャが存在し、その checkCreateClassLoader メソッドが新しいクラスローダの作成を許可しない場合

SearchableClassLoader

public SearchableClassLoader(ClassLoader parent)
指定された親クラスローダを使って、委譲のために新しいクラスローダを作成します。

パラメータ:
parent - 親のクラスローダ
例外:
SecurityException - セキュリティマネージャが存在し、その checkCreateClassLoader メソッドが新しいクラスローダの作成を許可しない場合
メソッドの詳細

addSearchPath

public void addSearchPath(File file)
指定されたパスがファイルを表している場合、jar または zip を指定されたと判断して、 ResourceLoader.addClassArchive(File)を呼び出します。 指定されたパスがディレクトリを表している場合、 ResourceLoader.addClassPath(File)および ResourceLoader.addClassArchiveLibrary(File)を呼び出します。

パラメータ:
file - クラスを検索するパス

getImplementedClasses

public Class[] getImplementedClasses(Class clazz)
                              throws ZipException,
                                     IOException,
                                     ClassNotFoundException
指定されたクラスと代入互換のあるインスタンスを生成できるクラスを検索します。 「代入互換がある」とは、以下のいずれかの条件をみたすクラスです。
  • 同一のクラスである
  • 継承している親クラスが指定したクラスと同一
  • 実装しているインタフェースが指定した（インタフェースを表す）クラスと同一

パラメータ:
clazz -
戻り値:
例外:
ZipException
IOException
ClassNotFoundException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ShutdownEventController (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス ShutdownEventController

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
public class ShutdownEventController
extends Object

このクラスは、サーバプロセスの基礎ロジック。

導入されたバージョン:
version 4.0
関連項目:
ShutdownListener

メソッドの概要
static void | addListener(ShutdownListener listener) シャットダウンリスナーを登録します。
static ShutdownListener[] | getShutdownListeners() 現在登録されているリスナを返します。
static boolean | isShutdown() シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
static boolean | removeListener(ShutdownListener listener) シャットダウンリスナーを削除します。
static void | shutdown() このプロセスを終了します。
static void | shutdown(int status) このプロセスを終了します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

addListener

public static void addListener(ShutdownListener listener)
シャットダウンリスナーを登録します。

パラメータ:
listener - イベントリスナーオブジェクト
例外:
IllegalStateException - すでにシャットダウン処理中
関連項目:
ShutdownListener

removeListener

public static boolean removeListener(ShutdownListener listener)
シャットダウンリスナーを削除します。

ただし、すでにシャットダウンフェーズに入ってしまっている場合は、 リスナーの削除に成功しても削除したリスナが実行されてしまう 可能性があります。

パラメータ:
listener - イベントリスナーオブジェクト
戻り値:
リストに、指定された要素が格納されている場合は true
関連項目:
ShutdownListener

getShutdownListeners

public static ShutdownListener[] getShutdownListeners()
現在登録されているリスナを返します。

戻り値:
登録されているリスナ

shutdown

public static void shutdown()
このプロセスを終了します。 このメソッドは、System.exit(0) と同様です。

導入されたバージョン:
version 4.0.1

shutdown

public static void shutdown(int status)
このプロセスを終了します。 引数はステータスコードとして作用します。 通例、ゼロ以外のステータスコードは異常終了を示します。 このメソッドは、正常に復帰することはありません。

パラメータ:
status - 終了のステータス
導入されたバージョン:
version 4.0.1

isShutdown

public static boolean isShutdown()
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。

戻り値:
シャットダウン中（またはシャットダウン処理を終了したとみなされる）場合は、true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ShutdownListener (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ShutdownListener

public interface ShutdownListener

シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。

このインターフェースを実装して ShutdownEventController クラスに登録する ことで、任意のロジックをシャットダウン直前に実行することができます。

導入されたバージョン:
version 5.0
関連項目:
ShutdownEventController

メソッドの概要
 void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。

メソッドの詳細

handleShutdown

public void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。 このメソッドを実装することで、 シャットダウン直前に任意のロジックを実行することができます。 このメソッドは、プロセスのシャットダウン直前に実行されるため、 必ずスレッドセーフであり、かつデッドロックしないように プログラムする必要があります。 このメソッド実行中の ShutdownEventController に対するリスナー登録は、 デッドロックの原因となるので、絶対にやってはいけません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StdErr (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StdErr

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
public class StdErr
extends Object

このクラスは、エラーメッセージ出力用です。

導入されたバージョン:
version 5.0

メソッドの概要
static void | addOutputStream(OutputStream out) メッセージの出力先を追加します。
static PrintStream | getDefaultPrintStream() このクラスがロードされた時点の、System.err を 返します。
static PrintStream | getPrintStream() メッセージを出力する出力ストリームを返します。
static ThrowablePrintListener | getThrowablePrintListener() 現在の例外出力リスナを返します。
static boolean | removeOutputStream(OutputStream out) メッセージの出力先を削除します。
static void | setThrowablePrintListener(ThrowablePrintListener listener) 指定の例外出力リスナを割り当て直します。
static void | write(String msg) 指定のメッセージを標準エラー出力および指定の出力先に書き出します。
static void | write(String msg, Throwable exception) 指定のメッセージを標準エラー出力および指定の出力先に書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getDefaultPrintStream

public static PrintStream getDefaultPrintStream()
このクラスがロードされた時点の、System.err を 返します。

このメソッドのリターン値を引数にして、 removeOutputStream(OutputStream) を実行すると、 標準エラー出力（コンソール）にメッセージが表示されなくなります。

戻り値:
標準エラー出力にメッセージを書き出す出力ストリーム

getPrintStream

public static PrintStream getPrintStream()
メッセージを出力する出力ストリームを返します。

返された出力ストリームの PrintStream.close() メソッドを 実行してストリームを閉じてしまうと、以後メッセージを出力できなく なります。

戻り値:
出力ストリーム

addOutputStream

public static void addOutputStream(OutputStream out)
メッセージの出力先を追加します。

パラメータ:
out - 出力ストリーム

removeOutputStream

public static boolean removeOutputStream(OutputStream out)
メッセージの出力先を削除します。

パラメータ:
out - 出力ストリーム
戻り値:
削除に成功した場合は true。

setThrowablePrintListener

public static void setThrowablePrintListener(ThrowablePrintListener listener)
指定の例外出力リスナを割り当て直します。

パラメータ:
listener - 新しい例外出力リスナ

getThrowablePrintListener

public static ThrowablePrintListener getThrowablePrintListener()
現在の例外出力リスナを返します。

戻り値:
現在有効な例外出力リスナ

write

public static void write(String msg)
指定のメッセージを標準エラー出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ

write

public static void write(String msg,
                         Throwable exception)
指定のメッセージを標準エラー出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ
exception - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StdOut (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StdOut

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
public class StdOut
extends Object

このクラスは、システムメッセージ出力用です。

導入されたバージョン:
version 5.0

メソッドの概要
static void | addOutputStream(OutputStream out) メッセージの出力先を追加します。
static PrintStream | getDefaultPrintStream() このクラスがロードされた時点の、System.out を 返します。
static PrintStream | getPrintStream() メッセージを出力する出力ストリームを返します。
static boolean | removeOutputStream(OutputStream out) メッセージの出力先を削除します。
static void | write(String msg) 指定のメッセージを標準出力および指定の出力先に書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getDefaultPrintStream

public static PrintStream getDefaultPrintStream()
このクラスがロードされた時点の、System.out を 返します。

このメソッドのリターン値を引数にして、 removeOutputStream(OutputStream) を実行すると、 標準出力（コンソール）にメッセージが表示されなくなります。

戻り値:
標準出力にメッセージを書き出す出力ストリーム

getPrintStream

public static PrintStream getPrintStream()
メッセージを出力する出力ストリームを返します。

返された出力ストリームの PrintStream.close() メソッドを 実行してストリームを閉じてしまうと、以後メッセージを出力できなく なります。

戻り値:
出力ストリーム

addOutputStream

public static void addOutputStream(OutputStream out)
メッセージの出力先を追加します。

パラメータ:
out - 出力ストリーム

removeOutputStream

public static boolean removeOutputStream(OutputStream out)
メッセージの出力先を削除します。

パラメータ:
out - 出力ストリーム
戻り値:
削除に成功した場合は true。

write

public static void write(String msg)
指定のメッセージを標準出力および指定の出力先に書き出します。

パラメータ:
msg - メッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StringUtil (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
クラス StringUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil
public class StringUtil
extends Object

文字列ユーティリティクラス。

文字列に関する実用的な関数および定数値を提供するクラス。

導入されたバージョン:
5.0
バージョン:
1.0

フィールドの概要
static String EMPTY_STRING
空文字列の定数値。
メソッドの概要
static String | join(Collection collection, String delm) コレクションの連結。
static String | join(Object[] objects, String delm) オブジェクト配列の連結。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

EMPTY_STRING

public static final String EMPTY_STRING
空文字列の定数値。

メソッドの詳細

join

public static String join(Collection collection,
                          String delm)
コレクションの連結。

引数で指定した区切り文字で、コレクション内の各オブジェクトの文字列表現を連結した文字列を返す。

パラメータ:
collection - 連結を行うコレクション
delm - 区切り文字
戻り値:
連結した文字列

join

public static String join(Object[] objects,
                          String delm)
オブジェクト配列の連結。

引数で指定した区切り文字で、オブジェクト配列の各オブジェクトの文字列表現を連結した文字列を返す。

パラメータ:
delm - 区切り文字
戻り値:
連結した文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ThreadStopListener (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ThreadStopListener

public interface ThreadStopListener

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0

メソッドの概要
 void handleThreadStop()
監視していたスレッドが終了したときに実行されるメソッドです。

メソッドの詳細

handleThreadStop

public void handleThreadStop()
監視していたスレッドが終了したときに実行されるメソッドです。 このメソッドをサブクラスが実行することで、特定のスレッド終了時に プログラムを実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ThrowablePrintListener (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.lang
インタフェース ThrowablePrintListener

public interface ThrowablePrintListener

このインタフェースは、例外情報を出力するためのものです。

StdErr クラスと合わせて利用します。

導入されたバージョン:
version 5.0

メソッドの概要
void | printMessage(Throwable t) 例外のメッセージを出力します。
void | printStackTrace(Throwable t) 例外のスタックトレースを出力します。

メソッドの詳細

printMessage

public void printMessage(Throwable t)
例外のメッセージを出力します。

パラメータ:
t - 例外

printStackTrace

public void printStackTrace(Throwable t)
例外のスタックトレースを出力します。

パラメータ:
t - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor の使用

AbstractSocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での AbstractSocketConnectionDistributor の使用

jp.co.intra_mart.common.aid.jdk.java.net での AbstractSocketConnectionDistributor のサブクラス
 class SocketPool
このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket の使用

ExtendedSocket を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedSocket の使用

jp.co.intra_mart.common.aid.jdk.java.net での ExtendedSocket のサブクラス
 class SocketConnection
ソケットプール用のスケルトン実装を提供します。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 void SocketEventListener.handleSocketEvent(ExtendedSocket socket)
ソケットに関するイベント発生時に呼び出されるメソッド。

ExtendedSocket 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のコンストラクタ
SocketConnection(ExtendedSocket socket)
ソケット入出力インスタンスを構築します。
ExtendedSocket(ExtendedSocket socket)
ソケットを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.Localhost の使用

Localhost を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での Localhost の使用

Localhost を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
static Localhost Localhost.instance()
このクラスから生成される唯一のインスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection の使用

SocketConnection を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnection の使用

SocketConnection を返す jp.co.intra_mart.common.aid.jdk.java.net のメソッド
SocketConnection | SocketPool.connection() コネクションの取得。
SocketConnection | SocketConnectionDistributor.connection() コネクションの取得。

SocketConnection 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
 boolean SocketPool.eject(SocketConnection connection)
指定コネクションをこのプールの管理から切り離します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor の使用

SocketConnectionDistributor を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionDistributor の使用

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionDistributor のサブインタフェース
 interface SocketConnectionManager
通信ソケットをプールする機能のインターフェースです。

SocketConnectionDistributor を実装している jp.co.intra_mart.common.aid.jdk.java.net のクラス
class | AbstractSocketConnectionDistributor このクラスは、通信ソケットを作成する機能を提供します。
class | SocketPool このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager の使用

SocketConnectionManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketConnectionManager の使用

SocketConnectionManager を実装している jp.co.intra_mart.common.aid.jdk.java.net のクラス
 class SocketPool
このクラスは、通信ソケットをプールする機能を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener の使用

SocketEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net での SocketEventListener の使用

SocketEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.net のメソッド
void | SocketPool.addCreateSocketEventListener(SocketEventListener listener) ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | SocketPool.addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | ExtendedSocket.addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.SocketPool の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.SocketPool の使用

jp.co.intra_mart.common.aid.jdk.java.net.SocketPool はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException の使用

jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractSocketConnectionDistributor (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス AbstractSocketConnectionDistributor

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor
すべての実装インタフェース:
SocketConnectionDistributor
直系の既知のサブクラス:
SocketPool
public abstract class AbstractSocketConnectionDistributor
extends Object
implements SocketConnectionDistributor

このクラスは、通信ソケットを作成する機能を提供します。

このクラスを継承してソケットプールを作成することができます。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractSocketConnectionDistributor(String address, int port)
ソケット作成オブジェクトを構築します。
メソッドの概要
protected Socket | createSocket() 新しいソケットを作成します。
String | getAddress() アドレスを返します。
int | getPort() ポートを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

コンストラクタの詳細

AbstractSocketConnectionDistributor

protected AbstractSocketConnectionDistributor(String address,
                                              int port)
ソケット作成オブジェクトを構築します。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
メソッドの詳細

createSocket

protected Socket createSocket()
                       throws UnknownHostException,
                              IOException
新しいソケットを作成します。

戻り値:
ソケット
例外:
UnknownHostException - ホストの IP アドレスを判定できなかった場合
IOException - ソケットの生成中に入出力エラーが発生した場合

getAddress

public String getAddress()
アドレスを返します。

戻り値:
このプールのネットワーク接続先サーバアドレス

getPort

public int getPort()
ポートを返します。

戻り値:
このプールのネットワーク接続先サーバポート
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedSocket (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス ExtendedSocket

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
直系の既知のサブクラス:
SocketConnection
public class ExtendedSocket
extends Object

このクラスは、ソケット通信用の入出力機能を提供します。

このクラスの提供している独自機能や、このクラスの持つメソッドから 取得したオブジェクトを使っている最中に例外がスローされた場合、 このクラスのインスタンスは発生した例外を保存します。 保存された例外は、lastError メソッドにより知ることができます。
ただし、このクラスが継承しているスーパークラスのメソッドの 呼び出し時にスローされた例外に関しては感知することはできません。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected | ExtendedSocket(ExtendedSocket socket) ソケットを構築します。
 | ExtendedSocket(Socket socket) ソケットを構築します。
 | ExtendedSocket(String address, int port) ソケットを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | clearError() このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
void | close() 入出力ストリームおよびソケットを閉じます。
Iterator | errorIterator() このインスタンスのメソッド実行中に発生した例外を返します。
Collection | getCloseSocketEventListeners() このソケットに登録されているクローズ・イベント・リスナーを返します。
ExtendedInputStream | getInputStream() 入力ストリームの取得。
ExtendedOutputStream | getOutputStream() 出力ストリームの取得。
Socket | getSocket() このオブジェクトの持つソケットオブジェクトを返します。
boolean | isClosed() このソケットが閉じられているかどうかをチェックします。
Throwable | lastError() このインスタンスのメソッド中で最後に発生した例外を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExtendedSocket

public ExtendedSocket(String address,
                      int port)
               throws UnknownHostException,
                      IOException
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
UnknownHostException - ホストの IP アドレスが判定できなかった場合にスローされます。
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

public ExtendedSocket(Socket socket)
               throws IOException
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

ExtendedSocket

protected ExtendedSocket(ExtendedSocket socket)
ソケットを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
メソッドの詳細

getSocket

public Socket getSocket()
このオブジェクトの持つソケットオブジェクトを返します。 このメソッドから取得したソケットオブジェクトの入出力ストリームと このオブジェクト自身から取得した入出力ストリームを 同時に利用した場合、データ送受信の整合性が失われてしまう可能性が あります。

戻り値:
ソケットオブジェクト

getInputStream

public ExtendedInputStream getInputStream()
入力ストリームの取得。

戻り値:
入力ストリーム

getOutputStream

public ExtendedOutputStream getOutputStream()
出力ストリームの取得。

戻り値:
出力ストリーム

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー
導入されたバージョン:
version 4.2

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
このソケットに登録されているクローズ・イベント・リスナーを返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection
導入されたバージョン:
version 4.2

lastError

public Throwable lastError()
このインスタンスのメソッド中で最後に発生した例外を返します。

戻り値:
最後に発生した例外

clearError

public void clearError()
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。

このメソッドを実行すると、次に例外が発生するまで lastError()メソッドは null を返し、 errorIterator()メソッドは空の反復子を返します。

導入されたバージョン:
version 4.0

errorIterator

public Iterator errorIterator()
このインスタンスのメソッド実行中に発生した例外を返します。 このメソッドの返す反復子は発生時間順に例外オブジェクトを返します。 反復子の返すオブジェクトは、Throwable クラスと代入互換のある オブジェクトになります。

戻り値:
例外の反復子

close

public void close()
           throws IOException
入出力ストリームおよびソケットを閉じます。
入出力ストリームを閉じる前にバッファに溜められているデータをすべて 出力ストリームに書き出します。

例外:
IOException - 入出力エラーが発生した場合

isClosed

public boolean isClosed()
このソケットが閉じられているかどうかをチェックします。

戻り値:
ソケットが閉じられている場合は true
導入されたバージョン:
version4.1
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Localhost (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス Localhost

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.Localhost
すべての実装インタフェース:
Serializable
public class Localhost
extends Object
implements Serializable

このクラスは、サーバプロセスの基礎情報を管理します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

メソッドの概要
byte[] | getAddress() このコンピュータのＩＰアドレスを返します。
String | getHostAddress() このコンピュータのアドレスを返します。
String | getHostName() このコンピュータのホスト名を返します。
static Localhost | instance() このクラスから生成される唯一のインスタンスを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

instance

public static Localhost instance()
                          throws UnknownHostException
このクラスから生成される唯一のインスタンスを返します。 このメソッドが返すインスタンスは、常に一定で、 VM 内で共有されます。

戻り値:
このクラスのインスタンス
例外:
UnknownHostException - このコンピュータのＩＰアドレスが判定できなかった場合

getAddress

public byte[] getAddress()
このコンピュータのＩＰアドレスを返します。

戻り値:
IPアドレス

getHostAddress

public String getHostAddress()
このコンピュータのアドレスを返します。

戻り値:
アドレス

getHostName

public String getHostName()
このコンピュータのホスト名を返します。

戻り値:
ホスト名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.net (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.net
インタフェース
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
クラス
AbstractSocketConnectionDistributor
ExtendedSocket
Localhost
SocketConnection
SocketPool
例外
UnsupportedNetworkConnectException


jp.co.intra_mart.common.aid.jdk.java.net (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

参照:
説明

インタフェースの概要
SocketConnectionDistributor | このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager | 通信ソケットをプールする機能のインターフェースです。
SocketEventListener | 通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

クラスの概要
AbstractSocketConnectionDistributor | このクラスは、通信ソケットを作成する機能を提供します。
ExtendedSocket | このクラスは、ソケット通信用の入出力機能を提供します。
Localhost | このクラスは、サーバプロセスの基礎情報を管理します。
SocketConnection | ソケットプール用のスケルトン実装を提供します。
SocketPool | このクラスは、通信ソケットをプールする機能を提供します。

例外の概要
UnsupportedNetworkConnectException To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.

パッケージ jp.co.intra_mart.common.aid.jdk.java.net の説明

ソケットによるネットワーク対応機能を実装するためのクラスを提供します。


jp.co.intra_mart.common.aid.jdk.java.net クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.net の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener


パッケージ jp.co.intra_mart.common.aid.jdk.java.net の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.net の使用

jp.co.intra_mart.common.aid.jdk.java.net を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.net ソケットによるネットワーク対応機能を実装するためのクラスを提供します。

jp.co.intra_mart.common.aid.jdk.java.net により使用される jp.co.intra_mart.common.aid.jdk.java.net のクラス
AbstractSocketConnectionDistributor
このクラスは、通信ソケットを作成する機能を提供します。
ExtendedSocket
このクラスは、ソケット通信用の入出力機能を提供します。
Localhost
このクラスは、サーバプロセスの基礎情報を管理します。
SocketConnection
ソケットプール用のスケルトン実装を提供します。
SocketConnectionDistributor
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager
通信ソケットをプールする機能のインターフェースです。
SocketEventListener
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SocketConnection (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス SocketConnection

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
        拡張 jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
public abstract class SocketConnection
extends ExtendedSocket

ソケットプール用のスケルトン実装を提供します。

導入されたバージョン:
version 5.0
関連項目:
SocketPool

コンストラクタの概要
protected | SocketConnection(ExtendedSocket socket) ソケット入出力インスタンスを構築します。
protected | SocketConnection(Socket socket) ソケット入出力インスタンスを構築します。
protected | SocketConnection(String address, int port) ソケット入出力インスタンスを構築します。
メソッドの概要
abstract  void release()
ソケットおよび入出力ストリームの利用を中止します。
クラス jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket から継承したメソッド
addCloseSocketEventListener, clearError, close, errorIterator, getCloseSocketEventListeners, getInputStream, getOutputStream, getSocket, isClosed, lastError
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketConnection

protected SocketConnection(String address,
                           int port)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
address - 接続先アドレス
port - 接続先ポート
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(Socket socket)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー

SocketConnection

protected SocketConnection(ExtendedSocket socket)
                    throws IOException
ソケット入出力インスタンスを構築します。

このコンストラクタは、通信クライアント用のインスタンス構築用として 利用します。

パラメータ:
socket - ソケットオブジェクト
例外:
IOException - 入出力ストリームの作成時エラー
メソッドの詳細

release

public abstract void release()
                      throws IOException
ソケットおよび入出力ストリームの利用を中止します。

このインスタンスの利用が終了したら、必ず呼び出して下さい。
このメソッドを呼び出さないと、プール領域中のリソースが完全には 開放されません。
また、スーパークラス ExtendedSocket の close メソッドを呼び出した場合も プール中のリソースが完全に開放されない可能性があります。

リソースの開放は、プールオブジェクトが必要に応じて行います。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionDistributor (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketConnectionDistributor

既知のサブインタフェースの一覧:
SocketConnectionManager
既知の実装クラスの一覧:
AbstractSocketConnectionDistributor, SocketPool
public interface SocketConnectionDistributor

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

導入されたバージョン:
version 5.0

メソッドの概要
void | clean() プール中のコネクションをすべて破棄します。
SocketConnection | connection() コネクションの取得。
void | destroy() このプールを破棄します。

メソッドの詳細

connection

public SocketConnection connection()
                            throws IOException
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

destroy

public void destroy()
このプールを破棄します。

clean

public void clean()
プール中のコネクションをすべて破棄します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketConnectionManager (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketConnectionManager

すべてのスーパーインタフェース:
SocketConnectionDistributor
既知の実装クラスの一覧:
SocketPool
public interface SocketConnectionManager
extends SocketConnectionDistributor

通信ソケットをプールする機能のインターフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
int | getCapacity() コネクション作成最大数の取得。
int | getSize() このプールが現在管理しているコネクション数です。
int | usableConnection() 現在待機中のコネクションをです。
インタフェース jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor から継承したメソッド
clean, connection, destroy

メソッドの詳細

getCapacity

public int getCapacity()
コネクション作成最大数の取得。

戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
現在待機中のコネクションをです。

戻り値:
待機中のコネクション数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SocketEventListener (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
インタフェース SocketEventListener

public interface SocketEventListener

通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。

ソケットに関するイベント通知側と組み合わせて利用することにより、 ソケットに関する特定のイベント発生時に独自の処理を実行することができます。

導入されたバージョン:
version 5.0

メソッドの概要
 void handleSocketEvent(ExtendedSocket socket)
ソケットに関するイベント発生時に呼び出されるメソッド。

メソッドの詳細

handleSocketEvent

public void handleSocketEvent(ExtendedSocket socket)
                       throws IOException
ソケットに関するイベント発生時に呼び出されるメソッド。 サブクラスは、このメソッドを実装することにより、特定のソケットに関する イベントの発生を知ることができます。

パラメータ:
socket - イベントの発生したソケット
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SocketPool (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス SocketPool

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor
        拡張 jp.co.intra_mart.common.aid.jdk.java.net.SocketPool
すべての実装インタフェース:
SocketConnectionDistributor, SocketConnectionManager
public class SocketPool
extends AbstractSocketConnectionDistributor
implements SocketConnectionManager

このクラスは、通信ソケットをプールする機能を提供します。

プール機能を利用することにより少ないソケットを複数のプログラムから 利用できるようになります。
このプールは、１つのインスタンスに付き１つの専用スレッドを持ちます。 プールは専用のスレッドにより管理され、一定時間に１つのコネクションが 順に破棄されていきます。したがって、コネクションを全く使用しないまま 長い時間が経過すると、このプール中にプールされているソケット・コネクションは ０個になります。

導入されたバージョン:
version 5.0

コンストラクタの概要
SocketPool(String address, int port)
ソケットプールを構築します。
SocketPool(String address, int port, int capacity)
ソケットプールを構築します。
メソッドの概要
void | addCloseSocketEventListener(SocketEventListener listener) ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
void | addCreateSocketEventListener(SocketEventListener listener) ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
void | clean() プール中のコネクションをすべて破棄します。
SocketConnection | connection() コネクションの取得。
void | destroy() このプールを破棄します。
boolean | eject(SocketConnection connection) 指定コネクションをこのプールの管理から切り離します。
protected void | finalize() このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
int | getCapacity() コネクション作成最大数の取得。
Collection | getCloseSocketEventListeners() このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
Collection | getCreateSocketEventListeners() このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
int | getSize() このプールが現在管理しているコネクション数です。
int | usableConnection() 現在待機中のコネクションをです。
クラス jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor から継承したメソッド
createSocket, getAddress, getPort
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SocketPool

public SocketPool(String address,
                  int port)
ソケットプールを構築します。

このプールで管理できるソケットコネクションは 1 個になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート

SocketPool

public SocketPool(String address,
                  int port,
                  int capacity)
ソケットプールを構築します。

コネクションは動的に生成されます。 capacity 個よりも多くのコネクション要求があった場合、 コネクションが開放されるまで待ち状態になります。
capacity にはプールの性質上、 1 以上の値を指定して下さい。 capacity に 1 より小さな値を指定した場合、プール数は 1 になります。

パラメータ:
address - 接続するサーバのアドレス
port - 接続するサーバがサービスを提供しているポート
capacity - 接続コネクションの最大数
メソッドの詳細

addCreateSocketEventListener

public void addCreateSocketEventListener(SocketEventListener listener)
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールで新規にソケットが 作成されたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCreateSocketEventListeners

public Collection getCreateSocketEventListeners()
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

addCloseSocketEventListener

public void addCloseSocketEventListener(SocketEventListener listener)
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。 このメソッドで追加したリスナーには、このプールのソケットが クローズされたときに、そのソケットをメソッド引数として handleSocketEventメソッドが実行されます。

パラメータ:
listener - ソケットイベントリスナー

getCloseSocketEventListeners

public Collection getCloseSocketEventListeners()
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。 このメソッドの戻り値となる Collection の各要素は SocketEventListener 型オブジェクトです。

戻り値:
SocketEventListener を要素とする Collection

getCapacity

public int getCapacity()
コネクション作成最大数の取得。

定義:
インタフェース SocketConnectionManager 内の getCapacity
戻り値:
このプールにより作成されるコネクションの最大数

getSize

public int getSize()
このプールが現在管理しているコネクション数です。

この数は、最小が 0 で最大が getCapacity() メソッドにより得られる値の 間で変動します。

定義:
インタフェース SocketConnectionManager 内の getSize
戻り値:
有効なコネクション数
導入されたバージョン:
version 4.2

usableConnection

public int usableConnection()
現在待機中のコネクションをです。

定義:
インタフェース SocketConnectionManager 内の usableConnection
戻り値:
待機中のコネクション数

connection

public SocketConnection connection()
                            throws IOException
コネクションの取得。

プール中にコネクションが待機している場合にはプールの中から 待機中のコネクションを返却します。 プール中にコネクションが存在しない場合には、 新しいコネクションを生成して返します。

定義:
インタフェース SocketConnectionDistributor 内の connection
戻り値:
通信用インスタンス
例外:
IOException - ソケットの接続エラー
関連項目:
SocketConnection

eject

public boolean eject(SocketConnection connection)
指定コネクションをこのプールの管理から切り離します。

指定コネクションがこのプールに管理されていたものなら、 このメソッド実行後はこのプールの管理するコネクションが１つ減少するので、 新たにコネクションを作成することができるようになります。

指定のコネクションをこのプールが管理していて他のスレッドによって 使用（connection() メソッドにより取得）されていない場合 true を 返します。指定のコネクションがこのプールにより管理されているもの であった場合でも、他のスレッドにより使用中の場合は false を返します。

パラメータ:
connection - 管理から切り離すコネクション
戻り値:
コネクションの切り離しに成功した場合 true

destroy

public void destroy()
このプールを破棄します。

定義:
インタフェース SocketConnectionDistributor 内の destroy

clean

public void clean()
プール中のコネクションをすべて破棄します。

定義:
インタフェース SocketConnectionDistributor 内の clean

finalize

protected void finalize()
                 throws Throwable
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。 SocketPool クラスは、このメソッドによりオブジェクトの破棄前に リソースのクリーンアップをします。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


UnsupportedNetworkConnectException (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.net
クラス UnsupportedNetworkConnectException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.io.IOException
                拡張 jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
すべての実装インタフェース:
Serializable
public class UnsupportedNetworkConnectException
extends IOException

To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates. To enable and disable the creation of type comments go to Window>Preferences>Java>Code Generation.

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnsupportedNetworkConnectException()
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String arg0)
Constructor for UnsupportedNetworkConnectException.
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException()
Constructor for UnsupportedNetworkConnectException.

UnsupportedNetworkConnectException

public UnsupportedNetworkConnectException(String arg0)
Constructor for UnsupportedNetworkConnectException.

パラメータ:
arg0 -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator の使用

AbstractDualComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での AbstractDualComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util での AbstractDualComparator のサブクラス
 class MultiComparator
複数のコンパレータを使用してソートを行うためにクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.java.util.DualComparator の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.java.util.DualComparator の使用

DualComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での DualComparator の使用

DualComparator を実装している jp.co.intra_mart.common.aid.jdk.java.util のクラス
class | AbstractDualComparator ２つのコンパレータを使用してソートを行うクラスです。
class | MultiComparator 複数のコンパレータを使用してソートを行うためにクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties の使用

ExtendedProperties を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での ExtendedProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml での ExtendedProperties のサブクラス
 class XMLProperties
XML をベースとした不変のプロパティセットを表します。

jp.co.intra_mart.common.aid.jdk.org.w3c.dom での ExtendedProperties の使用

jp.co.intra_mart.common.aid.jdk.org.w3c.dom での ExtendedProperties のサブクラス
 class ElementProperties
DOM をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle の使用

jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator の使用

FilterComparator を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util での FilterComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util での FilterComparator のサブクラス
 class ReverseComparator
コンパレータのフィルタとして機能します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap の使用

jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil の使用

jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil の使用

jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties の使用

jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator の使用

jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractDualComparator (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス AbstractDualComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
直系の既知のサブクラス:
MultiComparator
public abstract class AbstractDualComparator
extends Object
implements DualComparator

２つのコンパレータを使用してソートを行うクラスです。
比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 もし、その比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
AbstractDualComparator()
新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jdk.java.util.DualComparator から継承したメソッド
getPrimaryComparator, getSecondaryComparator
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

AbstractDualComparator

public AbstractDualComparator()
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は ０、最初の引数が ２ 番目の引 数より大きい場合は正の整数を返します。
このメソッドは ２ つのコンパレータを使用して比較を行いその結果を返します。 比較の順番は、指定された第１コンパレータ、第２コンパレータの順に行われます。まず、第１コンパレータで比較を行います。 比較の結果が０でないときは、その比較した結果を返します。もし比較の結果が０の時は第２コンパレータで比較を行いその結果を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DualComparator (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
インタフェース DualComparator

すべてのスーパーインタフェース:
Comparator, Serializable
既知の実装クラスの一覧:
AbstractDualComparator
public interface DualComparator
extends Serializable, Comparator

２つのコンパレータを使用してソートを行うためのインターフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
Comparator | getPrimaryComparator() １番目コンパレータを取得します。
Comparator | getSecondaryComparator() ２番目コンパレータを取得します。
インタフェース java.util.Comparator から継承したメソッド
compare, equals

メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
１番目コンパレータを取得します。

戻り値:
１番目のコンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
２番目コンパレータを取得します。

戻り値:
２番目のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedProperties (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ExtendedProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
直系の既知のサブクラス:
ElementProperties
public class ExtendedProperties
extends Properties

java.util.Properties を、より便利に利用するためのインタフェースを提供します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ExtendedProperties()
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties defaults)
指定されたデフォルト値を持つ空のプロパティリストを作成します。
メソッドの概要
double | doubleValue(String key) 指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
double | doubleValue(String key, double defaultValue) 指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
float | floatValue(String key) 指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
float | floatValue(String key, float defaultValue) 指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
int | intValue(String key) 指定されたキーによって示されるプロパティ値を 数値として取得します。
int | intValue(String key, int defaultValue) 指定されたキーによって示されるプロパティ値を 数値として取得します。
boolean | isFalse(String key) 指定されたキーによって示されるプロパティ値を真偽判定します。
boolean | isTrue(String key) 指定されたキーによって示されるプロパティ値を真偽判定します。
long | longValue(String key) 指定されたキーによって示されるプロパティ値を 長整数として取得します。
long | longValue(String key, long defaultValue) 指定されたキーによって示されるプロパティ値を 長整数として取得します。
int | parseInt(String key, int radix) 2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
long | parseLong(String key, int radix) 2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedProperties

public ExtendedProperties()
デフォルト値を持たない空のプロパティリストを作成します。

ExtendedProperties

public ExtendedProperties(Properties defaults)
指定されたデフォルト値を持つ空のプロパティリストを作成します。

パラメータ:
defaults - デフォルト値
メソッドの詳細

isTrue

public boolean isTrue(String key)
指定されたキーによって示されるプロパティ値を真偽判定します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値が "true" の場合(大文字と小文字は区別しない) true、そうでない場合 false。

isFalse

public boolean isFalse(String key)
指定されたキーによって示されるプロパティ値を真偽判定します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値が "false" の場合(大文字と小文字は区別しない) true、そうでない場合 false。

intValue

public int intValue(String key)
指定されたキーによって示されるプロパティ値を 数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は 0。

intValue

public int intValue(String key,
                    int defaultValue)
指定されたキーによって示されるプロパティ値を 数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

parseInt

public int parseInt(String key,
                    int radix)
             throws NumberFormatException
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。 このメソッドは、java.lang.Integer.parseInt(String s, int radix) メソッドの仕様に準じます。

パラメータ:
key - プロパティの名前
radix - 使用される基数
戻り値:
プロパティの文字列値を数値として表現した値。
例外:
NumberFormatException - 文字列が解析可能な整数を含まない場合

longValue

public long longValue(String key)
指定されたキーによって示されるプロパティ値を 長整数として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は 0。

longValue

public long longValue(String key,
                      long defaultValue)
指定されたキーによって示されるプロパティ値を 長整数として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

parseLong

public long parseLong(String key,
                      int radix)
               throws NumberFormatException
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。 このメソッドは、java.lang.Long.parseLong(String s, int radix) メソッドの仕様に準じます。

パラメータ:
key - プロパティの名前
radix - 使用される基数
戻り値:
プロパティの文字列値を数値として表現した値。
例外:
NumberFormatException - 文字列が解析可能な整数を含まない場合

floatValue

public float floatValue(String key)
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は float 型の非数 (NaN) 値。

floatValue

public float floatValue(String key,
                        float defaultValue)
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。

doubleValue

public double doubleValue(String key)
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。

パラメータ:
key - プロパティの名前
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)は double 型の非数 (NaN) 値。

doubleValue

public double doubleValue(String key,
                          double defaultValue)
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。

パラメータ:
key - プロパティの名前
defaultValue - デフォルト値
戻り値:
プロパティの文字列値を数値として表現した値。そのキーにプロパティがない場合(設定値が不適切なフォーマットも含む)はデフォルト値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileResourceBundle (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FileResourceBundle

java.lang.Object
    拡張 java.util.ResourceBundle
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle
public class FileResourceBundle
extends ResourceBundle

フィールドの概要
クラス java.util.ResourceBundle から継承したフィールド
parent
コンストラクタの概要
FileResourceBundle(String path)
プロパティリソースを作成します。
FileResourceBundle(String path, Locale locale)
プロパティリソースを作成します。
FileResourceBundle(String path, String ext)
プロパティリソースを作成します。
FileResourceBundle(String path, String ext, Locale locale)
プロパティリソースを作成します。
メソッドの概要
Enumeration | getKeys() キーの列挙を返します。
Locale | getLocale() ロケールを返します。
protected Object | handleGetObject(String key) キーに対応したオブジェクトを返します。
クラス java.util.ResourceBundle から継承したメソッド
getBundle, getBundle, getBundle, getObject, getString, getStringArray, setParent
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileResourceBundle

public FileResourceBundle(String path)
                   throws MissingResourceException,
                          IOException
プロパティリソースを作成します。

パラメータ:
path - ファイルパス
例外:
MissingResourceException
IOException

FileResourceBundle

public FileResourceBundle(String path,
                          Locale locale)
                   throws MissingResourceException,
                          IOException
プロパティリソースを作成します。

パラメータ:
path - ファイルパス
locale - ロケール
例外:
MissingResourceException
IOException

FileResourceBundle

public FileResourceBundle(String path,
                          String ext)
                   throws MissingResourceException,
                          IOException
プロパティリソースを作成します。

パラメータ:
path - ファイルパス
例外:
MissingResourceException
IOException

FileResourceBundle

public FileResourceBundle(String path,
                          String ext,
                          Locale locale)
                   throws MissingResourceException,
                          IOException
プロパティリソースを作成します。

パラメータ:
path - ファイルパス
locale - ロケール
例外:
MissingResourceException
IOException
メソッドの詳細

getKeys

public Enumeration getKeys()
キーの列挙を返します。

戻り値:
@see java.util.ResourceBundle#getKeys()

getLocale

public Locale getLocale()
ロケールを返します。

戻り値:
ロケール
関連項目:
ResourceBundle.getLocale()

handleGetObject

protected Object handleGetObject(String key)
                          throws MissingResourceException
キーに対応したオブジェクトを返します。

パラメータ:
key - キー
戻り値:
取得したオブジェクト
例外:
MissingResourceException
関連項目:
ResourceBundle.handleGetObject(java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterComparator (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FilterComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator
すべての実装インタフェース:
Comparator, Serializable
直系の既知のサブクラス:
ReverseComparator
public abstract class FilterComparator
extends Object
implements Comparator, Serializable

コンパレータのフィルターとして機能する抽象クラスです。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
FilterComparator(Comparator comparator)
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
int | compare(Object arg0, Object arg1) 順序付けのために 2 つの引数を比較するメソッドです。
Comparator | getParentComparator() フィルター対象のコンパレータを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

FilterComparator

public FilterComparator(Comparator comparator)
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために 2 つの引数を比較するメソッドです。
最初の引数が 2 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
比較した結果

getParentComparator

public Comparator getParentComparator()
フィルター対象のコンパレータを返します。

戻り値:
フィルター対象のコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FixedSizeMap (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス FixedSizeMap

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
すべての実装インタフェース:
Map
public class FixedSizeMap
extends AbstractMap

LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。

このクラスのマップは、決められたサイズの領域持ちます。 キーはコンストラクタで指定された マップのサイズに等しい個数しか、このマップに関連付けることはできません。 すでにマップのサイズに等しい個数のキーが関連付けられている状態で、 別の新しいキーを関連付けようとした場合、LRU アルゴリズムに従い 最も古くに使われたキーが削除され、全体のキー数がマップのサイズに 等しくなるように調整されます。
このオブジェクトは、Thread safe となっています。
このマップは LRU アルゴリズムにより動作するため、 マッピングの追加や更新をしたり、キーにマッピングされている値の取得を した時に、キーのアクセス順をチェックします。 したがって、マップのサイズが大きさに比例して put() や get() メソッドの レスポンス時間が長くなります。 このハッシュテーブルは、適度な大きさで利用することを推奨します。

導入されたバージョン:
version 5.0
関連項目:
Hashtable

入れ子クラスの概要
クラス java.util.Map から継承した入れ子クラス
Map.Entry
コンストラクタの概要
FixedSizeMap(int size)
指定されたサイズの領域を持つマップを構築します。
メソッドの概要
int | capacity() このマップに対してマップできるキーの最大個数を返します。
void | clear() マップからマッピングをすべて削除します。
boolean | containsKey(Object key) 指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
Set | entrySet() このマップに格納されているマッピングのセットビューを返します。
Object | get(Object key) マップが、指定されたキーにマッピングしている値を返します。
Object | put(Object key, Object value) 指定された値を、マップ内の指定されたキーに関連付けます 。
Object | remove(Object key) このキーにマッピングがある場合に、そのマッピングをマップから削除します。
クラス java.util.AbstractMap から継承したメソッド
clone, containsValue, equals, hashCode, isEmpty, keySet, putAll, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

FixedSizeMap

public FixedSizeMap(int size)
             throws IllegalArgumentException
指定されたサイズの領域を持つマップを構築します。

パラメータ:
size - ハッシュテーブルの容量
例外:
IllegalArgumentException - 容量が 1 より小さい場合
メソッドの詳細

capacity

public int capacity()
このマップに対してマップできるキーの最大個数を返します。 このメソッドの返す値は、コンストラクタで指定されたハッシュテーブルの 容量値をそのまま返すものです。

戻り値:
このマップにエントリできるキーの最大個数

clear

public void clear()
マップからマッピングをすべて削除します。

containsKey

public boolean containsKey(Object key)
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。

パラメータ:
key - このマップにあるかどうかを判定するキー
戻り値:
指定されたキーへのマッピングをこのマップが含む場合は true

entrySet

public Set entrySet()
このマップに格納されているマッピングのセットビューを返します。 このセットの各要素は Map.Entry です。セットはこのマップを 基にしているので、マップへの変更、およびセットへの変更は、 互いに反映されます。 セットでの繰り返し処理が進行中にマップが変更された場合、 反復の結果は保証されません。セットは要素の削除をサポートしており、 対応するエントリをマップから削除することができます。 削除には、Iterator.remove、Set.remove、removeAll、retainAll、 および clear オペレーションが使えます。 add または addAll オペレーションはサポートされません。

戻り値:
このマップに格納されているマッピングのセットビュー

get

public Object get(Object key)
マップが、指定されたキーにマッピングしている値を返します。 マップに、このキーに対するマッピングがない場合は null を返します。

パラメータ:
key - 関連付けられている値が返されるキー
戻り値:
マップが、指定されたキーにマッピングしている値。このキーに対するマッピングがマップにない場合は null
関連項目:
containsKey(Object)

put

public Object put(Object key,
                  Object value)
指定された値を、マップ内の指定されたキーに関連付けます 。 マップにすでにこのキーに対するマッピングがある場合、 古い値は置き換えられます。

パラメータ:
key - 指定された値が関連付けられるキー
value - 指定されたキーに関連付けられる値
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
例外:
NullPointerException - キーまたは値が null の場合

remove

public Object remove(Object key)
このキーにマッピングがある場合に、そのマッピングをマップから削除します。

パラメータ:
key - マッピングがマップから削除されるキー
戻り値:
指定されたキーに関連付けられていた以前の値。key にマッピングがなかった場合は null。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LocaleUtil (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス LocaleUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil
public class LocaleUtil
extends Object

ロケールユーティリティクラス。

ロケールに関する実用的な関数および定数値を提供するクラス。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static Locale toLocale(String locale)
ロケール文字列をロケールクラスに変換する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

toLocale

public static Locale toLocale(String locale)
ロケール文字列をロケールクラスに変換する。

ロケール文字列を解析し、ロケールクラスを生成して返却する。

パラメータ:
locale - ロケール文字列
例 ja_JP,en_US などロケールの文字列表現
戻り値:
ロケールクラス
ロケール文字列が空文字列、空白文字のみの文字列およびnullの場合はnullを返却する。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultiComparator (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス MultiComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
すべての実装インタフェース:
Comparator, DualComparator, Serializable
public class MultiComparator
extends AbstractDualComparator

複数のコンパレータを使用してソートを行うためにクラスです。
実行したコンパレータの compare() メソッドの戻り値が０でなくなるか、全てのコンパレータの実行が完了するまで下記の順番でコンパレータの実行が行われます。

・コンストラクタで指定された第１コンパレータ
・コンストラクタで指定された第２コンパレータ
・addComparator()で追加されたコンパレータ

このクラスは同じインスタンスのコンパレータを２つ以上持つことを想定されていません。 そのような操作を行うと、正しい結果が得られない可能性があります。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
MultiComparator(Comparator primaryComparator, Comparator secondaryComparator)
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
メソッドの概要
void | addComparator(Comparator comparator) 指定されたコンパレータ comparator を追加します。
Collection | getComparators() 設定されている全てのコンパレータを取得します。
Comparator | getPrimaryComparator() 第１コンパレータを返します。
Comparator | getSecondaryComparator() 第２コンパレータを返します。
boolean | removeComparator(Comparator comparator) 指定されたコンパレータ comparatorを削除します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator から継承したメソッド
compare
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

MultiComparator

public MultiComparator(Comparator primaryComparator,
                       Comparator secondaryComparator)
                throws NullPointerException
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
もし primaryComparator がnullで、 secondaryComparator がnullでない時は、secondaryComparator が第１コンパレータとして扱われます。
primaryComparator 、secondaryComparator がともにnullの時は例外を発生させます。

パラメータ:
primaryComparator - 第１コンパレータ
secondaryComparator - 第２コンパレータ
例外:
NullPointerException - primaryComparator 、 secondaryComparator がともにnullの時発生します。
メソッドの詳細

getPrimaryComparator

public Comparator getPrimaryComparator()
第１コンパレータを返します。

戻り値:
第１コンパレータ

getSecondaryComparator

public Comparator getSecondaryComparator()
第２コンパレータを返します。 このメソッドの戻り値は、設定された第２コンパレータをラップしたMultiComparatorのオブジェクトになります。 もし、第２コンパレータが設定されていないときはnullを返します。

戻り値:
第２コンパレータ

addComparator

public void addComparator(Comparator comparator)
                   throws NullPointerException
指定されたコンパレータ comparator を追加します。 指定されたコンパレータ comparatorがnullの時は例外を発生させます。

パラメータ:
comparator - コンパレータ
例外:
NullPointerException - 指定されたcomparatorがnullの時に発生します。

removeComparator

public boolean removeComparator(Comparator comparator)
                         throws IllegalArgumentException
指定されたコンパレータ comparatorを削除します。 指定されたコンパレータの削除に成功したときはtrue、失敗したときはfalseを返します。 このクラスのオブジェクトが持つ全てのコンパレータを削除しようとすると例外が発生します。

パラメータ:
comparator - 削除対象のコンパレータ
戻り値:
削除に成功したときはtrue、失敗したときはfalseを返す。
例外:
IllegalArgumentException - 全てのコンパレータを削除しようとした時に発生します。

getComparators

public Collection getComparators()
設定されている全てのコンパレータを取得します。

戻り値:
設定されている全てのコンパレータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.java.util (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.java.util
インタフェース
DualComparator
クラス
AbstractDualComparator
ExtendedProperties
FileResourceBundle
FilterComparator
FixedSizeMap
LocaleUtil
MultiComparator
PropertiesUtil
ResourceBundleProperties
ReverseComparator
SequenceComparator


jp.co.intra_mart.common.aid.jdk.java.util (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。

参照:
説明

インタフェースの概要
DualComparator ２つのコンパレータを使用してソートを行うためのインターフェースです。

クラスの概要
AbstractDualComparator | ２つのコンパレータを使用してソートを行うクラスです。
ExtendedProperties | java.util.Properties を、より便利に利用するためのインタフェースを提供します。
FileResourceBundle |
FilterComparator | コンパレータのフィルターとして機能する抽象クラスです。
FixedSizeMap | LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
LocaleUtil | ロケールユーティリティクラス。
MultiComparator | 複数のコンパレータを使用してソートを行うためにクラスです。
PropertiesUtil | java.util.Properties を、より便利に利用するためのインタフェースを提供します。
ResourceBundleProperties | このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ReverseComparator | コンパレータのフィルタとして機能します。
SequenceComparator | 挿入順にソートするためのコンパレータです。

パッケージ jp.co.intra_mart.common.aid.jdk.java.util の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.java.util クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.java.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil
    • class jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil
    • class java.util.ResourceBundle
      • class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
  • interface java.io.Serializable
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)


パッケージ jp.co.intra_mart.common.aid.jdk.java.util の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.java.util の使用

jp.co.intra_mart.common.aid.jdk.java.util を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.util により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
AbstractDualComparator
２つのコンパレータを使用してソートを行うクラスです。
DualComparator
２つのコンパレータを使用してソートを行うためのインターフェースです。
FilterComparator
コンパレータのフィルターとして機能する抽象クラスです。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
ExtendedProperties
java.util.Properties を、より便利に利用するためのインタフェースを提供します。

jp.co.intra_mart.common.aid.jdk.org.w3c.dom により使用される jp.co.intra_mart.common.aid.jdk.java.util のクラス
ExtendedProperties
java.util.Properties を、より便利に利用するためのインタフェースを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertiesUtil (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス PropertiesUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil
public class PropertiesUtil
extends Object

java.util.Properties を、より便利に利用するためのインタフェースを提供します。

導入されたバージョン:
version 5.0

メソッドの概要
static void store(Properties properties, OutputStream out, String header)
Properties テーブル内のプロパティリスト (キーと要素のペア) を、load メソッドを使って Properties テーブルにロードするのに適切なフォーマットで出力ストリームに書き込みます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

store

public static void store(Properties properties,
                         OutputStream out,
                         String header)
                  throws IOException
Properties テーブル内のプロパティリスト (キーと要素のペア) を、load メソッドを使って Properties テーブルにロードするのに適切なフォーマットで出力ストリームに書き込みます。

このメソッドは、 Properties.store(OutputStream, String) を 拡張したもので、出力内容は行単位で文字列ソートされます。

パラメータ:
properties - 出力元となる情報
out - 出力ストリーム
header - プロパティリストの記述
例外:
IOException - このプロパティリストを指定した出力ストリームに書き込んで、IOException がスローされた場合
ClassCastException - この Properties オブジェクトに、String ではないキーまたは値が格納されている場合
NullPointerException - out が null の場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ResourceBundleProperties (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ResourceBundleProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
public class ResourceBundleProperties
extends Properties

このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。プロパティデータは、java.util.ResourceBundle により取得されます。
ロードできるリソースに関しては、java.util.ResourceBundle の 説明を参照して下さい。
このクラスのコンストラクタが、java.util.ResourceBundle クラスの getBundle() メソッドと同様の機能を提供しています。 各コンストラクタは、引数の同じ getBundle() メソッドに対応しています。

導入されたバージョン:
version 5.0
関連項目:
Properties, ResourceBundle, 直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ResourceBundleProperties(String baseName)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String baseName, Locale locale, ClassLoader loader)
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
メソッドの概要
 Locale getLocale()
ResourceBundle の Locale を返します。
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceBundleProperties

public ResourceBundleProperties(String baseName)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
例外:
MissingResourceException - リソースの照合に失敗した場合

ResourceBundleProperties

public ResourceBundleProperties(String baseName,
                                Locale locale,
                                ClassLoader loader)
                         throws MissingResourceException
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。

パラメータ:
baseName - 目的のオブジェクトを含むリソースバンドルのファミリ名
locale - 目的のロケール
loader - リソースをロードする ClassLoader
例外:
MissingResourceException - リソースの照合に失敗した場合
メソッドの詳細

getLocale

public Locale getLocale()
ResourceBundle の Locale を返します。
この関数は、このオブジェクトが本当に要求されたロケールに対応しているか、 またはフォールバックであるかを判定するために、このオブジェクトが 構築されたあとで使用できます。

この関数は、java.util.ResourceBundle クラスの getLocale() と 同じであり、java.util.ResourceBundle クラスとインターフェースを 合わせるために提供されています。 java.util.ResourceBundle クラスの getLocale() の説明を参照して下さい。

戻り値:
ロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReverseComparator (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス ReverseComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator
        拡張 jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
すべての実装インタフェース:
Comparator, Serializable
public class ReverseComparator
extends FilterComparator

コンパレータのフィルタとして機能します。
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ReverseComparator(Comparator comparator)
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator から継承したメソッド
getParentComparator
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

ReverseComparator

public ReverseComparator(Comparator comparator)
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。

パラメータ:
comparator - フィルター対象のコンパレータ
メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。

定義:
インタフェース Comparator 内の compare
オーバーライド:
クラス FilterComparator 内の compare
パラメータ:
arg0 - 引数１
arg1 - 引数２
戻り値:
フィルタ対象のコンパレータの compare() メソッドの結果を反転させた値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SequenceComparator (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.java.util
クラス SequenceComparator

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator
すべての実装インタフェース:
Comparator, Serializable
public class SequenceComparator
extends Object
implements Comparator, Serializable

挿入順にソートするためのコンパレータです。
このコンパレータは挿入が早い物から遅い物の順に並べます。
このコンパレータは、挿入されたオブジェクトの順番をインスタンス変数として持っています。 そのため、複数のオブジェクトでこのコンパレータを共有使用すると正しく動作しない可能性があります。
またこのクラスは、java.lang.TreeSet、java.lang.TreeMapで使用されることを想定して作られています。 そのため、他のクラスのコンパレータとして使用すると正しく動作しない可能性があります。 クラスで管理できるオブジェクトの数は、２の３１乗-１までのみ管理できます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
SequenceComparator()
新しいオブジェクトを生成します。
メソッドの概要
 int compare(Object arg0, Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース java.util.Comparator から継承したメソッド
equals

コンストラクタの詳細

SequenceComparator

public SequenceComparator()
新しいオブジェクトを生成します。

メソッドの詳細

compare

public int compare(Object arg0,
                   Object arg1)
順序付けのために ２ つの引数を比較するメソッドです。
最初の引数が ２ 番目の引数より小さ い場合は負の整数、両方が等しい場合は 0、最初の引数が 2 番目の引 数より大きい場合は正の整数を返します。
このメソッドの目的は、挿入順にソートすることです。 引数１と引数２を比較したとき、引数１の方が挿入が遅いときは正の数、早い時は負の数を返します。
引数１と引数２が同じインスタンスの時は０を返します

定義:
インタフェース Comparator 内の compare
パラメータ:
arg0 - 引き数１
arg1 - 引き数２
戻り値:
比較した結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の使用

jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo の使用

DOMInfo を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での DOMInfo の使用

DOMInfo を実装している jp.co.intra_mart.common.aid.jdk.javax.xml のクラス
 class DOMBuilder
XML解析クラス。

DOMInfo を返す jp.co.intra_mart.common.aid.jdk.javax.xml のメソッド
static DOMInfo | DOMBuilder.newDocument(String elementName) DOMを新規に作成します。
static DOMInfo | DOMBuilder.newDocument(String elementName, EntityResolver resolver) DOMを新規に作成します。
static DOMInfo | DOMBuilder.newDocument(String elementName, String publicId, String systemId) DOMを新規に作成します。
static DOMInfo | DOMBuilder.newDocument(String elementName, String publicId, String systemId, EntityResolver resolver) DOMを新規に作成します。
static DOMInfo | DOMBuilder.newInstance(Document doc) ドキュメントからDOM情報を取得します。
static DOMInfo | DOMBuilder.newInstance(String path) ファイルからXMLを解析してDOM情報を作成します。
static DOMInfo | DOMBuilder.newInstance(String path, EntityResolver resolver) ファイルからXMLを解析してDOM情報を作成します。
static DOMInfo | DOMBuilder.newInstance(File file) ファイルクラスからXMLを解析してDOM情報を作成します。
static DOMInfo | DOMBuilder.newInstance(File file, EntityResolver resolver) ファイルクラスからXMLを解析してDOM情報を作成します。
static DOMInfo | DOMBuilder.newInstance(InputStream stream) ストリームからXMLを解析してDOM情報を作成します。
static DOMInfo | DOMBuilder.newInstance(InputStream stream, EntityResolver resolver) ストリームからXMLを解析してDOM情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode の使用

XmlNode を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での XmlNode の使用

XmlNode を返す jp.co.intra_mart.common.aid.jdk.javax.xml のメソッド
XmlNode | XmlNode.addAttr(String name, String value) 属性を追加します。
XmlNode | XmlNode.addNode(String name) エレメントを追加します。
XmlNode | XmlNode.addNode(String name, String targetPath) 相対パスのノードにエレメントを追加します。
XmlNode | XmlNode.delAttr(String name) 属性を削除します。
XmlNode | XmlNode.delNode() このノードを削除します。
XmlNode | XmlNode.delNode(String targetPath) 相対パスのノードを削除します。
XmlNode | XmlNode.delNode(XmlNode child) ノードを削除します。
XmlNode[] | XmlNode.getChildNode() 属性および子ノードの一覧を取得します。
XmlNode[] | XmlNode.getNodeList() 下階層からすべてのノードを取得します。
XmlNode | XmlNode.lookup(String tags) 子ノードを取得します。
XmlNode | XmlNode.lookup(List tags) 子ノードを取得します。
XmlNode[] | XmlNode.select(String tags) このノードの子ノードのリストを取得します。

XmlNode 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.javax.xml のメソッド
 XmlNode XmlNode.delNode(XmlNode child)
ノードを削除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DOMBuilder (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.javax.xml
クラス DOMBuilder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder
すべての実装インタフェース:
DOMInfo
public class DOMBuilder
extends Object
implements DOMInfo

XML解析クラス。

様々なストリームからXMLを解析することができる。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
protected | DOMBuilder()
protected | DOMBuilder(Document doc)
メソッドの概要
Document | getDocumet() ドキュメントノードの取得。
Node | getRootNode() ルートノードの取得。
static DOMInfo | newDocument(String elementName) DOMを新規に作成します。
static DOMInfo | newDocument(String elementName, EntityResolver resolver) DOMを新規に作成します。
static DOMInfo | newDocument(String elementName, String publicId, String systemId) DOMを新規に作成します。
static DOMInfo | newDocument(String elementName, String publicId, String systemId, EntityResolver resolver) DOMを新規に作成します。
static DOMInfo | newInstance(Document doc) ドキュメントからDOM情報を取得します。
static DOMInfo | newInstance(File file) ファイルクラスからXMLを解析してDOM情報を作成します。
static DOMInfo | newInstance(File file, EntityResolver resolver) ファイルクラスからXMLを解析してDOM情報を作成します。
static DOMInfo | newInstance(InputStream stream) ストリームからXMLを解析してDOM情報を作成します。
static DOMInfo | newInstance(InputStream stream, EntityResolver resolver) ストリームからXMLを解析してDOM情報を作成します。
static DOMInfo | newInstance(String path) ファイルからXMLを解析してDOM情報を作成します。
static DOMInfo | newInstance(String path, EntityResolver resolver) ファイルからXMLを解析してDOM情報を作成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DOMBuilder

protected DOMBuilder()

DOMBuilder

protected DOMBuilder(Document doc)
メソッドの詳細

newDocument

public static DOMInfo newDocument(String elementName)
                           throws IOException,
                                  SAXException
DOMを新規に作成します。

ルートノードの名前を指定して、新規にDOMを作成します。

パラメータ:
elementName - ルートノードの名前
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newDocument

public static DOMInfo newDocument(String elementName,
                                  EntityResolver resolver)
                           throws IOException,
                                  SAXException
DOMを新規に作成します。

ルートノードの名前およびエンティティリゾルバを指定して、新規にDOMを作成します。

パラメータ:
elementName - ルートノードの名前
resolver - エンティティリゾルバ
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newDocument

public static DOMInfo newDocument(String elementName,
                                  String publicId,
                                  String systemId)
                           throws IOException,
                                  SAXException
DOMを新規に作成します。

ルートノードの名前,パブリックID,システムIDを指定して、新規にDOMを作成します。

パラメータ:
elementName - ルートノードの名前
publicId - パブリックID
systemId - システムID
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newDocument

public static DOMInfo newDocument(String elementName,
                                  String publicId,
                                  String systemId,
                                  EntityResolver resolver)
                           throws IOException,
                                  SAXException
DOMを新規に作成します。

ルートノードの名前,パブリックID,システムIDおよびエンティティリゾルバを指定して、新規にDOMを作成します。

パラメータ:
elementName - ルートノードの名前
publicId - パブリックID
systemId - システムID
resolver - エンティティリゾルバ
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newInstance

public static DOMInfo newInstance(Document doc)
ドキュメントからDOM情報を取得します。

引数のドキュメントからDOM情報を作成します。

パラメータ:
doc - ドキュメントノード
戻り値:
作成されたDOM情報

newInstance

public static DOMInfo newInstance(String path)
                           throws IOException,
                                  SAXException
ファイルからXMLを解析してDOM情報を作成します。

引数のファイルからXMLを解析してDOM情報を作成します。

パラメータ:
path - 解析を行うXMLファイルののフルパス
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newInstance

public static DOMInfo newInstance(String path,
                                  EntityResolver resolver)
                           throws IOException,
                                  SAXException
ファイルからXMLを解析してDOM情報を作成します。

引数のファイルからXMLを解析してDOM情報を作成します。
エンティティリゾルバでDTDの検証を行います。

パラメータ:
path - 解析を行うXMLファイルののフルパス
resolver - エンティティリゾルバ
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newInstance

public static DOMInfo newInstance(File file)
                           throws IOException,
                                  SAXException
ファイルクラスからXMLを解析してDOM情報を作成します。

引数のファイルクラスからXMLを解析してDOM情報を作成します。

パラメータ:
file - ファイルクラス
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newInstance

public static DOMInfo newInstance(File file,
                                  EntityResolver resolver)
                           throws IOException,
                                  SAXException
ファイルクラスからXMLを解析してDOM情報を作成します。

引数のファイルクラスからXMLを解析してDOM情報を作成します。
エンティティリゾルバでDTDの検証を行います。

パラメータ:
file - ファイルクラス
resolver - エンティティリゾルバ
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newInstance

public static DOMInfo newInstance(InputStream stream)
                           throws IOException,
                                  SAXException
ストリームからXMLを解析してDOM情報を作成します。

引数のストリームからXMLを解析してDOM情報を作成します。

パラメータ:
stream - ストリーム
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

newInstance

public static DOMInfo newInstance(InputStream stream,
                                  EntityResolver resolver)
                           throws IOException,
                                  SAXException
ストリームからXMLを解析してDOM情報を作成します。

引数のストリームからXMLを解析してDOM情報を作成します。
エンティティリゾルバでDTDの検証を行います。

パラメータ:
stream - ストリーム
resolver - エンティティリゾルバ
戻り値:
作成されたDOM情報
例外:
IOException
SAXException

getDocumet

public Document getDocumet()
ドキュメントノードの取得。

ドキュメントノードを取得します。

定義:
インタフェース DOMInfo 内の getDocumet
戻り値:
ドキュメントノード
関連項目:
DOMInfo.getDocumet()

getRootNode

public Node getRootNode()
ルートノードの取得。

ルートのノードを取得します。

定義:
インタフェース DOMInfo 内の getRootNode
戻り値:
ルートノード
ルートノードが存在しない場合は、null
関連項目:
DOMInfo.getRootNode()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


DOMInfo (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.javax.xml
インタフェース DOMInfo

既知の実装クラスの一覧:
DOMBuilder
public interface DOMInfo

DOM情報インタフェース。

DOMのドキュメント、ルートノードを取得するためのインターフェース

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
Document | getDocumet() ドキュメントノードの取得。
Node | getRootNode() ルートノードの取得。

メソッドの詳細

getDocumet

public Document getDocumet()
ドキュメントノードの取得。

ドキュメントノードを取得します。

戻り値:
ドキュメントノード

getRootNode

public Node getRootNode()
ルートノードの取得。

ルートのノードを取得します。

戻り値:
ルートノード
存在しない場合はnull
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.javax.xml (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.javax.xml
インタフェース
DOMInfo
クラス
DOMBuilder
XmlNode
XMLProperties


jp.co.intra_mart.common.aid.jdk.javax.xml (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

参照:
説明

インタフェースの概要
DOMInfo DOM情報インタフェース。

クラスの概要
DOMBuilder | XML解析クラス。
XmlNode | DOMノード操作クラス。
XMLProperties | XML をベースとした不変のプロパティセットを表します。

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の説明

このパッケージには、ＸＭＬを利用するためのクラスが含まれています。


jp.co.intra_mart.common.aid.jdk.javax.xml クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
    • class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder (implements jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo)
    • class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo


パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml の使用

jp.co.intra_mart.common.aid.jdk.javax.xml を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.javax.xml のクラス
DOMInfo
DOM情報インタフェース。
XmlNode
DOMノード操作クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


XmlNode (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.javax.xml
クラス XmlNode

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode
public class XmlNode
extends Object

DOMノード操作クラス。

DOMノードを操作するユーティリティクラス。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
XmlNode(Attr attr)
コンストラクタ。
XmlNode(Document document)
コンストラクタ。
XmlNode(Element element)
コンストラクタ。
XmlNode(Node node)
コンストラクタ。
XmlNode(Node parent, Node node)
コンストラクタ。
メソッドの概要
XmlNode | addAttr(String name, String value) 属性を追加します。
XmlNode | addNode(String name) エレメントを追加します。
XmlNode | addNode(String name, String targetPath) 相対パスのノードにエレメントを追加します。
XmlNode | delAttr(String name) 属性を削除します。
XmlNode | delNode() このノードを削除します。
XmlNode | delNode(String targetPath) 相対パスのノードを削除します。
XmlNode | delNode(XmlNode child) ノードを削除します。
XmlNode[] | getChildNode() 属性および子ノードの一覧を取得します。
double | getDouble(String name) 子ノードの値を数値として取得します。
double | getDouble(String name, double def) 子ノードの値を数値として取得します。
float | getFloat(String name) 子ノードの値を数値として取得します。
float | getFloat(String name, float def) 子ノードの値を数値として取得します。
int | getInteger(String name) 子ノードの値を数値として取得します。
int | getInteger(String name, int def) 子ノードの値を数値として取得します。
long | getLong(String name) 子ノードの値を数値として取得します。
long | getLong(String name, long def) 子ノードの値を数値として取得します。
Node | getNode() このノードのDOMノードオブジェクトを取得します。
XmlNode[] | getNodeList() 下階層からすべてのノードを取得します。
String | getNodeName() ノードの名前を取得します。
String | getString(String name) 子ノードの値を文字列として取得します。
String | getString(String name, String def) 子ノードの値を文字列として取得します。
String | getURI() このノードのフルパスを取得します。
String | getURI(String root) このノードのフルパスを取得します。
String | getValue() このノードの値を文字列として取得します。
String | getValue(String def) このノードの値を文字列として取得します。
boolean | isFalse(String name) 子ノードの値が偽値であるかチェックします。
boolean | isTrue(String name) 子ノードの値が真値であるかチェックします。
boolean | isValid(String name) 子ノードの存在をチェックします。
XmlNode | lookup(List tags) 子ノードを取得します。
XmlNode | lookup(String tags) 子ノードを取得します。
void | removeValue() このノードの値を削除します。
XmlNode[] | select(String tags) このノードの子ノードのリストを取得します。
void | setNodeName(String name) このノードの名前を変更します。
void | setValue(String str) このノードの値を設定します。
void | setValue(String targetPath, String str) このノードの子ノードの値を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XmlNode

public XmlNode(Attr attr)
コンストラクタ。

属性ノードからインスタンスを生成します。

パラメータ:
attr - 属性ノード

XmlNode

public XmlNode(Document document)
コンストラクタ。

ドキュメントノードからインスタンスを生成します。

パラメータ:
document - ドキュメントノード

XmlNode

public XmlNode(Element element)
コンストラクタ。

エレメントノードからインスタンスを生成します。

パラメータ:
element - エレメントノード

XmlNode

public XmlNode(Node node)
コンストラクタ。

ノードからインスタンスを生成します。

パラメータ:
node - ノード

XmlNode

public XmlNode(Node parent,
               Node node)
コンストラクタ。

親ノードとノードからインスタンスを生成します。

パラメータ:
parent - 親ノード
node - ノード
メソッドの詳細

addAttr

public XmlNode addAttr(String name,
                       String value)
属性を追加します。

このノードに属性を追加します。
ノードに属性が既にある場合は、上書きされます。
ノードがエレメントでない場合は、追加されません。

パラメータ:
name - 属性名
value - 値
戻り値:
追加および変更された属性のXmlNode
追加できなかった場合はnull

addNode

public XmlNode addNode(String name)
エレメントを追加します。

このノードにエレメントを追加します。
このノードがドキュメントまたはエレメントである場合に、エレメントを追加します。

パラメータ:
name - 追加するエレメント名
戻り値:
追加されたエレメントのXmlNode
追加できなかった場合はnull

addNode

public XmlNode addNode(String name,
                       String targetPath)
相対パスのノードにエレメントを追加します。

相対パスのノードがドキュメントまたはエレメントである場合に、エレメントを追加します。

パラメータ:
name - 追加するエレメント名
targetPath - 相対パス
戻り値:
追加されたエレメントのXmlNode
追加できなかった場合はnull

delAttr

public XmlNode delAttr(String name)
属性を削除します。

このノードの属性を削除します。

パラメータ:
name - 属性名
戻り値:
削除された属性のXmlNode
削除できなかった場合はnull

delNode

public XmlNode delNode()
このノードを削除します。

戻り値:
削除できた場合はこのノードのXmlNode
削除できなかった場合はnull

delNode

public XmlNode delNode(String targetPath)
相対パスのノードを削除します。

相対パスのノードが存在する場合、そのノードを削除します。

パラメータ:
targetPath - 相対パス
戻り値:
削除されたノードのXmlNode
削除できなかった場合はnull

delNode

public XmlNode delNode(XmlNode child)
ノードを削除します。

パラメータ:
child - 削除するノード
戻り値:
削除されたノードのXmlNode
削除できなかった場合はnull

getChildNode

public XmlNode[] getChildNode()
属性および子ノードの一覧を取得します。

属性および子ノードの一覧を取得します。

戻り値:
属性および子ノードの配列 (XmlNode)

getDouble

public double getDouble(String name)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
戻り値:
浮動小数点数として返します。
値を正しく数値に変換できなかった場合には、“0”(ZERO)を 返します。

getDouble

public double getDouble(String name,
                        double def)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
def - 初期値
戻り値:
浮動小数点数として返します。
値を正しく数値に変換できなかった場合には、引数の初期値を返します。

getFloat

public float getFloat(String name)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
戻り値:
浮動小数点数として返します。
値を正しく数値に変換できなかった場合には、“0”(ZERO)を 返します。

getFloat

public float getFloat(String name,
                      float def)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
def - 初期値
戻り値:
浮動小数点数として返します。
値を正しく数値に変換できなかった場合には、引数の初期値を返します。

getInteger

public int getInteger(String name)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
戻り値:
整数として返します。
値を正しく数値に変換できなかった場合には、“0”(ZERO)を 返します。

getInteger

public int getInteger(String name,
                      int def)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
def - 初期値
戻り値:
整数として返します。
値を正しく数値に変換できなかった場合には、引数の初期値を返します。

getLong

public long getLong(String name)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
戻り値:
整数として返します。
値を正しく数値に変換できなかった場合には、“0”(ZERO)を 返します。

getLong

public long getLong(String name,
                    long def)
子ノードの値を数値として取得します。

このノードの子ノードの値を数値として取得します。

パラメータ:
name - 子ノードの名前
def - 初期値
戻り値:
整数として返します。
値を正しく数値に変換できなかった場合には、引数の初期値を返します。

getNode

public Node getNode()
このノードのDOMノードオブジェクトを取得します。

戻り値:
DOMノードオブジェクト

getNodeList

public XmlNode[] getNodeList()
下階層からすべてのノードを取得します。

戻り値:
下階層のすべてのノードリスト

getNodeName

public String getNodeName()
ノードの名前を取得します。

戻り値:
ノードの名前

getString

public String getString(String name)
子ノードの値を文字列として取得します。

このノードの子ノードの値を文字列として取得します。

パラメータ:
name - 子ノードの名前
戻り値:
文字列として返します。
値が存在しなかった場合には、null を返します。

getString

public String getString(String name,
                        String def)
子ノードの値を文字列として取得します。

このノードの子ノードの値を文字列として取得します。

パラメータ:
name - 子ノードの名前
def - 初期値
戻り値:
文字列として返します。
値が存在しなかった場合には、初期値を返します。

getURI

public String getURI()
このノードのフルパスを取得します。

このノードのフルパス '/'でつないだパスを取得します。

戻り値:
ノードのフルパス。

getURI

public String getURI(String root)
このノードのフルパスを取得します。

引数で指定したノードからのフルパス '/'でつないだパスを取得します。

パラメータ:
root -
戻り値:
引数で指定したノードからのフルパス。

getValue

public String getValue()
このノードの値を文字列として取得します。

このノードの値を文字列として取得します。

戻り値:
文字列として返します。
値が存在しなかった場合には、nullを返します。

getValue

public String getValue(String def)
このノードの値を文字列として取得します。

このノードの値を文字列として取得します。

パラメータ:
def - 初期値
戻り値:
文字列として返します。
値が存在しなかった場合には、初期値を返します。

isFalse

public boolean isFalse(String name)
子ノードの値が偽値であるかチェックします。

設定データが偽値である条件は以下の通り。
値が、“OFF”または“FALSE”の場合。 大文字・小文字の区別なし。
指定項目が未定義の場合には偽値を返します。

パラメータ:
name - 子ノードの名前
戻り値:
true：設定データは偽値である false：設定データは真値である。

isTrue

public boolean isTrue(String name)
子ノードの値が真値であるかチェックします。

設定データが真値である条件は以下の通り。
値が、“ON”または“TRUE”の場合。 大文字・小文字の区別なし。
指定項目が未定義の場合には偽値を返します。

パラメータ:
name - 子ノードの名前
戻り値:
true：設定データは真値である false：設定データは偽値である。

isValid

public boolean isValid(String name)
子ノードの存在をチェックします。

パラメータ:
name - 子ノードの名前
戻り値:
true：子ノードが存在する false：子ノードが存在しない。

lookup

public XmlNode lookup(String tags)
子ノードを取得します。

パラメータ:
tags - 子ノードのパス
戻り値:
子ノードのXmlNode。
存在しない場合は null。

lookup

public XmlNode lookup(List tags)
子ノードを取得します。

パラメータ:
tags - 子ノードのパスのリスト
戻り値:
子ノードのXmlNode。
存在しない場合は null。

removeValue

public void removeValue()
このノードの値を削除します。
値がない場合は、処理を行いません。

select

public XmlNode[] select(String tags)
このノードの子ノードのリストを取得します。

引数で指定したパスの子ノードのリストを取得します。

パラメータ:
tags - ノードのパス
戻り値:
子ノードの配列。
子ノードが存在しなかった場合には、空の配列を返します。

setNodeName

public void setNodeName(String name)
このノードの名前を変更します。

パラメータ:
name - 変更する名前

setValue

public void setValue(String str)
このノードの値を設定します。

パラメータ:
str - 設定する値。

setValue

public void setValue(String targetPath,
                     String str)
このノードの子ノードの値を設定します。

パラメータ:
targetPath - 子ノードのパス
str - 設定する値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


XMLProperties (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.javax.xml
クラス XMLProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
                    拡張 jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
                        拡張 jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
public class XMLProperties
extends ElementProperties

XML をベースとした不変のプロパティセットを表します。 このクラスは、XML を元データとして、Properties として 利用できるインタフェースを提供します。

読み込んだ XML ソースは、DocumentBuilderFactory が 返すパーサを利用して解析します。 XML で記述された各情報に対しては、XPath 形式の文字列をプロパティ名として Properties.getProperty(java.lang.String) により アクセスできます。

プロパティ名の例

  • /root/elm1 ・・・タグに挟まれた文字列情報
  • /root/elm1/@attr ・・・タグの属性
  • /root/elm1/text() ・・・タグに挟まれた文字列情報を連結したもの
  • /root/elm1/comment() ・・・コメントを連結したもの

上記以外の XPath 構文は、解釈できません。 また、.. や // 等を用いた相対指定もできません。

取得できる値は、テキストノードおよび属性(attribute)ノードの値のみです。 コメントノード等の値は取得できません。

バージョン:
Version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
XMLProperties(File f)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource in)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource in, Properties parent)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream in)
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream in, Properties parent)
指定データを持つ新しいプロパティセットを作成します。
メソッドの概要
 Document getDocument()
設定ファイルのドキュメントノードを返します。
クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties から継承したメソッド
getElement, getProperties
クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties から継承したメソッド
doubleValue, doubleValue, floatValue, floatValue, intValue, intValue, isFalse, isTrue, longValue, longValue, parseInt, parseLong
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

XMLProperties

public XMLProperties(File f)
              throws FileNotFoundException,
                     ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
f - 設定ファイル（xml）のパス
例外:
FileNotFoundException - ファイルがな場合。またはファイルにアクセスできない場合。
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputStream in)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputSource in)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputStream in,
                     Properties parent)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
parent - 基礎データ
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー

XMLProperties

public XMLProperties(InputSource in,
                     Properties parent)
              throws ParserConfigurationException,
                     SAXException,
                     IOException
指定データを持つ新しいプロパティセットを作成します。

パラメータ:
in - XML ソースを入力するストリーム
parent - 基礎データ
例外:
IOException - 入出力エラー
SAXException - XML の解析エラー
ParserConfigurationException - XML の解析エラー
メソッドの詳細

getDocument

public Document getDocument()
設定ファイルのドキュメントノードを返します。

戻り値:
ドキュメントノード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties の使用

ElementProperties を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml での ElementProperties の使用

jp.co.intra_mart.common.aid.jdk.javax.xml での ElementProperties のサブクラス
 class XMLProperties
XML をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ElementProperties (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.org.w3c.dom
クラス ElementProperties

java.lang.Object
    拡張 java.util.Dictionary
        拡張 java.util.Hashtable
            拡張 java.util.Properties
                拡張 jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
                    拡張 jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
すべての実装インタフェース:
Cloneable, Map, Serializable
直系の既知のサブクラス:
XMLProperties
public class ElementProperties
extends ExtendedProperties

DOM をベースとした不変のプロパティセットを表します。 このクラスは、DOM を元データとして、Properties として 利用できるインタフェースを提供します。

DOM の各情報に対しては、XPath 形式の文字列をプロパティ名として Properties.getProperty(java.lang.String) により アクセスできます。

プロパティ名の例

  • /root/elm1 ・・・タグに挟まれた文字列情報
  • /root/elm1/@attr ・・・タグの属性
  • /root/elm1/text() ・・・タグに挟まれた文字列情報を連結したもの
  • /root/elm1/comment() ・・・コメントを連結したもの

上記以外の XPath 構文は、解釈できません。 また、.. や // 等を用いた相対指定もできません。

取得できる値は、テキストノードおよび属性(attribute)ノードの値のみです。 コメントノード等の値は取得できません。

バージョン:
Version 5.0
関連項目:
直列化された形式

フィールドの概要
クラス java.util.Properties から継承したフィールド
defaults
コンストラクタの概要
ElementProperties(Element element)
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element element, Properties parent)
指定のエレメントの情報をプロパティズ化します。
メソッドの概要
Element | getElement() 現在のプロパティズの元となったエレメントノードを返します。
String[] | getProperties(String key) 指定のキーにマップされた値のリストを返します。
クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties から継承したメソッド
doubleValue, doubleValue, floatValue, floatValue, intValue, intValue, isFalse, isTrue, longValue, longValue, parseInt, parseLong
クラス java.util.Properties から継承したメソッド
getProperty, getProperty, list, list, load, propertyNames, save, setProperty, store
クラス java.util.Hashtable から継承したメソッド
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ElementProperties

public ElementProperties(Element element)
指定のエレメントの情報をプロパティズ化します。

パラメータ:
element - プロパティズ化するエレメントノード

ElementProperties

public ElementProperties(Element element,
                         Properties parent)
指定のエレメントの情報をプロパティズ化します。

パラメータ:
element - プロパティズ化するエレメントノード
parent - 基礎データ
メソッドの詳細

getElement

public Element getElement()
現在のプロパティズの元となったエレメントノードを返します。

戻り値:
エレメントノード

getProperties

public String[] getProperties(String key)
指定のキーにマップされた値のリストを返します。
XML 中で同名のタグが連続している場合など、タグや属性から生成された キー名称が同一のもののすべてを返します。

パラメータ:
key - キー
戻り値:
キーにマップされた値の配列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.org.w3c.dom (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.org.w3c.dom
クラス
ElementProperties


jp.co.intra_mart.common.aid.jdk.org.w3c.dom (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

このパッケージには、ＤＯＭを利用するためのクラスが含まれています。

参照:
説明

クラスの概要
ElementProperties DOM をベースとした不変のプロパティセットを表します。

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の説明

このパッケージには、ＤＯＭを利用するためのクラスが含まれています。


jp.co.intra_mart.common.aid.jdk.org.w3c.dom クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties


パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.org.w3c.dom の使用

jp.co.intra_mart.common.aid.jdk.org.w3c.dom を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.javax.xml このパッケージには、ＸＭＬを利用するためのクラスが含まれています。

jp.co.intra_mart.common.aid.jdk.javax.xml により使用される jp.co.intra_mart.common.aid.jdk.org.w3c.dom のクラス
ElementProperties
DOM をベースとした不変のプロパティセットを表します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter の使用

jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder の使用

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder の使用

CharacterMappingBuilder を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での CharacterMappingBuilder の使用

CharacterMappingBuilder を返す jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
static CharacterMappingBuilder CharacterMappingBuilder.instance()
ビルダを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の使用

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException の使用

ResourceFormatException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceFormatException の使用

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
static CharacterMappingBuilder | CharacterMappingBuilder.instance() ビルダを返します。
char[] | CharacterMappingBuilder.getMapping(String enc) 文字の修正用マッピングを返します。
protected void | CharacterEncoder.setCharacterEncoding(String enc) このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceFormatException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException の使用

ResourceNotFoundException を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset での ResourceNotFoundException の使用

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のメソッド
static CharacterMappingBuilder | CharacterMappingBuilder.instance() ビルダを返します。
char[] | CharacterMappingBuilder.getMapping(String enc) 文字の修正用マッピングを返します。
protected void | CharacterEncoder.setCharacterEncoding(String enc) このオブジェクトが対象とする文字エンコーディングを設定します。

ResourceNotFoundException をスローする jp.co.intra_mart.common.aid.jdk.util.charset のコンストラクタ
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AdvancedOutputStreamWriter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス AdvancedOutputStreamWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 java.io.FilterWriter
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
public class AdvancedOutputStreamWriter
extends FilterWriter

このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。

通常、ASCII の範囲に含まれない文字は、java.io.OutputStreamWriter を 利用して相互に文字コード変換した場合、各文字エンコーディングの Unicode に対するマッピングの相違により、本来その文字エンコーディングにおいて 存在する文字であってもコード不明を意味する「?」に置き換えられてしまう ことがあります。 いわゆる、この文字化けに対して、文字コード変換前に、 対象となる文字エンコーディングに対する Unicode の正しい文字に 置換することで、いくつかの文字については正しく文字コード変換することが できます。
このクラスでは、この方式により文字化けを回避します。

文字化けに対する文字のマッピングおよび対応する文字エンコーディングに 関しては、jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder クラスの仕様に準じます。

導入されたバージョン:
version 5.0
関連項目:
jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder

フィールドの概要
クラス java.io.FilterWriter から継承したフィールド
out
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
AdvancedOutputStreamWriter(OutputStream out)
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, Charset cs)
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, CharsetEncoder enc)
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream out, String charsetName)
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter writer)
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
メソッドの概要
String | getCharacterEncoding() このオブジェクトが対象としている文字エンコーディング名を返します。
OutputStreamWriter | getOutputStreamWriter() このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
void | write(char[] cbuf, int off, int len) 文字の配列の一部を書き込みます。
void | write(int c) 単一の文字を書き込みます。
void | write(String str, int off, int len) 文字列の一部を書き込みます。
クラス java.io.FilterWriter から継承したメソッド
close, flush
クラス java.io.Writer から継承したメソッド
write, write
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  String charsetName)
                           throws UnsupportedEncodingException,
                                  ResourceNotFoundException,
                                  ResourceFormatException,
                                  IOException
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
charsetName - サポートされる charset の名前
例外:
UnsupportedEncodingException - 指定された文字エンコーディングがサポートされていない場合
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out)
                           throws ResourceFormatException,
                                  ResourceNotFoundException,
                                  IOException
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  Charset cs)
                           throws IOException,
                                  ResourceFormatException,
                                  ResourceNotFoundException
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
cs - サポートされる Charset
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 入出力エラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStream out,
                                  CharsetEncoder enc)
                           throws ResourceFormatException,
                                  IOException,
                                  ResourceNotFoundException
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。

パラメータ:
out - 基礎となる出力ストリーム
enc - 文字エンコーディングエンコーダ
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
IOException - 設定の読み込みエラー
ResourceFormatException - 設定に不整合がある場合

AdvancedOutputStreamWriter

public AdvancedOutputStreamWriter(OutputStreamWriter writer)
                           throws ResourceNotFoundException,
                                  IOException,
                                  ResourceFormatException
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。

なお、このオブジェクトが対応する文字エンコーディングは、 java.io.OutputStreamWriter#getEncoding() の返す値によって 決定します。 java.io.OutputStreamWriter#getEncoding() が null を返す場合、 このコンストラクタは NUllPointerException をスローして オブジェクトの作成に失敗します。

パラメータ:
writer - 基本となるストリームを提供する java.io.OutputStreamWriter オブジェクト
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 対象となる文字エンコーディングに対応する設定がない場合
ResourceFormatException - 設定に不整合がある場合
IOException - 設定の読み込みエラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
文字の配列の一部を書き込みます。

パラメータ:
cbuf - 書き込む文字のバッファ
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

write

public void write(int c)
           throws IOException
単一の文字を書き込みます。

パラメータ:
c - 書き込む文字を指定する int
例外:
IOException - 入出力エラーが発生した場合

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
文字列の一部を書き込みます。

パラメータ:
str - 書き込まれる文字列
off - 文字の読み込み開始オフセット
len - 書き込む文字数
例外:
IOException - 入出力エラーが発生した場合

getOutputStreamWriter

public OutputStreamWriter getOutputStreamWriter()
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。

戻り値:
基礎となっている java.io.OutputStreamWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CharacterEncoder (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterEncoder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
public class CharacterEncoder
extends Object

このクラスは、文字エンコードの機能を提供します。

このクラスは、Java runtime が提供する通常の文字コード変換において 文字のマッピング定義の相違に起因して文字化けしてしまう現象を解決するための 一つの方法となります。 実際には、定義ファイルに設定されている文字をネイティブコードへ変換する前に 他の文字へ変更する事により、文字化けを防ぎます。

例えば、EUC_JP における文字「～」は、 Unicode へ変換した際 0x301C(Wave Dash) にマッピングされます。 これに対して、SJIS では文字「～」は、 Unicode の 0xFF5E(Fullwidth Tilde) にマッピングされています。 このため、相互に文字コード変換をすると、 文字「?」に置き換わると言う現象(いわゆる文字化け)が発生します。
このクラスでは、Unicode から SJIS へ変換する際に Unicode の文字 0x301C(Wave Dash) を 0xFF5E(Fullwidth Tilde) へ変更してから 文字コード変換を行います。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version 5.0

コンストラクタの概要
CharacterEncoder(String enc)
文字コード変換のためのエンコーダを作成します。
メソッドの概要
byte[] | encode(char c) 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(char[] c) 指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。
byte[] | encode(String str) 指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。
String | getCharacterEncoding() このオブジェクトが対象としている文字エンコーディング名を返します。
String | newString(char[] c) getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
String | newString(String str) getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
protected void | setCharacterEncoding(String enc) このオブジェクトが対象とする文字エンコーディングを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterEncoder

public CharacterEncoder(String enc)
                 throws ResourceNotFoundException,
                        ResourceFormatException,
                        IOException
文字コード変換のためのエンコーダを作成します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー
メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding()
このオブジェクトが対象としている文字エンコーディング名を返します。

戻り値:
文字エンコーディング名

setCharacterEncoding

protected void setCharacterEncoding(String enc)
                             throws ResourceFormatException,
                                    ResourceNotFoundException,
                                    IOException
このオブジェクトが対象とする文字エンコーディングを設定します。

パラメータ:
enc - エンコーディング名
例外:
NullPointerException - 引数が null の場合
ResourceNotFoundException - 設定が見つからなかった場合
ResourceFormatException - 設定情報が不適切だった場合
IOException - 入出力エラー

encode

public byte[] encode(char c)
              throws UnsupportedEncodingException,
                     IOException
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(char[] c)
              throws UnsupportedEncodingException,
                     IOException
指定の文字を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
c - 文字配列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

encode

public byte[] encode(String str)
              throws UnsupportedEncodingException,
                     IOException
指定の文字列を getCharacterEncoding() で表される文字コードへ エンコードします。

パラメータ:
str - 文字列
戻り値:
エンコードされたバイト列
例外:
UnsupportedEncodingException
IOException

newString

public String newString(String str)
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 str のマッピングを修正した 新しい文字列です。

パラメータ:
str - 文字列
戻り値:
マッピングを修正された新しい文字列

newString

public String newString(char[] c)
getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

返される文字列は、引数 c のマッピングを修正した 新しい文字列です。
引数の配列 c は変化しません。

パラメータ:
c - 文字配列
戻り値:
新しい文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CharacterMappingBuilder (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterMappingBuilder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder
public class CharacterMappingBuilder
extends Object

このクラスは、文字エンコードのマッピング定義を管理します。

定義ファイルは、クラスローダを利用して検索および読み込まれます。 したがって、定義ファイルはクラスパスに設定されているディレクトリまたは アーカイブファイル内に配置する必要があります。
各文字エンコーディングと文字の変換テーブルの関連については、 定義ファイル jp/co/intra_mart/resources/charset/encoding/mapping.xml に記載されています。

導入されたバージョン:
version5.0

フィールドの概要
static String CONFIG_FILE_PATH
マッピングを定義した定義ファイルのリストが記載されている定義ファイル名
メソッドの概要
char[] | getMapping(String enc) 文字の修正用マッピングを返します。
static CharacterMappingBuilder | instance() ビルダを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONFIG_FILE_PATH

public static final String CONFIG_FILE_PATH
マッピングを定義した定義ファイルのリストが記載されている定義ファイル名

関連項目:
定数フィールド値
メソッドの詳細

instance

public static CharacterMappingBuilder instance()
                                        throws ParserConfigurationException,
                                               SAXException,
                                               ResourceFormatException,
                                               IOException,
                                               ResourceNotFoundException
ビルダを返します。

戻り値:
ビルダ
例外:
ParserConfigurationException - XML 解析エラー
SAXException - XML 解析エラー
ResourceFormatException - 設定情報に不整合がある場合
IOException - 設定ファイルの入力エラー
ResourceNotFoundException - 設定ファイルがない場合

getMapping

public char[] getMapping(String enc)
                  throws ParserConfigurationException,
                         IOException,
                         SAXException,
                         ResourceFormatException,
                         ResourceNotFoundException
文字の修正用マッピングを返します。 マッピングは、対象の文字コードの数値表現をインデックスにした要素に 置換文字を持つ char 型配列です。

パラメータ:
enc - 文字エンコーディング名
戻り値:
エンコード用の文字マッピング
例外:
UnsupportedEncodingException - エンコーディング別のマッピング定義ファイルが見つからなかった場合
ParserConfigurationException
IOException
SAXException
ResourceFormatException
ResourceNotFoundException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CharacterSetManager (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス CharacterSetManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
public class CharacterSetManager
extends Object

このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。

J2SE,v1.4でサポートされているエンコーディングセット名から IANAに登録されているキャラクタセット名へのマッピングについては、 定義ファイル jp/co/intra_mart/common/aid/jdk/util/charset/jdk2iana.properties に記載されています。

IANAに登録されているキャラクタセット名と J2SE,v1.4 でサポートされているエンコーディングセット名へのマッピングについては、 定義ファイル jp/co/intra_mart/common/aid/jdk/util/charset/jdk2iana.properties に記載されています。

導入されたバージョン:
version 5.0

コンストラクタの概要
CharacterSetManager()
メソッドの概要
static String | toIANAName(String jdkEncodingSetName) 指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
static String | toJDKName(String ianaCharacterSetName) 指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CharacterSetManager

public CharacterSetManager()
メソッドの詳細

toJDKName

public static String toJDKName(String ianaCharacterSetName)
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
対応するエンコーディングセット名が見つからない場合には 指定されたキャラクタセット名をそのまま返却します。

パラメータ:
ianaCharacterSetName - IANAに登録されている キャラクタセット名
戻り値:
J2SEでサポートされているエンコーディングセット名

toIANAName

public static String toIANAName(String jdkEncodingSetName)
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
対応するキャラクタセット名が見つからない場合には 指定されたエンコーディングセット名をそのまま返却します。

パラメータ:
jdkEncodingSetName - J2SEでサポートされているエンコーディングセット名
戻り値:
IANAに登録されているキャラクタセット名
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.charset (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.util.charset
クラス
AdvancedOutputStreamWriter
CharacterEncoder
CharacterMappingBuilder
CharacterSetManager
例外
ResourceFormatException
ResourceNotFoundException


jp.co.intra_mart.common.aid.jdk.util.charset (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
AdvancedOutputStreamWriter | このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
CharacterEncoder | このクラスは、文字エンコードの機能を提供します。
CharacterMappingBuilder | このクラスは、文字エンコードのマッピング定義を管理します。
CharacterSetManager | このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。

例外の概要
ResourceFormatException | リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException | リソースがないことを通知する例外です。

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の説明

このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.util.charset クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter


パッケージ jp.co.intra_mart.common.aid.jdk.util.charset の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.charset の使用

jp.co.intra_mart.common.aid.jdk.util.charset を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.charset このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.charset により使用される jp.co.intra_mart.common.aid.jdk.util.charset のクラス
CharacterMappingBuilder
このクラスは、文字エンコードのマッピング定義を管理します。
ResourceFormatException
リソースの内容が不適切であることを通知する例外です。
ResourceNotFoundException
リソースがないことを通知する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ResourceFormatException (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceFormatException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
すべての実装インタフェース:
Serializable
public class ResourceFormatException
extends Exception

リソースの内容が不適切であることを通知する例外です。

設定の内容に誤りがあるか、または定義の書式が正しくない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceFormatException

public ResourceFormatException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceFormatException

public ResourceFormatException(String msg,
                               Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResourceNotFoundException (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.charset
クラス ResourceNotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
すべての実装インタフェース:
Serializable
public class ResourceNotFoundException
extends Exception

リソースがないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String msg, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ResourceNotFoundException

public ResourceNotFoundException(String msg)
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ

ResourceNotFoundException

public ResourceNotFoundException(String msg,
                                 Throwable cause)
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。

パラメータ:
msg - エラーメッセージ
cause - 原因。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jdk.util.Counter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.Counter の使用

jp.co.intra_mart.common.aid.jdk.util.Counter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.ErrorEvent の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.ErrorEvent の使用

ErrorEvent を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util での ErrorEvent の使用

ErrorEvent 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util のメソッド
 void ErrorEventListener.handleError(ErrorEvent err)
発生した例外を通知します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener の使用

ErrorEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io での ErrorEventListener の使用

ErrorEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.java.io のコンストラクタ
ExtendedOutputStream(OutputStream out, ErrorEventListener listener)
出力ストリームを構築します。
ExtendedInputStream(InputStream in, ErrorEventListener listener)
入力ストリームを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.EventListener の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.EventListener の使用

EventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util での EventListener の使用

EventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util のメソッド
 void EventQueueController.entry(EventListener listener)
イベントリスナーの登録。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.EventQueueController の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.EventQueueController の使用

EventQueueController を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での EventQueueController の使用

EventQueueController 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.LockMonitor の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.LockMonitor の使用

jp.co.intra_mart.common.aid.jdk.util.LockMonitor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions の使用

jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter の使用

AbstractMessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での AbstractMessageReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report での AbstractMessageReporter のサブクラス
class | FileReporter メッセージのファイル出力機能を提供します。
class | MultiCastReporter メッセージを複数のストリームに出力するためのフィルタークラスです。
class | PrintStreamReporter メッセージ出力用クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.FileReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の使用

FilterMessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での FilterMessageReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report での FilterMessageReporter のサブクラス
class | LineReportFilter メッセージを行出力するためのフィルタークラスです。
class | ReportLevelFilter メッセージの出力制御を行うためのフィルタークラスです。
class | RepresentativeReporter メッセージ出力をイベント処理するためのフィルタークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter の使用

jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter の使用

MessageReporter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での MessageReporter の使用

MessageReporter を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
class | AbstractMessageReporter メッセージ出力用のスケルトンクラスです。
class | FileReporter メッセージのファイル出力機能を提供します。
class | FilterMessageReporter メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
class | LineReportFilter メッセージを行出力するためのフィルタークラスです。
class | MultiCastReporter メッセージを複数のストリームに出力するためのフィルタークラスです。
class | PrintStreamReporter メッセージ出力用クラスです。
class | ReportLevelFilter メッセージの出力制御を行うためのフィルタークラスです。
class | RepresentativeReporter メッセージ出力をイベント処理するためのフィルタークラスです。

MessageReporter として宣言されている jp.co.intra_mart.common.aid.jdk.util.report のフィールド
protected  MessageReporter FilterMessageReporter.out
基礎出力ストリームです。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
void | MultiCastReporter.addReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
boolean | MultiCastReporter.hasReporter(MessageReporter reporter) 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | MultiCastReporter.removeReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

MessageReporter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ReportLevelFilter(MessageReporter out, int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner の使用

jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner の使用

ReportFileConditioner を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportFileConditioner の使用

ReportFileConditioner を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
class | EverydayConditioner このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | FileSizeConditioner このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | OutputSizeConditioner このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
class | PeriodicConditioner このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。

ReportFileConditioner 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
void | FileReporter.addConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
boolean | FileReporter.removeConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter の使用

ReportFileWriter を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportFileWriter の使用

ReportFileWriter として宣言されている jp.co.intra_mart.common.aid.jdk.util.report のフィールド
protected  ReportFileWriter FileReporter.out
基礎出力ストリームです。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のメソッド
boolean | ReportFileConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | PeriodicConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | OutputSizeConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | FileSizeConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。
boolean | EverydayConditioner.expiration(ReportFileWriter writer) メッセージファイルを再作成する必要があるかどうかを判定します。

ReportFileWriter 型のパラメータを持つ jp.co.intra_mart.common.aid.jdk.util.report のコンストラクタ
FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の使用

ReportLevel を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report での ReportLevel の使用

ReportLevel を実装している jp.co.intra_mart.common.aid.jdk.util.report のクラス
 class ReportLevelFilter
メッセージの出力制御を行うためのフィルタークラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の使用

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter の使用

jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractMessageReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス AbstractMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
FileReporter, MultiCastReporter, PrintStreamReporter
public abstract class AbstractMessageReporter
extends Object
implements MessageReporter

メッセージ出力用のスケルトンクラスです。

サブクラスでは、report メソッドをオーバーライドして、 任意の出力先にメッセージを出力する機能を実装する必要があります。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractMessageReporter()
唯一のコンストラクタ。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) data をメッセージとして出力します。
abstract void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractMessageReporter

protected AbstractMessageReporter()
唯一のコンストラクタ。

メソッドの詳細

report

public abstract void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(String.valueOf(data))

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 必要に応じてサブクラスでオーバーライドしてください。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EverydayConditioner (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス EverydayConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner
すべての実装インタフェース:
ReportFileConditioner
public class EverydayConditioner
extends Object
implements ReportFileConditioner

このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 指定時間になった(指定時間を経過した)ときに、 メッセージファイルのローテイト機能イベントを発生させることができます。 時間のチェックは時および分によるものなので、FileReporter の中で リフレッシュイベントは毎日発生することになります。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
EverydayConditioner(int hours, int minutes)
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int hours, int minutes, TimeZone timeZone)
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes,
                           TimeZone timeZone)
                    throws IllegalArgumentException
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、指定されたタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
timeZone - タイムゾーン
例外:
IllegalArgumentException - 引数が有効範囲外の場合

EverydayConditioner

public EverydayConditioner(int hours,
                           int minutes)
                    throws IllegalArgumentException
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、毎日指定された時刻に なった場合にリフレッシュイベント発生を通知します。
時刻の計算は、デフォルトタイムゾーンに基づきます。

パラメータ:
hours - 時間(0 ～ 23)
minutes - 分(0 ～ 59)
例外:
IllegalArgumentException - 引数が有効範囲外の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
このオブジェクトの作成時に指定された時刻を経過して最初の呼び出し時 の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FileReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
すべての実装インタフェース:
MessageReporter
public class FileReporter
extends AbstractMessageReporter

メッセージのファイル出力機能を提供します。

このクラスは、report メソッドで渡されたメッセージを指定のファイルに 出力します。

導入されたバージョン:
version 5.0

フィールドの概要
protected  ReportFileWriter out
基礎出力ストリームです。
コンストラクタの概要
FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | addConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
void | close() このオブジェクトを閉じます。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
boolean | removeConditioner(ReportFileConditioner conditioner) ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected ReportFileWriter out
基礎出力ストリームです。

コンストラクタの詳細

FileReporter

public FileReporter(ReportFileWriter out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

addConditioner

public void addConditioner(ReportFileConditioner conditioner)
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
引数が null の場合は、何の効果もありません。 また、conditioner が既に登録済みのインスタンスである場合、 追加登録はされません。

パラメータ:
conditioner - 追加する ReportFileConditioner のインスタンス

removeConditioner

public boolean removeConditioner(ReportFileConditioner conditioner)
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
引数が null の場合は、何の効果もありません。

パラメータ:
conditioner - 削除する ReportFileConditioner のインスタンス
戻り値:
指定のオブジェクトを削除できた場合 true。

report

public void report(String message)
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FileSizeConditioner (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FileSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
public class FileSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
FileSizeConditioner(long max)
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FileSizeConditioner

public FileSizeConditioner(long max)
                    throws IllegalArgumentException
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、メッセージファイルが指定の大きさ(max)以上に なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルサイズが、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FilterMessageReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス FilterMessageReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
すべての実装インタフェース:
MessageReporter
直系の既知のサブクラス:
LineReportFilter, ReportLevelFilter, RepresentativeReporter
public class FilterMessageReporter
extends Object
implements MessageReporter

メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。

基礎出力ストリームにメッセージを出力する前にメッセージを加工したりする 追加機能を提供するクラスを作成するために利用することができます。

このクラスは、単に MessageReporter の全てのメソッドを オーバーライドし、各要求を基礎出力ストリームに渡す機能を提供しています。 サブクラスでは、メソッドを追加したり、必要に応じてメソッドをオーバーライド することがあります。

導入されたバージョン:
version 5.0

フィールドの概要
protected  MessageReporter out
基礎出力ストリームです。
コンストラクタの概要
FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) 基礎出力ストリームに対してメッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

out

protected MessageReporter out
基礎出力ストリームです。

コンストラクタの詳細

FilterMessageReporter

public FilterMessageReporter(MessageReporter out)
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に message を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドでは、基礎出力リポートオブジェクトも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineReportFilter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス LineReportFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
すべての実装インタフェース:
MessageReporter
public class LineReportFilter
extends FilterMessageReporter

メッセージを行出力するためのフィルタークラスです。

このクラスを利用すると、report メソッドに渡されたメッセージ文字列に 改行コードを付加して、行出力することができます。
以下のようなプログラムにより、ログファイルをログファイルを作成することが できます。

FIle logFile = new File("test.log");
ReportFileWriter writer = new ReportFileWriter(logFile);
FileReporter writer = new FileReporter(writer);
MessageReporter reporter = new LineReportFilter(writer);
これで、変数 reporter の report メソッドを呼び出す毎に、 ファイル test.log に report メソッド指定したメッセージが １行として出力されます。

導入されたバージョン:
version 5.0
関連項目:
ReportLevel

フィールドの概要
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
メソッドの概要
void | report(Object data) 基礎出力ストリームに対してメッセージを出力します。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LineReportFilter

public LineReportFilter(MessageReporter out)
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
メッセージを出力します。
このメソッドは、基礎出力ストリームに対して、message に 改行コードを付加してメッセージを１行出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
基礎出力ストリームに対してメッセージを出力します。
このメソッドは、単純に data を基礎出力ストリームに渡します。 サブクラスで、このメソッドをオーバーライドすることにより、 データの加工などのフィルタリング処理を追加することができます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MessageReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース MessageReporter

既知の実装クラスの一覧:
AbstractMessageReporter, FilterMessageReporter
public interface MessageReporter

メッセージ出力のためのインターフェースです。

このインターフェースを実装したクラスでは、report メソッドで 指定されたメッセージを任意の出力先に対して出力する機能を提供します。

導入されたバージョン:
version 5.0

メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。

メソッドの詳細

report

public void report(String message)
メッセージを出力します。

パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、任意のオペレーションです。

例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultiCastReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス MultiCastReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
すべての実装インタフェース:
MessageReporter
public class MultiCastReporter
extends AbstractMessageReporter

メッセージを複数のストリームに出力するためのフィルタークラスです。

このクラスは、MessageReporter インターフェースを実装したクラスに対する フィルタークラスとして働きます。 report メソッドに渡されたメッセージデータは、指定された複数の MessageReporter インターフェースすべてに渡されます。
このフィルタークラスを利用することにより、複数の MessageReporter に 対して同じメッセージを渡すことができるため、メッセージ出力プログラムを 効率的に記述することができます。

メッセージの出力先となる MessageReporter は、addReporter メソッドで 定義します。addReporter メソッドでの定義順と、実際の実行順は 保証されません。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultiCastReporter()
唯一のコンストラクタ。
メソッドの概要
void | addReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
Iterator | getReporters() セット内の要素についての反復子を返します。
boolean | hasReporter(MessageReporter reporter) 指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。
boolean | removeReporter(MessageReporter reporter) 指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MultiCastReporter

public MultiCastReporter()
唯一のコンストラクタ。

メソッドの詳細

addReporter

public void addReporter(MessageReporter reporter)
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。 すでに指定のオブジェクトを要素としてもっていた場合、 このメソッドは何も行いません。

パラメータ:
reporter - セットに追加される要素

hasReporter

public boolean hasReporter(MessageReporter reporter)
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

パラメータ:
reporter - セットに含まれているかチェックする要素
戻り値:
セット内に指定された要素がある場合は true

removeReporter

public boolean removeReporter(MessageReporter reporter)
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。

パラメータ:
reporter - セットにあった場合に削除されるオブジェクト
戻り値:
指定された要素がセット内にあった場合は true

getReporters

public Iterator getReporters()
セット内の要素についての反復子を返します。 反復子から取得される各要素は、addReporter メソッドにより追加された リポーターオブジェクトになります。 各要素の取得順は保証されません。 このオブジェクトが閉じられている場合 null を返します。

戻り値:
セット内の要素についての反復子

report

public void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス AbstractMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 オブジェクトが閉じられると、report メソッドは何もしなくなります。 このオブジェクトの持つすべての Reporter オブジェクトを閉じて、 リソースを開放します。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 このメソッドは、何も行いません。 このオブジェクトの持つすべての Reporter オブジェクトをフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OutputSizeConditioner (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス OutputSizeConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner
すべての実装インタフェース:
ReportFileConditioner
public class OutputSizeConditioner
extends Object
implements ReportFileConditioner

このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 メッセージファイルが一定サイズ以上になったときに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
OutputSizeConditioner(long max)
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

OutputSizeConditioner

public OutputSizeConditioner(long max)
                      throws IllegalArgumentException
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
このオブジェクトは、ログファイルへ書き出したメッセージの量が 一定(max)以上の大きさに なった場合にリフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - max がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
ファイルへの出力文字数が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util.report (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.util.report
インタフェース
MessageReporter
ReportFileConditioner
ReportLevel
クラス
AbstractMessageReporter
EverydayConditioner
FileReporter
FileSizeConditioner
FilterMessageReporter
LineReportFilter
MultiCastReporter
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
ReportFileWriter
ReportLevelFilter
RepresentativeReporter


jp.co.intra_mart.common.aid.jdk.util.report (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MessageReporter | メッセージ出力のためのインターフェースです。
ReportFileConditioner | このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportLevel | メッセージレベルのインターフェースです。

クラスの概要
AbstractMessageReporter | メッセージ出力用のスケルトンクラスです。
EverydayConditioner | このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileReporter | メッセージのファイル出力機能を提供します。
FileSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FilterMessageReporter | メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
LineReportFilter | メッセージを行出力するためのフィルタークラスです。
MultiCastReporter | メッセージを複数のストリームに出力するためのフィルタークラスです。
OutputSizeConditioner | このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner | このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PrintStreamReporter | メッセージ出力用クラスです。
ReportFileWriter | メッセージをファイルに出力するストリームクラスです。
ReportLevelFilter | メッセージの出力制御を行うためのフィルタークラスです。
RepresentativeReporter | メッセージ出力をイベント処理するためのフィルタークラスです。

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の説明

このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jdk.util.report クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util.report の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.Writer
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.jdk.util.report の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util.report の使用

jp.co.intra_mart.common.aid.jdk.util.report を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.util.report このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.util.report により使用される jp.co.intra_mart.common.aid.jdk.util.report のクラス
AbstractMessageReporter
メッセージ出力用のスケルトンクラスです。
FilterMessageReporter
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
MessageReporter
メッセージ出力のためのインターフェースです。
ReportFileConditioner
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileWriter
メッセージをファイルに出力するストリームクラスです。
ReportLevel
メッセージレベルのインターフェースです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PeriodicConditioner (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス PeriodicConditioner

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner
すべての実装インタフェース:
ReportFileConditioner
public class PeriodicConditioner
extends Object
implements ReportFileConditioner

このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
このクラスは、FileReporter と組み合わせて利用します。 このクラスのオブジェクトを FileReporter オブジェクトにセットすることで、 一定期間の経過に合わせてに、 メッセージファイルのローテイト機能イベントを発生させることができます。

導入されたバージョン:
version 5.0
関連項目:
FileReporter, ReportFileWriter

コンストラクタの概要
PeriodicConditioner(long millis)
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PeriodicConditioner

public PeriodicConditioner(long millis)
                    throws IllegalArgumentException
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
このオブジェクトは、指定の時間が経過した時に リフレッシュイベント発生を通知します。

例外:
IllegalArgumentException - millis がゼロ以下の場合
メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
引数 outputSize の値が、このオブジェクトの作成時に指定された 値以上の場合 true を返します。

定義:
インタフェース ReportFileConditioner 内の expiration
パラメータ:
writer - 出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
関連項目:
FileReporter, ReportFileWriter
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrintStreamReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス PrintStreamReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
すべての実装インタフェース:
MessageReporter
public class PrintStreamReporter
extends AbstractMessageReporter

メッセージ出力用クラスです。

このクラスは、指定の PrintStream に対してメッセージを出力するための 機能を実装しています。 例えば、このクラスのコンストラクタの引数に java.lang.System.out を指定した 場合、標準出力に対してメッセージを出力することができます。
このクラスの特徴は、report メソッドに渡されたメッセージを PrintStream の println メソッドに渡します。 これにより、report メソッドの呼び出し毎にメッセージを改行付きで 指定の PrintStream に出力することができます（１行毎に出力）。

導入されたバージョン:
version 5.0

コンストラクタの概要
PrintStreamReporter(PrintStream out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | close() このオブジェクトを閉じます。
void | flush() このオブジェクトのバッファの情報をすべて出力します。
void | report(String message) メッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter から継承したメソッド
report
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PrintStreamReporter

public PrintStreamReporter(PrintStream out)
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力ストリーム
メソッドの詳細

report

public void report(String message)
メッセージを出力します。 このオブジェクトが既に閉じられている場合、このメソッドは 何も行いません。

定義:
インタフェース MessageReporter 内の report
定義:
クラス AbstractMessageReporter 内の report
パラメータ:
message - メッセージ

close

public void close()
           throws IOException
このオブジェクトを閉じます。 このオブジェクトに関わる全てのリソースを開放します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス AbstractMessageReporter 内の close
例外:
IOException - 入出力エラー

flush

public void flush()
           throws IOException
このオブジェクトのバッファの情報をすべて出力します。 また、このメソッドは基礎ストリームも同時にフラッシュします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス AbstractMessageReporter 内の flush
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileConditioner (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース ReportFileConditioner

既知の実装クラスの一覧:
EverydayConditioner, FileSizeConditioner, OutputSizeConditioner, PeriodicConditioner
public interface ReportFileConditioner

このクラスは、ReportFileWriter の初期化チェックのインターフェースです。

このクラスは FileReporter クラスにより ReportFileWriter へのメッセージ 書き出し前に呼び出されます。
このクラスは、FileReporter および ReportFileWriter オブジェクトと 組み合わせて使います。 これらのクラスと連携することにより、メッセージファイルの ローテイト機能などを実装することができます。

導入されたバージョン:
version 5.0

メソッドの概要
 boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。

メソッドの詳細

expiration

public boolean expiration(ReportFileWriter writer)
メッセージファイルを再作成する必要があるかどうかを判定します。
このメソッドは、FileReporter クラスにより呼び出されます。 真値(true)を返すと、ReportFileWriter は現在のログファイルに対して 初期化処理を行います。 メッセージファイルの初期化処理に関しては、 ReportFileWriter クラス(または、そのサブクラス)により行われます。

パラメータ:
writer - メッセージファイルへの出力ストリーム
戻り値:
メッセージファイルの再作成が必要と判断された場合は true。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportFileWriter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス ReportFileWriter

java.lang.Object
    拡張 java.io.Writer
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter
public class ReportFileWriter
extends Writer

メッセージをファイルに出力するストリームクラスです。

このクラスは、メッセージを指定のファイルに対して出力するための スケルトンです。 また、このクラスは reset メソッドをオーバーライドすることにより、 ファイルのローテイト機能などを実装することができます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス java.io.Writer から継承したフィールド
lock
コンストラクタの概要
ReportFileWriter(File f)
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
メソッドの概要
void | close() ストリームを閉じてフラッシュします。
protected Writer | createWriter() メッセージをファイルへ書き出すための出力ストリームを作成します。
Writer | currentWriter() このオブジェクトが文字を書き出している基礎 Writer を返します。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() ストリームをフラッシュします。
File | getFile() このオブジェクトが文字を書き出すファイルを取得します。
void | handleShutdown() シャットダウンイベントが発生したときに実行されるメソッドです。
long | length() このライターの出力文字数を取得します。
protected void | reconstruction() 現在使用中の Writer をリセットします。
protected Writer | reset(Writer writer) 文字の出力ストリームをリセットします。
void | write(char[] cbuf, int off, int len) 基礎ストリームに文字を出力します。
クラス java.io.Writer から継承したメソッド
write, write, write, write
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReportFileWriter

public ReportFileWriter(File f)
                 throws IOException
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。

パラメータ:
f - このライターで書き出すファイル
例外:
IOException - 入出力エラー
メソッドの詳細

getFile

public File getFile()
このオブジェクトが文字を書き出すファイルを取得します。
このメソッドは、このオブジェクトの作成時にコンストラクタの引数として 与えられた File オブジェクトへの参照を返します。

戻り値:
このライターで書き出すファイル

createWriter

protected Writer createWriter()
                       throws IOException
メッセージをファイルへ書き出すための出力ストリームを作成します。

このメソッドは、単に getFile メソッドが返すファイルに対して 文字を書き出すための出力ストリームを作成して返します。 このメソッドの返す出力ストリームを使うことで、 getFile メソッドの返す ファイルに対してメッセージを追記していくことができます。
メッセージを任意の文字コードに変換したり、出力バッファを備えた Writer オブジェクトを作成する必要がある場合には、サブクラスで このメソッドをオーバーライドして実装して下さい。

戻り値:
出力ストリーム
例外:
IOException

length

public long length()
このライターの出力文字数を取得します。
このメソッドで返される文字数は、このファイルに対して 現在までに出力した文字数です。 文字数カウンタは、reset メソッドを実行することにより 0 (ゼロ)にリセットされます。

戻り値:
出力文字数

currentWriter

public Writer currentWriter()
このオブジェクトが文字を書き出している基礎 Writer を返します。

戻り値:
基礎 Writer オブジェクト

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
基礎ストリームに文字を出力します。
このメソッドをサブクラスがオーバーライドすることにより、 バッファ機能などを実装することができます。 ただし、このメソッドをオーバーライドしたサブクラスは、 同時に length メソッドもオーバーライドする必要があります。

パラメータ:
cbuf - 文字の配列
off - 文字の書き込み開始オフセット
len - 書き込む文字数
例外:
IOException

reconstruction

protected void reconstruction()
                       throws IOException
現在使用中の Writer をリセットします。
このメソッドは、FileReporter クラスにより呼び出されます。 FileReporter オブジェクトでは、ReportFileConditioner オブジェクトが ファイルの初期化を必要と判断した場合に、このメソッドを呼び出して、 Writer の初期化を求めてきます。 これにより、リポートファイルのローテイト機能などを 実装することができます。

例外:
IOException

reset

protected Writer reset(Writer writer)
                throws IOException
文字の出力ストリームをリセットします。

このメソッドは reset メソッドに呼び出されます。
このメソッドは、単に引数のストリーム(writer)をそのまま リターンします。ファイルのローテイト機能などを実装する場合、 サブクラスでこのメソッドをオーバーライドして下さい。

パラメータ:
writer - 現在のストリーム
戻り値:
新しいストリーム
例外:
IOException

close

public void close()
           throws IOException
ストリームを閉じてフラッシュします。
ストリームを一度閉じると、以降 write() または flush() を呼び出すと、 IOException がスローされます。 ただし、前に閉じたストリームを閉じても効果はありません。

例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。
ストリームがさまざまな write() メソッドからの文字をバッファに 保存してある場合、これらの文字の目的の宛先にただちに文字を書き込みます。 宛先が別の文字またはバイトストリームの場合は、 この宛先をフラッシュします。 つまり 1 つの flush() の呼び出しで、 関連する Writer および OutputStream の すべてのバッファをフラッシュします。

サブクラスで、文字のバッファリング機能を実装している場合、 このメソッドをオーバーライドしてバッファに保存している 文字をフラッシュするように実装しなければいけません。

例外:
IOException - 入出力エラーが発生した場合

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable

handleShutdown

public void handleShutdown()
シャットダウンイベントが発生したときに実行されるメソッドです。 このメソッドは、シャットダウンイベント発生時に、 バッファされているバイトをすべて出力するために flush() メソッドを呼び出します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReportLevel (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
インタフェース ReportLevel

既知の実装クラスの一覧:
ReportLevelFilter
public interface ReportLevel

メッセージレベルのインターフェースです。

このインターフェースは、定数値化したメッセージレベルを示します。 すべてのメッセージに関して、必ずしもこのインターフェースで定義されている レベル値を使う必要はありませんが、このインターフェースを利用することにより プログラム全体でレベル値を統一することができます。

導入されたバージョン:
version 5.0

フィールドの概要
static int | MAX_VALUE レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
static int | MIN_VALUE レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
static int | TYPE_DEBUG デバッグレベル。
static int | TYPE_ERROR エラーレベル。
static int | TYPE_REPORT 通常の情報レベル。
static int | TYPE_WARNING 警告レベル。

フィールドの詳細

MIN_VALUE

public static final int MIN_VALUE
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。

関連項目:
定数フィールド値

MAX_VALUE

public static final int MAX_VALUE
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。

関連項目:
定数フィールド値

TYPE_DEBUG

public static final int TYPE_DEBUG
デバッグレベル。 デバッグ情報を出力する場合に利用します。

関連項目:
定数フィールド値

TYPE_REPORT

public static final int TYPE_REPORT
通常の情報レベル。
常に以下の関係が成り立ちます。

TYPE_DEBUG < TYPE_REPORT

関連項目:
定数フィールド値

TYPE_WARNING

public static final int TYPE_WARNING
警告レベル。 警告メッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_REPORT < TYPE_WARNING

関連項目:
定数フィールド値

TYPE_ERROR

public static final int TYPE_ERROR
エラーレベル。 エラーメッセージ出力時に利用します。
常に以下の関係が成り立ちます。

TYPE_WARNING < TYPE_ERROR

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ReportLevelFilter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス ReportLevelFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter
すべての実装インタフェース:
MessageReporter, ReportLevel
public class ReportLevelFilter
extends FilterMessageReporter
implements ReportLevel

メッセージの出力制御を行うためのフィルタークラスです。

このクラスを利用することにより、メッセージをメッセージレベルにより、 出力制御を行うことができます。

導入されたバージョン:
version 5.0
関連項目:
ReportLevel

フィールドの概要
protected  int datumpoint
このリポーターがフィルタリングする基準レベル値
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
インタフェース jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel から継承したフィールド
MAX_VALUE, MIN_VALUE, TYPE_DEBUG, TYPE_ERROR, TYPE_REPORT, TYPE_WARNING
コンストラクタの概要
ReportLevelFilter(MessageReporter out, int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
メソッドの概要
void | report(Object data) data をメッセージとして出力します。
void | report(Object data, int level) 指定のメッセージレベルが基準値以上のメッセージを出力します。
void | report(String message) メッセージを出力します。
void | report(String message, int level) 指定のメッセージレベルが基準値以上のメッセージを出力します。
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したメソッド
close, flush
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

datumpoint

protected int datumpoint
このリポーターがフィルタリングする基準レベル値

コンストラクタの詳細

ReportLevelFilter

public ReportLevelFilter(MessageReporter out,
                         int level)
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

report

public void report(String message)
メッセージを出力します。
このメソッドは、以下の呼出と同じです。

report(message, ReportLevel.MAX_VALUE)

つまり、メッセージ message は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(String message,
                   int level)
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
message - メッセージ
level - メッセージレベル

report

public void report(Object data)
data をメッセージとして出力します。
このメソッドは、以下の呼出と同じです。

report(data, ReportLevel.MAX_VALUE)

つまり、メッセージデータ data は必ず基礎出力リポーターに出力されます。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

report

public void report(Object data,
                   int level)
指定のメッセージレベルが基準値以上のメッセージを出力します。
メッセージレベルは以下の式で判定されます。

this.datumpoint <= level

判定式が true の場合、基礎出力リポーターに対して メッセージが出力されます。逆に判定結果が false の場合、 このメソッドは何も行いません。

パラメータ:
data - データ
level - メッセージレベル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RepresentativeReporter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util.report
クラス RepresentativeReporter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter
        拡張 jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
すべての実装インタフェース:
MessageReporter
public class RepresentativeReporter
extends FilterMessageReporter

メッセージ出力をイベント処理するためのフィルタークラスです。

このクラスを利用することにより、メッセージの MessageReporter における 処理を現在のスレッドと並列実行させることができます。 これにより、このクラスの report メソッドと、出力先となる MessageReporter の report メソッドの実行は非同期に処理されます。

このクラスを利用することのメリットは、メッセージの出力処理を 待たなくても、現在のスレッドの実行を継続できることにあります。 逆に、このクラスを利用することにより、メッセージ出力処理と現在のスレッド処理 がスレッドセーフであることが保証されなければなりません。
report メソッドで指定されたメッセージはキューに蓄積され、 現在のスレッドと異なるメッセージ処理専用のスレッドで 基礎出力ストリームに渡されます。 メッセージの出力処理は、現在のスレッドと非同期ですが、 report メソッドの実行順とメッセージの出力順は保証されます。

導入されたバージョン:
version 5.0

フィールドの概要
クラス jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter から継承したフィールド
out
コンストラクタの概要
RepresentativeReporter(MessageReporter out, EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
メソッドの概要
boolean | canReport() このストリームが書き込み可能かどうかをチェックします。
void | close() ストリームを閉じます。
void | flush() ストリームをフラッシュします。
void | report(Object data) data をメッセージとして出力します。
void | report(String message) メッセージを出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RepresentativeReporter

public RepresentativeReporter(MessageReporter out,
                              EventQueueController queue)
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。

パラメータ:
out - 基礎出力リポーター
メソッドの詳細

canReport

public boolean canReport()
このストリームが書き込み可能かどうかをチェックします。

戻り値:
ストリームの書き込みが可能な場合 true、そうでない場合 false。

report

public void report(String message)
メッセージを出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
message - メッセージ

report

public void report(Object data)
data をメッセージとして出力します。

定義:
インタフェース MessageReporter 内の report
オーバーライド:
クラス FilterMessageReporter 内の report
パラメータ:
data - データ

close

public void close()
           throws IOException
ストリームを閉じます。
このメソッドは、ストリームを閉じる前に flush メソッドを実行します。 オブジェクトが閉じられると、report メソッドは何もしなくなります。

定義:
インタフェース MessageReporter 内の close
オーバーライド:
クラス FilterMessageReporter 内の close
例外:
IOException - 入出力エラーが発生した場合

flush

public void flush()
           throws IOException
ストリームをフラッシュします。

ストリームに蓄積されているすべてのメッセージイベントを処理します。 このメソッドを実行した場合、現在のスレッドで メッセージが処理されます。また、このメソッドはすべてのメッセージ出力 処理が完了するまでブロックします。

定義:
インタフェース MessageReporter 内の flush
オーバーライド:
クラス FilterMessageReporter 内の flush
例外:
IOException - 入出力エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Counter (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス Counter

java.lang.Object
    拡張 java.lang.Number
        拡張 jp.co.intra_mart.common.aid.jdk.util.Counter
すべての実装インタフェース:
Serializable
public class Counter
extends Number
implements Serializable

このクラスは、カウンター機能を提供します。

ある数値を基準として１ずつ増やしたり１ずつ減らしたりすることができます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
Counter()
カウンターオブジェクトを作成します。
Counter(long initValue)
指定の初期値でカウンターオブジェクトを作成します。
メソッドの概要
long | decrement() カウンターの値を１だけ減少させます。
double | doubleValue() カウンターの現在の値を double 型として返します。
float | floatValue() カウンターの現在の値を float 型として返します。
long | increment() カウンターの値を１だけ増加させます。
int | intValue() カウンターの現在の値を int 型として返します。
long | longValue() カウンターの現在の値を long 型として返します。
クラス java.lang.Number から継承したメソッド
byteValue, shortValue
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Counter

public Counter()
カウンターオブジェクトを作成します。

初期値は０です。したがって、このコンストラクタの呼び出しは、 以下の呼び出しと同義です。
new Counter(0)

Counter

public Counter(long initValue)
指定の初期値でカウンターオブジェクトを作成します。

パラメータ:
initValue - カウンターの初期値
メソッドの詳細

increment

public long increment()
カウンターの値を１だけ増加させます。

戻り値:
変化後のカウンターの値

decrement

public long decrement()
カウンターの値を１だけ減少させます。

戻り値:
変化後のカウンターの値

intValue

public int intValue()
カウンターの現在の値を int 型として返します。 値を丸めたり切り捨てたりすることもあります。

戻り値:
このオブジェクトが表す数値を int 型に変換した値;

longValue

public long longValue()
カウンターの現在の値を long 型として返します。

戻り値:
このオブジェクトが表す数値を long 型に変換した値

floatValue

public float floatValue()
カウンターの現在の値を float 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を float 型に変換した値

doubleValue

public double doubleValue()
カウンターの現在の値を double 型として返します。 値を丸めることもあります。

戻り値:
このオブジェクトが表す数値を double 型に変換した値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ErrorEvent (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス ErrorEvent

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
public class ErrorEvent
extends Object

例外をイベントとして扱うためのプロトコルです。

イベントリスナー(インターフェース ErrorEventListener を実装したクラス) のオーナーオブジェクトは、例外の発生時にこのクラスのインスタンスを 生成して各リスナーに通知する義務があります。

導入されたバージョン:
version 5.0
関連項目:
ErrorEventListener

コンストラクタの概要
ErrorEvent(Throwable t, Object obj)
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable t, String msg, Object obj)
エラーを通知するためのイベントを構築します。
メソッドの概要
Throwable | getException() 通知されたエラーまたは例外を取得します。
String | getMessage() 通知されたエラーメッセージを取得します。
Object | getObject() 通知されたエラー発生オブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ErrorEvent

public ErrorEvent(Throwable t,
                  Object obj)
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
obj - エラーの発生したオブジェクト

ErrorEvent

public ErrorEvent(Throwable t,
                  String msg,
                  Object obj)
エラーを通知するためのイベントを構築します。

obj パラメータはエラーの発生したクラスまたはインスタンスです。

パラメータ:
t - 発生した例外
msg - エラーメッセージ
obj - エラーの発生したオブジェクト
メソッドの詳細

getObject

public Object getObject()
通知されたエラー発生オブジェクトを取得します。

戻り値:
通知されたエラーオブジェクト

getMessage

public String getMessage()
通知されたエラーメッセージを取得します。 メッセージが通知されていない場合、通知されたエラーのメッセージを 返します。

戻り値:
通知されたエラーメッセージ
関連項目:
Throwable.getMessage()

getException

public Throwable getException()
通知されたエラーまたは例外を取得します。

戻り値:
通知されたエラーまたは例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ErrorEventListener (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
インタフェース ErrorEventListener

public interface ErrorEventListener

例外をイベントとして扱うためのスケルトン実装を提供します。

このインターフェースを実装したクラスのインスタンスは例外の発生に伴い その例外をイベントとして受け取ることができます。 このインターフェースを実装しているクラスから生成されたインスタンスの オーナーオブジェクトは、 例外発生をイベントとしてインスタンスに対して通知する義務があります。

導入されたバージョン:
version 5.0

メソッドの概要
 void handleError(ErrorEvent err)
発生した例外を通知します。

メソッドの詳細

handleError

public void handleError(ErrorEvent err)
発生した例外を通知します。

パラメータ:
err - 発生したエラーイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventListener (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
インタフェース EventListener

public interface EventListener

このクラスは、イベントリスナーのインターフェースです。

イベントコントローラと組み合わせて使うことにより、 様々なイベント機能を実装することができます。

導入されたバージョン:
version 5.0
関連項目:
EventQueueController

メソッドの概要
 void handleEvent()
イベントが発生した時にコントローラから呼び出されます。

メソッドの詳細

handleEvent

public void handleEvent()
イベントが発生した時にコントローラから呼び出されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EventQueueController (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス EventQueueController

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.EventQueueController
public class EventQueueController
extends Object

このクラスは、イベントリスナーを実行するイベント機能を実装します。

イベントコントローラは、指定された時間間隔に従ってリスナー登録状況を確認し、 リスナーの登録が１つ以上あった場合、これらを専用スレッドで実行します。 このとき、イベントリスナーの実行順と実行の直列化が保証されます。
これらの機能により、通常の関数実行や java.lang.Thread クラスを利用した 並列処理などと異なった機能を実装することができます。

このクラスを利用することにより、現在の処理とイベント処理を並列化することが できます。また、一つのコントローラは同時に一つのイベントリスナーしか 実行しないため、それぞれのリスナーの処理が並列処理されることはありません。 従って、リスナーはマルチスレッドを意識したプログラムにする必要がありますが、 リスナー間でマルチスレッドを意識する必要はありません。

導入されたバージョン:
version 5.0
関連項目:
EventListener

コンストラクタの概要
EventQueueController()
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long millis)
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
メソッドの概要
void | entry(EventListener listener) イベントリスナーの登録。
void | eventGenerating() キューに登録されているイベントリスナーを一つ実行します。
protected void | finalize() このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
void | flush() キューに溜まっているすべてのイベントリスナーを実行します。
void | setCapacity(int max) キューの容量を変更します。
クラス java.lang.Object から継承したメソッド
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

EventQueueController

public EventQueueController()
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 コントローラがリスナー登録状況を監視する時間間隔はデフォルト値(60秒)が 適用されます。

EventQueueController

public EventQueueController(long millis)
                     throws IllegalArgumentException
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。 millis は、リスナーの登録状況を監視する時間間隔です。 コントローラは、リスナーが一つも登録されていない状態になると、 millis ミリ秒間隔でリスナー登録の有無を確認します。

パラメータ:
millis - イベントの監視間隔(ミリ秒)
例外:
IllegalArgumentException - millis が 0 以下の場合
メソッドの詳細

setCapacity

public void setCapacity(int max)
                 throws IllegalStateException,
                        IllegalArgumentException
キューの容量を変更します。

パラメータ:
max - イベントをプールできる最大量
例外:
IllegalStateException - max 個以上のリスナーが登録されている場合
IllegalArgumentException - max が 0 以下の場合

entry

public void entry(EventListener listener)
           throws NullPointerException,
                  IndexOutOfBoundsException,
                  IllegalStateException
イベントリスナーの登録。
イベントリスナーは、一旦キューに溜められます。 キューに保管されたリスナーは、 このコントローラにより現在実行中のスレッドとは 別のスレッドで登録順に呼び出されます。

実行されたリスナーは、処理が終了すると破棄されます。

通常のスレッドクラスを利用した並列処理との違いは、 イベントリスナーが登録順に実行される点と、 イベントリスナーの実行が直列化される点にあります。

パラメータ:
listener - イベントリスナー
例外:
NullPointerException - listener が null の場合
IndexOutOfBoundsException - キューが飽和状態の場合
IllegalStateException - コントローラが破棄処理済の場合

flush

public void flush()
キューに溜まっているすべてのイベントリスナーを実行します。

このメソッドは、現在実行中のスレッドで すべてのイベント処理を行います。

eventGenerating

public void eventGenerating()
                     throws NoSuchElementException
キューに登録されているイベントリスナーを一つ実行します。 実行されるリスナーは、現在キューに保管されているリスナーの中で 最も過去に登録されたリスナーです。 このメソッドは、現在実行中のスレッドで 登録順で最も過去のイベントを１つ実行します。

例外:
NoSuchElementException - 登録リスナーがない場合

finalize

protected void finalize()
                 throws Throwable
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
このオブジェクトの全てのリソースを破棄します。

例外:
Throwable
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LockMonitor (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス LockMonitor

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.LockMonitor
public class LockMonitor
extends Object

このクラスはモニター機能を提供します。
このクラスでは、複数個のモニターを管理することができます。 アプリケーションでは、entry() メソッドによりモニターを取得し、 release() メソッドでモニターを開放します。

導入されたバージョン:
version 5.0

コンストラクタの概要
LockMonitor(int max)
モニターを構築します。
メソッドの概要
int | activeCount() 現在取得済みモニターの数を取得します。
void | entry() モニターの取得。
int | queue() モニターを取得するための待ち行列に入っているスレッドの数です。
void | release() モニターの開放。
int | size() このオブジェクトの管理するモニターの数を取得します。
int | total() モニターを利用中、または利用しようとしているスレッドの数です。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LockMonitor

public LockMonitor(int max)
モニターを構築します。

パラメータ:
max - 管理するモニターの個数
メソッドの詳細

entry

public void entry()
モニターの取得。

モニターを取得できるまでブロックします。 モニターの取得＝動作の権利を取得

size

public int size()
このオブジェクトの管理するモニターの数を取得します。

戻り値:
モニターの数

activeCount

public int activeCount()
現在取得済みモニターの数を取得します。

戻り値:
取得済みモニターの数

total

public int total()
モニターを利用中、または利用しようとしているスレッドの数です。

戻り値:
entry() メソッドを実行して release() メソッドを実行していないスレッドの数
導入されたバージョン:
version 4.2

queue

public int queue()
モニターを取得するための待ち行列に入っているスレッドの数です。

戻り値:
entry() メソッドを実行して、ブロック状態になっているスレッドの数
導入されたバージョン:
version 4.2

release

public void release()
モニターの開放。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MultipurposeInternetMailExtensions (im_jdk_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jdk.util
クラス MultipurposeInternetMailExtensions

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
public class MultipurposeInternetMailExtensions
extends Object

MIME タイプを持つオブジェクトです。

導入されたバージョン:
version 5.0

コンストラクタの概要
MultipurposeInternetMailExtensions(File path)
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String filename)
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String mediaType, String subType)
指定のMIMEタイプを表すオブジェクトを構築します。
メソッドの概要
String | getMediaType() このオブジェクトが表す MIME タイプの Media Type を返します。
String | getSubType() このオブジェクトが表す MIME タイプの subtype を返します。
String | getType() このオブジェクトが表す MIME タイプを返します。
String | toString() このオブジェクトの文字列表現を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String filename)
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 filename の拡張子により解決されます。
引数 filename に拡張子がない場合や、拡張子から MIME タイプを解決 出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
filename - ファイル名

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(File path)
MIMEタイプを表すオブジェクトを構築します。

MIME タイプは引数 path の表すファイル名の拡張子により解決されます。
引数 path の表すファイル名に拡張子がない場合や、拡張子から MIME タイプを 解決出来なかった場合には、オブジェクトの表す MIME タイプは application/octet-stream となります。

パラメータ:
path - ファイル名を表す File クラスのインスタンス

MultipurposeInternetMailExtensions

public MultipurposeInternetMailExtensions(String mediaType,
                                          String subType)
指定のMIMEタイプを表すオブジェクトを構築します。

このコンストラクタにより構築されたオブジェクトの表す MIME タイプは、 mediaType "/" subType となります。

パラメータ:
mediaType - メディアタイプを表すキーワード
subType - サブタイプを表すキーワード
メソッドの詳細

getMediaType

public String getMediaType()
このオブジェクトが表す MIME タイプの Media Type を返します。

戻り値:
Media Type を表す文字列

getSubType

public String getSubType()
このオブジェクトが表す MIME タイプの subtype を返します。

戻り値:
subtype を表す文字列

getType

public String getType()
このオブジェクトが表す MIME タイプを返します。

戻り値:
MIME タイプを表す文字列

toString

public String toString()
このオブジェクトの文字列表現を返します。

戻り値:
MIME タイプを表す文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jdk.util (im_jdk_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jdk.util
インタフェース
ErrorEventListener
EventListener
クラス
Counter
ErrorEvent
EventQueueController
LockMonitor
MultipurposeInternetMailExtensions


jp.co.intra_mart.common.aid.jdk.util (im_jdk_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ErrorEventListener | 例外をイベントとして扱うためのスケルトン実装を提供します。
EventListener | このクラスは、イベントリスナーのインターフェースです。

クラスの概要
Counter | このクラスは、カウンター機能を提供します。
ErrorEvent | 例外をイベントとして扱うためのプロトコルです。
EventQueueController | このクラスは、イベントリスナーを実行するイベント機能を実装します。
LockMonitor | このクラスはモニター機能を提供します。
MultipurposeInternetMailExtensions | MIME タイプを持つオブジェクトです。

パッケージ jp.co.intra_mart.common.aid.jdk.util の説明

このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jdk.util クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jdk.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener


パッケージ jp.co.intra_mart.common.aid.jdk.util の使用 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jdk.util の使用

jp.co.intra_mart.common.aid.jdk.util を使用しているパッケージ
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jdk.java.io により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
ErrorEventListener
例外をイベントとして扱うためのスケルトン実装を提供します。

jp.co.intra_mart.common.aid.jdk.util により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
ErrorEvent
例外をイベントとして扱うためのプロトコルです。
EventListener
このクラスは、イベントリスナーのインターフェースです。

jp.co.intra_mart.common.aid.jdk.util.report により使用される jp.co.intra_mart.common.aid.jdk.util のクラス
EventQueueController
このクラスは、イベントリスナーを実行するイベント機能を実装します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


すべてのクラス (im_jdk_assist 6.1.14 API)

 すべてのクラス
AbstractDualComparator
AbstractMessageReporter
AbstractSocketConnectionDistributor
AdvancedOutputStreamWriter
BASE64DecodeInputStream
BASE64DecodeOutputStream
BASE64EncodeOutputStream
CharacterEncoder
CharacterMappingBuilder
CharacterSetManager
Counter
DOMBuilder
DOMInfo
Directory
DualComparator
ElementProperties
ErrorEvent
ErrorEventListener
EventListener
EventQueueController
EverydayConditioner
ExtendedClassLoader
ExtendedDirectory
ExtendedFile
ExtendedInputStream
ExtendedOutputStream
ExtendedProperties
ExtendedSocket
ExtendedThread
FileReporter
FileResourceBundle
FileSizeConditioner
FileUtil
FilterComparator
FilterMessageReporter
FixedSizeMap
HexInputStream
HexOutputStream
LineReportFilter
LocaleUtil
Localhost
LockMonitor
LuxuryClassLoader
MessageReporter
MultiCastReporter
MultiComparator
MultipleOutputStream
MultipurposeInternetMailExtensions
NumberUtil
OutputSizeConditioner
PeriodicConditioner
PrintStreamReporter
PropertiesUtil
ReplaceWriter
ReportFileConditioner
ReportFileWriter
ReportLevel
ReportLevelFilter
RepresentativeReporter
ResourceBundleProperties
ResourceFormatException
ResourceLoader
ResourceNotFoundException
ReverseComparator
SearchableClassLoader
SequenceComparator
ShutdownEventController
ShutdownListener
SocketConnection
SocketConnectionDistributor
SocketConnectionManager
SocketEventListener
SocketPool
StdErr
StdOut
StringUtil
ThreadStopListener
ThrowablePrintListener
TrimmedFilterReader
TrimmedFilterWriter
URLDecodeInputStream
URLDecodeOutputStream
URLEncodeOutputStream
UnlimitedBufferedOutputStream
UnsupportedNetworkConnectException
XMLProperties
XORInputStream
XOROutputStream
XmlNode


定数フィールド値 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder
public static final String CONFIG_FILE_PATH "jp/co/intra_mart/resources/charset/encoding/mapping.xml"

jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | TYPE_DEBUG | 0
public static final int | TYPE_ERROR | 3
public static final int | TYPE_REPORT | 1
public static final int | TYPE_WARNING | 2

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし
A B C D E F G H I J L M N O P Q R S T U W X

A

AbstractDualComparator - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator.
２つのコンパレータを使用してソートを行うクラスです。
AbstractDualComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のコンストラクタ
新しいオブジェクトを生成します。
AbstractMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter.
メッセージ出力用のスケルトンクラスです。
AbstractMessageReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のコンストラクタ
唯一のコンストラクタ。
AbstractSocketConnectionDistributor - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor.
このクラスは、通信ソケットを作成する機能を提供します。
AbstractSocketConnectionDistributor(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のコンストラクタ
ソケット作成オブジェクトを構築します。
AdvancedOutputStreamWriter - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter.
このクラスは、基礎となる java.io.OutputStreamWriter をフィルタリングした Writer 機能を提供します。
AdvancedOutputStreamWriter(OutputStream, String) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
指定された文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
デフォルトの文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, Charset) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStream, CharsetEncoder) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
与えられた文字エンコーディングエンコーダを使う AdvancedOutputStreamWriter を作成します。
AdvancedOutputStreamWriter(OutputStreamWriter) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のコンストラクタ
OutputStreamWriter をフィルタリングする新しい AdvancedOutputStreamWriter を作成します。
activeCount() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
現在取得済みモニターの数を取得します。
addAttr(String, String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
属性を追加します。
addClassArchive(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader のメソッド
クラスパスに指定のアーカイブファイルを追加します。
addClassArchive(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイルを追加します。
addClassArchiveLibrary(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスに指定のアーカイブファイル格納ディレクトリを追加します。
addClassPath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
クラスパスを追加します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addCloseSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットをクローズしたイベントを通知するためのリスナーを 設定します。
addComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparator を追加します。
addConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 追加登録。
addCreateSocketEventListener(SocketEventListener) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
ソケットを新規に作成したイベントを通知するためのリスナーを 設定します。
addListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを登録します。
addNativePath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
クラスパスを追加します。
addNode(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
エレメントを追加します。
addNode(String, String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
相対パスのノードにエレメントを追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を追加します。
addOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を追加します。
addReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象に追加します。
addSearchPath(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のメソッド
指定されたパスがファイルを表している場合、jar または zip を指定されたと判断して、 ResourceLoader.addClassArchive(File)を呼び出します。
addThreadStopListener(ThreadStopListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このスレッドが終了したときに呼び出されるイベントリスナーを登録します。
append(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
append(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
archive(File) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(File, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定のファイルにバックアップします。
archive(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(OutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。
archive(ZipOutputStream, FileFilter) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリ内にあるすべてのファイルを 指定の圧縮用出力ストリームに ZIP ファイル形式で出力します。

B

BASE64DecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream.
このクラスは、BASE64 エンコードされたデータを読み込むための ストリームフィルタを実装します。
BASE64DecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のコンストラクタ
指定された InputStream から読み込む BASE64 デコード入力ストリームを作成します。
BASE64DecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream.
このクラスは、BASE64 デコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64DecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
BASE64EncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream.
このクラスは、BASE64 エンコードされたデータを書き込むための ストリームフィルタを実装します。
BASE64EncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。
BASE64EncodeOutputStream(OutputStream, boolean) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64 エンコード出力ストリームを作成します。

C

CONFIG_FILE_PATH - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder の static 変数
マッピングを定義した定義ファイルのリストが記載されている定義ファイル名
CharacterEncoder - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder.
このクラスは、文字エンコードの機能を提供します。
CharacterEncoder(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のコンストラクタ
文字コード変換のためのエンコーダを作成します。
CharacterMappingBuilder - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder.
このクラスは、文字エンコードのマッピング定義を管理します。
CharacterSetManager - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager.
このクラスは J2SE,v1.4 でサポートされているエンコーディングセットと、 IANAに登録されているキャラクタセット名とのマッピング情報を管理するオブジェクトです。
CharacterSetManager() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager のコンストラクタ
Counter - class jp.co.intra_mart.common.aid.jdk.util.Counter.
このクラスは、カウンター機能を提供します。
Counter() - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
カウンターオブジェクトを作成します。
Counter(long) - class jp.co.intra_mart.common.aid.jdk.util.Counter のコンストラクタ
指定の初期値でカウンターオブジェクトを作成します。
canReport() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
このストリームが書き込み可能かどうかをチェックします。
capacity() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに対してマップできるキーの最大個数を返します。
childDirectories() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるサブディレクトリの抽象パスを 繰り返し処理する反復子を作成します。
childDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
childFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
childFiles() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
childPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
clean() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
プール中のコネクションをすべて破棄します。
clean() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
プール中のコネクションをすべて破棄します。
clear() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップからマッピングをすべて削除します。
clearError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外をすべて破棄します。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
ストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このストリームを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入出力ストリームおよびソケットを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトを閉じます。
close() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトを閉じます。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームを閉じてフラッシュします。
close() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームを閉じます。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
順序付けのために 2 つの引数を比較するメソッドです。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のメソッド
フィルタ対象のコンパレータの compare() メソッドの結果を反転させて返します。
compare(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のメソッド
順序付けのために ２ つの引数を比較するメソッドです。
connection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
コネクションの取得。
connection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクションの取得。
containsKey(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定されたキーへのマッピングをこのマップが格納する場合に true を返します。
createSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
新しいソケットを作成します。
createWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
メッセージをファイルへ書き出すための出力ストリームを作成します。
currentWriter() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出している基礎 Writer を返します。

D

DOMBuilder - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder.
XML解析クラス。
DOMBuilder() - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder のコンストラクタ
DOMBuilder(Document) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder のコンストラクタ
DOMInfo - interface jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo.
DOM情報インタフェース。
Directory - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory.
このクラスは、ディレクトリを扱う時に便利な機能を提供します。
Directory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
Directory(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
Directory(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
DualComparator - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator.
２つのコンパレータを使用してソートを行うためのインターフェースです。
datumpoint - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter の変数
このリポーターがフィルタリングする基準レベル値
decrement() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ減少させます。
delAttr(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
属性を削除します。
delNode() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードを削除します。
delNode(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
相対パスのノードを削除します。
delNode(XmlNode) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
ノードを削除します。
deleteAll() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリパスを削除します。
deleteChilds() - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
このディレクトリが持つファイルまたはサブディレクトリをすべて削除します。
destroy() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor のメソッド
このプールを破棄します。
destroy() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールを破棄します。
doubleValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue(String, double) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(double)表現された数値として取得します。
doubleValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を double 型として返します。

E

EMPTY_STRING - class jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil の static 変数
空文字列の定数値。
ElementProperties - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties.
DOM をベースとした不変のプロパティセットを表します。
ElementProperties(Element) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
ElementProperties(Element, Properties) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のコンストラクタ
指定のエレメントの情報をプロパティズ化します。
ErrorEvent - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent.
例外をイベントとして扱うためのプロトコルです。
ErrorEvent(Throwable, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEvent(Throwable, String, Object) - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のコンストラクタ
エラーを通知するためのイベントを構築します。
ErrorEventListener - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener.
例外をイベントとして扱うためのスケルトン実装を提供します。
EventListener - interface jp.co.intra_mart.common.aid.jdk.util.EventListener.
このクラスは、イベントリスナーのインターフェースです。
EventQueueController - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController.
このクラスは、イベントリスナーを実行するイベント機能を実装します。
EventQueueController() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EventQueueController(long) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のコンストラクタ
イベントリスナーを管理・実行するためのコントローラ・オブジェクトを 構築します。
EverydayConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner.
このクラスは、時間によりリフレッシュイベントを 発生させるためのヘルパークラスです。
EverydayConditioner(int, int, TimeZone) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のコンストラクタ
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
EverydayConditioner(int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のコンストラクタ
毎日定刻にリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
ExtendedClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader.
このクラスは、拡張されたクラスローダーです。
ExtendedClassLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ExtendedClassLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ExtendedDirectory - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory.
File インスタンスを作成するためのファクトリクラスです。
ExtendedDirectory(String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedDirectory(File, String, int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のコンストラクタ
File オブジェクトを作成するためのファクトリオブジェクトを作成します。
ExtendedFile - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile.
このクラスは、ファイルを扱う時に便利な機能を提供します。
ExtendedFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
指定されたパス名文字列を抽象パス名に変換して、 新しい File のインスタンスを生成します。
ExtendedFile(File, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親抽象パス名および子パス名文字列から新しい File のインスタンスを 生成します。
ExtendedFile(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のコンストラクタ
親パス名文字列および子パス名文字列から 新しい File のインスタンスを生成します。
ExtendedInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream.
このクラスは、標準の入力ストリームを拡張した機能を提供します。
ExtendedInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedInputStream(InputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のコンストラクタ
入力ストリームを構築します。
ExtendedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream.
このクラスは、標準の出力ストリームを拡張した機能を提供します。
ExtendedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedOutputStream(OutputStream, ErrorEventListener) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のコンストラクタ
出力ストリームを構築します。
ExtendedProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties.
java.util.Properties を、より便利に利用するためのインタフェースを提供します。
ExtendedProperties() - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
デフォルト値を持たない空のプロパティリストを作成します。
ExtendedProperties(Properties) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のコンストラクタ
指定されたデフォルト値を持つ空のプロパティリストを作成します。
ExtendedSocket - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket.
このクラスは、ソケット通信用の入出力機能を提供します。
ExtendedSocket(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedSocket(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のコンストラクタ
ソケットを構築します。
ExtendedThread - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ExtendedThread() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
ExtendedThread(ThreadGroup, Runnable, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のコンストラクタ
Constructor for ExtendedThread.
eject(SocketConnection) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
指定コネクションをこのプールの管理から切り離します。
encode(char) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
encode(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
指定の文字列を CharacterEncoder.getCharacterEncoding() で表される文字コードへ エンコードします。
entry(EventListener) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
イベントリスナーの登録。
entry() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの取得。
entrySet() - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このマップに格納されているマッピングのセットビューを返します。
errorIterator() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド実行中に発生した例外を返します。
eventGenerating() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに登録されているイベントリスナーを一つ実行します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。
expiration(ReportFileWriter) - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner のメソッド
メッセージファイルを再作成する必要があるかどうかを判定します。

F

FileReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter.
メッセージのファイル出力機能を提供します。
FileReporter(ReportFileWriter) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
FileResourceBundle - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle.
FileResourceBundle(String) - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のコンストラクタ
プロパティリソースを作成します。
FileResourceBundle(String, Locale) - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のコンストラクタ
プロパティリソースを作成します。
FileResourceBundle(String, String) - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のコンストラクタ
プロパティリソースを作成します。
FileResourceBundle(String, String, Locale) - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のコンストラクタ
プロパティリソースを作成します。
FileSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
FileSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner のコンストラクタ
メッセージファイルのサイズによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
FileUtil - class jp.co.intra_mart.common.aid.jdk.java.io.FileUtil.
Fileユーティリティクラス。
FilterComparator - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator.
コンパレータのフィルターとして機能する抽象クラスです。
FilterComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のコンストラクタ
指定されれたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
FilterMessageReporter - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter.
メッセージ出力ストリームをフィルタ処理するクラスのスーパークラスです。
FilterMessageReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む フィルターオブジェクトを作成します。
FixedSizeMap - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap.
LRU(Least Recently Used) アルゴリズムによる Map インターフェースの実装を提供します。
FixedSizeMap(int) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のコンストラクタ
指定されたサイズの領域を持つマップを構築します。
files(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルの抽象パスを 繰り返し処理する反復子を作成します。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
このオブジェクトをクリーンアップします。
finalize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このオブジェクトへの参照はもうないとガーベージコレクションによって 判断されたときに、ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
finalize() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトがガーベージコレクションによって破棄される時に、 ガーベージコレクタによって呼び出されます。
findClass(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
指定されたクラスを探します。
findDirectory(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedDirectory オブジェクトを返します。
findFile(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される ExtendedFile オブジェクトを返します。
findLibrary(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
ネイティブライブラリの絶対パス名を返します。
findPath(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
このディレクトリを親ディレクトリとして path で表される File オブジェクトを返します。
findResource(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つリソースを探します。
findResources(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
指定された名前を持つすべてのリソースを表す URL の Enumeration を返します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
出力ストリームへのエンコードデータの書き込みを終了します。
finish() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
バッファに保存してあるデータを書き出します。
fire() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
スレッド実行されるロジック。
floatValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue(String, float) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 浮動小数点数(float)表現された数値として取得します。
floatValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を float 型として返します。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
書き出しストリーム内のデータをすべて出力。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
この出力ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
この出力ストリームをフラッシュし、 バッファに入っている出力バイトをすべて強制的に書き込みます。
flush() - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューに溜まっているすべてのイベントリスナーを実行します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
このオブジェクトのバッファの情報をすべて出力します。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
ストリームをフラッシュします。
flush() - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
ストリームをフラッシュします。

G

get(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
マップが、指定されたキーにマッピングしている値を返します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
アドレスを返します。
getAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのＩＰアドレスを返します。
getBytes() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
この抽象パスが表すファイルからデータを読み込みます。
getCapacity() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
コネクション作成最大数の取得。
getCapacity() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
コネクション作成最大数の取得。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象としている文字エンコーディング名を返します。
getChildNode() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
属性および子ノードの一覧を取得します。
getClassArchives() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスアーカイブパスを返します。
getClassPaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のメソッド
このクラスローダーに設定されているクラスパスを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットに登録されているクローズ・イベント・リスナーを返します。
getCloseSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットをクローズしたイベントを通知するためのリスナーを 返します。
getComparators() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
設定されている全てのコンパレータを取得します。
getCreateSocketEventListeners() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールに登録されている ソケットを新規に作成したイベントを通知するためのリスナーを 返します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
このクラスがロードされた時点の、System.err を 返します。
getDefaultPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
このクラスがロードされた時点の、System.out を 返します。
getDocument() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のメソッド
設定ファイルのドキュメントノードを返します。
getDocumet() - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder のメソッド
ドキュメントノードの取得。
getDocumet() - interface jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo のメソッド
ドキュメントノードの取得。
getDouble(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getDouble(String, double) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getElement() - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
現在のプロパティズの元となったエレメントノードを返します。
getException() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーまたは例外を取得します。
getFile() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このオブジェクトが文字を書き出すファイルを取得します。
getFloat(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getFloat(String, float) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getHostAddress() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのアドレスを返します。
getHostName() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost のメソッド
このコンピュータのホスト名を返します。
getImplementedClasses(Class) - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のメソッド
指定されたクラスと代入互換のあるインスタンスを生成できるクラスを検索します。
getInputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
入力ストリームの取得。
getInteger(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getInteger(String, int) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getKeys() - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のメソッド
キーの列挙を返します。
getLocale() - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のメソッド
ロケールを返します。
getLocale() - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のメソッド
ResourceBundle の Locale を返します。
getLong(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getLong(String, long) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を数値として取得します。
getMapping(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder のメソッド
文字の修正用マッピングを返します。
getMediaType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの Media Type を返します。
getMessage() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラーメッセージを取得します。
getNativePaths() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader のメソッド
このクラスローダーに設定されているネイティブライブラリパスを返します。
getNode() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードのDOMノードオブジェクトを取得します。
getNodeList() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
下階層からすべてのノードを取得します。
getNodeName() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
ノードの名前を取得します。
getObject() - class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent のメソッド
通知されたエラー発生オブジェクトを取得します。
getOldestLastModifiedInDir(File) - class jp.co.intra_mart.common.aid.jdk.java.io.FileUtil の static メソッド
指定ディレクトリ直下のファイル群の中で一番古い更新日付を返却します。
getOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
出力ストリームの取得。
getOutputStreamWriter() - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
このオブジェクトの基礎出力となっている java.io.OutputStreamWriter を返します。
getParentComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator のメソッド
フィルター対象のコンパレータを返します。
getPort() - class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor のメソッド
ポートを返します。
getPrimaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
１番目コンパレータを取得します。
getPrimaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第１コンパレータを返します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージを出力する出力ストリームを返します。
getPrintStream() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージを出力する出力ストリームを返します。
getProperties(String) - class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties のメソッド
指定のキーにマップされた値のリストを返します。
getReporters() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
セット内の要素についての反復子を返します。
getRootNode() - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder のメソッド
ルートノードの取得。
getRootNode() - interface jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo のメソッド
ルートノードの取得。
getSecondaryComparator() - interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator のメソッド
２番目コンパレータを取得します。
getSecondaryComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
第２コンパレータを返します。
getShutdownListeners() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
現在登録されているリスナを返します。
getSize() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
このプールが現在管理しているコネクション数です。
getSize() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
このプールが現在管理しているコネクション数です。
getSocket() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このオブジェクトの持つソケットオブジェクトを返します。
getString(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を文字列として取得します。
getString(String, String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値を文字列として取得します。
getSubType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプの subtype を返します。
getThrowablePrintListener() - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
現在の例外出力リスナを返します。
getType() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトが表す MIME タイプを返します。
getURI() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードのフルパスを取得します。
getURI(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードのフルパスを取得します。
getValue() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの値を文字列として取得します。
getValue(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの値を文字列として取得します。

H

HexInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream.
このクラスは、16進数表現されたデータを読み込むための ストリームフィルタを実装します。
HexInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のコンストラクタ
指定された InputStream から読み込む HexInputStream を作成します。
HexOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream.
このクラスは、16進数表現されたデータを書き込むための ストリームフィルタを実装します。
HexOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のコンストラクタ
指定された OutputStream に書き込む HexOutputStream を作成します。
handleError(ErrorEvent) - interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener のメソッド
発生した例外を通知します。
handleEvent() - interface jp.co.intra_mart.common.aid.jdk.util.EventListener のメソッド
イベントが発生した時にコントローラから呼び出されます。
handleGetObject(String) - class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle のメソッド
キーに対応したオブジェクトを返します。
handleShutdown() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleShutdown() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
シャットダウンイベントが発生したときに実行されるメソッドです。
handleSocketEvent(ExtendedSocket) - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener のメソッド
ソケットに関するイベント発生時に呼び出されるメソッド。
handleThreadStop() - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener のメソッド
監視していたスレッドが終了したときに実行されるメソッドです。
hasReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のオブジェクトをこのオブジェクトの要素として持っているかどうか 判定します。

I

in - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream の変数
フィルタ処理される入力ストリームです。
increment() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの値を１だけ増加させます。
instance() - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost の static メソッド
このクラスから生成される唯一のインスタンスを返します。
instance() - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder の static メソッド
ビルダを返します。
intValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 数値として取得します。
intValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を int 型として返します。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
この入出力ストリームが閉じられているかチェックします。
isClosed() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このソケットが閉じられているかどうかをチェックします。
isFalse(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isFalse(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値が偽値であるかチェックします。
isShutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウン中（またはシャットダウン処理終了）かどうかを判定。
isTrue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を真偽判定します。
isTrue(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの値が真値であるかチェックします。
isValid(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードの存在をチェックします。

J

join(Collection, String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil の static メソッド
コレクションの連結。
join(Object[], String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil の static メソッド
オブジェクト配列の連結。
jp.co.intra_mart.common.aid.jdk.java.io - package jp.co.intra_mart.common.aid.jdk.java.io
このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file - package jp.co.intra_mart.common.aid.jdk.java.io.file
このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang - package jp.co.intra_mart.common.aid.jdk.java.lang
このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net - package jp.co.intra_mart.common.aid.jdk.java.net
ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util - package jp.co.intra_mart.common.aid.jdk.java.util
このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml - package jp.co.intra_mart.common.aid.jdk.javax.xml
このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom - package jp.co.intra_mart.common.aid.jdk.org.w3c.dom
このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util - package jp.co.intra_mart.common.aid.jdk.util
このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset - package jp.co.intra_mart.common.aid.jdk.util.charset
このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report - package jp.co.intra_mart.common.aid.jdk.util.report
このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

L

LineReportFilter - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter.
メッセージを行出力するためのフィルタークラスです。
LineReportFilter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のコンストラクタ
指定された基礎出力ストリームにメッセージを一行書き込む フィルターストリームを作成します。
LocaleUtil - class jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil.
ロケールユーティリティクラス。
Localhost - class jp.co.intra_mart.common.aid.jdk.java.net.Localhost.
このクラスは、サーバプロセスの基礎情報を管理します。
LockMonitor - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor.
このクラスはモニター機能を提供します。
LockMonitor(int) - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のコンストラクタ
モニターを構築します。
LuxuryClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader.
このクラスは、拡張されたクラスローダーです。
LuxuryClassLoader(File) - class jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
LuxuryClassLoader(ClassLoader, File) - class jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
lastError() - class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket のメソッド
このインスタンスのメソッド中で最後に発生した例外を返します。
length() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
このライターの出力文字数を取得します。
longValue(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue(String, long) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
指定されたキーによって示されるプロパティ値を 長整数として取得します。
longValue() - class jp.co.intra_mart.common.aid.jdk.util.Counter のメソッド
カウンターの現在の値を long 型として返します。
lookup(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードを取得します。
lookup(List) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
子ノードを取得します。

M

MAX_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最大値 この値は、java.lang.Integer.MAX_VALUE と同じです。
MIN_VALUE - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
レベル値として使用可能な最小値 この値は、java.lang.Integer.MIN_VALUE と同じです。
MessageReporter - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter.
メッセージ出力のためのインターフェースです。
MultiCastReporter - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter.
メッセージを複数のストリームに出力するためのフィルタークラスです。
MultiCastReporter() - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のコンストラクタ
唯一のコンストラクタ。
MultiComparator - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator.
複数のコンパレータを使用してソートを行うためにクラスです。
MultiComparator(Comparator, Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のコンストラクタ
第１コンパレータ 、第２コンパレータを指定して、新しいオブジェクトを生成します。
MultipleOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream.
複数の出力ストリームにバイトを書き出すためのフィルタ実装です。
MultipleOutputStream() - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のコンストラクタ
唯一のコンストラクタ
MultipurposeInternetMailExtensions - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions.
MIME タイプを持つオブジェクトです。
MultipurposeInternetMailExtensions(String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(File) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
MIMEタイプを表すオブジェクトを構築します。
MultipurposeInternetMailExtensions(String, String) - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のコンストラクタ
指定のMIMEタイプを表すオブジェクトを構築します。

N

NumberUtil - class jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil.
数値型に関するユーティリティクラス。
NumberUtil() - class jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil のコンストラクタ
コンストラクタ。
newDocument(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
DOMを新規に作成します。
newDocument(String, EntityResolver) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
DOMを新規に作成します。
newDocument(String, String, String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
DOMを新規に作成します。
newDocument(String, String, String, EntityResolver) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
DOMを新規に作成します。
newInstance(Document) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ドキュメントからDOM情報を取得します。
newInstance(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ファイルからXMLを解析してDOM情報を作成します。
newInstance(String, EntityResolver) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ファイルからXMLを解析してDOM情報を作成します。
newInstance(File) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ファイルクラスからXMLを解析してDOM情報を作成します。
newInstance(File, EntityResolver) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ファイルクラスからXMLを解析してDOM情報を作成します。
newInstance(InputStream) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ストリームからXMLを解析してDOM情報を作成します。
newInstance(InputStream, EntityResolver) - class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder の static メソッド
ストリームからXMLを解析してDOM情報を作成します。
newString(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。
newString(char[]) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
CharacterEncoder.getCharacterEncoding() で表される文字コードに対応した 新しい文字列を作成します。

O

OutputSizeConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner.
このクラスは、メッセージファイルのサイズによりリフレッシュイベントを 発生させるためのヘルパークラスです。
OutputSizeConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner のコンストラクタ
メッセージファイルへのデータ出力量によりリフレッシュイベントを 発生させるためのヘルパーオブジェクトを構築します。
out - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream の変数
フィルタ処理される基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter の変数
基礎出力ストリームです。
out - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter の変数
基礎出力ストリームです。

P

PeriodicConditioner - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner.
このクラスは、タイマーによりリフレッシュイベントを 発生させるためのヘルパークラスです。
PeriodicConditioner(long) - class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner のコンストラクタ
タイマーによりリフレッシュイベントを発生させるための ヘルパーオブジェクトを構築します。
PrintStreamReporter - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter.
メッセージ出力用クラスです。
PrintStreamReporter(PrintStream) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のコンストラクタ
指定された基礎出力ストリームにメッセージを書き込む Reporter オブジェクトを作成します。
PropertiesUtil - class jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil.
java.util.Properties を、より便利に利用するためのインタフェースを提供します。
parseInt(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き整数として解析します。
parseLong(String, int) - class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties のメソッド
2 番目の引数に指定された基数を元にして、 指定されたキーによって示されるプロパティ値を 符号付き長整数として解析します。
paths(int) - class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory のメソッド
この抽象パス名が示すディレクトリにあるファイルおよびディレクトリの 抽象パスを繰り返し処理する反復子を作成します。
printMessage(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のメッセージを出力します。
printStackTrace(Throwable) - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener のメソッド
例外のスタックトレースを出力します。
put(Object, Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
指定された値を、マップ内の指定されたキーに関連付けます 。

Q

queue() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを取得するための待ち行列に入っているスレッドの数です。

R

ReplaceWriter - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter.
このクラスは、部分文字列を別な部分文字列へ置換しながら ストリームに文字列を書き込むためのストリームフィルタを実装します。
ReplaceWriter(Writer, char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列削除のためのストリームフィルタを作成します。
ReplaceWriter(Writer, char[], char[]) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReplaceWriter(Writer, String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のコンストラクタ
文字列置換のためのストリームフィルタを作成します。
ReportFileConditioner - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner.
このクラスは、ReportFileWriter の初期化チェックのインターフェースです。
ReportFileWriter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter.
メッセージをファイルに出力するストリームクラスです。
ReportFileWriter(File) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のコンストラクタ
ファイルへメッセージを書き出すためのライターオブジェクトを作成します。
ReportLevel - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel.
メッセージレベルのインターフェースです。
ReportLevelFilter - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter.
メッセージの出力制御を行うためのフィルタークラスです。
ReportLevelFilter(MessageReporter, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のコンストラクタ
指定された基礎出力リポーターにメッセージを書き込む Reporter オブジェクトを作成します。
RepresentativeReporter - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter.
メッセージ出力をイベント処理するためのフィルタークラスです。
RepresentativeReporter(MessageReporter, EventQueueController) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のコンストラクタ
指定された出力ストリームにメッセージを書き込む イベントストリームを作成します。
ResourceBundleProperties - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties.
このクラスは、java.util.Properties クラスのインターフェースを実装した、 プロパティ管理クラスです。
ResourceBundleProperties(String) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceBundleProperties(String, Locale, ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties のコンストラクタ
リソースバンドルをプロパティズとして表現したオブジェクトを作成します。
ResourceFormatException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException.
リソースの内容が不適切であることを通知する例外です。
ResourceFormatException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceFormatException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ResourceLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader.
このクラスは、ローカルファイルシステムからリソースファイルを検索するクラスローダーの拡張実装です。
ResourceLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
このクラスをロードした ClassLoader を親クラスローダとして使用し、 新しいクラスローダを作成します。
ResourceLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader のコンストラクタ
指定された親クラスローダを使って、 委譲のために新しいクラスローダを作成します。
ResourceNotFoundException - exception jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException.
リソースがないことを通知する例外です。
ResourceNotFoundException(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージを使用して、新規スロー可能オブジェクトを構築します。
ResourceNotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規スロー可能オブジェクトを構築します。
ReverseComparator - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator.
コンパレータのフィルタとして機能します。
ReverseComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator のコンストラクタ
指定されたコンパレータ comparator をフィルター対象として、新しいオブジェクトを生成します。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
データ取得。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream のメソッド
デコードデータのバイトを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
単一の文字を読み込みます。
read(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のメソッド
配列の一部に文字を読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のメソッド
入力ストリームからバイト配列に最大 len バイトのデータを読み込みます。
read() - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
デコードデータのバイトを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のメソッド
入力ストリームからバイト配列へ最大 len バイトのデータを読み込みます。
readBoolean() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
boolean 型データ取得。
readInt() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
int 型データ取得。
readLines() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLines(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
ファイルの行を繰り返し処理する反復子を作成します。
readLong() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
long 型データ取得。
readObject() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
Object の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream のメソッド
文字列の取得。
readString() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
readString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
このオブジェクトの抽象パスが表すファイルからデータを読み込みます。
reconstruction() - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
現在使用中の Writer をリセットします。
release() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のメソッド
ソケットおよび入出力ストリームの利用を中止します。
release() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターの開放。
remove(Object) - class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap のメソッド
このキーにマッピングがある場合に、そのマッピングをマップから削除します。
removeComparator(Comparator) - class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator のメソッド
指定されたコンパレータ comparatorを削除します。
removeConditioner(ReportFileConditioner) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
ログファイルのローテイト機能などを実装するためのチェッカーオブジェクトの 削除。
removeListener(ShutdownListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
シャットダウンリスナーを削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
メッセージの出力先を削除します。
removeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
メッセージの出力先を削除します。
removeReporter(MessageReporter) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
指定のリポーターオブジェクトをこのオブジェクトの出力対象から 削除します。
removeValue() - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの値を削除します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter のメソッド
基礎出力ストリームに対してメッセージを出力します。
report(String) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
メッセージを出力します。
report(Object) - interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter のメソッド
data をメッセージとして出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter のメソッド
メッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
メッセージを出力します。
report(String, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
data をメッセージとして出力します。
report(Object, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter のメソッド
指定のメッセージレベルが基準値以上のメッセージを出力します。
report(String) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
メッセージを出力します。
report(Object) - class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter のメソッド
data をメッセージとして出力します。
reset() - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory のメソッド
キャッシュ領域をクリアします。
reset(Writer) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
文字の出力ストリームをリセットします。
run() - class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread のメソッド
このオブジェクトのスレッド実行ロジックです。

S

SearchableClassLoader - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader.
ユーティリティ的な実装を提供するクラスローダです。
SearchableClassLoader() - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のコンストラクタ
新しいクラスローダを生成します。
SearchableClassLoader(ClassLoader) - class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader のコンストラクタ
指定された親クラスローダを使って、委譲のために新しいクラスローダを作成します。
SequenceComparator - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator.
挿入順にソートするためのコンパレータです。
SequenceComparator() - class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator のコンストラクタ
新しいオブジェクトを生成します。
ShutdownEventController - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController.
このクラスは、サーバプロセスの基礎ロジック。
ShutdownListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener.
シャットダウンイベント時に実行する任意のロジックを実装するためのインターフェースです。
SocketConnection - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection.
ソケットプール用のスケルトン実装を提供します。
SocketConnection(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(Socket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnection(ExtendedSocket) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection のコンストラクタ
ソケット入出力インスタンスを構築します。
SocketConnectionDistributor - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor.
このクラスは、通信ソケットをプールする機能を提供します。
SocketConnectionManager - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager.
通信ソケットをプールする機能のインターフェースです。
SocketEventListener - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener.
通信ソケットに関するイベント発生を受け取るためのスケルトン実装です。
SocketPool - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool.
このクラスは、通信ソケットをプールする機能を提供します。
SocketPool(String, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
SocketPool(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のコンストラクタ
ソケットプールを構築します。
StdErr - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr.
このクラスは、エラーメッセージ出力用です。
StdOut - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut.
このクラスは、システムメッセージ出力用です。
StringUtil - class jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil.
文字列ユーティリティクラス。
select(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの子ノードのリストを取得します。
setCapacity(int) - class jp.co.intra_mart.common.aid.jdk.util.EventQueueController のメソッド
キューの容量を変更します。
setCharacterEncoding(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder のメソッド
このオブジェクトが対象とする文字エンコーディングを設定します。
setNodeName(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの名前を変更します。
setThrowablePrintListener(ThrowablePrintListener) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定の例外出力リスナを割り当て直します。
setValue(String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの値を設定します。
setValue(String, String) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のメソッド
このノードの子ノードの値を設定します。
shutdown() - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
shutdown(int) - class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController の static メソッド
このプロセスを終了します。
size() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
このオブジェクトの管理するモニターの数を取得します。
store(Properties, OutputStream, String) - class jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil の static メソッド
Properties テーブル内のプロパティリスト (キーと要素のペア) を、load メソッドを使って Properties テーブルにロードするのに適切なフォーマットで出力ストリームに書き込みます。

T

TYPE_DEBUG - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
デバッグレベル。
TYPE_ERROR - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
エラーレベル。
TYPE_REPORT - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
通常の情報レベル。
TYPE_WARNING - interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel の static 変数
警告レベル。
ThreadStopListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
ThrowablePrintListener - interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener.
このインタフェースは、例外情報を出力するためのものです。
TrimmedFilterReader - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader.
このクラスは、基礎となる java.io.Reader をフィルタリングした Writer 機能を提供します。
TrimmedFilterReader(Reader) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader のコンストラクタ
Reader をフィルタリングする新しい TrimmedFilterReader を作成します。
TrimmedFilterWriter - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter.
このクラスは、基礎となる java.io.Writer をフィルタリングした Writer 機能を提供します。
TrimmedFilterWriter(Writer) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のコンストラクタ
Writer をフィルタリングする新しい TrimmedFilterWriter を作成します。
toDouble(Object, double) - class jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil の static メソッド
オブジェクトを倍精度実数に変換します。
toIANAName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたエンコーディングセット名に対応する IANAに登録されている キャラクタセット名 を返却します。
toInt(Object, int) - class jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil の static メソッド
オブジェクトを整数に変換します。
toJDKName(String) - class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager の static メソッド
指定されたキャラクタセット名 に対応する J2SEでサポートされているエンコーディングセット名を返却します。
toLocale(String) - class jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil の static メソッド
ロケール文字列をロケールクラスに変換する。
toString() - class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions のメソッド
このオブジェクトの文字列表現を返します。
total() - class jp.co.intra_mart.common.aid.jdk.util.LockMonitor のメソッド
モニターを利用中、または利用しようとしているスレッドの数です。

U

URLDecodeInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream.
このクラスは、URL デコードされたデータを読み込むための ストリームフィルタを実装します。
URLDecodeInputStream(InputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream のコンストラクタ
指定された InputStream から URL デコードしながらバイトを読み込む 入力ストリームを作成します。
URLDecodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream.
このクラスは、URL デコードされたデータを書き込むための ストリームフィルタを実装します。
URLDecodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のコンストラクタ
指定された OutputStream に書き込む URLデコーダーを作成します。
URLEncodeOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream.
このクラスは、URL エンコードされたデータを書き込むための ストリームフィルタを実装します。
URLEncodeOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のコンストラクタ
指定された OutputStream に書き込む BASE64デコーダーを作成します。
UnlimitedBufferedOutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream.
出力データを一時的にバッファリングする出力ストリームの実装です。
UnlimitedBufferedOutputStream(OutputStream) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のコンストラクタ
出力データをバッファリングするためのフィルター出力ストリームを 新しく作成します。
UnsupportedNetworkConnectException - exception jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException.
To change this generated comment edit the template variable "typecomment": Window>Preferences>Java>Templates.
UnsupportedNetworkConnectException() - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
UnsupportedNetworkConnectException(String) - class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException のコンストラクタ
Constructor for UnsupportedNetworkConnectException.
usableConnection() - interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager のメソッド
現在待機中のコネクションをです。
usableConnection() - class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool のメソッド
現在待機中のコネクションをです。

W

write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
指定されたバイトを書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オフセット off から始まる指定のバイト配列から この出力ストリームに len バイトを書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream のメソッド
指定のバイトを 設定されている各出力先へ書き出します。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
単一文字を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter のメソッド
文字列の一部を基礎ストリームに書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter のメソッド
指定された文字が Java 空白文字でない場合に 単一文字を文字出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイトをデコードして出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定のバイトを出力します。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
指定された byte 配列の、オフセット位置 off から始まる len バイトを出力ストリームに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream のメソッド
b.length バイトのデータを出力ストリームに書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイトをエンコード出力ストリームに書き込みます。
write(byte[], int, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のメソッド
バイト列をエンコード出力ストリームに書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
デフォルトの文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(String, String) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定された文字列を指定の文字エンコーディングを使って このオブジェクトの表すファイルに書き込みます。
write(byte[]) - class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile のメソッド
指定されたバイト配列の b.length バイトをこのオブジェクトの表すファイルに 書き込みます。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String, Throwable) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr の static メソッド
指定のメッセージを標準エラー出力および指定の出力先に書き出します。
write(String) - class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut の static メソッド
指定のメッセージを標準出力および指定の出力先に書き出します。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字の配列の一部を書き込みます。
write(int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
単一の文字を書き込みます。
write(String, int, int) - class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter のメソッド
文字列の一部を書き込みます。
write(char[], int, int) - class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter のメソッド
基礎ストリームに文字を出力します。
writeBoolean(boolean) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
boolean 型データの送信。
writeInt(int) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
int 型データの送信。
writeLong(long) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
long 型データの送信。
writeObject(Object) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
オブジェクトの送信。
writeString(String) - class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream のメソッド
文字列の送信。

X

XMLProperties - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties.
XML をベースとした不変のプロパティセットを表します。
XMLProperties(File) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputStream, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XMLProperties(InputSource, Properties) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties のコンストラクタ
指定データを持つ新しいプロパティセットを作成します。
XORInputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream.
このクラスは、指定されたバイトとの排他論理和計算された結果の データを読み込むためのストリームフィルタを実装します。
XORInputStream(InputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream のコンストラクタ
指定された InputStream から指定されたバイトとの排他論理和を 取りながら読み込む XORInputStream を作成します。
XOROutputStream - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream.
このクラスは、指定のバイトデータとの排他論理和を計算した結果の バイトデータを書き込むためのストリームフィルタを実装します。
XOROutputStream(OutputStream, int) - class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream のコンストラクタ
指定された OutputStream に対して b との排他論理和を取ったバイトデータを書き込む XOROutputStream を作成します。
XmlNode - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode.
DOMノード操作クラス。
XmlNode(Attr) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のコンストラクタ
コンストラクタ。
XmlNode(Document) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のコンストラクタ
コンストラクタ。
XmlNode(Element) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のコンストラクタ
コンストラクタ。
XmlNode(Node) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のコンストラクタ
コンストラクタ。
XmlNode(Node, Node) - class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode のコンストラクタ
コンストラクタ。
A B C D E F G H I J L M N O P Q R S T U W X
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_jdk_assist 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_jdk_assist 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io
jp.co.intra_mart.common.aid.jdk.java.io.file
jp.co.intra_mart.common.aid.jdk.java.lang
jp.co.intra_mart.common.aid.jdk.java.net
jp.co.intra_mart.common.aid.jdk.java.util
jp.co.intra_mart.common.aid.jdk.javax.xml
jp.co.intra_mart.common.aid.jdk.org.w3c.dom
jp.co.intra_mart.common.aid.jdk.util
jp.co.intra_mart.common.aid.jdk.util.charset
jp.co.intra_mart.common.aid.jdk.util.report


概要 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_jdk_assist API Specifications

パッケージ
jp.co.intra_mart.common.aid.jdk.java.io | このパッケージには、アプリケーションを構築する際に利用すると 便利な入出力系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.io.file | このパッケージには、アプリケーションを構築する際に利用すると 便利なファイル系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.lang | このパッケージには、アプリケーションを構築する際に利用すると 便利な言語系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.java.net | ソケットによるネットワーク対応機能を実装するためのクラスを提供します。
jp.co.intra_mart.common.aid.jdk.java.util | このパッケージには、アプリケーションを構築する際に利用すると 便利なユーティリティ系汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.javax.xml | このパッケージには、ＸＭＬを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.org.w3c.dom | このパッケージには、ＤＯＭを利用するためのクラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util | このパッケージには、アプリケーションを構築する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.charset | このパッケージには、文字エンコーディングに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jdk.util.report | このパッケージには、ログ機能を実装するための汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.aid.jdk.java.io, jp.co.intra_mart.common.aid.jdk.java.io.file, jp.co.intra_mart.common.aid.jdk.java.lang, jp.co.intra_mart.common.aid.jdk.java.net, jp.co.intra_mart.common.aid.jdk.java.util, jp.co.intra_mart.common.aid.jdk.javax.xml, jp.co.intra_mart.common.aid.jdk.org.w3c.dom, jp.co.intra_mart.common.aid.jdk.util, jp.co.intra_mart.common.aid.jdk.util.charset, jp.co.intra_mart.common.aid.jdk.util.report

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator (implements jp.co.intra_mart.common.aid.jdk.java.util.DualComparator)
      • class jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator
    • class java.util.AbstractMap (implements java.util.Map)
      • class jp.co.intra_mart.common.aid.jdk.java.util.FixedSizeMap
    • class jp.co.intra_mart.common.aid.jdk.util.report.AbstractMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.FileReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.MultiCastReporter
      • class jp.co.intra_mart.common.aid.jdk.util.report.PrintStreamReporter
    • class jp.co.intra_mart.common.aid.jdk.java.net.AbstractSocketConnectionDistributor (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor)
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketPool (implements jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager)
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterEncoder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterMappingBuilder
    • class jp.co.intra_mart.common.aid.jdk.util.charset.CharacterSetManager
    • class java.lang.ClassLoader
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ResourceLoader
        • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedClassLoader
          • class jp.co.intra_mart.common.aid.jdk.java.lang.LuxuryClassLoader
          • class jp.co.intra_mart.common.aid.jdk.java.lang.SearchableClassLoader
    • class java.util.Dictionary
      • class java.util.Hashtable (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class java.util.Properties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties
            • class jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties
              • class jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties
          • class jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties
    • class jp.co.intra_mart.common.aid.jdk.javax.xml.DOMBuilder (implements jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo)
    • class jp.co.intra_mart.common.aid.jdk.util.ErrorEvent
    • class jp.co.intra_mart.common.aid.jdk.util.EventQueueController
    • class jp.co.intra_mart.common.aid.jdk.util.report.EverydayConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.java.net.ExtendedSocket
      • class jp.co.intra_mart.common.aid.jdk.java.net.SocketConnection
    • class java.io.File (implements java.lang.Comparable, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.Directory
        • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory
      • class jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile
    • class jp.co.intra_mart.common.aid.jdk.util.report.FileSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.java.io.FileUtil
    • class jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator (implements java.util.Comparator, java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator
    • class jp.co.intra_mart.common.aid.jdk.util.report.FilterMessageReporter (implements jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter)
      • class jp.co.intra_mart.common.aid.jdk.util.report.LineReportFilter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportLevelFilter (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel)
      • class jp.co.intra_mart.common.aid.jdk.util.report.RepresentativeReporter
    • class java.io.InputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedInputStream
      • class java.io.FilterInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeInputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XORInputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexInputStream
    • class jp.co.intra_mart.common.aid.jdk.java.util.LocaleUtil
    • class jp.co.intra_mart.common.aid.jdk.java.net.Localhost (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.util.LockMonitor
    • class jp.co.intra_mart.common.aid.jdk.util.MultipurposeInternetMailExtensions
    • class java.lang.Number (implements java.io.Serializable)
      • class jp.co.intra_mart.common.aid.jdk.util.Counter (implements java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.lang.NumberUtil
    • class jp.co.intra_mart.common.aid.jdk.util.report.OutputSizeConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class java.io.OutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.ExtendedOutputStream
      • class java.io.FilterOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64DecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.BASE64EncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.UnlimitedBufferedOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLDecodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.URLEncodeOutputStream
        • class jp.co.intra_mart.common.aid.jdk.java.io.XOROutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.HexOutputStream
      • class jp.co.intra_mart.common.aid.jdk.java.io.MultipleOutputStream
    • class jp.co.intra_mart.common.aid.jdk.util.report.PeriodicConditioner (implements jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner)
    • class jp.co.intra_mart.common.aid.jdk.java.util.PropertiesUtil
    • class java.io.Reader
      • class java.io.FilterReader
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterReader
    • class java.util.ResourceBundle
      • class jp.co.intra_mart.common.aid.jdk.java.util.FileResourceBundle
    • class jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator (implements java.util.Comparator, java.io.Serializable)
    • class jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownEventController
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdErr
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StdOut
    • class jp.co.intra_mart.common.aid.jdk.java.lang.StringUtil
    • class java.lang.Thread (implements java.lang.Runnable)
      • class jp.co.intra_mart.common.aid.jdk.java.lang.ExtendedThread
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.io.IOException
          • class jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException
        • class jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException
    • class java.io.Writer
      • class java.io.FilterWriter
        • class jp.co.intra_mart.common.aid.jdk.util.charset.AdvancedOutputStreamWriter
        • class jp.co.intra_mart.common.aid.jdk.java.io.TrimmedFilterWriter
      • class jp.co.intra_mart.common.aid.jdk.java.io.ReplaceWriter
      • class jp.co.intra_mart.common.aid.jdk.util.report.ReportFileWriter
    • class jp.co.intra_mart.common.aid.jdk.javax.xml.XmlNode

インタフェース階層

  • interface java.util.Comparator
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.io.Serializable)
  • interface jp.co.intra_mart.common.aid.jdk.javax.xml.DOMInfo
  • interface jp.co.intra_mart.common.aid.jdk.util.ErrorEventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.EventListener
  • interface jp.co.intra_mart.common.aid.jdk.util.report.MessageReporter
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportFileConditioner
  • interface jp.co.intra_mart.common.aid.jdk.util.report.ReportLevel
  • interface java.io.Serializable
    • interface jp.co.intra_mart.common.aid.jdk.java.util.DualComparator (同様に extends java.util.Comparator)
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ShutdownListener
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionDistributor
    • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketConnectionManager
  • interface jp.co.intra_mart.common.aid.jdk.java.net.SocketEventListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThreadStopListener
  • interface jp.co.intra_mart.common.aid.jdk.java.lang.ThrowablePrintListener
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_jdk_assist 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_jdk_assist 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.common.aid.jdk.java.io.file

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.Directory は File を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedDirectory は Directory を拡張し、Serializable を実装しています

直列化されたフィールド

POOL

FixedSizeMap POOL
このディレクトリを親とするファイルオブジェクトのキャッシュ領域

クラス jp.co.intra_mart.common.aid.jdk.java.io.file.ExtendedFile は File を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.net

クラス jp.co.intra_mart.common.aid.jdk.java.net.Localhost は Object を拡張し、Serializable を実装しています

直列化されたフィールド

localhostIPAddress

byte[] localhostIPAddress

localhostAddress

String localhostAddress

localhostName

String localhostName

クラス jp.co.intra_mart.common.aid.jdk.java.net.UnsupportedNetworkConnectException は IOException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.java.util

クラス jp.co.intra_mart.common.aid.jdk.java.util.AbstractDualComparator は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.ExtendedProperties は Properties を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.FilterComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

Comparator parent

クラス jp.co.intra_mart.common.aid.jdk.java.util.MultiComparator は AbstractDualComparator を拡張し、Serializable を実装しています

直列化されたフィールド

primaryComparator

Comparator primaryComparator
第１コンパレータ

secondaryComparator

MultiComparator secondaryComparator
第２コンパレータ

クラス jp.co.intra_mart.common.aid.jdk.java.util.ResourceBundleProperties は Properties を拡張し、Serializable を実装しています

直列化されたフィールド

currentLocale

Locale currentLocale

クラス jp.co.intra_mart.common.aid.jdk.java.util.ReverseComparator は FilterComparator を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.java.util.SequenceComparator は Object を拡張し、Serializable を実装しています

直列化されたフィールド

map

WeakHashMap map
map

count

long count
挿入順番

パッケージ jp.co.intra_mart.common.aid.jdk.javax.xml

クラス jp.co.intra_mart.common.aid.jdk.javax.xml.XMLProperties は ElementProperties を拡張し、Serializable を実装しています

直列化されたフィールド

domDocument

Document domDocument
このプロパティセットの元データとなった DOM

propertyList

Map propertyList
プロパティのリスト

パッケージ jp.co.intra_mart.common.aid.jdk.org.w3c.dom

クラス jp.co.intra_mart.common.aid.jdk.org.w3c.dom.ElementProperties は ExtendedProperties を拡張し、Serializable を実装しています

直列化されたフィールド

propertyList

Map propertyList
プロパティのリスト

element

Element element
このオブジェクトがラップするエレメントノード

パッケージ jp.co.intra_mart.common.aid.jdk.util.charset

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceFormatException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jdk.util.charset.ResourceNotFoundException は Exception を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jdk.util

クラス jp.co.intra_mart.common.aid.jdk.util.Counter は Number を拡張し、Serializable を実装しています

直列化されたフィールド

currentValue

long currentValue
カウンターの値

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity の使用

MultipartFormData.Entity を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http での MultipartFormData.Entity の使用

MultipartFormData.Entity を返す jp.co.intra_mart.common.aid.javaee.http のメソッド
MultipartFormData.Entity | MultipartFormData.getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | MultipartFormData.getEntity(String name) 指定の名前を持つエンティティを取得します。
MultipartFormData.Entity[] | MultipartFormData.getEntities(String name) 指定の名前を持つエンティティをすべて取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.MultipartFormData の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData の使用

jp.co.intra_mart.common.aid.javaee.http.MultipartFormData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MultipartFormData.Entity (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http
インタフェース MultipartFormData.Entity

含まれているインタフェース:
MultipartFormData
public static interface MultipartFormData.Entity

フォームデータのエンティティです。

フォームから送信された情報を解析した結果の各エンティティは、 ヘッダ情報とデータで構成されます。

メソッドの概要
boolean | containsHeader(String name) 指定された文字列がヘッダの名称かどうかを判定します。
byte[] | getBytes() データ部をバイト配列として取得します。
String | getContent() データ部を文字列表現として取得します。
String | getContent(String enc) データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
int | getContentLength() データ部をバイト長を取得します。
String | getFileName() アップロードされたファイルのファイル名を取得します。
String | getHeader(String name) ヘッダの取得。
String[] | getHeaderNames() ヘッダ名称一覧の取得。
InputStream | getInputStream() データ部を入力ストリームとして取得します。
String | getName() フォームのコントロール名称の取得。
Reader | getReader() 推奨されていません。 getReader(String) に置き換えられました。
Reader | getReader(String encoding) データ部を Reader として取得します。

メソッドの詳細

getName

public String getName()
フォームのコントロール名称の取得。

フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
コントロール名称

getFileName

public String getFileName()
アップロードされたファイルのファイル名を取得します。

ファイルアップロードをしたリクエストではない場合は、null を返します。
Content-Disposition: form-data; name="ctrl_name"; filename="file_path"
ヘッダは、上記のような形式で受け取れる
ctrl_name: <INPUT type="file"> の name 属性
file_path: クライアントでのファイル名
ヘッダ情報は他にもあるが、上記の行のみを対象に解析を行う

戻り値:
String ファイル名

getHeaderNames

public String[] getHeaderNames()
ヘッダ名称一覧の取得。

このエンティティのもつヘッダ情報の名称一覧を返します。

戻り値:
ヘッダ名称の取得

getHeader

public String getHeader(String name)
ヘッダの取得。

返却値は、文字エンコーディングの変換が行われていない状態の文字列を返却します。 具体的には、javax.servlet.ServletRequest#getInputStream()を利用して リクエストの内容をバイト配列で取得し、それを「ISO-8859-1」で文字列化した内容が返却されます。

別のエンコーディングに変換する場合、以下のようなコードで変換する必要があります。

 byte[] rawData = entity.getHeader(headerName).getBytes("ISO-8859-1");
 String encodedValue = new String(rawData, request.getCharacterEncoding());

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

containsHeader

public boolean containsHeader(String name)
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true

getContentLength

public int getContentLength()
データ部をバイト長を取得します。

戻り値:
データのサイズ

getContent

public String getContent()
データ部を文字列表現として取得します。

入力されたバイトデータから文字列への変換には、Application Runtimeが稼動しているJavaVMの デフォルト文字エンコーディングを使います。

戻り値:
データ

getContent

public String getContent(String enc)
                  throws UnsupportedEncodingException
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。

指定のエンコード名がサポートされていない場合 UnsupportedEncodingException がスローされます。

パラメータ:
enc - エンコード名
戻り値:
データ
例外:
UnsupportedEncodingException
関連項目:
UnsupportedEncodingException

getBytes

public byte[] getBytes()
データ部をバイト配列として取得します。

戻り値:
データ

getReader

public Reader getReader()
推奨されていません。 getReader(String) に置き換えられました。

データ部を Reader として取得します。

このReaderが文字に変換する際に使用する文字エンコーディングは、Application Runtimeが稼動している JavaVMのデフォルト文字エンコーディングです。

戻り値:
データ

getReader

public Reader getReader(String encoding)
データ部を Reader として取得します。

このReaderが文字に変換する際に使用する文字エンコーディングは、指定した文字エンコーディングです。

戻り値:
データ。エラーが発生した場合nullを返します。
導入されたバージョン:
6.1.12

getInputStream

public InputStream getInputStream()
データ部を入力ストリームとして取得します。

戻り値:
データ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MultipartFormData (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http
クラス MultipartFormData

java.lang.Object
    拡張 java.util.AbstractCollection
        拡張 java.util.AbstractList
            拡張 java.util.ArrayList
                拡張 jp.co.intra_mart.common.aid.javaee.http.MultipartFormData
すべての実装インタフェース:
Cloneable, Collection, List, RandomAccess, Serializable
public class MultipartFormData
extends ArrayList

フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。

このオブジェクトは、ブラウザから multipart/form-data 形式でリクエストされた データを解析し、boundary で区切られた各情報(エンティティ)をMultipartFormData.Entity としてリストに保管します。

このクラスを利用する事により、ブラウザからサーバに対するファイルの アップロードなどが簡単に実装する事ができます。

留意点

intra-mart6.1.11から、アップロードされたファイルが指定した閾値を超えた場合、 メモリ上ではなく一時ファイルに書き出し、OutOfMemoryErrorの発生を抑えることが できるようになりました。内部では Apache Commons FileUpload を利用しています。

一時ファイルは、ガベージコレクタがMultiPartFormData.Entityを解放するタイミングで 削除されます。従いまして、MultiPartFormData.Entityが解放される前にintra-martが 停止すると一時ファイルは削除されません。

一時ファイルの格納先は、デフォルトではJavaのテンポラリフォルダ(java.io.tmpdir)です。 ファイル名は upload_ランダムな文字列.tmp です。

なお、アップロードされたファイルを常にメモリ上で扱う実装と一時ファイルに書き出す実装の切り替え、 一時ファイルの格納先、一時ファイルに書き出すかどうかの閾値を設定ファイルで指定することができます。 設定ファイルは、 %ApplicationRuntime%/doc/imart/WEB-INF/classes/jp/co/intra_mart/common/aid/javaee/http/MultipartFormData.properties です。

設定ファイルの内容はMultipartFormDataResourceBundleを参照してください。

関連項目:
直列化された形式

入れ子クラスの概要
static interface MultipartFormData.Entity
フォームデータのエンティティです。
フィールドの概要
クラス java.util.AbstractList から継承したフィールド
modCount
コンストラクタの概要
MultipartFormData(ServletRequest req)
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData(ServletRequest req, IMFileItemFactory factory)
リクエストされた情報を解析して、新しいオブジェクトを構築します。
メソッドの概要
void | add(int index, Object element) リストの指定された位置に、指定された要素を挿入します。
boolean | add(Object o) リストの最後に、指定された要素を追加します。
boolean | addAll(Collection c) リストの末尾に、指定された Collection のすべての要素を追加します。
boolean | addAll(int index, Collection c) リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
void | clear() リストからすべての要素を削除します。
boolean | contains(Object elem) リストに指定の要素がある場合に true を返します。
boolean | containsAll(Collection c) このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
void | ensureCapacity(int minCapacity) 必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
boolean | equals(Object o) 指定されたオブジェクトとリストが等しいかどうかを比較します。
Object | get(int index) リスト内の指定された位置にある要素を返します。
MultipartFormData.Entity[] | getEntities(String name) 指定の名前を持つエンティティをすべて取得します。
MultipartFormData.Entity | getEntity(int index) 指定のインデックスに該当するエンティティを取得します。
MultipartFormData.Entity | getEntity(String name) 指定の名前を持つエンティティを取得します。
int | hashCode() このリストのハッシュコード値を返します。
int | indexOf(Object elem) equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
boolean | isEmpty() リストに要素がないかどうかを判定します。
Iterator | iterator() このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
int | lastIndexOf(Object elem) 指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
ListIterator | listIterator() このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
ListIterator | listIterator(int index) リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
Object | remove(int index) リスト内の指定された位置から要素を削除します。
boolean | remove(Object o) 指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
boolean | removeAll(Collection c) このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
boolean | retainAll(Collection c) このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。
Object | set(int index, Object element) リストの指定された位置にある要素を、指定された要素で置き換えます。
int | size() リスト内にある要素の数を返します。
List | subList(int fromIndex, int toIndex) このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。
Object[] | toArray() リスト内のすべての要素が正しい順序で格納されている配列を返します。
Object[] | toArray(Object[] a) リスト内のすべての要素が正しい順序で格納されている配列を返します。
void | trimToSize() この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。
クラス java.util.ArrayList から継承したメソッド
clone, removeRange
クラス java.util.AbstractCollection から継承したメソッド
toString
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MultipartFormData

public MultipartFormData(ServletRequest req)
                  throws IOException,
                         IllegalArgumentException
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合

MultipartFormData

public MultipartFormData(ServletRequest req,
                         IMFileItemFactory factory)
                  throws IOException,
                         IllegalArgumentException
リクエストされた情報を解析して、新しいオブジェクトを構築します。
multipart/form-data 形式のリクエストを解析します。

req が multipart/form-data で受信したリクエストではない場合、 IllegalArgumentException をスローします。

パラメータ:
req - サーブレットエンジンから渡されるリクエスト情報オブジェクト
factory - IMFileItemFactory のインスタンス
例外:
IOException - リクエストデータ解析時の入出力エラー
IllegalArgumentException - 引数が不正の場合
導入されたバージョン:
6.1.11
メソッドの詳細

getEntity

public MultipartFormData.Entity getEntity(int index)
指定のインデックスに該当するエンティティを取得します。

インデックスが範囲外の場合(インデックスが負または size() よりも大きい) IndexOutOfBoundsException をスローします。

パラメータ:
index - 返すエンティティのインデックス
戻り値:
リスト内の指定された位置にあるエンティティ

getEntity

public MultipartFormData.Entity getEntity(String name)
指定の名前を持つエンティティを取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 指定の名前を持つエンティティが複数存在する場合、その中のいずれか一つが 返されます。 該当するエンティティが存在しない場合 null を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

getEntities

public MultipartFormData.Entity[] getEntities(String name)
指定の名前を持つエンティティをすべて取得します。

エンティティの名前とは、フォームのコントロール名称のことです。 該当するエンティティが存在しない場合、空の配列を返します。

戻り値:
指定の名前を持つエンティティ
関連項目:
MultipartFormData.Entity.getName()

add

public void add(int index,
                Object element)
リストの指定された位置に、指定された要素を挿入します。

add

public boolean add(Object o)
リストの最後に、指定された要素を追加します。

addAll

public boolean addAll(Collection c)
リストの末尾に、指定された Collection のすべての要素を追加します。

addAll

public boolean addAll(int index,
                      Collection c)
リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。

clear

public void clear()
リストからすべての要素を削除します。

contains

public boolean contains(Object elem)
リストに指定の要素がある場合に true を返します。

containsAll

public boolean containsAll(Collection c)
このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。

ensureCapacity

public void ensureCapacity(int minCapacity)
必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。

equals

public boolean equals(Object o)
指定されたオブジェクトとリストが等しいかどうかを比較します。

get

public Object get(int index)
リスト内の指定された位置にある要素を返します。

hashCode

public int hashCode()
このリストのハッシュコード値を返します。

indexOf

public int indexOf(Object elem)
equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。

isEmpty

public boolean isEmpty()
リストに要素がないかどうかを判定します。

iterator

public Iterator iterator()
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

lastIndexOf

public int lastIndexOf(Object elem)
指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。

listIterator

public ListIterator listIterator()
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

listIterator

public ListIterator listIterator(int index)
リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。

remove

public Object remove(int index)
リスト内の指定された位置から要素を削除します。

remove

public boolean remove(Object o)
指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。

removeAll

public boolean removeAll(Collection c)
このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。

retainAll

public boolean retainAll(Collection c)
このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。

set

public Object set(int index,
                  Object element)
リストの指定された位置にある要素を、指定された要素で置き換えます。

size

public int size()
リスト内にある要素の数を返します。

subList

public List subList(int fromIndex,
                    int toIndex)
このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。

toArray

public Object[] toArray()
リスト内のすべての要素が正しい順序で格納されている配列を返します。

toArray

public Object[] toArray(Object[] a)
リスト内のすべての要素が正しい順序で格納されている配列を返します。

trimToSize

public void trimToSize()
この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.javaee.http (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.javaee.http
インタフェース
MultipartFormData.Entity
クラス
MultipartFormData
MultipartFormDataResourceBundle


jp.co.intra_mart.common.aid.javaee.http (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http

このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
MultipartFormData.Entity フォームデータのエンティティです。

クラスの概要
MultipartFormData | フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
MultipartFormDataResourceBundle | MultipartFormDataの設定情報を扱うクラスです。

パッケージ jp.co.intra_mart.common.aid.javaee.http の説明

このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.javaee.http クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData
    • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle

インタフェース階層

  • interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.javaee.http の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.javaee.http の使用

jp.co.intra_mart.common.aid.javaee.http を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http により使用される jp.co.intra_mart.common.aid.javaee.http のクラス
MultipartFormData.Entity
フォームデータのエンティティです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse の使用

ExtendedServletResponse を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletResponse の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletResponse のサブインタフェース
 interface HttpServletResponseEventController
レスポンスイベントコントローラのインタフェース。

ExtendedServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での ExtendedServletResponse の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での ExtendedServletResponse のサブインタフェース
 interface ExtendedHttpServletResponse
このインタフェースは、HttpServletResponseを拡張したものです。

ExtendedServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
class | ExtendedHttpServletResponseWrapper レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
class | SearchableHttpServletResponseWrapper HttpServletResponseWrapperの拡張実装を提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException の使用

BadRequestException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での BadRequestException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での BadRequestException のサブクラス
class | EmptyQueryException クエリがない場合にスローされる例外です。
class | ExcessiveQueryException クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
class | LengthRequiredException Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
class | UnripeQueryException クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException の使用

ExtendedServletException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での ExtendedServletException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での ExtendedServletException のサブクラス
class | BadRequestException 不正なリクエストを受け付けたことを通知するための例外です。
class | EmptyQueryException クエリがない場合にスローされる例外です。
class | ExcessiveQueryException クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
class | ForbiddenException アクセス権限がないことを通知する例外です。
class | LengthRequiredException Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
class | NotFoundException 指定されたコンテンツが見つからないことを通知するための例外です。
class | RequestEntityTooLargeException 処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
class | ServiceUnavailableException サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
class | UnauthorizedException リクエストを受け付けるためには認証が必要であることを通知するための例外です。
class | UnripeQueryException クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedServletException のサブクラス
class | HttpServletResponseEventControllerException コントローラに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventException イベントに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventFilterException レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
class | HttpServletResponseEventListenerException レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventValidatorException バリデータに関わる処理中にエラーが発生した事を通知する例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException の使用

UnripeQueryException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での UnripeQueryException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception での UnripeQueryException のサブクラス
 class EmptyQueryException
クエリがない場合にスローされる例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BadRequestException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス BadRequestException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExcessiveQueryException, LengthRequiredException, UnripeQueryException
public class BadRequestException
extends ExtendedServletException

不正なリクエストを受け付けたことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
BadRequestException()
例外を作成します。
BadRequestException(String message)
指定のメッセージを持つ例外を作成します。
BadRequestException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BadRequestException

public BadRequestException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

BadRequestException

public BadRequestException(String message,
                           Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

BadRequestException

public BadRequestException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EmptyQueryException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス EmptyQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
すべての実装インタフェース:
Serializable
public class EmptyQueryException
extends UnripeQueryException

クエリがない場合にスローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
EmptyQueryException()
例外を作成します。
EmptyQueryException(String message)
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

EmptyQueryException

public EmptyQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

EmptyQueryException

public EmptyQueryException(String message,
                           Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

EmptyQueryException

public EmptyQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExcessiveQueryException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ExcessiveQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
すべての実装インタフェース:
Serializable
public class ExcessiveQueryException
extends BadRequestException

クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ExcessiveQueryException()
例外を作成します。
ExcessiveQueryException(String message)
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExcessiveQueryException

public ExcessiveQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ExcessiveQueryException

public ExcessiveQueryException(String message,
                               Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ExcessiveQueryException

public ExcessiveQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtendedServletException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ExtendedServletException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BadRequestException, ForbiddenException, HttpServletResponseEventException, NotFoundException, RequestEntityTooLargeException, ServiceUnavailableException, UnauthorizedException
public class ExtendedServletException
extends ServletException

Servlet 例外の拡張モデルです。 JRE 1.4 から、Throwable に #getCause() が実装されました。 これと、ServletException が従来から持つ #getRootCause() が 同義となるようにしてあります。

導入されたバージョン:
version 5.0
関連項目:
ServletException, 直列化された形式

コンストラクタの概要
ExtendedServletException()
例外オブジェクトを作成します。
ExtendedServletException(String message)
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String message, Throwable rootCause)
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable rootCause)
根本原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtendedServletException

public ExtendedServletException()
例外オブジェクトを作成します。

ExtendedServletException

public ExtendedServletException(String message)
指定されたメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ExtendedServletException

public ExtendedServletException(String message,
                                Throwable rootCause)
指定されたメッセージと根本原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ExtendedServletException

public ExtendedServletException(Throwable rootCause)
根本原因となった例外を持つ例外を作成します。

パラメータ:
rootCause - 原因となった例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForbiddenException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ForbiddenException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
すべての実装インタフェース:
Serializable
public class ForbiddenException
extends ExtendedServletException

アクセス権限がないことを通知する例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ForbiddenException()
例外を作成します。
ForbiddenException(String message)
指定のメッセージを持つ例外を作成します。
ForbiddenException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForbiddenException

public ForbiddenException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ForbiddenException

public ForbiddenException(String message,
                          Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ForbiddenException

public ForbiddenException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LengthRequiredException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス LengthRequiredException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
すべての実装インタフェース:
Serializable
public class LengthRequiredException
extends BadRequestException

Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
LengthRequiredException()
例外を作成します。
LengthRequiredException(String message)
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LengthRequiredException

public LengthRequiredException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

LengthRequiredException

public LengthRequiredException(String message,
                               Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

LengthRequiredException

public LengthRequiredException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NotFoundException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス NotFoundException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
すべての実装インタフェース:
Serializable
public class NotFoundException
extends ExtendedServletException

指定されたコンテンツが見つからないことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
NotFoundException()
例外を作成します。
NotFoundException(String message)
指定のメッセージを持つ例外を作成します。
NotFoundException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NotFoundException

public NotFoundException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

NotFoundException

public NotFoundException(String message,
                         Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

NotFoundException

public NotFoundException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
例外
BadRequestException
EmptyQueryException
ExcessiveQueryException
ExtendedServletException
ForbiddenException
LengthRequiredException
NotFoundException
RequestEntityTooLargeException
ServiceUnavailableException
UnauthorizedException
UnripeQueryException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

例外の概要
BadRequestException | 不正なリクエストを受け付けたことを通知するための例外です。
EmptyQueryException | クエリがない場合にスローされる例外です。
ExcessiveQueryException | クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExtendedServletException | Servlet 例外の拡張モデルです。
ForbiddenException | アクセス権限がないことを通知する例外です。
LengthRequiredException | Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
NotFoundException | 指定されたコンテンツが見つからないことを通知するための例外です。
RequestEntityTooLargeException | 処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
ServiceUnavailableException | サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
UnauthorizedException | リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnripeQueryException | クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の説明

このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception のクラス
BadRequestException
不正なリクエストを受け付けたことを通知するための例外です。
ExtendedServletException
Servlet 例外の拡張モデルです。
UnripeQueryException
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception のクラス
ExtendedServletException
Servlet 例外の拡張モデルです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestEntityTooLargeException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス RequestEntityTooLargeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
すべての実装インタフェース:
Serializable
public class RequestEntityTooLargeException
extends ExtendedServletException

処理可能量より大きいリクエストを受け付けたことを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
RequestEntityTooLargeException()
例外を作成します。
RequestEntityTooLargeException(String message)
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RequestEntityTooLargeException

public RequestEntityTooLargeException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

RequestEntityTooLargeException

public RequestEntityTooLargeException(String message,
                                      Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

RequestEntityTooLargeException

public RequestEntityTooLargeException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ServiceUnavailableException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス ServiceUnavailableException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
すべての実装インタフェース:
Serializable
public class ServiceUnavailableException
extends ExtendedServletException

サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
ServiceUnavailableException()
例外を作成します。
ServiceUnavailableException(String message)
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ServiceUnavailableException

public ServiceUnavailableException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

ServiceUnavailableException

public ServiceUnavailableException(String message,
                                   Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

ServiceUnavailableException

public ServiceUnavailableException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnauthorizedException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス UnauthorizedException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
すべての実装インタフェース:
Serializable
public class UnauthorizedException
extends ExtendedServletException

リクエストを受け付けるためには認証が必要であることを通知するための例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnauthorizedException()
例外を作成します。
UnauthorizedException(String message)
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnauthorizedException

public UnauthorizedException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

UnauthorizedException

public UnauthorizedException(String message,
                             Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

UnauthorizedException

public UnauthorizedException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnripeQueryException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
クラス UnripeQueryException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
EmptyQueryException
public class UnripeQueryException
extends BadRequestException

クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
UnripeQueryException()
例外を作成します。
UnripeQueryException(String message)
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String message, Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnripeQueryException

public UnripeQueryException(String message)
指定のメッセージを持つ例外を作成します。

パラメータ:
message - メッセージ

UnripeQueryException

public UnripeQueryException(String message,
                            Throwable rootCause)
指定のメッセージと原因となった例外を持つ例外を作成します。

パラメータ:
message - メッセージ
rootCause - 原因となった例外

UnripeQueryException

public UnripeQueryException()
例外を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter の使用

AbstractFilter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractFilter のサブクラス
class | AbsoluteLinkFilter 絶対表現のＵＲＬをレスポンスするためのフィルタ。
class | ExceptionHandlingFilter サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
class | HTTPContextHandlingFilter このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
class | HttpServletResponseEventFilter サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。
class | LuxuryResponseWriterFilter
class | NoCacheFilter ブラウザのキャッシュを無効にするフィルタ。
class | RequestMessageBodyFilter リクエストをラップするフィルタです。
class | ResponseContentTypeManagementFilter レスポンスの Content-Type を自動解決するフィルタです。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での AbstractFilter のサブクラス
 class HttpSessionMonitoringFilter
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener の使用

AbstractHttpServletResponseEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractHttpServletResponseEventListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での AbstractHttpServletResponseEventListener のサブクラス
 class SimpleHttpServletResponseEventListener
レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper の使用

HttpServletRequestMessageBodyWrapper を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletRequestMessageBodyWrapper の使用

HttpServletRequestMessageBodyWrapper を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
static HttpServletRequestMessageBodyWrapper | RequestMessageBodyFilter.getCurrentRequest() 現在処理中のリクエストを返します。
HttpServletRequestMessageBodyWrapper | HttpServletRequestMessageBodyWrapperBuilder.buildExtendedHttpServletRequest(HttpServletRequest request, HttpServletResponse response) ExtendedHttpServletRequest を作成して返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig の使用

HttpServletResponseEventConfig を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventConfig の使用

HttpServletResponseEventConfig を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventConfig
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。

HttpServletResponseEventConfig を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
protected  HttpServletResponseEventConfig AbstractHttpServletResponseEventListener.getHttpServletResponseEventConfig()
このリスナに渡された設定オブジェクトを返します。

HttpServletResponseEventConfig 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | HttpServletResponseEventValidator.init(HttpServletResponseEventConfig config) この Validator を初期化します。
void | HttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
void | HttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。
void | AbstractHttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
void | AbstractHttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController の使用

HttpServletResponseEventController を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventController の使用

HttpServletResponseEventController を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

HttpServletResponseEventController を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder の使用

HttpServletResponseEventControllerBuilder を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventControllerBuilder の使用

HttpServletResponseEventControllerBuilder を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class StandardHttpServletResponseEventControllerBuilder
標準的なコントローラを構築するビルダです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException の使用

HttpServletResponseEventControllerException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventControllerException の使用

HttpServletResponseEventControllerException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | StandardHttpServletResponseEventControllerBuilder.init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | HttpServletResponseEventControllerBuilder.init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | HttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。
protected void | AbstractHttpServletResponseEventController.handleInit() このリスナを初期化します。
void | AbstractHttpServletResponseEventController.init(HttpServletResponseEventConfig config) このビルダを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException の使用

HttpServletResponseEventException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventException のサブクラス
class | HttpServletResponseEventControllerException コントローラに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventFilterException レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
class | HttpServletResponseEventListenerException レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
class | HttpServletResponseEventValidatorException バリデータに関わる処理中にエラーが発生した事を通知する例外です。

HttpServletResponseEventException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
 void HttpServletResponseEventComponentBuilder.init(String initParameterValue, ServletContext servletContext)
ビルダを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener の使用

HttpServletResponseEventListener を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventListener の使用

HttpServletResponseEventListener を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
class | AbstractHttpServletResponseEventListener レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
class | SimpleHttpServletResponseEventListener レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。

HttpServletResponseEventListener を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventListener[] | HttpServletResponseEventComponentBuilder.getListeners() リスナの配列を返します。
protected abstract HttpServletResponseEventListener | AbstractHttpServletResponseEventController.getHttpServletResponseEventListener() リスナを返します。

HttpServletResponseEventListener 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException の使用

HttpServletResponseEventListenerException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventListenerException の使用

HttpServletResponseEventListenerException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | HttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
HttpServletResponseEventListener[] | HttpServletResponseEventComponentBuilder.getListeners() リスナの配列を返します。
void | AbstractHttpServletResponseEventListener.init(HttpServletResponseEventConfig config) このビルダを初期化します。
protected void | AbstractHttpServletResponseEventListener.handleInit() このリスナを初期化します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator の使用

HttpServletResponseEventValidator を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventValidator の使用

HttpServletResponseEventValidator を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
 HttpServletResponseEventValidator[] HttpServletResponseEventComponentBuilder.getValidators()
バリデータの配列を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException の使用

HttpServletResponseEventValidatorException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での HttpServletResponseEventValidatorException の使用

HttpServletResponseEventValidatorException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
void | HttpServletResponseEventValidator.init(HttpServletResponseEventConfig config) この Validator を初期化します。
boolean | HttpServletResponseEventValidator.isValid(HttpServletRequest request, ExtendedHttpServletResponse response) イベントリスナを動作させるかどうかの意思決定をします。
HttpServletResponseEventValidator[] | HttpServletResponseEventComponentBuilder.getValidators() バリデータの配列を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter の使用

RequestParameter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での RequestParameter の使用

RequestParameter を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
static RequestParameter[] | RequestMessageBodyFilter.getRequestParameters() 現在のリクエストのパラメータを返します。
RequestParameter[] | HttpServletRequestMessageBodyWrapper.getRequestParameters() パラメータ情報を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbsoluteLinkFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbsoluteLinkFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
すべての実装インタフェース:
Filter
public class AbsoluteLinkFilter
extends AbstractFilter

絶対表現のＵＲＬをレスポンスするためのフィルタ。

このフィルタの目的は、ServletResponse#encodeURL() の実行結果として、 単にセッションＩＤ情報を付加するだけではなく、必ず絶対形式のＵＲＬを 作成することです。 したがって、このフィルタは、チェーンの次サーブレットまたはフィルタに対して、 ラップしたレスポンスを渡します。

このフィルタがレスポンスをラップするのは、事前に指定されたセッションに 関連したリクエストのみです。 #entry(ServletRequest) または entry(HttpSession) で 登録していないセッションに関するリクエストについては、 レスポンスをラップすることなくチェーンの次のサーブレットまたはフィルタを 実行します。

コンストラクタの概要
AbsoluteLinkFilter()
フィルタを新しく作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタ処理します。
static void | entry(HttpServletRequest request) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | entry(HttpSession session) このフィルタによってＵＲＬの制御を行うことを定義します。
static void | leave(HttpServletRequest request) 指定のセッションに関する、このフィルタの処理を停止します。
static void | leave(HttpSession session) 指定のセッションに関する、このフィルタの処理を停止します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbsoluteLinkFilter

public AbsoluteLinkFilter()
フィルタを新しく作成します。

メソッドの詳細

entry

public static void entry(HttpServletRequest request)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合
IllegalStateException - セッションを取得できなかった場合

entry

public static void entry(HttpSession session)
このフィルタによってＵＲＬの制御を行うことを定義します。

この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpServletRequest request)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

既にセッションが有効でない場合、このメソッドは何も行いません。

パラメータ:
request - リクエスト
例外:
NullPointerException - 引数が null の場合

leave

public static void leave(HttpSession session)
指定のセッションに関する、このフィルタの処理を停止します。 この処理は、このリクエスト中のみでなく、 同じセッションのすべてのリクエストに対して有効となります。

パラメータ:
session - セッション
例外:
NullPointerException - 引数が null の場合

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタ処理します。

現在のリクエストに関連付けられているセッションが、 このクラスの entry(HttpSession) で定義済みのセッションの場合、 レスポンスをラップします。 ラップされたレスポンスは、javax.servlet.http.HttpServletResponse#encodeURL(java.lang.String) の 返り値として、必ず絶対形式のＵＲＬを返すようになります。

レスポンスをラップするかどうかに関わらず、 このメソッドは、フィルタチェーン内の次のチェーンを呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - フィルタチェーンの次のビュー
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
すべての実装インタフェース:
Filter
直系の既知のサブクラス:
AbsoluteLinkFilter, ExceptionHandlingFilter, HTTPContextHandlingFilter, HttpServletResponseEventFilter, HttpSessionMonitoringFilter, LuxuryResponseWriterFilter, NoCacheFilter, RequestMessageBodyFilter, ResponseContentTypeManagementFilter
public abstract class AbstractFilter
extends Object
implements Filter

フィルタを実装するための抽象クラスです。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractFilter()
フィルタオブジェクトを作成します。
メソッドの概要
void | destroy() フィルタの終了処理。
abstract void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
FilterConfig | getFilterConfig() このフィルタの設定オブジェクトを返します。
ServletContext | getServletContext() この Filter を実行している ServletContext への参照を返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
void | init(FilterConfig config) フィルタを初期化します。
protected void | log(String msg) Servlet ログファイルに指定されたメッセージを出力します。
protected void | log(String msg, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractFilter

protected AbstractFilter()
フィルタオブジェクトを作成します。

メソッドの詳細

init

public final void init(FilterConfig config)
                throws ServletException
フィルタを初期化します。

このメソッドは、この抽象クラスの初期化を実行後に、 handleInit() を実行します。 サブクラスが独自の初期化処理を必要とする場合は、 handleInit() をオーバーライドして初期化処理を実装してください。

定義:
インタフェース Filter 内の init
パラメータ:
config - フィルタ設定オブジェクト
例外:
ServletException - 初期化エラー
関連項目:
Filter.init(FilterConfig)

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

例外:
ServletException - 初期化エラー
関連項目:
init(FilterConfig)

getFilterConfig

public FilterConfig getFilterConfig()
このフィルタの設定オブジェクトを返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
フィルタ設定オブジェクト。コンストラクタで呼び出した場合は null を返します。

getServletContext

public ServletContext getServletContext()
この Filter を実行している ServletContext への参照を返します。

このメソッドは、コンストラクタでは利用できません。

戻り値:
このフィルタが Servlet コンテナとの対話に使っている ServletContext オブジェクト
例外:
NullPointerException - コンストラクタで呼び出した場合

log

protected void log(String msg)
Servlet ログファイルに指定されたメッセージを出力します。
通常は event ログです。 Servlet ログファイルの名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String)

log

protected void log(String msg,
                   Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
Servlet ログファイルは通常は event ログですが、 名前やタイプは Servlet コンテナによって違います。

このメソッドの呼び出しは、下記と同等です。
this.getFilterConfig().getServletContext().log(msg, throwable);

このメソッドは、コンストラクタでは利用できません。

パラメータ:
msg - ログファイルに出力するメッセージ
throwable - エラーや例外
例外:
NullPointerException - コンストラクタで呼び出した場合
関連項目:
ServletContext.log(String, Throwable)

doFilter

public abstract void doFilter(ServletRequest request,
                              ServletResponse response,
                              FilterChain chain)
                       throws ServletException,
                              IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

destroy

public final void destroy()
フィルタの終了処理。

このメソッドは、handleDestroy() を呼び出します。
handleDestroy() から正常に制御が返ってきた場合も、
また handleDestroy() が例外をスローした場合も、
このメソッドが終了する直前に、この抽象クラスの破棄処理が行われます。

サブクラスが独自の初期化処理を必要とする場合は、 handleDestroy() をオーバーライドして 初期化処理を実装してください。

定義:
インタフェース Filter 内の destroy
関連項目:
Filter.destroy()

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

関連項目:
destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AbstractHttpServletResponseEventConfig (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractHttpServletResponseEventConfig

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig
すべての実装インタフェース:
HttpServletResponseEventConfig
public abstract class AbstractHttpServletResponseEventConfig
extends Object
implements HttpServletResponseEventConfig

レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。 リスナやコントローラの初期化の際に情報を渡すために使われます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
AbstractHttpServletResponseEventConfig(ServletContext servletContext)
新しい設定オブジェクトを作成します。
メソッドの概要
abstract String | getInitParameter(String name) 指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
abstract Enumeration | getInitParameterNames() 初期化パラメータの名前である String オブジェクトの Enumeration を返します。
ServletContext | getServletContext() 呼び出したコントローラを実行している ServletContext への参照を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractHttpServletResponseEventConfig

public AbstractHttpServletResponseEventConfig(ServletContext servletContext)
新しい設定オブジェクトを作成します。

パラメータ:
servletContext - サーブレットコンテキスト
メソッドの詳細

getInitParameter

public abstract String getInitParameter(String name)
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。

定義:
インタフェース HttpServletResponseEventConfig 内の getInitParameter
パラメータ:
name - 初期化パラメータの名前を指定する String
戻り値:
初期化パラメータの値である Strin

getInitParameterNames

public abstract Enumeration getInitParameterNames()
初期化パラメータの名前である String オブジェクトの Enumeration を返します。 または、初期化パラメータが無ければ空の Enumeration を返します。

定義:
インタフェース HttpServletResponseEventConfig 内の getInitParameterNames
戻り値:
初期化パラメータの名前である String オブジェクトの Enumeration

getServletContext

public ServletContext getServletContext()
呼び出したコントローラを実行している ServletContext への参照を返します。

定義:
インタフェース HttpServletResponseEventConfig 内の getServletContext
戻り値:
呼び出したコントローラが Servlet コンテナとの対話に使っている ServletContext オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AbstractHttpServletResponseEventController (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractHttpServletResponseEventController

java.lang.Object
    拡張 javax.servlet.ServletResponseWrapper
        拡張 javax.servlet.http.HttpServletResponseWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController
すべての実装インタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, HttpServletResponseEventController, ServletResponse
public abstract class AbstractHttpServletResponseEventController
extends ExtendedHttpServletResponseWrapper
implements HttpServletResponseEventController

イベントを制御するレスポンスの抽象実装です。

HttpServletResponse が持つ 各メソッド（非推奨を除く）をオーバーライドして、 リスナに処理を委任するロジックを追加します。

導入されたバージョン:
Version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
コンストラクタの概要
AbstractHttpServletResponseEventController(ExtendedHttpServletResponse response)
新しいインスタンスを生成します。
メソッドの概要
void | addCookie(Cookie cookie) 指定されたCookieをレスポンスに追加します。
void | addDateHeader(String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | addHeader(String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | addIntHeader(String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
boolean | containsHeader(String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | encodeRedirectURL(String url) sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
String | encodeURL(String url) 指定されたURLがセッションIDを含むようにエンコードします。
void | flushBuffer() バッファリングされているコンテンツを強制的にクライアントに出力します。
int | getBufferSize() このレスポンスに設定されている実バッファサイズを返します。
String | getCharacterEncoding() このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
protected abstract HttpServletRequest | getHttpServletRequest() リクエストを返します。
protected abstract HttpServletResponseEventListener | getHttpServletResponseEventListener() リスナを返します。
Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
ServletOutputStream | getOutputStream() レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | getWriter() 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
protected void | handleInit() このリスナを初期化します。
void | init(HttpServletResponseEventConfig config) このビルダを初期化します。
boolean | isCommitted() レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | reset() バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | resetBuffer() レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
void | sendError(int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendError(int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendRedirect(String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | setBufferSize(int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
void | setContentLength(int len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | setDateHeader(String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | setHeader(String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | setIntHeader(String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | setLocale(Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
void | setStatus(int sc) このレスポンスのステータスコードを設定します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper から継承したメソッド
getContentLength, getContentType, getCookies, getDateHeader, getDateHeaders, getExtendedHttpServletResponse, getHeader, getHeaders, getIntHeader, getIntHeaders, getStatus, getStringHeader, getStringHeaders, setContentType
クラス javax.servlet.http.HttpServletResponseWrapper から継承したメソッド
encodeRedirectUrl, encodeUrl, setStatus
クラス javax.servlet.ServletResponseWrapper から継承したメソッド
getLocale, getResponse, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse から継承したメソッド
getCookies, getDateHeader, getDateHeaders, getHeader, getHeaders, getIntHeader, getIntHeaders, getStatus, getStringHeader, getStringHeaders
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse から継承したメソッド
getContentLength, getContentType, setContentType
インタフェース javax.servlet.ServletResponse から継承したメソッド
getLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
encodeRedirectUrl, encodeUrl, setStatus

コンストラクタの詳細

AbstractHttpServletResponseEventController

public AbstractHttpServletResponseEventController(ExtendedHttpServletResponse response)
新しいインスタンスを生成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws HttpServletResponseEventControllerException
このリスナを初期化します。

このメソッドは、#init(HttpServletResponseEventListenerConfig) によって呼び出されます。 このメソッドは単にリターンするだけで、何もしません。
サブクラスが初期化処理を必要とする場合、 このメソッドをオーバーライドしてください。

例外:
HttpServletResponseEventControllerException - 初期化に失敗した場合

getHttpServletRequest

protected abstract HttpServletRequest getHttpServletRequest()
リクエストを返します。

戻り値:
現在のリクエスト

getHttpServletResponseEventListener

protected abstract HttpServletResponseEventListener getHttpServletResponseEventListener()
リスナを返します。

戻り値:
リスナ

init

public final void init(HttpServletResponseEventConfig config)
                throws HttpServletResponseEventControllerException
このビルダを初期化します。

定義:
インタフェース HttpServletResponseEventController 内の init
パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventControllerException - 初期化に失敗した場合

addCookie

public void addCookie(Cookie cookie)
指定されたCookieをレスポンスに追加します。

定義:
インタフェース HttpServletResponse 内の addCookie
パラメータ:
cookie - クライアントに返すCookie

containsHeader

public boolean containsHeader(String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

定義:
インタフェース HttpServletResponse 内の containsHeader
パラメータ:
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse

encodeURL

public String encodeURL(String url)
指定されたURLがセッションIDを含むようにエンコードします。

定義:
インタフェース HttpServletResponse 内の encodeURL
パラメータ:
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

encodeRedirectURL

public String encodeRedirectURL(String url)
sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

定義:
インタフェース HttpServletResponse 内の encodeRedirectURL
パラメータ:
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

sendError

public void sendError(int sc,
                      String msg)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

定義:
インタフェース HttpServletResponse 内の sendError
パラメータ:
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendError

public void sendError(int sc)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

定義:
インタフェース HttpServletResponse 内の sendError
パラメータ:
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendRedirect

public void sendRedirect(String location)
                  throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

定義:
インタフェース HttpServletResponse 内の sendRedirect
パラメータ:
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

setDateHeader

public void setDateHeader(String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

定義:
インタフェース HttpServletResponse 内の setDateHeader
パラメータ:
name - 設定するヘッダの名称
date - 設定するヘッダの値

addDateHeader

public void addDateHeader(String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

定義:
インタフェース HttpServletResponse 内の addDateHeader
パラメータ:
name - 追加するヘッダの名称
date - 追加するヘッダの値

setHeader

public void setHeader(String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

定義:
インタフェース HttpServletResponse 内の setHeader
パラメータ:
name - ヘッダの名称
value - ヘッダの値

addHeader

public void addHeader(String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

定義:
インタフェース HttpServletResponse 内の addHeader
パラメータ:
name - ヘッダの名称
value - 追加するヘッダの値

setIntHeader

public void setIntHeader(String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

定義:
インタフェース HttpServletResponse 内の setIntHeader
パラメータ:
name - ヘッダの名称
value - 割り当てられる整数値

addIntHeader

public void addIntHeader(String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

定義:
インタフェース HttpServletResponse 内の addIntHeader
パラメータ:
name - ヘッダの名称
value - 割り当てられる整数値

setStatus

public void setStatus(int sc)
このレスポンスのステータスコードを設定します。

定義:
インタフェース HttpServletResponse 内の setStatus
パラメータ:
sc - ステータスコード

getCharacterEncoding

public String getCharacterEncoding()
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

定義:
インタフェース ServletResponse 内の getCharacterEncoding
戻り値:
文字エンコーディング名を意味する String。

getOutputStream

public ServletOutputStream getOutputStream()
                                    throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

定義:
インタフェース ServletResponse 内の getOutputStream
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

getWriter

public PrintWriter getWriter()
                      throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

定義:
インタフェース ServletResponse 内の getWriter
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

setContentLength

public void setContentLength(int len)
レスポンスのメッセージボディ部分の長さをセットします。

定義:
インタフェース ServletResponse 内の setContentLength
パラメータ:
len - クライアントに送り返すメッセージボディの長さを指定する整数値。

setContentType

public void setContentType(String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

定義:
インタフェース ServletResponse 内の setContentType
パラメータ:
type - コンテントタイプを指定する String

setBufferSize

public void setBufferSize(int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

定義:
インタフェース ServletResponse 内の setBufferSize
パラメータ:
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合

getBufferSize

public int getBufferSize()
このレスポンスに設定されている実バッファサイズを返します。

定義:
インタフェース ServletResponse 内の getBufferSize
戻り値:
実際に使われているバッファサイズ

flushBuffer

public void flushBuffer()
                 throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

定義:
インタフェース ServletResponse 内の flushBuffer
例外:
IOException - 入出力時に例外が発生した場合

resetBuffer

public void resetBuffer()
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

定義:
インタフェース ServletResponse 内の resetBuffer

isCommitted

public boolean isCommitted()
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

定義:
インタフェース ServletResponse 内の isCommitted
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean

reset

public void reset()
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

定義:
インタフェース ServletResponse 内の reset

setLocale

public void setLocale(Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

定義:
インタフェース ServletResponse 内の setLocale
パラメータ:
loc - レスポンスのロケールを指定する Locale オブジェクト

getLocale

public Locale getLocale(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

戻り値:
レスポンスに設定されているロケール
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AbstractHttpServletResponseEventListener (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス AbstractHttpServletResponseEventListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener
すべての実装インタフェース:
HttpServletResponseEventListener
直系の既知のサブクラス:
SimpleHttpServletResponseEventListener
public abstract class AbstractHttpServletResponseEventListener
extends Object
implements HttpServletResponseEventListener

レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。

このクラスは、フックしたレスポンスの適当なメソッドを実行するだけの単純実装です。 アプリケーションは、このクラスを継承して、 任意のメソッドのみをオーバーライドする事により 必要なイベントフックのみを実装する事ができます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
protected AbstractHttpServletResponseEventListener()
新しいリスナを作成します。
メソッドの概要
abstract void | addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
abstract void | addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
abstract void | addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
abstract void | addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
abstract boolean | containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
abstract String | encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
abstract String | encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
abstract void | flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
abstract int | getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
abstract String | getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
protected HttpServletResponseEventConfig | getHttpServletResponseEventConfig() このリスナに渡された設定オブジェクトを返します。
abstract Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
abstract ServletOutputStream | getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
protected ServletContext | getServletContext() このリスナが実行されているサーブレットコンテキストを返します。
abstract PrintWriter | getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
protected void | handleInit() このリスナを初期化します。
void | init(HttpServletResponseEventConfig config) このビルダを初期化します。
abstract boolean | isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
abstract void | reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
abstract void | resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
abstract void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
abstract void | setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
abstract void | setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
abstract void | setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
abstract void | setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
abstract void | setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
abstract void | setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
abstract void | setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
abstract void | setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AbstractHttpServletResponseEventListener

protected AbstractHttpServletResponseEventListener()
新しいリスナを作成します。

メソッドの詳細

init

public final void init(HttpServletResponseEventConfig config)
                throws HttpServletResponseEventListenerException
このビルダを初期化します。

定義:
インタフェース HttpServletResponseEventListener 内の init
パラメータ:
config - 初期化パラメータ
例外:
ServletException - 初期化に失敗した場合
HttpServletResponseEventListenerException - 初期化に失敗した場合

handleInit

protected void handleInit()
                   throws HttpServletResponseEventListenerException
このリスナを初期化します。

このメソッドは、#init(HttpServletResponseEventListenerConfig) によって呼び出されます。 このメソッドは単にリターンするだけで、何もしません。
サブクラスが初期化処理を必要とする場合、 このメソッドをオーバーライドしてください。

例外:
ServletException - 初期化に失敗した場合
HttpServletResponseEventListenerException

getHttpServletResponseEventConfig

protected HttpServletResponseEventConfig getHttpServletResponseEventConfig()
このリスナに渡された設定オブジェクトを返します。

戻り値:
設定オブジェクト

getServletContext

protected ServletContext getServletContext()
このリスナが実行されているサーブレットコンテキストを返します。

戻り値:
サーブレットコンテキスト

getCharacterEncoding

public abstract String getCharacterEncoding(HttpServletRequest request,
                                            ExtendedHttpServletResponse response)
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

このメソッドは、単純に以下を実行します。
return response.getCharacterEncoding();

定義:
インタフェース HttpServletResponseEventListener 内の getCharacterEncoding
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
文字エンコーディング名を意味する String。
関連項目:
ServletResponse.getCharacterEncoding()

getOutputStream

public abstract ServletOutputStream getOutputStream(HttpServletRequest request,
                                                    ExtendedHttpServletResponse response)
                                             throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getOutputStream();

定義:
インタフェース HttpServletResponseEventListener 内の getOutputStream
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに #getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getWriter(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getWriter(),
ServletResponse.getOutputStream()

getWriter

public abstract PrintWriter getWriter(HttpServletRequest request,
                                      ExtendedHttpServletResponse response)
                               throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getWriter();

定義:
インタフェース HttpServletResponseEventListener 内の getWriter
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに #getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

setContentLength

public abstract void setContentLength(HttpServletRequest request,
                                      ExtendedHttpServletResponse response,
                                      int len)
レスポンスのメッセージボディ部分の長さをセットします。

このメソッドは、単純に以下を実行します。
response.setContentLength(len);

定義:
インタフェース HttpServletResponseEventListener 内の setContentLength
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
len - クライアントに送り返すメッセージボディの長さを指定する整数値。
関連項目:
ServletResponse.setContentLength(int)

setContentType

public abstract void setContentType(HttpServletRequest request,
                                    ExtendedHttpServletResponse response,
                                    String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

このメソッドは、単純に以下を実行します。
response.setContentType(type);

定義:
インタフェース HttpServletResponseEventListener 内の setContentType
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
type - コンテントタイプを指定する String
関連項目:
ServletResponse.setContentType(String),
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
#getWriter(HTTPContext, ExtendedHttpServletResponse)

setBufferSize

public abstract void setBufferSize(HttpServletRequest request,
                                   ExtendedHttpServletResponse response,
                                   int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

このメソッドは、単純に以下を実行します。
response.setBufferSize(size);

定義:
インタフェース HttpServletResponseEventListener 内の setBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合
関連項目:
ServletResponse.setBufferSize(int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

getBufferSize

public abstract int getBufferSize(HttpServletRequest request,
                                  ExtendedHttpServletResponse response)
このレスポンスに設定されている実バッファサイズを返します。

このメソッドは、単純に以下を実行します。
return response.getBufferSize();

定義:
インタフェース HttpServletResponseEventListener 内の getBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
実際に使われているバッファサイズ
関連項目:
ServletResponse.getBufferSize(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

flushBuffer

public abstract void flushBuffer(HttpServletRequest request,
                                 ExtendedHttpServletResponse response)
                          throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

このメソッドは、単純に以下を実行します。
response.flushBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の flushBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
例外:
IOException - 入出力時に例外が発生した場合
関連項目:
ServletResponse.flushBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

resetBuffer

public abstract void resetBuffer(HttpServletRequest request,
                                 ExtendedHttpServletResponse response)
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

このメソッドは、単純に以下を実行します。
response.resetBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の resetBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.resetBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

isCommitted

public abstract boolean isCommitted(HttpServletRequest request,
                                    ExtendedHttpServletResponse response)
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

このメソッドは、単純に以下を実行します。
return response.isCommitted();

定義:
インタフェース HttpServletResponseEventListener 内の isCommitted
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean
関連項目:
ServletResponse.isCommitted(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

reset

public abstract void reset(HttpServletRequest request,
                           ExtendedHttpServletResponse response)
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

このメソッドは、単純に以下を実行します。
response.reset();

定義:
インタフェース HttpServletResponseEventListener 内の reset
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.reset(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse)

setLocale

public abstract void setLocale(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

このメソッドは、単純に以下を実行します。
response.setLocale(loc);

定義:
インタフェース HttpServletResponseEventListener 内の setLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
loc - レスポンスのロケールを指定する Locale オブジェクト
関連項目:
ServletResponse.setLocale(Locale), #getLocale(HTTPContext, ExtendedHttpServletResponse)

getLocale

public abstract Locale getLocale(HttpServletRequest request,
                                 ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

このメソッドは、単純に以下を実行します。
return response.getLocale();

定義:
インタフェース HttpServletResponseEventListener 内の getLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスに設定されているロケール
関連項目:
ServletResponse.getLocale(), #setLocale(HTTPContext, ExtendedHttpServletResponse, java.util.Locale)

addCookie

public abstract void addCookie(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               Cookie cookie)
指定されたCookieをレスポンスに追加します。

このメソッドは、単純に以下を実行します。
response.addCookie(cookie);

定義:
インタフェース HttpServletResponseEventListener 内の addCookie
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
cookie - クライアントに返すCookie
関連項目:
HttpServletResponse.addCookie(Cookie)

containsHeader

public abstract boolean containsHeader(HttpServletRequest request,
                                       ExtendedHttpServletResponse response,
                                       String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

このメソッドは、単純に以下を実行します。
return response.containsHeader(name);

定義:
インタフェース HttpServletResponseEventListener 内の containsHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse
関連項目:
HttpServletResponse.containsHeader(String)

encodeURL

public abstract String encodeURL(HttpServletRequest request,
                                 ExtendedHttpServletResponse response,
                                 String url)
指定されたURLがセッションIDを含むようにエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeURL(String)

encodeRedirectURL

public abstract String encodeRedirectURL(HttpServletRequest request,
                                         ExtendedHttpServletResponse response,
                                         String url)
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeRedirectURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeRedirectURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeRedirectURL(String),
#sendRedirect(HTTPContext, ExtendedHttpServletResponse, String),
#encodeURL(HTTPContext, ExtendedHttpServletResponse, String)

sendError

public abstract void sendError(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               int sc,
                               String msg)
                        throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc, msg);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int, String)

sendError

public abstract void sendError(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               int sc)
                        throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int)

sendRedirect

public abstract void sendRedirect(HttpServletRequest request,
                                  ExtendedHttpServletResponse response,
                                  String location)
                           throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

このメソッドは、単純に以下を実行します。
response.sendRedirect(location);

定義:
インタフェース HttpServletResponseEventListener 内の sendRedirect
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendRedirect(String)

setDateHeader

public abstract void setDateHeader(HttpServletRequest request,
                                   ExtendedHttpServletResponse response,
                                   String name,
                                   long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の setDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 設定するヘッダの名称
date - 設定するヘッダの値
関連項目:
HttpServletResponse.setDateHeader(String, long),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

addDateHeader

public abstract void addDateHeader(HttpServletRequest request,
                                   ExtendedHttpServletResponse response,
                                   String name,
                                   long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の addDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 追加するヘッダの名称
date - 追加するヘッダの値
関連項目:
HttpServletResponse.addDateHeader(String, long), #setDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

setHeader

public abstract void setHeader(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               String name,
                               String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - ヘッダの値
関連項目:
HttpServletResponse.setHeader(String, String),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

addHeader

public abstract void addHeader(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               String name,
                               String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 追加するヘッダの値
関連項目:
HttpServletResponse.addHeader(String, String), #setHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

setIntHeader

public abstract void setIntHeader(HttpServletRequest request,
                                  ExtendedHttpServletResponse response,
                                  String name,
                                  int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.setIntHeader(String, int),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

addIntHeader

public abstract void addIntHeader(HttpServletRequest request,
                                  ExtendedHttpServletResponse response,
                                  String name,
                                  int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.addIntHeader(String, int), #setIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

setStatus

public abstract void setStatus(HttpServletRequest request,
                               ExtendedHttpServletResponse response,
                               int sc)
このレスポンスのステータスコードを設定します。

このメソッドは、単純に以下を実行します。
response.setStatus(sc);

定義:
インタフェース HttpServletResponseEventListener 内の setStatus
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - ステータスコード
関連項目:
HttpServletResponse.setStatus(int), #sendError(HTTPContext, ExtendedHttpServletResponse, int, java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExceptionHandlingFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ExceptionHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
すべての実装インタフェース:
Filter
public class ExceptionHandlingFilter
extends AbstractFilter

サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。

このフィルタを利用すると、例外の種類によって表示するエラーページを 切り替える事ができます。また、フォワード先ＵＲＬを JSP や Servlet にすると、 エラーログを出力するなどの例外処理をすることもできます。

フィルタの設定値は、以下のとおりです。

id.attribute.exception | フォワード先へ、発生した例外を通知するためのキー名です。 この指定値をキー名として、発生した例外を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.url | フォワード先へ、リクエストＵＲＬを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURL() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.uri | フォワード先へ、リクエストＵＲＩを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getRequestURI() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
id.attribute.servlet | フォワード先へ、サーブレットパスを通知するためのキー名です。 この指定値をキー名として、 現在の ServletRequest が #getServletPath() の結果として返す値を ServletRequest に #setAttribute() してから、エラーページへフォワードします。
path.mapping マッピングに関して定義した定義ファイルです。 定義ファイルはＸＭＬ形式で、以下のフォーマットになります。

   <error-page>
     <mapping>
      <exception-type logging="true|false (デフォルト: true)" >
         例外のクラス名
       </exception-type>
      <location>
         例外発生時にフォワードするパス
       </location>
      <location request-header="リクエストヘッダ名(小文字指定)">
         例外発生時にフォワードするパス
         （属性「request-header」と同名のリクエストヘッダーが付与されている場合）
       </location>
     </mapping>
   </error-page>
<mapping> は任意の個数だけ定義できます。

フィルタは、指定されたパスをクラスパスから検索します。 定義ファイルは、必ずクラスパスに設定されているディレクトリに 保存してください。

exception.cause.enable 例外がスローされた直接原因となった例外 （Throwable.getCause() が返す値） もチェック対象とするかどうかの設定です。

文字列 'true' を設定した場合、ネストされた例外もチェックします。 ただし、パフォーマンスが悪化する可能性があります。
文字列 'false' を設定した場合、スローされた例外のみをチェック対象とします。 パフォーマンス面では有利ですが、パターンによっては 適切なエラーページを表示できない恐れがあります。

コンストラクタの概要
ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExceptionHandlingFilter

public ExceptionHandlingFilter()
新しくフィルタオブジェクトを作成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPContextHandlingFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HTTPContextHandlingFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
すべての実装インタフェース:
Filter
public class HTTPContextHandlingFilter
extends AbstractFilter

このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。

導入されたバージョン:
version 5.0

コンストラクタの概要
HTTPContextHandlingFilter()
デフォルト・コンストラクタ
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextHandlingFilter

public HTTPContextHandlingFilter()
デフォルト・コンストラクタ

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
クラス AbstractFilter の記述:
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws IOException,
                     ServletException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
クラス AbstractFilter の記述:
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletRequestMessageBodyWrapper (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletRequestMessageBodyWrapper

すべてのスーパーインタフェース:
HttpServletRequest, ServletRequest
public interface HttpServletRequestMessageBodyWrapper
extends HttpServletRequest

HttpServletRequest を拡張したインタフェースです。

導入されたバージョン:
version 5.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletRequest から継承したフィールド
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
メソッドの概要
InputStream | getMessageBody() リクエストのメッセージボディを返します。
RequestParameter[] | getRequestParameters() パラメータ情報を返します。
インタフェース javax.servlet.http.HttpServletRequest から継承したメソッド
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
インタフェース javax.servlet.ServletRequest から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getParameter, getParameterMap, getParameterNames, getParameterValues, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

メソッドの詳細

getMessageBody

public InputStream getMessageBody()
                           throws IOException
リクエストのメッセージボディを返します。

このメソッドは、ServletRequest.getInputStream() または ServletRequest.getReader() を 実行した後でも、メッセージボディを含む入力ストリームを返します。
また同様に、 ServletRequest.getParameter(String name) を実行した後でも、メッセージボディを含む入力ストリームを返します。

戻り値:
メッセージボディを含む入力ストリーム
例外:
IOException - 入出力の例外が発生した場合

getRequestParameters

public RequestParameter[] getRequestParameters()
                                        throws IOException
パラメータ情報を返します。

戻り値:
パラメータ
例外:
IOException - 入出力エラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpServletRequestMessageBodyWrapperBuilder (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletRequestMessageBodyWrapperBuilder

public interface HttpServletRequestMessageBodyWrapperBuilder

HttpServletRequest を拡張したインタフェースです。

導入されたバージョン:
version 5.0

メソッドの概要
HttpServletRequestMessageBodyWrapper | buildExtendedHttpServletRequest(HttpServletRequest request, HttpServletResponse response) ExtendedHttpServletRequest を作成して返します。
void | destroy() このオブジェクトの破棄処理をします。
void | init(FilterConfig config) このオブジェクトを初期化します。

メソッドの詳細

init

public void init(FilterConfig config)
このオブジェクトを初期化します。

buildExtendedHttpServletRequest

public HttpServletRequestMessageBodyWrapper buildExtendedHttpServletRequest(HttpServletRequest request,
                                                                            HttpServletResponse response)
                                                                     throws IOException,
                                                                            ServletException
ExtendedHttpServletRequest を作成して返します。

パラメータ:
request - リクエスト
response - レスポンス
例外:
IOException - 入出力エラー
ServletException - その他の実行時エラー

destroy

public void destroy()
このオブジェクトの破棄処理をします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventComponentBuilder (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventComponentBuilder

public interface HttpServletResponseEventComponentBuilder

レスポンスイベントに関わる各種コンポーネント（リスナやバリデータ）をを構築するビルダです。

導入されたバージョン:
Version 6.0

メソッドの概要
HttpServletResponseEventListener[] | getListeners() リスナの配列を返します。
HttpServletResponseEventValidator[] | getValidators() バリデータの配列を返します。
void | init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。

メソッドの詳細

init

public void init(String initParameterValue,
                 ServletContext servletContext)
          throws HttpServletResponseEventException
ビルダを初期化します。

パラメータ:
initParameterValue - パラメータ
servletContext - サーブレットコンテキスト
例外:
HttpServletResponseEventException - エラーが発生した場合

getListeners

public HttpServletResponseEventListener[] getListeners()
                                                throws HttpServletResponseEventListenerException
リスナの配列を返します。

戻り値:
リスナの配列
例外:
HttpServletResponseEventListenerException - エラーが発生した場合

getValidators

public HttpServletResponseEventValidator[] getValidators()
                                                  throws HttpServletResponseEventValidatorException
バリデータの配列を返します。

戻り値:
バリデータの配列
例外:
HttpServletResponseEventValidatorException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventConfig (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventConfig

既知の実装クラスの一覧:
AbstractHttpServletResponseEventConfig
public interface HttpServletResponseEventConfig

レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。 リスナやコントローラの初期化の際に情報を渡すために使われます。

導入されたバージョン:
Version 6.0

メソッドの概要
String | getInitParameter(String name) 指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
Enumeration | getInitParameterNames() 初期化パラメータの名前である String オブジェクトの Enumeration を返します。
ServletContext | getServletContext() 呼び出したコントローラを実行している ServletContext への参照を返します。

メソッドの詳細

getInitParameter

public String getInitParameter(String name)
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。

パラメータ:
name - 初期化パラメータの名前を指定する String
戻り値:
初期化パラメータの値である Strin

getInitParameterNames

public Enumeration getInitParameterNames()
初期化パラメータの名前である String オブジェクトの Enumeration を返します。 または、初期化パラメータが無ければ空の Enumeration を返します。

戻り値:
初期化パラメータの名前である String オブジェクトの Enumeration

getServletContext

public ServletContext getServletContext()
呼び出したコントローラを実行している ServletContext への参照を返します。

戻り値:
呼び出したコントローラが Servlet コンテナとの対話に使っている ServletContext オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventController (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventController

すべてのスーパーインタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, ServletResponse
既知の実装クラスの一覧:
AbstractHttpServletResponseEventController
public interface HttpServletResponseEventController
extends ExtendedHttpServletResponse

レスポンスイベントコントローラのインタフェース。

バージョン:
6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
メソッドの概要
 void init(HttpServletResponseEventConfig config)
このビルダを初期化します。
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse から継承したメソッド
getCookies, getDateHeader, getDateHeaders, getHeader, getHeaders, getIntHeader, getIntHeaders, getStatus, getStringHeader, getStringHeaders
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse から継承したメソッド
getContentLength, getContentType, setContentType
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus

メソッドの詳細

init

public void init(HttpServletResponseEventConfig config)
          throws HttpServletResponseEventControllerException
このビルダを初期化します。

パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventControllerException - 初期化に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventControllerBuilder (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventControllerBuilder

既知の実装クラスの一覧:
StandardHttpServletResponseEventControllerBuilder
public interface HttpServletResponseEventControllerBuilder

コントローラを構築するビルダです。

導入されたバージョン:
Version 6.0

メソッドの概要
HttpServletResponseEventController | createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。

メソッドの詳細

init

public void init(String initParameterValue,
                 ServletContext servletContext)
          throws HttpServletResponseEventControllerException
ビルダを初期化します。

パラメータ:
initParameterValue - パラメータ
servletContext - サーブレットコンテキスト
例外:
HttpServletResponseEventControllerException - エラーが発生した場合

createController

public HttpServletResponseEventController createController(HttpServletRequest request,
                                                           ExtendedHttpServletResponse response,
                                                           HttpServletResponseEventListener listener)
                                                    throws HttpServletResponseEventControllerException
コントローラを返します。

戻り値:
コントローラ
例外:
HttpServletResponseEventControllerException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventControllerException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventControllerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventControllerException
extends HttpServletResponseEventException

コントローラに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventControllerException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventControllerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException(String message,
                                                   Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventControllerException

public HttpServletResponseEventControllerException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
HttpServletResponseEventControllerException, HttpServletResponseEventFilterException, HttpServletResponseEventListenerException, HttpServletResponseEventValidatorException
public class HttpServletResponseEventException
extends ExtendedServletException

イベントに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventException

public HttpServletResponseEventException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventException

public HttpServletResponseEventException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventException

public HttpServletResponseEventException(String message,
                                         Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventException

public HttpServletResponseEventException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter
すべての実装インタフェース:
Filter
public class HttpServletResponseEventFilter
extends AbstractFilter

サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。

このフィルタは、以下の設定値を持ちます。

component.builder.class | レスポンスリスナやバリデータのビルダ実装のクラス名（FQN）
component.builder.parameter | ビルダに対する初期化パラメータ
controller.builder.class | コントローラビルダ実装のクラス名（FQN）
controller.builder.parameter | コントローラビルダに対する初期化パラメータ

設定値 property.builder.class には、 HttpServletResponseEventComponentBuilder の実装クラス名を指定してください。 リスナクラスには、デフォルトコンストラクタが必要です。
property.builder.parameter に指定したパラメータ値は、 HttpServletResponseEventComponentBuilder.init(String, ServletContext) への引数に渡されます。

設定値 controller.builder.class には、 HttpServletResponseEventControllerBuilder の実装クラス名を指定してください。 リスナクラスには、デフォルトコンストラクタが必要です。
controller.builder.parameter に指定したパラメータ値は、 HttpServletResponseEventControllerBuilder.init(String, ServletContext) への引数に渡されます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
HttpServletResponseEventFilter()
新しいフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventFilter

public HttpServletResponseEventFilter()
新しいフィルタを作成します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(javax.servlet.ServletRequest, javax.servlet.ServletResponse, javax.servlet.FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventFilterException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventFilterException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventFilterException
extends HttpServletResponseEventException

レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventFilterException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventFilterException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException(String message,
                                               Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventFilterException

public HttpServletResponseEventFilterException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventListener (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventListener

既知の実装クラスの一覧:
AbstractHttpServletResponseEventListener
public interface HttpServletResponseEventListener

レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。

導入されたバージョン:
Version 6.0

メソッドの概要
void | addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
void | addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
boolean | containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
String | encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
void | flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
int | getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
String | getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
ServletOutputStream | getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
void | init(HttpServletResponseEventConfig config) このビルダを初期化します。
boolean | isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
void | setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
void | setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。

メソッドの詳細

init

public void init(HttpServletResponseEventConfig config)
          throws HttpServletResponseEventListenerException
このビルダを初期化します。

パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventListenerException - 初期化に失敗した場合

getCharacterEncoding

public String getCharacterEncoding(HttpServletRequest request,
                                   ExtendedHttpServletResponse response)
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

このメソッドは、 ServletResponse.getCharacterEncoding() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getCharacterEncoding() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
文字エンコーディング名を意味する String。
関連項目:
ServletResponse.getCharacterEncoding()

getOutputStream

public ServletOutputStream getOutputStream(HttpServletRequest request,
                                           ExtendedHttpServletResponse response)
                                    throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

このメソッドは、 ServletResponse.getOutputStream() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getOutputStream() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに #getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getWriter(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getWriter(),
ServletResponse.getOutputStream()

getWriter

public PrintWriter getWriter(HttpServletRequest request,
                             ExtendedHttpServletResponse response)
                      throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

このメソッドは、 ServletResponse.getWriter() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getWriter() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに #getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合
関連項目:
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
ServletResponse.getOutputStream(),
ServletResponse.getWriter()

setContentLength

public void setContentLength(HttpServletRequest request,
                             ExtendedHttpServletResponse response,
                             int len)
レスポンスのメッセージボディ部分の長さをセットします。

このメソッドは、 ServletResponse.setContentLength(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.setContentLength(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
len - クライアントに送り返すメッセージボディの長さを指定する整数値。
関連項目:
ServletResponse.setContentLength(int)

setContentType

public void setContentType(HttpServletRequest request,
                           ExtendedHttpServletResponse response,
                           String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

このメソッドは、 javax.servlet.ServletResponse#setContentLength(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの javax.servlet.ServletResponse#setContentLength(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
type - コンテントタイプを指定する String
関連項目:
ServletResponse.setContentType(String),
#getOutputStream(HTTPContext, ExtendedHttpServletResponse),
#getWriter(HTTPContext, ExtendedHttpServletResponse)

setBufferSize

public void setBufferSize(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

このメソッドは、 ServletResponse.setBufferSize(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.setBufferSize(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合
関連項目:
ServletResponse.setBufferSize(int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

getBufferSize

public int getBufferSize(HttpServletRequest request,
                         ExtendedHttpServletResponse response)
このレスポンスに設定されている実バッファサイズを返します。

このメソッドは、 ServletResponse.getBufferSize() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getBufferSize() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
実際に使われているバッファサイズ
関連項目:
ServletResponse.getBufferSize(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

flushBuffer

public void flushBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
                 throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

このメソッドは、 ServletResponse.flushBuffer() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.flushBuffer() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
例外:
IOException - 入出力時に例外が発生した場合
関連項目:
ServletResponse.flushBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

resetBuffer

public void resetBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

このメソッドは、 ServletResponse.resetBuffer() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.resetBuffer() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.resetBuffer(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

isCommitted

public boolean isCommitted(HttpServletRequest request,
                           ExtendedHttpServletResponse response)
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

このメソッドは、 ServletResponse.isCommitted() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.isCommitted() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean
関連項目:
ServletResponse.isCommitted(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#reset(HTTPContext, ExtendedHttpServletResponse)

reset

public void reset(HttpServletRequest request,
                  ExtendedHttpServletResponse response)
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

このメソッドは、 ServletResponse.reset() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.reset() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
関連項目:
ServletResponse.reset(),
#setBufferSize(HTTPContext, ExtendedHttpServletResponse, int),
#getBufferSize(HTTPContext, ExtendedHttpServletResponse),
#flushBuffer(HTTPContext, ExtendedHttpServletResponse),
#isCommitted(HTTPContext, ExtendedHttpServletResponse)

setLocale

public void setLocale(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

このメソッドは、 ServletResponse.setLocale(Locale) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.setLocale(Locale) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
loc - レスポンスのロケールを指定する Locale オブジェクト
関連項目:
ServletResponse.setLocale(Locale), #getLocale(HTTPContext, ExtendedHttpServletResponse)

getLocale

public Locale getLocale(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

このメソッドは、 ServletResponse.getLocale() の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの ServletResponse.getLocale() 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスに設定されているロケール
関連項目:
ServletResponse.getLocale(), #setLocale(HTTPContext, ExtendedHttpServletResponse, java.util.Locale)

addCookie

public void addCookie(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Cookie cookie)
指定されたCookieをレスポンスに追加します。

このメソッドは、 HttpServletResponse.addCookie(Cookie) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addCookie(Cookie) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
cookie - クライアントに返すCookie
関連項目:
HttpServletResponse.addCookie(Cookie)

containsHeader

public boolean containsHeader(HttpServletRequest request,
                              ExtendedHttpServletResponse response,
                              String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

このメソッドは、 HttpServletResponse.containsHeader(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.containsHeader(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse
関連項目:
HttpServletResponse.containsHeader(String)

encodeURL

public String encodeURL(HttpServletRequest request,
                        ExtendedHttpServletResponse response,
                        String url)
指定されたURLがセッションIDを含むようにエンコードします。

このメソッドは、 HttpServletResponse.encodeURL(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.encodeURL(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeURL(String)

encodeRedirectURL

public String encodeRedirectURL(HttpServletRequest request,
                                ExtendedHttpServletResponse response,
                                String url)
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

このメソッドは、 HttpServletResponse.encodeRedirectURL(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.encodeRedirectURL(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL
関連項目:
HttpServletResponse.encodeRedirectURL(String),
#sendRedirect(HTTPContext, ExtendedHttpServletResponse, String),
#encodeURL(HTTPContext, ExtendedHttpServletResponse, String)

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc,
                      String msg)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、 HttpServletResponse.sendError(int, String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.sendError(int, String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int, String)

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、 HttpServletResponse.sendError(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.sendError(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendError(int)

sendRedirect

public void sendRedirect(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String location)
                  throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

このメソッドは、 HttpServletResponse.sendRedirect(String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.sendRedirect(String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合
関連項目:
HttpServletResponse.sendRedirect(String)

setDateHeader

public void setDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

このメソッドは、 HttpServletResponse.setDateHeader(String, long) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setDateHeader(String, long) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 設定するヘッダの名称
date - 設定するヘッダの値
関連項目:
HttpServletResponse.setDateHeader(String, long),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

addDateHeader

public void addDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

このメソッドは、 HttpServletResponse.addDateHeader(String, long) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addDateHeader(String, long) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 追加するヘッダの名称
date - 追加するヘッダの値
関連項目:
HttpServletResponse.addDateHeader(String, long), #setDateHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, long)

setHeader

public void setHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

このメソッドは、 HttpServletResponse.setHeader(String, String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setHeader(String, String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - ヘッダの値
関連項目:
HttpServletResponse.setHeader(String, String),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

addHeader

public void addHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

このメソッドは、 HttpServletResponse.addHeader(String, String) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addHeader(String, String) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 追加するヘッダの値
関連項目:
HttpServletResponse.addHeader(String, String), #setHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, java.lang.String)

setIntHeader

public void setIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

このメソッドは、 HttpServletResponse.setIntHeader(String, int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setIntHeader(String, int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.setIntHeader(String, int),
#containsHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String),
#addIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

addIntHeader

public void addIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

このメソッドは、 HttpServletResponse.addIntHeader(String, int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.addIntHeader(String, int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値
関連項目:
HttpServletResponse.addIntHeader(String, int), #setIntHeader(HTTPContext, ExtendedHttpServletResponse, java.lang.String, int)

setStatus

public void setStatus(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
このレスポンスのステータスコードを設定します。

このメソッドは、 HttpServletResponse.setStatus(int) の呼び出しをフックします。 このメソッドの返り値が、フックしたレスポンスの HttpServletResponse.setStatus(int) 呼び出しに対する返り値になります。

パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - ステータスコード
関連項目:
HttpServletResponse.setStatus(int), #sendError(HTTPContext, ExtendedHttpServletResponse, int, java.lang.String)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventListenerException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventListenerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventListenerException
extends HttpServletResponseEventException

レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventListenerException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventListenerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException(String message,
                                                 Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventListenerException

public HttpServletResponseEventListenerException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventValidator (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース HttpServletResponseEventValidator

public interface HttpServletResponseEventValidator

レスポンスイベントが有効か無効かを判定するバリデータ。 このバリデータが無効と判定した場合、イベントリスナは呼び出されません。

導入されたバージョン:
Version 6.0

メソッドの概要
void | init(HttpServletResponseEventConfig config) この Validator を初期化します。
boolean | isValid(HttpServletRequest request, ExtendedHttpServletResponse response) イベントリスナを動作させるかどうかの意思決定をします。

メソッドの詳細

init

public void init(HttpServletResponseEventConfig config)
          throws HttpServletResponseEventValidatorException
この Validator を初期化します。

パラメータ:
config - 初期化パラメータ
例外:
HttpServletResponseEventValidatorException - 初期化に失敗した場合

isValid

public boolean isValid(HttpServletRequest request,
                       ExtendedHttpServletResponse response)
                throws HttpServletResponseEventValidatorException
イベントリスナを動作させるかどうかの意思決定をします。

パラメータ:
request - リクエスト
戻り値:
イベントリスナを動作させる場合 true。そうでない場合 false。
例外:
HttpServletResponseEventValidatorException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpServletResponseEventValidatorException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス HttpServletResponseEventValidatorException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 javax.servlet.ServletException
                拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
                    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
                        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException
すべての実装インタフェース:
Serializable
public class HttpServletResponseEventValidatorException
extends HttpServletResponseEventException

バリデータに関わる処理中にエラーが発生した事を通知する例外です。

導入されたバージョン:
Version 6.0
関連項目:
直列化された形式

コンストラクタの概要
HttpServletResponseEventValidatorException()
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventValidatorException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(Throwable cause)
指定された原因を使用して新規例外を構築します。
クラス javax.servlet.ServletException から継承したメソッド
getRootCause
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException()
詳細メッセージを null にして、新規例外を構築します。 このコンストラクタでは原因を初期化しません。

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException(String message)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。 このコンストラクタでは原因を初期化しません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException(String message,
                                                  Throwable cause)
指定された詳細メッセージおよび原因を使用して新規例外を構築します。

cause と関連付けられた詳細メッセージが、 この例外の詳細メッセージに自動的に統合されることはありません。

パラメータ:
message - 詳細メッセージ。詳細メッセージは Throwable.getMessage() メソッドによる取得用に保存される
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

HttpServletResponseEventValidatorException

public HttpServletResponseEventValidatorException(Throwable cause)
指定された原因を使用して新規例外を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


LuxuryResponseWriterFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス LuxuryResponseWriterFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
すべての実装インタフェース:
Filter
public class LuxuryResponseWriterFilter
extends AbstractFilter

導入されたバージョン:
version5.0
関連項目:
AbstractFilter

コンストラクタの概要
LuxuryResponseWriterFilter()
デフォルトコンストラクタ
メソッドの概要
 void doFilter(ServletRequest request, ServletResponse response, FilterChain chain)
フィルタとして動作するロジック。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, handleInit, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

LuxuryResponseWriterFilter

public LuxuryResponseWriterFilter()
デフォルトコンストラクタ

メソッドの詳細

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
クラス AbstractFilter の記述:
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
IOException - 入出力エラー
ServletException - 実行時エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NoCacheFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス NoCacheFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
すべての実装インタフェース:
Filter
public class NoCacheFilter
extends AbstractFilter

ブラウザのキャッシュを無効にするフィルタ。

このフィルタは、レスポンスヘッダに以下を追加します。

 Pragma: no-cache
 Cache-Control: no-cache
 Expires: Tue, 22 Feb 2000 12:00:00 GMT

レスポンスヘッダ Expires の値については、 フィルタの初期化パラメータ expires で任意に設定する事もできます。

設定可能な初期化パラメータは以下のとおりです。

expires コンテンツの有効期限日時

導入されたバージョン:
version 5.0

コンストラクタの概要
NoCacheFilter()
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NoCacheFilter

public NoCacheFilter()
メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
HttpServletResponseEventComponentBuilder
HttpServletResponseEventConfig
HttpServletResponseEventController
HttpServletResponseEventControllerBuilder
HttpServletResponseEventListener
HttpServletResponseEventValidator
RequestParameter
クラス
AbsoluteLinkFilter
AbstractFilter
AbstractHttpServletResponseEventConfig
AbstractHttpServletResponseEventController
AbstractHttpServletResponseEventListener
ExceptionHandlingFilter
HTTPContextHandlingFilter
HttpServletResponseEventFilter
LuxuryResponseWriterFilter
NoCacheFilter
RequestMessageBodyFilter
ResponseContentTypeManagementFilter
SimpleHttpServletResponseEventListener
StandardHttpServletResponseEventControllerBuilder
例外
HttpServletResponseEventControllerException
HttpServletResponseEventException
HttpServletResponseEventFilterException
HttpServletResponseEventListenerException
HttpServletResponseEventValidatorException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter

このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HttpServletRequestMessageBodyWrapper | HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder | HttpServletRequest を拡張したインタフェースです。
HttpServletResponseEventComponentBuilder | レスポンスイベントに関わる各種コンポーネント（リスナやバリデータ）をを構築するビルダです。
HttpServletResponseEventConfig | レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。
HttpServletResponseEventController | レスポンスイベントコントローラのインタフェース。
HttpServletResponseEventControllerBuilder | コントローラを構築するビルダです。
HttpServletResponseEventListener | レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。
HttpServletResponseEventValidator | レスポンスイベントが有効か無効かを判定するバリデータ。
RequestParameter | １つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

クラスの概要
AbsoluteLinkFilter | 絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbstractFilter | フィルタを実装するための抽象クラスです。
AbstractHttpServletResponseEventConfig | レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。
AbstractHttpServletResponseEventController | イベントを制御するレスポンスの抽象実装です。
AbstractHttpServletResponseEventListener | レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
ExceptionHandlingFilter | サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
HTTPContextHandlingFilter | このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
HttpServletResponseEventFilter | サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。
LuxuryResponseWriterFilter |
NoCacheFilter | ブラウザのキャッシュを無効にするフィルタ。
RequestMessageBodyFilter | リクエストをラップするフィルタです。
ResponseContentTypeManagementFilter | レスポンスの Content-Type を自動解決するフィルタです。
SimpleHttpServletResponseEventListener | レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。
StandardHttpServletResponseEventControllerBuilder | 標準的なコントローラを構築するビルダです。

例外の概要
HttpServletResponseEventControllerException | コントローラに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventException | イベントに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventFilterException | レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
HttpServletResponseEventListenerException | レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventValidatorException | バリデータに関わる処理中にエラーが発生した事を通知する例外です。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の説明

このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends javax.servlet.http.HttpServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface javax.servlet.http.HttpServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。
AbstractHttpServletResponseEventListener
レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
HttpServletRequestMessageBodyWrapper
HttpServletRequest を拡張したインタフェースです。
HttpServletResponseEventConfig
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。
HttpServletResponseEventController
レスポンスイベントコントローラのインタフェース。
HttpServletResponseEventControllerBuilder
コントローラを構築するビルダです。
HttpServletResponseEventControllerException
コントローラに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventException
イベントに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventListener
レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。
HttpServletResponseEventListenerException
レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventValidator
レスポンスイベントが有効か無効かを判定するバリデータ。
HttpServletResponseEventValidatorException
バリデータに関わる処理中にエラーが発生した事を通知する例外です。
RequestParameter
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
AbstractFilter
フィルタを実装するための抽象クラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestMessageBodyFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス RequestMessageBodyFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
すべての実装インタフェース:
Filter
public class RequestMessageBodyFilter
extends AbstractFilter

リクエストをラップするフィルタです。 このフィルタを利用する事により、リクエストの情報を、 いつでも取得できるようになります。

このフィルタを利用する場合は、実装を指定する必要があります。 フィルタの初期化パラメータ名 config に、 MIME タイプと インタフェース HttpServletRequestMessageBodyWrapperBuilder の 実装クラス名を指定したプロパティズファイルのパスを設定してください。

導入されたバージョン:
version 5.0

コンストラクタの概要
RequestMessageBodyFilter()
フィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
static HttpServletRequestMessageBodyWrapper | getCurrentRequest() 現在処理中のリクエストを返します。
static InputStream | getInputStream() 現在のリクエストのメッセージボディを返します。
static RequestParameter[] | getRequestParameters() 現在のリクエストのパラメータを返します。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestMessageBodyFilter

public RequestMessageBodyFilter()
フィルタを作成します。

メソッドの詳細

getInputStream

public static InputStream getInputStream()
                                  throws IOException
現在のリクエストのメッセージボディを返します。

リクエストまたはメッセージボディが不明の場合は、null を返します。

戻り値:
メッセージボディを含む入力ストリーム
例外:
IOException - 入出力の例外が発生した場合

getRequestParameters

public static RequestParameter[] getRequestParameters()
                                               throws IOException
現在のリクエストのパラメータを返します。

リクエストが不明な場合は null を返します。

戻り値:
パラメータ情報オブジェクトの配列
例外:
IOException - 入出力の例外が発生した場合

getCurrentRequest

public static HttpServletRequestMessageBodyWrapper getCurrentRequest()
現在処理中のリクエストを返します。

リクエストが不明、 またはHttpServletRequestMessageBodyWrapperに ラップされていない場合は、null を返します。

戻り値:
リクエスト

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RequestParameter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
インタフェース RequestParameter

public interface RequestParameter

１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。

導入されたバージョン:
Version 5.0

メソッドの概要
String | getHeader(String name) 指定のヘッダの値を返します。
String[] | getHeaderNames() ヘッダ名称一覧を返します。
String | getName() パラメータ名を返します。
InputStream | getNameAsStream() パラメータの名称を返します。
String | getValue() データ部を文字列表現として返します。
Reader | getValueAsReader() 推奨されていません。 getValueAsReader(String) に置き換えられました。
Reader | getValueAsReader(String encoding) データ部を Reader として取得します。
InputStream | getValueAsStream() データ部を入力ストリームとして取得します。
long | getValueLength() データ部のバイト長を返します。
boolean | hasHeader(String name) 指定された文字列がヘッダの名称かどうかを判定します。
boolean | hasHeaders() このオブジェクトがヘッダ情報を持つかどうかを判定します。

メソッドの詳細

getName

public String getName()
パラメータ名を返します。

GET の場合、各パラメータのパラメータ名を返します。
POST の場合、 フォームから送信された情報のうち、このエンティティが表す情報の もととなったフォーム中に定義されたコントロールの名称を返します。

戻り値:
パラメータ名

getNameAsStream

public InputStream getNameAsStream()
                            throws IOException
パラメータの名称を返します。

戻り値:
パラメータ名を含む入力ストリーム
例外:
IOException - 入出力エラー

getValue

public String getValue()
データ部を文字列表現として返します。

入力されたバイトデータから文字列への変換には、 リクエストの文字エンコーディング(javax.servlet.ServletRequest#getCharacterEncoding())を使います。

戻り値:
データ

getValueAsReader

public Reader getValueAsReader()
                        throws UnsupportedEncodingException,
                               IOException
推奨されていません。 getValueAsReader(String) に置き換えられました。

データ部を Reader として取得します。

文字コード変換には、 リクエストの文字エンコーディング(javax.servlet.ServletRequest#getCharacterEncoding())を使います。

戻り値:
データ
例外:
UnsupportedEncodingException
IOException

getValueAsReader

public Reader getValueAsReader(String encoding)
                        throws UnsupportedEncodingException,
                               IOException
データ部を Reader として取得します。

文字コード変換には、指定された文字エンコーディングを使います。

戻り値:
データ
例外:
UnsupportedEncodingException
IOException
導入されたバージョン:
6.1.12

getValueAsStream

public InputStream getValueAsStream()
                             throws IOException
データ部を入力ストリームとして取得します。

戻り値:
データ
例外:
IOException

getValueLength

public long getValueLength()
データ部のバイト長を返します。

戻り値:
データのサイズ

hasHeaders

public boolean hasHeaders()
このオブジェクトがヘッダ情報を持つかどうかを判定します。

戻り値:
ヘッダ情報を持つ場合 true

getHeaderNames

public String[] getHeaderNames()
ヘッダ名称一覧を返します。

このエンティティのもつヘッダ情報の名称一覧を返します。
ヘッダ情報がない場合、このメソッドは null を返します。

戻り値:
ヘッダ名称

getHeader

public String getHeader(String name)
指定のヘッダの値を返します。

指定のヘッダ名がない場合や、ヘッダ自体がない場合は、 null を返します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称にマップされている値

hasHeader

public boolean hasHeader(String name)
指定された文字列がヘッダの名称かどうかを判定します。

パラメータ:
name - ヘッダ名称
戻り値:
ヘッダ名称が値にマップされている場合 true
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ResponseContentTypeManagementFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス ResponseContentTypeManagementFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
すべての実装インタフェース:
Filter
public class ResponseContentTypeManagementFilter
extends AbstractFilter

レスポンスの Content-Type を自動解決するフィルタです。
このフィルタの次のチェーン以降でレスポンス(ServletResponse)に対して、 #setCopntentType() を呼び出さなかった場合、 #getWriter() または #getOutputStream() 呼び出し時に Content-Type を自動的に設定します。

設定する Content-Type は、このフィルタの初期化パラメータ Content-Type で 指定された値です。 初期化パラメータ Content-Type が未定義の場合、text/html が設定されます。

バージョン:
1.0

コンストラクタの概要
ResponseContentTypeManagementFilter()
新しくフィルタを作成します。
メソッドの概要
void | doFilter(ServletRequest servletRequest, ServletResponse servletResponse, FilterChain filterChain) レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
void | handleInit() このフィルタを初期化します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, handleDestroy, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ResponseContentTypeManagementFilter

public ResponseContentTypeManagementFilter()
新しくフィルタを作成します。

メソッドの詳細

handleInit

public void handleInit()
このフィルタを初期化します。

オーバーライド:
クラス AbstractFilter 内の handleInit
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest servletRequest,
                     ServletResponse servletResponse,
                     FilterChain filterChain)
              throws ServletException,
                     IOException
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。

このメソッドが作る HttpServletResponse は、引数 response をラップし、 #getWriter() または #getOutputStream() メソッドが実行された時に #setContentType() を一度も呼び出されていない場合、 フィルタの初期化パラメータで設定されている Content-Type をセットしてから、 引数 response の #getWriter() または #getOutputStream() メソッドを 呼び出します。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
servletRequest - リクエスト
servletResponse - レスポンス
filterChain - フィルタ
例外:
IOException - フィルタ処理実行時にIOExceptionが発生
ServletException - フィルタ処理実行時にServletExceptionが発生
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SimpleHttpServletResponseEventListener (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス SimpleHttpServletResponseEventListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener
すべての実装インタフェース:
HttpServletResponseEventListener
public class SimpleHttpServletResponseEventListener
extends AbstractHttpServletResponseEventListener

レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。

このクラスは、フックしたレスポンスの適当なメソッドを実行するだけの単純実装です。 アプリケーションは、このクラスを継承して、 任意のメソッドのみをオーバーライドする事により 必要なイベントフックのみを実装する事ができます。

導入されたバージョン:
Version 6.0

コンストラクタの概要
protected SimpleHttpServletResponseEventListener()
新しいリスナを作成します。
メソッドの概要
void | addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
void | addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
boolean | containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
String | encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
void | flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
int | getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
String | getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
Locale | getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
ServletOutputStream | getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
boolean | isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
void | setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
void | setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener から継承したメソッド
getHttpServletResponseEventConfig, getServletContext, handleInit, init
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

SimpleHttpServletResponseEventListener

protected SimpleHttpServletResponseEventListener()
新しいリスナを作成します。

メソッドの詳細

getCharacterEncoding

public String getCharacterEncoding(HttpServletRequest request,
                                   ExtendedHttpServletResponse response)
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。

このメソッドは、単純に以下を実行します。
return response.getCharacterEncoding();

定義:
インタフェース HttpServletResponseEventListener 内の getCharacterEncoding
定義:
クラス AbstractHttpServletResponseEventListener 内の getCharacterEncoding
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
文字エンコーディング名を意味する String。

getOutputStream

public ServletOutputStream getOutputStream(HttpServletRequest request,
                                           ExtendedHttpServletResponse response)
                                    throws IOException
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getOutputStream();

定義:
インタフェース HttpServletResponseEventListener 内の getOutputStream
定義:
クラス AbstractHttpServletResponseEventListener 内の getOutputStream
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
バイナリデータ出力に使用する ServletOutputStream
例外:
IllegalStateException - このレスポンスですでに #getWriter() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

getWriter

public PrintWriter getWriter(HttpServletRequest request,
                             ExtendedHttpServletResponse response)
                      throws IOException
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

このメソッドは、単純に以下を実行します。
return response.getWriter();

定義:
インタフェース HttpServletResponseEventListener 内の getWriter
定義:
クラス AbstractHttpServletResponseEventListener 内の getWriter
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
クライアントに文字データを送り返すことができる PrintWriter オブジェクト
例外:
UnsupportedEncodingException - setContentType メソッドで指定された文字エンコーディングがサポートされていない場合
IllegalStateException - このレスポンスですでに #getOutputStream() メソッドが実行されていた場合
IOException - 入出力時に例外が発生した場合

setContentLength

public void setContentLength(HttpServletRequest request,
                             ExtendedHttpServletResponse response,
                             int len)
レスポンスのメッセージボディ部分の長さをセットします。

このメソッドは、単純に以下を実行します。
response.setContentLength(len);

定義:
インタフェース HttpServletResponseEventListener 内の setContentLength
定義:
クラス AbstractHttpServletResponseEventListener 内の setContentLength
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
len - クライアントに送り返すメッセージボディの長さを指定する整数値。

setContentType

public void setContentType(HttpServletRequest request,
                           ExtendedHttpServletResponse response,
                           String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。

このメソッドは、単純に以下を実行します。
response.setContentType(type);

定義:
インタフェース HttpServletResponseEventListener 内の setContentType
定義:
クラス AbstractHttpServletResponseEventListener 内の setContentType
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
type - コンテントタイプを指定する String

setBufferSize

public void setBufferSize(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          int size)
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。

このメソッドは、単純に以下を実行します。
response.setBufferSize(size);

定義:
インタフェース HttpServletResponseEventListener 内の setBufferSize
定義:
クラス AbstractHttpServletResponseEventListener 内の setBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
size - 適当なバッファサイズを指定する整数値
例外:
IllegalStateException - すでにコンテンツが出力された後でこのメソッドが実行された場合

getBufferSize

public int getBufferSize(HttpServletRequest request,
                         ExtendedHttpServletResponse response)
このレスポンスに設定されている実バッファサイズを返します。

このメソッドは、単純に以下を実行します。
return response.getBufferSize();

定義:
インタフェース HttpServletResponseEventListener 内の getBufferSize
定義:
クラス AbstractHttpServletResponseEventListener 内の getBufferSize
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
実際に使われているバッファサイズ

flushBuffer

public void flushBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
                 throws IOException
バッファリングされているコンテンツを強制的にクライアントに出力します。

このメソッドは、単純に以下を実行します。
response.flushBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の flushBuffer
定義:
クラス AbstractHttpServletResponseEventListener 内の flushBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
例外:
IOException - 入出力時に例外が発生した場合

resetBuffer

public void resetBuffer(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。

このメソッドは、単純に以下を実行します。
response.resetBuffer();

定義:
インタフェース HttpServletResponseEventListener 内の resetBuffer
定義:
クラス AbstractHttpServletResponseEventListener 内の resetBuffer
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス

isCommitted

public boolean isCommitted(HttpServletRequest request,
                           ExtendedHttpServletResponse response)
レスポンスがすでにコミットされたかどうかを示す boolean を返します。

このメソッドは、単純に以下を実行します。
return response.isCommitted();

定義:
インタフェース HttpServletResponseEventListener 内の isCommitted
定義:
クラス AbstractHttpServletResponseEventListener 内の isCommitted
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスがすでにコミットされたかどうかを示す boolean

reset

public void reset(HttpServletRequest request,
                  ExtendedHttpServletResponse response)
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。

このメソッドは、単純に以下を実行します。
response.reset();

定義:
インタフェース HttpServletResponseEventListener 内の reset
定義:
クラス AbstractHttpServletResponseEventListener 内の reset
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス

setLocale

public void setLocale(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Locale loc)
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。

このメソッドは、単純に以下を実行します。
response.setLocale(loc);

定義:
インタフェース HttpServletResponseEventListener 内の setLocale
定義:
クラス AbstractHttpServletResponseEventListener 内の setLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
loc - レスポンスのロケールを指定する Locale オブジェクト

getLocale

public Locale getLocale(HttpServletRequest request,
                        ExtendedHttpServletResponse response)
レスポンスに設定されているロケールを返します。

このメソッドは、単純に以下を実行します。
return response.getLocale();

定義:
インタフェース HttpServletResponseEventListener 内の getLocale
定義:
クラス AbstractHttpServletResponseEventListener 内の getLocale
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
戻り値:
レスポンスに設定されているロケール

addCookie

public void addCookie(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      Cookie cookie)
指定されたCookieをレスポンスに追加します。

このメソッドは、単純に以下を実行します。
response.addCookie(cookie);

定義:
インタフェース HttpServletResponseEventListener 内の addCookie
定義:
クラス AbstractHttpServletResponseEventListener 内の addCookie
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
cookie - クライアントに返すCookie

containsHeader

public boolean containsHeader(HttpServletRequest request,
                              ExtendedHttpServletResponse response,
                              String name)
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。

このメソッドは、単純に以下を実行します。
return response.containsHeader(name);

定義:
インタフェース HttpServletResponseEventListener 内の containsHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の containsHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダ名
戻り値:
指定された名前のレスポンスヘッダが既にセットされていれば true、そうでなければfalse

encodeURL

public String encodeURL(HttpServletRequest request,
                        ExtendedHttpServletResponse response,
                        String url)
指定されたURLがセッションIDを含むようにエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeURL
定義:
クラス AbstractHttpServletResponseEventListener 内の encodeURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

encodeRedirectURL

public String encodeRedirectURL(HttpServletRequest request,
                                ExtendedHttpServletResponse response,
                                String url)
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。

このメソッドは、単純に以下を実行します。
return response.encodeRedirectURL(url);

定義:
インタフェース HttpServletResponseEventListener 内の encodeRedirectURL
定義:
クラス AbstractHttpServletResponseEventListener 内の encodeRedirectURL
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
url - エンコードするURL
戻り値:
エンコードが必要である場合、エンコードされたURL。 そうでない場合は与えられたそのままのURL

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc,
                      String msg)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc, msg);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
定義:
クラス AbstractHttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
msg - 説明文
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendError

public void sendError(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
               throws IOException
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。

このメソッドは、単純に以下を実行します。
response.sendError(sc);

定義:
インタフェース HttpServletResponseEventListener 内の sendError
定義:
クラス AbstractHttpServletResponseEventListener 内の sendError
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - エラーステータスコード
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

sendRedirect

public void sendRedirect(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String location)
                  throws IOException
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。

このメソッドは、単純に以下を実行します。
response.sendRedirect(location);

定義:
インタフェース HttpServletResponseEventListener 内の sendRedirect
定義:
クラス AbstractHttpServletResponseEventListener 内の sendRedirect
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
location - リダイレクト先のURL
例外:
IOException - 入出力例外が発生した場合
IllegalStateException - レスポンスが既にコミットされている場合

setDateHeader

public void setDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の setDateHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の setDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 設定するヘッダの名称
date - 設定するヘッダの値

addDateHeader

public void addDateHeader(HttpServletRequest request,
                          ExtendedHttpServletResponse response,
                          String name,
                          long date)
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addDateHeader(name, date);

定義:
インタフェース HttpServletResponseEventListener 内の addDateHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の addDateHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - 追加するヘッダの名称
date - 追加するヘッダの値

setHeader

public void setHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の setHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - ヘッダの値

addHeader

public void addHeader(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      String name,
                      String value)
指定された名称で指定された値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の addHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 追加するヘッダの値

setIntHeader

public void setIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。

このメソッドは、単純に以下を実行します。
response.setIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の setIntHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の setIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値

addIntHeader

public void addIntHeader(HttpServletRequest request,
                         ExtendedHttpServletResponse response,
                         String name,
                         int value)
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。

このメソッドは、単純に以下を実行します。
response.addIntHeader(name, value);

定義:
インタフェース HttpServletResponseEventListener 内の addIntHeader
定義:
クラス AbstractHttpServletResponseEventListener 内の addIntHeader
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
name - ヘッダの名称
value - 割り当てられる整数値

setStatus

public void setStatus(HttpServletRequest request,
                      ExtendedHttpServletResponse response,
                      int sc)
このレスポンスのステータスコードを設定します。

このメソッドは、単純に以下を実行します。
response.setStatus(sc);

定義:
インタフェース HttpServletResponseEventListener 内の setStatus
定義:
クラス AbstractHttpServletResponseEventListener 内の setStatus
パラメータ:
request - リクエスト
response - イベントの発生したレスポンス
sc - ステータスコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StandardHttpServletResponseEventControllerBuilder (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
クラス StandardHttpServletResponseEventControllerBuilder

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder
すべての実装インタフェース:
HttpServletResponseEventControllerBuilder
public class StandardHttpServletResponseEventControllerBuilder
extends Object
implements HttpServletResponseEventControllerBuilder

標準的なコントローラを構築するビルダです。

導入されたバージョン:
Version 6.0

コンストラクタの概要
StandardHttpServletResponseEventControllerBuilder()
新しいビルダを構築します。
メソッドの概要
HttpServletResponseEventController | createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
void | init(String initParameterValue, ServletContext servletContext) ビルダを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

StandardHttpServletResponseEventControllerBuilder

public StandardHttpServletResponseEventControllerBuilder()
新しいビルダを構築します。

メソッドの詳細

init

public void init(String initParameterValue,
                 ServletContext servletContext)
          throws HttpServletResponseEventControllerException
ビルダを初期化します。

定義:
インタフェース HttpServletResponseEventControllerBuilder 内の init
パラメータ:
initParameterValue - パラメータ
servletContext - サーブレットコンテキスト
例外:
HttpServletResponseEventControllerException - エラーが発生した場合

createController

public HttpServletResponseEventController createController(HttpServletRequest request,
                                                           ExtendedHttpServletResponse response,
                                                           HttpServletResponseEventListener listener)
                                                    throws HttpServletResponseEventControllerException
コントローラを返します。

定義:
インタフェース HttpServletResponseEventControllerBuilder 内の createController
戻り値:
コントローラ
例外:
HttpServletResponseEventControllerException - エラーが発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse の使用

ExtendedHttpServletResponse を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponse の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponse のサブインタフェース
 interface HttpServletResponseEventController
レスポンスイベントコントローラのインタフェース。

ExtendedHttpServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

ExtendedHttpServletResponse 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のメソッド
HttpServletResponseEventController | StandardHttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
String | SimpleHttpServletResponseEventListener.getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
ServletOutputStream | SimpleHttpServletResponseEventListener.getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | SimpleHttpServletResponseEventListener.getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
void | SimpleHttpServletResponseEventListener.setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | SimpleHttpServletResponseEventListener.setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | SimpleHttpServletResponseEventListener.setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
int | SimpleHttpServletResponseEventListener.getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
void | SimpleHttpServletResponseEventListener.flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
void | SimpleHttpServletResponseEventListener.resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
boolean | SimpleHttpServletResponseEventListener.isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | SimpleHttpServletResponseEventListener.reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | SimpleHttpServletResponseEventListener.setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
Locale | SimpleHttpServletResponseEventListener.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
void | SimpleHttpServletResponseEventListener.addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
boolean | SimpleHttpServletResponseEventListener.containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | SimpleHttpServletResponseEventListener.encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
String | SimpleHttpServletResponseEventListener.encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
void | SimpleHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | SimpleHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | SimpleHttpServletResponseEventListener.sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | SimpleHttpServletResponseEventListener.setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | SimpleHttpServletResponseEventListener.addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | SimpleHttpServletResponseEventListener.setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | SimpleHttpServletResponseEventListener.addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | SimpleHttpServletResponseEventListener.setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | SimpleHttpServletResponseEventListener.addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
void | SimpleHttpServletResponseEventListener.setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
boolean | HttpServletResponseEventValidator.isValid(HttpServletRequest request, ExtendedHttpServletResponse response) イベントリスナを動作させるかどうかの意思決定をします。
String | HttpServletResponseEventListener.getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
ServletOutputStream | HttpServletResponseEventListener.getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
PrintWriter | HttpServletResponseEventListener.getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
void | HttpServletResponseEventListener.setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
void | HttpServletResponseEventListener.setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
void | HttpServletResponseEventListener.setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
int | HttpServletResponseEventListener.getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
void | HttpServletResponseEventListener.flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
void | HttpServletResponseEventListener.resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
boolean | HttpServletResponseEventListener.isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
void | HttpServletResponseEventListener.reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
void | HttpServletResponseEventListener.setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
Locale | HttpServletResponseEventListener.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
void | HttpServletResponseEventListener.addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
boolean | HttpServletResponseEventListener.containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
String | HttpServletResponseEventListener.encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
String | HttpServletResponseEventListener.encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
void | HttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | HttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
void | HttpServletResponseEventListener.sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
void | HttpServletResponseEventListener.setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
void | HttpServletResponseEventListener.addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
void | HttpServletResponseEventListener.setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
void | HttpServletResponseEventListener.addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
void | HttpServletResponseEventListener.setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
void | HttpServletResponseEventListener.addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
void | HttpServletResponseEventListener.setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
HttpServletResponseEventController | HttpServletResponseEventControllerBuilder.createController(HttpServletRequest request, ExtendedHttpServletResponse response, HttpServletResponseEventListener listener) コントローラを返します。
abstract String | AbstractHttpServletResponseEventListener.getCharacterEncoding(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
abstract ServletOutputStream | AbstractHttpServletResponseEventListener.getOutputStream(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
abstract PrintWriter | AbstractHttpServletResponseEventListener.getWriter(HttpServletRequest request, ExtendedHttpServletResponse response) 文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
abstract void | AbstractHttpServletResponseEventListener.setContentLength(HttpServletRequest request, ExtendedHttpServletResponse response, int len) レスポンスのメッセージボディ部分の長さをセットします。
abstract void | AbstractHttpServletResponseEventListener.setContentType(HttpServletRequest request, ExtendedHttpServletResponse response, String type) クライアントに送り返されるレスポンスのコンテントタイプをセットします。
abstract void | AbstractHttpServletResponseEventListener.setBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response, int size) 適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
abstract int | AbstractHttpServletResponseEventListener.getBufferSize(HttpServletRequest request, ExtendedHttpServletResponse response) このレスポンスに設定されている実バッファサイズを返します。
abstract void | AbstractHttpServletResponseEventListener.flushBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているコンテンツを強制的にクライアントに出力します。
abstract void | AbstractHttpServletResponseEventListener.resetBuffer(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
abstract boolean | AbstractHttpServletResponseEventListener.isCommitted(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスがすでにコミットされたかどうかを示す boolean を返します。
abstract void | AbstractHttpServletResponseEventListener.reset(HttpServletRequest request, ExtendedHttpServletResponse response) バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
abstract void | AbstractHttpServletResponseEventListener.setLocale(HttpServletRequest request, ExtendedHttpServletResponse response, Locale loc) レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
abstract Locale | AbstractHttpServletResponseEventListener.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。
abstract void | AbstractHttpServletResponseEventListener.addCookie(HttpServletRequest request, ExtendedHttpServletResponse response, Cookie cookie) 指定されたCookieをレスポンスに追加します。
abstract boolean | AbstractHttpServletResponseEventListener.containsHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name) 指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
abstract String | AbstractHttpServletResponseEventListener.encodeURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) 指定されたURLがセッションIDを含むようにエンコードします。
abstract String | AbstractHttpServletResponseEventListener.encodeRedirectURL(HttpServletRequest request, ExtendedHttpServletResponse response, String url) #sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
abstract void | AbstractHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc, String msg) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | AbstractHttpServletResponseEventListener.sendError(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
abstract void | AbstractHttpServletResponseEventListener.sendRedirect(HttpServletRequest request, ExtendedHttpServletResponse response, String location) 指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
abstract void | AbstractHttpServletResponseEventListener.setDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
abstract void | AbstractHttpServletResponseEventListener.addDateHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, long date) 指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
abstract void | AbstractHttpServletResponseEventListener.setHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを設定します。
abstract void | AbstractHttpServletResponseEventListener.addHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, String value) 指定された名称で指定された値を持つレスポンスヘッダを追加します。
abstract void | AbstractHttpServletResponseEventListener.setIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
abstract void | AbstractHttpServletResponseEventListener.addIntHeader(HttpServletRequest request, ExtendedHttpServletResponse response, String name, int value) 指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
abstract void | AbstractHttpServletResponseEventListener.setStatus(HttpServletRequest request, ExtendedHttpServletResponse response, int sc) このレスポンスのステータスコードを設定します。
Locale | AbstractHttpServletResponseEventController.getLocale(HttpServletRequest request, ExtendedHttpServletResponse response) レスポンスに設定されているロケールを返します。

ExtendedHttpServletResponse 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter のコンストラクタ
AbstractHttpServletResponseEventController(ExtendedHttpServletResponse response)
新しいインスタンスを生成します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での ExtendedHttpServletResponse の使用

ExtendedHttpServletResponse を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
class | ExtendedHttpServletResponseWrapper レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
class | SearchableHttpServletResponseWrapper HttpServletResponseWrapperの拡張実装を提供します。

ExtendedHttpServletResponse を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
 ExtendedHttpServletResponse ExtendedHttpServletResponseWrapper.getExtendedHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。

ExtendedHttpServletResponse 型のパラメータを持つ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のコンストラクタ
ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper の使用

ExtendedHttpServletResponseWrapper を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponseWrapper の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter での ExtendedHttpServletResponseWrapper のサブクラス
 class AbstractHttpServletResponseEventController
イベントを制御するレスポンスの抽象実装です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext の使用

HTTPContext を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での HTTPContext の使用

HTTPContext を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
abstract HTTPContext | HTTPContextManager.getCurrentContext() 現在のスレッドに関連付けられた HTTP コンテキストを返します。
abstract HTTPContext[] | HTTPContextManager.getAllContext() マネージャーが保持するすべての HTTP コンテキストを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の使用

HTTPContextManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http での HTTPContextManager の使用

HTTPContextManager を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のメソッド
static HTTPContextManager HTTPContextManager.getInstance()
HTTP コンテキスト・マネージャのインスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager の使用

HttpSessionManager を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での HttpSessionManager の使用

HttpSessionManager を実装している jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のクラス
 class AbstractHttpSessionManager
インタフェース HttpSessionManager の抽象実装です。

HttpSessionManager を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
abstract  HttpSessionManager HttpSessionManagerFactory.getManager()
マネージャを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の使用

HttpSessionManagerFactory を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での HttpSessionManagerFactory の使用

HttpSessionManagerFactory を返す jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
static HttpSessionManagerFactory HttpSessionManagerFactory.getInstance()
インスタンスを返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException の使用

NoSuchSessionException を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session での NoSuchSessionException の使用

NoSuchSessionException をスローする jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のメソッド
long | HttpSessionManager.getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
long | HttpSessionManager.getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | HttpSessionManager.getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
abstract long | AbstractHttpSessionManager.getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
abstract long | AbstractHttpSessionManager.getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
abstract int | AbstractHttpSessionManager.getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AbstractHttpSessionManager (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス AbstractHttpSessionManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager
すべての実装インタフェース:
HttpSessionManager
public abstract class AbstractHttpSessionManager
extends Object
implements HttpSessionManager

インタフェース HttpSessionManager の抽象実装です。 インタフェースを実装するクラスは、この抽象実装を継承すると便利です。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected AbstractHttpSessionManager()
HttpSessionManager の抽象実装を構築します。
メソッドの概要
abstract String[] | getAllIds() 現在有効なすべての HttpSession のセッションＩＤを返します。
abstract long | getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
abstract long | getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | getLength() 現在有効な HttpSession の数を返します。
abstract int | getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager から継承したメソッド
getCount

コンストラクタの詳細

AbstractHttpSessionManager

protected AbstractHttpSessionManager()
HttpSessionManager の抽象実装を構築します。

メソッドの詳細

getLength

public int getLength()
現在有効な HttpSession の数を返します。

戻り値:
有効な HttpSession の個数

getAllIds

public abstract String[] getAllIds()
現在有効なすべての HttpSession のセッションＩＤを返します。 セッションＩＤは、HttpSession.getId() が 返す値です。

定義:
インタフェース HttpSessionManager 内の getAllIds
戻り値:
セッションＩＤの配列

getCreationTime

public abstract long getCreationTime(String id)
                              throws NoSuchSessionException,
                                     UnsupportedOperationException
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getCreationTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getCreationTime
パラメータ:
id - セッションＩＤ
戻り値:
セッションが作成された時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getLastAccessedTime

public abstract long getLastAccessedTime(String id)
                                  throws NoSuchSessionException,
                                         UnsupportedOperationException
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getLastAccessedTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getLastAccessedTime
パラメータ:
id - セッションＩＤ
戻り値:
セッションに対して最後にアクセスした時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getMaxInactiveInterval

public abstract int getMaxInactiveInterval(String id)
                                    throws NoSuchSessionException,
                                           UnsupportedOperationException
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getMaxInactiveInterval() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

定義:
インタフェース HttpSessionManager 内の getMaxInactiveInterval
パラメータ:
id - セッションＩＤ
戻り値:
クライアントからのリクエストの間に何秒間セッションを持続するかを表す数値
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionManager (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
インタフェース HttpSessionManager

既知の実装クラスの一覧:
AbstractHttpSessionManager
public interface HttpSessionManager

HttpSession に関する情報を提供するクラスの共通インタフェース定義です。

導入されたバージョン:
version 5.0

メソッドの概要
String[] | getAllIds() 現在有効なすべての HttpSession のセッションＩＤを返します。
int | getCount() 現在有効な HttpSession の数を返します。
long | getCreationTime(String id) 指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
long | getLastAccessedTime(String id) 指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
int | getMaxInactiveInterval(String id) 指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。

メソッドの詳細

getCount

public int getCount()
現在有効な HttpSession の数を返します。

戻り値:
有効な HttpSession の個数

getAllIds

public String[] getAllIds()
現在有効なすべての HttpSession のセッションＩＤを返します。 セッションＩＤは、HttpSession.getId() が 返す値です。

戻り値:
セッションＩＤの配列

getCreationTime

public long getCreationTime(String id)
                     throws NoSuchSessionException,
                            UnsupportedOperationException
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getCreationTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
セッションが作成された時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getLastAccessedTime

public long getLastAccessedTime(String id)
                         throws NoSuchSessionException,
                                UnsupportedOperationException
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getLastAccessedTime() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
セッションに対して最後にアクセスした時刻
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合

getMaxInactiveInterval

public int getMaxInactiveInterval(String id)
                           throws NoSuchSessionException,
                                  UnsupportedOperationException
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。（任意のオペレーション） このメソッドが返す値は、 HttpSession.getMaxInactiveInterval() が返す値です。

指定のＩＤに関連付けられている有効なＨＴＴＰセッションがない場合、 NoSuchSessionException をスローします。

このインタフェースの実装が、このメソッドをサポートしない場合、 UnsupportedOperationException をスローします。

パラメータ:
id - セッションＩＤ
戻り値:
クライアントからのリクエストの間に何秒間セッションを持続するかを表す数値
例外:
NoSuchSessionException - 指定のＩＤに関連付けられた有効なセッションを見つけられなかった場合
UnsupportedOperationException - このメソッドがサポートされない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HttpSessionManagerFactory (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionManagerFactory

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
public abstract class HttpSessionManagerFactory
extends Object

HttpSessionManager を作成するファクトリクラスの抽象実装です。

導入されたバージョン:
version 5.0

コンストラクタの概要
protected HttpSessionManagerFactory()
新しい HttpSessionManagerFactory を構築します。
メソッドの概要
static HttpSessionManagerFactory | getInstance() インスタンスを返します。
abstract HttpSessionManager | getManager() マネージャを返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionManagerFactory

protected HttpSessionManagerFactory()
新しい HttpSessionManagerFactory を構築します。

メソッドの詳細

getInstance

public static HttpSessionManagerFactory getInstance()
インスタンスを返します。
このメソッドが返すファクトリは、システムに標準実装されているものです。 独自実装を利用する場合は、このクラスを継承して新しいサブクラスを 作成してください。

戻り値:
ファクトリオブジェクトを返します。

getManager

public abstract HttpSessionManager getManager()
マネージャを返します。

戻り値:
マネージャ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionMonitoringFilter (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionMonitoringFilter

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter
        拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
すべての実装インタフェース:
Filter
public class HttpSessionMonitoringFilter
extends AbstractFilter

HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。 このフィルタを設定し動作させる事で、HttpSessionManager の標準実装が 正しい値を返します。

導入されたバージョン:
version 5.0

コンストラクタの概要
HttpSessionMonitoringFilter()
新しい HttpSessionMonitoringFilter を構築します。
メソッドの概要
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) フィルタとして動作するロジック。
protected void | handleDestroy() フィルタの破棄処理。
protected void | handleInit() フィルタの初期化をします。
クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter から継承したメソッド
destroy, getFilterConfig, getServletContext, init, log, log
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionMonitoringFilter

public HttpSessionMonitoringFilter()
新しい HttpSessionMonitoringFilter を構築します。

メソッドの詳細

handleInit

protected void handleInit()
                   throws ServletException
フィルタの初期化をします。

このメソッドは、フィルタ初期化時に AbstractFilter.init(FilterConfig) に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが初期化処理を必要とする場合は、 このメソッドをオーバーライドして初期化処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleInit
例外:
ServletException - 初期化エラー
関連項目:
AbstractFilter.init(FilterConfig)

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
フィルタとして動作するロジック。

定義:
インタフェース Filter 内の doFilter
定義:
クラス AbstractFilter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - チェーンの次のエンティティ
例外:
ServletException - 実行時エラー
IOException - 入出力エラー
関連項目:
Filter.doFilter(ServletRequest, ServletResponse, FilterChain)

handleDestroy

protected void handleDestroy()
フィルタの破棄処理。

このメソッドは、フィルタ破棄時に AbstractFilter.destroy() に 呼び出されます。
このメソッドは何もしません。ただリターンするだけです。

サブクラスが破棄処理を必要とする場合は、 このメソッドをオーバーライドして破棄処理を実装してください。

オーバーライド:
クラス AbstractFilter 内の handleDestroy
関連項目:
AbstractFilter.destroy()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HttpSessionMonitoringListener (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス HttpSessionMonitoringListener

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener
すべての実装インタフェース:
EventListener, HttpSessionListener
public class HttpSessionMonitoringListener
extends Object
implements HttpSessionListener

HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。 このリスナを設定し動作させる事で、HttpSessionManager の標準実装が 正しい値を返します。

導入されたバージョン:
version 5.0

コンストラクタの概要
HttpSessionMonitoringListener()
新しいセッションリスナを構築します。
メソッドの概要
void | sessionCreated(HttpSessionEvent se) セッションが作成されたことを通知します。
void | sessionDestroyed(HttpSessionEvent se) セッションが無効になったことを通知します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HttpSessionMonitoringListener

public HttpSessionMonitoringListener()
新しいセッションリスナを構築します。

メソッドの詳細

sessionCreated

public void sessionCreated(HttpSessionEvent se)
セッションが作成されたことを通知します。

定義:
インタフェース HttpSessionListener 内の sessionCreated
パラメータ:
se - 通知するイベント

sessionDestroyed

public void sessionDestroyed(HttpSessionEvent se)
セッションが無効になったことを通知します。

定義:
インタフェース HttpSessionListener 内の sessionDestroyed
パラメータ:
se - 通知するイベント
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NoSuchSessionException (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
クラス NoSuchSessionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
すべての実装インタフェース:
Serializable
public class NoSuchSessionException
extends Exception

特定のＨＴＴＰセッションが見つからない場合にスローされます。

導入されたバージョン:
version 5.0
関連項目:
直列化された形式

コンストラクタの概要
NoSuchSessionException()
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String message)
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String message, Throwable cause)
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable cause)
指定された原因を使用して新しい NoSuchSessionException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

NoSuchSessionException

public NoSuchSessionException()
詳細メッセージを持たない NoSuchSessionException を構築します。

NoSuchSessionException

public NoSuchSessionException(String message)
詳細メッセージを持つ NoSuchSessionException を構築します。

パラメータ:
message - 詳細メッセージ

NoSuchSessionException

public NoSuchSessionException(String message,
                              Throwable cause)
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。

パラメータ:
message - 詳細メッセージ
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す

NoSuchSessionException

public NoSuchSessionException(Throwable cause)
指定された原因を使用して新しい NoSuchSessionException を構築します。

パラメータ:
cause - 原因 (Throwable.getCause() メソッドによる取得用に保存される)。null 値が許可される。null 値は原因が存在しないか未知であることを示す
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
インタフェース
HttpSessionManager
クラス
AbstractHttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
例外
NoSuchSessionException


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
HttpSessionManager HttpSession に関する情報を提供するクラスの共通インタフェース定義です。

クラスの概要
AbstractHttpSessionManager | インタフェース HttpSessionManager の抽象実装です。
HttpSessionManagerFactory | HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionMonitoringFilter | HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringListener | HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。

例外の概要
NoSuchSessionException 特定のＨＴＴＰセッションが見つからない場合にスローされます。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の説明

このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session のクラス
HttpSessionManager
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory
HttpSessionManager を作成するファクトリクラスの抽象実装です。
NoSuchSessionException
特定のＨＴＴＰセッションが見つからない場合にスローされます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtendedHttpServletResponse (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース ExtendedHttpServletResponse

すべてのスーパーインタフェース:
ExtendedServletResponse, HttpServletResponse, ServletResponse
既知のサブインタフェースの一覧:
HttpServletResponseEventController
既知の実装クラスの一覧:
AbstractHttpServletResponseEventController, ExtendedHttpServletResponseWrapper, SearchableHttpServletResponseWrapper
public interface ExtendedHttpServletResponse
extends ExtendedServletResponse, HttpServletResponse

このインタフェースは、HttpServletResponseを拡張したものです。

導入されたバージョン:
version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
メソッドの概要
Cookie[] | getCookies() このレスポンスにセットされたすべての Cookie を返します。
Long | getDateHeader(String name) 指定された名称でレスポンスヘッダに設定されている日付の値を返します。
long[] | getDateHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
Object | getHeader(String name) 指定された名称でレスポンスヘッダに設定されている値を返します。
Object[] | getHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての値を返します。
Integer | getIntHeader(String name) 指定された名称でレスポンスヘッダに設定されている数値を返します。
int[] | getIntHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
Integer | getStatus() レスポンスにセットされている ステータスコードを返します。
String | getStringHeader(String name) 指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
String[] | getStringHeaders(String name) 指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
インタフェース jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse から継承したメソッド
getContentLength, getContentType, setContentType
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus

メソッドの詳細

getStatus

public Integer getStatus()
レスポンスにセットされている ステータスコードを返します。
このメソッドは、 HttpServletResponse.sendRedirect(String location)、 HttpServletResponse.sendError(int sc)、 HttpServletResponse.sendError(int sc, String msg)、 HttpServletResponse.setStatus(int sc)、 またはHttpServletResponse.setStatus(int sc, String sm) によってセットされたステータスコードを返します。 値を未設定の場合、null を返します。

戻り値:
ステータスコード

getIntHeader

public Integer getIntHeader(String name)
指定された名称でレスポンスヘッダに設定されている数値を返します。 このヘッダに対して数値を未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている整数値

getIntHeaders

public int[] getIntHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して数値を未設定の場合、空の配列を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての整数値

getDateHeader

public Long getDateHeader(String name)
指定された名称でレスポンスヘッダに設定されている日付の値を返します。 このヘッダに対して日付の値を未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている日付の値

getDateHeaders

public long[] getDateHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して日付の値を未設定の場合、空の配列を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての日付の値

getStringHeader

public String getStringHeader(String name)
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。 このヘッダに対して文字列の値を未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている文字列の値

getStringHeaders

public String[] getStringHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して文字列の値を未設定の場合、空の配列を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての文字列の値

getHeader

public Object getHeader(String name)
指定された名称でレスポンスヘッダに設定されている値を返します。 ヘッダをセットするために利用したメソッドにより、 返り値の型が決定されます。
メソッド 返り値の型
HttpServletResponse.addDateHeader(String name, long date) Long
HttpServletResponse.setDateHeader(String name, long date) Long
HttpServletResponse.addIntHeader(String name, int value) Integer
HttpServletResponse.setIntHeader(String name, int value) Integer
HttpServletResponse.addHeader(String name, String value) String
HttpServletResponse.setHeader(String name, String value) String
このヘッダが未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている値

getHeaders

public Object[] getHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての値を返します。 配列の各要素の型は、getHeader(String)の返り値と同様です。 このヘッダが未設定の場合、null を返します。

パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての値

getCookies

public Cookie[] getCookies()
このレスポンスにセットされたすべての Cookie を返します。 Cookie を未設定の場合、null を返します。

戻り値:
セットされている全ての Cookie
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedHttpServletResponseWrapper (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス ExtendedHttpServletResponseWrapper

java.lang.Object
    拡張 javax.servlet.ServletResponseWrapper
        拡張 javax.servlet.http.HttpServletResponseWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper
すべての実装インタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, ServletResponse
直系の既知のサブクラス:
AbstractHttpServletResponseEventController
public class ExtendedHttpServletResponseWrapper
extends HttpServletResponseWrapper
implements ExtendedHttpServletResponse

レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
このクラスは、WrapperパターンもしくはDecoratorパターンに基づいて 実装されています。 各々のメソッドは、ラップされたレスポンスオブジェクトのメソッドを デフォルトで呼び出します。

導入されたバージョン:
version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
コンストラクタの概要
protected ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
メソッドの概要
 Integer getContentLength()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentLength() メソッドをそのまま呼び出します。
 ContentType getContentType()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentType() メソッドをそのまま呼び出します。
 Cookie[] getCookies()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getCookies() メソッドをそのまま呼び出します。
 Long getDateHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeader(String) メソッドをそのまま呼び出します。
 long[] getDateHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeaders(String) メソッドをそのまま呼び出します。
 ExtendedHttpServletResponse getExtendedHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。
 Object getHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeader(String) メソッドをそのまま呼び出します。
 Object[] getHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeaders(String) メソッドをそのまま呼び出します。
 Integer getIntHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeader(String) メソッドをそのまま呼び出します。
 int[] getIntHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeaders(String) メソッドをそのまま呼び出します。
 Integer getStatus()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse#getStatus(String) メソッドをそのまま呼び出します。
 String getStringHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeader(String) メソッドをそのまま呼び出します。
 String[] getStringHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeaders(String) メソッドをそのまま呼び出します。
 void setContentType(ContentType type)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#setContentType(ContentType) メソッドをそのまま呼び出します。
クラス javax.servlet.http.HttpServletResponseWrapper から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus
クラス javax.servlet.ServletResponseWrapper から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getResponse, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
addCookie, addDateHeader, addHeader, addIntHeader, containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL, sendError, sendError, sendRedirect, setDateHeader, setHeader, setIntHeader, setStatus, setStatus

コンストラクタの詳細

ExtendedHttpServletResponseWrapper

protected ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。

パラメータ:
response - ラップ対象となるレスポンス
例外:
IllegalArgumentException - response が null である場合
メソッドの詳細

getStatus

public Integer getStatus()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse#getStatus(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getStatus
戻り値:
ステータスコード

getIntHeader

public Integer getIntHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getIntHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている整数値

getIntHeaders

public int[] getIntHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getIntHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての整数値

getDateHeader

public Long getDateHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getDateHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている日付の値

getDateHeaders

public long[] getDateHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getDateHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての日付の値

getStringHeader

public String getStringHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getStringHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている文字列の値

getStringHeaders

public String[] getStringHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getStringHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての文字列の値

getHeader

public Object getHeader(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeader(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getHeader
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている値

getHeaders

public Object[] getHeaders(String name)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeaders(String) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getHeaders
パラメータ:
name - ヘッダの名称
戻り値:
割り当てられている全ての値

getCookies

public Cookie[] getCookies()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getCookies() メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedHttpServletResponse 内の getCookies
戻り値:
セットされている全ての Cookie

getContentType

public ContentType getContentType()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentType() メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedServletResponse 内の getContentType
戻り値:
コンテントタイプを指定する ContentType

setContentType

public void setContentType(ContentType type)
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#setContentType(ContentType) メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedServletResponse 内の setContentType
パラメータ:
type - コンテントタイプを指定する ContentType

getContentLength

public Integer getContentLength()
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentLength() メソッドをそのまま呼び出します。

定義:
インタフェース ExtendedServletResponse 内の getContentLength
戻り値:
クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値

getExtendedHttpServletResponse

public ExtendedHttpServletResponse getExtendedHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。

戻り値:
ラップされているレスポンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HTTPContext (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース HTTPContext

public interface HTTPContext

リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。

メソッドの概要
HttpSession | getCurrentSession() このリクエストに関連づけられている現在のセッションを返します。
HttpServletRequest | getRequest() リクエストを返します。
HttpServletResponse | getResponse() レスポンスを返します。
ServletContext | getServletContext() サーブレットコンテキストを返します。
HttpSession | getSession() このリクエストに関連づけられている現在のセッションを返します。
void | log(String message) Servlet ログファイルに指定されたメッセージを出力します。
void | log(String message, Throwable throwable) 与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

メソッドの詳細

getServletContext

public ServletContext getServletContext()
サーブレットコンテキストを返します。

戻り値:
サーブレットコンテキスト

getRequest

public HttpServletRequest getRequest()
リクエストを返します。

戻り値:
リクエスト

getResponse

public HttpServletResponse getResponse()
レスポンスを返します。

戻り値:
レスポンス

getSession

public HttpSession getSession()
このリクエストに関連づけられている現在のセッションを返します。 リクエストがセッションを持たない場合はセッションを生成します。

戻り値:
このリクエストに関連づけられているHttpSession

getCurrentSession

public HttpSession getCurrentSession()
このリクエストに関連づけられている現在のセッションを返します。 リクエストが有効なHttpSessionを持たない場合は nullを返します。

戻り値:
このリクエストに関連づけられているHttpSession。リクエストが有効なセッションを持っていなければ null。

log

public void log(String message)
Servlet ログファイルに指定されたメッセージを出力します。

このメソッドは、現在の ServletContext の #log(String) を呼び出します。

パラメータ:
message - ログファイルに出力するメッセージを指定する String
関連項目:
ServletContext.log(String msg)

log

public void log(String message,
                Throwable throwable)
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

このメソッドは、現在の ServletContext の #log(String, Throwable) を呼び出します。

パラメータ:
message - エラーや例外を解説する String
throwable - Throwable エラーや例外
関連項目:
ServletContext.log(String message, Throwable throwable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


HTTPContextManager (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス HTTPContextManager

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
public abstract class HTTPContextManager
extends Object

HTTP コンテキスト・マネージャ

導入されたバージョン:
version 5.0

コンストラクタの概要
protected HTTPContextManager()
デフォルトコンストラクタ getInstance()を利用してください。
メソッドの概要
abstract HTTPContext[] | getAllContext() マネージャーが保持するすべての HTTP コンテキストを返します。
abstract HTTPContext | getCurrentContext() 現在のスレッドに関連付けられた HTTP コンテキストを返します。
static HTTPContextManager | getInstance() HTTP コンテキスト・マネージャのインスタンスを取得します。
abstract int | getLength() マネージャーが保持する HTTP コンテキストの数を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HTTPContextManager

protected HTTPContextManager()
デフォルトコンストラクタ getInstance()を利用してください。

メソッドの詳細

getInstance

public static HTTPContextManager getInstance()
HTTP コンテキスト・マネージャのインスタンスを取得します。

戻り値:
HTTP コンテキスト・マネージャ

getCurrentContext

public abstract HTTPContext getCurrentContext()
現在のスレッドに関連付けられた HTTP コンテキストを返します。

戻り値:
現在のスレッドに関連付けられた HTTP コンテキスト

getAllContext

public abstract HTTPContext[] getAllContext()
                                     throws UnsupportedOperationException
マネージャーが保持するすべての HTTP コンテキストを返します。

戻り値:
マネージャーが保持するすべての HTTP コンテキストの配列
例外:
UnsupportedOperationException - サブクラスが本メソッドをサポートしていない場合

getLength

public abstract int getLength()
                       throws UnsupportedOperationException
マネージャーが保持する HTTP コンテキストの数を返します。

戻り値:
マネージャーが保持する HTTP コンテキストの数
例外:
UnsupportedOperationException - サブクラスが本メソッドをサポートしていない場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
インタフェース
ExtendedHttpServletResponse
HTTPContext
クラス
EmptyParameterHttpServletRequestWrapper
ExtendedHttpServletResponseWrapper
HTTPContextManager
SearchableHttpServletResponseWrapper


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http

このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ExtendedHttpServletResponse | このインタフェースは、HttpServletResponseを拡張したものです。
HTTPContext | リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。

クラスの概要
EmptyParameterHttpServletRequestWrapper | エンプティーリクエストパラメータサーブレットリクエストラッパー。
ExtendedHttpServletResponseWrapper | レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
HTTPContextManager | HTTP コンテキスト・マネージャ
SearchableHttpServletResponseWrapper | HttpServletResponseWrapperの拡張実装を提供します。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の説明

このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet.http クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • class javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)

インタフェース階層

  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends javax.servlet.http.HttpServletResponse)
    • interface javax.servlet.http.HttpServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse)


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
ExtendedHttpServletResponse
このインタフェースは、HttpServletResponseを拡張したものです。
ExtendedHttpServletResponseWrapper
レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet.http のクラス
ExtendedHttpServletResponse
このインタフェースは、HttpServletResponseを拡張したものです。
HTTPContext
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextManager
HTTP コンテキスト・マネージャ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SearchableHttpServletResponseWrapper (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス SearchableHttpServletResponseWrapper

java.lang.Object
    拡張 javax.servlet.ServletResponseWrapper
        拡張 javax.servlet.http.HttpServletResponseWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper
すべての実装インタフェース:
ExtendedHttpServletResponse, ExtendedServletResponse, HttpServletResponse, ServletResponse
public class SearchableHttpServletResponseWrapper
extends HttpServletResponseWrapper
implements ExtendedHttpServletResponse

HttpServletResponseWrapperの拡張実装を提供します。 このクラスを利用する事により、レスポンスにセットした値を取得可能になり、 アプリケーションプログラム内での情報操作の利便性が向上します。

導入されたバージョン:
version 6.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletResponse から継承したフィールド
SC_ACCEPTED, SC_BAD_GATEWAY, SC_BAD_REQUEST, SC_CONFLICT, SC_CONTINUE, SC_CREATED, SC_EXPECTATION_FAILED, SC_FORBIDDEN, SC_GATEWAY_TIMEOUT, SC_GONE, SC_HTTP_VERSION_NOT_SUPPORTED, SC_INTERNAL_SERVER_ERROR, SC_LENGTH_REQUIRED, SC_METHOD_NOT_ALLOWED, SC_MOVED_PERMANENTLY, SC_MOVED_TEMPORARILY, SC_MULTIPLE_CHOICES, SC_NO_CONTENT, SC_NON_AUTHORITATIVE_INFORMATION, SC_NOT_ACCEPTABLE, SC_NOT_FOUND, SC_NOT_IMPLEMENTED, SC_NOT_MODIFIED, SC_OK, SC_PARTIAL_CONTENT, SC_PAYMENT_REQUIRED, SC_PRECONDITION_FAILED, SC_PROXY_AUTHENTICATION_REQUIRED, SC_REQUEST_ENTITY_TOO_LARGE, SC_REQUEST_TIMEOUT, SC_REQUEST_URI_TOO_LONG, SC_REQUESTED_RANGE_NOT_SATISFIABLE, SC_RESET_CONTENT, SC_SEE_OTHER, SC_SERVICE_UNAVAILABLE, SC_SWITCHING_PROTOCOLS, SC_TEMPORARY_REDIRECT, SC_UNAUTHORIZED, SC_UNSUPPORTED_MEDIA_TYPE, SC_USE_PROXY
コンストラクタの概要
SearchableHttpServletResponseWrapper(HttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
メソッドの概要
 void addCookie(Cookie cookie)
このメソッドは、スーパークラスにある HttpServletResponseWrapper.addCookie(Cookie cookie) メソッドをそのまま呼び出します。
 void addDateHeader(String name, long date)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
 void addHeader(String name, String value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
 void addIntHeader(String name, int value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
 Integer getContentLength()
レスポンスにセットされている メッセージボディ部の長さを返します。
 ContentType getContentType()
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
 Cookie[] getCookies()
このレスポンスにセットされたすべての Cookie を返します。
 Long getDateHeader(String name)
指定された名称でレスポンスヘッダに設定されている日付の値を返します。
 long[] getDateHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
 Object getHeader(String name)
指定された名称でレスポンスヘッダに設定されている値を返します。
 Object[] getHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての値を返します。
 HttpServletResponse getHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。
 Integer getIntHeader(String name)
指定された名称でレスポンスヘッダに設定されている数値を返します。
 int[] getIntHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
 Integer getStatus()
レスポンスにセットされている ステータスコードを返します。
 String getStringHeader(String name)
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
 String[] getStringHeaders(String name)
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
 void reset()
このメソッドは、スーパークラスの ServletResponseWrapper.reset() メソッドをそのまま呼び出します。
 void sendError(int sc)
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int) メソッドをそのまま呼び出します。
 void sendError(int sc, String msg)
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int, java.lang.String) メソッドをそのまま呼び出します。
 void sendRedirect(String location)
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendRedirect(java.lang.String) メソッドをそのまま呼び出します。
 void setContentLength(int len)
レスポンスのメッセージボディ部分の長さをセットします。
 void setContentType(ContentType type)
このメソッドは、 type の ContentType.toString() が返す値を ラップしている ServletResponse にセットします。
 void setContentType(String type)
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
 void setDateHeader(String name, long date)
このメソッドは、スーパークラスの HttpServletResponseWrapper.setDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
 void setHeader(String name, String value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.setHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
 void setIntHeader(String name, int value)
このメソッドは、スーパークラスの HttpServletResponseWrapper.setIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
 void setStatus(int sc)
このレスポンスのステータスコードを設定します。
 void setStatus(int sc, String sm)
推奨されていません。
クラス javax.servlet.http.HttpServletResponseWrapper から継承したメソッド
containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL
クラス javax.servlet.ServletResponseWrapper から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getResponse, getWriter, isCommitted, resetBuffer, setBufferSize, setLocale, setResponse
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, resetBuffer, setBufferSize, setLocale
インタフェース javax.servlet.http.HttpServletResponse から継承したメソッド
containsHeader, encodeRedirectUrl, encodeRedirectURL, encodeUrl, encodeURL

コンストラクタの詳細

SearchableHttpServletResponseWrapper

public SearchableHttpServletResponseWrapper(HttpServletResponse response)
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。

パラメータ:
response - ラップされるレスポンス・オブジェクト
例外:
IllegalArgumentException - response が null である場合
メソッドの詳細

getHttpServletResponse

public HttpServletResponse getHttpServletResponse()
このオブジェクトにラップされているレスポンスを返します。

戻り値:
ラップされているレスポンス

addCookie

public void addCookie(Cookie cookie)
このメソッドは、スーパークラスにある HttpServletResponseWrapper.addCookie(Cookie cookie) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 cookie を保持します。 保持したオブジェクト cookie は、 getCookies()メソッドによって アプリケーションに返されます。

定義:
インタフェース HttpServletResponse 内の addCookie
パラメータ:
cookie - クライアントに返すCookie

getCookies

public Cookie[] getCookies()
このレスポンスにセットされたすべての Cookie を返します。 Cookie を１つもセットしていない場合、null を返します。

定義:
インタフェース ExtendedHttpServletResponse 内の getCookies
戻り値:
セットされている全ての Cookie

addDateHeader

public void addDateHeader(String name,
                          long date)
このメソッドは、スーパークラスの HttpServletResponseWrapper.addDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および date を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getDateHeader(java.lang.String)
  • getDateHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の addDateHeader
    関連項目:
    HttpServletResponse.addDateHeader(java.lang.String, long), HttpServletResponseWrapper.addDateHeader(java.lang.String, long)

    • setDateHeader

    public void setDateHeader(String name,
                          long date)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.setDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および date を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getDateHeader(java.lang.String)
  • getDateHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の setDateHeader
    関連項目:
    HttpServletResponse.setDateHeader(java.lang.String, long), HttpServletResponseWrapper.setDateHeader(java.lang.String, long)

    • getDateHeader

    public Long getDateHeader(String name)
    指定された名称でレスポンスヘッダに設定されている日付の値を返します。 このヘッダに対して日付の値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getDateHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている日付の値

    getDateHeaders

    public long[] getDateHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して日付の値を未設定の場合、空の配列を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getDateHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての日付の値

    addIntHeader

    public void addIntHeader(String name,
                         int value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.addIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getIntHeader(java.lang.String)
  • getIntHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の addIntHeader
    関連項目:
    HttpServletResponse.addIntHeader(java.lang.String, int), HttpServletResponseWrapper.addIntHeader(java.lang.String, int)

    • setIntHeader

    public void setIntHeader(String name,
                         int value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.setIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getIntHeader(java.lang.String)
  • getIntHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の setIntHeader
    関連項目:
    HttpServletResponse.setIntHeader(java.lang.String, int), HttpServletResponseWrapper.setIntHeader(java.lang.String, int)

    • getIntHeader

    public Integer getIntHeader(String name)
    指定された名称でレスポンスヘッダに設定されている数値を返します。 このヘッダに対して数値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getIntHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている整数値

    getIntHeaders

    public int[] getIntHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての数値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して数値を未設定の場合、空の配列を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getIntHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての整数値

    addHeader

    public void addHeader(String name,
                      String value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.addHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getStringHeader(java.lang.String)
  • getStringHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の addHeader
    関連項目:
    HttpServletResponse.addHeader(java.lang.String, java.lang.String), HttpServletResponseWrapper.addHeader(java.lang.String, java.lang.String)

    • setHeader

    public void setHeader(String name,
                      String value)
    このメソッドは、スーパークラスの HttpServletResponseWrapper.setHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 name および value を保持します。 保持した情報は、以下のメソッドによってアプリケーションに返されます。
  • getStringHeader(java.lang.String)
  • getStringHeaders(java.lang.String)
  • getHeader(java.lang.String)
  • getHeaders(java.lang.String)

    定義:
    インタフェース HttpServletResponse 内の setHeader
    関連項目:
    HttpServletResponse.setHeader(java.lang.String, java.lang.String), HttpServletResponseWrapper.setHeader(java.lang.String, java.lang.String)

    • getStringHeader

    public String getStringHeader(String name)
    指定された名称でレスポンスヘッダに設定されている文字列の値を返します。 このヘッダに対して文字列の値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getStringHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている文字列の値

    getStringHeaders

    public String[] getStringHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。 このヘッダに対して値を未設定の場合、null を返します。 このヘッダに対して文字列の値を未設定の場合、空の配列を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getStringHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての文字列の値

    getHeader

    public Object getHeader(String name)
    指定された名称でレスポンスヘッダに設定されている値を返します。 ヘッダをセットするために利用したメソッドにより、 返り値の型が決定されます。
    メソッド 返り値の型
    HttpServletResponse.addDateHeader(String name, long date) Long
    HttpServletResponse.setDateHeader(String name, long date) Long
    HttpServletResponse.addIntHeader(String name, int value) Integer
    HttpServletResponse.setIntHeader(String name, int value) Integer
    HttpServletResponse.addHeader(String name, String value) String
    HttpServletResponse.setHeader(String name, String value) String
    このヘッダが未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getHeader
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている値

    getHeaders

    public Object[] getHeaders(String name)
    指定された名称でレスポンスヘッダに設定されている全ての値を返します。 配列の各要素の型は、getHeader(String)の返り値と同様です。 このヘッダが未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getHeaders
    パラメータ:
    name - ヘッダの名称
    戻り値:
    割り当てられている全ての値

    setStatus

    public void setStatus(int sc,
                      String sm)
    推奨されていません。

    定義:
    インタフェース HttpServletResponse 内の setStatus
    パラメータ:
    sc - ステータスコード
    sm - ステータスメッセージ
    関連項目:
    HttpServletResponse.setStatus(int, java.lang.String)

    setStatus

    public void setStatus(int sc)
    このレスポンスのステータスコードを設定します。

    このメソッドは、スーパークラスの HttpServletResponseWrapper.setStatus(int) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 sc を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の setStatus
    パラメータ:
    sc - ステータスコード
    関連項目:
    HttpServletResponse.setStatus(int)

    sendError

    public void sendError(int sc,
                      String msg)
               throws IOException
    このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int, java.lang.String) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 sc を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の sendError
    パラメータ:
    sc - ステータスコード
    msg - 説明文
    例外:
    IOException
    関連項目:
    HttpServletResponse.sendError(int, java.lang.String)

    sendError

    public void sendError(int sc)
               throws IOException
    このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 sc を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の sendError
    パラメータ:
    sc - ステータスコード
    例外:
    IOException
    関連項目:
    HttpServletResponse.sendError(int)

    sendRedirect

    public void sendRedirect(String location)
                  throws IOException
    このメソッドは、スーパークラスの HttpServletResponseWrapper.sendRedirect(java.lang.String) メソッドをそのまま呼び出します。 このメソッドでは、ステータスコード HttpServletResponse.SC_MOVED_TEMPORARILY が指定されたと判断し、このオブジェクト内に HttpServletResponse.SC_MOVED_TEMPORARILY を保持します。 保持した情報は、getStatus()によってアプリケーションに返されます。

    定義:
    インタフェース HttpServletResponse 内の sendRedirect
    パラメータ:
    location - リダイレクト先のURL
    例外:
    IOException
    関連項目:
    HttpServletResponse.sendRedirect(java.lang.String)

    getStatus

    public Integer getStatus()
    レスポンスにセットされている ステータスコードを返します。
    このメソッドは、 HttpServletResponse.sendRedirect(String location)、 HttpServletResponse.sendError(int sc)、 HttpServletResponse.sendError(int sc, String msg)、 HttpServletResponse.setStatus(int sc)、 またはHttpServletResponse.setStatus(int sc, String sm) によってセットされたステータスコードを返します。 値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedHttpServletResponse 内の getStatus
    戻り値:
    ステータスコード

    setContentLength

    public void setContentLength(int len)
    レスポンスのメッセージボディ部分の長さをセットします。

    このメソッドは、スーパークラスの ServletResponseWrapper.setContentLength(int) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 len を保持します。 保持した情報は、getContentLength()によってアプリケーションに返されます。

    定義:
    インタフェース ServletResponse 内の setContentLength
    パラメータ:
    len - クライアントに送り返すメッセージボディの長さを指定する整数
    関連項目:
    ServletResponse.setContentLength(int)

    getContentLength

    public Integer getContentLength()
    レスポンスにセットされている メッセージボディ部の長さを返します。
    このメソッドは、ServletResponse.setContentLength(int len) によってセットされた長さを返します。 値を未設定の場合、null を返します。

    定義:
    インタフェース ExtendedServletResponse 内の getContentLength
    戻り値:
    クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値

    setContentType

    public void setContentType(String type)
    クライアントに送り返されるレスポンスのコンテントタイプをセットします。

    このメソッドは、スーパークラスの ServletResponseWrapper.setContentType(java.lang.String) メソッドをそのまま呼び出します。 その後、このオブジェクト内に引数 type を保持します。 保持した情報は、getContentType()によってアプリケーションに返されます。

    定義:
    インタフェース ServletResponse 内の setContentType
    パラメータ:
    type - コンテントタイプを指定する String
    例外:
    IllegalArgumentException - type の構文解析に失敗した場合
    関連項目:
    ServletResponse.setContentType(java.lang.String)

    getContentType

    public ContentType getContentType()
    レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。

    定義:
    インタフェース ExtendedServletResponse 内の getContentType
    戻り値:
    コンテントタイプを指定する ContentType
    関連項目:
    ServletResponse.setContentType(java.lang.String)

    setContentType

    public void setContentType(ContentType type)
    このメソッドは、 type の ContentType.toString() が返す値を ラップしている ServletResponse にセットします。

    定義:
    インタフェース ExtendedServletResponse 内の setContentType
    パラメータ:
    type - コンテントタイプを指定する ContentType
    関連項目:
    ServletResponse.setContentType(java.lang.String)

    reset

    public void reset()
    このメソッドは、スーパークラスの ServletResponseWrapper.reset() メソッドをそのまま呼び出します。 その後、このオブジェクト内に保持している各データをクリアし、初期状態に戻します。

    定義:
    インタフェース ServletResponse 内の reset
    例外:
    IllegalStateException - レスポンスがすでにコミットされている場合
    関連項目:
    ServletResponse.reset()
    概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
            intra-mart 6.1.14
    前のクラス 次のクラス | フレームあり フレームなし
    概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedServletResponse (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet
インタフェース ExtendedServletResponse

すべてのスーパーインタフェース:
ServletResponse
既知のサブインタフェースの一覧:
ExtendedHttpServletResponse, HttpServletResponseEventController
既知の実装クラスの一覧:
AbstractHttpServletResponseEventController, ExtendedHttpServletResponseWrapper, SearchableHttpServletResponseWrapper
public interface ExtendedServletResponse
extends ServletResponse

このインタフェースは、ServletResponseを拡張したものです。

導入されたバージョン:
version 6.0

メソッドの概要
Integer | getContentLength() レスポンスにセットされている メッセージボディ部の長さを返します。
ContentType | getContentType() レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
void | setContentType(ContentType type) レスポンスに Content-Type をセットします。
インタフェース javax.servlet.ServletResponse から継承したメソッド
flushBuffer, getBufferSize, getCharacterEncoding, getLocale, getOutputStream, getWriter, isCommitted, reset, resetBuffer, setBufferSize, setContentLength, setContentType, setLocale

メソッドの詳細

getContentType

public ContentType getContentType()
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
このメソッドは、 ServletResponse.setContentType(String type) または setContentType(ContentType) によってセットされたコンテントタイプを返します。 コンテントタイプには、 例えば、 text/html; charset=ISO-8859-4 のように 文字エンコーディングのタイプが含まれることがあります。

戻り値:
コンテントタイプを指定する ContentType

setContentType

public void setContentType(ContentType type)
レスポンスに Content-Type をセットします。

このメソッドは、 ContentType での 引数指定を可能とするインタフェースを提供します。

パラメータ:
type - コンテントタイプを指定する ContentType

getContentLength

public Integer getContentLength()
レスポンスにセットされている メッセージボディ部の長さを返します。
このメソッドは、ServletResponse.setContentLength(int len) によってセットされた長さを返します。 値を未設定の場合、null を返します。

戻り値:
クライアントに送り返すメッセージボディの長さを指定する整数値。 HTTP の Content-Length ヘッダフィールドの値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


FilterServletInputStream (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet
クラス FilterServletInputStream

java.lang.Object
    拡張 java.io.InputStream
        拡張 javax.servlet.ServletInputStream
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
public class FilterServletInputStream
extends ServletInputStream

InputStream を ServletInputStream に変換するためのラッパです。

このクラスは、基礎ストリームの対応するメソッドを呼び出すだけです。 各メソッドをオーバーライドして再定義することにより、 入力をフィルタリングする事ができます。

導入されたバージョン:
Version 5.0

コンストラクタの概要
FilterServletInputStream(InputStream in)
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
メソッドの概要
int | available() この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。
void | close() 入力を閉じます。
protected InputStream | getInputStream() このオブジェクトがラップしている入力ストリームを返します。
void | mark(int readlimit) 入力ストリームの現在位置にマークを設定します。
boolean | markSupported() 入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。
int | read() 基礎入力から１バイト読み込みます。
int | read(byte[] b) 基礎入力から指定のバイト配列にデータを読み込みます。
int | read(byte[] b, int off, int len) 基礎入力から指定のバイト配列にデータを読み込みます。
void | reset() このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。
long | skip(long n) 指定のバイト数だけ入力をスキップします。
クラス javax.servlet.ServletInputStream から継承したメソッド
readLine
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FilterServletInputStream

public FilterServletInputStream(InputStream in)
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。

パラメータ:
in - 入力ストリーム
メソッドの詳細

getInputStream

protected InputStream getInputStream()
このオブジェクトがラップしている入力ストリームを返します。

戻り値:
入力ストリーム

read

public int read()
         throws IOException
基礎入力から１バイト読み込みます。

このメソッドは、以下と同じです。
getInputStream().read()

戻り値:
データの次のバイト。ストリームの終わりに達した場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b)
         throws IOException
基礎入力から指定のバイト配列にデータを読み込みます。

このメソッドは、以下と同じです。
getInputStream().read(b)

パラメータ:
b - データの読み込み先のバッファ
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
基礎入力から指定のバイト配列にデータを読み込みます。

このメソッドは、以下と同じです。
getInputStream().read(b, off, len)

パラメータ:
b - データの読み込み先のバッファ
off - データが書き込まれる配列 b の開始オフセット
len - 読み込む最大バイト数
戻り値:
バッファに読み込まれたバイトの合計数。ストリームの終わりに達してデータがない場合は -1
例外:
IOException - 入出力エラーが発生した場合

skip

public long skip(long n)
          throws IOException
指定のバイト数だけ入力をスキップします。

このメソッドは、以下と同じです。
getInputStream().skip(n)

パラメータ:
n - スキップするバイト数
戻り値:
実際にスキップされたバイト数
例外:
IOException - 入出力エラーが発生した場合

available

public int available()
              throws IOException
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

このメソッドは、以下と同じです。
getInputStream().available()

戻り値:
ブロックしないで入力ストリームから読み込むことができるバイト数
例外:
IOException - 入出力エラーが発生した場合

close

public void close()
           throws IOException
入力を閉じます。

このメソッドは、以下と同じです。
getInputStream().close()

例外:
IOException - 入出力エラーが発生した場合

mark

public void mark(int readlimit)
入力ストリームの現在位置にマークを設定します。

このメソッドは、以下と同じです。
getInputStream().mark(readlimit)

パラメータ:
readlimit - マーク位置が無効になる前に読み込み可能なバイトの最大リミット

reset

public void reset()
           throws IOException
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。

このメソッドは、以下と同じです。
getInputStream().reset()

例外:
IOException - ストリームにマークが設定されていなかった場合、またはマークが無効になっていた場合

markSupported

public boolean markSupported()
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。

このメソッドは、以下と同じです。
getInputStream().markSupported()

戻り値:
このストリームインスタンスが mark および reset メソッドをサポートしている場合は true、サポートしていない場合は false
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.javax.servlet (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.javax.servlet
インタフェース
ExtendedServletResponse
クラス
FilterServletInputStream


jp.co.intra_mart.common.aid.jsdk.javax.servlet (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。

参照:
説明

インタフェースの概要
ExtendedServletResponse このインタフェースは、ServletResponseを拡張したものです。

クラスの概要
FilterServletInputStream InputStream を ServletInputStream に変換するためのラッパです。

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の説明

このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。


jp.co.intra_mart.common.aid.jsdk.javax.servlet クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream

インタフェース階層

  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse


パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet を使用しているパッケージ
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet のクラス
ExtendedServletResponse
このインタフェースは、ServletResponseを拡張したものです。

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http により使用される jp.co.intra_mart.common.aid.jsdk.javax.servlet のクラス
ExtendedServletResponse
このインタフェースは、ServletResponseを拡張したものです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の使用

jp.co.intra_mart.common.aid.jsdk.utility.BrowseString はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の使用

jp.co.intra_mart.common.aid.jsdk.utility.URLUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BrowseString (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.utility
クラス BrowseString

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
public class BrowseString
extends Object

HTML表示用文字列変換ユーティリティクラス。

HTML表示用に文字列の変換を行うクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
static String convert(String string)
HTML表示可能な文字列に変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convert

public static String convert(String string)
HTML表示可能な文字列に変換します。

「>」、「<」、「"」、「&」、「半角スペース」、「改行コード」をHTML表示可能な文字に変換します。
改行コードは「<BR>」に変換します。

パラメータ:
string - 変換元文字列
戻り値:
変換された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.jsdk.utility (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.jsdk.utility
クラス
BrowseString
URLUtil


jp.co.intra_mart.common.aid.jsdk.utility (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

参照:
説明

クラスの概要
BrowseString | HTML表示用文字列変換ユーティリティクラス。
URLUtil | URL関連のユーティリティクラス。

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の説明

このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.common.aid.jsdk.utility クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.jsdk.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.common.aid.jsdk.utility の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.jsdk.utility の使用

jp.co.intra_mart.common.aid.jsdk.utility はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


URLUtil (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.utility
クラス URLUtil

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.jsdk.utility.URLUtil
public class URLUtil
extends Object

URL関連のユーティリティクラス。

HttpServletRequestが保持している情報を元に、URLを生成するクラスです。

導入されたバージョン:
5.0
バージョン:
1.0

コンストラクタの概要
URLUtil()
メソッドの概要
static String | encodeUrl(String src) 文字列をURLエンコードします。
static URL | getContextURL(HttpServletRequest request) 引数で与えられたリクエストのコンテキストを示すURLを生成します。
static URL | getContextURL(HttpServletRequest request, boolean appendSlash) 引数で与えられたリクエストのコンテキストを示すURLを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

URLUtil

public URLUtil()
メソッドの詳細

getContextURL

public static URL getContextURL(HttpServletRequest request)
                         throws MalformedURLException
引数で与えられたリクエストのコンテキストを示すURLを生成します。
このメソッドで生成されたURLの末尾は、常にスラッシュとなります。

パラメータ:
request - リクエスト
戻り値:
要求のコンテキストを示すURL
例外:
MalformedURLException - 引数で与えられたリクエストに使用されるスキーマが未知である場合

getContextURL

public static URL getContextURL(HttpServletRequest request,
                                boolean appendSlash)
                         throws MalformedURLException
引数で与えられたリクエストのコンテキストを示すURLを生成します。
このメソッドで生成されたURLの末尾は、引数 appendSlash によって変化します。

パラメータ:
request - リクエスト
appendSlash - このメソッドで生成されたURLの末尾にスラッシュを付加する場合は、true、　それ以外はfalse
戻り値:
要求のコンテキストを示すURL
例外:
MalformedURLException - 引数で与えられたリクエストに使用されるスキーマが未知である場合

encodeUrl

public static String encodeUrl(String src)
文字列をURLエンコードします。

パラメータ:
src - URLエンコード元文字列
戻り値:
URLエンコード後の文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (im_javaee_assist 6.1.14 API)

 すべてのクラス
AbsoluteLinkFilter
AbstractFilter
AbstractHttpServletResponseEventConfig
AbstractHttpServletResponseEventController
AbstractHttpServletResponseEventListener
AbstractHttpSessionManager
BadRequestException
BrowseString
EmptyParameterHttpServletRequestWrapper
EmptyQueryException
ExceptionHandlingFilter
ExcessiveQueryException
ExtendedHttpServletResponse
ExtendedHttpServletResponseWrapper
ExtendedServletException
ExtendedServletResponse
FilterServletInputStream
ForbiddenException
HTTPContext
HTTPContextHandlingFilter
HTTPContextManager
HttpServletRequestMessageBodyWrapper
HttpServletRequestMessageBodyWrapperBuilder
HttpServletResponseEventComponentBuilder
HttpServletResponseEventConfig
HttpServletResponseEventController
HttpServletResponseEventControllerBuilder
HttpServletResponseEventControllerException
HttpServletResponseEventException
HttpServletResponseEventFilter
HttpServletResponseEventFilterException
HttpServletResponseEventListener
HttpServletResponseEventListenerException
HttpServletResponseEventValidator
HttpServletResponseEventValidatorException
HttpSessionManager
HttpSessionManagerFactory
HttpSessionMonitoringFilter
HttpSessionMonitoringListener
IMDiskFileItem
IMDiskFileItemFactory
IMFileItemFactory
IMMultipartStream
IMServletFileUpload
LengthRequiredException
LuxuryResponseWriterFilter
MultipartFormData
MultipartFormData.Entity
MultipartFormDataResourceBundle
NoCacheFilter
NoSuchSessionException
NotFoundException
RequestEntityTooLargeException
RequestMessageBodyFilter
RequestParameter
ResponseContentTypeManagementFilter
SearchableHttpServletResponseWrapper
ServiceUnavailableException
SimpleHttpServletResponseEventListener
StandardHttpServletResponseEventControllerBuilder
URLUtil
UnauthorizedException
UnripeQueryException


定数フィールド値 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle
public static final String | DEFAULT_MULTIPART_PROPERTIES | "jp.co.intra_mart.common.aid.javaee.http.MultipartFormData"
public static final int | DEFAULT_SIZETHRESHOLD | 10240
public static final String | KEY_REPOSITORY | "repository"
public static final String | KEY_SIZE_THRESHOLD | "size_threshold"
public static final String | KEY_USE_COMMONS_FILEUPLOAD | "use_commons_fileupload"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないメソッド
jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity.getReader()
MultipartFormData.Entity.getReader(String) に置き換えられました。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter.getValueAsReader()
RequestParameter.getValueAsReader(String) に置き換えられました。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper.setStatus(int, String)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし
A B C D E F G H I J K L M N P R S T U W

A

AbsoluteLinkFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter.
絶対表現のＵＲＬをレスポンスするためのフィルタ。
AbsoluteLinkFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のコンストラクタ
フィルタを新しく作成します。
AbstractFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter.
フィルタを実装するための抽象クラスです。
AbstractFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のコンストラクタ
フィルタオブジェクトを作成します。
AbstractHttpServletResponseEventConfig - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig.
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトの抽象実装です。
AbstractHttpServletResponseEventConfig(ServletContext) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のコンストラクタ
新しい設定オブジェクトを作成します。
AbstractHttpServletResponseEventController - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController.
イベントを制御するレスポンスの抽象実装です。
AbstractHttpServletResponseEventController(ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のコンストラクタ
新しいインスタンスを生成します。
AbstractHttpServletResponseEventListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener.
レスポンスの各メソッド呼び出しに対するイベントをフックするための抽象実装です。
AbstractHttpServletResponseEventListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のコンストラクタ
新しいリスナを作成します。
AbstractHttpSessionManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager.
インタフェース HttpSessionManager の抽象実装です。
AbstractHttpSessionManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のコンストラクタ
HttpSessionManager の抽象実装を構築します。
add(int, Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの指定された位置に、指定された要素を挿入します。
add(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの最後に、指定された要素を追加します。
addAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの末尾に、指定された Collection のすべての要素を追加します。
addAll(int, Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の指定された位置から、指定された Collection のすべての要素を挿入します。
addCookie(Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(HttpServletRequest, ExtendedHttpServletResponse, Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(HttpServletRequest, ExtendedHttpServletResponse, Cookie) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(HttpServletRequest, ExtendedHttpServletResponse, Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定されたCookieをレスポンスに追加します。
addCookie(Cookie) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスにある HttpServletResponseWrapper.addCookie(Cookie cookie) メソッドをそのまま呼び出します。
addDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを追加します。
addDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.addDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
addHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを追加します。
addHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.addHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
addIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを追加します。
addIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.addIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
available() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
この入力ストリームのメソッドの次の呼び出し側からブロックされることなく、 この入力ストリームから読み込むことができる(またはスキップできる)バイト数 を返します。

B

BadRequestException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException.
不正なリクエストを受け付けたことを通知するための例外です。
BadRequestException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージを持つ例外を作成します。
BadRequestException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
BadRequestException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException のコンストラクタ
例外を作成します。
BrowseString - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString.
HTML表示用文字列変換ユーティリティクラス。
buildExtendedHttpServletRequest(HttpServletRequest, HttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
ExtendedHttpServletRequest を作成して返します。

C

clear() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストからすべての要素を削除します。
close() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力を閉じます。
contains(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストに指定の要素がある場合に true を返します。
containsAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このコレクション内に、指定されたコレクションのすべての要素がある場合に true を返します。
containsHeader(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
containsHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
containsHeader(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名前を持つヘッダが既にセットされているかどうかを表す booleanを返します。
convert(String) - class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString の static メソッド
HTML表示可能な文字列に変換します。
createController(HttpServletRequest, ExtendedHttpServletResponse, HttpServletResponseEventListener) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder のメソッド
コントローラを返します。
createController(HttpServletRequest, ExtendedHttpServletResponse, HttpServletResponseEventListener) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder のメソッド
コントローラを返します。
createItem(String, String, boolean, String, Map) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory のメソッド
ヘッダ情報を含むFileItemを生成します。
createItem(String, String, boolean, String, Map) - interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory のメソッド
ヘッダ情報を含むFileItemを生成します。
createItem(Map, boolean) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド

D

DEFAULT_MULTIPART_PROPERTIES - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
プロパティファイル名
DEFAULT_SIZETHRESHOLD - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
useCommonsFileuploadがtrueの場合、一時ファイルを作成するデフォルトの閾値（単位：バイト）
delete() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
一時ファイルを削除します。
destroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの終了処理。
destroy() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトの破棄処理をします。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter のメソッド
フィルタ処理します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のメソッド
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタとして動作するロジック。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
レスポンスソースの Content-Type を 自動解決する HttpServletResponse を作成して、 次のフィルタチェーンを実行します。
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタとして動作するロジック。

E

EmptyParameterHttpServletRequestWrapper - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper.
エンプティーリクエストパラメータサーブレットリクエストラッパー。
EmptyParameterHttpServletRequestWrapper(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のコンストラクタ
コンストラクタ。
EmptyQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException.
クエリがない場合にスローされる例外です。
EmptyQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
EmptyQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
EmptyQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException のコンストラクタ
例外を作成します。
ExceptionHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter.
サーブレットの実行例外をキャッチして、 指定のエラーページへフォワードするフィルタです。
ExceptionHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のコンストラクタ
新しくフィルタオブジェクトを作成します。
ExcessiveQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException.
クエリが Content-Length ヘッダで指定された量よりも過剰な場合に スローされる例外です。
ExcessiveQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ExcessiveQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ExcessiveQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException のコンストラクタ
例外を作成します。
ExtendedHttpServletResponse - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse.
このインタフェースは、HttpServletResponseを拡張したものです。
ExtendedHttpServletResponseWrapper - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper.
レスポンスのサプクラス化による拡張を可能とする ExtendedHttpServletResponse インタフェースの簡潔な実装方法を提供します。
ExtendedHttpServletResponseWrapper(ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のコンストラクタ
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
ExtendedServletException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException.
Servlet 例外の拡張モデルです。
ExtendedServletException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
例外オブジェクトを作成します。
ExtendedServletException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージを持つ例外を作成します。
ExtendedServletException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
指定されたメッセージと根本原因となった例外を持つ例外を作成します。
ExtendedServletException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException のコンストラクタ
根本原因となった例外を持つ例外を作成します。
ExtendedServletResponse - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse.
このインタフェースは、ServletResponseを拡張したものです。
encodeRedirectURL(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
AbstractHttpServletResponseEventController.sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeRedirectURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeRedirectURL(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeRedirectURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
#sendRedirect(String) メソッドの中で使えるように、 指定されたURLをエンコードします。
encodeURL(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeURL(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定されたURLがセッションIDを含むようにエンコードします。
encodeUrl(String) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
文字列をURLエンコードします。
ensureCapacity(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
必要に応じて、この ArrayList のインスタンスのサイズを拡大し、少なくとも最小サイズ引数で指定された数の要素を格納できるようにします。
entry(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
entry(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
このフィルタによってＵＲＬの制御を行うことを定義します。
equals(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定されたオブジェクトとリストが等しいかどうかを比較します。

F

FilterServletInputStream - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream.
InputStream を ServletInputStream に変換するためのラッパです。
FilterServletInputStream(InputStream) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のコンストラクタ
指定の入力を基礎入力とするサーブレット入力ストリームを作成します。
ForbiddenException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException.
アクセス権限がないことを通知する例外です。
ForbiddenException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ForbiddenException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ForbiddenException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException のコンストラクタ
例外を作成します。
flushBuffer() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
flushBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
flushBuffer(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。
flushBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファリングされているコンテンツを強制的にクライアントに出力します。

G

get(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の指定された位置にある要素を返します。
get() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容をバイト配列として取得します。
getAllContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持するすべての HTTP コンテキストを返します。
getAllIds() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getAllIds() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効なすべての HttpSession のセッションＩＤを返します。
getBufferSize() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBufferSize(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBufferSize(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBufferSize(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
このレスポンスに設定されている実バッファサイズを返します。
getBytes() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部をバイト配列として取得します。
getCharacterEncoding() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getCharacterEncoding(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
このレスポンスで送り返す MIME ボディに適用されている文字エンコーディング名を返します。
getContent() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を文字列表現として取得します。
getContent(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を指定された文字コードで変換した結果を文字列表現として 取得します。
getContentLength() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部をバイト長を取得します。
getContentLength() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse のメソッド
レスポンスにセットされている メッセージボディ部の長さを返します。
getContentLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentLength() メソッドをそのまま呼び出します。
getContentLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスにセットされている メッセージボディ部の長さを返します。
getContentType() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
コンテントタイプを取得します。
getContentType() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse のメソッド
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
getContentType() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#getContentType() メソッドをそのまま呼び出します。
getContentType() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスにセットされている クライアントに送り返されるレスポンスのコンテントタイプを 返します。
getContextURL(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getContextURL(HttpServletRequest, boolean) - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil の static メソッド
引数で与えられたリクエストのコンテキストを示すURLを生成します。
getCookies() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
このレスポンスにセットされたすべての Cookie を返します。
getCookies() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getCookies() メソッドをそのまま呼び出します。
getCookies() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このレスポンスにセットされたすべての Cookie を返します。
getCount() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getCreationTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCreationTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられているＨＴＴＰセッションが 作られた時刻を返します。
getCurrentContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
現在のスレッドに関連付けられた HTTP コンテキストを返します。
getCurrentRequest() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在処理中のリクエストを返します。
getCurrentSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getDateHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている日付の値を返します。
getDateHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeader(String) メソッドをそのまま呼び出します。
getDateHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている日付の値を返します。
getDateHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
getDateHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getDateHeaders(String) メソッドをそのまま呼び出します。
getDateHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての日付の値を返します。
getEntities(String) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定の名前を持つエンティティをすべて取得します。
getEntity(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定のインデックスに該当するエンティティを取得します。
getEntity(String) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定の名前を持つエンティティを取得します。
getExtendedHttpServletResponse() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このオブジェクトにラップされているレスポンスを返します。
getFieldName() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
フィールド名を取得します。
getFileName() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
アップロードされたファイルのファイル名を取得します。
getFileName(Map) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド
ヘッダのContent-Dispositionに含まれるファイル名を返します。
getFilterConfig() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
このフィルタの設定オブジェクトを返します。
getHeader(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
ヘッダの取得。
getHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定のヘッダの値を返します。
getHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている値を返します。
getHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeader(String) メソッドをそのまま呼び出します。
getHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている値を返します。
getHeaderNames() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
ヘッダ名称一覧の取得。
getHeaderNames() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
ヘッダ名称一覧を返します。
getHeaders() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ヘッダ情報を取得します。
getHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての値を返します。
getHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getHeaders(String) メソッドをそのまま呼び出します。
getHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての値を返します。
getHttpServletRequest() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
リクエストを返します。
getHttpServletResponse() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このオブジェクトにラップされているレスポンスを返します。
getHttpServletResponseEventConfig() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このリスナに渡された設定オブジェクトを返します。
getHttpServletResponseEventListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
リスナを返します。
getInitParameter(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のメソッド
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
getInitParameter(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig のメソッド
指定した名前の初期化パラメータの値である String、 あるいはパラメータが存在しなければ null を返します。
getInitParameterNames() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のメソッド
初期化パラメータの名前である String オブジェクトの Enumeration を返します。
getInitParameterNames() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig のメソッド
初期化パラメータの名前である String オブジェクトの Enumeration を返します。
getInputStream() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を入力ストリームとして取得します。
getInputStream() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
一時ファイルから取得したInputStreamを取得します。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このオブジェクトがラップしている入力ストリームを返します。
getInputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのメッセージボディを返します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager の static メソッド
HTTP コンテキスト・マネージャのインスタンスを取得します。
getInstance() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory の static メソッド
インスタンスを返します。
getIntHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている数値を返します。
getIntHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeader(String) メソッドをそのまま呼び出します。
getIntHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている数値を返します。
getIntHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
getIntHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getIntHeaders(String) メソッドをそのまま呼び出します。
getIntHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての数値を返します。
getLastAccessedTime(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLastAccessedTime(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションに関連したリクエストをクライアントが送った最後の時刻を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のメソッド
マネージャーが保持する HTTP コンテキストの数を返します。
getLength() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
現在有効な HttpSession の数を返します。
getListeners() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder のメソッド
リスナの配列を返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスに設定されているロケールを返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスに設定されているロケールを返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスに設定されているロケールを返します。
getLocale(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスに設定されているロケールを返します。
getManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のメソッド
マネージャを返します。
getMaxInactiveInterval(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMaxInactiveInterval(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager のメソッド
指定のＩＤに関連付けられてるセッションを保ち続ける最大の秒数を返します。
getMessageBody() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
リクエストのメッセージボディを返します。
getName() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
フォームのコントロール名称の取得。
getName() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイル名を取得します。
getName() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータ名を返します。
getNameAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
パラメータの名称を返します。
getOutputStream() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容を保存するのに使用できるOutputStreamを取得します。
getOutputStream() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getOutputStream(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスにバイナリデータを出力する際に使用する ServletOutputStream型のオブジェクトを返します。
getParameter(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
パラメータの存在有無に関わらず、全てのパラメータの値を null として返します。
getParameterMap() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
この要求から取得できるパラメータの存在有無に関わらず、 空のjava.util.Map で返します。
getParameterNames() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
この要求に含まれるパラメータの存在有無に関わらず、空のEnumerationを返します。
getParameterValues(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper のメソッド
指定された要求パラメータの存在有無に関わらずnullを返します。
getReader() - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
推奨されていません。 MultipartFormData.Entity.getReader(String) に置き換えられました。
getReader(String) - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity のメソッド
データ部を Reader として取得します。
getRepository() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static メソッド
useCommonsFileuploadがtrueの場合、一時ファイルを作成するフォルダを取得します。
getRequest() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
リクエストを返します。
getRequestParameters() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper のメソッド
パラメータ情報を返します。
getRequestParameters() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter の static メソッド
現在のリクエストのパラメータを返します。
getResponse() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
レスポンスを返します。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
この Filter を実行している ServletContext への参照を返します。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig のメソッド
呼び出したコントローラを実行している ServletContext への参照を返します。
getServletContext() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このリスナが実行されているサーブレットコンテキストを返します。
getServletContext() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig のメソッド
呼び出したコントローラを実行している ServletContext への参照を返します。
getServletContext() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
サーブレットコンテキストを返します。
getSession() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
このリクエストに関連づけられている現在のセッションを返します。
getSize() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルサイズを取得します。
getSizeThreshold() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static メソッド
useCommonsFileuploadがtrueの場合、一時ファイルを作成する閾値を取得します。
getStatus() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
レスポンスにセットされている ステータスコードを返します。
getStatus() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse#getStatus(String) メソッドをそのまま呼び出します。
getStatus() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスにセットされている ステータスコードを返します。
getString() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容をStringとして取得します。
getString(String) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
指定されたエンコードを使用してファイルの内容をStringとして取得します。
getStringHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
getStringHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeader(String) メソッドをそのまま呼び出します。
getStringHeader(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている文字列の値を返します。
getStringHeaders(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse のメソッド
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
getStringHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある ExtendedHttpServletResponse.getStringHeaders(String) メソッドをそのまま呼び出します。
getStringHeaders(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
指定された名称でレスポンスヘッダに設定されている全ての文字列の値を返します。
getValidators() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder のメソッド
バリデータの配列を返します。
getValue() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を文字列表現として返します。
getValueAsReader() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
推奨されていません。 RequestParameter.getValueAsReader(String) に置き換えられました。
getValueAsReader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を Reader として取得します。
getValueAsStream() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部を入力ストリームとして取得します。
getValueLength() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
データ部のバイト長を返します。
getWriter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWriter(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWriter(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。
getWriter(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
文字データをクライアントに送り返すのに使用する PrintWriterオブジェクトを返します。

H

HTTPContext - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext.
リクエスト、レスポンス、および サーブレットコンテキストへのアクセスを提供します。
HTTPContextHandlingFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter.
このフィルタを利用することにより、 HTTPContextManager経由で HTTPContextを取得できるようになります。
HTTPContextHandlingFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のコンストラクタ
デフォルト・コンストラクタ
HTTPContextManager - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager.
HTTP コンテキスト・マネージャ
HTTPContextManager() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager のコンストラクタ
デフォルトコンストラクタ HTTPContextManager.getInstance()を利用してください。
HttpServletRequestMessageBodyWrapper - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper.
HttpServletRequest を拡張したインタフェースです。
HttpServletRequestMessageBodyWrapperBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder.
HttpServletRequest を拡張したインタフェースです。
HttpServletResponseEventComponentBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder.
レスポンスイベントに関わる各種コンポーネント（リスナやバリデータ）をを構築するビルダです。
HttpServletResponseEventConfig - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig.
レスポンスの各メソッド呼び出しに対するイベントを 設定するためのオブジェクトです。
HttpServletResponseEventController - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController.
レスポンスイベントコントローラのインタフェース。
HttpServletResponseEventControllerBuilder - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder.
コントローラを構築するビルダです。
HttpServletResponseEventControllerException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException.
コントローラに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventControllerException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventControllerException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventControllerException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException.
イベントに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter.
サーブレットレスポンスの各メソッド呼び出しに対するリスナを設定するフィルタ。
HttpServletResponseEventFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter のコンストラクタ
新しいフィルタを作成します。
HttpServletResponseEventFilterException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException.
レスポンスイベントを定義するフィルタでエラーが発生した事を通知する例外です。
HttpServletResponseEventFilterException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventFilterException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventFilterException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventListener - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener.
レスポンスの各メソッド呼び出しに対するイベントをフックするためのインタフェースです。
HttpServletResponseEventListenerException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException.
レスポンスリスナに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventListenerException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventListenerException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventListenerException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpServletResponseEventValidator - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator.
レスポンスイベントが有効か無効かを判定するバリデータ。
HttpServletResponseEventValidatorException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException.
バリデータに関わる処理中にエラーが発生した事を通知する例外です。
HttpServletResponseEventValidatorException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
詳細メッセージを null にして、新規例外を構築します。
HttpServletResponseEventValidatorException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新規例外を構築します。
HttpServletResponseEventValidatorException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException のコンストラクタ
指定された原因を使用して新規例外を構築します。
HttpSessionManager - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager.
HttpSession に関する情報を提供するクラスの共通インタフェース定義です。
HttpSessionManagerFactory - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory.
HttpSessionManager を作成するファクトリクラスの抽象実装です。
HttpSessionManagerFactory() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory のコンストラクタ
新しい HttpSessionManagerFactory を構築します。
HttpSessionMonitoringFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するフィルタです。
HttpSessionMonitoringFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のコンストラクタ
新しい HttpSessionMonitoringFilter を構築します。
HttpSessionMonitoringListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener.
HttpSessionManagerFactory#instance() が返す、 HttpSessionManagerFactory および HttpSessionManager の 標準実装と連動するセッションリスナです。
HttpSessionMonitoringListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のコンストラクタ
新しいセッションリスナを構築します。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの破棄処理。
handleDestroy() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの破棄処理。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このリスナを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このリスナを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter のメソッド
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のメソッド
フィルタの初期化をします。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のメソッド
このフィルタを初期化します。
handleInit() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter のメソッド
フィルタの初期化をします。
hasHeader(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
指定された文字列がヘッダの名称かどうかを判定します。
hasHeaders() - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter のメソッド
このオブジェクトがヘッダ情報を持つかどうかを判定します。
hashCode() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリストのハッシュコード値を返します。

I

IMDiskFileItem - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem.
ヘッダ情報を追加したFileItemの実装クラスです。
IMDiskFileItem(String, String, boolean, String, int, File, Map) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のコンストラクタ
コンストラクタ
IMDiskFileItemFactory - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory.
ヘッダ情報を含むFileItemを生成するFactoryです。
IMDiskFileItemFactory() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory のコンストラクタ
デフォルトコンストラクタ
IMDiskFileItemFactory(int, File) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory のコンストラクタ
コンストラクタ
IMFileItemFactory - interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory.
ヘッダ情報を含むFileItemを生成するFactoryです。
IMMultipartStream - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream.
ヘッダの文字エンコーディングを変換しないMultipartStreamです。
IMMultipartStream() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream のコンストラクタ
デフォルトコンストラクタ
IMMultipartStream(InputStream, byte[]) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream のコンストラクタ
コンストラクタ。
IMServletFileUpload - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload.
ヘッダ情報を扱えるようにしたFileUploadクラスです。
IMServletFileUpload() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のコンストラクタ
デフォルトコンストラクタ
IMServletFileUpload(FileItemFactory) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のコンストラクタ
コンストラクタ
indexOf(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
equals メソッドを使って等しいかどうかを判定しながら、指定された引数と同じ内容の要素を先頭から検索します。
init(FilterConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
フィルタを初期化します。
init(HttpServletResponseEventConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このビルダを初期化します。
init(HttpServletResponseEventConfig) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このビルダを初期化します。
init(FilterConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder のメソッド
このオブジェクトを初期化します。
init(String, ServletContext) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder のメソッド
ビルダを初期化します。
init(HttpServletResponseEventConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController のメソッド
このビルダを初期化します。
init(String, ServletContext) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder のメソッド
ビルダを初期化します。
init(HttpServletResponseEventConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このビルダを初期化します。
init(HttpServletResponseEventConfig) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator のメソッド
この Validator を初期化します。
init(String, ServletContext) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder のメソッド
ビルダを初期化します。
isCommitted() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isCommitted(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isCommitted(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isCommitted(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスがすでにコミットされたかどうかを示す boolean を返します。
isEmpty() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストに要素がないかどうかを判定します。
isFormField() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
単純なフォームフィールドかどうかを取得します。
isInMemory() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルの内容がメモリから読み込まれるかどうかを取得します。
isValid(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator のメソッド
イベントリスナを動作させるかどうかの意思決定をします。
iterator() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。

J

jp.co.intra_mart.common.aid.javaee.http - package jp.co.intra_mart.common.aid.javaee.http
このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload - package jp.co.intra_mart.common.aid.javaee.http.fileupload
このパッケージには、アップロードされたファイルを扱うクラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet - package jp.co.intra_mart.common.aid.jsdk.javax.servlet
このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session - package jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility - package jp.co.intra_mart.common.aid.jsdk.utility
このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

K

KEY_REPOSITORY - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
一時ファイルの保存先 のキー
KEY_SIZE_THRESHOLD - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
一時ファイルを作成するかどうかの閾値のキー
KEY_USE_COMMONS_FILEUPLOAD - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static 変数
CommonsFileUploadを利用するかどうかのキー

L

LengthRequiredException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException.
Content-Length 指定がないためにリクエストを正常に処理できないことを 通知するための例外です。
LengthRequiredException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージを持つ例外を作成します。
LengthRequiredException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
LengthRequiredException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException のコンストラクタ
例外を作成します。
LuxuryResponseWriterFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter.
LuxuryResponseWriterFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter のコンストラクタ
デフォルトコンストラクタ
lastIndexOf(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定されたオブジェクトがリスト内で最後に現れるインデックスを返します。
leave(HttpServletRequest) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
leave(HttpSession) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter の static メソッド
指定のセッションに関する、このフィルタの処理を停止します。
listIterator() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリスト内の要素を適切な順序で繰り返し処理する反復子を返します。
listIterator(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の要素を適切な順序で繰り返し処理する、リスト内の指定された位置から開始する反復子を返します。
log(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。
log(String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
Servlet ログファイルに指定されたメッセージを出力します。
log(String, Throwable) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext のメソッド
与えられた Throwable 例外の説明となるメッセージとスタックトレースを Servlet のログファイルに出力します。

M

MultipartFormData - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.
フォームから enctype が multipart/form-data で送信されてきた情報を 解析するオブジェクトです。
MultipartFormData(ServletRequest) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のコンストラクタ
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData(ServletRequest, IMFileItemFactory) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のコンストラクタ
リクエストされた情報を解析して、新しいオブジェクトを構築します。
MultipartFormData.Entity - interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity.
フォームデータのエンティティです。
MultipartFormDataResourceBundle - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle.
MultipartFormDataの設定情報を扱うクラスです。
MultipartFormDataResourceBundle() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle のコンストラクタ
mark(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームの現在位置にマークを設定します。
markSupported() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
入力ストリームが mark および reset メソッドをサポートしているかどうかを 判定します。

N

NoCacheFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter.
ブラウザのキャッシュを無効にするフィルタ。
NoCacheFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter のコンストラクタ
NoSuchSessionException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException.
特定のＨＴＴＰセッションが見つからない場合にスローされます。
NoSuchSessionException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持たない NoSuchSessionException を構築します。
NoSuchSessionException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
詳細メッセージを持つ NoSuchSessionException を構築します。
NoSuchSessionException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された詳細メッセージおよび原因を使用して新しい NoSuchSessionException を構築します。
NoSuchSessionException(Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException のコンストラクタ
指定された原因を使用して新しい NoSuchSessionException を構築します。
NotFoundException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException.
指定されたコンテンツが見つからないことを通知するための例外です。
NotFoundException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージを持つ例外を作成します。
NotFoundException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
NotFoundException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException のコンストラクタ
例外を作成します。

P

parseHeaders(String) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド
CommonsFileuploadのFileuploadBaseにヘッダ情報のキーをtoLowerCaseしないヘッダ情報 を追加したメソッドです。
parseRequest(RequestContext) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload のメソッド
CommonsFileuploadのFileuploadBase#parRequestのヘッダをパースするインスタンスを IMMultipartStreamに変更したメソッドです。

R

RequestEntityTooLargeException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException.
処理可能量より大きいリクエストを受け付けたことを通知するための例外です。
RequestEntityTooLargeException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージを持つ例外を作成します。
RequestEntityTooLargeException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
RequestEntityTooLargeException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException のコンストラクタ
例外を作成します。
RequestMessageBodyFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter.
リクエストをラップするフィルタです。
RequestMessageBodyFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter のコンストラクタ
フィルタを作成します。
RequestParameter - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter.
１つのリクエストパラメータを保持するオブジェクトの共通インターフェース。
ResponseContentTypeManagementFilter - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter.
レスポンスの Content-Type を自動解決するフィルタです。
ResponseContentTypeManagementFilter() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter のコンストラクタ
新しくフィルタを作成します。
read() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から１バイト読み込みます。
read(byte[]) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
read(byte[], int, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
基礎入力から指定のバイト配列にデータを読み込みます。
readHeaders() - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream のメソッド
リクエストエンコーディングへのエンコーディング変換を行わずにヘッダ部を読み込みます。
remove(int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内の指定された位置から要素を削除します。
remove(Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
指定された要素のインスタンスがこのコレクションにあれば、そのインスタンスをコレクションから 1 つ削除します。
removeAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このコレクションから、指定されたコレクションに含まれる要素をすべて削除します。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
このストリームの位置を、 入力ストリームで最後に mark メソッドが呼び出されたときのマーク位置に 再設定します。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファリングされているデータ、ステータスコードとヘッダフィールドの値を削除します。
reset() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの ServletResponseWrapper.reset() メソッドをそのまま呼び出します。
resetBuffer() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetBuffer(HttpServletRequest, ExtendedHttpServletResponse) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
resetBuffer(HttpServletRequest, ExtendedHttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスのヘッダフィールドの値やステータスコードをそのままにしてバッファに溜められているコンテンツを消去します。
retainAll(Collection) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このコレクションにおいて、指定されたコレクションに格納されている要素だけを保持します。

S

SearchableHttpServletResponseWrapper - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper.
HttpServletResponseWrapperの拡張実装を提供します。
SearchableHttpServletResponseWrapper(HttpServletResponse) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のコンストラクタ
指定したレスポンスをラッピングしたレスポンス・アダプタを構築します。
ServiceUnavailableException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException.
サーバの都合により一時的にリクエストを処理できないことを 通知するための例外です。
ServiceUnavailableException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージを持つ例外を作成します。
ServiceUnavailableException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
ServiceUnavailableException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException のコンストラクタ
例外を作成します。
SimpleHttpServletResponseEventListener - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener.
レスポンスの各メソッド呼び出しに対するイベントをフックするためのコンポーネント実装です。
SimpleHttpServletResponseEventListener() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のコンストラクタ
新しいリスナを作成します。
StandardHttpServletResponseEventControllerBuilder - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder.
標準的なコントローラを構築するビルダです。
StandardHttpServletResponseEventControllerBuilder() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder のコンストラクタ
新しいビルダを構築します。
sendError(int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
バッファをクリアし、 指定されたステータスを使ってクライアントにエラーレスポンスを送ります。
sendError(int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int, java.lang.String) メソッドをそのまま呼び出します。
sendError(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendError(int) メソッドをそのまま呼び出します。
sendRedirect(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定されたリダイレクト先のURLを用いて、 クライアントに一時的なリダイレクトレスポンスを送信します。
sendRedirect(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.sendRedirect(java.lang.String) メソッドをそのまま呼び出します。
sessionCreated(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが作成されたことを通知します。
sessionDestroyed(HttpSessionEvent) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener のメソッド
セッションが無効になったことを通知します。
set(int, Object) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リストの指定された位置にある要素を、指定された要素で置き換えます。
setBufferSize(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBufferSize(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBufferSize(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setBufferSize(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
適当なバッファサイズをレスポンスに含まれるメッセージボディのサイズに設定します。
setContentLength(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentLength(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
レスポンスのメッセージボディ部分の長さをセットします。
setContentType(ContentType) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse のメソッド
レスポンスに Content-Type をセットします。
setContentType(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(HttpServletRequest, ExtendedHttpServletResponse, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(HttpServletRequest, ExtendedHttpServletResponse, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(ContentType) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper のメソッド
このメソッドにおけるデフォルトのふるまいとして、 ラップされたレスポンス・オブジェクトにある jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedServletResponse#setContentType(ContentType) メソッドをそのまま呼び出します。
setContentType(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
クライアントに送り返されるレスポンスのコンテントタイプをセットします。
setContentType(ContentType) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、 type の ContentType.toString() が返す値を ラップしている ServletResponse にセットします。
setDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(HttpServletRequest, ExtendedHttpServletResponse, String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された日付の値を持つレスポンスヘッダを設定します。
setDateHeader(String, long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.setDateHeader(java.lang.String name, long date) メソッドをそのまま呼び出します。
setFieldName(String) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
ファイルを参照するためのフィールド名をセットします。
setFormField(boolean) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
単純なフォームフィールドかどうかを指定します。
setHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(HttpServletRequest, ExtendedHttpServletResponse, String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された値を持つレスポンスヘッダを設定します。
setHeader(String, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.setHeader(java.lang.String name, java.lang.String value) メソッドをそのまま呼び出します。
setIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(HttpServletRequest, ExtendedHttpServletResponse, String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
指定された名称で指定された整数値を持つレスポンスヘッダを設定します。
setIntHeader(String, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このメソッドは、スーパークラスの HttpServletResponseWrapper.setIntHeader(java.lang.String name, int value) メソッドをそのまま呼び出します。
setLocale(Locale) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(HttpServletRequest, ExtendedHttpServletResponse, Locale) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(HttpServletRequest, ExtendedHttpServletResponse, Locale) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setLocale(HttpServletRequest, ExtendedHttpServletResponse, Locale) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
レスポンスのロケールをセットしますが、このとき(Content-Type で指定する文字エンコーディングを含む)ヘッダも適当な値にセットします。
setStatus(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController のメソッド
このレスポンスのステータスコードを設定します。
setStatus(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener のメソッド
このレスポンスのステータスコードを設定します。
setStatus(HttpServletRequest, ExtendedHttpServletResponse, int) - interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener のメソッド
このレスポンスのステータスコードを設定します。
setStatus(HttpServletRequest, ExtendedHttpServletResponse, int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener のメソッド
このレスポンスのステータスコードを設定します。
setStatus(int, String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
推奨されていません。
setStatus(int) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper のメソッド
このレスポンスのステータスコードを設定します。
size() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内にある要素の数を返します。
skip(long) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream のメソッド
指定のバイト数だけ入力をスキップします。
subList(int, int) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
このリストの、fromIndex (これを含む) から toIndex (これを含まない) の範囲の部分のビューを返します。

T

toArray() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内のすべての要素が正しい順序で格納されている配列を返します。
toArray(Object[]) - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
リスト内のすべての要素が正しい順序で格納されている配列を返します。
trimToSize() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData のメソッド
この ArrayList のインスタンスのサイズをリストの現在のサイズに縮小します。

U

URLUtil - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil.
URL関連のユーティリティクラス。
URLUtil() - class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil のコンストラクタ
UnauthorizedException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException.
リクエストを受け付けるためには認証が必要であることを通知するための例外です。
UnauthorizedException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnauthorizedException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnauthorizedException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException のコンストラクタ
例外を作成します。
UnripeQueryException - exception jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException.
クエリが Content-Lnegth ヘッダで指定された量に満たない場合に スローされる例外です。
UnripeQueryException(String) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージを持つ例外を作成します。
UnripeQueryException(String, Throwable) - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
指定のメッセージと原因となった例外を持つ例外を作成します。
UnripeQueryException() - class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException のコンストラクタ
例外を作成します。
useCommonsFileupload() - class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の static メソッド
アップロードされたファイルをメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用ように設定したかを取得します。

W

write(File) - class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem のメソッド
指定されたFileにアップロードされたファイルを書き出します。
A B C D E F G H I J K L M N P R S T U W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_javaee_assist 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_javaee_assist 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.common.aid.javaee.http
jp.co.intra_mart.common.aid.javaee.http.fileupload
jp.co.intra_mart.common.aid.jsdk.javax.servlet
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session
jp.co.intra_mart.common.aid.jsdk.utility


概要 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_javaee_assist API Specifications

パッケージ
jp.co.intra_mart.common.aid.javaee.http | このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload | このパッケージには、アップロードされたファイルを扱うクラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet | このパッケージには、サーブレットを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception | このパッケージには、例外処理を利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter | このパッケージには、フィルタを利用する際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http | このパッケージには、サーブレットコンテキストを利用する際に 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session | このパッケージには、HTTP セッションに関する 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.jsdk.utility | このパッケージには、ＨＴＭＬの表示変換に 便利な汎用クラスが含まれています。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.common.aid.javaee.http, jp.co.intra_mart.common.aid.javaee.http.fileupload, jp.co.intra_mart.common.aid.jsdk.javax.servlet, jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception, jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http, jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session, jp.co.intra_mart.common.aid.jsdk.utility

クラス階層

  • class java.lang.Object
    • class java.util.AbstractCollection (implements java.util.Collection)
      • class java.util.AbstractList (implements java.util.List)
        • class java.util.ArrayList (implements java.lang.Cloneable, java.util.List, java.util.RandomAccess, java.io.Serializable)
          • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormData
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractFilter (implements javax.servlet.Filter)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbsoluteLinkFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ExceptionHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HTTPContextHandlingFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.LuxuryResponseWriterFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.NoCacheFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestMessageBodyFilter
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.ResponseContentTypeManagementFilter
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventConfig (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventListener (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener)
      • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.SimpleHttpServletResponseEventListener
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.AbstractHttpSessionManager (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager)
    • class jp.co.intra_mart.common.aid.jsdk.utility.BrowseString
    • class org.apache.commons.fileupload.disk.DiskFileItemFactory (implements org.apache.commons.fileupload.FileItemFactory)
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory (implements jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory)
    • class org.apache.commons.fileupload.FileUploadBase
      • class org.apache.commons.fileupload.FileUpload
        • class org.apache.commons.fileupload.servlet.ServletFileUpload
          • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContextManager
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManagerFactory
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionMonitoringListener (implements javax.servlet.http.HttpSessionListener)
    • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem (implements org.apache.commons.fileupload.FileItem)
    • class java.io.InputStream
      • class javax.servlet.ServletInputStream
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.FilterServletInputStream
    • class jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle
    • class org.apache.commons.fileupload.MultipartStream
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream
    • class javax.servlet.ServletRequestWrapper (implements javax.servlet.ServletRequest)
      • class javax.servlet.http.HttpServletRequestWrapper (implements javax.servlet.http.HttpServletRequest)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper
    • class javax.servlet.ServletResponseWrapper (implements javax.servlet.ServletResponse)
      • class javax.servlet.http.HttpServletResponseWrapper (implements javax.servlet.http.HttpServletResponse)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.AbstractHttpServletResponseEventController (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController)
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.SearchableHttpServletResponseWrapper (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse)
    • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.StandardHttpServletResponseEventControllerBuilder (implements jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException
        • class javax.servlet.ServletException
          • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException
                • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException
              • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException
            • class jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException
    • class jp.co.intra_mart.common.aid.jsdk.utility.URLUtil

インタフェース階層

  • interface org.apache.commons.fileupload.FileItemFactory
    • interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.HTTPContext
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapperBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventComponentBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventConfig
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerBuilder
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListener
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidator
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.HttpSessionManager
  • interface jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.Entity
  • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.RequestParameter
  • interface javax.servlet.ServletRequest
    • interface javax.servlet.http.HttpServletRequest
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletRequestMessageBodyWrapper
  • interface javax.servlet.ServletResponse
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse, javax.servlet.http.HttpServletResponse)
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends javax.servlet.http.HttpServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface javax.servlet.http.HttpServletResponse
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.ExtendedHttpServletResponse (同様に extends jp.co.intra_mart.common.aid.jsdk.javax.servlet.ExtendedServletResponse)
        • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
      • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
    • interface jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventController
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_javaee_assist 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload

クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem は Object を拡張し、Serializable を実装しています

serialVersionUID: 4784522703387130736l

直列化されたフィールド

item

org.apache.commons.fileupload.disk.DiskFileItem item
Commons Fileupload のFileItemのインスタンス

headers

Map headers
ヘッダ情報

パッケージ jp.co.intra_mart.common.aid.javaee.http

クラス jp.co.intra_mart.common.aid.javaee.http.MultipartFormData は ArrayList を拡張し、Serializable を実装しています

直列化されたフィールド

instance

jp.co.intra_mart.common.aid.javaee.http.MultipartFormData.MultipartHandler instance

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.BadRequestException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.EmptyQueryException は UnripeQueryException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExcessiveQueryException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ExtendedServletException は ServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ForbiddenException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.LengthRequiredException は BadRequestException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.NotFoundException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.RequestEntityTooLargeException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.ServiceUnavailableException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnauthorizedException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.exception.UnripeQueryException は BadRequestException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventControllerException は HttpServletResponseEventException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventException は ExtendedServletException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventFilterException は HttpServletResponseEventException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventListenerException は HttpServletResponseEventException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.filter.HttpServletResponseEventValidatorException は HttpServletResponseEventException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session

クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.session.NoSuchSessionException は Exception を拡張し、Serializable を実装しています

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.exception.MKRuntimeException の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.exception.MKRuntimeException の使用

MKRuntimeException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.util での MKRuntimeException の使用

MKRuntimeException をスローする jp.co.intra_mart.extension.maskat.util のメソッド
static String | XMLUtil.getXMLString(Document doc) XML文字列を取得します。
static void | XMLUtil.writeXML(Document doc, OutputStream out) ドキュメントをストリームに出力します。
static Document | XMLUtil.readXML(InputStream in) ストリームからXMLを読み込み、ドキュメントを生成します。
Document | MKErrors.getDocument() エラー要素群のドキュメントを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.exception.MKSystemException の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.exception.MKSystemException の使用

MKSystemException を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での MKSystemException の使用

MKSystemException をスローする jp.co.intra_mart.extension.maskat.service のメソッド
Document | MKServiceResult.getTelegram() クライアントへ送信する電文を取得します。
Document | MKErrorsResult.getTelegram() クライアントへ送信するエラー電文を取得します。

MKSystemException をスローする jp.co.intra_mart.extension.maskat.service のコンストラクタ
DefaultMKServiceResult(String xmlString)
XML文字列から新規に処理結果を生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MKRuntimeException (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.exception
クラス MKRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.extension.maskat.exception.MKRuntimeException
すべての実装インタフェース:
Serializable
public class MKRuntimeException
extends RuntimeException

マスカットアプリケーション実行時に出力されるランタイム例外です。

関連項目:
直列化された形式

コンストラクタの概要
MKRuntimeException()
詳細メッセージを指定しないで MKRuntimeException を構築します。
MKRuntimeException(String msg)
指定された詳細メッセージを持つ MKRuntimeException を構築します。
MKRuntimeException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKRuntimeException を構築します。
MKRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ MKRuntimeException を構築します。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MKRuntimeException

public MKRuntimeException()
詳細メッセージを指定しないで MKRuntimeException を構築します。

MKRuntimeException

public MKRuntimeException(String msg)
指定された詳細メッセージを持つ MKRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ

MKRuntimeException

public MKRuntimeException(Throwable throwable)
この例外の発生原因となる例外を持つ MKRuntimeException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

MKRuntimeException

public MKRuntimeException(String msg,
                          Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKRuntimeException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKSystemException (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.exception
クラス MKSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.SystemException
                    拡張 jp.co.intra_mart.extension.maskat.exception.MKSystemException
すべての実装インタフェース:
Serializable
public class MKSystemException
extends jp.co.intra_mart.framework.system.exception.SystemException

マスカットアプリケーション実行時に出力される例外です。

関連項目:
直列化された形式

コンストラクタの概要
MKSystemException()
詳細メッセージを指定しないで MKSystemException を構築します。
MKSystemException(String msg)
指定された詳細メッセージを持つ MKSystemException を構築します。
MKSystemException(String msg, Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKSystemException を構築します。
MKSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ MKSystemException を構築します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MKSystemException

public MKSystemException()
詳細メッセージを指定しないで MKSystemException を構築します。

MKSystemException

public MKSystemException(String msg)
指定された詳細メッセージを持つ MKSystemException を構築します。

パラメータ:
msg - 詳細メッセージ

MKSystemException

public MKSystemException(Throwable throwable)
この例外の発生原因となる例外を持つ MKSystemException を構築します。

パラメータ:
throwable - この例外の発生原因となる例外

MKSystemException

public MKSystemException(String msg,
                         Throwable throwable)
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKSystemException を構築します。

パラメータ:
msg - 詳細メッセージ
throwable - この例外の発生原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.exception (im_maskat 6.1.14 API)

 jp.co.intra_mart.extension.maskat.exception
例外
MKRuntimeException
MKSystemException


jp.co.intra_mart.extension.maskat.exception (im_maskat 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.exception

例外の概要
MKRuntimeException | マスカットアプリケーション実行時に出力されるランタイム例外です。
MKSystemException | マスカットアプリケーション実行時に出力される例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.extension.maskat.exception クラス階層 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.extension.maskat.exception.MKSystemException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.extension.maskat.exception の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.exception の使用

jp.co.intra_mart.extension.maskat.exception を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.extension.maskat.exception のクラス
MKSystemException
マスカットアプリケーション実行時に出力される例外です。

jp.co.intra_mart.extension.maskat.util により使用される jp.co.intra_mart.extension.maskat.exception のクラス
MKRuntimeException
マスカットアプリケーション実行時に出力されるランタイム例外です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult の使用

jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.MKErrorsResult の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.MKErrorsResult の使用

jp.co.intra_mart.extension.maskat.service.MKErrorsResult はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.extension.maskat.service.MKServiceResult の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.extension.maskat.service.MKServiceResult の使用

MKServiceResult を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での MKServiceResult の使用

MKServiceResult を実装している jp.co.intra_mart.extension.maskat.service のクラス
class | DefaultMKServiceResult デフォルトのMKServiceResult実装です。
class | MKErrorsResult マスカットにエラーを返すサービス処理結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.MKTransition の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.MKTransition の使用

jp.co.intra_mart.extension.maskat.service.MKTransition はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter の使用

jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject の使用

jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の使用

jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MKControllerConverter (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service.controller
クラス MKControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter
すべての実装インタフェース:
jp.co.intra_mart.framework.base.service.controller.ControllerConverter
public class MKControllerConverter
extends Object
implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter

マスカット連携時に使用する汎用的なコントローラコンバータです。 コントローラオブジェクトは、MKControllerObjectである。 もしくはMKControllerObjectを継承したクラスである必要があります。

導入されたバージョン:
6.1

フィールドの概要
static String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
MKControllerConverter()
メソッドの概要
jp.co.intra_mart.framework.base.service.controller.ControllerObject | convert(jp.co.intra_mart.framework.base.service.RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() MKControllerConverterを破棄します。
void | init(jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig config) MKControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値
コンストラクタの詳細

MKControllerConverter

public MKControllerConverter()
メソッドの詳細

init

public void init(jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig config)
          throws jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
MKControllerConverterを初期化します。

定義:
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
jp.co.intra_mart.framework.base.service.controller.ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
MKControllerConverterを破棄します。

定義:
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter 内の destroy

convert

public jp.co.intra_mart.framework.base.service.controller.ControllerObject convert(jp.co.intra_mart.framework.base.service.RequestInfo info)
                                                                            throws jp.co.intra_mart.framework.base.service.controller.RequestFormatException,
                                                                                ServletException,
                                                                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
jp.co.intra_mart.framework.base.service.controller.RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKControllerObject (im_maskat 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service.controller
クラス MKControllerObject

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject
すべての実装インタフェース:
jp.co.intra_mart.framework.base.service.controller.ControllerObject, Serializable
public class MKControllerObject
extends Object
implements jp.co.intra_mart.framework.base.service.controller.ControllerObject

マスカット連携時に使用する汎用的なコントローラオブジェクトです。

関連項目:
直列化された形式

コンストラクタの概要
MKControllerObject()
MKControllerObjectを新規に生成します。
メソッドの概要
String | getComponentId() コンポーネントIDを取得します。
String | getEventId() イベントIDを取得します。
String | getLayoutId() レイアウトIDを取得します。
Document | getTelegram() 電文を取得します。
void | setComponentId(String componentId) コンポーネントIDを設定します。
void | setEventId(String eventId) イベントIDを設定します。
void | setLayoutId(String layoutId) レイアウトIDを設定します。
void | setTelegram(Document document) 電文を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MKControllerObject

public MKControllerObject()
MKControllerObjectを新規に生成します。

メソッドの詳細

getTelegram

public Document getTelegram()
電文を取得します。

戻り値:

setTelegram

public void setTelegram(Document document)
電文を設定します。

パラメータ:
document -

getComponentId

public String getComponentId()
コンポーネントIDを取得します。

戻り値:
コンポーネント

setComponentId

public void setComponentId(String componentId)
コンポーネントIDを設定します。

パラメータ:
componentId - コンポーネント

getEventId

public String getEventId()
イベントIDを取得します。

戻り値:

setEventId

public void setEventId(String eventId)
イベントIDを設定します。

パラメータ:
eventId -

getLayoutId

public String getLayoutId()
レイアウトIDを取得します。

戻り値:

setLayoutId

public void setLayoutId(String layoutId)
レイアウトIDを設定します。

パラメータ:
layoutId -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NodePathControllerConverter (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service.controller
クラス NodePathControllerConverter

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter
すべての実装インタフェース:
jp.co.intra_mart.framework.base.service.controller.ControllerConverter
public class NodePathControllerConverter
extends Object
implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter

コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。 フィールドの型はString、またはStringの配列です。 また、コントローラオブジェクトはMKControllerObject を継承している必要があります。 以下は受信電文に対応したコントローラオブジェクトの例です。

 <?xml version="1.0" encoding="UTF-8"?>
 <sampleParam>
   <arg1>value1</arg1>
   <arg2>value2</arg2>
 </sampleParam>

 public class MKControllerObjectImpl extends MKControllerObject {

   public static final String PATH_arg1 = "/sampleParam/arg1";
   public static final String PATH_arg2 = "/sampleParam/arg2";

   private String arg1 = null;
   private String arg2 = null;

   public String getArg1() {
     return arg1;
   }

   public void setArg1(String arg1) {
     this.arg1 = arg1;
   }

   public String getArg2() {
     return arg2;
   }

   public void setArg2(String arg2) {
     this.arg2 = arg2;
   }
 }

 ノードパスが複数列を対象とする場合フィールドの型は配列です。

 <?xml version="1.0" encoding="UTF-8"?>
 <sampleParam>
   <arg>value1</arg>
   <arg>value2</arg>
   <arg>value3</arg>
 </sampleParam>

 public class ControllerObjectImpl extends MKControllerObject {

   public static final String PATH_arg = "/sampleParam/arg";

   private String[] arg = null;

   public String[] getArg() {
     return arg;
   }

   public void setArg(String[] arg) {
     this.arg = arg;
   }
 }

導入されたバージョン:
6.1

フィールドの概要
static String | NODE_PATH_PREFIX Pathを記述するフィールドのプレフィックス
static String | OBJECT_PARAM_NAME コントローラオブジェクトのクラス名を設定するパラメータ名
コンストラクタの概要
NodePathControllerConverter()
メソッドの概要
jp.co.intra_mart.framework.base.service.controller.ControllerObject | convert(jp.co.intra_mart.framework.base.service.RequestInfo info) リクエスト情報をもとに入力オブジェクトを生成します。
void | destroy() NodePathControllerConverterを破棄します。
void | init(jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig config) NodePathControllerConverterを初期化します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

OBJECT_PARAM_NAME

public static final String OBJECT_PARAM_NAME
コントローラオブジェクトのクラス名を設定するパラメータ名

関連項目:
定数フィールド値

NODE_PATH_PREFIX

public static final String NODE_PATH_PREFIX
Pathを記述するフィールドのプレフィックス

関連項目:
定数フィールド値
コンストラクタの詳細

NodePathControllerConverter

public NodePathControllerConverter()
メソッドの詳細

init

public void init(jp.co.intra_mart.framework.base.service.controller.ControllerConverterConfig config)
          throws jp.co.intra_mart.framework.base.service.controller.ControllerConverterException
NodePathControllerConverterを初期化します。

定義:
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter 内の init
パラメータ:
config - 初期化情報
例外:
jp.co.intra_mart.framework.base.service.controller.ControllerConverterException - 初期化時に例外が発生

destroy

public void destroy()
NodePathControllerConverterを破棄します。

定義:
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter 内の destroy

convert

public jp.co.intra_mart.framework.base.service.controller.ControllerObject convert(jp.co.intra_mart.framework.base.service.RequestInfo info)
                                                                            throws jp.co.intra_mart.framework.base.service.controller.RequestFormatException,
                                                                                ServletException,
                                                                                IOException
リクエスト情報をもとに入力オブジェクトを生成します。

定義:
インタフェース jp.co.intra_mart.framework.base.service.controller.ControllerConverter 内の convert
パラメータ:
info - リクエスト情報
戻り値:
リクエストの内容が含まれる入力オブジェクト
例外:
jp.co.intra_mart.framework.base.service.controller.RequestFormatException - リクエストのフォーマットが不正
ServletException - 変換中にServletExceptionが発生
IOException - 変換中にIOExceptionが発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.service.controller (im_maskat 6.1.14 API)

 jp.co.intra_mart.extension.maskat.service.controller
クラス
MKControllerConverter
MKControllerObject
NodePathControllerConverter


jp.co.intra_mart.extension.maskat.service.controller (im_maskat 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service.controller

クラスの概要
MKControllerConverter | マスカット連携時に使用する汎用的なコントローラコンバータです。
MKControllerObject | マスカット連携時に使用する汎用的なコントローラオブジェクトです。
NodePathControllerConverter | コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。


jp.co.intra_mart.extension.maskat.service.controller クラス階層 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service.controller の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject (implements jp.co.intra_mart.framework.base.service.controller.ControllerObject)
    • class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)


パッケージ jp.co.intra_mart.extension.maskat.service.controller の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.service.controller の使用

jp.co.intra_mart.extension.maskat.service.controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DefaultMKServiceResult (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
クラス DefaultMKServiceResult

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult
すべての実装インタフェース:
MKServiceResult, jp.co.intra_mart.framework.base.service.ServiceResult
public class DefaultMKServiceResult
extends Object
implements MKServiceResult

デフォルトのMKServiceResult実装です。

コンストラクタの概要
DefaultMKServiceResult(Document doc)
ドキュメントから新規に処理結果を生成します。
DefaultMKServiceResult(String xmlString)
XML文字列から新規に処理結果を生成します。
メソッドの概要
 Document getTelegram()
クライアントへ送信する電文を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DefaultMKServiceResult

public DefaultMKServiceResult(Document doc)
ドキュメントから新規に処理結果を生成します。

パラメータ:
doc - ドキュメント

DefaultMKServiceResult

public DefaultMKServiceResult(String xmlString)
                       throws MKSystemException
XML文字列から新規に処理結果を生成します。

パラメータ:
xmlString - XML文字列
例外:
MKSystemException
メソッドの詳細

getTelegram

public Document getTelegram()
クライアントへ送信する電文を取得します。

定義:
インタフェース MKServiceResult 内の getTelegram
戻り値:
送信電文
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKErrorsResult (im_maskat 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
クラス MKErrorsResult

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKErrors
        拡張 jp.co.intra_mart.extension.maskat.service.MKErrorsResult
すべての実装インタフェース:
MKServiceResult, jp.co.intra_mart.framework.base.service.ServiceResult
public class MKErrorsResult
extends MKErrors
implements MKServiceResult

マスカットにエラーを返すサービス処理結果です。

導入されたバージョン:
6.1

フィールドの概要
クラス jp.co.intra_mart.extension.maskat.util.MKErrors から継承したフィールド
ERRORS_NODE
コンストラクタの概要
MKErrorsResult()
空のErrorsResultを新規に生成します。
MKErrorsResult(MKError error)
エラー要素を設定してErrorsResultを新規に生成します。
メソッドの概要
 Document getTelegram()
クライアントへ送信するエラー電文を取得します。
クラス jp.co.intra_mart.extension.maskat.util.MKErrors から継承したメソッド
addError, getDocument, size
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MKErrorsResult

public MKErrorsResult()
空のErrorsResultを新規に生成します。

MKErrorsResult

public MKErrorsResult(MKError error)
エラー要素を設定してErrorsResultを新規に生成します。

パラメータ:
error - エラー要素
メソッドの詳細

getTelegram

public Document getTelegram()
                     throws MKSystemException
クライアントへ送信するエラー電文を取得します。

定義:
インタフェース MKServiceResult 内の getTelegram
戻り値:
送信電文
例外:
MKSystemException - 電文取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MKServiceResult (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
インタフェース MKServiceResult

すべてのスーパーインタフェース:
jp.co.intra_mart.framework.base.service.ServiceResult
既知の実装クラスの一覧:
DefaultMKServiceResult, MKErrorsResult
public interface MKServiceResult
extends jp.co.intra_mart.framework.base.service.ServiceResult

マスカット連携を行う処理結果です。

導入されたバージョン:
6.1

メソッドの概要
 Document getTelegram()
クライアントへ送信する電文を取得します。

メソッドの詳細

getTelegram

public Document getTelegram()
                     throws MKSystemException
クライアントへ送信する電文を取得します。

戻り値:
送信電文
例外:
MKSystemException - 電文取得時に例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKTransition (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.service
クラス MKTransition

java.lang.Object
    拡張 jp.co.intra_mart.framework.base.service.Transition
        拡張 jp.co.intra_mart.framework.base.service.DefaultTransition
            拡張 jp.co.intra_mart.extension.maskat.service.MKTransition
public class MKTransition
extends jp.co.intra_mart.framework.base.service.DefaultTransition

マスカットに電文を送信するトランジションです。

導入されたバージョン:
6.1

コンストラクタの概要
MKTransition()
メソッドの概要
 void transfer()
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。
クラス jp.co.intra_mart.framework.base.service.DefaultTransition から継承したメソッド
getInputErrorPage, getNextPage, getServiceErrorPage, getSystemErrorPage, setInformation
クラス jp.co.intra_mart.framework.base.service.Transition から継承したメソッド
getApplication, getEntity, getNextPagePath, getNextPagePath, getRequest, getResponse, getResult, getService, getServiceManager, getSessionObject, setRequest, setResponse, setResult, setServiceManager
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

MKTransition

public MKTransition()
メソッドの詳細

transfer

public void transfer()
              throws jp.co.intra_mart.framework.system.exception.SystemException
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。 サービス処理結果はjp.co.intra_mart.extension.maskat.serviceMKServiceResultの実装クラスである必要があります。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.service (im_maskat 6.1.14 API)

 jp.co.intra_mart.extension.maskat.service
インタフェース
MKServiceResult
クラス
DefaultMKServiceResult
MKErrorsResult
MKTransition


jp.co.intra_mart.extension.maskat.service (im_maskat 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service

インタフェースの概要
MKServiceResult マスカット連携を行う処理結果です。

クラスの概要
DefaultMKServiceResult | デフォルトのMKServiceResult実装です。
MKErrorsResult | マスカットにエラーを返すサービス処理結果です。
MKTransition | マスカットに電文を送信するトランジションです。


jp.co.intra_mart.extension.maskat.service クラス階層 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.service の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.extension.maskat.util.MKErrors
      • class jp.co.intra_mart.extension.maskat.service.MKErrorsResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
        • class jp.co.intra_mart.extension.maskat.service.MKTransition

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.ServiceResult
    • interface jp.co.intra_mart.extension.maskat.service.MKServiceResult


パッケージ jp.co.intra_mart.extension.maskat.service の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.service の使用

jp.co.intra_mart.extension.maskat.service を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.extension.maskat.service のクラス
MKServiceResult
マスカット連携を行う処理結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.MKConst の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.MKConst の使用

jp.co.intra_mart.extension.maskat.util.MKConst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.MKError の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.MKError の使用

MKError を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.service での MKError の使用

MKError 型のパラメータを持つ jp.co.intra_mart.extension.maskat.service のコンストラクタ
MKErrorsResult(MKError error)
エラー要素を設定してErrorsResultを新規に生成します。

jp.co.intra_mart.extension.maskat.util での MKError の使用

MKError 型のパラメータを持つ jp.co.intra_mart.extension.maskat.util のメソッド
 void MKErrors.addError(MKError error)
エラー要素を追加します。

MKError 型のパラメータを持つ jp.co.intra_mart.extension.maskat.util のコンストラクタ
MKErrors(MKError error)
エラー要素を設定してMKErrorsを新規に生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.MKErrors の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.MKErrors の使用

MKErrors を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service

jp.co.intra_mart.extension.maskat.service での MKErrors の使用

jp.co.intra_mart.extension.maskat.service での MKErrors のサブクラス
 class MKErrorsResult
マスカットにエラーを返すサービス処理結果です。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.extension.maskat.util.XMLUtil の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.extension.maskat.util.XMLUtil の使用

jp.co.intra_mart.extension.maskat.util.XMLUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MKConst (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス MKConst

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKConst
public class MKConst
extends Object

マスカット連携に使用される定数値です。

導入されたバージョン:
6.1

フィールドの概要
static String | MASKAT_COMPONENT_ID_HEAD マスカット・コンポーネントIDのヘッダ属性
static String | MASKAT_DEFAULT_COMPONENT_ID デフォルトのコンポーネントID
static String | MASKAT_EVENT_ID_HEAD マスカット・イベントIDのヘッダ属性
static String | MASKAT_LAYOUT_ID_HEAD マスカット・レイアウトIDのヘッダ属性
コンストラクタの概要
MKConst()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MASKAT_LAYOUT_ID_HEAD

public static final String MASKAT_LAYOUT_ID_HEAD
マスカット・レイアウトIDのヘッダ属性

関連項目:
定数フィールド値

MASKAT_COMPONENT_ID_HEAD

public static final String MASKAT_COMPONENT_ID_HEAD
マスカット・コンポーネントIDのヘッダ属性

関連項目:
定数フィールド値

MASKAT_EVENT_ID_HEAD

public static final String MASKAT_EVENT_ID_HEAD
マスカット・イベントIDのヘッダ属性

関連項目:
定数フィールド値

MASKAT_DEFAULT_COMPONENT_ID

public static final String MASKAT_DEFAULT_COMPONENT_ID
デフォルトのコンポーネントID

関連項目:
定数フィールド値
コンストラクタの詳細

MKConst

public MKConst()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


MKError (im_maskat 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス MKError

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKError
public class MKError
extends Object

マスカットのエラー情報を保持します。

導入されたバージョン:
6.1

フィールドの概要
static String | ERROR_CODE_NODE errorCodeのノード名
static String | ERROR_NODE error要素のノード名
static String | INFO_NODE infoのノード名
static String | MESSAGE_CODE_NODE messageCodeのノード名
static String | MESSAGE_NODE messageのノード名
static String | SYSTEM_ERROR_MESSAGE_NODE systemErrorMessageのノード名
コンストラクタの概要
MKError()
MKErrorを新規に生成します。
メソッドの概要
String | getErrorCode() errorCodeを取得します。
String | getInfo() infoを取得します。
String | getMessage() messageを取得します。
String | getMessageCode() messageCodeを取得します。
String | getSystemErrorMessage() systemErrorMessageを取得します。
void | setErrorCode(String errorCode) errorCodeを設定します。
void | setInfo(String info) infoを設定します。
void | setMessage(String message) messageを設定します。
void | setMessageCode(String messageCode) messageCodeを設定します。
void | setSystemErrorMessage(String systemErrorMessage) systemErrorMessageを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ERROR_NODE

public static String ERROR_NODE
error要素のノード名

ERROR_CODE_NODE

public static String ERROR_CODE_NODE
errorCodeのノード名

MESSAGE_CODE_NODE

public static String MESSAGE_CODE_NODE
messageCodeのノード名

MESSAGE_NODE

public static String MESSAGE_NODE
messageのノード名

INFO_NODE

public static String INFO_NODE
infoのノード名

SYSTEM_ERROR_MESSAGE_NODE

public static String SYSTEM_ERROR_MESSAGE_NODE
systemErrorMessageのノード名

コンストラクタの詳細

MKError

public MKError()
MKErrorを新規に生成します。

メソッドの詳細

getErrorCode

public String getErrorCode()
errorCodeを取得します。

戻り値:
errorCode

setErrorCode

public void setErrorCode(String errorCode)
errorCodeを設定します。

パラメータ:
errorCode -

getInfo

public String getInfo()
infoを取得します。

戻り値:
info

setInfo

public void setInfo(String info)
infoを設定します。

パラメータ:
info -

getMessage

public String getMessage()
messageを取得します。

戻り値:
message

setMessage

public void setMessage(String message)
messageを設定します。

パラメータ:
message -

getMessageCode

public String getMessageCode()
messageCodeを取得します。

戻り値:
messageCode

setMessageCode

public void setMessageCode(String messageCode)
messageCodeを設定します。

パラメータ:
messageCode -

getSystemErrorMessage

public String getSystemErrorMessage()
systemErrorMessageを取得します。

戻り値:
systemErrorMessage

setSystemErrorMessage

public void setSystemErrorMessage(String systemErrorMessage)
systemErrorMessageを設定します。

パラメータ:
systemErrorMessage -
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MKErrors (im_maskat 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス MKErrors

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.MKErrors
直系の既知のサブクラス:
MKErrorsResult
public class MKErrors
extends Object

マスカットのエラー要素群を保持します。

フィールドの概要
static String ERRORS_NODE
errors要素のノード名
コンストラクタの概要
MKErrors()
空のMKErrorsを新規に生成します。
MKErrors(MKError error)
エラー要素を設定してMKErrorsを新規に生成します。
メソッドの概要
void | addError(MKError error) エラー要素を追加します。
Document | getDocument() エラー要素群のドキュメントを取得します。
int | size() errorの個数を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ERRORS_NODE

public static String ERRORS_NODE
errors要素のノード名

コンストラクタの詳細

MKErrors

public MKErrors()
空のMKErrorsを新規に生成します。

MKErrors

public MKErrors(MKError error)
エラー要素を設定してMKErrorsを新規に生成します。

パラメータ:
error - エラー要素
メソッドの詳細

addError

public void addError(MKError error)
エラー要素を追加します。

パラメータ:
error - エラー要素

getDocument

public Document getDocument()
                     throws MKRuntimeException
エラー要素群のドキュメントを取得します。

戻り値:
ドキュメント
例外:
MKRuntimeExceptionドキュメント取得時に例外が発生
MKRuntimeException

size

public int size()
errorの個数を取得します。

戻り値:
エラー要素の個数
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.extension.maskat.util (im_maskat 6.1.14 API)

 jp.co.intra_mart.extension.maskat.util
クラス
MKConst
MKError
MKErrors
XMLUtil


jp.co.intra_mart.extension.maskat.util (im_maskat 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.util

クラスの概要
MKConst | マスカット連携に使用される定数値です。
MKError | マスカットのエラー情報を保持します。
MKErrors | マスカットのエラー要素群を保持します。
XMLUtil | XMLのユーティリティクラスです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.extension.maskat.util クラス階層 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.extension.maskat.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.util.MKConst
    • class jp.co.intra_mart.extension.maskat.util.MKError
    • class jp.co.intra_mart.extension.maskat.util.MKErrors
    • class jp.co.intra_mart.extension.maskat.util.XMLUtil
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.extension.maskat.util の使用 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.extension.maskat.util の使用

jp.co.intra_mart.extension.maskat.util を使用しているパッケージ
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.util

jp.co.intra_mart.extension.maskat.service により使用される jp.co.intra_mart.extension.maskat.util のクラス
MKError
マスカットのエラー情報を保持します。
MKErrors
マスカットのエラー要素群を保持します。

jp.co.intra_mart.extension.maskat.util により使用される jp.co.intra_mart.extension.maskat.util のクラス
MKError
マスカットのエラー情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


XMLUtil (im_maskat 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.extension.maskat.util
クラス XMLUtil

java.lang.Object
    拡張 jp.co.intra_mart.extension.maskat.util.XMLUtil
public class XMLUtil
extends Object

XMLのユーティリティクラスです。

コンストラクタの概要
XMLUtil()
メソッドの概要
static String | getXMLString(Document doc) XML文字列を取得します。
static Document | readXML(InputStream in) ストリームからXMLを読み込み、ドキュメントを生成します。
static void | writeXML(Document doc, OutputStream out) ドキュメントをストリームに出力します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

XMLUtil

public XMLUtil()
メソッドの詳細

getXMLString

public static String getXMLString(Document doc)
                           throws MKRuntimeException
XML文字列を取得します。

戻り値:
XML文字列
例外:
MKRuntimeException - XML取得時に例外が発生

writeXML

public static void writeXML(Document doc,
                            OutputStream out)
                     throws MKRuntimeException
ドキュメントをストリームに出力します。

パラメータ:
doc - ドキュメント
out - 出力
例外:
MKRuntimeException - ストリーム出力時に例外が発生。

readXML

public static Document readXML(InputStream in)
                        throws MKRuntimeException
ストリームからXMLを読み込み、ドキュメントを生成します。

パラメータ:
in - 入力
戻り値:
doc ドキュメント
例外:
MKRuntimeException - ドキュメント生成時に例外が発生。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (im_maskat 6.1.14 API)

 すべてのクラス
DefaultMKServiceResult
MKConst
MKControllerConverter
MKControllerObject
MKError
MKErrors
MKErrorsResult
MKRuntimeException
MKServiceResult
MKSystemException
MKTransition
NodePathControllerConverter
XMLUtil


定数フィールド値 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter
public static final String OBJECT_PARAM_NAME "object"

jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter
public static final String | NODE_PATH_PREFIX | "PATH_"
public static final String | OBJECT_PARAM_NAME | "object"

jp.co.intra_mart.extension.maskat.util.MKConst
public static final String | MASKAT_COMPONENT_ID_HEAD | "maskat_componentID"
public static final String | MASKAT_DEFAULT_COMPONENT_ID | "onload"
public static final String | MASKAT_EVENT_ID_HEAD | "maskat_eventID"
public static final String | MASKAT_LAYOUT_ID_HEAD | "maskat_layoutID"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし
A C D E G I J M N O R S T W X

A

addError(MKError) - class jp.co.intra_mart.extension.maskat.util.MKErrors のメソッド
エラー要素を追加します。

C

convert(RequestInfo) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。
convert(RequestInfo) - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のメソッド
リクエスト情報をもとに入力オブジェクトを生成します。

D

DefaultMKServiceResult - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult.
デフォルトのMKServiceResult実装です。
DefaultMKServiceResult(Document) - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult のコンストラクタ
ドキュメントから新規に処理結果を生成します。
DefaultMKServiceResult(String) - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult のコンストラクタ
XML文字列から新規に処理結果を生成します。
destroy() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のメソッド
MKControllerConverterを破棄します。
destroy() - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のメソッド
NodePathControllerConverterを破棄します。

E

ERRORS_NODE - class jp.co.intra_mart.extension.maskat.util.MKErrors の static 変数
errors要素のノード名
ERROR_CODE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
errorCodeのノード名
ERROR_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
error要素のノード名

G

getComponentId() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
コンポーネントIDを取得します。
getDocument() - class jp.co.intra_mart.extension.maskat.util.MKErrors のメソッド
エラー要素群のドキュメントを取得します。
getErrorCode() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
errorCodeを取得します。
getEventId() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
イベントIDを取得します。
getInfo() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
infoを取得します。
getLayoutId() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
レイアウトIDを取得します。
getMessage() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageを取得します。
getMessageCode() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageCodeを取得します。
getSystemErrorMessage() - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
systemErrorMessageを取得します。
getTelegram() - class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult のメソッド
クライアントへ送信する電文を取得します。
getTelegram() - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult のメソッド
クライアントへ送信するエラー電文を取得します。
getTelegram() - interface jp.co.intra_mart.extension.maskat.service.MKServiceResult のメソッド
クライアントへ送信する電文を取得します。
getTelegram() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
電文を取得します。
getXMLString(Document) - class jp.co.intra_mart.extension.maskat.util.XMLUtil の static メソッド
XML文字列を取得します。

I

INFO_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
infoのノード名
init(ControllerConverterConfig) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のメソッド
MKControllerConverterを初期化します。
init(ControllerConverterConfig) - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のメソッド
NodePathControllerConverterを初期化します。

J

jp.co.intra_mart.extension.maskat.exception - package jp.co.intra_mart.extension.maskat.exception
jp.co.intra_mart.extension.maskat.service - package jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.service.controller - package jp.co.intra_mart.extension.maskat.service.controller
jp.co.intra_mart.extension.maskat.util - package jp.co.intra_mart.extension.maskat.util

M

MASKAT_COMPONENT_ID_HEAD - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
マスカット・コンポーネントIDのヘッダ属性
MASKAT_DEFAULT_COMPONENT_ID - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
デフォルトのコンポーネントID
MASKAT_EVENT_ID_HEAD - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
マスカット・イベントIDのヘッダ属性
MASKAT_LAYOUT_ID_HEAD - class jp.co.intra_mart.extension.maskat.util.MKConst の static 変数
マスカット・レイアウトIDのヘッダ属性
MESSAGE_CODE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
messageCodeのノード名
MESSAGE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
messageのノード名
MKConst - class jp.co.intra_mart.extension.maskat.util.MKConst.
マスカット連携に使用される定数値です。
MKConst() - class jp.co.intra_mart.extension.maskat.util.MKConst のコンストラクタ
MKControllerConverter - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter.
マスカット連携時に使用する汎用的なコントローラコンバータです。
MKControllerConverter() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter のコンストラクタ
MKControllerObject - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject.
マスカット連携時に使用する汎用的なコントローラオブジェクトです。
MKControllerObject() - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のコンストラクタ
MKControllerObjectを新規に生成します。
MKError - class jp.co.intra_mart.extension.maskat.util.MKError.
マスカットのエラー情報を保持します。
MKError() - class jp.co.intra_mart.extension.maskat.util.MKError のコンストラクタ
MKErrorを新規に生成します。
MKErrors - class jp.co.intra_mart.extension.maskat.util.MKErrors.
マスカットのエラー要素群を保持します。
MKErrors() - class jp.co.intra_mart.extension.maskat.util.MKErrors のコンストラクタ
空のMKErrorsを新規に生成します。
MKErrors(MKError) - class jp.co.intra_mart.extension.maskat.util.MKErrors のコンストラクタ
エラー要素を設定してMKErrorsを新規に生成します。
MKErrorsResult - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult.
マスカットにエラーを返すサービス処理結果です。
MKErrorsResult() - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult のコンストラクタ
空のErrorsResultを新規に生成します。
MKErrorsResult(MKError) - class jp.co.intra_mart.extension.maskat.service.MKErrorsResult のコンストラクタ
エラー要素を設定してErrorsResultを新規に生成します。
MKRuntimeException - exception jp.co.intra_mart.extension.maskat.exception.MKRuntimeException.
マスカットアプリケーション実行時に出力されるランタイム例外です。
MKRuntimeException() - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
詳細メッセージを指定しないで MKRuntimeException を構築します。
MKRuntimeException(String) - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
指定された詳細メッセージを持つ MKRuntimeException を構築します。
MKRuntimeException(Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
この例外の発生原因となる例外を持つ MKRuntimeException を構築します。
MKRuntimeException(String, Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKRuntimeException を構築します。
MKServiceResult - interface jp.co.intra_mart.extension.maskat.service.MKServiceResult.
マスカット連携を行う処理結果です。
MKSystemException - exception jp.co.intra_mart.extension.maskat.exception.MKSystemException.
マスカットアプリケーション実行時に出力される例外です。
MKSystemException() - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
詳細メッセージを指定しないで MKSystemException を構築します。
MKSystemException(String) - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
指定された詳細メッセージを持つ MKSystemException を構築します。
MKSystemException(Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
この例外の発生原因となる例外を持つ MKSystemException を構築します。
MKSystemException(String, Throwable) - class jp.co.intra_mart.extension.maskat.exception.MKSystemException のコンストラクタ
指定された詳細メッセージとこの例外の発生原因となる例外を持つ MKSystemException を構築します。
MKTransition - class jp.co.intra_mart.extension.maskat.service.MKTransition.
マスカットに電文を送信するトランジションです。
MKTransition() - class jp.co.intra_mart.extension.maskat.service.MKTransition のコンストラクタ

N

NODE_PATH_PREFIX - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の static 変数
Pathを記述するフィールドのプレフィックス
NodePathControllerConverter - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter.
コントローラオブジェクトに「PATH_フィールド名」となる名前の静的フィールドを定義し、 代入されるノードのパスを指定することにより、ノードの値をコントローラオブジェクトに代入します。
NodePathControllerConverter() - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter のコンストラクタ

O

OBJECT_PARAM_NAME - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名
OBJECT_PARAM_NAME - class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter の static 変数
コントローラオブジェクトのクラス名を設定するパラメータ名

R

readXML(InputStream) - class jp.co.intra_mart.extension.maskat.util.XMLUtil の static メソッド
ストリームからXMLを読み込み、ドキュメントを生成します。

S

SYSTEM_ERROR_MESSAGE_NODE - class jp.co.intra_mart.extension.maskat.util.MKError の static 変数
systemErrorMessageのノード名
setComponentId(String) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
コンポーネントIDを設定します。
setErrorCode(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
errorCodeを設定します。
setEventId(String) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
イベントIDを設定します。
setInfo(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
infoを設定します。
setLayoutId(String) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
レイアウトIDを設定します。
setMessage(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageを設定します。
setMessageCode(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
messageCodeを設定します。
setSystemErrorMessage(String) - class jp.co.intra_mart.extension.maskat.util.MKError のメソッド
systemErrorMessageを設定します。
setTelegram(Document) - class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject のメソッド
電文を設定します。
size() - class jp.co.intra_mart.extension.maskat.util.MKErrors のメソッド
errorの個数を取得します。

T

transfer() - class jp.co.intra_mart.extension.maskat.service.MKTransition のメソッド
サービス処理結果に格納されたドキュメントをレスポンスとして送信します。

W

writeXML(Document, OutputStream) - class jp.co.intra_mart.extension.maskat.util.XMLUtil の static メソッド
ドキュメントをストリームに出力します。

X

XMLUtil - class jp.co.intra_mart.extension.maskat.util.XMLUtil.
XMLのユーティリティクラスです。
XMLUtil() - class jp.co.intra_mart.extension.maskat.util.XMLUtil のコンストラクタ
A C D E G I J M N O R S T W X
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_maskat 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_maskat 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.extension.maskat.exception
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.service.controller
jp.co.intra_mart.extension.maskat.util


概要 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_maskat API Specifications

パッケージ
jp.co.intra_mart.extension.maskat.exception
jp.co.intra_mart.extension.maskat.service
jp.co.intra_mart.extension.maskat.service.controller
jp.co.intra_mart.extension.maskat.util

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.extension.maskat.exception, jp.co.intra_mart.extension.maskat.service, jp.co.intra_mart.extension.maskat.service.controller, jp.co.intra_mart.extension.maskat.util

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.extension.maskat.service.DefaultMKServiceResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.extension.maskat.util.MKConst
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject (implements jp.co.intra_mart.framework.base.service.controller.ControllerObject)
    • class jp.co.intra_mart.extension.maskat.util.MKError
    • class jp.co.intra_mart.extension.maskat.util.MKErrors
      • class jp.co.intra_mart.extension.maskat.service.MKErrorsResult (implements jp.co.intra_mart.extension.maskat.service.MKServiceResult)
    • class jp.co.intra_mart.extension.maskat.service.controller.NodePathControllerConverter (implements jp.co.intra_mart.framework.base.service.controller.ControllerConverter)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.SystemException
            • class jp.co.intra_mart.extension.maskat.exception.MKSystemException
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.extension.maskat.exception.MKRuntimeException
    • class jp.co.intra_mart.framework.base.service.Transition
      • class jp.co.intra_mart.framework.base.service.DefaultTransition
        • class jp.co.intra_mart.extension.maskat.service.MKTransition
    • class jp.co.intra_mart.extension.maskat.util.XMLUtil

インタフェース階層

  • interface jp.co.intra_mart.framework.base.service.ServiceResult
    • interface jp.co.intra_mart.extension.maskat.service.MKServiceResult
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_maskat 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_maskat 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.extension.maskat.exception

クラス jp.co.intra_mart.extension.maskat.exception.MKRuntimeException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.extension.maskat.exception.MKSystemException は jp.co.intra_mart.framework.system.exception.SystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.extension.maskat.service.controller

クラス jp.co.intra_mart.extension.maskat.service.controller.MKControllerObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

document

Document document

layoutId

String layoutId

componentId

String componentId

eventId

String eventId

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


imartDesignCss (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartDesignCss

デザインスタイルシートの宣言を行います。

<imarttag:imartDesignCss> により、現在指定されているテーマ（色）のスタイルシートを設定します。
ServerManager 配下の conf/system.xml ファイルの system/color-config/color-pattern タグ内で 設定したＣＳＳファイルが利用可能になります。
system/color-config/color-pattern に複数のＣＳＳファイルを設定することも可能です。

制約
本タグを配置する場所は、HTML の <HEAD> タグ内です。
注意点
各画面（ページ）を作成するJSPファイルの <HEAD> タグ内には、 必ず デザインスタイルシート <imarttag:imartDesignCss> を記述してください。

サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
    :
    :
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
属性定義なし

概要 ライブラリ タグ ヘルプ


imartIcon (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartIcon

ツールバー内に「処理リンク」を表示します。

<imarttag:imartIcon> タグにより、「アイコン＋処理名」の処理リンクが表示されます。
「アイコン」のみ、または「処理名」のみの表示も可能です。

表示するアイコンは、属性 icon により指定できます。
表示する処理名は、属性 name により指定できます。
処理を選択されたときのリンク先として、jsの関数名やURLを指定することができます。
また、リンク先の表示ウィンドウを指定することができます。

本タグを <imarttag:imartToolbarLeft> タグに挟まれた範囲に記述すると、ツールバー内で左寄せに表示されます。
本タグを <imarttag:imartToolbarRight> タグに挟まれた範囲に記述すると、ツールバー内で右寄せに表示されます。
本タグを記述した順番に、ツールバーの左から「処理リンク」が配置されます。

制約
属性 href を指定した場合、<A> タグとして作成されます。
属性 attr (任意の属性) を指定する場合、属性 href が設定されている必要があります。
サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
        <% String attr = "tabindex=\"0\""; %>

        <!-- 「アイコン」のみ表示 -->
        <imarttag:imartIcon
                  icon = "/images/standard/refresh.gif"
                  href = "javascript:onReloadAction();" />

        <!-- 「アイコン＋処理名」表示 -->
        <imarttag:imartIcon
                  name = "詳細情報"
                  icon = "/images/standard/info.gif"
                  href = "http://www.intra-mart.co.jp"
                  attr = "<%= attr %>" />
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | false | true | java.lang.String | 処理名
icon | false | true | java.lang.String | アイコンのファイル名 ※リクエストパスからの相対パス または コンテキストルートからの相対パス パスの先頭が「/」の場合は自動的にコンテキストパスを付加し、コンテキストパスを含む絶対パスに置き換えられます。
href | false | true | java.lang.String | 処理選択時のジャンプ先 ※js 実行関数名や、URL など
target | false | true | java.lang.String | 表示ウィンドウ
alt | false | true | java.lang.String | 画像の変わりに表示される文字列を指定
attr | false | true | java.lang.String | <A> タグに指定する属性値 値は一度「変数」に代入し、attr="<%= attr %>"で指定します。

概要 ライブラリ タグ ヘルプ


imartInputTd (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartInputTd

入力項目の入力フィールドを表示します。

<imarttag:imartInputTd> により、入力項目の入力フィールドを表示します。
登録系画面や、更新・削除系画面で、入力項目の入力フィールドを記述する際に使用します。

属性 type に指定した値によって、異なる入力フィールドを表示することができます。
属性 type="text" を指定した場合は、テキスト入力フィールドが表示されます。
属性 type="password" を指定した場合は、パスワード入力フィールドが表示されます。
属性 type="file" を指定した場合は、ファイル入力フィールドが表示されます。
属性 type="checkbox" を指定した場合は、チェックボックスが表示されます。
属性 type="radio" を指定した場合は、ラジオボタンが表示されます。
属性 type="textarea" を指定した場合は、テキストエリア入力フィールドが表示されます。
属性 type="textarea" 以外は、HTML の <INPUT> タグとして作成されます。

制約
HTMLの <TD> タグとして作成されるため、<TABLE><TR> ～ </TR></TABLE> 内に記述してください。
また、デザインを統一するために本タグを使用する際には、必ず、サンプルに示す <TABLE><TR> ～ </TR></TABLE> 内に記述してください。
サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
        <%-- 複数指定する場合、[属性名]="[値]" をスペース区切りで繋げた文字列を指定 --%>
        <% String attr="width=\"150\" height=\"30\""; %>
        <% String inputAttr = "maxlength=\"256\""; %>

        <TABLE class="edit">
            <TR>
                <imarttag:imartInputTd type="text" name="text_1" size="30" attr="<%= attr %>" value="リードオンリー" readonly="true" />
            </TR>
            <TR>
                <imarttag:imartInputTd type="text" name="text_2" size="50" value="テキスト" inputAttr="<%= inputAttr %>" />
            </TR>
            <TR>
                <imarttag:imartInputTd type="password" name="password_1" value="パスワード" size="40" />
            </TR>
            <TR>
                <imarttag:imartInputTd type="file" name="file_1" size="50" />
            </TR>
            <TR>
                <imarttag:imartInputTd type="textarea" name="textarea_1" cols="40" rows="5" value="テキストエリア" />
            </TR>
            <TR>
                <imarttag:imartInputTd type="checkbox" name="checkbox_1" caption="チェックボックス" checked="true" />
            </TR>
            <TR>
                <imarttag:imartInputTd type="radio" name="radioButton" caption="ラジオ１" />
                <imarttag:imartInputTd type="radio" name="radioButton" caption="ラジオ２" checked="true" />
            </TR>
        </TABLE>
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
type | true | true | java.lang.String | 部品の種類 ・text ：テキスト入力フィールド ・password：パスワード入力フィールド ・file ：ファイル入力フィールド ・checkbox：チェックボックス ・radio ：ラジオボタン ・textarea：テキストエリア入力フィールド
name | true | true | java.lang.String | 名前
value | false | true | java.lang.String | 初期値
size | false | true | java.lang.String | 大きさ
caption | false | true | java.lang.String | 部品の名称 (type="checkbox"/type="radio" が指定されている場合)
readonly | false | false | java.lang.String | 入力不可の指定
checked | false | false | java.lang.String | チェック状態の指定 (<input type="checkbox"/"radio"> の checked 属性)
cols | false | true | java.lang.String | テキストエリアの横幅 (<TEXTAREA> の cols 属性)
rows | false | true | java.lang.String | テキストエリアの縦幅(行数) (<TEXTAREA> の rows 属性)
attr | false | true | java.lang.String | <TD> タグに指定する属性値 値は一度「変数」に代入し、attr="<%= attr %>"で指定します。
inputAttr | false | true | java.lang.String | <INPUT> タグに指定する属性値 値は一度「変数」に代入し、inputAttr="<%= inputAttr %>"で指定します。

概要 ライブラリ タグ ヘルプ


imartItemNameTd (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartItemNameTd

入力項目の「項目名称」を表示します。

<imarttag:imartItemNameTd> により、入力項目の 「項目名称」 を表示します。
登録系画面や、更新・削除系画面で、入力項目の項目名称を記述する際に使用します。

属性 name に指定した値が、項目名称として表示されます。
属性 attr に指定した値は、<TD> タグの属性として出力されます。
属性 require に指定した値によって、「必須項目」または「通常項目」を切り替えることができます。

制約
HTMLの <TD> タグとして作成されるため、<TABLE><TR> ～ </TR></TABLE> 内に記述してください。
また、デザインを統一するために本タグを使用する際には、必ず、サンプルに示す <TABLE><TR> ～ </TR></TABLE> 内に記述してください。
サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
        <!-- 複数指定する場合、[属性名]="[値]" をスペース区切りで繋げた文字列を指定 -->
        <% String attr="width=\"150\" height=\"50\""; %>

        <TABLE class="edit">
            <TR>
                <imarttag:imartItemNameTd name="ユーザID" attr="<%= attr %>" />
            </TR>
            <TR>
                <imarttag:imartItemNameTd name="ユーザ名" require />
            </TR>
        </TABLE>
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | 項目名称
attr | false | true | java.lang.String | <TD> タグに指定する属性値 値は一度「変数」に代入し、attr="<%= attr %>"で指定します。
require | false | true | java.lang.String | 必須項目の指定

概要 ライブラリ タグ ヘルプ


imartListControl (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartListControl

各種一覧に対するソート切り替えコントロールと、ページ切り替えコントロールを表示します。

<imarttag:imartListControl> タグにより、各種一覧に対するソート切り替えコントロールと、ページ切り替えコントロールを表示します。
各コントロールはリンク表示となっています。
各コントロールのリンクがクリックされると JavaScript 関数が呼び出されるため、本タグを使用した場合は、各コントロールに対して JavaScript 関数の処理を記述する必要があります。
(詳細は デフォルトの必須 JavaScript 関数 を参照)

ソート切り替えコントロールには、昇順ソート(有効／無効)、 降順ソート(有効／無効) の矢印リンクが用意されています。
ソート切り替えコントロールは、属性の指定により表示、非表示を設定することができます。

ページ切り替えコントロールには、前のページ、次のページ、最初のページ、最後のページの矢印リンクが用意されています。
一覧で表示しているページによって、矢印リンクの表示および非表示を切り替えます。
一覧の表示件数が［全件数＜１ページの表示数］の場合は、ページ切り替えコントロールの矢印部分は表示されません。(全件数のみ表示)

制約
本タグは、HTML の <TABLE> タグとして作成されます。
本タグを配置する場所は、HTML の <BODY> タグ内です。

デフォルトの必須 JavaScript 関数

ソート切り替えコントロール、ページ切り替えコントロールのリンクをクリックした際に呼び出される、デフォルト JavaScript 関数の詳細を以下に示します。
本タグを使用する際に、下記の属性を未指定にした場合は、各自で必ずデフォルト JavaScript 関数の処理を記述してください。

  ・ 属性 prevPageFunc
  ・ 属性 nextPageFunc
  ・ 属性 firstPageFunc
  ・ 属性 lastPageFunc
  ・ 属性 ascSortFunc
  ・ 属性 descSortFunc

必須の JavaScript 関数を記述しない場合の動作については、保証外とします。
コーディング方法などの詳細については、サンプルを参照してください。
上記の属性を指定した場合は、デフォルト JavaScript 関数の処理を記述する必要はありません。

ソート切り替え
属性 ascSortFunc および属性 descSortFunc のいずれかを未指定にした場合、
ソート切り替えコントロールで 「昇順」および「降順」のリンクをクリックすると、JavaScript 関数の onSortLinkFunc() が呼び出されます。

■関数名
  onSortLinkFunc(mode)

■概要
  ソート切り替えコントロール(昇順／降順) がクリックされた際に、呼び出される関数です。
  引数 mode の値により、昇順／降順のどちらが選択されたかの情報を取得することができます。

■引数
変数 | 内容 | 値 | 条件
mode | ソート基準方向 | asc | 「昇順」リンクが選択された場合
desc | 「降順」リンクが選択された場合

ページ切り替え
属性 prevPageFunc、nextPageFunc、firstPageFunc、lastPageFunc のいずれかを未指定にした場合、
ページ切り替えコントロールで各矢印のリンクがクリックされると、JavaScript 関数の onPageLinkFunc() が呼び出されます。

■関数名
  onPageLinkFunc(num)

■概要
  ページ切り替えコントロールの各矢印リンクがクリックされた際に、呼び出される関数です。
  引数 num の値により、次に表示するページ番号の情報を取得することができます。

■引数
変数 | 内容 | 値 | 条件
num | ページ番号 | 1 | 「最初ページ」リンクが選択された場合
([属性maxRecord]／[属性pageLine])の小数点繰上げ | 「最後ページ」リンクが選択された場合
[属性currentPage]－1 | 「前ページ」リンクが選択された場合
[属性currentPage]＋1 | 「次ページ」リンクが選択された場合

サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
        <SCRIPT LANGUAGE="JavaScript">
            // ページ切り替えリンクがクリックされた時の処理
            function onPageLinkFunc(num)
            {
                        :
                // 各自で処理を記述
                        :
            }
            // 昇順／降順(ソート条件)がクリックされた時の処理
            function onSortLinkFunc(mode)
            {
                        :
                // 各自で処理を記述
                        :
            }
        </SCRIPT>
    </HEAD>
    <BODY>
        <TABLE border="0" width="100%" cellpadding="0" cellspacing="2">
            <TR>
                <TD>
                    <!-- リストコントロール -->
                    <imarttag:imartListControl
                              maxRecord="150"
                              currentPage="1"
                              pageLine="10"
                              sortOrder="asc" />
                </TD>
            </TR>
        </TABLE>
        </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
maxRecord | true | true | java.lang.String | 全件数
currentPage | false | true | java.lang.String | 表示するページ番号
pageLine | false | true | java.lang.String | 1ページの表示件数(未指定の場合：10)
sortDisplay | false | true | java.lang.String | 「昇順／降順」 の有無 （true：表示／false：非表示）
sortOrder | false | true | java.lang.String | ソート基準方向 （asc：昇順／desc：降順）
prevPageFunc | false | true | java.lang.String | 前ページ選択時の js 関数
nextPageFunc | false | true | java.lang.String | 次ページ選択時の js 関数
firstPageFunc | false | true | java.lang.String | 最初ページ選択時の js 関数
lastPageFunc | false | true | java.lang.String | 最終ページ選択時の js 関数
ascSortFunc | false | true | java.lang.String | 昇順ソート選択時の js 関数
descSortFunc | false | true | java.lang.String | 降順ソート選択時の js 関数

概要 ライブラリ タグ ヘルプ


imartListHeader (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartListHeader

各種一覧(リスト)に対するヘッダを表示します。

<imarttag:imartListHeader> により、各種一覧(リスト)に対するヘッダを表示します。
属性 headerData には、「一覧ヘッダ情報」を指定します。
属性 headerData には、List インターフェースを実装したクラスのインスタンスに、一覧のヘッダ情報クラス (ListHeaderObject) のインスタンスを格納して指定します。
属性 headerData に指定したインスタンスに格納されている、すべての ListHeaderObject クラスのインスタンスの値が、ヘッダ項目の表示要素になります。
属性 headerData に指定したインスタンスに格納されている、ListHeaderObject クラスのインスタンスを生成するときに指定した「項目ID」が、属性 sortKey の値と一致する場合に、該当の項目がソートキー(現在、ソートの基準になっている項目のこと)となります。

属性 sortKey には、ヘッダ項目の初期表示時にソートキーとする 「項目ID」を指定します。
属性 sortKey に指定した値が、属性 headerData に指定した ListHeaderObject クラスのインスタンスを生成するときに指定した「項目ID」として存在しない場合は、どの項目もソートキーにはなりません。

制約
本タグを配置する場所は、HTML の <BODY> タグ内です。
本タグは HTML の <TR> タグとして作成されるため、<TABLE> ～ </TABLE> 内に記述してください。
その際、<TABLE>タグには class="list_border_bg" または class="table_border_bg" を指定してください。

表全体の枠 (横幅100%固定) | <TABLE class="list_border_bg">
表全体の枠 (横幅任意指定) | <TABLE class="table_border_bg">

クラスListHeaderObject
jp.co.intra_mart.foundation.core.taglib.ListHeaderObject

List インターフェースを実装したクラスのインスタンスに、このヘッダ情報クラス ListHeaderObject のインスタンスを格納して、属性 headerData に指定します。
ListHeaderObject クラスをインスタンス化するときに、使用するコンストラクタによって異なるヘッダ情報を生成することができます。

ListHeaderObject に設定するヘッダ情報
設定内容 型 説明
項目ID java.lang.String 項目ID
"checkbox" を指定した場合、ヘッダ内にチェックボックスが表示されます。
項目名 java.lang.String ヘッダに表示する項目名
項目ID = "checkbox" の場合は、
<INPUT type="checkbox"> タグの name 属性となります。
ソート表示状態 boolean 項目名の表示状態
  ・true ： リンク表示(未指定の場合)
  ・false： 通常表示
項目ID = "checkbox" の場合は、false が設定されます。
項目名選択時の js 関数 java.lang.String 項目名がリンク表示の場合、リンクが選択された時のjs関数を指定
未指定の場合、onSortHeadClick(項目ID); が設定され、
項目ID = "checkbox" の場合は、「onClock イベントハンドラ」に設定する js 関数を指定します。
表示位置 java.lang.String 項目名の表示位置
  ・center ： 中央表示(未指定の場合)
  ・left　 ： 左寄せ
  ・right　： 右寄せ
項目の属性 java.lang.String 項目に設定する任意の属性(項目の<TD>タグの属性値)
複数の任意の属性を指定することも可能。

注意事項
ListHeaderObject クラスをインスタンス化した際に、ソート表示状態が「リンク表示」に設定された場合は、項目名はリンク表示となります。
項目名のリンクがクリックされると JavaScript 関数が呼び出されるため、本タグを使用した場合は、各項目名リンクに対しての JavaScript 関数の処理を記述する必要があります。
「項目名選択時の js 関数」を指定した場合は、指定した JavaScript 関数を記述してください。
「項目名選択時の js 関数」を未指定にした場合は、デフォルトの JavaScript 関数「onSortHeadClick」を必ず記述してください。

コンストラクタ

ListHeaderObject クラスをインスタンス化する際に、使用するコンストラクタによって異なるヘッダ情報を生成することができます。

public ListHeaderObject()
■概要
  空のヘッダ情報オブジェクトを作成します。
  空のヘッダ項目を作成する際に使用します。

■引数
  なし

public ListHeaderObject(String id, String name)
■概要
  項目ID と項目名を指定して、ヘッダ情報オブジェクトを作成します。

■引数
引数 | 型 | 説明
id | java.lang.String | 項目ID
name | java.lang.String | 項目名

public ListHeaderObject(String id, String name, boolean sortLink)
■概要
  項目ID と項目名、ソート表示状態を指定して、ヘッダ情報オブジェクトを作成します。

■引数
引数 | 型 | 説明
id | java.lang.String | 項目ID
name | java.lang.String | 項目名
sortLink boolean 項目名の表示状態を指定
  ・true ： リンク表示(未指定の場合)
  ・false： 通常表示

public ListHeaderObject(String id, String name, String href)
■概要
  項目ID と項目名、項目名選択時の js 関数を指定して、ヘッダ情報オブジェクトを作成します。

■引数
引数 | 型 | 説明
id | java.lang.String | 項目ID
name | java.lang.String | 項目名
href | java.lang.String | 項目名選択時の js 関数

ListHeaderObject ヘッダ情報を設定するためのメソッド

ヘッダ情報を設定するためのメソッドは、以下の通りです。
メソッド | パラメータ | 説明
setSortLink(boolean sortLink) ソート表示状態 項目名の表示状態を指定
  ・true ： リンク表示(未指定の場合)
  ・false： 通常表示
setHref(String href) 項目名選択時の js 関数 項目名がリンク表示の場合、リンクが選択された時のjs関数を指定します。
項目ID = "checkbox" の場合は、「onClock イベントハンドラ」に記述される js 関数を指定します。
setAlign(String align) 項目名の表示位置 項目名の表示位置を指定
  ・center： 中央表示(未指定の場合)
  ・left　　： 左寄せ
  ・right 　： 右寄せ
setAttr(String attr) | 項目の属性を指定 | 項目の<TD>タグの属性値を指定

デフォルトの必須 JavaScript 関数
リストヘッダの項目名リンクがクリックされた際に呼び出される、デフォルトの JavaScript 関数の詳細を以下に示します。

属性 headerData に指定する ListHeaderObject クラスをインスタンス化する際に、
ソート表示状態が「リンク表示」で「項目名選択時の js 関数」を指定していない場合は、各自でデフォルトの JavaScript 関数の処理を記述する必要があります。

必須の JavaScript 関数を記述しない場合の動作については、保証外とします。
コーディング方法などの詳細については、サンプルを参照してください。
ListHeaderObject クラスをインスタンス化する際に「項目名選択時の js 関数」を指定した場合は、デフォルトの JavaScript 関数の処理を記述する必要はありません。

ソートの項目切り替え
属性 headerData に指定する ListHeaderObject クラスをインスタンス化する際に、「項目名選択時の js 関数」を未指定にした場合、リストヘッダの項目名リンクをクリックすると JavaScript 関数の onSortHeadClick() が呼び出されます。

■関数名
  onSortHeadClick(key)

■概要
  リストヘッダの項目名リンクがクリックされた際に、呼び出される関数です。
  引数 key(項目ID) の値により、どのヘッダ項目が選択されたかの情報を取得することができます。

■引数
変数 | 内容 | 値 | 条件
key | ヘッダの項目ID | (例) userName | リストヘッダの項目名リンクが選択された場合

サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
<%@ page import="java.util.ArrayList" %>
<%@ page import="jp.co.intra_mart.foundation.core.taglib.ListHeaderObject" %>

<%
    // ヘッダ項目情報を設定
    ListHeaderObject objData = null;
    ArrayList data = new ArrayList();

    // (1) チェックボックスヘッダ
    objData = new ListHeaderObject("checkbox", "checkCtrl", "onCheckBox();");
    data.add(objData);

    objData = new ListHeaderObject("userId", "ユーザコード");
    data.add(objData);

    objData = new ListHeaderObject("userName", "ユーザ名");
    data.add(objData);

    // 項目情報生成後、メソッドでヘッダ情報を設定
    objData = new ListHeaderObject("comp", "会社／組織", false);
    objData.setAlign("left");
    objData.setAttr("width=\"150\" tabindex=\"1\"");
    data.add(objData);
%>
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
        <SCRIPT LANGUAGE="JavaScript">
            // 一覧の項目名リンクがクリックされた時の処理
            function onSortHeadClick(key)
            {
                        :
                // 各自で処理を記述
                        :
            }
            // (1) で指定したJavaScript 関数の処理
            function onCheckBox()
            {
                        :
                // 各自で処理を記述
                        :
            }
        </SCRIPT>
    </HEAD>
    <BODY>
        <TABLE class="list_border_bg">
            <!-- リストヘッダ -->
            <imarttag:imartListHeader headerData="<%= data %>" sortKey="userId" />
        </TABLE>
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
headerData | true | true | java.util.List | 一覧ヘッダ情報
sortKey | true | true | java.lang.String | ソートキーとする項目ID

概要 ライブラリ タグ ヘルプ


imartSelectTd (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartSelectTd

入力項目の選択ボックスを表示します。

<imarttag:imartSelectTd> により、入力項目の選択ボックスを表示します。
登録系画面や、更新・削除系画面で、入力項目の選択ボックスを記述する際に使用します。

既存の画面共通モジュール <imarttag:Select> と同じ機能であり、画面デザインを統一するためにデザインが変更されています。

制約
本タグを配置する場所は、HTML の <BODY> タグ内です。
HTMLの <TD> タグとして作成されるため、<TABLE><TR> ～ </TR></TABLE> 内に記述してください。
また、デザインを統一するために本タグを使用する際には、必ず、サンプルに示す <TABLE><TR> ～ </TR></TABLE> 内に記述してください。
サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Windows-31J" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>

<%
    // <imartSelectTd> のlist 属性に指定するデータを生成
    String[] fromOptionValue = new String[]{"Tokyo",  "Kanagawa", "Saitama", "Chiba"};
    String[] fromOptionText  = new String[]{"東京都", "神奈川県", "埼玉県",  "千葉県"};

    java.util.List fromList = new java.util.ArrayList();

    for(int i = 0 ; i < fromOptionValue.length ; i++)
    {
        java.util.Map map = new java.util.HashMap();
        map.put("value", fromOptionValue[i]);
        map.put("text",  fromOptionText[i]);
        fromList.add(map);
    }

%>

<%
    // 初期選択値の設定
    java.util.List selectedList = new java.util.ArrayList();
    selectedList.add(fromOptionValue[2]); // ここでは、"Saitama"を設定

    // SELECT タグに指定する属性値の設定（複数指定する場合、[属性名]="[値]" をスペース区切りで繋げた文字列を指定）
    String selectAttr = "title=\"出身地\" disabled";
%>

<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
        <TABLE class="edit">
            <TR>
                <imarttag:imartItemNameTd name="出身地" />
                <imarttag:imartSelectTd list        = "<%= fromList %>"
                                        name        = "hometown"
                                        optionValue = "value"
                                        optionText  = "text"
                                        size        = "1"  />

                <!-- selectAttrを使用した場合(attrも使用方法は同様) -->
                <imarttag:imartSelectTd list        = "<%= fromList %>"
                                        name        = "sel"
                                        optionValue = "value"
                                        optionText  = "text"
                                        selectAttr  = "<%= selectAttr %>"
                                        selected    = "<%= selectedList %>" />

            </TR>
        </TABLE>
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 表示リスト
name | false | true | java.lang.String | 名前
size | false | true | java.lang.String | 表示する行数 (未指定の場合：1)
selected | false | true | java.util.List | 初期選択値の設定
blank | false | true | java.lang.String | 空データを表示する位置 ・top ：先頭位置に空データ ・bottom：最後尾位置に空データ
attr | false | true | java.lang.String | <TD> タグに指定する属性値 値は一度「変数」に代入し、attr="<%= attr %>"で指定します。
selectAttr | false | true | java.lang.String | <SELECT> タグに指定する属性値 値は一度「変数」に代入し、selectAttr="<%= selectAttr %>"で指定します。
multiple | false | true | java.lang.String | 複数行選択の可否
optionValue | false | true | java.lang.String | <OPTION> タグの value 値に対応するキー名
optionText | false | true | java.lang.String | <OPTION> タグの text 値に対応するキー名(任意)

概要 ライブラリ タグ ヘルプ


imartTitleBar (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartTitleBar

タイトルバーを表示します。

<imarttag:imartTitleBar> により、タイトルバーを表示します。
タイトルバーには、「アイコン」 と 「ページタイトル名」 を指定して表示することができます。

制約
本タグを配置する場所は、HTML の <HEAD> タグ内です。

サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
        <!-- タイトルバー表示 -->
        <imarttag:imartTitleBar  title="新規登録" icon="/images/standard/title.gif" />
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
title | true | true | java.lang.String | ページタイトル名
icon | false | true | java.lang.String | アイコンのファイル名 ※リクエストパスからの相対パス または コンテキストルートからの相対パス パスの先頭が「/」の場合は自動的にコンテキストパスを付加し、コンテキストパスを含む絶対パスに置き換えられます。 属性 icon を未指定にした場合は、/images/standard/title.gif が表示されます。

概要 ライブラリ タグ ヘルプ


imartToolbarFrame (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartToolbarFrame

ツールバーの外枠を表示します。

<imarttag:imartToolbarFrame> により、ツールバーの外枠を表示します。
ツールバーの表示色は、テーマによって自動に設定されます。

制約
本タグを配置する場所は、HTML の <BODY> タグ内です。

サンプル:
<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Shift_JIS" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
    :
    :
<HTML>
    <HEAD>
        <imarttag:imartDesignCss />
    </HEAD>
    <BODY>
        <!-- タイトルバー表示 -->
              :
            (省略)
              :
        <!-- ツールバー(フレーム)表示 -->
        <imarttag:imartToolbarFrame>

            <!-- ツールバー(左)表示 -->
            <imarttag:imartToolbarLeft>
                <imarttag:imartIcon
                    name = "新規登録"
                    icon = "/images/standard/new.gif"
                    href = "javascript:onAddAction();" />
                <imarttag:imartIcon
                    name = "検索条件"
                    icon = "/images/standard/search.gif"
                    href = "javascript:onSearchAction();" />
            </imarttag:imartToolbarLeft>

            <!-- ツールバー(右)表示 -->
            <imarttag:imartToolbarRight>
                <imarttag:imartIcon
                    name = "戻る"
                    icon = "/images/standard/arrow_left.gif"
                    href = "javascript:onBackAction();" />
                <imarttag:imartIcon
                    name = "最新情報"
                    icon = "/images/standard/refresh.gif"
                    href = "javascript:onReloadAction();" />
            </imarttag:imartToolbarRight>

        </imarttag:imartToolbarFrame>
        :
        :
    </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
属性定義なし

概要 ライブラリ タグ ヘルプ


imartToolbarLeft (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartToolbarLeft

ツールバーの 左側 に「処理リンク」を表示します。

<imarttag:imartToolbarLeft> タグに挟まれた範囲に記述された「処理リンク」は、ツールバー内で左寄せに表示されます。
ツールバーの左側に表示する 「処理リンク」 がないときは、省略可能です。
本タグに挟まれた範囲には、複数の 「処理リンク」 を記述することができます。

「処理リンク」 には <imarttag:imartIcon> タグ(詳細は <imarttag:imartIcon> を参照) だけでなく、通常のHTMLタグ <A href="XXXX"> なども記述することが可能です。

制約
本タグを単独で利用することはできません。
<imarttag:imartToolbarFrame> タグの内部タグとして利用してください。
本タグは <imarttag:imartToolbarRight> タグの前に記述してください。
サンプル:
imartToolbarFrameタグのサンプルを参照してください。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
属性定義なし

概要 ライブラリ タグ ヘルプ


imartToolbarRight (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール
タグ imartToolbarRight

ツールバーの 右側 に「処理リンク」を表示します。

<imarttag:imartToolbarRight> タグに挟まれた範囲に記述された「処理リンク」は、ツールバー内で右寄せに表示されます。
ツールバーの右側に表示する 「処理リンク」 がないときは、省略可能です。
本タグに挟まれた範囲には、複数の 「処理リンク」 を記述することができます。

「処理リンク」 には <imarttag:imartIcon> タグ(詳細は <imarttag:imartIcon> を参照) だけでなく、通常のHTMLタグ <A href="XXXX"> なども記述することが可能です。

制約
本タグを単独で利用することはできません。
<imarttag:imartToolbarFrame> タグの内部タグとして利用してください。
本タグは <imarttag:imartToolbarLeft> タグの後に記述してください。
サンプル:
imartToolbarFrameタグのサンプルを参照してください。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
属性定義なし

概要 ライブラリ タグ ヘルプ


 intra-mart 画面デザイン共通モジュール
タグ一覧
imarttag:imartDesignCss
imarttag:imartIcon
imarttag:imartInputTd
imarttag:imartItemNameTd
imarttag:imartListControl
imarttag:imartListHeader
imarttag:imartSelectTd
imarttag:imartTitleBar
imarttag:imartToolbarFrame
imarttag:imartToolbarLeft
imarttag:imartToolbarRight


intra-mart 画面デザイン共通モジュール (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 画面デザイン共通モジュール

標準構文:
     <%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
XML構文:
     <anyxmlelement xmlns:imarttag="http://www.intra-mart.co.jp/taglib/foundation/imarttag" />
intra-mart 画面デザイン共通モジュール。

画面デザイン共通モジュール利用時の注意点

1. 画面デザイン共通モジュールを使用する際は、必ず各画面を構成しているHTMLの<HEAD>タグ内に、 デザインスタイルシートの宣言（＝<imarttag:imartDesignCss>）を行ってください。

2. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

3. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

4. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合には、当該JSP変数の型が属性値に渡されます。

5. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

6. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
intra-mart タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要があります。

<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/foundation/imarttag" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加される XML 名前空間識別子を指定するもので、 任意の名前を付けても構いません。(以下、この API リストでは、 prefix 属性を "imarttag" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" prefix="imarttag" />

タグライブラリ情報
表示名 | intra-mart 画面デザイン共通モジュール
Version | 1.0
Short Name | imarttag
URI | http://www.intra-mart.co.jp/taglib/foundation/imarttag

タグ 一覧
imartDesignCss | デザインスタイルシートの宣言を行います。
imartIcon | ツールバー内に「処理リンク」を表示します。
imartInputTd | 入力項目の入力フィールドを表示します。
imartItemNameTd | 入力項目の「項目名称」を表示します。
imartListControl | 各種一覧に対するソート切り替えコントロールと、ページ切り替えコントロールを表示します。
imartListHeader | 各種一覧(リスト)に対するヘッダを表示します。
imartSelectTd | 入力項目の選択ボックスを表示します。
imartTitleBar | タイトルバーを表示します。
imartToolbarFrame | ツールバーの外枠を表示します。
imartToolbarLeft | ツールバーの 左側 に「処理リンク」を表示します。
imartToolbarRight | ツールバーの 右側 に「処理リンク」を表示します。

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
imarttag:imartDesignCss
imarttag:imartIcon
imarttag:imartInputTd
imarttag:imartItemNameTd
imarttag:imartListControl
imarttag:imartListHeader
imarttag:imartSelectTd
imarttag:imartTitleBar
imarttag:imartToolbarFrame
imarttag:imartToolbarLeft
imarttag:imartToolbarRight


API ヘルプ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
PREV NEXT フレームあり フレームなし

このタグ・ライブラリ・ドキュメントはどう構成されているか。

このTLD(Tag Library Descriptor)ドキュメントのナビゲーション・バーの説明は以下の通り。

概要

概要 ページは、このTLDドキュメントの第一面であり、それぞれのために概要をすべてのタグ・ライブラリのリストを表示します。

ライブラリ

それぞれのタグ・ライブラリには、その検証、リスナー、タグ、関数のリストを含む1ページがあり、それぞれの概要となります。 このページは4つのカテゴリを含みます:
  • 検証
  • リスナー
  • タグ
  • 関数

検証

タグ・ライブラリは０以上の検証を定義することができます。 タグ・ライブラリに検証があるなら、それはそれ自身のページに検証、検証を実行するクラス、および利用可能な初期化パラメータについて説明します。

リスナー

タグ・ライブラリは０以上のリスナを定義することができます。 タグ・ライブラリに少なくとも1つのリスナが定義されているなら、すべてのリスナ・クラスを説明するページがあります。

タグ

タグ・ライブラリは０以上のタグを定義することができます。また、各タグにはタグについて説明するそれ自身のページがあります。 そのディスプレイ名、そのユニークなアクション名、タグを実行するクラス、TagExtraInfoクラス、ボディー内容、タイプ、変数情報、属性、タグが動的属性、およびタグのオプションの使用例を説明します。

関数

タグ・ライブラリは０以上の関数を定義することができます。各関数には、関数について説明するそれ自身のページがあります。 そのユニークなアクション名、そのディスプレイ名、タグを実行するクラスについて説明します。 タグ・ライブラリに少なくとも1つの関数が定義されているなら、機能のすべての機能、機能を実行するクラス、機能署名、およびオプションの使用例を示すページがあります。

Prev/Next

これらのリンクは次か前の検証、リスナー、タグ、関数、または関連するページに移動します。

フレームあり/フレームなし

これらのリンクは、HTMLフレームの使用、未使用を選択できます。

概要 ライブラリ タグ ヘルプ
PREV NEXT フレームあり フレームなし


Tag Library Documentation Generator - Generated Documentation

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link to Non-frame version.


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart 画面デザイン共通モジュール


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart 画面デザイン共通モジュール intra-mart 画面デザイン共通モジュール。

概要 ライブラリ タグ ヘルプ


Form (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ Form

HTMLのFORMタグに変換されます。

セッション情報を引き渡すために利用します。

本タグのapplication および service属性によって処理や遷移先が決定されます。

注意事項
本タグを配置する場所は、HTMLのFORMタグに準じます。
サンプル:
<imartj2ee:Form application="sample" service="view1" method="POST">
    <INPUT type="text" name="column1" size="20"><BR>
    <INPUT type="submit" value=" O K ">
</imartj2ee:Form>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
accept | false | true | java.lang.Number | HTMLにおけるFORMタグのaccept属性に相当します。
acceptcharset | false | true | java.lang.String | 奨励されていません。accept-charset属性を使用してください。 HTMLにおけるFORMタグのaccept-charset属性に相当します。 注意：属性名はハイフン無しで記述してください。
accept-charset | false | true | java.lang.String | HTMLにおけるFORMタグのaccept-charset属性に相当します。
application | true | true | java.lang.String | アプリケーションIDを指定します。
class | false | true | java.lang.String | HTMLにおけるFORMタグのclass属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるFORMタグのdir属性に相当します。
enctype | false | true | java.lang.String | HTMLにおけるFORMタグのenctype属性に相当します。
formclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるFORMタグのclass属性に相当します。 注意：変換後に属性名が変わります。
id | false | true | java.lang.String | HTMLにおけるFORMタグのid属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるFORMタグのlang属性に相当します。
method | false | true | java.lang.String | HTMLにおけるFORMタグのmethod属性に相当します。
name | false | true | java.lang.String | HTMLにおけるFORMタグのname属性に相当します。
onclick | false | true | java.lang.String | HTMLにおけるFORMタグのonClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
ondblclick | false | true | java.lang.String | HTMLにおけるFORMタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるFORMタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるFORMタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるFORMタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousedown | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるFORMタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onreset | false | true | java.lang.String | HTMLにおけるFORMタグのonReset属性に相当します。 注意：属性名はすべて小文字で記述してください。
onsubmit | false | true | java.lang.String | HTMLにおけるFORMタグのonSubmit属性に相当します。 注意：属性名はすべて小文字で記述してください。
service | true | true | java.lang.String | サービスIDを指定します。
style | false | true | java.lang.String | HTMLにおけるFORMタグのstyle属性に相当します。
target | false | true | java.lang.String | HTMLにおけるFORMタグのtarget属性に相当します。
title | false | true | java.lang.String | HTMLにおけるFORMタグのtitle属性に相当します。

概要 ライブラリ タグ ヘルプ


Frame (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ Frame

HTMLのFRAMEタグに変換されます。
セッション情報を引き渡すために利用します。

本タグのapplication および service属性によって処理や遷移先が決定されます。

注意事項
本タグを配置する場所は、HTMLのFRAMEタグに準じます。
サンプル:
<FRAMESET rows="50%,*">
    <imartj2ee:Frame application="sample" service="frametop">
        <imartj2ee:Param name="param1" value="value1"/>
    </imartj2ee:Frame>
    <imartj2ee:Frame application="sample" service="framebottom">
        <imartj2ee:Param name="param2" value="value2"/>
    </imartj2ee:Frame>
</FRAMESET>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるFRAMEタグのid属性に相当します。
application | true | true | java.lang.String | アプリケーションIDを指定します。
service | true | true | java.lang.String | サービスIDを指定します。
frameclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるFRAMEタグのclass属性に相当します。 注意：変換後に属性名が変わります。
class | false | true | java.lang.String | HTMLにおけるFRAMEタグのclass属性に相当します。
frameborder | false | true | java.lang.String | HTMLにおけるFRAMEタグのframeborder属性に相当します。
longdesc | false | true | java.lang.String | HTMLにおけるFRAMEタグのlongdesc属性に相当します。
marginheight | false | true | java.lang.String | HTMLにおけるFRAMEタグのmarginheight属性に相当します。
marginwidth | false | true | java.lang.String | HTMLにおけるFRAMEタグのmarginwidth属性に相当します。
name | false | true | java.lang.String | HTMLにおけるFRAMEタグのname属性に相当します。
noresize | false | true | java.lang.String | HTMLにおけるFRAMEタグのnoresize属性に相当します。
scrolling | false | true | java.lang.String | HTMLにおけるFRAMEタグのscrolling属性に相当します。
style | false | true | java.lang.String | HTMLにおけるFRAMEタグのstyle属性に相当します。
title | false | true | java.lang.String | HTMLにおけるFRAMEタグのtitle属性に相当します。

概要 ライブラリ タグ ヘルプ


HelperBean (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ HelperBean

HelperBeanを使用するための初期化を行います。
ErrorHelperBeanもこのタグで初期化できます。
このタグを使用すると、HelperBeanの生成、Requestの設定、Responseの設定、初期化(initメソッドの呼び出し)が自動的に行われます。

注意事項
JSP内でHelperBean（またはErrorHelperBean）を使用する場合、本タグを先に配置してください。
HelperBean（またはErrorHelperBean）を本タグより先に使用している場合、JSPのエラーが出る場合があります。
HelperBeanの詳細についてはAPIリスト等でjp.co.intra_mart.framework.base.web.bean.HelperBean（ErrorHelperBeanの場合はjp.co.intra_mart.framework.base.web.bean.ErrorHelperBean）を参照してください。

サンプル:
この中で使用されるsample.TestHelperBeanは社員コードを取得する以下のメソッドが実装されているものとします。
public String getCode()

<imartj2ee:HelperBean id="testHelper" class="sample.TestHelperBean" />
社員コード：<jsp:getProperty name="testHelper" property="code" />

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | true | false | java.lang.String | JSPの中でHelperBeanを使用するときの変数名を指定します。
helperclass | false | false | java.lang.String | 奨励されていません。class属性を使用してください。 HelperBeanの完全なクラス名(パッケージを含むクラス名)を指定します。 ここで指定するクラスはjp.co.intra_mart.framework.base.web.bean.HelperBeanを継承している必要があります。
class | false | false | java.lang.String | HelperBeanの完全なクラス名(パッケージを含むクラス名)を指定します。 ここで指定するクラスはjp.co.intra_mart.framework.base.web.bean.HelperBeanを継承している必要があります。

概要 ライブラリ タグ ヘルプ


Link (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ Link

HTMLのAタグに変換されます。
セッション情報を引き渡すために利用します。

本タグのapplication および service属性によって処理や遷移先が決定されます。

注意事項
本タグを配置する場所は、HTMLのFORMタグに準じます。
サンプル:
<imartj2ee:Link application="sample" service="view1">
    <imartj2ee:Param name="param1" value="value1"/>
    リンク１
</imartj2ee:Link>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるAタグのid属性に相当します。
application | true | true | java.lang.String | アプリケーションIDを指定します。
service | true | true | java.lang.String | サービスIDを指定します。
accesskey | false | true | java.lang.String | HTMLにおけるAタグのaccesskey属性に相当します。
charset | false | true | java.lang.String | HTMLにおけるAタグのcharset属性に相当します。
coords | false | true | java.lang.String | HTMLにおけるAタグのcoords属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるAタグのdir属性に相当します。
hreflang | false | true | java.lang.String | HTMLにおけるAタグのhreflang属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるAタグのlang属性に相当します。
linkclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるAタグのclass属性に相当します。 注意：変換後に属性名が変わります。
class | false | true | java.lang.String | HTMLにおけるAタグのclass属性に相当します。
name | false | true | java.lang.String | HTMLにおけるAタグのname属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるAタグのonBlur属性に相当します。 注意：属性名はすべて小文字で記述してください。
onclick | false | true | java.lang.String | HTMLにおけるAタグのonClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
ondblclick | false | true | java.lang.String | HTMLにおけるAタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onfocus | false | true | java.lang.String | HTMLにおけるAタグのonFocus属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるAタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるAタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるAタグのonKeyUp属性に相当します。
onmousedown | false | true | java.lang.String | HTMLにおけるAタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるAタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるAタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるAタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるAタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
rel | false | true | java.lang.String | HTMLにおけるAタグのrel属性に相当します。
rev | false | true | java.lang.String | HTMLにおけるAタグのrev属性に相当します。
shape | false | true | java.lang.String | HTMLにおけるAタグのshape属性に相当します。
style | false | true | java.lang.String | HTMLにおけるAタグのstyle属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるAタグのtabindex属性に相当します。
title | false | true | java.lang.String | HTMLにおけるAタグのtitle属性に相当します。
type | false | true | java.lang.String | HTMLにおけるAタグのtype属性に相当します。
target | false | true | java.lang.String | HTMLにおけるAタグのtarget属性に相当します。

概要 ライブラリ タグ ヘルプ


Message (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ Message

地域対応されたメッセージを表示します。
メッセージの国際化処理をJSPに埋め込むことなく地域対応したメッセージを表示したいときに利用します。

アプリケーションIDとキーは設定必須ですが、ロケールは省略可能です。ロケールを省略した場合、サービスフレームワークで決定されるロケールが使用されます。

内部タグであるMessageParamタグを使用するとメッセージ内の変数要素に値を入れることもできます。 この場合、MessageParamタグを複数指定すると、指定された順に整列された配列が生成され、Messageタグに渡されます。

注意事項
対応するメッセージが構築できなかった場合、このタグは"???<key>???"と表示します。<key>は属性keyで指定した値です。
メッセージの変換内容やルールは、JavaTMのjava.text.MessageFormatのformat(java.lang.Object obj)メソッドの呼び出しと同様です。

サンプル:
<imartj2ee:Message application="sample" key="welcome">
    <imartj2ee:MessageParam value="intra-mart" />
    <imartj2ee:MessageParam value="master" />
</imartj2ee:Message>

メッセージプロパティハンドラとしてDefaultMessagePropertyHandlerを使用し、MessageConfig_sample_ja_JP.propertiesに以下のような記述をしておきます。
（実際にはMessageConfig_sample_ja_JP.propertiesはnative2asciiなどで変換されている必要があります。）

welcome={0}へようこそ、{1}さん！

同様にMessageConfig_sample.propertiesに以下のような記述をしておきます。

welcome=Hello, {1}. Welcome to {0}!

この場合、最初に示したコードはサービスフレームワークで決定されるロケールによって以下のように表示されます。
ロケール | 表示内容
ja_JP | intra-martへようこそ、masterさん！
(指定なし) | Hello, master. Welcome to intra-mart!

また、以下のように明示的にロケールを指定することも可能です。この場合、サービスフレームワークで決定されるロケールは無視され、「intra-martへようこそ、masterさん！」と表示されます。

<imartj2ee:Message application="sample" key="welcome" locale="ja_JP" >
    <imartj2ee:MessageParam value="intra-mart" />
    <imartj2ee:MessageParam value="master" />
</imartj2ee:Message>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
application | true | true | java.lang.String | アプリケーションIDを指定します。
key | true | true | java.lang.String | メッセージのキーを指定します。
locale | false | true | java.lang.String | メッセージを構築するときのロケールを指定します。 省略した場合、サービスフレームワークで決定されるロケールが使用されます。

概要 ライブラリ タグ ヘルプ


MessageParam (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ MessageParam

地域対応されたメッセージに渡すパラメータを表示します。
メッセージ内部の変数をここで指定した値に置き換えるために使用します。

注意事項
本タグを単独で利用することはできません。
intra-mart JavaEEフレームワークタグライブラリのMessageタグの内部タグとして利用します。
サンプル:
Messageタグの例を参照してください。
タグ情報
表示名 | なし
ボディ コンテンツ | tagdependent

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.Object | 変換する値を指定します。

概要 ライブラリ タグ ヘルプ


Param (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ Param

リンク先や遷移先にパラメータを引き渡すために利用します。

本タグを単独で利用することはできません。
intra-mart JavaEEフレームワークタグライブラリのFrameおよびLinkタグの内部タグとして利用します。

注意事項
本タグを単独で利用することはできません。
intra-mart JavaEEフレームワークタグライブラリのFrameおよびLinkタグの内部タグとして利用します。
サンプル:
パラメータの引渡し（Linkタグ利用時）
<imartj2ee:Link application="sample" service="view1">
    <imartj2ee:Param name="param1" value="value1"/>
    リンク１
</imartj2ee:Link>

タグ情報
表示名 | なし
ボディ コンテンツ | tagdependent

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.String | パラメータ値を指定します。
name | true | true | java.lang.String | パラメータ名を指定します。

概要 ライブラリ タグ ヘルプ


Submit (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ Submit

サブミットボタンを表示します。

１つのフォーム内で複数のサブミットボタンを配置したいときなどに利用します。本タグを利用して複数のサブミットボタンを配置した場合、Formタグとは独立してアプリケーションIDとサービスIDを指定することが可能です。

本タグはFormタグの中でしか使用できません。

注意事項
本タグを単独で利用することはできません。
intra-mart JavaEEフレームワークタグライブラリのFormタグの内部タグとして利用します。
本タグを使用する場合、Formタグのname属性は設定必須となります。

サンプル:
<imartj2ee:Form application="sample" service="insert" method="POST" >
    コード：<INPUT type="text" name="code" value="" ><BR>
    <INPUT type="submit" name="normal" value="通常登録"/>
    <imartj2ee:Submit application="sample" service="insert1" value="登録１"/>
    <imartj2ee:Submit application="other" service="insert2" value="登録２"/>
    <imartj2ee:Submit service="insert3" value="登録３"/>
</imartj2ee:Form>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるINPUTタグのid属性に相当します。
application | false | true | java.lang.String | アプリケーションIDを指定します。 省略した場合、FormタグのアプリケーションIDが使用されます。
service | true | true | java.lang.String | サービスIDを指定します。
name | false | true | java.lang.String | HTMLにおけるINPUTタグのname属性に相当します。
submitclass | false | true | java.lang.String | 奨励されていません。class属性を使用してください。 HTMLにおけるINPUTタグのclass属性に相当します。 注意：変換後に属性名が変わります。
class | false | true | java.lang.String | HTMLにおけるINPUTタグのclass属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるINPUTタグのlang属性に相当します。
style | false | true | java.lang.String | HTMLにおけるINPUTタグのstyle属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるAタグのtabindex属性に相当します。
title | false | true | java.lang.String | HTMLにおけるINPUTタグのtitle属性に相当します。
onclick | false | true | java.lang.String | HTMLにおけるINPUTタグのonClick属性に相当します。
ondblclick | false | true | java.lang.String | HTMLにおけるINPUTタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousedown | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるINPUTタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるINPUTタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるINPUTタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるINPUTタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
dir | false | true | java.lang.String | HTMLにおけるINPUTタグのdir属性に相当します。
value | false | true | java.lang.String | HTMLにおけるINPUTタグのvalue属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるINPUTタグのonBlur属性に相当します。 注意：属性名はすべて小文字で記述してください。
onfocus | false | true | java.lang.String | HTMLにおけるINPUTタグのonFocus属性に相当します。 注意：属性名はすべて小文字で記述してください。

概要 ライブラリ タグ ヘルプ


SubmitLink (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ
タグ SubmitLink

Formタグによって指定されたフォームをサブミットするリンクに変換されます。

Formタグによって指定されたフォームの中で行うサブミットをボタンではなくリンクにしたい場合、また、フォームの外部からサブミットを行いたい場合このタグを利用します。

本タグのapplication および service属性は、該当するFormのapplication および service属性に優先されます。

注意事項
application属性、service属性、form属性は必須属性ではありませんが、以下のルールに従う必要があります。

    Formタグの外部にこのタグを指定する場合、form属性の指定は必須。（この場合、form属性で指定されたFormに対してサブミットが行われます）
    Formタグの内部にこのタグを指定する場合、form属性の指定は不可。（この場合、このタグを内包しているFormに対してサブミットが行われます）
    application属性を指定する場合、service属性の指定は必須。
    application属性を省略する場合、service属性の指定は不可。
    application属性を省略してservice属性を指定することは可能。（この場合、application属性は、このタグがサブミットするFormのapplication属性が指定されたものとみなされます）

一度サブミットした後にブラウザのBackボタンなどによって元の画面に戻り、このタグで再度サブミットした場合の遷移先は不定です。ブラウザの履歴によらない、通常の画面遷移によって同じ画面が表示された場合は上記のルールが再び適用されます。

また、通常のHTMLの<A>タグと違い、以下の属性が使用できません。
    charset
    type
    hreflang
    rel
    rev
    target

サンプル:
<imartj2ee:SubmitLink form="user_form"
                      application="other_out"
                      service="view_out1">Outer 1</imartj2ee:SubmitLink><BR>
<imartj2ee:SubmitLink form="user_form"
                      service="view_out2">Outer 2</imartj2ee:SubmitLink><BR>
<imartj2ee:SubmitLink form="user_form">Out 3</imartj2ee:SubmitLink><BR>

        :

<imartj2ee:Form name="user_form" application="sample" service="original">
    <INPUT type="text" name="user" value=""><BR>
    <imartj2ee:SubmitLink application="other_in"
                          service="view_in1">Inner 1</imartj2ee:SubmitLink><BR>
    <imartj2ee:SubmitLink service="view_in2">Inner 2</imartj2ee:SubmitLink><BR>
    <imartj2ee:SubmitLink>Inner 3</imartj2ee:SubmitLink><BR>
</imartj2ee:Form>

この例では６つのボタンが表示されます。それぞれの動作は以下のようになります。
リンク | 動作
Outer 1 | アプリケーションID=other_out、サービスID=view_out1となる時の処理、遷移が行われます。
Outer 2 | アプリケーションID=sample、サービスID=view_out2となる時の処理、遷移が行われます。
Outer 3 | アプリケーションID=sample、サービスID=originalとなる時の処理、遷移が行われます。
Inner 1 | アプリケーションID=other_in、サービスID=view_in1となる時の処理、遷移が行われます。
Inner 2 | アプリケーションID=sample、サービスID=view_in2となる時の処理、遷移が行われます。
Inner 3 | アプリケーションID=sample、サービスID=originalとなる時の処理、遷移が行われます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | false | true | java.lang.String | HTMLにおけるAタグのid属性に相当します。
application | false | true | java.lang.String | アプリケーションIDを指定します。 この項目を省略した場合、所属するFormタグ、またはform属性で指定されたフォームのアプリケーションIDが使用されます。 この項目を指定する場合、application属性も指定する必要があります。
service | false | true | java.lang.String | サービスIDを指定します。 この項目を省略した場合、所属するFormタグ、またはform属性で指定されたフォームのサービスIDが使用されます。 この項目を省略する場合、application属性も省略する必要があります。
accesskey | false | true | java.lang.String | HTMLにおけるAタグのaccesskey属性に相当します。
coords | false | true | java.lang.String | HTMLにおけるAタグのcoords属性に相当します。
dir | false | true | java.lang.String | HTMLにおけるAタグのdir属性に相当します。
lang | false | true | java.lang.String | HTMLにおけるAタグのlang属性に相当します。
class | false | true | java.lang.String | HTMLにおけるAタグのclass属性に相当します。
name | false | true | java.lang.String | HTMLにおけるAタグのname属性に相当します。
onblur | false | true | java.lang.String | HTMLにおけるAタグのonBlur属性に相当します。 注意：属性名はすべて小文字で記述してください。
onclick | false | true | java.lang.String | HTMLにおけるAタグのonClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
ondblclick | false | true | java.lang.String | HTMLにおけるAタグのonDblClick属性に相当します。 注意：属性名はすべて小文字で記述してください。
onfocus | false | true | java.lang.String | HTMLにおけるAタグのonFocus属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeydown | false | true | java.lang.String | HTMLにおけるAタグのonKeyDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeypress | false | true | java.lang.String | HTMLにおけるAタグのonKeyPress属性に相当します。 注意：属性名はすべて小文字で記述してください。
onkeyup | false | true | java.lang.String | HTMLにおけるAタグのonKeyUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousedown | false | true | java.lang.String | HTMLにおけるAタグのonMouseDown属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmousemove | false | true | java.lang.String | HTMLにおけるAタグのonMouseMove属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseout | false | true | java.lang.String | HTMLにおけるAタグのonMouseOut属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseover | false | true | java.lang.String | HTMLにおけるAタグのonMouseOver属性に相当します。 注意：属性名はすべて小文字で記述してください。
onmouseup | false | true | java.lang.String | HTMLにおけるAタグのonMouseUp属性に相当します。 注意：属性名はすべて小文字で記述してください。
shape | false | true | java.lang.String | HTMLにおけるAタグのshape属性に相当します。
style | false | true | java.lang.String | HTMLにおけるAタグのstyle属性に相当します。
tabindex | false | true | java.lang.String | HTMLにおけるAタグのtabindex属性に相当します。
title | false | true | java.lang.String | HTMLにおけるAタグのtitle属性に相当します。
form | false | true | java.lang.String | サブミットするFormタグのフォーム名です。 この属性を省略した場合、所属するFormタグをサブミットするリンクとして扱われます。 この属性を省略する場合、このタグはFormタグの中で指定される必要があります。

概要 ライブラリ タグ ヘルプ


 intra-mart JavaEE フレームワーク タグライブラリ
タグ一覧
imartj2ee:Form
imartj2ee:Frame
imartj2ee:HelperBean
imartj2ee:Link
imartj2ee:Message
imartj2ee:MessageParam
imartj2ee:Param
imartj2ee:Submit
imartj2ee:SubmitLink


intra-mart JavaEE フレームワーク タグライブラリ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart JavaEE フレームワーク タグライブラリ

標準構文:
     <%@ taglib prefix="imartj2ee" uri="http://www.intra-mart.co.jp/taglib/core/framework" %>
XML構文:
     <anyxmlelement xmlns:imartj2ee="http://www.intra-mart.co.jp/taglib/core/framework" />
intra-mart JavaEE フレームワーク タグライブラリ。

intra-mart JavaEE フレームワーク タグライブラリ 仕様

1. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

2. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

3. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。

4. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

5. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
intra-mart JavaEE フレームワーク タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/framework" prefix="imartj2ee" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/framework" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imartj2ee" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/core/framework" prefix="imartj2ee" />

サンプル
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/framework" prefix="imartj2ee" %>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 //EN">
<HTML>

<HEAD>
<TITLE>Hello intra-mart JavaEE framework.</TITLE>
</HEAD>

<BODY>

<CENTER><H2>
<imartj2ee:Form application="sample" service="view1" method="POST">
<INPUT type="text" name="column1" size="20"><BR>
<INPUT type="submit" value=" O K ">
</imartj2ee:Form>
</H2></CENTER>

</BODY>

</HTML>

タグライブラリ情報
表示名 | intra-mart JavaEE フレームワーク タグライブラリ
Version | 1.0
Short Name | imartj2ee
URI | http://www.intra-mart.co.jp/taglib/core/framework

タグ 一覧
Form | HTMLのFORMタグに変換されます。
Frame | HTMLのFRAMEタグに変換されます。
HelperBean | HelperBeanを使用するための初期化を行います。
Link | HTMLのAタグに変換されます。
Message | 地域対応されたメッセージを表示します。
MessageParam | 地域対応されたメッセージに渡すパラメータを表示します。
Param | リンク先や遷移先にパラメータを引き渡すために利用します。
Submit | サブミットボタンを表示します。
SubmitLink | Formタグによって指定されたフォームをサブミットするリンクに変換されます。

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
imartj2ee:Form
imartj2ee:Frame
imartj2ee:HelperBean
imartj2ee:Link
imartj2ee:Message
imartj2ee:MessageParam
imartj2ee:Param
imartj2ee:Submit
imartj2ee:SubmitLink


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart JavaEE フレームワーク タグライブラリ


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart JavaEE フレームワーク タグライブラリ intra-mart JavaEE フレームワーク タグライブラリ。

概要 ライブラリ タグ ヘルプ


accessCtrl (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ accessCtrl

タグに挟まれている範囲内のソースを権限に表示/非表示の制御を行います。
権限の設定は、アクセスコントローラ管理にて設定します。
サンプル:
<imarttag:accessCtrl controller="controller-id">
ログインユーザとアクセスコントローラIDの権限が一致した場合に表示されます。
アクセスコントローラIDに権限がない場合も表示されます。
</imarttag:accessCtrl>
<imarttag:accessCtrl controller="controller-id" defaultShow="false">
ログインユーザとアクセスコントローラIDの権限が一致した場合のみ表示されます。
アクセスコントローラIDに権限がない場合は表示されません。
</imarttag:accessCtrl>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
controller | true | true | java.lang.String | アクセスコントローラID
defaultShow | false | true | java.lang.Stringまたはjava.lang.Boolean | 対象のアクセスコントローラIDに権限が設定されていない場合の動作を設定します。 trueを指定した場合は、表示を行います。 falseを指定した場合は、表示を行いません。 省略した場合は、trueが設定された場合と同じ動作となります。

概要 ライブラリ タグ ヘルプ


calendar (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ calendar

カレンダーモジュールの画面ＨＴＭＬソースを作成します。

年月情報が正しくセットされなかった時の動作は未定義。

group にはデータカテゴリＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式
click_action 属性は必ず“正しく”指定する。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキック
された時にコールされる。その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報(1 - 12)
第6引数 | Number | クリックされた日情報

注意事項
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
メンテナンス画面から『構築』ボタンを利用して設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。
サンプル:
２００２年９月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<imtag:calendar year="2002" month="9" click_action="click_date"/>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
year | true | true | java.lang.String | 作成するカレンダーの年
month | true | true | java.lang.String | 作成するカレンダーの月(1 - 12)
group | true | true | java.lang.String | ログイングループID
calendarId | false | true | java.lang.String | カレンダーID 省略した場合はデフォルトのカレンダID(ログイングループID)となります。
format | false | true | java.lang.String | 使用するフォーマットファイルの指定
click_action | false | true | java.lang.String | 日リンクのクリック時に実行する関数名

概要 ライブラリ タグ ヘルプ


condition (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ condition

タグに挟まれた部分の実行の条件分岐を行います。

タグに挟まれた範囲内の部分の実行を制御します。
属性 validity に対して true 値を指定した場合は内部の処理を実行し、 false 値を指定した場合は内部の処理を無視します。
属性 negative を指定した場合、 属性 validity に対して指定した値を 逆解釈して処理します。

サンプル:
<imtag:condition validity="<%= flg%>">
真値
</imtag:condition>
<imtag:condition validity="<%= flg%>" negative="true" >
偽値
</imtag:condition>
JSPで変数 flg にセットされた真偽値により表示文字を動的選択します。
変数 flg の値が true であった場合は「真値」と表示され、false であった 場合には「偽値」と表示されます。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
validity | true | true | java.lang.String | 有効・無効フラグ
negative | false | true | java.lang.String | 条件反転判定フラグ(指定した場合はtrue,指定しなかった場合はfalse)

概要 ライブラリ タグ ヘルプ


Cal_view (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Cal_view

奨励されていません。calendar タグに置き換えられました。

カレンダーモジュールの画面ＨＴＭＬソースを作成します。

年月情報が正しくセットされなかった時の動作は未定義。

group にはデータカテゴリＩＤを指定（任意）。
無指定の場合は、ログイングループＩＤを自動的に選択する。
format 属性には、以下のキーワードのうちの１つを指定する。
standard | 標準形式
compact | 標準形式の簡易機能版
horizontal | 横１行形式
vertical | 縦１行形式
click_action 属性は必ず“正しく”指定する。
（指定が正しくない場合にはスクリプトエラーとなる。）
click_action 属性に指定されたＣＳＪＳ関数は、日リンクがキック
された時にコールされる。その時、引数が6つ渡される。

引数 | データ型 | 説明
第1引数 | Number | クリックされた年月日情報（1970/1/1からのミリ秒）
第2引数 | String | その日に設定されている名称
第3引数 | boolean | その日が休日かどうか
第4引数 | Number | クリックされた年情報
第5引数 | Number | クリックされた月情報(1 - 12)
第6引数 | Number | クリックされた日情報

注意事項
フレームワークに標準で組み込まれている『振替休日』をチェックするプラグイン関数は、“前日に対して休日設定が２種類以上適合”した場合に“休日”と判定するようにプログラムされています。
振替休日にしたくない場合には、非休日設定などを利用して設定を工夫するようにして下さい。

フレームワークに標準で組み込まれている『春分の日』および『秋分の日』をチェックするプラグイン関数は、予測値を計算するためのものであり、実際の法律で制定された祝日と異なる結果を示す場合があります。
『春分の日』および『秋分の日』に関する正式な日付に関しては、国立天文台が公示する文書を参考に設定するようにして下さい。

また、『春分の日』および『秋分の日』をチェックするプラグインは 1900 年以降 2099 年まで有効であり、この期間に含まれない年においては、正しくチェックできません。
メンテナンス画面から『構築』ボタンを利用して設定した初期データは、『春分の日』に関しては 1960 年から 2058 年まで、『秋分の日』に関しては 1983 年から 2099 年まで有効なデータのみを登録しています。この期間以外の年を指定してカレンダー表示を行うと、『春分の日』または『秋分の日』を正しく表示できない場合があります。
サンプル:
２００２年９月のカレンダーを表示するＨＴＭＬ
<SCRIPT language="JavaScript">
function click_date(nDate, sName, bHoliday, nYear, nMonth, nDay) {
    // クリックされた日付情報をもつ DATE 変数作成
     var dClick = new Date(nDate);
     // 画面表示文字列変数
     var sStr = dClick.toString();
     // 画面表示文字列の作成
     sStr += "　[ " + sName + " ]";
     sStr += "　[ " + bHoliday + " ]";
     sStr += "　[ " + nYear + "/" + nMonth + "/" + nDay + " ]";
     // 画面に表示して引数の確認
     window.alert(sStr);
}
</SCRIPT>
<imtag:Cal_view year="2002" month="9" click_action="click_date"/>

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
year | true | true | java.lang.String | 作成するカレンダーの年
month | true | true | java.lang.String | 作成するカレンダーの月(1 - 12)
group | true | true | java.lang.String | ログイングループID
calendarId | false | true | java.lang.String | カレンダーID 省略した場合はデフォルトのカレンダID(ログイングループID)となります。
format | false | true | java.lang.String | 使用するフォーマットファイルの指定
click_action | false | true | java.lang.String | 日リンクのクリック時に実行する関数名
weekCaption | false | false | java.lang.String | 曜日のキャプション（文字列の配列） 日曜 - 土曜までのキャプションを配列で指定します。 未指定の場合は、デフォルト値{"S","M","T","W","T","F","S"} になります。

概要 ライブラリ タグ ヘルプ


Condition (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Condition

奨励されていません。condition タグに置き換えられました。

タグに挟まれた部分の実行の条件分岐を行います。

タグに挟まれた範囲内の部分の実行を制御します。
属性 validity に対して true 値を指定した場合は内部の処理を実行し、 false 値を指定した場合は内部の処理を無視します。
属性 negative を指定した場合、 属性 validity に対して指定した値を 逆解釈して処理します。

サンプル:
<imtag:Condition validity="<%= flg%>">
真値
</imtag:Condition>
<imtag:Condition validity="<%= flg%>" negative="true" >
偽値
</imtag:Condition>
JSPで変数 flg にセットされた真偽値により表示文字を動的選択します。
変数 flg の値が true であった場合は「真値」と表示され、false であった 場合には「偽値」と表示されます。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
validity | true | true | boolean | 有効・無効フラグ
negative | false | true | boolean | 条件反転判定フラグ(指定した場合はtrue,指定しなかった場合はfalse)

概要 ライブラリ タグ ヘルプ


decision (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ decision

タグに挟まれた部分の実行の条件分岐をおこないます。

タグに挟まれた範囲内の部分の実行を制御します。
属性 value に与えられた値が、属性 case に与えられた値に等しい場合 のみタグに挟まれた範囲内の実行を行います。
サンプル:
<imtag:decision case="OK" value="<%= check%>">
該当
</imtag:decision>
JSPから変数 value により渡された値が case 属性に指定された値(この場合は "OK" という文字列)と等しい場合 該当という文字が表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
case | true | true | java.lang.Boolean | チェック値
value | true | true | java.lang.String | チェック対象の値

概要 ライブラリ タグ ヘルプ


drawer (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ drawer

画像ファイルを作成しHTMLに表示します。

属性 data にjp.co.intra_mart.foundation.drawer.AbstractDrawer を スーパークラスとしたインスタンスを渡すことにより 任意の画像ファイルをHTMLに表示します。

AbstractDrawerの既知のサブクラスとして、以下の５種類のグラフ描画クラスが用意されています。
jp.co.intra_mart.foundation.graph.BarGraphDrawer - 棒グラフ
jp.co.intra_mart.foundation.graph.CircleGraphDrawer - 円グラフ
jp.co.intra_mart.foundation.graph.LineGraphDrawer - 折れ線グラフ
jp.co.intra_mart.foundation.graph.PortFolioDrawer - ポートフォリオ
jp.co.intra_mart.foundation.graph.RadarChartDrawer - レーダーチャート

サンプル:
<%
BarGraphDrawer drawerBar = new BarGraphDrawer(0, 60, 10);
drawerBar.setWidth(300);
drawerBar.setHeight(300);
drawerBar.setCaption(new String[]{"１月", "２月", "３月"});

BarGraphObject objBar = new BarGraphObject(Color.black);
objBar.addData(50);
objBar.addData(10);
objBar.addData(30);
drawerBar.addData(objBar);
%>
<HTML>
<BODY>
<imarttag:drawer data="<%= drawerBar %>" />
</BODY>
</HTML>
属性 data にBarGraphDrawerインスタンスを与え、棒グラフの画像ファイルを表示します。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
data | true | true | java.lang.String | チェック対象の値 (jp.co.intra_mart.foundation.drawer.AbstractDrawerの実装クラス)

概要 ライブラリ タグ ヘルプ


Decision (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Decision

奨励されていません。decision タグに置き換えられました。

タグに挟まれた部分の実行の条件分岐をおこないます。

タグに挟まれた範囲内の部分の実行を制御します。
属性 value に与えられた値が、属性 case に与えられた値に等しい場合 のみタグに挟まれた範囲内の実行を行います。
サンプル:
<imtag:Decision case="OK" value="<%= check%>">
該当
</imtag:Decision>
JSPから変数 value により渡された値が case 属性に指定された値(この場合は "OK" という文字列)と等しい場合 該当という文字が表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
case | true | true | java.lang.Boolean | チェック値
value | true | true | java.lang.String | チェック対象の値

概要 ライブラリ タグ ヘルプ


Drawer (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Drawer

奨励されていません。drawer タグに置き換えられました。

画像ファイルを作成しHTMLに表示します。

属性 data にjp.co.intra_mart.foundation.drawer.AbstractDrawer を スーパークラスとしたインスタンスを渡すことにより 任意の画像ファイルをHTMLに表示します。

AbstractDrawerの既知のサブクラスとして、以下の５種類のグラフ描画クラスが用意されています。
jp.co.intra_mart.foundation.graph.BarGraphDrawer - 棒グラフ
jp.co.intra_mart.foundation.graph.CircleGraphDrawer - 円グラフ
jp.co.intra_mart.foundation.graph.LineGraphDrawer - 折れ線グラフ
jp.co.intra_mart.foundation.graph.PortFolioDrawer - ポートフォリオ
jp.co.intra_mart.foundation.graph.RadarChartDrawer - レーダーチャート

サンプル:
<%
BarGraphDrawer drawerBar = new BarGraphDrawer(0, 60, 10);
drawerBar.setWidth(300);
drawerBar.setHeight(300);
drawerBar.setCaption(new String[]{"１月", "２月", "３月"});

BarGraphObject objBar = new BarGraphObject(Color.black);
objBar.addData(50);
objBar.addData(10);
objBar.addData(30);
drawerBar.addData(objBar);
%>
<HTML>
<BODY>
<imarttag:Drawer data="<%= drawerBar %>" />
</BODY>
</HTML>
属性 data にBarGraphDrawerインスタンスを与え、棒グラフの画像ファイルを表示します。
タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
data | true | true | java.lang.String | チェック対象の値 (jp.co.intra_mart.foundation.drawer.AbstractDrawerの実装クラス)

概要 ライブラリ タグ ヘルプ


floatingCalendar (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ floatingCalendar

ドラッグ＆ドロップで移動可能なカレンダーをフレーム上に表示します

表示されたカレンダーの日付をクリックすると、 引数「element」で指定された要素に、選択された日付の文字列を反映します。 （日付文字列の形式は、引数「format」で指定可能です。）
カレンダーは、「カレンダー表示基準年月」を元に表示します。
（カレンダー表示基準年月は、引数「year」「month」を元に算出されます）

引数「year」および「month」が正しい年月に変換できない場合（未指定時含む）、 カレンダー表示基準年月はシステム日付の「年月」となります。
引数「year」が2桁の場合、「00から49」は 2000年代、「50から99」は 1900年代として処理されます。
引数「year」および「month」にて生成される年月は、1582年10月以降である必要があります。（1582年10月以前の動作は未定義）

引数「addMonth」が未設定の場合、「カレンダー表示基準年月」のカレンダーを表示します。
引数「addMonth」が設定された場合、「カレンダー表示基準年月 + (addMonth)ヶ月」のカレンダーを表示します。

[リロード]ボタン押下時、システム日付の「年月」のカレンダーを表示します。
ただし、引数「element」で指定された要素の値が、日付フォーマット形式に合致している場合、 その要素の値から算出される年月のカレンダーを表示します。

注意事項：
HTMLファイルの <HEAD> タグ内に、必ずデザインスタイルシートタグ（imDesignCss タグ）
および、< SCRIPT src=" < %web_path% > /csjs/im_floating_calendar.js" > を記述してください。
（ < %web_path% > はWeb Server Connectorをインストールしたディレクトリ）

なお、 < %web_path% > /csjs/im_floating_calendar.jsは、URLの関係で呼び出し時のソースパスは変わります。
スクリプト開発モデルの場合は、csjs/im_floating_calendar.js でリンクできます。

引数「position」に「event」を指定し、マウスクリック以外でカレンダーを表示すると、 IEの場合、マウスポインタがフレームから外れていると、カレンダーはフレームの外に表示されます。 NNの場合、フレームの左上（「left：0, top：0」）にカレンダーが表示されます。
サンプル:
●今月のカレンダーを表示するJSP
  ・テキストフィールド「document.floatingCalendarForm.date」にカレンダーで選択した日付を反映します。

<%@ taglib prefix="imtag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<%@ taglib prefix="imdesign"   uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
<HTML>
  <HEAD>
    <imdesign:imartDesignCss />
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <imtag:floatingCalendar element="document.floatingCalendarForm.date">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </imtag:floatingCalendar>
    </FORM>
  </BODY>
</HTML>

●以下の条件を満たしたカレンダーを表示するJSP
  ・2006年10月（＝2006年8月の2ヵ月後）のカレンダーを表示
  ・フレーム左上から、右に100px、下に200pxの位置にカレンダーを表示
  ・日付選択時に反映される文字列のフォーマットが「yyyy/MM/dd (E)」形式
  ・カレンダーID「sample」のカレンダーデータを表示
  ・表示カレンダーのキャプションを「日,月,火,水,木,金,土」で表示
  ・カレンダーの日付をクリックした際にJavascript関数「sampleCallBack」を呼び出す

<%@ taglib prefix="imtag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<%@ taglib prefix="imdesign"   uri="http://www.intra-mart.co.jp/taglib/foundation/imarttag" %>
<HTML>
  <HEAD>
    <imdesign:imartDesignCss />
    <SCRIPT src="csjs/im_floating_calendar.js"></SCRIPT>
    <SCRIPT type="text/javascript">
        function sampleCallBack(element, value){

            alert("sampleCallBack");
            alert("element.value = " + element.value);
            alert("value = " + value);

            element.value = value;
        }
    </SCRIPT>
  </HEAD>
  <BODY>
    <FORM name="floatingCalendarForm">
      <INPUT name="date" type="text" size="20" class="default">

      <!-- カレンダー（フローティング形式）を表示 -->
      <imtag:floatingCalendar
             element="document.floatingCalendarForm.date"
             year         = "2006"
             month        = "8"
             addMonth     = "2"
             position     = "100,200"
             format       = "yyyy/MM/dd (E)"
             calendarId   = "sample"
             weekCaptions = "日,月,火,水,木,金,土"
             callback     = "sampleCallBack">
          <IMG src="sample.gif" border="0" alt="カレンダー用の画像">
      </imtag:floatingCalendar>
    </FORM>
  </BODY>
</HTML>

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
element | true | true | java.lang.String | 選択した日付の文字列表現を反映する要素
year | false | true | java.lang.String | カレンダー表示基準年（デフォルトは システム日付の「年」)
month | false | true | java.lang.String | カレンダー表示基準月 [1-12]（デフォルトは システム日付の「月」)
addMonth | false | true | java.lang.String | カレンダー表示基準年月からの移動量 [月単位で数値指定]（デフォルトは「0」）
calendarId false true java.lang.String カレンダーID（デフォルトは「ログイングループのデフォルトカレンダーID」）
指定されたカレンダーIDが存在しない場合は、デフォルトカレンダーIDのカレンダーを表示します。
position false true java.lang.String カレンダー表示位置 [event | 'left,top']（デフォルトは「event」)
event | マウスカーソルのそばに表示
'left,top' | 指定位置に表示(ピクセル指定)
format false true java.lang.String 日付フォーマット（デフォルトは「yyyy/MM/dd」）
フォーマット指定文字（Format.fromDate()のフォーマット指定文字に準拠）
y | 年
M | 月
d | 日
E | 曜日
weekCaptions false true java.lang.String カレンダーに表示する曜日のキャプション。（デフォルトは、"Su,Mo,Tu,We,Th,Fr,Sa"）
カンマ区切りでキャプションを7つ指定します。（例."日,月,火,水,木,金,土"）
キャプション数が7つではない場合、デフォルト値を表示します。
callback false true java.lang.String カレンダーの日付をクリックした際に呼び出されるJavascript関数名。（デフォルトは、"callBackFloatingCalendar"）
指定された関数には、「引数「element」で指定された要素」、「選択された日付の文字列」が引数として渡されます。 （サンプルコード参照）
isUseElementMonth false true java.lang.String trueが指定された場合、elementで指定された要素の値をカレンダー表示基準年月とします。
（ただし、elementで指定された要素の値が日付フォーマット形式でない場合、falseが指定されたことになります）
falseが指定された場合、引数「year」および「month」を元にカレンダー表示基準年月を算出します。
（デフォルトは「true」）

概要 ライブラリ タグ ヘルプ


imartDateFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ imartDateFormat

タグの指定された場所に、指定された日付データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は yyyy/MM/dd のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の SimpleDateFormat クラスに準拠します。
サンプル:
<imtag:imartDateFormat value="<%=new Date()%>" format="yyyy/MM/dd"/>
このタグの位置に「2002/08/30」という形式で今日の日付情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.util.Date | 挿入する日付データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


imartEvent (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ imartEvent

ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。

このタグは、Client Side Java Script を利用して実現されています。
また、値のブリッジには、ブラウザのクッキーを利用しています。 (クッキーを利用しているので別ウィンドウ同士の通信にも利用できます。)
そのため、クッキーの容量制限を越える量の値をやり取り(監視や受取)は できません。また、このタグではクッキーを保存する際、クッキーの path 属性を 「/」として値を保存しています。セキュリティ的に問題と なる場合には、この機能を利用しないで下さい。

属性 name には、動作する際のイベント名称(キーコード)を指定します。 この name 属性に指定したコードが等しい <imtag:Event>タグ 同士が連携して動作します。
属性 focus には、監視対象となる Client Side Java Script の変数名称を 文字列として指定して下さい。 focus 属性で指定された変数の内容が送信される事になります。
属性 receive には、監視対象値を受け取るための Client Side Java Script の変数名称を文字列として指定して下さい。 ここで指定した変数によって focus で監視している変数の値を受信する事が できます。
属性 init には、動作前にクッキーを初期化する必要がある場合、 その初期値を文字列として指定する事ができます。
属性 onChange には、focus 属性で指定された変数内の値が変化した際に 実行される Client Side Java Script のソースコードを文字列として指定します。
属性 time には、監視のタイミングをミリ秒で指定します。 focus 属性で指定された変数やクッキー内の情報は、タイマー機能を利用して 一定時間毎の監視を行っています。 デフォルトでは 250 ミリ秒毎に監視していますが、連動のタイミングをより リアルタイムにしたい場合は、この値を小さく設定し、ブラウザ処理の負荷が 高く動作が重い場合には、この値を大きく設定する事で任意に調整して下さい。
サンプル:
<FORM name="form_a">
<INPUT type="text" name="a_text">
</FORM>
<imtag:imartEvent name="text_copy" focus="document.form_a.a_text.value"/>
<FORM name="form_b">
<INPUT type="text" name="b_text">
</FORM>
<imtag:imartEvent name="text_copy" receive="document.form_b.b_text.value"/>
画面には二つのテキストフィールドが表示されます。
上のテキストフィールドに文字を記入すると、下のテキストフィールド内に
上のテキストフィールドに入力した内容と同じものが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | カテゴリ名称
focus | false | true | java.lang.String | 監視対象ＣＳＪＳ変数名称
receive | false | true | java.lang.String | 監視変数内データの受け入れＣＳＪＳ変数名称
init | false | true | java.lang.String | クッキー内初期値
onChange | false | true | java.lang.String | データ変更時の実行スクリプト
time | false | true | java.lang.String | クッキー監視間隔時間（ミリ秒）

概要 ライブラリ タグ ヘルプ


imartNumberFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ imartNumberFormat

タグの指定されている個所に指定の数値データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は ###,### のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の DecimalFormat クラスに準拠します。
サンプル:
<imtag:imartNumberFormat value="<%=new Integer(12345)%>" format="###,###"/>
このタグの位置に「12,345」という形式で数値情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.String | 挿入する数値データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


ImartDateFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ ImartDateFormat

奨励されていません。imartDateFormat タグに置き換えられました。

タグの指定された場所に、指定された日付データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は yyyy/MM/dd のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の SimpleDateFormat クラスに準拠します。
サンプル:
<imtag:ImartDateFormat value="<%=new Date()%>" format="yyyy/MM/dd"/>
このタグの位置に「2002/08/30」という形式で今日の日付情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.util.Date | 挿入する日付データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


ImartEvent (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ ImartEvent

奨励されていません。imartEvent タグに置き換えられました。

ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。

このタグは、Client Side Java Script を利用して実現されています。
また、値のブリッジには、ブラウザのクッキーを利用しています。 (クッキーを利用しているので別ウィンドウ同士の通信にも利用できます。)
そのため、クッキーの容量制限を越える量の値をやり取り(監視や受取)は できません。また、このタグではクッキーを保存する際、クッキーの path 属性を 「/」として値を保存しています。セキュリティ的に問題と なる場合には、この機能を利用しないで下さい。

属性 name には、動作する際のイベント名称(キーコード)を指定します。 この name 属性に指定したコードが等しい <imtag:Event>タグ 同士が連携して動作します。
属性 focus には、監視対象となる Client Side Java Script の変数名称を 文字列として指定して下さい。 focus 属性で指定された変数の内容が送信される事になります。
属性 receive には、監視対象値を受け取るための Client Side Java Script の変数名称を文字列として指定して下さい。 ここで指定した変数によって focus で監視している変数の値を受信する事が できます。
属性 init には、動作前にクッキーを初期化する必要がある場合、 その初期値を文字列として指定する事ができます。
属性 onChange には、focus 属性で指定された変数内の値が変化した際に 実行される Client Side Java Script のソースコードを文字列として指定します。
属性 time には、監視のタイミングをミリ秒で指定します。 focus 属性で指定された変数やクッキー内の情報は、タイマー機能を利用して 一定時間毎の監視を行っています。 デフォルトでは 250 ミリ秒毎に監視していますが、連動のタイミングをより リアルタイムにしたい場合は、この値を小さく設定し、ブラウザ処理の負荷が 高く動作が重い場合には、この値を大きく設定する事で任意に調整して下さい。
サンプル:
<FORM name="form_a">
<INPUT type="text" name="a_text">
</FORM>
<imtag:ImartEvent name="text_copy" focus="document.form_a.a_text.value"/>
<FORM name="form_b">
<INPUT type="text" name="b_text">
</FORM>
<imtag:ImartEvent name="text_copy" receive="document.form_b.b_text.value"/>
画面には二つのテキストフィールドが表示されます。
上のテキストフィールドに文字を記入すると、下のテキストフィールド内に
上のテキストフィールドに入力した内容と同じものが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | カテゴリ名称
focus | false | true | java.lang.String | 監視対象ＣＳＪＳ変数名称
receive | false | true | java.lang.String | 監視変数内データの受け入れＣＳＪＳ変数名称
init | false | true | java.lang.String | クッキー内初期値
onChange | false | true | java.lang.String | データ変更時の実行スクリプト
time | false | true | java.lang.String | クッキー監視間隔時間（ミリ秒）

概要 ライブラリ タグ ヘルプ


ImartNumberFormat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ ImartNumberFormat

奨励されていません。imartNumberFormat タグに置き換えられました。

タグの指定されている個所に指定の数値データを文字列として挿入します。

実際には、タグ部分が指定文字列で置換されるように動作します。
フォーマット文字列は ###,### のように指定して下さい。
format 属性指定時の仕様に関しては、Java 2 API ドキュメント の DecimalFormat クラスに準拠します。
サンプル:
<imtag:ImartNumberFormat value="<%=new Integer(12345)%>" format="###,###"/>
このタグの位置に「12,345」という形式で数値情報を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
value | true | true | java.lang.String | 挿入する数値データ
format | true | true | java.lang.String | 表現フォーマット指定文字列

概要 ライブラリ タグ ヘルプ


loginUser (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ loginUser

ログインしているユーザの情報を表示します。
表示できる情報は、ユーザID、ユーザ名、ユーザカナ表記、主所属です。
ユーザ名、ユーザカナ表記、主所属は属性(locale)にロケールを指定することで、指定したロケールで表示することができます。
サンプル:
<imarttag:loginUser style="name"/>
このタグの位置にログインしているユーザのユーザ名を表示します。
<imarttag:loginUser style="code"/>
このタグの位置にログインしているユーザのユーザIDを表示します。
<imarttag:loginUser style="kana"/>
このタグの位置にログインしているユーザのカナ表記を表示します。
<imarttag:loginUser style="attach"/>
このタグの位置にログインしているユーザの主所属を表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
style | true | true | java.lang.String | 表示タイプ。 （"name":ユーザ名） （"code":ユーザID） （"kana":ユーザカナ表記） （"attach":主所属）
locale | false | true | java.lang.String | 表示ロケール。 省略した場合は、ログインしているロケールが設定されます。 この属性は表示する情報が、ユーザ名、ユーザカナ表記、主所属の場合は、有効となります。
date | false | true | java.util.Date | 情報を取得する対象の日付。 省略した場合は、現在の日付が設定されます。 この属性は表示する情報が、ユーザ名、ユーザカナ表記、主所属の場合は、有効となります。
separator | false | true | java.lang.String | 主所属情報の区切り文字。(String) この属性は表示する情報が主所属の場合、有効となります。 省略した場合は、"/"が設定されます。
cache | false | true | java.lang.String | 取得した情報をセッションに保管します。("true" または "false") ２回目以降セッションより情報を取得するようになります。 省略した場合は、"false"が設定されます。

概要 ライブラリ タグ ヘルプ


loop (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ loop

タグに挟まれている範囲内のソースを繰り返し処理します。

繰り返し処理は、属性 count に指定されている回数だけ行います。
(属性 count に、整数字列以外の指定がされた場合の動作は保証外。)
属性 index に、ファンクション・コンテナ内で定義してある変数名称を 指定する事で、何回目の繰り返しかを表す数値を受け取る事が出来ます。
(周回数は、0 から始まる整数値で、周回ごとに 1 ずつインクリメントされます。)
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
サンプル:
<imtag:loop count="5" index="loop_number">
<%=loop_number %> 回目
</imtag:loop>
画面には、以下のように出力されます。
0 回目
1 回目
2 回目
3 回目
4 回目
この場合は、必ず５回の繰り返し処理が行われます。
繰り返し毎に、属性 index で指定したスクリプティング変数に対して、繰り返し回数 - 1 の値が設定されます。
上記例では、タグの内部で参照されている loop_number というスクリプティング変数を通して、動的に回数を表示しています。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
count | true | true | java.lang.String | 繰り返し回数
index | false | true | java.lang.String | 周回番号の通知先変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号
mode | false | true | java.lang.String | ループの方向 大きい要素から小さい要素にループさせる場合は、"down"を設定

概要 ライブラリ タグ ヘルプ


Loop (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Loop

奨励されていません。loop タグに置き換えられました。

タグに挟まれている範囲内のソースを繰り返し処理します。

繰り返し処理は、属性 count に指定されている回数だけ行います。
(属性 count に、整数字列以外の指定がされた場合の動作は保証外。)
属性 index に、ファンクション・コンテナ内で定義してある変数名称を 指定する事で、何回目の繰り返しかを表す数値を受け取る事が出来ます。
(周回数は、0 から始まる整数値で、周回ごとに 1 ずつインクリメントされます。)
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
サンプル:
<imtag:Loop count="5" index="loop_number">
<%=loop_number %> 回目
</imtag:Loop>
画面には、以下のように出力されます。
0 回目
1 回目
2 回目
3 回目
4 回目
この場合は、必ず５回の繰り返し処理が行われます。
繰り返し毎に、属性 index で指定したスクリプティング変数に対して、繰り返し回数 - 1 の値が設定されます。
上記例では、タグの内部で参照されている loop_number というスクリプティング変数を通して、動的に回数を表示しています。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
count | true | true | java.lang.String | 繰り返し回数
index | false | true | java.lang.String | 周回番号の通知先変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号
mode | false | true | java.lang.String | ループの方向 大きい要素から小さい要素にループさせる場合は、"down"を設定

概要 ライブラリ タグ ヘルプ


message (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ message

タグの指定されている個所にメッセージIDで指定された文字列を挿入します。
サンプル:
<imarttag:message id="message-id"/>
<imarttag:message id="message-id" args="sample" />
<imarttag:message id="message-id" locale="ja"/>
<imarttag:message id="message-id" locale="ja" args="sample" />
メッセージIDに紐付けられているメッセージを表示します。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
id | true | true | java.lang.String | メッセージID
locale | false | true | java.lang.String | ロケール 指定したロケールのメッセージを取得します。 省略した場合は、ログインしているロケールが使用されます。
args | false | true | java.lang.Stringまたは java.lang.String[] | メッセージ引数 メッセージに置換用の定義がある場合、この引数の値に置換します。 文字列の配列で指定します。

概要 ライブラリ タグ ヘルプ


repeat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ repeat

タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。

属性 list に指定されたリストに対して、そのリスト内の要素数に 等しい回数だけ繰り返し処理を実行します。
属性 item に指定された変数名に該当するスクリプティング変数に対して、 繰り返し毎にlist から順次取得したデータを代入します。
その際、スクリプティング変数はjava.lang.Object型で入ってくるので、 リストに挿入した型にキャストして使用してください。
ただし、属性 type を指定した場合、その指定したクラスでキャストされているため、キャストする必要はございません。
また、属性 item は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 index に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得した要素番号(int)を代入します。
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 min に動作開始インデックスを指定した場合、それ以前に取得できた値は 無視されて、指定インデックス以降のデータのみを繰り返し処理の対象とします。
属性 min を未指定にした場合のデフォルト動作は、0 を指定した場合と同様です。
属性 max に動作終了インデックスを指定した場合、それ以後に取得できた値は 無視されて、指定インデックスより前のデータのみを繰り返し処理の対象とします。
属性 max を未指定にした場合のデフォルト動作は、list に渡されたオブジェクト 内に格納されているデータのうち、順次取得可能な最終データまでが処理対象となります。
サンプル:
<imtag:repeat list="<%= list%>" item="record" index="idx"> <%= idx%>
<%= ((Map)record).get("content")%>
</imtag:repeat>
または

<imtag:Repeat list="<%= list%>" type="java.util.Map" item="record" index="idx"> <%= idx%>
<%= record.get("content")%>
<imtag:Repeat>
JSPのページで変数 list に挿入されたインスタンスの中身を表示します。
画面上では要素番号とMapインターフェースを実装したクラスの"content"の値がリストの要素数に等しい行数分、表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List または java.lang.Object[] | 繰り返し処理をするjava.util.Listクラス、またはjava.lang.Objectクラスの配列
item | false | true | java.lang.String | 繰り返し処理中の配列内該当要素取得変数名
type | false | true | java.lang.String | 繰り返し処理中の配列内該当要素のキャスト先クラス名
index | false | true | java.lang.String | 繰り返し処理中の配列要素番号取得変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号

概要 ライブラリ タグ ヘルプ


Repeat (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Repeat

奨励されていません。repeat タグに置き換えられました。

タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。

属性 list に指定されたリストに対して、そのリスト内の要素数に 等しい回数だけ繰り返し処理を実行します。
属性 item に指定された変数名に該当するスクリプティング変数に対して、 繰り返し毎にlist から順次取得したデータを代入します。
その際、スクリプティング変数はjava.lang.Object型で入ってくるので、 リストに挿入した型にキャストして使用してください。
また、属性 item は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 index に指定された変数名に該当する変数に対して、繰り返し毎に list から順次取得した要素番号(int)を代入します。
また、属性 index は内部でJAVA変数として扱われますので、JAVA変数の命名 規則に従った名前を指定してください。
属性 min に動作開始インデックスを指定した場合、それ以前に取得できた値は 無視されて、指定インデックス以降のデータのみを繰り返し処理の対象とします。
属性 min を未指定にした場合のデフォルト動作は、0 を指定した場合と同様です。
属性 max に動作終了インデックスを指定した場合、それ以後に取得できた値は 無視されて、指定インデックスより前のデータのみを繰り返し処理の対象とします。
属性 max を未指定にした場合のデフォルト動作は、list に渡されたオブジェクト 内に格納されているデータのうち、順次取得可能な最終データまでが処理対象となります。
サンプル:
<imtag:Repeat list="<%= list%>" item="record" index="idx"> <%= idx%>
<%= (Map)record.get("content")%>
<imtag:Repeat>
JSPのページで変数 list に挿入されたインスタンスの中身を表示します。
画面上では要素番号とMapインターフェースを実装したクラスの"content"の値がリストの要素数に等しい行数分、表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 繰り返し処理をする配列
item | false | true | java.lang.String | 繰り返し処理中の配列内該当要素取得変数名
index | false | true | java.lang.String | 繰り返し処理中の配列要素番号取得変数名
min | false | true | java.lang.String | 繰り返し処理対象の最小要素番号
max | false | true | java.lang.String | 繰り返し処理対象の最大要素番号

概要 ライブラリ タグ ヘルプ


select (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ select

フォーム内にコンボボックス（またはリストボックス）を表示します。

属性 list に対しては、Listインターフェースを実装したクラスのインスタンスにMapインターフェースを実装したクラスのインスタンスを 格納して指定して下さい。
属性 list に指定したインスタンスに格納されているすべてのMapインターフェースを実装したクラスのインスタンス の値が、コンボボックス内の表示要素になります。
属性 list に指定されたインスタンスに格納されているMapインターフェースを実装したクラスのoption_value属性で指定された キー名に格納されている値が、コンボボックス内の各要素(<OPTION> タグ)のvalue 値になり、option_text属性で指定されたキー名に格納されている値がコンボボックス内の要素の 画面上での表示名になります。属性 option_valueのデフォルト値は「option_value」、 属性 option_textのデフォルト値は「option_text」です。 (Mapインターフェースを実装したクラスのインスタンスに格納されているキーおよび値が String 以外の場合の動作は保証外。)
属性 selected には、コンボボックスの初期選択(初期表示)値を指定します。 初期選択状態にする値のキー(属性 list に指定したMapインターフェースを実装したクラスのインスタンスの該当する キー名称)と一致する文字列を含むListインターフェースを実装したクラスのインスタンスを指定することで、初期選択状態にする ことができます。
属性 selected に指定した値に該当するキーが属性 list に指定したMapインターフェースを実装したクラスのインスタンス のキー名称として存在しない場合は、どの値も選択状態にはなりません。 (ただし、コンボボックスの初期選択指定が存在しない場合は、ブラウザの仕様で 自動的にコンボボックス内の先頭の要素が初期選択状態として表示されます。) また、初期選択状態とするキーを同時に複数個指定する場合は、属性 selected に 対して複数のキー文字列を含むListインターフェースを実装したクラスのインスタンスを指定する事で可能になります。 その際、配列内の各要素の値として、初期選択状態にするキー(属性 list に格納した Mapインターフェースを実装したクラスのインスタンスのキー名称)を格納してください。
属性 blank は、コンボボックス内の任意の位置に空データを表示させるための 属性指定になります。
値としてキーワード "top" を指定するとボックス内の先頭位置に空データが表示 され、キーワード "bottom" を指定するとボックス内の最後尾位置に空データが 表示されます。
属性 name に指定した値は <SELECT> タグの name 属性に出力されます。
属性 size に指定した値は <SELECT> タグの size 属性に出力されます。
属性 multipleをしてした場合は、 <SELECT> タグに multiple 属性が付加されます。
属性 attr に指定した値は、指定された文字列のまま <SELECT> タグの属性として 出力されます。(<SELECT> タグの仕様に関しては市販のＨＴＭＬリファレンスを 参照して下さい)。

サンプル:
<%
Vector list = new Vector();
Hashtable ht1 = new Hashtable();
Hashtable ht2 = new Hashtable();

ht1.put("value","test");
ht1.put("text","テスト");
ht2.put("value","test");
ht2.put("text","テスト");

list.add(ht1);
list.add(ht2);
%>

<FORM>
<imtag:select list="<%= list%>" option_value="value" option_text="text" name="test1"/>
<imtag:select list="<%= list%>"
option_value="value" option_text="text"
size="4" name="test2"/>
</FORM>
画面には、コンボボックスとリストボックスが表示されます。
ボックス内には、変数 list に格納されているMapインターフェースを実装したHashtableクラスのインスタンス内のデータが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 表示リスト
name | false | true | java.lang.String | <SELECT>タグのname属性
size | false | true | java.lang.String | <SELECT>タグのsize属性
selected | false | true | java.util.List | 初期選択値の設定
blank | false | true | java.lang.String | キーワードの示す位置へブランクデータを挿入
attr | false | true | java.lang.String | <SELECT>タグ内に指定するその他の属性値
multiple | false | true | java.lang.String | <SELECT>タグのmultiple属性(指定した場合は複数選択可)
option_value | false | true | java.lang.String | <option>タグのvalue値に対応するキー名
option_text | false | true | java.lang.String | <option>タグのtext値に対応するキー名

概要 ライブラリ タグ ヘルプ


Select (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Select

奨励されていません。select タグに置き換えられました。

フォーム内にコンボボックス（またはリストボックス）を表示します。

属性 list に対しては、Listインターフェースを実装したクラスのインスタンスにMapインターフェースを実装したクラスのインスタンスを 格納して指定して下さい。
属性 list に指定したインスタンスに格納されているすべてのMapインターフェースを実装したクラスのインスタンス の値が、コンボボックス内の表示要素になります。
属性 list に指定されたインスタンスに格納されているMapインターフェースを実装したクラスのoption_value属性で指定された キー名に格納されている値が、コンボボックス内の各要素(<OPTION> タグ)のvalue 値になり、option_text属性で指定されたキー名に格納されている値がコンボボックス内の要素の 画面上での表示名になります。属性 option_valueのデフォルト値は「option_value」、 属性 option_textのデフォルト値は「option_text」です。 (Mapインターフェースを実装したクラスのインスタンスに格納されているキーおよび値が String 以外の場合の動作は保証外。)
属性 selected には、コンボボックスの初期選択(初期表示)値を指定します。 初期選択状態にする値のキー(属性 list に指定したMapインターフェースを実装したクラスのインスタンスの該当する キー名称)と一致する文字列を含むListインターフェースを実装したクラスのインスタンスを指定することで、初期選択状態にする ことができます。
属性 selected に指定した値に該当するキーが属性 list に指定したMapインターフェースを実装したクラスのインスタンス のキー名称として存在しない場合は、どの値も選択状態にはなりません。 (ただし、コンボボックスの初期選択指定が存在しない場合は、ブラウザの仕様で 自動的にコンボボックス内の先頭の要素が初期選択状態として表示されます。) また、初期選択状態とするキーを同時に複数個指定する場合は、属性 selected に 対して複数のキー文字列を含むListインターフェースを実装したクラスのインスタンスを指定する事で可能になります。 その際、配列内の各要素の値として、初期選択状態にするキー(属性 list に格納した Mapインターフェースを実装したクラスのインスタンスのキー名称)を格納してください。
属性 blank は、コンボボックス内の任意の位置に空データを表示させるための 属性指定になります。
値としてキーワード "top" を指定するとボックス内の先頭位置に空データが表示 され、キーワード "bottom" を指定するとボックス内の最後尾位置に空データが 表示されます。
属性 name に指定した値は <SELECT> タグの name 属性に出力されます。
属性 size に指定した値は <SELECT> タグの size 属性に出力されます。
属性 multipleをしてした場合は、 <SELECT> タグに multiple 属性が付加されます。
属性 attr に指定した値は、指定された文字列のまま <SELECT> タグの属性として 出力されます。(<SELECT> タグの仕様に関しては市販のＨＴＭＬリファレンスを 参照して下さい)。

サンプル:
<%
Vector list = new Vector();
Hashtable ht1 = new Hashtable();
Hashtable ht2 = new Hashtable();

ht1.put("value","test");
ht1.put("text","テスト");
ht2.put("value","test");
ht2.put("text","テスト");

list.add(ht1);
list.add(ht2);
%>

<FORM>
<imtag:Select list="<%= list%>" option_value="value" option_text="text" name="test1"/>
<imtag:Select list="<%= list%>"
option_value="value" option_text="text"
size="4" name="test2"/>
</FORM>
画面には、コンボボックスとリストボックスが表示されます。
ボックス内には、変数 list に格納されているMapインターフェースを実装したHashtableクラスのインスタンス内のデータが表示されます。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
list | true | true | java.util.List | 表示リスト
name | false | true | java.lang.String | <SELECT>タグのname属性
size | false | true | java.lang.String | <SELECT>タグのsize属性
selected | false | true | java.util.List | 初期選択値の設定
blank | false | true | java.lang.String | キーワードの示す位置へブランクデータを挿入
attr | false | true | java.lang.String | <SELECT>タグ内に指定するその他の属性値
multiple | false | true | java.lang.String | <SELECT>タグのmultiple属性(指定した場合は複数選択可)
option_value | false | true | java.lang.String | <option>タグのvalue値に対応するキー名
option_text | false | true | java.lang.String | <option>タグのtext値に対応するキー名

概要 ライブラリ タグ ヘルプ


 intra-mart 標準 タグライブラリ
タグ一覧
imart:accessCtrl
imart:calendar
imart:condition
imart:decision
imart:drawer
imart:floatingCalendar
imart:imartDateFormat
imart:imartEvent
imart:imartNumberFormat
imart:loginUser
imart:loop
imart:message
imart:repeat
imart:select
imart:tree
imart:Cal_view 非推奨
imart:Condition 非推奨
imart:Decision 非推奨
imart:Drawer 非推奨
imart:ImartDateFormat 非推奨
imart:ImartEvent 非推奨
imart:ImartNumberFormat 非推奨
imart:Loop 非推奨
imart:Repeat 非推奨
imart:Select 非推奨
imart:Tree 非推奨


intra-mart 標準 タグライブラリ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ

標準構文:
     <%@ taglib prefix="imart" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
XML構文:
     <anyxmlelement xmlns:imart="http://www.intra-mart.co.jp/taglib/core/standard" />
intra-mart 標準 タグライブラリ。

intra-mart 標準 タグライブラリ仕様

1. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

2. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

3. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。

4. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

5. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
intra-mart タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/standard" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imtag" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" />

サンプル
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>
<%@ page import="java.util.*" %>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 //EN">
<HTML>

<HEAD>
<TITLE>Hello intra-mart.</TITLE>
</HEAD>

<%! private Date date = new Date(); %>

<BODY bgcolor="whitesmoke">

<CENTER><H2>
<imtag:ImartDateFormat value="<%= date%>" format="yyyy/MM/dd"/>
</H2></CENTER>

</BODY>

</HTML>

タグライブラリ情報
表示名 | intra-mart 標準 タグライブラリ
Version | 1.0
Short Name | imart
URI | http://www.intra-mart.co.jp/taglib/core/standard

タグ 一覧
accessCtrl | タグに挟まれている範囲内のソースを権限に表示/非表示の制御を行います。
calendar | カレンダーモジュールの画面ＨＴＭＬソースを作成します。
condition | タグに挟まれた部分の実行の条件分岐を行います。
decision | タグに挟まれた部分の実行の条件分岐をおこないます。
drawer | 画像ファイルを作成しHTMLに表示します。
floatingCalendar | ドラッグ＆ドロップで移動可能なカレンダーをフレーム上に表示します 表示されたカレンダーの日付をクリックすると、 引数「element」で指定された要素に、選択された日付の文字列を反映します。
imartDateFormat | タグの指定された場所に、指定された日付データを文字列として挿入します。
imartEvent | ページに対して、ブラウザ上で動作するイベント処理型ロジックを追加します。
imartNumberFormat | タグの指定されている個所に指定の数値データを文字列として挿入します。
loginUser | ログインしているユーザの情報を表示します。
loop | タグに挟まれている範囲内のソースを繰り返し処理します。
message | タグの指定されている個所にメッセージIDで指定された文字列を挿入します。
repeat | タグに挟まれた範囲内（ネスト部分）を指定の回数だけ繰り返し処理します。
select | フォーム内にコンボボックス（またはリストボックス）を表示します。
tree | 階層化データをツリー形式でブラウザ上に表示します。
Cal_view | 奨励されていません。calendar タグに置き換えられました。
Condition | 奨励されていません。condition タグに置き換えられました。
Decision | 奨励されていません。decision タグに置き換えられました。
Drawer | 奨励されていません。drawer タグに置き換えられました。
ImartDateFormat | 奨励されていません。imartDateFormat タグに置き換えられました。
ImartEvent | 奨励されていません。imartEvent タグに置き換えられました。
ImartNumberFormat | 奨励されていません。imartNumberFormat タグに置き換えられました。
Loop | 奨励されていません。loop タグに置き換えられました。
Repeat | 奨励されていません。repeat タグに置き換えられました。
Select | 奨励されていません。select タグに置き換えられました。
Tree | 奨励されていません。tree タグに置き換えられました。

概要 ライブラリ タグ ヘルプ


tree (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ tree

階層化データをツリー形式でブラウザ上に表示します。

このツリー表示ＡＰＩでは、以下の３種類のツリー表示部品を提供します。

フォルダー開閉式(初期表示は全閉)
フォルダー開閉式(初期表示は全開)
フォルダー開閉動作無し

属性 clickHome に対しては、ホーム名をクリックした時に実行したいJavaScript関数を指定してください。 無指定の時は、ホーム名のアンカータグがなくなります。
属性 clickFolder に対しては、フォルダ名をクリックした時に実行したいJavaScript関数を指定してください。 フォルダ名クリック時に引数を伴って実行されます。無指定の時は、フォルダ名のアンカータグがなくなります。
属性 clickItem に対しては、ページ名をクリックした時に実行したいJavaScript関数を指定してください。 ページ名クリック時に引数を伴って実行されます。無指定の時は、ページ名のアンカータグがなくなります。
属性 list には、 jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースを実装したクラスのインスタンスを指定してください。
属性 list に指定されてインスタンスが、ツリーの原点となる「ホーム」となります。 「ホーム」が持つ子ノードが、ツリーの「フォルダ」、「ページ」となりツリー表示が行われます。
属性 highlight に対しては、選択項目のハイライトカラーを指定してください。無指定の場合はデフォルト色の自動選択となります。（フォルダ開閉式ツリーのみ有効）

属性 type に対しては、ツリーの種類を指定してください。指定できるツリーの種類は下記の通りです。
無指定の時は、フォルダー開閉式（初期表示は全閉）が自動選択になります。
下記に存在しない type が指定されたときは例外が出力されます。
@DYNAMIC_TREE_OPEN_VIEW | フォルダー開閉式(初期表示は全開)
@DYNAMIC_TREE_CLOSE_VIEW | フォルダー開閉式(初期表示は全閉)
@STATIC_TREE_VIEW | フォルダー開閉動作無し

制約
属性 rootName に対しては「ホーム」の表示名称を指定してください。無指定の時は、「ホーム」の表示名称がなくなります。
属性 rootNote に対しては「ホーム」の説明文を指定してください。ポップアップ文字列として表示されます。無指定の時は、「ホーム」のポップアップ文字列がなくなります。

ツリーの各クリックイベントに対応した Client Side の JavaScript 関数は、必ずツリー呼び出しステートメントよりもファイルの上部に定義(記述)してください。

ツリー開閉式ツリー表示ユニットでは、Dynamic-HTML およびスタイルシート(CSS)技術を利用しています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、これらの技術を無闇に利用すると二重定義などが発生しツリーのイベントが正常に動作しなくなることがあります。

ツリー表示ユニットで利用している Dynamic-HTML(ツリー開閉式のみ) および CSS (ツリー開閉式のみ) の定義名や Client Side JavaScript 関数(ページ内グローバル)および変数(ページ内グローバル) の名称には tree_ というプレフィックスがついています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、Client Side JavaScript の各関数(ページ内グローバル)および各変数(ページ内グローバル)の名称などには、tree_ で開始される名称定義をしないでください。

ツリー表示ユニットでは、Dynamic-HTML(ツリー開閉式のみ) および Client Side JavaScript 技術を利用しています。
これら技術に対応していないブラウザでの利用はしないでください。

開閉式ツリー表示では、Dynamic-HTML 技術を利用して各項目の表示位置を自動的に計算して表示をしています。
ツリー表示呼び出しステートメントを記述してある位置を基準に表示位置を計算しているので、ツリー表示ステートメントはページの最下部に記述するようにしてください。
サンプル:
<%@ page contentType="text/html;charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.page.*" %>
<%@ taglib prefix="imart"
uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<HTML>
<HEAD>
<SCRIPT language="JavaScript">
function onClickHomeFunction(){
window.alert("click home !");
}
function onClickFolderFunction(arg){
window.alert("click folder: " + arg);
}
function onClickPageFunction(arg){
window.alert("click page: " + arg);
}
</SCRIPT>
<TITLE>Sample JSP</TITLE>
</HEAD>
<BODY>

<%
//「ホーム」を作成する
TreeRoot home = new TreeRoot();

//「フォルダ」を作成する
TreeBranch branch1 = new TreeBranch();
//「フォルダ」の表示名を設定する
branch1.setName("フォルダ１");
//「フォルダ」の説明を設定する
branch1.setNote("フォルダ１です");
//「フォルダ」のJavaScriptに渡される引数を設定する
branch1.setArgument("フォルダ１");

TreeBranch branch2 = new TreeBranch();
branch2.setName("フォルダ２");
branch2.setNote("フォルダ２です");
branch2.setArgument("フォルダ２");

//「ページ」を作成する
TreeLeaf leaf1 = new TreeLeaf();
//「ページ」の表示名を設定する
leaf1.setName("ページ１");
//「ページ」の説明を設定する
leaf1.setNote("ページ１です");
//「ページ」のJavaScriptに渡される引数を設定する
leaf1.setArgument("ページ１");

TreeLeaf leaf2 = new TreeLeaf();
leaf2.setName("ページ２");
leaf2.setNote("ページ２です");
leaf2.setArgument("ページ２");

//「ホーム」に「フォルダ」を登録する
home.addChildNode(branch1);
home.addChildNode(branch2);
//「フォルダ」に「ページ」を登録する
branch1.addChildNode(leaf1);
branch1.addChildNode(leaf2);
%>
<!--list属性に home を渡してツリーを表示させる -->
<imart:tree clickHome="onClickHomeFunction"
clickFolder="onClickFolderFunction"
clickItem="onClickPageFunction"
list="<%=home%>"
type="@DYNAMIC_TREE_OPEN_VIEW"
rootName="ホーム"
rootNote="ホームです"/>

</BODY>
</HTML>
プログラムを実行すると画面には下のような実行結果が表示されます。文字指定は「Shift-JIS」で行っています。
「ホーム」のインスタンスを jp.co.intra_mart.foundation.page.TreeRootクラスから作成していますが、このクラスは jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースの実装クラスです。
「フォルダ」のインスタンスは jp.co.intra_mart.foundation.page.TreeBranchクラスから、「ページ」のインスタンスは jp.co.intra_mart.foundation.page.TreeLeaf クラスからそれぞれ作成されています。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
clickHome | false | true | java.lang.String | ホーム名をクリックした時に実行するJavaScript関数名
clickFolder | false | true | java.lang.String | フォルダ名をクリックした時に実行するJavaScript関数名
clickItem | false | true | java.lang.String | ページ名をクリックした時に実行するJavaScript関数名
list | true | true | java.lang.String | ツリービュー表示の「ホーム」 (jp.co.intra_mart.foundation.page.TreeNodeProvider)
highlight | false | true | java.lang.String | 選択状態のハイライトカラー
type | false | true | java.lang.String | ツリービュー表示の種類
rootName | false | true | java.lang.String | ホームの名称
rootNote | false | true | java.lang.String | ホームに関する説明

概要 ライブラリ タグ ヘルプ


Tree (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart 標準 タグライブラリ
タグ Tree

奨励されていません。tree タグに置き換えられました。

階層化データをツリー形式でブラウザ上に表示します。

このツリー表示ＡＰＩでは、以下の３種類のツリー表示部品を提供します。

フォルダー開閉式(初期表示は全閉)
フォルダー開閉式(初期表示は全開)
フォルダー開閉動作無し

属性 clickHome に対しては、ホーム名をクリックした時に実行したいJavaScript関数を指定してください。 無指定の時は、ホーム名のアンカータグがなくなります。
属性 clickFolder に対しては、フォルダ名をクリックした時に実行したいJavaScript関数を指定してください。 フォルダ名クリック時に引数を伴って実行されます。無指定の時は、フォルダ名のアンカータグがなくなります。
属性 clickItem に対しては、ページ名をクリックした時に実行したいJavaScript関数を指定してください。 ページ名クリック時に引数を伴って実行されます。無指定の時は、ページ名のアンカータグがなくなります。
属性 list には、 jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースを実装したクラスのインスタンスを指定してください。
属性 list に指定されてインスタンスが、ツリーの原点となる「ホーム」となります。 「ホーム」が持つ子ノードが、ツリーの「フォルダ」、「ページ」となりツリー表示が行われます。
属性 highlight に対しては、選択項目のハイライトカラーを指定してください。無指定の場合はデフォルト色の自動選択となります。（フォルダ開閉式ツリーのみ有効）

属性 type に対しては、ツリーの種類を指定してください。指定できるツリーの種類は下記の通りです。
無指定の時は、フォルダー開閉式（初期表示は全閉）が自動選択になります。
下記に存在しない type が指定されたときは例外が出力されます。
@DYNAMIC_TREE_OPEN_VIEW | フォルダー開閉式(初期表示は全開)
@DYNAMIC_TREE_CLOSE_VIEW | フォルダー開閉式(初期表示は全閉)
@STATIC_TREE_VIEW | フォルダー開閉動作無し

制約
属性 rootName に対しては「ホーム」の表示名称を指定してください。無指定の時は、「ホーム」の表示名称がなくなります。
属性 rootNote に対しては「ホーム」の説明文を指定してください。ポップアップ文字列として表示されます。無指定の時は、「ホーム」のポップアップ文字列がなくなります。

ツリーの各クリックイベントに対応した Client Side の JavaScript 関数は、必ずツリー呼び出しステートメントよりもファイルの上部に定義(記述)してください。

ツリー開閉式ツリー表示ユニットでは、Dynamic-HTML およびスタイルシート(CSS)技術を利用しています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、これらの技術を無闇に利用すると二重定義などが発生しツリーのイベントが正常に動作しなくなることがあります。

ツリー表示ユニットで利用している Dynamic-HTML(ツリー開閉式のみ) および CSS (ツリー開閉式のみ) の定義名や Client Side JavaScript 関数(ページ内グローバル)および変数(ページ内グローバル) の名称には tree_ というプレフィックスがついています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、Client Side JavaScript の各関数(ページ内グローバル)および各変数(ページ内グローバル)の名称などには、tree_ で開始される名称定義をしないでください。

ツリー表示ユニットでは、Dynamic-HTML(ツリー開閉式のみ) および Client Side JavaScript 技術を利用しています。
これら技術に対応していないブラウザでの利用はしないでください。

開閉式ツリー表示では、Dynamic-HTML 技術を利用して各項目の表示位置を自動的に計算して表示をしています。
ツリー表示呼び出しステートメントを記述してある位置を基準に表示位置を計算しているので、ツリー表示ステートメントはページの最下部に記述するようにしてください。
サンプル:
<%@ page contentType="text/html;charset=Shift_JIS" %>
<%@ page import="jp.co.intra_mart.foundation.page.*" %>
<%@ taglib prefix="imart"
uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<HTML>
<HEAD>
<SCRIPT language="JavaScript">
function onClickHomeFunction(){
window.alert("click home !");
}
function onClickFolderFunction(arg){
window.alert("click folder: " + arg);
}
function onClickPageFunction(arg){
window.alert("click page: " + arg);
}
</SCRIPT>
<TITLE>Sample JSP</TITLE>
</HEAD>
<BODY>

<%
//「ホーム」を作成する
TreeRoot home = new TreeRoot();

//「フォルダ」を作成する
TreeBranch branch1 = new TreeBranch();
//「フォルダ」の表示名を設定する
branch1.setName("フォルダ１");
//「フォルダ」の説明を設定する
branch1.setNote("フォルダ１です");
//「フォルダ」のJavaScriptに渡される引数を設定する
branch1.setArgument("フォルダ１");

TreeBranch branch2 = new TreeBranch();
branch2.setName("フォルダ２");
branch2.setNote("フォルダ２です");
branch2.setArgument("フォルダ２");

//「ページ」を作成する
TreeLeaf leaf1 = new TreeLeaf();
//「ページ」の表示名を設定する
leaf1.setName("ページ１");
//「ページ」の説明を設定する
leaf1.setNote("ページ１です");
//「ページ」のJavaScriptに渡される引数を設定する
leaf1.setArgument("ページ１");

TreeLeaf leaf2 = new TreeLeaf();
leaf2.setName("ページ２");
leaf2.setNote("ページ２です");
leaf2.setArgument("ページ２");

//「ホーム」に「フォルダ」を登録する
home.addChildNode(branch1);
home.addChildNode(branch2);
//「フォルダ」に「ページ」を登録する
branch1.addChildNode(leaf1);
branch1.addChildNode(leaf2);
%>
<!--list属性に home を渡してツリーを表示させる -->
<imart:Tree clickHome="onClickHomeFunction"
clickFolder="onClickFolderFunction"
clickItem="onClickPageFunction"
list="<%=home%>"
type="@DYNAMIC_TREE_OPEN_VIEW"
rootName="ホーム"
rootNote="ホームです"/>

</BODY>
</HTML>
プログラムを実行すると画面には下のような実行結果が表示されます。文字指定は「Shift-JIS」で行っています。
「ホーム」のインスタンスを jp.co.intra_mart.foundation.page.TreeRootクラスから作成していますが、このクラスは jp.co.intra_mart.foundation.page.TreeNodeProviderインターフェースの実装クラスです。
「フォルダ」のインスタンスは jp.co.intra_mart.foundation.page.TreeBranchクラスから、「ページ」のインスタンスは jp.co.intra_mart.foundation.page.TreeLeaf クラスからそれぞれ作成されています。

タグ情報
表示名 | なし
ボディ コンテンツ | empty

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
clickHome | false | true | java.lang.String | ホーム名をクリックした時に実行するJavaScript関数名
clickFolder | false | true | java.lang.String | フォルダ名をクリックした時に実行するJavaScript関数名
clickItem | false | true | java.lang.String | ページ名をクリックした時に実行するJavaScript関数名
list | true | true | java.lang.String | ツリービュー表示の「ホーム」 (jp.co.intra_mart.foundation.page.TreeNodeProvider)
highlight | false | true | java.lang.String | 選択状態のハイライトカラー
type | false | true | java.lang.String | ツリービュー表示の種類
rootName | false | true | java.lang.String | ホームの名称
rootNote | false | true | java.lang.String | ホームに関する説明

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
imart:accessCtrl
imart:calendar
imart:condition
imart:decision
imart:drawer
imart:floatingCalendar
imart:imartDateFormat
imart:imartEvent
imart:imartNumberFormat
imart:loginUser
imart:loop
imart:message
imart:repeat
imart:select
imart:tree
imart:Cal_view 非推奨
imart:Condition 非推奨
imart:Decision 非推奨
imart:Drawer 非推奨
imart:ImartDateFormat 非推奨
imart:ImartEvent 非推奨
imart:ImartNumberFormat 非推奨
imart:Loop 非推奨
imart:Repeat 非推奨
imart:Select 非推奨
imart:Tree 非推奨


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart 標準 タグライブラリ


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart 標準 タグライブラリ intra-mart 標準 タグライブラリ。

概要 ライブラリ タグ ヘルプ


approve (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart ワークフロータグライブラリ
タグ approve

ワークフロー標準の審議画面に遷移するHTMLのフォームタグ（<FORM>）を生成します。

制約
本タグを配置する場所は、HTMLのFORMタグに準じます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | HTMLにおけるFORMタグのname属性
method | false | true | java.lang.String | HTMLにおけるFORMタグのmethod属性
target | false | true | java.lang.String | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | true | java.lang.String | プロセス定義コード(必須)
bpw_version_cd | true | true | java.lang.String | バージョンコード(必須)
bpw_process_cd | true | true | java.lang.String | プロセスコード(必須)
bpw_activity_cd | true | true | java.lang.String | アクティビティコード(必須)
bpw_app_type | false | true | java.lang.String | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | true | java.lang.String | 代理元ユーザコード(任意)
callBackApplicationId | false | true | java.lang.String | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | true | java.lang.String | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | true | java.lang.String | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | true | java.lang.String | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | true | java.lang.String | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | true | java.lang.String | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | true | java.lang.String | 審議時に実行するプログラムパス(任意)
refreshFlg | false | true | java.lang.String | 審議画面を初期化するフラグ(任意) "true"が指定された場合に、審議画面の項目の値を初期化して表示します。
attr | false | true | java.lang.String | <Form>タグに指定する属性(任意)

概要 ライブラリ タグ ヘルプ


draft (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart ワークフロータグライブラリ
タグ draft

ワークフロー標準の申請画面に遷移するHTMLのフォームタグ（<FORM>）を生成します。

制約
本タグを配置する場所は、HTMLのFORMタグに準じます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | HTMLにおけるFORMタグのname属性
method | false | true | java.lang.String | HTMLにおけるFORMタグのmethod属性
target | false | true | java.lang.String | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | true | java.lang.String | プロセス定義コード(必須)
bpw_version_cd | true | true | java.lang.String | バージョンコード(必須)
bpw_activity_cd | true | true | java.lang.String | アクティビティコード(必須)
bpw_app_type | false | true | java.lang.String | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | true | java.lang.String | 代理元ユーザコード(任意)
bpw_parameter_cds | true | true | java.lang.String | ユーザアプリケーションキー(必須)
bpw_draft_appoint_date | false | true | java.lang.String | 起票指定日(任意：未指定時は起票日と同日)
locale | false | true | java.lang.String | ロケール(任意：未指定はデフォルトロケールを使用)
callBackApplicationId | false | true | java.lang.String | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | true | java.lang.String | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | true | java.lang.String | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | true | java.lang.String | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | true | java.lang.String | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | true | java.lang.String | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | true | java.lang.String | 申請処理時に実行するプログラムパス(任意)
refreshFlg | false | true | java.lang.String | 申請画面を初期化するフラグ(任意) "true"が指定された場合に、申請画面の項目の値を初期化して表示します。
attr | false | true | java.lang.String | <Form>タグに指定する属性(任意)

概要 ライブラリ タグ ヘルプ


retry (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart ワークフロータグライブラリ
タグ retry

ワークフロー標準の再申請画面に遷移するHTMLのフォームタグ（<FORM>）を生成します。

制約
本タグを配置する場所は、HTMLのFORMタグに準じます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | HTMLにおけるFORMタグのname属性
method | false | true | java.lang.String | HTMLにおけるFORMタグのmethod属性
target | false | true | java.lang.String | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | true | java.lang.String | プロセス定義コード(必須)
bpw_version_cd | true | true | java.lang.String | バージョンコード(必須)
bpw_process_cd | true | true | java.lang.String | プロセスコード(必須)
bpw_activity_cd | true | true | java.lang.String | アクティビティコード(必須)
bpw_app_type | false | true | java.lang.String | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | true | java.lang.String | 代理元ユーザコード(任意)
bpw_parameter_cds | true | true | java.lang.String | ユーザアプリケーションキー(必須)
locale | false | true | java.lang.String | ロケール(任意：未指定はデフォルトロケールを使用)
callBackApplicationId | false | true | java.lang.String | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | true | java.lang.String | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | true | java.lang.String | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | true | java.lang.String | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | true | java.lang.String | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | true | java.lang.String | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | true | java.lang.String | 再申請処理時に実行するプログラムパス(任意)
refreshFlg | false | true | java.lang.String | 再申請画面を初期化するフラグ(任意) "true"が指定された場合に、再申請画面の項目の値を初期化して表示します。
attr | false | true | java.lang.String | <Form>タグに指定する属性(任意)

概要 ライブラリ タグ ヘルプ


subDraft (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart ワークフロータグライブラリ
タグ subDraft

ワークフロー標準のサブプロセス申請画面に遷移するHTMLのフォームタグ（<FORM>）を生成します。

制約
本タグを配置する場所は、HTMLのFORMタグに準じます。

タグ情報
表示名 | なし
ボディ コンテンツ | JSP

属性一覧
名称 | 必須 | 実行時評価 | 型 | 説明
name | true | true | java.lang.String | HTMLにおけるFORMタグのname属性
method | false | true | java.lang.String | HTMLにおけるFORMタグのmethod属性
target | false | true | java.lang.String | HTMLにおけるFORMタグのtarget属性
bpw_process_def_cd | true | true | java.lang.String | プロセス定義コード(必須)
bpw_version_cd | true | true | java.lang.String | バージョンコード(必須)
bpw_process_cd | true | true | java.lang.String | プロセスコード(必須)
bpw_activity_cd | true | true | java.lang.String | アクティビティコード(必須)
bpw_app_type | false | true | java.lang.String | 代理フラグ(任意) 本人処理："org" 代理処理："agt"
bpw_agt_user_cd | false | true | java.lang.String | 代理元ユーザコード(任意)
bpw_parameter_cds | true | true | java.lang.String | ユーザアプリケーションキー(必須)
callBackApplicationId | false | true | java.lang.String | 遷移画面からの戻り先のアプリケーションID(任意)
callBackServiceId | false | true | java.lang.String | 遷移画面からの戻り先のサービスID(任意)
callBackContentsPath | false | true | java.lang.String | 遷移画面からの戻り先のプレゼンテーションページ(Resource Service)のパス(任意)
successPageApplicationId | false | true | java.lang.String | 処理成功時遷移先のアプリケーションID(任意)
successPageServiceId | false | true | java.lang.String | 処理成功時遷移先のサービスID(任意)
successPageContentsPath | false | true | java.lang.String | 処理成功時遷移先のプレゼンテーションページ(Resource Service)のパス(任意)
programPath | false | true | java.lang.String | サブプロセスの申請時に実行するプログラムパス(任意)
refreshFlg | false | true | java.lang.String | サブプロセスの申請画面を初期化するフラグ(任意) "true"が指定された場合に、サブプロセスの申請画面の項目の値を初期化して表示します。
attr | false | true | java.lang.String | <Form>タグに指定する属性(任意)

概要 ライブラリ タグ ヘルプ


 intra-mart ワークフロータグライブラリ
タグ一覧
workflow:approve
workflow:draft
workflow:retry
workflow:subDraft


intra-mart ワークフロータグライブラリ (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

intra-mart ワークフロータグライブラリ

標準構文:
     <%@ taglib prefix="workflow" uri="http://www.intra-mart.co.jp/taglib/bpw/workflow" %>
XML構文:
     <anyxmlelement xmlns:workflow="http://www.intra-mart.co.jp/taglib/bpw/workflow" />
intra-mart ワークフロー タグライブラリ。

intra-mart ワークフロータグライブラリ仕様

1. タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。

2. タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。

3. タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合には、当該JSP変数の型が属性値に渡されます。

4. タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。

5. JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。
(ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法
intra-mart ワークフロー タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要があります。

<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/bpw/workflow" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/bpw/workflow" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加される XML 名前空間識別子を指定するもので、 任意の名前を付けても構いません。(以下、この API リストでは、 prefix 属性を "imarttag" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/bpw/workflow" prefix="imarttag" />

タグライブラリ情報
表示名 | intra-mart ワークフロータグライブラリ
Version | 1.0
Short Name | workflow
URI | http://www.intra-mart.co.jp/taglib/bpw/workflow

タグ 一覧
approve | ワークフロー標準の審議画面に遷移するHTMLのフォームタグ（ ）を生成します。
draft | ワークフロー標準の申請画面に遷移するHTMLのフォームタグ（）を生成します。
retry | ワークフロー標準の再申請画面に遷移するHTMLのフォームタグ（）を生成します。
subDraft | ワークフロー標準のサブプロセス申請画面に遷移するHTMLのフォームタグ（）を生成します。

概要 ライブラリ タグ ヘルプ


 すべてのタグおよび関数
workflow:approve
workflow:draft
workflow:retry
workflow:subDraft


概要 (Tag Library Documentation Generator - Generated Documentation)

タグライブラリ ドキュメント
すべてのタグおよび関数

タグライブラリ
intra-mart ワークフロータグライブラリ


概要 (Tag Library Documentation Generator - Generated Documentation)

概要 ライブラリ タグ ヘルプ
フレームあり フレームなし

タグライブラリ ドキュメント

タグライブラリ
intra-mart ワークフロータグライブラリ intra-mart ワークフロー タグライブラリ。

概要 ライブラリ タグ ヘルプ


インタフェース jp.co.intra_mart.foundation.portal.common.PortalConstant の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.common.PortalConstant の使用

jp.co.intra_mart.foundation.portal.common.PortalConstant はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.portal.common (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.common
インタフェース
PortalConstant


jp.co.intra_mart.foundation.portal.common (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common

インタフェースの概要
PortalConstant

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.portal.common クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.common.PortalConstant
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.portal.common の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.common の使用

jp.co.intra_mart.foundation.portal.common はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortalConstant (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.common
インタフェース PortalConstant

public interface PortalConstant

フィールドの概要
static String PORTAL_EXCEPTION_KEY
例外情報の格納キー

フィールドの詳細

PORTAL_EXCEPTION_KEY

public static final String PORTAL_EXCEPTION_KEY
例外情報の格納キー

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived の使用

NewArrived を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.general_purpose_portlet での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet のメソッド
static NewArrived[] NewArrivedManager.getNewArrivedList(String config)
汎用新着情報の一覧を取得します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrived の使用

NewArrived を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
NewArrived[] | PageBaseCallProvider.getNewArrivedList(String user, String group) 汎用新着情報を取得
NewArrived[] | NewArrivedProvider.getNewArrivedList(String user, String group) 新着情報を一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


NewArrived (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
クラス NewArrived

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived
すべての実装インタフェース:
Serializable
public class NewArrived
extends Object
implements Serializable

汎用新着情報を保持します。

導入されたバージョン:
5.1
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
NewArrived()
メソッドの概要
String | getCategory() 新着情報のカテゴリ名を取得します。
String | getContents() 新着情報の内容を取得します。
String | getDate() 日付を取得します。
String | getUrl() リンク先のURLを取得します。
boolean | isPopup() リンクへ参照時にポップアップを呼び出すかどうかを取得します。
void | setCategory(String category) 新着情報のカテゴリ名を設定します。
void | setContents(String contents) 新着情報の内容を設定します。
void | setDate(String date) 日付を設定します。
void | setPopup(boolean popup) リンクへ参照時にポップアップを呼び出すかどうかを設定します。
void | setUrl(String url) リンク先のURLを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrived

public NewArrived()
メソッドの詳細

getCategory

public String getCategory()
新着情報のカテゴリ名を取得します。

戻り値:
新着カテゴリ名

setCategory

public void setCategory(String category)
新着情報のカテゴリ名を設定します。 カテゴリ名に null が設定された場合は、空文字に変換します。

パラメータ:
category - 新着カテゴリ名

getContents

public String getContents()
新着情報の内容を取得します。

戻り値:
新着情報の内容

setContents

public void setContents(String contents)
新着情報の内容を設定します。 内容に null が設定された場合は、空文字に変換します。

パラメータ:
contents - 新着情報の内容

getUrl

public String getUrl()
リンク先のURLを取得します。

戻り値:
リンク先のURL

setUrl

public void setUrl(String url)
リンク先のURLを設定します。 URLに null が設定された場合は、空文字に変換します。

パラメータ:
url - リンク先のURL

isPopup

public boolean isPopup()
リンクへ参照時にポップアップを呼び出すかどうかを取得します。

戻り値:
ポップアップを呼び出す場合は true、それ以外は falseを返します。

setPopup

public void setPopup(boolean popup)
リンクへ参照時にポップアップを呼び出すかどうかを設定します。

パラメータ:
popup - ポップアップするかどうか

getDate

public String getDate()
日付を取得します。

戻り値:
日付

setDate

public void setDate(String date)
日付を設定します。 日付に null が設定された場合は、空文字に変換します。

パラメータ:
date - 日付
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
クラス
NewArrived


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

クラスの概要
NewArrived 汎用新着情報を保持します。


jp.co.intra_mart.foundation.portal.general_purpose_portlet.model クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.model を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.general_purpose_portlet により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.model のクラス
NewArrived
汎用新着情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider の使用

NewArrivedProvider を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrivedProvider の使用

NewArrivedProvider を実装している jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
 class PageBaseCallProvider
NewArrivedProvider インターフェースの実装です。

NewArrivedProvider を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
NewArrivedProvider[] | NewArrivedProviderConfigImpl.getProviders() プロバイダの一覧を取得します。
NewArrivedProvider[] | NewArrivedProviderConfig.getProviders() プロバイダの一覧を取得します。

NewArrivedProvider 型のパラメータを持つ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のコンストラクタ
NewArrivedProviderConfigImpl(boolean sort, NewArrivedProvider[] newArrivedProvider)
コンストラクタ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig の使用

NewArrivedProviderConfig を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrivedProviderConfig の使用

NewArrivedProviderConfig を実装している jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
 class NewArrivedProviderConfigImpl
汎用新着ポートレットに関するコンフィグ情報を格納する実装クラスです。

NewArrivedProviderConfig を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
 NewArrivedProviderConfig NewArrivedProviderHandler.getProviderConfig(String configPath)
指定された設定ファイルに定義されたプロバイダのインスタンスの一覧を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler の使用

NewArrivedProviderHandler を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider での NewArrivedProviderHandler の使用

NewArrivedProviderHandler を返す jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のメソッド
static NewArrivedProviderHandler NewArrivedProviderHandler.getInsntace()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


NewArrivedProvider (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース NewArrivedProvider

既知の実装クラスの一覧:
PageBaseCallProvider
public interface NewArrivedProvider

汎用新着情報のプロバイダのインターフェースです。

導入されたバージョン:
5.1
バージョン:
1.0

メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) 新着情報を一覧を取得します。
void | init(Properties properties) 初期化を行います。

メソッドの詳細

init

public void init(Properties properties)
初期化を行います。

パラメータ:
properties - 初期化パラメータ

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
                               throws jp.co.intra_mart.framework.system.exception.ApplicationException
新着情報を一覧を取得します。
新着情報が存在しない場合は、空の配列を返します。

パラメータ:
user - ログインユーザコード
group - ログイングループID
戻り値:
新着情報の一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - 新着情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NewArrivedProviderConfig (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース NewArrivedProviderConfig

既知の実装クラスの一覧:
NewArrivedProviderConfigImpl
public interface NewArrivedProviderConfig

汎用新着ポートレットに関するコンフィグ情報を格納します。

導入されたバージョン:
5.1

メソッドの概要
NewArrivedProvider[] | getProviders() プロバイダの一覧を取得します。
boolean | isSort() カテゴリによるソートを行うかどうか

メソッドの詳細

isSort

public boolean isSort()
カテゴリによるソートを行うかどうか

戻り値:
ソートを行う場合 true、それ以外の場合 false

getProviders

public NewArrivedProvider[] getProviders()
                                  throws jp.co.intra_mart.framework.system.exception.ApplicationException
プロバイダの一覧を取得します。

戻り値:
プロバイダの一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NewArrivedProviderConfigImpl (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
クラス NewArrivedProviderConfigImpl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl
すべての実装インタフェース:
NewArrivedProviderConfig
public class NewArrivedProviderConfigImpl
extends Object
implements NewArrivedProviderConfig

汎用新着ポートレットに関するコンフィグ情報を格納する実装クラスです。

導入されたバージョン:
5.1

コンストラクタの概要
NewArrivedProviderConfigImpl(boolean sort, NewArrivedProvider[] newArrivedProvider)
コンストラクタ
メソッドの概要
NewArrivedProvider[] | getProviders() プロバイダの一覧を取得します。
boolean | isSort() カテゴリによるソートを行うかどうか
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrivedProviderConfigImpl

public NewArrivedProviderConfigImpl(boolean sort,
                                    NewArrivedProvider[] newArrivedProvider)
コンストラクタ

パラメータ:
sort - ソート
newArrivedProvider - 汎用新着プロバイダー
メソッドの詳細

isSort

public boolean isSort()
カテゴリによるソートを行うかどうか

定義:
インタフェース NewArrivedProviderConfig 内の isSort
戻り値:
ソートを行う場合 true、それ以外の場合 false

getProviders

public NewArrivedProvider[] getProviders()
                                  throws jp.co.intra_mart.framework.system.exception.ApplicationException
プロバイダの一覧を取得します。

定義:
インタフェース NewArrivedProviderConfig 内の getProviders
戻り値:
プロバイダの一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NewArrivedProviderHandler (im_portal 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
クラス NewArrivedProviderHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler
public class NewArrivedProviderHandler
extends Object

新着一覧を取得するプロバイダを取扱います。

導入されたバージョン:
5.1

メソッドの概要
static NewArrivedProviderHandler | getInsntace() インスタンスを取得します。
NewArrivedProviderConfig | getProviderConfig(String configPath) 指定された設定ファイルに定義されたプロバイダのインスタンスの一覧を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getInsntace

public static NewArrivedProviderHandler getInsntace()
インスタンスを取得します。

戻り値:
NewArrivedProviderHandler のインスタンス

getProviderConfig

public NewArrivedProviderConfig getProviderConfig(String configPath)
                                           throws jp.co.intra_mart.framework.system.exception.ApplicationException
指定された設定ファイルに定義されたプロバイダのインスタンスの一覧を返します。

パラメータ:
configPath - 設定ファイルパス
戻り値:
プロバイダのインスタンスの一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
インタフェース
NewArrivedProvider
NewArrivedProviderConfig
クラス
NewArrivedProviderConfigImpl
NewArrivedProviderHandler
PageBaseCallProvider


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

インタフェースの概要
NewArrivedProvider | 汎用新着情報のプロバイダのインターフェースです。
NewArrivedProviderConfig | 汎用新着ポートレットに関するコンフィグ情報を格納します。

クラスの概要
NewArrivedProviderConfigImpl | 汎用新着ポートレットに関するコンフィグ情報を格納する実装クラスです。
NewArrivedProviderHandler | 新着一覧を取得するプロバイダを取扱います。
PageBaseCallProvider | NewArrivedProvider インターフェースの実装です。


jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider
  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider を使用しているパッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider により使用される jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider のクラス
NewArrivedProvider
汎用新着情報のプロバイダのインターフェースです。
NewArrivedProviderConfig
汎用新着ポートレットに関するコンフィグ情報を格納します。
NewArrivedProviderHandler
新着一覧を取得するプロバイダを取扱います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PageBaseCallProvider (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
クラス PageBaseCallProvider

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
すべての実装インタフェース:
NewArrivedProvider
public class PageBaseCallProvider
extends Object
implements NewArrivedProvider

NewArrivedProvider インターフェースの実装です。

このクラスは、initメソッドで設定される Properties オブジェクトから 定数 PAGE_PATH をキー名として特定されるページベースプログラムから、新着情報の一覧を取得します。
ページベースプログラムにパラメータを渡したい場合は、initメソッドで設定される Properties オブジェクトにページベースプログラムの情報に加えて、任意のキーでパラメータを設定して下さい。

このクラスから呼び出されるページベースプログラムは、返却値として配列を返す必要があります。 配列の要素は、以下のプロパティを格納したオブジェクトです。

新着情報オブジェクト
プロパティ名 | JavaScriptの型 | 設定内容
category | String | 新着情報のカテゴリ名
contents | String | 新着情報の内容
url | String | 新着情報の詳細情報へ遷移するURL
popup | Boolean | 詳細情報へ遷移する際にポップアップするかどうかのフラグ
date | String | 新着情報の配信日付

導入されたバージョン:
5.1
バージョン:
1.0

フィールドの概要
static String PAGE_PATH
ページベースプログラム名を特定するキー
コンストラクタの概要
PageBaseCallProvider()
メソッドの概要
NewArrived[] | getNewArrivedList(String user, String group) 汎用新着情報を取得
void | init(Properties properties) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_PATH

public static final String PAGE_PATH
ページベースプログラム名を特定するキー

関連項目:
定数フィールド値
コンストラクタの詳細

PageBaseCallProvider

public PageBaseCallProvider()
メソッドの詳細

getNewArrivedList

public NewArrived[] getNewArrivedList(String user,
                                      String group)
                               throws jp.co.intra_mart.framework.system.exception.ApplicationException
汎用新着情報を取得

定義:
インタフェース NewArrivedProvider 内の getNewArrivedList
パラメータ:
user - ユーザコード
group - グループコード
戻り値:
汎用新着情報一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - 新着情報の取得に失敗した場合

init

public void init(Properties properties)
初期化を行います。

定義:
インタフェース NewArrivedProvider 内の init
パラメータ:
properties - 初期化パラメータ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


NewArrivedManager (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.general_purpose_portlet
クラス NewArrivedManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager
public class NewArrivedManager
extends Object

汎用新着情報の取得処理を行うクラスです。
汎用新着情報の取得を行う際は、このクラスを利用します。

導入されたバージョン:
5.1
バージョン:
1.0

コンストラクタの概要
NewArrivedManager()
メソッドの概要
static NewArrived[] getNewArrivedList(String config)
汎用新着情報の一覧を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NewArrivedManager

public NewArrivedManager()
メソッドの詳細

getNewArrivedList

public static NewArrived[] getNewArrivedList(String config)
                                      throws jp.co.intra_mart.framework.system.exception.ApplicationException
汎用新着情報の一覧を取得します。
引数の設定ファイルは、ストレージサービスからの相対パスで指定します。
新着情報が存在しなかった場合は、空の配列を返します。

パラメータ:
config - 設定ファイル
戻り値:
新着情報の一覧
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - 新着情報の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.general_purpose_portlet (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.general_purpose_portlet
クラス
NewArrivedManager


jp.co.intra_mart.foundation.portal.general_purpose_portlet (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet

クラスの概要
NewArrivedManager 汎用新着情報の取得処理を行うクラスです。


jp.co.intra_mart.foundation.portal.general_purpose_portlet クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager


パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.general_purpose_portlet の使用

jp.co.intra_mart.foundation.portal.general_purpose_portlet はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener の使用

jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener の使用

jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener の使用

jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener の使用

jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


AccountChangedPortalAccessListener (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.listener
クラス AccountChangedPortalAccessListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener
すべての実装インタフェース:
jp.co.intra_mart.foundation.security.account.AccountChangedListener
public class AccountChangedPortalAccessListener
extends Object
implements jp.co.intra_mart.foundation.security.account.AccountChangedListener

アカウント情報書き込み時（書き込み直後）のリスナを定義します。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
AccountChangedPortalAccessListener()
メソッドの概要
void | accountAdded(String groupId, jp.co.intra_mart.foundation.security.account.Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | accountDeleted(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | accountRoleAdded(String groupId, String userId, jp.co.intra_mart.foundation.security.account.AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます
void | accountRoleDeleted(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | accountRoleUpdated(String groupId, String userId, jp.co.intra_mart.foundation.security.account.AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます
void | accountUpdated(String groupId, jp.co.intra_mart.foundation.security.account.Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | init(Map params) アカウントリスナーの初期化。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AccountChangedPortalAccessListener

public AccountChangedPortalAccessListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

accountAdded

public void accountAdded(String groupId,
                         jp.co.intra_mart.foundation.security.account.Account account)
                  throws jp.co.intra_mart.foundation.exception.ChangedListenerException
アカウント情報をデータストアに作成した直後にコールされます。

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の accountAdded
パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountDeleted

public void accountDeleted(String groupId,
                           String userId)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
アカウント情報をデータストアから削除した直後にコールされます。

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の accountDeleted
パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountUpdated

public void accountUpdated(String groupId,
                           jp.co.intra_mart.foundation.security.account.Account account)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
アカウント情報をデータストアに更新した直後にコールされます。

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の accountUpdated
パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleAdded

public void accountRoleAdded(String groupId,
                             String userId,
                             jp.co.intra_mart.foundation.security.account.AccountRole accountRole)
                      throws jp.co.intra_mart.foundation.exception.ChangedListenerException
アカウントロール情報をデータストアに作成した直後にコールされます

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の accountRoleAdded
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleDeleted

public void accountRoleDeleted(String groupId,
                               String userId,
                               String roleId)
                        throws jp.co.intra_mart.foundation.exception.ChangedListenerException
アカウントロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の accountRoleDeleted
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

accountRoleUpdated

public void accountRoleUpdated(String groupId,
                               String userId,
                               jp.co.intra_mart.foundation.security.account.AccountRole accountRole)
                        throws jp.co.intra_mart.foundation.exception.ChangedListenerException
アカウントロール情報をデータストアに更新した直後にコールされます

定義:
インタフェース jp.co.intra_mart.foundation.security.account.AccountChangedListener 内の accountRoleUpdated
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyChangedPortalAccessListener (im_portal 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.listener
クラス CompanyChangedPortalAccessListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener
すべての実装インタフェース:
jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener
public class CompanyChangedPortalAccessListener
extends Object
implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener

会社・組織に関する情報の変更時のリスナーです。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
CompanyChangedPortalAccessListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory category) 分類区分情報がデータストアから削除された後に呼び出されます。
void | categoryDetailSet(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory category) 分類区分情報がデータストアに登録された後に呼び出されます。
void | companyAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company company) 会社情報がデータストアに登録された後に呼び出されます
void | companyDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company company) 会社情報がデータストアから削除された後に呼び出されます
void | departmentAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department department) 組織情報がデータストアに登録された後に呼び出されます
void | departmentDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department department) 組織情報がデータストアから削除された後に呼び出されます
void | departmentJoined(String groupId, String company, String parentDepartment, String department, String version) 組織構成がデータストアに登録された後に呼び出されます
void | departmentLeft(String groupId, String company, String department, String version) 組織構成からの組織の離脱がデータストアに反映された後に呼び出されます
void | departmentMoved(String groupId, String company, String parentDepartment, String department, String version) 組織構成からの組織の移動がデータストアに反映された後に呼び出されます
void | departmentUpdated(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department department) 組織情報がデータストアから更新された後に呼び出されます
void | init(Map params) 会社リスナーの初期化を行います。
void | mainRemoved(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain main) 主所属情報がデータストアから削除された後に呼び出されます。
void | mainSet(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain main) 主所属情報がデータストアに登録された後に呼び出されます。
void | memberDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach attach) 組織からの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach attach) 組織への人員の割当がデータストアに登録された後に呼び出されます。
void | postAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost post) 役職情報がデータストアに登録された後に呼び出されます 。
void | postDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost post) 役職情報がデータストアから削除された後に呼び出されます 。
void | postUpdated(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost post) 役職情報がデータストアに更新された後に呼び出されます 。
void | setUserId(String userId) ログインユーザIDを設定します。
void | versionAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion version) 会社構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String company, String srcVersion, String destVersion, jp.co.intra_mart.foundation.datastore.common.structure.Term term) 登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion version) 会社構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion version) 会社構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CompanyChangedPortalAccessListener

public CompanyChangedPortalAccessListener()
メソッドの詳細

init

public void init(Map params)
会社リスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUserId

public void setUserId(String userId)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の setUserId
パラメータ:
userId - ログインユーザID

companyAdded

public void companyAdded(String groupId,
                         jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company company)
                  throws jp.co.intra_mart.foundation.exception.ChangedListenerException
会社情報がデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の companyAdded
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

companyDeleted

public void companyDeleted(String groupId,
                           jp.co.intra_mart.foundation.datastore.application.domain.company.company.Company company)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
会社情報がデータストアから削除された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の companyDeleted
パラメータ:
groupId - ログイングループID
company - 会社情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

departmentAdded

public void departmentAdded(String groupId,
                            jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department department)
                     throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織情報がデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の departmentAdded
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

departmentUpdated

public void departmentUpdated(String groupId,
                              jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department department)
                       throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織情報がデータストアから更新された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の departmentUpdated
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

departmentDeleted

public void departmentDeleted(String groupId,
                              jp.co.intra_mart.foundation.datastore.application.domain.company.department.Department department)
                       throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織情報がデータストアから削除された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の departmentDeleted
パラメータ:
groupId - ログイングループID
department - 組織情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

departmentJoined

public void departmentJoined(String groupId,
                             String company,
                             String parentDepartment,
                             String department,
                             String version)
                      throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織構成がデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の departmentJoined
パラメータ:
groupId - ログイングループID
company - 会社コード
parentDepartment - 新規登録する組織の上位となる組織の組織コード（または会社の会社コード）
department - 組織情報（会社に該当する組織は指定できない）
version - バージョンコード
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

departmentMoved

public void departmentMoved(String groupId,
                            String company,
                            String parentDepartment,
                            String department,
                            String version)
                     throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織構成からの組織の移動がデータストアに反映された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の departmentMoved
パラメータ:
groupId - ログイングループID
company - 上位組織と移動対象の組織が所属する会社の会社コード
parentDepartment - 上位組織の組織コード（または会社の会社コード）
department - 移動する組織の組織コード（会社に該当する組織は指定できない）
version - バージョンコード
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

departmentLeft

public void departmentLeft(String groupId,
                           String company,
                           String department,
                           String version)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の departmentLeft
パラメータ:
groupId - ログイングループID
company - 会社コード
department - 離脱させる組織の組織コード（会社に該当する組織は指定できない））
version - バージョンコード
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailSet

public void categoryDetailSet(String groupId,
                              jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory category)
                       throws jp.co.intra_mart.foundation.exception.ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 登録された分類区分詳細詳細情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  jp.co.intra_mart.foundation.datastore.application.domain.company.category.CompanyCategory category)
                           throws jp.co.intra_mart.foundation.exception.ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 削除された分類区分詳細詳細情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

memberSet

public void memberSet(String groupId,
                      jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach attach)
               throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織への人員の割当がデータストアに登録された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

memberDeleted

public void memberDeleted(String groupId,
                          jp.co.intra_mart.foundation.datastore.application.domain.company.attach.DepartmentAttach attach)
                   throws jp.co.intra_mart.foundation.exception.ChangedListenerException
組織からの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - 組織から外された人員の情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

mainSet

public void mainSet(String groupId,
                    jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain main)
             throws jp.co.intra_mart.foundation.exception.ChangedListenerException
主所属情報がデータストアに登録された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の mainSet
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

mainRemoved

public void mainRemoved(String groupId,
                        jp.co.intra_mart.foundation.datastore.application.domain.company.main.DepartmentMain main)
                 throws jp.co.intra_mart.foundation.exception.ChangedListenerException
主所属情報がデータストアから削除された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の mainRemoved
パラメータ:
groupId - ログイングループID
main - 主所属情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

versionAdded

public void versionAdded(String groupId,
                         jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion version)
                  throws jp.co.intra_mart.foundation.exception.ChangedListenerException
会社構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

versionUpdated

public void versionUpdated(String groupId,
                           jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion version)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
会社構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

versionDeleted

public void versionDeleted(String groupId,
                           jp.co.intra_mart.foundation.datastore.application.domain.company.version.CompanyVersion version)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
会社構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - 会社構成バージョン
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

versionCopied

public void versionCopied(String groupId,
                          String company,
                          String srcVersion,
                          String destVersion,
                          jp.co.intra_mart.foundation.datastore.common.structure.Term term)
                   throws jp.co.intra_mart.foundation.exception.ChangedListenerException
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。 。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
company - コピー元、コピー先の会社構成バージョンの会社コード
srcVersion - コピー元の会社構成バージョンのバージョンコード
destVersion - コピー先の会社構成バージョンのバージョンコード
term - コピー先の会社構成バージョンの期間
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

postAdded

public void postAdded(String groupId,
                      jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost post)
               throws jp.co.intra_mart.foundation.exception.ChangedListenerException
役職情報がデータストアに登録された後に呼び出されます 。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の postAdded
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

postUpdated

public void postUpdated(String groupId,
                        jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost post)
                 throws jp.co.intra_mart.foundation.exception.ChangedListenerException
役職情報がデータストアに更新された後に呼び出されます 。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の postUpdated
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合

postDeleted

public void postDeleted(String groupId,
                        jp.co.intra_mart.foundation.datastore.application.domain.company.post.CompanyPost post)
                 throws jp.co.intra_mart.foundation.exception.ChangedListenerException
役職情報がデータストアから削除された後に呼び出されます 。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener 内の postDeleted
パラメータ:
groupId - ログイングループID
post - 役職情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - リスナーの処理で例外が発生した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.listener (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.listener
クラス
AccountChangedPortalAccessListener
CompanyChangedPortalAccessListener
PublicGroupChangedPortalAccessListener
RoleChangedPortalAccessListener


jp.co.intra_mart.foundation.portal.listener (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.listener

クラスの概要
AccountChangedPortalAccessListener | アカウント情報書き込み時（書き込み直後）のリスナを定義します。
CompanyChangedPortalAccessListener | 会社・組織に関する情報の変更時のリスナーです。
PublicGroupChangedPortalAccessListener | パブリックグループに関する情報の更新時のリスナーです。
RoleChangedPortalAccessListener | ロール情報書き込み時（書き込み直後）のリスナを定義します。


jp.co.intra_mart.foundation.portal.listener クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.listener の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener (implements jp.co.intra_mart.foundation.security.account.AccountChangedListener)
    • class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)


パッケージ jp.co.intra_mart.foundation.portal.listener の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.listener の使用

jp.co.intra_mart.foundation.portal.listener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PublicGroupChangedPortalAccessListener (im_portal 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.listener
クラス PublicGroupChangedPortalAccessListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener
すべての実装インタフェース:
jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener
public class PublicGroupChangedPortalAccessListener
extends Object
implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener

パブリックグループに関する情報の更新時のリスナーです。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
PublicGroupChangedPortalAccessListener()
メソッドの概要
void | categoryDetailRemoved(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory category) 分類区分情報がデータストアから削除された後に呼び出されます
void | categoryDetailSet(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory category) 分類区分情報がデータストアに登録された後に呼び出されます
void | groupSetAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet groupSet) グループセットがデータストアに登録された後に呼び出されます
void | groupSetDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet groupSet) グループセットがデータストアから削除された後に呼び出されます
void | init(Map params) アカウントリスナーの初期化を行います。
void | memberDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach attach) パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
void | memberSet(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach attach) パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます
void | publicGroupAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup publicGroup) パブリックグループがデータストアに登録された後に呼び出されます
void | publicGroupDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup publicGroup) パブリックグループがデータストアから削除された後に呼び出されます
void | publicGroupJoined(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報がデータストアに登録された後に呼び出されます
void | publicGroupLeft(String groupId, String groupSet, String publicGroup, String version) パブリックグループ構成情報がデータストアから削除された後に呼び出されます
void | publicGroupMoved(String groupId, String groupSet, String parentGroup, String publicGroup, String version) パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます
void | publicGroupUpdated(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup publicGroup) パブリックグループがデータストアに更新された後に呼び出されます
void | setUesrId(String userid) ログインユーザIDを設定します。
void | versionAdded(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
void | versionCopied(String groupId, String groupSet, String srcVersion, String destVersion, jp.co.intra_mart.foundation.datastore.common.structure.Term term) 登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
void | versionDeleted(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
void | versionUpdated(String groupId, jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion version) パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PublicGroupChangedPortalAccessListener

public PublicGroupChangedPortalAccessListener()
メソッドの詳細

init

public void init(Map params)
アカウントリスナーの初期化を行います。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

setUesrId

public void setUesrId(String userid)
ログインユーザIDを設定します。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の setUesrId
パラメータ:
userid - ログインユーザID

groupSetAdded

public void groupSetAdded(String groupId,
                          jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet groupSet)
                   throws jp.co.intra_mart.foundation.exception.ChangedListenerException
グループセットがデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の groupSetAdded
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

groupSetDeleted

public void groupSetDeleted(String groupId,
                            jp.co.intra_mart.foundation.datastore.application.domain.public_group.set.PublicGroupSet groupSet)
                     throws jp.co.intra_mart.foundation.exception.ChangedListenerException
グループセットがデータストアから削除された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の groupSetDeleted
パラメータ:
groupId - ログイングループID
groupSet - グループセット
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

publicGroupAdded

public void publicGroupAdded(String groupId,
                             jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup publicGroup)
                      throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループがデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の publicGroupAdded
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

publicGroupUpdated

public void publicGroupUpdated(String groupId,
                               jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup publicGroup)
                        throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループがデータストアに更新された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の publicGroupUpdated
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

publicGroupDeleted

public void publicGroupDeleted(String groupId,
                               jp.co.intra_mart.foundation.datastore.application.domain.public_group.group.PublicGroup publicGroup)
                        throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループがデータストアから削除された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の publicGroupDeleted
パラメータ:
groupId - ログイングループID
publicGroup - パブリックグループ
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

publicGroupJoined

public void publicGroupJoined(String groupId,
                              String groupSet,
                              String parentGroup,
                              String publicGroup,
                              String version)
                       throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループ構成情報がデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の publicGroupJoined
パラメータ:
groupId - ログイングループID
publicGroup - 上位パブリックグループと新規登録されるパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 新規登録するパブリックグループの上位となるパブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
version - バージョンコード
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

publicGroupMoved

public void publicGroupMoved(String groupId,
                             String groupSet,
                             String parentGroup,
                             String publicGroup,
                             String version)
                      throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の publicGroupMoved
パラメータ:
groupId - ログイングループID
publicGroup - 上位パブリックグループと移動対象のパブリックグループが所属するパブリックグループセットのグループセットコード
parentGroup - 上位パブリックグループのグループコード（またはパブリックグループセットのグループセットコード）
version - バージョンコード
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

publicGroupLeft

public void publicGroupLeft(String groupId,
                            String groupSet,
                            String publicGroup,
                            String version)
                     throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループ構成情報がデータストアから削除された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の publicGroupLeft
パラメータ:
groupId - ログイングループID
groupSet - グループセットコード
publicGroup - 離脱させるパブリックグループのグループコード（パブリックグループセットに該当するパブリックグループは指定できない）
version - バージョンコード
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

categoryDetailSet

public void categoryDetailSet(String groupId,
                              jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory category)
                       throws jp.co.intra_mart.foundation.exception.ChangedListenerException
分類区分情報がデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の categoryDetailSet
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

categoryDetailRemoved

public void categoryDetailRemoved(String groupId,
                                  jp.co.intra_mart.foundation.datastore.application.domain.public_group.category.PublicGroupCategory category)
                           throws jp.co.intra_mart.foundation.exception.ChangedListenerException
分類区分情報がデータストアから削除された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の categoryDetailRemoved
パラメータ:
groupId - ログイングループID
category - 分類区分詳細詳細情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

memberSet

public void memberSet(String groupId,
                      jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach attach)
               throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の memberSet
パラメータ:
groupId - ログイングループID
attach - 割当られた人員の情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

memberDeleted

public void memberDeleted(String groupId,
                          jp.co.intra_mart.foundation.datastore.application.domain.public_group.attach.PublicGroupAttach attach)
                   throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の memberDeleted
パラメータ:
groupId - ログイングループID
attach - パブリックグループから外された人員の情報
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

versionAdded

public void versionAdded(String groupId,
                         jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion version)
                  throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の versionAdded
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

versionUpdated

public void versionUpdated(String groupId,
                           jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion version)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の versionUpdated
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

versionDeleted

public void versionDeleted(String groupId,
                           jp.co.intra_mart.foundation.datastore.application.domain.public_group.version.PublicGroupVersion version)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の versionDeleted
パラメータ:
groupId - ログイングループID
version - パブリックグループ構成バージョン
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException

versionCopied

public void versionCopied(String groupId,
                          String groupSet,
                          String srcVersion,
                          String destVersion,
                          jp.co.intra_mart.foundation.datastore.common.structure.Term term)
                   throws jp.co.intra_mart.foundation.exception.ChangedListenerException
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。

定義:
インタフェース jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener 内の versionCopied
パラメータ:
groupId - ログイングループID
groupSet - コピー元、コピー先のパブリックグループセット構成バージョンのパブリックグループコード
srcVersion - コピー元のパブリックグループセット構成バージョンのバージョンコード
destVersion - コピー先のパブリックグループセット構成バージョンのバージョンコード
term - コピー先のパブリックグループセット構成バージョンの期間
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RoleChangedPortalAccessListener (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.listener
クラス RoleChangedPortalAccessListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener
すべての実装インタフェース:
jp.co.intra_mart.foundation.security.role.RoleChangedListener
public class RoleChangedPortalAccessListener
extends Object
implements jp.co.intra_mart.foundation.security.role.RoleChangedListener

ロール情報書き込み時（書き込み直後）のリスナを定義します。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
RoleChangedPortalAccessListener()
メソッドの概要
void | init(Map params) ロールリスナーの初期化。
void | roleAdded(String groupId, jp.co.intra_mart.foundation.security.role.Role role) ロール情報をデータストアに作成した直後にコールされます。
void | roleDeleted(String groupId, String roleId) ロール情報をデータストアから削除した直後にコールされます
void | roleUpdated(String groupId, jp.co.intra_mart.foundation.security.role.Role role) ロール情報をデータストアに更新した直後にコールされます
void | subRoleAdded(String groupId, String roleId, String subRoleId) ロールにサブロールを追加した直後にコールされます
void | subRoleDeleted(String groupId, String roleId, String subRoleId) ロールからサブロールを削除した直後にコールされます
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RoleChangedPortalAccessListener

public RoleChangedPortalAccessListener()
メソッドの詳細

init

public void init(Map params)
ロールリスナーの初期化。
このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

roleAdded

public void roleAdded(String groupId,
                      jp.co.intra_mart.foundation.security.role.Role role)
               throws jp.co.intra_mart.foundation.exception.ChangedListenerException
ロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener 内の roleAdded
パラメータ:
groupId - ログイングループID
role - 作成されたロール
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleDeleted

public void roleDeleted(String groupId,
                        String roleId)
                 throws jp.co.intra_mart.foundation.exception.ChangedListenerException
ロール情報をデータストアから削除した直後にコールされます

定義:
インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener 内の roleDeleted
パラメータ:
groupId - ログイングループID
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

roleUpdated

public void roleUpdated(String groupId,
                        jp.co.intra_mart.foundation.security.role.Role role)
                 throws jp.co.intra_mart.foundation.exception.ChangedListenerException
ロール情報をデータストアに更新した直後にコールされます

定義:
インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener 内の roleUpdated
パラメータ:
groupId - ログイングループID
role - 更新されたロール
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleAdded

public void subRoleAdded(String groupId,
                         String roleId,
                         String subRoleId)
                  throws jp.co.intra_mart.foundation.exception.ChangedListenerException
ロールにサブロールを追加した直後にコールされます

定義:
インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener 内の subRoleAdded
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 追加されたサブロールID
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。

subRoleDeleted

public void subRoleDeleted(String groupId,
                           String roleId,
                           String subRoleId)
                    throws jp.co.intra_mart.foundation.exception.ChangedListenerException
ロールからサブロールを削除した直後にコールされます

定義:
インタフェース jp.co.intra_mart.foundation.security.role.RoleChangedListener 内の subRoleDeleted
パラメータ:
groupId - ログイングループID
roleId - ロールID
subRoleId - 削除されたサブロールID
例外:
jp.co.intra_mart.foundation.exception.ChangedListenerException - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.portal.portlet.PortletManager の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletManager の使用

jp.co.intra_mart.foundation.portal.portlet.PortletManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletManagerException の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletManagerException の使用

PortletManagerException を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet での PortletManagerException の使用

PortletManagerException をスローする jp.co.intra_mart.foundation.portal.portlet のメソッド
void | PortletManager.setPortlet(jp.co.intra_mart.foundation.portal.portlet.model.Portlet portlet) ポートレット情報を登録します。
void | PortletManager.deletePortlet(jp.co.intra_mart.foundation.portal.portlet.model.Portlet portlet) ポートレット情報を削除します。
jp.co.intra_mart.foundation.portal.portlet.model.Portlet | PortletManager.getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
jp.co.intra_mart.foundation.portal.portlet.model.Portlet[] | PortletManager.getPortlets() すでに登録されているポートレット情報の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.portlet.PortletMapping の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.portlet.PortletMapping の使用

PortletMapping を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet での PortletMapping の使用

PortletMapping を返す jp.co.intra_mart.foundation.portal.portlet のメソッド
static PortletMapping PortletMapping.getInstance()
インスタンスを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.portal.portlet (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.portlet
クラス
PortletManager
PortletMapping
例外
PortletManagerException


jp.co.intra_mart.foundation.portal.portlet (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet

クラスの概要
PortletManager | ポートレット情報の登録・参照を行うマネージャクラスです。
PortletMapping | ポートレットの種別とモデルのマッピングを管理します。

例外の概要
PortletManagerException ポートレットマネージャー操作時に発生するすべての例外のクラスです。


jp.co.intra_mart.foundation.portal.portlet クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.portlet の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.portlet.PortletManager
    • class jp.co.intra_mart.foundation.portal.portlet.PortletMapping
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException


パッケージ jp.co.intra_mart.foundation.portal.portlet の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.portlet の使用

jp.co.intra_mart.foundation.portal.portlet を使用しているパッケージ
jp.co.intra_mart.foundation.portal.portlet

jp.co.intra_mart.foundation.portal.portlet により使用される jp.co.intra_mart.foundation.portal.portlet のクラス
PortletManagerException
ポートレットマネージャー操作時に発生するすべての例外のクラスです。
PortletMapping
ポートレットの種別とモデルのマッピングを管理します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortletManager (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.PortletManager
public class PortletManager
extends Object

ポートレット情報の登録・参照を行うマネージャクラスです。

導入されたバージョン:
6.0
バージョン:
1.0

コンストラクタの概要
PortletManager(String groupId)
コンストラクタ
メソッドの概要
void | deletePortlet(jp.co.intra_mart.foundation.portal.portlet.model.Portlet portlet) ポートレット情報を削除します。
jp.co.intra_mart.foundation.portal.portlet.model.Portlet | getPortlet(String portletCode, String pageKind) すでに登録済のポートレット情報を取得します。
jp.co.intra_mart.foundation.portal.portlet.model.Portlet[] | getPortlets() すでに登録されているポートレット情報の一覧を取得します。
void | setPortlet(jp.co.intra_mart.foundation.portal.portlet.model.Portlet portlet) ポートレット情報を登録します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortletManager

public PortletManager(String groupId)
コンストラクタ

パラメータ:
groupId - ログイングループID
メソッドの詳細

setPortlet

public void setPortlet(jp.co.intra_mart.foundation.portal.portlet.model.Portlet portlet)
                throws PortletManagerException
ポートレット情報を登録します。

指定されたポートレット情報が存在ない場合は新規登録します。
すでに存在する場合は更新を行います。

パラメータ:
portlet - ポートレット情報
例外:
PortletManagerException - ポートレットの登録に失敗した場合

deletePortlet

public void deletePortlet(jp.co.intra_mart.foundation.portal.portlet.model.Portlet portlet)
                   throws PortletManagerException
ポートレット情報を削除します。

パラメータ:
portlet - ポートレット情報
例外:
PortletManagerException - ポートレットの削除に失敗した場合

getPortlet

public jp.co.intra_mart.foundation.portal.portlet.model.Portlet getPortlet(String portletCode,
                                                                           String pageKind)
                                                                    throws PortletManagerException
すでに登録済のポートレット情報を取得します。
指定されたポートレット情報が存在しない場合は、nullを返します。

パラメータ:
portletCode - ポートレットコード
pageKind - ページ種別
戻り値:
ポートレット情報
例外:
PortletManagerException - ポートレット情報の取得に失敗した場合

getPortlets

public jp.co.intra_mart.foundation.portal.portlet.model.Portlet[] getPortlets()
                                                                       throws PortletManagerException
すでに登録されているポートレット情報の一覧を取得します。

ポートレット情報を1件も取得できなかった場合は、空の配列を返します。

戻り値:
ポートレット情報の一覧
例外:
PortletManagerException - ポートレット一覧の取得に失敗した場合
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PortletManagerException (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletManagerException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.portal.portlet.PortletManagerException
すべての実装インタフェース:
Serializable
public class PortletManagerException
extends RuntimeException

ポートレットマネージャー操作時に発生するすべての例外のクラスです。

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

コンストラクタの概要
PortletManagerException()
コンストラクタ
PortletManagerException(String message)
コンストラクタ
PortletManagerException(String message, Throwable cause)
コンストラクタ
PortletManagerException(Throwable cause)
コンストラクタ
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PortletManagerException

public PortletManagerException()
コンストラクタ

PortletManagerException

public PortletManagerException(String message)
コンストラクタ

パラメータ:
message - 詳細メッセージ

PortletManagerException

public PortletManagerException(Throwable cause)
コンストラクタ

パラメータ:
cause - 原因

PortletManagerException

public PortletManagerException(String message,
                               Throwable cause)
コンストラクタ

パラメータ:
message - 詳細メッセージ
cause - 原因
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


PortletMapping (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.portlet
クラス PortletMapping

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.portlet.PortletMapping
public class PortletMapping
extends Object

ポートレットの種別とモデルのマッピングを管理します。

導入されたバージョン:
6.0
バージョン:
1.0

フィールドの概要
static String MAPPING_FILE_PATH
ポートレットマッピングの設定ファイルのパス情報
メソッドの概要
String[] | getAvailablePageKind() 利用可能なポートレット種別の一覧を取得します。
static PortletMapping | getInstance() インスタンスを取得します。
jp.co.intra_mart.foundation.portal.portlet.model.Portlet | getPortlet(String pageKind) 指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MAPPING_FILE_PATH

public static String MAPPING_FILE_PATH
ポートレットマッピングの設定ファイルのパス情報

メソッドの詳細

getInstance

public static PortletMapping getInstance()
インスタンスを取得します。

戻り値:
PortletMappingのインスタンス

getPortlet

public jp.co.intra_mart.foundation.portal.portlet.model.Portlet getPortlet(String pageKind)
指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。

パラメータ:
pageKind - ページ種別
戻り値:
ポートレットモデルのインスタンス

getAvailablePageKind

public String[] getAvailablePageKind()
利用可能なポートレット種別の一覧を取得します。

戻り値:
ポートレットのページ種別の一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.portal.utility.RequestFilter の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.utility.RequestFilter の使用

jp.co.intra_mart.foundation.portal.utility.RequestFilter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.portal.utility.Tools の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.portal.utility.Tools の使用

jp.co.intra_mart.foundation.portal.utility.Tools はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.portal.utility (im_portal 6.1.14 API)

 jp.co.intra_mart.foundation.portal.utility
クラス
RequestFilter
Tools


jp.co.intra_mart.foundation.portal.utility (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.utility

クラスの概要
RequestFilter | リクエスト情報をコンソールに出力する
Tools | ポータルシステム共通、各種ユーティリティ


jp.co.intra_mart.foundation.portal.utility クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.utility の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.utility.RequestFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.portal.utility.Tools


パッケージ jp.co.intra_mart.foundation.portal.utility の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.utility の使用

jp.co.intra_mart.foundation.portal.utility はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RequestFilter (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.utility
クラス RequestFilter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.utility.RequestFilter
すべての実装インタフェース:
Filter
public class RequestFilter
extends Object
implements Filter

リクエスト情報をコンソールに出力する

バージョン:
5.0

コンストラクタの概要
RequestFilter()
メソッドの概要
void | destroy() 終了処理
void | doFilter(ServletRequest request, ServletResponse response, FilterChain chain) 実行
void | init(FilterConfig arg0) 初期化処理
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

RequestFilter

public RequestFilter()
メソッドの詳細

init

public void init(FilterConfig arg0)
          throws ServletException
初期化処理

定義:
インタフェース Filter 内の init
例外:
ServletException

doFilter

public void doFilter(ServletRequest request,
                     ServletResponse response,
                     FilterChain chain)
              throws ServletException,
                     IOException
実行

定義:
インタフェース Filter 内の doFilter
パラメータ:
request - リクエスト
response - レスポンス
chain - フィルタチェーン
例外:
ServletException
IOException

destroy

public void destroy()
終了処理

定義:
インタフェース Filter 内の destroy
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Tools (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.utility
クラス Tools

java.lang.Object
    拡張 jp.co.intra_mart.foundation.portal.utility.Tools
public class Tools
extends Object

ポータルシステム共通、各種ユーティリティ

バージョン:
5.0

コンストラクタの概要
Tools()
メソッドの概要
static void | deleteFile(String path) ファイル削除
static String | getCommonConfig(String key) ポータル共通設定ファイルの内容を取得
static String | getCurrentDate() yyyy/MM/dd HH:mm:ssフォーマットの日時文字列を生成する
static String | getCurrentPage() ページ番号を取得する
static String | getErrorMessage(String key, Locale locale) エラーメッセージを取得
static String | getInsertSql(String tableName, HashMap map) PreparedStatement 登録SQL を生成する。
static int | getNumberOfEachPage() ページ毎の表示件数を取得する
static int | getNumberOfEachPageLink() ページ毎の表示件数を取得する
static String | getOrderFlag() 昇順・降順フラグを取得する
static String | getRssXmlPath() rssのxmlを取得する
static String | getUpdateSql(String tableName, HashMap map) PreparedStatement 更新SQL を生成する。
static String | readFile(String filePath) ファイルの内容を取得
static ArrayList | readRSS() パーサー情報を読み取り
static jp.co.intra_mart.foundation.portal.rss.model.RSSSettingInfo | readRSSXML(String rssId) RSS設定情報を読み取り
static int | setStmtParam(PreparedStatement stmt, HashMap map) PreparedStatementにデータをセットする。
static void | writeFile(String path, String htmlStr) ファイル生成
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Tools

public Tools()
メソッドの詳細

getRssXmlPath

public static String getRssXmlPath()
                            throws jp.co.intra_mart.framework.system.exception.ApplicationException
rssのxmlを取得する

戻り値:
ページ番号
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getNumberOfEachPage

public static int getNumberOfEachPage()
                               throws jp.co.intra_mart.framework.system.exception.ApplicationException
ページ毎の表示件数を取得する

戻り値:
ページ毎の表示件数
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getNumberOfEachPageLink

public static int getNumberOfEachPageLink()
                                   throws jp.co.intra_mart.framework.system.exception.ApplicationException
ページ毎の表示件数を取得する

戻り値:
ページ毎の表示件数
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getCurrentPage

public static String getCurrentPage()
                             throws jp.co.intra_mart.framework.system.exception.ApplicationException
ページ番号を取得する

戻り値:
ページ番号
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getOrderFlag

public static String getOrderFlag()
                           throws jp.co.intra_mart.framework.system.exception.ApplicationException
昇順・降順フラグを取得する

戻り値:
昇順・降順フラグ
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getCommonConfig

public static String getCommonConfig(String key)
                              throws jp.co.intra_mart.framework.system.exception.ApplicationException
ポータル共通設定ファイルの内容を取得

パラメータ:
key - メッセージキー
戻り値:
キーの値
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getCurrentDate

public static String getCurrentDate()
yyyy/MM/dd HH:mm:ssフォーマットの日時文字列を生成する

戻り値:
yyyy/MM/dd HH:mm:ssフォーマットの日時文字列

getErrorMessage

public static String getErrorMessage(String key,
                                     Locale locale)
エラーメッセージを取得

パラメータ:
key - メッセージのキー
戻り値:
結果文字列

writeFile

public static void writeFile(String path,
                             String htmlStr)
                      throws jp.co.intra_mart.framework.system.exception.ApplicationException
ファイル生成

パラメータ:
path - ファイル保存パス
htmlStr - 書き込む内容
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

deleteFile

public static void deleteFile(String path)
                       throws jp.co.intra_mart.framework.system.exception.ApplicationException
ファイル削除

パラメータ:
path - ファイル保存パス
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

readFile

public static String readFile(String filePath)
                       throws jp.co.intra_mart.framework.system.exception.ApplicationException
ファイルの内容を取得

パラメータ:
filePath - ファイルのパス
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

readRSSXML

public static jp.co.intra_mart.foundation.portal.rss.model.RSSSettingInfo readRSSXML(String rssId)
                                                                              throws jp.co.intra_mart.framework.system.exception.ApplicationException
RSS設定情報を読み取り

パラメータ:
rssId - 取得対象RSSID
戻り値:
RSS設定情報オブジェクト
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

readRSS

public static ArrayList readRSS()
                         throws jp.co.intra_mart.framework.system.exception.ApplicationException
パーサー情報を読み取り

戻り値:
パーサー情報
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException

getInsertSql

public static String getInsertSql(String tableName,
                                  HashMap map)
PreparedStatement 登録SQL を生成する。

戻り値:
String SQL 登録SQL

getUpdateSql

public static String getUpdateSql(String tableName,
                                  HashMap map)
PreparedStatement 更新SQL を生成する。

戻り値:
String SQL 更新SQL

setStmtParam

public static int setStmtParam(PreparedStatement stmt,
                               HashMap map)
                        throws SQLException
PreparedStatementにデータをセットする。

戻り値:
String SQL 更新SQL
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.system.javascript.portal.PortletManagerObject の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.javascript.portal.PortletManagerObject の使用

jp.co.intra_mart.system.javascript.portal.PortletManagerObject はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.system.javascript.portal (im_portal 6.1.14 API)

 jp.co.intra_mart.system.javascript.portal
クラス
PortletManagerObject


jp.co.intra_mart.system.javascript.portal (im_portal 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.system.javascript.portal

クラスの概要
PortletManagerObject PortletManagerオブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.system.javascript.portal クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.system.javascript.portal の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.javascript.ScriptableObject (implements jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.portal.PortletManagerObject (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.system.javascript.portal の使用 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.system.javascript.portal の使用

jp.co.intra_mart.system.javascript.portal はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PortletManagerObject (im_portal 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.javascript.portal
クラス PortletManagerObject

java.lang.Object
    拡張 jp.co.intra_mart.system.javascript.ScriptableObject
        拡張 jp.co.intra_mart.system.javascript.portal.PortletManagerObject
すべての実装インタフェース:
jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, Serializable
public class PortletManagerObject
extends jp.co.intra_mart.system.javascript.ScriptableObject
implements Serializable

PortletManagerオブジェクト。

ポートレットに関連する情報の参照、更新を行うマネージャオブジェクトです。

ポートレット情報を操作するオブジェクトの構成は以下の通りです。
ポートレット情報オブジェクト

ポートレット情報 オブジェクト (Object) | portletCode [必須] ポートレットコード (String)
 | application アプリケーション名 (String)
 | portletName [必須] ポートレット名 (String)
 | pageKind [必須] ページ種別 (String) 指定できるページ種別の値は以下のいずれか ・pagebase ：プレゼンテーションページ ・jsp ：Servlet/JSP ・internet ：インターネット ・framework ：im-J2EE Service Framework ・menu ：メニューリンク ・rss ：RSS
 | ページ種別で 固有の属性 | pagebase jsp internet | url [必須] ページURL(String)
 |  |  | argument ページ引数 (String)
 |  | framework | applicationId [必須] アプリケーションID (String)
 |  |  | serviceId [必須] サービスID (String)
 |  |  | argument ページ引数 (String)
 |  | menu | menuLinkSetCode [必須] メニューリンクセットコード (String)
 |  | rss | rssUrl [必須] RSSのURL (String)
 |  |  | parserKey [必須] RSS解析バージョンのキー情報 (String) %StrageService%/portal/rss.xmlに定義された RSS解析パーサーのIDを指定する。 具体的には、parser-config/parser/idの要素を指定する。 インストール時の定義は、rss10またはrss20。
 |  |  | proxyHost プロキシサーバのホスト名 (String)
 |  |  | proxyPort プロキシサーバのポート番号 (Number) 設定されていない場合、-1を返却します。
 | titleBar タイトルバーを表示するかどうか (Boolean) デフォルト値は true (タイトルバーを表示する)
 | cacheTime キャッシュ時間 (Number) デフォルト値は 0 (キャッシュ設定なし)
 | explain 説明 (String)
 | unit 表示単位 (String) 指定できる値は以下のいずれか ・null ：表示単位の指定なし (デフォルト値) ・c ：パーセント ・p ：ピクセル
 | width 表示単位に対する幅 (Number) デフォルト値は 0
 | height 表示単位に対する高さ (Number) デフォルト値は 0
 | recordUserCode 最終更新ユーザコード (String)
 | recordDate 最終更新日 (Date)

処理結果オブジェクトの構成は以下の通りです。
処理結果オブジェクトの data 属性は検索処理が成功 (error ステータスが false) の場合にのみ定義されます。
data属性には、呼び出されたメソッドの結果に応じたオブジェクトが設定されます。
処理結果オブジェクト
処理結果
オブジェクト
(Object)
error true(失敗) or false(成功) (Boolean)
code 0(成功) or -1(処理失敗) or -2(引数オブジェクト不正) (Number)
message エラー発生時のメッセージ (String)
data 任意のオブジェクト　(検索処理の成功時のみ)

導入されたバージョン:
6.0
バージョン:
1.0
関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したフィールド
DONTENUM, EMPTY, PERMANENT, READONLY
インタフェース jp.co.intra_mart.system.javascript.Scriptable から継承したフィールド
NOT_FOUND
コンストラクタの概要
PortletManagerObject()
デフォルトコンストラクタ
PortletManagerObject(String groupId)
コンストラクタ
メソッドの概要
String | getClassName() オブジェクト型名
static Object | jsConstructor(jp.co.intra_mart.system.javascript.Context cx, Object[] args, jp.co.intra_mart.system.javascript.Function ctorObj, boolean inNewExpr) コンストラクタ
boolean | jsFunction_deletePortlet(Object portlet) ポートレット情報を削除します。
Object | jsFunction_getPortlet(Object portletCode, Object pageKind) すでに登録済のポートレット情報を取得します。
Object | jsFunction_getPortlets() すでに登録されているポートレット情報の一覧を取得します。
boolean | jsFunction_setPortlet(Object portlet) ポートレット情報を登録します。
クラス jp.co.intra_mart.system.javascript.ScriptableObject から継承したメソッド
associateValue, callMethod, callMethod, defineClass, defineClass, defineClass, defineFunctionProperties, defineProperty, defineProperty, defineProperty, defineProperty, delete, delete, deleteProperty, deleteProperty, equivalentValues, get, get, getAllIds, getAssociatedValue, getAttributes, getAttributes, getAttributes, getAttributes, getClassPrototype, getDefaultValue, getFunctionPrototype, getIds, getObjectPrototype, getParentScope, getProperty, getProperty, getPropertyIds, getPrototype, getTopLevelScope, getTopScopeValue, has, has, hasInstance, hasProperty, hasProperty, isSealed, put, put, putProperty, putProperty, sealObject, setAttributes, setAttributes, setAttributes, setAttributes, setParentScope, setPrototype, toDate
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

PortletManagerObject

public PortletManagerObject()
デフォルトコンストラクタ

PortletManagerObject

public PortletManagerObject(String groupId)
コンストラクタ

パラメータ:
groupId - グループID
メソッドの詳細

getClassName

public String getClassName()
オブジェクト型名

定義:
インタフェース jp.co.intra_mart.system.javascript.Scriptable 内の getClassName

jsConstructor

public static Object jsConstructor(jp.co.intra_mart.system.javascript.Context cx,
                                   Object[] args,
                                   jp.co.intra_mart.system.javascript.Function ctorObj,
                                   boolean inNewExpr)
コンストラクタ

戻り値:
Object CompanyManagerオブジェクト

jsFunction_setPortlet

public boolean jsFunction_setPortlet(Object portlet)
ポートレット情報を登録します。

指定されたポートレット情報が存在ない場合は新規登録します。
すでに存在する場合は更新を行います。

パラメータ:
portlet - Object ポートレット情報オブジェクト
戻り値:
Boolean true : 成功 / false : 失敗

jsFunction_deletePortlet

public boolean jsFunction_deletePortlet(Object portlet)
ポートレット情報を削除します。

パラメータ:
portlet - Object ポートレット情報オブジェクト
戻り値:
Boolean true : 成功 / false : 失敗

jsFunction_getPortlet

public Object jsFunction_getPortlet(Object portletCode,
                                    Object pageKind)
すでに登録済のポートレット情報を取得します。
検索結果は、処理結果オブジェクトのdata属性にポートレット情報オブジェクトが設定されます。
指定されたポートレット情報が存在しない場合は、data属性に null が設定されます。

パラメータ:
portletCode - String ポートレットコード
pageKind - String ページ種別
戻り値:
Object 処理結果オブジェクト

jsFunction_getPortlets

public Object jsFunction_getPortlets()
すでに登録されているポートレット情報の一覧を取得します。

検索結果は、処理結果オブジェクトのdata属性にポートレット情報オブジェクトの配列 (Array) が設定されます。
ポートレット情報を1件も取得できなかった場合は、data属性に要素数が 0 の配列 (Array) が設定されます。

戻り値:
Object 処理結果オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (im_portal 6.1.14 API)

 すべてのクラス
AccountChangedPortalAccessListener
CompanyChangedPortalAccessListener
NewArrived
NewArrivedManager
NewArrivedProvider
NewArrivedProviderConfig
NewArrivedProviderConfigImpl
NewArrivedProviderHandler
PageBaseCallProvider
PortalConstant
PortletManager
PortletManagerException
PortletManagerObject
PortletMapping
PublicGroupChangedPortalAccessListener
RequestFilter
RoleChangedPortalAccessListener
Tools


定数フィールド値 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.portal.common.PortalConstant
public static final String PORTAL_EXCEPTION_KEY "im_portal.exception"

jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
public static final String PAGE_PATH "pagePath"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし
A C D G I J M N P R S T V W

A

AccountChangedPortalAccessListener - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener.
アカウント情報書き込み時（書き込み直後）のリスナを定義します。
AccountChangedPortalAccessListener() - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のコンストラクタ
accountAdded(String, Account) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウント情報をデータストアに作成した直後にコールされます。
accountDeleted(String, String) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウント情報をデータストアから削除した直後にコールされます。
accountRoleAdded(String, String, AccountRole) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウントロール情報をデータストアに作成した直後にコールされます
accountRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウントロール情報をデータストアから削除した直後にコールされます。
accountRoleUpdated(String, String, AccountRole) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウントロール情報をデータストアに更新した直後にコールされます
accountUpdated(String, Account) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウント情報をデータストアに更新した直後にコールされます。

C

CompanyChangedPortalAccessListener - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener.
会社・組織に関する情報の変更時のリスナーです。
CompanyChangedPortalAccessListener() - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のコンストラクタ
categoryDetailRemoved(String, CompanyCategory) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます。
categoryDetailRemoved(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
分類区分情報がデータストアから削除された後に呼び出されます
categoryDetailSet(String, CompanyCategory) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます。
categoryDetailSet(String, PublicGroupCategory) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
分類区分情報がデータストアに登録された後に呼び出されます
companyAdded(String, Company) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
会社情報がデータストアに登録された後に呼び出されます
companyDeleted(String, Company) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
会社情報がデータストアから削除された後に呼び出されます

D

deleteFile(String) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ファイル削除
deletePortlet(Portlet) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
ポートレット情報を削除します。
departmentAdded(String, Department) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織情報がデータストアに登録された後に呼び出されます
departmentDeleted(String, Department) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織情報がデータストアから削除された後に呼び出されます
departmentJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織構成がデータストアに登録された後に呼び出されます
departmentLeft(String, String, String, String) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織構成からの組織の離脱がデータストアに反映された後に呼び出されます
departmentMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織構成からの組織の移動がデータストアに反映された後に呼び出されます
departmentUpdated(String, Department) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織情報がデータストアから更新された後に呼び出されます
destroy() - class jp.co.intra_mart.foundation.portal.utility.RequestFilter のメソッド
終了処理
doFilter(ServletRequest, ServletResponse, FilterChain) - class jp.co.intra_mart.foundation.portal.utility.RequestFilter のメソッド
実行

G

getAvailablePageKind() - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping のメソッド
利用可能なポートレット種別の一覧を取得します。
getCategory() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報のカテゴリ名を取得します。
getClassName() - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のメソッド
オブジェクト型名
getCommonConfig(String) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ポータル共通設定ファイルの内容を取得
getContents() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報の内容を取得します。
getCurrentDate() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
yyyy/MM/dd HH:mm:ssフォーマットの日時文字列を生成する
getCurrentPage() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ページ番号を取得する
getDate() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
日付を取得します。
getErrorMessage(String, Locale) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
エラーメッセージを取得
getInsertSql(String, HashMap) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
PreparedStatement 登録SQL を生成する。
getInsntace() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler の static メソッド
インスタンスを取得します。
getInstance() - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping の static メソッド
インスタンスを取得します。
getNewArrivedList(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager の static メソッド
汎用新着情報の一覧を取得します。
getNewArrivedList(String, String) - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider のメソッド
新着情報を一覧を取得します。
getNewArrivedList(String, String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のメソッド
汎用新着情報を取得
getNumberOfEachPage() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ページ毎の表示件数を取得する
getNumberOfEachPageLink() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ページ毎の表示件数を取得する
getOrderFlag() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
昇順・降順フラグを取得する
getPortlet(String, String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
すでに登録済のポートレット情報を取得します。
getPortlet(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping のメソッド
指定されたページ種別に対応するポートレットモデルのインスタンスを取得します。
getPortlets() - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
すでに登録されているポートレット情報の一覧を取得します。
getProviderConfig(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler のメソッド
指定された設定ファイルに定義されたプロバイダのインスタンスの一覧を返します。
getProviders() - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig のメソッド
プロバイダの一覧を取得します。
getProviders() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl のメソッド
プロバイダの一覧を取得します。
getRssXmlPath() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
rssのxmlを取得する
getUpdateSql(String, HashMap) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
PreparedStatement 更新SQL を生成する。
getUrl() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンク先のURLを取得します。
groupSetAdded(String, PublicGroupSet) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
グループセットがデータストアに登録された後に呼び出されます
groupSetDeleted(String, PublicGroupSet) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
グループセットがデータストアから削除された後に呼び出されます

I

init(Properties) - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider のメソッド
初期化を行います。
init(Properties) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のメソッド
初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener のメソッド
アカウントリスナーの初期化。
init(Map) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
会社リスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
アカウントリスナーの初期化を行います。
init(Map) - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のメソッド
ロールリスナーの初期化。
init(FilterConfig) - class jp.co.intra_mart.foundation.portal.utility.RequestFilter のメソッド
初期化処理
isPopup() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンクへ参照時にポップアップを呼び出すかどうかを取得します。
isSort() - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig のメソッド
カテゴリによるソートを行うかどうか
isSort() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl のメソッド
カテゴリによるソートを行うかどうか

J

jp.co.intra_mart.foundation.portal.common - package jp.co.intra_mart.foundation.portal.common
jp.co.intra_mart.foundation.portal.general_purpose_portlet - package jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model - package jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider - package jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.portal.listener - package jp.co.intra_mart.foundation.portal.listener
jp.co.intra_mart.foundation.portal.portlet - package jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.utility - package jp.co.intra_mart.foundation.portal.utility
jp.co.intra_mart.system.javascript.portal - package jp.co.intra_mart.system.javascript.portal
jsConstructor(Context, Object[], Function, boolean) - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject の static メソッド
コンストラクタ
jsFunction_deletePortlet(Object) - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のメソッド
ポートレット情報を削除します。
jsFunction_getPortlet(Object, Object) - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のメソッド
すでに登録済のポートレット情報を取得します。
jsFunction_getPortlets() - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のメソッド
すでに登録されているポートレット情報の一覧を取得します。
jsFunction_setPortlet(Object) - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のメソッド
ポートレット情報を登録します。

M

MAPPING_FILE_PATH - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping の static 変数
ポートレットマッピングの設定ファイルのパス情報
mainRemoved(String, DepartmentMain) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
主所属情報がデータストアから削除された後に呼び出されます。
mainSet(String, DepartmentMain) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
主所属情報がデータストアに登録された後に呼び出されます。
memberDeleted(String, DepartmentAttach) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織からの人員の割当がデータストアから削除された後に呼び出されます。
memberDeleted(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループからの人員の割当がデータストアから削除された後に呼び出されます。
memberSet(String, DepartmentAttach) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
組織への人員の割当がデータストアに登録された後に呼び出されます。
memberSet(String, PublicGroupAttach) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループへの人員の割当がデータストアに登録された後に呼び出されます

N

NewArrived - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived.
汎用新着情報を保持します。
NewArrived() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のコンストラクタ
NewArrivedManager - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager.
汎用新着情報の取得処理を行うクラスです。
NewArrivedManager() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager のコンストラクタ
NewArrivedProvider - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider.
汎用新着情報のプロバイダのインターフェースです。
NewArrivedProviderConfig - interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig.
汎用新着ポートレットに関するコンフィグ情報を格納します。
NewArrivedProviderConfigImpl - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl.
汎用新着ポートレットに関するコンフィグ情報を格納する実装クラスです。
NewArrivedProviderConfigImpl(boolean, NewArrivedProvider[]) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl のコンストラクタ
コンストラクタ
NewArrivedProviderHandler - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler.
新着一覧を取得するプロバイダを取扱います。

P

PAGE_PATH - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider の static 変数
ページベースプログラム名を特定するキー
PORTAL_EXCEPTION_KEY - interface jp.co.intra_mart.foundation.portal.common.PortalConstant の static 変数
例外情報の格納キー
PageBaseCallProvider - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider.
NewArrivedProvider インターフェースの実装です。
PageBaseCallProvider() - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider のコンストラクタ
PortalConstant - interface jp.co.intra_mart.foundation.portal.common.PortalConstant.
PortletManager - class jp.co.intra_mart.foundation.portal.portlet.PortletManager.
ポートレット情報の登録・参照を行うマネージャクラスです。
PortletManager(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のコンストラクタ
コンストラクタ
PortletManagerException - exception jp.co.intra_mart.foundation.portal.portlet.PortletManagerException.
ポートレットマネージャー操作時に発生するすべての例外のクラスです。
PortletManagerException() - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(String) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(Throwable) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerException(String, Throwable) - class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException のコンストラクタ
コンストラクタ
PortletManagerObject - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject.
PortletManagerオブジェクト。
PortletManagerObject() - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のコンストラクタ
デフォルトコンストラクタ
PortletManagerObject(String) - class jp.co.intra_mart.system.javascript.portal.PortletManagerObject のコンストラクタ
コンストラクタ
PortletMapping - class jp.co.intra_mart.foundation.portal.portlet.PortletMapping.
ポートレットの種別とモデルのマッピングを管理します。
PublicGroupChangedPortalAccessListener - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener.
パブリックグループに関する情報の更新時のリスナーです。
PublicGroupChangedPortalAccessListener() - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のコンストラクタ
postAdded(String, CompanyPost) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
役職情報がデータストアに登録された後に呼び出されます 。
postDeleted(String, CompanyPost) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
役職情報がデータストアから削除された後に呼び出されます 。
postUpdated(String, CompanyPost) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
役職情報がデータストアに更新された後に呼び出されます 。
publicGroupAdded(String, PublicGroup) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループがデータストアに登録された後に呼び出されます
publicGroupDeleted(String, PublicGroup) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループがデータストアから削除された後に呼び出されます
publicGroupJoined(String, String, String, String, String) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループ構成情報がデータストアに登録された後に呼び出されます
publicGroupLeft(String, String, String, String) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループ構成情報がデータストアから削除された後に呼び出されます
publicGroupMoved(String, String, String, String, String) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループ構成情報の移動がデータストアに反映された後に呼び出されます
publicGroupUpdated(String, PublicGroup) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループがデータストアに更新された後に呼び出されます

R

RequestFilter - class jp.co.intra_mart.foundation.portal.utility.RequestFilter.
リクエスト情報をコンソールに出力する
RequestFilter() - class jp.co.intra_mart.foundation.portal.utility.RequestFilter のコンストラクタ
RoleChangedPortalAccessListener - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener.
ロール情報書き込み時（書き込み直後）のリスナを定義します。
RoleChangedPortalAccessListener() - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のコンストラクタ
readFile(String) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ファイルの内容を取得
readRSS() - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
パーサー情報を読み取り
readRSSXML(String) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
RSS設定情報を読み取り
roleAdded(String, Role) - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のメソッド
ロール情報をデータストアに作成した直後にコールされます。
roleDeleted(String, String) - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のメソッド
ロール情報をデータストアから削除した直後にコールされます
roleUpdated(String, Role) - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のメソッド
ロール情報をデータストアに更新した直後にコールされます

S

setCategory(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報のカテゴリ名を設定します。
setContents(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
新着情報の内容を設定します。
setDate(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
日付を設定します。
setPopup(boolean) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンクへ参照時にポップアップを呼び出すかどうかを設定します。
setPortlet(Portlet) - class jp.co.intra_mart.foundation.portal.portlet.PortletManager のメソッド
ポートレット情報を登録します。
setStmtParam(PreparedStatement, HashMap) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
PreparedStatementにデータをセットする。
setUesrId(String) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
ログインユーザIDを設定します。
setUrl(String) - class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived のメソッド
リンク先のURLを設定します。
setUserId(String) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
ログインユーザIDを設定します。
subRoleAdded(String, String, String) - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のメソッド
ロールにサブロールを追加した直後にコールされます
subRoleDeleted(String, String, String) - class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener のメソッド
ロールからサブロールを削除した直後にコールされます

T

Tools - class jp.co.intra_mart.foundation.portal.utility.Tools.
ポータルシステム共通、各種ユーティリティ
Tools() - class jp.co.intra_mart.foundation.portal.utility.Tools のコンストラクタ

V

versionAdded(String, CompanyVersion) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
会社構成バージョンがデータストアに登録された後に呼び出されます。
versionAdded(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループセット構成バージョンがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
登録済の会社構成バージョンのコピーがデータストアに登録された後に呼び出されます。
versionCopied(String, String, String, String, Term) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
登録済のパブリックグループセット構成バージョンの内容をコピーがデータストアに登録された後に呼び出されます。
versionDeleted(String, CompanyVersion) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
会社構成バージョンがデータストアから削除された後に呼び出されます。
versionDeleted(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループセット構成バージョンがデータストアから削除された後に呼び出されます。
versionUpdated(String, CompanyVersion) - class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener のメソッド
会社構成バージョンがデータストアに更新された後に呼び出されます。
versionUpdated(String, PublicGroupVersion) - class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener のメソッド
パブリックグループセット構成バージョンがデータストアに更新された後に呼び出されます。

W

writeFile(String, String) - class jp.co.intra_mart.foundation.portal.utility.Tools の static メソッド
ファイル生成
A C D G I J M N P R S T V W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_portal 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_portal 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.portal.common
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.portal.listener
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.utility
jp.co.intra_mart.system.javascript.portal


概要 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_portal API Specifications

パッケージ
jp.co.intra_mart.foundation.portal.common
jp.co.intra_mart.foundation.portal.general_purpose_portlet
jp.co.intra_mart.foundation.portal.general_purpose_portlet.model
jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider
jp.co.intra_mart.foundation.portal.listener
jp.co.intra_mart.foundation.portal.portlet
jp.co.intra_mart.foundation.portal.utility
jp.co.intra_mart.system.javascript.portal

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.portal.common, jp.co.intra_mart.foundation.portal.general_purpose_portlet, jp.co.intra_mart.foundation.portal.general_purpose_portlet.model, jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider, jp.co.intra_mart.foundation.portal.listener, jp.co.intra_mart.foundation.portal.portlet, jp.co.intra_mart.foundation.portal.utility, jp.co.intra_mart.system.javascript.portal

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.portal.listener.AccountChangedPortalAccessListener (implements jp.co.intra_mart.foundation.security.account.AccountChangedListener)
    • class jp.co.intra_mart.foundation.portal.listener.CompanyChangedPortalAccessListener (implements jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyChangedListener)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.NewArrivedManager
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfigImpl (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig)
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderHandler
    • class jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider (implements jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider)
    • class jp.co.intra_mart.foundation.portal.portlet.PortletManager
    • class jp.co.intra_mart.foundation.portal.portlet.PortletMapping
    • class jp.co.intra_mart.foundation.portal.listener.PublicGroupChangedPortalAccessListener (implements jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupChangedListener)
    • class jp.co.intra_mart.foundation.portal.utility.RequestFilter (implements javax.servlet.Filter)
    • class jp.co.intra_mart.foundation.portal.listener.RoleChangedPortalAccessListener (implements jp.co.intra_mart.foundation.security.role.RoleChangedListener)
    • class jp.co.intra_mart.system.javascript.ScriptableObject (implements jp.co.intra_mart.system.javascript.debug.DebuggableObject, jp.co.intra_mart.system.javascript.Scriptable, java.io.Serializable)
      • class jp.co.intra_mart.system.javascript.portal.PortletManagerObject (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.portal.portlet.PortletManagerException
    • class jp.co.intra_mart.foundation.portal.utility.Tools

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider
  • interface jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProviderConfig
  • interface jp.co.intra_mart.foundation.portal.common.PortalConstant
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_portal 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_portal 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.portal.general_purpose_portlet.model

クラス jp.co.intra_mart.foundation.portal.general_purpose_portlet.model.NewArrived は Object を拡張し、Serializable を実装しています

直列化されたフィールド

category

String category
カテゴリ名

contents

String contents
内容

date

String date
日付

url

String url
リンク先のURL

popup

boolean popup
リンク先をポップアップ画面で呼び出すかどうか

パッケージ jp.co.intra_mart.foundation.portal.portlet

クラス jp.co.intra_mart.foundation.portal.portlet.PortletManagerException は RuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.system.javascript.portal

クラス jp.co.intra_mart.system.javascript.portal.PortletManagerObject は jp.co.intra_mart.system.javascript.ScriptableObject を拡張し、Serializable を実装しています

直列化されたフィールド

manager

PortletManager manager
ポートレットマネージャー

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost の使用

AccEmployeePayPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での AccEmployeePayPost の使用

jp.co.intra_mart.foundation.sap.module.accounting での AccEmployeePayPost のサブクラス
 class AccEmployeePayPostController
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountGl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountTax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用

jp.co.intra_mart.foundation.sap.module.accounting.Bank はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BankController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用

BankList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BankList の使用

BankList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BankList BankController.getBaList()
銀行一覧を取得します｡

BankList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BankController.setBaList(BankList baList)
銀行一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用

BusinessAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BusinessAreaList の使用

BusinessAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BusinessAreaList BusinessAreaController.getBusAreaList()
事業領域一覧を取得します｡

BusinessAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BusinessAreaController.setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Company の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Company の使用

jp.co.intra_mart.foundation.sap.module.accounting.Company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CompanyController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用

CompanyList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CompanyList の使用

CompanyList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CompanyList CompanyController.getCompList()
会社一覧を取得します｡

CompanyList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CompanyController.setCompList(CompanyList compList)
会社一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用

ControllingAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ControllingAreaList の使用

ControllingAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ControllingAreaList ControllingAreaController.getControllAreaList()
管理領域一覧を取得します｡

ControllingAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ControllingAreaController.setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用

CostCenter を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CostCenter の使用

CostCenter を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CostCenter CostCenterController.getCostCenter(int index)
BAPI パラメータ の参照構造オブジェクトが既に 存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用

CostCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CostCenterList の使用

CostCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CostCenterList CostCenterController.getCostCentList()
原価センタ一覧を取得します｡

CostCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CostCenterController.setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用

DocumentHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での DocumentHeader の使用

DocumentHeader を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 DocumentHeader AccEmployeePayPost.getDocumentHeader()
伝票ヘッダを取得します｡

DocumentHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
static void | ParamDocumentHeader.setImportParam(BapiController bapiController, DocumentHeader documentHeader) 伝票ヘッダに値をセットします。
void | AccEmployeePayPost.setDocumentHeader(DocumentHeader documentHeader) 伝票ヘッダを設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Extension1 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Extension1 の使用

jp.co.intra_mart.foundation.sap.module.accounting.Extension1 はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn の使用

ExtensionIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ExtensionIn の使用

ExtensionIn を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ExtensionIn CostCenterController.getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN の参照構造オブジェクトが既に 存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut の使用

ExtensionOut を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ExtensionOut の使用

ExtensionOut を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ExtensionOut CostCenterController.getExtensionOut(int index)
BAPI パラメータ EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAcc はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAccController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用

GlAccList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での GlAccList の使用

GlAccList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 GlAccList GlAccController.getGlList()
勘定科目一覧を取得します｡

GlAccList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void GlAccController.setGlList(GlAccList glList)
勘定科目一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用

ProfitCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ProfitCenterList の使用

ProfitCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ProfitCenterList ProfitCenterController.getProfitCentList()
利益センタ一覧を取得します｡

ProfitCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ProfitCenterController.setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Travel の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Travel の使用

jp.co.intra_mart.foundation.sap.module.accounting.Travel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用

SAPAccountingAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingAppException の使用

SAPAccountingAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
void | CostCenterList.executeBapi() BapiControllerにより原価センタ一覧を作成します。
void | CostCenterList.setImportParam(BapiController bapiController) 原価センタ一覧を取得する条件をセットします。
void | CostCenterController.executeBapi() BapiControllerにより原価センタ一覧を作成します。
void | AccEmployeePayPostController.executeBapi() BapiControllerにより会計伝票を登録します。

SAPAccountingAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用

SAPAccountingSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingSystemException の使用

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
String | ProfitCenterController.getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
String | ProfitCenterController.getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
String | ProfitCenterController.getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | ProfitCenterController.getInChargeUser(String profitCtr) 利益センタを指定して利益センタに責任のあるユーザを取得します。
String | GlAccController.getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
String | GlAccController.getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
void | CostCenterList.executeBapi() BapiControllerにより原価センタ一覧を作成します。
void | CostCenterList.setImportParam(BapiController bapiController) 原価センタ一覧を取得する条件をセットします。
void | CostCenterController.executeBapi() BapiControllerにより原価センタ一覧を作成します。
String | CostCenterController.getName(String costCenter) 原価センタを指定して一般名称を取得します。
String | CostCenterController.getDescript(String costCenter) 原価センタを指定してテキストを取得します。
void | CostCenterController.setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
String | ControllingAreaController.getName(String coArea) 管理領域を指定して管理領域名を取得します。
String | CompanyController.getCompName(String compCode) 会社コードを指定して会社名を取得します。
String | BusinessAreaController.getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
String | BankController.getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | BankController.getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | AccEmployeePayPostController.executeBapi() BapiControllerにより会計伝票を登録します。
void | AccEmployeePayPost.setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | AccEmployeePayPost.setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String personincharge, String inChargeUser, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, String personincharge, String inChargeUser, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, String personincharge, String inChargeUser, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccList(String companyCode, String language, String languageIso, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, String language, String languageIso)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, String language, String languageIso, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController()
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaList(String lang, String isoLang, SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(String lang, String isoLang)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(String lang, String isoLang, SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankList(String bankCtry, int maxRows, SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(String bankCtry, int maxRows)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(String bankCtry, int maxRows, SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.accounting.exception (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.accounting.exception
例外
SAPAccountingAppException
SAPAccountingSystemException


jp.co.intra_mart.foundation.sap.module.accounting.exception (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

ＳＡＰ連携財務会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPAccountingAppException | 会計系APIアプリケーション例外クラス。
SAPAccountingSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の説明

ＳＡＰ連携財務会計系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.accounting.exception クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting.exception のクラス
SAPAccountingAppException
会計系APIアプリケーション例外クラス。
SAPAccountingSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPAccountingAppException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
すべての実装インタフェース:
Serializable
public class SAPAccountingAppException
extends SAPModuleAppException

会計系APIアプリケーション例外クラス。

SAP リアルタイム連携API におけるBAPI 実行後の成功・失敗の標準の基準は、 各API でのBAPI 実行後にRETURN パラメータのTYPE 値を取得して、S（正常終了） または空文字以外が１つでも存在するかどうかです。
失敗の場合、本例外がスローされます。

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingAppException(String message)
会計系APIアプリケーション例外
SAPAccountingAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingAppException

public SAPAccountingAppException(String message,
                                 Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAccountingAppException

public SAPAccountingAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAccountingSystemException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
すべての実装インタフェース:
Serializable
public class SAPAccountingSystemException
extends SAPModuleSystemException

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingSystemException

public SAPAccountingSystemException(String message,
                                    Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccEmployeePayPost (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccEmployeePayPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccEmployeePayPostController
public class AccEmployeePayPost
extends UpdateController
implements Serializable

伝票登録クラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
AccEmployeePayPost()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPost(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPost(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。
メソッドの概要
void | executeBapi(BapiController bapiController) 会計伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
ArrayList | getAccountGlList() G/L 勘定明細一覧（AccountGlインスタンスの配列）を取得します｡
ArrayList | getAccountPayableList() 仕入先明細一覧（AccountPayableインスタンスの配列）を取得します｡
ArrayList | getAccountTaxList() 税明細一覧（AccountTaxインスタンスの配列）を取得します｡
ArrayList | getCurrencyAmountList() 明細通貨項目一覧（CurrencyAmountインスタンスの配列）を取得します｡
DocumentHeader | getDocumentHeader() 伝票ヘッダを取得します｡
ArrayList | getExtension1List() カスタマ拡張テーブル一覧（Extension1インスタンスの配列）を取得します｡
String | getObjKey() 参照キーを取得します｡
String | getObjSys() 参照システムを取得します｡
String | getObjType() 参照処理を取得します｡
ArrayList | getTravelAmountList() 旅費資金計画通貨項目一覧（TravelAmountインスタンスの配列）を取得します｡
ArrayList | getTravelList() 旅費資金予算明細一覧（Travelインスタンスの配列）を取得します｡
void | setAccountGlList(ArrayList accountGlList) G/L 勘定明細一覧を設定します｡
void | setAccountPayableList(ArrayList accountPayableList) 仕入先明細一覧を設定します｡
void | setAccountTaxList(ArrayList accountTaxList) 税明細一覧を設定します｡
void | setCuAmtBase(String cuAmtBase, int index) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur(String cuAmtDoccur, int index) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency(String cuCurrency, int index) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc(String cuItemnoAcc, int index) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setCurrencyAmountList(ArrayList currencyAmountList) 明細通貨項目一覧を設定します｡
void | setDocAcDocNo(String docAcDocNo) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode(String docCompCode) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate(String docDocDate) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType(String docDocType) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFiscYear(String docFiscYear) 伝票ヘッダの会計年度に値を設定します。
void | setDocFisPeriod(String docFisPeriod) 伝票ヘッダの会計期間に値を設定します。
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey(String docObjKey) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType(String docObjType) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate(String docPstngDate) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo(String docRefDocNo) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocumentHeader(DocumentHeader documentHeader) 伝票ヘッダを設定します｡
void | setDocUsername(String docUsername) 伝票ヘッダのユーザ名に値を設定します。
void | setExportParam(BapiController bapiController) 伝票に登録された情報をセットします。
void | setExtension1List(ArrayList extension1List) カスタマ拡張テーブル一覧を設定します｡
void | setGlAllocNmbr(String glAllocNmbr, int index) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea(String glBusArea, int index) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode(String glCompCode, int index) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter(String glCostcenter, int index) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType(String glDocType, int index) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear(String glFiscYear, int index) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount(String glGlAccount, int index) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemnoAcc(String glItemnoAcc, int index) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlItemText(String glItemText, int index) G/L 勘定明細の明細テキストに値を設定します。
void | setGlOrderid(String glOrderid, int index) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate(String glPstngDate, int index) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1(String glRefKey1, int index) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode(String glTaxCode, int index) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement(String glWbsElement, int index) G/L 勘定明細のWBS 要素に値を設定します。
void | setImportParam(BapiController bapiController) 伝票に登録する値をセットします。
void | setObjKey(String objKey) 参照キーを設定します｡
void | setObjSys(String objSys) 参照システムを設定します｡
void | setObjType(String objType) 参照処理を設定します｡
void | setPaAllocNmbr(String paAllocNmbr, int index) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate(String paBlineDate, int index) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount(String paGlAccount, int index) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemnoAcc(String paItemnoAcc, int index) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaItemText(String paItemText, int index) 仕入先明細の明細テキストに値を設定します。
void | setPaPymtMeth(String paPymtMeth, int index) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo(String paVendorNo, int index) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | setTaGlAccount(String taGlAccount, int index) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc(String taItemnoAcc, int index) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode(String taTaxCode, int index) 税明細の消費税コードに値を設定します。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setTravelAmountList(ArrayList travelAmountList) 旅費資金計画通貨項目一覧を設定します｡
void | setTravelList(ArrayList travelList) 旅費資金予算明細一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccEmployeePayPost

public AccEmployeePayPost()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡

AccEmployeePayPost

public AccEmployeePayPost(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi(jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController)実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connetionManager - コネクションマネージャー

AccEmployeePayPost

public AccEmployeePayPost(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
会計伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralAppException,
                           SAPGeneralSystemException
伝票に登録する値をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setDocObjType

public void setDocObjType(String docObjType)
伝票ヘッダの参照処理に値を設定します。

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
伝票ヘッダのユーザ名に値を設定します。

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
伝票ヘッダの会社コードに値を設定します。

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
伝票ヘッダの会計伝票番号に値を設定します。

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
伝票ヘッダの会計年度に値を設定します。

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
伝票ヘッダの会計期間に値を設定します。

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票ヘッダの伝票タイプに値を設定します。

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
伝票ヘッダの参照伝票番号に値を設定します。

パラメータ:
docRefDocNo - 参照伝票番号

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc,
                           int index)
仕入先明細の会計伝票明細番号に値を設定します。

パラメータ:
paItemnoAcc - 会計伝票明細番号
index - レコード番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo,
                          int index)
仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード
index - レコード番号

setPaGlAccount

public void setPaGlAccount(String paGlAccount,
                           int index)
仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ:
paGlAccount - 総勘定元帳勘定
index - レコード番号

setPaBlineDate

public void setPaBlineDate(String paBlineDate,
                           int index)
仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ:
paBlineDate - 期日計算の支払基準日
index - レコード番号

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth,
                          int index)
仕入先明細の支払方法に値を設定します。

パラメータ:
paPymtMeth - 支払方法
index - レコード番号

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr,
                           int index)
仕入先明細のソートキーに値を設定します。

パラメータ:
paAllocNmbr - ソートキー
index - レコード番号

setPaItemText

public void setPaItemText(String paItemText,
                          int index)
仕入先明細の明細テキストに値を設定します。

パラメータ:
paItemText - 明細テキスト
index - レコード番号

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc,
                           int index)
G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ:
glItemnoAcc - 会計伝票明細番号
index - レコード番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount,
                           int index)
G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ:
glGlAccount - 総勘定元帳勘定
index - レコード番号

setGlCompCode

public void setGlCompCode(String glCompCode,
                          int index)
G/L 勘定明細の会社コードに値を設定します。

パラメータ:
glCompCode - 会社コード
index - レコード番号

setGlPstngDate

public void setGlPstngDate(String glPstngDate,
                           int index)
G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ:
glPstngDate - 伝票の転記日付
index - レコード番号

setGlDocType

public void setGlDocType(String glDocType,
                         int index)
G/L 勘定明細の伝票タイプに値を設定します。

パラメータ:
glDocType - 伝票タイプ
index - レコード番号

setGlFiscYear

public void setGlFiscYear(String glFiscYear,
                          int index)
G/L 勘定明細の会計年度に値を設定します。

パラメータ:
glFiscYear - 会計年度
index - レコード番号

setGlRefKey1

public void setGlRefKey1(String glRefKey1,
                         int index)
G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ:
glRefKey1 - 取引先参照キー
index - レコード番号

setGlItemText

public void setGlItemText(String glItemText,
                          int index)
G/L 勘定明細の明細テキストに値を設定します。

パラメータ:
glItemText - 明細テキスト
index - レコード番号

setGlTaxCode

public void setGlTaxCode(String glTaxCode,
                         int index)
G/L 勘定明細の消費税コードに値を設定します。

パラメータ:
glTaxCode - 消費税コード
index - レコード番号

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr,
                           int index)
G/L 勘定明細のソートキーに値を設定します。

パラメータ:
glAllocNmbr - ソートキー
index - レコード番号

setGlBusArea

public void setGlBusArea(String glBusArea,
                         int index)
G/L 勘定明細の事業領域に値を設定します。

パラメータ:
glBusArea - 事業領域
index - レコード番号

setGlCostcenter

public void setGlCostcenter(String glCostcenter,
                            int index)
G/L 勘定明細の原価センタに値を設定します。

パラメータ:
glCostcenter - 原価センタ
index - レコード番号

setGlOrderid

public void setGlOrderid(String glOrderid,
                         int index)
G/L 勘定明細の指図番号に値を設定します。

パラメータ:
glOrderid - 指図番号
index - レコード番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement,
                            int index)
G/L 勘定明細のWBS 要素に値を設定します。

パラメータ:
glWbsElement - WBS 要素
index - レコード番号

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc,
                           int index)
税明細の会計伝票明細番号に値を設定します。

パラメータ:
taItemnoAcc - 会計伝票明細番号
index - レコード番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount,
                           int index)
税明細の総勘定元帳勘定に値を設定します。

パラメータ:
taGlAccount - 総勘定元帳勘定
index - レコード番号

setTaTaxCode

public void setTaTaxCode(String taTaxCode,
                         int index)
税明細の消費税コードに値を設定します。

パラメータ:
taTaxCode - 消費税コード
index - レコード番号

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc,
                           int index)
明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ:
cuItemnoAcc - 会計伝票明細番号
index - レコード番号

setCuCurrency

public void setCuCurrency(String cuCurrency,
                          int index)
明細通貨項目の通貨コードに値を設定します。

パラメータ:
cuCurrency - 通貨コード
index - レコード番号

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur,
                           int index)
明細通貨項目の伝票通貨額に値を設定します。

パラメータ:
cuAmtDoccur - 伝票通貨額
index - レコード番号

setCuAmtBase

public void setCuAmtBase(String cuAmtBase,
                         int index)
明細通貨項目の課税基準額に値を設定します。

パラメータ:
cuAmtBase - 課税基準額
index - レコード番号

setObjType

public void setObjType(String objType)
参照処理を設定します｡

パラメータ:
objType - 参照処理

setObjSys

public void setObjSys(String objSys)
参照システムを設定します｡

パラメータ:
objSys - 参照システム

setObjKey

public void setObjKey(String objKey)
参照キーを設定します｡

パラメータ:
objKey - 参照キー

setDocumentHeader

public void setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setAccountPayableList

public void setAccountPayableList(ArrayList accountPayableList)
仕入先明細一覧を設定します｡

パラメータ:
accountPayableList - 仕入先明細一覧（AccountPayableインスタンスの配列）
関連項目:
AccountPayable

setAccountGlList

public void setAccountGlList(ArrayList accountGlList)
G/L 勘定明細一覧を設定します｡

パラメータ:
accountGlList - G/L 勘定明細一覧（AccountGlインスタンスの配列）
関連項目:
AccountGl

setAccountTaxList

public void setAccountTaxList(ArrayList accountTaxList)
税明細一覧を設定します｡

パラメータ:
accountTaxList - 税明細一覧（AccountTaxインスタンスの配列）
関連項目:
AccountTax

setCurrencyAmountList

public void setCurrencyAmountList(ArrayList currencyAmountList)
明細通貨項目一覧を設定します｡

パラメータ:
currencyAmountList - 明細通貨項目一覧（CurrencyAmountインスタンスの配列）
関連項目:
CurrencyAmount

setTravelAmountList

public void setTravelAmountList(ArrayList travelAmountList)
旅費資金計画通貨項目一覧を設定します｡

パラメータ:
travelAmountList - 旅費資金計画通貨項目一覧（TravelAmountインスタンスの配列）
関連項目:
jp.co.intra_mart.foundation.sap.module.accounting.travelAmount

setTravelList

public void setTravelList(ArrayList travelList)
旅費資金予算明細一覧を設定します｡

パラメータ:
travelList - 旅費資金予算明細一覧（TravelListインスタンスの配列）
関連項目:
Travel

setExtension1List

public void setExtension1List(ArrayList extension1List)
カスタマ拡張テーブル一覧を設定します｡

パラメータ:
extension1List - カスタマ拡張テーブル一覧（Extension1Listインスタンスの配列）
関連項目:
Extension1

getObjType

public String getObjType()
参照処理を取得します｡

戻り値:
objKey

getObjSys

public String getObjSys()
参照システムを取得します｡

戻り値:
objSys

getObjKey

public String getObjKey()
参照キーを取得します｡

戻り値:
objKey

getDocumentHeader

public DocumentHeader getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader

getAccountPayableList

public ArrayList getAccountPayableList()
仕入先明細一覧（AccountPayableインスタンスの配列）を取得します｡

戻り値:
accountPayableList
関連項目:
AccountPayable

getAccountGlList

public ArrayList getAccountGlList()
G/L 勘定明細一覧（AccountGlインスタンスの配列）を取得します｡

戻り値:
accountGlList
関連項目:
AccountGl

getAccountTaxList

public ArrayList getAccountTaxList()
税明細一覧（AccountTaxインスタンスの配列）を取得します｡

戻り値:
accountTaxList
関連項目:
AccountTax

getCurrencyAmountList

public ArrayList getCurrencyAmountList()
明細通貨項目一覧（CurrencyAmountインスタンスの配列）を取得します｡

戻り値:
currencyAmountList
関連項目:
CurrencyAmount

getTravelAmountList

public ArrayList getTravelAmountList()
旅費資金計画通貨項目一覧（TravelAmountインスタンスの配列）を取得します｡

戻り値:
travelAmountList
関連項目:
TravelAmount

getTravelList

public ArrayList getTravelList()
旅費資金予算明細一覧（Travelインスタンスの配列）を取得します｡

戻り値:
travelList
関連項目:
Travel

getExtension1List

public ArrayList getExtension1List()
カスタマ拡張テーブル一覧（Extension1インスタンスの配列）を取得します｡

戻り値:
extension1List
関連項目:
Extension1

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPAccountingSystemException
構造型の項目に値をセットします。
伝票ヘッダ構造型の設定方法は以下のとおりです。
構造名：「DocumentHeader」
項目名：伝票ヘッダの項目は以下のとおりです。
伝票ヘッダ
オブジェクト
(Object)
OBJ_TYPE 参照処理 (String)
OBJ_KEY オブジェクトキー (String)
OBJ_SYS 元伝票の論理システム (String)
USERNAME ユーザ名 (String)
HEADER_TXT 伝票ヘッダテキスト (String)
OBJ_KEY_R 取消: オブジェクトキー (AWREF_REV と AWORG_REV) (String)
BUS_ACT 取引 (String)
COMP_CODE 会社コード (String)
AC_DOC_NO 会計伝票番号 (String)
FISC_YEAR 会計年度 (String)
DOC_DATE 伝票の伝票日付 (String)
PSTNG_DATE 伝票の転記日付 (String)
FIS_PERIOD 会計期間 (String)
DOC_TYPE 伝票タイプ (String)
REF_DOC_NO 参照伝票番 (String)
COMPO_ACC ACC インタフェースの構成要素 (String)
TAX_COMP_CODE 税会社コード(String)
REASON_REV 反対仕訳理由 (String)
REF_DOC_NO_LONG 参照伝票番号 (依存性についてはテキスト長参照) (String)
NEG_POSTNG フラグ: マイナス転記 (String)

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPAccountingSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPAccountingSystemException
テーブル型の項目に値をセットします。
仕入先明細テーブルの設定方法は以下のとおりです。
テーブル名：「AccountPayable」
項目名：仕入先明細の項目は以下のとおりです。
仕入先明細
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
VENDOR_NO 仕入先または債権者の勘定コード (String)
REF_KEY_1 取引先参照キー (String)
REF_KEY_2 取引先参照キー (String)
REF_KEY_3 明細の参照キー (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
BLINE_DATE 期日計算の支払基準日 (String)
PMTMTHSUPL 支払方法追加 (String)
PYMT_METH 支払方法 (String)
BLLSRV_IND サービスコード (外貨支払) (String)
ALLOC_NMBR ソートキー (String)
ITEM_TEXT 明細テキスト (String)
ACCT_KEY 内部処理キー (String)
SCBANK_IND 中央銀行コード (String)
PYMT_AMT 支払通貨額 (String)
PYMT_CUR 自動支払通貨 (String)
PYMT_CUR_ISO ISO コード通貨(String)
PROFIT_CTR 利益センタ (String)
PART_PRCTR パートナ利益センタ(String)
SEGMENT セグメントレポートのセグメント (String)
PARTNER_SEGMENT セグメントレポートのパートナセグメント(String)
FUND ファンド(String)
PARTNER_FUND パートナファンド(String)
GRANT_NBR 補助金(String)
PARTNER_GRANT_NBR パートナ補助金(String)
BUS_AREA 事業領域(String)
TR_PART_BA 取引先事業領域 (String)
NEG_POSTNG フラグ: マイナス転記(String)

G/L勘定明細テーブルの設定方法は以下のとおりです。
テーブル名：「AccountGl」
項目名：G/L勘定明細の項目は以下のとおりです。
G/L勘定明細
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
COMP_CODE 会社コード (String)
PSTNG_DATE 伝票の転記日付 (String)
DOC_TYPE 伝票タイプ (String)
AC_DOC_NO 会計伝票番号 (String)
FISC_YEAR 会計年度 (String)
FIS_PERIOD 会計期間 (String)
STLMNT_PER 決済期間 (String)
REF_KEY_1 取引先参照キー(String)
REF_KEY_2 取引先参照キー (String)
REF_KEY_3 明細の参照キー (String)
ACCT_KEY 内部処理キー (String)
ITEM_TEXT 明細テキスト (String)
TAX_CODE 売上税コード (String)
TAXJURCODE 税管轄(String)
ALLOC_NMBR ソートキー (String)
BUS_AREA 事業領域(String)
PERSON_NO 従業員番号 (String)
COSTCENTER 原価センタ(String)
ORDERID 指図番号(String)
COST_OBJ 原価対象(String)
ACTIVITY 作業/活動番号(String)
QUANTITY 数量 (String)
BASE_UOM 基本数量単位(String)
WBS_ELEMENT WBS 要素 (String)
NETWORK 勘定割当のネットワーク番号(String)
CMMT_ITEM 予算コード(String)
FUNDS_CTR 予算センタ(String)
FUND ファンド(String)
SALES_ORD 受注伝票番号(String)
S_ORD_ITEM 受注明細番号(String)
ACTTYPE 活動タイプ(String)
OBJ_TYP_P 前伝票: 参照処理(String)
OBJ_KEY_P 前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)(String)
OBJ_POS_P 前伝票: 参照明細(String)
TRADE_ID 取引先の会社 ID(String)
CMMT_ITEM_LONG 前伝票: 参照明細(String)
OBJ_POS_P 予算コード(String)
GRANT_NBR 補助金(String)
FUNC_AREA_LONG 前機能領域(String)
PROFIT_CTR 利益センタ(String)
PART_PRCTR パートナ利益センタ(String)
SEGMENT セグメントレポートのセグメント(String)
PARTNER_SEGMENT セグメントレポートのパートナセグメント(String)
PARTNER_FUND パートナファンド(String)
PARTNER_GRANT_NBR パートナ補助金(String)
TR_PART_BA 取引先事業領域(String)
NEG_POSTNG フラグ: マイナス転記(String)

税明細テーブルの設定方法は以下のとおりです。
テーブル名：「AccountTax」
項目名：税明細の項目は以下のとおりです。
税明細
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
GL_ACCOUNT 総勘定元帳勘定 (String)
TAX_CODE 売上税コード (String)
ACCT_KEY 内部処理キー (String)
TAXJURCODE 税管轄 (String)
COND_KEY 条件タイプ (String)
TAX_RATE 税率 (String)
TAX_DATE 税率定義の日付 (String)
STAT_CON 統計に適用する条件 (String)
TAXJURCODE_DEEP 税管轄コード - 最下位レベル税管轄(String)
TAXJURCODE_LEVEL 税管轄コードレベル (String)
NEG_POSTNG フラグ: マイナス転記 (String)

明細通貨項目テーブルの設定方法は以下のとおりです。
テーブル名：「CurrencyAmount」
項目名：/明細通貨項目の項目は以下のとおりです。
明細通貨項目
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
CURR_TYPE 通貨タイプおよび評価ビュー (String)
CURRENCY 通貨コード(String)
AMT_DOCCUR 伝票通貨額 (String)
EXCH_RATE 換算レート (String)
AMT_BASE 課税基準額 (伝票通貨建て) (String)
EXCH_RATE_V 間接呼び値換算レート (String)
CURRENCY_ISO ISO コード通貨 (String)

明細通貨項目テーブルの設定方法は以下のとおりです。
テーブル名：「CurrencyAmount」
項目名：/明細通貨項目の項目は以下のとおりです。
明細通貨項目
オブジェクト
(Object)
ITEMNO_ACC 会計伝票明細番号 (String)
CURR_TYPE 通貨タイプおよび評価ビュー (String)
CURRENCY 通貨コード(String)
AMT_DOCCUR 伝票通貨額 (String)
EXCH_RATE 換算レート (String)
AMT_BASE 課税基準額 (伝票通貨建て) (String)
EXCH_RATE_V 間接呼び値換算レート (String)
CURRENCY_ISO ISO コード通貨 (String)

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPAccountingSystemException - 会計業務システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccEmployeePayPostController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccEmployeePayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost
                拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController
すべての実装インタフェース:
Serializable
public class AccEmployeePayPostController
extends AccEmployeePayPost
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。
メソッドの概要
 void executeBapi()
BapiControllerにより会計伝票を登録します。
クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost から継承したメソッド
executeBapi, getAccountGlList, getAccountPayableList, getAccountTaxList, getCurrencyAmountList, getDocumentHeader, getExtension1List, getObjKey, getObjSys, getObjType, getTravelAmountList, getTravelList, setAccountGlList, setAccountPayableList, setAccountTaxList, setCuAmtBase, setCuAmtDoccur, setCuCurrency, setCuItemnoAcc, setCurrencyAmountList, setDocAcDocNo, setDocCompCode, setDocDocDate, setDocDocType, setDocFiscYear, setDocFisPeriod, setDocHeaderTxt, setDocObjKey, setDocObjType, setDocPstngDate, setDocRefDocNo, setDocumentHeader, setDocUsername, setExportParam, setExtension1List, setGlAllocNmbr, setGlBusArea, setGlCompCode, setGlCostcenter, setGlDocType, setGlFiscYear, setGlGlAccount, setGlItemnoAcc, setGlItemText, setGlOrderid, setGlPstngDate, setGlRefKey1, setGlTaxCode, setGlWbsElement, setImportParam, setObjKey, setObjSys, setObjType, setPaAllocNmbr, setPaBlineDate, setPaGlAccount, setPaItemnoAcc, setPaItemText, setPaPymtMeth, setPaVendorNo, setStrParam, setTaGlAccount, setTaItemnoAcc, setTaTaxCode, setTblParam, setTravelAmountList, setTravelList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccEmployeePayPostController

public AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡

AccEmployeePayPostController

public AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connetionManager - コネクションマネージャー

AccEmployeePayPostController

public AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingAppException,
                        SAPAccountingSystemException
BapiControllerにより会計伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingAppException - 会計業務アプリケーション例外
SAPAccountingSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountGl (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountGl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountGl
すべての実装インタフェース:
Serializable
public class AccountGl
extends Object
implements Serializable

G/L 勘定明細クラス
機能は以下の通り

  • G/L 勘定明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountGl()
G/L 勘定明細情報を作成します。
AccountGl(int index)
G/L 勘定明細情報を作成します。
メソッドの概要
String | getAcctKey() 内部処理キーを取得します｡
String | getAcDocNo() 会計伝票番号を取得します｡
String | getActivity() 作業/活動番号を取得します｡
String | getActtype() 活動タイプを取得します｡
String | getAllocNmbr() ソートキーを取得します｡
String | getBaseUom() 基本数量単位を取得します｡
String | getBaseUomIso() ISO コードでの基本数量単位を取得します｡
String | getBusArea() 事業領域を取得します｡
String | getCmmtItem() 予算コードを取得します｡
String | getCmmtItemLong() 予算コードを取得します｡
String | getCompCode() 会社コードを取得します｡
String | getCostcenter() 原価センタを取得します｡
String | getCostObj() 原価対象を取得します｡
String | getDocType() 伝票タイプを取得します｡
String | getFiscYear() 会計年度を取得します｡
String | getFisPeriod() 会計期間を取得します｡
String | getFuncAreaLong() 機能領域を取得します｡
String | getFund() ファンドを取得します｡
String | getFundsCtr() 予算センタを取得します｡
String | getGlAccount() 総勘定元帳勘定を取得します｡
int | getGlIndex() レコード番号を取得します｡
String | getGrantNbr() 補助金を取得します｡
String | getItemnoAcc() 会計伝票明細番号を取得します｡
String | getItemText() 明細テキストを取得します｡
String | getNegPostng() フラグ: マイナス転記を取得します｡
String | getNetwork() 勘定割当のネットワーク番号を取得します｡
String | getObjKeyP() 前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)を取得します｡
String | getObjPosP() 前伝票: 参照明細を取得します｡
String | getObjTypP() 前伝票: 参照処理を取得します｡
String | getOrderid() 指図番号を取得します｡
String | getPartnerFund() パートナファンドを取得します｡
String | getPartnerGrantNbr() パートナ補助金を取得します｡
String | getPartnerSegment() セグメントレポートのパートナセグメントを取得します｡
String | getPartPrctr() パートナ利益センタを取得します｡
String | getPersonNo() 従業員番号を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getPstngDate() 伝票の転記日付を取得します｡
String | getQuantity() 数量を取得します｡
String | getRefKey1() 取引先参照キーを取得します｡
String | getRefKey2() 取引先参照キーを取得します｡
String | getRefKey3() 明細の参照キーを取得します｡
String | getSalesOrd() 受注伝票番号を取得します｡
String | getSegment() セグメントレポートのセグメントを取得します｡
String | getSOrdItem() 受注明細番号を取得します｡
String | getStlmntPer() 決済期間を取得します｡
String | getTaxCode() 消費税コードを取得します｡
String | getTaxjurcode() 税管轄を取得します｡
String | getTradeId() 取引先の会社 IDを取得します｡
String | getTrPartBa() 取引先事業領域を取得します｡
String | getWbsElement() WBS 要素を取得します｡
void | setAcctKey(String acctKey) 内部処理キーを設定します｡
void | setAcDocNo(String acDocNo) 会計伝票番号を設定します｡
void | setActivity(String activity) 作業/活動番号を設定します｡
void | setActtype(String acttype) 活動タイプを設定します｡
void | setAllocNmbr(String allocNmbr) ソートキーを設定します｡
void | setBaseUom(String baseUom) 基本数量単位を設定します｡
void | setBaseUomIso(String baseUomIso) ISO コードでの基本数量単位を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
void | setCmmtItem(String cmmtItem) 予算コードを設定します｡
void | setCmmtItemLong(String cmmtItemLong) 予算コードを設定します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCostcenter(String costcenter) 原価センタを設定します｡
void | setCostObj(String costObj) 原価対象を設定します｡
void | setDocType(String docType) 伝票タイプを設定します｡
void | setFiscYear(String fiscYear) 会計年度を設定します｡
void | setFisPeriod(String fisPeriod) 会計期間を設定します｡
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します｡
void | setFund(String fund) ファンドを設定します｡
void | setFundsCtr(String fundsCtr) 予算センタを設定します｡
void | setGlAccount(String glAccount) 総勘定元帳勘定を設定します｡
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGrantNbr(String grantNbr) 補助金を設定します｡
void | setItemnoAcc(String itemnoAcc) 会計伝票明細番号を設定します｡
void | setItemText(String itemText) 明細テキストを設定します｡
void | setNegPostng(String negPostng) フラグ: マイナス転記を設定します｡
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します｡
void | setObjKeyP(String objKeyP) 前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)を設定します｡
void | setObjPosP(String objPosP) 前伝票: 参照明細を設定します｡
void | setObjTypP(String objTypP) 前伝票: 参照処理を設定します｡
void | setOrderid(String orderid) 指図番号を設定します｡
void | setPartnerFund(String partnerFund) パートナファンドを設定します｡
void | setPartnerGrantNbr(String partnerGrantNbr) パートナ補助金を設定します｡
void | setPartnerSegment(String partnerSegment) セグメントレポートのパートナセグメントを設定します｡
void | setPartPrctr(String partPrctr) パートナ利益センタを設定します｡
void | setPersonNo(String personNo) 従業員番号を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setPstngDate(String pstngDate) 伝票の転記日付を設定します｡
void | setQuantity(String quantity) 数量を設定します｡
void | setRefKey1(String refKey1) 取引先参照キーを設定します｡
void | setRefKey2(String refKey2) 取引先参照キーを設定します｡
void | setRefKey3(String refKey3) 明細の参照キーを設定します｡
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します｡
void | setSegment(String segment) セグメントレポートのセグメントを設定します｡
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します｡
void | setStlmntPer(String stlmntPer) 決済期間を設定します｡
void | setTaxCode(String taxCode) 消費税コードを設定します｡
void | setTaxjurcode(String taxjurcode) 税管轄を設定します｡
void | setTradeId(String tradeId) 取引先の会社 IDを設定します｡
void | setTrPartBa(String trPartBa) 取引先事業領域を設定します｡
void | setWbsElement(String wbsElement) WBS 要素を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountGl

public AccountGl()
G/L 勘定明細情報を作成します。

AccountGl

public AccountGl(int index)
G/L 勘定明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setItemnoAcc

public void setItemnoAcc(String itemnoAcc)
会計伝票明細番号を設定します｡

パラメータ:
itemnoAcc - 会計伝票明細番号

setGlAccount

public void setGlAccount(String glAccount)
総勘定元帳勘定を設定します｡

パラメータ:
glAccount - 総勘定元帳勘定

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setPstngDate

public void setPstngDate(String pstngDate)
伝票の転記日付を設定します｡

パラメータ:
pstngDate - 伝票の転記日付

setDocType

public void setDocType(String docType)
伝票タイプを設定します｡

パラメータ:
docType - 伝票タイプ

setAcDocNo

public void setAcDocNo(String acDocNo)
会計伝票番号を設定します｡

パラメータ:
acDocNo - 会計伝票番号

setFiscYear

public void setFiscYear(String fiscYear)
会計年度を設定します｡

パラメータ:
fiscYear - 会計年度

setFisPeriod

public void setFisPeriod(String fisPeriod)
会計期間を設定します｡

パラメータ:
fisPeriod - 会計期間

setStlmntPer

public void setStlmntPer(String stlmntPer)
決済期間を設定します｡

パラメータ:
stlmntPer - 決済期間

setRefKey1

public void setRefKey1(String refKey1)
取引先参照キーを設定します｡

パラメータ:
refKey1 - 取引先参照キー

setRefKey2

public void setRefKey2(String refKey2)
取引先参照キーを設定します｡

パラメータ:
refKey2 - 取引先参照キー

setRefKey3

public void setRefKey3(String refKey3)
明細の参照キーを設定します｡

パラメータ:
refKey3 - 明細の参照キー

setItemText

public void setItemText(String itemText)
明細テキストを設定します｡

パラメータ:
itemText - 明細テキスト

setTaxCode

public void setTaxCode(String taxCode)
消費税コードを設定します｡

パラメータ:
taxCode - 消費税コード

setAcctKey

public void setAcctKey(String acctKey)
内部処理キーを設定します｡

パラメータ:
acctKey - 内部処理キー

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税管轄を設定します｡

パラメータ:
taxjurcode - 税管轄

setAllocNmbr

public void setAllocNmbr(String allocNmbr)
ソートキーを設定します｡

パラメータ:
allocNmbr - ソートキー

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setPersonNo

public void setPersonNo(String personNo)
従業員番号を設定します｡

パラメータ:
personNo - 従業員番号

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します｡

パラメータ:
costcenter - 原価センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します｡

パラメータ:
orderid - 指図番号

setCostObj

public void setCostObj(String costObj)
原価対象を設定します｡

パラメータ:
costObj - 原価対象

setActivity

public void setActivity(String activity)
作業/活動番号を設定します｡

パラメータ:
activity - 作業/活動番号

setQuantity

public void setQuantity(String quantity)
数量を設定します｡

パラメータ:
quantity - 数量

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します｡

パラメータ:
baseUom - 基本数量単位

setBaseUomIso

public void setBaseUomIso(String baseUomIso)
ISO コードでの基本数量単位を設定します｡

パラメータ:
baseUomIso - ISO コードでの基本数量単位

setWbsElement

public void setWbsElement(String wbsElement)
WBS 要素を設定します｡

パラメータ:
wbsElement - WBS 要素

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します｡

パラメータ:
network - 勘定割当のネットワーク番号

setCmmtItem

public void setCmmtItem(String cmmtItem)
予算コードを設定します｡

パラメータ:
cmmtItem - 予算コード

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します｡

パラメータ:
fundsCtr - 予算センタ

setFund

public void setFund(String fund)
ファンドを設定します｡

パラメータ:
fund - ファンド

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します｡

パラメータ:
salesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します｡

パラメータ:
sOrdItem - 受注明細番号

setActtype

public void setActtype(String acttype)
活動タイプを設定します｡

パラメータ:
acttype - 活動タイプ

setObjTypP

public void setObjTypP(String objTypP)
前伝票: 参照処理を設定します｡

パラメータ:
objTypP - 前伝票: 参照処理

setObjKeyP

public void setObjKeyP(String objKeyP)
前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)を設定します｡

パラメータ:
objKeyP - 前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)

setObjPosP

public void setObjPosP(String objPosP)
前伝票: 参照明細を設定します｡

パラメータ:
objPosP - 前伝票: 参照明細

setTradeId

public void setTradeId(String tradeId)
取引先の会社 IDを設定します｡

パラメータ:
tradeId - 取引先の会社 ID

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
予算コードを設定します｡

パラメータ:
cmmtItemLong - 予算コード

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します｡

パラメータ:
grantNbr - 補助金

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します｡

パラメータ:
funcAreaLong - 機能領域

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setPartPrctr

public void setPartPrctr(String partPrctr)
パートナ利益センタを設定します｡

パラメータ:
partPrctr - パートナ利益センタ

setSegment

public void setSegment(String segment)
セグメントレポートのセグメントを設定します｡

パラメータ:
segment - セグメントレポートのセグメント

setPartnerSegment

public void setPartnerSegment(String partnerSegment)
セグメントレポートのパートナセグメントを設定します｡

パラメータ:
partnerSegment - セグメントレポートのパートナセグメント

setPartnerFund

public void setPartnerFund(String partnerFund)
パートナファンドを設定します｡

パラメータ:
partnerFund - パートナファンド

setPartnerGrantNbr

public void setPartnerGrantNbr(String partnerGrantNbr)
パートナ補助金を設定します｡

パラメータ:
partnerGrantNbr - パートナ補助金

setTrPartBa

public void setTrPartBa(String trPartBa)
取引先事業領域を設定します｡

パラメータ:
trPartBa - 取引先事業領域

setNegPostng

public void setNegPostng(String negPostng)
フラグ: マイナス転記を設定します｡

パラメータ:
negPostng - フラグ: マイナス転記

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

getItemnoAcc

public String getItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
itemnoAcc

getGlAccount

public String getGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glAccount

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します｡

戻り値:
pstngDate

getDocType

public String getDocType()
伝票タイプを取得します｡

戻り値:
docType

getAcDocNo

public String getAcDocNo()
会計伝票番号を取得します｡

戻り値:
acDocNo

getFiscYear

public String getFiscYear()
会計年度を取得します｡

戻り値:
fiscYear

getFisPeriod

public String getFisPeriod()
会計期間を取得します｡

戻り値:
fisPeriod

getStlmntPer

public String getStlmntPer()
決済期間を取得します｡

戻り値:
stlmntPer

getRefKey1

public String getRefKey1()
取引先参照キーを取得します｡

戻り値:
refKey1

getRefKey2

public String getRefKey2()
取引先参照キーを取得します｡

戻り値:
refKey2

getRefKey3

public String getRefKey3()
明細の参照キーを取得します｡

戻り値:
refKey3

getItemText

public String getItemText()
明細テキストを取得します｡

戻り値:
itemText

getTaxCode

public String getTaxCode()
消費税コードを取得します｡

戻り値:
taxCode

getAcctKey

public String getAcctKey()
内部処理キーを取得します｡

戻り値:
acctKey

getTaxjurcode

public String getTaxjurcode()
税管轄を取得します｡

戻り値:
taxjurcode

getAllocNmbr

public String getAllocNmbr()
ソートキーを取得します｡

戻り値:
allocNmbr

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
busArea

getPersonNo

public String getPersonNo()
従業員番号を取得します｡

戻り値:
personNo

getCostcenter

public String getCostcenter()
原価センタを取得します｡

戻り値:
costcenter

getOrderid

public String getOrderid()
指図番号を取得します｡

戻り値:
orderid

getCostObj

public String getCostObj()
原価対象を取得します｡

戻り値:
costObj

getActivity

public String getActivity()
作業/活動番号を取得します｡

戻り値:
activity

getQuantity

public String getQuantity()
数量を取得します｡

戻り値:
quantity

getBaseUom

public String getBaseUom()
基本数量単位を取得します｡

戻り値:
baseUom

getBaseUomIso

public String getBaseUomIso()
ISO コードでの基本数量単位を取得します｡

戻り値:
baseUomIso

getWbsElement

public String getWbsElement()
WBS 要素を取得します｡

戻り値:
wbsElement

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します｡

戻り値:
network

getCmmtItem

public String getCmmtItem()
予算コードを取得します｡

戻り値:
cmmtItem

getFundsCtr

public String getFundsCtr()
予算センタを取得します｡

戻り値:
fundsCtr

getFund

public String getFund()
ファンドを取得します｡

戻り値:
fund

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します｡

戻り値:
salesOrd

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します｡

戻り値:
sOrdItem

getActtype

public String getActtype()
活動タイプを取得します｡

戻り値:
acttype

getObjTypP

public String getObjTypP()
前伝票: 参照処理を取得します｡

戻り値:
objTypP

getObjKeyP

public String getObjKeyP()
前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)を取得します｡

戻り値:
objKeyP

getObjPosP

public String getObjPosP()
前伝票: 参照明細を取得します｡

戻り値:
objPosP

getTradeId

public String getTradeId()
取引先の会社 IDを取得します｡

戻り値:
tradeId

getCmmtItemLong

public String getCmmtItemLong()
予算コードを取得します｡

戻り値:
cmmtItemLong

getGrantNbr

public String getGrantNbr()
補助金を取得します｡

戻り値:
grantNbr

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します｡

戻り値:
funcAreaLong

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getPartPrctr

public String getPartPrctr()
パートナ利益センタを取得します｡

戻り値:
partPrctr

getSegment

public String getSegment()
セグメントレポートのセグメントを取得します｡

戻り値:
segment

getPartnerSegment

public String getPartnerSegment()
セグメントレポートのパートナセグメントを取得します｡

戻り値:
segment

getPartnerFund

public String getPartnerFund()
パートナファンドを取得します｡

戻り値:
segment

getPartnerGrantNbr

public String getPartnerGrantNbr()
パートナ補助金を取得します｡

戻り値:
segment

getTrPartBa

public String getTrPartBa()
取引先事業領域を取得します｡

戻り値:
trPartBa

getNegPostng

public String getNegPostng()
フラグ: マイナス転記を取得します｡

戻り値:
negPostng

getGlIndex

public int getGlIndex()
レコード番号を取得します｡

戻り値:
giIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPayable (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountPayable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable
すべての実装インタフェース:
Serializable
public class AccountPayable
extends Object
implements Serializable

仕入先明細クラス
機能は以下の通り

  • 仕入先明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountPayable()
仕入先明細情報を作成します。
AccountPayable(int index)
仕入先明細情報を作成します。
メソッドの概要
String | getAcctKey() 内部処理キーを取得します｡
String | getAllocNmbr() ソートキーを取得します｡
String | getBlineDate() 期日計算の支払基準日を取得します｡
String | getBllsrvInd() サービスコード (外貨支払)を取得します｡
String | getBusArea() 事業領域を取得します｡
String | getFund() ファンドを取得します｡
String | getGlAccount() 総勘定元帳勘定を取得します｡
String | getGrantNbr() 補助金を取得します｡
String | getItemnoAcc() 会計伝票明細番号を取得します｡
String | getItemText() 明細テキストを取得します｡
String | getNegPostng() フラグ: マイナス転記を取得します｡
int | getPaIndex() レコード番号を取得します｡
String | getPartnerFund() パートナファンドを取得します｡
String | getPartnerGrantNbr() パートナ補助金を取得します｡
String | getPartnerSegment() セグメントレポートのパートナセグメントを取得します｡
String | getPartPrctr() パートナ利益センタを取得します｡
String | getPmtmthsupl() 支払方法追加を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getPymtAmt() 支払通貨額を取得します｡
String | getPymtCur() 自動支払通貨を取得します｡
String | getPymtCurIso() ISO コード通貨を取得します｡
String | getPymtMeth() 支払方法を取得します｡
String | getRefKey1() 取引先参照キーを取得します｡
String | getRefKey2() 取引先参照キーを取得します｡
String | getRefKey3() 明細の参照キーを取得します｡
String | getScbankInd() 中央銀行コードを取得します｡
String | getSegment() セグメントレポートのセグメントを取得します｡
String | getTrPartBa() 取引先事業領域を取得します｡
String | getVendorNo() 仕入先または債権者の勘定コードを取得します｡
void | setAcctKey(String acctKey) 内部処理キーを設定します｡
void | setAllocNmbr(String allocNmbr) ソートキーを設定します｡
void | setBlineDate(String blineDate) 期日計算の支払基準日を設定します｡
void | setBllsrvInd(String bllsrvInd) サービスコード (外貨支払)を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
void | setFund(String fund) ファンドを設定します｡
void | setGlAccount(String glAccount) 総勘定元帳勘定を設定します｡
void | setGrantNbr(String grantNbr) 補助金を設定します｡
void | setItemnoAcc(String itemnoAcc) 会計伝票明細番号を設定します｡
void | setItemText(String itemText) 明細テキストを設定します｡
void | setNegPostng(String negPostng) フラグ: マイナス転記を設定します｡
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPartnerFund(String partnerFund) パートナファンドを設定します｡
void | setPartnerGrantNbr(String partnerGrantNbr) パートナ補助金を設定します｡
void | setPartnerSegment(String partnerSegment) セグメントレポートのパートナセグメントを設定します｡
void | setPartPrctr(String partPrctr) パートナ利益センタを設定します｡
void | setPmtmthsupl(String pmtmthsupl) 支払方法追加を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setPymtAmt(String pymtAmt) 支払通貨額を設定します｡
void | setPymtCur(String pymtCur) 自動支払通貨を設定します｡
void | setPymtCurIso(String pymtCurIso) ISO コード通貨を設定します｡
void | setPymtMeth(String pymtMeth) 支払方法を設定します｡
void | setRefKey1(String refKey1) 取引先参照キーを設定します｡
void | setRefKey2(String refKey2) 取引先参照キーを設定します｡
void | setRefKey3(String refKey3) 明細の参照キーを設定します｡
void | setScbankInd(String scbankInd) 中央銀行コードを設定します｡
void | setSegment(String segment) セグメントレポートのセグメントを設定します｡
void | setTrPartBa(String trPartBa) 取引先事業領域を設定します｡
void | setVendorNo(String vendorNo) 仕入先または債権者の勘定コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountPayable

public AccountPayable()
仕入先明細情報を作成します。

AccountPayable

public AccountPayable(int index)
仕入先明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setItemnoAcc

public void setItemnoAcc(String itemnoAcc)
会計伝票明細番号を設定します｡

パラメータ:
itemnoAcc - 会計伝票明細番号

setVendorNo

public void setVendorNo(String vendorNo)
仕入先または債権者の勘定コードを設定します｡

パラメータ:
vendorNo - 仕入先または債権者の勘定コード

setRefKey1

public void setRefKey1(String refKey1)
取引先参照キーを設定します｡

パラメータ:
refKey1 - 取引先参照キー

setRefKey2

public void setRefKey2(String refKey2)
取引先参照キーを設定します｡

パラメータ:
refKey2 - 取引先参照キー

setRefKey3

public void setRefKey3(String refKey3)
明細の参照キーを設定します｡

パラメータ:
refKey3 - 明細の参照キー

setGlAccount

public void setGlAccount(String glAccount)
総勘定元帳勘定を設定します｡

パラメータ:
glAccount - 総勘定元帳勘定

setBlineDate

public void setBlineDate(String blineDate)
期日計算の支払基準日を設定します｡

パラメータ:
blineDate - 期日計算の支払基準日

setPmtmthsupl

public void setPmtmthsupl(String pmtmthsupl)
支払方法追加を設定します｡

パラメータ:
pmtmthsupl - 支払方法追加

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します｡

パラメータ:
pymtMeth - 支払方法

setBllsrvInd

public void setBllsrvInd(String bllsrvInd)
サービスコード (外貨支払)を設定します｡

パラメータ:
bllsrvInd - サービスコード (外貨支払)

setAllocNmbr

public void setAllocNmbr(String allocNmbr)
ソートキーを設定します｡

パラメータ:
allocNmbr - ソートキー

setItemText

public void setItemText(String itemText)
明細テキストを設定します｡

パラメータ:
itemText - 明細テキスト

setAcctKey

public void setAcctKey(String acctKey)
内部処理キーを設定します｡

パラメータ:
acctKey - 内部処理キー

setScbankInd

public void setScbankInd(String scbankInd)
中央銀行コードを設定します｡

パラメータ:
scbankInd - 中央銀行コード

setPymtAmt

public void setPymtAmt(String pymtAmt)
支払通貨額を設定します｡

パラメータ:
pymtAmt - 支払通貨額

setPymtCur

public void setPymtCur(String pymtCur)
自動支払通貨を設定します｡

パラメータ:
pymtCur - 自動支払通貨

setPymtCurIso

public void setPymtCurIso(String pymtCurIso)
ISO コード通貨を設定します｡

パラメータ:
pymtCurIso - ISO コード通貨

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setPartPrctr

public void setPartPrctr(String partPrctr)
パートナ利益センタを設定します｡

パラメータ:
partPrctr - パートナ利益センタ

setSegment

public void setSegment(String segment)
セグメントレポートのセグメントを設定します｡

パラメータ:
segment - セグメントレポートのセグメント

setPartnerSegment

public void setPartnerSegment(String partnerSegment)
セグメントレポートのパートナセグメントを設定します｡

パラメータ:
partnerSegment - セグメントレポートのパートナセグメント

setFund

public void setFund(String fund)
ファンドを設定します｡

パラメータ:
fund - ファンド

setPartnerFund

public void setPartnerFund(String partnerFund)
パートナファンドを設定します｡

パラメータ:
partnerFund - パートナファンド

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します｡

パラメータ:
grantNbr - 補助金

setPartnerGrantNbr

public void setPartnerGrantNbr(String partnerGrantNbr)
パートナ補助金を設定します｡

パラメータ:
partnerGrantNbr - パートナ補助金

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setTrPartBa

public void setTrPartBa(String trPartBa)
取引先事業領域を設定します｡

パラメータ:
trPartBa - 取引先事業領域

setNegPostng

public void setNegPostng(String negPostng)
フラグ: マイナス転記を設定します｡

パラメータ:
negPostng - フラグ: マイナス転記

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

getItemnoAcc

public String getItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
itemnoAcc

getVendorNo

public String getVendorNo()
仕入先または債権者の勘定コードを取得します｡

戻り値:
vendorNo

getRefKey1

public String getRefKey1()
取引先参照キーを取得します｡

戻り値:
refKey1

getRefKey2

public String getRefKey2()
取引先参照キーを取得します｡

戻り値:
refKey2

getRefKey3

public String getRefKey3()
明細の参照キーを取得します｡

戻り値:
refKey3

getGlAccount

public String getGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glAccount

getBlineDate

public String getBlineDate()
期日計算の支払基準日を取得します｡

戻り値:
blineDate

getPmtmthsupl

public String getPmtmthsupl()
支払方法追加を取得します｡

戻り値:
pmtmthsupl

getPymtMeth

public String getPymtMeth()
支払方法を取得します｡

戻り値:
pymtMeth

getBllsrvInd

public String getBllsrvInd()
サービスコード (外貨支払)を取得します｡

戻り値:
bllsrvInd

getAllocNmbr

public String getAllocNmbr()
ソートキーを取得します｡

戻り値:
allocNmbr

getItemText

public String getItemText()
明細テキストを取得します｡

戻り値:
itemText

getAcctKey

public String getAcctKey()
内部処理キーを取得します｡

戻り値:
acctKey

getScbankInd

public String getScbankInd()
中央銀行コードを取得します｡

戻り値:
scbankInd

getPymtAmt

public String getPymtAmt()
支払通貨額を取得します｡

戻り値:
pymtAmt

getPymtCur

public String getPymtCur()
自動支払通貨を取得します｡

戻り値:
pymtCur

getPymtCurIso

public String getPymtCurIso()
ISO コード通貨を取得します｡

戻り値:
pymtCurIso

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getPartPrctr

public String getPartPrctr()
パートナ利益センタを取得します｡

戻り値:
partPrctr

getSegment

public String getSegment()
セグメントレポートのセグメントを取得します｡

戻り値:
segment

getPartnerSegment

public String getPartnerSegment()
セグメントレポートのパートナセグメントを取得します｡

戻り値:
partnerSegment

getFund

public String getFund()
ファンドを取得します｡

戻り値:
fund

getPartnerFund

public String getPartnerFund()
パートナファンドを取得します｡

戻り値:
partnerFund

getGrantNbr

public String getGrantNbr()
補助金を取得します｡

戻り値:
grantNbr

getPartnerGrantNbr

public String getPartnerGrantNbr()
パートナ補助金を取得します｡

戻り値:
partnerGrantNbr

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
busArea

getTrPartBa

public String getTrPartBa()
取引先事業領域を取得します｡

戻り値:
trPartBa

getNegPostng

public String getNegPostng()
フラグ: マイナス転記を取得します｡

戻り値:
negPostng

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountTax (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountTax

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountTax
すべての実装インタフェース:
Serializable
public class AccountTax
extends Object
implements Serializable

税明細クラス
機能は以下の通り

  • 税明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountTax()
税明細情報を作成します｡
AccountTax(int index)
税明細情報を作成します｡
メソッドの概要
String | getAcctKey() 内部処理キーを取得します｡
String | getCondKey() 条件タイプを取得します｡
String | getGlAccount() 総勘定元帳勘定を取得します｡
String | getItemnoAcc() 会計伝票明細番号を取得します｡
String | getNegPostng() フラグ: マイナス転記を取得します｡
String | getStatCon() 統計に適用する条件を取得します｡
int | getTaIndex() レコード番号を取得します｡
String | getTaxCode() 消費税コードを取得します｡
String | getTaxDate() 税率定義の日付を取得します｡
String | getTaxjurcode() 税管轄を取得します｡
String | getTaxjurcodeDeep() 税管轄コード - 最下位レベル税管轄を取得します｡
String | getTaxjurcodeLevel() 税管轄コードレベルを取得します｡
String | getTaxRate() 税率を取得します｡
void | setAcctKey(String acctKey) 内部処理キーを設定します｡
void | setCondKey(String condKey) 条件タイプを設定します｡
void | setGlAccount(String glAccount) 総勘定元帳勘定コードを設定します｡
void | setItemnoAcc(String itemnoAcc) 会計伝票明細番号コードを設定します｡
void | setNegPostng(String negPostng) フラグ: マイナス転記を設定します｡
void | setStatCon(String statCon) 統計に適用する条件を設定します｡
void | setTaIndex(int taIndex) レコード番号を設定します｡
void | setTaxCode(String taxCode) 消費税コードを設定します｡
void | setTaxDate(String taxDate) 税率定義の日付を設定します｡
void | setTaxjurcode(String taxjurcode) 税管轄を設定します｡
void | setTaxjurcodeDeep(String taxjurcodeDeep) 税管轄コード - 最下位レベル税管轄を設定します｡
void | setTaxjurcodeLevel(String taxjurcodeLevel) 税管轄コードレベルを設定します｡
void | setTaxRate(String taxRate) 税率を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountTax

public AccountTax()
税明細情報を作成します｡

AccountTax

public AccountTax(int index)
税明細情報を作成します｡

パラメータ:
index - レコード番号
メソッドの詳細

setItemnoAcc

public void setItemnoAcc(String itemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
itemnoAcc - 会計伝票明細番号

setGlAccount

public void setGlAccount(String glAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
glAccount - 総勘定元帳勘定

setTaxCode

public void setTaxCode(String taxCode)
消費税コードを設定します｡

パラメータ:
taxCode - 消費税コード

setAcctKey

public void setAcctKey(String acctKey)
内部処理キーを設定します｡

パラメータ:
acctKey - 内部処理キー

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税管轄を設定します｡

パラメータ:
taxjurcode - 税管轄

setCondKey

public void setCondKey(String condKey)
条件タイプを設定します｡

パラメータ:
condKey - 条件タイプ

setTaxRate

public void setTaxRate(String taxRate)
税率を設定します｡

パラメータ:
taxRate - 税率

setTaxDate

public void setTaxDate(String taxDate)
税率定義の日付を設定します｡

パラメータ:
taxDate - 税率定義の日付

setStatCon

public void setStatCon(String statCon)
統計に適用する条件を設定します｡

パラメータ:
statCon - 統計に適用する条件

setTaxjurcodeDeep

public void setTaxjurcodeDeep(String taxjurcodeDeep)
税管轄コード - 最下位レベル税管轄を設定します｡

パラメータ:
taxjurcodeDeep - 税管轄コード - 最下位レベル税管轄

setTaxjurcodeLevel

public void setTaxjurcodeLevel(String taxjurcodeLevel)
税管轄コードレベルを設定します｡

パラメータ:
taxjurcodeLevel - 税管轄コードレベル

setNegPostng

public void setNegPostng(String negPostng)
フラグ: マイナス転記を設定します｡

パラメータ:
negPostng - フラグ: マイナス転記

setTaIndex

public void setTaIndex(int taIndex)
レコード番号を設定します｡

パラメータ:
taIndex - レコード番号

getItemnoAcc

public String getItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
itemnoAcc

getGlAccount

public String getGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glAccount

getTaxCode

public String getTaxCode()
消費税コードを取得します｡

戻り値:
taxCode

getAcctKey

public String getAcctKey()
内部処理キーを取得します｡

戻り値:
acctKey

getTaxjurcode

public String getTaxjurcode()
税管轄を取得します｡

戻り値:
taxjurcode

getCondKey

public String getCondKey()
条件タイプを取得します｡

戻り値:
condKey

getTaxRate

public String getTaxRate()
税率を取得します｡

戻り値:
taxRate

getTaxDate

public String getTaxDate()
税率定義の日付を取得します｡

戻り値:
taxDate

getStatCon

public String getStatCon()
統計に適用する条件を取得します｡

戻り値:
statCon

getTaxjurcodeDeep

public String getTaxjurcodeDeep()
税管轄コード - 最下位レベル税管轄を取得します｡

戻り値:
taxjurcodeDeep

getTaxjurcodeLevel

public String getTaxjurcodeLevel()
税管轄コードレベルを取得します｡

戻り値:
taxjurcodeLevel

getNegPostng

public String getNegPostng()
フラグ: マイナス転記を取得します｡

戻り値:
negPostng

getTaIndex

public int getTaIndex()
レコード番号を取得します｡

戻り値:
tadex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Bank (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Bank

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Bank
すべての実装インタフェース:
Serializable
public class Bank
extends Object
implements Serializable

銀行情報クラス
機能は以下の通り

  • 銀行の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Bank()
銀行情報を作成します。
メソッドの概要
String | getBankKey() 銀行コードを取得します｡
String | getBankName() 銀行名を取得します｡
String | getCity() 市区町村名を取得します｡
void | setBankKey(String bankKey) 銀行コードを設定します｡
void | setBankName(String bankName) 銀行名を設定します｡
void | setCity(String city) 市区町村名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Bank

public Bank()
銀行情報を作成します。

メソッドの詳細

setBankKey

public void setBankKey(String bankKey)
銀行コードを設定します｡

パラメータ:
bankKey - 銀行コード

setBankName

public void setBankName(String bankName)
銀行名を設定します｡

パラメータ:
bankName - 銀行名

setCity

public void setCity(String city)
市区町村名を設定します｡

パラメータ:
city - 市区町村名

getBankKey

public String getBankKey()
銀行コードを取得します｡

戻り値:
bankKey

getBankName

public String getBankName()
銀行名を取得します｡

戻り値:
bankName

getCity

public String getCity()
市区町村名を取得します｡

戻り値:
city

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankController
すべての実装インタフェース:
Serializable
public class BankController
extends Object
implements Serializable

銀行コントローラクラス
機能は以下の通り

  • 銀行の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(String bankCtry, int maxRows)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(String bankCtry, int maxRows, SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
メソッドの概要
BankList | getBaList() 銀行一覧を取得します｡
ArrayList | getBankList() 銀行一覧（Bankインスタンスの配列）を取得します。
String | getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | setBaList(BankList baList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankController

public BankController()
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。 「銀行国コード」に固定値"JP"を設定します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BankController

public BankController(SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BankController

public BankController(String bankCtry,
                      int maxRows)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。
「銀行国コード」・「最大該当行数」を引数より設定します。
「最大該当行数」(maxRows)は0以上の値を指定してください。

パラメータ:
bankCtry - 銀行国コード
maxRows - 最大該当行数
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BankController

public BankController(String bankCtry,
                      int maxRows,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。
「銀行国コード」・「最大該当行数」を引数より設定します。
「最大該当行数」(maxRows)は0以上の値を指定してください。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
bankCtry - 銀行国コード
maxRows - 最大該当行数
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBankList

public ArrayList getBankList()
銀行一覧（Bankインスタンスの配列）を取得します。

戻り値:
銀行一覧
関連項目:
Bank

getBankName

public String getBankName(String bankKey)
                   throws SAPAccountingSystemException
銀行コードを指定して銀行名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
bankName 銀行名
例外:
SAPAccountingSystemException - 会計業務システム例外

getCity

public String getCity(String bankKey)
               throws SAPAccountingSystemException
銀行コードを指定して市区町村名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
city 市区町村名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBaList

public void setBaList(BankList baList)
銀行一覧を設定します｡

パラメータ:
baList - 銀行一覧

getBaList

public BankList getBaList()
銀行一覧を取得します｡

戻り値:
baList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankList
すべての実装インタフェース:
Serializable
public class BankList
extends ReferenceController
implements Serializable

銀行一覧クラス
機能は以下の通り

  • 銀行の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankList(String bankCtry, int maxRows, SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
メソッドの概要
ArrayList | getBankList() 銀行一覧（Bankインスタンスの配列）を取得します｡
void | setBankList(ArrayList bankList) 銀行一覧（Bankインスタンスの配列）を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankList

public BankList(SapClient sapClient)
         throws SAPAuthAppException,
                SAPAuthSystemException,
                SAPGeneralAppException,
                SAPGeneralSystemException,
                SAPAccountingSystemException
executeBapiを呼び出し銀行一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BankList

public BankList(String bankCtry,
                int maxRows,
                SapClient sapClient)
         throws SAPAuthAppException,
                SAPAuthSystemException,
                SAPGeneralAppException,
                SAPGeneralSystemException,
                SAPAccountingSystemException
executeBapiを呼び出し銀行一覧を作成します。

パラメータ:
bankCtry - 銀行国コード
maxRows - 最大該当行数
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBankList

public void setBankList(ArrayList bankList)
銀行一覧（Bankインスタンスの配列）を設定します｡

パラメータ:
bankList - 銀行一覧
関連項目:
Bank

getBankList

public ArrayList getBankList()
銀行一覧（Bankインスタンスの配列）を取得します｡

戻り値:
銀行一覧
関連項目:
Bank

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessArea (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea
すべての実装インタフェース:
Serializable
public class BusinessArea
extends Object
implements Serializable

事業領域情報クラス
機能は以下の通り

  • 事業領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessArea()
事業領域情報を作成します。
メソッドの概要
String | getBusArDes() 事業領域名を取得します｡
String | getBusArea() 事業領域を取得します｡
void | setBusArDes(String busArDes) 事業領域名を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessArea

public BusinessArea()
事業領域情報を作成します。

メソッドの詳細

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setBusArDes

public void setBusArDes(String busArDes)
事業領域名を設定します｡

パラメータ:
busArDes - 事業領域名

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
businessAreaCode

getBusArDes

public String getBusArDes()
事業領域名を取得します｡

戻り値:
busArDes

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController
すべての実装インタフェース:
Serializable
public class BusinessAreaController
extends Object
implements Serializable

事業領域コントローラクラス
機能は以下の通り

  • 事業領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(String lang, String isoLang)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(String lang, String isoLang, SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
メソッドの概要
String | getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
BusinessAreaList | getBusAreaList() 事業領域一覧を取得します｡
ArrayList | getBusinessAreaList() 事業領域一覧（BusinessAreaインスタンスの配列）を取得します。
void | setBusAreaList(BusinessAreaList busAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaController

public BusinessAreaController()
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
「言語」・「ISO639準拠の言語」は「JA」がデフォルトで設定されます。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BusinessAreaController

public BusinessAreaController(SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
「言語」・「ISO639準拠の言語」は「JA」がデフォルトで設定されます。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BusinessAreaController

public BusinessAreaController(String lang,
                              String isoLang)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
「言語」・「ISO639準拠の言語」を引数より設定します。

パラメータ:
lang - 言語
isoLang - ISO639準拠の言語
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BusinessAreaController

public BusinessAreaController(String lang,
                              String isoLang,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
「言語」・「ISO639準拠の言語」を引数より設定します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
lang - 言語
isoLang - ISO639準拠の言語
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧（BusinessAreaインスタンスの配列）を取得します。

戻り値:
businessAreaList 事業領域一覧
関連項目:
BusinessArea

getBusArDes

public String getBusArDes(String busArea)
                   throws SAPAccountingSystemException
事業領域を指定して事業領域名を取得します。

パラメータ:
busArea - 事業領域
戻り値:
busArDes 事業領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBusAreaList

public void setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

パラメータ:
busAreaList - 事業領域一覧

getBusAreaList

public BusinessAreaList getBusAreaList()
事業領域一覧を取得します｡

戻り値:
busAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList
すべての実装インタフェース:
Serializable
public class BusinessAreaList
extends ReferenceController
implements Serializable

事業領域一覧クラス
機能は以下の通り

  • 事業領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaList(String lang, String isoLang, SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
メソッドの概要
ArrayList | getBusinessAreaList() 事業領域一覧（BusinessAreaインスタンスの配列）を取得します｡
String | getIsoLanguage() ISO639準拠を取得します｡
String | getLanguage() 言語を取得します｡
void | setBusinessAreaList(ArrayList businessAreaList) 事業領域一覧（BusinessAreaインスタンスの配列）を設定します｡
void | setIsoLanguage(String isoLanguage) ISO639準拠の言語を設定します｡
void | setLanguage(String language) 言語を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaList

public BusinessAreaList(SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し事業領域一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BusinessAreaList

public BusinessAreaList(String lang,
                        String isoLang,
                        SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し事業領域一覧を作成します。 「言語」・「ISO639準拠の言語」を引数より設定します。

パラメータ:
lang - 言語
isoLang - ISO639準拠の言語
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBusinessAreaList

public void setBusinessAreaList(ArrayList businessAreaList)
事業領域一覧（BusinessAreaインスタンスの配列）を設定します｡

パラメータ:
businessAreaList - 事業領域一覧
関連項目:
BusinessArea

setLanguage

public void setLanguage(String language)
言語を設定します｡

パラメータ:
language - 言語

setIsoLanguage

public void setIsoLanguage(String isoLanguage)
ISO639準拠の言語を設定します｡

パラメータ:
isoLanguage - ISO639準拠の言語

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧（BusinessAreaインスタンスの配列）を取得します｡

戻り値:
businessAreaList 事業領域一覧
関連項目:
BusinessArea

getLanguage

public String getLanguage()
言語を取得します｡

戻り値:
language 言語

getIsoLanguage

public String getIsoLanguage()
ISO639準拠を取得します｡

戻り値:
isoLanguage ISO639準拠

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Company (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社情報クラス
機能は以下の通り

  • 会社の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Company()
会社情報を作成します。
メソッドの概要
String | getCompCode() 会社コードを取得します｡
String | getCompName() 会社名を取得します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCompName(String compName) 会社名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社情報を作成します。

メソッドの詳細

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setCompName

public void setCompName(String compName)
会社名を設定します｡

パラメータ:
compName - 会社名

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getCompName

public String getCompName()
会社名を取得します｡

戻り値:
compName

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyController
すべての実装インタフェース:
Serializable
public class CompanyController
extends Object
implements Serializable

会社コントローラクラス
機能は以下の通り

  • 会社の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧（Companyインスタンスの配列）を取得します。
CompanyList | getCompList() 会社一覧を取得します｡
String | getCompName(String compCode) 会社コードを指定して会社名を取得します。
void | setCompList(CompanyList compList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyController

public CompanyController()
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CompanyController

public CompanyController(SapClient sapClient)
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCompanyList

public ArrayList getCompanyList()
会社一覧（Companyインスタンスの配列）を取得します。

戻り値:
会社一覧
関連項目:
Company

getCompName

public String getCompName(String compCode)
                   throws SAPAccountingSystemException
会社コードを指定して会社名を取得します。

パラメータ:
compCode - 会社コード
戻り値:
compName 会社名
例外:
SAPAccountingSystemException - 会計業務システム例外

setCompList

public void setCompList(CompanyList compList)
会社一覧を設定します｡

パラメータ:
compList - 会社一覧

getCompList

public CompanyList getCompList()
会社一覧を取得します｡

戻り値:
compList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyList
すべての実装インタフェース:
Serializable
public class CompanyList
extends ReferenceController
implements Serializable

会社一覧クラス
機能は以下の通り

  • 会社の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します｡
void | setCompanyList(ArrayList companyList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyList

public CompanyList(SapClient sapClient)
            throws SAPAuthAppException,
                   SAPAuthSystemException,
                   SAPGeneralAppException,
                   SAPGeneralSystemException,
                   SAPAccountingSystemException
executeBapiを呼び出し会社一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCompanyList

public void setCompanyList(ArrayList companyList)
会社一覧を設定します｡

パラメータ:
companyList - 会社一覧

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します｡

戻り値:
companyList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingArea (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea
すべての実装インタフェース:
Serializable
public class ControllingArea
extends Object
implements Serializable

管理領域情報クラス
機能は以下の通り

  • 管理領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingArea()
管理領域情報を作成します。
メソッドの概要
String | getCoArea() 管理領域を取得します｡
String | getName() 管理領域名を取得します｡
void | setCoArea(String coArea) 管理領域を設定します｡
void | setName(String name) 管理領域名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingArea

public ControllingArea()
管理領域情報を作成します。

メソッドの詳細

setCoArea

public void setCoArea(String coArea)
管理領域を設定します｡

パラメータ:
coArea - 管理領域

setName

public void setName(String name)
管理領域名を設定します｡

パラメータ:
name - 管理領域名

getCoArea

public String getCoArea()
管理領域を取得します｡

戻り値:
coArea

getName

public String getName()
管理領域名を取得します｡

戻り値:
name

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController
すべての実装インタフェース:
Serializable
public class ControllingAreaController
extends Object
implements Serializable

管理領域コントローラクラス
機能は以下の通り

  • 管理領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
メソッドの概要
ControllingAreaList | getControllAreaList() 管理領域一覧を取得します｡
ArrayList | getControllingAreaList() 管理領域一覧（ControllingAreaインスタンスの配列）を取得します。
String | getName(String coArea) 管理領域を指定して管理領域名を取得します。
void | setControllAreaList(ControllingAreaList controllAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaController

public ControllingAreaController()
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ControllingAreaController

public ControllingAreaController(SapClient sapClient)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧（ControllingAreaインスタンスの配列）を取得します。

戻り値:
管理領域一覧
関連項目:
ControllingArea

getName

public String getName(String coArea)
               throws SAPAccountingSystemException
管理領域を指定して管理領域名を取得します。

パラメータ:
coArea - 管理領域
戻り値:
name 管理領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setControllAreaList

public void setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

パラメータ:
controllAreaList - 管理領域一覧

getControllAreaList

public ControllingAreaList getControllAreaList()
管理領域一覧を取得します｡

戻り値:
controllAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList
すべての実装インタフェース:
Serializable
public class ControllingAreaList
extends ReferenceController
implements Serializable

管理領域一覧クラス
機能は以下の通り

  • 管理領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
メソッドの概要
ArrayList | getControllingAreaList() 管理領域一覧を取得します｡
void | setControllingAreaList(ArrayList controllingAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaList

public ControllingAreaList(SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPAccountingSystemException
executeBapiを呼び出し管理領域一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setControllingAreaList

public void setControllingAreaList(ArrayList controllingAreaList)
管理領域一覧を設定します｡

パラメータ:
controllingAreaList - 管理領域一覧

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します｡

戻り値:
controllingAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenter (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenter
すべての実装インタフェース:
Serializable
public class CostCenter
extends Object
implements Serializable

原価センタ情報クラス
機能は以下の通り

  • 原価センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenter()
原価センタ情報を取得します。
CostCenter(int index)
原価センタ情報を取得します。
メソッドの概要
String | getActState() 一般マスタレコードの有効化ステータスを取得します｡
String | getControllingArea() 管理領域を取得します｡
String | getCostCenter() 原価センタを取得します｡
String | getDescript() テキストを取得します｡
int | getIndex() レコード番号を取得します｡
String | getName() 一般名称を取得します｡
void | setActState(String actState) 一般マスタレコードの有効化ステータスを設定します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setCostCenter(String costCenter) 原価センタを設定します｡
void | setDescript(String descript) テキストを設定します｡
void | setIndex(int index) レコード番号を設定します｡
void | setName(String name) 一般名称を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenter

public CostCenter()
原価センタ情報を取得します。

CostCenter

public CostCenter(int index)
原価センタ情報を取得します。

パラメータ:
index - レコード番号
メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setCostCenter

public void setCostCenter(String costCenter)
原価センタを設定します｡

パラメータ:
costCenter - 原価センタ

setName

public void setName(String name)
一般名称を設定します｡

パラメータ:
name - 一般名称

setDescript

public void setDescript(String descript)
テキストを設定します｡

パラメータ:
descript - テキスト

setActState

public void setActState(String actState)
一般マスタレコードの有効化ステータスを設定します｡

パラメータ:
actState - 一般マスタレコードの有効化ステータス

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

getControllingArea

public String getControllingArea()
管理領域を取得します｡

戻り値:
controllingArea

getCostCenter

public String getCostCenter()
原価センタを取得します｡

戻り値:
costCenter

getName

public String getName()
一般名称を取得します｡

戻り値:
name

getDescript

public String getDescript()
テキストを取得します｡

戻り値:
descript

getActState

public String getActState()
一般マスタレコードの有効化ステータスを取得します｡

戻り値:
actState

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController
すべての実装インタフェース:
Serializable
public class CostCenterController
extends Object
implements Serializable

原価センタコントローラクラス
機能は以下の通り

  • 原価センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterController()
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより原価センタ一覧を作成します。
String | getBusinessAreaFrom() 事業領域を取得します｡
String | getBusinessAreaTo() 事業領域を取得します｡
String | getCompanycodeFrom() 会社コード（開始値）を取得します。
String | getCompanycodeTo() 会社コード（終了値）を取得します。
String | getControllingarea() 管理領域を取得します。
CostCenter | getCostCenter(int index) BAPI パラメータ の参照構造オブジェクトが既に 存在するかチェックします。
String | getCostcenterFrom() 原価センタ（開始値）を取得します。
String | getCostcentergroup() 原価センタグループを取得します。
ArrayList | getCostCenterList() 原価センタ一覧（CostCenterインスタンスの配列）を取得します。
String | getCostcenterTo() 原価センタ（終了値）を取得します。
CostCenterList | getCostCentList() 原価センタ一覧を取得します｡
String | getDateFrom() 有効期間：開始を取得します。
String | getDateTo() 有効期間：終了を取得します。
String | getDescript(String costCenter) 原価センタを指定してテキストを取得します。
ExtensionIn | getExtensionIn(int index) BAPI パラメータ EXTENSIONIN の参照構造オブジェクトが既に 存在するかチェックします。
ArrayList | getExtensionInList() EXTENSIONIN一覧を取得します｡
ExtensionOut | getExtensionOut(int index) BAPI パラメータ EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
ArrayList | getExtensionOutList() EXTENSIONOUT一覧を取得します｡
String | getMasterDataInactive() マスタレコードの無効化を取得します。
String | getName(String costCenter) 原価センタを指定して一般名称を取得します。
String | getPersonInChargeFrom() 責任者（開始値）を取得します。
String | getPersonInChargeTo() 責任者（終了値）を取得します。
String | getPersonInChargeUserFrom() 担当ユーザ（開始値）を取得します。
String | getPersonInChargeUserTo() 担当ユーザ（終了値）を取得します。
void | setBusinessAreaFrom(String businessAreaFrom) 事業領域を設定します｡
void | setBusinessAreaTo(String businessAreaTo) 事業領域を設定します｡
void | setCompanycodeFrom(String companycodeFrom) 会社コード（開始値）を設定します。
void | setCompanycodeTo(String companycodeTo) 会社コード（終了値）を設定します。
void | setControllingarea(String controllingarea) 管理領域を設定します。
void | setCostcenterFrom(String costcenterFrom) 原価センタ（開始値）を設定します。
void | setCostcentergroup(String costcentergroup) 原価センタグループを設定します。
void | setCostcenterTo(String costcenterTo) 原価センタ（終了値）を設定します。
void | setCostCentList(CostCenterList costCentList) 原価センタ一覧を設定します｡
void | setDateFrom(String dateFrom) 有効期間：開始を設定します。
void | setDateTo(String dateTo) 有効期間：終了を設定します。
void | setExtensionInList(ArrayList extensionInList) EXTENSIONIN一覧を設定します｡
void | setExtensionOutList(ArrayList extensionOutList) EXTENSIONOUT一覧を設定します｡
void | setMasterDataInactive(String masterDataInactive) マスタレコードの無効化を設定します。
void | setPersonInChargeFrom(String personInChargeFrom) 責任者（開始値）を設定します。
void | setPersonInChargeTo(String personInChargeTo) 責任者（終了値）を設定します。
void | setPersonInChargeUserFrom(String personInChargeUserFrom) 担当ユーザ（開始値）を設定します。
void | setPersonInChargeUserTo(String personInChargeUserTo) 担当ユーザ（終了値）を設定します。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterController

public CostCenterController()
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException,
                            SAPAccountingAppException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException,
                            SAPAccountingAppException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「管理領域」・「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外

CostCenterController

public CostCenterController(String controllingArea,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException,
                            SAPAccountingAppException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「管理領域」を引数より設定、「有効期間: 開始」をシステム日付より設定します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
controllingArea - 管理領域
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException,
                            SAPAccountingAppException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「管理領域」・「有効期間: 開始」を引数より設定します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAccountingSystemException,
                        SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingAppException
BapiControllerにより原価センタ一覧を作成します。

例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPAuthAppException - 認証系アプリケーション例外
SAPAccountingSystemException - 会計系APIシステム例外
SAPAccountingAppException - 会計系APIアプリケーション例外

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧（CostCenterインスタンスの配列）を取得します。

戻り値:
costCenterList 原価センタ一覧
関連項目:
CostCenter

getName

public String getName(String costCenter)
               throws SAPAccountingSystemException
原価センタを指定して一般名称を取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
name 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getDescript

public String getDescript(String costCenter)
                   throws SAPAccountingSystemException
原価センタを指定してテキストを取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
descript テキスト
例外:
SAPAccountingSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPAccountingSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPAccountingSystemException - 会計業務システム例外

getCostCenter

public CostCenter getCostCenter(int index)
BAPI パラメータ の参照構造オブジェクトが既に 存在するかチェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
costCenter COSTCENTER の参照構造オブジェクト

getExtensionIn

public ExtensionIn getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN の参照構造オブジェクトが既に 存在するかチェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
extensionIn EXTENSIONIN の参照構造オブジェクト

getExtensionOut

public ExtensionOut getExtensionOut(int index)
BAPI パラメータ EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
extensionOut EXTENSIONOUT の参照構造オブジェクト

setCostCentList

public void setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

パラメータ:
costCentList - 原価センタ一覧

getCostCentList

public CostCenterList getCostCentList()
原価センタ一覧を取得します｡

戻り値:
costCentList

setExtensionInList

public void setExtensionInList(ArrayList extensionInList)
EXTENSIONIN一覧を設定します｡

パラメータ:
extensionInList - EXTENSIONIN一覧

getExtensionInList

public ArrayList getExtensionInList()
EXTENSIONIN一覧を取得します｡

戻り値:
EXTENSIONIN一覧

setExtensionOutList

public void setExtensionOutList(ArrayList extensionOutList)
EXTENSIONOUT一覧を設定します｡

パラメータ:
extensionOutList - EXTENSIONOUT一覧

getExtensionOutList

public ArrayList getExtensionOutList()
EXTENSIONOUT一覧を取得します｡

戻り値:
EXTENSIONOUT一覧

getBusinessAreaFrom

public String getBusinessAreaFrom()
事業領域を取得します｡

戻り値:
businessAreaFrom

setBusinessAreaFrom

public void setBusinessAreaFrom(String businessAreaFrom)
事業領域を設定します｡

パラメータ:
businessAreaFrom - 事業領域

getBusinessAreaTo

public String getBusinessAreaTo()
事業領域を取得します｡

戻り値:
businessAreaTo

setBusinessAreaTo

public void setBusinessAreaTo(String businessAreaTo)
事業領域を設定します｡

パラメータ:
businessAreaTo - 事業領域

getCompanycodeFrom

public String getCompanycodeFrom()
会社コード（開始値）を取得します。

戻り値:
companycodeFrom

setCompanycodeFrom

public void setCompanycodeFrom(String companycodeFrom)
会社コード（開始値）を設定します。

パラメータ:
companycodeFrom - 会社コード（開始値）

getCompanycodeTo

public String getCompanycodeTo()
会社コード（終了値）を取得します。

戻り値:
companycodeTo

setCompanycodeTo

public void setCompanycodeTo(String companycodeTo)
会社コード（終了値）を設定します。

パラメータ:
companycodeTo - 会社コード（終了値）

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
controllingarea

setControllingarea

public void setControllingarea(String controllingarea)
管理領域を設定します。

パラメータ:
controllingarea - 管理領域

getCostcenterFrom

public String getCostcenterFrom()
原価センタ（開始値）を取得します。

戻り値:
costcenterFrom

setCostcenterFrom

public void setCostcenterFrom(String costcenterFrom)
原価センタ（開始値）を設定します。

パラメータ:
costcenterFrom - 原価センタ（開始値）

getCostcenterTo

public String getCostcenterTo()
原価センタ（終了値）を取得します。

戻り値:
costcenterTo

setCostcenterTo

public void setCostcenterTo(String costcenterTo)
原価センタ（終了値）を設定します。

パラメータ:
costcenterTo - 原価センタ（終了値）

getCostcentergroup

public String getCostcentergroup()
原価センタグループを取得します。

戻り値:
costcentergroup

setCostcentergroup

public void setCostcentergroup(String costcentergroup)
原価センタグループを設定します。

パラメータ:
costcentergroup - 原価センタグループ

getDateFrom

public String getDateFrom()
有効期間：開始を取得します。

戻り値:
dateFrom

setDateFrom

public void setDateFrom(String dateFrom)
有効期間：開始を設定します。

パラメータ:
dateFrom - 有効期間：開始

getDateTo

public String getDateTo()
有効期間：終了を取得します。

戻り値:
dateTo

setDateTo

public void setDateTo(String dateTo)
有効期間：終了を設定します。

パラメータ:
dateTo - 有効期間：終了

getMasterDataInactive

public String getMasterDataInactive()
マスタレコードの無効化を取得します。

戻り値:
masterDataInactive

setMasterDataInactive

public void setMasterDataInactive(String masterDataInactive)
マスタレコードの無効化を設定します。

パラメータ:
masterDataInactive - マスタレコードの無効化

getPersonInChargeFrom

public String getPersonInChargeFrom()
責任者（開始値）を取得します。

戻り値:
personInChargeFrom

setPersonInChargeFrom

public void setPersonInChargeFrom(String personInChargeFrom)
責任者（開始値）を設定します。

パラメータ:
personInChargeFrom - 責任者（開始値）

getPersonInChargeTo

public String getPersonInChargeTo()
責任者（終了値）を取得します。

戻り値:
personInChargeTo

setPersonInChargeTo

public void setPersonInChargeTo(String personInChargeTo)
責任者（終了値）を設定します。

パラメータ:
personInChargeTo - 責任者（終了値）

getPersonInChargeUserFrom

public String getPersonInChargeUserFrom()
担当ユーザ（開始値）を取得します。

戻り値:
personInChargeUserFrom

setPersonInChargeUserFrom

public void setPersonInChargeUserFrom(String personInChargeUserFrom)
担当ユーザ（開始値）を設定します。

パラメータ:
personInChargeUserFrom - 担当ユーザ（開始値）

getPersonInChargeUserTo

public String getPersonInChargeUserTo()
担当ユーザ（終了値）を取得します。

戻り値:
personInChargeUserTo

setPersonInChargeUserTo

public void setPersonInChargeUserTo(String personInChargeUserTo)
担当ユーザ（終了値）を設定します。

パラメータ:
personInChargeUserTo - 担当ユーザ（終了値）

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList
すべての実装インタフェース:
Serializable
public class CostCenterList
extends ReferenceController
implements Serializable

原価センタ一覧クラス
機能は以下の通り

  • 原価センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CostCenterList(SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより原価センタ一覧を作成します。
String | getBusinessAreaFrom() 事業領域を取得します｡
String | getBusinessAreaTo() 事業領域を取得します｡
String | getCompanycodeFrom() 会社コード（開始値）を取得します。
String | getCompanycodeTo() 会社コード（終了値）を取得します。
String | getControllingarea() 管理領域を取得します。
String | getCostcenterFrom() 原価センタ（開始値）を取得します。
String | getCostcentergroup() 原価センタグループを取得します。
ArrayList | getCostCenterList() 原価センタ一覧（CostCenterインスタンスの配列）を取得します｡
String | getCostcenterTo() 原価センタ（終了値）を取得します。
String | getDateFrom() 有効期間：開始を取得します。
String | getDateTo() 有効期間：終了を取得します。
ArrayList | getExtensionInList() EXTENSIONIN一覧を取得します｡
ArrayList | getExtensionOutList() EXTENSIONOUT一覧を取得します｡
String | getMasterDataInactive() マスタレコードの無効化を取得します。
String | getPersonInChargeFrom() 責任者（開始値）を取得します。
String | getPersonInChargeTo() 責任者（終了値）を取得します。
String | getPersonInChargeUserFrom() 担当ユーザ（開始値）を取得します。
String | getPersonInChargeUserTo() 担当ユーザ（終了値）を取得します。
void | setBusinessAreaFrom(String businessAreaFrom) 事業領域を設定します｡
void | setBusinessAreaTo(String businessAreaTo) 事業領域を設定します｡
void | setCompanycodeFrom(String companycodeFrom) 会社コード（開始値）を設定します。
void | setCompanycodeTo(String companycodeTo) 会社コード（終了値）を設定します。
void | setControllingarea(String controllingarea) 管理領域を設定します。
void | setCostcenterFrom(String costcenterFrom) 原価センタ（開始値）を設定します。
void | setCostcentergroup(String costcentergroup) 原価センタグループを設定します。
void | setCostCenterList(ArrayList costCenterList) 原価センタ一覧（CostCenterインスタンスの配列）を設定します｡
void | setCostcenterTo(String costcenterTo) 原価センタ（終了値）を設定します。
void | setDateFrom(String dateFrom) 有効期間：開始を設定します。
void | setDateTo(String dateTo) 有効期間：終了を設定します。
void | setExpExtensionIn(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONIN の参照構造 を設定します。
void | setExpExtensionOut(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONOUT の参照構造 を設定します。
void | setExtensionInList(ArrayList extensionInList) EXTENSIONIN一覧を設定します｡
void | setExtensionOutList(ArrayList extensionOutList) EXTENSIONOUT一覧を設定します｡
void | setImpCostcenterList(BapiController bapiController) BAPI パラメータ 原価センタ からインポート情報を設定します。
void | setImpExtensionIn(BapiController bapiController) BAPI パラメータ EXTENSIONIN の参照構造からインポート情報を 設定します。
void | setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONOUT の参照構造からインポート情報を 設定します。
void | setImportParam(BapiController bapiController) 原価センタ一覧を取得する条件をセットします。
void | setMasterDataInactive(String masterDataInactive) マスタレコードの無効化を設定します。
void | setPersonInChargeFrom(String personInChargeFrom) 責任者（開始値）を設定します。
void | setPersonInChargeTo(String personInChargeTo) 責任者（終了値）を設定します。
void | setPersonInChargeUserFrom(String personInChargeUserFrom) 担当ユーザ（開始値）を設定します。
void | setPersonInChargeUserTo(String personInChargeUserTo) 担当ユーザ（終了値）を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterList

public CostCenterList(SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
executeBapiを呼び出し原価センタ一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterList

public CostCenterList(String controllingArea,
                      String date,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException,
                      SAPAccountingAppException
executeBapiを呼び出し原価センタ一覧を作成します。 「管理領域」・「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException,
                        SAPAccountingAppException
BapiControllerにより原価センタ一覧を作成します。
インポートパラメータをセットします。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPAccountingSystemException,
                           SAPAccountingAppException
原価センタ一覧を取得する条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
SAPAccountingAppException - 会計系APIアプリケーション例外

setImpCostcenterList

public void setImpCostcenterList(BapiController bapiController)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
BAPI パラメータ 原価センタ からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpExtensionIn

public void setImpExtensionIn(BapiController bapiController)
                       throws SAPGeneralSystemException,
                              SAPGeneralAppException
BAPI パラメータ EXTENSIONIN の参照構造からインポート情報を 設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpExtensionOut

public void setImpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
BAPI パラメータ EXTENSIONOUT の参照構造からインポート情報を 設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExpExtensionIn

public void setExpExtensionIn(BapiController bapiController)
                       throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN の参照構造 を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpExtensionOut

public void setExpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONOUT の参照構造 を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setCostCenterList

public void setCostCenterList(ArrayList costCenterList)
原価センタ一覧（CostCenterインスタンスの配列）を設定します｡

パラメータ:
costCenterList - 原価センタ一覧
関連項目:
CostCenter

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧（CostCenterインスタンスの配列）を取得します｡

戻り値:
原価センタ一覧
関連項目:
CostCenter

setExtensionInList

public void setExtensionInList(ArrayList extensionInList)
EXTENSIONIN一覧を設定します｡

パラメータ:
extensionInList - EXTENSIONIN一覧

getExtensionInList

public ArrayList getExtensionInList()
EXTENSIONIN一覧を取得します｡

戻り値:
EXTENSIONIN一覧

setExtensionOutList

public void setExtensionOutList(ArrayList extensionOutList)
EXTENSIONOUT一覧を設定します｡

パラメータ:
extensionOutList - EXTENSIONOUT一覧

getExtensionOutList

public ArrayList getExtensionOutList()
EXTENSIONOUT一覧を取得します｡

戻り値:
EXTENSIONOUT一覧

getBusinessAreaFrom

public String getBusinessAreaFrom()
事業領域を取得します｡

戻り値:
businessAreaFrom

setBusinessAreaFrom

public void setBusinessAreaFrom(String businessAreaFrom)
事業領域を設定します｡

パラメータ:
businessAreaFrom - 事業領域

getBusinessAreaTo

public String getBusinessAreaTo()
事業領域を取得します｡

戻り値:
businessAreaTo

setBusinessAreaTo

public void setBusinessAreaTo(String businessAreaTo)
事業領域を設定します｡

パラメータ:
businessAreaTo - 事業領域

getCompanycodeFrom

public String getCompanycodeFrom()
会社コード（開始値）を取得します。

戻り値:
companycodeFrom

setCompanycodeFrom

public void setCompanycodeFrom(String companycodeFrom)
会社コード（開始値）を設定します。

パラメータ:
companycodeFrom - 会社コード（開始値）

getCompanycodeTo

public String getCompanycodeTo()
会社コード（終了値）を取得します。

戻り値:
companycodeTo

setCompanycodeTo

public void setCompanycodeTo(String companycodeTo)
会社コード（終了値）を設定します。

パラメータ:
companycodeTo - 会社コード（終了値）

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
controllingarea

setControllingarea

public void setControllingarea(String controllingarea)
管理領域を設定します。

パラメータ:
controllingarea - 管理領域

getCostcenterFrom

public String getCostcenterFrom()
原価センタ（開始値）を取得します。

戻り値:
costcenterFrom

setCostcenterFrom

public void setCostcenterFrom(String costcenterFrom)
原価センタ（開始値）を設定します。

パラメータ:
costcenterFrom - 原価センタ（開始値）

getCostcenterTo

public String getCostcenterTo()
原価センタ（終了値）を取得します。

戻り値:
costcenterTo

setCostcenterTo

public void setCostcenterTo(String costcenterTo)
原価センタ（終了値）を設定します。

パラメータ:
costcenterTo - 原価センタ（終了値）

getCostcentergroup

public String getCostcentergroup()
原価センタグループを取得します。

戻り値:
costcentergroup

setCostcentergroup

public void setCostcentergroup(String costcentergroup)
原価センタグループを設定します。

パラメータ:
costcentergroup - 原価センタグループ

getDateFrom

public String getDateFrom()
有効期間：開始を取得します。

戻り値:
dateFrom

setDateFrom

public void setDateFrom(String dateFrom)
有効期間：開始を設定します。

パラメータ:
dateFrom - 有効期間：開始

getDateTo

public String getDateTo()
有効期間：終了を取得します。

戻り値:
dateTo

setDateTo

public void setDateTo(String dateTo)
有効期間：終了を設定します。

パラメータ:
dateTo - 有効期間：終了

getMasterDataInactive

public String getMasterDataInactive()
マスタレコードの無効化を取得します。

戻り値:
masterDataInactive

setMasterDataInactive

public void setMasterDataInactive(String masterDataInactive)
マスタレコードの無効化を設定します。

パラメータ:
masterDataInactive - マスタレコードの無効化

getPersonInChargeFrom

public String getPersonInChargeFrom()
責任者（開始値）を取得します。

戻り値:
personInChargeFrom

setPersonInChargeFrom

public void setPersonInChargeFrom(String personInChargeFrom)
責任者（開始値）を設定します。

パラメータ:
personInChargeFrom - 責任者（開始値）

getPersonInChargeTo

public String getPersonInChargeTo()
責任者（終了値）を取得します。

戻り値:
personInChargeTo

setPersonInChargeTo

public void setPersonInChargeTo(String personInChargeTo)
責任者（終了値）を設定します。

パラメータ:
personInChargeTo - 責任者（終了値）

getPersonInChargeUserFrom

public String getPersonInChargeUserFrom()
担当ユーザ（開始値）を取得します。

戻り値:
personInChargeUserFrom

setPersonInChargeUserFrom

public void setPersonInChargeUserFrom(String personInChargeUserFrom)
担当ユーザ（開始値）を設定します。

パラメータ:
personInChargeUserFrom - 担当ユーザ（開始値）

getPersonInChargeUserTo

public String getPersonInChargeUserTo()
担当ユーザ（終了値）を取得します。

戻り値:
personInChargeUserTo

setPersonInChargeUserTo

public void setPersonInChargeUserTo(String personInChargeUserTo)
担当ユーザ（終了値）を設定します。

パラメータ:
personInChargeUserTo - 担当ユーザ（終了値）

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurrencyAmount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CurrencyAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount
すべての実装インタフェース:
Serializable
public class CurrencyAmount
extends Object
implements Serializable

明細通貨項目クラス
機能は以下の通り

  • 明細通貨項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CurrencyAmount()
明細通貨項目情報を作成します。
CurrencyAmount(int index)
明細通貨項目情報を作成します。
メソッドの概要
String | getAmtBase() 課税基準額を取得します｡
String | getAmtDoccur() 伝票通貨額を取得します｡
int | getCuIndex() レコード番号を取得します｡
String | getCurrency() 通貨コードを取得します｡
String | getCurrencyIso() ISO コード通貨を取得します｡
String | getCurrType() 通貨タイプおよび評価ビューを取得します｡
String | getExchRate() 換算レートを取得します｡
String | getExchRateV() 間接呼び値換算レートを取得します｡
String | getItemnoAcc() 会計伝票明細番号を取得します｡
void | setAmtBase(String amtBase) 課税基準額を設定します｡
void | setAmtDoccur(String amtDoccur) 伝票通貨額を設定します｡
void | setCuIndex(int cuIndex) レコード番号を設定します｡
void | setCurrency(String currency) 通貨コードを設定します｡
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します｡
void | setCurrType(String currType) 通貨タイプおよび評価ビューを設定します｡
void | setExchRate(String exchRate) 換算レートを設定します｡
void | setExchRateV(String exchRateV) 間接呼び値換算レートを設定します｡
void | setItemnoAcc(String itemnoAcc) 会計伝票明細番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurrencyAmount

public CurrencyAmount()
明細通貨項目情報を作成します。

CurrencyAmount

public CurrencyAmount(int index)
明細通貨項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setItemnoAcc

public void setItemnoAcc(String itemnoAcc)
会計伝票明細番号を設定します｡

パラメータ:
itemnoAcc - 会計伝票明細番号

setCurrType

public void setCurrType(String currType)
通貨タイプおよび評価ビューを設定します｡

パラメータ:
currType - 通貨タイプおよび評価ビュー

setCurrency

public void setCurrency(String currency)
通貨コードを設定します｡

パラメータ:
currency - 通貨コード

setAmtDoccur

public void setAmtDoccur(String amtDoccur)
伝票通貨額を設定します｡

パラメータ:
amtDoccur - 伝票通貨額

setExchRate

public void setExchRate(String exchRate)
換算レートを設定します｡

パラメータ:
exchRate - 換算レート

setAmtBase

public void setAmtBase(String amtBase)
課税基準額を設定します｡

パラメータ:
amtBase - 課税基準額

setExchRateV

public void setExchRateV(String exchRateV)
間接呼び値換算レートを設定します｡

パラメータ:
exchRateV - 間接呼び値換算レート

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します｡

パラメータ:
currencyIso - ISO コード通貨

setCuIndex

public void setCuIndex(int cuIndex)
レコード番号を設定します｡

パラメータ:
cuIndex - レコード番号

getItemnoAcc

public String getItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
ItemnoAcc

getCurrType

public String getCurrType()
通貨タイプおよび評価ビューを取得します｡

戻り値:
currType

getCurrency

public String getCurrency()
通貨コードを取得します｡

戻り値:
currency

getAmtDoccur

public String getAmtDoccur()
伝票通貨額を取得します｡

戻り値:
amtDoccur

getExchRate

public String getExchRate()
換算レートを取得します｡

戻り値:
exchRate

getAmtBase

public String getAmtBase()
課税基準額を取得します｡

戻り値:
amtBase

getExchRateV

public String getExchRateV()
間接呼び値換算レートを取得します｡

戻り値:
exchRateV

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します｡

戻り値:
currencyIso

getCuIndex

public int getCuIndex()
レコード番号を取得します｡

戻り値:
cuindex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DocumentHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス DocumentHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader
すべての実装インタフェース:
Serializable
public class DocumentHeader
extends Object
implements Serializable

伝票ヘッダクラス
機能は以下の通り

  • 伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DocumentHeader()
伝票ヘッダ情報を作成します。
メソッドの概要
String | getAcDocNo() 会計伝票番号を取得します｡
String | getBusAct() 取引を取得します｡
String | getCompCode() 会社コードを取得します｡
String | getCompoAcc() ACC インタフェースの構成要素を取得します｡
String | getDocDate() 伝票の伝票日付を取得します｡
String | getDocType() 伝票タイプを取得します｡
String | getFiscYear() 会計年度を取得します｡
String | getFisPeriod() 会計期間を取得します｡
String | getHeaderTxt() 伝票ヘッダテキストを取得します｡
String | getNegPostng() フラグ: マイナス転記を取得します｡
String | getObjKey() オブジェクトキーを取得します｡
String | getObjKeyR() 取消: オブジェクトキー (AWREF_REV と AWORG_REV)を取得します｡
String | getObjSys() 元伝票の論理システムを取得します｡
String | getObjType() 参照処理を取得します｡
String | getPstngDate() 伝票の転記日付を取得します｡
String | getReasonRev() 反対仕訳理由を取得します｡
String | getRefDocNo() 参照伝票番号を取得します｡
String | getRefDocNoLong() 参照伝票番号 (依存性についてはテキスト長参照)を取得します｡
String | getTaxCompCode() 税会社コードを取得します｡
String | getUsername() ユーザ名を取得します｡
void | setAcDocNo(String acDocNo) 会計伝票番号を設定します｡
void | setBusAct(String busAct) 取引を設定します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCompoAcc(String compoAcc) ACC インタフェースの構成要素を設定します｡
void | setDocDate(String docDate) 伝票の伝票日付を設定します｡
void | setDocType(String docType) 伝票タイプを設定します｡
void | setFiscYear(String fiscYear) 会計年度を設定します｡
void | setFisPeriod(String fisPeriod) 会計期間を設定します｡
void | setHeaderTxt(String headerTxt) 伝票ヘッダテキストを設定します｡
void | setNegPostng(String negPostng) フラグ: マイナス転記を設定します｡
void | setObjKey(String objKey) オブジェクトキーを設定します｡
void | setObjKeyR(String objKeyR) 取消: オブジェクトキー (AWREF_REV と AWORG_REV)を設定します｡
void | setObjSys(String objSys) 元伝票の論理システムを設定します｡
void | setObjType(String objType) 参照処理を設定します｡
void | setPstngDate(String pstngDate) 伝票の転記日付を設定します｡
void | setReasonRev(String reasonRev) 反対仕訳理由を設定します｡
void | setRefDocNo(String refDocNo) 参照伝票番号を設定します｡
void | setRefDocNoLong(String refDocNoLong) 参照伝票番号 (依存性についてはテキスト長参照)を設定します｡
void | setTaxCompCode(String taxCompCode) 税会社コードを設定します｡
void | setUsername(String username) ユーザ名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DocumentHeader

public DocumentHeader()
伝票ヘッダ情報を作成します。

メソッドの詳細

setObjType

public void setObjType(String objType)
参照処理を設定します｡

パラメータ:
objType - 参照処理

setObjKey

public void setObjKey(String objKey)
オブジェクトキーを設定します｡

パラメータ:
objKey - オブジェクトキー

setObjSys

public void setObjSys(String objSys)
元伝票の論理システムを設定します｡

パラメータ:
objSys - 元伝票の論理システム

setUsername

public void setUsername(String username)
ユーザ名を設定します｡

パラメータ:
username - ユーザ名

setHeaderTxt

public void setHeaderTxt(String headerTxt)
伝票ヘッダテキストを設定します｡

パラメータ:
headerTxt - 伝票ヘッダテキスト

setObjKeyR

public void setObjKeyR(String objKeyR)
取消: オブジェクトキー (AWREF_REV と AWORG_REV)を設定します｡

パラメータ:
objKeyR - 取消: オブジェクトキー (AWREF_REV と AWORG_REV)

setBusAct

public void setBusAct(String busAct)
取引を設定します｡

パラメータ:
busAct - 取引

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setAcDocNo

public void setAcDocNo(String acDocNo)
会計伝票番号を設定します｡

パラメータ:
acDocNo - 会計伝票番号

setFiscYear

public void setFiscYear(String fiscYear)
会計年度を設定します｡

パラメータ:
fiscYear - 会計年度

setDocDate

public void setDocDate(String docDate)
伝票の伝票日付を設定します｡

パラメータ:
docDate - 伝票の伝票日付

setPstngDate

public void setPstngDate(String pstngDate)
伝票の転記日付を設定します｡

パラメータ:
pstngDate - 伝票の転記日付

setFisPeriod

public void setFisPeriod(String fisPeriod)
会計期間を設定します｡

パラメータ:
fisPeriod - 会計期間

setDocType

public void setDocType(String docType)
伝票タイプを設定します｡

パラメータ:
docType - 伝票タイプ

setRefDocNo

public void setRefDocNo(String refDocNo)
参照伝票番号を設定します｡

パラメータ:
refDocNo - 参照伝票番号

setCompoAcc

public void setCompoAcc(String compoAcc)
ACC インタフェースの構成要素を設定します｡

パラメータ:
compoAcc - ACC インタフェースの構成要素

setTaxCompCode

public void setTaxCompCode(String taxCompCode)
税会社コードを設定します｡

パラメータ:
taxCompCode - 税会社コード

setReasonRev

public void setReasonRev(String reasonRev)
反対仕訳理由を設定します｡

パラメータ:
reasonRev - 反対仕訳理由

setRefDocNoLong

public void setRefDocNoLong(String refDocNoLong)
参照伝票番号 (依存性についてはテキスト長参照)を設定します｡

パラメータ:
refDocNoLong - 参照伝票番号 (依存性についてはテキスト長参照)

setNegPostng

public void setNegPostng(String negPostng)
フラグ: マイナス転記を設定します｡

パラメータ:
negPostng - フラグ: マイナス転記

getObjType

public String getObjType()
参照処理を取得します｡

戻り値:
objType

getObjKey

public String getObjKey()
オブジェクトキーを取得します｡

戻り値:
objKey

getObjSys

public String getObjSys()
元伝票の論理システムを取得します｡

戻り値:
objSys

getUsername

public String getUsername()
ユーザ名を取得します｡

戻り値:
username

getHeaderTxt

public String getHeaderTxt()
伝票ヘッダテキストを取得します｡

戻り値:
headerTxt

getObjKeyR

public String getObjKeyR()
取消: オブジェクトキー (AWREF_REV と AWORG_REV)を取得します｡

戻り値:
objKeyR

getBusAct

public String getBusAct()
取引を取得します｡

戻り値:
busAct

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getAcDocNo

public String getAcDocNo()
会計伝票番号を取得します｡

戻り値:
acDocNo

getFiscYear

public String getFiscYear()
会計年度を取得します｡

戻り値:
fiscYear

getDocDate

public String getDocDate()
伝票の伝票日付を取得します｡

戻り値:
docDate

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します｡

戻り値:
pstngDate

getFisPeriod

public String getFisPeriod()
会計期間を取得します｡

戻り値:
fisPeriod

getDocType

public String getDocType()
伝票タイプを取得します｡

戻り値:
docType

getRefDocNo

public String getRefDocNo()
参照伝票番号を取得します｡

戻り値:
refDocNo

getCompoAcc

public String getCompoAcc()
ACC インタフェースの構成要素を取得します｡

戻り値:
compoAcc

getTaxCompCode

public String getTaxCompCode()
税会社コードを取得します｡

戻り値:
taxCompCode

getReasonRev

public String getReasonRev()
反対仕訳理由を取得します｡

戻り値:
reasonRev

getRefDocNoLong

public String getRefDocNoLong()
参照伝票番号 (依存性についてはテキスト長参照)を取得します｡

戻り値:
refDocNoLong

getNegPostng

public String getNegPostng()
フラグ: マイナス転記を取得します｡

戻り値:
negPostng

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Extension1 (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Extension1

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Extension1
すべての実装インタフェース:
Serializable
public class Extension1
extends Object
implements Serializable

カスタマ拡張テーブルクラス
機能は以下の通り

  • カスタマ拡張テーブルの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Extension1()
カスタマ拡張テーブル情報を作成します。
Extension1(int index)
カスタマ拡張テーブル情報を作成します。
メソッドの概要
int | getExIndex() レコード番号を取得します｡
String | getField1() 文字項目長 250を取得します｡
String | getField2() 文字項目長 250を取得します｡
String | getField3() 文字項目長 250を取得します｡
String | getField4() 文字項目長 250を取得します｡
void | setExIndex(int exIndex) レコード番号を設定します｡
void | setField1(String field1) 文字項目長 250を設定します｡
void | setField2(String field2) 文字項目長 250を設定します｡
void | setField3(String field3) 文字項目長 250を設定します｡
void | setField4(String field4) 文字項目長 250を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Extension1

public Extension1()
カスタマ拡張テーブル情報を作成します。

Extension1

public Extension1(int index)
カスタマ拡張テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setField1

public void setField1(String field1)
文字項目長 250を設定します｡

パラメータ:
field1 - 文字項目長 250

setField2

public void setField2(String field2)
文字項目長 250を設定します｡

パラメータ:
field2 - 文字項目長 250

setField3

public void setField3(String field3)
文字項目長 250を設定します｡

パラメータ:
field3 - 文字項目長 250

setField4

public void setField4(String field4)
文字項目長 250を設定します｡

パラメータ:
field4 - 文字項目長 250

setExIndex

public void setExIndex(int exIndex)
レコード番号を設定します｡

パラメータ:
exIndex - レコード番号

getField1

public String getField1()
文字項目長 250を取得します｡

戻り値:
field1

getField2

public String getField2()
文字項目長 250を取得します｡

戻り値:
field2

getField3

public String getField3()
文字項目長 250を取得します｡

戻り値:
field3

getField4

public String getField4()
文字項目長 250を取得します｡

戻り値:
field4

getExIndex

public int getExIndex()
レコード番号を取得します｡

戻り値:
exIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtensionIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

ExtensionInの参照構造情報クラス
機能は以下の通り

  • ExtensionInの参照構造を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
ExtensionInの参照構造情報を取得します。
ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN の参照構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します｡
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します｡
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します｡
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します｡
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します｡
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します｡
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します｡
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します｡
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します｡
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
ExtensionInの参照構造情報を取得します。

ExtensionIn

public ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します｡

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart1 - BAPI　拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart2 - BAPI　拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart3 - BAPI　拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart4 - BAPI　拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します｡

戻り値:
structure

getValuepart1

public String getValuepart1()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart1

getValuepart2

public String getValuepart2()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart2

getValuepart3

public String getValuepart3()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart3

getValuepart4

public String getValuepart4()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart4

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtensionOut (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ExtensionOut

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut
すべての実装インタフェース:
Serializable
public class ExtensionOut
extends Object
implements Serializable

ExtensionOutの参照構造情報クラス
機能は以下の通り

  • ExtensionOutの参照構造を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionOut()
ExtensionOutの参照構造情報を取得します。
ExtensionOut(int index)
BAPI パラメータ EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します｡
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します｡
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します｡
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します｡
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します｡
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します｡
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します｡
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します｡
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します｡
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionOut

public ExtensionOut()
ExtensionOutの参照構造情報を取得します。

ExtensionOut

public ExtensionOut(int index)
BAPI パラメータ EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します｡

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart1 - BAPI　拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart2 - BAPI　拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart3 - BAPI　拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI　拡張パラメータのデータ部分を設定します｡

パラメータ:
valuepart4 - BAPI　拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します｡

戻り値:
structure

getValuepart1

public String getValuepart1()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart1

getValuepart2

public String getValuepart2()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart2

getValuepart3

public String getValuepart3()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart3

getValuepart4

public String getValuepart4()
BAPI　拡張パラメータのデータ部分を取得します｡

戻り値:
valuepart4

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAcc (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAcc

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAcc
すべての実装インタフェース:
Serializable
public class GlAcc
extends Object
implements Serializable

勘定項目情報クラス
機能は以下の通り

  • 勘定項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GlAcc()
勘定項目情報を作成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します｡
String | getGlAccount() G/L勘定コードを取得します｡
String | getLongText() 総勘定元帳勘定テキスト(長)を取得します｡
String | getShortText() G/L勘定コードテキスト(短)を取得します｡
void | setCompanyCode(String companyCode) 会社コードを設定します｡
void | setGlAccount(String glAccount) G/L勘定コードを設定します｡
void | setLongText(String longText) 総勘定元帳勘定テキスト(長)を設定します｡
void | setShortText(String shortText) G/L勘定コードテキスト(短)を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAcc

public GlAcc()
勘定項目情報を作成します。

メソッドの詳細

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します｡

パラメータ:
companyCode - 会社コード

setGlAccount

public void setGlAccount(String glAccount)
G/L勘定コードを設定します｡

パラメータ:
glAccount - G/L勘定コード

setShortText

public void setShortText(String shortText)
G/L勘定コードテキスト(短)を設定します｡

パラメータ:
shortText - G/L勘定コードテキスト(短)

setLongText

public void setLongText(String longText)
総勘定元帳勘定テキスト(長)を設定します｡

パラメータ:
longText - 総勘定元帳勘定テキスト(長)

getCompanyCode

public String getCompanyCode()
会社コードを取得します｡

戻り値:
companyCode

getGlAccount

public String getGlAccount()
G/L勘定コードを取得します｡

戻り値:
glAccount

getShortText

public String getShortText()
G/L勘定コードテキスト(短)を取得します｡

戻り値:
shortText

getLongText

public String getLongText()
総勘定元帳勘定テキスト(長)を取得します｡

戻り値:
longText

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccController
すべての実装インタフェース:
Serializable
public class GlAccController
extends Object
implements Serializable

勘定科目コントローラクラス
機能は以下の通り

  • 勘定科目の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, String language, String languageIso)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, String language, String languageIso, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目情報一覧（GlAccインスタンスの配列）を取得します。
GlAccList | getGlList() 勘定科目一覧を取得します｡
String | getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
void | setGlList(GlAccList glList) 勘定科目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccController

public GlAccController(String companyCode)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。 「会社コード」を引数より設定します。「言語」・「ISO639準拠の言語」は 固定値(JA)を設定します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

GlAccController

public GlAccController(String companyCode,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。 「会社コード」を引数より設定します。「言語」・「ISO639準拠の言語」は 固定値(JA)を設定します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
companyCode - 会社コード
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

GlAccController

public GlAccController(String companyCode,
                       String language,
                       String languageIso)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。 「会社コード」・「言語」・「ISO639準拠の言語」を引数より設定します。

パラメータ:
companyCode - 会社コード
language - 言語
languageIso - ISO639準拠の言語
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

GlAccController

public GlAccController(String companyCode,
                       String language,
                       String languageIso,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。 「会社コード」・「言語」・「ISO639準拠の言語」を引数より設定します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
companyCode - 会社コード
language - 言語
languageIso - ISO639準拠の言語
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getGlAccList

public ArrayList getGlAccList()
勘定項目情報一覧（GlAccインスタンスの配列）を取得します。

戻り値:
glAccList 勘定項目情報一覧
関連項目:
GlAcc

getShortText

public String getShortText(String glAccount)
                    throws SAPAccountingSystemException
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
shortText G/L勘定コードテキスト(短)
例外:
SAPAccountingSystemException - 会計業務システム例外

getLongText

public String getLongText(String glAccount)
                   throws SAPAccountingSystemException
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
longText 総勘定元帳勘定テキスト(長)
例外:
SAPAccountingSystemException - 会計業務システム例外

setGlList

public void setGlList(GlAccList glList)
勘定科目一覧を設定します｡

パラメータ:
glList - 勘定科目一覧

getGlList

public GlAccList getGlList()
勘定科目一覧を取得します｡

戻り値:
glList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccList
すべての実装インタフェース:
Serializable
public class GlAccList
extends ReferenceController
implements Serializable

勘定項目一覧クラス
機能は以下の通り

  • 勘定項目の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccList(String companyCode, String language, String languageIso, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目情報一覧（GlAccインスタンスの配列）を取得します｡
void | setGlAccList(ArrayList glAccList) 勘定項目一覧（GlAccインスタンスの配列）を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccList

public GlAccList(String companyCode,
                 SapClient sapClient)
          throws SAPAuthAppException,
                 SAPAuthSystemException,
                 SAPGeneralAppException,
                 SAPGeneralSystemException,
                 SAPAccountingSystemException
executeBapiを呼び出し勘定項目一覧を作成します。

パラメータ:
companyCode - 会社コード
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

GlAccList

public GlAccList(String companyCode,
                 String language,
                 String languageIso,
                 SapClient sapClient)
          throws SAPAuthAppException,
                 SAPAuthSystemException,
                 SAPGeneralAppException,
                 SAPGeneralSystemException,
                 SAPAccountingSystemException
executeBapiを呼び出し勘定項目一覧を作成します。

パラメータ:
companyCode - 会社コード
language - 言語
languageIso - ISO639準拠の言語
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setGlAccList

public void setGlAccList(ArrayList glAccList)
勘定項目一覧（GlAccインスタンスの配列）を設定します｡

パラメータ:
glAccList - 勘定項目一覧
関連項目:
GlAcc

getGlAccList

public ArrayList getGlAccList()
勘定項目情報一覧（GlAccインスタンスの配列）を取得します｡

戻り値:
勘定項目情報一覧
関連項目:
GlAcc

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.accounting (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.accounting
クラス
AccEmployeePayPost
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
Bank
BankController
BankList
BusinessArea
BusinessAreaController
BusinessAreaList
Company
CompanyController
CompanyList
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterList
CurrencyAmount
DocumentHeader
Extension1
ExtensionIn
ExtensionOut
GlAcc
GlAccController
GlAccList
ParamAccountGl
ParamAccountPayable
ParamAccountTax
ParamCurrencyAmount
ParamDocumentHeader
ParamExtension1
ParamTravel
ParamTravelAmount
ProfitCenter
ProfitCenterController
ProfitCenterList
Travel
TravelAmount


jp.co.intra_mart.foundation.sap.module.accounting (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

ＳＡＰ連携財務会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AccEmployeePayPost | 伝票登録クラス 機能は以下の通り 伝票を登録します。
AccEmployeePayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
AccountGl | G/L 勘定明細クラス 機能は以下の通り G/L 勘定明細の情報を保持します。
AccountPayable | 仕入先明細クラス 機能は以下の通り 仕入先明細の情報を保持します。
AccountTax | 税明細クラス 機能は以下の通り 税明細の情報を保持します。
Bank | 銀行情報クラス 機能は以下の通り 銀行の情報を保持します。
BankController | 銀行コントローラクラス 機能は以下の通り 銀行の情報を取得します。
BankList | 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
BusinessArea | 事業領域情報クラス 機能は以下の通り 事業領域の情報を保持します。
BusinessAreaController | 事業領域コントローラクラス 機能は以下の通り 事業領域の情報を取得します。
BusinessAreaList | 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
Company | 会社情報クラス 機能は以下の通り 会社の情報を保持します。
CompanyController | 会社コントローラクラス 機能は以下の通り 会社の情報を取得します。
CompanyList | 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
ControllingArea | 管理領域情報クラス 機能は以下の通り 管理領域の情報を保持します。
ControllingAreaController | 管理領域コントローラクラス 機能は以下の通り 管理領域の情報を取得します。
ControllingAreaList | 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
CostCenter | 原価センタ情報クラス 機能は以下の通り 原価センタの情報を保持します。
CostCenterController | 原価センタコントローラクラス 機能は以下の通り 原価センタの情報を取得します。
CostCenterList | 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
CurrencyAmount | 明細通貨項目クラス 機能は以下の通り 明細通貨項目の情報を保持します。
DocumentHeader | 伝票ヘッダクラス 機能は以下の通り 伝票ヘッダの情報を保持します。
Extension1 | カスタマ拡張テーブルクラス 機能は以下の通り カスタマ拡張テーブルの情報を保持します。
ExtensionIn | ExtensionInの参照構造情報クラス 機能は以下の通り ExtensionInの参照構造を保持します。
ExtensionOut | ExtensionOutの参照構造情報クラス 機能は以下の通り ExtensionOutの参照構造を保持します。
GlAcc | 勘定項目情報クラス 機能は以下の通り 勘定項目の情報を保持します。
GlAccController | 勘定科目コントローラクラス 機能は以下の通り 勘定科目の情報を取得します。
GlAccList | 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
ParamAccountGl | G/L 勘定明細パラメータ設定クラス 機能は以下の通り G/L 勘定明細のパラメータを設定します。
ParamAccountPayable | 仕入先明細パラメータ設定クラス 機能は以下の通り 仕入先明細のパラメータを設定します。
ParamAccountTax | 税明細パラメータ設定クラス 機能は以下の通り 税明細のパラメータを設定します。
ParamCurrencyAmount | 明細通貨項目パラメータ設定クラス 機能は以下の通り 明細通貨項目のパラメータを設定します。
ParamDocumentHeader | 伝票ヘッダパラメータ設定クラス 機能は以下の通り 伝票ヘッダのインポートパラメータを設定します。
ParamExtension1 | カスタマ拡張テーブルパラメータ設定クラス 機能は以下の通り カスタマ拡張テーブルのパラメータを設定します。
ParamTravel | 旅費資金予算明細パラメータ設定クラス 機能は以下の通り 旅費資金予算明細のパラメータを設定します。
ParamTravelAmount | 旅費資金計画通貨項目パラメータ設定クラス 機能は以下の通り 旅費資金計画通貨項目のパラメータを設定します。
ProfitCenter | 利益センタ情報クラス 機能は以下の通り 利益センタの情報を保持します。
ProfitCenterController | 利益センタコントローラクラス 機能は以下の通り 利益センタの情報を取得します。
ProfitCenterList | 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。
Travel | 旅費資金予算明細クラス 機能は以下の通り 旅費資金予算明細の情報を保持します。
TravelAmount | 旅費資金計画通貨項目クラス 機能は以下の通り 旅費資金計画通貨項目の情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の説明

ＳＡＰ連携財務会計系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.accounting クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Travel (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.accounting の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting の使用

jp.co.intra_mart.foundation.sap.module.accounting を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting のクラス
AccEmployeePayPost
伝票登録クラス
機能は以下の通り
伝票を登録します。
BankList
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BusinessAreaList
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
CompanyList
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
ControllingAreaList
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
CostCenter
原価センタ情報クラス
機能は以下の通り
原価センタの情報を保持します。
CostCenterList
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
DocumentHeader
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
ExtensionIn
ExtensionInの参照構造情報クラス
機能は以下の通り
ExtensionInの参照構造を保持します。
ExtensionOut
ExtensionOutの参照構造情報クラス
機能は以下の通り
ExtensionOutの参照構造を保持します。
GlAccList
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
ProfitCenterList
利益センタ一覧クラス

機能は以下の通り
利益センタの情報を一覧形式で取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamAccountGl (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamAccountGl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl
すべての実装インタフェース:
Serializable
public class ParamAccountGl
extends Object
implements Serializable

G/L 勘定明細パラメータ設定クラス
機能は以下の通り

  • G/L 勘定明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List accountGlList) G/L 勘定明細にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List accountGlList) G/L 勘定明細にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List accountGlList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
G/L 勘定明細にインポートする値をセットします。

パラメータ:
bapiController - BapiController
accountGlList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List accountGlList)
                           throws SAPGeneralSystemException
G/L 勘定明細にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
accountGlList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamAccountPayable (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamAccountPayable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable
すべての実装インタフェース:
Serializable
public class ParamAccountPayable
extends Object
implements Serializable

仕入先明細パラメータ設定クラス
機能は以下の通り

  • 仕入先明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List accountPayableList) 仕入先明細にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List accountPayableList) 仕入先明細にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List accountPayableList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
仕入先明細にインポートする値をセットします。

パラメータ:
bapiController - BapiController
accountPayableList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List accountPayableList)
                           throws SAPGeneralSystemException
仕入先明細にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
accountPayableList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamAccountTax (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamAccountTax

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax
すべての実装インタフェース:
Serializable
public class ParamAccountTax
extends Object
implements Serializable

税明細パラメータ設定クラス
機能は以下の通り

  • 税明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List accountTaxList) 税明細にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List accountTaxList) 税明細にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List accountTaxList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
税明細にインポートする値をセットします。

パラメータ:
bapiController - BapiController
accountTaxList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List accountTaxList)
                           throws SAPGeneralSystemException
税明細にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
accountTaxList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCurrencyAmount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamCurrencyAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount
すべての実装インタフェース:
Serializable
public class ParamCurrencyAmount
extends Object
implements Serializable

明細通貨項目パラメータ設定クラス
機能は以下の通り

  • 明細通貨項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List currencyAmountList) 明細通貨項目にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List currencyAmountList) 明細通貨項目にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List currencyAmountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細通貨項目にインポートする値をセットします。

パラメータ:
bapiController - BapiController
currencyAmountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List currencyAmountList)
                           throws SAPGeneralSystemException
明細通貨項目にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
currencyAmountList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamDocumentHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamDocumentHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader
すべての実装インタフェース:
Serializable
public class ParamDocumentHeader
extends Object
implements Serializable

伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • 伝票ヘッダのインポートパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, DocumentHeader documentHeader)
伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  DocumentHeader documentHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtension1 (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamExtension1

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1
すべての実装インタフェース:
Serializable
public class ParamExtension1
extends Object
implements Serializable

カスタマ拡張テーブルパラメータ設定クラス
機能は以下の通り

  • カスタマ拡張テーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extension1List) カスタマ拡張テーブルにエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List extension1List) カスタマ拡張テーブルにインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extension1List)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
カスタマ拡張テーブルにインポートする値をセットします。

パラメータ:
bapiController - BapiController
extension1List - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extension1List)
                           throws SAPGeneralSystemException
カスタマ拡張テーブルにエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
extension1List - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTravel (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamTravel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel
すべての実装インタフェース:
Serializable
public class ParamTravel
extends Object
implements Serializable

旅費資金予算明細パラメータ設定クラス
機能は以下の通り

  • 旅費資金予算明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List travelList) 旅費資金予算明細にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List travelList) 旅費資金予算明細にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List travelList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
旅費資金予算明細にインポートする値をセットします。

パラメータ:
bapiController - BapiController
travelList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List travelList)
                           throws SAPGeneralSystemException
旅費資金予算明細にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
travelList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTravelAmount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ParamTravelAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount
すべての実装インタフェース:
Serializable
public class ParamTravelAmount
extends Object
implements Serializable

旅費資金計画通貨項目パラメータ設定クラス
機能は以下の通り

  • 旅費資金計画通貨項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List travelAmountList) 旅費資金計画通貨項目にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List travelAmountList) 旅費資金計画通貨項目にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List travelAmountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
旅費資金計画通貨項目にインポートする値をセットします。

パラメータ:
bapiController - BapiController
travelAmountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List travelAmountList)
                           throws SAPGeneralSystemException
旅費資金計画通貨項目にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
travelAmountList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenter (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter
すべての実装インタフェース:
Serializable
public class ProfitCenter
extends Object
implements Serializable

利益センタ情報クラス
機能は以下の通り

  • 利益センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenter()
利益センタ情報を作成します。
メソッドの概要
String | getControllingArea() 管理領域コードを取得します｡
String | getInCharge() 利益センタ責任者を取得します｡
String | getInChargeUser() 利益センタの責任責任ユーザを取得します｡
String | getPctrName() 一般名称を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getValidTo() 有効終了日を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setInCharge(String inCharge) 利益センタ責任者を設定します｡
void | setInChargeUser(String inChargeUser) 利益センタの責任ユーザを設定します｡
void | setPctrName(String pctrName) 一般名称を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setValidTo(String validTo) 有効終了日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenter

public ProfitCenter()
利益センタ情報を作成します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setValidTo

public void setValidTo(String validTo)
有効終了日を設定します｡

パラメータ:
validTo - 有効終了日

setPctrName

public void setPctrName(String pctrName)
一般名称を設定します｡

パラメータ:
pctrName - 一般名称

setInCharge

public void setInCharge(String inCharge)
利益センタ責任者を設定します｡

パラメータ:
inCharge - 利益センタ責任者

setInChargeUser

public void setInChargeUser(String inChargeUser)
利益センタの責任ユーザを設定します｡

パラメータ:
inChargeUser - 利益センタの責任ユーザ

getControllingArea

public String getControllingArea()
管理領域コードを取得します｡

戻り値:
controllingArea

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getValidTo

public String getValidTo()
有効終了日を取得します｡

戻り値:
validTo

getPctrName

public String getPctrName()
一般名称を取得します｡

戻り値:
pctrName

getInCharge

public String getInCharge()
利益センタ責任者を取得します｡

戻り値:
inCharge

getInChargeUser

public String getInChargeUser()
利益センタの責任責任ユーザを取得します｡

戻り値:
inChargeUser

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController
すべての実装インタフェース:
Serializable
public class ProfitCenterController
extends Object
implements Serializable

利益センタコントローラクラス
機能は以下の通り

  • 利益センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, String personincharge, String inChargeUser, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, String personincharge, String inChargeUser, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
メソッドの概要
String | getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | getInChargeUser(String profitCtr) 利益センタを指定して利益センタに責任のあるユーザを取得します。
String | getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
ArrayList | getProfitCenterList() 利益センタ一覧（ProfitCenterインスタンスの配列）を取得します。
ProfitCenterList | getProfitCentList() 利益センタ一覧を取得します｡
String | getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
void | setProfitCentList(ProfitCenterList profitCentList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterController

public ProfitCenterController(String controllingArea)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「管理領域」を引数より設定し、「日付」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「管理領域」・「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「管理領域」を引数より設定し、「日付」をシステム日付より設定します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
controllingArea - 管理領域
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「管理領域」・「日付」を引数より設定します。
SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
controllingArea - 管理領域
date - 日付
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              String personincharge,
                              String inChargeUser,
                              Date date)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「管理領域」・「利益センタ責任者」・「利益センタに責任のあるユーザ」を 引数より設定し、「日付」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
personincharge - 利益センタ責任者
inChargeUser - 利益センタに責任のあるユーザ
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              String personincharge,
                              String inChargeUser,
                              Date date,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「管理領域」・「利益センタ責任者」・「利益センタに責任のあるユーザ」・「日付」 を引数より設定します。

パラメータ:
controllingArea - 管理領域
personincharge - 利益センタ責任者
inChargeUser - 利益センタに責任のあるユーザ
date - 日付
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧（ProfitCenterインスタンスの配列）を取得します。

戻り値:
profitCenterList 利益センタ一覧
関連項目:
ProfitCenter

getValidTo

public String getValidTo(String profitCtr)
                  throws SAPAccountingSystemException
利益センタを指定して有効終了日を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
validTo 有効終了日
例外:
SAPAccountingSystemException - 会計業務システム例外

getPctrName

public String getPctrName(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して一般名称を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
pctrName 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getInCharge

public String getInCharge(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して利益センタ責任者を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
inCharge 利益センタ責任者
例外:
SAPAccountingSystemException - 会計業務システム例外

getInChargeUser

public String getInChargeUser(String profitCtr)
                       throws SAPAccountingSystemException
利益センタを指定して利益センタに責任のあるユーザを取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
inChargeUser 利益センタに責任のあるユーザ
例外:
SAPAccountingSystemException - 会計業務システム例外

setProfitCentList

public void setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

パラメータ:
profitCentList - 利益センタ一覧

getProfitCentList

public ProfitCenterList getProfitCentList()
利益センタ一覧を取得します｡

戻り値:
profitCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList
すべての実装インタフェース:
Serializable
public class ProfitCenterList
extends ReferenceController
implements Serializable

利益センタ一覧クラス

機能は以下の通り

  • 利益センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProfitCenterList(String controllingArea, String personincharge, String inChargeUser, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
メソッドの概要
ArrayList | getProfitCenterList() 利益センタ一覧（ProfitCenterインスタンスの配列）を取得します｡
void | setProfitCenterList(ArrayList profitCenterList) 利益センタ一覧（ProfitCenterインスタンスの配列）を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterList

public ProfitCenterList(String controllingArea,
                        String personincharge,
                        String inChargeUser,
                        String date,
                        SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し利益センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
personincharge - 利益センタ責任者
inChargeUser - 利益センタに責任のあるユーザ
date - 日付
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setProfitCenterList

public void setProfitCenterList(ArrayList profitCenterList)
利益センタ一覧（ProfitCenterインスタンスの配列）を設定します｡

パラメータ:
profitCenterList - 利益センタ一覧
関連項目:
ProfitCenter

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧（ProfitCenterインスタンスの配列）を取得します｡

戻り値:
利益センタ一覧
関連項目:
ProfitCenter

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Travel (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Travel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Travel
すべての実装インタフェース:
Serializable
public class Travel
extends Object
implements Serializable

旅費資金予算明細クラス
機能は以下の通り

  • 旅費資金予算明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Travel()
旅費資金予算明細情報を作成します。
Travel(int index)
旅費資金予算明細情報を作成します。
メソッドの概要
String | getApproved() 出張申請または出張承認済 (区分)を取得します｡
String | getCmmtItem() 予算コードを取得します｡
String | getCmmtItemLong() 予算コードを取得します｡
String | getCompCode() 会社コードを取得します｡
String | getCostcenter() 原価センタを取得します｡
String | getDeleteInd() 資金計画削除フラグを取得します｡
String | getFmTransDate() FM 取引日付を取得します｡
String | getFuncAreaLong() 機能領域を取得します｡
String | getFund() ファンドを取得します｡
String | getFundsCtr() 予算センタを取得します｡
String | getGlAccount() G/L 勘定コードを取得します｡
String | getGrantNbr() 補助金を取得します｡
String | getNetwork() 勘定割当のネットワーク番号を取得します｡
String | getObjId() 参照伝票: 現在の IDを取得します｡
String | getObjKey() オブジェクトキーを取得します｡
String | getObjPos() 参照明細を取得します｡
String | getObjSys() 元伝票の論理システムを取得します｡
String | getObjType() 参照処理を取得します｡
String | getOrderid() 指図番号を取得します｡
String | getPstngDate() 伝票の転記日付を取得します｡
String | getSegText() セグメントテキストを取得します｡
int | getTrIndex() レコード番号を取得します｡
String | getWbsElement() WBS 要素を取得します｡
void | setApproved(String approved) 出張申請または出張承認済 (区分)を設定します｡
void | setCmmtItem(String cmmtItem) 予算コードを設定します｡
void | setCmmtItemLong(String cmmtItemLong) 予算コードを設定します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCostcenter(String costcenter) 原価センタを設定します｡
void | setDeleteInd(String deleteInd) 資金計画削除フラグを設定します｡
void | setFmTransDate(String fmTransDate) FM 取引日付を設定します｡
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します｡
void | setFund(String fund) ファンドを設定します｡
void | setFundsCtr(String fundsCtr) 予算センタを設定します｡
void | setGlAccount(String glAccount) G/L 勘定コードを設定します｡
void | setGrantNbr(String grantNbr) 補助金を設定します｡
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します｡
void | setObjId(String objId) 参照伝票: 現在の IDを設定します｡
void | setObjKey(String objKey) オブジェクトキーを設定します｡
void | setObjPos(String objPos) 参照明細を設定します｡
void | setObjSys(String objSys) 元伝票の論理システムを設定します｡
void | setObjType(String objType) 参照処理を設定します｡
void | setOrderid(String orderid) 指図番号を設定します｡
void | setPstngDate(String pstngDate) 伝票の転記日付を設定します｡
void | setSegText(String segText) セグメントテキストを設定します｡
void | setTrIndex(int trIndex) レコード番号を設定します｡
void | setWbsElement(String wbsElement) WBS 要素を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Travel

public Travel()
旅費資金予算明細情報を作成します。

Travel

public Travel(int index)
旅費資金予算明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setObjType

public void setObjType(String objType)
参照処理を設定します｡

パラメータ:
objType - 参照処理

setObjKey

public void setObjKey(String objKey)
オブジェクトキーを設定します｡

パラメータ:
objKey - オブジェクトキー

setObjSys

public void setObjSys(String objSys)
元伝票の論理システムを設定します｡

パラメータ:
objSys - 元伝票の論理システム

setObjPos

public void setObjPos(String objPos)
参照明細を設定します｡

パラメータ:
objPos - 参照明細

setObjId

public void setObjId(String objId)
参照伝票: 現在の IDを設定します｡

パラメータ:
objId - 参照伝票: 現在の ID

setPstngDate

public void setPstngDate(String pstngDate)
伝票の転記日付を設定します｡

パラメータ:
pstngDate - 伝票の転記日付

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します｡

パラメータ:
glAccount - G/L 勘定コード

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します｡

パラメータ:
network - 勘定割当のネットワーク番号

setOrderid

public void setOrderid(String orderid)
指図番号を設定します｡

パラメータ:
orderid - 指図番号

setWbsElement

public void setWbsElement(String wbsElement)
WBS 要素を設定します｡

パラメータ:
wbsElement - WBS 要素

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します｡

パラメータ:
costcenter - 原価センタ

setSegText

public void setSegText(String segText)
セグメントテキストを設定します｡

パラメータ:
segText - セグメントテキスト

setDeleteInd

public void setDeleteInd(String deleteInd)
資金計画削除フラグを設定します｡

パラメータ:
deleteInd - 資金計画削除フラグ

setCmmtItem

public void setCmmtItem(String cmmtItem)
予算コードを設定します｡

パラメータ:
cmmtItem - 予算コード

setFund

public void setFund(String fund)
ファンドを設定します｡

パラメータ:
fund - ファンド

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します｡

パラメータ:
fundsCtr - 予算センタ

setApproved

public void setApproved(String approved)
出張申請または出張承認済 (区分)を設定します｡

パラメータ:
approved - 出張申請または出張承認済 (区分)

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
予算コードを設定します｡

パラメータ:
cmmtItemLong - 予算コード

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します｡

パラメータ:
grantNbr - 補助金

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します｡

パラメータ:
funcAreaLong - 機能領域

setFmTransDate

public void setFmTransDate(String fmTransDate)
FM 取引日付を設定します｡

パラメータ:
fmTransDate - FM 取引日付

setTrIndex

public void setTrIndex(int trIndex)
レコード番号を設定します｡

パラメータ:
trIndex - レコード番号

getObjType

public String getObjType()
参照処理を取得します｡

戻り値:
objType

getObjKey

public String getObjKey()
オブジェクトキーを取得します｡

戻り値:
objKey

getObjSys

public String getObjSys()
元伝票の論理システムを取得します｡

戻り値:
objSys

getObjPos

public String getObjPos()
参照明細を取得します｡

戻り値:
objPos

getObjId

public String getObjId()
参照伝票: 現在の IDを取得します｡

戻り値:
objId

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します｡

戻り値:
pstngDate

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します｡

戻り値:
glAccount

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します｡

戻り値:
network

getOrderid

public String getOrderid()
指図番号を取得します｡

戻り値:
orderid

getWbsElement

public String getWbsElement()
WBS 要素を取得します｡

戻り値:
wbsElement

getCostcenter

public String getCostcenter()
原価センタを取得します｡

戻り値:
costcenter

getSegText

public String getSegText()
セグメントテキストを取得します｡

戻り値:
segText

getDeleteInd

public String getDeleteInd()
資金計画削除フラグを取得します｡

戻り値:
deleteInd

getCmmtItem

public String getCmmtItem()
予算コードを取得します｡

戻り値:
cmmtItem

getFund

public String getFund()
ファンドを取得します｡

戻り値:
fund

getFundsCtr

public String getFundsCtr()
予算センタを取得します｡

戻り値:
fundsCtr

getApproved

public String getApproved()
出張申請または出張承認済 (区分)を取得します｡

戻り値:
approved

getCmmtItemLong

public String getCmmtItemLong()
予算コードを取得します｡

戻り値:
cmmtItemLong

getGrantNbr

public String getGrantNbr()
補助金を取得します｡

戻り値:
grantNbr

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します｡

戻り値:
funcAreaLong

getFmTransDate

public String getFmTransDate()
FM 取引日付を取得します｡

戻り値:
fmTransDate

getTrIndex

public int getTrIndex()
レコード番号を取得します｡

戻り値:
trIndex レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TravelAmount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス TravelAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount
すべての実装インタフェース:
Serializable
public class TravelAmount
extends Object
implements Serializable

旅費資金計画通貨項目クラス
機能は以下の通り

  • 旅費資金計画通貨項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TravelAmount()
旅費資金計画通貨項目情報を作成します。
TravelAmount(int index)
旅費資金計画通貨項目情報を作成します。
メソッドの概要
String | getAmtActual() 削減額を取得します｡
String | getAmtOpen() 未決済金額を取得します｡
String | getAmtOrigin() 元金額を取得します｡
String | getCurrency() 通貨コードを取得します｡
String | getCurrencyIso() ISO コード通貨を取得します｡
String | getCurrType() 通貨タイプおよび評価ビューを取得します｡
String | getExchRate() 換算レートを取得します｡
String | getExchRateV() 間接呼び値換算レートを取得します｡
String | getObjId() 参照伝票: 現在の IDを取得します｡
String | getObjKey() オブジェクトキーを取得します｡
String | getObjPos() 参照明細を取得します｡
String | getObjSys() 元伝票の論理システムを取得します｡
String | getObjType() 参照処理を取得します｡
String | getOrvaltype() 購買発注額/受注額の金額タイプを取得します｡
int | getTraIndex() レコード番号を取得します｡
void | setAmtActual(String amtActual) 削減額を設定します｡
void | setAmtOpen(String amtOpen) 未決済金額を設定します｡
void | setAmtOrigin(String amtOrigin) 元金額を設定します｡
void | setCurrency(String currency) 通貨コードを設定します｡
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します｡
void | setCurrType(String currType) 通貨タイプおよび評価ビューを設定します｡
void | setExchRate(String exchRate) 換算レートを設定します｡
void | setExchRateV(String exchRateV) 間接呼び値換算レートを設定します｡
void | setObjId(String objId) 参照伝票: 現在の IDを設定します｡
void | setObjKey(String objKey) オブジェクトキーを設定します｡
void | setObjPos(String objPos) 参照明細を設定します｡
void | setObjSys(String objSys) 元伝票の論理システムを設定します｡
void | setObjType(String objType) 参照処理を設定します｡
void | setOrvaltype(String orvaltype) 購買発注額/受注額の金額タイプを設定します｡
void | setTraIndex(int traIndex) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TravelAmount

public TravelAmount()
旅費資金計画通貨項目情報を作成します。

TravelAmount

public TravelAmount(int index)
旅費資金計画通貨項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setObjType

public void setObjType(String objType)
参照処理を設定します｡

パラメータ:
objType - 参照処理

setObjKey

public void setObjKey(String objKey)
オブジェクトキーを設定します｡

パラメータ:
objKey - オブジェクトキー

setObjSys

public void setObjSys(String objSys)
元伝票の論理システムを設定します｡

パラメータ:
objSys - 元伝票の論理システム

setObjPos

public void setObjPos(String objPos)
参照明細を設定します｡

パラメータ:
objPos - 参照明細

setObjId

public void setObjId(String objId)
参照伝票: 現在の IDを設定します｡

パラメータ:
objId - 参照伝票: 現在の ID

setOrvaltype

public void setOrvaltype(String orvaltype)
購買発注額/受注額の金額タイプを設定します｡

パラメータ:
orvaltype - 購買発注額/受注額の金額タイプ

setCurrType

public void setCurrType(String currType)
通貨タイプおよび評価ビューを設定します｡

パラメータ:
currType - 通貨タイプおよび評価ビュー

setCurrency

public void setCurrency(String currency)
通貨コードを設定します｡

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します｡

パラメータ:
currencyIso - ISO コード通貨

setAmtOrigin

public void setAmtOrigin(String amtOrigin)
元金額を設定します｡

パラメータ:
amtOrigin - 元金額

setAmtOpen

public void setAmtOpen(String amtOpen)
未決済金額を設定します｡

パラメータ:
amtOpen - 未決済金額

setAmtActual

public void setAmtActual(String amtActual)
削減額を設定します｡

パラメータ:
amtActual - 削減額

setExchRate

public void setExchRate(String exchRate)
換算レートを設定します｡

パラメータ:
exchRate - 換算レート

setExchRateV

public void setExchRateV(String exchRateV)
間接呼び値換算レートを設定します｡

パラメータ:
exchRateV - 間接呼び値換算レート

setTraIndex

public void setTraIndex(int traIndex)
レコード番号を設定します｡

パラメータ:
traIndex - レコード番号

getObjType

public String getObjType()
参照処理を取得します｡

戻り値:
objType

getObjKey

public String getObjKey()
オブジェクトキーを取得します｡

戻り値:
objKey

getObjSys

public String getObjSys()
元伝票の論理システムを取得します｡

戻り値:
objSys

getObjPos

public String getObjPos()
参照明細を取得します｡

戻り値:
objPos

getObjId

public String getObjId()
参照伝票: 現在の IDを取得します｡

戻り値:
objId

getOrvaltype

public String getOrvaltype()
購買発注額/受注額の金額タイプを取得します｡

戻り値:
orvaltype

getCurrType

public String getCurrType()
通貨タイプおよび評価ビューを取得します｡

戻り値:
currType

getCurrency

public String getCurrency()
通貨コードを取得します｡

戻り値:
currency

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します｡

戻り値:
currencyIso

getAmtOrigin

public String getAmtOrigin()
元金額を取得します｡

戻り値:
amtOrigin

getAmtOpen

public String getAmtOpen()
未決済金額を取得します｡

戻り値:
amtOpen

getAmtActual

public String getAmtActual()
削減額を取得します｡

戻り値:
amtActual

getExchRate

public String getExchRate()
換算レートを取得します｡

戻り値:
exchRate

getExchRateV

public String getExchRateV()
間接呼び値換算レートを取得します｡

戻り値:
exchRateV

getTraIndex

public int getTraIndex()
レコード番号を取得します｡

戻り値:
traIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.AbstractController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.AbstractController の使用

AbstractController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module での AbstractController の使用

jp.co.intra_mart.foundation.sap.module での AbstractController のサブクラス
class | ReferenceController 参照系モジュール共通コントローラ親クラス。
class | UpdateController 登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.accounting での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.accounting での AbstractController のサブクラス
class | AccEmployeePayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | AccEmployeePayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | BankList 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
class | BusinessAreaList 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
class | CompanyList 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
class | ControllingAreaList 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
class | CostCenterList 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
class | GlAccList 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
class | ProfitCenterList 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.financial での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.financial での AbstractController のサブクラス
class | CommonCenterGrpGetDetail 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | CreditorGetDetail 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
class | DebtorGetDetail 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
class | ExchangeRateGetDetail 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
class | InternalOrderGetDetail 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
class | InternalOrderGetList 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
class | ProjectGetInfo WBS情報取得クラス 機能は以下の通り WBS情報を取得します。

jp.co.intra_mart.foundation.sap.module.purchase での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase での AbstractController のサブクラス
class | GoodsMvtCreateController 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
class | GoodsMvtGetItemsController 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
class | MaterialAvailabilityController 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
class | MaterialGetAllController 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
class | MaterialGetList 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialGetListController 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialSaveReplicaController 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
class | PurchaseGetItemSrel 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
class | PurchaseOrderPayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
class | PurchaseRelease 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。
class | SupplierDetail 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
class | SupplierExistenceCheck 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での AbstractController のサブクラス
 class GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での AbstractController のサブクラス
 class GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での AbstractController のサブクラス
 class MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での AbstractController のサブクラス
 class MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での AbstractController のサブクラス
 class MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での AbstractController のサブクラス
 class StdMaterialGetIntNumberList
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.sales での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales での AbstractController のサブクラス
class | BillingDocCreateMultipleController 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
class | BillingDocGetListController 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
class | InquiryCreateFromData2Controller 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
class | QuotationCreateFromData2Controller 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
class | SalesOrderCreateFromDat2Controller 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。
class | SalesOrderGetListController 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
class | SalesOrderGetStatusController 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での AbstractController のサブクラス
 class BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での AbstractController のサブクラス
 class BillingDocGetDetail
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での AbstractController のサブクラス
 class BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での AbstractController のサブクラス
 class InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での AbstractController のサブクラス
 class QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での AbstractController のサブクラス
 class SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での AbstractController のサブクラス
 class SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での AbstractController のサブクラス
 class SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.ReferenceController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.ReferenceController の使用

ReferenceController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module.accounting での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.accounting での ReferenceController のサブクラス
class | BankList 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
class | BusinessAreaList 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
class | CompanyList 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
class | ControllingAreaList 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
class | CostCenterList 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
class | GlAccList 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
class | ProfitCenterList 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.financial での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.financial での ReferenceController のサブクラス
class | CommonCenterGrpGetDetail 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | CreditorGetDetail 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
class | DebtorGetDetail 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
class | ExchangeRateGetDetail 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
class | InternalOrderGetDetail 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
class | InternalOrderGetList 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
class | ProjectGetInfo WBS情報取得クラス 機能は以下の通り WBS情報を取得します。

jp.co.intra_mart.foundation.sap.module.purchase での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase での ReferenceController のサブクラス
class | GoodsMvtGetItemsController 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
class | MaterialAvailabilityController 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
class | MaterialGetAllController 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
class | MaterialGetList 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialGetListController 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
class | PurchaseGetItemSrel 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
class | SupplierDetail 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
class | SupplierExistenceCheck 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での ReferenceController のサブクラス
 class GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での ReferenceController のサブクラス
 class MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ReferenceController のサブクラス
 class MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での ReferenceController のサブクラス
 class StdMaterialGetIntNumberList
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.sales での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales での ReferenceController のサブクラス
class | BillingDocGetListController 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
class | SalesOrderGetListController 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
class | SalesOrderGetStatusController 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での ReferenceController のサブクラス
 class BillingDocGetDetail
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での ReferenceController のサブクラス
 class BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での ReferenceController のサブクラス
 class SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での ReferenceController のサブクラス
 class SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.UpdateController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.UpdateController の使用

UpdateController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |

jp.co.intra_mart.foundation.sap.module.accounting での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.accounting での UpdateController のサブクラス
class | AccEmployeePayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | AccEmployeePayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。

jp.co.intra_mart.foundation.sap.module.purchase での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase での UpdateController のサブクラス
class | GoodsMvtCreateController 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
class | MaterialSaveReplicaController 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
class | PurchaseOrderPayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
class | PurchaseRelease 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での UpdateController のサブクラス
 class GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での UpdateController のサブクラス
 class MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales での UpdateController のサブクラス
class | BillingDocCreateMultipleController 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
class | InquiryCreateFromData2Controller 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
class | QuotationCreateFromData2Controller 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
class | SalesOrderCreateFromDat2Controller 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での UpdateController のサブクラス
 class BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での UpdateController のサブクラス
 class InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での UpdateController のサブクラス
 class QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での UpdateController のサブクラス
 class SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected  void AbstractController.executeBapi(BapiController bapiController)
引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPost.executeBapi(BapiController bapiController)
会計伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

jp.co.intra_mart.foundation.sap.module.purchase での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException の使用

SAPModuleAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleAppException のサブクラス
 class SAPAccountingAppException
会計系APIアプリケーション例外クラス。

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleAppException のサブクラス
 class SAPFinancialAppException
会計系APIアプリケーション例外クラス。

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleAppException のサブクラス
 class SAPPurchaseAppException
購買系APIアプリケーション例外クラス。

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleAppException のサブクラス
 class SAPSalesAppException
販売管理系APIアプリケーション例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException の使用

SAPModuleSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleSystemException のサブクラス
 class SAPAccountingSystemException
会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleSystemException のサブクラス
 class SAPFinancialSystemException
会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleSystemException のサブクラス
 class SAPPurchaseSystemException
購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleSystemException のサブクラス
 class SAPSalesSystemException
販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.exception (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.exception
例外
SAPBapiReturnErrMessageExistException
SAPModuleAppException
SAPModuleSystemException


jp.co.intra_mart.foundation.sap.module.exception (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.exception

例外の概要
SAPBapiReturnErrMessageExistException | BAPI実行結果例外クラス
SAPModuleAppException | モジュール用データ取得・追加・更新APIアプリケーション例外クラス。
SAPModuleSystemException | モジュール用データ取得・追加・更新APIシステム例外クラス


jp.co.intra_mart.foundation.sap.module.exception クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.exception の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.exception の使用

jp.co.intra_mart.foundation.sap.module.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.accounting.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス。
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス。
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス。
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス。
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPBapiReturnErrMessageExistException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPBapiReturnErrMessageExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
すべての実装インタフェース:
Serializable
public class SAPBapiReturnErrMessageExistException
extends SAPException

BAPI実行結果例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPBapiReturnErrMessageExistException(String message)
BAPI実行結果例外
SAPBapiReturnErrMessageExistException(String message, Throwable ex)
BAPI実行結果例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPBapiReturnErrMessageExistException

public SAPBapiReturnErrMessageExistException(String message,
                                             Throwable ex)
BAPI実行結果例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPBapiReturnErrMessageExistException

public SAPBapiReturnErrMessageExistException(String message)
BAPI実行結果例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPModuleAppException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPModuleAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAccountingAppException, SAPFinancialAppException, SAPPurchaseAppException, SAPSalesAppException
public class SAPModuleAppException
extends SAPException

モジュール用データ取得・追加・更新APIアプリケーション例外クラス。

SAP リアルタイム連携API におけるBAPI 実行後の成功・失敗の標準の基準は、 各API でのBAPI 実行後にRETURN パラメータのTYPE 値を取得して、S（正常終了） または空文字以外が１つでも存在するかどうかです。
失敗の場合、本例外がスローされます。

関連項目:
直列化された形式

コンストラクタの概要
SAPModuleAppException(String message)
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleAppException(String message, Throwable ex)
モジュール用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPModuleAppException

public SAPModuleAppException(String message,
                             Throwable ex)
モジュール用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPModuleAppException

public SAPModuleAppException(String message)
モジュール用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SAPModuleSystemException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPModuleSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAccountingSystemException, SAPFinancialSystemException, SAPPurchaseSystemException, SAPSalesSystemException
public class SAPModuleSystemException
extends SAPException

モジュール用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPModuleSystemException(String message)
モジュール用データ取得・追加・更新APIシステム例外
SAPModuleSystemException(String message, Throwable ex)
モジュール用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPModuleSystemException

public SAPModuleSystemException(String message,
                                Throwable ex)
モジュール用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPModuleSystemException

public SAPModuleSystemException(String message)
モジュール用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract の使用

jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail の使用

CommonCenterGrpGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CommonCenterGrpGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial での CommonCenterGrpGetDetail のサブクラス
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail の使用

CreditorGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CreditorGetDetail の使用

CreditorGetDetail を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
 CreditorGetDetail CreditorGetDetailController.getCreditorGetDetail()
仕入先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail の使用

DebtorGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での DebtorGetDetail の使用

DebtorGetDetail を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
 DebtorGetDetail DebtorGetDetailController.getDebtorGetDetail()
得意先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchRate の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchRate の使用

ExchRate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での ExchRate の使用

ExchRate を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
ExchRate | ExchangeRateGetDetailController.getExchRate() 換算レート、係数 (通貨ペア)を取得します。
ExchRate | ExchangeRateGetDetail.getExchRate() 換算レート、係数 (通貨ペア)を取得します。

ExchRate 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ExchangeRateGetDetailController.setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。
void | ExchangeRateGetDetail.setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpActivity の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpActivity の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpActivity はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpMessage の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpMessage の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpMessage はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes の使用

jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues の使用

jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement の使用

jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.Language の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.Language の使用

Language を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での Language の使用

Language を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
Language | CostCenterGroupGetDetailController.getLanguage() Language in which Texts are Read(言語情報)を取得します。
Language | CommonCenterGrpGetDetail.getLanguage() Language in which Texts are Read(言語情報)を取得します。

Language 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | CostCenterGroupGetDetailController.setLanguage(Language language) Language in which Texts are Read(言語情報)を設定します。
void | CommonCenterGrpGetDetail.setLanguage(Language language) Language in which Texts are Read(言語情報)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.MasterData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.MasterData の使用

MasterData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での MasterData の使用

MasterData を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
MasterData | InternalOrderGetDetailController.getMasterData() 指図のマスタデータ構造を取得します。
MasterData | InternalOrderGetDetail.getMasterData() 指図のマスタデータ構造を取得します。

MasterData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | InternalOrderGetDetailController.setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。
void | InternalOrderGetDetail.setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.OrderList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.OrderList の使用

jp.co.intra_mart.foundation.sap.module.financial.OrderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition の使用

ProjectDefinition を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での ProjectDefinition の使用

ProjectDefinition を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
ProjectDefinition | ProjectGetInfoController.getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。
ProjectDefinition | ProjectGetInfo.getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。

ProjectDefinition 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ProjectGetInfoController.setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。
void | ProjectGetInfo.setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo の使用

jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController の使用

jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.SystemStatus の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.SystemStatus の使用

jp.co.intra_mart.foundation.sap.module.financial.SystemStatus はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.UserStatus の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.UserStatus の使用

jp.co.intra_mart.foundation.sap.module.financial.UserStatus はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException の使用

SAPFinancialAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での SAPFinancialAppException の使用

SAPFinancialAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。

SAPFinancialAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname, String langu, String languIso)
CostCenterGroupGetDetailController(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException の使用

SAPFinancialSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での SAPFinancialSystemException の使用

SAPFinancialSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfoController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 String ProjectGetInfoController.getProjectDefinition()
プロジェクト定義を識別するキーを取得します。
 String ProjectGetInfoController.getWithActivities()
従属活動を取得します。
 String ProjectGetInfoController.getWithMilestones()
従属 WBS マイルストーンを取得します。
 String ProjectGetInfoController.getWithSubtree()
サブプロジェクトを取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProjectGetInfo.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void ProjectGetInfo.setImportParam(BapiController bapiController)
WEBの詳細情報を検索する条件ををセットします。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetList.setImportParam(BapiController bapiController)
内部指図書（一覧）情報を検索する条件ををセットします。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void InternalOrderGetDetail.setImportParam(BapiController bapiController)
内部指図書詳細情報を検索する条件ををセットします。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void ExchangeRateGetDetail.setImportParam(BapiController bapiController)
為替換算レート情報を検索する条件ををセットします。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void DebtorGetDetail.setImportParam(BapiController bapiController)
得意先コードの詳細情報を検索する条件ををセットします。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CreditorGetDetail.setImportParam(BapiController bapiController)
仕入先コードの詳細情報を検索する条件ををセットします。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
 void CommonCenterGrpGetDetail.setImportParam(BapiController bapiController)
センタグループを検索する条件ををセットします。

SAPFinancialSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname, String langu, String languIso)
CostCenterGroupGetDetailController(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.financial.exception (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.financial.exception
例外
SAPFinancialAppException
SAPFinancialSystemException


jp.co.intra_mart.foundation.sap.module.financial.exception (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception

ＳＡＰ連携管理会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPFinancialAppException | 会計系APIアプリケーション例外クラス。
SAPFinancialSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の説明

ＳＡＰ連携管理会計系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.financial.exception クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.financial.exception の使用

jp.co.intra_mart.foundation.sap.module.financial.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module.financial.exception のクラス
SAPFinancialAppException
会計系APIアプリケーション例外クラス。
SAPFinancialSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPFinancialAppException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial.exception
クラス SAPFinancialAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
すべての実装インタフェース:
Serializable
public class SAPFinancialAppException
extends SAPModuleAppException

会計系APIアプリケーション例外クラス。

SAP リアルタイム連携API におけるBAPI 実行後の成功・失敗の標準の基準は、 各API でのBAPI 実行後にRETURN パラメータのTYPE 値を取得して、S（正常終了） または空文字以外が１つでも存在するかどうかです。
失敗の場合、本例外がスローされます。

関連項目:
直列化された形式

コンストラクタの概要
SAPFinancialAppException(String message)
会計系APIアプリケーション例外
SAPFinancialAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPFinancialAppException

public SAPFinancialAppException(String message,
                                Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPFinancialAppException

public SAPFinancialAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPFinancialSystemException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial.exception
クラス SAPFinancialSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException
すべての実装インタフェース:
Serializable
public class SAPFinancialSystemException
extends SAPModuleSystemException

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPFinancialSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPFinancialSystemException

public SAPFinancialSystemException(String message,
                                   Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AllowedBusTract (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス AllowedBusTract

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract
すべての実装インタフェース:
Serializable
public class AllowedBusTract
extends Object
implements Serializable

使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り

  • 使用可能業務トランザクションのテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AllowedBusTract()
使用可能業務トランザクションのテーブルを作成します。
メソッドの概要
String | getDescript() テキスト (30 文字)を取得します。
String | getTrans() 取引を取得します。
void | setDescript(String strDescript) テキスト (30 文字)を設定します。
void | setTrans(String strTrans) 取引を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AllowedBusTract

public AllowedBusTract()
使用可能業務トランザクションのテーブルを作成します。

メソッドの詳細

getTrans

public String getTrans()
取引を取得します。

戻り値:
srtTrans 取引

getDescript

public String getDescript()
テキスト (30 文字)を取得します。

戻り値:
srtDescript テキスト (30 文字)

setTrans

public void setTrans(String strTrans)
取引を設定します。

パラメータ:
strTrans - 取引

setDescript

public void setDescript(String strDescript)
テキスト (30 文字)を設定します。

パラメータ:
strDescript - テキスト (30 文字)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CommonCenterGrpGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CommonCenterGrpGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
CostCenterGroupGetDetail, ProfitCenterGrpGetDetail
public class CommonCenterGrpGetDetail
extends ReferenceController
implements Serializable

原価・利益センタグループ情報取得共通クラス
機能は以下の通り

  • 原価・利益センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
メソッドの概要
String | getControllingarea() 管理領域を取得します。
String | getGroupname() グループ名を取得します。
ArrayList | getHierarchyNodesList() 階層ノード一覧（HierarchyNodesインスタンスの配列）を取得します。
ArrayList | getHierarchyValuesList() 階層値一覧（HierarchyValuesインスタンスの配列）を取得します。
Language | getLanguage() Language in which Texts are Read(言語情報)を取得します。
void | setControllingarea(String strControllingarea) 管理領域を設定します。
void | setExportParam(BapiController bapiController) センタグループ情報ををセットします。
void | setGroupname(String strGroupname) グループ名を設定します。
void | setHierarchyNodesList(ArrayList hierarchyNodesList) 階層ノード一覧（HierarchyNodesインスタンスの配列）を設定します。
void | setHierarchyValuesList(ArrayList hierarchyValuesList) 階層値一覧（HierarchyValuesインスタンスの配列）を設定します。
void | setImportParam(BapiController bapiController) センタグループを検索する条件ををセットします。
void | setLanguage(Language language) Language in which Texts are Read(言語情報)を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                String langu,
                                String languIso,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
langu - 言語キー
languIso - ISO639準拠の言語
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
センタグループを検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
センタグループ情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

setLanguage

public void setLanguage(Language language)
Language in which Texts are Read(言語情報)を設定します。

パラメータ:
language - Language in which Texts are Read(言語情報)

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

getLanguage

public Language getLanguage()
Language in which Texts are Read(言語情報)を取得します。

戻り値:
language Language in which Texts are Read(言語情報)

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧（HierarchyNodesインスタンスの配列）を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧
関連項目:
HierarchyNodes

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧（HierarchyValuesインスタンスの配列）を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧
関連項目:
HierarchyValues

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧（HierarchyNodesインスタンスの配列）を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧
関連項目:
HierarchyNodes

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧（HierarchyValuesインスタンスの配列）を取得します。

戻り値:
hierarchyValuesList 階層値一覧
関連項目:
HierarchyValues

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterGroupGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CostCenterGroupGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
                拡張 jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail
すべての実装インタフェース:
Serializable
public class CostCenterGroupGetDetail
extends CommonCenterGrpGetDetail
implements Serializable

原価センタグループ情報取得クラス
機能は以下の通り

  • 原価センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
メソッドの概要
 void executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail から継承したメソッド
getControllingarea, getGroupname, getHierarchyNodesList, getHierarchyValuesList, getLanguage, setControllingarea, setExportParam, setGroupname, setHierarchyNodesList, setHierarchyValuesList, setImportParam, setLanguage, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(String controllingarea,
                                String groupname,
                                String langu,
                                String languIso,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
langu - 言語キー
languIso - ISO639準拠の言語
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより原価センタグループ検索を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterGroupGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CostCenterGroupGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController
すべての実装インタフェース:
Serializable
public class CostCenterGroupGetDetailController
extends Object
implements Serializable

原価センタグループコントローラクラス
機能は以下の通り

  • 原価センタグループを取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterGroupGetDetailController()
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname, String langu, String languIso)
CostCenterGroupGetDetailController(String controllingarea, String groupname, String langu, String languIso, SapClient sapClient)
メソッドの概要
 void executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 String getControllingarea()
管理領域を取得します。
 String getGroupname()
グループ名を取得します。
 ArrayList getHierarchyNodesList()
階層ノード一覧（HierarchyNodesインスタンスの配列）を取得します。
 ArrayList getHierarchyValuesList()
階層値一覧（HierarchyValuesインスタンスの配列）を取得します。
 Language getLanguage()
Language in which Texts are Read(言語情報)を取得します。
 void setControllingarea(String strControllingarea)
管理領域を設定します。
 void setGroupname(String strGroupname)
グループ名を設定します。
 void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧（HierarchyNodesインスタンスの配列）を設定します。
 void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧（HierarchyValuesインスタンスの配列）を設定します。
 void setLanguage(Language language)
Language in which Texts are Read(言語情報)を設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname,
                                          String langu,
                                          String languIso)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
langu - 言語キー
languIso - ISO639準拠の言語
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname,
                                          String langu,
                                          String languIso,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
langu - 言語キー
languIso - ISO639準拠の言語
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController()
CostCenterGroupGetDetailControllerのコンストラクタを生成します。

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

setLanguage

public void setLanguage(Language language)
Language in which Texts are Read(言語情報)を設定します。

パラメータ:
language - Language in which Texts are Read(言語情報)

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

getLanguage

public Language getLanguage()
Language in which Texts are Read(言語情報)を取得します。

戻り値:
language Language in which Texts are Read(言語情報)

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧（HierarchyNodesインスタンスの配列）を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧
関連項目:
HierarchyNodes

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧（HierarchyValuesインスタンスの配列）を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧
関連項目:
HierarchyValues

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧（HierarchyNodesインスタンスの配列）を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧
関連項目:
HierarchyNodes

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧（HierarchyValuesインスタンスの配列）を取得します。

戻り値:
hierarchyValuesList 階層値一覧
関連項目:
HierarchyValues

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreditorGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CreditorGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail
すべての実装インタフェース:
Serializable
public class CreditorGetDetail
extends ReferenceController
implements Serializable

仕入先詳細情報取得クラス
機能は以下の通り

  • 仕入先詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより仕入先コードを検索します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getCreditorid() 仕入先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setCreditorid(String strCreditorid) 仕入先コードを設定します｡
void | setExportParam(BapiController bapiController) 仕入先コードの詳細情報ををセットします。
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setImportParam(BapiController bapiController) 仕入先コードの詳細情報を検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreditorGetDetail

public CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

CreditorGetDetail

public CreditorGetDetail(String creditorid,
                         String companycode,
                         SapClient sapClient)
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPFinancialAppException,
                         SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより仕入先コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
仕入先コードの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
仕入先コードの詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getCreditorid

public String getCreditorid()
仕入先コードを取得します｡

戻り値:
strCreditorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setCreditorid

public void setCreditorid(String strCreditorid)
仕入先コードを設定します｡

パラメータ:
strCreditorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreditorGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CreditorGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController
すべての実装インタフェース:
Serializable
public class CreditorGetDetailController
extends Object
implements Serializable

仕入先詳細コントローラクラス
機能は以下の通り

  • 仕入先詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CreditorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
メソッドの概要
ArrayList | getBankDataList() 銀行データ情報を取得します。
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CreditorGetDetail | getCreditorGetDetail() 仕入先マスタ詳細情報を取得します｡
String | getCreditorid() 仕入先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strCreditorid) 仕入先コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreditorGetDetailController

public CreditorGetDetailController(String creditorid,
                                   String companycode)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPFinancialAppException,
                                   SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CreditorGetDetailController

public CreditorGetDetailController(String creditorid,
                                   String companycode,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPFinancialAppException,
                                   SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CreditorGetDetailController

public CreditorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。

CreditorGetDetailController

public CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setDebtorid

public void setDebtorid(String strCreditorid)
仕入先コードを設定します｡

パラメータ:
strCreditorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

getCreditorGetDetail

public CreditorGetDetail getCreditorGetDetail()
仕入先マスタ詳細情報を取得します｡

戻り値:
DebtorGetDetail

getCreditorid

public String getCreditorid()
仕入先コードを取得します｡

戻り値:
strCreditorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DebtorGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス DebtorGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail
すべての実装インタフェース:
Serializable
public class DebtorGetDetail
extends ReferenceController
implements Serializable

得意先詳細情報取得クラス
機能は以下の通り

  • 得意先詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより得意先コードを検索します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getDebtorid() 得意先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strDebtorid) 得意先コードを設定します｡
void | setExportParam(BapiController bapiController) 得意先コードの詳細情報ををセットします。
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setImportParam(BapiController bapiController) 得意先コードの詳細情報を検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DebtorGetDetail

public DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

DebtorGetDetail

public DebtorGetDetail(String Debtorid,
                       String Companycode,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPFinancialAppException,
                       SAPFinancialSystemException
パラメータ:
Debtorid - 得意先コード
Companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより得意先コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
得意先コードの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
得意先コードの詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getDebtorid

public String getDebtorid()
得意先コードを取得します｡

戻り値:
strDebtorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setDebtorid

public void setDebtorid(String strDebtorid)
得意先コードを設定します｡

パラメータ:
strDebtorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DebtorGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス DebtorGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController
すべての実装インタフェース:
Serializable
public class DebtorGetDetailController
extends Object
implements Serializable

得意先詳細コントローラクラス
機能は以下の通り

  • 得意先詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
DebtorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
メソッドの概要
ArrayList | getBankDataList() 銀行データ情報を取得します。
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
DebtorGetDetail | getDebtorGetDetail() 得意先マスタ詳細情報を取得します｡
String | getDebtorid() 得意先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strDebtorid) 得意先コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DebtorGetDetailController

public DebtorGetDetailController(String debtorid,
                                 String companycode)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPFinancialAppException,
                                 SAPFinancialSystemException
パラメータ:
debtorid - 得意先コード
companycode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

DebtorGetDetailController

public DebtorGetDetailController(String debtorid,
                                 String companycode,
                                 SapClient sapClient)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPFinancialAppException,
                                 SAPFinancialSystemException
パラメータ:
debtorid - 得意先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

DebtorGetDetailController

public DebtorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。

DebtorGetDetailController

public DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setDebtorid

public void setDebtorid(String strDebtorid)
得意先コードを設定します｡

パラメータ:
strDebtorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

getDebtorGetDetail

public DebtorGetDetail getDebtorGetDetail()
得意先マスタ詳細情報を取得します｡

戻り値:
DebtorGetDetail

getDebtorid

public String getDebtorid()
得意先コードを取得します｡

戻り値:
strDebtorid 得意先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchangeRateGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchangeRateGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail
すべての実装インタフェース:
Serializable
public class ExchangeRateGetDetail
extends ReferenceController
implements Serializable

為替換算レート情報取得クラス
機能は以下の通り

  • 為替換算レート情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより為替換算レート情報を検索します。
String | getDate() 起算日を取得します。
ExchRate | getExchRate() 換算レート、係数 (通貨ペア)を取得します。
String | getFromCurr() 換算前通貨を取得します。
String | getRateType() 換算レートタイプを取得します。
String | getToCurrncy() 換算後通貨を取得します。
void | setDate(String strDate) 起算日を設定します。
void | setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。
void | setExportParam(BapiController bapiController) 為替換算レート情報ををセットします。
void | setFromCurr(String strFromCurr) 換算前通貨を設定します。
void | setImportParam(BapiController bapiController) 為替換算レート情報を検索する条件ををセットします。
void | setRateType(String strRateType) 換算レートタイプを設定します。
void | setToCurrncy(String strToCurrncy) 換算後通貨を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExchangeRateGetDetail

public ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

ExchangeRateGetDetail

public ExchangeRateGetDetail(String rateType,
                             String fromCurr,
                             String toCurrncy,
                             String date,
                             SapClient sapClient)
                      throws SAPAuthAppException,
                             SAPAuthSystemException,
                             SAPGeneralAppException,
                             SAPGeneralSystemException,
                             SAPFinancialAppException,
                             SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより為替換算レート情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
為替換算レート情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
為替換算レート情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setDate

public void setDate(String strDate)
起算日を設定します。

パラメータ:
strDate - 起算日

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtTo_Currncy 換算後通貨

getDate

public String getDate()
起算日を取得します。

戻り値:
srtDate 起算日

setExchRate

public void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。

パラメータ:
exchRate - 換算レート、係数 (通貨ペア)

getExchRate

public ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。

戻り値:
exchRate 換算レート、係数 (通貨ペア)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchangeRateGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchangeRateGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController
すべての実装インタフェース:
Serializable
public class ExchangeRateGetDetailController
extends Object
implements Serializable

為替換算レートコントローラクラス
機能は以下の通り

  • 為替換算レートを取得します。

関連項目:
直列化された形式

コンストラクタの概要
ExchangeRateGetDetailController()
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
メソッドの概要
 void executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 String getDate()
起算日を取得します。
 ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。
 String getFromCurr()
換算前通貨を取得します。
 String getRateType()
換算レートタイプを取得します。
 String getToCurrncy()
換算後通貨を取得します。
 void setDate(String strDate)
起算日を設定します。
 void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。
 void setFromCurr(String strFromCurr)
換算前通貨を設定します。
 void setRateType(String strRateType)
換算レートタイプを設定します。
 void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(String rateType,
                                       String fromCurr,
                                       String toCurrncy,
                                       String date)
                                throws SAPAuthAppException,
                                       SAPAuthSystemException,
                                       SAPGeneralAppException,
                                       SAPGeneralSystemException,
                                       SAPFinancialAppException,
                                       SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(String rateType,
                                       String fromCurr,
                                       String toCurrncy,
                                       String date,
                                       SapClient sapClient)
                                throws SAPAuthAppException,
                                       SAPAuthSystemException,
                                       SAPGeneralAppException,
                                       SAPGeneralSystemException,
                                       SAPFinancialAppException,
                                       SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ExchangeRateGetDetailController

public ExchangeRateGetDetailController()
ExchangeRateGetDetailControllerのコンストラクタを生成します。

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setDate

public void setDate(String strDate)
起算日を設定します。

パラメータ:
strDate - 起算日

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtTo_Currncy 換算後通貨

getDate

public String getDate()
起算日を取得します。

戻り値:
srtDate 起算日

setExchRate

public void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。

パラメータ:
exchRate - 換算レート、係数 (通貨ペア)

getExchRate

public ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。

戻り値:
exchRate 換算レート、係数 (通貨ペア)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchRate (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchRate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchRate
すべての実装インタフェース:
Serializable
public class ExchRate
extends Object
implements Serializable

換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り

  • 換算レート、係数 (通貨ペア)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExchRate()
換算レート、係数 (通貨ペア)を作成します。
メソッドの概要
String | getExchRate() 直接呼び値換算レートを取得します。
String | getExchRateV() 間接呼び値換算レートを取得します。
String | getFromCurr() 換算前通貨を取得します。
String | getFromFactor() 換算前 通貨単位の係数を取得します。
String | getFromFactorV() 換算前 通貨単位の係数を取得します。
String | getRateType() 換算レートタイプを取得します。
String | getToCurrncy() 換算後通貨を取得します。
String | getToFactor() 換算後 通貨単位の係数を取得します。
String | getToFactorV() 換算後 通貨単位の係数を取得します。
String | getValidFrom() エントリの有効開始日を取得します。
void | setExchRate(String strExchRate) 直接呼び値換算レートを設定します。
void | setExchRateV(String strExchRateV) 間接呼び値換算レートを設定します。
void | setFromCurr(String strFromCurr) 換算前通貨を設定します。
void | setFromFactor(String strFromFactor) 換算前 通貨単位の係数を設定します。
void | setFromFactorV(String strFromFactorV) 換算前 通貨単位の係数を設定します。
void | setRateType(String strRateType) 換算レートタイプを設定します。
void | setToCurrncy(String strToCurrncy) 換算後通貨を設定します。
void | setToFactor(String strToFactor) 換算後 通貨単位の係数を設定します。
void | setToFactorV(String strToFactorV) 換算後 通貨単位の係数を設定します。
void | setValidFrom(String strValidFrom) エントリの有効開始日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExchRate

public ExchRate()
換算レート、係数 (通貨ペア)を作成します。

メソッドの詳細

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtToCurrncy 換算後通貨

getValidFrom

public String getValidFrom()
エントリの有効開始日を取得します。

戻り値:
srtValidFrom エントリの有効開始日

getExchRate

public String getExchRate()
直接呼び値換算レートを取得します。

戻り値:
srtExchRate 直接呼び値換算レート

getFromFactor

public String getFromFactor()
換算前 通貨単位の係数を取得します。

戻り値:
srtFromFactor 換算前 通貨単位の係数

getToFactor

public String getToFactor()
換算後 通貨単位の係数を取得します。

戻り値:
srtToFactor 換算後 通貨単位の係数

getExchRateV

public String getExchRateV()
間接呼び値換算レートを取得します。

戻り値:
srtExchRateV 間接呼び値換算レート

getFromFactorV

public String getFromFactorV()
換算前 通貨単位の係数を取得します。

戻り値:
srtFromFactorV 換算前 通貨単位の係数

getToFactorV

public String getToFactorV()
換算後 通貨単位の係数を取得します。

戻り値:
srtToFactorV 換算後 通貨単位の係数

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setValidFrom

public void setValidFrom(String strValidFrom)
エントリの有効開始日を設定します。

パラメータ:
strValidFrom - エントリの有効開始日

setExchRate

public void setExchRate(String strExchRate)
直接呼び値換算レートを設定します。

パラメータ:
strExchRate - 直接呼び値換算レート

setFromFactor

public void setFromFactor(String strFromFactor)
換算前 通貨単位の係数を設定します。

パラメータ:
strFromFactor - 換算前 通貨単位の係数

setToFactor

public void setToFactor(String strToFactor)
換算後 通貨単位の係数を設定します。

パラメータ:
strToFactor - 換算後 通貨単位の係数

setExchRateV

public void setExchRateV(String strExchRateV)
間接呼び値換算レートを設定します。

パラメータ:
strExchRateV - 間接呼び値換算レート

setFromFactorV

public void setFromFactorV(String strFromFactorV)
換算前 通貨単位の係数を設定します。

パラメータ:
strFromFactorV - 換算前 通貨単位の係数

setToFactorV

public void setToFactorV(String strToFactorV)
換算後 通貨単位の係数を設定します。

パラメータ:
strToFactorV - 換算後 通貨単位の係数

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpActivity (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpActivity

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpActivity
すべての実装インタフェース:
Serializable
public class ExpActivity
extends Object
implements Serializable

活動に関する詳細情報クラス 機能は以下の通り

  • 活動に関する詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpActivity()
活動に関する詳細情報を作成します。
メソッドの概要
String | getActivity() ネットワーク/標準ネットワークの活動番号を取得します。
String | getActivityCosts() 活動の原価を取得します。
String | getActtype() 活動タイプを取得します。
String | getActualCost() 実際原価を取得します。
String | getActualFinishDate() 実績終了日: 実行 (日付)を取得します。
String | getActualStartDate() 実績開始日: 実行 (日付)を取得します。
String | getComplete() 最終確認の有効化を取得します。
String | getConstraintFinishDate() 活動の基準終了日に対する制約を取得します。
String | getConstraintFinishDateFc() 予測終了日付を取得します。
String | getConstraintFinishTime() 活動の基準終了時間を取得します。
String | getConstraintFinishTimeFc() 活動の予測終了時間を取得します。
String | getConstraintStartDate() 活動の基準開始日に対する制約を取得します。
String | getConstraintStartDateFc() 活動の予測開始日を取得します。
String | getConstraintStartTime() 活動の基準開始時間の制約を取得します。
String | getConstraintStartTimeFc() 活動の需要予測開始時間を取得します。
String | getConstraintTypeFinish() 活動の終了日に対する制約を取得します。
String | getConstraintTypeFinishFc() 活動終了の制約条件付き需要予測日付を取得します。
String | getConstraintTypeStart() 活動の基準開始日に対する制約を取得します。
String | getConstraintTypeStartFc() 活動開始の制約条件付き需要予測日付を取得します。
String | getControlKey() 管理キーを取得します。
String | getControllingAreaCurrency() 通貨コードを取得します。
String | getCostElem() 原価要素を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() 作業テキスト (短)を取得します。
String | getDistributingKey() 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。
String | getDurationConfirmFc() 確認の予測活動期間を取得します。
String | getDurationConfirmFcUnit() 確認の予測期間単位を取得します。
String | getDurationConfirmFcUnitIso() 単位の ISO コードを取得します。
String | getDurationMinimum() 最短活動期間を取得します。
String | getDurationMinimumFc() 活動の最小期間(需要予測より)を取得します。
String | getDurationMinimumFcUnit() 予測最短期間の単位を取得します。
String | getDurationMinimumFcUnitIso() 単位の ISO コードを取得します。
String | getDurationMinimumUnit() 最短期間の単位を取得します。
String | getDurationMinimumUnitIso() 単位の ISO コードを取得します。
String | getDurationNormal() 標準活動期間を取得します。
String | getDurationNormalFc() 標準活動期間 (予測)を取得します。
String | getDurationNormalFcUnit() 標準予測期間の単位を取得します。
String | getDurationNormalFcUnitIso() 単位の ISO コードを取得します。
String | getDurationNormalUnit() 標準期間/単位を取得します。
String | getDurationNormalUnitIso() 単位の ISO コードを取得します。
String | getDurationScheduled() 処理時間を取得します。
String | getDurationScheduledFc() 処理時間の長さ (予測値)を取得します。
String | getDurationScheduledUnit() 処理時間単位を取得します。
String | getDurationScheduledUnitIso() 単位の ISO コードを取得します。
String | getEarlyFinishDate() 最早計画終了: 実行 (日)を取得します。
String | getEarlyFinishDateFc() 最早計画終了日 (予測)を取得します。
String | getEarlyFinishTime() 最早計画終了: 実行 (時刻)を取得します。
String | getEarlyFinishTimeFc() 最早計画終了時間(需要予測)を取得します。
String | getEarlyStartDate() 最早計画開始: 実行 (日)を取得します。
String | getEarlyStartDateFc() 最早計画開始日付(需要予測)を取得します。
String | getEarlyStartTime() 最早計画開始: 作業実施(時間)を取得します。
String | getEarlyStartTimeFc() 最早計画開始時間(需要予測)を取得します。
String | getFactoryCalendar() 稼働日カレンダを取得します。
String | getFlexibleDuration() 区分: 可変期間を取得します。
String | getFloatFree() 自由余裕を取得します。
String | getFloatFreeFc() 自由余裕 (予測)を取得します。
String | getFloatTotal() 余裕合計を取得します。
String | getFloatTotalFc() 余裕合計 (予測)を取得します。
String | getForecastFinishDate() 予測終了日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getInfoRec() 購買情報番号を取得します。
String | getLatestFinishDate() 計画最遅終了: 作業(日付)を取得します。
String | getLatestFinishDateFc() 最遅計画済終了日付(需要予測)を取得します。
String | getLatestFinishTime() 計画最遅終了: 作業(時間)を取得します。
String | getLatestFinishTimeFc() 最遅計画終了時間 (予測)を取得します。
String | getLatestStartDate() 計画最遅開始: 作業(日付)を取得します。
String | getLatestStartDateFc() 最遅計画済開始日付(需要予測)を取得します。
String | getLatestStartTime() 計画最遅開始: 作業(時間)を取得します。
String | getLatestStartTimeFc() 最遅計画済開始時間(需要予測)を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMilestone() 用途を取得します。
String | getNetwork() ネットワーク番号を取得します。
String | getNotMrpApplicable() 区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。
String | getNumberOfCapacities() 所要能力数を取得します。
String | getObjectclass() オブジェクトクラス (言語非依存)を取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getOperationMeasureUnit() 活動単位を取得します。
String | getOperationMeasureUnitIso() 単位の ISO コードを取得します。
String | getPercentOfWork() 作業の比率 (%)を取得します。
String | getPlannedCost() 計画原価を取得します。
String | getPlant() プラントを取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPrice() 価格を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getPriority() 優先度を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjectSummarization() 区分: プロジェクト集計用に活動を考慮を取得します。
String | getPurchOrg() 購買組織を取得します。
String | getPurGroup() 購買グループを取得します。
String | getReferencePoint() BOM 転送の参照ポイントを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnWork() 作業単位を取得します。
String | getUnWorkIso() 単位の ISO コードを取得します。
String | getUserFieldChar10_1() ユーザ定義項目 (10 文字)を取得します。
String | getUserFieldChar10_2() ユーザ定義項目 (10 文字)を取得します。
String | getUserFieldChar20_1() 20 文字のユーザ項目を取得します。
String | getUserFieldChar20_2() 20 文字のユーザ項目を取得します。
String | getUserFieldCuky1() ユーザ項目: 値項目の単位を取得します。
String | getUserFieldCuky1Iso() ISO 通貨コードを取得します。
String | getUserFieldCuky2() ユーザ項目: 値項目の単位を取得します。
String | getUserFieldCuky2Iso() ISO 通貨コードを取得します。
String | getUserFieldCurr1() 値のユーザ定義項目 (長さ 10,3)を取得します。
String | getUserFieldCurr2() 値のユーザ定義項目 (長さ 10,3)を取得します。
String | getUserFieldDate1() 日付のユーザ項目を取得します。
String | getUserFieldDate2() 日付のユーザ項目を取得します。
String | getUserFieldFlag1() ユーザ定義項目: レポート区分を取得します。
String | getUserFieldFlag2() ユーザ定義項目: レポート区分を取得します。
String | getUserFieldKey() ユーザ定義項目のキーワード IDを取得します。
String | getUserFieldQuan1() 数量のユーザ項目 (長さ 10,3)を取得します。
String | getUserFieldQuan2() 数量のユーザ項目 (長さ 10,3)を取得します。
String | getUserFieldUnit1() ユーザ項目: 数量項目の単位を取得します。
String | getUserFieldUnit1Iso() 単位の ISO コードを取得します。
String | getUserFieldUnit2() ユーザ項目: 数量項目の単位を取得します。
String | getUserFieldUnit2Iso() 単位の ISO コードを取得します。
String | getVendorNo() 仕入先または債権者の勘定コードを取得します。
String | getWbsElement() WBS 要素を取得します。
String | getWorkActivity() 活動に含まれる作業を取得します。
String | getWorkActual() 実績作業を取得します。
String | getWorkCntr() 作業区を取得します。
String | getWorkForecast() 予測作業 (実績 + 残存)を取得します。
void | setActivity(String strActivity) ネットワーク/標準ネットワークの活動番号を設定します。
void | setActivityCosts(String strActivityCosts) 活動の原価を設定します。
void | setActtype(String strActtype) 活動タイプを設定します。
void | setActualCost(String strActualCost) 実際原価を設定します。
void | setActualFinishDate(String strActualFinishDate) 実績終了日: 実行 (日付)を設定します。
void | setActualStartDate(String strActualStartDate) 実績開始日: 実行 (日付)を設定します。
void | setComplete(String strComplete) 最終確認の有効化を設定します。
void | setConstraintFinishDate(String strConstraintFinishDate) 活動の基準終了日に対する制約を設定します。
void | setConstraintFinishDateFc(String strConstraintFinishDateFc) 予測終了日付を設定します。
void | setConstraintFinishTime(String strConstraintFinishTime) 活動の基準終了時間を設定します。
void | setConstraintFinishTimeFc(String strConstraintFinishTimeFc) 活動の予測終了時間を設定します。
void | setConstraintStartDate(String strConstraintStartDate) 活動の基準開始日に対する制約を設定します。
void | setConstraintStartDateFc(String strConstraintStartDateFc) 活動の予測開始日を設定します。
void | setConstraintStartTime(String strConstraintStartTime) 活動の基準開始時間の制約を設定します。
void | setConstraintStartTimeFc(String strConstraintStartTimeFc) 活動の需要予測開始時間を設定します。
void | setConstraintTypeFinish(String strConstraintTypeFinish) 活動の終了日に対する制約を設定します。
void | setConstraintTypeFinishFc(String strConstraintTypeFinishFc) 活動終了の制約条件付き需要予測日付を設定します。
void | setConstraintTypeStart(String strConstraintTypeStart) 活動の基準開始日に対する制約を設定します。
void | setConstraintTypeStartFc(String strConstraintTypeStartFc) 活動開始の制約条件付き需要予測日付を設定します。
void | setControlKey(String strControlKey) 管理キーを設定します。
void | setControllingAreaCurrency(String strControllingAreaCurrency) 通貨コードを設定します。
void | setCostElem(String strCostElem) 原価要素を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) 作業テキスト (短)を設定します。
void | setDistributingKey(String strDistributingKey) 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。
void | setDurationConfirmFc(String strDurationConfirmFc) 確認の予測活動期間を設定します。
void | setDurationConfirmFcUnit(String strDurationConfirmFcUnit) 確認の予測期間単位を設定します。
void | setDurationConfirmFcUnitIso(String strDurationConfirmFcUnitIso) 単位の ISO コードを設定します。
void | setDurationMinimum(String strDurationMinimum) 最短活動期間を設定します。
void | setDurationMinimumFc(String strDurationMinimumFc) 活動の最小期間(需要予測より)を設定します。
void | setDurationMinimumFcUnit(String strDurationMinimumFcUnit) 予測最短期間の単位を設定します。
void | setDurationMinimumFcUnitIso(String strDurationMinimumFcUnitIso) 単位の ISO コードを設定します。
void | setDurationMinimumUnit(String strDurationMinimumUnit) 最短期間の単位を設定します。
void | setDurationMinimumUnitIso(String strDurationMinimumUnitIso) 単位の ISO コードを設定します。
void | setDurationNormal(String strDurationNormal) 標準活動期間を設定します。
void | setDurationNormalFc(String strDurationNormalFc) 標準活動期間 (予測)を設定します。
void | setDurationNormalFcUnit(String strDurationNormalFcUnit) 標準予測期間の単位を設定します。
void | setDurationNormalFcUnitIso(String strDurationNormalFcUnitIso) 単位の ISO コードを設定します。
void | setDurationNormalUnit(String strDurationNormalUnit) 標準期間/単位を設定します。
void | setDurationNormalUnitIso(String strDurationNormalUnitIso) 単位の ISO コードを設定します。
void | setDurationScheduled(String strDurationScheduled) 処理時間を設定します。
void | setDurationScheduledFc(String strDurationScheduledFc) 処理時間の長さ (予測値)を設定します。
void | setDurationScheduledUnit(String strDurationScheduledUnit) 処理時間単位を設定します。
void | setDurationScheduledUnitIso(String strDurationScheduledUnitIso) 単位の ISO コードを設定します。
void | setEarlyFinishDate(String strEarlyFinishDate) 最早計画終了: 実行 (日)を設定します。
void | setEarlyFinishDateFc(String strEarlyFinishDateFc) 最早計画終了日 (予測)を設定します。
void | setEarlyFinishTime(String strEarlyFinishTime) 最早計画終了: 実行 (時刻)を設定します。
void | setEarlyFinishTimeFc(String strEarlyFinishTimeFc) 最早計画終了時間(需要予測)を設定します。
void | setEarlyStartDate(String strEarlyStartDate) 最早計画開始: 実行 (日)を設定します。
void | setEarlyStartDateFc(String strEarlyStartDateFc) 最早計画開始日付(需要予測)を設定します。
void | setEarlyStartTime(String strEarlyStartTime) 最早計画開始: 作業実施(時間)を設定します。
void | setEarlyStartTimeFc(String strEarlyStartTimeFc) 最早計画開始時間(需要予測)を設定します。
void | setFactoryCalendar(String strFactoryCalendar) 稼働日カレンダを設定します。
void | setFlexibleDuration(String strFlexibleDuration) 区分: 可変期間を設定します。
void | setFloatFree(String strFloatFree) 自由余裕を設定します。
void | setFloatFreeFc(String strFloatFreeFc) 自由余裕 (予測)を設定します。
void | setFloatTotal(String strFloatTotal) 余裕合計を設定します。
void | setFloatTotalFc(String strFloatTotalFc) 余裕合計 (予測)を設定します。
void | setForecastFinishDate(String strForecastFinishDate) 予測終了日を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setInfoRec(String strInfoRec) 購買情報番号を設定します。
void | setLatestFinishDate(String strLatestFinishDate) 計画最遅終了: 作業(日付)を設定します。
void | setLatestFinishDateFc(String strLatestFinishDateFc) 最遅計画済終了日付(需要予測)を設定します。
void | setLatestFinishTime(String strLatestFinishTime) 計画最遅終了: 作業(時間)を設定します。
void | setLatestFinishTimeFc(String strLatestFinishTimeFc) 最遅計画終了時間 (予測)を設定します。
void | setLatestStartDate(String strLatestStartDate) 計画最遅開始: 作業(日付)を設定します。
void | setLatestStartDateFc(String strLatestStartDateFc) 最遅計画済開始日付(需要予測)を設定します。
void | setLatestStartTime(String strLatestStartTime) 計画最遅開始: 作業(時間)を設定します。
void | setLatestStartTimeFc(String strLatestStartTimeFc) 最遅計画済開始時間(需要予測)を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setMilestone(String strMilestone) 用途を設定します。
void | setNetwork(String strNetwork) ネットワーク番号を設定します。
void | setNotMrpApplicable(String strNotMrpApplicable) 区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。
void | setNumberOfCapacities(String strNumberOfCapacities) 所要能力数を設定します。
void | setObjectclass(String strObjectclass) オブジェクトクラス (言語非依存)を設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setOperationMeasureUnit(String strOperationMeasureUnit) 活動単位を設定します。
void | setOperationMeasureUnitIso(String strOperationMeasureUnitIso) 単位の ISO コードを設定します。
void | setPercentOfWork(String strPercentOfWork) 作業の比率 (%)を設定します。
void | setPlannedCost(String strPlannedCost) 計画原価を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPlndDelry(String strPlndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPrice(String strPrice) 価格を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setPriority(String strPriority) 優先度を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjectSummarization(String strProjectSummarization) 区分: プロジェクト集計用に活動を考慮を設定します。
void | setPurchOrg(String strPurchOrg) 購買組織を設定します。
void | setPurGroup(String strPurGroup) 購買グループを設定します。
void | setReferencePoint(String strReferencePoint) BOM 転送の参照ポイントを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnWork(String strUnWork) 作業単位を設定します。
void | setUnWorkIso(String strUnWorkIso) 単位の ISO コードを設定します。
void | setUserFieldChar10_1(String strUserFieldChar101) ユーザ定義項目 (10 文字)を設定します。
void | setUserFieldChar10_2(String strUserFieldChar102) ユーザ定義項目 (10 文字)を設定します。
void | setUserFieldChar20_1(String strUserFieldChar201) 20 文字のユーザ項目を設定します。
void | setUserFieldChar20_2(String strUserFieldChar202) 20 文字のユーザ項目を設定します。
void | setUserFieldCuky1(String strUserFieldCuky1) ユーザ項目: 値項目の単位を設定します。
void | setUserFieldCuky1Iso(String strUserFieldCuky1Iso) ISO 通貨コードを設定します。
void | setUserFieldCuky2(String strUserFieldCuky2) ユーザ項目: 値項目の単位を設定します。
void | setUserFieldCuky2Iso(String strUserFieldCuky2Iso) ISO 通貨コードを設定します。
void | setUserFieldCurr1(String strUserFieldCurr1) 値のユーザ定義項目 (長さ 10,3)を設定します。
void | setUserFieldCurr2(String strUserFieldCurr2) 値のユーザ定義項目 (長さ 10,3)を設定します。
void | setUserFieldDate1(String strUserFieldDate1) 日付のユーザ項目を設定します。
void | setUserFieldDate2(String strUserFieldDate2) 日付のユーザ項目を設定します。
void | setUserFieldFlag1(String strUserFieldFlag1) ユーザ定義項目: レポート区分を設定します。
void | setUserFieldFlag2(String strUserFieldFlag2) ユーザ定義項目: レポート区分を設定します。
void | setUserFieldKey(String strUserFieldKey) ユーザ定義項目のキーワード IDを設定します。
void | setUserFieldQuan1(String strUserFieldQuan1) 数量のユーザ項目 (長さ 10,3)を設定します。
void | setUserFieldQuan2(String strUserFieldQuan2) 数量のユーザ項目 (長さ 10,3)を設定します。
void | setUserFieldUnit1(String strUserFieldUnit1) ユーザ項目: 数量項目の単位を設定します。
void | setUserFieldUnit1Iso(String strUserFieldUnit1Iso) 単位の ISO コードを設定します。
void | setUserFieldUnit2(String strUserFieldUnit2) ユーザ項目: 数量項目の単位を設定します。
void | setUserFieldUnit2Iso(String strUserFieldUnit2Iso) 単位の ISO コードを設定します。
void | setVendorNo(String strVendorNo) 仕入先または債権者の勘定コードを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
void | setWorkActivity(String strWorkActivity) 活動に含まれる作業を設定します。
void | setWorkActual(String strWorkActual) 実績作業を設定します。
void | setWorkCntr(String strWorkCntr) 作業区を設定します。
void | setWorkForecast(String strWorkForecast) 予測作業 (実績 + 残存)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpActivity

public ExpActivity()
活動に関する詳細情報を作成します。

メソッドの詳細

getNetwork

public String getNetwork()
ネットワーク番号を取得します。

戻り値:
srtNetwork ネットワーク番号

getActivity

public String getActivity()
ネットワーク/標準ネットワークの活動番号を取得します。

戻り値:
srtActivity ネットワーク/標準ネットワークの活動番号

getControlKey

public String getControlKey()
管理キーを取得します。

戻り値:
srtControlKey 管理キー

getWorkCntr

public String getWorkCntr()
作業区を取得します。

戻り値:
srtWorkCntr 作業区

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getDescription

public String getDescription()
作業テキスト (短)を取得します。

戻り値:
srtDescription 作業テキスト (短)

getVendorNo

public String getVendorNo()
仕入先または債権者の勘定コードを取得します。

戻り値:
srtVendorNo 仕入先または債権者の勘定コード

getPrice

public String getPrice()
価格を取得します。

戻り値:
srtPrice 価格

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
srtPriceUnit 価格単位

getCostElem

public String getCostElem()
原価要素を取得します。

戻り値:
srtCostElem 原価要素

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtCurrencyIso ISO 通貨コード

getInfoRec

public String getInfoRec()
購買情報番号を取得します。

戻り値:
srtInfoRec 購買情報番号

getPurchOrg

public String getPurchOrg()
購買組織を取得します。

戻り値:
srtPurchOrg 購買組織

getPurGroup

public String getPurGroup()
購買グループを取得します。

戻り値:
srtPurGroup 購買グループ

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getFlexibleDuration

public String getFlexibleDuration()
区分: 可変期間を取得します。

戻り値:
srtFlexibleDuration 区分: 可変期間

getNumberOfCapacities

public String getNumberOfCapacities()
所要能力数を取得します。

戻り値:
srtNumberOfCapacities 所要能力数

getPercentOfWork

public String getPercentOfWork()
作業の比率 (%)を取得します。

戻り値:
srtPercentOfWork 作業の比率 (%)

getMilestone

public String getMilestone()
用途を取得します。

戻り値:
srtMilestone 用途

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
srtActtype 活動タイプ

getActivityCosts

public String getActivityCosts()
活動の原価を取得します。

戻り値:
srtActivityCosts 活動の原価

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getFactoryCalendar

public String getFactoryCalendar()
稼働日カレンダを取得します。

戻り値:
srtFactoryCalendar 稼働日カレンダ

getDistributingKey

public String getDistributingKey()
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。

戻り値:
srtDistributingKey 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

getPriority

public String getPriority()
優先度を取得します。

戻り値:
srtPriority 優先度

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getObjectclass

public String getObjectclass()
オブジェクトクラス (言語非依存)を取得します。

戻り値:
srtObjectclass オブジェクトクラス (言語非依存)

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getNotMrpApplicable

public String getNotMrpApplicable()
区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。

戻り値:
srtNotMrpApplicable 区分: MRP への入出庫予定の適用不可と購買依頼未登録

getProjectSummarization

public String getProjectSummarization()
区分: プロジェクト集計用に活動を考慮を取得します。

戻り値:
srtProjectSummarization 区分: プロジェクト集計用に活動を考慮

getOperationMeasureUnit

public String getOperationMeasureUnit()
活動単位を取得します。

戻り値:
srtOperationMeasureUnit 活動単位

getOperationMeasureUnitIso

public String getOperationMeasureUnitIso()
単位の ISO コードを取得します。

戻り値:
srtOperationMeasureUnitIso 単位の ISO コード

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
srtPlndDelry 予定納入時間 (単位: 日)

getDurationNormal

public String getDurationNormal()
標準活動期間を取得します。

戻り値:
srtDurationNormal 標準活動期間

getDurationNormalUnit

public String getDurationNormalUnit()
標準期間/単位を取得します。

戻り値:
srtDurationNormalUnit 標準期間/単位

getDurationNormalUnitIso

public String getDurationNormalUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationNormalUnitIso 単位の ISO コード

getDurationMinimum

public String getDurationMinimum()
最短活動期間を取得します。

戻り値:
srtDurationMinimum 最短活動期間

getDurationMinimumUnit

public String getDurationMinimumUnit()
最短期間の単位を取得します。

戻り値:
srtDurationMinimumUnit 最短期間の単位

getDurationMinimumUnitIso

public String getDurationMinimumUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationMinimumUnitIso 単位の ISO コード

getConstraintTypeStart

public String getConstraintTypeStart()
活動の基準開始日に対する制約を取得します。

戻り値:
srtConstraintTypeStart 活動の基準開始日に対する制約

getConstraintTypeFinish

public String getConstraintTypeFinish()
活動の終了日に対する制約を取得します。

戻り値:
srtConstraintTypeFinish 活動の終了日に対する制約

getWorkActivity

public String getWorkActivity()
活動に含まれる作業を取得します。

戻り値:
srtWorkActivity 活動に含まれる作業

getUnWork

public String getUnWork()
作業単位を取得します。

戻り値:
srtUnWork 作業単位

getUnWorkIso

public String getUnWorkIso()
単位の ISO コードを取得します。

戻り値:
srtUnWorkIso 単位の ISO コード

getEarlyStartDate

public String getEarlyStartDate()
最早計画開始: 実行 (日)を取得します。

戻り値:
srtEarlyStartDate 最早計画開始: 実行 (日)

getEarlyStartTime

public String getEarlyStartTime()
最早計画開始: 作業実施(時間)を取得します。

戻り値:
srtEarlyStartTime 最早計画開始: 作業実施(時間)

getEarlyFinishDate

public String getEarlyFinishDate()
最早計画終了: 実行 (日)を取得します。

戻り値:
srtEarlyFinishDate 最早計画終了: 実行 (日)

getEarlyFinishTime

public String getEarlyFinishTime()
最早計画終了: 実行 (時刻)を取得します。

戻り値:
srtEarlyFinishTime 最早計画終了: 実行 (時刻)

getLatestStartDate

public String getLatestStartDate()
計画最遅開始: 作業(日付)を取得します。

戻り値:
srtLatestStartDate 計画最遅開始: 作業(日付)

getLatestStartTime

public String getLatestStartTime()
計画最遅開始: 作業(時間)を取得します。

戻り値:
srtLatestStartTime 計画最遅開始: 作業(時間)

getLatestFinishDate

public String getLatestFinishDate()
計画最遅終了: 作業(日付)を取得します。

戻り値:
srtLatestFinishDate 計画最遅終了: 作業(日付)

getLatestFinishTime

public String getLatestFinishTime()
計画最遅終了: 作業(時間)を取得します。

戻り値:
srtLatestFinishTime 計画最遅終了: 作業(時間)

getFloatFree

public String getFloatFree()
自由余裕を取得します。

戻り値:
srtFloatFree 自由余裕

getFloatTotal

public String getFloatTotal()
余裕合計を取得します。

戻り値:
srtFloatTotal 余裕合計

getConstraintStartDate

public String getConstraintStartDate()
活動の基準開始日に対する制約を取得します。

戻り値:
srtConstraintStartDate 活動の基準開始日に対する制約

getConstraintStartTime

public String getConstraintStartTime()
活動の基準開始時間の制約を取得します。

戻り値:
srtConstraintStartTime 活動の基準開始時間の制約

getConstraintFinishDate

public String getConstraintFinishDate()
活動の基準終了日に対する制約を取得します。

戻り値:
srtConstraintFinishDate 活動の基準終了日に対する制約

getConstraintFinishTime

public String getConstraintFinishTime()
活動の基準終了時間を取得します。

戻り値:
srtConstraintFinishTime 活動の基準終了時間

getUserFieldKey

public String getUserFieldKey()
ユーザ定義項目のキーワード IDを取得します。

戻り値:
srtUserFieldKey ユーザ定義項目のキーワード ID

getUserFieldChar20_1

public String getUserFieldChar20_1()
20 文字のユーザ項目を取得します。

戻り値:
srtUserFieldChar201 20 文字のユーザ項目

getUserFieldChar20_2

public String getUserFieldChar20_2()
20 文字のユーザ項目を取得します。

戻り値:
srtUserFieldChar202 20 文字のユーザ項目

getUserFieldChar10_1

public String getUserFieldChar10_1()
ユーザ定義項目 (10 文字)を取得します。

戻り値:
srtUserFieldChar101 ユーザ定義項目 (10 文字)

getUserFieldChar10_2

public String getUserFieldChar10_2()
ユーザ定義項目 (10 文字)を取得します。

戻り値:
srtUserFieldChar102 ユーザ定義項目 (10 文字)

getUserFieldQuan1

public String getUserFieldQuan1()
数量のユーザ項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldQuan1 数量のユーザ項目 (長さ 10,3)

getUserFieldUnit1

public String getUserFieldUnit1()
ユーザ項目: 数量項目の単位を取得します。

戻り値:
srtUserFieldUnit1 ユーザ項目: 数量項目の単位

getUserFieldUnit1Iso

public String getUserFieldUnit1Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit1Iso 単位の ISO コード

getUserFieldQuan2

public String getUserFieldQuan2()
数量のユーザ項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldQuan2 数量のユーザ項目 (長さ 10,3)

getUserFieldUnit2

public String getUserFieldUnit2()
ユーザ項目: 数量項目の単位を取得します。

戻り値:
srtUserFieldUnit2 ユーザ項目: 数量項目の単位

getUserFieldUnit2Iso

public String getUserFieldUnit2Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit2Iso 単位の ISO コード

getUserFieldCurr1

public String getUserFieldCurr1()
値のユーザ定義項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldCurr1 値のユーザ定義項目 (長さ 10,3)

getUserFieldCuky1

public String getUserFieldCuky1()
ユーザ項目: 値項目の単位を取得します。

戻り値:
srtUserFieldCuky1 ユーザ項目: 値項目の単位

getUserFieldCuky1Iso

public String getUserFieldCuky1Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky1Iso ISO 通貨コード

getUserFieldCurr2

public String getUserFieldCurr2()
値のユーザ定義項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldCurr2 値のユーザ定義項目 (長さ 10,3)

getUserFieldCuky2

public String getUserFieldCuky2()
ユーザ項目: 値項目の単位を取得します。

戻り値:
srtUserFieldCuky2 ユーザ項目: 値項目の単位

getUserFieldCuky2Iso

public String getUserFieldCuky2Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky2Iso ISO 通貨コード

getUserFieldDate1

public String getUserFieldDate1()
日付のユーザ項目を取得します。

戻り値:
srtUserFieldDate1 日付のユーザ項目

getUserFieldDate2

public String getUserFieldDate2()
日付のユーザ項目を取得します。

戻り値:
srtUserFieldDate2 日付のユーザ項目

getUserFieldFlag1

public String getUserFieldFlag1()
ユーザ定義項目: レポート区分を取得します。

戻り値:
srtUserFieldFlag1 ユーザ定義項目: レポート区分

getUserFieldFlag2

public String getUserFieldFlag2()
ユーザ定義項目: レポート区分を取得します。

戻り値:
srtUserFieldFlag2 ユーザ定義項目: レポート区分

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getDurationNormalFc

public String getDurationNormalFc()
標準活動期間 (予測)を取得します。

戻り値:
srtDurationNormalFc 標準活動期間 (予測)

getDurationNormalFcUnit

public String getDurationNormalFcUnit()
標準予測期間の単位を取得します。

戻り値:
srtDurationNormalFcUnit 標準予測期間の単位

getDurationNormalFcUnitIso

public String getDurationNormalFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationNormalFcUnitIso 単位の ISO コード

getDurationMinimumFc

public String getDurationMinimumFc()
活動の最小期間(需要予測より)を取得します。

戻り値:
srtDurationMinimumFc 活動の最小期間(需要予測より)

getDurationMinimumFcUnit

public String getDurationMinimumFcUnit()
予測最短期間の単位を取得します。

戻り値:
srtDurationMinimumFcUnit 予測最短期間の単位

getDurationMinimumFcUnitIso

public String getDurationMinimumFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationMinimumFcUnitIso 単位の ISO コード

getConstraintTypeFinishFc

public String getConstraintTypeFinishFc()
活動終了の制約条件付き需要予測日付を取得します。

戻り値:
srtConstraintTypeFinishFc 活動終了の制約条件付き需要予測日付

getConstraintTypeStartFc

public String getConstraintTypeStartFc()
活動開始の制約条件付き需要予測日付を取得します。

戻り値:
srtConstraintTypeStartFc 活動開始の制約条件付き需要予測日付

getConstraintStartDateFc

public String getConstraintStartDateFc()
活動の予測開始日を取得します。

戻り値:
srtConstraintStartDateFc 活動の予測開始日

getConstraintStartTimeFc

public String getConstraintStartTimeFc()
活動の需要予測開始時間を取得します。

戻り値:
srtConstraintStartTimeFc 活動の需要予測開始時間

getConstraintFinishDateFc

public String getConstraintFinishDateFc()
予測終了日付を取得します。

戻り値:
srtConstraintFinishDateFc 予測終了日付

getConstraintFinishTimeFc

public String getConstraintFinishTimeFc()
活動の予測終了時間を取得します。

戻り値:
srtConstraintFinishTimeFc 活動の予測終了時間

getEarlyStartDateFc

public String getEarlyStartDateFc()
最早計画開始日付(需要予測)を取得します。

戻り値:
srtEarlyStartDateFc 最早計画開始日付(需要予測)

getEarlyStartTimeFc

public String getEarlyStartTimeFc()
最早計画開始時間(需要予測)を取得します。

戻り値:
srtEarlyStartTimeFc 最早計画開始時間(需要予測)

getEarlyFinishDateFc

public String getEarlyFinishDateFc()
最早計画終了日 (予測)を取得します。

戻り値:
srtEarlyFinishDateFc 最早計画終了日 (予測)

getEarlyFinishTimeFc

public String getEarlyFinishTimeFc()
最早計画終了時間(需要予測)を取得します。

戻り値:
srtEarlyFinishTimeFc 最早計画終了時間(需要予測)

getLatestStartDateFc

public String getLatestStartDateFc()
最遅計画済開始日付(需要予測)を取得します。

戻り値:
srtLatestStartDateFc 最遅計画済開始日付(需要予測)

getLatestStartTimeFc

public String getLatestStartTimeFc()
最遅計画済開始時間(需要予測)を取得します。

戻り値:
srtLatestStartTimeFc 最遅計画済開始時間(需要予測)

getLatestFinishDateFc

public String getLatestFinishDateFc()
最遅計画済終了日付(需要予測)を取得します。

戻り値:
srtLatestFinishDateFc 最遅計画済終了日付(需要予測)

getLatestFinishTimeFc

public String getLatestFinishTimeFc()
最遅計画終了時間 (予測)を取得します。

戻り値:
srtLatestFinishTimeFc 最遅計画終了時間 (予測)

getFloatFreeFc

public String getFloatFreeFc()
自由余裕 (予測)を取得します。

戻り値:
srtFloatFreeFc 自由余裕 (予測)

getFloatTotalFc

public String getFloatTotalFc()
余裕合計 (予測)を取得します。

戻り値:
srtFloatTotalFc 余裕合計 (予測)

getWorkForecast

public String getWorkForecast()
予測作業 (実績 + 残存)を取得します。

戻り値:
srtWorkForecast 予測作業 (実績 + 残存)

getWorkActual

public String getWorkActual()
実績作業を取得します。

戻り値:
srtWorkActual 実績作業

getDurationScheduled

public String getDurationScheduled()
処理時間を取得します。

戻り値:
srtDurationScheduled 処理時間

getDurationScheduledFc

public String getDurationScheduledFc()
処理時間の長さ (予測値)を取得します。

戻り値:
srtDurationScheduledFc 処理時間の長さ (予測値)

getDurationScheduledUnit

public String getDurationScheduledUnit()
処理時間単位を取得します。

戻り値:
srtDurationScheduledUnit 処理時間単位

getDurationScheduledUnitIso

public String getDurationScheduledUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationScheduledUnitIso 単位の ISO コード

getDurationConfirmFc

public String getDurationConfirmFc()
確認の予測活動期間を取得します。

戻り値:
srtDurationConfirmFc 確認の予測活動期間

getDurationConfirmFcUnit

public String getDurationConfirmFcUnit()
確認の予測期間単位を取得します。

戻り値:
srtDurationConfirmFcUnit 確認の予測期間単位

getDurationConfirmFcUnitIso

public String getDurationConfirmFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationConfirmFcUnitIso 単位の ISO コード

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getPlannedCost

public String getPlannedCost()
計画原価を取得します。

戻り値:
srtPlannedCost 計画原価

getActualCost

public String getActualCost()
実際原価を取得します。

戻り値:
srtActualCost 実際原価

getControllingAreaCurrency

public String getControllingAreaCurrency()
通貨コードを取得します。

戻り値:
srtControllingAreaCurrency 通貨コード

getActualStartDate

public String getActualStartDate()
実績開始日: 実行 (日付)を取得します。

戻り値:
srtActualStartDate 実績開始日: 実行 (日付)

getActualFinishDate

public String getActualFinishDate()
実績終了日: 実行 (日付)を取得します。

戻り値:
srtActualFinishDate 実績終了日: 実行 (日付)

getForecastFinishDate

public String getForecastFinishDate()
予測終了日を取得します。

戻り値:
srtForecastFinishDate 予測終了日

getComplete

public String getComplete()
最終確認の有効化を取得します。

戻り値:
srtComplete 最終確認の有効化

getReferencePoint

public String getReferencePoint()
BOM 転送の参照ポイントを取得します。

戻り値:
srtReferencePoint BOM 転送の参照ポイント

setNetwork

public void setNetwork(String strNetwork)
ネットワーク番号を設定します。

パラメータ:
strNetwork - ネットワーク番号

setActivity

public void setActivity(String strActivity)
ネットワーク/標準ネットワークの活動番号を設定します。

パラメータ:
strActivity - ネットワーク/標準ネットワークの活動番号

setControlKey

public void setControlKey(String strControlKey)
管理キーを設定します。

パラメータ:
strControlKey - 管理キー

setWorkCntr

public void setWorkCntr(String strWorkCntr)
作業区を設定します。

パラメータ:
strWorkCntr - 作業区

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setDescription

public void setDescription(String strDescription)
作業テキスト (短)を設定します。

パラメータ:
strDescription - 作業テキスト (短)

setVendorNo

public void setVendorNo(String strVendorNo)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendorNo - 仕入先または債権者の勘定コード

setPrice

public void setPrice(String strPrice)
価格を設定します。

パラメータ:
strPrice - 価格

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setCostElem

public void setCostElem(String strCostElem)
原価要素を設定します。

パラメータ:
strCostElem - 原価要素

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setInfoRec

public void setInfoRec(String strInfoRec)
購買情報番号を設定します。

パラメータ:
strInfoRec - 購買情報番号

setPurchOrg

public void setPurchOrg(String strPurchOrg)
購買組織を設定します。

パラメータ:
strPurchOrg - 購買組織

setPurGroup

public void setPurGroup(String strPurGroup)
購買グループを設定します。

パラメータ:
strPurGroup - 購買グループ

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setFlexibleDuration

public void setFlexibleDuration(String strFlexibleDuration)
区分: 可変期間を設定します。

パラメータ:
strFlexibleDuration - 区分: 可変期間

setNumberOfCapacities

public void setNumberOfCapacities(String strNumberOfCapacities)
所要能力数を設定します。

パラメータ:
strNumberOfCapacities - 所要能力数

setPercentOfWork

public void setPercentOfWork(String strPercentOfWork)
作業の比率 (%)を設定します。

パラメータ:
strPercentOfWork - 作業の比率 (%)

setMilestone

public void setMilestone(String strMilestone)
用途を設定します。

パラメータ:
strMilestone - 用途

setActtype

public void setActtype(String strActtype)
活動タイプを設定します。

パラメータ:
strActtype - 活動タイプ

setActivityCosts

public void setActivityCosts(String strActivityCosts)
活動の原価を設定します。

パラメータ:
strActivityCosts - 活動の原価

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setFactoryCalendar

public void setFactoryCalendar(String strFactoryCalendar)
稼働日カレンダを設定します。

パラメータ:
strFactoryCalendar - 稼働日カレンダ

setDistributingKey

public void setDistributingKey(String strDistributingKey)
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。

パラメータ:
strDistributingKey - 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

setPriority

public void setPriority(String strPriority)
優先度を設定します。

パラメータ:
strPriority - 優先度

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setObjectclass

public void setObjectclass(String strObjectclass)
オブジェクトクラス (言語非依存)を設定します。

パラメータ:
strObjectclass - オブジェクトクラス (言語非依存)

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setNotMrpApplicable

public void setNotMrpApplicable(String strNotMrpApplicable)
区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。

パラメータ:
strNotMrpApplicable - 区分: MRP への入出庫予定の適用不可と購買依頼未登録

setProjectSummarization

public void setProjectSummarization(String strProjectSummarization)
区分: プロジェクト集計用に活動を考慮を設定します。

パラメータ:
strProjectSummarization - 区分: プロジェクト集計用に活動を考慮

setOperationMeasureUnit

public void setOperationMeasureUnit(String strOperationMeasureUnit)
活動単位を設定します。

パラメータ:
strOperationMeasureUnit - 活動単位

setOperationMeasureUnitIso

public void setOperationMeasureUnitIso(String strOperationMeasureUnitIso)
単位の ISO コードを設定します。

パラメータ:
strOperationMeasureUnitIso - 単位の ISO コード

setPlndDelry

public void setPlndDelry(String strPlndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
strPlndDelry - 予定納入時間 (単位: 日)

setDurationNormal

public void setDurationNormal(String strDurationNormal)
標準活動期間を設定します。

パラメータ:
strDurationNormal - 標準活動期間

setDurationNormalUnit

public void setDurationNormalUnit(String strDurationNormalUnit)
標準期間/単位を設定します。

パラメータ:
strDurationNormalUnit - 標準期間/単位

setDurationNormalUnitIso

public void setDurationNormalUnitIso(String strDurationNormalUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationNormalUnitIso - 単位の ISO コード

setDurationMinimum

public void setDurationMinimum(String strDurationMinimum)
最短活動期間を設定します。

パラメータ:
strDurationMinimum - 最短活動期間

setDurationMinimumUnit

public void setDurationMinimumUnit(String strDurationMinimumUnit)
最短期間の単位を設定します。

パラメータ:
strDurationMinimumUnit - 最短期間の単位

setDurationMinimumUnitIso

public void setDurationMinimumUnitIso(String strDurationMinimumUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationMinimumUnitIso - 単位の ISO コード

setConstraintTypeStart

public void setConstraintTypeStart(String strConstraintTypeStart)
活動の基準開始日に対する制約を設定します。

パラメータ:
strConstraintTypeStart - 活動の基準開始日に対する制約

setConstraintTypeFinish

public void setConstraintTypeFinish(String strConstraintTypeFinish)
活動の終了日に対する制約を設定します。

パラメータ:
strConstraintTypeFinish - 活動の終了日に対する制約

setWorkActivity

public void setWorkActivity(String strWorkActivity)
活動に含まれる作業を設定します。

パラメータ:
strWorkActivity - 活動に含まれる作業

setUnWork

public void setUnWork(String strUnWork)
作業単位を設定します。

パラメータ:
strUnWork - 作業単位

setUnWorkIso

public void setUnWorkIso(String strUnWorkIso)
単位の ISO コードを設定します。

パラメータ:
strUnWorkIso - 単位の ISO コード

setEarlyStartDate

public void setEarlyStartDate(String strEarlyStartDate)
最早計画開始: 実行 (日)を設定します。

パラメータ:
strEarlyStartDate - 最早計画開始: 実行 (日)

setEarlyStartTime

public void setEarlyStartTime(String strEarlyStartTime)
最早計画開始: 作業実施(時間)を設定します。

パラメータ:
strEarlyStartTime - 最早計画開始: 作業実施(時間)

setEarlyFinishDate

public void setEarlyFinishDate(String strEarlyFinishDate)
最早計画終了: 実行 (日)を設定します。

パラメータ:
strEarlyFinishDate - 最早計画終了: 実行 (日)

setEarlyFinishTime

public void setEarlyFinishTime(String strEarlyFinishTime)
最早計画終了: 実行 (時刻)を設定します。

パラメータ:
strEarlyFinishTime - 最早計画終了: 実行 (時刻)

setLatestStartDate

public void setLatestStartDate(String strLatestStartDate)
計画最遅開始: 作業(日付)を設定します。

パラメータ:
strLatestStartDate - 計画最遅開始: 作業(日付)

setLatestStartTime

public void setLatestStartTime(String strLatestStartTime)
計画最遅開始: 作業(時間)を設定します。

パラメータ:
strLatestStartTime - 計画最遅開始: 作業(時間)

setLatestFinishDate

public void setLatestFinishDate(String strLatestFinishDate)
計画最遅終了: 作業(日付)を設定します。

パラメータ:
strLatestFinishDate - 計画最遅終了: 作業(日付)

setLatestFinishTime

public void setLatestFinishTime(String strLatestFinishTime)
計画最遅終了: 作業(時間)を設定します。

パラメータ:
strLatestFinishTime - 計画最遅終了: 作業(時間)

setFloatFree

public void setFloatFree(String strFloatFree)
自由余裕を設定します。

パラメータ:
strFloatFree - 自由余裕

setFloatTotal

public void setFloatTotal(String strFloatTotal)
余裕合計を設定します。

パラメータ:
strFloatTotal - 余裕合計

setConstraintStartDate

public void setConstraintStartDate(String strConstraintStartDate)
活動の基準開始日に対する制約を設定します。

パラメータ:
strConstraintStartDate - 活動の基準開始日に対する制約

setConstraintStartTime

public void setConstraintStartTime(String strConstraintStartTime)
活動の基準開始時間の制約を設定します。

パラメータ:
strConstraintStartTime - 活動の基準開始時間の制約

setConstraintFinishDate

public void setConstraintFinishDate(String strConstraintFinishDate)
活動の基準終了日に対する制約を設定します。

パラメータ:
strConstraintFinishDate - 活動の基準終了日に対する制約

setConstraintFinishTime

public void setConstraintFinishTime(String strConstraintFinishTime)
活動の基準終了時間を設定します。

パラメータ:
strConstraintFinishTime - 活動の基準終了時間

setUserFieldKey

public void setUserFieldKey(String strUserFieldKey)
ユーザ定義項目のキーワード IDを設定します。

パラメータ:
strUserFieldKey - ユーザ定義項目のキーワード ID

setUserFieldChar20_1

public void setUserFieldChar20_1(String strUserFieldChar201)
20 文字のユーザ項目を設定します。

パラメータ:
strUserFieldChar201 - 20 文字のユーザ項目

setUserFieldChar20_2

public void setUserFieldChar20_2(String strUserFieldChar202)
20 文字のユーザ項目を設定します。

パラメータ:
strUserFieldChar202 - 20 文字のユーザ項目

setUserFieldChar10_1

public void setUserFieldChar10_1(String strUserFieldChar101)
ユーザ定義項目 (10 文字)を設定します。

パラメータ:
strUserFieldChar101 - ユーザ定義項目 (10 文字)

setUserFieldChar10_2

public void setUserFieldChar10_2(String strUserFieldChar102)
ユーザ定義項目 (10 文字)を設定します。

パラメータ:
strUserFieldChar102 - ユーザ定義項目 (10 文字)

setUserFieldQuan1

public void setUserFieldQuan1(String strUserFieldQuan1)
数量のユーザ項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldQuan1 - 数量のユーザ項目 (長さ 10,3)

setUserFieldUnit1

public void setUserFieldUnit1(String strUserFieldUnit1)
ユーザ項目: 数量項目の単位を設定します。

パラメータ:
strUserFieldUnit1 - ユーザ項目: 数量項目の単位

setUserFieldUnit1Iso

public void setUserFieldUnit1Iso(String strUserFieldUnit1Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit1Iso - 単位の ISO コード

setUserFieldQuan2

public void setUserFieldQuan2(String strUserFieldQuan2)
数量のユーザ項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldQuan2 - 数量のユーザ項目 (長さ 10,3)

setUserFieldUnit2

public void setUserFieldUnit2(String strUserFieldUnit2)
ユーザ項目: 数量項目の単位を設定します。

パラメータ:
strUserFieldUnit2 - ユーザ項目: 数量項目の単位

setUserFieldUnit2Iso

public void setUserFieldUnit2Iso(String strUserFieldUnit2Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit2Iso - 単位の ISO コード

setUserFieldCurr1

public void setUserFieldCurr1(String strUserFieldCurr1)
値のユーザ定義項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldCurr1 - 値のユーザ定義項目 (長さ 10,3)

setUserFieldCuky1

public void setUserFieldCuky1(String strUserFieldCuky1)
ユーザ項目: 値項目の単位を設定します。

パラメータ:
strUserFieldCuky1 - ユーザ項目: 値項目の単位

setUserFieldCuky1Iso

public void setUserFieldCuky1Iso(String strUserFieldCuky1Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky1Iso - ISO 通貨コード

setUserFieldCurr2

public void setUserFieldCurr2(String strUserFieldCurr2)
値のユーザ定義項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldCurr2 - 値のユーザ定義項目 (長さ 10,3)

setUserFieldCuky2

public void setUserFieldCuky2(String strUserFieldCuky2)
ユーザ項目: 値項目の単位を設定します。

パラメータ:
strUserFieldCuky2 - ユーザ項目: 値項目の単位

setUserFieldCuky2Iso

public void setUserFieldCuky2Iso(String strUserFieldCuky2Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky2Iso - ISO 通貨コード

setUserFieldDate1

public void setUserFieldDate1(String strUserFieldDate1)
日付のユーザ項目を設定します。

パラメータ:
strUserFieldDate1 - 日付のユーザ項目

setUserFieldDate2

public void setUserFieldDate2(String strUserFieldDate2)
日付のユーザ項目を設定します。

パラメータ:
strUserFieldDate2 - 日付のユーザ項目

setUserFieldFlag1

public void setUserFieldFlag1(String strUserFieldFlag1)
ユーザ定義項目: レポート区分を設定します。

パラメータ:
strUserFieldFlag1 - ユーザ定義項目: レポート区分

setUserFieldFlag2

public void setUserFieldFlag2(String strUserFieldFlag2)
ユーザ定義項目: レポート区分を設定します。

パラメータ:
strUserFieldFlag2 - ユーザ定義項目: レポート区分

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setDurationNormalFc

public void setDurationNormalFc(String strDurationNormalFc)
標準活動期間 (予測)を設定します。

パラメータ:
strDurationNormalFc - 標準活動期間 (予測)

setDurationNormalFcUnit

public void setDurationNormalFcUnit(String strDurationNormalFcUnit)
標準予測期間の単位を設定します。

パラメータ:
strDurationNormalFcUnit - 標準予測期間の単位

setDurationNormalFcUnitIso

public void setDurationNormalFcUnitIso(String strDurationNormalFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationNormalFcUnitIso - 単位の ISO コード

setDurationMinimumFc

public void setDurationMinimumFc(String strDurationMinimumFc)
活動の最小期間(需要予測より)を設定します。

パラメータ:
strDurationMinimumFc - 活動の最小期間(需要予測より)

setDurationMinimumFcUnit

public void setDurationMinimumFcUnit(String strDurationMinimumFcUnit)
予測最短期間の単位を設定します。

パラメータ:
strDurationMinimumFcUnit - 予測最短期間の単位

setDurationMinimumFcUnitIso

public void setDurationMinimumFcUnitIso(String strDurationMinimumFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationMinimumFcUnitIso - 単位の ISO コード

setConstraintTypeFinishFc

public void setConstraintTypeFinishFc(String strConstraintTypeFinishFc)
活動終了の制約条件付き需要予測日付を設定します。

パラメータ:
strConstraintTypeFinishFc - 活動終了の制約条件付き需要予測日付

setConstraintTypeStartFc

public void setConstraintTypeStartFc(String strConstraintTypeStartFc)
活動開始の制約条件付き需要予測日付を設定します。

パラメータ:
strConstraintTypeStartFc - 活動開始の制約条件付き需要予測日付

setConstraintStartDateFc

public void setConstraintStartDateFc(String strConstraintStartDateFc)
活動の予測開始日を設定します。

パラメータ:
strConstraintStartDateFc - 活動の予測開始日

setConstraintStartTimeFc

public void setConstraintStartTimeFc(String strConstraintStartTimeFc)
活動の需要予測開始時間を設定します。

パラメータ:
strConstraintStartTimeFc - 活動の需要予測開始時間

setConstraintFinishDateFc

public void setConstraintFinishDateFc(String strConstraintFinishDateFc)
予測終了日付を設定します。

パラメータ:
strConstraintFinishDateFc - 予測終了日付

setConstraintFinishTimeFc

public void setConstraintFinishTimeFc(String strConstraintFinishTimeFc)
活動の予測終了時間を設定します。

パラメータ:
strConstraintFinishTimeFc - 活動の予測終了時間

setEarlyStartDateFc

public void setEarlyStartDateFc(String strEarlyStartDateFc)
最早計画開始日付(需要予測)を設定します。

パラメータ:
strEarlyStartDateFc - 最早計画開始日付(需要予測)

setEarlyStartTimeFc

public void setEarlyStartTimeFc(String strEarlyStartTimeFc)
最早計画開始時間(需要予測)を設定します。

パラメータ:
strEarlyStartTimeFc - 最早計画開始時間(需要予測)

setEarlyFinishDateFc

public void setEarlyFinishDateFc(String strEarlyFinishDateFc)
最早計画終了日 (予測)を設定します。

パラメータ:
strEarlyFinishDateFc - 最早計画終了日 (予測)

setEarlyFinishTimeFc

public void setEarlyFinishTimeFc(String strEarlyFinishTimeFc)
最早計画終了時間(需要予測)を設定します。

パラメータ:
strEarlyFinishTimeFc - 最早計画終了時間(需要予測)

setLatestStartDateFc

public void setLatestStartDateFc(String strLatestStartDateFc)
最遅計画済開始日付(需要予測)を設定します。

パラメータ:
strLatestStartDateFc - 最遅計画済開始日付(需要予測)

setLatestStartTimeFc

public void setLatestStartTimeFc(String strLatestStartTimeFc)
最遅計画済開始時間(需要予測)を設定します。

パラメータ:
strLatestStartTimeFc - 最遅計画済開始時間(需要予測)

setLatestFinishDateFc

public void setLatestFinishDateFc(String strLatestFinishDateFc)
最遅計画済終了日付(需要予測)を設定します。

パラメータ:
strLatestFinishDateFc - 最遅計画済終了日付(需要予測)

setLatestFinishTimeFc

public void setLatestFinishTimeFc(String strLatestFinishTimeFc)
最遅計画終了時間 (予測)を設定します。

パラメータ:
strLatestFinishTimeFc - 最遅計画終了時間 (予測)

setFloatFreeFc

public void setFloatFreeFc(String strFloatFreeFc)
自由余裕 (予測)を設定します。

パラメータ:
strFloatFreeFc - 自由余裕 (予測)

setFloatTotalFc

public void setFloatTotalFc(String strFloatTotalFc)
余裕合計 (予測)を設定します。

パラメータ:
strFloatTotalFc - 余裕合計 (予測)

setWorkForecast

public void setWorkForecast(String strWorkForecast)
予測作業 (実績 + 残存)を設定します。

パラメータ:
strWorkForecast - 予測作業 (実績 + 残存)

setWorkActual

public void setWorkActual(String strWorkActual)
実績作業を設定します。

パラメータ:
strWorkActual - 実績作業

setDurationScheduled

public void setDurationScheduled(String strDurationScheduled)
処理時間を設定します。

パラメータ:
strDurationScheduled - 処理時間

setDurationScheduledFc

public void setDurationScheduledFc(String strDurationScheduledFc)
処理時間の長さ (予測値)を設定します。

パラメータ:
strDurationScheduledFc - 処理時間の長さ (予測値)

setDurationScheduledUnit

public void setDurationScheduledUnit(String strDurationScheduledUnit)
処理時間単位を設定します。

パラメータ:
strDurationScheduledUnit - 処理時間単位

setDurationScheduledUnitIso

public void setDurationScheduledUnitIso(String strDurationScheduledUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationScheduledUnitIso - 単位の ISO コード

setDurationConfirmFc

public void setDurationConfirmFc(String strDurationConfirmFc)
確認の予測活動期間を設定します。

パラメータ:
strDurationConfirmFc - 確認の予測活動期間

setDurationConfirmFcUnit

public void setDurationConfirmFcUnit(String strDurationConfirmFcUnit)
確認の予測期間単位を設定します。

パラメータ:
strDurationConfirmFcUnit - 確認の予測期間単位

setDurationConfirmFcUnitIso

public void setDurationConfirmFcUnitIso(String strDurationConfirmFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationConfirmFcUnitIso - 単位の ISO コード

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setPlannedCost

public void setPlannedCost(String strPlannedCost)
計画原価を設定します。

パラメータ:
strPlannedCost - 計画原価

setActualCost

public void setActualCost(String strActualCost)
実際原価を設定します。

パラメータ:
strActualCost - 実際原価

setControllingAreaCurrency

public void setControllingAreaCurrency(String strControllingAreaCurrency)
通貨コードを設定します。

パラメータ:
strControllingAreaCurrency - 通貨コード

setActualStartDate

public void setActualStartDate(String strActualStartDate)
実績開始日: 実行 (日付)を設定します。

パラメータ:
strActualStartDate - 実績開始日: 実行 (日付)

setActualFinishDate

public void setActualFinishDate(String strActualFinishDate)
実績終了日: 実行 (日付)を設定します。

パラメータ:
strActualFinishDate - 実績終了日: 実行 (日付)

setForecastFinishDate

public void setForecastFinishDate(String strForecastFinishDate)
予測終了日を設定します。

パラメータ:
strForecastFinishDate - 予測終了日

setComplete

public void setComplete(String strComplete)
最終確認の有効化を設定します。

パラメータ:
strComplete - 最終確認の有効化

setReferencePoint

public void setReferencePoint(String strReferencePoint)
BOM 転送の参照ポイントを設定します。

パラメータ:
strReferencePoint - BOM 転送の参照ポイント

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpMessage (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpMessage

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpMessage
すべての実装インタフェース:
Serializable
public class ExpMessage
extends Object
implements Serializable

詳細情報を読み込みエラー情報クラス 機能は以下の通り

  • 詳細情報を読み込みエラー情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpMessage()
詳細情報を読み込みエラー情報を作成します。
メソッドの概要
String | getExternalObjectId() SAP 外部対象キーを取得します。
String | getInternalObjectId() SAP 内部対象キーを取得します。
String | getMessageId() メッセージ IDを取得します。
String | getMessageNumber() システムメッセージ番号を取得します。
String | getMessageText() メッセージのテキスト行を取得します。
String | getMessageType() メッセージタイプを取得します。
String | getMethod() メソッドを取得します。
String | getObjectType() オブジェクトタイプを取得します。
void | setExternalObjectId(String strExternalObjectId) SAP 外部対象キーを設定します。
void | setInternalObjectId(String strInternalObjectId) SAP 内部対象キーを設定します。
void | setMessageId(String strMessageId) メッセージ IDを設定します。
void | setMessageNumber(String strMessageNumber) システムメッセージ番号を設定します。
void | setMessageText(String strMessageText) メッセージのテキスト行を設定します。
void | setMessageType(String strMessageType) メッセージタイプを設定します。
void | setMethod(String strMethod) メソッドを設定します。
void | setObjectType(String strObjectType) オブジェクトタイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpMessage

public ExpMessage()
詳細情報を読み込みエラー情報を作成します。

メソッドの詳細

getMethod

public String getMethod()
メソッドを取得します。

戻り値:
srtMethod メソッド

getObjectType

public String getObjectType()
オブジェクトタイプを取得します。

戻り値:
srtObjectType オブジェクトタイプ

getInternalObjectId

public String getInternalObjectId()
SAP 内部対象キーを取得します。

戻り値:
srtInternalObjectId SAP 内部対象キー

getExternalObjectId

public String getExternalObjectId()
SAP 外部対象キーを取得します。

戻り値:
srtExternalObjectId SAP 外部対象キー

getMessageId

public String getMessageId()
メッセージ IDを取得します。

戻り値:
srtMessageId メッセージ ID

getMessageNumber

public String getMessageNumber()
システムメッセージ番号を取得します。

戻り値:
srtMessageNumber システムメッセージ番号

getMessageType

public String getMessageType()
メッセージタイプを取得します。

戻り値:
srtMessageType メッセージタイプ

getMessageText

public String getMessageText()
メッセージのテキスト行を取得します。

戻り値:
srtMessageText メッセージのテキスト行

setMethod

public void setMethod(String strMethod)
メソッドを設定します。

パラメータ:
strMethod - メソッド

setObjectType

public void setObjectType(String strObjectType)
オブジェクトタイプを設定します。

パラメータ:
strObjectType - オブジェクトタイプ

setInternalObjectId

public void setInternalObjectId(String strInternalObjectId)
SAP 内部対象キーを設定します。

パラメータ:
strInternalObjectId - SAP 内部対象キー

setExternalObjectId

public void setExternalObjectId(String strExternalObjectId)
SAP 外部対象キーを設定します。

パラメータ:
strExternalObjectId - SAP 外部対象キー

setMessageId

public void setMessageId(String strMessageId)
メッセージ IDを設定します。

パラメータ:
strMessageId - メッセージ ID

setMessageNumber

public void setMessageNumber(String strMessageNumber)
システムメッセージ番号を設定します。

パラメータ:
strMessageNumber - システムメッセージ番号

setMessageType

public void setMessageType(String strMessageType)
メッセージタイプを設定します。

パラメータ:
strMessageType - メッセージタイプ

setMessageText

public void setMessageText(String strMessageText)
メッセージのテキスト行を設定します。

パラメータ:
strMessageText - メッセージのテキスト行

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsElement (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsElement

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement
すべての実装インタフェース:
Serializable
public class ExpWbsElement
extends Object
implements Serializable

WBS 要素についての詳細情報クラス
機能は以下の通り

  • WBS 要素についての詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsElement()
WBS 要素についての詳細情報を作成します。
メソッドの概要
String | getApplicantNo() 申請者番号を取得します。
String | getBusArea() 事業領域を取得します。
String | getCalendar() 稼動日カレンダを取得します。
String | getChangeNo() 変更番号を取得します。
String | getCoArea() 管理領域を取得します。
String | getCompCode() 会社コードを取得します。
String | getCostingSheet() 原価計算表を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() PS: テキスト(短)(第一テキスト行)を取得します。
String | getEquipment() 設備番号を取得します。
String | getEquityType() 持分タイプを取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFunctionalLocation() 機能場所を取得します。
String | getIntProfile() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getInvestProfile() 設備投資案件プロファイルを取得します。
String | getJointVenture() ジョイントベンチャを取得します。
String | getJvJibClass() JIB/JIBE クラスを取得します。
String | getJvJibSubClassA() JIB/JIBE サブクラスAを取得します。
String | getJvObjectType() ジョイントベンチャ対象タイプを取得します。
String | getLocation() 場所を取得します。
String | getNetworkAssignment() ネットワーク割当を取得します。
String | getObjectclass() 対象クラスを取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getOverheadKey() 間接費キーを取得します。
String | getPlant() プラントを取得します。
String | getPriority() 優先度を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjType() プロジェクトタイプを取得します。
String | getRecoveryInd() リカバリフラグを取得します。
String | getRequestCctr() 申請原価センタを取得します。
String | getRequestCctrControllingArea() 依頼原価センタの管理領域を取得します。
String | getRequestCompCode() 会社コード要求を取得します。
String | getResAnalKey() 結果分析キーを取得します。
String | getResponsibleNo() 責任者番号 (プロジェクト責任者)を取得します。
String | getRespsblCctr() 責任原価センタを取得します。
String | getRespsblCctrControllingArea() 責任原価センタの管理領域を取得します。
String | getShortId() WBS 要素 ショート IDを取得します。
String | getStatistical() 統計 WBS 要素を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUserFieldChar10_1() 10 桁の第 3 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldChar10_2() 10 桁の第 4 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldChar20_1() 20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。
String | getUserFieldChar20_2() 20 桁の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldCuky1() 値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldCuky1Iso() ISO 通貨コードを取得します。
String | getUserFieldCuky2() 値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldCuky2Iso() ISO 通貨コードを取得します。
String | getUserFieldCurr1() 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldCurr2() 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldDate1() 日付の第 1 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldDate2() 日付の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldFlag1() '評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldFlag2() '評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldKey() ユーザ定義項目のキーワード IDを取得します。
String | getUserFieldQuan1() 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldQuan2() 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldUnit1() 数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldUnit1Iso() 単位の ISO コードを取得します。
String | getUserFieldUnit2() 数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldUnit2Iso() 単位の ISO コードを取得します。
String | getWbsAccountAssignmentElement() 区分: 勘定設定要素を取得します。
String | getWbsActualDuration() WBS 要素の実績長(期間)を取得します。
String | getWbsActualDurUnit() 実績 WBS 要素日付の期間単位を取得します。
String | getWbsActualDurUnitIso() 単位の ISO コードを取得します。
String | getWbsActualFinishDate() WBS 要素の実績終了日を取得します。
String | getWbsActualStartDate() WBS 要素の実績開始日付を取得します。
String | getWbsBasicDuration() WBS 要素の基準日の長さ(期間)を取得します。
String | getWbsBasicDurUnit() 基準 WBS 要素日付の期間単位を取得します。
String | getWbsBasicDurUnitIso() 単位の ISO コードを取得します。
String | getWbsBasicFinishDate() WBS 要素: 基本終了日付を取得します。
String | getWbsBasicStartDate() WBS 要素: 基本開始日を取得します。
String | getWbsBillingElement() 区分: 請求要素を取得します。
String | getWbsCctrPostedActual() 原価が実際に転記される原価センタを取得します。
String | getWbsElement() WBS 要素を取得します。
String | getWbsForcastDurUnit() WBS 要素計画日付の単位を取得します。
String | getWbsForecastDuration() WBS 要素の予測期間を取得します。
String | getWbsForecastDurUnitIso() 単位の ISO コードを取得します。
String | getWbsForecastFinishDate() WBS 要素の予測済終了日付を取得します。
String | getWbsForecastStartDate() WBS 要素の予測開始日を取得します。
String | getWbsPlanningElement() 区分: 計画要素を取得します。
String | getWbsScdActualFinishDate() WBS 要素の仮実績終了日を取得します。
String | getWbsScdActualStartDate() WBS 要素の仮実績開始日を取得します。
String | getWbsScdBasicFinishDate() 最遅計画終了日 (基準)を取得します。
String | getWbsScdBasicStartDate() 最早計画開始日 (基準)を取得します。
String | getWbsScdForecastFinishDate() 最遅計画終了日 (予測)を取得します。
String | getWbsScdForecastStartDate() 計画開始日 (予測)を取得します。
void | setApplicantNo(String strApplicantNo) 申請者番号を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCalendar(String strCalendar) 稼動日カレンダを設定します。
void | setChangeNo(String strChangeNo) 変更番号を設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCostingSheet(String strCostingSheet) 原価計算表を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) PS: テキスト(短)(第一テキスト行)を設定します。
void | setEquipment(String strEquipment) 設備番号を設定します。
void | setEquityType(String strEquityType) 持分タイプを設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFunctionalLocation(String strFunctionalLocation) 機能場所を設定します。
void | setIntProfile(String strIntProfile) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setInvestProfile(String strInvestProfile) 設備投資案件プロファイルを設定します。
void | setJointVenture(String strJointVenture) ジョイントベンチャを設定します。
void | setJvJibClass(String strJvJibClass) JIB/JIBE クラスを設定します。
void | setJvJibSubClassA(String strJvJibSubClassA) JIB/JIBE サブクラスAを設定します。
void | setJvObjectType(String strJvObjectType) ジョイントベンチャ対象タイプを設定します。
void | setLocation(String strLocation) 場所を設定します。
void | setNetworkAssignment(String strNetworkAssignment) ネットワーク割当を設定します。
void | setObjectclass(String strObjectclass) 対象クラスを設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setOverheadKey(String strOverheadKey) 間接費キーを設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPriority(String strPriority) 優先度を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjType(String strProjType) プロジェクトタイプを設定します。
void | setRecoveryInd(String strRecoveryInd) リカバリフラグを設定します。
void | setRequestCctr(String strRequestCctr) 申請原価センタを設定します。
void | setRequestCctrControllingArea(String strRequestCctrControllingArea) 依頼原価センタの管理領域を設定します。
void | setRequestCompCode(String strRequestCompCode) 会社コード要求を設定します。
void | setResAnalKey(String strResAnalKey) 結果分析キーを設定します。
void | setResponsibleNo(String strResponsibleNo) 責任者番号 (プロジェクト責任者)を設定します。
void | setRespsblCctr(String strRespsblCctr) 責任原価センタを設定します。
void | setRespsblCctrControllingArea(String strRespsblCctrControllingArea) 責任原価センタの管理領域を設定します。
void | setShortId(String strShortId) WBS 要素 ショート IDを設定します。
void | setStatistical(String strStatistical) 統計 WBS 要素を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUserFieldChar10_1(String strUserFieldChar101) 10 桁の第 3 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldChar10_2(String strUserFieldChar102) 10 桁の第 4 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldChar20_1(String strUserFieldChar201) 20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。
void | setUserFieldChar20_2(String strUserFieldChar202) 20 桁の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldCuky1(String strUserFieldCuky1) 値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldCuky1Iso(String strUserFieldCuky1Iso) ISO 通貨コードを設定します。
void | setUserFieldCuky2(String strUserFieldCuky2) 値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldCuky2Iso(String strUserFieldCuky2Iso) ISO 通貨コードを設定します。
void | setUserFieldCurr1(String strUserFieldCurr1) 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldCurr2(String strUserFieldCurr2) 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldDate1(String strUserFieldDate1) 日付の第 1 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldDate2(String strUserFieldDate2) 日付の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldFlag1(String strUserFieldFlag1) '評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldFlag2(String strUserFieldFlag2) '評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldKey(String strUserFieldKey) ユーザ定義項目のキーワード IDを設定します。
void | setUserFieldQuan1(String strUserFieldQuan1) 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldQuan2(String strUserFieldQuan2) 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldUnit1(String strUserFieldUnit1) 数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldUnit1Iso(String strUserFieldUnit1Iso) 単位の ISO コードを設定します。
void | setUserFieldUnit2(String strUserFieldUnit2) 数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldUnit2Iso(String strUserFieldUnit2Iso) 単位の ISO コードを設定します。
void | setWbsAccountAssignmentElement(String strWbsAccountAssignmentElement) 区分: 勘定設定要素を設定します。
void | setWbsActualDuration(String strWbsActualDuration) WBS 要素の実績長(期間)を設定します。
void | setWbsActualDurUnit(String strWbsActualDurUnit) 実績 WBS 要素日付の期間単位を設定します。
void | setWbsActualDurUnitIso(String strWbsActualDurUnitIso) 単位の ISO コードを設定します。
void | setWbsActualFinishDate(String strWbsActualFinishDate) WBS 要素の実績終了日を設定します。
void | setWbsActualStartDate(String strWbsActualStartDate) WBS 要素の実績開始日付を設定します。
void | setWbsBasicDuration(String strWbsBasicDuration) WBS 要素の基準日の長さ(期間)を設定します。
void | setWbsBasicDurUnit(String strWbsBasicDurUnit) 基準 WBS 要素日付の期間単位を設定します。
void | setWbsBasicDurUnitIso(String strWbsBasicDurUnitIso) 単位の ISO コードを設定します。
void | setWbsBasicFinishDate(String strWbsBasicFinishDate) WBS 要素: 基本終了日付を設定します。
void | setWbsBasicStartDate(String strWbsBasicStartDate) WBS 要素: 基本開始日を設定します。
void | setWbsBillingElement(String strWbsBillingElement) 区分: 請求要素を設定します。
void | setWbsCctrPostedActual(String strWbsCctrPostedActual) 原価が実際に転記される原価センタを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
void | setWbsForcastDurUnit(String strWbsForcastDurUnit) WBS 要素計画日付の単位を設定します。
void | setWbsForecastDuration(String strWbsForecastDuration) WBS 要素の予測期間を設定します。
void | setWbsForecastDurUnitIso(String strWbsForecastDurUnitIso) 単位の ISO コードを設定します。
void | setWbsForecastFinishDate(String strWbsForecastFinishDate) WBS 要素の予測済終了日付を設定します。
void | setWbsForecastStartDate(String strWbsForecastStartDate) WBS 要素の予測開始日を設定します。
void | setWbsPlanningElement(String strWbsPlanningElement) 区分: 計画要素を設定します。
void | setWbsScdActualFinishDate(String strWbsScdActualFinishDate) WBS 要素の仮実績終了日を設定します。
void | setWbsScdActualStartDate(String strWbsScdActualStartDate) WBS 要素の仮実績開始日を設定します。
void | setWbsScdBasicFinishDate(String strWbsScdBasicFinishDate) 最遅計画終了日 (基準)を設定します。
void | setWbsScdBasicStartDate(String strWbsScdBasicStartDate) 最早計画開始日 (基準)を設定します。
void | setWbsScdForecastFinishDate(String strWbsScdForecastFinishDate) 最遅計画終了日 (予測)を設定します。
void | setWbsScdForecastStartDate(String strWbsScdForecastStartDate) 計画開始日 (予測)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsElement

public ExpWbsElement()
WBS 要素についての詳細情報を作成します。

メソッドの詳細

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getDescription

public String getDescription()
PS: テキスト(短)(第一テキスト行)を取得します。

戻り値:
srtDescription PS: テキスト(短)(第一テキスト行)

getShortId

public String getShortId()
WBS 要素 ショート IDを取得します。

戻り値:
srtShortId WBS 要素 ショート ID

getResponsibleNo

public String getResponsibleNo()
責任者番号 (プロジェクト責任者)を取得します。

戻り値:
srtResponsibleNo 責任者番号 (プロジェクト責任者)

getApplicantNo

public String getApplicantNo()
申請者番号を取得します。

戻り値:
srtApplicantNo 申請者番号

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getProjType

public String getProjType()
プロジェクトタイプを取得します。

戻り値:
srtProjType プロジェクトタイプ

getNetworkAssignment

public String getNetworkAssignment()
ネットワーク割当を取得します。

戻り値:
srtNetworkAssignment ネットワーク割当

getCostingSheet

public String getCostingSheet()
原価計算表を取得します。

戻り値:
srtCostingSheet 原価計算表

getOverheadKey

public String getOverheadKey()
間接費キーを取得します。

戻り値:
srtOverheadKey 間接費キー

getCalendar

public String getCalendar()
稼動日カレンダを取得します。

戻り値:
srtCalendar 稼動日カレンダ

getPriority

public String getPriority()
優先度を取得します。

戻り値:
srtPriority 優先度

getEquipment

public String getEquipment()
設備番号を取得します。

戻り値:
srtEquipment 設備番号

getFunctionalLocation

public String getFunctionalLocation()
機能場所を取得します。

戻り値:
srtFunctionalLocation 機能場所

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtCurrencyIso ISO 通貨コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getUserFieldKey

public String getUserFieldKey()
ユーザ定義項目のキーワード IDを取得します。

戻り値:
srtUserFieldKey ユーザ定義項目のキーワード ID

getUserFieldChar20_1

public String getUserFieldChar20_1()
20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。

戻り値:
srtUserFieldChar201 20 文字の第 1 ユーザ項目 - WBS 要素 -

getUserFieldChar20_2

public String getUserFieldChar20_2()
20 桁の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar202 20 桁の第 2 ユーザ項目 - WBS 要素

getUserFieldChar10_1

public String getUserFieldChar10_1()
10 桁の第 3 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar101 10 桁の第 3 ユーザ項目 - WBS 要素

getUserFieldChar10_2

public String getUserFieldChar10_2()
10 桁の第 4 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar102 10 桁の第 4 ユーザ項目 - WBS 要素

getUserFieldQuan1

public String getUserFieldQuan1()
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldQuan1 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldUnit1

public String getUserFieldUnit1()
数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldUnit1 数量項目単位の第１ユーザ定義項目 - WBS 要素

getUserFieldUnit1Iso

public String getUserFieldUnit1Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit1Iso 単位の ISO コード

getUserFieldQuan2

public String getUserFieldQuan2()
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldQuan2 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldUnit2

public String getUserFieldUnit2()
数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldUnit2 数量項目単位の第２ユーザ定義項目 - WBS 要素

getUserFieldUnit2Iso

public String getUserFieldUnit2Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit2Iso 単位の ISO コード

getUserFieldCurr1

public String getUserFieldCurr1()
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldCurr1 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldCuky1

public String getUserFieldCuky1()
値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldCuky1 値項目単位の第１ユーザ定義項目 - WBS 要素

getUserFieldCuky1Iso

public String getUserFieldCuky1Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky1Iso ISO 通貨コード

getUserFieldCurr2

public String getUserFieldCurr2()
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldCurr2 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldCuky2

public String getUserFieldCuky2()
値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldCuky2 値項目単位の第２ユーザ定義項目 - WBS 要素

getUserFieldCuky2Iso

public String getUserFieldCuky2Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky2Iso ISO 通貨コード

getUserFieldDate1

public String getUserFieldDate1()
日付の第 1 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldDate1 日付の第 1 ユーザ項目 - WBS 要素

getUserFieldDate2

public String getUserFieldDate2()
日付の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldDate2 日付の第 2 ユーザ項目 - WBS 要素

getUserFieldFlag1

public String getUserFieldFlag1()
'評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldFlag1 '評価区分' の第 1 ユーザ項目 - WBS 要素

getUserFieldFlag2

public String getUserFieldFlag2()
'評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldFlag2 '評価区分' の第 2 ユーザ項目 - WBS 要素

getObjectclass

public String getObjectclass()
対象クラスを取得します。

戻り値:
srtObjectclass 対象クラス

getStatistical

public String getStatistical()
統計 WBS 要素を取得します。

戻り値:
srtStatistical 統計 WBS 要素

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getIntProfile

public String getIntProfile()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtIntProfile プロジェクト/指図金利計算の金利プロファイル

getJointVenture

public String getJointVenture()
ジョイントベンチャを取得します。

戻り値:
srtJointVenture ジョイントベンチャ

getRecoveryInd

public String getRecoveryInd()
リカバリフラグを取得します。

戻り値:
srtRecoveryInd リカバリフラグ

getEquityType

public String getEquityType()
持分タイプを取得します。

戻り値:
srtEquityType 持分タイプ

getJvObjectType

public String getJvObjectType()
ジョイントベンチャ対象タイプを取得します。

戻り値:
srtJvObjectType ジョイントベンチャ対象タイプ

getJvJibClass

public String getJvJibClass()
JIB/JIBE クラスを取得します。

戻り値:
srtJvJibClass JIB/JIBE クラス

getJvJibSubClassA

public String getJvJibSubClassA()
JIB/JIBE サブクラスAを取得します。

戻り値:
srtJvJibSubClassA JIB/JIBE サブクラスA

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getWbsPlanningElement

public String getWbsPlanningElement()
区分: 計画要素を取得します。

戻り値:
srtWbsPlanningElement 区分: 計画要素

getWbsAccountAssignmentElement

public String getWbsAccountAssignmentElement()
区分: 勘定設定要素を取得します。

戻り値:
srtWbsAccountAssignmentElement 区分: 勘定設定要素

getWbsBillingElement

public String getWbsBillingElement()
区分: 請求要素を取得します。

戻り値:
srtWbsBillingElement 区分: 請求要素

getRespsblCctr

public String getRespsblCctr()
責任原価センタを取得します。

戻り値:
srtRespsblCctr 責任原価センタ

getRespsblCctrControllingArea

public String getRespsblCctrControllingArea()
責任原価センタの管理領域を取得します。

戻り値:
srtRespsblCctrControllingArea 責任原価センタの管理領域

getRequestCctr

public String getRequestCctr()
申請原価センタを取得します。

戻り値:
srtRequestCctr 申請原価センタ

getRequestCompCode

public String getRequestCompCode()
会社コード要求を取得します。

戻り値:
srtRequestCompCode 会社コード要求

getRequestCctrControllingArea

public String getRequestCctrControllingArea()
依頼原価センタの管理領域を取得します。

戻り値:
srtRequestCctrControllingArea 依頼原価センタの管理領域

getLocation

public String getLocation()
場所を取得します。

戻り値:
srtLocation 場所

getChangeNo

public String getChangeNo()
変更番号を取得します。

戻り値:
srtChangeNo 変更番号

getInvestProfile

public String getInvestProfile()
設備投資案件プロファイルを取得します。

戻り値:
srtInvestProfile 設備投資案件プロファイル

getResAnalKey

public String getResAnalKey()
結果分析キーを取得します。

戻り値:
srtResAnalKey 結果分析キー

getWbsCctrPostedActual

public String getWbsCctrPostedActual()
原価が実際に転記される原価センタを取得します。

戻り値:
srtWbsCctrPostedActual 原価が実際に転記される原価センタ

getWbsBasicStartDate

public String getWbsBasicStartDate()
WBS 要素: 基本開始日を取得します。

戻り値:
srtWbsBasicStartDate WBS 要素: 基本開始日

getWbsBasicFinishDate

public String getWbsBasicFinishDate()
WBS 要素: 基本終了日付を取得します。

戻り値:
srtWbsBasicFinishDate WBS 要素: 基本終了日付

getWbsForecastStartDate

public String getWbsForecastStartDate()
WBS 要素の予測開始日を取得します。

戻り値:
srtWbsForecastStartDate WBS 要素の予測開始日

getWbsForecastFinishDate

public String getWbsForecastFinishDate()
WBS 要素の予測済終了日付を取得します。

戻り値:
srtWbsForecastFinishDate WBS 要素の予測済終了日付

getWbsActualStartDate

public String getWbsActualStartDate()
WBS 要素の実績開始日付を取得します。

戻り値:
srtWbsActualStartDate WBS 要素の実績開始日付

getWbsActualFinishDate

public String getWbsActualFinishDate()
WBS 要素の実績終了日を取得します。

戻り値:
srtWbsActualFinishDate WBS 要素の実績終了日

getWbsBasicDuration

public String getWbsBasicDuration()
WBS 要素の基準日の長さ(期間)を取得します。

戻り値:
srtWbsBasicDuration WBS 要素の基準日の長さ(期間)

getWbsBasicDurUnit

public String getWbsBasicDurUnit()
基準 WBS 要素日付の期間単位を取得します。

戻り値:
srtWbsBasicDurUnit 基準 WBS 要素日付の期間単位

getWbsBasicDurUnitIso

public String getWbsBasicDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsBasicDurUnitIso 単位の ISO コード

getWbsForecastDuration

public String getWbsForecastDuration()
WBS 要素の予測期間を取得します。

戻り値:
srtWbsForecastDuration WBS 要素の予測期間

getWbsForcastDurUnit

public String getWbsForcastDurUnit()
WBS 要素計画日付の単位を取得します。

戻り値:
srtWbsForcastDurUnit WBS 要素計画日付の単位

getWbsForecastDurUnitIso

public String getWbsForecastDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsForecastDurUnitIso 単位の ISO コード

getWbsActualDuration

public String getWbsActualDuration()
WBS 要素の実績長(期間)を取得します。

戻り値:
srtWbsActualDuration WBS 要素の実績長(期間)

getWbsActualDurUnit

public String getWbsActualDurUnit()
実績 WBS 要素日付の期間単位を取得します。

戻り値:
srtWbsActualDurUnit 実績 WBS 要素日付の期間単位

getWbsActualDurUnitIso

public String getWbsActualDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsActualDurUnitIso 単位の ISO コード

getWbsScdBasicStartDate

public String getWbsScdBasicStartDate()
最早計画開始日 (基準)を取得します。

戻り値:
srtWbsScdBasicStartDate 最早計画開始日 (基準)

getWbsScdBasicFinishDate

public String getWbsScdBasicFinishDate()
最遅計画終了日 (基準)を取得します。

戻り値:
srtWbsScdBasicFinishDate 最遅計画終了日 (基準)

getWbsScdForecastStartDate

public String getWbsScdForecastStartDate()
計画開始日 (予測)を取得します。

戻り値:
srtWbsScdForecastStartDate 計画開始日 (予測)

getWbsScdForecastFinishDate

public String getWbsScdForecastFinishDate()
最遅計画終了日 (予測)を取得します。

戻り値:
srtWbsScdForecastFinishDate 最遅計画終了日 (予測)

getWbsScdActualStartDate

public String getWbsScdActualStartDate()
WBS 要素の仮実績開始日を取得します。

戻り値:
srtWbsScdActualStartDate WBS 要素の仮実績開始日

getWbsScdActualFinishDate

public String getWbsScdActualFinishDate()
WBS 要素の仮実績終了日を取得します。

戻り値:
srtWbsScdActualFinishDate WBS 要素の仮実績終了日

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setDescription

public void setDescription(String strDescription)
PS: テキスト(短)(第一テキスト行)を設定します。

パラメータ:
strDescription - PS: テキスト(短)(第一テキスト行)

setShortId

public void setShortId(String strShortId)
WBS 要素 ショート IDを設定します。

パラメータ:
strShortId - WBS 要素 ショート ID

setResponsibleNo

public void setResponsibleNo(String strResponsibleNo)
責任者番号 (プロジェクト責任者)を設定します。

パラメータ:
strResponsibleNo - 責任者番号 (プロジェクト責任者)

setApplicantNo

public void setApplicantNo(String strApplicantNo)
申請者番号を設定します。

パラメータ:
strApplicantNo - 申請者番号

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setProjType

public void setProjType(String strProjType)
プロジェクトタイプを設定します。

パラメータ:
strProjType - プロジェクトタイプ

setNetworkAssignment

public void setNetworkAssignment(String strNetworkAssignment)
ネットワーク割当を設定します。

パラメータ:
strNetworkAssignment - ネットワーク割当

setCostingSheet

public void setCostingSheet(String strCostingSheet)
原価計算表を設定します。

パラメータ:
strCostingSheet - 原価計算表

setOverheadKey

public void setOverheadKey(String strOverheadKey)
間接費キーを設定します。

パラメータ:
strOverheadKey - 間接費キー

setCalendar

public void setCalendar(String strCalendar)
稼動日カレンダを設定します。

パラメータ:
strCalendar - 稼動日カレンダ

setPriority

public void setPriority(String strPriority)
優先度を設定します。

パラメータ:
strPriority - 優先度

setEquipment

public void setEquipment(String strEquipment)
設備番号を設定します。

パラメータ:
strEquipment - 設備番号

setFunctionalLocation

public void setFunctionalLocation(String strFunctionalLocation)
機能場所を設定します。

パラメータ:
strFunctionalLocation - 機能場所

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setUserFieldKey

public void setUserFieldKey(String strUserFieldKey)
ユーザ定義項目のキーワード IDを設定します。

パラメータ:
strUserFieldKey - ユーザ定義項目のキーワード ID

setUserFieldChar20_1

public void setUserFieldChar20_1(String strUserFieldChar201)
20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。

パラメータ:
strUserFieldChar201 - 20 文字の第 1 ユーザ項目 - WBS 要素 -

setUserFieldChar20_2

public void setUserFieldChar20_2(String strUserFieldChar202)
20 桁の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar202 - 20 桁の第 2 ユーザ項目 - WBS 要素

setUserFieldChar10_1

public void setUserFieldChar10_1(String strUserFieldChar101)
10 桁の第 3 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar101 - 10 桁の第 3 ユーザ項目 - WBS 要素

setUserFieldChar10_2

public void setUserFieldChar10_2(String strUserFieldChar102)
10 桁の第 4 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar102 - 10 桁の第 4 ユーザ項目 - WBS 要素

setUserFieldQuan1

public void setUserFieldQuan1(String strUserFieldQuan1)
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldQuan1 - 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldUnit1

public void setUserFieldUnit1(String strUserFieldUnit1)
数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldUnit1 - 数量項目単位の第１ユーザ定義項目 - WBS 要素

setUserFieldUnit1Iso

public void setUserFieldUnit1Iso(String strUserFieldUnit1Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit1Iso - 単位の ISO コード

setUserFieldQuan2

public void setUserFieldQuan2(String strUserFieldQuan2)
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldQuan2 - 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldUnit2

public void setUserFieldUnit2(String strUserFieldUnit2)
数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldUnit2 - 数量項目単位の第２ユーザ定義項目 - WBS 要素

setUserFieldUnit2Iso

public void setUserFieldUnit2Iso(String strUserFieldUnit2Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit2Iso - 単位の ISO コード

setUserFieldCurr1

public void setUserFieldCurr1(String strUserFieldCurr1)
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldCurr1 - 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldCuky1

public void setUserFieldCuky1(String strUserFieldCuky1)
値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldCuky1 - 値項目単位の第１ユーザ定義項目 - WBS 要素

setUserFieldCuky1Iso

public void setUserFieldCuky1Iso(String strUserFieldCuky1Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky1Iso - ISO 通貨コード

setUserFieldCurr2

public void setUserFieldCurr2(String strUserFieldCurr2)
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldCurr2 - 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldCuky2

public void setUserFieldCuky2(String strUserFieldCuky2)
値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldCuky2 - 値項目単位の第２ユーザ定義項目 - WBS 要素

setUserFieldCuky2Iso

public void setUserFieldCuky2Iso(String strUserFieldCuky2Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky2Iso - ISO 通貨コード

setUserFieldDate1

public void setUserFieldDate1(String strUserFieldDate1)
日付の第 1 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldDate1 - 日付の第 1 ユーザ項目 - WBS 要素

setUserFieldDate2

public void setUserFieldDate2(String strUserFieldDate2)
日付の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldDate2 - 日付の第 2 ユーザ項目 - WBS 要素

setUserFieldFlag1

public void setUserFieldFlag1(String strUserFieldFlag1)
'評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldFlag1 - '評価区分' の第 1 ユーザ項目 - WBS 要素

setUserFieldFlag2

public void setUserFieldFlag2(String strUserFieldFlag2)
'評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldFlag2 - '評価区分' の第 2 ユーザ項目 - WBS 要素

setObjectclass

public void setObjectclass(String strObjectclass)
対象クラスを設定します。

パラメータ:
strObjectclass - 対象クラス

setStatistical

public void setStatistical(String strStatistical)
統計 WBS 要素を設定します。

パラメータ:
strStatistical - 統計 WBS 要素

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setIntProfile

public void setIntProfile(String strIntProfile)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strIntProfile - プロジェクト/指図金利計算の金利プロファイル

setJointVenture

public void setJointVenture(String strJointVenture)
ジョイントベンチャを設定します。

パラメータ:
strJointVenture - ジョイントベンチャ

setRecoveryInd

public void setRecoveryInd(String strRecoveryInd)
リカバリフラグを設定します。

パラメータ:
strRecoveryInd - リカバリフラグ

setEquityType

public void setEquityType(String strEquityType)
持分タイプを設定します。

パラメータ:
strEquityType - 持分タイプ

setJvObjectType

public void setJvObjectType(String strJvObjectType)
ジョイントベンチャ対象タイプを設定します。

パラメータ:
strJvObjectType - ジョイントベンチャ対象タイプ

setJvJibClass

public void setJvJibClass(String strJvJibClass)
JIB/JIBE クラスを設定します。

パラメータ:
strJvJibClass - JIB/JIBE クラス

setJvJibSubClassA

public void setJvJibSubClassA(String strJvJibSubClassA)
JIB/JIBE サブクラスAを設定します。

パラメータ:
strJvJibSubClassA - JIB/JIBE サブクラスA

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setWbsPlanningElement

public void setWbsPlanningElement(String strWbsPlanningElement)
区分: 計画要素を設定します。

パラメータ:
strWbsPlanningElement - 区分: 計画要素

setWbsAccountAssignmentElement

public void setWbsAccountAssignmentElement(String strWbsAccountAssignmentElement)
区分: 勘定設定要素を設定します。

パラメータ:
strWbsAccountAssignmentElement - 区分: 勘定設定要素

setWbsBillingElement

public void setWbsBillingElement(String strWbsBillingElement)
区分: 請求要素を設定します。

パラメータ:
strWbsBillingElement - 区分: 請求要素

setRespsblCctr

public void setRespsblCctr(String strRespsblCctr)
責任原価センタを設定します。

パラメータ:
strRespsblCctr - 責任原価センタ

setRespsblCctrControllingArea

public void setRespsblCctrControllingArea(String strRespsblCctrControllingArea)
責任原価センタの管理領域を設定します。

パラメータ:
strRespsblCctrControllingArea - 責任原価センタの管理領域

setRequestCctr

public void setRequestCctr(String strRequestCctr)
申請原価センタを設定します。

パラメータ:
strRequestCctr - 申請原価センタ

setRequestCompCode

public void setRequestCompCode(String strRequestCompCode)
会社コード要求を設定します。

パラメータ:
strRequestCompCode - 会社コード要求

setRequestCctrControllingArea

public void setRequestCctrControllingArea(String strRequestCctrControllingArea)
依頼原価センタの管理領域を設定します。

パラメータ:
strRequestCctrControllingArea - 依頼原価センタの管理領域

setLocation

public void setLocation(String strLocation)
場所を設定します。

パラメータ:
strLocation - 場所

setChangeNo

public void setChangeNo(String strChangeNo)
変更番号を設定します。

パラメータ:
strChangeNo - 変更番号

setInvestProfile

public void setInvestProfile(String strInvestProfile)
設備投資案件プロファイルを設定します。

パラメータ:
strInvestProfile - 設備投資案件プロファイル

setResAnalKey

public void setResAnalKey(String strResAnalKey)
結果分析キーを設定します。

パラメータ:
strResAnalKey - 結果分析キー

setWbsCctrPostedActual

public void setWbsCctrPostedActual(String strWbsCctrPostedActual)
原価が実際に転記される原価センタを設定します。

パラメータ:
strWbsCctrPostedActual - 原価が実際に転記される原価センタ

setWbsBasicStartDate

public void setWbsBasicStartDate(String strWbsBasicStartDate)
WBS 要素: 基本開始日を設定します。

パラメータ:
strWbsBasicStartDate - WBS 要素: 基本開始日

setWbsBasicFinishDate

public void setWbsBasicFinishDate(String strWbsBasicFinishDate)
WBS 要素: 基本終了日付を設定します。

パラメータ:
strWbsBasicFinishDate - WBS 要素: 基本終了日付

setWbsForecastStartDate

public void setWbsForecastStartDate(String strWbsForecastStartDate)
WBS 要素の予測開始日を設定します。

パラメータ:
strWbsForecastStartDate - WBS 要素の予測開始日

setWbsForecastFinishDate

public void setWbsForecastFinishDate(String strWbsForecastFinishDate)
WBS 要素の予測済終了日付を設定します。

パラメータ:
strWbsForecastFinishDate - WBS 要素の予測済終了日付

setWbsActualStartDate

public void setWbsActualStartDate(String strWbsActualStartDate)
WBS 要素の実績開始日付を設定します。

パラメータ:
strWbsActualStartDate - WBS 要素の実績開始日付

setWbsActualFinishDate

public void setWbsActualFinishDate(String strWbsActualFinishDate)
WBS 要素の実績終了日を設定します。

パラメータ:
strWbsActualFinishDate - WBS 要素の実績終了日

setWbsBasicDuration

public void setWbsBasicDuration(String strWbsBasicDuration)
WBS 要素の基準日の長さ(期間)を設定します。

パラメータ:
strWbsBasicDuration - WBS 要素の基準日の長さ(期間)

setWbsBasicDurUnit

public void setWbsBasicDurUnit(String strWbsBasicDurUnit)
基準 WBS 要素日付の期間単位を設定します。

パラメータ:
strWbsBasicDurUnit - 基準 WBS 要素日付の期間単位

setWbsBasicDurUnitIso

public void setWbsBasicDurUnitIso(String strWbsBasicDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsBasicDurUnitIso - 単位の ISO コード

setWbsForecastDuration

public void setWbsForecastDuration(String strWbsForecastDuration)
WBS 要素の予測期間を設定します。

パラメータ:
strWbsForecastDuration - WBS 要素の予測期間

setWbsForcastDurUnit

public void setWbsForcastDurUnit(String strWbsForcastDurUnit)
WBS 要素計画日付の単位を設定します。

パラメータ:
strWbsForcastDurUnit - WBS 要素計画日付の単位

setWbsForecastDurUnitIso

public void setWbsForecastDurUnitIso(String strWbsForecastDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsForecastDurUnitIso - 単位の ISO コード

setWbsActualDuration

public void setWbsActualDuration(String strWbsActualDuration)
WBS 要素の実績長(期間)を設定します。

パラメータ:
strWbsActualDuration - WBS 要素の実績長(期間)

setWbsActualDurUnit

public void setWbsActualDurUnit(String strWbsActualDurUnit)
実績 WBS 要素日付の期間単位を設定します。

パラメータ:
strWbsActualDurUnit - 実績 WBS 要素日付の期間単位

setWbsActualDurUnitIso

public void setWbsActualDurUnitIso(String strWbsActualDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsActualDurUnitIso - 単位の ISO コード

setWbsScdBasicStartDate

public void setWbsScdBasicStartDate(String strWbsScdBasicStartDate)
最早計画開始日 (基準)を設定します。

パラメータ:
strWbsScdBasicStartDate - 最早計画開始日 (基準)

setWbsScdBasicFinishDate

public void setWbsScdBasicFinishDate(String strWbsScdBasicFinishDate)
最遅計画終了日 (基準)を設定します。

パラメータ:
strWbsScdBasicFinishDate - 最遅計画終了日 (基準)

setWbsScdForecastStartDate

public void setWbsScdForecastStartDate(String strWbsScdForecastStartDate)
計画開始日 (予測)を設定します。

パラメータ:
strWbsScdForecastStartDate - 計画開始日 (予測)

setWbsScdForecastFinishDate

public void setWbsScdForecastFinishDate(String strWbsScdForecastFinishDate)
最遅計画終了日 (予測)を設定します。

パラメータ:
strWbsScdForecastFinishDate - 最遅計画終了日 (予測)

setWbsScdActualStartDate

public void setWbsScdActualStartDate(String strWbsScdActualStartDate)
WBS 要素の仮実績開始日を設定します。

パラメータ:
strWbsScdActualStartDate - WBS 要素の仮実績開始日

setWbsScdActualFinishDate

public void setWbsScdActualFinishDate(String strWbsScdActualFinishDate)
WBS 要素の仮実績終了日を設定します。

パラメータ:
strWbsScdActualFinishDate - WBS 要素の仮実績終了日

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsHierarchie (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsHierarchie

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie
すべての実装インタフェース:
Serializable
public class ExpWbsHierarchie
extends Object
implements Serializable

WBS 階層についての情報クラス 機能は以下の通り

  • WBS 階層についての情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsHierarchie()
WBS 階層についての情報を作成します。
メソッドの概要
String | getDown() WBS 要素を取得します。
String | getLeft() WBS 要素を取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getRight() WBS 要素を取得します。
String | getUp() WBS 要素を取得します。
String | getWbsElement() WBS 要素を取得します。
void | setDown(String strDown) WBS 要素を設定します。
void | setLeft(String strLeft) WBS 要素を設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setRight(String strRight) WBS 要素を設定します。
void | setUp(String strUp) WBS 要素を設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsHierarchie

public ExpWbsHierarchie()
WBS 階層についての情報を作成します。

メソッドの詳細

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getUp

public String getUp()
WBS 要素を取得します。

戻り値:
srtUp WBS 要素

getDown

public String getDown()
WBS 要素を取得します。

戻り値:
srtDown WBS 要素

getLeft

public String getLeft()
WBS 要素を取得します。

戻り値:
srtLeft WBS 要素

getRight

public String getRight()
WBS 要素を取得します。

戻り値:
srtRight WBS 要素

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setUp

public void setUp(String strUp)
WBS 要素を設定します。

パラメータ:
strUp - WBS 要素

setDown

public void setDown(String strDown)
WBS 要素を設定します。

パラメータ:
strDown - WBS 要素

setLeft

public void setLeft(String strLeft)
WBS 要素を設定します。

パラメータ:
strLeft - WBS 要素

setRight

public void setRight(String strRight)
WBS 要素を設定します。

パラメータ:
strRight - WBS 要素

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsMilestone (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsMilestone

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone
すべての実装インタフェース:
Serializable
public class ExpWbsMilestone
extends Object
implements Serializable

WBS マイルストーンに関する詳細情報クラス 機能は以下の通り

  • WBS マイルストーンに関する詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsMilestone()
WBS マイルストーンに関する詳細情報を作成します。
メソッドの概要
String | getActualDate() 実績日付(マイルストーン通過)を取得します。
String | getActualTime() 実績日/時間(マイルストーン適合)を取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() テキストを取得します。
String | getEarnedValueIndicator() 進捗分析関連のマイルストーンを取得します。
String | getFixedMilestoneDateBasic() 固定マイルストーン日付(基準)を取得します。
String | getFixedMilestoneDateForecast() マイルストーン固定日付を取得します。
String | getFixedMilestoneTimeBasic() 固定マイルストーン時間(基準)を取得します。
String | getFixedMilestoneTimeForecast() マイルストーン固定時間 (F)を取得します。
String | getInvoicePercentage() 請求金額率 (%)を取得します。
String | getLatestDatesIndicator() 区分: 最遅日を取得します。
String | getMilestoneNumber() マイルストーン番号を取得します。
String | getMilestoneUsage() マイルストーン用途を取得します。
String | getOffsetMilestoneDate() マイルストーン日付のオフセットを取得します。
String | getOffsetMilestoneDateUnit() マイルストーンのオフセットのための時間単位を取得します。
String | getOffsetMilestoneDateUnitIso() 単位の ISO コードを取得します。
String | getOffsetPercentage() 活動日に対するマイルストーンの百分率によるオフセットを取得します。
String | getOffsetStartEndIndicator() 区分: オフセット用の参照（開始/終了活動日）を取得します。
String | getPercentageOfCompletion() 進捗度 (%)を取得します。
String | getSalesDocDateInidicator() 販売伝票の日付に関連するマイルストーンを取得します。
String | getSchedMilestoneDateBasic() マイルストーン計画日(基準)を取得します。
String | getSchedMilestoneDateForecast() マイルストーン計画日(予測)を取得します。
String | getSchedMilestoneTimeBasic() マイルストーン計画時間(基準)を取得します。
String | getSchedMilestoneTimeForecast() マイルストーン計画時間(予測)を取得します。
String | getTrendAnalysisIndicator() 傾向分析の関連マイルストーンを取得します。
String | getWbsElement() WBS 要素を取得します。
void | setActualDate(String strActualDate) 実績日付(マイルストーン通過)を設定します。
void | setActualTime(String strActualTime) 実績日/時間(マイルストーン適合)を設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) テキストを設定します。
void | setEarnedValueIndicator(String strEarnedValueIndicator) 進捗分析関連のマイルストーンを設定します。
void | setFixedMilestoneDateBasic(String strFixedMilestoneDateBasic) 固定マイルストーン日付(基準)を設定します。
void | setFixedMilestoneDateForecast(String strFixedMilestoneDateForecast) マイルストーン固定日付を設定します。
void | setFixedMilestoneTimeBasic(String strFixedMilestoneTimeBasic) 固定マイルストーン時間(基準)を設定します。
void | setFixedMilestoneTimeForecast(String strFixedMilestoneTimeForecast) マイルストーン固定時間 (F)を設定します。
void | setInvoicePercentage(String strInvoicePercentage) 請求金額率 (%)を設定します。
void | setLatestDatesIndicator(String strLatestDatesIndicator) 区分: 最遅日を設定します。
void | setMilestoneNumber(String strMilestoneNumber) マイルストーン番号を設定します。
void | setMilestoneUsage(String strMilestoneUsage) マイルストーン用途を設定します。
void | setOffsetMilestoneDate(String strOffsetMilestoneDate) マイルストーン日付のオフセットを設定します。
void | setOffsetMilestoneDateUnit(String strOffsetMilestoneDateUnit) マイルストーンのオフセットのための時間単位を設定します。
void | setOffsetMilestoneDateUnitIso(String strOffsetMilestoneDateUnitIso) 単位の ISO コードを設定します。
void | setOffsetPercentage(String strOffsetPercentage) 活動日に対するマイルストーンの百分率によるオフセットを設定します。
void | setOffsetStartEndIndicator(String strOffsetStartEndIndicator) 区分: オフセット用の参照（開始/終了活動日）を設定します。
void | setPercentageOfCompletion(String strPercentageOfCompletion) 進捗度 (%)を設定します。
void | setSalesDocDateInidicator(String strSalesDocDateInidicator) 販売伝票の日付に関連するマイルストーンを設定します。
void | setSchedMilestoneDateBasic(String strSchedMilestoneDateBasic) マイルストーン計画日(基準)を設定します。
void | setSchedMilestoneDateForecast(String strSchedMilestoneDateForecast) マイルストーン計画日(予測)を設定します。
void | setSchedMilestoneTimeBasic(String strSchedMilestoneTimeBasic) マイルストーン計画時間(基準)を設定します。
void | setSchedMilestoneTimeForecast(String strSchedMilestoneTimeForecast) マイルストーン計画時間(予測)を設定します。
void | setTrendAnalysisIndicator(String strTrendAnalysisIndicator) 傾向分析の関連マイルストーンを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsMilestone

public ExpWbsMilestone()
WBS マイルストーンに関する詳細情報を作成します。

メソッドの詳細

getMilestoneNumber

public String getMilestoneNumber()
マイルストーン番号を取得します。

戻り値:
srtMilestoneNumber マイルストーン番号

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getMilestoneUsage

public String getMilestoneUsage()
マイルストーン用途を取得します。

戻り値:
srtMilestoneUsage マイルストーン用途

getDescription

public String getDescription()
テキストを取得します。

戻り値:
srtDescription テキスト

getSchedMilestoneDateBasic

public String getSchedMilestoneDateBasic()
マイルストーン計画日(基準)を取得します。

戻り値:
srtSchedMilestoneDateBasic マイルストーン計画日(基準)

getSchedMilestoneTimeBasic

public String getSchedMilestoneTimeBasic()
マイルストーン計画時間(基準)を取得します。

戻り値:
srtSchedMilestoneTimeBasic マイルストーン計画時間(基準)

getSchedMilestoneDateForecast

public String getSchedMilestoneDateForecast()
マイルストーン計画日(予測)を取得します。

戻り値:
srtSchedMilestoneDateForecast マイルストーン計画日(予測)

getSchedMilestoneTimeForecast

public String getSchedMilestoneTimeForecast()
マイルストーン計画時間(予測)を取得します。

戻り値:
srtSchedMilestoneTimeForecast マイルストーン計画時間(予測)

getFixedMilestoneDateBasic

public String getFixedMilestoneDateBasic()
固定マイルストーン日付(基準)を取得します。

戻り値:
srtFixedMilestoneDateBasic 固定マイルストーン日付(基準)

getFixedMilestoneTimeBasic

public String getFixedMilestoneTimeBasic()
固定マイルストーン時間(基準)を取得します。

戻り値:
srtFixedMilestoneTimeBasic 固定マイルストーン時間(基準)

getFixedMilestoneDateForecast

public String getFixedMilestoneDateForecast()
マイルストーン固定日付を取得します。

戻り値:
srtFixedMilestoneDateForecast マイルストーン固定日付

getFixedMilestoneTimeForecast

public String getFixedMilestoneTimeForecast()
マイルストーン固定時間 (F)を取得します。

戻り値:
srtFixedMilestoneTimeForecast マイルストーン固定時間 (F)

getActualDate

public String getActualDate()
実績日付(マイルストーン通過)を取得します。

戻り値:
srtActualDate 実績日付(マイルストーン通過)

getActualTime

public String getActualTime()
実績日/時間(マイルストーン適合)を取得します。

戻り値:
srtActualTime 実績日/時間(マイルストーン適合)

getLatestDatesIndicator

public String getLatestDatesIndicator()
区分: 最遅日を取得します。

戻り値:
srtLatestDatesIndicator 区分: 最遅日

getOffsetStartEndIndicator

public String getOffsetStartEndIndicator()
区分: オフセット用の参照（開始/終了活動日）を取得します。

戻り値:
srtOffsetStartEndIndicator 区分: オフセット用の参照（開始/終了活動日）

getOffsetMilestoneDate

public String getOffsetMilestoneDate()
マイルストーン日付のオフセットを取得します。

戻り値:
srtOffsetMilestoneDate マイルストーン日付のオフセット

getOffsetMilestoneDateUnit

public String getOffsetMilestoneDateUnit()
マイルストーンのオフセットのための時間単位を取得します。

戻り値:
srtOffsetMilestoneDateUnit マイルストーンのオフセットのための時間単位

getOffsetMilestoneDateUnitIso

public String getOffsetMilestoneDateUnitIso()
単位の ISO コードを取得します。

戻り値:
srtOffsetMilestoneDateUnitIso 単位の ISO コード

getOffsetPercentage

public String getOffsetPercentage()
活動日に対するマイルストーンの百分率によるオフセットを取得します。

戻り値:
srtOffsetPercentage 活動日に対するマイルストーンの百分率によるオフセット

getTrendAnalysisIndicator

public String getTrendAnalysisIndicator()
傾向分析の関連マイルストーンを取得します。

戻り値:
srtTrendAnalysisIndicator 傾向分析の関連マイルストーン

getEarnedValueIndicator

public String getEarnedValueIndicator()
進捗分析関連のマイルストーンを取得します。

戻り値:
srtEarnedValueIndicator 進捗分析関連のマイルストーン

getPercentageOfCompletion

public String getPercentageOfCompletion()
進捗度 (%)を取得します。

戻り値:
srtPercentageOfCompletion 進捗度 (%)

getSalesDocDateInidicator

public String getSalesDocDateInidicator()
販売伝票の日付に関連するマイルストーンを取得します。

戻り値:
srtSalesDocDateInidicator 販売伝票の日付に関連するマイルストーン

getInvoicePercentage

public String getInvoicePercentage()
請求金額率 (%)を取得します。

戻り値:
srtInvoicePercentage 請求金額率 (%)

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

setMilestoneNumber

public void setMilestoneNumber(String strMilestoneNumber)
マイルストーン番号を設定します。

パラメータ:
strMilestoneNumber - マイルストーン番号

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setMilestoneUsage

public void setMilestoneUsage(String strMilestoneUsage)
マイルストーン用途を設定します。

パラメータ:
strMilestoneUsage - マイルストーン用途

setDescription

public void setDescription(String strDescription)
テキストを設定します。

パラメータ:
strDescription - テキスト

setSchedMilestoneDateBasic

public void setSchedMilestoneDateBasic(String strSchedMilestoneDateBasic)
マイルストーン計画日(基準)を設定します。

パラメータ:
strSchedMilestoneDateBasic - マイルストーン計画日(基準)

setSchedMilestoneTimeBasic

public void setSchedMilestoneTimeBasic(String strSchedMilestoneTimeBasic)
マイルストーン計画時間(基準)を設定します。

パラメータ:
strSchedMilestoneTimeBasic - マイルストーン計画時間(基準)

setSchedMilestoneDateForecast

public void setSchedMilestoneDateForecast(String strSchedMilestoneDateForecast)
マイルストーン計画日(予測)を設定します。

パラメータ:
strSchedMilestoneDateForecast - マイルストーン計画日(予測)

setSchedMilestoneTimeForecast

public void setSchedMilestoneTimeForecast(String strSchedMilestoneTimeForecast)
マイルストーン計画時間(予測)を設定します。

パラメータ:
strSchedMilestoneTimeForecast - マイルストーン計画時間(予測)

setFixedMilestoneDateBasic

public void setFixedMilestoneDateBasic(String strFixedMilestoneDateBasic)
固定マイルストーン日付(基準)を設定します。

パラメータ:
strFixedMilestoneDateBasic - 固定マイルストーン日付(基準)

setFixedMilestoneTimeBasic

public void setFixedMilestoneTimeBasic(String strFixedMilestoneTimeBasic)
固定マイルストーン時間(基準)を設定します。

パラメータ:
strFixedMilestoneTimeBasic - 固定マイルストーン時間(基準)

setFixedMilestoneDateForecast

public void setFixedMilestoneDateForecast(String strFixedMilestoneDateForecast)
マイルストーン固定日付を設定します。

パラメータ:
strFixedMilestoneDateForecast - マイルストーン固定日付

setFixedMilestoneTimeForecast

public void setFixedMilestoneTimeForecast(String strFixedMilestoneTimeForecast)
マイルストーン固定時間 (F)を設定します。

パラメータ:
strFixedMilestoneTimeForecast - マイルストーン固定時間 (F)

setActualDate

public void setActualDate(String strActualDate)
実績日付(マイルストーン通過)を設定します。

パラメータ:
strActualDate - 実績日付(マイルストーン通過)

setActualTime

public void setActualTime(String strActualTime)
実績日/時間(マイルストーン適合)を設定します。

パラメータ:
strActualTime - 実績日/時間(マイルストーン適合)

setLatestDatesIndicator

public void setLatestDatesIndicator(String strLatestDatesIndicator)
区分: 最遅日を設定します。

パラメータ:
strLatestDatesIndicator - 区分: 最遅日

setOffsetStartEndIndicator

public void setOffsetStartEndIndicator(String strOffsetStartEndIndicator)
区分: オフセット用の参照（開始/終了活動日）を設定します。

パラメータ:
strOffsetStartEndIndicator - 区分: オフセット用の参照（開始/終了活動日）

setOffsetMilestoneDate

public void setOffsetMilestoneDate(String strOffsetMilestoneDate)
マイルストーン日付のオフセットを設定します。

パラメータ:
strOffsetMilestoneDate - マイルストーン日付のオフセット

setOffsetMilestoneDateUnit

public void setOffsetMilestoneDateUnit(String strOffsetMilestoneDateUnit)
マイルストーンのオフセットのための時間単位を設定します。

パラメータ:
strOffsetMilestoneDateUnit - マイルストーンのオフセットのための時間単位

setOffsetMilestoneDateUnitIso

public void setOffsetMilestoneDateUnitIso(String strOffsetMilestoneDateUnitIso)
単位の ISO コードを設定します。

パラメータ:
strOffsetMilestoneDateUnitIso - 単位の ISO コード

setOffsetPercentage

public void setOffsetPercentage(String strOffsetPercentage)
活動日に対するマイルストーンの百分率によるオフセットを設定します。

パラメータ:
strOffsetPercentage - 活動日に対するマイルストーンの百分率によるオフセット

setTrendAnalysisIndicator

public void setTrendAnalysisIndicator(String strTrendAnalysisIndicator)
傾向分析の関連マイルストーンを設定します。

パラメータ:
strTrendAnalysisIndicator - 傾向分析の関連マイルストーン

setEarnedValueIndicator

public void setEarnedValueIndicator(String strEarnedValueIndicator)
進捗分析関連のマイルストーンを設定します。

パラメータ:
strEarnedValueIndicator - 進捗分析関連のマイルストーン

setPercentageOfCompletion

public void setPercentageOfCompletion(String strPercentageOfCompletion)
進捗度 (%)を設定します。

パラメータ:
strPercentageOfCompletion - 進捗度 (%)

setSalesDocDateInidicator

public void setSalesDocDateInidicator(String strSalesDocDateInidicator)
販売伝票の日付に関連するマイルストーンを設定します。

パラメータ:
strSalesDocDateInidicator - 販売伝票の日付に関連するマイルストーン

setInvoicePercentage

public void setInvoicePercentage(String strInvoicePercentage)
請求金額率 (%)を設定します。

パラメータ:
strInvoicePercentage - 請求金額率 (%)

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HierarchyNodes (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス HierarchyNodes

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes
すべての実装インタフェース:
Serializable
public class HierarchyNodes
extends Object
implements Serializable

階層ノード情報クラス 機能は以下の通り

  • 階層ノード情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HierarchyNodes()
階層ノードを作成します。
メソッドの概要
String | getDescript() グループテキスト (短)を取得します。
String | getGroupname() グループ名を取得します。
String | getHierlevel() 階層のエントリレベルを取得します。
String | getValcount() 階層ノード内の値の値数を取得します。
void | setDescript(String strDescript) グループテキスト (短)を設定します。
void | setGroupname(String strGroupname) グループ名を設定します。
void | setHierlevel(String strHierlevel) 階層のエントリレベルを設定します。
void | setValcount(String strValcount) 階層ノード内の値の値数を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HierarchyNodes

public HierarchyNodes()
階層ノードを作成します。

メソッドの詳細

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

getHierlevel

public String getHierlevel()
階層のエントリレベルを取得します。

戻り値:
srtHierlevel 階層のエントリレベル

getValcount

public String getValcount()
階層ノード内の値の値数を取得します。

戻り値:
srtValcount 階層ノード内の値の値数

getDescript

public String getDescript()
グループテキスト (短)を取得します。

戻り値:
srtDescript グループテキスト (短)

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

setHierlevel

public void setHierlevel(String strHierlevel)
階層のエントリレベルを設定します。

パラメータ:
strHierlevel - 階層のエントリレベル

setValcount

public void setValcount(String strValcount)
階層ノード内の値の値数を設定します。

パラメータ:
strValcount - 階層ノード内の値の値数

setDescript

public void setDescript(String strDescript)
グループテキスト (短)を設定します。

パラメータ:
strDescript - グループテキスト (短)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HierarchyValues (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス HierarchyValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues
すべての実装インタフェース:
Serializable
public class HierarchyValues
extends Object
implements Serializable

階層値情報クラス 機能は以下の通り

  • 階層値情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HierarchyValues()
階層値を作成します。
メソッドの概要
String | getValfrom() 原価センタ/利益センタを取得します。
String | getValto() 原価センタ/利益センタを取得します。
void | setValfrom(String strValfrom) 原価センタ/利益センタを設定します。
void | setValto(String strValto) 原価センタ/利益センタを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HierarchyValues

public HierarchyValues()
階層値を作成します。

メソッドの詳細

getValfrom

public String getValfrom()
原価センタ/利益センタを取得します。

戻り値:
srtValfrom 原価センタ/利益センタ

getValto

public String getValto()
原価センタ/利益センタを取得します。

戻り値:
srtValto 原価センタ/利益センタ

setValfrom

public void setValfrom(String strValfrom)
原価センタ/利益センタを設定します。

パラメータ:
strValfrom - 原価センタ/利益センタ

setValto

public void setValto(String strValto)
原価センタ/利益センタを設定します。

パラメータ:
strValto - 原価センタ/利益センタ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImpWbsElement (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ImpWbsElement

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement
すべての実装インタフェース:
Serializable
public class ImpWbsElement
extends Object
implements Serializable

詳細情報を必要とする WBS 要素クラス 機能は以下の通り

  • 詳細情報を必要とする WBS 要素を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ImpWbsElement()
詳細情報を必要とする WBS 要素を作成します。
ImpWbsElement(int index)
詳細情報を必要とする WBS 要素を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getWbsElement() WBS 要素を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImpWbsElement

public ImpWbsElement()
詳細情報を必要とする WBS 要素を作成します。

ImpWbsElement

public ImpWbsElement(int index)
詳細情報を必要とする WBS 要素を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail
すべての実装インタフェース:
Serializable
public class InternalOrderGetDetail
extends ReferenceController
implements Serializable

内部指図書詳細情報取得クラス
機能は以下の通り

  • 内部指図書詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより内部指図書詳細情報を検索します。
ArrayList | getAllowedBusTractList() 使用可能業務トランザクションのテーブル（AllowedBusTractインスタンスの配列）を取得します。
String | getLanguage() ステータスおよび業務トランザクションテキストの言語を取得します。
MasterData | getMasterData() 指図のマスタデータ構造を取得します。
String | getOrderid() 指図番号を取得します。
ArrayList | getSystemStatusList() システムステータステーブルを取得します。
ArrayList | getUserStatusList() ユーザステータス/指図ステータステーブルを取得します。
void | setAllowedBusTractList(ArrayList allowedBusTractList) 使用可能業務トランザクションのテーブル（AllowedBusTractインスタンスの配列）を設定します。
void | setExportParam(BapiController bapiController) 内部指図書詳細情報ををセットします。
void | setImportParam(BapiController bapiController) 内部指図書詳細情報を検索する条件ををセットします。
void | setLanguage(String strLanguage) ステータスおよび業務トランザクションテキストの言語を設定します。
void | setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。
void | setOrderid(String strOrderid) 指図番号を設定します。
void | setSystemStatusList(ArrayList systemStatusList) システムステータステーブルを設定します。
void | setUserStatusList(ArrayList userStatusList) ユーザステータス/指図ステータステーブルを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternalOrderGetDetail

public InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

InternalOrderGetDetail

public InternalOrderGetDetail(String orderId,
                              String language,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPFinancialAppException,
                              SAPFinancialSystemException
パラメータ:
orderId - 指図番号
language - ステータス及び業務トランザクションテキストの言語
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより内部指図書詳細情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
内部指図書詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
内部指図書詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setLanguage

public void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。

パラメータ:
strLanguage - ステータスおよび業務トランザクションテキストの言語

setMasterData

public void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。

パラメータ:
masterData - 指図のマスタデータ構造

setSystemStatusList

public void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。

パラメータ:
systemStatusList - システムステータステーブル（SystemStatusインスタンスの配列
関連項目:
SystemStatus

setUserStatusList

public void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。

パラメータ:
userStatusList - ユーザステータス/指図ステータステーブル（UserStatusインスタンスの配列）
関連項目:
UserStatus

setAllowedBusTractList

public void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブル（AllowedBusTractインスタンスの配列）を設定します。

パラメータ:
allowedBusTractList - 使用可能業務トランザクションのテーブル
関連項目:
AllowedBusTract

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getLanguage

public String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。

戻り値:
srtLanguage ステータスおよび業務トランザクションテキストの言語

getMasterData

public MasterData getMasterData()
指図のマスタデータ構造を取得します。

戻り値:
masterData 指図のマスタデータ構造

getSystemStatusList

public ArrayList getSystemStatusList()
システムステータステーブルを取得します。

戻り値:
systemStatusList システムステータステーブル（SystemStatusインスタンスの配列
関連項目:
SystemStatus

getUserStatusList

public ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。

戻り値:
userStatusList ユーザステータス/指図ステータステーブル（UserStatusインスタンスの配列）
関連項目:
UserStatus

getAllowedBusTractList

public ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブル（AllowedBusTractインスタンスの配列）を取得します。

戻り値:
allowedBusTractList 使用可能業務トランザクションのテーブル
関連項目:
AllowedBusTract

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController
すべての実装インタフェース:
Serializable
public class InternalOrderGetDetailController
extends Object
implements Serializable

内部指図書詳細コントローラクラス
機能は以下の通り

  • 内部指図書詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
InternalOrderGetDetailController()
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
メソッドの概要
 void executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。
 String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。
 MasterData getMasterData()
指図のマスタデータ構造を取得します。
 String getOrderid()
指図番号を取得します。
 ArrayList getSystemStatusList()
システムステータステーブルを取得します。
 ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。
 void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。
 void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。
 void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。
 void setOrderid(String strOrderid)
指図番号を設定します。
 void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。
 void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InternalOrderGetDetailController

public InternalOrderGetDetailController(String orderid,
                                        String language)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPFinancialAppException,
                                        SAPFinancialSystemException
パラメータ:
orderid - 指図番号
language - ステータスおよび業務トランザクションテキストの言語
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetDetailController

public InternalOrderGetDetailController(String orderid,
                                        String language,
                                        SapClient sapClient)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPFinancialAppException,
                                        SAPFinancialSystemException
パラメータ:
orderid - 指図番号
language - ステータスおよび業務トランザクションテキストの言語
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetDetailController

public InternalOrderGetDetailController()
InternalOrderGetDetailControllerのコンストラクタを生成します。

InternalOrderGetDetailController

public InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setLanguage

public void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。

パラメータ:
strLanguage - ステータスおよび業務トランザクションテキストの言語

setMasterData

public void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。

パラメータ:
masterData - 指図のマスタデータ構造

setSystemStatusList

public void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。

パラメータ:
systemStatusList - システムステータステーブル

setUserStatusList

public void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。

パラメータ:
userStatusList - ユーザステータス/指図ステータステーブル

setAllowedBusTractList

public void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。

パラメータ:
allowedBusTractList - 使用可能業務トランザクションのテーブル

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getLanguage

public String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。

戻り値:
srtLanguage ステータスおよび業務トランザクションテキストの言語

getMasterData

public MasterData getMasterData()
指図のマスタデータ構造を取得します。

戻り値:
masterData 指図のマスタデータ構造

getSystemStatusList

public ArrayList getSystemStatusList()
システムステータステーブルを取得します。

戻り値:
systemStatusList システムステータステーブル

getUserStatusList

public ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。

戻り値:
userStatusList ユーザステータス/指図ステータステーブル

getAllowedBusTractList

public ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。

戻り値:
allowedBusTractList 使用可能業務トランザクションのテーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList
すべての実装インタフェース:
Serializable
public class InternalOrderGetList
extends ReferenceController
implements Serializable

内部指図書（一覧）情報取得クラス
機能は以下の通り

  • 内部指図書（一覧）情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより内部指図書（一覧）情報を検索します。
String | getControllingArea() 管理領域を取得します。
String | getOrder() 指図番号 (個別値、または下限値)を取得します。
String | getOrderExternalNo() 外部指図番号 (個別値、または下限値)を取得します。
String | getOrderExternalNoTo() 外部指図番号 (上限値)を取得します。
ArrayList | getOrderListList() 選択指図一覧を取得します。
String | getOrderTo() 指図番号 (上限値)を取得します。
String | getOrderType() 指図タイプを取得します。
String | getRespCostCenter() 責任原価センタを取得します。
void | setControllingArea(String strControllingArea) 管理領域を設定します。
void | setExportParam(BapiController bapiController) 内部指図書（一覧）情報ををセットします。
void | setImportParam(BapiController bapiController) 内部指図書（一覧）情報を検索する条件ををセットします。
void | setOrder(String strOrder) 指図番号 (個別値、または下限値)を設定します。
void | setOrderExternalNo(String strOrderExternalNo) 外部指図番号 (個別値、または下限値)を設定します。
void | setOrderExternalNoTo(String strOrderExternalNoTo) 外部指図番号 (上限値)を設定します。
void | setOrderListList(ArrayList orderListList) 選択指図一覧を設定します。
void | setOrderTo(String strOrderTo) 指図番号 (上限値)を設定します。
void | setOrderType(String strOrderType) 指図タイプを設定します。
void | setRespCostCenter(String strRespCostCenter) 責任原価センタを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternalOrderGetList

public InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

InternalOrderGetList

public InternalOrderGetList(String controllingArea,
                            String respCostCenter,
                            String orderType,
                            String order,
                            String orderTo,
                            String orderExternalNo,
                            String orderExternalNoTo,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPFinancialAppException,
                            SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより内部指図書（一覧）情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
内部指図書（一覧）情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
内部指図書（一覧）情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setRespCostCenter

public void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。

パラメータ:
strRespCostCenter - 責任原価センタ

setOrderType

public void setOrderType(String strOrderType)
指図タイプを設定します。

パラメータ:
strOrderType - 指図タイプ

setOrder

public void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrder - 指図番号 (個別値、または下限値)

setOrderTo

public void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。

パラメータ:
strOrderTo - 指図番号 (上限値)

setOrderExternalNo

public void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrderExternalNo - 外部指図番号 (個別値、または下限値)

setOrderExternalNoTo

public void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。

パラメータ:
strOrderExternalNoTo - 外部指図番号 (上限値)

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getRespCostCenter

public String getRespCostCenter()
責任原価センタを取得します。

戻り値:
srtRespCostCenter 責任原価センタ

getOrderType

public String getOrderType()
指図タイプを取得します。

戻り値:
srtOrderType 指図タイプ

getOrder

public String getOrder()
指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrder 指図番号 (個別値、または下限値)

getOrderTo

public String getOrderTo()
指図番号 (上限値)を取得します。

戻り値:
srtOrderTo 指図番号 (上限値)

getOrderExternalNo

public String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrderExternalNo 外部指図番号 (個別値、または下限値)

getOrderExternalNoTo

public String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。

戻り値:
srtOrderExternalNoTo 外部指図番号 (上限値)

setOrderListList

public void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。

パラメータ:
orderListList - 選択指図一覧

getOrderListList

public ArrayList getOrderListList()
選択指図一覧を取得します。

戻り値:
orderListList 選択指図一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetListController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController
すべての実装インタフェース:
Serializable
public class InternalOrderGetListController
extends Object
implements Serializable

内部指図書一覧コントローラクラス
機能は以下の通り

  • 内部指図書一覧を取得します。

関連項目:
直列化された形式

コンストラクタの概要
InternalOrderGetListController()
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 String getControllingArea()
管理領域を取得します。
 String getOrder()
指図番号 (個別値、または下限値)を取得します。
 String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。
 String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。
 ArrayList getOrderListList()
選択指図一覧を取得します。
 String getOrderTo()
指図番号 (上限値)を取得します。
 String getOrderType()
指図タイプを取得します。
 String getRespCostCenter()
責任原価センタを取得します。
 void setControllingArea(String strControllingArea)
管理領域を設定します。
 void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。
 void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。
 void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。
 void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。
 void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。
 void setOrderType(String strOrderType)
指図タイプを設定します。
 void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InternalOrderGetListController

public InternalOrderGetListController(String controllingArea,
                                      String respCostCenter,
                                      String orderType,
                                      String order,
                                      String orderTo,
                                      String orderExternalNo,
                                      String orderExternalNoTo)
                               throws SAPAuthAppException,
                                      SAPAuthSystemException,
                                      SAPGeneralAppException,
                                      SAPGeneralSystemException,
                                      SAPFinancialAppException,
                                      SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetListController

public InternalOrderGetListController(String controllingArea,
                                      String respCostCenter,
                                      String orderType,
                                      String order,
                                      String orderTo,
                                      String orderExternalNo,
                                      String orderExternalNoTo,
                                      SapClient sapClient)
                               throws SAPAuthAppException,
                                      SAPAuthSystemException,
                                      SAPGeneralAppException,
                                      SAPGeneralSystemException,
                                      SAPFinancialAppException,
                                      SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetListController

public InternalOrderGetListController()
InternalOrderGetListControllerのコンストラクタを生成します。

InternalOrderGetListController

public InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計系APIアプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setRespCostCenter

public void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。

パラメータ:
strRespCostCenter - 責任原価センタ

setOrderType

public void setOrderType(String strOrderType)
指図タイプを設定します。

パラメータ:
strOrderType - 指図タイプ

setOrder

public void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrder - 指図番号 (個別値、または下限値)

setOrderTo

public void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。

パラメータ:
strOrderTo - 指図番号 (上限値)

setOrderExternalNo

public void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrderExternalNo - 外部指図番号 (個別値、または下限値)

setOrderExternalNoTo

public void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。

パラメータ:
strOrderExternalNoTo - 外部指図番号 (上限値)

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getRespCostCenter

public String getRespCostCenter()
責任原価センタを取得します。

戻り値:
srtRespCostCenter 責任原価センタ

getOrderType

public String getOrderType()
指図タイプを取得します。

戻り値:
srtOrderType 指図タイプ

getOrder

public String getOrder()
指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrder 指図番号 (個別値、または下限値)

getOrderTo

public String getOrderTo()
指図番号 (上限値)を取得します。

戻り値:
srtOrderTo 指図番号 (上限値)

getOrderExternalNo

public String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrderExternalNo 外部指図番号 (個別値、または下限値)

getOrderExternalNoTo

public String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。

戻り値:
srtOrderExternalNoTo 外部指図番号 (上限値)

setOrderListList

public void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。

パラメータ:
orderListList - 選択指図一覧

getOrderListList

public ArrayList getOrderListList()
選択指図一覧を取得します。

戻り値:
orderListList 選択指図一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Language (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス Language

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.Language
すべての実装インタフェース:
Serializable
public class Language
extends Object
implements Serializable

言語情報クラス 機能は以下の通り

  • 言語情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Language()
詳細情報を読み込みエラー情報を作成します。
メソッドの概要
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) ISO 639 準拠の言語を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Language

public Language()
詳細情報を読み込みエラー情報を作成します。

メソッドの詳細

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
strLangu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
strLanguIso ISO 639 準拠の言語

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
ISO 639 準拠の言語を設定します。

パラメータ:
strLanguIso - ISO 639 準拠の言語

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MasterData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス MasterData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.MasterData
すべての実装インタフェース:
Serializable
public class MasterData
extends Object
implements Serializable

指図のマスタデータ構造情報クラス 機能は以下の通り

  • 指図のマスタデータ構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MasterData()
指図のマスタデータ構造を作成します。
メソッドの概要
String | getApplicant() 申請者を取得します。
String | getApplicantPhone() 申請者の電話番号を取得します。
String | getApplicationDate() 申請日を取得します。
String | getBusArea() 事業領域を取得します。
String | getCctrPosted() 原価が実際に転記された原価センタを取得します。
String | getCoArea() 管理領域を取得します。
String | getCompCode() 会社コードを取得します。
String | getCstgSheet() 原価計算表を取得します。
String | getCurrency() 購買発注通貨を取得します。
String | getDateWorkBegins() 作業開始を取得します。
String | getDateWorkEnds() 作業終了を取得します。
String | getDepartment() 部署を取得します。
String | getEstimatedCosts() 指図の見積原価合計を取得します。
String | getExtOrdNo() 外部指図番号を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getInChargeUser() CO 内部指図の責任者を取得します。
String | getInterestProf() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getObjectNo() 対象番号を取得します。
String | getOrder() 指図番号を取得します。
String | getOrderName() テキストを取得します。
String | getOrderType() 販売伝票タイプを取得します。
String | getOverheadKey() 間接費キーを取得します。
String | getPersonResp() 責任者を取得します。
String | getPersonRespPhone() 責任者の電話番号を取得します。
String | getPlant() プラントを取得します。
String | getPlnClose() 計画終了日付を取得します。
String | getPlnCompletion() 計画完了日を取得します。
String | getPlnRelease() 計画リリース日付を取得します。
String | getProcessingGroup() 処理グループを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getRequCompCode() 会社コード要求を取得します。
String | getRequestCctr() 申請原価センタを取得します。
String | getRequestOrder() 申請指図を取得します。
String | getResAnalKey() 結果分析キーを取得します。
String | getRespcctr() 責任原価センタを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getWbsElem() 作業詳細項目要素 (WBS 要素)を取得します。
String | getWbsElementExt() WBS 要素を取得します。
String | getWorkPermit() 仕事許可済フラグを取得します。
void | setApplicant(String strApplicant) 申請者を設定します。
void | setApplicantPhone(String strApplicantPhone) 申請者の電話番号を設定します。
void | setApplicationDate(String strApplicationDate) 申請日を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCctrPosted(String strCctrPosted) 原価が実際に転記された原価センタを設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCstgSheet(String strCstgSheet) 原価計算表を設定します。
void | setCurrency(String strCurrency) 購買発注通貨を設定します。
void | setDateWorkBegins(String strDateWorkBegins) 作業開始を設定します。
void | setDateWorkEnds(String strDateWorkEnds) 作業終了を設定します。
void | setDepartment(String strDepartment) 部署を設定します。
void | setEstimatedCosts(String strEstimatedCosts) 指図の見積原価合計を設定します。
void | setExtOrdNo(String strExtOrdNo) 外部指図番号を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setInChargeUser(String strInChargeUser) CO 内部指図の責任者を設定します。
void | setInterestProf(String strInterestProf) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setObjectNo(String strObjectNo) 対象番号を設定します。
void | setOrder(String strOrder) 指図番号を設定します。
void | setOrderName(String strOrderName) テキストを設定します。
void | setOrderType(String strOrderType) 販売伝票タイプを設定します。
void | setOverheadKey(String strOverheadKey) 間接費キーを設定します。
void | setPersonResp(String strPersonResp) 責任者を設定します。
void | setPersonRespPhone(String strPersonRespPhone) 責任者の電話番号を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPlnClose(String strPlnClose) 計画終了日付を設定します。
void | setPlnCompletion(String strPlnCompletion) 計画完了日を設定します。
void | setPlnRelease(String strPlnRelease) 計画リリース日付を設定します。
void | setProcessingGroup(String strProcessingGroup) 処理グループを設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setRequCompCode(String strRequCompCode) 会社コード要求を設定します。
void | setRequestCctr(String strRequestCctr) 申請原価センタを設定します。
void | setRequestOrder(String strRequestOrder) 申請指図を設定します。
void | setResAnalKey(String strResAnalKey) 結果分析キーを設定します。
void | setRespcctr(String strRespcctr) 責任原価センタを設定します。
void | setSalesOrd(String strSalesOrd) 受注伝票番号を設定します。
void | setSOrdItem(String strSOrdItem) 受注明細番号を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setWbsElem(String strWbsElem) 作業詳細項目要素 (WBS 要素)を設定します。
void | setWbsElementExt(String strWbsElementExt) WBS 要素を設定します。
void | setWorkPermit(String strWorkPermit) 仕事許可済フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MasterData

public MasterData()
指図のマスタデータ構造を作成します。

メソッドの詳細

getOrder

public String getOrder()
指図番号を取得します。

戻り値:
srtOrder 指図番号

getOrderType

public String getOrderType()
販売伝票タイプを取得します。

戻り値:
srtOrderType 販売伝票タイプ

getOrderName

public String getOrderName()
テキストを取得します。

戻り値:
srtOrderName テキスト

getExtOrdNo

public String getExtOrdNo()
外部指図番号を取得します。

戻り値:
srtExtOrdNo 外部指図番号

getObjectNo

public String getObjectNo()
対象番号を取得します。

戻り値:
srtObjectNo 対象番号

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getRespcctr

public String getRespcctr()
責任原価センタを取得します。

戻り値:
srtRespcctr 責任原価センタ

getWbsElem

public String getWbsElem()
作業詳細項目要素 (WBS 要素)を取得します。

戻り値:
srtWbsElem 作業詳細項目要素 (WBS 要素)

getWbsElementExt

public String getWbsElementExt()
WBS 要素を取得します。

戻り値:
srtWbsElementExt WBS 要素

getRequestCctr

public String getRequestCctr()
申請原価センタを取得します。

戻り値:
srtRequestCctr 申請原価センタ

getRequCompCode

public String getRequCompCode()
会社コード要求を取得します。

戻り値:
srtRequCompCode 会社コード要求

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
srtSalesOrd 受注伝票番号

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
srtSOrdItem 受注明細番号

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getCctrPosted

public String getCctrPosted()
原価が実際に転記された原価センタを取得します。

戻り値:
srtCctrPosted 原価が実際に転記された原価センタ

getCurrency

public String getCurrency()
購買発注通貨を取得します。

戻り値:
srtCurrency 購買発注通貨

getCstgSheet

public String getCstgSheet()
原価計算表を取得します。

戻り値:
srtCstgSheet 原価計算表

getOverheadKey

public String getOverheadKey()
間接費キーを取得します。

戻り値:
srtOverheadKey 間接費キー

getResAnalKey

public String getResAnalKey()
結果分析キーを取得します。

戻り値:
srtResAnalKey 結果分析キー

getInterestProf

public String getInterestProf()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtInterestProf プロジェクト/指図金利計算の金利プロファイル

getApplicant

public String getApplicant()
申請者を取得します。

戻り値:
srtApplicant 申請者

getApplicantPhone

public String getApplicantPhone()
申請者の電話番号を取得します。

戻り値:
srtApplicantPhone 申請者の電話番号

getPersonResp

public String getPersonResp()
責任者を取得します。

戻り値:
srtPersonResp 責任者

getPersonRespPhone

public String getPersonRespPhone()
責任者の電話番号を取得します。

戻り値:
srtPersonRespPhone 責任者の電話番号

getEstimatedCosts

public String getEstimatedCosts()
指図の見積原価合計を取得します。

戻り値:
srtEstimatedCosts 指図の見積原価合計

getApplicationDate

public String getApplicationDate()
申請日を取得します。

戻り値:
srtApplicationDate 申請日

getDepartment

public String getDepartment()
部署を取得します。

戻り値:
srtDepartment 部署

getDateWorkBegins

public String getDateWorkBegins()
作業開始を取得します。

戻り値:
srtDateWorkBegins 作業開始

getDateWorkEnds

public String getDateWorkEnds()
作業終了を取得します。

戻り値:
srtDateWorkEnds 作業終了

getWorkPermit

public String getWorkPermit()
仕事許可済フラグを取得します。

戻り値:
srtWorkPermit 仕事許可済フラグ

getProcessingGroup

public String getProcessingGroup()
処理グループを取得します。

戻り値:
srtProcessingGroup 処理グループ

getPlnRelease

public String getPlnRelease()
計画リリース日付を取得します。

戻り値:
srtPlnRelease 計画リリース日付

getPlnCompletion

public String getPlnCompletion()
計画完了日を取得します。

戻り値:
srtPlnCompletion 計画完了日

getPlnClose

public String getPlnClose()
計画終了日付を取得します。

戻り値:
srtPlnClose 計画終了日付

getRequestOrder

public String getRequestOrder()
申請指図を取得します。

戻り値:
srtRequestOrder 申請指図

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getInChargeUser

public String getInChargeUser()
CO 内部指図の責任者を取得します。

戻り値:
srtOrder CO 内部指図の責任者

setOrder

public void setOrder(String strOrder)
指図番号を設定します。

パラメータ:
strOrder - 指図番号

setOrderType

public void setOrderType(String strOrderType)
販売伝票タイプを設定します。

パラメータ:
strOrderType - 販売伝票タイプ

setOrderName

public void setOrderName(String strOrderName)
テキストを設定します。

パラメータ:
strOrderName - テキスト

setExtOrdNo

public void setExtOrdNo(String strExtOrdNo)
外部指図番号を設定します。

パラメータ:
strExtOrdNo - 外部指図番号

setObjectNo

public void setObjectNo(String strObjectNo)
対象番号を設定します。

パラメータ:
strObjectNo - 対象番号

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setRespcctr

public void setRespcctr(String strRespcctr)
責任原価センタを設定します。

パラメータ:
strRespcctr - 責任原価センタ

setWbsElem

public void setWbsElem(String strWbsElem)
作業詳細項目要素 (WBS 要素)を設定します。

パラメータ:
strWbsElem - 作業詳細項目要素 (WBS 要素)

setWbsElementExt

public void setWbsElementExt(String strWbsElementExt)
WBS 要素を設定します。

パラメータ:
strWbsElementExt - WBS 要素

setRequestCctr

public void setRequestCctr(String strRequestCctr)
申請原価センタを設定します。

パラメータ:
strRequestCctr - 申請原価センタ

setRequCompCode

public void setRequCompCode(String strRequCompCode)
会社コード要求を設定します。

パラメータ:
strRequCompCode - 会社コード要求

setSalesOrd

public void setSalesOrd(String strSalesOrd)
受注伝票番号を設定します。

パラメータ:
strSalesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String strSOrdItem)
受注明細番号を設定します。

パラメータ:
strSOrdItem - 受注明細番号

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setCctrPosted

public void setCctrPosted(String strCctrPosted)
原価が実際に転記された原価センタを設定します。

パラメータ:
strCctrPosted - 原価が実際に転記された原価センタ

setCurrency

public void setCurrency(String strCurrency)
購買発注通貨を設定します。

パラメータ:
strCurrency - 購買発注通貨

setCstgSheet

public void setCstgSheet(String strCstgSheet)
原価計算表を設定します。

パラメータ:
strCstgSheet - 原価計算表

setOverheadKey

public void setOverheadKey(String strOverheadKey)
間接費キーを設定します。

パラメータ:
strOverheadKey - 間接費キー

setResAnalKey

public void setResAnalKey(String strResAnalKey)
結果分析キーを設定します。

パラメータ:
strResAnalKey - 結果分析キー

setInterestProf

public void setInterestProf(String strInterestProf)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strInterestProf - プロジェクト/指図金利計算の金利プロファイル

setApplicant

public void setApplicant(String strApplicant)
申請者を設定します。

パラメータ:
strApplicant - 申請者

setApplicantPhone

public void setApplicantPhone(String strApplicantPhone)
申請者の電話番号を設定します。

パラメータ:
strApplicantPhone - 申請者の電話番号

setPersonResp

public void setPersonResp(String strPersonResp)
責任者を設定します。

パラメータ:
strPersonResp - 責任者

setPersonRespPhone

public void setPersonRespPhone(String strPersonRespPhone)
責任者の電話番号を設定します。

パラメータ:
strPersonRespPhone - 責任者の電話番号

setEstimatedCosts

public void setEstimatedCosts(String strEstimatedCosts)
指図の見積原価合計を設定します。

パラメータ:
strEstimatedCosts - 指図の見積原価合計

setApplicationDate

public void setApplicationDate(String strApplicationDate)
申請日を設定します。

パラメータ:
strApplicationDate - 申請日

setDepartment

public void setDepartment(String strDepartment)
部署を設定します。

パラメータ:
strDepartment - 部署

setDateWorkBegins

public void setDateWorkBegins(String strDateWorkBegins)
作業開始を設定します。

パラメータ:
strDateWorkBegins - 作業開始

setDateWorkEnds

public void setDateWorkEnds(String strDateWorkEnds)
作業終了を設定します。

パラメータ:
strDateWorkEnds - 作業終了

setWorkPermit

public void setWorkPermit(String strWorkPermit)
仕事許可済フラグを設定します。

パラメータ:
strWorkPermit - 仕事許可済フラグ

setProcessingGroup

public void setProcessingGroup(String strProcessingGroup)
処理グループを設定します。

パラメータ:
strProcessingGroup - 処理グループ

setPlnRelease

public void setPlnRelease(String strPlnRelease)
計画リリース日付を設定します。

パラメータ:
strPlnRelease - 計画リリース日付

setPlnCompletion

public void setPlnCompletion(String strPlnCompletion)
計画完了日を設定します。

パラメータ:
strPlnCompletion - 計画完了日

setPlnClose

public void setPlnClose(String strPlnClose)
計画終了日付を設定します。

パラメータ:
strPlnClose - 計画終了日付

setRequestOrder

public void setRequestOrder(String strRequestOrder)
申請指図を設定します。

パラメータ:
strRequestOrder - 申請指図

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setInChargeUser

public void setInChargeUser(String strInChargeUser)
CO 内部指図の責任者を設定します。

パラメータ:
strInChargeUser - CO 内部指図の責任者

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OrderList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス OrderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.OrderList
すべての実装インタフェース:
Serializable
public class OrderList
extends Object
implements Serializable

選択指図一覧情報クラス 機能は以下の通り

  • 選択指図一覧情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
OrderList()
選択指図一覧を作成します。
メソッドの概要
String | getObjectNo() 対象番号を取得します。
String | getOrder() 指図番号を取得します。
String | getOrderName() テキストを取得します。
String | getOrderType() 販売伝票タイプを取得します。
void | setObjectNo(String strObjectNo) 対象番号を設定します。
void | setOrder(String strOrder) 指図番号を設定します。
void | setOrderName(String strOrderName) テキストを設定します。
void | setOrderType(String strOrderType) 販売伝票タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

OrderList

public OrderList()
選択指図一覧を作成します。

メソッドの詳細

getOrder

public String getOrder()
指図番号を取得します。

戻り値:
srtOrder 指図番号

getObjectNo

public String getObjectNo()
対象番号を取得します。

戻り値:
srtObjectNo 対象番号

getOrderType

public String getOrderType()
販売伝票タイプを取得します。

戻り値:
srtOrderType 販売伝票タイプ

getOrderName

public String getOrderName()
テキストを取得します。

戻り値:
srtOrderName テキスト

setOrder

public void setOrder(String strOrder)
指図番号を設定します。

パラメータ:
strOrder - 指図番号

setObjectNo

public void setObjectNo(String strObjectNo)
対象番号を設定します。

パラメータ:
strObjectNo - 対象番号

setOrderType

public void setOrderType(String strOrderType)
販売伝票タイプを設定します。

パラメータ:
strOrderType - 販売伝票タイプ

setOrderName

public void setOrderName(String strOrderName)
テキストを設定します。

パラメータ:
strOrderName - テキスト

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.financial (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.financial
クラス
AllowedBusTract
CommonCenterGrpGetDetail
CostCenterGroupGetDetail
CostCenterGroupGetDetailController
CreditorGetDetail
CreditorGetDetailController
DebtorGetDetail
DebtorGetDetailController
ExchangeRateGetDetail
ExchangeRateGetDetailController
ExchRate
ExpActivity
ExpMessage
ExpWbsElement
ExpWbsHierarchie
ExpWbsMilestone
HierarchyNodes
HierarchyValues
ImpWbsElement
InternalOrderGetDetail
InternalOrderGetDetailController
InternalOrderGetList
InternalOrderGetListController
Language
MasterData
OrderList
ProfitCenterGrpGetDetail
ProfitCenterGrpGetDetailController
ProjectDefinition
ProjectGetInfo
ProjectGetInfoController
SystemStatus
UserStatus


jp.co.intra_mart.foundation.sap.module.financial (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial

ＳＡＰ連携管理会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AllowedBusTract | 使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り 使用可能業務トランザクションのテーブル情報を保持します。
CommonCenterGrpGetDetail | 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
CostCenterGroupGetDetail | 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
CostCenterGroupGetDetailController | 原価センタグループコントローラクラス 機能は以下の通り 原価センタグループを取得します。
CreditorGetDetail | 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
CreditorGetDetailController | 仕入先詳細コントローラクラス 機能は以下の通り 仕入先詳細を取得します。
DebtorGetDetail | 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
DebtorGetDetailController | 得意先詳細コントローラクラス 機能は以下の通り 得意先詳細を取得します。
ExchangeRateGetDetail | 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
ExchangeRateGetDetailController | 為替換算レートコントローラクラス 機能は以下の通り 為替換算レートを取得します。
ExchRate | 換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り 換算レート、係数 (通貨ペア)情報を保持します。
ExpActivity | 活動に関する詳細情報クラス 機能は以下の通り 活動に関する詳細情報を保持します。
ExpMessage | 詳細情報を読み込みエラー情報クラス 機能は以下の通り 詳細情報を読み込みエラー情報を保持します。
ExpWbsElement | WBS 要素についての詳細情報クラス 機能は以下の通り WBS 要素についての詳細情報を保持します。
ExpWbsHierarchie | WBS 階層についての情報クラス 機能は以下の通り WBS 階層についての情報を保持します。
ExpWbsMilestone | WBS マイルストーンに関する詳細情報クラス 機能は以下の通り WBS マイルストーンに関する詳細情報を保持します。
HierarchyNodes | 階層ノード情報クラス 機能は以下の通り 階層ノード情報を保持します。
HierarchyValues | 階層値情報クラス 機能は以下の通り 階層値情報を保持します。
ImpWbsElement | 詳細情報を必要とする WBS 要素クラス 機能は以下の通り 詳細情報を必要とする WBS 要素を保持します。
InternalOrderGetDetail | 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
InternalOrderGetDetailController | 内部指図書詳細コントローラクラス 機能は以下の通り 内部指図書詳細を取得します。
InternalOrderGetList | 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
InternalOrderGetListController | 内部指図書一覧コントローラクラス 機能は以下の通り 内部指図書一覧を取得します。
Language | 言語情報クラス 機能は以下の通り 言語情報を保持します。
MasterData | 指図のマスタデータ構造情報クラス 機能は以下の通り 指図のマスタデータ構造情報を保持します。
OrderList | 選択指図一覧情報クラス 機能は以下の通り 選択指図一覧情報を保持します。
ProfitCenterGrpGetDetail | 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
ProfitCenterGrpGetDetailController | 利益センタグループコントローラクラス 機能は以下の通り 利益センタグループを取得します。
ProjectDefinition | プロジェクトについての詳細情報クラス 機能は以下の通り プロジェクトについての詳細情報を保持します。
ProjectGetInfo | WBS情報取得クラス 機能は以下の通り WBS情報を取得します。
ProjectGetInfoController | WBSの詳細コントローラクラス 機能は以下の通り WBSの詳細を取得します。
SystemStatus | システムステータステーブル情報クラス 機能は以下の通り システムステータステーブル情報を保持します。
UserStatus | ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り ユーザステータス/指図ステータステーブル情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.financial の説明

ＳＡＰ連携管理会計系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.financial クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchRate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.Language (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.MasterData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.OrderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.UserStatus (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.financial の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.financial の使用

jp.co.intra_mart.foundation.sap.module.financial を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module.financial のクラス
CommonCenterGrpGetDetail
原価・利益センタグループ情報取得共通クラス
機能は以下の通り
原価・利益センタグループ情報を取得します。
CreditorGetDetail
仕入先詳細情報取得クラス
機能は以下の通り
仕入先詳細情報を取得します。
DebtorGetDetail
得意先詳細情報取得クラス
機能は以下の通り
得意先詳細情報を取得します。
ExchRate
換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り
換算レート、係数 (通貨ペア)情報を保持します。
Language
言語情報クラス 機能は以下の通り
言語情報を保持します。
MasterData
指図のマスタデータ構造情報クラス 機能は以下の通り
指図のマスタデータ構造情報を保持します。
ProjectDefinition
プロジェクトについての詳細情報クラス 機能は以下の通り
プロジェクトについての詳細情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProfitCenterGrpGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProfitCenterGrpGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
                拡張 jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail
すべての実装インタフェース:
Serializable
public class ProfitCenterGrpGetDetail
extends CommonCenterGrpGetDetail
implements Serializable

利益センタグループ情報取得クラス
機能は以下の通り

  • 利益センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail から継承したメソッド
getControllingarea, getGroupname, getHierarchyNodesList, getHierarchyValuesList, getLanguage, setControllingarea, setExportParam, setGroupname, setHierarchyNodesList, setHierarchyValuesList, setImportParam, setLanguage, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterGrpGetDetail

public ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト

ProfitCenterGrpGetDetail

public ProfitCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより利益センタグループ検索を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterGrpGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProfitCenterGrpGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController
すべての実装インタフェース:
Serializable
public class ProfitCenterGrpGetDetailController
extends Object
implements Serializable

利益センタグループコントローラクラス
機能は以下の通り

  • 利益センタグループを取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterGrpGetDetailController()
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 String getControllingarea()
管理領域を取得します。
 String getGroupname()
グループ名を取得します。
 ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。
 ArrayList getHierarchyValuesList()
階層値一覧を取得します。
 void setControllingarea(String strControllingarea)
管理領域を設定します。
 void setGroupname(String strGroupname)
グループ名を設定します。
 void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。
 void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(String controllingarea,
                                          String groupname)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(String controllingarea,
                                          String groupname,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController()
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectDefinition (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectDefinition

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition
すべての実装インタフェース:
Serializable
public class ProjectDefinition
extends Object
implements Serializable

プロジェクトについての詳細情報クラス 機能は以下の通り

  • プロジェクトについての詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProjectDefinition()
プロジェクトについての詳細情報を作成します。
メソッドの概要
String | getApplicantNo() 申請者番号を取得します。
String | getBudgetProfile() 予算プロファイルを取得します。
String | getBusArea() 事業領域を取得します。
String | getCalendar() 稼動日カレンダを取得します。
String | getCompCode() 会社コードを取得します。
String | getControllingArea() 管理領域を取得します。
String | getCshBdgtProfile() 資金計画プロファイルを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() PS: テキスト(短)(第一テキスト行)を取得します。
String | getEquityType() 持分タイプを取得します。
String | getFinish() プロジェクトの計画終了日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getIntProfile() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getJointVenture() ジョイントベンチャを取得します。
String | getJvJibClass() JIB/JIBE クラスを取得します。
String | getJvJibSubClassA() JIB/JIBE サブクラスAを取得します。
String | getJvObjectType() ジョイントベンチャ対象タイプを取得します。
String | getMaskId() WBS 要素 ID(短)の選択マスクを取得します。
String | getNetworkAssignment() ネットワーク割当を取得します。
String | getNetworkProfile() ネットワークプロファイルを取得します。
String | getObjectclass() 対象クラスを取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getPlanBasic() プロジェクト基準日付計画方法を取得します。
String | getPlanFcst() プロジェクト予測日付の計画方法を取得します。
String | getPlanProfile() 計画プロファイルを取得します。
String | getPlant() プラントを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectCurrency() WBS 通貨(プロジェクト定義)を取得します。
String | getProjectCurrencyIso() ISO 通貨コードを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjectProfile() プロジェクトプロファイルを取得します。
String | getProjectStock() プロジェクト在庫を取得します。
String | getRecoveryInd() リカバリフラグを取得します。
String | getResponsibleNo() 責任者番号 (プロジェクト責任者)を取得します。
String | getStart() プロジェクト計画開始日付を取得します。
String | getStatistical() 統計 WBS 要素を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTimeUnit() 時間計画単位を取得します。
String | getTimeUnitIso() 単位の ISO コードを取得します。
String | getWbsSchedProfile() WBS 日程計画のプロファイルを取得します。
void | setApplicantNo(String strApplicantNo) 申請者番号を設定します。
void | setBudgetProfile(String strBudgetProfile) 予算プロファイルを設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCalendar(String strCalendar) 稼動日カレンダを設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setControllingArea(String strControllingArea) 管理領域を設定します。
void | setCshBdgtProfile(String strCshBdgtProfile) 資金計画プロファイルを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) PS: テキスト(短)(第一テキスト行)を設定します。
void | setEquityType(String strEquityType) 持分タイプを設定します。
void | setFinish(String strFinish) プロジェクトの計画終了日を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setIntProfile(String strIntProfile) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setJointVenture(String strJointVenture) ジョイントベンチャを設定します。
void | setJvJibClass(String strJvJibClass) JIB/JIBE クラスを設定します。
void | setJvJibSubClassA(String strJvJibSubClassA) JIB/JIBE サブクラスAを設定します。
void | setJvObjectType(String strJvObjectType) ジョイントベンチャ対象タイプを設定します。
void | setMaskId(String strMaskId) WBS 要素 ID(短)の選択マスクを設定します。
void | setNetworkAssignment(String strNetworkAssignment) ネットワーク割当を設定します。
void | setNetworkProfile(String strNetworkProfile) ネットワークプロファイルを設定します。
void | setObjectclass(String strObjectclass) 対象クラスを設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setPlanBasic(String strPlanBasic) プロジェクト基準日付計画方法を設定します。
void | setPlanFcst(String strPlanFcst) プロジェクト予測日付の計画方法を設定します。
void | setPlanProfile(String strPlanProfile) 計画プロファイルを設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectCurrency(String strProjectCurrency) WBS 通貨(プロジェクト定義)を設定します。
void | setProjectCurrencyIso(String strProjectCurrencyIso) ISO 通貨コードを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjectProfile(String strProjectProfile) プロジェクトプロファイルを設定します。
void | setProjectStock(String strProjectStock) プロジェクト在庫を設定します。
void | setRecoveryInd(String strRecoveryInd) リカバリフラグを設定します。
void | setResponsibleNo(String strResponsibleNo) 責任者番号 (プロジェクト責任者)を設定します。
void | setStart(String strStart) プロジェクト計画開始日付を設定します。
void | setStatistical(String strStatistical) 統計 WBS 要素を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTimeUnit(String strTimeUnit) 時間計画単位を設定します。
void | setTimeUnitIso(String strTimeUnitIso) 単位の ISO コードを設定します。
void | setWbsSchedProfile(String strWbsSchedProfile) WBS 日程計画のプロファイルを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProjectDefinition

public ProjectDefinition()
プロジェクトについての詳細情報を作成します。

メソッドの詳細

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getDescription

public String getDescription()
PS: テキスト(短)(第一テキスト行)を取得します。

戻り値:
srtDescription PS: テキスト(短)(第一テキスト行)

getMaskId

public String getMaskId()
WBS 要素 ID(短)の選択マスクを取得します。

戻り値:
srtMaskId WBS 要素 ID(短)の選択マスク

getResponsibleNo

public String getResponsibleNo()
責任者番号 (プロジェクト責任者)を取得します。

戻り値:
srtResponsibleNo 責任者番号 (プロジェクト責任者)

getApplicantNo

public String getApplicantNo()
申請者番号を取得します。

戻り値:
srtApplicantNo 申請者番号

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getProjectCurrency

public String getProjectCurrency()
WBS 通貨(プロジェクト定義)を取得します。

戻り値:
srtProjectCurrency WBS 通貨(プロジェクト定義)

getProjectCurrencyIso

public String getProjectCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtProjectCurrencyIso ISO 通貨コード

getNetworkAssignment

public String getNetworkAssignment()
ネットワーク割当を取得します。

戻り値:
srtNetworkAssignment ネットワーク割当

getStart

public String getStart()
プロジェクト計画開始日付を取得します。

戻り値:
srtStart プロジェクト計画開始日付

getFinish

public String getFinish()
プロジェクトの計画終了日を取得します。

戻り値:
srtFinish プロジェクトの計画終了日

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getCalendar

public String getCalendar()
稼動日カレンダを取得します。

戻り値:
srtCalendar 稼動日カレンダ

getPlanBasic

public String getPlanBasic()
プロジェクト基準日付計画方法を取得します。

戻り値:
srtPlanBasic プロジェクト基準日付計画方法

getPlanFcst

public String getPlanFcst()
プロジェクト予測日付の計画方法を取得します。

戻り値:
srtPlanFcst プロジェクト予測日付の計画方法

getTimeUnit

public String getTimeUnit()
時間計画単位を取得します。

戻り値:
srtTimeUnit 時間計画単位

getTimeUnitIso

public String getTimeUnitIso()
単位の ISO コードを取得します。

戻り値:
srtTimeUnitIso 単位の ISO コード

getNetworkProfile

public String getNetworkProfile()
ネットワークプロファイルを取得します。

戻り値:
srtNetworkProfile ネットワークプロファイル

getProjectProfile

public String getProjectProfile()
プロジェクトプロファイルを取得します。

戻り値:
srtProjectProfile プロジェクトプロファイル

getBudgetProfile

public String getBudgetProfile()
予算プロファイルを取得します。

戻り値:
srtBudgetProfile 予算プロファイル

getProjectStock

public String getProjectStock()
プロジェクト在庫を取得します。

戻り値:
srtProjectStock プロジェクト在庫

getObjectclass

public String getObjectclass()
対象クラスを取得します。

戻り値:
srtObjectclass 対象クラス

getStatistical

public String getStatistical()
統計 WBS 要素を取得します。

戻り値:
srtStatistical 統計 WBS 要素

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getIntProfile

public String getIntProfile()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtIntProfile プロジェクト/指図金利計算の金利プロファイル

getWbsSchedProfile

public String getWbsSchedProfile()
WBS 日程計画のプロファイルを取得します。

戻り値:
srtWbsSchedProfile WBS 日程計画のプロファイル

getCshBdgtProfile

public String getCshBdgtProfile()
資金計画プロファイルを取得します。

戻り値:
srtCshBdgtProfile 資金計画プロファイル

getPlanProfile

public String getPlanProfile()
計画プロファイルを取得します。

戻り値:
srtPlanProfile 計画プロファイル

getJointVenture

public String getJointVenture()
ジョイントベンチャを取得します。

戻り値:
srtJointVenture ジョイントベンチャ

getRecoveryInd

public String getRecoveryInd()
リカバリフラグを取得します。

戻り値:
srtRecoveryInd リカバリフラグ

getEquityType

public String getEquityType()
持分タイプを取得します。

戻り値:
srtEquityType 持分タイプ

getJvObjectType

public String getJvObjectType()
ジョイントベンチャ対象タイプを取得します。

戻り値:
srtJvObjectType ジョイントベンチャ対象タイプ

getJvJibClass

public String getJvJibClass()
JIB/JIBE クラスを取得します。

戻り値:
srtJvJibClass JIB/JIBE クラス

getJvJibSubClassA

public String getJvJibSubClassA()
JIB/JIBE サブクラスAを取得します。

戻り値:
srtJvJibSubClassA JIB/JIBE サブクラスA

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setDescription

public void setDescription(String strDescription)
PS: テキスト(短)(第一テキスト行)を設定します。

パラメータ:
strDescription - PS: テキスト(短)(第一テキスト行)

setMaskId

public void setMaskId(String strMaskId)
WBS 要素 ID(短)の選択マスクを設定します。

パラメータ:
strMaskId - WBS 要素 ID(短)の選択マスク

setResponsibleNo

public void setResponsibleNo(String strResponsibleNo)
責任者番号 (プロジェクト責任者)を設定します。

パラメータ:
strResponsibleNo - 責任者番号 (プロジェクト責任者)

setApplicantNo

public void setApplicantNo(String strApplicantNo)
申請者番号を設定します。

パラメータ:
strApplicantNo - 申請者番号

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setProjectCurrency

public void setProjectCurrency(String strProjectCurrency)
WBS 通貨(プロジェクト定義)を設定します。

パラメータ:
strProjectCurrency - WBS 通貨(プロジェクト定義)

setProjectCurrencyIso

public void setProjectCurrencyIso(String strProjectCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strProjectCurrencyIso - ISO 通貨コード

setNetworkAssignment

public void setNetworkAssignment(String strNetworkAssignment)
ネットワーク割当を設定します。

パラメータ:
strNetworkAssignment - ネットワーク割当

setStart

public void setStart(String strStart)
プロジェクト計画開始日付を設定します。

パラメータ:
strStart - プロジェクト計画開始日付

setFinish

public void setFinish(String strFinish)
プロジェクトの計画終了日を設定します。

パラメータ:
strFinish - プロジェクトの計画終了日

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setCalendar

public void setCalendar(String strCalendar)
稼動日カレンダを設定します。

パラメータ:
strCalendar - 稼動日カレンダ

setPlanBasic

public void setPlanBasic(String strPlanBasic)
プロジェクト基準日付計画方法を設定します。

パラメータ:
strPlanBasic - プロジェクト基準日付計画方法

setPlanFcst

public void setPlanFcst(String strPlanFcst)
プロジェクト予測日付の計画方法を設定します。

パラメータ:
strPlanFcst - プロジェクト予測日付の計画方法

setTimeUnit

public void setTimeUnit(String strTimeUnit)
時間計画単位を設定します。

パラメータ:
strTimeUnit - 時間計画単位

setTimeUnitIso

public void setTimeUnitIso(String strTimeUnitIso)
単位の ISO コードを設定します。

パラメータ:
strTimeUnitIso - 単位の ISO コード

setNetworkProfile

public void setNetworkProfile(String strNetworkProfile)
ネットワークプロファイルを設定します。

パラメータ:
strNetworkProfile - ネットワークプロファイル

setProjectProfile

public void setProjectProfile(String strProjectProfile)
プロジェクトプロファイルを設定します。

パラメータ:
strProjectProfile - プロジェクトプロファイル

setBudgetProfile

public void setBudgetProfile(String strBudgetProfile)
予算プロファイルを設定します。

パラメータ:
strBudgetProfile - 予算プロファイル

setProjectStock

public void setProjectStock(String strProjectStock)
プロジェクト在庫を設定します。

パラメータ:
strProjectStock - プロジェクト在庫

setObjectclass

public void setObjectclass(String strObjectclass)
対象クラスを設定します。

パラメータ:
strObjectclass - 対象クラス

setStatistical

public void setStatistical(String strStatistical)
統計 WBS 要素を設定します。

パラメータ:
strStatistical - 統計 WBS 要素

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setIntProfile

public void setIntProfile(String strIntProfile)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strIntProfile - プロジェクト/指図金利計算の金利プロファイル

setWbsSchedProfile

public void setWbsSchedProfile(String strWbsSchedProfile)
WBS 日程計画のプロファイルを設定します。

パラメータ:
strWbsSchedProfile - WBS 日程計画のプロファイル

setCshBdgtProfile

public void setCshBdgtProfile(String strCshBdgtProfile)
資金計画プロファイルを設定します。

パラメータ:
strCshBdgtProfile - 資金計画プロファイル

setPlanProfile

public void setPlanProfile(String strPlanProfile)
計画プロファイルを設定します。

パラメータ:
strPlanProfile - 計画プロファイル

setJointVenture

public void setJointVenture(String strJointVenture)
ジョイントベンチャを設定します。

パラメータ:
strJointVenture - ジョイントベンチャ

setRecoveryInd

public void setRecoveryInd(String strRecoveryInd)
リカバリフラグを設定します。

パラメータ:
strRecoveryInd - リカバリフラグ

setEquityType

public void setEquityType(String strEquityType)
持分タイプを設定します。

パラメータ:
strEquityType - 持分タイプ

setJvObjectType

public void setJvObjectType(String strJvObjectType)
ジョイントベンチャ対象タイプを設定します。

パラメータ:
strJvObjectType - ジョイントベンチャ対象タイプ

setJvJibClass

public void setJvJibClass(String strJvJibClass)
JIB/JIBE クラスを設定します。

パラメータ:
strJvJibClass - JIB/JIBE クラス

setJvJibSubClassA

public void setJvJibSubClassA(String strJvJibSubClassA)
JIB/JIBE サブクラスAを設定します。

パラメータ:
strJvJibSubClassA - JIB/JIBE サブクラスA

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectGetInfo (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectGetInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo
すべての実装インタフェース:
Serializable
public class ProjectGetInfo
extends ReferenceController
implements Serializable

WBS情報取得クラス
機能は以下の通り

  • WBS情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。
メソッドの概要
void | executeBapi() BapiControllerによりWBSの詳細情報の検索します。
ArrayList | getExpActivityList() 活動に関する詳細情報を取得します。
ArrayList | getExpMessageList() 詳細情報を読み込みエラーを取得します。
ArrayList | getExpWbsElementList() WBS 要素についての詳細情報を取得します。
ArrayList | getExpWbsHierarchieList() WBS 階層についての情報を取得します。
ArrayList | getExpWbsMilestoneList() WBS マイルストーンに関する詳細情報を取得します。
ArrayList | getImpWbsElementList() 詳細情報を必要とする WBS 要素を取得します。
String | getProjectDefinition() プロジェクト定義を識別するキーを取得します。
ProjectDefinition | getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。
String | getWithActivities() 従属活動を取得します。
String | getWithMilestones() 従属 WBS マイルストーンを取得します。
String | getWithSubtree() サブプロジェクトを取得します。
void | setExpActivityList(ArrayList expActivityList) 活動に関する詳細情報を設定します。
void | setExpMessageList(ArrayList expMessageList) 詳細情報を読み込みエラーを設定します。
void | setExportParam(BapiController bapiController) 登録された情報ををセットします。
void | setExpWbsElementList(ArrayList expWbsElementList) WBS 要素についての詳細情報を設定します。
void | setExpWbsHierarchieList(ArrayList expWbsHierarchieList) WBS 階層についての情報を設定します。
void | setExpWbsMilestoneList(ArrayList expWbsMilestoneList) WBS マイルストーンに関する詳細情報を設定します。
void | setImportParam(BapiController bapiController) WEBの詳細情報を検索する条件ををセットします。
void | setImpWbsElementList(ArrayList impWbsElementList) 詳細情報を必要とする WBS 要素を設定します。
void | setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を識別するキーを設定します。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setWithActivities(String strWithActivities) 従属活動を設定します。
void | setWithMilestones(String strWithMilestones) 従属 WBS マイルストーンを設定します。
void | setWithSubtree(String strWithSubtree) サブプロジェクトを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProjectGetInfo

public ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerによりWBSの詳細情報の検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPFinancialSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
WEBの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。

パラメータ:
strProjectDefinition - プロジェクト定義を識別するキー

setWithActivities

public void setWithActivities(String strWithActivities)
従属活動を設定します。

パラメータ:
strWithActivities - 従属活動がエクスポートされます

setWithMilestones

public void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。

パラメータ:
strWithMilestones - 従属 WBS マイルストーンがエクスポートされます

setWithSubtree

public void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。

パラメータ:
strWithSubtree - サブプロジェクトがエクスポートされます

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を識別するキーを取得します。

戻り値:
srtProjectDefinition プロジェクト定義を識別するキー

getWithActivities

public String getWithActivities()
従属活動を取得します。

戻り値:
srtWith_Activities 従属活動がエクスポートされます

getWithMilestones

public String getWithMilestones()
従属 WBS マイルストーンを取得します。

戻り値:
srtWithMilestones 従属 WBS マイルストーンがエクスポートされます

getWithSubtree

public String getWithSubtree()
サブプロジェクトを取得します。

戻り値:
srtWithSubtree サブプロジェクトがエクスポートされます

setProjectDefinition

public void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。

パラメータ:
projectDefinition - プロジェクトについての詳細情報

setImpWbsElementList

public void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。

パラメータ:
impWbsElementList - 詳細情報を必要とする WBS 要素

setExpWbsElementList

public void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。

パラメータ:
expWbsElementList - WBS 要素についての詳細情報

setExpWbsMilestoneList

public void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。

パラメータ:
expWbsMilestoneList - WBS マイルストーンに関する詳細情報

setExpWbsHierarchieList

public void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。

パラメータ:
expWbsHierarchieList - WBS 階層についての情報

setExpActivityList

public void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。

パラメータ:
expActivityList - 活動に関する詳細情報

setExpMessageList

public void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。

パラメータ:
expMessageList - 詳細情報を読み込みエラー

getProjectDefinitionInfo

public ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。

戻り値:
projectDefinition プロジェクトについての詳細情報

getImpWbsElementList

public ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。

戻り値:
impWbsElementList 詳細情報を必要とする WBS 要素

getExpWbsElementList

public ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。

戻り値:
expWbsElementList WBS 要素についての詳細情報

getExpWbsMilestoneList

public ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。

戻り値:
expWbsMilestoneList WBS マイルストーンに関する詳細情報

getExpWbsHierarchieList

public ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。

戻り値:
expWbsHierarchieList WBS 階層についての情報

getExpActivityList

public ArrayList getExpActivityList()
活動に関する詳細情報を取得します。

戻り値:
expActivityList 活動に関する詳細情報

getExpMessageList

public ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。

戻り値:
expMessageList 詳細情報を読み込みエラー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectGetInfoController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectGetInfoController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController
すべての実装インタフェース:
Serializable
public class ProjectGetInfoController
extends Object
implements Serializable

WBSの詳細コントローラクラス
機能は以下の通り

  • WBSの詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProjectGetInfoController()
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 ArrayList getExpActivityList()
活動に関する詳細情報を取得します。
 ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。
 ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。
 ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。
 ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。
 ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。
 String getProjectDefinition()
プロジェクト定義を識別するキーを取得します。
 ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。
 String getWithActivities()
従属活動を取得します。
 String getWithMilestones()
従属 WBS マイルストーンを取得します。
 String getWithSubtree()
サブプロジェクトを取得します。
 void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。
 void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。
 void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。
 void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。
 void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。
 void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。
 void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。
 void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void setWithActivities(String strWithActivities)
従属活動を設定します。
 void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。
 void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ProjectGetInfoController

public ProjectGetInfoController()
ProjectGetInfoControllerのコンストラクタを生成します。

ProjectGetInfoController

public ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPFinancialSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPFinancialSystemException - 会計業務システム例外

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。

パラメータ:
strProjectDefinition - プロジェクト定義を識別するキー

setWithActivities

public void setWithActivities(String strWithActivities)
従属活動を設定します。

パラメータ:
strWithActivities - 従属活動がエクスポートされます

setWithMilestones

public void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。

パラメータ:
strWithMilestones - 従属 WBS マイルストーンがエクスポートされます

setWithSubtree

public void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。

パラメータ:
strWithSubtree - サブプロジェクトがエクスポートされます

getProjectDefinition

public String getProjectDefinition()
                            throws SAPFinancialSystemException
プロジェクト定義を識別するキーを取得します。

戻り値:
srtProjectDefinition プロジェクト定義を識別するキー
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithActivities

public String getWithActivities()
                         throws SAPFinancialSystemException
従属活動を取得します。

戻り値:
srtWith_Activities 従属活動がエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithMilestones

public String getWithMilestones()
                         throws SAPFinancialSystemException
従属 WBS マイルストーンを取得します。

戻り値:
srtWithMilestones 従属 WBS マイルストーンがエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithSubtree

public String getWithSubtree()
                      throws SAPFinancialSystemException
サブプロジェクトを取得します。

戻り値:
srtWithSubtree サブプロジェクトがエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

setProjectDefinition

public void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。

パラメータ:
projectDefinition - プロジェクトについての詳細情報

setImpWbsElementList

public void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。

パラメータ:
impWbsElementList - 詳細情報を必要とする WBS 要素

setExpWbsElementList

public void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。

パラメータ:
expWbsElementList - WBS 要素についての詳細情報

setExpWbsMilestoneList

public void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。

パラメータ:
expWbsMilestoneList - WBS マイルストーンに関する詳細情報

setExpWbsHierarchieList

public void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。

パラメータ:
expWbsHierarchieList - WBS 階層についての情報

setExpActivityList

public void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。

パラメータ:
expActivityList - 活動に関する詳細情報

setExpMessageList

public void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。

パラメータ:
expMessageList - 詳細情報を読み込みエラー

getProjectDefinitionInfo

public ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。

戻り値:
projectDefinition プロジェクトについての詳細情報

getImpWbsElementList

public ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。

戻り値:
impWbsElementList 詳細情報を必要とする WBS 要素

getExpWbsElementList

public ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。

戻り値:
expWbsElementList WBS 要素についての詳細情報

getExpWbsMilestoneList

public ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。

戻り値:
expWbsMilestoneList WBS マイルストーンに関する詳細情報

getExpWbsHierarchieList

public ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。

戻り値:
expWbsHierarchieList WBS 階層についての情報

getExpActivityList

public ArrayList getExpActivityList()
活動に関する詳細情報を取得します。

戻り値:
expActivityList 活動に関する詳細情報

getExpMessageList

public ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。

戻り値:
expMessageList 詳細情報を読み込みエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemStatus (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス SystemStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.SystemStatus
すべての実装インタフェース:
Serializable
public class SystemStatus
extends Object
implements Serializable

システムステータステーブル情報クラス 機能は以下の通り

  • システムステータステーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SystemStatus()
システムステータステーブルを作成します。
メソッドの概要
String | getSysStatus() システムステータスを取得します。
String | getSyStDscr() オブジェクトステータスを取得します。
String | getSyStText() オブジェクトの個別ステータス (簡略形式)を取得します。
void | setSysStatus(String strSysStatus) システムステータスを設定します。
void | setSyStDscr(String strSyStDscr) オブジェクトステータスを設定します。
void | setSyStText(String strSyStText) オブジェクトの個別ステータス (簡略形式)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemStatus

public SystemStatus()
システムステータステーブルを作成します。

メソッドの詳細

getSysStatus

public String getSysStatus()
システムステータスを取得します。

戻り値:
srtSysStatus システムステータス

getSyStText

public String getSyStText()
オブジェクトの個別ステータス (簡略形式)を取得します。

戻り値:
srtSyStText オブジェクトの個別ステータス (簡略形式)

getSyStDscr

public String getSyStDscr()
オブジェクトステータスを取得します。

戻り値:
srtSyStDscr オブジェクトステータス

setSysStatus

public void setSysStatus(String strSysStatus)
システムステータスを設定します。

パラメータ:
strSysStatus - システムステータス

setSyStText

public void setSyStText(String strSyStText)
オブジェクトの個別ステータス (簡略形式)を設定します。

パラメータ:
strSyStText - オブジェクトの個別ステータス (簡略形式)

setSyStDscr

public void setSyStDscr(String strSyStDscr)
オブジェクトステータスを設定します。

パラメータ:
strSyStDscr - オブジェクトステータス

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserStatus (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス UserStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.UserStatus
すべての実装インタフェース:
Serializable
public class UserStatus
extends Object
implements Serializable

ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り

  • ユーザステータス/指図ステータステーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UserStatus()
ユーザステータス/指図ステータステーブルを作成します。
メソッドの概要
String | getStatProf() ステータスプロファイルを取得します。
String | getUsrStatus() ユーザステータスを取得します。
String | getUsStDscr() オブジェクトステータスを取得します。
String | getUsStNumb() ステータス番号を取得します。
String | getUsStText() オブジェクトの個別ステータス (簡略形式)を取得します。
void | setStatProf(String strStatProf) ステータスプロファイルを設定します。
void | setUsrStatus(String strUsrStatus) ユーザステータスを設定します。
void | setUsStDscr(String strUsStDscr) オブジェクトステータスを設定します。
void | setUsStNumb(String strUsStNumb) ステータス番号を設定します。
void | setUsStText(String strUsStText) オブジェクトの個別ステータス (簡略形式)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserStatus

public UserStatus()
ユーザステータス/指図ステータステーブルを作成します。

メソッドの詳細

getStatProf

public String getStatProf()
ステータスプロファイルを取得します。

戻り値:
srtStatProf ステータスプロファイル

getUsrStatus

public String getUsrStatus()
ユーザステータスを取得します。

戻り値:
srtUsrStatus ユーザステータス

getUsStNumb

public String getUsStNumb()
ステータス番号を取得します。

戻り値:
srtUsStNumb ステータス番号

getUsStText

public String getUsStText()
オブジェクトの個別ステータス (簡略形式)を取得します。

戻り値:
srtUsStText オブジェクトの個別ステータス (簡略形式)

getUsStDscr

public String getUsStDscr()
オブジェクトステータスを取得します。

戻り値:
srtUsStDscr オブジェクトステータス

setStatProf

public void setStatProf(String strStatProf)
ステータスプロファイルを設定します。

パラメータ:
strStatProf - ステータスプロファイル

setUsrStatus

public void setUsrStatus(String strUsrStatus)
ユーザステータスを設定します。

パラメータ:
strUsrStatus - ユーザステータス

setUsStNumb

public void setUsStNumb(String strUsStNumb)
ステータス番号を設定します。

パラメータ:
strUsStNumb - ステータス番号

setUsStText

public void setUsStText(String strUsStText)
オブジェクトの個別ステータス (簡略形式)を設定します。

パラメータ:
strUsStText - オブジェクトの個別ステータス (簡略形式)

setUsStDscr

public void setUsStDscr(String strUsStDscr)
オブジェクトステータスを設定します。

パラメータ:
strUsStDscr - オブジェクトステータス

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.AllVersions の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.AllVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.AllVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Cond の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Cond の使用

jp.co.intra_mart.foundation.sap.module.purchase.Cond はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractService の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractService の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractService はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader の使用

ExportHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExportHeader の使用

ExportHeader を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExportHeader PurchaseOrderPayPost.getExportHeader()
貿易管理ヘッダを取得します｡

ExportHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setExportHeader(ExportHeader exportHeader) 貿易管理ヘッダを設定します｡
static void | ParamExportHeader.setImportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
static void | ParamExportHeader.setExportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ExportItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ExportItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Extension の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Extension の使用

jp.co.intra_mart.foundation.sap.module.purchase.Extension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController の使用

jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Limits の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Limits の使用

jp.co.intra_mart.foundation.sap.module.purchase.Limits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb の使用

jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList の使用

MaterialGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetList の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetList のサブクラス
 class MaterialGetListController
品目コード検索コントローラクラス
機能は以下の通り
品目コード、テキストを検索します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MatnrList の使用

jp.co.intra_mart.foundation.sap.module.purchase.MatnrList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Partner の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Partner の使用

jp.co.intra_mart.foundation.sap.module.purchase.Partner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment の使用

jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel の使用

PurchaseGetItemSrel を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseGetItemSrel の使用

PurchaseGetItemSrel を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PurchaseGetItemSrel PurchaseGetItemSrelController.getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader の使用

PurchaseHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeader のサブクラス
class | PurchaseHeaderPost 購買発注伝票ヘッダ情報クラス 機能は以下の通り 購買発注伝票ヘッダの情報を保持します。
class | PurchaseHeaders 伝票の承認対象一覧ヘッダ情報クラス 機能は以下の通り 伝票の承認対象一覧ヘッダの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost の使用

PurchaseHeaderPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeaderPost の使用

PurchaseHeaderPost を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PurchaseHeaderPost PurchaseOrderPayPost.getDocumentHeader()
伝票ヘッダを取得します｡

PurchaseHeaderPost 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setDocumentHeader(PurchaseHeaderPost documentHeader) 伝票ヘッダを設定します｡
static void | ParamHeader.setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
static void | ParamHeader.setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem の使用

PurchaseItem を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseItem の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseItem のサブクラス
class | PurchaseItemPost 購買発注伝票明細情報クラス 機能は以下の通り 購買発注伝票明細情報を保持します。
class | PurchaseItems 伝票の承認対象明細情報クラス 機能は以下の通り 伝票の承認対象明細情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost の使用

PurchaseOrderPayPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseOrderPayPost の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseOrderPayPost のサブクラス
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease の使用

PurchaseRelease を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseRelease の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseRelease のサブクラス
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText の使用

PurchaseText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseText の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseText のサブクラス
 class ContractServiceText
外注サービステキスト情報クラス
機能は以下の通り
外注サービステキスト情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Selection の使用

Selection を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での Selection の使用

jp.co.intra_mart.foundation.sap.module.purchase での Selection のサブクラス
class | DistributionChannelSelection 流通チャネルの選択オプションクラス 機能は以下の通り 流通チャネルの選択オプションの情報を保持します。
class | MaterialShortDescsel 品目テキストの選択オプションクラス 機能は以下の通り 品目テキストの選択オプションの情報を保持します。
class | MatnrSelection 品目コードの選択オプションクラス 機能は以下の通り 品目コードの選択オプションの情報を保持します。
class | PlantSelection プラントの選択オプションクラス 機能は以下の通り プラントの選択オプションの情報を保持します。
class | SalesOrganisationSelection 販売組織の選択オプションクラス 機能は以下の通り 販売組織の選択オプションの情報を保持します。
class | StorageLocationSelect 保管場所の選択オプションクラス 機能は以下の通り 保管場所の選択オプションの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController の使用

jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect の使用

jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail の使用

SupplierDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SupplierDetail の使用

SupplierDetail を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SupplierDetail SupplierGetDetailController.getSupplierDetail()
仕入先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck の使用

SupplierExistenceCheck を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SupplierExistenceCheck の使用

SupplierExistenceCheck を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SupplierExistenceCheck SupplierExistenceCheckController.getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の使用

jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress の使用

VendorAddress を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での VendorAddress の使用

VendorAddress を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 VendorAddress PurchaseOrderPayPost.getSupplierInfo()
仕入先住所を取得します｡

VendorAddress 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseOrderPayPost.setSupplierInfo(VendorAddress supplierInfo)
仕入先住所を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Versions の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Versions の使用

Versions を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での Versions の使用

Versions を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 Versions PurchaseOrderPayPost.getVersions()
バージョン管理を取得します｡

Versions 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setVersions(Versions versions) バージョン管理ヘッダを設定します｡
static void | ParamVersions.setImportParam(BapiController bapiController, Versions versions) バージョン管理に値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData の使用

ClientData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ClientData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ClientData のサブクラス
 class ClientDataList
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ClientData の使用

ClientData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ClientData MaterialGetAll.getClientData()
品目データ (クライアントレベル)を取得します。

ClientData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setClientData(ClientData clientData)
品目データ (クライアントレベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList の使用

ClientDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ClientDataList の使用

ClientDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ClientDataList MaterialSaveReplicaController.getClientDataList(int index)
品目データ (クライアントレベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters の使用

ForecastParameters を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ForecastParameters の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ForecastParameters のサブクラス
 class ForecastParametersList
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ForecastParameters の使用

ForecastParameters を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ForecastParameters MaterialGetAll.getForecastParameters()
予測パラメータを取得します。

ForecastParameters 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setForecastParameters(ForecastParameters forecastParameters)
予測パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList の使用

ForecastParametersList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ForecastParametersList の使用

ForecastParametersList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ForecastParametersList MaterialSaveReplicaController.getForecastParametersList(int index)
需要予測パラメータが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader の使用

GoodsMvtHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.common.model での GoodsMvtHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での GoodsMvtHeader のサブクラス
 class GoodsMvtHeaderList
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。

GoodsMvtHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void ParamGoodsMvtHeader.setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtHeader の使用

GoodsMvtHeader を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtHeader GoodsMvtCreate.getGoodsMvtHeader()
入出庫伝票ヘッダデータを取得します。

GoodsMvtHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 void GoodsMvtCreate.setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription の使用

MaterialDescription を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialDescription の使用

MaterialDescription を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
MaterialDescription | MaterialSaveReplicaController.getMaterialDescription(int index) 品目テキストが既に存在するかチェックします。
MaterialDescription | MaterialGetAllController.getMaterialDescription(int index) 品目テキストオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg の使用

MaterialEvg を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での MaterialEvg の使用

MaterialEvg 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void ParamMaterialEvg.setImportParam(BapiController bapiController, MaterialEvg materialEvg)
品目コード(長)をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での MaterialEvg の使用

MaterialEvg を返す jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のメソッド
 MaterialEvg MaterialAvailability.getMaterialEvg()
品目コード(長)を取得します。

MaterialEvg 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のメソッド
 void MaterialAvailability.setMaterialEvg(MaterialEvg materialEvg)
品目コード(長)を設定します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での MaterialEvg の使用

MaterialEvg を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 MaterialEvg MaterialGetAll.getMaterialEvg()
品目コード(長)を取得します。

MaterialEvg 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setMaterialEvg(MaterialEvg materialEvg)
品目コード(長)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData の使用

PlanningData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlanningData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlanningData のサブクラス
 class PlanningDataList
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での PlanningData の使用

PlanningData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 PlanningData MaterialGetAll.getPlanningData()
品目マスタ/製品グループの変更伝票構造を取得します。

PlanningData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setPlanningData(PlanningData planningData)
品目マスタ/製品グループの変更伝票構造を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList の使用

PlanningDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PlanningDataList の使用

PlanningDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PlanningDataList MaterialSaveReplicaController.getPlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData の使用

PlantData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlantData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlantData のサブクラス
 class PlantDataList
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での PlantData の使用

PlantData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 PlantData MaterialGetAll.getPlantData()
品目データ (プラントレベル)を取得します。

PlantData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setPlantData(PlantData plantData)
品目データ (プラントレベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList の使用

PlantDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PlantDataList の使用

PlantDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PlantDataList MaterialSaveReplicaController.getPlantDataList(int index)
品目データ (プラントレベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData の使用

SalesData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SalesData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SalesData のサブクラス
 class SalesDataList
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での SalesData の使用

SalesData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 SalesData MaterialGetAll.getSalesData()
販売データを取得します。

SalesData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setSalesData(SalesData salesData)
販売データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList の使用

SalesDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SalesDataList の使用

SalesDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SalesDataList MaterialSaveReplicaController.getSalesDataList(int index)
販売データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData の使用

StorageLocationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageLocationData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageLocationData のサブクラス
 class StorageLocationDataList
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での StorageLocationData の使用

StorageLocationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 StorageLocationData MaterialGetAll.getStorageLocationData()
品目データ (保管場所レベル)を取得します。

StorageLocationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setStorageLocationData(StorageLocationData storageLocationData)
品目データ (保管場所レベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList の使用

StorageLocationDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での StorageLocationDataList の使用

StorageLocationDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 StorageLocationDataList MaterialSaveReplicaController.getStorageLocationDataList(int index)
品目データ (保管場所レベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData の使用

StorageTypeData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageTypeData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageTypeData のサブクラス
 class StorageTypeDataList
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での StorageTypeData の使用

StorageTypeData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 StorageTypeData MaterialGetAll.getStorageTypeData()
保管域タイプデータを取得します。

StorageTypeData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setStorageTypeData(StorageTypeData storageTypeData)
保管域タイプデータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList の使用

StorageTypeDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での StorageTypeDataList の使用

StorageTypeDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 StorageTypeDataList MaterialSaveReplicaController.getStorageTypeDataList(int index)
保管域タイプデータが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications の使用

TaxClassifications を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での TaxClassifications の使用

TaxClassifications を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
TaxClassifications | MaterialSaveReplicaController.getTaxClassifications(int index) 制御デ－タが既に存在するかチェックします。
TaxClassifications | MaterialGetAllController.getTaxClassifications(int index) 制御デ－タオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure の使用

UnitSofmeasure を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での UnitSofmeasure の使用

UnitSofmeasure を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
UnitSofmeasure | MaterialSaveReplicaController.getUnitSofmeasure(int index) 数量単位が既に存在するかチェックします。
UnitSofmeasure | MaterialGetAllController.getUnitSofmeasure(int index) 数量単位オブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData の使用

ValuationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ValuationData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ValuationData のサブクラス
 class ValuationDataList
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ValuationData の使用

ValuationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ValuationData MaterialGetAll.getValuationData()
評価データを取得します。

ValuationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setValuationData(ValuationData valuationData)
評価データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList の使用

ValuationDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ValuationDataList の使用

ValuationDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ValuationDataList MaterialSaveReplicaController.getValuationDataList(int index)
評価データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData の使用

WarehouseNumberData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での WarehouseNumberData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での WarehouseNumberData のサブクラス
 class WarehouseNumberDataList
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での WarehouseNumberData の使用

WarehouseNumberData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 WarehouseNumberData MaterialGetAll.getWarehouseNumberData()
倉庫番号データを取得します。

WarehouseNumberData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setWarehouseNumberData(WarehouseNumberData warehouseNumberData)
倉庫番号データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList の使用

WarehouseNumberDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での WarehouseNumberDataList の使用

WarehouseNumberDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 WarehouseNumberDataList MaterialSaveReplicaController.getWarehouseNumberDataList(int index)
倉庫番号データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ClientData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ClientData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ClientDataList
public class ClientData
extends Object
implements Serializable

品目データ (クライアントレベル)情報クラス
機能は以下の通り

  • 品目データ (クライアントレベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ClientData()
品目データ (クライアントレベル)情報を作成します。
メソッドの概要
String | getAllowedWt() 許容梱包重量を取得します。
String | getAllwdVol() 許容梱包容積を取得します。
String | getAppdBRec() 区分: バッチ製造記録の承認必須を取得します。
String | getAuthoritygroup() 権限グループを取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBaseUomIso() ISO コードでの基本数量単位を取得します。
String | getBasicMatl() 主構成物質を取得します。
String | getBatchMgmt() ロット管理所要量区分を取得します。
String | getCadId() CAD 区分を取得します。
String | getCatprofile() カタログプロファイルを取得します。
String | getChangedBy() オブジェクトの変更者名を取得します。
String | getClosedBox() 完了した梱包材を取得します。
String | getCmRelevanceFlag() 構成管理関連を取得します。
String | getCompetitor() 競合会社を取得します。
String | getConfigured() 選定可能品目を取得します。
String | getConfMatl() プラント共通選定可能品目を取得します。
String | getConfMatlExternal() 項目 CONF_MATL の品目コード(長)を取得します。
String | getConfMatlGuid() 項目 CONF_MATL の外部GUIDを取得します。
String | getConfMatlVersion() 項目 CONF_MATL のバージョン番号を取得します。
String | getContainer() 容器条件を取得します。
String | getCoProduct() 区分: 連産品としても使用可能な品目を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCreatedOn() 登録日付を取得します。
String | getDelFlag() クライアントレベルでの品目削除フラグを取得します。
String | getDivision() 製品部門を取得します。
String | getDocChgNo() 文書変更番号 (文書管理システム外)を取得します。
String | getDocFormat() 文書のページ書式 (文書管理システムによらない)を取得します。
String | getDocType() 文書タイプ (文書管理システムによらない)を取得します。
String | getDocument() 文書番号 (文書管理システムによらない)を取得します。
String | getDocVers() 文書バージョン (文書管理システムによらない)を取得します。
String | getDsnOffice() 研究室/設計室を取得します。
String | getEnvtRlvt() 区分: 環境関連を取得します。
String | getExtmatlgrp() 外部品目グループを取得します。
String | getFillLevel() 最大レベル (容積別)を取得します。
String | getFunction() BAPI 機能を取得します。
String | getGdsRelevant() 区分:グローバルデータ同期関連を取得します。
String | getGtinVariant() グローバルトレード明細番号バリアントを取得します。
String | getHazMatNo() 危険物コードを取得します。
String | getHazMatNoExternal() 項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
String | getHazMatNoGuid() 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
String | getHazMatNoVersion() 項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
String | getHazmatprof() 危険物インジケータプロファイルを取得します。
String | getHighVisc() 区分: 高粘性を取得します。
String | getIndSector() 産業コードを取得します。
String | getInvMatNo() 会社固有 (内部) 在庫管理品目コードを取得します。
String | getInvMatNoExternal() 項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
String | getInvMatNoGuid() 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
String | getInvMatNoVersion() 項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
String | getItemCat() 一般明細カテゴリグループを取得します。
String | getLabelForm() ラベル書式を取得します。
String | getLabelType() ラベルタイプを取得します。
String | getLastChnge() 最終変更日付を取得します。
String | getLooseorliq() 区分: バルク/液体を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getManufProf() 製造者製品プロファイルを取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMatcmpllvl() 品目完了レベルを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード(長)を取得します。
String | getMaterialFixed() ロックされている品目を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMatGrpSm() 品目グループ: 梱包材を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatlType() 品目タイプを取得します。
String | getMatStatus() 品目更新完了ステータスを取得します。
String | getMfrNo() 製造者番号を取得します。
String | getMinremlife() 最低有効期間残を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNoSheets() 文書枚数 (文書管理システムによらない)を取得します。
String | getOldMatNo() 旧品目コードを取得します。
String | getPackVoUn() 容積単位 (許容梱包容積)を取得します。
String | getPackVoUnIso() ISO コードでの容積単位 (許容梱包容積)を取得します。
String | getPackWtUn() 重量単位 (許容梱包重量)を取得します。
String | getPackWtUnIso() ISO コードでの重量単位 (許容梱包重量)を取得します。
String | getPageformat() 製造メモのページ書式を取得します。
String | getPageNo() 文書ページ番号 (文書管理システムによらない)を取得します。
String | getParEff() 有効性パラメータへの値割当/変更番号よりも優先を取得します。
String | getPeriodIndExpirationDate() 有効期間期限日の期間区分を取得します。
String | getPlRefMat() 梱包方法が同じ品目の参照品目を取得します。
String | getPlRefMatExternal() 項目 PL_REF_MAT の品目コード(長)を取得します。
String | getPlRefMatGuid() 項目 PL_REF_MAT の外部GUIDを取得します。
String | getPlRefMatVersion() 項目 PL_REF_MAT のバージョン番号を取得します。
String | getPoUnit() 発注単位を取得します。
String | getPoUnitIso() ISO コードによる発注単位を取得します。
String | getProcRule() 調達規則を取得します。
String | getProdAlloc() 製品割当決定手順を取得します。
String | getProdCompositionOnPackaging() 区分: 梱包材にプリントされた生産構造を取得します。
String | getProdHier() 品目階層を取得します。
String | getProdMemo() 製造/検査メモを取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPrRefMatExternal() 項目 PR_REF_MAT の品目コード(長)を取得します。
String | getPrRefMatGuid() 項目 PR_REF_MAT の外部GUIDを取得します。
String | getPrRefMatVersion() 項目 PL_REF_MAT のバージョン番号を取得します。
String | getPurStatus() プラント共通品目ステータスを取得します。
String | getPurValkey() 購買許容値キーを取得します。
String | getPvalidfrom() プラント共通品目のステータス有効開始日付を取得します。
String | getQmProcmnt() 調達における品質管理有効を取得します。
String | getQtyGrGi() 数量: 印刷予定入出庫票数を取得します。
String | getQualDik() 無償納入による割引対象品目を取得します。
String | getRoundUpRuleExpirationDate() 有効期間期限日計算の丸め規則を取得します。
String | getSalStatus() 流通チェーン間品目ステータスを取得します。
String | getSeason() 季節カテゴリを取得します。
String | getSerializationLevel() シリアル番号の指定レベルを取得します。
String | getShelfLife() 総有効期間を取得します。
String | getShMatTyp() 梱包材タイプを取得します。
String | getSizeDim() サイズ/寸法を取得します。
String | getSledBbd() 有効期限を取得します。
String | getStackFact() 山積係数を取得します。
String | getStdDescr() 標準テキスト (ANSI、ISO など)を取得します。
String | getStorConds() 保管条件を取得します。
String | getStorPct() 残存有効期間割合 %を取得します。
String | getSupSource() 供給元を取得します。
String | getSvalidfrom() 流通チェーン間品目ステータスの有効開始日付を取得します。
String | getTempConds() 温度条件区分を取得します。
String | getTransGrp() 輸送グループを取得します。
String | getUnitOfWt() 重量単位を取得します。
String | getUnitOfWtIso() ISO コードでの重量単位を取得します。
String | getUomusage() 使用数量単位を取得します。
String | getVarOrdUn() 可変購買発注単位有効を取得します。
String | getVolTolLt() 荷役単位の容積超過許容量を取得します。
String | getWeOriginAcceptance() 仕入先構内での受領を取得します。
String | getWtTolLt() 荷役単位の重量超過許容量を取得します。
void | setAllowedWt(String allowedWt) 許容梱包重量を設定します。
void | setAllwdVol(String allwdVol) 許容梱包容積を設定します。
void | setAppdBRec(String appdBRec) 区分: バッチ製造記録の承認必須を設定します。
void | setAuthoritygroup(String authoritygroup) 権限グループを設定します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBaseUomIso(String baseUomIso) ISO コードでの基本数量単位を設定します。
void | setBasicMatl(String basicMatl) 主構成物質を設定します。
void | setBatchMgmt(String batchMgmt) ロット管理所要量区分を設定します。
void | setCadId(String cadId) CAD 区分を設定します。
void | setCatprofile(String catprofile) カタログプロファイルを設定します。
void | setChangedBy(String changedBy) オブジェクトの変更者名を設定します。
void | setClosedBox(String closedBox) 完了した梱包材を設定します。
void | setCmRelevanceFlag(String cmRelevanceFlag) 構成管理関連を設定します。
void | setCompetitor(String competitor) 競合会社を設定します。
void | setConfigured(String configured) 選定可能品目を設定します。
void | setConfMatl(String confMatl) プラント共通選定可能品目を設定します。
void | setConfMatlExternal(String confMatlExternal) 項目 CONF_MATL の品目コード(長)を設定します。
void | setConfMatlGuid(String confMatlGuid) 項目 CONF_MATL の外部GUIDを設定します。
void | setConfMatlVersion(String confMatlVersion) 項目 CONF_MATL のバージョン番号を設定します。
void | setContainer(String container) 容器条件を設定します。
void | setCoProduct(String coProduct) 区分: 連産品としても使用可能な品目を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCreatedOn(String createdOn) 登録日付を設定します。
void | setDelFlag(String delFlag) クライアントレベルでの品目削除フラグを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDocChgNo(String docChgNo) 文書変更番号 (文書管理システム外)を設定します。
void | setDocFormat(String docFormat) 文書のページ書式 (文書管理システムによらない)を設定します。
void | setDocType(String docType) 文書タイプ (文書管理システムによらない)を設定します。
void | setDocument(String document) 文書番号 (文書管理システムによらない)を設定します。
void | setDocVers(String docVers) 文書バージョン (文書管理システムによらない)を設定します。
void | setDsnOffice(String dsnOffice) 研究室/設計室を設定します。
void | setEnvtRlvt(String envtRlvt) 区分: 環境関連を設定します。
void | setExtmatlgrp(String extmatlgrp) 外部品目グループを設定します。
void | setFillLevel(String fillLevel) 最大レベル (容積別)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGdsRelevant(String gdsRelevant) 区分:グローバルデータ同期関連を設定します。
void | setGtinVariant(String gtinVariant) グローバルトレード明細番号バリアントを設定します。
void | setHazMatNo(String hazMatNo) 危険物コードを設定します。
void | setHazMatNoExternal(String hazMatNoExternal) 項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
void | setHazMatNoGuid(String hazMatNoGuid) 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
void | setHazMatNoVersion(String hazMatNoVersion) 項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
void | setHazmatprof(String hazmatprof) 危険物インジケータプロファイルを設定します。
void | setHighVisc(String highVisc) 区分: 高粘性を設定します。
void | setIndSector(String indSector) 産業コードを設定します。
void | setInvMatNo(String invMatNo) 会社固有 (内部) 在庫管理品目コードを設定します。
void | setInvMatNoExternal(String invMatNoExternal) 項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
void | setInvMatNoGuid(String invMatNoGuid) 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
void | setInvMatNoVersion(String invMatNoVersion) 項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
void | setItemCat(String itemCat) 一般明細カテゴリグループを設定します。
void | setLabelForm(String labelForm) ラベル書式を設定します。
void | setLabelType(String labelType) ラベルタイプを設定します。
void | setLastChnge(String lastChnge) 最終変更日付を設定します。
void | setLooseorliq(String looseorliq) 区分: バルク/液体を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setManufProf(String manufProf) 製造者製品プロファイルを設定します。
void | setManuMat(String manuMat) 製造者製品コードを設定します。
void | setMatcmpllvl(String matcmpllvl) 品目完了レベルを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード(長)を設定します。
void | setMaterialFixed(String materialFixed) ロックされている品目を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMatGrpSm(String matGrpSm) 品目グループ: 梱包材を設定します。
void | setMatlGroup(String matlGroup) 品目グループを設定します。
void | setMatlType(String matlType) 品目タイプを設定します。
void | setMatStatus(String matStatus) 品目更新完了ステータスを設定します。
void | setMfrNo(String mfrNo) 製造者番号を設定します。
void | setMinremlife(String minremlife) 最低有効期間残を設定します。
void | setNetWeight(String netWeight) 正味重量を設定します。
void | setNoSheets(String noSheets) 文書枚数 (文書管理システムによらない)を設定します。
void | setOldMatNo(String oldMatNo) 旧品目コードを設定します。
void | setPackVoUn(String packVoUn) 容積単位 (許容梱包容積)を設定します。
void | setPackVoUnIso(String packVoUnIso) ISO コードでの容積単位 (許容梱包容積)を設定します。
void | setPackWtUn(String packWtUn) 重量単位 (許容梱包重量)を設定します。
void | setPackWtUnIso(String packWtUnIso) ISO コードでの重量単位 (許容梱包重量)を設定します。
void | setPageformat(String pageformat) 製造メモのページ書式を設定します。
void | setPageNo(String pageNo) 文書ページ番号 (文書管理システムによらない)を設定します。
void | setParEff(String parEff) 有効性パラメータへの値割当/変更番号よりも優先を設定します。
void | setPeriodIndExpirationDate(String periodIndExpirationDate) 有効期間期限日の期間区分を設定します。
void | setPlRefMat(String plRefMat) 梱包方法が同じ品目の参照品目を設定します。
void | setPlRefMatExternal(String plRefMatExternal) 項目 PL_REF_MAT の品目コード(長)を設定します。
void | setPlRefMatGuid(String plRefMatGuid) 項目 PL_REF_MAT の外部GUIDを設定します。
void | setPlRefMatVersion(String plRefMatVersion) 項目 PL_REF_MAT のバージョン番号を設定します。
void | setPoUnit(String poUnit) 発注単位を設定します。
void | setPoUnitIso(String poUnitIso) ISO コードによる発注単位を設定します。
void | setProcRule(String procRule) 調達規則を設定します。
void | setProdAlloc(String prodAlloc) 製品割当決定手順を設定します。
void | setProdCompositionOnPackaging(String prodCompositionOnPackaging) 区分: 梱包材にプリントされた生産構造を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setProdMemo(String prodMemo) 製造/検査メモを設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPrRefMatExternal(String prRefMatExternal) 項目 PR_REF_MAT の品目コード(長)を設定します。
void | setPrRefMatGuid(String prRefMatGuid) 項目 PR_REF_MAT の外部GUIDを設定します。
void | setPrRefMatVersion(String prRefMatVersion) 項目 PR_REF_MAT のバージョン番号を設定します。
void | setPurStatus(String purStatus) プラント共通品目ステータスを設定します。
void | setPurValkey(String purValkey) 購買許容値キーを設定します。
void | setPvalidfrom(String pvalidfrom) プラント共通品目のステータス有効開始日付を設定します。
void | setQmProcmnt(String qmProcmnt) 調達における品質管理有効を設定します。
void | setQtyGrGi(String qtyGrGi) 数量: 印刷予定入出庫票数を設定します。
void | setQualDik(String qualDik) 無償納入による割引対象品目を設定します。
void | setRoundUpRuleExpirationDate(String roundUpRuleExpirationDate) 有効期間期限日計算の丸め規則を設定します。
void | setSalStatus(String salStatus) 流通チェーン間品目ステータスを設定します。
void | setSeason(String season) 季節カテゴリを設定します。
void | setSerializationLevel(String serializationLevel) シリアル番号の指定レベルを設定します。
void | setShelfLife(String shelfLife) 総有効期間を設定します。
void | setShMatTyp(String shMatTyp) 梱包材タイプを設定します。
void | setSizeDim(String sizeDim) サイズ/寸法を設定します。
void | setSledBbd(String sledBbd) 有効期限を設定します。
void | setStackFact(String stackFact) 山積係数を設定します。
void | setStdDescr(String stdDescr) 標準テキスト (ANSI、ISO など)を設定します。
void | setStorConds(String storConds) 保管条件を設定します。
void | setStorPct(String storPct) 残存有効期間割合 %を設定します。
void | setSupSource(String supSource) 供給元を設定します。
void | setSvalidfrom(String svalidfrom) 流通チェーン間品目ステータスの有効開始日付を設定します。
void | setTempConds(String tempConds) 温度条件区分を設定します。
void | setTransGrp(String transGrp) 輸送グループを設定します。
void | setUnitOfWt(String unitOfWt) 重量単位を設定します。
void | setUnitOfWtIso(String unitOfWtIso) ISO コードでの重量単位を設定します。
void | setUomusage(String uomusage) 使用数量単位を設定します。
void | setVarOrdUn(String varOrdUn) 可変購買発注単位有効を設定します。
void | setVolTolLt(String volTolLt) 荷役単位の容積超過許容量を設定します。
void | setWeOriginAcceptance(String weOriginAcceptance) 仕入先構内での受領を設定します。
void | setWtTolLt(String wtTolLt) 荷役単位の重量超過許容量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ClientData

public ClientData()
品目データ (クライアントレベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getIndSector

public String getIndSector()
産業コードを取得します。

戻り値:
indSector 産業コード

getMatlType

public String getMatlType()
品目タイプを取得します。

戻り値:
matlType 品目タイプ

getCreatedOn

public String getCreatedOn()
登録日付を取得します。

戻り値:
createdOn 登録日付

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getLastChnge

public String getLastChnge()
最終変更日付を取得します。

戻り値:
lastChnge 最終変更日付

getChangedBy

public String getChangedBy()
オブジェクトの変更者名を取得します。

戻り値:
changedBy オブジェクトの変更者名

getMatStatus

public String getMatStatus()
品目更新完了ステータスを取得します。

戻り値:
matStatus 品目更新完了ステータス

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
クライアントレベルでの品目削除フラグを取得します。

戻り値:
delFlag クライアントレベルでの品目削除フラグ

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
matlGroup 品目グループ

getOldMatNo

public String getOldMatNo()
旧品目コードを取得します。

戻り値:
oldMatNo 旧品目コード

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getBaseUomIso

public String getBaseUomIso()
ISO コードでの基本数量単位を取得します。

戻り値:
baseUomIso ISO コードでの基本数量単位

getPoUnit

public String getPoUnit()
発注単位を取得します。

戻り値:
poUnit 発注単位

getPoUnitIso

public String getPoUnitIso()
ISO コードによる発注単位を取得します。

戻り値:
poUnitIso ISO コードによる発注単位

getDocument

public String getDocument()
文書番号 (文書管理システムによらない)を取得します。

戻り値:
document 文書番号 (文書管理システムによらない)

getDocType

public String getDocType()
文書タイプ (文書管理システムによらない)を取得します。

戻り値:
docType 文書タイプ (文書管理システムによらない)

getDocVers

public String getDocVers()
文書バージョン (文書管理システムによらない)を取得します。

戻り値:
docVers 文書バージョン (文書管理システムによらない)

getDocFormat

public String getDocFormat()
文書のページ書式 (文書管理システムによらない)を取得します。

戻り値:
docFormat 文書のページ書式 (文書管理システムによらない)

getDocChgNo

public String getDocChgNo()
文書変更番号 (文書管理システム外)を取得します。

戻り値:
docChgNo 文書変更番号 (文書管理システム外)

getPageNo

public String getPageNo()
文書ページ番号 (文書管理システムによらない)を取得します。

戻り値:
pageNo 文書ページ番号 (文書管理システムによらない)

getNoSheets

public String getNoSheets()
文書枚数 (文書管理システムによらない)を取得します。

戻り値:
noSheets 文書枚数 (文書管理システムによらない)

getProdMemo

public String getProdMemo()
製造/検査メモを取得します。

戻り値:
prodMemo 製造/検査メモ

getPageformat

public String getPageformat()
製造メモのページ書式を取得します。

戻り値:
pageformat 製造メモのページ書式

getSizeDim

public String getSizeDim()
サイズ/寸法を取得します。

戻り値:
sizeDim サイズ/寸法

getBasicMatl

public String getBasicMatl()
主構成物質を取得します。

戻り値:
basicMatl 主構成物質

getStdDescr

public String getStdDescr()
標準テキスト (ANSI、ISO など)を取得します。

戻り値:
stdDescr 標準テキスト (ANSI、ISO など)

getDsnOffice

public String getDsnOffice()
研究室/設計室を取得します。

戻り値:
dsnOffice 研究室/設計室

getPurValkey

public String getPurValkey()
購買許容値キーを取得します。

戻り値:
purValkey 購買許容値キー

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
netWeight 正味重量

getUnitOfWt

public String getUnitOfWt()
重量単位を取得します。

戻り値:
unitOfWt 重量単位

getUnitOfWtIso

public String getUnitOfWtIso()
ISO コードでの重量単位を取得します。

戻り値:
unitOfWtIso ISO コードでの重量単位

getContainer

public String getContainer()
容器条件を取得します。

戻り値:
container 容器条件

getStorConds

public String getStorConds()
保管条件を取得します。

戻り値:
storConds 保管条件

getTempConds

public String getTempConds()
温度条件区分を取得します。

戻り値:
tempConds 温度条件区分

getTransGrp

public String getTransGrp()
輸送グループを取得します。

戻り値:
transGrp 輸送グループ

getHazMatNo

public String getHazMatNo()
危険物コードを取得します。

戻り値:
hazMatNo 危険物コード

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getCompetitor

public String getCompetitor()
競合会社を取得します。

戻り値:
competitor 競合会社

getQtyGrGi

public String getQtyGrGi()
数量: 印刷予定入出庫票数を取得します。

戻り値:
qtyGrGi 数量: 印刷予定入出庫票数

getProcRule

public String getProcRule()
調達規則を取得します。

戻り値:
procRule 調達規則

getSupSource

public String getSupSource()
供給元を取得します。

戻り値:
supSource 供給元

getSeason

public String getSeason()
季節カテゴリを取得します。

戻り値:
season 季節カテゴリ

getLabelType

public String getLabelType()
ラベルタイプを取得します。

戻り値:
labelType ラベルタイプ

getLabelForm

public String getLabelForm()
ラベル書式を取得します。

戻り値:
labelForm ラベル書式

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getCadId

public String getCadId()
CAD 区分を取得します。

戻り値:
cadId CAD 区分

getAllowedWt

public String getAllowedWt()
許容梱包重量を取得します。

戻り値:
allowedWt 許容梱包重量

getPackWtUn

public String getPackWtUn()
重量単位 (許容梱包重量)を取得します。

戻り値:
packWtUn 重量単位 (許容梱包重量)

getPackWtUnIso

public String getPackWtUnIso()
ISO コードでの重量単位 (許容梱包重量)を取得します。

戻り値:
packWtUnIso ISO コードでの重量単位 (許容梱包重量)

getAllwdVol

public String getAllwdVol()
許容梱包容積を取得します。

戻り値:
allwdVol 許容梱包容積

getPackVoUn

public String getPackVoUn()
容積単位 (許容梱包容積)を取得します。

戻り値:
packVoUn 容積単位 (許容梱包容積)

getPackVoUnIso

public String getPackVoUnIso()
ISO コードでの容積単位 (許容梱包容積)を取得します。

戻り値:
packVoUnIso ISO コードでの容積単位 (許容梱包容積)

getWtTolLt

public String getWtTolLt()
荷役単位の重量超過許容量を取得します。

戻り値:
wtTolLt 荷役単位の重量超過許容量

getVolTolLt

public String getVolTolLt()
荷役単位の容積超過許容量を取得します。

戻り値:
volTolLt 荷役単位の容積超過許容量

getVarOrdUn

public String getVarOrdUn()
可変購買発注単位有効を取得します。

戻り値:
varOrdUn 可変購買発注単位有効

getConfigured

public String getConfigured()
選定可能品目を取得します。

戻り値:
configured 選定可能品目

getBatchMgmt

public String getBatchMgmt()
ロット管理所要量区分を取得します。

戻り値:
batchMgmt ロット管理所要量区分

getShMatTyp

public String getShMatTyp()
梱包材タイプを取得します。

戻り値:
shMatTyp 梱包材タイプ

getFillLevel

public String getFillLevel()
最大レベル (容積別)を取得します。

戻り値:
fillLevel 最大レベル (容積別)

getStackFact

public String getStackFact()
山積係数を取得します。

戻り値:
stackFact 山積係数

getMatGrpSm

public String getMatGrpSm()
品目グループ: 梱包材を取得します。

戻り値:
matGrpSm 品目グループ: 梱包材

getAuthoritygroup

public String getAuthoritygroup()
権限グループを取得します。

戻り値:
authoritygroup 権限グループ

getQmProcmnt

public String getQmProcmnt()
調達における品質管理有効を取得します。

戻り値:
qmProcmnt 調達における品質管理有効

getCatprofile

public String getCatprofile()
カタログプロファイルを取得します。

戻り値:
catprofile カタログプロファイル

getMinremlife

public String getMinremlife()
最低有効期間残を取得します。

戻り値:
minremlife 最低有効期間残

getShelfLife

public String getShelfLife()
総有効期間を取得します。

戻り値:
shelfLife 総有効期間

getStorPct

public String getStorPct()
残存有効期間割合 %を取得します。

戻り値:
storPct 残存有効期間割合 %

getConfMatl

public String getConfMatl()
プラント共通選定可能品目を取得します。

戻り値:
confMatl プラント共通選定可能品目

getCoProduct

public String getCoProduct()
区分: 連産品としても使用可能な品目を取得します。

戻り値:
coProduct 区分: 連産品としても使用可能な品目

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getPurStatus

public String getPurStatus()
プラント共通品目ステータスを取得します。

戻り値:
purStatus プラント共通品目ステータス

getSalStatus

public String getSalStatus()
流通チェーン間品目ステータスを取得します。

戻り値:
salStatus 流通チェーン間品目ステータス

getPvalidfrom

public String getPvalidfrom()
プラント共通品目のステータス有効開始日付を取得します。

戻り値:
pvalidfrom プラント共通品目のステータス有効開始日付

getSvalidfrom

public String getSvalidfrom()
流通チェーン間品目ステータスの有効開始日付を取得します。

戻り値:
svalidfrom 流通チェーン間品目ステータスの有効開始日付

getEnvtRlvt

public String getEnvtRlvt()
区分: 環境関連を取得します。

戻り値:
envtRlvt 区分: 環境関連

getProdAlloc

public String getProdAlloc()
製品割当決定手順を取得します。

戻り値:
prodAlloc 製品割当決定手順

getQualDik

public String getQualDik()
無償納入による割引対象品目を取得します。

戻り値:
qualDik 無償納入による割引対象品目

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
manuMat 製造者製品コード

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
mfrNo 製造者番号

getInvMatNo

public String getInvMatNo()
会社固有 (内部) 在庫管理品目コードを取得します。

戻り値:
invMatNo 会社固有 (内部) 在庫管理品目コード

getManufProf

public String getManufProf()
製造者製品プロファイルを取得します。

戻り値:
manufProf 製造者製品プロファイル

getHazmatprof

public String getHazmatprof()
危険物インジケータプロファイルを取得します。

戻り値:
hazmatprof 危険物インジケータプロファイル

getHighVisc

public String getHighVisc()
区分: 高粘性を取得します。

戻り値:
highVisc 区分: 高粘性

getLooseorliq

public String getLooseorliq()
区分: バルク/液体を取得します。

戻り値:
looseorliq 区分: バルク/液体

getClosedBox

public String getClosedBox()
完了した梱包材を取得します。

戻り値:
closedBox 完了した梱包材

getAppdBRec

public String getAppdBRec()
区分: バッチ製造記録の承認必須を取得します。

戻り値:
appdBRec 区分: バッチ製造記録の承認必須

getMatcmpllvl

public String getMatcmpllvl()
品目完了レベルを取得します。

戻り値:
matcmpllvl 品目完了レベル

getParEff

public String getParEff()
有効性パラメータへの値割当/変更番号よりも優先を取得します。

戻り値:
parEff 有効性パラメータへの値割当/変更番号よりも優先

getRoundUpRuleExpirationDate

public String getRoundUpRuleExpirationDate()
有効期間期限日計算の丸め規則を取得します。

戻り値:
roundUpRuleExpirationDate 有効期間期限日計算の丸め規則

getPeriodIndExpirationDate

public String getPeriodIndExpirationDate()
有効期間期限日の期間区分を取得します。

戻り値:
periodIndExpirationDate 有効期間期限日の期間区分

getProdCompositionOnPackaging

public String getProdCompositionOnPackaging()
区分: 梱包材にプリントされた生産構造を取得します。

戻り値:
prodCompositionOnPackaging 区分: 梱包材にプリントされた生産構造

getItemCat

public String getItemCat()
一般明細カテゴリグループを取得します。

戻り値:
itemCat 一般明細カテゴリグループ

getHazMatNoExternal

public String getHazMatNoExternal()
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
hazMatNoExternal 項目 HAZ_MAT_NO の品目コード (長) (今後の リリースで開発)

getHazMatNoGuid

public String getHazMatNoGuid()
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
hazMatNoGuid 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

getHazMatNoVersion

public String getHazMatNoVersion()
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
hazMatNoVersion 項目 HAZ_MAT_NO のバージョン番号 (今後の リリースで開発)

getInvMatNoExternal

public String getInvMatNoExternal()
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
invMatNoExternal 項目 INV_MAT_NO の品目コード (長) (今後の リリースで開発)

getInvMatNoGuid

public String getInvMatNoGuid()
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
invMatNoGuid 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

getInvMatNoVersion

public String getInvMatNoVersion()
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
invMatNoVersion 項目 INV_MAT_NO のバージョン番号 (今後の リリースで開発)

getMaterialFixed

public String getMaterialFixed()
ロックされている品目を取得します。

戻り値:
materialFixed ロックされている品目

getCmRelevanceFlag

public String getCmRelevanceFlag()
構成管理関連を取得します。

戻り値:
cmRelevanceFlag 構成管理関連

getSledBbd

public String getSledBbd()
有効期限を取得します。

戻り値:
sledBbd 有効期限

getGtinVariant

public String getGtinVariant()
グローバルトレード明細番号バリアントを取得します。

戻り値:
gtinVariant グローバルトレード明細番号バリアント

getSerializationLevel

public String getSerializationLevel()
シリアル番号の指定レベルを取得します。

戻り値:
serializationLevel シリアル番号の指定レベル

getPlRefMat

public String getPlRefMat()
梱包方法が同じ品目の参照品目を取得します。

戻り値:
plRefMat 梱包方法が同じ品目の参照品目

getExtmatlgrp

public String getExtmatlgrp()
外部品目グループを取得します。

戻り値:
extmatlgrp 外部品目グループ

getUomusage

public String getUomusage()
使用数量単位を取得します。

戻り値:
uomusage 使用数量単位

getGdsRelevant

public String getGdsRelevant()
区分:グローバルデータ同期関連を取得します。

戻り値:
gdsRelevant 区分:グローバルデータ同期関連

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード(長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード(長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getConfMatlExternal

public String getConfMatlExternal()
項目 CONF_MATL の品目コード(長)を取得します。

戻り値:
confMatlExternal 項目 CONF_MATL の品目コード(長)

getConfMatlGuid

public String getConfMatlGuid()
項目 CONF_MATL の外部GUIDを取得します。

戻り値:
confMatlGuid 項目 CONF_MATL の外部GUID

getConfMatlVersion

public String getConfMatlVersion()
項目 CONF_MATL のバージョン番号を取得します。

戻り値:
confMatlVersion 項目 CONF_MATL のバージョン番号

getPlRefMatExternal

public String getPlRefMatExternal()
項目 PL_REF_MAT の品目コード(長)を取得します。

戻り値:
plRefMatExternal 項目 PL_REF_MAT の品目コード(長)

getPlRefMatGuid

public String getPlRefMatGuid()
項目 PL_REF_MAT の外部GUIDを取得します。

戻り値:
plRefMatGuid 項目 PL_REF_MAT の外部GUID

getPlRefMatVersion

public String getPlRefMatVersion()
項目 PL_REF_MAT のバージョン番号を取得します。

戻り値:
plRefMatVersion 項目 PL_REF_MAT のバージョン番号

getPrRefMatExternal

public String getPrRefMatExternal()
項目 PR_REF_MAT の品目コード(長)を取得します。

戻り値:
prRefMatExternal 項目 PR_REF_MAT の品目コード(長)

getPrRefMatGuid

public String getPrRefMatGuid()
項目 PR_REF_MAT の外部GUIDを取得します。

戻り値:
prRefMatGuid 項目 PR_REF_MAT の外部GUID

getPrRefMatVersion

public String getPrRefMatVersion()
項目 PL_REF_MAT のバージョン番号を取得します。

戻り値:
plRefMatVersion 項目 PR_REF_MAT のバージョン番号

getWeOriginAcceptance

public String getWeOriginAcceptance()
仕入先構内での受領を取得します。

戻り値:
weOriginAcceptance 仕入先構内での受領

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setIndSector

public void setIndSector(String indSector)
産業コードを設定します。

パラメータ:
indSector - 産業コード

setMatlType

public void setMatlType(String matlType)
品目タイプを設定します。

パラメータ:
matlType - 品目タイプ

setCreatedOn

public void setCreatedOn(String createdOn)
登録日付を設定します。

パラメータ:
createdOn - 登録日付

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setLastChnge

public void setLastChnge(String lastChnge)
最終変更日付を設定します。

パラメータ:
lastChnge - 最終変更日付

setChangedBy

public void setChangedBy(String changedBy)
オブジェクトの変更者名を設定します。

パラメータ:
changedBy - オブジェクトの変更者名

setMatStatus

public void setMatStatus(String matStatus)
品目更新完了ステータスを設定します。

パラメータ:
matStatus - 品目更新完了ステータス

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
クライアントレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - クライアントレベルでの品目削除フラグ

setMatlGroup

public void setMatlGroup(String matlGroup)
品目グループを設定します。

パラメータ:
matlGroup - 品目グループ

setOldMatNo

public void setOldMatNo(String oldMatNo)
旧品目コードを設定します。

パラメータ:
oldMatNo - 旧品目コード

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setBaseUomIso

public void setBaseUomIso(String baseUomIso)
ISO コードでの基本数量単位を設定します。

パラメータ:
baseUomIso - ISO コードでの基本数量単位

setPoUnit

public void setPoUnit(String poUnit)
発注単位を設定します。

パラメータ:
poUnit - 発注単位

setPoUnitIso

public void setPoUnitIso(String poUnitIso)
ISO コードによる発注単位を設定します。

パラメータ:
poUnitIso - ISO コードによる発注単位

setDocument

public void setDocument(String document)
文書番号 (文書管理システムによらない)を設定します。

パラメータ:
document - 文書番号 (文書管理システムによらない)

setDocType

public void setDocType(String docType)
文書タイプ (文書管理システムによらない)を設定します。

パラメータ:
docType - 文書タイプ (文書管理システムによらない)

setDocVers

public void setDocVers(String docVers)
文書バージョン (文書管理システムによらない)を設定します。

パラメータ:
docVers - 文書バージョン (文書管理システムによらない)

setDocFormat

public void setDocFormat(String docFormat)
文書のページ書式 (文書管理システムによらない)を設定します。

パラメータ:
docFormat - 文書のページ書式 (文書管理システムによらない)

setDocChgNo

public void setDocChgNo(String docChgNo)
文書変更番号 (文書管理システム外)を設定します。

パラメータ:
docChgNo - 文書変更番号 (文書管理システム外)

setPageNo

public void setPageNo(String pageNo)
文書ページ番号 (文書管理システムによらない)を設定します。

パラメータ:
pageNo - 文書ページ番号 (文書管理システムによらない)

setNoSheets

public void setNoSheets(String noSheets)
文書枚数 (文書管理システムによらない)を設定します。

パラメータ:
noSheets - 文書枚数 (文書管理システムによらない)

setProdMemo

public void setProdMemo(String prodMemo)
製造/検査メモを設定します。

パラメータ:
prodMemo - 製造/検査メモ

setPageformat

public void setPageformat(String pageformat)
製造メモのページ書式を設定します。

パラメータ:
pageformat - 製造メモのページ書式

setSizeDim

public void setSizeDim(String sizeDim)
サイズ/寸法を設定します。

パラメータ:
sizeDim - サイズ/寸法

setBasicMatl

public void setBasicMatl(String basicMatl)
主構成物質を設定します。

パラメータ:
basicMatl - 主構成物質

setStdDescr

public void setStdDescr(String stdDescr)
標準テキスト (ANSI、ISO など)を設定します。

パラメータ:
stdDescr - 標準テキスト (ANSI、ISO など)

setDsnOffice

public void setDsnOffice(String dsnOffice)
研究室/設計室を設定します。

パラメータ:
dsnOffice - 研究室/設計室

setPurValkey

public void setPurValkey(String purValkey)
購買許容値キーを設定します。

パラメータ:
purValkey - 購買許容値キー

setNetWeight

public void setNetWeight(String netWeight)
正味重量を設定します。

パラメータ:
netWeight - 正味重量

setUnitOfWt

public void setUnitOfWt(String unitOfWt)
重量単位を設定します。

パラメータ:
unitOfWt - 重量単位

setUnitOfWtIso

public void setUnitOfWtIso(String unitOfWtIso)
ISO コードでの重量単位を設定します。

パラメータ:
unitOfWtIso - ISO コードでの重量単位

setContainer

public void setContainer(String container)
容器条件を設定します。

パラメータ:
container - 容器条件

setStorConds

public void setStorConds(String storConds)
保管条件を設定します。

パラメータ:
storConds - 保管条件

setTempConds

public void setTempConds(String tempConds)
温度条件区分を設定します。

パラメータ:
tempConds - 温度条件区分

setTransGrp

public void setTransGrp(String transGrp)
輸送グループを設定します。

パラメータ:
transGrp - 輸送グループ

setHazMatNo

public void setHazMatNo(String hazMatNo)
危険物コードを設定します。

パラメータ:
hazMatNo - 危険物コード

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setCompetitor

public void setCompetitor(String competitor)
競合会社を設定します。

パラメータ:
competitor - 競合会社

setQtyGrGi

public void setQtyGrGi(String qtyGrGi)
数量: 印刷予定入出庫票数を設定します。

パラメータ:
qtyGrGi - 数量: 印刷予定入出庫票数

setProcRule

public void setProcRule(String procRule)
調達規則を設定します。

パラメータ:
procRule - 調達規則

setSupSource

public void setSupSource(String supSource)
供給元を設定します。

パラメータ:
supSource - 供給元

setSeason

public void setSeason(String season)
季節カテゴリを設定します。

パラメータ:
season - 季節カテゴリ

setLabelType

public void setLabelType(String labelType)
ラベルタイプを設定します。

パラメータ:
labelType - ラベルタイプ

setLabelForm

public void setLabelForm(String labelForm)
ラベル書式を設定します。

パラメータ:
labelForm - ラベル書式

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setCadId

public void setCadId(String cadId)
CAD 区分を設定します。

パラメータ:
cadId - CAD 区分

setAllowedWt

public void setAllowedWt(String allowedWt)
許容梱包重量を設定します。

パラメータ:
allowedWt - 許容梱包重量

setPackWtUn

public void setPackWtUn(String packWtUn)
重量単位 (許容梱包重量)を設定します。

パラメータ:
packWtUn - 重量単位 (許容梱包重量)

setPackWtUnIso

public void setPackWtUnIso(String packWtUnIso)
ISO コードでの重量単位 (許容梱包重量)を設定します。

パラメータ:
packWtUnIso - ISO コードでの重量単位 (許容梱包重量)

setAllwdVol

public void setAllwdVol(String allwdVol)
許容梱包容積を設定します。

パラメータ:
allwdVol - 許容梱包容積

setPackVoUn

public void setPackVoUn(String packVoUn)
容積単位 (許容梱包容積)を設定します。

パラメータ:
packVoUn - 容積単位 (許容梱包容積)

setPackVoUnIso

public void setPackVoUnIso(String packVoUnIso)
ISO コードでの容積単位 (許容梱包容積)を設定します。

パラメータ:
packVoUnIso - ISO コードでの容積単位 (許容梱包容積)

setWtTolLt

public void setWtTolLt(String wtTolLt)
荷役単位の重量超過許容量を設定します。

パラメータ:
wtTolLt - 荷役単位の重量超過許容量

setVolTolLt

public void setVolTolLt(String volTolLt)
荷役単位の容積超過許容量を設定します。

パラメータ:
volTolLt - 荷役単位の容積超過許容量

setVarOrdUn

public void setVarOrdUn(String varOrdUn)
可変購買発注単位有効を設定します。

パラメータ:
varOrdUn - 可変購買発注単位有効

setConfigured

public void setConfigured(String configured)
選定可能品目を設定します。

パラメータ:
configured - 選定可能品目

setBatchMgmt

public void setBatchMgmt(String batchMgmt)
ロット管理所要量区分を設定します。

パラメータ:
batchMgmt - ロット管理所要量区分

setShMatTyp

public void setShMatTyp(String shMatTyp)
梱包材タイプを設定します。

パラメータ:
shMatTyp - 梱包材タイプ

setFillLevel

public void setFillLevel(String fillLevel)
最大レベル (容積別)を設定します。

パラメータ:
fillLevel - 最大レベル (容積別)

setStackFact

public void setStackFact(String stackFact)
山積係数を設定します。

パラメータ:
stackFact - 山積係数

setMatGrpSm

public void setMatGrpSm(String matGrpSm)
品目グループ: 梱包材を設定します。

パラメータ:
matGrpSm - 品目グループ: 梱包材

setAuthoritygroup

public void setAuthoritygroup(String authoritygroup)
権限グループを設定します。

パラメータ:
authoritygroup - 権限グループ

setQmProcmnt

public void setQmProcmnt(String qmProcmnt)
調達における品質管理有効を設定します。

パラメータ:
qmProcmnt - 調達における品質管理有効

setCatprofile

public void setCatprofile(String catprofile)
カタログプロファイルを設定します。

パラメータ:
catprofile - カタログプロファイル

setMinremlife

public void setMinremlife(String minremlife)
最低有効期間残を設定します。

パラメータ:
minremlife - 最低有効期間残

setShelfLife

public void setShelfLife(String shelfLife)
総有効期間を設定します。

パラメータ:
shelfLife - 総有効期間

setStorPct

public void setStorPct(String storPct)
残存有効期間割合 %を設定します。

パラメータ:
storPct - 残存有効期間割合 %

setConfMatl

public void setConfMatl(String confMatl)
プラント共通選定可能品目を設定します。

パラメータ:
confMatl - プラント共通選定可能品目

setCoProduct

public void setCoProduct(String coProduct)
区分: 連産品としても使用可能な品目を設定します。

パラメータ:
coProduct - 区分: 連産品としても使用可能な品目

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setPurStatus

public void setPurStatus(String purStatus)
プラント共通品目ステータスを設定します。

パラメータ:
purStatus - プラント共通品目ステータス

setSalStatus

public void setSalStatus(String salStatus)
流通チェーン間品目ステータスを設定します。

パラメータ:
salStatus - 流通チェーン間品目ステータス

setPvalidfrom

public void setPvalidfrom(String pvalidfrom)
プラント共通品目のステータス有効開始日付を設定します。

パラメータ:
pvalidfrom - プラント共通品目のステータス有効開始日付

setSvalidfrom

public void setSvalidfrom(String svalidfrom)
流通チェーン間品目ステータスの有効開始日付を設定します。

パラメータ:
svalidfrom - 流通チェーン間品目ステータスの有効開始日付

setEnvtRlvt

public void setEnvtRlvt(String envtRlvt)
区分: 環境関連を設定します。

パラメータ:
envtRlvt - 区分: 環境関連

setProdAlloc

public void setProdAlloc(String prodAlloc)
製品割当決定手順を設定します。

パラメータ:
prodAlloc - 製品割当決定手順

setQualDik

public void setQualDik(String qualDik)
無償納入による割引対象品目を設定します。

パラメータ:
qualDik - 無償納入による割引対象品目

setManuMat

public void setManuMat(String manuMat)
製造者製品コードを設定します。

パラメータ:
manuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String mfrNo)
製造者番号を設定します。

パラメータ:
mfrNo - 製造者番号

setInvMatNo

public void setInvMatNo(String invMatNo)
会社固有 (内部) 在庫管理品目コードを設定します。

パラメータ:
invMatNo - 会社固有 (内部) 在庫管理品目コード

setManufProf

public void setManufProf(String manufProf)
製造者製品プロファイルを設定します。

パラメータ:
manufProf - 製造者製品プロファイル

setHazmatprof

public void setHazmatprof(String hazmatprof)
危険物インジケータプロファイルを設定します。

パラメータ:
hazmatprof - 危険物インジケータプロファイル

setHighVisc

public void setHighVisc(String highVisc)
区分: 高粘性を設定します。

パラメータ:
highVisc - 区分: 高粘性

setLooseorliq

public void setLooseorliq(String looseorliq)
区分: バルク/液体を設定します。

パラメータ:
looseorliq - 区分: バルク/液体

setClosedBox

public void setClosedBox(String closedBox)
完了した梱包材を設定します。

パラメータ:
closedBox - 完了した梱包材

setAppdBRec

public void setAppdBRec(String appdBRec)
区分: バッチ製造記録の承認必須を設定します。

パラメータ:
appdBRec - 区分: バッチ製造記録の承認必須

setMatcmpllvl

public void setMatcmpllvl(String matcmpllvl)
品目完了レベルを設定します。

パラメータ:
matcmpllvl - 品目完了レベル

setParEff

public void setParEff(String parEff)
有効性パラメータへの値割当/変更番号よりも優先を設定します。

パラメータ:
parEff - 有効性パラメータへの値割当/変更番号よりも優先

setRoundUpRuleExpirationDate

public void setRoundUpRuleExpirationDate(String roundUpRuleExpirationDate)
有効期間期限日計算の丸め規則を設定します。

パラメータ:
roundUpRuleExpirationDate - 有効期間期限日計算の丸め規則

setPeriodIndExpirationDate

public void setPeriodIndExpirationDate(String periodIndExpirationDate)
有効期間期限日の期間区分を設定します。

パラメータ:
periodIndExpirationDate - 有効期間期限日の期間区分

setProdCompositionOnPackaging

public void setProdCompositionOnPackaging(String prodCompositionOnPackaging)
区分: 梱包材にプリントされた生産構造を設定します。

パラメータ:
prodCompositionOnPackaging - 区分: 梱包材にプリントされた生産構造

setItemCat

public void setItemCat(String itemCat)
一般明細カテゴリグループを設定します。

パラメータ:
itemCat - 一般明細カテゴリグループ

setHazMatNoExternal

public void setHazMatNoExternal(String hazMatNoExternal)
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoExternal - 項目 HAZ_MAT_NO の品目コード (長) (今後の リリースで開発)

setHazMatNoGuid

public void setHazMatNoGuid(String hazMatNoGuid)
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoGuid - 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

setHazMatNoVersion

public void setHazMatNoVersion(String hazMatNoVersion)
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoVersion - 項目 HAZ_MAT_NO のバージョン番号 (今後の リリースで開発)

setInvMatNoExternal

public void setInvMatNoExternal(String invMatNoExternal)
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
invMatNoExternal - 項目 INV_MAT_NO の品目コード (長) (今後の リリースで開発)

setInvMatNoGuid

public void setInvMatNoGuid(String invMatNoGuid)
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
invMatNoGuid - 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

setInvMatNoVersion

public void setInvMatNoVersion(String invMatNoVersion)
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
invMatNoVersion - 項目 INV_MAT_NO のバージョン番号 (今後の リリースで開発)

setMaterialFixed

public void setMaterialFixed(String materialFixed)
ロックされている品目を設定します。

パラメータ:
materialFixed - ロックされている品目

setCmRelevanceFlag

public void setCmRelevanceFlag(String cmRelevanceFlag)
構成管理関連を設定します。

パラメータ:
cmRelevanceFlag - 構成管理関連

setSledBbd

public void setSledBbd(String sledBbd)
有効期限を設定します。

パラメータ:
sledBbd - 有効期限

setGtinVariant

public void setGtinVariant(String gtinVariant)
グローバルトレード明細番号バリアントを設定します。

パラメータ:
gtinVariant - グローバルトレード明細番号バリアント

setSerializationLevel

public void setSerializationLevel(String serializationLevel)
シリアル番号の指定レベルを設定します。

パラメータ:
serializationLevel - シリアル番号の指定レベル

setPlRefMat

public void setPlRefMat(String plRefMat)
梱包方法が同じ品目の参照品目を設定します。

パラメータ:
plRefMat - 梱包方法が同じ品目の参照品目

setExtmatlgrp

public void setExtmatlgrp(String extmatlgrp)
外部品目グループを設定します。

パラメータ:
extmatlgrp - 外部品目グループ

setUomusage

public void setUomusage(String uomusage)
使用数量単位を設定します。

パラメータ:
uomusage - 使用数量単位

setGdsRelevant

public void setGdsRelevant(String gdsRelevant)
区分:グローバルデータ同期関連を設定します。

パラメータ:
gdsRelevant - 区分:グローバルデータ同期関連

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード(長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード(長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setConfMatlExternal

public void setConfMatlExternal(String confMatlExternal)
項目 CONF_MATL の品目コード(長)を設定します。

パラメータ:
confMatlExternal - 項目 CONF_MATL の品目コード(長)

setConfMatlGuid

public void setConfMatlGuid(String confMatlGuid)
項目 CONF_MATL の外部GUIDを設定します。

パラメータ:
confMatlGuid - 項目 CONF_MATL の外部GUID

setConfMatlVersion

public void setConfMatlVersion(String confMatlVersion)
項目 CONF_MATL のバージョン番号を設定します。

パラメータ:
confMatlVersion - 項目 CONF_MATL のバージョン番号

setPlRefMatExternal

public void setPlRefMatExternal(String plRefMatExternal)
項目 PL_REF_MAT の品目コード(長)を設定します。

パラメータ:
plRefMatExternal - 項目 PL_REF_MAT の品目コード(長)

setPlRefMatGuid

public void setPlRefMatGuid(String plRefMatGuid)
項目 PL_REF_MAT の外部GUIDを設定します。

パラメータ:
plRefMatGuid - 項目 PL_REF_MAT の外部GUID

setPlRefMatVersion

public void setPlRefMatVersion(String plRefMatVersion)
項目 PL_REF_MAT のバージョン番号を設定します。

パラメータ:
plRefMatVersion - 項目 PL_REF_MAT のバージョン番号

setPrRefMatExternal

public void setPrRefMatExternal(String prRefMatExternal)
項目 PR_REF_MAT の品目コード(長)を設定します。

パラメータ:
prRefMatExternal - 項目 PR_REF_MAT の品目コード(長)

setPrRefMatGuid

public void setPrRefMatGuid(String prRefMatGuid)
項目 PR_REF_MAT の外部GUIDを設定します。

パラメータ:
prRefMatGuid - 項目 PR_REF_MAT の外部GUID

setPrRefMatVersion

public void setPrRefMatVersion(String prRefMatVersion)
項目 PR_REF_MAT のバージョン番号を設定します。

パラメータ:
prRefMatVersion - 項目 PR_REF_MAT のバージョン番号

setWeOriginAcceptance

public void setWeOriginAcceptance(String weOriginAcceptance)
仕入先構内での受領を設定します。

パラメータ:
weOriginAcceptance - 仕入先構内での受領

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ClientDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ClientDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList
すべての実装インタフェース:
Serializable
public class ClientDataList
extends ClientData
implements Serializable

品目データ (クライアントレベル)情報クラス
機能は以下の通り

  • 品目データ (クライアントレベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ClientDataList()
品目データ (クライアントレベル)情報を作成します。
ClientDataList(int index)
品目データ (クライアントレベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData から継承したメソッド
getAllowedWt, getAllwdVol, getAppdBRec, getAuthoritygroup, getBaseUom, getBaseUomIso, getBasicMatl, getBatchMgmt, getCadId, getCatprofile, getChangedBy, getClosedBox, getCmRelevanceFlag, getCompetitor, getConfigured, getConfMatl, getConfMatlExternal, getConfMatlGuid, getConfMatlVersion, getContainer, getCoProduct, getCreatedBy, getCreatedOn, getDelFlag, getDivision, getDocChgNo, getDocFormat, getDocType, getDocument, getDocVers, getDsnOffice, getEnvtRlvt, getExtmatlgrp, getFillLevel, getFunction, getGdsRelevant, getGtinVariant, getHazMatNo, getHazMatNoExternal, getHazMatNoGuid, getHazMatNoVersion, getHazmatprof, getHighVisc, getIndSector, getInvMatNo, getInvMatNoExternal, getInvMatNoGuid, getInvMatNoVersion, getItemCat, getLabelForm, getLabelType, getLastChnge, getLooseorliq, getMaintStat, getManufProf, getManuMat, getMatcmpllvl, getMaterial, getMaterialExternal, getMaterialFixed, getMaterialGuid, getMaterialVersion, getMatGrpSm, getMatlGroup, getMatlType, getMatStatus, getMfrNo, getMinremlife, getNetWeight, getNoSheets, getOldMatNo, getPackVoUn, getPackVoUnIso, getPackWtUn, getPackWtUnIso, getPageformat, getPageNo, getParEff, getPeriodIndExpirationDate, getPlRefMat, getPlRefMatExternal, getPlRefMatGuid, getPlRefMatVersion, getPoUnit, getPoUnitIso, getProcRule, getProdAlloc, getProdCompositionOnPackaging, getProdHier, getProdMemo, getPrRefMat, getPrRefMatExternal, getPrRefMatGuid, getPrRefMatVersion, getPurStatus, getPurValkey, getPvalidfrom, getQmProcmnt, getQtyGrGi, getQualDik, getRoundUpRuleExpirationDate, getSalStatus, getSeason, getSerializationLevel, getShelfLife, getShMatTyp, getSizeDim, getSledBbd, getStackFact, getStdDescr, getStorConds, getStorPct, getSupSource, getSvalidfrom, getTempConds, getTransGrp, getUnitOfWt, getUnitOfWtIso, getUomusage, getVarOrdUn, getVolTolLt, getWeOriginAcceptance, getWtTolLt, setAllowedWt, setAllwdVol, setAppdBRec, setAuthoritygroup, setBaseUom, setBaseUomIso, setBasicMatl, setBatchMgmt, setCadId, setCatprofile, setChangedBy, setClosedBox, setCmRelevanceFlag, setCompetitor, setConfigured, setConfMatl, setConfMatlExternal, setConfMatlGuid, setConfMatlVersion, setContainer, setCoProduct, setCreatedBy, setCreatedOn, setDelFlag, setDivision, setDocChgNo, setDocFormat, setDocType, setDocument, setDocVers, setDsnOffice, setEnvtRlvt, setExtmatlgrp, setFillLevel, setFunction, setGdsRelevant, setGtinVariant, setHazMatNo, setHazMatNoExternal, setHazMatNoGuid, setHazMatNoVersion, setHazmatprof, setHighVisc, setIndSector, setInvMatNo, setInvMatNoExternal, setInvMatNoGuid, setInvMatNoVersion, setItemCat, setLabelForm, setLabelType, setLastChnge, setLooseorliq, setMaintStat, setManufProf, setManuMat, setMatcmpllvl, setMaterial, setMaterialExternal, setMaterialFixed, setMaterialGuid, setMaterialVersion, setMatGrpSm, setMatlGroup, setMatlType, setMatStatus, setMfrNo, setMinremlife, setNetWeight, setNoSheets, setOldMatNo, setPackVoUn, setPackVoUnIso, setPackWtUn, setPackWtUnIso, setPageformat, setPageNo, setParEff, setPeriodIndExpirationDate, setPlRefMat, setPlRefMatExternal, setPlRefMatGuid, setPlRefMatVersion, setPoUnit, setPoUnitIso, setProcRule, setProdAlloc, setProdCompositionOnPackaging, setProdHier, setProdMemo, setPrRefMat, setPrRefMatExternal, setPrRefMatGuid, setPrRefMatVersion, setPurStatus, setPurValkey, setPvalidfrom, setQmProcmnt, setQtyGrGi, setQualDik, setRoundUpRuleExpirationDate, setSalStatus, setSeason, setSerializationLevel, setShelfLife, setShMatTyp, setSizeDim, setSledBbd, setStackFact, setStdDescr, setStorConds, setStorPct, setSupSource, setSvalidfrom, setTempConds, setTransGrp, setUnitOfWt, setUnitOfWtIso, setUomusage, setVarOrdUn, setVolTolLt, setWeOriginAcceptance, setWtTolLt, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ClientDataList

public ClientDataList()
品目データ (クライアントレベル)情報を作成します。

ClientDataList

public ClientDataList(int index)
品目データ (クライアントレベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastParameters (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ForecastParameters

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ForecastParametersList
public class ForecastParameters
extends Object
implements Serializable

予測パラメータ情報クラス
機能は以下の通り

  • 予測パラメータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastParameters()
予測パラメータ情報を作成します。
メソッドの概要
String | getAlphaFact() アルファ係数使用による基本値の平滑化を取得します。
String | getBasicValue() 基準値を取得します。
String | getBasicValue1() 第二指図の基準値を取得します。
String | getBasicValue2() 第二指図の基準値を取得します。
String | getBasicValuePp() 前期間の基準値を取得します。
String | getBasicValuePp1() 前期間における第二指図の基準値を取得します。
String | getBasicValuePp2() 前期間における第二指図の基準値を取得します。
String | getBetaFact() ベータ係数による傾向値平準化を取得します。
String | getCoeffTheil() タイル係数を取得します。
String | getDeltaFact() デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。
String | getErrorTotal() エラー合計を取得します。
String | getErrorTotalPp() 前期間のエラー合計を取得します。
String | getExceptList() 例外メッセージバーを取得します。
String | getExpostPds() 事後的需要予測に含む履歴値の数を取得します。
String | getFixedPds() 固定期間を取得します。
String | getForecFlowCont() 予測フロー管理を取得します。
String | getForeDate() 最終需要予測日を取得します。
String | getForeModel() 予測モデルを取得します。
String | getForePds() 需要予測期間を取得します。
String | getForeProf() 需要予測プロファイルを取得します。
String | getFunction() BAPI 機能を取得します。
String | getFyVariant() 会計年度バリアントを取得します。
String | getGammaFact() ガンマ係数使用の平滑化のための季節指数を取得します。
String | getHistVals() 履歴値の数を取得します。
String | getInitialize() 初期化区分を取得します。
String | getInitPds() 初期化で使用する履歴値の数を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMeanAbsolDev() 絶対平均偏差 (MAD)を取得します。
String | getMeanAbsolDevPp() 前期間の平均絶対偏差を取得します。
String | getModelSi() モデル選択区分を取得します。
String | getModelSp() モデル選択方式を取得します。
String | getOptimLev() 最適化レベルを取得します。
String | getParamOpt() パラメータ最適化用の区分を取得します。
String | getPeriodInd() 期間区分を取得します。
String | getPlant() プラントを取得します。
String | getSeasonPds() 季節周期ごとの期間数を取得します。
String | getTracklimit() 警告限界を取得します。
String | getTrendValue() 傾向値を取得します。
String | getTrendValuePp() 前期間の傾向値を取得します。
String | getWtgGroup() 加重グループを取得します。
void | setAlphaFact(String alphaFact) アルファ係数使用による基本値の平滑化を設定します。
void | setBasicValue(String basicValue) 基準値を設定します。
void | setBasicValue1(String basicValue1) 第二指図の基準値を設定します。
void | setBasicValue2(String basicValue2) 第二指図の基準値を設定します。
void | setBasicValuePp(String basicValuePp) 前期間の基準値を設定します。
void | setBasicValuePp1(String basicValuePp1) 前期間における第二指図の基準値を設定します。
void | setBasicValuePp2(String basicValuePp2) 前期間における第二指図の基準値を設定します。
void | setBetaFact(String betaFact) ベータ係数による傾向値平準化を設定します。
void | setCoeffTheil(String coeffTheil) タイル係数を設定します。
void | setDeltaFact(String deltaFact) デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。
void | setErrorTotal(String errorTotal) エラー合計を設定します。
void | setErrorTotalPp(String errorTotalPp) 前期間のエラー合計を設定します。
void | setExceptList(String exceptList) 例外メッセージバーを設定します。
void | setExpostPds(String expostPds) 事後的需要予測に含む履歴値の数を設定します。
void | setFixedPds(String fixedPds) 固定期間を設定します。
void | setForecFlowCont(String forecFlowCont) 予測フロー管理を設定します。
void | setForeDate(String foreDate) 最終需要予測日を設定します。
void | setForeModel(String foreModel) 予測モデルを設定します。
void | setForePds(String forePds) 需要予測期間を設定します。
void | setForeProf(String foreProf) 需要予測プロファイルを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFyVariant(String fyVariant) 会計年度バリアントを設定します。
void | setGammaFact(String gammaFact) ガンマ係数使用の平滑化のための季節指数を設定します。
void | setHistVals(String histVals) 履歴値の数を設定します。
void | setInitialize(String initialize) 初期化区分を設定します。
void | setInitPds(String initPds) 初期化で使用する履歴値の数を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMeanAbsolDev(String meanAbsolDev) 絶対平均偏差 (MAD)を設定します。
void | setMeanAbsolDevPp(String meanAbsolDevPp) 前期間の平均絶対偏差を設定します。
void | setModelSi(String modelSi) モデル選択区分を設定します。
void | setModelSp(String modelSp) モデル選択方式を設定します。
void | setOptimLev(String optimLev) 最適化レベルを設定します。
void | setParamOpt(String paramOpt) パラメータ最適化用の区分を設定します。
void | setPeriodInd(String periodInd) 期間区分を設定します。
void | setPlant(String plant) プラントを設定します。
void | setSeasonPds(String seasonPds) 季節周期ごとの期間数を設定します。
void | setTracklimit(String tracklimit) 警告限界を設定します。
void | setTrendValue(String trendValue) 傾向値を設定します。
void | setTrendValuePp(String trendValuePp) 前期間の傾向値を設定します。
void | setWtgGroup(String wtgGroup) 加重グループを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastParameters

public ForecastParameters()
予測パラメータ情報を作成します。 需要予測パラメータ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getForeProf

public String getForeProf()
需要予測プロファイルを取得します。

戻り値:
foreProf 需要予測プロファイル

getModelSi

public String getModelSi()
モデル選択区分を取得します。

戻り値:
modelSi モデル選択区分

getModelSp

public String getModelSp()
モデル選択方式を取得します。

戻り値:
modelSp モデル選択方式

getParamOpt

public String getParamOpt()
パラメータ最適化用の区分を取得します。

戻り値:
paramOpt パラメータ最適化用の区分

getOptimLev

public String getOptimLev()
最適化レベルを取得します。

戻り値:
optimLev 最適化レベル

getInitialize

public String getInitialize()
初期化区分を取得します。

戻り値:
initialize 初期化区分

getForeModel

public String getForeModel()
予測モデルを取得します。

戻り値:
foreModel 予測モデル

getAlphaFact

public String getAlphaFact()
アルファ係数使用による基本値の平滑化を取得します。

戻り値:
alphaFact アルファ係数使用による基本値の平滑化

getBetaFact

public String getBetaFact()
ベータ係数による傾向値平準化を取得します。

戻り値:
betaFact ベータ係数による傾向値平準化

getGammaFact

public String getGammaFact()
ガンマ係数使用の平滑化のための季節指数を取得します。

戻り値:
gammaFact ガンマ係数使用の平滑化のための季節指数

getDeltaFact

public String getDeltaFact()
デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。

戻り値:
deltaFact デルタ係数使用による MAD (絶対平均偏差) 平準化

getTracklimit

public String getTracklimit()
警告限界を取得します。

戻り値:
tracklimit 警告限界

getForeDate

public String getForeDate()
最終需要予測日を取得します。

戻り値:
foreDate 最終需要予測日

getHistVals

public String getHistVals()
履歴値の数を取得します。

戻り値:
histVals 履歴値の数

getInitPds

public String getInitPds()
初期化で使用する履歴値の数を取得します。

戻り値:
initPds 初期化で使用する履歴値の数

getSeasonPds

public String getSeasonPds()
季節周期ごとの期間数を取得します。

戻り値:
seasonPds 季節周期ごとの期間数

getExpostPds

public String getExpostPds()
事後的需要予測に含む履歴値の数を取得します。

戻り値:
expostPds 事後的需要予測に含む履歴値の数

getForePds

public String getForePds()
需要予測期間を取得します。

戻り値:
forePds 需要予測期間

getFixedPds

public String getFixedPds()
固定期間を取得します。

戻り値:
fixedPds 固定期間

getBasicValue

public String getBasicValue()
基準値を取得します。

戻り値:
basicValue 基準値

getBasicValue1

public String getBasicValue1()
第二指図の基準値を取得します。

戻り値:
basicValue1 第二指図の基準値

getBasicValue2

public String getBasicValue2()
第二指図の基準値を取得します。

戻り値:
basicValue2 第二指図の基準値

getBasicValuePp

public String getBasicValuePp()
前期間の基準値を取得します。

戻り値:
basicValuePp 前期間の基準値

getBasicValuePp1

public String getBasicValuePp1()
前期間における第二指図の基準値を取得します。

戻り値:
basicValuePp1 前期間における第二指図の基準値

getBasicValuePp2

public String getBasicValuePp2()
前期間における第二指図の基準値を取得します。

戻り値:
basicValuePp2 前期間における第二指図の基準値

getTrendValue

public String getTrendValue()
傾向値を取得します。

戻り値:
trendValue 傾向値

getTrendValuePp

public String getTrendValuePp()
前期間の傾向値を取得します。

戻り値:
trendValuePp 前期間の傾向値

getMeanAbsolDev

public String getMeanAbsolDev()
絶対平均偏差 (MAD)を取得します。

戻り値:
meanAbsolDev 絶対平均偏差 (MAD)

getMeanAbsolDevPp

public String getMeanAbsolDevPp()
前期間の平均絶対偏差を取得します。

戻り値:
meanAbsolDevPp 前期間の平均絶対偏差

getErrorTotal

public String getErrorTotal()
エラー合計を取得します。

戻り値:
errorTotal エラー合計

getErrorTotalPp

public String getErrorTotalPp()
前期間のエラー合計を取得します。

戻り値:
errorTotalPp 前期間のエラー合計

getWtgGroup

public String getWtgGroup()
加重グループを取得します。

戻り値:
wtgGroup 加重グループ

getCoeffTheil

public String getCoeffTheil()
タイル係数を取得します。

戻り値:
coeffTheil タイル係数

getExceptList

public String getExceptList()
例外メッセージバーを取得します。

戻り値:
exceptList 例外メッセージバー

getForecFlowCont

public String getForecFlowCont()
予測フロー管理を取得します。

戻り値:
forecFlowCont 予測フロー管理

getPeriodInd

public String getPeriodInd()
期間区分を取得します。

戻り値:
periodInd 期間区分

getFyVariant

public String getFyVariant()
会計年度バリアントを取得します。

戻り値:
fyVariant 会計年度バリアント

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setForeProf

public void setForeProf(String foreProf)
需要予測プロファイルを設定します。

パラメータ:
foreProf - 需要予測プロファイル

setModelSi

public void setModelSi(String modelSi)
モデル選択区分を設定します。

パラメータ:
modelSi - モデル選択区分

setModelSp

public void setModelSp(String modelSp)
モデル選択方式を設定します。

パラメータ:
modelSp - モデル選択方式

setParamOpt

public void setParamOpt(String paramOpt)
パラメータ最適化用の区分を設定します。

パラメータ:
paramOpt - パラメータ最適化用の区分

setOptimLev

public void setOptimLev(String optimLev)
最適化レベルを設定します。

パラメータ:
optimLev - 最適化レベル

setInitialize

public void setInitialize(String initialize)
初期化区分を設定します。

パラメータ:
initialize - 初期化区分

setForeModel

public void setForeModel(String foreModel)
予測モデルを設定します。

パラメータ:
foreModel - 予測モデル

setAlphaFact

public void setAlphaFact(String alphaFact)
アルファ係数使用による基本値の平滑化を設定します。

パラメータ:
alphaFact - アルファ係数使用による基本値の平滑化

setBetaFact

public void setBetaFact(String betaFact)
ベータ係数による傾向値平準化を設定します。

パラメータ:
betaFact - ベータ係数による傾向値平準化

setGammaFact

public void setGammaFact(String gammaFact)
ガンマ係数使用の平滑化のための季節指数を設定します。

パラメータ:
gammaFact - ガンマ係数使用の平滑化のための季節指数

setDeltaFact

public void setDeltaFact(String deltaFact)
デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。

パラメータ:
deltaFact - デルタ係数使用による MAD (絶対平均偏差) 平準化

setTracklimit

public void setTracklimit(String tracklimit)
警告限界を設定します。

パラメータ:
tracklimit - 警告限界

setForeDate

public void setForeDate(String foreDate)
最終需要予測日を設定します。

パラメータ:
foreDate - 最終需要予測日

setHistVals

public void setHistVals(String histVals)
履歴値の数を設定します。

パラメータ:
histVals - 履歴値の数

setInitPds

public void setInitPds(String initPds)
初期化で使用する履歴値の数を設定します。

パラメータ:
initPds - 初期化で使用する履歴値の数

setSeasonPds

public void setSeasonPds(String seasonPds)
季節周期ごとの期間数を設定します。

パラメータ:
seasonPds - 季節周期ごとの期間数

setExpostPds

public void setExpostPds(String expostPds)
事後的需要予測に含む履歴値の数を設定します。

パラメータ:
expostPds - 事後的需要予測に含む履歴値の数

setForePds

public void setForePds(String forePds)
需要予測期間を設定します。

パラメータ:
forePds - 需要予測期間

setFixedPds

public void setFixedPds(String fixedPds)
固定期間を設定します。

パラメータ:
fixedPds - 固定期間

setBasicValue

public void setBasicValue(String basicValue)
基準値を設定します。

パラメータ:
basicValue - 基準値

setBasicValue1

public void setBasicValue1(String basicValue1)
第二指図の基準値を設定します。

パラメータ:
basicValue1 - 第二指図の基準値

setBasicValue2

public void setBasicValue2(String basicValue2)
第二指図の基準値を設定します。

パラメータ:
basicValue2 - 第二指図の基準値

setBasicValuePp

public void setBasicValuePp(String basicValuePp)
前期間の基準値を設定します。

パラメータ:
basicValuePp - 前期間の基準値

setBasicValuePp1

public void setBasicValuePp1(String basicValuePp1)
前期間における第二指図の基準値を設定します。

パラメータ:
basicValuePp1 - 前期間における第二指図の基準値

setBasicValuePp2

public void setBasicValuePp2(String basicValuePp2)
前期間における第二指図の基準値を設定します。

パラメータ:
basicValuePp2 - 前期間における第二指図の基準値

setTrendValue

public void setTrendValue(String trendValue)
傾向値を設定します。

パラメータ:
trendValue - 傾向値

setTrendValuePp

public void setTrendValuePp(String trendValuePp)
前期間の傾向値を設定します。

パラメータ:
trendValuePp - 前期間の傾向値

setMeanAbsolDev

public void setMeanAbsolDev(String meanAbsolDev)
絶対平均偏差 (MAD)を設定します。

パラメータ:
meanAbsolDev - 絶対平均偏差 (MAD)

setMeanAbsolDevPp

public void setMeanAbsolDevPp(String meanAbsolDevPp)
前期間の平均絶対偏差を設定します。

パラメータ:
meanAbsolDevPp - 前期間の平均絶対偏差

setErrorTotal

public void setErrorTotal(String errorTotal)
エラー合計を設定します。

パラメータ:
errorTotal - エラー合計

setErrorTotalPp

public void setErrorTotalPp(String errorTotalPp)
前期間のエラー合計を設定します。

パラメータ:
errorTotalPp - 前期間のエラー合計

setWtgGroup

public void setWtgGroup(String wtgGroup)
加重グループを設定します。

パラメータ:
wtgGroup - 加重グループ

setCoeffTheil

public void setCoeffTheil(String coeffTheil)
タイル係数を設定します。

パラメータ:
coeffTheil - タイル係数

setExceptList

public void setExceptList(String exceptList)
例外メッセージバーを設定します。

パラメータ:
exceptList - 例外メッセージバー

setForecFlowCont

public void setForecFlowCont(String forecFlowCont)
予測フロー管理を設定します。

パラメータ:
forecFlowCont - 予測フロー管理

setPeriodInd

public void setPeriodInd(String periodInd)
期間区分を設定します。

パラメータ:
periodInd - 期間区分

setFyVariant

public void setFyVariant(String fyVariant)
会計年度バリアントを設定します。

パラメータ:
fyVariant - 会計年度バリアント

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastParametersList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ForecastParametersList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList
すべての実装インタフェース:
Serializable
public class ForecastParametersList
extends ForecastParameters
implements Serializable

需要予測パラメータ情報クラス
機能は以下の通り

  • 需要予測パラメータ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastParametersList()
需要予測パラメータ情報を作成します。
ForecastParametersList(int index)
需要予測パラメータ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters から継承したメソッド
getAlphaFact, getBasicValue, getBasicValue1, getBasicValue2, getBasicValuePp, getBasicValuePp1, getBasicValuePp2, getBetaFact, getCoeffTheil, getDeltaFact, getErrorTotal, getErrorTotalPp, getExceptList, getExpostPds, getFixedPds, getForecFlowCont, getForeDate, getForeModel, getForePds, getForeProf, getFunction, getFyVariant, getGammaFact, getHistVals, getInitialize, getInitPds, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMeanAbsolDev, getMeanAbsolDevPp, getModelSi, getModelSp, getOptimLev, getParamOpt, getPeriodInd, getPlant, getSeasonPds, getTracklimit, getTrendValue, getTrendValuePp, getWtgGroup, setAlphaFact, setBasicValue, setBasicValue1, setBasicValue2, setBasicValuePp, setBasicValuePp1, setBasicValuePp2, setBetaFact, setCoeffTheil, setDeltaFact, setErrorTotal, setErrorTotalPp, setExceptList, setExpostPds, setFixedPds, setForecFlowCont, setForeDate, setForeModel, setForePds, setForeProf, setFunction, setFyVariant, setGammaFact, setHistVals, setInitialize, setInitPds, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMeanAbsolDev, setMeanAbsolDevPp, setModelSi, setModelSp, setOptimLev, setParamOpt, setPeriodInd, setPlant, setSeasonPds, setTracklimit, setTrendValue, setTrendValuePp, setWtgGroup, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastParametersList

public ForecastParametersList()
需要予測パラメータ情報を作成します。

ForecastParametersList

public ForecastParametersList(int index)
需要予測パラメータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtHeaderList
public class GoodsMvtHeader
extends Object
implements Serializable

入出庫伝票ヘッダデータ情報クラス
機能は以下の通り

  • 入出庫伝票ヘッダデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeader()
入出庫伝票ヘッダデータ情報を作成します。
メソッドの概要
String | getBarCode() バーコードエントリを取得します。
String | getBillOfLading() 入庫時に登録した B/L 番号を取得します。
String | getBillOfLadingLong() 入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。
String | getDocDate() 伝票の伝票日付を取得します。
String | getDocYear() 入出庫伝票年度を取得します。
String | getEntryDate() 会計伝票登録日を取得します。
String | getEntryTime() 登録時刻を取得します。
String | getExpimpNo() 貿易データ番号: MM/SD 伝票を取得します。
String | getExtWms() 外部倉庫管理の転記の制御を取得します。
String | getGrGiSlipNo() 入出庫票番号を取得します。
String | getHeaderTxt() 伝票ヘッダテキストを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getPrUname() ユーザ名を取得します。
String | getPstngDate() 伝票の転記日付を取得します。
String | getRefDocNo() 参照伝票番号を取得します。
String | getRefDocNoLong() 参照伝票番号 (依存性についてはテキスト長参照)を取得します。
String | getTrEvType() トランザクション/イベントタイプを取得します。
String | getUsername() ユーザ名を取得します。
String | getVerGrGiSlip() 入出庫票の印刷バ－ジョンを取得します。
String | getVerGrGiSlipx() 関連ユーザデータ項目の更新情報を取得します。
void | setBarCode(String barCode) バーコードエントリを設定します。
void | setBillOfLading(String billOfLading) 入庫時に登録した B/L 番号を設定します。
void | setBillOfLadingLong(String billOfLadingLong) 入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。
void | setDocDate(String docDate) 伝票の伝票日付を設定します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setEntryDate(String entryDate) 会計伝票登録日を設定します。
void | setEntryTime(String entryTime) 登録時刻を設定します。
void | setExpimpNo(String expimpNo) 貿易データ番号: MM/SD 伝票を設定します。
void | setExtWms(String extWms) 外部倉庫管理の転記の制御を設定します。
void | setGrGiSlipNo(String grGiSlipNo) 入出庫票番号を設定します。
void | setHeaderTxt(String headerTxt) 伝票ヘッダテキストを設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
void | setPrUname(String prUname) ユーザ名を設定します。
void | setPstngDate(String pstngDate) 伝票の転記日付を設定します。
void | setRefDocNo(String refDocNo) 参照伝票番号を設定します。
void | setRefDocNoLong(String refDocNoLong) 参照伝票番号 (依存性についてはテキスト長参照)を設定します。
void | setTrEvType(String trEvType) トランザクション/イベントタイプを設定します。
void | setUsername(String username) ユーザ名を設定します。
void | setVerGrGiSlip(String verGrGiSlip) 入出庫票の印刷バ－ジョンを設定します。
void | setVerGrGiSlipx(String verGrGiSlipx) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeader

public GoodsMvtHeader()
入出庫伝票ヘッダデータ情報を作成します。

メソッドの詳細

getDocDate

public String getDocDate()
伝票の伝票日付を取得します。

戻り値:
docDate 伝票の伝票日付

getHeaderTxt

public String getHeaderTxt()
伝票ヘッダテキストを取得します。

戻り値:
headerTxt 伝票ヘッダテキスト

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します。

戻り値:
pstngDate 伝票の転記日付

getRefDocNo

public String getRefDocNo()
参照伝票番号を取得します。

戻り値:
refDocNo 参照伝票番号

getRefDocNoLong

public String getRefDocNoLong()
参照伝票番号 (依存性についてはテキスト長参照)を取得します。

戻り値:
refDocNoLong 参照伝票番号 (依存性についてはテキスト長参照)

getVerGrGiSlip

public String getVerGrGiSlip()
入出庫票の印刷バ－ジョンを取得します。

戻り値:
verGrGiSlip 入出庫票の印刷バ－ジョン

getBillOfLading

public String getBillOfLading()
入庫時に登録した B/L 番号を取得します。

戻り値:
billOfLading 入庫時に登録した B/L 番号

getGrGiSlipNo

public String getGrGiSlipNo()
入出庫票番号を取得します。

戻り値:
grGiSlipNo 入出庫票番号

getPrUname

public String getPrUname()
ユーザ名を取得します。

戻り値:
prUname ユーザ名

getVerGrGiSlipx

public String getVerGrGiSlipx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
verGrGiSlipx 関連ユーザデータ項目の更新情報

getExtWms

public String getExtWms()
外部倉庫管理の転記の制御を取得します。

戻り値:
extWms 外部倉庫管理の転記の制御

getBillOfLadingLong

public String getBillOfLadingLong()
入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。

戻り値:
billOfLadingLong 入庫の船荷証券番号 (依存: テキスト (長) 参照)

getBarCode

public String getBarCode()
バーコードエントリを取得します。

戻り値:
barCode バーコードエントリ

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

getTrEvType

public String getTrEvType()
トランザクション/イベントタイプを取得します。

戻り値:
trEvType トランザクション/イベントタイプ

getEntryDate

public String getEntryDate()
会計伝票登録日を取得します。

戻り値:
entryDate 会計伝票登録日

getEntryTime

public String getEntryTime()
登録時刻を取得します。

戻り値:
entryTime 登録時刻

getUsername

public String getUsername()
ユーザ名を取得します。

戻り値:
username ユーザ名

getExpimpNo

public String getExpimpNo()
貿易データ番号: MM/SD 伝票を取得します。

戻り値:
expimpNo 貿易データ番号: MM/SD 伝票

setDocDate

public void setDocDate(String docDate)
伝票の伝票日付を設定します。

パラメータ:
docDate - 伝票の伝票日付

setHeaderTxt

public void setHeaderTxt(String headerTxt)
伝票ヘッダテキストを設定します。

パラメータ:
headerTxt - 伝票ヘッダテキスト

setPstngDate

public void setPstngDate(String pstngDate)
伝票の転記日付を設定します。

パラメータ:
pstngDate - 伝票の転記日付

setRefDocNo

public void setRefDocNo(String refDocNo)
参照伝票番号を設定します。

パラメータ:
refDocNo - 参照伝票番号

setRefDocNoLong

public void setRefDocNoLong(String refDocNoLong)
参照伝票番号 (依存性についてはテキスト長参照)を設定します。

パラメータ:
refDocNoLong - 参照伝票番号 (依存性についてはテキスト長参照)

setVerGrGiSlip

public void setVerGrGiSlip(String verGrGiSlip)
入出庫票の印刷バ－ジョンを設定します。

パラメータ:
verGrGiSlip - 入出庫票の印刷バ－ジョン

setBillOfLading

public void setBillOfLading(String billOfLading)
入庫時に登録した B/L 番号を設定します。

パラメータ:
billOfLading - 入庫時に登録した B/L 番号

setGrGiSlipNo

public void setGrGiSlipNo(String grGiSlipNo)
入出庫票番号を設定します。

パラメータ:
grGiSlipNo - 入出庫票番号

setPrUname

public void setPrUname(String prUname)
ユーザ名を設定します。

パラメータ:
prUname - ユーザ名

setVerGrGiSlipx

public void setVerGrGiSlipx(String verGrGiSlipx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
verGrGiSlipx - 関連ユーザデータ項目の更新情報

setExtWms

public void setExtWms(String extWms)
外部倉庫管理の転記の制御を設定します。

パラメータ:
extWms - 外部倉庫管理の転記の制御

setBillOfLadingLong

public void setBillOfLadingLong(String billOfLadingLong)
入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。

パラメータ:
billOfLadingLong - 入庫の船荷証券番号 (依存: テキスト (長) 参照)

setBarCode

public void setBarCode(String barCode)
バーコードエントリを設定します。

パラメータ:
barCode - バーコードエントリ

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

setTrEvType

public void setTrEvType(String trEvType)
トランザクション/イベントタイプを設定します。

パラメータ:
trEvType - トランザクション/イベントタイプ

setEntryDate

public void setEntryDate(String entryDate)
会計伝票登録日を設定します。

パラメータ:
entryDate - 会計伝票登録日

setEntryTime

public void setEntryTime(String entryTime)
登録時刻を設定します。

パラメータ:
entryTime - 登録時刻

setUsername

public void setUsername(String username)
ユーザ名を設定します。

パラメータ:
username - ユーザ名

setExpimpNo

public void setExpimpNo(String expimpNo)
貿易データ番号: MM/SD 伝票を設定します。

パラメータ:
expimpNo - 貿易データ番号: MM/SD 伝票

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeaderList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtHeaderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList
すべての実装インタフェース:
Serializable
public class GoodsMvtHeaderList
extends GoodsMvtHeader
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeaderList()
入出庫伝票明細情報を作成します。
GoodsMvtHeaderList(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
void | setIndex(int index) レコード番号を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader から継承したメソッド
getBarCode, getBillOfLading, getBillOfLadingLong, getDocDate, getDocYear, getEntryDate, getEntryTime, getExpimpNo, getExtWms, getGrGiSlipNo, getHeaderTxt, getMatDoc, getPrUname, getPstngDate, getRefDocNo, getRefDocNoLong, getTrEvType, getUsername, getVerGrGiSlip, getVerGrGiSlipx, setBarCode, setBillOfLading, setBillOfLadingLong, setDocDate, setDocYear, setEntryDate, setEntryTime, setExpimpNo, setExtWms, setGrGiSlipNo, setHeaderTxt, setMatDoc, setPrUname, setPstngDate, setRefDocNo, setRefDocNoLong, setTrEvType, setUsername, setVerGrGiSlip, setVerGrGiSlipx, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeaderList

public GoodsMvtHeaderList()
入出庫伝票明細情報を作成します。

GoodsMvtHeaderList

public GoodsMvtHeaderList(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtItems (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems
すべての実装インタフェース:
Serializable
public class GoodsMvtItems
extends Object
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtItems()
入出庫伝票明細情報を作成します。
GoodsMvtItems(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAmountLc() マニュアル入力による転記金額 (国内通貨)を取得します。
String | getAmountSv() 外部入力による販売金額 (国内通貨)を取得します。
String | getAssetNo() 資産番号を取得します。
String | getBatch() ロット番号を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCompShip() 出荷指示順守を取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostObj() 原価対象を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getCustomer() 得意先コードを取得します。
String | getDocYear() 入出庫伝票年度を取得します。
String | getEntryQnt() 入力単位での数量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 単位の ISO コードを取得します。
String | getExpirydate() 有効期間期限日を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrRcpt() 受領者を取得します。
int | getIndex() レコード番号を取得します｡
String | getItemText() 明細テキストを取得します。
String | getLineDepth() 伝票での明細行階層レベルを取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMoveBatch() 入庫/出庫ロットを取得します。
String | getMoveMat() 入庫/出庫品目を取得します。
String | getMoveMatExternal() 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getMoveMatGuid() 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getMoveMatVersion() 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getMovePlant() 入庫/出庫プラントを取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveStloc() 入庫/出庫保管場所を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getMoveValType() 転送ロットの評価タイプを取得します。
String | getMvtInd() 移動区分を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderItno() 指図明細番号を取得します。
String | getOrderprUn() 購買発注価格単位 (購買管理)を取得します。
String | getOrderprUnIso() 単位の ISO コードを取得します。
String | getParentId() 1 レベル上位の行 IDを取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買発注番号を取得します。
String | getPoPrQnt() 数量 (購買発注価格単位)を取得します。
String | getProdDate() ロット製造日付を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細番号を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getReservNo() 入出庫予定/従属所要量の番号を取得します。
String | getResItem() 入出庫予定/従属所要量の明細番号を取得します。
String | getResType() レコードタイプを取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSchedLine() 受注納入日程を取得します。
String | getShipping() 出荷指示を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getSpecStock() 特殊在庫区分を取得します。
String | getStckType() 在庫タイプを取得します。
String | getStgeLoc() 保管場所を取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getSupplVend() 供給仕入先を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getValSalesOrd() 評価受注在庫の受注番号を取得します。
String | getValSOrdItem() 評価受注在庫の受注明細を取得します。
String | getValType() 評価タイプを取得します。
String | getValWbsElem() WBS 要素を取得します。
String | getVendor() 仕入先勘定コードを取得します。
String | getWbsElem() WBS 要素を取得します。
String | getWithdrawn() 入出庫予定に対する出庫完了を取得します。
String | getXAutoCre() 自動登録済み明細を取得します。
void | setActivity(String activity) 作業番号を設定します。
void | setActtype(String acttype) 活動タイプを設定します。
void | setAmountLc(String amountLc) マニュアル入力による転記金額 (国内通貨)を設定します。
void | setAmountSv(String amountSv) 外部入力による販売金額 (国内通貨)を設定します。
void | setAssetNo(String assetNo) 資産番号を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCmmtItem(String cmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String cmmtItemLong) 資金予算コードを設定します。
void | setCoBusproc(String coBusproc) 業務プロセスを設定します。
void | setCompShip(String compShip) 出荷指示順守を設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCostObj(String costObj) 原価対象を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO 通貨コードを設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setEntryQnt(String entryQnt) 入力単位での数量を設定します。
void | setEntryUom(String entryUom) 入力単位を設定します。
void | setEntryUomIso(String entryUomIso) 単位の ISO コードを設定します。
void | setExpirydate(String expirydate) 有効期間期限日を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setFund(String fund) 会計区分を設定します。
void | setFundsCtr(String fundsCtr) 予算センタを設定します。
void | setGrantNbr(String grantNbr) 補助金を設定します。
void | setGrRcpt(String grRcpt) 受領者を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItemText(String itemText) 明細テキストを設定します。
void | setLineDepth(String lineDepth) 伝票での明細行階層レベルを設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
void | setMatdocItm(String matdocItm) 入出庫伝票の明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMoveBatch(String moveBatch) 入庫/出庫ロットを設定します。
void | setMoveMat(String moveMat) 入庫/出庫品目を設定します。
void | setMoveMatExternal(String moveMatExternal) 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setMoveMatGuid(String moveMatGuid) 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setMoveMatVersion(String moveMatVersion) 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setMovePlant(String movePlant) 入庫/出庫プラントを設定します。
void | setMoveReas(String moveReas) 移動理由を設定します。
void | setMoveStloc(String moveStloc) 入庫/出庫保管場所を設定します。
void | setMoveType(String moveType) 移動タイプ (在庫管理)を設定します。
void | setMoveValType(String moveValType) 転送ロットの評価タイプを設定します。
void | setMvtInd(String mvtInd) 移動区分を設定します。
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します。
void | setNoMoreGr(String noMoreGr) 納入完了 区分を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderItno(String orderItno) 指図明細番号を設定します。
void | setOrderprUn(String orderprUn) 購買発注価格単位 (購買管理)を設定します。
void | setOrderprUnIso(String orderprUnIso) 単位の ISO コードを設定します。
void | setParentId(String parentId) 1 レベル上位の行 IDを設定します。
void | setPartAcct(String partAcct) 取引先勘定コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPoItem(String poItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String poNumber) 購買発注番号を設定します。
void | setPoPrQnt(String poPrQnt) 数量 (購買発注価格単位)を設定します。
void | setProdDate(String prodDate) ロット製造日付を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setRefDate(String refDate) 決済の参照日付を設定します。
void | setRefDoc(String refDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String refDocIt) 参照伝票の明細番号を設定します。
void | setRefDocYr(String refDocYr) 参照伝票の会計年度を設定します。
void | setReservNo(String reservNo) 入出庫予定/従属所要量の番号を設定します。
void | setResItem(String resItem) 入出庫予定/従属所要量の明細番号を設定します。
void | setResType(String resType) レコードタイプを設定します。
void | setRlEstKey(String rlEstKey) 不動産管理対象の内部キーを設定します。
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します。
void | setSchedLine(String schedLine) 受注納入日程を設定します。
void | setShipping(String shipping) 出荷指示を設定します。
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します。
void | setSpecStock(String specStock) 特殊在庫区分を設定します。
void | setStckType(String stckType) 在庫タイプを設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setSubNumber(String subNumber) 資産補助番号を設定します。
void | setSupplVend(String supplVend) 供給仕入先を設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
void | setValSalesOrd(String valSalesOrd) 評価受注在庫の受注番号を設定します。
void | setValSOrdItem(String valSOrdItem) 評価受注在庫の受注明細を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setValWbsElem(String valWbsElem) WBS 要素を設定します。
void | setVendor(String vendor) 仕入先勘定コードを設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWithdrawn(String withdrawn) 入出庫予定に対する出庫完了を設定します。
void | setXAutoCre(String xAutoCre) 自動登録済み明細を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtItems

public GoodsMvtItems()
入出庫伝票明細情報を作成します。

GoodsMvtItems

public GoodsMvtItems(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
activity 作業番号

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
acttype 活動タイプ

getAmountLc

public String getAmountLc()
マニュアル入力による転記金額 (国内通貨)を取得します。

戻り値:
amountLc マニュアル入力による転記金額 (国内通貨)

getAmountSv

public String getAmountSv()
外部入力による販売金額 (国内通貨)を取得します。

戻り値:
amountSv 外部入力による販売金額 (国内通貨)

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
assetNo 資産番号

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
cmmtItem 資金予算コード

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
cmmtItemLong 資金予算コード

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
coBusproc 業務プロセス

getCompShip

public String getCompShip()
出荷指示順守を取得します。

戻り値:
compShip 出荷指示順守

getCostObj

public String getCostObj()
原価対象を取得します。

戻り値:
costObj 原価対象

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
currencyIso ISO 通貨コード

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

getEntryQnt

public String getEntryQnt()
入力単位での数量を取得します。

戻り値:
entryQnt 入力単位での数量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
entryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
単位の ISO コードを取得します。

戻り値:
entryUomIso 単位の ISO コード

getExpirydate

public String getExpirydate()
有効期間期限日を取得します。

戻り値:
expirydate 有効期間期限日

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getFund

public String getFund()
会計区分を取得します。

戻り値:
fund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
fundsCtr 予算センタ

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
grRcpt 受領者

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
grantNbr 補助金

getItemText

public String getItemText()
明細テキストを取得します。

戻り値:
itemText 明細テキスト

getLineDepth

public String getLineDepth()
伝票での明細行階層レベルを取得します。

戻り値:
lineDepth 伝票での明細行階層レベル

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
matdocItm 入出庫伝票の明細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getMoveBatch

public String getMoveBatch()
入庫/出庫ロットを取得します。

戻り値:
moveBatch 入庫/出庫ロット

getMoveMat

public String getMoveMat()
入庫/出庫品目を取得します。

戻り値:
moveMat 入庫/出庫品目

getMoveMatExternal

public String getMoveMatExternal()
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
moveMatExternal 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

getMoveMatGuid

public String getMoveMatGuid()
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
moveMatGuid 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

getMoveMatVersion

public String getMoveMatVersion()
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
moveMatVersion 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

getMovePlant

public String getMovePlant()
入庫/出庫プラントを取得します。

戻り値:
movePlant 入庫/出庫プラント

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
moveReas 移動理由

getMoveStloc

public String getMoveStloc()
入庫/出庫保管場所を取得します。

戻り値:
moveStloc 入庫/出庫保管場所

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
moveType 移動タイプ (在庫管理)

getMoveValType

public String getMoveValType()
転送ロットの評価タイプを取得します。

戻り値:
moveValType 転送ロットの評価タイプ

getMvtInd

public String getMvtInd()
移動区分を取得します。

戻り値:
mvtInd 移動区分

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
network 勘定割当のネットワーク番号

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
noMoreGr 納入完了 区分

getOrderItno

public String getOrderItno()
指図明細番号を取得します。

戻り値:
orderItno 指図明細番号

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getOrderprUn

public String getOrderprUn()
購買発注価格単位 (購買管理)を取得します。

戻り値:
orderprUn 購買発注価格単位 (購買管理)

getOrderprUnIso

public String getOrderprUnIso()
単位の ISO コードを取得します。

戻り値:
orderprUnIso 単位の ISO コード

getParentId

public String getParentId()
1 レベル上位の行 IDを取得します。

戻り値:
parentId 1 レベル上位の行 ID

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
partAcct 取引先勘定コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
poItem 購買伝票の明細番号

getPoNumber

public String getPoNumber()
購買発注番号を取得します。

戻り値:
poNumber 購買発注番号

getPoPrQnt

public String getPoPrQnt()
数量 (購買発注価格単位)を取得します。

戻り値:
poPrQnt 数量 (購買発注価格単位)

getProdDate

public String getProdDate()
ロット製造日付を取得します。

戻り値:
prodDate ロット製造日付

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
refDate 決済の参照日付

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
refDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細番号を取得します。

戻り値:
refDocIt 参照伝票の明細番号

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
refDocYr 参照伝票の会計年度

getResItem

public String getResItem()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
resItem 入出庫予定/従属所要量の明細番号

getResType

public String getResType()
レコードタイプを取得します。

戻り値:
resType レコードタイプ

getReservNo

public String getReservNo()
入出庫予定/従属所要量の番号を取得します。

戻り値:
reservNo 入出庫予定/従属所要量の番号

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
rlEstKey 不動産管理対象の内部キー

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
sOrdItem 受注明細番号

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
salesOrd 受注伝票番号

getSchedLine

public String getSchedLine()
受注納入日程を取得します。

戻り値:
schedLine 受注納入日程

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
shipping 出荷指示

getSpecStock

public String getSpecStock()
特殊在庫区分を取得します。

戻り値:
specStock 特殊在庫区分

getStckType

public String getStckType()
在庫タイプを取得します。

戻り値:
stckType 在庫タイプ

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
subNumber 資産補助番号

getSupplVend

public String getSupplVend()
供給仕入先を取得します。

戻り値:
supplVend 供給仕入先

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getValSOrdItem

public String getValSOrdItem()
評価受注在庫の受注明細を取得します。

戻り値:
valSOrdItem 評価受注在庫の受注明細

getValSalesOrd

public String getValSalesOrd()
評価受注在庫の受注番号を取得します。

戻り値:
valSalesOrd 評価受注在庫の受注番号

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getValWbsElem

public String getValWbsElem()
WBS 要素を取得します。

戻り値:
valWbsElem WBS 要素

getVendor

public String getVendor()
仕入先勘定コードを取得します。

戻り値:
vendor 仕入先勘定コード

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getWithdrawn

public String getWithdrawn()
入出庫予定に対する出庫完了を取得します。

戻り値:
withdrawn 入出庫予定に対する出庫完了

getXAutoCre

public String getXAutoCre()
自動登録済み明細を取得します。

戻り値:
xAutoCre 自動登録済み明細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setActivity

public void setActivity(String activity)
作業番号を設定します。

パラメータ:
activity - 作業番号

setActtype

public void setActtype(String acttype)
活動タイプを設定します。

パラメータ:
acttype - 活動タイプ

setAmountLc

public void setAmountLc(String amountLc)
マニュアル入力による転記金額 (国内通貨)を設定します。

パラメータ:
amountLc - マニュアル入力による転記金額 (国内通貨)

setAmountSv

public void setAmountSv(String amountSv)
外部入力による販売金額 (国内通貨)を設定します。

パラメータ:
amountSv - 外部入力による販売金額 (国内通貨)

setAssetNo

public void setAssetNo(String assetNo)
資産番号を設定します。

パラメータ:
assetNo - 資産番号

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

setCmmtItem

public void setCmmtItem(String cmmtItem)
資金予算コードを設定します。

パラメータ:
cmmtItem - 資金予算コード

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
資金予算コードを設定します。

パラメータ:
cmmtItemLong - 資金予算コード

setCoBusproc

public void setCoBusproc(String coBusproc)
業務プロセスを設定します。

パラメータ:
coBusproc - 業務プロセス

setCompShip

public void setCompShip(String compShip)
出荷指示順守を設定します。

パラメータ:
compShip - 出荷指示順守

setCostObj

public void setCostObj(String costObj)
原価対象を設定します。

パラメータ:
costObj - 原価対象

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO 通貨コードを設定します。

パラメータ:
currencyIso - ISO 通貨コード

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

setEntryQnt

public void setEntryQnt(String entryQnt)
入力単位での数量を設定します。

パラメータ:
entryQnt - 入力単位での数量

setEntryUom

public void setEntryUom(String entryUom)
入力単位を設定します。

パラメータ:
entryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String entryUomIso)
単位の ISO コードを設定します。

パラメータ:
entryUomIso - 単位の ISO コード

setExpirydate

public void setExpirydate(String expirydate)
有効期間期限日を設定します。

パラメータ:
expirydate - 有効期間期限日

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setFund

public void setFund(String fund)
会計区分を設定します。

パラメータ:
fund - 会計区分

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します。

パラメータ:
fundsCtr - 予算センタ

setGrRcpt

public void setGrRcpt(String grRcpt)
受領者を設定します。

パラメータ:
grRcpt - 受領者

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します。

パラメータ:
grantNbr - 補助金

setItemText

public void setItemText(String itemText)
明細テキストを設定します。

パラメータ:
itemText - 明細テキスト

setLineDepth

public void setLineDepth(String lineDepth)
伝票での明細行階層レベルを設定します。

パラメータ:
lineDepth - 伝票での明細行階層レベル

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setMatdocItm

public void setMatdocItm(String matdocItm)
入出庫伝票の明細を設定します。

パラメータ:
matdocItm - 入出庫伝票の明細

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setMoveBatch

public void setMoveBatch(String moveBatch)
入庫/出庫ロットを設定します。

パラメータ:
moveBatch - 入庫/出庫ロット

setMoveMat

public void setMoveMat(String moveMat)
入庫/出庫品目を設定します。

パラメータ:
moveMat - 入庫/出庫品目

setMoveMatExternal

public void setMoveMatExternal(String moveMatExternal)
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
moveMatExternal - 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

setMoveMatGuid

public void setMoveMatGuid(String moveMatGuid)
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
moveMatGuid - 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

setMoveMatVersion

public void setMoveMatVersion(String moveMatVersion)
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
moveMatVersion - 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

setMovePlant

public void setMovePlant(String movePlant)
入庫/出庫プラントを設定します。

パラメータ:
movePlant - 入庫/出庫プラント

setMoveReas

public void setMoveReas(String moveReas)
移動理由を設定します。

パラメータ:
moveReas - 移動理由

setMoveStloc

public void setMoveStloc(String moveStloc)
入庫/出庫保管場所を設定します。

パラメータ:
moveStloc - 入庫/出庫保管場所

setMoveType

public void setMoveType(String moveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
moveType - 移動タイプ (在庫管理)

setMoveValType

public void setMoveValType(String moveValType)
転送ロットの評価タイプを設定します。

パラメータ:
moveValType - 転送ロットの評価タイプ

setMvtInd

public void setMvtInd(String mvtInd)
移動区分を設定します。

パラメータ:
mvtInd - 移動区分

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します。

パラメータ:
network - 勘定割当のネットワーク番号

setNoMoreGr

public void setNoMoreGr(String noMoreGr)
納入完了 区分を設定します。

パラメータ:
noMoreGr - 納入完了 区分

setOrderItno

public void setOrderItno(String orderItno)
指図明細番号を設定します。

パラメータ:
orderItno - 指図明細番号

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setOrderprUn

public void setOrderprUn(String orderprUn)
購買発注価格単位 (購買管理)を設定します。

パラメータ:
orderprUn - 購買発注価格単位 (購買管理)

setOrderprUnIso

public void setOrderprUnIso(String orderprUnIso)
単位の ISO コードを設定します。

パラメータ:
orderprUnIso - 単位の ISO コード

setParentId

public void setParentId(String parentId)
1 レベル上位の行 IDを設定します。

パラメータ:
parentId - 1 レベル上位の行 ID

setPartAcct

public void setPartAcct(String partAcct)
取引先勘定コードを設定します。

パラメータ:
partAcct - 取引先勘定コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setPoItem

public void setPoItem(String poItem)
購買伝票の明細番号を設定します。

パラメータ:
poItem - 購買伝票の明細番号

setPoNumber

public void setPoNumber(String poNumber)
購買発注番号を設定します。

パラメータ:
poNumber - 購買発注番号

setPoPrQnt

public void setPoPrQnt(String poPrQnt)
数量 (購買発注価格単位)を設定します。

パラメータ:
poPrQnt - 数量 (購買発注価格単位)

setProdDate

public void setProdDate(String prodDate)
ロット製造日付を設定します。

パラメータ:
prodDate - ロット製造日付

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setRefDate

public void setRefDate(String refDate)
決済の参照日付を設定します。

パラメータ:
refDate - 決済の参照日付

setRefDoc

public void setRefDoc(String refDoc)
参照伝票の伝票番号を設定します。

パラメータ:
refDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照伝票の明細番号を設定します。

パラメータ:
refDocIt - 参照伝票の明細番号

setRefDocYr

public void setRefDocYr(String refDocYr)
参照伝票の会計年度を設定します。

パラメータ:
refDocYr - 参照伝票の会計年度

setResItem

public void setResItem(String resItem)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
resItem - 入出庫予定/従属所要量の明細番号

setResType

public void setResType(String resType)
レコードタイプを設定します。

パラメータ:
resType - レコードタイプ

setReservNo

public void setReservNo(String reservNo)
入出庫予定/従属所要量の番号を設定します。

パラメータ:
reservNo - 入出庫予定/従属所要量の番号

setRlEstKey

public void setRlEstKey(String rlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
rlEstKey - 不動産管理対象の内部キー

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します。

パラメータ:
sOrdItem - 受注明細番号

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します。

パラメータ:
salesOrd - 受注伝票番号

setSchedLine

public void setSchedLine(String schedLine)
受注納入日程を設定します。

パラメータ:
schedLine - 受注納入日程

setShipping

public void setShipping(String shipping)
出荷指示を設定します。

パラメータ:
shipping - 出荷指示

setSpecStock

public void setSpecStock(String specStock)
特殊在庫区分を設定します。

パラメータ:
specStock - 特殊在庫区分

setStckType

public void setStckType(String stckType)
在庫タイプを設定します。

パラメータ:
stckType - 在庫タイプ

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setSubNumber

public void setSubNumber(String subNumber)
資産補助番号を設定します。

パラメータ:
subNumber - 資産補助番号

setSupplVend

public void setSupplVend(String supplVend)
供給仕入先を設定します。

パラメータ:
supplVend - 供給仕入先

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setValSOrdItem

public void setValSOrdItem(String valSOrdItem)
評価受注在庫の受注明細を設定します。

パラメータ:
valSOrdItem - 評価受注在庫の受注明細

setValSalesOrd

public void setValSalesOrd(String valSalesOrd)
評価受注在庫の受注番号を設定します。

パラメータ:
valSalesOrd - 評価受注在庫の受注番号

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setValWbsElem

public void setValWbsElem(String valWbsElem)
WBS 要素を設定します。

パラメータ:
valWbsElem - WBS 要素

setVendor

public void setVendor(String vendor)
仕入先勘定コードを設定します。

パラメータ:
vendor - 仕入先勘定コード

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setWithdrawn

public void setWithdrawn(String withdrawn)
入出庫予定に対する出庫完了を設定します。

パラメータ:
withdrawn - 入出庫予定に対する出庫完了

setXAutoCre

public void setXAutoCre(String xAutoCre)
自動登録済み明細を設定します。

パラメータ:
xAutoCre - 自動登録済み明細

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialDescription (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス MaterialDescription

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription
すべての実装インタフェース:
Serializable
public class MaterialDescription
extends Object
implements Serializable

品目テキスト情報クラス
機能は以下の通り

  • 品目テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialDescription()
品目テキスト情報を作成します。
MaterialDescription(int index)
品目テキスト情報を作成します。
メソッドの概要
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMatlDesc() 品目テキストを取得します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMatlDesc(String matlDesc) 品目テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialDescription

public MaterialDescription()
品目テキスト情報を作成します。

MaterialDescription

public MaterialDescription(int index)
品目テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getMatlDesc

public String getMatlDesc()
品目テキストを取得します。

戻り値:
matlDesc 品目テキスト

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setMatlDesc

public void setMatlDesc(String matlDesc)
品目テキストを設定します。

パラメータ:
matlDesc - 品目テキスト

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialEvg (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス MaterialEvg

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg
すべての実装インタフェース:
Serializable
public class MaterialEvg
extends Object
implements Serializable

品目コード(長)情報クラス
機能は以下の通り

  • 品目コード(長)を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialEvg()
品目コード(長)を作成します。
メソッドの概要
String | getMaterialExt() 外部品目コードを取得します。
String | getMaterialGuid() 品目コード(外部 GUID)を取得します。
String | getMaterialVers() 品目バージョン番号を取得します。
void | setMaterialExt(String materialExt) 外部品目コードを設定します。
void | setMaterialGuid(String materialGuid) 品目コード(外部 GUID)を設定します。
void | setMaterialVers(String materialVers) 品目バージョン番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialEvg

public MaterialEvg()
品目コード(長)を作成します。

メソッドの詳細

getMaterialExt

public String getMaterialExt()
外部品目コードを取得します。

戻り値:
materialExt 外部品目コード

getMaterialVers

public String getMaterialVers()
品目バージョン番号を取得します。

戻り値:
materialVers 品目バージョン番号

getMaterialGuid

public String getMaterialGuid()
品目コード(外部 GUID)を取得します。

戻り値:
materialGuid 品目コード(外部 GUID)

setMaterialExt

public void setMaterialExt(String materialExt)
外部品目コードを設定します。

パラメータ:
materialExt - 外部品目コード

setMaterialVers

public void setMaterialVers(String materialVers)
品目バージョン番号を設定します。

パラメータ:
materialVers - 品目バージョン番号

setMaterialGuid

public void setMaterialGuid(String materialGuid)
品目コード(外部 GUID)を設定します。

パラメータ:
materialGuid - 品目コード(外部 GUID)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.common.model (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス
ClientData
ClientDataList
ForecastParameters
ForecastParametersList
GoodsMvtHeader
GoodsMvtHeaderList
GoodsMvtItems
MaterialDescription
MaterialEvg
ParamGoodsMvtHeader
ParamGoodsMvtHeaderList
ParamGoodsMvtItems
ParamMaterialEvg
PlanningData
PlanningDataList
PlantData
PlantDataList
SalesData
SalesDataList
StorageLocationData
StorageLocationDataList
StorageTypeData
StorageTypeDataList
TaxClassifications
UnitSofmeasure
ValuationData
ValuationDataList
WarehouseNumberData
WarehouseNumberDataList


jp.co.intra_mart.foundation.sap.module.purchase.common.model (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model

クラスの概要
ClientData | 品目データ (クライアントレベル)情報クラス 機能は以下の通り 品目データ (クライアントレベル)情報を保持します。
ClientDataList | 品目データ (クライアントレベル)情報クラス 機能は以下の通り 品目データ (クライアントレベル)情報をテーブル型で保持します。
ForecastParameters | 予測パラメータ情報クラス 機能は以下の通り 予測パラメータ情報を保持します。
ForecastParametersList | 需要予測パラメータ情報クラス 機能は以下の通り 需要予測パラメータ情報をテーブル型で保持します。
GoodsMvtHeader | 入出庫伝票ヘッダデータ情報クラス 機能は以下の通り 入出庫伝票ヘッダデータ情報を保持します。
GoodsMvtHeaderList | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
GoodsMvtItems | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
MaterialDescription | 品目テキスト情報クラス 機能は以下の通り 品目テキスト情報を保持します。
MaterialEvg | 品目コード(長)情報クラス 機能は以下の通り 品目コード(長)を保持します。
ParamGoodsMvtHeader | 入出庫伝票ヘッダデータ設定クラス 機能は以下の通り 入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtHeaderList | リターン構造、入出庫伝票ヘッダパラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票ヘッダのパラメータを設定します。
ParamGoodsMvtItems | リターン構造、入出庫伝票明細パラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票明細のパラメータを設定します。
ParamMaterialEvg | 品目コード(長)パラメータ設定クラス 機能は以下の通り 品目コード(長)のパラメータを設定します。
PlanningData | 品目マスタ/製品グループの変更伝票構造情報クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningDataList | 品目マスタ/製品グループの変更伝票構造情報クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData | 品目データ (プラントレベル)情報クラス 機能は以下の通り 品目データ (プラントレベル)情報を保持します。
PlantDataList | 品目データ (プラントレベル)情報クラス 機能は以下の通り 品目データ (プラントレベル)情報をテーブル型で保持します。
SalesData | 販売データ情報クラス 機能は以下の通り 販売データ情報を保持します。
SalesDataList | 販売データ情報クラス 機能は以下の通り 販売データ情報をテーブル型で保持します。
StorageLocationData | 品目データ (保管場所レベル)情報クラス 機能は以下の通り 品目データ (保管場所レベル)情報を保持します。
StorageLocationDataList | 品目データ (保管場所レベル)情報クラス 機能は以下の通り 品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageTypeData | 保管域タイプデータ情報クラス 機能は以下の通り 保管域タイプデータ情報を保持します。
StorageTypeDataList | 保管域タイプデータ情報クラス 機能は以下の通り 保管域タイプデータ情報をテーブル型で保持します。
TaxClassifications | 制御デ－タ情報クラス 機能は以下の通り 制御デ－タ情報を保持します。
UnitSofmeasure | 数量単位情報クラス 機能は以下の通り 数量単位情報を保持します。
ValuationData | 評価データ情報クラス 機能は以下の通り 評価データ情報を保持します。
ValuationDataList | 評価データ情報クラス 機能は以下の通り 評価データ情報をテーブル型で保持します。
WarehouseNumberData | 倉庫番号データ情報クラス 機能は以下の通り 倉庫番号データ情報を保持します。
WarehouseNumberDataList | 倉庫番号データ情報クラス 機能は以下の通り 倉庫番号データ情報をテーブル型で保持します。


jp.co.intra_mart.foundation.sap.module.purchase.common.model クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientDataList
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。
ForecastParametersList
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。
MaterialDescription
品目テキスト情報クラス
機能は以下の通り
品目テキスト情報を保持します。
PlanningDataList
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantDataList
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。
SalesDataList
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。
StorageLocationDataList
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageTypeDataList
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。
TaxClassifications
制御デ－タ情報クラス
機能は以下の通り
制御デ－タ情報を保持します。
UnitSofmeasure
数量単位情報クラス
機能は以下の通り
数量単位情報を保持します。
ValuationDataList
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。
WarehouseNumberDataList
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.common.model により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientData
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ForecastParameters
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
GoodsMvtHeader
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。
MaterialEvg
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。
PlanningData
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
SalesData
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
StorageLocationData
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageTypeData
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
ValuationData
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
WarehouseNumberData
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
GoodsMvtHeader
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
MaterialEvg
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientData
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ForecastParameters
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
MaterialEvg
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。
PlanningData
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
SalesData
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
StorageLocationData
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageTypeData
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
ValuationData
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
WarehouseNumberData
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamGoodsMvtHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeader
extends Object
implements Serializable

入出庫伝票ヘッダデータ設定クラス
機能は以下の通り

  • 入出庫伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtHeader goodsMvtHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入出庫伝票ヘッダデータに値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeader - GoodsMvtHeadrer
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtHeaderList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtHeaderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeaderList
extends Object
implements Serializable

リターン構造、入出庫伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtItems (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtItems
extends Object
implements Serializable

リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtItemsList) table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtItemsList) リターン構造、入出庫伝票明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtItemsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票明細に値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtItemsList)
                           throws SAPGeneralSystemException
table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialEvg (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamMaterialEvg

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg
すべての実装インタフェース:
Serializable
public final class ParamMaterialEvg
extends Object
implements Serializable

品目コード(長)パラメータ設定クラス
機能は以下の通り

  • 品目コード(長)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, MaterialEvg materialEvg)
品目コード(長)をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  MaterialEvg materialEvg)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
品目コード(長)をセットします。

パラメータ:
bapiController - BapiController
materialEvg - MaterialEvg
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlanningData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlanningData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PlanningDataList
public class PlanningData
extends Object
implements Serializable

品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlanningData()
品目マスタ/製品グループの変更伝票構造情報を作成します。
メソッドの概要
String | getConvfactor() 計画品目用変換係数を取得します。
String | getFunction() BAPI 機能を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getPlant() プラントを取得します。
String | getPlngMatl() 計画品目を取得します。
String | getPlngMatlExternal() 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。
String | getPlngMatlGuid() 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。
String | getPlngMatlVersion() 項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlngPlant() 計画プラントを取得します。
void | setConvfactor(String convfactor) 計画品目用変換係数を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlngMatl(String plngMatl) 計画品目を設定します。
void | setPlngMatlExternal(String plngMatlExternal) 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。
void | setPlngMatlGuid(String plngMatlGuid) 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。
void | setPlngMatlVersion(String plngMatlVersion) 項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlngPlant(String plngPlant) 計画プラントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlanningData

public PlanningData()
品目マスタ/製品グループの変更伝票構造情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getPlngMatl

public String getPlngMatl()
計画品目を取得します。

戻り値:
plngMatl 計画品目

getPlngPlant

public String getPlngPlant()
計画プラントを取得します。

戻り値:
plngPlant 計画プラント

getConvfactor

public String getConvfactor()
計画品目用変換係数を取得します。

戻り値:
convfactor 計画品目用変換係数

getPlngMatlExternal

public String getPlngMatlExternal()
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
plngMatlExternal 項目 PLNG_MATL の品目コード (長) (今後の リリースで開発)

getPlngMatlGuid

public String getPlngMatlGuid()
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
plngMatlGuid 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

getPlngMatlVersion

public String getPlngMatlVersion()
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
plngMatlVersion 項目 PLNG_MATL のバージョン番号 (今後の リリースで開発)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setPlngMatl

public void setPlngMatl(String plngMatl)
計画品目を設定します。

パラメータ:
plngMatl - 計画品目

setPlngPlant

public void setPlngPlant(String plngPlant)
計画プラントを設定します。

パラメータ:
plngPlant - 計画プラント

setConvfactor

public void setConvfactor(String convfactor)
計画品目用変換係数を設定します。

パラメータ:
convfactor - 計画品目用変換係数

setPlngMatlExternal

public void setPlngMatlExternal(String plngMatlExternal)
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
plngMatlExternal - 項目 PLNG_MATL の品目コード (長) (今後の リリースで開発)

setPlngMatlGuid

public void setPlngMatlGuid(String plngMatlGuid)
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
plngMatlGuid - 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

setPlngMatlVersion

public void setPlngMatlVersion(String plngMatlVersion)
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
plngMatlVersion - 項目 PLNG_MATL のバージョン番号 (今後の リリースで開発)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlanningDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlanningDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList
すべての実装インタフェース:
Serializable
public class PlanningDataList
extends PlanningData
implements Serializable

品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlanningDataList()
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
void | setIndex(int index) レコード番号を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData から継承したメソッド
getConvfactor, getFunction, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getPlant, getPlngMatl, getPlngMatlExternal, getPlngMatlGuid, getPlngMatlVersion, getPlngPlant, setConvfactor, setFunction, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setPlant, setPlngMatl, setPlngMatlExternal, setPlngMatlGuid, setPlngMatlVersion, setPlngPlant, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlanningDataList

public PlanningDataList()
品目マスタ/製品グループの変更伝票構造情報を作成します。

PlanningDataList

public PlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlantData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PlantDataList
public class PlantData
extends Object
implements Serializable

品目データ (プラントレベル)情報クラス
機能は以下の通り

  • 品目データ (プラントレベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantData()
品目データ (プラントレベル)情報を作成します。
メソッドの概要
String | getAbcId() ABC 区分を取得します。
String | getAccountView() 会計ビューを取得します。
String | getAltBomId() 代替 BOM 選択の方法を取得します。
String | getAlternativeBom() 代替 BOMを取得します。
String | getAssyScrap() 組立不良率を取得します。
String | getAutoPOrd() 区分: "購買発注自動生成"を取得します。
String | getAutoReset() 予測モデル自動リセットを取得します。
String | getAvailcheck() 利用可能在庫確認の確認グループを取得します。
String | getAvailCheckAllProjSegments() プロジェクト間品目区分を取得します。
String | getBackflush() 区分: バックフラッシュを取得します。
String | getBaseQty() 基本数量を取得します。
String | getBaseQtyPlan() 出荷の能力計画のための基本数量を取得します。
String | getBatchentry() 製造/プロセス指図でのロット入力設定を取得します。
String | getBatchMgmt() ロット管理所要量区分を取得します。
String | getBomUsage() BOM 用途を取得します。
String | getBulkMat() 区分: バルク品目を取得します。
String | getBwdCons() 消費期間: 後方を取得します。
String | getCasNo() CAS 番号： 薬事品目 - 貿易を取得します。
String | getCcFixed() 循環棚卸区分固定を取得します。
String | getCcPhInv() 循環棚卸の実地棚卸区分を取得します。
String | getCertType() 証明書タイプを取得します。
String | getCommCode() 貿易: 統計品目コード/輸入コード番号を取得します。
String | getCommCoUn() 物品コード (貿易) の数量単位を取得します。
String | getCommCoUnIso() ISO コードによる物品コード (貿易管理) の数量単位を取得します。
String | getCompScrap() 構成品目不良率を取得します。
String | getConsummode() 消費モードを取得します。
String | getCoProduct() 区分: 連産品としても使用可能な品目を取得します。
String | getCorrFact() 区分: 修正係数を需要予測値計算に使用を取得します。
String | getCostView() 原価計算ビューを取得します。
String | getCountryori() 品目の原産国を取得します。
String | getCountryoriIso() ISO コードでの品目原産国を取得します。
String | getCovprofile() 在庫日数プロファイルを取得します。
String | getCritPart() 区分: 重要品目を取得します。
String | getCtrlCode() 貿易: 消費税の管理コードを取得します。
String | getCtrlKey() 調達における品質管理の管理キーを取得します。
String | getCycleTime() タクトタイムを取得します。
String | getDeclStatFlag() 区分: 仕入先申告ありを取得します。
String | getDelFlag() プラントレベルでの品目削除フラグを取得します。
String | getDeployHoriz() 供給分配期間の日数を取得します。
String | getDepReqId() 個別所要量と包括所要量に対する従属所要量区分を取得します。
String | getDetermGrp() 在庫決定グループを取得します。
String | getDiscontinu() 打切区分を取得します。
String | getDistrProf() サイトの商品の物流プロファイルを取得します。
String | getDocReqd() 文書必須フラグを取得します。
String | getDToRefM() 消費データ参照の有効終了日を取得します。
String | getEffODay() 有効終了日を取得します。
String | getEuListNo() CAP: CAP 製品一覧番号を取得します。
String | getEuMatGrp() EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。
String | getExCertDt() 非該当証明書発行日を取得します。
String | getExCertId() 法令管理: 認定書区分を取得します。
String | getExCertNoNew() 非該当証明書番号 - 法令管理を取得します。
String | getExpimpgrp() 輸出/輸入品目グループを取得します。
String | getFairShareRule() 均等配賦ルールを取得します。
String | getFixedLot() 固定ロットサイズを取得します。
String | getFixLotSize() 需要供給の一致に対する固定ロットサイズを取得します。
String | getFollowUp() フォローアップ品目を取得します。
String | getFollowUpExternal() 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。
String | getFollowUpGuid() 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。
String | getFollowUpVersion() 項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。
String | getForecastView() 需要予測ビューを取得します。
String | getFunction() BAPI 機能を取得します。
String | getFwdCons() 消費期間: 前方を取得します。
String | getFxdPrice() 固定価格連産品を取得します。
String | getFyVariant() 会計年度バリアントを取得します。
String | getGrpReqmts() 区分: 所要量グループ化を取得します。
String | getGrPrTime() 入庫処理日数を取得します。
String | getHandlgGrp() ワークロード計算のロジスティクス処理グループを取得します。
String | getIndPostToInspStock() 品質検査中在庫への転記を取得します。
String | getInhseprodt() 内製日数を取得します。
String | getInspInt() 次回再検査までの間隔を取得します。
String | getInspSetupFlag() 品目/プラントに QM 検査データ設定を取得します。
String | getInterop() 移動時間を取得します。
String | getIssStLoc() 出庫保管場所を取得します。
String | getIssueUnit() 出庫単位を取得します。
String | getIssueUnitIso() ISO コードでの出庫単位を取得します。
String | getJitRelvt() 区分: JIT 納入日程の関連明細を取得します。
String | getLoadinggrp() 積載グループを取得します。
String | getLotIncrement() 需要と供給を一致させるためのロットサイズ増分を取得します。
String | getLotSize() 原価計算ロットサイズを取得します。
String | getLotsizekey() ロットサイズ (品目計画)を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMatCfop() 品目 CFOP カテゴリを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMatfrgtgrp() 品目運賃グループを取得します。
String | getMatGrpTrans() 段取替えマトリクスに対する品目のグループを取得します。
String | getMaxlotsize() 最大ロットサイズを取得します。
String | getMaxLotSize() 需要と供給を一致させるための最大ロットサイズを取得します。
String | getMaxStock() 最大在庫レベルを取得します。
String | getMilitId() ID: 武器を取得します。
String | getMinlotsize() 最小ロットサイズを取得します。
String | getMinLotSize() 需要と供給を一致させるための最小ロットサイズを取得します。
String | getMinSafetyStk() 最小安全在庫を取得します。
String | getMixedMrp() 二重 MRP 区分を取得します。
String | getMrpAreaExists() 区分: MRP エリア登録済を取得します。
String | getMrpCtrler() MRP 管理者を取得します。
String | getMrpGroup() MRP グループを取得します。
String | getMrpprofile() 品目: MRP プロファイルを取得します。
String | getMrpRelevancyDepRequirements() 従属所要量と MRP の関連性を取得します。
String | getMrpType() MRP タイプを取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getMultRefM() 消費データ参照品目の乗数を取得します。
String | getNegStocks() プラントにおけるマイナス在庫許可を取得します。
String | getNoCosting() 原価計算なしを取得します。
String | getOrdCosts() 発注原価 (BAPI インタフェース)を取得します。
String | getOriginalBatchFlag() 元ロット管理区分を取得します。
String | getOriginalBatchRefMaterial() 元ロットの参照品目を取得します。
String | getOriginalBatchRefMaterialE() オリジナルロット参照品目を取得します。
String | getOriginalBatchRefMaterialG() オリジナルロット参照品目を取得します。
String | getOriginalBatchRefMaterialV() オリジナルロット参照品目を取得します。
String | getOverallprf() 指図変更管理の全体プロファイルを取得します。
String | getOverTol() 過剰納入許容範囲リミットを取得します。
String | getPeriodInd() 期間区分を取得します。
String | getPeriodProfileSafetyTime() 安全時間の期間プロファイルを取得します。
String | getPlanlistcnt() グループカウンタを取得します。
String | getPlanlistgrp() タスクリストグループのキーを取得します。
String | getPlanStrgp() 計画方針グループを取得します。
String | getPlant() プラントを取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPlngCycle() 計画サイクルを取得します。
String | getPlordCtrl() アクション管理: 計画手配処理を取得します。
String | getPlTiFnce() 計画タイムフェンスを取得します。
String | getPpcPlCal() PPC 計画カレンダを取得します。
String | getPrefStatFlag() 区分: 特恵関税 - 輸出/輸入を取得します。
String | getProcTime() 処理時間を取得します。
String | getProcType() 調達タイプを取得します。
String | getProdcomNo() 生産統計: 貿易における PRODCOM コードを取得します。
String | getProdConvType() 生産値の変換タイプを取得します。
String | getProdprof() 製造計画プロファイルを取得します。
String | getProductionScheduler() 製造計画担当を取得します。
String | getProdUnit() 製造単位を取得します。
String | getProdUnitIso() 製造単位 (ISO コード)を取得します。
String | getProdverscs() 原価計算を行う製造バージョンを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getPrtView() 生産資源/治工具 (PRT) ビューを取得します。
String | getPsConfMat() 選定可能品目を取得します。
String | getPsConfMatExternal() PS_CO 項目の(将来の開発用)品目コード(長)を取得します。
String | getPsConfMatGuid() PS_CONF_MAT 項目の外部 GUID (将来の開発用)を取得します。
String | getPsConfMatVersion() PS_CONF_MAT 項目のバージョン番号 (将来の開発用)を取得します。
String | getPurchView() 購買管理ビューを取得します。
String | getPurGroup() 購買グループを取得します。
String | getPurStatus() プラント特有品目ステータスを取得します。
String | getPushDistrib() 区分: プッシュ配賦を取得します。
String | getPvalidfrom() プラント品目ステータス有効期間開始日を取得します。
String | getQmAuthgrp() QM における活動の品目権限グループを取得します。
String | getQmRgmts() 仕入先の必須 QM システムを取得します。
String | getQualityView() 品質管理ビューを取得します。
String | getQuotausage() 供給量割当の使用を取得します。
String | getRefmatcons() 消費参照品目を取得します。
String | getRefmatconsExternal() 項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。
String | getRefmatconsGuid() 項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。
String | getRefmatconsVersion() 項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。
String | getRefpltcons() 消費参照プラントを取得します。
String | getRegionorig() 品目の原産地 (非特恵対象地区の原産)を取得します。
String | getReorderPt() 発注点を取得します。
String | getReplacePt() 取替部品を取得します。
String | getReplentime() 補充リードタイム合計 (稼動日数)を取得します。
String | getRepmanprof() 繰返生産プロファイルを取得します。
String | getRepManuf() 区分: 繰返生産許可を取得します。
String | getRotationDate() 原価計算ビューを取得します。
String | getRoundProf() 丸めプロファイルを取得します。
String | getRoundVal() 購買発注数量の丸め数量を取得します。
String | getSafetyStk() 安全在庫を取得します。
String | getSafetytime() 安全時間 (稼動日数)を取得します。
String | getSaftyTId() 安全時間区分（安全リードタイムあり/なし)を取得します。
String | getSalesView() 販売ビューを取得します。
String | getSernoProf() シリアル番号プロファイルを取得します。
String | getServLevel() サービスレベルを取得します。
String | getSetuptime() 段取時間と片付け時間を取得します。
String | getSetupTime() 出荷準備時間を取得します。
String | getShipProcTime() 出荷処理時間を取得します。
String | getSlocExprc() 外部調達の初期保管場所を取得します。
String | getSmKey() 日程計画余裕キーを取得します。
String | getSourcelist() 区分: 供給元一覧必須を取得します。
String | getSpecprocty() 原価計算の特殊調達タイプを取得します。
String | getSplitInd() 分割区分を取得します。
String | getSpproctype() 特殊調達タイプを取得します。
String | getStgePdUn() 最長保管期間の単位を取得します。
String | getStgePdUnIso() ISO コードでの最長保管期間単位を取得します。
String | getStgeperiod() 最長保管期間を取得します。
String | getStorageView() 保管ビューを取得します。
String | getStorCosts() 保管経費区分を取得します。
String | getSupplyArea() 品目マスタレコードで提案される供給場所を取得します。
String | getSupSource() 供給元を取得します。
String | getTaskListType() タスクリストタイプを取得します。
String | getUnderTol() 不足納入許容範囲リミットを取得します。
String | getUnitGroup() 数量単位グループを取得します。
String | getUnlimited() 区分: 無制限過剰納入可能を取得します。
String | getVarianceKey() 差異キーを取得します。
String | getVersionFlag() バージョン区分を取得します。
String | getWarehouseView() 倉庫管理ビューを取得します。
String | getWorkSchedView() 作業計画ビューを取得します。
void | setAbcId(String abcId) ABC 区分を設定します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setAltBomId(String altBomId) 代替 BOM 選択の方法を設定します。
void | setAlternativeBom(String alternativeBom) 代替 BOMを設定します。
void | setAssyScrap(String assyScrap) 組立不良率を設定します。
void | setAutoPOrd(String autoPOrd) 区分: "購買発注自動生成"を設定します。
void | setAutoReset(String autoReset) 予測モデル自動リセットを設定します。
void | setAvailcheck(String availcheck) 利用可能在庫確認の確認グループを設定します。
void | setAvailCheckAllProjSegments(String availCheckAllProjSegments) プロジェクト間品目区分を設定します。
void | setBackflush(String backflush) 区分: バックフラッシュを設定します。
void | setBaseQty(String baseQty) 基本数量を設定します。
void | setBaseQtyPlan(String baseQtyPlan) 出荷の能力計画のための基本数量を設定します。
void | setBatchentry(String batchentry) 製造/プロセス指図でのロット入力設定を設定します。
void | setBatchMgmt(String batchMgmt) ロット管理所要量区分を設定します。
void | setBomUsage(String bomUsage) BOM 用途を設定します。
void | setBulkMat(String bulkMat) 区分: バルク品目を設定します。
void | setBwdCons(String bwdCons) 消費期間: 後方を設定します。
void | setCasNo(String casNo) CAS 番号： 薬事品目 - 貿易を設定します。
void | setCcFixed(String ccFixed) 循環棚卸区分固定を設定します。
void | setCcPhInv(String ccPhInv) 循環棚卸の実地棚卸区分を設定します。
void | setCertType(String certType) 証明書タイプを設定します。
void | setCommCode(String commCode) 貿易: 統計品目コード/輸入コード番号を設定します。
void | setCommCoUn(String commCoUn) 物品コード (貿易) の数量単位を設定します。
void | setCommCoUnIso(String commCoUnIso) ISO コードによる物品コード (貿易管理) の数量単位を設定します。
void | setCompScrap(String compScrap) 構成品目不良率を設定します。
void | setConsummode(String consummode) 消費モードを設定します。
void | setCoProduct(String coProduct) 区分: 連産品としても使用可能な品目を設定します。
void | setCorrFact(String corrFact) 区分: 修正係数を需要予測値計算に使用を設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setCountryori(String countryori) 品目の原産国を設定します。
void | setCountryoriIso(String countryoriIso) ISO コードでの品目原産国を設定します。
void | setCovprofile(String covprofile) 在庫日数プロファイルを設定します。
void | setCritPart(String critPart) 区分: 重要品目を設定します。
void | setCtrlCode(String ctrlCode) 貿易: 消費税の管理コードを設定します。
void | setCtrlKey(String ctrlKey) 調達における品質管理の管理キーを設定します。
void | setCycleTime(String cycleTime) タクトタイムを設定します。
void | setDeclStatFlag(String declStatFlag) 区分: 仕入先申告ありを設定します。
void | setDelFlag(String delFlag) プラントレベルでの品目削除フラグを設定します。
void | setDeployHoriz(String deployHoriz) 供給分配期間の日数を設定します。
void | setDepReqId(String depReqId) 個別所要量と包括所要量に対する従属所要量区分を設定します。
void | setDetermGrp(String determGrp) 在庫決定グループを設定します。
void | setDiscontinu(String discontinu) 打切区分を設定します。
void | setDistrProf(String distrProf) サイトの商品の物流プロファイルを設定します。
void | setDocReqd(String docReqd) 文書必須フラグを設定します。
void | setDToRefM(String dToRefM) 消費データ参照の有効終了日を設定します。
void | setEffODay(String effODay) 有効終了日を設定します。
void | setEuListNo(String euListNo) CAP: CAP 製品一覧番号を設定します。
void | setEuMatGrp(String euMatGrp) EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。
void | setExCertDt(String exCertDt) 非該当証明書発行日を設定します。
void | setExCertId(String exCertId) 法令管理: 認定書区分を設定します。
void | setExCertNoNew(String exCertNoNew) 非該当証明書番号 - 法令管理を設定します。
void | setExpimpgrp(String expimpgrp) 輸出/輸入品目グループを設定します。
void | setFairShareRule(String fairShareRule) 均等配賦ルールを設定します。
void | setFixedLot(String fixedLot) 固定ロットサイズを設定します。
void | setFixLotSize(String fixLotSize) 需要供給の一致に対する固定ロットサイズを設定します。
void | setFollowUp(String followUp) フォローアップ品目を設定します。
void | setFollowUpExternal(String followUpExternal) 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。
void | setFollowUpGuid(String followUpGuid) 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。
void | setFollowUpVersion(String followUpVersion) 項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。
void | setForecastView(String forecastView) 需要予測ビューを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFwdCons(String fwdCons) 消費期間: 前方を設定します。
void | setFxdPrice(String fxdPrice) 固定価格連産品を設定します。
void | setFyVariant(String fyVariant) 会計年度バリアントを設定します。
void | setGrpReqmts(String grpReqmts) 区分: 所要量グループ化を設定します。
void | setGrPrTime(String grPrTime) 入庫処理日数を設定します。
void | setHandlgGrp(String handlgGrp) ワークロード計算のロジスティクス処理グループを設定します。
void | setIndPostToInspStock(String indPostToInspStock) 品質検査中在庫への転記を設定します。
void | setInhseprodt(String inhseprodt) 内製日数を設定します。
void | setInspInt(String inspInt) 次回再検査までの間隔を設定します。
void | setInspSetupFlag(String inspSetupFlag) 品目/プラントに QM 検査データ設定を設定します。
void | setInterop(String interop) 移動時間を設定します。
void | setIssStLoc(String issStLoc) 出庫保管場所を設定します。
void | setIssueUnit(String issueUnit) 出庫単位を設定します。
void | setIssueUnitIso(String issueUnitIso) ISO コードでの出庫単位を設定します。
void | setJitRelvt(String jitRelvt) 区分: JIT 納入日程の関連明細を設定します。
void | setLoadinggrp(String loadinggrp) 積載グループを設定します。
void | setLotIncrement(String lotIncrement) 需要と供給を一致させるためのロットサイズ増分を設定します。
void | setLotSize(String lotSize) 原価計算ロットサイズを設定します。
void | setLotsizekey(String lotsizekey) ロットサイズ (品目計画)を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMatCfop(String matCfop) 品目 CFOP カテゴリを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 品目運賃グループを設定します。
void | setMatGrpTrans(String matGrpTrans) 段取替えマトリクスに対する品目のグループを設定します。
void | setMaxlotsize(String maxlotsize) 最大ロットサイズを設定します。
void | setMaxLotSize(String maxLotSize) 需要と供給を一致させるための最大ロットサイズを設定します。
void | setMaxStock(String maxStock) 最大在庫レベルを設定します。
void | setMilitId(String militId) ID: 武器を設定します。
void | setMinlotsize(String minlotsize) 最小ロットサイズを設定します。
void | setMinLotSize(String minLotSize) 需要と供給を一致させるための最小ロットサイズを設定します。
void | setMinSafetyStk(String minSafetyStk) 最小安全在庫を設定します。
void | setMixedMrp(String mixedMrp) 二重 MRP 区分を設定します。
void | setMrpAreaExists(String mrpAreaExists) 区分: MRP エリア登録済を設定します。
void | setMrpCtrler(String mrpCtrler) MRP 管理者を設定します。
void | setMrpGroup(String mrpGroup) MRP グループを設定します。
void | setMrpprofile(String mrpprofile) 品目: MRP プロファイルを設定します。
void | setMrpRelevancyDepRequirements(String mrpRelevancyDepRequirements) 従属所要量と MRP の関連性を設定します。
void | setMrpType(String mrpType) MRP タイプを設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setMultRefM(String multRefM) 消費データ参照品目の乗数を設定します。
void | setNegStocks(String negStocks) プラントにおけるマイナス在庫許可を設定します。
void | setNoCosting(String noCosting) 原価計算なしを設定します。
void | setOrdCosts(String ordCosts) 発注原価 (BAPI インタフェース)を設定します。
void | setOriginalBatchFlag(String originalBatchFlag) 元ロット管理区分を設定します。
void | setOriginalBatchRefMaterial(String originalBatchRefMaterial) 元ロットの参照品目を設定します。
void | setOriginalBatchRefMaterialE(String originalBatchRefMaterialE) オリジナルロット参照品目を設定します。
void | setOriginalBatchRefMaterialG(String originalBatchRefMaterialG) オリジナルロット参照品目を設定します。
void | setOriginalBatchRefMaterialV(String originalBatchRefMaterialV) オリジナルロット参照品目を設定します。
void | setOverallprf(String overallprf) 指図変更管理の全体プロファイルを設定します。
void | setOverTol(String overTol) 過剰納入許容範囲リミットを設定します。
void | setPeriodInd(String periodInd) 期間区分を設定します。
void | setPeriodProfileSafetyTime(String periodProfileSafetyTime) 安全時間の期間プロファイルを設定します。
void | setPlanlistcnt(String planlistcnt) グループカウンタを設定します。
void | setPlanlistgrp(String planlistgrp) タスクリストグループのキーを設定します。
void | setPlanStrgp(String planStrgp) 計画方針グループを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlndDelry(String plndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPlngCycle(String plngCycle) 計画サイクルを設定します。
void | setPlordCtrl(String plordCtrl) アクション管理: 計画手配処理を設定します。
void | setPlTiFnce(String plTiFnce) 計画タイムフェンスを設定します。
void | setPpcPlCal(String ppcPlCal) PPC 計画カレンダを設定します。
void | setPrefStatFlag(String prefStatFlag) 区分: 特恵関税 - 輸出/輸入を設定します。
void | setProcTime(String procTime) 処理時間を設定します。
void | setProcType(String procType) 調達タイプを設定します。
void | setProdcomNo(String prodcomNo) 生産統計: 貿易における PRODCOM コードを設定します。
void | setProdConvType(String prodConvType) 生産値の変換タイプを設定します。
void | setProdprof(String prodprof) 製造計画プロファイルを設定します。
void | setProductionScheduler(String productionScheduler) 製造計画担当を設定します。
void | setProdUnit(String prodUnit) 製造単位を設定します。
void | setProdUnitIso(String prodUnitIso) 製造単位 (ISO コード)を設定します。
void | setProdverscs(String prodverscs) 原価計算を行う製造バージョンを設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setPrtView(String prtView) 生産資源/治工具 (PRT) ビューを設定します。
void | setPsConfMat(String psConfMat) 選定可能品目を設定します。
void | setPsConfMatExternal(String psConfMatExternal) PS_CO 項目の(将来の開発用)品目コード(長)を設定します。
void | setPsConfMatGuid(String psConfMatGuid) PS_CONF_MAT 項目の外部 GUID (将来の開発用)を設定します。
void | setPsConfMatVersion(String psConfMatVersion) PS_CONF_MAT 項目のバージョン番号 (将来の開発用)を設定します。
void | setPurchView(String purchView) 購買管理ビューを設定します。
void | setPurGroup(String purGroup) 購買グループを設定します。
void | setPurStatus(String purStatus) プラント特有品目ステータスを設定します。
void | setPushDistrib(String pushDistrib) 区分: プッシュ配賦を設定します。
void | setPvalidfrom(String pvalidfrom) プラント品目ステータス有効期間開始日を設定します。
void | setQmAuthgrp(String qmAuthgrp) QM における活動の品目権限グループを設定します。
void | setQmRgmts(String qmRgmts) 仕入先の必須 QM システムを設定します。
void | setQualityView(String qualityView) 品質管理ビューを設定します。
void | setQuotausage(String quotausage) 供給量割当の使用を設定します。
void | setRefmatcons(String refmatcons) 消費参照品目を設定します。
void | setRefmatconsExternal(String refmatconsExternal) 項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。
void | setRefmatconsGuid(String refmatconsGuid) 項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。
void | setRefmatconsVersion(String refmatconsVersion) 項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。
void | setRefpltcons(String refpltcons) 消費参照プラントを設定します。
void | setRegionorig(String regionorig) 品目の原産地 (非特恵対象地区の原産)を設定します。
void | setReorderPt(String reorderPt) 発注点を設定します。
void | setReplacePt(String replacePt) 取替部品を設定します。
void | setReplentime(String replentime) 補充リードタイム合計 (稼動日数)を設定します。
void | setRepmanprof(String repmanprof) 繰返生産プロファイルを設定します。
void | setRepManuf(String repManuf) 区分: 繰返生産許可を設定します。
void | setRotationDate(String rotationDate) 原価計算ビューを設定します。
void | setRoundProf(String roundProf) 丸めプロファイルを設定します。
void | setRoundVal(String roundVal) 購買発注数量の丸め数量を設定します。
void | setSafetyStk(String safetyStk) 安全在庫を設定します。
void | setSafetytime(String safetytime) 安全時間 (稼動日数)を設定します。
void | setSaftyTId(String saftyTId) 安全時間区分（安全リードタイムあり/なし)を設定します。
void | setSalesView(String salesView) 販売ビューを設定します。
void | setSernoProf(String sernoProf) シリアル番号プロファイルを設定します。
void | setServLevel(String servLevel) サービスレベルを設定します。
void | setSetuptime(String setuptime) 段取時間と片付け時間を設定します。
void | setSetupTime(String setupTime) 出荷準備時間を設定します。
void | setShipProcTime(String shipProcTime) 出荷処理時間を設定します。
void | setSlocExprc(String slocExprc) 外部調達の初期保管場所を設定します。
void | setSmKey(String smKey) 日程計画余裕キーを設定します。
void | setSourcelist(String sourcelist) 区分: 供給元一覧必須を設定します。
void | setSpecprocty(String specprocty) 原価計算の特殊調達タイプを設定します。
void | setSplitInd(String splitInd) 分割区分を設定します。
void | setSpproctype(String spproctype) 特殊調達タイプを設定します。
void | setStgePdUn(String stgePdUn) 最長保管期間の単位を設定します。
void | setStgePdUnIso(String stgePdUnIso) ISO コードでの最長保管期間単位を設定します。
void | setStgeperiod(String stgeperiod) 最長保管期間を設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
void | setStorCosts(String storCosts) 保管経費区分を設定します。
void | setSupplyArea(String supplyArea) 品目マスタレコードで提案される供給場所を設定します。
void | setSupSource(String supSource) 供給元を設定します。
void | setTaskListType(String taskListType) タスクリストタイプを設定します。
void | setUnderTol(String underTol) 不足納入許容範囲リミットを設定します。
void | setUnitGroup(String unitGroup) 数量単位グループを設定します。
void | setUnlimited(String unlimited) 区分: 無制限過剰納入可能を設定します。
void | setVarianceKey(String varianceKey) 差異キーを設定します。
void | setVersionFlag(String versionFlag) バージョン区分を設定します。
void | setWarehouseView(String warehouseView) 倉庫管理ビューを設定します。
void | setWorkSchedView(String workSchedView) 作業計画ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantData

public PlantData()
品目データ (プラントレベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
プラントレベルでの品目削除フラグを取得します。

戻り値:
delFlag プラントレベルでの品目削除フラグ

getAbcId

public String getAbcId()
ABC 区分を取得します。

戻り値:
abcId ABC 区分

getCritPart

public String getCritPart()
区分: 重要品目を取得します。

戻り値:
critPart 区分: 重要品目

getPurGroup

public String getPurGroup()
購買グループを取得します。

戻り値:
purGroup 購買グループ

getIssueUnit

public String getIssueUnit()
出庫単位を取得します。

戻り値:
issueUnit 出庫単位

getIssueUnitIso

public String getIssueUnitIso()
ISO コードでの出庫単位を取得します。

戻り値:
issueUnitIso ISO コードでの出庫単位

getMrpprofile

public String getMrpprofile()
品目: MRP プロファイルを取得します。

戻り値:
mrpprofile 品目: MRP プロファイル

getMrpType

public String getMrpType()
MRP タイプを取得します。

戻り値:
mrpType MRP タイプ

getMrpCtrler

public String getMrpCtrler()
MRP 管理者を取得します。

戻り値:
mrpCtrler MRP 管理者

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
plndDelry 予定納入時間 (単位: 日)

getGrPrTime

public String getGrPrTime()
入庫処理日数を取得します。

戻り値:
grPrTime 入庫処理日数

getPeriodInd

public String getPeriodInd()
期間区分を取得します。

戻り値:
periodInd 期間区分

getAssyScrap

public String getAssyScrap()
組立不良率を取得します。

戻り値:
assyScrap 組立不良率

getLotsizekey

public String getLotsizekey()
ロットサイズ (品目計画)を取得します。

戻り値:
lotsizekey ロットサイズ (品目計画)

getProcType

public String getProcType()
調達タイプを取得します。

戻り値:
procType 調達タイプ

getSpproctype

public String getSpproctype()
特殊調達タイプを取得します。

戻り値:
spproctype 特殊調達タイプ

getReorderPt

public String getReorderPt()
発注点を取得します。

戻り値:
reorderPt 発注点

getSafetyStk

public String getSafetyStk()
安全在庫を取得します。

戻り値:
safetyStk 安全在庫

getMinlotsize

public String getMinlotsize()
最小ロットサイズを取得します。

戻り値:
minlotsize 最小ロットサイズ

getMaxlotsize

public String getMaxlotsize()
最大ロットサイズを取得します。

戻り値:
maxlotsize 最大ロットサイズ

getFixedLot

public String getFixedLot()
固定ロットサイズを取得します。

戻り値:
fixedLot 固定ロットサイズ

getRoundVal

public String getRoundVal()
購買発注数量の丸め数量を取得します。

戻り値:
roundVal 購買発注数量の丸め数量

getMaxStock

public String getMaxStock()
最大在庫レベルを取得します。

戻り値:
maxStock 最大在庫レベル

getOrdCosts

public String getOrdCosts()
発注原価 (BAPI インタフェース)を取得します。

戻り値:
ordCosts 発注原価 (BAPI インタフェース)

getDepReqId

public String getDepReqId()
個別所要量と包括所要量に対する従属所要量区分を取得します。

戻り値:
depReqId 個別所要量と包括所要量に対する従属所要量区分

getStorCosts

public String getStorCosts()
保管経費区分を取得します。

戻り値:
storCosts 保管経費区分

getAltBomId

public String getAltBomId()
代替 BOM 選択の方法を取得します。

戻り値:
altBomId 代替 BOM 選択の方法

getDiscontinu

public String getDiscontinu()
打切区分を取得します。

戻り値:
discontinu 打切区分

getEffODay

public String getEffODay()
有効終了日を取得します。

戻り値:
effODay 有効終了日

getFollowUp

public String getFollowUp()
フォローアップ品目を取得します。

戻り値:
followUp フォローアップ品目

getGrpReqmts

public String getGrpReqmts()
区分: 所要量グループ化を取得します。

戻り値:
grpReqmts 区分: 所要量グループ化

getMixedMrp

public String getMixedMrp()
二重 MRP 区分を取得します。

戻り値:
mixedMrp 二重 MRP 区分

getSmKey

public String getSmKey()
日程計画余裕キーを取得します。

戻り値:
smKey 日程計画余裕キー

getBackflush

public String getBackflush()
区分: バックフラッシュを取得します。

戻り値:
backflush 区分: バックフラッシュ

getProductionScheduler

public String getProductionScheduler()
製造計画担当を取得します。

戻り値:
productionScheduler 製造計画担当

getProcTime

public String getProcTime()
処理時間を取得します。

戻り値:
procTime 処理時間

getSetuptime

public String getSetuptime()
段取時間と片付け時間を取得します。

戻り値:
setuptime 段取時間と片付け時間

getInterop

public String getInterop()
移動時間を取得します。

戻り値:
interop 移動時間

getBaseQty

public String getBaseQty()
基本数量を取得します。

戻り値:
baseQty 基本数量

getInhseprodt

public String getInhseprodt()
内製日数を取得します。

戻り値:
inhseprodt 内製日数

getStgeperiod

public String getStgeperiod()
最長保管期間を取得します。

戻り値:
stgeperiod 最長保管期間

getStgePdUn

public String getStgePdUn()
最長保管期間の単位を取得します。

戻り値:
stgePdUn 最長保管期間の単位

getStgePdUnIso

public String getStgePdUnIso()
ISO コードでの最長保管期間単位を取得します。

戻り値:
stgePdUnIso ISO コードでの最長保管期間単位

getOverTol

public String getOverTol()
過剰納入許容範囲リミットを取得します。

戻り値:
overTol 過剰納入許容範囲リミット

getUnlimited

public String getUnlimited()
区分: 無制限過剰納入可能を取得します。

戻り値:
unlimited 区分: 無制限過剰納入可能

getUnderTol

public String getUnderTol()
不足納入許容範囲リミットを取得します。

戻り値:
underTol 不足納入許容範囲リミット

getReplentime

public String getReplentime()
補充リードタイム合計 (稼動日数)を取得します。

戻り値:
replentime 補充リードタイム合計 (稼動日数)

getReplacePt

public String getReplacePt()
取替部品を取得します。

戻り値:
replacePt 取替部品

getIndPostToInspStock

public String getIndPostToInspStock()
品質検査中在庫への転記を取得します。

戻り値:
indPostToInspStock 品質検査中在庫への転記

getCtrlKey

public String getCtrlKey()
調達における品質管理の管理キーを取得します。

戻り値:
ctrlKey 調達における品質管理の管理キー

getDocReqd

public String getDocReqd()
文書必須フラグを取得します。

戻り値:
docReqd 文書必須フラグ

getLoadinggrp

public String getLoadinggrp()
積載グループを取得します。

戻り値:
loadinggrp 積載グループ

getBatchMgmt

public String getBatchMgmt()
ロット管理所要量区分を取得します。

戻り値:
batchMgmt ロット管理所要量区分

getQuotausage

public String getQuotausage()
供給量割当の使用を取得します。

戻り値:
quotausage 供給量割当の使用

getServLevel

public String getServLevel()
サービスレベルを取得します。

戻り値:
servLevel サービスレベル

getSplitInd

public String getSplitInd()
分割区分を取得します。

戻り値:
splitInd 分割区分

getAvailcheck

public String getAvailcheck()
利用可能在庫確認の確認グループを取得します。

戻り値:
availcheck 利用可能在庫確認の確認グループ

getFyVariant

public String getFyVariant()
会計年度バリアントを取得します。

戻り値:
fyVariant 会計年度バリアント

getCorrFact

public String getCorrFact()
区分: 修正係数を需要予測値計算に使用を取得します。

戻り値:
corrFact 区分: 修正係数を需要予測値計算に使用

getSetupTime

public String getSetupTime()
出荷準備時間を取得します。

戻り値:
setupTime 出荷準備時間

getBaseQtyPlan

public String getBaseQtyPlan()
出荷の能力計画のための基本数量を取得します。

戻り値:
baseQtyPlan 出荷の能力計画のための基本数量

getShipProcTime

public String getShipProcTime()
出荷処理時間を取得します。

戻り値:
shipProcTime 出荷処理時間

getSupSource

public String getSupSource()
供給元を取得します。

戻り値:
supSource 供給元

getAutoPOrd

public String getAutoPOrd()
区分: "購買発注自動生成"を取得します。

戻り値:
autoPOrd 区分: "購買発注自動生成"

getSourcelist

public String getSourcelist()
区分: 供給元一覧必須を取得します。

戻り値:
sourcelist 区分: 供給元一覧必須

getCommCode

public String getCommCode()
貿易: 統計品目コード/輸入コード番号を取得します。

戻り値:
commCode 貿易: 統計品目コード/輸入コード番号

getCountryori

public String getCountryori()
品目の原産国を取得します。

戻り値:
countryori 品目の原産国

getCountryoriIso

public String getCountryoriIso()
ISO コードでの品目原産国を取得します。

戻り値:
countryoriIso ISO コードでの品目原産国

getRegionorig

public String getRegionorig()
品目の原産地 (非特恵対象地区の原産)を取得します。

戻り値:
regionorig 品目の原産地 (非特恵対象地区の原産)

getCommCoUn

public String getCommCoUn()
物品コード (貿易) の数量単位を取得します。

戻り値:
commCoUn 物品コード (貿易) の数量単位

getCommCoUnIso

public String getCommCoUnIso()
ISO コードによる物品コード (貿易管理) の数量単位を取得します。

戻り値:
commCoUnIso ISO コードによる物品コード (貿易管理) の数量単位

getExpimpgrp

public String getExpimpgrp()
輸出/輸入品目グループを取得します。

戻り値:
expimpgrp 輸出/輸入品目グループ

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getPpcPlCal

public String getPpcPlCal()
PPC 計画カレンダを取得します。

戻り値:
ppcPlCal PPC 計画カレンダ

getRepManuf

public String getRepManuf()
区分: 繰返生産許可を取得します。

戻り値:
repManuf 区分: 繰返生産許可

getPlTiFnce

public String getPlTiFnce()
計画タイムフェンスを取得します。

戻り値:
plTiFnce 計画タイムフェンス

getConsummode

public String getConsummode()
消費モードを取得します。

戻り値:
consummode 消費モード

getBwdCons

public String getBwdCons()
消費期間: 後方を取得します。

戻り値:
bwdCons 消費期間: 後方

getFwdCons

public String getFwdCons()
消費期間: 前方を取得します。

戻り値:
fwdCons 消費期間: 前方

getVersionFlag

public String getVersionFlag()
バージョン区分を取得します。

戻り値:
versionFlag バージョン区分

getAlternativeBom

public String getAlternativeBom()
代替 BOMを取得します。

戻り値:
alternativeBom 代替 BOM

getBomUsage

public String getBomUsage()
BOM 用途を取得します。

戻り値:
bomUsage BOM 用途

getPlanlistgrp

public String getPlanlistgrp()
タスクリストグループのキーを取得します。

戻り値:
planlistgrp タスクリストグループのキー

getPlanlistcnt

public String getPlanlistcnt()
グループカウンタを取得します。

戻り値:
planlistcnt グループカウンタ

getLotSize

public String getLotSize()
原価計算ロットサイズを取得します。

戻り値:
lotSize 原価計算ロットサイズ

getSpecprocty

public String getSpecprocty()
原価計算の特殊調達タイプを取得します。

戻り値:
specprocty 原価計算の特殊調達タイプ

getProdUnit

public String getProdUnit()
製造単位を取得します。

戻り値:
prodUnit 製造単位

getProdUnitIso

public String getProdUnitIso()
製造単位 (ISO コード)を取得します。

戻り値:
prodUnitIso 製造単位 (ISO コード)

getIssStLoc

public String getIssStLoc()
出庫保管場所を取得します。

戻り値:
issStLoc 出庫保管場所

getMrpGroup

public String getMrpGroup()
MRP グループを取得します。

戻り値:
mrpGroup MRP グループ

getCompScrap

public String getCompScrap()
構成品目不良率を取得します。

戻り値:
compScrap 構成品目不良率

getCertType

public String getCertType()
証明書タイプを取得します。

戻り値:
certType 証明書タイプ

getCycleTime

public String getCycleTime()
タクトタイムを取得します。

戻り値:
cycleTime タクトタイム

getInspSetupFlag

public String getInspSetupFlag()
品目/プラントに QM 検査データ設定を取得します。

戻り値:
inspSetupFlag 品目/プラントに QM 検査データ設定

getCovprofile

public String getCovprofile()
在庫日数プロファイルを取得します。

戻り値:
covprofile 在庫日数プロファイル

getCcPhInv

public String getCcPhInv()
循環棚卸の実地棚卸区分を取得します。

戻り値:
ccPhInv 循環棚卸の実地棚卸区分

getVarianceKey

public String getVarianceKey()
差異キーを取得します。

戻り値:
varianceKey 差異キー

getSernoProf

public String getSernoProf()
シリアル番号プロファイルを取得します。

戻り値:
sernoProf シリアル番号プロファイル

getPsConfMat

public String getPsConfMat()
選定可能品目を取得します。

戻り値:
psConfMat 選定可能品目

getRepmanprof

public String getRepmanprof()
繰返生産プロファイルを取得します。

戻り値:
repmanprof 繰返生産プロファイル

getNegStocks

public String getNegStocks()
プラントにおけるマイナス在庫許可を取得します。

戻り値:
negStocks プラントにおけるマイナス在庫許可

getQmRgmts

public String getQmRgmts()
仕入先の必須 QM システムを取得します。

戻り値:
qmRgmts 仕入先の必須 QM システム

getPlngCycle

public String getPlngCycle()
計画サイクルを取得します。

戻り値:
plngCycle 計画サイクル

getRoundProf

public String getRoundProf()
丸めプロファイルを取得します。

戻り値:
roundProf 丸めプロファイル

getRefmatcons

public String getRefmatcons()
消費参照品目を取得します。

戻り値:
refmatcons 消費参照品目

getRefpltcons

public String getRefpltcons()
消費参照プラントを取得します。

戻り値:
refpltcons 消費参照プラント

getDToRefM

public String getDToRefM()
消費データ参照の有効終了日を取得します。

戻り値:
dToRefM 消費データ参照の有効終了日

getMultRefM

public String getMultRefM()
消費データ参照品目の乗数を取得します。

戻り値:
multRefM 消費データ参照品目の乗数

getAutoReset

public String getAutoReset()
予測モデル自動リセットを取得します。

戻り値:
autoReset 予測モデル自動リセット

getPrefStatFlag

public String getPrefStatFlag()
区分: 特恵関税 - 輸出/輸入を取得します。

戻り値:
prefStatFlag 区分: 特恵関税 - 輸出/輸入

getExCertId

public String getExCertId()
法令管理: 認定書区分を取得します。

戻り値:
exCertId 法令管理: 認定書区分

getExCertNoNew

public String getExCertNoNew()
非該当証明書番号 - 法令管理を取得します。

戻り値:
exCertNoNew 非該当証明書番号 - 法令管理

getExCertDt

public String getExCertDt()
非該当証明書発行日を取得します。

戻り値:
exCertDt 非該当証明書発行日

getDeclStatFlag

public String getDeclStatFlag()
区分: 仕入先申告ありを取得します。

戻り値:
declStatFlag 区分: 仕入先申告あり

getMilitId

public String getMilitId()
ID: 武器を取得します。

戻り値:
militId ID: 武器

getInspInt

public String getInspInt()
次回再検査までの間隔を取得します。

戻り値:
inspInt 次回再検査までの間隔

getCoProduct

public String getCoProduct()
区分: 連産品としても使用可能な品目を取得します。

戻り値:
coProduct 区分: 連産品としても使用可能な品目

getPlanStrgp

public String getPlanStrgp()
計画方針グループを取得します。

戻り値:
planStrgp 計画方針グループ

getSlocExprc

public String getSlocExprc()
外部調達の初期保管場所を取得します。

戻り値:
slocExprc 外部調達の初期保管場所

getBulkMat

public String getBulkMat()
区分: バルク品目を取得します。

戻り値:
bulkMat 区分: バルク品目

getCcFixed

public String getCcFixed()
循環棚卸区分固定を取得します。

戻り値:
ccFixed 循環棚卸区分固定

getDetermGrp

public String getDetermGrp()
在庫決定グループを取得します。

戻り値:
determGrp 在庫決定グループ

getQmAuthgrp

public String getQmAuthgrp()
QM における活動の品目権限グループを取得します。

戻り値:
qmAuthgrp QM における活動の品目権限グループ

getTaskListType

public String getTaskListType()
タスクリストタイプを取得します。

戻り値:
taskListType タスクリストタイプ

getPurStatus

public String getPurStatus()
プラント特有品目ステータスを取得します。

戻り値:
purStatus プラント特有品目ステータス

getProdprof

public String getProdprof()
製造計画プロファイルを取得します。

戻り値:
prodprof 製造計画プロファイル

getSaftyTId

public String getSaftyTId()
安全時間区分（安全リードタイムあり/なし)を取得します。

戻り値:
saftyTId 安全時間区分（安全リードタイムあり/なし)

getSafetytime

public String getSafetytime()
安全時間 (稼動日数)を取得します。

戻り値:
safetytime 安全時間 (稼動日数)

getPlordCtrl

public String getPlordCtrl()
アクション管理: 計画手配処理を取得します。

戻り値:
plordCtrl アクション管理: 計画手配処理

getBatchentry

public String getBatchentry()
製造/プロセス指図でのロット入力設定を取得します。

戻り値:
batchentry 製造/プロセス指図でのロット入力設定

getPvalidfrom

public String getPvalidfrom()
プラント品目ステータス有効期間開始日を取得します。

戻り値:
pvalidfrom プラント品目ステータス有効期間開始日

getMatfrgtgrp

public String getMatfrgtgrp()
品目運賃グループを取得します。

戻り値:
matfrgtgrp 品目運賃グループ

getProdverscs

public String getProdverscs()
原価計算を行う製造バージョンを取得します。

戻り値:
prodverscs 原価計算を行う製造バージョン

getMatCfop

public String getMatCfop()
品目 CFOP カテゴリを取得します。

戻り値:
matCfop 品目 CFOP カテゴリ

getEuListNo

public String getEuListNo()
CAP: CAP 製品一覧番号を取得します。

戻り値:
euListNo CAP: CAP 製品一覧番号

getEuMatGrp

public String getEuMatGrp()
EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。

戻り値:
euMatGrp EEC 農産物政策: CAP 生産品グループ - 貿易

getCasNo

public String getCasNo()
CAS 番号： 薬事品目 - 貿易を取得します。

戻り値:
casNo CAS 番号： 薬事品目 - 貿易

getProdcomNo

public String getProdcomNo()
生産統計: 貿易における PRODCOM コードを取得します。

戻り値:
prodcomNo 生産統計: 貿易における PRODCOM コード

getCtrlCode

public String getCtrlCode()
貿易: 消費税の管理コードを取得します。

戻り値:
ctrlCode 貿易: 消費税の管理コード

getJitRelvt

public String getJitRelvt()
区分: JIT 納入日程の関連明細を取得します。

戻り値:
jitRelvt 区分: JIT 納入日程の関連明細

getMatGrpTrans

public String getMatGrpTrans()
段取替えマトリクスに対する品目のグループを取得します。

戻り値:
matGrpTrans 段取替えマトリクスに対する品目のグループ

getHandlgGrp

public String getHandlgGrp()
ワークロード計算のロジスティクス処理グループを取得します。

戻り値:
handlgGrp ワークロード計算のロジスティクス処理グループ

getSupplyArea

public String getSupplyArea()
品目マスタレコードで提案される供給場所を取得します。

戻り値:
supplyArea 品目マスタレコードで提案される供給場所

getFairShareRule

public String getFairShareRule()
均等配賦ルールを取得します。

戻り値:
fairShareRule 均等配賦ルール

getPushDistrib

public String getPushDistrib()
区分: プッシュ配賦を取得します。

戻り値:
pushDistrib 区分: プッシュ配賦

getDeployHoriz

public String getDeployHoriz()
供給分配期間の日数を取得します。

戻り値:
deployHoriz 供給分配期間の日数

getMinLotSize

public String getMinLotSize()
需要と供給を一致させるための最小ロットサイズを取得します。

戻り値:
minLotSize 需要と供給を一致させるための最小ロットサイズ

getMaxLotSize

public String getMaxLotSize()
需要と供給を一致させるための最大ロットサイズを取得します。

戻り値:
maxLotSize 需要と供給を一致させるための最大ロットサイズ

getFixLotSize

public String getFixLotSize()
需要供給の一致に対する固定ロットサイズを取得します。

戻り値:
fixLotSize 需要供給の一致に対する固定ロットサイズ

getLotIncrement

public String getLotIncrement()
需要と供給を一致させるためのロットサイズ増分を取得します。

戻り値:
lotIncrement 需要と供給を一致させるためのロットサイズ増分

getProdConvType

public String getProdConvType()
生産値の変換タイプを取得します。

戻り値:
prodConvType 生産値の変換タイプ

getDistrProf

public String getDistrProf()
サイトの商品の物流プロファイルを取得します。

戻り値:
distrProf サイトの商品の物流プロファイル

getPeriodProfileSafetyTime

public String getPeriodProfileSafetyTime()
安全時間の期間プロファイルを取得します。

戻り値:
periodProfileSafetyTime 安全時間の期間プロファイル

getFxdPrice

public String getFxdPrice()
固定価格連産品を取得します。

戻り値:
fxdPrice 固定価格連産品

getAvailCheckAllProjSegments

public String getAvailCheckAllProjSegments()
プロジェクト間品目区分を取得します。

戻り値:
availCheckAllProjSegments プロジェクト間品目区分

getOverallprf

public String getOverallprf()
指図変更管理の全体プロファイルを取得します。

戻り値:
overallprf 指図変更管理の全体プロファイル

getMrpRelevancyDepRequirements

public String getMrpRelevancyDepRequirements()
従属所要量と MRP の関連性を取得します。

戻り値:
mrpRelevancyDepRequirements 従属所要量と MRP の関連性

getMrpAreaExists

public String getMrpAreaExists()
区分: MRP エリア登録済を取得します。

戻り値:
mrpAreaExists 区分: MRP エリア登録済

getMinSafetyStk

public String getMinSafetyStk()
最小安全在庫を取得します。

戻り値:
minSafetyStk 最小安全在庫

getNoCosting

public String getNoCosting()
原価計算なしを取得します。

戻り値:
noCosting 原価計算なし

getUnitGroup

public String getUnitGroup()
数量単位グループを取得します。

戻り値:
unitGroup 数量単位グループ

getFollowUpExternal

public String getFollowUpExternal()
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
followUpExternal 項目 FOLLOW_UP の品目コード (長) (今後の リリースで開発)

getFollowUpGuid

public String getFollowUpGuid()
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
followUpGuid 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

getFollowUpVersion

public String getFollowUpVersion()
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
followUpVersion 項目 FOLLOW_UP のバージョン番号 (今後の リリースで開発)

getRefmatconsExternal

public String getRefmatconsExternal()
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
refmatconsExternal 項目 REFMATCONS の品目コード (長) (今後の リリースで開発)

getRefmatconsGuid

public String getRefmatconsGuid()
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
refmatconsGuid 項目 REFMATCONS の外部 GUID (今後のリリースで開発)

getRefmatconsVersion

public String getRefmatconsVersion()
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
refmatconsVersion 項目 REFMATCONS のバージョン番号 (今後の リリースで開発)

getSalesView

public String getSalesView()
販売ビューを取得します。

戻り値:
salesView 販売ビュー

getPurchView

public String getPurchView()
購買管理ビューを取得します。

戻り値:
purchView 購買管理ビュー

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getForecastView

public String getForecastView()
需要予測ビューを取得します。

戻り値:
forecastView 需要予測ビュー

getWorkSchedView

public String getWorkSchedView()
作業計画ビューを取得します。

戻り値:
workSchedView 作業計画ビュー

getPrtView

public String getPrtView()
生産資源/治工具 (PRT) ビューを取得します。

戻り値:
prtView 生産資源/治工具 (PRT) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getWarehouseView

public String getWarehouseView()
倉庫管理ビューを取得します。

戻り値:
warehouseView 倉庫管理ビュー

getQualityView

public String getQualityView()
品質管理ビューを取得します。

戻り値:
qualityView 品質管理ビュー

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getRotationDate

public String getRotationDate()
原価計算ビューを取得します。

戻り値:
rotationDate 原価計算ビュー

getOriginalBatchFlag

public String getOriginalBatchFlag()
元ロット管理区分を取得します。

戻り値:
originalBatchFlag 元ロット管理区分

getOriginalBatchRefMaterial

public String getOriginalBatchRefMaterial()
元ロットの参照品目を取得します。

戻り値:
originalBatchRefMaterial 元ロットの参照品目

getPsConfMatExternal

public String getPsConfMatExternal()
PS_CO 項目の(将来の開発用)品目コード(長)を取得します。

戻り値:
psConfMatExternal PS_CO 項目の(将来の開発用)品目コード(長)

getPsConfMatGuid

public String getPsConfMatGuid()
PS_CONF_MAT 項目の外部 GUID (将来の開発用)を取得します。

戻り値:
psConfMatGuid PS_CONF_MAT 項目の外部 GUID (将来の開発用)

getPsConfMatVersion

public String getPsConfMatVersion()
PS_CONF_MAT 項目のバージョン番号 (将来の開発用)を取得します。

戻り値:
psConfMatVersion PS_CONF_MAT 項目のバージョン番号(将来の開発用)

getOriginalBatchRefMaterialE

public String getOriginalBatchRefMaterialE()
オリジナルロット参照品目を取得します。

戻り値:
originalBatchRefMaterialE PS_CONF_MAT オリジナルロット参照品目

getOriginalBatchRefMaterialV

public String getOriginalBatchRefMaterialV()
オリジナルロット参照品目を取得します。

戻り値:
originalBatchRefMaterialV PS_CONF_MAT オリジナルロット参照品目

getOriginalBatchRefMaterialG

public String getOriginalBatchRefMaterialG()
オリジナルロット参照品目を取得します。

戻り値:
originalBatchRefMaterialG PS_CONF_MAT オリジナルロット参照品目

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
プラントレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - プラントレベルでの品目削除フラグ

setAbcId

public void setAbcId(String abcId)
ABC 区分を設定します。

パラメータ:
abcId - ABC 区分

setCritPart

public void setCritPart(String critPart)
区分: 重要品目を設定します。

パラメータ:
critPart - 区分: 重要品目

setPurGroup

public void setPurGroup(String purGroup)
購買グループを設定します。

パラメータ:
purGroup - 購買グループ

setIssueUnit

public void setIssueUnit(String issueUnit)
出庫単位を設定します。

パラメータ:
issueUnit - 出庫単位

setIssueUnitIso

public void setIssueUnitIso(String issueUnitIso)
ISO コードでの出庫単位を設定します。

パラメータ:
issueUnitIso - ISO コードでの出庫単位

setMrpprofile

public void setMrpprofile(String mrpprofile)
品目: MRP プロファイルを設定します。

パラメータ:
mrpprofile - 品目: MRP プロファイル

setMrpType

public void setMrpType(String mrpType)
MRP タイプを設定します。

パラメータ:
mrpType - MRP タイプ

setMrpCtrler

public void setMrpCtrler(String mrpCtrler)
MRP 管理者を設定します。

パラメータ:
mrpCtrler - MRP 管理者

setPlndDelry

public void setPlndDelry(String plndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
plndDelry - 予定納入時間 (単位: 日)

setGrPrTime

public void setGrPrTime(String grPrTime)
入庫処理日数を設定します。

パラメータ:
grPrTime - 入庫処理日数

setPeriodInd

public void setPeriodInd(String periodInd)
期間区分を設定します。

パラメータ:
periodInd - 期間区分

setAssyScrap

public void setAssyScrap(String assyScrap)
組立不良率を設定します。

パラメータ:
assyScrap - 組立不良率

setLotsizekey

public void setLotsizekey(String lotsizekey)
ロットサイズ (品目計画)を設定します。

パラメータ:
lotsizekey - ロットサイズ (品目計画)

setProcType

public void setProcType(String procType)
調達タイプを設定します。

パラメータ:
procType - 調達タイプ

setSpproctype

public void setSpproctype(String spproctype)
特殊調達タイプを設定します。

パラメータ:
spproctype - 特殊調達タイプ

setReorderPt

public void setReorderPt(String reorderPt)
発注点を設定します。

パラメータ:
reorderPt - 発注点

setSafetyStk

public void setSafetyStk(String safetyStk)
安全在庫を設定します。

パラメータ:
safetyStk - 安全在庫

setMinlotsize

public void setMinlotsize(String minlotsize)
最小ロットサイズを設定します。

パラメータ:
minlotsize - 最小ロットサイズ

setMaxlotsize

public void setMaxlotsize(String maxlotsize)
最大ロットサイズを設定します。

パラメータ:
maxlotsize - 最大ロットサイズ

setFixedLot

public void setFixedLot(String fixedLot)
固定ロットサイズを設定します。

パラメータ:
fixedLot - 固定ロットサイズ

setRoundVal

public void setRoundVal(String roundVal)
購買発注数量の丸め数量を設定します。

パラメータ:
roundVal - 購買発注数量の丸め数量

setMaxStock

public void setMaxStock(String maxStock)
最大在庫レベルを設定します。

パラメータ:
maxStock - 最大在庫レベル

setOrdCosts

public void setOrdCosts(String ordCosts)
発注原価 (BAPI インタフェース)を設定します。

パラメータ:
ordCosts - 発注原価 (BAPI インタフェース)

setDepReqId

public void setDepReqId(String depReqId)
個別所要量と包括所要量に対する従属所要量区分を設定します。

パラメータ:
depReqId - 個別所要量と包括所要量に対する従属所要量区分

setStorCosts

public void setStorCosts(String storCosts)
保管経費区分を設定します。

パラメータ:
storCosts - 保管経費区分

setAltBomId

public void setAltBomId(String altBomId)
代替 BOM 選択の方法を設定します。

パラメータ:
altBomId - 代替 BOM 選択の方法

setDiscontinu

public void setDiscontinu(String discontinu)
打切区分を設定します。

パラメータ:
discontinu - 打切区分

setEffODay

public void setEffODay(String effODay)
有効終了日を設定します。

パラメータ:
effODay - 有効終了日

setFollowUp

public void setFollowUp(String followUp)
フォローアップ品目を設定します。

パラメータ:
followUp - フォローアップ品目

setGrpReqmts

public void setGrpReqmts(String grpReqmts)
区分: 所要量グループ化を設定します。

パラメータ:
grpReqmts - 区分: 所要量グループ化

setMixedMrp

public void setMixedMrp(String mixedMrp)
二重 MRP 区分を設定します。

パラメータ:
mixedMrp - 二重 MRP 区分

setSmKey

public void setSmKey(String smKey)
日程計画余裕キーを設定します。

パラメータ:
smKey - 日程計画余裕キー

setBackflush

public void setBackflush(String backflush)
区分: バックフラッシュを設定します。

パラメータ:
backflush - 区分: バックフラッシュ

setProductionScheduler

public void setProductionScheduler(String productionScheduler)
製造計画担当を設定します。

パラメータ:
productionScheduler - 製造計画担当

setProcTime

public void setProcTime(String procTime)
処理時間を設定します。

パラメータ:
procTime - 処理時間

setSetuptime

public void setSetuptime(String setuptime)
段取時間と片付け時間を設定します。

パラメータ:
setuptime - 段取時間と片付け時間

setInterop

public void setInterop(String interop)
移動時間を設定します。

パラメータ:
interop - 移動時間

setBaseQty

public void setBaseQty(String baseQty)
基本数量を設定します。

パラメータ:
baseQty - 基本数量

setInhseprodt

public void setInhseprodt(String inhseprodt)
内製日数を設定します。

パラメータ:
inhseprodt - 内製日数

setStgeperiod

public void setStgeperiod(String stgeperiod)
最長保管期間を設定します。

パラメータ:
stgeperiod - 最長保管期間

setStgePdUn

public void setStgePdUn(String stgePdUn)
最長保管期間の単位を設定します。

パラメータ:
stgePdUn - 最長保管期間の単位

setStgePdUnIso

public void setStgePdUnIso(String stgePdUnIso)
ISO コードでの最長保管期間単位を設定します。

パラメータ:
stgePdUnIso - ISO コードでの最長保管期間単位

setOverTol

public void setOverTol(String overTol)
過剰納入許容範囲リミットを設定します。

パラメータ:
overTol - 過剰納入許容範囲リミット

setUnlimited

public void setUnlimited(String unlimited)
区分: 無制限過剰納入可能を設定します。

パラメータ:
unlimited - 区分: 無制限過剰納入可能

setUnderTol

public void setUnderTol(String underTol)
不足納入許容範囲リミットを設定します。

パラメータ:
underTol - 不足納入許容範囲リミット

setReplentime

public void setReplentime(String replentime)
補充リードタイム合計 (稼動日数)を設定します。

パラメータ:
replentime - 補充リードタイム合計 (稼動日数)

setReplacePt

public void setReplacePt(String replacePt)
取替部品を設定します。

パラメータ:
replacePt - 取替部品

setIndPostToInspStock

public void setIndPostToInspStock(String indPostToInspStock)
品質検査中在庫への転記を設定します。

パラメータ:
indPostToInspStock - 品質検査中在庫への転記

setCtrlKey

public void setCtrlKey(String ctrlKey)
調達における品質管理の管理キーを設定します。

パラメータ:
ctrlKey - 調達における品質管理の管理キー

setDocReqd

public void setDocReqd(String docReqd)
文書必須フラグを設定します。

パラメータ:
docReqd - 文書必須フラグ

setLoadinggrp

public void setLoadinggrp(String loadinggrp)
積載グループを設定します。

パラメータ:
loadinggrp - 積載グループ

setBatchMgmt

public void setBatchMgmt(String batchMgmt)
ロット管理所要量区分を設定します。

パラメータ:
batchMgmt - ロット管理所要量区分

setQuotausage

public void setQuotausage(String quotausage)
供給量割当の使用を設定します。

パラメータ:
quotausage - 供給量割当の使用

setServLevel

public void setServLevel(String servLevel)
サービスレベルを設定します。

パラメータ:
servLevel - サービスレベル

setSplitInd

public void setSplitInd(String splitInd)
分割区分を設定します。

パラメータ:
splitInd - 分割区分

setAvailcheck

public void setAvailcheck(String availcheck)
利用可能在庫確認の確認グループを設定します。

パラメータ:
availcheck - 利用可能在庫確認の確認グループ

setFyVariant

public void setFyVariant(String fyVariant)
会計年度バリアントを設定します。

パラメータ:
fyVariant - 会計年度バリアント

setCorrFact

public void setCorrFact(String corrFact)
区分: 修正係数を需要予測値計算に使用を設定します。

パラメータ:
corrFact - 区分: 修正係数を需要予測値計算に使用

setSetupTime

public void setSetupTime(String setupTime)
出荷準備時間を設定します。

パラメータ:
setupTime - 出荷準備時間

setBaseQtyPlan

public void setBaseQtyPlan(String baseQtyPlan)
出荷の能力計画のための基本数量を設定します。

パラメータ:
baseQtyPlan - 出荷の能力計画のための基本数量

setShipProcTime

public void setShipProcTime(String shipProcTime)
出荷処理時間を設定します。

パラメータ:
shipProcTime - 出荷処理時間

setSupSource

public void setSupSource(String supSource)
供給元を設定します。

パラメータ:
supSource - 供給元

setAutoPOrd

public void setAutoPOrd(String autoPOrd)
区分: "購買発注自動生成"を設定します。

パラメータ:
autoPOrd - 区分: "購買発注自動生成"

setSourcelist

public void setSourcelist(String sourcelist)
区分: 供給元一覧必須を設定します。

パラメータ:
sourcelist - 区分: 供給元一覧必須

setCommCode

public void setCommCode(String commCode)
貿易: 統計品目コード/輸入コード番号を設定します。

パラメータ:
commCode - 貿易: 統計品目コード/輸入コード番号

setCountryori

public void setCountryori(String countryori)
品目の原産国を設定します。

パラメータ:
countryori - 品目の原産国

setCountryoriIso

public void setCountryoriIso(String countryoriIso)
ISO コードでの品目原産国を設定します。

パラメータ:
countryoriIso - ISO コードでの品目原産国

setRegionorig

public void setRegionorig(String regionorig)
品目の原産地 (非特恵対象地区の原産)を設定します。

パラメータ:
regionorig - 品目の原産地 (非特恵対象地区の原産)

setCommCoUn

public void setCommCoUn(String commCoUn)
物品コード (貿易) の数量単位を設定します。

パラメータ:
commCoUn - 物品コード (貿易) の数量単位

setCommCoUnIso

public void setCommCoUnIso(String commCoUnIso)
ISO コードによる物品コード (貿易管理) の数量単位を設定します。

パラメータ:
commCoUnIso - ISO コードによる物品コード (貿易管理) の数量単位

setExpimpgrp

public void setExpimpgrp(String expimpgrp)
輸出/輸入品目グループを設定します。

パラメータ:
expimpgrp - 輸出/輸入品目グループ

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setPpcPlCal

public void setPpcPlCal(String ppcPlCal)
PPC 計画カレンダを設定します。

パラメータ:
ppcPlCal - PPC 計画カレンダ

setRepManuf

public void setRepManuf(String repManuf)
区分: 繰返生産許可を設定します。

パラメータ:
repManuf - 区分: 繰返生産許可

setPlTiFnce

public void setPlTiFnce(String plTiFnce)
計画タイムフェンスを設定します。

パラメータ:
plTiFnce - 計画タイムフェンス

setConsummode

public void setConsummode(String consummode)
消費モードを設定します。

パラメータ:
consummode - 消費モード

setBwdCons

public void setBwdCons(String bwdCons)
消費期間: 後方を設定します。

パラメータ:
bwdCons - 消費期間: 後方

setFwdCons

public void setFwdCons(String fwdCons)
消費期間: 前方を設定します。

パラメータ:
fwdCons - 消費期間: 前方

setVersionFlag

public void setVersionFlag(String versionFlag)
バージョン区分を設定します。

パラメータ:
versionFlag - バージョン区分

setAlternativeBom

public void setAlternativeBom(String alternativeBom)
代替 BOMを設定します。

パラメータ:
alternativeBom - 代替 BOM

setBomUsage

public void setBomUsage(String bomUsage)
BOM 用途を設定します。

パラメータ:
bomUsage - BOM 用途

setPlanlistgrp

public void setPlanlistgrp(String planlistgrp)
タスクリストグループのキーを設定します。

パラメータ:
planlistgrp - タスクリストグループのキー

setPlanlistcnt

public void setPlanlistcnt(String planlistcnt)
グループカウンタを設定します。

パラメータ:
planlistcnt - グループカウンタ

setLotSize

public void setLotSize(String lotSize)
原価計算ロットサイズを設定します。

パラメータ:
lotSize - 原価計算ロットサイズ

setSpecprocty

public void setSpecprocty(String specprocty)
原価計算の特殊調達タイプを設定します。

パラメータ:
specprocty - 原価計算の特殊調達タイプ

setProdUnit

public void setProdUnit(String prodUnit)
製造単位を設定します。

パラメータ:
prodUnit - 製造単位

setProdUnitIso

public void setProdUnitIso(String prodUnitIso)
製造単位 (ISO コード)を設定します。

パラメータ:
prodUnitIso - 製造単位 (ISO コード)

setIssStLoc

public void setIssStLoc(String issStLoc)
出庫保管場所を設定します。

パラメータ:
issStLoc - 出庫保管場所

setMrpGroup

public void setMrpGroup(String mrpGroup)
MRP グループを設定します。

パラメータ:
mrpGroup - MRP グループ

setCompScrap

public void setCompScrap(String compScrap)
構成品目不良率を設定します。

パラメータ:
compScrap - 構成品目不良率

setCertType

public void setCertType(String certType)
証明書タイプを設定します。

パラメータ:
certType - 証明書タイプ

setCycleTime

public void setCycleTime(String cycleTime)
タクトタイムを設定します。

パラメータ:
cycleTime - タクトタイム

setInspSetupFlag

public void setInspSetupFlag(String inspSetupFlag)
品目/プラントに QM 検査データ設定を設定します。

パラメータ:
inspSetupFlag - 品目/プラントに QM 検査データ設定

setCovprofile

public void setCovprofile(String covprofile)
在庫日数プロファイルを設定します。

パラメータ:
covprofile - 在庫日数プロファイル

setCcPhInv

public void setCcPhInv(String ccPhInv)
循環棚卸の実地棚卸区分を設定します。

パラメータ:
ccPhInv - 循環棚卸の実地棚卸区分

setVarianceKey

public void setVarianceKey(String varianceKey)
差異キーを設定します。

パラメータ:
varianceKey - 差異キー

setSernoProf

public void setSernoProf(String sernoProf)
シリアル番号プロファイルを設定します。

パラメータ:
sernoProf - シリアル番号プロファイル

setPsConfMat

public void setPsConfMat(String psConfMat)
選定可能品目を設定します。

パラメータ:
psConfMat - 選定可能品目

setRepmanprof

public void setRepmanprof(String repmanprof)
繰返生産プロファイルを設定します。

パラメータ:
repmanprof - 繰返生産プロファイル

setNegStocks

public void setNegStocks(String negStocks)
プラントにおけるマイナス在庫許可を設定します。

パラメータ:
negStocks - プラントにおけるマイナス在庫許可

setQmRgmts

public void setQmRgmts(String qmRgmts)
仕入先の必須 QM システムを設定します。

パラメータ:
qmRgmts - 仕入先の必須 QM システム

setPlngCycle

public void setPlngCycle(String plngCycle)
計画サイクルを設定します。

パラメータ:
plngCycle - 計画サイクル

setRoundProf

public void setRoundProf(String roundProf)
丸めプロファイルを設定します。

パラメータ:
roundProf - 丸めプロファイル

setRefmatcons

public void setRefmatcons(String refmatcons)
消費参照品目を設定します。

パラメータ:
refmatcons - 消費参照品目

setRefpltcons

public void setRefpltcons(String refpltcons)
消費参照プラントを設定します。

パラメータ:
refpltcons - 消費参照プラント

setDToRefM

public void setDToRefM(String dToRefM)
消費データ参照の有効終了日を設定します。

パラメータ:
dToRefM - 消費データ参照の有効終了日

setMultRefM

public void setMultRefM(String multRefM)
消費データ参照品目の乗数を設定します。

パラメータ:
multRefM - 消費データ参照品目の乗数

setAutoReset

public void setAutoReset(String autoReset)
予測モデル自動リセットを設定します。

パラメータ:
autoReset - 予測モデル自動リセット

setPrefStatFlag

public void setPrefStatFlag(String prefStatFlag)
区分: 特恵関税 - 輸出/輸入を設定します。

パラメータ:
prefStatFlag - 区分: 特恵関税 - 輸出/輸入

setExCertId

public void setExCertId(String exCertId)
法令管理: 認定書区分を設定します。

パラメータ:
exCertId - 法令管理: 認定書区分

setExCertNoNew

public void setExCertNoNew(String exCertNoNew)
非該当証明書番号 - 法令管理を設定します。

パラメータ:
exCertNoNew - 非該当証明書番号 - 法令管理

setExCertDt

public void setExCertDt(String exCertDt)
非該当証明書発行日を設定します。

パラメータ:
exCertDt - 非該当証明書発行日

setDeclStatFlag

public void setDeclStatFlag(String declStatFlag)
区分: 仕入先申告ありを設定します。

パラメータ:
declStatFlag - 区分: 仕入先申告あり

setMilitId

public void setMilitId(String militId)
ID: 武器を設定します。

パラメータ:
militId - ID: 武器

setInspInt

public void setInspInt(String inspInt)
次回再検査までの間隔を設定します。

パラメータ:
inspInt - 次回再検査までの間隔

setCoProduct

public void setCoProduct(String coProduct)
区分: 連産品としても使用可能な品目を設定します。

パラメータ:
coProduct - 区分: 連産品としても使用可能な品目

setPlanStrgp

public void setPlanStrgp(String planStrgp)
計画方針グループを設定します。

パラメータ:
planStrgp - 計画方針グループ

setSlocExprc

public void setSlocExprc(String slocExprc)
外部調達の初期保管場所を設定します。

パラメータ:
slocExprc - 外部調達の初期保管場所

setBulkMat

public void setBulkMat(String bulkMat)
区分: バルク品目を設定します。

パラメータ:
bulkMat - 区分: バルク品目

setCcFixed

public void setCcFixed(String ccFixed)
循環棚卸区分固定を設定します。

パラメータ:
ccFixed - 循環棚卸区分固定

setDetermGrp

public void setDetermGrp(String determGrp)
在庫決定グループを設定します。

パラメータ:
determGrp - 在庫決定グループ

setQmAuthgrp

public void setQmAuthgrp(String qmAuthgrp)
QM における活動の品目権限グループを設定します。

パラメータ:
qmAuthgrp - QM における活動の品目権限グループ

setTaskListType

public void setTaskListType(String taskListType)
タスクリストタイプを設定します。

パラメータ:
taskListType - タスクリストタイプ

setPurStatus

public void setPurStatus(String purStatus)
プラント特有品目ステータスを設定します。

パラメータ:
purStatus - プラント特有品目ステータス

setProdprof

public void setProdprof(String prodprof)
製造計画プロファイルを設定します。

パラメータ:
prodprof - 製造計画プロファイル

setSaftyTId

public void setSaftyTId(String saftyTId)
安全時間区分（安全リードタイムあり/なし)を設定します。

パラメータ:
saftyTId - 安全時間区分（安全リードタイムあり/なし)

setSafetytime

public void setSafetytime(String safetytime)
安全時間 (稼動日数)を設定します。

パラメータ:
safetytime - 安全時間 (稼動日数)

setPlordCtrl

public void setPlordCtrl(String plordCtrl)
アクション管理: 計画手配処理を設定します。

パラメータ:
plordCtrl - アクション管理: 計画手配処理

setBatchentry

public void setBatchentry(String batchentry)
製造/プロセス指図でのロット入力設定を設定します。

パラメータ:
batchentry - 製造/プロセス指図でのロット入力設定

setPvalidfrom

public void setPvalidfrom(String pvalidfrom)
プラント品目ステータス有効期間開始日を設定します。

パラメータ:
pvalidfrom - プラント品目ステータス有効期間開始日

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
品目運賃グループを設定します。

パラメータ:
matfrgtgrp - 品目運賃グループ

setProdverscs

public void setProdverscs(String prodverscs)
原価計算を行う製造バージョンを設定します。

パラメータ:
prodverscs - 原価計算を行う製造バージョン

setMatCfop

public void setMatCfop(String matCfop)
品目 CFOP カテゴリを設定します。

パラメータ:
matCfop - 品目 CFOP カテゴリ

setEuListNo

public void setEuListNo(String euListNo)
CAP: CAP 製品一覧番号を設定します。

パラメータ:
euListNo - CAP: CAP 製品一覧番号

setEuMatGrp

public void setEuMatGrp(String euMatGrp)
EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。

パラメータ:
euMatGrp - EEC 農産物政策: CAP 生産品グループ - 貿易

setCasNo

public void setCasNo(String casNo)
CAS 番号： 薬事品目 - 貿易を設定します。

パラメータ:
casNo - CAS 番号： 薬事品目 - 貿易

setProdcomNo

public void setProdcomNo(String prodcomNo)
生産統計: 貿易における PRODCOM コードを設定します。

パラメータ:
prodcomNo - 生産統計: 貿易における PRODCOM コード

setCtrlCode

public void setCtrlCode(String ctrlCode)
貿易: 消費税の管理コードを設定します。

パラメータ:
ctrlCode - 貿易: 消費税の管理コード

setJitRelvt

public void setJitRelvt(String jitRelvt)
区分: JIT 納入日程の関連明細を設定します。

パラメータ:
jitRelvt - 区分: JIT 納入日程の関連明細

setMatGrpTrans

public void setMatGrpTrans(String matGrpTrans)
段取替えマトリクスに対する品目のグループを設定します。

パラメータ:
matGrpTrans - 段取替えマトリクスに対する品目のグループ

setHandlgGrp

public void setHandlgGrp(String handlgGrp)
ワークロード計算のロジスティクス処理グループを設定します。

パラメータ:
handlgGrp - ワークロード計算のロジスティクス処理グループ

setSupplyArea

public void setSupplyArea(String supplyArea)
品目マスタレコードで提案される供給場所を設定します。

パラメータ:
supplyArea - 品目マスタレコードで提案される供給場所

setFairShareRule

public void setFairShareRule(String fairShareRule)
均等配賦ルールを設定します。

パラメータ:
fairShareRule - 均等配賦ルール

setPushDistrib

public void setPushDistrib(String pushDistrib)
区分: プッシュ配賦を設定します。

パラメータ:
pushDistrib - 区分: プッシュ配賦

setDeployHoriz

public void setDeployHoriz(String deployHoriz)
供給分配期間の日数を設定します。

パラメータ:
deployHoriz - 供給分配期間の日数

setMinLotSize

public void setMinLotSize(String minLotSize)
需要と供給を一致させるための最小ロットサイズを設定します。

パラメータ:
minLotSize - 需要と供給を一致させるための最小ロットサイズ

setMaxLotSize

public void setMaxLotSize(String maxLotSize)
需要と供給を一致させるための最大ロットサイズを設定します。

パラメータ:
maxLotSize - 需要と供給を一致させるための最大ロットサイズ

setFixLotSize

public void setFixLotSize(String fixLotSize)
需要供給の一致に対する固定ロットサイズを設定します。

パラメータ:
fixLotSize - 需要供給の一致に対する固定ロットサイズ

setLotIncrement

public void setLotIncrement(String lotIncrement)
需要と供給を一致させるためのロットサイズ増分を設定します。

パラメータ:
lotIncrement - 需要と供給を一致させるためのロットサイズ増分

setProdConvType

public void setProdConvType(String prodConvType)
生産値の変換タイプを設定します。

パラメータ:
prodConvType - 生産値の変換タイプ

setDistrProf

public void setDistrProf(String distrProf)
サイトの商品の物流プロファイルを設定します。

パラメータ:
distrProf - サイトの商品の物流プロファイル

setPeriodProfileSafetyTime

public void setPeriodProfileSafetyTime(String periodProfileSafetyTime)
安全時間の期間プロファイルを設定します。

パラメータ:
periodProfileSafetyTime - 安全時間の期間プロファイル

setFxdPrice

public void setFxdPrice(String fxdPrice)
固定価格連産品を設定します。

パラメータ:
fxdPrice - 固定価格連産品

setAvailCheckAllProjSegments

public void setAvailCheckAllProjSegments(String availCheckAllProjSegments)
プロジェクト間品目区分を設定します。

パラメータ:
availCheckAllProjSegments - プロジェクト間品目区分

setOverallprf

public void setOverallprf(String overallprf)
指図変更管理の全体プロファイルを設定します。

パラメータ:
overallprf - 指図変更管理の全体プロファイル

setMrpRelevancyDepRequirements

public void setMrpRelevancyDepRequirements(String mrpRelevancyDepRequirements)
従属所要量と MRP の関連性を設定します。

パラメータ:
mrpRelevancyDepRequirements - 従属所要量と MRP の関連性

setMrpAreaExists

public void setMrpAreaExists(String mrpAreaExists)
区分: MRP エリア登録済を設定します。

パラメータ:
mrpAreaExists - 区分: MRP エリア登録済

setMinSafetyStk

public void setMinSafetyStk(String minSafetyStk)
最小安全在庫を設定します。

パラメータ:
minSafetyStk - 最小安全在庫

setNoCosting

public void setNoCosting(String noCosting)
原価計算なしを設定します。

パラメータ:
noCosting - 原価計算なし

setUnitGroup

public void setUnitGroup(String unitGroup)
数量単位グループを設定します。

パラメータ:
unitGroup - 数量単位グループ

setFollowUpExternal

public void setFollowUpExternal(String followUpExternal)
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
followUpExternal - 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)

setFollowUpGuid

public void setFollowUpGuid(String followUpGuid)
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
followUpGuid - 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

setFollowUpVersion

public void setFollowUpVersion(String followUpVersion)
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
followUpVersion - 項目 FOLLOW_UP のバージョン番号 (今後の リリースで開発)

setRefmatconsExternal

public void setRefmatconsExternal(String refmatconsExternal)
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
refmatconsExternal - 項目 REFMATCONS の品目コード (長) (今後の リリースで開発)

setRefmatconsGuid

public void setRefmatconsGuid(String refmatconsGuid)
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
refmatconsGuid - 項目 REFMATCONS の外部 GUID (今後のリリースで開発)

setRefmatconsVersion

public void setRefmatconsVersion(String refmatconsVersion)
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
refmatconsVersion - 項目 REFMATCONS のバージョン番号 (今後の リリースで開発)

setSalesView

public void setSalesView(String salesView)
販売ビューを設定します。

パラメータ:
salesView - 販売ビュー

setPurchView

public void setPurchView(String purchView)
購買管理ビューを設定します。

パラメータ:
purchView - 購買管理ビュー

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setForecastView

public void setForecastView(String forecastView)
需要予測ビューを設定します。

パラメータ:
forecastView - 需要予測ビュー

setWorkSchedView

public void setWorkSchedView(String workSchedView)
作業計画ビューを設定します。

パラメータ:
workSchedView - 作業計画ビュー

setPrtView

public void setPrtView(String prtView)
生産資源/治工具 (PRT) ビューを設定します。

パラメータ:
prtView - 生産資源/治工具 (PRT) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setWarehouseView

public void setWarehouseView(String warehouseView)
倉庫管理ビューを設定します。

パラメータ:
warehouseView - 倉庫管理ビュー

setQualityView

public void setQualityView(String qualityView)
品質管理ビューを設定します。

パラメータ:
qualityView - 品質管理ビュー

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setRotationDate

public void setRotationDate(String rotationDate)
原価計算ビューを設定します。

パラメータ:
rotationDate - 原価計算ビュー

setOriginalBatchFlag

public void setOriginalBatchFlag(String originalBatchFlag)
元ロット管理区分を設定します。

パラメータ:
originalBatchFlag - 元ロット管理区分

setOriginalBatchRefMaterial

public void setOriginalBatchRefMaterial(String originalBatchRefMaterial)
元ロットの参照品目を設定します。

パラメータ:
originalBatchRefMaterial - 元ロットの参照品目

setPsConfMatExternal

public void setPsConfMatExternal(String psConfMatExternal)
PS_CO 項目の(将来の開発用)品目コード(長)を設定します。

パラメータ:
psConfMatExternal - PS_CO 項目の(将来の開発用)品目コード(長)

setPsConfMatGuid

public void setPsConfMatGuid(String psConfMatGuid)
PS_CONF_MAT 項目の外部 GUID (将来の開発用)を設定します。

パラメータ:
psConfMatGuid - PS_CONF_MAT 項目の外部 GUID (将来の開発用)

setPsConfMatVersion

public void setPsConfMatVersion(String psConfMatVersion)
PS_CONF_MAT 項目のバージョン番号 (将来の開発用)を設定します。

パラメータ:
psConfMatVersion - PS_CONF_MAT 項目のバージョン番号 (将来の開発用)

setOriginalBatchRefMaterialE

public void setOriginalBatchRefMaterialE(String originalBatchRefMaterialE)
オリジナルロット参照品目を設定します。

パラメータ:
originalBatchRefMaterialE - オリジナルロット参照品目

setOriginalBatchRefMaterialV

public void setOriginalBatchRefMaterialV(String originalBatchRefMaterialV)
オリジナルロット参照品目を設定します。

パラメータ:
originalBatchRefMaterialV - オリジナルロット参照品目

setOriginalBatchRefMaterialG

public void setOriginalBatchRefMaterialG(String originalBatchRefMaterialG)
オリジナルロット参照品目を設定します。

パラメータ:
originalBatchRefMaterialG - オリジナルロット参照品目

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlantDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList
すべての実装インタフェース:
Serializable
public class PlantDataList
extends PlantData
implements Serializable

品目データ (プラントレベル)情報クラス
機能は以下の通り

  • 品目データ (プラントレベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantDataList()
品目データ (プラントレベル)情報を作成します。
PlantDataList(int index)
品目データ (プラントレベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData から継承したメソッド
getAbcId, getAccountView, getAltBomId, getAlternativeBom, getAssyScrap, getAutoPOrd, getAutoReset, getAvailcheck, getAvailCheckAllProjSegments, getBackflush, getBaseQty, getBaseQtyPlan, getBatchentry, getBatchMgmt, getBomUsage, getBulkMat, getBwdCons, getCasNo, getCcFixed, getCcPhInv, getCertType, getCommCode, getCommCoUn, getCommCoUnIso, getCompScrap, getConsummode, getCoProduct, getCorrFact, getCostView, getCountryori, getCountryoriIso, getCovprofile, getCritPart, getCtrlCode, getCtrlKey, getCycleTime, getDeclStatFlag, getDelFlag, getDeployHoriz, getDepReqId, getDetermGrp, getDiscontinu, getDistrProf, getDocReqd, getDToRefM, getEffODay, getEuListNo, getEuMatGrp, getExCertDt, getExCertId, getExCertNoNew, getExpimpgrp, getFairShareRule, getFixedLot, getFixLotSize, getFollowUp, getFollowUpExternal, getFollowUpGuid, getFollowUpVersion, getForecastView, getFunction, getFwdCons, getFxdPrice, getFyVariant, getGrpReqmts, getGrPrTime, getHandlgGrp, getIndPostToInspStock, getInhseprodt, getInspInt, getInspSetupFlag, getInterop, getIssStLoc, getIssueUnit, getIssueUnitIso, getJitRelvt, getLoadinggrp, getLotIncrement, getLotSize, getLotsizekey, getMaintStat, getMatCfop, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMatfrgtgrp, getMatGrpTrans, getMaxlotsize, getMaxLotSize, getMaxStock, getMilitId, getMinlotsize, getMinLotSize, getMinSafetyStk, getMixedMrp, getMrpAreaExists, getMrpCtrler, getMrpGroup, getMrpprofile, getMrpRelevancyDepRequirements, getMrpType, getMrpView, getMultRefM, getNegStocks, getNoCosting, getOrdCosts, getOriginalBatchFlag, getOriginalBatchRefMaterial, getOriginalBatchRefMaterialE, getOriginalBatchRefMaterialG, getOriginalBatchRefMaterialV, getOverallprf, getOverTol, getPeriodInd, getPeriodProfileSafetyTime, getPlanlistcnt, getPlanlistgrp, getPlanStrgp, getPlant, getPlndDelry, getPlngCycle, getPlordCtrl, getPlTiFnce, getPpcPlCal, getPrefStatFlag, getProcTime, getProcType, getProdcomNo, getProdConvType, getProdprof, getProductionScheduler, getProdUnit, getProdUnitIso, getProdverscs, getProfitCtr, getPrtView, getPsConfMat, getPsConfMatExternal, getPsConfMatGuid, getPsConfMatVersion, getPurchView, getPurGroup, getPurStatus, getPushDistrib, getPvalidfrom, getQmAuthgrp, getQmRgmts, getQualityView, getQuotausage, getRefmatcons, getRefmatconsExternal, getRefmatconsGuid, getRefmatconsVersion, getRefpltcons, getRegionorig, getReorderPt, getReplacePt, getReplentime, getRepmanprof, getRepManuf, getRotationDate, getRoundProf, getRoundVal, getSafetyStk, getSafetytime, getSaftyTId, getSalesView, getSernoProf, getServLevel, getSetuptime, getSetupTime, getShipProcTime, getSlocExprc, getSmKey, getSourcelist, getSpecprocty, getSplitInd, getSpproctype, getStgePdUn, getStgePdUnIso, getStgeperiod, getStorageView, getStorCosts, getSupplyArea, getSupSource, getTaskListType, getUnderTol, getUnitGroup, getUnlimited, getVarianceKey, getVersionFlag, getWarehouseView, getWorkSchedView, setAbcId, setAccountView, setAltBomId, setAlternativeBom, setAssyScrap, setAutoPOrd, setAutoReset, setAvailcheck, setAvailCheckAllProjSegments, setBackflush, setBaseQty, setBaseQtyPlan, setBatchentry, setBatchMgmt, setBomUsage, setBulkMat, setBwdCons, setCasNo, setCcFixed, setCcPhInv, setCertType, setCommCode, setCommCoUn, setCommCoUnIso, setCompScrap, setConsummode, setCoProduct, setCorrFact, setCostView, setCountryori, setCountryoriIso, setCovprofile, setCritPart, setCtrlCode, setCtrlKey, setCycleTime, setDeclStatFlag, setDelFlag, setDeployHoriz, setDepReqId, setDetermGrp, setDiscontinu, setDistrProf, setDocReqd, setDToRefM, setEffODay, setEuListNo, setEuMatGrp, setExCertDt, setExCertId, setExCertNoNew, setExpimpgrp, setFairShareRule, setFixedLot, setFixLotSize, setFollowUp, setFollowUpExternal, setFollowUpGuid, setFollowUpVersion, setForecastView, setFunction, setFwdCons, setFxdPrice, setFyVariant, setGrpReqmts, setGrPrTime, setHandlgGrp, setIndPostToInspStock, setInhseprodt, setInspInt, setInspSetupFlag, setInterop, setIssStLoc, setIssueUnit, setIssueUnitIso, setJitRelvt, setLoadinggrp, setLotIncrement, setLotSize, setLotsizekey, setMaintStat, setMatCfop, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMatfrgtgrp, setMatGrpTrans, setMaxlotsize, setMaxLotSize, setMaxStock, setMilitId, setMinlotsize, setMinLotSize, setMinSafetyStk, setMixedMrp, setMrpAreaExists, setMrpCtrler, setMrpGroup, setMrpprofile, setMrpRelevancyDepRequirements, setMrpType, setMrpView, setMultRefM, setNegStocks, setNoCosting, setOrdCosts, setOriginalBatchFlag, setOriginalBatchRefMaterial, setOriginalBatchRefMaterialE, setOriginalBatchRefMaterialG, setOriginalBatchRefMaterialV, setOverallprf, setOverTol, setPeriodInd, setPeriodProfileSafetyTime, setPlanlistcnt, setPlanlistgrp, setPlanStrgp, setPlant, setPlndDelry, setPlngCycle, setPlordCtrl, setPlTiFnce, setPpcPlCal, setPrefStatFlag, setProcTime, setProcType, setProdcomNo, setProdConvType, setProdprof, setProductionScheduler, setProdUnit, setProdUnitIso, setProdverscs, setProfitCtr, setPrtView, setPsConfMat, setPsConfMatExternal, setPsConfMatGuid, setPsConfMatVersion, setPurchView, setPurGroup, setPurStatus, setPushDistrib, setPvalidfrom, setQmAuthgrp, setQmRgmts, setQualityView, setQuotausage, setRefmatcons, setRefmatconsExternal, setRefmatconsGuid, setRefmatconsVersion, setRefpltcons, setRegionorig, setReorderPt, setReplacePt, setReplentime, setRepmanprof, setRepManuf, setRotationDate, setRoundProf, setRoundVal, setSafetyStk, setSafetytime, setSaftyTId, setSalesView, setSernoProf, setServLevel, setSetuptime, setSetupTime, setShipProcTime, setSlocExprc, setSmKey, setSourcelist, setSpecprocty, setSplitInd, setSpproctype, setStgePdUn, setStgePdUnIso, setStgeperiod, setStorageView, setStorCosts, setSupplyArea, setSupSource, setTaskListType, setUnderTol, setUnitGroup, setUnlimited, setVarianceKey, setVersionFlag, setWarehouseView, setWorkSchedView, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantDataList

public PlantDataList()
品目データ (プラントレベル)情報を作成します。

PlantDataList

public PlantDataList(int index)
品目データ (プラントレベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス SalesData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesDataList
public class SalesData
extends Object
implements Serializable

販売データ情報クラス
機能は以下の通り

  • 販売データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesData()
販売データ情報を作成します。
メソッドの概要
String | getAcctAssgt() 品目の勘定設定グループを取得します。
String | getCashDisc() 現金値引区分を取得します。
String | getCommGroup() 手数料グループを取得します。
String | getDelFlag() 区分: 流通チャネルレベルでの品目削除フラグを取得します。
String | getDelygPlnt() 出荷プラントを取得します。
String | getDelyUnit() 出荷単位を取得します。
String | getDelyUom() 出荷数量単位を取得します。
String | getDelyUomIso() ISO コードでの出荷単位の数量単位を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getFunction() BAPI 機能を取得します。
String | getItemCat() 品目マスタの明細カテゴリグループを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMatlGrp1() 品目グループ 1を取得します。
String | getMatlGrp2() 品目グループ 2を取得します。
String | getMatlGrp3() 品目グループ 3を取得します。
String | getMatlGrp4() 品目グループ 4を取得します。
String | getMatlGrp5() 品目グループ 5を取得します。
String | getMatlStats() 品目統計グループを取得します。
String | getMatPrGrp() 品目価格設定グループを取得します。
String | getMinDely() 納品書処理時の最小納入数量を取得します。
String | getMinMto() 受注製造品最少受注数量を取得します。
String | getMinOrder() 基本数量単位での最小受注数量を取得します。
String | getProdAtt1() ID: 製品属性 1を取得します。
String | getProdAtt10() 品目属性 10 用 IDを取得します。
String | getProdAtt2() 品目属性 2 用 IDを取得します。
String | getProdAtt3() 品目属性 3 用 IDを取得します。
String | getProdAtt4() 品目属性 4 用 IDを取得します。
String | getProdAtt5() 品目属性 5 用 IDを取得します。
String | getProdAtt6() 品目属性 6 の IDを取得します。
String | getProdAtt7() 品目属性 7 用 IDを取得します。
String | getProdAtt8() 品目属性 8 用 IDを取得します。
String | getProdAtt9() 品目属性 9を取得します。
String | getProdHier() 品目階層を取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPrRefMatExternal() 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPrRefMatGuid() 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPrRefMatVersion() 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getRebateGrp() 取引量リベートグループを取得します。
String | getRoundProf() 丸めプロファイルを取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSalesUnitIso() ISO コードによる販売単位を取得します。
String | getSalStatus() 販売ビューからの品目ステータスを取得します。
String | getUnitGroup() 数量単位グループを取得します。
String | getValidFrom() 流通チェーン別品目ステータスの有効期間開始日を取得します。
String | getVarSalesUn() 可変販売単位の使用不可を取得します。
void | setAcctAssgt(String acctAssgt) 品目の勘定設定グループを設定します。
void | setCashDisc(String cashDisc) 現金値引区分を設定します。
void | setCommGroup(String commGroup) 手数料グループを設定します。
void | setDelFlag(String delFlag) 区分: 流通チャネルレベルでの品目削除フラグを設定します。
void | setDelygPlnt(String delygPlnt) 出荷プラントを設定します。
void | setDelyUnit(String delyUnit) 出荷単位を設定します。
void | setDelyUom(String delyUom) 出荷数量単位を設定します。
void | setDelyUomIso(String delyUomIso) ISO コードでの出荷単位の数量単位を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setItemCat(String itemCat) 品目マスタの明細カテゴリグループを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMatlGrp1(String matlGrp1) 品目グループ 1を設定します。
void | setMatlGrp2(String matlGrp2) 品目グループ 2を設定します。
void | setMatlGrp3(String matlGrp3) 品目グループ 3を設定します。
void | setMatlGrp4(String matlGrp4) 品目グループ 4を設定します。
void | setMatlGrp5(String matlGrp5) 品目グループ 5を設定します。
void | setMatlStats(String matlStats) 品目統計グループを設定します。
void | setMatPrGrp(String matPrGrp) 品目価格設定グループを設定します。
void | setMinDely(String minDely) 納品書処理時の最小納入数量を設定します。
void | setMinMto(String minMto) 受注製造品最少受注数量を設定します。
void | setMinOrder(String minOrder) 基本数量単位での最小受注数量を設定します。
void | setProdAtt1(String prodAtt1) ID: 製品属性 1を設定します。
void | setProdAtt10(String prodAtt10) 品目属性 10 用 IDを設定します。
void | setProdAtt2(String prodAtt2) 品目属性 2 用 IDを設定します。
void | setProdAtt3(String prodAtt3) 品目属性 3 用 IDを設定します。
void | setProdAtt4(String prodAtt4) 品目属性 4 用 IDを設定します。
void | setProdAtt5(String prodAtt5) 品目属性 5 用 IDを設定します。
void | setProdAtt6(String prodAtt6) 品目属性 6 の IDを設定します。
void | setProdAtt7(String prodAtt7) 品目属性 7 用 IDを設定します。
void | setProdAtt8(String prodAtt8) 品目属性 8 用 IDを設定します。
void | setProdAtt9(String prodAtt9) 品目属性 9を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPrRefMatExternal(String prRefMatExternal) 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPrRefMatGuid(String prRefMatGuid) 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPrRefMatVersion(String prRefMatVersion) 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setRebateGrp(String rebateGrp) 取引量リベートグループを設定します。
void | setRoundProf(String roundProf) 丸めプロファイルを設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSalesUnitIso(String salesUnitIso) ISO コードによる販売単位を設定します。
void | setSalStatus(String salStatus) 販売ビューからの品目ステータスを設定します。
void | setUnitGroup(String unitGroup) 数量単位グループを設定します。
void | setValidFrom(String validFrom) 流通チェーン別品目ステータスの有効期間開始日を設定します。
void | setVarSalesUn(String varSalesUn) 可変販売単位の使用不可を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesData

public SalesData()
販売データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDelFlag

public String getDelFlag()
区分: 流通チャネルレベルでの品目削除フラグを取得します。

戻り値:
delFlag 区分: 流通チャネルレベルでの品目削除フラグ

getMatlStats

public String getMatlStats()
品目統計グループを取得します。

戻り値:
matlStats 品目統計グループ

getRebateGrp

public String getRebateGrp()
取引量リベートグループを取得します。

戻り値:
rebateGrp 取引量リベートグループ

getCommGroup

public String getCommGroup()
手数料グループを取得します。

戻り値:
commGroup 手数料グループ

getCashDisc

public String getCashDisc()
現金値引区分を取得します。

戻り値:
cashDisc 現金値引区分

getSalStatus

public String getSalStatus()
販売ビューからの品目ステータスを取得します。

戻り値:
salStatus 販売ビューからの品目ステータス

getValidFrom

public String getValidFrom()
流通チェーン別品目ステータスの有効期間開始日を取得します。

戻り値:
validFrom 流通チェーン別品目ステータスの有効期間開始日

getMinOrder

public String getMinOrder()
基本数量単位での最小受注数量を取得します。

戻り値:
minOrder 基本数量単位での最小受注数量

getMinDely

public String getMinDely()
納品書処理時の最小納入数量を取得します。

戻り値:
minDely 納品書処理時の最小納入数量

getMinMto

public String getMinMto()
受注製造品最少受注数量を取得します。

戻り値:
minMto 受注製造品最少受注数量

getDelyUnit

public String getDelyUnit()
出荷単位を取得します。

戻り値:
delyUnit 出荷単位

getDelyUom

public String getDelyUom()
出荷数量単位を取得します。

戻り値:
delyUom 出荷数量単位

getDelyUomIso

public String getDelyUomIso()
ISO コードでの出荷単位の数量単位を取得します。

戻り値:
delyUomIso ISO コードでの出荷単位の数量単位

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getSalesUnitIso

public String getSalesUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
salesUnitIso ISO コードによる販売単位

getItemCat

public String getItemCat()
品目マスタの明細カテゴリグループを取得します。

戻り値:
itemCat 品目マスタの明細カテゴリグループ

getDelygPlnt

public String getDelygPlnt()
出荷プラントを取得します。

戻り値:
delygPlnt 出荷プラント

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getMatPrGrp

public String getMatPrGrp()
品目価格設定グループを取得します。

戻り値:
matPrGrp 品目価格設定グループ

getAcctAssgt

public String getAcctAssgt()
品目の勘定設定グループを取得します。

戻り値:
acctAssgt 品目の勘定設定グループ

getMatlGrp1

public String getMatlGrp1()
品目グループ 1を取得します。

戻り値:
matlGrp1 品目グループ 1

getMatlGrp2

public String getMatlGrp2()
品目グループ 2を取得します。

戻り値:
matlGrp2 品目グループ 2

getMatlGrp3

public String getMatlGrp3()
品目グループ 3を取得します。

戻り値:
matlGrp3 品目グループ 3

getMatlGrp4

public String getMatlGrp4()
品目グループ 4を取得します。

戻り値:
matlGrp4 品目グループ 4

getMatlGrp5

public String getMatlGrp5()
品目グループ 5を取得します。

戻り値:
matlGrp5 品目グループ 5

getProdAtt1

public String getProdAtt1()
ID: 製品属性 1を取得します。

戻り値:
prodAtt1 ID: 製品属性 1

getProdAtt2

public String getProdAtt2()
品目属性 2 用 IDを取得します。

戻り値:
prodAtt2 品目属性 2 用 ID

getProdAtt3

public String getProdAtt3()
品目属性 3 用 IDを取得します。

戻り値:
prodAtt3 品目属性 3 用 ID

getProdAtt4

public String getProdAtt4()
品目属性 4 用 IDを取得します。

戻り値:
prodAtt4 品目属性 4 用 ID

getProdAtt5

public String getProdAtt5()
品目属性 5 用 IDを取得します。

戻り値:
prodAtt5 品目属性 5 用 ID

getProdAtt6

public String getProdAtt6()
品目属性 6 の IDを取得します。

戻り値:
prodAtt6 品目属性 6 の ID

getProdAtt7

public String getProdAtt7()
品目属性 7 用 IDを取得します。

戻り値:
prodAtt7 品目属性 7 用 ID

getProdAtt8

public String getProdAtt8()
品目属性 8 用 IDを取得します。

戻り値:
prodAtt8 品目属性 8 用 ID

getProdAtt9

public String getProdAtt9()
品目属性 9を取得します。

戻り値:
prodAtt9 品目属性 9

getProdAtt10

public String getProdAtt10()
品目属性 10 用 IDを取得します。

戻り値:
prodAtt10 品目属性 10 用 ID

getRoundProf

public String getRoundProf()
丸めプロファイルを取得します。

戻り値:
roundProf 丸めプロファイル

getVarSalesUn

public String getVarSalesUn()
可変販売単位の使用不可を取得します。

戻り値:
varSalesUn 可変販売単位の使用不可

getUnitGroup

public String getUnitGroup()
数量単位グループを取得します。

戻り値:
unitGroup 数量単位グループ

getPrRefMatExternal

public String getPrRefMatExternal()
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
prRefMatExternal 項目 PR_REF_MAT の品目コード (長) (今後の リリースで開発)

getPrRefMatGuid

public String getPrRefMatGuid()
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
prRefMatGuid 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

getPrRefMatVersion

public String getPrRefMatVersion()
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
prRefMatVersion 項目 PR_REF_MAT のバージョン番号 (今後の リリースで開発)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDelFlag

public void setDelFlag(String delFlag)
区分: 流通チャネルレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - 区分: 流通チャネルレベルでの品目削除フラグ

setMatlStats

public void setMatlStats(String matlStats)
品目統計グループを設定します。

パラメータ:
matlStats - 品目統計グループ

setRebateGrp

public void setRebateGrp(String rebateGrp)
取引量リベートグループを設定します。

パラメータ:
rebateGrp - 取引量リベートグループ

setCommGroup

public void setCommGroup(String commGroup)
手数料グループを設定します。

パラメータ:
commGroup - 手数料グループ

setCashDisc

public void setCashDisc(String cashDisc)
現金値引区分を設定します。

パラメータ:
cashDisc - 現金値引区分

setSalStatus

public void setSalStatus(String salStatus)
販売ビューからの品目ステータスを設定します。

パラメータ:
salStatus - 販売ビューからの品目ステータス

setValidFrom

public void setValidFrom(String validFrom)
流通チェーン別品目ステータスの有効期間開始日を設定します。

パラメータ:
validFrom - 流通チェーン別品目ステータスの有効期間開始日

setMinOrder

public void setMinOrder(String minOrder)
基本数量単位での最小受注数量を設定します。

パラメータ:
minOrder - 基本数量単位での最小受注数量

setMinDely

public void setMinDely(String minDely)
納品書処理時の最小納入数量を設定します。

パラメータ:
minDely - 納品書処理時の最小納入数量

setMinMto

public void setMinMto(String minMto)
受注製造品最少受注数量を設定します。

パラメータ:
minMto - 受注製造品最少受注数量

setDelyUnit

public void setDelyUnit(String delyUnit)
出荷単位を設定します。

パラメータ:
delyUnit - 出荷単位

setDelyUom

public void setDelyUom(String delyUom)
出荷数量単位を設定します。

パラメータ:
delyUom - 出荷数量単位

setDelyUomIso

public void setDelyUomIso(String delyUomIso)
ISO コードでの出荷単位の数量単位を設定します。

パラメータ:
delyUomIso - ISO コードでの出荷単位の数量単位

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setSalesUnitIso

public void setSalesUnitIso(String salesUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
salesUnitIso - ISO コードによる販売単位

setItemCat

public void setItemCat(String itemCat)
品目マスタの明細カテゴリグループを設定します。

パラメータ:
itemCat - 品目マスタの明細カテゴリグループ

setDelygPlnt

public void setDelygPlnt(String delygPlnt)
出荷プラントを設定します。

パラメータ:
delygPlnt - 出荷プラント

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
品目価格設定グループを設定します。

パラメータ:
matPrGrp - 品目価格設定グループ

setAcctAssgt

public void setAcctAssgt(String acctAssgt)
品目の勘定設定グループを設定します。

パラメータ:
acctAssgt - 品目の勘定設定グループ

setMatlGrp1

public void setMatlGrp1(String matlGrp1)
品目グループ 1を設定します。

パラメータ:
matlGrp1 - 品目グループ 1

setMatlGrp2

public void setMatlGrp2(String matlGrp2)
品目グループ 2を設定します。

パラメータ:
matlGrp2 - 品目グループ 2

setMatlGrp3

public void setMatlGrp3(String matlGrp3)
品目グループ 3を設定します。

パラメータ:
matlGrp3 - 品目グループ 3

setMatlGrp4

public void setMatlGrp4(String matlGrp4)
品目グループ 4を設定します。

パラメータ:
matlGrp4 - 品目グループ 4

setMatlGrp5

public void setMatlGrp5(String matlGrp5)
品目グループ 5を設定します。

パラメータ:
matlGrp5 - 品目グループ 5

setProdAtt1

public void setProdAtt1(String prodAtt1)
ID: 製品属性 1を設定します。

パラメータ:
prodAtt1 - ID: 製品属性 1

setProdAtt2

public void setProdAtt2(String prodAtt2)
品目属性 2 用 IDを設定します。

パラメータ:
prodAtt2 - 品目属性 2 用 ID

setProdAtt3

public void setProdAtt3(String prodAtt3)
品目属性 3 用 IDを設定します。

パラメータ:
prodAtt3 - 品目属性 3 用 ID

setProdAtt4

public void setProdAtt4(String prodAtt4)
品目属性 4 用 IDを設定します。

パラメータ:
prodAtt4 - 品目属性 4 用 ID

setProdAtt5

public void setProdAtt5(String prodAtt5)
品目属性 5 用 IDを設定します。

パラメータ:
prodAtt5 - 品目属性 5 用 ID

setProdAtt6

public void setProdAtt6(String prodAtt6)
品目属性 6 の IDを設定します。

パラメータ:
prodAtt6 - 品目属性 6 の ID

setProdAtt7

public void setProdAtt7(String prodAtt7)
品目属性 7 用 IDを設定します。

パラメータ:
prodAtt7 - 品目属性 7 用 ID

setProdAtt8

public void setProdAtt8(String prodAtt8)
品目属性 8 用 IDを設定します。

パラメータ:
prodAtt8 - 品目属性 8 用 ID

setProdAtt9

public void setProdAtt9(String prodAtt9)
品目属性 9を設定します。

パラメータ:
prodAtt9 - 品目属性 9

setProdAtt10

public void setProdAtt10(String prodAtt10)
品目属性 10 用 IDを設定します。

パラメータ:
prodAtt10 - 品目属性 10 用 ID

setRoundProf

public void setRoundProf(String roundProf)
丸めプロファイルを設定します。

パラメータ:
roundProf - 丸めプロファイル

setVarSalesUn

public void setVarSalesUn(String varSalesUn)
可変販売単位の使用不可を設定します。

パラメータ:
varSalesUn - 可変販売単位の使用不可

setUnitGroup

public void setUnitGroup(String unitGroup)
数量単位グループを設定します。

パラメータ:
unitGroup - 数量単位グループ

setPrRefMatExternal

public void setPrRefMatExternal(String prRefMatExternal)
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
prRefMatExternal - 項目 PR_REF_MAT の品目コード (長) (今後の リリースで開発)

setPrRefMatGuid

public void setPrRefMatGuid(String prRefMatGuid)
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
prRefMatGuid - 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

setPrRefMatVersion

public void setPrRefMatVersion(String prRefMatVersion)
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
prRefMatVersion - 項目 PR_REF_MAT のバージョン番号 (今後の リリースで開発)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス SalesDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList
すべての実装インタフェース:
Serializable
public class SalesDataList
extends SalesData
implements Serializable

販売データ情報クラス
機能は以下の通り

  • 販売データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesDataList()
販売データ情報を作成します。
SalesDataList(int index)
販売データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData から継承したメソッド
getAcctAssgt, getCashDisc, getCommGroup, getDelFlag, getDelygPlnt, getDelyUnit, getDelyUom, getDelyUomIso, getDistrChan, getFunction, getItemCat, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMatlGrp1, getMatlGrp2, getMatlGrp3, getMatlGrp4, getMatlGrp5, getMatlStats, getMatPrGrp, getMinDely, getMinMto, getMinOrder, getProdAtt1, getProdAtt10, getProdAtt2, getProdAtt3, getProdAtt4, getProdAtt5, getProdAtt6, getProdAtt7, getProdAtt8, getProdAtt9, getProdHier, getPrRefMat, getPrRefMatExternal, getPrRefMatGuid, getPrRefMatVersion, getRebateGrp, getRoundProf, getSalesOrg, getSalesUnit, getSalesUnitIso, getSalStatus, getUnitGroup, getValidFrom, getVarSalesUn, setAcctAssgt, setCashDisc, setCommGroup, setDelFlag, setDelygPlnt, setDelyUnit, setDelyUom, setDelyUomIso, setDistrChan, setFunction, setItemCat, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMatlGrp1, setMatlGrp2, setMatlGrp3, setMatlGrp4, setMatlGrp5, setMatlStats, setMatPrGrp, setMinDely, setMinMto, setMinOrder, setProdAtt1, setProdAtt10, setProdAtt2, setProdAtt3, setProdAtt4, setProdAtt5, setProdAtt6, setProdAtt7, setProdAtt8, setProdAtt9, setProdHier, setPrRefMat, setPrRefMatExternal, setPrRefMatGuid, setPrRefMatVersion, setRebateGrp, setRoundProf, setSalesOrg, setSalesUnit, setSalesUnitIso, setSalStatus, setUnitGroup, setValidFrom, setVarSalesUn, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesDataList

public SalesDataList()
販売データ情報を作成します。

SalesDataList

public SalesDataList(int index)
販売データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageLocationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
StorageLocationDataList
public class StorageLocationData
extends Object
implements Serializable

品目データ (保管場所レベル)情報クラス
機能は以下の通り

  • 品目データ (保管場所レベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationData()
品目データ (保管場所レベル)情報を作成します。
メソッドの概要
String | getCurrPeriod() 当期 (転記期間)を取得します。
String | getDelFlag() 保管場所レベルでの品目削除フラグを取得します。
String | getFiscYear() 当会計年度を取得します。
String | getFunction() BAPI 機能を取得します。
String | getInvCorrFac() 在庫修正係数を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMrpInd() 保管場所 MRP 区分を取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getPickgArea() 簡易倉庫管理のピッキングエリアを取得します。
String | getPlant() プラントを取得します。
String | getReorderPt() 保管場所 MRP に対する発注点を取得します。
String | getReplQty() 保管場所 MRP に対する補充数量を取得します。
String | getSpecProc() 保管場所レベルでの特殊調達タイプを取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStorageView() 保管ビューを取得します。
void | setCurrPeriod(String currPeriod) 当期 (転記期間)を設定します。
void | setDelFlag(String delFlag) 保管場所レベルでの品目削除フラグを設定します。
void | setFiscYear(String fiscYear) 当会計年度を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setInvCorrFac(String invCorrFac) 在庫修正係数を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMrpInd(String mrpInd) 保管場所 MRP 区分を設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setPickgArea(String pickgArea) 簡易倉庫管理のピッキングエリアを設定します。
void | setPlant(String plant) プラントを設定します。
void | setReorderPt(String reorderPt) 保管場所 MRP に対する発注点を設定します。
void | setReplQty(String replQty) 保管場所 MRP に対する補充数量を設定します。
void | setSpecProc(String specProc) 保管場所レベルでの特殊調達タイプを設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationData

public StorageLocationData()
品目データ (保管場所レベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
保管場所レベルでの品目削除フラグを取得します。

戻り値:
delFlag 保管場所レベルでの品目削除フラグ

getFiscYear

public String getFiscYear()
当会計年度を取得します。

戻り値:
fiscYear 当会計年度

getCurrPeriod

public String getCurrPeriod()
当期 (転記期間)を取得します。

戻り値:
currPeriod 当期 (転記期間)

getMrpInd

public String getMrpInd()
保管場所 MRP 区分を取得します。

戻り値:
mrpInd 保管場所 MRP 区分

getSpecProc

public String getSpecProc()
保管場所レベルでの特殊調達タイプを取得します。

戻り値:
specProc 保管場所レベルでの特殊調達タイプ

getReorderPt

public String getReorderPt()
保管場所 MRP に対する発注点を取得します。

戻り値:
reorderPt 保管場所 MRP に対する発注点

getReplQty

public String getReplQty()
保管場所 MRP に対する補充数量を取得します。

戻り値:
replQty 保管場所 MRP に対する補充数量

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getPickgArea

public String getPickgArea()
簡易倉庫管理のピッキングエリアを取得します。

戻り値:
pickgArea 簡易倉庫管理のピッキングエリア

getInvCorrFac

public String getInvCorrFac()
在庫修正係数を取得します。

戻り値:
invCorrFac 在庫修正係数

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
保管場所レベルでの品目削除フラグを設定します。

パラメータ:
delFlag - 保管場所レベルでの品目削除フラグ

setFiscYear

public void setFiscYear(String fiscYear)
当会計年度を設定します。

パラメータ:
fiscYear - 当会計年度

setCurrPeriod

public void setCurrPeriod(String currPeriod)
当期 (転記期間)を設定します。

パラメータ:
currPeriod - 当期 (転記期間)

setMrpInd

public void setMrpInd(String mrpInd)
保管場所 MRP 区分を設定します。

パラメータ:
mrpInd - 保管場所 MRP 区分

setSpecProc

public void setSpecProc(String specProc)
保管場所レベルでの特殊調達タイプを設定します。

パラメータ:
specProc - 保管場所レベルでの特殊調達タイプ

setReorderPt

public void setReorderPt(String reorderPt)
保管場所 MRP に対する発注点を設定します。

パラメータ:
reorderPt - 保管場所 MRP に対する発注点

setReplQty

public void setReplQty(String replQty)
保管場所 MRP に対する補充数量を設定します。

パラメータ:
replQty - 保管場所 MRP に対する補充数量

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setPickgArea

public void setPickgArea(String pickgArea)
簡易倉庫管理のピッキングエリアを設定します。

パラメータ:
pickgArea - 簡易倉庫管理のピッキングエリア

setInvCorrFac

public void setInvCorrFac(String invCorrFac)
在庫修正係数を設定します。

パラメータ:
invCorrFac - 在庫修正係数

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageLocationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList
すべての実装インタフェース:
Serializable
public class StorageLocationDataList
extends StorageLocationData
implements Serializable

品目データ (保管場所レベル)情報クラス
機能は以下の通り

  • 品目データ (保管場所レベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationDataList()
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList(int index)
品目データ (保管場所レベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData から継承したメソッド
getCurrPeriod, getDelFlag, getFiscYear, getFunction, getInvCorrFac, getMaintStat, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMrpInd, getMrpView, getPickgArea, getPlant, getReorderPt, getReplQty, getSpecProc, getStgeBin, getStgeLoc, getStorageView, setCurrPeriod, setDelFlag, setFiscYear, setFunction, setInvCorrFac, setMaintStat, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMrpInd, setMrpView, setPickgArea, setPlant, setReorderPt, setReplQty, setSpecProc, setStgeBin, setStgeLoc, setStorageView, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationDataList

public StorageLocationDataList()
品目データ (保管場所レベル)情報を作成します。

StorageLocationDataList

public StorageLocationDataList(int index)
品目データ (保管場所レベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageTypeData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageTypeData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
StorageTypeDataList
public class StorageTypeData
extends Object
implements Serializable

保管域タイプデータ情報クラス
機能は以下の通り

  • 保管域タイプデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageTypeData()
保管域タイプデータ情報を作成します。
メソッドの概要
String | getCtrlQty() 管理数量を取得します。
String | getDelFlag() 保管タイプに該当する全品目データ削除フラグを取得します。
String | getFunction() BAPI 機能を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMaxSbQty() 最大棚番在庫数量を取得します。
String | getMinSbQty() 最小棚番在庫数量を取得します。
String | getPickArea() ピッキングエリアを取得します。
String | getReplenQty() 補充数量を取得します。
String | getRoundQty() 丸め数量を取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeType() 保管域タイプを取得します。
String | getWhseNo() 倉庫番号/複合倉庫を取得します。
void | setCtrlQty(String ctrlQty) 管理数量を設定します。
void | setDelFlag(String delFlag) 保管タイプに該当する全品目データ削除フラグを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMaxSbQty(String maxSbQty) 最大棚番在庫数量を設定します。
void | setMinSbQty(String minSbQty) 最小棚番在庫数量を設定します。
void | setPickArea(String pickArea) ピッキングエリアを設定します。
void | setReplenQty(String replenQty) 補充数量を設定します。
void | setRoundQty(String roundQty) 丸め数量を設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeType(String stgeType) 保管域タイプを設定します。
void | setWhseNo(String whseNo) 倉庫番号/複合倉庫を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageTypeData

public StorageTypeData()
保管域タイプデータ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getWhseNo

public String getWhseNo()
倉庫番号/複合倉庫を取得します。

戻り値:
whseNo 倉庫番号/複合倉庫

getStgeType

public String getStgeType()
保管域タイプを取得します。

戻り値:
stgeType 保管域タイプ

getDelFlag

public String getDelFlag()
保管タイプに該当する全品目データ削除フラグを取得します。

戻り値:
delFlag 保管タイプに該当する全品目データ削除フラグ

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getMaxSbQty

public String getMaxSbQty()
最大棚番在庫数量を取得します。

戻り値:
maxSbQty 最大棚番在庫数量

getMinSbQty

public String getMinSbQty()
最小棚番在庫数量を取得します。

戻り値:
minSbQty 最小棚番在庫数量

getCtrlQty

public String getCtrlQty()
管理数量を取得します。

戻り値:
ctrlQty 管理数量

getReplenQty

public String getReplenQty()
補充数量を取得します。

戻り値:
replenQty 補充数量

getPickArea

public String getPickArea()
ピッキングエリアを取得します。

戻り値:
pickArea ピッキングエリア

getRoundQty

public String getRoundQty()
丸め数量を取得します。

戻り値:
roundQty 丸め数量

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setWhseNo

public void setWhseNo(String whseNo)
倉庫番号/複合倉庫を設定します。

パラメータ:
whseNo - 倉庫番号/複合倉庫

setStgeType

public void setStgeType(String stgeType)
保管域タイプを設定します。

パラメータ:
stgeType - 保管域タイプ

setDelFlag

public void setDelFlag(String delFlag)
保管タイプに該当する全品目データ削除フラグを設定します。

パラメータ:
delFlag - 保管タイプに該当する全品目データ削除フラグ

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setMaxSbQty

public void setMaxSbQty(String maxSbQty)
最大棚番在庫数量を設定します。

パラメータ:
maxSbQty - 最大棚番在庫数量

setMinSbQty

public void setMinSbQty(String minSbQty)
最小棚番在庫数量を設定します。

パラメータ:
minSbQty - 最小棚番在庫数量

setCtrlQty

public void setCtrlQty(String ctrlQty)
管理数量を設定します。

パラメータ:
ctrlQty - 管理数量

setReplenQty

public void setReplenQty(String replenQty)
補充数量を設定します。

パラメータ:
replenQty - 補充数量

setPickArea

public void setPickArea(String pickArea)
ピッキングエリアを設定します。

パラメータ:
pickArea - ピッキングエリア

setRoundQty

public void setRoundQty(String roundQty)
丸め数量を設定します。

パラメータ:
roundQty - 丸め数量

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageTypeDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageTypeDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList
すべての実装インタフェース:
Serializable
public class StorageTypeDataList
extends StorageTypeData
implements Serializable

保管域タイプデータ情報クラス
機能は以下の通り

  • 保管域タイプデータ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageTypeDataList()
保管域タイプデータ情報を作成します。
StorageTypeDataList(int index)
保管域タイプデータ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData から継承したメソッド
getCtrlQty, getDelFlag, getFunction, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMaxSbQty, getMinSbQty, getPickArea, getReplenQty, getRoundQty, getStgeBin, getStgeType, getWhseNo, setCtrlQty, setDelFlag, setFunction, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMaxSbQty, setMinSbQty, setPickArea, setReplenQty, setRoundQty, setStgeBin, setStgeType, setWhseNo, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageTypeDataList

public StorageTypeDataList()
保管域タイプデータ情報を作成します。

StorageTypeDataList

public StorageTypeDataList(int index)
保管域タイプデータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TaxClassifications (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス TaxClassifications

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications
すべての実装インタフェース:
Serializable
public class TaxClassifications
extends Object
implements Serializable

制御デ－タ情報クラス
機能は以下の通り

  • 制御デ－タ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TaxClassifications()
制御デ－タ情報を作成します。
TaxClassifications(int index)
制御デ－タ情報を作成します。
メソッドの概要
String | getDepcountry() 出荷国 (商品発送国)を取得します。
String | getDepcountryIso() 出荷国の ISO コードを取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getTaxclass1() 品目の税分類を取得します。
String | getTaxclass2() 品目の税分類を取得します。
String | getTaxclass3() 品目の税分類を取得します。
String | getTaxclass4() 品目の税分類を取得します。
String | getTaxclass5() 品目の税分類を取得します。
String | getTaxclass6() 品目の税分類を取得します。
String | getTaxclass7() 品目の税分類を取得します。
String | getTaxclass8() 品目の税分類を取得します。
String | getTaxclass9() 品目の税分類を取得します。
String | getTaxInd() 税区分: 品目 (購買管理)を取得します。
String | getTaxType1() 税カテゴリ (消費税等)を取得します。
String | getTaxType2() 税カテゴリ (消費税等)を取得します。
String | getTaxType3() 税カテゴリ (消費税等)を取得します。
String | getTaxType4() 税カテゴリ (消費税等)を取得します。
String | getTaxType5() 税カテゴリ (消費税等)を取得します。
String | getTaxType6() 税カテゴリ (消費税等)を取得します。
String | getTaxType7() 税カテゴリ (消費税等)を取得します。
String | getTaxType8() 税カテゴリ (消費税等)を取得します。
String | getTaxType9() 税カテゴリ (消費税等)を取得します。
void | setDepcountry(String depcountry) 出荷国 (商品発送国)を設定します。
void | setDepcountryIso(String depcountryIso) 出荷国の ISO コードを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setTaxclass1(String taxclass1) 品目の税分類を設定します。
void | setTaxclass2(String taxclass2) 品目の税分類を設定します。
void | setTaxclass3(String taxclass3) 品目の税分類を設定します。
void | setTaxclass4(String taxclass4) 品目の税分類を設定します。
void | setTaxclass5(String taxclass5) 品目の税分類を設定します。
void | setTaxclass6(String taxclass6) 品目の税分類を設定します。
void | setTaxclass7(String taxclass7) 品目の税分類を設定します。
void | setTaxclass8(String taxclass8) 品目の税分類を設定します。
void | setTaxclass9(String taxclass9) 品目の税分類を設定します。
void | setTaxInd(String taxInd) 税区分: 品目 (購買管理)を設定します。
void | setTaxType1(String taxType1) 税カテゴリ (消費税等)を設定します。
void | setTaxType2(String taxType2) 税カテゴリ (消費税等)を設定します。
void | setTaxType3(String taxType3) 税カテゴリ (消費税等)を設定します。
void | setTaxType4(String taxType4) 税カテゴリ (消費税等)を設定します。
void | setTaxType5(String taxType5) 税カテゴリ (消費税等)を設定します。
void | setTaxType6(String taxType6) 税カテゴリ (消費税等)を設定します。
void | setTaxType7(String taxType7) 税カテゴリ (消費税等)を設定します。
void | setTaxType8(String taxType8) 税カテゴリ (消費税等)を設定します。
void | setTaxType9(String taxType9) 税カテゴリ (消費税等)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TaxClassifications

public TaxClassifications()
制御デ－タ情報を作成します。

TaxClassifications

public TaxClassifications(int index)
制御デ－タ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getDepcountry

public String getDepcountry()
出荷国 (商品発送国)を取得します。

戻り値:
depcountry 出荷国 (商品発送国)

getDepcountryIso

public String getDepcountryIso()
出荷国の ISO コードを取得します。

戻り値:
depcountryIso 出荷国の ISO コード

getTaxType1

public String getTaxType1()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType1 税カテゴリ (消費税等)

getTaxclass1

public String getTaxclass1()
品目の税分類を取得します。

戻り値:
taxclass1 品目の税分類

getTaxType2

public String getTaxType2()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType2 税カテゴリ (消費税等)

getTaxclass2

public String getTaxclass2()
品目の税分類を取得します。

戻り値:
taxclass2 品目の税分類

getTaxType3

public String getTaxType3()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType3 税カテゴリ (消費税等)

getTaxclass3

public String getTaxclass3()
品目の税分類を取得します。

戻り値:
taxclass3 品目の税分類

getTaxType4

public String getTaxType4()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType4 税カテゴリ (消費税等)

getTaxclass4

public String getTaxclass4()
品目の税分類を取得します。

戻り値:
taxclass4 品目の税分類

getTaxType5

public String getTaxType5()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType5 税カテゴリ (消費税等)

getTaxclass5

public String getTaxclass5()
品目の税分類を取得します。

戻り値:
taxclass5 品目の税分類

getTaxType6

public String getTaxType6()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType6 税カテゴリ (消費税等)

getTaxclass6

public String getTaxclass6()
品目の税分類を取得します。

戻り値:
taxclass6 品目の税分類

getTaxType7

public String getTaxType7()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType7 税カテゴリ (消費税等)

getTaxclass7

public String getTaxclass7()
品目の税分類を取得します。

戻り値:
taxclass7 品目の税分類

getTaxType8

public String getTaxType8()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType8 税カテゴリ (消費税等)

getTaxclass8

public String getTaxclass8()
品目の税分類を取得します。

戻り値:
taxclass8 品目の税分類

getTaxType9

public String getTaxType9()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType9 税カテゴリ (消費税等)

getTaxclass9

public String getTaxclass9()
品目の税分類を取得します。

戻り値:
taxclass9 品目の税分類

getTaxInd

public String getTaxInd()
税区分: 品目 (購買管理)を取得します。

戻り値:
taxInd 税区分: 品目 (購買管理)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setDepcountry

public void setDepcountry(String depcountry)
出荷国 (商品発送国)を設定します。

パラメータ:
depcountry - 出荷国 (商品発送国)

setDepcountryIso

public void setDepcountryIso(String depcountryIso)
出荷国の ISO コードを設定します。

パラメータ:
depcountryIso - 出荷国の ISO コード

setTaxType1

public void setTaxType1(String taxType1)
税カテゴリ (消費税等)を設定します。

setTaxclass1

public void setTaxclass1(String taxclass1)
品目の税分類を設定します。

setTaxType2

public void setTaxType2(String taxType2)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType2 - 税カテゴリ (消費税等)

setTaxclass2

public void setTaxclass2(String taxclass2)
品目の税分類を設定します。

パラメータ:
taxclass2 - 品目の税分類

setTaxType3

public void setTaxType3(String taxType3)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType3 - 税カテゴリ (消費税等)

setTaxclass3

public void setTaxclass3(String taxclass3)
品目の税分類を設定します。

パラメータ:
taxclass3 - 品目の税分類

setTaxType4

public void setTaxType4(String taxType4)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType4 - 税カテゴリ (消費税等)

setTaxclass4

public void setTaxclass4(String taxclass4)
品目の税分類を設定します。

パラメータ:
taxclass4 - 品目の税分類

setTaxType5

public void setTaxType5(String taxType5)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType5 - 税カテゴリ (消費税等)

setTaxclass5

public void setTaxclass5(String taxclass5)
品目の税分類を設定します。

パラメータ:
taxclass5 - 品目の税分類

setTaxType6

public void setTaxType6(String taxType6)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType6 - 税カテゴリ (消費税等)

setTaxclass6

public void setTaxclass6(String taxclass6)
品目の税分類を設定します。

パラメータ:
taxclass6 - 品目の税分類

setTaxType7

public void setTaxType7(String taxType7)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType7 - 税カテゴリ (消費税等)

setTaxclass7

public void setTaxclass7(String taxclass7)
品目の税分類を設定します。

パラメータ:
taxclass7 - 品目の税分類

setTaxType8

public void setTaxType8(String taxType8)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType8 - 税カテゴリ (消費税等)

setTaxclass8

public void setTaxclass8(String taxclass8)
品目の税分類を設定します。

パラメータ:
taxclass8 - 品目の税分類

setTaxType9

public void setTaxType9(String taxType9)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType9 - 税カテゴリ (消費税等)

setTaxclass9

public void setTaxclass9(String taxclass9)
品目の税分類を設定します。

パラメータ:
taxclass9 - 品目の税分類

setTaxInd

public void setTaxInd(String taxInd)
税区分: 品目 (購買管理)を設定します。

パラメータ:
taxInd - 税区分: 品目 (購買管理)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnitSofmeasure (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス UnitSofmeasure

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure
すべての実装インタフェース:
Serializable
public class UnitSofmeasure
extends Object
implements Serializable

数量単位情報クラス
機能は以下の通り

  • 数量単位情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UnitSofmeasure()
数量単位情報を作成します。
UnitSofmeasure(int index)
数量単位情報を作成します。
メソッドの概要
String | getAltUnit() 在庫保管単位の代替数量単位を取得します。
String | getAltUnitIso() ISO コードによる在庫単位の代替数量単位を取得します。
String | getCharUnit() 特性の数量単位を取得します。
String | getCharUnitIso() 下位レベル数量単位 (ISO コード)を取得します。
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getDenominatr() 分母: 基本数量単位へ変換する場合を取得します。
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getFunction() BAPI 機能を取得します。
String | getGrossWt() 総重量を取得します。
String | getGtinVariant() グローバルトレード明細番号バリアントを取得します。
String | getHeight() 高さを取得します。
int | getIndex() レコード番号を取得します｡
String | getInternalChar() 内部特性を取得します。
String | getLeadinguom() 主要ロット特定数量単位を取得します。
String | getLength() 長さを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMeAnzSub() 下位レベル数量単位数を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNumerator() 基本数量単位への換算分子を取得します。
String | getSubUom() 梱包階層の下位レベル数量単位を取得します。
String | getSubUomIso() 下位レベル数量単位 (ISO コード)を取得します。
String | getUnitDim() 寸法単位 (長さ/幅/高さ)を取得します。
String | getUnitDimIso() ISO コードでの長さ、幅、高さの単位を取得します。
String | getUnitOfWt() 重量単位を取得します。
String | getUnitOfWtIso() ISO コードでの重量単位を取得します。
String | getUomsortnumber() 数量単位ソート番号を取得します。
String | getValueduom() ロット特定数量単位での評価を取得します。
String | getVolume() 容積を取得します。
String | getVolumeunit() 容積単位を取得します。
String | getVolumeunitIso() ISO コードでの容積単位を取得します。
String | getWidth() 幅を取得します。
void | setAltUnit(String altUnit) 在庫保管単位の代替数量単位を設定します。
void | setAltUnitIso(String altUnitIso) ISO コードによる在庫単位の代替数量単位を設定します。
void | setCharUnit(String charUnit) 特性の数量単位を設定します。
void | setCharUnitIso(String charUnitIso) 下位レベル数量単位 (ISO コード)を設定します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setDenominatr(String denominatr) 分母: 基本数量単位へ変換する場合を設定します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGrossWt(String grossWt) 総重量を設定します。
void | setGtinVariant(String gtinVariant) グローバルトレード明細番号バリアントを設定します。
void | setHeight(String height) 高さを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInternalChar(String internalChar) 内部特性を設定します。
void | setLeadinguom(String leadinguom) 主要ロット特定数量単位を設定します。
void | setLength(String length) 長さを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMeAnzSub(String meAnzSub) 下位レベル数量単位数を設定します。
void | setNetWeight(String netWeight) 正味重量を設定します。
void | setNumerator(String numerator) 基本数量単位への換算分子を設定します。
void | setSubUom(String subUom) 梱包階層の下位レベル数量単位を設定します。
void | setSubUomIso(String subUomIso) 下位レベル数量単位 (ISO コード)を設定します。
void | setUnitDim(String unitDim) 寸法単位 (長さ/幅/高さ)を設定します。
void | setUnitDimIso(String unitDimIso) ISO コードでの長さ、幅、高さの単位を設定します。
void | setUnitOfWt(String unitOfWt) 重量単位を設定します。
void | setUnitOfWtIso(String unitOfWtIso) ISO コードでの重量単位を設定します。
void | setUomsortnumber(String uomsortnumber) 数量単位ソート番号を設定します。
void | setValueduom(String valueduom) ロット特定数量単位での評価を設定します。
void | setVolume(String volume) 容積を設定します。
void | setVolumeunit(String volumeunit) 容積単位を設定します。
void | setVolumeunitIso(String volumeunitIso) ISO コードでの容積単位を設定します。
void | setWidth(String width) 幅を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnitSofmeasure

public UnitSofmeasure()
数量単位情報を作成します。

UnitSofmeasure

public UnitSofmeasure(int index)
数量単位情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getAltUnit

public String getAltUnit()
在庫保管単位の代替数量単位を取得します。

戻り値:
altUnit 在庫保管単位の代替数量単位

getAltUnitIso

public String getAltUnitIso()
ISO コードによる在庫単位の代替数量単位を取得します。

戻り値:
altUnitIso ISO コードによる在庫単位の代替数量単位

getNumerator

public String getNumerator()
基本数量単位への換算分子を取得します。

戻り値:
numerator 基本数量単位への換算分子

getDenominatr

public String getDenominatr()
分母: 基本数量単位へ変換する場合を取得します。

戻り値:
denominatr 分母: 基本数量単位へ変換する場合

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getLength

public String getLength()
長さを取得します。

戻り値:
length 長さ

getWidth

public String getWidth()
幅を取得します。

戻り値:
width 幅

getHeight

public String getHeight()
高さを取得します。

戻り値:
height 高さ

getUnitDim

public String getUnitDim()
寸法単位 (長さ/幅/高さ)を取得します。

戻り値:
unitDim 寸法単位 (長さ/幅/高さ)

getUnitDimIso

public String getUnitDimIso()
ISO コードでの長さ、幅、高さの単位を取得します。

戻り値:
unitDimIso ISO コードでの長さ、幅、高さの単位

getVolume

public String getVolume()
容積を取得します。

戻り値:
volume 容積

getVolumeunit

public String getVolumeunit()
容積単位を取得します。

戻り値:
volumeunit 容積単位

getVolumeunitIso

public String getVolumeunitIso()
ISO コードでの容積単位を取得します。

戻り値:
volumeunitIso ISO コードでの容積単位

getGrossWt

public String getGrossWt()
総重量を取得します。

戻り値:
grossWt 総重量

getUnitOfWt

public String getUnitOfWt()
重量単位を取得します。

戻り値:
unitOfWt 重量単位

getUnitOfWtIso

public String getUnitOfWtIso()
ISO コードでの重量単位を取得します。

戻り値:
unitOfWtIso ISO コードでの重量単位

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getSubUom

public String getSubUom()
梱包階層の下位レベル数量単位を取得します。

戻り値:
subUom 梱包階層の下位レベル数量単位

getSubUomIso

public String getSubUomIso()
下位レベル数量単位 (ISO コード)を取得します。

戻り値:
subUomIso 下位レベル数量単位 (ISO コード)

getInternalChar

public String getInternalChar()
内部特性を取得します。

戻り値:
internalChar 内部特性

getUomsortnumber

public String getUomsortnumber()
数量単位ソート番号を取得します。

戻り値:
uomsortnumber 数量単位ソート番号

getLeadinguom

public String getLeadinguom()
主要ロット特定数量単位を取得します。

戻り値:
leadinguom 主要ロット特定数量単位

getValueduom

public String getValueduom()
ロット特定数量単位での評価を取得します。

戻り値:
valueduom ロット特定数量単位での評価

getCharUnit

public String getCharUnit()
特性の数量単位を取得します。

戻り値:
charUnit 特性の数量単位

getCharUnitIso

public String getCharUnitIso()
下位レベル数量単位 (ISO コード)を取得します。

戻り値:
charUnitIso 下位レベル数量単位 (ISO コード)

getGtinVariant

public String getGtinVariant()
グローバルトレード明細番号バリアントを取得します。

戻り値:
gtinVariant グローバルトレード明細番号バリアント

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
netWeight 正味重量

getMeAnzSub

public String getMeAnzSub()
下位レベル数量単位数を取得します。

戻り値:
meAnzSub 下位レベル数量単位数

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setAltUnit

public void setAltUnit(String altUnit)
在庫保管単位の代替数量単位を設定します。

パラメータ:
altUnit - 在庫保管単位の代替数量単位

setAltUnitIso

public void setAltUnitIso(String altUnitIso)
ISO コードによる在庫単位の代替数量単位を設定します。

パラメータ:
altUnitIso - ISO コードによる在庫単位の代替数量単位

setNumerator

public void setNumerator(String numerator)
基本数量単位への換算分子を設定します。

パラメータ:
numerator - 基本数量単位への換算分子

setDenominatr

public void setDenominatr(String denominatr)
分母: 基本数量単位へ変換する場合を設定します。

パラメータ:
denominatr - 分母: 基本数量単位へ変換する場合

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setLength

public void setLength(String length)
長さを設定します。

パラメータ:
length - 長さ

setWidth

public void setWidth(String width)
幅を設定します。

パラメータ:
width - 幅

setHeight

public void setHeight(String height)
高さを設定します。

パラメータ:
height - 高さ

setUnitDim

public void setUnitDim(String unitDim)
寸法単位 (長さ/幅/高さ)を設定します。

パラメータ:
unitDim - 寸法単位 (長さ/幅/高さ)

setUnitDimIso

public void setUnitDimIso(String unitDimIso)
ISO コードでの長さ、幅、高さの単位を設定します。

パラメータ:
unitDimIso - ISO コードでの長さ、幅、高さの単位

setVolume

public void setVolume(String volume)
容積を設定します。

パラメータ:
volume - 容積

setVolumeunit

public void setVolumeunit(String volumeunit)
容積単位を設定します。

パラメータ:
volumeunit - 容積単位

setVolumeunitIso

public void setVolumeunitIso(String volumeunitIso)
ISO コードでの容積単位を設定します。

パラメータ:
volumeunitIso - ISO コードでの容積単位

setGrossWt

public void setGrossWt(String grossWt)
総重量を設定します。

パラメータ:
grossWt - 総重量

setUnitOfWt

public void setUnitOfWt(String unitOfWt)
重量単位を設定します。

パラメータ:
unitOfWt - 重量単位

setUnitOfWtIso

public void setUnitOfWtIso(String unitOfWtIso)
ISO コードでの重量単位を設定します。

パラメータ:
unitOfWtIso - ISO コードでの重量単位

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setSubUom

public void setSubUom(String subUom)
梱包階層の下位レベル数量単位を設定します。

パラメータ:
subUom - 梱包階層の下位レベル数量単位

setSubUomIso

public void setSubUomIso(String subUomIso)
下位レベル数量単位 (ISO コード)を設定します。

パラメータ:
subUomIso - 下位レベル数量単位 (ISO コード)

setInternalChar

public void setInternalChar(String internalChar)
内部特性を設定します。

パラメータ:
internalChar - 内部特性

setUomsortnumber

public void setUomsortnumber(String uomsortnumber)
数量単位ソート番号を設定します。

パラメータ:
uomsortnumber - 数量単位ソート番号

setLeadinguom

public void setLeadinguom(String leadinguom)
主要ロット特定数量単位を設定します。

パラメータ:
leadinguom - 主要ロット特定数量単位

setValueduom

public void setValueduom(String valueduom)
ロット特定数量単位での評価を設定します。

パラメータ:
valueduom - ロット特定数量単位での評価

setCharUnit

public void setCharUnit(String charUnit)
特性の数量単位を設定します。

パラメータ:
charUnit - 特性の数量単位

setCharUnitIso

public void setCharUnitIso(String charUnitIso)
下位レベル数量単位 (ISO コード)を設定します。

パラメータ:
charUnitIso - 下位レベル数量単位 (ISO コード)

setGtinVariant

public void setGtinVariant(String gtinVariant)
グローバルトレード明細番号バリアントを設定します。

パラメータ:
gtinVariant - グローバルトレード明細番号バリアント

setNetWeight

public void setNetWeight(String netWeight)
正味重量を設定します。

パラメータ:
netWeight - 正味重量

setMeAnzSub

public void setMeAnzSub(String meAnzSub)
下位レベル数量単位数を設定します。

パラメータ:
meAnzSub - 下位レベル数量単位数

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValuationData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ValuationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ValuationDataList
public class ValuationData
extends Object
implements Serializable

評価データ情報クラス
機能は以下の通り

  • 評価データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ValuationData()
評価データ情報を作成します。
メソッドの概要
String | getAccountView() 会計ビューを取得します。
String | getCommprice1() 商法による評価額: レベル 1を取得します。
String | getCommprice2() 商法による評価額: レベル 2を取得します。
String | getCommprice3() 商法基準評価額: レベル 3を取得します。
String | getCostView() 原価計算ビューを取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getCurrPeriod() 当期 (転記期間)を取得します。
String | getCurrPlanPrice() 税法基準評価額: レベル 2を取得します。
String | getDelFlag() 評価タイプに該当する全品目データ削除フラグを取得します。
String | getDevalInd() 低価法: 評価減区分を取得します。
String | getFijCurCostEst() 当期標準原価見積の会計年度を取得します。
String | getFijFutCostEst() 将来標準原価見積の会計年度を取得します。
String | getFijPreCostEst() 前期標準原価見積の会計年度を取得します。
String | getFiscYear() 当会計年度を取得します。
String | getFunction() BAPI 機能を取得します。
String | getFuturePr() 次期標準原価を取得します。
String | getInHouse() 内部生産を取得します。
String | getLifoFifo() LIFO/FIFO 関連を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMatlUsage() 品目の用途を取得します。
String | getMatOrigin() 品目の原産地を取得します。
String | getMlActive() 品目レベルで有効な品目元帳を取得します。
String | getMlSettle() 品目元帳決済: 管理を取得します。
String | getMovingPr() 移動平均原価/期間単位価格を取得します。
String | getMovPrPp() 前期移動平均原価/期間平均原価を取得します。
String | getMovPrPy() 前年度の移動平均原価/期間単価を取得します。
String | getOrigGroup() 発生源グループ (原価要素の下位区分)を取得します。
String | getOrigMat() 品目発生源を取得します。
String | getOverheadGrp() 原価計算間接費グループを取得します。
String | getPerCurCostEst() 現行標準原価見積期間を取得します。
String | getPerFutCostEst() 将来標準原価見積期間を取得します。
String | getPerPreCostEst() 前標準原価見積期間を取得します。
String | getPlndprdate1() 予定原価 1 の有効開始日を取得します。
String | getPlndprdate2() 予定原価 2 の有効開始日を取得します。
String | getPlndprdate3() 予定原価 3 の有効開始日を取得します。
String | getPlndPrice() 予定計画原価を取得します。
String | getPlndprice1() 予定計画原価 1を取得します。
String | getPlndprice2() 予定計画原価 2を取得します。
String | getPlndprice3() 予定計画原価 3を取得します。
String | getPoolnumber() LIFO 評価でのプール番号を取得します。
String | getPrCtrlPp() 前期間の原価管理区分を取得します。
String | getPrCtrlPy() 前年度の原価管理区分を取得します。
String | getPrevPlanPrice() 税法基準評価額: レベル 2を取得します。
String | getPriceCtrl() 原価管理区分を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getPrUnitPp() 前期価格単位を取得します。
String | getPrUnitPy() 前年度価格単位を取得します。
String | getQtyStruct() 数量構成により原価計算を行う品目を取得します。
String | getStdPrice() 標準原価を取得します。
String | getStdPrPp() 前期標準標準原価を取得します。
String | getStdPrPy() 前年度標準原価を取得します。
String | getTaxCmlUn() 税法/商法にもとづく評価額価格単位を取得します。
String | getTaxprice1() 税法による評価額: レベル 1を取得します。
String | getTaxprice2() 税法による評価額: レベル 2を取得します。
String | getTaxprice3() 税法基準評価額: レベル 3を取得します。
String | getValArea() 評価レベルを取得します。
String | getValCat() 評価カテゴリを取得します。
String | getValClass() 評価クラスを取得します。
String | getValidFrom() 原価有効開始日を取得します。
String | getValType() 評価タイプを取得します。
String | getVclassPp() 前期評価クラスを取得します。
String | getVclassPy() 前年度の評価クラスを取得します。
String | getVmPStock() プロジェクト在庫の評価クラスを取得します。
String | getVmSoStk() 受注在庫の評価クラスを取得します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setCommprice1(String commprice1) 商法による評価額: レベル 1を設定します。
void | setCommprice2(String commprice2) 商法による評価額: レベル 2を設定します。
void | setCommprice3(String commprice3) 商法基準評価額: レベル 3を設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setCurrPeriod(String currPeriod) 当期 (転記期間)を設定します。
void | setCurrPlanPrice(String currPlanPrice) 税法基準評価額: レベル 2を設定します。
void | setDelFlag(String delFlag) 評価タイプに該当する全品目データ削除フラグを設定します。
void | setDevalInd(String devalInd) 低価法: 評価減区分を設定します。
void | setFijCurCostEst(String fijCurCostEst) 当期標準原価見積の会計年度を設定します。
void | setFijFutCostEst(String fijFutCostEst) 将来標準原価見積の会計年度を設定します。
void | setFijPreCostEst(String fijPreCostEst) 前期標準原価見積の会計年度を設定します。
void | setFiscYear(String fiscYear) 当会計年度を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFuturePr(String futurePr) 次期標準原価を設定します。
void | setInHouse(String inHouse) 内部生産を設定します。
void | setLifoFifo(String lifoFifo) LIFO/FIFO 関連を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMatlUsage(String matlUsage) 品目の用途を設定します。
void | setMatOrigin(String matOrigin) 品目の原産地を設定します。
void | setMlActive(String mlActive) 品目レベルで有効な品目元帳を設定します。
void | setMlSettle(String mlSettle) 品目元帳決済: 管理を設定します。
void | setMovingPr(String movingPr) 移動平均原価/期間単位価格を設定します。
void | setMovPrPp(String movPrPp) 前期移動平均原価/期間平均原価を設定します。
void | setMovPrPy(String movPrPy) 前年度の移動平均原価/期間単価を設定します。
void | setOrigGroup(String origGroup) 発生源グループ (原価要素の下位区分)を設定します。
void | setOrigMat(String origMat) 品目発生源を設定します。
void | setOverheadGrp(String overheadGrp) 原価計算間接費グループを設定します。
void | setPerCurCostEst(String perCurCostEst) 現行標準原価見積期間を設定します。
void | setPerFutCostEst(String perFutCostEst) 将来標準原価見積期間を設定します。
void | setPerPreCostEst(String perPreCostEst) 前標準原価見積期間を設定します。
void | setPlndprdate1(String plndprdate1) 予定原価 1 の有効開始日を設定します。
void | setPlndprdate2(String plndprdate2) 予定原価 2 の有効開始日を設定します。
void | setPlndprdate3(String plndprdate3) 予定原価 3 の有効開始日を設定します。
void | setPlndPrice(String plndPrice) 予定計画原価を設定します。
void | setPlndprice1(String plndprice1) 予定計画原価 1を設定します。
void | setPlndprice2(String plndprice2) 予定計画原価 2を設定します。
void | setPlndprice3(String plndprice3) 予定計画原価 3を設定します。
void | setPoolnumber(String poolnumber) LIFO 評価でのプール番号を設定します。
void | setPrCtrlPp(String prCtrlPp) 前期間の原価管理区分を設定します。
void | setPrCtrlPy(String prCtrlPy) 前年度の原価管理区分を設定します。
void | setPrevPlanPrice(String prevPlanPrice) 税法基準評価額: レベル 2を設定します。
void | setPriceCtrl(String priceCtrl) 原価管理区分を設定します。
void | setPriceUnit(String priceUnit) 価格単位を設定します。
void | setPrUnitPp(String prUnitPp) 前期価格単位を設定します。
void | setPrUnitPy(String prUnitPy) 前年度価格単位を設定します。
void | setQtyStruct(String qtyStruct) 数量構成により原価計算を行う品目を設定します。
void | setStdPrice(String stdPrice) 標準原価を設定します。
void | setStdPrPp(String stdPrPp) 前期標準標準原価を設定します。
void | setStdPrPy(String stdPrPy) 前年度標準原価を設定します。
void | setTaxCmlUn(String taxCmlUn) 税法/商法にもとづく評価額価格単位を設定します。
void | setTaxprice1(String taxprice1) 税法による評価額: レベル 1を設定します。
void | setTaxprice2(String taxprice2) 税法による評価額: レベル 2を設定します。
void | setTaxprice3(String taxprice3) 税法基準評価額: レベル 3を設定します。
void | setValArea(String valArea) 評価レベルを設定します。
void | setValCat(String valCat) 評価カテゴリを設定します。
void | setValClass(String valClass) 評価クラスを設定します。
void | setValidFrom(String validFrom) 原価有効開始日を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setVclassPp(String vclassPp) 前期評価クラスを設定します。
void | setVclassPy(String vclassPy) 前年度の評価クラスを設定します。
void | setVmPStock(String vmPStock) プロジェクト在庫の評価クラスを設定します。
void | setVmSoStk(String vmSoStk) 受注在庫の評価クラスを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValuationData

public ValuationData()
評価データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getValArea

public String getValArea()
評価レベルを取得します。

戻り値:
valArea 評価レベル

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
評価タイプに該当する全品目データ削除フラグを取得します。

戻り値:
delFlag 評価タイプに該当する全品目データ削除フラグ

getPriceCtrl

public String getPriceCtrl()
原価管理区分を取得します。

戻り値:
priceCtrl 原価管理区分

getMovingPr

public String getMovingPr()
移動平均原価/期間単位価格を取得します。

戻り値:
movingPr 移動平均原価/期間単位価格

getStdPrice

public String getStdPrice()
標準原価を取得します。

戻り値:
stdPrice 標準原価

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
priceUnit 価格単位

getValClass

public String getValClass()
評価クラスを取得します。

戻り値:
valClass 評価クラス

getPrCtrlPp

public String getPrCtrlPp()
前期間の原価管理区分を取得します。

戻り値:
prCtrlPp 前期間の原価管理区分

getMovPrPp

public String getMovPrPp()
前期移動平均原価/期間平均原価を取得します。

戻り値:
movPrPp 前期移動平均原価/期間平均原価

getStdPrPp

public String getStdPrPp()
前期標準標準原価を取得します。

戻り値:
stdPrPp 前期標準標準原価

getPrUnitPp

public String getPrUnitPp()
前期価格単位を取得します。

戻り値:
prUnitPp 前期価格単位

getVclassPp

public String getVclassPp()
前期評価クラスを取得します。

戻り値:
vclassPp 前期評価クラス

getPrCtrlPy

public String getPrCtrlPy()
前年度の原価管理区分を取得します。

戻り値:
prCtrlPy 前年度の原価管理区分

getMovPrPy

public String getMovPrPy()
前年度の移動平均原価/期間単価を取得します。

戻り値:
movPrPy 前年度の移動平均原価/期間単価

getStdPrPy

public String getStdPrPy()
前年度標準原価を取得します。

戻り値:
stdPrPy 前年度標準原価

getVclassPy

public String getVclassPy()
前年度の評価クラスを取得します。

戻り値:
vclassPy 前年度の評価クラス

getPrUnitPy

public String getPrUnitPy()
前年度価格単位を取得します。

戻り値:
prUnitPy 前年度価格単位

getFiscYear

public String getFiscYear()
当会計年度を取得します。

戻り値:
fiscYear 当会計年度

getCurrPeriod

public String getCurrPeriod()
当期 (転記期間)を取得します。

戻り値:
currPeriod 当期 (転記期間)

getValCat

public String getValCat()
評価カテゴリを取得します。

戻り値:
valCat 評価カテゴリ

getFuturePr

public String getFuturePr()
次期標準原価を取得します。

戻り値:
futurePr 次期標準原価

getValidFrom

public String getValidFrom()
原価有効開始日を取得します。

戻り値:
validFrom 原価有効開始日

getTaxprice1

public String getTaxprice1()
税法による評価額: レベル 1を取得します。

戻り値:
taxprice1 税法による評価額: レベル 1

getCommprice1

public String getCommprice1()
商法による評価額: レベル 1を取得します。

戻り値:
commprice1 商法による評価額: レベル 1

getTaxprice3

public String getTaxprice3()
税法基準評価額: レベル 3を取得します。

戻り値:
taxprice3 税法基準評価額: レベル 3

getCommprice3

public String getCommprice3()
商法基準評価額: レベル 3を取得します。

戻り値:
commprice3 商法基準評価額: レベル 3

getPlndPrice

public String getPlndPrice()
予定計画原価を取得します。

戻り値:
plndPrice 予定計画原価

getPlndprice1

public String getPlndprice1()
予定計画原価 1を取得します。

戻り値:
plndprice1 予定計画原価 1

getPlndprice2

public String getPlndprice2()
予定計画原価 2を取得します。

戻り値:
plndprice2 予定計画原価 2

getPlndprice3

public String getPlndprice3()
予定計画原価 3を取得します。

戻り値:
plndprice3 予定計画原価 3

getPlndprdate1

public String getPlndprdate1()
予定原価 1 の有効開始日を取得します。

戻り値:
plndprdate1 予定原価 1 の有効開始日

getPlndprdate2

public String getPlndprdate2()
予定原価 2 の有効開始日を取得します。

戻り値:
plndprdate2 予定原価 2 の有効開始日

getPlndprdate3

public String getPlndprdate3()
予定原価 3 の有効開始日を取得します。

戻り値:
plndprdate3 予定原価 3 の有効開始日

getLifoFifo

public String getLifoFifo()
LIFO/FIFO 関連を取得します。

戻り値:
lifoFifo LIFO/FIFO 関連

getPoolnumber

public String getPoolnumber()
LIFO 評価でのプール番号を取得します。

戻り値:
poolnumber LIFO 評価でのプール番号

getTaxprice2

public String getTaxprice2()
税法による評価額: レベル 2を取得します。

戻り値:
taxprice2 税法による評価額: レベル 2

getCommprice2

public String getCommprice2()
商法による評価額: レベル 2を取得します。

戻り値:
commprice2 商法による評価額: レベル 2

getDevalInd

public String getDevalInd()
低価法: 評価減区分を取得します。

戻り値:
devalInd 低価法: 評価減区分

getOrigGroup

public String getOrigGroup()
発生源グループ (原価要素の下位区分)を取得します。

戻り値:
origGroup 発生源グループ (原価要素の下位区分)

getOverheadGrp

public String getOverheadGrp()
原価計算間接費グループを取得します。

戻り値:
overheadGrp 原価計算間接費グループ

getPerFutCostEst

public String getPerFutCostEst()
将来標準原価見積期間を取得します。

戻り値:
perFutCostEst 将来標準原価見積期間

getPerCurCostEst

public String getPerCurCostEst()
現行標準原価見積期間を取得します。

戻り値:
perCurCostEst 現行標準原価見積期間

getPerPreCostEst

public String getPerPreCostEst()
前標準原価見積期間を取得します。

戻り値:
perPreCostEst 前標準原価見積期間

getFijFutCostEst

public String getFijFutCostEst()
将来標準原価見積の会計年度を取得します。

戻り値:
fijFutCostEst 将来標準原価見積の会計年度

getFijCurCostEst

public String getFijCurCostEst()
当期標準原価見積の会計年度を取得します。

戻り値:
fijCurCostEst 当期標準原価見積の会計年度

getFijPreCostEst

public String getFijPreCostEst()
前期標準原価見積の会計年度を取得します。

戻り値:
fijPreCostEst 前期標準原価見積の会計年度

getQtyStruct

public String getQtyStruct()
数量構成により原価計算を行う品目を取得します。

戻り値:
qtyStruct 数量構成により原価計算を行う品目

getPrevPlanPrice

public String getPrevPlanPrice()
税法基準評価額: レベル 2を取得します。

戻り値:
prevPlanPrice 税法基準評価額: レベル 2

getMlActive

public String getMlActive()
品目レベルで有効な品目元帳を取得します。

戻り値:
mlActive 品目レベルで有効な品目元帳

getMlSettle

public String getMlSettle()
品目元帳決済: 管理を取得します。

戻り値:
mlSettle 品目元帳決済: 管理

getCurrPlanPrice

public String getCurrPlanPrice()
税法基準評価額: レベル 2を取得します。

戻り値:
currPlanPrice 税法基準評価額: レベル 2

getOrigMat

public String getOrigMat()
品目発生源を取得します。

戻り値:
origMat 品目発生源

getVmSoStk

public String getVmSoStk()
受注在庫の評価クラスを取得します。

戻り値:
vmSoStk 受注在庫の評価クラス

getVmPStock

public String getVmPStock()
プロジェクト在庫の評価クラスを取得します。

戻り値:
vmPStock プロジェクト在庫の評価クラス

getMatlUsage

public String getMatlUsage()
品目の用途を取得します。

戻り値:
matlUsage 品目の用途

getMatOrigin

public String getMatOrigin()
品目の原産地を取得します。

戻り値:
matOrigin 品目の原産地

getInHouse

public String getInHouse()
内部生産を取得します。

戻り値:
inHouse 内部生産

getTaxCmlUn

public String getTaxCmlUn()
税法/商法にもとづく評価額価格単位を取得します。

戻り値:
taxCmlUn 税法/商法にもとづく評価額価格単位

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setValArea

public void setValArea(String valArea)
評価レベルを設定します。

パラメータ:
valArea - 評価レベル

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
評価タイプに該当する全品目データ削除フラグを設定します。

パラメータ:
delFlag - 評価タイプに該当する全品目データ削除フラグ

setPriceCtrl

public void setPriceCtrl(String priceCtrl)
原価管理区分を設定します。

パラメータ:
priceCtrl - 原価管理区分

setMovingPr

public void setMovingPr(String movingPr)
移動平均原価/期間単位価格を設定します。

パラメータ:
movingPr - 移動平均原価/期間単位価格

setStdPrice

public void setStdPrice(String stdPrice)
標準原価を設定します。

パラメータ:
stdPrice - 標準原価

setPriceUnit

public void setPriceUnit(String priceUnit)
価格単位を設定します。

パラメータ:
priceUnit - 価格単位

setValClass

public void setValClass(String valClass)
評価クラスを設定します。

パラメータ:
valClass - 評価クラス

setPrCtrlPp

public void setPrCtrlPp(String prCtrlPp)
前期間の原価管理区分を設定します。

パラメータ:
prCtrlPp - 前期間の原価管理区分

setMovPrPp

public void setMovPrPp(String movPrPp)
前期移動平均原価/期間平均原価を設定します。

パラメータ:
movPrPp - 前期移動平均原価/期間平均原価

setStdPrPp

public void setStdPrPp(String stdPrPp)
前期標準標準原価を設定します。

パラメータ:
stdPrPp - 前期標準標準原価

setPrUnitPp

public void setPrUnitPp(String prUnitPp)
前期価格単位を設定します。

パラメータ:
prUnitPp - 前期価格単位

setVclassPp

public void setVclassPp(String vclassPp)
前期評価クラスを設定します。

パラメータ:
vclassPp - 前期評価クラス

setPrCtrlPy

public void setPrCtrlPy(String prCtrlPy)
前年度の原価管理区分を設定します。

パラメータ:
prCtrlPy - 前年度の原価管理区分

setMovPrPy

public void setMovPrPy(String movPrPy)
前年度の移動平均原価/期間単価を設定します。

パラメータ:
movPrPy - 前年度の移動平均原価/期間単価

setStdPrPy

public void setStdPrPy(String stdPrPy)
前年度標準原価を設定します。

パラメータ:
stdPrPy - 前年度標準原価

setVclassPy

public void setVclassPy(String vclassPy)
前年度の評価クラスを設定します。

パラメータ:
vclassPy - 前年度の評価クラス

setPrUnitPy

public void setPrUnitPy(String prUnitPy)
前年度価格単位を設定します。

パラメータ:
prUnitPy - 前年度価格単位

setFiscYear

public void setFiscYear(String fiscYear)
当会計年度を設定します。

パラメータ:
fiscYear - 当会計年度

setCurrPeriod

public void setCurrPeriod(String currPeriod)
当期 (転記期間)を設定します。

パラメータ:
currPeriod - 当期 (転記期間)

setValCat

public void setValCat(String valCat)
評価カテゴリを設定します。

パラメータ:
valCat - 評価カテゴリ

setFuturePr

public void setFuturePr(String futurePr)
次期標準原価を設定します。

パラメータ:
futurePr - 次期標準原価

setValidFrom

public void setValidFrom(String validFrom)
原価有効開始日を設定します。

パラメータ:
validFrom - 原価有効開始日

setTaxprice1

public void setTaxprice1(String taxprice1)
税法による評価額: レベル 1を設定します。

パラメータ:
taxprice1 - 税法による評価額: レベル 1

setCommprice1

public void setCommprice1(String commprice1)
商法による評価額: レベル 1を設定します。

パラメータ:
commprice1 - 商法による評価額: レベル 1

setTaxprice3

public void setTaxprice3(String taxprice3)
税法基準評価額: レベル 3を設定します。

パラメータ:
taxprice3 - 税法基準評価額: レベル 3

setCommprice3

public void setCommprice3(String commprice3)
商法基準評価額: レベル 3を設定します。

パラメータ:
commprice3 - 商法基準評価額: レベル 3

setPlndPrice

public void setPlndPrice(String plndPrice)
予定計画原価を設定します。

パラメータ:
plndPrice - 予定計画原価

setPlndprice1

public void setPlndprice1(String plndprice1)
予定計画原価 1を設定します。

パラメータ:
plndprice1 - 予定計画原価 1

setPlndprice2

public void setPlndprice2(String plndprice2)
予定計画原価 2を設定します。

パラメータ:
plndprice2 - 予定計画原価 2

setPlndprice3

public void setPlndprice3(String plndprice3)
予定計画原価 3を設定します。

パラメータ:
plndprice3 - 予定計画原価 3

setPlndprdate1

public void setPlndprdate1(String plndprdate1)
予定原価 1 の有効開始日を設定します。

パラメータ:
plndprdate1 - 予定原価 1 の有効開始日

setPlndprdate2

public void setPlndprdate2(String plndprdate2)
予定原価 2 の有効開始日を設定します。

パラメータ:
plndprdate2 - 予定原価 2 の有効開始日

setPlndprdate3

public void setPlndprdate3(String plndprdate3)
予定原価 3 の有効開始日を設定します。

パラメータ:
plndprdate3 - 予定原価 3 の有効開始日

setLifoFifo

public void setLifoFifo(String lifoFifo)
LIFO/FIFO 関連を設定します。

パラメータ:
lifoFifo - LIFO/FIFO 関連

setPoolnumber

public void setPoolnumber(String poolnumber)
LIFO 評価でのプール番号を設定します。

パラメータ:
poolnumber - LIFO 評価でのプール番号

setTaxprice2

public void setTaxprice2(String taxprice2)
税法による評価額: レベル 2を設定します。

パラメータ:
taxprice2 - 税法による評価額: レベル 2

setCommprice2

public void setCommprice2(String commprice2)
商法による評価額: レベル 2を設定します。

パラメータ:
commprice2 - 商法による評価額: レベル 2

setDevalInd

public void setDevalInd(String devalInd)
低価法: 評価減区分を設定します。

パラメータ:
devalInd - 低価法: 評価減区分

setOrigGroup

public void setOrigGroup(String origGroup)
発生源グループ (原価要素の下位区分)を設定します。

パラメータ:
origGroup - 発生源グループ (原価要素の下位区分)

setOverheadGrp

public void setOverheadGrp(String overheadGrp)
原価計算間接費グループを設定します。

パラメータ:
overheadGrp - 原価計算間接費グループ

setPerFutCostEst

public void setPerFutCostEst(String perFutCostEst)
将来標準原価見積期間を設定します。

パラメータ:
perFutCostEst - 将来標準原価見積期間

setPerCurCostEst

public void setPerCurCostEst(String perCurCostEst)
現行標準原価見積期間を設定します。

パラメータ:
perCurCostEst - 現行標準原価見積期間

setPerPreCostEst

public void setPerPreCostEst(String perPreCostEst)
前標準原価見積期間を設定します。

パラメータ:
perPreCostEst - 前標準原価見積期間

setFijFutCostEst

public void setFijFutCostEst(String fijFutCostEst)
将来標準原価見積の会計年度を設定します。

パラメータ:
fijFutCostEst - 将来標準原価見積の会計年度

setFijCurCostEst

public void setFijCurCostEst(String fijCurCostEst)
当期標準原価見積の会計年度を設定します。

パラメータ:
fijCurCostEst - 当期標準原価見積の会計年度

setFijPreCostEst

public void setFijPreCostEst(String fijPreCostEst)
前期標準原価見積の会計年度を設定します。

パラメータ:
fijPreCostEst - 前期標準原価見積の会計年度

setQtyStruct

public void setQtyStruct(String qtyStruct)
数量構成により原価計算を行う品目を設定します。

パラメータ:
qtyStruct - 数量構成により原価計算を行う品目

setPrevPlanPrice

public void setPrevPlanPrice(String prevPlanPrice)
税法基準評価額: レベル 2を設定します。

パラメータ:
prevPlanPrice - 税法基準評価額: レベル 2

setMlActive

public void setMlActive(String mlActive)
品目レベルで有効な品目元帳を設定します。

パラメータ:
mlActive - 品目レベルで有効な品目元帳

setMlSettle

public void setMlSettle(String mlSettle)
品目元帳決済: 管理を設定します。

パラメータ:
mlSettle - 品目元帳決済: 管理

setCurrPlanPrice

public void setCurrPlanPrice(String currPlanPrice)
税法基準評価額: レベル 2を設定します。

パラメータ:
currPlanPrice - 税法基準評価額: レベル 2

setOrigMat

public void setOrigMat(String origMat)
品目発生源を設定します。

パラメータ:
origMat - 品目発生源

setVmSoStk

public void setVmSoStk(String vmSoStk)
受注在庫の評価クラスを設定します。

パラメータ:
vmSoStk - 受注在庫の評価クラス

setVmPStock

public void setVmPStock(String vmPStock)
プロジェクト在庫の評価クラスを設定します。

パラメータ:
vmPStock - プロジェクト在庫の評価クラス

setMatlUsage

public void setMatlUsage(String matlUsage)
品目の用途を設定します。

パラメータ:
matlUsage - 品目の用途

setMatOrigin

public void setMatOrigin(String matOrigin)
品目の原産地を設定します。

パラメータ:
matOrigin - 品目の原産地

setInHouse

public void setInHouse(String inHouse)
内部生産を設定します。

パラメータ:
inHouse - 内部生産

setTaxCmlUn

public void setTaxCmlUn(String taxCmlUn)
税法/商法にもとづく評価額価格単位を設定します。

パラメータ:
taxCmlUn - 税法/商法にもとづく評価額価格単位

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValuationDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ValuationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList
すべての実装インタフェース:
Serializable
public class ValuationDataList
extends ValuationData
implements Serializable

評価データ情報クラス
機能は以下の通り

  • 評価データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ValuationDataList()
評価データ情報を作成します。
ValuationDataList(int index)
評価データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData から継承したメソッド
getAccountView, getCommprice1, getCommprice2, getCommprice3, getCostView, getCurrency, getCurrencyIso, getCurrPeriod, getCurrPlanPrice, getDelFlag, getDevalInd, getFijCurCostEst, getFijFutCostEst, getFijPreCostEst, getFiscYear, getFunction, getFuturePr, getInHouse, getLifoFifo, getMaintStat, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMatlUsage, getMatOrigin, getMlActive, getMlSettle, getMovingPr, getMovPrPp, getMovPrPy, getOrigGroup, getOrigMat, getOverheadGrp, getPerCurCostEst, getPerFutCostEst, getPerPreCostEst, getPlndprdate1, getPlndprdate2, getPlndprdate3, getPlndPrice, getPlndprice1, getPlndprice2, getPlndprice3, getPoolnumber, getPrCtrlPp, getPrCtrlPy, getPrevPlanPrice, getPriceCtrl, getPriceUnit, getPrUnitPp, getPrUnitPy, getQtyStruct, getStdPrice, getStdPrPp, getStdPrPy, getTaxCmlUn, getTaxprice1, getTaxprice2, getTaxprice3, getValArea, getValCat, getValClass, getValidFrom, getValType, getVclassPp, getVclassPy, getVmPStock, getVmSoStk, setAccountView, setCommprice1, setCommprice2, setCommprice3, setCostView, setCurrency, setCurrencyIso, setCurrPeriod, setCurrPlanPrice, setDelFlag, setDevalInd, setFijCurCostEst, setFijFutCostEst, setFijPreCostEst, setFiscYear, setFunction, setFuturePr, setInHouse, setLifoFifo, setMaintStat, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMatlUsage, setMatOrigin, setMlActive, setMlSettle, setMovingPr, setMovPrPp, setMovPrPy, setOrigGroup, setOrigMat, setOverheadGrp, setPerCurCostEst, setPerFutCostEst, setPerPreCostEst, setPlndprdate1, setPlndprdate2, setPlndprdate3, setPlndPrice, setPlndprice1, setPlndprice2, setPlndprice3, setPoolnumber, setPrCtrlPp, setPrCtrlPy, setPrevPlanPrice, setPriceCtrl, setPriceUnit, setPrUnitPp, setPrUnitPy, setQtyStruct, setStdPrice, setStdPrPp, setStdPrPy, setTaxCmlUn, setTaxprice1, setTaxprice2, setTaxprice3, setValArea, setValCat, setValClass, setValidFrom, setValType, setVclassPp, setVclassPy, setVmPStock, setVmSoStk, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValuationDataList

public ValuationDataList()
評価データ情報を作成します。

ValuationDataList

public ValuationDataList(int index)
評価データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WarehouseNumberData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス WarehouseNumberData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
WarehouseNumberDataList
public class WarehouseNumberData
extends Object
implements Serializable

倉庫番号データ情報クラス
機能は以下の通り

  • 倉庫番号データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
WarehouseNumberData()
倉庫番号データ情報を作成します。
メソッドの概要
String | getAddToStk() 既存在庫への追加許可を取得します。
String | getBlockStge() 平置保管域区分を取得します。
String | getCapyUsage() 保管容量使用を取得します。
String | getDelFlag() WM 倉庫内の全品目データ削除フラグを取得します。
String | getFunction() BAPI 機能を取得します。
String | getLEquip1() 積載装置数量 1を取得します。
String | getLEquip2() 積載装置数量 2を取得します。
String | getLEquip3() 積載装置数量 3を取得します。
String | getLeqUnit1() 積載装置数量 1 の数量単位を取得します。
String | getLeqUnit1Iso() ISO コードによる積載装置数量 1 の数量単位を取得します。
String | getLeqUnit2() 積載装置数量 2 の数量単位を取得します。
String | getLeqUnit2Iso() ISO コードによる積載装置数量 2 の数量単位を取得します。
String | getLeqUnit3() 積載装置数量 3 の数量単位を取得します。
String | getLeqUnit3Iso() ISO コードによる積載装置数量 3 の数量単位を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMsgToIm() 区分: 在庫管理への出力を取得します。
String | getPlacement() 在庫受入に対する保管域タイプ検索区分を取得します。
String | getProcureUn() 保管容量消費の数量単位を取得します。
String | getProcureUnIso() ISO コードでの保管容量消費の数量単位を取得します。
String | getRefUnit() 品目マスタレコードの数量単位初期値を取得します。
String | getSpecMvmt() 倉庫管理の特殊移動区分を取得します。
String | getStgesector() 保管区画区分を取得します。
String | getStgeType() 概略計画および詳細計画のピッキング保管域タイプを取得します。
String | getTwoStepPick() ツーステップピッキング適用品目を取得します。
String | getUnittype1() 第１保管単位タイプを取得します。
String | getUnittype2() 第２保管単位タイプを取得します。
String | getUnittype3() 第３保管単位タイプを取得します。
String | getWhseNo() 倉庫番号/複合倉庫を取得します。
String | getWithdrawal() 在庫払出に対する保管域タイプ区分を取得します。
String | getWmUnit() 倉庫管理の数量単位を取得します。
String | getWmUnitIso() ISO コードでの倉庫管理単位を取得します。
void | setAddToStk(String addToStk) 既存在庫への追加許可を設定します。
void | setBlockStge(String blockStge) 平置保管域区分を設定します。
void | setCapyUsage(String capyUsage) 保管容量使用を設定します。
void | setDelFlag(String delFlag) WM 倉庫内の全品目データ削除フラグを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setLEquip1(String lEquip1) 積載装置数量 1を設定します。
void | setLEquip2(String lEquip2) 積載装置数量 2を設定します。
void | setLEquip3(String lEquip3) 積載装置数量 3を設定します。
void | setLeqUnit1(String leqUnit1) 積載装置数量 1 の数量単位を設定します。
void | setLeqUnit1Iso(String leqUnit1Iso) ISO コードによる積載装置数量 1 の数量単位を設定します。
void | setLeqUnit2(String leqUnit2) 積載装置数量 2 の数量単位を設定します。
void | setLeqUnit2Iso(String leqUnit2Iso) ISO コードによる積載装置数量 2 の数量単位を設定します。
void | setLeqUnit3(String leqUnit3) 積載装置数量 3 の数量単位を設定します。
void | setLeqUnit3Iso(String leqUnit3Iso) ISO コードによる積載装置数量 3 の数量単位を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMsgToIm(String msgToIm) 区分: 在庫管理への出力を設定します。
void | setPlacement(String placement) 在庫受入に対する保管域タイプ検索区分を設定します。
void | setProcureUn(String procureUn) 保管容量消費の数量単位を設定します。
void | setProcureUnIso(String procureUnIso) ISO コードでの保管容量消費の数量単位を設定します。
void | setRefUnit(String refUnit) 品目マスタレコードの数量単位初期値を設定します。
void | setSpecMvmt(String specMvmt) 倉庫管理の特殊移動区分を設定します。
void | setStgesector(String stgesector) 保管区画区分を設定します。
void | setStgeType(String stgeType) 概略計画および詳細計画のピッキング保管域タイプを設定します。
void | setTwoStepPick(String twoStepPick) ツーステップピッキング適用品目を設定します。
void | setUnittype1(String unittype1) 第１保管単位タイプを設定します。
void | setUnittype2(String unittype2) 第２保管単位タイプを設定します。
void | setUnittype3(String unittype3) 第３保管単位タイプを設定します。
void | setWhseNo(String whseNo) 倉庫番号/複合倉庫を設定します。
void | setWithdrawal(String withdrawal) 在庫払出に対する保管域タイプ区分を設定します。
void | setWmUnit(String wmUnit) 倉庫管理の数量単位を設定します。
void | setWmUnitIso(String wmUnitIso) ISO コードでの倉庫管理単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WarehouseNumberData

public WarehouseNumberData()
倉庫番号データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getWhseNo

public String getWhseNo()
倉庫番号/複合倉庫を取得します。

戻り値:
whseNo 倉庫番号/複合倉庫

getDelFlag

public String getDelFlag()
WM 倉庫内の全品目データ削除フラグを取得します。

戻り値:
delFlag WM 倉庫内の全品目データ削除フラグ

getStgesector

public String getStgesector()
保管区画区分を取得します。

戻り値:
stgesector 保管区画区分

getPlacement

public String getPlacement()
在庫受入に対する保管域タイプ検索区分を取得します。

戻り値:
placement 在庫受入に対する保管域タイプ検索区分

getWithdrawal

public String getWithdrawal()
在庫払出に対する保管域タイプ区分を取得します。

戻り値:
withdrawal 在庫払出に対する保管域タイプ区分

getLEquip1

public String getLEquip1()
積載装置数量 1を取得します。

戻り値:
lEquip1 積載装置数量 1

getLEquip2

public String getLEquip2()
積載装置数量 2を取得します。

戻り値:
lEquip2 積載装置数量 2

getLEquip3

public String getLEquip3()
積載装置数量 3を取得します。

戻り値:
lEquip3 積載装置数量 3

getLeqUnit1

public String getLeqUnit1()
積載装置数量 1 の数量単位を取得します。

戻り値:
leqUnit1 積載装置数量 1 の数量単位

getLeqUnit1Iso

public String getLeqUnit1Iso()
ISO コードによる積載装置数量 1 の数量単位を取得します。

戻り値:
leqUnit1Iso ISO コードによる積載装置数量 1 の数量単位

getLeqUnit2

public String getLeqUnit2()
積載装置数量 2 の数量単位を取得します。

戻り値:
leqUnit2 積載装置数量 2 の数量単位

getLeqUnit2Iso

public String getLeqUnit2Iso()
ISO コードによる積載装置数量 2 の数量単位を取得します。

戻り値:
leqUnit2Iso ISO コードによる積載装置数量 2 の数量単位

getLeqUnit3

public String getLeqUnit3()
積載装置数量 3 の数量単位を取得します。

戻り値:
leqUnit3 積載装置数量 3 の数量単位

getLeqUnit3Iso

public String getLeqUnit3Iso()
ISO コードによる積載装置数量 3 の数量単位を取得します。

戻り値:
leqUnit3Iso ISO コードによる積載装置数量 3 の数量単位

getUnittype1

public String getUnittype1()
第１保管単位タイプを取得します。

戻り値:
unittype1 第１保管単位タイプ

getUnittype2

public String getUnittype2()
第２保管単位タイプを取得します。

戻り値:
unittype2 第２保管単位タイプ

getUnittype3

public String getUnittype3()
第３保管単位タイプを取得します。

戻り値:
unittype3 第３保管単位タイプ

getWmUnit

public String getWmUnit()
倉庫管理の数量単位を取得します。

戻り値:
wmUnit 倉庫管理の数量単位

getWmUnitIso

public String getWmUnitIso()
ISO コードでの倉庫管理単位を取得します。

戻り値:
wmUnitIso ISO コードでの倉庫管理単位

getAddToStk

public String getAddToStk()
既存在庫への追加許可を取得します。

戻り値:
addToStk 既存在庫への追加許可

getBlockStge

public String getBlockStge()
平置保管域区分を取得します。

戻り値:
blockStge 平置保管域区分

getMsgToIm

public String getMsgToIm()
区分: 在庫管理への出力を取得します。

戻り値:
msgToIm 区分: 在庫管理への出力

getSpecMvmt

public String getSpecMvmt()
倉庫管理の特殊移動区分を取得します。

戻り値:
specMvmt 倉庫管理の特殊移動区分

getCapyUsage

public String getCapyUsage()
保管容量使用を取得します。

戻り値:
capyUsage 保管容量使用

getProcureUn

public String getProcureUn()
保管容量消費の数量単位を取得します。

戻り値:
procureUn 保管容量消費の数量単位

getProcureUnIso

public String getProcureUnIso()
ISO コードでの保管容量消費の数量単位を取得します。

戻り値:
procureUnIso ISO コードでの保管容量消費の数量単位

getStgeType

public String getStgeType()
概略計画および詳細計画のピッキング保管域タイプを取得します。

戻り値:
stgeType 概略計画および詳細計画のピッキング保管域タイプ

getRefUnit

public String getRefUnit()
品目マスタレコードの数量単位初期値を取得します。

戻り値:
refUnit 品目マスタレコードの数量単位初期値

getTwoStepPick

public String getTwoStepPick()
ツーステップピッキング適用品目を取得します。

戻り値:
twoStepPick ツーステップピッキング適用品目

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setWhseNo

public void setWhseNo(String whseNo)
倉庫番号/複合倉庫を設定します。

パラメータ:
whseNo - 倉庫番号/複合倉庫

setDelFlag

public void setDelFlag(String delFlag)
WM 倉庫内の全品目データ削除フラグを設定します。

パラメータ:
delFlag - WM 倉庫内の全品目データ削除フラグ

setStgesector

public void setStgesector(String stgesector)
保管区画区分を設定します。

パラメータ:
stgesector - 保管区画区分

setPlacement

public void setPlacement(String placement)
在庫受入に対する保管域タイプ検索区分を設定します。

パラメータ:
placement - 在庫受入に対する保管域タイプ検索区分

setWithdrawal

public void setWithdrawal(String withdrawal)
在庫払出に対する保管域タイプ区分を設定します。

パラメータ:
withdrawal - 在庫払出に対する保管域タイプ区分

setLEquip1

public void setLEquip1(String lEquip1)
積載装置数量 1を設定します。

パラメータ:
lEquip1 - 積載装置数量 1

setLEquip2

public void setLEquip2(String lEquip2)
積載装置数量 2を設定します。

パラメータ:
lEquip2 - 積載装置数量 2

setLEquip3

public void setLEquip3(String lEquip3)
積載装置数量 3を設定します。

パラメータ:
lEquip3 - 積載装置数量 3

setLeqUnit1

public void setLeqUnit1(String leqUnit1)
積載装置数量 1 の数量単位を設定します。

パラメータ:
leqUnit1 - 積載装置数量 1 の数量単位

setLeqUnit1Iso

public void setLeqUnit1Iso(String leqUnit1Iso)
ISO コードによる積載装置数量 1 の数量単位を設定します。

パラメータ:
leqUnit1Iso - ISO コードによる積載装置数量 1 の数量単位

setLeqUnit2

public void setLeqUnit2(String leqUnit2)
積載装置数量 2 の数量単位を設定します。

パラメータ:
leqUnit2 - 積載装置数量 2 の数量単位

setLeqUnit2Iso

public void setLeqUnit2Iso(String leqUnit2Iso)
ISO コードによる積載装置数量 2 の数量単位を設定します。

パラメータ:
leqUnit2Iso - ISO コードによる積載装置数量 2 の数量単位

setLeqUnit3

public void setLeqUnit3(String leqUnit3)
積載装置数量 3 の数量単位を設定します。

パラメータ:
leqUnit3 - 積載装置数量 3 の数量単位

setLeqUnit3Iso

public void setLeqUnit3Iso(String leqUnit3Iso)
ISO コードによる積載装置数量 3 の数量単位を設定します。

パラメータ:
leqUnit3Iso - ISO コードによる積載装置数量 3 の数量単位

setUnittype1

public void setUnittype1(String unittype1)
第１保管単位タイプを設定します。

パラメータ:
unittype1 - 第１保管単位タイプ

setUnittype2

public void setUnittype2(String unittype2)
第２保管単位タイプを設定します。

パラメータ:
unittype2 - 第２保管単位タイプ

setUnittype3

public void setUnittype3(String unittype3)
第３保管単位タイプを設定します。

パラメータ:
unittype3 - 第３保管単位タイプ

setWmUnit

public void setWmUnit(String wmUnit)
倉庫管理の数量単位を設定します。

パラメータ:
wmUnit - 倉庫管理の数量単位

setWmUnitIso

public void setWmUnitIso(String wmUnitIso)
ISO コードでの倉庫管理単位を設定します。

パラメータ:
wmUnitIso - ISO コードでの倉庫管理単位

setAddToStk

public void setAddToStk(String addToStk)
既存在庫への追加許可を設定します。

パラメータ:
addToStk - 既存在庫への追加許可

setBlockStge

public void setBlockStge(String blockStge)
平置保管域区分を設定します。

パラメータ:
blockStge - 平置保管域区分

setMsgToIm

public void setMsgToIm(String msgToIm)
区分: 在庫管理への出力を設定します。

パラメータ:
msgToIm - 区分: 在庫管理への出力

setSpecMvmt

public void setSpecMvmt(String specMvmt)
倉庫管理の特殊移動区分を設定します。

パラメータ:
specMvmt - 倉庫管理の特殊移動区分

setCapyUsage

public void setCapyUsage(String capyUsage)
保管容量使用を設定します。

パラメータ:
capyUsage - 保管容量使用

setProcureUn

public void setProcureUn(String procureUn)
保管容量消費の数量単位を設定します。

パラメータ:
procureUn - 保管容量消費の数量単位

setProcureUnIso

public void setProcureUnIso(String procureUnIso)
ISO コードでの保管容量消費の数量単位を設定します。

パラメータ:
procureUnIso - ISO コードでの保管容量消費の数量単位

setStgeType

public void setStgeType(String stgeType)
概略計画および詳細計画のピッキング保管域タイプを設定します。

パラメータ:
stgeType - 概略計画および詳細計画のピッキング保管域タイプ

setRefUnit

public void setRefUnit(String refUnit)
品目マスタレコードの数量単位初期値を設定します。

パラメータ:
refUnit - 品目マスタレコードの数量単位初期値

setTwoStepPick

public void setTwoStepPick(String twoStepPick)
ツーステップピッキング適用品目を設定します。

パラメータ:
twoStepPick - ツーステップピッキング適用品目

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WarehouseNumberDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス WarehouseNumberDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList
すべての実装インタフェース:
Serializable
public class WarehouseNumberDataList
extends WarehouseNumberData
implements Serializable

倉庫番号データ情報クラス
機能は以下の通り

  • 倉庫番号データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
WarehouseNumberDataList()
倉庫番号データ情報を作成します。
WarehouseNumberDataList(int index)
倉庫番号データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData から継承したメソッド
getAddToStk, getBlockStge, getCapyUsage, getDelFlag, getFunction, getLEquip1, getLEquip2, getLEquip3, getLeqUnit1, getLeqUnit1Iso, getLeqUnit2, getLeqUnit2Iso, getLeqUnit3, getLeqUnit3Iso, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getMsgToIm, getPlacement, getProcureUn, getProcureUnIso, getRefUnit, getSpecMvmt, getStgesector, getStgeType, getTwoStepPick, getUnittype1, getUnittype2, getUnittype3, getWhseNo, getWithdrawal, getWmUnit, getWmUnitIso, setAddToStk, setBlockStge, setCapyUsage, setDelFlag, setFunction, setLEquip1, setLEquip2, setLEquip3, setLeqUnit1, setLeqUnit1Iso, setLeqUnit2, setLeqUnit2Iso, setLeqUnit3, setLeqUnit3Iso, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setMsgToIm, setPlacement, setProcureUn, setProcureUnIso, setRefUnit, setSpecMvmt, setStgesector, setStgeType, setTwoStepPick, setUnittype1, setUnittype2, setUnittype3, setWhseNo, setWithdrawal, setWmUnit, setWmUnitIso, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WarehouseNumberDataList

public WarehouseNumberDataList()
倉庫番号データ情報を作成します。

WarehouseNumberDataList

public WarehouseNumberDataList(int index)
倉庫番号データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException の使用

SAPPurchaseAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase での SAPPurchaseAppException の使用

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPPurchaseAppException の使用

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException の使用

SAPPurchaseSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase での SAPPurchaseSystemException の使用

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 String PurchaseReleaseController.getRetCode()
リターン値、ABAP 命令後のリターン値を取得します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPostChangeController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 ArrayList PurchaseOrderPayPost.getItemTextList()
明細テキスト一覧を取得します｡
 void PurchaseOrderPayPost.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void PurchaseOrderPayPost.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialSaveReplicaController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetList.setImportParam(BapiController bapiController)
品目コードを検索する条件ををセットします。
 void MaterialGetList.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialGetAllController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialAvailabilityController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtCreateController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPPurchaseSystemException の使用

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.purchase.exception (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.exception
例外
SAPPurchaseAppException
SAPPurchaseSystemException


jp.co.intra_mart.foundation.sap.module.purchase.exception (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception

ＳＡＰ連携経費購買系例外クラスを提供します。

参照:
説明

例外の概要
SAPPurchaseAppException | 購買系APIアプリケーション例外クラス。
SAPPurchaseSystemException | 購買系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の説明

ＳＡＰ連携経費購買系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.purchase.exception クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.exception の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.exception のクラス
SAPPurchaseAppException
購買系APIアプリケーション例外クラス。
SAPPurchaseSystemException
購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.module.purchase.exception のクラス
SAPPurchaseAppException
購買系APIアプリケーション例外クラス。
SAPPurchaseSystemException
購買系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPPurchaseAppException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.exception
クラス SAPPurchaseAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
すべての実装インタフェース:
Serializable
public class SAPPurchaseAppException
extends SAPModuleAppException

購買系APIアプリケーション例外クラス。

SAP リアルタイム連携API におけるBAPI 実行後の成功・失敗の標準の基準は、 各API でのBAPI 実行後にRETURN パラメータのTYPE 値を取得して、S（正常終了） または空文字以外が１つでも存在するかどうかです。
失敗の場合、本例外がスローされます。

関連項目:
直列化された形式

コンストラクタの概要
SAPPurchaseAppException(String message)
購買系APIアプリケーション例外
SAPPurchaseAppException(String message, Throwable ex)
購買系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPPurchaseAppException

public SAPPurchaseAppException(String message,
                               Throwable ex)
購買系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPPurchaseAppException

public SAPPurchaseAppException(String message)
購買系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPPurchaseSystemException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.exception
クラス SAPPurchaseSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException
すべての実装インタフェース:
Serializable
public class SAPPurchaseSystemException
extends SAPModuleSystemException

購買系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPPurchaseSystemException(String message, Throwable ex)
購買系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPPurchaseSystemException

public SAPPurchaseSystemException(String message,
                                  Throwable ex)
購買系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode の使用

GoodsMvtCode を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtCode の使用

GoodsMvtCode を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtCode GoodsMvtCreate.getGoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当を取得します。

GoodsMvtCode 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtCode.setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当の値をセットします。
void | GoodsMvtCreate.setGoodsMvtCode(GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate の使用

GoodsMvtCreate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtCreate の使用

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtCreate のサブクラス
 class GoodsMvtCreateController
入庫伝票登録コントローラクラス
機能は以下の通り
入庫伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret の使用

GoodsMvtHeadret を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtHeadret の使用

GoodsMvtHeadret を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtHeadret GoodsMvtCreate.getGoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度を取得します。

GoodsMvtHeadret 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtHeadret.setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票ヘッダデータの値をセットします。
void | GoodsMvtCreate.setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票番号/入出庫伝票会計年度を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm の使用

GoodsMvtRefEwm を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtRefEwm の使用

GoodsMvtRefEwm を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtRefEwm GoodsMvtCreate.getGoodsMvtRefEwm()
BAdI 通信構造: 入出庫伝票 EWM 照会を取得します。

GoodsMvtRefEwm 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtRefEwm.setImportParam(BapiController bapiController, GoodsMvtRefEwm goodsMvtRefEwm) BAdI 通信構造: 入出庫伝票 EWMの値をセットします。
void | GoodsMvtCreate.setGoodsMvtRefEwm(GoodsMvtRefEwm goodsMvtRefEwm) BAdI 通信構造: 入出庫伝票 EWM 照会を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Extensionin (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス Extensionin

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin
すべての実装インタフェース:
Serializable
public class Extensionin
extends Object
implements Serializable

Reference Structure情報クラス
機能は以下の通り

  • Reference Structure情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Extensionin()
Reference Structure情報を作成します。
Extensionin(int index)
Reference Structure情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分 IDを取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Extensionin

public Extensionin()
Reference Structure情報を作成します。

Extensionin

public Extensionin(int index)
Reference Structure情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分 IDを取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分 ID

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCode (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtCode

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode
すべての実装インタフェース:
Serializable
public class GoodsMvtCode
extends Object
implements Serializable

在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り

  • 在庫移動に対するコードのトランザクションへの割当情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当情報を作成します。
メソッドの概要
String | getGmCode() BAPI 在庫移動トランザクションのコード割当を取得します。
void | setGmCode(String gmCode) BAPI 在庫移動トランザクションのコード割当を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCode

public GoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当情報を作成します。

メソッドの詳細

getGmCode

public String getGmCode()
BAPI 在庫移動トランザクションのコード割当を取得します。

戻り値:
gmCode BAPI 在庫移動トランザクションのコード割当

setGmCode

public void setGmCode(String gmCode)
BAPI 在庫移動トランザクションのコード割当を設定します。

パラメータ:
gmCode - BAPI 在庫移動トランザクションのコード割当

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCreate (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtCreate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtCreateController
public class GoodsMvtCreate
extends UpdateController
implements Serializable

入出庫伝票登録情報クラス
機能は以下の通り

  • 入出庫伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtCreate()
コンストラクタ。
GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
List | getExtensioninList() Reference Structureを取得します。
GoodsMvtCode | getGoodsMvtCode() 在庫移動に対するコードのトランザクションへの割当を取得します。
GoodsMvtHeader | getGoodsMvtHeader() 入出庫伝票ヘッダデータを取得します。
GoodsMvtHeadret | getGoodsMvtHeadret() 入出庫伝票番号/入出庫伝票会計年度を取得します。
List | getGoodsMvtItemList() 入出庫伝票明細を取得します。
GoodsMvtRefEwm | getGoodsMvtRefEwm() BAdI 通信構造: 入出庫伝票 EWM 照会を取得します。
List | getGoodsMvtSerialNumberList() シリアル番号を取得します。
List | getGoodsMvtServPartDataList() ServPartDataを取得します。
String | getMatdocumentyear() 入出庫伝票会計年度を取得します。
String | getMaterialdocument() 入出庫伝票番号を取得します。
String | getTestrun() 在庫移動シミュレーションを取得します。
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setExtensioninList(List extensioninList) Reference Structureを設定します。
void | setGoodsMvtCode(GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当を設定します。
void | setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータを設定します。
void | setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票番号/入出庫伝票会計年度を設定します。
void | setGoodsMvtItemList(List goodsMvtItemList) 入出庫伝票明細を設定します。
void | setGoodsMvtRefEwm(GoodsMvtRefEwm goodsMvtRefEwm) BAdI 通信構造: 入出庫伝票 EWM 照会を設定します。
void | setGoodsMvtSerialNumberList(List goodsMvtSerialNumberList) シリアル番号を設定します。
void | setGoodsMvtServPartDataList(List goodsMvtServPartDataList) ServPartDataを設定します。
void | setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | setMatdocumentyear(String matdocumentyear) 入出庫伝票会計年度を設定します。
void | setMaterialdocument(String materialdocument) 入出庫伝票番号を設定します。
void | setTestrun(String testrun) 在庫移動シミュレーションを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCreate

public GoodsMvtCreate()
コンストラクタ。

GoodsMvtCreate

public GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

GoodsMvtCreate

public GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
在庫移動シミュレーションを取得します。

戻り値:
testrun 在庫移動シミュレーション

getMatdocumentyear

public String getMatdocumentyear()
入出庫伝票会計年度を取得します。

戻り値:
matdocumentyear 入出庫伝票会計年度

getMaterialdocument

public String getMaterialdocument()
入出庫伝票番号を取得します。

戻り値:
materialdocument 入出庫伝票番号

getGoodsMvtCode

public GoodsMvtCode getGoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当を取得します。

戻り値:
goodsMvtCode 在庫移動に対するコードのトランザクションへの割当

getGoodsMvtHeader

public GoodsMvtHeader getGoodsMvtHeader()
入出庫伝票ヘッダデータを取得します。

戻り値:
goodsMvtHeader 入出庫伝票ヘッダデータ

getGoodsMvtRefEwm

public GoodsMvtRefEwm getGoodsMvtRefEwm()
BAdI 通信構造: 入出庫伝票 EWM 照会を取得します。

戻り値:
goodsMvtRefEwm BAdI 通信構造: 入出庫伝票 EWM 照会

getGoodsMvtHeadret

public GoodsMvtHeadret getGoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度を取得します。

戻り値:
goodsMvtHeadret 入出庫伝票番号/入出庫伝票会計年度

getGoodsMvtItemList

public List getGoodsMvtItemList()
入出庫伝票明細を取得します。

戻り値:
goodsMvtItemList 入出庫伝票明細

getGoodsMvtSerialNumberList

public List getGoodsMvtSerialNumberList()
シリアル番号を取得します。

戻り値:
goodsMvtSerialNumberList シリアル番号

getGoodsMvtServPartDataList

public List getGoodsMvtServPartDataList()
ServPartDataを取得します。

戻り値:
goodsMvtServPartDataList ServPartData

getExtensioninList

public List getExtensioninList()
Reference Structureを取得します。

戻り値:
extensioninList Reference Structure

setTestrun

public void setTestrun(String testrun)
在庫移動シミュレーションを設定します。

パラメータ:
testrun - 在庫移動シミュレーション

setMatdocumentyear

public void setMatdocumentyear(String matdocumentyear)
入出庫伝票会計年度を設定します。

パラメータ:
matdocumentyear - 入出庫伝票会計年度

setMaterialdocument

public void setMaterialdocument(String materialdocument)
入出庫伝票番号を設定します。

パラメータ:
materialdocument - 入出庫伝票番号

setGoodsMvtCode

public void setGoodsMvtCode(GoodsMvtCode goodsMvtCode)
在庫移動に対するコードのトランザクションへの割当を設定します。

パラメータ:
goodsMvtCode - 在庫移動に対するコードのトランザクションへの割当

setGoodsMvtHeader

public void setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータを設定します。

パラメータ:
goodsMvtHeader - 入出庫伝票ヘッダデータ

setGoodsMvtRefEwm

public void setGoodsMvtRefEwm(GoodsMvtRefEwm goodsMvtRefEwm)
BAdI 通信構造: 入出庫伝票 EWM 照会を設定します。

パラメータ:
goodsMvtRefEwm - BAdI 通信構造: 入出庫伝票 EWM 照会

setGoodsMvtHeadret

public void setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret)
入出庫伝票番号/入出庫伝票会計年度を設定します。

パラメータ:
goodsMvtHeadret - 入出庫伝票番号/入出庫伝票会計年度

setGoodsMvtItemList

public void setGoodsMvtItemList(List goodsMvtItemList)
入出庫伝票明細を設定します。

パラメータ:
goodsMvtItemList - 入出庫伝票明細

setGoodsMvtSerialNumberList

public void setGoodsMvtSerialNumberList(List goodsMvtSerialNumberList)
シリアル番号を設定します。

パラメータ:
goodsMvtSerialNumberList - シリアル番号

setGoodsMvtServPartDataList

public void setGoodsMvtServPartDataList(List goodsMvtServPartDataList)
ServPartDataを設定します。

パラメータ:
goodsMvtServPartDataList - ServPartData

setExtensioninList

public void setExtensioninList(List extensioninList)
Reference Structureを設定します。

パラメータ:
extensioninList - Reference Structure

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeadret (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtHeadret

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret
すべての実装インタフェース:
Serializable
public class GoodsMvtHeadret
extends Object
implements Serializable

入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り

  • 入出庫伝票番号/入出庫伝票会計年度情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度情報を作成します。
メソッドの概要
String | getDocYear() 入出庫伝票年度を取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeadret

public GoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度情報を作成します。

メソッドの詳細

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem
すべての実装インタフェース:
Serializable
public class GoodsMvtItem
extends Object
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtItem()
入出庫伝票明細情報を作成します。
GoodsMvtItem(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAmountLc() マニュアル入力による転記金額 (国内通貨)を取得します。
String | getAmountSv() 外部入力による販売金額 (国内通貨)を取得します。
String | getAssetNo() 資産番号を取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBatch() ロット番号を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCompShip() 出荷指示順守を取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostObj() 原価対象を取得します。
String | getCustomer() 得意先コードを取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivItemToSearch() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDelivNumbToSearch() 出荷伝票を取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getEntryQnt() 入力単位での数量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 単位の ISO コードを取得します。
String | getExpirydate() 有効期間期限日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrNumber() 入庫番号を取得します。
String | getGrRcpt() 受領者を取得します。
String | getGrRcptx() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getIndProposeQuanx() 提案数量 (初期数量)を取得します。
String | getItemText() 明細テキストを取得します。
String | getLineDepth() 伝票での明細行階層レベルを取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getLongnum() Long Procurement Document Numberを取得します。
String | getMatdocTrCancel() 取消予定の転送要求の入出庫伝票番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatitemTrCancel() 取消予定の転送数量入出庫伝票明細を取得します。
String | getMatyearTrCancel() 取消予定の転送要求入出庫伝票年度を取得します。
String | getMoveBatch() 入庫/出庫ロットを取得します。
String | getMoveMat() 入庫/出庫品目を取得します。
String | getMoveMatExternal() 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getMoveMatGuid() 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getMoveMatVersion() 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getMovePlant() 入庫/出庫プラントを取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveStloc() 入庫/出庫保管場所を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getMoveValType() 転送ロットの評価タイプを取得します。
String | getMvtInd() 移動区分を取得します。
String | getNbSlips() 入庫/出庫票の印刷部数を取得します。
String | getNbSlipsx() 関連ユーザデータ項目の更新情報を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getNoPstChgnt() 区分: 振替要求通知登録禁止を取得します。
String | getNoTransferReq() 区分: 転送要求未登録を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderItno() 指図明細番号を取得します。
String | getOrderprUn() 購買発注価格単位 (購買管理)を取得します。
String | getOrderprUnIso() 単位の ISO コードを取得します。
String | getParCompco() 決済会社コードを取得します。
String | getParentId() 1 レベル上位の行 IDを取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買発注番号を取得します。
String | getPoPrQnt() 数量 (購買発注価格単位)を取得します。
String | getProdDate() ロット製造日付を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getQuantity() 数量を取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細番号を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getReservNo() 入出庫予定/従属所要量の番号を取得します。
String | getResItem() 入出庫予定/従属所要量の明細番号を取得します。
String | getResType() レコードタイプを取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSchedLine() 受注納入日程を取得します。
String | getSerialnoAutoNumberassignment() シリアル番号の自動登録を取得します。
String | getShipping() 出荷指示を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getSpecMvmt() 倉庫管理の特殊移動区分を取得します。
String | getSpecStock() 特殊在庫区分を取得します。
String | getStckType() 在庫タイプを取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeBinPc() 在庫転送棚番を取得します。
String | getStgeBinSt() 在庫転送棚番を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStgeType() 保管域タイプを取得します。
String | getStgeTypePc() 在庫転送の保管域タイプを取得します。
String | getStgeTypeSt() 在庫転送の保管域タイプを取得します。
String | getStUnQtyy1() 代替数量単位での在庫受入予定保管単位別数量を取得します。
String | getStUnQtyy1Iso() 単位の ISO コードを取得します。
String | getStUnQtyy2() 代替数量単位での在庫受入予定保管単位別数量を取得します。
String | getStUnQtyy2Iso() 単位の ISO コードを取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getSuPlStck1() 在庫受入予定の保管単位数を取得します。
String | getSuPlStck2() 在庫受入予定の保管単位数を取得します。
String | getSupplVend() 供給仕入先を取得します。
String | getTrPartBa() 取引会社事業領域を取得します。
String | getUnittype1() 保管単位タイプを取得します。
String | getUnittype2() 保管単位タイプを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getUnloadPtx() 関連ユーザデータ項目の更新情報を取得します。
String | getValSalesOrd() 評価受注在庫の受注番号を取得します。
String | getValSOrdItem() 評価受注在庫の受注明細を取得します。
String | getValType() 評価タイプを取得します。
String | getValWbsElem() WBS 要素を取得します。
String | getVendor() 仕入先勘定コードを取得します。
String | getVendrbatch() 仕入先ロット番号を取得します。
String | getWbsElem() WBS 要素を取得します。
String | getWithdrawn() 入出庫予定に対する出庫完了を取得します。
String | getXstob() 取消移動タイプ区分の使用を取得します。
void | setActivity(String activity) 作業番号を設定します。
void | setActtype(String acttype) 活動タイプを設定します。
void | setAmountLc(String amountLc) マニュアル入力による転記金額 (国内通貨)を設定します。
void | setAmountSv(String amountSv) 外部入力による販売金額 (国内通貨)を設定します。
void | setAssetNo(String assetNo) 資産番号を設定します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCmmtItem(String cmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String cmmtItemLong) 資金予算コードを設定します。
void | setCoBusproc(String coBusproc) 業務プロセスを設定します。
void | setCompShip(String compShip) 出荷指示順守を設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCostObj(String costObj) 原価対象を設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivItemToSearch(String delivItemToSearch) 出荷明細を設定します。
void | setDelivNumb(String delivNumb) 出荷伝票を設定します。
void | setDelivNumbToSearch(String delivNumbToSearch) 出荷伝票を設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setEntryQnt(String entryQnt) 入力単位での数量を設定します。
void | setEntryUom(String entryUom) 入力単位を設定します。
void | setEntryUomIso(String entryUomIso) 単位の ISO コードを設定します。
void | setExpirydate(String expirydate) 有効期間期限日を設定します。
void | setFuncArea(String funcArea) 機能領域を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setFund(String fund) 会計区分を設定します。
void | setFundsCtr(String fundsCtr) 予算センタを設定します。
void | setGlAccount(String glAccount) G/L 勘定コードを設定します。
void | setGrantNbr(String grantNbr) 補助金を設定します。
void | setGrNumber(String grNumber) 入庫番号を設定します。
void | setGrRcpt(String grRcpt) 受領者を設定します。
void | setGrRcptx(String grRcptx) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIndProposeQuanx(String indProposeQuanx) 提案数量 (初期数量)を設定します。
void | setItemText(String itemText) 明細テキストを設定します。
void | setLineDepth(String lineDepth) 伝票での明細行階層レベルを設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setLongnum(String longnum) Long Procurement Document Numberを設定します。
void | setMatdocTrCancel(String matdocTrCancel) 取消予定の転送要求の入出庫伝票番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatitemTrCancel(String matitemTrCancel) 取消予定の転送数量入出庫伝票明細を設定します。
void | setMatyearTrCancel(String matyearTrCancel) 取消予定の転送要求入出庫伝票年度を設定します。
void | setMoveBatch(String moveBatch) 入庫/出庫ロットを設定します。
void | setMoveMat(String moveMat) 入庫/出庫品目を設定します。
void | setMoveMatExternal(String moveMatExternal) 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setMoveMatGuid(String moveMatGuid) 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setMoveMatVersion(String moveMatVersion) 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setMovePlant(String movePlant) 入庫/出庫プラントを設定します。
void | setMoveReas(String moveReas) 移動理由を設定します。
void | setMoveStloc(String moveStloc) 入庫/出庫保管場所を設定します。
void | setMoveType(String moveType) 移動タイプ (在庫管理)を設定します。
void | setMoveValType(String moveValType) 転送ロットの評価タイプを設定します。
void | setMvtInd(String mvtInd) 移動区分を設定します。
void | setNbSlips(String nbSlips) 入庫/出庫票の印刷部数を設定します。
void | setNbSlipsx(String nbSlipsx) 関連ユーザデータ項目の更新情報を設定します。
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します。
void | setNoMoreGr(String noMoreGr) 納入完了 区分を設定します。
void | setNoPstChgnt(String noPstChgnt) 区分: 振替要求通知登録禁止を設定します。
void | setNoTransferReq(String noTransferReq) 区分: 転送要求未登録を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderItno(String orderItno) 指図明細番号を設定します。
void | setOrderprUn(String orderprUn) 購買発注価格単位 (購買管理)を設定します。
void | setOrderprUnIso(String orderprUnIso) 単位の ISO コードを設定します。
void | setParCompco(String parCompco) 決済会社コードを設定します。
void | setParentId(String parentId) 1 レベル上位の行 IDを設定します。
void | setPartAcct(String partAcct) 取引先勘定コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPoItem(String poItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String poNumber) 購買発注番号を設定します。
void | setPoPrQnt(String poPrQnt) 数量 (購買発注価格単位)を設定します。
void | setProdDate(String prodDate) ロット製造日付を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setQuantity(String quantity) 数量を設定します。
void | setRefDate(String refDate) 決済の参照日付を設定します。
void | setRefDoc(String refDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String refDocIt) 参照伝票の明細番号を設定します。
void | setRefDocYr(String refDocYr) 参照伝票の会計年度を設定します。
void | setReservNo(String reservNo) 入出庫予定/従属所要量の番号を設定します。
void | setResItem(String resItem) 入出庫予定/従属所要量の明細番号を設定します。
void | setResType(String resType) レコードタイプを設定します。
void | setRlEstKey(String rlEstKey) 不動産管理対象の内部キーを設定します。
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します。
void | setSchedLine(String schedLine) 受注納入日程を設定します。
void | setSerialnoAutoNumberassignment(String serialnoAutoNumberassignment) シリアル番号の自動登録を設定します。
void | setShipping(String shipping) 出荷指示を設定します。
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します。
void | setSpecMvmt(String specMvmt) 倉庫管理の特殊移動区分を設定します。
void | setSpecStock(String specStock) 特殊在庫区分を設定します。
void | setStckType(String stckType) 在庫タイプを設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeBinPc(String stgeBinPc) 在庫転送棚番を設定します。
void | setStgeBinSt(String stgeBinSt) 在庫転送棚番を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStgeType(String stgeType) 保管域タイプを設定します。
void | setStgeTypePc(String stgeTypePc) 在庫転送の保管域タイプを設定します。
void | setStgeTypeSt(String stgeTypeSt) 在庫転送の保管域タイプを設定します。
void | setStUnQtyy1(String stUnQtyy1) 代替数量単位での在庫受入予定保管単位別数量を設定します。
void | setStUnQtyy1Iso(String stUnQtyy1Iso) 単位の ISO コードを設定します。
void | setStUnQtyy2(String stUnQtyy2) 代替数量単位での在庫受入予定保管単位別数量を設定します。
void | setStUnQtyy2Iso(String stUnQtyy2Iso) 単位の ISO コードを設定します。
void | setSubNumber(String subNumber) 資産補助番号を設定します。
void | setSuPlStck1(String suPlStck1) 在庫受入予定の保管単位数を設定します。
void | setSuPlStck2(String suPlStck2) 在庫受入予定の保管単位数を設定します。
void | setSupplVend(String supplVend) 供給仕入先を設定します。
void | setTrPartBa(String trPartBa) 取引会社事業領域を設定します。
void | setUnittype1(String unittype1) 保管単位タイプを設定します。
void | setUnittype2(String unittype2) 保管単位タイプを設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
void | setUnloadPtx(String unloadPtx) 関連ユーザデータ項目の更新情報を設定します。
void | setValSalesOrd(String valSalesOrd) 評価受注在庫の受注番号を設定します。
void | setValSOrdItem(String valSOrdItem) 評価受注在庫の受注明細を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setValWbsElem(String valWbsElem) WBS 要素を設定します。
void | setVendor(String vendor) 仕入先勘定コードを設定します。
void | setVendrbatch(String vendrbatch) 仕入先ロット番号を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWithdrawn(String withdrawn) 入出庫予定に対する出庫完了を設定します。
void | setXstob(String xstob) 取消移動タイプ区分の使用を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtItem

public GoodsMvtItem()
入出庫伝票明細情報を作成します。

GoodsMvtItem

public GoodsMvtItem(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
moveType 移動タイプ (在庫管理)

getStckType

public String getStckType()
在庫タイプを取得します。

戻り値:
stckType 在庫タイプ

getSpecStock

public String getSpecStock()
特殊在庫区分を取得します。

戻り値:
specStock 特殊在庫区分

getVendor

public String getVendor()
仕入先勘定コードを取得します。

戻り値:
vendor 仕入先勘定コード

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
salesOrd 受注伝票番号

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
sOrdItem 受注明細番号

getSchedLine

public String getSchedLine()
受注納入日程を取得します。

戻り値:
schedLine 受注納入日程

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getEntryQnt

public String getEntryQnt()
入力単位での数量を取得します。

戻り値:
entryQnt 入力単位での数量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
entryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
単位の ISO コードを取得します。

戻り値:
entryUomIso 単位の ISO コード

getPoPrQnt

public String getPoPrQnt()
数量 (購買発注価格単位)を取得します。

戻り値:
poPrQnt 数量 (購買発注価格単位)

getOrderprUn

public String getOrderprUn()
購買発注価格単位 (購買管理)を取得します。

戻り値:
orderprUn 購買発注価格単位 (購買管理)

getOrderprUnIso

public String getOrderprUnIso()
単位の ISO コードを取得します。

戻り値:
orderprUnIso 単位の ISO コード

getPoNumber

public String getPoNumber()
購買発注番号を取得します。

戻り値:
poNumber 購買発注番号

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
poItem 購買伝票の明細番号

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
shipping 出荷指示

getCompShip

public String getCompShip()
出荷指示順守を取得します。

戻り値:
compShip 出荷指示順守

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
noMoreGr 納入完了 区分

getItemText

public String getItemText()
明細テキストを取得します。

戻り値:
itemText 明細テキスト

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
grRcpt 受領者

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getOrderItno

public String getOrderItno()
指図明細番号を取得します。

戻り値:
orderItno 指図明細番号

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
assetNo 資産番号

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
subNumber 資産補助番号

getReservNo

public String getReservNo()
入出庫予定/従属所要量の番号を取得します。

戻り値:
reservNo 入出庫予定/従属所要量の番号

getResItem

public String getResItem()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
resItem 入出庫予定/従属所要量の明細番号

getResType

public String getResType()
レコードタイプを取得します。

戻り値:
resType レコードタイプ

getWithdrawn

public String getWithdrawn()
入出庫予定に対する出庫完了を取得します。

戻り値:
withdrawn 入出庫予定に対する出庫完了

getMoveMat

public String getMoveMat()
入庫/出庫品目を取得します。

戻り値:
moveMat 入庫/出庫品目

getMovePlant

public String getMovePlant()
入庫/出庫プラントを取得します。

戻り値:
movePlant 入庫/出庫プラント

getMoveStloc

public String getMoveStloc()
入庫/出庫保管場所を取得します。

戻り値:
moveStloc 入庫/出庫保管場所

getMoveBatch

public String getMoveBatch()
入庫/出庫ロットを取得します。

戻り値:
moveBatch 入庫/出庫ロット

getMoveValType

public String getMoveValType()
転送ロットの評価タイプを取得します。

戻り値:
moveValType 転送ロットの評価タイプ

getMvtInd

public String getMvtInd()
移動区分を取得します。

戻り値:
mvtInd 移動区分

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
moveReas 移動理由

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
rlEstKey 不動産管理対象の内部キー

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
refDate 決済の参照日付

getCostObj

public String getCostObj()
原価対象を取得します。

戻り値:
costObj 原価対象

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
network 勘定割当のネットワーク番号

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
activity 作業番号

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
partAcct 取引先勘定コード

getAmountLc

public String getAmountLc()
マニュアル入力による転記金額 (国内通貨)を取得します。

戻り値:
amountLc マニュアル入力による転記金額 (国内通貨)

getAmountSv

public String getAmountSv()
外部入力による販売金額 (国内通貨)を取得します。

戻り値:
amountSv 外部入力による販売金額 (国内通貨)

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
refDocYr 参照伝票の会計年度

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
refDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細番号を取得します。

戻り値:
refDocIt 参照伝票の明細番号

getExpirydate

public String getExpirydate()
有効期間期限日を取得します。

戻り値:
expirydate 有効期間期限日

getProdDate

public String getProdDate()
ロット製造日付を取得します。

戻り値:
prodDate ロット製造日付

getFund

public String getFund()
会計区分を取得します。

戻り値:
fund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
fundsCtr 予算センタ

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
cmmtItem 資金予算コード

getValSalesOrd

public String getValSalesOrd()
評価受注在庫の受注番号を取得します。

戻り値:
valSalesOrd 評価受注在庫の受注番号

getValSOrdItem

public String getValSOrdItem()
評価受注在庫の受注明細を取得します。

戻り値:
valSOrdItem 評価受注在庫の受注明細

getValWbsElem

public String getValWbsElem()
WBS 要素を取得します。

戻り値:
valWbsElem WBS 要素

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
glAccount G/L 勘定コード

getIndProposeQuanx

public String getIndProposeQuanx()
提案数量 (初期数量)を取得します。

戻り値:
indProposeQuanx 提案数量 (初期数量)

getXstob

public String getXstob()
取消移動タイプ区分の使用を取得します。

戻り値:
xstob 取消移動タイプ区分の使用

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getDelivNumbToSearch

public String getDelivNumbToSearch()
出荷伝票を取得します。

戻り値:
delivNumbToSearch 出荷伝票

getDelivItemToSearch

public String getDelivItemToSearch()
出荷明細を取得します。

戻り値:
delivItemToSearch 出荷明細

getSerialnoAutoNumberassignment

public String getSerialnoAutoNumberassignment()
シリアル番号の自動登録を取得します。

戻り値:
serialnoAutoNumberassignment シリアル番号の自動登録

getVendrbatch

public String getVendrbatch()
仕入先ロット番号を取得します。

戻り値:
vendrbatch 仕入先ロット番号

getStgeType

public String getStgeType()
保管域タイプを取得します。

戻り値:
stgeType 保管域タイプ

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getSuPlStck1

public String getSuPlStck1()
在庫受入予定の保管単位数を取得します。

戻り値:
suPlStck1 在庫受入予定の保管単位数

getStUnQtyy1

public String getStUnQtyy1()
代替数量単位での在庫受入予定保管単位別数量を取得します。

戻り値:
stUnQtyy1 代替数量単位での在庫受入予定保管単位別数量

getStUnQtyy1Iso

public String getStUnQtyy1Iso()
単位の ISO コードを取得します。

戻り値:
stUnQtyy1Iso 単位の ISO コード

getUnittype1

public String getUnittype1()
保管単位タイプを取得します。

戻り値:
unittype1 保管単位タイプ

getSuPlStck2

public String getSuPlStck2()
在庫受入予定の保管単位数を取得します。

戻り値:
suPlStck2 在庫受入予定の保管単位数

getStUnQtyy2

public String getStUnQtyy2()
代替数量単位での在庫受入予定保管単位別数量を取得します。

戻り値:
stUnQtyy2 代替数量単位での在庫受入予定保管単位別数量

getStUnQtyy2Iso

public String getStUnQtyy2Iso()
単位の ISO コードを取得します。

戻り値:
stUnQtyy2Iso 単位の ISO コード

getUnittype2

public String getUnittype2()
保管単位タイプを取得します。

戻り値:
unittype2 保管単位タイプ

getStgeTypePc

public String getStgeTypePc()
在庫転送の保管域タイプを取得します。

戻り値:
stgeTypePc 在庫転送の保管域タイプ

getStgeBinPc

public String getStgeBinPc()
在庫転送棚番を取得します。

戻り値:
stgeBinPc 在庫転送棚番

getNoPstChgnt

public String getNoPstChgnt()
区分: 振替要求通知登録禁止を取得します。

戻り値:
noPstChgnt 区分: 振替要求通知登録禁止

getGrNumber

public String getGrNumber()
入庫番号を取得します。

戻り値:
grNumber 入庫番号

getStgeTypeSt

public String getStgeTypeSt()
在庫転送の保管域タイプを取得します。

戻り値:
stgeTypeSt 在庫転送の保管域タイプ

getStgeBinSt

public String getStgeBinSt()
在庫転送棚番を取得します。

戻り値:
stgeBinSt 在庫転送棚番

getMatdocTrCancel

public String getMatdocTrCancel()
取消予定の転送要求の入出庫伝票番号を取得します。

戻り値:
matdocTrCancel 取消予定の転送要求の入出庫伝票番号

getMatitemTrCancel

public String getMatitemTrCancel()
取消予定の転送数量入出庫伝票明細を取得します。

戻り値:
matitemTrCancel 取消予定の転送数量入出庫伝票明細

getMatyearTrCancel

public String getMatyearTrCancel()
取消予定の転送要求入出庫伝票年度を取得します。

戻り値:
matyearTrCancel 取消予定の転送要求入出庫伝票年度

getNoTransferReq

public String getNoTransferReq()
区分: 転送要求未登録を取得します。

戻り値:
noTransferReq 区分: 転送要求未登録

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
coBusproc 業務プロセス

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
acttype 活動タイプ

getSupplVend

public String getSupplVend()
供給仕入先を取得します。

戻り値:
supplVend 供給仕入先

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getMoveMatExternal

public String getMoveMatExternal()
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
moveMatExternal 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

getMoveMatGuid

public String getMoveMatGuid()
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
moveMatGuid 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

getMoveMatVersion

public String getMoveMatVersion()
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
moveMatVersion 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
funcArea 機能領域

getTrPartBa

public String getTrPartBa()
取引会社事業領域を取得します。

戻り値:
trPartBa 取引会社事業領域

getParCompco

public String getParCompco()
決済会社コードを取得します。

戻り値:
parCompco 決済会社コード

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
delivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getNbSlips

public String getNbSlips()
入庫/出庫票の印刷部数を取得します。

戻り値:
nbSlips 入庫/出庫票の印刷部数

getNbSlipsx

public String getNbSlipsx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
nbSlipsx 関連ユーザデータ項目の更新情報

getGrRcptx

public String getGrRcptx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
grRcptx 関連ユーザデータ項目の更新情報

getUnloadPtx

public String getUnloadPtx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unloadPtx 関連ユーザデータ項目の更新情報

getSpecMvmt

public String getSpecMvmt()
倉庫管理の特殊移動区分を取得します。

戻り値:
specMvmt 倉庫管理の特殊移動区分

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
grantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
cmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getParentId

public String getParentId()
1 レベル上位の行 IDを取得します。

戻り値:
parentId 1 レベル上位の行 ID

getLineDepth

public String getLineDepth()
伝票での明細行階層レベルを取得します。

戻り値:
lineDepth 伝票での明細行階層レベル

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
quantity 数量

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getLongnum

public String getLongnum()
Long Procurement Document Numberを取得します。

戻り値:
longnum Long Procurement Document Number

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setMoveType

public void setMoveType(String moveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
moveType - 移動タイプ (在庫管理)

setStckType

public void setStckType(String stckType)
在庫タイプを設定します。

パラメータ:
stckType - 在庫タイプ

setSpecStock

public void setSpecStock(String specStock)
特殊在庫区分を設定します。

パラメータ:
specStock - 特殊在庫区分

setVendor

public void setVendor(String vendor)
仕入先勘定コードを設定します。

パラメータ:
vendor - 仕入先勘定コード

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します。

パラメータ:
salesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します。

パラメータ:
sOrdItem - 受注明細番号

setSchedLine

public void setSchedLine(String schedLine)
受注納入日程を設定します。

パラメータ:
schedLine - 受注納入日程

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setEntryQnt

public void setEntryQnt(String entryQnt)
入力単位での数量を設定します。

パラメータ:
entryQnt - 入力単位での数量

setEntryUom

public void setEntryUom(String entryUom)
入力単位を設定します。

パラメータ:
entryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String entryUomIso)
単位の ISO コードを設定します。

パラメータ:
entryUomIso - 単位の ISO コード

setPoPrQnt

public void setPoPrQnt(String poPrQnt)
数量 (購買発注価格単位)を設定します。

パラメータ:
poPrQnt - 数量 (購買発注価格単位)

setOrderprUn

public void setOrderprUn(String orderprUn)
購買発注価格単位 (購買管理)を設定します。

パラメータ:
orderprUn - 購買発注価格単位 (購買管理)

setOrderprUnIso

public void setOrderprUnIso(String orderprUnIso)
単位の ISO コードを設定します。

パラメータ:
orderprUnIso - 単位の ISO コード

setPoNumber

public void setPoNumber(String poNumber)
購買発注番号を設定します。

パラメータ:
poNumber - 購買発注番号

setPoItem

public void setPoItem(String poItem)
購買伝票の明細番号を設定します。

パラメータ:
poItem - 購買伝票の明細番号

setShipping

public void setShipping(String shipping)
出荷指示を設定します。

パラメータ:
shipping - 出荷指示

setCompShip

public void setCompShip(String compShip)
出荷指示順守を設定します。

パラメータ:
compShip - 出荷指示順守

setNoMoreGr

public void setNoMoreGr(String noMoreGr)
納入完了 区分を設定します。

パラメータ:
noMoreGr - 納入完了 区分

setItemText

public void setItemText(String itemText)
明細テキストを設定します。

パラメータ:
itemText - 明細テキスト

setGrRcpt

public void setGrRcpt(String grRcpt)
受領者を設定します。

パラメータ:
grRcpt - 受領者

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setOrderItno

public void setOrderItno(String orderItno)
指図明細番号を設定します。

パラメータ:
orderItno - 指図明細番号

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

setAssetNo

public void setAssetNo(String assetNo)
資産番号を設定します。

パラメータ:
assetNo - 資産番号

setSubNumber

public void setSubNumber(String subNumber)
資産補助番号を設定します。

パラメータ:
subNumber - 資産補助番号

setReservNo

public void setReservNo(String reservNo)
入出庫予定/従属所要量の番号を設定します。

パラメータ:
reservNo - 入出庫予定/従属所要量の番号

setResItem

public void setResItem(String resItem)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
resItem - 入出庫予定/従属所要量の明細番号

setResType

public void setResType(String resType)
レコードタイプを設定します。

パラメータ:
resType - レコードタイプ

setWithdrawn

public void setWithdrawn(String withdrawn)
入出庫予定に対する出庫完了を設定します。

パラメータ:
withdrawn - 入出庫予定に対する出庫完了

setMoveMat

public void setMoveMat(String moveMat)
入庫/出庫品目を設定します。

パラメータ:
moveMat - 入庫/出庫品目

setMovePlant

public void setMovePlant(String movePlant)
入庫/出庫プラントを設定します。

パラメータ:
movePlant - 入庫/出庫プラント

setMoveStloc

public void setMoveStloc(String moveStloc)
入庫/出庫保管場所を設定します。

パラメータ:
moveStloc - 入庫/出庫保管場所

setMoveBatch

public void setMoveBatch(String moveBatch)
入庫/出庫ロットを設定します。

パラメータ:
moveBatch - 入庫/出庫ロット

setMoveValType

public void setMoveValType(String moveValType)
転送ロットの評価タイプを設定します。

パラメータ:
moveValType - 転送ロットの評価タイプ

setMvtInd

public void setMvtInd(String mvtInd)
移動区分を設定します。

パラメータ:
mvtInd - 移動区分

setMoveReas

public void setMoveReas(String moveReas)
移動理由を設定します。

パラメータ:
moveReas - 移動理由

setRlEstKey

public void setRlEstKey(String rlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
rlEstKey - 不動産管理対象の内部キー

setRefDate

public void setRefDate(String refDate)
決済の参照日付を設定します。

パラメータ:
refDate - 決済の参照日付

setCostObj

public void setCostObj(String costObj)
原価対象を設定します。

パラメータ:
costObj - 原価対象

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します。

パラメータ:
network - 勘定割当のネットワーク番号

setActivity

public void setActivity(String activity)
作業番号を設定します。

パラメータ:
activity - 作業番号

setPartAcct

public void setPartAcct(String partAcct)
取引先勘定コードを設定します。

パラメータ:
partAcct - 取引先勘定コード

setAmountLc

public void setAmountLc(String amountLc)
マニュアル入力による転記金額 (国内通貨)を設定します。

パラメータ:
amountLc - マニュアル入力による転記金額 (国内通貨)

setAmountSv

public void setAmountSv(String amountSv)
外部入力による販売金額 (国内通貨)を設定します。

パラメータ:
amountSv - 外部入力による販売金額 (国内通貨)

setRefDocYr

public void setRefDocYr(String refDocYr)
参照伝票の会計年度を設定します。

パラメータ:
refDocYr - 参照伝票の会計年度

setRefDoc

public void setRefDoc(String refDoc)
参照伝票の伝票番号を設定します。

パラメータ:
refDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照伝票の明細番号を設定します。

パラメータ:
refDocIt - 参照伝票の明細番号

setExpirydate

public void setExpirydate(String expirydate)
有効期間期限日を設定します。

パラメータ:
expirydate - 有効期間期限日

setProdDate

public void setProdDate(String prodDate)
ロット製造日付を設定します。

パラメータ:
prodDate - ロット製造日付

setFund

public void setFund(String fund)
会計区分を設定します。

パラメータ:
fund - 会計区分

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します。

パラメータ:
fundsCtr - 予算センタ

setCmmtItem

public void setCmmtItem(String cmmtItem)
資金予算コードを設定します。

パラメータ:
cmmtItem - 資金予算コード

setValSalesOrd

public void setValSalesOrd(String valSalesOrd)
評価受注在庫の受注番号を設定します。

パラメータ:
valSalesOrd - 評価受注在庫の受注番号

setValSOrdItem

public void setValSOrdItem(String valSOrdItem)
評価受注在庫の受注明細を設定します。

パラメータ:
valSOrdItem - 評価受注在庫の受注明細

setValWbsElem

public void setValWbsElem(String valWbsElem)
WBS 要素を設定します。

パラメータ:
valWbsElem - WBS 要素

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します。

パラメータ:
glAccount - G/L 勘定コード

setIndProposeQuanx

public void setIndProposeQuanx(String indProposeQuanx)
提案数量 (初期数量)を設定します。

パラメータ:
indProposeQuanx - 提案数量 (初期数量)

setXstob

public void setXstob(String xstob)
取消移動タイプ区分の使用を設定します。

パラメータ:
xstob - 取消移動タイプ区分の使用

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setDelivNumbToSearch

public void setDelivNumbToSearch(String delivNumbToSearch)
出荷伝票を設定します。

パラメータ:
delivNumbToSearch - 出荷伝票

setDelivItemToSearch

public void setDelivItemToSearch(String delivItemToSearch)
出荷明細を設定します。

パラメータ:
delivItemToSearch - 出荷明細

setSerialnoAutoNumberassignment

public void setSerialnoAutoNumberassignment(String serialnoAutoNumberassignment)
シリアル番号の自動登録を設定します。

パラメータ:
serialnoAutoNumberassignment - シリアル番号の自動登録

setVendrbatch

public void setVendrbatch(String vendrbatch)
仕入先ロット番号を設定します。

パラメータ:
vendrbatch - 仕入先ロット番号

setStgeType

public void setStgeType(String stgeType)
保管域タイプを設定します。

パラメータ:
stgeType - 保管域タイプ

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setSuPlStck1

public void setSuPlStck1(String suPlStck1)
在庫受入予定の保管単位数を設定します。

パラメータ:
suPlStck1 - 在庫受入予定の保管単位数

setStUnQtyy1

public void setStUnQtyy1(String stUnQtyy1)
代替数量単位での在庫受入予定保管単位別数量を設定します。

パラメータ:
stUnQtyy1 - 代替数量単位での在庫受入予定保管単位別数量

setStUnQtyy1Iso

public void setStUnQtyy1Iso(String stUnQtyy1Iso)
単位の ISO コードを設定します。

パラメータ:
stUnQtyy1Iso - 単位の ISO コード

setUnittype1

public void setUnittype1(String unittype1)
保管単位タイプを設定します。

パラメータ:
unittype1 - 保管単位タイプ

setSuPlStck2

public void setSuPlStck2(String suPlStck2)
在庫受入予定の保管単位数を設定します。

パラメータ:
suPlStck2 - 在庫受入予定の保管単位数

setStUnQtyy2

public void setStUnQtyy2(String stUnQtyy2)
代替数量単位での在庫受入予定保管単位別数量を設定します。

パラメータ:
stUnQtyy2 - 代替数量単位での在庫受入予定保管単位別数量

setStUnQtyy2Iso

public void setStUnQtyy2Iso(String stUnQtyy2Iso)
単位の ISO コードを設定します。

パラメータ:
stUnQtyy2Iso - 単位の ISO コード

setUnittype2

public void setUnittype2(String unittype2)
保管単位タイプを設定します。

パラメータ:
unittype2 - 保管単位タイプ

setStgeTypePc

public void setStgeTypePc(String stgeTypePc)
在庫転送の保管域タイプを設定します。

パラメータ:
stgeTypePc - 在庫転送の保管域タイプ

setStgeBinPc

public void setStgeBinPc(String stgeBinPc)
在庫転送棚番を設定します。

パラメータ:
stgeBinPc - 在庫転送棚番

setNoPstChgnt

public void setNoPstChgnt(String noPstChgnt)
区分: 振替要求通知登録禁止を設定します。

パラメータ:
noPstChgnt - 区分: 振替要求通知登録禁止

setGrNumber

public void setGrNumber(String grNumber)
入庫番号を設定します。

パラメータ:
grNumber - 入庫番号

setStgeTypeSt

public void setStgeTypeSt(String stgeTypeSt)
在庫転送の保管域タイプを設定します。

パラメータ:
stgeTypeSt - 在庫転送の保管域タイプ

setStgeBinSt

public void setStgeBinSt(String stgeBinSt)
在庫転送棚番を設定します。

パラメータ:
stgeBinSt - 在庫転送棚番

setMatdocTrCancel

public void setMatdocTrCancel(String matdocTrCancel)
取消予定の転送要求の入出庫伝票番号を設定します。

パラメータ:
matdocTrCancel - 取消予定の転送要求の入出庫伝票番号

setMatitemTrCancel

public void setMatitemTrCancel(String matitemTrCancel)
取消予定の転送数量入出庫伝票明細を設定します。

パラメータ:
matitemTrCancel - 取消予定の転送数量入出庫伝票明細

setMatyearTrCancel

public void setMatyearTrCancel(String matyearTrCancel)
取消予定の転送要求入出庫伝票年度を設定します。

パラメータ:
matyearTrCancel - 取消予定の転送要求入出庫伝票年度

setNoTransferReq

public void setNoTransferReq(String noTransferReq)
区分: 転送要求未登録を設定します。

パラメータ:
noTransferReq - 区分: 転送要求未登録

setCoBusproc

public void setCoBusproc(String coBusproc)
業務プロセスを設定します。

パラメータ:
coBusproc - 業務プロセス

setActtype

public void setActtype(String acttype)
活動タイプを設定します。

パラメータ:
acttype - 活動タイプ

setSupplVend

public void setSupplVend(String supplVend)
供給仕入先を設定します。

パラメータ:
supplVend - 供給仕入先

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setMoveMatExternal

public void setMoveMatExternal(String moveMatExternal)
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
moveMatExternal - 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

setMoveMatGuid

public void setMoveMatGuid(String moveMatGuid)
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
moveMatGuid - 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

setMoveMatVersion

public void setMoveMatVersion(String moveMatVersion)
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
moveMatVersion - 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

setFuncArea

public void setFuncArea(String funcArea)
機能領域を設定します。

パラメータ:
funcArea - 機能領域

setTrPartBa

public void setTrPartBa(String trPartBa)
取引会社事業領域を設定します。

パラメータ:
trPartBa - 取引会社事業領域

setParCompco

public void setParCompco(String parCompco)
決済会社コードを設定します。

パラメータ:
parCompco - 決済会社コード

setDelivNumb

public void setDelivNumb(String delivNumb)
出荷伝票を設定します。

パラメータ:
delivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setNbSlips

public void setNbSlips(String nbSlips)
入庫/出庫票の印刷部数を設定します。

パラメータ:
nbSlips - 入庫/出庫票の印刷部数

setNbSlipsx

public void setNbSlipsx(String nbSlipsx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
nbSlipsx - 関連ユーザデータ項目の更新情報

setGrRcptx

public void setGrRcptx(String grRcptx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
grRcptx - 関連ユーザデータ項目の更新情報

setUnloadPtx

public void setUnloadPtx(String unloadPtx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unloadPtx - 関連ユーザデータ項目の更新情報

setSpecMvmt

public void setSpecMvmt(String specMvmt)
倉庫管理の特殊移動区分を設定します。

パラメータ:
specMvmt - 倉庫管理の特殊移動区分

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します。

パラメータ:
grantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
資金予算コードを設定します。

パラメータ:
cmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setParentId

public void setParentId(String parentId)
1 レベル上位の行 IDを設定します。

パラメータ:
parentId - 1 レベル上位の行 ID

setLineDepth

public void setLineDepth(String lineDepth)
伝票での明細行階層レベルを設定します。

パラメータ:
lineDepth - 伝票での明細行階層レベル

setQuantity

public void setQuantity(String quantity)
数量を設定します。

パラメータ:
quantity - 数量

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setLongnum

public void setLongnum(String longnum)
Long Procurement Document Numberを設定します。

パラメータ:
longnum - Long Procurement Document Number

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtRefEwm (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtRefEwm

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm
すべての実装インタフェース:
Serializable
public class GoodsMvtRefEwm
extends Object
implements Serializable

BAdI 通信構造: 入出庫伝票 EWM 照会情報クラス
機能は以下の通り

  • BAdI 通信構造: 入出庫伝票 EWM 照会情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtRefEwm()
BAdI 通信構造: 入出庫伝票 EWM 照会情報を作成します。
メソッドの概要
String | getGtsScrapNo() 廃棄処理の税関参照番号を取得します。
String | getLogsys() EWM 入出庫伝票の論理システムを取得します。
String | getRefDocEwm() EWM 入出庫伝票番号を取得します。
void | setGtsScrapNo(String gtsScrapNo) 廃棄処理の税関参照番号を設定します。
void | setLogsys(String logsys) EWM 入出庫伝票の論理システムを設定します。
void | setRefDocEwm(String refDocEwm) EWM 入出庫伝票番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtRefEwm

public GoodsMvtRefEwm()
BAdI 通信構造: 入出庫伝票 EWM 照会情報を作成します。

メソッドの詳細

getRefDocEwm

public String getRefDocEwm()
EWM 入出庫伝票番号を取得します。

戻り値:
refDocEwm EWM 入出庫伝票番号

getLogsys

public String getLogsys()
EWM 入出庫伝票の論理システムを取得します。

戻り値:
logsys EWM 入出庫伝票の論理システム

getGtsScrapNo

public String getGtsScrapNo()
廃棄処理の税関参照番号を取得します。

戻り値:
gtsScrapNo 廃棄処理の税関参照番号

setRefDocEwm

public void setRefDocEwm(String refDocEwm)
EWM 入出庫伝票番号を設定します。

パラメータ:
refDocEwm - BAPI EWM 入出庫伝票番号

setLogsys

public void setLogsys(String logsys)
EWM 入出庫伝票の論理システムを設定します。

パラメータ:
logsys - EWM 入出庫伝票の論理システム

setGtsScrapNo

public void setGtsScrapNo(String gtsScrapNo)
廃棄処理の税関参照番号を設定します。

パラメータ:
gtsScrapNo - 廃棄処理の税関参照番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtSerialNumber (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtSerialNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber
すべての実装インタフェース:
Serializable
public class GoodsMvtSerialNumber
extends Object
implements Serializable

シリアル番号情報クラス
機能は以下の通り

  • シリアル番号情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtSerialNumber()
シリアル番号情報を作成します。
GoodsMvtSerialNumber(int index)
シリアル番号情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getSerialno() シリアル番号を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setMatdocItm(String matdocItm) 入出庫伝票の明細を設定します。
void | setSerialno(String serialno) シリアル番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtSerialNumber

public GoodsMvtSerialNumber()
シリアル番号情報を作成します。

GoodsMvtSerialNumber

public GoodsMvtSerialNumber(int index)
シリアル番号情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
matdocItm 入出庫伝票の明細

getSerialno

public String getSerialno()
シリアル番号を取得します。

戻り値:
serialno シリアル番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setMatdocItm

public void setMatdocItm(String matdocItm)
入出庫伝票の明細を設定します。

パラメータ:
matdocItm - 入出庫伝票の明細

setSerialno

public void setSerialno(String serialno)
シリアル番号を設定します。

パラメータ:
serialno - シリアル番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtServPartData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtServPartData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData
すべての実装インタフェース:
Serializable
public class GoodsMvtServPartData
extends Object
implements Serializable

情報クラス
機能は以下の通り

  • 情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtServPartData()
情報を作成します。
GoodsMvtServPartData(int index)
情報を作成します。
メソッドの概要
String | getDate() 日付を取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivNumber() 出荷伝票を取得します。
String | getEvent() 論理時間を取得します。
String | getGtsStockType() GTS在庫タイプを取得します。
String | getHuNumber() 外部荷役単位 IDを取得します。
int | getIndex() レコード番号を取得します｡
String | getInspoutGuid() 品質検査結果: EWM 設定の在庫 GUIDを取得します。
String | getKeepQuantity() EWM での廃棄処理の保持数量を取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getMoveGtsStockType() GTS在庫タイプを取得します。
String | getRetAuthNumber() 返品権限番号を取得します。
String | getScrapIndicator() EWM 処理の廃棄区分を取得します。
String | getTime() 時刻を取得します。
String | getTimestamp() 取引開始時刻 (UTCタイムスタンプ)を取得します。
String | getZonlo() 現在のユーザのタイムゾーンを取得します。
void | setDate(String date) 日付を設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivNumber(String delivNumber) 出荷伝票を設定します。
void | setEvent(String event) 論理時間を設定します。
void | setGtsStockType(String gtsStockType) GTS在庫タイプを設定します。
void | setHuNumber(String huNumber) 外部荷役単位 IDを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInspoutGuid(String inspoutGuid) 品質検査結果: EWM 設定の在庫 GUIDを設定します。
void | setKeepQuantity(String keepQuantity) EWM での廃棄処理の保持数量を設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setMoveGtsStockType(String moveGtsStockType) GTS在庫タイプを設定します。
void | setRetAuthNumber(String retAuthNumber) 返品権限番号を設定します。
void | setScrapIndicator(String scrapIndicator) EWM 処理の廃棄区分を設定します。
void | setTime(String time) 時刻を設定します。
void | setTimestamp(String timestamp) 取引開始時刻 (UTCタイムスタンプ)を設定します。
void | setZonlo(String zonlo) 現在のユーザのタイムゾーンを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtServPartData

public GoodsMvtServPartData()
情報を作成します。

GoodsMvtServPartData

public GoodsMvtServPartData(int index)
情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getRetAuthNumber

public String getRetAuthNumber()
返品権限番号を取得します。

戻り値:
retAuthNumber 返品権限番号

getDelivNumber

public String getDelivNumber()
出荷伝票を取得します。

戻り値:
delivNumber 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getHuNumber

public String getHuNumber()
外部荷役単位 IDを取得します。

戻り値:
huNumber 外部荷役単位 ID

getInspoutGuid

public String getInspoutGuid()
品質検査結果: EWM 設定の在庫 GUIDを取得します。

戻り値:
inspoutGuid 品質検査結果: EWM 設定の在庫 GUID

getEvent

public String getEvent()
論理時間を取得します。

戻り値:
event 論理時間

getDate

public String getDate()
日付を取得します。

戻り値:
date 日付

getTime

public String getTime()
時刻を取得します。

戻り値:
time 時刻

getZonlo

public String getZonlo()
現在のユーザのタイムゾーンを取得します。

戻り値:
zonlo 現在のユーザのタイムゾーン

getTimestamp

public String getTimestamp()
取引開始時刻 (UTCタイムスタンプ)を取得します。

戻り値:
timestamp 取引開始時刻 (UTCタイムスタンプ)

getScrapIndicator

public String getScrapIndicator()
EWM 処理の廃棄区分を取得します。

戻り値:
scrapIndicator EWM 処理の廃棄区分

getKeepQuantity

public String getKeepQuantity()
EWM での廃棄処理の保持数量を取得します。

戻り値:
keepQuantity EWM での廃棄処理の保持数量

getGtsStockType

public String getGtsStockType()
GTS在庫タイプを取得します。

戻り値:
gtsStockType GTS在庫タイプ

getMoveGtsStockType

public String getMoveGtsStockType()
GTS在庫タイプを取得します。

戻り値:
moveGtsStockType GTS在庫タイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setRetAuthNumber

public void setRetAuthNumber(String retAuthNumber)
返品権限番号を設定します。

パラメータ:
retAuthNumber - 返品権限番号

setDelivNumber

public void setDelivNumber(String delivNumber)
出荷伝票を設定します。

パラメータ:
delivNumber - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setHuNumber

public void setHuNumber(String huNumber)
外部荷役単位 IDを設定します。

パラメータ:
huNumber - 外部荷役単位 ID

setInspoutGuid

public void setInspoutGuid(String inspoutGuid)
品質検査結果: EWM 設定の在庫 GUIDを設定します。

パラメータ:
inspoutGuid - 品質検査結果: EWM 設定の在庫 GUID

setEvent

public void setEvent(String event)
論理時間を設定します。

パラメータ:
event - 論理時間

setDate

public void setDate(String date)
日付を設定します。

パラメータ:
date - 日付

setTime

public void setTime(String time)
時刻を設定します。

パラメータ:
time - 時刻

setZonlo

public void setZonlo(String zonlo)
現在のユーザのタイムゾーンを設定します。

パラメータ:
zonlo - 現在のユーザのタイムゾーン

setTimestamp

public void setTimestamp(String timestamp)
取引開始時刻 (UTCタイムスタンプ)を設定します。

パラメータ:
timestamp - 取引開始時刻 (UTCタイムスタンプ)

setScrapIndicator

public void setScrapIndicator(String scrapIndicator)
EWM 処理の廃棄区分を設定します。

パラメータ:
scrapIndicator - EWM 処理の廃棄区分

setKeepQuantity

public void setKeepQuantity(String keepQuantity)
EWM での廃棄処理の保持数量を設定します。

パラメータ:
keepQuantity - EWM での廃棄処理の保持数量

setGtsStockType

public void setGtsStockType(String gtsStockType)
GTS在庫タイプを設定します。

パラメータ:
gtsStockType - GTS在庫タイプ

setMoveGtsStockType

public void setMoveGtsStockType(String moveGtsStockType)
GTS在庫タイプを設定します。

パラメータ:
moveGtsStockType - GTS在庫タイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス
Extensionin
GoodsMvtCode
GoodsMvtCreate
GoodsMvtHeadret
GoodsMvtItem
GoodsMvtRefEwm
GoodsMvtSerialNumber
GoodsMvtServPartData
ParamExtensionin
ParamGoodsMvtCode
ParamGoodsMvtHeadret
ParamGoodsMvtItem
ParamGoodsMvtRefEwm
ParamGoodsMvtSerialNumber
ParamGoodsMvtServPartData


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

クラスの概要
Extensionin | Reference Structure情報クラス 機能は以下の通り Reference Structure情報を保持します。
GoodsMvtCode | 在庫移動に対するコードのトランザクションへの割当情報クラス 機能は以下の通り 在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtCreate | 入出庫伝票登録情報クラス 機能は以下の通り 入出庫伝票登録情報を保持します。
GoodsMvtHeadret | 入出庫伝票番号/入出庫伝票会計年度情報クラス 機能は以下の通り 入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtItem | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
GoodsMvtRefEwm | BAdI 通信構造: 入出庫伝票 EWM 照会情報クラス 機能は以下の通り BAdI 通信構造: 入出庫伝票 EWM 照会情報を保持します。
GoodsMvtSerialNumber | シリアル番号情報クラス 機能は以下の通り シリアル番号情報を保持します。
GoodsMvtServPartData | 情報クラス 機能は以下の通り 情報を保持します。
ParamExtensionin | Reference Structure設定クラス 機能は以下の通り Reference Structureを設定します。
ParamGoodsMvtCode | 在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス 機能は以下の通り 在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。
ParamGoodsMvtHeadret | 入出庫伝票ヘッダデータパラメータ設定クラス 機能は以下の通り 入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtItem | リターン構造、入出庫伝票明細パラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtRefEwm | BAdI 通信構造: 入出庫伝票 EWMパラメータ設定クラス 機能は以下の通り BAdI 通信構造: 入出庫伝票 EWMのパラメータを設定します。
ParamGoodsMvtSerialNumber | シリアル番号パラメータ設定クラス 機能は以下の通り シリアル番号のパラメータを設定します。
ParamGoodsMvtServPartData | 設定クラス 機能は以下の通り 設定します。


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のクラス
GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のクラス
GoodsMvtCode
在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtHeadret
入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り
入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtRefEwm
BAdI 通信構造: 入出庫伝票 EWM 照会情報クラス
機能は以下の通り
BAdI 通信構造: 入出庫伝票 EWM 照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamExtensionin (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamExtensionin

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin
すべての実装インタフェース:
Serializable
public final class ParamExtensionin
extends Object
implements Serializable

Reference Structure設定クラス
機能は以下の通り

  • Reference Structureを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensioninList) table(Export)情報から返却されたReference Structure値をセットします。
static void | setImportParam(BapiController bapiController, List extensioninList) Reference Structureの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensioninList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
Reference Structureの値をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensioninList)
                           throws SAPGeneralSystemException
table(Export)情報から返却されたReference Structure値をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtCode (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtCode

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtCode
extends Object
implements Serializable

在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス
機能は以下の通り

  • 在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode)
在庫移動に対するコードのトランザクションへの割当の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtCode goodsMvtCode)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
在庫移動に対するコードのトランザクションへの割当の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtCode - GoodsMvtCode
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtHeadret (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtHeadret

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeadret
extends Object
implements Serializable

入出庫伝票ヘッダデータパラメータ設定クラス
機能は以下の通り

    入出庫伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret)
入出庫伝票ヘッダデータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  GoodsMvtHeadret goodsMvtHeadret)
                           throws SAPGeneralSystemException
入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeadret - GoodsMvtHeadret
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtItem
extends Object
implements Serializable

リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtItemList) table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtItemList) リターン構造、入出庫伝票明細の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtItemList)
                           throws SAPGeneralSystemException
table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtRefEwm (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtRefEwm

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtRefEwm
extends Object
implements Serializable

BAdI 通信構造: 入出庫伝票 EWMパラメータ設定クラス
機能は以下の通り

  • BAdI 通信構造: 入出庫伝票 EWMのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, GoodsMvtRefEwm goodsMvtRefEwm)
BAdI 通信構造: 入出庫伝票 EWMの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtRefEwm goodsMvtRefEwm)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
BAdI 通信構造: 入出庫伝票 EWMの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtRefEwm - GoodsMvtRefEwm
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtSerialNumber (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtSerialNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtSerialNumber
extends Object
implements Serializable

シリアル番号パラメータ設定クラス
機能は以下の通り

  • シリアル番号のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtSerialNumberList) table(Export)情報からシリアル番号の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtSerialNumberList) シリアル番号の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtSerialNumberList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
シリアル番号の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtSerialNumberList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtSerialNumberList)
                           throws SAPGeneralSystemException
table(Export)情報からシリアル番号の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtSerialNumberList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtServPartData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtServPartData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtServPartData
extends Object
implements Serializable

設定クラス
機能は以下の通り

  • 設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtServPartDataList) table(Export)情報から返却された値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtServPartDataList) 値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtServPartDataList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
値をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtServPartDataList)
                           throws SAPGeneralSystemException
table(Export)情報から返却された値をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems の使用

GoodsMvtGetItems を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtGetItems の使用

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtGetItems のサブクラス
 class GoodsMvtGetItemsController
入出庫伝票一覧取得コントローラクラス
機能は以下の通り
入出庫伝票の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BatchRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス BatchRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa
すべての実装インタフェース:
Serializable
public class BatchRa
extends Object
implements Serializable

ロットの範囲情報クラス
機能は以下の通り

  • ロットの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BatchRa()
ロットの範囲情報を作成します。
BatchRa(int index)
ロットの範囲情報を作成します。
メソッドの概要
String | getHigh() ロット番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() ロット番号を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) ロット番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) ロット番号を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchRa

public BatchRa()
ロットの範囲情報を作成します。

BatchRa

public BatchRa(int index)
ロットの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
ロット番号を取得します。

戻り値:
low ロット番号

getHigh

public String getHigh()
ロット番号を取得します。

戻り値:
high ロット番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
ロット番号を設定します。

パラメータ:
low - ロット番号

setHigh

public void setHigh(String high)
ロット番号を設定します。

パラメータ:
high - ロット番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtGetItems (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス GoodsMvtGetItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtGetItemsController
public class GoodsMvtGetItems
extends ReferenceController
implements Serializable

出庫確認一覧照会情報クラス
機能は以下の通り

  • 出庫確認一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。
メソッドの概要
List | getBatchRaList() ロットの範囲を取得します。
List | getGoodsMvtHeaderList() リターン構造、入出庫伝票ヘッダを取得します。
List | getGoodsMvtItemsList() リターン構造、入出庫伝票明細を取得します。
List | getMaterialRaList() 品目コードの範囲を取得します。
List | getMoveTypeRaList() 移動タイプの範囲を取得します。
List | getPlantRaList() プラントの範囲を取得します。
List | getPstngDateRaList() 登録日付の範囲を取得します。
List | getSpecStockRaList() 特殊在庫区分の範囲を取得します。
List | getStgeLocRaList() 保管場所の範囲を取得します。
List | getTrEvTypeRaList() トランザクション/イベントタイプの範囲を取得します。
List | getUserNameRaList() ユーザ名の範囲を取得します。
List | getVendorRaList() 仕入先の範囲を取得します。
void | setBatchRaList(List batchRaList) ロットの範囲を設定します。
void | setExportParam(BapiController bapiController) 返却された入出庫伝票照会情報をセットします。
void | setGoodsMvtHeaderList(List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダを設定します。
void | setGoodsMvtItemsList(List goodsMvtItemsList) リターン構造、入出庫伝票明細を設定します。
void | setImportParam(BapiController bapiController) 入出庫伝票一覧照会する情報をセットします。
void | setMaterialRaList(List materialRaList) 品目コードの範囲を設定します。
void | setMoveTypeRaList(List moveTypeRaList) 移動タイプの範囲を設定します。
void | setPlantRaList(List plantRaList) プラントの範囲を設定します。
void | setPstngDateRaList(List pstngDateRaList) 登録日付の範囲を設定します。
void | setSpecStockRaList(List specStockRaList) 特殊在庫区分の範囲を設定します。
void | setStgeLocRaList(List stgeLocRaList) 保管場所の範囲を設定します。
void | setTrEvTypeRaList(List trEvTypeRaList) トランザクション/イベントタイプの範囲を設定します。
void | setUserNameRaList(List userNameRaList) ユーザ名の範囲を設定します。
void | setVendorRaList(List vendorRaList) 仕入先の範囲を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtGetItems

public GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
入出庫伝票一覧照会する情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された入出庫伝票照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getVendorRaList

public List getVendorRaList()
仕入先の範囲を取得します。

戻り値:
vendorRaList 仕入先の範囲

getUserNameRaList

public List getUserNameRaList()
ユーザ名の範囲を取得します。

戻り値:
userNameRaList ユーザ名の範囲

getTrEvTypeRaList

public List getTrEvTypeRaList()
トランザクション/イベントタイプの範囲を取得します。

戻り値:
trEvTypeRaList トランザクション/イベントタイプの範囲

getStgeLocRaList

public List getStgeLocRaList()
保管場所の範囲を取得します。

戻り値:
stgeLocRaList 保管場所の範囲

getSpecStockRaList

public List getSpecStockRaList()
特殊在庫区分の範囲を取得します。

戻り値:
specStockRaList 特殊在庫区分の範囲

getPstngDateRaList

public List getPstngDateRaList()
登録日付の範囲を取得します。

戻り値:
pstngDateRaList 登録日付の範囲

getPlantRaList

public List getPlantRaList()
プラントの範囲を取得します。

戻り値:
plantRaList プラントの範囲

getMoveTypeRaList

public List getMoveTypeRaList()
移動タイプの範囲を取得します。

戻り値:
moveTypeRaList 移動タイプの範囲

getMaterialRaList

public List getMaterialRaList()
品目コードの範囲を取得します。

戻り値:
materialRaList 品目コードの範囲

getGoodsMvtItemsList

public List getGoodsMvtItemsList()
リターン構造、入出庫伝票明細を取得します。

戻り値:
goodsMvtItemsList リターン構造、入出庫伝票明細

getGoodsMvtHeaderList

public List getGoodsMvtHeaderList()
リターン構造、入出庫伝票ヘッダを取得します。

戻り値:
goodsMvtHeaderList リターン構造、入出庫伝票ヘッダ

getBatchRaList

public List getBatchRaList()
ロットの範囲を取得します。

戻り値:
batchRaList ロットの範囲

setVendorRaList

public void setVendorRaList(List vendorRaList)
仕入先の範囲を設定します。

パラメータ:
vendorRaList - 仕入先の範囲

setUserNameRaList

public void setUserNameRaList(List userNameRaList)
ユーザ名の範囲を設定します。

パラメータ:
userNameRaList - ユーザ名の範囲

setTrEvTypeRaList

public void setTrEvTypeRaList(List trEvTypeRaList)
トランザクション/イベントタイプの範囲を設定します。

パラメータ:
trEvTypeRaList - トランザクション/イベントタイプの範囲

setStgeLocRaList

public void setStgeLocRaList(List stgeLocRaList)
保管場所の範囲を設定します。

パラメータ:
stgeLocRaList - 保管場所の範囲

setSpecStockRaList

public void setSpecStockRaList(List specStockRaList)
特殊在庫区分の範囲を設定します。

パラメータ:
specStockRaList - 特殊在庫区分の範囲

setPstngDateRaList

public void setPstngDateRaList(List pstngDateRaList)
登録日付の範囲を設定します。

パラメータ:
pstngDateRaList - 登録日付の範囲

setPlantRaList

public void setPlantRaList(List plantRaList)
プラントの範囲を設定します。

パラメータ:
plantRaList - プラントの範囲

setMoveTypeRaList

public void setMoveTypeRaList(List moveTypeRaList)
移動タイプの範囲を設定します。

パラメータ:
moveTypeRaList - 移動タイプの範囲

setMaterialRaList

public void setMaterialRaList(List materialRaList)
品目コードの範囲を設定します。

パラメータ:
materialRaList - 品目コードの範囲

setGoodsMvtItemsList

public void setGoodsMvtItemsList(List goodsMvtItemsList)
リターン構造、入出庫伝票明細を設定します。

パラメータ:
goodsMvtItemsList - リターン構造、入出庫伝票明細

setGoodsMvtHeaderList

public void setGoodsMvtHeaderList(List goodsMvtHeaderList)
リターン構造、入出庫伝票ヘッダを設定します。

パラメータ:
goodsMvtHeaderList - リターン構造、入出庫伝票ヘッダ

setBatchRaList

public void setBatchRaList(List batchRaList)
ロットの範囲を設定します。

パラメータ:
batchRaList - ロットの範囲

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス MaterialRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa
すべての実装インタフェース:
Serializable
public class MaterialRa
extends Object
implements Serializable

品目コードの範囲情報クラス
機能は以下の通り

  • 品目コードの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialRa()
品目コードの範囲情報を作成します。
MaterialRa(int index)
品目コードの範囲情報を作成します。
メソッドの概要
String | getHigh() 品目コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 品目コードを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 品目コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 品目コードを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialRa

public MaterialRa()
品目コードの範囲情報を作成します。

MaterialRa

public MaterialRa(int index)
品目コードの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
品目コードを取得します。

戻り値:
low 品目コード

getHigh

public String getHigh()
品目コードを取得します。

戻り値:
high 品目コード

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
品目コードを設定します。

パラメータ:
low - 品目コード

setHigh

public void setHigh(String high)
品目コードを設定します。

パラメータ:
high - 品目コード

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MoveTypeRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス MoveTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa
すべての実装インタフェース:
Serializable
public class MoveTypeRa
extends Object
implements Serializable

移動タイプの範囲情報クラス
機能は以下の通り

  • 移動タイプの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MoveTypeRa()
移動タイプの範囲情報を作成します。
MoveTypeRa(int index)
移動タイプの範囲情報を作成します。
メソッドの概要
String | getHigh() 移動タイプ (在庫管理)を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 移動タイプ (在庫管理)を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 移動タイプ (在庫管理)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 移動タイプ (在庫管理)を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MoveTypeRa

public MoveTypeRa()
移動タイプの範囲情報を作成します。

MoveTypeRa

public MoveTypeRa(int index)
移動タイプの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
移動タイプ (在庫管理)を取得します。

戻り値:
low 移動タイプ (在庫管理)

getHigh

public String getHigh()
移動タイプ (在庫管理)を取得します。

戻り値:
high 移動タイプ (在庫管理)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
移動タイプ (在庫管理)を設定します。

パラメータ:
low - 移動タイプ (在庫管理)

setHigh

public void setHigh(String high)
移動タイプ (在庫管理)を設定します。

パラメータ:
high - 移動タイプ (在庫管理)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス
BatchRa
GoodsMvtGetItems
MaterialRa
MoveTypeRa
ParamBatchRa
ParamMaterialRa
ParamMoveTypeRa
ParamPlantRa
ParamPstngDateRa
ParamSpecStockRa
ParamStgeLocRa
ParamTrEvTypeRa
ParamUserNameRa
ParamVendorRa
PlantRa
PstngDateRa
SpecStockRa
StgeLocRa
TrEvTypeRa
UserNameRa
VendorRa


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

クラスの概要
BatchRa | ロットの範囲情報クラス 機能は以下の通り ロットの範囲情報を保持します。
GoodsMvtGetItems | 出庫確認一覧照会情報クラス 機能は以下の通り 出庫確認一覧照会情報を保持します。
MaterialRa | 品目コードの範囲情報クラス 機能は以下の通り 品目コードの範囲情報を保持します。
MoveTypeRa | 移動タイプの範囲情報クラス 機能は以下の通り 移動タイプの範囲情報を保持します。
ParamBatchRa | ロットの範囲パラメータ設定クラス 機能は以下の通り ロットの範囲のパラメータを設定します。
ParamMaterialRa | 品目コードの範囲パラメータ設定クラス 機能は以下の通り 品目コードの範囲のパラメータを設定します。
ParamMoveTypeRa | 移動タイプの範囲パラメータ設定クラス 機能は以下の通り 移動タイプの範囲のパラメータを設定します。
ParamPlantRa | プラントの範囲パラメータ設定クラス 機能は以下の通り プラントの範囲のパラメータを設定します。
ParamPstngDateRa | 登録日付の範囲パラメータ設定クラス 機能は以下の通り 登録日付の範囲のパラメータを設定します。
ParamSpecStockRa | 特殊在庫区分の範囲パラメータ設定クラス 機能は以下の通り 特殊在庫区分の範囲のパラメータを設定します。
ParamStgeLocRa | 保管場所の範囲パラメータ設定クラス 機能は以下の通り 保管場所の範囲のパラメータを設定します。
ParamTrEvTypeRa | トランザクション/イベントタイプの範囲パラメータ設定クラス。
ParamUserNameRa | ユーザ名の範囲パラメータ設定クラス 機能は以下の通り ユーザ名の範囲のパラメータを設定します。
ParamVendorRa | 仕入先の範囲パラメータ設定クラス 機能は以下の通り 仕入先の範囲のパラメータを設定します。
PlantRa | プラントの範囲情報クラス 機能は以下の通り プラントの範囲情報を保持します。
PstngDateRa | 登録日付の範囲情報クラス 機能は以下の通り 登録日付の範囲情報を保持します。
SpecStockRa | 特殊在庫区分の範囲情報クラス 機能は以下の通り 特殊在庫区分の範囲情報を保持します。
StgeLocRa | 保管場所の範囲情報クラス 機能は以下の通り 保管場所の範囲情報を保持します。
TrEvTypeRa | トランザクション/イベントタイプの範囲情報クラス 機能は以下の通り トランザクション/イベントタイプの範囲情報を保持します。
UserNameRa | ユーザ名の範囲情報クラス 機能は以下の通り ユーザ名の範囲情報を保持します。
VendorRa | 仕入先の範囲情報クラス 機能は以下の通り 仕入先の範囲情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のクラス
GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBatchRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamBatchRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa
すべての実装インタフェース:
Serializable
public final class ParamBatchRa
extends Object
implements Serializable

ロットの範囲パラメータ設定クラス
機能は以下の通り

  • ロットの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List batchRaList) table(Export)情報からロットの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List batchRaList) ロットの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List batchRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ロットの範囲の値をセットします。

パラメータ:
bapiController - BapiController
batchRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List batchRaList)
                           throws SAPGeneralSystemException
table(Export)情報からロットの範囲の値をセットします。

パラメータ:
bapiController - BapiController
batchRaList - BatchRa
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamMaterialRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa
すべての実装インタフェース:
Serializable
public final class ParamMaterialRa
extends Object
implements Serializable

品目コードの範囲パラメータ設定クラス
機能は以下の通り

  • 品目コードの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialRaList) table(Export)情報から品目コードの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List materialRaList) 品目コードの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List materialRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
品目コードの範囲の値をセットします。

パラメータ:
bapiController - BapiController
materialRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialRaList)
                           throws SAPGeneralSystemException
table(Export)情報から品目コードの範囲の値をセットします。

パラメータ:
bapiController - BapiController
materialRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMoveTypeRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamMoveTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa
すべての実装インタフェース:
Serializable
public final class ParamMoveTypeRa
extends Object
implements Serializable

移動タイプの範囲パラメータ設定クラス
機能は以下の通り

  • 移動タイプの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List moveTypeRaList) table(Export)情報から移動タイプの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List moveTypeRaList) 移動タイプの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List moveTypeRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
移動タイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
moveTypeRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List moveTypeRaList)
                           throws SAPGeneralSystemException
table(Export)情報から移動タイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
moveTypeRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlantRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamPlantRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa
すべての実装インタフェース:
Serializable
public final class ParamPlantRa
extends Object
implements Serializable

プラントの範囲パラメータ設定クラス
機能は以下の通り

  • プラントの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List plantRaList) table(Export)情報からプラントの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List plantRaList) プラントの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List plantRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
プラントの範囲の値をセットします。

パラメータ:
bapiController - BapiController
plantRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List plantRaList)
                           throws SAPGeneralSystemException
table(Export)情報からプラントの範囲の値をセットします。

パラメータ:
bapiController - BapiController
plantRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPstngDateRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamPstngDateRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa
すべての実装インタフェース:
Serializable
public final class ParamPstngDateRa
extends Object
implements Serializable

登録日付の範囲パラメータ設定クラス
機能は以下の通り

  • 登録日付の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List pstngDateRaList) table(Export)情報から登録日付の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List pstngDateRaList) 登録日付の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List pstngDateRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
登録日付の範囲の値をセットします。

パラメータ:
bapiController - BapiController
pstngDateRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List pstngDateRaList)
                           throws SAPGeneralSystemException
table(Export)情報から登録日付の範囲の値をセットします。

パラメータ:
bapiController - BapiController
pstngDateRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSpecStockRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamSpecStockRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa
すべての実装インタフェース:
Serializable
public final class ParamSpecStockRa
extends Object
implements Serializable

特殊在庫区分の範囲パラメータ設定クラス
機能は以下の通り

  • 特殊在庫区分の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List specStockRaList) table(Export)情報から特殊在庫区分の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List specStockRaList) 特殊在庫区分の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List specStockRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
特殊在庫区分の範囲の値をセットします。

パラメータ:
bapiController - BapiController
specStockRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List specStockRaList)
                           throws SAPGeneralSystemException
table(Export)情報から特殊在庫区分の範囲の値をセットします。

パラメータ:
bapiController - BapiController
specStockRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStgeLocRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamStgeLocRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa
すべての実装インタフェース:
Serializable
public final class ParamStgeLocRa
extends Object
implements Serializable

保管場所の範囲パラメータ設定クラス
機能は以下の通り

  • 保管場所の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeLocRaList) table(Export)情報から保管場所の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List stgeLocRaList) 保管場所の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List stgeLocRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
保管場所の範囲の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeLocRaList)
                           throws SAPGeneralSystemException
table(Export)情報から保管場所の範囲の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTrEvTypeRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamTrEvTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa
すべての実装インタフェース:
Serializable
public final class ParamTrEvTypeRa
extends Object
implements Serializable

トランザクション/イベントタイプの範囲パラメータ設定クラス。
機能は以下の通り。

  • トランザクション/イベントタイプの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List trEvTypeRaList) table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List trEvTypeRaList) ParamTrEvTypeRaの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List trEvTypeRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ParamTrEvTypeRaの値をセットします。

パラメータ:
bapiController - BapiController
trEvTypeRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List trEvTypeRaList)
                           throws SAPGeneralSystemException
table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
trEvTypeRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUserNameRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamUserNameRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa
すべての実装インタフェース:
Serializable
public final class ParamUserNameRa
extends Object
implements Serializable

ユーザ名の範囲パラメータ設定クラス
機能は以下の通り

  • ユーザ名の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List userNameRaList) table(Export)情報からユーザ名の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List userNameRaList) ユーザ名の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List userNameRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ユーザ名の範囲の値をセットします。

パラメータ:
bapiController - BapiController
userNameRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List userNameRaList)
                           throws SAPGeneralSystemException
table(Export)情報からユーザ名の範囲の値をセットします。

パラメータ:
bapiController - BapiController
userNameRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVendorRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamVendorRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa
すべての実装インタフェース:
Serializable
public final class ParamVendorRa
extends Object
implements Serializable

仕入先の範囲パラメータ設定クラス
機能は以下の通り

  • 仕入先の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List vendorRaList) table(Export)情報から仕入先の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List vendorRaList) 仕入先の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List vendorRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
仕入先の範囲の値をセットします。

パラメータ:
bapiController - BapiController
vendorRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List vendorRaList)
                           throws SAPGeneralSystemException
table(Export)情報から仕入先の範囲の値をセットします。

パラメータ:
bapiController - BapiController
vendorRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス PlantRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa
すべての実装インタフェース:
Serializable
public class PlantRa
extends Object
implements Serializable

プラントの範囲情報クラス
機能は以下の通り

  • プラントの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantRa()
プラントの範囲情報を作成します。
PlantRa(int index)
プラントの範囲情報を作成します。
メソッドの概要
String | getHigh() プラントを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() プラントを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) プラントを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) プラントを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantRa

public PlantRa()
プラントの範囲情報を作成します。

PlantRa

public PlantRa(int index)
プラントの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
プラントを取得します。

戻り値:
low プラント

getHigh

public String getHigh()
プラントを取得します。

戻り値:
high プラント

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
プラントを設定します。

パラメータ:
low - プラント

setHigh

public void setHigh(String high)
プラントを設定します。

パラメータ:
high - プラント

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PstngDateRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス PstngDateRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa
すべての実装インタフェース:
Serializable
public class PstngDateRa
extends Object
implements Serializable

登録日付の範囲情報クラス
機能は以下の通り

  • 登録日付の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PstngDateRa()
登録日付の範囲情報を作成します。
PstngDateRa(int index)
登録日付の範囲情報を作成します。
メソッドの概要
String | getHigh() 伝票の転記日付を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 伝票の転記日付を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 伝票の転記日付を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 伝票の転記日付を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PstngDateRa

public PstngDateRa()
登録日付の範囲情報を作成します。

PstngDateRa

public PstngDateRa(int index)
登録日付の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
伝票の転記日付を取得します。

戻り値:
low 伝票の転記日付

getHigh

public String getHigh()
伝票の転記日付を取得します。

戻り値:
high 伝票の転記日付

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
伝票の転記日付を設定します。

パラメータ:
low - 伝票の転記日付

setHigh

public void setHigh(String high)
伝票の転記日付を設定します。

パラメータ:
high - 伝票の転記日付

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SpecStockRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス SpecStockRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa
すべての実装インタフェース:
Serializable
public class SpecStockRa
extends Object
implements Serializable

特殊在庫区分の範囲情報クラス
機能は以下の通り

  • 特殊在庫区分の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SpecStockRa()
特殊在庫区分の範囲情報を作成します。
SpecStockRa(int index)
特殊在庫区分の範囲情報を作成します。
メソッドの概要
String | getHigh() 特殊在庫区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 特殊在庫区分を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 特殊在庫区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 特殊在庫区分を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SpecStockRa

public SpecStockRa()
特殊在庫区分の範囲情報を作成します。

SpecStockRa

public SpecStockRa(int index)
特殊在庫区分の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
特殊在庫区分を取得します。

戻り値:
low 特殊在庫区分

getHigh

public String getHigh()
特殊在庫区分を取得します。

戻り値:
high 特殊在庫区分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
特殊在庫区分を設定します。

パラメータ:
low - 特殊在庫区分

setHigh

public void setHigh(String high)
特殊在庫区分を設定します。

パラメータ:
high - 特殊在庫区分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StgeLocRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス StgeLocRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa
すべての実装インタフェース:
Serializable
public class StgeLocRa
extends Object
implements Serializable

保管場所の範囲情報クラス
機能は以下の通り

  • 保管場所の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StgeLocRa()
保管場所の範囲情報を作成します。
StgeLocRa(int index)
保管場所の範囲情報を作成します。
メソッドの概要
String | getHigh() 保管場所を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 保管場所を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 保管場所を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 保管場所を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StgeLocRa

public StgeLocRa()
保管場所の範囲情報を作成します。

StgeLocRa

public StgeLocRa(int index)
保管場所の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
保管場所を取得します。

戻り値:
low 保管場所

getHigh

public String getHigh()
保管場所を取得します。

戻り値:
high 保管場所

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
保管場所を設定します。

パラメータ:
low - 保管場所

setHigh

public void setHigh(String high)
保管場所を設定します。

パラメータ:
high - 保管場所

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrEvTypeRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス TrEvTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa
すべての実装インタフェース:
Serializable
public class TrEvTypeRa
extends Object
implements Serializable

トランザクション/イベントタイプの範囲情報クラス
機能は以下の通り

  • トランザクション/イベントタイプの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TrEvTypeRa()
トランザクション/イベントタイプの範囲情報を作成します。
TrEvTypeRa(int index)
トランザクション/イベントタイプの範囲情報を作成します。
メソッドの概要
String | getHigh() トランザクション/イベントタイプを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() トランザクション/イベントタイプを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) トランザクション/イベントタイプを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) トランザクション/イベントタイプを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TrEvTypeRa

public TrEvTypeRa()
トランザクション/イベントタイプの範囲情報を作成します。

TrEvTypeRa

public TrEvTypeRa(int index)
トランザクション/イベントタイプの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
トランザクション/イベントタイプを取得します。

戻り値:
low トランザクション/イベントタイプ

getHigh

public String getHigh()
トランザクション/イベントタイプを取得します。

戻り値:
high トランザクション/イベントタイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
トランザクション/イベントタイプを設定します。

パラメータ:
low - トランザクション/イベントタイプ

setHigh

public void setHigh(String high)
トランザクション/イベントタイプを設定します。

パラメータ:
high - トランザクション/イベントタイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserNameRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス UserNameRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa
すべての実装インタフェース:
Serializable
public class UserNameRa
extends Object
implements Serializable

ユーザ名の範囲情報クラス
機能は以下の通り

  • ユーザ名の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UserNameRa()
ユーザ名の範囲情報を作成します。
UserNameRa(int index)
ユーザ名の範囲情報を作成します。
メソッドの概要
String | getHigh() ユーザ名を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() ユーザ名を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) ユーザ名を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) ユーザ名を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserNameRa

public UserNameRa()
ユーザ名の範囲情報を作成します。

UserNameRa

public UserNameRa(int index)
ユーザ名の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
ユーザ名を取得します。

戻り値:
low ユーザ名

getHigh

public String getHigh()
ユーザ名を取得します。

戻り値:
high ユーザ名

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
ユーザ名を設定します。

パラメータ:
low - ユーザ名

setHigh

public void setHigh(String high)
ユーザ名を設定します。

パラメータ:
high - ユーザ名

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VendorRa (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス VendorRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa
すべての実装インタフェース:
Serializable
public class VendorRa
extends Object
implements Serializable

仕入先の範囲情報クラス
機能は以下の通り

  • 仕入先の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
VendorRa()
仕入先の範囲情報を作成します。
VendorRa(int index)
仕入先の範囲情報を作成します。
メソッドの概要
String | getHigh() 仕入先勘定コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 仕入先勘定コードを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 仕入先勘定コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 仕入先勘定コードを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

VendorRa

public VendorRa()
仕入先の範囲情報を作成します。

VendorRa

public VendorRa(int index)
仕入先の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
仕入先勘定コードを取得します。

戻り値:
low 仕入先勘定コード

getHigh

public String getHigh()
仕入先勘定コードを取得します。

戻り値:
high 仕入先勘定コード

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
仕入先勘定コードを設定します。

パラメータ:
low - 仕入先勘定コード

setHigh

public void setHigh(String high)
仕入先勘定コードを設定します。

パラメータ:
high - 仕入先勘定コード

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability の使用

MaterialAvailability を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialAvailability の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialAvailability のサブクラス
 class MaterialAvailabilityController
品目在庫確認コントローラクラス
機能は以下の通り
在庫情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MaterialAvailability (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス MaterialAvailability

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialAvailabilityController
public class MaterialAvailability
extends ReferenceController
implements Serializable

品目在庫確認情報クラス
機能は以下の通り

  • 品目在庫確認情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。
メソッドの概要
String | getAvQtyPlt() プラントレベル利用可能数量を取得します。
String | getBatch() ロットを取得します。
String | getCheckRule() 確認規則を取得します。
String | getCustomer() 得意先コードを取得します。
String | getDecForRounding() 小数点位置 (その位置まで丸める)を取得します。
String | getDecForRoundingX() 関連ユーザデータ項目の更新情報を取得します。
String | getDialogflag() 区分 (X = 利用不可 /N = 確認なし)を取得します。
String | getDocNumber() 伝票番号を取得します。
String | getEndleadtme() 補充リードタイムの終了日付を取得します。
String | getItmNumber() 明細番号を取得します。
String | getMaterial() 品目コードを取得します。
MaterialEvg | getMaterialEvg() 品目コード(長)を取得します。
String | getPlant() プラントを取得します。
String | getReadAtpLock() 管理区分:利用可能在庫確認を取得します。
String | getReadAtpLockX() 関連ユーザデータ項目の更新情報を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStockInd() 特殊在庫区分を取得します。
String | getUnit() 表示数量単位を取得します。
String | getWbsElem() WBS 要素を取得します。
List | getWmdvexList() 出力テーブル (日付および ATP 数量)を取得します。
List | getWmdvsxList() 入力テーブル (日付/数量)を取得します。
void | setAvQtyPlt(String avQtyPlt) プラントレベル利用可能数量を設定します。
void | setBatch(String batch) ロットを設定します。
void | setCheckRule(String checkRule) 確認規則を設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDecForRounding(String decForRounding) 小数点位置 (その位置まで丸める)を設定します。
void | setDecForRoundingX(String decForRoundingX) 関連ユーザデータ項目の更新情報を設定します。
void | setDialogflag(String dialogflag) 区分 (X = 利用不可 /N = 確認なし)を設定します。
void | setDocNumber(String docNumber) 伝票番号を設定します。
void | setEndleadtme(String endleadtme) 補充リードタイムの終了日付を設定します。
void | setExportParam(BapiController bapiController) 取得した品目在庫確認情報をセットします。
void | setImportParam(BapiController bapiController) 品目在庫確認情報を取得する為の条件をセットします。
void | setItmNumber(String itmNumber) 明細番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialEvg(MaterialEvg materialEvg) 品目コード(長)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setReadAtpLock(String readAtpLock) 管理区分:利用可能在庫確認を設定します。
void | setReadAtpLockX(String readAtpLockX) 関連ユーザデータ項目の更新情報を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStockInd(String stockInd) 特殊在庫区分を設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWmdvexList(List wmdvexList) 出力テーブル (日付および ATP 数量)を設定します。
void | setWmdvsxList(List wmdvsxList) 入力テーブル (日付/数量)を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialAvailability

public MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getStockInd

public String getStockInd()
特殊在庫区分を取得します。

戻り値:
stockInd 特殊在庫区分

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getItmNumber

public String getItmNumber()
明細番号を取得します。

戻り値:
itmNumber 明細番号

getDocNumber

public String getDocNumber()
伝票番号を取得します。

戻り値:
docNumber 伝票番号

getDecForRoundingX

public String getDecForRoundingX()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
decForRoundingX 関連ユーザデータ項目の更新情報

getDecForRounding

public String getDecForRounding()
小数点位置 (その位置まで丸める)を取得します。

戻り値:
decForRounding 小数点位置 (その位置まで丸める)

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getCheckRule

public String getCheckRule()
確認規則を取得します。

戻り値:
checkRule 確認規則

getBatch

public String getBatch()
ロットを取得します。

戻り値:
batch ロット

getReadAtpLockX

public String getReadAtpLockX()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
readAtpLockX 関連ユーザデータ項目の更新情報

getReadAtpLock

public String getReadAtpLock()
管理区分:利用可能在庫確認を取得します。

戻り値:
readAtpLock 管理区分:利用可能在庫確認

getEndleadtme

public String getEndleadtme()
補充リードタイムの終了日付を取得します。

戻り値:
endleadtme 補充リードタイムの終了日付

getDialogflag

public String getDialogflag()
区分 (X = 利用不可 /N = 確認なし)を取得します。

戻り値:
dialogflag 区分 (X = 利用不可 /N = 確認なし)

getAvQtyPlt

public String getAvQtyPlt()
プラントレベル利用可能数量を取得します。

戻り値:
avQtyPlt プラントレベル利用可能数量

getMaterialEvg

public MaterialEvg getMaterialEvg()
品目コード(長)を取得します。

戻り値:
materialEvg 品目コード(長)

getWmdvexList

public List getWmdvexList()
出力テーブル (日付および ATP 数量)を取得します。

戻り値:
wmdvexList 出力テーブル (日付および ATP 数量)

getWmdvsxList

public List getWmdvsxList()
入力テーブル (日付/数量)を取得します。

戻り値:
wmdvsxList 入力テーブル (日付/数量)

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setStockInd

public void setStockInd(String stockInd)
特殊在庫区分を設定します。

パラメータ:
stockInd - 特殊在庫区分

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setItmNumber

public void setItmNumber(String itmNumber)
明細番号を設定します。

パラメータ:
itmNumber - 明細番号

setDocNumber

public void setDocNumber(String docNumber)
伝票番号を設定します。

パラメータ:
docNumber - 伝票番号

setDecForRoundingX

public void setDecForRoundingX(String decForRoundingX)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
decForRoundingX - 関連ユーザデータ項目の更新情報

setDecForRounding

public void setDecForRounding(String decForRounding)
小数点位置 (その位置まで丸める)を設定します。

パラメータ:
decForRounding - 小数点位置 (その位置まで丸める)

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setCheckRule

public void setCheckRule(String checkRule)
確認規則を設定します。

パラメータ:
checkRule - 確認規則

setBatch

public void setBatch(String batch)
ロットを設定します。

パラメータ:
batch - ロット

setReadAtpLockX

public void setReadAtpLockX(String readAtpLockX)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
readAtpLockX - 関連ユーザデータ項目の更新情報

setReadAtpLock

public void setReadAtpLock(String readAtpLock)
管理区分:利用可能在庫確認を設定します。

パラメータ:
readAtpLock - 管理区分:利用可能在庫確認

setEndleadtme

public void setEndleadtme(String endleadtme)
補充リードタイムの終了日付を設定します。

パラメータ:
endleadtme - 補充リードタイムの終了日付

setDialogflag

public void setDialogflag(String dialogflag)
区分 (X = 利用不可 /N = 確認なし)を設定します。

パラメータ:
dialogflag - 区分 (X = 利用不可 /N = 確認なし)

setAvQtyPlt

public void setAvQtyPlt(String avQtyPlt)
プラントレベル利用可能数量を設定します。

パラメータ:
avQtyPlt - プラントレベル利用可能数量

setMaterialEvg

public void setMaterialEvg(MaterialEvg materialEvg)
品目コード(長)を設定します。

パラメータ:
materialEvg - 品目コード(長)

setWmdvexList

public void setWmdvexList(List wmdvexList)
出力テーブル (日付および ATP 数量)を設定します。

パラメータ:
wmdvexList - 出力テーブル (日付および ATP 数量)

setWmdvsxList

public void setWmdvsxList(List wmdvsxList)
入力テーブル (日付/数量)を設定します。

パラメータ:
wmdvsxList - 入力テーブル (日付/数量)

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目在庫確認情報を取得する為の条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用アプリケーション例外
SAPGeneralAppException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
取得した品目在庫確認情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス
MaterialAvailability
ParamWmdvex
ParamWmdvsx
Wmdvex
Wmdvsx


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

クラスの概要
MaterialAvailability | 品目在庫確認情報クラス 機能は以下の通り 品目在庫確認情報を保持します。
ParamWmdvex | 出力テーブル (日付および ATP 数量)パラメータ設定クラス 機能は以下の通り 出力テーブル (日付および ATP 数量)のパラメータを設定します。
ParamWmdvsx | 入力テーブル (日付/数量)パラメータ設定クラス 機能は以下の通り 入力テーブル (日付/数量)のパラメータを設定します。
Wmdvex | 出力テーブル (日付および ATP 数量)情報クラス 機能は以下の通り 出力テーブル (日付および ATP 数量)情報を保持します。
Wmdvsx | 入力テーブル (日付/数量)情報クラス 機能は以下の通り 入力テーブル (日付/数量)情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のクラス
MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamWmdvex (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス ParamWmdvex

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex
すべての実装インタフェース:
Serializable
public final class ParamWmdvex
extends Object
implements Serializable

出力テーブル (日付および ATP 数量)パラメータ設定クラス
機能は以下の通り

  • 出力テーブル (日付および ATP 数量)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List wmdvexList) table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
static void | setImportParam(BapiController bapiController, List wmdvexList) 出力テーブル (日付および ATP 数量)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List wmdvexList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
出力テーブル (日付および ATP 数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvexList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List wmdvexList)
                           throws SAPGeneralSystemException
table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvexList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamWmdvsx (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス ParamWmdvsx

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx
すべての実装インタフェース:
Serializable
public final class ParamWmdvsx
extends Object
implements Serializable

入力テーブル (日付/数量)パラメータ設定クラス
機能は以下の通り

  • 入力テーブル (日付/数量)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List wmdvsxList) table(Export)情報から入力テーブル (日付/数量)の値をセットします。
static void | setImportParam(BapiController bapiController, List wmdvsxList) 入力テーブル (日付/数量)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List wmdvsxList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入力テーブル (日付/数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvsxList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List wmdvsxList)
                           throws SAPGeneralSystemException
table(Export)情報から入力テーブル (日付/数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvsxList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Wmdvex (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス Wmdvex

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex
すべての実装インタフェース:
Serializable
public class Wmdvex
extends Object
implements Serializable

出力テーブル (日付および ATP 数量)情報クラス
機能は以下の通り

  • 出力テーブル (日付および ATP 数量)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Wmdvex()
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvex(int index)
出力テーブル (日付および ATP 数量)情報を作成します。
メソッドの概要
String | getBdcnt() 5 文字数値 NUMCを取得します。
String | getComDate() 確認日を取得します。
String | getComQty() 確認数量を取得します。
int | getIndex() レコード番号を取得します｡
String | getReqDate() 所要日付を取得します。
String | getReqQty() 利用可能在庫確認の所要量を取得します。
void | setBdcnt(String bdcnt) 5 文字数値 NUMCを設定します。
void | setComDate(String comDate) 確認日を設定します。
void | setComQty(String comQty) 確認数量を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setReqDate(String reqDate) 所要日付を設定します。
void | setReqQty(String reqQty) 利用可能在庫確認の所要量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Wmdvex

public Wmdvex()
出力テーブル (日付および ATP 数量)情報を作成します。

Wmdvex

public Wmdvex(int index)
出力テーブル (日付および ATP 数量)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getBdcnt

public String getBdcnt()
5 文字数値 NUMCを取得します。

戻り値:
bdcnt 5 文字数値 NUMC

getReqDate

public String getReqDate()
所要日付を取得します。

戻り値:
reqDate 所要日付

getReqQty

public String getReqQty()
利用可能在庫確認の所要量を取得します。

戻り値:
reqQty 利用可能在庫確認の所要量

getComDate

public String getComDate()
確認日を取得します。

戻り値:
comDate 確認日

getComQty

public String getComQty()
確認数量を取得します。

戻り値:
comQty 確認数量

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setBdcnt

public void setBdcnt(String bdcnt)
5 文字数値 NUMCを設定します。

パラメータ:
bdcnt - 5 文字数値 NUMC

setReqDate

public void setReqDate(String reqDate)
所要日付を設定します。

パラメータ:
reqDate - 所要日付

setReqQty

public void setReqQty(String reqQty)
利用可能在庫確認の所要量を設定します。

パラメータ:
reqQty - 利用可能在庫確認の所要量

setComDate

public void setComDate(String comDate)
確認日を設定します。

パラメータ:
comDate - 確認日

setComQty

public void setComQty(String comQty)
確認数量を設定します。

パラメータ:
comQty - 確認数量

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Wmdvsx (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス Wmdvsx

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx
すべての実装インタフェース:
Serializable
public class Wmdvsx
extends Object
implements Serializable

入力テーブル (日付/数量)情報クラス
機能は以下の通り

  • 入力テーブル (日付/数量)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Wmdvsx()
入力テーブル (日付/数量)情報を作成します。
Wmdvsx(int index)
入力テーブル (日付/数量)情報を作成します。
メソッドの概要
String | getDelkz() MRP 要素区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getReqDate() 所要日付を取得します。
String | getReqQty() 所要量を取得します。
String | getYline() 内部テ－ブル処理の行索引を取得します。
void | setDelkz(String delkz) MRP 要素区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setReqDate(String reqDate) 所要日付を設定します。
void | setReqQty(String reqQty) 所要量を設定します。
void | setYline(String yline) 内部テ－ブル処理の行索引を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Wmdvsx

public Wmdvsx()
入力テーブル (日付/数量)情報を作成します。

Wmdvsx

public Wmdvsx(int index)
入力テーブル (日付/数量)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getReqDate

public String getReqDate()
所要日付を取得します。

戻り値:
reqDate 所要日付

getReqQty

public String getReqQty()
所要量を取得します。

戻り値:
reqQty 所要量

getDelkz

public String getDelkz()
MRP 要素区分を取得します。

戻り値:
delkz MRP 要素区分

getYline

public String getYline()
内部テ－ブル処理の行索引を取得します。

戻り値:
yline 内部テ－ブル処理の行索引

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setReqDate

public void setReqDate(String reqDate)
所要日付を設定します。

パラメータ:
reqDate - 所要日付

setReqQty

public void setReqQty(String reqQty)
所要量を設定します。

パラメータ:
reqQty - 所要量

setDelkz

public void setDelkz(String delkz)
MRP 要素区分を設定します。

パラメータ:
delkz - MRP 要素区分

setYline

public void setYline(String yline)
内部テ－ブル処理の行索引を設定します。

パラメータ:
yline - 内部テ－ブル処理の行索引

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut の使用

ExtensionOut を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionOut の使用

ExtensionOut を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionOut MaterialGetAllController.getExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers の使用

InternationArticleNumbers を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での InternationArticleNumbers の使用

InternationArticleNumbers を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 InternationArticleNumbers MaterialGetAllController.getInternationArticleNumbers(int index)
EANオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData の使用

LifoValuationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での LifoValuationData の使用

LifoValuationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 LifoValuationData MaterialGetAll.getLifoValuationData()
LIFO 関連品目データを取得します。

LifoValuationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setLifoValuationData(LifoValuationData lifoValuationData)
LIFO 関連品目データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll の使用

MaterialGetAll を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetAll の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetAll のサブクラス
 class MaterialGetAllController
品目マスタ照会コントローラクラス
機能は以下の通り
品目マスタの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText の使用

MaterialText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialText の使用

MaterialText を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 MaterialText MaterialGetAllController.getMaterialText(int index)
テキスト (長)オブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData の使用

ProductionResourceToolData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ProductionResourceToolData の使用

ProductionResourceToolData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ProductionResourceToolData MaterialGetAll.getProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

ProductionResourceToolData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setProductionResourceToolData(ProductionResourceToolData productionResourceToolData)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtensionOut (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス ExtensionOut

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut
すべての実装インタフェース:
Serializable
public class ExtensionOut
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionOut()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionOut

public ExtensionOut()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

ExtensionOut

public ExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart4 - BAPI 拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


InternationArticleNumbers (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス InternationArticleNumbers

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers
すべての実装インタフェース:
Serializable
public class InternationArticleNumbers
extends Object
implements Serializable

EAN情報クラス
機能は以下の通り

  • EAN情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
InternationArticleNumbers()
EAN情報を作成します。
InternationArticleNumbers(int index)
EAN情報を作成します。
メソッドの概要
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
int | getIndex() レコード番号を取得します｡
String | getMainEan() 区分: 主要 EANを取得します。
String | getUnit() 表示数量単位を取得します。
String | getUnitIso() ISO コードでの表示数量単位を取得します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMainEan(String mainEan) 区分: 主要 EANを設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setUnitIso(String unitIso) ISO コードでの表示数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternationArticleNumbers

public InternationArticleNumbers()
EAN情報を作成します。

InternationArticleNumbers

public InternationArticleNumbers(int index)
EAN情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getUnitIso

public String getUnitIso()
ISO コードでの表示数量単位を取得します。

戻り値:
unitIso ISO コードでの表示数量単位

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getMainEan

public String getMainEan()
区分: 主要 EANを取得します。

戻り値:
mainEan 区分: 主要 EAN

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setUnitIso

public void setUnitIso(String unitIso)
ISO コードでの表示数量単位を設定します。

パラメータ:
unitIso - ISO コードでの表示数量単位

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setMainEan

public void setMainEan(String mainEan)
区分: 主要 EANを設定します。

パラメータ:
mainEan - 区分: 主要 EAN

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LifoValuationData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス LifoValuationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData
すべての実装インタフェース:
Serializable
public class LifoValuationData
extends Object
implements Serializable

LIFO 関連品目データ情報クラス
機能は以下の通り

  • LIFO 関連品目データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
LifoValuationData()
LIFO 関連品目データ情報を作成します。
メソッドの概要
String | getLifoValuationLevel() LIFO 評価レベルを取得します。
String | getPoolnumber() LIFO 評価でのプール番号を取得します。
void | setLifoValuationLevel(String lifoValuationLevel) LIFO 評価レベルを設定します。
void | setPoolnumber(String poolnumber) LIFO 評価でのプール番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LifoValuationData

public LifoValuationData()
LIFO 関連品目データ情報を作成します。

メソッドの詳細

getLifoValuationLevel

public String getLifoValuationLevel()
LIFO 評価レベルを取得します。

戻り値:
lifoValuationLevel LIFO 評価レベル

getPoolnumber

public String getPoolnumber()
LIFO 評価でのプール番号を取得します。

戻り値:
poolnumber LIFO 評価でのプール番号

setLifoValuationLevel

public void setLifoValuationLevel(String lifoValuationLevel)
LIFO 評価レベルを設定します。

パラメータ:
lifoValuationLevel - LIFO 評価レベル

setPoolnumber

public void setPoolnumber(String poolnumber)
LIFO 評価でのプール番号を設定します。

パラメータ:
poolnumber - LIFO 評価でのプール番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetAll (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス MaterialGetAll

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialGetAllController
public class MaterialGetAll
extends ReferenceController
implements Serializable

品目マスタ照会情報クラス
機能は以下の通り

  • 品目マスタ照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。
MaterialGetAll(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
品目マスタ照会情報を作成します。
メソッドの概要
ClientData | getClientData() 品目データ (クライアントレベル)を取得します。
String | getCompanycode() 会社コードを取得します。
String | getDistributionchannel() 流通チャネルを取得します。
List | getExtensionOutList() BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
ForecastParameters | getForecastParameters() 予測パラメータを取得します。
List | getInternationArticleNumbersList() EANを取得します。
LifoValuationData | getLifoValuationData() LIFO 関連品目データを取得します。
String | getLifovaluationlevel() LIFO 評価レベルを取得します。
String | getMaterial() 品目コードを取得します。
List | getMaterialDescriptionList() 品目テキストを取得します。
MaterialEvg | getMaterialEvg() 品目コード(長)を取得します。
List | getMaterialTextList() テキスト (長)を取得します。
PlanningData | getPlanningData() 品目マスタ/製品グループの変更伝票構造を取得します。
String | getPlant() プラントを取得します。
PlantData | getPlantData() 品目データ (プラントレベル)を取得します。
ProductionResourceToolData | getProductionResourceToolData() 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
SalesData | getSalesData() 販売データを取得します。
String | getSalesorganisation() 販売組織を取得します。
String | getStoragelocation() 保管場所を取得します。
StorageLocationData | getStorageLocationData() 品目データ (保管場所レベル)を取得します。
String | getStoragetype() 保管域タイプを取得します。
StorageTypeData | getStorageTypeData() 保管域タイプデータを取得します。
List | getTaxClassificationsList() 制御デ－タを取得します。
List | getUnitSofmeasureList() 数量単位を取得します。
String | getValuationarea() 評価レベルを取得します。
ValuationData | getValuationData() 評価データを取得します。
String | getValuationtype() 評価タイプを取得します。
String | getWarehousenumber() 倉庫番号/複合倉庫を取得します。
WarehouseNumberData | getWarehouseNumberData() 倉庫番号データを取得します。
void | initMaterialGetAll() 品目マスタ照会情報を作成します。
void | setClientData(ClientData clientData) 品目データ (クライアントレベル)を設定します。
void | setCompanycode(String companycode) 会社コードを設定します。
void | setDistributionchannel(String distributionchannel) 流通チャネルを設定します。
void | setExpClientData(BapiController bapiController) structure(Export)情報から品目データ (クライアントレベル) を設定します。
void | setExpExtensionOut(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。
void | setExpForecastParameters(BapiController bapiController) structure(Export)情報から予測データを設定します。
void | setExpInternationArticleNumbers(BapiController bapiController) table(Export)情報からEANを設定します。
void | setExpLifoValuationData(BapiController bapiController) structure(Export)情報からLIFO 関連品目データを設定します。
void | setExpMaterialDescription(BapiController bapiController) table(Export)情報から品目テキストを設定します。
void | setExpMaterialText(BapiController bapiController) table(Export)情報からテキスト (長) を設定します。
void | setExportParam(BapiController bapiController) 返却された品目マスタ照会情報をセットします。
void | setExpPlanningData(BapiController bapiController) structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
void | setExpPlantData(BapiController bapiController) structure(Export)情報から品目データ (プラントレベル) を設定します。
void | setExpProductionResourceToolData(BapiController bapiController) structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setExpSalesData(BapiController bapiController) structure(Export)情報から販売データを設定します。
void | setExpStorageLocationData(BapiController bapiController) structure(Export)情報から品目データ (保管場所レベル)を設定します。
void | setExpStorageTypeData(BapiController bapiController) structure(Export)情報から保管域タイプデータを設定します。
void | setExpTaxClassifications(BapiController bapiController) table(Export)情報から制御データを設定します。
void | setExpUnitSofmeasure(BapiController bapiController) table(Export)情報から数量単位を設定します。
void | setExpValuationData(BapiController bapiController) structure(Export)情報から評価データを設定します。
void | setExpWarehouseNumberData(BapiController bapiController) structure(Export)情報から倉庫番号データを設定します。
void | setExtensionOutList(List extensionOutList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
void | setForecastParameters(ForecastParameters forecastParameters) 予測パラメータを設定します。
void | setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
void | setImpInternationArticleNumbers(BapiController bapiController) EANからインポート情報を設定します。
void | setImpMaterialDescription(BapiController bapiController) 品目テキストからインポート情報を設定します。
void | setImpMaterialText(BapiController bapiController) テキスト (長) からインポート情報を設定します。
void | setImportParam(BapiController bapiController) 品目マスタ照会条件ををセットします。
void | setImpTaxClassifications(BapiController bapiController) 制御データからインポート情報を設定します。
void | setImpUnitSofmeasure(BapiController bapiController) 数量単位からインポート情報を設定します。
void | setInternationArticleNumbersList(List internationArticleNumbersList) EANを設定します。
void | setLifoValuationData(LifoValuationData lifoValuationData) LIFO 関連品目データを設定します。
void | setLifovaluationlevel(String lifovaluationlevel) LIFO 評価レベルを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialDescriptionList(List materialDescriptionList) 品目テキストを設定します。
void | setMaterialEvg(MaterialEvg materialEvg) 品目コード(長)を設定します。
void | setMaterialTextList(List materialTextList) テキスト (長)を設定します。
void | setPlanningData(PlanningData planningData) 品目マスタ/製品グループの変更伝票構造を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlantData(PlantData plantData) 品目データ (プラントレベル)を設定します。
void | setProductionResourceToolData(ProductionResourceToolData productionResourceToolData) 品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setSalesData(SalesData salesData) 販売データを設定します。
void | setSalesorganisation(String salesorganisation) 販売組織を設定します。
void | setStoragelocation(String storagelocation) 保管場所を設定します。
void | setStorageLocationData(StorageLocationData storageLocationData) 品目データ (保管場所レベル)を設定します。
void | setStoragetype(String storagetype) 保管域タイプを設定します。
void | setStorageTypeData(StorageTypeData storageTypeData) 保管域タイプデータを設定します。
void | setTaxClassificationsList(List taxClassificationsList) 制御デ－タを設定します。
void | setUnitSofmeasureList(List unitSofmeasureList) 数量単位を設定します。
void | setValuationarea(String valuationarea) 評価レベルを設定します。
void | setValuationData(ValuationData valuationData) 評価データを設定します。
void | setValuationtype(String valuationtype) 評価タイプを設定します。
void | setWarehousenumber(String warehousenumber) 倉庫番号/複合倉庫を設定します。
void | setWarehouseNumberData(WarehouseNumberData warehouseNumberData) 倉庫番号データを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetAll

public MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

MaterialGetAll

public MaterialGetAll(String material,
                      String companyCode,
                      String plant,
                      String storageLocation,
                      String salesOrganisation,
                      String distributionChannel,
                      SapClient sapClient)
品目マスタ照会情報を作成します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル
sapClient - SAPクライアント
メソッドの詳細

initMaterialGetAll

public void initMaterialGetAll()
品目マスタ照会情報を作成します。

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目マスタ照会条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された品目マスタ照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setImpMaterialDescription

public void setImpMaterialDescription(BapiController bapiController)
                               throws SAPGeneralSystemException,
                                      SAPGeneralAppException
品目テキストからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpUnitSofmeasure

public void setImpUnitSofmeasure(BapiController bapiController)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
数量単位からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpInternationArticleNumbers

public void setImpInternationArticleNumbers(BapiController bapiController)
                                     throws SAPGeneralSystemException,
                                            SAPGeneralAppException
EANからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpMaterialText

public void setImpMaterialText(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
テキスト (長) からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpTaxClassifications

public void setImpTaxClassifications(BapiController bapiController)
                              throws SAPGeneralSystemException,
                                     SAPGeneralAppException
制御データからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpExtensionOut

public void setImpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExpClientData

public void setExpClientData(BapiController bapiController)
                      throws SAPGeneralSystemException
structure(Export)情報から品目データ (クライアントレベル) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpPlantData

public void setExpPlantData(BapiController bapiController)
                     throws SAPGeneralSystemException
structure(Export)情報から品目データ (プラントレベル) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpForecastParameters

public void setExpForecastParameters(BapiController bapiController)
                              throws SAPGeneralSystemException
structure(Export)情報から予測データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpPlanningData

public void setExpPlanningData(BapiController bapiController)
                        throws SAPGeneralSystemException
structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpStorageLocationData

public void setExpStorageLocationData(BapiController bapiController)
                               throws SAPGeneralSystemException
structure(Export)情報から品目データ (保管場所レベル)を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpValuationData

public void setExpValuationData(BapiController bapiController)
                         throws SAPGeneralSystemException
structure(Export)情報から評価データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpWarehouseNumberData

public void setExpWarehouseNumberData(BapiController bapiController)
                               throws SAPGeneralSystemException
structure(Export)情報から倉庫番号データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpSalesData

public void setExpSalesData(BapiController bapiController)
                     throws SAPGeneralSystemException
structure(Export)情報から販売データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpStorageTypeData

public void setExpStorageTypeData(BapiController bapiController)
                           throws SAPGeneralSystemException
structure(Export)情報から保管域タイプデータを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpProductionResourceToolData

public void setExpProductionResourceToolData(BapiController bapiController)
                                      throws SAPGeneralSystemException
structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpLifoValuationData

public void setExpLifoValuationData(BapiController bapiController)
                             throws SAPGeneralSystemException
structure(Export)情報からLIFO 関連品目データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpMaterialDescription

public void setExpMaterialDescription(BapiController bapiController)
                               throws SAPGeneralSystemException
table(Export)情報から品目テキストを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpUnitSofmeasure

public void setExpUnitSofmeasure(BapiController bapiController)
                          throws SAPGeneralSystemException
table(Export)情報から数量単位を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpInternationArticleNumbers

public void setExpInternationArticleNumbers(BapiController bapiController)
                                     throws SAPGeneralSystemException
table(Export)情報からEANを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpMaterialText

public void setExpMaterialText(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からテキスト (長) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpTaxClassifications

public void setExpTaxClassifications(BapiController bapiController)
                              throws SAPGeneralSystemException
table(Export)情報から制御データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpExtensionOut

public void setExpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesorganisation

public String getSalesorganisation()
販売組織を取得します。

戻り値:
salesorganisation 販売組織

getStoragelocation

public String getStoragelocation()
保管場所を取得します。

戻り値:
storagelocation 保管場所

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoragetype

public String getStoragetype()
保管域タイプを取得します。

戻り値:
storagetype 保管域タイプ

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getLifovaluationlevel

public String getLifovaluationlevel()
LIFO 評価レベルを取得します。

戻り値:
lifovaluationlevel LIFO 評価レベル

getValuationarea

public String getValuationarea()
評価レベルを取得します。

戻り値:
valuationarea 評価レベル

getValuationtype

public String getValuationtype()
評価タイプを取得します。

戻り値:
valuationtype 評価タイプ

getWarehousenumber

public String getWarehousenumber()
倉庫番号/複合倉庫を取得します。

戻り値:
warehousenumber 倉庫番号/複合倉庫

getDistributionchannel

public String getDistributionchannel()
流通チャネルを取得します。

戻り値:
distributionchannel 流通チャネル

getCompanycode

public String getCompanycode()
会社コードを取得します。

戻り値:
companycode 会社コード

getValuationData

public ValuationData getValuationData()
評価データを取得します。

戻り値:
valuationData 評価データ

getStorageTypeData

public StorageTypeData getStorageTypeData()
保管域タイプデータを取得します。

戻り値:
storageTypeData 保管域タイプデータ

getStorageLocationData

public StorageLocationData getStorageLocationData()
品目データ (保管場所レベル)を取得します。

戻り値:
storageLocationData 品目データ (保管場所レベル)

getWarehouseNumberData

public WarehouseNumberData getWarehouseNumberData()
倉庫番号データを取得します。

戻り値:
warehouseNumberData 倉庫番号データ

getSalesData

public SalesData getSalesData()
販売データを取得します。

戻り値:
salesData 販売データ

getClientData

public ClientData getClientData()
品目データ (クライアントレベル)を取得します。

戻り値:
clientData 品目データ (クライアントレベル)

getProductionResourceToolData

public ProductionResourceToolData getProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

戻り値:
productionResourceToolData 品目マスタの生産資源/治工具 (PRT) 項目

getPlantData

public PlantData getPlantData()
品目データ (プラントレベル)を取得します。

戻り値:
plantData 品目データ (プラントレベル)

getPlanningData

public PlanningData getPlanningData()
品目マスタ/製品グループの変更伝票構造を取得します。

戻り値:
planningData 品目マスタ/製品グループの変更伝票構造

getForecastParameters

public ForecastParameters getForecastParameters()
予測パラメータを取得します。

戻り値:
forecastParameters 予測パラメータ

getLifoValuationData

public LifoValuationData getLifoValuationData()
LIFO 関連品目データを取得します。

戻り値:
lifoValuationData LIFO 関連品目データ

getExtensionOutList

public List getExtensionOutList()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。

戻り値:
extensionOutList BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

getInternationArticleNumbersList

public List getInternationArticleNumbersList()
EANを取得します。

戻り値:
internationArticleNumbersList EAN

getUnitSofmeasureList

public List getUnitSofmeasureList()
数量単位を取得します。

戻り値:
unitSofmeasureList 数量単位

getTaxClassificationsList

public List getTaxClassificationsList()
制御デ－タを取得します。

戻り値:
taxClassificationsList 制御デ－タ

getMaterialDescriptionList

public List getMaterialDescriptionList()
品目テキストを取得します。

戻り値:
materialDescriptionList 品目テキスト

getMaterialTextList

public List getMaterialTextList()
テキスト (長)を取得します。

戻り値:
materialTextList テキスト (長)

getMaterialEvg

public MaterialEvg getMaterialEvg()
品目コード(長)を取得します。

戻り値:
materialEvg 品目コード(長)

setSalesorganisation

public void setSalesorganisation(String salesorganisation)
販売組織を設定します。

パラメータ:
salesorganisation - 販売組織

setStoragelocation

public void setStoragelocation(String storagelocation)
保管場所を設定します。

パラメータ:
storagelocation - 保管場所

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoragetype

public void setStoragetype(String storagetype)
保管域タイプを設定します。

パラメータ:
storagetype - 保管域タイプ

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setLifovaluationlevel

public void setLifovaluationlevel(String lifovaluationlevel)
LIFO 評価レベルを設定します。

パラメータ:
lifovaluationlevel - LIFO 評価レベル

setValuationarea

public void setValuationarea(String valuationarea)
評価レベルを設定します。

パラメータ:
valuationarea - 評価レベル

setValuationtype

public void setValuationtype(String valuationtype)
評価タイプを設定します。

パラメータ:
valuationtype - 評価タイプ

setWarehousenumber

public void setWarehousenumber(String warehousenumber)
倉庫番号/複合倉庫を設定します。

パラメータ:
warehousenumber - 倉庫番号/複合倉庫

setDistributionchannel

public void setDistributionchannel(String distributionchannel)
流通チャネルを設定します。

パラメータ:
distributionchannel - 流通チャネル

setCompanycode

public void setCompanycode(String companycode)
会社コードを設定します。

パラメータ:
companycode - 会社コード

setValuationData

public void setValuationData(ValuationData valuationData)
評価データを設定します。

パラメータ:
valuationData - 評価データ

setStorageTypeData

public void setStorageTypeData(StorageTypeData storageTypeData)
保管域タイプデータを設定します。

パラメータ:
storageTypeData - 保管域タイプデータ

setStorageLocationData

public void setStorageLocationData(StorageLocationData storageLocationData)
品目データ (保管場所レベル)を設定します。

パラメータ:
storageLocationData - 品目データ (保管場所レベル)

setWarehouseNumberData

public void setWarehouseNumberData(WarehouseNumberData warehouseNumberData)
倉庫番号データを設定します。

パラメータ:
warehouseNumberData - 倉庫番号データ

setSalesData

public void setSalesData(SalesData salesData)
販売データを設定します。

パラメータ:
salesData - 販売データ

setClientData

public void setClientData(ClientData clientData)
品目データ (クライアントレベル)を設定します。

パラメータ:
clientData - 品目データ (クライアントレベル)

setProductionResourceToolData

public void setProductionResourceToolData(ProductionResourceToolData productionResourceToolData)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
productionResourceToolData - 品目マスタの生産資源/治工具 (PRT) 項目

setPlantData

public void setPlantData(PlantData plantData)
品目データ (プラントレベル)を設定します。

パラメータ:
plantData - 品目データ (プラントレベル)

setPlanningData

public void setPlanningData(PlanningData planningData)
品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
planningData - 品目マスタ/製品グループの変更伝票構造

setForecastParameters

public void setForecastParameters(ForecastParameters forecastParameters)
予測パラメータを設定します。

パラメータ:
forecastParameters - 予測パラメータ

setLifoValuationData

public void setLifoValuationData(LifoValuationData lifoValuationData)
LIFO 関連品目データを設定します。

パラメータ:
lifoValuationData - LIFO 関連品目データ

setExtensionOutList

public void setExtensionOutList(List extensionOutList)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。

パラメータ:
extensionOutList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

setInternationArticleNumbersList

public void setInternationArticleNumbersList(List internationArticleNumbersList)
EANを設定します。

パラメータ:
internationArticleNumbersList - EAN

setUnitSofmeasureList

public void setUnitSofmeasureList(List unitSofmeasureList)
数量単位を設定します。

パラメータ:
unitSofmeasureList - 数量単位

setTaxClassificationsList

public void setTaxClassificationsList(List taxClassificationsList)
制御デ－タを設定します。

パラメータ:
taxClassificationsList - 制御デ－タ

setMaterialDescriptionList

public void setMaterialDescriptionList(List materialDescriptionList)
品目テキストを設定します。

パラメータ:
materialDescriptionList - 品目テキスト

setMaterialTextList

public void setMaterialTextList(List materialTextList)
テキスト (長)を設定します。

パラメータ:
materialTextList - テキスト (長)

setMaterialEvg

public void setMaterialEvg(MaterialEvg materialEvg)
品目コード(長)を設定します。

パラメータ:
materialEvg - 品目コード(長)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス MaterialText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText
すべての実装インタフェース:
Serializable
public class MaterialText
extends Object
implements Serializable

テキスト (長)情報クラス
機能は以下の通り

  • テキスト (長)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialText()
テキスト (長)情報を作成します。
MaterialText(int index)
テキスト (長)情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getFormatCol() タグ列を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
String | getTextName() 名称を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
void | setTextName(String textName) 名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialText

public MaterialText()
テキスト (長)情報を作成します。

MaterialText

public MaterialText(int index)
テキスト (長)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextName

public String getTextName()
名称を取得します。

戻り値:
textName 名称

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextName

public void setTextName(String textName)
名称を設定します。

パラメータ:
textName - 名称

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス
ExtensionOut
InternationArticleNumbers
LifoValuationData
MaterialGetAll
MaterialText
ProductionResourceToolData


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

クラスの概要
ExtensionOut | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
InternationArticleNumbers | EAN情報クラス 機能は以下の通り EAN情報を保持します。
LifoValuationData | LIFO 関連品目データ情報クラス 機能は以下の通り LIFO 関連品目データ情報を保持します。
MaterialGetAll | 品目マスタ照会情報クラス 機能は以下の通り 品目マスタ照会情報を保持します。
MaterialText | テキスト (長)情報クラス 機能は以下の通り テキスト (長)情報を保持します。
ProductionResourceToolData | 品目マスタの生産資源/治工具 (PRT) 項目情報クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のクラス
ExtensionOut
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
InternationArticleNumbers
EAN情報クラス
機能は以下の通り
EAN情報を保持します。
MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。
MaterialText
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のクラス
LifoValuationData
LIFO 関連品目データ情報クラス
機能は以下の通り
LIFO 関連品目データ情報を保持します。
ProductionResourceToolData
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProductionResourceToolData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス ProductionResourceToolData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData
すべての実装インタフェース:
Serializable
public class ProductionResourceToolData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
メソッドの概要
String | getCreateLoadRecs() 区分: 生産資源/治工具の負荷レコード登録を取得します。
String | getCtrlKey() 生産資源/治工具管理の管理キーを取得します。
String | getCtrlKeyNoChg() 管理キーは変更できませんを取得します。
String | getEndOffset() 生産資源/治工具用途の終了オフセットを取得します。
String | getEndOffsetNoChg() 終了オフセットは変更できませんを取得します。
String | getEndOffsetUnit() 生産資源/治工具使用終了オフセット単位を取得します。
String | getEndOffsetUnitIso() PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
String | getEndRefDate() 生産資源/治工具使用終了日の参照日付を取得します。
String | getEndRefDateNoChg() 終了参照日付は変更できませんを取得します。
String | getFormulaTotQty() 生産資源/治工具の合計数量の計算式を取得します。
String | getFormulaTotQtyNoChg() 合計数量の計算式は変更できませんを取得します。
String | getFormulaTotUsage() 生産資源/治工具の総用途値の計算式を取得します。
String | getFormulaTotUsageNoChg() すべての用途値を計算する計算式は変更できませんを取得します。
String | getGrpKey1() 生産資源/治工具のグループキー 1を取得します。
String | getGrpKey2() 生産資源/治工具のグループキー 2を取得します。
String | getPlant() プラントを取得します。
String | getPrtUsage() 生産資源/治工具用途を取得します。
String | getRefKeyNoChg() 参照キーは変更できませんを取得します。
String | getStartOffset() 生産資源/治工具使用の開始オフセットを取得します。
String | getStartOffsetNoChg() 開始オフセットは変更できませんを取得します。
String | getStartOffsetUnit() 生産資源/治工具使用開始のオフセット単位を取得します。
String | getStartOffsetUnitIso() PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
String | getStartRefDate() 生産資源/治工具使用開始の参照日付を取得します。
String | getStdTextKey() 生産資源/治工具の標準テキストキーを取得します。
String | getStRefDateNoChg() 開始参照日付は変更できませんを取得します。
void | setCreateLoadRecs(String createLoadRecs) 区分: 生産資源/治工具の負荷レコード登録を設定します。
void | setCtrlKey(String ctrlKey) 生産資源/治工具管理の管理キーを設定します。
void | setCtrlKeyNoChg(String ctrlKeyNoChg) 管理キーは変更できませんを設定します。
void | setEndOffset(String endOffset) 生産資源/治工具用途の終了オフセットを設定します。
void | setEndOffsetNoChg(String endOffsetNoChg) 終了オフセットは変更できませんを設定します。
void | setEndOffsetUnit(String endOffsetUnit) 生産資源/治工具使用終了オフセット単位を設定します。
void | setEndOffsetUnitIso(String endOffsetUnitIso) PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
void | setEndRefDate(String endRefDate) 生産資源/治工具使用終了日の参照日付を設定します。
void | setEndRefDateNoChg(String endRefDateNoChg) 終了参照日付は変更できませんを設定します。
void | setFormulaTotQty(String formulaTotQty) 生産資源/治工具の合計数量の計算式を設定します。
void | setFormulaTotQtyNoChg(String formulaTotQtyNoChg) 合計数量の計算式は変更できませんを設定します。
void | setFormulaTotUsage(String formulaTotUsage) 生産資源/治工具の総用途値の計算式を設定します。
void | setFormulaTotUsageNoChg(String formulaTotUsageNoChg) すべての用途値を計算する計算式は変更できませんを設定します。
void | setGrpKey1(String grpKey1) 生産資源/治工具のグループキー 1を設定します。
void | setGrpKey2(String grpKey2) 生産資源/治工具のグループキー 2を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPrtUsage(String prtUsage) 生産資源/治工具用途を設定します。
void | setRefKeyNoChg(String refKeyNoChg) 参照キーは変更できませんを設定します。
void | setStartOffset(String startOffset) 生産資源/治工具使用の開始オフセットを設定します。
void | setStartOffsetNoChg(String startOffsetNoChg) 開始オフセットは変更できませんを設定します。
void | setStartOffsetUnit(String startOffsetUnit) 生産資源/治工具使用開始のオフセット単位を設定します。
void | setStartOffsetUnitIso(String startOffsetUnitIso) PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
void | setStartRefDate(String startRefDate) 生産資源/治工具使用開始の参照日付を設定します。
void | setStdTextKey(String stdTextKey) 生産資源/治工具の標準テキストキーを設定します。
void | setStRefDateNoChg(String stRefDateNoChg) 開始参照日付は変更できませんを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProductionResourceToolData

public ProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

メソッドの詳細

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getCreateLoadRecs

public String getCreateLoadRecs()
区分: 生産資源/治工具の負荷レコード登録を取得します。

戻り値:
createLoadRecs 区分: 生産資源/治工具の負荷レコード登録

getCtrlKey

public String getCtrlKey()
生産資源/治工具管理の管理キーを取得します。

戻り値:
ctrlKey 生産資源/治工具管理の管理キー

getCtrlKeyNoChg

public String getCtrlKeyNoChg()
管理キーは変更できませんを取得します。

戻り値:
ctrlKeyNoChg 管理キーは変更できません

getGrpKey1

public String getGrpKey1()
生産資源/治工具のグループキー 1を取得します。

戻り値:
grpKey1 生産資源/治工具のグループキー 1

getGrpKey2

public String getGrpKey2()
生産資源/治工具のグループキー 2を取得します。

戻り値:
grpKey2 生産資源/治工具のグループキー 2

getPrtUsage

public String getPrtUsage()
生産資源/治工具用途を取得します。

戻り値:
prtUsage 生産資源/治工具用途

getStdTextKey

public String getStdTextKey()
生産資源/治工具の標準テキストキーを取得します。

戻り値:
stdTextKey 生産資源/治工具の標準テキストキー

getRefKeyNoChg

public String getRefKeyNoChg()
参照キーは変更できませんを取得します。

戻り値:
refKeyNoChg 参照キーは変更できません

getStartRefDate

public String getStartRefDate()
生産資源/治工具使用開始の参照日付を取得します。

戻り値:
startRefDate 生産資源/治工具使用開始の参照日付

getStRefDateNoChg

public String getStRefDateNoChg()
開始参照日付は変更できませんを取得します。

戻り値:
stRefDateNoChg 開始参照日付は変更できません

getStartOffset

public String getStartOffset()
生産資源/治工具使用の開始オフセットを取得します。

戻り値:
startOffset 生産資源/治工具使用の開始オフセット

getStartOffsetUnit

public String getStartOffsetUnit()
生産資源/治工具使用開始のオフセット単位を取得します。

戻り値:
startOffsetUnit 生産資源/治工具使用開始のオフセット単位

getStartOffsetUnitIso

public String getStartOffsetUnitIso()
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。

戻り値:
startOffsetUnitIso PRT 用途開始決定の間隔時間単位 (ISO)

getStartOffsetNoChg

public String getStartOffsetNoChg()
開始オフセットは変更できませんを取得します。

戻り値:
startOffsetNoChg 開始オフセットは変更できません

getEndRefDate

public String getEndRefDate()
生産資源/治工具使用終了日の参照日付を取得します。

戻り値:
endRefDate 生産資源/治工具使用終了日の参照日付

getEndRefDateNoChg

public String getEndRefDateNoChg()
終了参照日付は変更できませんを取得します。

戻り値:
endRefDateNoChg 終了参照日付は変更できません

getEndOffset

public String getEndOffset()
生産資源/治工具用途の終了オフセットを取得します。

戻り値:
endOffset 生産資源/治工具用途の終了オフセット

getEndOffsetUnit

public String getEndOffsetUnit()
生産資源/治工具使用終了オフセット単位を取得します。

戻り値:
endOffsetUnit 生産資源/治工具使用終了オフセット単位

getEndOffsetUnitIso

public String getEndOffsetUnitIso()
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。

戻り値:
endOffsetUnitIso PRT 用途終了決定の間隔時間単位 (ISO)

getEndOffsetNoChg

public String getEndOffsetNoChg()
終了オフセットは変更できませんを取得します。

戻り値:
endOffsetNoChg 終了オフセットは変更できません

getFormulaTotQty

public String getFormulaTotQty()
生産資源/治工具の合計数量の計算式を取得します。

戻り値:
formulaTotQty 生産資源/治工具の合計数量の計算式

getFormulaTotQtyNoChg

public String getFormulaTotQtyNoChg()
合計数量の計算式は変更できませんを取得します。

戻り値:
formulaTotQtyNoChg 合計数量の計算式は変更できません

getFormulaTotUsage

public String getFormulaTotUsage()
生産資源/治工具の総用途値の計算式を取得します。

戻り値:
formulaTotUsage 生産資源/治工具の総用途値の計算式

getFormulaTotUsageNoChg

public String getFormulaTotUsageNoChg()
すべての用途値を計算する計算式は変更できませんを取得します。

戻り値:
formulaTotUsageNoChg すべての用途値を計算する計算式は変更できません

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setCreateLoadRecs

public void setCreateLoadRecs(String createLoadRecs)
区分: 生産資源/治工具の負荷レコード登録を設定します。

パラメータ:
createLoadRecs - 区分: 生産資源/治工具の負荷レコード登録

setCtrlKey

public void setCtrlKey(String ctrlKey)
生産資源/治工具管理の管理キーを設定します。

パラメータ:
ctrlKey - 生産資源/治工具管理の管理キー

setCtrlKeyNoChg

public void setCtrlKeyNoChg(String ctrlKeyNoChg)
管理キーは変更できませんを設定します。

パラメータ:
ctrlKeyNoChg - 管理キーは変更できません

setGrpKey1

public void setGrpKey1(String grpKey1)
生産資源/治工具のグループキー 1を設定します。

パラメータ:
grpKey1 - 生産資源/治工具のグループキー 1

setGrpKey2

public void setGrpKey2(String grpKey2)
生産資源/治工具のグループキー 2を設定します。

パラメータ:
grpKey2 - 生産資源/治工具のグループキー 2

setPrtUsage

public void setPrtUsage(String prtUsage)
生産資源/治工具用途を設定します。

パラメータ:
prtUsage - 生産資源/治工具用途

setStdTextKey

public void setStdTextKey(String stdTextKey)
生産資源/治工具の標準テキストキーを設定します。

パラメータ:
stdTextKey - 生産資源/治工具の標準テキストキー

setRefKeyNoChg

public void setRefKeyNoChg(String refKeyNoChg)
参照キーは変更できませんを設定します。

パラメータ:
refKeyNoChg - 参照キーは変更できません

setStartRefDate

public void setStartRefDate(String startRefDate)
生産資源/治工具使用開始の参照日付を設定します。

パラメータ:
startRefDate - 生産資源/治工具使用開始の参照日付

setStRefDateNoChg

public void setStRefDateNoChg(String stRefDateNoChg)
開始参照日付は変更できませんを設定します。

パラメータ:
stRefDateNoChg - 開始参照日付は変更できません

setStartOffset

public void setStartOffset(String startOffset)
生産資源/治工具使用の開始オフセットを設定します。

パラメータ:
startOffset - 生産資源/治工具使用の開始オフセット

setStartOffsetUnit

public void setStartOffsetUnit(String startOffsetUnit)
生産資源/治工具使用開始のオフセット単位を設定します。

パラメータ:
startOffsetUnit - 生産資源/治工具使用開始のオフセット単位

setStartOffsetUnitIso

public void setStartOffsetUnitIso(String startOffsetUnitIso)
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。

パラメータ:
startOffsetUnitIso - PRT 用途開始決定の間隔時間単位 (ISO)

setStartOffsetNoChg

public void setStartOffsetNoChg(String startOffsetNoChg)
開始オフセットは変更できませんを設定します。

パラメータ:
startOffsetNoChg - 開始オフセットは変更できません

setEndRefDate

public void setEndRefDate(String endRefDate)
生産資源/治工具使用終了日の参照日付を設定します。

パラメータ:
endRefDate - 生産資源/治工具使用終了日の参照日付

setEndRefDateNoChg

public void setEndRefDateNoChg(String endRefDateNoChg)
終了参照日付は変更できませんを設定します。

パラメータ:
endRefDateNoChg - 終了参照日付は変更できません

setEndOffset

public void setEndOffset(String endOffset)
生産資源/治工具用途の終了オフセットを設定します。

パラメータ:
endOffset - 生産資源/治工具用途の終了オフセット

setEndOffsetUnit

public void setEndOffsetUnit(String endOffsetUnit)
生産資源/治工具使用終了オフセット単位を設定します。

パラメータ:
endOffsetUnit - 生産資源/治工具使用終了オフセット単位

setEndOffsetUnitIso

public void setEndOffsetUnitIso(String endOffsetUnitIso)
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。

パラメータ:
endOffsetUnitIso - PRT 用途終了決定の間隔時間単位 (ISO)

setEndOffsetNoChg

public void setEndOffsetNoChg(String endOffsetNoChg)
終了オフセットは変更できませんを設定します。

パラメータ:
endOffsetNoChg - 終了オフセットは変更できません

setFormulaTotQty

public void setFormulaTotQty(String formulaTotQty)
生産資源/治工具の合計数量の計算式を設定します。

パラメータ:
formulaTotQty - 生産資源/治工具の合計数量の計算式

setFormulaTotQtyNoChg

public void setFormulaTotQtyNoChg(String formulaTotQtyNoChg)
合計数量の計算式は変更できませんを設定します。

パラメータ:
formulaTotQtyNoChg - 合計数量の計算式は変更できません

setFormulaTotUsage

public void setFormulaTotUsage(String formulaTotUsage)
生産資源/治工具の総用途値の計算式を設定します。

パラメータ:
formulaTotUsage - 生産資源/治工具の総用途値の計算式

setFormulaTotUsageNoChg

public void setFormulaTotUsageNoChg(String formulaTotUsageNoChg)
すべての用途値を計算する計算式は変更できませんを設定します。

パラメータ:
formulaTotUsageNoChg - すべての用途値を計算する計算式は変更できません

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn の使用

ExtensionIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionIn の使用

ExtensionIn を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionIn MaterialSaveReplicaController.getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX の使用

ExtensionInX を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionInX の使用

ExtensionInX を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionInX MaterialSaveReplicaController.getExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues の使用

ForecastValues を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ForecastValues の使用

ForecastValues を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ForecastValues MaterialSaveReplicaController.getForecastValues(int index)
需要予測値のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData の使用

HeadData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での HeadData の使用

HeadData を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 HeadData MaterialSaveReplicaController.getHeadData(int index)
管理情報設定ヘッダセグメントが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos の使用

InternationalArtnos を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での InternationalArtnos の使用

InternationalArtnos を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 InternationalArtnos MaterialSaveReplicaController.getInternationalArtnos(int index)
国際商品コード (EAN)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText の使用

MaterialLongText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialLongText の使用

MaterialLongText を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 MaterialLongText MaterialSaveReplicaController.getMaterialLongText(int index)
テキスト (長)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica の使用

MaterialSaveReplica を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialSaveReplica の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialSaveReplica のサブクラス
 class MaterialSaveReplicaController
品目マスタ更新コントローラクラス
機能は以下の通り
品目マスタを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData の使用

PrtData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PrtData の使用

PrtData を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PrtData MaterialSaveReplicaController.getPrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption の使用

TotalConsumption を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での TotalConsumption の使用

TotalConsumption を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 TotalConsumption MaterialSaveReplicaController.getTotalConsumption(int index)
品目総消費量のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption の使用

UnplndConsumption を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での UnplndConsumption の使用

UnplndConsumption を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 UnplndConsumption MaterialSaveReplicaController.getUnplndConsumption(int index)
計画外消費のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtensionIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() 長さ 229 の文字データのコンテナを取得します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) 長さ 229 の文字データのコンテナを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

ExtensionIn

public ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
長さ 229 の文字データのコンテナを取得します。

戻り値:
valuepart4 長さ 229 の文字データのコンテナ

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
長さ 229 の文字データのコンテナを設定します。

パラメータ:
valuepart4 - 長さ 229 の文字データのコンテナ

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtensionInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ExtensionInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX
すべての実装インタフェース:
Serializable
public class ExtensionInX
extends Object
implements Serializable

拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り

  • 拡張イン/拡張アウトのチェックボックス構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionInX()
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
メソッドの概要
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() 長さ 229 の文字データのコンテナを取得します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) 長さ 229 の文字データのコンテナを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionInX

public ExtensionInX()
拡張イン/拡張アウトのチェックボックス構造情報を作成します。

ExtensionInX

public ExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
長さ 229 の文字データのコンテナを取得します。

戻り値:
valuepart4 長さ 229 の文字データのコンテナ

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
長さ 229 の文字データのコンテナを設定します。

パラメータ:
valuepart4 - 長さ 229 の文字データのコンテナ

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastValues (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ForecastValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues
すべての実装インタフェース:
Serializable
public class ForecastValues
extends Object
implements Serializable

需要予測値のデータ転送情報クラス
機能は以下の通り

  • 需要予測値のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastValues()
需要予測値のデータ転送情報を作成します。
ForecastValues(int index)
需要予測値のデータ転送情報を作成します。
メソッドの概要
String | getCorrValue() 需要予測に対する修正値を取得します。
String | getCvalueFxd() 区分: 消費金額の確定を取得します。
String | getExpostVal() 事後的需要予測値を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getForeValue() 予測値を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getSeasIndex() 季節指数を取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setCorrValue(String corrValue) 需要予測に対する修正値を設定します。
void | setCvalueFxd(String cvalueFxd) 区分: 消費金額の確定を設定します。
void | setExpostVal(String expostVal) 事後的需要予測値を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setForeValue(String foreValue) 予測値を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setSeasIndex(String seasIndex) 季節指数を設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastValues

public ForecastValues()
需要予測値のデータ転送情報を作成します。

ForecastValues

public ForecastValues(int index)
需要予測値のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getForeValue

public String getForeValue()
予測値を取得します。

戻り値:
foreValue 予測値

getCorrValue

public String getCorrValue()
需要予測に対する修正値を取得します。

戻り値:
corrValue 需要予測に対する修正値

getSeasIndex

public String getSeasIndex()
季節指数を取得します。

戻り値:
seasIndex 季節指数

getCvalueFxd

public String getCvalueFxd()
区分: 消費金額の確定を取得します。

戻り値:
cvalueFxd 区分: 消費金額の確定

getExpostVal

public String getExpostVal()
事後的需要予測値を取得します。

戻り値:
expostVal 事後的需要予測値

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setForeValue

public void setForeValue(String foreValue)
予測値を設定します。

パラメータ:
foreValue - 予測値

setCorrValue

public void setCorrValue(String corrValue)
需要予測に対する修正値を設定します。

パラメータ:
corrValue - 需要予測に対する修正値

setSeasIndex

public void setSeasIndex(String seasIndex)
季節指数を設定します。

パラメータ:
seasIndex - 季節指数

setCvalueFxd

public void setCvalueFxd(String cvalueFxd)
区分: 消費金額の確定を設定します。

パラメータ:
cvalueFxd - 区分: 消費金額の確定

setExpostVal

public void setExpostVal(String expostVal)
事後的需要予測値を設定します。

パラメータ:
expostVal - 事後的需要予測値

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeadData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス HeadData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData
すべての実装インタフェース:
Serializable
public class HeadData
extends Object
implements Serializable

管理情報設定ヘッダセグメント情報クラス
機能は以下の通り

  • 管理情報設定ヘッダセグメント情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeadData()
管理情報設定ヘッダセグメント情報を作成します。
HeadData(int index)
管理情報設定ヘッダセグメント情報を作成します。
メソッドの概要
String | getAccountView() 会計ビューを取得します。
String | getBasicView() 基本データビューを取得します。
String | getCostView() 原価計算ビューを取得します。
String | getForecastView() 需要予測ビューを取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getIndSector() 産業コードを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatlType() 品目タイプを取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getPrtView() 生産資源/治工具 (PRT) ビューを取得します。
String | getPurchaseView() 購買管理ビューを取得します。
String | getQualityView() 品質管理ビューを取得します。
String | getSalesView() 販売ビューを取得します。
String | getStorageView() 保管ビューを取得します。
String | getWarehouseView() 倉庫管理ビューを取得します。
String | getWorkSchedView() 作業計画ビューを取得します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setBasicView(String basicView) 基本データビューを設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setForecastView(String forecastView) 需要予測ビューを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIndSector(String indSector) 産業コードを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatlType(String matlType) 品目タイプを設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setPrtView(String prtView) 生産資源/治工具 (PRT) ビューを設定します。
void | setPurchaseView(String purchaseView) 購買管理ビューを設定します。
void | setQualityView(String qualityView) 品質管理ビューを設定します。
void | setSalesView(String salesView) 販売ビューを設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
void | setWarehouseView(String warehouseView) 倉庫管理ビューを設定します。
void | setWorkSchedView(String workSchedView) 作業計画ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeadData

public HeadData()
管理情報設定ヘッダセグメント情報を作成します。

HeadData

public HeadData(int index)
管理情報設定ヘッダセグメント情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getIndSector

public String getIndSector()
産業コードを取得します。

戻り値:
indSector 産業コード

getMatlType

public String getMatlType()
品目タイプを取得します。

戻り値:
matlType 品目タイプ

getBasicView

public String getBasicView()
基本データビューを取得します。

戻り値:
basicView 基本データビュー

getSalesView

public String getSalesView()
販売ビューを取得します。

戻り値:
salesView 販売ビュー

getPurchaseView

public String getPurchaseView()
購買管理ビューを取得します。

戻り値:
purchaseView 購買管理ビュー

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getForecastView

public String getForecastView()
需要予測ビューを取得します。

戻り値:
forecastView 需要予測ビュー

getWorkSchedView

public String getWorkSchedView()
作業計画ビューを取得します。

戻り値:
workSchedView 作業計画ビュー

getPrtView

public String getPrtView()
生産資源/治工具 (PRT) ビューを取得します。

戻り値:
prtView 生産資源/治工具 (PRT) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getWarehouseView

public String getWarehouseView()
倉庫管理ビューを取得します。

戻り値:
warehouseView 倉庫管理ビュー

getQualityView

public String getQualityView()
品質管理ビューを取得します。

戻り値:
qualityView 品質管理ビュー

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setIndSector

public void setIndSector(String indSector)
産業コードを設定します。

パラメータ:
indSector - 産業コード

setMatlType

public void setMatlType(String matlType)
品目タイプを設定します。

パラメータ:
matlType - 品目タイプ

setBasicView

public void setBasicView(String basicView)
基本データビューを設定します。

パラメータ:
basicView - 基本データビュー

setSalesView

public void setSalesView(String salesView)
販売ビューを設定します。

パラメータ:
salesView - 販売ビュー

setPurchaseView

public void setPurchaseView(String purchaseView)
購買管理ビューを設定します。

パラメータ:
purchaseView - 購買管理ビュー

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setForecastView

public void setForecastView(String forecastView)
需要予測ビューを設定します。

パラメータ:
forecastView - 需要予測ビュー

setWorkSchedView

public void setWorkSchedView(String workSchedView)
作業計画ビューを設定します。

パラメータ:
workSchedView - 作業計画ビュー

setPrtView

public void setPrtView(String prtView)
生産資源/治工具 (PRT) ビューを設定します。

パラメータ:
prtView - 生産資源/治工具 (PRT) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setWarehouseView

public void setWarehouseView(String warehouseView)
倉庫管理ビューを設定します。

パラメータ:
warehouseView - 倉庫管理ビュー

setQualityView

public void setQualityView(String qualityView)
品質管理ビューを設定します。

パラメータ:
qualityView - 品質管理ビュー

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalArtnos (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス InternationalArtnos

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos
すべての実装インタフェース:
Serializable
public class InternationalArtnos
extends Object
implements Serializable

国際商品コード (EAN)情報クラス
機能は以下の通り

  • 国際商品コード (EAN)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
InternationalArtnos()
国際商品コード (EAN)情報を作成します。
InternationalArtnos(int index)
国際商品コード (EAN)情報を作成します。
メソッドの概要
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getUnit() 表示数量単位を取得します。
String | getUnitIso() ISO コードでの表示数量単位を取得します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setUnitIso(String unitIso) ISO コードでの表示数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternationalArtnos

public InternationalArtnos()
国際商品コード (EAN)情報を作成します。

InternationalArtnos

public InternationalArtnos(int index)
国際商品コード (EAN)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getUnitIso

public String getUnitIso()
ISO コードでの表示数量単位を取得します。

戻り値:
unitIso ISO コードでの表示数量単位

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setUnitIso

public void setUnitIso(String unitIso)
ISO コードでの表示数量単位を設定します。

パラメータ:
unitIso - ISO コードでの表示数量単位

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialLongText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス MaterialLongText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText
すべての実装インタフェース:
Serializable
public class MaterialLongText
extends Object
implements Serializable

テキスト (長)情報クラス
機能は以下の通り

  • テキスト (長)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialLongText()
テキスト (長)情報を作成します。
MaterialLongText(int index)
テキスト (長)情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getFormatCol() タグ列を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
String | getTextName() 名称を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
void | setTextName(String textName) 名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialLongText

public MaterialLongText()
テキスト (長)情報を作成します。

MaterialLongText

public MaterialLongText(int index)
テキスト (長)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextName

public String getTextName()
名称を取得します。

戻り値:
textName 名称

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextName

public void setTextName(String textName)
名称を設定します。

パラメータ:
textName - 名称

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialSaveReplica (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス MaterialSaveReplica

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialSaveReplicaController
public class MaterialSaveReplica
extends UpdateController
implements Serializable

品目マスタ更新情報クラス
機能は以下の通り

  • 品目マスタ更新情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialSaveReplica()
品目マスタ更新情報を作成します。
MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。
MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。
メソッドの概要
List | getClientDataList() 品目データ (クライアントレベル)を取得します。
List | getExtensionInList() BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
List | getExtensionInXList() 拡張イン/拡張アウトのチェックボックス構造を取得します。
String | getFlagCadCall() CAD システムからコールを取得します。
String | getFlagOnline() No ALE Field Selectionを取得します。
List | getForecastParametersList() 需要予測パラメータを取得します。
List | getForecastValuesList() 需要予測値のデータ転送を取得します。
List | getHeadDataList() 管理情報設定ヘッダセグメントを取得します。
String | getInpfldcheck() 項目無効時の応答を取得します。
List | getInternationalArtnosList() 国際商品コード (EAN)を取得します。
List | getMaterialDescriptionList() 品目テキストを取得します。
List | getMaterialLongTextList() テキスト (長)を取得します。
String | getNoappllog() アプリケーションログ書込なしを取得します。
String | getNochangedoc() 変更伝票書込なしを取得します。
String | getNoRollbackWork() Override Rollback Workを取得します。
List | getPlanningDataList() 品目マスタ/製品グループの変更伝票構造を取得します。
List | getPlantDataList() 品目データ (プラントレベル)を取得します。
List | getPrtDataList() 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
List | getReturnMessagesList() リターンパラメータ BAPIRET2 の代替構造を取得します。
List | getSalesDataList() 販売データを取得します。
List | getStorageLocationDataList() 品目データ (保管場所レベル)を取得します。
List | getStorageTypeDataList() 保管域タイプデータを取得します。
List | getTaxClassificationsList() 制御デ－タを取得します。
String | getTestrun() 書込 BAPI のシミュレーションセッションへの切替を取得します。
List | getTotalConsumptionList() 品目総消費量のデータ転送を取得します。
List | getUnitSofmeasureList() 数量単位を取得します。
List | getUnplndConsumptionList() 計画外消費のデータ転送を取得します。
List | getValuationDataList() 評価データを取得します。
List | getWarehouseNumberDataList() 倉庫番号データを取得します。
void | initMaterialSaveReplica() 品目マスタ更新情報の各種インスタンスを生成します。
void | setClientDataList(List clientDataList) 品目データ (クライアントレベル)を設定します。
void | setExportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | setExtensionInList(List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
void | setExtensionInXList(List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造を設定します。
void | setFlagCadCall(String flagCadCall) CAD システムからコールを設定します。
void | setFlagOnline(String flagOnline) No ALE Field Selectionを設定します。
void | setForecastParametersList(List forecastParametersList) 需要予測パラメータを設定します。
void | setForecastValuesList(List forecastValuesList) 需要予測値のデータ転送を設定します。
void | setHeadDataList(List headDataList) 管理情報設定ヘッダセグメントを設定します。
void | setImportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | setInpfldcheck(String inpFldCheck) 項目無効時の応答を設定します。
void | setInternationalArtnosList(List internationalArtnosList) 国際商品コード (EAN)を設定します。
void | setMaterialDescriptionList(List materialDescriptionList) 品目テキストを設定します。
void | setMaterialLongTextList(List materialLongTextList) テキスト (長)を設定します。
void | setNoappllog(String noApplLog) アプリケーションログ書込なしを設定します。
void | setNochangedoc(String noChangeDoc) 変更伝票書込なしを設定します。
void | setNoRollbackWork(String noRollbackWork) Override Rollback Workを設定します。
void | setPlanningDataList(List planningDataList) 品目マスタ/製品グループの変更伝票構造を設定します。
void | setPlantDataList(List plantDataList) 品目データ (プラントレベル)を設定します。
void | setPrtDataList(List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setReturnMessagesList(List returnMessagesList) リターンパラメータ BAPIRET2 の代替構造を設定します。
void | setSalesDataList(List salesDataList) 販売データを設定します。
void | setStorageLocationDataList(List storageLocationDataList) 品目データ (保管場所レベル)を設定します。
void | setStorageTypeDataList(List storageTypeDataList) 保管域タイプデータを設定します。
void | setTaxClassificationsList(List taxClassificationsList) 制御デ－タを設定します。
void | setTestrun(String testRun) 書込 BAPI のシミュレーションセッションへの切替を設定します。
void | setTotalConsumptionList(List totalConsumptionList) 品目総消費量のデータ転送を設定します。
void | setUnitSofmeasureList(List unitSofmeasureList) 数量単位を設定します。
void | setUnplndConsumptionList(List unplndConsumptionList) 計画外消費のデータ転送を設定します。
void | setValuationDataList(List valuationDataList) 評価データを設定します。
void | setWarehouseNumberDataList(List warehouseNumberDataList) 倉庫番号データを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialSaveReplica

public MaterialSaveReplica()
品目マスタ更新情報を作成します。

MaterialSaveReplica

public MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。

パラメータ:
connectionManager - コネクションオブジェクト

MaterialSaveReplica

public MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

initMaterialSaveReplica

public void initMaterialSaveReplica()
品目マスタ更新情報の各種インスタンスを生成します。

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目マスタに登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
品目マスタに登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getNochangedoc

public String getNochangedoc()
変更伝票書込なしを取得します。

戻り値:
nochangedoc 変更伝票書込なし

getNoappllog

public String getNoappllog()
アプリケーションログ書込なしを取得します。

戻り値:
noappllog アプリケーションログ書込なし

getTestrun

public String getTestrun()
書込 BAPI のシミュレーションセッションへの切替を取得します。

戻り値:
testrun 書込 BAPI のシミュレーションセッションへの切替

getInpfldcheck

public String getInpfldcheck()
項目無効時の応答を取得します。

戻り値:
inpfldcheck 項目無効時の応答

getFlagCadCall

public String getFlagCadCall()
CAD システムからコールを取得します。

戻り値:
flagCadCall CAD システムからコール

getFlagOnline

public String getFlagOnline()
No ALE Field Selectionを取得します。

戻り値:
flagOnline No ALE Field Selection

getNoRollbackWork

public String getNoRollbackWork()
Override Rollback Workを取得します。

戻り値:
noRollbackWork Override Rollback Work

getHeadDataList

public List getHeadDataList()
管理情報設定ヘッダセグメントを取得します。

戻り値:
headDataList 管理情報設定ヘッダセグメント

getClientDataList

public List getClientDataList()
品目データ (クライアントレベル)を取得します。

戻り値:
clientDataList 品目データ (クライアントレベル)

getPlantDataList

public List getPlantDataList()
品目データ (プラントレベル)を取得します。

戻り値:
plantDataList 品目データ (プラントレベル)

getForecastParametersList

public List getForecastParametersList()
需要予測パラメータを取得します。

戻り値:
forecastParametersList 需要予測パラメータ

getPlanningDataList

public List getPlanningDataList()
品目マスタ/製品グループの変更伝票構造を取得します。

戻り値:
planningDataList 品目マスタ/製品グループの変更伝票構造

getStorageLocationDataList

public List getStorageLocationDataList()
品目データ (保管場所レベル)を取得します。

戻り値:
storageLocationDataList 品目データ (保管場所レベル)

getValuationDataList

public List getValuationDataList()
評価データを取得します。

戻り値:
valuationDataList 評価データ

getWarehouseNumberDataList

public List getWarehouseNumberDataList()
倉庫番号データを取得します。

戻り値:
warehouseNumberDataList 倉庫番号データ

getSalesDataList

public List getSalesDataList()
販売データを取得します。

戻り値:
salesDataList 販売データ

getStorageTypeDataList

public List getStorageTypeDataList()
保管域タイプデータを取得します。

戻り値:
storageTypeDataList 保管域タイプデータ

getMaterialDescriptionList

public List getMaterialDescriptionList()
品目テキストを取得します。

戻り値:
materialDescriptionList 品目テキスト

getUnitSofmeasureList

public List getUnitSofmeasureList()
数量単位を取得します。

戻り値:
unitSofmeasureList 数量単位

getInternationalArtnosList

public List getInternationalArtnosList()
国際商品コード (EAN)を取得します。

戻り値:
internationalArtnosList 国際商品コード (EAN)

getMaterialLongTextList

public List getMaterialLongTextList()
テキスト (長)を取得します。

戻り値:
materialLongTextList テキスト (長)

getTaxClassificationsList

public List getTaxClassificationsList()
制御デ－タを取得します。

戻り値:
taxClassificationsList 制御デ－タ

getPrtDataList

public List getPrtDataList()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

戻り値:
prtDataList 品目マスタの生産資源/治工具 (PRT) 項目

getExtensionInList

public List getExtensionInList()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。

戻り値:
extensionInList BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

getExtensionInXList

public List getExtensionInXList()
拡張イン/拡張アウトのチェックボックス構造を取得します。

戻り値:
extensionInXList 拡張イン/拡張アウトのチェックボックス構造

getForecastValuesList

public List getForecastValuesList()
需要予測値のデータ転送を取得します。

戻り値:
forecastValuesList 需要予測値のデータ転送

getUnplndConsumptionList

public List getUnplndConsumptionList()
計画外消費のデータ転送を取得します。

戻り値:
unplndConsumptionList 計画外消費のデータ転送

getTotalConsumptionList

public List getTotalConsumptionList()
品目総消費量のデータ転送を取得します。

戻り値:
totalConsumptionList 品目総消費量のデータ転送

getReturnMessagesList

public List getReturnMessagesList()
リターンパラメータ BAPIRET2 の代替構造を取得します。

戻り値:
returnMessagesList リターンパラメータ BAPIRET2 の代替構造

setNochangedoc

public void setNochangedoc(String noChangeDoc)
変更伝票書込なしを設定します。

パラメータ:
noChangeDoc - 変更伝票書込なし

setNoappllog

public void setNoappllog(String noApplLog)
アプリケーションログ書込なしを設定します。

パラメータ:
noApplLog - アプリケーションログ書込なし

setTestrun

public void setTestrun(String testRun)
書込 BAPI のシミュレーションセッションへの切替を設定します。

パラメータ:
testRun - 書込 BAPI のシミュレーションセッションへの切替

setInpfldcheck

public void setInpfldcheck(String inpFldCheck)
項目無効時の応答を設定します。

パラメータ:
inpFldCheck - 項目無効時の応答

setFlagCadCall

public void setFlagCadCall(String flagCadCall)
CAD システムからコールを設定します。

パラメータ:
flagCadCall - CAD システムからコール

setFlagOnline

public void setFlagOnline(String flagOnline)
No ALE Field Selectionを設定します。

パラメータ:
flagOnline - No ALE Field Selection

setNoRollbackWork

public void setNoRollbackWork(String noRollbackWork)
Override Rollback Workを設定します。

パラメータ:
noRollbackWork - Override Rollback Work

setHeadDataList

public void setHeadDataList(List headDataList)
管理情報設定ヘッダセグメントを設定します。

パラメータ:
headDataList - 管理情報設定ヘッダセグメント

setClientDataList

public void setClientDataList(List clientDataList)
品目データ (クライアントレベル)を設定します。

パラメータ:
clientDataList - 品目データ (クライアントレベル)

setPlantDataList

public void setPlantDataList(List plantDataList)
品目データ (プラントレベル)を設定します。

パラメータ:
plantDataList - 品目データ (プラントレベル)

setForecastParametersList

public void setForecastParametersList(List forecastParametersList)
需要予測パラメータを設定します。

パラメータ:
forecastParametersList - 需要予測パラメータ

setPlanningDataList

public void setPlanningDataList(List planningDataList)
品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
planningDataList - 品目マスタ/製品グループの変更伝票構造

setStorageLocationDataList

public void setStorageLocationDataList(List storageLocationDataList)
品目データ (保管場所レベル)を設定します。

パラメータ:
storageLocationDataList - 品目データ (保管場所レベル)

setValuationDataList

public void setValuationDataList(List valuationDataList)
評価データを設定します。

パラメータ:
valuationDataList - 評価データ

setWarehouseNumberDataList

public void setWarehouseNumberDataList(List warehouseNumberDataList)
倉庫番号データを設定します。

パラメータ:
warehouseNumberDataList - 倉庫番号データ

setSalesDataList

public void setSalesDataList(List salesDataList)
販売データを設定します。

パラメータ:
salesDataList - 販売データ

setStorageTypeDataList

public void setStorageTypeDataList(List storageTypeDataList)
保管域タイプデータを設定します。

パラメータ:
storageTypeDataList - 保管域タイプデータ

setMaterialDescriptionList

public void setMaterialDescriptionList(List materialDescriptionList)
品目テキストを設定します。

パラメータ:
materialDescriptionList - 品目テキスト

setUnitSofmeasureList

public void setUnitSofmeasureList(List unitSofmeasureList)
数量単位を設定します。

パラメータ:
unitSofmeasureList - 数量単位

setInternationalArtnosList

public void setInternationalArtnosList(List internationalArtnosList)
国際商品コード (EAN)を設定します。

パラメータ:
internationalArtnosList - 国際商品コード (EAN)

setMaterialLongTextList

public void setMaterialLongTextList(List materialLongTextList)
テキスト (長)を設定します。

パラメータ:
materialLongTextList - テキスト (長)

setTaxClassificationsList

public void setTaxClassificationsList(List taxClassificationsList)
制御デ－タを設定します。

パラメータ:
taxClassificationsList - 制御デ－タ

setPrtDataList

public void setPrtDataList(List prtDataList)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目

setExtensionInList

public void setExtensionInList(List extensionInList)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。

パラメータ:
extensionInList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

setExtensionInXList

public void setExtensionInXList(List extensionInXList)
拡張イン/拡張アウトのチェックボックス構造を設定します。

パラメータ:
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造

setForecastValuesList

public void setForecastValuesList(List forecastValuesList)
需要予測値のデータ転送を設定します。

パラメータ:
forecastValuesList - 需要予測値のデータ転送

setUnplndConsumptionList

public void setUnplndConsumptionList(List unplndConsumptionList)
計画外消費のデータ転送を設定します。

パラメータ:
unplndConsumptionList - 計画外消費のデータ転送

setTotalConsumptionList

public void setTotalConsumptionList(List totalConsumptionList)
品目総消費量のデータ転送を設定します。

パラメータ:
totalConsumptionList - 品目総消費量のデータ転送

setReturnMessagesList

public void setReturnMessagesList(List returnMessagesList)
リターンパラメータ BAPIRET2 の代替構造を設定します。

パラメータ:
returnMessagesList - リターンパラメータ BAPIRET2 の代替構造

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス
ExtensionIn
ExtensionInX
ForecastValues
HeadData
InternationalArtnos
MaterialLongText
MaterialSaveReplica
ParamClientDataList
ParamExtensionIn
ParamExtensionInX
ParamForecastParametersList
ParamForecastValues
ParamHeadData
ParamInternationalArtnos
ParamMaterialDescription
ParamMaterialLongText
ParamPlanningDataList
ParamPlantDataList
ParamPrtData
ParamReturnMessages
ParamSalesDataList
ParamStorageLocationDataList
ParamStorageTypeDataList
ParamTaxClassifications
ParamTotalConsumption
ParamUnitSofmeasure
ParamUnplndConsumption
ParamValuationDataList
ParamWarehouseNumberDataList
PrtData
ReturnMessages
TotalConsumption
UnplndConsumption


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

クラスの概要
ExtensionIn | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionInX | 拡張イン/拡張アウトのチェックボックス構造情報クラス 機能は以下の通り 拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ForecastValues | 需要予測値のデータ転送情報クラス 機能は以下の通り 需要予測値のデータ転送情報を保持します。
HeadData | 管理情報設定ヘッダセグメント情報クラス 機能は以下の通り 管理情報設定ヘッダセグメント情報を保持します。
InternationalArtnos | 国際商品コード (EAN)情報クラス 機能は以下の通り 国際商品コード (EAN)情報を保持します。
MaterialLongText | テキスト (長)情報クラス 機能は以下の通り テキスト (長)情報を保持します。
MaterialSaveReplica | 品目マスタ更新情報クラス 機能は以下の通り 品目マスタ更新情報を保持します。
ParamClientDataList | 品目データ (クライアントレベル)パラメータ設定クラス 機能は以下の通り 品目データ (クライアントレベル)パラメータを設定します。
ParamExtensionIn | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。
ParamExtensionInX | 拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス 機能は以下の通り 拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。
ParamForecastParametersList | 需要予測パラメータ設定クラス 機能は以下の通り 需要予測パラメータのパラメータを設定します。
ParamForecastValues | 需要予測値のデータ転送パラメータ設定クラス 機能は以下の通り 需要予測値のデータ転送のパラメータを設定します。
ParamHeadData | 管理情報設定ヘッダセグメントパラメータ設定クラス 機能は以下の通り 管理情報設定ヘッダセグメントのパラメータを設定します。
ParamInternationalArtnos | 国際商品コード (EAN)パラメータ設定クラス 機能は以下の通り 国際商品コード (EAN)のパラメータを設定します。
ParamMaterialDescription | 品目テキストパラメータ設定クラス 機能は以下の通り 品目テキストのパラメータを設定します。
ParamMaterialLongText | テキスト (長)パラメータ設定クラス 機能は以下の通り テキスト (長)のパラメータを設定します。
ParamPlanningDataList | 品目マスタ/製品グループの変更伝票構造パラメータ設定クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
ParamPlantDataList | 品目データ (プラントレベル)パラメータ設定クラス 機能は以下の通り 品目データ (プラントレベル)のパラメータを設定します。
ParamPrtData | 品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
ParamReturnMessages | リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス 機能は以下の通り リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。
ParamSalesDataList | 倉庫番号データパラメータ設定クラス 機能は以下の通り 倉庫番号データのパラメータを設定します。
ParamStorageLocationDataList | 品目データ (保管場所レベル)パラメータ設定クラス 機能は以下の通り 品目データ (保管場所レベル)のパラメータを設定します。
ParamStorageTypeDataList | 品目データ (保管場所レベル)パラメータ設定クラス 機能は以下の通り 品目データ (保管場所レベル)のパラメータを設定します。
ParamTaxClassifications | 制御デ－タパラメータ設定クラス 機能は以下の通り 制御デ－タのパラメータを設定します。
ParamTotalConsumption | 品目総消費量のデータ転送パラメータ設定クラス 機能は以下の通り 品目総消費量のデータ転送のパラメータを設定します。
ParamUnitSofmeasure | 数量単位パラメータ設定クラス 機能は以下の通り 数量単位のパラメータを設定します。
ParamUnplndConsumption | 計画外消費のデータ転送パラメータ設定クラス 機能は以下の通り 計画外消費のデータ転送のパラメータを設定します。
ParamValuationDataList | 評価データパラメータ設定クラス 機能は以下の通り 評価データのパラメータを設定します。
ParamWarehouseNumberDataList | 倉庫番号データパラメータ設定クラス 機能は以下の通り 倉庫番号データのパラメータを設定します。
PrtData | 品目マスタの生産資源/治工具 (PRT) 項目情報クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
ReturnMessages | リターンパラメータ BAPIRET2 の代替構造情報クラス 機能は以下の通り リターンパラメータ BAPIRET2 の代替構造情報を保持します。
TotalConsumption | 品目総消費量のデータ転送情報クラス 機能は以下の通り 品目総消費量のデータ転送情報を保持します。
UnplndConsumption | 計画外消費のデータ転送情報クラス 機能は以下の通り 計画外消費のデータ転送情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のクラス
ExtensionIn
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionInX
拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ForecastValues
需要予測値のデータ転送情報クラス
機能は以下の通り
需要予測値のデータ転送情報を保持します。
HeadData
管理情報設定ヘッダセグメント情報クラス
機能は以下の通り
管理情報設定ヘッダセグメント情報を保持します。
InternationalArtnos
国際商品コード (EAN)情報クラス
機能は以下の通り
国際商品コード (EAN)情報を保持します。
MaterialLongText
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。
PrtData
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
TotalConsumption
品目総消費量のデータ転送情報クラス
機能は以下の通り
品目総消費量のデータ転送情報を保持します。
UnplndConsumption
計画外消費のデータ転送情報クラス
機能は以下の通り
計画外消費のデータ転送情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamClientDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamClientDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList
すべての実装インタフェース:
Serializable
public final class ParamClientDataList
extends Object
implements Serializable

品目データ (クライアントレベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (クライアントレベル)パラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List clientDataList) table(Export)情報から品目データ (クライアントレベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List clientDataList) 品目データ (クライアントレベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List clientDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (クライアントレベル)の値をセットします。 CLIENTDATA の情報の更新の値をセットします。

パラメータ:
bapiController - BapiController
clientDataList - 品目データ (クライアントレベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List clientDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (クライアントレベル)の値をセットします。

パラメータ:
bapiController - BapiController
clientDataList - 品目データ (クライアントレベル)配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn
すべての実装インタフェース:
Serializable
public final class ParamExtensionIn
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
static void | setTableParam(BapiController bapiController, List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List extensionInList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - EXTENSIONIN/EXTENSIONOUT の参照構造配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamExtensionInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX
すべての実装インタフェース:
Serializable
public final class ParamExtensionInX
extends Object
implements Serializable

拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス
機能は以下の通り

  • 拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInXList) 実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
static void | setTableParam(BapiController bapiController, List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List extensionInXList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
拡張イン/拡張アウトのチェックボックス構造の値をセットします。

パラメータ:
bapiController - BapiController
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInXList)
                           throws SAPGeneralSystemException
実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。

パラメータ:
bapiController - BapiController
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamForecastParametersList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamForecastParametersList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList
すべての実装インタフェース:
Serializable
public final class ParamForecastParametersList
extends Object
implements Serializable

需要予測パラメータ設定クラス
機能は以下の通り

  • 需要予測パラメータのパラメータを設定します。
  • FORECASTDATA の情報の更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List forecastParametersList) table(Export)情報から需要予測パラメータの値をセットします。
static void | setTableParam(BapiController bapiController, List forecastParametersList) 需要予測パラメータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List forecastParametersList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
需要予測パラメータの値をセットします。 FORECASTDATA の情報の更新の値をセットします。

パラメータ:
bapiController - BapiController
forecastParametersList - 需要予測パラメータ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List forecastParametersList)
                           throws SAPGeneralSystemException
table(Export)情報から需要予測パラメータの値をセットします。

パラメータ:
bapiController - BapiController
forecastParametersList - 需要予測パラメータ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamForecastValues (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamForecastValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues
すべての実装インタフェース:
Serializable
public final class ParamForecastValues
extends Object
implements Serializable

需要予測値のデータ転送パラメータ設定クラス
機能は以下の通り

  • 需要予測値のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List forecastValuesList) table(Export)情報から需要予測値のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List forecastValuesList) 需要予測値のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List forecastValuesList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
需要予測値のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
forecastValuesList - 需要予測値のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List forecastValuesList)
                           throws SAPGeneralSystemException
table(Export)情報から需要予測値のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
forecastValuesList - 需要予測値のデータ転送配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeadData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamHeadData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData
すべての実装インタフェース:
Serializable
public final class ParamHeadData
extends Object
implements Serializable

管理情報設定ヘッダセグメントパラメータ設定クラス
機能は以下の通り

  • 管理情報設定ヘッダセグメントのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List headDataList) table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
static void | setTableParam(BapiController bapiController, List headDataList) 管理情報設定ヘッダセグメントの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List headDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
管理情報設定ヘッダセグメントの値をセットします。

パラメータ:
bapiController - BapiController
headDataList - 管理情報設定ヘッダセグメント配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List headDataList)
                           throws SAPGeneralSystemException
table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。

パラメータ:
bapiController - BapiController
headDataList - 管理情報設定ヘッダセグメント
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamInternationalArtnos (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamInternationalArtnos

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos
すべての実装インタフェース:
Serializable
public final class ParamInternationalArtnos
extends Object
implements Serializable

国際商品コード (EAN)パラメータ設定クラス
機能は以下の通り

  • 国際商品コード (EAN)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List internationalArtnosList) table(Export)情報から国際商品コード (EAN)の値をセットします。
static void | setTableParam(BapiController bapiController, List internationalArtnosList) 国際商品コード (EAN)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List internationalArtnosList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
国際商品コード (EAN)の値をセットします。

パラメータ:
bapiController - BapiController
internationalArtnosList - 国際商品コード (EAN)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List internationalArtnosList)
                           throws SAPGeneralSystemException
table(Export)情報から国際商品コード (EAN)の値をセットします。

パラメータ:
bapiController - BapiController
internationalArtnosList - 国際商品コード (EAN)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialDescription (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamMaterialDescription

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription
すべての実装インタフェース:
Serializable
public final class ParamMaterialDescription
extends Object
implements Serializable

品目テキストパラメータ設定クラス
機能は以下の通り

  • 品目テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialDescriptionList) table(Export)情報から品目テキストを設定します。
static void | setTableParam(BapiController bapiController, List materialDescriptionList) 品目テキストの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List materialDescriptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目テキストの値をセットします。

パラメータ:
bapiController - BapiController
materialDescriptionList - 品目テキスト配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialDescriptionList)
                           throws SAPGeneralSystemException
table(Export)情報から品目テキストを設定します。

パラメータ:
bapiController - BapiController
materialDescriptionList - 品目テキスト配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialLongText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamMaterialLongText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText
すべての実装インタフェース:
Serializable
public final class ParamMaterialLongText
extends Object
implements Serializable

テキスト (長)パラメータ設定クラス
機能は以下の通り

  • テキスト (長)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialLongTextList) table(Export)情報からテキスト (長)の値をセットします。
static void | setTableParam(BapiController bapiController, List list) テキスト (長)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List list)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
テキスト (長)の値をセットします。

パラメータ:
bapiController - BapiController
list - テキスト (長)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialLongTextList)
                           throws SAPGeneralSystemException
table(Export)情報からテキスト (長)の値をセットします。

パラメータ:
bapiController - BapiController
materialLongTextList - テキスト (長)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlanningDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPlanningDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList
すべての実装インタフェース:
Serializable
public final class ParamPlanningDataList
extends Object
implements Serializable

品目マスタ/製品グループの変更伝票構造パラメータ設定クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
  • PLANNINGDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List planningDataList) table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | setTableParam(BapiController bapiController, List planningDataList) 品目マスタ/製品グループの変更伝票構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List planningDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目マスタ/製品グループの変更伝票構造の値をセットします。 PLANNINGDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
planningDataList - 品目マスタ/製品グループの変更伝票構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List planningDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。

パラメータ:
bapiController - BapiController
planningDataList - 品目マスタ/製品グループの変更伝票構造
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlantDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPlantDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList
すべての実装インタフェース:
Serializable
public final class ParamPlantDataList
extends Object
implements Serializable

品目データ (プラントレベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (プラントレベル)のパラメータを設定します。
  • PLANTDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List plantDataList) table(Export)情報から品目データ (プラントレベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List plantDataList) 品目データ (プラントレベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List plantDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (プラントレベル)の値をセットします。 PLANTDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
plantDataList - 品目データ (プラントレベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List plantDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (プラントレベル)の値をセットします。

パラメータ:
bapiController - BapiController
plantDataList - 品目データ (プラントレベル)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPrtData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPrtData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData
すべての実装インタフェース:
Serializable
public final class ParamPrtData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
  • PRTDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List prtDataList) table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
static void | setTableParam(BapiController bapiController, List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List prtDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。 PRTDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List prtDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。

パラメータ:
bapiController - BapiController
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamReturnMessages (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamReturnMessages

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages
すべての実装インタフェース:
Serializable
public final class ParamReturnMessages
extends Object
implements Serializable

リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス
機能は以下の通り

  • リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, List returnMessages)
品目マスタ更新結果をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List returnMessages)
                           throws SAPGeneralSystemException
品目マスタ更新結果をセットします。

パラメータ:
bapiController - BapiController
returnMessages - リターンパラメータ BAPIRET2 の代替構造
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSalesDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamSalesDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList
すべての実装インタフェース:
Serializable
public final class ParamSalesDataList
extends Object
implements Serializable

倉庫番号データパラメータ設定クラス
機能は以下の通り

  • 倉庫番号データのパラメータを設定します。
  • WAREHOUSEDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List salesDataList) table(Export)情報から販売データの値をセットします。
static void | setTableParam(BapiController bapiController, List salesDataList) 販売データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List salesDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
販売データの値をセットします。 SALESDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
salesDataList - 販売データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List salesDataList)
                           throws SAPGeneralSystemException
table(Export)情報から販売データの値をセットします。

パラメータ:
bapiController - BapiController
salesDataList - 販売データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStorageLocationDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamStorageLocationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList
すべての実装インタフェース:
Serializable
public final class ParamStorageLocationDataList
extends Object
implements Serializable

品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (保管場所レベル)のパラメータを設定します。
  • STORAGELOCATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeLocDataList) table(Export)情報から品目データ (保管場所レベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List storageLicationDataList) 品目データ (保管場所レベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List storageLicationDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (保管場所レベル)の値をセットします。 STORAGELOCATIONDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
storageLicationDataList - 品目データ (保管場所レベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeLocDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (保管場所レベル)の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocDataList - 品目データ (保管場所レベル)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStorageTypeDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamStorageTypeDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList
すべての実装インタフェース:
Serializable
public final class ParamStorageTypeDataList
extends Object
implements Serializable

品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (保管場所レベル)のパラメータを設定します。
  • STORAGELOCATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeTypeDataList) table(Export)情報から保管域タイプデータの値をセットします。
static void | setTableParam(BapiController bapiController, List storageTypeDataList) 保管域タイプデータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List storageTypeDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
保管域タイプデータの値をセットします。 STORAGETYPEDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
storageTypeDataList - 保管域タイプデータ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeTypeDataList)
                           throws SAPGeneralSystemException
table(Export)情報から保管域タイプデータの値をセットします。

パラメータ:
bapiController - BapiController
stgeTypeDataList - 保管域タイプデータ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTaxClassifications (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamTaxClassifications

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications
すべての実装インタフェース:
Serializable
public final class ParamTaxClassifications
extends Object
implements Serializable

制御デ－タパラメータ設定クラス
機能は以下の通り

  • 制御デ－タのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List taxClassificationsList) table(Export)情報から制御データを設定します。
static void | setTableParam(BapiController bapiController, List taxClassificationsList) 制御デ－タの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List taxClassificationsList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
制御デ－タの値をセットします。

パラメータ:
bapiController - BapiController
taxClassificationsList - 制御デ－タ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List taxClassificationsList)
                           throws SAPGeneralSystemException
table(Export)情報から制御データを設定します。

パラメータ:
bapiController - BapiController
taxClassificationsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTotalConsumption (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamTotalConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption
すべての実装インタフェース:
Serializable
public final class ParamTotalConsumption
extends Object
implements Serializable

品目総消費量のデータ転送パラメータ設定クラス
機能は以下の通り

  • 品目総消費量のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List totalConsumptionList) table(Export)情報から品目総消費量のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List totalConsumptionList) 品目総消費量のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List totalConsumptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目総消費量のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
totalConsumptionList - 品目総消費量のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List totalConsumptionList)
                           throws SAPGeneralSystemException
table(Export)情報から品目総消費量のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
totalConsumptionList - 品目総消費量のデータ転送
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUnitSofmeasure (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamUnitSofmeasure

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure
すべての実装インタフェース:
Serializable
public final class ParamUnitSofmeasure
extends Object
implements Serializable

数量単位パラメータ設定クラス
機能は以下の通り

  • 数量単位のパラメータを設定します。
  • UNITSOFMEASURE の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List unitSofmeasureList) table(Export)情報から数量単位を設定します。
static void | setTableParam(BapiController bapiController, List unitSofmeasureList) 数量単位の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List unitSofmeasureList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
数量単位の値をセットします。 UNITSOFMEASURE の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
unitSofmeasureList - 数量単位配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List unitSofmeasureList)
                           throws SAPGeneralSystemException
table(Export)情報から数量単位を設定します。

パラメータ:
bapiController - BapiController
unitSofmeasureList - 数量単位配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUnplndConsumption (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamUnplndConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption
すべての実装インタフェース:
Serializable
public final class ParamUnplndConsumption
extends Object
implements Serializable

計画外消費のデータ転送パラメータ設定クラス
機能は以下の通り

  • 計画外消費のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List unplndConsumptionList) table(Export)情報から計画外消費のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List unplndConsumptionList) 計画外消費のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List unplndConsumptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
計画外消費のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
unplndConsumptionList - 計画外消費のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List unplndConsumptionList)
                           throws SAPGeneralSystemException
table(Export)情報から計画外消費のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
unplndConsumptionList - 計画外消費のデータ転送
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamValuationDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamValuationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList
すべての実装インタフェース:
Serializable
public final class ParamValuationDataList
extends Object
implements Serializable

評価データパラメータ設定クラス
機能は以下の通り

  • 評価データのパラメータを設定します。
  • VALUATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List valuationDataList) table(Export)情報から評価データの値をセットします。
static void | setTableParam(BapiController bapiController, List valuationDataList) 評価データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List valuationDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
評価データの値をセットします。 VALUATIONDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
valuationDataList - 評価データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List valuationDataList)
                           throws SAPGeneralSystemException
table(Export)情報から評価データの値をセットします。

パラメータ:
bapiController - BapiController
valuationDataList - 評価データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamWarehouseNumberDataList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamWarehouseNumberDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList
すべての実装インタフェース:
Serializable
public final class ParamWarehouseNumberDataList
extends Object
implements Serializable

倉庫番号データパラメータ設定クラス
機能は以下の通り

  • 倉庫番号データのパラメータを設定します。
  • WAREHOUSEDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List whseNoDataList) table(Export)情報から倉庫番号データを設定します。
static void | setTableParam(BapiController bapiController, List warehouseNumberDataList) 倉庫番号データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List warehouseNumberDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
倉庫番号データの値をセットします。 WAREHOUSEDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
warehouseNumberDataList - 倉庫番号データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List whseNoDataList)
                           throws SAPGeneralSystemException
table(Export)情報から倉庫番号データを設定します。

パラメータ:
bapiController - BapiController
whseNoDataList - 倉庫番号データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrtData (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス PrtData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData
すべての実装インタフェース:
Serializable
public class PrtData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PrtData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
メソッドの概要
String | getCreateLoadRecs() 区分: 生産資源/治工具の負荷レコード登録を取得します。
String | getCtrlKey() 生産資源/治工具管理の管理キーを取得します。
String | getCtrlKeyNoChg() 管理キーは変更できませんを取得します。
String | getEndOffset() 生産資源/治工具用途の終了オフセットを取得します。
String | getEndOffsetNoChg() 終了オフセットは変更できませんを取得します。
String | getEndOffsetUnit() 生産資源/治工具使用終了オフセット単位を取得します。
String | getEndOffsetUnitIso() PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
String | getEndRefDate() 生産資源/治工具使用終了日の参照日付を取得します。
String | getEndRefDateNoChg() 終了参照日付は変更できませんを取得します。
String | getFormulaTotQty() 生産資源/治工具の合計数量の計算式を取得します。
String | getFormulaTotQtyNoChg() 合計数量の計算式は変更できませんを取得します。
String | getFormulaTotUsage() 生産資源/治工具の総用途値の計算式を取得します。
String | getFormulaTotUsageNoChg() すべての用途値を計算する計算式は変更できませんを取得します。
String | getFunction() BAPI 機能を取得します。
String | getGrpKey1() 生産資源/治工具のグループキー 1を取得します。
String | getGrpKey2() 生産資源/治工具のグループキー 2を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getPlant() プラントを取得します。
String | getPrtUsage() 生産資源/治工具用途を取得します。
String | getRefKeyNoChg() 参照キーは変更できませんを取得します。
String | getStartOffset() 生産資源/治工具使用の開始オフセットを取得します。
String | getStartOffsetNoChg() 開始オフセットは変更できませんを取得します。
String | getStartOffsetUnit() 生産資源/治工具使用開始のオフセット単位を取得します。
String | getStartOffsetUnitIso() PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
String | getStartRefDate() 生産資源/治工具使用開始の参照日付を取得します。
String | getStdTextKey() 生産資源/治工具の標準テキストキーを取得します。
String | getStRefDateNoChg() 開始参照日付は変更できませんを取得します。
void | setCreateLoadRecs(String createLoadRecs) 区分: 生産資源/治工具の負荷レコード登録を設定します。
void | setCtrlKey(String ctrlKey) 生産資源/治工具管理の管理キーを設定します。
void | setCtrlKeyNoChg(String ctrlKeyNoChg) 管理キーは変更できませんを設定します。
void | setEndOffset(String endOffset) 生産資源/治工具用途の終了オフセットを設定します。
void | setEndOffsetNoChg(String endOffsetNoChg) 終了オフセットは変更できませんを設定します。
void | setEndOffsetUnit(String endOffsetUnit) 生産資源/治工具使用終了オフセット単位を設定します。
void | setEndOffsetUnitIso(String endOffsetUnitIso) PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
void | setEndRefDate(String endRefDate) 生産資源/治工具使用終了日の参照日付を設定します。
void | setEndRefDateNoChg(String endRefDateNoChg) 終了参照日付は変更できませんを設定します。
void | setFormulaTotQty(String formulaTotQty) 生産資源/治工具の合計数量の計算式を設定します。
void | setFormulaTotQtyNoChg(String formulaTotQtyNoChg) 合計数量の計算式は変更できませんを設定します。
void | setFormulaTotUsage(String formulaTotUsage) 生産資源/治工具の総用途値の計算式を設定します。
void | setFormulaTotUsageNoChg(String formulaTotUsageNoChg) すべての用途値を計算する計算式は変更できませんを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGrpKey1(String grpKey1) 生産資源/治工具のグループキー 1を設定します。
void | setGrpKey2(String grpKey2) 生産資源/治工具のグループキー 2を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPrtUsage(String prtUsage) 生産資源/治工具用途を設定します。
void | setRefKeyNoChg(String refKeyNoChg) 参照キーは変更できませんを設定します。
void | setStartOffset(String startOffset) 生産資源/治工具使用の開始オフセットを設定します。
void | setStartOffsetNoChg(String startOffsetNoChg) 開始オフセットは変更できませんを設定します。
void | setStartOffsetUnit(String startOffsetUnit) 生産資源/治工具使用開始のオフセット単位を設定します。
void | setStartOffsetUnitIso(String startOffsetUnitIso) PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
void | setStartRefDate(String startRefDate) 生産資源/治工具使用開始の参照日付を設定します。
void | setStdTextKey(String stdTextKey) 生産資源/治工具の標準テキストキーを設定します。
void | setStRefDateNoChg(String stRefDateNoChg) 開始参照日付は変更できませんを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PrtData

public PrtData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

PrtData

public PrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getCreateLoadRecs

public String getCreateLoadRecs()
区分: 生産資源/治工具の負荷レコード登録を取得します。

戻り値:
createLoadRecs 区分: 生産資源/治工具の負荷レコード登録

getCtrlKey

public String getCtrlKey()
生産資源/治工具管理の管理キーを取得します。

戻り値:
ctrlKey 生産資源/治工具管理の管理キー

getCtrlKeyNoChg

public String getCtrlKeyNoChg()
管理キーは変更できませんを取得します。

戻り値:
ctrlKeyNoChg 管理キーは変更できません

getGrpKey1

public String getGrpKey1()
生産資源/治工具のグループキー 1を取得します。

戻り値:
grpKey_1 生産資源/治工具のグループキー 1

getGrpKey2

public String getGrpKey2()
生産資源/治工具のグループキー 2を取得します。

戻り値:
grpKey_2 生産資源/治工具のグループキー 2

getPrtUsage

public String getPrtUsage()
生産資源/治工具用途を取得します。

戻り値:
prtUsage 生産資源/治工具用途

getStdTextKey

public String getStdTextKey()
生産資源/治工具の標準テキストキーを取得します。

戻り値:
stdTextKey 生産資源/治工具の標準テキストキー

getRefKeyNoChg

public String getRefKeyNoChg()
参照キーは変更できませんを取得します。

戻り値:
refKeyNoChg 参照キーは変更できません

getStartRefDate

public String getStartRefDate()
生産資源/治工具使用開始の参照日付を取得します。

戻り値:
startRefDate 生産資源/治工具使用開始の参照日付

getStRefDateNoChg

public String getStRefDateNoChg()
開始参照日付は変更できませんを取得します。

戻り値:
stRefDateNoChg 開始参照日付は変更できません

getStartOffset

public String getStartOffset()
生産資源/治工具使用の開始オフセットを取得します。

戻り値:
startOffset 生産資源/治工具使用の開始オフセット

getStartOffsetUnit

public String getStartOffsetUnit()
生産資源/治工具使用開始のオフセット単位を取得します。

戻り値:
startOffsetUnit 生産資源/治工具使用開始のオフセット単位

getStartOffsetUnitIso

public String getStartOffsetUnitIso()
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。

戻り値:
startOffsetUnitIso PRT 用途開始決定の間隔時間単位 (ISO)

getStartOffsetNoChg

public String getStartOffsetNoChg()
開始オフセットは変更できませんを取得します。

戻り値:
startOffsetNoChg 開始オフセットは変更できません

getEndRefDate

public String getEndRefDate()
生産資源/治工具使用終了日の参照日付を取得します。

戻り値:
endRefDate 生産資源/治工具使用終了日の参照日付

getEndRefDateNoChg

public String getEndRefDateNoChg()
終了参照日付は変更できませんを取得します。

戻り値:
endRefDateNoChg 終了参照日付は変更できません

getEndOffset

public String getEndOffset()
生産資源/治工具用途の終了オフセットを取得します。

戻り値:
endOffset 生産資源/治工具用途の終了オフセット

getEndOffsetUnit

public String getEndOffsetUnit()
生産資源/治工具使用終了オフセット単位を取得します。

戻り値:
endOffsetUnit 生産資源/治工具使用終了オフセット単位

getEndOffsetUnitIso

public String getEndOffsetUnitIso()
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。

戻り値:
endOffsetUnitIso PRT 用途終了決定の間隔時間単位 (ISO)

getEndOffsetNoChg

public String getEndOffsetNoChg()
終了オフセットは変更できませんを取得します。

戻り値:
endOffsetNoChg 終了オフセットは変更できません

getFormulaTotQty

public String getFormulaTotQty()
生産資源/治工具の合計数量の計算式を取得します。

戻り値:
formulaTotQty 生産資源/治工具の合計数量の計算式

getFormulaTotQtyNoChg

public String getFormulaTotQtyNoChg()
合計数量の計算式は変更できませんを取得します。

戻り値:
formulaTotQtyNoChg 合計数量の計算式は変更できません

getFormulaTotUsage

public String getFormulaTotUsage()
生産資源/治工具の総用途値の計算式を取得します。

戻り値:
formulaTotUsage 生産資源/治工具の総用途値の計算式

getFormulaTotUsageNoChg

public String getFormulaTotUsageNoChg()
すべての用途値を計算する計算式は変更できませんを取得します。

戻り値:
formulaTotUsageNoChg すべての用途値を計算する計算式は変更できません

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setCreateLoadRecs

public void setCreateLoadRecs(String createLoadRecs)
区分: 生産資源/治工具の負荷レコード登録を設定します。

パラメータ:
createLoadRecs - 区分: 生産資源/治工具の負荷レコード登録

setCtrlKey

public void setCtrlKey(String ctrlKey)
生産資源/治工具管理の管理キーを設定します。

パラメータ:
ctrlKey - 生産資源/治工具管理の管理キー

setCtrlKeyNoChg

public void setCtrlKeyNoChg(String ctrlKeyNoChg)
管理キーは変更できませんを設定します。

パラメータ:
ctrlKeyNoChg - 管理キーは変更できません

setGrpKey1

public void setGrpKey1(String grpKey1)
生産資源/治工具のグループキー 1を設定します。

パラメータ:
grpKey1 - 生産資源/治工具のグループキー 1

setGrpKey2

public void setGrpKey2(String grpKey2)
生産資源/治工具のグループキー 2を設定します。

パラメータ:
grpKey2 - 生産資源/治工具のグループキー 2

setPrtUsage

public void setPrtUsage(String prtUsage)
生産資源/治工具用途を設定します。

パラメータ:
prtUsage - 生産資源/治工具用途

setStdTextKey

public void setStdTextKey(String stdTextKey)
生産資源/治工具の標準テキストキーを設定します。

パラメータ:
stdTextKey - 生産資源/治工具の標準テキストキー

setRefKeyNoChg

public void setRefKeyNoChg(String refKeyNoChg)
参照キーは変更できませんを設定します。

パラメータ:
refKeyNoChg - 参照キーは変更できません

setStartRefDate

public void setStartRefDate(String startRefDate)
生産資源/治工具使用開始の参照日付を設定します。

パラメータ:
startRefDate - 生産資源/治工具使用開始の参照日付

setStRefDateNoChg

public void setStRefDateNoChg(String stRefDateNoChg)
開始参照日付は変更できませんを設定します。

パラメータ:
stRefDateNoChg - 開始参照日付は変更できません

setStartOffset

public void setStartOffset(String startOffset)
生産資源/治工具使用の開始オフセットを設定します。

パラメータ:
startOffset - 生産資源/治工具使用の開始オフセット

setStartOffsetUnit

public void setStartOffsetUnit(String startOffsetUnit)
生産資源/治工具使用開始のオフセット単位を設定します。

パラメータ:
startOffsetUnit - 生産資源/治工具使用開始のオフセット単位

setStartOffsetUnitIso

public void setStartOffsetUnitIso(String startOffsetUnitIso)
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。

パラメータ:
startOffsetUnitIso - PRT 用途開始決定の間隔時間単位 (ISO)

setStartOffsetNoChg

public void setStartOffsetNoChg(String startOffsetNoChg)
開始オフセットは変更できませんを設定します。

パラメータ:
startOffsetNoChg - 開始オフセットは変更できません

setEndRefDate

public void setEndRefDate(String endRefDate)
生産資源/治工具使用終了日の参照日付を設定します。

パラメータ:
endRefDate - 生産資源/治工具使用終了日の参照日付

setEndRefDateNoChg

public void setEndRefDateNoChg(String endRefDateNoChg)
終了参照日付は変更できませんを設定します。

パラメータ:
endRefDateNoChg - 終了参照日付は変更できません

setEndOffset

public void setEndOffset(String endOffset)
生産資源/治工具用途の終了オフセットを設定します。

パラメータ:
endOffset - 生産資源/治工具用途の終了オフセット

setEndOffsetUnit

public void setEndOffsetUnit(String endOffsetUnit)
生産資源/治工具使用終了オフセット単位を設定します。

パラメータ:
endOffsetUnit - 生産資源/治工具使用終了オフセット単位

setEndOffsetUnitIso

public void setEndOffsetUnitIso(String endOffsetUnitIso)
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。

パラメータ:
endOffsetUnitIso - PRT 用途終了決定の間隔時間単位 (ISO)

setEndOffsetNoChg

public void setEndOffsetNoChg(String endOffsetNoChg)
終了オフセットは変更できませんを設定します。

パラメータ:
endOffsetNoChg - 終了オフセットは変更できません

setFormulaTotQty

public void setFormulaTotQty(String formulaTotQty)
生産資源/治工具の合計数量の計算式を設定します。

パラメータ:
formulaTotQty - 生産資源/治工具の合計数量の計算式

setFormulaTotQtyNoChg

public void setFormulaTotQtyNoChg(String formulaTotQtyNoChg)
合計数量の計算式は変更できませんを設定します。

パラメータ:
formulaTotQtyNoChg - 合計数量の計算式は変更できません

setFormulaTotUsage

public void setFormulaTotUsage(String formulaTotUsage)
生産資源/治工具の総用途値の計算式を設定します。

パラメータ:
formulaTotUsage - 生産資源/治工具の総用途値の計算式

setFormulaTotUsageNoChg

public void setFormulaTotUsageNoChg(String formulaTotUsageNoChg)
すべての用途値を計算する計算式は変更できませんを設定します。

パラメータ:
formulaTotUsageNoChg - すべての用途値を計算する計算式は変更できません

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReturnMessages (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ReturnMessages

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages
すべての実装インタフェース:
Serializable
public class ReturnMessages
extends Object
implements Serializable

リターンパラメータ BAPIRET2 の代替構造情報クラス
機能は以下の通り

  • リターンパラメータ BAPIRET2 の代替構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ReturnMessages()
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReturnMessages(int index)
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
メソッドの概要
String | getField() パラメータの項目を取得します。
String | getId() メッセージ、メッセージクラスを取得します。
int | getIndex() レコード番号を取得します｡
String | getLogMsgNo() アプリケーションログ: メッセージシリアル番号を取得します。
String | getLogNo() アプリケーションログ: ログ番号を取得します。
String | getMessage() メッセージテキストを取得します。
String | getMessageV1() メッセージ、メッセージ変数を取得します。
String | getMessageV2() メッセージ、メッセージ変数を取得します。
String | getMessageV3() メッセージ、メッセージ変数を取得します。
String | getMessageV4() メッセージ、メッセージ変数を取得します。
String | getNumber() メッセージ、メッセージ番号を取得します。
String | getParameter() パラメータ名を取得します。
String | getRow() パラメータの行を取得します。
String | getSystem() メッセージが発行された論理システムを取得します。
String | getType() メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
void | setField(String field) パラメータの項目を設定します。
void | setId(String id) メッセージ、メッセージクラスを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLogMsgNo(String logMsgNo) アプリケーションログ: メッセージシリアル番号を設定します。
void | setLogNo(String logNo) アプリケーションログ: ログ番号を設定します。
void | setMessage(String message) メッセージテキストを設定します。
void | setMessageV1(String messageV1) メッセージ、メッセージ変数を設定します。
void | setMessageV2(String messageV2) メッセージ、メッセージ変数を設定します。
void | setMessageV3(String messageV3) メッセージ、メッセージ変数を設定します。
void | setMessageV4(String messageV4) メッセージ、メッセージ変数を設定します。
void | setNumber(String number) メッセージ、メッセージ番号を設定します。
void | setParameter(String parameter) パラメータ名を設定します。
void | setRow(String row) パラメータの行を設定します。
void | setSystem(String system) メッセージが発行された論理システムを設定します。
void | setType(String type) メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ReturnMessages

public ReturnMessages()
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

ReturnMessages

public ReturnMessages(int index)
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getType

public String getType()
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。

戻り値:
type メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

getId

public String getId()
メッセージ、メッセージクラスを取得します。

戻り値:
id メッセージ、メッセージクラス

getNumber

public String getNumber()
メッセージ、メッセージ番号を取得します。

戻り値:
number メッセージ、メッセージ番号

getMessage

public String getMessage()
メッセージテキストを取得します。

戻り値:
message メッセージテキスト

getLogNo

public String getLogNo()
アプリケーションログ: ログ番号を取得します。

戻り値:
logNo アプリケーションログ: ログ番号

getLogMsgNo

public String getLogMsgNo()
アプリケーションログ: メッセージシリアル番号を取得します。

戻り値:
logMsgNo アプリケーションログ: メッセージシリアル番号

getMessageV1

public String getMessageV1()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV1 メッセージ、メッセージ変数

getMessageV2

public String getMessageV2()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV2 メッセージ、メッセージ変数

getMessageV3

public String getMessageV3()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV3 メッセージ、メッセージ変数

getMessageV4

public String getMessageV4()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV4 メッセージ、メッセージ変数

getParameter

public String getParameter()
パラメータ名を取得します。

戻り値:
parameter パラメータ名

getRow

public String getRow()
パラメータの行を取得します。

戻り値:
row パラメータの行

getField

public String getField()
パラメータの項目を取得します。

戻り値:
field パラメータの項目

getSystem

public String getSystem()
メッセージが発行された論理システムを取得します。

戻り値:
system メッセージが発行された論理システム

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setType

public void setType(String type)
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。

パラメータ:
type - メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

setId

public void setId(String id)
メッセージ、メッセージクラスを設定します。

パラメータ:
id - メッセージ、メッセージクラス

setNumber

public void setNumber(String number)
メッセージ、メッセージ番号を設定します。

パラメータ:
number - メッセージ、メッセージ番号

setMessage

public void setMessage(String message)
メッセージテキストを設定します。

パラメータ:
message - メッセージテキスト

setLogNo

public void setLogNo(String logNo)
アプリケーションログ: ログ番号を設定します。

パラメータ:
logNo - アプリケーションログ: ログ番号

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
アプリケーションログ: メッセージシリアル番号を設定します。

パラメータ:
logMsgNo - アプリケーションログ: メッセージシリアル番号

setMessageV1

public void setMessageV1(String messageV1)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV1 - メッセージ、メッセージ変数

setMessageV2

public void setMessageV2(String messageV2)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV2 - メッセージ、メッセージ変数

setMessageV3

public void setMessageV3(String messageV3)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV3 - メッセージ、メッセージ変数

setMessageV4

public void setMessageV4(String messageV4)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV4 - メッセージ、メッセージ変数

setParameter

public void setParameter(String parameter)
パラメータ名を設定します。

パラメータ:
parameter - パラメータ名

setRow

public void setRow(String row)
パラメータの行を設定します。

パラメータ:
row - パラメータの行

setField

public void setField(String field)
パラメータの項目を設定します。

パラメータ:
field - パラメータの項目

setSystem

public void setSystem(String system)
メッセージが発行された論理システムを設定します。

パラメータ:
system - メッセージが発行された論理システム

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TotalConsumption (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス TotalConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption
すべての実装インタフェース:
Serializable
public class TotalConsumption
extends Object
implements Serializable

品目総消費量のデータ転送情報クラス
機能は以下の通り

  • 品目総消費量のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TotalConsumption()
品目総消費量のデータ転送情報を作成します。
TotalConsumption(int index)
品目総消費量のデータ転送情報を作成します。
メソッドの概要
String | getConsValue() 消費量を取得します。
String | getCorrValue() 修正消費量を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setConsValue(String consValue) 消費量を設定します。
void | setCorrValue(String corrValue) 修正消費量を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TotalConsumption

public TotalConsumption()
品目総消費量のデータ転送情報を作成します。

TotalConsumption

public TotalConsumption(int index)
品目総消費量のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getConsValue

public String getConsValue()
消費量を取得します。

戻り値:
consValue 消費量

getCorrValue

public String getCorrValue()
修正消費量を取得します。

戻り値:
corrValue 修正消費量

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setConsValue

public void setConsValue(String consValue)
消費量を設定します。

パラメータ:
consValue - 消費量

setCorrValue

public void setCorrValue(String corrValue)
修正消費量を設定します。

パラメータ:
corrValue - 修正消費量

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnplndConsumption (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス UnplndConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption
すべての実装インタフェース:
Serializable
public class UnplndConsumption
extends Object
implements Serializable

計画外消費のデータ転送情報クラス
機能は以下の通り

  • 計画外消費のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UnplndConsumption()
計画外消費のデータ転送情報を作成します。
UnplndConsumption(int index)
計画外消費のデータ転送情報を作成します。
メソッドの概要
String | getConsValue() 消費量を取得します。
String | getCorrValue() 修正消費量を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setConsValue(String consValue) 消費量を設定します。
void | setCorrValue(String corrValue) 修正消費量を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnplndConsumption

public UnplndConsumption()
計画外消費のデータ転送情報を作成します。

UnplndConsumption

public UnplndConsumption(int index)
計画外消費のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getConsValue

public String getConsValue()
消費量を取得します。

戻り値:
consValue 消費量

getCorrValue

public String getCorrValue()
修正消費量を取得します。

戻り値:
corrValue 修正消費量

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setConsValue

public void setConsValue(String consValue)
消費量を設定します。

パラメータ:
consValue - 消費量

setCorrValue

public void setCorrValue(String corrValue)
修正消費量を設定します。

パラメータ:
corrValue - 修正消費量

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス
StdMaterialGetIntNumber
StdMaterialGetIntNumberList


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

クラスの概要
StdMaterialGetIntNumber | 品目コード割当済情報クラス 機能は以下の通り 品目コード割当済の情報を保持します。
StdMaterialGetIntNumberList | 品目コード割当済一覧クラス 機能は以下の通り 品目コード割当済の情報を一覧形式で取得します。


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StdMaterialGetIntNumber (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス StdMaterialGetIntNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumber
extends Object
implements Serializable

品目コード割当済情報クラス
機能は以下の通り

  • 品目コード割当済の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StdMaterialGetIntNumber()
品目コード割当済情報を作成します。
メソッドの概要
String | getMaterial() 品目コードを取得します｡
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します｡
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します｡
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します｡
void | setMaterial(String material) 品目コードを設定します｡
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します｡
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します｡
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumber

public StdMaterialGetIntNumber()
品目コード割当済情報を作成します。

メソッドの詳細

setMaterial

public void setMaterial(String material)
品目コードを設定します｡

パラメータ:
material - 品目コード

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します｡

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します｡

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します｡

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

getMaterial

public String getMaterial()
品目コードを取得します｡

戻り値:
material

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します｡

戻り値:
materialExternal

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します｡

戻り値:
materialGuid

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します｡

戻り値:
materialVersion

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StdMaterialGetIntNumberList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス StdMaterialGetIntNumberList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumberList
extends ReferenceController
implements Serializable

品目コード割当済一覧クラス
機能は以下の通り

  • 品目コード割当済の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。
メソッドの概要
List | getStdMaterialGetIntNumberList() 品目コード割当済一覧を取得します｡
void | setStdMaterialGetIntNumberList(List stdMaterialGetIntNumberList) 品目コード割当済一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumberList

public StdMaterialGetIntNumberList(String materialType,
                                   String industrySector,
                                   String requiredNumbers,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseSystemException,
                                   SAPPurchaseAppException
executeBapiを呼び出し品目コード割当済一覧を作成します。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外
メソッドの詳細

setStdMaterialGetIntNumberList

public void setStdMaterialGetIntNumberList(List stdMaterialGetIntNumberList)
品目コード割当済一覧を設定します｡

パラメータ:
stdMaterialGetIntNumberList - 品目コード割当済一覧

getStdMaterialGetIntNumberList

public List getStdMaterialGetIntNumberList()
品目コード割当済一覧を取得します｡

戻り値:
stdMaterialGetIntNumberList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AllVersions (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス AllVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.AllVersions
すべての実装インタフェース:
Serializable
public class AllVersions
extends Object
implements Serializable

全バージョン管理情報クラス
機能は以下の通り

  • 全バージョン管理情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AllVersions()
バージョン管理を作成します。
AllVersions(int index)
出荷データを作成します。
メソッドの概要
String | getCompleted() ステータス "バージョン完了済"を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCrOn() レコード登録日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDescription() バージョンテキスト（長）を取得します。
String | getDocNumber() 購買管理におけるオブジェクト番号を取得します。
String | getDocType() 購買伝票カテゴリを取得します。
int | getIndex() レコード番号を取得します。
String | getItemNumber() 購買管理オブジェクト: 明細を取得します。
String | getNetValue() 購買発注通貨による正味発注額を取得します。
String | getPostDate() バージョンの転記日付を取得します。
String | getReason() 変更理由を取得します。
String | getRecTime() 登録時刻を取得します。
String | getReleasebyPur() 承認購買担当者名を取得します。
String | getReleaseDate() 承認日を取得します。
String | getReleasedatePur() 購買担当者承認日付を取得します。
String | getReleasedBy() 承認者名を取得します。
String | getReleaseTime() 承認時刻を取得します。
String | getReleasetimePur() 購買担当者承認時刻を取得します。
String | getReqBy() 変更を依頼した従業員を取得します。
String | getReqByExt() バージョンの外部変更番号を取得します。
String | getStatus() バージョンステータスを取得します。
String | getStatusDocOld() このバージョンの前の旧処理状況 (購買伝票内)を取得します。
String | getValueChanged() バージョンによる金額変更を取得します。
String | getVersion() 購買管理におけるバージョン番号を取得します。
void | setCompleted(String strCompleted) ステータス "バージョン完了済"を設定します。
void | setCreatedBy(String strCreatedBy) オブジェクト登録者名を設定します。
void | setCrOn(String strCrOn) レコード登録日を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO コード通貨を設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDescription(String strDescription) バージョンテキスト（長）を設定します。
void | setDocNumber(String strDocNumber) 購買管理におけるオブジェクト番号を設定します。
void | setDocType(String strDocType) 購買伝票カテゴリを設定します。
void | setIndex(int index) レコード番号を設定します。
void | setItemNumber(String strItemNumber) 購買管理オブジェクト: 明細を設定します。
void | setNetValue(String strNetValue) 購買発注通貨による正味発注額を設定します。
void | setPostDate(String strPostDate) バージョンの転記日付を設定します。
void | setReason(String strReason) 変更理由を設定します。
void | setRecTime(String strRecTime) 登録時刻を設定します。
void | setReleasebyPur(String strReleasebyPur) 承認購買担当者名を設定します。
void | setReleaseDate(String strReleaseDate) 承認日を設定します。
void | setReleasedatePur(String strReleasedatePur) 購買担当者承認日付を設定します。
void | setReleasedBy(String strReleasedBy) 承認者名を設定します。
void | setReleaseTime(String strReleaseTime) 承認時刻を設定します。
void | setReleasetimePur(String strReleasetimePur) 購買担当者承認時刻を設定します。
void | setReqBy(String strReqBy) 変更を依頼した従業員を設定します。
void | setReqByExt(String strReqByExt) バージョンの外部変更番号を設定します。
void | setStatus(String strStatus) バージョンステータスを設定します。
void | setStatusDocOld(String strStatusDocOld) このバージョンの前の旧処理状況 (購買伝票内)を設定します。
void | setValueChanged(String strValueChanged) バージョンによる金額変更を設定します。
void | setVersion(String strVersion) 購買管理におけるバージョン番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AllVersions

public AllVersions()
バージョン管理を作成します。

AllVersions

public AllVersions(int index)
出荷データを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocType

public String getDocType()
購買伝票カテゴリを取得します。

戻り値:
srtDocType 購買伝票カテゴリ

getDocNumber

public String getDocNumber()
購買管理におけるオブジェクト番号を取得します。

戻り値:
srtDocNumber 購買管理におけるオブジェクト番号

getItemNumber

public String getItemNumber()
購買管理オブジェクト: 明細を取得します。

戻り値:
srtItemNumber 購買管理オブジェクト: 明細

getVersion

public String getVersion()
購買管理におけるバージョン番号を取得します。

戻り値:
srtVersion 購買管理におけるバージョン番号

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
srtCreatedBy オブジェクト登録者名

getCrOn

public String getCrOn()
レコード登録日を取得します。

戻り値:
srtCrOn レコード登録日

getRecTime

public String getRecTime()
登録時刻を取得します。

戻り値:
srtRecTime 登録時刻

getReleasedBy

public String getReleasedBy()
承認者名を取得します。

戻り値:
srtReleasedBy 承認者名

getReleaseDate

public String getReleaseDate()
承認日を取得します。

戻り値:
srtReleaseDate 承認日

getReleaseTime

public String getReleaseTime()
承認時刻を取得します。

戻り値:
srtReleaseTime 承認時刻

getReleasebyPur

public String getReleasebyPur()
承認購買担当者名を取得します。

戻り値:
srtReleasebyPur 承認購買担当者名

getReleasedatePur

public String getReleasedatePur()
購買担当者承認日付を取得します。

戻り値:
srtReleasedatePur 購買担当者承認日付

getReleasetimePur

public String getReleasetimePur()
購買担当者承認時刻を取得します。

戻り値:
srtReleasetimePur 購買担当者承認時刻

getReason

public String getReason()
変更理由を取得します。

戻り値:
srtReason 変更理由

getDescription

public String getDescription()
バージョンテキスト（長）を取得します。

戻り値:
srtDescription バージョンテキスト（長）

getReqByExt

public String getReqByExt()
バージョンの外部変更番号を取得します。

戻り値:
srtReqByExt バージョンの外部変更番号

getReqBy

public String getReqBy()
変更を依頼した従業員を取得します。

戻り値:
srtReqBy 変更を依頼した従業員

getNetValue

public String getNetValue()
購買発注通貨による正味発注額を取得します。

戻り値:
srtNetValue 購買発注通貨による正味発注額

getValueChanged

public String getValueChanged()
バージョンによる金額変更を取得します。

戻り値:
srtValueChanged バージョンによる金額変更

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrencyIso ISO コード通貨

getPostDate

public String getPostDate()
バージョンの転記日付を取得します。

戻り値:
srtPostDate バージョンの転記日付

getCompleted

public String getCompleted()
ステータス "バージョン完了済"を取得します。

戻り値:
srtCompleted ステータス "バージョン完了済"

getStatus

public String getStatus()
バージョンステータスを取得します。

戻り値:
srtStatus バージョンステータス

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
srtDeleteInd 購買伝票の削除フラグ

getStatusDocOld

public String getStatusDocOld()
このバージョンの前の旧処理状況 (購買伝票内)を取得します。

戻り値:
srtStatusDocOld このバージョンの前の旧処理状況 (購買伝票内)

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setDocType

public void setDocType(String strDocType)
購買伝票カテゴリを設定します。

パラメータ:
strDocType - 購買伝票カテゴリ

setDocNumber

public void setDocNumber(String strDocNumber)
購買管理におけるオブジェクト番号を設定します。

パラメータ:
strDocNumber - 購買管理におけるオブジェクト番号

setItemNumber

public void setItemNumber(String strItemNumber)
購買管理オブジェクト: 明細を設定します。

パラメータ:
strItemNumber - 購買管理オブジェクト: 明細

setVersion

public void setVersion(String strVersion)
購買管理におけるバージョン番号を設定します。

パラメータ:
strVersion - 購買管理におけるバージョン番号

setCreatedBy

public void setCreatedBy(String strCreatedBy)
オブジェクト登録者名を設定します。

パラメータ:
strCreatedBy - オブジェクト登録者名

setCrOn

public void setCrOn(String strCrOn)
レコード登録日を設定します。

パラメータ:
strCrOn - レコード登録日

setRecTime

public void setRecTime(String strRecTime)
登録時刻を設定します。

パラメータ:
strRecTime - 登録時刻

setReleasedBy

public void setReleasedBy(String strReleasedBy)
承認者名を設定します。

パラメータ:
strReleasedBy - 承認者名

setReleaseDate

public void setReleaseDate(String strReleaseDate)
承認日を設定します。

パラメータ:
strReleaseDate - 承認日

setReleaseTime

public void setReleaseTime(String strReleaseTime)
承認時刻を設定します。

パラメータ:
strReleaseTime - 承認時刻

setReleasebyPur

public void setReleasebyPur(String strReleasebyPur)
承認購買担当者名を設定します。

パラメータ:
strReleasebyPur - 承認購買担当者名

setReleasedatePur

public void setReleasedatePur(String strReleasedatePur)
購買担当者承認日付を設定します。

パラメータ:
strReleasedatePur - 購買担当者承認日付

setReleasetimePur

public void setReleasetimePur(String strReleasetimePur)
購買担当者承認時刻を設定します。

パラメータ:
strReleasetimePur - 購買担当者承認時刻

setReason

public void setReason(String strReason)
変更理由を設定します。

パラメータ:
strReason - 変更理由

setDescription

public void setDescription(String strDescription)
バージョンテキスト（長）を設定します。

パラメータ:
strDescription - バージョンテキスト（長）

setReqByExt

public void setReqByExt(String strReqByExt)
バージョンの外部変更番号を設定します。

パラメータ:
strReqByExt - バージョンの外部変更番号

setReqBy

public void setReqBy(String strReqBy)
変更を依頼した従業員を設定します。

パラメータ:
strReqBy - 変更を依頼した従業員

setNetValue

public void setNetValue(String strNetValue)
購買発注通貨による正味発注額を設定します。

パラメータ:
strNetValue - 購買発注通貨による正味発注額

setValueChanged

public void setValueChanged(String strValueChanged)
バージョンによる金額変更を設定します。

パラメータ:
strValueChanged - バージョンによる金額変更

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrencyIso - ISO コード通貨

setPostDate

public void setPostDate(String strPostDate)
バージョンの転記日付を設定します。

パラメータ:
strPostDate - バージョンの転記日付

setCompleted

public void setCompleted(String strCompleted)
ステータス "バージョン完了済"を設定します。

パラメータ:
strCompleted - ステータス "バージョン完了済"

setStatus

public void setStatus(String strStatus)
バージョンステータスを設定します。

パラメータ:
strStatus - バージョンステータス

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setStatusDocOld

public void setStatusDocOld(String strStatusDocOld)
このバージョンの前の旧処理状況 (購買伝票内)を設定します。

パラメータ:
strStatusDocOld - このバージョンの前の旧処理状況 (購買伝票内)

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Cond (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Cond

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Cond
すべての実装インタフェース:
Serializable
public class Cond
extends Object
implements Serializable

条件情報クラス
機能は以下の通り

  • 条件情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Cond()
条件を作成します。
Cond(int index)
条件を作成します。
メソッドの概要
String | getAccessSeq() 検索順序 - 検索番号を取得します。
String | getAccruals() 見越額関連条件 (運賃など)を取得します。
String | getApplicatio() アプリケーションを取得します。
String | getCalctypcon() 条件計算タイプを取得します。
String | getChangeId() 変更タイプ(U、I、E、D)を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getConbaseval() 条件基礎値を取得します。
String | getCondchaman() 条件 (マニュアル変更済)を取得します。
String | getCondclass() 条件クラスを取得します。
String | getCondcntrl() 条件管理を取得します。
String | getCondconfig() システム設定の条件を取得します。
String | getCondcount() 条件連続番号を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getCondincomp() 会社間請求の条件を取得します。
String | getCondisacti() 無効条件を取得します。
String | getConditionNo() 伝票条件番号を取得します。
String | getCondNo() 条件レコード番号を取得します。
String | getCondorigin() 条件生成区分を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondtype() 条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 条件単位を取得します。
String | getCondUnitIso() 条件数量単位 (ISO コード)を取得します。
String | getCondUpdat() 条件更新を取得します。
String | getCondValue() 条件レートを取得します。
String | getConexchrat() 現地通貨への換算レートに対する条件を取得します。
String | getConinvolst() 請求書一覧条件を取得します。
String | getConpricdat() 条件価格設定日付を取得します。
String | getCurrenckey() スケール通貨を取得します。
String | getCurrenckeyIso() ISO コード通貨を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDenominato() 条件単位を基本単位へ変換する分母を取得します。
String | getFactbasval() 条件基礎値に対する要因を取得します。
String | getGroupcond() グループ条件区分を取得します。
String | getItmNumber() 条件明細番号を取得します。
String | getNumconvert() 条件単位を基本単位へ変換する分子を取得します。
String | getScalbasval() 条件のスケール基準値を取得します。
String | getScalebasin() スケール基準区分を取得します。
String | getScaletype() スケールタイプを取得します。
String | getStatCon() 統計に適用する条件を取得します。
String | getUnitmeasur() 条件スケール単位を取得します。
String | getUnitmeasurIso() 単位の ISO コードを取得します。
String | getVendorNo() 仕入先または債権者の勘定コードを取得します。
void | setAccessSeq(String strAccessSeq) 検索順序 - 検索番号を設定します。
void | setAccruals(String strAccruals) 見越額関連条件 (運賃など)を設定します。
void | setApplicatio(String strApplicatio) アプリケーションを設定します。
void | setCalctypcon(String strCalctypcon) 条件計算タイプを設定します。
void | setChangeId(String strChangeId) 変更タイプ(U、I、E、D)を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setConbaseval(String strConbaseval) 条件基礎値を設定します。
void | setCondchaman(String strCondchaman) 条件 (マニュアル変更済)を設定します。
void | setCondclass(String strCondclass) 条件クラスを設定します。
void | setCondcntrl(String strCondcntrl) 条件管理を設定します。
void | setCondconfig(String strCondconfig) システム設定の条件を設定します。
void | setCondcount(String strCondcount) 条件連続番号を設定します。
void | setCondCount(String strCondCount) 条件カウンタを設定します。
void | setCondincomp(String strCondincomp) 会社間請求の条件を設定します。
void | setCondisacti(String strCondisacti) 無効条件を設定します。
void | setConditionNo(String strConditionNo) 伝票条件番号を設定します。
void | setCondNo(String strCondNo) 条件レコード番号を設定します。
void | setCondorigin(String strCondorigin) 条件生成区分を設定します。
void | setCondPUnt(String strCondPUnt) 価格条件単位を設定します。
void | setCondStNo(String strCondStNo) ステップ番号を設定します。
void | setCondtype(String strCondtype) 条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
void | setCondType(String strCondType) 条件タイプを設定します。
void | setCondUnit(String strCondUnit) 条件単位を設定します。
void | setCondUnitIso(String strCondUnitIso) 条件数量単位 (ISO コード)を設定します。
void | setCondUpdat(String strCondUpdat) 条件更新を設定します。
void | setCondValue(String strCondValue) 条件レートを設定します。
void | setConexchrat(String strConexchrat) 現地通貨への換算レートに対する条件を設定します。
void | setConinvolst(String strConinvolst) 請求書一覧条件を設定します。
void | setConpricdat(String strConpricdat) 条件価格設定日付を設定します。
void | setCurrenckey(String strCurrenckey) スケール通貨を設定します。
void | setCurrenckeyIso(String strCurrenckeyIso) ISO コード通貨を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO コード通貨を設定します。
void | setDenominato(String strDenominato) 条件単位を基本単位へ変換する分母を設定します。
void | setFactbasval(String strFactbasval) 条件基礎値に対する要因を設定します。
void | setGroupcond(String strGroupcond) グループ条件区分を設定します。
void | setItmNumber(String strItmNumber) 条件明細番号を設定します。
void | setNumconvert(String strNumconvert) 条件単位を基本単位へ変換する分子を設定します。
void | setScalbasval(String strScalbasval) 条件のスケール基準値を設定します。
void | setScalebasin(String strScalebasin) スケール基準区分を設定します。
void | setScaletype(String strScaletype) スケールタイプを設定します。
void | setStatCon(String strStatCon) 統計に適用する条件を設定します。
void | setUnitmeasur(String strUnitmeasur) 条件スケール単位を設定します。
void | setUnitmeasurIso(String strUnitmeasurIso) 単位の ISO コードを設定します。
void | setVendorNo(String strVendorNo) 仕入先または債権者の勘定コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Cond

public Cond()
条件を作成します。

Cond

public Cond(int index)
条件を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConditionNo

public String getConditionNo()
伝票条件番号を取得します。

戻り値:
srtConditionNo 伝票条件番号

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
srtItmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
srtCondStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
srtCondCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
srtCondType 条件タイプ

getCondValue

public String getCondValue()
条件レートを取得します。

戻り値:
srtCondValue 条件レート

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrencyIso ISO コード通貨

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
srtCondUnit 条件単位

getCondUnitIso

public String getCondUnitIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
srtCondUnitIso 条件数量単位 (ISO コード)

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
srtCondPUnt 価格条件単位

getApplicatio

public String getApplicatio()
アプリケーションを取得します。

戻り値:
srtApplicatio アプリケーション

getConpricdat

public String getConpricdat()
条件価格設定日付を取得します。

戻り値:
srtConpricdat 条件価格設定日付

getCalctypcon

public String getCalctypcon()
条件計算タイプを取得します。

戻り値:
srtCalctypcon 条件計算タイプ

getConbaseval

public String getConbaseval()
条件基礎値を取得します。

戻り値:
srtConbaseval 条件基礎値

getConexchrat

public String getConexchrat()
現地通貨への換算レートに対する条件を取得します。

戻り値:
srtConexchrat 現地通貨への換算レートに対する条件

getNumconvert

public String getNumconvert()
条件単位を基本単位へ変換する分子を取得します。

戻り値:
srtNumconvert 条件単位を基本単位へ変換する分子

getDenominato

public String getDenominato()
条件単位を基本単位へ変換する分母を取得します。

戻り値:
srtDenominato 条件単位を基本単位へ変換する分母

getCondtype

public String getCondtype()
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。

戻り値:
srtCondtype 条件カテゴリ (例: 税、運賃、価格、原価)

getStatCon

public String getStatCon()
統計に適用する条件を取得します。

戻り値:
srtStatCon 統計に適用する条件

getScaletype

public String getScaletype()
スケールタイプを取得します。

戻り値:
srtScaletype スケールタイプ

getAccruals

public String getAccruals()
見越額関連条件 (運賃など)を取得します。

戻り値:
srtAccruals 見越額関連条件 (運賃など)

getConinvolst

public String getConinvolst()
請求書一覧条件を取得します。

戻り値:
srtConinvolst 請求書一覧条件

getCondorigin

public String getCondorigin()
条件生成区分を取得します。

戻り値:
srtCondorigin 条件生成区分

getGroupcond

public String getGroupcond()
グループ条件区分を取得します。

戻り値:
srtGroupcond グループ条件区分

getCondUpdat

public String getCondUpdat()
条件更新を取得します。

戻り値:
srtCondUpdat 条件更新

getAccessSeq

public String getAccessSeq()
検索順序 - 検索番号を取得します。

戻り値:
srtAccessSeq 検索順序 - 検索番号

getCondcount

public String getCondcount()
条件連続番号を取得します。

戻り値:
srtCondcount 条件連続番号

getCondcntrl

public String getCondcntrl()
条件管理を取得します。

戻り値:
srtCondcntrl 条件管理

getCondisacti

public String getCondisacti()
無効条件を取得します。

戻り値:
srtCondisacti 無効条件

getCondclass

public String getCondclass()
条件クラスを取得します。

戻り値:
srtCondclass 条件クラス

getFactbasval

public String getFactbasval()
条件基礎値に対する要因を取得します。

戻り値:
srtFactbasval 条件基礎値に対する要因

getScalebasin

public String getScalebasin()
スケール基準区分を取得します。

戻り値:
srtScalebasin スケール基準区分

getScalbasval

public String getScalbasval()
条件のスケール基準値を取得します。

戻り値:
srtScalbasval 条件のスケール基準値

getUnitmeasur

public String getUnitmeasur()
条件スケール単位を取得します。

戻り値:
srtUnitmeasur 条件スケール単位

getUnitmeasurIso

public String getUnitmeasurIso()
単位の ISO コードを取得します。

戻り値:
srtUnitmeasurIso 単位の ISO コード

getCurrenckey

public String getCurrenckey()
スケール通貨を取得します。

戻り値:
srtCurrenckey スケール通貨

getCurrenckeyIso

public String getCurrenckeyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrenckeyIso ISO コード通貨

getCondincomp

public String getCondincomp()
会社間請求の条件を取得します。

戻り値:
srtCondincomp 会社間請求の条件

getCondconfig

public String getCondconfig()
システム設定の条件を取得します。

戻り値:
srtCondconfig システム設定の条件

getCondchaman

public String getCondchaman()
条件 (マニュアル変更済)を取得します。

戻り値:
srtCondchaman 条件 (マニュアル変更済)

getCondNo

public String getCondNo()
条件レコード番号を取得します。

戻り値:
srtCondNo 条件レコード番号

getChangeId

public String getChangeId()
変更タイプ(U、I、E、D)を取得します。

戻り値:
srtChangeId 変更タイプ(U、I、E、D)

getVendorNo

public String getVendorNo()
仕入先または債権者の勘定コードを取得します。

戻り値:
strVendorNo 仕入先または債権者の勘定コード

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setConditionNo

public void setConditionNo(String strConditionNo)
伝票条件番号を設定します。

パラメータ:
strConditionNo - 伝票条件番号

setItmNumber

public void setItmNumber(String strItmNumber)
条件明細番号を設定します。

パラメータ:
strItmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String strCondStNo)
ステップ番号を設定します。

パラメータ:
strCondStNo - ステップ番号

setCondCount

public void setCondCount(String strCondCount)
条件カウンタを設定します。

パラメータ:
strCondCount - 条件カウンタ

setCondType

public void setCondType(String strCondType)
条件タイプを設定します。

パラメータ:
strCondType - 条件タイプ

setCondValue

public void setCondValue(String strCondValue)
条件レートを設定します。

パラメータ:
strCondValue - 条件レート

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrencyIso - ISO コード通貨

setCondUnit

public void setCondUnit(String strCondUnit)
条件単位を設定します。

パラメータ:
strCondUnit - 条件単位

setCondUnitIso

public void setCondUnitIso(String strCondUnitIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
strCondUnitIso - 条件数量単位 (ISO コード)

setCondPUnt

public void setCondPUnt(String strCondPUnt)
価格条件単位を設定します。

パラメータ:
strCondPUnt - 価格条件単位

setApplicatio

public void setApplicatio(String strApplicatio)
アプリケーションを設定します。

パラメータ:
strApplicatio - アプリケーション

setConpricdat

public void setConpricdat(String strConpricdat)
条件価格設定日付を設定します。

パラメータ:
strConpricdat - 条件価格設定日付

setCalctypcon

public void setCalctypcon(String strCalctypcon)
条件計算タイプを設定します。

パラメータ:
strCalctypcon - 条件計算タイプ

setConbaseval

public void setConbaseval(String strConbaseval)
条件基礎値を設定します。

パラメータ:
strConbaseval - 条件基礎値

setConexchrat

public void setConexchrat(String strConexchrat)
現地通貨への換算レートに対する条件を設定します。

パラメータ:
strConexchrat - 現地通貨への換算レートに対する条件

setNumconvert

public void setNumconvert(String strNumconvert)
条件単位を基本単位へ変換する分子を設定します。

パラメータ:
strNumconvert - 条件単位を基本単位へ変換する分子

setDenominato

public void setDenominato(String strDenominato)
条件単位を基本単位へ変換する分母を設定します。

パラメータ:
strDenominato - 条件単位を基本単位へ変換する分母

setCondtype

public void setCondtype(String strCondtype)
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。

パラメータ:
strCondtype - 条件カテゴリ (例: 税、運賃、価格、原価)

setStatCon

public void setStatCon(String strStatCon)
統計に適用する条件を設定します。

パラメータ:
strStatCon - 統計に適用する条件

setScaletype

public void setScaletype(String strScaletype)
スケールタイプを設定します。

パラメータ:
strScaletype - スケールタイプ

setAccruals

public void setAccruals(String strAccruals)
見越額関連条件 (運賃など)を設定します。

パラメータ:
strAccruals - 見越額関連条件 (運賃など)

setConinvolst

public void setConinvolst(String strConinvolst)
請求書一覧条件を設定します。

パラメータ:
strConinvolst - 請求書一覧条件

setCondorigin

public void setCondorigin(String strCondorigin)
条件生成区分を設定します。

パラメータ:
strCondorigin - 条件生成区分

setGroupcond

public void setGroupcond(String strGroupcond)
グループ条件区分を設定します。

パラメータ:
strGroupcond - グループ条件区分

setCondUpdat

public void setCondUpdat(String strCondUpdat)
条件更新を設定します。

パラメータ:
strCondUpdat - 条件更新

setAccessSeq

public void setAccessSeq(String strAccessSeq)
検索順序 - 検索番号を設定します。

パラメータ:
strAccessSeq - 検索順序 - 検索番号

setCondcount

public void setCondcount(String strCondcount)
条件連続番号を設定します。

パラメータ:
strCondcount - 条件連続番号

setCondcntrl

public void setCondcntrl(String strCondcntrl)
条件管理を設定します。

パラメータ:
strCondcntrl - 条件管理

setCondisacti

public void setCondisacti(String strCondisacti)
無効条件を設定します。

パラメータ:
strCondisacti - 無効条件

setCondclass

public void setCondclass(String strCondclass)
条件クラスを設定します。

パラメータ:
strCondclass - 条件クラス

setFactbasval

public void setFactbasval(String strFactbasval)
条件基礎値に対する要因を設定します。

パラメータ:
strFactbasval - 条件基礎値に対する要因

setScalebasin

public void setScalebasin(String strScalebasin)
スケール基準区分を設定します。

パラメータ:
strScalebasin - スケール基準区分

setScalbasval

public void setScalbasval(String strScalbasval)
条件のスケール基準値を設定します。

パラメータ:
strScalbasval - 条件のスケール基準値

setUnitmeasur

public void setUnitmeasur(String strUnitmeasur)
条件スケール単位を設定します。

パラメータ:
strUnitmeasur - 条件スケール単位

setUnitmeasurIso

public void setUnitmeasurIso(String strUnitmeasurIso)
単位の ISO コードを設定します。

パラメータ:
strUnitmeasurIso - 単位の ISO コード

setCurrenckey

public void setCurrenckey(String strCurrenckey)
スケール通貨を設定します。

パラメータ:
strCurrenckey - スケール通貨

setCurrenckeyIso

public void setCurrenckeyIso(String strCurrenckeyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrenckeyIso - ISO コード通貨

setCondincomp

public void setCondincomp(String strCondincomp)
会社間請求の条件を設定します。

パラメータ:
strCondincomp - 会社間請求の条件

setCondconfig

public void setCondconfig(String strCondconfig)
システム設定の条件を設定します。

パラメータ:
strCondconfig - システム設定の条件

setCondchaman

public void setCondchaman(String strCondchaman)
条件 (マニュアル変更済)を設定します。

パラメータ:
strCondchaman - 条件 (マニュアル変更済)

setCondNo

public void setCondNo(String strCondNo)
条件レコード番号を設定します。

パラメータ:
strCondNo - 条件レコード番号

setChangeId

public void setChangeId(String strChangeId)
変更タイプ(U、I、E、D)を設定します。

パラメータ:
strChangeId - 変更タイプ(U、I、E、D)

setVendorNo

public void setVendorNo(String strVendorNo)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendorNo - 仕入先または債権者の勘定コード

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractLimits (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits
すべての実装インタフェース:
Serializable
public class ContractLimits
extends Object
implements Serializable

外注基本契約制限情報クラス
機能は以下の通り

  • 外注基本契約情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractLimits()
外注基本契約を作成します。
ContractLimits(int index)
外注基本契約を作成します。
メソッドの概要
int | getClIndex() レコード番号を取得します｡
String | getConItem() 明細番号、契約を取得します。
String | getConNumber() 基本契約番号を取得します。
String | getDeleteInd() 削除フラグを取得します。
String | getLimit() 全体制限を取得します。
String | getLineNo() 制限の内部明細番号を取得します。
String | getNoLimit() 制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getShortText() テキスト 1 (短)を取得します。
void | setClIndex(int clIndex) レコード番号を設定します｡
void | setConItem(String strConItem) 明細番号、契約を設定します。
void | setConNumber(String strConNumber) 基本契約番号を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します。
void | setLimit(String strLimit) 全体制限を設定します。
void | setLineNo(String strLineNo) 制限の内部明細番号を設定します。
void | setNoLimit(String strNoLimit) 制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setShortText(String strShortText) テキスト 1 (短)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractLimits

public ContractLimits()
外注基本契約を作成します。

ContractLimits

public ContractLimits(int index)
外注基本契約を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
制限の内部明細番号を取得します。

戻り値:
srtLineNo 制限の内部明細番号

getConNumber

public String getConNumber()
基本契約番号を取得します。

戻り値:
srtConNumber 基本契約番号

getConItem

public String getConItem()
明細番号、契約を取得します。

戻り値:
srtConItem 明細番号、契約

getLimit

public String getLimit()
全体制限を取得します。

戻り値:
srtLimit 全体制限

getNoLimit

public String getNoLimit()
制限なしを取得します。

戻り値:
srtNoLimit 制限なし

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getShortText

public String getShortText()
テキスト 1 (短)を取得します。

戻り値:
srtShortText テキスト 1 (短)

getDeleteInd

public String getDeleteInd()
削除フラグを取得します。

戻り値:
srtDeleteInd 削除フラグ

getClIndex

public int getClIndex()
レコード番号を取得します｡

戻り値:
clIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
制限の内部明細番号を設定します。

パラメータ:
strLineNo - 制限の内部明細番号

setConNumber

public void setConNumber(String strConNumber)
基本契約番号を設定します。

パラメータ:
strConNumber - 基本契約番号

setConItem

public void setConItem(String strConItem)
明細番号、契約を設定します。

パラメータ:
strConItem - 明細番号、契約

setLimit

public void setLimit(String strLimit)
全体制限を設定します。

パラメータ:
strLimit - 全体制限

setNoLimit

public void setNoLimit(String strNoLimit)
制限なしを設定します。

パラメータ:
strNoLimit - 制限なし

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setShortText

public void setShortText(String strShortText)
テキスト 1 (短)を設定します。

パラメータ:
strShortText - テキスト 1 (短)

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します。

パラメータ:
strDeleteInd - 削除フラグ

setClIndex

public void setClIndex(int clIndex)
レコード番号を設定します｡

パラメータ:
clIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractService (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractService

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractService
すべての実装インタフェース:
Serializable
public class ContractService
extends Object
implements Serializable

外注サービス情報クラス
機能は以下の通り

  • 外注サービス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractService()
外注サービスを作成します。
ContractService(int index)
外注サービスを作成します。
メソッドの概要
String | getAlternat() 代替明細を取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBasicLine() 基本明細を取得します。
String | getBaslineNo() 代替: 基本明細参照を取得します。
String | getBegintime() 開始時刻を取得します。
String | getBidder() 入札者の明細を取得します。
String | getBlanket() 包括明細を取得します。
String | getConLine() 入力: 基本契約の計画外を取得します。
String | getConPckg() 入力: 基本契約の計画外を取得します。
int | getCsIndex() レコード番号を取得します｡
String | getDate() 日付を取得します。
String | getDeleteInd() 削除フラグを取得します。
String | getDistrib() 複数勘定設定の配賦区分を取得します。
String | getEdition() サービスタイプのバージョンを取得します。
String | getEndtime() 終了時刻を取得します。
String | getEventual() 偶発的明細を取得します。
String | getExtLine() 明細番号を取得します。
String | getExtpersNo() 外部従業員番号を取得します。
String | getExtrefkey() サービスの外部参照キーを取得します。
String | getExtServ() 仕入先のサービス番号を取得します。
String | getFormula() 計算式番号を取得します。
String | getFormVal1() 計算式値を取得します。
String | getFormVal2() 計算式値を取得します。
String | getFormVal3() 計算式値を取得します。
String | getFormVal4() 計算式値を取得します。
String | getFormVal5() 計算式値を取得します。
String | getFromLine() 下限を取得します。
String | getGrPrice() 基準額を取得します。
String | getHiLineNo() 上位階層明細番号を取得します。
String | getInform() 情報行を取得します。
String | getLimitLine() 入力: 計画外、明細制限を取得します。
String | getLineNo() 内部明細番号を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getOpenQty() 未処理数量のある明細を取得します。
String | getOutlInd() 区分: 出力行を取得します。
String | getOutlLevel() グループの階層レベルを取得します。
String | getOutlNo() アウトラインレベルを取得します。
String | getOvfTol() 超過許容値を取得します。
String | getOvfUnlim() 契約外サービス制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPersNo() 従業員番号を取得します。
String | getPlnLine() 入力: 計画梱包明細行を取得します。
String | getPlnPckg() パッケージ番号供給元一覧を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getQuantity() +/- 記号あり/なし数量を取得します。
String | getService() 活動番号を取得します。
String | getServType() サービスタイプのテキスト (短)を取得します。
String | getShortText() テキスト(短)を取得します。
String | getSscItem() 標準サービスカタログ: 明細を取得します。
String | getSscLim() 標準サービスカタログ制限参照のサービス行を取得します。
String | getSubpckgNo() サブパッケージ番号を取得します。
String | getSuppLine() 補足明細を取得します。
String | getTargetVal() 目標値を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTmpLine() 入力: モデル仕様からの計画外サービスを取得します。
String | getTmpPckg() 入力: モデル仕様からの計画外サービスを取得します。
String | getToLine() 上限を取得します。
String | getUomIso() 単位の ISO コードを取得します。
String | getUserf1Num() ユーザ定義項目を取得します。
String | getUserf1Txt() ユーザ定義項目を取得します。
String | getUserf2Num() ユーザ定義項目を取得します。
String | getUserf2Txt() ユーザ定義項目を取得します。
String | getWagetype() ウェイジタイプを取得します。
void | setAlternat(String strAlternat) 代替明細を設定します。
void | setBaseUom(String strBaseUom) 基本数量単位を設定します。
void | setBasicLine(String strBasicLine) 基本明細を設定します。
void | setBaslineNo(String strBaslineNo) 代替: 基本明細参照を設定します。
void | setBegintime(String strBegintime) 開始時刻を設定します。
void | setBidder(String strBidder) 入札者の明細を設定します。
void | setBlanket(String strBlanket) 包括明細を設定します。
void | setConLine(String strConLine) 入力: 基本契約の計画外を設定します。
void | setConPckg(String strConPckg) 入力: 基本契約の計画外を設定します。
void | setCsIndex(int csIndex) レコード番号を設定します｡
void | setDate(String strDate) 日付を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します。
void | setDistrib(String strDistrib) 複数勘定設定の配賦区分を設定します。
void | setEdition(String strEdition) サービスタイプのバージョンを設定します。
void | setEndtime(String strEndtime) 終了時刻を設定します。
void | setEventual(String strEventual) 偶発的明細を設定します。
void | setExtLine(String strExtLine) 明細番号を設定します。
void | setExtpersNo(String strExtpersNo) 外部従業員番号を設定します。
void | setExtrefkey(String strExtrefkey) サービスの外部参照キーを設定します。
void | setExtServ(String strExtServ) 仕入先のサービス番号を設定します。
void | setFormula(String strFormula) 計算式番号を設定します。
void | setFormVal1(String strFormVal1) 計算式値を設定します。
void | setFormVal2(String strFormVal2) 計算式値を設定します。
void | setFormVal3(String strFormVal3) 計算式値を設定します。
void | setFormVal4(String strFormVal4) 計算式値を設定します。
void | setFormVal5(String strFormVal5) 計算式値を設定します。
void | setFromLine(String strFromLine) 下限を設定します。
void | setGrPrice(String strGrPrice) 基準額を設定します。
void | setHiLineNo(String strHiLineNo) 上位階層明細番号を設定します。
void | setInform(String strInform) 情報行を設定します。
void | setLimitLine(String strLimitLine) 入力: 計画外、明細制限を設定します。
void | setLineNo(String strLineNo) 内部明細番号を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setOpenQty(String strOpenQty) 未処理数量のある明細を設定します。
void | setOutlInd(String strOutlInd) 区分: 出力行を設定します。
void | setOutlLevel(String strOutlLevel) グループの階層レベルを設定します。
void | setOutlNo(String strOutlNo) アウトラインレベルを設定します。
void | setOvfTol(String strOvfTol) 超過許容値を設定します。
void | setOvfUnlim(String strOvfUnlim) 契約外サービス制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPersNo(String strPersNo) 従業員番号を設定します。
void | setPlnLine(String strPlnLine) 入力: 計画梱包明細行を設定します。
void | setPlnPckg(String strPlnPckg) パッケージ番号供給元一覧を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setQuantity(String strQuantity) +/- 記号あり/なし数量を設定します。
void | setService(String strService) 活動番号を設定します。
void | setServType(String strServType) サービスタイプのテキスト (短)を設定します。
void | setShortText(String strShortText) テキスト(短)を設定します。
void | setSscItem(String strSscItem) 標準サービスカタログ: 明細を設定します。
void | setSscLim(String strSscLim) 標準サービスカタログ制限参照のサービス行を設定します。
void | setSubpckgNo(String strSubpckgNo) サブパッケージ番号を設定します。
void | setSuppLine(String strSuppLine) 補足明細を設定します。
void | setTargetVal(String strTargetVal) 目標値を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTmpLine(String strTmpLine) 入力: モデル仕様からの計画外サービスを設定します。
void | setTmpPckg(String strTmpPckg) 入力: モデル仕様からの計画外サービスを設定します。
void | setToLine(String strToLine) 上限を設定します。
void | setUomIso(String strUomIso) 単位の ISO コードを設定します。
void | setUserf1Num(String strUserf1Num) ユーザ定義項目を設定します。
void | setUserf1Txt(String strUserf1Txt) ユーザ定義項目を設定します。
void | setUserf2Num(String strUserf2Num) ユーザ定義項目を設定します。
void | setUserf2Txt(String strUserf2Txt) ユーザ定義項目を設定します。
void | setWagetype(String strWagetype) ウェイジタイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractService

public ContractService()
外注サービスを作成します。

ContractService

public ContractService(int index)
外注サービスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
内部明細番号を取得します。

戻り値:
srtLineNo 内部明細番号

getExtLine

public String getExtLine()
明細番号を取得します。

戻り値:
srtExtLine 明細番号

getOutlLevel

public String getOutlLevel()
グループの階層レベルを取得します。

戻り値:
srtOutlLevel グループの階層レベル

getOutlNo

public String getOutlNo()
アウトラインレベルを取得します。

戻り値:
srtOutlNo アウトラインレベル

getOutlInd

public String getOutlInd()
区分: 出力行を取得します。

戻り値:
srtOutlInd 区分: 出力行

getSubpckgNo

public String getSubpckgNo()
サブパッケージ番号を取得します。

戻り値:
srtSubpckgNo サブパッケージ番号

getService

public String getService()
活動番号を取得します。

戻り値:
srtService 活動番号

getServType

public String getServType()
サービスタイプのテキスト (短)を取得します。

戻り値:
srtServType サービスタイプのテキスト (短)

getEdition

public String getEdition()
サービスタイプのバージョンを取得します。

戻り値:
srtEdition サービスタイプのバージョン

getSscItem

public String getSscItem()
標準サービスカタログ: 明細を取得します。

戻り値:
srtSscItem 標準サービスカタログ: 明細

getExtServ

public String getExtServ()
仕入先のサービス番号を取得します。

戻り値:
srtExtServ 仕入先のサービス番号

getQuantity

public String getQuantity()
+/- 記号あり/なし数量を取得します。

戻り値:
srtQuantity +/- 記号あり/なし数量

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
srtBaseUom 基本数量単位

getUomIso

public String getUomIso()
単位の ISO コードを取得します。

戻り値:
srtUomIso 単位の ISO コード

getOvfTol

public String getOvfTol()
超過許容値を取得します。

戻り値:
srtOvfTol 超過許容値

getOvfUnlim

public String getOvfUnlim()
契約外サービス制限なしを取得します。

戻り値:
srtOvfUnlim 契約外サービス制限なし

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
srtPriceUnit 価格単位

getGrPrice

public String getGrPrice()
基準額を取得します。

戻り値:
srtGrPrice 基準額

getFromLine

public String getFromLine()
下限を取得します。

戻り値:
srtFromLine 下限

getToLine

public String getToLine()
上限を取得します。

戻り値:
srtToLine 上限

getShortText

public String getShortText()
テキスト(短)を取得します。

戻り値:
srtShortText テキスト(短)

getDistrib

public String getDistrib()
複数勘定設定の配賦区分を取得します。

戻り値:
srtDistrib 複数勘定設定の配賦区分

getPersNo

public String getPersNo()
従業員番号を取得します。

戻り値:
srtPersNo 従業員番号

getWagetype

public String getWagetype()
ウェイジタイプを取得します。

戻り値:
srtWagetype ウェイジタイプ

getPlnPckg

public String getPlnPckg()
パッケージ番号供給元一覧を取得します。

戻り値:
srtPlnPckg パッケージ番号供給元一覧

getPlnLine

public String getPlnLine()
入力: 計画梱包明細行を取得します。

戻り値:
srtPlnLine 入力: 計画梱包明細行

getConPckg

public String getConPckg()
入力: 基本契約の計画外を取得します。

戻り値:
srtConPckg 入力: 基本契約の計画外

getConLine

public String getConLine()
入力: 基本契約の計画外を取得します。

戻り値:
srtConLine 入力: 基本契約の計画外

getTmpPckg

public String getTmpPckg()
入力: モデル仕様からの計画外サービスを取得します。

戻り値:
srtTmpPckg 入力: モデル仕様からの計画外サービス

getTmpLine

public String getTmpLine()
入力: モデル仕様からの計画外サービスを取得します。

戻り値:
srtTmpLine 入力: モデル仕様からの計画外サービス

getSscLim

public String getSscLim()
標準サービスカタログ制限参照のサービス行を取得します。

戻り値:
srtSscLim 標準サービスカタログ制限参照のサービス行

getLimitLine

public String getLimitLine()
入力: 計画外、明細制限を取得します。

戻り値:
srtLimitLine 入力: 計画外、明細制限

getTargetVal

public String getTargetVal()
目標値を取得します。

戻り値:
srtTargetVal 目標値

getBaslineNo

public String getBaslineNo()
代替: 基本明細参照を取得します。

戻り値:
srtBaslineNo 代替: 基本明細参照

getBasicLine

public String getBasicLine()
基本明細を取得します。

戻り値:
srtBasicLine 基本明細

getAlternat

public String getAlternat()
代替明細を取得します。

戻り値:
srtAlternat 代替明細

getBidder

public String getBidder()
入札者の明細を取得します。

戻り値:
srtBidder 入札者の明細

getSuppLine

public String getSuppLine()
補足明細を取得します。

戻り値:
srtSuppLine 補足明細

getOpenQty

public String getOpenQty()
未処理数量のある明細を取得します。

戻り値:
srtOpenQty 未処理数量のある明細

getInform

public String getInform()
情報行を取得します。

戻り値:
srtInform 情報行

getBlanket

public String getBlanket()
包括明細を取得します。

戻り値:
srtBlanket 包括明細

getEventual

public String getEventual()
偶発的明細を取得します。

戻り値:
srtEventual 偶発的明細

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
srtTaxCode 消費税コード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getDate

public String getDate()
日付を取得します。

戻り値:
srtDate 日付

getBegintime

public String getBegintime()
開始時刻を取得します。

戻り値:
srtBegintime 開始時刻

getEndtime

public String getEndtime()
終了時刻を取得します。

戻り値:
srtEndtime 終了時刻

getExtpersNo

public String getExtpersNo()
外部従業員番号を取得します。

戻り値:
srtExtpersNo 外部従業員番号

getFormula

public String getFormula()
計算式番号を取得します。

戻り値:
srtFormula 計算式番号

getFormVal1

public String getFormVal1()
計算式値を取得します。

戻り値:
srtFormVal1 計算式値

getFormVal2

public String getFormVal2()
計算式値を取得します。

戻り値:
srtFormVal2 計算式値

getFormVal3

public String getFormVal3()
計算式値を取得します。

戻り値:
srtFormVal3 計算式値

getFormVal4

public String getFormVal4()
計算式値を取得します。

戻り値:
srtFormVal4 計算式値

getFormVal5

public String getFormVal5()
計算式値を取得します。

戻り値:
srtFormVal5 計算式値

getUserf1Num

public String getUserf1Num()
ユーザ定義項目を取得します。

戻り値:
srtUserf1Num ユーザ定義項目

getUserf2Num

public String getUserf2Num()
ユーザ定義項目を取得します。

戻り値:
srtUserf2Num ユーザ定義項目

getUserf1Txt

public String getUserf1Txt()
ユーザ定義項目を取得します。

戻り値:
srtUserf1Txt ユーザ定義項目

getUserf2Txt

public String getUserf2Txt()
ユーザ定義項目を取得します。

戻り値:
srtUserf2Txt ユーザ定義項目

getHiLineNo

public String getHiLineNo()
上位階層明細番号を取得します。

戻り値:
srtHiLineNo 上位階層明細番号

getExtrefkey

public String getExtrefkey()
サービスの外部参照キーを取得します。

戻り値:
srtExtrefkey サービスの外部参照キー

getDeleteInd

public String getDeleteInd()
削除フラグを取得します。

戻り値:
srtDeleteInd 削除フラグ

getCsIndex

public int getCsIndex()
レコード番号を取得します｡

戻り値:
csIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
内部明細番号を設定します。

パラメータ:
strLineNo - 内部明細番号

setExtLine

public void setExtLine(String strExtLine)
明細番号を設定します。

パラメータ:
strExtLine - 明細番号

setOutlLevel

public void setOutlLevel(String strOutlLevel)
グループの階層レベルを設定します。

パラメータ:
strOutlLevel - グループの階層レベル

setOutlNo

public void setOutlNo(String strOutlNo)
アウトラインレベルを設定します。

パラメータ:
strOutlNo - アウトラインレベル

setOutlInd

public void setOutlInd(String strOutlInd)
区分: 出力行を設定します。

パラメータ:
strOutlInd - 区分: 出力行

setSubpckgNo

public void setSubpckgNo(String strSubpckgNo)
サブパッケージ番号を設定します。

パラメータ:
strSubpckgNo - サブパッケージ番号

setService

public void setService(String strService)
活動番号を設定します。

パラメータ:
strService - 活動番号

setServType

public void setServType(String strServType)
サービスタイプのテキスト (短)を設定します。

パラメータ:
strServType - サービスタイプのテキスト (短)

setEdition

public void setEdition(String strEdition)
サービスタイプのバージョンを設定します。

パラメータ:
strEdition - サービスタイプのバージョン

setSscItem

public void setSscItem(String strSscItem)
標準サービスカタログ: 明細を設定します。

パラメータ:
strSscItem - 標準サービスカタログ: 明細

setExtServ

public void setExtServ(String strExtServ)
仕入先のサービス番号を設定します。

パラメータ:
strExtServ - 仕入先のサービス番号

setQuantity

public void setQuantity(String strQuantity)
+/- 記号あり/なし数量を設定します。

パラメータ:
strQuantity - +/- 記号あり/なし数量

setBaseUom

public void setBaseUom(String strBaseUom)
基本数量単位を設定します。

パラメータ:
strBaseUom - 基本数量単位

setUomIso

public void setUomIso(String strUomIso)
単位の ISO コードを設定します。

パラメータ:
strUomIso - 単位の ISO コード

setOvfTol

public void setOvfTol(String strOvfTol)
超過許容値を設定します。

パラメータ:
strOvfTol - 超過許容値

setOvfUnlim

public void setOvfUnlim(String strOvfUnlim)
契約外サービス制限なしを設定します。

パラメータ:
strOvfUnlim - 契約外サービス制限なし

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setGrPrice

public void setGrPrice(String strGrPrice)
基準額を設定します。

パラメータ:
strGrPrice - 基準額

setFromLine

public void setFromLine(String strFromLine)
下限を設定します。

パラメータ:
strFromLine - 下限

setToLine

public void setToLine(String strToLine)
上限を設定します。

パラメータ:
strToLine - 上限

setShortText

public void setShortText(String strShortText)
テキスト(短)を設定します。

パラメータ:
strShortText - テキスト(短)

setDistrib

public void setDistrib(String strDistrib)
複数勘定設定の配賦区分を設定します。

パラメータ:
strDistrib - 複数勘定設定の配賦区分

setPersNo

public void setPersNo(String strPersNo)
従業員番号を設定します。

パラメータ:
strPersNo - 従業員番号

setWagetype

public void setWagetype(String strWagetype)
ウェイジタイプを設定します。

パラメータ:
strWagetype - ウェイジタイプ

setPlnPckg

public void setPlnPckg(String strPlnPckg)
パッケージ番号供給元一覧を設定します。

パラメータ:
strPlnPckg - パッケージ番号供給元一覧

setPlnLine

public void setPlnLine(String strPlnLine)
入力: 計画梱包明細行を設定します。

パラメータ:
strPlnLine - 入力: 計画梱包明細行

setConPckg

public void setConPckg(String strConPckg)
入力: 基本契約の計画外を設定します。

パラメータ:
strConPckg - 入力: 基本契約の計画外

setConLine

public void setConLine(String strConLine)
入力: 基本契約の計画外を設定します。

パラメータ:
strConLine - 入力: 基本契約の計画外

setTmpPckg

public void setTmpPckg(String strTmpPckg)
入力: モデル仕様からの計画外サービスを設定します。

パラメータ:
strTmpPckg - 入力: モデル仕様からの計画外サービス

setTmpLine

public void setTmpLine(String strTmpLine)
入力: モデル仕様からの計画外サービスを設定します。

パラメータ:
strTmpLine - 入力: モデル仕様からの計画外サービス

setSscLim

public void setSscLim(String strSscLim)
標準サービスカタログ制限参照のサービス行を設定します。

パラメータ:
strSscLim - 標準サービスカタログ制限参照のサービス行

setLimitLine

public void setLimitLine(String strLimitLine)
入力: 計画外、明細制限を設定します。

パラメータ:
strLimitLine - 入力: 計画外、明細制限

setTargetVal

public void setTargetVal(String strTargetVal)
目標値を設定します。

パラメータ:
strTargetVal - 目標値

setBaslineNo

public void setBaslineNo(String strBaslineNo)
代替: 基本明細参照を設定します。

パラメータ:
strBaslineNo - 代替: 基本明細参照

setBasicLine

public void setBasicLine(String strBasicLine)
基本明細を設定します。

パラメータ:
strBasicLine - 基本明細

setAlternat

public void setAlternat(String strAlternat)
代替明細を設定します。

パラメータ:
strAlternat - 代替明細

setBidder

public void setBidder(String strBidder)
入札者の明細を設定します。

パラメータ:
strBidder - 入札者の明細

setSuppLine

public void setSuppLine(String strSuppLine)
補足明細を設定します。

パラメータ:
strSuppLine - 補足明細

setOpenQty

public void setOpenQty(String strOpenQty)
未処理数量のある明細を設定します。

パラメータ:
strOpenQty - 未処理数量のある明細

setInform

public void setInform(String strInform)
情報行を設定します。

パラメータ:
strInform - 情報行

setBlanket

public void setBlanket(String strBlanket)
包括明細を設定します。

パラメータ:
strBlanket - 包括明細

setEventual

public void setEventual(String strEventual)
偶発的明細を設定します。

パラメータ:
strEventual - 偶発的明細

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setDate

public void setDate(String strDate)
日付を設定します。

パラメータ:
strDate - 日付

setBegintime

public void setBegintime(String strBegintime)
開始時刻を設定します。

パラメータ:
strBegintime - 開始時刻

setEndtime

public void setEndtime(String strEndtime)
終了時刻を設定します。

パラメータ:
strEndtime - 終了時刻

setExtpersNo

public void setExtpersNo(String strExtpersNo)
外部従業員番号を設定します。

パラメータ:
strExtpersNo - 外部従業員番号

setFormula

public void setFormula(String strFormula)
計算式番号を設定します。

パラメータ:
strFormula - 計算式番号

setFormVal1

public void setFormVal1(String strFormVal1)
計算式値を設定します。

パラメータ:
strFormVal1 - 計算式値

setFormVal2

public void setFormVal2(String strFormVal2)
計算式値を設定します。

パラメータ:
strFormVal2 - 計算式値

setFormVal3

public void setFormVal3(String strFormVal3)
計算式値を設定します。

パラメータ:
strFormVal3 - 計算式値

setFormVal4

public void setFormVal4(String strFormVal4)
計算式値を設定します。

パラメータ:
strFormVal4 - 計算式値

setFormVal5

public void setFormVal5(String strFormVal5)
計算式値を設定します。

パラメータ:
strFormVal5 - 計算式値

setUserf1Num

public void setUserf1Num(String strUserf1Num)
ユーザ定義項目を設定します。

パラメータ:
strUserf1Num - ユーザ定義項目

setUserf2Num

public void setUserf2Num(String strUserf2Num)
ユーザ定義項目を設定します。

パラメータ:
strUserf2Num - ユーザ定義項目

setUserf1Txt

public void setUserf1Txt(String strUserf1Txt)
ユーザ定義項目を設定します。

パラメータ:
strUserf1Txt - ユーザ定義項目

setUserf2Txt

public void setUserf2Txt(String strUserf2Txt)
ユーザ定義項目を設定します。

パラメータ:
strUserf2Txt - ユーザ定義項目

setHiLineNo

public void setHiLineNo(String strHiLineNo)
上位階層明細番号を設定します。

パラメータ:
strHiLineNo - 上位階層明細番号

setExtrefkey

public void setExtrefkey(String strExtrefkey)
サービスの外部参照キーを設定します。

パラメータ:
strExtrefkey - サービスの外部参照キー

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します。

パラメータ:
strDeleteInd - 削除フラグ

setCsIndex

public void setCsIndex(int csIndex)
レコード番号を設定します｡

パラメータ:
csIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractServiceAccount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractServiceAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount
すべての実装インタフェース:
Serializable
public class ContractServiceAccount
extends Object
implements Serializable

外注サービス勘定設定情報クラス
機能は以下の通り

  • 外注サービス勘定設定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractServiceAccount()
外注サービス勘定設定を作成します。
ContractServiceAccount(int index)
外注サービス勘定設定を作成します。
メソッドの概要
String | getLineNo() 明細行番号を取得します。
String | getNetValue() 明細の正味額を取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPercentage() 勘定設定金額配賦のパーセントを取得します。
String | getQuantity() +/- 記号あり/なし数量を取得します。
int | getSaIndex() レコード番号を取得します｡
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getSernoLine() 勘定コード設定のシリアル番号、サービス明細を取得します。
void | setLineNo(String strLineNo) 明細行番号を設定します。
void | setNetValue(String strNetValue) 明細の正味額を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPercentage(String strPercentage) 勘定設定金額配賦のパーセントを設定します。
void | setQuantity(String strQuantity) +/- 記号あり/なし数量を設定します。
void | setSaIndex(int saIndex) レコード番号を設定します｡
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setSernoLine(String strSernoLine) 勘定コード設定のシリアル番号、サービス明細を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractServiceAccount

public ContractServiceAccount()
外注サービス勘定設定を作成します。

ContractServiceAccount

public ContractServiceAccount(int index)
外注サービス勘定設定を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
明細行番号を取得します。

戻り値:
srtLineNo 明細行番号

getSernoLine

public String getSernoLine()
勘定コード設定のシリアル番号、サービス明細を取得します。

戻り値:
srtSernoLine 勘定コード設定のシリアル番号、サービス明細

getPercentage

public String getPercentage()
勘定設定金額配賦のパーセントを取得します。

戻り値:
srtPercentage 勘定設定金額配賦のパーセント

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getQuantity

public String getQuantity()
+/- 記号あり/なし数量を取得します。

戻り値:
srtQuantity +/- 記号あり/なし数量

getNetValue

public String getNetValue()
明細の正味額を取得します。

戻り値:
srtNetValue 明細の正味額

getSaIndex

public int getSaIndex()
レコード番号を取得します｡

戻り値:
saIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
明細行番号を設定します。

パラメータ:
strLineNo - 明細行番号

setSernoLine

public void setSernoLine(String strSernoLine)
勘定コード設定のシリアル番号、サービス明細を設定します。

パラメータ:
strSernoLine - 勘定コード設定のシリアル番号、サービス明細

setPercentage

public void setPercentage(String strPercentage)
勘定設定金額配賦のパーセントを設定します。

パラメータ:
strPercentage - 勘定設定金額配賦のパーセント

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setQuantity

public void setQuantity(String strQuantity)
+/- 記号あり/なし数量を設定します。

パラメータ:
strQuantity - +/- 記号あり/なし数量

setNetValue

public void setNetValue(String strNetValue)
明細の正味額を設定します。

パラメータ:
strNetValue - 明細の正味額

setSaIndex

public void setSaIndex(int saIndex)
レコード番号を設定します｡

パラメータ:
saIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractServiceText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractServiceText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
すべての実装インタフェース:
Serializable
public class ContractServiceText
extends PurchaseText

外注サービステキスト情報クラス
機能は以下の通り

  • 外注サービステキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractServiceText()
外注サービステキストを作成します。
ContractServiceText(int index)
外注サービステキストを作成します。
メソッドの概要
String | getFormatCol() タグ列を取得します。
String | getLineNo() 内部明細番号を取得します。
String | getPckgNo() パッケージ番号を取得します。
void | setFormatCol(String strFormatCol) タグ列を設定します。
void | setLineNo(String strLineNo) 内部明細番号を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText から継承したメソッド
getPoItem, getPoNumber, getTeIndex, getTextForm, getTextId, getTextLine, setPoItem, setPoNumber, setTeIndex, setTextForm, setTextId, setTextLine
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractServiceText

public ContractServiceText()
外注サービステキストを作成します。

ContractServiceText

public ContractServiceText(int index)
外注サービステキストを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
内部明細番号を取得します。

戻り値:
srtLineNo 内部明細番号

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
srtFormatCol タグ列

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
内部明細番号を設定します。

パラメータ:
strLineNo - 内部明細番号

setFormatCol

public void setFormatCol(String strFormatCol)
タグ列を設定します。

パラメータ:
strFormatCol - タグ列

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseText 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DeliveryAddress (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス DeliveryAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress
すべての実装インタフェース:
Serializable
public class DeliveryAddress
extends Object
implements Serializable

入荷伝票アドレス情報クラス
機能は以下の通り

  • 入荷伝票アドレス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DeliveryAddress()
入荷伝票アドレスを作成します。
DeliveryAddress(int index)
入荷伝票アドレスを作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCity() 市区町村を取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
int | getDeIndex() レコード番号を取得します｡
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getDistrict() 所在地を取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getFormofaddr() 敬称テキストを取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getLocation() 地名 5を取得します。
String | getName_2() 名称 2を取得します。
String | getName_3() 名称 3を取得します。
String | getName_4() 名称 4を取得します。
String | getName() 名称 1を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPoBox() 私書箱を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreet() 地名を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String strAddrNo) アドレス番号を設定します。
void | setAdrNotes(String strAdrNotes) 住所注記を設定します。
void | setBuilding(String strBuilding) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String strBuildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String strChckstatus) 市区町村ファイルテストステータスを設定します。
void | setCity(String strCity) 市区町村を設定します。
void | setCityNo(String strCityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String strCommType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String strCOName) 気付を設定します。
void | setCountry(String strCountry) 国コードを設定します。
void | setCountryiso(String strCountryiso) ISO 国コードを設定します。
void | setDeIndex(int deIndex) レコード番号を設定します｡
void | setDelivDis(String strDelivDis) 郵便配達地域を設定します。
void | setDistrctNo(String strDistrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setDistrict(String strDistrict) 所在地を設定します。
void | setEMail(String strEMail) 電子メールアドレスを設定します。
void | setFaxExtens(String strFaxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String strFaxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String strFloor) 建物の階を設定します。
void | setFormofaddr(String strFormofaddr) 敬称テキストを設定します。
void | setHouseNo(String strHouseNo) 番地-号を設定します。
void | setHouseNo2(String strHouseNo2) 番地補足を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) ISO 639 準拠の言語を設定します。
void | setLocation(String strLocation) 地名 5を設定します。
void | setName_2(String strName2) 名称 2を設定します。
void | setName_3(String strName3) 名称 3を設定します。
void | setName_4(String strName4) 名称 4を設定します。
void | setName(String strName) 名称 1を設定します。
void | setPboxcitNo(String strPboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPoBox(String strPoBox) 私書箱を設定します。
void | setPoBoxCit(String strPoBoxCit) 私書箱住所を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPostlCod1(String strPostlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String strPostlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String strPostlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setRegiogroup(String strRegiogroup) 地域構造グループ化を設定します。
void | setRegion(String strRegion) 地域 (都道府県)を設定します。
void | setRoomNo(String strRoomNo) 部屋/アパート番号を設定します。
void | setSort1(String strSort1) 検索条件 1を設定します。
void | setSort2(String strSort2) 検索条件 2を設定します。
void | setStrAbbr(String strStrAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreet(String strStreet) 地名を設定します。
void | setStreetLng(String strStreetLng) 地名を設定します。
void | setStreetNo(String strStreetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strStrSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strStrSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strStrSuppl3) 地名 4を設定します。
void | setTaxjurcode(String strTaxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String strTel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String strTel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String strTimeZone) アドレスタイムゾーンを設定します。
void | setTitle(String strTitle) タイトル (敬称)を設定します。
void | setTranspzone(String strTranspzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DeliveryAddress

public DeliveryAddress()
入荷伝票アドレスを作成します。

DeliveryAddress

public DeliveryAddress(int index)
入荷伝票アドレスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
srtAddrNo アドレス番号

getFormofaddr

public String getFormofaddr()
敬称テキストを取得します。

戻り値:
srtFormofaddr 敬称テキスト

getName

public String getName()
名称 1を取得します。

戻り値:
srtName 名称 1

getName_2

public String getName_2()
名称 2を取得します。

戻り値:
srtName2 名称 2

getName_3

public String getName_3()
名称 3を取得します。

戻り値:
srtName3 名称 3

getName_4

public String getName_4()
名称 4を取得します。

戻り値:
srtName4 名称 4

getCOName

public String getCOName()
気付を取得します。

戻り値:
srtCOName 気付

getCity

public String getCity()
市区町村を取得します。

戻り値:
srtCity 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
srtDistrict 所在地

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
srtCityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
srtPostlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
srtPostlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
srtPostlCod3 会社郵便番号 (大規模なユーザ用)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
srtPoBox 私書箱

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
srtPoBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
srtDelivDis 郵便配達地域

getStreet

public String getStreet()
地名を取得します。

戻り値:
srtStreet 地名

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
srtStreetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
srtStrAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
srtHouseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
srtStrSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
srtStrSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
srtLocation 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
srtBuilding 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
srtFloor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
srtRoomNo 部屋/アパート番号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
srtCountry 国コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
srtRegion 地域 (都道府県)

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
srtSort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
srtSort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
srtTimeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
srtTaxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
srtAdrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
srtCommType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
srtTel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
srtTel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
srtFaxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
srtFaxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
srtStreetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
srtDistrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
srtChckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
srtPboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
srtTranspzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
srtHouseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
srtEMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
srtStrSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
srtTitle タイトル (敬称)

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
srtCountryiso ISO 国コード

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
srtLanguIso ISO 639 準拠の言語

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
srtBuildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
srtRegiogroup 地域構造グループ化

getDeIndex

public int getDeIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setAddrNo

public void setAddrNo(String strAddrNo)
アドレス番号を設定します。

パラメータ:
strAddrNo - アドレス番号

setFormofaddr

public void setFormofaddr(String strFormofaddr)
敬称テキストを設定します。

パラメータ:
strFormofaddr - 敬称テキスト

setName

public void setName(String strName)
名称 1を設定します。

パラメータ:
strName - 名称 1

setName_2

public void setName_2(String strName2)
名称 2を設定します。

パラメータ:
strName2 - 名称 2

setName_3

public void setName_3(String strName3)
名称 3を設定します。

パラメータ:
strName3 - 名称 3

setName_4

public void setName_4(String strName4)
名称 4を設定します。

パラメータ:
strName4 - 名称 4

setCOName

public void setCOName(String strCOName)
気付を設定します。

パラメータ:
strCOName - 気付

setCity

public void setCity(String strCity)
市区町村を設定します。

パラメータ:
strCity - 市区町村

setDistrict

public void setDistrict(String strDistrict)
所在地を設定します。

パラメータ:
strDistrict - 所在地

setCityNo

public void setCityNo(String strCityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
strCityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String strPostlCod1)
市区町村の郵便番号を設定します。

パラメータ:
strPostlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String strPostlCod2)
私書箱郵便番号を設定します。

パラメータ:
strPostlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String strPostlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
strPostlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBox

public void setPoBox(String strPoBox)
私書箱を設定します。

パラメータ:
strPoBox - 私書箱

setPoBoxCit

public void setPoBoxCit(String strPoBoxCit)
私書箱住所を設定します。

パラメータ:
strPoBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String strDelivDis)
郵便配達地域を設定します。

パラメータ:
strDelivDis - 郵便配達地域

setStreet

public void setStreet(String strStreet)
地名を設定します。

パラメータ:
strStreet - 地名

setStreetNo

public void setStreetNo(String strStreetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
strStreetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strStrAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strStrAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String strHouseNo)
番地-号を設定します。

パラメータ:
strHouseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strStrSuppl1)
地名 2を設定します。

パラメータ:
strStrSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strStrSuppl2)
地名 3を設定します。

パラメータ:
strStrSuppl2 - 地名 3

setLocation

public void setLocation(String strLocation)
地名 5を設定します。

パラメータ:
strLocation - 地名 5

setBuilding

public void setBuilding(String strBuilding)
旧: 建物 (番号または略称)を設定します。

パラメータ:
strBuilding - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String strFloor)
建物の階を設定します。

パラメータ:
strFloor - 建物の階

setRoomNo

public void setRoomNo(String strRoomNo)
部屋/アパート番号を設定します。

パラメータ:
strRoomNo - 部屋/アパート番号

setCountry

public void setCountry(String strCountry)
国コードを設定します。

パラメータ:
strCountry - 国コード

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setRegion

public void setRegion(String strRegion)
地域 (都道府県)を設定します。

パラメータ:
strRegion - 地域 (都道府県)

setSort1

public void setSort1(String strSort1)
検索条件 1を設定します。

パラメータ:
strSort1 - 検索条件 1

setSort2

public void setSort2(String strSort2)
検索条件 2を設定します。

パラメータ:
strSort2 - 検索条件 2

setTimeZone

public void setTimeZone(String strTimeZone)
アドレスタイムゾーンを設定します。

パラメータ:
strTimeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String strAdrNotes)
住所注記を設定します。

パラメータ:
strAdrNotes - 住所注記

setCommType

public void setCommType(String strCommType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
strCommType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String strTel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
strTel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String strTel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
strTel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String strFaxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
strFaxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String strFaxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
strFaxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String strStreetLng)
地名を設定します。

パラメータ:
strStreetLng - 地名

setDistrctNo

public void setDistrctNo(String strDistrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
strDistrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String strChckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
strChckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String strPboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
strPboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String strTranspzone)
商品の納入区域を設定します。

パラメータ:
strTranspzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String strHouseNo2)
番地補足を設定します。

パラメータ:
strHouseNo2 - 番地補足

setEMail

public void setEMail(String strEMail)
電子メールアドレスを設定します。

パラメータ:
strEMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strStrSuppl3)
地名 4を設定します。

パラメータ:
strStrSuppl3 - 地名 4

setTitle

public void setTitle(String strTitle)
タイトル (敬称)を設定します。

パラメータ:
strTitle - タイトル (敬称)

setCountryiso

public void setCountryiso(String strCountryiso)
ISO 国コードを設定します。

パラメータ:
strCountryiso - ISO 国コード

setLanguIso

public void setLanguIso(String strLanguIso)
ISO 639 準拠の言語を設定します。

パラメータ:
strLanguIso - ISO 639 準拠の言語

setBuildLong

public void setBuildLong(String strBuildLong)
建物 (番号またはコード)を設定します。

パラメータ:
strBuildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String strRegiogroup)
地域構造グループ化を設定します。

パラメータ:
strRegiogroup - 地域構造グループ化

setDeIndex

public void setDeIndex(int deIndex)
レコード番号を設定します｡

パラメータ:
deIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributionChannelSelection (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス DistributionChannelSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection
すべての実装インタフェース:
Serializable
public class DistributionChannelSelection
extends Selection
implements Serializable

流通チャネルの選択オプションクラス
機能は以下の通り

  • 流通チャネルの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DistributionChannelSelection()
流通チャネルの選択オプション情報を作成します。
DistributionChannelSelection(int index)
流通チャネルの選択オプション情報を作成します。
メソッドの概要
String | getDistrChanHigh() 流通チャネルの範囲終了を取得します。
String | getDistrChanLow() 流通チャネルの範囲開始を取得します。
int | getIndex() レコード番号を取得します。
void | setDistrChanHigh(String strDistrChanHigh) 流通チャネルの範囲終了を設定します。
void | setDistrChanLow(String strDistrChanLow) 流通チャネルの範囲開始を設定します。
void | setIndex(int index) レコード番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DistributionChannelSelection

public DistributionChannelSelection()
流通チャネルの選択オプション情報を作成します。

DistributionChannelSelection

public DistributionChannelSelection(int index)
流通チャネルの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDistrChanLow

public String getDistrChanLow()
流通チャネルの範囲開始を取得します。

戻り値:
srtDistrChanLow

getDistrChanHigh

public String getDistrChanHigh()
流通チャネルの範囲終了を取得します。

戻り値:
srtDistrChanHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index

setDistrChanLow

public void setDistrChanLow(String strDistrChanLow)
流通チャネルの範囲開始を設定します。

パラメータ:
strDistrChanLow - 流通チャネルの範囲開始

setDistrChanHigh

public void setDistrChanHigh(String strDistrChanHigh)
流通チャネルの範囲終了を設定します。

パラメータ:
strDistrChanHigh - 流通チャネルの範囲終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExportHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ExportHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader
すべての実装インタフェース:
Serializable
public class ExportHeader
extends Object
implements Serializable

貿易管理ヘッダ情報クラス
機能は以下の通り

  • 貿易管理ヘッダ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExportHeader()
貿易管理明細を作成します。
メソッドの概要
String | getCustoms() 税関: 税関 (出国時)を取得します。
String | getTransportMode() 貿易管理の輸送モードを取得します。
void | setCustoms(String strCustoms) 税関: 税関 (出国時)を設定します。
void | setTransportMode(String strTransportMode) 貿易管理の輸送モードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportHeader

public ExportHeader()
貿易管理明細を作成します。

メソッドの詳細

getTransportMode

public String getTransportMode()
貿易管理の輸送モードを取得します。

戻り値:
srtTransportMode 貿易管理の輸送モード

getCustoms

public String getCustoms()
税関: 税関 (出国時)を取得します。

戻り値:
srtCustoms 税関: 税関 (出国時)

setTransportMode

public void setTransportMode(String strTransportMode)
貿易管理の輸送モードを設定します。

パラメータ:
strTransportMode - 貿易管理の輸送モード

setCustoms

public void setCustoms(String strCustoms)
税関: 税関 (出国時)を設定します。

パラメータ:
strCustoms - 税関: 税関 (出国時)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExportItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ExportItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ExportItem
すべての実装インタフェース:
Serializable
public class ExportItem
extends Object
implements Serializable

貿易管理明細情報クラス
機能は以下の通り

  • 貿易管理明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExportItem()
貿易管理明細を作成します。
ExportItem(int index)
貿易管理明細を作成します。
メソッドの概要
String | getBusinessTransactionType() 貿易管理の取引タイプを取得します。
String | getCommCode() 貿易: 統計品目コード/輸入コード番号を取得します。
String | getCountryori() 品目の原産国を取得します。
String | getCountryoriIso() ISO 国コードを取得します。
int | getEiIndex() レコード番号を取得します｡
String | getExportImportProcedure() 貿易の輸出入手続を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getRegionorig() 品目の原産地 (非特恵対象地区の原産)を取得します。
String | getShippingCountry() 貿易: 出荷国を取得します。
String | getShippingCountryIso() ISO 国コードを取得します。
void | setBusinessTransactionType(String strBusinessTransactionType) 貿易管理の取引タイプを設定します。
void | setCommCode(String strCommCode) 貿易: 統計品目コード/輸入コード番号を設定します。
void | setCountryori(String strCountryori) 品目の原産国を設定します。
void | setCountryoriIso(String strCountryoriIso) ISO 国コードを設定します。
void | setEiIndex(int eiIndex) レコード番号を設定します｡
void | setExportImportProcedure(String strExportImportProcedure) 貿易の輸出入手続を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setRegionorig(String strRegionorig) 品目の原産地 (非特恵対象地区の原産)を設定します。
void | setShippingCountry(String strShippingCountry) 貿易: 出荷国を設定します。
void | setShippingCountryIso(String strShippingCountryIso) ISO 国コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportItem

public ExportItem()
貿易管理明細を作成します。

ExportItem

public ExportItem(int index)
貿易管理明細を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getBusinessTransactionType

public String getBusinessTransactionType()
貿易管理の取引タイプを取得します。

戻り値:
srtBusinessTransactionType 貿易管理の取引タイプ

getExportImportProcedure

public String getExportImportProcedure()
貿易の輸出入手続を取得します。

戻り値:
srtExportImportProcedure 貿易の輸出入手続

getCountryori

public String getCountryori()
品目の原産国を取得します。

戻り値:
srtCountryori 品目の原産国

getCountryoriIso

public String getCountryoriIso()
ISO 国コードを取得します。

戻り値:
srtCountryoriIso ISO 国コード

getRegionorig

public String getRegionorig()
品目の原産地 (非特恵対象地区の原産)を取得します。

戻り値:
srtRegionorig 品目の原産地 (非特恵対象地区の原産)

getCommCode

public String getCommCode()
貿易: 統計品目コード/輸入コード番号を取得します。

戻り値:
srtCommCode 貿易: 統計品目コード/輸入コード番号

getShippingCountry

public String getShippingCountry()
貿易: 出荷国を取得します。

戻り値:
srtShippingCountry 貿易: 出荷国

getShippingCountryIso

public String getShippingCountryIso()
ISO 国コードを取得します。

戻り値:
srtShippingCountryIso ISO 国コード

getEiIndex

public int getEiIndex()
レコード番号を取得します｡

戻り値:
eiIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setBusinessTransactionType

public void setBusinessTransactionType(String strBusinessTransactionType)
貿易管理の取引タイプを設定します。

パラメータ:
strBusinessTransactionType - 貿易管理の取引タイプ

setExportImportProcedure

public void setExportImportProcedure(String strExportImportProcedure)
貿易の輸出入手続を設定します。

パラメータ:
strExportImportProcedure - 貿易の輸出入手続

setCountryori

public void setCountryori(String strCountryori)
品目の原産国を設定します。

パラメータ:
strCountryori - 品目の原産国

setCountryoriIso

public void setCountryoriIso(String strCountryoriIso)
ISO 国コードを設定します。

パラメータ:
strCountryoriIso - ISO 国コード

setRegionorig

public void setRegionorig(String strRegionorig)
品目の原産地 (非特恵対象地区の原産)を設定します。

パラメータ:
strRegionorig - 品目の原産地 (非特恵対象地区の原産)

setCommCode

public void setCommCode(String strCommCode)
貿易: 統計品目コード/輸入コード番号を設定します。

パラメータ:
strCommCode - 貿易: 統計品目コード/輸入コード番号

setShippingCountry

public void setShippingCountry(String strShippingCountry)
貿易: 出荷国を設定します。

パラメータ:
strShippingCountry - 貿易: 出荷国

setShippingCountryIso

public void setShippingCountryIso(String strShippingCountryIso)
ISO 国コードを設定します。

パラメータ:
strShippingCountryIso - ISO 国コード

setEiIndex

public void setEiIndex(int eiIndex)
レコード番号を設定します｡

パラメータ:
eiIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Extension (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Extension

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Extension
すべての実装インタフェース:
Serializable
public class Extension
extends Object
implements Serializable

拡張得意先項目情報クラス
機能は以下の通り

  • 拡張得意先項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Extension()
拡張得意先項目を作成します。
Extension(int index)
拡張得意先項目アドレスを作成します。
メソッドの概要
int | getExIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setExIndex(int exIndex) レコード番号を設定します｡
void | setStructure(String strStructure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String strValuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String strValuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String strValuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String strValuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Extension

public Extension()
拡張得意先項目を作成します。

Extension

public Extension(int index)
拡張得意先項目アドレスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
srtStructure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart4 BAPI 拡張パラメータのデータ部分

getExIndex

public int getExIndex()
レコード番号を取得します｡

戻り値:
exIndex レコード番号

setStructure

public void setStructure(String strStructure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
strStructure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String strValuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String strValuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String strValuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String strValuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart4 - BAPI 拡張パラメータのデータ部分

setExIndex

public void setExIndex(int exIndex)
レコード番号を設定します｡

パラメータ:
exIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCreateController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス GoodsMvtCreateController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController
すべての実装インタフェース:
Serializable
public class GoodsMvtCreateController
extends GoodsMvtCreate
implements Serializable

入庫伝票登録コントローラクラス
機能は以下の通り

  • 入庫伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtCreateController()
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate から継承したメソッド
getExtensioninList, getGoodsMvtCode, getGoodsMvtHeader, getGoodsMvtHeadret, getGoodsMvtItemList, getGoodsMvtRefEwm, getGoodsMvtSerialNumberList, getGoodsMvtServPartDataList, getMatdocumentyear, getMaterialdocument, getTestrun, setExportParam, setExtensioninList, setGoodsMvtCode, setGoodsMvtHeader, setGoodsMvtHeadret, setGoodsMvtItemList, setGoodsMvtRefEwm, setGoodsMvtSerialNumberList, setGoodsMvtServPartDataList, setImportParam, setMatdocumentyear, setMaterialdocument, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCreateController

public GoodsMvtCreateController()
GoodsMvtCreateControllerのコンストラクタを生成します。

GoodsMvtCreateController

public GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

GoodsMvtCreateController

public GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPPurchaseSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtGetItemsController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス GoodsMvtGetItemsController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController
すべての実装インタフェース:
Serializable
public class GoodsMvtGetItemsController
extends GoodsMvtGetItems
implements Serializable

入出庫伝票一覧取得コントローラクラス
機能は以下の通り

  • 入出庫伝票の一覧を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtGetItemsController()
コンストラクタ生成
GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems から継承したメソッド
getBatchRaList, getGoodsMvtHeaderList, getGoodsMvtItemsList, getMaterialRaList, getMoveTypeRaList, getPlantRaList, getPstngDateRaList, getSpecStockRaList, getStgeLocRaList, getTrEvTypeRaList, getUserNameRaList, getVendorRaList, setBatchRaList, setExportParam, setGoodsMvtHeaderList, setGoodsMvtItemsList, setImportParam, setMaterialRaList, setMoveTypeRaList, setPlantRaList, setPstngDateRaList, setSpecStockRaList, setStgeLocRaList, setTrEvTypeRaList, setUserNameRaList, setVendorRaList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtGetItemsController

public GoodsMvtGetItemsController()
コンストラクタ生成

GoodsMvtGetItemsController

public GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Limits (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Limits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Limits
すべての実装インタフェース:
Serializable
public class Limits
extends Object
implements Serializable

外注制限情報クラス
機能は以下の通り

  • 外注制限情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Limits()
外注制限を作成します。
Limits(int index)
外注制限を作成します。
メソッドの概要
String | getConExist() 基本契約明細の制限を取得します。
String | getContPerc() 価格決定率を取得します。
String | getEdition() サービスタイプのバージョンを取得します。
String | getExpValue() 見込金額を取得します。
String | getFreeLimit() 自由制限を取得します。
int | getLiIndex() レコード番号を取得します｡
String | getLimit() 全体制限を取得します。
String | getNoFrlimit() 制限なしを取得します。
String | getNoLimit() 制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getServType() サービスタイプのテキスト (短)を取得します。
String | getSscExist() サービスタイプの制限を取得します。
String | getSscLimit() サービスタイプの金額制限を取得します。
String | getSscNolim() 標準サービスタイプの制限なしを取得します。
String | getSscPerc() 価格決定率を取得します。
String | getSscPrschg() 入力シートの価格変更を取得します。
String | getTmpExist() サービスパッケージの制限を取得します。
String | getTmpLimit() モデルサービス明細制限を取得します。
String | getTmpNolim() モデル仕様の制限なしを取得します。
String | getTmpNumber() モデルサービス明細セット番号を取得します。
String | getTmpPerc() 価格決定率を取得します。
String | getTmpPrschg() 入力シートの価格変更を取得します。
void | setConExist(String strConExist) 基本契約明細の制限を設定します。
void | setContPerc(String strContPerc) 価格決定率を設定します。
void | setEdition(String strEdition) サービスタイプのバージョンを設定します。
void | setExpValue(String strExpValue) 見込金額を設定します。
void | setFreeLimit(String strFreeLimit) 自由制限を設定します。
void | setLiIndex(int liIndex) レコード番号を設定します｡
void | setLimit(String strLimit) 全体制限を設定します。
void | setNoFrlimit(String strNoFrlimit) 制限なしを設定します。
void | setNoLimit(String strNoLimit) 制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setServType(String strServType) サービスタイプのテキスト (短)を設定します。
void | setSscExist(String strSscExist) サービスタイプの制限を設定します。
void | setSscLimit(String strSscLimit) サービスタイプの金額制限を設定します。
void | setSscNolim(String strSscNolim) 標準サービスタイプの制限なしを設定します。
void | setSscPerc(String strSscPerc) 価格決定率を設定します。
void | setSscPrschg(String strSscPrschg) 入力シートの価格変更を設定します。
void | setTmpExist(String strTmpExist) サービスパッケージの制限を設定します。
void | setTmpLimit(String strTmpLimit) モデルサービス明細制限を設定します。
void | setTmpNolim(String strTmpNolim) モデル仕様の制限なしを設定します。
void | setTmpNumber(String strTmpNumber) モデルサービス明細セット番号を設定します。
void | setTmpPerc(String strTmpPerc) 価格決定率を設定します。
void | setTmpPrschg(String strTmpPrschg) 入力シートの価格変更を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Limits

public Limits()
外注制限を作成します。

Limits

public Limits(int index)
外注制限を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLimit

public String getLimit()
全体制限を取得します。

戻り値:
srtLimit 全体制限

getNoLimit

public String getNoLimit()
制限なしを取得します。

戻り値:
srtNoLimit 制限なし

getExpValue

public String getExpValue()
見込金額を取得します。

戻り値:
srtExpValue 見込金額

getSscExist

public String getSscExist()
サービスタイプの制限を取得します。

戻り値:
srtSscExist サービスタイプの制限

getConExist

public String getConExist()
基本契約明細の制限を取得します。

戻り値:
srtConExist 基本契約明細の制限

getTmpExist

public String getTmpExist()
サービスパッケージの制限を取得します。

戻り値:
srtTmpExist サービスパッケージの制限

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getFreeLimit

public String getFreeLimit()
自由制限を取得します。

戻り値:
srtFreeLimit 自由制限

getNoFrlimit

public String getNoFrlimit()
制限なしを取得します。

戻り値:
srtNoFrlimit 制限なし

getServType

public String getServType()
サービスタイプのテキスト (短)を取得します。

戻り値:
srtServType サービスタイプのテキスト (短)

getEdition

public String getEdition()
サービスタイプのバージョンを取得します。

戻り値:
srtEdition サービスタイプのバージョン

getSscLimit

public String getSscLimit()
サービスタイプの金額制限を取得します。

戻り値:
srtSscLimit サービスタイプの金額制限

getSscNolim

public String getSscNolim()
標準サービスタイプの制限なしを取得します。

戻り値:
srtSscNolim 標準サービスタイプの制限なし

getSscPrschg

public String getSscPrschg()
入力シートの価格変更を取得します。

戻り値:
srtSscPrschg 入力シートの価格変更

getSscPerc

public String getSscPerc()
価格決定率を取得します。

戻り値:
srtSscPerc 価格決定率

getTmpNumber

public String getTmpNumber()
モデルサービス明細セット番号を取得します。

戻り値:
srtTmpNumber モデルサービス明細セット番号

getTmpLimit

public String getTmpLimit()
モデルサービス明細制限を取得します。

戻り値:
srtTmpLimit モデルサービス明細制限

getTmpNolim

public String getTmpNolim()
モデル仕様の制限なしを取得します。

戻り値:
srtTmpNolim モデル仕様の制限なし

getTmpPrschg

public String getTmpPrschg()
入力シートの価格変更を取得します。

戻り値:
srtTmpPrschg 入力シートの価格変更

getTmpPerc

public String getTmpPerc()
価格決定率を取得します。

戻り値:
srtTmpPerc 価格決定率

getContPerc

public String getContPerc()
価格決定率を取得します。

戻り値:
srtContPerc 価格決定率

getLiIndex

public int getLiIndex()
レコード番号を取得します｡

戻り値:
liIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLimit

public void setLimit(String strLimit)
全体制限を設定します。

パラメータ:
strLimit - 全体制限

setNoLimit

public void setNoLimit(String strNoLimit)
制限なしを設定します。

パラメータ:
strNoLimit - 制限なし

setExpValue

public void setExpValue(String strExpValue)
見込金額を設定します。

パラメータ:
strExpValue - 見込金額

setSscExist

public void setSscExist(String strSscExist)
サービスタイプの制限を設定します。

パラメータ:
strSscExist - サービスタイプの制限

setConExist

public void setConExist(String strConExist)
基本契約明細の制限を設定します。

パラメータ:
strConExist - 基本契約明細の制限

setTmpExist

public void setTmpExist(String strTmpExist)
サービスパッケージの制限を設定します。

パラメータ:
strTmpExist - サービスパッケージの制限

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setFreeLimit

public void setFreeLimit(String strFreeLimit)
自由制限を設定します。

パラメータ:
strFreeLimit - 自由制限

setNoFrlimit

public void setNoFrlimit(String strNoFrlimit)
制限なしを設定します。

パラメータ:
strNoFrlimit - 制限なし

setServType

public void setServType(String strServType)
サービスタイプのテキスト (短)を設定します。

パラメータ:
strServType - サービスタイプのテキスト (短)

setEdition

public void setEdition(String strEdition)
サービスタイプのバージョンを設定します。

パラメータ:
strEdition - サービスタイプのバージョン

setSscLimit

public void setSscLimit(String strSscLimit)
サービスタイプの金額制限を設定します。

パラメータ:
strSscLimit - サービスタイプの金額制限

setSscNolim

public void setSscNolim(String strSscNolim)
標準サービスタイプの制限なしを設定します。

パラメータ:
strSscNolim - 標準サービスタイプの制限なし

setSscPrschg

public void setSscPrschg(String strSscPrschg)
入力シートの価格変更を設定します。

パラメータ:
strSscPrschg - 入力シートの価格変更

setSscPerc

public void setSscPerc(String strSscPerc)
価格決定率を設定します。

パラメータ:
strSscPerc - 価格決定率

setTmpNumber

public void setTmpNumber(String strTmpNumber)
モデルサービス明細セット番号を設定します。

パラメータ:
strTmpNumber - モデルサービス明細セット番号

setTmpLimit

public void setTmpLimit(String strTmpLimit)
モデルサービス明細制限を設定します。

パラメータ:
strTmpLimit - モデルサービス明細制限

setTmpNolim

public void setTmpNolim(String strTmpNolim)
モデル仕様の制限なしを設定します。

パラメータ:
strTmpNolim - モデル仕様の制限なし

setTmpPrschg

public void setTmpPrschg(String strTmpPrschg)
入力シートの価格変更を設定します。

パラメータ:
strTmpPrschg - 入力シートの価格変更

setTmpPerc

public void setTmpPerc(String strTmpPerc)
価格決定率を設定します。

パラメータ:
strTmpPerc - 価格決定率

setContPerc

public void setContPerc(String strContPerc)
価格決定率を設定します。

パラメータ:
strContPerc - 価格決定率

setLiIndex

public void setLiIndex(int liIndex)
レコード番号を設定します｡

パラメータ:
liIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ManufacturerPartNumb (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ManufacturerPartNumb

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb
すべての実装インタフェース:
Serializable
public class ManufacturerPartNumb
extends Object
implements Serializable

製造業者と製造者製品コードクラス
機能は以下の通り

  • 製造業者と製造者製品コードの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ManufacturerPartNumb()
製造業者と製造者製品コード情報を作成します。
ManufacturerPartNumb(int index)
製造業者と製造者製品コード情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMfrNo() 製造者番号を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setManuMat(String strManuMat) 製造者製品コードを設定します。
void | setMfrNo(String strMfrNo) 製造者番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ManufacturerPartNumb

public ManufacturerPartNumb()
製造業者と製造者製品コード情報を作成します。

ManufacturerPartNumb

public ManufacturerPartNumb(int index)
製造業者と製造者製品コード情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
srtManuMat 製造者製品コード

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
srtMfrNo 製造者番号

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setManuMat

public void setManuMat(String strManuMat)
製造者製品コードを設定します。

パラメータ:
strManuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String strMfrNo)
製造者番号を設定します。

パラメータ:
strMfrNo - 製造者番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialAvailabilityController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialAvailabilityController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController
すべての実装インタフェース:
Serializable
public class MaterialAvailabilityController
extends MaterialAvailability
implements Serializable

品目在庫確認コントローラクラス
機能は以下の通り

  • 在庫情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialAvailabilityController()
コンストラクタ生成
MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability から継承したメソッド
getAvQtyPlt, getBatch, getCheckRule, getCustomer, getDecForRounding, getDecForRoundingX, getDialogflag, getDocNumber, getEndleadtme, getItmNumber, getMaterial, getMaterialEvg, getPlant, getReadAtpLock, getReadAtpLockX, getStgeLoc, getStockInd, getUnit, getWbsElem, getWmdvexList, getWmdvsxList, setAvQtyPlt, setBatch, setCheckRule, setCustomer, setDecForRounding, setDecForRoundingX, setDialogflag, setDocNumber, setEndleadtme, setExportParam, setImportParam, setItmNumber, setMaterial, setMaterialEvg, setPlant, setReadAtpLock, setReadAtpLockX, setStgeLoc, setStockInd, setUnit, setWbsElem, setWmdvexList, setWmdvsxList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialAvailabilityController

public MaterialAvailabilityController()
コンストラクタ生成

MaterialAvailabilityController

public MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetAllController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetAllController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController
すべての実装インタフェース:
Serializable
public class MaterialGetAllController
extends MaterialGetAll
implements Serializable

品目マスタ照会コントローラクラス
機能は以下の通り

  • 品目マスタの情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetAllController()
コンストラクタ生成
MaterialGetAllController(SapClient sapClient)
コンストラクタ生成
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
メソッドの概要
void | executeBapi() BapiControllerにより品目マスタ照会を行います。
ExtensionOut | getExtensionOut(int index) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
InternationArticleNumbers | getInternationArticleNumbers(int index) EANオブジェクトが既に存在するかチェックします。
MaterialDescription | getMaterialDescription(int index) 品目テキストオブジェクトが既に存在するかチェックします。
MaterialText | getMaterialText(int index) テキスト (長)オブジェクトが既に存在するかチェックします。
TaxClassifications | getTaxClassifications(int index) 制御デ－タオブジェクトが既に存在するかチェックします。
UnitSofmeasure | getUnitSofmeasure(int index) 数量単位オブジェクトが既に存在するかチェックします。
void | setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll から継承したメソッド
getClientData, getCompanycode, getDistributionchannel, getExtensionOutList, getForecastParameters, getInternationArticleNumbersList, getLifoValuationData, getLifovaluationlevel, getMaterial, getMaterialDescriptionList, getMaterialEvg, getMaterialTextList, getPlanningData, getPlant, getPlantData, getProductionResourceToolData, getSalesData, getSalesorganisation, getStoragelocation, getStorageLocationData, getStoragetype, getStorageTypeData, getTaxClassificationsList, getUnitSofmeasureList, getValuationarea, getValuationData, getValuationtype, getWarehousenumber, getWarehouseNumberData, initMaterialGetAll, setClientData, setCompanycode, setDistributionchannel, setExpClientData, setExpExtensionOut, setExpForecastParameters, setExpInternationArticleNumbers, setExpLifoValuationData, setExpMaterialDescription, setExpMaterialText, setExportParam, setExpPlanningData, setExpPlantData, setExpProductionResourceToolData, setExpSalesData, setExpStorageLocationData, setExpStorageTypeData, setExpTaxClassifications, setExpUnitSofmeasure, setExpValuationData, setExpWarehouseNumberData, setExtensionOutList, setForecastParameters, setImpExtensionOut, setImpInternationArticleNumbers, setImpMaterialDescription, setImpMaterialText, setImportParam, setImpTaxClassifications, setImpUnitSofmeasure, setInternationArticleNumbersList, setLifoValuationData, setLifovaluationlevel, setMaterial, setMaterialDescriptionList, setMaterialEvg, setMaterialTextList, setPlanningData, setPlant, setPlantData, setProductionResourceToolData, setSalesData, setSalesorganisation, setStoragelocation, setStorageLocationData, setStoragetype, setStorageTypeData, setTaxClassificationsList, setUnitSofmeasureList, setValuationarea, setValuationData, setValuationtype, setWarehousenumber, setWarehouseNumberData, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetAllController

public MaterialGetAllController()
コンストラクタ生成

MaterialGetAllController

public MaterialGetAllController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

MaterialGetAllController

public MaterialGetAllController(String material,
                                String companyCode,
                                String plant,
                                String storageLocation,
                                String salesOrganisation,
                                String distributionChannel)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル

MaterialGetAllController

public MaterialGetAllController(String material,
                                String companyCode,
                                String plant,
                                String storageLocation,
                                String salesOrganisation,
                                String distributionChannel,
                                SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより品目マスタ照会を行います。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getMaterialDescription

public MaterialDescription getMaterialDescription(int index)
品目テキストオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
materialDescription 品目テキストオブジェクト

getUnitSofmeasure

public UnitSofmeasure getUnitSofmeasure(int index)
数量単位オブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
unitSofmeasure 数量単位オブジェクト

getInternationArticleNumbers

public InternationArticleNumbers getInternationArticleNumbers(int index)
EANオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
internationArticleNumbers EANオブジェクト

getMaterialText

public MaterialText getMaterialText(int index)
テキスト (長)オブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
materialText テキスト (長)オブジェクト

getTaxClassifications

public TaxClassifications getTaxClassifications(int index)
制御デ－タオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
taxClassifications 制御デ－タオブジェクト

getExtensionOut

public ExtensionOut getExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
extensionOut EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialGetListController
public class MaterialGetList
extends ReferenceController
implements Serializable

品目コード検索クラス
機能は以下の通り

  • 品目コード、テキストを検索します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
メソッドの概要
ArrayList | getDistributionChannelSelectionList() 流通チャネルの選択オプション一覧を取得します｡
ArrayList | getManufacturerPartNumbList() 製造業者と製造者製品コード一覧を取得します｡
ArrayList | getMaterialShortDescselList() 品目テキストの選択オプション一覧を取得します｡
ArrayList | getMatnrListList() 品目コードと品目テキストの一覧を取得します｡
ArrayList | getMatnrSelectionList() 品目コードの選択オプション一覧を取得します｡
String | getMaxRows() 選択予定品目の最大数を取得します｡
ArrayList | getPlantSelectionList() プラントの選択オプション一覧を取得します｡
ArrayList | getSalesOrganisationSelectionList() 販売組織の選択オプション一覧を取得します｡
ArrayList | getStorageLocationselectList() 保管場所の選択オプション一覧を取得します｡
void | setDistributionChannelSelectionList(ArrayList distributionChannelSelectionList) 流通チャネルの選択オプション一覧を設定します｡
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setImportParam(BapiController bapiController) 品目コードを検索する条件ををセットします。
void | setManufacturerPartNumbList(ArrayList manufacturerPartNumbList) 製造業者と製造者製品コード一覧を設定します｡
void | setMaterialShortDescselList(ArrayList materialShortDescselList) 品目テキストの選択オプション一覧を設定します。
void | setMatnrListList(ArrayList matnrListList) 品目コードと品目テキスト一覧を設定します｡
void | setMatnrSelectionList(ArrayList matnrSelectionList) 品目コードの選択オプション一覧を設定します。
void | setMaxRows(String strMaxRows) 選択予定品目の最大数を設定します。
void | setPlantSelectionList(ArrayList plantSelectionList) プラントの選択オプション一覧を設定します｡
void | setSalesOrganisationSelectionList(ArrayList salesOrganisationSelectionList) 販売組織の選択オプション一覧を設定します｡
void | setStoragelocationselectList(ArrayList storageLocationselectList) 保管場所の選択オプション一覧を設定します｡
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetList

public MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPPurchaseSystemException
品目コードを検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setMaxRows

public void setMaxRows(String strMaxRows)
選択予定品目の最大数を設定します。

パラメータ:
strMaxRows - 選択予定品目の最大数

setMatnrSelectionList

public void setMatnrSelectionList(ArrayList matnrSelectionList)
品目コードの選択オプション一覧を設定します。

パラメータ:
matnrSelectionList - 品目コードの選択オプション一覧

setMaterialShortDescselList

public void setMaterialShortDescselList(ArrayList materialShortDescselList)
品目テキストの選択オプション一覧を設定します。

パラメータ:
materialShortDescselList - 品目テキストの選択オプション一覧

setManufacturerPartNumbList

public void setManufacturerPartNumbList(ArrayList manufacturerPartNumbList)
製造業者と製造者製品コード一覧を設定します｡

パラメータ:
manufacturerPartNumbList - 製造業者と製造者製品コード一覧

setPlantSelectionList

public void setPlantSelectionList(ArrayList plantSelectionList)
プラントの選択オプション一覧を設定します｡

パラメータ:
plantSelectionList - プラントの選択オプション一覧

setStoragelocationselectList

public void setStoragelocationselectList(ArrayList storageLocationselectList)
保管場所の選択オプション一覧を設定します｡

パラメータ:
storageLocationselectList - 保管場所の選択オプション一覧

setSalesOrganisationSelectionList

public void setSalesOrganisationSelectionList(ArrayList salesOrganisationSelectionList)
販売組織の選択オプション一覧を設定します｡

パラメータ:
salesOrganisationSelectionList - 販売組織の選択オプション一覧

setDistributionChannelSelectionList

public void setDistributionChannelSelectionList(ArrayList distributionChannelSelectionList)
流通チャネルの選択オプション一覧を設定します｡

パラメータ:
distributionChannelSelectionList - 流通チャネルの選択オプション一覧

setMatnrListList

public void setMatnrListList(ArrayList matnrListList)
品目コードと品目テキスト一覧を設定します｡

パラメータ:
matnrListList - 品目コードと品目テキスト一覧

getMaxRows

public String getMaxRows()
選択予定品目の最大数を取得します｡

戻り値:
strMaxRows 選択予定品目の最大数

getMatnrSelectionList

public ArrayList getMatnrSelectionList()
品目コードの選択オプション一覧を取得します｡

戻り値:
matnrSelectionList 品目コードの選択オプション一覧

getMaterialShortDescselList

public ArrayList getMaterialShortDescselList()
品目テキストの選択オプション一覧を取得します｡

戻り値:
materialShortDescselList 品目テキストの選択オプション一覧

getManufacturerPartNumbList

public ArrayList getManufacturerPartNumbList()
製造業者と製造者製品コード一覧を取得します｡

戻り値:
manufacturerPartNoList 製造業者と製造者製品コード一覧

getPlantSelectionList

public ArrayList getPlantSelectionList()
プラントの選択オプション一覧を取得します｡

戻り値:
plantSelectionList プラントの選択オプション一覧

getStorageLocationselectList

public ArrayList getStorageLocationselectList()
保管場所の選択オプション一覧を取得します｡

戻り値:
storagelocationselectList 保管場所の選択オプション一覧

getSalesOrganisationSelectionList

public ArrayList getSalesOrganisationSelectionList()
販売組織の選択オプション一覧を取得します｡

戻り値:
salesOrganisationSelectionList 販売組織の選択オプション一覧

getDistributionChannelSelectionList

public ArrayList getDistributionChannelSelectionList()
流通チャネルの選択オプション一覧を取得します｡

戻り値:
distributionChannelSelectionList 流通チャネルの選択オプション一覧

getMatnrListList

public ArrayList getMatnrListList()
品目コードと品目テキストの一覧を取得します｡

戻り値:
matnrListList 品目コードと品目テキストの一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetListController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController
すべての実装インタフェース:
Serializable
public class MaterialGetListController
extends MaterialGetList
implements Serializable

品目コード検索コントローラクラス
機能は以下の通り

  • 品目コード、テキストを検索します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetListController()
MaterialGetListのコンストラクタを生成します。
MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList から継承したメソッド
getDistributionChannelSelectionList, getManufacturerPartNumbList, getMaterialShortDescselList, getMatnrListList, getMatnrSelectionList, getMaxRows, getPlantSelectionList, getSalesOrganisationSelectionList, getStorageLocationselectList, setDistributionChannelSelectionList, setExportParam, setImportParam, setManufacturerPartNumbList, setMaterialShortDescselList, setMatnrListList, setMatnrSelectionList, setMaxRows, setPlantSelectionList, setSalesOrganisationSelectionList, setStoragelocationselectList, setTblParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetListController

public MaterialGetListController()
MaterialGetListのコンストラクタを生成します。

MaterialGetListController

public MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialSaveReplicaController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialSaveReplicaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController
すべての実装インタフェース:
Serializable
public class MaterialSaveReplicaController
extends MaterialSaveReplica
implements Serializable

品目マスタ更新コントローラクラス
機能は以下の通り

  • 品目マスタを更新します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialSaveReplicaController()
コンストラクタ生成
MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成
MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
void | executeBapi() BapiControllerにより品目マスタを更新します。
ClientDataList | getClientDataList(int index) 品目データ (クライアントレベル)が既に存在するかチェックします。
ExtensionIn | getExtensionIn(int index) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。
ExtensionInX | getExtensionInX(int index) 拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。
ForecastParametersList | getForecastParametersList(int index) 需要予測パラメータが既に存在するかチェックします。
ForecastValues | getForecastValues(int index) 需要予測値のデータ転送が既に存在するかチェックします。
HeadData | getHeadData(int index) 管理情報設定ヘッダセグメントが既に存在するかチェックします。
InternationalArtnos | getInternationalArtnos(int index) 国際商品コード (EAN)が既に存在するかチェックします。
MaterialDescription | getMaterialDescription(int index) 品目テキストが既に存在するかチェックします。
MaterialLongText | getMaterialLongText(int index) テキスト (長)が既に存在するかチェックします。
PlanningDataList | getPlanningDataList(int index) 品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。
PlantDataList | getPlantDataList(int index) 品目データ (プラントレベル)が既に存在するかチェックします。
PrtData | getPrtData(int index) 品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。
SalesDataList | getSalesDataList(int index) 販売データが既に存在するかチェックします。
StorageLocationDataList | getStorageLocationDataList(int index) 品目データ (保管場所レベル)が既に存在するかチェックします。
StorageTypeDataList | getStorageTypeDataList(int index) 保管域タイプデータが既に存在するかチェックします。
TaxClassifications | getTaxClassifications(int index) 制御デ－タが既に存在するかチェックします。
TotalConsumption | getTotalConsumption(int index) 品目総消費量のデータ転送が既に存在するかチェックします。
UnitSofmeasure | getUnitSofmeasure(int index) 数量単位が既に存在するかチェックします。
UnplndConsumption | getUnplndConsumption(int index) 計画外消費のデータ転送が既に存在するかチェックします。
ValuationDataList | getValuationDataList(int index) 評価データが既に存在するかチェックします。
WarehouseNumberDataList | getWarehouseNumberDataList(int index) 倉庫番号データが既に存在するかチェックします。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica から継承したメソッド
getClientDataList, getExtensionInList, getExtensionInXList, getFlagCadCall, getFlagOnline, getForecastParametersList, getForecastValuesList, getHeadDataList, getInpfldcheck, getInternationalArtnosList, getMaterialDescriptionList, getMaterialLongTextList, getNoappllog, getNochangedoc, getNoRollbackWork, getPlanningDataList, getPlantDataList, getPrtDataList, getReturnMessagesList, getSalesDataList, getStorageLocationDataList, getStorageTypeDataList, getTaxClassificationsList, getTestrun, getTotalConsumptionList, getUnitSofmeasureList, getUnplndConsumptionList, getValuationDataList, getWarehouseNumberDataList, initMaterialSaveReplica, setClientDataList, setExportParam, setExtensionInList, setExtensionInXList, setFlagCadCall, setFlagOnline, setForecastParametersList, setForecastValuesList, setHeadDataList, setImportParam, setInpfldcheck, setInternationalArtnosList, setMaterialDescriptionList, setMaterialLongTextList, setNoappllog, setNochangedoc, setNoRollbackWork, setPlanningDataList, setPlantDataList, setPrtDataList, setReturnMessagesList, setSalesDataList, setStorageLocationDataList, setStorageTypeDataList, setTaxClassificationsList, setTestrun, setTotalConsumptionList, setUnitSofmeasureList, setUnplndConsumptionList, setValuationDataList, setWarehouseNumberDataList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialSaveReplicaController

public MaterialSaveReplicaController()
コンストラクタ生成

MaterialSaveReplicaController

public MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成

パラメータ:
connectionManager - コネクションオブジェクト

MaterialSaveReplicaController

public MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより品目マスタを更新します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getHeadData

public HeadData getHeadData(int index)
管理情報設定ヘッダセグメントが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 管理情報設定ヘッダセグメントオブジェクト

getClientDataList

public ClientDataList getClientDataList(int index)
品目データ (クライアントレベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (クライアントレベル) オブジェクト

getPlantDataList

public PlantDataList getPlantDataList(int index)
品目データ (プラントレベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (プラントレベル) オブジェクト

getForecastParametersList

public ForecastParametersList getForecastParametersList(int index)
需要予測パラメータが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 需要予測パラメータオブジェクト

getPlanningDataList

public PlanningDataList getPlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目マスタ/製品グループの変更伝票構造オブジェクト

getStorageLocationDataList

public StorageLocationDataList getStorageLocationDataList(int index)
品目データ (保管場所レベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (保管場所レベル) オブジェクト

getValuationDataList

public ValuationDataList getValuationDataList(int index)
評価データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 評価データオブジェクト

getWarehouseNumberDataList

public WarehouseNumberDataList getWarehouseNumberDataList(int index)
倉庫番号データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 倉庫番号データオブジェクト

getSalesDataList

public SalesDataList getSalesDataList(int index)
販売データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 販売データオブジェクト

getStorageTypeDataList

public StorageTypeDataList getStorageTypeDataList(int index)
保管域タイプデータが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 保管域タイプデータオブジェクト

getMaterialDescription

public MaterialDescription getMaterialDescription(int index)
品目テキストが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目テキストオブジェクト

getUnitSofmeasure

public UnitSofmeasure getUnitSofmeasure(int index)
数量単位が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 数量単位オブジェクト

getInternationalArtnos

public InternationalArtnos getInternationalArtnos(int index)
国際商品コード (EAN)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 国際商品コード (EAN)オブジェクト

getMaterialLongText

public MaterialLongText getMaterialLongText(int index)
テキスト (長)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj テキスト (長)オブジェクト

getTaxClassifications

public TaxClassifications getTaxClassifications(int index)
制御デ－タが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 制御デ－タオブジェクト

getPrtData

public PrtData getPrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目マスタの生産資源/治工具 (PRT) 項目オブジェクト

getExtensionIn

public ExtensionIn getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 オブジェクト

getExtensionInX

public ExtensionInX getExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 拡張イン/拡張アウトのチェックボックス構造オブジェクト

getForecastValues

public ForecastValues getForecastValues(int index)
需要予測値のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 需要予測値のデータ転送オブジェクト

getUnplndConsumption

public UnplndConsumption getUnplndConsumption(int index)
計画外消費のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 計画外消費のデータ転送オブジェクト

getTotalConsumption

public TotalConsumption getTotalConsumption(int index)
品目総消費量のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目総消費量のデータ転送オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialShortDescsel (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialShortDescsel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel
すべての実装インタフェース:
Serializable
public class MaterialShortDescsel
extends Selection
implements Serializable

品目テキストの選択オプションクラス
機能は以下の通り

  • 品目テキストの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialShortDescsel()
品目テキストの選択オプション情報を作成します。
MaterialShortDescsel(int index)
品目テキストの選択オプション情報を作成します。
メソッドの概要
String | getDescrHigh() 終了品目テキストを取得します。
String | getDescrLow() 開始品目テキストを取得します。
int | getIndex() レコード番号を取得します。
void | setDescrHigh(String strDescrHigh) 終了品目テキストを設定します。
void | setDescrLow(String strDescrLow) 開始品目テキストを設定します。
void | setIndex(int index) レコード番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialShortDescsel

public MaterialShortDescsel()
品目テキストの選択オプション情報を作成します。

MaterialShortDescsel

public MaterialShortDescsel(int index)
品目テキストの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDescrLow

public String getDescrLow()
開始品目テキストを取得します。

戻り値:
srtDescrLow 開始品目テキスト

getDescrHigh

public String getDescrHigh()
終了品目テキストを取得します。

戻り値:
srtDescrHigh 品目テキスト

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setDescrLow

public void setDescrLow(String strDescrLow)
開始品目テキストを設定します。

パラメータ:
strDescrLow - 開始品目テキスト

setDescrHigh

public void setDescrHigh(String strDescrHigh)
終了品目テキストを設定します。

パラメータ:
strDescrHigh - 品目テキスト

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MatnrList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MatnrList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.MatnrList
すべての実装インタフェース:
Serializable
public class MatnrList
extends Object
implements Serializable

品目コードと品目テキストの一覧クラス
機能は以下の通り

  • 品目コードと品目テキストの一覧の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MatnrList()
品目コードと品目テキストの一覧情報を作成します。
メソッドの概要
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatlDesc() 品目テキストを取得します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String strMaterialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String strMaterialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatlDesc(String strMatlDesc) 品目テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MatnrList

public MatnrList()
品目コードと品目テキストの一覧情報を作成します。

メソッドの詳細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
srtMaterial

getMatlDesc

public String getMatlDesc()
品目テキストを取得します。

戻り値:
srtMatlDesc

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
srtMaterialExternal

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
srtMaterialGuid

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
srtMaterialVersion

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setMatlDesc

public void setMatlDesc(String strMatlDesc)
品目テキストを設定します。

パラメータ:
strMatlDesc - 品目テキスト

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
strMaterialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
strMaterialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
strMaterialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MatnrSelection (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MatnrSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection
すべての実装インタフェース:
Serializable
public class MatnrSelection
extends Selection
implements Serializable

品目コードの選択オプションクラス
機能は以下の通り

  • 品目コードの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MatnrSelection()
品目コードの選択オプション情報を作成します。
MatnrSelection(int index)
品目コードの選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getMatnrHigh() 終了品目コードを取得します。
String | getMatnrLow() 開始品目コードを取得します。
void | setIndex(int index) レコード番号を設定します。
void | setMatnrHigh(String strMatnrHigh) 終了品目コードを設定します。
void | setMatnrLow(String strMatnrLow) 開始品目コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MatnrSelection

public MatnrSelection()
品目コードの選択オプション情報を作成します。

MatnrSelection

public MatnrSelection(int index)
品目コードの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMatnrLow

public String getMatnrLow()
開始品目コードを取得します。

戻り値:
srtMatnrLow 開始品目コード

getMatnrHigh

public String getMatnrHigh()
終了品目コードを取得します。

戻り値:
srtMatnrHigh 終了品目コード

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setMatnrLow

public void setMatnrLow(String strMatnrLow)
開始品目コードを設定します。

パラメータ:
strMatnrLow - 開始品目コード

setMatnrHigh

public void setMatnrHigh(String strMatnrHigh)
終了品目コードを設定します。

パラメータ:
strMatnrHigh - 終了品目コード

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase
クラス
AllVersions
Cond
ContractLimits
ContractService
ContractServiceAccount
ContractServiceText
DeliveryAddress
DistributionChannelSelection
ExportHeader
ExportItem
Extension
GoodsMvtCreateController
GoodsMvtGetItemsController
Limits
ManufacturerPartNumb
MaterialAvailabilityController
MaterialGetAllController
MaterialGetList
MaterialGetListController
MaterialSaveReplicaController
MaterialShortDescsel
MatnrList
MatnrSelection
ParamAllVersions
ParamCondHeader
ParamCondItem
ParamContractLimits
ParamContractService
ParamContractServiceAccount
ParamContractServiceText
ParamDeliveryAddress
ParamExportHeader
ParamExportItem
ParamExtension
ParamHeader
ParamHeaderText
ParamItem
ParamItemText
ParamLimits
ParamPartner
ParamProfitSegment
ParamPurchaseAccount
ParamPurchaseComponents
ParamPurchaseConfirmation
ParamPurchaseHistory
ParamPurchaseHistoryTotals
ParamPurchaseSchedule
ParamPurchaseShipping
ParamPurchaseShippingExp
ParamVendorAddress
ParamVersions
Partner
PlantSelection
ProfitSegment
PurchaseAccount
PurchaseComponents
PurchaseConfirmation
PurchaseGetItemSrel
PurchaseGetItemSrelController
PurchaseHeader
PurchaseHeaderPost
PurchaseHeaders
PurchaseHistory
PurchaseHistoryTotals
PurchaseItem
PurchaseItemPost
PurchaseItems
PurchaseOrderPayPost
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseRelease
PurchaseReleaseController
PurchaseResetReleaseController
PurchaseSchedule
PurchaseShipping
PurchaseShippingExp
PurchaseText
SalesOrganisationSelection
Selection
StdMaterialGetIntNumberController
StorageLocationSelect
SupplierDetail
SupplierExistenceCheck
SupplierExistenceCheckController
SupplierGetDetailController
VendorAddress
Versions


jp.co.intra_mart.foundation.sap.module.purchase (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase

ＳＡＰ連携経費購買系に関するクラスを提供します。

参照:
説明

クラスの概要
AllVersions | 全バージョン管理情報クラス 機能は以下の通り 全バージョン管理情報を保持します。
Cond | 条件情報クラス 機能は以下の通り 条件情報を保持します。
ContractLimits | 外注基本契約制限情報クラス 機能は以下の通り 外注基本契約情報を保持します。
ContractService | 外注サービス情報クラス 機能は以下の通り 外注サービス情報を保持します。
ContractServiceAccount | 外注サービス勘定設定情報クラス 機能は以下の通り 外注サービス勘定設定情報を保持します。
ContractServiceText | 外注サービステキスト情報クラス 機能は以下の通り 外注サービステキスト情報を保持します。
DeliveryAddress | 入荷伝票アドレス情報クラス 機能は以下の通り 入荷伝票アドレス情報を保持します。
DistributionChannelSelection | 流通チャネルの選択オプションクラス 機能は以下の通り 流通チャネルの選択オプションの情報を保持します。
ExportHeader | 貿易管理ヘッダ情報クラス 機能は以下の通り 貿易管理ヘッダ情報を保持します。
ExportItem | 貿易管理明細情報クラス 機能は以下の通り 貿易管理明細情報を保持します。
Extension | 拡張得意先項目情報クラス 機能は以下の通り 拡張得意先項目情報を保持します。
GoodsMvtCreateController | 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
GoodsMvtGetItemsController | 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
Limits | 外注制限情報クラス 機能は以下の通り 外注制限情報を保持します。
ManufacturerPartNumb | 製造業者と製造者製品コードクラス 機能は以下の通り 製造業者と製造者製品コードの情報を保持します。
MaterialAvailabilityController | 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
MaterialGetAllController | 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
MaterialGetList | 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
MaterialGetListController | 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
MaterialSaveReplicaController | 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
MaterialShortDescsel | 品目テキストの選択オプションクラス 機能は以下の通り 品目テキストの選択オプションの情報を保持します。
MatnrList | 品目コードと品目テキストの一覧クラス 機能は以下の通り 品目コードと品目テキストの一覧の情報を保持します。
MatnrSelection | 品目コードの選択オプションクラス 機能は以下の通り 品目コードの選択オプションの情報を保持します。
ParamAllVersions | 全バージョンパラメータ設定クラス 機能は以下の通り 全バージョンのパラメータを設定します。
ParamCondHeader | 条件ヘッダパラメータ設定クラス 機能は以下の通り 条件ヘッダのパラメータを設定します。
ParamCondItem | 条件明細パラメータ設定ラクラス 機能は以下の通り 条件明細のパラメータを設定します。
ParamContractLimits | 外注基本契約制限パラメータ設定クラス 機能は以下の通り 外注基本契約制限のパラメータを設定します。
ParamContractService | 外注サービスパラメータ設定クラス 機能は以下の通り 外注サービスのパラメータを設定します。
ParamContractServiceAccount | 外注サービス勘定設定パラメータ設定クラス 機能は以下の通り 外注サービス勘定設定のパラメータを設定します。
ParamContractServiceText | 外注サービステキストパラメータ設定クラス 機能は以下の通り 外注サービステキストのパラメータを設定します。
ParamDeliveryAddress | 入荷伝票アドレスパラメータ設定ラクラス 機能は以下の通り 入荷伝票アドレスのパラメータを設定します。
ParamExportHeader | 貿易管理ヘッダパラメータ設定ラクラス 機能は以下の通り 貿易管理ヘッダのパラメータを設定します。
ParamExportItem | 貿易管理明細インポートパラメータ設定クラス 機能は以下の通り 貿易管理明細のパラメータを設定します。
ParamExtension | 拡張得意先項目パラメータ設定クラス 機能は以下の通り 拡張得意先項目のパラメータを設定します。
ParamHeader | 伝票ヘッダパラメータ設定クラス 機能は以下の通り 伝票ヘッダのインポートパラメータを設定します。
ParamHeaderText | ヘッダテキストパラメータ設定クラス 機能は以下の通り ヘッダテキストのパラメータを設定します。
ParamItem | 明細パラメータ設定クラス 機能は以下の通り 明細のパラメータを設定します。
ParamItemText | 明細テキストパラメータ設定クラス 機能は以下の通り 明細テキストのパラメータを設定します。
ParamLimits | 外注制限パラメータ設定クラス 機能は以下の通り 外注制限のパラメータを設定します。
ParamPartner | 得意先インポートパラメータ設定クラス 機能は以下の通り 得意先のパラメータを設定します。
ParamProfitSegment | 入出庫予定パラメータ設定クラス 機能は以下の通り 入出庫予定のパラメータを設定します。
ParamPurchaseAccount | 勘定設定パラメータ設定クラス 機能は以下の通り 勘定設定のパラメータを設定します。
ParamPurchaseComponents | コンポーネントパラメータ設定クラス 機能は以下の通り コンポーネントのパラメータを設定します。
ParamPurchaseConfirmation | 転送構造：照会／一覧情報パラメータ設定クラス 機能は以下の通り 転送構造：照会／一覧情報のパラメータを設定します。
ParamPurchaseHistory | 購買発注履歴情報パラメータ設定クラス 機能は以下の通り 購買発注履歴情報のパラメータを設定します。
ParamPurchaseHistoryTotals | 購買発注履歴(合計)情報パラメータ設定クラス 機能は以下の通り 購買発注履歴(合計)情報のパラメータを設定します。
ParamPurchaseSchedule | 納入日程パラメータ設定クラス 機能は以下の通り 納入日程のパラメータを設定します。
ParamPurchaseShipping | 出荷データパラメータ設定クラス 機能は以下の通り 出荷データのパラメータを設定します。
ParamPurchaseShippingExp | 出荷データエクスポート情報パラメータ設定クラス 機能は以下の通り 出荷データエクスポート情報のパラメータを設定します。
ParamVendorAddress | 仕入先住所パラメータ設定クラス 機能は以下の通り 仕入先住所のパラメータを設定します。
ParamVersions | バージョン管理パラメータ設定ラクラス 機能は以下の通り バージョン管理のパラメータを設定します。
Partner | 取引先情報クラス 機能は以下の通り 取引先情報を保持します。
PlantSelection | プラントの選択オプションクラス 機能は以下の通り プラントの選択オプションの情報を保持します。
ProfitSegment | 入出庫予定情報クラス 機能は以下の通り 入出庫予定情報を保持します。
PurchaseAccount | 購買発注伝票勘定情報クラス 機能は以下の通り 購買発注伝票勘定情報を保持します。
PurchaseComponents | コンポーネント情報クラス 機能は以下の通り コンポーネント情報を保持します。
PurchaseConfirmation | 転送構造：照会／一覧情報クラス 機能は以下の通り 転送構造：照会／一覧情報を保持します。
PurchaseGetItemSrel | 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
PurchaseGetItemSrelController | 伝票の承認対象一覧取得コントローラクラス 機能は以下の通り 伝票の承認対象一覧を取得します。
PurchaseHeader | 購買発注ヘッダ情報スーパークラス 機能は以下の通り 購買発注のヘッダ情報を保持します。
PurchaseHeaderPost | 購買発注伝票ヘッダ情報クラス 機能は以下の通り 購買発注伝票ヘッダの情報を保持します。
PurchaseHeaders | 伝票の承認対象一覧ヘッダ情報クラス 機能は以下の通り 伝票の承認対象一覧ヘッダの情報を保持します。
PurchaseHistory | 購買発注履歴情報クラス 機能は以下の通り 購買発注履歴情報を保持します。
PurchaseHistoryTotals | 購買発注履歴（合計）情報クラス 機能は以下の通り 購買発注履歴（合計）情報を保持します。
PurchaseItem | 購買発注明細情報スーパークラス 機能は以下の通り 購買発注の明細情報を保持します。
PurchaseItemPost | 購買発注伝票明細情報クラス 機能は以下の通り 購買発注伝票明細情報を保持します。
PurchaseItems | 伝票の承認対象明細情報クラス 機能は以下の通り 伝票の承認対象明細情報を保持します。
PurchaseOrderPayPost | 伝票登録クラス 機能は以下の通り 伝票を登録します。
PurchaseOrderPayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
PurchaseOrderPostChangeController | 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
PurchaseRelease | 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
PurchaseReleaseController | 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
PurchaseResetReleaseController | 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。
PurchaseSchedule | 購買発注伝票納入日程情報クラス 機能は以下の通り 購買発注伝票納入日程情報を保持します。
PurchaseShipping | 出荷データクラス 機能は以下の通り 出荷データを保持します。
PurchaseShippingExp | 出荷データエクスポートクラス 機能は以下の通り 出荷データエクスポート情報を保持します。
PurchaseText | 購買発注伝票テキストクラス 機能は以下の通り 購買発注伝テキストを保持します。
SalesOrganisationSelection | 販売組織の選択オプションクラス 機能は以下の通り 販売組織の選択オプションの情報を保持します。
Selection | 選択オプションクラス 機能は以下の通り 選択オプションの情報を保持します。
StdMaterialGetIntNumberController | 品目コード割当済照会コントローラクラス。
StorageLocationSelect | 保管場所の選択オプションクラス 機能は以下の通り 保管場所の選択オプションの情報を保持します。
SupplierDetail | 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
SupplierExistenceCheck | 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。
SupplierExistenceCheckController | 仕入先コード存在チェックコントローラ 機能は以下の通り 仕入先コード存在チェックを行います。
SupplierGetDetailController | 仕入先マスタの詳細情報取得コントローラ 機能は以下の通り 仕入先マスタの詳細情報を取得します。
VendorAddress | 仕入先住所情報クラス 機能は以下の通り 仕入先住所を保持します。
Versions | バージョン管理情報クラス 機能は以下の通り バージョン管理情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.purchase の説明

ＳＡＰ連携経費購買系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.purchase クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Cond (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Extension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
    • class jp.co.intra_mart.foundation.sap.module.purchase.Limits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Partner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
    • class jp.co.intra_mart.foundation.sap.module.purchase.Selection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Versions (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase の使用

jp.co.intra_mart.foundation.sap.module.purchase を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase のクラス
ExportHeader
貿易管理ヘッダ情報クラス
機能は以下の通り
貿易管理ヘッダ情報を保持します。
MaterialGetList
品目コード検索クラス
機能は以下の通り
品目コード、テキストを検索します。
PurchaseGetItemSrel
伝票承認対象一覧情報クラス
機能は以下の通り
伝票承認対象一覧を取得します。
PurchaseHeader
購買発注ヘッダ情報スーパークラス
機能は以下の通り
購買発注のヘッダ情報を保持します。
PurchaseHeaderPost
購買発注伝票ヘッダ情報クラス
機能は以下の通り
購買発注伝票ヘッダの情報を保持します。
PurchaseItem
購買発注明細情報スーパークラス
機能は以下の通り
購買発注の明細情報を保持します。
PurchaseOrderPayPost
伝票登録クラス
機能は以下の通り
伝票を登録します。
PurchaseRelease
承認情報スーパークラス
機能は以下の通り
承認情報を保持します。
PurchaseText
購買発注伝票テキストクラス
機能は以下の通り
購買発注伝テキストを保持します。
Selection
選択オプションクラス
機能は以下の通り
選択オプションの情報を保持します。
SupplierDetail
仕入先マスタ詳細情報クラス
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierExistenceCheck
仕入先コード存在チェッククラス
機能は以下の通り
仕入先コード存在チェック結果を取得します。
VendorAddress
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。
Versions
バージョン管理情報クラス
機能は以下の通り
バージョン管理情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamAllVersions (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamAllVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions
すべての実装インタフェース:
Serializable
public final class ParamAllVersions
extends Object
implements Serializable

全バージョンパラメータ設定クラス
機能は以下の通り

  • 全バージョンのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, List allVersionsList)
全バージョンに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List allVersionsList)
                           throws SAPGeneralSystemException
全バージョンに値をセットします。

パラメータ:
bapiController - BapiController
allVersionsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCondHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamCondHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader
すべての実装インタフェース:
Serializable
public final class ParamCondHeader
extends Object
implements Serializable

条件ヘッダパラメータ設定クラス
機能は以下の通り

  • 条件ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List condHeaderList)
条件ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List condHeaderList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
condHeaderList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCondItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamCondItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem
すべての実装インタフェース:
Serializable
public final class ParamCondItem
extends Object
implements Serializable

条件明細パラメータ設定ラクラス
機能は以下の通り

  • 条件明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List condItemList)
条件明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List condItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件明細に値をセットします。

パラメータ:
bapiController - BapiController
condItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractLimits (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits
すべての実装インタフェース:
Serializable
public final class ParamContractLimits
extends Object
implements Serializable

外注基本契約制限パラメータ設定クラス
機能は以下の通り

  • 外注基本契約制限のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractLimitsList)
外注基本契約制限に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractLimitsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注基本契約制限に値をセットします。

パラメータ:
bapiController - BapiController
contractLimitsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractService (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractService

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService
すべての実装インタフェース:
Serializable
public final class ParamContractService
extends Object
implements Serializable

外注サービスパラメータ設定クラス
機能は以下の通り

  • 外注サービスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceList)
外注サービスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービスに値をセットします。

パラメータ:
bapiController - BapiController
contractServiceList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractServiceAccount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractServiceAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount
すべての実装インタフェース:
Serializable
public final class ParamContractServiceAccount
extends Object
implements Serializable

外注サービス勘定設定パラメータ設定クラス
機能は以下の通り

  • 外注サービス勘定設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceAccountList)
外注サービス勘定設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceAccountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービス勘定設定に値をセットします。

パラメータ:
bapiController - BapiController
contractServiceAccountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractServiceText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractServiceText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText
すべての実装インタフェース:
Serializable
public final class ParamContractServiceText
extends Object
implements Serializable

外注サービステキストパラメータ設定クラス
機能は以下の通り

  • 外注サービステキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceTextList)
外注サービステキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービステキストに値をセットします。

パラメータ:
bapiController - BapiController
contractServiceTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamDeliveryAddress (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamDeliveryAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress
すべての実装インタフェース:
Serializable
public final class ParamDeliveryAddress
extends Object
implements Serializable

入荷伝票アドレスパラメータ設定ラクラス
機能は以下の通り

  • 入荷伝票アドレスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List deliveryAddressList)
入荷伝票アドレスヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List deliveryAddressList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入荷伝票アドレスヘッダに値をセットします。

パラメータ:
bapiController - BapiController
deliveryAddressList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExportHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExportHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader
すべての実装インタフェース:
Serializable
public final class ParamExportHeader
extends Object
implements Serializable

貿易管理ヘッダパラメータ設定ラクラス
機能は以下の通り

  • 貿易管理ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
static void | setImportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  ExportHeader exportHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
貿易管理ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
exportHeader - ExportHeader
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  ExportHeader exportHeader)
                           throws SAPGeneralSystemException
貿易管理ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
exportHeader - ExportHeader
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExportItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExportItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem
すべての実装インタフェース:
Serializable
public final class ParamExportItem
extends Object
implements Serializable

貿易管理明細インポートパラメータ設定クラス
機能は以下の通り

  • 貿易管理明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List exportItemList)
貿易管理明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List exportItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
貿易管理明細に値をセットします。

パラメータ:
bapiController - BapiController
exportItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtension (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExtension

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension
すべての実装インタフェース:
Serializable
public final class ParamExtension
extends Object
implements Serializable

拡張得意先項目パラメータ設定クラス
機能は以下の通り

  • 拡張得意先項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionList) 拡張得意先項目に値をセットします。
static void | setImportParam(BapiController bapiController, List extensionList) 拡張得意先項目に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensionList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
拡張得意先項目に値をセットします。

パラメータ:
bapiController - BapiController
extensionList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionList)
                           throws SAPGeneralSystemException
拡張得意先項目に値をセットします。

パラメータ:
bapiController - BapiController
extensionList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader
すべての実装インタフェース:
Serializable
public final class ParamHeader
extends Object
implements Serializable

伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • 伝票ヘッダのインポートパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
static void | setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  PurchaseHeaderPost documentHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  PurchaseHeaderPost documentHeader)
                           throws SAPGeneralSystemException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamHeaderText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText
すべての実装インタフェース:
Serializable
public final class ParamHeaderText
extends Object
implements Serializable

ヘッダテキストパラメータ設定クラス
機能は以下の通り

  • ヘッダテキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List headerTextList)
ヘッダテキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List headerTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ヘッダテキストに値をセットします。

パラメータ:
bapiController - BapiController
headerTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamItem
すべての実装インタフェース:
Serializable
public final class ParamItem
extends Object
implements Serializable

明細パラメータ設定クラス
機能は以下の通り

  • 明細のパラメータを設定します。

関連項目:
直列化された形式

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamItemText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText
すべての実装インタフェース:
Serializable
public final class ParamItemText
extends Object
implements Serializable

明細テキストパラメータ設定クラス
機能は以下の通り

  • 明細テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List itemTextList)
明細テキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細テキストに値をセットします。

パラメータ:
bapiController - BapiController
itemTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamLimits (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits
すべての実装インタフェース:
Serializable
public final class ParamLimits
extends Object
implements Serializable

外注制限パラメータ設定クラス
機能は以下の通り

  • 外注制限のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List limitsList)
外注制限に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List limitsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注制限に値をセットします。

パラメータ:
bapiController - BapiController
limitsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartner (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPartner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner
すべての実装インタフェース:
Serializable
public final class ParamPartner
extends Object
implements Serializable

得意先インポートパラメータ設定クラス
機能は以下の通り

  • 得意先のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List partnerList)
得意先に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnerList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
得意先に値をセットします。

パラメータ:
bapiController - BapiController
partnerList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamProfitSegment (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamProfitSegment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment
すべての実装インタフェース:
Serializable
public final class ParamProfitSegment
extends Object
implements Serializable

入出庫予定パラメータ設定クラス
機能は以下の通り

  • 入出庫予定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List profitSegmentList)
入出庫予定ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List profitSegmentList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入出庫予定ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
profitSegmentList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseAccount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount
すべての実装インタフェース:
Serializable
public final class ParamPurchaseAccount
extends Object
implements Serializable

勘定設定パラメータ設定クラス
機能は以下の通り

  • 勘定設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List purchaseAccountList)
勘定設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseAccountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
勘定設定に値をセットします。

パラメータ:
bapiController - BapiController
purchaseAccountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseComponents (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseComponents

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents
すべての実装インタフェース:
Serializable
public final class ParamPurchaseComponents
extends Object
implements Serializable

コンポーネントパラメータ設定クラス
機能は以下の通り

  • コンポーネントのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List purchaseComponentsList) コンポーネントにエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List purchaseComponentsList) コンポーネントにインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseComponentsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
コンポーネントにインポートする値をセットします。

パラメータ:
bapiController - BapiController
purchaseComponentsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List purchaseComponentsList)
                           throws SAPGeneralSystemException
コンポーネントにエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
purchaseComponentsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseConfirmation (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseConfirmation

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation
すべての実装インタフェース:
Serializable
public final class ParamPurchaseConfirmation
extends Object
implements Serializable

転送構造：照会／一覧情報パラメータ設定クラス
機能は以下の通り

  • 転送構造：照会／一覧情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List purchaseConfirmationList) 転送構造：照会／一覧情報にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List purchaseConfirmationList) 転送構造：照会／一覧情報にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseConfirmationList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
転送構造：照会／一覧情報にインポートする値をセットします。

パラメータ:
bapiController - BapiController
purchaseConfirmationList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List purchaseConfirmationList)
                           throws SAPGeneralSystemException
転送構造：照会／一覧情報にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
purchaseConfirmationList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseHistory (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseHistory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory
すべての実装インタフェース:
Serializable
public final class ParamPurchaseHistory
extends Object
implements Serializable

購買発注履歴情報パラメータ設定クラス
機能は以下の通り

  • 購買発注履歴情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List purchaseHistoryList) 購買発注履歴情報にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List purchaseHistoryList) 購買発注履歴情報にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseHistoryList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
購買発注履歴情報にインポートする値をセットします。

パラメータ:
bapiController - BapiController
purchaseHistoryList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List purchaseHistoryList)
                           throws SAPGeneralSystemException
購買発注履歴情報にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
purchaseHistoryList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseHistoryTotals (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseHistoryTotals

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals
すべての実装インタフェース:
Serializable
public final class ParamPurchaseHistoryTotals
extends Object
implements Serializable

購買発注履歴(合計)情報パラメータ設定クラス
機能は以下の通り

  • 購買発注履歴(合計)情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List purchaseHistoryTotalsList) 購買発注履歴(合計)情報にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List purchaseHistoryTotalsList) 購買発注履歴(合計)情報にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseHistoryTotalsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
購買発注履歴(合計)情報にインポートする値をセットします。

パラメータ:
bapiController - BapiController
purchaseHistoryTotalsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List purchaseHistoryTotalsList)
                           throws SAPGeneralSystemException
購買発注履歴(合計)情報にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
purchaseHistoryTotalsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseSchedule (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseSchedule

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule
すべての実装インタフェース:
Serializable
public final class ParamPurchaseSchedule
extends Object
implements Serializable

納入日程パラメータ設定クラス
機能は以下の通り

  • 納入日程のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List purchaseScheduleList)
納入日程に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseScheduleList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程に値をセットします。

パラメータ:
bapiController - BapiController
purchaseScheduleList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseShipping (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseShipping

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping
すべての実装インタフェース:
Serializable
public final class ParamPurchaseShipping
extends Object
implements Serializable

出荷データパラメータ設定クラス
機能は以下の通り

  • 出荷データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List purchaseShippingList) 出荷データにエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List purchaseShippingList) 出荷データにインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseShippingList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
出荷データにインポートする値をセットします。

パラメータ:
bapiController - BapiController
purchaseShippingList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List purchaseShippingList)
                           throws SAPGeneralSystemException
出荷データにエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
purchaseShippingList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseShippingExp (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseShippingExp

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp
すべての実装インタフェース:
Serializable
public class ParamPurchaseShippingExp
extends Object
implements Serializable

出荷データエクスポート情報パラメータ設定クラス
機能は以下の通り

  • 出荷データエクスポート情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List purchaseShippingExpList) 出荷データ（エクスポート）にエクスポートされた値をセットします。
static void | setImportParam(BapiController bapiController, List purchaseShippingExpList) 出荷データ（エクスポート）にインポートする値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseShippingExpList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
出荷データ（エクスポート）にインポートする値をセットします。

パラメータ:
bapiController - BapiController
purchaseShippingExpList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List purchaseShippingExpList)
                           throws SAPGeneralSystemException
出荷データ（エクスポート）にエクスポートされた値をセットします。

パラメータ:
bapiController - BapiController
purchaseShippingExpList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVendorAddress (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamVendorAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress
すべての実装インタフェース:
Serializable
public final class ParamVendorAddress
extends Object
implements Serializable

仕入先住所パラメータ設定クラス
機能は以下の通り

  • 仕入先住所のパラメータを設定します。

関連項目:
直列化された形式

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVersions (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions
すべての実装インタフェース:
Serializable
public final class ParamVersions
extends Object
implements Serializable

バージョン管理パラメータ設定ラクラス
機能は以下の通り

  • バージョン管理のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, Versions versions)
バージョン管理に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  Versions versions)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
バージョン管理に値をセットします。

パラメータ:
bapiController - BapiController
versions - Versions
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Partner (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Partner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Partner
すべての実装インタフェース:
Serializable
public class Partner
extends Object
implements Serializable

取引先情報クラス
機能は以下の通り

  • 取引先情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Partner()
取引先を作成します。
Partner(int index)
取引先を作成します。
メソッドの概要
String | getBuspartno() 取引先の仕入先マスタコードを取得します。
String | getDeleteInd() 削除フラグを取得します｡
String | getLangu() 言語キーを取得します。
int | getPaIndex() レコード番号を取得します｡
String | getPartnerdesc() 言語別取引先機能テキストを取得します。
void | setBuspartno(String strBuspartno) 取引先の仕入先マスタコードを設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します｡
void | setLangu(String strLangu) 言語キーを設定します。
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPartnerdesc(String strPartnerdesc) 言語別取引先機能テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Partner

public Partner()
取引先を作成します。

Partner

public Partner(int index)
取引先を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPartnerdesc

public String getPartnerdesc()
言語別取引先機能テキストを取得します。

戻り値:
srtPartnerdesc 言語別取引先機能テキスト

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getBuspartno

public String getBuspartno()
取引先の仕入先マスタコードを取得します。

戻り値:
srtBuspartno 取引先の仕入先マスタコード

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex レコード番号

getDeleteInd

public String getDeleteInd()
削除フラグを取得します｡

戻り値:
strDeleteInd 削除フラグ

setPartnerdesc

public void setPartnerdesc(String strPartnerdesc)
言語別取引先機能テキストを設定します。

パラメータ:
strPartnerdesc - 言語別取引先機能テキスト

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setBuspartno

public void setBuspartno(String strBuspartno)
取引先の仕入先マスタコードを設定します。

パラメータ:
strBuspartno - 取引先の仕入先マスタコード

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します｡

パラメータ:
strDeleteInd - 削除フラグ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantSelection (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PlantSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection
すべての実装インタフェース:
Serializable
public class PlantSelection
extends Selection
implements Serializable

プラントの選択オプションクラス
機能は以下の通り

  • プラントの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantSelection()
プラントの選択オプション情報を作成します。
PlantSelection(int index)
Sプラントの選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getPlantHigh() 対象プラント 終了を取得します。
String | getPlantLow() 対象プラント 開始を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setPlantHigh(String strPlantHigh) 対象プラント 終了を設定します。
void | setPlantLow(String strPlantLow) 対象プラント 開始を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantSelection

public PlantSelection()
プラントの選択オプション情報を作成します。

PlantSelection

public PlantSelection(int index)
Sプラントの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPlantLow

public String getPlantLow()
対象プラント 開始を取得します。

戻り値:
srtPlantLow 対象プラント 開始

getPlantHigh

public String getPlantHigh()
対象プラント 終了を取得します。

戻り値:
srtPlantHigh 対象プラント 終了

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setPlantLow

public void setPlantLow(String strPlantLow)
対象プラント 開始を設定します。

パラメータ:
strPlantLow - 対象プラント 開始

setPlantHigh

public void setPlantHigh(String strPlantHigh)
対象プラント 終了を設定します。

パラメータ:
strPlantHigh - 対象プラント 終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitSegment (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ProfitSegment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment
すべての実装インタフェース:
Serializable
public class ProfitSegment
extends Object
implements Serializable

入出庫予定情報クラス
機能は以下の通り

  • 入出庫予定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitSegment()
入出庫予定を作成します。
ProfitSegment(int index)
入出庫予定を作成します。
メソッドの概要
String | getFieldname() 項目名を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
int | getPrIndex() レコード番号を取得します｡
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getValue() CO-PA 特性値を取得します。
void | setFieldname(String strFieldname) 項目名を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPrIndex(int prIndex) レコード番号を設定します｡
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setValue(String strValue) CO-PA 特性値を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitSegment

public ProfitSegment()
入出庫予定を作成します。

ProfitSegment

public ProfitSegment(int index)
入出庫予定を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getFieldname

public String getFieldname()
項目名を取得します。

戻り値:
srtFieldname 項目名

getValue

public String getValue()
CO-PA 特性値を取得します。

戻り値:
srtValue CO-PA 特性値

getPrIndex

public int getPrIndex()
レコード番号を取得します｡

戻り値:
prIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setFieldname

public void setFieldname(String strFieldname)
項目名を設定します。

パラメータ:
strFieldname - 項目名

setValue

public void setValue(String strValue)
CO-PA 特性値を設定します。

パラメータ:
strValue - CO-PA 特性値

setPrIndex

public void setPrIndex(int prIndex)
レコード番号を設定します｡

パラメータ:
prIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseAccount (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount
すべての実装インタフェース:
Serializable
public class PurchaseAccount
extends Object
implements Serializable

購買発注伝票勘定情報クラス
機能は以下の通り

  • 購買発注伝票勘定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseAccount()
購買発注伝票明細を作成します。
PurchaseAccount(int index)
購買発注伝票明細を作成します。
メソッドの概要
int | getAcIndex() レコード番号を取得します｡
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAssetNo() 資産番号を取得します。
String | getBusArea() 事業領域を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoArea() 管理領域を取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostobject() 原価対象を取得します。
String | getCreatDate() レコード登録日を取得します。
String | getDeleteInd() 削除フラグ: 購買伝票勘定設定を取得します。
String | getDistrPerc() 配賦率 % (複数勘定設定)を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrRcpt() 受領者を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getNetValue() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNondItax() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getOrderid() 指図番号を取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getQuantity() 数量を取得します。
String | getRecInd() リカバリフラグを取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getResDoc() 用途指定予算の伝票番号を取得します。
String | getResItem() 用途指定予算: 伝票明細を取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSdDoc() 販売管理伝票番号を取得します。
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getWbsElement() WBS 要素を取得します。
void | setAcIndex(int acIndex) レコード番号を設定します｡
void | setActivity(String strActivity) 作業番号を設定します。
void | setActtype(String strActtype) 活動タイプを設定します。
void | setAssetNo(String strAssetNo) 資産番号を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCmmtItem(String strCmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String strCmmtItemLong) 資金予算コードを設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCoBusproc(String strCoBusproc) 業務プロセスを設定します。
void | setCostcenter(String strCostcenter) 原価センタを設定します。
void | setCostobject(String strCostobject) 原価対象を設定します。
void | setCreatDate(String strCreatDate) レコード登録日を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグ: 購買伝票勘定設定を設定します。
void | setDistrPerc(String strDistrPerc) 配賦率 % (複数勘定設定)を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFund(String strFund) 会計区分を設定します。
void | setFundsCtr(String strFundsCtr) 予算センタを設定します。
void | setGlAccount(String strGlAccount) G/L 勘定コードを設定します。
void | setGrantNbr(String strGrantNbr) 補助金を設定します。
void | setGrRcpt(String strGrRcpt) 受領者を設定します。
void | setItmNumber(String strItmNumber) 販売伝票明細を設定します。
void | setNetValue(String strNetValue) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setNetwork(String strNetwork) 勘定割当のネットワーク番号を設定します。
void | setNondItax(String strNondItax) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setOrderid(String strOrderid) 指図番号を設定します。
void | setPartAcct(String strPartAcct) 取引先勘定コードを設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setQuantity(String strQuantity) 数量を設定します。
void | setRecInd(String strRecInd) リカバリフラグを設定します。
void | setRefDate(String strRefDate) 決済の参照日付を設定します。
void | setResDoc(String strResDoc) 用途指定予算の伝票番号を設定します。
void | setResItem(String strResItem) 用途指定予算: 伝票明細を設定します。
void | setRlEstKey(String strRlEstKey) 不動産管理対象の内部キーを設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
void | setSdDoc(String strSdDoc) 販売管理伝票番号を設定します。
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setSubNumber(String strSubNumber) 資産補助番号を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnloadPt(String strUnloadPt) 荷渡ポイントを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseAccount

public PurchaseAccount()
購買発注伝票明細を作成します。

PurchaseAccount

public PurchaseAccount(int index)
購買発注伝票明細を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getDeleteInd

public String getDeleteInd()
削除フラグ: 購買伝票勘定設定を取得します。

戻り値:
srtDeleteInd 削除フラグ: 購買伝票勘定設定

getCreatDate

public String getCreatDate()
レコード登録日を取得します。

戻り値:
srtCreatDate レコード登録日

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
srtQuantity 数量

getDistrPerc

public String getDistrPerc()
配賦率 % (複数勘定設定)を取得します。

戻り値:
srtDistrPerc 配賦率 % (複数勘定設定)

getNetValue

public String getNetValue()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
srtNetValue BAPI の通貨額 (小数点以下９桁)

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
srtGlAccount G/L 勘定コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
srtCostcenter 原価センタ

getSdDoc

public String getSdDoc()
販売管理伝票番号を取得します。

戻り値:
srtSdDoc 販売管理伝票番号

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
srtItmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
srtSchedLine 納入日程行

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
srtAssetNo 資産番号

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
srtSubNumber 資産補助番号

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
srtGrRcpt 受領者

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
srtUnloadPt 荷渡ポイント

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getCostobject

public String getCostobject()
原価対象を取得します。

戻り値:
srtCostobject 原価対象

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
srtNetwork 勘定割当のネットワーク番号

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
srtRlEstKey 不動産管理対象の内部キー

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
srtPartAcct 取引先勘定コード

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
srtCmmtItem 資金予算コード

getRecInd

public String getRecInd()
リカバリフラグを取得します。

戻り値:
srtRecInd リカバリフラグ

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
srtFundsCtr 予算センタ

getFund

public String getFund()
会計区分を取得します。

戻り値:
srtFund 会計区分

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
srtRefDate 決済の参照日付

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
srtTaxCode 消費税コード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getNondItax

public String getNondItax()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
srtNondItax BAPI の通貨額 (小数点以下９桁)

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
srtActtype 活動タイプ

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
srtCoBusproc 業務プロセス

getResDoc

public String getResDoc()
用途指定予算の伝票番号を取得します。

戻り値:
srtResDoc 用途指定予算の伝票番号

getResItem

public String getResItem()
用途指定予算: 伝票明細を取得します。

戻り値:
srtResItem 用途指定予算: 伝票明細

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
srtActivity 作業番号

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
srtGrantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
srtCmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getAcIndex

public int getAcIndex()
レコード番号を取得します｡

戻り値:
acIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグ: 購買伝票勘定設定を設定します。

パラメータ:
strDeleteInd - 削除フラグ: 購買伝票勘定設定

setCreatDate

public void setCreatDate(String strCreatDate)
レコード登録日を設定します。

パラメータ:
strCreatDate - レコード登録日

setQuantity

public void setQuantity(String strQuantity)
数量を設定します。

パラメータ:
strQuantity - 数量

setDistrPerc

public void setDistrPerc(String strDistrPerc)
配賦率 % (複数勘定設定)を設定します。

パラメータ:
strDistrPerc - 配賦率 % (複数勘定設定)

setNetValue

public void setNetValue(String strNetValue)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
strNetValue - BAPI の通貨額 (小数点以下９桁)

setGlAccount

public void setGlAccount(String strGlAccount)
G/L 勘定コードを設定します。

パラメータ:
strGlAccount - G/L 勘定コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setCostcenter

public void setCostcenter(String strCostcenter)
原価センタを設定します。

パラメータ:
strCostcenter - 原価センタ

setSdDoc

public void setSdDoc(String strSdDoc)
販売管理伝票番号を設定します。

パラメータ:
strSdDoc - 販売管理伝票番号

setItmNumber

public void setItmNumber(String strItmNumber)
販売伝票明細を設定します。

パラメータ:
strItmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setAssetNo

public void setAssetNo(String strAssetNo)
資産番号を設定します。

パラメータ:
strAssetNo - 資産番号

setSubNumber

public void setSubNumber(String strSubNumber)
資産補助番号を設定します。

パラメータ:
strSubNumber - 資産補助番号

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setGrRcpt

public void setGrRcpt(String strGrRcpt)
受領者を設定します。

パラメータ:
strGrRcpt - 受領者

setUnloadPt

public void setUnloadPt(String strUnloadPt)
荷渡ポイントを設定します。

パラメータ:
strUnloadPt - 荷渡ポイント

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setCostobject

public void setCostobject(String strCostobject)
原価対象を設定します。

パラメータ:
strCostobject - 原価対象

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setNetwork

public void setNetwork(String strNetwork)
勘定割当のネットワーク番号を設定します。

パラメータ:
strNetwork - 勘定割当のネットワーク番号

setRlEstKey

public void setRlEstKey(String strRlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
strRlEstKey - 不動産管理対象の内部キー

setPartAcct

public void setPartAcct(String strPartAcct)
取引先勘定コードを設定します。

パラメータ:
strPartAcct - 取引先勘定コード

setCmmtItem

public void setCmmtItem(String strCmmtItem)
資金予算コードを設定します。

パラメータ:
strCmmtItem - 資金予算コード

setRecInd

public void setRecInd(String strRecInd)
リカバリフラグを設定します。

パラメータ:
strRecInd - リカバリフラグ

setFundsCtr

public void setFundsCtr(String strFundsCtr)
予算センタを設定します。

パラメータ:
strFundsCtr - 予算センタ

setFund

public void setFund(String strFund)
会計区分を設定します。

パラメータ:
strFund - 会計区分

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setRefDate

public void setRefDate(String strRefDate)
決済の参照日付を設定します。

パラメータ:
strRefDate - 決済の参照日付

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setNondItax

public void setNondItax(String strNondItax)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
strNondItax - BAPI の通貨額 (小数点以下９桁)

setActtype

public void setActtype(String strActtype)
活動タイプを設定します。

パラメータ:
strActtype - 活動タイプ

setCoBusproc

public void setCoBusproc(String strCoBusproc)
業務プロセスを設定します。

パラメータ:
strCoBusproc - 業務プロセス

setResDoc

public void setResDoc(String strResDoc)
用途指定予算の伝票番号を設定します。

パラメータ:
strResDoc - 用途指定予算の伝票番号

setResItem

public void setResItem(String strResItem)
用途指定予算: 伝票明細を設定します。

パラメータ:
strResItem - 用途指定予算: 伝票明細

setActivity

public void setActivity(String strActivity)
作業番号を設定します。

パラメータ:
strActivity - 作業番号

setGrantNbr

public void setGrantNbr(String strGrantNbr)
補助金を設定します。

パラメータ:
strGrantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String strCmmtItemLong)
資金予算コードを設定します。

パラメータ:
strCmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setAcIndex

public void setAcIndex(int acIndex)
レコード番号を設定します｡

パラメータ:
acIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseComponents (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseComponents

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents
すべての実装インタフェース:
Serializable
public class PurchaseComponents
extends Object
implements Serializable

コンポーネント情報クラス
機能は以下の通り

  • コンポーネント情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseComponents()
コンポーネント情報を作成します。
PurchaseComponents(int index)
コンポーネント情報を作成します。
メソッドの概要
String | getChangeId() 変更タイプ(U、I、E、D)を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getEntryQuantity() 構成品目の所要量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 入力単位 (ISO コード)を取得します。
String | getFixedQuan() 数量固定を取得します。
String | getItemNo() 入出庫予定/従属所要量の明細番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getReqDate() 構成品目の所要日付を取得します。
String | getSchedLine() 納入日程行を取得します。
void | setChangeId(String strChangeId) 変更タイプ(U、I、E、D)を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setEntryQuantity(String strEntryQuantity) 構成品目の所要量を設定します。
void | setEntryUom(String strEntryUom) 入力単位を設定します。
void | setEntryUomIso(String strEntryUomIso) 入力単位 (ISO コード)を設定します。
void | setFixedQuan(String strFixedQuan) 数量固定を設定します。
void | setItemNo(String strItemNo) 入出庫予定/従属所要量の明細番号を設定します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String strMaterialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String strMaterialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setReqDate(String strReqDate) 構成品目の所要日付を設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseComponents

public PurchaseComponents()
コンポーネント情報を作成します。

PurchaseComponents

public PurchaseComponents(int index)
コンポーネント情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
strPoItem 購買伝票の明細番号

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
strSchedLine 納入日程行

getItemNo

public String getItemNo()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
strItemNo 入出庫予定/従属所要量の明細番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
strMaterial 品目コード

getEntryQuantity

public String getEntryQuantity()
構成品目の所要量を取得します。

戻り値:
strEntryQuantity 構成品目の所要量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
strEntryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
入力単位 (ISO コード)を取得します。

戻り値:
strEntryUomIso 入力単位 (ISO コード)

getFixedQuan

public String getFixedQuan()
数量固定を取得します。

戻り値:
strFixedQuan 数量固定

getPlant

public String getPlant()
プラントを取得します。

戻り値:
strPlant プラント

getReqDate

public String getReqDate()
構成品目の所要日付を取得します。

戻り値:
strReqDate 構成品目の所要日付

getChangeId

public String getChangeId()
変更タイプ(U、I、E、D)を取得します。

戻り値:
strChangeId 変更タイプ(U、I、E、D)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
strMaterialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
strMaterialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
strMaterialVersion 項目 MATERIAL のバージョン番号

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setItemNo

public void setItemNo(String strItemNo)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
strItemNo - 入出庫予定/従属所要量の明細番号

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setEntryQuantity

public void setEntryQuantity(String strEntryQuantity)
構成品目の所要量を設定します。

パラメータ:
strEntryQuantity - 構成品目の所要量

setEntryUom

public void setEntryUom(String strEntryUom)
入力単位を設定します。

パラメータ:
strEntryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String strEntryUomIso)
入力単位 (ISO コード)を設定します。

パラメータ:
strEntryUomIso - 入力単位 (ISO コード)

setFixedQuan

public void setFixedQuan(String strFixedQuan)
数量固定を設定します。

パラメータ:
strFixedQuan - 数量固定

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setReqDate

public void setReqDate(String strReqDate)
構成品目の所要日付を設定します。

パラメータ:
strReqDate - 構成品目の所要日付

setChangeId

public void setChangeId(String strChangeId)
変更タイプ(U、I、E、D)を設定します。

パラメータ:
strChangeId - 変更タイプ(U、I、E、D)

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
strMaterialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
strMaterialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
strMaterialVersion - 項目 MATERIAL のバージョン番号

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseConfirmation (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseConfirmation

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation
すべての実装インタフェース:
Serializable
public class PurchaseConfirmation
extends Object
implements Serializable

転送構造：照会／一覧情報クラス
機能は以下の通り

  • 転送構造：照会／一覧情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseConfirmation()
転送構造：照会／一覧情報を作成します。
PurchaseConfirmation(int index)
転送構造：照会／一覧情報を作成します。
メソッドの概要
int | getCoIndex() レコード番号を取得します｡
String | getConfName() 確認カテゴリ: テキストを取得します。
String | getConfSer() 仕入先確認の連続番号を取得します。
String | getConfType() 確認カテゴリを取得します。
String | getDelDatcat() 仕入先確認における納入期日の日付カテゴリを取得します。
String | getDelDatcatExt() 納入期日カテゴリを取得します。
String | getDeleteInd() 区分: 仕入先確認削除を取得します。
String | getDelivDate() 仕入先確認の納入日付を取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDelivTime() 仕入先確認の納入日時を取得します。
String | getDispoRel() 区分: MRP 関連の確認を取得します。
String | getExtDoc() 仕入先確認の外部伝票番号を取得します。
String | getExtDocLong() 参照伝票番号 (依存性についてはテキスト長参照)を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getQuantity() 仕入先確認による数量を取得します。
String | getReceiptRel() 区分: 入庫関連の確認を取得します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setConfName(String strConfName) 確認カテゴリ: テキストを設定します。
void | setConfSer(String strConfSer) 仕入先確認の連続番号を設定します。
void | setConfType(String strConfType) 確認カテゴリを設定します。
void | setDelDatcat(String strDelDatcat) 仕入先確認における納入期日の日付カテゴリを設定します。
void | setDelDatcatExt(String strDelDatcatExt) 納入期日カテゴリを設定します。
void | setDeleteInd(String strDeleteInd) 区分: 仕入先確認削除を設定します。
void | setDelivDate(String strDelivDate) 仕入先確認の納入日付を設定します。
void | setDelivItem(String strDelivItem) 出荷明細を設定します。
void | setDelivNumb(String strDelivNumb) 出荷伝票を設定します。
void | setDelivTime(String strDelivTime) 仕入先確認の納入日時を設定します。
void | setDispoRel(String strDispoRel) 区分: MRP 関連の確認を設定します。
void | setExtDoc(String strExtDoc) 仕入先確認の外部伝票番号を設定します。
void | setExtDocLong(String strExtDocLong) 参照伝票番号 (依存性についてはテキスト長参照)を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setQuantity(String strQuantity) 仕入先確認による数量を設定します。
void | setReceiptRel(String strReceiptRel) 区分: 入庫関連の確認を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseConfirmation

public PurchaseConfirmation()
転送構造：照会／一覧情報を作成します。

PurchaseConfirmation

public PurchaseConfirmation(int index)
転送構造：照会／一覧情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
strPoItem 購買伝票の明細番号

getConfSer

public String getConfSer()
仕入先確認の連続番号を取得します。

戻り値:
strConfSer 仕入先確認の連続番号

getConfType

public String getConfType()
確認カテゴリを取得します。

戻り値:
strConfType 確認カテゴリ

getConfName

public String getConfName()
確認カテゴリ: テキストを取得します。

戻り値:
strConfName 確認カテゴリ: テキスト

getDelDatcat

public String getDelDatcat()
仕入先確認における納入期日の日付カテゴリを取得します。

戻り値:
strDelDatcat 仕入先確認における納入期日の日付カテゴリ

getDelDatcatExt

public String getDelDatcatExt()
納入期日カテゴリを取得します。

戻り値:
strDelDatcatExt 納入期日カテゴリ

getDelivDate

public String getDelivDate()
仕入先確認の納入日付を取得します。

戻り値:
strDelivDate 仕入先確認の納入日付

getDelivTime

public String getDelivTime()
仕入先確認の納入日時を取得します。

戻り値:
strDelivTime 仕入先確認の納入日時

getQuantity

public String getQuantity()
仕入先確認による数量を取得します。

戻り値:
strQuantity 仕入先確認による数量

getDeleteInd

public String getDeleteInd()
区分: 仕入先確認削除を取得します。

戻り値:
strDeleteInd 区分: 仕入先確認削除

getDispoRel

public String getDispoRel()
区分: MRP 関連の確認を取得します。

戻り値:
strDispoRel 区分: MRP 関連の確認

getReceiptRel

public String getReceiptRel()
区分: 入庫関連の確認を取得します。

戻り値:
strReceiptRel 区分: 入庫関連の確認

getExtDoc

public String getExtDoc()
仕入先確認の外部伝票番号を取得します。

戻り値:
strExtDoc 仕入先確認の外部伝票番号

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
strDelivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
strDelivItem 出荷明細

getExtDocLong

public String getExtDocLong()
参照伝票番号 (依存性についてはテキスト長参照)を取得します。

戻り値:
strExtDocLong 参照伝票番号 (依存性についてはテキスト長参照)

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setConfSer

public void setConfSer(String strConfSer)
仕入先確認の連続番号を設定します。

パラメータ:
strConfSer - 仕入先確認の連続番号

setConfType

public void setConfType(String strConfType)
確認カテゴリを設定します。

パラメータ:
strConfType - 確認カテゴリ

setConfName

public void setConfName(String strConfName)
確認カテゴリ: テキストを設定します。

パラメータ:
strConfName - 確認カテゴリ: テキスト

setDelDatcat

public void setDelDatcat(String strDelDatcat)
仕入先確認における納入期日の日付カテゴリを設定します。

パラメータ:
strDelDatcat - 仕入先確認における納入期日の日付カテゴリ

setDelDatcatExt

public void setDelDatcatExt(String strDelDatcatExt)
納入期日カテゴリを設定します。

パラメータ:
strDelDatcatExt - 納入期日カテゴリ

setDelivDate

public void setDelivDate(String strDelivDate)
仕入先確認の納入日付を設定します。

パラメータ:
strDelivDate - 仕入先確認の納入日付

setDelivTime

public void setDelivTime(String strDelivTime)
仕入先確認の納入日時を設定します。

パラメータ:
strDelivTime - 仕入先確認の納入日時

setQuantity

public void setQuantity(String strQuantity)
仕入先確認による数量を設定します。

パラメータ:
strQuantity - 仕入先確認による数量

setDeleteInd

public void setDeleteInd(String strDeleteInd)
区分: 仕入先確認削除を設定します。

パラメータ:
strDeleteInd - 区分: 仕入先確認削除

setDispoRel

public void setDispoRel(String strDispoRel)
区分: MRP 関連の確認を設定します。

パラメータ:
strDispoRel - 区分: MRP 関連の確認

setReceiptRel

public void setReceiptRel(String strReceiptRel)
区分: 入庫関連の確認を設定します。

パラメータ:
strReceiptRel - 区分: 入庫関連の確認

setExtDoc

public void setExtDoc(String strExtDoc)
仕入先確認の外部伝票番号を設定します。

パラメータ:
strExtDoc - 仕入先確認の外部伝票番号

setDelivNumb

public void setDelivNumb(String strDelivNumb)
出荷伝票を設定します。

パラメータ:
strDelivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String strDelivItem)
出荷明細を設定します。

パラメータ:
strDelivItem - 出荷明細

setExtDocLong

public void setExtDocLong(String strExtDocLong)
参照伝票番号 (依存性についてはテキスト長参照)を設定します。

パラメータ:
strExtDocLong - 参照伝票番号 (依存性についてはテキスト長参照)

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseGetItemSrel (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseGetItemSrel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel
すべての実装インタフェース:
Serializable
public class PurchaseGetItemSrel
extends ReferenceController
implements Serializable

伝票承認対象一覧情報クラス
機能は以下の通り

  • 伝票承認対象一覧を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先マスタ詳細を作成します。
String | getItemsForRelease() 区分: 承認待ち購買発注のみ照会を取得します。
ArrayList | getPurchaseHeadersList() 伝票ヘッダ一覧（PurchaseHeadersインスタンスの配列）を取得します。
ArrayList | getPurchaseItemsList() 伝票明細一覧（PurchaseItemsインスタンスの配列）を取得します｡
String | getRelCode() 承認コードを取得します。
String | getRelGroup() 承認グループを取得します。
void | setItemsForRelease(String strItemsForRelease) 区分: 承認待ち購買発注のみ照会を設定します。
void | setPurchaseHeadersList(ArrayList purchaseHeadersList) 伝票ヘッダ一覧（PurchaseHeadersインスタンスの配列）を設定します。
void | setPurchaseItemsList(ArrayList purchaseItemsList) 伝票明細一覧（PurchaseItemsインスタンスの配列）を設定します。
void | setRelCode(String strRelCode) 承認コードを設定します。
void | setRelGroup(String strRelGroup) 承認グループを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseGetItemSrel

public PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

PurchaseGetItemSrel

public PurchaseGetItemSrel(String relGroup,
                           String relCode,
                           String itemsForRelease,
                           SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPPurchaseAppException,
                           SAPPurchaseSystemException
承認対象一覧を作成します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先マスタ詳細を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelCode

public void setRelCode(String strRelCode)
承認コードを設定します。

パラメータ:
strRelCode - 承認コード

setItemsForRelease

public void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。

パラメータ:
strItemsForRelease - 区分: 承認待ち購買発注のみ照会

setPurchaseHeadersList

public void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧（PurchaseHeadersインスタンスの配列）を設定します。

パラメータ:
purchaseHeadersList - 伝票ヘッダ一覧を設定します｡
関連項目:
PurchaseHeaders

setPurchaseItemsList

public void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧（PurchaseItemsインスタンスの配列）を設定します。

パラメータ:
purchaseItemsList - 伝票明細一覧を設定します。
関連項目:
PurchaseItems

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup 承認グループ

getRelCode

public String getRelCode()
承認コードを取得します。

戻り値:
srtRelCode 承認コード

getItemsForRelease

public String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。

戻り値:
srtItemsForRelease 区分: 承認待ち購買発注のみ照会

getPurchaseHeadersList

public ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧（PurchaseHeadersインスタンスの配列）を取得します。

戻り値:
deliveryAddressList 出荷伝票アドレス一覧
関連項目:
PurchaseHeaders

getPurchaseItemsList

public ArrayList getPurchaseItemsList()
伝票明細一覧（PurchaseItemsインスタンスの配列）を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧
関連項目:
PurchaseItems

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseGetItemSrelController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseGetItemSrelController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController
すべての実装インタフェース:
Serializable
public class PurchaseGetItemSrelController
extends Object
implements Serializable

伝票の承認対象一覧取得コントローラクラス
機能は以下の通り

  • 伝票の承認対象一覧を取得します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseGetItemSrelController()
コンストラクタ生成
PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
メソッドの概要
 void executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。
 PurchaseGetItemSrel getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡
 ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します。
 ArrayList getPurchaseItemsList()
伝票明細一覧を取得します。
 String getRelCode()
承認コードを取得します。
 String getRelGroup()
承認グループを取得します。
 void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。
 void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を設定します。
 void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を設定します。
 void setRelCode(String strRelCode)
承認コードを設定します。
 void setRelGroup(String strRelGroup)
承認グループを設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseGetItemSrelController

public PurchaseGetItemSrelController()
コンストラクタ生成

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(String relGroup,
                                     String relCode,
                                     String itemsForRelease)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPPurchaseAppException,
                                     SAPPurchaseSystemException
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分 「X」：承認可能な購買発注のみ照会 「ブランク」：すでに承認された購買発注のみ照会
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(String relGroup,
                                     String relCode,
                                     String itemsForRelease,
                                     SapClient sapClient)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPPurchaseAppException,
                                     SAPPurchaseSystemException
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト 「X」：承認可能な購買発注のみ照会 「ブランク」：すでに承認された購買発注のみ照会
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelCode

public void setRelCode(String strRelCode)
承認コードを設定します。

パラメータ:
strRelCode - 承認コード

setItemsForRelease

public void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。

パラメータ:
strItemsForRelease - 区分: 承認待ち購買発注のみ照会

setPurchaseHeadersList

public void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を設定します。

パラメータ:
purchaseHeadersList - 伝票ヘッダ一覧

setPurchaseItemsList

public void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を設定します。

パラメータ:
purchaseItemsList - 伝票明細一覧

getPurchaseGetItemSrel

public PurchaseGetItemSrel getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡

戻り値:
SupplierDetail

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup 承認グループ

getRelCode

public String getRelCode()
承認コードを取得します。

戻り値:
srtRelCode 承認コード

getItemsForRelease

public String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。

戻り値:
srtItemsForRelease 区分: 承認待ち購買発注のみ照会

getPurchaseHeadersList

public ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します。

戻り値:
ArrayList 伝票ヘッダ一覧

getPurchaseItemsList

public ArrayList getPurchaseItemsList()
伝票明細一覧を取得します。

戻り値:
ArrayList 伝票明細一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeader (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseHeaderPost, PurchaseHeaders
public class PurchaseHeader
extends Object
implements Serializable

購買発注ヘッダ情報スーパークラス
機能は以下の通り

  • 購買発注のヘッダ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeader()
購買発注伝票ヘッダを作成します。
メソッドの概要
String | getAgreement() 購買契約番号を取得します｡
String | getCreatedBy() 登録者名を取得します｡
String | getCurrency() 通貨コードを取得します｡
String | getCurrencyIso() ISO通貨コードを取得します｡
String | getCustomer() 得意先コード1を取得します｡
String | getDeleteInd() 削除フラグを取得します｡
String | getDiffInv() 仕入先と請求元が異なる場合の供給元のコードを取得します｡
String | getDocDate() 購買伝票日付を取得します｡
String | getDocType() 伝票タイプを取得します｡
String | getDscnt1To() 現金割引日数1を取得します｡
String | getDscnt2To() 現金割引日数2を取得します｡
String | getDscnt3To() 現金割引日数3を取得します｡
String | getExchRate() 換算レートを取得します｡
String | getExRateFx() 換算レート固定区分を取得します｡
String | getGrMessage() 入庫メッセージ区分を取得します｡
String | getIncoterms1() インコタームズ1を取得します｡
String | getIncoterms2() インコタームズ2を取得します｡
String | getItemIntvl() 明細番号間隔を取得します｡
String | getLogsystem() 論理システムを取得します｡
String | getOurRef() 社内参照番号を取得します｡
String | getPmnttrms() 支払条件キーを取得します｡
String | getPoNumber() 購買伝票を取得します｡
String | getPurchOrg() 購買組織を取得します｡
String | getPurGroup() 購買グループを取得します｡
String | getQuotation() 見積番号を取得します｡
String | getQuotDate() 見積提出日を取得します｡
String | getRef_1() 得意先/仕入先の内部参照コードを取得します｡
String | getRelStatus() 承認状況を取得します｡
String | getSalesPers() 仕入先営業担当者を取得します｡
String | getStatus() 伝票ステータスを取得します｡
String | getSubitemint() 副明細の明細間隔を取得します｡
String | getSupplPlnt() 在庫転送オーダーにおける供給(出庫)プラントを取得します｡
String | getSupplVend() 供給仕入先を取得します｡
String | getTelephone() 仕入先電話番号を取得します｡
String | getVendor() 仕入先勘定コードを取得します｡
String | getVperEnd() 有効期間終了日を取得します｡
String | getVperStart() 有効期間開始日を取得します｡
String | getWarranty() 保証日を取得します｡
void | setAgreement(String strAgreement) 購買契約番号を設定します｡
void | setCreatedBy(String strCreatedBy) 登録者名を設定します｡
void | setCurrency(String strCurrency) 通貨コードを設定します｡
void | setCurrencyIso(String strCurrencyIso) ISO通貨コードを設定します｡
void | setCustomer(String strCustomer) 得意先コード1を設定します｡
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します｡
void | setDiffInv(String strDiffInv) 仕入先と請求元が異なる場合の請求元コードを設定します｡
void | setDocDate(String strDocDate) 購買伝票日付を設定します｡
void | setDocType(String strDocType) 伝票タイプを設定します｡
void | setDscnt1To(String strDscnt1To) 現金割引日数1を設定します｡
void | setDscnt2To(String strDscnt2To) 現金割引日数2を設定します｡
void | setDscnt3To(String strDscnt3To) 現金割引日数3を設定します｡
void | setExchRate(String strExchRate) 換算レートを設定します｡
void | setExRateFx(String strExRateFx) 換算レート固定区分を設定します｡
void | setGrMessage(String strGrMessage) 入庫メッセージ区分を設定します｡
void | setIncoterms1(String strIncoterms1) インコタームズ1を設定します｡
void | setIncoterms2(String strIncoterms2) インコタームズ2を設定します｡
void | setItemIntvl(String strItemIntvl) 明細番号間隔を設定します｡
void | setLogsystem(String strLogsystem) 論理システムを設定します｡
void | setOurRef(String strOurRef) 社内参照番号を設定します｡
void | setPmnttrms(String strPmnttrms) 支払条件キーを設定します｡
void | setPoNumber(String strPonNmber) 購買伝票番号を設定します｡
void | setPurchOrg(String strPurchOrg) 購買組織を設定します｡
void | setPurGroup(String strPurGroup) 購買グループを設定します｡
void | setQuotation(String strQuotation) 見積番号を設定します｡
void | setQuotDate(String strQuotDate) 見積提出日を設定します｡
void | setRef_1(String strRef1) 得意先/仕入先の内部参照コードを設定します｡
void | setRelStatus(String strRelStatus) 承認状況を設定します｡
void | setSalesPers(String strSalesPers) 仕入先営業担当者を設定します｡
void | setStatus(String strStatus) ステータスを設定します｡
void | setSubitemint(String strSubitemint) 副明細の明細間隔を設定します｡
void | setSupplPlnt(String strSupplPlnt) 在庫転送オーダーにおける供給(出庫)プラントを設定します｡
void | setSupplVend(String strSupplVend) 供給仕入先を設定します｡
void | setTelephone(String strTelephone) 仕入先電話番号を設定します｡
void | setVendor(String strVendor) 仕入先勘定コードを設定します｡
void | setVperEnd(String strVperEnd) 有効期間終了日を設定します｡
void | setVperStart(String strVperStart) 有効期間開始日を設定します｡
void | setWarranty(String strWarranty) 保証日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeader

public PurchaseHeader()
購買発注伝票ヘッダを作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票を取得します｡

戻り値:
strPoNumber

getDocType

public String getDocType()
伝票タイプを取得します｡

戻り値:
strDocType

getDeleteInd

public String getDeleteInd()
削除フラグを取得します｡

戻り値:
strDeleteInd

getStatus

public String getStatus()
伝票ステータスを取得します｡

戻り値:
strStatus

getCreatedBy

public String getCreatedBy()
登録者名を取得します｡

戻り値:
strCreatedBy

getItemIntvl

public String getItemIntvl()
明細番号間隔を取得します｡

戻り値:
strItemIntvl

getVendor

public String getVendor()
仕入先勘定コードを取得します｡

戻り値:
strVendor

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します｡

戻り値:
strPmnttrms

getDscnt1To

public String getDscnt1To()
現金割引日数1を取得します｡

戻り値:
strDscnt1To

getDscnt2To

public String getDscnt2To()
現金割引日数2を取得します｡

戻り値:
strDscnt2to

getDscnt3To

public String getDscnt3To()
現金割引日数3を取得します｡

戻り値:
strDscnt3To

getPurchOrg

public String getPurchOrg()
購買組織を取得します｡

戻り値:
strPutchOrg

getPurGroup

public String getPurGroup()
購買グループを取得します｡

戻り値:
strPurGroup

getCurrency

public String getCurrency()
通貨コードを取得します｡

戻り値:
strCurrency

getCurrencyIso

public String getCurrencyIso()
ISO通貨コードを取得します｡

戻り値:
strCurrencyIso

getExchRate

public String getExchRate()
換算レートを取得します｡

戻り値:
strExchRate

getExRateFx

public String getExRateFx()
換算レート固定区分を取得します｡

戻り値:
strExRateFx

getDocDate

public String getDocDate()
購買伝票日付を取得します｡

戻り値:
strDocDate

getVperStart

public String getVperStart()
有効期間開始日を取得します｡

戻り値:
strVperStart

getVperEnd

public String getVperEnd()
有効期間終了日を取得します｡

戻り値:
strVperEnd

getWarranty

public String getWarranty()
保証日を取得します｡

戻り値:
strWarranty

getQuotation

public String getQuotation()
見積番号を取得します｡

戻り値:
strQuotation

getQuotDate

public String getQuotDate()
見積提出日を取得します｡

戻り値:
strQuotDate

getRef_1

public String getRef_1()
得意先/仕入先の内部参照コードを取得します｡

戻り値:
strRef1

getSalesPers

public String getSalesPers()
仕入先営業担当者を取得します｡

戻り値:
strSalesPers

getTelephone

public String getTelephone()
仕入先電話番号を取得します｡

戻り値:
strTelephone

getSupplVend

public String getSupplVend()
供給仕入先を取得します｡

戻り値:
strSupplVend

getCustomer

public String getCustomer()
得意先コード1を取得します｡

戻り値:
strCustomer

getAgreement

public String getAgreement()
購買契約番号を取得します｡

戻り値:
strAgreement

getGrMessage

public String getGrMessage()
入庫メッセージ区分を取得します｡

戻り値:
strGrMessage

getSupplPlnt

public String getSupplPlnt()
在庫転送オーダーにおける供給(出庫)プラントを取得します｡

戻り値:
strSupplPlnt

getIncoterms1

public String getIncoterms1()
インコタームズ1を取得します｡

戻り値:
strIncoterms1

getIncoterms2

public String getIncoterms2()
インコタームズ2を取得します｡

戻り値:
strIncoterms2

getDiffInv

public String getDiffInv()
仕入先と請求元が異なる場合の供給元のコードを取得します｡

戻り値:
strDiffInv

getOurRef

public String getOurRef()
社内参照番号を取得します｡

戻り値:
strOurRef

getLogsystem

public String getLogsystem()
論理システムを取得します｡

戻り値:
strLogsystem

getSubitemint

public String getSubitemint()
副明細の明細間隔を取得します｡

戻り値:
strSubitemint

getRelStatus

public String getRelStatus()
承認状況を取得します｡

戻り値:
strRelStatus

setPoNumber

public void setPoNumber(String strPonNmber)
購買伝票番号を設定します｡

パラメータ:
strPonNmber - 購買伝票番号

setDocType

public void setDocType(String strDocType)
伝票タイプを設定します｡

パラメータ:
strDocType - 伝票タイプ

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します｡

パラメータ:
strDeleteInd - 削除フラグ

setStatus

public void setStatus(String strStatus)
ステータスを設定します｡

パラメータ:
strStatus - ステータス

setCreatedBy

public void setCreatedBy(String strCreatedBy)
登録者名を設定します｡

パラメータ:
strCreatedBy - 登録者名

setItemIntvl

public void setItemIntvl(String strItemIntvl)
明細番号間隔を設定します｡

パラメータ:
strItemIntvl - 明細番号間隔

setVendor

public void setVendor(String strVendor)
仕入先勘定コードを設定します｡

パラメータ:
strVendor - 仕入先勘定コード

setPmnttrms

public void setPmnttrms(String strPmnttrms)
支払条件キーを設定します｡

パラメータ:
strPmnttrms - 支払条件キー

setDscnt1To

public void setDscnt1To(String strDscnt1To)
現金割引日数1を設定します｡

パラメータ:
strDscnt1To - 現金割引日数1

setDscnt2To

public void setDscnt2To(String strDscnt2To)
現金割引日数2を設定します｡

パラメータ:
strDscnt2To - 現金割引日数2

setDscnt3To

public void setDscnt3To(String strDscnt3To)
現金割引日数3を設定します｡

パラメータ:
strDscnt3To - 現金割引日数3

setPurchOrg

public void setPurchOrg(String strPurchOrg)
購買組織を設定します｡

パラメータ:
strPurchOrg - 購買組織

setPurGroup

public void setPurGroup(String strPurGroup)
購買グループを設定します｡

パラメータ:
strPurGroup - 購買グループ

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します｡

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO通貨コードを設定します｡

パラメータ:
strCurrencyIso - ISO通貨コード

setExchRate

public void setExchRate(String strExchRate)
換算レートを設定します｡

パラメータ:
strExchRate - 換算レート

setExRateFx

public void setExRateFx(String strExRateFx)
換算レート固定区分を設定します｡

パラメータ:
strExRateFx - 換算レート固定区分

setDocDate

public void setDocDate(String strDocDate)
購買伝票日付を設定します｡

パラメータ:
strDocDate - 購買伝票日付

setVperStart

public void setVperStart(String strVperStart)
有効期間開始日を設定します｡

パラメータ:
strVperStart - 有効期間開始日

setVperEnd

public void setVperEnd(String strVperEnd)
有効期間終了日を設定します｡

パラメータ:
strVperEnd - 有効期間終了日

setWarranty

public void setWarranty(String strWarranty)
保証日を設定します｡

パラメータ:
strWarranty - 保証日

setQuotation

public void setQuotation(String strQuotation)
見積番号を設定します｡

パラメータ:
strQuotation - 見積番号

setQuotDate

public void setQuotDate(String strQuotDate)
見積提出日を設定します｡

パラメータ:
strQuotDate - 見積提出日

setRef_1

public void setRef_1(String strRef1)
得意先/仕入先の内部参照コードを設定します｡

パラメータ:
strRef1 - 得意先/仕入先の内部参照コード

setSalesPers

public void setSalesPers(String strSalesPers)
仕入先営業担当者を設定します｡

パラメータ:
strSalesPers - 仕入先営業担当者

setTelephone

public void setTelephone(String strTelephone)
仕入先電話番号を設定します｡

パラメータ:
strTelephone - 仕入先電話番号

setSupplVend

public void setSupplVend(String strSupplVend)
供給仕入先を設定します｡

パラメータ:
strSupplVend - 供給仕入先

setCustomer

public void setCustomer(String strCustomer)
得意先コード1を設定します｡

パラメータ:
strCustomer - 得意先コード1

setAgreement

public void setAgreement(String strAgreement)
購買契約番号を設定します｡

パラメータ:
strAgreement - 購買契約番号

setGrMessage

public void setGrMessage(String strGrMessage)
入庫メッセージ区分を設定します｡

パラメータ:
strGrMessage - 入庫メッセージ区分

setSupplPlnt

public void setSupplPlnt(String strSupplPlnt)
在庫転送オーダーにおける供給(出庫)プラントを設定します｡

パラメータ:
strSupplPlnt - 在庫転送オーダーにおける供給(出庫)プラント

setIncoterms1

public void setIncoterms1(String strIncoterms1)
インコタームズ1を設定します｡

パラメータ:
strIncoterms1 - インコタームズ1

setIncoterms2

public void setIncoterms2(String strIncoterms2)
インコタームズ2を設定します｡

パラメータ:
strIncoterms2 - インコタームズ2

setDiffInv

public void setDiffInv(String strDiffInv)
仕入先と請求元が異なる場合の請求元コードを設定します｡

パラメータ:
strDiffInv - 仕入先と請求元が異なる場合の請求元コード

setOurRef

public void setOurRef(String strOurRef)
社内参照番号を設定します｡

パラメータ:
strOurRef - 社内参照番号

setLogsystem

public void setLogsystem(String strLogsystem)
論理システムを設定します｡

パラメータ:
strLogsystem - 論理システム

setSubitemint

public void setSubitemint(String strSubitemint)
副明細の明細間隔を設定します｡

パラメータ:
strSubitemint - 副明細の明細間隔

setRelStatus

public void setRelStatus(String strRelStatus)
承認状況を設定します｡

パラメータ:
strRelStatus - 承認状況

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeaderPost (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeaderPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost
すべての実装インタフェース:
Serializable
public class PurchaseHeaderPost
extends PurchaseHeader
implements Serializable

購買発注伝票ヘッダ情報クラス
機能は以下の通り

  • 購買発注伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeaderPost()
購買発注伝票ヘッダを作成します。
メソッドの概要
String | getCollectNo() 一括番号を取得します。
String | getCompCode() 会社コードを取得します｡
String | getCreatDate() レコード登録日を取得します。
String | getDsctPct1() 割引率 1を取得します。
String | getDsctPct2() 割引率 2を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() 言語キーの ISO コードを取得します。
String | getPoRelInd() 承認区分: 購買伝票を取得します。
String | getReasonCancel() 取消理由を取得します。
String | getReasonCode() Goods Receipt Reason Codeを取得します。
String | getVatCntry() 売上税 ID 番号国を取得します。
String | getVatCntryIso() 消費税登録番号の ISO 国コードを取得します。
void | setCollectNo(String strCollectNo) 一括番号を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します｡
void | setCreatDate(String strCreatDate) レコード登録日を設定します。
void | setDsctPct1(String strDsctPct1) 割引率 1を設定します。
void | setDsctPct2(String strDsctPct2) 割引率 2を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) 言語キーの ISO コードを設定します。
void | setPoRelInd(String strPoRelInd) 承認区分: 購買伝票を設定します。
void | setReasonCancel(String strReasonCancel) 取消理由を設定します。
void | setReasonCode(String strReasonCode) Goods Receipt Reason Codeを設定します。
void | setVatCntry(String strVatCntry) 売上税 ID 番号国を設定します。
void | setVatCntryIso(String strVatCntryIso) 消費税登録番号の ISO 国コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader から継承したメソッド
getAgreement, getCreatedBy, getCurrency, getCurrencyIso, getCustomer, getDeleteInd, getDiffInv, getDocDate, getDocType, getDscnt1To, getDscnt2To, getDscnt3To, getExchRate, getExRateFx, getGrMessage, getIncoterms1, getIncoterms2, getItemIntvl, getLogsystem, getOurRef, getPmnttrms, getPoNumber, getPurchOrg, getPurGroup, getQuotation, getQuotDate, getRef_1, getRelStatus, getSalesPers, getStatus, getSubitemint, getSupplPlnt, getSupplVend, getTelephone, getVendor, getVperEnd, getVperStart, getWarranty, setAgreement, setCreatedBy, setCurrency, setCurrencyIso, setCustomer, setDeleteInd, setDiffInv, setDocDate, setDocType, setDscnt1To, setDscnt2To, setDscnt3To, setExchRate, setExRateFx, setGrMessage, setIncoterms1, setIncoterms2, setItemIntvl, setLogsystem, setOurRef, setPmnttrms, setPoNumber, setPurchOrg, setPurGroup, setQuotation, setQuotDate, setRef_1, setRelStatus, setSalesPers, setStatus, setSubitemint, setSupplPlnt, setSupplVend, setTelephone, setVendor, setVperEnd, setVperStart, setWarranty
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeaderPost

public PurchaseHeaderPost()
購買発注伝票ヘッダを作成します。

メソッドの詳細

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompCode

getCreatDate

public String getCreatDate()
レコード登録日を取得します。

戻り値:
srtCreatDate レコード登録日

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getLanguIso

public String getLanguIso()
言語キーの ISO コードを取得します。

戻り値:
srtLanguIso 言語キーの ISO コード

getDsctPct1

public String getDsctPct1()
割引率 1を取得します。

戻り値:
srtDsctPct1 割引率 1

getDsctPct2

public String getDsctPct2()
割引率 2を取得します。

戻り値:
srtDsctPct2 割引率 2

getCollectNo

public String getCollectNo()
一括番号を取得します。

戻り値:
srtCollectNo 一括番号

getPoRelInd

public String getPoRelInd()
承認区分: 購買伝票を取得します。

戻り値:
srtPoRelInd 承認区分: 購買伝票

getVatCntry

public String getVatCntry()
売上税 ID 番号国を取得します。

戻り値:
srtVatCntry 売上税 ID 番号国

getVatCntryIso

public String getVatCntryIso()
消費税登録番号の ISO 国コードを取得します。

戻り値:
srtVatCntryIso 消費税登録番号の ISO 国コード

getReasonCancel

public String getReasonCancel()
取消理由を取得します。

戻り値:
srtReasonCancel 取消理由

getReasonCode

public String getReasonCode()
Goods Receipt Reason Codeを取得します。

戻り値:
strReasonCode Goods Receipt Reason Code

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCreatDate

public void setCreatDate(String strCreatDate)
レコード登録日を設定します。

パラメータ:
strCreatDate - レコード登録日

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
言語キーの ISO コードを設定します。

パラメータ:
strLanguIso - 言語キーの ISO コード

setDsctPct1

public void setDsctPct1(String strDsctPct1)
割引率 1を設定します。

パラメータ:
strDsctPct1 - 割引率 1

setDsctPct2

public void setDsctPct2(String strDsctPct2)
割引率 2を設定します。

パラメータ:
strDsctPct2 - 割引率 2

setCollectNo

public void setCollectNo(String strCollectNo)
一括番号を設定します。

パラメータ:
strCollectNo - 一括番号

setPoRelInd

public void setPoRelInd(String strPoRelInd)
承認区分: 購買伝票を設定します。

パラメータ:
strPoRelInd - 承認区分: 購買伝票

setVatCntry

public void setVatCntry(String strVatCntry)
売上税 ID 番号国を設定します。

パラメータ:
strVatCntry - 売上税 ID 番号国

setVatCntryIso

public void setVatCntryIso(String strVatCntryIso)
消費税登録番号の ISO 国コードを設定します。

パラメータ:
strVatCntryIso - 消費税登録番号の ISO 国コード

setReasonCancel

public void setReasonCancel(String strReasonCancel)
取消理由を設定します。

パラメータ:
strReasonCancel - 取消理由

setReasonCode

public void setReasonCode(String strReasonCode)
Goods Receipt Reason Codeを設定します。

パラメータ:
strReasonCode - Goods Receipt Reason Code

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseHeader 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeaders (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeaders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders
すべての実装インタフェース:
Serializable
public class PurchaseHeaders
extends PurchaseHeader
implements Serializable

伝票の承認対象一覧ヘッダ情報クラス
機能は以下の通り

  • 伝票の承認対象一覧ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeaders()
伝票の承認対象一覧ヘッダを作成します。
メソッドの概要
String | getApplicBy() 見積提出期限を取得します。
String | getBidinvNo() 見積管理番号を取得します。
String | getBindgPer() 見積有効期間を取得します。
String | getCashDisc1() 割引率 1を取得します。
String | getCashDisc2() 割引率 2を取得します。
String | getCntrlInd() 購買伝票タイプに対する管理区分を取得します。
String | getCoCode() 会社コードを取得します。
String | getCollNo() 一括番号を取得します。
String | getComplDlv() 全購買発注に対する一括納入指定を取得します。
String | getCreatedOn() レコード登録日を取得します。
String | getDocCat() 購買伝票カテゴリを取得します。
String | getDocCond() 伝票条件番号を取得します。
String | getExchRateCm() 間接呼び値換算レートを取得します。
String | getExportNo() 貿易データ番号: MM/SD 伝票を取得します。
String | getHold() 購買発注の不完全を取得します。
String | getLanguage() 言語キーを取得します。
String | getLastItem() 最終明細番号を取得します。
String | getMastCond() 期間依存条件伝票を取得します。
String | getProcedure() 決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。
String | getQuotDead() 見積提出期限を取得します。
String | getRcvgVend() 未使用項目を取得します。
String | getRejReason() 見積および受注の拒否理由を取得します。
String | getRelGroup() 承認グループを取得します。
String | getRelInd() 承認区分: 購買伝票を取得します。
String | getRelStrat() 承認方針を取得します。
String | getSchedInd() 分納契約のリリース伝票区分を取得します。
String | getSubjToR() 承認未完了を取得します。
String | getTargetVal() 累積計画金額を取得します。
String | getTaxrCntry() 納税申告書の国を取得します。
String | getUpdateGrp() 統計更新の更新グループを取得します。
String | getVendName() 名称 1を取得します。
void | setApplicBy(String strApplicBy) 見積提出期限を設定します。
void | setBidinvNo(String strBidinvNo) 見積管理番号を設定します。
void | setBindgPer(String strBindgPer) 見積有効期間を設定します。
void | setCashDisc1(String strCashDisc1) 割引率 1を設定します。
void | setCashDisc2(String strCashDisc2) 割引率 2を設定します。
void | setCntrlInd(String strCntrlInd) 購買伝票タイプに対する管理区分を設定します。
void | setCoCode(String strCoCode) 会社コードを設定します。
void | setCollNo(String strCollNo) 一括番号を設定します。
void | setComplDlv(String strComplDlv) 全購買発注に対する一括納入指定を設定します。
void | setCreatedOn(String strCreatedOn) レコード登録日を設定します。
void | setDocCat(String strDocCat) 購買伝票カテゴリを設定します。
void | setDocCond(String strDocCond) 伝票条件番号を設定します。
void | setExchRateCm(String strExchRateCm) 間接呼び値換算レートを設定します。
void | setExportNo(String strExportNo) 貿易データ番号: MM/SD 伝票を設定します。
void | setHold(String strHold) 購買発注の不完全を設定します。
void | setLanguage(String strLanguage) 言語キーを設定します。
void | setLastItem(String strLastItem) 最終明細番号を設定します。
void | setMastCond(String strMastCond) 期間依存条件伝票を設定します。
void | setProcedure(String strProcedure) 決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。
void | setQuotDead(String strQuotDead) 見積提出期限を設定します。
void | setRcvgVend(String strRcvgVend) 未使用項目を設定します。
void | setRejReason(String strRejReason) 見積および受注の拒否理由を設定します。
void | setRelGroup(String strRelGroup) 承認グループを設定します。
void | setRelInd(String strRelInd) 承認区分: 購買伝票を設定します。
void | setRelStrat(String strRelStrat) 承認方針を設定します。
void | setSchedInd(String strSchedInd) 分納契約のリリース伝票区分を設定します。
void | setSubjToR(String strSubjToR) 承認未完了を設定します。
void | setTargetVal(String strTargetVal) 累積計画金額を設定します。
void | setTaxrCntry(String strTaxrCntry) 納税申告書の国を設定します。
void | setUpdateGrp(String strUpdateGrp) 統計更新の更新グループを設定します。
void | setVendName(String strVendName) 名称 1を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader から継承したメソッド
getAgreement, getCreatedBy, getCurrency, getCurrencyIso, getCustomer, getDeleteInd, getDiffInv, getDocDate, getDocType, getDscnt1To, getDscnt2To, getDscnt3To, getExchRate, getExRateFx, getGrMessage, getIncoterms1, getIncoterms2, getItemIntvl, getLogsystem, getOurRef, getPmnttrms, getPoNumber, getPurchOrg, getPurGroup, getQuotation, getQuotDate, getRef_1, getRelStatus, getSalesPers, getStatus, getSubitemint, getSupplPlnt, getSupplVend, getTelephone, getVendor, getVperEnd, getVperStart, getWarranty, setAgreement, setCreatedBy, setCurrency, setCurrencyIso, setCustomer, setDeleteInd, setDiffInv, setDocDate, setDocType, setDscnt1To, setDscnt2To, setDscnt3To, setExchRate, setExRateFx, setGrMessage, setIncoterms1, setIncoterms2, setItemIntvl, setLogsystem, setOurRef, setPmnttrms, setPoNumber, setPurchOrg, setPurGroup, setQuotation, setQuotDate, setRef_1, setRelStatus, setSalesPers, setStatus, setSubitemint, setSupplPlnt, setSupplVend, setTelephone, setVendor, setVperEnd, setVperStart, setWarranty
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeaders

public PurchaseHeaders()
伝票の承認対象一覧ヘッダを作成します。

メソッドの詳細

getCoCode

public String getCoCode()
会社コードを取得します。

戻り値:
srtCoCode

getDocCat

public String getDocCat()
購買伝票カテゴリを取得します。

戻り値:
srtDocCat

getCntrlInd

public String getCntrlInd()
購買伝票タイプに対する管理区分を取得します。

戻り値:
srtCntrlInd

getCreatedOn

public String getCreatedOn()
レコード登録日を取得します。

戻り値:
srtCreatedOn

getLastItem

public String getLastItem()
最終明細番号を取得します。

戻り値:
srtLastItem

getLanguage

public String getLanguage()
言語キーを取得します。

戻り値:
srtLanguage

getCashDisc1

public String getCashDisc1()
割引率 1を取得します。

戻り値:
srtCashDisc1

getCashDisc2

public String getCashDisc2()
割引率 2を取得します。

戻り値:
srtCashDisc2

getApplicBy

public String getApplicBy()
見積提出期限を取得します。

戻り値:
srtApplicBy

getQuotDead

public String getQuotDead()
見積提出期限を取得します。

戻り値:
srtQuotDead

getBindgPer

public String getBindgPer()
見積有効期間を取得します。

戻り値:
srtBindgPer

getBidinvNo

public String getBidinvNo()
見積管理番号を取得します。

戻り値:
srtBidinvNo

getRejReason

public String getRejReason()
見積および受注の拒否理由を取得します。

戻り値:
srtRejReason

getComplDlv

public String getComplDlv()
全購買発注に対する一括納入指定を取得します。

戻り値:
srtComplDlv

getRcvgVend

public String getRcvgVend()
未使用項目を取得します。

戻り値:
srtRcvgVend

getTargetVal

public String getTargetVal()
累積計画金額を取得します。

戻り値:
srtTargetVal

getCollNo

public String getCollNo()
一括番号を取得します。

戻り値:
srtCollNo

getDocCond

public String getDocCond()
伝票条件番号を取得します。

戻り値:
srtDocCond

getProcedure

public String getProcedure()
決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。

戻り値:
srtProcedure

getUpdateGrp

public String getUpdateGrp()
統計更新の更新グループを取得します。

戻り値:
srtUpdateGrp

getExportNo

public String getExportNo()
貿易データ番号: MM/SD 伝票を取得します。

戻り値:
srtExportNo

getMastCond

public String getMastCond()
期間依存条件伝票を取得します。

戻り値:
srtMastCond

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup

getRelStrat

public String getRelStrat()
承認方針を取得します。

戻り値:
srtRelStrat

getRelInd

public String getRelInd()
承認区分: 購買伝票を取得します。

戻り値:
srtRelInd

getSubjToR

public String getSubjToR()
承認未完了を取得します。

戻り値:
srtSubjToR

getTaxrCntry

public String getTaxrCntry()
納税申告書の国を取得します。

戻り値:
srtTaxrCntry

getSchedInd

public String getSchedInd()
分納契約のリリース伝票区分を取得します。

戻り値:
srtSchedInd

getVendName

public String getVendName()
名称 1を取得します。

戻り値:
srtVendName

getExchRateCm

public String getExchRateCm()
間接呼び値換算レートを取得します。

戻り値:
srtExchRateCm

getHold

public String getHold()
購買発注の不完全を取得します。

戻り値:
srtHold

setCoCode

public void setCoCode(String strCoCode)
会社コードを設定します。

パラメータ:
strCoCode - 会社コード

setDocCat

public void setDocCat(String strDocCat)
購買伝票カテゴリを設定します。

パラメータ:
strDocCat - 購買伝票カテゴリ

setCntrlInd

public void setCntrlInd(String strCntrlInd)
購買伝票タイプに対する管理区分を設定します。

パラメータ:
strCntrlInd - 購買伝票タイプに対する管理区分

setCreatedOn

public void setCreatedOn(String strCreatedOn)
レコード登録日を設定します。

パラメータ:
strCreatedOn - レコード登録日

setLastItem

public void setLastItem(String strLastItem)
最終明細番号を設定します。

パラメータ:
strLastItem - 最終明細番号

setLanguage

public void setLanguage(String strLanguage)
言語キーを設定します。

パラメータ:
strLanguage - 言語キー

setCashDisc1

public void setCashDisc1(String strCashDisc1)
割引率 1を設定します。

パラメータ:
strCashDisc1 - 割引率 1

setCashDisc2

public void setCashDisc2(String strCashDisc2)
割引率 2を設定します。

パラメータ:
strCashDisc2 - 割引率 2

setApplicBy

public void setApplicBy(String strApplicBy)
見積提出期限を設定します。

パラメータ:
strApplicBy - 見積提出期限

setQuotDead

public void setQuotDead(String strQuotDead)
見積提出期限を設定します。

パラメータ:
strQuotDead - 見積提出期限

setBindgPer

public void setBindgPer(String strBindgPer)
見積有効期間を設定します。

パラメータ:
strBindgPer - 見積有効期間

setBidinvNo

public void setBidinvNo(String strBidinvNo)
見積管理番号を設定します。

パラメータ:
strBidinvNo - 見積管理番号

setRejReason

public void setRejReason(String strRejReason)
見積および受注の拒否理由を設定します。

パラメータ:
strRejReason - 見積および受注の拒否理由

setComplDlv

public void setComplDlv(String strComplDlv)
全購買発注に対する一括納入指定を設定します。

パラメータ:
strComplDlv - 全購買発注に対する一括納入指定

setRcvgVend

public void setRcvgVend(String strRcvgVend)
未使用項目を設定します。

パラメータ:
strRcvgVend - 未使用項目

setTargetVal

public void setTargetVal(String strTargetVal)
累積計画金額を設定します。

パラメータ:
strTargetVal - 累積計画金額

setCollNo

public void setCollNo(String strCollNo)
一括番号を設定します。

パラメータ:
strCollNo - 一括番号

setDocCond

public void setDocCond(String strDocCond)
伝票条件番号を設定します。

パラメータ:
strDocCond - 伝票条件番号

setProcedure

public void setProcedure(String strProcedure)
決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。

パラメータ:
strProcedure - 決定表 (価格設定/出力管理/勘定設定/原価計算など)

setUpdateGrp

public void setUpdateGrp(String strUpdateGrp)
統計更新の更新グループを設定します。

パラメータ:
strUpdateGrp - 統計更新の更新グループ

setExportNo

public void setExportNo(String strExportNo)
貿易データ番号: MM/SD 伝票を設定します。

パラメータ:
strExportNo - 貿易データ番号: MM/SD 伝票

setMastCond

public void setMastCond(String strMastCond)
期間依存条件伝票を設定します。

パラメータ:
strMastCond - 期間依存条件伝票

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelStrat

public void setRelStrat(String strRelStrat)
承認方針を設定します。

パラメータ:
strRelStrat - 承認方針

setRelInd

public void setRelInd(String strRelInd)
承認区分: 購買伝票を設定します。

パラメータ:
strRelInd - 承認区分: 購買伝票

setSubjToR

public void setSubjToR(String strSubjToR)
承認未完了を設定します。

パラメータ:
strSubjToR - 承認未完了

setTaxrCntry

public void setTaxrCntry(String strTaxrCntry)
納税申告書の国を設定します。

パラメータ:
strTaxrCntry - 納税申告書の国

setSchedInd

public void setSchedInd(String strSchedInd)
分納契約のリリース伝票区分を設定します。

パラメータ:
strSchedInd - 分納契約のリリース伝票区分

setVendName

public void setVendName(String strVendName)
名称 1を設定します。

パラメータ:
strVendName - 名称 1

setExchRateCm

public void setExchRateCm(String strExchRateCm)
間接呼び値換算レートを設定します。

パラメータ:
strExchRateCm - 間接呼び値換算レート

setHold

public void setHold(String strHold)
購買発注の不完全を設定します。

パラメータ:
strHold - 購買発注の不完全

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseHeader 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHistory (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHistory

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory
すべての実装インタフェース:
Serializable
public class PurchaseHistory
extends Object
implements Serializable

購買発注履歴情報クラス
機能は以下の通り

  • 購買発注履歴情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHistory()
購買発注履歴情報を作成します。
PurchaseHistory(int index)
転購買発注履歴情報を作成します。
メソッドの概要
String | getBatch() ロット番号を取得します。
String | getBlockedQy() 発注単位の入庫保留在庫を取得します。
String | getBlQty() 入庫保留在庫数量 (発注価格単位)を取得します。
String | getClValLoc() 国内通貨による入庫/請求仮勘定決済金額を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getCondition() 伝票条件番号を取得します。
String | getConfSer() 仕入先確認の連続番号を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDbCrInd() 借方/貸方フラグを取得します。
String | getDelivQty() 納品書数量単位の数量を取得します。
String | getDelivUnit() 納品書の数量単位を取得します。
String | getDelivUnitIso() 納品書数量単位の ISO コードを取得します。
String | getDocDate() 伝票の伝票日付を取得します。
String | getDocYear() 入出庫伝票年を取得します。
String | getEntryDate() 会計伝票登録日付を取得します。
String | getEntryTime() 登録時刻を取得します。
String | getHistType() 購買発注履歴カテゴリを取得します。
String | getIvvalFor() 外貨での入力請求額を取得します。
String | getIvvalLoc() 国内通貨での入力請求額を取得します。
String | getLocCurr() 国内通貨コードを取得します。
String | getLocCurrIso() 国内通貨の ISO コードを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getProcessId() 購買発注履歴取引タイプを取得します。
String | getPstngDate() 伝票の転記日付を取得します。
String | getPurMat() 品目コードを取得します。
String | getPurMatExternal() 項目 PUR_MAT の品目コード (長)を取得します。
String | getPurMatGuid() 項目 PUR_MAT の外部 GUIDを取得します。
String | getPurMatVersion() 項目 PUR_MAT のバージョン番号を取得します。
String | getQuantity() 数量を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細を取得します。
String | getRefDocNo() 参照伝票番号を取得します。
String | getRefDocNoLong() 参照伝票番号 (依存性についてはテキスト長参照)を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getTaxCode() 売上税コードを取得します。
String | getValForcur() 伝票通貨額を取得します。
String | getValLoccur() 国内通貨額を取得します。
String | getValType() 評価タイプを取得します。
void | setBatch(String strBatch) ロット番号を設定します。
void | setBlockedQy(String strBlockedQy) 発注単位の入庫保留在庫を設定します。
void | setBlQty(String strBlQty) 入庫保留在庫数量 (発注価格単位)を設定します。
void | setClValLoc(String strClValLoc) 国内通貨による入庫/請求仮勘定決済金額を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setCondition(String strCondition) 伝票条件番号を設定します。
void | setConfSer(String strConfSer) 仕入先確認の連続番号を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDbCrInd(String strDbCrInd) 借方/貸方フラグを設定します。
void | setDelivQty(String strDelivQty) 納品書数量単位の数量を設定します。
void | setDelivUnit(String strDelivUnit) 納品書の数量単位を設定します。
void | setDelivUnitIso(String strDelivUnitIso) 納品書数量単位の ISO コードを設定します。
void | setDocDate(String strDocDate) 伝票の伝票日付を設定します。
void | setDocYear(String strDocYear) 入出庫伝票年を設定します。
void | setEntryDate(String strEntryDate) 会計伝票登録日付を設定します。
void | setEntryTime(String strEntryTime) 登録時刻を設定します。
void | setHistType(String strHistType) 購買発注履歴カテゴリを設定します。
void | setIvvalFor(String strIvvalFor) 外貨での入力請求額を設定します。
void | setIvvalLoc(String strIvvalLoc) 国内通貨での入力請求額を設定します。
void | setLocCurr(String strLocCurr) 国内通貨コードを設定します。
void | setLocCurrIso(String strLocCurrIso) 国内通貨の ISO コードを設定します。
void | setMatDoc(String strMatDoc) 入出庫伝票番号を設定します。
void | setMatdocItm(String strMatdocItm) 入出庫伝票の明細を設定します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 項目 MATERIAL の品目コード (長)を設定します。
void | setMaterialGuid(String strMaterialGuid) 項目 MATERIAL の外部 GUIDを設定します。
void | setMaterialVersion(String strMaterialVersion) 項目 MATERIAL のバージョン番号を設定します。
void | setMoveReas(String strMoveReas) 移動理由を設定します。
void | setMoveType(String strMoveType) 移動タイプ (在庫管理)を設定します。
void | setNoMoreGr(String strNoMoreGr) 納入完了 区分を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setProcessId(String strProcessId) 購買発注履歴取引タイプを設定します。
void | setPstngDate(String strPstngDate) 伝票の転記日付を設定します。
void | setPurMat(String strPurMat) 品目コードを設定します。
void | setPurMatExternal(String strPurMatExternal) 項目 PUR_MAT の品目コード (長)を設定します。
void | setPurMatGuid(String strPurMatGuid) 項目 PUR_MAT の外部 GUIDを設定します。
void | setPurMatVersion(String strPurMatVersion) 項目 PUR_MAT のバージョン番号を設定します。
void | setQuantity(String strQuantity) 数量を設定します。
void | setRefDoc(String strRefDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String strRefDocIt) 参照伝票の明細を設定します。
void | setRefDocNo(String strRefDocNo) 参照伝票番号を設定します。
void | setRefDocNoLong(String strRefDocNoLong) 参照伝票番号 (依存性についてはテキスト長参照)を設定します。
void | setRefDocYr(String strRefDocYr) 参照伝票の会計年度を設定します。
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setTaxCode(String strTaxCode) 売上税コードを設定します。
void | setValForcur(String strValForcur) 伝票通貨額を設定します。
void | setValLoccur(String strValLoccur) 国内通貨額を設定します。
void | setValType(String strValType) 評価タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHistory

public PurchaseHistory()
購買発注履歴情報を作成します。

PurchaseHistory

public PurchaseHistory(int index)
転購買発注履歴情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
strPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
strSerialNo 勘定設定の連続番号

getProcessId

public String getProcessId()
購買発注履歴取引タイプを取得します。

戻り値:
strProcessId 購買発注履歴取引タイプ

getDocYear

public String getDocYear()
入出庫伝票年を取得します。

戻り値:
strDocYear 入出庫伝票年

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
strMatDoc 入出庫伝票番号

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
strMatdocItm 入出庫伝票の明細

getHistType

public String getHistType()
購買発注履歴カテゴリを取得します。

戻り値:
strHistType 購買発注履歴カテゴリ

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
strMoveType 移動タイプ (在庫管理)

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します。

戻り値:
strPstngDate 伝票の転記日付

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
strQuantity 数量

getValLoccur

public String getValLoccur()
国内通貨額を取得します。

戻り値:
strValLoccur 国内通貨額

getValForcur

public String getValForcur()
伝票通貨額を取得します。

戻り値:
strValForcur 伝票通貨額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
strCurrency 通貨コード

getClValLoc

public String getClValLoc()
国内通貨による入庫/請求仮勘定決済金額を取得します。

戻り値:
strClValLoc 国内通貨による入庫/請求仮勘定決済金額

getBlockedQy

public String getBlockedQy()
発注単位の入庫保留在庫を取得します。

戻り値:
strBlockedQy 発注単位の入庫保留在庫

getBlQty

public String getBlQty()
入庫保留在庫数量 (発注価格単位)を取得します。

戻り値:
strBlQty 入庫保留在庫数量 (発注価格単位)

getDbCrInd

public String getDbCrInd()
借方/貸方フラグを取得します。

戻り値:
strDbCrInd 借方/貸方フラグ

getValType

public String getValType()
評価タイプを取得します。

戻り値:
strValType 評価タイプ

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
strNoMoreGr 納入完了 区分

getRefDocNo

public String getRefDocNo()
参照伝票番号を取得します。

戻り値:
strRefDocNo 参照伝票番号

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
strRefDocYr 参照伝票の会計年度

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
strRefDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細を取得します。

戻り値:
strRefDocIt 参照伝票の明細

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
strMoveReas 移動理由

getEntryDate

public String getEntryDate()
会計伝票登録日付を取得します。

戻り値:
strEntryDate 会計伝票登録日付

getEntryTime

public String getEntryTime()
登録時刻を取得します。

戻り値:
strEntryTime 登録時刻

getIvvalLoc

public String getIvvalLoc()
国内通貨での入力請求額を取得します。

戻り値:
strIvvalLoc 国内通貨での入力請求額

getIvvalFor

public String getIvvalFor()
外貨での入力請求額を取得します。

戻り値:
strIvvalFor 外貨での入力請求額

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
strMaterial 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
strPlant プラント

getConfSer

public String getConfSer()
仕入先確認の連続番号を取得します。

戻り値:
strConfSer 仕入先確認の連続番号

getCondition

public String getCondition()
伝票条件番号を取得します。

戻り値:
strCondition 伝票条件番号

getTaxCode

public String getTaxCode()
売上税コードを取得します。

戻り値:
strTaxCode 売上税コード

getDelivQty

public String getDelivQty()
納品書数量単位の数量を取得します。

戻り値:
strDelivQty 納品書数量単位の数量

getDelivUnit

public String getDelivUnit()
納品書の数量単位を取得します。

戻り値:
strDelivUnit 納品書の数量単位

getPurMat

public String getPurMat()
品目コードを取得します。

戻り値:
strPurMat 品目コード

getLocCurr

public String getLocCurr()
国内通貨コードを取得します。

戻り値:
strLocCurr 国内通貨コード

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
strBatch ロット番号

getDocDate

public String getDocDate()
伝票の伝票日付を取得します。

戻り値:
strDocDate 伝票の伝票日付

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
strCurrencyIso ISO 通貨コード

getLocCurrIso

public String getLocCurrIso()
国内通貨の ISO コードを取得します。

戻り値:
strLocCurrIso 国内通貨の ISO コード

getDelivUnitIso

public String getDelivUnitIso()
納品書数量単位の ISO コードを取得します。

戻り値:
strDelivUnitIso 納品書数量単位の ISO コード

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します。

戻り値:
strMaterialExternal 項目 MATERIAL の品目コード (長)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します。

戻り値:
strMaterialGuid 項目 MATERIAL の外部 GUID

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します。

戻り値:
strMaterialVersion 項目 MATERIAL のバージョン番号

getPurMatExternal

public String getPurMatExternal()
項目 PUR_MAT の品目コード (長)を取得します。

戻り値:
strPurMatExternal 項目 PUR_MAT の品目コード (長)

getPurMatGuid

public String getPurMatGuid()
項目 PUR_MAT の外部 GUIDを取得します。

戻り値:
strPurMatGuid 項目 PUR_MAT の外部 GUID

getPurMatVersion

public String getPurMatVersion()
項目 PUR_MAT のバージョン番号を取得します。

戻り値:
strPurMatVersion 項目 PUR_MAT のバージョン番号

getRefDocNoLong

public String getRefDocNoLong()
参照伝票番号 (依存性についてはテキスト長参照)を取得します。

戻り値:
strRefDocNoLong 参照伝票番号 (依存性についてはテキスト長参照)

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setProcessId

public void setProcessId(String strProcessId)
購買発注履歴取引タイプを設定します。

パラメータ:
strProcessId - 購買発注履歴取引タイプ

setDocYear

public void setDocYear(String strDocYear)
入出庫伝票年を設定します。

パラメータ:
strDocYear - 入出庫伝票年

setMatDoc

public void setMatDoc(String strMatDoc)
入出庫伝票番号を設定します。

パラメータ:
strMatDoc - 入出庫伝票番号

setMatdocItm

public void setMatdocItm(String strMatdocItm)
入出庫伝票の明細を設定します。

パラメータ:
strMatdocItm - 入出庫伝票の明細

setHistType

public void setHistType(String strHistType)
購買発注履歴カテゴリを設定します。

パラメータ:
strHistType - 購買発注履歴カテゴリ

setMoveType

public void setMoveType(String strMoveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
strMoveType - 移動タイプ (在庫管理)

setPstngDate

public void setPstngDate(String strPstngDate)
伝票の転記日付を設定します。

パラメータ:
strPstngDate - 伝票の転記日付

setQuantity

public void setQuantity(String strQuantity)
数量を設定します。

パラメータ:
strQuantity - 数量

setValLoccur

public void setValLoccur(String strValLoccur)
国内通貨額を設定します。

パラメータ:
strValLoccur - 国内通貨額

setValForcur

public void setValForcur(String strValForcur)
伝票通貨額を設定します。

パラメータ:
strValForcur - 伝票通貨額

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setClValLoc

public void setClValLoc(String strClValLoc)
国内通貨による入庫/請求仮勘定決済金額を設定します。

パラメータ:
strClValLoc - 国内通貨による入庫/請求仮勘定決済金額

setBlockedQy

public void setBlockedQy(String strBlockedQy)
発注単位の入庫保留在庫を設定します。

パラメータ:
strBlockedQy - 発注単位の入庫保留在庫

setBlQty

public void setBlQty(String strBlQty)
入庫保留在庫数量 (発注価格単位)を設定します。

パラメータ:
strBlQty - 入庫保留在庫数量 (発注価格単位)

setDbCrInd

public void setDbCrInd(String strDbCrInd)
借方/貸方フラグを設定します。

パラメータ:
strDbCrInd - 借方/貸方フラグ

setValType

public void setValType(String strValType)
評価タイプを設定します。

パラメータ:
strValType - 評価タイプ

setNoMoreGr

public void setNoMoreGr(String strNoMoreGr)
納入完了 区分を設定します。

パラメータ:
strNoMoreGr - 納入完了 区分

setRefDocNo

public void setRefDocNo(String strRefDocNo)
参照伝票番号を設定します。

パラメータ:
strRefDocNo - 参照伝票番号

setRefDocYr

public void setRefDocYr(String strRefDocYr)
参照伝票の会計年度を設定します。

パラメータ:
strRefDocYr - 参照伝票の会計年度

setRefDoc

public void setRefDoc(String strRefDoc)
参照伝票の伝票番号を設定します。

パラメータ:
strRefDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String strRefDocIt)
参照伝票の明細を設定します。

パラメータ:
strRefDocIt - 参照伝票の明細

setMoveReas

public void setMoveReas(String strMoveReas)
移動理由を設定します。

パラメータ:
strMoveReas - 移動理由

setEntryDate

public void setEntryDate(String strEntryDate)
会計伝票登録日付を設定します。

パラメータ:
strEntryDate - 会計伝票登録日付

setEntryTime

public void setEntryTime(String strEntryTime)
登録時刻を設定します。

パラメータ:
strEntryTime - 登録時刻

setIvvalLoc

public void setIvvalLoc(String strIvvalLoc)
国内通貨での入力請求額を設定します。

パラメータ:
strIvvalLoc - 国内通貨での入力請求額

setIvvalFor

public void setIvvalFor(String strIvvalFor)
外貨での入力請求額を設定します。

パラメータ:
strIvvalFor - 外貨での入力請求額

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setConfSer

public void setConfSer(String strConfSer)
仕入先確認の連続番号を設定します。

パラメータ:
strConfSer - 仕入先確認の連続番号

setCondition

public void setCondition(String strCondition)
伝票条件番号を設定します。

パラメータ:
strCondition - 伝票条件番号

setTaxCode

public void setTaxCode(String strTaxCode)
売上税コードを設定します。

パラメータ:
strTaxCode - 売上税コード

setDelivQty

public void setDelivQty(String strDelivQty)
納品書数量単位の数量を設定します。

パラメータ:
strDelivQty - 納品書数量単位の数量

setDelivUnit

public void setDelivUnit(String strDelivUnit)
納品書の数量単位を設定します。

パラメータ:
strDelivUnit - 納品書の数量単位

setPurMat

public void setPurMat(String strPurMat)
品目コードを設定します。

パラメータ:
strPurMat - 品目コード

setLocCurr

public void setLocCurr(String strLocCurr)
国内通貨コードを設定します。

パラメータ:
strLocCurr - 国内通貨コード

setBatch

public void setBatch(String strBatch)
ロット番号を設定します。

パラメータ:
strBatch - ロット番号

setDocDate

public void setDocDate(String strDocDate)
伝票の伝票日付を設定します。

パラメータ:
strDocDate - 伝票の伝票日付

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setLocCurrIso

public void setLocCurrIso(String strLocCurrIso)
国内通貨の ISO コードを設定します。

パラメータ:
strLocCurrIso - 国内通貨の ISO コード

setDelivUnitIso

public void setDelivUnitIso(String strDelivUnitIso)
納品書数量単位の ISO コードを設定します。

パラメータ:
strDelivUnitIso - 納品書数量単位の ISO コード

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
項目 MATERIAL の品目コード (長)を設定します。

パラメータ:
strMaterialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
項目 MATERIAL の外部 GUIDを設定します。

パラメータ:
strMaterialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
項目 MATERIAL のバージョン番号を設定します。

パラメータ:
strMaterialVersion - 項目 MATERIAL のバージョン番号

setPurMatExternal

public void setPurMatExternal(String strPurMatExternal)
項目 PUR_MAT の品目コード (長)を設定します。

パラメータ:
strPurMatExternal - 項目 PUR_MAT の品目コード (長)

setPurMatGuid

public void setPurMatGuid(String strPurMatGuid)
項目 PUR_MAT の外部 GUIDを設定します。

パラメータ:
strPurMatGuid - 項目 PUR_MAT の外部 GUID

setPurMatVersion

public void setPurMatVersion(String strPurMatVersion)
項目 PUR_MAT のバージョン番号を設定します。

パラメータ:
strPurMatVersion - 項目 PUR_MAT のバージョン番号

setRefDocNoLong

public void setRefDocNoLong(String strRefDocNoLong)
参照伝票番号 (依存性についてはテキスト長参照)を設定します。

パラメータ:
strRefDocNoLong - 参照伝票番号 (依存性についてはテキスト長参照)

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHistoryTotals (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHistoryTotals

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals
すべての実装インタフェース:
Serializable
public class PurchaseHistoryTotals
extends Object
implements Serializable

購買発注履歴（合計）情報クラス
機能は以下の通り

  • 購買発注履歴（合計）情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHistoryTotals()
購買発注履歴（合計）情報を作成します。
PurchaseHistoryTotals(int index)
購買発注履歴（合計）情報を作成します。
メソッドの概要
String | getBlockedQy() 発注単位の入庫保留在庫を取得します。
String | getBlQty() 入庫保留在庫数量 (発注価格単位)を取得します。
String | getBlQtyTotal() 発注単位による入庫保留在庫 (絶対額)を取得します。
String | getClValFor() 外貨による入庫/請求仮勘定決済金額を取得します。
String | getClValLoc() 国内通貨による入庫/請求仮勘定決済金額を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDelivQty() 入庫数量を取得します。
String | getDlQtyTotal() 入庫数量: 絶対額を取得します。
String | getDlQtyTrsp() 納入済数量 (在庫転送)を取得します。
String | getDopVlLoc() 国内通貨による前払金合計を取得します。
String | getIvQty() 請求数量を取得します。
String | getIvQtyPo() 購買価格数量単位による請求数量を取得します。
String | getIvQtyTotal() 請求書受領数量: 絶対額を取得します。
String | getIvvalFor() 外貨での入力済請求額を取得します。
String | getIvvalLoc() 国内通貨での入力請求額を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoPrQnt() 購買発注価格単位での数量を取得します。
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getValGrFor() 外国通貨での入庫額を取得します。
String | getValGrLoc() 国内通貨による入庫額を取得します。
String | getValIvFor() 外貨による請求額を取得します。
String | getValIvLoc() 国内通貨による請求額を取得します。
String | getWithdrQty() 出庫量を取得します。
void | setBlockedQy(String strBlockedQy) 発注単位の入庫保留在庫を設定します。
void | setBlQty(String strBlQty) 入庫保留在庫数量 (発注価格単位)を設定します。
void | setBlQtyTotal(String strBlQtyTotal) 発注単位による入庫保留在庫 (絶対額)を設定します。
void | setClValFor(String strClValFor) 外貨による入庫/請求仮勘定決済金額を設定します。
void | setClValLoc(String strClValLoc) 国内通貨による入庫/請求仮勘定決済金額を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDelivQty(String strDelivQty) 入庫数量を設定します。
void | setDlQtyTotal(String strDlQtyTotal) 入庫数量: 絶対額を設定します。
void | setDlQtyTrsp(String strDlQtyTrsp) 納入済数量 (在庫転送)を設定します。
void | setDopVlLoc(String strDopVlLoc) 国内通貨による前払金合計を設定します。
void | setIvQty(String strIvQty) 請求数量を設定します。
void | setIvQtyPo(String strIvQtyPo) 購買価格数量単位による請求数量を設定します。
void | setIvQtyTotal(String strIvQtyTotal) 請求書受領数量: 絶対額を設定します。
void | setIvvalFor(String strIvvalFor) 外貨での入力済請求額を設定します。
void | setIvvalLoc(String strIvvalLoc) 国内通貨での入力請求額を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPoPrQnt(String strPoPrQnt) 購買発注価格単位での数量を設定します。
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setValGrFor(String strValGrFor) 外国通貨での入庫額を設定します。
void | setValGrLoc(String strValGrLoc) 国内通貨による入庫額を設定します。
void | setValIvFor(String strValIvFor) 外貨による請求額を設定します。
void | setValIvLoc(String strValIvLoc) 国内通貨による請求額を設定します。
void | setWithdrQty(String strWithdrQty) 出庫量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHistoryTotals

public PurchaseHistoryTotals()
購買発注履歴（合計）情報を作成します。

PurchaseHistoryTotals

public PurchaseHistoryTotals(int index)
購買発注履歴（合計）情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
strPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
strSerialNo 勘定設定の連続番号

getWithdrQty

public String getWithdrQty()
出庫量を取得します。

戻り値:
strWithdrQty 出庫量

getBlockedQy

public String getBlockedQy()
発注単位の入庫保留在庫を取得します。

戻り値:
strBlockedQy 発注単位の入庫保留在庫

getBlQty

public String getBlQty()
入庫保留在庫数量 (発注価格単位)を取得します。

戻り値:
strBlQty 入庫保留在庫数量 (発注価格単位)

getDelivQty

public String getDelivQty()
入庫数量を取得します。

戻り値:
strDelivQty 入庫数量

getPoPrQnt

public String getPoPrQnt()
購買発注価格単位での数量を取得します。

戻り値:
strPoPrQnt 購買発注価格単位での数量

getValGrLoc

public String getValGrLoc()
国内通貨による入庫額を取得します。

戻り値:
strValGrLoc 国内通貨による入庫額

getValGrFor

public String getValGrFor()
外国通貨での入庫額を取得します。

戻り値:
strValGrFor 外国通貨での入庫額

getIvQty

public String getIvQty()
請求数量を取得します。

戻り値:
strIvQty 請求数量

getIvQtyPo

public String getIvQtyPo()
購買価格数量単位による請求数量を取得します。

戻り値:
strIvQtyPo 購買価格数量単位による請求数量

getValIvLoc

public String getValIvLoc()
国内通貨による請求額を取得します。

戻り値:
strValIvLoc 国内通貨による請求額

getValIvFor

public String getValIvFor()
外貨による請求額を取得します。

戻り値:
strValIvFor 外貨による請求額

getClValLoc

public String getClValLoc()
国内通貨による入庫/請求仮勘定決済金額を取得します。

戻り値:
strClValLoc 国内通貨による入庫/請求仮勘定決済金額

getClValFor

public String getClValFor()
外貨による入庫/請求仮勘定決済金額を取得します。

戻り値:
strClValFor 外貨による入庫/請求仮勘定決済金額

getDopVlLoc

public String getDopVlLoc()
国内通貨による前払金合計を取得します。

戻り値:
strDopVlLoc 国内通貨による前払金合計

getIvvalLoc

public String getIvvalLoc()
国内通貨での入力請求額を取得します。

戻り値:
strIvvalLoc 国内通貨での入力請求額

getIvvalFor

public String getIvvalFor()
外貨での入力済請求額を取得します。

戻り値:
strIvvalFor 外貨での入力済請求額

getDlQtyTrsp

public String getDlQtyTrsp()
納入済数量 (在庫転送)を取得します。

戻り値:
strDlQtyTrsp 納入済数量 (在庫転送)

getBlQtyTotal

public String getBlQtyTotal()
発注単位による入庫保留在庫 (絶対額)を取得します。

戻り値:
strBlQtyTotal 発注単位による入庫保留在庫 (絶対額)

getDlQtyTotal

public String getDlQtyTotal()
入庫数量: 絶対額を取得します。

戻り値:
strDlQtyTotal 入庫数量: 絶対額

getIvQtyTotal

public String getIvQtyTotal()
請求書受領数量: 絶対額を取得します。

戻り値:
strIvQtyTotal 請求書受領数量: 絶対額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
strCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
strCurrencyIso ISO 通貨コード

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setWithdrQty

public void setWithdrQty(String strWithdrQty)
出庫量を設定します。

パラメータ:
strWithdrQty - 出庫量

setBlockedQy

public void setBlockedQy(String strBlockedQy)
発注単位の入庫保留在庫を設定します。

パラメータ:
strBlockedQy - 発注単位の入庫保留在庫

setBlQty

public void setBlQty(String strBlQty)
入庫保留在庫数量 (発注価格単位)を設定します。

パラメータ:
strBlQty - 入庫保留在庫数量 (発注価格単位)

setDelivQty

public void setDelivQty(String strDelivQty)
入庫数量を設定します。

パラメータ:
strDelivQty - 入庫数量

setPoPrQnt

public void setPoPrQnt(String strPoPrQnt)
購買発注価格単位での数量を設定します。

パラメータ:
strPoPrQnt - 購買発注価格単位での数量

setValGrLoc

public void setValGrLoc(String strValGrLoc)
国内通貨による入庫額を設定します。

パラメータ:
strValGrLoc - 国内通貨による入庫額

setValGrFor

public void setValGrFor(String strValGrFor)
外国通貨での入庫額を設定します。

パラメータ:
strValGrFor - 外国通貨での入庫額

setIvQty

public void setIvQty(String strIvQty)
請求数量を設定します。

パラメータ:
strIvQty - 請求数量

setIvQtyPo

public void setIvQtyPo(String strIvQtyPo)
購買価格数量単位による請求数量を設定します。

パラメータ:
strIvQtyPo - 購買価格数量単位による請求数量

setValIvLoc

public void setValIvLoc(String strValIvLoc)
国内通貨による請求額を設定します。

パラメータ:
strValIvLoc - 国内通貨による請求額

setValIvFor

public void setValIvFor(String strValIvFor)
外貨による請求額を設定します。

パラメータ:
strValIvFor - 外貨による請求額

setClValLoc

public void setClValLoc(String strClValLoc)
国内通貨による入庫/請求仮勘定決済金額を設定します。

パラメータ:
strClValLoc - 国内通貨による入庫/請求仮勘定決済金額

setClValFor

public void setClValFor(String strClValFor)
外貨による入庫/請求仮勘定決済金額を設定します。

パラメータ:
strClValFor - 外貨による入庫/請求仮勘定決済金額

setDopVlLoc

public void setDopVlLoc(String strDopVlLoc)
国内通貨による前払金合計を設定します。

パラメータ:
strDopVlLoc - 国内通貨による前払金合計

setIvvalLoc

public void setIvvalLoc(String strIvvalLoc)
国内通貨での入力請求額を設定します。

パラメータ:
strIvvalLoc - 国内通貨での入力請求額

setIvvalFor

public void setIvvalFor(String strIvvalFor)
外貨での入力済請求額を設定します。

パラメータ:
strIvvalFor - 外貨での入力済請求額

setDlQtyTrsp

public void setDlQtyTrsp(String strDlQtyTrsp)
納入済数量 (在庫転送)を設定します。

パラメータ:
strDlQtyTrsp - 納入済数量 (在庫転送)

setBlQtyTotal

public void setBlQtyTotal(String strBlQtyTotal)
発注単位による入庫保留在庫 (絶対額)を設定します。

パラメータ:
strBlQtyTotal - 発注単位による入庫保留在庫 (絶対額)

setDlQtyTotal

public void setDlQtyTotal(String strDlQtyTotal)
入庫数量: 絶対額を設定します。

パラメータ:
strDlQtyTotal - 入庫数量: 絶対額

setIvQtyTotal

public void setIvQtyTotal(String strIvQtyTotal)
請求書受領数量: 絶対額を設定します。

パラメータ:
strIvQtyTotal - 請求書受領数量: 絶対額

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItem (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseItemPost, PurchaseItems
public class PurchaseItem
extends Object
implements Serializable

購買発注明細情報スーパークラス
機能は以下の通り

  • 購買発注の明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItem()
購買発注伝票明細を作成します。
メソッドの概要
String | getAcctasscat() 勘定設定カテゴリを取得します。
String | getAcknReqd() 購買発注請求書依頼を取得します。
String | getAgmtItem() 購買契約の明細番号を取得します。
String | getAgreement() 購買契約番号を取得します。
String | getAtRelev() 適当テーブル関連を取得します。
String | getConvDen1() 購買価格単位から購買発注単位への変換分母を取得します。
String | getConvNum1() 購買価格単位から購買発注単位への変換分子を取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDistrib() 複数勘定設定の配賦区分を取得します。
String | getInfoRec() 購買情報番号を取得します。
String | getItemCat() 購買伝票の明細カテゴリを取得します。
String | getKanbanInd() かんばん区分を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 品目コード（長）を取得します。
String | getMaterialGuid() 品目コードの外部GUIDを取得します。
String | getMaterialVersion() 品目コードのバージョン番号を取得します。
String | getNetPrice() 通貨額を取得します。
String | getNoMoreGr() 納入完了区分を取得します。
String | getNoRounding() 購買発注明細での非表示丸めを取得します。
String | getOrderprUn() 購買発注価格単位を取得します。
String | getOrderprUnIso() 購買発注価格のISOコードを取得します。
String | getPartInv() 一部請求区分を取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPlanDel() 予定納入日数を取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 明細番号を取得します。
String | getPoPrice() 価格採用区分を取得します。
String | getPoUnitIso() ISOコードによる発注単位を取得します。
String | getPreqName() 購買依頼者名/要求者名を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getQualInsp() 在庫タイプを取得します。
String | getRetItem() 返品明細を取得します。
String | getShipping() 出荷指示を取得します。
String | getShortText() 品目コードテキスト（短）を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTrackingno() 購買依頼追跡番号を取得します。
String | getValType() 評価タイプを取得します。
String | getVendMat() 仕入先が使用している品目コードを取得します。
void | setAcctasscat(String strAcctasscat) 勘定設定カテゴリを設定します。
void | setAcknReqd(String strAcknReqd) 購買発注請求書依頼を設定します。
void | setAgmtItem(String strAgmtItem) 購買契約の明細番号を設定します。
void | setAgreement(String strAgreement) 購買契約番号を設定します。
void | setAtRelev(String strAtRelev) 適当テーブル関連を設定します。
void | setConvDen1(String strConvDen1) 購買価格単位から購買発注単位への変換分母を設定します。
void | setConvNum1(String strConvNum1) 購買価格単位から購買発注単位への変換分子を設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDistrib(String strDistrib) 複数勘定設定の配賦区分を設定します。
void | setInfoRec(String strInfoRec) 購買情報番号を設定します。
void | setItemCat(String strItemCat) 購買伝票の明細カテゴリを設定します。
void | setKanbanInd(String strKanbanInd) かんばん区分を設定します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 品目コード（長）を設定します。
void | setMaterialGuid(String strMaterialGuid) 品目コードの外部GUIDを設定します。
void | setMaterialVersion(String strMaterialVersion) 品目コードのバージョン番号を設定します。
void | setNetPrice(String strNetPrice) 通貨額を設定します。
void | setNoMoreGr(String strNoMoreGr) 納入完了区分を設定します。
void | setNoRounding(String strNoRounding) 購買発注明細での非表示丸めを設定します。
void | setOrderprUn(String strOrderprUn) 購買発注価格単位を設定します。
void | setOrderprUnIso(String strOrderprUnIso) 購買発注価格のISOコードを設定します。
void | setPartInv(String strPartInv) 一部請求区分を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPlanDel(String strPlanDel) 予定納入日数を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPoItem(String strPoItem) 明細番号を設定します。
void | setPoPrice(String strPoPrice) 価格採用区分を設定します。
void | setPoUnitIso(String strPoUnitIso) ISOコードによる発注単位を設定します。
void | setPreqName(String strPreqName) 購買依頼者名/要求者名を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setQualInsp(String strQualInsp) 在庫タイプを設定します。
void | setRetItem(String strRetItem) 返品明細を設定します。
void | setShipping(String strShipping) 出荷指示を設定します。
void | setShortText(String strShortText) 品目コードテキスト（短）を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTrackingno(String strTrackingno) 購買依頼追跡番号を設定します。
void | setValType(String strValType) 評価タイプを設定します。
void | setVendMat(String strVendMat) 仕入先が使用している品目コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItem

public PurchaseItem()
購買発注伝票明細を作成します。

メソッドの詳細

getPoItem

public String getPoItem()
明細番号を取得します。

戻り値:
strPoItem

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
strDeleteInd

getShortText

public String getShortText()
品目コードテキスト（短）を取得します。

戻り値:
strShortText

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
strMaterial

getMaterialExternal

public String getMaterialExternal()
品目コード（長）を取得します。

戻り値:
strMaterialExternal

getMaterialGuid

public String getMaterialGuid()
品目コードの外部GUIDを取得します。

戻り値:
strMaterialGuid

getMaterialVersion

public String getMaterialVersion()
品目コードのバージョン番号を取得します。

戻り値:
strMaterialVersion

getPlant

public String getPlant()
プラントを取得します。

戻り値:
strPlant

getTrackingno

public String getTrackingno()
購買依頼追跡番号を取得します。

戻り値:
strTrackingno

getInfoRec

public String getInfoRec()
購買情報番号を取得します。

戻り値:
strInfoRec

getVendMat

public String getVendMat()
仕入先が使用している品目コードを取得します。

戻り値:
strVendMat

getPoUnitIso

public String getPoUnitIso()
ISOコードによる発注単位を取得します。

戻り値:
strPoUnitIso

getOrderprUn

public String getOrderprUn()
購買発注価格単位を取得します。

戻り値:
strOrderprUn

getOrderprUnIso

public String getOrderprUnIso()
購買発注価格のISOコードを取得します。

戻り値:
strOrderprUnIso

getConvNum1

public String getConvNum1()
購買価格単位から購買発注単位への変換分子を取得します。

戻り値:
strConvNum1

getConvDen1

public String getConvDen1()
購買価格単位から購買発注単位への変換分母を取得します。

戻り値:
strConvDen1

getNetPrice

public String getNetPrice()
通貨額を取得します。

戻り値:
strNetPrice

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
strPriceUnit

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
strTaxCode

getQualInsp

public String getQualInsp()
在庫タイプを取得します。

戻り値:
strQualInsp

getValType

public String getValType()
評価タイプを取得します。

戻り値:
strValType

getNoMoreGr

public String getNoMoreGr()
納入完了区分を取得します。

戻り値:
strNoMoreGr

getItemCat

public String getItemCat()
購買伝票の明細カテゴリを取得します。

戻り値:
strItemCat

getAcctasscat

public String getAcctasscat()
勘定設定カテゴリを取得します。

戻り値:
strAcctasscat

getDistrib

public String getDistrib()
複数勘定設定の配賦区分を取得します。

戻り値:
strDistrib

getPartInv

public String getPartInv()
一部請求区分を取得します。

戻り値:
strPartInv

getAcknReqd

public String getAcknReqd()
購買発注請求書依頼を取得します。

戻り値:
strAcknReqd

getAgreement

public String getAgreement()
購買契約番号を取得します。

戻り値:
strAgreement

getAgmtItem

public String getAgmtItem()
購買契約の明細番号を取得します。

戻り値:
strAgmtItem

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
strShipping

getPlanDel

public String getPlanDel()
予定納入日数を取得します。

戻り値:
strPlanDel

getKanbanInd

public String getKanbanInd()
かんばん区分を取得します。

戻り値:
strKanbanInd

getRetItem

public String getRetItem()
返品明細を取得します。

戻り値:
strRetItem

getAtRelev

public String getAtRelev()
適当テーブル関連を取得します。

戻り値:
strAtRelev

getPreqName

public String getPreqName()
購買依頼者名/要求者名を取得します。

戻り値:
strPreqName

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
strPckgNo

getNoRounding

public String getNoRounding()
購買発注明細での非表示丸めを取得します。

戻り値:
strNoRounding

getPoPrice

public String getPoPrice()
価格採用区分を取得します。

戻り値:
strPoPrice

setPoItem

public void setPoItem(String strPoItem)
明細番号を設定します。

パラメータ:
strPoItem - 明細番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setShortText

public void setShortText(String strShortText)
品目コードテキスト（短）を設定します。

パラメータ:
strShortText - 品目コードテキスト（短）

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
品目コード（長）を設定します。

パラメータ:
strMaterialExternal - 品目コード（長）

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
品目コードの外部GUIDを設定します。

パラメータ:
strMaterialGuid - 品目コードの外部GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
品目コードのバージョン番号を設定します。

パラメータ:
strMaterialVersion - 品目コードのバージョン番号

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setTrackingno

public void setTrackingno(String strTrackingno)
購買依頼追跡番号を設定します。

パラメータ:
strTrackingno - 購買依頼追跡番号

setInfoRec

public void setInfoRec(String strInfoRec)
購買情報番号を設定します。

パラメータ:
strInfoRec - 購買情報番号

setVendMat

public void setVendMat(String strVendMat)
仕入先が使用している品目コードを設定します。

パラメータ:
strVendMat - 仕入先が使用している品目コード

setPoUnitIso

public void setPoUnitIso(String strPoUnitIso)
ISOコードによる発注単位を設定します。

パラメータ:
strPoUnitIso - ISOコードによる発注単位

setOrderprUn

public void setOrderprUn(String strOrderprUn)
購買発注価格単位を設定します。

パラメータ:
strOrderprUn - 購買発注価格単位

setOrderprUnIso

public void setOrderprUnIso(String strOrderprUnIso)
購買発注価格のISOコードを設定します。

パラメータ:
strOrderprUnIso - 購買発注価格のISOコード

setConvNum1

public void setConvNum1(String strConvNum1)
購買価格単位から購買発注単位への変換分子を設定します。

パラメータ:
strConvNum1 - 購買価格単位から購買発注単位への変換分子

setConvDen1

public void setConvDen1(String strConvDen1)
購買価格単位から購買発注単位への変換分母を設定します。

パラメータ:
strConvDen1 - 購買価格単位から購買発注単位への変換分母

setNetPrice

public void setNetPrice(String strNetPrice)
通貨額を設定します。

パラメータ:
strNetPrice - 通貨額

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setQualInsp

public void setQualInsp(String strQualInsp)
在庫タイプを設定します。

パラメータ:
strQualInsp - 在庫タイプ

setValType

public void setValType(String strValType)
評価タイプを設定します。

パラメータ:
strValType - 評価タイプ

setNoMoreGr

public void setNoMoreGr(String strNoMoreGr)
納入完了区分を設定します。

パラメータ:
strNoMoreGr - 納入完了区分

setItemCat

public void setItemCat(String strItemCat)
購買伝票の明細カテゴリを設定します。

パラメータ:
strItemCat - 購買伝票の明細カテゴリ

setAcctasscat

public void setAcctasscat(String strAcctasscat)
勘定設定カテゴリを設定します。

パラメータ:
strAcctasscat - 勘定設定カテゴリ

setDistrib

public void setDistrib(String strDistrib)
複数勘定設定の配賦区分を設定します。

パラメータ:
strDistrib - 複数勘定設定の配賦区分

setPartInv

public void setPartInv(String strPartInv)
一部請求区分を設定します。

パラメータ:
strPartInv - 一部請求区分

setAcknReqd

public void setAcknReqd(String strAcknReqd)
購買発注請求書依頼を設定します。

パラメータ:
strAcknReqd - 購買発注請求書依頼

setAgreement

public void setAgreement(String strAgreement)
購買契約番号を設定します。

パラメータ:
strAgreement - 購買契約番号

setAgmtItem

public void setAgmtItem(String strAgmtItem)
購買契約の明細番号を設定します。

パラメータ:
strAgmtItem - 購買契約の明細番号

setShipping

public void setShipping(String strShipping)
出荷指示を設定します。

パラメータ:
strShipping - 出荷指示

setPlanDel

public void setPlanDel(String strPlanDel)
予定納入日数を設定します。

パラメータ:
strPlanDel - 予定納入日数

setKanbanInd

public void setKanbanInd(String strKanbanInd)
かんばん区分を設定します。

パラメータ:
strKanbanInd - かんばん区分

setRetItem

public void setRetItem(String strRetItem)
返品明細を設定します。

パラメータ:
strRetItem - 返品明細

setAtRelev

public void setAtRelev(String strAtRelev)
適当テーブル関連を設定します。

パラメータ:
strAtRelev - 適当テーブル関連

setPreqName

public void setPreqName(String strPreqName)
購買依頼者名/要求者名を設定します。

パラメータ:
strPreqName - 購買依頼者名/要求者名

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setNoRounding

public void setNoRounding(String strNoRounding)
購買発注明細での非表示丸めを設定します。

パラメータ:
strNoRounding - 購買発注明細での非表示丸め

setPoPrice

public void setPoPrice(String strPoPrice)
価格採用区分を設定します。

パラメータ:
strPoPrice - 価格採用区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItemPost (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItemPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost
すべての実装インタフェース:
Serializable
public class PurchaseItemPost
extends PurchaseItem
implements Serializable

購買発注伝票明細情報クラス
機能は以下の通り

  • 購買発注伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItemPost()
購買発注伝票明細を作成します。
PurchaseItemPost(int index)
購買発注伝票明細を作成します。
メソッドの概要
String | getAcknowlNo() 購買発注請書番号を取得します。
String | getAllocTbl() 商品配分表番号を取得します。
String | getAllocTblItem() 割当テーブルの明細番号を取得します。
String | getBatch() ロット番号を取得します。
String | getBonGrp1() 決済グループ1を取得します。
String | getBonGrp2() 決済グループ 2 (リベート決済、購買)を取得します。
String | getBonGrp3() 決済グループ 3 (リベート決済、購買)を取得します。
String | getBrasNbm() Brazilian NCM Codeを取得します。
String | getCalctype() 価格設定タイプを取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCondGroup() 仕入先条件グループを取得します。
String | getConfCtrl() 確認管理キーを取得します。
String | getCrmRefSalesOrderNo() 仕入先直送発注処理の CRM 参照受注番号を取得します。
String | getCrmRefSoItemNo() 仕入先直送発注処理での CRM 参照受注明細番号を取得します。
String | getCrmSalesOrderItemNo() 仕入先直送発注処理での CRM 受注明細番号を取得します。
String | getCrmSalesOrderNo() 仕入先直送発注処理の CRM 受注番号を取得します。
String | getCtrlKey() 調達における品質管理の管理キーを取得します。
String | getCustomer() 得意先コードを取得します。
String | getDelivCompl() 出荷完了 区分を取得します。
String | getEmaterial() 品目コードを取得します。
String | getEmaterialExternal() 品目コード（長）を取得します。
String | getEmaterialGuid() 品目コードの外部GUIDを取得します。
String | getEmaterialVersion() 品目コードのバージョン番号を取得します。
String | getErs() ERS（入庫/請求自動決済）を取得します。
String | getEstPrice() 概算価格区分を取得します。
String | getFinalInv() 請求書処理完了区分を取得します。
String | getFreeItem() 無償明細を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getFundsRes() 予算執行伝票の伝票番号を取得します。
int | getGlIndex() レコード番号を設定します｡
String | getGrantNbr() 補助金を取得します。
String | getGrBasediv() 入庫基準の請求書照合区分を取得します。
String | getGrInd() 入庫区分を取得します。
String | getGrNonVal() 非評価入庫を取得します。
String | getGrossWt() 総重量を取得します。
String | getGrPrTime() 入庫処理日数を取得します。
String | getGrToDate() 納入最終期限を取得します。
String | getHlItem() 購買伝票中の上位明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
String | getIndus3() 品目 CFOP カテゴリを取得します。
String | getInfIndex() インフレーション指数を取得します。
String | getInfoUpd() 購買情報更新区分を取得します。
String | getInHouse() 内部生産を取得します。
String | getIntObjNo() 選定 (内部オブジェクト番号)を取得します。
String | getIrInd() 請求書受領区分を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatlUsage() 品目の用途を取得します。
String | getMatOrigin() 品目の原産地を取得します。
String | getMinremlife() 最低有効期間残を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNoDisct() 現金値引対象外明細を取得します。
String | getOrderReason() 発注理由を取得します。
String | getOrigAccept() 仕入先構内での受領を取得します。
String | getOverDlvTol() 過剰納入許容範囲を取得します。
String | getPartDeliv() 明細レベルでの分割納入 (在庫転送)を取得します。
String | getPeriodIndExpirationDate() 有効期間期限日の期間区分を取得します。
String | getPoints() リベートポイント数を取得します。
String | getPointUnit() ポイント単位を取得します。
String | getPointUnitIso() ポイント単位の ISO コードを取得します。
String | getPoUnit() 発注単位を取得します。
String | getPreqItem() 購買依頼の明細番号を取得します。
String | getPreqNo() 購買依頼番号を取得します。
String | getPreVendor() 製造元/販売元を取得します。
String | getPricedate() 価格設定日カテゴリ (価格設定日管理)を取得します。
String | getPriceDate() 価格設定日を取得します。
String | getPrioRequirement() 所要量の優先順位を取得します。
String | getPrioUrgency() 所要量の緊急度を取得します。
String | getPrntPrice() 価格印刷を取得します。
String | getQuantity() 購買発注数量を取得します。
String | getReasonCode() Goods Receipt Reason Codeを取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefItem() 参照伝票の明細を取得します。
String | getReminder1() 第一回催促状/督促状の日数を取得します。
String | getReminder2() 第二回催促状/督促状の日数を取得します。
String | getReminder3() 第三回催促状/督促状の日数を取得します。
String | getResItem() 用途指定予算: 伝票明細を取得します。
String | getRevLev() 改訂レベルを取得します。
String | getRfqItem() 見積依頼明細番号を取得します。
String | getRfqNo() 見積依頼番号を取得します。
String | getRPromo() プロモーションを取得します。
String | getScVendor() 外注仕入先を取得します。
String | getSeason() 季節カテゴリを取得します。
String | getSeasonYr() シーズン年度を取得します。
String | getSettItem() リベート (期末) 決済対象の明細を取得します。
String | getShipBlocked() SD 出荷伝票の明細ブロックを取得します。
String | getSiCat() 補助明細カテゴリ、購買伝票を取得します。
String | getSrcStockType() 在庫転送オーダーの元保管場所在庫タイプを取得します。
String | getSrvBasedIv() サービス基準請求書照合の区分を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getSupplStloc() 出庫保管場所: 在庫転送オーダーを取得します。
String | getSuppVendor() 供給仕入先/仕入入庫を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnderDlvTol() 不足納入許容範囲リミットを取得します。
String | getUnlimitedDlv() 区分: 無制限過剰納入可能を取得します。
String | getUntilDate() インフレーション指数日付を取得します。
String | getVendPart() 仕入先部門を取得します。
String | getVendrbatch() 仕入先ロット番号を取得します。
String | getVolume() 容積を取得します。
String | getVolumeunit() 容積単位を取得します。
String | getVolumeunitIso() ISO コードでの容積単位を取得します。
String | getWeightunit() 重量単位を取得します。
String | getWeightunitIso() 重量単位のISOコードを取得します。
void | setAcknowlNo(String strAcknowlNo) 購買発注請書番号を設定します。
void | setAllocTbl(String strAllocTbl) 商品配分表番号を設定します。
void | setAllocTblItem(String strAllocTblItem) 割当テーブルの明細番号を設定します。
void | setBatch(String strBatch) ロット番号を設定します。
void | setBonGrp1(String strBonGrp1) 決済グループ1を設定します。
void | setBonGrp2(String strBonGrp2) 決済グループ 2 (リベート決済、購買)を設定します。
void | setBonGrp3(String strBonGrp3) 決済グループ 3 (リベート決済、購買)を設定します。
void | setBrasNbm(String strBrasNbm) Brazilian NCM Codeを設定します。
void | setCalctype(String strCalctype) 価格設定タイプを設定します。
void | setCmmtItem(String strCmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String strCmmtItemLong) 資金予算コードを設定します。
void | setCondGroup(String strCondGroup) 仕入先条件グループを設定します。
void | setConfCtrl(String strConfCtrl) 確認管理キーを設定します。
void | setCrmRefSalesOrderNo(String strCrmRefSalesOrderNo) 仕入先直送発注処理の CRM 参照受注番号を設定します。
void | setCrmRefSoItemNo(String strCrmRefSoItemNo) 仕入先直送発注処理での CRM 参照受注明細番号を設定します。
void | setCrmSalesOrderItemNo(String strCrmSalesOrderItemNo) 仕入先直送発注処理での CRM 受注明細番号を設定します。
void | setCrmSalesOrderNo(String strCrmSalesOrderNo) 仕入先直送発注処理の CRM 受注番号を設定します。
void | setCtrlKey(String strCtrlKey) 調達における品質管理の管理キーを設定します。
void | setCustomer(String strCustomer) 得意先コードを設定します。
void | setDelivCompl(String strDelivCompl) 出荷完了 区分を設定します。
void | setEmaterial(String strEmaterial) 品目コードを設定します。
void | setEmaterialExternal(String strEmaterialExternal) 品目コード（長）を設定します。
void | setEmaterialGuid(String strEmaterialGuid) 品目コードの外部GUIDを設定します。
void | setEmaterialVersion(String strEmaterialVersion) 品目コードのバージョン番号を設定します。
void | setErs(String strErs) ERS（入庫/請求自動決済）を設定します。
void | setEstPrice(String strEstPrice) 概算価格区分を設定します。
void | setFinalInv(String strFinalInv) 請求書処理完了区分を設定します。
void | setFreeItem(String strFreeItem) 無償明細を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFund(String strFund) 会計区分を設定します。
void | setFundsCtr(String strFundsCtr) 予算センタを設定します。
void | setFundsRes(String strFundsRes) 予算執行伝票の伝票番号を設定します。
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGrantNbr(String strGrantNbr) 補助金を設定します。
void | setGrBasediv(String strGrBasediv) 入庫基準の請求書照合区分を設定します。
void | setGrInd(String strGrInd) 入庫区分を設定します。
void | setGrNonVal(String strGrNonVal) 非評価入庫を設定します。
void | setGrossWt(String strGrossWt) 総重量を設定します。
void | setGrPrTime(String strGrPrTime) 入庫処理日数を設定します。
void | setGrToDate(String strGrToDate) 納入最終期限を設定します。
void | setHlItem(String strHlItem) 購買伝票中の上位明細を設定します。
void | setIncoterms1(String strIncoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String strIncoterms2) インコタームズ 2を設定します。
void | setIndus3(String strIndus3) 品目 CFOP カテゴリを設定します。
void | setInfIndex(String strInfIndex) インフレーション指数を設定します。
void | setInfoUpd(String strInfoUpd) 購買情報更新区分を設定します。
void | setInHouse(String strInHouse) 内部生産を設定します。
void | setIntObjNo(String strIntObjNo) 選定 (内部オブジェクト番号)を設定します。
void | setIrInd(String strIrInd) 請求書受領区分を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setMatlUsage(String strMatlUsage) 品目の用途を設定します。
void | setMatOrigin(String strMatOrigin) 品目の原産地を設定します。
void | setMinremlife(String strMinremlife) 最低有効期間残を設定します。
void | setNetWeight(String strNetWeight) 正味重量を設定します。
void | setNoDisct(String strNoDisct) 現金値引対象外明細を設定します。
void | setOrderReason(String strOrderReason) 発注理由を設定します。
void | setOrigAccept(String strOrigAccept) 仕入先構内での受領を設定します。
void | setOverDlvTol(String strOverDlvTol) 過剰納入許容範囲を設定します。
void | setPartDeliv(String strPartDeliv) 明細レベルでの分割納入 (在庫転送)を設定します。
void | setPeriodIndExpirationDate(String strPeriodIndExpirationDate) 有効期間期限日の期間区分を設定します。
void | setPoints(String strPoints) リベートポイント数を設定します。
void | setPointUnit(String strPointUnit) ポイント単位を設定します。
void | setPointUnitIso(String strPointUnitIso) ポイント単位の ISO コードを設定します。
void | setPoUnit(String strPoUnit) 発注単位を設定します。
void | setPreqItem(String strPreqItem) 購買依頼の明細番号を設定します。
void | setPreqNo(String strPreqNo) 購買依頼番号を設定します。
void | setPreVendor(String strPreVendor) 製造元/販売元を設定します。
void | setPricedate(String strPricedate) 価格設定日カテゴリ (価格設定日管理)を設定します。
void | setPriceDate(String strPriceDate) 価格設定日を設定します。
void | setPrioRequirement(String strPrioRequirement) 所要量の優先順位を設定します。
void | setPrioUrgency(String strPrioUrgency) 所要量の緊急度を設定します。
void | setPrntPrice(String strPrntPrice) 価格印刷を設定します。
void | setQuantity(String strQuantity) 購買発注数量を設定します。
void | setReasonCode(String strReasonCode) Goods Receipt Reason Codeを設定します。
void | setReasonRej(String strReasonRej) 見積および受注の拒否理由を設定します。
void | setRefDoc(String strRefDoc) 参照伝票番号を設定します。
void | setRefItem(String strRefItem) 参照伝票の明細を設定します。
void | setReminder1(String strReminder1) 第一回催促状/督促状の日数を設定します。
void | setReminder2(String strReminder2) 第二回催促状/督促状の日数を設定します。
void | setReminder3(String strReminder3) 第三回催促状/督促状の日数を設定します。
void | setResItem(String strResItem) 用途指定予算: 伝票明細を設定します。
void | setRevLev(String strRevLev) 改訂レベルを設定します。
void | setRfqItem(String strRfqItem) 見積依頼明細番号を設定します。
void | setRfqNo(String strRfqNo) 見積依頼番号を設定します。
void | setRPromo(String strRPromo) プロモーションを設定します。
void | setScVendor(String strScVendor) 外注仕入先を設定します。
void | setSeason(String strSeason) 季節カテゴリを設定します。
void | setSeasonYr(String strSeasonYr) シーズン年度を設定します。
void | setSettItem(String strSettItem) リベート (期末) 決済対象の明細を設定します。
void | setShipBlocked(String strShipBlocked) SD 出荷伝票の明細ブロックを設定します。
void | setSiCat(String strSiCat) 補助明細カテゴリ、購買伝票を設定します。
void | setSrcStockType(String strSrcStockType) 在庫転送オーダーの元保管場所在庫タイプを設定します。
void | setSrvBasedIv(String strSrvBasedIv) サービス基準請求書照合の区分を設定します。
void | setStgeLoc(String strStgeLoc) 保管場所を設定します。
void | setSupplStloc(String strSupplStloc) 出庫保管場所: 在庫転送オーダーを設定します。
void | setSuppVendor(String strSuppVendor) 供給仕入先/仕入入庫を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnderDlvTol(String strUnderDlvTol) 不足納入許容範囲リミットを設定します。
void | setUnlimitedDlv(String strUnlimitedDlv) 区分: 無制限過剰納入可能を設定します。
void | setUntilDate(String strUntilDate) インフレーション指数日付を設定します。
void | setVendPart(String strVendPart) 仕入先部門を設定します。
void | setVendrbatch(String strVendrbatch) 仕入先ロット番号を設定します。
void | setVolume(String strVolume) 容積を設定します。
void | setVolumeunit(String strVolumeunit) 容積単位を設定します。
void | setVolumeunitIso(String strVolumeunitIso) ISO コードでの容積単位を設定します。
void | setWeightunit(String strWeightunit) 重量単位を設定します。
void | setWeightunitIso(String strWeightunitIso) 重量単位のISOコードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem から継承したメソッド
getAcctasscat, getAcknReqd, getAgmtItem, getAgreement, getAtRelev, getConvDen1, getConvNum1, getDeleteInd, getDistrib, getInfoRec, getItemCat, getKanbanInd, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getNetPrice, getNoMoreGr, getNoRounding, getOrderprUn, getOrderprUnIso, getPartInv, getPckgNo, getPlanDel, getPlant, getPoItem, getPoPrice, getPoUnitIso, getPreqName, getPriceUnit, getQualInsp, getRetItem, getShipping, getShortText, getTaxCode, getTrackingno, getValType, getVendMat, setAcctasscat, setAcknReqd, setAgmtItem, setAgreement, setAtRelev, setConvDen1, setConvNum1, setDeleteInd, setDistrib, setInfoRec, setItemCat, setKanbanInd, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setNetPrice, setNoMoreGr, setNoRounding, setOrderprUn, setOrderprUnIso, setPartInv, setPckgNo, setPlanDel, setPlant, setPoItem, setPoPrice, setPoUnitIso, setPreqName, setPriceUnit, setQualInsp, setRetItem, setShipping, setShortText, setTaxCode, setTrackingno, setValType, setVendMat
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItemPost

public PurchaseItemPost()
購買発注伝票明細を作成します。

PurchaseItemPost

public PurchaseItemPost(int index)
購買発注伝票明細を作成します。

パラメータ:
index - レコード件数
メソッドの詳細

getEmaterial

public String getEmaterial()
品目コードを取得します。

戻り値:
srtEmaterial 品目コード

getEmaterialExternal

public String getEmaterialExternal()
品目コード（長）を取得します。

戻り値:
srtEmaterialExternal 品目コード（長）

getEmaterialGuid

public String getEmaterialGuid()
品目コードの外部GUIDを取得します。

戻り値:
srtEmaterialGuid 品目コードの外部GUID

getEmaterialVersion

public String getEmaterialVersion()
品目コードのバージョン番号を取得します。

戻り値:
srtEmaterialVersion 品目コードのバージョン番号

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
srtStgeLoc 保管場所

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getQuantity

public String getQuantity()
購買発注数量を取得します。

戻り値:
srtQuantity 購買発注数量

getPoUnit

public String getPoUnit()
発注単位を取得します。

戻り値:
srtPoUnit 発注単位

getGrPrTime

public String getGrPrTime()
入庫処理日数を取得します。

戻り値:
srtGrPrTime 入庫処理日数

getBonGrp1

public String getBonGrp1()
決済グループ1を取得します。

戻り値:
srtBonGrp1 決済グループ1

getInfoUpd

public String getInfoUpd()
購買情報更新区分を取得します。

戻り値:
srtInfoUpd 購買情報更新区分

getPrntPrice

public String getPrntPrice()
価格印刷を取得します。

戻り値:
srtPrntPrice 価格印刷

getEstPrice

public String getEstPrice()
概算価格区分を取得します。

戻り値:
srtEstPrice 概算価格区分

getReminder1

public String getReminder1()
第一回催促状/督促状の日数を取得します。

戻り値:
srtReminder1 第一回催促状/督促状の日数

getReminder2

public String getReminder2()
第二回催促状/督促状の日数を取得します。

戻り値:
srtReminder2 第二回催促状/督促状の日数

getReminder3

public String getReminder3()
第三回催促状/督促状の日数を取得します。

戻り値:
srtReminder3 第三回催促状/督促状の日数

getOverDlvTol

public String getOverDlvTol()
過剰納入許容範囲を取得します。

戻り値:
srtOverDlvTol 過剰納入許容範囲

getUnlimitedDlv

public String getUnlimitedDlv()
区分: 無制限過剰納入可能を取得します。

戻り値:
srtUnlimitedDlv 区分: 無制限過剰納入可能

getUnderDlvTol

public String getUnderDlvTol()
不足納入許容範囲リミットを取得します。

戻り値:
srtUnderDlvTol 不足納入許容範囲リミット

getFinalInv

public String getFinalInv()
請求書処理完了区分を取得します。

戻り値:
srtFinalInv 請求書処理完了区分

getGrInd

public String getGrInd()
入庫区分を取得します。

戻り値:
srtGrInd 入庫区分

getGrNonVal

public String getGrNonVal()
非評価入庫を取得します。

戻り値:
srtGrNonVal 非評価入庫

getIrInd

public String getIrInd()
請求書受領区分を取得します。

戻り値:
srtIrInd 請求書受領区分

getFreeItem

public String getFreeItem()
無償明細を取得します。

戻り値:
srtFreeItem 無償明細

getGrBasediv

public String getGrBasediv()
入庫基準の請求書照合区分を取得します。

戻り値:
srtGrBasediv 入庫基準の請求書照合区分

getAcknowlNo

public String getAcknowlNo()
購買発注請書番号を取得します。

戻り値:
srtAcknowlNo 購買発注請書番号

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
srtCustomer 得意先コード

getCondGroup

public String getCondGroup()
仕入先条件グループを取得します。

戻り値:
srtCondGroup 仕入先条件グループ

getNoDisct

public String getNoDisct()
現金値引対象外明細を取得します。

戻り値:
srtNoDisct 現金値引対象外明細

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
srtNetWeight 正味重量

getWeightunit

public String getWeightunit()
重量単位を取得します。

戻り値:
srtWeightunit 重量単位

getWeightunitIso

public String getWeightunitIso()
重量単位のISOコードを取得します。

戻り値:
srtWeightunitIso 重量単位のISOコード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getCtrlKey

public String getCtrlKey()
調達における品質管理の管理キーを取得します。

戻り値:
srtCtrlKey 調達における品質管理の管理キー

getConfCtrl

public String getConfCtrl()
確認管理キーを取得します。

戻り値:
srtConfCtrl 確認管理キー

getRevLev

public String getRevLev()
改訂レベルを取得します。

戻り値:
srtRevLev 改訂レベル

getFund

public String getFund()
会計区分を取得します。

戻り値:
srtFund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
srtFundsCtr 予算センタ

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
srtCmmtItem 資金予算コード

getPricedate

public String getPricedate()
価格設定日カテゴリ (価格設定日管理)を取得します。

戻り値:
srtPricedate 価格設定日カテゴリ (価格設定日管理)

getPriceDate

public String getPriceDate()
価格設定日を取得します。

戻り値:
srtPriceDate 価格設定日

getGrossWt

public String getGrossWt()
総重量を取得します。

戻り値:
srtGrossWt 総重量

getVolume

public String getVolume()
容積を取得します。

戻り値:
srtVolume 容積

getVolumeunit

public String getVolumeunit()
容積単位を取得します。

戻り値:
srtVolumeunit 容積単位

getVolumeunitIso

public String getVolumeunitIso()
ISO コードでの容積単位を取得します。

戻り値:
srtVolumeunitIso ISO コードでの容積単位

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
srtIncoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
srtIncoterms2 インコタームズ 2

getPreVendor

public String getPreVendor()
製造元/販売元を取得します。

戻り値:
srtPreVendor 製造元/販売元

getVendPart

public String getVendPart()
仕入先部門を取得します。

戻り値:
srtVendPart 仕入先部門

getHlItem

public String getHlItem()
購買伝票中の上位明細を取得します。

戻り値:
srtHlItem 購買伝票中の上位明細

getGrToDate

public String getGrToDate()
納入最終期限を取得します。

戻り値:
srtGrToDate 納入最終期限

getSuppVendor

public String getSuppVendor()
供給仕入先/仕入入庫を取得します。

戻り値:
srtSuppVendor 供給仕入先/仕入入庫

getScVendor

public String getScVendor()
外注仕入先を取得します。

戻り値:
srtScVendor 外注仕入先

getErs

public String getErs()
ERS（入庫/請求自動決済）を取得します。

戻り値:
srtErs ERS（入庫/請求自動決済）

getRPromo

public String getRPromo()
プロモーションを取得します。

戻り値:
srtRPromo プロモーション

getPoints

public String getPoints()
リベートポイント数を取得します。

戻り値:
srtPoints リベートポイント数

getPointUnit

public String getPointUnit()
ポイント単位を取得します。

戻り値:
srtPointUnit ポイント単位

getPointUnitIso

public String getPointUnitIso()
ポイント単位の ISO コードを取得します。

戻り値:
srtPointUnitIso ポイント単位の ISO コード

getSeason

public String getSeason()
季節カテゴリを取得します。

戻り値:
srtSeason 季節カテゴリ

getSeasonYr

public String getSeasonYr()
シーズン年度を取得します。

戻り値:
srtSeasonYr シーズン年度

getBonGrp2

public String getBonGrp2()
決済グループ 2 (リベート決済、購買)を取得します。

戻り値:
srtBonGrp2 決済グループ 2 (リベート決済、購買)

getBonGrp3

public String getBonGrp3()
決済グループ 3 (リベート決済、購買)を取得します。

戻り値:
srtBonGrp3 決済グループ 3 (リベート決済、購買)

getSettItem

public String getSettItem()
リベート (期末) 決済対象の明細を取得します。

戻り値:
srtSettItem リベート (期末) 決済対象の明細

getMinremlife

public String getMinremlife()
最低有効期間残を取得します。

戻り値:
srtMinremlife 最低有効期間残

getRfqNo

public String getRfqNo()
見積依頼番号を取得します。

戻り値:
srtRfqNo 見積依頼番号

getRfqItem

public String getRfqItem()
見積依頼明細番号を取得します。

戻り値:
srtRfqItem 見積依頼明細番号

getPreqNo

public String getPreqNo()
購買依頼番号を取得します。

戻り値:
srtPreqNo 購買依頼番号

getPreqItem

public String getPreqItem()
購買依頼の明細番号を取得します。

戻り値:
srtPreqItem 購買依頼の明細番号

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
srtRefDoc 参照伝票番号

getRefItem

public String getRefItem()
参照伝票の明細を取得します。

戻り値:
srtRefItem 参照伝票の明細

getSiCat

public String getSiCat()
補助明細カテゴリ、購買伝票を取得します。

戻り値:
srtSiCat 補助明細カテゴリ、購買伝票

getOrderReason

public String getOrderReason()
発注理由を取得します。

戻り値:
srtOrderReason 発注理由

getBrasNbm

public String getBrasNbm()
Brazilian NCM Codeを取得します。

戻り値:
srtBrasNbm Brazilian NCM Code

getMatlUsage

public String getMatlUsage()
品目の用途を取得します。

戻り値:
srtMatlUsage 品目の用途

getMatOrigin

public String getMatOrigin()
品目の原産地を取得します。

戻り値:
srtMatOrigin 品目の原産地

getInHouse

public String getInHouse()
内部生産を取得します。

戻り値:
srtInHouse 内部生産

getIndus3

public String getIndus3()
品目 CFOP カテゴリを取得します。

戻り値:
srtIndus3 品目 CFOP カテゴリ

getInfIndex

public String getInfIndex()
インフレーション指数を取得します。

戻り値:
srtInfIndex インフレーション指数

getUntilDate

public String getUntilDate()
インフレーション指数日付を取得します。

戻り値:
srtUntilDate インフレーション指数日付

getDelivCompl

public String getDelivCompl()
出荷完了 区分を取得します。

戻り値:
srtDelivCompl 出荷完了 区分

getPartDeliv

public String getPartDeliv()
明細レベルでの分割納入 (在庫転送)を取得します。

戻り値:
srtPartDeliv 明細レベルでの分割納入 (在庫転送)

getShipBlocked

public String getShipBlocked()
SD 出荷伝票の明細ブロックを取得します。

戻り値:
srtShipBlocked SD 出荷伝票の明細ブロック

getPeriodIndExpirationDate

public String getPeriodIndExpirationDate()
有効期間期限日の期間区分を取得します。

戻り値:
srtPeriodIndExpirationDate 有効期間期限日の期間区分

getIntObjNo

public String getIntObjNo()
選定 (内部オブジェクト番号)を取得します。

戻り値:
srtIntObjNo 選定 (内部オブジェクト番号)

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
srtBatch ロット番号

getVendrbatch

public String getVendrbatch()
仕入先ロット番号を取得します。

戻り値:
srtVendrbatch 仕入先ロット番号

getCalctype

public String getCalctype()
価格設定タイプを取得します。

戻り値:
srtCalctype 価格設定タイプ

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
srtGrantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
srtCmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getSupplStloc

public String getSupplStloc()
出庫保管場所: 在庫転送オーダーを取得します。

戻り値:
srtSupplStloc 出庫保管場所: 在庫転送オーダー

getSrvBasedIv

public String getSrvBasedIv()
サービス基準請求書照合の区分を取得します。

戻り値:
strSrvBasedIv サービス基準請求書照合の区分

getFundsRes

public String getFundsRes()
予算執行伝票の伝票番号を取得します。

戻り値:
strFundsRes 予算執行伝票の伝票番号

getResItem

public String getResItem()
用途指定予算: 伝票明細を取得します。

戻り値:
strResItem 用途指定予算: 伝票明細

getOrigAccept

public String getOrigAccept()
仕入先構内での受領を取得します。

戻り値:
strOrigAccept 仕入先構内での受領

getAllocTbl

public String getAllocTbl()
商品配分表番号を取得します。

戻り値:
strAllocTbl 商品配分表番号

getAllocTblItem

public String getAllocTblItem()
割当テーブルの明細番号を取得します。

戻り値:
strAllocTblItem 割当テーブルの明細番号

getSrcStockType

public String getSrcStockType()
在庫転送オーダーの元保管場所在庫タイプを取得します。

戻り値:
strSrcStockType 在庫転送オーダーの元保管場所在庫タイプ

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
strReasonRej 見積および受注の拒否理由

getCrmSalesOrderNo

public String getCrmSalesOrderNo()
仕入先直送発注処理の CRM 受注番号を取得します。

戻り値:
strCrmSalesOrderNo 仕入先直送発注処理の CRM 受注番号

getCrmSalesOrderItemNo

public String getCrmSalesOrderItemNo()
仕入先直送発注処理での CRM 受注明細番号を取得します。

戻り値:
strCrmSalesOrderItemNo 仕入先直送発注処理での CRM 受注明細番号

getCrmRefSalesOrderNo

public String getCrmRefSalesOrderNo()
仕入先直送発注処理の CRM 参照受注番号を取得します。

戻り値:
strCrmRefSalesOrderNo 仕入先直送発注処理の CRM 参照受注番号

getCrmRefSoItemNo

public String getCrmRefSoItemNo()
仕入先直送発注処理での CRM 参照受注明細番号を取得します。

戻り値:
strCrmRefSoItemNo 仕入先直送発注処理での CRM 参照受注明細番号

getPrioUrgency

public String getPrioUrgency()
所要量の緊急度を取得します。

戻り値:
strPrioUrgency 所要量の緊急度

getPrioRequirement

public String getPrioRequirement()
所要量の優先順位を取得します。

戻り値:
strPrioRequirement 所要量の優先順位

getReasonCode

public String getReasonCode()
Goods Receipt Reason Codeを取得します。

戻り値:
strReasonCode Goods Receipt Reason Code

getGlIndex

public int getGlIndex()
レコード番号を設定します｡

戻り値:
glIndex レコード番号

setEmaterial

public void setEmaterial(String strEmaterial)
品目コードを設定します。

パラメータ:
strEmaterial - 品目コード

setEmaterialExternal

public void setEmaterialExternal(String strEmaterialExternal)
品目コード（長）を設定します。

パラメータ:
strEmaterialExternal - 品目コード（長）

setEmaterialGuid

public void setEmaterialGuid(String strEmaterialGuid)
品目コードの外部GUIDを設定します。

パラメータ:
strEmaterialGuid - 品目コードの外部GUID

setEmaterialVersion

public void setEmaterialVersion(String strEmaterialVersion)
品目コードのバージョン番号を設定します。

パラメータ:
strEmaterialVersion - 品目コードのバージョン番号

setStgeLoc

public void setStgeLoc(String strStgeLoc)
保管場所を設定します。

パラメータ:
strStgeLoc - 保管場所

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setQuantity

public void setQuantity(String strQuantity)
購買発注数量を設定します。

パラメータ:
strQuantity - 購買発注数量

setPoUnit

public void setPoUnit(String strPoUnit)
発注単位を設定します。

パラメータ:
strPoUnit - 発注単位

setGrPrTime

public void setGrPrTime(String strGrPrTime)
入庫処理日数を設定します。

パラメータ:
strGrPrTime - 入庫処理日数

setBonGrp1

public void setBonGrp1(String strBonGrp1)
決済グループ1を設定します。

パラメータ:
strBonGrp1 - 決済グループ1

setInfoUpd

public void setInfoUpd(String strInfoUpd)
購買情報更新区分を設定します。

パラメータ:
strInfoUpd - 購買情報更新区分

setPrntPrice

public void setPrntPrice(String strPrntPrice)
価格印刷を設定します。

パラメータ:
strPrntPrice - 価格印刷

setEstPrice

public void setEstPrice(String strEstPrice)
概算価格区分を設定します。

パラメータ:
strEstPrice - 概算価格区分

setReminder1

public void setReminder1(String strReminder1)
第一回催促状/督促状の日数を設定します。

パラメータ:
strReminder1 - 第一回催促状/督促状の日数

setReminder2

public void setReminder2(String strReminder2)
第二回催促状/督促状の日数を設定します。

パラメータ:
strReminder2 - 第二回催促状/督促状の日数

setReminder3

public void setReminder3(String strReminder3)
第三回催促状/督促状の日数を設定します。

パラメータ:
strReminder3 - 第三回催促状/督促状の日数

setOverDlvTol

public void setOverDlvTol(String strOverDlvTol)
過剰納入許容範囲を設定します。

パラメータ:
strOverDlvTol - 過剰納入許容範囲

setUnlimitedDlv

public void setUnlimitedDlv(String strUnlimitedDlv)
区分: 無制限過剰納入可能を設定します。

パラメータ:
strUnlimitedDlv - 区分: 無制限過剰納入可能

setUnderDlvTol

public void setUnderDlvTol(String strUnderDlvTol)
不足納入許容範囲リミットを設定します。

パラメータ:
strUnderDlvTol - 不足納入許容範囲リミット

setFinalInv

public void setFinalInv(String strFinalInv)
請求書処理完了区分を設定します。

パラメータ:
strFinalInv - 請求書処理完了区分

setGrInd

public void setGrInd(String strGrInd)
入庫区分を設定します。

パラメータ:
strGrInd - 入庫区分

setGrNonVal

public void setGrNonVal(String strGrNonVal)
非評価入庫を設定します。

パラメータ:
strGrNonVal - 非評価入庫

setIrInd

public void setIrInd(String strIrInd)
請求書受領区分を設定します。

パラメータ:
strIrInd - 請求書受領区分

setFreeItem

public void setFreeItem(String strFreeItem)
無償明細を設定します。

パラメータ:
strFreeItem - 無償明細

setGrBasediv

public void setGrBasediv(String strGrBasediv)
入庫基準の請求書照合区分を設定します。

パラメータ:
strGrBasediv - 入庫基準の請求書照合区分

setAcknowlNo

public void setAcknowlNo(String strAcknowlNo)
購買発注請書番号を設定します。

パラメータ:
strAcknowlNo - 購買発注請書番号

setCustomer

public void setCustomer(String strCustomer)
得意先コードを設定します。

パラメータ:
strCustomer - 得意先コード

setCondGroup

public void setCondGroup(String strCondGroup)
仕入先条件グループを設定します。

パラメータ:
strCondGroup - 仕入先条件グループ

setNoDisct

public void setNoDisct(String strNoDisct)
現金値引対象外明細を設定します。

パラメータ:
strNoDisct - 現金値引対象外明細

setNetWeight

public void setNetWeight(String strNetWeight)
正味重量を設定します。

パラメータ:
strNetWeight - 正味重量

setWeightunit

public void setWeightunit(String strWeightunit)
重量単位を設定します。

パラメータ:
strWeightunit - 重量単位

setWeightunitIso

public void setWeightunitIso(String strWeightunitIso)
重量単位のISOコードを設定します。

パラメータ:
strWeightunitIso - 重量単位のISOコード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setCtrlKey

public void setCtrlKey(String strCtrlKey)
調達における品質管理の管理キーを設定します。

パラメータ:
strCtrlKey - 調達における品質管理の管理キー

setConfCtrl

public void setConfCtrl(String strConfCtrl)
確認管理キーを設定します。

パラメータ:
strConfCtrl - 確認管理キー

setRevLev

public void setRevLev(String strRevLev)
改訂レベルを設定します。

パラメータ:
strRevLev - 改訂レベル

setFund

public void setFund(String strFund)
会計区分を設定します。

パラメータ:
strFund - 会計区分

setFundsCtr

public void setFundsCtr(String strFundsCtr)
予算センタを設定します。

パラメータ:
strFundsCtr - 予算センタ

setCmmtItem

public void setCmmtItem(String strCmmtItem)
資金予算コードを設定します。

パラメータ:
strCmmtItem - 資金予算コード

setPricedate

public void setPricedate(String strPricedate)
価格設定日カテゴリ (価格設定日管理)を設定します。

パラメータ:
strPricedate - 価格設定日カテゴリ (価格設定日管理)

setPriceDate

public void setPriceDate(String strPriceDate)
価格設定日を設定します。

パラメータ:
strPriceDate - 価格設定日

setGrossWt

public void setGrossWt(String strGrossWt)
総重量を設定します。

パラメータ:
strGrossWt - 総重量

setVolume

public void setVolume(String strVolume)
容積を設定します。

パラメータ:
strVolume - 容積

setVolumeunit

public void setVolumeunit(String strVolumeunit)
容積単位を設定します。

パラメータ:
strVolumeunit - 容積単位

setVolumeunitIso

public void setVolumeunitIso(String strVolumeunitIso)
ISO コードでの容積単位を設定します。

パラメータ:
strVolumeunitIso - ISO コードでの容積単位

setIncoterms1

public void setIncoterms1(String strIncoterms1)
インコタームズ (1)を設定します。

パラメータ:
strIncoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String strIncoterms2)
インコタームズ 2を設定します。

パラメータ:
strIncoterms2 - インコタームズ 2

setPreVendor

public void setPreVendor(String strPreVendor)
製造元/販売元を設定します。

パラメータ:
strPreVendor - 製造元/販売元

setVendPart

public void setVendPart(String strVendPart)
仕入先部門を設定します。

パラメータ:
strVendPart - 仕入先部門

setHlItem

public void setHlItem(String strHlItem)
購買伝票中の上位明細を設定します。

パラメータ:
strHlItem - 購買伝票中の上位明細

setGrToDate

public void setGrToDate(String strGrToDate)
納入最終期限を設定します。

パラメータ:
strGrToDate - 納入最終期限

setSuppVendor

public void setSuppVendor(String strSuppVendor)
供給仕入先/仕入入庫を設定します。

パラメータ:
strSuppVendor - 供給仕入先/仕入入庫

setScVendor

public void setScVendor(String strScVendor)
外注仕入先を設定します。

パラメータ:
strScVendor - 外注仕入先

setErs

public void setErs(String strErs)
ERS（入庫/請求自動決済）を設定します。

パラメータ:
strErs - ERS（入庫/請求自動決済）

setRPromo

public void setRPromo(String strRPromo)
プロモーションを設定します。

パラメータ:
strRPromo - プロモーション

setPoints

public void setPoints(String strPoints)
リベートポイント数を設定します。

パラメータ:
strPoints - リベートポイント数

setPointUnit

public void setPointUnit(String strPointUnit)
ポイント単位を設定します。

パラメータ:
strPointUnit - ポイント単位

setPointUnitIso

public void setPointUnitIso(String strPointUnitIso)
ポイント単位の ISO コードを設定します。

パラメータ:
strPointUnitIso - ポイント単位の ISO コード

setSeason

public void setSeason(String strSeason)
季節カテゴリを設定します。

パラメータ:
strSeason - 季節カテゴリ

setSeasonYr

public void setSeasonYr(String strSeasonYr)
シーズン年度を設定します。

パラメータ:
strSeasonYr - シーズン年度

setBonGrp2

public void setBonGrp2(String strBonGrp2)
決済グループ 2 (リベート決済、購買)を設定します。

パラメータ:
strBonGrp2 - 決済グループ 2 (リベート決済、購買)

setBonGrp3

public void setBonGrp3(String strBonGrp3)
決済グループ 3 (リベート決済、購買)を設定します。

パラメータ:
strBonGrp3 - 決済グループ 3 (リベート決済、購買)

setSettItem

public void setSettItem(String strSettItem)
リベート (期末) 決済対象の明細を設定します。

パラメータ:
strSettItem - リベート (期末) 決済対象の明細

setMinremlife

public void setMinremlife(String strMinremlife)
最低有効期間残を設定します。

パラメータ:
strMinremlife - 最低有効期間残

setRfqNo

public void setRfqNo(String strRfqNo)
見積依頼番号を設定します。

パラメータ:
strRfqNo - 見積依頼番号

setRfqItem

public void setRfqItem(String strRfqItem)
見積依頼明細番号を設定します。

パラメータ:
strRfqItem - 見積依頼明細番号

setPreqNo

public void setPreqNo(String strPreqNo)
購買依頼番号を設定します。

パラメータ:
strPreqNo - 購買依頼番号

setPreqItem

public void setPreqItem(String strPreqItem)
購買依頼の明細番号を設定します。

パラメータ:
strPreqItem - 購買依頼の明細番号

setRefDoc

public void setRefDoc(String strRefDoc)
参照伝票番号を設定します。

パラメータ:
strRefDoc - 参照伝票番号

setRefItem

public void setRefItem(String strRefItem)
参照伝票の明細を設定します。

パラメータ:
strRefItem - 参照伝票の明細

setSiCat

public void setSiCat(String strSiCat)
補助明細カテゴリ、購買伝票を設定します。

パラメータ:
strSiCat - 補助明細カテゴリ、購買伝票

setOrderReason

public void setOrderReason(String strOrderReason)
発注理由を設定します。

パラメータ:
strOrderReason - 発注理由

setBrasNbm

public void setBrasNbm(String strBrasNbm)
Brazilian NCM Codeを設定します。

パラメータ:
strBrasNbm - Brazilian NCM Code

setMatlUsage

public void setMatlUsage(String strMatlUsage)
品目の用途を設定します。

パラメータ:
strMatlUsage - 品目の用途

setMatOrigin

public void setMatOrigin(String strMatOrigin)
品目の原産地を設定します。

パラメータ:
strMatOrigin - 品目の原産地

setInHouse

public void setInHouse(String strInHouse)
内部生産を設定します。

パラメータ:
strInHouse - 内部生産

setIndus3

public void setIndus3(String strIndus3)
品目 CFOP カテゴリを設定します。

パラメータ:
strIndus3 - 品目 CFOP カテゴリ

setInfIndex

public void setInfIndex(String strInfIndex)
インフレーション指数を設定します。

パラメータ:
strInfIndex - インフレーション指数

setUntilDate

public void setUntilDate(String strUntilDate)
インフレーション指数日付を設定します。

パラメータ:
strUntilDate - インフレーション指数日付

setDelivCompl

public void setDelivCompl(String strDelivCompl)
出荷完了 区分を設定します。

パラメータ:
strDelivCompl - 出荷完了 区分

setPartDeliv

public void setPartDeliv(String strPartDeliv)
明細レベルでの分割納入 (在庫転送)を設定します。

パラメータ:
strPartDeliv - 明細レベルでの分割納入 (在庫転送)

setShipBlocked

public void setShipBlocked(String strShipBlocked)
SD 出荷伝票の明細ブロックを設定します。

パラメータ:
strShipBlocked - SD 出荷伝票の明細ブロック

setPeriodIndExpirationDate

public void setPeriodIndExpirationDate(String strPeriodIndExpirationDate)
有効期間期限日の期間区分を設定します。

パラメータ:
strPeriodIndExpirationDate - 有効期間期限日の期間区分

setIntObjNo

public void setIntObjNo(String strIntObjNo)
選定 (内部オブジェクト番号)を設定します。

パラメータ:
strIntObjNo - 選定 (内部オブジェクト番号)

setBatch

public void setBatch(String strBatch)
ロット番号を設定します。

パラメータ:
strBatch - ロット番号

setVendrbatch

public void setVendrbatch(String strVendrbatch)
仕入先ロット番号を設定します。

パラメータ:
strVendrbatch - 仕入先ロット番号

setCalctype

public void setCalctype(String strCalctype)
価格設定タイプを設定します。

パラメータ:
strCalctype - 価格設定タイプ

setGrantNbr

public void setGrantNbr(String strGrantNbr)
補助金を設定します。

パラメータ:
strGrantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String strCmmtItemLong)
資金予算コードを設定します。

パラメータ:
strCmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setSupplStloc

public void setSupplStloc(String strSupplStloc)
出庫保管場所: 在庫転送オーダーを設定します。

パラメータ:
strSupplStloc - 出庫保管場所: 在庫転送オーダー

setSrvBasedIv

public void setSrvBasedIv(String strSrvBasedIv)
サービス基準請求書照合の区分を設定します。

パラメータ:
strSrvBasedIv - サービス基準請求書照合の区分

setFundsRes

public void setFundsRes(String strFundsRes)
予算執行伝票の伝票番号を設定します。

パラメータ:
strFundsRes - 予算執行伝票の伝票番号

setResItem

public void setResItem(String strResItem)
用途指定予算: 伝票明細を設定します。

パラメータ:
strResItem - 用途指定予算: 伝票明細

setOrigAccept

public void setOrigAccept(String strOrigAccept)
仕入先構内での受領を設定します。

パラメータ:
strOrigAccept - 仕入先構内での受領

setAllocTbl

public void setAllocTbl(String strAllocTbl)
商品配分表番号を設定します。

パラメータ:
strAllocTbl - 商品配分表番号

setAllocTblItem

public void setAllocTblItem(String strAllocTblItem)
割当テーブルの明細番号を設定します。

パラメータ:
strAllocTblItem - 割当テーブルの明細番号

setSrcStockType

public void setSrcStockType(String strSrcStockType)
在庫転送オーダーの元保管場所在庫タイプを設定します。

パラメータ:
strSrcStockType - 在庫転送オーダーの元保管場所在庫タイプ

setReasonRej

public void setReasonRej(String strReasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
strReasonRej - 見積および受注の拒否理由

setCrmSalesOrderNo

public void setCrmSalesOrderNo(String strCrmSalesOrderNo)
仕入先直送発注処理の CRM 受注番号を設定します。

パラメータ:
strCrmSalesOrderNo - 仕入先直送発注処理の CRM 受注番号

setCrmSalesOrderItemNo

public void setCrmSalesOrderItemNo(String strCrmSalesOrderItemNo)
仕入先直送発注処理での CRM 受注明細番号を設定します。

パラメータ:
strCrmSalesOrderItemNo - 仕入先直送発注処理での CRM 受注明細番号

setCrmRefSalesOrderNo

public void setCrmRefSalesOrderNo(String strCrmRefSalesOrderNo)
仕入先直送発注処理の CRM 参照受注番号を設定します。

パラメータ:
strCrmRefSalesOrderNo - 仕入先直送発注処理の CRM 参照受注番号

setCrmRefSoItemNo

public void setCrmRefSoItemNo(String strCrmRefSoItemNo)
仕入先直送発注処理での CRM 参照受注明細番号を設定します。

パラメータ:
strCrmRefSoItemNo - 仕入先直送発注処理での CRM 参照受注明細番号

setPrioUrgency

public void setPrioUrgency(String strPrioUrgency)
所要量の緊急度を設定します。

パラメータ:
strPrioUrgency - 所要量の緊急度

setPrioRequirement

public void setPrioRequirement(String strPrioRequirement)
所要量の優先順位を設定します。

パラメータ:
strPrioRequirement - 所要量の優先順位

setReasonCode

public void setReasonCode(String strReasonCode)
Goods Receipt Reason Codeを設定します。

パラメータ:
strReasonCode - Goods Receipt Reason Code

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseItem 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItems (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems
すべての実装インタフェース:
Serializable
public class PurchaseItems
extends PurchaseItem
implements Serializable

伝票の承認対象明細情報クラス
機能は以下の通り

  • 伝票の承認対象明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItems()
伝票の承認対象明細を作成します。
メソッドの概要
String | getAcknowlNo() 購買発注請書番号を取得します。
String | getAddress() 住所を取得します。
String | getAllocTbl() 商品配分表番号を取得します。
String | getAtItem() 割当テーブルの明細番号を取得します。
String | getDispQuan() 購買発注数量: 表示目的全納入日程合計を取得します。
String | getItemCatExt() 購買伝票の明細カテゴリを取得します。
String | getManufProf() 製造者製品プロファイルを取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMatGrp() 品目グループを取得します。
String | getMfrNo() 製造者番号を取得します。
String | getMfrNoExt() 外部製造者コード名または番号を取得します。
String | getPoNumber() 購買伝票番号を取得します。
String | getPrClosed() 購買依頼処理済を取得します。
String | getPromotion() プロモーションを取得します。
String | getPurMat() 品目コードを取得します。
String | getPurMatExternal() 項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPurMatGuid() 項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPurMatVersion() 項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getUnit() 発注単位を取得します。
void | setAcknowlNo(String strAcknowlNo) 購買発注請書番号を設定します。
void | setAddress(String strAddress) 住所を設定します。
void | setAllocTbl(String strAllocTbl) 商品配分表番号を設定します。
void | setAtItem(String strAtItem) 割当テーブルの明細番号を設定します。
void | setDispQuan(String strDispQuan) 購買発注数量: 表示目的全納入日程合計を設定します。
void | setItemCatExt(String strItemCatExt) 購買伝票の明細カテゴリを設定します。
void | setManufProf(String strManufProf) 製造者製品プロファイルを設定します。
void | setManuMat(String strManuMat) 製造者製品コードを設定します。
void | setMatGrp(String strMatGrp) 品目グループを設定します。
void | setMfrNo(String strMfrNo) 製造者番号を設定します。
void | setMfrNoExt(String strMfrNoExt) 外部製造者コード名または番号を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setPrClosed(String strPrClosed) 購買依頼処理済を設定します。
void | setPromotion(String strPromotion) プロモーションを設定します。
void | setPurMat(String strPurMat) 品目コードを設定します。
void | setPurMatExternal(String strPurMatExternal) 項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPurMatGuid(String strPurMatGuid) 項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPurMatVersion(String strPurMatVersion) 項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setStoreLoc(String strStoreLoc) 保管場所を設定します。
void | setUnit(String strUnit) 発注単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem から継承したメソッド
getAcctasscat, getAcknReqd, getAgmtItem, getAgreement, getAtRelev, getConvDen1, getConvNum1, getDeleteInd, getDistrib, getInfoRec, getItemCat, getKanbanInd, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getNetPrice, getNoMoreGr, getNoRounding, getOrderprUn, getOrderprUnIso, getPartInv, getPckgNo, getPlanDel, getPlant, getPoItem, getPoPrice, getPoUnitIso, getPreqName, getPriceUnit, getQualInsp, getRetItem, getShipping, getShortText, getTaxCode, getTrackingno, getValType, getVendMat, setAcctasscat, setAcknReqd, setAgmtItem, setAgreement, setAtRelev, setConvDen1, setConvNum1, setDeleteInd, setDistrib, setInfoRec, setItemCat, setKanbanInd, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setNetPrice, setNoMoreGr, setNoRounding, setOrderprUn, setOrderprUnIso, setPartInv, setPckgNo, setPlanDel, setPlant, setPoItem, setPoPrice, setPoUnitIso, setPreqName, setPriceUnit, setQualInsp, setRetItem, setShipping, setShortText, setTaxCode, setTrackingno, setValType, setVendMat
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItems

public PurchaseItems()
伝票の承認対象明細を作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber

getAddress

public String getAddress()
住所を取得します。

戻り値:
srtAddress

getPurMat

public String getPurMat()
品目コードを取得します。

戻り値:
srtPurMat

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
srtStoreLoc

getMatGrp

public String getMatGrp()
品目グループを取得します。

戻り値:
srtMatGrp

getAllocTbl

public String getAllocTbl()
商品配分表番号を取得します。

戻り値:
srtAllocTbl

getAtItem

public String getAtItem()
割当テーブルの明細番号を取得します。

戻り値:
srtAtItem

getUnit

public String getUnit()
発注単位を取得します。

戻り値:
srtUnit

getPromotion

public String getPromotion()
プロモーションを取得します。

戻り値:
srtPromotion

getManufProf

public String getManufProf()
製造者製品プロファイルを取得します。

戻り値:
srtManufProf

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
srtManuMat

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
srtMfrNo

getMfrNoExt

public String getMfrNoExt()
外部製造者コード名または番号を取得します。

戻り値:
srtMfrNoExt

getItemCatExt

public String getItemCatExt()
購買伝票の明細カテゴリを取得します。

戻り値:
srtItemCatExt

getDispQuan

public String getDispQuan()
購買発注数量: 表示目的全納入日程合計を取得します。

戻り値:
srtDispQuan

getPurMatExternal

public String getPurMatExternal()
項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
srtPurMatExternal

getPurMatGuid

public String getPurMatGuid()
項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
srtPurMatGuid

getPurMatVersion

public String getPurMatVersion()
項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
srtPurMatVersion

getPrClosed

public String getPrClosed()
購買依頼処理済を取得します。

戻り値:
srtPrClosed

getAcknowlNo

public String getAcknowlNo()
購買発注請書番号を取得します。

戻り値:
strAcknowlNo

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setAddress

public void setAddress(String strAddress)
住所を設定します。

パラメータ:
strAddress - 住所

setPurMat

public void setPurMat(String strPurMat)
品目コードを設定します。

パラメータ:
strPurMat - 品目コード

setStoreLoc

public void setStoreLoc(String strStoreLoc)
保管場所を設定します。

パラメータ:
strStoreLoc - 保管場所

setMatGrp

public void setMatGrp(String strMatGrp)
品目グループを設定します。

パラメータ:
strMatGrp - 品目グループ

setAllocTbl

public void setAllocTbl(String strAllocTbl)
商品配分表番号を設定します。

パラメータ:
strAllocTbl - 商品配分表番号

setAtItem

public void setAtItem(String strAtItem)
割当テーブルの明細番号を設定します。

パラメータ:
strAtItem - 割当テーブルの明細番号

setUnit

public void setUnit(String strUnit)
発注単位を設定します。

パラメータ:
strUnit - 発注単位

setPromotion

public void setPromotion(String strPromotion)
プロモーションを設定します。

パラメータ:
strPromotion - プロモーション

setManufProf

public void setManufProf(String strManufProf)
製造者製品プロファイルを設定します。

パラメータ:
strManufProf - 製造者製品プロファイル

setManuMat

public void setManuMat(String strManuMat)
製造者製品コードを設定します。

パラメータ:
strManuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String strMfrNo)
製造者番号を設定します。

パラメータ:
strMfrNo - 製造者番号

setMfrNoExt

public void setMfrNoExt(String strMfrNoExt)
外部製造者コード名または番号を設定します。

パラメータ:
strMfrNoExt - 外部製造者コード名または番号

setItemCatExt

public void setItemCatExt(String strItemCatExt)
購買伝票の明細カテゴリを設定します。

パラメータ:
strItemCatExt - 購買伝票の明細カテゴリ

setDispQuan

public void setDispQuan(String strDispQuan)
購買発注数量: 表示目的全納入日程合計を設定します。

パラメータ:
strDispQuan - 購買発注数量: 表示目的全納入日程合計

setPurMatExternal

public void setPurMatExternal(String strPurMatExternal)
項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
strPurMatExternal - 項目 PURMAT の品目コード (長)

setPurMatGuid

public void setPurMatGuid(String strPurMatGuid)
項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
strPurMatGuid - 項目 PURMAT の外部 GUID

setPurMatVersion

public void setPurMatVersion(String strPurMatVersion)
項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
strPurMatVersion - 項目 PURMAT のバージョン番号

setPrClosed

public void setPrClosed(String strPrClosed)
購買依頼処理済を設定します。

パラメータ:
strPrClosed - 購買依頼処理済

setAcknowlNo

public void setAcknowlNo(String strAcknowlNo)
購買発注請書番号を設定します。

パラメータ:
strAcknowlNo - 購買発注請書番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseItem 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPayPost (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPayPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseOrderPayPostController, PurchaseOrderPostChangeController
public class PurchaseOrderPayPost
extends UpdateController
implements Serializable

伝票登録クラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPayPost()
コンストラクタ。
PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
void | executeBapi(BapiController bapiController) 購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
ArrayList | getAllVersionsList() 全バージョン一覧を取得します｡
ArrayList | getCondHeaderList() 条件ヘッダ一覧を取得します｡
ArrayList | getCondItemList() 条件明細一覧を取得します｡
ArrayList | getContractLimitsList() 外注基本契約制限一覧を取得します｡
ArrayList | getContractServiceAccountList() 外注サービス勘定設定一覧を取得します｡
ArrayList | getContractServiceList() 外注サービス一覧を取得します｡
ArrayList | getContractServiceTextList() 外注サービステキスト一覧を取得します｡
ArrayList | getDeliverryAddressList() 出荷伝票アドレス一覧を取得します｡
PurchaseHeaderPost | getDocumentHeader() 伝票ヘッダを取得します｡
ExportHeader | getExportHeader() 貿易管理ヘッダを取得します｡
ArrayList | getExportItemList() 貿易管理明細一覧を取得します｡
ArrayList | getExtensionList() 拡張得意先項目一覧を取得します｡
ArrayList | getHeaderTextList() ヘッダテキスト一覧を取得します｡
ArrayList | getItemTextList() 明細テキスト一覧を取得します｡
ArrayList | getLimitsList() 外注制限一覧を取得します｡
String | getMemoryComplete() エラーがない場合に購買発注を保留にする区分を取得します｡
String | getMemoryUnComplete() エラーがある場合に購買発注を保留にする区分を取得します｡
String | getNoAuthority() 権限チェックなし区分を取得します｡
String | getNoMessageReq() メッセージ不要区分を取得します｡
String | getNoMessaging() 出力決定なし区分を取得します｡
String | getNoPriceFromPo() 最終伝票からの価格転送なし区分を取得します｡
ArrayList | getPartnerList() 得意先一覧を取得します｡
String | getPoNumber() 購買伝票番号を取得します｡
ArrayList | getProfitSegmentList() 入出庫予定一覧を取得します｡
ArrayList | getPurchaseAccountList() 勘定設定一覧を取得します｡
ArrayList | getPurchaseComponentsList() コンポーネント一覧を取得します｡
ArrayList | getPurchaseConfirmationList() 転送構造：照会／一覧一覧を取得します｡
ArrayList | getPurchaseHistoryList() 購買発注履歴を取得します｡
ArrayList | getPurchaseHistoryTotalsList() 購買発注履歴(合計)を取得します｡
ArrayList | getPurchaseItemPostList() 明細一覧を取得します｡
ArrayList | getPurchaseScheduleList() 納入日程一覧を取得します｡
ArrayList | getPurchaseShippingExpList() 出荷データエクスポート一覧を取得します｡
ArrayList | getPurchaseShippingList() 出荷データ一覧を取得します｡
VendorAddress | getSupplierInfo() 仕入先住所を取得します｡
String | getTestRun() テスト区分を取得します｡
Versions | getVersions() バージョン管理を取得します｡
void | setAllVersionsList(ArrayList allVersionsList) 全バージョン一覧を設定します｡
void | setCondHeaderList(ArrayList condHeaderList) 条件ヘッダ一覧を設定します｡
void | setCondItemList(ArrayList condItemList) 条件明細一覧を設定します｡
void | setContractLimitsList(ArrayList contractLimitsList) 外注基本契約制限一覧を設定します｡
void | setContractServiceAccountList(ArrayList contractServiceAccountList) 外注サービス勘定設定一覧を設定します｡
void | setContractServiceList(ArrayList contractServiceList) 外注サービス一覧を設定します｡
void | setContractServiceTextList(ArrayList contractServiceTextList) 外注サービステキスト一覧を設定します｡
void | setDeliveryAddressList(ArrayList deliveryAddressList) 入荷伝票アドレス一覧を設定します｡
void | setDocumentHeader(PurchaseHeaderPost documentHeader) 伝票ヘッダを設定します｡
void | setExportHeader(ExportHeader exportHeader) 貿易管理ヘッダを設定します｡
void | setExportItemList(ArrayList exportItemList) 貿易管理明細を設定します｡
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setExtensionList(ArrayList extensionList) 拡張得意先項目を設定します｡
void | setHeaderTextList(ArrayList headerTextList) ヘッダテキスト一覧を設定します｡
void | setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | setItemTextList(ArrayList itemTextList) 明細テキスト一覧を設定します｡
void | setLimitsList(ArrayList limitsList) 外注制限一覧を設定します｡
void | setMemoryComplete(String memoryComplete) エラーがない場合に購買発注を保留する区分を設定します｡
void | setMemoryUnComplete(String memoryUnComplete) エラーがある場合に購買発注を保留する区分を設定します｡
void | setNoAuthority(String noAuthority) 権限チェックなし区分に購買発注を保留する区分を設定します｡
void | setNoMessage(String noMessaging) 出力決定なし区分に購買発注を保留する区分を設定します｡
void | setNoMessageReq(String noMessageReq) メッセージ不要区分を設定します｡
void | setNoPriceFromPo(String noPriceFromPo) 最終伝票からの価格転送なし区分を設定します｡
void | setPartnerList(ArrayList partnerList) 取引先一覧を設定します｡
void | setPoNumber(String poNumber) 購買伝票番号に値を設定します。
void | setProfitSegmentList(ArrayList profitSegmentList) 入出庫予定一覧を設定します｡
void | setPurchaseAccountList(ArrayList purchaseAccountList) 勘定設定一覧を設定します｡
void | setPurchaseComponentsList(ArrayList purchaseComponentsList) コンポーネント一覧を設定します｡
void | setPurchaseConfirmationList(ArrayList purchaseConfirmationList) 転送構造：照会／一覧一覧を設定します｡
void | setPurchaseHistory(ArrayList purchaseHistoryList) 購買発注履歴を設定します｡
void | setPurchaseHistorysTotal(ArrayList purchaseHistoryTotalsList) 購買発注履歴(合計)を設定します｡
void | setPurchaseItemPostList(ArrayList purchaseItemPostList) 明細一覧を設定します｡
void | setPurchaseScheduleList(ArrayList purchaseScheduleList) 納入日程一覧を設定します｡
void | setPurchaseShippingExpList(ArrayList purchaseShippingExpList) 出荷データエクスポート一覧を設定します｡
void | setPurchaseShippingList(ArrayList purchaseShippingList) 出荷データ一覧を設定します｡
void | setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | setSupplierInfo(VendorAddress supplierInfo) 仕入先住所を設定します｡
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setTestRun(String testRun) テスト区分を設定します｡
void | setVersions(Versions versions) バージョン管理ヘッダを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPayPost

public PurchaseOrderPayPost()
コンストラクタ。

PurchaseOrderPayPost

public PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

PurchaseOrderPayPost

public PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setPoNumber

public void setPoNumber(String poNumber)
購買伝票番号に値を設定します。

パラメータ:
poNumber - 購買伝票番号

setTestRun

public void setTestRun(String testRun)
テスト区分を設定します｡

パラメータ:
testRun - テスト区分

setMemoryUnComplete

public void setMemoryUnComplete(String memoryUnComplete)
エラーがある場合に購買発注を保留する区分を設定します｡

パラメータ:
memoryUnComplete - エラーがある場合に購買発注を保留する区分

setMemoryComplete

public void setMemoryComplete(String memoryComplete)
エラーがない場合に購買発注を保留する区分を設定します｡

パラメータ:
memoryComplete - エラーがない場合に購買発注を保留する区分

setNoMessage

public void setNoMessage(String noMessaging)
出力決定なし区分に購買発注を保留する区分を設定します｡

パラメータ:
noMessaging - 出力決定なし区分

setNoMessageReq

public void setNoMessageReq(String noMessageReq)
メッセージ不要区分を設定します｡

パラメータ:
noMessageReq - メッセージ不要区分

setNoAuthority

public void setNoAuthority(String noAuthority)
権限チェックなし区分に購買発注を保留する区分を設定します｡

パラメータ:
noAuthority - 権限チェックなし区分

setNoPriceFromPo

public void setNoPriceFromPo(String noPriceFromPo)
最終伝票からの価格転送なし区分を設定します｡

パラメータ:
noPriceFromPo - 最終伝票からの価格転送なし区分

setDocumentHeader

public void setDocumentHeader(PurchaseHeaderPost documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setSupplierInfo

public void setSupplierInfo(VendorAddress supplierInfo)
仕入先住所を設定します｡

パラメータ:
supplierInfo - 仕入先住所

setExportHeader

public void setExportHeader(ExportHeader exportHeader)
貿易管理ヘッダを設定します｡

パラメータ:
exportHeader - 貿易管理ヘッダ

setVersions

public void setVersions(Versions versions)
バージョン管理ヘッダを設定します｡

パラメータ:
versions - バージョン管理ヘッダ

setPurchaseItemPostList

public void setPurchaseItemPostList(ArrayList purchaseItemPostList)
明細一覧を設定します｡

パラメータ:
purchaseItemPostList - 明細一覧

setDeliveryAddressList

public void setDeliveryAddressList(ArrayList deliveryAddressList)
入荷伝票アドレス一覧を設定します｡

パラメータ:
deliveryAddressList - 入荷伝票アドレス一覧

setPurchaseScheduleList

public void setPurchaseScheduleList(ArrayList purchaseScheduleList)
納入日程一覧を設定します｡

パラメータ:
purchaseScheduleList - 納入日程一覧

setProfitSegmentList

public void setProfitSegmentList(ArrayList profitSegmentList)
入出庫予定一覧を設定します｡

パラメータ:
profitSegmentList - 入出庫予定一覧

setPurchaseAccountList

public void setPurchaseAccountList(ArrayList purchaseAccountList)
勘定設定一覧を設定します｡

パラメータ:
purchaseAccountList - 勘定設定一覧

setCondHeaderList

public void setCondHeaderList(ArrayList condHeaderList)
条件ヘッダ一覧を設定します｡

パラメータ:
condHeaderList - 条件ヘッダ一覧

setCondItemList

public void setCondItemList(ArrayList condItemList)
条件明細一覧を設定します｡

パラメータ:
condItemList - 条件明細一覧

setLimitsList

public void setLimitsList(ArrayList limitsList)
外注制限一覧を設定します｡

パラメータ:
limitsList - 外注制限一覧

setContractLimitsList

public void setContractLimitsList(ArrayList contractLimitsList)
外注基本契約制限一覧を設定します｡

パラメータ:
contractLimitsList - 外注基本契約制限一覧

setContractServiceList

public void setContractServiceList(ArrayList contractServiceList)
外注サービス一覧を設定します｡

パラメータ:
contractServiceList - 外注サービス一覧

setContractServiceAccountList

public void setContractServiceAccountList(ArrayList contractServiceAccountList)
外注サービス勘定設定一覧を設定します｡

パラメータ:
contractServiceAccountList - 外注サービス勘定設定一覧

setContractServiceTextList

public void setContractServiceTextList(ArrayList contractServiceTextList)
外注サービステキスト一覧を設定します｡

パラメータ:
contractServiceTextList - 外注サービステキスト一覧

setExtensionList

public void setExtensionList(ArrayList extensionList)
拡張得意先項目を設定します｡

パラメータ:
extensionList - 拡張得意先項目

setExportItemList

public void setExportItemList(ArrayList exportItemList)
貿易管理明細を設定します｡

パラメータ:
exportItemList - 貿易管理明細

setHeaderTextList

public void setHeaderTextList(ArrayList headerTextList)
ヘッダテキスト一覧を設定します｡

パラメータ:
headerTextList - ヘッダテキスト一覧

setItemTextList

public void setItemTextList(ArrayList itemTextList)
明細テキスト一覧を設定します｡

パラメータ:
itemTextList - 明細テキスト一覧

setPartnerList

public void setPartnerList(ArrayList partnerList)
取引先一覧を設定します｡

パラメータ:
partnerList - 取引先一覧

setAllVersionsList

public void setAllVersionsList(ArrayList allVersionsList)
全バージョン一覧を設定します｡

パラメータ:
allVersionsList - 全バージョン一覧

setPurchaseShippingList

public void setPurchaseShippingList(ArrayList purchaseShippingList)
出荷データ一覧を設定します｡

パラメータ:
purchaseShippingList - 出荷データ一覧

setPurchaseShippingExpList

public void setPurchaseShippingExpList(ArrayList purchaseShippingExpList)
出荷データエクスポート一覧を設定します｡

パラメータ:
purchaseShippingExpList - 出荷データ変更ツールバー一覧

setPurchaseComponentsList

public void setPurchaseComponentsList(ArrayList purchaseComponentsList)
コンポーネント一覧を設定します｡

パラメータ:
purchaseComponentsList - コンポーネント一覧

setPurchaseConfirmationList

public void setPurchaseConfirmationList(ArrayList purchaseConfirmationList)
転送構造：照会／一覧一覧を設定します｡

パラメータ:
purchaseConfirmationList - 転送構造：照会／一覧一覧

setPurchaseHistory

public void setPurchaseHistory(ArrayList purchaseHistoryList)
購買発注履歴を設定します｡

パラメータ:
purchaseHistoryList - 購買発注履歴

setPurchaseHistorysTotal

public void setPurchaseHistorysTotal(ArrayList purchaseHistoryTotalsList)
購買発注履歴(合計)を設定します｡

パラメータ:
purchaseHistoryTotalsList - 購買発注履歴(合計)

getPoNumber

public String getPoNumber()
購買伝票番号を取得します｡

戻り値:
poNumber 購買伝票番号

getTestRun

public String getTestRun()
テスト区分を取得します｡

戻り値:
testRun テスト区分

getMemoryUnComplete

public String getMemoryUnComplete()
エラーがある場合に購買発注を保留にする区分を取得します｡

戻り値:
memoryUnComplete エラーがある場合に購買発注を保留にする区分

getMemoryComplete

public String getMemoryComplete()
エラーがない場合に購買発注を保留にする区分を取得します｡

戻り値:
memoryComplete エラーがない場合に購買発注を保留にする区分

getNoMessageReq

public String getNoMessageReq()
メッセージ不要区分を取得します｡

戻り値:
noMessageReq メッセージ不要区分

getNoAuthority

public String getNoAuthority()
権限チェックなし区分を取得します｡

戻り値:
noAuthority 権限チェックなし区分

getNoMessaging

public String getNoMessaging()
出力決定なし区分を取得します｡

戻り値:
noMessaging 出力決定なし区分

getNoPriceFromPo

public String getNoPriceFromPo()
最終伝票からの価格転送なし区分を取得します｡

戻り値:
noPriceFromPo 最終伝票からの価格転送なし区分

getDocumentHeader

public PurchaseHeaderPost getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader 伝票ヘッダ

getSupplierInfo

public VendorAddress getSupplierInfo()
仕入先住所を取得します｡

戻り値:
VendorAddress 仕入先住所

getExportHeader

public ExportHeader getExportHeader()
貿易管理ヘッダを取得します｡

戻り値:
exportHeader 貿易管理ヘッダ

getVersions

public Versions getVersions()
バージョン管理を取得します｡

戻り値:
versions バージョン管理

getPurchaseItemPostList

public ArrayList getPurchaseItemPostList()
明細一覧を取得します｡

戻り値:
purchaseItemPostList 明細一覧

getDeliverryAddressList

public ArrayList getDeliverryAddressList()
出荷伝票アドレス一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

getPurchaseScheduleList

public ArrayList getPurchaseScheduleList()
納入日程一覧を取得します｡

戻り値:
purchaseScheduleList 納入日程一覧

getPurchaseAccountList

public ArrayList getPurchaseAccountList()
勘定設定一覧を取得します｡

戻り値:
purchaseAccountList 勘定設定一覧

getProfitSegmentList

public ArrayList getProfitSegmentList()
入出庫予定一覧を取得します｡

戻り値:
profitSegmentList 入出庫予定一覧

getCondHeaderList

public ArrayList getCondHeaderList()
条件ヘッダ一覧を取得します｡

戻り値:
condHeaderList 条件ヘッダ一覧

getCondItemList

public ArrayList getCondItemList()
条件明細一覧を取得します｡

戻り値:
condItemList 条件明細一覧

getLimitsList

public ArrayList getLimitsList()
外注制限一覧を取得します｡

戻り値:
limitsList 外注制限一覧

getContractLimitsList

public ArrayList getContractLimitsList()
外注基本契約制限一覧を取得します｡

戻り値:
contractLimitsList 外注基本契約制限一覧

getContractServiceList

public ArrayList getContractServiceList()
外注サービス一覧を取得します｡

戻り値:
contractServiceList 外注サービス一覧

getContractServiceAccountList

public ArrayList getContractServiceAccountList()
外注サービス勘定設定一覧を取得します｡

戻り値:
contractServiceAccountList 外注サービス勘定設定一覧

getContractServiceTextList

public ArrayList getContractServiceTextList()
外注サービステキスト一覧を取得します｡

戻り値:
contractServiceTextList 外注サービステキスト一覧

getExtensionList

public ArrayList getExtensionList()
拡張得意先項目一覧を取得します｡

戻り値:
extensionList 拡張得意先項目一覧

getExportItemList

public ArrayList getExportItemList()
貿易管理明細一覧を取得します｡

戻り値:
exportItemList 貿易管理明細一覧

getHeaderTextList

public ArrayList getHeaderTextList()
ヘッダテキスト一覧を取得します｡

戻り値:
headerTextList ヘッダテキスト一覧

getItemTextList

public ArrayList getItemTextList()
                          throws SAPPurchaseSystemException
明細テキスト一覧を取得します｡

戻り値:
itemTextList 明細テキスト一覧
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getPartnerList

public ArrayList getPartnerList()
得意先一覧を取得します｡

戻り値:
partnerList 得意先一覧

getAllVersionsList

public ArrayList getAllVersionsList()
全バージョン一覧を取得します｡

戻り値:
allVersionsList 全バージョン一覧

getPurchaseShippingList

public ArrayList getPurchaseShippingList()
出荷データ一覧を取得します｡

戻り値:
purchaseShippingList 出荷データ一覧

getPurchaseShippingExpList

public ArrayList getPurchaseShippingExpList()
出荷データエクスポート一覧を取得します｡

戻り値:
purchaseShippingExpList 出荷データエクスポート一覧

getPurchaseComponentsList

public ArrayList getPurchaseComponentsList()
コンポーネント一覧を取得します｡

戻り値:
purchaseComponentsList コンポーネント一覧

getPurchaseConfirmationList

public ArrayList getPurchaseConfirmationList()
転送構造：照会／一覧一覧を取得します｡

戻り値:
purchaseConfirmationList 転送構造：照会／一覧一覧

getPurchaseHistoryList

public ArrayList getPurchaseHistoryList()
購買発注履歴を取得します｡

戻り値:
purchaseHistoryList 購買発注履歴

getPurchaseHistoryTotalsList

public ArrayList getPurchaseHistoryTotalsList()
購買発注履歴(合計)を取得します｡

戻り値:
purchaseHistoryTotalsList 購買発注履歴(合計)

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPPurchaseSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPayPostController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController
すべての実装インタフェース:
Serializable
public class PurchaseOrderPayPostController
extends PurchaseOrderPayPost
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPayPostController()
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost から継承したメソッド
executeBapi, getAllVersionsList, getCondHeaderList, getCondItemList, getContractLimitsList, getContractServiceAccountList, getContractServiceList, getContractServiceTextList, getDeliverryAddressList, getDocumentHeader, getExportHeader, getExportItemList, getExtensionList, getHeaderTextList, getItemTextList, getLimitsList, getMemoryComplete, getMemoryUnComplete, getNoAuthority, getNoMessageReq, getNoMessaging, getNoPriceFromPo, getPartnerList, getPoNumber, getProfitSegmentList, getPurchaseAccountList, getPurchaseComponentsList, getPurchaseConfirmationList, getPurchaseHistoryList, getPurchaseHistoryTotalsList, getPurchaseItemPostList, getPurchaseScheduleList, getPurchaseShippingExpList, getPurchaseShippingList, getSupplierInfo, getTestRun, getVersions, setAllVersionsList, setCondHeaderList, setCondItemList, setContractLimitsList, setContractServiceAccountList, setContractServiceList, setContractServiceTextList, setDeliveryAddressList, setDocumentHeader, setExportHeader, setExportItemList, setExportParam, setExtensionList, setHeaderTextList, setImportParam, setItemTextList, setLimitsList, setMemoryComplete, setMemoryUnComplete, setNoAuthority, setNoMessage, setNoMessageReq, setNoPriceFromPo, setPartnerList, setPoNumber, setProfitSegmentList, setPurchaseAccountList, setPurchaseComponentsList, setPurchaseConfirmationList, setPurchaseHistory, setPurchaseHistorysTotal, setPurchaseItemPostList, setPurchaseScheduleList, setPurchaseShippingExpList, setPurchaseShippingList, setStrParam, setSupplierInfo, setTblParam, setTestRun, setVersions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPayPostController

public PurchaseOrderPayPostController()
PurchaseOrderPayPostControllerのコンストラクタを生成します。

PurchaseOrderPayPostController

public PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

PurchaseOrderPayPostController

public PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPostChangeController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPostChangeController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController
すべての実装インタフェース:
Serializable
public class PurchaseOrderPostChangeController
extends PurchaseOrderPayPost
implements Serializable

伝票登録変更コントローラクラス
機能は以下の通り

  • 伝票を変更します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPostChangeController()
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void setExportParam(BapiController bapiController)
伝票に登録された情報をセットします。
 void setImportParam(BapiController bapiController)
伝票に登録する値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost から継承したメソッド
executeBapi, getAllVersionsList, getCondHeaderList, getCondItemList, getContractLimitsList, getContractServiceAccountList, getContractServiceList, getContractServiceTextList, getDeliverryAddressList, getDocumentHeader, getExportHeader, getExportItemList, getExtensionList, getHeaderTextList, getItemTextList, getLimitsList, getMemoryComplete, getMemoryUnComplete, getNoAuthority, getNoMessageReq, getNoMessaging, getNoPriceFromPo, getPartnerList, getPoNumber, getProfitSegmentList, getPurchaseAccountList, getPurchaseComponentsList, getPurchaseConfirmationList, getPurchaseHistoryList, getPurchaseHistoryTotalsList, getPurchaseItemPostList, getPurchaseScheduleList, getPurchaseShippingExpList, getPurchaseShippingList, getSupplierInfo, getTestRun, getVersions, setAllVersionsList, setCondHeaderList, setCondItemList, setContractLimitsList, setContractServiceAccountList, setContractServiceList, setContractServiceTextList, setDeliveryAddressList, setDocumentHeader, setExportHeader, setExportItemList, setExtensionList, setHeaderTextList, setItemTextList, setLimitsList, setMemoryComplete, setMemoryUnComplete, setNoAuthority, setNoMessage, setNoMessageReq, setNoPriceFromPo, setPartnerList, setPoNumber, setProfitSegmentList, setPurchaseAccountList, setPurchaseComponentsList, setPurchaseConfirmationList, setPurchaseHistory, setPurchaseHistorysTotal, setPurchaseItemPostList, setPurchaseScheduleList, setPurchaseShippingExpList, setPurchaseShippingList, setStrParam, setSupplierInfo, setTestRun, setVersions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController()
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値をセットします。 オーバーライドして、転送構造：照会／一覧、購買発注履歴、 購買発注履歴(合計)テーブルの情報をセットします。

オーバーライド:
クラス PurchaseOrderPayPost 内の setImportParam
パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報をセットします。 オーバーライドして、転送構造：照会／一覧、購買発注履歴、 購買発注履歴(合計)テーブルの情報をセットします。

オーバーライド:
クラス PurchaseOrderPayPost 内の setExportParam
パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

オーバーライド:
クラス PurchaseOrderPayPost 内の setTblParam
パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseRelease (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseRelease

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseReleaseController, PurchaseResetReleaseController
public class PurchaseRelease
extends UpdateController
implements Serializable

承認情報スーパークラス
機能は以下の通り

  • 承認情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseRelease()
伝票承認を作成します。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, String noCommit)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, String noCommit, ConnectionManager connectionManager)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, String noCommit, SapClient sapClient)
コンストラクタ生成。
メソッドの概要
void | executeBapi(BapiController bapiController) 伝票承認取消処理を実行します。
String | getNoCommit() コミットワーク はい/いいえを取得します。
String | getPoRelCode() 承認コードを取得します。
String | getPurchaseorder() 購買発注番号を取得します。
String | getRelIndicatorNew() 返却規承認区分を取得します。
String | getRelStatusNew() 返却承認状況を取得します。
String | getUseExceptions() 例外メッセージ設定とエラーメッセージ出力を取得します。
void | setExportParam(BapiController bapiController) 実行結果を取得します。
void | setNoCommit(String strNoCommit) コミットワーク はい/いいえを取得します。
void | setPoRelCode(String strPoRelCode) 承認コードを設定します。
void | setPurchaseorder(String strPurchaseorder) 購買発注番号を設定します。
void | setRelIndicatorNew(String strRelIndicatorNew) 返却承認区分を設定します。
void | setRelStatusNew(String strRelStatusNew) 返却承認状況を設定します。
void | setUseExceptions(String strUseExceptions) 例外メッセージ設定とエラーメッセージ出力を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseRelease

public PurchaseRelease()
伝票承認を作成します。

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       ConnectionManager connectionManager)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
connectionManager - コネクションマネージャー

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       SapClient sapClient)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
sapClient - SAPへの接続情報が格納されたオブジェクト

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       String noCommit)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
noCommit - コミットワーク はい/いいえ

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       String noCommit,
                       ConnectionManager connectionManager)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
noCommit - コミットワーク はい/いいえ
connectionManager - コネクションマネージャー

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       String noCommit,
                       SapClient sapClient)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
noCommit - コミットワーク はい/いいえ
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
伝票承認取消処理を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
実行結果を取得します。

パラメータ:
bapiController - BAPIコントローラー
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

getPurchaseorder

public String getPurchaseorder()
購買発注番号を取得します。

戻り値:
srtPurchaseorder

getPoRelCode

public String getPoRelCode()
承認コードを取得します。

戻り値:
srtPoRelCode

getUseExceptions

public String getUseExceptions()
例外メッセージ設定とエラーメッセージ出力を取得します。

戻り値:
srtUseExceptions

getNoCommit

public String getNoCommit()
コミットワーク はい/いいえを取得します。

戻り値:
strNoCommit

getRelStatusNew

public String getRelStatusNew()
返却承認状況を取得します。

戻り値:
srtRelStatusNew

getRelIndicatorNew

public String getRelIndicatorNew()
返却規承認区分を取得します。

戻り値:
srtRelIndicatorNew

setPurchaseorder

public void setPurchaseorder(String strPurchaseorder)
購買発注番号を設定します。

パラメータ:
strPurchaseorder - 購買発注番号

setPoRelCode

public void setPoRelCode(String strPoRelCode)
承認コードを設定します。

パラメータ:
strPoRelCode - 承認コード

setUseExceptions

public void setUseExceptions(String strUseExceptions)
例外メッセージ設定とエラーメッセージ出力を設定します。

パラメータ:
strUseExceptions - 例外メッセージ設定とエラーメッセージ出力

setNoCommit

public void setNoCommit(String strNoCommit)
コミットワーク はい/いいえを取得します。を設定します。

パラメータ:
strNoCommit - コミットワーク はい/いいえを取得します。

setRelStatusNew

public void setRelStatusNew(String strRelStatusNew)
返却承認状況を設定します。

パラメータ:
strRelStatusNew - 返却承認状況

setRelIndicatorNew

public void setRelIndicatorNew(String strRelIndicatorNew)
返却承認区分を設定します。

パラメータ:
strRelIndicatorNew - 返却規承認区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseReleaseController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseReleaseController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController
すべての実装インタフェース:
Serializable
public class PurchaseReleaseController
extends PurchaseRelease
implements Serializable

伝票承認コントローラクラス
機能は以下の通り

  • 伝票を承認します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, String noCommit)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, String noCommit, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, String noCommit, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
メソッドの概要
void | executeBapi() 伝票承認処理を実行します。
String | getRetCode() リターン値、ABAP 命令後のリターン値を取得します。
void | setRetCode(String strRetCode) リターン値、ABAP 命令後のリターン値を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease から継承したメソッド
executeBapi, getNoCommit, getPoRelCode, getPurchaseorder, getRelIndicatorNew, getRelStatusNew, getUseExceptions, setExportParam, setNoCommit, setPoRelCode, setPurchaseorder, setRelIndicatorNew, setRelStatusNew, setUseExceptions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
noCommit(コミットワーク)は設定されませんので、コミット処理が実行されます。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

noCommit(コミットワーク)は設定されませんので、コミット処理が実行されます。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
connectionManager - コネクションマネージャー

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。
noCommit(コミットワーク)は設定されませんので、コミット処理が実行されます。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
sapClient - SAPへの接続情報が格納されたオブジェクト

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 String noCommit)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
noCommit - コミットワーク はい/いいえ

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 String noCommit,
                                 ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
noCommit - コミットワーク はい/いいえ
connectionManager - コネクションマネージャー

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 String noCommit,
                                 SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。
noCommit(コミットワーク)の設定方法は以下のとおりです。
指定しない：コミット処理が実行されます。
「X」を指定：コミット処理が実行されません。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
noCommit - コミットワーク はい/いいえ
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
伝票承認処理を実行します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

getRetCode

public String getRetCode()
                  throws SAPPurchaseSystemException
リターン値、ABAP 命令後のリターン値を取得します。

戻り値:
srtRetCode
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setRetCode

public void setRetCode(String strRetCode)
リターン値、ABAP 命令後のリターン値を設定します。

パラメータ:
strRetCode - リターン値、ABAP 命令後のリターン値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseResetReleaseController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseResetReleaseController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController
すべての実装インタフェース:
Serializable
public class PurchaseResetReleaseController
extends PurchaseRelease
implements Serializable

伝票承認取消コントローラクラス
機能は以下の通り

  • 伝票の承認取消します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
メソッドの概要
 void executeBapi()
伝票承認取消処理を実行します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease から継承したメソッド
executeBapi, getNoCommit, getPoRelCode, getPurchaseorder, getRelIndicatorNew, getRelStatusNew, getUseExceptions, setExportParam, setNoCommit, setPoRelCode, setPurchaseorder, setRelIndicatorNew, setRelStatusNew, setUseExceptions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

【重要】標準BAPIでは、BAPI内部でコミット処理が実行されます。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions,
                                      ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RESET_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
connectionManager - コネクションマネージャー

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions,
                                      SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RESET_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
伝票承認取消処理を実行します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseSchedule (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseSchedule

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule
すべての実装インタフェース:
Serializable
public class PurchaseSchedule
extends Object
implements Serializable

購買発注伝票納入日程情報クラス
機能は以下の通り

  • 購買発注伝票納入日程情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseSchedule()
購買発注伝票納入日程を作成します。
PurchaseSchedule(int index)
購買発注伝票納入日程を作成します。
メソッドの概要
String | getComDate() 確認日を取得します。
String | getComQty() 確認数量を取得します。
String | getDelDatcatExt() 納入期日カテゴリを取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDeliveryDate() 納入期日を取得します。
String | getDelivTime() 納入期日における指定時間を取得します。
String | getGiDate() 出庫日付を取得します。
String | getGiTime() 出庫時刻 (現地時間 - プラント参照)を取得します。
String | getGrEndDate() 入庫終了日付を取得します。
String | getGrEndTime() 入庫終了時刻 (ローカル、プラントに関連)を取得します。
String | getLoadDate() 積載日付を取得します。
String | getLoadTime() 積載時刻 (現地時間: 出荷ポイント)を取得します。
String | getMsDate() 品目利用可能日を取得します。
String | getMsTime() 品目供給ステージ (現地時刻: プラント参照)を取得します。
String | getPoDate() 納入日程の購買発注日付を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPreqItem() 購買依頼の明細番号を取得します。
String | getPreqNo() 購買依頼番号を取得します。
String | getQuantity() 計画数量を取得します。
String | getReqClosed() 購買依頼処理済を取得します。
String | getRoutesched() 輸送経路計画を取得します。
String | getSchedLine() 納入日程行を取得します。
int | getScIndex() レコード番号を取得します｡
String | getStatDate() 統計的納入期日を取得します。
String | getTpDate() 輸送計画日付を取得します。
String | getTpTime() 輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
void | setComDate(String strComDate) 確認日を設定します。
void | setComQty(String strComQty) 確認数量を設定します。
void | setDelDatcatExt(String strDelDatcatExt) 納入期日カテゴリを設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDeliveryDate(String strDeliveryDate) 納入期日を設定します。
void | setDelivTime(String strDelivTime) 納入期日における指定時間を設定します。
void | setGiDate(String strGiDate) 出庫日付を設定します。
void | setGiTime(String strGiTime) 出庫時刻 (現地時間 - プラント参照)を設定します。
void | setGrEndDate(String strGrEndDate) 入庫終了日付を設定します。
void | setGrEndTime(String strGrEndTime) 入庫終了時刻 (ローカル、プラントに関連)を設定します。
void | setLoadDate(String strLoadDate) 積載日付を設定します。
void | setLoadTime(String strLoadTime) 積載時刻 (現地時間: 出荷ポイント)を設定します。
void | setMsDate(String strMsDate) 品目利用可能日を設定します。
void | setMsTime(String strMsTime) 品目供給ステージ (現地時刻: プラント参照)を設定します。
void | setPoDate(String strPoDate) 納入日程の購買発注日付を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPreqItem(String strPreqItem) 購買依頼の明細番号を設定します。
void | setPreqNo(String strPreqNo) 購買依頼番号を設定します。
void | setQuantity(String strQuantity) 計画数量を設定します。
void | setReqClosed(String strReqClosed) 購買依頼処理済を設定します。
void | setRoutesched(String strRoutesched) 輸送経路計画を設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
void | setScIndex(int scIndex) レコード番号を設定します｡
void | setStatDate(String strStatDate) 統計的納入期日を設定します。
void | setTpDate(String strTpDate) 輸送計画日付を設定します。
void | setTpTime(String strTpTime) 輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseSchedule

public PurchaseSchedule()
購買発注伝票納入日程を作成します。

PurchaseSchedule

public PurchaseSchedule(int index)
購買発注伝票納入日程を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
srtSchedLine 納入日程行

getDelDatcatExt

public String getDelDatcatExt()
納入期日カテゴリを取得します。

戻り値:
srtDelDatcatExt 納入期日カテゴリ

getDeliveryDate

public String getDeliveryDate()
納入期日を取得します。

戻り値:
srtDeliveryDate 納入期日

getQuantity

public String getQuantity()
計画数量を取得します。

戻り値:
srtQuantity 計画数量

getDelivTime

public String getDelivTime()
納入期日における指定時間を取得します。

戻り値:
srtDelivTime 納入期日における指定時間

getStatDate

public String getStatDate()
統計的納入期日を取得します。

戻り値:
srtStatDate 統計的納入期日

getPreqNo

public String getPreqNo()
購買依頼番号を取得します。

戻り値:
srtPreqNo 購買依頼番号

getPreqItem

public String getPreqItem()
購買依頼の明細番号を取得します。

戻り値:
srtPreqItem 購買依頼の明細番号

getPoDate

public String getPoDate()
納入日程の購買発注日付を取得します。

戻り値:
srtPoDate 納入日程の購買発注日付

getRoutesched

public String getRoutesched()
輸送経路計画を取得します。

戻り値:
srtRoutesched 輸送経路計画

getMsDate

public String getMsDate()
品目利用可能日を取得します。

戻り値:
srtMsDate 品目利用可能日

getMsTime

public String getMsTime()
品目供給ステージ (現地時刻: プラント参照)を取得します。

戻り値:
srtMsTime 品目供給ステージ (現地時刻: プラント参照)

getLoadDate

public String getLoadDate()
積載日付を取得します。

戻り値:
srtLoadDate 積載日付

getLoadTime

public String getLoadTime()
積載時刻 (現地時間: 出荷ポイント)を取得します。

戻り値:
srtLoadTime 積載時刻 (現地時間: 出荷ポイント)

getTpDate

public String getTpDate()
輸送計画日付を取得します。

戻り値:
srtTpDate 輸送計画日付

getTpTime

public String getTpTime()
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。

戻り値:
srtTpTime 輸送計画 - 時間 (現地時間/出荷ポイント参照)

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
srtGiDate 出庫日付

getGiTime

public String getGiTime()
出庫時刻 (現地時間 - プラント参照)を取得します。

戻り値:
srtGiTime 出庫時刻 (現地時間 - プラント参照)

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
srtDeleteInd 購買伝票の削除フラグ

getReqClosed

public String getReqClosed()
購買依頼処理済を取得します。

戻り値:
strReqClosed 購買依頼処理済

getGrEndDate

public String getGrEndDate()
入庫終了日付を取得します。

戻り値:
strGrEndDate 入庫終了日付

getGrEndTime

public String getGrEndTime()
入庫終了時刻 (ローカル、プラントに関連)を取得します。

戻り値:
strGrEndTime 入庫終了時刻 (ローカル、プラントに関連)

getComQty

public String getComQty()
確認数量を取得します。

戻り値:
strComQty 確認数量

getComDate

public String getComDate()
確認日を取得します。

戻り値:
strComDate 確認日

getScIndex

public int getScIndex()
レコード番号を取得します｡

戻り値:
scIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setDelDatcatExt

public void setDelDatcatExt(String strDelDatcatExt)
納入期日カテゴリを設定します。

パラメータ:
strDelDatcatExt - 納入期日カテゴリ

setDeliveryDate

public void setDeliveryDate(String strDeliveryDate)
納入期日を設定します。

パラメータ:
strDeliveryDate - 納入期日

setQuantity

public void setQuantity(String strQuantity)
計画数量を設定します。

パラメータ:
strQuantity - 計画数量

setDelivTime

public void setDelivTime(String strDelivTime)
納入期日における指定時間を設定します。

パラメータ:
strDelivTime - 納入期日における指定時間

setStatDate

public void setStatDate(String strStatDate)
統計的納入期日を設定します。

パラメータ:
strStatDate - 統計的納入期日

setPreqNo

public void setPreqNo(String strPreqNo)
購買依頼番号を設定します。

パラメータ:
strPreqNo - 購買依頼番号

setPreqItem

public void setPreqItem(String strPreqItem)
購買依頼の明細番号を設定します。

パラメータ:
strPreqItem - 購買依頼の明細番号

setPoDate

public void setPoDate(String strPoDate)
納入日程の購買発注日付を設定します。

パラメータ:
strPoDate - 納入日程の購買発注日付

setRoutesched

public void setRoutesched(String strRoutesched)
輸送経路計画を設定します。

パラメータ:
strRoutesched - 輸送経路計画

setMsDate

public void setMsDate(String strMsDate)
品目利用可能日を設定します。

パラメータ:
strMsDate - 品目利用可能日

setMsTime

public void setMsTime(String strMsTime)
品目供給ステージ (現地時刻: プラント参照)を設定します。

パラメータ:
strMsTime - 品目供給ステージ (現地時刻: プラント参照)

setLoadDate

public void setLoadDate(String strLoadDate)
積載日付を設定します。

パラメータ:
strLoadDate - 積載日付

setLoadTime

public void setLoadTime(String strLoadTime)
積載時刻 (現地時間: 出荷ポイント)を設定します。

パラメータ:
strLoadTime - 積載時刻 (現地時間: 出荷ポイント)

setTpDate

public void setTpDate(String strTpDate)
輸送計画日付を設定します。

パラメータ:
strTpDate - 輸送計画日付

setTpTime

public void setTpTime(String strTpTime)
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。

パラメータ:
strTpTime - 輸送計画 - 時間 (現地時間/出荷ポイント参照)

setGiDate

public void setGiDate(String strGiDate)
出庫日付を設定します。

パラメータ:
strGiDate - 出庫日付

setGiTime

public void setGiTime(String strGiTime)
出庫時刻 (現地時間 - プラント参照)を設定します。

パラメータ:
strGiTime - 出庫時刻 (現地時間 - プラント参照)

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setReqClosed

public void setReqClosed(String strReqClosed)
購買依頼処理済を設定します。

パラメータ:
strReqClosed - 購買依頼処理済

setGrEndDate

public void setGrEndDate(String strGrEndDate)
入庫終了日付を設定します。

パラメータ:
strGrEndDate - 入庫終了日付

setGrEndTime

public void setGrEndTime(String strGrEndTime)
入庫終了時刻 (ローカル、プラントに関連)を設定します。

パラメータ:
strGrEndTime - 入庫終了時刻 (ローカル、プラントに関連)

setComQty

public void setComQty(String strComQty)
確認数量を設定します。

パラメータ:
strComQty - 確認数量

setComDate

public void setComDate(String strComDate)
確認日を設定します。

パラメータ:
strComDate - 確認日

setScIndex

public void setScIndex(int scIndex)
レコード番号を設定します｡

パラメータ:
scIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseShipping (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseShipping

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping
すべての実装インタフェース:
Serializable
public class PurchaseShipping
extends Object
implements Serializable

出荷データクラス
機能は以下の通り

  • 出荷データを保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseShipping()
出荷データを作成します。
PurchaseShipping(int index)
出荷データを作成します。
メソッドの概要
String | getAuthNumber() 返品権限番号を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getDlvPrio() 出荷優先順位を取得します。
String | getFollowUp() デフォルト後続アクティビティコードを取得します。
String | getInspoutGuid() 品質検査結果： EWM 設定の在庫 GUIDを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getRoute() 輸送経路を取得します。
String | getShipCond() 出荷条件を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getSrcDlvNo() 元出荷番号を取得します。
String | getSrcHandlgUnit() 元/先 荷役単位 (外部 ID)を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
void | setAuthNumber(String strAuthNumber) 返品権限番号を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setDlvPrio(String strDlvPrio) 出荷優先順位を設定します。
void | setFollowUp(String strFollowUp) デフォルト後続アクティビティコードを設定します。
void | setInspoutGuid(String strInspoutGuid) 品質検査結果： EWM 設定の在庫 GUIDを設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setRoute(String strRoute) 輸送経路を設定します。
void | setShipCond(String strShipCond) 出荷条件を設定します。
void | setShipPoint(String strShipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setSrcDlvNo(String strSrcDlvNo) 元出荷番号を設定します。
void | setSrcHandlgUnit(String strSrcHandlgUnit) 元/先 荷役単位 (外部 ID)を設定します。
void | setUnloadPt(String strUnloadPt) 荷渡ポイントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseShipping

public PurchaseShipping()
出荷データを作成します。

PurchaseShipping

public PurchaseShipping(int index)
出荷データを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
strPoItem 購買伝票の明細番号

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
strShipPoint 出荷ポイント/入荷ポイント

getDlvPrio

public String getDlvPrio()
出荷優先順位を取得します。

戻り値:
strDlvPrio 出荷優先順位

getRoute

public String getRoute()
輸送経路を取得します。

戻り値:
strRoute 輸送経路

getShipCond

public String getShipCond()
出荷条件を取得します。

戻り値:
strShipCond 出荷条件

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
strUnloadPt 荷渡ポイント

getAuthNumber

public String getAuthNumber()
返品権限番号を取得します。

戻り値:
strAuthNumber 返品権限番号

getSrcDlvNo

public String getSrcDlvNo()
元出荷番号を取得します。

戻り値:
strSrcDlvNo 元出荷番号

getSrcHandlgUnit

public String getSrcHandlgUnit()
元/先 荷役単位 (外部 ID)を取得します。

戻り値:
strSrcHandlgUnit 元/先 荷役単位 (外部 ID)

getInspoutGuid

public String getInspoutGuid()
品質検査結果： EWM 設定の在庫 GUIDを取得します。

戻り値:
strInspoutGuid 品質検査結果： EWM 設定の在庫 GUID

getFollowUp

public String getFollowUp()
デフォルト後続アクティビティコードを取得します。

戻り値:
strFollowUp デフォルト後続アクティビティコード

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setShipPoint

public void setShipPoint(String strShipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
strShipPoint - 出荷ポイント/入荷ポイント

setDlvPrio

public void setDlvPrio(String strDlvPrio)
出荷優先順位を設定します。

パラメータ:
strDlvPrio - 出荷優先順位

setRoute

public void setRoute(String strRoute)
輸送経路を設定します。

パラメータ:
strRoute - 輸送経路

setShipCond

public void setShipCond(String strShipCond)
出荷条件を設定します。

パラメータ:
strShipCond - 出荷条件

setUnloadPt

public void setUnloadPt(String strUnloadPt)
荷渡ポイントを設定します。

パラメータ:
strUnloadPt - 荷渡ポイント

setAuthNumber

public void setAuthNumber(String strAuthNumber)
返品権限番号を設定します。

パラメータ:
strAuthNumber - 返品権限番号

setSrcDlvNo

public void setSrcDlvNo(String strSrcDlvNo)
元出荷番号を設定します。

パラメータ:
strSrcDlvNo - 元出荷番号

setSrcHandlgUnit

public void setSrcHandlgUnit(String strSrcHandlgUnit)
元/先 荷役単位 (外部 ID)を設定します。

パラメータ:
strSrcHandlgUnit - 元/先 荷役単位 (外部 ID)

setInspoutGuid

public void setInspoutGuid(String strInspoutGuid)
品質検査結果： EWM 設定の在庫 GUIDを設定します。

パラメータ:
strInspoutGuid - 品質検査結果： EWM 設定の在庫 GUID

setFollowUp

public void setFollowUp(String strFollowUp)
デフォルト後続アクティビティコードを設定します。

パラメータ:
strFollowUp - デフォルト後続アクティビティコード

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseShippingExp (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseShippingExp

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp
すべての実装インタフェース:
Serializable
public class PurchaseShippingExp
extends Object
implements Serializable

出荷データエクスポートクラス
機能は以下の通り

  • 出荷データエクスポート情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseShippingExp()
出荷データエクスポート情報を作成します。
PurchaseShippingExp(int index)
出荷データエクスポート情報を作成します。
メソッドの概要
String | getAuthNumber() 返品権限番号を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getCustomer() 得意先コード 1を取得します。
String | getDelCreateDate() 出荷登録日付を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvPrio() 出荷優先順位を取得します。
String | getFollowUp() デフォルト後続アクティビティコードを取得します。
String | getFwdagent() 海貨業者を取得します。
String | getInspoutGuid() 品質検査結果： EWM 設定の在庫 GUIDを取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() 言語キーの ISO コードを取得します。
String | getLoadinggrp() 積載グループを取得します。
String | getOrdcombind() 受注結合区分を取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getRoute() 輸送経路を取得します。
String | getSalesorg() 販売組織を取得します。
String | getShipCond() 出荷条件を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getSoldTo() 受注先を取得します。
String | getSrcDlvNo() 元出荷番号を取得します。
String | getSrcHandlgUnit() 元/先 荷役単位 (外部 ID)を取得します。
String | getTimeZone() 出荷場所のタイムゾーンを取得します。
String | getTransGrp() 輸送グループを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
void | setAuthNumber(String strAuthNumber) 返品権限番号を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setCustomer(String strCustomer) 得意先コード 1を設定します。
void | setDelCreateDate(String strDelCreateDate) 出荷登録日付を設定します。
void | setDistrChan(String strDistrChan) 流通チャネルを設定します。
void | setDivision(String strDivision) 製品部門を設定します。
void | setDlvPrio(String strDlvPrio) 出荷優先順位を設定します。
void | setFollowUp(String strFollowUp) デフォルト後続アクティビティコードを設定します。
void | setFwdagent(String strFwdagent) 海貨業者を設定します。
void | setInspoutGuid(String strInspoutGuid) 品質検査結果： EWM 設定の在庫 GUIDを設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) 言語キーの ISO コードを設定します。
void | setLoadinggrp(String strLoadinggrp) 積載グループを設定します。
void | setOrdcombind(String strOrdcombind) 受注結合区分を設定します。
void | setPlndDelry(String strPlndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setRoute(String strRoute) 輸送経路を設定します。
void | setSalesorg(String strSalesorg) 販売組織を設定します。
void | setShipCond(String strShipCond) 出荷条件を設定します。
void | setShipPoint(String strShipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setSoldTo(String strSoldTo) 受注先を設定します。
void | setSrcDlvNo(String strSrcDlvNo) 元出荷番号を設定します。
void | setSrcHandlgUnit(String strSrcHandlgUnit) 元/先 荷役単位 (外部 ID)を設定します。
void | setTimeZone(String strTimeZone) 出荷場所のタイムゾーンを設定します。
void | setTransGrp(String strTransGrp) 輸送グループを設定します。
void | setUnloadPt(String strUnloadPt) 荷渡ポイントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseShippingExp

public PurchaseShippingExp()
出荷データエクスポート情報を作成します。

PurchaseShippingExp

public PurchaseShippingExp(int index)
出荷データエクスポート情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
strPoItem 購買伝票の明細番号

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
strShipPoint 出荷ポイント/入荷ポイント

getDlvPrio

public String getDlvPrio()
出荷優先順位を取得します。

戻り値:
strDlvPrio 出荷優先順位

getRoute

public String getRoute()
輸送経路を取得します。

戻り値:
strRoute 輸送経路

getCustomer

public String getCustomer()
得意先コード 1を取得します。

戻り値:
strCustomer 得意先コード 1

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
strSoldTo 受注先

getFwdagent

public String getFwdagent()
海貨業者を取得します。

戻り値:
strFwdagent 海貨業者

getSalesorg

public String getSalesorg()
販売組織を取得します。

戻り値:
strSalesorg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
strDistrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
strDivision 製品部門

getDelCreateDate

public String getDelCreateDate()
出荷登録日付を取得します。

戻り値:
strDelCreateDate 出荷登録日付

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
strPlndDelry 予定納入時間 (単位: 日)

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
strLangu 言語キー

getLanguIso

public String getLanguIso()
言語キーの ISO コードを取得します。

戻り値:
strLanguIso 言語キーの ISO コード

getShipCond

public String getShipCond()
出荷条件を取得します。

戻り値:
strShipCond 出荷条件

getLoadinggrp

public String getLoadinggrp()
積載グループを取得します。

戻り値:
strLoadinggrp 積載グループ

getTransGrp

public String getTransGrp()
輸送グループを取得します。

戻り値:
strTransGrp 輸送グループ

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
strUnloadPt 荷渡ポイント

getOrdcombind

public String getOrdcombind()
受注結合区分を取得します。

戻り値:
strOrdcombind 受注結合区分

getTimeZone

public String getTimeZone()
出荷場所のタイムゾーンを取得します。

戻り値:
strTimeZone 出荷場所のタイムゾーン

getAuthNumber

public String getAuthNumber()
返品権限番号を取得します。

戻り値:
strAuthNumber 返品権限番号

getSrcDlvNo

public String getSrcDlvNo()
元出荷番号を取得します。

戻り値:
strSrcDlvNo 元出荷番号

getSrcHandlgUnit

public String getSrcHandlgUnit()
元/先 荷役単位 (外部 ID)を取得します。

戻り値:
strSrcHandlgUnit 元/先 荷役単位 (外部 ID)

getInspoutGuid

public String getInspoutGuid()
品質検査結果： EWM 設定の在庫 GUIDを取得します。

戻り値:
strInspoutGuid 品質検査結果： EWM 設定の在庫 GUID

getFollowUp

public String getFollowUp()
デフォルト後続アクティビティコードを取得します。

戻り値:
strFollowUp デフォルト後続アクティビティコード

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setShipPoint

public void setShipPoint(String strShipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
strShipPoint - 出荷ポイント/入荷ポイント

setDlvPrio

public void setDlvPrio(String strDlvPrio)
出荷優先順位を設定します。

パラメータ:
strDlvPrio - 出荷優先順位

setRoute

public void setRoute(String strRoute)
輸送経路を設定します。

パラメータ:
strRoute - 輸送経路

setCustomer

public void setCustomer(String strCustomer)
得意先コード 1を設定します。

パラメータ:
strCustomer - 得意先コード 1

setSoldTo

public void setSoldTo(String strSoldTo)
受注先を設定します。

パラメータ:
strSoldTo - 受注先

setFwdagent

public void setFwdagent(String strFwdagent)
海貨業者を設定します。

パラメータ:
strFwdagent - 海貨業者

setSalesorg

public void setSalesorg(String strSalesorg)
販売組織を設定します。

パラメータ:
strSalesorg - 販売組織

setDistrChan

public void setDistrChan(String strDistrChan)
流通チャネルを設定します。

パラメータ:
strDistrChan - 流通チャネル

setDivision

public void setDivision(String strDivision)
製品部門を設定します。

パラメータ:
strDivision - 製品部門

setDelCreateDate

public void setDelCreateDate(String strDelCreateDate)
出荷登録日付を設定します。

パラメータ:
strDelCreateDate - 出荷登録日付

setPlndDelry

public void setPlndDelry(String strPlndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
strPlndDelry - 予定納入時間 (単位: 日)

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
言語キーの ISO コードを設定します。

パラメータ:
strLanguIso - 言語キーの ISO コード

setShipCond

public void setShipCond(String strShipCond)
出荷条件を設定します。

パラメータ:
strShipCond - 出荷条件

setLoadinggrp

public void setLoadinggrp(String strLoadinggrp)
積載グループを設定します。

パラメータ:
strLoadinggrp - 積載グループ

setTransGrp

public void setTransGrp(String strTransGrp)
輸送グループを設定します。

パラメータ:
strTransGrp - 輸送グループ

setUnloadPt

public void setUnloadPt(String strUnloadPt)
荷渡ポイントを設定します。

パラメータ:
strUnloadPt - 荷渡ポイント

setOrdcombind

public void setOrdcombind(String strOrdcombind)
受注結合区分を設定します。

パラメータ:
strOrdcombind - 受注結合区分

setTimeZone

public void setTimeZone(String strTimeZone)
出荷場所のタイムゾーンを設定します。

パラメータ:
strTimeZone - 出荷場所のタイムゾーン

setAuthNumber

public void setAuthNumber(String strAuthNumber)
返品権限番号を設定します。

パラメータ:
strAuthNumber - 返品権限番号

setSrcDlvNo

public void setSrcDlvNo(String strSrcDlvNo)
元出荷番号を設定します。

パラメータ:
strSrcDlvNo - 元出荷番号

setSrcHandlgUnit

public void setSrcHandlgUnit(String strSrcHandlgUnit)
元/先 荷役単位 (外部 ID)を設定します。

パラメータ:
strSrcHandlgUnit - 元/先 荷役単位 (外部 ID)

setInspoutGuid

public void setInspoutGuid(String strInspoutGuid)
品質検査結果： EWM 設定の在庫 GUIDを設定します。

パラメータ:
strInspoutGuid - 品質検査結果： EWM 設定の在庫 GUID

setFollowUp

public void setFollowUp(String strFollowUp)
デフォルト後続アクティビティコードを設定します。

パラメータ:
strFollowUp - デフォルト後続アクティビティコード

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ContractServiceText
public class PurchaseText
extends Object
implements Serializable

購買発注伝票テキストクラス
機能は以下の通り

  • 購買発注伝テキストを保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseText()
購買発注伝票テキストを作成します。
PurchaseText(int index)
購買発注伝票テキストを作成します。
メソッドの概要
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買伝票番号を取得します。
int | getTeIndex() レコード番号を取得します｡
String | getTextForm() タグ列を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setTeIndex(int teIndex) レコード番号を設定します｡
void | setTextForm(String strTextForm) タグ列を設定します。
void | setTextId(String strTextId) テキスト IDを設定します。
void | setTextLine(String strTextLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseText

public PurchaseText()
購買発注伝票テキストを作成します。

PurchaseText

public PurchaseText(int index)
購買発注伝票テキストを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber 購買伝票番号

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
srtTextId テキスト ID

getTextForm

public String getTextForm()
タグ列を取得します。

戻り値:
srtTextForm タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
srtTextLine テキスト行

getTeIndex

public int getTeIndex()
レコード番号を取得します｡

戻り値:
teIndex レコード番号

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setTextId

public void setTextId(String strTextId)
テキスト IDを設定します。

パラメータ:
strTextId - テキスト ID

setTextForm

public void setTextForm(String strTextForm)
タグ列を設定します。

パラメータ:
strTextForm - タグ列

setTextLine

public void setTextLine(String strTextLine)
テキスト行を設定します。

パラメータ:
strTextLine - テキスト行

setTeIndex

public void setTeIndex(int teIndex)
レコード番号を設定します｡

パラメータ:
teIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrganisationSelection (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SalesOrganisationSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection
すべての実装インタフェース:
Serializable
public class SalesOrganisationSelection
extends Selection
implements Serializable

販売組織の選択オプションクラス
機能は以下の通り

  • 販売組織の選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesOrganisationSelection()
販売組織の選択オプション情報を作成します。
SalesOrganisationSelection(int index)
販売組織の選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getSalesorgHigh() 販売組織の範囲終了を取得します。
String | getSalesorgLow() 販売組織の範囲開始を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setSalesorgHigh(String strSalesorgHigh) 販売組織の範囲終了を設定します。
void | setSalesorgLow(String strSalesorgLow) 販売組織の範囲開始を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrganisationSelection

public SalesOrganisationSelection()
販売組織の選択オプション情報を作成します。

SalesOrganisationSelection

public SalesOrganisationSelection(int index)
販売組織の選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSalesorgLow

public String getSalesorgLow()
販売組織の範囲開始を取得します。

戻り値:
srtSalesorgLow 販売組織の範囲開始

getSalesorgHigh

public String getSalesorgHigh()
販売組織の範囲終了を取得します。

戻り値:
srtSalesorgHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setSalesorgLow

public void setSalesorgLow(String strSalesorgLow)
販売組織の範囲開始を設定します。

パラメータ:
strSalesorgLow - 販売組織の範囲開始

setSalesorgHigh

public void setSalesorgHigh(String strSalesorgHigh)
販売組織の範囲終了を設定します。

パラメータ:
strSalesorgHigh - 販売組織の範囲終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Selection (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Selection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DistributionChannelSelection, MaterialShortDescsel, MatnrSelection, PlantSelection, SalesOrganisationSelection, StorageLocationSelect
public class Selection
extends Object
implements Serializable

選択オプションクラス
機能は以下の通り

  • 選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Selection()
選択オプション情報を作成します。
メソッドの概要
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setOption(String strOption) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String strSign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Selection

public Selection()
選択オプション情報を作成します。

メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
srtSign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
srtOption 選択演算子 OPTION (範囲テーブル)

setSign

public void setSign(String strSign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
strSign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String strOption)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
strOption - 選択演算子 OPTION (範囲テーブル)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StdMaterialGetIntNumberController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス StdMaterialGetIntNumberController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumberController
extends Object
implements Serializable

品目コード割当済照会コントローラクラス。
機能は以下の通り

  • 品目コード割当済情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
メソッドの概要
List | getStdMaterialGetIntNumberList() 品目コード割当済一覧(結果)（StdMaterialGetIntNumberインスタンスの配列）を取得します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumberController

public StdMaterialGetIntNumberController(String materialType,
                                         String industrySector,
                                         String requiredNumbers)
                                  throws SAPAuthAppException,
                                         SAPAuthSystemException,
                                         SAPGeneralAppException,
                                         SAPGeneralSystemException,
                                         SAPPurchaseSystemException,
                                         SAPPurchaseAppException
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外

StdMaterialGetIntNumberController

public StdMaterialGetIntNumberController(String materialType,
                                         String industrySector,
                                         String requiredNumbers,
                                         SapClient sapClient)
                                  throws SAPAuthAppException,
                                         SAPAuthSystemException,
                                         SAPGeneralAppException,
                                         SAPGeneralSystemException,
                                         SAPPurchaseSystemException,
                                         SAPPurchaseAppException
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外
メソッドの詳細

getStdMaterialGetIntNumberList

public List getStdMaterialGetIntNumberList()
品目コード割当済一覧(結果)（StdMaterialGetIntNumberインスタンスの配列）を取得します。

戻り値:
stdMaterialGetIntNumberList 品目コード割当済一覧(結果)
関連項目:
StdMaterialGetIntNumber

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationSelect (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス StorageLocationSelect

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect
すべての実装インタフェース:
Serializable
public class StorageLocationSelect
extends Selection
implements Serializable

保管場所の選択オプションクラス
機能は以下の通り

  • 保管場所の選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationSelect()
保管場所の選択オプション情報を作成します。
StorageLocationSelect(int index)
保管場所の選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getStlocHigh() 終了保管場所を取得します。
String | getStlocLow() 開始保管場所を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setStlocHigh(String strStlocHigh) 終了保管場所を設定します。
void | setStlocLow(String strStlocLow) 開始保管場所を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationSelect

public StorageLocationSelect()
保管場所の選択オプション情報を作成します。

StorageLocationSelect

public StorageLocationSelect(int index)
保管場所の選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStlocLow

public String getStlocLow()
開始保管場所を取得します。

戻り値:
srtStlocLow

getStlocHigh

public String getStlocHigh()
終了保管場所を取得します。

戻り値:
srtStlocHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index

setStlocLow

public void setStlocLow(String strStlocLow)
開始保管場所を設定します。

パラメータ:
strStlocLow - 開始保管場所

setStlocHigh

public void setStlocHigh(String strStlocHigh)
終了保管場所を設定します。

パラメータ:
strStlocHigh - 終了保管場所

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail
すべての実装インタフェース:
Serializable
public class SupplierDetail
extends ReferenceController
implements Serializable

仕入先マスタ詳細情報クラス
機能は以下の通り

  • 仕入先マスタの詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先マスタ詳細を作成します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getCompCode() 会社コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
String | getVendor() 仕入先コードを取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setCompCode(String strCompode) 会社コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setVendor(String strVendor) 仕入先コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierDetail

public SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierDetail

public SupplierDetail(String vendor,
                      String compCode,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPPurchaseAppException,
                      SAPPurchaseSystemException
executeBapiを呼び出し仕入先マスタ詳細を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先マスタ詳細を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
strVendor 仕入先コード

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompode)
会社コードを設定します｡

パラメータ:
strCompode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierExistenceCheck (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierExistenceCheck

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck
すべての実装インタフェース:
Serializable
public class SupplierExistenceCheck
extends ReferenceController
implements Serializable

仕入先コード存在チェッククラス
機能は以下の通り

  • 仕入先コード存在チェック結果を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先コード存在チェックを作成します。
String | getCheckReturn() 結果を取得します｡
String | getCompCode() 会社コードを取得します｡
String | getVendor() 仕入先コードを取得します｡
void | setCheckReturn(String checkReturn) 結果を設定します｡
void | setCompCode(String strCompCode) 会社コードを設定します｡
void | setVendor(String strVendor) 仕入先コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierExistenceCheck

public SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierExistenceCheck

public SupplierExistenceCheck(String vendor,
                              String compCode,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPPurchaseAppException,
                              SAPPurchaseSystemException
executeBapiを呼び出し仕入先コード存在チェックを作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先コード存在チェックを作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
strVendor 仕入先コード

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompCode 会社コード

getCheckReturn

public String getCheckReturn()
結果を取得します｡

戻り値:
checkReturn 結果

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCheckReturn

public void setCheckReturn(String checkReturn)
結果を設定します｡

パラメータ:
checkReturn - 結果

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierExistenceCheckController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierExistenceCheckController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController
すべての実装インタフェース:
Serializable
public class SupplierExistenceCheckController
extends Object
implements Serializable

仕入先コード存在チェックコントローラ
機能は以下の通り

  • 仕入先コード存在チェックを行います。

関連項目:
直列化された形式

コンストラクタの概要
SupplierExistenceCheckController()
コンストラクタ生成
SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
メソッドの概要
 void executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 String getCheckReturn()
結果情報を取得します｡
 String getCompCode()
会社コードを取得します｡
 SupplierExistenceCheck getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡
 String getVendor()
仕入先コードを取得します｡
static void setCheckReturn(String checkReturn)
結果を設定します｡
 void setCompCode(String strCompCode)
会社コードを設定します｡
 void setVendor(String strVendor)
仕入先コードを設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierExistenceCheckController

public SupplierExistenceCheckController()
コンストラクタ生成

SupplierExistenceCheckController

public SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierExistenceCheckController

public SupplierExistenceCheckController(String vendor,
                                        String compCode)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPPurchaseAppException,
                                        SAPPurchaseSystemException
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

SupplierExistenceCheckController

public SupplierExistenceCheckController(String vendor,
                                        String compCode,
                                        SapClient sapClient)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPPurchaseAppException,
                                        SAPPurchaseSystemException
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCheckReturn

public static void setCheckReturn(String checkReturn)
結果を設定します｡

パラメータ:
checkReturn - 結果

getSupplierExistenceCheck

public SupplierExistenceCheck getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡

戻り値:
supplierExistenceCheck

getCheckReturn

public String getCheckReturn()
結果情報を取得します｡

戻り値:
checkReturn

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
vendor

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController
すべての実装インタフェース:
Serializable
public class SupplierGetDetailController
extends Object
implements Serializable

仕入先マスタの詳細情報取得コントローラ
機能は以下の通り

  • 仕入先マスタの詳細情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
SupplierGetDetailController()
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
メソッドの概要
 void executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 ArrayList getBankDataList()
銀行データ情報を取得します。
 CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡
 GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡
 SupplierDetail getSupplierDetail()
仕入先マスタ詳細情報を取得します｡
 void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡
 void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡
 void setCompCode(String strCompode)
会社コードを設定します｡
 void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡
 void setVendor(String strVendor)
仕入先コードを設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierGetDetailController

public SupplierGetDetailController()
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

SupplierGetDetailController

public SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierGetDetailController

public SupplierGetDetailController(String vendor,
                                   String compCode)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseAppException,
                                   SAPPurchaseSystemException
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

SupplierGetDetailController

public SupplierGetDetailController(String vendor,
                                   String compCode,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseAppException,
                                   SAPPurchaseSystemException
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

getSupplierDetail

public SupplierDetail getSupplierDetail()
仕入先マスタ詳細情報を取得します｡

戻り値:
SupplierDetail

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompode)
会社コードを設定します｡

パラメータ:
strCompode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VendorAddress (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス VendorAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
すべての実装インタフェース:
Serializable
public class VendorAddress
extends GeneralDataInfo

仕入先住所情報クラス
機能は以下の通り

  • 仕入先住所を保持します。

関連項目:
直列化された形式

コンストラクタの概要
VendorAddress()
入出庫予定を作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getLocation() 地名 5を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoNumber() 購買伝票番号を取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String strAddrNo) アドレス番号を設定します。
void | setAdrNotes(String strAdrNotes) 住所注記を設定します。
void | setBuilding(String strBuilding) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String strBuildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String strChckstatus) 市区町村ファイルテストステータスを設定します。
void | setCityNo(String strCityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String strCommType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String strCOName) 気付を設定します。
void | setDelivDis(String strDelivDis) 郵便配達地域を設定します。
void | setDistrctNo(String strDistrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setEMail(String strEMail) 電子メールアドレスを設定します。
void | setFaxExtens(String strFaxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String strFaxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String strFloor) 建物の階を設定します。
void | setHouseNo(String strHouseNo) 番地-号を設定します。
void | setHouseNo2(String strHouseNo2) 番地補足を設定します。
void | setLocation(String strLocation) 地名 5を設定します。
void | setPboxcitNo(String strPboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPoBoxCit(String strPoBoxCit) 私書箱住所を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setPostlCod1(String strPostlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String strPostlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String strPostlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setRegiogroup(String strRegiogroup) 地域構造グループ化を設定します。
void | setRoomNo(String strRoomNo) 部屋/アパート番号を設定します。
void | setSort1(String strSort1) 検索条件 1を設定します。
void | setSort2(String strSort2) 検索条件 2を設定します。
void | setStrAbbr(String strStrAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreetLng(String strStreetLng) 地名を設定します。
void | setStreetNo(String strStreetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strStrSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strStrSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strStrSuppl3) 地名 4を設定します。
void | setTaxjurcode(String strTaxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String strTel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String strTel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String strTimeZone) アドレスタイムゾーンを設定します。
void | setTitle(String strTitle) タイトル (敬称)を設定します。
void | setTranspzone(String strTranspzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo から継承したメソッド
getCity, getCityCode, getCountry, getCountryiso, getCountycode, getCustomer, getDistrict, getFax1, getFormofaddr, getLangu, getLanguIso, getName_2, getName_3, getName_4, getName, getPoBox, getPobxCty, getPobxPcd, getPostlCode, getRegion, getStreet, getTelephone, getTelephone2, getVendor, setCity, setCityCode, setCountry, setCountryiso, setCountycode, setCustomer, setDistrict, setFax1, setFormofaddr, setLangu, setLanguIso, setName_2, setName_3, setName_4, setName, setPoBox, setPobxCty, setPobxPcd, setPostlCode, setRegion, setStreet, setTelephone, setTelephone2, setVendor
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

VendorAddress

public VendorAddress()
入出庫予定を作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber 購買伝票番号

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
srtAddrNo アドレス番号

getCOName

public String getCOName()
気付を取得します。

戻り値:
srtCOName 気付

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
srtCityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
srtPostlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
srtPostlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
srtPostlCod3 会社郵便番号 (大規模なユーザ用)

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
srtPoBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
srtDelivDis 郵便配達地域

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
srtStreetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
srtStrAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
srtHouseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
srtStrSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
srtStrSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
srtLocation 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
srtBuilding 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
srtFloor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
srtRoomNo 部屋/アパート番号

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
srtSort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
srtSort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
srtTimeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
srtTaxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
srtAdrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
srtCommType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
srtTel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
srtTel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
srtFaxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
srtFaxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
srtStreetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
srtDistrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
srtChckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
srtPboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
srtTranspzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
srtHouseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
srtEMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
srtStrSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
srtTitle タイトル (敬称)

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
srtBuildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
srtRegiogroup 地域構造グループ化

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setAddrNo

public void setAddrNo(String strAddrNo)
アドレス番号を設定します。

パラメータ:
strAddrNo - アドレス番号

setCOName

public void setCOName(String strCOName)
気付を設定します。

パラメータ:
strCOName - 気付

setCityNo

public void setCityNo(String strCityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
strCityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String strPostlCod1)
市区町村の郵便番号を設定します。

パラメータ:
strPostlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String strPostlCod2)
私書箱郵便番号を設定します。

パラメータ:
strPostlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String strPostlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
strPostlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBoxCit

public void setPoBoxCit(String strPoBoxCit)
私書箱住所を設定します。

パラメータ:
strPoBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String strDelivDis)
郵便配達地域を設定します。

パラメータ:
strDelivDis - 郵便配達地域

setStreetNo

public void setStreetNo(String strStreetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
strStreetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strStrAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strStrAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String strHouseNo)
番地-号を設定します。

パラメータ:
strHouseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strStrSuppl1)
地名 2を設定します。

パラメータ:
strStrSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strStrSuppl2)
地名 3を設定します。

パラメータ:
strStrSuppl2 - 地名 3

setLocation

public void setLocation(String strLocation)
地名 5を設定します。

パラメータ:
strLocation - 地名 5

setBuilding

public void setBuilding(String strBuilding)
旧: 建物 (番号または略称)を設定します。

パラメータ:
strBuilding - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String strFloor)
建物の階を設定します。

パラメータ:
strFloor - 建物の階

setRoomNo

public void setRoomNo(String strRoomNo)
部屋/アパート番号を設定します。

パラメータ:
strRoomNo - 部屋/アパート番号

setSort1

public void setSort1(String strSort1)
検索条件 1を設定します。

パラメータ:
strSort1 - 検索条件 1

setSort2

public void setSort2(String strSort2)
検索条件 2を設定します。

パラメータ:
strSort2 - 検索条件 2

setTimeZone

public void setTimeZone(String strTimeZone)
アドレスタイムゾーンを設定します。

パラメータ:
strTimeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String strAdrNotes)
住所注記を設定します。

パラメータ:
strAdrNotes - 住所注記

setCommType

public void setCommType(String strCommType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
strCommType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String strTel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
strTel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String strTel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
strTel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String strFaxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
strFaxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String strFaxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
strFaxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String strStreetLng)
地名を設定します。

パラメータ:
strStreetLng - 地名

setDistrctNo

public void setDistrctNo(String strDistrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
strDistrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String strChckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
strChckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String strPboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
strPboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String strTranspzone)
商品の納入区域を設定します。

パラメータ:
strTranspzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String strHouseNo2)
番地補足を設定します。

パラメータ:
strHouseNo2 - 番地補足

setEMail

public void setEMail(String strEMail)
電子メールアドレスを設定します。

パラメータ:
strEMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strStrSuppl3)
地名 4を設定します。

パラメータ:
strStrSuppl3 - 地名 4

setTitle

public void setTitle(String strTitle)
タイトル (敬称)を設定します。

パラメータ:
strTitle - タイトル (敬称)

setBuildLong

public void setBuildLong(String strBuildLong)
建物 (番号またはコード)を設定します。

パラメータ:
strBuildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String strRegiogroup)
地域構造グループ化を設定します。

パラメータ:
strRegiogroup - 地域構造グループ化

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Versions (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Versions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Versions
すべての実装インタフェース:
Serializable
public class Versions
extends Object
implements Serializable

バージョン管理情報クラス
機能は以下の通り

  • バージョン管理情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Versions()
バージョン管理を作成します。
メソッドの概要
String | getActivity() 処理タイプを取得します。
String | getCompleted() ステータス "バージョン完了済"を取得します。
String | getDescription() バージョンテキスト（長）を取得します。
String | getPostDate() バージョンの転記日付を取得します。
String | getReason() 変更理由を取得します。
String | getReqBy() 変更を依頼した従業員を取得します。
String | getReqByExt() バージョンの外部変更番号を取得します。
void | setActivity(String strActivity) 処理タイプを設定します。
void | setCompleted(String strCompleted) ステータス "バージョン完了済"を設定します。
void | setDescription(String strDescription) バージョンテキスト（長）を設定します。
void | setPostDate(String strPostDate) バージョンの転記日付を設定します。
void | setReason(String strReason) 変更理由を設定します。
void | setReqBy(String strReqBy) 変更を依頼した従業員を設定します。
void | setReqByExt(String strReqByExt) バージョンの外部変更番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Versions

public Versions()
バージョン管理を作成します。

メソッドの詳細

getPostDate

public String getPostDate()
バージョンの転記日付を取得します。

戻り値:
srtPostDate バージョンの転記日付

getCompleted

public String getCompleted()
ステータス "バージョン完了済"を取得します。

戻り値:
srtCompleted ステータス "バージョン完了済"

getReason

public String getReason()
変更理由を取得します。

戻り値:
srtReason 変更理由

getDescription

public String getDescription()
バージョンテキスト（長）を取得します。

戻り値:
srtDescription バージョンテキスト（長）

getReqBy

public String getReqBy()
変更を依頼した従業員を取得します。

戻り値:
srtReqBy 変更を依頼した従業員

getReqByExt

public String getReqByExt()
バージョンの外部変更番号を取得します。

戻り値:
srtReqByExt バージョンの外部変更番号

getActivity

public String getActivity()
処理タイプを取得します。（SAP ERP6.0 では使用されない項目です。）

戻り値:
srtActivity 処理タイプ（SAP ERP6.0 では使用されない項目です。）

setPostDate

public void setPostDate(String strPostDate)
バージョンの転記日付を設定します。

パラメータ:
strPostDate - バージョンの転記日付

setCompleted

public void setCompleted(String strCompleted)
ステータス "バージョン完了済"を設定します。

パラメータ:
strCompleted - ステータス "バージョン完了済"

setReason

public void setReason(String strReason)
変更理由を設定します。

パラメータ:
strReason - 変更理由

setDescription

public void setDescription(String strDescription)
バージョンテキスト（長）を設定します。

パラメータ:
strDescription - バージョンテキスト（長）

setReqBy

public void setReqBy(String strReqBy)
変更を依頼した従業員を設定します。

パラメータ:
strReqBy - 変更を依頼した従業員

setReqByExt

public void setReqByExt(String strReqByExt)
バージョンの外部変更番号を設定します。

パラメータ:
strReqByExt - バージョンの外部変更番号

setActivity

public void setActivity(String strActivity)
処理タイプを設定します。（SAP ERP6.0 では使用されない項目です。）

パラメータ:
strActivity - 処理タイプ（SAP ERP6.0 では使用されない項目です。）

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple の使用

BillingDocCreateMultiple を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での BillingDocCreateMultiple の使用

jp.co.intra_mart.foundation.sap.module.sales での BillingDocCreateMultiple のサブクラス
 class BillingDocCreateMultipleController
請求伝票登録コントローラクラス
機能は以下の通り
請求伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn の使用

CreatorDataIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での CreatorDataIn の使用

CreatorDataIn を返す jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
 CreatorDataIn BillingDocCreateMultiple.getCreatorDataIn()
取り込まれる日付の順序を取得します。

CreatorDataIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
static void | ParamCreatorDataIn.setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn) 取り込まれる日付の順序の値をセットします。
void | BillingDocCreateMultiple.setCreatorDataIn(CreatorDataIn creatorDataIn) 取り込まれる日付の順序を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス BillingDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn
すべての実装インタフェース:
Serializable
public class BillingDataIn
extends Object
implements Serializable

処理予定明細データのテーブル情報クラス
機能は以下の通り

  • 処理予定明細データのテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDataIn()
処理予定明細データのテーブル情報を作成します。
BillingDataIn(int index)
処理予定明細データのテーブル情報を作成します。
メソッドの概要
String | getAcctasgnmt() 品目の勘定設定グループを取得します。
String | getAddrNo() アドレス: アドレス番号を取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillTo() 請求先を取得します。
String | getCity() 市区町村を取得します。
String | getConsumctry() 消費者の国キーを取得します。
String | getCostcenter() 原価センタを取得します。
String | getCountry() 出荷国 (商品発送国)を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDistrict() 所在地を取得します。
String | getDivision() 製品部門を取得します。
String | getDocNumber() 販売伝票を取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getExchangeRate() 価格設定/統計用換算レートを取得します。
String | getHgLvItem() BOM 構成の上位レベル明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ (2)を取得します。
int | getIndex() レコード番号を取得します｡
String | getItem() 開始明細を取得します。
String | getItemCateg() 明細カテゴリ (販売伝票)を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getNoMatmast() 品目マスタ確認禁止を取得します。
String | getOrdbilltyp() 受注関連請求伝票に対する提案請求伝票タイプを取得します。
String | getOrderid() 指図番号を取得します。
String | getOrigindoc() 開始伝票を取得します。
String | getParallelQty() Quantity in Parallel Unit of Measureを取得します。
String | getParallelUom() Parallel Unit of Measureを取得します。
String | getPayer() 支払人を取得します。
String | getPaymentTerms() 支払条件キーを取得します。
String | getPlant() プラントを取得します。
String | getPostlCode() 郵便番号を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getProdHier() 品目階層を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getPurchOrd() 出荷先発注番号を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocCa() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefItem() 参照明細番号を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesorg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getServDate() サービス提供日を取得します。
String | getShipTo() 出荷先を取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSoldTo() 受注先を取得します。
String | getStatGroup() 統計グループを取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTaxcl1Mat() 品目の税分類を取得します。
String | getTaxDepartCty() 税出荷国を取得します。
String | getTaxDestCty() 税仕向国を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTitle() 敬称を取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAcctasgnmt(String acctasgnmt) 品目の勘定設定グループを設定します。
void | setAddrNo(String addrNo) アドレス: アドレス番号を設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillTo(String billTo) 請求先を設定します。
void | setCity(String city) 市区町村を設定します。
void | setConsumctry(String consumctry) 消費者の国キーを設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCountry(String country) 出荷国 (商品発送国)を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setExchangeRate(String exchangeRate) 価格設定/統計用換算レートを設定します。
void | setHgLvItem(String hgLvItem) BOM 構成の上位レベル明細を設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ (2)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItem(String item) 開始明細を設定します。
void | setItemCateg(String itemCateg) 明細カテゴリ (販売伝票)を設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setNoMatmast(String noMatmast) 品目マスタ確認禁止を設定します。
void | setOrdbilltyp(String ordbilltyp) 受注関連請求伝票に対する提案請求伝票タイプを設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrigindoc(String origindoc) 開始伝票を設定します。
void | setParallelQty(String parallelQty) Quantity in Parallel Unit of Measureを設定します。
void | setParallelUom(String parallelUom) Parallel Unit of Measureを設定します。
void | setPayer(String payer) 支払人を設定します。
void | setPaymentTerms(String paymentTerms) 支払条件キーを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPostlCode(String postlCode) 郵便番号を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setPurchOrd(String purchOrd) 出荷先発注番号を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocCa(String refDocCa) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefItem(String refItem) 参照明細番号を設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesorg(String salesorg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipTo(String shipTo) 出荷先を設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSoldTo(String soldTo) 受注先を設定します。
void | setStatGroup(String statGroup) 統計グループを設定します。
void | setStreet(String street) 地名/番地-号を設定します。
void | setTaxcl1Mat(String taxcl1Mat) 品目の税分類を設定します。
void | setTaxDepartCty(String taxDepartCty) 税出荷国を設定します。
void | setTaxDestCty(String taxDestCty) 税仕向国を設定します。
void | setTaxjurcode(String taxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTitle(String title) 敬称を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDataIn

public BillingDataIn()
処理予定明細データのテーブル情報を作成します。

BillingDataIn

public BillingDataIn(int index)
処理予定明細データのテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSalesorg

public String getSalesorg()
販売組織を取得します。

戻り値:
salesorg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getOrdbilltyp

public String getOrdbilltyp()
受注関連請求伝票に対する提案請求伝票タイプを取得します。

戻り値:
ordbilltyp 受注関連請求伝票に対する提案請求伝票タイプ

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
soldTo 受注先

getItemCateg

public String getItemCateg()
明細カテゴリ (販売伝票)を取得します。

戻り値:
itemCateg 明細カテゴリ (販売伝票)

getAcctasgnmt

public String getAcctasgnmt()
品目の勘定設定グループを取得します。

戻り値:
acctasgnmt 品目の勘定設定グループ

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getCountry

public String getCountry()
出荷国 (商品発送国)を取得します。

戻り値:
country 出荷国 (商品発送国)

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getBillTo

public String getBillTo()
請求先を取得します。

戻り値:
billTo 請求先

getPayer

public String getPayer()
支払人を取得します。

戻り値:
payer 支払人

getShipTo

public String getShipTo()
出荷先を取得します。

戻り値:
shipTo 出荷先

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getTaxcl1Mat

public String getTaxcl1Mat()
品目の税分類を取得します。

戻り値:
taxcl1Mat 品目の税分類

getRefItem

public String getRefItem()
参照明細番号を取得します。

戻り値:
refItem 参照明細番号

getStatGroup

public String getStatGroup()
統計グループを取得します。

戻り値:
statGroup 統計グループ

getNoMatmast

public String getNoMatmast()
品目マスタ確認禁止を取得します。

戻り値:
noMatmast 品目マスタ確認禁止

getAddrNo

public String getAddrNo()
アドレス: アドレス番号を取得します。

戻り値:
addrNo アドレス: アドレス番号

getTitle

public String getTitle()
敬称を取得します。

戻り値:
title 敬称

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
postlCode 郵便番号

getConsumctry

public String getConsumctry()
消費者の国キーを取得します。

戻り値:
consumctry 消費者の国キー

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
street 地名/番地-号

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
taxjurcode 税計算管轄コード - 税管轄コード

getPurchOrd

public String getPurchOrd()
出荷先発注番号を取得します。

戻り値:
purchOrd 出荷先発注番号

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getOrigindoc

public String getOrigindoc()
開始伝票を取得します。

戻り値:
origindoc 開始伝票

getItem

public String getItem()
開始明細を取得します。

戻り値:
item 開始明細

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ (2)を取得します。

戻り値:
incoterms2 インコタームズ (2)

getExchangeRate

public String getExchangeRate()
価格設定/統計用換算レートを取得します。

戻り値:
exchangeRate 価格設定/統計用換算レート

getPaymentTerms

public String getPaymentTerms()
支払条件キーを取得します。

戻り値:
paymentTerms 支払条件キー

getHgLvItem

public String getHgLvItem()
BOM 構成の上位レベル明細を取得します。

戻り値:
hgLvItem BOM 構成の上位レベル明細

getRefDocCa

public String getRefDocCa()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refDocCa 先行販売管理伝票の伝票カテゴリ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getTaxDepartCty

public String getTaxDepartCty()
税出荷国を取得します。

戻り値:
taxDepartCty 税出荷国

getTaxDestCty

public String getTaxDestCty()
税仕向国を取得します。

戻り値:
taxDestCty 税仕向国

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getParallelQty

public String getParallelQty()
Quantity in Parallel Unit of Measureを取得します。

戻り値:
parallelQty Quantity in Parallel Unit of Measure

getParallelUom

public String getParallelUom()
Parallel Unit of Measureを取得します。

戻り値:
parallelUom Parallel Unit of Measure

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSalesorg

public void setSalesorg(String salesorg)
販売組織を設定します。

パラメータ:
salesorg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setOrdbilltyp

public void setOrdbilltyp(String ordbilltyp)
受注関連請求伝票に対する提案請求伝票タイプを設定します。

パラメータ:
ordbilltyp - 受注関連請求伝票に対する提案請求伝票タイプ

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setSoldTo

public void setSoldTo(String soldTo)
受注先を設定します。

パラメータ:
soldTo - 受注先

setItemCateg

public void setItemCateg(String itemCateg)
明細カテゴリ (販売伝票)を設定します。

パラメータ:
itemCateg - 明細カテゴリ (販売伝票)

setAcctasgnmt

public void setAcctasgnmt(String acctasgnmt)
品目の勘定設定グループを設定します。

パラメータ:
acctasgnmt - 品目の勘定設定グループ

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setCountry

public void setCountry(String country)
出荷国 (商品発送国)を設定します。

パラメータ:
country - 出荷国 (商品発送国)

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setBillTo

public void setBillTo(String billTo)
請求先を設定します。

パラメータ:
billTo - 請求先

setPayer

public void setPayer(String payer)
支払人を設定します。

パラメータ:
payer - 支払人

setShipTo

public void setShipTo(String shipTo)
出荷先を設定します。

パラメータ:
shipTo - 出荷先

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setTaxcl1Mat

public void setTaxcl1Mat(String taxcl1Mat)
品目の税分類を設定します。

パラメータ:
taxcl1Mat - 品目の税分類

setRefItem

public void setRefItem(String refItem)
参照明細番号を設定します。

パラメータ:
refItem - 参照明細番号

setStatGroup

public void setStatGroup(String statGroup)
統計グループを設定します。

パラメータ:
statGroup - 統計グループ

setNoMatmast

public void setNoMatmast(String noMatmast)
品目マスタ確認禁止を設定します。

パラメータ:
noMatmast - 品目マスタ確認禁止

setAddrNo

public void setAddrNo(String addrNo)
アドレス: アドレス番号を設定します。

パラメータ:
addrNo - アドレス: アドレス番号

setTitle

public void setTitle(String title)
敬称を設定します。

パラメータ:
title - 敬称

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setPostlCode

public void setPostlCode(String postlCode)
郵便番号を設定します。

パラメータ:
postlCode - 郵便番号

setConsumctry

public void setConsumctry(String consumctry)
消費者の国キーを設定します。

パラメータ:
consumctry - 消費者の国キー

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setStreet

public void setStreet(String street)
地名/番地-号を設定します。

パラメータ:
street - 地名/番地-号

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
taxjurcode - 税計算管轄コード - 税管轄コード

setPurchOrd

public void setPurchOrd(String purchOrd)
出荷先発注番号を設定します。

パラメータ:
purchOrd - 出荷先発注番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setOrigindoc

public void setOrigindoc(String origindoc)
開始伝票を設定します。

パラメータ:
origindoc - 開始伝票

setItem

public void setItem(String item)
開始明細を設定します。

パラメータ:
item - 開始明細

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ (2)を設定します。

パラメータ:
incoterms2 - インコタームズ (2)

setExchangeRate

public void setExchangeRate(String exchangeRate)
価格設定/統計用換算レートを設定します。

パラメータ:
exchangeRate - 価格設定/統計用換算レート

setPaymentTerms

public void setPaymentTerms(String paymentTerms)
支払条件キーを設定します。

パラメータ:
paymentTerms - 支払条件キー

setHgLvItem

public void setHgLvItem(String hgLvItem)
BOM 構成の上位レベル明細を設定します。

パラメータ:
hgLvItem - BOM 構成の上位レベル明細

setRefDocCa

public void setRefDocCa(String refDocCa)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refDocCa - 先行販売管理伝票の伝票カテゴリ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setTaxDepartCty

public void setTaxDepartCty(String taxDepartCty)
税出荷国を設定します。

パラメータ:
taxDepartCty - 税出荷国

setTaxDestCty

public void setTaxDestCty(String taxDestCty)
税仕向国を設定します。

パラメータ:
taxDestCty - 税仕向国

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setParallelQty

public void setParallelQty(String parallelQty)
Quantity in Parallel Unit of Measureを設定します。

パラメータ:
parallelQty - Quantity in Parallel Unit of Measure

setParallelUom

public void setParallelUom(String parallelUom)
Parallel Unit of Measureを設定します。

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocCreateMultiple (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス BillingDocCreateMultiple

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocCreateMultipleController
public class BillingDocCreateMultiple
extends UpdateController
implements Serializable

請求伝票登録情報クラス
機能は以下の通り

  • 請求伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocCreateMultiple()
請求伝票登録情報を作成します。
BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
List | getBillingDataInList() 処理予定明細データのテーブルを取得します。
List | getCCardDataInList() 処理予定支払方法のテーブルを取得します。
List | getConditionDataInList() 処理予定条件のテーブルを取得します。
CreatorDataIn | getCreatorDataIn() 取り込まれる日付の順序を取得します。
List | getErrorsList() 前明細の不正処理に関する情報を取得します。
String | getPosting() Posting category:postを取得します。
List | getSuccessList() 正常に処理された明細のテーブルを取得します。
String | getTestrun() シミュレーション実行 ('X')、更新実行 (' ')を取得します。
List | getTextDataInList() 請求インタフェースの通信構造テキストを取得します。
void | setBillingDataInList(List billingDataInList) 処理予定明細データのテーブルを設定します。
void | setCCardDataInList(List cCardDataInList) 処理予定支払方法のテーブルを設定します。
void | setConditionDataInList(List conditionDataInList) 処理予定条件のテーブルを設定します。
void | setCreatorDataIn(CreatorDataIn creatorDataIn) 取り込まれる日付の順序を設定します。
void | setErrorsList(List errorsList) 前明細の不正処理に関する情報を設定します。
void | setExportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | setImportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | setPosting(String posting) Posting category:postを設定します。
void | setSuccessList(List successList) 正常に処理された明細のテーブルを設定します。
void | setTestrun(String testrun) シミュレーション実行 ('X')、更新実行 (' ')を設定します。
void | setTextDataInList(List textDataInList) 請求インタフェースの通信構造テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocCreateMultiple

public BillingDocCreateMultiple()
請求伝票登録情報を作成します。

BillingDocCreateMultiple

public BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

BillingDocCreateMultiple

public BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
請求伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
請求伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
シミュレーション実行 ('X')、更新実行 (' ')を取得します。

戻り値:
testrun シミュレーション実行 ('X')、更新実行 (' ')

getCreatorDataIn

public CreatorDataIn getCreatorDataIn()
取り込まれる日付の順序を取得します。

戻り値:
creatorDataIn 取り込まれる日付の順序

getBillingDataInList

public List getBillingDataInList()
処理予定明細データのテーブルを取得します。

戻り値:
billingDataInList 処理予定明細データのテーブル

getCCardDataInList

public List getCCardDataInList()
処理予定支払方法のテーブルを取得します。

戻り値:
cCardDataInList 処理予定支払方法のテーブル

getConditionDataInList

public List getConditionDataInList()
処理予定条件のテーブルを取得します。

戻り値:
conditionDataInList 処理予定条件のテーブル

getErrorsList

public List getErrorsList()
前明細の不正処理に関する情報を取得します。

戻り値:
errorsList 前明細の不正処理に関する情報

getSuccessList

public List getSuccessList()
正常に処理された明細のテーブルを取得します。

戻り値:
successList 正常に処理された明細のテーブル

getTextDataInList

public List getTextDataInList()
請求インタフェースの通信構造テキストを取得します。

戻り値:
textDataInList 請求インタフェースの通信構造テキスト

getPosting

public String getPosting()
Posting category:postを取得します。

戻り値:
posting Posting category:post

setTestrun

public void setTestrun(String testrun)
シミュレーション実行 ('X')、更新実行 (' ')を設定します。

パラメータ:
testrun - シミュレーション実行 ('X')、更新実行 (' ')

setCreatorDataIn

public void setCreatorDataIn(CreatorDataIn creatorDataIn)
取り込まれる日付の順序を設定します。

パラメータ:
creatorDataIn - 取り込まれる日付の順序

setBillingDataInList

public void setBillingDataInList(List billingDataInList)
処理予定明細データのテーブルを設定します。

パラメータ:
billingDataInList - 処理予定明細データのテーブル

setCCardDataInList

public void setCCardDataInList(List cCardDataInList)
処理予定支払方法のテーブルを設定します。

パラメータ:
cCardDataInList - 処理予定支払方法のテーブル

setConditionDataInList

public void setConditionDataInList(List conditionDataInList)
処理予定条件のテーブルを設定します。

パラメータ:
conditionDataInList - 処理予定条件のテーブル

setErrorsList

public void setErrorsList(List errorsList)
前明細の不正処理に関する情報を設定します。

パラメータ:
errorsList - 前明細の不正処理に関する情報

setSuccessList

public void setSuccessList(List successList)
正常に処理された明細のテーブルを設定します。

パラメータ:
successList - 正常に処理された明細のテーブル

setTextDataInList

public void setTextDataInList(List textDataInList)
請求インタフェースの通信構造テキストを設定します。

パラメータ:
textDataInList - 請求インタフェースの通信構造テキスト

setPosting

public void setPosting(String posting)
Posting category:postを設定します。

パラメータ:
posting - Posting category:post

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CCardDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス CCardDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn
すべての実装インタフェース:
Serializable
public class CCardDataIn
extends Object
implements Serializable

処理予定支払方法のテーブル情報クラス
機能は以下の通り

  • 処理予定支払方法のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CCardDataIn()
処理予定支払方法のテーブル情報を作成します。
CCardDataIn(int index)
処理予定支払方法のテーブル情報を作成します。
メソッドの概要
String | getAuthamount() 支払カード: 承認額を取得します。
String | getAuthDate() 支払カード: 承認日を取得します。
String | getAuthFlag() 支払カード: 振替権限を取得します。
String | getAuthRefno() 支払カード: 決済代行会社の権限参照コードを取得します。
String | getAuthTime() 支払カード: 承認時刻を取得します。
String | getBillPlan() 請求計画番号を取得します。
String | getBillPlani() 明細: 請求計画/支払計画/支払カードを取得します。
String | getBillValue() 請求金額: 請求計画に請求日付が指定されている場合を取得します。
String | getCcAuthNo() 支払カード: 承認番号を取得します。
String | getCcLocId() 支払カード: トランザクション (入庫時点)を取得します。
String | getCcName() 支払カード: カード所有者の氏名を取得します。
String | getCcNumber() 支払カード: カード番号を取得します。
String | getCcSeqNo() 支払カード: 支払カード - 接尾辞を取得します。
String | getCcSettled() 支払カード: 決済終了を取得します。
String | getCcType() 支払カードタイプ: カードタイプを取得します。
String | getCcValidF() 支払カード: 使用有効開始日付を取得します。
String | getCcValidT() 支払カード: 有効終了日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDataorigin() 支払カード: 入力モードを取得します。
int | getIndex() レコード番号を取得します｡
String | getMerchidcl() 支払カード: 決済代行会社のマーチャント IDを取得します。
String | getPaytype() 支払手段: 支払カード計画の明細分類を取得します。
String | getTerminal() 支払カード: 端末を取得します。
void | setAuthamount(String authamount) 支払カード: 承認額を設定します。
void | setAuthDate(String authDate) 支払カード: 承認日を設定します。
void | setAuthFlag(String authFlag) 支払カード: 振替権限を設定します。
void | setAuthRefno(String authRefno) 支払カード: 決済代行会社の権限参照コードを設定します。
void | setAuthTime(String authTime) 支払カード: 承認時刻を設定します。
void | setBillPlan(String billPlan) 請求計画番号を設定します。
void | setBillPlani(String billPlani) 明細: 請求計画/支払計画/支払カードを設定します。
void | setBillValue(String billValue) 請求金額: 請求計画に請求日付が指定されている場合を設定します。
void | setCcAuthNo(String ccAuthNo) 支払カード: 承認番号を設定します。
void | setCcLocId(String ccLocId) 支払カード: トランザクション (入庫時点)を設定します。
void | setCcName(String ccName) 支払カード: カード所有者の氏名を設定します。
void | setCcNumber(String ccNumber) 支払カード: カード番号を設定します。
void | setCcSeqNo(String ccSeqNo) 支払カード: 支払カード - 接尾辞を設定します。
void | setCcSettled(String ccSettled) 支払カード: 決済終了を設定します。
void | setCcType(String ccType) 支払カードタイプ: カードタイプを設定します。
void | setCcValidF(String ccValidF) 支払カード: 使用有効開始日付を設定します。
void | setCcValidT(String ccValidT) 支払カード: 有効終了日を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setDataorigin(String dataorigin) 支払カード: 入力モードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMerchidcl(String merchidcl) 支払カード: 決済代行会社のマーチャント IDを設定します。
void | setPaytype(String paytype) 支払手段: 支払カード計画の明細分類を設定します。
void | setTerminal(String terminal) 支払カード: 端末を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CCardDataIn

public CCardDataIn()
処理予定支払方法のテーブル情報を作成します。

CCardDataIn

public CCardDataIn(int index)
処理予定支払方法のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPaytype

public String getPaytype()
支払手段: 支払カード計画の明細分類を取得します。

戻り値:
paytype 支払手段: 支払カード計画の明細分類

getCcType

public String getCcType()
支払カードタイプ: カードタイプを取得します。

戻り値:
ccType 支払カードタイプ: カードタイプ

getCcNumber

public String getCcNumber()
支払カード: カード番号を取得します。

戻り値:
ccNumber 支払カード: カード番号

getCcSeqNo

public String getCcSeqNo()
支払カード: 支払カード - 接尾辞を取得します。

戻り値:
ccSeqNo 支払カード: 支払カード - 接尾辞

getCcValidF

public String getCcValidF()
支払カード: 使用有効開始日付を取得します。

戻り値:
ccValidF 支払カード: 使用有効開始日付

getCcValidT

public String getCcValidT()
支払カード: 有効終了日を取得します。

戻り値:
ccValidT 支払カード: 有効終了日

getCcName

public String getCcName()
支払カード: カード所有者の氏名を取得します。

戻り値:
ccName 支払カード: カード所有者の氏名

getAuthamount

public String getAuthamount()
支払カード: 承認額を取得します。

戻り値:
authamount 支払カード: 承認額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getAuthFlag

public String getAuthFlag()
支払カード: 振替権限を取得します。

戻り値:
authFlag 支払カード: 振替権限

getAuthDate

public String getAuthDate()
支払カード: 承認日を取得します。

戻り値:
authDate 支払カード: 承認日

getAuthTime

public String getAuthTime()
支払カード: 承認時刻を取得します。

戻り値:
authTime 支払カード: 承認時刻

getCcAuthNo

public String getCcAuthNo()
支払カード: 承認番号を取得します。

戻り値:
ccAuthNo 支払カード: 承認番号

getAuthRefno

public String getAuthRefno()
支払カード: 決済代行会社の権限参照コードを取得します。

戻り値:
authRefno 支払カード: 決済代行会社の権限参照コード

getMerchidcl

public String getMerchidcl()
支払カード: 決済代行会社のマーチャント IDを取得します。

戻り値:
merchidcl 支払カード: 決済代行会社のマーチャント ID

getTerminal

public String getTerminal()
支払カード: 端末を取得します。

戻り値:
terminal 支払カード: 端末

getDataorigin

public String getDataorigin()
支払カード: 入力モードを取得します。

戻り値:
dataorigin 支払カード: 入力モード

getCcSettled

public String getCcSettled()
支払カード: 決済終了を取得します。

戻り値:
ccSettled 支払カード: 決済終了

getCcLocId

public String getCcLocId()
支払カード: トランザクション (入庫時点)を取得します。

戻り値:
ccLocId 支払カード: トランザクション (入庫時点)

getBillPlan

public String getBillPlan()
請求計画番号を取得します。

戻り値:
billPlan 請求計画番号

getBillPlani

public String getBillPlani()
明細: 請求計画/支払計画/支払カードを取得します。

戻り値:
billPlani 明細: 請求計画/支払計画/支払カード

getBillValue

public String getBillValue()
請求金額: 請求計画に請求日付が指定されている場合を取得します。

戻り値:
billValue 請求金額: 請求計画に請求日付が指定されている場合

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPaytype

public void setPaytype(String paytype)
支払手段: 支払カード計画の明細分類を設定します。

パラメータ:
paytype - 支払手段: 支払カード計画の明細分類

setCcType

public void setCcType(String ccType)
支払カードタイプ: カードタイプを設定します。

パラメータ:
ccType - 支払カードタイプ: カードタイプ

setCcNumber

public void setCcNumber(String ccNumber)
支払カード: カード番号を設定します。

パラメータ:
ccNumber - 支払カード: カード番号

setCcSeqNo

public void setCcSeqNo(String ccSeqNo)
支払カード: 支払カード - 接尾辞を設定します。

パラメータ:
ccSeqNo - 支払カード: 支払カード - 接尾辞

setCcValidF

public void setCcValidF(String ccValidF)
支払カード: 使用有効開始日付を設定します。

パラメータ:
ccValidF - 支払カード: 使用有効開始日付

setCcValidT

public void setCcValidT(String ccValidT)
支払カード: 有効終了日を設定します。

パラメータ:
ccValidT - 支払カード: 有効終了日

setCcName

public void setCcName(String ccName)
支払カード: カード所有者の氏名を設定します。

パラメータ:
ccName - 支払カード: カード所有者の氏名

setAuthamount

public void setAuthamount(String authamount)
支払カード: 承認額を設定します。

パラメータ:
authamount - 支払カード: 承認額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setAuthFlag

public void setAuthFlag(String authFlag)
支払カード: 振替権限を設定します。

パラメータ:
authFlag - 支払カード: 振替権限

setAuthDate

public void setAuthDate(String authDate)
支払カード: 承認日を設定します。

パラメータ:
authDate - 支払カード: 承認日

setAuthTime

public void setAuthTime(String authTime)
支払カード: 承認時刻を設定します。

パラメータ:
authTime - 支払カード: 承認時刻

setCcAuthNo

public void setCcAuthNo(String ccAuthNo)
支払カード: 承認番号を設定します。

パラメータ:
ccAuthNo - 支払カード: 承認番号

setAuthRefno

public void setAuthRefno(String authRefno)
支払カード: 決済代行会社の権限参照コードを設定します。

パラメータ:
authRefno - 支払カード: 決済代行会社の権限参照コード

setMerchidcl

public void setMerchidcl(String merchidcl)
支払カード: 決済代行会社のマーチャント IDを設定します。

パラメータ:
merchidcl - 支払カード: 決済代行会社のマーチャント ID

setTerminal

public void setTerminal(String terminal)
支払カード: 端末を設定します。

パラメータ:
terminal - 支払カード: 端末

setDataorigin

public void setDataorigin(String dataorigin)
支払カード: 入力モードを設定します。

パラメータ:
dataorigin - 支払カード: 入力モード

setCcSettled

public void setCcSettled(String ccSettled)
支払カード: 決済終了を設定します。

パラメータ:
ccSettled - 支払カード: 決済終了

setCcLocId

public void setCcLocId(String ccLocId)
支払カード: トランザクション (入庫時点)を設定します。

パラメータ:
ccLocId - 支払カード: トランザクション (入庫時点)

setBillPlan

public void setBillPlan(String billPlan)
請求計画番号を設定します。

パラメータ:
billPlan - 請求計画番号

setBillPlani

public void setBillPlani(String billPlani)
明細: 請求計画/支払計画/支払カードを設定します。

パラメータ:
billPlani - 明細: 請求計画/支払計画/支払カード

setBillValue

public void setBillValue(String billValue)
請求金額: 請求計画に請求日付が指定されている場合を設定します。

パラメータ:
billValue - 請求金額: 請求計画に請求日付が指定されている場合

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ConditionDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn
すべての実装インタフェース:
Serializable
public class ConditionDataIn
extends Object
implements Serializable

処理予定条件のテーブル情報クラス
機能は以下の通り

  • 処理予定条件のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionDataIn()
処理予定条件のテーブル情報を作成します。
ConditionDataIn(int index)
処理予定条件のテーブル情報を作成します。
メソッドの概要
String | getCondCurr() 条件通貨 (累積項目用)を取得します。
String | getCondDUnt() 伝票の条件単位を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondValue() 条件金額/率を取得します。
String | getDataIndex() 別の構成のテーブル入力へのポインタを取得します。
int | getIndex() レコード番号を取得します｡
void | setCondCurr(String condCurr) 条件通貨 (累積項目用)を設定します。
void | setCondDUnt(String condDUnt) 伝票の条件単位を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondValue(String condValue) 条件金額/率を設定します。
void | setDataIndex(String dataIndex) 別の構成のテーブル入力へのポインタを設定します。
void | setIndex(int index) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionDataIn

public ConditionDataIn()
処理予定条件のテーブル情報を作成します。

ConditionDataIn

public ConditionDataIn(int index)
処理予定条件のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDataIndex

public String getDataIndex()
別の構成のテーブル入力へのポインタを取得します。

戻り値:
dataIndex 別の構成のテーブル入力へのポインタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getCondValue

public String getCondValue()
条件金額/率を取得します。

戻り値:
condValue 条件金額/率

getCondCurr

public String getCondCurr()
条件通貨 (累積項目用)を取得します。

戻り値:
condCurr 条件通貨 (累積項目用)

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondDUnt

public String getCondDUnt()
伝票の条件単位を取得します。

戻り値:
condDUnt 伝票の条件単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDataIndex

public void setDataIndex(String dataIndex)
別の構成のテーブル入力へのポインタを設定します。

パラメータ:
dataIndex - 別の構成のテーブル入力へのポインタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setCondValue

public void setCondValue(String condValue)
条件金額/率を設定します。

パラメータ:
condValue - 条件金額/率

setCondCurr

public void setCondCurr(String condCurr)
条件通貨 (累積項目用)を設定します。

パラメータ:
condCurr - 条件通貨 (累積項目用)

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondDUnt

public void setCondDUnt(String condDUnt)
伝票の条件単位を設定します。

パラメータ:
condDUnt - 伝票の条件単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreatorDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス CreatorDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn
すべての実装インタフェース:
Serializable
public class CreatorDataIn
extends Object
implements Serializable

取り込まれる日付の順序情報クラス
機能は以下の通り

  • 取り込まれる日付の順序情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CreatorDataIn()
取り込まれる日付の順序情報を作成します。
メソッドの概要
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCreatedOn() レコード登録日を取得します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCreatedOn(String createdOn) レコード登録日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreatorDataIn

public CreatorDataIn()
取り込まれる日付の順序情報を作成します。

メソッドの詳細

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getCreatedOn

public String getCreatedOn()
レコード登録日を取得します。

戻り値:
createdOn レコード登録日

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setCreatedOn

public void setCreatedOn(String createdOn)
レコード登録日を設定します。

パラメータ:
createdOn - レコード登録日

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Errors (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス Errors

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors
すべての実装インタフェース:
Serializable
public class Errors
extends Object
implements Serializable

前明細の不正処理に関する情報情報クラス
機能は以下の通り

  • 前明細の不正処理に関する情報情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Errors()
前明細の不正処理に関する情報情報を作成します。
Errors(int index)
前明細の不正処理に関する情報情報を作成します。
メソッドの概要
String | getId() メッセージ、メッセージクラスを取得します。
int | getIndex() レコード番号を取得します｡
String | getLogMsgNo() アプリケーションログ: メッセージシリアル番号を取得します。
String | getLogNo() アプリケーションログ: ログ番号を取得します。
String | getMessage() メッセージテキストを取得します。
String | getMessageV1() メッセージ、メッセージ変数を取得します。
String | getMessageV2() メッセージ、メッセージ変数を取得します。
String | getMessageV3() メッセージ、メッセージ変数を取得します。
String | getMessageV4() メッセージ、メッセージ変数を取得します。
String | getNumber() メッセージ、メッセージ番号を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocItem() 参照明細番号を取得します。
String | getType() メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
void | setId(String id) メッセージ、メッセージクラスを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLogMsgNo(String logMsgNo) アプリケーションログ: メッセージシリアル番号を設定します。
void | setLogNo(String logNo) アプリケーションログ: ログ番号を設定します。
void | setMessage(String message) メッセージテキストを設定します。
void | setMessageV1(String messageV1) メッセージ、メッセージ変数を設定します。
void | setMessageV2(String messageV2) メッセージ、メッセージ変数を設定します。
void | setMessageV3(String messageV3) メッセージ、メッセージ変数を設定します。
void | setMessageV4(String messageV4) メッセージ、メッセージ変数を設定します。
void | setNumber(String number) メッセージ、メッセージ番号を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocItem(String refDocItem) 参照明細番号を設定します。
void | setType(String type) メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Errors

public Errors()
前明細の不正処理に関する情報情報を作成します。

Errors

public Errors(int index)
前明細の不正処理に関する情報情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocItem

public String getRefDocItem()
参照明細番号を取得します。

戻り値:
refDocItem 参照明細番号

getType

public String getType()
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。

戻り値:
type メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

getId

public String getId()
メッセージ、メッセージクラスを取得します。

戻り値:
id メッセージ、メッセージクラス

getNumber

public String getNumber()
メッセージ、メッセージ番号を取得します。

戻り値:
number メッセージ、メッセージ番号

getMessage

public String getMessage()
メッセージテキストを取得します。

戻り値:
message メッセージテキスト

getLogNo

public String getLogNo()
アプリケーションログ: ログ番号を取得します。

戻り値:
logNo アプリケーションログ: ログ番号

getLogMsgNo

public String getLogMsgNo()
アプリケーションログ: メッセージシリアル番号を取得します。

戻り値:
logMsgNo アプリケーションログ: メッセージシリアル番号

getMessageV1

public String getMessageV1()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV1 メッセージ、メッセージ変数

getMessageV2

public String getMessageV2()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV2 メッセージ、メッセージ変数

getMessageV3

public String getMessageV3()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV3 メッセージ、メッセージ変数

getMessageV4

public String getMessageV4()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV4 メッセージ、メッセージ変数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocItem

public void setRefDocItem(String refDocItem)
参照明細番号を設定します。

パラメータ:
refDocItem - 参照明細番号

setType

public void setType(String type)
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。

パラメータ:
type - メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

setId

public void setId(String id)
メッセージ、メッセージクラスを設定します。

パラメータ:
id - メッセージ、メッセージクラス

setNumber

public void setNumber(String number)
メッセージ、メッセージ番号を設定します。

パラメータ:
number - メッセージ、メッセージ番号

setMessage

public void setMessage(String message)
メッセージテキストを設定します。

パラメータ:
message - メッセージテキスト

setLogNo

public void setLogNo(String logNo)
アプリケーションログ: ログ番号を設定します。

パラメータ:
logNo - アプリケーションログ: ログ番号

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
アプリケーションログ: メッセージシリアル番号を設定します。

パラメータ:
logMsgNo - アプリケーションログ: メッセージシリアル番号

setMessageV1

public void setMessageV1(String messageV1)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV1 - メッセージ、メッセージ変数

setMessageV2

public void setMessageV2(String messageV2)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV2 - メッセージ、メッセージ変数

setMessageV3

public void setMessageV3(String messageV3)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV3 - メッセージ、メッセージ変数

setMessageV4

public void setMessageV4(String messageV4)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV4 - メッセージ、メッセージ変数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス
BillingDataIn
BillingDocCreateMultiple
CCardDataIn
ConditionDataIn
CreatorDataIn
Errors
ParamBillingDataIn
ParamCCardDataIn
ParamConditionDataIn
ParamCreatorDataIn
ParamErrors
ParamTextDataIn
TextDataIn


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

クラスの概要
BillingDataIn | 処理予定明細データのテーブル情報クラス 機能は以下の通り 処理予定明細データのテーブル情報を保持します。
BillingDocCreateMultiple | 請求伝票登録情報クラス 機能は以下の通り 請求伝票登録情報を保持します。
CCardDataIn | 処理予定支払方法のテーブル情報クラス 機能は以下の通り 処理予定支払方法のテーブル情報を保持します。
ConditionDataIn | 処理予定条件のテーブル情報クラス 機能は以下の通り 処理予定条件のテーブル情報を保持します。
CreatorDataIn | 取り込まれる日付の順序情報クラス 機能は以下の通り 取り込まれる日付の順序情報を保持します。
Errors | 前明細の不正処理に関する情報情報クラス 機能は以下の通り 前明細の不正処理に関する情報情報を保持します。
ParamBillingDataIn | 処理予定明細データのテーブルパラメータ設定クラス 機能は以下の通り 処理予定明細データのテーブルパラメータを設定します。
ParamCCardDataIn | 処理予定支払方法のテーブルパラメータ設定クラス 機能は以下の通り 処理予定支払方法のテーブルパラメータを設定します。
ParamConditionDataIn | 処理予定条件のテーブルパラメータ設定クラス 機能は以下の通り 処理予定条件のテーブルのパラメータを設定します。
ParamCreatorDataIn | 取り込まれる日付の順序パラメータ設定クラス 機能は以下の通り 取り込まれる日付の順序のパラメータを設定します。
ParamErrors | 前明細の不正処理に関する情報パラメータ設定クラス 機能は以下の通り 前明細の不正処理に関する情報のパラメータを設定します。
ParamTextDataIn | 請求インタフェースの通信構造テキストパラメータ設定クラス 機能は以下の通り 請求インタフェースの通信構造テキストのパラメータを設定します。
TextDataIn | 請求インタフェースの通信構造テキスト情報クラス 機能は以下の通り 請求インタフェースの通信構造テキスト情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のクラス
BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のクラス
CreatorDataIn
取り込まれる日付の順序情報クラス
機能は以下の通り
取り込まれる日付の順序情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBillingDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamBillingDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn
すべての実装インタフェース:
Serializable
public final class ParamBillingDataIn
extends Object
implements Serializable

処理予定明細データのテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定明細データのテーブルパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List billingDataInList) table(Export)情報から処理予定明細データのテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List billingDataInList) 処理予定明細データのテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List billingDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定明細データのテーブルの値をセットします。

パラメータ:
bapiController - BapiController
billingDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List billingDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から処理予定明細データのテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
billingDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCCardDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamCCardDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn
すべての実装インタフェース:
Serializable
public final class ParamCCardDataIn
extends Object
implements Serializable

処理予定支払方法のテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定支払方法のテーブルパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cCardDataInList) table(Export)情報から理予定支払方法のテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List cCardDataInList) 処理予定支払方法のテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cCardDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定支払方法のテーブルの値をセットします。

パラメータ:
bapiController - BapiController
cCardDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cCardDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から理予定支払方法のテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cCardDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamConditionDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn
すべての実装インタフェース:
Serializable
public final class ParamConditionDataIn
extends Object
implements Serializable

処理予定条件のテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定条件のテーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionDataInList) table(Export)情報から処理予定条件のテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List conditionDataInList) 処理予定条件のテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定条件のテーブルの値をセットします。

パラメータ:
bapiController - BapiController
conditionDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から処理予定条件のテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCreatorDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamCreatorDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn
すべての実装インタフェース:
Serializable
public final class ParamCreatorDataIn
extends Object
implements Serializable

取り込まれる日付の順序パラメータ設定クラス
機能は以下の通り

  • 取り込まれる日付の順序のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn)
取り込まれる日付の順序の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  CreatorDataIn creatorDataIn)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
取り込まれる日付の順序の値をセットします。

パラメータ:
bapiController - BapiController
creatorDataIn - CreatorDataIn
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamErrors (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamErrors

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors
すべての実装インタフェース:
Serializable
public final class ParamErrors
extends Object
implements Serializable

前明細の不正処理に関する情報パラメータ設定クラス
機能は以下の通り

  • 前明細の不正処理に関する情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List errorsList) table(Export)情報から前明細の不正処理に関する情報の値をセットします。
static void | setImportParam(BapiController bapiController, List errorsList) 前明細の不正処理に関する情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List errorsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
前明細の不正処理に関する情報の値をセットします。

パラメータ:
bapiController - BapiController
errorsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List errorsList)
                           throws SAPGeneralSystemException
table(Export)情報から前明細の不正処理に関する情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
errorsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTextDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamTextDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn
すべての実装インタフェース:
Serializable
public final class ParamTextDataIn
extends Object
implements Serializable

請求インタフェースの通信構造テキストパラメータ設定クラス
機能は以下の通り

  • 請求インタフェースの通信構造テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List textDataInList) table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
static void | setImportParam(BapiController bapiController, List textDataInList) 請求インタフェースの通信構造テキストの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List textDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
請求インタフェースの通信構造テキストの値をセットします。

パラメータ:
bapiController - BapiController
textDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List textDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
textDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextDataIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス TextDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn
すべての実装インタフェース:
Serializable
public class TextDataIn
extends Object
implements Serializable

請求インタフェースの通信構造テキスト情報クラス
機能は以下の通り

  • 請求インタフェースの通信構造テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TextDataIn()
請求インタフェースの通信構造テキスト情報を作成します。
TextDataIn(int index)
請求インタフェースの通信構造テキスト情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getFormatCol() タグ列を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefItem() 参照明細番号を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefItem(String refItem) 参照明細番号を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TextDataIn

public TextDataIn()
請求インタフェースの通信構造テキスト情報を作成します。

TextDataIn

public TextDataIn(int index)
請求インタフェースの通信構造テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefItem

public String getRefItem()
参照明細番号を取得します。

戻り値:
refItem 参照明細番号

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefItem

public void setRefItem(String refItem)
参照明細番号を設定します。

パラメータ:
refItem - 参照明細番号

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocGetDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
クラス BillingDocGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail
すべての実装インタフェース:
Serializable
public class BillingDocGetDetail
extends ReferenceController
implements Serializable

請求伝票詳細照会情報クラス
機能は以下の通り

  • 請求伝票詳細照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。
メソッドの概要
 void executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。
 String getBillingdocument()
処理予定の請求伝票数を取得します。
 BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。
 void setBillingdocument(String billingdocument)
処理予定の請求伝票数を設定します。
 void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。
 void setExportParam(BapiController bapiController)
返却された請求伝票詳細照会情報をセットします。
 String toString()
デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetDetail

public BillingDocGetDetail(String billingdocument,
                           SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPSalesAppException,
                           SAPSalesSystemException
請求伝票詳細照会情報を作成します。

パラメータ:
sapClient - SapClient SAPクライアント
billingdocument - String 請求伝票
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された請求伝票詳細照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getBillingdocument

public String getBillingdocument()
処理予定の請求伝票数を取得します。

戻り値:
billingdocument 処理予定の請求伝票数

getBillingDocumentDetail

public BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

戻り値:
billingDocumentDetail 請求伝票に関する詳細情報

setBillingdocument

public void setBillingdocument(String billingdocument)
処理予定の請求伝票数を設定します。

パラメータ:
billingdocument - 処理予定の請求伝票数

setBillingDocumentDetail

public void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

パラメータ:
billingDocumentDetail - 請求伝票に関する詳細情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
クラス
BillingDocGetDetail


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

クラスの概要
BillingDocGetDetail 請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList の使用

BillingDocGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での BillingDocGetList の使用

jp.co.intra_mart.foundation.sap.module.sales での BillingDocGetList のサブクラス
 class BillingDocGetListController
請求伝票一覧照会情報コントローラクラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange の使用

RefDocRange を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での RefDocRange の使用

RefDocRange を返す jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
 RefDocRange BillingDocGetList.getRefDocRange()
前伝票の範囲を取得します。

RefDocRange 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
static void | ParamRefDocRange.setImportParam(BapiController bapiController, RefDocRange refDocRange) 前伝票の範囲の値をセットします。
void | BillingDocGetList.setRefDocRange(RefDocRange refDocRange) 前伝票の範囲を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocGetList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス BillingDocGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocGetListController
public class BillingDocGetList
extends ReferenceController
implements Serializable

請求伝票一覧照会情報クラス
機能は以下の通り

  • 請求伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。
BillingDocGetList(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
請求伝票一覧照会情報を作成します。
メソッドの概要
List | getBillingDocumentDetailListList() 後続請求伝票のテーブルを取得します。
RefDocRange | getRefDocRange() 前伝票の範囲を取得します。
List | getSuccessList() 後続請求伝票の明細テーブルを取得します。
void | setBillingDocumentDetailListList(ArrayList billingDocumentDetailListList) 後続請求伝票のテーブルを設定します。
void | setExportParam(BapiController bapiController) 取得した請求伝票一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
void | setRefDocRange(RefDocRange refDocRange) 前伝票の範囲を設定します。
void | setSuccessList(ArrayList successList) 後続請求伝票の明細テーブルを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetList

public BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

BillingDocGetList

public BillingDocGetList(String sign,
                         String option,
                         String refDocRow,
                         String refDocHigh,
                         SapClient sapClient)
請求伝票一覧照会情報を作成します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号
sapClient - SAPクライアント
メソッドの詳細

getRefDocRange

public RefDocRange getRefDocRange()
前伝票の範囲を取得します。

戻り値:
refDocRange 前伝票の範囲

getBillingDocumentDetailListList

public List getBillingDocumentDetailListList()
後続請求伝票のテーブルを取得します。

戻り値:
billingDocumentDetailListList 後続請求伝票のテーブル

getSuccessList

public List getSuccessList()
後続請求伝票の明細テーブルを取得します。

戻り値:
successList 後続請求伝票の明細テーブル

setRefDocRange

public void setRefDocRange(RefDocRange refDocRange)
前伝票の範囲を設定します。

パラメータ:
refDocRange - 前伝票の範囲

setBillingDocumentDetailListList

public void setBillingDocumentDetailListList(ArrayList billingDocumentDetailListList)
後続請求伝票のテーブルを設定します。

パラメータ:
billingDocumentDetailListList - 後続請求伝票のテーブル

setSuccessList

public void setSuccessList(ArrayList successList)
後続請求伝票の明細テーブルを設定します。

パラメータ:
successList - 後続請求伝票の明細テーブル

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralAppException,
                           SAPGeneralSystemException
請求伝票一覧照会情報を、取得する為に必要な情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
取得した請求伝票一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス
BillingDocGetList
ParamRefDocRange
RefDocRange


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

クラスの概要
BillingDocGetList | 請求伝票一覧照会情報クラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
ParamRefDocRange | 前伝票の範囲パラメータ設定クラス 機能は以下の通り 前伝票の範囲のパラメータを設定します。
RefDocRange | 前伝票の範囲情報クラス 機能は以下の通り 前伝票の範囲情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のクラス
BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のクラス
RefDocRange
前伝票の範囲情報クラス
機能は以下の通り
前伝票の範囲情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamRefDocRange (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス ParamRefDocRange

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange
すべての実装インタフェース:
Serializable
public final class ParamRefDocRange
extends Object
implements Serializable

前伝票の範囲パラメータ設定クラス
機能は以下の通り

  • 前伝票の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, RefDocRange refDocRange)
前伝票の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  RefDocRange refDocRange)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
前伝票の範囲の値をセットします。

パラメータ:
bapiController - BapiController
refDocRange - RefDocRange
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RefDocRange (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス RefDocRange

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange
すべての実装インタフェース:
Serializable
public class RefDocRange
extends Object
implements Serializable

前伝票の範囲情報クラス
機能は以下の通り

  • 前伝票の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
RefDocRange()
前伝票の範囲情報を作成します。
メソッドの概要
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getRefDocHigh() 前伝票の終了伝票番号を取得します。
String | getRefDocLow() 前伝票の開始伝票番号を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setRefDocHigh(String refDocHigh) 前伝票の終了伝票番号を設定します。
void | setRefDocLow(String refDocLow) 前伝票の開始伝票番号を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RefDocRange

public RefDocRange()
前伝票の範囲情報を作成します。

メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getRefDocLow

public String getRefDocLow()
前伝票の開始伝票番号を取得します。

戻り値:
refDocLow 前伝票の開始伝票番号

getRefDocHigh

public String getRefDocHigh()
前伝票の終了伝票番号を取得します。

戻り値:
refDocHigh 前伝票の終了伝票番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setRefDocLow

public void setRefDocLow(String refDocLow)
前伝票の開始伝票番号を設定します。

パラメータ:
refDocLow - 前伝票の開始伝票番号

setRefDocHigh

public void setRefDocHigh(String refDocHigh)
前伝票の終了伝票番号を設定します。

パラメータ:
refDocHigh - 前伝票の終了伝票番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail の使用

BillingDocumentDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.common.model

jp.co.intra_mart.foundation.sap.module.sales での BillingDocumentDetail の使用

BillingDocumentDetail を返す jp.co.intra_mart.foundation.sap.module.sales のメソッド
 BillingDocumentDetail BillingDocGetDetailController.getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

BillingDocumentDetail 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void BillingDocGetDetailController.setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での BillingDocumentDetail の使用

BillingDocumentDetail を返す jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 BillingDocumentDetail BillingDocGetDetail.getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

BillingDocumentDetail 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

jp.co.intra_mart.foundation.sap.module.sales.common.model での BillingDocumentDetail の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model での BillingDocumentDetail のサブクラス
 class BillingDocumentDetailList
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn の使用

HeaderIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での HeaderIn の使用

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamHeaderIn.setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType)
販売伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 HeaderIn InquiryCreateFromData2.getInquiryHeaderIn()
引合伝票ヘッダデータを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setInquiryHeaderIn(HeaderIn inquiryHeaderIn)
引合伝票ヘッダデータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 HeaderIn QuotationCreateFromData2.getQuotationHeaderIn()
伝票ヘッダデータを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setQuotationHeaderIn(HeaderIn quotationHeaderIn)
伝票ヘッダデータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 HeaderIn SalesOrderCreateFromDat2.getOrderHeaderIn()
受注伝票ヘッダを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setOrderHeaderIn(HeaderIn orderHeaderIn)
受注伝票ヘッダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX の使用

HeaderInX を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での HeaderInX の使用

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamHeaderInX.setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType)
ヘッダデータチェックボックスに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 HeaderInX InquiryCreateFromData2.getInquiryHeaderInX()
ヘッダデータチェックボックスを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setInquiryHeaderInX(HeaderInX inquiryHeaderInX)
ヘッダデータチェックボックスを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 HeaderInX QuotationCreateFromData2.getQuotationHeaderInX()
伝票ヘッダチェックボックスを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setQuotationHeaderInX(HeaderInX quotationHeaderInX)
伝票ヘッダチェックボックスを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 HeaderInX SalesOrderCreateFromDat2.getOrderHeaderInX()
受注伝票チェックリストを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setOrderHeaderInX(HeaderInX orderHeaderInX)
受注伝票チェックリストを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch の使用

LogicSwitch を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での LogicSwitch の使用

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamLogicSwitch.setImportParam(BapiController bapiController, LogicSwitch logicSwitch)
内部制御パラメータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 LogicSwitch InquiryCreateFromData2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 LogicSwitch QuotationCreateFromData2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 LogicSwitch SalesOrderCreateFromDat2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg の使用

MaterialEvg を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

jp.co.intra_mart.foundation.sap.module.sales.common.model での MaterialEvg の使用

MaterialEvg 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamMaterialEvg.setImportParam(BapiController bapiController, MaterialEvg materialEvg)
品目コード(長)をセットします。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での MaterialEvg の使用

MaterialEvg を返す jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のメソッド
 MaterialEvg SalesOrderGetList.getMaterialEvg()
品目コード(長)を取得します。

MaterialEvg 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のメソッド
 void SalesOrderGetList.setMaterialEvg(MaterialEvg materialEvg)
品目コード(長)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender の使用

Sender を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での Sender の使用

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamSender.setImportParam(BapiController bapiController, Sender sender)
論理システム - 送信者に値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 Sender InquiryCreateFromData2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setSender(Sender sender)
論理システム - 送信者を設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 Sender QuotationCreateFromData2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setSender(Sender sender)
論理システム - 送信者を設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 Sender SalesOrderCreateFromDat2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setSender(Sender sender)
論理システム - 送信者を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Success の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Success の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Success はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Text の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Text の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Text はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocumentDetail (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス BillingDocumentDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocumentDetailList
public class BillingDocumentDetail
extends Object
implements Serializable

後続請求伝票のテーブル情報クラス
機能は以下の通り

  • 後続請求伝票のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocumentDetail()
後続請求伝票のテーブル情報を作成します。
メソッドの概要
String | getAcctstatus() 会計への転記ステータスを取得します。
String | getBillcateg() 請求カテゴリを取得します。
String | getBillingdoc() 請求伝票を取得します。
String | getBillType() 請求タイプを取得します。
String | getCancelled() 中止区分を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getNetValue() 正味金額を取得します。
String | getSdDocCat() 販売管理伝票カテゴリを取得します。
String | getTaxValue() 税額を取得します。
void | setAcctstatus(String acctstatus) 会計への転記ステータスを設定します。
void | setBillcateg(String billcateg) 請求カテゴリを設定します。
void | setBillingdoc(String billingdoc) 請求伝票を設定します。
void | setBillType(String billType) 請求タイプを設定します。
void | setCancelled(String cancelled) 中止区分を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrencyIso(String currencyIso) ISO 通貨コードを設定します。
void | setNetValue(String netValue) 正味金額を設定します。
void | setSdDocCat(String sdDocCat) 販売管理伝票カテゴリを設定します。
void | setTaxValue(String taxValue) 税額を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocumentDetail

public BillingDocumentDetail()
後続請求伝票のテーブル情報を作成します。

メソッドの詳細

getBillingdoc

public String getBillingdoc()
請求伝票を取得します。

戻り値:
billingdoc 請求伝票

getBillType

public String getBillType()
請求タイプを取得します。

戻り値:
billType 請求タイプ

getBillcateg

public String getBillcateg()
請求カテゴリを取得します。

戻り値:
billcateg 請求カテゴリ

getSdDocCat

public String getSdDocCat()
販売管理伝票カテゴリを取得します。

戻り値:
sdDocCat 販売管理伝票カテゴリ

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
currencyIso ISO 通貨コード

getAcctstatus

public String getAcctstatus()
会計への転記ステータスを取得します。

戻り値:
acctstatus 会計への転記ステータス

getNetValue

public String getNetValue()
正味金額を取得します。

戻り値:
netValue 正味金額

getTaxValue

public String getTaxValue()
税額を取得します。

戻り値:
taxValue 税額

getCancelled

public String getCancelled()
中止区分を取得します。

戻り値:
cancelled 中止区分

setBillingdoc

public void setBillingdoc(String billingdoc)
請求伝票を設定します。

パラメータ:
billingdoc - 請求伝票

setBillType

public void setBillType(String billType)
請求タイプを設定します。

パラメータ:
billType - 請求タイプ

setBillcateg

public void setBillcateg(String billcateg)
請求カテゴリを設定します。

パラメータ:
billcateg - 請求カテゴリ

setSdDocCat

public void setSdDocCat(String sdDocCat)
販売管理伝票カテゴリを設定します。

パラメータ:
sdDocCat - 販売管理伝票カテゴリ

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO 通貨コードを設定します。

パラメータ:
currencyIso - ISO 通貨コード

setAcctstatus

public void setAcctstatus(String acctstatus)
会計への転記ステータスを設定します。

パラメータ:
acctstatus - 会計への転記ステータス

setNetValue

public void setNetValue(String netValue)
正味金額を設定します。

パラメータ:
netValue - 正味金額

setTaxValue

public void setTaxValue(String taxValue)
税額を設定します。

パラメータ:
taxValue - 税額

setCancelled

public void setCancelled(String cancelled)
中止区分を設定します。

パラメータ:
cancelled - 中止区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocumentDetailList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス BillingDocumentDetailList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail
        拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList
すべての実装インタフェース:
Serializable
public class BillingDocumentDetailList
extends BillingDocumentDetail
implements Serializable

後続請求伝票のテーブル情報クラス
機能は以下の通り

  • 後続請求伝票のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocumentDetailList()
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList(int index)
後続請求伝票のテーブル情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail から継承したメソッド
getAcctstatus, getBillcateg, getBillingdoc, getBillType, getCancelled, getCurrency, getCurrencyIso, getNetValue, getSdDocCat, getTaxValue, setAcctstatus, setBillcateg, setBillingdoc, setBillType, setCancelled, setCurrency, setCurrencyIso, setNetValue, setSdDocCat, setTaxValue, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocumentDetailList

public BillingDocumentDetailList()
後続請求伝票のテーブル情報を作成します。

BillingDocumentDetailList

public BillingDocumentDetailList(int index)
後続請求伝票のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsBlob (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsBlob

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob
すべての実装インタフェース:
Serializable
public class CfgsBlob
extends Object
implements Serializable

選定: BLOB 内部データ (SCE)情報クラス
機能は以下の通り

  • 選定: BLOB 内部データ (SCE)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsBlob()
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsBlob(int index)
選定: BLOB 内部データ (SCE)情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getContext() CU: 選定の BLOB (SCE)を取得します。
int | getIndex() レコード番号を取得します｡
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setContext(String context) CU: 選定の BLOB (SCE)を設定します。
void | setIndex(int index) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsBlob

public CfgsBlob()
選定: BLOB 内部データ (SCE)情報を作成します。

CfgsBlob

public CfgsBlob(int index)
選定: BLOB 内部データ (SCE)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getContext

public String getContext()
CU: 選定の BLOB (SCE)を取得します。

戻り値:
context CU: 選定の BLOB (SCE)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setContext

public void setContext(String context)
CU: 選定の BLOB (SCE)を設定します。

パラメータ:
context - CU: 選定の BLOB (SCE)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsInst (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst
すべての実装インタフェース:
Serializable
public class CfgsInst
extends Object
implements Serializable

選定: インスタンス情報クラス
機能は以下の通り

  • 選定: インスタンス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsInst()
選定: インスタンス情報を作成します。
CfgsInst(int index)
選定: インスタンス情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getClassType() クラスタイプを取得します。
String | getComplete() 一般区分を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getConsistent() 一般区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getObjectGuid() インスタンス用 TYPE_OF ステートメントの GUIDを取得します。
String | getObjKey() 対象キーを取得します。
String | getObjTxt() 言語依存対象テキストを取得します。
String | getObjType() 対象タイプを取得します。
String | getPersistId() インスタンス番号 (固定)を取得します。
String | getPersistIdType() インスタンス番号タイプ (固定)を取得します。
String | getQuantity() インスタンス数量を取得します。
String | getQuantityUnit() 数量単位を取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setClassType(String classType) クラスタイプを設定します。
void | setComplete(String complete) 一般区分を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setConsistent(String consistent) 一般区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setObjectGuid(String objectGuid) インスタンス用 TYPE_OF ステートメントの GUIDを設定します。
void | setObjKey(String objKey) 対象キーを設定します。
void | setObjTxt(String objTxt) 言語依存対象テキストを設定します。
void | setObjType(String objType) 対象タイプを設定します。
void | setPersistId(String persistId) インスタンス番号 (固定)を設定します。
void | setPersistIdType(String persistIdType) インスタンス番号タイプ (固定)を設定します。
void | setQuantity(String quantity) インスタンス数量を設定します。
void | setQuantityUnit(String quantityUnit) 数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsInst

public CfgsInst()
選定: インスタンス情報を作成します。

CfgsInst

public CfgsInst(int index)
選定: インスタンス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getObjType

public String getObjType()
対象タイプを取得します。

戻り値:
objType 対象タイプ

getClassType

public String getClassType()
クラスタイプを取得します。

戻り値:
classType クラスタイプ

getObjKey

public String getObjKey()
対象キーを取得します。

戻り値:
objKey 対象キー

getObjTxt

public String getObjTxt()
言語依存対象テキストを取得します。

戻り値:
objTxt 言語依存対象テキスト

getQuantity

public String getQuantity()
インスタンス数量を取得します。

戻り値:
quantity インスタンス数量

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getQuantityUnit

public String getQuantityUnit()
数量単位を取得します。

戻り値:
quantityUnit 数量単位

getComplete

public String getComplete()
一般区分を取得します。

戻り値:
complete 一般区分

getConsistent

public String getConsistent()
一般区分を取得します。

戻り値:
consistent 一般区分

getObjectGuid

public String getObjectGuid()
インスタンス用 TYPE_OF ステートメントの GUIDを取得します。

戻り値:
objectGuid インスタンス用 TYPE_OF ステートメントの GUID

getPersistId

public String getPersistId()
インスタンス番号 (固定)を取得します。

戻り値:
persistId インスタンス番号 (固定)

getPersistIdType

public String getPersistIdType()
インスタンス番号タイプ (固定)を取得します。

戻り値:
persistIdType インスタンス番号タイプ (固定)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setObjType

public void setObjType(String objType)
対象タイプを設定します。

パラメータ:
objType - 対象タイプ

setClassType

public void setClassType(String classType)
クラスタイプを設定します。

パラメータ:
classType - クラスタイプ

setObjKey

public void setObjKey(String objKey)
対象キーを設定します。

パラメータ:
objKey - 対象キー

setObjTxt

public void setObjTxt(String objTxt)
言語依存対象テキストを設定します。

パラメータ:
objTxt - 言語依存対象テキスト

setQuantity

public void setQuantity(String quantity)
インスタンス数量を設定します。

パラメータ:
quantity - インスタンス数量

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setQuantityUnit

public void setQuantityUnit(String quantityUnit)
数量単位を設定します。

パラメータ:
quantityUnit - 数量単位

setComplete

public void setComplete(String complete)
一般区分を設定します。

パラメータ:
complete - 一般区分

setConsistent

public void setConsistent(String consistent)
一般区分を設定します。

パラメータ:
consistent - 一般区分

setObjectGuid

public void setObjectGuid(String objectGuid)
インスタンス用 TYPE_OF ステートメントの GUIDを設定します。

パラメータ:
objectGuid - インスタンス用 TYPE_OF ステートメントの GUID

setPersistId

public void setPersistId(String persistId)
インスタンス番号 (固定)を設定します。

パラメータ:
persistId - インスタンス番号 (固定)

setPersistIdType

public void setPersistIdType(String persistIdType)
インスタンス番号タイプ (固定)を設定します。

パラメータ:
persistIdType - インスタンス番号タイプ (固定)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsPartOf (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsPartOf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf
すべての実装インタフェース:
Serializable
public class CfgsPartOf
extends Object
implements Serializable

選定: 部分設定情報クラス
機能は以下の通り

  • 選定: 部分設定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsPartOf()
選定: 部分設定情報を作成します。
CfgsPartOf(int index)
選定: 部分設定情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getClassType() クラスタイプを取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getObjKey() 対象キーを取得します。
String | getObjType() 対象タイプを取得します。
String | getParentId() 選定におけるインスタンス番号を取得します。
String | getPartOfGuid() インスタンス用 PART_OF ステートメントの GUIDを取得します。
String | getPartOfNo() Part_of 明細番号を取得します。
String | getSalesRelevant() この部品は販売に関連していますを取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setClassType(String classType) クラスタイプを設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setObjKey(String objKey) 対象キーを設定します。
void | setObjType(String objType) 対象タイプを設定します。
void | setParentId(String parentId) 選定におけるインスタンス番号を設定します。
void | setPartOfGuid(String partOfGuid) インスタンス用 PART_OF ステートメントの GUIDを設定します。
void | setPartOfNo(String partOfNo) Part_of 明細番号を設定します。
void | setSalesRelevant(String salesRelevant) この部品は販売に関連していますを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsPartOf

public CfgsPartOf()
選定: 部分設定情報を作成します。

CfgsPartOf

public CfgsPartOf(int index)
選定: 部分設定情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getParentId

public String getParentId()
選定におけるインスタンス番号を取得します。

戻り値:
parentId 選定におけるインスタンス番号

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getPartOfNo

public String getPartOfNo()
Part_of 明細番号を取得します。

戻り値:
partOfNo Part_of 明細番号

getObjType

public String getObjType()
対象タイプを取得します。

戻り値:
objType 対象タイプ

getClassType

public String getClassType()
クラスタイプを取得します。

戻り値:
classType クラスタイプ

getObjKey

public String getObjKey()
対象キーを取得します。

戻り値:
objKey 対象キー

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getSalesRelevant

public String getSalesRelevant()
この部品は販売に関連していますを取得します。

戻り値:
salesRelevant この部品は販売に関連しています

getPartOfGuid

public String getPartOfGuid()
インスタンス用 PART_OF ステートメントの GUIDを取得します。

戻り値:
partOfGuid インスタンス用 PART_OF ステートメントの GUID

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setParentId

public void setParentId(String parentId)
選定におけるインスタンス番号を設定します。

パラメータ:
parentId - 選定におけるインスタンス番号

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setPartOfNo

public void setPartOfNo(String partOfNo)
Part_of 明細番号を設定します。

パラメータ:
partOfNo - Part_of 明細番号

setObjType

public void setObjType(String objType)
対象タイプを設定します。

パラメータ:
objType - 対象タイプ

setClassType

public void setClassType(String classType)
クラスタイプを設定します。

パラメータ:
classType - クラスタイプ

setObjKey

public void setObjKey(String objKey)
対象キーを設定します。

パラメータ:
objKey - 対象キー

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setSalesRelevant

public void setSalesRelevant(String salesRelevant)
この部品は販売に関連していますを設定します。

パラメータ:
salesRelevant - この部品は販売に関連しています

setPartOfGuid

public void setPartOfGuid(String partOfGuid)
インスタンス用 PART_OF ステートメントの GUIDを設定します。

パラメータ:
partOfGuid - インスタンス用 PART_OF ステートメントの GUID

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsRef (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsRef

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef
すべての実装インタフェース:
Serializable
public class CfgsRef
extends Object
implements Serializable

選定: 参照データ情報クラス
機能は以下の通り

  • 選定: 参照データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsRef()
選定: 参照データ情報を作成します。
CfgsRef(int index)
選定: 参照データ情報を作成します。
メソッドの概要
String | getCbaseId() インスタンス番号 (固定)を取得します。
String | getCbaseIdType() インスタンス番号タイプ (固定)を取得します。
String | getCfginfo() CU: 選定の BLOB (SCE)を取得します。
String | getComplete() 一般区分を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getConsistent() 一般区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getKblanguage() システム設定の言語を取得します。
String | getKbname() ナレッジベースオブジェクトを取得します。
String | getKbprofile() ナレッジベースプロファイルを取得します。
String | getKbversion() SCE ナレッジベースの実行時バージョンを取得します。
String | getPosex() 外部明細番号を取得します。
String | getRootId() 選定におけるインスタンス番号を取得します。
String | getSce() CUX: 選定タイプを取得します。
void | setCbaseId(String cbaseId) インスタンス番号 (固定)を設定します。
void | setCbaseIdType(String cbaseIdType) インスタンス番号タイプ (固定)を設定します。
void | setCfginfo(String cfginfo) CU: 選定の BLOB (SCE)を設定します。
void | setComplete(String complete) 一般区分を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setConsistent(String consistent) 一般区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setKblanguage(String kblanguage) システム設定の言語を設定します。
void | setKbname(String kbname) ナレッジベースオブジェクトを設定します。
void | setKbprofile(String kbprofile) ナレッジベースプロファイルを設定します。
void | setKbversion(String kbversion) SCE ナレッジベースの実行時バージョンを設定します。
void | setPosex(String posex) 外部明細番号を設定します。
void | setRootId(String rootId) 選定におけるインスタンス番号を設定します。
void | setSce(String sce) CUX: 選定タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsRef

public CfgsRef()
選定: 参照データ情報を作成します。

CfgsRef

public CfgsRef(int index)
選定: 参照データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPosex

public String getPosex()
外部明細番号を取得します。

戻り値:
posex 外部明細番号

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getRootId

public String getRootId()
選定におけるインスタンス番号を取得します。

戻り値:
rootId 選定におけるインスタンス番号

getSce

public String getSce()
CUX: 選定タイプを取得します。

戻り値:
sce CUX: 選定タイプ

getKbname

public String getKbname()
ナレッジベースオブジェクトを取得します。

戻り値:
kbname ナレッジベースオブジェクト

getKbversion

public String getKbversion()
SCE ナレッジベースの実行時バージョンを取得します。

戻り値:
kbversion SCE ナレッジベースの実行時バージョン

getComplete

public String getComplete()
一般区分を取得します。

戻り値:
complete 一般区分

getConsistent

public String getConsistent()
一般区分を取得します。

戻り値:
consistent 一般区分

getCfginfo

public String getCfginfo()
CU: 選定の BLOB (SCE)を取得します。

戻り値:
cfginfo CU: 選定の BLOB (SCE)

getKbprofile

public String getKbprofile()
ナレッジベースプロファイルを取得します。

戻り値:
kbprofile ナレッジベースプロファイル

getKblanguage

public String getKblanguage()
システム設定の言語を取得します。

戻り値:
kblanguage システム設定の言語

getCbaseId

public String getCbaseId()
インスタンス番号 (固定)を取得します。

戻り値:
cbaseId インスタンス番号 (固定)

getCbaseIdType

public String getCbaseIdType()
インスタンス番号タイプ (固定)を取得します。

戻り値:
cbaseIdType インスタンス番号タイプ (固定)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPosex

public void setPosex(String posex)
外部明細番号を設定します。

パラメータ:
posex - 外部明細番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setRootId

public void setRootId(String rootId)
選定におけるインスタンス番号を設定します。

パラメータ:
rootId - 選定におけるインスタンス番号

setSce

public void setSce(String sce)
CUX: 選定タイプを設定します。

パラメータ:
sce - CUX: 選定タイプ

setKbname

public void setKbname(String kbname)
ナレッジベースオブジェクトを設定します。

パラメータ:
kbname - ナレッジベースオブジェクト

setKbversion

public void setKbversion(String kbversion)
SCE ナレッジベースの実行時バージョンを設定します。

パラメータ:
kbversion - SCE ナレッジベースの実行時バージョン

setComplete

public void setComplete(String complete)
一般区分を設定します。

パラメータ:
complete - 一般区分

setConsistent

public void setConsistent(String consistent)
一般区分を設定します。

パラメータ:
consistent - 一般区分

setCfginfo

public void setCfginfo(String cfginfo)
CU: 選定の BLOB (SCE)を設定します。

パラメータ:
cfginfo - CU: 選定の BLOB (SCE)

setKbprofile

public void setKbprofile(String kbprofile)
ナレッジベースプロファイルを設定します。

パラメータ:
kbprofile - ナレッジベースプロファイル

setKblanguage

public void setKblanguage(String kblanguage)
システム設定の言語を設定します。

パラメータ:
kblanguage - システム設定の言語

setCbaseId

public void setCbaseId(String cbaseId)
インスタンス番号 (固定)を設定します。

パラメータ:
cbaseId - インスタンス番号 (固定)

setCbaseIdType

public void setCbaseIdType(String cbaseIdType)
インスタンス番号タイプ (固定)を設定します。

パラメータ:
cbaseIdType - インスタンス番号タイプ (固定)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsRefInst (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsRefInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst
すべての実装インタフェース:
Serializable
public class CfgsRefInst
extends Object
implements Serializable

選定: 参照明細/インスタンス情報クラス
機能は以下の通り

  • 選定: 参照明細/インスタンス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsRefInst()
選定: 参照明細/インスタンス情報を作成します。
CfgsRefInst(int index)
選定: 参照明細/インスタンス情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getPosex() 外部明細番号を取得します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setPosex(String posex) 外部明細番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsRefInst

public CfgsRefInst()
選定: 参照明細/インスタンス情報を作成します。

CfgsRefInst

public CfgsRefInst(int index)
選定: 参照明細/インスタンス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPosex

public String getPosex()
外部明細番号を取得します。

戻り値:
posex 外部明細番号

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPosex

public void setPosex(String posex)
外部明細番号を設定します。

パラメータ:
posex - 外部明細番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsValue (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsValue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue
すべての実装インタフェース:
Serializable
public class CfgsValue
extends Object
implements Serializable

選定: 特性値情報クラス
機能は以下の通り

  • 選定: 特性値情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsValue()
選定: 特性値情報を作成します。
CfgsValue(int index)
選定: 特性値情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getCharc() 特性名を取得します。
String | getCharcTxt() 言語依存特性テキストを取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getValcode() 値タイプ: 範囲制限 - 単一値を取得します。
String | getValue() 特性値を取得します。
String | getValueTo() 特性値を取得します。
String | getValueTxt() 特性値の言語依存テキストを取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setCharc(String charc) 特性名を設定します。
void | setCharcTxt(String charcTxt) 言語依存特性テキストを設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setValcode(String valcode) 値タイプ: 範囲制限 - 単一値を設定します。
void | setValue(String value) 特性値を設定します。
void | setValueTo(String valueTo) 特性値を設定します。
void | setValueTxt(String valueTxt) 特性値の言語依存テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsValue

public CfgsValue()
選定: 特性値情報を作成します。

CfgsValue

public CfgsValue(int index)
選定: 特性値情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getCharc

public String getCharc()
特性名を取得します。

戻り値:
charc 特性名

getCharcTxt

public String getCharcTxt()
言語依存特性テキストを取得します。

戻り値:
charcTxt 言語依存特性テキスト

getValue

public String getValue()
特性値を取得します。

戻り値:
value 特性値

getValueTxt

public String getValueTxt()
特性値の言語依存テキストを取得します。

戻り値:
valueTxt 特性値の言語依存テキスト

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getValueTo

public String getValueTo()
特性値を取得します。

戻り値:
valueTo 特性値

getValcode

public String getValcode()
値タイプ: 範囲制限 - 単一値を取得します。

戻り値:
valcode 値タイプ: 範囲制限 - 単一値

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setCharc

public void setCharc(String charc)
特性名を設定します。

パラメータ:
charc - 特性名

setCharcTxt

public void setCharcTxt(String charcTxt)
言語依存特性テキストを設定します。

パラメータ:
charcTxt - 言語依存特性テキスト

setValue

public void setValue(String value)
特性値を設定します。

パラメータ:
value - 特性値

setValueTxt

public void setValueTxt(String valueTxt)
特性値の言語依存テキストを設定します。

パラメータ:
valueTxt - 特性値の言語依存テキスト

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setValueTo

public void setValueTo(String valueTo)
特性値を設定します。

パラメータ:
valueTo - 特性値

setValcode

public void setValcode(String valcode)
値タイプ: 範囲制限 - 単一値を設定します。

パラメータ:
valcode - 値タイプ: 範囲制限 - 単一値

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsVk (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsVk

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk
すべての実装インタフェース:
Serializable
public class CfgsVk
extends Object
implements Serializable

選定: バリアント条件キー情報クラス
機能は以下の通り

  • 選定: バリアント条件キー情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsVk()
選定: バリアント条件キー情報を作成します。
CfgsVk(int index)
選定: バリアント条件キー情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getFactor() バリアント条件の加重係数を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getVkey() バリアント条件名を取得します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setFactor(String factor) バリアント条件の加重係数を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setVkey(String vkey) バリアント条件名を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsVk

public CfgsVk()
選定: バリアント条件キー情報を作成します。

CfgsVk

public CfgsVk(int index)
選定: バリアント条件キー情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getVkey

public String getVkey()
バリアント条件名を取得します。

戻り値:
vkey バリアント条件名

getFactor

public String getFactor()
バリアント条件の加重係数を取得します。

戻り値:
factor バリアント条件の加重係数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setVkey

public void setVkey(String vkey)
バリアント条件名を設定します。

パラメータ:
vkey - バリアント条件名

setFactor

public void setFactor(String factor)
バリアント条件の加重係数を設定します。

パラメータ:
factor - バリアント条件の加重係数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionsIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ConditionsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn
すべての実装インタフェース:
Serializable
public class ConditionsIn
extends Object
implements Serializable

条件情報クラス
機能は以下の通り

  • 条件情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionsIn()
条件情報を作成します。
ConditionsIn(int index)
条件情報を作成します。
メソッドの概要
String | getAccessSeq() 検索順序 - 検索番号を取得します。
String | getAccountKe() 勘定キー 見越/引当を取得します。
String | getAccountkey() 勘定キーを取得します。
String | getAccruals() 見越額関連条件 (運賃など)を取得します。
String | getApplicatio() アプリケーションを取得します。
String | getCalctypcon() 条件計算タイプを取得します。
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getConbaseval() 条件基礎値を取得します。
String | getCondchaman() 条件 (マニュアル変更済)を取得します。
String | getCondclass() 条件クラスを取得します。
String | getCondcntrl() 条件管理を取得します。
String | getCondcoinhd() 条件カウンタ (ヘッダ条件)を取得します。
String | getCondconfig() システム設定の条件を取得します。
String | getCondcount() 条件連続番号を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getCondincomp() 会社間請求の条件を取得します。
String | getCondisacti() 無効条件を取得します。
String | getCondNo() 条件レコード番号を取得します。
String | getCondorigin() 条件生成区分を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondtype() 条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 条件単位を取得します。
String | getCondUpdat() 条件更新を取得します。
String | getCondvalue() 条件金額を取得します。
String | getCondValue() 条件レートを取得します。
String | getConexchrat() 現地通貨への換算レートに対する条件を取得します。
String | getConinvolst() 請求書一覧条件を取得します。
String | getConpricdat() 条件価格設定日付を取得します。
String | getCurrenckey() スケール通貨を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrency2() 販売伝票通貨を取得します。
String | getCurreniso() ISO コード通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCurrIso2() ISO コード通貨を取得します。
String | getDenominato() 条件単位を基本単位へ変換する分母を取得します。
String | getFactbasval() 条件基礎値に対する要因を取得します。
String | getFactconbas() 条件基準の係数 (期間)を取得します。
String | getGroupcond() グループ条件区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getIsoUnit() 単位の ISO コードを取得します。
String | getItmNumber() 条件明細番号を取得します。
String | getNumconvert() 条件単位を基本単位へ変換する分子を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRoundoffdi() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getScalbasval() 条件のスケール基準値を取得します。
String | getScalebasin() スケール基準区分を取得します。
String | getScaletype() スケールタイプを取得します。
String | getStatCon() 統計に適用する条件を取得します。
String | getStructcond() 構造条件を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getUnitmeasur() 条件スケール単位を取得します。
String | getVarcond() バリアント条件を取得します。
String | getWtWithcd() 源泉徴収税コードを取得します。
void | setAccessSeq(String accessSeq) 検索順序 - 検索番号を設定します。
void | setAccountKe(String accountKe) 勘定キー 見越/引当を設定します。
void | setAccountkey(String accountkey) 勘定キーを設定します。
void | setAccruals(String accruals) 見越額関連条件 (運賃など)を設定します。
void | setApplicatio(String applicatio) アプリケーションを設定します。
void | setCalctypcon(String calctypcon) 条件計算タイプを設定します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setConbaseval(String conbaseval) 条件基礎値を設定します。
void | setCondchaman(String condchaman) 条件 (マニュアル変更済)を設定します。
void | setCondclass(String condclass) 条件クラスを設定します。
void | setCondcntrl(String condcntrl) 条件管理を設定します。
void | setCondcoinhd(String condcoinhd) 条件カウンタ (ヘッダ条件)を設定します。
void | setCondconfig(String condconfig) システム設定の条件を設定します。
void | setCondcount(String condcount) 条件連続番号を設定します。
void | setCondCount(String condCount) 条件カウンタを設定します。
void | setCondincomp(String condincomp) 会社間請求の条件を設定します。
void | setCondisacti(String condisacti) 無効条件を設定します。
void | setCondNo(String condNo) 条件レコード番号を設定します。
void | setCondorigin(String condorigin) 条件生成区分を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondtype(String condtype) 条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCondUpdat(String condUpdat) 条件更新を設定します。
void | setCondvalue(String condvalue) 条件金額を設定します。
void | setCondValue(String condValue) 条件レートを設定します。
void | setConexchrat(String conexchrat) 現地通貨への換算レートに対する条件を設定します。
void | setConinvolst(String coninvolst) 請求書一覧条件を設定します。
void | setConpricdat(String conpricdat) 条件価格設定日付を設定します。
void | setCurrenckey(String currenckey) スケール通貨を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrency2(String currency2) 販売伝票通貨を設定します。
void | setCurreniso(String curreniso) ISO コード通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCurrIso2(String currIso2) ISO コード通貨を設定します。
void | setDenominato(String denominato) 条件単位を基本単位へ変換する分母を設定します。
void | setFactbasval(String factbasval) 条件基礎値に対する要因を設定します。
void | setFactconbas(String factconbas) 条件基準の係数 (期間)を設定します。
void | setGroupcond(String groupcond) グループ条件区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIsoUnit(String isoUnit) 単位の ISO コードを設定します。
void | setItmNumber(String itmNumber) 条件明細番号を設定します。
void | setNumconvert(String numconvert) 条件単位を基本単位へ変換する分子を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRoundoffdi(String roundoffdi) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setScalbasval(String scalbasval) 条件のスケール基準値を設定します。
void | setScalebasin(String scalebasin) スケール基準区分を設定します。
void | setScaletype(String scaletype) スケールタイプを設定します。
void | setStatCon(String statCon) 統計に適用する条件を設定します。
void | setStructcond(String structcond) 構造条件を設定します。
void | setTaxCode(String taxCode) 消費税コードを設定します。
void | setUnitmeasur(String unitmeasur) 条件スケール単位を設定します。
void | setVarcond(String varcond) バリアント条件を設定します。
void | setWtWithcd(String wtWithcd) 源泉徴収税コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionsIn

public ConditionsIn()
条件情報を作成します。

ConditionsIn

public ConditionsIn(int index)
条件情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
itmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
condCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getCondValue

public String getCondValue()
条件レートを取得します。

戻り値:
condValue 条件レート

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getApplicatio

public String getApplicatio()
アプリケーションを取得します。

戻り値:
applicatio アプリケーション

getConpricdat

public String getConpricdat()
条件価格設定日付を取得します。

戻り値:
conpricdat 条件価格設定日付

getCalctypcon

public String getCalctypcon()
条件計算タイプを取得します。

戻り値:
calctypcon 条件計算タイプ

getConbaseval

public String getConbaseval()
条件基礎値を取得します。

戻り値:
conbaseval 条件基礎値

getConexchrat

public String getConexchrat()
現地通貨への換算レートに対する条件を取得します。

戻り値:
conexchrat 現地通貨への換算レートに対する条件

getNumconvert

public String getNumconvert()
条件単位を基本単位へ変換する分子を取得します。

戻り値:
numconvert 条件単位を基本単位へ変換する分子

getDenominato

public String getDenominato()
条件単位を基本単位へ変換する分母を取得します。

戻り値:
denominato 条件単位を基本単位へ変換する分母

getCondtype

public String getCondtype()
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。

戻り値:
condtype 条件カテゴリ (例: 税、運賃、価格、原価)

getStatCon

public String getStatCon()
統計に適用する条件を取得します。

戻り値:
statCon 統計に適用する条件

getScaletype

public String getScaletype()
スケールタイプを取得します。

戻り値:
scaletype スケールタイプ

getAccruals

public String getAccruals()
見越額関連条件 (運賃など)を取得します。

戻り値:
accruals 見越額関連条件 (運賃など)

getConinvolst

public String getConinvolst()
請求書一覧条件を取得します。

戻り値:
coninvolst 請求書一覧条件

getCondorigin

public String getCondorigin()
条件生成区分を取得します。

戻り値:
condorigin 条件生成区分

getGroupcond

public String getGroupcond()
グループ条件区分を取得します。

戻り値:
groupcond グループ条件区分

getCondUpdat

public String getCondUpdat()
条件更新を取得します。

戻り値:
condUpdat 条件更新

getAccessSeq

public String getAccessSeq()
検索順序 - 検索番号を取得します。

戻り値:
accessSeq 検索順序 - 検索番号

getCondcount

public String getCondcount()
条件連続番号を取得します。

戻り値:
condcount 条件連続番号

getRoundoffdi

public String getRoundoffdi()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
roundoffdi BAPI の通貨額 (小数点以下９桁)

getCondvalue

public String getCondvalue()
条件金額を取得します。

戻り値:
condvalue 条件金額

getCurrency2

public String getCurrency2()
販売伝票通貨を取得します。

戻り値:
currency2 販売伝票通貨

getCurrIso2

public String getCurrIso2()
ISO コード通貨を取得します。

戻り値:
currIso2 ISO コード通貨

getCondcntrl

public String getCondcntrl()
条件管理を取得します。

戻り値:
condcntrl 条件管理

getCondisacti

public String getCondisacti()
無効条件を取得します。

戻り値:
condisacti 無効条件

getCondclass

public String getCondclass()
条件クラスを取得します。

戻り値:
condclass 条件クラス

getFactbasval

public String getFactbasval()
条件基礎値に対する要因を取得します。

戻り値:
factbasval 条件基礎値に対する要因

getScalebasin

public String getScalebasin()
スケール基準区分を取得します。

戻り値:
scalebasin スケール基準区分

getScalbasval

public String getScalbasval()
条件のスケール基準値を取得します。

戻り値:
scalbasval 条件のスケール基準値

getUnitmeasur

public String getUnitmeasur()
条件スケール単位を取得します。

戻り値:
unitmeasur 条件スケール単位

getIsoUnit

public String getIsoUnit()
単位の ISO コードを取得します。

戻り値:
isoUnit 単位の ISO コード

getCurrenckey

public String getCurrenckey()
スケール通貨を取得します。

戻り値:
currenckey スケール通貨

getCurreniso

public String getCurreniso()
ISO コード通貨を取得します。

戻り値:
curreniso ISO コード通貨

getCondincomp

public String getCondincomp()
会社間請求の条件を取得します。

戻り値:
condincomp 会社間請求の条件

getCondconfig

public String getCondconfig()
システム設定の条件を取得します。

戻り値:
condconfig システム設定の条件

getCondchaman

public String getCondchaman()
条件 (マニュアル変更済)を取得します。

戻り値:
condchaman 条件 (マニュアル変更済)

getCondNo

public String getCondNo()
条件レコード番号を取得します。

戻り値:
condNo 条件レコード番号

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
taxCode 消費税コード

getVarcond

public String getVarcond()
バリアント条件を取得します。

戻り値:
varcond バリアント条件

getAccountkey

public String getAccountkey()
勘定キーを取得します。

戻り値:
accountkey 勘定キー

getAccountKe

public String getAccountKe()
勘定キー 見越/引当を取得します。

戻り値:
accountKe 勘定キー 見越/引当

getWtWithcd

public String getWtWithcd()
源泉徴収税コードを取得します。

戻り値:
wtWithcd 源泉徴収税コード

getStructcond

public String getStructcond()
構造条件を取得します。

戻り値:
structcond 構造条件

getFactconbas

public String getFactconbas()
条件基準の係数 (期間)を取得します。

戻り値:
factconbas 条件基準の係数 (期間)

getCondcoinhd

public String getCondcoinhd()
条件カウンタ (ヘッダ条件)を取得します。

戻り値:
condcoinhd 条件カウンタ (ヘッダ条件)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
条件明細番号を設定します。

パラメータ:
itmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件カウンタを設定します。

パラメータ:
condCount - 条件カウンタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setCondValue

public void setCondValue(String condValue)
条件レートを設定します。

パラメータ:
condValue - 条件レート

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setApplicatio

public void setApplicatio(String applicatio)
アプリケーションを設定します。

パラメータ:
applicatio - アプリケーション

setConpricdat

public void setConpricdat(String conpricdat)
条件価格設定日付を設定します。

パラメータ:
conpricdat - 条件価格設定日付

setCalctypcon

public void setCalctypcon(String calctypcon)
条件計算タイプを設定します。

パラメータ:
calctypcon - 条件計算タイプ

setConbaseval

public void setConbaseval(String conbaseval)
条件基礎値を設定します。

パラメータ:
conbaseval - 条件基礎値

setConexchrat

public void setConexchrat(String conexchrat)
現地通貨への換算レートに対する条件を設定します。

パラメータ:
conexchrat - 現地通貨への換算レートに対する条件

setNumconvert

public void setNumconvert(String numconvert)
条件単位を基本単位へ変換する分子を設定します。

パラメータ:
numconvert - 条件単位を基本単位へ変換する分子

setDenominato

public void setDenominato(String denominato)
条件単位を基本単位へ変換する分母を設定します。

パラメータ:
denominato - 条件単位を基本単位へ変換する分母

setCondtype

public void setCondtype(String condtype)
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。

パラメータ:
condtype - 条件カテゴリ (例: 税、運賃、価格、原価)

setStatCon

public void setStatCon(String statCon)
統計に適用する条件を設定します。

パラメータ:
statCon - 統計に適用する条件

setScaletype

public void setScaletype(String scaletype)
スケールタイプを設定します。

パラメータ:
scaletype - スケールタイプ

setAccruals

public void setAccruals(String accruals)
見越額関連条件 (運賃など)を設定します。

パラメータ:
accruals - 見越額関連条件 (運賃など)

setConinvolst

public void setConinvolst(String coninvolst)
請求書一覧条件を設定します。

パラメータ:
coninvolst - 請求書一覧条件

setCondorigin

public void setCondorigin(String condorigin)
条件生成区分を設定します。

パラメータ:
condorigin - 条件生成区分

setGroupcond

public void setGroupcond(String groupcond)
グループ条件区分を設定します。

パラメータ:
groupcond - グループ条件区分

setCondUpdat

public void setCondUpdat(String condUpdat)
条件更新を設定します。

パラメータ:
condUpdat - 条件更新

setAccessSeq

public void setAccessSeq(String accessSeq)
検索順序 - 検索番号を設定します。

パラメータ:
accessSeq - 検索順序 - 検索番号

setCondcount

public void setCondcount(String condcount)
条件連続番号を設定します。

パラメータ:
condcount - 条件連続番号

setRoundoffdi

public void setRoundoffdi(String roundoffdi)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
roundoffdi - BAPI の通貨額 (小数点以下９桁)

setCondvalue

public void setCondvalue(String condvalue)
条件金額を設定します。

パラメータ:
condvalue - 条件金額

setCurrency2

public void setCurrency2(String currency2)
販売伝票通貨を設定します。

パラメータ:
currency2 - 販売伝票通貨

setCurrIso2

public void setCurrIso2(String currIso2)
ISO コード通貨を設定します。

パラメータ:
currIso2 - ISO コード通貨

setCondcntrl

public void setCondcntrl(String condcntrl)
条件管理を設定します。

パラメータ:
condcntrl - 条件管理

setCondisacti

public void setCondisacti(String condisacti)
無効条件を設定します。

パラメータ:
condisacti - 無効条件

setCondclass

public void setCondclass(String condclass)
条件クラスを設定します。

パラメータ:
condclass - 条件クラス

setFactbasval

public void setFactbasval(String factbasval)
条件基礎値に対する要因を設定します。

パラメータ:
factbasval - 条件基礎値に対する要因

setScalebasin

public void setScalebasin(String scalebasin)
スケール基準区分を設定します。

パラメータ:
scalebasin - スケール基準区分

setScalbasval

public void setScalbasval(String scalbasval)
条件のスケール基準値を設定します。

パラメータ:
scalbasval - 条件のスケール基準値

setUnitmeasur

public void setUnitmeasur(String unitmeasur)
条件スケール単位を設定します。

パラメータ:
unitmeasur - 条件スケール単位

setIsoUnit

public void setIsoUnit(String isoUnit)
単位の ISO コードを設定します。

パラメータ:
isoUnit - 単位の ISO コード

setCurrenckey

public void setCurrenckey(String currenckey)
スケール通貨を設定します。

パラメータ:
currenckey - スケール通貨

setCurreniso

public void setCurreniso(String curreniso)
ISO コード通貨を設定します。

パラメータ:
curreniso - ISO コード通貨

setCondincomp

public void setCondincomp(String condincomp)
会社間請求の条件を設定します。

パラメータ:
condincomp - 会社間請求の条件

setCondconfig

public void setCondconfig(String condconfig)
システム設定の条件を設定します。

パラメータ:
condconfig - システム設定の条件

setCondchaman

public void setCondchaman(String condchaman)
条件 (マニュアル変更済)を設定します。

パラメータ:
condchaman - 条件 (マニュアル変更済)

setCondNo

public void setCondNo(String condNo)
条件レコード番号を設定します。

パラメータ:
condNo - 条件レコード番号

setTaxCode

public void setTaxCode(String taxCode)
消費税コードを設定します。

パラメータ:
taxCode - 消費税コード

setVarcond

public void setVarcond(String varcond)
バリアント条件を設定します。

パラメータ:
varcond - バリアント条件

setAccountkey

public void setAccountkey(String accountkey)
勘定キーを設定します。

パラメータ:
accountkey - 勘定キー

setAccountKe

public void setAccountKe(String accountKe)
勘定キー 見越/引当を設定します。

パラメータ:
accountKe - 勘定キー 見越/引当

setWtWithcd

public void setWtWithcd(String wtWithcd)
源泉徴収税コードを設定します。

パラメータ:
wtWithcd - 源泉徴収税コード

setStructcond

public void setStructcond(String structcond)
構造条件を設定します。

パラメータ:
structcond - 構造条件

setFactconbas

public void setFactconbas(String factconbas)
条件基準の係数 (期間)を設定します。

パラメータ:
factconbas - 条件基準の係数 (期間)

setCondcoinhd

public void setCondcoinhd(String condcoinhd)
条件カウンタ (ヘッダ条件)を設定します。

パラメータ:
condcoinhd - 条件カウンタ (ヘッダ条件)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionsInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ConditionsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX
すべての実装インタフェース:
Serializable
public class ConditionsInX
extends Object
implements Serializable

受注における条件更新の通信項目情報クラス
機能は以下の通り

  • 受注における条件更新の通信項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionsInX()
受注における条件更新の通信項目情報を作成します。
ConditionsInX(int index)
受注における条件更新の通信項目情報を作成します。
メソッドの概要
String | getCondCount() 条件連続番号を取得します。
String | getCondPUnt() 関連ユーザデータ項目の更新情報を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 関連ユーザデータ項目の更新情報を取得します。
String | getCondValue() 関連ユーザデータ項目の更新情報を取得します。
String | getCurrency() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 条件明細番号を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getVarcond() バリアント条件を取得します。
void | setCondCount(String condCount) 条件連続番号を設定します。
void | setCondPUnt(String condPUnt) 関連ユーザデータ項目の更新情報を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondUnit(String condUnit) 関連ユーザデータ項目の更新情報を設定します。
void | setCondValue(String condValue) 関連ユーザデータ項目の更新情報を設定します。
void | setCurrency(String currency) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 条件明細番号を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setVarcond(String varcond) バリアント条件を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionsInX

public ConditionsInX()
受注における条件更新の通信項目情報を作成します。

ConditionsInX

public ConditionsInX(int index)
受注における条件更新の通信項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
itmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件連続番号を取得します。

戻り値:
condCount 条件連続番号

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getCondValue

public String getCondValue()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condValue 関連ユーザデータ項目の更新情報

getCurrency

public String getCurrency()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
currency 関連ユーザデータ項目の更新情報

getCondUnit

public String getCondUnit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condUnit 関連ユーザデータ項目の更新情報

getCondPUnt

public String getCondPUnt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condPUnt 関連ユーザデータ項目の更新情報

getVarcond

public String getVarcond()
バリアント条件を取得します。

戻り値:
varcond バリアント条件

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
条件明細番号を設定します。

パラメータ:
itmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件連続番号を設定します。

パラメータ:
condCount - 条件連続番号

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setCondValue

public void setCondValue(String condValue)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condValue - 関連ユーザデータ項目の更新情報

setCurrency

public void setCurrency(String currency)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
currency - 関連ユーザデータ項目の更新情報

setCondUnit

public void setCondUnit(String condUnit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condUnit - 関連ユーザデータ項目の更新情報

setCondPUnt

public void setCondPUnt(String condPUnt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condPUnt - 関連ユーザデータ項目の更新情報

setVarcond

public void setVarcond(String varcond)
バリアント条件を設定します。

パラメータ:
varcond - バリアント条件

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtensionIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

VBAK、VBAP、VBEP のカスタマ拡張情報クラス
機能は以下の通り

  • VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionIn(int index)
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。

ExtensionIn

public ExtensionIn(int index)
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart4 - BAPI 拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeaderIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス HeaderIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn
すべての実装インタフェース:
Serializable
public class HeaderIn
extends Object
implements Serializable

販売伝票ヘッダデータ情報クラス
機能は以下の通り

  • 販売伝票ヘッダデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeaderIn()
販売伝票ヘッダデータ情報を作成します。
メソッドの概要
String | getAccntAsgn() 得意先の勘定設定グループを取得します。
String | getAddValDy() 有効日からの日数を取得します。
String | getAlttaxCls() 代替税分類を取得します。
String | getAssNumber() 割当番号を取得します。
String | getBillBlock() 販売管理伝票の請求ブロックを取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillSched() 請求日程 (稼働日カレンダ指定)を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCampaign() 総括プロジェクト計画: 外部 SAP システムの GUIDを取得します。
String | getChkprtauth() 取引先権限チェックを取得します。
String | getCmlqtyDat() 累積出荷数量日付を取得します。
String | getCollectNo() 一括番号を取得します。
String | getCompCdeB() 請求対象会社コードを取得します。
String | getComplDlv() 一括納入区分を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCstcndgrp1() 得意先条件グループ１を取得します。
String | getCstcndgrp2() 得意先条件グループ２を取得します。
String | getCstcndgrp3() 得意先条件グループ３を取得します。
String | getCstcndgrp4() 得意先条件グループ４を取得します。
String | getCstcndgrp5() 得意先条件グループ５を取得します。
String | getCtValidF() 有効開始日付 (販売契約/品目提案)を取得します。
String | getCtValidT() 有効終了日付 (販売契約/品目提案)を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCustGroup() 得意先グループを取得します。
String | getCustGrp1() 得意先グループ 1を取得します。
String | getCustGrp2() 得意先グループ 2を取得します。
String | getCustGrp3() 得意先グループ 3を取得します。
String | getCustGrp4() 得意先グループ 4を取得します。
String | getCustGrp5() 得意先グループ 5を取得します。
String | getDateType() 提案日付タイプを取得します。
String | getDepartmNo() 部門コードを取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvschduse() 用途区分を取得します。
String | getDlvTime() 契約出荷期間を取得します。
String | getDocClass() リリースおよびトランザクション管理を備えた元システムを取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocNumFi() ドキュメンタリクレジット処理: 内部番号を取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getDunCount() 得意先商談回数を取得します。
String | getDunDate() 得意先との前回の商談日を取得します。
String | getDunnBlock() 督促処理保留を取得します。
String | getDunnKey() 督促処理キーを取得します。
String | getEutriDeal() フラグ: EC 内三角取引を取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getExchRateFiV() FI 転記の換算レート (間接相場)を取得します。
String | getExrateFi() FI 転記の換算レート (直接相場)を取得します。
String | getFixValDy() 有効日日付を取得します。
String | getFkkConacct() 長さ 12 の文字項目を取得します。
String | getHCurr() 通貨コードを取得します。
String | getHCurrIso() ISO 通貨コードを取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
String | getInvoSched() 請求書一覧日程 (稼働日カレンダ指定)を取得します。
String | getLineTime() 納入日程の提案時刻 (現地時間: 販売組織参照)を取得します。
String | getMastContr() グループマスタ契約番号を取得します。
String | getMnInvoice() マニュアル請求書更新を取得します。
String | getName() 発注者名称を取得します。
String | getNotifNo() 通知番号を取得します。
String | getOrdcombIn() 受注結合出荷区分を取得します。
String | getOrdReason() 受注理由 (取引理由)を取得します。
String | getPldlvstyp() MRP: 出荷計画タイプを取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getPmtgarPro() 支払保証決定表を取得します。
String | getPoDatS() 出荷先の出荷先発注日付を取得します。
String | getPoMethod() 得意先発注タイプを取得します。
String | getPoMethS() 出荷先の出荷先発注タイプを取得します。
String | getPoSupplem() 得意先発注番号補足を取得します。
String | getPpSearch() 品目提案検索条件を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getPriceGrp() 価格グループ (得意先)を取得します。
String | getPriceList() 価格表タイプを取得します。
String | getPurchDate() 得意先発注日付を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getPurchNoS() 出荷先の得意先発注番号を取得します。
String | getPymtMeth() 支払方法を取得します。
String | getQtValidF() 見積/引合有効開始日を取得します。
String | getQtValidT() 見積の有効終了日を取得します。
String | getRecPoint() 入荷ポイントを取得します。
String | getRef1() 得意先/仕入先の内部参照コードを取得します。
String | getRef1S() 出荷先文字を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefdocCat() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefDocL() 参照伝票番号を取得します。
String | getRefDocLLong() 参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。
String | getRefdoctype() 参照オブジェクトの伝票タイプを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRefProc() 参照限定条件: 決定区分を取得します。
String | getReqDateH() 指定納入期日を取得します。
String | getSalesDist() 販売地域を取得します。
String | getSalesGrp() 営業グループを取得します。
String | getSalesOff() 営業所を取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSdDocCat() 販売管理伝票カテゴリを取得します。
String | getServDate() サービス提供日を取得します。
String | getShipCond() 出荷条件を取得します。
String | getShipType() 出荷タイプを取得します。
String | getSProcInd() 特別処理区分を取得します。
String | getTaxClass2() 得意先税分類 2を取得します。
String | getTaxClass3() 得意先税分類 3を取得します。
String | getTaxClass4() 得意先に対する税クラス 4を取得します。
String | getTaxClass5() 得意先に対する税クラス 5を取得します。
String | getTaxClass6() 得意先に対する税クラス 6を取得します。
String | getTaxClass7() 得意先に対する税クラス 7を取得します。
String | getTaxClass8() 得意先に対する税クラス 8を取得します。
String | getTaxClass9() 得意先に対する税クラス 9を取得します。
String | getTaxdepCty() 税出荷国を取得します。
String | getTaxdstCty() 税仕向国を取得します。
String | getTelephone() 電話番号を取得します。
String | getVersion() 販売伝票バージョン番号を取得します。
String | getWarDate() 保証期間の開始日付を取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAccntAsgn(String accntAsgn) 得意先の勘定設定グループを設定します。
void | setAddValDy(String addValDy) 有効日からの日数を設定します。
void | setAlttaxCls(String alttaxCls) 代替税分類を設定します。
void | setAssNumber(String assNumber) 割当番号を設定します。
void | setBillBlock(String billBlock) 販売管理伝票の請求ブロックを設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillSched(String billSched) 請求日程 (稼働日カレンダ指定)を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCampaign(String campaign) 総括プロジェクト計画: 外部 SAP システムの GUIDを設定します。
void | setChkprtauth(String chkprtauth) 取引先権限チェックを設定します。
void | setCmlqtyDat(String cmlqtyDat) 累積出荷数量日付を設定します。
void | setCollectNo(String collectNo) 一括番号を設定します。
void | setCompCdeB(String compCdeB) 請求対象会社コードを設定します。
void | setComplDlv(String complDlv) 一括納入区分を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCstcndgrp1(String cstcndgrp1) 得意先条件グループ１を設定します。
void | setCstcndgrp2(String cstcndgrp2) 得意先条件グループ２を設定します。
void | setCstcndgrp3(String cstcndgrp3) 得意先条件グループ３を設定します。
void | setCstcndgrp4(String cstcndgrp4) 得意先条件グループ４を設定します。
void | setCstcndgrp5(String cstcndgrp5) 得意先条件グループ５を設定します。
void | setCtValidF(String ctValidF) 有効開始日付 (販売契約/品目提案)を設定します。
void | setCtValidT(String ctValidT) 有効終了日付 (販売契約/品目提案)を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCustGroup(String custGroup) 得意先グループを設定します。
void | setCustGrp1(String custGrp1) 得意先グループ 1を設定します。
void | setCustGrp2(String custGrp2) 得意先グループ 2を設定します。
void | setCustGrp3(String custGrp3) 得意先グループ 3を設定します。
void | setCustGrp4(String custGrp4) 得意先グループ 4を設定します。
void | setCustGrp5(String custGrp5) 得意先グループ 5を設定します。
void | setDateType(String dateType) 提案日付タイプを設定します。
void | setDepartmNo(String departmNo) 部門コードを設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvschduse(String dlvschduse) 用途区分を設定します。
void | setDlvTime(String dlvTime) 契約出荷期間を設定します。
void | setDocClass(String docClass) リリースおよびトランザクション管理を備えた元システムを設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocNumFi(String docNumFi) ドキュメンタリクレジット処理: 内部番号を設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setDunCount(String dunCount) 得意先商談回数を設定します。
void | setDunDate(String dunDate) 得意先との前回の商談日を設定します。
void | setDunnBlock(String dunnBlock) 督促処理保留を設定します。
void | setDunnKey(String dunnKey) 督促処理キーを設定します。
void | setEutriDeal(String eutriDeal) フラグ: EC 内三角取引を設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setExchRateFiV(String exchRateFiV) FI 転記の換算レート (間接相場)を設定します。
void | setExrateFi(String exrateFi) FI 転記の換算レート (直接相場)を設定します。
void | setFixValDy(String fixValDy) 有効日日付を設定します。
void | setFkkConacct(String fkkConacct) 長さ 12 の文字項目を設定します。
void | setHCurr(String hCurr) 通貨コードを設定します。
void | setHCurrIso(String hCurrIso) ISO 通貨コードを設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ 2を設定します。
void | setInvoSched(String invoSched) 請求書一覧日程 (稼働日カレンダ指定)を設定します。
void | setLineTime(String lineTime) 納入日程の提案時刻 (現地時間: 販売組織参照)を設定します。
void | setMastContr(String mastContr) グループマスタ契約番号を設定します。
void | setMnInvoice(String mnInvoice) マニュアル請求書更新を設定します。
void | setName(String name) 発注者名称を設定します。
void | setNotifNo(String notifNo) 通知番号を設定します。
void | setOrdcombIn(String ordcombIn) 受注結合出荷区分を設定します。
void | setOrdReason(String ordReason) 受注理由 (取引理由)を設定します。
void | setPldlvstyp(String pldlvstyp) MRP: 出荷計画タイプを設定します。
void | setPmnttrms(String pmnttrms) 支払条件キーを設定します。
void | setPmtgarPro(String pmtgarPro) 支払保証決定表を設定します。
void | setPoDatS(String poDatS) 出荷先の出荷先発注日付を設定します。
void | setPoMethod(String poMethod) 得意先発注タイプを設定します。
void | setPoMethS(String poMethS) 出荷先の出荷先発注タイプを設定します。
void | setPoSupplem(String poSupplem) 得意先発注番号補足を設定します。
void | setPpSearch(String ppSearch) 品目提案検索条件を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setPriceGrp(String priceGrp) 価格グループ (得意先)を設定します。
void | setPriceList(String priceList) 価格表タイプを設定します。
void | setPurchDate(String purchDate) 得意先発注日付を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setPurchNoS(String purchNoS) 出荷先の得意先発注番号を設定します。
void | setPymtMeth(String pymtMeth) 支払方法を設定します。
void | setQtValidF(String qtValidF) 見積/引合有効開始日を設定します。
void | setQtValidT(String qtValidT) 見積の有効終了日を設定します。
void | setRecPoint(String recPoint) 入荷ポイントを設定します。
void | setRef1(String ref1) 得意先/仕入先の内部参照コードを設定します。
void | setRef1S(String ref1S) 出荷先文字を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefdocCat(String refdocCat) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefDocL(String refDocL) 参照伝票番号を設定します。
void | setRefDocLLong(String refDocLLong) 参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。
void | setRefdoctype(String refdoctype) 参照オブジェクトの伝票タイプを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRefProc(String refProc) 参照限定条件: 決定区分を設定します。
void | setReqDateH(String reqDateH) 指定納入期日を設定します。
void | setSalesDist(String salesDist) 販売地域を設定します。
void | setSalesGrp(String salesGrp) 営業グループを設定します。
void | setSalesOff(String salesOff) 営業所を設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSdDocCat(String sdDocCat) 販売管理伝票カテゴリを設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipCond(String shipCond) 出荷条件を設定します。
void | setShipType(String shipType) 出荷タイプを設定します。
void | setSProcInd(String sProcInd) 特別処理区分を設定します。
void | setTaxClass2(String taxClass2) 得意先税分類 2を設定します。
void | setTaxClass3(String taxClass3) 得意先税分類 3を設定します。
void | setTaxClass4(String taxClass4) 得意先に対する税クラス 4を設定します。
void | setTaxClass5(String taxClass5) 得意先に対する税クラス 5を設定します。
void | setTaxClass6(String taxClass6) 得意先に対する税クラス 6を設定します。
void | setTaxClass7(String taxClass7) 得意先に対する税クラス 7を設定します。
void | setTaxClass8(String taxClass8) 得意先に対する税クラス 8を設定します。
void | setTaxClass9(String taxClass9) 得意先に対する税クラス 9を設定します。
void | setTaxdepCty(String taxdepCty) 税出荷国を設定します。
void | setTaxdstCty(String taxdstCty) 税仕向国を設定します。
void | setTelephone(String telephone) 電話番号を設定します。
void | setVersion(String version) 販売伝票バージョン番号を設定します。
void | setWarDate(String warDate) 保証期間の開始日付を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeaderIn

public HeaderIn()
販売伝票ヘッダデータ情報を作成します。

メソッドの詳細

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getRefdoctype

public String getRefdoctype()
参照オブジェクトの伝票タイプを取得します。

戻り値:
refdoctype 参照オブジェクトの伝票タイプ

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getCollectNo

public String getCollectNo()
一括番号を取得します。

戻り値:
collectNo 一括番号

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getSalesGrp

public String getSalesGrp()
営業グループを取得します。

戻り値:
salesGrp 営業グループ

getSalesOff

public String getSalesOff()
営業所を取得します。

戻り値:
salesOff 営業所

getReqDateH

public String getReqDateH()
指定納入期日を取得します。

戻り値:
reqDateH 指定納入期日

getDateType

public String getDateType()
提案日付タイプを取得します。

戻り値:
dateType 提案日付タイプ

getPurchDate

public String getPurchDate()
得意先発注日付を取得します。

戻り値:
purchDate 得意先発注日付

getPoMethod

public String getPoMethod()
得意先発注タイプを取得します。

戻り値:
poMethod 得意先発注タイプ

getPoSupplem

public String getPoSupplem()
得意先発注番号補足を取得します。

戻り値:
poSupplem 得意先発注番号補足

getRef1

public String getRef1()
得意先/仕入先の内部参照コードを取得します。

戻り値:
ref1 得意先/仕入先の内部参照コード

getName

public String getName()
発注者名称を取得します。

戻り値:
name 発注者名称

getTelephone

public String getTelephone()
電話番号を取得します。

戻り値:
telephone 電話番号

getPriceGrp

public String getPriceGrp()
価格グループ (得意先)を取得します。

戻り値:
priceGrp 価格グループ (得意先)

getCustGroup

public String getCustGroup()
得意先グループを取得します。

戻り値:
custGroup 得意先グループ

getSalesDist

public String getSalesDist()
販売地域を取得します。

戻り値:
salesDist 販売地域

getPriceList

public String getPriceList()
価格表タイプを取得します。

戻り値:
priceList 価格表タイプ

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
incoterms2 インコタームズ 2

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
pmnttrms 支払条件キー

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getBillBlock

public String getBillBlock()
販売管理伝票の請求ブロックを取得します。

戻り値:
billBlock 販売管理伝票の請求ブロック

getOrdReason

public String getOrdReason()
受注理由 (取引理由)を取得します。

戻り値:
ordReason 受注理由 (取引理由)

getComplDlv

public String getComplDlv()
一括納入区分を取得します。

戻り値:
complDlv 一括納入区分

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getQtValidF

public String getQtValidF()
見積/引合有効開始日を取得します。

戻り値:
qtValidF 見積/引合有効開始日

getQtValidT

public String getQtValidT()
見積の有効終了日を取得します。

戻り値:
qtValidT 見積の有効終了日

getCtValidF

public String getCtValidF()
有効開始日付 (販売契約/品目提案)を取得します。

戻り値:
ctValidF 有効開始日付 (販売契約/品目提案)

getCtValidT

public String getCtValidT()
有効終了日付 (販売契約/品目提案)を取得します。

戻り値:
ctValidT 有効終了日付 (販売契約/品目提案)

getCustGrp1

public String getCustGrp1()
得意先グループ 1を取得します。

戻り値:
custGrp1 得意先グループ 1

getCustGrp2

public String getCustGrp2()
得意先グループ 2を取得します。

戻り値:
custGrp2 得意先グループ 2

getCustGrp3

public String getCustGrp3()
得意先グループ 3を取得します。

戻り値:
custGrp3 得意先グループ 3

getCustGrp4

public String getCustGrp4()
得意先グループ 4を取得します。

戻り値:
custGrp4 得意先グループ 4

getCustGrp5

public String getCustGrp5()
得意先グループ 5を取得します。

戻り値:
custGrp5 得意先グループ 5

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getPurchNoS

public String getPurchNoS()
出荷先の得意先発注番号を取得します。

戻り値:
purchNoS 出荷先の得意先発注番号

getPoDatS

public String getPoDatS()
出荷先の出荷先発注日付を取得します。

戻り値:
poDatS 出荷先の出荷先発注日付

getPoMethS

public String getPoMethS()
出荷先の出荷先発注タイプを取得します。

戻り値:
poMethS 出荷先の出荷先発注タイプ

getRef1S

public String getRef1S()
出荷先文字を取得します。

戻り値:
ref1S 出荷先文字

getSdDocCat

public String getSdDocCat()
販売管理伝票カテゴリを取得します。

戻り値:
sdDocCat 販売管理伝票カテゴリ

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getWarDate

public String getWarDate()
保証期間の開始日付を取得します。

戻り値:
warDate 保証期間の開始日付

getShipCond

public String getShipCond()
出荷条件を取得します。

戻り値:
shipCond 出荷条件

getPpSearch

public String getPpSearch()
品目提案検索条件を取得します。

戻り値:
ppSearch 品目提案検索条件

getDunCount

public String getDunCount()
得意先商談回数を取得します。

戻り値:
dunCount 得意先商談回数

getDunDate

public String getDunDate()
得意先との前回の商談日を取得します。

戻り値:
dunDate 得意先との前回の商談日

getDlvschduse

public String getDlvschduse()
用途区分を取得します。

戻り値:
dlvschduse 用途区分

getPldlvstyp

public String getPldlvstyp()
MRP: 出荷計画タイプを取得します。

戻り値:
pldlvstyp MRP: 出荷計画タイプ

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getCompCdeB

public String getCompCdeB()
請求対象会社コードを取得します。

戻り値:
compCdeB 請求対象会社コード

getAlttaxCls

public String getAlttaxCls()
代替税分類を取得します。

戻り値:
alttaxCls 代替税分類

getTaxClass2

public String getTaxClass2()
得意先税分類 2を取得します。

戻り値:
taxClass2 得意先税分類 2

getTaxClass3

public String getTaxClass3()
得意先税分類 3を取得します。

戻り値:
taxClass3 得意先税分類 3

getTaxClass4

public String getTaxClass4()
得意先に対する税クラス 4を取得します。

戻り値:
taxClass4 得意先に対する税クラス 4

getTaxClass5

public String getTaxClass5()
得意先に対する税クラス 5を取得します。

戻り値:
taxClass5 得意先に対する税クラス 5

getTaxClass6

public String getTaxClass6()
得意先に対する税クラス 6を取得します。

戻り値:
taxClass6 得意先に対する税クラス 6

getTaxClass7

public String getTaxClass7()
得意先に対する税クラス 7を取得します。

戻り値:
taxClass7 得意先に対する税クラス 7

getTaxClass8

public String getTaxClass8()
得意先に対する税クラス 8を取得します。

戻り値:
taxClass8 得意先に対する税クラス 8

getTaxClass9

public String getTaxClass9()
得意先に対する税クラス 9を取得します。

戻り値:
taxClass9 得意先に対する税クラス 9

getRefDocL

public String getRefDocL()
参照伝票番号を取得します。

戻り値:
refDocL 参照伝票番号

getAssNumber

public String getAssNumber()
割当番号を取得します。

戻り値:
assNumber 割当番号

getRefdocCat

public String getRefdocCat()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refdocCat 先行販売管理伝票の伝票カテゴリ

getOrdcombIn

public String getOrdcombIn()
受注結合出荷区分を取得します。

戻り値:
ordcombIn 受注結合出荷区分

getBillSched

public String getBillSched()
請求日程 (稼働日カレンダ指定)を取得します。

戻り値:
billSched 請求日程 (稼働日カレンダ指定)

getInvoSched

public String getInvoSched()
請求書一覧日程 (稼働日カレンダ指定)を取得します。

戻り値:
invoSched 請求書一覧日程 (稼働日カレンダ指定)

getMnInvoice

public String getMnInvoice()
マニュアル請求書更新を取得します。

戻り値:
mnInvoice マニュアル請求書更新

getExrateFi

public String getExrateFi()
FI 転記の換算レート (直接相場)を取得します。

戻り値:
exrateFi FI 転記の換算レート (直接相場)

getAddValDy

public String getAddValDy()
有効日からの日数を取得します。

戻り値:
addValDy 有効日からの日数

getFixValDy

public String getFixValDy()
有効日日付を取得します。

戻り値:
fixValDy 有効日日付

getPymtMeth

public String getPymtMeth()
支払方法を取得します。

戻り値:
pymtMeth 支払方法

getAccntAsgn

public String getAccntAsgn()
得意先の勘定設定グループを取得します。

戻り値:
accntAsgn 得意先の勘定設定グループ

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getDunnKey

public String getDunnKey()
督促処理キーを取得します。

戻り値:
dunnKey 督促処理キー

getDunnBlock

public String getDunnBlock()
督促処理保留を取得します。

戻り値:
dunnBlock 督促処理保留

getPmtgarPro

public String getPmtgarPro()
支払保証決定表を取得します。

戻り値:
pmtgarPro 支払保証決定表

getDepartmNo

public String getDepartmNo()
部門コードを取得します。

戻り値:
departmNo 部門コード

getRecPoint

public String getRecPoint()
入荷ポイントを取得します。

戻り値:
recPoint 入荷ポイント

getDocNumFi

public String getDocNumFi()
ドキュメンタリクレジット処理: 内部番号を取得します。

戻り値:
docNumFi ドキュメンタリクレジット処理: 内部番号

getCstcndgrp1

public String getCstcndgrp1()
得意先条件グループ１を取得します。

戻り値:
cstcndgrp1 得意先条件グループ１

getCstcndgrp2

public String getCstcndgrp2()
得意先条件グループ２を取得します。

戻り値:
cstcndgrp2 得意先条件グループ２

getCstcndgrp3

public String getCstcndgrp3()
得意先条件グループ３を取得します。

戻り値:
cstcndgrp3 得意先条件グループ３

getCstcndgrp4

public String getCstcndgrp4()
得意先条件グループ４を取得します。

戻り値:
cstcndgrp4 得意先条件グループ４

getCstcndgrp5

public String getCstcndgrp5()
得意先条件グループ５を取得します。

戻り値:
cstcndgrp5 得意先条件グループ５

getDlvTime

public String getDlvTime()
契約出荷期間を取得します。

戻り値:
dlvTime 契約出荷期間

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getTaxdepCty

public String getTaxdepCty()
税出荷国を取得します。

戻り値:
taxdepCty 税出荷国

getTaxdstCty

public String getTaxdstCty()
税仕向国を取得します。

戻り値:
taxdstCty 税仕向国

getEutriDeal

public String getEutriDeal()
フラグ: EC 内三角取引を取得します。

戻り値:
eutriDeal フラグ: EC 内三角取引

getMastContr

public String getMastContr()
グループマスタ契約番号を取得します。

戻り値:
mastContr グループマスタ契約番号

getRefProc

public String getRefProc()
参照限定条件: 決定区分を取得します。

戻り値:
refProc 参照限定条件: 決定区分

getChkprtauth

public String getChkprtauth()
取引先権限チェックを取得します。

戻り値:
chkprtauth 取引先権限チェック

getCmlqtyDat

public String getCmlqtyDat()
累積出荷数量日付を取得します。

戻り値:
cmlqtyDat 累積出荷数量日付

getVersion

public String getVersion()
販売伝票バージョン番号を取得します。

戻り値:
version 販売伝票バージョン番号

getNotifNo

public String getNotifNo()
通知番号を取得します。

戻り値:
notifNo 通知番号

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getExchRateFiV

public String getExchRateFiV()
FI 転記の換算レート (間接相場)を取得します。

戻り値:
exchRateFiV FI 転記の換算レート (間接相場)

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getFkkConacct

public String getFkkConacct()
長さ 12 の文字項目を取得します。

戻り値:
fkkConacct 長さ 12 の文字項目

getCampaign

public String getCampaign()
総括プロジェクト計画: 外部 SAP システムの GUIDを取得します。

戻り値:
campaign 総括プロジェクト計画: 外部 SAP システムの GUID

getDocClass

public String getDocClass()
リリースおよびトランザクション管理を備えた元システムを取得します。

戻り値:
docClass リリースおよびトランザクション管理を備えた元システム

getHCurr

public String getHCurr()
通貨コードを取得します。

戻り値:
hCurr 通貨コード

getHCurrIso

public String getHCurrIso()
ISO 通貨コードを取得します。

戻り値:
hCurrIso ISO 通貨コード

getShipType

public String getShipType()
出荷タイプを取得します。

戻り値:
shipType 出荷タイプ

getSProcInd

public String getSProcInd()
特別処理区分を取得します。

戻り値:
sProcInd 特別処理区分

getRefDocLLong

public String getRefDocLLong()
参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。

戻り値:
refDocLLong 参照伝票番号 (依存関係についてはテキスト (長) を参照)

getLineTime

public String getLineTime()
納入日程の提案時刻 (現地時間: 販売組織参照)を取得します。

戻り値:
lineTime 納入日程の提案時刻 (現地時間: 販売組織参照)

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setRefdoctype

public void setRefdoctype(String refdoctype)
参照オブジェクトの伝票タイプを設定します。

パラメータ:
refdoctype - 参照オブジェクトの伝票タイプ

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setCollectNo

public void setCollectNo(String collectNo)
一括番号を設定します。

パラメータ:
collectNo - 一括番号

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setSalesGrp

public void setSalesGrp(String salesGrp)
営業グループを設定します。

パラメータ:
salesGrp - 営業グループ

setSalesOff

public void setSalesOff(String salesOff)
営業所を設定します。

パラメータ:
salesOff - 営業所

setReqDateH

public void setReqDateH(String reqDateH)
指定納入期日を設定します。

パラメータ:
reqDateH - 指定納入期日

setDateType

public void setDateType(String dateType)
提案日付タイプを設定します。

パラメータ:
dateType - 提案日付タイプ

setPurchDate

public void setPurchDate(String purchDate)
得意先発注日付を設定します。

パラメータ:
purchDate - 得意先発注日付

setPoMethod

public void setPoMethod(String poMethod)
得意先発注タイプを設定します。

パラメータ:
poMethod - 得意先発注タイプ

setPoSupplem

public void setPoSupplem(String poSupplem)
得意先発注番号補足を設定します。

パラメータ:
poSupplem - 得意先発注番号補足

setRef1

public void setRef1(String ref1)
得意先/仕入先の内部参照コードを設定します。

パラメータ:
ref1 - 得意先/仕入先の内部参照コード

setName

public void setName(String name)
発注者名称を設定します。

パラメータ:
name - 発注者名称

setTelephone

public void setTelephone(String telephone)
電話番号を設定します。

パラメータ:
telephone - 電話番号

setPriceGrp

public void setPriceGrp(String priceGrp)
価格グループ (得意先)を設定します。

パラメータ:
priceGrp - 価格グループ (得意先)

setCustGroup

public void setCustGroup(String custGroup)
得意先グループを設定します。

パラメータ:
custGroup - 得意先グループ

setSalesDist

public void setSalesDist(String salesDist)
販売地域を設定します。

パラメータ:
salesDist - 販売地域

setPriceList

public void setPriceList(String priceList)
価格表タイプを設定します。

パラメータ:
priceList - 価格表タイプ

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ 2を設定します。

パラメータ:
incoterms2 - インコタームズ 2

setPmnttrms

public void setPmnttrms(String pmnttrms)
支払条件キーを設定します。

パラメータ:
pmnttrms - 支払条件キー

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setBillBlock

public void setBillBlock(String billBlock)
販売管理伝票の請求ブロックを設定します。

パラメータ:
billBlock - 販売管理伝票の請求ブロック

setOrdReason

public void setOrdReason(String ordReason)
受注理由 (取引理由)を設定します。

パラメータ:
ordReason - 受注理由 (取引理由)

setComplDlv

public void setComplDlv(String complDlv)
一括納入区分を設定します。

パラメータ:
complDlv - 一括納入区分

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setQtValidF

public void setQtValidF(String qtValidF)
見積/引合有効開始日を設定します。

パラメータ:
qtValidF - 見積/引合有効開始日

setQtValidT

public void setQtValidT(String qtValidT)
見積の有効終了日を設定します。

パラメータ:
qtValidT - 見積の有効終了日

setCtValidF

public void setCtValidF(String ctValidF)
有効開始日付 (販売契約/品目提案)を設定します。

パラメータ:
ctValidF - 有効開始日付 (販売契約/品目提案)

setCtValidT

public void setCtValidT(String ctValidT)
有効終了日付 (販売契約/品目提案)を設定します。

パラメータ:
ctValidT - 有効終了日付 (販売契約/品目提案)

setCustGrp1

public void setCustGrp1(String custGrp1)
得意先グループ 1を設定します。

パラメータ:
custGrp1 - 得意先グループ 1

setCustGrp2

public void setCustGrp2(String custGrp2)
得意先グループ 2を設定します。

パラメータ:
custGrp2 - 得意先グループ 2

setCustGrp3

public void setCustGrp3(String custGrp3)
得意先グループ 3を設定します。

パラメータ:
custGrp3 - 得意先グループ 3

setCustGrp4

public void setCustGrp4(String custGrp4)
得意先グループ 4を設定します。

パラメータ:
custGrp4 - 得意先グループ 4

setCustGrp5

public void setCustGrp5(String custGrp5)
得意先グループ 5を設定します。

パラメータ:
custGrp5 - 得意先グループ 5

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setPurchNoS

public void setPurchNoS(String purchNoS)
出荷先の得意先発注番号を設定します。

パラメータ:
purchNoS - 出荷先の得意先発注番号

setPoDatS

public void setPoDatS(String poDatS)
出荷先の出荷先発注日付を設定します。

パラメータ:
poDatS - 出荷先の出荷先発注日付

setPoMethS

public void setPoMethS(String poMethS)
出荷先の出荷先発注タイプを設定します。

パラメータ:
poMethS - 出荷先の出荷先発注タイプ

setRef1S

public void setRef1S(String ref1S)
出荷先文字を設定します。

パラメータ:
ref1S - 出荷先文字

setSdDocCat

public void setSdDocCat(String sdDocCat)
販売管理伝票カテゴリを設定します。

パラメータ:
sdDocCat - 販売管理伝票カテゴリ

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setWarDate

public void setWarDate(String warDate)
保証期間の開始日付を設定します。

パラメータ:
warDate - 保証期間の開始日付

setShipCond

public void setShipCond(String shipCond)
出荷条件を設定します。

パラメータ:
shipCond - 出荷条件

setPpSearch

public void setPpSearch(String ppSearch)
品目提案検索条件を設定します。

パラメータ:
ppSearch - 品目提案検索条件

setDunCount

public void setDunCount(String dunCount)
得意先商談回数を設定します。

パラメータ:
dunCount - 得意先商談回数

setDunDate

public void setDunDate(String dunDate)
得意先との前回の商談日を設定します。

パラメータ:
dunDate - 得意先との前回の商談日

setDlvschduse

public void setDlvschduse(String dlvschduse)
用途区分を設定します。

パラメータ:
dlvschduse - 用途区分

setPldlvstyp

public void setPldlvstyp(String pldlvstyp)
MRP: 出荷計画タイプを設定します。

パラメータ:
pldlvstyp - MRP: 出荷計画タイプ

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setCompCdeB

public void setCompCdeB(String compCdeB)
請求対象会社コードを設定します。

パラメータ:
compCdeB - 請求対象会社コード

setAlttaxCls

public void setAlttaxCls(String alttaxCls)
代替税分類を設定します。

パラメータ:
alttaxCls - 代替税分類

setTaxClass2

public void setTaxClass2(String taxClass2)
得意先税分類 2を設定します。

パラメータ:
taxClass2 - 得意先税分類 2

setTaxClass3

public void setTaxClass3(String taxClass3)
得意先税分類 3を設定します。

パラメータ:
taxClass3 - 得意先税分類 3

setTaxClass4

public void setTaxClass4(String taxClass4)
得意先に対する税クラス 4を設定します。

パラメータ:
taxClass4 - 得意先に対する税クラス 4

setTaxClass5

public void setTaxClass5(String taxClass5)
得意先に対する税クラス 5を設定します。

パラメータ:
taxClass5 - 得意先に対する税クラス 5

setTaxClass6

public void setTaxClass6(String taxClass6)
得意先に対する税クラス 6を設定します。

パラメータ:
taxClass6 - 得意先に対する税クラス 6

setTaxClass7

public void setTaxClass7(String taxClass7)
得意先に対する税クラス 7を設定します。

パラメータ:
taxClass7 - 得意先に対する税クラス 7

setTaxClass8

public void setTaxClass8(String taxClass8)
得意先に対する税クラス 8を設定します。

パラメータ:
taxClass8 - 得意先に対する税クラス 8

setTaxClass9

public void setTaxClass9(String taxClass9)
得意先に対する税クラス 9を設定します。

パラメータ:
taxClass9 - 得意先に対する税クラス 9

setRefDocL

public void setRefDocL(String refDocL)
参照伝票番号を設定します。

パラメータ:
refDocL - 参照伝票番号

setAssNumber

public void setAssNumber(String assNumber)
割当番号を設定します。

パラメータ:
assNumber - 割当番号

setRefdocCat

public void setRefdocCat(String refdocCat)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refdocCat - 先行販売管理伝票の伝票カテゴリ

setOrdcombIn

public void setOrdcombIn(String ordcombIn)
受注結合出荷区分を設定します。

パラメータ:
ordcombIn - 受注結合出荷区分

setBillSched

public void setBillSched(String billSched)
請求日程 (稼働日カレンダ指定)を設定します。

パラメータ:
billSched - 請求日程 (稼働日カレンダ指定)

setInvoSched

public void setInvoSched(String invoSched)
請求書一覧日程 (稼働日カレンダ指定)を設定します。

パラメータ:
invoSched - 請求書一覧日程 (稼働日カレンダ指定)

setMnInvoice

public void setMnInvoice(String mnInvoice)
マニュアル請求書更新を設定します。

パラメータ:
mnInvoice - マニュアル請求書更新

setExrateFi

public void setExrateFi(String exrateFi)
FI 転記の換算レート (直接相場)を設定します。

パラメータ:
exrateFi - FI 転記の換算レート (直接相場)

setAddValDy

public void setAddValDy(String addValDy)
有効日からの日数を設定します。

パラメータ:
addValDy - 有効日からの日数

setFixValDy

public void setFixValDy(String fixValDy)
有効日日付を設定します。

パラメータ:
fixValDy - 有効日日付

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します。

パラメータ:
pymtMeth - 支払方法

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
得意先の勘定設定グループを設定します。

パラメータ:
accntAsgn - 得意先の勘定設定グループ

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setDunnKey

public void setDunnKey(String dunnKey)
督促処理キーを設定します。

パラメータ:
dunnKey - 督促処理キー

setDunnBlock

public void setDunnBlock(String dunnBlock)
督促処理保留を設定します。

パラメータ:
dunnBlock - 督促処理保留

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
支払保証決定表を設定します。

パラメータ:
pmtgarPro - 支払保証決定表

setDepartmNo

public void setDepartmNo(String departmNo)
部門コードを設定します。

パラメータ:
departmNo - 部門コード

setRecPoint

public void setRecPoint(String recPoint)
入荷ポイントを設定します。

パラメータ:
recPoint - 入荷ポイント

setDocNumFi

public void setDocNumFi(String docNumFi)
ドキュメンタリクレジット処理: 内部番号を設定します。

パラメータ:
docNumFi - ドキュメンタリクレジット処理: 内部番号

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
得意先条件グループ１を設定します。

パラメータ:
cstcndgrp1 - 得意先条件グループ１

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
得意先条件グループ２を設定します。

パラメータ:
cstcndgrp2 - 得意先条件グループ２

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
得意先条件グループ３を設定します。

パラメータ:
cstcndgrp3 - 得意先条件グループ３

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
得意先条件グループ４を設定します。

パラメータ:
cstcndgrp4 - 得意先条件グループ４

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
得意先条件グループ５を設定します。

パラメータ:
cstcndgrp5 - 得意先条件グループ５

setDlvTime

public void setDlvTime(String dlvTime)
契約出荷期間を設定します。

パラメータ:
dlvTime - 契約出荷期間

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setTaxdepCty

public void setTaxdepCty(String taxdepCty)
税出荷国を設定します。

パラメータ:
taxdepCty - 税出荷国

setTaxdstCty

public void setTaxdstCty(String taxdstCty)
税仕向国を設定します。

パラメータ:
taxdstCty - 税仕向国

setEutriDeal

public void setEutriDeal(String eutriDeal)
フラグ: EC 内三角取引を設定します。

パラメータ:
eutriDeal - フラグ: EC 内三角取引

setMastContr

public void setMastContr(String mastContr)
グループマスタ契約番号を設定します。

パラメータ:
mastContr - グループマスタ契約番号

setRefProc

public void setRefProc(String refProc)
参照限定条件: 決定区分を設定します。

パラメータ:
refProc - 参照限定条件: 決定区分

setChkprtauth

public void setChkprtauth(String chkprtauth)
取引先権限チェックを設定します。

パラメータ:
chkprtauth - 取引先権限チェック

setCmlqtyDat

public void setCmlqtyDat(String cmlqtyDat)
累積出荷数量日付を設定します。

パラメータ:
cmlqtyDat - 累積出荷数量日付

setVersion

public void setVersion(String version)
販売伝票バージョン番号を設定します。

パラメータ:
version - 販売伝票バージョン番号

setNotifNo

public void setNotifNo(String notifNo)
通知番号を設定します。

パラメータ:
notifNo - 通知番号

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
FI 転記の換算レート (間接相場)を設定します。

パラメータ:
exchRateFiV - FI 転記の換算レート (間接相場)

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setFkkConacct

public void setFkkConacct(String fkkConacct)
長さ 12 の文字項目を設定します。

パラメータ:
fkkConacct - 長さ 12 の文字項目

setCampaign

public void setCampaign(String campaign)
総括プロジェクト計画: 外部 SAP システムの GUIDを設定します。

パラメータ:
campaign - 総括プロジェクト計画: 外部 SAP システムの GUID

setDocClass

public void setDocClass(String docClass)
リリースおよびトランザクション管理を備えた元システムを設定します。

パラメータ:
docClass - リリースおよびトランザクション管理を備えた元システム

setHCurr

public void setHCurr(String hCurr)
通貨コードを設定します。

パラメータ:
hCurr - 通貨コード

setHCurrIso

public void setHCurrIso(String hCurrIso)
ISO 通貨コードを設定します。

パラメータ:
hCurrIso - ISO 通貨コード

setShipType

public void setShipType(String shipType)
出荷タイプを設定します。

パラメータ:
shipType - 出荷タイプ

setSProcInd

public void setSProcInd(String sProcInd)
特別処理区分を設定します。

パラメータ:
sProcInd - 特別処理区分

setRefDocLLong

public void setRefDocLLong(String refDocLLong)
参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。

パラメータ:
refDocLLong - 参照伝票番号 (依存関係についてはテキスト (長) を参照)

setLineTime

public void setLineTime(String lineTime)
納入日程の提案時刻 (現地時間: 販売組織参照)を設定します。

パラメータ:
lineTime - 納入日程の提案時刻 (現地時間: 販売組織参照)

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeaderInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス HeaderInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX
すべての実装インタフェース:
Serializable
public class HeaderInX
extends Object
implements Serializable

ヘッダデータチェックボックス情報クラス
機能は以下の通り

  • ヘッダデータチェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeaderInX()
ヘッダデータチェックボックス情報を作成します。
メソッドの概要
String | getAccntAsgn() 関連ユーザデータ項目の更新情報を取得します。
String | getAddValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getAlttaxCls() 関連ユーザデータ項目の更新情報を取得します。
String | getAssNumber() 関連ユーザデータ項目の更新情報を取得します。
String | getBillBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getBillDate() 関連ユーザデータ項目の更新情報を取得します。
String | getBillSched() 関連ユーザデータ項目の更新情報を取得します。
String | getCalcMotive() 関連ユーザデータ項目の更新情報を取得します。
String | getCampaign() 関連ユーザデータ項目の更新情報を取得します。
String | getChkprtauth() 関連ユーザデータ項目の更新情報を取得します。
String | getCmlqtyDat() 関連ユーザデータ項目の更新情報を取得します。
String | getCollectNo() 関連ユーザデータ項目の更新情報を取得します。
String | getCompCdeB() 関連ユーザデータ項目の更新情報を取得します。
String | getComplDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getCtValidF() 関連ユーザデータ項目の更新情報を取得します。
String | getCtValidT() 関連ユーザデータ項目の更新情報を取得します。
String | getCurrency() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getDateType() 関連ユーザデータ項目の更新情報を取得します。
String | getDepartmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getDistrChan() 関連ユーザデータ項目の更新情報を取得します。
String | getDivision() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvschduse() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getDocClass() 関連ユーザデータ項目の更新情報を取得します。
String | getDocDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDocNumFi() 関連ユーザデータ項目の更新情報を取得します。
String | getDocType() 関連ユーザデータ項目の更新情報を取得します。
String | getDunCount() 関連ユーザデータ項目の更新情報を取得します。
String | getDunDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnKey() 関連ユーザデータ項目の更新情報を取得します。
String | getEutriDeal() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRate() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRateV() 関連ユーザデータ項目の更新情報を取得します。
String | getExchRateFiV() 関連ユーザデータ項目の更新情報を取得します。
String | getExrateFi() 関連ユーザデータ項目の更新情報を取得します。
String | getFixValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getFkkConacct() 関連ユーザデータ項目の更新情報を取得します。
String | getHCurr() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms1() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms2() 関連ユーザデータ項目の更新情報を取得します。
String | getInvoSched() 関連ユーザデータ項目の更新情報を取得します。
String | getLineTime() 関連ユーザデータ項目の更新情報を取得します。
String | getMastContr() 関連ユーザデータ項目の更新情報を取得します。
String | getMnInvoice() 関連ユーザデータ項目の更新情報を取得します。
String | getName() 関連ユーザデータ項目の更新情報を取得します。
String | getNotifNo() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdcombIn() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdReason() 関連ユーザデータ項目の更新情報を取得します。
String | getPldlvstyp() 関連ユーザデータ項目の更新情報を取得します。
String | getPmnttrms() 関連ユーザデータ項目の更新情報を取得します。
String | getPmtgarPro() 関連ユーザデータ項目の更新情報を取得します。
String | getPoDatS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoitmNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethod() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoSupplem() 関連ユーザデータ項目の更新情報を取得します。
String | getPpSearch() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceList() 関連ユーザデータ項目の更新情報を取得します。
String | getPromotion() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoC() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPymtMeth() 関連ユーザデータ項目の更新情報を取得します。
String | getQtValidF() 関連ユーザデータ項目の更新情報を取得します。
String | getQtValidT() 関連ユーザデータ項目の更新情報を取得します。
String | getRecPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1S() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDoc() 関連ユーザデータ項目の更新情報を取得します。
String | getRefdocCat() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocL() 関連ユーザデータ項目の更新情報を取得します。
String | getRefProc() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDateH() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesDist() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesOff() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesOrg() 関連ユーザデータ項目の更新情報を取得します。
String | getSdDocCat() 関連ユーザデータ項目の更新情報を取得します。
String | getServDate() 関連ユーザデータ項目の更新情報を取得します。
String | getShipCond() 関連ユーザデータ項目の更新情報を取得します。
String | getShipType() 関連ユーザデータ項目の更新情報を取得します。
String | getSProcInd() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass2() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass3() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass4() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass5() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass6() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass7() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass8() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass9() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxdepCty() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxdstCty() 関連ユーザデータ項目の更新情報を取得します。
String | getTelephone() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getVersion() 関連ユーザデータ項目の更新情報を取得します。
String | getWarDate() 関連ユーザデータ項目の更新情報を取得します。
String | getWbsElem() 関連ユーザデータ項目の更新情報を取得します。
void | setAccntAsgn(String accntAsgn) 関連ユーザデータ項目の更新情報を設定します。
void | setAddValDy(String addValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setAlttaxCls(String alttaxCls) 関連ユーザデータ項目の更新情報を設定します。
void | setAssNumber(String assNumber) 関連ユーザデータ項目の更新情報を設定します。
void | setBillBlock(String billBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setBillDate(String billDate) 関連ユーザデータ項目の更新情報を設定します。
void | setBillSched(String billSched) 関連ユーザデータ項目の更新情報を設定します。
void | setCalcMotive(String calcMotive) 関連ユーザデータ項目の更新情報を設定します。
void | setCampaign(String campaign) 関連ユーザデータ項目の更新情報を設定します。
void | setChkprtauth(String chkprtauth) 関連ユーザデータ項目の更新情報を設定します。
void | setCmlqtyDat(String cmlqtyDat) 関連ユーザデータ項目の更新情報を設定します。
void | setCollectNo(String collectNo) 関連ユーザデータ項目の更新情報を設定します。
void | setCompCdeB(String compCdeB) 関連ユーザデータ項目の更新情報を設定します。
void | setComplDlv(String complDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp1(String cstcndgrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp2(String cstcndgrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp3(String cstcndgrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp4(String cstcndgrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp5(String cstcndgrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setCtValidF(String ctValidF) 関連ユーザデータ項目の更新情報を設定します。
void | setCtValidT(String ctValidT) 関連ユーザデータ項目の更新情報を設定します。
void | setCurrency(String currency) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGroup(String custGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp1(String custGrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp2(String custGrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp3(String custGrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp4(String custGrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp5(String custGrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setDateType(String dateType) 関連ユーザデータ項目の更新情報を設定します。
void | setDepartmNo(String departmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setDistrChan(String distrChan) 関連ユーザデータ項目の更新情報を設定します。
void | setDivision(String division) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvBlock(String dlvBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvschduse(String dlvschduse) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setDocClass(String docClass) 関連ユーザデータ項目の更新情報を設定します。
void | setDocDate(String docDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDocNumFi(String docNumFi) 関連ユーザデータ項目の更新情報を設定します。
void | setDocType(String docType) 関連ユーザデータ項目の更新情報を設定します。
void | setDunCount(String dunCount) 関連ユーザデータ項目の更新情報を設定します。
void | setDunDate(String dunDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnBlock(String dunnBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnKey(String dunnKey) 関連ユーザデータ項目の更新情報を設定します。
void | setEutriDeal(String eutriDeal) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRate(String exchgRate) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRateV(String exchgRateV) 関連ユーザデータ項目の更新情報を設定します。
void | setExchRateFiV(String exchRateFiV) 関連ユーザデータ項目の更新情報を設定します。
void | setExrateFi(String exrateFi) 関連ユーザデータ項目の更新情報を設定します。
void | setFixValDy(String fixValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setFkkConacct(String fkkConacct) 関連ユーザデータ項目の更新情報を設定します。
void | setHCurr(String hCurr) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms1(String incoterms1) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms2(String incoterms2) 関連ユーザデータ項目の更新情報を設定します。
void | setInvoSched(String invoSched) 関連ユーザデータ項目の更新情報を設定します。
void | setLineTime(String lineTime) 関連ユーザデータ項目の更新情報を設定します。
void | setMastContr(String mastContr) 関連ユーザデータ項目の更新情報を設定します。
void | setMnInvoice(String mnInvoice) 関連ユーザデータ項目の更新情報を設定します。
void | setName(String name) 関連ユーザデータ項目の更新情報を設定します。
void | setNotifNo(String notifNo) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdcombIn(String ordcombIn) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdReason(String ordReason) 関連ユーザデータ項目の更新情報を設定します。
void | setPldlvstyp(String pldlvstyp) 関連ユーザデータ項目の更新情報を設定します。
void | setPmnttrms(String pmnttrms) 関連ユーザデータ項目の更新情報を設定します。
void | setPmtgarPro(String pmtgarPro) 関連ユーザデータ項目の更新情報を設定します。
void | setPoDatS(String poDatS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoitmNoS(String poitmNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethod(String poMethod) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethS(String poMethS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoSupplem(String poSupplem) 関連ユーザデータ項目の更新情報を設定します。
void | setPpSearch(String ppSearch) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceDate(String priceDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceGrp(String priceGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceList(String priceList) 関連ユーザデータ項目の更新情報を設定します。
void | setPromotion(String promotion) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchDate(String purchDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoC(String purchNoC) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoS(String purchNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPymtMeth(String pymtMeth) 関連ユーザデータ項目の更新情報を設定します。
void | setQtValidF(String qtValidF) 関連ユーザデータ項目の更新情報を設定します。
void | setQtValidT(String qtValidT) 関連ユーザデータ項目の更新情報を設定します。
void | setRecPoint(String recPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1(String ref1) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1S(String ref1S) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDoc(String refDoc) 関連ユーザデータ項目の更新情報を設定します。
void | setRefdocCat(String refdocCat) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocL(String refDocL) 関連ユーザデータ項目の更新情報を設定します。
void | setRefProc(String refProc) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDateH(String reqDateH) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesDist(String salesDist) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesGrp(String salesGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesOff(String salesOff) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesOrg(String salesOrg) 関連ユーザデータ項目の更新情報を設定します。
void | setSdDocCat(String sdDocCat) 関連ユーザデータ項目の更新情報を設定します。
void | setServDate(String servDate) 関連ユーザデータ項目の更新情報を設定します。
void | setShipCond(String shipCond) 関連ユーザデータ項目の更新情報を設定します。
void | setShipType(String shipType) 関連ユーザデータ項目の更新情報を設定します。
void | setSProcInd(String sProcInd) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass2(String taxClass2) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass3(String taxClass3) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass4(String taxClass4) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass5(String taxClass5) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass6(String taxClass6) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass7(String taxClass7) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass8(String taxClass8) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass9(String taxClass9) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxdepCty(String taxdepCty) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxdstCty(String taxdstCty) 関連ユーザデータ項目の更新情報を設定します。
void | setTelephone(String telephone) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setVersion(String version) 関連ユーザデータ項目の更新情報を設定します。
void | setWarDate(String warDate) 関連ユーザデータ項目の更新情報を設定します。
void | setWbsElem(String wbsElem) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeaderInX

public HeaderInX()
ヘッダデータチェックボックス情報を作成します。

メソッドの詳細

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getDocType

public String getDocType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docType 関連ユーザデータ項目の更新情報

getCollectNo

public String getCollectNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
collectNo 関連ユーザデータ項目の更新情報

getSalesOrg

public String getSalesOrg()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesOrg 関連ユーザデータ項目の更新情報

getDistrChan

public String getDistrChan()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
distrChan 関連ユーザデータ項目の更新情報

getDivision

public String getDivision()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
division 関連ユーザデータ項目の更新情報

getSalesGrp

public String getSalesGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesGrp 関連ユーザデータ項目の更新情報

getSalesOff

public String getSalesOff()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesOff 関連ユーザデータ項目の更新情報

getReqDateH

public String getReqDateH()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDateH 関連ユーザデータ項目の更新情報

getDateType

public String getDateType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dateType 関連ユーザデータ項目の更新情報

getPurchDate

public String getPurchDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchDate 関連ユーザデータ項目の更新情報

getPoMethod

public String getPoMethod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethod 関連ユーザデータ項目の更新情報

getPoSupplem

public String getPoSupplem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poSupplem 関連ユーザデータ項目の更新情報

getRef1

public String getRef1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1 関連ユーザデータ項目の更新情報

getName

public String getName()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
name 関連ユーザデータ項目の更新情報

getTelephone

public String getTelephone()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
telephone 関連ユーザデータ項目の更新情報

getPriceGrp

public String getPriceGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceGrp 関連ユーザデータ項目の更新情報

getCustGroup

public String getCustGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGroup 関連ユーザデータ項目の更新情報

getSalesDist

public String getSalesDist()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesDist 関連ユーザデータ項目の更新情報

getPriceList

public String getPriceList()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceList 関連ユーザデータ項目の更新情報

getIncoterms1

public String getIncoterms1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms1 関連ユーザデータ項目の更新情報

getIncoterms2

public String getIncoterms2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms2 関連ユーザデータ項目の更新情報

getPmnttrms

public String getPmnttrms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmnttrms 関連ユーザデータ項目の更新情報

getDlvBlock

public String getDlvBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvBlock 関連ユーザデータ項目の更新情報

getBillBlock

public String getBillBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billBlock 関連ユーザデータ項目の更新情報

getOrdReason

public String getOrdReason()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordReason 関連ユーザデータ項目の更新情報

getComplDlv

public String getComplDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
complDlv 関連ユーザデータ項目の更新情報

getPriceDate

public String getPriceDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceDate 関連ユーザデータ項目の更新情報

getQtValidF

public String getQtValidF()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
qtValidF 関連ユーザデータ項目の更新情報

getQtValidT

public String getQtValidT()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
qtValidT 関連ユーザデータ項目の更新情報

getCtValidF

public String getCtValidF()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ctValidF 関連ユーザデータ項目の更新情報

getCtValidT

public String getCtValidT()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ctValidT 関連ユーザデータ項目の更新情報

getCustGrp1

public String getCustGrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp1 関連ユーザデータ項目の更新情報

getCustGrp2

public String getCustGrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp2 関連ユーザデータ項目の更新情報

getCustGrp3

public String getCustGrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp3 関連ユーザデータ項目の更新情報

getCustGrp4

public String getCustGrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp4 関連ユーザデータ項目の更新情報

getCustGrp5

public String getCustGrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp5 関連ユーザデータ項目の更新情報

getPurchNoC

public String getPurchNoC()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoC 関連ユーザデータ項目の更新情報

getPurchNoS

public String getPurchNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoS 関連ユーザデータ項目の更新情報

getPoDatS

public String getPoDatS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poDatS 関連ユーザデータ項目の更新情報

getPoMethS

public String getPoMethS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethS 関連ユーザデータ項目の更新情報

getRef1S

public String getRef1S()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1S 関連ユーザデータ項目の更新情報

getSdDocCat

public String getSdDocCat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sdDocCat 関連ユーザデータ項目の更新情報

getDocDate

public String getDocDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docDate 関連ユーザデータ項目の更新情報

getWarDate

public String getWarDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
warDate 関連ユーザデータ項目の更新情報

getShipCond

public String getShipCond()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipCond 関連ユーザデータ項目の更新情報

getPpSearch

public String getPpSearch()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ppSearch 関連ユーザデータ項目の更新情報

getDunCount

public String getDunCount()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunCount 関連ユーザデータ項目の更新情報

getDunDate

public String getDunDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunDate 関連ユーザデータ項目の更新情報

getDlvschduse

public String getDlvschduse()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvschduse 関連ユーザデータ項目の更新情報

getPldlvstyp

public String getPldlvstyp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pldlvstyp 関連ユーザデータ項目の更新情報

getRefDoc

public String getRefDoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDoc 関連ユーザデータ項目の更新情報

getCompCdeB

public String getCompCdeB()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
compCdeB 関連ユーザデータ項目の更新情報

getAlttaxCls

public String getAlttaxCls()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
alttaxCls 関連ユーザデータ項目の更新情報

getTaxClass2

public String getTaxClass2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass2 関連ユーザデータ項目の更新情報

getTaxClass3

public String getTaxClass3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass3 関連ユーザデータ項目の更新情報

getTaxClass4

public String getTaxClass4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass4 関連ユーザデータ項目の更新情報

getTaxClass5

public String getTaxClass5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass5 関連ユーザデータ項目の更新情報

getTaxClass6

public String getTaxClass6()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass6 関連ユーザデータ項目の更新情報

getTaxClass7

public String getTaxClass7()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass7 関連ユーザデータ項目の更新情報

getTaxClass8

public String getTaxClass8()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass8 関連ユーザデータ項目の更新情報

getTaxClass9

public String getTaxClass9()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass9 関連ユーザデータ項目の更新情報

getRefDocL

public String getRefDocL()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocL 関連ユーザデータ項目の更新情報

getAssNumber

public String getAssNumber()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
assNumber 関連ユーザデータ項目の更新情報

getRefdocCat

public String getRefdocCat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refdocCat 関連ユーザデータ項目の更新情報

getOrdcombIn

public String getOrdcombIn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordcombIn 関連ユーザデータ項目の更新情報

getBillSched

public String getBillSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billSched 関連ユーザデータ項目の更新情報

getInvoSched

public String getInvoSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
invoSched 関連ユーザデータ項目の更新情報

getMnInvoice

public String getMnInvoice()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mnInvoice 関連ユーザデータ項目の更新情報

getExrateFi

public String getExrateFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exrateFi 関連ユーザデータ項目の更新情報

getAddValDy

public String getAddValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
addValDy 関連ユーザデータ項目の更新情報

getFixValDy

public String getFixValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixValDy 関連ユーザデータ項目の更新情報

getPymtMeth

public String getPymtMeth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pymtMeth 関連ユーザデータ項目の更新情報

getAccntAsgn

public String getAccntAsgn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
accntAsgn 関連ユーザデータ項目の更新情報

getExchgRate

public String getExchgRate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRate 関連ユーザデータ項目の更新情報

getBillDate

public String getBillDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billDate 関連ユーザデータ項目の更新情報

getServDate

public String getServDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
servDate 関連ユーザデータ項目の更新情報

getDunnKey

public String getDunnKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnKey 関連ユーザデータ項目の更新情報

getDunnBlock

public String getDunnBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnBlock 関連ユーザデータ項目の更新情報

getPromotion

public String getPromotion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
promotion 関連ユーザデータ項目の更新情報

getPmtgarPro

public String getPmtgarPro()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmtgarPro 関連ユーザデータ項目の更新情報

getDepartmNo

public String getDepartmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
departmNo 関連ユーザデータ項目の更新情報

getRecPoint

public String getRecPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
recPoint 関連ユーザデータ項目の更新情報

getPoitmNoS

public String getPoitmNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poitmNoS 関連ユーザデータ項目の更新情報

getDocNumFi

public String getDocNumFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docNumFi 関連ユーザデータ項目の更新情報

getCstcndgrp1

public String getCstcndgrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp1 関連ユーザデータ項目の更新情報

getCstcndgrp2

public String getCstcndgrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp2 関連ユーザデータ項目の更新情報

getCstcndgrp3

public String getCstcndgrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp3 関連ユーザデータ項目の更新情報

getCstcndgrp4

public String getCstcndgrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp4 関連ユーザデータ項目の更新情報

getCstcndgrp5

public String getCstcndgrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp5 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getCurrency

public String getCurrency()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
currency 関連ユーザデータ項目の更新情報

getTaxdepCty

public String getTaxdepCty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxdepCty 関連ユーザデータ項目の更新情報

getTaxdstCty

public String getTaxdstCty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxdstCty 関連ユーザデータ項目の更新情報

getEutriDeal

public String getEutriDeal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
eutriDeal 関連ユーザデータ項目の更新情報

getMastContr

public String getMastContr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mastContr 関連ユーザデータ項目の更新情報

getRefProc

public String getRefProc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refProc 関連ユーザデータ項目の更新情報

getChkprtauth

public String getChkprtauth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
chkprtauth 関連ユーザデータ項目の更新情報

getCmlqtyDat

public String getCmlqtyDat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cmlqtyDat 関連ユーザデータ項目の更新情報

getVersion

public String getVersion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
version 関連ユーザデータ項目の更新情報

getNotifNo

public String getNotifNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
notifNo 関連ユーザデータ項目の更新情報

getWbsElem

public String getWbsElem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
wbsElem 関連ユーザデータ項目の更新情報

getExchRateFiV

public String getExchRateFiV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchRateFiV 関連ユーザデータ項目の更新情報

getExchgRateV

public String getExchgRateV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRateV 関連ユーザデータ項目の更新情報

getFkkConacct

public String getFkkConacct()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fkkConacct 関連ユーザデータ項目の更新情報

getCampaign

public String getCampaign()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
campaign 関連ユーザデータ項目の更新情報

getDocClass

public String getDocClass()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docClass 関連ユーザデータ項目の更新情報

getHCurr

public String getHCurr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
hCurr 関連ユーザデータ項目の更新情報

getShipType

public String getShipType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipType 関連ユーザデータ項目の更新情報

getSProcInd

public String getSProcInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sProcInd 関連ユーザデータ項目の更新情報

getLineTime

public String getLineTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
lineTime 関連ユーザデータ項目の更新情報

getCalcMotive

public String getCalcMotive()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
calcMotive 関連ユーザデータ項目の更新情報

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setDocType

public void setDocType(String docType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docType - 関連ユーザデータ項目の更新情報

setCollectNo

public void setCollectNo(String collectNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
collectNo - 関連ユーザデータ項目の更新情報

setSalesOrg

public void setSalesOrg(String salesOrg)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesOrg - 関連ユーザデータ項目の更新情報

setDistrChan

public void setDistrChan(String distrChan)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
distrChan - 関連ユーザデータ項目の更新情報

setDivision

public void setDivision(String division)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
division - 関連ユーザデータ項目の更新情報

setSalesGrp

public void setSalesGrp(String salesGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesGrp - 関連ユーザデータ項目の更新情報

setSalesOff

public void setSalesOff(String salesOff)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesOff - 関連ユーザデータ項目の更新情報

setReqDateH

public void setReqDateH(String reqDateH)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDateH - 関連ユーザデータ項目の更新情報

setDateType

public void setDateType(String dateType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dateType - 関連ユーザデータ項目の更新情報

setPurchDate

public void setPurchDate(String purchDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchDate - 関連ユーザデータ項目の更新情報

setPoMethod

public void setPoMethod(String poMethod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethod - 関連ユーザデータ項目の更新情報

setPoSupplem

public void setPoSupplem(String poSupplem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poSupplem - 関連ユーザデータ項目の更新情報

setRef1

public void setRef1(String ref1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1 - 関連ユーザデータ項目の更新情報

setName

public void setName(String name)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
name - 関連ユーザデータ項目の更新情報

setTelephone

public void setTelephone(String telephone)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
telephone - 関連ユーザデータ項目の更新情報

setPriceGrp

public void setPriceGrp(String priceGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceGrp - 関連ユーザデータ項目の更新情報

setCustGroup

public void setCustGroup(String custGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGroup - 関連ユーザデータ項目の更新情報

setSalesDist

public void setSalesDist(String salesDist)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesDist - 関連ユーザデータ項目の更新情報

setPriceList

public void setPriceList(String priceList)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceList - 関連ユーザデータ項目の更新情報

setIncoterms1

public void setIncoterms1(String incoterms1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms1 - 関連ユーザデータ項目の更新情報

setIncoterms2

public void setIncoterms2(String incoterms2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms2 - 関連ユーザデータ項目の更新情報

setPmnttrms

public void setPmnttrms(String pmnttrms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmnttrms - 関連ユーザデータ項目の更新情報

setDlvBlock

public void setDlvBlock(String dlvBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvBlock - 関連ユーザデータ項目の更新情報

setBillBlock

public void setBillBlock(String billBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billBlock - 関連ユーザデータ項目の更新情報

setOrdReason

public void setOrdReason(String ordReason)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordReason - 関連ユーザデータ項目の更新情報

setComplDlv

public void setComplDlv(String complDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
complDlv - 関連ユーザデータ項目の更新情報

setPriceDate

public void setPriceDate(String priceDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceDate - 関連ユーザデータ項目の更新情報

setQtValidF

public void setQtValidF(String qtValidF)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
qtValidF - 関連ユーザデータ項目の更新情報

setQtValidT

public void setQtValidT(String qtValidT)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
qtValidT - 関連ユーザデータ項目の更新情報

setCtValidF

public void setCtValidF(String ctValidF)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ctValidF - 関連ユーザデータ項目の更新情報

setCtValidT

public void setCtValidT(String ctValidT)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ctValidT - 関連ユーザデータ項目の更新情報

setCustGrp1

public void setCustGrp1(String custGrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp1 - 関連ユーザデータ項目の更新情報

setCustGrp2

public void setCustGrp2(String custGrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp2 - 関連ユーザデータ項目の更新情報

setCustGrp3

public void setCustGrp3(String custGrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp3 - 関連ユーザデータ項目の更新情報

setCustGrp4

public void setCustGrp4(String custGrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp4 - 関連ユーザデータ項目の更新情報

setCustGrp5

public void setCustGrp5(String custGrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp5 - 関連ユーザデータ項目の更新情報

setPurchNoC

public void setPurchNoC(String purchNoC)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoC - 関連ユーザデータ項目の更新情報

setPurchNoS

public void setPurchNoS(String purchNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoS - 関連ユーザデータ項目の更新情報

setPoDatS

public void setPoDatS(String poDatS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poDatS - 関連ユーザデータ項目の更新情報

setPoMethS

public void setPoMethS(String poMethS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethS - 関連ユーザデータ項目の更新情報

setRef1S

public void setRef1S(String ref1S)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1S - 関連ユーザデータ項目の更新情報

setSdDocCat

public void setSdDocCat(String sdDocCat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sdDocCat - 関連ユーザデータ項目の更新情報

setDocDate

public void setDocDate(String docDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docDate - 関連ユーザデータ項目の更新情報

setWarDate

public void setWarDate(String warDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
warDate - 関連ユーザデータ項目の更新情報

setShipCond

public void setShipCond(String shipCond)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipCond - 関連ユーザデータ項目の更新情報

setPpSearch

public void setPpSearch(String ppSearch)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ppSearch - 関連ユーザデータ項目の更新情報

setDunCount

public void setDunCount(String dunCount)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunCount - 関連ユーザデータ項目の更新情報

setDunDate

public void setDunDate(String dunDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunDate - 関連ユーザデータ項目の更新情報

setDlvschduse

public void setDlvschduse(String dlvschduse)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvschduse - 関連ユーザデータ項目の更新情報

setPldlvstyp

public void setPldlvstyp(String pldlvstyp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pldlvstyp - 関連ユーザデータ項目の更新情報

setRefDoc

public void setRefDoc(String refDoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDoc - 関連ユーザデータ項目の更新情報

setCompCdeB

public void setCompCdeB(String compCdeB)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
compCdeB - 関連ユーザデータ項目の更新情報

setAlttaxCls

public void setAlttaxCls(String alttaxCls)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
alttaxCls - 関連ユーザデータ項目の更新情報

setTaxClass2

public void setTaxClass2(String taxClass2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass2 - 関連ユーザデータ項目の更新情報

setTaxClass3

public void setTaxClass3(String taxClass3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass3 - 関連ユーザデータ項目の更新情報

setTaxClass4

public void setTaxClass4(String taxClass4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass4 - 関連ユーザデータ項目の更新情報

setTaxClass5

public void setTaxClass5(String taxClass5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass5 - 関連ユーザデータ項目の更新情報

setTaxClass6

public void setTaxClass6(String taxClass6)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass6 - 関連ユーザデータ項目の更新情報

setTaxClass7

public void setTaxClass7(String taxClass7)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass7 - 関連ユーザデータ項目の更新情報

setTaxClass8

public void setTaxClass8(String taxClass8)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass8 - 関連ユーザデータ項目の更新情報

setTaxClass9

public void setTaxClass9(String taxClass9)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass9 - 関連ユーザデータ項目の更新情報

setRefDocL

public void setRefDocL(String refDocL)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocL - 関連ユーザデータ項目の更新情報

setAssNumber

public void setAssNumber(String assNumber)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
assNumber - 関連ユーザデータ項目の更新情報

setRefdocCat

public void setRefdocCat(String refdocCat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refdocCat - 関連ユーザデータ項目の更新情報

setOrdcombIn

public void setOrdcombIn(String ordcombIn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordcombIn - 関連ユーザデータ項目の更新情報

setBillSched

public void setBillSched(String billSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billSched - 関連ユーザデータ項目の更新情報

setInvoSched

public void setInvoSched(String invoSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
invoSched - 関連ユーザデータ項目の更新情報

setMnInvoice

public void setMnInvoice(String mnInvoice)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mnInvoice - 関連ユーザデータ項目の更新情報

setExrateFi

public void setExrateFi(String exrateFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exrateFi - 関連ユーザデータ項目の更新情報

setAddValDy

public void setAddValDy(String addValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
addValDy - 関連ユーザデータ項目の更新情報

setFixValDy

public void setFixValDy(String fixValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixValDy - 関連ユーザデータ項目の更新情報

setPymtMeth

public void setPymtMeth(String pymtMeth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pymtMeth - 関連ユーザデータ項目の更新情報

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
accntAsgn - 関連ユーザデータ項目の更新情報

setExchgRate

public void setExchgRate(String exchgRate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRate - 関連ユーザデータ項目の更新情報

setBillDate

public void setBillDate(String billDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billDate - 関連ユーザデータ項目の更新情報

setServDate

public void setServDate(String servDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
servDate - 関連ユーザデータ項目の更新情報

setDunnKey

public void setDunnKey(String dunnKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnKey - 関連ユーザデータ項目の更新情報

setDunnBlock

public void setDunnBlock(String dunnBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnBlock - 関連ユーザデータ項目の更新情報

setPromotion

public void setPromotion(String promotion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
promotion - 関連ユーザデータ項目の更新情報

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmtgarPro - 関連ユーザデータ項目の更新情報

setDepartmNo

public void setDepartmNo(String departmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
departmNo - 関連ユーザデータ項目の更新情報

setRecPoint

public void setRecPoint(String recPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
recPoint - 関連ユーザデータ項目の更新情報

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poitmNoS - 関連ユーザデータ項目の更新情報

setDocNumFi

public void setDocNumFi(String docNumFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docNumFi - 関連ユーザデータ項目の更新情報

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp1 - 関連ユーザデータ項目の更新情報

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp2 - 関連ユーザデータ項目の更新情報

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp3 - 関連ユーザデータ項目の更新情報

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp4 - 関連ユーザデータ項目の更新情報

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp5 - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setCurrency

public void setCurrency(String currency)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
currency - 関連ユーザデータ項目の更新情報

setTaxdepCty

public void setTaxdepCty(String taxdepCty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxdepCty - 関連ユーザデータ項目の更新情報

setTaxdstCty

public void setTaxdstCty(String taxdstCty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxdstCty - 関連ユーザデータ項目の更新情報

setEutriDeal

public void setEutriDeal(String eutriDeal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
eutriDeal - 関連ユーザデータ項目の更新情報

setMastContr

public void setMastContr(String mastContr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mastContr - 関連ユーザデータ項目の更新情報

setRefProc

public void setRefProc(String refProc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refProc - 関連ユーザデータ項目の更新情報

setChkprtauth

public void setChkprtauth(String chkprtauth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
chkprtauth - 関連ユーザデータ項目の更新情報

setCmlqtyDat

public void setCmlqtyDat(String cmlqtyDat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cmlqtyDat - 関連ユーザデータ項目の更新情報

setVersion

public void setVersion(String version)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
version - 関連ユーザデータ項目の更新情報

setNotifNo

public void setNotifNo(String notifNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
notifNo - 関連ユーザデータ項目の更新情報

setWbsElem

public void setWbsElem(String wbsElem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
wbsElem - 関連ユーザデータ項目の更新情報

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchRateFiV - 関連ユーザデータ項目の更新情報

setExchgRateV

public void setExchgRateV(String exchgRateV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRateV - 関連ユーザデータ項目の更新情報

setFkkConacct

public void setFkkConacct(String fkkConacct)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fkkConacct - 関連ユーザデータ項目の更新情報

setCampaign

public void setCampaign(String campaign)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
campaign - 関連ユーザデータ項目の更新情報

setDocClass

public void setDocClass(String docClass)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docClass - 関連ユーザデータ項目の更新情報

setHCurr

public void setHCurr(String hCurr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
hCurr - 関連ユーザデータ項目の更新情報

setShipType

public void setShipType(String shipType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipType - 関連ユーザデータ項目の更新情報

setSProcInd

public void setSProcInd(String sProcInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sProcInd - 関連ユーザデータ項目の更新情報

setLineTime

public void setLineTime(String lineTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
lineTime - 関連ユーザデータ項目の更新情報

setCalcMotive

public void setCalcMotive(String calcMotive)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
calcMotive - 関連ユーザデータ項目の更新情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemsIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ItemsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn
すべての実装インタフェース:
Serializable
public class ItemsIn
extends Object
implements Serializable

明細データ情報クラス
機能は以下の通り

  • 明細データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ItemsIn()
明細データ情報を作成します。
ItemsIn(int index)
明細データ情報を作成します。
メソッドの概要
String | getAccntAsgn() 得意先の勘定設定グループを取得します。
String | getAddValDy() 有効日からの日数を取得します。
String | getAlternBom() 代替 BOMを取得します。
String | getAltToItm() 代替明細を取得します。
String | getAssortMod() 品揃モジュールを取得します。
String | getBatch() ロット番号を取得します。
String | getBegdemPer() 見越期間の提案開始日付を取得します。
String | getBilForm() 請求書式を取得します。
String | getBillBlock() ブロックを取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillRel() 請求関連 (CRM)を取得します。
String | getBillSched() 請求日程 (稼働日カレンダ指定)を取得します。
String | getBomexplNo() BOM 展開番号を取得します。
String | getBusTranst() 貿易管理の取引タイプを取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCampaign() 総括プロジェクト計画: 外部 SAP システムの GUIDを取得します。
String | getCfopCode() CFOP code and extension (old 5 char version)を取得します。
String | getCfopLong() CFOP code and extensionを取得します。
String | getCompQuant() 構成品目数量を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCstcndgrp1() 得意先条件グループ１を取得します。
String | getCstcndgrp2() 得意先条件グループ２を取得します。
String | getCstcndgrp3() 得意先条件グループ３を取得します。
String | getCstcndgrp4() 得意先条件グループ４を取得します。
String | getCstcndgrp5() 得意先条件グループ５を取得します。
String | getCstgSheet() 原価計算表を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCustGroup() 得意先グループを取得します。
String | getCustMat22() 得意先品目コード (無効)を取得します。
String | getCustMat35() 得意先品目を取得します。
String | getDepartmNo() 部門コードを取得します。
String | getDeprecPer() ドキュメンタリクレジット処理に関する償却率 (%)を取得します。
String | getDivision() 製品部門を取得します。
String | getDliProfil() 動的明細プロセッサプロファイルを取得します。
String | getDlvGroup() 出荷グループ (明細一括出荷)を取得します。
String | getDlvPrio() 出荷優先順位を取得します。
String | getDlvschduse() 用途区分を取得します。
String | getDlvTime() 契約出荷期間を取得します。
String | getDocNumFi() ドキュメンタリクレジット処理: 内部番号を取得します。
String | getDunnBlock() 督促処理保留を取得します。
String | getDunnKey() 督促処理キーを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getExchRateFiV() FI 転記の換算レート (間接相場)を取得します。
String | getExRateFi() FI 転記の換算レート (直接相場)を取得します。
String | getFixdatQty() 納期と出荷数量の固定を取得します。
String | getFixedQuan() 数量固定区分を取得します。
String | getFixValDy() 有効日日付を取得します。
String | getFkkConacct() 長さ 12 の文字項目を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getGrossWght() 明細の総重量を取得します。
String | getHgLvItem() 上位レベル明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getInvoSched() 請求書一覧日程 (稼働日カレンダ指定)を取得します。
String | getItemCateg() 明細カテゴリ (販売伝票)を取得します。
String | getItemguidAtp() ATP: 暗号 - DELNR および DELPSを取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getItmTypeUsage() 明細用途を取得します。
String | getLocActcode() 総所得税の活動コードを取得します。
String | getLocDisttype() 所得税の配賦タイプを取得します。
String | getLocTaxcat() 税タイプを取得します。
String | getLocTxrelclas() 税関連分類を取得します。
String | getLocZerovat() locZerovatを取得します。
String | getLogSystemOwn() 論理システムを取得します。
String | getMatEntrd() 入力品目を取得します。
String | getMatEntrdExternal() 項目 MAT_ENTRD の品目コード (長)を取得します。
String | getMatEntrdGuid() 項目 MAT_ENTRD の外部 GUIDを取得します。
String | getMatEntrdVersion() 項目 MAT_ENTRD のバージョン番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatExt() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMatfrgtgrp() 品目運賃グループを取得します。
String | getMatGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatPrGrp() 品目価格設定グループを取得します。
String | getMatVers() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMaxdevamnt() 数量に関する許容偏差 (絶対値)を取得します。
String | getMaxdevDay() シフト所要日数を取得します。
String | getMaxdevper() 数量に関する許容偏差 (%)を取得します。
String | getMaxPlDlv() 明細ごとの分割納入可能な最大回数を取得します。
String | getMnInvoice() マニュアル請求書更新を取得します。
String | getNetWeight() 明細の正味重量を取得します。
String | getNoGrPost() 得意先が入庫を転記していませんを取得します。
String | getOrdcompIn() 受注結合出荷区分を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderProb() 明細の受注可能性を取得します。
String | getOverdlvtol() 過剰納入許容範囲を取得します。
String | getOverhdKey() 間接費キーを取得します。
String | getPartDlv() 明細レベルの分納納入を取得します。
String | getPlant() プラントを取得します。
String | getPldlvshdin() 出荷計画に関する指示を取得します。
String | getPMatExt() 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPMatGuid() 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPMatVers() 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getPmtgarPro() 支払保証決定表を取得します。
String | getPoDatS() 出荷先の出荷先発注日付を取得します。
String | getPoItmNo() 元となる購買発注の明細番号を取得します。
String | getPoitmNoS() 元となる購買発注の明細番号を取得します。
String | getPoMethod() 得意先発注タイプを取得します。
String | getPoMethS() 出荷先の出荷先発注タイプを取得します。
String | getPrcGroup1() 品目グループ 1を取得します。
String | getPrcGroup2() 品目グループ 2を取得します。
String | getPrcGroup3() 品目グループ 3を取得します。
String | getPrcGroup4() 品目グループ 4を取得します。
String | getPrcGroup5() 品目グループ 5を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getPriceGrp() 価格グループ (得意先)を取得します。
String | getPriceList() 価格表タイプを取得します。
String | getProdcat() 製品カタログ番号を取得します。
String | getProdHiera() 品目階層を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getPromotion() プロモーションを取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPurchDate() 得意先発注日付を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getPurchNoS() 出荷先の得意先発注番号を取得します。
String | getPymtMeth() 支払方法を取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getRecPoint() 入荷ポイントを取得します。
String | getRef1() 得意先/仕入先の内部参照コードを取得します。
String | getRef1S() 出荷先文字を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocCa() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefDocIt() 参照明細番号を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getReqmtsTyp() 所要量タイプを取得します。
String | getResanalkey() 結果分析キーを取得します。
String | getRevType() 収益承認カテゴリを取得します。
String | getRnddlvQty() 丸め数量: 出荷を取得します。
String | getRoute() 輸送経路を取得します。
String | getSalesDist() 販売地域を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSalqtyden() 販売数量単位を SKU に換算するための分母 (除数)を取得します。
String | getSalqtynum() 販売数量単位から基本数量単位への変換係数の分子を取得します。
String | getSdTaxcode() を取得します。
String | getSelection() 選択 ID (永続)を取得します。
String | getSeqNo() KANBAN/連続番号を取得します。
String | getServDate() サービス提供日を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getShipType() 出荷タイプを取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSProcInd() 特別処理区分を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getSUnitIso() 単位の ISO コードを取得します。
String | getTargetQty() 目標数量（販売単位）を取得します。
String | getTargetQu() 目標数量 (数量単位)を取得します。
String | getTargetVal() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getTaxClass1() 品目の税分類を取得します。
String | getTaxClass2() 品目の税分類を取得します。
String | getTaxClass3() 品目の税分類を取得します。
String | getTaxClass4() 品目の税分類を取得します。
String | getTaxClass5() 品目の税分類を取得します。
String | getTaxClass6() 品目の税分類を取得します。
String | getTaxClass7() 品目の税分類を取得します。
String | getTaxClass8() 品目の税分類を取得します。
String | getTaxClass9() 品目の税分類を取得します。
String | getTaxlawicms() 税法: ICMSを取得します。
String | getTaxlawipi() 税法: IPIを取得します。
String | getTaxlawiss() ISS Tax Lawを取得します。
String | getTrgqtyDen() 販売単位から基本単位への換算係数を取得します。
String | getTrgQtyNo() 販売単位から基本単位への換算係数を取得します。
String | getTUnitIso() 目標数量単位 (ISO コード)を取得します。
String | getUnddlvTol() 不足納入許容範囲リミットを取得します。
String | getUnlmtDlv() 区分: 無制限過剰納入可能を取得します。
String | getUnofWtiso() ISO コードでの重量単位を取得します。
String | getUntofWght() 重量単位を取得します。
String | getUsageInd() 未使用 - 予約長 3を取得します。
String | getValConI() 金額契約明細を取得します。
String | getValContr() 金額契約番号を取得します。
String | getValType() 評価タイプを取得します。
String | getVolume() 明細の総数量を取得します。
String | getVolunit() 容積単位を取得します。
String | getVolunitiso() ISO コードでの容積単位を取得します。
String | getVwUepos() 上位レベル明細用途 IDを取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAccntAsgn(String accntAsgn) 得意先の勘定設定グループを設定します。
void | setAddValDy(String addValDy) 有効日からの日数を設定します。
void | setAlternBom(String alternBom) 代替 BOMを設定します。
void | setAltToItm(String altToItm) 代替明細を設定します。
void | setAssortMod(String assortMod) 品揃モジュールを設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setBegdemPer(String begdemPer) 見越期間の提案開始日付を設定します。
void | setBilForm(String bilForm) 請求書式を設定します。
void | setBillBlock(String billBlock) ブロックを設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillRel(String billRel) 請求関連 (CRM)を設定します。
void | setBillSched(String billSched) 請求日程 (稼働日カレンダ指定)を設定します。
void | setBomexplNo(String bomexplNo) BOM 展開番号を設定します。
void | setBusTranst(String busTranst) 貿易管理の取引タイプを設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します｡
void | setCampaign(String campaign) 総括プロジェクト計画: 外部 SAP システムの GUIDを設定します。
void | setCfopCode(String cfopCode) CFOP code and extension (old 5 char version)を設定します。
void | setCfopLong(String cfopLong) CFOP code and extensionを設定します。
void | setCompQuant(String compQuant) 構成品目数量を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCstcndgrp1(String cstcndgrp1) 得意先条件グループ１を設定します。
void | setCstcndgrp2(String cstcndgrp2) 得意先条件グループ２を設定します。
void | setCstcndgrp3(String cstcndgrp3) 得意先条件グループ３を設定します。
void | setCstcndgrp4(String cstcndgrp4) 得意先条件グループ４を設定します。
void | setCstcndgrp5(String cstcndgrp5) 得意先条件グループ５を設定します。
void | setCstgSheet(String cstgSheet) 原価計算表を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCustGroup(String custGroup) 得意先グループを設定します。
void | setCustMat22(String custMat22) 得意先品目コード (無効)を設定します。
void | setCustMat35(String custMat35) 得意先品目を設定します。
void | setDepartmNo(String departmNo) 部門コードを設定します。
void | setDeprecPer(String deprecPer) ドキュメンタリクレジット処理に関する償却率 (%)を設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDliProfil(String dliProfil) 動的明細プロセッサプロファイルを設定します。
void | setDlvGroup(String dlvGroup) 出荷グループ (明細一括出荷)を設定します。
void | setDlvPrio(String dlvPrio) 出荷優先順位を設定します。
void | setDlvschduse(String dlvschduse) 用途区分を設定します。
void | setDlvTime(String dlvTime) 契約出荷期間を設定します。
void | setDocNumFi(String docNumFi) ドキュメンタリクレジット処理: 内部番号を設定します。
void | setDunnBlock(String dunnBlock) 督促処理保留を設定します。
void | setDunnKey(String dunnKey) 督促処理キーを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setExchRateFiV(String exchRateFiV) FI 転記の換算レート (間接相場)を設定します。
void | setExRateFi(String exRateFi) FI 転記の換算レート (直接相場)を設定します。
void | setFixdatQty(String fixdatQty) 納期と出荷数量の固定を設定します。
void | setFixedQuan(String fixedQuan) 数量固定区分を設定します。
void | setFixValDy(String fixValDy) 有効日日付を設定します。
void | setFkkConacct(String fkkConacct) 長さ 12 の文字項目を設定します。
void | setFuncArea(String funcArea) 機能領域を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setGrossWght(String grossWght) 明細の総重量を設定します。
void | setHgLvItem(String hgLvItem) 上位レベル明細を設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ 2を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setInvoSched(String invoSched) 請求書一覧日程 (稼働日カレンダ指定)を設定します。
void | setItemCateg(String itemCateg) 明細カテゴリ (販売伝票)を設定します。
void | setItemguidAtp(String itemguidAtp) ATP: 暗号 - DELNR および DELPSを設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setItmTypeUsage(String itmTypeUsage) 明細用途を設定します。
void | setLocActcode(String locActcode) 総所得税の活動コードを設定します。
void | setLocDisttype(String locDisttype) 所得税の配賦タイプを設定します。
void | setLocTaxcat(String locTaxcat) 税タイプを設定します。
void | setLocTxrelclas(String locTxrelclas) 税関連分類を設定します。
void | setLocZerovat(String locZerovat) locZerovatを 設定します。
void | setLogSystemOwn(String logSystemOwn) 論理システムを設定します。
void | setMatEntrd(String matEntrd) 入力品目を設定します。
void | setMatEntrdExternal(String matEntrdExternal) 項目 MAT_ENTRD の品目コード (長)を設定します。
void | setMatEntrdGuid(String matEntrdGuid) 項目 MAT_ENTRD の外部 GUIDを設定します。
void | setMatEntrdVersion(String matEntrdVersion) 項目 MAT_ENTRD のバージョン番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatExt(String matExt) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 品目運賃グループを設定します。
void | setMatGuid(String matGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMatlGroup(String matlGroup) 品目グループを設定します。
void | setMatPrGrp(String matPrGrp) 品目価格設定グループを設定します。
void | setMatVers(String matVers) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMaxdevamnt(String maxdevamnt) 数量に関する許容偏差 (絶対値)を設定します。
void | setMaxdevDay(String maxdevDay) シフト所要日数を設定します。
void | setMaxdevper(String maxdevper) 数量に関する許容偏差 (%)を設定します。
void | setMaxPlDlv(String maxPlDlv) 明細ごとの分割納入可能な最大回数を設定します。
void | setMnInvoice(String mnInvoice) マニュアル請求書更新を設定します。
void | setNetWeight(String netWeight) 明細の正味重量を設定します。
void | setNoGrPost(String noGrPost) 得意先が入庫を転記していませんを設定します。
void | setOrdcompIn(String ordcompIn) 受注結合出荷区分を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderProb(String orderProb) 明細の受注可能性を設定します。
void | setOverdlvtol(String overdlvtol) 過剰納入許容範囲を設定します。
void | setOverhdKey(String overhdKey) 間接費キーを設定します。
void | setPartDlv(String partDlv) 明細レベルの分納納入を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPldlvshdin(String pldlvshdin) 出荷計画に関する指示を設定します。
void | setPMatExt(String pMatExt) 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPMatGuid(String pMatGuid) 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPMatVers(String pMatVers) 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setPmnttrms(String pmnttrms) 支払条件キーを設定します。
void | setPmtgarPro(String pmtgarPro) 支払保証決定表を設定します。
void | setPoDatS(String poDatS) 出荷先の出荷先発注日付を設定します。
void | setPoItmNo(String poItmNo) 元となる購買発注の明細番号を設定します。
void | setPoitmNoS(String poitmNoS) 元となる購買発注の明細番号を設定します。
void | setPoMethod(String poMethod) 得意先発注タイプを設定します。
void | setPoMethS(String poMethS) 出荷先の出荷先発注タイプを設定します。
void | setPrcGroup1(String prcGroup1) 品目グループ 1を設定します。
void | setPrcGroup2(String prcGroup2) 品目グループ 2を設定します。
void | setPrcGroup3(String prcGroup3) 品目グループ 3を設定します。
void | setPrcGroup4(String prcGroup4) 品目グループ 4を設定します。
void | setPrcGroup5(String prcGroup5) 品目グループ 5を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setPriceGrp(String priceGrp) 価格グループ (得意先)を設定します。
void | setPriceList(String priceList) 価格表タイプを設定します。
void | setProdcat(String prodcat) 製品カタログ番号を設定します。
void | setProdHiera(String prodHiera) 品目階層を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setPromotion(String promotion) プロモーションを設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPurchDate(String purchDate) 得意先発注日付を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setPurchNoS(String purchNoS) 出荷先の得意先発注番号を設定します。
void | setPymtMeth(String pymtMeth) 支払方法を設定します。
void | setReasonRej(String reasonRej) 見積および受注の拒否理由を設定します。
void | setRecPoint(String recPoint) 入荷ポイントを設定します。
void | setRef1(String ref1) 得意先/仕入先の内部参照コードを設定します。
void | setRef1S(String ref1S) 出荷先文字を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocCa(String refDocCa) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefDocIt(String refDocIt) 参照明細番号を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setReqmtsTyp(String reqmtsTyp) 所要量タイプを設定します。
void | setResanalkey(String resanalkey) 結果分析キーを設定します。
void | setRevType(String revType) 収益承認カテゴリを設定します。
void | setRnddlvQty(String rnddlvQty) 丸め数量: 出荷を設定します。
void | setRoute(String route) 輸送経路を設定します。
void | setSalesDist(String salesDist) 販売地域を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSalqtyden(String salqtyden) 販売数量単位を SKU に換算するための分母 (除数)を設定します。
void | setSalqtynum(String salqtynum) 販売数量単位から基本数量単位への変換係数の分子を設定します。
void | setSdTaxcode(String sdTaxcode) 0を設定します。
void | setSelection(String selection) 選択 ID (永続)を設定します。
void | setSeqNo(String seqNo) KANBAN/連続番号を設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipPoint(String shipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setShipType(String shipType) 出荷タイプを設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSProcInd(String sProcInd) 特別処理区分を設定します。
void | setStoreLoc(String storeLoc) 保管場所を設定します。
void | setSUnitIso(String sUnitIso) 単位の ISO コードを設定します。
void | setTargetQty(String targetQty) 目標数量（販売単位）を設定します。
void | setTargetQu(String targetQu) 目標数量 (数量単位)を設定します。
void | setTargetVal(String targetVal) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setTaxClass1(String taxClass1) 品目の税分類を設定します。
void | setTaxClass2(String taxClass2) 品目の税分類を設定します。
void | setTaxClass3(String taxClass3) 品目の税分類を設定します。
void | setTaxClass4(String taxClass4) 品目の税分類を設定します。
void | setTaxClass5(String taxClass5) 品目の税分類を設定します。
void | setTaxClass6(String taxClass6) 品目の税分類を設定します。
void | setTaxClass7(String taxClass7) 品目の税分類を設定します。
void | setTaxClass8(String taxClass8) 品目の税分類を設定します。
void | setTaxClass9(String taxClass9) 品目の税分類を設定します。
void | setTaxlawicms(String taxlawicms) 税法: ICMSを設定します。
void | setTaxlawipi(String taxlawipi) 税法: IPIを設定します。
void | setTaxlawiss(String taxlawiss) ISS Tax Lawを設定します。
void | setTrgqtyDen(String trgqtyDen) 販売単位から基本単位への換算係数を設定します。
void | setTrgQtyNo(String trgQtyNo) 販売単位から基本単位への換算係数を設定します。
void | setTUnitIso(String tUnitIso) 目標数量単位 (ISO コード)を設定します。
void | setUnddlvTol(String unddlvTol) 不足納入許容範囲リミットを設定します。
void | setUnlmtDlv(String unlmtDlv) 区分: 無制限過剰納入可能を設定します。
void | setUnofWtiso(String unofWtiso) ISO コードでの重量単位を設定します。
void | setUntofWght(String untofWght) 重量単位を設定します。
void | setUsageInd(String usageInd) 未使用 - 予約長 3を設定します。
void | setValConI(String valConI) 金額契約明細を設定します。
void | setValContr(String valContr) 金額契約番号を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setVolume(String volume) 明細の総数量を設定します。
void | setVolunit(String volunit) 容積単位を設定します。
void | setVolunitiso(String volunitiso) ISO コードでの容積単位を設定します。
void | setVwUepos(String vwUepos) 上位レベル明細用途 IDを設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ItemsIn

public ItemsIn()
明細データ情報を作成します。

ItemsIn

public ItemsIn(int index)
明細データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getHgLvItem

public String getHgLvItem()
上位レベル明細を取得します。

戻り値:
hgLvItem 上位レベル明細

getPoItmNo

public String getPoItmNo()
元となる購買発注の明細番号を取得します。

戻り値:
poItmNo 元となる購買発注の明細番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getAltToItm

public String getAltToItm()
代替明細を取得します。

戻り値:
altToItm 代替明細

getCustMat22

public String getCustMat22()
得意先品目コード (無効)を取得します。

戻り値:
custMat22 得意先品目コード (無効)

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getDlvGroup

public String getDlvGroup()
出荷グループ (明細一括出荷)を取得します。

戻り値:
dlvGroup 出荷グループ (明細一括出荷)

getPartDlv

public String getPartDlv()
明細レベルの分納納入を取得します。

戻り値:
partDlv 明細レベルの分納納入

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
reasonRej 見積および受注の拒否理由

getBillBlock

public String getBillBlock()
ブロックを取得します。

戻り値:
billBlock ブロック

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
storeLoc 保管場所

getTargetQty

public String getTargetQty()
目標数量（販売単位）を取得します。

戻り値:
targetQty 目標数量（販売単位）

getTargetQu

public String getTargetQu()
目標数量 (数量単位)を取得します。

戻り値:
targetQu 目標数量 (数量単位)

getTUnitIso

public String getTUnitIso()
目標数量単位 (ISO コード)を取得します。

戻り値:
tUnitIso 目標数量単位 (ISO コード)

getItemCateg

public String getItemCateg()
明細カテゴリ (販売伝票)を取得します。

戻り値:
itemCateg 明細カテゴリ (販売伝票)

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getPrcGroup1

public String getPrcGroup1()
品目グループ 1を取得します。

戻り値:
prcGroup1 品目グループ 1

getPrcGroup2

public String getPrcGroup2()
品目グループ 2を取得します。

戻り値:
prcGroup2 品目グループ 2

getPrcGroup3

public String getPrcGroup3()
品目グループ 3を取得します。

戻り値:
prcGroup3 品目グループ 3

getPrcGroup4

public String getPrcGroup4()
品目グループ 4を取得します。

戻り値:
prcGroup4 品目グループ 4

getPrcGroup5

public String getPrcGroup5()
品目グループ 5を取得します。

戻り値:
prcGroup5 品目グループ 5

getProdHiera

public String getProdHiera()
品目階層を取得します。

戻り値:
prodHiera 品目階層

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
matlGroup 品目グループ

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getPurchDate

public String getPurchDate()
得意先発注日付を取得します。

戻り値:
purchDate 得意先発注日付

getPoMethod

public String getPoMethod()
得意先発注タイプを取得します。

戻り値:
poMethod 得意先発注タイプ

getRef1

public String getRef1()
得意先/仕入先の内部参照コードを取得します。

戻り値:
ref1 得意先/仕入先の内部参照コード

getPurchNoS

public String getPurchNoS()
出荷先の得意先発注番号を取得します。

戻り値:
purchNoS 出荷先の得意先発注番号

getPoDatS

public String getPoDatS()
出荷先の出荷先発注日付を取得します。

戻り値:
poDatS 出荷先の出荷先発注日付

getPoMethS

public String getPoMethS()
出荷先の出荷先発注タイプを取得します。

戻り値:
poMethS 出荷先の出荷先発注タイプ

getRef1S

public String getRef1S()
出荷先文字を取得します。

戻り値:
ref1S 出荷先文字

getPoitmNoS

public String getPoitmNoS()
元となる購買発注の明細番号を取得します。

戻り値:
poitmNoS 元となる購買発注の明細番号

getPriceGrp

public String getPriceGrp()
価格グループ (得意先)を取得します。

戻り値:
priceGrp 価格グループ (得意先)

getCustGroup

public String getCustGroup()
得意先グループを取得します。

戻り値:
custGroup 得意先グループ

getSalesDist

public String getSalesDist()
販売地域を取得します。

戻り値:
salesDist 販売地域

getPriceList

public String getPriceList()
価格表タイプを取得します。

戻り値:
priceList 価格表タイプ

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
incoterms2 インコタームズ 2

getOrdcompIn

public String getOrdcompIn()
受注結合出荷区分を取得します。

戻り値:
ordcompIn 受注結合出荷区分

getBillSched

public String getBillSched()
請求日程 (稼働日カレンダ指定)を取得します。

戻り値:
billSched 請求日程 (稼働日カレンダ指定)

getInvoSched

public String getInvoSched()
請求書一覧日程 (稼働日カレンダ指定)を取得します。

戻り値:
invoSched 請求書一覧日程 (稼働日カレンダ指定)

getMnInvoice

public String getMnInvoice()
マニュアル請求書更新を取得します。

戻り値:
mnInvoice マニュアル請求書更新

getExRateFi

public String getExRateFi()
FI 転記の換算レート (直接相場)を取得します。

戻り値:
exRateFi FI 転記の換算レート (直接相場)

getAddValDy

public String getAddValDy()
有効日からの日数を取得します。

戻り値:
addValDy 有効日からの日数

getFixValDy

public String getFixValDy()
有効日日付を取得します。

戻り値:
fixValDy 有効日日付

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
pmnttrms 支払条件キー

getPymtMeth

public String getPymtMeth()
支払方法を取得します。

戻り値:
pymtMeth 支払方法

getAccntAsgn

public String getAccntAsgn()
得意先の勘定設定グループを取得します。

戻り値:
accntAsgn 得意先の勘定設定グループ

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getDunnKey

public String getDunnKey()
督促処理キーを取得します。

戻り値:
dunnKey 督促処理キー

getDunnBlock

public String getDunnBlock()
督促処理保留を取得します。

戻り値:
dunnBlock 督促処理保留

getPromotion

public String getPromotion()
プロモーションを取得します。

戻り値:
promotion プロモーション

getPmtgarPro

public String getPmtgarPro()
支払保証決定表を取得します。

戻り値:
pmtgarPro 支払保証決定表

getDocNumFi

public String getDocNumFi()
ドキュメンタリクレジット処理: 内部番号を取得します。

戻り値:
docNumFi ドキュメンタリクレジット処理: 内部番号

getDepartmNo

public String getDepartmNo()
部門コードを取得します。

戻り値:
departmNo 部門コード

getRecPoint

public String getRecPoint()
入荷ポイントを取得します。

戻り値:
recPoint 入荷ポイント

getCstcndgrp1

public String getCstcndgrp1()
得意先条件グループ１を取得します。

戻り値:
cstcndgrp1 得意先条件グループ１

getCstcndgrp2

public String getCstcndgrp2()
得意先条件グループ２を取得します。

戻り値:
cstcndgrp2 得意先条件グループ２

getCstcndgrp3

public String getCstcndgrp3()
得意先条件グループ３を取得します。

戻り値:
cstcndgrp3 得意先条件グループ３

getCstcndgrp4

public String getCstcndgrp4()
得意先条件グループ４を取得します。

戻り値:
cstcndgrp4 得意先条件グループ４

getCstcndgrp5

public String getCstcndgrp5()
得意先条件グループ５を取得します。

戻り値:
cstcndgrp5 得意先条件グループ５

getDlvTime

public String getDlvTime()
契約出荷期間を取得します。

戻り値:
dlvTime 契約出荷期間

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getSUnitIso

public String getSUnitIso()
単位の ISO コードを取得します。

戻り値:
sUnitIso 単位の ISO コード

getTrgQtyNo

public String getTrgQtyNo()
販売単位から基本単位への換算係数を取得します。

戻り値:
trgQtyNo 販売単位から基本単位への換算係数

getTrgqtyDen

public String getTrgqtyDen()
販売単位から基本単位への換算係数を取得します。

戻り値:
trgqtyDen 販売単位から基本単位への換算係数

getRnddlvQty

public String getRnddlvQty()
丸め数量: 出荷を取得します。

戻り値:
rnddlvQty 丸め数量: 出荷

getMaxdevamnt

public String getMaxdevamnt()
数量に関する許容偏差 (絶対値)を取得します。

戻り値:
maxdevamnt 数量に関する許容偏差 (絶対値)

getMaxdevper

public String getMaxdevper()
数量に関する許容偏差 (%)を取得します。

戻り値:
maxdevper 数量に関する許容偏差 (%)

getMaxdevDay

public String getMaxdevDay()
シフト所要日数を取得します。

戻り値:
maxdevDay シフト所要日数

getUsageInd

public String getUsageInd()
未使用 - 予約長 3を取得します。

戻り値:
usageInd 未使用 - 予約長 3

getFixedQuan

public String getFixedQuan()
数量固定区分を取得します。

戻り値:
fixedQuan 数量固定区分

getUnlmtDlv

public String getUnlmtDlv()
区分: 無制限過剰納入可能を取得します。

戻り値:
unlmtDlv 区分: 無制限過剰納入可能

getOverdlvtol

public String getOverdlvtol()
過剰納入許容範囲を取得します。

戻り値:
overdlvtol 過剰納入許容範囲

getUnddlvTol

public String getUnddlvTol()
不足納入許容範囲リミットを取得します。

戻り値:
unddlvTol 不足納入許容範囲リミット

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getSalqtynum

public String getSalqtynum()
販売数量単位から基本数量単位への変換係数の分子を取得します。

戻り値:
salqtynum 販売数量単位から基本数量単位への変換係数の分子

getSalqtyden

public String getSalqtyden()
販売数量単位を SKU に換算するための分母 (除数)を取得します。

戻り値:
salqtyden 販売数量単位を SKU に換算するための分母 (除数)

getGrossWght

public String getGrossWght()
明細の総重量を取得します。

戻り値:
grossWght 明細の総重量

getNetWeight

public String getNetWeight()
明細の正味重量を取得します。

戻り値:
netWeight 明細の正味重量

getUntofWght

public String getUntofWght()
重量単位を取得します。

戻り値:
untofWght 重量単位

getUnofWtiso

public String getUnofWtiso()
ISO コードでの重量単位を取得します。

戻り値:
unofWtiso ISO コードでの重量単位

getVolume

public String getVolume()
明細の総数量を取得します。

戻り値:
volume 明細の総数量

getVolunit

public String getVolunit()
容積単位を取得します。

戻り値:
volunit 容積単位

getVolunitiso

public String getVolunitiso()
ISO コードでの容積単位を取得します。

戻り値:
volunitiso ISO コードでの容積単位

getDlvPrio

public String getDlvPrio()
出荷優先順位を取得します。

戻り値:
dlvPrio 出荷優先順位

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
shipPoint 出荷ポイント/入荷ポイント

getRoute

public String getRoute()
輸送経路を取得します。

戻り値:
route 輸送経路

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getTaxClass1

public String getTaxClass1()
品目の税分類を取得します。

戻り値:
taxClass1 品目の税分類

getTaxClass2

public String getTaxClass2()
品目の税分類を取得します。

戻り値:
taxClass2 品目の税分類

getTaxClass3

public String getTaxClass3()
品目の税分類を取得します。

戻り値:
taxClass3 品目の税分類

getTaxClass4

public String getTaxClass4()
品目の税分類を取得します。

戻り値:
taxClass4 品目の税分類

getTaxClass5

public String getTaxClass5()
品目の税分類を取得します。

戻り値:
taxClass5 品目の税分類

getTaxClass6

public String getTaxClass6()
品目の税分類を取得します。

戻り値:
taxClass6 品目の税分類

getTaxClass7

public String getTaxClass7()
品目の税分類を取得します。

戻り値:
taxClass7 品目の税分類

getTaxClass8

public String getTaxClass8()
品目の税分類を取得します。

戻り値:
taxClass8 品目の税分類

getTaxClass9

public String getTaxClass9()
品目の税分類を取得します。

戻り値:
taxClass9 品目の税分類

getMatPrGrp

public String getMatPrGrp()
品目価格設定グループを取得します。

戻り値:
matPrGrp 品目価格設定グループ

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getFixdatQty

public String getFixdatQty()
納期と出荷数量の固定を取得します。

戻り値:
fixdatQty 納期と出荷数量の固定

getBomexplNo

public String getBomexplNo()
BOM 展開番号を取得します。

戻り値:
bomexplNo BOM 展開番号

getResanalkey

public String getResanalkey()
結果分析キーを取得します。

戻り値:
resanalkey 結果分析キー

getReqmtsTyp

public String getReqmtsTyp()
所要量タイプを取得します。

戻り値:
reqmtsTyp 所要量タイプ

getNoGrPost

public String getNoGrPost()
得意先が入庫を転記していませんを取得します。

戻り値:
noGrPost 得意先が入庫を転記していません

getBusTranst

public String getBusTranst()
貿易管理の取引タイプを取得します。

戻り値:
busTranst 貿易管理の取引タイプ

getOverhdKey

public String getOverhdKey()
間接費キーを取得します。

戻り値:
overhdKey 間接費キー

getCstgSheet

public String getCstgSheet()
原価計算表を取得します。

戻り値:
cstgSheet 原価計算表

getMatfrgtgrp

public String getMatfrgtgrp()
品目運賃グループを取得します。

戻り値:
matfrgtgrp 品目運賃グループ

getPldlvshdin

public String getPldlvshdin()
出荷計画に関する指示を取得します。

戻り値:
pldlvshdin 出荷計画に関する指示

getSeqNo

public String getSeqNo()
KANBAN/連続番号を取得します。

戻り値:
seqNo KANBAN/連続番号

getBilForm

public String getBilForm()
請求書式を取得します。

戻り値:
bilForm 請求書式

getDliProfil

public String getDliProfil()
動的明細プロセッサプロファイルを取得します。

戻り値:
dliProfil 動的明細プロセッサプロファイル

getRevType

public String getRevType()
収益承認カテゴリを取得します。

戻り値:
revType 収益承認カテゴリ

getBegdemPer

public String getBegdemPer()
見越期間の提案開始日付を取得します。

戻り値:
begdemPer 見越期間の提案開始日付

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getOrderProb

public String getOrderProb()
明細の受注可能性を取得します。

戻り値:
orderProb 明細の受注可能性

getMaxPlDlv

public String getMaxPlDlv()
明細ごとの分割納入可能な最大回数を取得します。

戻り値:
maxPlDlv 明細ごとの分割納入可能な最大回数

getCfopCode

public String getCfopCode()
CFOP code and extension (old 5 char version)を取得します。

戻り値:
cfopCode CFOP code and extension (old 5 char version)

getTaxlawicms

public String getTaxlawicms()
税法: ICMSを取得します。

戻り値:
taxlawicms 税法: ICMS

getTaxlawipi

public String getTaxlawipi()
税法: IPIを取得します。

戻り値:
taxlawipi 税法: IPI

getSdTaxcode

public String getSdTaxcode()
を取得します。

戻り値:
sdTaxcode

getAssortMod

public String getAssortMod()
品揃モジュールを取得します。

戻り値:
assortMod 品揃モジュール

getCompQuant

public String getCompQuant()
構成品目数量を取得します。

戻り値:
compQuant 構成品目数量

getTargetVal

public String getTargetVal()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
targetVal BAPI の通貨額 (小数点以下９桁)

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getDeprecPer

public String getDeprecPer()
ドキュメンタリクレジット処理に関する償却率 (%)を取得します。

戻り値:
deprecPer ドキュメンタリクレジット処理に関する償却率 (%)

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocIt

public String getRefDocIt()
参照明細番号を取得します。

戻り値:
refDocIt 参照明細番号

getRefDocCa

public String getRefDocCa()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refDocCa 先行販売管理伝票の伝票カテゴリ

getCustMat35

public String getCustMat35()
得意先品目を取得します。

戻り値:
custMat35 得意先品目

getExchRateFiV

public String getExchRateFiV()
FI 転記の換算レート (間接相場)を取得します。

戻り値:
exchRateFiV FI 転記の換算レート (間接相場)

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getItemguidAtp

public String getItemguidAtp()
ATP: 暗号 - DELNR および DELPSを取得します。

戻り値:
itemguidAtp ATP: 暗号 - DELNR および DELPS

getValContr

public String getValContr()
金額契約番号を取得します。

戻り値:
valContr 金額契約番号

getValConI

public String getValConI()
金額契約明細を取得します。

戻り値:
valConI 金額契約明細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getMatExt

public String getMatExt()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
matExt 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMatGuid

public String getMatGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
matGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMatVers

public String getMatVers()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
matVers 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getPMatExt

public String getPMatExt()
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
pMatExt 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

getPMatGuid

public String getPMatGuid()
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
pMatGuid 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

getPMatVers

public String getPMatVers()
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
pMatVers 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
funcArea 機能領域

getAlternBom

public String getAlternBom()
代替 BOMを取得します。

戻り値:
alternBom 代替 BOM

getFkkConacct

public String getFkkConacct()
長さ 12 の文字項目を取得します。

戻り値:
fkkConacct 長さ 12 の文字項目

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getProdcat

public String getProdcat()
製品カタログ番号を取得します。

戻り値:
prodcat 製品カタログ番号

getShipType

public String getShipType()
出荷タイプを取得します。

戻り値:
shipType 出荷タイプ

getSProcInd

public String getSProcInd()
特別処理区分を取得します。

戻り値:
sProcInd 特別処理区分

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getBillRel

public String getBillRel()
請求関連 (CRM)を取得します。

戻り値:
billRel 請求関連 (CRM)

getVwUepos

public String getVwUepos()
上位レベル明細用途 IDを取得します。

戻り値:
vwUepos 上位レベル明細用途 ID

getCampaign

public String getCampaign()
総括プロジェクト計画: 外部 SAP システムの GUIDを取得します。

戻り値:
campaign 総括プロジェクト計画: 外部 SAP システムの GUID

getDlvschduse

public String getDlvschduse()
用途区分を取得します。

戻り値:
dlvschduse 用途区分

getCfopLong

public String getCfopLong()
CFOP code and extensionを取得します。

戻り値:
cfopLong CFOP code and extension

getSelection

public String getSelection()
選択 ID (永続)を取得します。

戻り値:
selection 選択 ID (永続)

getMatEntrd

public String getMatEntrd()
入力品目を取得します。

戻り値:
matEntrd 入力品目

getLogSystemOwn

public String getLogSystemOwn()
論理システムを取得します。

戻り値:
logSystemOwn 論理システム

getItmTypeUsage

public String getItmTypeUsage()
明細用途を取得します。

戻り値:
itmTypeUsage 明細用途

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

getTaxlawiss

public String getTaxlawiss()
ISS Tax Lawを取得します。

戻り値:
taxlawiss ISS Tax Law

getMatEntrdExternal

public String getMatEntrdExternal()
項目 MAT_ENTRD の品目コード (長)を取得します。

戻り値:
matEntrdExternal 項目 MAT_ENTRD の品目コード (長)

getMatEntrdGuid

public String getMatEntrdGuid()
項目 MAT_ENTRD の外部 GUIDを取得します。

戻り値:
matEntrdGuid 項目 MAT_ENTRD の外部 GUID

getMatEntrdVersion

public String getMatEntrdVersion()
項目 MAT_ENTRD のバージョン番号を取得します。

戻り値:
matEntrdVersion 項目 MAT_ENTRD のバージョン番号

getLocTaxcat

public String getLocTaxcat()
税タイプを取得します。

戻り値:
locTaxcat 税タイプ

getLocZerovat

public String getLocZerovat()
locZerovatを取得します。

戻り値:
locZerovat locZerovat

getLocActcode

public String getLocActcode()
総所得税の活動コードを取得します。

戻り値:
locActcode 総所得税の活動コード

getLocDisttype

public String getLocDisttype()
所得税の配賦タイプを取得します。

戻り値:
locDisttype 所得税の配賦タイプ

getLocTxrelclas

public String getLocTxrelclas()
税関連分類を取得します。

戻り値:
locTxrelclas 税関連分類

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setHgLvItem

public void setHgLvItem(String hgLvItem)
上位レベル明細を設定します。

パラメータ:
hgLvItem - 上位レベル明細

setPoItmNo

public void setPoItmNo(String poItmNo)
元となる購買発注の明細番号を設定します。

パラメータ:
poItmNo - 元となる購買発注の明細番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setAltToItm

public void setAltToItm(String altToItm)
代替明細を設定します。

パラメータ:
altToItm - 代替明細

setCustMat22

public void setCustMat22(String custMat22)
得意先品目コード (無効)を設定します。

パラメータ:
custMat22 - 得意先品目コード (無効)

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setDlvGroup

public void setDlvGroup(String dlvGroup)
出荷グループ (明細一括出荷)を設定します。

パラメータ:
dlvGroup - 出荷グループ (明細一括出荷)

setPartDlv

public void setPartDlv(String partDlv)
明細レベルの分納納入を設定します。

パラメータ:
partDlv - 明細レベルの分納納入

setReasonRej

public void setReasonRej(String reasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
reasonRej - 見積および受注の拒否理由

setBillBlock

public void setBillBlock(String billBlock)
ブロックを設定します。

パラメータ:
billBlock - ブロック

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoreLoc

public void setStoreLoc(String storeLoc)
保管場所を設定します。

パラメータ:
storeLoc - 保管場所

setTargetQty

public void setTargetQty(String targetQty)
目標数量（販売単位）を設定します。

パラメータ:
targetQty - 目標数量（販売単位）

setTargetQu

public void setTargetQu(String targetQu)
目標数量 (数量単位)を設定します。

パラメータ:
targetQu - 目標数量 (数量単位)

setTUnitIso

public void setTUnitIso(String tUnitIso)
目標数量単位 (ISO コード)を設定します。

パラメータ:
tUnitIso - 目標数量単位 (ISO コード)

setItemCateg

public void setItemCateg(String itemCateg)
明細カテゴリ (販売伝票)を設定します。

パラメータ:
itemCateg - 明細カテゴリ (販売伝票)

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setPrcGroup1

public void setPrcGroup1(String prcGroup1)
品目グループ 1を設定します。

パラメータ:
prcGroup1 - 品目グループ 1

setPrcGroup2

public void setPrcGroup2(String prcGroup2)
品目グループ 2を設定します。

パラメータ:
prcGroup2 - 品目グループ 2

setPrcGroup3

public void setPrcGroup3(String prcGroup3)
品目グループ 3を設定します。

パラメータ:
prcGroup3 - 品目グループ 3

setPrcGroup4

public void setPrcGroup4(String prcGroup4)
品目グループ 4を設定します。

パラメータ:
prcGroup4 - 品目グループ 4

setPrcGroup5

public void setPrcGroup5(String prcGroup5)
品目グループ 5を設定します。

パラメータ:
prcGroup5 - 品目グループ 5

setProdHiera

public void setProdHiera(String prodHiera)
品目階層を設定します。

パラメータ:
prodHiera - 品目階層

setMatlGroup

public void setMatlGroup(String matlGroup)
品目グループを設定します。

パラメータ:
matlGroup - 品目グループ

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setPurchDate

public void setPurchDate(String purchDate)
得意先発注日付を設定します。

パラメータ:
purchDate - 得意先発注日付

setPoMethod

public void setPoMethod(String poMethod)
得意先発注タイプを設定します。

パラメータ:
poMethod - 得意先発注タイプ

setRef1

public void setRef1(String ref1)
得意先/仕入先の内部参照コードを設定します。

パラメータ:
ref1 - 得意先/仕入先の内部参照コード

setPurchNoS

public void setPurchNoS(String purchNoS)
出荷先の得意先発注番号を設定します。

パラメータ:
purchNoS - 出荷先の得意先発注番号

setPoDatS

public void setPoDatS(String poDatS)
出荷先の出荷先発注日付を設定します。

パラメータ:
poDatS - 出荷先の出荷先発注日付

setPoMethS

public void setPoMethS(String poMethS)
出荷先の出荷先発注タイプを設定します。

パラメータ:
poMethS - 出荷先の出荷先発注タイプ

setRef1S

public void setRef1S(String ref1S)
出荷先文字を設定します。

パラメータ:
ref1S - 出荷先文字

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
元となる購買発注の明細番号を設定します。

パラメータ:
poitmNoS - 元となる購買発注の明細番号

setPriceGrp

public void setPriceGrp(String priceGrp)
価格グループ (得意先)を設定します。

パラメータ:
priceGrp - 価格グループ (得意先)

setCustGroup

public void setCustGroup(String custGroup)
得意先グループを設定します。

パラメータ:
custGroup - 得意先グループ

setSalesDist

public void setSalesDist(String salesDist)
販売地域を設定します。

パラメータ:
salesDist - 販売地域

setPriceList

public void setPriceList(String priceList)
価格表タイプを設定します。

パラメータ:
priceList - 価格表タイプ

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ 2を設定します。

パラメータ:
incoterms2 - インコタームズ 2

setOrdcompIn

public void setOrdcompIn(String ordcompIn)
受注結合出荷区分を設定します。

パラメータ:
ordcompIn - 受注結合出荷区分

setBillSched

public void setBillSched(String billSched)
請求日程 (稼働日カレンダ指定)を設定します。

パラメータ:
billSched - 請求日程 (稼働日カレンダ指定)

setInvoSched

public void setInvoSched(String invoSched)
請求書一覧日程 (稼働日カレンダ指定)を設定します。

パラメータ:
invoSched - 請求書一覧日程 (稼働日カレンダ指定)

setMnInvoice

public void setMnInvoice(String mnInvoice)
マニュアル請求書更新を設定します。

パラメータ:
mnInvoice - マニュアル請求書更新

setExRateFi

public void setExRateFi(String exRateFi)
FI 転記の換算レート (直接相場)を設定します。

パラメータ:
exRateFi - FI 転記の換算レート (直接相場)

setAddValDy

public void setAddValDy(String addValDy)
有効日からの日数を設定します。

パラメータ:
addValDy - 有効日からの日数

setFixValDy

public void setFixValDy(String fixValDy)
有効日日付を設定します。

パラメータ:
fixValDy - 有効日日付

setPmnttrms

public void setPmnttrms(String pmnttrms)
支払条件キーを設定します。

パラメータ:
pmnttrms - 支払条件キー

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します。

パラメータ:
pymtMeth - 支払方法

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
得意先の勘定設定グループを設定します。

パラメータ:
accntAsgn - 得意先の勘定設定グループ

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setDunnKey

public void setDunnKey(String dunnKey)
督促処理キーを設定します。

パラメータ:
dunnKey - 督促処理キー

setDunnBlock

public void setDunnBlock(String dunnBlock)
督促処理保留を設定します。

パラメータ:
dunnBlock - 督促処理保留

setPromotion

public void setPromotion(String promotion)
プロモーションを設定します。

パラメータ:
promotion - プロモーション

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
支払保証決定表を設定します。

パラメータ:
pmtgarPro - 支払保証決定表

setDocNumFi

public void setDocNumFi(String docNumFi)
ドキュメンタリクレジット処理: 内部番号を設定します。

パラメータ:
docNumFi - ドキュメンタリクレジット処理: 内部番号

setDepartmNo

public void setDepartmNo(String departmNo)
部門コードを設定します。

パラメータ:
departmNo - 部門コード

setRecPoint

public void setRecPoint(String recPoint)
入荷ポイントを設定します。

パラメータ:
recPoint - 入荷ポイント

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
得意先条件グループ１を設定します。

パラメータ:
cstcndgrp1 - 得意先条件グループ１

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
得意先条件グループ２を設定します。

パラメータ:
cstcndgrp2 - 得意先条件グループ２

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
得意先条件グループ３を設定します。

パラメータ:
cstcndgrp3 - 得意先条件グループ３

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
得意先条件グループ４を設定します。

パラメータ:
cstcndgrp4 - 得意先条件グループ４

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
得意先条件グループ５を設定します。

パラメータ:
cstcndgrp5 - 得意先条件グループ５

setDlvTime

public void setDlvTime(String dlvTime)
契約出荷期間を設定します。

パラメータ:
dlvTime - 契約出荷期間

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setSUnitIso

public void setSUnitIso(String sUnitIso)
単位の ISO コードを設定します。

パラメータ:
sUnitIso - 単位の ISO コード

setTrgQtyNo

public void setTrgQtyNo(String trgQtyNo)
販売単位から基本単位への換算係数を設定します。

パラメータ:
trgQtyNo - 販売単位から基本単位への換算係数

setTrgqtyDen

public void setTrgqtyDen(String trgqtyDen)
販売単位から基本単位への換算係数を設定します。

パラメータ:
trgqtyDen - 販売単位から基本単位への換算係数

setRnddlvQty

public void setRnddlvQty(String rnddlvQty)
丸め数量: 出荷を設定します。

パラメータ:
rnddlvQty - 丸め数量: 出荷

setMaxdevamnt

public void setMaxdevamnt(String maxdevamnt)
数量に関する許容偏差 (絶対値)を設定します。

パラメータ:
maxdevamnt - 数量に関する許容偏差 (絶対値)

setMaxdevper

public void setMaxdevper(String maxdevper)
数量に関する許容偏差 (%)を設定します。

パラメータ:
maxdevper - 数量に関する許容偏差 (%)

setMaxdevDay

public void setMaxdevDay(String maxdevDay)
シフト所要日数を設定します。

パラメータ:
maxdevDay - シフト所要日数

setUsageInd

public void setUsageInd(String usageInd)
未使用 - 予約長 3を設定します。

パラメータ:
usageInd - 未使用 - 予約長 3

setFixedQuan

public void setFixedQuan(String fixedQuan)
数量固定区分を設定します。

パラメータ:
fixedQuan - 数量固定区分

setUnlmtDlv

public void setUnlmtDlv(String unlmtDlv)
区分: 無制限過剰納入可能を設定します。

パラメータ:
unlmtDlv - 区分: 無制限過剰納入可能

setOverdlvtol

public void setOverdlvtol(String overdlvtol)
過剰納入許容範囲を設定します。

パラメータ:
overdlvtol - 過剰納入許容範囲

setUnddlvTol

public void setUnddlvTol(String unddlvTol)
不足納入許容範囲リミットを設定します。

パラメータ:
unddlvTol - 不足納入許容範囲リミット

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setSalqtynum

public void setSalqtynum(String salqtynum)
販売数量単位から基本数量単位への変換係数の分子を設定します。

パラメータ:
salqtynum - 販売数量単位から基本数量単位への変換係数の分子

setSalqtyden

public void setSalqtyden(String salqtyden)
販売数量単位を SKU に換算するための分母 (除数)を設定します。

パラメータ:
salqtyden - 販売数量単位を SKU に換算するための分母 (除数)

setGrossWght

public void setGrossWght(String grossWght)
明細の総重量を設定します。

パラメータ:
grossWght - 明細の総重量

setNetWeight

public void setNetWeight(String netWeight)
明細の正味重量を設定します。

パラメータ:
netWeight - 明細の正味重量

setUntofWght

public void setUntofWght(String untofWght)
重量単位を設定します。

パラメータ:
untofWght - 重量単位

setUnofWtiso

public void setUnofWtiso(String unofWtiso)
ISO コードでの重量単位を設定します。

パラメータ:
unofWtiso - ISO コードでの重量単位

setVolume

public void setVolume(String volume)
明細の総数量を設定します。

パラメータ:
volume - 明細の総数量

setVolunit

public void setVolunit(String volunit)
容積単位を設定します。

パラメータ:
volunit - 容積単位

setVolunitiso

public void setVolunitiso(String volunitiso)
ISO コードでの容積単位を設定します。

パラメータ:
volunitiso - ISO コードでの容積単位

setDlvPrio

public void setDlvPrio(String dlvPrio)
出荷優先順位を設定します。

パラメータ:
dlvPrio - 出荷優先順位

setShipPoint

public void setShipPoint(String shipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
shipPoint - 出荷ポイント/入荷ポイント

setRoute

public void setRoute(String route)
輸送経路を設定します。

パラメータ:
route - 輸送経路

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setTaxClass1

public void setTaxClass1(String taxClass1)
品目の税分類を設定します。

パラメータ:
taxClass1 - 品目の税分類

setTaxClass2

public void setTaxClass2(String taxClass2)
品目の税分類を設定します。

パラメータ:
taxClass2 - 品目の税分類

setTaxClass3

public void setTaxClass3(String taxClass3)
品目の税分類を設定します。

パラメータ:
taxClass3 - 品目の税分類

setTaxClass4

public void setTaxClass4(String taxClass4)
品目の税分類を設定します。

パラメータ:
taxClass4 - 品目の税分類

setTaxClass5

public void setTaxClass5(String taxClass5)
品目の税分類を設定します。

パラメータ:
taxClass5 - 品目の税分類

setTaxClass6

public void setTaxClass6(String taxClass6)
品目の税分類を設定します。

パラメータ:
taxClass6 - 品目の税分類

setTaxClass7

public void setTaxClass7(String taxClass7)
品目の税分類を設定します。

パラメータ:
taxClass7 - 品目の税分類

setTaxClass8

public void setTaxClass8(String taxClass8)
品目の税分類を設定します。

パラメータ:
taxClass8 - 品目の税分類

setTaxClass9

public void setTaxClass9(String taxClass9)
品目の税分類を設定します。

パラメータ:
taxClass9 - 品目の税分類

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
品目価格設定グループを設定します。

パラメータ:
matPrGrp - 品目価格設定グループ

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setFixdatQty

public void setFixdatQty(String fixdatQty)
納期と出荷数量の固定を設定します。

パラメータ:
fixdatQty - 納期と出荷数量の固定

setBomexplNo

public void setBomexplNo(String bomexplNo)
BOM 展開番号を設定します。

パラメータ:
bomexplNo - BOM 展開番号

setResanalkey

public void setResanalkey(String resanalkey)
結果分析キーを設定します。

パラメータ:
resanalkey - 結果分析キー

setReqmtsTyp

public void setReqmtsTyp(String reqmtsTyp)
所要量タイプを設定します。

パラメータ:
reqmtsTyp - 所要量タイプ

setNoGrPost

public void setNoGrPost(String noGrPost)
得意先が入庫を転記していませんを設定します。

パラメータ:
noGrPost - 得意先が入庫を転記していません

setBusTranst

public void setBusTranst(String busTranst)
貿易管理の取引タイプを設定します。

パラメータ:
busTranst - 貿易管理の取引タイプ

setOverhdKey

public void setOverhdKey(String overhdKey)
間接費キーを設定します。

パラメータ:
overhdKey - 間接費キー

setCstgSheet

public void setCstgSheet(String cstgSheet)
原価計算表を設定します。

パラメータ:
cstgSheet - 原価計算表

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
品目運賃グループを設定します。

パラメータ:
matfrgtgrp - 品目運賃グループ

setPldlvshdin

public void setPldlvshdin(String pldlvshdin)
出荷計画に関する指示を設定します。

パラメータ:
pldlvshdin - 出荷計画に関する指示

setSeqNo

public void setSeqNo(String seqNo)
KANBAN/連続番号を設定します。

パラメータ:
seqNo - KANBAN/連続番号

setBilForm

public void setBilForm(String bilForm)
請求書式を設定します。

パラメータ:
bilForm - 請求書式

setDliProfil

public void setDliProfil(String dliProfil)
動的明細プロセッサプロファイルを設定します。

パラメータ:
dliProfil - 動的明細プロセッサプロファイル

setRevType

public void setRevType(String revType)
収益承認カテゴリを設定します。

パラメータ:
revType - 収益承認カテゴリ

setBegdemPer

public void setBegdemPer(String begdemPer)
見越期間の提案開始日付を設定します。

パラメータ:
begdemPer - 見越期間の提案開始日付

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setOrderProb

public void setOrderProb(String orderProb)
明細の受注可能性を設定します。

パラメータ:
orderProb - 明細の受注可能性

setMaxPlDlv

public void setMaxPlDlv(String maxPlDlv)
明細ごとの分割納入可能な最大回数を設定します。

パラメータ:
maxPlDlv - 明細ごとの分割納入可能な最大回数

setCfopCode

public void setCfopCode(String cfopCode)
CFOP code and extension (old 5 char version)を設定します。

パラメータ:
cfopCode - CFOP code and extension (old 5 char version)

setTaxlawicms

public void setTaxlawicms(String taxlawicms)
税法: ICMSを設定します。

パラメータ:
taxlawicms - 税法: ICMS

setTaxlawipi

public void setTaxlawipi(String taxlawipi)
税法: IPIを設定します。

パラメータ:
taxlawipi - 税法: IPI

setSdTaxcode

public void setSdTaxcode(String sdTaxcode)
0を設定します。

パラメータ:
sdTaxcode - 0

setAssortMod

public void setAssortMod(String assortMod)
品揃モジュールを設定します。

パラメータ:
assortMod - 品揃モジュール

setCompQuant

public void setCompQuant(String compQuant)
構成品目数量を設定します。

パラメータ:
compQuant - 構成品目数量

setTargetVal

public void setTargetVal(String targetVal)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
targetVal - BAPI の通貨額 (小数点以下９桁)

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setDeprecPer

public void setDeprecPer(String deprecPer)
ドキュメンタリクレジット処理に関する償却率 (%)を設定します。

パラメータ:
deprecPer - ドキュメンタリクレジット処理に関する償却率 (%)

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照明細番号を設定します。

パラメータ:
refDocIt - 参照明細番号

setRefDocCa

public void setRefDocCa(String refDocCa)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refDocCa - 先行販売管理伝票の伝票カテゴリ

setCustMat35

public void setCustMat35(String custMat35)
得意先品目を設定します。

パラメータ:
custMat35 - 得意先品目

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
FI 転記の換算レート (間接相場)を設定します。

パラメータ:
exchRateFiV - FI 転記の換算レート (間接相場)

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setItemguidAtp

public void setItemguidAtp(String itemguidAtp)
ATP: 暗号 - DELNR および DELPSを設定します。

パラメータ:
itemguidAtp - ATP: 暗号 - DELNR および DELPS

setValContr

public void setValContr(String valContr)
金額契約番号を設定します。

パラメータ:
valContr - 金額契約番号

setValConI

public void setValConI(String valConI)
金額契約明細を設定します。

パラメータ:
valConI - 金額契約明細

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setMatExt

public void setMatExt(String matExt)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
matExt - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMatGuid

public void setMatGuid(String matGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
matGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMatVers

public void setMatVers(String matVers)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
matVers - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setPMatExt

public void setPMatExt(String pMatExt)
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
pMatExt - 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

setPMatGuid

public void setPMatGuid(String pMatGuid)
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
pMatGuid - 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

setPMatVers

public void setPMatVers(String pMatVers)
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
pMatVers - 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

setFuncArea

public void setFuncArea(String funcArea)
機能領域を設定します。

パラメータ:
funcArea - 機能領域

setAlternBom

public void setAlternBom(String alternBom)
代替 BOMを設定します。

パラメータ:
alternBom - 代替 BOM

setFkkConacct

public void setFkkConacct(String fkkConacct)
長さ 12 の文字項目を設定します。

パラメータ:
fkkConacct - 長さ 12 の文字項目

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setProdcat

public void setProdcat(String prodcat)
製品カタログ番号を設定します。

パラメータ:
prodcat - 製品カタログ番号

setShipType

public void setShipType(String shipType)
出荷タイプを設定します。

パラメータ:
shipType - 出荷タイプ

setSProcInd

public void setSProcInd(String sProcInd)
特別処理区分を設定します。

パラメータ:
sProcInd - 特別処理区分

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setBillRel

public void setBillRel(String billRel)
請求関連 (CRM)を設定します。

パラメータ:
billRel - 請求関連 (CRM)

setVwUepos

public void setVwUepos(String vwUepos)
上位レベル明細用途 IDを設定します。

パラメータ:
vwUepos - 上位レベル明細用途 ID

setCampaign

public void setCampaign(String campaign)
総括プロジェクト計画: 外部 SAP システムの GUIDを設定します。

パラメータ:
campaign - 総括プロジェクト計画: 外部 SAP システムの GUID

setDlvschduse

public void setDlvschduse(String dlvschduse)
用途区分を設定します。

パラメータ:
dlvschduse - 用途区分

setCfopLong

public void setCfopLong(String cfopLong)
CFOP code and extensionを設定します。

パラメータ:
cfopLong - CFOP code and extension

setSelection

public void setSelection(String selection)
選択 ID (永続)を設定します。

パラメータ:
selection - 選択 ID (永続)

setMatEntrd

public void setMatEntrd(String matEntrd)
入力品目を設定します。

パラメータ:
matEntrd - 入力品目

setLogSystemOwn

public void setLogSystemOwn(String logSystemOwn)
論理システムを設定します。

パラメータ:
logSystemOwn - 論理システム

setItmTypeUsage

public void setItmTypeUsage(String itmTypeUsage)
明細用途を設定します。

パラメータ:
itmTypeUsage - 明細用途

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

setTaxlawiss

public void setTaxlawiss(String taxlawiss)
ISS Tax Lawを設定します。

パラメータ:
taxlawiss - ISS Tax Law

setMatEntrdExternal

public void setMatEntrdExternal(String matEntrdExternal)
項目 MAT_ENTRD の品目コード (長)を設定します。

パラメータ:
matEntrdExternal - 項目 MAT_ENTRD の品目コード (長)

setMatEntrdGuid

public void setMatEntrdGuid(String matEntrdGuid)
項目 MAT_ENTRD の外部 GUIDを設定します。

パラメータ:
matEntrdGuid - 項目 MAT_ENTRD の外部 GUID

setMatEntrdVersion

public void setMatEntrdVersion(String matEntrdVersion)
項目 MAT_ENTRD のバージョン番号を設定します。

パラメータ:
matEntrdVersion - 項目 MAT_ENTRD のバージョン番号

setLocTaxcat

public void setLocTaxcat(String locTaxcat)
税タイプを設定します。

パラメータ:
locTaxcat - 税タイプ

setLocZerovat

public void setLocZerovat(String locZerovat)
locZerovatを 設定します。

パラメータ:
locZerovat - locZerovat

setLocActcode

public void setLocActcode(String locActcode)
総所得税の活動コードを設定します。

パラメータ:
locActcode - 総所得税の活動コード

setLocDisttype

public void setLocDisttype(String locDisttype)
所得税の配賦タイプを設定します。

パラメータ:
locDisttype - 所得税の配賦タイプ

setLocTxrelclas

public void setLocTxrelclas(String locTxrelclas)
税関連分類を設定します。

パラメータ:
locTxrelclas - 税関連分類

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します｡

パラメータ:
calcMotive - 計算区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemsInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ItemsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX
すべての実装インタフェース:
Serializable
public class ItemsInX
extends Object
implements Serializable

明細データチェックボックス情報クラス
機能は以下の通り

  • 明細データチェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ItemsInX()
明細データチェックボックス情報を作成します。
ItemsInX(int index)
明細データチェックボックス情報を作成します。
メソッドの概要
String | getAccntAsgn() 関連ユーザデータ項目の更新情報を取得します。
String | getAddValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getAlternBom() 関連ユーザデータ項目の更新情報を取得します。
String | getAltToItm() 関連ユーザデータ項目の更新情報を取得します。
String | getAssortMod() 関連ユーザデータ項目の更新情報を取得します。
String | getBatch() 関連ユーザデータ項目の更新情報を取得します。
String | getBegdemPer() 関連ユーザデータ項目の更新情報を取得します。
String | getBilForm() 関連ユーザデータ項目の更新情報を取得します。
String | getBillBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getBillDate() 関連ユーザデータ項目の更新情報を取得します。
String | getBillRel() 関連ユーザデータ項目の更新情報を取得します。
String | getBillSched() 関連ユーザデータ項目の更新情報を取得します。
String | getBomexplNo() 関連ユーザデータ項目の更新情報を取得します。
String | getBusTranst() 関連ユーザデータ項目の更新情報を取得します。
String | getCalcMotive() 関連ユーザデータ項目の更新情報を取得します。
String | getCampaign() 関連ユーザデータ項目の更新情報を取得します。
String | getCfopCode() 関連ユーザデータ項目の更新情報を取得します。
String | getCompQuant() 関連ユーザデータ項目の更新情報を取得します。
String | getConfigId() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getCstgSheet() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getCustMat22() 関連ユーザデータ項目の更新情報を取得します。
String | getCustMat35() 関連ユーザデータ項目の更新情報を取得します。
String | getDepartmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getDeprecPer() 関連ユーザデータ項目の更新情報を取得します。
String | getDivision() 関連ユーザデータ項目の更新情報を取得します。
String | getDliProfil() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvPrio() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvschduse() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getDocNumFi() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnKey() 関連ユーザデータ項目の更新情報を取得します。
String | getEanUpc() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRate() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRateV() 関連ユーザデータ項目の更新情報を取得します。
String | getExchRateFiV() 関連ユーザデータ項目の更新情報を取得します。
String | getExRateFi() 関連ユーザデータ項目の更新情報を取得します。
String | getFixdatQty() 関連ユーザデータ項目の更新情報を取得します。
String | getFixedQuan() 関連ユーザデータ項目の更新情報を取得します。
String | getFixValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getFkkConacct() 関連ユーザデータ項目の更新情報を取得します。
String | getFuncArea() 関連ユーザデータ項目の更新情報を取得します。
String | getGrossWght() 関連ユーザデータ項目の更新情報を取得します。
String | getHgLvItem() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms1() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms2() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 関連ユーザデータ項目の更新情報を取得します。
String | getInvoSched() 関連ユーザデータ項目の更新情報を取得します。
String | getItemCateg() 関連ユーザデータ項目の更新情報を取得します。
String | getItemguidAtp() 関連ユーザデータ項目の更新情報を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getItmTypeUsage() 関連ユーザデータ項目の更新情報を取得します。
String | getLocActcode() 関連ユーザデータ項目の更新情報を取得します。
String | getLocDisttype() 関連ユーザデータ項目の更新情報を取得します。
String | getLocTaxcat() 関連ユーザデータ項目の更新情報を取得します。
String | getLocTxrelclas() 関連ユーザデータ項目の更新情報を取得します。
String | getLocZerovat() 関連ユーザデータ項目の更新情報取得します。
String | getLogSystemOwn() 関連ユーザデータ項目の更新情報を取得します。
String | getMatEntrd() 関連ユーザデータ項目の更新情報を取得します。
String | getMatEntrdExternal() 関連ユーザデータ項目の更新情報を取得します。
String | getMatEntrdGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getMatEntrdVersion() 関連ユーザデータ項目の更新情報を取得します。
String | getMaterial() 関連ユーザデータ項目の更新情報を取得します。
String | getMatExt() 関連ユーザデータ項目の更新情報を取得します。
String | getMatfrgtgrp() 関連ユーザデータ項目の更新情報を取得します。
String | getMatGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getMatlGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getMatPrGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getMatVers() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevamnt() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevDay() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevper() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxPlDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getMnInvoice() 関連ユーザデータ項目の更新情報を取得します。
String | getNetWeight() 関連ユーザデータ項目の更新情報を取得します。
String | getNoGrPost() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdcompIn() 関連ユーザデータ項目の更新情報を取得します。
String | getOrderid() 関連ユーザデータ項目の更新情報を取得します。
String | getOrderProb() 関連ユーザデータ項目の更新情報を取得します。
String | getOverdlvtol() 関連ユーザデータ項目の更新情報を取得します。
String | getOverhdKey() 関連ユーザデータ項目の更新情報を取得します。
String | getPartDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getPlant() 関連ユーザデータ項目の更新情報を取得します。
String | getPldlvshdin() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatExt() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatVers() 関連ユーザデータ項目の更新情報を取得します。
String | getPmnttrms() 関連ユーザデータ項目の更新情報を取得します。
String | getPmtgarPro() 関連ユーザデータ項目の更新情報を取得します。
String | getPoDatS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoItmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getPoitmNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethod() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethS() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup1() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup2() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup3() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup4() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup5() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceList() 関連ユーザデータ項目の更新情報を取得します。
String | getProdcat() 関連ユーザデータ項目の更新情報を取得します。
String | getProdHiera() 関連ユーザデータ項目の更新情報を取得します。
String | getProfitCtr() 関連ユーザデータ項目の更新情報を取得します。
String | getPromotion() 関連ユーザデータ項目の更新情報を取得します。
String | getPrRefMat() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoC() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPymtMeth() 関連ユーザデータ項目の更新情報を取得します。
String | getReasonRej() 関連ユーザデータ項目の更新情報を取得します。
String | getRecPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1S() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDoc() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocCa() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocIt() 関連ユーザデータ項目の更新情報を取得します。
String | getReflogsys() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjkey() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjtype() 関連ユーザデータ項目の更新情報を取得します。
String | getReqmtsTyp() 関連ユーザデータ項目の更新情報を取得します。
String | getResanalkey() 関連ユーザデータ項目の更新情報を取得します。
String | getRevType() 関連ユーザデータ項目の更新情報を取得します。
String | getRnddlvQty() 関連ユーザデータ項目の更新情報を取得します。
String | getRoute() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesDist() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesUnit() 関連ユーザデータ項目の更新情報を取得します。
String | getSalqtyden() 関連ユーザデータ項目の更新情報を取得します。
String | getSalqtynum() 関連ユーザデータ項目の更新情報を取得します。
String | getSdTaxcode() 関連ユーザデータ項目の更新情報を取得します。
String | getSelection() 関連ユーザデータ項目の更新情報を取得します。
String | getSeqNo() 関連ユーザデータ項目の更新情報を取得します。
String | getServDate() 関連ユーザデータ項目の更新情報を取得します。
String | getShipPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getShipType() 関連ユーザデータ項目の更新情報を取得します。
String | getShortText() 関連ユーザデータ項目の更新情報を取得します。
String | getSProcInd() 関連ユーザデータ項目の更新情報を取得します。
String | getStoreLoc() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetQty() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetQu() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetVal() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass1() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass2() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass3() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass4() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass5() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass6() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass7() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass8() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass9() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxlawicms() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxlawipi() 関連ユーザデータ項目の更新情報を取得します。
String | getTrgqtyDen() 関連ユーザデータ項目の更新情報を取得します。
String | getTrgQtyNo() 関連ユーザデータ項目の更新情報を取得します。
String | getTUnitIso() 関連ユーザデータ項目の更新情報を取得します。
String | getUnddlvTol() 関連ユーザデータ項目の更新情報を取得します。
String | getUnlmtDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getUntofWght() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getUsageInd() 関連ユーザデータ項目の更新情報を取得します。
String | getValConI() 関連ユーザデータ項目の更新情報を取得します。
String | getValContr() 関連ユーザデータ項目の更新情報を取得します。
String | getValType() 関連ユーザデータ項目の更新情報を取得します。
String | getVolume() 関連ユーザデータ項目の更新情報を取得します。
String | getVolunit() 関連ユーザデータ項目の更新情報を取得します。
String | getVwUepos() 関連ユーザデータ項目の更新情報を取得します。
String | getWbsElem() 関連ユーザデータ項目の更新情報を取得します。
void | setAccntAsgn(String accntAsgn) 関連ユーザデータ項目の更新情報を設定します。
void | setAddValDy(String addValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setAlternBom(String alternBom) 関連ユーザデータ項目の更新情報を設定します。
void | setAltToItm(String altToItm) 関連ユーザデータ項目の更新情報を設定します。
void | setAssortMod(String assortMod) 関連ユーザデータ項目の更新情報を設定します。
void | setBatch(String batch) 関連ユーザデータ項目の更新情報を設定します。
void | setBegdemPer(String begdemPer) 関連ユーザデータ項目の更新情報を設定します。
void | setBilForm(String bilForm) 関連ユーザデータ項目の更新情報を設定します。
void | setBillBlock(String billBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setBillDate(String billDate) 関連ユーザデータ項目の更新情報を設定します。
void | setBillRel(String billRel) 関連ユーザデータ項目の更新情報を設定します。
void | setBillSched(String billSched) 関連ユーザデータ項目の更新情報を設定します。
void | setBomexplNo(String bomexplNo) 関連ユーザデータ項目の更新情報を設定します。
void | setBusTranst(String busTranst) 関連ユーザデータ項目の更新情報を設定します。
void | setCalcMotive(String calcMotive) 関連ユーザデータ項目の更新情報を設定します｡
void | setCampaign(String campaign) 関連ユーザデータ項目の更新情報を設定します。
void | setCfopCode(String cfopCode) 関連ユーザデータ項目の更新情報を設定します。
void | setCompQuant(String compQuant) 関連ユーザデータ項目の更新情報を設定します。
void | setConfigId(String configId) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp1(String cstcndgrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp2(String cstcndgrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp3(String cstcndgrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp4(String cstcndgrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp5(String cstcndgrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setCstgSheet(String cstgSheet) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGroup(String custGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setCustMat22(String custMat22) 関連ユーザデータ項目の更新情報を設定します。
void | setCustMat35(String custMat35) 関連ユーザデータ項目の更新情報を設定します。
void | setDepartmNo(String departmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setDeprecPer(String deprecPer) 関連ユーザデータ項目の更新情報を設定します。
void | setDivision(String division) 関連ユーザデータ項目の更新情報を設定します。
void | setDliProfil(String dliProfil) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvGroup(String dlvGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvPrio(String dlvPrio) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvschduse(String dlvschduse) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setDocNumFi(String docNumFi) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnBlock(String dunnBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnKey(String dunnKey) 関連ユーザデータ項目の更新情報を設定します。
void | setEanUpc(String eanUpc) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRate(String exchgRate) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRateV(String exchgRateV) 関連ユーザデータ項目の更新情報を設定します。
void | setExchRateFiV(String exchRateFiV) 関連ユーザデータ項目の更新情報を設定します。
void | setExRateFi(String exRateFi) 関連ユーザデータ項目の更新情報を設定します。
void | setFixdatQty(String fixdatQty) 関連ユーザデータ項目の更新情報を設定します。
void | setFixedQuan(String fixedQuan) 関連ユーザデータ項目の更新情報を設定します。
void | setFixValDy(String fixValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setFkkConacct(String fkkConacct) 関連ユーザデータ項目の更新情報を設定します。
void | setFuncArea(String funcArea) 関連ユーザデータ項目の更新情報を設定します。
void | setGrossWght(String grossWght) 関連ユーザデータ項目の更新情報を設定します。
void | setHgLvItem(String hgLvItem) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms1(String incoterms1) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms2(String incoterms2) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 関連ユーザデータ項目の更新情報を設定します。
void | setInvoSched(String invoSched) 関連ユーザデータ項目の更新情報を設定します。
void | setItemCateg(String itemCateg) 関連ユーザデータ項目の更新情報を設定します。
void | setItemguidAtp(String itemguidAtp) 関連ユーザデータ項目の更新情報を設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setItmTypeUsage(String itmTypeUsage) 関連ユーザデータ項目の更新情報を設定します。
void | setLocActcode(String locActcode) 関連ユーザデータ項目の更新情報を設定します。
void | setLocDisttype(String locDisttype) 関連ユーザデータ項目の更新情報を設定します。
void | setLocTaxcat(String locTaxcat) 関連ユーザデータ項目の更新情報を設定します。
void | setLocTxrelclas(String locTxrelclas) 関連ユーザデータ項目の更新情報を設定します。
void | setLocZerovat(String locZerovat) 関連ユーザデータ項目の更新情報設定します。
void | setLogSystemOwn(String logSystemOwn) 関連ユーザデータ項目の更新情報を設定します。
void | setMatEntrd(String matEntrd) 関連ユーザデータ項目の更新情報を設定します。
void | setMatEntrdExternal(String matEntrdExternal) 関連ユーザデータ項目の更新情報を設定します。
void | setMatEntrdGuid(String matEntrdGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setMatEntrdVersion(String matEntrdVersion) 関連ユーザデータ項目の更新情報を設定します。
void | setMaterial(String material) 関連ユーザデータ項目の更新情報を設定します。
void | setMatExt(String matExt) 関連ユーザデータ項目の更新情報を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 関連ユーザデータ項目の更新情報を設定します。
void | setMatGuid(String matGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setMatlGroup(String matlGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setMatPrGrp(String matPrGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setMatVers(String matVers) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevamnt(String maxdevamnt) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevDay(String maxdevDay) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevper(String maxdevper) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxPlDlv(String maxPlDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setMnInvoice(String mnInvoice) 関連ユーザデータ項目の更新情報を設定します。
void | setNetWeight(String netWeight) 関連ユーザデータ項目の更新情報を設定します。
void | setNoGrPost(String noGrPost) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdcompIn(String ordcompIn) 関連ユーザデータ項目の更新情報を設定します。
void | setOrderid(String orderid) 関連ユーザデータ項目の更新情報を設定します。
void | setOrderProb(String orderProb) 関連ユーザデータ項目の更新情報を設定します。
void | setOverdlvtol(String overdlvtol) 関連ユーザデータ項目の更新情報を設定します。
void | setOverhdKey(String overhdKey) 関連ユーザデータ項目の更新情報を設定します。
void | setPartDlv(String partDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setPlant(String plant) 関連ユーザデータ項目の更新情報を設定します。
void | setPldlvshdin(String pldlvshdin) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatExt(String pMatExt) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatGuid(String pMatGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatVers(String pMatVers) 関連ユーザデータ項目の更新情報を設定します。
void | setPmnttrms(String pmnttrms) 関連ユーザデータ項目の更新情報を設定します。
void | setPmtgarPro(String pmtgarPro) 関連ユーザデータ項目の更新情報を設定します。
void | setPoDatS(String poDatS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoItmNo(String poItmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setPoitmNoS(String poitmNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethod(String poMethod) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethS(String poMethS) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup1(String prcGroup1) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup2(String prcGroup2) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup3(String prcGroup3) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup4(String prcGroup4) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup5(String prcGroup5) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceDate(String priceDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceGrp(String priceGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceList(String priceList) 関連ユーザデータ項目の更新情報を設定します。
void | setProdcat(String prodcat) 関連ユーザデータ項目の更新情報を設定します。
void | setProdHiera(String prodHiera) 関連ユーザデータ項目の更新情報を設定します。
void | setProfitCtr(String profitCtr) 関連ユーザデータ項目の更新情報を設定します。
void | setPromotion(String promotion) 関連ユーザデータ項目の更新情報を設定します。
void | setPrRefMat(String prRefMat) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchDate(String purchDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoC(String purchNoC) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoS(String purchNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPymtMeth(String pymtMeth) 関連ユーザデータ項目の更新情報を設定します。
void | setReasonRej(String reasonRej) 関連ユーザデータ項目の更新情報を設定します。
void | setRecPoint(String recPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1(String ref1) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1S(String ref1S) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDoc(String refDoc) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocCa(String refDocCa) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocIt(String refDocIt) 関連ユーザデータ項目の更新情報を設定します。
void | setReflogsys(String reflogsys) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjkey(String refobjkey) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjtype(String refobjtype) 関連ユーザデータ項目の更新情報を設定します。
void | setReqmtsTyp(String reqmtsTyp) 関連ユーザデータ項目の更新情報を設定します。
void | setResanalkey(String resanalkey) 関連ユーザデータ項目の更新情報を設定します。
void | setRevType(String revType) 関連ユーザデータ項目の更新情報を設定します。
void | setRnddlvQty(String rnddlvQty) 関連ユーザデータ項目の更新情報を設定します。
void | setRoute(String route) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesDist(String salesDist) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesUnit(String salesUnit) 関連ユーザデータ項目の更新情報を設定します。
void | setSalqtyden(String salqtyden) 関連ユーザデータ項目の更新情報を設定します。
void | setSalqtynum(String salqtynum) 関連ユーザデータ項目の更新情報を設定します。
void | setSdTaxcode(String sdTaxcode) 関連ユーザデータ項目の更新情報を設定します。
void | setSelection(String selection) 関連ユーザデータ項目の更新情報を設定します。
void | setSeqNo(String seqNo) 関連ユーザデータ項目の更新情報を設定します。
void | setServDate(String servDate) 関連ユーザデータ項目の更新情報を設定します。
void | setShipPoint(String shipPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setShipType(String shipType) 関連ユーザデータ項目の更新情報を設定します。
void | setShortText(String shortText) 関連ユーザデータ項目の更新情報を設定します。
void | setSProcInd(String sProcInd) 関連ユーザデータ項目の更新情報を設定します。
void | setStoreLoc(String storeLoc) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetQty(String targetQty) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetQu(String targetQu) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetVal(String targetVal) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass1(String taxClass1) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass2(String taxClass2) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass3(String taxClass3) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass4(String taxClass4) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass5(String taxClass5) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass6(String taxClass6) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass7(String taxClass7) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass8(String taxClass8) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass9(String taxClass9) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxlawicms(String taxlawicms) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxlawipi(String taxlawipi) 関連ユーザデータ項目の更新情報を設定します。
void | setTrgqtyDen(String trgqtyDen) 関連ユーザデータ項目の更新情報を設定します。
void | setTrgQtyNo(String trgQtyNo) 関連ユーザデータ項目の更新情報を設定します。
void | setTUnitIso(String tUnitIso) 関連ユーザデータ項目の更新情報を設定します。
void | setUnddlvTol(String unddlvTol) 関連ユーザデータ項目の更新情報を設定します。
void | setUnlmtDlv(String unlmtDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setUntofWght(String untofWght) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setUsageInd(String usageInd) 関連ユーザデータ項目の更新情報を設定します。
void | setValConI(String valConI) 関連ユーザデータ項目の更新情報を設定します。
void | setValContr(String valContr) 関連ユーザデータ項目の更新情報を設定します。
void | setValType(String valType) 関連ユーザデータ項目の更新情報を設定します。
void | setVolume(String volume) 関連ユーザデータ項目の更新情報を設定します。
void | setVolunit(String volunit) 関連ユーザデータ項目の更新情報を設定します。
void | setVwUepos(String vwUepos) 関連ユーザデータ項目の更新情報を設定します。
void | setWbsElem(String wbsElem) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ItemsInX

public ItemsInX()
明細データチェックボックス情報を作成します。

ItemsInX

public ItemsInX(int index)
明細データチェックボックス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getHgLvItem

public String getHgLvItem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
hgLvItem 関連ユーザデータ項目の更新情報

getPoItmNo

public String getPoItmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poItmNo 関連ユーザデータ項目の更新情報

getMaterial

public String getMaterial()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
material 関連ユーザデータ項目の更新情報

getAltToItm

public String getAltToItm()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
altToItm 関連ユーザデータ項目の更新情報

getCustMat22

public String getCustMat22()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custMat22 関連ユーザデータ項目の更新情報

getBatch

public String getBatch()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
batch 関連ユーザデータ項目の更新情報

getDlvGroup

public String getDlvGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvGroup 関連ユーザデータ項目の更新情報

getPartDlv

public String getPartDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
partDlv 関連ユーザデータ項目の更新情報

getReasonRej

public String getReasonRej()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reasonRej 関連ユーザデータ項目の更新情報

getBillBlock

public String getBillBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billBlock 関連ユーザデータ項目の更新情報

getBillDate

public String getBillDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billDate 関連ユーザデータ項目の更新情報

getPlant

public String getPlant()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
plant 関連ユーザデータ項目の更新情報

getStoreLoc

public String getStoreLoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
storeLoc 関連ユーザデータ項目の更新情報

getTargetQty

public String getTargetQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetQty 関連ユーザデータ項目の更新情報

getTargetQu

public String getTargetQu()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetQu 関連ユーザデータ項目の更新情報

getTUnitIso

public String getTUnitIso()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tUnitIso 関連ユーザデータ項目の更新情報

getItemCateg

public String getItemCateg()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itemCateg 関連ユーザデータ項目の更新情報

getShortText

public String getShortText()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shortText 関連ユーザデータ項目の更新情報

getPrcGroup1

public String getPrcGroup1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup1 関連ユーザデータ項目の更新情報

getPrcGroup2

public String getPrcGroup2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup2 関連ユーザデータ項目の更新情報

getPrcGroup3

public String getPrcGroup3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup3 関連ユーザデータ項目の更新情報

getPrcGroup4

public String getPrcGroup4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup4 関連ユーザデータ項目の更新情報

getPrcGroup5

public String getPrcGroup5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup5 関連ユーザデータ項目の更新情報

getProdHiera

public String getProdHiera()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prodHiera 関連ユーザデータ項目の更新情報

getMatlGroup

public String getMatlGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matlGroup 関連ユーザデータ項目の更新情報

getPurchNoC

public String getPurchNoC()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoC 関連ユーザデータ項目の更新情報

getPurchDate

public String getPurchDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchDate 関連ユーザデータ項目の更新情報

getPoMethod

public String getPoMethod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethod 関連ユーザデータ項目の更新情報

getRef1

public String getRef1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1 関連ユーザデータ項目の更新情報

getPurchNoS

public String getPurchNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoS 関連ユーザデータ項目の更新情報

getPoDatS

public String getPoDatS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poDatS 関連ユーザデータ項目の更新情報

getPoMethS

public String getPoMethS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethS 関連ユーザデータ項目の更新情報

getRef1S

public String getRef1S()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1S 関連ユーザデータ項目の更新情報

getPoitmNoS

public String getPoitmNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poitmNoS 関連ユーザデータ項目の更新情報

getPriceGrp

public String getPriceGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceGrp 関連ユーザデータ項目の更新情報

getCustGroup

public String getCustGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGroup 関連ユーザデータ項目の更新情報

getSalesDist

public String getSalesDist()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesDist 関連ユーザデータ項目の更新情報

getPriceList

public String getPriceList()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceList 関連ユーザデータ項目の更新情報

getIncoterms1

public String getIncoterms1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms1 関連ユーザデータ項目の更新情報

getIncoterms2

public String getIncoterms2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms2 関連ユーザデータ項目の更新情報

getOrdcompIn

public String getOrdcompIn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordcompIn 関連ユーザデータ項目の更新情報

getBillSched

public String getBillSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billSched 関連ユーザデータ項目の更新情報

getInvoSched

public String getInvoSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
invoSched 関連ユーザデータ項目の更新情報

getMnInvoice

public String getMnInvoice()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mnInvoice 関連ユーザデータ項目の更新情報

getExRateFi

public String getExRateFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exRateFi 関連ユーザデータ項目の更新情報

getAddValDy

public String getAddValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
addValDy 関連ユーザデータ項目の更新情報

getFixValDy

public String getFixValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixValDy 関連ユーザデータ項目の更新情報

getPmnttrms

public String getPmnttrms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmnttrms 関連ユーザデータ項目の更新情報

getPymtMeth

public String getPymtMeth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pymtMeth 関連ユーザデータ項目の更新情報

getAccntAsgn

public String getAccntAsgn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
accntAsgn 関連ユーザデータ項目の更新情報

getExchgRate

public String getExchgRate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRate 関連ユーザデータ項目の更新情報

getPriceDate

public String getPriceDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceDate 関連ユーザデータ項目の更新情報

getServDate

public String getServDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
servDate 関連ユーザデータ項目の更新情報

getDunnKey

public String getDunnKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnKey 関連ユーザデータ項目の更新情報

getDunnBlock

public String getDunnBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnBlock 関連ユーザデータ項目の更新情報

getPromotion

public String getPromotion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
promotion 関連ユーザデータ項目の更新情報

getPmtgarPro

public String getPmtgarPro()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmtgarPro 関連ユーザデータ項目の更新情報

getDocNumFi

public String getDocNumFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docNumFi 関連ユーザデータ項目の更新情報

getDepartmNo

public String getDepartmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
departmNo 関連ユーザデータ項目の更新情報

getRecPoint

public String getRecPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
recPoint 関連ユーザデータ項目の更新情報

getCstcndgrp1

public String getCstcndgrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp1 関連ユーザデータ項目の更新情報

getCstcndgrp2

public String getCstcndgrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp2 関連ユーザデータ項目の更新情報

getCstcndgrp3

public String getCstcndgrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp3 関連ユーザデータ項目の更新情報

getCstcndgrp4

public String getCstcndgrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp4 関連ユーザデータ項目の更新情報

getCstcndgrp5

public String getCstcndgrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp5 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getSalesUnit

public String getSalesUnit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesUnit 関連ユーザデータ項目の更新情報

getTrgQtyNo

public String getTrgQtyNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
trgQtyNo 関連ユーザデータ項目の更新情報

getTrgqtyDen

public String getTrgqtyDen()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
trgqtyDen 関連ユーザデータ項目の更新情報

getRnddlvQty

public String getRnddlvQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
rnddlvQty 関連ユーザデータ項目の更新情報

getMaxdevamnt

public String getMaxdevamnt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevamnt 関連ユーザデータ項目の更新情報

getMaxdevper

public String getMaxdevper()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevper 関連ユーザデータ項目の更新情報

getMaxdevDay

public String getMaxdevDay()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevDay 関連ユーザデータ項目の更新情報

getUsageInd

public String getUsageInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
usageInd 関連ユーザデータ項目の更新情報

getFixedQuan

public String getFixedQuan()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixedQuan 関連ユーザデータ項目の更新情報

getUnlmtDlv

public String getUnlmtDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unlmtDlv 関連ユーザデータ項目の更新情報

getOverdlvtol

public String getOverdlvtol()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
overdlvtol 関連ユーザデータ項目の更新情報

getUnddlvTol

public String getUnddlvTol()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unddlvTol 関連ユーザデータ項目の更新情報

getDivision

public String getDivision()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
division 関連ユーザデータ項目の更新情報

getSalqtynum

public String getSalqtynum()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salqtynum 関連ユーザデータ項目の更新情報

getSalqtyden

public String getSalqtyden()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salqtyden 関連ユーザデータ項目の更新情報

getGrossWght

public String getGrossWght()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
grossWght 関連ユーザデータ項目の更新情報

getNetWeight

public String getNetWeight()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
netWeight 関連ユーザデータ項目の更新情報

getUntofWght

public String getUntofWght()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
untofWght 関連ユーザデータ項目の更新情報

getVolume

public String getVolume()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
volume 関連ユーザデータ項目の更新情報

getVolunit

public String getVolunit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
volunit 関連ユーザデータ項目の更新情報

getDlvPrio

public String getDlvPrio()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvPrio 関連ユーザデータ項目の更新情報

getShipPoint

public String getShipPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipPoint 関連ユーザデータ項目の更新情報

getRoute

public String getRoute()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
route 関連ユーザデータ項目の更新情報

getTaxClass1

public String getTaxClass1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass1 関連ユーザデータ項目の更新情報

getTaxClass2

public String getTaxClass2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass2 関連ユーザデータ項目の更新情報

getTaxClass3

public String getTaxClass3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass3 関連ユーザデータ項目の更新情報

getTaxClass4

public String getTaxClass4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass4 関連ユーザデータ項目の更新情報

getTaxClass5

public String getTaxClass5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass5 関連ユーザデータ項目の更新情報

getTaxClass6

public String getTaxClass6()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass6 関連ユーザデータ項目の更新情報

getTaxClass7

public String getTaxClass7()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass7 関連ユーザデータ項目の更新情報

getTaxClass8

public String getTaxClass8()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass8 関連ユーザデータ項目の更新情報

getTaxClass9

public String getTaxClass9()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass9 関連ユーザデータ項目の更新情報

getMatPrGrp

public String getMatPrGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matPrGrp 関連ユーザデータ項目の更新情報

getValType

public String getValType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valType 関連ユーザデータ項目の更新情報

getFixdatQty

public String getFixdatQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixdatQty 関連ユーザデータ項目の更新情報

getBomexplNo

public String getBomexplNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
bomexplNo 関連ユーザデータ項目の更新情報

getResanalkey

public String getResanalkey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
resanalkey 関連ユーザデータ項目の更新情報

getReqmtsTyp

public String getReqmtsTyp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqmtsTyp 関連ユーザデータ項目の更新情報

getNoGrPost

public String getNoGrPost()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
noGrPost 関連ユーザデータ項目の更新情報

getBusTranst

public String getBusTranst()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
busTranst 関連ユーザデータ項目の更新情報

getOverhdKey

public String getOverhdKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
overhdKey 関連ユーザデータ項目の更新情報

getCstgSheet

public String getCstgSheet()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstgSheet 関連ユーザデータ項目の更新情報

getMatfrgtgrp

public String getMatfrgtgrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matfrgtgrp 関連ユーザデータ項目の更新情報

getPldlvshdin

public String getPldlvshdin()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pldlvshdin 関連ユーザデータ項目の更新情報

getSeqNo

public String getSeqNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
seqNo 関連ユーザデータ項目の更新情報

getBilForm

public String getBilForm()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
bilForm 関連ユーザデータ項目の更新情報

getDliProfil

public String getDliProfil()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dliProfil 関連ユーザデータ項目の更新情報

getRevType

public String getRevType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
revType 関連ユーザデータ項目の更新情報

getBegdemPer

public String getBegdemPer()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
begdemPer 関連ユーザデータ項目の更新情報

getPrRefMat

public String getPrRefMat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prRefMat 関連ユーザデータ項目の更新情報

getRefobjtype

public String getRefobjtype()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refobjtype 関連ユーザデータ項目の更新情報

getRefobjkey

public String getRefobjkey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refobjkey 関連ユーザデータ項目の更新情報

getReflogsys

public String getReflogsys()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reflogsys 関連ユーザデータ項目の更新情報

getOrderProb

public String getOrderProb()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
orderProb 関連ユーザデータ項目の更新情報

getMaxPlDlv

public String getMaxPlDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxPlDlv 関連ユーザデータ項目の更新情報

getCfopCode

public String getCfopCode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cfopCode 関連ユーザデータ項目の更新情報

getTaxlawicms

public String getTaxlawicms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxlawicms 関連ユーザデータ項目の更新情報

getTaxlawipi

public String getTaxlawipi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxlawipi 関連ユーザデータ項目の更新情報

getSdTaxcode

public String getSdTaxcode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sdTaxcode 関連ユーザデータ項目の更新情報

getAssortMod

public String getAssortMod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
assortMod 関連ユーザデータ項目の更新情報

getCompQuant

public String getCompQuant()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
compQuant 関連ユーザデータ項目の更新情報

getTargetVal

public String getTargetVal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetVal 関連ユーザデータ項目の更新情報

getProfitCtr

public String getProfitCtr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
profitCtr 関連ユーザデータ項目の更新情報

getOrderid

public String getOrderid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
orderid 関連ユーザデータ項目の更新情報

getWbsElem

public String getWbsElem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
wbsElem 関連ユーザデータ項目の更新情報

getDeprecPer

public String getDeprecPer()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
deprecPer 関連ユーザデータ項目の更新情報

getRefDoc

public String getRefDoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDoc 関連ユーザデータ項目の更新情報

getRefDocIt

public String getRefDocIt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocIt 関連ユーザデータ項目の更新情報

getRefDocCa

public String getRefDocCa()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocCa 関連ユーザデータ項目の更新情報

getCustMat35

public String getCustMat35()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custMat35 関連ユーザデータ項目の更新情報

getExchRateFiV

public String getExchRateFiV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchRateFiV 関連ユーザデータ項目の更新情報

getExchgRateV

public String getExchgRateV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRateV 関連ユーザデータ項目の更新情報

getItemguidAtp

public String getItemguidAtp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itemguidAtp 関連ユーザデータ項目の更新情報

getValContr

public String getValContr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valContr 関連ユーザデータ項目の更新情報

getValConI

public String getValConI()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valConI 関連ユーザデータ項目の更新情報

getConfigId

public String getConfigId()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
configId 関連ユーザデータ項目の更新情報

getInstId

public String getInstId()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
instId 関連ユーザデータ項目の更新情報

getMatExt

public String getMatExt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matExt 関連ユーザデータ項目の更新情報

getMatGuid

public String getMatGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matGuid 関連ユーザデータ項目の更新情報

getMatVers

public String getMatVers()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matVers 関連ユーザデータ項目の更新情報

getPMatExt

public String getPMatExt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatExt 関連ユーザデータ項目の更新情報

getPMatGuid

public String getPMatGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatGuid 関連ユーザデータ項目の更新情報

getPMatVers

public String getPMatVers()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatVers 関連ユーザデータ項目の更新情報

getFuncArea

public String getFuncArea()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
funcArea 関連ユーザデータ項目の更新情報

getAlternBom

public String getAlternBom()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
alternBom 関連ユーザデータ項目の更新情報

getFkkConacct

public String getFkkConacct()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fkkConacct 関連ユーザデータ項目の更新情報

getEanUpc

public String getEanUpc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
eanUpc 関連ユーザデータ項目の更新情報

getProdcat

public String getProdcat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prodcat 関連ユーザデータ項目の更新情報

getShipType

public String getShipType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipType 関連ユーザデータ項目の更新情報

getSProcInd

public String getSProcInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sProcInd 関連ユーザデータ項目の更新情報

getBillRel

public String getBillRel()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billRel 関連ユーザデータ項目の更新情報

getVwUepos

public String getVwUepos()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
vwUepos 関連ユーザデータ項目の更新情報

getCampaign

public String getCampaign()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
campaign 関連ユーザデータ項目の更新情報

getDlvschduse

public String getDlvschduse()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvschduse 関連ユーザデータ項目の更新情報

getSelection

public String getSelection()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
selection 関連ユーザデータ項目の更新情報

getMatEntrd

public String getMatEntrd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matEntrd 関連ユーザデータ項目の更新情報

getLogSystemOwn

public String getLogSystemOwn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
logSystemOwn 関連ユーザデータ項目の更新情報

getItmTypeUsage

public String getItmTypeUsage()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itmTypeUsage 関連ユーザデータ項目の更新情報

getMatEntrdExternal

public String getMatEntrdExternal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matEntrdExternal 関連ユーザデータ項目の更新情報

getMatEntrdGuid

public String getMatEntrdGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matEntrdGuid 関連ユーザデータ項目の更新情報

getMatEntrdVersion

public String getMatEntrdVersion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matEntrdVersion 関連ユーザデータ項目の更新情報

getLocTaxcat

public String getLocTaxcat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
locTaxcat 関連ユーザデータ項目の更新情報

getLocZerovat

public String getLocZerovat()
関連ユーザデータ項目の更新情報取得します。

戻り値:
locZerovat 関連ユーザデータ項目の更新情報

getLocActcode

public String getLocActcode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
locActcode 関連ユーザデータ項目の更新情報

getLocDisttype

public String getLocDisttype()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
locDisttype 関連ユーザデータ項目の更新情報

getLocTxrelclas

public String getLocTxrelclas()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
locTxrelclas 関連ユーザデータ項目の更新情報

getCalcMotive

public String getCalcMotive()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
calcMotive 関連ユーザデータ項目の更新情報

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setHgLvItem

public void setHgLvItem(String hgLvItem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
hgLvItem - 関連ユーザデータ項目の更新情報

setPoItmNo

public void setPoItmNo(String poItmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poItmNo - 関連ユーザデータ項目の更新情報

setMaterial

public void setMaterial(String material)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
material - 関連ユーザデータ項目の更新情報

setAltToItm

public void setAltToItm(String altToItm)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
altToItm - 関連ユーザデータ項目の更新情報

setCustMat22

public void setCustMat22(String custMat22)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custMat22 - 関連ユーザデータ項目の更新情報

setBatch

public void setBatch(String batch)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
batch - 関連ユーザデータ項目の更新情報

setDlvGroup

public void setDlvGroup(String dlvGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvGroup - 関連ユーザデータ項目の更新情報

setPartDlv

public void setPartDlv(String partDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
partDlv - 関連ユーザデータ項目の更新情報

setReasonRej

public void setReasonRej(String reasonRej)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reasonRej - 関連ユーザデータ項目の更新情報

setBillBlock

public void setBillBlock(String billBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billBlock - 関連ユーザデータ項目の更新情報

setBillDate

public void setBillDate(String billDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billDate - 関連ユーザデータ項目の更新情報

setPlant

public void setPlant(String plant)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
plant - 関連ユーザデータ項目の更新情報

setStoreLoc

public void setStoreLoc(String storeLoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
storeLoc - 関連ユーザデータ項目の更新情報

setTargetQty

public void setTargetQty(String targetQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetQty - 関連ユーザデータ項目の更新情報

setTargetQu

public void setTargetQu(String targetQu)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetQu - 関連ユーザデータ項目の更新情報

setTUnitIso

public void setTUnitIso(String tUnitIso)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tUnitIso - 関連ユーザデータ項目の更新情報

setItemCateg

public void setItemCateg(String itemCateg)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itemCateg - 関連ユーザデータ項目の更新情報

setShortText

public void setShortText(String shortText)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shortText - 関連ユーザデータ項目の更新情報

setPrcGroup1

public void setPrcGroup1(String prcGroup1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup1 - 関連ユーザデータ項目の更新情報

setPrcGroup2

public void setPrcGroup2(String prcGroup2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup2 - 関連ユーザデータ項目の更新情報

setPrcGroup3

public void setPrcGroup3(String prcGroup3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup3 - 関連ユーザデータ項目の更新情報

setPrcGroup4

public void setPrcGroup4(String prcGroup4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup4 - 関連ユーザデータ項目の更新情報

setPrcGroup5

public void setPrcGroup5(String prcGroup5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup5 - 関連ユーザデータ項目の更新情報

setProdHiera

public void setProdHiera(String prodHiera)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prodHiera - 関連ユーザデータ項目の更新情報

setMatlGroup

public void setMatlGroup(String matlGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matlGroup - 関連ユーザデータ項目の更新情報

setPurchNoC

public void setPurchNoC(String purchNoC)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoC - 関連ユーザデータ項目の更新情報

setPurchDate

public void setPurchDate(String purchDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchDate - 関連ユーザデータ項目の更新情報

setPoMethod

public void setPoMethod(String poMethod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethod - 関連ユーザデータ項目の更新情報

setRef1

public void setRef1(String ref1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1 - 関連ユーザデータ項目の更新情報

setPurchNoS

public void setPurchNoS(String purchNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoS - 関連ユーザデータ項目の更新情報

setPoDatS

public void setPoDatS(String poDatS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poDatS - 関連ユーザデータ項目の更新情報

setPoMethS

public void setPoMethS(String poMethS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethS - 関連ユーザデータ項目の更新情報

setRef1S

public void setRef1S(String ref1S)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1S - 関連ユーザデータ項目の更新情報

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poitmNoS - 関連ユーザデータ項目の更新情報

setPriceGrp

public void setPriceGrp(String priceGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceGrp - 関連ユーザデータ項目の更新情報

setCustGroup

public void setCustGroup(String custGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGroup - 関連ユーザデータ項目の更新情報

setSalesDist

public void setSalesDist(String salesDist)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesDist - 関連ユーザデータ項目の更新情報

setPriceList

public void setPriceList(String priceList)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceList - 関連ユーザデータ項目の更新情報

setIncoterms1

public void setIncoterms1(String incoterms1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms1 - 関連ユーザデータ項目の更新情報

setIncoterms2

public void setIncoterms2(String incoterms2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms2 - 関連ユーザデータ項目の更新情報

setOrdcompIn

public void setOrdcompIn(String ordcompIn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordcompIn - 関連ユーザデータ項目の更新情報

setBillSched

public void setBillSched(String billSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billSched - 関連ユーザデータ項目の更新情報

setInvoSched

public void setInvoSched(String invoSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
invoSched - 関連ユーザデータ項目の更新情報

setMnInvoice

public void setMnInvoice(String mnInvoice)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mnInvoice - 関連ユーザデータ項目の更新情報

setExRateFi

public void setExRateFi(String exRateFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exRateFi - 関連ユーザデータ項目の更新情報

setAddValDy

public void setAddValDy(String addValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
addValDy - 関連ユーザデータ項目の更新情報

setFixValDy

public void setFixValDy(String fixValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixValDy - 関連ユーザデータ項目の更新情報

setPmnttrms

public void setPmnttrms(String pmnttrms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmnttrms - 関連ユーザデータ項目の更新情報

setPymtMeth

public void setPymtMeth(String pymtMeth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pymtMeth - 関連ユーザデータ項目の更新情報

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
accntAsgn - 関連ユーザデータ項目の更新情報

setExchgRate

public void setExchgRate(String exchgRate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRate - 関連ユーザデータ項目の更新情報

setPriceDate

public void setPriceDate(String priceDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceDate - 関連ユーザデータ項目の更新情報

setServDate

public void setServDate(String servDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
servDate - 関連ユーザデータ項目の更新情報

setDunnKey

public void setDunnKey(String dunnKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnKey - 関連ユーザデータ項目の更新情報

setDunnBlock

public void setDunnBlock(String dunnBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnBlock - 関連ユーザデータ項目の更新情報

setPromotion

public void setPromotion(String promotion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
promotion - 関連ユーザデータ項目の更新情報

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmtgarPro - 関連ユーザデータ項目の更新情報

setDocNumFi

public void setDocNumFi(String docNumFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docNumFi - 関連ユーザデータ項目の更新情報

setDepartmNo

public void setDepartmNo(String departmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
departmNo - 関連ユーザデータ項目の更新情報

setRecPoint

public void setRecPoint(String recPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
recPoint - 関連ユーザデータ項目の更新情報

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp1 - 関連ユーザデータ項目の更新情報

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp2 - 関連ユーザデータ項目の更新情報

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp3 - 関連ユーザデータ項目の更新情報

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp4 - 関連ユーザデータ項目の更新情報

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp5 - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setSalesUnit

public void setSalesUnit(String salesUnit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesUnit - 関連ユーザデータ項目の更新情報

setTrgQtyNo

public void setTrgQtyNo(String trgQtyNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
trgQtyNo - 関連ユーザデータ項目の更新情報

setTrgqtyDen

public void setTrgqtyDen(String trgqtyDen)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
trgqtyDen - 関連ユーザデータ項目の更新情報

setRnddlvQty

public void setRnddlvQty(String rnddlvQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
rnddlvQty - 関連ユーザデータ項目の更新情報

setMaxdevamnt

public void setMaxdevamnt(String maxdevamnt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevamnt - 関連ユーザデータ項目の更新情報

setMaxdevper

public void setMaxdevper(String maxdevper)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevper - 関連ユーザデータ項目の更新情報

setMaxdevDay

public void setMaxdevDay(String maxdevDay)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevDay - 関連ユーザデータ項目の更新情報

setUsageInd

public void setUsageInd(String usageInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
usageInd - 関連ユーザデータ項目の更新情報

setFixedQuan

public void setFixedQuan(String fixedQuan)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixedQuan - 関連ユーザデータ項目の更新情報

setUnlmtDlv

public void setUnlmtDlv(String unlmtDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unlmtDlv - 関連ユーザデータ項目の更新情報

setOverdlvtol

public void setOverdlvtol(String overdlvtol)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
overdlvtol - 関連ユーザデータ項目の更新情報

setUnddlvTol

public void setUnddlvTol(String unddlvTol)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unddlvTol - 関連ユーザデータ項目の更新情報

setDivision

public void setDivision(String division)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
division - 関連ユーザデータ項目の更新情報

setSalqtynum

public void setSalqtynum(String salqtynum)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salqtynum - 関連ユーザデータ項目の更新情報

setSalqtyden

public void setSalqtyden(String salqtyden)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salqtyden - 関連ユーザデータ項目の更新情報

setGrossWght

public void setGrossWght(String grossWght)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
grossWght - 関連ユーザデータ項目の更新情報

setNetWeight

public void setNetWeight(String netWeight)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
netWeight - 関連ユーザデータ項目の更新情報

setUntofWght

public void setUntofWght(String untofWght)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
untofWght - 関連ユーザデータ項目の更新情報

setVolume

public void setVolume(String volume)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
volume - 関連ユーザデータ項目の更新情報

setVolunit

public void setVolunit(String volunit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
volunit - 関連ユーザデータ項目の更新情報

setDlvPrio

public void setDlvPrio(String dlvPrio)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvPrio - 関連ユーザデータ項目の更新情報

setShipPoint

public void setShipPoint(String shipPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipPoint - 関連ユーザデータ項目の更新情報

setRoute

public void setRoute(String route)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
route - 関連ユーザデータ項目の更新情報

setTaxClass1

public void setTaxClass1(String taxClass1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass1 - 関連ユーザデータ項目の更新情報

setTaxClass2

public void setTaxClass2(String taxClass2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass2 - 関連ユーザデータ項目の更新情報

setTaxClass3

public void setTaxClass3(String taxClass3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass3 - 関連ユーザデータ項目の更新情報

setTaxClass4

public void setTaxClass4(String taxClass4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass4 - 関連ユーザデータ項目の更新情報

setTaxClass5

public void setTaxClass5(String taxClass5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass5 - 関連ユーザデータ項目の更新情報

setTaxClass6

public void setTaxClass6(String taxClass6)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass6 - 関連ユーザデータ項目の更新情報

setTaxClass7

public void setTaxClass7(String taxClass7)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass7 - 関連ユーザデータ項目の更新情報

setTaxClass8

public void setTaxClass8(String taxClass8)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass8 - 関連ユーザデータ項目の更新情報

setTaxClass9

public void setTaxClass9(String taxClass9)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass9 - 関連ユーザデータ項目の更新情報

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matPrGrp - 関連ユーザデータ項目の更新情報

setValType

public void setValType(String valType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valType - 関連ユーザデータ項目の更新情報

setFixdatQty

public void setFixdatQty(String fixdatQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixdatQty - 関連ユーザデータ項目の更新情報

setBomexplNo

public void setBomexplNo(String bomexplNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
bomexplNo - 関連ユーザデータ項目の更新情報

setResanalkey

public void setResanalkey(String resanalkey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
resanalkey - 関連ユーザデータ項目の更新情報

setReqmtsTyp

public void setReqmtsTyp(String reqmtsTyp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqmtsTyp - 関連ユーザデータ項目の更新情報

setNoGrPost

public void setNoGrPost(String noGrPost)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
noGrPost - 関連ユーザデータ項目の更新情報

setBusTranst

public void setBusTranst(String busTranst)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
busTranst - 関連ユーザデータ項目の更新情報

setOverhdKey

public void setOverhdKey(String overhdKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
overhdKey - 関連ユーザデータ項目の更新情報

setCstgSheet

public void setCstgSheet(String cstgSheet)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstgSheet - 関連ユーザデータ項目の更新情報

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matfrgtgrp - 関連ユーザデータ項目の更新情報

setPldlvshdin

public void setPldlvshdin(String pldlvshdin)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pldlvshdin - 関連ユーザデータ項目の更新情報

setSeqNo

public void setSeqNo(String seqNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
seqNo - 関連ユーザデータ項目の更新情報

setBilForm

public void setBilForm(String bilForm)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
bilForm - 関連ユーザデータ項目の更新情報

setDliProfil

public void setDliProfil(String dliProfil)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dliProfil - 関連ユーザデータ項目の更新情報

setRevType

public void setRevType(String revType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
revType - 関連ユーザデータ項目の更新情報

setBegdemPer

public void setBegdemPer(String begdemPer)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
begdemPer - 関連ユーザデータ項目の更新情報

setPrRefMat

public void setPrRefMat(String prRefMat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prRefMat - 関連ユーザデータ項目の更新情報

setRefobjtype

public void setRefobjtype(String refobjtype)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refobjtype - 関連ユーザデータ項目の更新情報

setRefobjkey

public void setRefobjkey(String refobjkey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refobjkey - 関連ユーザデータ項目の更新情報

setReflogsys

public void setReflogsys(String reflogsys)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reflogsys - 関連ユーザデータ項目の更新情報

setOrderProb

public void setOrderProb(String orderProb)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
orderProb - 関連ユーザデータ項目の更新情報

setMaxPlDlv

public void setMaxPlDlv(String maxPlDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxPlDlv - 関連ユーザデータ項目の更新情報

setCfopCode

public void setCfopCode(String cfopCode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cfopCode - 関連ユーザデータ項目の更新情報

setTaxlawicms

public void setTaxlawicms(String taxlawicms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxlawicms - 関連ユーザデータ項目の更新情報

setTaxlawipi

public void setTaxlawipi(String taxlawipi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxlawipi - 関連ユーザデータ項目の更新情報

setSdTaxcode

public void setSdTaxcode(String sdTaxcode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sdTaxcode - 関連ユーザデータ項目の更新情報

setAssortMod

public void setAssortMod(String assortMod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
assortMod - 関連ユーザデータ項目の更新情報

setCompQuant

public void setCompQuant(String compQuant)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
compQuant - 関連ユーザデータ項目の更新情報

setTargetVal

public void setTargetVal(String targetVal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetVal - 関連ユーザデータ項目の更新情報

setProfitCtr

public void setProfitCtr(String profitCtr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
profitCtr - 関連ユーザデータ項目の更新情報

setOrderid

public void setOrderid(String orderid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
orderid - 関連ユーザデータ項目の更新情報

setWbsElem

public void setWbsElem(String wbsElem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
wbsElem - 関連ユーザデータ項目の更新情報

setDeprecPer

public void setDeprecPer(String deprecPer)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
deprecPer - 関連ユーザデータ項目の更新情報

setRefDoc

public void setRefDoc(String refDoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDoc - 関連ユーザデータ項目の更新情報

setRefDocIt

public void setRefDocIt(String refDocIt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocIt - 関連ユーザデータ項目の更新情報

setRefDocCa

public void setRefDocCa(String refDocCa)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocCa - 関連ユーザデータ項目の更新情報

setCustMat35

public void setCustMat35(String custMat35)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custMat35 - 関連ユーザデータ項目の更新情報

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchRateFiV - 関連ユーザデータ項目の更新情報

setExchgRateV

public void setExchgRateV(String exchgRateV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRateV - 関連ユーザデータ項目の更新情報

setItemguidAtp

public void setItemguidAtp(String itemguidAtp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itemguidAtp - 関連ユーザデータ項目の更新情報

setValContr

public void setValContr(String valContr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valContr - 関連ユーザデータ項目の更新情報

setValConI

public void setValConI(String valConI)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valConI - 関連ユーザデータ項目の更新情報

setConfigId

public void setConfigId(String configId)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
configId - 関連ユーザデータ項目の更新情報

setInstId

public void setInstId(String instId)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
instId - 関連ユーザデータ項目の更新情報

setMatExt

public void setMatExt(String matExt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matExt - 関連ユーザデータ項目の更新情報

setMatGuid

public void setMatGuid(String matGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matGuid - 関連ユーザデータ項目の更新情報

setMatVers

public void setMatVers(String matVers)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matVers - 関連ユーザデータ項目の更新情報

setPMatExt

public void setPMatExt(String pMatExt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatExt - 関連ユーザデータ項目の更新情報

setPMatGuid

public void setPMatGuid(String pMatGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatGuid - 関連ユーザデータ項目の更新情報

setPMatVers

public void setPMatVers(String pMatVers)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatVers - 関連ユーザデータ項目の更新情報

setFuncArea

public void setFuncArea(String funcArea)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
funcArea - 関連ユーザデータ項目の更新情報

setAlternBom

public void setAlternBom(String alternBom)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
alternBom - 関連ユーザデータ項目の更新情報

setFkkConacct

public void setFkkConacct(String fkkConacct)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fkkConacct - 関連ユーザデータ項目の更新情報

setEanUpc

public void setEanUpc(String eanUpc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
eanUpc - 関連ユーザデータ項目の更新情報

setProdcat

public void setProdcat(String prodcat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prodcat - 関連ユーザデータ項目の更新情報

setShipType

public void setShipType(String shipType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipType - 関連ユーザデータ項目の更新情報

setSProcInd

public void setSProcInd(String sProcInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sProcInd - 関連ユーザデータ項目の更新情報

setBillRel

public void setBillRel(String billRel)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billRel - 関連ユーザデータ項目の更新情報

setVwUepos

public void setVwUepos(String vwUepos)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
vwUepos - 関連ユーザデータ項目の更新情報

setCampaign

public void setCampaign(String campaign)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
campaign - 関連ユーザデータ項目の更新情報

setDlvschduse

public void setDlvschduse(String dlvschduse)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvschduse - 関連ユーザデータ項目の更新情報

setSelection

public void setSelection(String selection)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
selection - 関連ユーザデータ項目の更新情報

setMatEntrd

public void setMatEntrd(String matEntrd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matEntrd - 関連ユーザデータ項目の更新情報

setLogSystemOwn

public void setLogSystemOwn(String logSystemOwn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
logSystemOwn - 関連ユーザデータ項目の更新情報

setItmTypeUsage

public void setItmTypeUsage(String itmTypeUsage)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itmTypeUsage - 関連ユーザデータ項目の更新情報

setMatEntrdExternal

public void setMatEntrdExternal(String matEntrdExternal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matEntrdExternal - 関連ユーザデータ項目の更新情報

setMatEntrdGuid

public void setMatEntrdGuid(String matEntrdGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matEntrdGuid - 関連ユーザデータ項目の更新情報

setMatEntrdVersion

public void setMatEntrdVersion(String matEntrdVersion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matEntrdVersion - 関連ユーザデータ項目の更新情報

setLocTaxcat

public void setLocTaxcat(String locTaxcat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
locTaxcat - 関連ユーザデータ項目の更新情報

setLocZerovat

public void setLocZerovat(String locZerovat)
関連ユーザデータ項目の更新情報設定します。

パラメータ:
locZerovat - 関連ユーザデータ項目の更新情報

setLocActcode

public void setLocActcode(String locActcode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
locActcode - 関連ユーザデータ項目の更新情報

setLocDisttype

public void setLocDisttype(String locDisttype)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
locDisttype - 関連ユーザデータ項目の更新情報

setLocTxrelclas

public void setLocTxrelclas(String locTxrelclas)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
locTxrelclas - 関連ユーザデータ項目の更新情報

setCalcMotive

public void setCalcMotive(String calcMotive)
関連ユーザデータ項目の更新情報を設定します｡

パラメータ:
calcMotive - 関連ユーザデータ項目の更新情報

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Keys (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Keys

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys
すべての実装インタフェース:
Serializable
public class Keys
extends Object
implements Serializable

参照キーの出力テーブル情報クラス
機能は以下の通り

  • 参照キーの出力テーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Keys()
参照キーの出力テーブル情報を作成します。
Keys(int index)
参照キーの出力テーブル情報を作成します。
メソッドの概要
String | getAbart() 承認タイプを取得します。
String | getAbrli() 内部納入日程番号を取得します。
String | getAddress() 住所を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getConditemno() 条件明細番号を取得します。
String | getCondNo() 伝票条件番号を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondType() 条件タイプを取得します。
String | getDocNumber() 販売管理伝票番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobject() オブジェクト名を取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtyp() オブジェクトタイプを取得します。
String | getSchedLin() 納入日程行を取得します。
String | getStatus() 単一文字フラグを取得します。
String | getTindex() 数値項目: 長さ 6を取得します。
void | setAbart(String abart) 承認タイプを設定します。
void | setAbrli(String abrli) 内部納入日程番号を設定します。
void | setAddress(String address) 住所を設定します。
void | setCondCount(String condCount) 条件カウンタを設定します。
void | setConditemno(String conditemno) 条件明細番号を設定します。
void | setCondNo(String condNo) 伝票条件番号を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setDocNumber(String docNumber) 販売管理伝票番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobject(String refobject) オブジェクト名を設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtyp(String refobjtyp) オブジェクトタイプを設定します。
void | setSchedLin(String schedLin) 納入日程行を設定します。
void | setStatus(String status) 単一文字フラグを設定します。
void | setTindex(String tindex) 数値項目: 長さ 6を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Keys

public Keys()
参照キーの出力テーブル情報を作成します。

Keys

public Keys(int index)
参照キーの出力テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefobjtyp

public String getRefobjtyp()
オブジェクトタイプを取得します。

戻り値:
refobjtyp オブジェクトタイプ

getRefobject

public String getRefobject()
オブジェクト名を取得します。

戻り値:
refobject オブジェクト名

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getDocNumber

public String getDocNumber()
販売管理伝票番号を取得します。

戻り値:
docNumber 販売管理伝票番号

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLin

public String getSchedLin()
納入日程行を取得します。

戻り値:
schedLin 納入日程行

getCondNo

public String getCondNo()
伝票条件番号を取得します。

戻り値:
condNo 伝票条件番号

getConditemno

public String getConditemno()
条件明細番号を取得します。

戻り値:
conditemno 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
condCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getStatus

public String getStatus()
単一文字フラグを取得します。

戻り値:
status 単一文字フラグ

getTindex

public String getTindex()
数値項目: 長さ 6を取得します。

戻り値:
tindex 数値項目: 長さ 6

getAddress

public String getAddress()
住所を取得します。

戻り値:
address 住所

getAbrli

public String getAbrli()
内部納入日程番号を取得します。

戻り値:
abrli 内部納入日程番号

getAbart

public String getAbart()
承認タイプを取得します。

戻り値:
abart 承認タイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefobjtyp

public void setRefobjtyp(String refobjtyp)
オブジェクトタイプを設定します。

パラメータ:
refobjtyp - オブジェクトタイプ

setRefobject

public void setRefobject(String refobject)
オブジェクト名を設定します。

パラメータ:
refobject - オブジェクト名

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setDocNumber

public void setDocNumber(String docNumber)
販売管理伝票番号を設定します。

パラメータ:
docNumber - 販売管理伝票番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLin

public void setSchedLin(String schedLin)
納入日程行を設定します。

パラメータ:
schedLin - 納入日程行

setCondNo

public void setCondNo(String condNo)
伝票条件番号を設定します。

パラメータ:
condNo - 伝票条件番号

setConditemno

public void setConditemno(String conditemno)
条件明細番号を設定します。

パラメータ:
conditemno - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件カウンタを設定します。

パラメータ:
condCount - 条件カウンタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setStatus

public void setStatus(String status)
単一文字フラグを設定します。

パラメータ:
status - 単一文字フラグ

setTindex

public void setTindex(String tindex)
数値項目: 長さ 6を設定します。

パラメータ:
tindex - 数値項目: 長さ 6

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所

setAbrli

public void setAbrli(String abrli)
内部納入日程番号を設定します。

パラメータ:
abrli - 内部納入日程番号

setAbart

public void setAbart(String abart)
承認タイプを設定します。

パラメータ:
abart - 承認タイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogicSwitch (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス LogicSwitch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch
すべての実装インタフェース:
Serializable
public class LogicSwitch
extends Object
implements Serializable

内部制御パラメータ情報クラス
機能は以下の通り

  • 内部制御パラメータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
LogicSwitch()
内部制御パラメータ情報を作成します。
メソッドの概要
String | getAtpWrkmod() ATP セッション: 結果取得/新規決定 APO-ATPを取得します。
String | getCondHandl() 選択: 条件行処理 (SD 伝票変更)を取得します。
String | getNostructure() チェックボックスを取得します。
String | getPricing() 価格設定タイプを取得します。
String | getScheduling() 単一文字フラグを取得します。
void | setAtpWrkmod(String atpWrkmod) ATP セッション: 結果取得/新規決定 APO-ATPを設定します。
void | setCondHandl(String condHandl) 選択: 条件行処理 (SD 伝票変更)を設定します。
void | setNostructure(String nostructure) チェックボックスを設定します。
void | setPricing(String pricing) 価格設定タイプを設定します。
void | setScheduling(String scheduling) 単一文字フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogicSwitch

public LogicSwitch()
内部制御パラメータ情報を作成します。

メソッドの詳細

getPricing

public String getPricing()
価格設定タイプを取得します。

戻り値:
pricing 価格設定タイプ

getAtpWrkmod

public String getAtpWrkmod()
ATP セッション: 結果取得/新規決定 APO-ATPを取得します。

戻り値:
atpWrkmod ATP セッション: 結果取得/新規決定 APO-ATP

getScheduling

public String getScheduling()
単一文字フラグを取得します。

戻り値:
scheduling 単一文字フラグ

getNostructure

public String getNostructure()
チェックボックスを取得します。

戻り値:
nostructure チェックボックス

getCondHandl

public String getCondHandl()
選択: 条件行処理 (SD 伝票変更)を取得します。

戻り値:
condHandl 選択: 条件行処理 (SD 伝票変更)

setPricing

public void setPricing(String pricing)
価格設定タイプを設定します。

パラメータ:
pricing - 価格設定タイプ

setAtpWrkmod

public void setAtpWrkmod(String atpWrkmod)
ATP セッション: 結果取得/新規決定 APO-ATPを設定します。

パラメータ:
atpWrkmod - ATP セッション: 結果取得/新規決定 APO-ATP

setScheduling

public void setScheduling(String scheduling)
単一文字フラグを設定します。

パラメータ:
scheduling - 単一文字フラグ

setNostructure

public void setNostructure(String nostructure)
チェックボックスを設定します。

パラメータ:
nostructure - チェックボックス

setCondHandl

public void setCondHandl(String condHandl)
選択: 条件行処理 (SD 伝票変更)を設定します。

パラメータ:
condHandl - 選択: 条件行処理 (SD 伝票変更)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialEvg (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス MaterialEvg

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg
すべての実装インタフェース:
Serializable
public class MaterialEvg
extends Object
implements Serializable

品目コード(長)情報クラス
機能は以下の通り

  • 品目コード(長)を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialEvg()
品目コード(長)を作成します。
メソッドの概要
String | getMaterialExt() 外部品目コードを取得します。
String | getMaterialGuid() 品目コード(外部 GUID)を取得します。
String | getMaterialVers() 品目バージョン番号を取得します。
void | setMaterialExt(String materialExt) 外部品目コードを設定します。
void | setMaterialGuid(String materialGuid) 品目コード(外部 GUID)を設定します。
void | setMaterialVers(String materialVers) 品目バージョン番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialEvg

public MaterialEvg()
品目コード(長)を作成します。

メソッドの詳細

getMaterialExt

public String getMaterialExt()
外部品目コードを取得します。

戻り値:
materialExt 外部品目コード

getMaterialVers

public String getMaterialVers()
品目バージョン番号を取得します。

戻り値:
materialVers 品目バージョン番号

getMaterialGuid

public String getMaterialGuid()
品目コード(外部 GUID)を取得します。

戻り値:
materialGuid 品目コード(外部 GUID)

setMaterialExt

public void setMaterialExt(String materialExt)
外部品目コードを設定します。

パラメータ:
materialExt - 外部品目コード

setMaterialVers

public void setMaterialVers(String materialVers)
品目バージョン番号を設定します。

パラメータ:
materialVers - 品目バージョン番号

setMaterialGuid

public void setMaterialGuid(String materialGuid)
品目コード(外部 GUID)を設定します。

パラメータ:
materialGuid - 品目コード(外部 GUID)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.common.model (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス
BillingDocumentDetail
BillingDocumentDetailList
CfgsBlob
CfgsInst
CfgsPartOf
CfgsRef
CfgsRefInst
CfgsValue
CfgsVk
ConditionsIn
ConditionsInX
ExtensionIn
HeaderIn
HeaderInX
ItemsIn
ItemsInX
Keys
LogicSwitch
MaterialEvg
ParamBillingDocumentDetailList
ParamCfgsBlob
ParamCfgsInst
ParamCfgsPartOf
ParamCfgsRef
ParamCfgsRefInst
ParamCfgsValue
ParamCfgsVk
ParamConditionsIn
ParamConditionsInX
ParamExtensionIn
ParamHeaderIn
ParamHeaderInX
ParamItemsIn
ParamItemsInX
ParamKeys
ParamLogicSwitch
ParamMaterialEvg
ParamPartnerAddresses
ParamPartners
ParamSchedulesIn
ParamSchedulesInX
ParamSender
ParamSuccess
ParamText
PartnerAddresses
Partners
SchedulesIn
SchedulesInX
Sender
Success
Text


jp.co.intra_mart.foundation.sap.module.sales.common.model (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model

クラスの概要
BillingDocumentDetail | 後続請求伝票のテーブル情報クラス 機能は以下の通り 後続請求伝票のテーブル情報を保持します。
BillingDocumentDetailList | 後続請求伝票のテーブル情報クラス 機能は以下の通り 後続請求伝票のテーブル情報を保持します。
CfgsBlob | 選定: BLOB 内部データ (SCE)情報クラス 機能は以下の通り 選定: BLOB 内部データ (SCE)情報を保持します。
CfgsInst | 選定: インスタンス情報クラス 機能は以下の通り 選定: インスタンス情報を保持します。
CfgsPartOf | 選定: 部分設定情報クラス 機能は以下の通り 選定: 部分設定情報を保持します。
CfgsRef | 選定: 参照データ情報クラス 機能は以下の通り 選定: 参照データ情報を保持します。
CfgsRefInst | 選定: 参照明細/インスタンス情報クラス 機能は以下の通り 選定: 参照明細/インスタンス情報を保持します。
CfgsValue | 選定: 特性値情報クラス 機能は以下の通り 選定: 特性値情報を保持します。
CfgsVk | 選定: バリアント条件キー情報クラス 機能は以下の通り 選定: バリアント条件キー情報を保持します。
ConditionsIn | 条件情報クラス 機能は以下の通り 条件情報を保持します。
ConditionsInX | 受注における条件更新の通信項目情報クラス 機能は以下の通り 受注における条件更新の通信項目情報を保持します。
ExtensionIn | VBAK、VBAP、VBEP のカスタマ拡張情報クラス 機能は以下の通り VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。
HeaderIn | 販売伝票ヘッダデータ情報クラス 機能は以下の通り 販売伝票ヘッダデータ情報を保持します。
HeaderInX | ヘッダデータチェックボックス情報クラス 機能は以下の通り ヘッダデータチェックボックス情報を保持します。
ItemsIn | 明細データ情報クラス 機能は以下の通り 明細データ情報を保持します。
ItemsInX | 明細データチェックボックス情報クラス 機能は以下の通り 明細データチェックボックス情報を保持します。
Keys | 参照キーの出力テーブル情報クラス 機能は以下の通り 参照キーの出力テーブル情報を保持します。
LogicSwitch | 内部制御パラメータ情報クラス 機能は以下の通り 内部制御パラメータ情報を保持します。
MaterialEvg | 品目コード(長)情報クラス 機能は以下の通り 品目コード(長)を保持します。
ParamBillingDocumentDetailList | 後続請求伝票のテーブルパラメータ設定クラス 機能は以下の通り 後続請求伝票のテーブルのパラメータを設定します。
ParamCfgsBlob | 選定: BLOB 内部データ (SCE)パラメータ設定クラス 機能は以下の通り 選定: BLOB 内部データ (SCE)のパラメータを設定します。
ParamCfgsInst | 選定: インスタンスパラメータ設定クラス 機能は以下の通り 選定: インスタンスのパラメータを設定します。
ParamCfgsPartOf | 選定: 部分設定パラメータ設定クラス 機能は以下の通り 選定: 部分設定のパラメータを設定します。
ParamCfgsRef | 選定: 参照データパラメータ設定クラス 機能は以下の通り 選定: 参照データのパラメータを設定します。
ParamCfgsRefInst | 選定: 参照明細/インスタンスパラメータ設定クラス 機能は以下の通り 選定: 参照明細/インスタンスのパラメータを設定します。
ParamCfgsValue | 選定: 特性値パラメータ設定クラス 機能は以下の通り 選定: 特性値のパラメータを設定します。
ParamCfgsVk | 選定: バリアント条件キーパラメータ設定クラス 機能は以下の通り 選定: バリアント条件キーのパラメータを設定します。
ParamConditionsIn | 条件パラメータ設定クラス 機能は以下の通り 条件のパラメータを設定します。
ParamConditionsInX | 受注における条件更新の通信項目パラメータ設定クラス 機能は以下の通り 受注における条件更新の通信項目のパラメータを設定します。
ParamExtensionIn | VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス 機能は以下の通り VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。
ParamHeaderIn | 販売伝票ヘッダデータセグメントパラメータ設定クラス 機能は以下の通り 販売伝票ヘッダデータのパラメータを設定します。
ParamHeaderInX | ヘッダデータチェックボックスパラメータ設定クラス 機能は以下の通り ヘッダデータチェックボックスのパラメータを設定します。
ParamItemsIn | 明細データパラメータ設定クラス 機能は以下の通り 明細データのパラメータを設定します。
ParamItemsInX | 明細データチェックボックス のパラメータ設定クラス 機能は以下の通り 明細データチェックボックスのパラメータを設定します。
ParamKeys | 参照キーパラメータ設定クラス 機能は以下の通り 参照キーのパラメータを設定します。
ParamLogicSwitch | 内部制御パラメータパラメータ設定クラス 機能は以下の通り 内部制御パラメータのパラメータを設定します。
ParamMaterialEvg | 品目コード(長)パラメータ設定クラス 機能は以下の通り 品目コード(長)のパラメータを設定します。
ParamPartnerAddresses | アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス 機能は以下の通り アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。
ParamPartners | 伝票取引先パラメータ設定クラス 機能は以下の通り 伝票取引先のパラメータを設定します。
ParamSchedulesIn | 納入日程行パラメータ設定クラス 機能は以下の通り 納入日程行のパラメータを設定します。
ParamSchedulesInX | 納入日程行チェックボックスパラメータ設定クラス 機能は以下の通り 納入日程行チェックボックスのパラメータを設定します。
ParamSender | 論理システム - 送信者セグメントパラメータ設定クラス 機能は以下の通り 論理システム - 送信者のパラメータを設定します。
ParamSuccess | 後続請求伝票の明細テーブルパラメータ設定クラス 機能は以下の通り 後続請求伝票の明細テーブルのパラメータを設定します。
ParamText | テキストパラメータ設定クラス 機能は以下の通り テキストのパラメータを設定します。
PartnerAddresses | アドレス (組織/会社) 用 BAPI 参照構造情報クラス 機能は以下の通り アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。
Partners | 伝票取引先情報クラス 機能は以下の通り 伝票取引先情報を保持します。
SchedulesIn | 納入日程行情報クラス 機能は以下の通り 納入日程行情報を保持します。
SchedulesInX | 納入日程行チェックボックス情報クラス 機能は以下の通り 納入日程行チェックボックス情報を保持します。
Sender | 論理システム - 送信者情報クラス 機能は以下の通り 論理システム - 送信者情報を保持します。
Success | 正常に処理された明細のテーブル情報クラス 機能は以下の通り 正常に処理された明細のテーブル情報を保持します。
Text | テキスト情報クラス 機能は以下の通り テキスト情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.common.model クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.common.model により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
MaterialEvg
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
MaterialEvg
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBillingDocumentDetailList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamBillingDocumentDetailList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList
すべての実装インタフェース:
Serializable
public final class ParamBillingDocumentDetailList
extends Object
implements Serializable

後続請求伝票のテーブルパラメータ設定クラス
機能は以下の通り

    後続請求伝票のテーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List billingDocumentDetailListList) table(Export)情報から請求伝票詳細の値をセットします。
static void | setImportParam(BapiController bapiController, List billingDocumentDetailListList) 請求伝票詳細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List billingDocumentDetailListList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
請求伝票詳細に値をセットします。

パラメータ:
bapiController - BapiController
billingDocumentDetailListList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List billingDocumentDetailListList)
                           throws SAPGeneralSystemException
table(Export)情報から請求伝票詳細の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
billingDocumentDetailListList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsBlob (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsBlob

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob
すべての実装インタフェース:
Serializable
public final class ParamCfgsBlob
extends Object
implements Serializable

選定: BLOB 内部データ (SCE)パラメータ設定クラス
機能は以下の通り

  • 選定: BLOB 内部データ (SCE)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsBlobList, String paramType) table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsBlobList, String paramType) 選定: BLOB 内部データ (SCE)に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsBlobList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: BLOB 内部データ (SCE)に値をセットします。

パラメータ:
bapiController - BapiController
cfgsBlobList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsBlobList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsBlobList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsInst (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst
すべての実装インタフェース:
Serializable
public final class ParamCfgsInst
extends Object
implements Serializable

選定: インスタンスパラメータ設定クラス
機能は以下の通り

  • 選定: インスタンスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsInstList, String paramType) table(Export)情報から選定: インスタンスの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsInstList, String paramType) 選定: インスタンスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsInstList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: インスタンスに値をセットします。

パラメータ:
bapiController - BapiController
cfgsInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsInstList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: インスタンスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsPartOf (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsPartOf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf
すべての実装インタフェース:
Serializable
public final class ParamCfgsPartOf
extends Object
implements Serializable

選定: 部分設定パラメータ設定クラス
機能は以下の通り

  • 選定: 部分設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsPartOfList, String paramType) table(Export)情報から選定: 部分設定の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsPartOfList, String paramType) 選定: 部分設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsPartOfList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 部分設定に値をセットします。

パラメータ:
bapiController - BapiController
cfgsPartOfList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsPartOfList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 部分設定の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsPartOfList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsRef (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsRef

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef
すべての実装インタフェース:
Serializable
public final class ParamCfgsRef
extends Object
implements Serializable

選定: 参照データパラメータ設定クラス
機能は以下の通り

  • 選定: 参照データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsRefList, String paramType) table(Export)情報から選定: 参照データの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsRefList, String paramType) 選定: 参照データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsRefList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 参照データに値をセットします。

パラメータ:
bapiController - BapiController
cfgsRefList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsRefList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 参照データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsRefList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsRefInst (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsRefInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst
すべての実装インタフェース:
Serializable
public final class ParamCfgsRefInst
extends Object
implements Serializable

選定: 参照明細/インスタンスパラメータ設定クラス
機能は以下の通り

  • 選定: 参照明細/インスタンスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsRefInstList, String paramType) table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsRefInstList, String paramType) 選定: 参照明細/インスタンスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsRefInstList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 参照明細/インスタンスに値をセットします。

パラメータ:
bapiController - BapiController
cfgsRefInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsRefInstList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 参照明細/インスタンスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsRefInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsValue (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsValue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue
すべての実装インタフェース:
Serializable
public final class ParamCfgsValue
extends Object
implements Serializable

選定: 特性値パラメータ設定クラス
機能は以下の通り

  • 選定: 特性値のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsValueList, String paramType) table(Export)情報から選定: 特性値の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsValueList, String paramType) 選定: 特性値に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsValueList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 特性値に値をセットします。

パラメータ:
bapiController - BapiController
cfgsValueList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsValueList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 特性値の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsValueList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsVk (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsVk

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk
すべての実装インタフェース:
Serializable
public final class ParamCfgsVk
extends Object
implements Serializable

選定: バリアント条件キーパラメータ設定クラス
機能は以下の通り

  • 選定: バリアント条件キーのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsVkList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsVkList, String paramType) 選定: バリアント条件キーに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsVkList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: バリアント条件キーに値をセットします。

パラメータ:
bapiController - BapiController
cfgsVkList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsVkList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsVkList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionsIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamConditionsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn
すべての実装インタフェース:
Serializable
public final class ParamConditionsIn
extends Object
implements Serializable

条件パラメータ設定クラス
機能は以下の通り

  • 条件のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionsInList, String paramType) table(Export)情報から条件の値をセットします。
static void | setImportParam(BapiController bapiController, List conditionsInList, String paramType) 条件に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionsInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件に値をセットします。

パラメータ:
bapiController - BapiController
conditionsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionsInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から条件の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionsInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamConditionsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX
すべての実装インタフェース:
Serializable
public final class ParamConditionsInX
extends Object
implements Serializable

受注における条件更新の通信項目パラメータ設定クラス
機能は以下の通り

  • 受注における条件更新の通信項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionsInXList, String paramType) table(Export)情報から受注における条件更新の通信項目の値をセットします。
static void | setImportParam(BapiController bapiController, List conditionsInXList, String paramType) 受注における条件更新の通信項目に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
受注における条件更新の通信項目に値をセットします。

パラメータ:
bapiController - BapiController
conditionsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から受注における条件更新の通信項目の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn
すべての実装インタフェース:
Serializable
public final class ParamExtensionIn
extends Object
implements Serializable

VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス
機能は以下の通り

  • VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
static void | setImportParam(BapiController bapiController, List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException
table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
extensionInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamHeaderIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn
すべての実装インタフェース:
Serializable
public final class ParamHeaderIn
extends Object
implements Serializable

販売伝票ヘッダデータセグメントパラメータ設定クラス
機能は以下の通り

  • 販売伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType)
販売伝票ヘッダデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  HeaderIn headerIn,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
販売伝票ヘッダデータに値をセットします。

パラメータ:
bapiController - BapiController
headerIn - HeaderIn
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamHeaderInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX
すべての実装インタフェース:
Serializable
public final class ParamHeaderInX
extends Object
implements Serializable

ヘッダデータチェックボックスパラメータ設定クラス
機能は以下の通り

  • ヘッダデータチェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType)
ヘッダデータチェックボックスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  HeaderInX headerInX,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ヘッダデータチェックボックスに値をセットします。

パラメータ:
bapiController - BapiController
headerInX - HeaderInX
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemsIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamItemsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn
すべての実装インタフェース:
Serializable
public final class ParamItemsIn
extends Object
implements Serializable

明細データパラメータ設定クラス
機能は以下の通り

  • 明細データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List itemsInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List itemsInList, String paramType) 明細データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemsInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細データに値をセットします。

パラメータ:
bapiController - BapiController
itemsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List itemsInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
itemsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemsInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamItemsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX
すべての実装インタフェース:
Serializable
public final class ParamItemsInX
extends Object
implements Serializable

明細データチェックボックス のパラメータ設定クラス
機能は以下の通り

  • 明細データチェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List itemsInXList, String paramType) table(Export)情報から明細データチェックボックスの値をセットします。
static void | setImportParam(BapiController bapiController, List itemsInXList, String paramType) 明細データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細データに値をセットします。

パラメータ:
bapiController - BapiController
itemsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List itemsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データチェックボックスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
itemsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamKeys (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamKeys

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys
すべての実装インタフェース:
Serializable
public final class ParamKeys
extends Object
implements Serializable

参照キーパラメータ設定クラス
機能は以下の通り

  • 参照キーのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List keysList, String paramType) table(Export)情報から参照キーの出力テーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List keysList, String paramType) 参照キーの出力テーブルに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List keysList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
参照キーの出力テーブルに値をセットします。

パラメータ:
bapiController - BapiController
keysList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List keysList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から参照キーの出力テーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
keysList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamLogicSwitch (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamLogicSwitch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch
すべての実装インタフェース:
Serializable
public final class ParamLogicSwitch
extends Object
implements Serializable

内部制御パラメータパラメータ設定クラス
機能は以下の通り

  • 内部制御パラメータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, LogicSwitch logicSwitch)
内部制御パラメータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  LogicSwitch logicSwitch)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
内部制御パラメータに値をセットします。

パラメータ:
bapiController - BapiController
logicSwitch - LogicSwitch
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialEvg (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamMaterialEvg

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg
すべての実装インタフェース:
Serializable
public final class ParamMaterialEvg
extends Object
implements Serializable

品目コード(長)パラメータ設定クラス
機能は以下の通り

  • 品目コード(長)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, MaterialEvg materialEvg)
品目コード(長)をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  MaterialEvg materialEvg)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
品目コード(長)をセットします。

パラメータ:
bapiController - BapiController
materialEvg - MaterialEvg
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartnerAddresses (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamPartnerAddresses

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses
すべての実装インタフェース:
Serializable
public final class ParamPartnerAddresses
extends Object
implements Serializable

アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス
機能は以下の通り

  • アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List partnerAddressesList) table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
static void | setImportParam(BapiController bapiController, List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnerAddressesList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。

パラメータ:
bapiController - BapiController
partnerAddressesList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List partnerAddressesList)
                           throws SAPGeneralSystemException
table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
partnerAddressesList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartners (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamPartners

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners
すべての実装インタフェース:
Serializable
public final class ParamPartners
extends Object
implements Serializable

伝票取引先パラメータ設定クラス
機能は以下の通り

  • 伝票取引先のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List partnersList, String paramType) table(Export)情報から伝票取引先の値をセットします。
static void | setImportParam(BapiController bapiController, List partnersList, String paramType) 伝票取引先に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnersList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票取引先に値をセットします。

パラメータ:
bapiController - BapiController
partnersList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List partnersList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から伝票取引先の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
partnersList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSchedulesIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSchedulesIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn
すべての実装インタフェース:
Serializable
public final class ParamSchedulesIn
extends Object
implements Serializable

納入日程行パラメータ設定クラス
機能は以下の通り

  • 納入日程行のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List schedulesInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List schedulesInList, String paramType) 納入日程行に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List schedulesInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程行に値をセットします。

パラメータ:
bapiController - BapiController
schedulesInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List schedulesInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
schedulesInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSchedulesInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSchedulesInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX
すべての実装インタフェース:
Serializable
public final class ParamSchedulesInX
extends Object
implements Serializable

納入日程行チェックボックスパラメータ設定クラス
機能は以下の通り

  • 納入日程行チェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List schedulesInXList, String paramType) table(Export)情報から納入日程行チェックボックスの値をセットします。
static void | setImportParam(BapiController bapiController, List schedulesInXList, String paramType) 納入日程行チェックボックスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List schedulesInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程行チェックボックスに値をセットします。

パラメータ:
bapiController - BapiController
schedulesInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List schedulesInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から納入日程行チェックボックスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
schedulesInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSender (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender
すべての実装インタフェース:
Serializable
public final class ParamSender
extends Object
implements Serializable

論理システム - 送信者セグメントパラメータ設定クラス
機能は以下の通り

  • 論理システム - 送信者のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, Sender sender)
論理システム - 送信者に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  Sender sender)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
論理システム - 送信者に値をセットします。

パラメータ:
bapiController - BapiController
sender - Sender
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSuccess (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSuccess

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess
すべての実装インタフェース:
Serializable
public final class ParamSuccess
extends Object
implements Serializable

後続請求伝票の明細テーブルパラメータ設定クラス
機能は以下の通り

  • 後続請求伝票の明細テーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List successList) table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List successList) 後続請求伝票の明細テーブルに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List successList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
後続請求伝票の明細テーブルに値をセットします。

パラメータ:
bapiController - BapiController
successList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List successList)
                           throws SAPGeneralSystemException
table(Export)情報から後続請求伝票の明細テーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
successList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamText (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText
すべての実装インタフェース:
Serializable
public final class ParamText
extends Object
implements Serializable

テキストパラメータ設定クラス
機能は以下の通り

  • テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List textList, String paramType) table(Export)情報からテキストの値をセットします。
static void | setImportParam(BapiController bapiController, List textList, String paramType) テキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List textList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
テキストに値をセットします。

パラメータ:
bapiController - BapiController
textList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List textList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報からテキストの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
textList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PartnerAddresses (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス PartnerAddresses

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses
すべての実装インタフェース:
Serializable
public class PartnerAddresses
extends Object
implements Serializable

アドレス (組織/会社) 用 BAPI 参照構造情報クラス
機能は以下の通り

  • アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PartnerAddresses()
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
PartnerAddresses(int index)
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCity() 市区町村を取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getDistrict() 所在地を取得します。
String | getDontUseP() 私書箱住所配達不可フラグを取得します。
String | getDontUseS() 地名住所配達不可フラグを取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getFormofaddr() 敬称テキストを取得します。
String | getHomeCity() 市区町村 (郵便用市区町村と異なる場合)を取得します。
String | getHomecityno() 別の市区町村 (市区町村/地名ファイル)を取得します。
String | getHomepage() URI 例: ホームページ、FTP アドレスを取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getHouseNo3() 番地範囲を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguCr() アドレスレコード登録オリジナル言語を取得します。
String | getLangucriso() ISO 639 準拠の言語を取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getLocation() 地名 5を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getName3() 名称 3を取得します。
String | getName4() 名称 4を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPcode1Ext() 市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。
String | getPcode2Ext() 私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。
String | getPcode3Ext() 主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。
String | getPoBox() 私書箱を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoboxCtry() 私書箱の国指定を取得します。
String | getPoBoxReg() 私書箱の地域 (国、都道府県、地域、...)を取得します。
String | getPoCtryiso() ISO 国コードを取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getPoWONo() フラグ: 郵便私書箱 (番号なし)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreet() 地名を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String addrNo) アドレス番号を設定します。
void | setAdrNotes(String adrNotes) 住所注記を設定します。
void | setBuilding(String building) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String buildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String chckstatus) 市区町村ファイルテストステータスを設定します。
void | setCity(String city) 市区町村を設定します。
void | setCityNo(String cityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String commType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String cOName) 気付を設定します。
void | setCountry(String country) 国コードを設定します。
void | setCountryiso(String countryiso) ISO 国コードを設定します。
void | setDelivDis(String delivDis) 郵便配達地域を設定します。
void | setDistrctNo(String distrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setDontUseP(String dontUseP) 私書箱住所配達不可フラグを設定します。
void | setDontUseS(String dontUseS) 地名住所配達不可フラグを設定します。
void | setEMail(String eMail) 電子メールアドレスを設定します。
void | setFaxExtens(String faxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String faxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String floor) 建物の階を設定します。
void | setFormofaddr(String formofaddr) 敬称テキストを設定します。
void | setHomeCity(String homeCity) 市区町村 (郵便用市区町村と異なる場合)を設定します。
void | setHomecityno(String homecityno) 別の市区町村 (市区町村/地名ファイル)を設定します。
void | setHomepage(String homepage) URI 例: ホームページ、FTP アドレスを設定します。
void | setHouseNo(String houseNo) 番地-号を設定します。
void | setHouseNo2(String houseNo2) 番地補足を設定します。
void | setHouseNo3(String houseNo3) 番地範囲を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguCr(String languCr) アドレスレコード登録オリジナル言語を設定します。
void | setLangucriso(String langucriso) ISO 639 準拠の言語を設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setLocation(String location) 地名 5を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setName3(String name3) 名称 3を設定します。
void | setName4(String name4) 名称 4を設定します。
void | setPboxcitNo(String pboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPcode1Ext(String pcode1Ext) 市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。
void | setPcode2Ext(String pcode2Ext) 私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。
void | setPcode3Ext(String pcode3Ext) 主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。
void | setPoBox(String poBox) 私書箱を設定します。
void | setPoBoxCit(String poBoxCit) 私書箱住所を設定します。
void | setPoboxCtry(String poboxCtry) 私書箱の国指定を設定します。
void | setPoBoxReg(String poBoxReg) 私書箱の地域 (国、都道府県、地域、...)を設定します。
void | setPoCtryiso(String poCtryiso) ISO 国コードを設定します。
void | setPostlCod1(String postlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String postlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String postlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setPoWONo(String poWONo) フラグ: 郵便私書箱 (番号なし)を設定します。
void | setRegiogroup(String regiogroup) 地域構造グループ化を設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setRoomNo(String roomNo) 部屋/アパート番号を設定します。
void | setSort1(String sort1) 検索条件 1を設定します。
void | setSort2(String sort2) 検索条件 2を設定します。
void | setStrAbbr(String strAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreet(String street) 地名を設定します。
void | setStreetLng(String streetLng) 地名を設定します。
void | setStreetNo(String streetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strSuppl3) 地名 4を設定します。
void | setTaxjurcode(String taxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String tel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String tel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String timeZone) アドレスタイムゾーンを設定します。
void | setTitle(String title) タイトル (敬称)を設定します。
void | setTranspzone(String transpzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PartnerAddresses

public PartnerAddresses()
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。

PartnerAddresses

public PartnerAddresses(int index)
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
addrNo アドレス番号

getFormofaddr

public String getFormofaddr()
敬称テキストを取得します。

戻り値:
formofaddr 敬称テキスト

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getName3

public String getName3()
名称 3を取得します。

戻り値:
name3 名称 3

getName4

public String getName4()
名称 4を取得します。

戻り値:
name4 名称 4

getCOName

public String getCOName()
気付を取得します。

戻り値:
cOName 気付

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
cityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
postlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
postlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
postlCod3 会社郵便番号 (大規模なユーザ用)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
poBox 私書箱

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
poBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
delivDis 郵便配達地域

getStreet

public String getStreet()
地名を取得します。

戻り値:
street 地名

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
streetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
strAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
houseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
strSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
strSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
location 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
building 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
floor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
roomNo 部屋/アパート番号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
country 国コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
sort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
sort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
timeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
taxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
adrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
commType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
tel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
tel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
faxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
faxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
streetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
distrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
chckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
pboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
transpzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
houseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
eMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
strSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
title タイトル (敬称)

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
countryiso ISO 国コード

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
buildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
regiogroup 地域構造グループ化

getHomeCity

public String getHomeCity()
市区町村 (郵便用市区町村と異なる場合)を取得します。

戻り値:
homeCity 市区町村 (郵便用市区町村と異なる場合)

getHomecityno

public String getHomecityno()
別の市区町村 (市区町村/地名ファイル)を取得します。

戻り値:
homecityno 別の市区町村 (市区町村/地名ファイル)

getPcode1Ext

public String getPcode1Ext()
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode1Ext 市区町村郵便番号の拡張子 例: 郵便番号 +4+2

getPcode2Ext

public String getPcode2Ext()
私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode2Ext 私書箱郵便番号拡張子 例: 郵便番号 +4+2

getPcode3Ext

public String getPcode3Ext()
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode3Ext 主要得意先郵便番号拡張子 例: 郵便番号 +4+2

getPoWONo

public String getPoWONo()
フラグ: 郵便私書箱 (番号なし)を取得します。

戻り値:
poWONo フラグ: 郵便私書箱 (番号なし)

getPoBoxReg

public String getPoBoxReg()
私書箱の地域 (国、都道府県、地域、...)を取得します。

戻り値:
poBoxReg 私書箱の地域 (国、都道府県、地域、...)

getPoboxCtry

public String getPoboxCtry()
私書箱の国指定を取得します。

戻り値:
poboxCtry 私書箱の国指定

getPoCtryiso

public String getPoCtryiso()
ISO 国コードを取得します。

戻り値:
poCtryiso ISO 国コード

getHomepage

public String getHomepage()
URI 例: ホームページ、FTP アドレスを取得します。

戻り値:
homepage URI 例: ホームページ、FTP アドレス

getDontUseS

public String getDontUseS()
地名住所配達不可フラグを取得します。

戻り値:
dontUseS 地名住所配達不可フラグ

getDontUseP

public String getDontUseP()
私書箱住所配達不可フラグを取得します。

戻り値:
dontUseP 私書箱住所配達不可フラグ

getHouseNo3

public String getHouseNo3()
番地範囲を取得します。

戻り値:
houseNo3 番地範囲

getLanguCr

public String getLanguCr()
アドレスレコード登録オリジナル言語を取得します。

戻り値:
languCr アドレスレコード登録オリジナル言語

getLangucriso

public String getLangucriso()
ISO 639 準拠の言語を取得します。

戻り値:
langucriso ISO 639 準拠の言語

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setAddrNo

public void setAddrNo(String addrNo)
アドレス番号を設定します。

パラメータ:
addrNo - アドレス番号

setFormofaddr

public void setFormofaddr(String formofaddr)
敬称テキストを設定します。

パラメータ:
formofaddr - 敬称テキスト

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setName3

public void setName3(String name3)
名称 3を設定します。

パラメータ:
name3 - 名称 3

setName4

public void setName4(String name4)
名称 4を設定します。

パラメータ:
name4 - 名称 4

setCOName

public void setCOName(String cOName)
気付を設定します。

パラメータ:
cOName - 気付

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setCityNo

public void setCityNo(String cityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
cityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String postlCod1)
市区町村の郵便番号を設定します。

パラメータ:
postlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String postlCod2)
私書箱郵便番号を設定します。

パラメータ:
postlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String postlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
postlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBox

public void setPoBox(String poBox)
私書箱を設定します。

パラメータ:
poBox - 私書箱

setPoBoxCit

public void setPoBoxCit(String poBoxCit)
私書箱住所を設定します。

パラメータ:
poBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String delivDis)
郵便配達地域を設定します。

パラメータ:
delivDis - 郵便配達地域

setStreet

public void setStreet(String street)
地名を設定します。

パラメータ:
street - 地名

setStreetNo

public void setStreetNo(String streetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
streetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String houseNo)
番地-号を設定します。

パラメータ:
houseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strSuppl1)
地名 2を設定します。

パラメータ:
strSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strSuppl2)
地名 3を設定します。

パラメータ:
strSuppl2 - 地名 3

setLocation

public void setLocation(String location)
地名 5を設定します。

パラメータ:
location - 地名 5

setBuilding

public void setBuilding(String building)
旧: 建物 (番号または略称)を設定します。

パラメータ:
building - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String floor)
建物の階を設定します。

パラメータ:
floor - 建物の階

setRoomNo

public void setRoomNo(String roomNo)
部屋/アパート番号を設定します。

パラメータ:
roomNo - 部屋/アパート番号

setCountry

public void setCountry(String country)
国コードを設定します。

パラメータ:
country - 国コード

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setSort1

public void setSort1(String sort1)
検索条件 1を設定します。

パラメータ:
sort1 - 検索条件 1

setSort2

public void setSort2(String sort2)
検索条件 2を設定します。

パラメータ:
sort2 - 検索条件 2

setTimeZone

public void setTimeZone(String timeZone)
アドレスタイムゾーンを設定します。

パラメータ:
timeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税管轄コードを設定します。

パラメータ:
taxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String adrNotes)
住所注記を設定します。

パラメータ:
adrNotes - 住所注記

setCommType

public void setCommType(String commType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
commType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String tel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
tel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String tel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
tel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String faxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
faxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String faxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
faxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String streetLng)
地名を設定します。

パラメータ:
streetLng - 地名

setDistrctNo

public void setDistrctNo(String distrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
distrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String chckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
chckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String pboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
pboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String transpzone)
商品の納入区域を設定します。

パラメータ:
transpzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String houseNo2)
番地補足を設定します。

パラメータ:
houseNo2 - 番地補足

setEMail

public void setEMail(String eMail)
電子メールアドレスを設定します。

パラメータ:
eMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strSuppl3)
地名 4を設定します。

パラメータ:
strSuppl3 - 地名 4

setTitle

public void setTitle(String title)
タイトル (敬称)を設定します。

パラメータ:
title - タイトル (敬称)

setCountryiso

public void setCountryiso(String countryiso)
ISO 国コードを設定します。

パラメータ:
countryiso - ISO 国コード

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setBuildLong

public void setBuildLong(String buildLong)
建物 (番号またはコード)を設定します。

パラメータ:
buildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String regiogroup)
地域構造グループ化を設定します。

パラメータ:
regiogroup - 地域構造グループ化

setHomeCity

public void setHomeCity(String homeCity)
市区町村 (郵便用市区町村と異なる場合)を設定します。

パラメータ:
homeCity - 市区町村 (郵便用市区町村と異なる場合)

setHomecityno

public void setHomecityno(String homecityno)
別の市区町村 (市区町村/地名ファイル)を設定します。

パラメータ:
homecityno - 別の市区町村 (市区町村/地名ファイル)

setPcode1Ext

public void setPcode1Ext(String pcode1Ext)
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode1Ext - 市区町村郵便番号の拡張子 例: 郵便番号 +4+2

setPcode2Ext

public void setPcode2Ext(String pcode2Ext)
私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode2Ext - 私書箱郵便番号拡張子 例: 郵便番号 +4+2

setPcode3Ext

public void setPcode3Ext(String pcode3Ext)
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode3Ext - 主要得意先郵便番号拡張子 例: 郵便番号 +4+2

setPoWONo

public void setPoWONo(String poWONo)
フラグ: 郵便私書箱 (番号なし)を設定します。

パラメータ:
poWONo - フラグ: 郵便私書箱 (番号なし)

setPoBoxReg

public void setPoBoxReg(String poBoxReg)
私書箱の地域 (国、都道府県、地域、...)を設定します。

パラメータ:
poBoxReg - 私書箱の地域 (国、都道府県、地域、...)

setPoboxCtry

public void setPoboxCtry(String poboxCtry)
私書箱の国指定を設定します。

パラメータ:
poboxCtry - 私書箱の国指定

setPoCtryiso

public void setPoCtryiso(String poCtryiso)
ISO 国コードを設定します。

パラメータ:
poCtryiso - ISO 国コード

setHomepage

public void setHomepage(String homepage)
URI 例: ホームページ、FTP アドレスを設定します。

パラメータ:
homepage - URI 例: ホームページ、FTP アドレス

setDontUseS

public void setDontUseS(String dontUseS)
地名住所配達不可フラグを設定します。

パラメータ:
dontUseS - 地名住所配達不可フラグ

setDontUseP

public void setDontUseP(String dontUseP)
私書箱住所配達不可フラグを設定します。

パラメータ:
dontUseP - 私書箱住所配達不可フラグ

setHouseNo3

public void setHouseNo3(String houseNo3)
番地範囲を設定します。

パラメータ:
houseNo3 - 番地範囲

setLanguCr

public void setLanguCr(String languCr)
アドレスレコード登録オリジナル言語を設定します。

パラメータ:
languCr - アドレスレコード登録オリジナル言語

setLangucriso

public void setLangucriso(String langucriso)
ISO 639 準拠の言語を設定します。

パラメータ:
langucriso - ISO 639 準拠の言語

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Partners (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Partners

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners
すべての実装インタフェース:
Serializable
public class Partners
extends Object
implements Serializable

伝票取引先情報クラス
機能は以下の通り

  • 伝票取引先情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Partners()
伝票取引先情報を作成します。
Partners(int index)
伝票取引先情報を作成します。
メソッドの概要
String | getAddress() 住所を取得します。
String | getAddrLink() 住所コードへのリンクを取得します。
String | getAddrOrig() コピー元住所を取得します。
String | getAddrType() アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。
String | getCity() 市区町村を取得します。
String | getCountrIso() 国キー (ISO コード)を取得します。
String | getCountry() 国コードを取得します。
String | getDistrict() 所在地を取得します。
String | getFaxNumber() FAX 番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 明細番号 (販売管理伝票)を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getName3() 名称 3を取得します。
String | getName4() 名称 4を取得します。
String | getPartnNumb() 得意先コード 1を取得します。
String | getPartnRole() 取引先機能を取得します。
String | getPoBox() 私書箱を取得します。
String | getPobxCty() 私書箱住所を取得します。
String | getPobxPcd() 私書箱番号を取得します。
String | getPostlCode() 郵便番号を取得します。
String | getPrivAddr() 自宅住所を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTelebox() テレボックス番号を取得します。
String | getTelephone() 電話番号 1を取得します。
String | getTelephone2() 電話番号 2を取得します。
String | getTeletexNo() テレテクス番号を取得します。
String | getTelexNo() テレックス番号を取得します。
String | getTitle() 敬称を取得します。
String | getTranspzone() 商品の納入区域を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
void | setAddress(String address) 住所を設定します。
void | setAddrLink(String addrLink) 住所コードへのリンクを設定します。
void | setAddrOrig(String addrOrig) コピー元住所を設定します。
void | setAddrType(String addrType) アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。
void | setCity(String city) 市区町村を設定します。
void | setCountrIso(String countrIso) 国キー (ISO コード)を設定します。
void | setCountry(String country) 国コードを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setFaxNumber(String faxNumber) FAX 番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 明細番号 (販売管理伝票)を設定します。
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setName3(String name3) 名称 3を設定します。
void | setName4(String name4) 名称 4を設定します。
void | setPartnNumb(String partnNumb) 得意先コード 1を設定します。
void | setPartnRole(String partnRole) 取引先機能を設定します。
void | setPoBox(String poBox) 私書箱を設定します。
void | setPobxCty(String pobxCty) 私書箱住所を設定します。
void | setPobxPcd(String pobxPcd) 私書箱番号を設定します。
void | setPostlCode(String postlCode) 郵便番号を設定します。
void | setPrivAddr(String privAddr) 自宅住所を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setStreet(String street) 地名/番地-号を設定します。
void | setTaxjurcode(String taxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTelebox(String telebox) テレボックス番号を設定します。
void | setTelephone(String telephone) 電話番号 1を設定します。
void | setTelephone2(String telephone2) 電話番号 2を設定します。
void | setTeletexNo(String teletexNo) テレテクス番号を設定します。
void | setTelexNo(String telexNo) テレックス番号を設定します。
void | setTitle(String title) 敬称を設定します。
void | setTranspzone(String transpzone) 商品の納入区域を設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Partners

public Partners()
伝票取引先情報を作成します。

Partners

public Partners(int index)
伝票取引先情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPartnRole

public String getPartnRole()
取引先機能を取得します。

戻り値:
partnRole 取引先機能

getPartnNumb

public String getPartnNumb()
得意先コード 1を取得します。

戻り値:
partnNumb 得意先コード 1

getItmNumber

public String getItmNumber()
明細番号 (販売管理伝票)を取得します。

戻り値:
itmNumber 明細番号 (販売管理伝票)

getTitle

public String getTitle()
敬称を取得します。

戻り値:
title 敬称

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getName3

public String getName3()
名称 3を取得します。

戻り値:
name3 名称 3

getName4

public String getName4()
名称 4を取得します。

戻り値:
name4 名称 4

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
street 地名/番地-号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
country 国コード

getCountrIso

public String getCountrIso()
国キー (ISO コード)を取得します。

戻り値:
countrIso 国キー (ISO コード)

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
postlCode 郵便番号

getPobxPcd

public String getPobxPcd()
私書箱番号を取得します。

戻り値:
pobxPcd 私書箱番号

getPobxCty

public String getPobxCty()
私書箱住所を取得します。

戻り値:
pobxCty 私書箱住所

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
poBox 私書箱

getTelephone

public String getTelephone()
電話番号 1を取得します。

戻り値:
telephone 電話番号 1

getTelephone2

public String getTelephone2()
電話番号 2を取得します。

戻り値:
telephone2 電話番号 2

getTelebox

public String getTelebox()
テレボックス番号を取得します。

戻り値:
telebox テレボックス番号

getFaxNumber

public String getFaxNumber()
FAX 番号を取得します。

戻り値:
faxNumber FAX 番号

getTeletexNo

public String getTeletexNo()
テレテクス番号を取得します。

戻り値:
teletexNo テレテクス番号

getTelexNo

public String getTelexNo()
テレックス番号を取得します。

戻り値:
telexNo テレックス番号

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
transpzone 商品の納入区域

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
taxjurcode 税計算管轄コード - 税管轄コード

getAddress

public String getAddress()
住所を取得します。

戻り値:
address 住所

getPrivAddr

public String getPrivAddr()
自宅住所を取得します。

戻り値:
privAddr 自宅住所

getAddrType

public String getAddrType()
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。

戻り値:
addrType アドレスタイプ (1=組織、2=個人、3=取引先担当者)

getAddrOrig

public String getAddrOrig()
コピー元住所を取得します。

戻り値:
addrOrig コピー元住所

getAddrLink

public String getAddrLink()
住所コードへのリンクを取得します。

戻り値:
addrLink 住所コードへのリンク

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPartnRole

public void setPartnRole(String partnRole)
取引先機能を設定します。

パラメータ:
partnRole - 取引先機能

setPartnNumb

public void setPartnNumb(String partnNumb)
得意先コード 1を設定します。

パラメータ:
partnNumb - 得意先コード 1

setItmNumber

public void setItmNumber(String itmNumber)
明細番号 (販売管理伝票)を設定します。

パラメータ:
itmNumber - 明細番号 (販売管理伝票)

setTitle

public void setTitle(String title)
敬称を設定します。

パラメータ:
title - 敬称

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setName3

public void setName3(String name3)
名称 3を設定します。

パラメータ:
name3 - 名称 3

setName4

public void setName4(String name4)
名称 4を設定します。

パラメータ:
name4 - 名称 4

setStreet

public void setStreet(String street)
地名/番地-号を設定します。

パラメータ:
street - 地名/番地-号

setCountry

public void setCountry(String country)
国コードを設定します。

パラメータ:
country - 国コード

setCountrIso

public void setCountrIso(String countrIso)
国キー (ISO コード)を設定します。

パラメータ:
countrIso - 国キー (ISO コード)

setPostlCode

public void setPostlCode(String postlCode)
郵便番号を設定します。

パラメータ:
postlCode - 郵便番号

setPobxPcd

public void setPobxPcd(String pobxPcd)
私書箱番号を設定します。

パラメータ:
pobxPcd - 私書箱番号

setPobxCty

public void setPobxCty(String pobxCty)
私書箱住所を設定します。

パラメータ:
pobxCty - 私書箱住所

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setPoBox

public void setPoBox(String poBox)
私書箱を設定します。

パラメータ:
poBox - 私書箱

setTelephone

public void setTelephone(String telephone)
電話番号 1を設定します。

パラメータ:
telephone - 電話番号 1

setTelephone2

public void setTelephone2(String telephone2)
電話番号 2を設定します。

パラメータ:
telephone2 - 電話番号 2

setTelebox

public void setTelebox(String telebox)
テレボックス番号を設定します。

パラメータ:
telebox - テレボックス番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX 番号を設定します。

パラメータ:
faxNumber - FAX 番号

setTeletexNo

public void setTeletexNo(String teletexNo)
テレテクス番号を設定します。

パラメータ:
teletexNo - テレテクス番号

setTelexNo

public void setTelexNo(String telexNo)
テレックス番号を設定します。

パラメータ:
telexNo - テレックス番号

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setTranspzone

public void setTranspzone(String transpzone)
商品の納入区域を設定します。

パラメータ:
transpzone - 商品の納入区域

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
taxjurcode - 税計算管轄コード - 税管轄コード

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所

setPrivAddr

public void setPrivAddr(String privAddr)
自宅住所を設定します。

パラメータ:
privAddr - 自宅住所

setAddrType

public void setAddrType(String addrType)
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。

パラメータ:
addrType - アドレスタイプ (1=組織、2=個人、3=取引先担当者)

setAddrOrig

public void setAddrOrig(String addrOrig)
コピー元住所を設定します。

パラメータ:
addrOrig - コピー元住所

setAddrLink

public void setAddrLink(String addrLink)
住所コードへのリンクを設定します。

パラメータ:
addrLink - 住所コードへのリンク

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SchedulesIn (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス SchedulesIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn
すべての実装インタフェース:
Serializable
public class SchedulesIn
extends Object
implements Serializable

納入日程行情報クラス
機能は以下の通り

  • 納入日程行情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SchedulesIn()
納入日程行情報を作成します。
SchedulesIn(int index)
納入日程行情報を作成します。
メソッドの概要
String | getDateType() 日付タイプ (日、週、月、期間)を取得します。
String | getDlvDate() 納入日程日付を取得します。
String | getDlvTime() 納入時間を取得します。
String | getGiDate() 出庫日付を取得します。
String | getGiTime() 出庫時刻 (現地時間 - プラント参照)を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLoadDate() 積載日付を取得します。
String | getLoadTime() 積載時刻 (現地時間: 出荷ポイント)を取得します。
String | getMsDate() 品目利用可能日を取得します。
String | getMsTime() 品目供給ステージ (現地時刻: プラント参照)を取得します。
String | getPlanSchedType() 納入日程行タイプ EDIを取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRelType() 承認タイプを取得します。
String | getReqDate() 納入日程日付を取得します。
String | getReqDlvBl() 出荷ブロック中の納入日程行を取得します。
String | getReqQty() 販売単位による受注数量を取得します。
String | getReqTime() 納入時間を取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSchedType() 納入日程カテゴリを取得します。
String | getTpDate() 輸送計画日付を取得します。
String | getTpTime() 輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
void | setDateType(String dateType) 日付タイプ (日、週、月、期間)を設定します。
void | setDlvDate(String dlvDate) 納入日程日付を設定します。
void | setDlvTime(String dlvTime) 納入時間を設定します。
void | setGiDate(String giDate) 出庫日付を設定します。
void | setGiTime(String giTime) 出庫時刻 (現地時間 - プラント参照)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLoadDate(String loadDate) 積載日付を設定します。
void | setLoadTime(String loadTime) 積載時刻 (現地時間: 出荷ポイント)を設定します。
void | setMsDate(String msDate) 品目利用可能日を設定します。
void | setMsTime(String msTime) 品目供給ステージ (現地時刻: プラント参照)を設定します。
void | setPlanSchedType(String planSchedType) 納入日程行タイプ EDIを設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRelType(String relType) 承認タイプを設定します。
void | setReqDate(String reqDate) 納入日程日付を設定します。
void | setReqDlvBl(String reqDlvBl) 出荷ブロック中の納入日程行を設定します。
void | setReqQty(String reqQty) 販売単位による受注数量を設定します。
void | setReqTime(String reqTime) 納入時間を設定します。
void | setSchedLine(String schedLine) 納入日程行を設定します。
void | setSchedType(String schedType) 納入日程カテゴリを設定します。
void | setTpDate(String tpDate) 輸送計画日付を設定します。
void | setTpTime(String tpTime) 輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SchedulesIn

public SchedulesIn()
納入日程行情報を作成します。

SchedulesIn

public SchedulesIn(int index)
納入日程行情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
schedLine 納入日程行

getReqDate

public String getReqDate()
納入日程日付を取得します。

戻り値:
reqDate 納入日程日付

getDateType

public String getDateType()
日付タイプ (日、週、月、期間)を取得します。

戻り値:
dateType 日付タイプ (日、週、月、期間)

getReqTime

public String getReqTime()
納入時間を取得します。

戻り値:
reqTime 納入時間

getReqQty

public String getReqQty()
販売単位による受注数量を取得します。

戻り値:
reqQty 販売単位による受注数量

getReqDlvBl

public String getReqDlvBl()
出荷ブロック中の納入日程行を取得します。

戻り値:
reqDlvBl 出荷ブロック中の納入日程行

getSchedType

public String getSchedType()
納入日程カテゴリを取得します。

戻り値:
schedType 納入日程カテゴリ

getTpDate

public String getTpDate()
輸送計画日付を取得します。

戻り値:
tpDate 輸送計画日付

getMsDate

public String getMsDate()
品目利用可能日を取得します。

戻り値:
msDate 品目利用可能日

getLoadDate

public String getLoadDate()
積載日付を取得します。

戻り値:
loadDate 積載日付

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
giDate 出庫日付

getTpTime

public String getTpTime()
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。

戻り値:
tpTime 輸送計画 - 時間 (現地時間/出荷ポイント参照)

getMsTime

public String getMsTime()
品目供給ステージ (現地時刻: プラント参照)を取得します。

戻り値:
msTime 品目供給ステージ (現地時刻: プラント参照)

getLoadTime

public String getLoadTime()
積載時刻 (現地時間: 出荷ポイント)を取得します。

戻り値:
loadTime 積載時刻 (現地時間: 出荷ポイント)

getGiTime

public String getGiTime()
出庫時刻 (現地時間 - プラント参照)を取得します。

戻り値:
giTime 出庫時刻 (現地時間 - プラント参照)

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getDlvDate

public String getDlvDate()
納入日程日付を取得します。

戻り値:
dlvDate 納入日程日付

getDlvTime

public String getDlvTime()
納入時間を取得します。

戻り値:
dlvTime 納入時間

getRelType

public String getRelType()
承認タイプを取得します。

戻り値:
relType 承認タイプ

getPlanSchedType

public String getPlanSchedType()
納入日程行タイプ EDIを取得します。

戻り値:
planSchedType 納入日程行タイプ EDI

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String schedLine)
納入日程行を設定します。

パラメータ:
schedLine - 納入日程行

setReqDate

public void setReqDate(String reqDate)
納入日程日付を設定します。

パラメータ:
reqDate - 納入日程日付

setDateType

public void setDateType(String dateType)
日付タイプ (日、週、月、期間)を設定します。

パラメータ:
dateType - 日付タイプ (日、週、月、期間)

setReqTime

public void setReqTime(String reqTime)
納入時間を設定します。

パラメータ:
reqTime - 納入時間

setReqQty

public void setReqQty(String reqQty)
販売単位による受注数量を設定します。

パラメータ:
reqQty - 販売単位による受注数量

setReqDlvBl

public void setReqDlvBl(String reqDlvBl)
出荷ブロック中の納入日程行を設定します。

パラメータ:
reqDlvBl - 出荷ブロック中の納入日程行

setSchedType

public void setSchedType(String schedType)
納入日程カテゴリを設定します。

パラメータ:
schedType - 納入日程カテゴリ

setTpDate

public void setTpDate(String tpDate)
輸送計画日付を設定します。

パラメータ:
tpDate - 輸送計画日付

setMsDate

public void setMsDate(String msDate)
品目利用可能日を設定します。

パラメータ:
msDate - 品目利用可能日

setLoadDate

public void setLoadDate(String loadDate)
積載日付を設定します。

パラメータ:
loadDate - 積載日付

setGiDate

public void setGiDate(String giDate)
出庫日付を設定します。

パラメータ:
giDate - 出庫日付

setTpTime

public void setTpTime(String tpTime)
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。

パラメータ:
tpTime - 輸送計画 - 時間 (現地時間/出荷ポイント参照)

setMsTime

public void setMsTime(String msTime)
品目供給ステージ (現地時刻: プラント参照)を設定します。

パラメータ:
msTime - 品目供給ステージ (現地時刻: プラント参照)

setLoadTime

public void setLoadTime(String loadTime)
積載時刻 (現地時間: 出荷ポイント)を設定します。

パラメータ:
loadTime - 積載時刻 (現地時間: 出荷ポイント)

setGiTime

public void setGiTime(String giTime)
出庫時刻 (現地時間 - プラント参照)を設定します。

パラメータ:
giTime - 出庫時刻 (現地時間 - プラント参照)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setDlvDate

public void setDlvDate(String dlvDate)
納入日程日付を設定します。

パラメータ:
dlvDate - 納入日程日付

setDlvTime

public void setDlvTime(String dlvTime)
納入時間を設定します。

パラメータ:
dlvTime - 納入時間

setRelType

public void setRelType(String relType)
承認タイプを設定します。

パラメータ:
relType - 承認タイプ

setPlanSchedType

public void setPlanSchedType(String planSchedType)
納入日程行タイプ EDIを設定します。

パラメータ:
planSchedType - 納入日程行タイプ EDI

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SchedulesInX (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス SchedulesInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX
すべての実装インタフェース:
Serializable
public class SchedulesInX
extends Object
implements Serializable

納入日程行チェックボックス情報クラス
機能は以下の通り

  • 納入日程行チェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SchedulesInX()
納入日程行チェックボックス情報を作成します。
SchedulesInX(int index)
納入日程行チェックボックス情報を作成します。
メソッドの概要
String | getDateType() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getGiDate() 関連ユーザデータ項目の更新情報を取得します。
String | getGiTime() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLoadDate() 関連ユーザデータ項目の更新情報を取得します。
String | getLoadTime() 関連ユーザデータ項目の更新情報を取得します。
String | getMsDate() 関連ユーザデータ項目の更新情報を取得します。
String | getMsTime() 関連ユーザデータ項目の更新情報を取得します。
String | getPlanSchedType() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRelType() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDate() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDlvBl() 関連ユーザデータ項目の更新情報を取得します。
String | getReqQty() 関連ユーザデータ項目の更新情報を取得します。
String | getReqTime() 関連ユーザデータ項目の更新情報を取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSchedType() 関連ユーザデータ項目の更新情報を取得します。
String | getTpDate() 関連ユーザデータ項目の更新情報を取得します。
String | getTpTime() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
void | setDateType(String dateType) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvDate(String dlvDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setGiDate(String giDate) 関連ユーザデータ項目の更新情報を設定します。
void | setGiTime(String giTime) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLoadDate(String loadDate) 関連ユーザデータ項目の更新情報を設定します。
void | setLoadTime(String loadTime) 関連ユーザデータ項目の更新情報を設定します。
void | setMsDate(String msDate) 関連ユーザデータ項目の更新情報を設定します。
void | setMsTime(String msTime) 関連ユーザデータ項目の更新情報を設定します。
void | setPlanSchedType(String planSchedType) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRelType(String relType) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDate(String reqDate) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDlvBl(String reqDlvBl) 関連ユーザデータ項目の更新情報を設定します。
void | setReqQty(String reqQty) 関連ユーザデータ項目の更新情報を設定します。
void | setReqTime(String reqTime) 関連ユーザデータ項目の更新情報を設定します。
void | setSchedLine(String schedLine) 納入日程行を設定します。
void | setSchedType(String schedType) 関連ユーザデータ項目の更新情報を設定します。
void | setTpDate(String tpDate) 関連ユーザデータ項目の更新情報を設定します。
void | setTpTime(String tpTime) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SchedulesInX

public SchedulesInX()
納入日程行チェックボックス情報を作成します。

SchedulesInX

public SchedulesInX(int index)
納入日程行チェックボックス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
schedLine 納入日程行

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getReqDate

public String getReqDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDate 関連ユーザデータ項目の更新情報

getDateType

public String getDateType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dateType 関連ユーザデータ項目の更新情報

getReqTime

public String getReqTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqTime 関連ユーザデータ項目の更新情報

getReqQty

public String getReqQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqQty 関連ユーザデータ項目の更新情報

getReqDlvBl

public String getReqDlvBl()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDlvBl 関連ユーザデータ項目の更新情報

getSchedType

public String getSchedType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
schedType 関連ユーザデータ項目の更新情報

getTpDate

public String getTpDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tpDate 関連ユーザデータ項目の更新情報

getMsDate

public String getMsDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
msDate 関連ユーザデータ項目の更新情報

getLoadDate

public String getLoadDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
loadDate 関連ユーザデータ項目の更新情報

getGiDate

public String getGiDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
giDate 関連ユーザデータ項目の更新情報

getTpTime

public String getTpTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tpTime 関連ユーザデータ項目の更新情報

getMsTime

public String getMsTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
msTime 関連ユーザデータ項目の更新情報

getLoadTime

public String getLoadTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
loadTime 関連ユーザデータ項目の更新情報

getGiTime

public String getGiTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
giTime 関連ユーザデータ項目の更新情報

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getDlvDate

public String getDlvDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvDate 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getRelType

public String getRelType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
relType 関連ユーザデータ項目の更新情報

getPlanSchedType

public String getPlanSchedType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
planSchedType 関連ユーザデータ項目の更新情報

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String schedLine)
納入日程行を設定します。

パラメータ:
schedLine - 納入日程行

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setReqDate

public void setReqDate(String reqDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDate - 関連ユーザデータ項目の更新情報

setDateType

public void setDateType(String dateType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dateType - 関連ユーザデータ項目の更新情報

setReqTime

public void setReqTime(String reqTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqTime - 関連ユーザデータ項目の更新情報

setReqQty

public void setReqQty(String reqQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqQty - 関連ユーザデータ項目の更新情報

setReqDlvBl

public void setReqDlvBl(String reqDlvBl)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDlvBl - 関連ユーザデータ項目の更新情報

setSchedType

public void setSchedType(String schedType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
schedType - 関連ユーザデータ項目の更新情報

setTpDate

public void setTpDate(String tpDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tpDate - 関連ユーザデータ項目の更新情報

setMsDate

public void setMsDate(String msDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
msDate - 関連ユーザデータ項目の更新情報

setLoadDate

public void setLoadDate(String loadDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
loadDate - 関連ユーザデータ項目の更新情報

setGiDate

public void setGiDate(String giDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
giDate - 関連ユーザデータ項目の更新情報

setTpTime

public void setTpTime(String tpTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tpTime - 関連ユーザデータ項目の更新情報

setMsTime

public void setMsTime(String msTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
msTime - 関連ユーザデータ項目の更新情報

setLoadTime

public void setLoadTime(String loadTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
loadTime - 関連ユーザデータ項目の更新情報

setGiTime

public void setGiTime(String giTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
giTime - 関連ユーザデータ項目の更新情報

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setDlvDate

public void setDlvDate(String dlvDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvDate - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setRelType

public void setRelType(String relType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
relType - 関連ユーザデータ項目の更新情報

setPlanSchedType

public void setPlanSchedType(String planSchedType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
planSchedType - 関連ユーザデータ項目の更新情報

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Sender (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Sender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender
すべての実装インタフェース:
Serializable
public class Sender
extends Object
implements Serializable

論理システム - 送信者情報クラス
機能は以下の通り

  • 論理システム - 送信者情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Sender()
論理システム - 送信者情報を作成します。
メソッドの概要
String | getLogSystem() 論理システムを取得します。
void | setLogSystem(String logSystem) 論理システムを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Sender

public Sender()
論理システム - 送信者情報を作成します。

メソッドの詳細

getLogSystem

public String getLogSystem()
論理システムを取得します。

戻り値:
logSystem 論理システム

setLogSystem

public void setLogSystem(String logSystem)
論理システムを設定します。

パラメータ:
logSystem - 論理システム

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Success (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Success

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Success
すべての実装インタフェース:
Serializable
public class Success
extends Object
implements Serializable

正常に処理された明細のテーブル情報クラス
機能は以下の通り

  • 正常に処理された明細のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Success()
正常に処理された明細のテーブル情報を作成します。
Success(int index)
正常に処理された明細のテーブル情報を作成します。
メソッドの概要
String | getBillDoc() 請求伝票を取得します。
String | getBillDocItem() 請求伝票明細を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getGroValueItem() 総額を取得します。
int | getIndex() レコード番号を取得します｡
String | getNetValue() 正味金額を取得します。
String | getNetValueItem() 正味金額を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocItem() 参照明細番号を取得します。
String | getTaxValue() 税額を取得します。
String | getTaxValueItem() 税額を取得します。
void | setBillDoc(String billDoc) 請求伝票を設定します。
void | setBillDocItem(String billDocItem) 請求伝票明細を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setGroValueItem(String groValueItem) 総額を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setNetValue(String netValue) 正味金額を設定します。
void | setNetValueItem(String netValueItem) 正味金額を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocItem(String refDocItem) 参照明細番号を設定します。
void | setTaxValue(String taxValue) 税額を設定します。
void | setTaxValueItem(String taxValueItem) 税額を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Success

public Success()
正常に処理された明細のテーブル情報を作成します。

Success

public Success(int index)
正常に処理された明細のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocItem

public String getRefDocItem()
参照明細番号を取得します。

戻り値:
refDocItem 参照明細番号

getBillDoc

public String getBillDoc()
請求伝票を取得します。

戻り値:
billDoc 請求伝票

getBillDocItem

public String getBillDocItem()
請求伝票明細を取得します。

戻り値:
billDocItem 請求伝票明細

getNetValue

public String getNetValue()
正味金額を取得します。

戻り値:
netValue 正味金額

getTaxValue

public String getTaxValue()
税額を取得します。

戻り値:
taxValue 税額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getNetValueItem

public String getNetValueItem()
正味金額を取得します。

戻り値:
netValueItem 正味金額

getTaxValueItem

public String getTaxValueItem()
税額を取得します。

戻り値:
taxValueItem 税額

getGroValueItem

public String getGroValueItem()
総額を取得します。

戻り値:
groValueItem 総額

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocItem

public void setRefDocItem(String refDocItem)
参照明細番号を設定します。

パラメータ:
refDocItem - 参照明細番号

setBillDoc

public void setBillDoc(String billDoc)
請求伝票を設定します。

パラメータ:
billDoc - 請求伝票

setBillDocItem

public void setBillDocItem(String billDocItem)
請求伝票明細を設定します。

パラメータ:
billDocItem - 請求伝票明細

setNetValue

public void setNetValue(String netValue)
正味金額を設定します。

パラメータ:
netValue - 正味金額

setTaxValue

public void setTaxValue(String taxValue)
税額を設定します。

パラメータ:
taxValue - 税額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setNetValueItem

public void setNetValueItem(String netValueItem)
正味金額を設定します。

パラメータ:
netValueItem - 正味金額

setTaxValueItem

public void setTaxValueItem(String taxValueItem)
税額を設定します。

パラメータ:
taxValueItem - 税額

setGroValueItem

public void setGroValueItem(String groValueItem)
総額を設定します。

パラメータ:
groValueItem - 総額

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Text (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Text

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Text
すべての実装インタフェース:
Serializable
public class Text
extends Object
implements Serializable

テキスト情報クラス
機能は以下の通り

  • テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Text()
テキスト情報を作成します。
Text(int index)
テキスト情報を作成します。
メソッドの概要
String | getDocNumber() 販売伝票を取得します。
String | getFormatCol() タグ列を取得します。
String | getFunction() 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setFunction(String function) 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Text

public Text()
テキスト情報を作成します。

Text

public Text(int index)
テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getFunction

public String getFunction()
機能を取得します。

戻り値:
function 機能

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setFunction

public void setFunction(String function)
機能を設定します。

パラメータ:
function - 機能

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException の使用

SAPSalesAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales での SAPSalesAppException の使用

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPSalesAppException の使用

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException の使用

SAPSalesSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |

jp.co.intra_mart.foundation.sap.module.purchase での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | MaterialGetAllController.setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | MaterialAvailabilityController.setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。

jp.co.intra_mart.foundation.sap.module.sales での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetStatusController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderGetListController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void SalesOrderGetListController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void SalesOrderCreateFromDat2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void SalesOrderCreateFromDat2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void QuotationCreateFromData2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void QuotationCreateFromData2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void InquiryCreateFromData2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void InquiryCreateFromData2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocGetListController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void BillingDocGetListController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
 void BillingDocCreateMultipleController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void BillingDocCreateMultipleController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.exception (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.exception
例外
SAPSalesAppException
SAPSalesSystemException


jp.co.intra_mart.foundation.sap.module.sales.exception (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception

例外の概要
SAPSalesAppException | 販売管理系APIアプリケーション例外クラス。
SAPSalesSystemException | 販売管理系APIシステム例外クラス


jp.co.intra_mart.foundation.sap.module.sales.exception クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.exception の使用

jp.co.intra_mart.foundation.sap.module.sales.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesSystemException
販売管理系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesAppException
販売管理系APIアプリケーション例外クラス。
SAPSalesSystemException
販売管理系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesAppException
販売管理系APIアプリケーション例外クラス。
SAPSalesSystemException
販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPSalesAppException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.exception
クラス SAPSalesAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
すべての実装インタフェース:
Serializable
public class SAPSalesAppException
extends SAPModuleAppException

販売管理系APIアプリケーション例外クラス。

SAP リアルタイム連携API におけるBAPI 実行後の成功・失敗の標準の基準は、 各API でのBAPI 実行後にRETURN パラメータのTYPE 値を取得して、S（正常終了） または空文字以外が１つでも存在するかどうかです。
失敗の場合、本例外がスローされます。

関連項目:
直列化された形式

コンストラクタの概要
SAPSalesAppException(String message)
販売管理系APIアプリケーション例外
SAPSalesAppException(String message, Throwable ex)
販売管理系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPSalesAppException

public SAPSalesAppException(String message,
                            Throwable ex)
販売管理系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPSalesAppException

public SAPSalesAppException(String message)
販売管理系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPSalesSystemException (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.exception
クラス SAPSalesSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException
すべての実装インタフェース:
Serializable
public class SAPSalesSystemException
extends SAPModuleSystemException

販売管理系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPSalesSystemException(String message, Throwable ex)
販売管理系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPSalesSystemException

public SAPSalesSystemException(String message,
                               Throwable ex)
販売管理系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 の使用

InquiryCreateFromData2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での InquiryCreateFromData2 の使用

jp.co.intra_mart.foundation.sap.module.sales での InquiryCreateFromData2 のサブクラス
 class InquiryCreateFromData2Controller
引合伝票登録コントローラクラス
機能は以下の通り
引合伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InquiryCreateFromData2 (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
クラス InquiryCreateFromData2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
InquiryCreateFromData2Controller
public class InquiryCreateFromData2
extends UpdateController
implements Serializable

引合伝票登録情報クラス
機能は以下の通り

  • 引合伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InquiryCreateFromData2()
コンストラクタ。
InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 変換: 取引先機能 + 受注伝票タイプを取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
List | getInquiryCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getInquiryCfgsInstList() 選定: インスタンスを取得します。
List | getInquiryCfgsPartOfList() 選定: 部分設定を取得します。
List | getInquiryCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getInquiryCfgsRefList() 選定: 参照データを取得します。
List | getInquiryCfgsValueList() 選定: 特性値を取得します。
List | getInquiryCfgsVkList() 選定: バリアント条件キーを取得します。
List | getInquiryConditionsInList() 条件を取得します。
List | getInquiryConditionsInXList() 受注における条件更新の通信項目を取得します。
HeaderIn | getInquiryHeaderIn() 引合伝票ヘッダデータを取得します。
HeaderInX | getInquiryHeaderInX() ヘッダデータチェックボックスを取得します。
List | getInquiryItemsInList() 明細データを取得します。
List | getInquiryItemsInXList() 明細データチェックボックスを取得します。
List | getInquiryKeysList() 参照キーの出力テーブルを取得します。
List | getInquiryPartnersList() 伝票取引先を取得します。
List | getInquirySchedulesInList() 納入日程行を取得します。
List | getInquirySchedulesInXList() 納入日程行チェックボックスを取得します。
List | getInquiryTextList() テキストを取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
String | getSalesdocument() 販売伝票番号を取得します。
String | getSalesdocumentin() 販売管理伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 変換: 取引先機能 + 受注伝票タイプを設定します。
void | setExportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | setInquiryCfgsBlobList(List inquiryCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setInquiryCfgsInstList(List inquiryCfgsInstList) 選定: インスタンスを設定します。
void | setInquiryCfgsPartOfList(List inquiryCfgsPartOfList) 選定: 部分設定を設定します。
void | setInquiryCfgsRefInstList(List inquiryCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setInquiryCfgsRefList(List inquiryCfgsRefList) 選定: 参照データを設定します。
void | setInquiryCfgsValueList(List inquiryCfgsValueList) 選定: 特性値を設定します。
void | setInquiryCfgsVkList(List inquiryCfgsVkList) 選定: バリアント条件キーを設定します。
void | setInquiryConditionsInList(List inquiryConditionsInList) 条件を設定します。
void | setInquiryConditionsInXList(List inquiryConditionsInXList) 受注における条件更新の通信項目を設定します。
void | setInquiryHeaderIn(HeaderIn inquiryHeaderIn) 引合伝票ヘッダデータを設定します。
void | setInquiryHeaderInX(HeaderInX inquiryHeaderInX) ヘッダデータチェックボックスを設定します。
void | setInquiryItemsInList(List inquiryItemsInList) 明細データを設定します。
void | setInquiryItemsInXList(List inquiryItemsInXList) 明細データチェックボックスを設定します。
void | setInquiryKeysList(List inquiryKeysList) 参照キーの出力テーブルを設定します。
void | setInquiryPartnersList(List inquiryPartnersList) 伝票取引先を設定します。
void | setInquirySchedulesInList(List inquirySchedulesInList) 納入日程行を設定します。
void | setInquirySchedulesInXList(List inquirySchedulesInXList) 納入日程行チェックボックスを設定します。
void | setInquiryTextList(List inquiryTextList) テキストを設定します。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setSalesdocument(String salesdocument) 販売伝票番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 販売管理伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InquiryCreateFromData2

public InquiryCreateFromData2()
コンストラクタ。

InquiryCreateFromData2

public InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

InquiryCreateFromData2

public InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引合伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
引合伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getSalesdocumentin

public String getSalesdocumentin()
販売管理伝票番号を取得します。

戻り値:
salesdocumentin 販売管理伝票番号

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getConvert

public String getConvert()
変換: 取引先機能 + 受注伝票タイプを取得します。

戻り値:
convert 変換: 取引先機能 + 受注伝票タイプ

getSalesdocument

public String getSalesdocument()
販売伝票番号を取得します。

戻り値:
salesdocument 販売伝票番号

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getInquiryHeaderInX

public HeaderInX getInquiryHeaderInX()
ヘッダデータチェックボックスを取得します。

戻り値:
inquiryHeaderInX ヘッダデータチェックボックス

getInquiryHeaderIn

public HeaderIn getInquiryHeaderIn()
引合伝票ヘッダデータを取得します。

戻り値:
inquiryHeaderIn 引合伝票ヘッダデータ

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

getInquiryCfgsBlobList

public List getInquiryCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
inquiryCfgsBlobList 選定: BLOB 内部データ (SCE)

getInquiryTextList

public List getInquiryTextList()
テキストを取得します。

戻り値:
inquiryTextList テキスト

getInquirySchedulesInXList

public List getInquirySchedulesInXList()
納入日程行チェックボックスを取得します。

戻り値:
inquirySchedulesInXList 納入日程行チェックボックス

getInquirySchedulesInList

public List getInquirySchedulesInList()
納入日程行を取得します。

戻り値:
inquirySchedulesInList 納入日程行

getInquiryPartnersList

public List getInquiryPartnersList()
伝票取引先を取得します。

戻り値:
inquiryPartnersList 伝票取引先

getInquiryKeysList

public List getInquiryKeysList()
参照キーの出力テーブルを取得します。

戻り値:
inquiryKeysList 参照キーの出力テーブル

getInquiryItemsInXList

public List getInquiryItemsInXList()
明細データチェックボックスを取得します。

戻り値:
inquiryItemsInXList 明細データチェックボックス

getInquiryItemsInList

public List getInquiryItemsInList()
明細データを取得します。

戻り値:
inquiryItemsInList 明細データ

getInquiryCfgsInstList

public List getInquiryCfgsInstList()
選定: インスタンスを取得します。

戻り値:
inquiryCfgsInstList 選定: インスタンス

getInquiryCfgsPartOfList

public List getInquiryCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
inquiryCfgsPartOfList 選定: 部分設定

getInquiryConditionsInXList

public List getInquiryConditionsInXList()
受注における条件更新の通信項目を取得します。

戻り値:
inquiryConditionsInXList 受注における条件更新の通信項目

getInquiryConditionsInList

public List getInquiryConditionsInList()
条件を取得します。

戻り値:
inquiryConditionsInList 条件

getInquiryCfgsVkList

public List getInquiryCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
inquiryCfgsVkList 選定: バリアント条件キー

getInquiryCfgsValueList

public List getInquiryCfgsValueList()
選定: 特性値を取得します。

戻り値:
inquiryCfgsValueList 選定: 特性値

getInquiryCfgsRefInstList

public List getInquiryCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
inquiryCfgsRefInstList 選定: 参照明細/インスタンス

getInquiryCfgsRefList

public List getInquiryCfgsRefList()
選定: 参照データを取得します。

戻り値:
inquiryCfgsRefList 選定: 参照データ

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
販売管理伝票番号を設定します。

パラメータ:
salesdocumentin - 販売管理伝票番号

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setConvert

public void setConvert(String convert)
変換: 取引先機能 + 受注伝票タイプを設定します。

パラメータ:
convert - 変換: 取引先機能 + 受注伝票タイプ

setSalesdocument

public void setSalesdocument(String salesdocument)
販売伝票番号を設定します。

パラメータ:
salesdocument - 販売伝票番号

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setInquiryHeaderInX

public void setInquiryHeaderInX(HeaderInX inquiryHeaderInX)
ヘッダデータチェックボックスを設定します。

パラメータ:
inquiryHeaderInX - ヘッダデータチェックボックス

setInquiryHeaderIn

public void setInquiryHeaderIn(HeaderIn inquiryHeaderIn)
引合伝票ヘッダデータを設定します。

パラメータ:
inquiryHeaderIn - 引合伝票ヘッダデータ

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

setInquiryCfgsBlobList

public void setInquiryCfgsBlobList(List inquiryCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
inquiryCfgsBlobList - 選定: BLOB 内部データ (SCE)

setInquiryTextList

public void setInquiryTextList(List inquiryTextList)
テキストを設定します。

パラメータ:
inquiryTextList - テキスト

setInquirySchedulesInXList

public void setInquirySchedulesInXList(List inquirySchedulesInXList)
納入日程行チェックボックスを設定します。

パラメータ:
inquirySchedulesInXList - 納入日程行チェックボックス

setInquirySchedulesInList

public void setInquirySchedulesInList(List inquirySchedulesInList)
納入日程行を設定します。

パラメータ:
inquirySchedulesInList - 納入日程行

setInquiryPartnersList

public void setInquiryPartnersList(List inquiryPartnersList)
伝票取引先を設定します。

パラメータ:
inquiryPartnersList - 伝票取引先

setInquiryKeysList

public void setInquiryKeysList(List inquiryKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
inquiryKeysList - 参照キーの出力テーブル

setInquiryItemsInXList

public void setInquiryItemsInXList(List inquiryItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
inquiryItemsInXList - 明細データチェックボックス

setInquiryItemsInList

public void setInquiryItemsInList(List inquiryItemsInList)
明細データを設定します。

パラメータ:
inquiryItemsInList - 明細データ

setInquiryCfgsInstList

public void setInquiryCfgsInstList(List inquiryCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
inquiryCfgsInstList - 選定: インスタンス

setInquiryCfgsPartOfList

public void setInquiryCfgsPartOfList(List inquiryCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
inquiryCfgsPartOfList - 選定: 部分設定

setInquiryConditionsInXList

public void setInquiryConditionsInXList(List inquiryConditionsInXList)
受注における条件更新の通信項目を設定します。

パラメータ:
inquiryConditionsInXList - 受注における条件更新の通信項目

setInquiryConditionsInList

public void setInquiryConditionsInList(List inquiryConditionsInList)
条件を設定します。

パラメータ:
inquiryConditionsInList - 条件

setInquiryCfgsVkList

public void setInquiryCfgsVkList(List inquiryCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
inquiryCfgsVkList - 選定: バリアント条件キー

setInquiryCfgsValueList

public void setInquiryCfgsValueList(List inquiryCfgsValueList)
選定: 特性値を設定します。

パラメータ:
inquiryCfgsValueList - 選定: 特性値

setInquiryCfgsRefInstList

public void setInquiryCfgsRefInstList(List inquiryCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
inquiryCfgsRefInstList - 選定: 参照明細/インスタンス

setInquiryCfgsRefList

public void setInquiryCfgsRefList(List inquiryCfgsRefList)
選定: 参照データを設定します。

パラメータ:
inquiryCfgsRefList - 選定: 参照データ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
クラス
InquiryCreateFromData2


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

クラスの概要
InquiryCreateFromData2 引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のクラス
InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 の使用

QuotationCreateFromData2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での QuotationCreateFromData2 の使用

jp.co.intra_mart.foundation.sap.module.sales での QuotationCreateFromData2 のサブクラス
 class QuotationCreateFromData2Controller
見積伝票登録情報コントローラクラス
機能は以下の通り
見積伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
クラス
QuotationCreateFromData2


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

クラスの概要
QuotationCreateFromData2 見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のクラス
QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


QuotationCreateFromData2 (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
クラス QuotationCreateFromData2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
QuotationCreateFromData2Controller
public class QuotationCreateFromData2
extends UpdateController
implements Serializable

見積伝票登録情報クラス
機能は以下の通り

  • 見積伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
QuotationCreateFromData2()
コンストラクタ。
QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 取引先機能/受注伝票タイプの変換を取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
List | getQuotationCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getQuotationCfgsInstList() 選定: インスタンスを取得します。
List | getQuotationCfgsPartOfList() 選定: 部分設定を取得します。
List | getQuotationCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getQuotationCfgsRefList() 選定: 参照データを取得します。
List | getQuotationCfgsValueList() 選定: 特性値を取得します。
List | getQuotationCfgsVkList() 選定: バリアント条件キーを取得します。
List | getQuotationConditionsInList() 条件を取得します。
List | getQuotationConditionsInXList() 受注における条件更新の通信項目を取得します。
HeaderIn | getQuotationHeaderIn() 伝票ヘッダデータを取得します。
HeaderInX | getQuotationHeaderInX() 伝票ヘッダチェックボックスを取得します。
List | getQuotationItemsInList() 明細データを取得します。
List | getQuotationItemsInXList() 明細データチェックボックスを取得します。
List | getQuotationKeysList() 参照キーの出力テーブルを取得します。
List | getQuotationPartnersList() 伝票取引先を取得します。
List | getQuotationSchedulesInList() 納入日程行データを取得します。
List | getQuotationSchedulesInXList() 納入日程行データチェックボックスを取得します。
List | getQuotationTextList() テキストを取得します。
String | getSalesdocument() 販売管理伝票番号を取得します。
String | getSalesdocumentin() 見積伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 取引先機能/受注伝票タイプの変換を設定します。
void | setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setQuotationCfgsBlobList(List quotationCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setQuotationCfgsInstList(List quotationCfgsInstList) 選定: インスタンスを設定します。
void | setQuotationCfgsPartOfList(List quotationCfgsPartOfList) 選定: 部分設定を設定します。
void | setQuotationCfgsRefInstList(List quotationCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setQuotationCfgsRefList(List quotationCfgsRefList) 選定: 参照データを設定します。
void | setQuotationCfgsValueList(List quotationCfgsValueList) 選定: 特性値を設定します。
void | setQuotationCfgsVkList(List quotationCfgsVkList) 選定: バリアント条件キーを設定します。
void | setQuotationConditionsInList(List quotationConditionsInList) 条件を設定します。
void | setQuotationConditionsInXList(List quotationConditionsInXList) 受注における条件更新の通信項目を設定します。
void | setQuotationHeaderIn(HeaderIn quotationHeaderIn) 伝票ヘッダデータを設定します。
void | setQuotationHeaderInX(HeaderInX quotationHeaderInX) 伝票ヘッダチェックボックスを設定します。
void | setQuotationItemsInList(List quotationItemsInList) 明細データを設定します。
void | setQuotationItemsInXList(List quotationItemsInXList) 明細データチェックボックスを設定します。
void | setQuotationKeysList(List quotationKeysList) 参照キーの出力テーブルを設定します。
void | setQuotationPartnersList(List quotationPartnersList) 伝票取引先を設定します。
void | setQuotationSchedulesInList(List quotationSchedulesInList) 納入日程行データを設定します。
void | setQuotationSchedulesInXList(List quotationSchedulesInXList) 納入日程行データチェックボックスを設定します。
void | setQuotationTextList(List quotationTextList) テキストを設定します。
void | setSalesdocument(String salesdocument) 販売管理伝票番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 見積伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

QuotationCreateFromData2

public QuotationCreateFromData2()
コンストラクタ。

QuotationCreateFromData2

public QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

QuotationCreateFromData2

public QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getConvert

public String getConvert()
取引先機能/受注伝票タイプの変換を取得します。

戻り値:
convert 取引先機能/受注伝票タイプの変換

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getSalesdocumentin

public String getSalesdocumentin()
見積伝票番号を取得します。

戻り値:
salesdocumentin 見積伝票番号

getSalesdocument

public String getSalesdocument()
販売管理伝票番号を取得します。

戻り値:
salesdocument 販売管理伝票番号

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getQuotationHeaderInX

public HeaderInX getQuotationHeaderInX()
伝票ヘッダチェックボックスを取得します。

戻り値:
quotationHeaderInX 伝票ヘッダチェックボックス

getQuotationHeaderIn

public HeaderIn getQuotationHeaderIn()
伝票ヘッダデータを取得します。

戻り値:
quotationHeaderIn 伝票ヘッダデータ

getQuotationTextList

public List getQuotationTextList()
テキストを取得します。

戻り値:
quotationTextList テキスト

getQuotationSchedulesInXList

public List getQuotationSchedulesInXList()
納入日程行データチェックボックスを取得します。

戻り値:
quotationSchedulesInXList 納入日程行データチェックボックス

getQuotationSchedulesInList

public List getQuotationSchedulesInList()
納入日程行データを取得します。

戻り値:
quotationSchedulesInList 納入日程行データ

getQuotationPartnersList

public List getQuotationPartnersList()
伝票取引先を取得します。

戻り値:
quotationPartnersList 伝票取引先

getQuotationKeysList

public List getQuotationKeysList()
参照キーの出力テーブルを取得します。

戻り値:
quotationKeysList 参照キーの出力テーブル

getQuotationItemsInXList

public List getQuotationItemsInXList()
明細データチェックボックスを取得します。

戻り値:
quotationItemsInXList 明細データチェックボックス

getQuotationItemsInList

public List getQuotationItemsInList()
明細データを取得します。

戻り値:
quotationItemsInList 明細データ

getQuotationConditionsInXList

public List getQuotationConditionsInXList()
受注における条件更新の通信項目を取得します。

戻り値:
quotationConditionsInXList 受注における条件更新の通信項目

getQuotationConditionsInList

public List getQuotationConditionsInList()
条件を取得します。

戻り値:
quotationConditionsInList 条件

getQuotationCfgsVkList

public List getQuotationCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
quotationCfgsVkList 選定: バリアント条件キー

getQuotationCfgsValueList

public List getQuotationCfgsValueList()
選定: 特性値を取得します。

戻り値:
quotationCfgsValueList 選定: 特性値

getQuotationCfgsRefInstList

public List getQuotationCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
quotationCfgsRefInstList 選定: 参照明細/インスタンス

getQuotationCfgsRefList

public List getQuotationCfgsRefList()
選定: 参照データを取得します。

戻り値:
quotationCfgsRefList 選定: 参照データ

getQuotationCfgsPartOfList

public List getQuotationCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
quotationCfgsPartOfList 選定: 部分設定

getQuotationCfgsInstList

public List getQuotationCfgsInstList()
選定: インスタンスを取得します。

戻り値:
quotationCfgsInstList 選定: インスタンス

getQuotationCfgsBlobList

public List getQuotationCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
quotationCfgsBlobList 選定: BLOB 内部データ (SCE)

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setConvert

public void setConvert(String convert)
取引先機能/受注伝票タイプの変換を設定します。

パラメータ:
convert - 取引先機能/受注伝票タイプの変換

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
見積伝票番号を設定します。

パラメータ:
salesdocumentin - 見積伝票番号

setSalesdocument

public void setSalesdocument(String salesdocument)
販売管理伝票番号を設定します。

パラメータ:
salesdocument - 販売管理伝票番号

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setQuotationHeaderInX

public void setQuotationHeaderInX(HeaderInX quotationHeaderInX)
伝票ヘッダチェックボックスを設定します。

パラメータ:
quotationHeaderInX - 伝票ヘッダチェックボックス

setQuotationHeaderIn

public void setQuotationHeaderIn(HeaderIn quotationHeaderIn)
伝票ヘッダデータを設定します。

パラメータ:
quotationHeaderIn - 伝票ヘッダデータ

setQuotationTextList

public void setQuotationTextList(List quotationTextList)
テキストを設定します。

パラメータ:
quotationTextList - テキスト

setQuotationSchedulesInXList

public void setQuotationSchedulesInXList(List quotationSchedulesInXList)
納入日程行データチェックボックスを設定します。

パラメータ:
quotationSchedulesInXList - 納入日程行データチェックボックス

setQuotationSchedulesInList

public void setQuotationSchedulesInList(List quotationSchedulesInList)
納入日程行データを設定します。

パラメータ:
quotationSchedulesInList - 納入日程行データ

setQuotationPartnersList

public void setQuotationPartnersList(List quotationPartnersList)
伝票取引先を設定します。

パラメータ:
quotationPartnersList - 伝票取引先

setQuotationKeysList

public void setQuotationKeysList(List quotationKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
quotationKeysList - 参照キーの出力テーブル

setQuotationItemsInXList

public void setQuotationItemsInXList(List quotationItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
quotationItemsInXList - 明細データチェックボックス

setQuotationItemsInList

public void setQuotationItemsInList(List quotationItemsInList)
明細データを設定します。

パラメータ:
quotationItemsInList - 明細データ

setQuotationConditionsInXList

public void setQuotationConditionsInXList(List quotationConditionsInXList)
受注における条件更新の通信項目を設定します。

パラメータ:
quotationConditionsInXList - 受注における条件更新の通信項目

setQuotationConditionsInList

public void setQuotationConditionsInList(List quotationConditionsInList)
条件を設定します。

パラメータ:
quotationConditionsInList - 条件

setQuotationCfgsVkList

public void setQuotationCfgsVkList(List quotationCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
quotationCfgsVkList - 選定: バリアント条件キー

setQuotationCfgsValueList

public void setQuotationCfgsValueList(List quotationCfgsValueList)
選定: 特性値を設定します。

パラメータ:
quotationCfgsValueList - 選定: 特性値

setQuotationCfgsRefInstList

public void setQuotationCfgsRefInstList(List quotationCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
quotationCfgsRefInstList - 選定: 参照明細/インスタンス

setQuotationCfgsRefList

public void setQuotationCfgsRefList(List quotationCfgsRefList)
選定: 参照データを設定します。

パラメータ:
quotationCfgsRefList - 選定: 参照データ

setQuotationCfgsPartOfList

public void setQuotationCfgsPartOfList(List quotationCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
quotationCfgsPartOfList - 選定: 部分設定

setQuotationCfgsInstList

public void setQuotationCfgsInstList(List quotationCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
quotationCfgsInstList - 選定: インスタンス

setQuotationCfgsBlobList

public void setQuotationCfgsBlobList(List quotationCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
quotationCfgsBlobList - 選定: BLOB 内部データ (SCE)

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 の使用

SalesOrderCreateFromDat2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderCreateFromDat2 の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderCreateFromDat2 のサブクラス
 class SalesOrderCreateFromDat2Controller
受注伝票登録コントローラクラス
機能は以下の通り
受注伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


OrderCcard (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス OrderCcard

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard
すべての実装インタフェース:
Serializable
public class OrderCcard
extends Object
implements Serializable

クレジットカードデータ情報クラス
機能は以下の通り

  • クレジットカードデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
OrderCcard()
クレジットカードデータ情報を作成します。
OrderCcard(int index)
クレジットカードデータ情報を作成します。
メソッドの概要
String | getAmountchan() 支払カード: 金額変更を取得します。
String | getAuthamount() 支払カード: 承認額を取得します。
String | getAuthCcNo() 支払カード: 承認番号を取得します。
String | getAuthDate() 支払カード: 承認日を取得します。
String | getAuthFlag() 支払カード: 振替権限を取得します。
String | getAuthortype() 支払カード: 承認タイプを取得します。
String | getAuthRefno() 支払カード: 決済代行会社の権限参照コードを取得します。
String | getAuthTime() 支払カード: 承認時刻を取得します。
String | getBillamount() 請求金額: 請求計画に請求日付が指定されている場合を取得します。
String | getCcCtrlField() カード照合額の制御項目を取得します。
String | getCcInUseSt() カード照合額の使用ステータスを取得します。
String | getCcLimited() 支払カード: 限度額を取得します。
String | getCcName() 支払カード: カード所有者の氏名を取得します。
String | getCcNumber() 支払カード: カード番号を取得します。
String | getCcReact() 支払カード: 権限確認に対する応答を取得します。
String | getCcReactT() 支払カード: 結果テキストを取得します。
String | getCcReAmount() BAPI インタフェースの通貨金額を取得します。
String | getCcSeqNo() 支払カード: 支払カード - 接尾辞を取得します。
String | getCcStatEx() 支払カード: 外部システム呼出時のステータスを取得します。
String | getCcType() 支払カードタイプ: カードタイプを取得します。
String | getCcValidT() 支払カード: 有効終了日を取得します。
String | getCcVerifValue() カード照合額を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDataorigin() 支払カード: 入力モードを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getMerchidcl() 支払カード: 決済代行会社のマーチャント IDを取得します。
String | getPreAuth() 支払カード: 事前承認を取得します。
String | getRadrcheck1() 支払カード: 住所チェックの結果 (住所結果)を取得します。
String | getRadrcheck2() 支払カード: 住所チェックの結果 (住所承認)を取得します。
String | getRadrcheck3() 支払カード: 住所チェックの結果 (郵便番号結果)を取得します。
String | getRcardcheck() 支払カード: カードチェックの結果 (返信コード)を取得します。
String | getVirtCard() チェックボックスを取得します。
void | setAmountchan(String amountchan) 支払カード: 金額変更を設定します。
void | setAuthamount(String authamount) 支払カード: 承認額を設定します。
void | setAuthCcNo(String authCcNo) 支払カード: 承認番号を設定します。
void | setAuthDate(String authDate) 支払カード: 承認日を設定します。
void | setAuthFlag(String authFlag) 支払カード: 振替権限を設定します。
void | setAuthortype(String authortype) 支払カード: 承認タイプを設定します。
void | setAuthRefno(String authRefno) 支払カード: 決済代行会社の権限参照コードを設定します。
void | setAuthTime(String authTime) 支払カード: 承認時刻を設定します。
void | setBillamount(String billamount) 請求金額: 請求計画に請求日付が指定されている場合を設定します。
void | setCcCtrlField(String ccCtrlField) カード照合額の制御項目を設定します。
void | setCcInUseSt(String ccInUseSt) カード照合額の使用ステータスを設定します。
void | setCcLimited(String ccLimited) 支払カード: 限度額を設定します。
void | setCcName(String ccName) 支払カード: カード所有者の氏名を設定します。
void | setCcNumber(String ccNumber) 支払カード: カード番号を設定します。
void | setCcReact(String ccReact) 支払カード: 権限確認に対する応答を設定します。
void | setCcReactT(String ccReactT) 支払カード: 結果テキストを設定します。
void | setCcReAmount(String ccReAmount) BAPI インタフェースの通貨金額を設定します。
void | setCcSeqNo(String ccSeqNo) 支払カード: 支払カード - 接尾辞を設定します。
void | setCcStatEx(String ccStatEx) 支払カード: 外部システム呼出時のステータスを設定します。
void | setCcType(String ccType) 支払カードタイプ: カードタイプを設定します。
void | setCcValidT(String ccValidT) 支払カード: 有効終了日を設定します。
void | setCcVerifValue(String ccVerifValue) カード照合額を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDataorigin(String dataorigin) 支払カード: 入力モードを設定します。
void | setGlAccount(String glAccount) G/L 勘定コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMerchidcl(String merchidcl) 支払カード: 決済代行会社のマーチャント IDを設定します。
void | setPreAuth(String preAuth) 支払カード: 事前承認を設定します。
void | setRadrcheck1(String radrcheck1) 支払カード: 住所チェックの結果 (住所結果)を設定します。
void | setRadrcheck2(String radrcheck2) 支払カード: 住所チェックの結果 (住所承認)を設定します。
void | setRadrcheck3(String radrcheck3) 支払カード: 住所チェックの結果 (郵便番号結果)を設定します。
void | setRcardcheck(String rcardcheck) 支払カード: カードチェックの結果 (返信コード)を設定します。
void | setVirtCard(String virtCard) チェックボックスを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

OrderCcard

public OrderCcard()
クレジットカードデータ情報を作成します。

OrderCcard

public OrderCcard(int index)
クレジットカードデータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getCcType

public String getCcType()
支払カードタイプ: カードタイプを取得します。

戻り値:
ccType 支払カードタイプ: カードタイプ

getCcNumber

public String getCcNumber()
支払カード: カード番号を取得します。

戻り値:
ccNumber 支払カード: カード番号

getCcValidT

public String getCcValidT()
支払カード: 有効終了日を取得します。

戻り値:
ccValidT 支払カード: 有効終了日

getCcName

public String getCcName()
支払カード: カード所有者の氏名を取得します。

戻り値:
ccName 支払カード: カード所有者の氏名

getBillamount

public String getBillamount()
請求金額: 請求計画に請求日付が指定されている場合を取得します。

戻り値:
billamount 請求金額: 請求計画に請求日付が指定されている場合

getAuthFlag

public String getAuthFlag()
支払カード: 振替権限を取得します。

戻り値:
authFlag 支払カード: 振替権限

getAuthamount

public String getAuthamount()
支払カード: 承認額を取得します。

戻り値:
authamount 支払カード: 承認額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getAuthDate

public String getAuthDate()
支払カード: 承認日を取得します。

戻り値:
authDate 支払カード: 承認日

getAuthTime

public String getAuthTime()
支払カード: 承認時刻を取得します。

戻り値:
authTime 支払カード: 承認時刻

getAuthCcNo

public String getAuthCcNo()
支払カード: 承認番号を取得します。

戻り値:
authCcNo 支払カード: 承認番号

getAuthRefno

public String getAuthRefno()
支払カード: 決済代行会社の権限参照コードを取得します。

戻り値:
authRefno 支払カード: 決済代行会社の権限参照コード

getCcReact

public String getCcReact()
支払カード: 権限確認に対する応答を取得します。

戻り値:
ccReact 支払カード: 権限確認に対する応答

getCcReAmount

public String getCcReAmount()
BAPI インタフェースの通貨金額を取得します。

戻り値:
ccReAmount BAPI インタフェースの通貨金額

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
glAccount G/L 勘定コード

getCcStatEx

public String getCcStatEx()
支払カード: 外部システム呼出時のステータスを取得します。

戻り値:
ccStatEx 支払カード: 外部システム呼出時のステータス

getCcReactT

public String getCcReactT()
支払カード: 結果テキストを取得します。

戻り値:
ccReactT 支払カード: 結果テキスト

getVirtCard

public String getVirtCard()
チェックボックスを取得します。

戻り値:
virtCard チェックボックス

getMerchidcl

public String getMerchidcl()
支払カード: 決済代行会社のマーチャント IDを取得します。

戻り値:
merchidcl 支払カード: 決済代行会社のマーチャント ID

getPreAuth

public String getPreAuth()
支払カード: 事前承認を取得します。

戻り値:
preAuth 支支払カード: 事前承認

getCcSeqNo

public String getCcSeqNo()
支払カード: 支払カード - 接尾辞を取得します。

戻り値:
ccSeqNo 支払カード: 支払カード - 接尾辞

getAmountchan

public String getAmountchan()
支払カード: 金額変更を取得します。

戻り値:
amountchan 支払カード: 金額変更

getAuthortype

public String getAuthortype()
支払カード: 承認タイプを取得します。

戻り値:
authortype 支払カード: 承認タイプ

getDataorigin

public String getDataorigin()
支払カード: 入力モードを取得します。

戻り値:
dataorigin 支払カード: 入力モード

getRadrcheck1

public String getRadrcheck1()
支払カード: 住所チェックの結果 (住所結果)を取得します。

戻り値:
radrcheck1 支払カード: 住所チェックの結果 (住所結果)

getRadrcheck2

public String getRadrcheck2()
支払カード: 住所チェックの結果 (住所承認)を取得します。

戻り値:
radrcheck2 支払カード: 住所チェックの結果 (住所承認)

getRadrcheck3

public String getRadrcheck3()
支払カード: 住所チェックの結果 (郵便番号結果)を取得します。

戻り値:
radrcheck3 支払カード: 住所チェックの結果 (郵便番号結果)

getRcardcheck

public String getRcardcheck()
支払カード: カードチェックの結果 (返信コード)を取得します。

戻り値:
rcardcheck 支払カード: カードチェックの結果 (返信コード)

getCcLimited

public String getCcLimited()
支払カード: 限度額を取得します。

戻り値:
ccLimited 支払カード: 限度額

getCcVerifValue

public String getCcVerifValue()
カード照合額を取得します。

戻り値:
ccVerifValue カード照合額

getCcCtrlField

public String getCcCtrlField()
カード照合額の制御項目を取得します。

戻り値:
ccCtrlField カード照合額の制御項目

getCcInUseSt

public String getCcInUseSt()
カード照合額の使用ステータスを取得します。

戻り値:
ccInUseSt カード照合額の使用ステータス

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setCcType

public void setCcType(String ccType)
支払カードタイプ: カードタイプを設定します。

パラメータ:
ccType - 支払カードタイプ: カードタイプ

setCcNumber

public void setCcNumber(String ccNumber)
支払カード: カード番号を設定します。

パラメータ:
ccNumber - 支払カード: カード番号

setCcValidT

public void setCcValidT(String ccValidT)
支払カード: 有効終了日を設定します。

パラメータ:
ccValidT - 支払カード: 有効終了日

setCcName

public void setCcName(String ccName)
支払カード: カード所有者の氏名を設定します。

パラメータ:
ccName - 支払カード: カード所有者の氏名

setBillamount

public void setBillamount(String billamount)
請求金額: 請求計画に請求日付が指定されている場合を設定します。

パラメータ:
billamount - 請求金額: 請求計画に請求日付が指定されている場合

setAuthFlag

public void setAuthFlag(String authFlag)
支払カード: 振替権限を設定します。

パラメータ:
authFlag - 支払カード: 振替権限

setAuthamount

public void setAuthamount(String authamount)
支払カード: 承認額を設定します。

パラメータ:
authamount - 支払カード: 承認額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setAuthDate

public void setAuthDate(String authDate)
支払カード: 承認日を設定します。

パラメータ:
authDate - 支払カード: 承認日

setAuthTime

public void setAuthTime(String authTime)
支払カード: 承認時刻を設定します。

パラメータ:
authTime - 支払カード: 承認時刻

setAuthCcNo

public void setAuthCcNo(String authCcNo)
支払カード: 承認番号を設定します。

パラメータ:
authCcNo - 支払カード: 承認番号

setAuthRefno

public void setAuthRefno(String authRefno)
支払カード: 決済代行会社の権限参照コードを設定します。

パラメータ:
authRefno - 支払カード: 決済代行会社の権限参照コード

setCcReact

public void setCcReact(String ccReact)
支払カード: 権限確認に対する応答を設定します。

パラメータ:
ccReact - 支払カード: 権限確認に対する応答

setCcReAmount

public void setCcReAmount(String ccReAmount)
BAPI インタフェースの通貨金額を設定します。

パラメータ:
ccReAmount - BAPI インタフェースの通貨金額

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します。

パラメータ:
glAccount - G/L 勘定コード

setCcStatEx

public void setCcStatEx(String ccStatEx)
支払カード: 外部システム呼出時のステータスを設定します。

パラメータ:
ccStatEx - 支払カード: 外部システム呼出時のステータス

setCcReactT

public void setCcReactT(String ccReactT)
支払カード: 結果テキストを設定します。

パラメータ:
ccReactT - 支払カード: 結果テキスト

setVirtCard

public void setVirtCard(String virtCard)
チェックボックスを設定します。

パラメータ:
virtCard - チェックボックス

setMerchidcl

public void setMerchidcl(String merchidcl)
支払カード: 決済代行会社のマーチャント IDを設定します。

パラメータ:
merchidcl - 支払カード: 決済代行会社のマーチャント ID

setPreAuth

public void setPreAuth(String preAuth)
支払カード: 事前承認を設定します。

パラメータ:
preAuth - 支払カード: 事前承認

setCcSeqNo

public void setCcSeqNo(String ccSeqNo)
支払カード: 支払カード - 接尾辞を設定します。

パラメータ:
ccSeqNo - 支払カード: 支払カード - 接尾辞

setAmountchan

public void setAmountchan(String amountchan)
支払カード: 金額変更を設定します。

パラメータ:
amountchan - 支払カード: 金額変更

setAuthortype

public void setAuthortype(String authortype)
支払カード: 承認タイプを設定します。

パラメータ:
authortype - 支払カード: 承認タイプ

setDataorigin

public void setDataorigin(String dataorigin)
支払カード: 入力モードを設定します。

パラメータ:
dataorigin - 支払カード: 入力モード

setRadrcheck1

public void setRadrcheck1(String radrcheck1)
支払カード: 住所チェックの結果 (住所結果)を設定します。

パラメータ:
radrcheck1 - 支払カード: 住所チェックの結果 (住所結果)

setRadrcheck2

public void setRadrcheck2(String radrcheck2)
支払カード: 住所チェックの結果 (住所承認)を設定します。

パラメータ:
radrcheck2 - 支払カード: 住所チェックの結果 (住所承認)

setRadrcheck3

public void setRadrcheck3(String radrcheck3)
支払カード: 住所チェックの結果 (郵便番号結果)を設定します。

パラメータ:
radrcheck3 - 支払カード: 住所チェックの結果 (郵便番号結果)

setRcardcheck

public void setRcardcheck(String rcardcheck)
支払カード: カードチェックの結果 (返信コード)を設定します。

パラメータ:
rcardcheck - 支払カード: カードチェックの結果 (返信コード)

setCcLimited

public void setCcLimited(String ccLimited)
支払カード: 限度額を設定します。

パラメータ:
ccLimited - 支払カード: 限度額

setCcVerifValue

public void setCcVerifValue(String ccVerifValue)
カード照合額を設定します。

パラメータ:
ccVerifValue - カード照合額

setCcCtrlField

public void setCcCtrlField(String ccCtrlField)
カード照合額の制御項目を設定します。

パラメータ:
ccCtrlField - カード照合額の制御項目

setCcInUseSt

public void setCcInUseSt(String ccInUseSt)
カード照合額の使用ステータスを設定します。

パラメータ:
ccInUseSt - カード照合額の使用ステータス

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス
OrderCcard
ParamOrderCcard
SalesOrderCreateFromDat2


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

クラスの概要
OrderCcard | クレジットカードデータ情報クラス 機能は以下の通り クレジットカードデータ情報を保持します。
ParamOrderCcard | クレジットカードデータ情報パラメータ設定クラス 機能は以下の通り クレジットカードデータ情報のパラメータを設定します。
SalesOrderCreateFromDat2 | 受注伝票登録情報クラス 機能は以下の通り 受注伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のクラス
SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamOrderCcard (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス ParamOrderCcard

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard
すべての実装インタフェース:
Serializable
public final class ParamOrderCcard
extends Object
implements Serializable

クレジットカードデータ情報パラメータ設定クラス
機能は以下の通り

  • クレジットカードデータ情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List orderCcardList) table(Export)情報からクレジットカードデータの値をセットします。
static void | setImportParam(BapiController bapiController, List orderCcardList) クレジットカードデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List orderCcardList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
クレジットカードデータに値をセットします。

パラメータ:
bapiController - BapiController
orderCcardList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List orderCcardList)
                           throws SAPGeneralSystemException
table(Export)情報からクレジットカードデータの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
orderCcardList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderCreateFromDat2 (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス SalesOrderCreateFromDat2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderCreateFromDat2Controller
public class SalesOrderCreateFromDat2
extends UpdateController
implements Serializable

受注伝票登録情報クラス
機能は以下の通り

  • 受注伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderCreateFromDat2()
コンストラクタ。
SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 変換: 取引先機能 + 受注伝票タイプを取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getOrderCcardList() クレジットカードデータを取得します。
List | getOrderCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getOrderCfgsInstList() 選定: インスタンスを取得します。
List | getOrderCfgsPartOfList() 選定: 部分設定を取得します。
List | getOrderCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getOrderCfgsRefList() 選定: 参照データを取得します。
List | getOrderCfgsValueList() 選定: 特性値を取得します。
List | getOrderCfgsVkList() 選定: バリアント条件キーを取得します。
List | getOrderConditionsInList() 条件を取得します。
List | getOrderConditionsInXList() 条件チェックボックスを取得します。
HeaderIn | getOrderHeaderIn() 受注伝票ヘッダを取得します。
HeaderInX | getOrderHeaderInX() 受注伝票チェックリストを取得します。
List | getOrderItemsInList() 明細データを取得します。
List | getOrderItemsInXList() 明細データチェックボックスを取得します。
List | getOrderKeysList() 参照キーの出力テーブルを取得します。
List | getOrderPartnersList() 伝票取引先を取得します。
List | getOrderSchedulesInList() 納入日程行データを取得します。
List | getOrderSchedulesInXList() 納入日程行データチェックボックスを取得します。
List | getOrderTextList() テキストを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
String | getSalesdocument() 生成された伝票の番号を取得します。
String | getSalesdocumentin() 販売管理伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 変換: 取引先機能 + 受注伝票タイプを設定します。
void | setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setOrderCcardList(List orderCcardList) クレジットカードデータを設定します。
void | setOrderCfgsBlobList(List orderCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setOrderCfgsInstList(List orderCfgsInstList) 選定: インスタンスを設定します。
void | setOrderCfgsPartOfList(List orderCfgsPartOfList) 選定: 部分設定を設定します。
void | setOrderCfgsRefInstList(List orderCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setOrderCfgsRefList(List orderCfgsRefList) 選定: 参照データを設定します。
void | setOrderCfgsValueList(List orderCfgsValueList) 選定: 特性値を設定します。
void | setOrderCfgsVkList(List orderCfgsVkList) 選定: バリアント条件キーを設定します。
void | setOrderConditionsInList(List orderConditionsInList) 条件を設定します。
void | setOrderConditionsInXList(List orderConditionsInXList) 条件チェックボックスを設定します。
void | setOrderHeaderIn(HeaderIn orderHeaderIn) 受注伝票ヘッダを設定します。
void | setOrderHeaderInX(HeaderInX orderHeaderInX) 受注伝票チェックリストを設定します。
void | setOrderItemsInList(List orderItemsInList) 明細データを設定します。
void | setOrderItemsInXList(List orderItemsInXList) 明細データチェックボックスを設定します。
void | setOrderKeysList(List orderKeysList) 参照キーの出力テーブルを設定します。
void | setOrderPartnersList(List orderPartnersList) 伝票取引先を設定します。
void | setOrderSchedulesInList(List orderSchedulesInList) 納入日程行データを設定します。
void | setOrderSchedulesInXList(List orderSchedulesInXList) 納入日程行データチェックボックスを設定します。
void | setOrderTextList(List orderTextList) テキストを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setSalesdocument(String salesdocument) 生成された伝票の番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 販売管理伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2()
コンストラクタ。

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesdocumentin

public String getSalesdocumentin()
販売管理伝票番号を取得します。

戻り値:
salesdocumentin 販売管理伝票番号

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getConvert

public String getConvert()
変換: 取引先機能 + 受注伝票タイプを取得します。

戻り値:
convert 変換: 取引先機能 + 受注伝票タイプ

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getSalesdocument

public String getSalesdocument()
生成された伝票の番号を取得します。

戻り値:
salesdocument 生成された伝票の番号

getOrderHeaderIn

public HeaderIn getOrderHeaderIn()
受注伝票ヘッダを取得します。

戻り値:
orderHeaderIn 受注伝票ヘッダ

getOrderHeaderInX

public HeaderInX getOrderHeaderInX()
受注伝票チェックリストを取得します。

戻り値:
orderHeaderInX 受注伝票チェックリスト

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getOrderItemsInXList

public List getOrderItemsInXList()
明細データチェックボックスを取得します。

戻り値:
orderItemsInXList 明細データチェックボックス

getOrderKeysList

public List getOrderKeysList()
参照キーの出力テーブルを取得します。

戻り値:
orderKeysList 参照キーの出力テーブル

getOrderPartnersList

public List getOrderPartnersList()
伝票取引先を取得します。

戻り値:
orderPartnersList 伝票取引先

getOrderSchedulesInList

public List getOrderSchedulesInList()
納入日程行データを取得します。

戻り値:
orderSchedulesInList 納入日程行データ

getOrderSchedulesInXList

public List getOrderSchedulesInXList()
納入日程行データチェックボックスを取得します。

戻り値:
orderSchedulesInXList 納入日程行データチェックボックス

getOrderTextList

public List getOrderTextList()
テキストを取得します。

戻り値:
orderTextList テキスト

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

getOrderCcardList

public List getOrderCcardList()
クレジットカードデータを取得します。

戻り値:
orderCcardList クレジットカードデータ

getOrderCfgsBlobList

public List getOrderCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
orderCfgsBlobList 選定: BLOB 内部データ (SCE)

getOrderCfgsInstList

public List getOrderCfgsInstList()
選定: インスタンスを取得します。

戻り値:
orderCfgsInstList 選定: インスタンス

getOrderCfgsPartOfList

public List getOrderCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
orderCfgsPartOfList 選定: 部分設定

getOrderCfgsRefList

public List getOrderCfgsRefList()
選定: 参照データを取得します。

戻り値:
orderCfgsRefList 選定: 参照データ

getOrderCfgsRefInstList

public List getOrderCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
orderCfgsRefInstList 選定: 参照明細/インスタンス

getOrderCfgsValueList

public List getOrderCfgsValueList()
選定: 特性値を取得します。

戻り値:
orderCfgsValueList 選定: 特性値

getOrderCfgsVkList

public List getOrderCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
orderCfgsVkList 選定: バリアント条件キー

getOrderConditionsInList

public List getOrderConditionsInList()
条件を取得します。

戻り値:
orderConditionsInList 条件

getOrderConditionsInXList

public List getOrderConditionsInXList()
条件チェックボックスを取得します。

戻り値:
orderConditionsInXList 条件チェックボックス

getOrderItemsInList

public List getOrderItemsInList()
明細データを取得します。

戻り値:
orderItemsInList 明細データ

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
販売管理伝票番号を設定します。

パラメータ:
salesdocumentin - 販売管理伝票番号

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setConvert

public void setConvert(String convert)
変換: 取引先機能 + 受注伝票タイプを設定します。

パラメータ:
convert - 変換: 取引先機能 + 受注伝票タイプ

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setSalesdocument

public void setSalesdocument(String salesdocument)
生成された伝票の番号を設定します。

パラメータ:
salesdocument - 生成された伝票の番号

setOrderHeaderIn

public void setOrderHeaderIn(HeaderIn orderHeaderIn)
受注伝票ヘッダを設定します。

パラメータ:
orderHeaderIn - 受注伝票ヘッダ

setOrderHeaderInX

public void setOrderHeaderInX(HeaderInX orderHeaderInX)
受注伝票チェックリストを設定します。

パラメータ:
orderHeaderInX - 受注伝票チェックリスト

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setOrderItemsInXList

public void setOrderItemsInXList(List orderItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
orderItemsInXList - 明細データチェックボックス

setOrderKeysList

public void setOrderKeysList(List orderKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
orderKeysList - 参照キーの出力テーブル

setOrderPartnersList

public void setOrderPartnersList(List orderPartnersList)
伝票取引先を設定します。

パラメータ:
orderPartnersList - 伝票取引先

setOrderSchedulesInList

public void setOrderSchedulesInList(List orderSchedulesInList)
納入日程行データを設定します。

パラメータ:
orderSchedulesInList - 納入日程行データ

setOrderSchedulesInXList

public void setOrderSchedulesInXList(List orderSchedulesInXList)
納入日程行データチェックボックスを設定します。

パラメータ:
orderSchedulesInXList - 納入日程行データチェックボックス

setOrderTextList

public void setOrderTextList(List orderTextList)
テキストを設定します。

パラメータ:
orderTextList - テキスト

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

setOrderCcardList

public void setOrderCcardList(List orderCcardList)
クレジットカードデータを設定します。

パラメータ:
orderCcardList - クレジットカードデータ

setOrderCfgsBlobList

public void setOrderCfgsBlobList(List orderCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
orderCfgsBlobList - 選定: BLOB 内部データ (SCE)

setOrderCfgsInstList

public void setOrderCfgsInstList(List orderCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
orderCfgsInstList - 選定: インスタンス

setOrderCfgsPartOfList

public void setOrderCfgsPartOfList(List orderCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
orderCfgsPartOfList - 選定: 部分設定

setOrderCfgsRefList

public void setOrderCfgsRefList(List orderCfgsRefList)
選定: 参照データを設定します。

パラメータ:
orderCfgsRefList - 選定: 参照データ

setOrderCfgsRefInstList

public void setOrderCfgsRefInstList(List orderCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
orderCfgsRefInstList - 選定: 参照明細/インスタンス

setOrderCfgsValueList

public void setOrderCfgsValueList(List orderCfgsValueList)
選定: 特性値を設定します。

パラメータ:
orderCfgsValueList - 選定: 特性値

setOrderCfgsVkList

public void setOrderCfgsVkList(List orderCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
orderCfgsVkList - 選定: バリアント条件キー

setOrderConditionsInList

public void setOrderConditionsInList(List orderConditionsInList)
条件を設定します。

パラメータ:
orderConditionsInList - 条件

setOrderConditionsInXList

public void setOrderConditionsInXList(List orderConditionsInXList)
条件チェックボックスを設定します。

パラメータ:
orderConditionsInXList - 条件チェックボックス

setOrderItemsInList

public void setOrderItemsInList(List orderItemsInList)
明細データを設定します。

パラメータ:
orderItemsInList - 明細データ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList の使用

SalesOrderGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetList の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetList のサブクラス
 class SalesOrderGetListController
販売伝票一覧照会コントローラクラス
機能は以下の通り
販売伝票一覧の情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス
ParamSalesOrders
SalesOrderGetList
SalesOrders


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

クラスの概要
ParamSalesOrders | 得意先受注テーブル情報パラメータ設定クラス 機能は以下の通り 得意先受注テーブル情報のパラメータを設定します。
SalesOrderGetList | 販売伝票一覧照会情報クラス 機能は以下の通り 販売伝票一覧照会情報を保持します。
SalesOrders | 得意先受注テーブル情報クラス 機能は以下の通り 得意先受注テーブル情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のクラス
SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamSalesOrders (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス ParamSalesOrders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders
すべての実装インタフェース:
Serializable
public final class ParamSalesOrders
extends Object
implements Serializable

得意先受注テーブル情報パラメータ設定クラス
機能は以下の通り

  • 得意先受注テーブル情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List salesOrdersList) table(Export)情報から得意先受注テーブル情報の値をセットします。
static void | setImportParam(BapiController bapiController, List salesOrdersList) 得意先受注テーブル情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List salesOrdersList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
得意先受注テーブル情報の値をセットします。

パラメータ:
bapiController - BapiController
salesOrdersList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List salesOrdersList)
                           throws SAPGeneralSystemException
table(Export)情報から得意先受注テーブル情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
salesOrdersList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetList (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス SalesOrderGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderGetListController
public class SalesOrderGetList
extends ReferenceController
implements Serializable

販売伝票一覧照会情報クラス
機能は以下の通り

  • 販売伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
販売伝票一覧照会情報を作成します。
メソッドの概要
String | getCustomerNumber() 得意先コードを取得します。
String | getDocumentDate() 登録日付を取得します。
String | getDocumentDateTo() 入力日付 (以前/以降)を取得します。
String | getMaterial() 品目コードを取得します。
MaterialEvg | getMaterialEvg() 品目コード(長)を取得します。
String | getPurchaseOrder() 得意先発注番号を取得します。
String | getPurchaseOrderNumber() 得意先発注番号1を取得します。
List | getSalesOrdersList() 得意先受注テーブルを取得します。
String | getSalesOrganization() 販売組織を取得します。
String | getTransactionGroup() 一文字フラグを取得します。
void | setCustomerNumber(String customerNumber) 得意先コードを設定します。
void | setDocumentDate(String documentDate) 登録日付を設定します。
void | setDocumentDateTo(String documentDateTo) 入力日付 (以前/以降)を設定します。
void | setExportParam(BapiController bapiController) 返却された販売伝票一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 販売伝票一覧の検索条件をセットします。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialEvg(MaterialEvg materialEvg) 品目コード(長)を設定します。
void | setPurchaseOrder(String purchaseOrder) 得意先発注番号を設定します。
void | setPurchaseOrderNumber(String purchaseOrderNumber) 得意先発注番号1を設定します。
void | setSalesOrdersList(List salesOrdersList) 得意先受注テーブルを設定します。
void | setSalesOrganization(String salesOrganization) 販売組織を設定します。
void | setTransactionGroup(String transactionGroup) 一文字フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetList

public SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

SalesOrderGetList

public SalesOrderGetList(String customerNumber,
                         String salesOrganisation,
                         String material,
                         String purchaseOrder,
                         String transactionGroup,
                         SapClient sapClient)
販売伝票一覧照会情報を作成します。

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ
sapClient - SAPクライアント
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
販売伝票一覧の検索条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された販売伝票一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getCustomerNumber

public String getCustomerNumber()
得意先コードを取得します。

戻り値:
customerNumber 得意先コード

getDocumentDate

public String getDocumentDate()
登録日付を取得します。

戻り値:
documentDate 登録日付

getDocumentDateTo

public String getDocumentDateTo()
入力日付 (以前/以降)を取得します。

戻り値:
documentDateTo 入力日付 (以前/以降)

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPurchaseOrder

public String getPurchaseOrder()
得意先発注番号を取得します。

戻り値:
purchaseOrder 得意先発注番号

getPurchaseOrderNumber

public String getPurchaseOrderNumber()
得意先発注番号1を取得します。

戻り値:
purchaseOrderNumber 得意先発注番号1

getSalesOrganization

public String getSalesOrganization()
販売組織を取得します。

戻り値:
salesOrganization 販売組織

getTransactionGroup

public String getTransactionGroup()
一文字フラグを取得します。

戻り値:
transactionGroup 一文字フラグ

getSalesOrdersList

public List getSalesOrdersList()
得意先受注テーブルを取得します。

戻り値:
salesOrdersList 得意先受注テーブル

getMaterialEvg

public MaterialEvg getMaterialEvg()
品目コード(長)を取得します。

戻り値:
materialEvg 品目コード(長)

setCustomerNumber

public void setCustomerNumber(String customerNumber)
得意先コードを設定します。

パラメータ:
customerNumber - 得意先コード

setDocumentDate

public void setDocumentDate(String documentDate)
登録日付を設定します。

パラメータ:
documentDate - 登録日付

setDocumentDateTo

public void setDocumentDateTo(String documentDateTo)
入力日付 (以前/以降)を設定します。

パラメータ:
documentDateTo - 入力日付 (以前/以降)

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPurchaseOrder

public void setPurchaseOrder(String purchaseOrder)
得意先発注番号を設定します。

パラメータ:
purchaseOrder - 得意先発注番号

setPurchaseOrderNumber

public void setPurchaseOrderNumber(String purchaseOrderNumber)
得意先発注番号1を設定します。

パラメータ:
purchaseOrderNumber - 得意先発注番号1

setSalesOrganization

public void setSalesOrganization(String salesOrganization)
販売組織を設定します。

パラメータ:
salesOrganization - 販売組織

setTransactionGroup

public void setTransactionGroup(String transactionGroup)
一文字フラグを設定します。

パラメータ:
transactionGroup - 一文字フラグ

setSalesOrdersList

public void setSalesOrdersList(List salesOrdersList)
得意先受注テーブルを設定します。

パラメータ:
salesOrdersList - 得意先受注テーブル

setMaterialEvg

public void setMaterialEvg(MaterialEvg materialEvg)
品目コード(長)を設定します。

パラメータ:
materialEvg - 品目コード(長)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrders (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス SalesOrders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders
すべての実装インタフェース:
Serializable
public class SalesOrders
extends Object
implements Serializable

得意先受注テーブル情報クラス
機能は以下の通り

  • 得意先受注テーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesOrders()
得意先受注テーブル情報を作成します。
SalesOrders(int index)
得意先受注テーブル情報を作成します。
メソッドの概要
String | getBaseUom() 基本数量単位を取得します。
String | getBatch() ロット番号を取得します。
String | getBillBlock() 販売管理伝票の請求ブロックを取得します。
String | getBUomIso() ISO コードでの基本数量単位を取得します。
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondUnit() 条件単位を取得します。
String | getCreationDate() レコード登録日を取得します。
String | getCreationTime() 登録時刻を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvQty() 出荷数量実績 (販売単位)を取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocStatus() 伝票ステータスを取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getGiDate() 出庫日付を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 明細番号 (販売管理伝票)を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatExt() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMatGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMatVers() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getName() 名称 1を取得します。
String | getNetPrice() 正味価格を取得します。
String | getNetValHd() 受注正味額 (伝票通貨)を取得します。
String | getNetValue() 伝票通貨による正味額を取得します。
String | getOrdReason() 受注理由 (取引理由)を取得します。
String | getPlant() プラントを取得します。
String | getPurchNo() 得意先発注番号を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getReqDate() 指定納期を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesGrp() 営業グループを取得します。
String | getSalesOff() 営業所を取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSdDoc() 販売管理伝票番号を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSoldTo() 受注先を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getSUnitIso() ISO コードによる販売単位を取得します。
String | getValidFrom() 見積または基本契約の有効開始日を取得します。
String | getValidTo() 見積または基本契約有効終了日を取得します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setBillBlock(String billBlock) 販売管理伝票の請求ブロックを設定します。
void | setBUomIso(String bUomIso) ISO コードでの基本数量単位を設定します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCreationDate(String creationDate) レコード登録日を設定します。
void | setCreationTime(String creationTime) 登録時刻を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvQty(String dlvQty) 出荷数量実績 (販売単位)を設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocStatus(String docStatus) 伝票ステータスを設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setGiDate(String giDate) 出庫日付を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 明細番号 (販売管理伝票)を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatExt(String matExt) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMatGuid(String matGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMatVers(String matVers) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setName(String name) 名称 1を設定します。
void | setNetPrice(String netPrice) 正味価格を設定します。
void | setNetValHd(String netValHd) 受注正味額 (伝票通貨)を設定します。
void | setNetValue(String netValue) 伝票通貨による正味額を設定します。
void | setOrdReason(String ordReason) 受注理由 (取引理由)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPurchNo(String purchNo) 得意先発注番号を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setReasonRej(String reasonRej) 見積および受注の拒否理由を設定します。
void | setReqDate(String reqDate) 指定納期を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesGrp(String salesGrp) 営業グループを設定します。
void | setSalesOff(String salesOff) 営業所を設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSdDoc(String sdDoc) 販売管理伝票番号を設定します。
void | setShipPoint(String shipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSoldTo(String soldTo) 受注先を設定します。
void | setStoreLoc(String storeLoc) 保管場所を設定します。
void | setSUnitIso(String sUnitIso) ISO コードによる販売単位を設定します。
void | setValidFrom(String validFrom) 見積または基本契約の有効開始日を設定します。
void | setValidTo(String validTo) 見積または基本契約有効終了日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrders

public SalesOrders()
得意先受注テーブル情報を作成します。

SalesOrders

public SalesOrders(int index)
得意先受注テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSdDoc

public String getSdDoc()
販売管理伝票番号を取得します。

戻り値:
sdDoc 販売管理伝票番号

getItmNumber

public String getItmNumber()
明細番号 (販売管理伝票)を取得します。

戻り値:
itmNumber 明細番号 (販売管理伝票)

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getReqDate

public String getReqDate()
指定納期を取得します。

戻り値:
reqDate 指定納期

getPurchNo

public String getPurchNo()
得意先発注番号を取得します。

戻り値:
purchNo 得意先発注番号

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getValidFrom

public String getValidFrom()
見積または基本契約の有効開始日を取得します。

戻り値:
validFrom 見積または基本契約の有効開始日

getValidTo

public String getValidTo()
見積または基本契約有効終了日を取得します。

戻り値:
validTo 見積または基本契約有効終了日

getBillBlock

public String getBillBlock()
販売管理伝票の請求ブロックを取得します。

戻り値:
billBlock 販売管理伝票の請求ブロック

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
soldTo 受注先

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getDlvQty

public String getDlvQty()
出荷数量実績 (販売単位)を取得します。

戻り値:
dlvQty 出荷数量実績 (販売単位)

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getNetPrice

public String getNetPrice()
正味価格を取得します。

戻り値:
netPrice 正味価格

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getNetValHd

public String getNetValHd()
受注正味額 (伝票通貨)を取得します。

戻り値:
netValHd 受注正味額 (伝票通貨)

getNetValue

public String getNetValue()
伝票通貨による正味額を取得します。

戻り値:
netValue 伝票通貨による正味額

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getDocStatus

public String getDocStatus()
伝票ステータスを取得します。

戻り値:
docStatus 伝票ステータス

getSalesGrp

public String getSalesGrp()
営業グループを取得します。

戻り値:
salesGrp 営業グループ

getSalesOff

public String getSalesOff()
営業所を取得します。

戻り値:
salesOff 営業所

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
shipPoint 出荷ポイント/入荷ポイント

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
giDate 出庫日付

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
storeLoc 保管場所

getOrdReason

public String getOrdReason()
受注理由 (取引理由)を取得します。

戻り値:
ordReason 受注理由 (取引理由)

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
reasonRej 見積および受注の拒否理由

getBUomIso

public String getBUomIso()
ISO コードでの基本数量単位を取得します。

戻り値:
bUomIso ISO コードでの基本数量単位

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getSUnitIso

public String getSUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
sUnitIso ISO コードによる販売単位

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getMatExt

public String getMatExt()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
matExt 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMatGuid

public String getMatGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
matGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMatVers

public String getMatVers()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
matVers 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getCreationDate

public String getCreationDate()
レコード登録日を取得します。

戻り値:
creationDate レコード登録日

getCreationTime

public String getCreationTime()
登録時刻を取得します。

戻り値:
creationTime 登録時刻

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSdDoc

public void setSdDoc(String sdDoc)
販売管理伝票番号を設定します。

パラメータ:
sdDoc - 販売管理伝票番号

setItmNumber

public void setItmNumber(String itmNumber)
明細番号 (販売管理伝票)を設定します。

パラメータ:
itmNumber - 明細番号 (販売管理伝票)

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setReqDate

public void setReqDate(String reqDate)
指定納期を設定します。

パラメータ:
reqDate - 指定納期

setPurchNo

public void setPurchNo(String purchNo)
得意先発注番号を設定します。

パラメータ:
purchNo - 得意先発注番号

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setValidFrom

public void setValidFrom(String validFrom)
見積または基本契約の有効開始日を設定します。

パラメータ:
validFrom - 見積または基本契約の有効開始日

setValidTo

public void setValidTo(String validTo)
見積または基本契約有効終了日を設定します。

パラメータ:
validTo - 見積または基本契約有効終了日

setBillBlock

public void setBillBlock(String billBlock)
販売管理伝票の請求ブロックを設定します。

パラメータ:
billBlock - 販売管理伝票の請求ブロック

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setSoldTo

public void setSoldTo(String soldTo)
受注先を設定します。

パラメータ:
soldTo - 受注先

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setDlvQty

public void setDlvQty(String dlvQty)
出荷数量実績 (販売単位)を設定します。

パラメータ:
dlvQty - 出荷数量実績 (販売単位)

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setNetPrice

public void setNetPrice(String netPrice)
正味価格を設定します。

パラメータ:
netPrice - 正味価格

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setNetValHd

public void setNetValHd(String netValHd)
受注正味額 (伝票通貨)を設定します。

パラメータ:
netValHd - 受注正味額 (伝票通貨)

setNetValue

public void setNetValue(String netValue)
伝票通貨による正味額を設定します。

パラメータ:
netValue - 伝票通貨による正味額

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setDocStatus

public void setDocStatus(String docStatus)
伝票ステータスを設定します。

パラメータ:
docStatus - 伝票ステータス

setSalesGrp

public void setSalesGrp(String salesGrp)
営業グループを設定します。

パラメータ:
salesGrp - 営業グループ

setSalesOff

public void setSalesOff(String salesOff)
営業所を設定します。

パラメータ:
salesOff - 営業所

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setShipPoint

public void setShipPoint(String shipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
shipPoint - 出荷ポイント/入荷ポイント

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setGiDate

public void setGiDate(String giDate)
出庫日付を設定します。

パラメータ:
giDate - 出庫日付

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoreLoc

public void setStoreLoc(String storeLoc)
保管場所を設定します。

パラメータ:
storeLoc - 保管場所

setOrdReason

public void setOrdReason(String ordReason)
受注理由 (取引理由)を設定します。

パラメータ:
ordReason - 受注理由 (取引理由)

setReasonRej

public void setReasonRej(String reasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
reasonRej - 見積および受注の拒否理由

setBUomIso

public void setBUomIso(String bUomIso)
ISO コードでの基本数量単位を設定します。

パラメータ:
bUomIso - ISO コードでの基本数量単位

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setSUnitIso

public void setSUnitIso(String sUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
sUnitIso - ISO コードによる販売単位

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setMatExt

public void setMatExt(String matExt)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
matExt - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMatGuid

public void setMatGuid(String matGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
matGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMatVers

public void setMatVers(String matVers)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
matVers - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setCreationDate

public void setCreationDate(String creationDate)
レコード登録日を設定します。

パラメータ:
creationDate - レコード登録日

setCreationTime

public void setCreationTime(String creationTime)
登録時刻を設定します。

パラメータ:
creationTime - 登録時刻

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus の使用

SalesOrderGetStatus を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetStatus の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetStatus のサブクラス
 class SalesOrderGetStatusController
販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り
販売伝票ステータス一覧の情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス
ParamStatusInfo
SalesOrderGetStatus
StatusInfo


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラスの概要
ParamStatusInfo | ステータス情報パラメータ設定クラス 機能は以下の通り ステータス情報のパラメータを設定します。
SalesOrderGetStatus | 販売伝票ステータス一覧照会情報クラス 機能は以下の通り 販売伝票ステータス一覧照会情報を保持します。
StatusInfo | ステータス情報情報クラス 機能は以下の通り ステータス情報情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のクラス
SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamStatusInfo (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス ParamStatusInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo
すべての実装インタフェース:
Serializable
public final class ParamStatusInfo
extends Object
implements Serializable

ステータス情報パラメータ設定クラス
機能は以下の通り

  • ステータス情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List statusInfoList) table(Export)情報からステータス情報の値をセットします。
static void | setImportParam(BapiController bapiController, List statusInfoList) ステータス情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List statusInfoList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ステータス情報の値をセットします。

パラメータ:
bapiController - BapiController
statusInfoList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List statusInfoList)
                           throws SAPGeneralSystemException
table(Export)情報からステータス情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
statusInfoList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetStatus (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス SalesOrderGetStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderGetStatusController
public class SalesOrderGetStatus
extends ReferenceController
implements Serializable

販売伝票ステータス一覧照会情報クラス
機能は以下の通り

  • 販売伝票ステータス一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String salesdocument, SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
メソッドの概要
String | getSalesdocument() 販売管理伝票番号を取得します。
ArrayList | getStatusInfoList() ステータス情報を取得します。
void | setExportParam(BapiController bapiController) 返却された販売伝票ステータス一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 販売伝票ステータス一覧の検索条件をセットします。
void | setSalesdocument(String salesdocument) 販売管理伝票番号を設定します。
void | setStatusInfoList(ArrayList statusInfoList) ステータス情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetStatus

public SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

SalesOrderGetStatus

public SalesOrderGetStatus(String salesdocument,
                           SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント
salesdocument - 販売管理伝票番号
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
販売伝票ステータス一覧の検索条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された販売伝票ステータス一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesdocument

public String getSalesdocument()
販売管理伝票番号を取得します。

戻り値:
salesdocument 販売管理伝票番号

getStatusInfoList

public ArrayList getStatusInfoList()
ステータス情報を取得します。

戻り値:
statusInfoList ステータス情報

setSalesdocument

public void setSalesdocument(String salesdocument)
販売管理伝票番号を設定します。

パラメータ:
salesdocument - 販売管理伝票番号

setStatusInfoList

public void setStatusInfoList(ArrayList statusInfoList)
ステータス情報を設定します。

パラメータ:
statusInfoList - ステータス情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StatusInfo (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス StatusInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo
すべての実装インタフェース:
Serializable
public class StatusInfo
extends Object
implements Serializable

ステータス情報情報クラス
機能は以下の通り

  • ステータス情報情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StatusInfo()
ステータス情報情報を作成します。
StatusInfo(int index)
ステータス情報情報を作成します。
メソッドの概要
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondUnit() 条件単位を取得します。
String | getCreationDate() レコード登録日を取得します。
String | getCreationTime() 登録時刻を取得します。
String | getCumCfQty() 累積確認数量 (販売数量単位)を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDelivDate() 納入期日を取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvQty() 出荷数量実績 (販売単位)を取得します。
String | getDlvStatH() 全明細の出荷ステータスを取得します。
String | getDlvStatI() 明細の全体出荷ステータスを取得します。
String | getDlvUnitIso() ISO コードでの出荷単位の数量単位を取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocNumber() 販売伝票を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getNetPrice() 正味価格を取得します。
String | getNetValue() 伝票通貨での受注明細正味額を取得します。
String | getPoItmNo() 元となる購買発注の明細番号を取得します。
String | getPrcStatH() 伝票の全処理ステータスを取得します。
String | getPurchNo() 得意先発注番号を取得します。
String | getPurchNoC() 得意先発注番号を取得します｡
String | getReaForRe() 見積および受注の拒否理由を取得します｡
String | getRefQty() 基本数量単位による参照数量を取得します。
String | getReqDate() 納入日程日付を取得します。
String | getReqDateH() 指定納入期日を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSUnitDlv() 出荷単位を取得します。
String | getSUnitIso() ISO コードによる販売単位を取得します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCreationDate(String creationDate) レコード登録日を設定します。
void | setCreationTime(String creationTime) 登録時刻を設定します。
void | setCumCfQty(String cumCfQty) 累積確認数量 (販売数量単位)を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDelivDate(String delivDate) 納入期日を設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivNumb(String delivNumb) 出荷伝票を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvQty(String dlvQty) 出荷数量実績 (販売単位)を設定します。
void | setDlvStatH(String dlvStatH) 全明細の出荷ステータスを設定します。
void | setDlvStatI(String dlvStatI) 明細の全体出荷ステータスを設定します。
void | setDlvUnitIso(String dlvUnitIso) ISO コードでの出荷単位の数量単位を設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setNetPrice(String netPrice) 正味価格を設定します。
void | setNetValue(String netValue) 伝票通貨での受注明細正味額を設定します。
void | setPoItmNo(String poItmNo) 元となる購買発注の明細番号を設定します。
void | setPrcStatH(String prcStatH) 伝票の全処理ステータスを設定します。
void | setPurchNo(String purchNo) 得意先発注番号を設定します。
void | setPurchNoC(String purchNoC) 得意先発注番号を設定します｡
void | setReaForRe(String reaForRe) 見積および受注の拒否理由を設定します｡
void | setRefQty(String refQty) 基本数量単位による参照数量を設定します。
void | setReqDate(String reqDate) 納入日程日付を設定します。
void | setReqDateH(String reqDateH) 指定納入期日を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSUnitDlv(String sUnitDlv) 出荷単位を設定します。
void | setSUnitIso(String sUnitIso) ISO コードによる販売単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StatusInfo

public StatusInfo()
ステータス情報情報を作成します。

StatusInfo

public StatusInfo(int index)
ステータス情報情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getPurchNo

public String getPurchNo()
得意先発注番号を取得します。

戻り値:
purchNo 得意先発注番号

getPrcStatH

public String getPrcStatH()
伝票の全処理ステータスを取得します。

戻り値:
prcStatH 伝票の全処理ステータス

getDlvStatH

public String getDlvStatH()
全明細の出荷ステータスを取得します。

戻り値:
dlvStatH 全明細の出荷ステータス

getReqDateH

public String getReqDateH()
指定納入期日を取得します。

戻り値:
reqDateH 指定納入期日

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getReqDate

public String getReqDate()
納入日程日付を取得します。

戻り値:
reqDate 納入日程日付

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getCumCfQty

public String getCumCfQty()
累積確認数量 (販売数量単位)を取得します。

戻り値:
cumCfQty 累積確認数量 (販売数量単位)

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getNetValue

public String getNetValue()
伝票通貨での受注明細正味額を取得します。

戻り値:
netValue 伝票通貨での受注明細正味額

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getNetPrice

public String getNetPrice()
正味価格を取得します。

戻り値:
netPrice 正味価格

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getDlvStatI

public String getDlvStatI()
明細の全体出荷ステータスを取得します。

戻り値:
dlvStatI 明細の全体出荷ステータス

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
delivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getDelivDate

public String getDelivDate()
納入期日を取得します。

戻り値:
delivDate 納入期日

getDlvQty

public String getDlvQty()
出荷数量実績 (販売単位)を取得します。

戻り値:
dlvQty 出荷数量実績 (販売単位)

getRefQty

public String getRefQty()
基本数量単位による参照数量を取得します。

戻り値:
refQty 基本数量単位による参照数量

getSUnitIso

public String getSUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
sUnitIso ISO コードによる販売単位

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getPoItmNo

public String getPoItmNo()
元となる購買発注の明細番号を取得します。

戻り値:
poItmNo 元となる購買発注の明細番号

getCreationDate

public String getCreationDate()
レコード登録日を取得します。

戻り値:
creationDate レコード登録日

getCreationTime

public String getCreationTime()
登録時刻を取得します。

戻り値:
creationTime 登録時刻

getSUnitDlv

public String getSUnitDlv()
出荷単位を取得します。

戻り値:
sUnitDlv 出荷単位

getDlvUnitIso

public String getDlvUnitIso()
ISO コードでの出荷単位の数量単位を取得します。

戻り値:
dlvUnitIso ISO コードでの出荷単位の数量単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

getReaForRe

public String getReaForRe()
見積および受注の拒否理由を取得します｡

戻り値:
reaForRe 見積および受注の拒否理由

getPurchNoC

public String getPurchNoC()
得意先発注番号を取得します｡

戻り値:
reaForRe 得意先発注番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setPurchNo

public void setPurchNo(String purchNo)
得意先発注番号を設定します。

パラメータ:
purchNo - 得意先発注番号

setPrcStatH

public void setPrcStatH(String prcStatH)
伝票の全処理ステータスを設定します。

パラメータ:
prcStatH - 伝票の全処理ステータス

setDlvStatH

public void setDlvStatH(String dlvStatH)
全明細の出荷ステータスを設定します。

パラメータ:
dlvStatH - 全明細の出荷ステータス

setReqDateH

public void setReqDateH(String reqDateH)
指定納入期日を設定します。

パラメータ:
reqDateH - 指定納入期日

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setReqDate

public void setReqDate(String reqDate)
納入日程日付を設定します。

パラメータ:
reqDate - 納入日程日付

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setCumCfQty

public void setCumCfQty(String cumCfQty)
累積確認数量 (販売数量単位)を設定します。

パラメータ:
cumCfQty - 累積確認数量 (販売数量単位)

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setNetValue

public void setNetValue(String netValue)
伝票通貨での受注明細正味額を設定します。

パラメータ:
netValue - 伝票通貨での受注明細正味額

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setNetPrice

public void setNetPrice(String netPrice)
正味価格を設定します。

パラメータ:
netPrice - 正味価格

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setDlvStatI

public void setDlvStatI(String dlvStatI)
明細の全体出荷ステータスを設定します。

パラメータ:
dlvStatI - 明細の全体出荷ステータス

setDelivNumb

public void setDelivNumb(String delivNumb)
出荷伝票を設定します。

パラメータ:
delivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setDelivDate

public void setDelivDate(String delivDate)
納入期日を設定します。

パラメータ:
delivDate - 納入期日

setDlvQty

public void setDlvQty(String dlvQty)
出荷数量実績 (販売単位)を設定します。

パラメータ:
dlvQty - 出荷数量実績 (販売単位)

setRefQty

public void setRefQty(String refQty)
基本数量単位による参照数量を設定します。

パラメータ:
refQty - 基本数量単位による参照数量

setSUnitIso

public void setSUnitIso(String sUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
sUnitIso - ISO コードによる販売単位

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setPoItmNo

public void setPoItmNo(String poItmNo)
元となる購買発注の明細番号を設定します。

パラメータ:
poItmNo - 元となる購買発注の明細番号

setCreationDate

public void setCreationDate(String creationDate)
レコード登録日を設定します。

パラメータ:
creationDate - レコード登録日

setCreationTime

public void setCreationTime(String creationTime)
登録時刻を設定します。

パラメータ:
creationTime - 登録時刻

setSUnitDlv

public void setSUnitDlv(String sUnitDlv)
出荷単位を設定します。

パラメータ:
sUnitDlv - 出荷単位

setDlvUnitIso

public void setDlvUnitIso(String dlvUnitIso)
ISO コードでの出荷単位の数量単位を設定します。

パラメータ:
dlvUnitIso - ISO コードでの出荷単位の数量単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

setReaForRe

public void setReaForRe(String reaForRe)
見積および受注の拒否理由を設定します｡

パラメータ:
reaForRe - 見積および受注の拒否理由

setPurchNoC

public void setPurchNoC(String purchNoC)
得意先発注番号を設定します｡

パラメータ:
purchNoC - 得意先発注番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocCreateMultipleController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocCreateMultipleController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple
                拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController
すべての実装インタフェース:
Serializable
public class BillingDocCreateMultipleController
extends BillingDocCreateMultiple
implements Serializable

請求伝票登録コントローラクラス
機能は以下の通り

  • 請求伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocCreateMultipleController()
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple から継承したメソッド
getBillingDataInList, getCCardDataInList, getConditionDataInList, getCreatorDataIn, getErrorsList, getPosting, getSuccessList, getTestrun, getTextDataInList, setBillingDataInList, setCCardDataInList, setConditionDataInList, setCreatorDataIn, setErrorsList, setExportParam, setImportParam, setPosting, setSuccessList, setTestrun, setTextDataInList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocCreateMultipleController

public BillingDocCreateMultipleController()
BillingDocCreateMultipleControllerのコンストラクタを生成します。

BillingDocCreateMultipleController

public BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

BillingDocCreateMultipleController

public BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocGetDetailController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController
すべての実装インタフェース:
Serializable
public class BillingDocGetDetailController
extends Object
implements Serializable

請求伝票詳細照会情報コントローラクラス
機能は以下の通り

  • 請求伝票詳細照会情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成
メソッドの概要
String | getBapiReturnErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage() 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
BillingDocumentDetail | getBillingDocumentDetail() 請求伝票に関する詳細情報を取得します。
void | setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail) 請求伝票に関する詳細情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BillingDocGetDetailController

public BillingDocGetDetailController(String billingDocument)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPSalesAppException,
                                     SAPSalesSystemException
コンストラクタ生成

パラメータ:
billingDocument - 処理予定の請求伝票数
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

BillingDocGetDetailController

public BillingDocGetDetailController(String billingDocument,
                                     SapClient sapClient)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPSalesAppException,
                                     SAPSalesSystemException
コンストラクタ生成

パラメータ:
billingDocument - 処理予定の請求伝票数
sapClient - SAPクライアント
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外
メソッドの詳細

getBillingDocumentDetail

public BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

戻り値:
billingDocumentDetail 請求伝票に関する詳細情報

setBillingDocumentDetail

public void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

パラメータ:
billingDocumentDetail - 請求伝票に関する詳細情報

getBapiReturnMessage

public String getBapiReturnMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getMessage()をご参照ください。

戻り値:
BAPI実行結果のすべてのメッセージ情報

getBapiReturnErrMessage

public String getBapiReturnErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getErrMessage()をご参照ください。

戻り値:
BAPI実行結果エラーとなった全てのメッセージ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BillingDocGetListController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList
                拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController
すべての実装インタフェース:
Serializable
public class BillingDocGetListController
extends BillingDocGetList
implements Serializable

請求伝票一覧照会情報コントローラクラス
機能は以下の通り

  • 請求伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetListController()
コンストラクタ生成
BillingDocGetListController(SapClient sapClient)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList から継承したメソッド
getBillingDocumentDetailListList, getRefDocRange, getSuccessList, setBillingDocumentDetailListList, setExportParam, setImportParam, setRefDocRange, setSuccessList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetListController

public BillingDocGetListController()
コンストラクタ生成

BillingDocGetListController

public BillingDocGetListController(String sign,
                                   String option,
                                   String refDocRow,
                                   String refDocHigh)
コンストラクタ生成

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号

BillingDocGetListController

public BillingDocGetListController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

BillingDocGetListController

public BillingDocGetListController(String sign,
                                   String option,
                                   String refDocRow,
                                   String refDocHigh,
                                   SapClient sapClient)
コンストラクタ生成

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InquiryCreateFromData2Controller (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス InquiryCreateFromData2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller
すべての実装インタフェース:
Serializable
public class InquiryCreateFromData2Controller
extends InquiryCreateFromData2
implements Serializable

引合伝票登録コントローラクラス
機能は以下の通り

  • 引合伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InquiryCreateFromData2Controller()
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getInquiryCfgsBlobList, getInquiryCfgsInstList, getInquiryCfgsPartOfList, getInquiryCfgsRefInstList, getInquiryCfgsRefList, getInquiryCfgsValueList, getInquiryCfgsVkList, getInquiryConditionsInList, getInquiryConditionsInXList, getInquiryHeaderIn, getInquiryHeaderInX, getInquiryItemsInList, getInquiryItemsInXList, getInquiryKeysList, getInquiryPartnersList, getInquirySchedulesInList, getInquirySchedulesInXList, getInquiryTextList, getIntNumberAssignment, getLogicSwitch, getPartnerAddressesList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setInquiryCfgsBlobList, setInquiryCfgsInstList, setInquiryCfgsPartOfList, setInquiryCfgsRefInstList, setInquiryCfgsRefList, setInquiryCfgsValueList, setInquiryCfgsVkList, setInquiryConditionsInList, setInquiryConditionsInXList, setInquiryHeaderIn, setInquiryHeaderInX, setInquiryItemsInList, setInquiryItemsInXList, setInquiryKeysList, setInquiryPartnersList, setInquirySchedulesInList, setInquirySchedulesInXList, setInquiryTextList, setIntNumberAssignment, setLogicSwitch, setPartnerAddressesList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller()
InquiryCreateFromData2Controllerのコンストラクタを生成します。

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales
クラス
BillingDocCreateMultipleController
BillingDocGetDetailController
BillingDocGetListController
InquiryCreateFromData2Controller
QuotationCreateFromData2Controller
SalesOrderCreateFromDat2Controller
SalesOrderGetListController
SalesOrderGetStatusController


jp.co.intra_mart.foundation.sap.module.sales (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales

クラスの概要
BillingDocCreateMultipleController | 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
BillingDocGetDetailController | 請求伝票詳細照会情報コントローラクラス 機能は以下の通り 請求伝票詳細照会情報を保持します。
BillingDocGetListController | 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
InquiryCreateFromData2Controller | 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
QuotationCreateFromData2Controller | 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
SalesOrderCreateFromDat2Controller | 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。
SalesOrderGetListController | 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
SalesOrderGetStatusController | 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。


jp.co.intra_mart.foundation.sap.module.sales クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales の使用

jp.co.intra_mart.foundation.sap.module.sales はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


QuotationCreateFromData2Controller (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス QuotationCreateFromData2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller
すべての実装インタフェース:
Serializable
public class QuotationCreateFromData2Controller
extends QuotationCreateFromData2
implements Serializable

見積伝票登録情報コントローラクラス
機能は以下の通り

  • 見積伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
QuotationCreateFromData2Controller()
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getIntNumberAssignment, getLogicSwitch, getPartnerAddressesList, getQuotationCfgsBlobList, getQuotationCfgsInstList, getQuotationCfgsPartOfList, getQuotationCfgsRefInstList, getQuotationCfgsRefList, getQuotationCfgsValueList, getQuotationCfgsVkList, getQuotationConditionsInList, getQuotationConditionsInXList, getQuotationHeaderIn, getQuotationHeaderInX, getQuotationItemsInList, getQuotationItemsInXList, getQuotationKeysList, getQuotationPartnersList, getQuotationSchedulesInList, getQuotationSchedulesInXList, getQuotationTextList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setIntNumberAssignment, setLogicSwitch, setPartnerAddressesList, setQuotationCfgsBlobList, setQuotationCfgsInstList, setQuotationCfgsPartOfList, setQuotationCfgsRefInstList, setQuotationCfgsRefList, setQuotationCfgsValueList, setQuotationCfgsVkList, setQuotationConditionsInList, setQuotationConditionsInXList, setQuotationHeaderIn, setQuotationHeaderInX, setQuotationItemsInList, setQuotationItemsInXList, setQuotationKeysList, setQuotationPartnersList, setQuotationSchedulesInList, setQuotationSchedulesInXList, setQuotationTextList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller()
QuotationCreateFromData2Controllerのコンストラクタを生成します。

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderCreateFromDat2Controller (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderCreateFromDat2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller
すべての実装インタフェース:
Serializable
public class SalesOrderCreateFromDat2Controller
extends SalesOrderCreateFromDat2
implements Serializable

受注伝票登録コントローラクラス
機能は以下の通り

  • 受注伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderCreateFromDat2Controller()
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getIntNumberAssignment, getLogicSwitch, getOrderCcardList, getOrderCfgsBlobList, getOrderCfgsInstList, getOrderCfgsPartOfList, getOrderCfgsRefInstList, getOrderCfgsRefList, getOrderCfgsValueList, getOrderCfgsVkList, getOrderConditionsInList, getOrderConditionsInXList, getOrderHeaderIn, getOrderHeaderInX, getOrderItemsInList, getOrderItemsInXList, getOrderKeysList, getOrderPartnersList, getOrderSchedulesInList, getOrderSchedulesInXList, getOrderTextList, getPartnerAddressesList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setIntNumberAssignment, setLogicSwitch, setOrderCcardList, setOrderCfgsBlobList, setOrderCfgsInstList, setOrderCfgsPartOfList, setOrderCfgsRefInstList, setOrderCfgsRefList, setOrderCfgsValueList, setOrderCfgsVkList, setOrderConditionsInList, setOrderConditionsInXList, setOrderHeaderIn, setOrderHeaderInX, setOrderItemsInList, setOrderItemsInXList, setOrderKeysList, setOrderPartnersList, setOrderSchedulesInList, setOrderSchedulesInXList, setOrderTextList, setPartnerAddressesList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller()
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetListController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController
すべての実装インタフェース:
Serializable
public class SalesOrderGetListController
extends SalesOrderGetList
implements Serializable

販売伝票一覧照会コントローラクラス
機能は以下の通り

  • 販売伝票一覧の情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetListController()
コンストラクタ生成
SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList から継承したメソッド
getCustomerNumber, getDocumentDate, getDocumentDateTo, getMaterial, getMaterialEvg, getPurchaseOrder, getPurchaseOrderNumber, getSalesOrdersList, getSalesOrganization, getTransactionGroup, setCustomerNumber, setDocumentDate, setDocumentDateTo, setExportParam, setImportParam, setMaterial, setMaterialEvg, setPurchaseOrder, setPurchaseOrderNumber, setSalesOrdersList, setSalesOrganization, setTransactionGroup, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetListController

public SalesOrderGetListController()
コンストラクタ生成

SalesOrderGetListController

public SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

SalesOrderGetListController

public SalesOrderGetListController(String customerNumber,
                                   String salesOrganisation,
                                   String material,
                                   String purchaseOrder,
                                   String transactionGroup)
コンストラクタ生成

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ

SalesOrderGetListController

public SalesOrderGetListController(String customerNumber,
                                   String salesOrganisation,
                                   String material,
                                   String purchaseOrder,
                                   String transactionGroup,
                                   SapClient sapClient)
コンストラクタ生成

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理アプリケーション例外
SAPSalesSystemException - 販売管理システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetStatusController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderGetStatusController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController
すべての実装インタフェース:
Serializable
public class SalesOrderGetStatusController
extends SalesOrderGetStatus
implements Serializable

販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り

  • 販売伝票ステータス一覧の情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetStatusController()
コンストラクタ生成
SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus から継承したメソッド
getSalesdocument, getStatusInfoList, setExportParam, setImportParam, setSalesdocument, setStatusInfoList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetStatusController

public SalesOrderGetStatusController()
コンストラクタ生成

SalesOrderGetStatusController

public SalesOrderGetStatusController(String salesdocument)
コンストラクタ生成

パラメータ:
salesdocument - 販売管理伝票番号

SalesOrderGetStatusController

public SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

SalesOrderGetStatusController

public SalesOrderGetStatusController(String salesdocument,
                                     SapClient sapClient)
コンストラクタ生成

パラメータ:
salesdocument - 販売管理伝票番号
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス AbstractController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ReferenceController, UpdateController
public class AbstractController
extends Object
implements Serializable

モジュール共通抽象コントローラクラス。

機能は以下の通り

  • BapiControllerの取得用メソッド
  • BAPI実行メッセージのセットするBapiController.executeBapi()実行メソッド
  • セットされたBAPI実行メッセージの取得

関連項目:
直列化された形式

フィールドの概要
protected String | bapiReturnErrMessage BAPI実行エラーメッセージ
protected String | bapiReturnMessage BAPI実行結果メッセージ
protected SapClient | sapClient SAPクライアント
コンストラクタの概要
protected | AbstractController() コンストラクタ。
protected | AbstractController(SapClient sapClient) コンストラクタ。
メソッドの概要
protected BapiController | createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected void | executeBapi(BapiController bapiController) 引数で指定された bapiController のexecuteBapiメソッドを実行します。
String | getBapiReturnErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage() 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sapClient

protected SapClient sapClient
SAPクライアント

bapiReturnErrMessage

protected String bapiReturnErrMessage
BAPI実行エラーメッセージ

bapiReturnMessage

protected String bapiReturnMessage
BAPI実行結果メッセージ

コンストラクタの詳細

AbstractController

protected AbstractController()
コンストラクタ。

AbstractController

protected AbstractController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

createBapiController

protected BapiController createBapiController(String propertyFileName)
                                       throws SAPGeneralSystemException,
                                              SAPAuthSystemException,
                                              SAPGeneralAppException
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

パラメータ:
propertyFileName - プロパティファイル名
戻り値:
BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

executeBapi

protected void executeBapi(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPAuthSystemException,
                           SAPAuthAppException,
                           SAPBapiReturnErrMessageExistException
引数で指定された bapiController のexecuteBapiメソッドを実行します。

引数で指定された bapiController のメソッドBapiController.executeBapi()を実行し、 実行後、BAPI実行エラーメッセージ、BAPI実行結果メッセージをセットします。 これらの値は getBapiReturnErrMessage()、 getBapiReturnMessage()で取得できます。 BAPI実行エラーメッセージが存在する場合、 SAPBapiReturnErrMessageExistExceptionがスローされます。

その他のスローされる例外やConnectionManagerを指定した場合の注意点等については、 BapiController.executeBapi()を参照して下さい。

パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
SAPAuthSystemException - 認証系システム例外処理
SAPAuthAppException - 認証系APIアプリケーション例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

getBapiReturnErrMessage

public String getBapiReturnErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getErrMessage()をご参照ください。

戻り値:
BAPI実行結果エラーとなった全てのメッセージ情報

getBapiReturnMessage

public String getBapiReturnMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getMessage()をご参照ください。

戻り値:
BAPI実行結果のすべてのメッセージ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module (imsap_bapi_for_erp60 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module
クラス
AbstractController
ReferenceController
UpdateController


jp.co.intra_mart.foundation.sap.module (imsap_bapi_for_erp60 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module

クラスの概要
AbstractController | モジュール共通抽象コントローラクラス。
ReferenceController | 参照系モジュール共通コントローラ親クラス。
UpdateController | 登録・更新系モジュール共通コントローラ親クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.module の使用 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module の使用

jp.co.intra_mart.foundation.sap.module を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReferenceController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス ReferenceController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BankList, BillingDocGetDetail, BillingDocGetList, BusinessAreaList, CommonCenterGrpGetDetail, CompanyList, ControllingAreaList, CostCenterList, CreditorGetDetail, DebtorGetDetail, ExchangeRateGetDetail, GlAccList, GoodsMvtGetItems, InternalOrderGetDetail, InternalOrderGetList, MaterialAvailability, MaterialGetAll, MaterialGetList, ProfitCenterList, ProjectGetInfo, PurchaseGetItemSrel, SalesOrderGetList, SalesOrderGetStatus, StdMaterialGetIntNumberList, SupplierDetail, SupplierExistenceCheck
public class ReferenceController
extends AbstractController
implements Serializable

参照系モジュール共通コントローラ親クラス。

このクラスは参照系モジュールに継承されることを期待しています。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
protected | ReferenceController() コンストラクタ。
protected | ReferenceController(SapClient sapClient) コンストラクタ。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReferenceController

protected ReferenceController()
コンストラクタ。

ReferenceController

protected ReferenceController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UpdateController (imsap_bapi_for_erp60 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス UpdateController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccEmployeePayPost, BillingDocCreateMultiple, GoodsMvtCreate, InquiryCreateFromData2, MaterialSaveReplica, PurchaseOrderPayPost, PurchaseRelease, QuotationCreateFromData2, SalesOrderCreateFromDat2
public class UpdateController
extends AbstractController
implements Serializable

登録・更新系モジュール共通コントローラ親クラス。

このクラスは登録・更新系モジュールに継承されることを期待しています。

関連項目:
直列化された形式

フィールドの概要
protected  ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
protected | UpdateController() コンストラクタ。
protected | UpdateController(ConnectionManager connectionManager) コンストラクタ。
protected | UpdateController(SapClient sapClient) コンストラクタ。
メソッドの概要
protected  BapiController createBapiController(String propertyFileName)
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connectionManager

protected ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

コンストラクタの詳細

UpdateController

protected UpdateController()
コンストラクタ。

UpdateController

protected UpdateController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト

UpdateController

protected UpdateController(ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
なお、AbstractController.executeBapi(jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController)実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】トランザクション処理が記述されているBAPIもあります。 その場合、AbstractController.executeBapi(BapiController)実行後に ここまでのコネクションマネージャーで実行したすべての処理がcommitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
connectionManager - コネクションマネージャー
メソッドの詳細

createBapiController

protected BapiController createBapiController(String propertyFileName)
                                       throws SAPGeneralSystemException,
                                              SAPAuthSystemException,
                                              SAPGeneralAppException
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

オーバーライド:
クラス AbstractController 内の createBapiController
パラメータ:
propertyFileName - プロパティファイル名
戻り値:
BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (imsap_bapi_for_erp60 6.1.14 API)

 すべてのクラス
AbstractController
AccEmployeePayPost
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
AllVersions
AllowedBusTract
Bank
BankController
BankList
BatchRa
BillingDataIn
BillingDocCreateMultiple
BillingDocCreateMultipleController
BillingDocGetDetail
BillingDocGetDetailController
BillingDocGetList
BillingDocGetListController
BillingDocumentDetail
BillingDocumentDetailList
BusinessArea
BusinessAreaController
BusinessAreaList
CCardDataIn
CfgsBlob
CfgsInst
CfgsPartOf
CfgsRef
CfgsRefInst
CfgsValue
CfgsVk
ClientData
ClientDataList
CommonCenterGrpGetDetail
Company
CompanyController
CompanyList
Cond
ConditionDataIn
ConditionsIn
ConditionsInX
ContractLimits
ContractService
ContractServiceAccount
ContractServiceText
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterGroupGetDetail
CostCenterGroupGetDetailController
CostCenterList
CreatorDataIn
CreditorGetDetail
CreditorGetDetailController
CurrencyAmount
DebtorGetDetail
DebtorGetDetailController
DeliveryAddress
DistributionChannelSelection
DocumentHeader
Errors
ExchRate
ExchangeRateGetDetail
ExchangeRateGetDetailController
ExpActivity
ExpMessage
ExpWbsElement
ExpWbsHierarchie
ExpWbsMilestone
ExportHeader
ExportItem
Extension
Extension1
ExtensionIn
ExtensionIn
ExtensionIn
ExtensionInX
ExtensionOut
ExtensionOut
Extensionin
ForecastParameters
ForecastParametersList
ForecastValues
GlAcc
GlAccController
GlAccList
GoodsMvtCode
GoodsMvtCreate
GoodsMvtCreateController
GoodsMvtGetItems
GoodsMvtGetItemsController
GoodsMvtHeader
GoodsMvtHeaderList
GoodsMvtHeadret
GoodsMvtItem
GoodsMvtItems
GoodsMvtRefEwm
GoodsMvtSerialNumber
GoodsMvtServPartData
HeadData
HeaderIn
HeaderInX
HierarchyNodes
HierarchyValues
ImpWbsElement
InquiryCreateFromData2
InquiryCreateFromData2Controller
InternalOrderGetDetail
InternalOrderGetDetailController
InternalOrderGetList
InternalOrderGetListController
InternationArticleNumbers
InternationalArtnos
ItemsIn
ItemsInX
Keys
Language
LifoValuationData
Limits
LogicSwitch
ManufacturerPartNumb
MasterData
MaterialAvailability
MaterialAvailabilityController
MaterialDescription
MaterialEvg
MaterialEvg
MaterialGetAll
MaterialGetAllController
MaterialGetList
MaterialGetListController
MaterialLongText
MaterialRa
MaterialSaveReplica
MaterialSaveReplicaController
MaterialShortDescsel
MaterialText
MatnrList
MatnrSelection
MoveTypeRa
OrderCcard
OrderList
ParamAccountGl
ParamAccountPayable
ParamAccountTax
ParamAllVersions
ParamBatchRa
ParamBillingDataIn
ParamBillingDocumentDetailList
ParamCCardDataIn
ParamCfgsBlob
ParamCfgsInst
ParamCfgsPartOf
ParamCfgsRef
ParamCfgsRefInst
ParamCfgsValue
ParamCfgsVk
ParamClientDataList
ParamCondHeader
ParamCondItem
ParamConditionDataIn
ParamConditionsIn
ParamConditionsInX
ParamContractLimits
ParamContractService
ParamContractServiceAccount
ParamContractServiceText
ParamCreatorDataIn
ParamCurrencyAmount
ParamDeliveryAddress
ParamDocumentHeader
ParamErrors
ParamExportHeader
ParamExportItem
ParamExtension
ParamExtension1
ParamExtensionIn
ParamExtensionIn
ParamExtensionInX
ParamExtensionin
ParamForecastParametersList
ParamForecastValues
ParamGoodsMvtCode
ParamGoodsMvtHeader
ParamGoodsMvtHeaderList
ParamGoodsMvtHeadret
ParamGoodsMvtItem
ParamGoodsMvtItems
ParamGoodsMvtRefEwm
ParamGoodsMvtSerialNumber
ParamGoodsMvtServPartData
ParamHeadData
ParamHeader
ParamHeaderIn
ParamHeaderInX
ParamHeaderText
ParamInternationalArtnos
ParamItem
ParamItemText
ParamItemsIn
ParamItemsInX
ParamKeys
ParamLimits
ParamLogicSwitch
ParamMaterialDescription
ParamMaterialEvg
ParamMaterialEvg
ParamMaterialLongText
ParamMaterialRa
ParamMoveTypeRa
ParamOrderCcard
ParamPartner
ParamPartnerAddresses
ParamPartners
ParamPlanningDataList
ParamPlantDataList
ParamPlantRa
ParamProfitSegment
ParamPrtData
ParamPstngDateRa
ParamPurchaseAccount
ParamPurchaseComponents
ParamPurchaseConfirmation
ParamPurchaseHistory
ParamPurchaseHistoryTotals
ParamPurchaseSchedule
ParamPurchaseShipping
ParamPurchaseShippingExp
ParamRefDocRange
ParamReturnMessages
ParamSalesDataList
ParamSalesOrders
ParamSchedulesIn
ParamSchedulesInX
ParamSender
ParamSpecStockRa
ParamStatusInfo
ParamStgeLocRa
ParamStorageLocationDataList
ParamStorageTypeDataList
ParamSuccess
ParamTaxClassifications
ParamText
ParamTextDataIn
ParamTotalConsumption
ParamTrEvTypeRa
ParamTravel
ParamTravelAmount
ParamUnitSofmeasure
ParamUnplndConsumption
ParamUserNameRa
ParamValuationDataList
ParamVendorAddress
ParamVendorRa
ParamVersions
ParamWarehouseNumberDataList
ParamWmdvex
ParamWmdvsx
Partner
PartnerAddresses
Partners
PlanningData
PlanningDataList
PlantData
PlantDataList
PlantRa
PlantSelection
ProductionResourceToolData
ProfitCenter
ProfitCenterController
ProfitCenterGrpGetDetail
ProfitCenterGrpGetDetailController
ProfitCenterList
ProfitSegment
ProjectDefinition
ProjectGetInfo
ProjectGetInfoController
PrtData
PstngDateRa
PurchaseAccount
PurchaseComponents
PurchaseConfirmation
PurchaseGetItemSrel
PurchaseGetItemSrelController
PurchaseHeader
PurchaseHeaderPost
PurchaseHeaders
PurchaseHistory
PurchaseHistoryTotals
PurchaseItem
PurchaseItemPost
PurchaseItems
PurchaseOrderPayPost
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseRelease
PurchaseReleaseController
PurchaseResetReleaseController
PurchaseSchedule
PurchaseShipping
PurchaseShippingExp
PurchaseText
QuotationCreateFromData2
QuotationCreateFromData2Controller
RefDocRange
ReferenceController
ReturnMessages
SAPAccountingAppException
SAPAccountingSystemException
SAPBapiReturnErrMessageExistException
SAPFinancialAppException
SAPFinancialSystemException
SAPModuleAppException
SAPModuleSystemException
SAPPurchaseAppException
SAPPurchaseSystemException
SAPSalesAppException
SAPSalesSystemException
SalesData
SalesDataList
SalesOrderCreateFromDat2
SalesOrderCreateFromDat2Controller
SalesOrderGetList
SalesOrderGetListController
SalesOrderGetStatus
SalesOrderGetStatusController
SalesOrders
SalesOrganisationSelection
SchedulesIn
SchedulesInX
Selection
Sender
SpecStockRa
StatusInfo
StdMaterialGetIntNumber
StdMaterialGetIntNumberController
StdMaterialGetIntNumberList
StgeLocRa
StorageLocationData
StorageLocationDataList
StorageLocationSelect
StorageTypeData
StorageTypeDataList
Success
SupplierDetail
SupplierExistenceCheck
SupplierExistenceCheckController
SupplierGetDetailController
SystemStatus
TaxClassifications
Text
TextDataIn
TotalConsumption
TrEvTypeRa
Travel
TravelAmount
UnitSofmeasure
UnplndConsumption
UpdateController
UserNameRa
UserStatus
ValuationData
ValuationDataList
VendorAddress
VendorRa
Versions
WarehouseNumberData
WarehouseNumberDataList
Wmdvex
Wmdvsx


定数フィールド値 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (imsap_bapi_for_erp60 6.1.14 API)

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし

A B C D E F G H I J K L M O P Q R S T U V W

A

AbstractController - class jp.co.intra_mart.foundation.sap.module.AbstractController.
モジュール共通抽象コントローラクラス。
AbstractController() - class jp.co.intra_mart.foundation.sap.module.AbstractController のコンストラクタ
コンストラクタ。
AbstractController(SapClient) - class jp.co.intra_mart.foundation.sap.module.AbstractController のコンストラクタ
コンストラクタ。
AccEmployeePayPost - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost.
伝票登録クラス
機能は以下の通り
伝票を登録します。
AccEmployeePayPost() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPost(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPost(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。
AccEmployeePayPostController - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
AccEmployeePayPostController() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPostController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPostController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバへデータを登録することが可能です。
AccountGl - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl.
G/L 勘定明細クラス
機能は以下の通り
G/L 勘定明細の情報を保持します。
AccountGl() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のコンストラクタ
G/L 勘定明細情報を作成します。
AccountGl(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のコンストラクタ
G/L 勘定明細情報を作成します。
AccountPayable - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable.
仕入先明細クラス
機能は以下の通り
仕入先明細の情報を保持します。
AccountPayable() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のコンストラクタ
仕入先明細情報を作成します。
AccountPayable(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のコンストラクタ
仕入先明細情報を作成します。
AccountTax - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax.
税明細クラス
機能は以下の通り
税明細の情報を保持します。
AccountTax() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のコンストラクタ
税明細情報を作成します｡
AccountTax(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のコンストラクタ
税明細情報を作成します｡
AllVersions - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions.
全バージョン管理情報クラス
機能は以下の通り
全バージョン管理情報を保持します。
AllVersions() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のコンストラクタ
バージョン管理を作成します。
AllVersions(int) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のコンストラクタ
出荷データを作成します。
AllowedBusTract - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract.
使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り
使用可能業務トランザクションのテーブル情報を保持します。
AllowedBusTract() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のコンストラクタ
使用可能業務トランザクションのテーブルを作成します。

B

Bank - class jp.co.intra_mart.foundation.sap.module.accounting.Bank.
銀行情報クラス
機能は以下の通り
銀行の情報を保持します。
Bank() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のコンストラクタ
銀行情報を作成します。
BankController - class jp.co.intra_mart.foundation.sap.module.accounting.BankController.
銀行コントローラクラス
機能は以下の通り
銀行の情報を取得します。
BankController() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(String, int, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankList - class jp.co.intra_mart.foundation.sap.module.accounting.BankList.
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BankList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のコンストラクタ
executeBapiを呼び出し銀行一覧を作成します。
BankList(String, int, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のコンストラクタ
executeBapiを呼び出し銀行一覧を作成します。
BatchRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa.
ロットの範囲情報クラス
機能は以下の通り
ロットの範囲情報を保持します。
BatchRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のコンストラクタ
ロットの範囲情報を作成します。
BatchRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のコンストラクタ
ロットの範囲情報を作成します。
BillingDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn.
処理予定明細データのテーブル情報クラス
機能は以下の通り
処理予定明細データのテーブル情報を保持します。
BillingDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のコンストラクタ
処理予定明細データのテーブル情報を作成します。
BillingDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のコンストラクタ
処理予定明細データのテーブル情報を作成します。
BillingDocCreateMultiple - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple.
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。
BillingDocCreateMultiple() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
請求伝票登録情報を作成します。
BillingDocCreateMultiple(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
BillingDocCreateMultiple(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
BillingDocCreateMultipleController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController.
請求伝票登録コントローラクラス
機能は以下の通り
請求伝票を登録します。
BillingDocCreateMultipleController() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocGetDetail - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail.
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。
BillingDocGetDetail(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のコンストラクタ
請求伝票詳細照会情報を作成します。
BillingDocGetDetailController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController.
請求伝票詳細照会情報コントローラクラス
機能は以下の通り
請求伝票詳細照会情報を保持します。
BillingDocGetDetailController(String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のコンストラクタ
コンストラクタ生成
BillingDocGetDetailController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のコンストラクタ
コンストラクタ生成
BillingDocGetList - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList.
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。
BillingDocGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のコンストラクタ
請求伝票一覧照会情報を作成します。
BillingDocGetList(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のコンストラクタ
請求伝票一覧照会情報を作成します。
BillingDocGetListController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController.
請求伝票一覧照会情報コントローラクラス
機能は以下の通り
請求伝票一覧照会情報を保持します。
BillingDocGetListController() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocumentDetail - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail.
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
BillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList.
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
BillingDocumentDetailList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BusinessArea - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea.
事業領域情報クラス
機能は以下の通り
事業領域の情報を保持します。
BusinessArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のコンストラクタ
事業領域情報を作成します。
BusinessAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController.
事業領域コントローラクラス
機能は以下の通り
事業領域の情報を取得します。
BusinessAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList.
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
BusinessAreaList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のコンストラクタ
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaList(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のコンストラクタ
executeBapiを呼び出し事業領域一覧を作成します。
bapiReturnErrMessage - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
BAPI実行エラーメッセージ
bapiReturnMessage - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
BAPI実行結果メッセージ

C

CCardDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn.
処理予定支払方法のテーブル情報クラス
機能は以下の通り
処理予定支払方法のテーブル情報を保持します。
CCardDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のコンストラクタ
処理予定支払方法のテーブル情報を作成します。
CCardDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のコンストラクタ
処理予定支払方法のテーブル情報を作成します。
CfgsBlob - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob.
選定: BLOB 内部データ (SCE)情報クラス
機能は以下の通り
選定: BLOB 内部データ (SCE)情報を保持します。
CfgsBlob() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のコンストラクタ
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsBlob(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のコンストラクタ
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst.
選定: インスタンス情報クラス
機能は以下の通り
選定: インスタンス情報を保持します。
CfgsInst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のコンストラクタ
選定: インスタンス情報を作成します。
CfgsInst(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のコンストラクタ
選定: インスタンス情報を作成します。
CfgsPartOf - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf.
選定: 部分設定情報クラス
機能は以下の通り
選定: 部分設定情報を保持します。
CfgsPartOf() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のコンストラクタ
選定: 部分設定情報を作成します。
CfgsPartOf(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のコンストラクタ
選定: 部分設定情報を作成します。
CfgsRef - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef.
選定: 参照データ情報クラス
機能は以下の通り
選定: 参照データ情報を保持します。
CfgsRef() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のコンストラクタ
選定: 参照データ情報を作成します。
CfgsRef(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のコンストラクタ
選定: 参照データ情報を作成します。
CfgsRefInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst.
選定: 参照明細/インスタンス情報クラス
機能は以下の通り
選定: 参照明細/インスタンス情報を保持します。
CfgsRefInst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のコンストラクタ
選定: 参照明細/インスタンス情報を作成します。
CfgsRefInst(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のコンストラクタ
選定: 参照明細/インスタンス情報を作成します。
CfgsValue - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue.
選定: 特性値情報クラス
機能は以下の通り
選定: 特性値情報を保持します。
CfgsValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のコンストラクタ
選定: 特性値情報を作成します。
CfgsValue(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のコンストラクタ
選定: 特性値情報を作成します。
CfgsVk - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk.
選定: バリアント条件キー情報クラス
機能は以下の通り
選定: バリアント条件キー情報を保持します。
CfgsVk() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のコンストラクタ
選定: バリアント条件キー情報を作成します。
CfgsVk(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のコンストラクタ
選定: バリアント条件キー情報を作成します。
ClientData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData.
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ClientData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList.
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。
ClientDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
CommonCenterGrpGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail.
原価・利益センタグループ情報取得共通クラス
機能は以下の通り
原価・利益センタグループ情報を取得します。
CommonCenterGrpGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ
センタグループ情報を作成
CommonCenterGrpGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ

CommonCenterGrpGetDetail(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ

Company - class jp.co.intra_mart.foundation.sap.module.accounting.Company.
会社情報クラス
機能は以下の通り
会社の情報を保持します。
Company() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のコンストラクタ
会社情報を作成します。
CompanyController - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController.
会社コントローラクラス
機能は以下の通り
会社の情報を取得します。
CompanyController() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyList - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList.
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
CompanyList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のコンストラクタ
executeBapiを呼び出し会社一覧を作成します。
Cond - class jp.co.intra_mart.foundation.sap.module.purchase.Cond.
条件情報クラス
機能は以下の通り
条件情報を保持します。
Cond() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のコンストラクタ
条件を作成します。
Cond(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のコンストラクタ
条件を作成します。
ConditionDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn.
処理予定条件のテーブル情報クラス
機能は以下の通り
処理予定条件のテーブル情報を保持します。
ConditionDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のコンストラクタ
処理予定条件のテーブル情報を作成します。
ConditionDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のコンストラクタ
処理予定条件のテーブル情報を作成します。
ConditionsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn.
条件情報クラス
機能は以下の通り
条件情報を保持します。
ConditionsIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のコンストラクタ
条件情報を作成します。
ConditionsIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のコンストラクタ
条件情報を作成します。
ConditionsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX.
受注における条件更新の通信項目情報クラス
機能は以下の通り
受注における条件更新の通信項目情報を保持します。
ConditionsInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のコンストラクタ
受注における条件更新の通信項目情報を作成します。
ConditionsInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のコンストラクタ
受注における条件更新の通信項目情報を作成します。
ContractLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits.
外注基本契約制限情報クラス
機能は以下の通り
外注基本契約情報を保持します。
ContractLimits() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のコンストラクタ
外注基本契約を作成します。
ContractLimits(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のコンストラクタ
外注基本契約を作成します。
ContractService - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService.
外注サービス情報クラス
機能は以下の通り
外注サービス情報を保持します。
ContractService() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のコンストラクタ
外注サービスを作成します。
ContractService(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のコンストラクタ
外注サービスを作成します。
ContractServiceAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount.
外注サービス勘定設定情報クラス
機能は以下の通り
外注サービス勘定設定情報を保持します。
ContractServiceAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のコンストラクタ
外注サービス勘定設定を作成します。
ContractServiceAccount(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のコンストラクタ
外注サービス勘定設定を作成します。
ContractServiceText - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText.
外注サービステキスト情報クラス
機能は以下の通り
外注サービステキスト情報を保持します。
ContractServiceText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のコンストラクタ
外注サービステキストを作成します。
ContractServiceText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のコンストラクタ
外注サービステキストを作成します。
ControllingArea - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea.
管理領域情報クラス
機能は以下の通り
管理領域の情報を保持します。
ControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のコンストラクタ
管理領域情報を作成します。
ControllingAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController.
管理領域コントローラクラス
機能は以下の通り
管理領域の情報を取得します。
ControllingAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList.
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
ControllingAreaList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のコンストラクタ
executeBapiを呼び出し管理領域一覧を作成します。
CostCenter - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter.
原価センタ情報クラス
機能は以下の通り
原価センタの情報を保持します。
CostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のコンストラクタ
原価センタ情報を取得します。
CostCenter(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のコンストラクタ
原価センタ情報を取得します。
CostCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController.
原価センタコントローラクラス
機能は以下の通り
原価センタの情報を取得します。
CostCenterController() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterGroupGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail.
原価センタグループ情報取得クラス
機能は以下の通り
原価センタグループ情報を取得します。
CostCenterGroupGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ
原価センタグループ情報を作成
CostCenterGroupGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ

CostCenterGroupGetDetail(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ

CostCenterGroupGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController.
原価センタグループコントローラクラス
機能は以下の通り
原価センタグループを取得します。
CostCenterGroupGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList.
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
CostCenterList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のコンストラクタ
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterList(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のコンストラクタ
executeBapiを呼び出し原価センタ一覧を作成します。
CreatorDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn.
取り込まれる日付の順序情報クラス
機能は以下の通り
取り込まれる日付の順序情報を保持します。
CreatorDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のコンストラクタ
取り込まれる日付の順序情報を作成します。
CreditorGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail.
仕入先詳細情報取得クラス
機能は以下の通り
仕入先詳細情報を取得します。
CreditorGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のコンストラクタ
仕入先詳細情報を作成
CreditorGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のコンストラクタ

CreditorGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController.
仕入先詳細コントローラクラス
機能は以下の通り
仕入先詳細を取得します。
CreditorGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ

CreditorGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ

CreditorGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
CurrencyAmount - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount.
明細通貨項目クラス
機能は以下の通り
明細通貨項目の情報を保持します。
CurrencyAmount() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のコンストラクタ
明細通貨項目情報を作成します。
CurrencyAmount(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のコンストラクタ
明細通貨項目情報を作成します。
connectionManager - class jp.co.intra_mart.foundation.sap.module.UpdateController の変数
コネクション(トランザクション)オブジェクト
createBapiController(String) - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
createBapiController(String) - class jp.co.intra_mart.foundation.sap.module.UpdateController のメソッド
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

D

DebtorGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail.
得意先詳細情報取得クラス
機能は以下の通り
得意先詳細情報を取得します。
DebtorGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のコンストラクタ
得意先詳細情報を作成
DebtorGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のコンストラクタ

DebtorGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController.
得意先詳細コントローラクラス
機能は以下の通り
得意先詳細を取得します。
DebtorGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ

DebtorGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ

DebtorGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
DeliveryAddress - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress.
入荷伝票アドレス情報クラス
機能は以下の通り
入荷伝票アドレス情報を保持します。
DeliveryAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のコンストラクタ
入荷伝票アドレスを作成します。
DeliveryAddress(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のコンストラクタ
入荷伝票アドレスを作成します。
DistributionChannelSelection - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection.
流通チャネルの選択オプションクラス
機能は以下の通り
流通チャネルの選択オプションの情報を保持します。
DistributionChannelSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のコンストラクタ
流通チャネルの選択オプション情報を作成します。
DistributionChannelSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のコンストラクタ
流通チャネルの選択オプション情報を作成します。
DocumentHeader - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader.
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
DocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のコンストラクタ
伝票ヘッダ情報を作成します。

E

Errors - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors.
前明細の不正処理に関する情報情報クラス
機能は以下の通り
前明細の不正処理に関する情報情報を保持します。
Errors() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のコンストラクタ
前明細の不正処理に関する情報情報を作成します。
Errors(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のコンストラクタ
前明細の不正処理に関する情報情報を作成します。
ExchRate - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate.
換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り
換算レート、係数 (通貨ペア)情報を保持します。
ExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のコンストラクタ
換算レート、係数 (通貨ペア)を作成します。
ExchangeRateGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail.
為替換算レート情報取得クラス
機能は以下の通り
為替換算レート情報を取得します。
ExchangeRateGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のコンストラクタ
為替換算レート情報を作成
ExchangeRateGetDetail(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のコンストラクタ

ExchangeRateGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController.
為替換算レートコントローラクラス
機能は以下の通り
為替換算レートを取得します。
ExchangeRateGetDetailController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ

ExchangeRateGetDetailController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ

ExchangeRateGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExpActivity - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity.
活動に関する詳細情報クラス 機能は以下の通り
活動に関する詳細情報を保持します。
ExpActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のコンストラクタ
活動に関する詳細情報を作成します。
ExpMessage - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage.
詳細情報を読み込みエラー情報クラス 機能は以下の通り
詳細情報を読み込みエラー情報を保持します。
ExpMessage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のコンストラクタ
詳細情報を読み込みエラー情報を作成します。
ExpWbsElement - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement.
WBS 要素についての詳細情報クラス
機能は以下の通り
WBS 要素についての詳細情報を保持します。
ExpWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のコンストラクタ
WBS 要素についての詳細情報を作成します。
ExpWbsHierarchie - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie.
WBS 階層についての情報クラス 機能は以下の通り
WBS 階層についての情報を保持します。
ExpWbsHierarchie() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のコンストラクタ
WBS 階層についての情報を作成します。
ExpWbsMilestone - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone.
WBS マイルストーンに関する詳細情報クラス 機能は以下の通り
WBS マイルストーンに関する詳細情報を保持します。
ExpWbsMilestone() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のコンストラクタ
WBS マイルストーンに関する詳細情報を作成します。
ExportHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader.
貿易管理ヘッダ情報クラス
機能は以下の通り
貿易管理ヘッダ情報を保持します。
ExportHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のコンストラクタ
貿易管理明細を作成します。
ExportItem - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem.
貿易管理明細情報クラス
機能は以下の通り
貿易管理明細情報を保持します。
ExportItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のコンストラクタ
貿易管理明細を作成します。
ExportItem(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のコンストラクタ
貿易管理明細を作成します。
Extension - class jp.co.intra_mart.foundation.sap.module.purchase.Extension.
拡張得意先項目情報クラス
機能は以下の通り
拡張得意先項目情報を保持します。
Extension() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のコンストラクタ
拡張得意先項目を作成します。
Extension(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のコンストラクタ
拡張得意先項目アドレスを作成します。
Extension1 - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1.
カスタマ拡張テーブルクラス
機能は以下の通り
カスタマ拡張テーブルの情報を保持します。
Extension1() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のコンストラクタ
カスタマ拡張テーブル情報を作成します。
Extension1(int) - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のコンストラクタ
カスタマ拡張テーブル情報を作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn.
ExtensionInの参照構造情報クラス
機能は以下の通り
ExtensionInの参照構造を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のコンストラクタ
ExtensionInの参照構造情報を取得します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN の参照構造情報を作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn.
VBAK、VBAP、VBEP のカスタマ拡張情報クラス
機能は以下の通り
VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のコンストラクタ
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のコンストラクタ
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionInX - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX.
拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ExtensionInX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のコンストラクタ
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionInX(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のコンストラクタ
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionOut - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut.
ExtensionOutの参照構造情報クラス
機能は以下の通り
ExtensionOutの参照構造を保持します。
ExtensionOut() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のコンストラクタ
ExtensionOutの参照構造情報を取得します。
ExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionOut() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
Extensionin - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin.
Reference Structure情報クラス
機能は以下の通り
Reference Structure情報を保持します。
Extensionin() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のコンストラクタ
Reference Structure情報を作成します。
Extensionin(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のコンストラクタ
Reference Structure情報を作成します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
引数で指定された bapiController のexecuteBapiメソッドを実行します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
会計伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
BapiControllerにより会計伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
BapiControllerにより原価センタ一覧を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
BapiControllerにより原価センタ一覧を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のメソッド
BapiControllerにより原価センタグループ検索を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
BapiControllerにより仕入先コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
BapiControllerにより得意先コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
BapiControllerにより為替換算レート情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
BapiControllerにより内部指図書詳細情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
BapiControllerにより内部指図書（一覧）情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のメソッド
BapiControllerにより利益センタグループ検索を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
BapiControllerによりWBSの詳細情報の検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のメソッド
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
BapiControllerにより品目マスタ照会を行います。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のメソッド
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
BapiControllerにより品目マスタを更新します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
BapiControllerにより仕入先マスタ詳細を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
伝票承認取消処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
伝票承認処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のメソッド
伝票承認取消処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
BapiControllerにより仕入先マスタ詳細を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
BapiControllerにより仕入先コード存在チェックを作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のメソッド
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

F

ForecastParameters - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters.
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
ForecastParameters() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のコンストラクタ
予測パラメータ情報を作成します。
ForecastParametersList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList.
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。
ForecastParametersList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のコンストラクタ
需要予測パラメータ情報を作成します。
ForecastParametersList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のコンストラクタ
需要予測パラメータ情報を作成します。
ForecastValues - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues.
需要予測値のデータ転送情報クラス
機能は以下の通り
需要予測値のデータ転送情報を保持します。
ForecastValues() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のコンストラクタ
需要予測値のデータ転送情報を作成します。
ForecastValues(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のコンストラクタ
需要予測値のデータ転送情報を作成します。

G

GlAcc - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc.
勘定項目情報クラス
機能は以下の通り
勘定項目の情報を保持します。
GlAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のコンストラクタ
勘定項目情報を作成します。
GlAccController - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController.
勘定科目コントローラクラス
機能は以下の通り
勘定科目の情報を取得します。
GlAccController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccList - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList.
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
GlAccList(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のコンストラクタ
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccList(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のコンストラクタ
executeBapiを呼び出し勘定項目一覧を作成します。
GoodsMvtCode - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode.
在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のコンストラクタ
在庫移動に対するコードのトランザクションへの割当情報を作成します。
GoodsMvtCreate - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate.
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。
GoodsMvtCreate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
コンストラクタ。
GoodsMvtCreate(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
GoodsMvtCreate(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
GoodsMvtCreateController - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController.
入庫伝票登録コントローラクラス
機能は以下の通り
入庫伝票を登録します。
GoodsMvtCreateController() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtGetItems - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems.
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。
GoodsMvtGetItems(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のコンストラクタ
出庫確認一覧照会情報を作成します。
GoodsMvtGetItemsController - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController.
入出庫伝票一覧取得コントローラクラス
機能は以下の通り
入出庫伝票の一覧を取得します。
GoodsMvtGetItemsController() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のコンストラクタ
コンストラクタ生成
GoodsMvtGetItemsController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のコンストラクタ
コンストラクタ生成
GoodsMvtHeader - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader.
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。
GoodsMvtHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のコンストラクタ
入出庫伝票ヘッダデータ情報を作成します。
GoodsMvtHeaderList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtHeaderList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtHeadret - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret.
入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り
入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtHeadret() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のコンストラクタ
入出庫伝票番号/入出庫伝票会計年度情報を作成します。
GoodsMvtItem - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItem(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItems - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtItems() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItems(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtRefEwm - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm.
BAdI 通信構造: 入出庫伝票 EWM 照会情報クラス
機能は以下の通り
BAdI 通信構造: 入出庫伝票 EWM 照会情報を保持します。
GoodsMvtRefEwm() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のコンストラクタ
BAdI 通信構造: 入出庫伝票 EWM 照会情報を作成します。
GoodsMvtSerialNumber - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber.
シリアル番号情報クラス
機能は以下の通り
シリアル番号情報を保持します。
GoodsMvtSerialNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のコンストラクタ
シリアル番号情報を作成します。
GoodsMvtSerialNumber(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のコンストラクタ
シリアル番号情報を作成します。
GoodsMvtServPartData - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData.
情報クラス
機能は以下の通り
情報を保持します。
GoodsMvtServPartData() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のコンストラクタ
情報を作成します。
GoodsMvtServPartData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のコンストラクタ
情報を作成します。
getAbart() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
承認タイプを取得します。
getAbcId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ABC 区分を取得します。
getAbrli() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
内部納入日程番号を取得します。
getAcDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票番号を取得します｡
getAcDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号を取得します｡
getAcIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード番号を取得します｡
getAccessSeq() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
検索順序 - 検索番号を取得します。
getAccessSeq() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
検索順序 - 検索番号を取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先の勘定設定グループを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先の勘定設定グループを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAccountGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細一覧（AccountGlインスタンスの配列）を取得します｡
getAccountKe() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キー 見越/引当を取得します。
getAccountPayableList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細一覧（AccountPayableインスタンスの配列）を取得します｡
getAccountTaxList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
税明細一覧（AccountTaxインスタンスの配列）を取得します｡
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計ビューを取得します。
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
会計ビューを取得します。
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
会計ビューを取得します。
getAccountkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キーを取得します。
getAccruals() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
見越額関連条件 (運賃など)を取得します。
getAccruals() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
見越額関連条件 (運賃など)を取得します。
getAcctAssgt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目の勘定設定グループを取得します。
getAcctKey() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
内部処理キーを取得します｡
getAcctKey() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
内部処理キーを取得します｡
getAcctKey() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
内部処理キーを取得します｡
getAcctasgnmt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の勘定設定グループを取得します。
getAcctasscat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
勘定設定カテゴリを取得します。
getAcctstatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
会計への転記ステータスを取得します。
getAcknReqd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注請求書依頼を取得します。
getAcknowlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注請書番号を取得します。
getAcknowlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注請書番号を取得します。
getActState() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般マスタレコードの有効化ステータスを取得します｡
getActivity() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
作業/活動番号を取得します｡
getActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク/標準ネットワークの活動番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
作業番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
処理タイプを取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
作業番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
作業番号を取得します。
getActivityCosts() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の原価を取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
活動タイプを取得します｡
getActtype() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
活動タイプを取得します。
getActualCost() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実際原価を取得します。
getActualDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日付(マイルストーン通過)を取得します。
getActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績終了日: 実行 (日付)を取得します。
getActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績開始日: 実行 (日付)を取得します。
getActualTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日/時間(マイルストーン適合)を取得します。
getAddToStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
既存在庫への追加許可を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日からの日数を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日からの日数を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAddrLink() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所コードへのリンクを取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
アドレス: アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレス番号を取得します。
getAddrOrig() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
コピー元住所を取得します。
getAddrType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
住所注記を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
住所注記を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
住所注記を取得します。
getAgmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約の明細番号を取得します。
getAgreement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買契約番号を取得します｡
getAgreement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約番号を取得します。
getAllVersionsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
全バージョン一覧を取得します｡
getAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーを取得します｡
getAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーを取得します｡
getAllocTbl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
商品配分表番号を取得します。
getAllocTbl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
商品配分表番号を取得します。
getAllocTblItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
割当テーブルの明細番号を取得します。
getAllowedBusTractList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
使用可能業務トランザクションのテーブル（AllowedBusTractインスタンスの配列）を取得します。
getAllowedBusTractList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
使用可能業務トランザクションのテーブルを取得します。
getAllowedWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包重量を取得します。
getAllwdVol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包容積を取得します。
getAlphaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
アルファ係数使用による基本値の平滑化を取得します。
getAltBomId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOM 選択の方法を取得します。
getAltToItm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替明細を取得します。
getAltToItm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAltUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
在庫保管単位の代替数量単位を取得します。
getAltUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードによる在庫単位の代替数量単位を取得します。
getAlternBom() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替 BOMを取得します。
getAlternBom() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAlternat() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替明細を取得します。
getAlternativeBom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOMを取得します。
getAlttaxCls() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
代替税分類を取得します。
getAlttaxCls() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAmountLc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
マニュアル入力による転記金額 (国内通貨)を取得します。
getAmountLc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
マニュアル入力による転記金額 (国内通貨)を取得します。
getAmountSv() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
外部入力による販売金額 (国内通貨)を取得します。
getAmountSv() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
外部入力による販売金額 (国内通貨)を取得します。
getAmountchan() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 金額変更を取得します。
getAmtActual() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
削減額を取得します｡
getAmtBase() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を取得します｡
getAmtDoccur() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額を取得します｡
getAmtOpen() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
未決済金額を取得します｡
getAmtOrigin() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
元金額を取得します｡
getAppdBRec() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バッチ製造記録の承認必須を取得します。
getApplicBy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を取得します。
getApplicant() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者を取得します。
getApplicantNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請者番号を取得します。
getApplicantNo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
申請者番号を取得します。
getApplicantPhone() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者の電話番号を取得します。
getApplicatio() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
アプリケーションを取得します。
getApplicatio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
アプリケーションを取得します。
getApplicationDate() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請日を取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApproved() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
出張申請または出張承認済 (区分)を取得します｡
getAssNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
割当番号を取得します。
getAssNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産番号を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産番号を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産番号を取得します。
getAssortMod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品揃モジュールを取得します。
getAssortMod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAssyScrap() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
組立不良率を取得します。
getAtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
割当テーブルの明細番号を取得します。
getAtRelev() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
適当テーブル関連を取得します。
getAtpWrkmod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
ATP セッション: 結果取得/新規決定 APO-ATPを取得します。
getAuthCcNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認番号を取得します。
getAuthDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認日を取得します。
getAuthDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認日を取得します。
getAuthFlag() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 振替権限を取得します。
getAuthFlag() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 振替権限を取得します。
getAuthNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
返品権限番号を取得します。
getAuthNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
返品権限番号を取得します。
getAuthRefno() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社の権限参照コードを取得します。
getAuthRefno() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社の権限参照コードを取得します。
getAuthTime() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認時刻を取得します。
getAuthTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認時刻を取得します。
getAuthamount() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認額を取得します。
getAuthamount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認額を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
報告書提案済を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
報告書提案済を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
報告書提案済を取得します。
getAuthoritygroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
権限グループを取得します。
getAuthortype() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認タイプを取得します。
getAutoPOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: "購買発注自動生成"を取得します。
getAutoReset() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予測モデル自動リセットを取得します。
getAvQtyPlt() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントレベル利用可能数量を取得します。
getAvailCheckAllProjSegments() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プロジェクト間品目区分を取得します。
getAvailcheck() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利用可能在庫確認の確認グループを取得します。
getBUomIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードでの基本数量単位を取得します。
getBaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します｡
getBackflush() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バックフラッシュを取得します。
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
銀行データ情報を取得します。
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
銀行データ情報を取得します。
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
銀行データ情報を取得します。
getBankKey() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを取得します｡
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧（Bankインスタンスの配列）を取得します。
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧（Bankインスタンスの配列）を取得します｡
getBankName() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を取得します｡
getBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して銀行名を取得します。
getBapiReturnErrMessage() - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getBapiReturnErrMessage() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getBapiReturnMessage() - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getBapiReturnMessage() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getBarCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
バーコードエントリを取得します。
getBaseQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
基本数量を取得します。
getBaseQtyPlan() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷の能力計画のための基本数量を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
基本数量単位を取得します｡
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
基本数量単位を取得します。
getBaseUomIso() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ISO コードでの基本数量単位を取得します｡
getBaseUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの基本数量単位を取得します。
getBasicLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本明細を取得します。
getBasicMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
主構成物質を取得します。
getBasicValue() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
基準値を取得します。
getBasicValue1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を取得します。
getBasicValue2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を取得します。
getBasicValuePp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の基準値を取得します。
getBasicValuePp1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を取得します。
getBasicValuePp2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を取得します。
getBasicView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
基本データビューを取得します。
getBaslineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替: 基本明細参照を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
ロットを取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ロット番号を取得します。
getBatchMgmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロット管理所要量区分を取得します。
getBatchMgmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロット管理所要量区分を取得します。
getBatchRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ロットの範囲を取得します。
getBatchentry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造/プロセス指図でのロット入力設定を取得します。
getBdcnt() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
5 文字数値 NUMCを取得します。
getBegdemPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見越期間の提案開始日付を取得します。
getBegdemPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBegintime() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
開始時刻を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
エラー処理を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
エラー処理を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
エラー処理を取得します。
getBetaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ベータ係数による傾向値平準化を取得します。
getBidder() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入札者の明細を取得します。
getBidinvNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積管理番号を取得します。
getBilForm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書式を取得します。
getBilForm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票の請求ブロックを取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ブロックを取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票の請求ブロックを取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票を取得します。
getBillDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票明細を取得します。
getBillOfLading() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫時に登録した B/L 番号を取得します。
getBillOfLadingLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。
getBillPlan() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求計画番号を取得します。
getBillPlani() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
明細: 請求計画/支払計画/支払カードを取得します。
getBillRel() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求関連 (CRM)を取得します。
getBillRel() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求日程 (稼働日カレンダ指定)を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求日程 (稼働日カレンダ指定)を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求先を取得します。
getBillType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求タイプを取得します。
getBillValue() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求金額: 請求計画に請求日付が指定されている場合を取得します。
getBillamount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
請求金額: 請求計画に請求日付が指定されている場合を取得します。
getBillcateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求カテゴリを取得します。
getBillingDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定明細データのテーブルを取得します。
getBillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
請求伝票に関する詳細情報を取得します。
getBillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
請求伝票に関する詳細情報を取得します。
getBillingDocumentDetailListList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票のテーブルを取得します。
getBillingdoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求伝票を取得します。
getBillingdocument() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
処理予定の請求伝票数を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBindgPer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積有効期間を取得します。
getBlQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入庫保留在庫数量 (発注価格単位)を取得します。
getBlQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
入庫保留在庫数量 (発注価格単位)を取得します。
getBlQtyTotal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
発注単位による入庫保留在庫 (絶対額)を取得します。
getBlanket() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
包括明細を取得します。
getBlineDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日を取得します｡
getBllsrvInd() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
サービスコード (外貨支払)を取得します｡
getBlockStge() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
平置保管域区分を取得します。
getBlockedQy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
発注単位の入庫保留在庫を取得します。
getBlockedQy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
発注単位の入庫保留在庫を取得します。
getBomUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BOM 用途を取得します。
getBomexplNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BOM 展開番号を取得します。
getBomexplNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBonGrp1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ1を取得します。
getBonGrp2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 2 (リベート決済、購買)を取得します。
getBonGrp3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 3 (リベート決済、購買)を取得します。
getBrasNbm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Brazilian NCM Codeを取得します。
getBudgetProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
予算プロファイルを取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物 (番号またはコード)を取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物 (番号またはコード)を取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物 (番号またはコード)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
旧: 建物 (番号または略称)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
旧: 建物 (番号または略称)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
旧: 建物 (番号または略称)を取得します。
getBulkMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バルク品目を取得します。
getBusAct() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
取引を取得します｡
getBusArDes() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を取得します｡
getBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域を指定して事業領域名を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域を取得します｡
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
事業領域を取得します｡
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を取得します｡
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
事業領域を取得します。
getBusAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します｡
getBusTranst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
貿易管理の取引タイプを取得します。
getBusTranst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBusinessAreaFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
事業領域を取得します｡
getBusinessAreaFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
事業領域を取得します｡
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧（BusinessAreaインスタンスの配列）を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧（BusinessAreaインスタンスの配列）を取得します｡
getBusinessAreaTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
事業領域を取得します｡
getBusinessAreaTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
事業領域を取得します｡
getBusinessTransactionType() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易管理の取引タイプを取得します。
getBuspartno() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
取引先の仕入先マスタコードを取得します。
getBwdCons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 後方を取得します。
getCCardDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定支払方法のテーブルを取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
気付を取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
気付を取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
気付を取得します。
getCadId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
CAD 区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
計算区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
計算区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
計算区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
計算区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCalctypcon() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件計算タイプを取得します。
getCalctypcon() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件計算タイプを取得します。
getCalctype() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定タイプを取得します。
getCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
稼動日カレンダを取得します。
getCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
稼動日カレンダを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
総括プロジェクト計画: 外部 SAP システムの GUIDを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総括プロジェクト計画: 外部 SAP システムの GUIDを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCancelled() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
中止区分を取得します。
getCapyUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量使用を取得します。
getCasNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAS 番号： 薬事品目 - 貿易を取得します。
getCashDisc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
現金値引区分を取得します。
getCashDisc1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 1を取得します。
getCashDisc2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 2を取得します。
getCatprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
カタログプロファイルを取得します。
getCbaseId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号 (固定)を取得します。
getCbaseIdType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号タイプ (固定)を取得します。
getCcAuthNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認番号を取得します。
getCcCtrlField() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
カード照合額の制御項目を取得します。
getCcFixed() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸区分固定を取得します。
getCcInUseSt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
カード照合額の使用ステータスを取得します。
getCcLimited() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 限度額を取得します。
getCcLocId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: トランザクション (入庫時点)を取得します。
getCcName() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード所有者の氏名を取得します。
getCcName() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード所有者の氏名を取得します。
getCcNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード番号を取得します。
getCcNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード番号を取得します。
getCcPhInv() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸の実地棚卸区分を取得します。
getCcReAmount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
BAPI インタフェースの通貨金額を取得します。
getCcReact() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 権限確認に対する応答を取得します。
getCcReactT() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 結果テキストを取得します。
getCcSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 支払カード - 接尾辞を取得します。
getCcSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 支払カード - 接尾辞を取得します。
getCcSettled() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済終了を取得します。
getCcStatEx() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 外部システム呼出時のステータスを取得します。
getCcType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カードタイプ: カードタイプを取得します。
getCcType() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カードタイプ: カードタイプを取得します。
getCcValidF() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 使用有効開始日付を取得します。
getCcValidT() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 有効終了日を取得します。
getCcValidT() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 有効終了日を取得します。
getCcVerifValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
カード照合額を取得します。
getCctrPosted() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価が実際に転記された原価センタを取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件数量単位 (ISO コード)を取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件数量単位 (ISO コード)を取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件数量単位 (ISO コード)を取得します。
getCertType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
証明書タイプを取得します。
getCfginfo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CU: 選定の BLOB (SCE)を取得します。
getCfopCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extension (old 5 char version)を取得します。
getCfopCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCfopLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extensionを取得します。
getChangeId() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
変更タイプ(U、I、E、D)を取得します。
getChangeId() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
変更タイプ(U、I、E、D)を取得します。
getChangeNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
変更番号を取得します。
getChangedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクトの変更者名を取得します。
getCharUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
特性の数量単位を取得します。
getCharUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を取得します。
getCharc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性名を取得します。
getCharcTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
言語依存特性テキストを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村ファイルテストステータスを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村ファイルテストステータスを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村ファイルテストステータスを取得します。
getCheckReturn() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
結果を取得します｡
getCheckReturn() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
結果情報を取得します｡
getCheckRule() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
確認規則を取得します。
getChkprtauth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
取引先権限チェックを取得します。
getChkprtauth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を取得します｡
getCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して市区町村名を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
市区町村を取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getClIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
レコード番号を取得します｡
getClValFor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外貨による入庫/請求仮勘定決済金額を取得します。
getClValLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨による入庫/請求仮勘定決済金額を取得します。
getClValLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による入庫/請求仮勘定決済金額を取得します。
getClassType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
クラスタイプを取得します。
getClassType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
クラスタイプを取得します。
getClientData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (クライアントレベル)を取得します。
getClientDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (クライアントレベル)が既に存在するかチェックします。
getClientDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (クライアントレベル)を取得します。
getClosedBox() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
完了した梱包材を取得します。
getCmRelevanceFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
構成管理関連を取得します。
getCmlqtyDat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
累積出荷数量日付を取得します。
getCmlqtyDat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
予算コードを取得します｡
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
予算コードを取得します｡
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
予算コードを取得します｡
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
予算コードを取得します｡
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを取得します。
getCntrlInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票タイプに対する管理区分を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を取得します｡
getCoArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
管理領域を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
管理領域を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
管理領域を取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
業務プロセスを取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
業務プロセスを取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
業務プロセスを取得します。
getCoCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
会社コードを取得します。
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
レコード番号を取得します｡
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
レコード番号を取得します｡
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
レコード番号を取得します｡
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
レコード番号を取得します｡
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
レコード番号を取得します｡
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
レコード番号を取得します｡
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
レコード番号を取得します｡
getCoProduct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 連産品としても使用可能な品目を取得します。
getCoProduct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 連産品としても使用可能な品目を取得します。
getCoeffTheil() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
タイル係数を取得します。
getCollNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getComDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
確認日を取得します。
getComDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認日を取得します。
getComQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
確認数量を取得します。
getComQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認数量を取得します。
getCommCoUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
物品コード (貿易) の数量単位を取得します。
getCommCoUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードによる物品コード (貿易管理) の数量単位を取得します。
getCommCode() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 統計品目コード/輸入コード番号を取得します。
getCommCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 統計品目コード/輸入コード番号を取得します。
getCommGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
手数料グループを取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 1を取得します。
getCommprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 2を取得します。
getCommprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法基準評価額: レベル 3を取得します。
getCompCdeB() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求対象会社コードを取得します。
getCompCdeB() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
会社コードを取得します｡
getCompList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します｡
getCompName() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を取得します｡
getCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社コードを指定して会社名を取得します。
getCompQuant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
構成品目数量を取得します。
getCompQuant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCompScrap() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
構成品目不良率を取得します。
getCompShip() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示順守を取得します。
getCompShip() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示順守を取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧（Companyインスタンスの配列）を取得します。
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
会社コードを取得します。
getCompanycodeFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
会社コード（開始値）を取得します。
getCompanycodeFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
会社コード（開始値）を取得します。
getCompanycodeTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
会社コード（終了値）を取得します。
getCompanycodeTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
会社コード（終了値）を取得します。
getCompetitor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
競合会社を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
全購買発注に対する一括納入指定を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括納入区分を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最終確認の有効化を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を取得します。
getCompleted() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ステータス "バージョン完了済"を取得します。
getCompleted() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
ステータス "バージョン完了済"を取得します。
getCompoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ACC インタフェースの構成要素を取得します｡
getConExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
基本契約明細の制限を取得します。
getConItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
明細番号、契約を取得します。
getConLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を取得します。
getConNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
基本契約番号を取得します。
getConPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を取得します。
getConbaseval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値を取得します。
getConbaseval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値を取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カウンタを取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタを取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件連続番号を取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件カウンタを取得します。
getCondCurr() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件通貨 (累積項目用)を取得します。
getCondDUnt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
伝票の条件単位を取得します。
getCondGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先条件グループを取得します。
getCondHandl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
選択: 条件行処理 (SD 伝票変更)を取得します。
getCondHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件ヘッダ一覧を取得します｡
getCondItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件明細一覧を取得します｡
getCondKey() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
条件タイプを取得します｡
getCondNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レコード番号を取得します。
getCondNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レコード番号を取得します。
getCondNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
伝票条件番号を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
価格条件単位を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
ステップ番号を取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件タイプを取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件単位を取得します。
getCondUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件数量単位 (ISO コード)を取得します。
getCondUpdat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件更新を取得します。
getCondUpdat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件更新を取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レートを取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件金額/率を取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レートを取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondchaman() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件 (マニュアル変更済)を取得します。
getCondchaman() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件 (マニュアル変更済)を取得します。
getCondclass() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件クラスを取得します。
getCondclass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件クラスを取得します。
getCondcntrl() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件管理を取得します。
getCondcntrl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件管理を取得します。
getCondcoinhd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタ (ヘッダ条件)を取得します。
getCondconfig() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
システム設定の条件を取得します。
getCondconfig() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
システム設定の条件を取得します。
getCondcount() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件連続番号を取得します。
getCondcount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件連続番号を取得します。
getCondincomp() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
会社間請求の条件を取得します。
getCondincomp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
会社間請求の条件を取得します。
getCondisacti() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
無効条件を取得します。
getCondisacti() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
無効条件を取得します。
getConditemno() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件明細番号を取得します。
getCondition() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票条件番号を取得します。
getConditionDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定条件のテーブルを取得します。
getConditionNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
伝票条件番号を取得します。
getCondorigin() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件生成区分を取得します。
getCondorigin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件生成区分を取得します。
getCondtype() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
getCondtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
getCondvalue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件金額を取得します。
getConexchrat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
現地通貨への換算レートに対する条件を取得します。
getConexchrat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
現地通貨への換算レートに対する条件を取得します。
getConfCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
確認管理キーを取得します。
getConfMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通選定可能品目を取得します。
getConfMatlExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 CONF_MATL の品目コード(長)を取得します。
getConfMatlGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 CONF_MATL の外部GUIDを取得します。
getConfMatlVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 CONF_MATL のバージョン番号を取得します。
getConfName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
確認カテゴリ: テキストを取得します。
getConfSer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の連続番号を取得します。
getConfSer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
仕入先確認の連続番号を取得します。
getConfType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
確認カテゴリを取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getConfigured() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
選定可能品目を取得します。
getConinvolst() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
請求書一覧条件を取得します。
getConinvolst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
請求書一覧条件を取得します。
getConpricdat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件価格設定日付を取得します。
getConpricdat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件価格設定日付を取得します。
getConsValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
消費量を取得します。
getConsValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
消費量を取得します。
getConsistent() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を取得します。
getConsistent() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を取得します。
getConstraintFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了日に対する制約を取得します。
getConstraintFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日付を取得します。
getConstraintFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了時間を取得します。
getConstraintFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測終了時間を取得します。
getConstraintStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を取得します。
getConstraintStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測開始日を取得します。
getConstraintStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始時間の制約を取得します。
getConstraintStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の需要予測開始時間を取得します。
getConstraintTypeFinish() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の終了日に対する制約を取得します。
getConstraintTypeFinishFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動終了の制約条件付き需要予測日付を取得します。
getConstraintTypeStart() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を取得します。
getConstraintTypeStartFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動開始の制約条件付き需要予測日付を取得します。
getConsumctry() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
消費者の国キーを取得します。
getConsummode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費モードを取得します。
getContPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getContainer() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容器条件を取得します。
getContext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
CU: 選定の BLOB (SCE)を取得します。
getContractLimitsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注基本契約制限一覧を取得します｡
getContractServiceAccountList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス勘定設定一覧を取得します｡
getContractServiceList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス一覧を取得します｡
getContractServiceTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービステキスト一覧を取得します｡
getControlKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
管理キーを取得します。
getControllAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域コードを取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
管理領域を取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
管理領域を取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
管理領域を取得します。
getControllingAreaCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧（ControllingAreaインスタンスの配列）を取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を取得します｡
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
管理領域を取得します。
getConvDen1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分母を取得します。
getConvNum1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分子を取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
変換: 取引先機能 + 受注伝票タイプを取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
取引先機能/受注伝票タイプの変換を取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
変換: 取引先機能 + 受注伝票タイプを取得します。
getConvfactor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目用変換係数を取得します。
getCorrFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 修正係数を需要予測値計算に使用を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
需要予測に対する修正値を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
修正消費量を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
修正消費量を取得します。
getCostCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します｡
getCostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを取得します｡
getCostCenter(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
BAPI パラメータ の参照構造オブジェクトが既に 存在するかチェックします。
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧（CostCenterインスタンスの配列）を取得します。
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧（CostCenterインスタンスの配列）を取得します｡
getCostElem() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
原価要素を取得します。
getCostObj() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価対象を取得します｡
getCostObj() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価対象を取得します。
getCostObj() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価対象を取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算ビューを取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
原価計算ビューを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタを取得します｡
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
原価センタを取得します｡
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
原価センタを取得します。
getCostcenterFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ（開始値）を取得します。
getCostcenterFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ（開始値）を取得します。
getCostcenterTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ（終了値）を取得します。
getCostcenterTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ（終了値）を取得します。
getCostcentergroup() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタグループを取得します。
getCostcentergroup() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタグループを取得します。
getCostingSheet() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価計算表を取得します。
getCostobject() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価対象を取得します。
getCountrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国キー (ISO コード)を取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷国 (商品発送国)を取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを取得します。
getCountryori() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産国を取得します。
getCountryori() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産国を取得します。
getCountryoriIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを取得します。
getCountryoriIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの品目原産国を取得します。
getCovprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫日数プロファイルを取得します。
getCrOn() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード登録日を取得します。
getCreatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード登録日を取得します。
getCreatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
レコード登録日を取得します。
getCreateLoadRecs() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
区分: 生産資源/治工具の負荷レコード登録を取得します。
getCreateLoadRecs() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
区分: 生産資源/治工具の負荷レコード登録を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
登録者名を取得します｡
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクト登録者名を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
レコード登録日を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
登録日付を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
レコード登録日を取得します。
getCreationDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード登録日を取得します。
getCreationDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード登録日を取得します。
getCreationTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
登録時刻を取得します。
getCreationTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
登録時刻を取得します。
getCreatorDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
取り込まれる日付の順序を取得します。
getCreditorGetDetail() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先マスタ詳細情報を取得します｡
getCreditorid() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードを取得します｡
getCreditorid() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先コードを取得します｡
getCritPart() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 重要品目を取得します。
getCrmRefSalesOrderNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理の CRM 参照受注番号を取得します。
getCrmRefSoItemNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理での CRM 参照受注明細番号を取得します。
getCrmSalesOrderItemNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理での CRM 受注明細番号を取得します。
getCrmSalesOrderNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理の CRM 受注番号を取得します。
getCsIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
レコード番号を取得します｡
getCshBdgtProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
資金計画プロファイルを取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ１を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ１を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ２を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ２を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ３を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ３を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ４を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ４を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ５を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ５を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価計算表を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
原価計算表を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効開始日付 (販売契約/品目提案)を取得します。
getCtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効終了日付 (販売契約/品目提案)を取得します。
getCtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtrlCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 消費税の管理コードを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
調達における品質管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達における品質管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具管理の管理キーを取得します。
getCtrlKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
管理キーは変更できませんを取得します。
getCtrlKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
管理キーは変更できませんを取得します。
getCtrlQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
管理数量を取得します。
getCuIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を取得します｡
getCumCfQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積確認数量 (販売数量単位)を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コード通貨を取得します。
getCurrIso2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrPeriod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当期 (転記期間)を取得します。
getCurrPeriod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期 (転記期間)を取得します。
getCurrPlanPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を取得します。
getCurrType() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨タイプおよび評価ビューを取得します｡
getCurrType() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
通貨タイプおよび評価ビューを取得します｡
getCurrenckey() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール通貨を取得します。
getCurrenckey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール通貨を取得します。
getCurrenckeyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを取得します｡
getCurrency() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
通貨コードを取得します｡
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
購買発注通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
通貨コードを取得します｡
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票通貨を取得します。
getCurrency2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
販売伝票通貨を取得します。
getCurrencyAmountList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
明細通貨項目一覧（CurrencyAmountインスタンスの配列）を取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
ISO コード通貨を取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
ISO コード通貨を取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ISO通貨コードを取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
ISO コード通貨を取得します。
getCurreniso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループを取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先グループを取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 1を取得します。
getCustGrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 2を取得します。
getCustGrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 3を取得します。
getCustGrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 4を取得します。
getCustGrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 5を取得します。
getCustGrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustMat22() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目コード (無効)を取得します。
getCustMat22() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustMat35() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目を取得します。
getCustMat35() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先コード1を取得します｡
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
得意先コード 1を取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
得意先コードを取得します。
getCustomerNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先コードを取得します。
getCustoms() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
税関: 税関 (出国時)を取得します。
getCvalueFxd() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
区分: 消費金額の確定を取得します。
getCycleTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タクトタイムを取得します。
getDToRefM() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照の有効終了日を取得します。
getDataIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
別の構成のテーブル入力へのポインタを取得します。
getDataorigin() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 入力モードを取得します。
getDataorigin() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 入力モードを取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
起算日を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
起算日を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
日付を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
日付を取得します。
getDateFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
有効期間：開始を取得します。
getDateFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
有効期間：開始を取得します。
getDateTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
有効期間：終了を取得します。
getDateTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
有効期間：終了を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
提案日付タイプを取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
日付タイプ (日、週、月、期間)を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDateWorkBegins() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業開始を取得します。
getDateWorkEnds() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業終了を取得します。
getDbCrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
借方/貸方フラグを取得します。
getDeIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
レコード番号を取得します｡
getDebtorGetDetail() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先マスタ詳細情報を取得します｡
getDebtorid() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードを取得します｡
getDebtorid() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先コードを取得します｡
getDecForRounding() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
小数点位置 (その位置まで丸める)を取得します。
getDecForRoundingX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDeclStatFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 仕入先申告ありを取得します。
getDelCreateDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷登録日付を取得します。
getDelDatcat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認における納入期日の日付カテゴリを取得します。
getDelDatcatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
納入期日カテゴリを取得します。
getDelDatcatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日カテゴリを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
クライアントレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
区分: 流通チャネルレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管タイプに該当する全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプに該当する全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
WM 倉庫内の全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
資金計画削除フラグを取得します｡
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票の削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
削除フラグを取得します｡
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
削除フラグ: 購買伝票勘定設定を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
区分: 仕入先確認削除を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
削除フラグを取得します｡
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
削除フラグを取得します。
getDelivCompl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出荷完了 区分を取得します。
getDelivDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の納入日付を取得します。
getDelivDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入期日を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
郵便配達地域を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
郵便配達地域を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
郵便配達地域を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
出荷明細を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
出荷明細を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷明細を取得します。
getDelivItemToSearch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
出荷伝票を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷伝票を取得します。
getDelivNumbToSearch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を取得します。
getDelivNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
出荷伝票を取得します。
getDelivQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納品書数量単位の数量を取得します。
getDelivQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
入庫数量を取得します。
getDelivTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の納入日時を取得します。
getDelivTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日における指定時間を取得します。
getDelivUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納品書の数量単位を取得します。
getDelivUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納品書数量単位の ISO コードを取得します。
getDeliverryAddressList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷伝票アドレス一覧を取得します｡
getDeliveryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日を取得します。
getDelkz() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
MRP 要素区分を取得します。
getDeltaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。
getDelyUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷単位を取得します。
getDelyUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷数量単位を取得します。
getDelyUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードでの出荷単位の数量単位を取得します。
getDelygPlnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷プラントを取得します。
getDenominato() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分母を取得します。
getDenominato() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分母を取得します。
getDenominatr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
分母: 基本数量単位へ変換する場合を取得します。
getDepReqId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
個別所要量と包括所要量に対する従属所要量区分を取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
部門コードを取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
部門コードを取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepartment() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
部署を取得します。
getDepcountry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国 (商品発送国)を取得します。
getDepcountryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国の ISO コードを取得します。
getDeployHoriz() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給分配期間の日数を取得します。
getDeprecPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理に関する償却率 (%)を取得します。
getDeprecPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDescrHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
終了品目テキストを取得します。
getDescrLow() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
開始品目テキストを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを取得します｡
getDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定してテキストを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
テキスト (30 文字)を取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループテキスト (短)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業テキスト (短)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
PS: テキスト(短)(第一テキスト行)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
テキストを取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
PS: テキスト(短)(第一テキスト行)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンテキスト（長）を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンテキスト（長）を取得します。
getDetermGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫決定グループを取得します。
getDevalInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
低価法: 評価減区分を取得します。
getDialogflag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
区分 (X = 利用不可 /N = 確認なし)を取得します。
getDiffInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先と請求元が異なる場合の供給元のコードを取得します｡
getDiscontinu() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
打切区分を取得します。
getDispQuan() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注数量: 表示目的全納入日程合計を取得します。
getDispoRel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
区分: MRP 関連の確認を取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
流通チャネルを取得します。
getDistrChanHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲終了を取得します。
getDistrChanLow() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲開始を取得します。
getDistrPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
配賦率 % (複数勘定設定)を取得します。
getDistrProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サイトの商品の物流プロファイルを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
複数勘定設定の配賦区分を取得します。
getDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
複数勘定設定の配賦区分を取得します。
getDistributingKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。
getDistributionChannelSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
流通チャネルの選択オプション一覧を取得します｡
getDistributionchannel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
流通チャネルを取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
所在地を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
製品部門を取得します。
getDlQtyTotal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
入庫数量: 絶対額を取得します。
getDlQtyTrsp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
納入済数量 (在庫転送)を取得します。
getDliProfil() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
動的明細プロセッサプロファイルを取得します。
getDliProfil() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を取得します。
getDlvDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷グループ (明細一括出荷)を取得します。
getDlvGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
出荷優先順位を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷優先順位を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷優先順位を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷数量実績 (販売単位)を取得します。
getDlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷数量実績 (販売単位)を取得します。
getDlvStatH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
全明細の出荷ステータスを取得します。
getDlvStatI() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
明細の全体出荷ステータスを取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
契約出荷期間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
契約出荷期間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードでの出荷単位の数量単位を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
用途区分を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
用途区分を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票カテゴリを取得します。
getDocChgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書変更番号 (文書管理システム外)を取得します。
getDocClass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
リリースおよびトランザクション管理を備えた元システムを取得します。
getDocClass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
伝票条件番号を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付を取得します｡
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票日付を取得します｡
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票の伝票日付を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の伝票日付を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocFormat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書のページ書式 (文書管理システムによらない)を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ドキュメンタリクレジット処理: 内部番号を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理: 内部番号を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるオブジェクト番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
伝票番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売管理伝票番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票を取得します。
getDocReqd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
文書必須フラグを取得します。
getDocStatus() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票ステータスを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプを取得します｡
getDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプを取得します｡
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票カテゴリを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票タイプを取得します｡
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書タイプ (文書管理システムによらない)を取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票タイプを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票タイプを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票タイプを取得します。
getDocVers() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書バージョン (文書管理システムによらない)を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入出庫伝票年を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票年度を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票年度を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票年度を取得します。
getDocument() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書番号 (文書管理システムによらない)を取得します。
getDocumentDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
登録日付を取得します。
getDocumentDateTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
入力日付 (以前/以降)を取得します。
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダを取得します｡
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票ヘッダを取得します｡
getDontUseP() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所配達不可フラグを取得します。
getDontUseS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名住所配達不可フラグを取得します。
getDopVlLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による前払金合計を取得します。
getDown() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getDscnt1To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数1を取得します｡
getDscnt2To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数2を取得します｡
getDscnt3To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数3を取得します｡
getDsctPct1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 1を取得します。
getDsctPct2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 2を取得します。
getDsnOffice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
研究室/設計室を取得します。
getDunCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先商談回数を取得します。
getDunCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先との前回の商談日を取得します。
getDunDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理保留を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理保留を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理キーを取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理キーを取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDurationConfirmFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測活動期間を取得します。
getDurationConfirmFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測期間単位を取得します。
getDurationConfirmFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationMinimum() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短活動期間を取得します。
getDurationMinimumFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の最小期間(需要予測より)を取得します。
getDurationMinimumFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測最短期間の単位を取得します。
getDurationMinimumFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationMinimumUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短期間の単位を取得します。
getDurationMinimumUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationNormal() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間を取得します。
getDurationNormalFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間 (予測)を取得します。
getDurationNormalFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準予測期間の単位を取得します。
getDurationNormalFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationNormalUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準期間/単位を取得します。
getDurationNormalUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationScheduled() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間を取得します。
getDurationScheduledFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間の長さ (予測値)を取得します。
getDurationScheduledUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間単位を取得します。
getDurationScheduledUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
電子メールアドレスを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
電子メールアドレスを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
電子メールアドレスを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getEarlyFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (日)を取得します。
getEarlyFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了日 (予測)を取得します。
getEarlyFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (時刻)を取得します。
getEarlyFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了時間(需要予測)を取得します。
getEarlyStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 実行 (日)を取得します。
getEarlyStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始日付(需要予測)を取得します。
getEarlyStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 作業実施(時間)を取得します。
getEarlyStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始時間(需要予測)を取得します。
getEarnedValueIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗分析関連のマイルストーンを取得します。
getEdition() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのバージョンを取得します。
getEdition() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのバージョンを取得します。
getEffODay() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
有効終了日を取得します。
getEiIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
レコード番号を取得します｡
getEmaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードを取得します。
getEmaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コード（長）を取得します。
getEmaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードの外部GUIDを取得します。
getEmaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードのバージョン番号を取得します。
getEndOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途の終了オフセットを取得します。
getEndOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途の終了オフセットを取得します。
getEndOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了オフセットは変更できませんを取得します。
getEndOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了オフセットは変更できませんを取得します。
getEndOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了オフセット単位を取得します。
getEndOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了オフセット単位を取得します。
getEndOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
getEndOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
getEndRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了日の参照日付を取得します。
getEndRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了日の参照日付を取得します。
getEndRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了参照日付は変更できませんを取得します。
getEndRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了参照日付は変更できませんを取得します。
getEndleadtme() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
補充リードタイムの終了日付を取得します。
getEndtime() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
終了時刻を取得します。
getEntryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
会計伝票登録日付を取得します。
getEntryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
会計伝票登録日を取得します。
getEntryQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位での数量を取得します。
getEntryQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位での数量を取得します。
getEntryQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
構成品目の所要量を取得します。
getEntryTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
登録時刻を取得します。
getEntryTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
登録時刻を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
入力単位を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位を取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
入力単位 (ISO コード)を取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getEnvtRlvt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 環境関連を取得します。
getEquipment() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備番号を取得します。
getEquityType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
持分タイプを取得します。
getEquityType() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
持分タイプを取得します。
getErrorTotal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
エラー合計を取得します。
getErrorTotalPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間のエラー合計を取得します。
getErrorsList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
前明細の不正処理に関する情報を取得します。
getErs() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ERS（入庫/請求自動決済）を取得します。
getEstPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
概算価格区分を取得します。
getEstimatedCosts() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図の見積原価合計を取得します。
getEuListNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAP: CAP 製品一覧番号を取得します。
getEuMatGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。
getEutriDeal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
フラグ: EC 内三角取引を取得します。
getEutriDeal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getEvent() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
論理時間を取得します。
getEventual() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
偶発的明細を取得します。
getExCertDt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書発行日を取得します。
getExCertId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
法令管理: 認定書区分を取得します。
getExCertNoNew() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書番号 - 法令管理を取得します。
getExIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
レコード番号を取得します｡
getExIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
レコード番号を取得します｡
getExRateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (直接相場)を取得します。
getExRateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExRateFx() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レート固定区分を取得します｡
getExceptList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
例外メッセージバーを取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
換算レートを取得します｡
getExchRate() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
換算レートを取得します｡
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
直接呼び値換算レートを取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レート、係数 (通貨ペア)を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レート、係数 (通貨ペア)を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レートを取得します｡
getExchRateCm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
間接呼び値換算レートを取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (間接相場)を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (間接相場)を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchRateV() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
間接呼び値換算レートを取得します｡
getExchRateV() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
間接呼び値換算レートを取得します｡
getExchRateV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
間接呼び値換算レートを取得します。
getExchangeRate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/統計用換算レートを取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExpActivityList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
活動に関する詳細情報を取得します。
getExpActivityList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
活動に関する詳細情報を取得します。
getExpMessageList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を読み込みエラーを取得します。
getExpMessageList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を読み込みエラーを取得します。
getExpValue() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
見込金額を取得します。
getExpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 要素についての詳細情報を取得します。
getExpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 要素についての詳細情報を取得します。
getExpWbsHierarchieList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 階層についての情報を取得します。
getExpWbsHierarchieList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 階層についての情報を取得します。
getExpWbsMilestoneList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS マイルストーンに関する詳細情報を取得します。
getExpWbsMilestoneList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS マイルストーンに関する詳細情報を取得します。
getExpimpNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
貿易データ番号: MM/SD 伝票を取得します。
getExpimpgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
輸出/輸入品目グループを取得します。
getExpirydate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
有効期間期限日を取得します。
getExpirydate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
有効期間期限日を取得します。
getExportHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理ヘッダを取得します｡
getExportImportProcedure() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易の輸出入手続を取得します。
getExportItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理明細一覧を取得します｡
getExportNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
貿易データ番号: MM/SD 伝票を取得します。
getExpostPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
事後的需要予測に含む履歴値の数を取得します。
getExpostVal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
事後的需要予測値を取得します。
getExrateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (直接相場)を取得します。
getExrateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExtDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の外部伝票番号を取得します。
getExtDocLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を取得します。
getExtLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
明細番号を取得します。
getExtOrdNo() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
外部指図番号を取得します。
getExtServ() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
仕入先のサービス番号を取得します。
getExtWms() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
外部倉庫管理の転記の制御を取得します。
getExtension1List() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
カスタマ拡張テーブル一覧（Extension1インスタンスの配列）を取得します｡
getExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
BAPI パラメータ EXTENSIONIN の参照構造オブジェクトが既に 存在するかチェックします。
getExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
EXTENSIONIN一覧を取得します｡
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
EXTENSIONIN一覧を取得します｡
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInX(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。
getExtensionInXList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
拡張イン/拡張アウトのチェックボックス構造を取得します。
getExtensionList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
拡張得意先項目一覧を取得します｡
getExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
BAPI パラメータ EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
getExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
getExtensionOutList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
EXTENSIONOUT一覧を取得します｡
getExtensionOutList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
EXTENSIONOUT一覧を取得します｡
getExtensionOutList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
getExtensioninList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
Reference Structureを取得します。
getExternalObjectId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 外部対象キーを取得します。
getExtmatlgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
外部品目グループを取得します。
getExtpersNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
外部従業員番号を取得します。
getExtrefkey() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスの外部参照キーを取得します。
getFactbasval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値に対する要因を取得します。
getFactbasval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値に対する要因を取得します。
getFactconbas() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基準の係数 (期間)を取得します。
getFactor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件の加重係数を取得します。
getFactoryCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
稼働日カレンダを取得します。
getFairShareRule() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
均等配賦ルールを取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: 内線を取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: 内線を取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: 内線を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
FAX 番号を取得します。
getField() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの項目を取得します。
getField1() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を取得します｡
getField2() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を取得します｡
getField3() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を取得します｡
getField4() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を取得します｡
getFieldname() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
項目名を取得します。
getFijCurCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期標準原価見積の会計年度を取得します。
getFijFutCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積の会計年度を取得します。
getFijPreCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準原価見積の会計年度を取得します。
getFillLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最大レベル (容積別)を取得します。
getFinalInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書処理完了区分を取得します。
getFinish() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトの計画終了日を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
値参照期間の第一日目を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
値参照期間の第一日目を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
値参照期間の第一日目を取得します。
getFisPeriod() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計期間を取得します｡
getFisPeriod() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間を取得します｡
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度を取得します｡
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度を取得します｡
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当会計年度を取得します。
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当会計年度を取得します。
getFixLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要供給の一致に対する固定ロットサイズを取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日日付を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日日付を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixdatQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
納期と出荷数量の固定を取得します。
getFixdatQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixedLot() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定ロットサイズを取得します。
getFixedMilestoneDateBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン日付(基準)を取得します。
getFixedMilestoneDateForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定日付を取得します。
getFixedMilestoneTimeBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン時間(基準)を取得します。
getFixedMilestoneTimeForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定時間 (F)を取得します。
getFixedPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
固定期間を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
数量固定を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量固定区分を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
長さ 12 の文字項目を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
長さ 12 の文字項目を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFlagCadCall() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
CAD システムからコールを取得します。
getFlagOnline() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
No ALE Field Selectionを取得します。
getFlexibleDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: 可変期間を取得します。
getFloatFree() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕を取得します。
getFloatFreeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕 (予測)を取得します。
getFloatTotal() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計を取得します。
getFloatTotalFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計 (予測)を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物の階を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物の階を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物の階を取得します。
getFmTransDate() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
FM 取引日付を取得します｡
getFollowUp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
デフォルト後続アクティビティコードを取得します。
getFollowUp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
デフォルト後続アクティビティコードを取得します。
getFollowUp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
フォローアップ品目を取得します。
getFollowUpExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。
getFollowUpGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。
getFollowUpVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。
getForeDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最終需要予測日を取得します。
getForeModel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測モデルを取得します。
getForePds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測期間を取得します。
getForeProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測プロファイルを取得します。
getForeValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
予測値を取得します。
getForecFlowCont() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測フロー管理を取得します。
getForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日を取得します。
getForecastParameters() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
予測パラメータを取得します。
getForecastParametersList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
需要予測パラメータが既に存在するかチェックします。
getForecastParametersList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測パラメータを取得します。
getForecastValues(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
需要予測値のデータ転送が既に存在するかチェックします。
getForecastValuesList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測値のデータ転送を取得します。
getForecastView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要予測ビューを取得します。
getForecastView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
需要予測ビューを取得します。
getFormVal1() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal2() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal3() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal4() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal5() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
タグ列を取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
敬称テキストを取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
敬称テキストを取得します。
getFormula() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式番号を取得します。
getFormulaTotQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の合計数量の計算式を取得します。
getFormulaTotQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の合計数量の計算式を取得します。
getFormulaTotQtyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
合計数量の計算式は変更できませんを取得します。
getFormulaTotQtyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
合計数量の計算式は変更できませんを取得します。
getFormulaTotUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の総用途値の計算式を取得します。
getFormulaTotUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の総用途値の計算式を取得します。
getFormulaTotUsageNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
すべての用途値を計算する計算式は変更できませんを取得します。
getFormulaTotUsageNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
すべての用途値を計算する計算式は変更できませんを取得します。
getFreeItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
無償明細を取得します。
getFreeLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
自由制限を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前通貨を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算前通貨を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算前通貨を取得します。
getFromFactor() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を取得します。
getFromFactorV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を取得します。
getFromLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
下限を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
機能領域を取得します｡
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
機能領域を取得します｡
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
機能を取得します。
getFunctionalLocation() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能場所を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ファンドを取得します｡
getFund() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ファンドを取得します｡
getFund() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
ファンドを取得します｡
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
会計区分を取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
予算センタを取得します｡
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
予算センタを取得します｡
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
予算センタを取得します。
getFundsRes() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算執行伝票の伝票番号を取得します。
getFuturePr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
次期標準原価を取得します。
getFwdCons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 前方を取得します。
getFwdagent() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
海貨業者を取得します。
getFxdPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定価格連産品を取得します。
getFyVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
会計年度バリアントを取得します。
getFyVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計年度バリアントを取得します。
getGammaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ガンマ係数使用の平滑化のための季節指数を取得します。
getGdsRelevant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分:グローバルデータ同期関連を取得します。
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
一般データ情報を取得します｡
getGiDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫日付を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫日付を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出庫日付を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫時刻 (現地時間 - プラント参照)を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫時刻 (現地時間 - プラント参照)を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定項目情報一覧（GlAccインスタンスの配列）を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目情報一覧（GlAccインスタンスの配列）を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
G/L 勘定コードを取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
G/L 勘定コードを取得します。
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
G/L 勘定コードを取得します。
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
G/L 勘定コードを取得します。
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
レコード番号を設定します｡
getGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します｡
getGmCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
BAPI 在庫移動トランザクションのコード割当を取得します。
getGoodsMvtCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動に対するコードのトランザクションへの割当を取得します。
getGoodsMvtHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票ヘッダデータを取得します。
getGoodsMvtHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票ヘッダを取得します。
getGoodsMvtHeadret() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号/入出庫伝票会計年度を取得します。
getGoodsMvtItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票明細を取得します。
getGoodsMvtItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票明細を取得します。
getGoodsMvtRefEwm() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
BAdI 通信構造: 入出庫伝票 EWM 照会を取得します。
getGoodsMvtSerialNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
シリアル番号を取得します。
getGoodsMvtServPartDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
ServPartDataを取得します。
getGrBasediv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫基準の請求書照合区分を取得します。
getGrEndDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
入庫終了日付を取得します。
getGrEndTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
入庫終了時刻 (ローカル、プラントに関連)を取得します。
getGrGiSlipNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票番号を取得します。
getGrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫区分を取得します。
getGrMessage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
入庫メッセージ区分を取得します｡
getGrNonVal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
非評価入庫を取得します。
getGrNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫番号を取得します。
getGrPrTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫処理日数を取得します。
getGrPrTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
入庫処理日数を取得します。
getGrPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基準額を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
受領者を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受領者を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受領者を取得します。
getGrRcptx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGrToDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
納入最終期限を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
補助金を取得します｡
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
補助金を取得します｡
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
補助金を取得します｡
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
補助金を取得します。
getGroValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
総額を取得します。
getGrossWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総重量を取得します。
getGrossWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGrossWt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
総重量を取得します。
getGrossWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
総重量を取得します。
getGroupcond() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
グループ条件区分を取得します。
getGroupcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
グループ条件区分を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
グループ名を取得します。
getGrpKey1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 1を取得します。
getGrpKey1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 1を取得します。
getGrpKey2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 2を取得します。
getGrpKey2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 2を取得します。
getGrpReqmts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 所要量グループ化を取得します。
getGtinVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
グローバルトレード明細番号バリアントを取得します。
getGtinVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
グローバルトレード明細番号バリアントを取得します。
getGtsScrapNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
廃棄処理の税関参照番号を取得します。
getGtsStockType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
GTS在庫タイプを取得します。
getHCurr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通貨コードを取得します。
getHCurr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getHCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO 通貨コードを取得します。
getHandlgGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ワークロード計算のロジスティクス処理グループを取得します。
getHazMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物コードを取得します。
getHazMatNoExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
getHazMatNoGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
getHazMatNoVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
getHazmatprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物インジケータプロファイルを取得します。
getHeadData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
管理情報設定ヘッダセグメントが既に存在するかチェックします。
getHeadDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
管理情報設定ヘッダセグメントを取得します。
getHeaderTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
ヘッダテキスト一覧を取得します｡
getHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストを取得します｡
getHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票ヘッダテキストを取得します。
getHeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
高さを取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
BOM 構成の上位レベル明細を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getHiLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上位階層明細番号を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層ノード一覧（HierarchyNodesインスタンスの配列）を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層ノード一覧（HierarchyNodesインスタンスの配列）を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層ノード一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層値一覧（HierarchyValuesインスタンスの配列）を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層値一覧（HierarchyValuesインスタンスの配列）を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層値一覧を取得します。
getHierlevel() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層のエントリレベルを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを取得します。
getHighVisc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 高粘性を取得します。
getHistType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
購買発注履歴カテゴリを取得します。
getHistVals() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
履歴値の数を取得します。
getHlItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買伝票中の上位明細を取得します。
getHold() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買発注の不完全を取得します。
getHomeCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村 (郵便用市区町村と異なる場合)を取得します。
getHomecityno() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
別の市区町村 (市区町村/地名ファイル)を取得します。
getHomepage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
URI 例: ホームページ、FTP アドレスを取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地-号を取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地-号を取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地-号を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地補足を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地補足を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地補足を取得します。
getHouseNo3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地範囲を取得します。
getHuNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
外部荷役単位 IDを取得します。
getId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージクラスを取得します。
getId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージクラスを取得します。
getImpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を必要とする WBS 要素を取得します。
getImpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を必要とする WBS 要素を取得します。
getInCharge() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を取得します｡
getInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して利益センタ責任者を取得します。
getInChargeUser() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタの責任責任ユーザを取得します｡
getInChargeUser(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して利益センタに責任のあるユーザを取得します。
getInChargeUser() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
CO 内部指図の責任者を取得します。
getInHouse() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
内部生産を取得します。
getInHouse() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
内部生産を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ1を取得します｡
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ2を取得します｡
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (2)を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIndPostToInspStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質検査中在庫への転記を取得します。
getIndProposeQuanx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
提案数量 (初期数量)を取得します。
getIndSector() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
産業コードを取得します。
getIndSector() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
産業コードを取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード番号を取得します｡
getIndus3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目 CFOP カテゴリを取得します。
getInfIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数を取得します。
getInfoRec() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買情報番号を取得します。
getInfoRec() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買情報番号を取得します。
getInfoUpd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買情報更新区分を取得します。
getInform() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
情報行を取得します。
getInhseprodt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
内製日数を取得します。
getInitPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化で使用する履歴値の数を取得します。
getInitialize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化区分を取得します。
getInpfldcheck() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
項目無効時の応答を取得します。
getInquiryCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getInquiryCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: インスタンスを取得します。
getInquiryCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 部分設定を取得します。
getInquiryCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照明細/インスタンスを取得します。
getInquiryCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照データを取得します。
getInquiryCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 特性値を取得します。
getInquiryCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: バリアント条件キーを取得します。
getInquiryConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
条件を取得します。
getInquiryConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
受注における条件更新の通信項目を取得します。
getInquiryHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票ヘッダデータを取得します。
getInquiryHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
ヘッダデータチェックボックスを取得します。
getInquiryItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データを取得します。
getInquiryItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データチェックボックスを取得します。
getInquiryKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
参照キーの出力テーブルを取得します。
getInquiryPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
伝票取引先を取得します。
getInquirySchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行を取得します。
getInquirySchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行チェックボックスを取得します。
getInquiryTextList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テキストを取得します。
getInspInt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
次回再検査までの間隔を取得します。
getInspSetupFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目/プラントに QM 検査データ設定を取得します。
getInspoutGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
品質検査結果： EWM 設定の在庫 GUIDを取得します。
getInspoutGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
品質検査結果： EWM 設定の在庫 GUIDを取得します。
getInspoutGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
品質検査結果: EWM 設定の在庫 GUIDを取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細番号内部採番を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細番号内部採番を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細番号内部採番を取得します。
getIntObjNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
選定 (内部オブジェクト番号)を取得します。
getIntProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getIntProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getInterestProf() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getInternalChar() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
内部特性を取得します。
getInternalObjectId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 内部対象キーを取得します。
getInternationArticleNumbers(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
EANオブジェクトが既に存在するかチェックします。
getInternationArticleNumbersList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANを取得します。
getInternationalArtnos(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
国際商品コード (EAN)が既に存在するかチェックします。
getInternationalArtnosList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
国際商品コード (EAN)を取得します。
getInterop() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
移動時間を取得します。
getInvCorrFac() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
在庫修正係数を取得します。
getInvMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
会社固有 (内部) 在庫管理品目コードを取得します。
getInvMatNoExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
getInvMatNoGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
getInvMatNoVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
getInvestProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備投資案件プロファイルを取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInvoicePercentage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
請求金額率 (%)を取得します。
getIrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書受領区分を取得します。
getIsoLanguage() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
ISO639準拠を取得します｡
getIsoUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
単位の ISO コードを取得します。
getIssStLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫保管場所を取得します。
getIssueUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫単位を取得します。
getIssueUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの出庫単位を取得します。
getItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始明細を取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の明細カテゴリを取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
一般明細カテゴリグループを取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目マスタの明細カテゴリグループを取得します。
getItemCatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票の明細カテゴリを取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
明細カテゴリ (販売伝票)を取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細カテゴリ (販売伝票)を取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getItemIntvl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
明細番号間隔を取得します｡
getItemNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getItemNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理オブジェクト: 明細を取得します。
getItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストを取得します｡
getItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストを取得します｡
getItemText() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
明細テキストを取得します。
getItemText() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
明細テキストを取得します。
getItemTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細テキスト一覧を取得します｡
getItemguidAtp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ATP: 暗号 - DELNR および DELPSを取得します。
getItemguidAtp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号を取得します｡
getItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号を取得します｡
getItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号を取得します｡
getItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号を取得します｡
getItemsForRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
区分: 承認待ち購買発注のみ照会を取得します。
getItemsForRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
区分: 承認待ち購買発注のみ照会を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
明細番号 (販売管理伝票)を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
明細番号 (販売管理伝票)を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票明細を取得します。
getItmTypeUsage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細用途を取得します。
getItmTypeUsage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIvQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
請求数量を取得します。
getIvQtyPo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
購買価格数量単位による請求数量を取得します。
getIvQtyTotal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
請求書受領数量: 絶対額を取得します。
getIvvalFor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
外貨での入力請求額を取得します。
getIvvalFor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外貨での入力済請求額を取得します。
getIvvalLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨での入力請求額を取得します。
getIvvalLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨での入力請求額を取得します。
getJitRelvt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: JIT 納入日程の関連明細を取得します。
getJointVenture() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャを取得します。
getJointVenture() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャを取得します。
getJvJibClass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE クラスを取得します。
getJvJibClass() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE クラスを取得します。
getJvJibSubClassA() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE サブクラスAを取得します。
getJvJibSubClassA() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE サブクラスAを取得します。
getJvObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャ対象タイプを取得します。
getJvObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャ対象タイプを取得します。
getKanbanInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
かんばん区分を取得します。
getKblanguage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
システム設定の言語を取得します。
getKbname() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースオブジェクトを取得します。
getKbprofile() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースプロファイルを取得します。
getKbversion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
SCE ナレッジベースの実行時バージョンを取得します。
getKeepQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
EWM での廃棄処理の保持数量を取得します。
getLEquip1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1を取得します。
getLEquip2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2を取得します。
getLEquip3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3を取得します。
getLabelForm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベル書式を取得します。
getLabelType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベルタイプを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.financial.Language のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
言語キーを取得します。
getLanguCr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスレコード登録オリジナル言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.financial.Language のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーの ISO コードを取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
言語キーの ISO コードを取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
ISO 639 準拠の言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
言語を取得します｡
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
Language in which Texts are Read(言語情報)を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
Language in which Texts are Read(言語情報)を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ステータスおよび業務トランザクションテキストの言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ステータスおよび業務トランザクションテキストの言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
言語キーを取得します。
getLangucriso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を取得します。
getLastChnge() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最終変更日付を取得します。
getLastItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
最終明細番号を取得します。
getLatestDatesIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: 最遅日を取得します。
getLatestFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(日付)を取得します。
getLatestFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済終了日付(需要予測)を取得します。
getLatestFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(時間)を取得します。
getLatestFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画終了時間 (予測)を取得します。
getLatestStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(日付)を取得します。
getLatestStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始日付(需要予測)を取得します。
getLatestStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(時間)を取得します。
getLatestStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始時間(需要予測)を取得します。
getLeadinguom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
主要ロット特定数量単位を取得します。
getLeft() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getLength() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
長さを取得します。
getLeqUnit1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1 の数量単位を取得します。
getLeqUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 1 の数量単位を取得します。
getLeqUnit2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2 の数量単位を取得します。
getLeqUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 2 の数量単位を取得します。
getLeqUnit3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3 の数量単位を取得します。
getLeqUnit3Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 3 の数量単位を取得します。
getLiIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
レコード番号を取得します｡
getLifoFifo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO/FIFO 関連を取得します。
getLifoValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 関連品目データを取得します。
getLifoValuationLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価レベルを取得します。
getLifovaluationlevel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 評価レベルを取得します。
getLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
全体制限を取得します。
getLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
全体制限を取得します。
getLimitLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画外、明細制限を取得します。
getLimitsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注制限一覧を取得します｡
getLineDepth() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票での明細行階層レベルを取得します。
getLineDepth() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票での明細行階層レベルを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票明細行の一意 IDを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票明細行の一意 IDを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
伝票明細行の一意 IDを取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限の内部明細番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
内部明細番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細行番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
内部明細番号を取得します。
getLineTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
納入日程の提案時刻 (現地時間: 販売組織参照)を取得します。
getLineTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載日付を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載日付を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載時刻 (現地時間: 出荷ポイント)を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載時刻 (現地時間: 出荷ポイント)を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadinggrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
積載グループを取得します。
getLoadinggrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
積載グループを取得します。
getLocActcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総所得税の活動コードを取得します。
getLocActcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLocCurr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨コードを取得します。
getLocCurrIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨の ISO コードを取得します。
getLocDisttype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所得税の配賦タイプを取得します。
getLocDisttype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLocTaxcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税タイプを取得します。
getLocTaxcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLocTxrelclas() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税関連分類を取得します。
getLocTxrelclas() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLocZerovat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
locZerovatを取得します。
getLocZerovat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
場所を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 5を取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: メッセージシリアル番号を取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: メッセージシリアル番号を取得します。
getLogNo() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: ログ番号を取得します。
getLogNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: ログ番号を取得します。
getLogSystem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
論理システムを取得します。
getLogSystemOwn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを取得します。
getLogSystemOwn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
内部制御パラメータを取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
内部制御パラメータを取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
内部制御パラメータを取得します。
getLogsys() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
EWM 入出庫伝票の論理システムを取得します。
getLogsystem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
論理システムを取得します｡
getLongText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を取得します｡
getLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
getLongnum() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
Long Procurement Document Numberを取得します。
getLooseorliq() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バルク/液体を取得します。
getLotIncrement() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるためのロットサイズ増分を取得します。
getLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ロットサイズを取得します。
getLotsizekey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロットサイズ (品目計画)を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを取得します。
getMainEan() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
区分: 主要 EANを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
更新ステータスを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者製品コードを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品コードを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品コードを取得します。
getManufProf() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品プロファイルを取得します。
getManufProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品プロファイルを取得します。
getManufacturerPartNumbList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
製造業者と製造者製品コード一覧を取得します｡
getMaskId() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 要素 ID(短)の選択マスクを取得します。
getMastCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
期間依存条件伝票を取得します。
getMastContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
グループマスタ契約番号を取得します。
getMastContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMasterData() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図のマスタデータ構造を取得します。
getMasterData() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図のマスタデータ構造を取得します。
getMasterDataInactive() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
マスタレコードの無効化を取得します。
getMasterDataInactive() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
マスタレコードの無効化を取得します。
getMatCfop() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目 CFOP カテゴリを取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票番号を取得します。
getMatEntrd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入力品目を取得します。
getMatEntrd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatEntrdExternal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MAT_ENTRD の品目コード (長)を取得します。
getMatEntrdExternal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatEntrdGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MAT_ENTRD の外部 GUIDを取得します。
getMatEntrdGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatEntrdVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MAT_ENTRD のバージョン番号を取得します。
getMatEntrdVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMatGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目グループを取得します。
getMatGrpSm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループ: 梱包材を取得します。
getMatGrpTrans() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取替えマトリクスに対する品目のグループを取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMatOrigin() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の原産地を取得します。
getMatOrigin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の原産地を取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目価格設定グループを取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目価格設定グループを取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目更新完了ステータスを取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMatcmpllvl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目完了レベルを取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入出庫伝票の明細を取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票の明細を取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
入出庫伝票の明細を取得します。
getMatdocTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求の入出庫伝票番号を取得します。
getMatdocumentyear() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票会計年度を取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
品目コードを取得します｡
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
品目コードを取得します。
getMaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
品目テキストオブジェクトが既に存在するかチェックします。
getMaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目テキストが既に存在するかチェックします。
getMaterialDescriptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストを取得します。
getMaterialDescriptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目テキストを取得します。
getMaterialEvg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コード(長)を取得します。
getMaterialEvg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コード(長)を取得します。
getMaterialEvg() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コード(長)を取得します。
getMaterialExt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
外部品目コードを取得します。
getMaterialExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
外部品目コードを取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コード（長）を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 MATERIAL の品目コード(長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
項目 MATERIAL の品目コード (長)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の品目コード (長)を取得します｡
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialFixed() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロックされている品目を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードの外部GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 MATERIAL の外部GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
品目コード(外部 GUID)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
項目 MATERIAL の外部 GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の外部 GUIDを取得します｡
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
品目コード(外部 GUID)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialLongText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
テキスト (長)が既に存在するかチェックします。
getMaterialLongTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
テキスト (長)を取得します。
getMaterialRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
品目コードの範囲を取得します。
getMaterialShortDescselList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目テキストの選択オプション一覧を取得します｡
getMaterialText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
テキスト (長)オブジェクトが既に存在するかチェックします。
getMaterialTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長)を取得します。
getMaterialVers() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
品目バージョン番号を取得します。
getMaterialVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
品目バージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードのバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
項目 MATERIAL のバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL のバージョン番号を取得します｡
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialdocument() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号を取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目運賃グループを取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目運賃グループを取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatitemTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送数量入出庫伝票明細を取得します。
getMatlDesc() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目テキストを取得します。
getMatlDesc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目テキストを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatlGrp1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 1を取得します。
getMatlGrp2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 2を取得します。
getMatlGrp3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 3を取得します。
getMatlGrp4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 4を取得します。
getMatlGrp5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 5を取得します。
getMatlStats() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目統計グループを取得します。
getMatlType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目タイプを取得します。
getMatlType() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目タイプを取得します。
getMatlUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の用途を取得します。
getMatlUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の用途を取得します。
getMatnrHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
終了品目コードを取得します。
getMatnrListList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードと品目テキストの一覧を取得します｡
getMatnrLow() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
開始品目コードを取得します。
getMatnrSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードの選択オプション一覧を取得します｡
getMatyearTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求入出庫伝票年度を取得します。
getMaxLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最大ロットサイズを取得します。
getMaxPlDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細ごとの分割納入可能な最大回数を取得します。
getMaxPlDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxRows() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
選択予定品目の最大数を取得します｡
getMaxSbQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最大棚番在庫数量を取得します。
getMaxStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大在庫レベルを取得します。
getMaxdevDay() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
シフト所要日数を取得します。
getMaxdevDay() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxdevamnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (絶対値)を取得します。
getMaxdevamnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxdevper() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (%)を取得します。
getMaxdevper() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxlotsize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大ロットサイズを取得します。
getMeAnzSub() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位数を取得します。
getMeanAbsolDev() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
絶対平均偏差 (MAD)を取得します。
getMeanAbsolDevPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の平均絶対偏差を取得します。
getMemoryComplete() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがない場合に購買発注を保留にする区分を取得します｡
getMemoryUnComplete() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがある場合に購買発注を保留にする区分を取得します｡
getMerchidcl() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社のマーチャント IDを取得します。
getMerchidcl() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社のマーチャント IDを取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージテキストを取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージテキストを取得します。
getMessageId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージ IDを取得します。
getMessageNumber() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
システムメッセージ番号を取得します。
getMessageText() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージのテキスト行を取得します。
getMessageType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージタイプを取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV3() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV4() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMethod() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メソッドを取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者番号を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者番号を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者番号を取得します。
getMfrNoExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
外部製造者コード名または番号を取得します。
getMilestone() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
用途を取得します。
getMilestoneNumber() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン番号を取得します。
getMilestoneUsage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン用途を取得します。
getMilitId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ID: 武器を取得します。
getMinDely() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
納品書処理時の最小納入数量を取得します。
getMinLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最小ロットサイズを取得します。
getMinMto() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
受注製造品最少受注数量を取得します。
getMinOrder() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
基本数量単位での最小受注数量を取得します。
getMinSafetyStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小安全在庫を取得します。
getMinSbQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最小棚番在庫数量を取得します。
getMinlotsize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小ロットサイズを取得します。
getMinremlife() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
最低有効期間残を取得します。
getMinremlife() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最低有効期間残を取得します。
getMixedMrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
二重 MRP 区分を取得します。
getMlActive() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目レベルで有効な品目元帳を取得します。
getMlSettle() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目元帳決済: 管理を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
マニュアル請求書更新を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
マニュアル請求書更新を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getModelSi() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択区分を取得します。
getModelSp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択方式を取得します。
getMovPrPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期移動平均原価/期間平均原価を取得します。
getMovPrPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の移動平均原価/期間単価を取得します。
getMoveBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫ロットを取得します。
getMoveBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫ロットを取得します。
getMoveGtsStockType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
GTS在庫タイプを取得します。
getMoveMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫品目を取得します。
getMoveMat() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫品目を取得します。
getMoveMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getMoveMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getMoveMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
getMoveMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
getMoveMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getMoveMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getMovePlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫プラントを取得します。
getMovePlant() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫プラントを取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
移動理由を取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動理由を取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動理由を取得します。
getMoveStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫保管場所を取得します。
getMoveStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫保管場所を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
移動タイプ (在庫管理)を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動タイプ (在庫管理)を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動タイプ (在庫管理)を取得します。
getMoveTypeRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
移動タイプの範囲を取得します。
getMoveValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
転送ロットの評価タイプを取得します。
getMoveValType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
転送ロットの評価タイプを取得します。
getMovingPr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
移動平均原価/期間単位価格を取得します。
getMrpAreaExists() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: MRP エリア登録済を取得します。
getMrpCtrler() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP 管理者を取得します。
getMrpGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP グループを取得します。
getMrpInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP 区分を取得します。
getMrpRelevancyDepRequirements() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
従属所要量と MRP の関連性を取得します。
getMrpType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP タイプを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目: MRP プロファイルを取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目利用可能日を取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目利用可能日を取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目供給ステージ (現地時刻: プラント参照)を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目供給ステージ (現地時刻: プラント参照)を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMsgToIm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
区分: 在庫管理への出力を取得します。
getMultRefM() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照品目の乗数を取得します。
getMvtInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動区分を取得します。
getMvtInd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動区分を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域を指定して管理領域名を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定して一般名称を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
発注者名称を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
名称 1を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 2を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 2を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 2を取得します。
getName3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 3を取得します。
getName3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 3を取得します。
getName4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 4を取得します。
getName4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 4を取得します。
getName_2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 2を取得します。
getName_3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 3を取得します。
getName_4() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 4を取得します。
getNbSlips() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫票の印刷部数を取得します。
getNbSlipsx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNegPostng() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
フラグ: マイナス転記を取得します｡
getNegPostng() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
フラグ: マイナス転記を取得します｡
getNegPostng() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
フラグ: マイナス転記を取得します｡
getNegPostng() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
フラグ: マイナス転記を取得します｡
getNegStocks() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントにおけるマイナス在庫許可を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
通貨額を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
正味価格を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
正味価格を取得します。
getNetValHd() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注正味額 (伝票通貨)を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買発注通貨による正味発注額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細の正味額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
正味金額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票通貨による正味額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票通貨での受注明細正味額を取得します。
getNetValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
勘定割当のネットワーク番号を取得します｡
getNetwork() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
勘定割当のネットワーク番号を取得します｡
getNetwork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定割当のネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
勘定割当のネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
勘定割当のネットワーク番号を取得します。
getNetworkAssignment() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ネットワーク割当を取得します。
getNetworkAssignment() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワーク割当を取得します。
getNetworkProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワークプロファイルを取得します。
getNoAuthority() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
権限チェックなし区分を取得します｡
getNoCommit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
コミットワーク はい/いいえを取得します。
getNoCosting() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算なしを取得します。
getNoDisct() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
現金値引対象外明細を取得します。
getNoFrlimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを取得します。
getNoGrPost() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先が入庫を転記していませんを取得します。
getNoGrPost() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNoLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限なしを取得します。
getNoLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを取得します。
getNoMatmast() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目マスタ確認禁止を取得します。
getNoMessageReq() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
メッセージ不要区分を取得します｡
getNoMessaging() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出力決定なし区分を取得します｡
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納入完了 区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
納入完了区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
納入完了 区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
納入完了 区分を取得します。
getNoPriceFromPo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
最終伝票からの価格転送なし区分を取得します｡
getNoPstChgnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 振替要求通知登録禁止を取得します。
getNoRollbackWork() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
Override Rollback Workを取得します。
getNoRounding() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注明細での非表示丸めを取得します。
getNoSheets() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書枚数 (文書管理システムによらない)を取得します。
getNoTransferReq() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 転送要求未登録を取得します。
getNoappllog() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
アプリケーションログ書込なしを取得します。
getNochangedoc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
変更伝票書込なしを取得します。
getNondItax() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getNostructure() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
チェックボックスを取得します。
getNotMrpApplicable() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。
getNotifNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通知番号を取得します。
getNotifNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ番号を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ番号を取得します。
getNumberOfCapacities() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
所要能力数を取得します。
getNumconvert() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分子を取得します。
getNumconvert() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分子を取得します。
getNumerator() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
基本数量単位への換算分子を取得します。
getObjId() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
参照伝票: 現在の IDを取得します｡
getObjId() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
参照伝票: 現在の IDを取得します｡
getObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
参照キーを取得します｡
getObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーを取得します｡
getObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
オブジェクトキーを取得します｡
getObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
オブジェクトキーを取得します｡
getObjKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象キーを取得します。
getObjKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象キーを取得します。
getObjKeyP() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)を取得します｡
getObjKeyR() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
取消: オブジェクトキー (AWREF_REV と AWORG_REV)を取得します｡
getObjPos() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
参照明細を取得します｡
getObjPos() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
参照明細を取得します｡
getObjPosP() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
前伝票: 参照明細を取得します｡
getObjSys() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
参照システムを取得します｡
getObjSys() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
元伝票の論理システムを取得します｡
getObjSys() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
元伝票の論理システムを取得します｡
getObjSys() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
元伝票の論理システムを取得します｡
getObjTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
言語依存対象テキストを取得します。
getObjTypP() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
前伝票: 参照処理を取得します｡
getObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
参照処理を取得します｡
getObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理を取得します｡
getObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
参照処理を取得します｡
getObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
参照処理を取得します｡
getObjType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象タイプを取得します。
getObjType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象タイプを取得します。
getObjectGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス用 TYPE_OF ステートメントの GUIDを取得します。
getObjectNo() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
対象番号を取得します。
getObjectNo() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
対象番号を取得します。
getObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
オブジェクトタイプを取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス (言語非依存)を取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
対象クラスを取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
対象クラスを取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス、言語依存を取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
オブジェクトクラス、言語依存を取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
オブジェクトクラス、言語依存を取得します。
getOffsetMilestoneDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン日付のオフセットを取得します。
getOffsetMilestoneDateUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーンのオフセットのための時間単位を取得します。
getOffsetMilestoneDateUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
単位の ISO コードを取得します。
getOffsetPercentage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
活動日に対するマイルストーンの百分率によるオフセットを取得します。
getOffsetStartEndIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: オフセット用の参照（開始/終了活動日）を取得します。
getOldMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
旧品目コードを取得します。
getOpenQty() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
未処理数量のある明細を取得します。
getOperationMeasureUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動単位を取得します。
getOperationMeasureUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getOptimLev() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最適化レベルを取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOrdCosts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注原価 (BAPI インタフェース)を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注理由 (取引理由)を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注理由 (取引理由)を取得します。
getOrdbilltyp() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注関連請求伝票に対する提案請求伝票タイプを取得します。
getOrdcombIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注結合出荷区分を取得します。
getOrdcombIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrdcombind() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
受注結合区分を取得します。
getOrdcompIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
受注結合出荷区分を取得します。
getOrdcompIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (個別値、または下限値)を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (個別値、または下限値)を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図番号を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
指図番号を取得します。
getOrderCcardList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
クレジットカードデータを取得します。
getOrderCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getOrderCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: インスタンスを取得します。
getOrderCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 部分設定を取得します。
getOrderCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照明細/インスタンスを取得します。
getOrderCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照データを取得します。
getOrderCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 特性値を取得します。
getOrderCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: バリアント条件キーを取得します。
getOrderConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件を取得します。
getOrderConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件チェックボックスを取得します。
getOrderExternalNo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (個別値、または下限値)を取得します。
getOrderExternalNo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (個別値、または下限値)を取得します。
getOrderExternalNoTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (上限値)を取得します。
getOrderExternalNoTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (上限値)を取得します。
getOrderHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票ヘッダを取得します。
getOrderHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票チェックリストを取得します。
getOrderItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データを取得します。
getOrderItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データチェックボックスを取得します。
getOrderItno() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図明細番号を取得します。
getOrderItno() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図明細番号を取得します。
getOrderKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
参照キーの出力テーブルを取得します。
getOrderListList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
選択指図一覧を取得します。
getOrderListList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
選択指図一覧を取得します。
getOrderName() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
テキストを取得します。
getOrderName() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
テキストを取得します。
getOrderPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
伝票取引先を取得します。
getOrderProb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の受注可能性を取得します。
getOrderProb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrderReason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注理由を取得します。
getOrderSchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データを取得します。
getOrderSchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データチェックボックスを取得します。
getOrderTextList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テキストを取得します。
getOrderTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (上限値)を取得します。
getOrderTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (上限値)を取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
販売伝票タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
販売伝票タイプを取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号を取得します｡
getOrderid() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
指図番号を取得します｡
getOrderid() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格単位を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注価格単位 (購買管理)を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注価格単位 (購買管理)を取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格のISOコードを取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getOrigAccept() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先構内での受領を取得します。
getOrigGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
発生源グループ (原価要素の下位区分)を取得します。
getOrigMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目発生源を取得します。
getOriginalBatchFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロット管理区分を取得します。
getOriginalBatchRefMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロットの参照品目を取得します。
getOriginalBatchRefMaterialE() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
オリジナルロット参照品目を取得します。
getOriginalBatchRefMaterialG() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
オリジナルロット参照品目を取得します。
getOriginalBatchRefMaterialV() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
オリジナルロット参照品目を取得します。
getOrigindoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始伝票を取得します。
getOrvaltype() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
購買発注額/受注額の金額タイプを取得します｡
getOurRef() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
社内参照番号を取得します｡
getOutlInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
区分: 出力行を取得します。
getOutlLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
グループの階層レベルを取得します。
getOutlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
アウトラインレベルを取得します。
getOverDlvTol() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
過剰納入許容範囲を取得します。
getOverTol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
過剰納入許容範囲リミットを取得します。
getOverallprf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
指図変更管理の全体プロファイルを取得します。
getOverdlvtol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
過剰納入許容範囲を取得します。
getOverdlvtol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOverhdKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
間接費キーを取得します。
getOverhdKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOverheadGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算間接費グループを取得します。
getOverheadKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
間接費キーを取得します。
getOverheadKey() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
間接費キーを取得します。
getOvfTol() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
超過許容値を取得します。
getOvfUnlim() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
契約外サービス制限なしを取得します。
getPMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getPMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
getPMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getPMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
レコード番号を取得します｡
getPackVoUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容積単位 (許容梱包容積)を取得します。
getPackVoUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの容積単位 (許容梱包容積)を取得します。
getPackWtUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位 (許容梱包重量)を取得します。
getPackWtUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位 (許容梱包重量)を取得します。
getPageNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書ページ番号 (文書管理システムによらない)を取得します。
getPageformat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造メモのページ書式を取得します。
getParCompco() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済会社コードを取得します。
getParEff() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効性パラメータへの値割当/変更番号よりも優先を取得します。
getParallelQty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
Quantity in Parallel Unit of Measureを取得します。
getParallelUom() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
Parallel Unit of Measureを取得します。
getParamOpt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
パラメータ最適化用の区分を取得します。
getParameter() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータ名を取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
1 レベル上位の行 IDを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
1 レベル上位の行 IDを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
取引先勘定コードを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
取引先勘定コードを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引先勘定コードを取得します。
getPartDeliv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
明細レベルでの分割納入 (在庫転送)を取得します。
getPartDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細レベルの分納納入を取得します。
getPartDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPartInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
一部請求区分を取得します。
getPartOfGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
インスタンス用 PART_OF ステートメントの GUIDを取得します。
getPartOfNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
Part_of 明細番号を取得します。
getPartPrctr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
パートナ利益センタを取得します｡
getPartPrctr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
パートナ利益センタを取得します｡
getPartnNumb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
得意先コード 1を取得します。
getPartnRole() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
取引先機能を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerFund() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
パートナファンドを取得します｡
getPartnerFund() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
パートナファンドを取得します｡
getPartnerGrantNbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
パートナ補助金を取得します｡
getPartnerGrantNbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
パートナ補助金を取得します｡
getPartnerList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
得意先一覧を取得します｡
getPartnerSegment() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
セグメントレポートのパートナセグメントを取得します｡
getPartnerSegment() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
セグメントレポートのパートナセグメントを取得します｡
getPartnerdesc() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語別取引先機能テキストを取得します。
getPayer() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払人を取得します。
getPaymentTerms() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払条件キーを取得します。
getPaytype() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払手段: 支払カード計画の明細分類を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
パッケージ番号を取得します。
getPcode1Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。
getPcode2Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。
getPcode3Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。
getPctrName() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を取得します｡
getPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して一般名称を取得します。
getPerCurCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
現行標準原価見積期間を取得します。
getPerFutCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積期間を取得します。
getPerPreCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前標準原価見積期間を取得します。
getPercentOfWork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業の比率 (%)を取得します。
getPercentage() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定金額配賦のパーセントを取得します。
getPercentageOfCompletion() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗度 (%)を取得します。
getPeriodInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
期間区分を取得します。
getPeriodInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
期間区分を取得します。
getPeriodIndExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
有効期間期限日の期間区分を取得します。
getPeriodIndExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日の期間区分を取得します。
getPeriodProfileSafetyTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間の期間プロファイルを取得します。
getPersNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
従業員番号を取得します。
getPersistId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号 (固定)を取得します。
getPersistIdType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号タイプ (固定)を取得します。
getPersonInChargeFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
責任者（開始値）を取得します。
getPersonInChargeFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
責任者（開始値）を取得します。
getPersonInChargeTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
責任者（終了値）を取得します。
getPersonInChargeTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
責任者（終了値）を取得します。
getPersonInChargeUserFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
担当ユーザ（開始値）を取得します。
getPersonInChargeUserFrom() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
担当ユーザ（開始値）を取得します。
getPersonInChargeUserTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
担当ユーザ（終了値）を取得します。
getPersonInChargeUserTo() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
担当ユーザ（終了値）を取得します。
getPersonNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
従業員番号を取得します｡
getPersonResp() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者を取得します。
getPersonRespPhone() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者の電話番号を取得します。
getPickArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
ピッキングエリアを取得します。
getPickgArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
簡易倉庫管理のピッキングエリアを取得します。
getPlRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包方法が同じ品目の参照品目を取得します。
getPlRefMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT の品目コード(長)を取得します。
getPlRefMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT の外部GUIDを取得します。
getPlRefMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT のバージョン番号を取得します。
getPlTiFnce() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画タイムフェンスを取得します。
getPlacement() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫受入に対する保管域タイプ検索区分を取得します。
getPlanBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト基準日付計画方法を取得します。
getPlanDel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
予定納入日数を取得します。
getPlanFcst() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト予測日付の計画方法を取得します。
getPlanProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
計画プロファイルを取得します。
getPlanSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行タイプ EDIを取得します。
getPlanSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlanStrgp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画方針グループを取得します。
getPlanlistcnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
グループカウンタを取得します。
getPlanlistgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストグループのキーを取得します。
getPlannedCost() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画原価を取得します。
getPlanningData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ/製品グループの変更伝票構造を取得します。
getPlanningDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。
getPlanningDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ/製品グループの変更伝票構造を取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
プラントを取得します。
getPlantData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (プラントレベル)を取得します。
getPlantDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (プラントレベル)が既に存在するかチェックします。
getPlantDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (プラントレベル)を取得します。
getPlantHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 終了を取得します。
getPlantLow() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 開始を取得します。
getPlantRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
プラントの範囲を取得します。
getPlantSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
プラントの選択オプション一覧を取得します｡
getPldlvshdin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷計画に関する指示を取得します。
getPldlvshdin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPldlvstyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
MRP: 出荷計画タイプを取得します。
getPldlvstyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlnClose() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画終了日付を取得します。
getPlnCompletion() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画完了日を取得します。
getPlnLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画梱包明細行を取得します。
getPlnPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号供給元一覧を取得します。
getPlnRelease() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画リリース日付を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価を取得します。
getPlndprdate1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 1 の有効開始日を取得します。
getPlndprdate2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 2 の有効開始日を取得します。
getPlndprdate3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 3 の有効開始日を取得します。
getPlndprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 1を取得します。
getPlndprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 2を取得します。
getPlndprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 3を取得します。
getPlngCycle() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画サイクルを取得します。
getPlngMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目を取得します。
getPlngMatlExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。
getPlngMatlGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。
getPlngMatlVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。
getPlngPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画プラントを取得します。
getPlordCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
アクション管理: 計画手配処理を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
支払条件キーを取得します｡
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払保証決定表を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払保証決定表を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtmthsupl() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法追加を取得します｡
getPoBox() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱住所を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱住所を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所を取得します。
getPoBoxReg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の地域 (国、都道府県、地域、...)を取得します。
getPoCtryiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注日付を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注日付を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程の購買発注日付を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買伝票の明細番号を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
元となる購買発注の明細番号を取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注タイプを取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注タイプを取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注タイプを取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注タイプを取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票を取得します｡
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買伝票番号を取得します｡
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注番号を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
購買発注価格単位での数量を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
数量 (購買発注価格単位)を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量 (購買発注価格単位)を取得します。
getPoPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格採用区分を取得します。
getPoRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
承認コードを取得します。
getPoRelInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
承認区分: 購買伝票を取得します。
getPoSupplem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注番号補足を取得します。
getPoSupplem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注単位を取得します。
getPoUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
発注単位を取得します。
getPoUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
ISOコードによる発注単位を取得します。
getPoUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードによる発注単位を取得します。
getPoWONo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
フラグ: 郵便私書箱 (番号なし)を取得します。
getPoboxCtry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の国指定を取得します。
getPobxCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱住所を取得します。
getPobxPcd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱番号を取得します。
getPointUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位を取得します。
getPointUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位の ISO コードを取得します。
getPoints() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベートポイント数を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoolnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO 評価でのプール番号を取得します。
getPoolnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価でのプール番号を取得します。
getPosex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部明細番号を取得します。
getPosex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部明細番号を取得します。
getPostDate() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの転記日付を取得します。
getPostDate() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの転記日付を取得します。
getPosting() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
Posting category:postを取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村の郵便番号を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村の郵便番号を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村の郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
郵便番号を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
郵便番号を取得します。
getPpSearch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
品目提案検索条件を取得します。
getPpSearch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPpcPlCal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PPC 計画カレンダを取得します。
getPrClosed() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買依頼処理済を取得します。
getPrCtrlPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期間の原価管理区分を取得します。
getPrCtrlPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の原価管理区分を取得します。
getPrIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
レコード番号を取得します｡
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrRefMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PR_REF_MAT の品目コード(長)を取得します。
getPrRefMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getPrRefMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PR_REF_MAT の外部GUIDを取得します。
getPrRefMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
getPrRefMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT のバージョン番号を取得します。
getPrRefMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getPrUname() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を取得します。
getPrUnitPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期価格単位を取得します。
getPrUnitPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度価格単位を取得します。
getPrcGroup1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 1を取得します。
getPrcGroup1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 2を取得します。
getPrcGroup2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 3を取得します。
getPrcGroup3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 4を取得します。
getPrcGroup4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 5を取得します。
getPrcGroup5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcStatH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票の全処理ステータスを取得します。
getPreAuth() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 事前承認を取得します。
getPreVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
製造元/販売元を取得します。
getPrefStatFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 特恵関税 - 輸出/輸入を取得します。
getPreqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼の明細番号を取得します。
getPreqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼の明細番号を取得します。
getPreqName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼者名/要求者名を取得します。
getPreqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼番号を取得します。
getPreqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼番号を取得します。
getPrevPlanPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を取得します。
getPrice() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
入力シートの価格変更を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力シートの価格変更を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getPriceCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価管理区分を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格グループ (得意先)を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格グループ (得意先)を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格表タイプを取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格表タイプを取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
価格単位を取得します。
getPricedate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日カテゴリ (価格設定日管理)を取得します。
getPricing() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
価格設定タイプを取得します。
getPrioRequirement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
所要量の優先順位を取得します。
getPrioUrgency() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
所要量の緊急度を取得します。
getPriority() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
優先度を取得します。
getPriority() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
優先度を取得します。
getPrivAddr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
自宅住所を取得します。
getPrntPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格印刷を取得します。
getProcRule() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達規則を取得します。
getProcTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
処理時間を取得します。
getProcType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達タイプを取得します。
getProcedure() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。
getProcessId() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
購買発注履歴取引タイプを取得します。
getProcessingGroup() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
処理グループを取得します。
getProcureUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量消費の数量単位を取得します。
getProcureUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの保管容量消費の数量単位を取得します。
getProdAlloc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品割当決定手順を取得します。
getProdAtt1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ID: 製品属性 1を取得します。
getProdAtt10() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 10 用 IDを取得します。
getProdAtt2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 2 用 IDを取得します。
getProdAtt3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 3 用 IDを取得します。
getProdAtt4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 4 用 IDを取得します。
getProdAtt5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 5 用 IDを取得します。
getProdAtt6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 6 の IDを取得します。
getProdAtt7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 7 用 IDを取得します。
getProdAtt8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 8 用 IDを取得します。
getProdAtt9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 9を取得します。
getProdCompositionOnPackaging() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 梱包材にプリントされた生産構造を取得します。
getProdConvType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産値の変換タイプを取得します。
getProdDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット製造日付を取得します。
getProdDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット製造日付を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目階層を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目階層を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目階層を取得します。
getProdHiera() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目階層を取得します。
getProdHiera() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProdMemo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造/検査メモを取得します。
getProdUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位を取得します。
getProdUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位 (ISO コード)を取得します。
getProdcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品カタログ番号を取得します。
getProdcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProdcomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産統計: 貿易における PRODCOM コードを取得します。
getProdprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画プロファイルを取得します。
getProductionResourceToolData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を取得します。
getProductionScheduler() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画担当を取得します。
getProdverscs() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算を行う製造バージョンを取得します。
getProfitCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します｡
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧（ProfitCenterインスタンスの配列）を取得します。
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧（ProfitCenterインスタンスの配列）を取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
利益センタを取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
利益センタを取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmentList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入出庫予定一覧を取得します｡
getProjType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクトタイプを取得します。
getProjectCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 通貨(プロジェクト定義)を取得します。
getProjectCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ISO 通貨コードを取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクト定義を識別するキーを取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクト定義を識別するキーを取得します。
getProjectDefinitionInfo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクトについての詳細情報を取得します。
getProjectDefinitionInfo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクトについての詳細情報を取得します。
getProjectProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトプロファイルを取得します。
getProjectStock() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト在庫を取得します。
getProjectSummarization() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: プロジェクト集計用に活動を考慮を取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
プロモーションを取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プロモーションを取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrtData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。
getPrtDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を取得します。
getPrtUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途を取得します。
getPrtUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途を取得します。
getPrtView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産資源/治工具 (PRT) ビューを取得します。
getPrtView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
生産資源/治工具 (PRT) ビューを取得します。
getPsConfMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
選定可能品目を取得します。
getPsConfMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PS_CO 項目の(将来の開発用)品目コード(長)を取得します。
getPsConfMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PS_CONF_MAT 項目の外部 GUID (将来の開発用)を取得します。
getPsConfMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PS_CONF_MAT 項目のバージョン番号 (将来の開発用)を取得します。
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付を取得します｡
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付を取得します｡
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
伝票の転記日付を取得します｡
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票の転記日付を取得します。
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の転記日付を取得します。
getPstngDateRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
登録日付の範囲を取得します。
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買グループを取得します。
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買グループを取得します｡
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買グループを取得します。
getPurMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
品目コードを取得します。
getPurMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目コードを取得します。
getPurMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 PUR_MAT の品目コード (長)を取得します。
getPurMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。
getPurMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 PUR_MAT の外部 GUIDを取得します。
getPurMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。
getPurMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 PUR_MAT のバージョン番号を取得します。
getPurMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。
getPurStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目ステータスを取得します。
getPurStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント特有品目ステータスを取得します。
getPurValkey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
購買許容値キーを取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注日付を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注日付を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
得意先発注番号を取得します。
getPurchNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を取得します｡
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の得意先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の得意先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchOrd() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先発注番号を取得します。
getPurchOrg() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買組織を取得します。
getPurchOrg() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買組織を取得します｡
getPurchView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買管理ビューを取得します。
getPurchaseAccountList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
勘定設定一覧を取得します｡
getPurchaseComponentsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
コンポーネント一覧を取得します｡
getPurchaseConfirmationList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
転送構造：照会／一覧一覧を取得します｡
getPurchaseGetItemSrel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認対象一覧情報を取得します｡
getPurchaseHeadersList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票ヘッダ一覧（PurchaseHeadersインスタンスの配列）を取得します。
getPurchaseHeadersList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票ヘッダ一覧を取得します。
getPurchaseHistoryList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注履歴を取得します｡
getPurchaseHistoryTotalsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注履歴(合計)を取得します｡
getPurchaseItemPostList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細一覧を取得します｡
getPurchaseItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票明細一覧（PurchaseItemsインスタンスの配列）を取得します｡
getPurchaseItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票明細一覧を取得します。
getPurchaseOrder() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号を取得します。
getPurchaseOrderNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号1を取得します。
getPurchaseScheduleList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
納入日程一覧を取得します｡
getPurchaseShippingExpList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷データエクスポート一覧を取得します｡
getPurchaseShippingList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷データ一覧を取得します｡
getPurchaseView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
購買管理ビューを取得します。
getPurchaseorder() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
購買発注番号を取得します。
getPushDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: プッシュ配賦を取得します。
getPvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目のステータス有効開始日付を取得します。
getPvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント品目ステータス有効期間開始日を取得します。
getPymtAmt() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払通貨額を取得します｡
getPymtCur() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
自動支払通貨を取得します｡
getPymtCurIso() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ISO コード通貨を取得します｡
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を取得します｡
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払方法を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払方法を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQmAuthgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
QM における活動の品目権限グループを取得します。
getQmProcmnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達における品質管理有効を取得します。
getQmRgmts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
仕入先の必須 QM システムを取得します。
getQtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積/引合有効開始日を取得します。
getQtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積の有効終了日を取得します。
getQtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQtyGrGi() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
数量: 印刷予定入出庫票数を取得します。
getQtyStruct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
数量構成により原価計算を行う品目を取得します。
getQualDik() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
無償納入による割引対象品目を取得します。
getQualInsp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
在庫タイプを取得します。
getQualityView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質管理ビューを取得します。
getQualityView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品質管理ビューを取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
数量を取得します｡
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
+/- 記号あり/なし数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
+/- 記号あり/なし数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認による数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
計画数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス数量を取得します。
getQuantityUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
数量単位を取得します。
getQuotDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積提出日を取得します｡
getQuotDead() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を取得します。
getQuotation() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積番号を取得します｡
getQuotationCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getQuotationCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: インスタンスを取得します。
getQuotationCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 部分設定を取得します。
getQuotationCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照明細/インスタンスを取得します。
getQuotationCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照データを取得します。
getQuotationCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 特性値を取得します。
getQuotationCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: バリアント条件キーを取得します。
getQuotationConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
条件を取得します。
getQuotationConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
受注における条件更新の通信項目を取得します。
getQuotationHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダデータを取得します。
getQuotationHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダチェックボックスを取得します。
getQuotationItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データを取得します。
getQuotationItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データチェックボックスを取得します。
getQuotationKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
参照キーの出力テーブルを取得します。
getQuotationPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票取引先を取得します。
getQuotationSchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データを取得します。
getQuotationSchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データチェックボックスを取得します。
getQuotationTextList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テキストを取得します。
getQuotausage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給量割当の使用を取得します。
getRPromo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
プロモーションを取得します。
getRadrcheck1() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 住所チェックの結果 (住所結果)を取得します。
getRadrcheck2() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 住所チェックの結果 (住所承認)を取得します。
getRadrcheck3() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 住所チェックの結果 (郵便番号結果)を取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算レートタイプを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レートタイプを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レートタイプを取得します。
getRcardcheck() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カードチェックの結果 (返信コード)を取得します。
getRcvgVend() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
未使用項目を取得します。
getReaForRe() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
見積および受注の拒否理由を取得します｡
getReadAtpLock() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
管理区分:利用可能在庫確認を取得します。
getReadAtpLockX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReason() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更理由を取得します。
getReason() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更理由を取得します。
getReasonCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
取消理由を取得します。
getReasonCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
Goods Receipt Reason Codeを取得します。
getReasonCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Goods Receipt Reason Codeを取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積および受注の拒否理由を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見積および受注の拒否理由を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積および受注の拒否理由を取得します。
getReasonRev() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
反対仕訳理由を取得します｡
getRebateGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
取引量リベートグループを取得します。
getRecInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
リカバリフラグを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
入荷ポイントを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入荷ポイントを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRecTime() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
登録時刻を取得します。
getReceiptRel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
区分: 入庫関連の確認を取得します。
getRecoveryInd() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
リカバリフラグを取得します。
getRecoveryInd() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
リカバリフラグを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先/仕入先の内部参照コードを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先/仕入先の内部参照コードを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先文字を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先文字を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
決済の参照日付を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
決済の参照日付を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済の参照日付を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照伝票番号を取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocEwm() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
EWM 入出庫伝票番号を取得します。
getRefDocHigh() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の終了伝票番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票の明細を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照明細番号を取得します。
getRefDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照明細番号を取得します。
getRefDocL() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を取得します。
getRefDocL() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocLLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。
getRefDocLow() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の開始伝票番号を取得します。
getRefDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号を取得します｡
getRefDocNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票番号を取得します。
getRefDocNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号を取得します。
getRefDocNoLong() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を取得します｡
getRefDocNoLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を取得します。
getRefDocNoLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を取得します。
getRefDocRange() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
前伝票の範囲を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票の会計年度を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の会計年度を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の会計年度を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票の明細を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照明細番号を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照明細番号を取得します。
getRefKey1() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを取得します｡
getRefKey1() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
取引先参照キーを取得します｡
getRefKey2() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを取得します｡
getRefKey2() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
取引先参照キーを取得します｡
getRefKey3() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細の参照キーを取得します｡
getRefKey3() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細の参照キーを取得します｡
getRefKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
参照キーは変更できませんを取得します。
getRefKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
参照キーは変更できませんを取得します。
getRefProc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照限定条件: 決定区分を取得します。
getRefProc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
基本数量単位による参照数量を取得します。
getRefUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目マスタレコードの数量単位初期値を取得します。
getRef_1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先/仕入先の内部参照コードを取得します｡
getRefdocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefdocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefdoctype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照オブジェクトの伝票タイプを取得します。
getReferencePoint() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
BOM 転送の参照ポイントを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
論理システムを取得します。
getRefmatcons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照品目を取得します。
getRefmatconsExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。
getRefmatconsGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。
getRefmatconsVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。
getRefobject() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクト名を取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトキーを取得します。
getRefobjtyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトタイプを取得します。
getRefpltcons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照プラントを取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域構造グループ化を取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地域構造グループ化を取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域構造グループ化を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地域 (都道府県)を取得します。
getRegionorig() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産地 (非特恵対象地区の原産)を取得します。
getRegionorig() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産地 (非特恵対象地区の原産)を取得します。
getRejReason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積および受注の拒否理由を取得します。
getRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認コードを取得します。
getRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認コードを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認グループを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認グループを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認グループを取得します。
getRelInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認区分: 購買伝票を取得します。
getRelIndicatorNew() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却規承認区分を取得します。
getRelStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
承認状況を取得します｡
getRelStatusNew() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認状況を取得します。
getRelStrat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認方針を取得します。
getRelType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
承認タイプを取得します。
getRelType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReleaseDate() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認日を取得します。
getReleaseTime() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認時刻を取得します。
getReleasebyPur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認購買担当者名を取得します。
getReleasedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認者名を取得します。
getReleasedatePur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認日付を取得します。
getReleasetimePur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認時刻を取得します。
getReminder1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第一回催促状/督促状の日数を取得します。
getReminder2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第二回催促状/督促状の日数を取得します。
getReminder3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第三回催促状/督促状の日数を取得します。
getReorderPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注点を取得します。
getReorderPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する発注点を取得します。
getRepManuf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 繰返生産許可を取得します。
getReplQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する補充数量を取得します。
getReplacePt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
取替部品を取得します。
getReplenQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
補充数量を取得します。
getReplentime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
補充リードタイム合計 (稼動日数)を取得します。
getRepmanprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
繰返生産プロファイルを取得します。
getReqBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更を依頼した従業員を取得します。
getReqBy() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更を依頼した従業員を取得します。
getReqByExt() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの外部変更番号を取得します。
getReqByExt() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの外部変更番号を取得します。
getReqClosed() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼処理済を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
構成品目の所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
指定納期を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入日程日付を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
指定納入期日を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
指定納入期日を取得します。
getReqDlvBl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出荷ブロック中の納入日程行を取得します。
getReqDlvBl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
利用可能在庫確認の所要量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
累積受注数量 (販売単位)を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売単位による受注数量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
累積受注数量 (販売単位)を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積受注数量 (販売単位)を取得します。
getReqTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を取得します。
getReqTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqmtsTyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所要量タイプを取得します。
getReqmtsTyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRequCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コード要求を取得します。
getRequestCctr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請原価センタを取得します。
getRequestCctr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請原価センタを取得します。
getRequestCctrControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
依頼原価センタの管理領域を取得します。
getRequestCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コード要求を取得します。
getRequestOrder() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請指図を取得します。
getResAnalKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
結果分析キーを取得します。
getResAnalKey() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
結果分析キーを取得します。
getResDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算の伝票番号を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算: 伝票明細を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
用途指定予算: 伝票明細を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getResType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコードタイプを取得します。
getResType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコードタイプを取得します。
getResanalkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
結果分析キーを取得します。
getResanalkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReservNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の番号を取得します。
getReservNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の番号を取得します。
getRespCostCenter() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
責任原価センタを取得します。
getRespCostCenter() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
責任原価センタを取得します。
getRespcctr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任原価センタを取得します。
getResponsibleNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任者番号 (プロジェクト責任者)を取得します。
getResponsibleNo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
責任者番号 (プロジェクト責任者)を取得します。
getRespsblCctr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタを取得します。
getRespsblCctrControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタの管理領域を取得します。
getRetAuthNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
返品権限番号を取得します。
getRetCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
リターン値、ABAP 命令後のリターン値を取得します。
getRetItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
返品明細を取得します。
getReturnMessagesList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
リターンパラメータ BAPIRET2 の代替構造を取得します。
getRevLev() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
改訂レベルを取得します。
getRevType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
収益承認カテゴリを取得します。
getRevType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRfqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼明細番号を取得します。
getRfqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼番号を取得します。
getRight() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
不動産管理対象の内部キーを取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
不動産管理対象の内部キーを取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
不動産管理対象の内部キーを取得します。
getRnddlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
丸め数量: 出荷を取得します。
getRnddlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
部屋/アパート番号を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
部屋/アパート番号を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
部屋/アパート番号を取得します。
getRootId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
選定におけるインスタンス番号を取得します。
getRotationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを取得します。
getRoundProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
丸めプロファイルを取得します。
getRoundProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
丸めプロファイルを取得します。
getRoundQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
丸め数量を取得します。
getRoundUpRuleExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日計算の丸め規則を取得します。
getRoundVal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買発注数量の丸め数量を取得します。
getRoundoffdi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
輸送経路を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
輸送経路を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
輸送経路を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRoutesched() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送経路計画を取得します。
getRow() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの行を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
受注明細番号を取得します｡
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注明細番号を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注明細番号を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注明細番号を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
特別処理区分を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
特別処理区分を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSUnitDlv() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷単位を取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
単位の ISO コードを取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードによる販売単位を取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードによる販売単位を取得します。
getSaIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
レコード番号を取得します｡
getSafetyStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全在庫を取得します。
getSafetytime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間 (稼動日数)を取得します。
getSaftyTId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間区分（安全リードタイムあり/なし)を取得します。
getSalStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスを取得します。
getSalStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売ビューからの品目ステータスを取得します。
getSalesData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売データを取得します。
getSalesDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
販売データが既に存在するかチェックします。
getSalesDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
販売データを取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売地域を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売地域を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesDocDateInidicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
販売伝票の日付に関連するマイルストーンを取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業グループを取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業グループを取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業所を取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業所を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
受注伝票番号を取得します｡
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注伝票番号を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注伝票番号を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注伝票番号を取得します。
getSalesOrdersList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先受注テーブルを取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売組織を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売組織を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売組織を取得します。
getSalesOrganisationSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
販売組織の選択オプション一覧を取得します｡
getSalesOrganization() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売組織を取得します。
getSalesPers() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先営業担当者を取得します｡
getSalesRelevant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
この部品は販売に関連していますを取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売単位を取得します。
getSalesUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードによる販売単位を取得します。
getSalesView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
販売ビューを取得します。
getSalesView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
販売ビューを取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売伝票番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
販売管理伝票番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
生成された伝票の番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売管理伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売管理伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
販売管理伝票番号を取得します。
getSalesorg() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
販売組織を取得します。
getSalesorg() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売組織を取得します。
getSalesorgHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲終了を取得します。
getSalesorgLow() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲開始を取得します。
getSalesorganisation() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売組織を取得します。
getSalqtyden() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位を SKU に換算するための分母 (除数)を取得します。
getSalqtyden() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalqtynum() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位から基本数量単位への変換係数の分子を取得します。
getSalqtynum() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getScIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
レコード番号を取得します｡
getScVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
外注仕入先を取得します。
getScalbasval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件のスケール基準値を取得します。
getScalbasval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件のスケール基準値を取得します。
getScalebasin() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール基準区分を取得します。
getScalebasin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール基準区分を取得します。
getScaletype() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケールタイプを取得します。
getScaletype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケールタイプを取得します。
getScbankInd() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
中央銀行コードを取得します｡
getSce() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CUX: 選定タイプを取得します。
getSchedInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
分納契約のリリース伝票区分を取得します。
getSchedLin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注納入日程を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注納入日程を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
納入日程行を取得します。
getSchedMilestoneDateBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(基準)を取得します。
getSchedMilestoneDateForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(予測)を取得します。
getSchedMilestoneTimeBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(基準)を取得します。
getSchedMilestoneTimeForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(予測)を取得します。
getSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程カテゴリを取得します。
getSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getScheduling() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
単一文字フラグを取得します。
getScrapIndicator() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
EWM 処理の廃棄区分を取得します。
getSdDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売管理伝票番号を取得します。
getSdDoc() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票番号を取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売管理伝票カテゴリを取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票カテゴリを取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSdTaxcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
を取得します。
getSdTaxcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSeasIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
季節指数を取得します。
getSeason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
季節カテゴリを取得します。
getSeason() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
季節カテゴリを取得します。
getSeasonPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
季節周期ごとの期間数を取得します。
getSeasonYr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
シーズン年度を取得します。
getSegText() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
セグメントテキストを取得します｡
getSegment() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
セグメントレポートのセグメントを取得します｡
getSegment() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
セグメントレポートのセグメントを取得します｡
getSelection() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選択 ID (永続)を取得します。
getSelection() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
論理システム - 送信者を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
論理システム - 送信者を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
論理システム - 送信者を取得します。
getSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
KANBAN/連続番号を取得します。
getSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
勘定設定の連続番号を取得します。
getSerializationLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
シリアル番号の指定レベルを取得します。
getSerialno() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
シリアル番号を取得します。
getSerialnoAutoNumberassignment() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
シリアル番号の自動登録を取得します。
getSernoLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定コード設定のシリアル番号、サービス明細を取得します。
getSernoProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
シリアル番号プロファイルを取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getServLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サービスレベルを取得します。
getServType() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのテキスト (短)を取得します。
getServType() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのテキスト (短)を取得します。
getService() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
活動番号を取得します。
getSettItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベート (期末) 決済対象の明細を取得します。
getSetupTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷準備時間を取得します。
getSetuptime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取時間と片付け時間を取得します。
getShMatTyp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包材タイプを取得します。
getShelfLife() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
総有効期間を取得します。
getShipBlocked() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
SD 出荷伝票の明細ブロックを取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
出荷条件を取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷条件を取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷条件を取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipProcTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷処理時間を取得します。
getShipTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先を取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷タイプを取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷タイプを取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
出荷指示を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示を取得します。
getShippingCountry() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 出荷国を取得します。
getShippingCountryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを取得します。
getShortId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素 ショート IDを取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を取得します｡
getShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
テキスト 1 (短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
テキスト(短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードテキスト（短）を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
テキスト (短): 受注明細を取得します。
getSiCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助明細カテゴリ、購買伝票を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSizeDim() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
サイズ/寸法を取得します。
getSledBbd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期限を取得します。
getSlocExprc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
外部調達の初期保管場所を取得します。
getSmKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
日程計画余裕キーを取得します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
受注先を取得します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注先を取得します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注先を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 1を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 1を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 1を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 2を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 2を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 2を取得します。
getSourcelist() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 供給元一覧必須を取得します。
getSpecMvmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の特殊移動区分を取得します。
getSpecMvmt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
倉庫管理の特殊移動区分を取得します。
getSpecProc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの特殊調達タイプを取得します。
getSpecStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
特殊在庫区分を取得します。
getSpecStock() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
特殊在庫区分を取得します。
getSpecStockRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
特殊在庫区分の範囲を取得します。
getSpecprocty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算の特殊調達タイプを取得します。
getSplitInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
分割区分を取得します。
getSpproctype() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
特殊調達タイプを取得します。
getSrcDlvNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
元出荷番号を取得します。
getSrcDlvNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
元出荷番号を取得します。
getSrcHandlgUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
元/先 荷役単位 (外部 ID)を取得します。
getSrcHandlgUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
元/先 荷役単位 (外部 ID)を取得します。
getSrcStockType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
在庫転送オーダーの元保管場所在庫タイプを取得します。
getSrvBasedIv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
サービス基準請求書照合の区分を取得します。
getSscExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの制限を取得します。
getSscItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ: 明細を取得します。
getSscLim() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ制限参照のサービス行を取得します。
getSscLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの金額制限を取得します。
getSscNolim() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
標準サービスタイプの制限なしを取得します。
getSscPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getSscPrschg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getStRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始参照日付は変更できませんを取得します。
getStRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始参照日付は変更できませんを取得します。
getStUnQtyy1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を取得します。
getStUnQtyy1Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getStUnQtyy2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を取得します。
getStUnQtyy2Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getStackFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
山積係数を取得します。
getStart() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト計画開始日付を取得します。
getStartOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用の開始オフセットを取得します。
getStartOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用の開始オフセットを取得します。
getStartOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始オフセットは変更できませんを取得します。
getStartOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始オフセットは変更できませんを取得します。
getStartOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始のオフセット単位を取得します。
getStartOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始のオフセット単位を取得します。
getStartOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
getStartOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
getStartRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始の参照日付を取得します。
getStartRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始の参照日付を取得します。
getStatCon() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
統計に適用する条件を取得します｡
getStatCon() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
統計に適用する条件を取得します。
getStatCon() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
統計に適用する条件を取得します。
getStatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
統計的納入期日を取得します。
getStatGroup() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
統計グループを取得します。
getStatProf() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータスプロファイルを取得します。
getStatistical() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
統計 WBS 要素を取得します。
getStatistical() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
統計 WBS 要素を取得します。
getStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンステータスを取得します。
getStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票ステータスを取得します｡
getStatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
単一文字フラグを取得します。
getStatusDocOld() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
このバージョンの前の旧処理状況 (購買伝票内)を取得します。
getStatusInfoList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
ステータス情報を取得します。
getStckType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
在庫タイプを取得します。
getStckType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫タイプを取得します。
getStdDescr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
標準テキスト (ANSI、ISO など)を取得します。
getStdMaterialGetIntNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のメソッド
品目コード割当済一覧(結果)（StdMaterialGetIntNumberインスタンスの配列）を取得します。
getStdMaterialGetIntNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
品目コード割当済一覧を取得します｡
getStdPrPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準標準原価を取得します。
getStdPrPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度標準原価を取得します。
getStdPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
標準原価を取得します。
getStdTextKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の標準テキストキーを取得します。
getStdTextKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の標準テキストキーを取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
棚番を取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
棚番を取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
棚番を取得します。
getStgeBinPc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を取得します。
getStgeBinSt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
保管場所を取得します。
getStgeLocRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
保管場所の範囲を取得します。
getStgePdUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間の単位を取得します。
getStgePdUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの最長保管期間単位を取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管域タイプを取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
概略計画および詳細計画のピッキング保管域タイプを取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管域タイプを取得します。
getStgeTypePc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを取得します。
getStgeTypeSt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを取得します。
getStgeperiod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間を取得します。
getStgesector() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管区画区分を取得します。
getStlmntPer() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
決済期間を取得します｡
getStlocHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
終了保管場所を取得します。
getStlocLow() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
開始保管場所を取得します。
getStockInd() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
特殊在庫区分を取得します。
getStorConds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
保管条件を取得します。
getStorCosts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管経費区分を取得します。
getStorPct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
残存有効期間割合 %を取得します。
getStorageLocationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (保管場所レベル)を取得します。
getStorageLocationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (保管場所レベル)が既に存在するかチェックします。
getStorageLocationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (保管場所レベル)を取得します。
getStorageLocationselectList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
保管場所の選択オプション一覧を取得します｡
getStorageTypeData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプデータを取得します。
getStorageTypeDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
保管域タイプデータが既に存在するかチェックします。
getStorageTypeDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
保管域タイプデータを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管ビューを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管ビューを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
保管ビューを取得します。
getStoragelocation() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管場所を取得します。
getStoragetype() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプを取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
保管場所を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
保管場所を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
保管場所を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名の略称 (例: スペイン)を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名の略称 (例: スペイン)を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名の略称 (例: スペイン)を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 2を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 2を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 2を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 3を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 3を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 3を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 4を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 4を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 4を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地名/番地-号を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地名/番地-号を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStructcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
構造条件を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します｡
getStructure() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を取得します｡
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します。
getSuPlStck1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を取得します。
getSuPlStck2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産補助番号を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産補助番号を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産補助番号を取得します。
getSubUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
梱包階層の下位レベル数量単位を取得します。
getSubUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を取得します。
getSubitemint() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
副明細の明細間隔を取得します｡
getSubjToR() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認未完了を取得します。
getSubpckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サブパッケージ番号を取得します。
getSuccessList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
正常に処理された明細のテーブルを取得します。
getSuccessList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票の明細テーブルを取得します。
getSupSource() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
供給元を取得します。
getSupSource() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給元を取得します。
getSuppLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
補足明細を取得します。
getSuppVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
供給仕入先/仕入入庫を取得します。
getSupplPlnt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
在庫転送オーダーにおける供給(出庫)プラントを取得します｡
getSupplStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出庫保管場所: 在庫転送オーダーを取得します。
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
供給仕入先を取得します｡
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
供給仕入先を取得します。
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
供給仕入先を取得します。
getSupplierDetail() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
仕入先マスタ詳細情報を取得します｡
getSupplierExistenceCheck() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードチェック情報を取得します｡
getSupplierInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
仕入先住所を取得します｡
getSupplyArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目マスタレコードで提案される供給場所を取得します。
getSvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスの有効開始日付を取得します。
getSyStDscr() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトステータスを取得します。
getSyStText() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を取得します。
getSysStatus() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
システムステータスを取得します。
getSystem() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージが発行された論理システムを取得します。
getSystemStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
システムステータステーブルを取得します。
getSystemStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
システムステータステーブルを取得します。
getTUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量単位 (ISO コード)を取得します。
getTUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を取得します｡
getTargetQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量（販売単位）を取得します。
getTargetQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTargetQu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量 (数量単位)を取得します。
getTargetQu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
目標値を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
累積計画金額を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaskListType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストタイプを取得します。
getTaxClass1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 2を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 3を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 4を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 5を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 6を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 7を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 8を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 9を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
制御デ－タオブジェクトが既に存在するかチェックします。
getTaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
制御デ－タが既に存在するかチェックします。
getTaxClassificationsList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御デ－タを取得します。
getTaxClassificationsList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
制御デ－タを取得します。
getTaxCmlUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法/商法にもとづく評価額価格単位を取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードを取得します｡
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードを取得します｡
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
売上税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
消費税コードを取得します。
getTaxCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
税会社コードを取得します｡
getTaxDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税率定義の日付を取得します｡
getTaxDepartCty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税出荷国を取得します。
getTaxDestCty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税仕向国を取得します。
getTaxInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税区分: 品目 (購買管理)を取得します。
getTaxRate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税率を取得します｡
getTaxType1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
税額を取得します。
getTaxValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を取得します。
getTaxValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を取得します。
getTaxcl1Mat() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の税分類を取得します。
getTaxclass1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxdepCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税出荷国を取得します。
getTaxdepCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxdstCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税仕向国を取得します。
getTaxdstCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
税管轄を取得します｡
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税管轄を取得します｡
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcodeDeep() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税管轄コード - 最下位レベル税管轄を取得します｡
getTaxjurcodeLevel() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税管轄コードレベルを取得します｡
getTaxlawicms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: ICMSを取得します。
getTaxlawicms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxlawipi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: IPIを取得します。
getTaxlawipi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxlawiss() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISS Tax Lawを取得します。
getTaxprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 1を取得します。
getTaxprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 2を取得します。
getTaxprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 3を取得します。
getTaxrCntry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
納税申告書の国を取得します。
getTeIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
レコード番号を取得します｡
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第 1 電話番号: 内線を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第 1 電話番号: 内線を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第 1 電話番号: 内線を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTelebox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレボックス番号を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先電話番号を取得します｡
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
電話番号を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 1を取得します。
getTelephone2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 2を取得します。
getTeletexNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレテクス番号を取得します。
getTelexNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレックス番号を取得します。
getTempConds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
温度条件区分を取得します。
getTerminal() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 端末を取得します。
getTestRun() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テスト区分を取得します｡
getTestrun() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動シミュレーションを取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
書込 BAPI のシミュレーションセッションへの切替を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
シミュレーション実行 ('X')、更新実行 (' ')を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テスト実行を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テスト実行を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テスト実行を取得します。
getTextDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求インタフェースの通信構造テキストを取得します。
getTextForm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
タグ列を取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト IDを取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト行を取得します。
getTextName() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
名称を取得します。
getTextName() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
名称を取得します。
getTime() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
時刻を取得します。
getTimeUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
時間計画単位を取得します。
getTimeUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
単位の ISO コードを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレスタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷場所のタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレスタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスタイムゾーンを取得します。
getTimestamp() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
取引開始時刻 (UTCタイムスタンプ)を取得します。
getTindex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
数値項目: 長さ 6を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
敬称を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
敬称を取得します。
getTmpExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスパッケージの制限を取得します。
getTmpLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細制限を取得します。
getTmpLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを取得します。
getTmpNolim() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデル仕様の制限なしを取得します。
getTmpNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細セット番号を取得します。
getTmpPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを取得します。
getTmpPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getTmpPrschg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後通貨を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算後通貨を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算後通貨を取得します。
getToFactor() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を取得します。
getToFactorV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を取得します。
getToLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上限を取得します。
getTotalConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目総消費量のデータ転送が既に存在するかチェックします。
getTotalConsumptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目総消費量のデータ転送を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画日付を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画日付を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTrEvType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
トランザクション/イベントタイプを取得します。
getTrEvTypeRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
トランザクション/イベントタイプの範囲を取得します。
getTrIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
レコード番号を取得します｡
getTrPartBa() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先事業領域を取得します｡
getTrPartBa() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
取引先事業領域を取得します｡
getTrPartBa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引会社事業領域を取得します。
getTraIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
レコード番号を取得します｡
getTrackingno() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼追跡番号を取得します。
getTracklimit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
警告限界を取得します。
getTradeId() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先の会社 IDを取得します｡
getTrans() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
取引を取得します。
getTransGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
輸送グループを取得します。
getTransGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
輸送グループを取得します。
getTransactionGroup() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
一文字フラグを取得します。
getTransportMode() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
貿易管理の輸送モードを取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
商品の納入区域を取得します。
getTravelAmountList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
旅費資金計画通貨項目一覧（TravelAmountインスタンスの配列）を取得します｡
getTravelList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
旅費資金予算明細一覧（Travelインスタンスの配列）を取得します｡
getTrendAnalysisIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
傾向分析の関連マイルストーンを取得します。
getTrendValue() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
傾向値を取得します。
getTrendValuePp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の傾向値を取得します。
getTrgQtyNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を取得します。
getTrgQtyNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTrgqtyDen() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を取得します。
getTrgqtyDen() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTwoStepPick() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ツーステップピッキング適用品目を取得します。
getType() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
getType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
getUnWork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業単位を取得します。
getUnWorkIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUnddlvTol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
不足納入許容範囲リミットを取得します。
getUnddlvTol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnderDlvTol() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
不足納入許容範囲リミットを取得します。
getUnderTol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
不足納入許容範囲リミットを取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
発注単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
表示数量単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
表示数量単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
表示数量単位を取得します。
getUnitDim() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
寸法単位 (長さ/幅/高さ)を取得します。
getUnitDimIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの長さ、幅、高さの単位を取得します。
getUnitGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
数量単位グループを取得します。
getUnitGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
数量単位グループを取得します。
getUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
ISO コードでの表示数量単位を取得します。
getUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
ISO コードでの表示数量単位を取得します。
getUnitOfWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位を取得します。
getUnitOfWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
重量単位を取得します。
getUnitOfWtIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位を取得します。
getUnitOfWtIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの重量単位を取得します。
getUnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
数量単位オブジェクトが既に存在するかチェックします。
getUnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
数量単位が既に存在するかチェックします。
getUnitSofmeasureList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位を取得します。
getUnitSofmeasureList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
数量単位を取得します。
getUnitmeasur() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件スケール単位を取得します。
getUnitmeasur() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件スケール単位を取得します。
getUnitmeasurIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
単位の ISO コードを取得します。
getUnittype1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第１保管単位タイプを取得します。
getUnittype1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを取得します。
getUnittype2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第２保管単位タイプを取得します。
getUnittype2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを取得します。
getUnittype3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第３保管単位タイプを取得します。
getUnlimited() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlimitedDlv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlmtDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlmtDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
荷渡ポイントを取得します。
getUnloadPtx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnofWtiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの重量単位を取得します。
getUnplndConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
計画外消費のデータ転送が既に存在するかチェックします。
getUnplndConsumptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
計画外消費のデータ転送を取得します。
getUntilDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数日付を取得します。
getUntofWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
重量単位を取得します。
getUntofWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
単位の ISO コードを取得します。
getUomsortnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
数量単位ソート番号を取得します。
getUomusage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
使用数量単位を取得します。
getUp() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getUpdateGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
統計更新の更新グループを取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
更新区分を取得します。
getUsStDscr() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトステータスを取得します。
getUsStNumb() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータス番号を取得します。
getUsStText() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を取得します。
getUsageInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
未使用 - 予約長 3を取得します。
getUsageInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUseExceptions() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
例外メッセージ設定とエラーメッセージ出力を取得します。
getUserFieldChar10_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を取得します。
getUserFieldChar10_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 3 ユーザ項目 - WBS 要素を取得します。
getUserFieldChar10_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を取得します。
getUserFieldChar10_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 4 ユーザ項目 - WBS 要素を取得します。
getUserFieldChar20_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を取得します。
getUserFieldChar20_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。
getUserFieldChar20_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を取得します。
getUserFieldChar20_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 桁の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldCuky1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を取得します。
getUserFieldCuky1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
getUserFieldCuky1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を取得します。
getUserFieldCuky2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
getUserFieldCuky2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getUserFieldCurr1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を取得します。
getUserFieldCurr1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldCurr2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を取得します。
getUserFieldCurr2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldDate1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を取得します。
getUserFieldDate1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 1 ユーザ項目 - WBS 要素を取得します。
getUserFieldDate2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を取得します。
getUserFieldDate2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldFlag1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を取得します。
getUserFieldFlag1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。
getUserFieldFlag2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を取得します。
getUserFieldFlag2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目のキーワード IDを取得します。
getUserFieldKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ユーザ定義項目のキーワード IDを取得します。
getUserFieldQuan1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を取得します。
getUserFieldQuan1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldQuan2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を取得します。
getUserFieldQuan2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldUnit1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を取得します。
getUserFieldUnit1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
getUserFieldUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUserFieldUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getUserFieldUnit2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を取得します。
getUserFieldUnit2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
getUserFieldUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUserFieldUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getUserNameRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ユーザ名の範囲を取得します。
getUserStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ユーザステータス/指図ステータステーブルを取得します。
getUserStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ユーザステータス/指図ステータステーブルを取得します。
getUserf1Num() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf1Txt() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf2Num() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf2Txt() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUsername() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名を取得します｡
getUsername() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を取得します。
getUsrStatus() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ユーザステータスを取得します。
getValArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価レベルを取得します。
getValCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価カテゴリを取得します。
getValClass() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価クラスを取得します。
getValConI() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約明細を取得します。
getValConI() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約番号を取得します。
getValContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValForcur() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票通貨額を取得します。
getValGrFor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外国通貨での入庫額を取得します。
getValGrLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による入庫額を取得します。
getValIvFor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外貨による請求額を取得します。
getValIvLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による請求額を取得します。
getValLoccur() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨額を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注明細を取得します。
getValSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注明細を取得します。
getValSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注番号を取得します。
getValSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注番号を取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を取得します。
getValWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を取得します。
getValcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
値タイプ: 範囲制限 - 単一値を取得します。
getValcount() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層ノード内の値の値数を取得します。
getValfrom() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
エントリの有効開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チェーン別品目ステータスの有効期間開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価有効開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約の有効開始日を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を取得します｡
getValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して有効終了日を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約有効終了日を取得します。
getValto() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを取得します。
getValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価データを取得します。
getValuationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
評価データが既に存在するかチェックします。
getValuationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
評価データを取得します。
getValuationarea() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価レベルを取得します。
getValuationtype() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価タイプを取得します。
getValue() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
CO-PA 特性値を取得します。
getValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を取得します。
getValueChanged() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンによる金額変更を取得します。
getValueTo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を取得します。
getValueTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値の言語依存テキストを取得します。
getValueduom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ロット特定数量単位での評価を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を取得します｡
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分 IDを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
長さ 229 の文字データのコンテナを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
長さ 229 の文字データのコンテナを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getVarOrdUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
可変購買発注単位有効を取得します。
getVarSalesUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
可変販売単位の使用不可を取得します。
getVarcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
バリアント条件を取得します。
getVarcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
バリアント条件を取得します。
getVarianceKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
差異キーを取得します。
getVatCntry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
売上税 ID 番号国を取得します。
getVatCntryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
消費税登録番号の ISO 国コードを取得します。
getVclassPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期評価クラスを取得します。
getVclassPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の評価クラスを取得します。
getVendMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
仕入先が使用している品目コードを取得します。
getVendName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
名称 1を取得します。
getVendPart() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先部門を取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先勘定コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
仕入先勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先勘定コードを取得します。
getVendorNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードを取得します｡
getVendorNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
仕入先または債権者の勘定コードを取得します。
getVendorNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
仕入先または債権者の勘定コードを取得します。
getVendorRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
仕入先の範囲を取得します。
getVendrbatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先ロット番号を取得します。
getVendrbatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先ロット番号を取得します。
getVerGrGiSlip() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票の印刷バ－ジョンを取得します。
getVerGrGiSlipx() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるバージョン番号を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票バージョン番号を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVersionFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
バージョン区分を取得します。
getVersions() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
バージョン管理を取得します｡
getVirtCard() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
チェックボックスを取得します。
getVkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件名を取得します。
getVmPStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
プロジェクト在庫の評価クラスを取得します。
getVmSoStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
受注在庫の評価クラスを取得します。
getVolTolLt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の容積超過許容量を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総数量を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVolumeunit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積単位を取得します。
getVolumeunit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積単位を取得します。
getVolumeunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ISO コードでの容積単位を取得します。
getVolumeunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの容積単位を取得します。
getVolunit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
容積単位を取得します。
getVolunit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVolunitiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの容積単位を取得します。
getVperEnd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間終了日を取得します｡
getVperStart() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間開始日を取得します｡
getVwUepos() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細用途 IDを取得します。
getVwUepos() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWagetype() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ウェイジタイプを取得します。
getWarDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
保証期間の開始日付を取得します。
getWarDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWarehouseNumberData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号データを取得します。
getWarehouseNumberDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
倉庫番号データが既に存在するかチェックします。
getWarehouseNumberDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
倉庫番号データを取得します。
getWarehouseView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
倉庫管理ビューを取得します。
getWarehouseView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
倉庫管理ビューを取得します。
getWarehousenumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号/複合倉庫を取得します。
getWarranty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
保証日を取得します｡
getWbsAccountAssignmentElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 勘定設定要素を取得します。
getWbsActualDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
実績 WBS 要素日付の期間単位を取得します。
getWbsActualDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsActualDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績長(期間)を取得します。
getWbsActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績終了日を取得します。
getWbsActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績開始日付を取得します。
getWbsBasicDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
基準 WBS 要素日付の期間単位を取得します。
getWbsBasicDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsBasicDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の基準日の長さ(期間)を取得します。
getWbsBasicFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本終了日付を取得します。
getWbsBasicStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本開始日を取得します。
getWbsBillingElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 請求要素を取得します。
getWbsCctrPostedActual() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価が実際に転記される原価センタを取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業詳細項目要素 (WBS 要素)を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素を取得します｡
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
WBS 要素を取得します｡
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
WBS 要素を取得します。
getWbsElementExt() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
WBS 要素を取得します。
getWbsForcastDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素計画日付の単位を取得します。
getWbsForecastDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsForecastDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測期間を取得します。
getWbsForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測済終了日付を取得します。
getWbsForecastStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測開始日を取得します。
getWbsPlanningElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 計画要素を取得します。
getWbsScdActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績終了日を取得します。
getWbsScdActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績開始日を取得します。
getWbsScdBasicFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (基準)を取得します。
getWbsScdBasicStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最早計画開始日 (基準)を取得します。
getWbsScdForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (予測)を取得します。
getWbsScdForecastStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
計画開始日 (予測)を取得します。
getWbsSchedProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 日程計画のプロファイルを取得します。
getWeOriginAcceptance() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
仕入先構内での受領を取得します。
getWeightunit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位を取得します。
getWeightunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位のISOコードを取得します。
getWhseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
倉庫番号/複合倉庫を取得します。
getWhseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫番号/複合倉庫を取得します。
getWidth() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
幅を取得します。
getWithActivities() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属活動を取得します。
getWithActivities() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属活動を取得します。
getWithMilestones() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属 WBS マイルストーンを取得します。
getWithMilestones() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属 WBS マイルストーンを取得します。
getWithSubtree() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
サブプロジェクトを取得します。
getWithSubtree() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
サブプロジェクトを取得します。
getWithdrQty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
出庫量を取得します。
getWithdrawal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫払出に対する保管域タイプ区分を取得します。
getWithdrawn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定に対する出庫完了を取得します。
getWithdrawn() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定に対する出庫完了を取得します。
getWmUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の数量単位を取得します。
getWmUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの倉庫管理単位を取得します。
getWmdvexList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
出力テーブル (日付および ATP 数量)を取得します。
getWmdvsxList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
入力テーブル (日付/数量)を取得します。
getWorkActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動に含まれる作業を取得します。
getWorkActual() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績作業を取得します。
getWorkCntr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業区を取得します。
getWorkForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測作業 (実績 + 残存)を取得します。
getWorkPermit() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
仕事許可済フラグを取得します。
getWorkSchedView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
作業計画ビューを取得します。
getWorkSchedView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
作業計画ビューを取得します。
getWtTolLt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の重量超過許容量を取得します。
getWtWithcd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
源泉徴収税コードを取得します。
getWtgGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
加重グループを取得します。
getXAutoCre() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
自動登録済み明細を取得します。
getXstob() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消移動タイプ区分の使用を取得します。
getYline() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
内部テ－ブル処理の行索引を取得します。
getZonlo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
現在のユーザのタイムゾーンを取得します。

H

HeadData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData.
管理情報設定ヘッダセグメント情報クラス
機能は以下の通り
管理情報設定ヘッダセグメント情報を保持します。
HeadData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のコンストラクタ
管理情報設定ヘッダセグメント情報を作成します。
HeadData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のコンストラクタ
管理情報設定ヘッダセグメント情報を作成します。
HeaderIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn.
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のコンストラクタ
販売伝票ヘッダデータ情報を作成します。
HeaderInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX.
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
HeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のコンストラクタ
ヘッダデータチェックボックス情報を作成します。
HierarchyNodes - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes.
階層ノード情報クラス 機能は以下の通り
階層ノード情報を保持します。
HierarchyNodes() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のコンストラクタ
階層ノードを作成します。
HierarchyValues - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues.
階層値情報クラス 機能は以下の通り
階層値情報を保持します。
HierarchyValues() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のコンストラクタ
階層値を作成します。

I

ImpWbsElement - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement.
詳細情報を必要とする WBS 要素クラス 機能は以下の通り
詳細情報を必要とする WBS 要素を保持します。
ImpWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のコンストラクタ
詳細情報を必要とする WBS 要素を作成します。
ImpWbsElement(int) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のコンストラクタ
詳細情報を必要とする WBS 要素を作成します。
InquiryCreateFromData2 - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2.
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。
InquiryCreateFromData2() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
コンストラクタ。
InquiryCreateFromData2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
InquiryCreateFromData2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
InquiryCreateFromData2Controller - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller.
引合伝票登録コントローラクラス
機能は以下の通り
引合伝票を登録します。
InquiryCreateFromData2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InternalOrderGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail.
内部指図書詳細情報取得クラス
機能は以下の通り
内部指図書詳細情報を取得します。
InternalOrderGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のコンストラクタ
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のコンストラクタ

InternalOrderGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController.
内部指図書詳細コントローラクラス
機能は以下の通り
内部指図書詳細を取得します。
InternalOrderGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ

InternalOrderGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ

InternalOrderGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetList - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList.
内部指図書（一覧）情報取得クラス
機能は以下の通り
内部指図書（一覧）情報を取得します。
InternalOrderGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のコンストラクタ
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String, String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のコンストラクタ

InternalOrderGetListController - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController.
内部指図書一覧コントローラクラス
機能は以下の通り
内部指図書一覧を取得します。
InternalOrderGetListController(String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ

InternalOrderGetListController(String, String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ

InternalOrderGetListController() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ
InternalOrderGetListControllerのコンストラクタを生成します。
InternationArticleNumbers - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers.
EAN情報クラス
機能は以下の通り
EAN情報を保持します。
InternationArticleNumbers() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のコンストラクタ
EAN情報を作成します。
InternationArticleNumbers(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のコンストラクタ
EAN情報を作成します。
InternationalArtnos - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos.
国際商品コード (EAN)情報クラス
機能は以下の通り
国際商品コード (EAN)情報を保持します。
InternationalArtnos() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のコンストラクタ
国際商品コード (EAN)情報を作成します。
InternationalArtnos(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のコンストラクタ
国際商品コード (EAN)情報を作成します。
ItemsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn.
明細データ情報クラス
機能は以下の通り
明細データ情報を保持します。
ItemsIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のコンストラクタ
明細データ情報を作成します。
ItemsIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のコンストラクタ
明細データ情報を作成します。
ItemsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX.
明細データチェックボックス情報クラス
機能は以下の通り
明細データチェックボックス情報を保持します。
ItemsInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のコンストラクタ
明細データチェックボックス情報を作成します。
ItemsInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のコンストラクタ
明細データチェックボックス情報を作成します。
initMaterialGetAll() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ照会情報を作成します。
initMaterialSaveReplica() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ更新情報の各種インスタンスを生成します。

J

jp.co.intra_mart.foundation.sap.module - package jp.co.intra_mart.foundation.sap.module

jp.co.intra_mart.foundation.sap.module.accounting - package jp.co.intra_mart.foundation.sap.module.accounting
ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception - package jp.co.intra_mart.foundation.sap.module.accounting.exception
ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception - package jp.co.intra_mart.foundation.sap.module.exception

jp.co.intra_mart.foundation.sap.module.financial - package jp.co.intra_mart.foundation.sap.module.financial
ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception - package jp.co.intra_mart.foundation.sap.module.financial.exception
ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase - package jp.co.intra_mart.foundation.sap.module.purchase
ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model - package jp.co.intra_mart.foundation.sap.module.purchase.common.model

jp.co.intra_mart.foundation.sap.module.purchase.exception - package jp.co.intra_mart.foundation.sap.module.purchase.exception
ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate - package jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems - package jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability - package jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall - package jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica - package jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber - package jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

jp.co.intra_mart.foundation.sap.module.sales - package jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple - package jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail - package jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist - package jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales.common.model - package jp.co.intra_mart.foundation.sap.module.sales.common.model

jp.co.intra_mart.foundation.sap.module.sales.exception - package jp.co.intra_mart.foundation.sap.module.sales.exception

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist - package jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus - package jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

K

Keys - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys.
参照キーの出力テーブル情報クラス
機能は以下の通り
参照キーの出力テーブル情報を保持します。
Keys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のコンストラクタ
参照キーの出力テーブル情報を作成します。
Keys(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のコンストラクタ
参照キーの出力テーブル情報を作成します。

L

Language - class jp.co.intra_mart.foundation.sap.module.financial.Language.
言語情報クラス 機能は以下の通り
言語情報を保持します。
Language() - class jp.co.intra_mart.foundation.sap.module.financial.Language のコンストラクタ
詳細情報を読み込みエラー情報を作成します。
LifoValuationData - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData.
LIFO 関連品目データ情報クラス
機能は以下の通り
LIFO 関連品目データ情報を保持します。
LifoValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のコンストラクタ
LIFO 関連品目データ情報を作成します。
Limits - class jp.co.intra_mart.foundation.sap.module.purchase.Limits.
外注制限情報クラス
機能は以下の通り
外注制限情報を保持します。
Limits() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のコンストラクタ
外注制限を作成します。
Limits(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のコンストラクタ
外注制限を作成します。
LogicSwitch - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch.
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
LogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のコンストラクタ
内部制御パラメータ情報を作成します。

M

ManufacturerPartNumb - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb.
製造業者と製造者製品コードクラス
機能は以下の通り
製造業者と製造者製品コードの情報を保持します。
ManufacturerPartNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のコンストラクタ
製造業者と製造者製品コード情報を作成します。
ManufacturerPartNumb(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のコンストラクタ
製造業者と製造者製品コード情報を作成します。
MasterData - class jp.co.intra_mart.foundation.sap.module.financial.MasterData.
指図のマスタデータ構造情報クラス 機能は以下の通り
指図のマスタデータ構造情報を保持します。
MasterData() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のコンストラクタ
指図のマスタデータ構造を作成します。
MaterialAvailability - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability.
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。
MaterialAvailability(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のコンストラクタ
品目在庫確認情報を作成します。
MaterialAvailabilityController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController.
品目在庫確認コントローラクラス
機能は以下の通り
在庫情報を取得します。
MaterialAvailabilityController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のコンストラクタ
コンストラクタ生成
MaterialAvailabilityController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のコンストラクタ
コンストラクタ生成
MaterialDescription - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription.
品目テキスト情報クラス
機能は以下の通り
品目テキスト情報を保持します。
MaterialDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のコンストラクタ
品目テキスト情報を作成します。
MaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のコンストラクタ
品目テキスト情報を作成します。
MaterialEvg - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg.
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。
MaterialEvg() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のコンストラクタ
品目コード(長)を作成します。
MaterialEvg - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg.
品目コード(長)情報クラス
機能は以下の通り
品目コード(長)を保持します。
MaterialEvg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のコンストラクタ
品目コード(長)を作成します。
MaterialGetAll - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll.
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。
MaterialGetAll(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のコンストラクタ
品目マスタ照会情報を作成します。
MaterialGetAll(String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のコンストラクタ
品目マスタ照会情報を作成します。
MaterialGetAllController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController.
品目マスタ照会コントローラクラス
機能は以下の通り
品目マスタの情報を取得します。
MaterialGetAllController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
コンストラクタ生成
MaterialGetAllController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
コンストラクタ生成
MaterialGetAllController(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetAllController(String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetList - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList.
品目コード検索クラス
機能は以下の通り
品目コード、テキストを検索します。
MaterialGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のコンストラクタ
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
MaterialGetListController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController.
品目コード検索コントローラクラス
機能は以下の通り
品目コード、テキストを検索します。
MaterialGetListController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のコンストラクタ
MaterialGetListのコンストラクタを生成します。
MaterialGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のコンストラクタ
MaterialGetListのコンストラクタを生成します。
MaterialLongText - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText.
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialLongText() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のコンストラクタ
テキスト (長)情報を作成します。
MaterialLongText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のコンストラクタ
テキスト (長)情報を作成します。
MaterialRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa.
品目コードの範囲情報クラス
機能は以下の通り
品目コードの範囲情報を保持します。
MaterialRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のコンストラクタ
品目コードの範囲情報を作成します。
MaterialRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のコンストラクタ
品目コードの範囲情報を作成します。
MaterialSaveReplica - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica.
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。
MaterialSaveReplica() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplica(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplica(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplicaController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController.
品目マスタ更新コントローラクラス
機能は以下の通り
品目マスタを更新します。
MaterialSaveReplicaController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialSaveReplicaController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialSaveReplicaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialShortDescsel - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel.
品目テキストの選択オプションクラス
機能は以下の通り
品目テキストの選択オプションの情報を保持します。
MaterialShortDescsel() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のコンストラクタ
品目テキストの選択オプション情報を作成します。
MaterialShortDescsel(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のコンストラクタ
品目テキストの選択オプション情報を作成します。
MaterialText - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText.
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialText() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のコンストラクタ
テキスト (長)情報を作成します。
MaterialText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のコンストラクタ
テキスト (長)情報を作成します。
MatnrList - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList.
品目コードと品目テキストの一覧クラス
機能は以下の通り
品目コードと品目テキストの一覧の情報を保持します。
MatnrList() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のコンストラクタ
品目コードと品目テキストの一覧情報を作成します。
MatnrSelection - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection.
品目コードの選択オプションクラス
機能は以下の通り
品目コードの選択オプションの情報を保持します。
MatnrSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のコンストラクタ
品目コードの選択オプション情報を作成します。
MatnrSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のコンストラクタ
品目コードの選択オプション情報を作成します。
MoveTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa.
移動タイプの範囲情報クラス
機能は以下の通り
移動タイプの範囲情報を保持します。
MoveTypeRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のコンストラクタ
移動タイプの範囲情報を作成します。
MoveTypeRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のコンストラクタ
移動タイプの範囲情報を作成します。

O

OrderCcard - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard.
クレジットカードデータ情報クラス
機能は以下の通り
クレジットカードデータ情報を保持します。
OrderCcard() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のコンストラクタ
クレジットカードデータ情報を作成します。
OrderCcard(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のコンストラクタ
クレジットカードデータ情報を作成します。
OrderList - class jp.co.intra_mart.foundation.sap.module.financial.OrderList.
選択指図一覧情報クラス 機能は以下の通り
選択指図一覧情報を保持します。
OrderList() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のコンストラクタ
選択指図一覧を作成します。

P

ParamAccountGl - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl.
G/L 勘定明細パラメータ設定クラス
機能は以下の通り
G/L 勘定明細のパラメータを設定します。
ParamAccountPayable - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable.
仕入先明細パラメータ設定クラス
機能は以下の通り
仕入先明細のパラメータを設定します。
ParamAccountTax - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax.
税明細パラメータ設定クラス
機能は以下の通り
税明細のパラメータを設定します。
ParamAllVersions - class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions.
全バージョンパラメータ設定クラス
機能は以下の通り
全バージョンのパラメータを設定します。
ParamBatchRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa.
ロットの範囲パラメータ設定クラス
機能は以下の通り
ロットの範囲のパラメータを設定します。
ParamBillingDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn.
処理予定明細データのテーブルパラメータ設定クラス
機能は以下の通り
処理予定明細データのテーブルパラメータを設定します。
ParamBillingDocumentDetailList - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList.
後続請求伝票のテーブルパラメータ設定クラス
機能は以下の通り
後続請求伝票のテーブルのパラメータを設定します。
ParamCCardDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn.
処理予定支払方法のテーブルパラメータ設定クラス
機能は以下の通り
処理予定支払方法のテーブルパラメータを設定します。
ParamCfgsBlob - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob.
選定: BLOB 内部データ (SCE)パラメータ設定クラス
機能は以下の通り
選定: BLOB 内部データ (SCE)のパラメータを設定します。
ParamCfgsInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst.
選定: インスタンスパラメータ設定クラス
機能は以下の通り
選定: インスタンスのパラメータを設定します。
ParamCfgsPartOf - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf.
選定: 部分設定パラメータ設定クラス
機能は以下の通り
選定: 部分設定のパラメータを設定します。
ParamCfgsRef - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef.
選定: 参照データパラメータ設定クラス
機能は以下の通り
選定: 参照データのパラメータを設定します。
ParamCfgsRefInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst.
選定: 参照明細/インスタンスパラメータ設定クラス
機能は以下の通り
選定: 参照明細/インスタンスのパラメータを設定します。
ParamCfgsValue - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue.
選定: 特性値パラメータ設定クラス
機能は以下の通り
選定: 特性値のパラメータを設定します。
ParamCfgsVk - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk.
選定: バリアント条件キーパラメータ設定クラス
機能は以下の通り
選定: バリアント条件キーのパラメータを設定します。
ParamClientDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList.
品目データ (クライアントレベル)パラメータ設定クラス
機能は以下の通り
品目データ (クライアントレベル)パラメータを設定します。
ParamCondHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader.
条件ヘッダパラメータ設定クラス
機能は以下の通り
条件ヘッダのパラメータを設定します。
ParamCondItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem.
条件明細パラメータ設定ラクラス
機能は以下の通り
条件明細のパラメータを設定します。
ParamConditionDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn.
処理予定条件のテーブルパラメータ設定クラス
機能は以下の通り
処理予定条件のテーブルのパラメータを設定します。
ParamConditionsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn.
条件パラメータ設定クラス
機能は以下の通り
条件のパラメータを設定します。
ParamConditionsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX.
受注における条件更新の通信項目パラメータ設定クラス
機能は以下の通り
受注における条件更新の通信項目のパラメータを設定します。
ParamContractLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits.
外注基本契約制限パラメータ設定クラス
機能は以下の通り
外注基本契約制限のパラメータを設定します。
ParamContractService - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService.
外注サービスパラメータ設定クラス
機能は以下の通り
外注サービスのパラメータを設定します。
ParamContractServiceAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount.
外注サービス勘定設定パラメータ設定クラス
機能は以下の通り
外注サービス勘定設定のパラメータを設定します。
ParamContractServiceText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText.
外注サービステキストパラメータ設定クラス
機能は以下の通り
外注サービステキストのパラメータを設定します。
ParamCreatorDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn.
取り込まれる日付の順序パラメータ設定クラス
機能は以下の通り
取り込まれる日付の順序のパラメータを設定します。
ParamCurrencyAmount - class jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount.
明細通貨項目パラメータ設定クラス
機能は以下の通り
明細通貨項目のパラメータを設定します。
ParamDeliveryAddress - class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress.
入荷伝票アドレスパラメータ設定ラクラス
機能は以下の通り
入荷伝票アドレスのパラメータを設定します。
ParamDocumentHeader - class jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader.
伝票ヘッダパラメータ設定クラス
機能は以下の通り
伝票ヘッダのインポートパラメータを設定します。
ParamErrors - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors.
前明細の不正処理に関する情報パラメータ設定クラス
機能は以下の通り
前明細の不正処理に関する情報のパラメータを設定します。
ParamExportHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader.
貿易管理ヘッダパラメータ設定ラクラス
機能は以下の通り
貿易管理ヘッダのパラメータを設定します。
ParamExportItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem.
貿易管理明細インポートパラメータ設定クラス
機能は以下の通り
貿易管理明細のパラメータを設定します。
ParamExtension - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension.
拡張得意先項目パラメータ設定クラス
機能は以下の通り
拡張得意先項目のパラメータを設定します。
ParamExtension1 - class jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1.
カスタマ拡張テーブルパラメータ設定クラス
機能は以下の通り
カスタマ拡張テーブルのパラメータを設定します。
ParamExtensionIn - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。
ParamExtensionIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn.
VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス
機能は以下の通り
VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。
ParamExtensionInX - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX.
拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。
ParamExtensionin - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin.
Reference Structure設定クラス
機能は以下の通り
Reference Structureを設定します。
ParamForecastParametersList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList.
需要予測パラメータ設定クラス
機能は以下の通り
需要予測パラメータのパラメータを設定します。
ParamForecastValues - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues.
需要予測値のデータ転送パラメータ設定クラス
機能は以下の通り
需要予測値のデータ転送のパラメータを設定します。
ParamGoodsMvtCode - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode.
在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。
ParamGoodsMvtHeader - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader.
入出庫伝票ヘッダデータ設定クラス
機能は以下の通り
入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtHeaderList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList.
リターン構造、入出庫伝票ヘッダパラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票ヘッダのパラメータを設定します。
ParamGoodsMvtHeadret - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret.
入出庫伝票ヘッダデータパラメータ設定クラス
機能は以下の通り
入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtItem - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem.
リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtItems - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems.
リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtRefEwm - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm.
BAdI 通信構造: 入出庫伝票 EWMパラメータ設定クラス
機能は以下の通り
BAdI 通信構造: 入出庫伝票 EWMのパラメータを設定します。
ParamGoodsMvtSerialNumber - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber.
シリアル番号パラメータ設定クラス
機能は以下の通り
シリアル番号のパラメータを設定します。
ParamGoodsMvtServPartData - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData.
設定クラス
機能は以下の通り
設定します。
ParamHeadData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData.
管理情報設定ヘッダセグメントパラメータ設定クラス
機能は以下の通り
管理情報設定ヘッダセグメントのパラメータを設定します。
ParamHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader.
伝票ヘッダパラメータ設定クラス
機能は以下の通り
伝票ヘッダのインポートパラメータを設定します。
ParamHeaderIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn.
販売伝票ヘッダデータセグメントパラメータ設定クラス
機能は以下の通り
販売伝票ヘッダデータのパラメータを設定します。
ParamHeaderInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX.
ヘッダデータチェックボックスパラメータ設定クラス
機能は以下の通り
ヘッダデータチェックボックスのパラメータを設定します。
ParamHeaderText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText.
ヘッダテキストパラメータ設定クラス
機能は以下の通り
ヘッダテキストのパラメータを設定します。
ParamInternationalArtnos - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos.
国際商品コード (EAN)パラメータ設定クラス
機能は以下の通り
国際商品コード (EAN)のパラメータを設定します。
ParamItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem.
明細パラメータ設定クラス
機能は以下の通り
明細のパラメータを設定します。
ParamItemText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText.
明細テキストパラメータ設定クラス
機能は以下の通り
明細テキストのパラメータを設定します。
ParamItemsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn.
明細データパラメータ設定クラス
機能は以下の通り
明細データのパラメータを設定します。
ParamItemsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX.
明細データチェックボックス のパラメータ設定クラス
機能は以下の通り
明細データチェックボックスのパラメータを設定します。
ParamKeys - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys.
参照キーパラメータ設定クラス
機能は以下の通り
参照キーのパラメータを設定します。
ParamLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits.
外注制限パラメータ設定クラス
機能は以下の通り
外注制限のパラメータを設定します。
ParamLogicSwitch - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch.
内部制御パラメータパラメータ設定クラス
機能は以下の通り
内部制御パラメータのパラメータを設定します。
ParamMaterialDescription - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription.
品目テキストパラメータ設定クラス
機能は以下の通り
品目テキストのパラメータを設定します。
ParamMaterialEvg - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg.
品目コード(長)パラメータ設定クラス
機能は以下の通り
品目コード(長)のパラメータを設定します。
ParamMaterialEvg - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg.
品目コード(長)パラメータ設定クラス
機能は以下の通り
品目コード(長)のパラメータを設定します。
ParamMaterialLongText - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText.
テキスト (長)パラメータ設定クラス
機能は以下の通り
テキスト (長)のパラメータを設定します。
ParamMaterialRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa.
品目コードの範囲パラメータ設定クラス
機能は以下の通り
品目コードの範囲のパラメータを設定します。
ParamMoveTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa.
移動タイプの範囲パラメータ設定クラス
機能は以下の通り
移動タイプの範囲のパラメータを設定します。
ParamOrderCcard - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard.
クレジットカードデータ情報パラメータ設定クラス
機能は以下の通り
クレジットカードデータ情報のパラメータを設定します。
ParamPartner - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner.
得意先インポートパラメータ設定クラス
機能は以下の通り
得意先のパラメータを設定します。
ParamPartnerAddresses - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses.
アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス
機能は以下の通り
アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。
ParamPartners - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners.
伝票取引先パラメータ設定クラス
機能は以下の通り
伝票取引先のパラメータを設定します。
ParamPlanningDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList.
品目マスタ/製品グループの変更伝票構造パラメータ設定クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
ParamPlantDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList.
品目データ (プラントレベル)パラメータ設定クラス
機能は以下の通り
品目データ (プラントレベル)のパラメータを設定します。
ParamPlantRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa.
プラントの範囲パラメータ設定クラス
機能は以下の通り
プラントの範囲のパラメータを設定します。
ParamProfitSegment - class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment.
入出庫予定パラメータ設定クラス
機能は以下の通り
入出庫予定のパラメータを設定します。
ParamPrtData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData.
品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
ParamPstngDateRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa.
登録日付の範囲パラメータ設定クラス
機能は以下の通り
登録日付の範囲のパラメータを設定します。
ParamPurchaseAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount.
勘定設定パラメータ設定クラス
機能は以下の通り
勘定設定のパラメータを設定します。
ParamPurchaseComponents - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents.
コンポーネントパラメータ設定クラス
機能は以下の通り
コンポーネントのパラメータを設定します。
ParamPurchaseConfirmation - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation.
転送構造：照会／一覧情報パラメータ設定クラス
機能は以下の通り
転送構造：照会／一覧情報のパラメータを設定します。
ParamPurchaseHistory - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory.
購買発注履歴情報パラメータ設定クラス
機能は以下の通り
購買発注履歴情報のパラメータを設定します。
ParamPurchaseHistoryTotals - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals.
購買発注履歴(合計)情報パラメータ設定クラス
機能は以下の通り
購買発注履歴(合計)情報のパラメータを設定します。
ParamPurchaseSchedule - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule.
納入日程パラメータ設定クラス
機能は以下の通り
納入日程のパラメータを設定します。
ParamPurchaseShipping - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping.
出荷データパラメータ設定クラス
機能は以下の通り
出荷データのパラメータを設定します。
ParamPurchaseShippingExp - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp.
出荷データエクスポート情報パラメータ設定クラス
機能は以下の通り
出荷データエクスポート情報のパラメータを設定します。
ParamRefDocRange - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange.
前伝票の範囲パラメータ設定クラス
機能は以下の通り
前伝票の範囲のパラメータを設定します。
ParamReturnMessages - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages.
リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス
機能は以下の通り
リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。
ParamSalesDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList.
倉庫番号データパラメータ設定クラス
機能は以下の通り
倉庫番号データのパラメータを設定します。
ParamSalesOrders - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders.
得意先受注テーブル情報パラメータ設定クラス
機能は以下の通り
得意先受注テーブル情報のパラメータを設定します。
ParamSchedulesIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn.
納入日程行パラメータ設定クラス
機能は以下の通り
納入日程行のパラメータを設定します。
ParamSchedulesInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX.
納入日程行チェックボックスパラメータ設定クラス
機能は以下の通り
納入日程行チェックボックスのパラメータを設定します。
ParamSender - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender.
論理システム - 送信者セグメントパラメータ設定クラス
機能は以下の通り
論理システム - 送信者のパラメータを設定します。
ParamSpecStockRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa.
特殊在庫区分の範囲パラメータ設定クラス
機能は以下の通り
特殊在庫区分の範囲のパラメータを設定します。
ParamStatusInfo - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo.
ステータス情報パラメータ設定クラス
機能は以下の通り
ステータス情報のパラメータを設定します。
ParamStgeLocRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa.
保管場所の範囲パラメータ設定クラス
機能は以下の通り
保管場所の範囲のパラメータを設定します。
ParamStorageLocationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList.
品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り
品目データ (保管場所レベル)のパラメータを設定します。
ParamStorageTypeDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList.
品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り
品目データ (保管場所レベル)のパラメータを設定します。
ParamSuccess - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess.
後続請求伝票の明細テーブルパラメータ設定クラス
機能は以下の通り
後続請求伝票の明細テーブルのパラメータを設定します。
ParamTaxClassifications - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications.
制御デ－タパラメータ設定クラス
機能は以下の通り
制御デ－タのパラメータを設定します。
ParamText - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText.
テキストパラメータ設定クラス
機能は以下の通り
テキストのパラメータを設定します。
ParamTextDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn.
請求インタフェースの通信構造テキストパラメータ設定クラス
機能は以下の通り
請求インタフェースの通信構造テキストのパラメータを設定します。
ParamTotalConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption.
品目総消費量のデータ転送パラメータ設定クラス
機能は以下の通り
品目総消費量のデータ転送のパラメータを設定します。
ParamTrEvTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa.
トランザクション/イベントタイプの範囲パラメータ設定クラス。
ParamTravel - class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel.
旅費資金予算明細パラメータ設定クラス
機能は以下の通り
旅費資金予算明細のパラメータを設定します。
ParamTravelAmount - class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount.
旅費資金計画通貨項目パラメータ設定クラス
機能は以下の通り
旅費資金計画通貨項目のパラメータを設定します。
ParamUnitSofmeasure - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure.
数量単位パラメータ設定クラス
機能は以下の通り
数量単位のパラメータを設定します。
ParamUnplndConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption.
計画外消費のデータ転送パラメータ設定クラス
機能は以下の通り
計画外消費のデータ転送のパラメータを設定します。
ParamUserNameRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa.
ユーザ名の範囲パラメータ設定クラス
機能は以下の通り
ユーザ名の範囲のパラメータを設定します。
ParamValuationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList.
評価データパラメータ設定クラス
機能は以下の通り
評価データのパラメータを設定します。
ParamVendorAddress - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress.
仕入先住所パラメータ設定クラス
機能は以下の通り
仕入先住所のパラメータを設定します。
ParamVendorRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa.
仕入先の範囲パラメータ設定クラス
機能は以下の通り
仕入先の範囲のパラメータを設定します。
ParamVersions - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions.
バージョン管理パラメータ設定ラクラス
機能は以下の通り
バージョン管理のパラメータを設定します。
ParamWarehouseNumberDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList.
倉庫番号データパラメータ設定クラス
機能は以下の通り
倉庫番号データのパラメータを設定します。
ParamWmdvex - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex.
出力テーブル (日付および ATP 数量)パラメータ設定クラス
機能は以下の通り
出力テーブル (日付および ATP 数量)のパラメータを設定します。
ParamWmdvsx - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx.
入力テーブル (日付/数量)パラメータ設定クラス
機能は以下の通り
入力テーブル (日付/数量)のパラメータを設定します。
Partner - class jp.co.intra_mart.foundation.sap.module.purchase.Partner.
取引先情報クラス
機能は以下の通り
取引先情報を保持します。
Partner() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のコンストラクタ
取引先を作成します。
Partner(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のコンストラクタ
取引先を作成します。
PartnerAddresses - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses.
アドレス (組織/会社) 用 BAPI 参照構造情報クラス
機能は以下の通り
アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。
PartnerAddresses() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のコンストラクタ
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
PartnerAddresses(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のコンストラクタ
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
Partners - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners.
伝票取引先情報クラス
機能は以下の通り
伝票取引先情報を保持します。
Partners() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のコンストラクタ
伝票取引先情報を作成します。
Partners(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のコンストラクタ
伝票取引先情報を作成します。
PlanningData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData.
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList.
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlantData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData.
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
PlantData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList.
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。
PlantDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa.
プラントの範囲情報クラス
機能は以下の通り
プラントの範囲情報を保持します。
PlantRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のコンストラクタ
プラントの範囲情報を作成します。
PlantRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のコンストラクタ
プラントの範囲情報を作成します。
PlantSelection - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection.
プラントの選択オプションクラス
機能は以下の通り
プラントの選択オプションの情報を保持します。
PlantSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のコンストラクタ
プラントの選択オプション情報を作成します。
PlantSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のコンストラクタ
Sプラントの選択オプション情報を作成します。
ProductionResourceToolData - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData.
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
ProductionResourceToolData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
ProfitCenter - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter.
利益センタ情報クラス
機能は以下の通り
利益センタの情報を保持します。
ProfitCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のコンストラクタ
利益センタ情報を作成します。
ProfitCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController.
利益センタコントローラクラス
機能は以下の通り
利益センタの情報を取得します。
ProfitCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, String, String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, String, String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterGrpGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail.
利益センタグループ情報取得クラス
機能は以下の通り
利益センタグループ情報を取得します。
ProfitCenterGrpGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のコンストラクタ
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のコンストラクタ

ProfitCenterGrpGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController.
利益センタグループコントローラクラス
機能は以下の通り
利益センタグループを取得します。
ProfitCenterGrpGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ

ProfitCenterGrpGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ

ProfitCenterGrpGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList.
利益センタ一覧クラス

機能は以下の通り
利益センタの情報を一覧形式で取得します。
ProfitCenterList(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のコンストラクタ
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitSegment - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment.
入出庫予定情報クラス
機能は以下の通り
入出庫予定情報を保持します。
ProfitSegment() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のコンストラクタ
入出庫予定を作成します。
ProfitSegment(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のコンストラクタ
入出庫予定を作成します。
ProjectDefinition - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition.
プロジェクトについての詳細情報クラス 機能は以下の通り
プロジェクトについての詳細情報を保持します。
ProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のコンストラクタ
プロジェクトについての詳細情報を作成します。
ProjectGetInfo - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo.
WBS情報取得クラス
機能は以下の通り
WBS情報を取得します。
ProjectGetInfo(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のコンストラクタ
WBS情報を作成します。
ProjectGetInfoController - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController.
WBSの詳細コントローラクラス
機能は以下の通り
WBSの詳細を取得します。
ProjectGetInfoController() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のコンストラクタ
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfoController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のコンストラクタ
ProjectGetInfoControllerのコンストラクタを生成します。
PrtData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData.
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
PrtData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PrtData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PstngDateRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa.
登録日付の範囲情報クラス
機能は以下の通り
登録日付の範囲情報を保持します。
PstngDateRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のコンストラクタ
登録日付の範囲情報を作成します。
PstngDateRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のコンストラクタ
登録日付の範囲情報を作成します。
PurchaseAccount - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount.
購買発注伝票勘定情報クラス
機能は以下の通り
購買発注伝票勘定情報を保持します。
PurchaseAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のコンストラクタ
購買発注伝票明細を作成します。
PurchaseAccount(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のコンストラクタ
購買発注伝票明細を作成します。
PurchaseComponents - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents.
コンポーネント情報クラス
機能は以下の通り
コンポーネント情報を保持します。
PurchaseComponents() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のコンストラクタ
コンポーネント情報を作成します。
PurchaseComponents(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のコンストラクタ
コンポーネント情報を作成します。
PurchaseConfirmation - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation.
転送構造：照会／一覧情報クラス
機能は以下の通り
転送構造：照会／一覧情報を保持します。
PurchaseConfirmation() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のコンストラクタ
転送構造：照会／一覧情報を作成します。
PurchaseConfirmation(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のコンストラクタ
転送構造：照会／一覧情報を作成します。
PurchaseGetItemSrel - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel.
伝票承認対象一覧情報クラス
機能は以下の通り
伝票承認対象一覧を取得します。
PurchaseGetItemSrel(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrel(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のコンストラクタ
承認対象一覧を作成します。
PurchaseGetItemSrelController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController.
伝票の承認対象一覧取得コントローラクラス
機能は以下の通り
伝票の承認対象一覧を取得します。
PurchaseGetItemSrelController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrelController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrelController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseHeader - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader.
購買発注ヘッダ情報スーパークラス
機能は以下の通り
購買発注のヘッダ情報を保持します。
PurchaseHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のコンストラクタ
購買発注伝票ヘッダを作成します。
PurchaseHeaderPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost.
購買発注伝票ヘッダ情報クラス
機能は以下の通り
購買発注伝票ヘッダの情報を保持します。
PurchaseHeaderPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のコンストラクタ
購買発注伝票ヘッダを作成します。
PurchaseHeaders - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders.
伝票の承認対象一覧ヘッダ情報クラス
機能は以下の通り
伝票の承認対象一覧ヘッダの情報を保持します。
PurchaseHeaders() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のコンストラクタ
伝票の承認対象一覧ヘッダを作成します。
PurchaseHistory - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory.
購買発注履歴情報クラス
機能は以下の通り
購買発注履歴情報を保持します。
PurchaseHistory() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のコンストラクタ
購買発注履歴情報を作成します。
PurchaseHistory(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のコンストラクタ
転購買発注履歴情報を作成します。
PurchaseHistoryTotals - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals.
購買発注履歴（合計）情報クラス
機能は以下の通り
購買発注履歴（合計）情報を保持します。
PurchaseHistoryTotals() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のコンストラクタ
購買発注履歴（合計）情報を作成します。
PurchaseHistoryTotals(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のコンストラクタ
購買発注履歴（合計）情報を作成します。
PurchaseItem - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem.
購買発注明細情報スーパークラス
機能は以下の通り
購買発注の明細情報を保持します。
PurchaseItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItemPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost.
購買発注伝票明細情報クラス
機能は以下の通り
購買発注伝票明細情報を保持します。
PurchaseItemPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItemPost(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItems - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems.
伝票の承認対象明細情報クラス
機能は以下の通り
伝票の承認対象明細情報を保持します。
PurchaseItems() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のコンストラクタ
伝票の承認対象明細を作成します。
PurchaseOrderPayPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost.
伝票登録クラス
機能は以下の通り
伝票を登録します。
PurchaseOrderPayPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
コンストラクタ。
PurchaseOrderPayPost(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
PurchaseOrderPayPost(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
PurchaseOrderPayPostController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
PurchaseOrderPayPostController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController.
伝票登録変更コントローラクラス
機能は以下の通り
伝票を変更します。
PurchaseOrderPostChangeController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseRelease - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease.
承認情報スーパークラス
機能は以下の通り
承認情報を保持します。
PurchaseRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
伝票承認を作成します。
PurchaseRelease(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseReleaseController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController.
伝票承認コントローラクラス
機能は以下の通り
伝票を承認します。
PurchaseReleaseController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseResetReleaseController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController.
伝票承認取消コントローラクラス
機能は以下の通り
伝票の承認取消します。
PurchaseResetReleaseController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseSchedule - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule.
購買発注伝票納入日程情報クラス
機能は以下の通り
購買発注伝票納入日程情報を保持します。
PurchaseSchedule() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のコンストラクタ
購買発注伝票納入日程を作成します。
PurchaseSchedule(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のコンストラクタ
購買発注伝票納入日程を作成します。
PurchaseShipping - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping.
出荷データクラス
機能は以下の通り
出荷データを保持します。
PurchaseShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のコンストラクタ
出荷データを作成します。
PurchaseShipping(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のコンストラクタ
出荷データを作成します。
PurchaseShippingExp - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp.
出荷データエクスポートクラス
機能は以下の通り
出荷データエクスポート情報を保持します。
PurchaseShippingExp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のコンストラクタ
出荷データエクスポート情報を作成します。
PurchaseShippingExp(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のコンストラクタ
出荷データエクスポート情報を作成します。
PurchaseText - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText.
購買発注伝票テキストクラス
機能は以下の通り
購買発注伝テキストを保持します。
PurchaseText() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のコンストラクタ
購買発注伝票テキストを作成します。
PurchaseText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のコンストラクタ
購買発注伝票テキストを作成します。

Q

QuotationCreateFromData2 - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2.
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。
QuotationCreateFromData2() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
コンストラクタ。
QuotationCreateFromData2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
QuotationCreateFromData2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
QuotationCreateFromData2Controller - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller.
見積伝票登録情報コントローラクラス
機能は以下の通り
見積伝票登録情報を保持します。
QuotationCreateFromData2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。

R

RefDocRange - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange.
前伝票の範囲情報クラス
機能は以下の通り
前伝票の範囲情報を保持します。
RefDocRange() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のコンストラクタ
前伝票の範囲情報を作成します。
ReferenceController - class jp.co.intra_mart.foundation.sap.module.ReferenceController.
参照系モジュール共通コントローラ親クラス。
ReferenceController() - class jp.co.intra_mart.foundation.sap.module.ReferenceController のコンストラクタ
コンストラクタ。
ReferenceController(SapClient) - class jp.co.intra_mart.foundation.sap.module.ReferenceController のコンストラクタ
コンストラクタ。
ReturnMessages - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages.
リターンパラメータ BAPIRET2 の代替構造情報クラス
機能は以下の通り
リターンパラメータ BAPIRET2 の代替構造情報を保持します。
ReturnMessages() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のコンストラクタ
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReturnMessages(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のコンストラクタ
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

S

SAPAccountingAppException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException.
会計系APIアプリケーション例外クラス。
SAPAccountingAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingAppException(String) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingSystemException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException.
会計系APIシステム例外クラス
SAPAccountingSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException のコンストラクタ
会計系APIシステム例外
SAPBapiReturnErrMessageExistException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException.
BAPI実行結果例外クラス
SAPBapiReturnErrMessageExistException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException のコンストラクタ
BAPI実行結果例外
SAPBapiReturnErrMessageExistException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException のコンストラクタ
BAPI実行結果例外
SAPFinancialAppException - exception jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException.
会計系APIアプリケーション例外クラス。
SAPFinancialAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException のコンストラクタ
会計系APIアプリケーション例外
SAPFinancialAppException(String) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException のコンストラクタ
会計系APIアプリケーション例外
SAPFinancialSystemException - exception jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException.
会計系APIシステム例外クラス
SAPFinancialSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException のコンストラクタ
会計系APIシステム例外
SAPModuleAppException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException.
モジュール用データ取得・追加・更新APIアプリケーション例外クラス。
SAPModuleAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException のコンストラクタ
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleAppException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException のコンストラクタ
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleSystemException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException.
モジュール用データ取得・追加・更新APIシステム例外クラス
SAPModuleSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException のコンストラクタ
モジュール用データ取得・追加・更新APIシステム例外
SAPModuleSystemException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException のコンストラクタ
モジュール用データ取得・追加・更新APIシステム例外
SAPPurchaseAppException - exception jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException.
購買系APIアプリケーション例外クラス。
SAPPurchaseAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException のコンストラクタ
購買系APIアプリケーション例外
SAPPurchaseAppException(String) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException のコンストラクタ
購買系APIアプリケーション例外
SAPPurchaseSystemException - exception jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException.
購買系APIシステム例外クラス
SAPPurchaseSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException のコンストラクタ
購買系APIシステム例外
SAPSalesAppException - exception jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException.
販売管理系APIアプリケーション例外クラス。
SAPSalesAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException のコンストラクタ
販売管理系APIアプリケーション例外
SAPSalesAppException(String) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException のコンストラクタ
販売管理系APIアプリケーション例外
SAPSalesSystemException - exception jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException.
販売管理系APIシステム例外クラス
SAPSalesSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException のコンストラクタ
販売管理系APIシステム例外
SalesData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData.
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
SalesData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のコンストラクタ
販売データ情報を作成します。
SalesDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList.
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。
SalesDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のコンストラクタ
販売データ情報を作成します。
SalesDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のコンストラクタ
販売データ情報を作成します。
SalesOrderCreateFromDat2 - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2.
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。
SalesOrderCreateFromDat2() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
コンストラクタ。
SalesOrderCreateFromDat2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
SalesOrderCreateFromDat2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
SalesOrderCreateFromDat2Controller - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller.
受注伝票登録コントローラクラス
機能は以下の通り
受注伝票を登録します。
SalesOrderCreateFromDat2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderGetList - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList.
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。
SalesOrderGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のコンストラクタ
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のコンストラクタ
販売伝票一覧照会情報を作成します。
SalesOrderGetListController - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController.
販売伝票一覧照会コントローラクラス
機能は以下の通り
販売伝票一覧の情報を取得します。
SalesOrderGetListController() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatus - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus.
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。
SalesOrderGetStatus(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のコンストラクタ
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のコンストラクタ
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatusController - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController.
販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り
販売伝票ステータス一覧の情報を取得します。
SalesOrderGetStatusController() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrders - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders.
得意先受注テーブル情報クラス
機能は以下の通り
得意先受注テーブル情報を保持します。
SalesOrders() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のコンストラクタ
得意先受注テーブル情報を作成します。
SalesOrders(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のコンストラクタ
得意先受注テーブル情報を作成します。
SalesOrganisationSelection - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection.
販売組織の選択オプションクラス
機能は以下の通り
販売組織の選択オプションの情報を保持します。
SalesOrganisationSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のコンストラクタ
販売組織の選択オプション情報を作成します。
SalesOrganisationSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のコンストラクタ
販売組織の選択オプション情報を作成します。
SchedulesIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn.
納入日程行情報クラス
機能は以下の通り
納入日程行情報を保持します。
SchedulesIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のコンストラクタ
納入日程行情報を作成します。
SchedulesIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のコンストラクタ
納入日程行情報を作成します。
SchedulesInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX.
納入日程行チェックボックス情報クラス
機能は以下の通り
納入日程行チェックボックス情報を保持します。
SchedulesInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のコンストラクタ
納入日程行チェックボックス情報を作成します。
SchedulesInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のコンストラクタ
納入日程行チェックボックス情報を作成します。
Selection - class jp.co.intra_mart.foundation.sap.module.purchase.Selection.
選択オプションクラス
機能は以下の通り
選択オプションの情報を保持します。
Selection() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のコンストラクタ
選択オプション情報を作成します。
Sender - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender.
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。
Sender() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のコンストラクタ
論理システム - 送信者情報を作成します。
SpecStockRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa.
特殊在庫区分の範囲情報クラス
機能は以下の通り
特殊在庫区分の範囲情報を保持します。
SpecStockRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のコンストラクタ
特殊在庫区分の範囲情報を作成します。
SpecStockRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のコンストラクタ
特殊在庫区分の範囲情報を作成します。
StatusInfo - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo.
ステータス情報情報クラス
機能は以下の通り
ステータス情報情報を保持します。
StatusInfo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のコンストラクタ
ステータス情報情報を作成します。
StatusInfo(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のコンストラクタ
ステータス情報情報を作成します。
StdMaterialGetIntNumber - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber.
品目コード割当済情報クラス
機能は以下の通り
品目コード割当済の情報を保持します。
StdMaterialGetIntNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のコンストラクタ
品目コード割当済情報を作成します。
StdMaterialGetIntNumberController - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController.
品目コード割当済照会コントローラクラス。
StdMaterialGetIntNumberController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のコンストラクタ
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のコンストラクタ
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberList - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList.
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。
StdMaterialGetIntNumberList(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のコンストラクタ
executeBapiを呼び出し品目コード割当済一覧を作成します。
StgeLocRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa.
保管場所の範囲情報クラス
機能は以下の通り
保管場所の範囲情報を保持します。
StgeLocRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のコンストラクタ
保管場所の範囲情報を作成します。
StgeLocRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のコンストラクタ
保管場所の範囲情報を作成します。
StorageLocationData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData.
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageLocationData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList.
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageLocationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationSelect - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect.
保管場所の選択オプションクラス
機能は以下の通り
保管場所の選択オプションの情報を保持します。
StorageLocationSelect() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のコンストラクタ
保管場所の選択オプション情報を作成します。
StorageLocationSelect(int) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のコンストラクタ
保管場所の選択オプション情報を作成します。
StorageTypeData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData.
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
StorageTypeData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のコンストラクタ
保管域タイプデータ情報を作成します。
StorageTypeDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList.
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。
StorageTypeDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のコンストラクタ
保管域タイプデータ情報を作成します。
StorageTypeDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のコンストラクタ
保管域タイプデータ情報を作成します。
Success - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success.
正常に処理された明細のテーブル情報クラス
機能は以下の通り
正常に処理された明細のテーブル情報を保持します。
Success() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のコンストラクタ
正常に処理された明細のテーブル情報を作成します。
Success(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のコンストラクタ
正常に処理された明細のテーブル情報を作成します。
SupplierDetail - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail.
仕入先マスタ詳細情報クラス
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のコンストラクタ
仕入先詳細情報クラスを取得します
SupplierDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のコンストラクタ
executeBapiを呼び出し仕入先マスタ詳細を作成します。
SupplierExistenceCheck - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck.
仕入先コード存在チェッククラス
機能は以下の通り
仕入先コード存在チェック結果を取得します。
SupplierExistenceCheck(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のコンストラクタ
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のコンストラクタ
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierExistenceCheckController - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController.
仕入先コード存在チェックコントローラ
機能は以下の通り
仕入先コード存在チェックを行います。
SupplierExistenceCheckController() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
コンストラクタ生成
SupplierExistenceCheckController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
コンストラクタ生成
SupplierExistenceCheckController(String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierGetDetailController - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController.
仕入先マスタの詳細情報取得コントローラ
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierGetDetailController() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SystemStatus - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus.
システムステータステーブル情報クラス 機能は以下の通り
システムステータステーブル情報を保持します。
SystemStatus() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のコンストラクタ
システムステータステーブルを作成します。
sapClient - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
SAPクライアント
setAbart(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
承認タイプを設定します。
setAbcId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ABC 区分を設定します。
setAbrli(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
内部納入日程番号を設定します。
setAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票番号を設定します｡
setAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号を設定します｡
setAcIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード番号を設定します｡
setAccessSeq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
検索順序 - 検索番号を設定します。
setAccessSeq(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
検索順序 - 検索番号を設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先の勘定設定グループを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先の勘定設定グループを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAccountGlList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細一覧を設定します｡
setAccountKe(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キー 見越/引当を設定します。
setAccountPayableList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細一覧を設定します｡
setAccountTaxList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
税明細一覧を設定します｡
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計ビューを設定します。
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
会計ビューを設定します。
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
会計ビューを設定します。
setAccountkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キーを設定します。
setAccruals(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
見越額関連条件 (運賃など)を設定します。
setAccruals(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
見越額関連条件 (運賃など)を設定します。
setAcctAssgt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目の勘定設定グループを設定します。
setAcctKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
内部処理キーを設定します｡
setAcctKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
内部処理キーを設定します｡
setAcctKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
内部処理キーを設定します｡
setAcctasgnmt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の勘定設定グループを設定します。
setAcctasscat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
勘定設定カテゴリを設定します。
setAcctstatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
会計への転記ステータスを設定します。
setAcknReqd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注請求書依頼を設定します。
setAcknowlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注請書番号を設定します。
setAcknowlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注請書番号を設定します。
setActState(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般マスタレコードの有効化ステータスを設定します｡
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
作業/活動番号を設定します｡
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク/標準ネットワークの活動番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
作業番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
処理タイプを設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
作業番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
作業番号を設定します。
setActivityCosts(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の原価を設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
活動タイプを設定します｡
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
活動タイプを設定します。
setActualCost(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実際原価を設定します。
setActualDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日付(マイルストーン通過)を設定します。
setActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績終了日: 実行 (日付)を設定します。
setActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績開始日: 実行 (日付)を設定します。
setActualTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日/時間(マイルストーン適合)を設定します。
setAddToStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
既存在庫への追加許可を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日からの日数を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日からの日数を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAddrLink(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所コードへのリンクを設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
アドレス: アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレス番号を設定します。
setAddrOrig(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
コピー元住所を設定します。
setAddrType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
住所注記を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
住所注記を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
住所注記を設定します。
setAgmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約の明細番号を設定します。
setAgreement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買契約番号を設定します｡
setAgreement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約番号を設定します。
setAllVersionsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
全バージョン一覧を設定します｡
setAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーを設定します｡
setAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーを設定します｡
setAllocTbl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
商品配分表番号を設定します。
setAllocTbl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
商品配分表番号を設定します。
setAllocTblItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
割当テーブルの明細番号を設定します。
setAllowedBusTractList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
使用可能業務トランザクションのテーブル（AllowedBusTractインスタンスの配列）を設定します。
setAllowedBusTractList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
使用可能業務トランザクションのテーブルを設定します。
setAllowedWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包重量を設定します。
setAllwdVol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包容積を設定します。
setAlphaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
アルファ係数使用による基本値の平滑化を設定します。
setAltBomId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOM 選択の方法を設定します。
setAltToItm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替明細を設定します。
setAltToItm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAltUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
在庫保管単位の代替数量単位を設定します。
setAltUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードによる在庫単位の代替数量単位を設定します。
setAlternBom(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替 BOMを設定します。
setAlternBom(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAlternat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替明細を設定します。
setAlternativeBom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOMを設定します。
setAlttaxCls(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
代替税分類を設定します。
setAlttaxCls(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAmountLc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
マニュアル入力による転記金額 (国内通貨)を設定します。
setAmountLc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
マニュアル入力による転記金額 (国内通貨)を設定します。
setAmountSv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
外部入力による販売金額 (国内通貨)を設定します。
setAmountSv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
外部入力による販売金額 (国内通貨)を設定します。
setAmountchan(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 金額変更を設定します。
setAmtActual(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
削減額を設定します｡
setAmtBase(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を設定します｡
setAmtDoccur(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額を設定します｡
setAmtOpen(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
未決済金額を設定します｡
setAmtOrigin(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
元金額を設定します｡
setAppdBRec(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バッチ製造記録の承認必須を設定します。
setApplicBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を設定します。
setApplicant(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者を設定します。
setApplicantNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請者番号を設定します。
setApplicantNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
申請者番号を設定します。
setApplicantPhone(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者の電話番号を設定します。
setApplicatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
アプリケーションを設定します。
setApplicatio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
アプリケーションを設定します。
setApplicationDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請日を設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApproved(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
出張申請または出張承認済 (区分)を設定します｡
setAssNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
割当番号を設定します。
setAssNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産番号を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産番号を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産番号を設定します。
setAssortMod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品揃モジュールを設定します。
setAssortMod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAssyScrap(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
組立不良率を設定します。
setAtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
割当テーブルの明細番号を設定します。
setAtRelev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
適当テーブル関連を設定します。
setAtpWrkmod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
ATP セッション: 結果取得/新規決定 APO-ATPを設定します。
setAuthCcNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認番号を設定します。
setAuthDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認日を設定します。
setAuthDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認日を設定します。
setAuthFlag(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 振替権限を設定します。
setAuthFlag(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 振替権限を設定します。
setAuthNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
返品権限番号を設定します。
setAuthNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
返品権限番号を設定します。
setAuthRefno(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社の権限参照コードを設定します。
setAuthRefno(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社の権限参照コードを設定します。
setAuthTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認時刻を設定します。
setAuthTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認時刻を設定します。
setAuthamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認額を設定します。
setAuthamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認額を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
報告書提案済を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
報告書提案済を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
報告書提案済を設定します。
setAuthoritygroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
権限グループを設定します。
setAuthortype(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認タイプを設定します。
setAutoPOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: "購買発注自動生成"を設定します。
setAutoReset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予測モデル自動リセットを設定します。
setAvQtyPlt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントレベル利用可能数量を設定します。
setAvailCheckAllProjSegments(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プロジェクト間品目区分を設定します。
setAvailcheck(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利用可能在庫確認の確認グループを設定します。
setBUomIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードでの基本数量単位を設定します。
setBaList(BankList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を設定します｡
setBackflush(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バックフラッシュを設定します。
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
銀行データ情報を設定します｡
setBankKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを設定します｡
setBankList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧（Bankインスタンスの配列）を設定します｡
setBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を設定します｡
setBarCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
バーコードエントリを設定します。
setBaseQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
基本数量を設定します。
setBaseQtyPlan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷の能力計画のための基本数量を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
基本数量単位を設定します｡
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
基本数量単位を設定します。
setBaseUomIso(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ISO コードでの基本数量単位を設定します｡
setBaseUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの基本数量単位を設定します。
setBasicLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本明細を設定します。
setBasicMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
主構成物質を設定します。
setBasicValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
基準値を設定します。
setBasicValue1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を設定します。
setBasicValue2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を設定します。
setBasicValuePp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の基準値を設定します。
setBasicValuePp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を設定します。
setBasicValuePp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を設定します。
setBasicView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
基本データビューを設定します。
setBaslineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替: 基本明細参照を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
ロットを設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ロット番号を設定します。
setBatchMgmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロット管理所要量区分を設定します。
setBatchMgmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロット管理所要量区分を設定します。
setBatchRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ロットの範囲を設定します。
setBatchentry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造/プロセス指図でのロット入力設定を設定します。
setBdcnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
5 文字数値 NUMCを設定します。
setBegdemPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見越期間の提案開始日付を設定します。
setBegdemPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBegintime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
開始時刻を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
エラー処理を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
エラー処理を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
エラー処理を設定します。
setBetaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ベータ係数による傾向値平準化を設定します。
setBidder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入札者の明細を設定します。
setBidinvNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積管理番号を設定します。
setBilForm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書式を設定します。
setBilForm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票の請求ブロックを設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ブロックを設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票の請求ブロックを設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票を設定します。
setBillDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票明細を設定します。
setBillOfLading(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫時に登録した B/L 番号を設定します。
setBillOfLadingLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。
setBillPlan(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求計画番号を設定します。
setBillPlani(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
明細: 請求計画/支払計画/支払カードを設定します。
setBillRel(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求関連 (CRM)を設定します。
setBillRel(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求日程 (稼働日カレンダ指定)を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求日程 (稼働日カレンダ指定)を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求先を設定します。
setBillType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求タイプを設定します。
setBillValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求金額: 請求計画に請求日付が指定されている場合を設定します。
setBillamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
請求金額: 請求計画に請求日付が指定されている場合を設定します。
setBillcateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求カテゴリを設定します。
setBillingDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定明細データのテーブルを設定します。
setBillingDocumentDetail(BillingDocumentDetail) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
請求伝票に関する詳細情報を設定します。
setBillingDocumentDetail(BillingDocumentDetail) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
請求伝票に関する詳細情報を設定します。
setBillingDocumentDetailListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票のテーブルを設定します。
setBillingdoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求伝票を設定します。
setBillingdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
処理予定の請求伝票数を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBindgPer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積有効期間を設定します。
setBlQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入庫保留在庫数量 (発注価格単位)を設定します。
setBlQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
入庫保留在庫数量 (発注価格単位)を設定します。
setBlQtyTotal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
発注単位による入庫保留在庫 (絶対額)を設定します。
setBlanket(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
包括明細を設定します。
setBlineDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日を設定します｡
setBllsrvInd(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
サービスコード (外貨支払)を設定します｡
setBlockStge(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
平置保管域区分を設定します。
setBlockedQy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
発注単位の入庫保留在庫を設定します。
setBlockedQy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
発注単位の入庫保留在庫を設定します。
setBomUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BOM 用途を設定します。
setBomexplNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BOM 展開番号を設定します。
setBomexplNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBonGrp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ1を設定します。
setBonGrp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 2 (リベート決済、購買)を設定します。
setBonGrp3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 3 (リベート決済、購買)を設定します。
setBrasNbm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Brazilian NCM Codeを設定します。
setBudgetProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
予算プロファイルを設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物 (番号またはコード)を設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物 (番号またはコード)を設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物 (番号またはコード)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
旧: 建物 (番号または略称)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
旧: 建物 (番号または略称)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
旧: 建物 (番号または略称)を設定します。
setBulkMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バルク品目を設定します。
setBusAct(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
取引を設定します｡
setBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
事業領域を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
事業領域を設定します。
setBusAreaList(BusinessAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を設定します｡
setBusTranst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
貿易管理の取引タイプを設定します。
setBusTranst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBusinessAreaFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
事業領域を設定します｡
setBusinessAreaFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
事業領域を設定します｡
setBusinessAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧（BusinessAreaインスタンスの配列）を設定します｡
setBusinessAreaTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
事業領域を設定します｡
setBusinessAreaTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
事業領域を設定します｡
setBusinessTransactionType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易管理の取引タイプを設定します。
setBuspartno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
取引先の仕入先マスタコードを設定します。
setBwdCons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 後方を設定します。
setCCardDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定支払方法のテーブルを設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
気付を設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
気付を設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
気付を設定します。
setCadId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
CAD 区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
計算区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
計算区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
計算区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
計算区分を設定します｡
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します｡
setCalctypcon(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件計算タイプを設定します。
setCalctypcon(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件計算タイプを設定します。
setCalctype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定タイプを設定します。
setCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
稼動日カレンダを設定します。
setCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
稼動日カレンダを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
総括プロジェクト計画: 外部 SAP システムの GUIDを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総括プロジェクト計画: 外部 SAP システムの GUIDを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCancelled(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
中止区分を設定します。
setCapyUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量使用を設定します。
setCasNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAS 番号： 薬事品目 - 貿易を設定します。
setCashDisc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
現金値引区分を設定します。
setCashDisc1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 1を設定します。
setCashDisc2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 2を設定します。
setCatprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
カタログプロファイルを設定します。
setCbaseId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号 (固定)を設定します。
setCbaseIdType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号タイプ (固定)を設定します。
setCcAuthNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認番号を設定します。
setCcCtrlField(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
カード照合額の制御項目を設定します。
setCcFixed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸区分固定を設定します。
setCcInUseSt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
カード照合額の使用ステータスを設定します。
setCcLimited(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 限度額を設定します。
setCcLocId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: トランザクション (入庫時点)を設定します。
setCcName(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード所有者の氏名を設定します。
setCcName(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード所有者の氏名を設定します。
setCcNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード番号を設定します。
setCcNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード番号を設定します。
setCcPhInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸の実地棚卸区分を設定します。
setCcReAmount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
BAPI インタフェースの通貨金額を設定します。
setCcReact(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 権限確認に対する応答を設定します。
setCcReactT(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 結果テキストを設定します。
setCcSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 支払カード - 接尾辞を設定します。
setCcSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 支払カード - 接尾辞を設定します。
setCcSettled(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済終了を設定します。
setCcStatEx(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 外部システム呼出時のステータスを設定します。
setCcType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カードタイプ: カードタイプを設定します。
setCcType(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カードタイプ: カードタイプを設定します。
setCcValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 使用有効開始日付を設定します。
setCcValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 有効終了日を設定します。
setCcValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 有効終了日を設定します。
setCcVerifValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
カード照合額を設定します。
setCctrPosted(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価が実際に転記された原価センタを設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件数量単位 (ISO コード)を設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件数量単位 (ISO コード)を設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件数量単位 (ISO コード)を設定します。
setCertType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
証明書タイプを設定します。
setCfginfo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CU: 選定の BLOB (SCE)を設定します。
setCfopCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extension (old 5 char version)を設定します。
setCfopCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCfopLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extensionを設定します。
setChangeId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
変更タイプ(U、I、E、D)を設定します。
setChangeId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
変更タイプ(U、I、E、D)を設定します。
setChangeNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
変更番号を設定します。
setChangedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクトの変更者名を設定します。
setCharUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
特性の数量単位を設定します。
setCharUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を設定します。
setCharc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性名を設定します。
setCharcTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
言語依存特性テキストを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村ファイルテストステータスを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村ファイルテストステータスを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村ファイルテストステータスを設定します。
setCheckReturn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
結果を設定します｡
setCheckReturn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の static メソッド
結果を設定します｡
setCheckRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
確認規則を設定します。
setChkprtauth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
取引先権限チェックを設定します。
setChkprtauth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を設定します｡
setCity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
市区町村を設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setClIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
レコード番号を設定します｡
setClValFor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外貨による入庫/請求仮勘定決済金額を設定します。
setClValLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨による入庫/請求仮勘定決済金額を設定します。
setClValLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による入庫/請求仮勘定決済金額を設定します。
setClassType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
クラスタイプを設定します。
setClassType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
クラスタイプを設定します。
setClientData(ClientData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (クライアントレベル)を設定します。
setClientDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (クライアントレベル)を設定します。
setClosedBox(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
完了した梱包材を設定します。
setCmRelevanceFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
構成管理関連を設定します。
setCmlqtyDat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
累積出荷数量日付を設定します。
setCmlqtyDat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
予算コードを設定します｡
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
予算コードを設定します｡
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
予算コードを設定します｡
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
予算コードを設定します｡
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを設定します。
setCntrlInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票タイプに対する管理区分を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を設定します｡
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
管理領域を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
管理領域を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
管理領域を設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
業務プロセスを設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
業務プロセスを設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
業務プロセスを設定します。
setCoCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
会社コードを設定します。
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
レコード番号を設定します｡
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
レコード番号を設定します｡
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
レコード番号を設定します｡
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
レコード番号を設定します｡
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
レコード番号を設定します｡
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
レコード番号を設定します｡
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
レコード番号を設定します｡
setCoProduct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 連産品としても使用可能な品目を設定します。
setCoProduct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 連産品としても使用可能な品目を設定します。
setCoeffTheil(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
タイル係数を設定します。
setCollNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setComDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
確認日を設定します。
setComDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認日を設定します。
setComQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
確認数量を設定します。
setComQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認数量を設定します。
setCommCoUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
物品コード (貿易) の数量単位を設定します。
setCommCoUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードによる物品コード (貿易管理) の数量単位を設定します。
setCommCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 統計品目コード/輸入コード番号を設定します。
setCommCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 統計品目コード/輸入コード番号を設定します。
setCommGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
手数料グループを設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 1を設定します。
setCommprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 2を設定します。
setCommprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法基準評価額: レベル 3を設定します。
setCompCdeB(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求対象会社コードを設定します。
setCompCdeB(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社コードを設定します｡
setCompList(CompanyList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を設定します｡
setCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を設定します｡
setCompQuant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
構成品目数量を設定します。
setCompQuant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCompScrap(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
構成品目不良率を設定します。
setCompShip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示順守を設定します。
setCompShip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示順守を設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
会社コードを設定します。
setCompanycodeFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
会社コード（開始値）を設定します。
setCompanycodeFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
会社コード（開始値）を設定します。
setCompanycodeTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
会社コード（終了値）を設定します。
setCompanycodeTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
会社コード（終了値）を設定します。
setCompetitor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
競合会社を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
全購買発注に対する一括納入指定を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括納入区分を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最終確認の有効化を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を設定します。
setCompleted(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ステータス "バージョン完了済"を設定します。
setCompleted(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
ステータス "バージョン完了済"を設定します。
setCompoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ACC インタフェースの構成要素を設定します｡
setConExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
基本契約明細の制限を設定します。
setConItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
明細番号、契約を設定します。
setConLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を設定します。
setConNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
基本契約番号を設定します。
setConPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を設定します。
setConbaseval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値を設定します。
setConbaseval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値を設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カウンタを設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタを設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件連続番号を設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件カウンタを設定します。
setCondCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件通貨 (累積項目用)を設定します。
setCondDUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
伝票の条件単位を設定します。
setCondGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先条件グループを設定します。
setCondHandl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
選択: 条件行処理 (SD 伝票変更)を設定します。
setCondHeaderList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件ヘッダ一覧を設定します｡
setCondItemList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件明細一覧を設定します｡
setCondKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
条件タイプを設定します｡
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レコード番号を設定します。
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レコード番号を設定します。
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
伝票条件番号を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
価格条件単位を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
ステップ番号を設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件タイプを設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件単位を設定します。
setCondUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件数量単位 (ISO コード)を設定します。
setCondUpdat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件更新を設定します。
setCondUpdat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件更新を設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レートを設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件金額/率を設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レートを設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondchaman(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件 (マニュアル変更済)を設定します。
setCondchaman(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件 (マニュアル変更済)を設定します。
setCondclass(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件クラスを設定します。
setCondclass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件クラスを設定します。
setCondcntrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件管理を設定します。
setCondcntrl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件管理を設定します。
setCondcoinhd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタ (ヘッダ条件)を設定します。
setCondconfig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
システム設定の条件を設定します。
setCondconfig(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
システム設定の条件を設定します。
setCondcount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件連続番号を設定します。
setCondcount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件連続番号を設定します。
setCondincomp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
会社間請求の条件を設定します。
setCondincomp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
会社間請求の条件を設定します。
setCondisacti(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
無効条件を設定します。
setCondisacti(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
無効条件を設定します。
setConditemno(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件明細番号を設定します。
setCondition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票条件番号を設定します。
setConditionDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定条件のテーブルを設定します。
setConditionNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
伝票条件番号を設定します。
setCondorigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件生成区分を設定します。
setCondorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件生成区分を設定します。
setCondtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
setCondtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
setCondvalue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件金額を設定します。
setConexchrat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
現地通貨への換算レートに対する条件を設定します。
setConexchrat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
現地通貨への換算レートに対する条件を設定します。
setConfCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
確認管理キーを設定します。
setConfMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通選定可能品目を設定します。
setConfMatlExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 CONF_MATL の品目コード(長)を設定します。
setConfMatlGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 CONF_MATL の外部GUIDを設定します。
setConfMatlVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 CONF_MATL のバージョン番号を設定します。
setConfName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
確認カテゴリ: テキストを設定します。
setConfSer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の連続番号を設定します。
setConfSer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
仕入先確認の連続番号を設定します。
setConfType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
確認カテゴリを設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setConfigured(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
選定可能品目を設定します。
setConinvolst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
請求書一覧条件を設定します。
setConinvolst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
請求書一覧条件を設定します。
setConpricdat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件価格設定日付を設定します。
setConpricdat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件価格設定日付を設定します。
setConsValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
消費量を設定します。
setConsValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
消費量を設定します。
setConsistent(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を設定します。
setConsistent(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を設定します。
setConstraintFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了日に対する制約を設定します。
setConstraintFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日付を設定します。
setConstraintFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了時間を設定します。
setConstraintFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測終了時間を設定します。
setConstraintStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を設定します。
setConstraintStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測開始日を設定します。
setConstraintStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始時間の制約を設定します。
setConstraintStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の需要予測開始時間を設定します。
setConstraintTypeFinish(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の終了日に対する制約を設定します。
setConstraintTypeFinishFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動終了の制約条件付き需要予測日付を設定します。
setConstraintTypeStart(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を設定します。
setConstraintTypeStartFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動開始の制約条件付き需要予測日付を設定します。
setConsumctry(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
消費者の国キーを設定します。
setConsummode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費モードを設定します。
setContPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setContainer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容器条件を設定します。
setContext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
CU: 選定の BLOB (SCE)を設定します。
setContractLimitsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注基本契約制限一覧を設定します｡
setContractServiceAccountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス勘定設定一覧を設定します｡
setContractServiceList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス一覧を設定します｡
setContractServiceTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービステキスト一覧を設定します｡
setControlKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
管理キーを設定します。
setControllAreaList(ControllingAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
管理領域を設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
管理領域を設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
管理領域を設定します。
setControllingAreaCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを設定します。
setControllingAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を設定します｡
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
管理領域を設定します。
setConvDen1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分母を設定します。
setConvNum1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分子を設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
変換: 取引先機能 + 受注伝票タイプを設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
取引先機能/受注伝票タイプの変換を設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
変換: 取引先機能 + 受注伝票タイプを設定します。
setConvfactor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目用変換係数を設定します。
setCorrFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 修正係数を需要予測値計算に使用を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
需要予測に対する修正値を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
修正消費量を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
修正消費量を設定します。
setCostCentList(CostCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を設定します｡
setCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを設定します｡
setCostCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧（CostCenterインスタンスの配列）を設定します｡
setCostElem(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
原価要素を設定します。
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価対象を設定します｡
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価対象を設定します。
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価対象を設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算ビューを設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
原価計算ビューを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタを設定します｡
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
原価センタを設定します｡
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
原価センタを設定します。
setCostcenterFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ（開始値）を設定します。
setCostcenterFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ（開始値）を設定します。
setCostcenterTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ（終了値）を設定します。
setCostcenterTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ（終了値）を設定します。
setCostcentergroup(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタグループを設定します。
setCostcentergroup(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタグループを設定します。
setCostingSheet(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価計算表を設定します。
setCostobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価対象を設定します。
setCountrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国キー (ISO コード)を設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷国 (商品発送国)を設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを設定します。
setCountryori(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産国を設定します。
setCountryori(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産国を設定します。
setCountryoriIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを設定します。
setCountryoriIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの品目原産国を設定します。
setCovprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫日数プロファイルを設定します。
setCrOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード登録日を設定します。
setCreatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード登録日を設定します。
setCreatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
レコード登録日を設定します。
setCreateLoadRecs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
区分: 生産資源/治工具の負荷レコード登録を設定します。
setCreateLoadRecs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
区分: 生産資源/治工具の負荷レコード登録を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
登録者名を設定します｡
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクト登録者名を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
レコード登録日を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
登録日付を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
レコード登録日を設定します。
setCreationDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード登録日を設定します。
setCreationDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード登録日を設定します。
setCreationTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
登録時刻を設定します。
setCreationTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
登録時刻を設定します。
setCreatorDataIn(CreatorDataIn) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
取り込まれる日付の順序を設定します。
setCreditorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードを設定します｡
setCritPart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 重要品目を設定します。
setCrmRefSalesOrderNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理の CRM 参照受注番号を設定します。
setCrmRefSoItemNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理での CRM 参照受注明細番号を設定します。
setCrmSalesOrderItemNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理での CRM 受注明細番号を設定します。
setCrmSalesOrderNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先直送発注処理の CRM 受注番号を設定します。
setCsIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
レコード番号を設定します｡
setCshBdgtProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
資金計画プロファイルを設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ１を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ１を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ２を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ２を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ３を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ３を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ４を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ４を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ５を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ５を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価計算表を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
原価計算表を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効開始日付 (販売契約/品目提案)を設定します。
setCtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効終了日付 (販売契約/品目提案)を設定します。
setCtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtrlCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 消費税の管理コードを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
調達における品質管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達における品質管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具管理の管理キーを設定します。
setCtrlKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
管理キーは変更できませんを設定します。
setCtrlKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
管理キーは変更できませんを設定します。
setCtrlQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
管理数量を設定します。
setCuAmtBase(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
明細通貨項目の課税基準額に値を設定します。
setCuAmtDoccur(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
明細通貨項目の伝票通貨額に値を設定します。
setCuCurrency(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
明細通貨項目の通貨コードに値を設定します。
setCuIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を設定します｡
setCuItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
明細通貨項目の会計伝票明細番号に値を設定します。
setCumCfQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積確認数量 (販売数量単位)を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コード通貨を設定します。
setCurrIso2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCurrPeriod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当期 (転記期間)を設定します。
setCurrPeriod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期 (転記期間)を設定します。
setCurrPlanPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を設定します。
setCurrType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨タイプおよび評価ビューを設定します｡
setCurrType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
通貨タイプおよび評価ビューを設定します｡
setCurrenckey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール通貨を設定します。
setCurrenckey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール通貨を設定します。
setCurrenckeyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを設定します｡
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
通貨コードを設定します｡
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
購買発注通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
通貨コードを設定します｡
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票通貨を設定します。
setCurrency2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
販売伝票通貨を設定します。
setCurrencyAmountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
明細通貨項目一覧を設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
ISO コード通貨を設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
ISO コード通貨を設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ISO通貨コードを設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
ISO コード通貨を設定します。
setCurreniso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループを設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先グループを設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 1を設定します。
setCustGrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 2を設定します。
setCustGrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 3を設定します。
setCustGrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 4を設定します。
setCustGrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 5を設定します。
setCustGrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustMat22(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目コード (無効)を設定します。
setCustMat22(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustMat35(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目を設定します。
setCustMat35(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先コード1を設定します｡
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
得意先コード 1を設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
得意先コードを設定します。
setCustomerNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先コードを設定します。
setCustoms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
税関: 税関 (出国時)を設定します。
setCvalueFxd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
区分: 消費金額の確定を設定します。
setCycleTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タクトタイムを設定します。
setDToRefM(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照の有効終了日を設定します。
setDataIndex(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
別の構成のテーブル入力へのポインタを設定します。
setDataorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 入力モードを設定します。
setDataorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 入力モードを設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
起算日を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
起算日を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
日付を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
日付を設定します。
setDateFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
有効期間：開始を設定します。
setDateFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
有効期間：開始を設定します。
setDateTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
有効期間：終了を設定します。
setDateTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
有効期間：終了を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
提案日付タイプを設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
日付タイプ (日、週、月、期間)を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDateWorkBegins(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業開始を設定します。
setDateWorkEnds(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業終了を設定します。
setDbCrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
借方/貸方フラグを設定します。
setDeIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
レコード番号を設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先コードを設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードを設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先コードを設定します｡
setDecForRounding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
小数点位置 (その位置まで丸める)を設定します。
setDecForRoundingX(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDeclStatFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 仕入先申告ありを設定します。
setDelCreateDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷登録日付を設定します。
setDelDatcat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認における納入期日の日付カテゴリを設定します。
setDelDatcatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
納入期日カテゴリを設定します。
setDelDatcatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日カテゴリを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
クライアントレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
区分: 流通チャネルレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管タイプに該当する全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプに該当する全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
WM 倉庫内の全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
資金計画削除フラグを設定します｡
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票の削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
削除フラグを設定します｡
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
削除フラグ: 購買伝票勘定設定を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
区分: 仕入先確認削除を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
削除フラグを設定します｡
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
削除フラグを設定します。
setDelivCompl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出荷完了 区分を設定します。
setDelivDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の納入日付を設定します。
setDelivDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入期日を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
郵便配達地域を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
郵便配達地域を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
郵便配達地域を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
出荷明細を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
出荷明細を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷明細を設定します。
setDelivItemToSearch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
出荷伝票を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷伝票を設定します。
setDelivNumbToSearch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を設定します。
setDelivNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
出荷伝票を設定します。
setDelivQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納品書数量単位の数量を設定します。
setDelivQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
入庫数量を設定します。
setDelivTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の納入日時を設定します。
setDelivTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日における指定時間を設定します。
setDelivUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納品書の数量単位を設定します。
setDelivUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納品書数量単位の ISO コードを設定します。
setDeliveryAddressList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入荷伝票アドレス一覧を設定します｡
setDeliveryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日を設定します。
setDelkz(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
MRP 要素区分を設定します。
setDeltaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。
setDelyUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷単位を設定します。
setDelyUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷数量単位を設定します。
setDelyUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードでの出荷単位の数量単位を設定します。
setDelygPlnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷プラントを設定します。
setDenominato(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分母を設定します。
setDenominato(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分母を設定します。
setDenominatr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
分母: 基本数量単位へ変換する場合を設定します。
setDepReqId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
個別所要量と包括所要量に対する従属所要量区分を設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
部門コードを設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
部門コードを設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepartment(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
部署を設定します。
setDepcountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国 (商品発送国)を設定します。
setDepcountryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国の ISO コードを設定します。
setDeployHoriz(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給分配期間の日数を設定します。
setDeprecPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理に関する償却率 (%)を設定します。
setDeprecPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDescrHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
終了品目テキストを設定します。
setDescrLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
開始品目テキストを設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを設定します｡
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
テキスト (30 文字)を設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループテキスト (短)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業テキスト (短)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
PS: テキスト(短)(第一テキスト行)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
テキストを設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
PS: テキスト(短)(第一テキスト行)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンテキスト（長）を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンテキスト（長）を設定します。
setDetermGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫決定グループを設定します。
setDevalInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
低価法: 評価減区分を設定します。
setDialogflag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
区分 (X = 利用不可 /N = 確認なし)を設定します。
setDiffInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先と請求元が異なる場合の請求元コードを設定します｡
setDiscontinu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
打切区分を設定します。
setDispQuan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注数量: 表示目的全納入日程合計を設定します。
setDispoRel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
区分: MRP 関連の確認を設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
流通チャネルを設定します。
setDistrChanHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲終了を設定します。
setDistrChanLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲開始を設定します。
setDistrPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
配賦率 % (複数勘定設定)を設定します。
setDistrProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サイトの商品の物流プロファイルを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
複数勘定設定の配賦区分を設定します。
setDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
複数勘定設定の配賦区分を設定します。
setDistributingKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。
setDistributionChannelSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
流通チャネルの選択オプション一覧を設定します｡
setDistributionchannel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
流通チャネルを設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
所在地を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
製品部門を設定します。
setDlQtyTotal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
入庫数量: 絶対額を設定します。
setDlQtyTrsp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
納入済数量 (在庫転送)を設定します。
setDliProfil(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
動的明細プロセッサプロファイルを設定します。
setDliProfil(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を設定します。
setDlvDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷グループ (明細一括出荷)を設定します。
setDlvGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
出荷優先順位を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷優先順位を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷優先順位を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷数量実績 (販売単位)を設定します。
setDlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷数量実績 (販売単位)を設定します。
setDlvStatH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
全明細の出荷ステータスを設定します。
setDlvStatI(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
明細の全体出荷ステータスを設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
契約出荷期間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
契約出荷期間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードでの出荷単位の数量単位を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
用途区分を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
用途区分を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの会計伝票番号に値を設定します。
setDocCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票カテゴリを設定します。
setDocChgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書変更番号 (文書管理システム外)を設定します。
setDocClass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
リリースおよびトランザクション管理を備えた元システムを設定します。
setDocClass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの会社コードに値を設定します。
setDocCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
伝票条件番号を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付を設定します｡
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票日付を設定します｡
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票の伝票日付を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の伝票日付を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの伝票の伝票日付に値を設定します。
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの伝票タイプに値を設定します。
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの会計期間に値を設定します。
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの会計年度に値を設定します。
setDocFormat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書のページ書式 (文書管理システムによらない)を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの伝票ヘッダテキストに値を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ドキュメンタリクレジット処理: 内部番号を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理: 内部番号を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるオブジェクト番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
伝票番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売管理伝票番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダのオブジェクトキーに値を設定します。
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの参照処理に値を設定します。
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの伝票の転記日付に値を設定します。
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダの参照伝票番号に値を設定します。
setDocReqd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
文書必須フラグを設定します。
setDocStatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票ステータスを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプを設定します｡
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプを設定します｡
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票カテゴリを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票タイプを設定します｡
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書タイプ (文書管理システムによらない)を設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票タイプを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票タイプを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票タイプを設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダのユーザ名に値を設定します。
setDocVers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書バージョン (文書管理システムによらない)を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入出庫伝票年を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票年度を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票年度を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票年度を設定します。
setDocument(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書番号 (文書管理システムによらない)を設定します。
setDocumentDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
登録日付を設定します。
setDocumentDateTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
入力日付 (以前/以降)を設定します。
setDocumentHeader(DocumentHeader) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票ヘッダを設定します｡
setDocumentHeader(PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票ヘッダを設定します｡
setDontUseP(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所配達不可フラグを設定します。
setDontUseS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名住所配達不可フラグを設定します。
setDopVlLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による前払金合計を設定します。
setDown(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setDscnt1To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数1を設定します｡
setDscnt2To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数2を設定します｡
setDscnt3To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数3を設定します｡
setDsctPct1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 1を設定します。
setDsctPct2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 2を設定します。
setDsnOffice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
研究室/設計室を設定します。
setDunCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先商談回数を設定します。
setDunCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先との前回の商談日を設定します。
setDunDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理保留を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理保留を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理キーを設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理キーを設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDurationConfirmFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測活動期間を設定します。
setDurationConfirmFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測期間単位を設定します。
setDurationConfirmFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationMinimum(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短活動期間を設定します。
setDurationMinimumFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の最小期間(需要予測より)を設定します。
setDurationMinimumFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測最短期間の単位を設定します。
setDurationMinimumFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationMinimumUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短期間の単位を設定します。
setDurationMinimumUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationNormal(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間を設定します。
setDurationNormalFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間 (予測)を設定します。
setDurationNormalFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準予測期間の単位を設定します。
setDurationNormalFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationNormalUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準期間/単位を設定します。
setDurationNormalUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationScheduled(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間を設定します。
setDurationScheduledFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間の長さ (予測値)を設定します。
setDurationScheduledUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間単位を設定します。
setDurationScheduledUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
電子メールアドレスを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
電子メールアドレスを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
電子メールアドレスを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setEarlyFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (日)を設定します。
setEarlyFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了日 (予測)を設定します。
setEarlyFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (時刻)を設定します。
setEarlyFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了時間(需要予測)を設定します。
setEarlyStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 実行 (日)を設定します。
setEarlyStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始日付(需要予測)を設定します。
setEarlyStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 作業実施(時間)を設定します。
setEarlyStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始時間(需要予測)を設定します。
setEarnedValueIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗分析関連のマイルストーンを設定します。
setEdition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのバージョンを設定します。
setEdition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのバージョンを設定します。
setEffODay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
有効終了日を設定します。
setEiIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
レコード番号を設定します｡
setEmaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードを設定します。
setEmaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コード（長）を設定します。
setEmaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードの外部GUIDを設定します。
setEmaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードのバージョン番号を設定します。
setEndOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途の終了オフセットを設定します。
setEndOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途の終了オフセットを設定します。
setEndOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了オフセットは変更できませんを設定します。
setEndOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了オフセットは変更できませんを設定します。
setEndOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了オフセット単位を設定します。
setEndOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了オフセット単位を設定します。
setEndOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
setEndOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
setEndRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了日の参照日付を設定します。
setEndRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了日の参照日付を設定します。
setEndRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了参照日付は変更できませんを設定します。
setEndRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了参照日付は変更できませんを設定します。
setEndleadtme(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
補充リードタイムの終了日付を設定します。
setEndtime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
終了時刻を設定します。
setEntryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
会計伝票登録日付を設定します。
setEntryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
会計伝票登録日を設定します。
setEntryQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位での数量を設定します。
setEntryQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位での数量を設定します。
setEntryQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
構成品目の所要量を設定します。
setEntryTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
登録時刻を設定します。
setEntryTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
登録時刻を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
入力単位を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位を設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
入力単位 (ISO コード)を設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setEnvtRlvt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 環境関連を設定します。
setEquipment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備番号を設定します。
setEquityType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
持分タイプを設定します。
setEquityType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
持分タイプを設定します。
setErrorTotal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
エラー合計を設定します。
setErrorTotalPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間のエラー合計を設定します。
setErrorsList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
前明細の不正処理に関する情報を設定します。
setErs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ERS（入庫/請求自動決済）を設定します。
setEstPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
概算価格区分を設定します。
setEstimatedCosts(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図の見積原価合計を設定します。
setEuListNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAP: CAP 製品一覧番号を設定します。
setEuMatGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。
setEutriDeal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
フラグ: EC 内三角取引を設定します。
setEutriDeal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setEvent(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
論理時間を設定します。
setEventual(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
偶発的明細を設定します。
setExCertDt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書発行日を設定します。
setExCertId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
法令管理: 認定書区分を設定します。
setExCertNoNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書番号 - 法令管理を設定します。
setExIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
レコード番号を設定します｡
setExIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
レコード番号を設定します｡
setExRateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (直接相場)を設定します。
setExRateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExRateFx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レート固定区分を設定します｡
setExceptList(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
例外メッセージバーを設定します。
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
換算レートを設定します｡
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
換算レートを設定します｡
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
直接呼び値換算レートを設定します。
setExchRate(ExchRate) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レート、係数 (通貨ペア)を設定します。
setExchRate(ExchRate) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レート、係数 (通貨ペア)を設定します。
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レートを設定します｡
setExchRateCm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
間接呼び値換算レートを設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (間接相場)を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (間接相場)を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchRateV(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
間接呼び値換算レートを設定します｡
setExchRateV(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
間接呼び値換算レートを設定します｡
setExchRateV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
間接呼び値換算レートを設定します。
setExchangeRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/統計用換算レートを設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExpActivityList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
活動に関する詳細情報を設定します。
setExpActivityList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
活動に関する詳細情報を設定します。
setExpClientData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (クライアントレベル) を設定します。
setExpExtensionIn(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN の参照構造 を設定します。
setExpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
table(Export)情報からBAPI パラメータ EXTENSIONOUT の参照構造 を設定します。
setExpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。
setExpForecastParameters(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から予測データを設定します。
setExpInternationArticleNumbers(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からEANを設定します。
setExpLifoValuationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報からLIFO 関連品目データを設定します。
setExpMaterialDescription(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から品目テキストを設定します。
setExpMaterialText(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からテキスト (長) を設定します。
setExpMessageList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を読み込みエラーを設定します。
setExpMessageList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を読み込みエラーを設定します。
setExpPlanningData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
setExpPlantData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (プラントレベル) を設定します。
setExpProductionResourceToolData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setExpSalesData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から販売データを設定します。
setExpStorageLocationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (保管場所レベル)を設定します。
setExpStorageTypeData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から保管域タイプデータを設定します。
setExpTaxClassifications(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から制御データを設定します。
setExpUnitSofmeasure(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から数量単位を設定します。
setExpValuationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から評価データを設定します。
setExpValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
見込金額を設定します。
setExpWarehouseNumberData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から倉庫番号データを設定します。
setExpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 要素についての詳細情報を設定します。
setExpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 要素についての詳細情報を設定します。
setExpWbsHierarchieList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 階層についての情報を設定します。
setExpWbsHierarchieList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 階層についての情報を設定します。
setExpWbsMilestoneList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS マイルストーンに関する詳細情報を設定します。
setExpWbsMilestoneList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS マイルストーンに関する詳細情報を設定します。
setExpimpNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
貿易データ番号: MM/SD 伝票を設定します。
setExpimpgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
輸出/輸入品目グループを設定します。
setExpirydate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
有効期間期限日を設定します。
setExpirydate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
有効期間期限日を設定します。
setExportHeader(ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理ヘッダを設定します｡
setExportImportProcedure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易の輸出入手続を設定します。
setExportItemList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理明細を設定します｡
setExportNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
貿易データ番号: MM/SD 伝票を設定します。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票に登録された情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl の static メソッド
G/L 勘定明細にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable の static メソッド
仕入先明細にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax の static メソッド
税明細にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount の static メソッド
明細通貨項目にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 の static メソッド
カスタマ拡張テーブルにエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel の static メソッド
旅費資金予算明細にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount の static メソッド
旅費資金計画通貨項目にエクスポートされた値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
センタグループ情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードの詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードの詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
為替換算レート情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
内部指図書詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
内部指図書（一覧）情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
登録された情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の static メソッド
全バージョンに値をセットします。
setExportParam(BapiController, ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の static メソッド
貿易管理ヘッダに値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の static メソッド
拡張得意先項目に値をセットします。
setExportParam(BapiController, PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の static メソッド
伝票ヘッダに値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents の static メソッド
コンポーネントにエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation の static メソッド
転送構造：照会／一覧情報にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory の static メソッド
購買発注履歴情報にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals の static メソッド
購買発注履歴(合計)情報にエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping の static メソッド
出荷データにエクスポートされた値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp の static メソッド
出荷データ（エクスポート）にエクスポートされた値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のメソッド
伝票に登録された情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
実行結果を取得します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の static メソッド
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の static メソッド
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の static メソッド
table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin の static メソッド
table(Export)情報から返却されたReference Structure値をセットします。
setExportParam(BapiController, GoodsMvtHeadret) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の static メソッド
入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の static メソッド
table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の static メソッド
table(Export)情報からシリアル番号の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData の static メソッド
table(Export)情報から返却された値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
返却された入出庫伝票照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の static メソッド
table(Export)情報からロットの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の static メソッド
table(Export)情報から品目コードの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の static メソッド
table(Export)情報から移動タイプの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の static メソッド
table(Export)情報からプラントの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の static メソッド
table(Export)情報から登録日付の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の static メソッド
table(Export)情報から特殊在庫区分の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の static メソッド
table(Export)情報から保管場所の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の static メソッド
table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の static メソッド
table(Export)情報からユーザ名の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の static メソッド
table(Export)情報から仕入先の範囲の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
取得した品目在庫確認情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の static メソッド
table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の static メソッド
table(Export)情報から入力テーブル (日付/数量)の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
返却された品目マスタ照会情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタに登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の static メソッド
table(Export)情報から品目データ (クライアントレベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の static メソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の static メソッド
実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の static メソッド
table(Export)情報から需要予測パラメータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の static メソッド
table(Export)情報から需要予測値のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の static メソッド
table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の static メソッド
table(Export)情報から国際商品コード (EAN)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の static メソッド
table(Export)情報から品目テキストを設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の static メソッド
table(Export)情報からテキスト (長)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の static メソッド
table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の static メソッド
table(Export)情報から品目データ (プラントレベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の static メソッド
table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の static メソッド
品目マスタ更新結果をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の static メソッド
table(Export)情報から販売データの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の static メソッド
table(Export)情報から品目データ (保管場所レベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の static メソッド
table(Export)情報から保管域タイプデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の static メソッド
table(Export)情報から制御データを設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の static メソッド
table(Export)情報から品目総消費量のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の static メソッド
table(Export)情報から数量単位を設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の static メソッド
table(Export)情報から計画外消費のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の static メソッド
table(Export)情報から評価データの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の static メソッド
table(Export)情報から倉庫番号データを設定します。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の static メソッド
table(Export)情報から処理予定明細データのテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の static メソッド
table(Export)情報から理予定支払方法のテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の static メソッド
table(Export)情報から処理予定条件のテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の static メソッド
table(Export)情報から前明細の不正処理に関する情報の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の static メソッド
table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
返却された請求伝票詳細照会情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
取得した請求伝票一覧照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の static メソッド
table(Export)情報から請求伝票詳細の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の static メソッド
table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の static メソッド
table(Export)情報から選定: インスタンスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の static メソッド
table(Export)情報から選定: 部分設定の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の static メソッド
table(Export)情報から選定: 参照データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の static メソッド
table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の static メソッド
table(Export)情報から選定: 特性値の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の static メソッド
table(Export)情報から条件の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の static メソッド
table(Export)情報から受注における条件更新の通信項目の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の static メソッド
table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の static メソッド
table(Export)情報から明細データチェックボックスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の static メソッド
table(Export)情報から参照キーの出力テーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の static メソッド
table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の static メソッド
table(Export)情報から伝票取引先の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の static メソッド
table(Export)情報から納入日程行チェックボックスの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の static メソッド
table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の static メソッド
table(Export)情報からテキストの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票に登録する値ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の static メソッド
table(Export)情報からクレジットカードデータの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
見積伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の static メソッド
table(Export)情報から得意先受注テーブル情報の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
返却された販売伝票一覧照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の static メソッド
table(Export)情報からステータス情報の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
返却された販売伝票ステータス一覧照会情報をセットします。
setExpostPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
事後的需要予測に含む履歴値の数を設定します。
setExpostVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
事後的需要予測値を設定します。
setExrateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (直接相場)を設定します。
setExrateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExtDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認の外部伝票番号を設定します。
setExtDocLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を設定します。
setExtLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
明細番号を設定します。
setExtOrdNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
外部指図番号を設定します。
setExtServ(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
仕入先のサービス番号を設定します。
setExtWms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
外部倉庫管理の転記の制御を設定します。
setExtension1List(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
カスタマ拡張テーブル一覧を設定します｡
setExtensionInList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
EXTENSIONIN一覧を設定します｡
setExtensionInList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
EXTENSIONIN一覧を設定します｡
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInXList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
拡張イン/拡張アウトのチェックボックス構造を設定します。
setExtensionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
拡張得意先項目を設定します｡
setExtensionOutList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
EXTENSIONOUT一覧を設定します｡
setExtensionOutList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
EXTENSIONOUT一覧を設定します｡
setExtensionOutList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
setExtensioninList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
Reference Structureを設定します。
setExternalObjectId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 外部対象キーを設定します。
setExtmatlgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
外部品目グループを設定します。
setExtpersNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
外部従業員番号を設定します。
setExtrefkey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスの外部参照キーを設定します。
setFactbasval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値に対する要因を設定します。
setFactbasval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値に対する要因を設定します。
setFactconbas(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基準の係数 (期間)を設定します。
setFactor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件の加重係数を設定します。
setFactoryCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
稼働日カレンダを設定します。
setFairShareRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
均等配賦ルールを設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: 内線を設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: 内線を設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: 内線を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
FAX 番号を設定します。
setField(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの項目を設定します。
setField1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を設定します｡
setField2(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を設定します｡
setField3(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を設定します｡
setField4(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
文字項目長 250を設定します｡
setFieldname(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
項目名を設定します。
setFijCurCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期標準原価見積の会計年度を設定します。
setFijFutCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積の会計年度を設定します。
setFijPreCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準原価見積の会計年度を設定します。
setFillLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最大レベル (容積別)を設定します。
setFinalInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書処理完了区分を設定します。
setFinish(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトの計画終了日を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
値参照期間の第一日目を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
値参照期間の第一日目を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
値参照期間の第一日目を設定します。
setFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計期間を設定します｡
setFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間を設定します｡
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度を設定します｡
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度を設定します｡
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当会計年度を設定します。
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当会計年度を設定します。
setFixLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要供給の一致に対する固定ロットサイズを設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日日付を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日日付を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixdatQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
納期と出荷数量の固定を設定します。
setFixdatQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixedLot(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定ロットサイズを設定します。
setFixedMilestoneDateBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン日付(基準)を設定します。
setFixedMilestoneDateForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定日付を設定します。
setFixedMilestoneTimeBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン時間(基準)を設定します。
setFixedMilestoneTimeForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定時間 (F)を設定します。
setFixedPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
固定期間を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
数量固定を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量固定区分を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
長さ 12 の文字項目を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
長さ 12 の文字項目を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFlagCadCall(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
CAD システムからコールを設定します。
setFlagOnline(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
No ALE Field Selectionを設定します。
setFlexibleDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: 可変期間を設定します。
setFloatFree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕を設定します。
setFloatFreeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕 (予測)を設定します。
setFloatTotal(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計を設定します。
setFloatTotalFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計 (予測)を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物の階を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物の階を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物の階を設定します。
setFmTransDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
FM 取引日付を設定します｡
setFollowUp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
デフォルト後続アクティビティコードを設定します。
setFollowUp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
デフォルト後続アクティビティコードを設定します。
setFollowUp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
フォローアップ品目を設定します。
setFollowUpExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。
setFollowUpGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。
setFollowUpVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。
setForeDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最終需要予測日を設定します。
setForeModel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測モデルを設定します。
setForePds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測期間を設定します。
setForeProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測プロファイルを設定します。
setForeValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
予測値を設定します。
setForecFlowCont(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測フロー管理を設定します。
setForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日を設定します。
setForecastParameters(ForecastParameters) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
予測パラメータを設定します。
setForecastParametersList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測パラメータを設定します。
setForecastValuesList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測値のデータ転送を設定します。
setForecastView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要予測ビューを設定します。
setForecastView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
需要予測ビューを設定します。
setFormVal1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
タグ列を設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
敬称テキストを設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
敬称テキストを設定します。
setFormula(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式番号を設定します。
setFormulaTotQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の合計数量の計算式を設定します。
setFormulaTotQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の合計数量の計算式を設定します。
setFormulaTotQtyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
合計数量の計算式は変更できませんを設定します。
setFormulaTotQtyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
合計数量の計算式は変更できませんを設定します。
setFormulaTotUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の総用途値の計算式を設定します。
setFormulaTotUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の総用途値の計算式を設定します。
setFormulaTotUsageNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
すべての用途値を計算する計算式は変更できませんを設定します。
setFormulaTotUsageNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
すべての用途値を計算する計算式は変更できませんを設定します。
setFreeItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
無償明細を設定します。
setFreeLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
自由制限を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前通貨を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算前通貨を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算前通貨を設定します。
setFromFactor(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を設定します。
setFromFactorV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を設定します。
setFromLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
下限を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
機能領域を設定します｡
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
機能領域を設定します｡
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
機能を設定します。
setFunctionalLocation(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能場所を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ファンドを設定します｡
setFund(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ファンドを設定します｡
setFund(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
ファンドを設定します｡
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
会計区分を設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
予算センタを設定します｡
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
予算センタを設定します｡
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
予算センタを設定します。
setFundsRes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算執行伝票の伝票番号を設定します。
setFuturePr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
次期標準原価を設定します。
setFwdCons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 前方を設定します。
setFwdagent(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
海貨業者を設定します。
setFxdPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定価格連産品を設定します。
setFyVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
会計年度バリアントを設定します。
setFyVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計年度バリアントを設定します。
setGammaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ガンマ係数使用の平滑化のための季節指数を設定します。
setGdsRelevant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分:グローバルデータ同期関連を設定します。
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
一般データ情報を設定します｡
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫日付を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫日付を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出庫日付を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫時刻 (現地時間 - プラント参照)を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫時刻 (現地時間 - プラント参照)を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGlAccList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧（GlAccインスタンスの配列）を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定コードを設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
G/L 勘定コードを設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
G/L 勘定コードを設定します。
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
G/L 勘定コードを設定します。
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
G/L 勘定コードを設定します。
setGlAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細のソートキーに値を設定します。
setGlBusArea(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の事業領域に値を設定します。
setGlCompCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の会社コードに値を設定します。
setGlCostcenter(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の原価センタに値を設定します。
setGlDocType(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の伝票タイプに値を設定します。
setGlFiscYear(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の会計年度に値を設定します。
setGlGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の総勘定元帳勘定に値を設定します。
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
レコード番号を設定します｡
setGlItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の明細テキストに値を設定します。
setGlItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の会計伝票明細番号に値を設定します。
setGlList(GlAccList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を設定します｡
setGlOrderid(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の指図番号に値を設定します。
setGlPstngDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の伝票の転記日付に値を設定します。
setGlRefKey1(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の取引先参照キーに値を設定します。
setGlTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細の消費税コードに値を設定します。
setGlWbsElement(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
G/L 勘定明細のWBS 要素に値を設定します。
setGmCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
BAPI 在庫移動トランザクションのコード割当を設定します。
setGoodsMvtCode(GoodsMvtCode) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動に対するコードのトランザクションへの割当を設定します。
setGoodsMvtHeader(GoodsMvtHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票ヘッダデータを設定します。
setGoodsMvtHeaderList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票ヘッダを設定します。
setGoodsMvtHeadret(GoodsMvtHeadret) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号/入出庫伝票会計年度を設定します。
setGoodsMvtItemList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票明細を設定します。
setGoodsMvtItemsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票明細を設定します。
setGoodsMvtRefEwm(GoodsMvtRefEwm) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
BAdI 通信構造: 入出庫伝票 EWM 照会を設定します。
setGoodsMvtSerialNumberList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
シリアル番号を設定します。
setGoodsMvtServPartDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
ServPartDataを設定します。
setGrBasediv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫基準の請求書照合区分を設定します。
setGrEndDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
入庫終了日付を設定します。
setGrEndTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
入庫終了時刻 (ローカル、プラントに関連)を設定します。
setGrGiSlipNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票番号を設定します。
setGrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫区分を設定します。
setGrMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
入庫メッセージ区分を設定します｡
setGrNonVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
非評価入庫を設定します。
setGrNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫番号を設定します。
setGrPrTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫処理日数を設定します。
setGrPrTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
入庫処理日数を設定します。
setGrPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基準額を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
受領者を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受領者を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受領者を設定します。
setGrRcptx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGrToDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
納入最終期限を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
補助金を設定します｡
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
補助金を設定します｡
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
補助金を設定します｡
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
補助金を設定します。
setGroValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
総額を設定します。
setGrossWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総重量を設定します。
setGrossWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGrossWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
総重量を設定します。
setGrossWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
総重量を設定します。
setGroupcond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
グループ条件区分を設定します。
setGroupcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
グループ条件区分を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
グループ名を設定します。
setGrpKey1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 1を設定します。
setGrpKey1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 1を設定します。
setGrpKey2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 2を設定します。
setGrpKey2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 2を設定します。
setGrpReqmts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 所要量グループ化を設定します。
setGtinVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
グローバルトレード明細番号バリアントを設定します。
setGtinVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
グローバルトレード明細番号バリアントを設定します。
setGtsScrapNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
廃棄処理の税関参照番号を設定します。
setGtsStockType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
GTS在庫タイプを設定します。
setHCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通貨コードを設定します。
setHCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setHCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO 通貨コードを設定します。
setHandlgGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ワークロード計算のロジスティクス処理グループを設定します。
setHazMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物コードを設定します。
setHazMatNoExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
setHazMatNoGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
setHazMatNoVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
setHazmatprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物インジケータプロファイルを設定します。
setHeadDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
管理情報設定ヘッダセグメントを設定します。
setHeaderTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
ヘッダテキスト一覧を設定します｡
setHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストを設定します｡
setHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票ヘッダテキストを設定します。
setHeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
高さを設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
BOM 構成の上位レベル明細を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setHiLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上位階層明細番号を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層ノード一覧（HierarchyNodesインスタンスの配列）を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層ノード一覧（HierarchyNodesインスタンスの配列）を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層ノード一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層値一覧（HierarchyValuesインスタンスの配列）を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層値一覧（HierarchyValuesインスタンスの配列）を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層値一覧を設定します。
setHierlevel(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層のエントリレベルを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを設定します。
setHighVisc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 高粘性を設定します。
setHistType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
購買発注履歴カテゴリを設定します。
setHistVals(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
履歴値の数を設定します。
setHlItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買伝票中の上位明細を設定します。
setHold(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買発注の不完全を設定します。
setHomeCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村 (郵便用市区町村と異なる場合)を設定します。
setHomecityno(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
別の市区町村 (市区町村/地名ファイル)を設定します。
setHomepage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
URI 例: ホームページ、FTP アドレスを設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地-号を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地-号を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地-号を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地補足を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地補足を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地補足を設定します。
setHouseNo3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地範囲を設定します。
setHuNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
外部荷役単位 IDを設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージクラスを設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージクラスを設定します。
setImpCostcenterList(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
BAPI パラメータ 原価センタ からインポート情報を設定します。
setImpExtensionIn(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
BAPI パラメータ EXTENSIONIN の参照構造からインポート情報を 設定します。
setImpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
BAPI パラメータ EXTENSIONOUT の参照構造からインポート情報を 設定します。
setImpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
setImpInternationArticleNumbers(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANからインポート情報を設定します。
setImpMaterialDescription(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストからインポート情報を設定します。
setImpMaterialText(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長) からインポート情報を設定します。
setImpTaxClassifications(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御データからインポート情報を設定します。
setImpUnitSofmeasure(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位からインポート情報を設定します。
setImpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を必要とする WBS 要素を設定します。
setImpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を必要とする WBS 要素を設定します。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
伝票に登録する値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を取得する条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl の static メソッド
G/L 勘定明細にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable の static メソッド
仕入先明細にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax の static メソッド
税明細にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount の static メソッド
明細通貨項目にインポートする値をセットします。
setImportParam(BapiController, DocumentHeader) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader の static メソッド
伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 の static メソッド
カスタマ拡張テーブルにインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel の static メソッド
旅費資金予算明細にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount の static メソッド
旅費資金計画通貨項目にインポートする値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
センタグループを検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
為替換算レート情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
内部指図書詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
内部指図書（一覧）情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WEBの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードを検索する条件ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の static メソッド
条件ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の static メソッド
条件明細に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の static メソッド
外注基本契約制限に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の static メソッド
外注サービスに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の static メソッド
外注サービス勘定設定に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の static メソッド
外注サービステキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の static メソッド
入荷伝票アドレスヘッダに値をセットします。
setImportParam(BapiController, ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の static メソッド
貿易管理ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の static メソッド
貿易管理明細に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の static メソッド
拡張得意先項目に値をセットします。
setImportParam(BapiController, PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の static メソッド
伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の static メソッド
ヘッダテキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の static メソッド
明細テキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の static メソッド
外注制限に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の static メソッド
得意先に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の static メソッド
入出庫予定ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の static メソッド
勘定設定に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents の static メソッド
コンポーネントにインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation の static メソッド
転送構造：照会／一覧情報にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory の static メソッド
購買発注履歴情報にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals の static メソッド
購買発注履歴(合計)情報にインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の static メソッド
納入日程に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping の static メソッド
出荷データにインポートする値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp の static メソッド
出荷データ（エクスポート）にインポートする値をセットします。
setImportParam(BapiController, Versions) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の static メソッド
バージョン管理に値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票に登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のメソッド
伝票に登録する値をセットします。
setImportParam(BapiController, GoodsMvtHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の static メソッド
入出庫伝票ヘッダデータに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の static メソッド
リターン構造、入出庫伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の static メソッド
リターン構造、入出庫伝票明細に値をセットします。
setImportParam(BapiController, MaterialEvg) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg の static メソッド
品目コード(長)をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin の static メソッド
Reference Structureの値をセットします。
setImportParam(BapiController, GoodsMvtCode) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の static メソッド
在庫移動に対するコードのトランザクションへの割当の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の static メソッド
リターン構造、入出庫伝票明細の値をセットします。
setImportParam(BapiController, GoodsMvtRefEwm) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm の static メソッド
BAdI 通信構造: 入出庫伝票 EWMの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の static メソッド
シリアル番号の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData の static メソッド
値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
入出庫伝票一覧照会する情報をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の static メソッド
ロットの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の static メソッド
品目コードの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の static メソッド
移動タイプの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の static メソッド
プラントの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の static メソッド
登録日付の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の static メソッド
特殊在庫区分の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の static メソッド
保管場所の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の static メソッド
ParamTrEvTypeRaの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の static メソッド
ユーザ名の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の static メソッド
仕入先の範囲の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目在庫確認情報を取得する為の条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の static メソッド
出力テーブル (日付および ATP 数量)の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の static メソッド
入力テーブル (日付/数量)の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ照会条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタに登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の static メソッド
処理予定明細データのテーブルの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の static メソッド
処理予定支払方法のテーブルの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の static メソッド
処理予定条件のテーブルの値をセットします。
setImportParam(BapiController, CreatorDataIn) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の static メソッド
取り込まれる日付の順序の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の static メソッド
前明細の不正処理に関する情報の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の static メソッド
請求インタフェースの通信構造テキストの値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
setImportParam(BapiController, RefDocRange) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の static メソッド
前伝票の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の static メソッド
請求伝票詳細に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の static メソッド
選定: BLOB 内部データ (SCE)に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の static メソッド
選定: インスタンスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の static メソッド
選定: 部分設定に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の static メソッド
選定: 参照データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の static メソッド
選定: 参照明細/インスタンスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の static メソッド
選定: 特性値に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の static メソッド
選定: バリアント条件キーに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の static メソッド
条件に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の static メソッド
受注における条件更新の通信項目に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の static メソッド
VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
setImportParam(BapiController, HeaderIn, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の static メソッド
販売伝票ヘッダデータに値をセットします。
setImportParam(BapiController, HeaderInX, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の static メソッド
ヘッダデータチェックボックスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の static メソッド
明細データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の static メソッド
明細データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の static メソッド
参照キーの出力テーブルに値をセットします。
setImportParam(BapiController, LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の static メソッド
内部制御パラメータに値をセットします。
setImportParam(BapiController, MaterialEvg) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg の static メソッド
品目コード(長)をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の static メソッド
アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の static メソッド
伝票取引先に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の static メソッド
納入日程行に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の static メソッド
納入日程行チェックボックスに値をセットします。
setImportParam(BapiController, Sender) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の static メソッド
論理システム - 送信者に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の static メソッド
後続請求伝票の明細テーブルに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の static メソッド
テキストに値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票に登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の static メソッド
クレジットカードデータに値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
見積伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の static メソッド
得意先受注テーブル情報の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売伝票一覧の検索条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の static メソッド
ステータス情報の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売伝票ステータス一覧の検索条件をセットします。
setInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を設定します｡
setInChargeUser(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタの責任ユーザを設定します｡
setInChargeUser(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
CO 内部指図の責任者を設定します。
setInHouse(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
内部生産を設定します。
setInHouse(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
内部生産を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ1を設定します｡
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ2を設定します｡
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (2)を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIndPostToInspStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質検査中在庫への転記を設定します。
setIndProposeQuanx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
提案数量 (初期数量)を設定します。
setIndSector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
産業コードを設定します。
setIndSector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
産業コードを設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード番号を設定します｡
setIndus3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目 CFOP カテゴリを設定します。
setInfIndex(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数を設定します。
setInfoRec(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買情報番号を設定します。
setInfoRec(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買情報番号を設定します。
setInfoUpd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買情報更新区分を設定します。
setInform(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
情報行を設定します。
setInhseprodt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
内製日数を設定します。
setInitPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化で使用する履歴値の数を設定します。
setInitialize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化区分を設定します。
setInpfldcheck(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
項目無効時の応答を設定します。
setInquiryCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setInquiryCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: インスタンスを設定します。
setInquiryCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 部分設定を設定します。
setInquiryCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照明細/インスタンスを設定します。
setInquiryCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照データを設定します。
setInquiryCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 特性値を設定します。
setInquiryCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: バリアント条件キーを設定します。
setInquiryConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
条件を設定します。
setInquiryConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
受注における条件更新の通信項目を設定します。
setInquiryHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票ヘッダデータを設定します。
setInquiryHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
ヘッダデータチェックボックスを設定します。
setInquiryItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データを設定します。
setInquiryItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データチェックボックスを設定します。
setInquiryKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
参照キーの出力テーブルを設定します。
setInquiryPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
伝票取引先を設定します。
setInquirySchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行を設定します。
setInquirySchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行チェックボックスを設定します。
setInquiryTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テキストを設定します。
setInspInt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
次回再検査までの間隔を設定します。
setInspSetupFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目/プラントに QM 検査データ設定を設定します。
setInspoutGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
品質検査結果： EWM 設定の在庫 GUIDを設定します。
setInspoutGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
品質検査結果： EWM 設定の在庫 GUIDを設定します。
setInspoutGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
品質検査結果: EWM 設定の在庫 GUIDを設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細番号内部採番を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細番号内部採番を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細番号内部採番を設定します。
setIntObjNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
選定 (内部オブジェクト番号)を設定します。
setIntProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setIntProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setInterestProf(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setInternalChar(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
内部特性を設定します。
setInternalObjectId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 内部対象キーを設定します。
setInternationArticleNumbersList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANを設定します。
setInternationalArtnosList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
国際商品コード (EAN)を設定します。
setInterop(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
移動時間を設定します。
setInvCorrFac(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
在庫修正係数を設定します。
setInvMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
会社固有 (内部) 在庫管理品目コードを設定します。
setInvMatNoExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
setInvMatNoGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
setInvMatNoVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
setInvestProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備投資案件プロファイルを設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setInvoicePercentage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
請求金額率 (%)を設定します。
setIrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書受領区分を設定します。
setIsoLanguage(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
ISO639準拠の言語を設定します｡
setIsoUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
単位の ISO コードを設定します。
setIssStLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫保管場所を設定します。
setIssueUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫単位を設定します。
setIssueUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの出庫単位を設定します。
setItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始明細を設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の明細カテゴリを設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
一般明細カテゴリグループを設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目マスタの明細カテゴリグループを設定します。
setItemCatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票の明細カテゴリを設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
明細カテゴリ (販売伝票)を設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細カテゴリ (販売伝票)を設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setItemIntvl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
明細番号間隔を設定します｡
setItemNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setItemNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理オブジェクト: 明細を設定します。
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストを設定します｡
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストを設定します｡
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
明細テキストを設定します。
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
明細テキストを設定します。
setItemTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細テキスト一覧を設定します｡
setItemguidAtp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ATP: 暗号 - DELNR および DELPSを設定します。
setItemguidAtp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号を設定します｡
setItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号を設定します｡
setItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号コードを設定します｡
setItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号を設定します｡
setItemsForRelease(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
区分: 承認待ち購買発注のみ照会を設定します。
setItemsForRelease(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
区分: 承認待ち購買発注のみ照会を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
明細番号 (販売管理伝票)を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
明細番号 (販売管理伝票)を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票明細を設定します。
setItmTypeUsage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細用途を設定します。
setItmTypeUsage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIvQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
請求数量を設定します。
setIvQtyPo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
購買価格数量単位による請求数量を設定します。
setIvQtyTotal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
請求書受領数量: 絶対額を設定します。
setIvvalFor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
外貨での入力請求額を設定します。
setIvvalFor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外貨での入力済請求額を設定します。
setIvvalLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨での入力請求額を設定します。
setIvvalLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨での入力請求額を設定します。
setJitRelvt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: JIT 納入日程の関連明細を設定します。
setJointVenture(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャを設定します。
setJointVenture(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャを設定します。
setJvJibClass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE クラスを設定します。
setJvJibClass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE クラスを設定します。
setJvJibSubClassA(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE サブクラスAを設定します。
setJvJibSubClassA(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE サブクラスAを設定します。
setJvObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャ対象タイプを設定します。
setJvObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャ対象タイプを設定します。
setKanbanInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
かんばん区分を設定します。
setKblanguage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
システム設定の言語を設定します。
setKbname(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースオブジェクトを設定します。
setKbprofile(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースプロファイルを設定します。
setKbversion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
SCE ナレッジベースの実行時バージョンを設定します。
setKeepQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
EWM での廃棄処理の保持数量を設定します。
setLEquip1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1を設定します。
setLEquip2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2を設定します。
setLEquip3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3を設定します。
setLabelForm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベル書式を設定します。
setLabelType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベルタイプを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.financial.Language のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
言語キーを設定します。
setLanguCr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスレコード登録オリジナル言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.Language のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーの ISO コードを設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
言語キーの ISO コードを設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
ISO 639 準拠の言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
言語を設定します｡
setLanguage(Language) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
Language in which Texts are Read(言語情報)を設定します。
setLanguage(Language) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
Language in which Texts are Read(言語情報)を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ステータスおよび業務トランザクションテキストの言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ステータスおよび業務トランザクションテキストの言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
言語キーを設定します。
setLangucriso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を設定します。
setLastChnge(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最終変更日付を設定します。
setLastItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
最終明細番号を設定します。
setLatestDatesIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: 最遅日を設定します。
setLatestFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(日付)を設定します。
setLatestFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済終了日付(需要予測)を設定します。
setLatestFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(時間)を設定します。
setLatestFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画終了時間 (予測)を設定します。
setLatestStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(日付)を設定します。
setLatestStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始日付(需要予測)を設定します。
setLatestStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(時間)を設定します。
setLatestStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始時間(需要予測)を設定します。
setLeadinguom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
主要ロット特定数量単位を設定します。
setLeft(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setLength(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
長さを設定します。
setLeqUnit1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1 の数量単位を設定します。
setLeqUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 1 の数量単位を設定します。
setLeqUnit2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2 の数量単位を設定します。
setLeqUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 2 の数量単位を設定します。
setLeqUnit3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3 の数量単位を設定します。
setLeqUnit3Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 3 の数量単位を設定します。
setLiIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
レコード番号を設定します｡
setLifoFifo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO/FIFO 関連を設定します。
setLifoValuationData(LifoValuationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 関連品目データを設定します。
setLifoValuationLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価レベルを設定します。
setLifovaluationlevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 評価レベルを設定します。
setLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
全体制限を設定します。
setLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
全体制限を設定します。
setLimitLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画外、明細制限を設定します。
setLimitsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注制限一覧を設定します｡
setLineDepth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票での明細行階層レベルを設定します。
setLineDepth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票での明細行階層レベルを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票明細行の一意 IDを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票明細行の一意 IDを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
伝票明細行の一意 IDを設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限の内部明細番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
内部明細番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細行番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
内部明細番号を設定します。
setLineTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
納入日程の提案時刻 (現地時間: 販売組織参照)を設定します。
setLineTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載日付を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載日付を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載時刻 (現地時間: 出荷ポイント)を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載時刻 (現地時間: 出荷ポイント)を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadinggrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
積載グループを設定します。
setLoadinggrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
積載グループを設定します。
setLocActcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総所得税の活動コードを設定します。
setLocActcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLocCurr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨コードを設定します。
setLocCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨の ISO コードを設定します。
setLocDisttype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所得税の配賦タイプを設定します。
setLocDisttype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLocTaxcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税タイプを設定します。
setLocTaxcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLocTxrelclas(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税関連分類を設定します。
setLocTxrelclas(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLocZerovat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
locZerovatを 設定します。
setLocZerovat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
場所を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 5を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: メッセージシリアル番号を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: メッセージシリアル番号を設定します。
setLogNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: ログ番号を設定します。
setLogNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: ログ番号を設定します。
setLogSystem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
論理システムを設定します。
setLogSystemOwn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを設定します。
setLogSystemOwn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
内部制御パラメータを設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
内部制御パラメータを設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
内部制御パラメータを設定します。
setLogsys(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
EWM 入出庫伝票の論理システムを設定します。
setLogsystem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
論理システムを設定します｡
setLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を設定します｡
setLongnum(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
Long Procurement Document Numberを設定します。
setLooseorliq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バルク/液体を設定します。
setLotIncrement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるためのロットサイズ増分を設定します。
setLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ロットサイズを設定します。
setLotsizekey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロットサイズ (品目計画)を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを設定します。
setMainEan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
区分: 主要 EANを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
更新ステータスを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者製品コードを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品コードを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品コードを設定します。
setManufProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品プロファイルを設定します。
setManufProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品プロファイルを設定します。
setManufacturerPartNumbList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
製造業者と製造者製品コード一覧を設定します｡
setMaskId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 要素 ID(短)の選択マスクを設定します。
setMastCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
期間依存条件伝票を設定します。
setMastContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
グループマスタ契約番号を設定します。
setMastContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMasterData(MasterData) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図のマスタデータ構造を設定します。
setMasterData(MasterData) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図のマスタデータ構造を設定します。
setMasterDataInactive(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
マスタレコードの無効化を設定します。
setMasterDataInactive(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
マスタレコードの無効化を設定します。
setMatCfop(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目 CFOP カテゴリを設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票番号を設定します。
setMatEntrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入力品目を設定します。
setMatEntrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatEntrdExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MAT_ENTRD の品目コード (長)を設定します。
setMatEntrdExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatEntrdGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MAT_ENTRD の外部 GUIDを設定します。
setMatEntrdGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatEntrdVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MAT_ENTRD のバージョン番号を設定します。
setMatEntrdVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMatGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目グループを設定します。
setMatGrpSm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループ: 梱包材を設定します。
setMatGrpTrans(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取替えマトリクスに対する品目のグループを設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMatOrigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の原産地を設定します。
setMatOrigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の原産地を設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目価格設定グループを設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目価格設定グループを設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目更新完了ステータスを設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMatcmpllvl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目完了レベルを設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
入出庫伝票の明細を設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票の明細を設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
入出庫伝票の明細を設定します。
setMatdocTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求の入出庫伝票番号を設定します。
setMatdocumentyear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票会計年度を設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
品目コードを設定します｡
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
品目コードを設定します。
setMaterialDescriptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストを設定します。
setMaterialDescriptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目テキストを設定します。
setMaterialEvg(MaterialEvg) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コード(長)を設定します。
setMaterialEvg(MaterialEvg) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コード(長)を設定します。
setMaterialEvg(MaterialEvg) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コード(長)を設定します。
setMaterialExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
外部品目コードを設定します。
setMaterialExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
外部品目コードを設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コード（長）を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 MATERIAL の品目コード(長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
項目 MATERIAL の品目コード (長)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の品目コード (長)を設定します｡
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialFixed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロックされている品目を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードの外部GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 MATERIAL の外部GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
品目コード(外部 GUID)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
項目 MATERIAL の外部 GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の外部 GUIDを設定します｡
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
品目コード(外部 GUID)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialLongTextList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
テキスト (長)を設定します。
setMaterialRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
品目コードの範囲を設定します。
setMaterialShortDescselList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目テキストの選択オプション一覧を設定します。
setMaterialTextList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長)を設定します。
setMaterialVers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
品目バージョン番号を設定します。
setMaterialVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
品目バージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードのバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
項目 MATERIAL のバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL のバージョン番号を設定します｡
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialdocument(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号を設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目運賃グループを設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目運賃グループを設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatitemTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送数量入出庫伝票明細を設定します。
setMatlDesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目テキストを設定します。
setMatlDesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目テキストを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatlGrp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 1を設定します。
setMatlGrp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 2を設定します。
setMatlGrp3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 3を設定します。
setMatlGrp4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 4を設定します。
setMatlGrp5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 5を設定します。
setMatlStats(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目統計グループを設定します。
setMatlType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目タイプを設定します。
setMatlType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目タイプを設定します。
setMatlUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の用途を設定します。
setMatlUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の用途を設定します。
setMatnrHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
終了品目コードを設定します。
setMatnrListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードと品目テキスト一覧を設定します｡
setMatnrLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
開始品目コードを設定します。
setMatnrSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードの選択オプション一覧を設定します。
setMatyearTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求入出庫伝票年度を設定します。
setMaxLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最大ロットサイズを設定します。
setMaxPlDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細ごとの分割納入可能な最大回数を設定します。
setMaxPlDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxRows(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
選択予定品目の最大数を設定します。
setMaxSbQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最大棚番在庫数量を設定します。
setMaxStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大在庫レベルを設定します。
setMaxdevDay(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
シフト所要日数を設定します。
setMaxdevDay(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxdevamnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (絶対値)を設定します。
setMaxdevamnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxdevper(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (%)を設定します。
setMaxdevper(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxlotsize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大ロットサイズを設定します。
setMeAnzSub(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位数を設定します。
setMeanAbsolDev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
絶対平均偏差 (MAD)を設定します。
setMeanAbsolDevPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の平均絶対偏差を設定します。
setMemoryComplete(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがない場合に購買発注を保留する区分を設定します｡
setMemoryUnComplete(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがある場合に購買発注を保留する区分を設定します｡
setMerchidcl(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社のマーチャント IDを設定します。
setMerchidcl(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社のマーチャント IDを設定します。
setMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージテキストを設定します。
setMessage(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージテキストを設定します。
setMessageId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージ IDを設定します。
setMessageNumber(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
システムメッセージ番号を設定します。
setMessageText(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージのテキスト行を設定します。
setMessageType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージタイプを設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMethod(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メソッドを設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者番号を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者番号を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者番号を設定します。
setMfrNoExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
外部製造者コード名または番号を設定します。
setMilestone(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
用途を設定します。
setMilestoneNumber(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン番号を設定します。
setMilestoneUsage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン用途を設定します。
setMilitId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ID: 武器を設定します。
setMinDely(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
納品書処理時の最小納入数量を設定します。
setMinLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最小ロットサイズを設定します。
setMinMto(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
受注製造品最少受注数量を設定します。
setMinOrder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
基本数量単位での最小受注数量を設定します。
setMinSafetyStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小安全在庫を設定します。
setMinSbQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最小棚番在庫数量を設定します。
setMinlotsize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小ロットサイズを設定します。
setMinremlife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
最低有効期間残を設定します。
setMinremlife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最低有効期間残を設定します。
setMixedMrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
二重 MRP 区分を設定します。
setMlActive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目レベルで有効な品目元帳を設定します。
setMlSettle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目元帳決済: 管理を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
マニュアル請求書更新を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
マニュアル請求書更新を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setModelSi(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択区分を設定します。
setModelSp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択方式を設定します。
setMovPrPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期移動平均原価/期間平均原価を設定します。
setMovPrPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の移動平均原価/期間単価を設定します。
setMoveBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫ロットを設定します。
setMoveBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫ロットを設定します。
setMoveGtsStockType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
GTS在庫タイプを設定します。
setMoveMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫品目を設定します。
setMoveMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫品目を設定します。
setMoveMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setMoveMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setMoveMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
setMoveMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
setMoveMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setMoveMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setMovePlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫プラントを設定します。
setMovePlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫プラントを設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
移動理由を設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動理由を設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動理由を設定します。
setMoveStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫保管場所を設定します。
setMoveStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫保管場所を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
移動タイプ (在庫管理)を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動タイプ (在庫管理)を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動タイプ (在庫管理)を設定します。
setMoveTypeRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
移動タイプの範囲を設定します。
setMoveValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
転送ロットの評価タイプを設定します。
setMoveValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
転送ロットの評価タイプを設定します。
setMovingPr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
移動平均原価/期間単位価格を設定します。
setMrpAreaExists(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: MRP エリア登録済を設定します。
setMrpCtrler(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP 管理者を設定します。
setMrpGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP グループを設定します。
setMrpInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP 区分を設定します。
setMrpRelevancyDepRequirements(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
従属所要量と MRP の関連性を設定します。
setMrpType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP タイプを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目: MRP プロファイルを設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目利用可能日を設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目利用可能日を設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目供給ステージ (現地時刻: プラント参照)を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目供給ステージ (現地時刻: プラント参照)を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMsgToIm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
区分: 在庫管理への出力を設定します。
setMultRefM(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照品目の乗数を設定します。
setMvtInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動区分を設定します。
setMvtInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動区分を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
発注者名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
名称 1を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 2を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 2を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 2を設定します。
setName3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 3を設定します。
setName3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 3を設定します。
setName4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 4を設定します。
setName4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 4を設定します。
setName_2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 2を設定します。
setName_3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 3を設定します。
setName_4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 4を設定します。
setNbSlips(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫票の印刷部数を設定します。
setNbSlipsx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNegPostng(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
フラグ: マイナス転記を設定します｡
setNegPostng(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
フラグ: マイナス転記を設定します｡
setNegPostng(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
フラグ: マイナス転記を設定します｡
setNegPostng(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
フラグ: マイナス転記を設定します｡
setNegStocks(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントにおけるマイナス在庫許可を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
通貨額を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
正味価格を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
正味価格を設定します。
setNetValHd(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注正味額 (伝票通貨)を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買発注通貨による正味発注額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細の正味額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
正味金額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票通貨による正味額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票通貨での受注明細正味額を設定します。
setNetValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
勘定割当のネットワーク番号を設定します｡
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
勘定割当のネットワーク番号を設定します｡
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定割当のネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
勘定割当のネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
勘定割当のネットワーク番号を設定します。
setNetworkAssignment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ネットワーク割当を設定します。
setNetworkAssignment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワーク割当を設定します。
setNetworkProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワークプロファイルを設定します。
setNoAuthority(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
権限チェックなし区分に購買発注を保留する区分を設定します｡
setNoCommit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
コミットワーク はい/いいえを取得します。
setNoCosting(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算なしを設定します。
setNoDisct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
現金値引対象外明細を設定します。
setNoFrlimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを設定します。
setNoGrPost(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先が入庫を転記していませんを設定します。
setNoGrPost(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNoLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限なしを設定します。
setNoLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを設定します。
setNoMatmast(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目マスタ確認禁止を設定します。
setNoMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出力決定なし区分に購買発注を保留する区分を設定します｡
setNoMessageReq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
メッセージ不要区分を設定します｡
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
納入完了 区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
納入完了区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
納入完了 区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
納入完了 区分を設定します。
setNoPriceFromPo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
最終伝票からの価格転送なし区分を設定します｡
setNoPstChgnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 振替要求通知登録禁止を設定します。
setNoRollbackWork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
Override Rollback Workを設定します。
setNoRounding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注明細での非表示丸めを設定します。
setNoSheets(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書枚数 (文書管理システムによらない)を設定します。
setNoTransferReq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 転送要求未登録を設定します。
setNoappllog(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
アプリケーションログ書込なしを設定します。
setNochangedoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
変更伝票書込なしを設定します。
setNondItax(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setNostructure(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
チェックボックスを設定します。
setNotMrpApplicable(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。
setNotifNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通知番号を設定します。
setNotifNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ番号を設定します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ番号を設定します。
setNumberOfCapacities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
所要能力数を設定します。
setNumconvert(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分子を設定します。
setNumconvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分子を設定します。
setNumerator(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
基本数量単位への換算分子を設定します。
setObjId(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
参照伝票: 現在の IDを設定します｡
setObjId(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
参照伝票: 現在の IDを設定します｡
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
参照キーを設定します｡
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーを設定します｡
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
オブジェクトキーを設定します｡
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
オブジェクトキーを設定します｡
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象キーを設定します。
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象キーを設定します。
setObjKeyP(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)を設定します｡
setObjKeyR(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
取消: オブジェクトキー (AWREF_REV と AWORG_REV)を設定します｡
setObjPos(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
参照明細を設定します｡
setObjPos(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
参照明細を設定します｡
setObjPosP(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
前伝票: 参照明細を設定します｡
setObjSys(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
参照システムを設定します｡
setObjSys(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
元伝票の論理システムを設定します｡
setObjSys(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
元伝票の論理システムを設定します｡
setObjSys(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
元伝票の論理システムを設定します｡
setObjTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
言語依存対象テキストを設定します。
setObjTypP(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
前伝票: 参照処理を設定します｡
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
参照処理を設定します｡
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理を設定します｡
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
参照処理を設定します｡
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
参照処理を設定します｡
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象タイプを設定します。
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象タイプを設定します。
setObjectGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス用 TYPE_OF ステートメントの GUIDを設定します。
setObjectNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
対象番号を設定します。
setObjectNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
対象番号を設定します。
setObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
オブジェクトタイプを設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス (言語非依存)を設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
対象クラスを設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
対象クラスを設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス、言語依存を設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
オブジェクトクラス、言語依存を設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
オブジェクトクラス、言語依存を設定します。
setOffsetMilestoneDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン日付のオフセットを設定します。
setOffsetMilestoneDateUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーンのオフセットのための時間単位を設定します。
setOffsetMilestoneDateUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
単位の ISO コードを設定します。
setOffsetPercentage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
活動日に対するマイルストーンの百分率によるオフセットを設定します。
setOffsetStartEndIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: オフセット用の参照（開始/終了活動日）を設定します。
setOldMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
旧品目コードを設定します。
setOpenQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
未処理数量のある明細を設定します。
setOperationMeasureUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動単位を設定します。
setOperationMeasureUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setOptimLev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最適化レベルを設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOrdCosts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注原価 (BAPI インタフェース)を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注理由 (取引理由)を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注理由 (取引理由)を設定します。
setOrdbilltyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注関連請求伝票に対する提案請求伝票タイプを設定します。
setOrdcombIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注結合出荷区分を設定します。
setOrdcombIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrdcombind(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
受注結合区分を設定します。
setOrdcompIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
受注結合出荷区分を設定します。
setOrdcompIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (個別値、または下限値)を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (個別値、または下限値)を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図番号を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
指図番号を設定します。
setOrderCcardList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
クレジットカードデータを設定します。
setOrderCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setOrderCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: インスタンスを設定します。
setOrderCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 部分設定を設定します。
setOrderCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照明細/インスタンスを設定します。
setOrderCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照データを設定します。
setOrderCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 特性値を設定します。
setOrderCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: バリアント条件キーを設定します。
setOrderConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件を設定します。
setOrderConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件チェックボックスを設定します。
setOrderExternalNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (個別値、または下限値)を設定します。
setOrderExternalNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (個別値、または下限値)を設定します。
setOrderExternalNoTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (上限値)を設定します。
setOrderExternalNoTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (上限値)を設定します。
setOrderHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票ヘッダを設定します。
setOrderHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票チェックリストを設定します。
setOrderItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データを設定します。
setOrderItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データチェックボックスを設定します。
setOrderItno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図明細番号を設定します。
setOrderItno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図明細番号を設定します。
setOrderKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
参照キーの出力テーブルを設定します。
setOrderListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
選択指図一覧を設定します。
setOrderListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
選択指図一覧を設定します。
setOrderName(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
テキストを設定します。
setOrderName(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
テキストを設定します。
setOrderPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
伝票取引先を設定します。
setOrderProb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の受注可能性を設定します。
setOrderProb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrderReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注理由を設定します。
setOrderSchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データを設定します。
setOrderSchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データチェックボックスを設定します。
setOrderTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テキストを設定します。
setOrderTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (上限値)を設定します。
setOrderTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (上限値)を設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
販売伝票タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
販売伝票タイプを設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号を設定します｡
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
指図番号を設定します｡
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格単位を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注価格単位 (購買管理)を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注価格単位 (購買管理)を設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格のISOコードを設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setOrigAccept(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先構内での受領を設定します。
setOrigGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
発生源グループ (原価要素の下位区分)を設定します。
setOrigMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目発生源を設定します。
setOriginalBatchFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロット管理区分を設定します。
setOriginalBatchRefMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロットの参照品目を設定します。
setOriginalBatchRefMaterialE(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
オリジナルロット参照品目を設定します。
setOriginalBatchRefMaterialG(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
オリジナルロット参照品目を設定します。
setOriginalBatchRefMaterialV(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
オリジナルロット参照品目を設定します。
setOrigindoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始伝票を設定します。
setOrvaltype(String) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
購買発注額/受注額の金額タイプを設定します｡
setOurRef(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
社内参照番号を設定します｡
setOutlInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
区分: 出力行を設定します。
setOutlLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
グループの階層レベルを設定します。
setOutlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
アウトラインレベルを設定します。
setOverDlvTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
過剰納入許容範囲を設定します。
setOverTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
過剰納入許容範囲リミットを設定します。
setOverallprf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
指図変更管理の全体プロファイルを設定します。
setOverdlvtol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
過剰納入許容範囲を設定します。
setOverdlvtol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOverhdKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
間接費キーを設定します。
setOverhdKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOverheadGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算間接費グループを設定します。
setOverheadKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
間接費キーを設定します。
setOverheadKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
間接費キーを設定します。
setOvfTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
超過許容値を設定します。
setOvfUnlim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
契約外サービス制限なしを設定します。
setPMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setPMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
setPMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setPMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPaAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細のソートキーに値を設定します。
setPaBlineDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細の期日計算の支払基準日に値を設定します。
setPaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細の総勘定元帳勘定に値を設定します。
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
レコード番号を設定します｡
setPaItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細の明細テキストに値を設定します。
setPaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細の会計伝票明細番号に値を設定します。
setPaPymtMeth(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細の支払方法に値を設定します。
setPaVendorNo(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
仕入先明細の仕入先または債権者の勘定コードに値を設定します。
setPackVoUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容積単位 (許容梱包容積)を設定します。
setPackVoUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの容積単位 (許容梱包容積)を設定します。
setPackWtUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位 (許容梱包重量)を設定します。
setPackWtUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位 (許容梱包重量)を設定します。
setPageNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書ページ番号 (文書管理システムによらない)を設定します。
setPageformat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造メモのページ書式を設定します。
setParCompco(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済会社コードを設定します。
setParEff(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効性パラメータへの値割当/変更番号よりも優先を設定します。
setParallelQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
Quantity in Parallel Unit of Measureを設定します。
setParallelUom(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
Parallel Unit of Measureを設定します。
setParamOpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
パラメータ最適化用の区分を設定します。
setParameter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータ名を設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
1 レベル上位の行 IDを設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
1 レベル上位の行 IDを設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
取引先勘定コードを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
取引先勘定コードを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引先勘定コードを設定します。
setPartDeliv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
明細レベルでの分割納入 (在庫転送)を設定します。
setPartDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細レベルの分納納入を設定します。
setPartDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPartInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
一部請求区分を設定します。
setPartOfGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
インスタンス用 PART_OF ステートメントの GUIDを設定します。
setPartOfNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
Part_of 明細番号を設定します。
setPartPrctr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
パートナ利益センタを設定します｡
setPartPrctr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
パートナ利益センタを設定します｡
setPartnNumb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
得意先コード 1を設定します。
setPartnRole(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
取引先機能を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerFund(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
パートナファンドを設定します｡
setPartnerFund(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
パートナファンドを設定します｡
setPartnerGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
パートナ補助金を設定します｡
setPartnerGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
パートナ補助金を設定します｡
setPartnerList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
取引先一覧を設定します｡
setPartnerSegment(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
セグメントレポートのパートナセグメントを設定します｡
setPartnerSegment(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
セグメントレポートのパートナセグメントを設定します｡
setPartnerdesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語別取引先機能テキストを設定します。
setPayer(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払人を設定します。
setPaymentTerms(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払条件キーを設定します。
setPaytype(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払手段: 支払カード計画の明細分類を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
パッケージ番号を設定します。
setPcode1Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。
setPcode2Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。
setPcode3Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。
setPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を設定します｡
setPerCurCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
現行標準原価見積期間を設定します。
setPerFutCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積期間を設定します。
setPerPreCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前標準原価見積期間を設定します。
setPercentOfWork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業の比率 (%)を設定します。
setPercentage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定金額配賦のパーセントを設定します。
setPercentageOfCompletion(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗度 (%)を設定します。
setPeriodInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
期間区分を設定します。
setPeriodInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
期間区分を設定します。
setPeriodIndExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
有効期間期限日の期間区分を設定します。
setPeriodIndExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日の期間区分を設定します。
setPeriodProfileSafetyTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間の期間プロファイルを設定します。
setPersNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
従業員番号を設定します。
setPersistId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号 (固定)を設定します。
setPersistIdType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号タイプ (固定)を設定します。
setPersonInChargeFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
責任者（開始値）を設定します。
setPersonInChargeFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
責任者（開始値）を設定します。
setPersonInChargeTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
責任者（終了値）を設定します。
setPersonInChargeTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
責任者（終了値）を設定します。
setPersonInChargeUserFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
担当ユーザ（開始値）を設定します。
setPersonInChargeUserFrom(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
担当ユーザ（開始値）を設定します。
setPersonInChargeUserTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
担当ユーザ（終了値）を設定します。
setPersonInChargeUserTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
担当ユーザ（終了値）を設定します。
setPersonNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
従業員番号を設定します｡
setPersonResp(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者を設定します。
setPersonRespPhone(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者の電話番号を設定します。
setPickArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
ピッキングエリアを設定します。
setPickgArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
簡易倉庫管理のピッキングエリアを設定します。
setPlRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包方法が同じ品目の参照品目を設定します。
setPlRefMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT の品目コード(長)を設定します。
setPlRefMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT の外部GUIDを設定します。
setPlRefMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PL_REF_MAT のバージョン番号を設定します。
setPlTiFnce(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画タイムフェンスを設定します。
setPlacement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫受入に対する保管域タイプ検索区分を設定します。
setPlanBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト基準日付計画方法を設定します。
setPlanDel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
予定納入日数を設定します。
setPlanFcst(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト予測日付の計画方法を設定します。
setPlanProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
計画プロファイルを設定します。
setPlanSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行タイプ EDIを設定します。
setPlanSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlanStrgp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画方針グループを設定します。
setPlanlistcnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
グループカウンタを設定します。
setPlanlistgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストグループのキーを設定します。
setPlannedCost(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画原価を設定します。
setPlanningData(PlanningData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ/製品グループの変更伝票構造を設定します。
setPlanningDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ/製品グループの変更伝票構造を設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
プラントを設定します。
setPlantData(PlantData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (プラントレベル)を設定します。
setPlantDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (プラントレベル)を設定します。
setPlantHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 終了を設定します。
setPlantLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 開始を設定します。
setPlantRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
プラントの範囲を設定します。
setPlantSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
プラントの選択オプション一覧を設定します｡
setPldlvshdin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷計画に関する指示を設定します。
setPldlvshdin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPldlvstyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
MRP: 出荷計画タイプを設定します。
setPldlvstyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlnClose(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画終了日付を設定します。
setPlnCompletion(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画完了日を設定します。
setPlnLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画梱包明細行を設定します。
setPlnPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号供給元一覧を設定します。
setPlnRelease(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画リリース日付を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価を設定します。
setPlndprdate1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 1 の有効開始日を設定します。
setPlndprdate2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 2 の有効開始日を設定します。
setPlndprdate3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 3 の有効開始日を設定します。
setPlndprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 1を設定します。
setPlndprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 2を設定します。
setPlndprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 3を設定します。
setPlngCycle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画サイクルを設定します。
setPlngMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目を設定します。
setPlngMatlExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。
setPlngMatlGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。
setPlngMatlVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。
setPlngPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画プラントを設定します。
setPlordCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
アクション管理: 計画手配処理を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
支払条件キーを設定します｡
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払保証決定表を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払保証決定表を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtmthsupl(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法追加を設定します｡
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱住所を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱住所を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所を設定します。
setPoBoxReg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の地域 (国、都道府県、地域、...)を設定します。
setPoCtryiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注日付を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注日付を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程の購買発注日付を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買伝票の明細番号を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
元となる購買発注の明細番号を設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注タイプを設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注タイプを設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注タイプを設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注タイプを設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票番号を設定します｡
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買伝票番号に値を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注番号を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
購買発注価格単位での数量を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
数量 (購買発注価格単位)を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量 (購買発注価格単位)を設定します。
setPoPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格採用区分を設定します。
setPoRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
承認コードを設定します。
setPoRelInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
承認区分: 購買伝票を設定します。
setPoSupplem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注番号補足を設定します。
setPoSupplem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注単位を設定します。
setPoUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
発注単位を設定します。
setPoUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
ISOコードによる発注単位を設定します。
setPoUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードによる発注単位を設定します。
setPoWONo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
フラグ: 郵便私書箱 (番号なし)を設定します。
setPoboxCtry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の国指定を設定します。
setPobxCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱住所を設定します。
setPobxPcd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱番号を設定します。
setPointUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位を設定します。
setPointUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位の ISO コードを設定します。
setPoints(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベートポイント数を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoolnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO 評価でのプール番号を設定します。
setPoolnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価でのプール番号を設定します。
setPosex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部明細番号を設定します。
setPosex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部明細番号を設定します。
setPostDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの転記日付を設定します。
setPostDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの転記日付を設定します。
setPosting(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
Posting category:postを設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村の郵便番号を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村の郵便番号を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村の郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
郵便番号を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
郵便番号を設定します。
setPpSearch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
品目提案検索条件を設定します。
setPpSearch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPpcPlCal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PPC 計画カレンダを設定します。
setPrClosed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買依頼処理済を設定します。
setPrCtrlPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期間の原価管理区分を設定します。
setPrCtrlPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の原価管理区分を設定します。
setPrIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
レコード番号を設定します｡
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrRefMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PR_REF_MAT の品目コード(長)を設定します。
setPrRefMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setPrRefMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PR_REF_MAT の外部GUIDを設定します。
setPrRefMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
setPrRefMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 PR_REF_MAT のバージョン番号を設定します。
setPrRefMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setPrUname(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を設定します。
setPrUnitPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期価格単位を設定します。
setPrUnitPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度価格単位を設定します。
setPrcGroup1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 1を設定します。
setPrcGroup1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 2を設定します。
setPrcGroup2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 3を設定します。
setPrcGroup3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 4を設定します。
setPrcGroup4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 5を設定します。
setPrcGroup5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcStatH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票の全処理ステータスを設定します。
setPreAuth(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 事前承認を設定します。
setPreVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
製造元/販売元を設定します。
setPrefStatFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 特恵関税 - 輸出/輸入を設定します。
setPreqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼の明細番号を設定します。
setPreqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼の明細番号を設定します。
setPreqName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼者名/要求者名を設定します。
setPreqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼番号を設定します。
setPreqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼番号を設定します。
setPrevPlanPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を設定します。
setPrice(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
入力シートの価格変更を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力シートの価格変更を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setPriceCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価管理区分を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格グループ (得意先)を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格グループ (得意先)を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格表タイプを設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格表タイプを設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
価格単位を設定します。
setPricedate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日カテゴリ (価格設定日管理)を設定します。
setPricing(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
価格設定タイプを設定します。
setPrioRequirement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
所要量の優先順位を設定します。
setPrioUrgency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
所要量の緊急度を設定します。
setPriority(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
優先度を設定します。
setPriority(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
優先度を設定します。
setPrivAddr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
自宅住所を設定します。
setPrntPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格印刷を設定します。
setProcRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達規則を設定します。
setProcTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
処理時間を設定します。
setProcType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達タイプを設定します。
setProcedure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。
setProcessId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
購買発注履歴取引タイプを設定します。
setProcessingGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
処理グループを設定します。
setProcureUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量消費の数量単位を設定します。
setProcureUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの保管容量消費の数量単位を設定します。
setProdAlloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品割当決定手順を設定します。
setProdAtt1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ID: 製品属性 1を設定します。
setProdAtt10(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 10 用 IDを設定します。
setProdAtt2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 2 用 IDを設定します。
setProdAtt3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 3 用 IDを設定します。
setProdAtt4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 4 用 IDを設定します。
setProdAtt5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 5 用 IDを設定します。
setProdAtt6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 6 の IDを設定します。
setProdAtt7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 7 用 IDを設定します。
setProdAtt8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 8 用 IDを設定します。
setProdAtt9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 9を設定します。
setProdCompositionOnPackaging(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 梱包材にプリントされた生産構造を設定します。
setProdConvType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産値の変換タイプを設定します。
setProdDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット製造日付を設定します。
setProdDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット製造日付を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目階層を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目階層を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目階層を設定します。
setProdHiera(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目階層を設定します。
setProdHiera(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProdMemo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造/検査メモを設定します。
setProdUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位を設定します。
setProdUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位 (ISO コード)を設定します。
setProdcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品カタログ番号を設定します。
setProdcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProdcomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産統計: 貿易における PRODCOM コードを設定します。
setProdprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画プロファイルを設定します。
setProductionResourceToolData(ProductionResourceToolData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setProductionScheduler(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画担当を設定します。
setProdverscs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算を行う製造バージョンを設定します。
setProfitCentList(ProfitCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を設定します｡
setProfitCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧（ProfitCenterインスタンスの配列）を設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
利益センタを設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
利益センタを設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmentList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入出庫予定一覧を設定します｡
setProjType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクトタイプを設定します。
setProjectCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 通貨(プロジェクト定義)を設定します。
setProjectCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ISO 通貨コードを設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクト定義を識別するキーを設定します。
setProjectDefinition(ProjectDefinition) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクトについての詳細情報を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクト定義を識別するキーを設定します。
setProjectDefinition(ProjectDefinition) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクトについての詳細情報を設定します。
setProjectProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトプロファイルを設定します。
setProjectStock(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト在庫を設定します。
setProjectSummarization(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: プロジェクト集計用に活動を考慮を設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
プロモーションを設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プロモーションを設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrtDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setPrtUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途を設定します。
setPrtUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途を設定します。
setPrtView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産資源/治工具 (PRT) ビューを設定します。
setPrtView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
生産資源/治工具 (PRT) ビューを設定します。
setPsConfMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
選定可能品目を設定します。
setPsConfMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PS_CO 項目の(将来の開発用)品目コード(長)を設定します。
setPsConfMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PS_CONF_MAT 項目の外部 GUID (将来の開発用)を設定します。
setPsConfMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PS_CONF_MAT 項目のバージョン番号 (将来の開発用)を設定します。
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付を設定します｡
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付を設定します｡
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
伝票の転記日付を設定します｡
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票の転記日付を設定します。
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の転記日付を設定します。
setPstngDateRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
登録日付の範囲を設定します。
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買グループを設定します。
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買グループを設定します｡
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買グループを設定します。
setPurMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
品目コードを設定します。
setPurMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目コードを設定します。
setPurMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 PUR_MAT の品目コード (長)を設定します。
setPurMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。
setPurMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 PUR_MAT の外部 GUIDを設定します。
setPurMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。
setPurMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
項目 PUR_MAT のバージョン番号を設定します。
setPurMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。
setPurStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目ステータスを設定します。
setPurStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント特有品目ステータスを設定します。
setPurValkey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
購買許容値キーを設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注日付を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注日付を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
得意先発注番号を設定します。
setPurchNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を設定します｡
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の得意先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の得意先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchOrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先発注番号を設定します。
setPurchOrg(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買組織を設定します。
setPurchOrg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買組織を設定します｡
setPurchView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買管理ビューを設定します。
setPurchaseAccountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
勘定設定一覧を設定します｡
setPurchaseComponentsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
コンポーネント一覧を設定します｡
setPurchaseConfirmationList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
転送構造：照会／一覧一覧を設定します｡
setPurchaseHeadersList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票ヘッダ一覧（PurchaseHeadersインスタンスの配列）を設定します。
setPurchaseHeadersList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票ヘッダ一覧を設定します。
setPurchaseHistory(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注履歴を設定します｡
setPurchaseHistorysTotal(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注履歴(合計)を設定します｡
setPurchaseItemPostList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細一覧を設定します｡
setPurchaseItemsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票明細一覧（PurchaseItemsインスタンスの配列）を設定します。
setPurchaseItemsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票明細一覧を設定します。
setPurchaseOrder(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号を設定します。
setPurchaseOrderNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号1を設定します。
setPurchaseScheduleList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
納入日程一覧を設定します｡
setPurchaseShippingExpList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷データエクスポート一覧を設定します｡
setPurchaseShippingList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷データ一覧を設定します｡
setPurchaseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
購買管理ビューを設定します。
setPurchaseorder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
購買発注番号を設定します。
setPushDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: プッシュ配賦を設定します。
setPvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目のステータス有効開始日付を設定します。
setPvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント品目ステータス有効期間開始日を設定します。
setPymtAmt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払通貨額を設定します｡
setPymtCur(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
自動支払通貨を設定します｡
setPymtCurIso(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ISO コード通貨を設定します｡
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を設定します｡
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払方法を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払方法を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQmAuthgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
QM における活動の品目権限グループを設定します。
setQmProcmnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達における品質管理有効を設定します。
setQmRgmts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
仕入先の必須 QM システムを設定します。
setQtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積/引合有効開始日を設定します。
setQtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積の有効終了日を設定します。
setQtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQtyGrGi(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
数量: 印刷予定入出庫票数を設定します。
setQtyStruct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
数量構成により原価計算を行う品目を設定します。
setQualDik(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
無償納入による割引対象品目を設定します。
setQualInsp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
在庫タイプを設定します。
setQualityView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質管理ビューを設定します。
setQualityView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品質管理ビューを設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
数量を設定します｡
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
+/- 記号あり/なし数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
+/- 記号あり/なし数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
仕入先確認による数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
計画数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス数量を設定します。
setQuantityUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
数量単位を設定します。
setQuotDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積提出日を設定します｡
setQuotDead(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を設定します。
setQuotation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積番号を設定します｡
setQuotationCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setQuotationCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: インスタンスを設定します。
setQuotationCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 部分設定を設定します。
setQuotationCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照明細/インスタンスを設定します。
setQuotationCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照データを設定します。
setQuotationCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 特性値を設定します。
setQuotationCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: バリアント条件キーを設定します。
setQuotationConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
条件を設定します。
setQuotationConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
受注における条件更新の通信項目を設定します。
setQuotationHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダデータを設定します。
setQuotationHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダチェックボックスを設定します。
setQuotationItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データを設定します。
setQuotationItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データチェックボックスを設定します。
setQuotationKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
参照キーの出力テーブルを設定します。
setQuotationPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票取引先を設定します。
setQuotationSchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データを設定します。
setQuotationSchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データチェックボックスを設定します。
setQuotationTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テキストを設定します。
setQuotausage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給量割当の使用を設定します。
setRPromo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
プロモーションを設定します。
setRadrcheck1(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 住所チェックの結果 (住所結果)を設定します。
setRadrcheck2(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 住所チェックの結果 (住所承認)を設定します。
setRadrcheck3(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 住所チェックの結果 (郵便番号結果)を設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算レートタイプを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レートタイプを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レートタイプを設定します。
setRcardcheck(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カードチェックの結果 (返信コード)を設定します。
setRcvgVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
未使用項目を設定します。
setReaForRe(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
見積および受注の拒否理由を設定します｡
setReadAtpLock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
管理区分:利用可能在庫確認を設定します。
setReadAtpLockX(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更理由を設定します。
setReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更理由を設定します。
setReasonCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
取消理由を設定します。
setReasonCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
Goods Receipt Reason Codeを設定します。
setReasonCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Goods Receipt Reason Codeを設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積および受注の拒否理由を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見積および受注の拒否理由を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積および受注の拒否理由を設定します。
setReasonRev(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
反対仕訳理由を設定します｡
setRebateGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
取引量リベートグループを設定します。
setRecInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
リカバリフラグを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
入荷ポイントを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入荷ポイントを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRecTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
登録時刻を設定します。
setReceiptRel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
区分: 入庫関連の確認を設定します。
setRecoveryInd(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
リカバリフラグを設定します。
setRecoveryInd(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
リカバリフラグを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先/仕入先の内部参照コードを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先/仕入先の内部参照コードを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先文字を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先文字を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
決済の参照日付を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
決済の参照日付を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済の参照日付を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照伝票番号を設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocEwm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
EWM 入出庫伝票番号を設定します。
setRefDocHigh(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の終了伝票番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票の明細を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照明細番号を設定します。
setRefDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照明細番号を設定します。
setRefDocL(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を設定します。
setRefDocL(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocLLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。
setRefDocLow(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の開始伝票番号を設定します。
setRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号を設定します｡
setRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票番号を設定します。
setRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号を設定します。
setRefDocNoLong(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を設定します｡
setRefDocNoLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を設定します。
setRefDocNoLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を設定します。
setRefDocRange(RefDocRange) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
前伝票の範囲を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
参照伝票の会計年度を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の会計年度を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の会計年度を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票の明細を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照明細番号を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照明細番号を設定します。
setRefKey1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを設定します｡
setRefKey1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
取引先参照キーを設定します｡
setRefKey2(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを設定します｡
setRefKey2(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
取引先参照キーを設定します｡
setRefKey3(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細の参照キーを設定します｡
setRefKey3(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細の参照キーを設定します｡
setRefKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
参照キーは変更できませんを設定します。
setRefKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
参照キーは変更できませんを設定します。
setRefProc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照限定条件: 決定区分を設定します。
setRefProc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
基本数量単位による参照数量を設定します。
setRefUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目マスタレコードの数量単位初期値を設定します。
setRef_1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先/仕入先の内部参照コードを設定します｡
setRefdocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefdocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefdoctype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照オブジェクトの伝票タイプを設定します。
setReferencePoint(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
BOM 転送の参照ポイントを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
論理システムを設定します。
setRefmatcons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照品目を設定します。
setRefmatconsExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。
setRefmatconsGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。
setRefmatconsVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。
setRefobject(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクト名を設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトキーを設定します。
setRefobjtyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトタイプを設定します。
setRefpltcons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照プラントを設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域構造グループ化を設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地域構造グループ化を設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域構造グループ化を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地域 (都道府県)を設定します。
setRegionorig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産地 (非特恵対象地区の原産)を設定します。
setRegionorig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産地 (非特恵対象地区の原産)を設定します。
setRejReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積および受注の拒否理由を設定します。
setRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認コードを設定します。
setRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認コードを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認グループを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認グループを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認グループを設定します。
setRelInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認区分: 購買伝票を設定します。
setRelIndicatorNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認区分を設定します。
setRelStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
承認状況を設定します｡
setRelStatusNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認状況を設定します。
setRelStrat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認方針を設定します。
setRelType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
承認タイプを設定します。
setRelType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReleaseDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認日を設定します。
setReleaseTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認時刻を設定します。
setReleasebyPur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認購買担当者名を設定します。
setReleasedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認者名を設定します。
setReleasedatePur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認日付を設定します。
setReleasetimePur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認時刻を設定します。
setReminder1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第一回催促状/督促状の日数を設定します。
setReminder2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第二回催促状/督促状の日数を設定します。
setReminder3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第三回催促状/督促状の日数を設定します。
setReorderPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注点を設定します。
setReorderPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する発注点を設定します。
setRepManuf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 繰返生産許可を設定します。
setReplQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する補充数量を設定します。
setReplacePt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
取替部品を設定します。
setReplenQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
補充数量を設定します。
setReplentime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
補充リードタイム合計 (稼動日数)を設定します。
setRepmanprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
繰返生産プロファイルを設定します。
setReqBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更を依頼した従業員を設定します。
setReqBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更を依頼した従業員を設定します。
setReqByExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの外部変更番号を設定します。
setReqByExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの外部変更番号を設定します。
setReqClosed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼処理済を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
構成品目の所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
指定納期を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入日程日付を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
指定納入期日を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
指定納入期日を設定します。
setReqDlvBl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出荷ブロック中の納入日程行を設定します。
setReqDlvBl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
利用可能在庫確認の所要量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
累積受注数量 (販売単位)を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売単位による受注数量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
累積受注数量 (販売単位)を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積受注数量 (販売単位)を設定します。
setReqTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を設定します。
setReqTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqmtsTyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所要量タイプを設定します。
setReqmtsTyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRequCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コード要求を設定します。
setRequestCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請原価センタを設定します。
setRequestCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請原価センタを設定します。
setRequestCctrControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
依頼原価センタの管理領域を設定します。
setRequestCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コード要求を設定します。
setRequestOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請指図を設定します。
setResAnalKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
結果分析キーを設定します。
setResAnalKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
結果分析キーを設定します。
setResDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算の伝票番号を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算: 伝票明細を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
用途指定予算: 伝票明細を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setResType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコードタイプを設定します。
setResType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコードタイプを設定します。
setResanalkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
結果分析キーを設定します。
setResanalkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReservNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の番号を設定します。
setReservNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の番号を設定します。
setRespCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
責任原価センタを設定します。
setRespCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
責任原価センタを設定します。
setRespcctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任原価センタを設定します。
setResponsibleNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任者番号 (プロジェクト責任者)を設定します。
setResponsibleNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
責任者番号 (プロジェクト責任者)を設定します。
setRespsblCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタを設定します。
setRespsblCctrControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタの管理領域を設定します。
setRetAuthNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
返品権限番号を設定します。
setRetCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
リターン値、ABAP 命令後のリターン値を設定します。
setRetItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
返品明細を設定します。
setReturnMessagesList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
リターンパラメータ BAPIRET2 の代替構造を設定します。
setRevLev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
改訂レベルを設定します。
setRevType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
収益承認カテゴリを設定します。
setRevType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRfqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼明細番号を設定します。
setRfqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼番号を設定します。
setRight(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
不動産管理対象の内部キーを設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
不動産管理対象の内部キーを設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
不動産管理対象の内部キーを設定します。
setRnddlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
丸め数量: 出荷を設定します。
setRnddlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
部屋/アパート番号を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
部屋/アパート番号を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
部屋/アパート番号を設定します。
setRootId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
選定におけるインスタンス番号を設定します。
setRotationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを設定します。
setRoundProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
丸めプロファイルを設定します。
setRoundProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
丸めプロファイルを設定します。
setRoundQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
丸め数量を設定します。
setRoundUpRuleExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日計算の丸め規則を設定します。
setRoundVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買発注数量の丸め数量を設定します。
setRoundoffdi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
輸送経路を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
輸送経路を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
輸送経路を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRoutesched(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送経路計画を設定します。
setRow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの行を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
受注明細番号を設定します｡
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注明細番号を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注明細番号を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注明細番号を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
特別処理区分を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
特別処理区分を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSUnitDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷単位を設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
単位の ISO コードを設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードによる販売単位を設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードによる販売単位を設定します。
setSaIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
レコード番号を設定します｡
setSafetyStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全在庫を設定します。
setSafetytime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間 (稼動日数)を設定します。
setSaftyTId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間区分（安全リードタイムあり/なし)を設定します。
setSalStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスを設定します。
setSalStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売ビューからの品目ステータスを設定します。
setSalesData(SalesData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売データを設定します。
setSalesDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
販売データを設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売地域を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売地域を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesDocDateInidicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
販売伝票の日付に関連するマイルストーンを設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業グループを設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業グループを設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業所を設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業所を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
受注伝票番号を設定します｡
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注伝票番号を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注伝票番号を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注伝票番号を設定します。
setSalesOrdersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先受注テーブルを設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売組織を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売組織を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売組織を設定します。
setSalesOrganisationSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
販売組織の選択オプション一覧を設定します｡
setSalesOrganization(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売組織を設定します。
setSalesPers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先営業担当者を設定します｡
setSalesRelevant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
この部品は販売に関連していますを設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売単位を設定します。
setSalesUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードによる販売単位を設定します。
setSalesView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
販売ビューを設定します。
setSalesView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
販売ビューを設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売伝票番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
販売管理伝票番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
生成された伝票の番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売管理伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売管理伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
販売管理伝票番号を設定します。
setSalesorg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
販売組織を設定します。
setSalesorg(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売組織を設定します。
setSalesorgHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲終了を設定します。
setSalesorgLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲開始を設定します。
setSalesorganisation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売組織を設定します。
setSalqtyden(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位を SKU に換算するための分母 (除数)を設定します。
setSalqtyden(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalqtynum(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位から基本数量単位への変換係数の分子を設定します。
setSalqtynum(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setScIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
レコード番号を設定します｡
setScVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
外注仕入先を設定します。
setScalbasval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件のスケール基準値を設定します。
setScalbasval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件のスケール基準値を設定します。
setScalebasin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール基準区分を設定します。
setScalebasin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール基準区分を設定します。
setScaletype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケールタイプを設定します。
setScaletype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケールタイプを設定します。
setScbankInd(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
中央銀行コードを設定します｡
setSce(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CUX: 選定タイプを設定します。
setSchedInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
分納契約のリリース伝票区分を設定します。
setSchedLin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注納入日程を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注納入日程を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
納入日程行を設定します。
setSchedMilestoneDateBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(基準)を設定します。
setSchedMilestoneDateForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(予測)を設定します。
setSchedMilestoneTimeBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(基準)を設定します。
setSchedMilestoneTimeForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(予測)を設定します。
setSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程カテゴリを設定します。
setSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setScheduling(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
単一文字フラグを設定します。
setScrapIndicator(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
EWM 処理の廃棄区分を設定します。
setSdDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売管理伝票番号を設定します。
setSdDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票番号を設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売管理伝票カテゴリを設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票カテゴリを設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSdTaxcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
0を設定します。
setSdTaxcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSeasIndex(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
季節指数を設定します。
setSeason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
季節カテゴリを設定します。
setSeason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
季節カテゴリを設定します。
setSeasonPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
季節周期ごとの期間数を設定します。
setSeasonYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
シーズン年度を設定します。
setSegText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
セグメントテキストを設定します｡
setSegment(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
セグメントレポートのセグメントを設定します｡
setSegment(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
セグメントレポートのセグメントを設定します｡
setSelection(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選択 ID (永続)を設定します。
setSelection(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
論理システム - 送信者を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
論理システム - 送信者を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
論理システム - 送信者を設定します。
setSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
KANBAN/連続番号を設定します。
setSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
勘定設定の連続番号を設定します。
setSerializationLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
シリアル番号の指定レベルを設定します。
setSerialno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
シリアル番号を設定します。
setSerialnoAutoNumberassignment(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
シリアル番号の自動登録を設定します。
setSernoLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定コード設定のシリアル番号、サービス明細を設定します。
setSernoProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
シリアル番号プロファイルを設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setServLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サービスレベルを設定します。
setServType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのテキスト (短)を設定します。
setServType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのテキスト (短)を設定します。
setService(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
活動番号を設定します。
setSettItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベート (期末) 決済対象の明細を設定します。
setSetupTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷準備時間を設定します。
setSetuptime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取時間と片付け時間を設定します。
setShMatTyp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包材タイプを設定します。
setShelfLife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
総有効期間を設定します。
setShipBlocked(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
SD 出荷伝票の明細ブロックを設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
出荷条件を設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷条件を設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷条件を設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipProcTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷処理時間を設定します。
setShipTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先を設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷タイプを設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷タイプを設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
出荷指示を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示を設定します。
setShippingCountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 出荷国を設定します。
setShippingCountryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを設定します。
setShortId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素 ショート IDを設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を設定します｡
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
テキスト 1 (短)を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
テキスト(短)を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードテキスト（短）を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
テキスト (短): 受注明細を設定します。
setSiCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助明細カテゴリ、購買伝票を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSizeDim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
サイズ/寸法を設定します。
setSledBbd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期限を設定します。
setSlocExprc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
外部調達の初期保管場所を設定します。
setSmKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
日程計画余裕キーを設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
受注先を設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注先を設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注先を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 1を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 1を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 1を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 2を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 2を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 2を設定します。
setSourcelist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 供給元一覧必須を設定します。
setSpecMvmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の特殊移動区分を設定します。
setSpecMvmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
倉庫管理の特殊移動区分を設定します。
setSpecProc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの特殊調達タイプを設定します。
setSpecStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
特殊在庫区分を設定します。
setSpecStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
特殊在庫区分を設定します。
setSpecStockRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
特殊在庫区分の範囲を設定します。
setSpecprocty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算の特殊調達タイプを設定します。
setSplitInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
分割区分を設定します。
setSpproctype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
特殊調達タイプを設定します。
setSrcDlvNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
元出荷番号を設定します。
setSrcDlvNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
元出荷番号を設定します。
setSrcHandlgUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
元/先 荷役単位 (外部 ID)を設定します。
setSrcHandlgUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
元/先 荷役単位 (外部 ID)を設定します。
setSrcStockType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
在庫転送オーダーの元保管場所在庫タイプを設定します。
setSrvBasedIv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
サービス基準請求書照合の区分を設定します。
setSscExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの制限を設定します。
setSscItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ: 明細を設定します。
setSscLim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ制限参照のサービス行を設定します。
setSscLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの金額制限を設定します。
setSscNolim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
標準サービスタイプの制限なしを設定します。
setSscPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setSscPrschg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setStRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始参照日付は変更できませんを設定します。
setStRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始参照日付は変更できませんを設定します。
setStUnQtyy1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を設定します。
setStUnQtyy1Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setStUnQtyy2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を設定します。
setStUnQtyy2Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setStackFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
山積係数を設定します。
setStart(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト計画開始日付を設定します。
setStartOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用の開始オフセットを設定します。
setStartOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用の開始オフセットを設定します。
setStartOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始オフセットは変更できませんを設定します。
setStartOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始オフセットは変更できませんを設定します。
setStartOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始のオフセット単位を設定します。
setStartOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始のオフセット単位を設定します。
setStartOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
setStartOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
setStartRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始の参照日付を設定します。
setStartRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始の参照日付を設定します。
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
統計に適用する条件を設定します｡
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
統計に適用する条件を設定します。
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
統計に適用する条件を設定します。
setStatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
統計的納入期日を設定します。
setStatGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
統計グループを設定します。
setStatProf(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータスプロファイルを設定します。
setStatistical(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
統計 WBS 要素を設定します。
setStatistical(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
統計 WBS 要素を設定します。
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンステータスを設定します。
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ステータスを設定します｡
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
単一文字フラグを設定します。
setStatusDocOld(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
このバージョンの前の旧処理状況 (購買伝票内)を設定します。
setStatusInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
ステータス情報を設定します。
setStckType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
在庫タイプを設定します。
setStckType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫タイプを設定します。
setStdDescr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
標準テキスト (ANSI、ISO など)を設定します。
setStdMaterialGetIntNumberList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
品目コード割当済一覧を設定します｡
setStdPrPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準標準原価を設定します。
setStdPrPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度標準原価を設定します。
setStdPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
標準原価を設定します。
setStdTextKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の標準テキストキーを設定します。
setStdTextKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の標準テキストキーを設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
棚番を設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
棚番を設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
棚番を設定します。
setStgeBinPc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を設定します。
setStgeBinSt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
保管場所を設定します。
setStgeLocRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
保管場所の範囲を設定します。
setStgePdUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間の単位を設定します。
setStgePdUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの最長保管期間単位を設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管域タイプを設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
概略計画および詳細計画のピッキング保管域タイプを設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管域タイプを設定します。
setStgeTypePc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを設定します。
setStgeTypeSt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを設定します。
setStgeperiod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間を設定します。
setStgesector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管区画区分を設定します。
setStlmntPer(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
決済期間を設定します｡
setStlocHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
終了保管場所を設定します。
setStlocLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
開始保管場所を設定します。
setStockInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
特殊在庫区分を設定します。
setStorConds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
保管条件を設定します。
setStorCosts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管経費区分を設定します。
setStorPct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
残存有効期間割合 %を設定します。
setStorageLocationData(StorageLocationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (保管場所レベル)を設定します。
setStorageLocationDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (保管場所レベル)を設定します。
setStorageTypeData(StorageTypeData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプデータを設定します。
setStorageTypeDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
保管域タイプデータを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管ビューを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管ビューを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
保管ビューを設定します。
setStoragelocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管場所を設定します。
setStoragelocationselectList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
保管場所の選択オプション一覧を設定します｡
setStoragetype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプを設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
保管場所を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
保管場所を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
保管場所を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名の略称 (例: スペイン)を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名の略称 (例: スペイン)を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名の略称 (例: スペイン)を設定します。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
構造型の項目に値をセットします。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 2を設定します。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 2を設定します。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 2を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 3を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 3を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 3を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 4を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 4を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 4を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地名/番地-号を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地名/番地-号を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStructcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
構造条件を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します｡
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を設定します｡
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します。
setSuPlStck1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を設定します。
setSuPlStck2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産補助番号を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産補助番号を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産補助番号を設定します。
setSubUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
梱包階層の下位レベル数量単位を設定します。
setSubUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を設定します。
setSubitemint(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
副明細の明細間隔を設定します｡
setSubjToR(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認未完了を設定します。
setSubpckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サブパッケージ番号を設定します。
setSuccessList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
正常に処理された明細のテーブルを設定します。
setSuccessList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票の明細テーブルを設定します。
setSupSource(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
供給元を設定します。
setSupSource(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給元を設定します。
setSuppLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
補足明細を設定します。
setSuppVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
供給仕入先/仕入入庫を設定します。
setSupplPlnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
在庫転送オーダーにおける供給(出庫)プラントを設定します｡
setSupplStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出庫保管場所: 在庫転送オーダーを設定します。
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
供給仕入先を設定します｡
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
供給仕入先を設定します。
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
供給仕入先を設定します。
setSupplierInfo(VendorAddress) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
仕入先住所を設定します｡
setSupplyArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目マスタレコードで提案される供給場所を設定します。
setSvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスの有効開始日付を設定します。
setSyStDscr(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトステータスを設定します。
setSyStText(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を設定します。
setSysStatus(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
システムステータスを設定します。
setSystem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージが発行された論理システムを設定します。
setSystemStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
システムステータステーブルを設定します。
setSystemStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
システムステータステーブルを設定します。
setTUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量単位 (ISO コード)を設定します。
setTUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
税明細の総勘定元帳勘定に値を設定します。
setTaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を設定します｡
setTaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
税明細の会計伝票明細番号に値を設定します。
setTaTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
税明細の消費税コードに値を設定します。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の static メソッド
品目データ (クライアントレベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の static メソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の static メソッド
拡張イン/拡張アウトのチェックボックス構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の static メソッド
需要予測パラメータの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の static メソッド
需要予測値のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の static メソッド
管理情報設定ヘッダセグメントの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の static メソッド
国際商品コード (EAN)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の static メソッド
品目テキストの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の static メソッド
テキスト (長)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の static メソッド
品目マスタ/製品グループの変更伝票構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の static メソッド
品目データ (プラントレベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の static メソッド
品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の static メソッド
販売データの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の static メソッド
品目データ (保管場所レベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の static メソッド
保管域タイプデータの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の static メソッド
制御デ－タの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の static メソッド
品目総消費量のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の static メソッド
数量単位の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の static メソッド
計画外消費のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の static メソッド
評価データの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の static メソッド
倉庫番号データの値をセットします。
setTargetQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量（販売単位）を設定します。
setTargetQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTargetQu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量 (数量単位)を設定します。
setTargetQu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
目標値を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
累積計画金額を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaskListType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストタイプを設定します。
setTaxClass1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 2を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 3を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 4を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 5を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 6を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 7を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 8を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 9を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClassificationsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御デ－タを設定します。
setTaxClassificationsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
制御デ－タを設定します。
setTaxCmlUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法/商法にもとづく評価額価格単位を設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードを設定します｡
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードを設定します｡
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
売上税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
消費税コードを設定します。
setTaxCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
税会社コードを設定します｡
setTaxDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税率定義の日付を設定します｡
setTaxDepartCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税出荷国を設定します。
setTaxDestCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税仕向国を設定します。
setTaxInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税区分: 品目 (購買管理)を設定します。
setTaxRate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税率を設定します｡
setTaxType1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
税額を設定します。
setTaxValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を設定します。
setTaxValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を設定します。
setTaxcl1Mat(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の税分類を設定します。
setTaxclass1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxdepCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税出荷国を設定します。
setTaxdepCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxdstCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税仕向国を設定します。
setTaxdstCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
税管轄を設定します｡
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税管轄を設定します｡
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcodeDeep(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税管轄コード - 最下位レベル税管轄を設定します｡
setTaxjurcodeLevel(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
税管轄コードレベルを設定します｡
setTaxlawicms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: ICMSを設定します。
setTaxlawicms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxlawipi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: IPIを設定します。
setTaxlawipi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxlawiss(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISS Tax Lawを設定します。
setTaxprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 1を設定します。
setTaxprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 2を設定します。
setTaxprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 3を設定します。
setTaxrCntry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
納税申告書の国を設定します。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のメソッド
テーブル型の項目に値をセットします。
setTeIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
レコード番号を設定します｡
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第 1 電話番号: 内線を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第 1 電話番号: 内線を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第 1 電話番号: 内線を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTelebox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレボックス番号を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先電話番号を設定します｡
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
電話番号を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 1を設定します。
setTelephone2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 2を設定します。
setTeletexNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレテクス番号を設定します。
setTelexNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレックス番号を設定します。
setTempConds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
温度条件区分を設定します。
setTerminal(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 端末を設定します。
setTestRun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テスト区分を設定します｡
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動シミュレーションを設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
書込 BAPI のシミュレーションセッションへの切替を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
シミュレーション実行 ('X')、更新実行 (' ')を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テスト実行を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テスト実行を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テスト実行を設定します。
setTextDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求インタフェースの通信構造テキストを設定します。
setTextForm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
タグ列を設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト IDを設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト行を設定します。
setTextName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
名称を設定します。
setTextName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
名称を設定します。
setTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
時刻を設定します。
setTimeUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
時間計画単位を設定します。
setTimeUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
単位の ISO コードを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレスタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
出荷場所のタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレスタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスタイムゾーンを設定します。
setTimestamp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
取引開始時刻 (UTCタイムスタンプ)を設定します。
setTindex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
数値項目: 長さ 6を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
敬称を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
敬称を設定します。
setTmpExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスパッケージの制限を設定します。
setTmpLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細制限を設定します。
setTmpLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを設定します。
setTmpNolim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデル仕様の制限なしを設定します。
setTmpNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細セット番号を設定します。
setTmpPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを設定します。
setTmpPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setTmpPrschg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後通貨を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算後通貨を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算後通貨を設定します。
setToFactor(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を設定します。
setToFactorV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を設定します。
setToLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上限を設定します。
setTotalConsumptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目総消費量のデータ転送を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画日付を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画日付を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTrEvType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
トランザクション/イベントタイプを設定します。
setTrEvTypeRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
トランザクション/イベントタイプの範囲を設定します。
setTrIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
レコード番号を設定します｡
setTrPartBa(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先事業領域を設定します｡
setTrPartBa(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
取引先事業領域を設定します｡
setTrPartBa(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引会社事業領域を設定します。
setTraIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
レコード番号を設定します｡
setTrackingno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼追跡番号を設定します。
setTracklimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
警告限界を設定します。
setTradeId(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先の会社 IDを設定します｡
setTrans(String) - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
取引を設定します。
setTransGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
輸送グループを設定します。
setTransGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
輸送グループを設定します。
setTransactionGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
一文字フラグを設定します。
setTransportMode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
貿易管理の輸送モードを設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
商品の納入区域を設定します。
setTravelAmountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
旅費資金計画通貨項目一覧を設定します｡
setTravelList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
旅費資金予算明細一覧を設定します｡
setTrendAnalysisIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
傾向分析の関連マイルストーンを設定します。
setTrendValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
傾向値を設定します。
setTrendValuePp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の傾向値を設定します。
setTrgQtyNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を設定します。
setTrgQtyNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTrgqtyDen(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を設定します。
setTrgqtyDen(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTwoStepPick(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ツーステップピッキング適用品目を設定します。
setType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
setType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
setUnWork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業単位を設定します。
setUnWorkIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUnddlvTol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
不足納入許容範囲リミットを設定します。
setUnddlvTol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnderDlvTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
不足納入許容範囲リミットを設定します。
setUnderTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
不足納入許容範囲リミットを設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
発注単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
表示数量単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
表示数量単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
表示数量単位を設定します。
setUnitDim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
寸法単位 (長さ/幅/高さ)を設定します。
setUnitDimIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの長さ、幅、高さの単位を設定します。
setUnitGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
数量単位グループを設定します。
setUnitGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
数量単位グループを設定します。
setUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
ISO コードでの表示数量単位を設定します。
setUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
ISO コードでの表示数量単位を設定します。
setUnitOfWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位を設定します。
setUnitOfWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
重量単位を設定します。
setUnitOfWtIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位を設定します。
setUnitOfWtIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの重量単位を設定します。
setUnitSofmeasureList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位を設定します。
setUnitSofmeasureList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
数量単位を設定します。
setUnitmeasur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件スケール単位を設定します。
setUnitmeasur(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件スケール単位を設定します。
setUnitmeasurIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
単位の ISO コードを設定します。
setUnittype1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第１保管単位タイプを設定します。
setUnittype1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを設定します。
setUnittype2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第２保管単位タイプを設定します。
setUnittype2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを設定します。
setUnittype3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第３保管単位タイプを設定します。
setUnlimited(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlimitedDlv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlmtDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlmtDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
荷渡ポイントを設定します。
setUnloadPtx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnofWtiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの重量単位を設定します。
setUnplndConsumptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
計画外消費のデータ転送を設定します。
setUntilDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数日付を設定します。
setUntofWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
重量単位を設定します。
setUntofWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
単位の ISO コードを設定します。
setUomsortnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
数量単位ソート番号を設定します。
setUomusage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
使用数量単位を設定します。
setUp(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setUpdateGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
統計更新の更新グループを設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
更新区分を設定します。
setUsStDscr(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトステータスを設定します。
setUsStNumb(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータス番号を設定します。
setUsStText(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を設定します。
setUsageInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
未使用 - 予約長 3を設定します。
setUsageInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUseExceptions(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
例外メッセージ設定とエラーメッセージ出力を設定します。
setUserFieldChar10_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を設定します。
setUserFieldChar10_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 3 ユーザ項目 - WBS 要素を設定します。
setUserFieldChar10_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を設定します。
setUserFieldChar10_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 4 ユーザ項目 - WBS 要素を設定します。
setUserFieldChar20_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を設定します。
setUserFieldChar20_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。
setUserFieldChar20_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を設定します。
setUserFieldChar20_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 桁の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldCuky1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を設定します。
setUserFieldCuky1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
setUserFieldCuky1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を設定します。
setUserFieldCuky2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
setUserFieldCuky2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setUserFieldCurr1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を設定します。
setUserFieldCurr1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldCurr2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を設定します。
setUserFieldCurr2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldDate1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を設定します。
setUserFieldDate1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 1 ユーザ項目 - WBS 要素を設定します。
setUserFieldDate2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を設定します。
setUserFieldDate2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldFlag1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を設定します。
setUserFieldFlag1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。
setUserFieldFlag2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を設定します。
setUserFieldFlag2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目のキーワード IDを設定します。
setUserFieldKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ユーザ定義項目のキーワード IDを設定します。
setUserFieldQuan1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を設定します。
setUserFieldQuan1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldQuan2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を設定します。
setUserFieldQuan2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldUnit1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を設定します。
setUserFieldUnit1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
setUserFieldUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUserFieldUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setUserFieldUnit2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を設定します。
setUserFieldUnit2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
setUserFieldUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUserFieldUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setUserNameRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ユーザ名の範囲を設定します。
setUserStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ユーザステータス/指図ステータステーブルを設定します。
setUserStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ユーザステータス/指図ステータステーブルを設定します。
setUserf1Num(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf1Txt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf2Num(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf2Txt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名を設定します｡
setUsername(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を設定します。
setUsrStatus(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ユーザステータスを設定します。
setValArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価レベルを設定します。
setValCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価カテゴリを設定します。
setValClass(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価クラスを設定します。
setValConI(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約明細を設定します。
setValConI(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約番号を設定します。
setValContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValForcur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
伝票通貨額を設定します。
setValGrFor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外国通貨での入庫額を設定します。
setValGrLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による入庫額を設定します。
setValIvFor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
外貨による請求額を設定します。
setValIvLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
国内通貨による請求額を設定します。
setValLoccur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
国内通貨額を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注明細を設定します。
setValSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注明細を設定します。
setValSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注番号を設定します。
setValSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注番号を設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を設定します。
setValWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を設定します。
setValcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
値タイプ: 範囲制限 - 単一値を設定します。
setValcount(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層ノード内の値の値数を設定します。
setValfrom(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
エントリの有効開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チェーン別品目ステータスの有効期間開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価有効開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約の有効開始日を設定します。
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を設定します｡
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約有効終了日を設定します。
setValto(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを設定します。
setValuationData(ValuationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価データを設定します。
setValuationDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
評価データを設定します。
setValuationarea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価レベルを設定します。
setValuationtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価タイプを設定します。
setValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
CO-PA 特性値を設定します。
setValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を設定します。
setValueChanged(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンによる金額変更を設定します。
setValueTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を設定します。
setValueTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値の言語依存テキストを設定します。
setValueduom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ロット特定数量単位での評価を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
BAPI　拡張パラメータのデータ部分を設定します｡
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
長さ 229 の文字データのコンテナを設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
長さ 229 の文字データのコンテナを設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setVarOrdUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
可変購買発注単位有効を設定します。
setVarSalesUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
可変販売単位の使用不可を設定します。
setVarcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
バリアント条件を設定します。
setVarcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
バリアント条件を設定します。
setVarianceKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
差異キーを設定します。
setVatCntry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
売上税 ID 番号国を設定します。
setVatCntryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
消費税登録番号の ISO 国コードを設定します。
setVclassPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期評価クラスを設定します。
setVclassPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の評価クラスを設定します。
setVendMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
仕入先が使用している品目コードを設定します。
setVendName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
名称 1を設定します。
setVendPart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先部門を設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先勘定コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
仕入先勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先勘定コードを設定します。
setVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードを設定します｡
setVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
仕入先または債権者の勘定コードを設定します。
setVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
仕入先または債権者の勘定コードを設定します。
setVendorRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
仕入先の範囲を設定します。
setVendrbatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先ロット番号を設定します。
setVendrbatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先ロット番号を設定します。
setVerGrGiSlip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票の印刷バ－ジョンを設定します。
setVerGrGiSlipx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるバージョン番号を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票バージョン番号を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVersionFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
バージョン区分を設定します。
setVersions(Versions) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
バージョン管理ヘッダを設定します｡
setVirtCard(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
チェックボックスを設定します。
setVkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件名を設定します。
setVmPStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
プロジェクト在庫の評価クラスを設定します。
setVmSoStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
受注在庫の評価クラスを設定します。
setVolTolLt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の容積超過許容量を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総数量を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVolumeunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積単位を設定します。
setVolumeunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積単位を設定します。
setVolumeunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ISO コードでの容積単位を設定します。
setVolumeunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの容積単位を設定します。
setVolunit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
容積単位を設定します。
setVolunit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVolunitiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの容積単位を設定します。
setVperEnd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間終了日を設定します｡
setVperStart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間開始日を設定します｡
setVwUepos(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細用途 IDを設定します。
setVwUepos(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWagetype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ウェイジタイプを設定します。
setWarDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
保証期間の開始日付を設定します。
setWarDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWarehouseNumberData(WarehouseNumberData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号データを設定します。
setWarehouseNumberDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
倉庫番号データを設定します。
setWarehouseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
倉庫管理ビューを設定します。
setWarehouseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
倉庫管理ビューを設定します。
setWarehousenumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号/複合倉庫を設定します。
setWarranty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
保証日を設定します｡
setWbsAccountAssignmentElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 勘定設定要素を設定します。
setWbsActualDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
実績 WBS 要素日付の期間単位を設定します。
setWbsActualDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsActualDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績長(期間)を設定します。
setWbsActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績終了日を設定します。
setWbsActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績開始日付を設定します。
setWbsBasicDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
基準 WBS 要素日付の期間単位を設定します。
setWbsBasicDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsBasicDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の基準日の長さ(期間)を設定します。
setWbsBasicFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本終了日付を設定します。
setWbsBasicStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本開始日を設定します。
setWbsBillingElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 請求要素を設定します。
setWbsCctrPostedActual(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価が実際に転記される原価センタを設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業詳細項目要素 (WBS 要素)を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素を設定します｡
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
WBS 要素を設定します｡
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
WBS 要素を設定します。
setWbsElementExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
WBS 要素を設定します。
setWbsForcastDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素計画日付の単位を設定します。
setWbsForecastDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsForecastDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測期間を設定します。
setWbsForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測済終了日付を設定します。
setWbsForecastStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測開始日を設定します。
setWbsPlanningElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 計画要素を設定します。
setWbsScdActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績終了日を設定します。
setWbsScdActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績開始日を設定します。
setWbsScdBasicFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (基準)を設定します。
setWbsScdBasicStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最早計画開始日 (基準)を設定します。
setWbsScdForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (予測)を設定します。
setWbsScdForecastStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
計画開始日 (予測)を設定します。
setWbsSchedProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 日程計画のプロファイルを設定します。
setWeOriginAcceptance(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
仕入先構内での受領を設定します。
setWeightunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位を設定します。
setWeightunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位のISOコードを設定します。
setWhseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
倉庫番号/複合倉庫を設定します。
setWhseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫番号/複合倉庫を設定します。
setWidth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
幅を設定します。
setWithActivities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属活動を設定します。
setWithActivities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属活動を設定します。
setWithMilestones(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属 WBS マイルストーンを設定します。
setWithMilestones(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属 WBS マイルストーンを設定します。
setWithSubtree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
サブプロジェクトを設定します。
setWithSubtree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
サブプロジェクトを設定します。
setWithdrQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
出庫量を設定します。
setWithdrawal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫払出に対する保管域タイプ区分を設定します。
setWithdrawn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定に対する出庫完了を設定します。
setWithdrawn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定に対する出庫完了を設定します。
setWmUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の数量単位を設定します。
setWmUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの倉庫管理単位を設定します。
setWmdvexList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
出力テーブル (日付および ATP 数量)を設定します。
setWmdvsxList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
入力テーブル (日付/数量)を設定します。
setWorkActivity(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動に含まれる作業を設定します。
setWorkActual(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績作業を設定します。
setWorkCntr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業区を設定します。
setWorkForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測作業 (実績 + 残存)を設定します。
setWorkPermit(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
仕事許可済フラグを設定します。
setWorkSchedView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
作業計画ビューを設定します。
setWorkSchedView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
作業計画ビューを設定します。
setWtTolLt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の重量超過許容量を設定します。
setWtWithcd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
源泉徴収税コードを設定します。
setWtgGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
加重グループを設定します。
setXAutoCre(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
自動登録済み明細を設定します。
setXstob(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消移動タイプ区分の使用を設定します。
setYline(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
内部テ－ブル処理の行索引を設定します。
setZonlo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
現在のユーザのタイムゾーンを設定します。

T

TaxClassifications - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications.
制御デ－タ情報クラス
機能は以下の通り
制御デ－タ情報を保持します。
TaxClassifications() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のコンストラクタ
制御デ－タ情報を作成します。
TaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のコンストラクタ
制御デ－タ情報を作成します。
Text - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text.
テキスト情報クラス
機能は以下の通り
テキスト情報を保持します。
Text() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のコンストラクタ
テキスト情報を作成します。
Text(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のコンストラクタ
テキスト情報を作成します。
TextDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn.
請求インタフェースの通信構造テキスト情報クラス
機能は以下の通り
請求インタフェースの通信構造テキスト情報を保持します。
TextDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のコンストラクタ
請求インタフェースの通信構造テキスト情報を作成します。
TextDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のコンストラクタ
請求インタフェースの通信構造テキスト情報を作成します。
TotalConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption.
品目総消費量のデータ転送情報クラス
機能は以下の通り
品目総消費量のデータ転送情報を保持します。
TotalConsumption() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のコンストラクタ
品目総消費量のデータ転送情報を作成します。
TotalConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のコンストラクタ
品目総消費量のデータ転送情報を作成します。
TrEvTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa.
トランザクション/イベントタイプの範囲情報クラス
機能は以下の通り
トランザクション/イベントタイプの範囲情報を保持します。
TrEvTypeRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のコンストラクタ
トランザクション/イベントタイプの範囲情報を作成します。
TrEvTypeRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のコンストラクタ
トランザクション/イベントタイプの範囲情報を作成します。
Travel - class jp.co.intra_mart.foundation.sap.module.accounting.Travel.
旅費資金予算明細クラス
機能は以下の通り
旅費資金予算明細の情報を保持します。
Travel() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のコンストラクタ
旅費資金予算明細情報を作成します。
Travel(int) - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のコンストラクタ
旅費資金予算明細情報を作成します。
TravelAmount - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount.
旅費資金計画通貨項目クラス
機能は以下の通り
旅費資金計画通貨項目の情報を保持します。
TravelAmount() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のコンストラクタ
旅費資金計画通貨項目情報を作成します。
TravelAmount(int) - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のコンストラクタ
旅費資金計画通貨項目情報を作成します。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Travel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.Language のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
デバッグ用のメソッドです。

U

UnitSofmeasure - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure.
数量単位情報クラス
機能は以下の通り
数量単位情報を保持します。
UnitSofmeasure() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のコンストラクタ
数量単位情報を作成します。
UnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のコンストラクタ
数量単位情報を作成します。
UnplndConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption.
計画外消費のデータ転送情報クラス
機能は以下の通り
計画外消費のデータ転送情報を保持します。
UnplndConsumption() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のコンストラクタ
計画外消費のデータ転送情報を作成します。
UnplndConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のコンストラクタ
計画外消費のデータ転送情報を作成します。
UpdateController - class jp.co.intra_mart.foundation.sap.module.UpdateController.
登録・更新系モジュール共通コントローラ親クラス。
UpdateController() - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateController(SapClient) - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UserNameRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa.
ユーザ名の範囲情報クラス
機能は以下の通り
ユーザ名の範囲情報を保持します。
UserNameRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のコンストラクタ
ユーザ名の範囲情報を作成します。
UserNameRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のコンストラクタ
ユーザ名の範囲情報を作成します。
UserStatus - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus.
ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り
ユーザステータス/指図ステータステーブル情報を保持します。
UserStatus() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のコンストラクタ
ユーザステータス/指図ステータステーブルを作成します。

V

ValuationData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData.
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
ValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のコンストラクタ
評価データ情報を作成します。
ValuationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList.
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。
ValuationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のコンストラクタ
評価データ情報を作成します。
ValuationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のコンストラクタ
評価データ情報を作成します。
VendorAddress - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress.
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。
VendorAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のコンストラクタ
入出庫予定を作成します。
VendorRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa.
仕入先の範囲情報クラス
機能は以下の通り
仕入先の範囲情報を保持します。
VendorRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のコンストラクタ
仕入先の範囲情報を作成します。
VendorRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のコンストラクタ
仕入先の範囲情報を作成します。
Versions - class jp.co.intra_mart.foundation.sap.module.purchase.Versions.
バージョン管理情報クラス
機能は以下の通り
バージョン管理情報を保持します。
Versions() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のコンストラクタ
バージョン管理を作成します。

W

WarehouseNumberData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData.
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。
WarehouseNumberData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のコンストラクタ
倉庫番号データ情報を作成します。
WarehouseNumberDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList.
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。
WarehouseNumberDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のコンストラクタ
倉庫番号データ情報を作成します。
WarehouseNumberDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のコンストラクタ
倉庫番号データ情報を作成します。
Wmdvex - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex.
出力テーブル (日付および ATP 数量)情報クラス
機能は以下の通り
出力テーブル (日付および ATP 数量)情報を保持します。
Wmdvex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のコンストラクタ
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のコンストラクタ
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvsx - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx.
入力テーブル (日付/数量)情報クラス
機能は以下の通り
入力テーブル (日付/数量)情報を保持します。
Wmdvsx() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のコンストラクタ
入力テーブル (日付/数量)情報を作成します。
Wmdvsx(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のコンストラクタ
入力テーブル (日付/数量)情報を作成します。
A B C D E F G H I J K L M O P Q R S T U V W

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし


imsap_bapi_for_erp60 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (imsap_bapi_for_erp60 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.sap.module
jp.co.intra_mart.foundation.sap.module.accounting
jp.co.intra_mart.foundation.sap.module.accounting.exception
jp.co.intra_mart.foundation.sap.module.exception
jp.co.intra_mart.foundation.sap.module.financial
jp.co.intra_mart.foundation.sap.module.financial.exception
jp.co.intra_mart.foundation.sap.module.purchase
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.exception
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.exception
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus


概要 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_sap_bapi (ERP 6.0) API Specifications

パッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception |
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.exception |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.sap.module, jp.co.intra_mart.foundation.sap.module.accounting, jp.co.intra_mart.foundation.sap.module.accounting.exception, jp.co.intra_mart.foundation.sap.module.exception, jp.co.intra_mart.foundation.sap.module.financial, jp.co.intra_mart.foundation.sap.module.financial.exception, jp.co.intra_mart.foundation.sap.module.purchase, jp.co.intra_mart.foundation.sap.module.purchase.common.model, jp.co.intra_mart.foundation.sap.module.purchase.exception, jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate, jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems, jp.co.intra_mart.foundation.sap.module.purchase.materialavailability, jp.co.intra_mart.foundation.sap.module.purchase.materialgetall, jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica, jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber, jp.co.intra_mart.foundation.sap.module.sales, jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple, jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail, jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist, jp.co.intra_mart.foundation.sap.module.sales.common.model, jp.co.intra_mart.foundation.sap.module.sales.exception, jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist, jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Cond (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchRate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Extension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Extension1 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.Language (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Limits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.MasterData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.OrderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Partner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Selection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Travel (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.UserStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Versions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(imsap_bapi_for_erp60 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (imsap_bapi_for_erp60 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.sap.module

クラス jp.co.intra_mart.foundation.sap.module.AbstractController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sapClient

SapClient sapClient
SAPクライアント

bapiReturnErrMessage

String bapiReturnErrMessage
BAPI実行エラーメッセージ

bapiReturnMessage

String bapiReturnMessage
BAPI実行結果メッセージ

クラス jp.co.intra_mart.foundation.sap.module.ReferenceController は AbstractController を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.UpdateController は AbstractController を拡張し、Serializable を実装しています

直列化されたフィールド

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPost は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

objType

String objType
参照処理

objSys

String objSys
参照システム

objKey

String objKey
参照キー

documentHeader

DocumentHeader documentHeader
伝票ヘッダ

accountPayableList

ArrayList accountPayableList
仕入先明細一覧

accountGlList

ArrayList accountGlList
G/L 勘定明細一覧

accountTaxList

ArrayList accountTaxList
税明細一覧

currencyAmountList

ArrayList currencyAmountList
明細通貨項目一覧

travelAmountList

ArrayList travelAmountList
旅費資金計画通貨項目

travelList

ArrayList travelList
旅費資金予算明細

extension1List

ArrayList extension1List
カスタマ拡張テーブル

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController は AccEmployeePayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemnoAcc

String itemnoAcc
会計伝票明細番号

glAccount

String glAccount
総勘定元帳勘定

compCode

String compCode
会社コード

pstngDate

String pstngDate
伝票の転記日付

docType

String docType
伝票タイプ

acDocNo

String acDocNo
会計伝票番号

fiscYear

String fiscYear
会計年度

fisPeriod

String fisPeriod
会計期間

stlmntPer

String stlmntPer
決済期間

refKey1

String refKey1
取引先参照キー

refKey2

String refKey2
取引先参照キー

refKey3

String refKey3
明細の参照キー

itemText

String itemText
明細テキスト

taxCode

String taxCode
消費税コード

acctKey

String acctKey
内部処理キー

taxjurcode

String taxjurcode
税管轄

allocNmbr

String allocNmbr
ソートキー

busArea

String busArea
事業領域

personNo

String personNo
従業員番号

costcenter

String costcenter
原価センタ

orderid

String orderid
指図番号

costObj

String costObj
原価対象

activity

String activity
作業/活動番号

quantity

String quantity
数量

baseUom

String baseUom
基本数量単位

baseUomIso

String baseUomIso
ISO コードでの基本数量単位

wbsElement

String wbsElement
WBS 要素

network

String network
勘定割当のネットワーク番号

cmmtItem

String cmmtItem
予算コード

fundsCtr

String fundsCtr
予算センタ

fund

String fund
ファンド

salesOrd

String salesOrd
受注伝票番号

sOrdItem

String sOrdItem
受注明細番号

acttype

String acttype
活動タイプ

objTypP

String objTypP
前伝票: 参照処理

objKeyP

String objKeyP
前伝票: オブジェクトキー (AWREF_REV と AWORG_REV)

objPosP

String objPosP
前伝票: 参照明細

tradeId

String tradeId
取引先の会社 ID

cmmtItemLong

String cmmtItemLong
予算コード

grantNbr

String grantNbr
補助金

funcAreaLong

String funcAreaLong
機能領域

profitCtr

String profitCtr
利益センタ

partPrctr

String partPrctr
パートナ利益センタ

segment

String segment
セグメントレポートのセグメント

partnerSegment

String partnerSegment
セグメントレポートのパートナセグメント

partnerFund

String partnerFund
パートナファンド

partnerGrantNbr

String partnerGrantNbr
パートナ補助金

trPartBa

String trPartBa
取引先事業領域

negPostng

String negPostng
フラグ: マイナス転記

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemnoAcc

String itemnoAcc
会計伝票明細番号

vendorNo

String vendorNo
仕入先または債権者の勘定コード

refKey1

String refKey1
取引先参照キー

refKey2

String refKey2
取引先参照キー

refKey3

String refKey3
明細の参照キー

glAccount

String glAccount
総勘定元帳勘定

blineDate

String blineDate
期日計算の支払基準日

pmtmthsupl

String pmtmthsupl
支払方法追加

pymtMeth

String pymtMeth
支払方法

bllsrvInd

String bllsrvInd
サービスコード (外貨支払)

allocNmbr

String allocNmbr
ソートキー

itemText

String itemText
明細テキスト

acctKey

String acctKey
内部処理キー

scbankInd

String scbankInd
中央銀行コード

pymtAmt

String pymtAmt
支払通貨額

pymtCur

String pymtCur
自動支払通貨

pymtCurIso

String pymtCurIso
ISO コード通貨

profitCtr

String profitCtr
利益センタ

partPrctr

String partPrctr
パートナ利益センタ

segment

String segment
セグメントレポートのセグメント

partnerSegment

String partnerSegment
セグメントレポートのパートナセグメント

fund

String fund
ファンド

partnerFund

String partnerFund
パートナファンド

grantNbr

String grantNbr
補助金

partnerGrantNbr

String partnerGrantNbr
パートナ補助金

busArea

String busArea
事業領域

trPartBa

String trPartBa
取引先事業領域

negPostng

String negPostng
フラグ: マイナス転記

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemnoAcc

String itemnoAcc
会計伝票明細番号

glAccount

String glAccount
総勘定元帳勘定

taxCode

String taxCode
消費税コード

acctKey

String acctKey
内部処理キー

taxjurcode

String taxjurcode
税管轄

condKey

String condKey
条件タイプ

taxRate

String taxRate
税率

taxDate

String taxDate
税率定義の日付

statCon

String statCon
統計に適用する条件

taxjurcodeDeep

String taxjurcodeDeep
税管轄コード - 最下位レベル税管轄

taxjurcodeLevel

String taxjurcodeLevel
税管轄コードレベル

negPostng

String negPostng
フラグ: マイナス転記

taIndex

int taIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankKey

String bankKey
銀行コード

bankName

String bankName
銀行名

city

String city
市区町村名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

baList

BankList baList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

bankList

ArrayList bankList
銀行一覧

bankCtry

String bankCtry
銀行国コード

maxRows

int maxRows
最大該当行数

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busArea

String busArea
事業領域

busArDes

String busArDes
事業領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busAreaList

BusinessAreaList busAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

businessAreaList

ArrayList businessAreaList
事業領域一覧

language

String language
言語

isoLanguage

String isoLanguage
ISO639準拠の言語

クラス jp.co.intra_mart.foundation.sap.module.accounting.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compCode

String compCode
会社コード

compName

String compName
会社名

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compList

CompanyList compList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

companyList

ArrayList companyList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

coArea

String coArea
管理領域

name

String name
管理領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllAreaList

ControllingAreaList controllAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

controllingAreaList

ArrayList controllingAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

costCenter

String costCenter
原価センタ

name

String name
一般名称

descript

String descript
テキスト

actState

String actState
一般マスタレコードの有効化ステータス

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCentList

CostCenterList costCentList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterList

ArrayList costCenterList
原価センタ一覧

extensionInList

ArrayList extensionInList
ExtensionInの参照構造一覧

extensionOutList

ArrayList extensionOutList
ExtensionOutの参照構造一覧

personInChargeTo

String personInChargeTo
責任者（終了値）

personInChargeFrom

String personInChargeFrom
責任者（開始値）

masterDataInactive

String masterDataInactive
マスタレコードの無効化

dateTo

String dateTo
有効期間：終了

dateFrom

String dateFrom
有効期間：開始

costcenterTo

String costcenterTo
原価センタ（終了値）

costcenterFrom

String costcenterFrom
原価センタ（開始値）

costcentergroup

String costcentergroup
原価センタグループ

controllingarea

String controllingarea
管理領域

companycodeTo

String companycodeTo
会社コード（終了値）

companycodeFrom

String companycodeFrom
会社コード（開始値）

businessAreaTo

String businessAreaTo
事業領域

businessAreaFrom

String businessAreaFrom
事業領域

personInChargeUserTo

String personInChargeUserTo
担当ユーザ（終了値）

personInChargeUserFrom

String personInChargeUserFrom
担当ユーザ（開始値）

クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itemnoAcc

String itemnoAcc
会計伝票明細番号

currType

String currType
通貨タイプおよび評価ビュー

currency

String currency
通貨コード

amtDoccur

String amtDoccur
伝票通貨額

exchRate

String exchRate
換算レート

amtBase

String amtBase
課税基準額

exchRateV

String exchRateV
間接呼び値換算レート

currencyIso

String currencyIso
ISO コード通貨

cuIndex

int cuIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

objType

String objType
参照処理

objKey

String objKey
オブジェクトキー

objSys

String objSys
元伝票の論理システム

username

String username
ユーザ名

headerTxt

String headerTxt
伝票ヘッダテキスト

objKeyR

String objKeyR
取消: オブジェクトキー (AWREF_REV と AWORG_REV)

busAct

String busAct
取引

compCode

String compCode
会社コード

acDocNo

String acDocNo
会計伝票番号

fiscYear

String fiscYear
会計年度

docDate

String docDate
伝票の伝票日付

pstngDate

String pstngDate
伝票の転記日付

fisPeriod

String fisPeriod
会計期間

docType

String docType
伝票タイプ

refDocNo

String refDocNo
参照伝票番号

compoAcc

String compoAcc
ACC インタフェースの構成要素

taxCompCode

String taxCompCode
税会社コード

reasonRev

String reasonRev
反対仕訳理由

refDocNoLong

String refDocNoLong
参照伝票番号 (依存性についてはテキスト長参照)

negPostng

String negPostng
参照伝票番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.Extension1 は Object を拡張し、Serializable を実装しています

直列化されたフィールド

field1

String field1
文字項目長 250

field2

String field2
文字項目長 250

field3

String field3
文字項目長 250

field4

String field4
文字項目長 250

exIndex

int exIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI　拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI　拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI　拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI　拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.ExtensionOut は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI　拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI　拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI　拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI　拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

glAccount

String glAccount
G/L勘定コード

shortText

String shortText
G/L勘定コードテキスト(短)

longText

String longText
総勘定元帳勘定テキスト(長)

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glList

GlAccList glList
勘定科目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

glAccList

ArrayList glAccList
勘定項目一覧

language

String language
言語

languageIso

String languageIso
ISO639準拠の言語

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountGl は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountPayable は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamAccountTax は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamCurrencyAmount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamDocumentHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamExtension1 は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamTravel は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ParamTravelAmount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

profitCtr

String profitCtr
利益センタ

validTo

String validTo
有効終了日

pctrName

String pctrName
一般名称

inCharge

String inCharge
利益センタ責任者

inChargeUser

String inChargeUser
利益センタの責任責任ユーザ

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCentList

ProfitCenterList profitCentList
利益センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterList

ArrayList profitCenterList
利益センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.Travel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

objType

String objType
参照処理

objKey

String objKey
オブジェクトキー

objSys

String objSys
元伝票の論理システム

objPos

String objPos
参照明細

objId

String objId
参照伝票: 現在の ID

pstngDate

String pstngDate
伝票の転記日付

compCode

String compCode
会社コード

glAccount

String glAccount
G/L 勘定コード

network

String network
勘定割当のネットワーク番号

orderid

String orderid
指図番号

wbsElement

String wbsElement
WBS 要素

costcenter

String costcenter
原価センタ

segText

String segText
セグメントテキスト

deleteInd

String deleteInd
資金計画削除フラグ

cmmtItem

String cmmtItem
予算コード

fund

String fund
ファンド

fundsCtr

String fundsCtr
予算センタ

approved

String approved
出張申請または出張承認済 (区分)

cmmtItemLong

String cmmtItemLong
予算コード

grantNbr

String grantNbr
補助金

funcAreaLong

String funcAreaLong
機能領域

fmTransDate

String fmTransDate
FM 取引日付

trIndex

int trIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.TravelAmount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

objType

String objType
参照処理

objKey

String objKey
オブジェクトキー

objSys

String objSys
元伝票の論理システム

objPos

String objPos
参照明細

objId

String objId
参照伝票: 現在の ID

orvaltype

String orvaltype
購買発注額/受注額の金額タイプ

currType

String currType
通貨タイプおよび評価ビュー

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

amtOrigin

String amtOrigin
元金額

amtOpen

String amtOpen
未決済金額

amtActual

String amtActual
削減額

exchRate

String exchRate
換算レート

exchRateV

String exchRateV
間接呼び値換算レート

traIndex

int traIndex
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.exception

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.financial

クラス jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strTrans

String strTrans
取引

strDescript

String strDescript
テキスト (30 文字)

クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strControllingarea

String strControllingarea
管理領域

strGroupname

String strGroupname
グループ名

language

Language language
言語情報

hierarchyNodesList

ArrayList hierarchyNodesList
階層ノード一覧

hierarchyValuesList

ArrayList hierarchyValuesList
階層値一覧

クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail は CommonCenterGrpGetDetail を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterGroupGetDetail

CostCenterGroupGetDetail costCenterGroupGetDetail
原価センタグループ情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strCreditorid

String strCreditorid
仕入先コード

strCompanycode

String strCompanycode
会社コード

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

creditorGetDetail

CreditorGetDetail creditorGetDetail
仕入先コード詳細情報

クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strDebtorid

String strDebtorid
得意先コード

strCompanycode

String strCompanycode
会社コード

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

debtorGetDetail

DebtorGetDetail debtorGetDetail
得意先コード詳細情報

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strRateType

String strRateType
換算レートタイプ

strFromCurr

String strFromCurr
換算前通貨

strToCurrncy

String strToCurrncy
換算後通貨

strDate

String strDate
起算日

exchRate

ExchRate exchRate
換算レート、係数 (通貨ペア)

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

exchangeRateGetDetail

ExchangeRateGetDetail exchangeRateGetDetail
為替換算レート情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchRate は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strRateType

String strRateType
換算レートタイプ

strFromCurr

String strFromCurr
換算前通貨

strToCurrncy

String strToCurrncy
換算後通貨

strValidFrom

String strValidFrom
エントリの有効開始日

strExchRate

String strExchRate
直接呼び値換算レート

strFromFactor

String strFromFactor
換算前 通貨単位の係数

strToFactor

String strToFactor
換算後 通貨単位の係数

strExchRateV

String strExchRateV
間接呼び値換算レート

strFromFactorV

String strFromFactorV
換算前 通貨単位の係数

strToFactorV

String strToFactorV
換算後 通貨単位の係数

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpActivity は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strNetwork

String strNetwork
ネットワーク番号

strActivity

String strActivity
ネットワーク/標準ネットワークの活動番号

strControlKey

String strControlKey
管理キー

strWorkCntr

String strWorkCntr
作業区

strPlant

String strPlant
プラント

strDescription

String strDescription
作業テキスト (短)

strVendorNo

String strVendorNo
仕入先または債権者の勘定コード

strPrice

String strPrice
価格

strPriceUnit

String strPriceUnit
価格単位

strCostElem

String strCostElem
原価要素

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strInfoRec

String strInfoRec
購買情報番号

strPurchOrg

String strPurchOrg
購買組織

strPurGroup

String strPurGroup
購買グループ

strMatlGroup

String strMatlGroup
品目グループ

strFlexibleDuration

String strFlexibleDuration
区分: 可変期間

strNumberOfCapacities

String strNumberOfCapacities
所要能力数

strPercentOfWork

String strPercentOfWork
作業の比率 (%)

strMilestone

String strMilestone
用途

strActtype

String strActtype
活動タイプ

strActivityCosts

String strActivityCosts
活動の原価

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strWbsElement

String strWbsElement
WBS 要素

strFactoryCalendar

String strFactoryCalendar
稼働日カレンダ

strDistributingKey

String strDistributingKey
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

strPriority

String strPriority
優先度

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strObjectclass

String strObjectclass
オブジェクトクラス (言語非依存)

strProfitCtr

String strProfitCtr
利益センタ

strNotMrpApplicable

String strNotMrpApplicable
区分: MRP への入出庫予定の適用不可と購買依頼未登録

strProjectSummarization

String strProjectSummarization
区分: プロジェクト集計用に活動を考慮

strOperationMeasureUnit

String strOperationMeasureUnit
活動単位

strOperationMeasureUnitIso

String strOperationMeasureUnitIso
単位の ISO コード

strPlndDelry

String strPlndDelry
予定納入時間 (単位: 日)

strDurationNormal

String strDurationNormal
標準活動期間

strDurationNormalUnit

String strDurationNormalUnit
標準期間/単位

strDurationNormalUnitIso

String strDurationNormalUnitIso
単位の ISO コード

strDurationMinimum

String strDurationMinimum
最短活動期間

strDurationMinimumUnit

String strDurationMinimumUnit
最短期間の単位

strDurationMinimumUnitIso

String strDurationMinimumUnitIso
単位の ISO コード

strConstraintTypeStart

String strConstraintTypeStart
活動の基準開始日に対する制約

strConstraintTypeFinish

String strConstraintTypeFinish
活動の終了日に対する制約

strWorkActivity

String strWorkActivity
活動に含まれる作業

strUnWork

String strUnWork
作業単位

strUnWorkIso

String strUnWorkIso
単位の ISO コード

strEarlyStartDate

String strEarlyStartDate
最早計画開始: 実行 (日)

strEarlyStartTime

String strEarlyStartTime
最早計画開始: 作業実施(時間)

strEarlyFinishDate

String strEarlyFinishDate
最早計画終了: 実行 (日)

strEarlyFinishTime

String strEarlyFinishTime
最早計画終了: 実行 (時刻)

strLatestStartDate

String strLatestStartDate
計画最遅開始: 作業(日付)

strLatestStartTime

String strLatestStartTime
計画最遅開始: 作業(時間)

strLatestFinishDate

String strLatestFinishDate
計画最遅終了: 作業(日付)

strLatestFinishTime

String strLatestFinishTime
計画最遅終了: 作業(時間)

strFloatFree

String strFloatFree
自由余裕

strFloatTotal

String strFloatTotal
余裕合計

strConstraintStartDate

String strConstraintStartDate
活動の基準開始日に対する制約

strConstraintStartTime

String strConstraintStartTime
活動の基準開始時間の制約

strConstraintFinishDate

String strConstraintFinishDate
活動の基準終了日に対する制約

strConstraintFinishTime

String strConstraintFinishTime
活動の基準終了時間

strUserFieldKey

String strUserFieldKey
ユーザ定義項目のキーワード ID

strUserFieldChar201

String strUserFieldChar201
20 文字のユーザ項目

strUserFieldChar202

String strUserFieldChar202
20 文字のユーザ項目

strUserFieldChar101

String strUserFieldChar101
ユーザ定義項目 (10 文字)

strUserFieldChar102

String strUserFieldChar102
ユーザ定義項目 (10 文字)

strUserFieldQuan1

String strUserFieldQuan1
数量のユーザ項目 (長さ 10,3)

strUserFieldUnit1

String strUserFieldUnit1
ユーザ項目: 数量項目の単位

strUserFieldUnit1Iso

String strUserFieldUnit1Iso
単位の ISO コード

strUserFieldQuan2

String strUserFieldQuan2
数量のユーザ項目 (長さ 10,3)

strUserFieldUnit2

String strUserFieldUnit2
ユーザ項目: 数量項目の単位

strUserFieldUnit2Iso

String strUserFieldUnit2Iso
単位の ISO コード

strUserFieldCurr1

String strUserFieldCurr1
値のユーザ定義項目 (長さ 10,3)

strUserFieldCuky1

String strUserFieldCuky1
ユーザ項目: 値項目の単位

strUserFieldCuky1Iso

String strUserFieldCuky1Iso
ISO 通貨コード

strUserFieldCurr2

String strUserFieldCurr2
値のユーザ定義項目 (長さ 10,3)

strUserFieldCuky2

String strUserFieldCuky2
ユーザ項目: 値項目の単位

strUserFieldCuky2Iso

String strUserFieldCuky2Iso
ISO 通貨コード

strUserFieldDate1

String strUserFieldDate1
日付のユーザ項目

strUserFieldDate2

String strUserFieldDate2
日付のユーザ項目

strUserFieldFlag1

String strUserFieldFlag1
ユーザ定義項目: レポート区分

strUserFieldFlag2

String strUserFieldFlag2
ユーザ定義項目: レポート区分

strDeletionFlag

String strDeletionFlag
削除フラグ

strDurationNormalFc

String strDurationNormalFc
標準活動期間 (予測)

strDurationNormalFcUnit

String strDurationNormalFcUnit
標準予測期間の単位

strDurationNormalFcUnitIso

String strDurationNormalFcUnitIso
単位の ISO コード

strDurationMinimumFc

String strDurationMinimumFc
活動の最小期間(需要予測より)

strDurationMinimumFcUnit

String strDurationMinimumFcUnit
予測最短期間の単位

strDurationMinimumFcUnitIso

String strDurationMinimumFcUnitIso
単位の ISO コード

strConstraintTypeFinishFc

String strConstraintTypeFinishFc
活動終了の制約条件付き需要予測日付

strConstraintTypeStartFc

String strConstraintTypeStartFc
活動開始の制約条件付き需要予測日付

strConstraintStartDateFc

String strConstraintStartDateFc
活動の予測開始日

strConstraintStartTimeFc

String strConstraintStartTimeFc
活動の需要予測開始時間

strConstraintFinishDateFc

String strConstraintFinishDateFc
予測終了日付

strConstraintFinishTimeFc

String strConstraintFinishTimeFc
活動の予測終了時間

strEarlyStartDateFc

String strEarlyStartDateFc
最早計画開始日付(需要予測)

strEarlyStartTimeFc

String strEarlyStartTimeFc
最早計画開始時間(需要予測)

strEarlyFinishDateFc

String strEarlyFinishDateFc
最早計画終了日 (予測)

strEarlyFinishTimeFc

String strEarlyFinishTimeFc
最早計画終了時間(需要予測)

strLatestStartDateFc

String strLatestStartDateFc
最遅計画済開始日付(需要予測)

strLatestStartTimeFc

String strLatestStartTimeFc
最遅計画済開始時間(需要予測)

strLatestFinishDateFc

String strLatestFinishDateFc
最遅計画済終了日付(需要予測)

strLatestFinishTimeFc

String strLatestFinishTimeFc
最遅計画終了時間 (予測)

strFloatFreeFc

String strFloatFreeFc
自由余裕 (予測)

strFloatTotalFc

String strFloatTotalFc
余裕合計 (予測)

strWorkForecast

String strWorkForecast
予測作業 (実績 + 残存)

strWorkActual

String strWorkActual
実績作業

strDurationScheduled

String strDurationScheduled
処理時間

strDurationScheduledFc

String strDurationScheduledFc
処理時間の長さ (予測値)

strDurationScheduledUnit

String strDurationScheduledUnit
処理時間単位

strDurationScheduledUnitIso

String strDurationScheduledUnitIso
単位の ISO コード

strDurationConfirmFc

String strDurationConfirmFc
確認の予測活動期間

strDurationConfirmFcUnit

String strDurationConfirmFcUnit
確認の予測期間単位

strDurationConfirmFcUnitIso

String strDurationConfirmFcUnitIso
単位の ISO コード

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

strPlannedCost

String strPlannedCost
計画原価

strActualCost

String strActualCost
実際原価

strControllingAreaCurrency

String strControllingAreaCurrency
通貨コード

strActualStartDate

String strActualStartDate
実績開始日: 実行 (日付)

strActualFinishDate

String strActualFinishDate
実績終了日: 実行 (日付)

strForecastFinishDate

String strForecastFinishDate
予測終了日

strComplete

String strComplete
最終確認の有効化

strReferencePoint

String strReferencePoint
BOM 転送の参照ポイント

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpMessage は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMethod

String strMethod
メソッド

strObjectType

String strObjectType
オブジェクトタイプ

strInternalObjectId

String strInternalObjectId
SAP 内部対象キー

strExternalObjectId

String strExternalObjectId
SAP 外部対象キー

strMessageId

String strMessageId
メッセージ ID

strMessageNumber

String strMessageNumber
システムメッセージ番号

strMessageType

String strMessageType
メッセージタイプ

strMessageText

String strMessageText
メッセージのテキスト行

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strDescription

String strDescription
PS: テキスト(短)(第一テキスト行)

strShortId

String strShortId
WBS 要素 ショート ID

strResponsibleNo

String strResponsibleNo
責任者番号 (プロジェクト責任者)

strApplicantNo

String strApplicantNo
申請者番号

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strCoArea

String strCoArea
管理領域

strProfitCtr

String strProfitCtr
利益センタ

strProjType

String strProjType
プロジェクトタイプ

strNetworkAssignment

String strNetworkAssignment
ネットワーク割当

strCostingSheet

String strCostingSheet
原価計算表

strOverheadKey

String strOverheadKey
間接費キー

strCalendar

String strCalendar
稼動日カレンダ

strPriority

String strPriority
優先度

strEquipment

String strEquipment
設備番号

strFunctionalLocation

String strFunctionalLocation
機能場所

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strPlant

String strPlant
プラント

strUserFieldKey

String strUserFieldKey
ユーザ定義項目のキーワード ID

strUserFieldChar201

String strUserFieldChar201
20 文字の第 1 ユーザ項目 - WBS 要素 -

strUserFieldChar202

String strUserFieldChar202
20 桁の第 2 ユーザ項目 - WBS 要素

strUserFieldChar101

String strUserFieldChar101
10 桁の第 3 ユーザ項目 - WBS 要素

strUserFieldChar102

String strUserFieldChar102
10 桁の第 4 ユーザ項目 - WBS 要素

strUserFieldQuan1

String strUserFieldQuan1
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldUnit1

String strUserFieldUnit1
数量項目単位の第１ユーザ定義項目 - WBS 要素

strUserFieldUnit1Iso

String strUserFieldUnit1Iso
単位の ISO コード

strUserFieldQuan2

String strUserFieldQuan2
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldUnit2

String strUserFieldUnit2
数量項目単位の第２ユーザ定義項目 - WBS 要素

strUserFieldUnit2Iso

String strUserFieldUnit2Iso
単位の ISO コード

strUserFieldCurr1

String strUserFieldCurr1
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldCuky1

String strUserFieldCuky1
値項目単位の第１ユーザ定義項目 - WBS 要素

strUserFieldCuky1Iso

String strUserFieldCuky1Iso
ISO 通貨コード

strUserFieldCurr2

String strUserFieldCurr2
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldCuky2

String strUserFieldCuky2
値項目単位の第２ユーザ定義項目 - WBS 要素

strUserFieldCuky2Iso

String strUserFieldCuky2Iso
ISO 通貨コード

strUserFieldDate1

String strUserFieldDate1
日付の第 1 ユーザ項目 - WBS 要素

strUserFieldDate2

String strUserFieldDate2
日付の第 2 ユーザ項目 - WBS 要素

strUserFieldFlag1

String strUserFieldFlag1
'評価区分' の第 1 ユーザ項目 - WBS 要素

strUserFieldFlag2

String strUserFieldFlag2
'評価区分' の第 2 ユーザ項目 - WBS 要素

strObjectclass

String strObjectclass
対象クラス

strStatistical

String strStatistical
統計 WBS 要素

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strIntProfile

String strIntProfile
プロジェクト/指図金利計算の金利プロファイル

strJointVenture

String strJointVenture
ジョイントベンチャ

strRecoveryInd

String strRecoveryInd
リカバリフラグ

strEquityType

String strEquityType
持分タイプ

strJvObjectType

String strJvObjectType
ジョイントベンチャ対象タイプ

strJvJibClass

String strJvJibClass
JIB/JIBE クラス

strJvJibSubClassA

String strJvJibSubClassA
JIB/JIBE サブクラスA

strDeletionFlag

String strDeletionFlag
削除フラグ

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strWbsPlanningElement

String strWbsPlanningElement
区分: 計画要素

strWbsAccountAssignmentElement

String strWbsAccountAssignmentElement
区分: 勘定設定要素

strWbsBillingElement

String strWbsBillingElement
区分: 請求要素

strRespsblCctr

String strRespsblCctr
責任原価センタ

strRespsblCctrControllingArea

String strRespsblCctrControllingArea
責任原価センタの管理領域

strRequestCctr

String strRequestCctr
申請原価センタ

strRequestCompCode

String strRequestCompCode
会社コード要求

strRequestCctrControllingArea

String strRequestCctrControllingArea
依頼原価センタの管理領域

strLocation

String strLocation
場所

strChangeNo

String strChangeNo
変更番号

strInvestProfile

String strInvestProfile
設備投資案件プロファイル

strResAnalKey

String strResAnalKey
結果分析キー

strWbsCctrPostedActual

String strWbsCctrPostedActual
原価が実際に転記される原価センタ

strWbsBasicStartDate

String strWbsBasicStartDate
WBS 要素: 基本開始日

strWbsBasicFinishDate

String strWbsBasicFinishDate
WBS 要素: 基本終了日付

strWbsForecastStartDate

String strWbsForecastStartDate
WBS 要素の予測開始日

strWbsForecastFinishDate

String strWbsForecastFinishDate
WBS 要素の予測済終了日付

strWbsActualStartDate

String strWbsActualStartDate
WBS 要素の実績開始日付

strWbsActualFinishDate

String strWbsActualFinishDate
WBS 要素の実績終了日

strWbsBasicDuration

String strWbsBasicDuration
WBS 要素の基準日の長さ(期間)

strWbsBasicDurUnit

String strWbsBasicDurUnit
基準 WBS 要素日付の期間単位

strWbsBasicDurUnitIso

String strWbsBasicDurUnitIso
単位の ISO コード

strWbsForecastDuration

String strWbsForecastDuration
WBS 要素の予測期間

strWbsForcastDurUnit

String strWbsForcastDurUnit
WBS 要素計画日付の単位

strWbsForecastDurUnitIso

String strWbsForecastDurUnitIso
単位の ISO コード

strWbsActualDuration

String strWbsActualDuration
WBS 要素の実績長(期間)

strWbsActualDurUnit

String strWbsActualDurUnit
実績 WBS 要素日付の期間単位

strWbsActualDurUnitIso

String strWbsActualDurUnitIso
単位の ISO コード

strWbsScdBasicStartDate

String strWbsScdBasicStartDate
最早計画開始日 (基準)

strWbsScdBasicFinishDate

String strWbsScdBasicFinishDate
最遅計画終了日 (基準)

strWbsScdForecastStartDate

String strWbsScdForecastStartDate
計画開始日 (予測)

strWbsScdForecastFinishDate

String strWbsScdForecastFinishDate
最遅計画終了日 (予測)

strWbsScdActualStartDate

String strWbsScdActualStartDate
WBS 要素の仮実績開始日

strWbsScdActualFinishDate

String strWbsScdActualFinishDate
WBS 要素の仮実績終了日

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strUp

String strUp
WBS 要素

strDown

String strDown
WBS 要素

strLeft

String strLeft
WBS 要素

strRight

String strRight
WBS 要素

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMilestoneNumber

String strMilestoneNumber
マイルストーン番号

strWbsElement

String strWbsElement
WBS 要素

strMilestoneUsage

String strMilestoneUsage
マイルストーン用途

strDescription

String strDescription
テキスト

strSchedMilestoneDateBasic

String strSchedMilestoneDateBasic
マイルストーン計画日(基準)

strSchedMilestoneTimeBasic

String strSchedMilestoneTimeBasic
マイルストーン計画時間(基準)

strSchedMilestoneDateForecast

String strSchedMilestoneDateForecast
マイルストーン計画日(予測)

strSchedMilestoneTimeForecast

String strSchedMilestoneTimeForecast
マイルストーン計画時間(予測)

strFixedMilestoneDateBasic

String strFixedMilestoneDateBasic
固定マイルストーン日付(基準)

strFixedMilestoneTimeBasic

String strFixedMilestoneTimeBasic
固定マイルストーン時間(基準)

strFixedMilestoneDateForecast

String strFixedMilestoneDateForecast
マイルストーン固定日付

strFixedMilestoneTimeForecast

String strFixedMilestoneTimeForecast
マイルストーン固定時間 (F)

strActualDate

String strActualDate
実績日付(マイルストーン通過)

strActualTime

String strActualTime
実績日/時間(マイルストーン適合)

strLatestDatesIndicator

String strLatestDatesIndicator
区分: 最遅日

strOffsetStartEndIndicator

String strOffsetStartEndIndicator
区分: オフセット用の参照（開始/終了活動日）

strOffsetMilestoneDate

String strOffsetMilestoneDate
マイルストーン日付のオフセット

strOffsetMilestoneDateUnit

String strOffsetMilestoneDateUnit
マイルストーンのオフセットのための時間単位

strOffsetMilestoneDateUnitIso

String strOffsetMilestoneDateUnitIso
単位の ISO コード

strOffsetPercentage

String strOffsetPercentage
活動日に対するマイルストーンの百分率によるオフセット

strTrendAnalysisIndicator

String strTrendAnalysisIndicator
傾向分析の関連マイルストーン

strEarnedValueIndicator

String strEarnedValueIndicator
進捗分析関連のマイルストーン

strPercentageOfCompletion

String strPercentageOfCompletion
進捗度 (%)

strSalesDocDateInidicator

String strSalesDocDateInidicator
販売伝票の日付に関連するマイルストーン

strInvoicePercentage

String strInvoicePercentage
請求金額率 (%)

strDeletionFlag

String strDeletionFlag
削除フラグ

クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strGroupname

String strGroupname
グループ名

strHierlevel

String strHierlevel
階層のエントリレベル

strValcount

String strValcount
階層ノード内の値の値数

strDescript

String strDescript
グループテキスト (短)

クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strValfrom

String strValfrom
原価センタ/利益センタ

strValto

String strValto
原価センタ/利益センタ

クラス jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strOrderid

String strOrderid
指図番号

strLanguage

String strLanguage
ステータスおよび業務トランザクションテキストの言語

masterData

MasterData masterData
指図のマスタデータ構造

systemStatusList

ArrayList systemStatusList
システムステータステーブル

userStatusList

ArrayList userStatusList
ユーザステータス/指図ステータステーブル

allowedBusTractList

ArrayList allowedBusTractList
使用可能業務トランザクションのテーブル

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

internalOrderGetDetail

InternalOrderGetDetail internalOrderGetDetail
内部指図書詳細情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strControllingArea

String strControllingArea
管理領域

strRespCostCenter

String strRespCostCenter
責任原価センタ

strOrderType

String strOrderType
指図タイプ

strOrder

String strOrder
指図番号 (個別値、または下限値)

strOrderTo

String strOrderTo
指図番号 (上限値)

strOrderExternalNo

String strOrderExternalNo
外部指図番号 (個別値、または下限値)

strOrderExternalNoTo

String strOrderExternalNoTo
外部指図番号 (上限値)

orderListList

ArrayList orderListList
選択指図一覧

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

internalOrderGetList

InternalOrderGetList internalOrderGetList
内部指図書一覧情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.Language は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
ISO 639 準拠の言語

クラス jp.co.intra_mart.foundation.sap.module.financial.MasterData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strOrder

String strOrder
指図番号

strOrderType

String strOrderType
販売伝票タイプ

strOrderName

String strOrderName
テキスト

strExtOrdNo

String strExtOrdNo
外部指図番号

strObjectNo

String strObjectNo
対象番号

strCoArea

String strCoArea
管理領域

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strPlant

String strPlant
プラント

strProfitCtr

String strProfitCtr
利益センタ

strRespcctr

String strRespcctr
責任原価センタ

strWbsElem

String strWbsElem
作業詳細項目要素 (WBS 要素)

strWbsElementExt

String strWbsElementExt
WBS 要素

strRequestCctr

String strRequestCctr
申請原価センタ

strRequCompCode

String strRequCompCode
会社コード要求

strSalesOrd

String strSalesOrd
受注伝票番号

strSOrdItem

String strSOrdItem
受注明細番号

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strCctrPosted

String strCctrPosted
原価が実際に転記された原価センタ

strCurrency

String strCurrency
購買発注通貨

strCstgSheet

String strCstgSheet
原価計算表

strOverheadKey

String strOverheadKey
間接費キー

strResAnalKey

String strResAnalKey
結果分析キー

strInterestProf

String strInterestProf
プロジェクト/指図金利計算の金利プロファイル

strApplicant

String strApplicant
申請者

strApplicantPhone

String strApplicantPhone
申請者の電話番号

strPersonResp

String strPersonResp
責任者

strPersonRespPhone

String strPersonRespPhone
責任者の電話番号

strEstimatedCosts

String strEstimatedCosts
指図の見積原価合計

strApplicationDate

String strApplicationDate
申請日

strDepartment

String strDepartment
部署

strDateWorkBegins

String strDateWorkBegins
作業開始

strDateWorkEnds

String strDateWorkEnds
作業終了

strWorkPermit

String strWorkPermit
仕事許可済フラグ

strProcessingGroup

String strProcessingGroup
処理グループ

strPlnRelease

String strPlnRelease
計画リリース日付

strPlnCompletion

String strPlnCompletion
計画完了日

strPlnClose

String strPlnClose
計画終了日付

strRequestOrder

String strRequestOrder
申請指図

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

strInChargeUser

String strInChargeUser
CO 内部指図の責任者

クラス jp.co.intra_mart.foundation.sap.module.financial.OrderList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strOrder

String strOrder
指図番号

strObjectNo

String strObjectNo
対象番号

strOrderType

String strOrderType
販売伝票タイプ

strOrderName

String strOrderName
テキスト

クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail は CommonCenterGrpGetDetail を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterGrpGetDetail

ProfitCenterGrpGetDetail profitCenterGrpGetDetail
利益センタグループ情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strDescription

String strDescription
PS: テキスト(短)(第一テキスト行)

strMaskId

String strMaskId
WBS 要素 ID(短)の選択マスク

strResponsibleNo

String strResponsibleNo
責任者番号 (プロジェクト責任者)

strApplicantNo

String strApplicantNo
申請者番号

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strControllingArea

String strControllingArea
管理領域

strProfitCtr

String strProfitCtr
利益センタ

strProjectCurrency

String strProjectCurrency
WBS 通貨(プロジェクト定義)

strProjectCurrencyIso

String strProjectCurrencyIso
ISO 通貨コード

strNetworkAssignment

String strNetworkAssignment
ネットワーク割当

strStart

String strStart
プロジェクト計画開始日付

strFinish

String strFinish
プロジェクトの計画終了日

strPlant

String strPlant
プラント

strCalendar

String strCalendar
稼動日カレンダ

strPlanBasic

String strPlanBasic
プロジェクト基準日付計画方法

strPlanFcst

String strPlanFcst
プロジェクト予測日付の計画方法

strTimeUnit

String strTimeUnit
時間計画単位

strTimeUnitIso

String strTimeUnitIso
単位の ISO コード

strNetworkProfile

String strNetworkProfile
ネットワークプロファイル

strProjectProfile

String strProjectProfile
プロジェクトプロファイル

strBudgetProfile

String strBudgetProfile
予算プロファイル

strProjectStock

String strProjectStock
プロジェクト在庫

strObjectclass

String strObjectclass
対象クラス

strStatistical

String strStatistical
統計 WBS 要素

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strIntProfile

String strIntProfile
プロジェクト/指図金利計算の金利プロファイル

strWbsSchedProfile

String strWbsSchedProfile
WBS 日程計画のプロファイル

strCshBdgtProfile

String strCshBdgtProfile
資金計画プロファイル

strPlanProfile

String strPlanProfile
計画プロファイル

strJointVenture

String strJointVenture
ジョイントベンチャ

strRecoveryInd

String strRecoveryInd
リカバリフラグ

strEquityType

String strEquityType
持分タイプ

strJvObjectType

String strJvObjectType
ジョイントベンチャ対象タイプ

strJvJibClass

String strJvJibClass
JIB/JIBE クラス

strJvJibSubClassA

String strJvJibSubClassA
JIB/JIBE サブクラスA

strDeletionFlag

String strDeletionFlag
削除フラグ

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strWithActivities

String strWithActivities
区分: 活動があるプロジェクト

strWithMilestones

String strWithMilestones
マイルストーンがあるプロジェクトの出力

strWithSubtree

String strWithSubtree
WBS 要素サブツリーの出力

impWbsElementList

ArrayList impWbsElementList
WBS 要素

projectDefinition

ProjectDefinition projectDefinition
プロジェクトについての詳細情報

expWbsElementList

ArrayList expWbsElementList
WBS 要素についての詳細情報

expWbsMilestoneList

ArrayList expWbsMilestoneList
WBS マイルストーンに関する詳細情報

expWbsHierarchieList

ArrayList expWbsHierarchieList
WBS 階層についての情報

expActivityList

ArrayList expActivityList
活動に関する詳細情報

expMessageList

ArrayList expMessageList
詳細情報を読み込みエラー

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

projectGetInfo

ProjectGetInfo projectGetInfo
WBSの詳細情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.SystemStatus は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strSysStatus

String strSysStatus
システムステータス

strSyStText

String strSyStText
オブジェクトの個別ステータス (簡略形式)

strSyStDscr

String strSyStDscr
オブジェクトステータス

クラス jp.co.intra_mart.foundation.sap.module.financial.UserStatus は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strStatProf

String strStatProf
ステータスプロファイル

strUsrStatus

String strUsrStatus
ユーザステータス

strUsStNumb

String strUsStNumb
ステータス番号

strUsStText

String strUsStText
オブジェクトの個別ステータス (簡略形式)

strUsStDscr

String strUsStDscr
オブジェクトステータス

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception

クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase

クラス jp.co.intra_mart.foundation.sap.module.purchase.AllVersions は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strDocType

String strDocType
購買伝票カテゴリ

strDocNumber

String strDocNumber
購買管理におけるオブジェクト番号

strItemNumber

String strItemNumber
購買管理オブジェクト: 明細

strVersion

String strVersion
購買管理におけるバージョン番号

strCreatedBy

String strCreatedBy
オブジェクト登録者名

strCrOn

String strCrOn
レコード登録日

strRecTime

String strRecTime
登録時刻

strReleasedBy

String strReleasedBy
承認者名

strReleaseDate

String strReleaseDate
承認日

strReleaseTime

String strReleaseTime
承認時刻

strReleasebyPur

String strReleasebyPur
承認購買担当者名

strReleasedatePur

String strReleasedatePur
購買担当者承認日付

strReleasetimePur

String strReleasetimePur
購買担当者承認時刻

strReason

String strReason
変更理由

strDescription

String strDescription
バージョンテキスト（長）

strReqByExt

String strReqByExt
バージョンの外部変更番号

strReqBy

String strReqBy
変更を依頼した従業員

strNetValue

String strNetValue
購買発注通貨による正味発注額

strValueChanged

String strValueChanged
バージョンによる金額変更

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO コード通貨

strPostDate

String strPostDate
バージョンの転記日付

strCompleted

String strCompleted
ステータス "バージョン完了済"

strStatus

String strStatus
バージョンステータス

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strStatusDocOld

String strStatusDocOld
このバージョンの前の旧処理状況 (購買伝票内)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Cond は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strConditionNo

String strConditionNo
伝票条件番号

strItmNumber

String strItmNumber
条件明細番号

strCondStNo

String strCondStNo
ステップ番号

strCondCount

String strCondCount
条件カウンタ

strCondType

String strCondType
条件タイプ

strCondValue

String strCondValue
条件レート

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO コード通貨

strCondUnit

String strCondUnit
条件単位

strCondUnitIso

String strCondUnitIso
条件数量単位 (ISO コード)

strCondPUnt

String strCondPUnt
価格条件単位

strApplicatio

String strApplicatio
アプリケーション

strConpricdat

String strConpricdat
条件価格設定日付

strCalctypcon

String strCalctypcon
条件計算タイプ

strConbaseval

String strConbaseval
条件基礎値

strConexchrat

String strConexchrat
現地通貨への換算レートに対する条件

strNumconvert

String strNumconvert
条件単位を基本単位へ変換する分子

strDenominato

String strDenominato
条件単位を基本単位へ変換する分母

strCondtype

String strCondtype
条件カテゴリ (例: 税、運賃、価格、原価)

strStatCon

String strStatCon
統計に適用する条件

strScaletype

String strScaletype
スケールタイプ

strAccruals

String strAccruals
見越額関連条件 (運賃など)

strConinvolst

String strConinvolst
請求書一覧条件

strCondorigin

String strCondorigin
条件生成区分

strGroupcond

String strGroupcond
グループ条件区分

strCondUpdat

String strCondUpdat
条件更新

strAccessSeq

String strAccessSeq
検索順序 - 検索番号

strCondcount

String strCondcount
条件連続番号

strCondcntrl

String strCondcntrl
条件管理

strCondisacti

String strCondisacti
無効条件

strCondclass

String strCondclass
条件クラス

strFactbasval

String strFactbasval
条件基礎値に対する要因

strScalebasin

String strScalebasin
スケール基準区分

strScalbasval

String strScalbasval
条件のスケール基準値

strUnitmeasur

String strUnitmeasur
条件スケール単位

strUnitmeasurIso

String strUnitmeasurIso
単位の ISO コード

strCurrenckey

String strCurrenckey
スケール通貨

strCurrenckeyIso

String strCurrenckeyIso
ISO コード通貨

strCondincomp

String strCondincomp
会社間請求の条件

strCondconfig

String strCondconfig
システム設定の条件

strCondchaman

String strCondchaman
条件 (マニュアル変更済)

strCondNo

String strCondNo
条件レコード番号

strChangeId

String strChangeId
変更タイプ(U、I、E、D)

strVendorNo

String strVendorNo
仕入先または債権者の勘定コード

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
制限の内部明細番号

strConNumber

String strConNumber
基本契約番号

strConItem

String strConItem
明細番号、契約

strLimit

String strLimit
全体制限

strNoLimit

String strNoLimit
制限なし

strPriceChg

String strPriceChg
入力シートの価格変更

strShortText

String strShortText
テキスト 1 (短)

strDeleteInd

String strDeleteInd
削除フラグ

clIndex

int clIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractService は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
内部明細番号

strExtLine

String strExtLine
明細番号

strOutlLevel

String strOutlLevel
グループの階層レベル

strOutlNo

String strOutlNo
アウトラインレベル

strOutlInd

String strOutlInd
区分: 出力行

strSubpckgNo

String strSubpckgNo
サブパッケージ番号

strService

String strService
活動番号

strServType

String strServType
サービスタイプのテキスト (短)

strEdition

String strEdition
サービスタイプのバージョン

strSscItem

String strSscItem
標準サービスカタログ: 明細

strExtServ

String strExtServ
仕入先のサービス番号

strQuantity

String strQuantity
+/- 記号あり/なし数量

strBaseUom

String strBaseUom
基本数量単位

strUomIso

String strUomIso
単位の ISO コード

strOvfTol

String strOvfTol
超過許容値

strOvfUnlim

String strOvfUnlim
契約外サービス制限なし

strPriceUnit

String strPriceUnit
価格単位

strGrPrice

String strGrPrice
基準額

strFromLine

String strFromLine
下限

strToLine

String strToLine
上限

strShortText

String strShortText
テキスト(短)

strDistrib

String strDistrib
複数勘定設定の配賦区分

strPersNo

String strPersNo
従業員番号

strWagetype

String strWagetype
ウェイジタイプ

strPlnPckg

String strPlnPckg
パッケージ番号供給元一覧

strPlnLine

String strPlnLine
入力: 計画梱包明細行

strConPckg

String strConPckg
入力: 基本契約の計画外

strConLine

String strConLine
入力: 基本契約の計画外

strTmpPckg

String strTmpPckg
入力: モデル仕様からの計画外サービス

strTmpLine

String strTmpLine
入力: モデル仕様からの計画外サービス

strSscLim

String strSscLim
標準サービスカタログ制限参照のサービス行

strLimitLine

String strLimitLine
入力: 計画外、明細制限

strTargetVal

String strTargetVal
目標値

strBaslineNo

String strBaslineNo
代替: 基本明細参照

strBasicLine

String strBasicLine
基本明細

strAlternat

String strAlternat
代替明細

strBidder

String strBidder
入札者の明細

strSuppLine

String strSuppLine
補足明細

strOpenQty

String strOpenQty
未処理数量のある明細

strInform

String strInform
情報行

strBlanket

String strBlanket
包括明細

strEventual

String strEventual
偶発的明細

strTaxCode

String strTaxCode
消費税コード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strPriceChg

String strPriceChg
入力シートの価格変更

strMatlGroup

String strMatlGroup
品目グループ

strDate

String strDate
日付

strBegintime

String strBegintime
開始時刻

strEndtime

String strEndtime
終了時刻

strExtpersNo

String strExtpersNo
外部従業員番号

strFormula

String strFormula
計算式番号

strFormVal1

String strFormVal1
計算式値

strFormVal2

String strFormVal2
計算式値

strFormVal3

String strFormVal3
計算式値

strFormVal4

String strFormVal4
計算式値

strFormVal5

String strFormVal5
計算式値

strUserf1Num

String strUserf1Num
ユーザ定義項目

strUserf2Num

String strUserf2Num
ユーザ定義項目

strUserf1Txt

String strUserf1Txt
ユーザ定義項目

strUserf2Txt

String strUserf2Txt
ユーザ定義項目

strHiLineNo

String strHiLineNo
上位階層明細番号

strExtrefkey

String strExtrefkey
サービスの外部参照キー

strDeleteInd

String strDeleteInd
削除フラグ

csIndex

int csIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
明細行番号

strSernoLine

String strSernoLine
勘定コード設定のシリアル番号、サービス明細

strPercentage

String strPercentage
勘定設定金額配賦のパーセント

strSerialNo

String strSerialNo
勘定設定の連続番号

strQuantity

String strQuantity
+/- 記号あり/なし数量

strNetValue

String strNetValue
明細の正味額

saIndex

int saIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText は PurchaseText を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
内部明細番号

strFormatCol

String strFormatCol
タグ列

クラス jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strAddrNo

String strAddrNo
アドレス番号

strFormofaddr

String strFormofaddr
敬称テキスト

strName

String strName
名称 1

strName2

String strName2
名称 2

strName3

String strName3
名称 3

strName4

String strName4
名称 4

strCOName

String strCOName
気付

strCity

String strCity
市区町村

strDistrict

String strDistrict
所在地

strCityNo

String strCityNo
市区町村/地名ファイルの市区町村コード

strPostlCod1

String strPostlCod1
市区町村の郵便番号

strPostlCod2

String strPostlCod2
私書箱郵便番号

strPostlCod3

String strPostlCod3
会社郵便番号 (大規模なユーザ用)

strPoBox

String strPoBox
私書箱

strPoBoxCit

String strPoBoxCit
私書箱住所

strDelivDis

String strDelivDis
郵便配達地域

strStreet

String strStreet
地名

strStreetNo

String strStreetNo
市区町村/地名ファイルの地名コード

strStrAbbr

String strStrAbbr
地名の略称 (例: スペイン)

strHouseNo

String strHouseNo
番地-号

strStrSuppl1

String strStrSuppl1
地名 2

strStrSuppl2

String strStrSuppl2
地名 3

strLocation

String strLocation
地名 5

strBuilding

String strBuilding
旧: 建物 (番号または略称)

strFloor

String strFloor
建物の階

strRoomNo

String strRoomNo
部屋/アパート番号

strCountry

String strCountry
国コード

strLangu

String strLangu
言語キー

strRegion

String strRegion
地域 (都道府県)

strSort1

String strSort1
検索条件 1

strSort2

String strSort2
検索条件 2

strTimeZone

String strTimeZone
アドレスタイムゾーン

strTaxjurcode

String strTaxjurcode
税管轄コード

strAdrNotes

String strAdrNotes
住所注記

strCommType

String strCommType
通信方法 (キー) (アドレス管理)

strTel1Numbr

String strTel1Numbr
第一電話番号: ダイヤルコード + 番号

strTel1Ext

String strTel1Ext
第 1 電話番号: 内線

strFaxNumber

String strFaxNumber
第一 FAX 番号: ダイヤルコード + 番号

strFaxExtens

String strFaxExtens
第一 FAX 番号: 内線

strStreetLng

String strStreetLng
地名

strDistrctNo

String strDistrctNo
市区町村/地名ファイルの所在地コード

strChckstatus

String strChckstatus
市区町村ファイルテストステータス

strPboxcitNo

String strPboxcitNo
市区町村私書箱コード (市ファイル)

strTranspzone

String strTranspzone
商品の納入区域

strHouseNo2

String strHouseNo2
番地補足

strEMail

String strEMail
電子メールアドレス

strStrSuppl3

String strStrSuppl3
地名 4

strTitle

String strTitle
タイトル (敬称)

strCountryiso

String strCountryiso
ISO 国コード

strLanguIso

String strLanguIso
ISO 639 準拠の言語

strBuildLong

String strBuildLong
建物 (番号またはコード)

strRegiogroup

String strRegiogroup
地域構造グループ化

deIndex

int deIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strDistrChanLow

String strDistrChanLow
流通チャネルの範囲開始

strDistrChanHigh

String strDistrChanHigh
流通チャネルの範囲終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strTransportMode

String strTransportMode
貿易管理の輸送モード

strCustoms

String strCustoms
税関: 税関 (出国時)

クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strBusinessTransactionType

String strBusinessTransactionType
貿易管理の取引タイプ

strExportImportProcedure

String strExportImportProcedure
貿易の輸出入手続

strCountryori

String strCountryori
品目の原産国

strCountryoriIso

String strCountryoriIso
ISO 国コード

strRegionorig

String strRegionorig
品目の原産地 (非特恵対象地区の原産)

strCommCode

String strCommCode
貿易: 統計品目コード/輸入コード番号

strShippingCountry

String strShippingCountry
貿易: 出荷国

strShippingCountryIso

String strShippingCountryIso
ISO 国コード

eiIndex

int eiIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Extension は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strStructure

String strStructure
BAPI テーブル拡張の構造名

strValuepart1

String strValuepart1
BAPI 拡張パラメータのデータ部分

strValuepart2

String strValuepart2
BAPI 拡張パラメータのデータ部分

strValuepart3

String strValuepart3
BAPI 拡張パラメータのデータ部分

strValuepart4

String strValuepart4
BAPI 拡張パラメータのデータ部分

exIndex

int exIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController は GoodsMvtCreate を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController は GoodsMvtGetItems を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.Limits は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLimit

String strLimit
全体制限

strNoLimit

String strNoLimit
制限なし

strExpValue

String strExpValue
見込金額

strSscExist

String strSscExist
サービスタイプの制限

strConExist

String strConExist
基本契約明細の制限

strTmpExist

String strTmpExist
サービスパッケージの制限

strPriceChg

String strPriceChg
入力シートの価格変更

strFreeLimit

String strFreeLimit
自由制限

strNoFrlimit

String strNoFrlimit
制限なし

strServType

String strServType
サービスタイプのテキスト (短)

strEdition

String strEdition
サービスタイプのバージョン

strSscLimit

String strSscLimit
サービスタイプの金額制限

strSscNolim

String strSscNolim
標準サービスタイプの制限なし

strSscPrschg

String strSscPrschg
入力シートの価格変更

strSscPerc

String strSscPerc
価格決定率

strTmpNumber

String strTmpNumber
モデルサービス明細セット番号

strTmpLimit

String strTmpLimit
モデルサービス明細制限

strTmpNolim

String strTmpNolim
モデル仕様の制限なし

strTmpPrschg

String strTmpPrschg
入力シートの価格変更

strTmpPerc

String strTmpPerc
価格決定率

strContPerc

String strContPerc
価格決定率

liIndex

int liIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strManuMat

String strManuMat
製造者製品コード

strMfrNo

String strMfrNo
製造者番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController は MaterialAvailability を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController は MaterialGetAll を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strMaxRows

String strMaxRows
選択予定品目の最大数

matnrSelectionList

ArrayList matnrSelectionList
品目コードの選択オプション一覧

materialShortDescselList

ArrayList materialShortDescselList
品目テキストの選択オプション一覧

manufacturerPartNumbList

ArrayList manufacturerPartNumbList
製造業者と製造者製品コード一覧

plantSelectionList

ArrayList plantSelectionList
プラントの選択オプション一覧

storageLocationselectList

ArrayList storageLocationselectList
保管場所の選択オプション一覧

salesOrganisationSelectionList

ArrayList salesOrganisationSelectionList
販売組織の選択オプション一覧

distributionChannelSelectionList

ArrayList distributionChannelSelectionList
流通チャネルの選択オプション一覧

matnrListList

ArrayList matnrListList
品目コードと品目テキスト一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController は MaterialGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController は MaterialSaveReplica を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strDescrLow

String strDescrLow
開始品目テキスト

strDescrHigh

String strDescrHigh
品目テキスト

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMaterial

String strMaterial
品目コード

strMatlDesc

String strMatlDesc
品目テキスト

strMaterialExternal

String strMaterialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

strMaterialGuid

String strMaterialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

strMaterialVersion

String strMaterialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strMatnrLow

String strMatnrLow
開始品目コード

strMatnrHigh

String strMatnrHigh
終了品目コード

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseComponents は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseConfirmation は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistory は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseHistoryTotals は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShipping は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseShippingExp は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.Partner は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPartnerdesc

String strPartnerdesc
言語別取引先機能テキスト

strLangu

String strLangu
言語キー

strBuspartno

String strBuspartno
取引先の仕入先マスタコード

strDeleteInd

String strDeleteInd
削除フラグ

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strPlantLow

String strPlantLow
対象プラント 開始

strPlantHigh

String strPlantHigh
対象プラント 終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strFieldname

String strFieldname
項目名

strValue

String strValue
CO-PA 特性値

prIndex

int prIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strDeleteInd

String strDeleteInd
削除フラグ: 購買伝票勘定設定

strCreatDate

String strCreatDate
レコード登録日

strQuantity

String strQuantity
数量

strDistrPerc

String strDistrPerc
配賦率 % (複数勘定設定)

strNetValue

String strNetValue
BAPI の通貨額 (小数点以下９桁)

strGlAccount

String strGlAccount
G/L 勘定コード

strBusArea

String strBusArea
事業領域

strCostcenter

String strCostcenter
原価センタ

strSdDoc

String strSdDoc
販売管理伝票番号

strItmNumber

String strItmNumber
販売伝票明細

strSchedLine

String strSchedLine
納入日程行

strAssetNo

String strAssetNo
資産番号

strSubNumber

String strSubNumber
資産補助番号

strOrderid

String strOrderid
指図番号

strGrRcpt

String strGrRcpt
受領者

strUnloadPt

String strUnloadPt
荷渡ポイント

strCoArea

String strCoArea
管理領域

strCostobject

String strCostobject
原価対象

strProfitCtr

String strProfitCtr
利益センタ

strWbsElement

String strWbsElement
WBS 要素

strNetwork

String strNetwork
勘定割当のネットワーク番号

strRlEstKey

String strRlEstKey
不動産管理対象の内部キー

strPartAcct

String strPartAcct
取引先勘定コード

strCmmtItem

String strCmmtItem
資金予算コード

strRecInd

String strRecInd
リカバリフラグ

strFundsCtr

String strFundsCtr
予算センタ

strFund

String strFund
会計区分

strFuncArea

String strFuncArea
機能領域

strRefDate

String strRefDate
決済の参照日付

strTaxCode

String strTaxCode
消費税コード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strNondItax

String strNondItax
BAPI の通貨額 (小数点以下９桁)

strActtype

String strActtype
活動タイプ

strCoBusproc

String strCoBusproc
業務プロセス

strResDoc

String strResDoc
用途指定予算の伝票番号

strResItem

String strResItem
用途指定予算: 伝票明細

strActivity

String strActivity
作業番号

strGrantNbr

String strGrantNbr
補助金

strCmmtItemLong

String strCmmtItemLong
資金予算コード

strFuncAreaLong

String strFuncAreaLong
機能領域

acIndex

int acIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseComponents は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSchedLine

String strSchedLine
納入日程行

strItemNo

String strItemNo
入出庫予定/従属所要量の明細番号

strMaterial

String strMaterial
品目コード

strEntryQuantity

String strEntryQuantity
構成品目の所要量

strEntryUom

String strEntryUom
入力単位

strEntryUomIso

String strEntryUomIso
入力単位 (ISO コード)

strFixedQuan

String strFixedQuan
数量固定

strPlant

String strPlant
プラント

strReqDate

String strReqDate
構成品目の所要日付

strChangeId

String strChangeId
変更タイプ(U、I、E、D)

strMaterialExternal

String strMaterialExternal
項目 MATERIAL の品目コード (長)

strMaterialGuid

String strMaterialGuid
項目 MATERIAL の外部 GUID

strMaterialVersion

String strMaterialVersion
項目 MATERIAL のバージョン番号

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseConfirmation は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strConfSer

String strConfSer
仕入先確認の連続番号

strConfType

String strConfType
確認カテゴリ

strConfName

String strConfName
確認カテゴリ: テキスト

strDelDatcat

String strDelDatcat
仕入先確認における納入期日の日付カテゴリ

strDelDatcatExt

String strDelDatcatExt
納入期日カテゴリ

strDelivDate

String strDelivDate
仕入先確認の納入日付

strDelivTime

String strDelivTime
仕入先確認の納入日時

strQuantity

String strQuantity
仕入先確認による数量

strDeleteInd

String strDeleteInd
区分: 仕入先確認削除

strDispoRel

String strDispoRel
区分: MRP 関連の確認

strReceiptRel

String strReceiptRel
区分: 入庫関連の確認

strExtDoc

String strExtDoc
仕入先確認の外部伝票番号

strDelivNumb

String strDelivNumb
出荷伝票

strDelivItem

String strDelivItem
出荷明細

strExtDocLong

String strExtDocLong
参照伝票番号 (依存性についてはテキスト長参照)

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strRelGroup

String strRelGroup
承認グループ

strRelCode

String strRelCode
承認コード

strItemsForRelease

String strItemsForRelease
区分: 承認待ち購買発注のみ照会

purchaseHeadersList

ArrayList purchaseHeadersList
ヘッダ一覧

purchaseItemsList

ArrayList purchaseItemsList
明細一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

purchaseGetItemSrel

PurchaseGetItemSrel purchaseGetItemSrel
購買承認対象一覧情報クラス

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strDocType

String strDocType
伝票タイプ

strDeleteInd

String strDeleteInd
削除フラグ

strStatus

String strStatus
ステータス

strCreatedBy

String strCreatedBy
登録者名

strItemIntvl

String strItemIntvl
明細番号間隔

strVendor

String strVendor
仕入先勘定コード

strPmnttrms

String strPmnttrms
支払条件キー

strDscnt1To

String strDscnt1To
現金割引日数1

strDscnt2To

String strDscnt2To
現金割引日数2

strDscnt3To

String strDscnt3To
現金割引日数3

strPurchOrg

String strPurchOrg
購買組織

strPurGroup

String strPurGroup
購買グループ

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO通貨コード

strExchRate

String strExchRate
換算レート

strExRateFx

String strExRateFx
換算レート固定区分

strDocDate

String strDocDate
購買伝票日付

strVperStart

String strVperStart
有効期間開始日

strVperEnd

String strVperEnd
有効期間終了日

strWarranty

String strWarranty
保証日

strQuotation

String strQuotation
見積番号

strQuotDate

String strQuotDate
見積提出日

strRef1

String strRef1
得意先/仕入先の内部参照コード

strSalesPers

String strSalesPers
仕入先営業担当者

strTelephone

String strTelephone
仕入先電話番号

strSupplVend

String strSupplVend
供給仕入先

strCustomer

String strCustomer
得意先コード1

strAgreement

String strAgreement
購買契約番号

strGrMessage

String strGrMessage
入庫メッセージ区分

strSupplPlnt

String strSupplPlnt
在庫転送オーダーにおける供給(出庫)プラント

strIncoterms1

String strIncoterms1
インコタームズ1

strIncoterms2

String strIncoterms2
インコタームズ2

strDiffInv

String strDiffInv
仕入先と請求元が異なる場合の請求書元コード

strOurRef

String strOurRef
社内参照番号

strLogsystem

String strLogsystem
論理システム

strSubitemint

String strSubitemint
副明細の明細間隔

strRelStatus

String strRelStatus
承認状況

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost は PurchaseHeader を拡張し、Serializable を実装しています

直列化されたフィールド

strCompCode

String strCompCode
会社コード

strCreatDate

String strCreatDate
レコード登録日

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
言語キーの ISO コード

strDsctPct1

String strDsctPct1
割引率 1

strDsctPct2

String strDsctPct2
割引率 2

strCollectNo

String strCollectNo
一括番号

strPoRelInd

String strPoRelInd
承認区分: 購買伝票

strVatCntry

String strVatCntry
売上税 ID 番号国

strVatCntryIso

String strVatCntryIso
消費税登録番号の ISO 国コード

strReasonCancel

String strReasonCancel
取消理由

strReasonCode

String strReasonCode
Goods Receipt Reason Code

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders は PurchaseHeader を拡張し、Serializable を実装しています

直列化されたフィールド

strCoCode

String strCoCode
会社コード

strDocCat

String strDocCat
購買伝票カテゴリ

strCntrlInd

String strCntrlInd
購買伝票タイプに対する管理区分

strCreatedOn

String strCreatedOn
レコード登録日

strLastItem

String strLastItem
最終明細番号

strLanguage

String strLanguage
言語キー

strCashDisc1

String strCashDisc1
割引率 1

strCashDisc2

String strCashDisc2
割引率 2

strApplicBy

String strApplicBy
見積提出期限

strQuotDead

String strQuotDead
見積提出期限

strBindgPer

String strBindgPer
見積有効期間

strBidinvNo

String strBidinvNo
見積管理番号

strRejReason

String strRejReason
見積および受注の拒否理由

strComplDlv

String strComplDlv
全購買発注に対する一括納入指定

strRcvgVend

String strRcvgVend
未使用項目

strTargetVal

String strTargetVal
累積計画金額

strCollNo

String strCollNo
一括番号

strDocCond

String strDocCond
伝票条件番号

strProcedure

String strProcedure
決定表 (価格設定/出力管理/勘定設定/原価計算など)

strUpdateGrp

String strUpdateGrp
統計更新の更新グループ

strExportNo

String strExportNo
貿易データ番号: MM/SD 伝票

strMastCond

String strMastCond
期間依存条件伝票

strRelGroup

String strRelGroup
承認グループ

strRelStrat

String strRelStrat
承認方針

strRelInd

String strRelInd
承認区分: 購買伝票

strSubjToR

String strSubjToR
承認未完了

strTaxrCntry

String strTaxrCntry
納税申告書の国

strSchedInd

String strSchedInd
分納契約のリリース伝票区分

strVendName

String strVendName
名称 1

strExchRateCm

String strExchRateCm
間接呼び値換算レート

strHold

String strHold
購買発注の不完全

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistory は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strProcessId

String strProcessId
購買発注履歴取引タイプ

strDocYear

String strDocYear
入出庫伝票年

strMatDoc

String strMatDoc
入出庫伝票番号

strMatdocItm

String strMatdocItm
入出庫伝票の明細

strHistType

String strHistType
購買発注履歴カテゴリ

strMoveType

String strMoveType
移動タイプ (在庫管理)

strPstngDate

String strPstngDate
伝票の転記日付

strQuantity

String strQuantity
数量

strValLoccur

String strValLoccur
国内通貨額

strValForcur

String strValForcur
伝票通貨額

strCurrency

String strCurrency
通貨コード

strClValLoc

String strClValLoc
国内通貨による入庫/請求仮勘定決済金額

strBlockedQy

String strBlockedQy
発注単位の入庫保留在庫

strBlQty

String strBlQty
入庫保留在庫数量 (発注価格単位)

strDbCrInd

String strDbCrInd
借方/貸方フラグ

strValType

String strValType
評価タイプ

strNoMoreGr

String strNoMoreGr
納入完了 区分

strRefDocNo

String strRefDocNo
参照伝票番号

strRefDocYr

String strRefDocYr
参照伝票の会計年度

strRefDoc

String strRefDoc
参照伝票の伝票番号

strRefDocIt

String strRefDocIt
参照伝票の明細

strMoveReas

String strMoveReas
移動理由

strEntryDate

String strEntryDate
会計伝票登録日付

strEntryTime

String strEntryTime
登録時刻

strIvvalLoc

String strIvvalLoc
国内通貨での入力請求額

strIvvalFor

String strIvvalFor
外貨での入力済請求額

strMaterial

String strMaterial
品目コード

strPlant

String strPlant
プラント

strConfSer

String strConfSer
仕入先確認の連続番号

strCondition

String strCondition
伝票条件番号

strTaxCode

String strTaxCode
売上税コード

strDelivQty

String strDelivQty
納品書数量単位の数量

strDelivUnit

String strDelivUnit
納品書の数量単位

strPurMat

String strPurMat
品目コード

strLocCurr

String strLocCurr
国内通貨コード

strBatch

String strBatch
ロット番号

strDocDate

String strDocDate
伝票の伝票日付

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strLocCurrIso

String strLocCurrIso
国内通貨の ISO コード

strDelivUnitIso

String strDelivUnitIso
納品書数量単位の ISO コード

strMaterialExternal

String strMaterialExternal
項目 MATERIAL の品目コード (長)

strMaterialGuid

String strMaterialGuid
項目 MATERIAL の外部 GUID

strMaterialVersion

String strMaterialVersion
項目 MATERIAL のバージョン番号

strPurMatExternal

String strPurMatExternal
項目 PUR_MAT の品目コード (長)

strPurMatGuid

String strPurMatGuid
項目 PUR_MAT の外部 GUID

strPurMatVersion

String strPurMatVersion
項目 PUR_MAT のバージョン番号

strRefDocNoLong

String strRefDocNoLong
参照伝票番号 (依存性についてはテキスト長参照)

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHistoryTotals は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strWithdrQty

String strWithdrQty
出庫量

strBlockedQy

String strBlockedQy
発注単位の入庫保留在庫

strBlQty

String strBlQty
入庫保留在庫数量 (発注価格単位)

strDelivQty

String strDelivQty
入庫数量

strPoPrQnt

String strPoPrQnt
購買発注価格単位での数量

strValGrLoc

String strValGrLoc
国内通貨による入庫額

strValGrFor

String strValGrFor
外国通貨での入庫額

strIvQty

String strIvQty
請求数量

strIvQtyPo

String strIvQtyPo
購買価格数量単位による請求数量

strValIvLoc

String strValIvLoc
国内通貨による請求額

strValIvFor

String strValIvFor
外貨による請求額

strClValLoc

String strClValLoc
国内通貨による入庫/請求仮勘定決済金額

strClValFor

String strClValFor
外貨による入庫/請求仮勘定決済金額

strDopVlLoc

String strDopVlLoc
国内通貨による前払金合計

strIvvalLoc

String strIvvalLoc
国内通貨での入力請求額

strIvvalFor

String strIvvalFor
外貨での入力済請求額

strDlQtyTrsp

String strDlQtyTrsp
納入済数量 (在庫転送)

strBlQtyTotal

String strBlQtyTotal
発注単位による入庫保留在庫 (絶対額)

strDlQtyTotal

String strDlQtyTotal
入庫数量: 絶対額

strIvQtyTotal

String strIvQtyTotal
請求書受領数量: 絶対額

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
明細番号

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strShortText

String strShortText
品目コードテキスト（短）

strMaterial

String strMaterial
品目コード

strMaterialExternal

String strMaterialExternal
品目コード（長）

strMaterialGuid

String strMaterialGuid
品目コードの外部GUID

strMaterialVersion

String strMaterialVersion
品目コードのバージョン番号

strPlant

String strPlant
プラント

strTrackingno

String strTrackingno
購買依頼追跡番号

strInfoRec

String strInfoRec
購買情報番号

strVendMat

String strVendMat
仕入先が使用している品目コード

strPoUnitIso

String strPoUnitIso
ISOコードによる発注単位

strOrderprUn

String strOrderprUn
購買発注価格単位

strOrderprUnIso

String strOrderprUnIso
購買発注価格のISOコード

strConvNum1

String strConvNum1
購買価格単位から購買発注単位への変換分子

strConvDen1

String strConvDen1
購買価格単位から購買発注単位への変換分母

strNetPrice

String strNetPrice
通貨額

strPriceUnit

String strPriceUnit
価格単位

strTaxCode

String strTaxCode
消費税コード

strQualInsp

String strQualInsp
在庫タイプ

strValType

String strValType
評価タイプ

strNoMoreGr

String strNoMoreGr
納入完了区分

strItemCat

String strItemCat
購買伝票の明細カテゴリ

strAcctasscat

String strAcctasscat
勘定設定カテゴリ

strDistrib

String strDistrib
複数勘定設定の配賦区分

strPartInv

String strPartInv
一部請求区分

strAcknReqd

String strAcknReqd
購買発注請求書依頼

strAgreement

String strAgreement
購買契約番号

strAgmtItem

String strAgmtItem
購買契約の明細番号

strShipping

String strShipping
出荷指示

strPlanDel

String strPlanDel
予定納入日数

strKanbanInd

String strKanbanInd
かんばん区分

strRetItem

String strRetItem
返品明細

strAtRelev

String strAtRelev
適当テーブル関連

strPreqName

String strPreqName
購買依頼者名/要求者名

strPckgNo

String strPckgNo
パッケージ番号

strNoRounding

String strNoRounding
購買発注明細での非表示丸め

strPoPrice

String strPoPrice
価格採用区分

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost は PurchaseItem を拡張し、Serializable を実装しています

直列化されたフィールド

strEmaterial

String strEmaterial
品目コード

strEmaterialExternal

String strEmaterialExternal
品目コード（長）

strEmaterialGuid

String strEmaterialGuid
品目コードの外部GUID

strEmaterialVersion

String strEmaterialVersion
品目コードのバージョン番号

strStgeLoc

String strStgeLoc
保管場所

strMatlGroup

String strMatlGroup
品目グループ

strQuantity

String strQuantity
購買発注数量

strPoUnit

String strPoUnit
発注単位

strGrPrTime

String strGrPrTime
入庫処理日数

strBonGrp1

String strBonGrp1
決済グループ1

strInfoUpd

String strInfoUpd
購買情報更新区分

strPrntPrice

String strPrntPrice
価格印刷

strEstPrice

String strEstPrice
概算価格区分

strReminder1

String strReminder1
第一回催促状/督促状の日数

strReminder2

String strReminder2
第二回催促状/督促状の日数

strReminder3

String strReminder3
第三回催促状/督促状の日数

strOverDlvTol

String strOverDlvTol
過剰納入許容範囲

strUnlimitedDlv

String strUnlimitedDlv
区分: 無制限過剰納入可能

strUnderDlvTol

String strUnderDlvTol
不足納入許容範囲リミット

strFinalInv

String strFinalInv
請求書処理完了区分

strGrInd

String strGrInd
入庫区分

strGrNonVal

String strGrNonVal
非評価入庫

strIrInd

String strIrInd
請求書受領区分

strFreeItem

String strFreeItem
無償明細

strGrBasediv

String strGrBasediv
入庫基準の請求書照合区分

strAcknowlNo

String strAcknowlNo
購買発注請書番号

strCustomer

String strCustomer
得意先コード

strCondGroup

String strCondGroup
仕入先条件グループ

strNoDisct

String strNoDisct
現金値引対象外明細

strNetWeight

String strNetWeight
正味重量

strWeightunit

String strWeightunit
重量単位

strWeightunitIso

String strWeightunitIso
重量単位のISOコード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strCtrlKey

String strCtrlKey
調達における品質管理の管理キー

strConfCtrl

String strConfCtrl
確認管理キー

strRevLev

String strRevLev
改訂レベル

strFund

String strFund
会計区分

strFundsCtr

String strFundsCtr
予算センタ

strCmmtItem

String strCmmtItem
資金予算コード

strPricedate

String strPricedate
価格設定日カテゴリ (価格設定日管理)

strPriceDate

String strPriceDate
価格設定日

strGrossWt

String strGrossWt
総重量

strVolume

String strVolume
容積

strVolumeunit

String strVolumeunit
容積単位

strVolumeunitIso

String strVolumeunitIso
ISO コードでの容積単位

strIncoterms1

String strIncoterms1
インコタームズ (1)

strIncoterms2

String strIncoterms2
インコタームズ 2

strPreVendor

String strPreVendor
製造元/販売元

strVendPart

String strVendPart
仕入先部門

strHlItem

String strHlItem
購買伝票中の上位明細

strGrToDate

String strGrToDate
納入最終期限

strSuppVendor

String strSuppVendor
供給仕入先/仕入入庫

strScVendor

String strScVendor
外注仕入先

strErs

String strErs
ERS（入庫/請求自動決済）

strRPromo

String strRPromo
プロモーション

strPoints

String strPoints
リベートポイント数

strPointUnit

String strPointUnit
ポイント単位

strPointUnitIso

String strPointUnitIso
ポイント単位の ISO コード

strSeason

String strSeason
季節カテゴリ

strSeasonYr

String strSeasonYr
シーズン年度

strBonGrp2

String strBonGrp2
決済グループ 2 (リベート決済、購買)

strBonGrp3

String strBonGrp3
決済グループ 3 (リベート決済、購買)

strSettItem

String strSettItem
リベート (期末) 決済対象の明細

strMinremlife

String strMinremlife
最低有効期間残

strRfqNo

String strRfqNo
見積依頼番号

strRfqItem

String strRfqItem
見積依頼明細番号

strPreqNo

String strPreqNo
購買依頼番号

strPreqItem

String strPreqItem
購買依頼の明細番号

strRefDoc

String strRefDoc
参照伝票番号

strRefItem

String strRefItem
参照伝票の明細

strSiCat

String strSiCat
補助明細カテゴリ、購買伝票

strOrderReason

String strOrderReason
発注理由

strBrasNbm

String strBrasNbm
Brazilian NCM Code

strMatlUsage

String strMatlUsage
品目の用途

strMatOrigin

String strMatOrigin
品目の原産地

strInHouse

String strInHouse
内部生産

strIndus3

String strIndus3
品目 CFOP カテゴリ

strInfIndex

String strInfIndex
インフレーション指数

strUntilDate

String strUntilDate
インフレーション指数日付

strDelivCompl

String strDelivCompl
出荷完了 区分

strPartDeliv

String strPartDeliv
明細レベルでの分割納入 (在庫転送)

strShipBlocked

String strShipBlocked
SD 出荷伝票の明細ブロック

strPeriodIndExpirationDate

String strPeriodIndExpirationDate
有効期間期限日の期間区分

strIntObjNo

String strIntObjNo
選定 (内部オブジェクト番号)

strBatch

String strBatch
ロット番号

strVendrbatch

String strVendrbatch
仕入先ロット番号

strCalctype

String strCalctype
価格設定タイプ

strGrantNbr

String strGrantNbr
補助金

strCmmtItemLong

String strCmmtItemLong
資金予算コード

strFuncAreaLong

String strFuncAreaLong
機能領域

strSupplStloc

String strSupplStloc
出庫保管場所: 在庫転送オーダー

strSrvBasedIv

String strSrvBasedIv
サービス基準請求書照合の区分

strFundsRes

String strFundsRes
予算執行伝票の伝票番号

strResItem

String strResItem
用途指定予算: 伝票明細

strOrigAccept

String strOrigAccept
仕入先構内での受領

strAllocTbl

String strAllocTbl
商品配分表番号

strAllocTblItem

String strAllocTblItem
割当テーブルの明細番号

strSrcStockType

String strSrcStockType
在庫転送オーダーの元保管場所在庫タイプ

strReasonRej

String strReasonRej
見積および受注の拒否理由

strCrmSalesOrderNo

String strCrmSalesOrderNo
仕入先直送発注処理の CRM 受注番号

strCrmSalesOrderItemNo

String strCrmSalesOrderItemNo
仕入先直送発注処理での CRM 受注明細番号

strCrmRefSalesOrderNo

String strCrmRefSalesOrderNo
仕入先直送発注処理の CRM 参照受注番号

strCrmRefSoItemNo

String strCrmRefSoItemNo
仕入先直送発注処理での CRM 参照受注明細番号

strPrioUrgency

String strPrioUrgency
所要量の緊急度

strPrioRequirement

String strPrioRequirement
所要量の優先順位

strReasonCode

String strReasonCode
Goods Receipt Reason Code

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems は PurchaseItem を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strAddress

String strAddress
住所

strPurMat

String strPurMat
品目コード

strStoreLoc

String strStoreLoc
保管場所

strMatGrp

String strMatGrp
品目グループ

strAllocTbl

String strAllocTbl
商品配分表番号

strAtItem

String strAtItem
割当テーブルの明細番号

strUnit

String strUnit
発注単位

strPromotion

String strPromotion
プロモーション

strManufProf

String strManufProf
製造者製品プロファイル

strManuMat

String strManuMat
製造者製品コード

strMfrNo

String strMfrNo
製造者番号

strMfrNoExt

String strMfrNoExt
外部製造者コード名または番号

strItemCatExt

String strItemCatExt
購買伝票の明細カテゴリ

strDispQuan

String strDispQuan
購買発注数量: 表示目的全納入日程合計

strPurMatExternal

String strPurMatExternal
項目 PURMAT の品目コード (長) (今後のリリースで開発)

strPurMatGuid

String strPurMatGuid
項目 PURMAT の外部 GUID (今後のリリースで開発)

strPurMatVersion

String strPurMatVersion
項目 PURMAT のバージョン番号 (今後のリリースで開発)

strPrClosed

String strPrClosed
購買依頼処理済

strAcknowlNo

String strAcknowlNo
購買発注請書番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

poNumber

String poNumber
購買伝票番号

testRun

String testRun
テスト区分

memoryUnComplete

String memoryUnComplete
エラーがある場合に購買発注を保留する区分

memoryComplete

String memoryComplete
エラーがない場合に購買発注を保留する区分

noMessaging

String noMessaging
出力決定なし区分

noMessageReq

String noMessageReq
メッセージ不要区分

noAuthority

String noAuthority
権限チェックなし区分

noPriceFromPo

String noPriceFromPo
最終伝票からの価格転送なし区分

documentHeader

PurchaseHeaderPost documentHeader
伝票ヘッダ

supplierInfo

VendorAddress supplierInfo
仕入先住所

exportHeader

ExportHeader exportHeader
貿易管理ヘッダ

versions

Versions versions
バージョン管理

purchaseItemPostList

ArrayList purchaseItemPostList
明細一覧

deliveryAddressList

ArrayList deliveryAddressList
入荷伝票アドレス一覧

purchaseScheduleList

ArrayList purchaseScheduleList
納入日程一覧

purchaseAccountList

ArrayList purchaseAccountList
勘定設定一覧

profitSegmentList

ArrayList profitSegmentList
入出庫予定一覧

condHeaderList

ArrayList condHeaderList
条件ヘッダ一覧

condItemList

ArrayList condItemList
条件明細一覧

limitsList

ArrayList limitsList
外注制限一覧

contractLimitsList

ArrayList contractLimitsList
外注基本契約制限一覧

contractServiceList

ArrayList contractServiceList
外注サービス一覧

contractServiceAccountList

ArrayList contractServiceAccountList
外注サービス勘定設定一覧

contractServiceTextList

ArrayList contractServiceTextList
外注サービステキスト一覧

extensionList

ArrayList extensionList
拡張得意先項目一覧

exportItemList

ArrayList exportItemList
貿易管理明細一覧

headerTextList

ArrayList headerTextList
ヘッダテキスト一覧

itemTextList

ArrayList itemTextList
明細テキスト一覧

partnerList

ArrayList partnerList
取引先一覧

allVersionsList

ArrayList allVersionsList
全バージョン一覧

purchaseShippingList

ArrayList purchaseShippingList
出荷データ

purchaseShippingExpList

ArrayList purchaseShippingExpList
出荷データのエクスポート

purchaseComponentsList

ArrayList purchaseComponentsList
コンポーネント

purchaseConfirmationList

ArrayList purchaseConfirmationList
転送構造：照会／一覧

purchaseHistoryList

ArrayList purchaseHistoryList
購買発注履歴

purchaseHistoryTotalsList

ArrayList purchaseHistoryTotalsList
購買発注履歴(合計)

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController は PurchaseOrderPayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController は PurchaseOrderPayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

strPurchaseorder

String strPurchaseorder
購買発注番号

strPoRelCode

String strPoRelCode
承認コード

strUseExceptions

String strUseExceptions
例外メッセージ設定とエラーメッセージ出力

strNoCommit

String strNoCommit
コミットワーク はい/いいえ

strRelStatusNew

String strRelStatusNew
返却承認状況

strRelIndicatorNew

String strRelIndicatorNew
返却規承認区分

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController は PurchaseRelease を拡張し、Serializable を実装しています

直列化されたフィールド

strRetCode

String strRetCode
リターン値、ABAP 命令後のリターン値

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController は PurchaseRelease を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSchedLine

String strSchedLine
納入日程行

strDelDatcatExt

String strDelDatcatExt
納入期日カテゴリ

strDeliveryDate

String strDeliveryDate
納入期日

strQuantity

String strQuantity
計画数量

strDelivTime

String strDelivTime
納入期日における指定時間

strStatDate

String strStatDate
統計的納入期日

strPreqNo

String strPreqNo
購買依頼番号

strPreqItem

String strPreqItem
購買依頼の明細番号

strPoDate

String strPoDate
納入日程の購買発注日付

strRoutesched

String strRoutesched
輸送経路計画

strMsDate

String strMsDate
品目利用可能日

strMsTime

String strMsTime
品目供給ステージ (現地時刻: プラント参照)

strLoadDate

String strLoadDate
積載日付

strLoadTime

String strLoadTime
積載時刻 (現地時間: 出荷ポイント)

strTpDate

String strTpDate
輸送計画日付

strTpTime

String strTpTime
輸送計画 - 時間 (現地時間/出荷ポイント参照)

strGiDate

String strGiDate
出庫日付

strGiTime

String strGiTime
出庫時刻 (現地時間 - プラント参照)

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strReqClosed

String strReqClosed
購買依頼処理済

strGrEndDate

String strGrEndDate
入庫終了日付

strGrEndTime

String strGrEndTime
入庫終了時刻 (ローカル、プラントに関連)

strComQty

String strComQty
確認数量

strComDate

String strComDate
確認日

scIndex

int scIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShipping は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strShipPoint

String strShipPoint
出荷ポイント/入荷ポイント

strDlvPrio

String strDlvPrio
出荷優先順位

strRoute

String strRoute
輸送経路

strShipCond

String strShipCond
出荷条件

strUnloadPt

String strUnloadPt
荷渡ポイント

strAuthNumber

String strAuthNumber
返品権限番号

strSrcDlvNo

String strSrcDlvNo
元出荷番号

strSrcHandlgUnit

String strSrcHandlgUnit
元/先 荷役単位 (外部 ID)

strInspoutGuid

String strInspoutGuid
品質検査結果： EWM 設定の在庫 GUID

strFollowUp

String strFollowUp
デフォルト後続アクティビティコード

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseShippingExp は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strShipPoint

String strShipPoint
出荷ポイント/入荷ポイント

strDlvPrio

String strDlvPrio
出荷優先順位

strRoute

String strRoute
輸送経路

strCustomer

String strCustomer
得意先コード 1

strSoldTo

String strSoldTo
受注先

strFwdagent

String strFwdagent
海貨業者

strSalesorg

String strSalesorg
販売組織

strDistrChan

String strDistrChan
流通チャネル

strDivision

String strDivision
製品部門

strDelCreateDate

String strDelCreateDate
出荷登録日付

strPlndDelry

String strPlndDelry
予定納入時間 (単位: 日)

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
言語キーの ISO コード

strShipCond

String strShipCond
出荷条件

strLoadinggrp

String strLoadinggrp
積載グループ

strTransGrp

String strTransGrp
輸送グループ

strUnloadPt

String strUnloadPt
荷渡ポイント

strOrdcombind

String strOrdcombind
受注結合区分

strTimeZone

String strTimeZone
出荷場所のタイムゾーン

strAuthNumber

String strAuthNumber
返品権限番号

strSrcDlvNo

String strSrcDlvNo
元出荷番号

strSrcHandlgUnit

String strSrcHandlgUnit
元/先 荷役単位 (外部 ID)

strInspoutGuid

String strInspoutGuid
品質検査結果： EWM 設定の在庫 GUID

strFollowUp

String strFollowUp
デフォルト後続アクティビティコード

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strPoItem

String strPoItem
購買伝票の明細番号

strTextId

String strTextId
テキスト ID

strTextForm

String strTextForm
タグ列

strTextLine

String strTextLine
テキスト行

teIndex

int teIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strSalesorgLow

String strSalesorgLow
販売組織の範囲開始

strSalesorgHigh

String strSalesorgHigh
販売組織の範囲終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strSign

String strSign
選択演算子 SIGN (テーブル範囲)

strOption

String strOption
選択演算子 OPTION (範囲テーブル)

クラス jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

stdIntNumList

StdMaterialGetIntNumberList stdIntNumList
品目コード割当済一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strStlocLow

String strStlocLow
開始保管場所

strStlocHigh

String strStlocHigh
終了保管場所

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
実行パラメータ(仕入先コード)

strCompode

String strCompode
実行パラメータ(会社コード)

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
実行パラメータ(仕入先コード)

strCompCode

String strCompCode
実行パラメータ(会社コード)

checkReturn

String checkReturn
返却値

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

supplierDetail

SupplierDetail supplierDetail
仕入先マスタ詳細情報

クラス jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress は GeneralDataInfo を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strAddrNo

String strAddrNo
アドレス番号

strCOName

String strCOName
気付

strCityNo

String strCityNo
市区町村/地名ファイルの市区町村コード

strPostlCod1

String strPostlCod1
市区町村の郵便番号

strPostlCod2

String strPostlCod2
私書箱郵便番号

strPostlCod3

String strPostlCod3
会社郵便番号 (大規模なユーザ用)

strPoBoxCit

String strPoBoxCit
私書箱住所

strDelivDis

String strDelivDis
郵便配達地域

strStreetNo

String strStreetNo
市区町村/地名ファイルの地名コード

strStrAbbr

String strStrAbbr
地名の略称 (例: スペイン)

strHouseNo

String strHouseNo
番地-号

strStrSuppl1

String strStrSuppl1
地名 2

strStrSuppl2

String strStrSuppl2
地名 3

strLocation

String strLocation
地名 5

strBuilding

String strBuilding
旧: 建物 (番号または略称)

strFloor

String strFloor
建物の階

strRoomNo

String strRoomNo
部屋/アパート番号

strSort1

String strSort1
検索条件 1

strSort2

String strSort2
検索条件 2

strTimeZone

String strTimeZone
アドレスタイムゾーン

strTaxjurcode

String strTaxjurcode
税管轄コード

strAdrNotes

String strAdrNotes
住所注記

strCommType

String strCommType
通信方法 (キー) (アドレス管理)

strTel1Numbr

String strTel1Numbr
第一電話番号: ダイヤルコード + 番号

strTel1Ext

String strTel1Ext
第 1 電話番号: 内線

strFaxNumber

String strFaxNumber
第一 FAX 番号: ダイヤルコード + 番号

strFaxExtens

String strFaxExtens
第一 FAX 番号: 内線

strStreetLng

String strStreetLng
地名

strDistrctNo

String strDistrctNo
市区町村/地名ファイルの所在地コード

strChckstatus

String strChckstatus
市区町村ファイルテストステータス

strPboxcitNo

String strPboxcitNo
市区町村私書箱コード (市ファイル)

strTranspzone

String strTranspzone
商品の納入区域

strHouseNo2

String strHouseNo2
番地補足

strEMail

String strEMail
電子メールアドレス

strStrSuppl3

String strStrSuppl3
地名 4

strTitle

String strTitle
タイトル (敬称)

strBuildLong

String strBuildLong
建物 (番号またはコード)

strRegiogroup

String strRegiogroup
地域構造グループ化

クラス jp.co.intra_mart.foundation.sap.module.purchase.Versions は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPostDate

String strPostDate
バージョンの転記日付

strCompleted

String strCompleted
ステータス "バージョン完了済"

strReason

String strReason
変更理由

strDescription

String strDescription
バージョンテキスト（長）

strReqBy

String strReqBy
変更を依頼した従業員

strReqByExt

String strReqByExt
バージョンの外部変更番号

strActivity

String strActivity
処理タイプ（SAP ERP6.0 では使用されない項目です。）

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

indSector

String indSector
産業コード

matlType

String matlType
品目タイプ

createdOn

String createdOn
登録日付

createdBy

String createdBy
オブジェクト登録者名

lastChnge

String lastChnge
最終変更日付

changedBy

String changedBy
オブジェクトの変更者名

matStatus

String matStatus
品目更新完了ステータス

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
クライアントレベルでの品目削除フラグ

matlGroup

String matlGroup
品目グループ

oldMatNo

String oldMatNo
旧品目コード

baseUom

String baseUom
基本数量単位

baseUomIso

String baseUomIso
ISO コードでの基本数量単位

poUnit

String poUnit
発注単位

poUnitIso

String poUnitIso
ISO コードによる発注単位

document

String document
文書番号 (文書管理システムによらない)

docType

String docType
文書タイプ (文書管理システムによらない)

docVers

String docVers
文書バージョン (文書管理システムによらない)

docFormat

String docFormat
文書のページ書式 (文書管理システムによらない)

docChgNo

String docChgNo
文書変更番号 (文書管理システム外)

pageNo

String pageNo
文書ページ番号 (文書管理システムによらない)

noSheets

String noSheets
文書枚数 (文書管理システムによらない)

prodMemo

String prodMemo
製造/検査メモ

pageformat

String pageformat
製造メモのページ書式

sizeDim

String sizeDim
サイズ/寸法

basicMatl

String basicMatl
主構成物質

stdDescr

String stdDescr
標準テキスト (ANSI、ISO など)

dsnOffice

String dsnOffice
研究室/設計室

purValkey

String purValkey
購買許容値キー

netWeight

String netWeight
正味重量

unitOfWt

String unitOfWt
重量単位

unitOfWtIso

String unitOfWtIso
ISO コードでの重量単位

container

String container
容器条件

storConds

String storConds
保管条件

tempConds

String tempConds
温度条件区分

transGrp

String transGrp
輸送グループ

hazMatNo

String hazMatNo
危険物コード

division

String division
製品部門

competitor

String competitor
競合会社

qtyGrGi

String qtyGrGi
数量: 印刷予定入出庫票数

procRule

String procRule
調達規則

supSource

String supSource
供給元

season

String season
季節カテゴリ

labelType

String labelType
ラベルタイプ

labelForm

String labelForm
ラベル書式

prodHier

String prodHier
品目階層

cadId

String cadId
CAD 区分

allowedWt

String allowedWt
許容梱包重量

packWtUn

String packWtUn
重量単位 (許容梱包重量)

packWtUnIso

String packWtUnIso
ISO コードでの重量単位 (許容梱包重量)

allwdVol

String allwdVol
許容梱包容積

packVoUn

String packVoUn
容積単位 (許容梱包容積)

packVoUnIso

String packVoUnIso
ISO コードでの容積単位 (許容梱包容積)

wtTolLt

String wtTolLt
荷役単位の重量超過許容量

volTolLt

String volTolLt
荷役単位の容積超過許容量

varOrdUn

String varOrdUn
可変購買発注単位有効

configured

String configured
選定可能品目

batchMgmt

String batchMgmt
ロット管理所要量区分

shMatTyp

String shMatTyp
梱包材タイプ

fillLevel

String fillLevel
最大レベル (容積別)

stackFact

String stackFact
山積係数

matGrpSm

String matGrpSm
品目グループ: 梱包材

authoritygroup

String authoritygroup
権限グループ

qmProcmnt

String qmProcmnt
調達における品質管理有効

catprofile

String catprofile
カタログプロファイル

minremlife

String minremlife
最低有効期間残

shelfLife

String shelfLife
総有効期間

storPct

String storPct
残存有効期間割合 %

confMatl

String confMatl
プラント共通選定可能品目

coProduct

String coProduct
区分: 連産品としても使用可能な品目

prRefMat

String prRefMat
価格設定参照品目

purStatus

String purStatus
プラント共通品目ステータス

salStatus

String salStatus
流通チェーン間品目ステータス

pvalidfrom

String pvalidfrom
プラント共通品目のステータス有効開始日付

svalidfrom

String svalidfrom
流通チェーン間品目ステータスの有効開始日付

envtRlvt

String envtRlvt
区分: 環境関連

prodAlloc

String prodAlloc
製品割当決定手順

qualDik

String qualDik
無償納入による割引対象品目

manuMat

String manuMat
製造者製品コード

mfrNo

String mfrNo
製造者番号

invMatNo

String invMatNo
会社固有 (内部) 在庫管理品目コード

manufProf

String manufProf
製造者製品プロファイル

hazmatprof

String hazmatprof
危険物インジケータプロファイル

highVisc

String highVisc
区分: 高粘性

looseorliq

String looseorliq
区分: バルク/液体

closedBox

String closedBox
完了した梱包材

appdBRec

String appdBRec
区分: バッチ製造記録の承認必須

matcmpllvl

String matcmpllvl
品目完了レベル

parEff

String parEff
有効性パラメータへの値割当/変更番号よりも優先

roundUpRuleExpirationDate

String roundUpRuleExpirationDate
有効期間期限日計算の丸め規則

periodIndExpirationDate

String periodIndExpirationDate
有効期間期限日の期間区分

prodCompositionOnPackaging

String prodCompositionOnPackaging
区分: 梱包材にプリントされた生産構造

itemCat

String itemCat
一般明細カテゴリグループ

hazMatNoExternal

String hazMatNoExternal
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)

hazMatNoGuid

String hazMatNoGuid
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

hazMatNoVersion

String hazMatNoVersion
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)

invMatNoExternal

String invMatNoExternal
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)

invMatNoGuid

String invMatNoGuid
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

invMatNoVersion

String invMatNoVersion
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)

materialFixed

String materialFixed
ロックされている品目

cmRelevanceFlag

String cmRelevanceFlag
構成管理関連

sledBbd

String sledBbd
有効期限

gtinVariant

String gtinVariant
グローバルトレード明細番号バリアント

serializationLevel

String serializationLevel
シリアル番号の指定レベル

plRefMat

String plRefMat
梱包方法が同じ品目の参照品目

extmatlgrp

String extmatlgrp
外部品目グループ

uomusage

String uomusage
使用数量単位

gdsRelevant

String gdsRelevant
区分:グローバルデータ同期関連

materialExternal

String materialExternal
項目 MATERIAL の品目コード(長)

materialGuid

String materialGuid
項目 MATERIAL の外部GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

confMatlExternal

String confMatlExternal
項目 CONF_MATL の品目コード(長)

confMatlGuid

String confMatlGuid
項目 CONF_MATL の外部GUID

confMatlVersion

String confMatlVersion
項目 CONF_MATL のバージョン番号

plRefMatExternal

String plRefMatExternal
項目 PL_REF_MAT の品目コード(長)

plRefMatGuid

String plRefMatGuid
項目 PL_REF_MAT の外部GUID

plRefMatVersion

String plRefMatVersion
項目 PL_REF_MAT のバージョン番号

prRefMatExternal

String prRefMatExternal
項目 PR_REF_MAT の品目コード(長)

prRefMatGuid

String prRefMatGuid
項目 PR_REF_MAT の外部GUID

prRefMatVersion

String prRefMatVersion
項目 PR_REF_MAT のバージョン番号

weOriginAcceptance

String weOriginAcceptance
仕入先構内での受領

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList は ClientData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

foreProf

String foreProf
需要予測プロファイル

modelSi

String modelSi
モデル選択区分

modelSp

String modelSp
モデル選択方式

paramOpt

String paramOpt
パラメータ最適化用の区分

optimLev

String optimLev
最適化レベル

initialize

String initialize
初期化区分

foreModel

String foreModel
予測モデル

alphaFact

String alphaFact
アルファ係数使用による基本値の平滑化

betaFact

String betaFact
ベータ係数による傾向値平準化

gammaFact

String gammaFact
ガンマ係数使用の平滑化のための季節指数

deltaFact

String deltaFact
デルタ係数使用による MAD (絶対平均偏差) 平準化

tracklimit

String tracklimit
警告限界

foreDate

String foreDate
最終需要予測日

histVals

String histVals
履歴値の数

initPds

String initPds
初期化で使用する履歴値の数

seasonPds

String seasonPds
季節周期ごとの期間数

expostPds

String expostPds
事後的需要予測に含む履歴値の数

forePds

String forePds
需要予測期間

fixedPds

String fixedPds
固定期間

basicValue

String basicValue
基準値

basicValue1

String basicValue1
第二指図の基準値

basicValue2

String basicValue2
第二指図の基準値

basicValuePp

String basicValuePp
前期間の基準値

basicValuePp1

String basicValuePp1
前期間における第二指図の基準値

basicValuePp2

String basicValuePp2
前期間における第二指図の基準値

trendValue

String trendValue
傾向値

trendValuePp

String trendValuePp
前期間の傾向値

meanAbsolDev

String meanAbsolDev
絶対平均偏差 (MAD)

meanAbsolDevPp

String meanAbsolDevPp
前期間の平均絶対偏差

errorTotal

String errorTotal
エラー合計

errorTotalPp

String errorTotalPp
前期間のエラー合計

wtgGroup

String wtgGroup
加重グループ

coeffTheil

String coeffTheil
タイル係数

exceptList

String exceptList
例外メッセージバー

forecFlowCont

String forecFlowCont
予測フロー管理

periodInd

String periodInd
期間区分

fyVariant

String fyVariant
会計年度バリアント

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList は ForecastParameters を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docDate

String docDate
伝票の伝票日付

headerTxt

String headerTxt
伝票ヘッダテキスト

pstngDate

String pstngDate
伝票の転記日付

refDocNo

String refDocNo
参照伝票番号

refDocNoLong

String refDocNoLong
参照伝票番号 (依存性についてはテキスト長参照)

verGrGiSlip

String verGrGiSlip
入出庫票の印刷バ－ジョン

billOfLading

String billOfLading
入庫時に登録した B/L 番号

grGiSlipNo

String grGiSlipNo
入出庫票番号

prUname

String prUname
ユーザ名

verGrGiSlipx

String verGrGiSlipx
関連ユーザデータ項目の更新情報

extWms

String extWms
外部倉庫管理の転記の制御

billOfLadingLong

String billOfLadingLong
入庫の船荷証券番号 (依存: テキスト (長) 参照)

barCode

String barCode
バーコードエントリ

matDoc

String matDoc
入出庫伝票番号

docYear

String docYear
入出庫伝票年度

trEvType

String trEvType
トランザクション/イベントタイプ

entryDate

String entryDate
会計伝票登録日

entryTime

String entryTime
登録時刻

username

String username
ユーザ名

expimpNo

String expimpNo
貿易データ番号: MM/SD 伝票

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList は GoodsMvtHeader を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activity

String activity
作業番号

acttype

String acttype
活動タイプ

amountLc

String amountLc
マニュアル入力による転記金額 (国内通貨)

amountSv

String amountSv
外部入力による販売金額 (国内通貨)

assetNo

String assetNo
資産番号

batch

String batch
ロット番号

calcMotive

String calcMotive
計算区分

cmmtItem

String cmmtItem
資金予算コード

cmmtItemLong

String cmmtItemLong
資金予算コード

coBusproc

String coBusproc
業務プロセス

compShip

String compShip
出荷指示順守

costObj

String costObj
原価対象

costcenter

String costcenter
原価センタ

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO 通貨コード

customer

String customer
得意先コード

docYear

String docYear
入出庫伝票年度

entryQnt

String entryQnt
入力単位での数量

entryUom

String entryUom
入力単位

entryUomIso

String entryUomIso
単位の ISO コード

expirydate

String expirydate
有効期間期限日

funcAreaLong

String funcAreaLong
機能領域

fund

String fund
会計区分

fundsCtr

String fundsCtr
予算センタ

grRcpt

String grRcpt
受領者

grantNbr

String grantNbr
補助金

itemText

String itemText
明細テキスト

lineDepth

String lineDepth
伝票での明細行階層レベル

lineId

String lineId
伝票明細行の一意 ID

matDoc

String matDoc
入出庫伝票番号

matdocItm

String matdocItm
入出庫伝票の明細

material

String material
品目コード

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

moveBatch

String moveBatch
入庫/出庫ロット

moveMat

String moveMat
入庫/出庫品目

moveMatExternal

String moveMatExternal
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

moveMatGuid

String moveMatGuid
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

moveMatVersion

String moveMatVersion
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

movePlant

String movePlant
入庫/出庫プラント

moveReas

String moveReas
移動理由

moveStloc

String moveStloc
入庫/出庫保管場所

moveType

String moveType
移動タイプ (在庫管理)

moveValType

String moveValType
転送ロットの評価タイプ

mvtInd

String mvtInd
移動区分

network

String network
勘定割当のネットワーク番号

noMoreGr

String noMoreGr
納入完了 区分

orderItno

String orderItno
指図明細番号

orderid

String orderid
指図番号

orderprUn

String orderprUn
購買発注価格単位 (購買管理)

orderprUnIso

String orderprUnIso
単位の ISO コード

parentId

String parentId
1 レベル上位の行 ID

partAcct

String partAcct
取引先勘定コード

plant

String plant
プラント

poItem

String poItem
購買伝票の明細番号

poNumber

String poNumber
購買発注番号

poPrQnt

String poPrQnt
数量 (購買発注価格単位)

prodDate

String prodDate
ロット製造日付

profitCtr

String profitCtr
利益センタ

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

refDate

String refDate
決済の参照日付

refDoc

String refDoc
参照伝票の伝票番号

refDocIt

String refDocIt
参照伝票の明細番号

refDocYr

String refDocYr
参照伝票の会計年度

resItem

String resItem
入出庫予定/従属所要量の明細番号

resType

String resType
レコードタイプ

reservNo

String reservNo
入出庫予定/従属所要量の番号

rlEstKey

String rlEstKey
不動産管理対象の内部キー

sOrdItem

String sOrdItem
受注明細番号

salesOrd

String salesOrd
受注伝票番号

schedLine

String schedLine
受注納入日程

shipping

String shipping
出荷指示

specStock

String specStock
特殊在庫区分

stckType

String stckType
在庫タイプ

stgeLoc

String stgeLoc
保管場所

subNumber

String subNumber
資産補助番号

supplVend

String supplVend
供給仕入先

unloadPt

String unloadPt
荷渡ポイント

valSOrdItem

String valSOrdItem
評価受注在庫の受注明細

valSalesOrd

String valSalesOrd
評価受注在庫の受注番号

valType

String valType
評価タイプ

valWbsElem

String valWbsElem
WBS 要素

vendor

String vendor
仕入先勘定コード

wbsElem

String wbsElem
WBS 要素

withdrawn

String withdrawn
入出庫予定に対する出庫完了

xAutoCre

String xAutoCre
自動登録済み明細

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

matlDesc

String matlDesc
品目テキスト

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialEvg は Object を拡張し、Serializable を実装しています

直列化されたフィールド

materialExt

String materialExt
外部品目コード

materialVers

String materialVers
品目バージョン番号

materialGuid

String materialGuid
品目コード(外部 GUID)

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamMaterialEvg は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

plngMatl

String plngMatl
計画品目

plngPlant

String plngPlant
計画プラント

convfactor

String convfactor
計画品目用変換係数

plngMatlExternal

String plngMatlExternal
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)

plngMatlGuid

String plngMatlGuid
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

plngMatlVersion

String plngMatlVersion
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList は PlanningData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
プラントレベルでの品目削除フラグ

abcId

String abcId
ABC 区分

critPart

String critPart
区分: 重要品目

purGroup

String purGroup
購買グループ

issueUnit

String issueUnit
出庫単位

issueUnitIso

String issueUnitIso
ISO コードでの出庫単位

mrpprofile

String mrpprofile
品目: MRP プロファイル

mrpType

String mrpType
MRP タイプ

mrpCtrler

String mrpCtrler
MRP 管理者

plndDelry

String plndDelry
予定納入時間 (単位: 日)

grPrTime

String grPrTime
入庫処理日数

periodInd

String periodInd
期間区分

assyScrap

String assyScrap
組立不良率

lotsizekey

String lotsizekey
ロットサイズ (品目計画)

procType

String procType
調達タイプ

spproctype

String spproctype
特殊調達タイプ

reorderPt

String reorderPt
発注点

safetyStk

String safetyStk
安全在庫

minlotsize

String minlotsize
最小ロットサイズ

maxlotsize

String maxlotsize
最大ロットサイズ

fixedLot

String fixedLot
固定ロットサイズ

roundVal

String roundVal
購買発注数量の丸め数量

maxStock

String maxStock
最大在庫レベル

ordCosts

String ordCosts
発注原価 (BAPI インタフェース)

depReqId

String depReqId
個別所要量と包括所要量に対する従属所要量区分

storCosts

String storCosts
保管経費区分

altBomId

String altBomId
代替 BOM 選択の方法

discontinu

String discontinu
打切区分

effODay

String effODay
有効終了日

followUp

String followUp
フォローアップ品目

grpReqmts

String grpReqmts
区分: 所要量グループ化

mixedMrp

String mixedMrp
二重 MRP 区分

smKey

String smKey
日程計画余裕キー

backflush

String backflush
区分: バックフラッシュ

productionScheduler

String productionScheduler
製造計画担当

procTime

String procTime
処理時間

setuptime

String setuptime
段取時間と片付け時間

interop

String interop
移動時間

baseQty

String baseQty
基本数量

inhseprodt

String inhseprodt
内製日数

stgeperiod

String stgeperiod
最長保管期間

stgePdUn

String stgePdUn
最長保管期間の単位

stgePdUnIso

String stgePdUnIso
ISO コードでの最長保管期間単位

overTol

String overTol
過剰納入許容範囲リミット

unlimited

String unlimited
区分: 無制限過剰納入可能

underTol

String underTol
不足納入許容範囲リミット

replentime

String replentime
補充リードタイム合計 (稼動日数)

replacePt

String replacePt
取替部品

indPostToInspStock

String indPostToInspStock
品質検査中在庫への転記

ctrlKey

String ctrlKey
調達における品質管理の管理キー

docReqd

String docReqd
文書必須フラグ

loadinggrp

String loadinggrp
積載グループ

batchMgmt

String batchMgmt
ロット管理所要量区分

quotausage

String quotausage
供給量割当の使用

servLevel

String servLevel
サービスレベル

splitInd

String splitInd
分割区分

availcheck

String availcheck
利用可能在庫確認の確認グループ

fyVariant

String fyVariant
会計年度バリアント

corrFact

String corrFact
区分: 修正係数を需要予測値計算に使用

setupTime

String setupTime
出荷準備時間

baseQtyPlan

String baseQtyPlan
出荷の能力計画のための基本数量

shipProcTime

String shipProcTime
出荷処理時間

supSource

String supSource
供給元

autoPOrd

String autoPOrd
区分: "購買発注自動生成"

sourcelist

String sourcelist
区分: 供給元一覧必須

commCode

String commCode
貿易: 統計品目コード/輸入コード番号

countryori

String countryori
品目の原産国

countryoriIso

String countryoriIso
ISO コードでの品目原産国

regionorig

String regionorig
品目の原産地 (非特恵対象地区の原産)

commCoUn

String commCoUn
物品コード (貿易) の数量単位

commCoUnIso

String commCoUnIso
ISO コードによる物品コード (貿易管理) の数量単位

expimpgrp

String expimpgrp
輸出/輸入品目グループ

profitCtr

String profitCtr
利益センタ

ppcPlCal

String ppcPlCal
PPC 計画カレンダ

repManuf

String repManuf
区分: 繰返生産許可

plTiFnce

String plTiFnce
計画タイムフェンス

consummode

String consummode
消費モード

bwdCons

String bwdCons
消費期間: 後方

fwdCons

String fwdCons
消費期間: 前方

versionFlag

String versionFlag
バージョン区分

alternativeBom

String alternativeBom
代替 BOM

bomUsage

String bomUsage
BOM 用途

planlistgrp

String planlistgrp
タスクリストグループのキー

planlistcnt

String planlistcnt
グループカウンタ

lotSize

String lotSize
原価計算ロットサイズ

specprocty

String specprocty
原価計算の特殊調達タイプ

prodUnit

String prodUnit
製造単位

prodUnitIso

String prodUnitIso
製造単位 (ISO コード)

issStLoc

String issStLoc
出庫保管場所

mrpGroup

String mrpGroup
MRP グループ

compScrap

String compScrap
構成品目不良率

certType

String certType
証明書タイプ

cycleTime

String cycleTime
タクトタイム

inspSetupFlag

String inspSetupFlag
品目/プラントに QM 検査データ設定

covprofile

String covprofile
在庫日数プロファイル

ccPhInv

String ccPhInv
循環棚卸の実地棚卸区分

varianceKey

String varianceKey
差異キー

sernoProf

String sernoProf
シリアル番号プロファイル

psConfMat

String psConfMat
選定可能品目

repmanprof

String repmanprof
繰返生産プロファイル

negStocks

String negStocks
プラントにおけるマイナス在庫許可

qmRgmts

String qmRgmts
仕入先の必須 QM システム

plngCycle

String plngCycle
計画サイクル

roundProf

String roundProf
丸めプロファイル

refmatcons

String refmatcons
消費参照品目

refpltcons

String refpltcons
消費参照プラント

dToRefM

String dToRefM
消費データ参照の有効終了日

multRefM

String multRefM
消費データ参照品目の乗数

autoReset

String autoReset
予測モデル自動リセット

prefStatFlag

String prefStatFlag
区分: 特恵関税 - 輸出/輸入

exCertId

String exCertId
法令管理: 認定書区分

exCertNoNew

String exCertNoNew
非該当証明書番号 - 法令管理

exCertDt

String exCertDt
非該当証明書発行日

declStatFlag

String declStatFlag
区分: 仕入先申告あり

militId

String militId
ID: 武器

inspInt

String inspInt
次回再検査までの間隔

coProduct

String coProduct
区分: 連産品としても使用可能な品目

planStrgp

String planStrgp
計画方針グループ

slocExprc

String slocExprc
外部調達の初期保管場所

bulkMat

String bulkMat
区分: バルク品目

ccFixed

String ccFixed
循環棚卸区分固定

determGrp

String determGrp
在庫決定グループ

qmAuthgrp

String qmAuthgrp
QM における活動の品目権限グループ

taskListType

String taskListType
タスクリストタイプ

purStatus

String purStatus
プラント特有品目ステータス

prodprof

String prodprof
製造計画プロファイル

saftyTId

String saftyTId
安全時間区分（安全リードタイムあり/なし)

safetytime

String safetytime
安全時間 (稼動日数)

plordCtrl

String plordCtrl
アクション管理: 計画手配処理

batchentry

String batchentry
製造/プロセス指図でのロット入力設定

pvalidfrom

String pvalidfrom
プラント品目ステータス有効期間開始日

matfrgtgrp

String matfrgtgrp
品目運賃グループ

prodverscs

String prodverscs
原価計算を行う製造バージョン

matCfop

String matCfop
品目 CFOP カテゴリ

euListNo

String euListNo
CAP: CAP 製品一覧番号

euMatGrp

String euMatGrp
EEC 農産物政策: CAP 生産品グループ - 貿易

casNo

String casNo
CAS 番号： 薬事品目 - 貿易

prodcomNo

String prodcomNo
生産統計: 貿易における PRODCOM コード

ctrlCode

String ctrlCode
貿易: 消費税の管理コード

jitRelvt

String jitRelvt
区分: JIT 納入日程の関連明細

matGrpTrans

String matGrpTrans
段取替えマトリクスに対する品目のグループ

handlgGrp

String handlgGrp
ワークロード計算のロジスティクス処理グループ

supplyArea

String supplyArea
品目マスタレコードで提案される供給場所

fairShareRule

String fairShareRule
均等配賦ルール

pushDistrib

String pushDistrib
区分: プッシュ配賦

deployHoriz

String deployHoriz
供給分配期間の日数

minLotSize

String minLotSize
需要と供給を一致させるための最小ロットサイズ

maxLotSize

String maxLotSize
需要と供給を一致させるための最大ロットサイズ

fixLotSize

String fixLotSize
需要供給の一致に対する固定ロットサイズ

lotIncrement

String lotIncrement
需要と供給を一致させるためのロットサイズ増分

prodConvType

String prodConvType
生産値の変換タイプ

distrProf

String distrProf
サイトの商品の物流プロファイル

periodProfileSafetyTime

String periodProfileSafetyTime
安全時間の期間プロファイル

fxdPrice

String fxdPrice
固定価格連産品

availCheckAllProjSegments

String availCheckAllProjSegments
プロジェクト間品目区分

overallprf

String overallprf
指図変更管理の全体プロファイル

mrpRelevancyDepRequirements

String mrpRelevancyDepRequirements
従属所要量と MRP の関連性

mrpAreaExists

String mrpAreaExists
区分: MRP エリア登録済

minSafetyStk

String minSafetyStk
最小安全在庫

noCosting

String noCosting
原価計算なし

unitGroup

String unitGroup
数量単位グループ

followUpExternal

String followUpExternal
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)

followUpGuid

String followUpGuid
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

followUpVersion

String followUpVersion
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)

refmatconsExternal

String refmatconsExternal
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)

refmatconsGuid

String refmatconsGuid
項目 REFMATCONS の外部 GUID (今後のリリースで開発)

refmatconsVersion

String refmatconsVersion
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)

salesView

String salesView
販売ビュー

purchView

String purchView
購買管理ビュー

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

forecastView

String forecastView
需要予測ビュー

workSchedView

String workSchedView
作業計画ビュー

prtView

String prtView
生産資源/治工具 (PRT) ビュー

storageView

String storageView
保管ビュー

warehouseView

String warehouseView
倉庫管理ビュー

qualityView

String qualityView
品質管理ビュー

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

rotationDate

String rotationDate
原価計算ビュー

originalBatchFlag

String originalBatchFlag
元ロット管理区分

originalBatchRefMaterial

String originalBatchRefMaterial
元ロットの参照品目

psConfMatExternal

String psConfMatExternal
PS_CO 項目の(将来の開発用)品目コード(長)

psConfMatGuid

String psConfMatGuid
PS_CONF_MAT 項目の外部 GUID (将来の開発用)

psConfMatVersion

String psConfMatVersion
PS_CONF_MAT 項目のバージョン番号 (将来の開発用)

originalBatchRefMaterialE

String originalBatchRefMaterialE
オリジナルロット参照品目

originalBatchRefMaterialV

String originalBatchRefMaterialV
オリジナルロット参照品目

originalBatchRefMaterialG

String originalBatchRefMaterialG
オリジナルロット参照品目

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList は PlantData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

salesOrg

String salesOrg
販売組織

distrChan

String distrChan
流通チャネル

delFlag

String delFlag
区分: 流通チャネルレベルでの品目削除フラグ

matlStats

String matlStats
品目統計グループ

rebateGrp

String rebateGrp
取引量リベートグループ

commGroup

String commGroup
手数料グループ

cashDisc

String cashDisc
現金値引区分

salStatus

String salStatus
販売ビューからの品目ステータス

validFrom

String validFrom
流通チェーン別品目ステータスの有効期間開始日

minOrder

String minOrder
基本数量単位での最小受注数量

minDely

String minDely
納品書処理時の最小納入数量

minMto

String minMto
受注製造品最少受注数量

delyUnit

String delyUnit
出荷単位

delyUom

String delyUom
出荷数量単位

delyUomIso

String delyUomIso
ISO コードでの出荷単位の数量単位

salesUnit

String salesUnit
販売単位

salesUnitIso

String salesUnitIso
ISO コードによる販売単位

itemCat

String itemCat
品目マスタの明細カテゴリグループ

delygPlnt

String delygPlnt
出荷プラント

prodHier

String prodHier
品目階層

prRefMat

String prRefMat
価格設定参照品目

matPrGrp

String matPrGrp
品目価格設定グループ

acctAssgt

String acctAssgt
品目の勘定設定グループ

matlGrp1

String matlGrp1
品目グループ 1

matlGrp2

String matlGrp2
品目グループ 2

matlGrp3

String matlGrp3
品目グループ 3

matlGrp4

String matlGrp4
品目グループ 4

matlGrp5

String matlGrp5
品目グループ 5

prodAtt1

String prodAtt1
ID: 製品属性 1

prodAtt2

String prodAtt2
品目属性 2 用 ID

prodAtt3

String prodAtt3
品目属性 3 用 ID

prodAtt4

String prodAtt4
品目属性 4 用 ID

prodAtt5

String prodAtt5
品目属性 5 用 ID

prodAtt6

String prodAtt6
品目属性 6 の ID

prodAtt7

String prodAtt7
品目属性 7 用 ID

prodAtt8

String prodAtt8
品目属性 8 用 ID

prodAtt9

String prodAtt9
品目属性 9

prodAtt10

String prodAtt10
品目属性 10 用 ID

roundProf

String roundProf
丸めプロファイル

varSalesUn

String varSalesUn
可変販売単位の使用不可

unitGroup

String unitGroup
数量単位グループ

prRefMatExternal

String prRefMatExternal
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

prRefMatGuid

String prRefMatGuid
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

prRefMatVersion

String prRefMatVersion
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList は SalesData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

stgeLoc

String stgeLoc
保管場所

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
保管場所レベルでの品目削除フラグ

fiscYear

String fiscYear
当会計年度

currPeriod

String currPeriod
当期 (転記期間)

mrpInd

String mrpInd
保管場所 MRP 区分

specProc

String specProc
保管場所レベルでの特殊調達タイプ

reorderPt

String reorderPt
保管場所 MRP に対する発注点

replQty

String replQty
保管場所 MRP に対する補充数量

stgeBin

String stgeBin
棚番

pickgArea

String pickgArea
簡易倉庫管理のピッキングエリア

invCorrFac

String invCorrFac
在庫修正係数

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

storageView

String storageView
保管ビュー

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList は StorageLocationData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

whseNo

String whseNo
倉庫番号/複合倉庫

stgeType

String stgeType
保管域タイプ

delFlag

String delFlag
保管タイプに該当する全品目データ削除フラグ

stgeBin

String stgeBin
棚番

maxSbQty

String maxSbQty
最大棚番在庫数量

minSbQty

String minSbQty
最小棚番在庫数量

ctrlQty

String ctrlQty
管理数量

replenQty

String replenQty
補充数量

pickArea

String pickArea
ピッキングエリア

roundQty

String roundQty
丸め数量

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList は StorageTypeData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

depcountry

String depcountry
出荷国 (商品発送国)

depcountryIso

String depcountryIso
出荷国の ISO コード

taxType1

String taxType1
税カテゴリ (消費税等)

taxclass1

String taxclass1
品目の税分類

taxType2

String taxType2
税カテゴリ (消費税等)

taxclass2

String taxclass2
品目の税分類

taxType3

String taxType3
税カテゴリ (消費税等)

taxclass3

String taxclass3
品目の税分類

taxType4

String taxType4
税カテゴリ (消費税等)

taxclass4

String taxclass4
品目の税分類

taxType5

String taxType5
税カテゴリ (消費税等)

taxclass5

String taxclass5
品目の税分類

taxType6

String taxType6
税カテゴリ (消費税等)

taxclass6

String taxclass6
品目の税分類

taxType7

String taxType7
税カテゴリ (消費税等)

taxclass7

String taxclass7
品目の税分類

taxType8

String taxType8
税カテゴリ (消費税等)

taxclass8

String taxclass8
品目の税分類

taxType9

String taxType9
税カテゴリ (消費税等)

taxclass9

String taxclass9
品目の税分類

taxInd

String taxInd
税区分: 品目 (購買管理)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

altUnit

String altUnit
在庫保管単位の代替数量単位

altUnitIso

String altUnitIso
ISO コードによる在庫単位の代替数量単位

numerator

String numerator
基本数量単位への換算分子

denominatr

String denominatr
分母: 基本数量単位へ変換する場合

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

length

String length
長さ

width

String width
幅

height

String height
高さ

unitDim

String unitDim
寸法単位 (長さ/幅/高さ)

unitDimIso

String unitDimIso
ISO コードでの長さ、幅、高さの単位

volume

String volume
容積

volumeunit

String volumeunit
容積単位

volumeunitIso

String volumeunitIso
ISO コードでの容積単位

grossWt

String grossWt
総重量

unitOfWt

String unitOfWt
重量単位

unitOfWtIso

String unitOfWtIso
ISO コードでの重量単位

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

subUom

String subUom
梱包階層の下位レベル数量単位

subUomIso

String subUomIso
下位レベル数量単位 (ISO コード)

internalChar

String internalChar
内部特性

uomsortnumber

String uomsortnumber
数量単位ソート番号

leadinguom

String leadinguom
主要ロット特定数量単位

valueduom

String valueduom
ロット特定数量単位での評価

charUnit

String charUnit
特性の数量単位

charUnitIso

String charUnitIso
下位レベル数量単位 (ISO コード)

gtinVariant

String gtinVariant
グローバルトレード明細番号バリアント

netWeight

String netWeight
正味重量

meAnzSub

String meAnzSub
下位レベル数量単位数

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

valArea

String valArea
評価レベル

valType

String valType
評価タイプ

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
評価タイプに該当する全品目データ削除フラグ

priceCtrl

String priceCtrl
原価管理区分

movingPr

String movingPr
移動平均原価/期間単位価格

stdPrice

String stdPrice
標準原価

priceUnit

String priceUnit
価格単位

valClass

String valClass
評価クラス

prCtrlPp

String prCtrlPp
前期間の原価管理区分

movPrPp

String movPrPp
前期移動平均原価/期間平均原価

stdPrPp

String stdPrPp
前期標準標準原価

prUnitPp

String prUnitPp
前期価格単位

vclassPp

String vclassPp
前期評価クラス

prCtrlPy

String prCtrlPy
前年度の原価管理区分

movPrPy

String movPrPy
前年度の移動平均原価/期間単価

stdPrPy

String stdPrPy
前年度標準原価

vclassPy

String vclassPy
前年度の評価クラス

prUnitPy

String prUnitPy
前年度価格単位

fiscYear

String fiscYear
当会計年度

currPeriod

String currPeriod
当期 (転記期間)

valCat

String valCat
評価カテゴリ

futurePr

String futurePr
次期標準原価

validFrom

String validFrom
原価有効開始日

taxprice1

String taxprice1
税法による評価額: レベル 1

commprice1

String commprice1
商法による評価額: レベル 1

taxprice3

String taxprice3
税法基準評価額: レベル 3

commprice3

String commprice3
商法基準評価額: レベル 3

plndPrice

String plndPrice
予定計画原価

plndprice1

String plndprice1
予定計画原価 1

plndprice2

String plndprice2
予定計画原価 2

plndprice3

String plndprice3
予定計画原価 3

plndprdate1

String plndprdate1
予定原価 1 の有効開始日

plndprdate2

String plndprdate2
予定原価 2 の有効開始日

plndprdate3

String plndprdate3
予定原価 3 の有効開始日

lifoFifo

String lifoFifo
LIFO/FIFO 関連

poolnumber

String poolnumber
LIFO 評価でのプール番号

taxprice2

String taxprice2
税法による評価額: レベル 2

commprice2

String commprice2
商法による評価額: レベル 2

devalInd

String devalInd
低価法: 評価減区分

origGroup

String origGroup
発生源グループ (原価要素の下位区分)

overheadGrp

String overheadGrp
原価計算間接費グループ

perFutCostEst

String perFutCostEst
将来標準原価見積期間

perCurCostEst

String perCurCostEst
現行標準原価見積期間

perPreCostEst

String perPreCostEst
前標準原価見積期間

fijFutCostEst

String fijFutCostEst
将来標準原価見積の会計年度

fijCurCostEst

String fijCurCostEst
当期標準原価見積の会計年度

fijPreCostEst

String fijPreCostEst
前期標準原価見積の会計年度

qtyStruct

String qtyStruct
数量構成により原価計算を行う品目

prevPlanPrice

String prevPlanPrice
税法基準評価額: レベル 2

mlActive

String mlActive
品目レベルで有効な品目元帳

mlSettle

String mlSettle
品目元帳決済: 管理

currPlanPrice

String currPlanPrice
税法基準評価額: レベル 2

origMat

String origMat
品目発生源

vmSoStk

String vmSoStk
受注在庫の評価クラス

vmPStock

String vmPStock
プロジェクト在庫の評価クラス

matlUsage

String matlUsage
品目の用途

matOrigin

String matOrigin
品目の原産地

inHouse

String inHouse
内部生産

taxCmlUn

String taxCmlUn
税法/商法にもとづく評価額価格単位

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList は ValuationData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

whseNo

String whseNo
倉庫番号/複合倉庫

delFlag

String delFlag
WM 倉庫内の全品目データ削除フラグ

stgesector

String stgesector
保管区画区分

placement

String placement
在庫受入に対する保管域タイプ検索区分

withdrawal

String withdrawal
在庫払出に対する保管域タイプ区分

lEquip1

String lEquip1
積載装置数量 1

lEquip2

String lEquip2
積載装置数量 2

lEquip3

String lEquip3
積載装置数量 3

leqUnit1

String leqUnit1
積載装置数量 1 の数量単位

leqUnit1Iso

String leqUnit1Iso
ISO コードによる積載装置数量 1 の数量単位

leqUnit2

String leqUnit2
積載装置数量 2 の数量単位

leqUnit2Iso

String leqUnit2Iso
ISO コードによる積載装置数量 2 の数量単位

leqUnit3

String leqUnit3
積載装置数量 3 の数量単位

leqUnit3Iso

String leqUnit3Iso
ISO コードによる積載装置数量 3 の数量単位

unittype1

String unittype1
第１保管単位タイプ

unittype2

String unittype2
第２保管単位タイプ

unittype3

String unittype3
第３保管単位タイプ

wmUnit

String wmUnit
倉庫管理の数量単位

wmUnitIso

String wmUnitIso
ISO コードでの倉庫管理単位

addToStk

String addToStk
既存在庫への追加許可

blockStge

String blockStge
平置保管域区分

msgToIm

String msgToIm
区分: 在庫管理への出力

specMvmt

String specMvmt
倉庫管理の特殊移動区分

capyUsage

String capyUsage
保管容量使用

procureUn

String procureUn
保管容量消費の数量単位

procureUnIso

String procureUnIso
ISO コードでの保管容量消費の数量単位

stgeType

String stgeType
概略計画および詳細計画のピッキング保管域タイプ

refUnit

String refUnit
品目マスタレコードの数量単位初期値

twoStepPick

String twoStepPick
ツーステップピッキング適用品目

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList は WarehouseNumberData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception

クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.Extensionin は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode は Object を拡張し、Serializable を実装しています

直列化されたフィールド

gmCode

String gmCode
BAPI 在庫移動トランザクションのコード割当

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
在庫移動シミュレーション

matdocumentyear

String matdocumentyear
入出庫伝票会計年度

materialdocument

String materialdocument
入出庫伝票番号

goodsMvtCode

GoodsMvtCode goodsMvtCode
在庫移動に対するコードのトランザクションへの割当

goodsMvtHeader

GoodsMvtHeader goodsMvtHeader
入出庫伝票ヘッダデータ

goodsMvtHeadret

GoodsMvtHeadret goodsMvtHeadret
入出庫伝票番号/入出庫伝票会計年度

goodsMvtRefEwm

GoodsMvtRefEwm goodsMvtRefEwm
BAdI 通信構造: 入出庫伝票 EWM 照会

goodsMvtItemList

List goodsMvtItemList
入出庫伝票明細

goodsMvtSerialNumberList

List goodsMvtSerialNumberList
シリアル番号

goodsMvtServPartDataList

List goodsMvtServPartDataList
ServPartData

extensioninList

List extensioninList
Reference Structure

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret は Object を拡張し、Serializable を実装しています

直列化されたフィールド

matDoc

String matDoc
入出庫伝票番号

docYear

String docYear
入出庫伝票年度

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

plant

String plant
プラント

stgeLoc

String stgeLoc
保管場所

batch

String batch
ロット番号

moveType

String moveType
移動タイプ (在庫管理)

stckType

String stckType
在庫タイプ

specStock

String specStock
特殊在庫区分

vendor

String vendor
仕入先勘定コード

customer

String customer
得意先コード

salesOrd

String salesOrd
受注伝票番号

sOrdItem

String sOrdItem
受注明細番号

schedLine

String schedLine
受注納入日程

valType

String valType
評価タイプ

entryQnt

String entryQnt
入力単位での数量

entryUom

String entryUom
入力単位

entryUomIso

String entryUomIso
単位の ISO コード

poPrQnt

String poPrQnt
数量 (購買発注価格単位)

orderprUn

String orderprUn
購買発注価格単位 (購買管理)

orderprUnIso

String orderprUnIso
単位の ISO コード

poNumber

String poNumber
購買発注番号

poItem

String poItem
購買伝票の明細番号

shipping

String shipping
出荷指示

compShip

String compShip
出荷指示順守

noMoreGr

String noMoreGr
納入完了 区分

itemText

String itemText
明細テキスト

grRcpt

String grRcpt
受領者

unloadPt

String unloadPt
荷渡ポイント

costcenter

String costcenter
原価センタ

orderid

String orderid
指図番号

orderItno

String orderItno
指図明細番号

calcMotive

String calcMotive
計算区分

assetNo

String assetNo
資産番号

subNumber

String subNumber
資産補助番号

reservNo

String reservNo
入出庫予定/従属所要量の番号

resItem

String resItem
入出庫予定/従属所要量の明細番号

resType

String resType
レコードタイプ

withdrawn

String withdrawn
入出庫予定に対する出庫完了

moveMat

String moveMat
入庫/出庫品目

movePlant

String movePlant
入庫/出庫プラント

moveStloc

String moveStloc
入庫/出庫保管場所

moveBatch

String moveBatch
入庫/出庫ロット

moveValType

String moveValType
転送ロットの評価タイプ

mvtInd

String mvtInd
移動区分

moveReas

String moveReas
移動理由

rlEstKey

String rlEstKey
不動産管理対象の内部キー

refDate

String refDate
決済の参照日付

costObj

String costObj
原価対象

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

profitCtr

String profitCtr
利益センタ

wbsElem

String wbsElem
WBS 要素

network

String network
勘定割当のネットワーク番号

activity

String activity
作業番号

partAcct

String partAcct
取引先勘定コード

amountLc

String amountLc
マニュアル入力による転記金額 (国内通貨)

amountSv

String amountSv
外部入力による販売金額 (国内通貨)

refDocYr

String refDocYr
参照伝票の会計年度

refDoc

String refDoc
参照伝票の伝票番号

refDocIt

String refDocIt
参照伝票の明細番号

expirydate

String expirydate
有効期間期限日

prodDate

String prodDate
ロット製造日付

fund

String fund
会計区分

fundsCtr

String fundsCtr
予算センタ

cmmtItem

String cmmtItem
資金予算コード

valSalesOrd

String valSalesOrd
評価受注在庫の受注番号

valSOrdItem

String valSOrdItem
評価受注在庫の受注明細

valWbsElem

String valWbsElem
WBS 要素

glAccount

String glAccount
G/L 勘定コード

indProposeQuanx

String indProposeQuanx
提案数量 (初期数量)

xstob

String xstob
取消移動タイプ区分の使用

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

delivNumbToSearch

String delivNumbToSearch
出荷伝票

delivItemToSearch

String delivItemToSearch
出荷明細

serialnoAutoNumberassignment

String serialnoAutoNumberassignment
シリアル番号の自動登録

vendrbatch

String vendrbatch
仕入先ロット番号

stgeType

String stgeType
保管域タイプ

stgeBin

String stgeBin
棚番

suPlStck1

String suPlStck1
在庫受入予定の保管単位数

stUnQtyy1

String stUnQtyy1
代替数量単位での在庫受入予定保管単位別数量

stUnQtyy1Iso

String stUnQtyy1Iso
単位の ISO コード

unittype1

String unittype1
保管単位タイプ

suPlStck2

String suPlStck2
在庫受入予定の保管単位数

stUnQtyy2

String stUnQtyy2
代替数量単位での在庫受入予定保管単位別数量

stUnQtyy2Iso

String stUnQtyy2Iso
単位の ISO コード

unittype2

String unittype2
保管単位タイプ

stgeTypePc

String stgeTypePc
在庫転送の保管域タイプ

stgeBinPc

String stgeBinPc
在庫転送棚番

noPstChgnt

String noPstChgnt
区分: 振替要求通知登録禁止

grNumber

String grNumber
入庫番号

stgeTypeSt

String stgeTypeSt
在庫転送の保管域タイプ

stgeBinSt

String stgeBinSt
在庫転送棚番

matdocTrCancel

String matdocTrCancel
取消予定の転送要求の入出庫伝票番号

matitemTrCancel

String matitemTrCancel
取消予定の転送数量入出庫伝票明細

matyearTrCancel

String matyearTrCancel
取消予定の転送要求入出庫伝票年度

noTransferReq

String noTransferReq
区分: 転送要求未登録

coBusproc

String coBusproc
業務プロセス

acttype

String acttype
活動タイプ

supplVend

String supplVend
供給仕入先

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

moveMatExternal

String moveMatExternal
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

moveMatGuid

String moveMatGuid
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

moveMatVersion

String moveMatVersion
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

funcArea

String funcArea
機能領域

trPartBa

String trPartBa
取引会社事業領域

parCompco

String parCompco
決済会社コード

delivNumb

String delivNumb
出荷伝票

delivItem

String delivItem
出荷明細

nbSlips

String nbSlips
入庫/出庫票の印刷部数

nbSlipsx

String nbSlipsx
関連ユーザデータ項目の更新情報

grRcptx

String grRcptx
関連ユーザデータ項目の更新情報

unloadPtx

String unloadPtx
関連ユーザデータ項目の更新情報

specMvmt

String specMvmt
倉庫管理の特殊移動区分

grantNbr

String grantNbr
補助金

cmmtItemLong

String cmmtItemLong
資金予算コード

funcAreaLong

String funcAreaLong
機能領域

lineId

String lineId
伝票明細行の一意 ID

parentId

String parentId
1 レベル上位の行 ID

lineDepth

String lineDepth
伝票での明細行階層レベル

quantity

String quantity
数量

baseUom

String baseUom
基本数量単位

longnum

String longnum
Long Procurement Document Number

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtRefEwm は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDocEwm

String refDocEwm
EWM 入出庫伝票番号

logsys

String logsys
EWM 入出庫伝票の論理システム

gtsScrapNo

String gtsScrapNo
廃棄処理の税関参照番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber は Object を拡張し、Serializable を実装しています

直列化されたフィールド

matdocItm

String matdocItm
入出庫伝票の明細

serialno

String serialno
シリアル番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtServPartData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

lineId

String lineId
伝票明細行の一意 ID

retAuthNumber

String retAuthNumber
返品権限番号

delivNumber

String delivNumber
出荷伝票

delivItem

String delivItem
出荷明細

huNumber

String huNumber
外部荷役単位 ID

inspoutGuid

String inspoutGuid
品質検査結果: EWM 設定の在庫 GUID

event

String event
論理時間

date

String date
日付

time

String time
時刻

zonlo

String zonlo
現在のユーザのタイムゾーン

timestamp

String timestamp
取引開始時刻 (UTCタイムスタンプ)

scrapIndicator

String scrapIndicator
EWM 処理の廃棄区分

keepQuantity

String keepQuantity
EWM での廃棄処理の保持数量

gtsStockType

String gtsStockType
GTS在庫タイプ

moveGtsStockType

String moveGtsStockType
GTS在庫タイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamExtensionin は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtRefEwm は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtServPartData は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
ロット番号

high

String high
ロット番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

vendorRaList

List vendorRaList
仕入先の範囲

userNameRaList

List userNameRaList
ユーザ名の範囲

trEvTypeRaList

List trEvTypeRaList
トランザクション/イベントタイプの範囲

stgeLocRaList

List stgeLocRaList
保管場所の範囲

specStockRaList

List specStockRaList
特殊在庫区分の範囲

pstngDateRaList

List pstngDateRaList
登録日付の範囲

plantRaList

List plantRaList
プラントの範囲

moveTypeRaList

List moveTypeRaList
移動タイプの範囲

materialRaList

List materialRaList
品目コードの範囲

goodsMvtItemsList

List goodsMvtItemsList
リターン構造、入出庫伝票明細

goodsMvtHeaderList

List goodsMvtHeaderList
リターン構造、入出庫伝票ヘッダ

batchRaList

List batchRaList
ロットの範囲

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
品目コード

high

String high
品目コード

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
移動タイプ (在庫管理)

high

String high
移動タイプ (在庫管理)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
プラント

high

String high
プラント

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
伝票の転記日付

high

String high
伝票の転記日付

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
特殊在庫区分

high

String high
特殊在庫区分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
保管場所

high

String high
保管場所

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
トランザクション/イベントタイプ

high

String high
トランザクション/イベントタイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
ユーザ名

high

String high
ユーザ名

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
仕入先勘定コード

high

String high
仕入先勘定コード

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

wbsElem

String wbsElem
WBS 要素

unit

String unit
表示数量単位

stockInd

String stockInd
特殊在庫区分

stgeLoc

String stgeLoc
保管場所

plant

String plant
プラント

material

String material
品目コード

itmNumber

String itmNumber
明細番号

docNumber

String docNumber
伝票番号

decForRoundingX

String decForRoundingX
関連ユーザデータ項目の更新情報

decForRounding

String decForRounding
小数点位置 (その位置まで丸める)

customer

String customer
得意先コード

checkRule

String checkRule
確認規則

batch

String batch
ロット

readAtpLockX

String readAtpLockX
関連ユーザデータ項目の更新情報

readAtpLock

String readAtpLock
管理区分:利用可能在庫確認

endleadtme

String endleadtme
補充リードタイムの終了日付

dialogflag

String dialogflag
区分 (X = 利用不可 /N = 確認なし)

avQtyPlt

String avQtyPlt
プラントレベル利用可能数量

materialEvg

MaterialEvg materialEvg
品目コード(長)

wmdvexList

List wmdvexList
出力テーブル (日付および ATP 数量)

wmdvsxList

List wmdvsxList
入力テーブル (日付/数量)

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bdcnt

String bdcnt
5 文字数値 NUMC

reqDate

String reqDate
所要日付

reqQty

String reqQty
利用可能在庫確認の所要量

comDate

String comDate
確認日

comQty

String comQty
確認数量

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx は Object を拡張し、Serializable を実装しています

直列化されたフィールド

reqDate

String reqDate
所要日付

reqQty

String reqQty
所要量

delkz

String delkz
MRP 要素区分

yline

String yline
内部テ－ブル処理の行索引

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers は Object を拡張し、Serializable を実装しています

直列化されたフィールド

unit

String unit
表示数量単位

unitIso

String unitIso
ISO コードでの表示数量単位

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

mainEan

String mainEan
区分: 主要 EAN

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

lifoValuationLevel

String lifoValuationLevel
LIFO 評価レベル

poolnumber

String poolnumber
LIFO 評価でのプール番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

companycode

String companycode
会社コード

valuationarea

String valuationarea
評価レベル

valuationtype

String valuationtype
評価タイプ

plant

String plant
プラント

storagelocation

String storagelocation
保管場所

salesorganisation

String salesorganisation
販売組織

distributionchannel

String distributionchannel
流通チャネル

warehousenumber

String warehousenumber
倉庫番号/複合倉庫

storagetype

String storagetype
保管域タイプ

lifovaluationlevel

String lifovaluationlevel
LIFO 評価レベル

clientData

ClientData clientData
品目データ (クライアントレベル)

plantData

PlantData plantData
品目データ (プラントレベル)

forecastParameters

ForecastParameters forecastParameters
予測パラメータ

planningData

PlanningData planningData
品目マスタ/製品グループの変更伝票構造

storageLocationData

StorageLocationData storageLocationData
品目データ (保管場所レベル)

valuationData

ValuationData valuationData
評価データ

warehouseNumberData

WarehouseNumberData warehouseNumberData
倉庫番号データ

salesData

SalesData salesData
販売データ

storageTypeData

StorageTypeData storageTypeData
保管域タイプデータ

productionResourceToolData

ProductionResourceToolData productionResourceToolData
品目マスタの生産資源/治工具 (PRT) 項目

lifoValuationData

LifoValuationData lifoValuationData
LIFO 関連品目データ

materialDescriptionList

List materialDescriptionList
品目テキスト

unitSofmeasureList

List unitSofmeasureList
数量単位

internationArticleNumbersList

List internationArticleNumbersList
EAN

materialTextList

List materialTextList
テキスト (長)

taxClassificationsList

List taxClassificationsList
制御デ－タ

extensionOutList

List extensionOutList
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

materialEvg

MaterialEvg materialEvg
品目コード(長)

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

applobject

String applobject
テキスト: アプリケーションオブジェクト

textName

String textName
名称

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

plant

String plant
プラント

createLoadRecs

String createLoadRecs
区分: 生産資源/治工具の負荷レコード登録

ctrlKey

String ctrlKey
生産資源/治工具管理の管理キー

ctrlKeyNoChg

String ctrlKeyNoChg
管理キーは変更できません

grpKey1

String grpKey1
生産資源/治工具のグループキー 1

grpKey2

String grpKey2
生産資源/治工具のグループキー 2

prtUsage

String prtUsage
生産資源/治工具用途

stdTextKey

String stdTextKey
生産資源/治工具の標準テキストキー

refKeyNoChg

String refKeyNoChg
参照キーは変更できません

startRefDate

String startRefDate
生産資源/治工具使用開始の参照日付

stRefDateNoChg

String stRefDateNoChg
開始参照日付は変更できません

startOffset

String startOffset
生産資源/治工具使用の開始オフセット

startOffsetUnit

String startOffsetUnit
生産資源/治工具使用開始のオフセット単位

startOffsetUnitIso

String startOffsetUnitIso
PRT 用途開始決定の間隔時間単位 (ISO)

startOffsetNoChg

String startOffsetNoChg
開始オフセットは変更できません

endRefDate

String endRefDate
生産資源/治工具使用終了日の参照日付

endRefDateNoChg

String endRefDateNoChg
終了参照日付は変更できません

endOffset

String endOffset
生産資源/治工具用途の終了オフセット

endOffsetUnit

String endOffsetUnit
生産資源/治工具使用終了オフセット単位

endOffsetUnitIso

String endOffsetUnitIso
PRT 用途終了決定の間隔時間単位 (ISO)

endOffsetNoChg

String endOffsetNoChg
終了オフセットは変更できません

formulaTotQty

String formulaTotQty
生産資源/治工具の合計数量の計算式

formulaTotQtyNoChg

String formulaTotQtyNoChg
合計数量の計算式は変更できません

formulaTotUsage

String formulaTotUsage
生産資源/治工具の総用途値の計算式

formulaTotUsageNoChg

String formulaTotUsageNoChg
すべての用途値を計算する計算式は変更できません

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
長さ 229 の文字データのコンテナ

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
長さ 229 の文字データのコンテナ

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

foreValue

String foreValue
予測値

corrValue

String corrValue
需要予測に対する修正値

seasIndex

String seasIndex
季節指数

cvalueFxd

String cvalueFxd
区分: 消費金額の確定

expostVal

String expostVal
事後的需要予測値

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

indSector

String indSector
産業コード

matlType

String matlType
品目タイプ

basicView

String basicView
基本データビュー

salesView

String salesView
販売ビュー

purchaseView

String purchaseView
購買管理ビュー

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

forecastView

String forecastView
需要予測ビュー

workSchedView

String workSchedView
作業計画ビュー

prtView

String prtView
生産資源/治工具 (PRT) ビュー

storageView

String storageView
保管ビュー

warehouseView

String warehouseView
倉庫管理ビュー

qualityView

String qualityView
品質管理ビュー

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

unit

String unit
表示数量単位

unitIso

String unitIso
ISO コードでの表示数量単位

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

applobject

String applobject
テキスト: アプリケーションオブジェクト

textName

String textName
名称

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

nochangedoc

String nochangedoc
変更伝票書込なし

noappllog

String noappllog
アプリケーションログ書込なし

testrun

String testrun
書込 BAPI のシミュレーションセッションへの切替

inpfldcheck

String inpfldcheck
項目無効時の応答

flagCadCall

String flagCadCall
CAD システムからコール

flagOnline

String flagOnline
No ALE Field Selection

noRollbackWork

String noRollbackWork
Override Rollback Work

headDataList

List headDataList
管理情報設定ヘッダセグメント

clientDataList

List clientDataList
品目データ (クライアントレベル)

plantDataList

List plantDataList
品目データ (プラントレベル)

forecastParametersList

List forecastParametersList
需要予測パラメータ

planningDataList

List planningDataList
品目マスタ/製品グループの変更伝票構造

storageLocationDataList

List storageLocationDataList
品目データ (保管場所レベル)

valuationDataList

List valuationDataList
評価データ

warehouseNumberDataList

List warehouseNumberDataList
倉庫番号データ

salesDataList

List salesDataList
販売データ

storageTypeDataList

List storageTypeDataList
保管域タイプデータ

materialDescriptionList

List materialDescriptionList
品目テキスト

unitSofmeasureList

List unitSofmeasureList
数量単位

internationalArtnosList

List internationalArtnosList
国際商品コード (EAN)

materialLongTextList

List materialLongTextList
テキスト (長)

taxClassificationsList

List taxClassificationsList
制御デ－タ

prtDataList

List prtDataList
品目マスタの生産資源/治工具 (PRT) 項目

extensionInList

List extensionInList
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

extensionInXList

List extensionInXList
拡張イン/拡張アウトのチェックボックス構造

forecastValuesList

List forecastValuesList
需要予測値のデータ転送

unplndConsumptionList

List unplndConsumptionList
計画外消費のデータ転送

totalConsumptionList

List totalConsumptionList
品目総消費量のデータ転送

returnMessagesList

List returnMessagesList
リターンパラメータ BAPIRET2 の代替構造

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

createLoadRecs

String createLoadRecs
区分: 生産資源/治工具の負荷レコード登録

ctrlKey

String ctrlKey
生産資源/治工具管理の管理キー

ctrlKeyNoChg

String ctrlKeyNoChg
管理キーは変更できません

grpKey1

String grpKey1
生産資源/治工具のグループキー 1

grpKey2

String grpKey2
生産資源/治工具のグループキー 2

prtUsage

String prtUsage
生産資源/治工具用途

stdTextKey

String stdTextKey
生産資源/治工具の標準テキストキー

refKeyNoChg

String refKeyNoChg
参照キーは変更できません

startRefDate

String startRefDate
生産資源/治工具使用開始の参照日付

stRefDateNoChg

String stRefDateNoChg
開始参照日付は変更できません

startOffset

String startOffset
生産資源/治工具使用の開始オフセット

startOffsetUnit

String startOffsetUnit
生産資源/治工具使用開始のオフセット単位

startOffsetUnitIso

String startOffsetUnitIso
PRT 用途開始決定の間隔時間単位 (ISO)

startOffsetNoChg

String startOffsetNoChg
開始オフセットは変更できません

endRefDate

String endRefDate
生産資源/治工具使用終了日の参照日付

endRefDateNoChg

String endRefDateNoChg
終了参照日付は変更できません

endOffset

String endOffset
生産資源/治工具用途の終了オフセット

endOffsetUnit

String endOffsetUnit
生産資源/治工具使用終了オフセット単位

endOffsetUnitIso

String endOffsetUnitIso
PRT 用途終了決定の間隔時間単位 (ISO)

endOffsetNoChg

String endOffsetNoChg
終了オフセットは変更できません

formulaTotQty

String formulaTotQty
生産資源/治工具の合計数量の計算式

formulaTotQtyNoChg

String formulaTotQtyNoChg
合計数量の計算式は変更できません

formulaTotUsage

String formulaTotUsage
生産資源/治工具の総用途値の計算式

formulaTotUsageNoChg

String formulaTotUsageNoChg
すべての用途値を計算する計算式は変更できません

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

id

String id
メッセージ、メッセージクラス

number

String number
メッセージ、メッセージ番号

message

String message
メッセージテキスト

logNo

String logNo
アプリケーションログ: ログ番号

logMsgNo

String logMsgNo
アプリケーションログ: メッセージシリアル番号

messageV1

String messageV1
メッセージ、メッセージ変数

messageV2

String messageV2
メッセージ、メッセージ変数

messageV3

String messageV3
メッセージ、メッセージ変数

messageV4

String messageV4
メッセージ、メッセージ変数

parameter

String parameter
パラメータ名

row

String row
パラメータの行

field

String field
パラメータの項目

system

String system
メッセージが発行された論理システム

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

consValue

String consValue
消費量

corrValue

String corrValue
修正消費量

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

consValue

String consValue
消費量

corrValue

String corrValue
修正消費量

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber は Object を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

stdMaterialGetIntNumberList

List stdMaterialGetIntNumberList
品目コード割当済一覧

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

salesorg

String salesorg
販売組織

distrChan

String distrChan
流通チャネル

division

String division
製品部門

docType

String docType
販売伝票タイプ

ordbilltyp

String ordbilltyp
受注関連請求伝票に対する提案請求伝票タイプ

billDate

String billDate
請求索引および印刷に対する請求日

soldTo

String soldTo
受注先

itemCateg

String itemCateg
明細カテゴリ (販売伝票)

acctasgnmt

String acctasgnmt
品目の勘定設定グループ

priceDate

String priceDate
価格設定/外貨換算の実行日付

country

String country
出荷国 (商品発送国)

plant

String plant
プラント

billTo

String billTo
請求先

payer

String payer
支払人

shipTo

String shipTo
出荷先

refDoc

String refDoc
参照伝票番号

material

String material
品目コード

reqQty

String reqQty
累積受注数量 (販売単位)

currency

String currency
販売伝票通貨

shortText

String shortText
テキスト (短): 受注明細

taxcl1Mat

String taxcl1Mat
品目の税分類

refItem

String refItem
参照明細番号

statGroup

String statGroup
統計グループ

noMatmast

String noMatmast
品目マスタ確認禁止

addrNo

String addrNo
アドレス: アドレス番号

title

String title
敬称

name

String name
名称 1

name2

String name2
名称 2

postlCode

String postlCode
郵便番号

consumctry

String consumctry
消費者の国キー

city

String city
市区町村

district

String district
所在地

street

String street
地名/番地-号

region

String region
地域 (都道府県)

prodHier

String prodHier
品目階層

salesUnit

String salesUnit
販売単位

profitCtr

String profitCtr
利益センタ

taxjurcode

String taxjurcode
税計算管轄コード - 税管轄コード

purchOrd

String purchOrd
出荷先発注番号

docNumber

String docNumber
販売伝票

itmNumber

String itmNumber
販売伝票明細

origindoc

String origindoc
開始伝票

item

String item
開始明細

createdBy

String createdBy
オブジェクト登録者名

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ (2)

exchangeRate

String exchangeRate
価格設定/統計用換算レート

paymentTerms

String paymentTerms
支払条件キー

hgLvItem

String hgLvItem
BOM 構成の上位レベル明細

refDocCa

String refDocCa
先行販売管理伝票の伝票カテゴリ

orderid

String orderid
指図番号

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

costcenter

String costcenter
原価センタ

wbsElem

String wbsElem
WBS 要素

taxDepartCty

String taxDepartCty
税出荷国

taxDestCty

String taxDestCty
税仕向国

servDate

String servDate
サービス提供日

parallelQty

String parallelQty
Quantity in Parallel Unit of Measure

parallelUom

String parallelUom
Parallel Unit of Measure

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
シミュレーション実行 ('X')、更新実行 (' ')

posting

String posting
Posting category:post

creatorDataIn

CreatorDataIn creatorDataIn
取り込まれる日付の順序

billingDataInList

List billingDataInList
処理予定明細データのテーブル

cCardDataInList

List cCardDataInList
処理予定支払方法のテーブル

conditionDataInList

List conditionDataInList
処理予定条件のテーブル

errorsList

List errorsList
前明細の不正処理に関する情報

successList

List successList
正常に処理された明細のテーブル

textDataInList

List textDataInList
請求インタフェースの通信構造テキスト

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paytype

String paytype
支払手段: 支払カード計画の明細分類

ccType

String ccType
支払カードタイプ: カードタイプ

ccNumber

String ccNumber
支払カード: カード番号

ccSeqNo

String ccSeqNo
支払カード: 支払カード - 接尾辞

ccValidF

String ccValidF
支払カード: 使用有効開始日付

ccValidT

String ccValidT
支払カード: 有効終了日

ccName

String ccName
支払カード: カード所有者の氏名

authamount

String authamount
支払カード: 承認額

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

authFlag

String authFlag
支払カード: 振替権限

authDate

String authDate
支払カード: 承認日

authTime

String authTime
支払カード: 承認時刻

ccAuthNo

String ccAuthNo
支払カード: 承認番号

authRefno

String authRefno
支払カード: 決済代行会社の権限参照コード

merchidcl

String merchidcl
支払カード: 決済代行会社のマーチャント ID

terminal

String terminal
支払カード: 端末

dataorigin

String dataorigin
支払カード: 入力モード

ccSettled

String ccSettled
支払カード: 決済終了

ccLocId

String ccLocId
支払カード: トランザクション (入庫時点)

billPlan

String billPlan
請求計画番号

billPlani

String billPlani
明細: 請求計画/支払計画/支払カード

billValue

String billValue
請求金額: 請求計画に請求日付が指定されている場合

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

dataIndex

String dataIndex
別の構成のテーブル入力へのポインタ

condType

String condType
条件タイプ

condValue

String condValue
条件金額/率

condCurr

String condCurr
条件通貨 (累積項目用)

condPUnt

String condPUnt
価格条件単位

condDUnt

String condDUnt
伝票の条件単位

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

createdBy

String createdBy
オブジェクト登録者名

createdOn

String createdOn
レコード登録日

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refDocItem

String refDocItem
参照明細番号

type

String type
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

id

String id
メッセージ、メッセージクラス

number

String number
メッセージ、メッセージ番号

message

String message
メッセージテキスト

logNo

String logNo
アプリケーションログ: ログ番号

logMsgNo

String logMsgNo
アプリケーションログ: メッセージシリアル番号

messageV1

String messageV1
メッセージ、メッセージ変数

messageV2

String messageV2
メッセージ、メッセージ変数

messageV3

String messageV3
メッセージ、メッセージ変数

messageV4

String messageV4
メッセージ、メッセージ変数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refItem

String refItem
参照明細番号

applobject

String applobject
テキスト: アプリケーションオブジェクト

textId

String textId
テキスト ID

langu

String langu
言語キー

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController は BillingDocCreateMultiple を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

billingDocGetDetail

BillingDocGetDetail billingDocGetDetail
請求伝票詳細照会情報クラス

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController は BillingDocGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller は InquiryCreateFromData2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller は QuotationCreateFromData2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller は SalesOrderCreateFromDat2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController は SalesOrderGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController は SalesOrderGetStatus を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

billingdocument

String billingdocument
処理予定の請求伝票数

billingDocumentDetail

BillingDocumentDetail billingDocumentDetail
請求伝票に関する詳細情報

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

refDocRange

RefDocRange refDocRange
前伝票の範囲

billingDocumentDetailListList

List billingDocumentDetailListList
後続請求伝票のテーブル

successList

List successList
後続請求伝票の明細テーブル

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

refDocLow

String refDocLow
前伝票の開始伝票番号

refDocHigh

String refDocHigh
前伝票の終了伝票番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

billingdoc

String billingdoc
請求伝票

billType

String billType
請求タイプ

billcateg

String billcateg
請求カテゴリ

sdDocCat

String sdDocCat
販売管理伝票カテゴリ

currency

String currency
販売伝票通貨

currencyIso

String currencyIso
ISO 通貨コード

acctstatus

String acctstatus
会計への転記ステータス

netValue

String netValue
正味金額

taxValue

String taxValue
税額

cancelled

String cancelled
中止区分

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList は BillingDocumentDetail を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

context

String context
CU: 選定の BLOB (SCE)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

objType

String objType
対象タイプ

classType

String classType
クラスタイプ

objKey

String objKey
対象キー

objTxt

String objTxt
言語依存対象テキスト

quantity

String quantity
インスタンス数量

author

String author
報告書提案済

quantityUnit

String quantityUnit
数量単位

complete

String complete
一般区分

consistent

String consistent
一般区分

objectGuid

String objectGuid
インスタンス用 TYPE_OF ステートメントの GUID

persistId

String persistId
インスタンス番号 (固定)

persistIdType

String persistIdType
インスタンス番号タイプ (固定)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

parentId

String parentId
選定におけるインスタンス番号

instId

String instId
選定におけるインスタンス番号

partOfNo

String partOfNo
Part_of 明細番号

objType

String objType
対象タイプ

classType

String classType
クラスタイプ

objKey

String objKey
対象キー

author

String author
報告書提案済

salesRelevant

String salesRelevant
この部品は販売に関連しています

partOfGuid

String partOfGuid
インスタンス用 PART_OF ステートメントの GUID

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef は Object を拡張し、Serializable を実装しています

直列化されたフィールド

posex

String posex
外部明細番号

configId

String configId
外部選定 ID (仮)

rootId

String rootId
選定におけるインスタンス番号

sce

String sce
CUX: 選定タイプ

kbname

String kbname
ナレッジベースオブジェクト

kbversion

String kbversion
SCE ナレッジベースの実行時バージョン

complete

String complete
一般区分

consistent

String consistent
一般区分

cfginfo

String cfginfo
CU: 選定の BLOB (SCE)

kbprofile

String kbprofile
ナレッジベースプロファイル

kblanguage

String kblanguage
システム設定の言語

cbaseId

String cbaseId
インスタンス番号 (固定)

cbaseIdType

String cbaseIdType
インスタンス番号タイプ (固定)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst は Object を拡張し、Serializable を実装しています

直列化されたフィールド

posex

String posex
外部明細番号

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

charc

String charc
特性名

charcTxt

String charcTxt
言語依存特性テキスト

value

String value
特性値

valueTxt

String valueTxt
特性値の言語依存テキスト

author

String author
報告書提案済

valueTo

String valueTo
特性値

valcode

String valcode
値タイプ: 範囲制限 - 単一値

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

vkey

String vkey
バリアント条件名

factor

String factor
バリアント条件の加重係数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件カウンタ

condType

String condType
条件タイプ

condValue

String condValue
条件レート

currency

String currency
通貨コード

condUnit

String condUnit
条件単位

condPUnt

String condPUnt
価格条件単位

currIso

String currIso
ISO コード通貨

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

applicatio

String applicatio
アプリケーション

conpricdat

String conpricdat
条件価格設定日付

calctypcon

String calctypcon
条件計算タイプ

conbaseval

String conbaseval
条件基礎値

conexchrat

String conexchrat
現地通貨への換算レートに対する条件

numconvert

String numconvert
条件単位を基本単位へ変換する分子

denominato

String denominato
条件単位を基本単位へ変換する分母

condtype

String condtype
条件カテゴリ (例: 税、運賃、価格、原価)

statCon

String statCon
統計に適用する条件

scaletype

String scaletype
スケールタイプ

accruals

String accruals
見越額関連条件 (運賃など)

coninvolst

String coninvolst
請求書一覧条件

condorigin

String condorigin
条件生成区分

groupcond

String groupcond
グループ条件区分

condUpdat

String condUpdat
条件更新

accessSeq

String accessSeq
検索順序 - 検索番号

condcount

String condcount
条件連続番号

roundoffdi

String roundoffdi
BAPI の通貨額 (小数点以下９桁)

condvalue

String condvalue
条件金額

currency2

String currency2
販売伝票通貨

currIso2

String currIso2
ISO コード通貨

condcntrl

String condcntrl
条件管理

condisacti

String condisacti
無効条件

condclass

String condclass
条件クラス

factbasval

String factbasval
条件基礎値に対する要因

scalebasin

String scalebasin
スケール基準区分

scalbasval

String scalbasval
条件のスケール基準値

unitmeasur

String unitmeasur
条件スケール単位

isoUnit

String isoUnit
単位の ISO コード

currenckey

String currenckey
スケール通貨

curreniso

String curreniso
ISO コード通貨

condincomp

String condincomp
会社間請求の条件

condconfig

String condconfig
システム設定の条件

condchaman

String condchaman
条件 (マニュアル変更済)

condNo

String condNo
条件レコード番号

taxCode

String taxCode
消費税コード

varcond

String varcond
バリアント条件

accountkey

String accountkey
勘定キー

accountKe

String accountKe
勘定キー 見越/引当

wtWithcd

String wtWithcd
源泉徴収税コード

structcond

String structcond
構造条件

factconbas

String factconbas
条件基準の係数 (期間)

condcoinhd

String condcoinhd
条件カウンタ (ヘッダ条件)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件連続番号

condType

String condType
条件タイプ

updateflag

String updateflag
更新区分

condValue

String condValue
関連ユーザデータ項目の更新情報

currency

String currency
関連ユーザデータ項目の更新情報

condUnit

String condUnit
関連ユーザデータ項目の更新情報

condPUnt

String condPUnt
関連ユーザデータ項目の更新情報

varcond

String varcond
バリアント条件

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

refdoctype

String refdoctype
参照オブジェクトの伝票タイプ

docType

String docType
販売伝票タイプ

collectNo

String collectNo
一括番号

salesOrg

String salesOrg
販売組織

distrChan

String distrChan
流通チャネル

division

String division
製品部門

salesGrp

String salesGrp
営業グループ

salesOff

String salesOff
営業所

reqDateH

String reqDateH
指定納入期日

dateType

String dateType
提案日付タイプ

purchDate

String purchDate
得意先発注日付

poMethod

String poMethod
得意先発注タイプ

poSupplem

String poSupplem
得意先発注番号補足

ref1

String ref1
得意先/仕入先の内部参照コード

name

String name
発注者名称

telephone

String telephone
電話番号

priceGrp

String priceGrp
価格グループ (得意先)

custGroup

String custGroup
得意先グループ

salesDist

String salesDist
販売地域

priceList

String priceList
価格表タイプ

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ 2

pmnttrms

String pmnttrms
支払条件キー

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

billBlock

String billBlock
販売管理伝票の請求ブロック

ordReason

String ordReason
受注理由 (取引理由)

complDlv

String complDlv
一括納入区分

priceDate

String priceDate
価格設定/外貨換算の実行日付

qtValidF

String qtValidF
見積/引合有効開始日

qtValidT

String qtValidT
見積の有効終了日

ctValidF

String ctValidF
有効開始日付 (販売契約/品目提案)

ctValidT

String ctValidT
有効終了日付 (販売契約/品目提案)

custGrp1

String custGrp1
得意先グループ 1

custGrp2

String custGrp2
得意先グループ 2

custGrp3

String custGrp3
得意先グループ 3

custGrp4

String custGrp4
得意先グループ 4

custGrp5

String custGrp5
得意先グループ 5

purchNoC

String purchNoC
出荷先発注番号

purchNoS

String purchNoS
出荷先の得意先発注番号

poDatS

String poDatS
出荷先の出荷先発注日付

poMethS

String poMethS
出荷先の出荷先発注タイプ

ref1S

String ref1S
出荷先文字

sdDocCat

String sdDocCat
販売管理伝票カテゴリ

docDate

String docDate
伝票日付 (受信日/送信日)

warDate

String warDate
保証期間の開始日付

shipCond

String shipCond
出荷条件

ppSearch

String ppSearch
品目提案検索条件

dunCount

String dunCount
得意先商談回数

dunDate

String dunDate
得意先との前回の商談日

dlvschduse

String dlvschduse
用途区分

pldlvstyp

String pldlvstyp
MRP: 出荷計画タイプ

refDoc

String refDoc
参照伝票番号

compCdeB

String compCdeB
請求対象会社コード

alttaxCls

String alttaxCls
代替税分類

taxClass2

String taxClass2
得意先税分類 2

taxClass3

String taxClass3
得意先税分類 3

taxClass4

String taxClass4
得意先に対する税クラス 4

taxClass5

String taxClass5
得意先に対する税クラス 5

taxClass6

String taxClass6
得意先に対する税クラス 6

taxClass7

String taxClass7
得意先に対する税クラス 7

taxClass8

String taxClass8
得意先に対する税クラス 8

taxClass9

String taxClass9
得意先に対する税クラス 9

refDocL

String refDocL
参照伝票番号

assNumber

String assNumber
割当番号

refdocCat

String refdocCat
先行販売管理伝票の伝票カテゴリ

ordcombIn

String ordcombIn
受注結合出荷区分

billSched

String billSched
請求日程 (稼働日カレンダ指定)

invoSched

String invoSched
請求書一覧日程 (稼働日カレンダ指定)

mnInvoice

String mnInvoice
マニュアル請求書更新

exrateFi

String exrateFi
FI 転記の換算レート (直接相場)

addValDy

String addValDy
有効日からの日数

fixValDy

String fixValDy
有効日日付

pymtMeth

String pymtMeth
支払方法

accntAsgn

String accntAsgn
得意先の勘定設定グループ

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

billDate

String billDate
請求索引および印刷に対する請求日

servDate

String servDate
サービス提供日

dunnKey

String dunnKey
督促処理キー

dunnBlock

String dunnBlock
督促処理保留

pmtgarPro

String pmtgarPro
支払保証決定表

departmNo

String departmNo
部門コード

recPoint

String recPoint
入荷ポイント

docNumFi

String docNumFi
ドキュメンタリクレジット処理: 内部番号

cstcndgrp1

String cstcndgrp1
得意先条件グループ１

cstcndgrp2

String cstcndgrp2
得意先条件グループ２

cstcndgrp3

String cstcndgrp3
得意先条件グループ３

cstcndgrp4

String cstcndgrp4
得意先条件グループ４

cstcndgrp5

String cstcndgrp5
得意先条件グループ５

dlvTime

String dlvTime
契約出荷期間

currency

String currency
販売伝票通貨

currIso

String currIso
ISO コード通貨

createdBy

String createdBy
オブジェクト登録者名

taxdepCty

String taxdepCty
税出荷国

taxdstCty

String taxdstCty
税仕向国

eutriDeal

String eutriDeal
フラグ: EC 内三角取引

mastContr

String mastContr
グループマスタ契約番号

refProc

String refProc
参照限定条件: 決定区分

chkprtauth

String chkprtauth
取引先権限チェック

cmlqtyDat

String cmlqtyDat
累積出荷数量日付

version

String version
販売伝票バージョン番号

notifNo

String notifNo
通知番号

wbsElem

String wbsElem
WBS 要素

exchRateFiV

String exchRateFiV
FI 転記の換算レート (間接相場)

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

fkkConacct

String fkkConacct
長さ 12 の文字項目

campaign

String campaign
総括プロジェクト計画: 外部 SAP システムの GUID

docClass

String docClass
リリースおよびトランザクション管理を備えた元システム

hCurr

String hCurr
通貨コード

hCurrIso

String hCurrIso
ISO 通貨コード

shipType

String shipType
出荷タイプ

sProcInd

String sProcInd
特別処理区分

refDocLLong

String refDocLLong
参照伝票番号 (依存関係についてはテキスト (長) を参照)

lineTime

String lineTime
納入日程の提案時刻 (現地時間: 販売組織参照)

calcMotive

String calcMotive
計算区分

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

updateflag

String updateflag
更新区分

docType

String docType
関連ユーザデータ項目の更新情報

collectNo

String collectNo
関連ユーザデータ項目の更新情報

salesOrg

String salesOrg
関連ユーザデータ項目の更新情報

distrChan

String distrChan
関連ユーザデータ項目の更新情報

division

String division
関連ユーザデータ項目の更新情報

salesGrp

String salesGrp
関連ユーザデータ項目の更新情報

salesOff

String salesOff
関連ユーザデータ項目の更新情報

reqDateH

String reqDateH
関連ユーザデータ項目の更新情報

dateType

String dateType
関連ユーザデータ項目の更新情報

purchDate

String purchDate
関連ユーザデータ項目の更新情報

poMethod

String poMethod
関連ユーザデータ項目の更新情報

poSupplem

String poSupplem
関連ユーザデータ項目の更新情報

ref1

String ref1
関連ユーザデータ項目の更新情報

name

String name
関連ユーザデータ項目の更新情報

telephone

String telephone
関連ユーザデータ項目の更新情報

priceGrp

String priceGrp
関連ユーザデータ項目の更新情報

custGroup

String custGroup
関連ユーザデータ項目の更新情報

salesDist

String salesDist
関連ユーザデータ項目の更新情報

priceList

String priceList
関連ユーザデータ項目の更新情報

incoterms1

String incoterms1
関連ユーザデータ項目の更新情報

incoterms2

String incoterms2
関連ユーザデータ項目の更新情報

pmnttrms

String pmnttrms
関連ユーザデータ項目の更新情報

dlvBlock

String dlvBlock
関連ユーザデータ項目の更新情報

billBlock

String billBlock
関連ユーザデータ項目の更新情報

ordReason

String ordReason
関連ユーザデータ項目の更新情報

complDlv

String complDlv
関連ユーザデータ項目の更新情報

priceDate

String priceDate
関連ユーザデータ項目の更新情報

qtValidF

String qtValidF
関連ユーザデータ項目の更新情報

qtValidT

String qtValidT
関連ユーザデータ項目の更新情報

ctValidF

String ctValidF
関連ユーザデータ項目の更新情報

ctValidT

String ctValidT
関連ユーザデータ項目の更新情報

custGrp1

String custGrp1
関連ユーザデータ項目の更新情報

custGrp2

String custGrp2
関連ユーザデータ項目の更新情報

custGrp3

String custGrp3
関連ユーザデータ項目の更新情報

custGrp4

String custGrp4
関連ユーザデータ項目の更新情報

custGrp5

String custGrp5
関連ユーザデータ項目の更新情報

purchNoC

String purchNoC
関連ユーザデータ項目の更新情報

purchNoS

String purchNoS
関連ユーザデータ項目の更新情報

poDatS

String poDatS
関連ユーザデータ項目の更新情報

poMethS

String poMethS
関連ユーザデータ項目の更新情報

ref1S

String ref1S
関連ユーザデータ項目の更新情報

sdDocCat

String sdDocCat
関連ユーザデータ項目の更新情報

docDate

String docDate
関連ユーザデータ項目の更新情報

warDate

String warDate
関連ユーザデータ項目の更新情報

shipCond

String shipCond
関連ユーザデータ項目の更新情報

ppSearch

String ppSearch
関連ユーザデータ項目の更新情報

dunCount

String dunCount
関連ユーザデータ項目の更新情報

dunDate

String dunDate
関連ユーザデータ項目の更新情報

dlvschduse

String dlvschduse
関連ユーザデータ項目の更新情報

pldlvstyp

String pldlvstyp
関連ユーザデータ項目の更新情報

refDoc

String refDoc
関連ユーザデータ項目の更新情報

compCdeB

String compCdeB
関連ユーザデータ項目の更新情報

alttaxCls

String alttaxCls
関連ユーザデータ項目の更新情報

taxClass2

String taxClass2
関連ユーザデータ項目の更新情報

taxClass3

String taxClass3
関連ユーザデータ項目の更新情報

taxClass4

String taxClass4
関連ユーザデータ項目の更新情報

taxClass5

String taxClass5
関連ユーザデータ項目の更新情報

taxClass6

String taxClass6
関連ユーザデータ項目の更新情報

taxClass7

String taxClass7
関連ユーザデータ項目の更新情報

taxClass8

String taxClass8
関連ユーザデータ項目の更新情報

taxClass9

String taxClass9
関連ユーザデータ項目の更新情報

refDocL

String refDocL
関連ユーザデータ項目の更新情報

assNumber

String assNumber
関連ユーザデータ項目の更新情報

refdocCat

String refdocCat
関連ユーザデータ項目の更新情報

ordcombIn

String ordcombIn
関連ユーザデータ項目の更新情報

billSched

String billSched
関連ユーザデータ項目の更新情報

invoSched

String invoSched
関連ユーザデータ項目の更新情報

mnInvoice

String mnInvoice
関連ユーザデータ項目の更新情報

exrateFi

String exrateFi
関連ユーザデータ項目の更新情報

addValDy

String addValDy
関連ユーザデータ項目の更新情報

fixValDy

String fixValDy
関連ユーザデータ項目の更新情報

pymtMeth

String pymtMeth
関連ユーザデータ項目の更新情報

accntAsgn

String accntAsgn
関連ユーザデータ項目の更新情報

exchgRate

String exchgRate
関連ユーザデータ項目の更新情報

billDate

String billDate
関連ユーザデータ項目の更新情報

servDate

String servDate
関連ユーザデータ項目の更新情報

dunnKey

String dunnKey
関連ユーザデータ項目の更新情報

dunnBlock

String dunnBlock
関連ユーザデータ項目の更新情報

promotion

String promotion
関連ユーザデータ項目の更新情報

pmtgarPro

String pmtgarPro
関連ユーザデータ項目の更新情報

departmNo

String departmNo
関連ユーザデータ項目の更新情報

recPoint

String recPoint
関連ユーザデータ項目の更新情報

poitmNoS

String poitmNoS
関連ユーザデータ項目の更新情報

docNumFi

String docNumFi
関連ユーザデータ項目の更新情報

cstcndgrp1

String cstcndgrp1
関連ユーザデータ項目の更新情報

cstcndgrp2

String cstcndgrp2
関連ユーザデータ項目の更新情報

cstcndgrp3

String cstcndgrp3
関連ユーザデータ項目の更新情報

cstcndgrp4

String cstcndgrp4
関連ユーザデータ項目の更新情報

cstcndgrp5

String cstcndgrp5
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

currency

String currency
関連ユーザデータ項目の更新情報

taxdepCty

String taxdepCty
関連ユーザデータ項目の更新情報

taxdstCty

String taxdstCty
関連ユーザデータ項目の更新情報

eutriDeal

String eutriDeal
関連ユーザデータ項目の更新情報

mastContr

String mastContr
関連ユーザデータ項目の更新情報

refProc

String refProc
関連ユーザデータ項目の更新情報

chkprtauth

String chkprtauth
関連ユーザデータ項目の更新情報

cmlqtyDat

String cmlqtyDat
関連ユーザデータ項目の更新情報

version

String version
関連ユーザデータ項目の更新情報

notifNo

String notifNo
関連ユーザデータ項目の更新情報

wbsElem

String wbsElem
関連ユーザデータ項目の更新情報

exchRateFiV

String exchRateFiV
関連ユーザデータ項目の更新情報

exchgRateV

String exchgRateV
関連ユーザデータ項目の更新情報

fkkConacct

String fkkConacct
関連ユーザデータ項目の更新情報

campaign

String campaign
関連ユーザデータ項目の更新情報

docClass

String docClass
関連ユーザデータ項目の更新情報

hCurr

String hCurr
関連ユーザデータ項目の更新情報

shipType

String shipType
関連ユーザデータ項目の更新情報

sProcInd

String sProcInd
関連ユーザデータ項目の更新情報

lineTime

String lineTime
関連ユーザデータ項目の更新情報

calcMotive

String calcMotive
関連ユーザデータ項目の更新情報

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

hgLvItem

String hgLvItem
上位レベル明細

poItmNo

String poItmNo
元となる購買発注の明細番号

material

String material
品目コード

altToItm

String altToItm
代替明細

custMat22

String custMat22
得意先品目コード (無効)

batch

String batch
ロット番号

dlvGroup

String dlvGroup
出荷グループ (明細一括出荷)

partDlv

String partDlv
明細レベルの分納納入

reasonRej

String reasonRej
見積および受注の拒否理由

billBlock

String billBlock
ブロック

billDate

String billDate
請求索引および印刷に対する請求日

plant

String plant
プラント

storeLoc

String storeLoc
保管場所

targetQty

String targetQty
目標数量（販売単位）

targetQu

String targetQu
目標数量 (数量単位)

tUnitIso

String tUnitIso
目標数量単位 (ISO コード)

itemCateg

String itemCateg
明細カテゴリ (販売伝票)

shortText

String shortText
テキスト (短): 受注明細

prcGroup1

String prcGroup1
品目グループ 1

prcGroup2

String prcGroup2
品目グループ 2

prcGroup3

String prcGroup3
品目グループ 3

prcGroup4

String prcGroup4
品目グループ 4

prcGroup5

String prcGroup5
品目グループ 5

prodHiera

String prodHiera
品目階層

matlGroup

String matlGroup
品目グループ

purchNoC

String purchNoC
出荷先発注番号

purchDate

String purchDate
得意先発注日付

poMethod

String poMethod
得意先発注タイプ

ref1

String ref1
得意先/仕入先の内部参照コード

purchNoS

String purchNoS
出荷先の得意先発注番号

poDatS

String poDatS
出荷先の出荷先発注日付

poMethS

String poMethS
出荷先の出荷先発注タイプ

ref1S

String ref1S
出荷先文字

poitmNoS

String poitmNoS
元となる購買発注の明細番号

priceGrp

String priceGrp
価格グループ (得意先)

custGroup

String custGroup
得意先グループ

salesDist

String salesDist
販売地域

priceList

String priceList
価格表タイプ

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ 2

ordcompIn

String ordcompIn
受注結合出荷区分

billSched

String billSched
請求日程 (稼働日カレンダ指定)

invoSched

String invoSched
請求書一覧日程 (稼働日カレンダ指定)

mnInvoice

String mnInvoice
マニュアル請求書更新

exRateFi

String exRateFi
FI 転記の換算レート (直接相場)

addValDy

String addValDy
有効日からの日数

fixValDy

String fixValDy
有効日日付

pmnttrms

String pmnttrms
支払条件キー

pymtMeth

String pymtMeth
支払方法

accntAsgn

String accntAsgn
得意先の勘定設定グループ

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

priceDate

String priceDate
価格設定/外貨換算の実行日付

servDate

String servDate
サービス提供日

dunnKey

String dunnKey
督促処理キー

dunnBlock

String dunnBlock
督促処理保留

promotion

String promotion
プロモーション

pmtgarPro

String pmtgarPro
支払保証決定表

docNumFi

String docNumFi
ドキュメンタリクレジット処理: 内部番号

departmNo

String departmNo
部門コード

recPoint

String recPoint
入荷ポイント

cstcndgrp1

String cstcndgrp1
得意先条件グループ１

cstcndgrp2

String cstcndgrp2
得意先条件グループ２

cstcndgrp3

String cstcndgrp3
得意先条件グループ３

cstcndgrp4

String cstcndgrp4
得意先条件グループ４

cstcndgrp5

String cstcndgrp5
得意先条件グループ５

dlvTime

String dlvTime
契約出荷期間

salesUnit

String salesUnit
販売単位

sUnitIso

String sUnitIso
単位の ISO コード

trgQtyNo

String trgQtyNo
販売単位から基本単位への換算係数

trgqtyDen

String trgqtyDen
販売単位から基本単位への換算係数

rnddlvQty

String rnddlvQty
丸め数量: 出荷

maxdevamnt

String maxdevamnt
数量に関する許容偏差 (絶対値)

maxdevper

String maxdevper
数量に関する許容偏差 (%)

maxdevDay

String maxdevDay
シフト所要日数

usageInd

String usageInd
未使用 - 予約長 3

fixedQuan

String fixedQuan
数量固定区分

unlmtDlv

String unlmtDlv
区分: 無制限過剰納入可能

overdlvtol

String overdlvtol
過剰納入許容範囲

unddlvTol

String unddlvTol
不足納入許容範囲リミット

division

String division
製品部門

salqtynum

String salqtynum
販売数量単位から基本数量単位への変換係数の分子

salqtyden

String salqtyden
販売数量単位を SKU に換算するための分母 (除数)

grossWght

String grossWght
明細の総重量

netWeight

String netWeight
明細の正味重量

untofWght

String untofWght
重量単位

unofWtiso

String unofWtiso
ISO コードでの重量単位

volume

String volume
明細の総数量

volunit

String volunit
容積単位

volunitiso

String volunitiso
ISO コードでの容積単位

dlvPrio

String dlvPrio
出荷優先順位

shipPoint

String shipPoint
出荷ポイント/入荷ポイント

route

String route
輸送経路

createdBy

String createdBy
オブジェクト登録者名

taxClass1

String taxClass1
品目の税分類

taxClass2

String taxClass2
品目の税分類

taxClass3

String taxClass3
品目の税分類

taxClass4

String taxClass4
品目の税分類

taxClass5

String taxClass5
品目の税分類

taxClass6

String taxClass6
品目の税分類

taxClass7

String taxClass7
品目の税分類

taxClass8

String taxClass8
品目の税分類

taxClass9

String taxClass9
品目の税分類

matPrGrp

String matPrGrp
品目価格設定グループ

valType

String valType
評価タイプ

fixdatQty

String fixdatQty
納期と出荷数量の固定

bomexplNo

String bomexplNo
BOM 展開番号

resanalkey

String resanalkey
結果分析キー

reqmtsTyp

String reqmtsTyp
所要量タイプ

noGrPost

String noGrPost
得意先が入庫を転記していません

busTranst

String busTranst
貿易管理の取引タイプ

overhdKey

String overhdKey
間接費キー

cstgSheet

String cstgSheet
原価計算表

matfrgtgrp

String matfrgtgrp
品目運賃グループ

pldlvshdin

String pldlvshdin
出荷計画に関する指示

seqNo

String seqNo
KANBAN/連続番号

bilForm

String bilForm
請求書式

dliProfil

String dliProfil
動的明細プロセッサプロファイル

revType

String revType
収益承認カテゴリ

begdemPer

String begdemPer
見越期間の提案開始日付

prRefMat

String prRefMat
価格設定参照品目

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

orderProb

String orderProb
明細の受注可能性

maxPlDlv

String maxPlDlv
明細ごとの分割納入可能な最大回数

cfopCode

String cfopCode
CFOP code and extension (old 5 char version)

taxlawicms

String taxlawicms
税法: ICMS

taxlawipi

String taxlawipi
税法: IPI

sdTaxcode

String sdTaxcode
0

assortMod

String assortMod
品揃モジュール

compQuant

String compQuant
構成品目数量

targetVal

String targetVal
BAPI の通貨額 (小数点以下９桁)

currency

String currency
販売伝票通貨

currIso

String currIso
ISO コード通貨

profitCtr

String profitCtr
利益センタ

orderid

String orderid
指図番号

wbsElem

String wbsElem
WBS 要素

deprecPer

String deprecPer
ドキュメンタリクレジット処理に関する償却率 (%)

refDoc

String refDoc
参照伝票番号

refDocIt

String refDocIt
参照明細番号

refDocCa

String refDocCa
先行販売管理伝票の伝票カテゴリ

custMat35

String custMat35
得意先品目

exchRateFiV

String exchRateFiV
FI 転記の換算レート (間接相場)

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

itemguidAtp

String itemguidAtp
ATP: 暗号 - DELNR および DELPS

valContr

String valContr
金額契約番号

valConI

String valConI
金額契約明細

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

matExt

String matExt
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

matGuid

String matGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

matVers

String matVers
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

pMatExt

String pMatExt
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

pMatGuid

String pMatGuid
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

pMatVers

String pMatVers
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

funcArea

String funcArea
機能領域

alternBom

String alternBom
代替 BOM

fkkConacct

String fkkConacct
長さ 12 の文字項目

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

prodcat

String prodcat
製品カタログ番号

shipType

String shipType
出荷タイプ

sProcInd

String sProcInd
特別処理区分

funcAreaLong

String funcAreaLong
機能領域

billRel

String billRel
請求関連 (CRM)

vwUepos

String vwUepos
上位レベル明細用途 ID

campaign

String campaign
総括プロジェクト計画: 外部 SAP システムの GUID

dlvschduse

String dlvschduse
用途区分

cfopLong

String cfopLong
CFOP code and extension

selection

String selection
選択 ID (永続)

matEntrd

String matEntrd
入力品目

logSystemOwn

String logSystemOwn
論理システム

itmTypeUsage

String itmTypeUsage
明細用途

index

int index
レコード番号

taxlawiss

String taxlawiss
ISS Tax Law

matEntrdExternal

String matEntrdExternal
項目 MAT_ENTRD の品目コード (長)

matEntrdGuid

String matEntrdGuid
項目 MAT_ENTRD の外部 GUID

matEntrdVersion

String matEntrdVersion
項目 MAT_ENTRD のバージョン番号

locTaxcat

String locTaxcat
税タイプ

locZerovat

String locZerovat
locZerovat

locActcode

String locActcode
総所得税の活動コード

locDisttype

String locDisttype
所得税の配賦タイプ

locTxrelclas

String locTxrelclas
税関連分類

calcMotive

String calcMotive
計算区分

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

updateflag

String updateflag
更新区分

hgLvItem

String hgLvItem
関連ユーザデータ項目の更新情報

poItmNo

String poItmNo
関連ユーザデータ項目の更新情報

material

String material
関連ユーザデータ項目の更新情報

altToItm

String altToItm
関連ユーザデータ項目の更新情報

custMat22

String custMat22
関連ユーザデータ項目の更新情報

batch

String batch
関連ユーザデータ項目の更新情報

dlvGroup

String dlvGroup
関連ユーザデータ項目の更新情報

partDlv

String partDlv
関連ユーザデータ項目の更新情報

reasonRej

String reasonRej
関連ユーザデータ項目の更新情報

billBlock

String billBlock
関連ユーザデータ項目の更新情報

billDate

String billDate
関連ユーザデータ項目の更新情報

plant

String plant
関連ユーザデータ項目の更新情報

storeLoc

String storeLoc
関連ユーザデータ項目の更新情報

targetQty

String targetQty
関連ユーザデータ項目の更新情報

targetQu

String targetQu
関連ユーザデータ項目の更新情報

tUnitIso

String tUnitIso
関連ユーザデータ項目の更新情報

itemCateg

String itemCateg
関連ユーザデータ項目の更新情報

shortText

String shortText
関連ユーザデータ項目の更新情報

prcGroup1

String prcGroup1
関連ユーザデータ項目の更新情報

prcGroup2

String prcGroup2
関連ユーザデータ項目の更新情報

prcGroup3

String prcGroup3
関連ユーザデータ項目の更新情報

prcGroup4

String prcGroup4
関連ユーザデータ項目の更新情報

prcGroup5

String prcGroup5
関連ユーザデータ項目の更新情報

prodHiera

String prodHiera
関連ユーザデータ項目の更新情報

matlGroup

String matlGroup
関連ユーザデータ項目の更新情報

purchNoC

String purchNoC
関連ユーザデータ項目の更新情報

purchDate

String purchDate
関連ユーザデータ項目の更新情報

poMethod

String poMethod
関連ユーザデータ項目の更新情報

ref1

String ref1
関連ユーザデータ項目の更新情報

purchNoS

String purchNoS
関連ユーザデータ項目の更新情報

poDatS

String poDatS
関連ユーザデータ項目の更新情報

poMethS

String poMethS
関連ユーザデータ項目の更新情報

ref1S

String ref1S
関連ユーザデータ項目の更新情報

poitmNoS

String poitmNoS
関連ユーザデータ項目の更新情報

priceGrp

String priceGrp
関連ユーザデータ項目の更新情報

custGroup

String custGroup
関連ユーザデータ項目の更新情報

salesDist

String salesDist
関連ユーザデータ項目の更新情報

priceList

String priceList
関連ユーザデータ項目の更新情報

incoterms1

String incoterms1
関連ユーザデータ項目の更新情報

incoterms2

String incoterms2
関連ユーザデータ項目の更新情報

ordcompIn

String ordcompIn
関連ユーザデータ項目の更新情報

billSched

String billSched
関連ユーザデータ項目の更新情報

invoSched

String invoSched
関連ユーザデータ項目の更新情報

mnInvoice

String mnInvoice
関連ユーザデータ項目の更新情報

exRateFi

String exRateFi
関連ユーザデータ項目の更新情報

addValDy

String addValDy
関連ユーザデータ項目の更新情報

fixValDy

String fixValDy
関連ユーザデータ項目の更新情報

pmnttrms

String pmnttrms
関連ユーザデータ項目の更新情報

pymtMeth

String pymtMeth
関連ユーザデータ項目の更新情報

accntAsgn

String accntAsgn
関連ユーザデータ項目の更新情報

exchgRate

String exchgRate
関連ユーザデータ項目の更新情報

priceDate

String priceDate
関連ユーザデータ項目の更新情報

servDate

String servDate
関連ユーザデータ項目の更新情報

dunnKey

String dunnKey
関連ユーザデータ項目の更新情報

dunnBlock

String dunnBlock
関連ユーザデータ項目の更新情報

promotion

String promotion
関連ユーザデータ項目の更新情報

pmtgarPro

String pmtgarPro
関連ユーザデータ項目の更新情報

docNumFi

String docNumFi
関連ユーザデータ項目の更新情報

departmNo

String departmNo
関連ユーザデータ項目の更新情報

recPoint

String recPoint
関連ユーザデータ項目の更新情報

cstcndgrp1

String cstcndgrp1
関連ユーザデータ項目の更新情報

cstcndgrp2

String cstcndgrp2
関連ユーザデータ項目の更新情報

cstcndgrp3

String cstcndgrp3
関連ユーザデータ項目の更新情報

cstcndgrp4

String cstcndgrp4
関連ユーザデータ項目の更新情報

cstcndgrp5

String cstcndgrp5
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

salesUnit

String salesUnit
関連ユーザデータ項目の更新情報

trgQtyNo

String trgQtyNo
関連ユーザデータ項目の更新情報

trgqtyDen

String trgqtyDen
関連ユーザデータ項目の更新情報

rnddlvQty

String rnddlvQty
関連ユーザデータ項目の更新情報

maxdevamnt

String maxdevamnt
関連ユーザデータ項目の更新情報

maxdevper

String maxdevper
関連ユーザデータ項目の更新情報

maxdevDay

String maxdevDay
関連ユーザデータ項目の更新情報

usageInd

String usageInd
関連ユーザデータ項目の更新情報

fixedQuan

String fixedQuan
関連ユーザデータ項目の更新情報

unlmtDlv

String unlmtDlv
関連ユーザデータ項目の更新情報

overdlvtol

String overdlvtol
関連ユーザデータ項目の更新情報

unddlvTol

String unddlvTol
関連ユーザデータ項目の更新情報

division

String division
関連ユーザデータ項目の更新情報

salqtynum

String salqtynum
関連ユーザデータ項目の更新情報

salqtyden

String salqtyden
関連ユーザデータ項目の更新情報

grossWght

String grossWght
関連ユーザデータ項目の更新情報

netWeight

String netWeight
関連ユーザデータ項目の更新情報

untofWght

String untofWght
関連ユーザデータ項目の更新情報

volume

String volume
関連ユーザデータ項目の更新情報

volunit

String volunit
関連ユーザデータ項目の更新情報

dlvPrio

String dlvPrio
関連ユーザデータ項目の更新情報

shipPoint

String shipPoint
関連ユーザデータ項目の更新情報

route

String route
関連ユーザデータ項目の更新情報

taxClass1

String taxClass1
関連ユーザデータ項目の更新情報

taxClass2

String taxClass2
関連ユーザデータ項目の更新情報

taxClass3

String taxClass3
関連ユーザデータ項目の更新情報

taxClass4

String taxClass4
関連ユーザデータ項目の更新情報

taxClass5

String taxClass5
関連ユーザデータ項目の更新情報

taxClass6

String taxClass6
関連ユーザデータ項目の更新情報

taxClass7

String taxClass7
関連ユーザデータ項目の更新情報

taxClass8

String taxClass8
関連ユーザデータ項目の更新情報

taxClass9

String taxClass9
関連ユーザデータ項目の更新情報

matPrGrp

String matPrGrp
関連ユーザデータ項目の更新情報

valType

String valType
関連ユーザデータ項目の更新情報

fixdatQty

String fixdatQty
関連ユーザデータ項目の更新情報

bomexplNo

String bomexplNo
関連ユーザデータ項目の更新情報

resanalkey

String resanalkey
関連ユーザデータ項目の更新情報

reqmtsTyp

String reqmtsTyp
関連ユーザデータ項目の更新情報

noGrPost

String noGrPost
関連ユーザデータ項目の更新情報

busTranst

String busTranst
関連ユーザデータ項目の更新情報

overhdKey

String overhdKey
関連ユーザデータ項目の更新情報

cstgSheet

String cstgSheet
関連ユーザデータ項目の更新情報

matfrgtgrp

String matfrgtgrp
関連ユーザデータ項目の更新情報

pldlvshdin

String pldlvshdin
関連ユーザデータ項目の更新情報

seqNo

String seqNo
関連ユーザデータ項目の更新情報

bilForm

String bilForm
関連ユーザデータ項目の更新情報

dliProfil

String dliProfil
関連ユーザデータ項目の更新情報

revType

String revType
関連ユーザデータ項目の更新情報

begdemPer

String begdemPer
関連ユーザデータ項目の更新情報

prRefMat

String prRefMat
関連ユーザデータ項目の更新情報

refobjtype

String refobjtype
関連ユーザデータ項目の更新情報

refobjkey

String refobjkey
関連ユーザデータ項目の更新情報

reflogsys

String reflogsys
関連ユーザデータ項目の更新情報

orderProb

String orderProb
関連ユーザデータ項目の更新情報

maxPlDlv

String maxPlDlv
関連ユーザデータ項目の更新情報

cfopCode

String cfopCode
関連ユーザデータ項目の更新情報

taxlawicms

String taxlawicms
関連ユーザデータ項目の更新情報

taxlawipi

String taxlawipi
関連ユーザデータ項目の更新情報

sdTaxcode

String sdTaxcode
関連ユーザデータ項目の更新情報

assortMod

String assortMod
関連ユーザデータ項目の更新情報

compQuant

String compQuant
関連ユーザデータ項目の更新情報

targetVal

String targetVal
関連ユーザデータ項目の更新情報

profitCtr

String profitCtr
関連ユーザデータ項目の更新情報

orderid

String orderid
関連ユーザデータ項目の更新情報

wbsElem

String wbsElem
関連ユーザデータ項目の更新情報

deprecPer

String deprecPer
関連ユーザデータ項目の更新情報

refDoc

String refDoc
関連ユーザデータ項目の更新情報

refDocIt

String refDocIt
関連ユーザデータ項目の更新情報

refDocCa

String refDocCa
関連ユーザデータ項目の更新情報

custMat35

String custMat35
関連ユーザデータ項目の更新情報

exchRateFiV

String exchRateFiV
関連ユーザデータ項目の更新情報

exchgRateV

String exchgRateV
関連ユーザデータ項目の更新情報

itemguidAtp

String itemguidAtp
関連ユーザデータ項目の更新情報

valContr

String valContr
関連ユーザデータ項目の更新情報

valConI

String valConI
関連ユーザデータ項目の更新情報

configId

String configId
関連ユーザデータ項目の更新情報

instId

String instId
関連ユーザデータ項目の更新情報

matExt

String matExt
関連ユーザデータ項目の更新情報

matGuid

String matGuid
関連ユーザデータ項目の更新情報

matVers

String matVers
関連ユーザデータ項目の更新情報

pMatExt

String pMatExt
関連ユーザデータ項目の更新情報

pMatGuid

String pMatGuid
関連ユーザデータ項目の更新情報

pMatVers

String pMatVers
関連ユーザデータ項目の更新情報

funcArea

String funcArea
関連ユーザデータ項目の更新情報

alternBom

String alternBom
関連ユーザデータ項目の更新情報

fkkConacct

String fkkConacct
関連ユーザデータ項目の更新情報

eanUpc

String eanUpc
関連ユーザデータ項目の更新情報

prodcat

String prodcat
関連ユーザデータ項目の更新情報

shipType

String shipType
関連ユーザデータ項目の更新情報

sProcInd

String sProcInd
関連ユーザデータ項目の更新情報

billRel

String billRel
関連ユーザデータ項目の更新情報

vwUepos

String vwUepos
関連ユーザデータ項目の更新情報

campaign

String campaign
関連ユーザデータ項目の更新情報

dlvschduse

String dlvschduse
関連ユーザデータ項目の更新情報

selection

String selection
関連ユーザデータ項目の更新情報

matEntrd

String matEntrd
関連ユーザデータ項目の更新情報

logSystemOwn

String logSystemOwn
関連ユーザデータ項目の更新情報

itmTypeUsage

String itmTypeUsage
関連ユーザデータ項目の更新情報

matEntrdExternal

String matEntrdExternal
関連ユーザデータ項目の更新情報

matEntrdGuid

String matEntrdGuid
関連ユーザデータ項目の更新情報

matEntrdVersion

String matEntrdVersion
関連ユーザデータ項目の更新情報

locTaxcat

String locTaxcat
関連ユーザデータ項目の更新情報

locZerovat

String locZerovat
関連ユーザデータ項目の更新情報

locActcode

String locActcode
関連ユーザデータ項目の更新情報

locDisttype

String locDisttype
関連ユーザデータ項目の更新情報

locTxrelclas

String locTxrelclas
関連ユーザデータ項目の更新情報

calcMotive

String calcMotive
関連ユーザデータ項目の更新情報

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refobjtyp

String refobjtyp
オブジェクトタイプ

refobject

String refobject
オブジェクト名

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

docNumber

String docNumber
販売管理伝票番号

itmNumber

String itmNumber
販売伝票明細

schedLin

String schedLin
納入日程行

condNo

String condNo
伝票条件番号

conditemno

String conditemno
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件カウンタ

condType

String condType
条件タイプ

status

String status
単一文字フラグ

tindex

String tindex
数値項目: 長さ 6

address

String address
住所

abrli

String abrli
内部納入日程番号

abart

String abart
承認タイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

pricing

String pricing
価格設定タイプ

atpWrkmod

String atpWrkmod
ATP セッション: 結果取得/新規決定 APO-ATP

scheduling

String scheduling
単一文字フラグ

nostructure

String nostructure
チェックボックス

condHandl

String condHandl
選択: 条件行処理 (SD 伝票変更)

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.MaterialEvg は Object を拡張し、Serializable を実装しています

直列化されたフィールド

materialExt

String materialExt
外部品目コード

materialVers

String materialVers
品目バージョン番号

materialGuid

String materialGuid
品目コード(外部 GUID)

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamMaterialEvg は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses は Object を拡張し、Serializable を実装しています

直列化されたフィールド

addrNo

String addrNo
アドレス番号

formofaddr

String formofaddr
敬称テキスト

name

String name
名称 1

name2

String name2
名称 2

name3

String name3
名称 3

name4

String name4
名称 4

cOName

String cOName
気付

city

String city
市区町村

district

String district
所在地

cityNo

String cityNo
市区町村/地名ファイルの市区町村コード

postlCod1

String postlCod1
市区町村の郵便番号

postlCod2

String postlCod2
私書箱郵便番号

postlCod3

String postlCod3
会社郵便番号 (大規模なユーザ用)

poBox

String poBox
私書箱

poBoxCit

String poBoxCit
私書箱住所

delivDis

String delivDis
郵便配達地域

street

String street
地名

streetNo

String streetNo
市区町村/地名ファイルの地名コード

strAbbr

String strAbbr
地名の略称 (例: スペイン)

houseNo

String houseNo
番地-号

strSuppl1

String strSuppl1
地名 2

strSuppl2

String strSuppl2
地名 3

location

String location
地名 5

building

String building
旧: 建物 (番号または略称)

floor

String floor
建物の階

roomNo

String roomNo
部屋/アパート番号

country

String country
国コード

langu

String langu
言語キー

region

String region
地域 (都道府県)

sort1

String sort1
検索条件 1

sort2

String sort2
検索条件 2

timeZone

String timeZone
アドレスタイムゾーン

taxjurcode

String taxjurcode
税管轄コード

adrNotes

String adrNotes
住所注記

commType

String commType
通信方法 (キー) (アドレス管理)

tel1Numbr

String tel1Numbr
第一電話番号: ダイヤルコード + 番号

tel1Ext

String tel1Ext
第 1 電話番号: 内線

faxNumber

String faxNumber
第一 FAX 番号: ダイヤルコード + 番号

faxExtens

String faxExtens
第一 FAX 番号: 内線

streetLng

String streetLng
地名

distrctNo

String distrctNo
市区町村/地名ファイルの所在地コード

chckstatus

String chckstatus
市区町村ファイルテストステータス

pboxcitNo

String pboxcitNo
市区町村私書箱コード (市ファイル)

transpzone

String transpzone
商品の納入区域

houseNo2

String houseNo2
番地補足

eMail

String eMail
電子メールアドレス

strSuppl3

String strSuppl3
地名 4

title

String title
タイトル (敬称)

countryiso

String countryiso
ISO 国コード

languIso

String languIso
ISO 639 準拠の言語

buildLong

String buildLong
建物 (番号またはコード)

regiogroup

String regiogroup
地域構造グループ化

homeCity

String homeCity
市区町村 (郵便用市区町村と異なる場合)

homecityno

String homecityno
別の市区町村 (市区町村/地名ファイル)

pcode1Ext

String pcode1Ext
市区町村郵便番号の拡張子 例: 郵便番号 +4+2

pcode2Ext

String pcode2Ext
私書箱郵便番号拡張子 例: 郵便番号 +4+2

pcode3Ext

String pcode3Ext
主要得意先郵便番号拡張子 例: 郵便番号 +4+2

poWONo

String poWONo
フラグ: 郵便私書箱 (番号なし)

poBoxReg

String poBoxReg
私書箱の地域 (国、都道府県、地域、...)

poboxCtry

String poboxCtry
私書箱の国指定

poCtryiso

String poCtryiso
ISO 国コード

homepage

String homepage
URI 例: ホームページ、FTP アドレス

dontUseS

String dontUseS
地名住所配達不可フラグ

dontUseP

String dontUseP
私書箱住所配達不可フラグ

houseNo3

String houseNo3
番地範囲

languCr

String languCr
アドレスレコード登録オリジナル言語

langucriso

String langucriso
ISO 639 準拠の言語

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners は Object を拡張し、Serializable を実装しています

直列化されたフィールド

partnRole

String partnRole
取引先機能

partnNumb

String partnNumb
得意先コード 1

itmNumber

String itmNumber
明細番号 (販売管理伝票)

title

String title
敬称

name

String name
名称 1

name2

String name2
名称 2

name3

String name3
名称 3

name4

String name4
名称 4

street

String street
地名/番地-号

country

String country
国コード

countrIso

String countrIso
国キー (ISO コード)

postlCode

String postlCode
郵便番号

pobxPcd

String pobxPcd
私書箱番号

pobxCty

String pobxCty
私書箱住所

city

String city
市区町村

district

String district
所在地

region

String region
地域 (都道府県)

poBox

String poBox
私書箱

telephone

String telephone
電話番号 1

telephone2

String telephone2
電話番号 2

telebox

String telebox
テレボックス番号

faxNumber

String faxNumber
FAX 番号

teletexNo

String teletexNo
テレテクス番号

telexNo

String telexNo
テレックス番号

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

unloadPt

String unloadPt
荷渡ポイント

transpzone

String transpzone
商品の納入区域

taxjurcode

String taxjurcode
税計算管轄コード - 税管轄コード

address

String address
住所

privAddr

String privAddr
自宅住所

addrType

String addrType
アドレスタイプ (1=組織、2=個人、3=取引先担当者)

addrOrig

String addrOrig
コピー元住所

addrLink

String addrLink
住所コードへのリンク

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

schedLine

String schedLine
納入日程行

reqDate

String reqDate
納入日程日付

dateType

String dateType
日付タイプ (日、週、月、期間)

reqTime

String reqTime
納入時間

reqQty

String reqQty
販売単位による受注数量

reqDlvBl

String reqDlvBl
出荷ブロック中の納入日程行

schedType

String schedType
納入日程カテゴリ

tpDate

String tpDate
輸送計画日付

msDate

String msDate
品目利用可能日

loadDate

String loadDate
積載日付

giDate

String giDate
出庫日付

tpTime

String tpTime
輸送計画 - 時間 (現地時間/出荷ポイント参照)

msTime

String msTime
品目供給ステージ (現地時刻: プラント参照)

loadTime

String loadTime
積載時刻 (現地時間: 出荷ポイント)

giTime

String giTime
出庫時刻 (現地時間 - プラント参照)

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

dlvDate

String dlvDate
納入日程日付

dlvTime

String dlvTime
納入時間

relType

String relType
承認タイプ

planSchedType

String planSchedType
納入日程行タイプ EDI

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

schedLine

String schedLine
納入日程行

updateflag

String updateflag
更新区分

reqDate

String reqDate
関連ユーザデータ項目の更新情報

dateType

String dateType
関連ユーザデータ項目の更新情報

reqTime

String reqTime
関連ユーザデータ項目の更新情報

reqQty

String reqQty
関連ユーザデータ項目の更新情報

reqDlvBl

String reqDlvBl
関連ユーザデータ項目の更新情報

schedType

String schedType
関連ユーザデータ項目の更新情報

tpDate

String tpDate
関連ユーザデータ項目の更新情報

msDate

String msDate
関連ユーザデータ項目の更新情報

loadDate

String loadDate
関連ユーザデータ項目の更新情報

giDate

String giDate
関連ユーザデータ項目の更新情報

tpTime

String tpTime
関連ユーザデータ項目の更新情報

msTime

String msTime
関連ユーザデータ項目の更新情報

loadTime

String loadTime
関連ユーザデータ項目の更新情報

giTime

String giTime
関連ユーザデータ項目の更新情報

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

dlvDate

String dlvDate
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

relType

String relType
関連ユーザデータ項目の更新情報

planSchedType

String planSchedType
関連ユーザデータ項目の更新情報

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender は Object を拡張し、Serializable を実装しています

直列化されたフィールド

logSystem

String logSystem
論理システム

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Success は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refDocItem

String refDocItem
参照明細番号

billDoc

String billDoc
請求伝票

billDocItem

String billDocItem
請求伝票明細

netValue

String netValue
正味金額

taxValue

String taxValue
税額

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

netValueItem

String netValueItem
正味金額

taxValueItem

String taxValueItem
税額

groValueItem

String groValueItem
総額

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Text は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docNumber

String docNumber
販売伝票

itmNumber

String itmNumber
販売伝票明細

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

function

String function
機能

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception

クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
テスト実行

salesdocumentin

String salesdocumentin
販売管理伝票番号

intNumberAssignment

String intNumberAssignment
明細番号内部採番

behaveWhenError

String behaveWhenError
エラー処理

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

convert

String convert
変換: 取引先機能 + 受注伝票タイプ

salesdocument

String salesdocument
販売伝票番号

sender

Sender sender
論理システム - 送信者

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

inquiryHeaderInX

HeaderInX inquiryHeaderInX
ヘッダデータチェックボックス

inquiryHeaderIn

HeaderIn inquiryHeaderIn
引合伝票ヘッダデータ

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

inquiryCfgsBlobList

List inquiryCfgsBlobList
選定: BLOB 内部データ (SCE)

inquiryTextList

List inquiryTextList
テキスト

inquirySchedulesInXList

List inquirySchedulesInXList
納入日程行チェックボックス

inquirySchedulesInList

List inquirySchedulesInList
納入日程行

inquiryPartnersList

List inquiryPartnersList
伝票取引先

inquiryKeysList

List inquiryKeysList
参照キーの出力テーブル

inquiryItemsInXList

List inquiryItemsInXList
明細データチェックボックス

inquiryItemsInList

List inquiryItemsInList
明細データ

inquiryCfgsInstList

List inquiryCfgsInstList
選定: インスタンス

inquiryCfgsPartOfList

List inquiryCfgsPartOfList
選定: 部分設定

inquiryConditionsInXList

List inquiryConditionsInXList
受注における条件更新の通信項目

inquiryConditionsInList

List inquiryConditionsInList
条件

inquiryCfgsVkList

List inquiryCfgsVkList
選定: バリアント条件キー

inquiryCfgsValueList

List inquiryCfgsValueList
選定: 特性値

inquiryCfgsRefInstList

List inquiryCfgsRefInstList
選定: 参照明細/インスタンス

inquiryCfgsRefList

List inquiryCfgsRefList
選定: 参照データ

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

behaveWhenError

String behaveWhenError
エラー処理

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

convert

String convert
取引先機能/受注伝票タイプの変換

testrun

String testrun
テスト実行

intNumberAssignment

String intNumberAssignment
明細番号内部採番

salesdocumentin

String salesdocumentin
見積伝票番号

salesdocument

String salesdocument
販売管理伝票番号

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

sender

Sender sender
論理システム - 送信者

quotationHeaderInX

HeaderInX quotationHeaderInX
伝票ヘッダチェックボックス

quotationHeaderIn

HeaderIn quotationHeaderIn
伝票ヘッダデータ

quotationTextList

List quotationTextList
テキスト

quotationSchedulesInXList

List quotationSchedulesInXList
納入日程行データチェックボックス

quotationSchedulesInList

List quotationSchedulesInList
納入日程行データ

quotationPartnersList

List quotationPartnersList
伝票取引先

quotationKeysList

List quotationKeysList
参照キーの出力テーブル

quotationItemsInXList

List quotationItemsInXList
明細データチェックボックス

quotationItemsInList

List quotationItemsInList
明細データ

quotationConditionsInXList

List quotationConditionsInXList
受注における条件更新の通信項目

quotationConditionsInList

List quotationConditionsInList
条件

quotationCfgsVkList

List quotationCfgsVkList
選定: バリアント条件キー

quotationCfgsValueList

List quotationCfgsValueList
選定: 特性値

quotationCfgsRefInstList

List quotationCfgsRefInstList
選定: 参照明細/インスタンス

quotationCfgsRefList

List quotationCfgsRefList
選定: 参照データ

quotationCfgsPartOfList

List quotationCfgsPartOfList
選定: 部分設定

quotationCfgsInstList

List quotationCfgsInstList
選定: インスタンス

quotationCfgsBlobList

List quotationCfgsBlobList
選定: BLOB 内部データ (SCE)

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ccType

String ccType
支払カードタイプ: カードタイプ

ccNumber

String ccNumber
支払カード: カード番号

ccValidT

String ccValidT
支払カード: 有効終了日

ccName

String ccName
支払カード: カード所有者の氏名

billamount

String billamount
請求金額: 請求計画に請求日付が指定されている場合

authFlag

String authFlag
支払カード: 振替権限

authamount

String authamount
支払カード: 承認額

currency

String currency
通貨コード

currIso

String currIso
ISO コード通貨

authDate

String authDate
支払カード: 承認日

authTime

String authTime
支払カード: 承認時刻

authCcNo

String authCcNo
支払カード: 承認番号

authRefno

String authRefno
支払カード: 決済代行会社の権限参照コード

ccReact

String ccReact
支払カード: 権限確認に対する応答

ccReAmount

String ccReAmount
BAPI インタフェースの通貨金額

glAccount

String glAccount
G/L 勘定コード

ccStatEx

String ccStatEx
支払カード: 外部システム呼出時のステータス

ccReactT

String ccReactT
支払カード: 結果テキスト

virtCard

String virtCard
チェックボックス

merchidcl

String merchidcl
支払カード: 決済代行会社のマーチャント ID

preAuth

String preAuth
支払カード: 事前承認

ccSeqNo

String ccSeqNo
支払カード: 支払カード - 接尾辞

amountchan

String amountchan
支払カード: 金額変更

authortype

String authortype
支払カード: 承認タイプ

dataorigin

String dataorigin
支払カード: 入力モード

radrcheck1

String radrcheck1
支払カード: 住所チェックの結果 (住所結果)

radrcheck2

String radrcheck2
支払カード: 住所チェックの結果 (住所承認)

radrcheck3

String radrcheck3
支払カード: 住所チェックの結果 (郵便番号結果)

rcardcheck

String rcardcheck
支払カード: カードチェックの結果 (返信コード)

ccLimited

String ccLimited
支払カード: 限度額

ccVerifValue

String ccVerifValue
カード照合額

ccCtrlField

String ccCtrlField
カード照合額の制御項目

ccInUseSt

String ccInUseSt
カード照合額の使用ステータス

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

salesdocumentin

String salesdocumentin
販売管理伝票番号

intNumberAssignment

String intNumberAssignment
明細番号内部採番

testrun

String testrun
テスト実行

convert

String convert
変換: 取引先機能 + 受注伝票タイプ

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

behaveWhenError

String behaveWhenError
エラー処理

salesdocument

String salesdocument
生成された伝票の番号

orderHeaderIn

HeaderIn orderHeaderIn
受注伝票ヘッダ

orderHeaderInX

HeaderInX orderHeaderInX
受注伝票チェックリスト

sender

Sender sender
論理システム - 送信者

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

orderItemsInXList

List orderItemsInXList
明細データチェックボックス

orderKeysList

List orderKeysList
参照キーの出力テーブル

orderPartnersList

List orderPartnersList
伝票取引先

orderSchedulesInList

List orderSchedulesInList
納入日程行データ

orderSchedulesInXList

List orderSchedulesInXList
納入日程行データチェックボックス

orderTextList

List orderTextList
テキスト

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

orderCcardList

List orderCcardList
クレジットカードデータ

orderCfgsBlobList

List orderCfgsBlobList
選定: BLOB 内部データ (SCE)

orderCfgsInstList

List orderCfgsInstList
選定: インスタンス

orderCfgsPartOfList

List orderCfgsPartOfList
選定: 部分設定

orderCfgsRefList

List orderCfgsRefList
選定: 参照データ

orderCfgsRefInstList

List orderCfgsRefInstList
選定: 参照明細/インスタンス

orderCfgsValueList

List orderCfgsValueList
選定: 特性値

orderCfgsVkList

List orderCfgsVkList
選定: バリアント条件キー

orderConditionsInList

List orderConditionsInList
条件

orderConditionsInXList

List orderConditionsInXList
条件チェックボックス

orderItemsInList

List orderItemsInList
明細データ

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

customerNumber

String customerNumber
得意先コード

documentDate

String documentDate
登録日付

documentDateTo

String documentDateTo
入力日付 (以前/以降)

material

String material
品目コード

purchaseOrder

String purchaseOrder
得意先発注番号

purchaseOrderNumber

String purchaseOrderNumber
得意先発注番号1

salesOrganization

String salesOrganization
販売組織

transactionGroup

String transactionGroup
一文字フラグ

salesOrdersList

List salesOrdersList
得意先受注テーブル

materialEvg

MaterialEvg materialEvg
品目コード(長)

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sdDoc

String sdDoc
販売管理伝票番号

itmNumber

String itmNumber
明細番号 (販売管理伝票)

material

String material
品目コード

shortText

String shortText
テキスト (短): 受注明細

docType

String docType
販売伝票タイプ

docDate

String docDate
伝票日付 (受信日/送信日)

reqQty

String reqQty
累積受注数量 (販売単位)

reqDate

String reqDate
指定納期

purchNo

String purchNo
得意先発注番号

batch

String batch
ロット番号

validFrom

String validFrom
見積または基本契約の有効開始日

validTo

String validTo
見積または基本契約有効終了日

billBlock

String billBlock
販売管理伝票の請求ブロック

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

soldTo

String soldTo
受注先

name

String name
名称 1

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

dlvQty

String dlvQty
出荷数量実績 (販売単位)

baseUom

String baseUom
基本数量単位

netPrice

String netPrice
正味価格

condPUnt

String condPUnt
価格条件単位

condUnit

String condUnit
条件単位

netValHd

String netValHd
受注正味額 (伝票通貨)

netValue

String netValue
伝票通貨による正味額

division

String division
製品部門

docStatus

String docStatus
伝票ステータス

salesGrp

String salesGrp
営業グループ

salesOff

String salesOff
営業所

salesOrg

String salesOrg
販売組織

salesUnit

String salesUnit
販売単位

shipPoint

String shipPoint
出荷ポイント/入荷ポイント

distrChan

String distrChan
流通チャネル

giDate

String giDate
出庫日付

currency

String currency
販売伝票通貨

plant

String plant
プラント

storeLoc

String storeLoc
保管場所

ordReason

String ordReason
受注理由 (取引理由)

reasonRej

String reasonRej
見積および受注の拒否理由

bUomIso

String bUomIso
ISO コードでの基本数量単位

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

sUnitIso

String sUnitIso
ISO コードによる販売単位

currIso

String currIso
ISO コード通貨

purchNoC

String purchNoC
出荷先発注番号

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

matExt

String matExt
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

matGuid

String matGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

matVers

String matVers
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

creationDate

String creationDate
レコード登録日

creationTime

String creationTime
登録時刻

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

salesdocument

String salesdocument
販売管理伝票番号

statusInfoList

ArrayList statusInfoList
ステータス情報

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docNumber

String docNumber
販売伝票

docDate

String docDate
伝票日付 (受信日/送信日)

purchNo

String purchNo
得意先発注番号

prcStatH

String prcStatH
伝票の全処理ステータス

dlvStatH

String dlvStatH
全明細の出荷ステータス

reqDateH

String reqDateH
指定納入期日

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

itmNumber

String itmNumber
販売伝票明細

material

String material
品目コード

shortText

String shortText
テキスト (短): 受注明細

reqDate

String reqDate
納入日程日付

reqQty

String reqQty
累積受注数量 (販売単位)

cumCfQty

String cumCfQty
累積確認数量 (販売数量単位)

salesUnit

String salesUnit
販売単位

netValue

String netValue
伝票通貨での受注明細正味額

currency

String currency
販売伝票通貨

netPrice

String netPrice
正味価格

condPUnt

String condPUnt
価格条件単位

condUnit

String condUnit
条件単位

dlvStatI

String dlvStatI
明細の全体出荷ステータス

delivNumb

String delivNumb
出荷伝票

delivItem

String delivItem
出荷明細

delivDate

String delivDate
納入期日

dlvQty

String dlvQty
出荷数量実績 (販売単位)

refQty

String refQty
基本数量単位による参照数量

sUnitIso

String sUnitIso
ISO コードによる販売単位

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

currIso

String currIso
ISO コード通貨

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

poItmNo

String poItmNo
元となる購買発注の明細番号

creationDate

String creationDate
レコード登録日

creationTime

String creationTime
登録時刻

sUnitDlv

String sUnitDlv
出荷単位

dlvUnitIso

String dlvUnitIso
ISO コードでの出荷単位の数量単位

index

int index
レコード番号

reaForRe

String reaForRe
見積および受注の拒否理由

purchNoC

String purchNoC
得意先発注番号

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountGl の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountGl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.AccountTax の使用

jp.co.intra_mart.foundation.sap.module.accounting.AccountTax はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Bank の使用

jp.co.intra_mart.foundation.sap.module.accounting.Bank はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BankController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BankList の使用

BankList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BankList の使用

BankList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BankList BankController.getBaList()
銀行一覧を取得します｡

BankList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BankController.setBaList(BankList baList)
銀行一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList の使用

BusinessAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での BusinessAreaList の使用

BusinessAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 BusinessAreaList BusinessAreaController.getBusAreaList()
事業領域一覧を取得します｡

BusinessAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void BusinessAreaController.setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.Company の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.Company の使用

jp.co.intra_mart.foundation.sap.module.accounting.Company はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CompanyController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CompanyList の使用

CompanyList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CompanyList の使用

CompanyList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CompanyList CompanyController.getCompList()
会社一覧を取得します｡

CompanyList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CompanyController.setCompList(CompanyList compList)
会社一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList の使用

ControllingAreaList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ControllingAreaList の使用

ControllingAreaList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ControllingAreaList ControllingAreaController.getControllAreaList()
管理領域一覧を取得します｡

ControllingAreaList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ControllingAreaController.setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList の使用

CostCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での CostCenterList の使用

CostCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 CostCenterList CostCenterController.getCostCentList()
原価センタ一覧を取得します｡

CostCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void CostCenterController.setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount の使用

jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader の使用

DocumentHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での DocumentHeader の使用

DocumentHeader を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 DocumentHeader AccEmployeePayPostController.getDocumentHeader()
伝票ヘッダを取得します｡

DocumentHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAcc の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAcc はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccController の使用

jp.co.intra_mart.foundation.sap.module.accounting.GlAccController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.GlAccList の使用

GlAccList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での GlAccList の使用

GlAccList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 GlAccList GlAccController.getGlList()
勘定科目一覧を取得します｡

GlAccList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void GlAccController.setGlList(GlAccList glList)
勘定科目一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController の使用

jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList の使用

ProfitCenterList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での ProfitCenterList の使用

ProfitCenterList を返す jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 ProfitCenterList ProfitCenterController.getProfitCentList()
利益センタ一覧を取得します｡

ProfitCenterList 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void ProfitCenterController.setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException の使用

SAPAccountingAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingAppException の使用

SAPAccountingAppException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
 void AccEmployeePayPostController.executeBapi()
BapiControllerにより会計伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException の使用

SAPAccountingSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting での SAPAccountingSystemException の使用

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のメソッド
String | ProfitCenterController.getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
String | ProfitCenterController.getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
String | ProfitCenterController.getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | GlAccController.getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
String | GlAccController.getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | CostCenterController.getName(String costCenter) 原価センタを指定して一般名称を取得します。
String | CostCenterController.getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | ControllingAreaController.getName(String coArea) 管理領域を指定して管理領域名を取得します。
String | CompanyController.getCompName(String compCode) 会社コードを指定して会社名を取得します。
String | BusinessAreaController.getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
String | BankController.getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | BankController.getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | AccEmployeePayPostController.executeBapi() BapiControllerにより会計伝票を登録します。

SAPAccountingSystemException をスローする jp.co.intra_mart.foundation.sap.module.accounting のコンストラクタ
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.accounting.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.accounting.exception
例外
SAPAccountingAppException
SAPAccountingSystemException


jp.co.intra_mart.foundation.sap.module.accounting.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

ＳＡＰ連携財務会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPAccountingAppException | p 会計系APIアプリケーション例外クラス
SAPAccountingSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の説明

ＳＡＰ連携財務会計系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.accounting.exception クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting.exception のクラス
SAPAccountingAppException
p 会計系APIアプリケーション例外クラス
SAPAccountingSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPAccountingAppException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
すべての実装インタフェース:
Serializable
public class SAPAccountingAppException
extends SAPModuleAppException

p 会計系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingAppException(String message)
会計系APIアプリケーション例外
SAPAccountingAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingAppException

public SAPAccountingAppException(String message,
                                 Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAccountingAppException

public SAPAccountingAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAccountingSystemException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting.exception
クラス SAPAccountingSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
すべての実装インタフェース:
Serializable
public class SAPAccountingSystemException
extends SAPModuleSystemException

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAccountingSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAccountingSystemException

public SAPAccountingSystemException(String message,
                                    Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccEmployeePayPostController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccEmployeePayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController
すべての実装インタフェース:
Serializable
public class AccEmployeePayPostController
extends UpdateController
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。
メソッドの概要
void | executeBapi() BapiControllerにより会計伝票を登録します。
ArrayList | getAccountGlList() G/L 勘定明細一覧を取得します｡
ArrayList | getAccountPayableList() 仕入先明細一覧を取得します｡
ArrayList | getAccountTaxList() 税明細一覧を取得します｡
ArrayList | getCurrencyAmountList() 明細通貨項目一覧を取得します｡
DocumentHeader | getDocumentHeader() 伝票ヘッダを取得します｡
void | setAccountGlList(ArrayList accountGlList) G/L 勘定明細一覧を設定します｡
void | setAccountPayableList(ArrayList accountPayableList) 仕入先明細一覧を設定します｡
void | setAccountTaxList(ArrayList accountTaxList) 税明細一覧を設定します｡
void | setCuAmtBase(String cuAmtBase, int index) 明細通貨項目の課税基準額に値を設定します。
void | setCuAmtDoccur(String cuAmtDoccur, int index) 明細通貨項目の伝票通貨額に値を設定します。
void | setCuCurrency(String cuCurrency, int index) 明細通貨項目の通貨コードに値を設定します。
void | setCuItemnoAcc(String cuItemnoAcc, int index) 明細通貨項目の会計伝票明細番号に値を設定します。
void | setCurrencyAmountList(ArrayList currencyAmountList) 明細通貨項目一覧を設定します｡
void | setDocAcDocNo(String docAcDocNo) 伝票ヘッダの会計伝票番号に値を設定します。
void | setDocCompCode(String docCompCode) 伝票ヘッダの会社コードに値を設定します。
void | setDocDocDate(String docDocDate) 伝票ヘッダの伝票の伝票日付に値を設定します。
void | setDocDocType(String docDocType) 伝票ヘッダの伝票タイプに値を設定します。
void | setDocFiscYear(String docFiscYear) 伝票ヘッダの会計年度に値を設定します。
void | setDocFisPeriod(String docFisPeriod) 伝票ヘッダの会計期間に値を設定します。
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダの伝票ヘッダテキストに値を設定します。
void | setDocObjKey(String docObjKey) 伝票ヘッダのオブジェクトキーに値を設定します。
void | setDocObjType(String docObjType) 伝票ヘッダの参照処理に値を設定します。
void | setDocPstngDate(String docPstngDate) 伝票ヘッダの伝票の転記日付に値を設定します。
void | setDocRefDocNo(String docRefDocNo) 伝票ヘッダの参照伝票番号に値を設定します。
void | setDocumentHeader(DocumentHeader documentHeader) 伝票ヘッダを設定します｡
void | setDocUsername(String docUsername) 伝票ヘッダのユーザ名に値を設定します。
void | setGlAllocNmbr(String glAllocNmbr, int index) G/L 勘定明細のソートキーに値を設定します。
void | setGlBusArea(String glBusArea, int index) G/L 勘定明細の事業領域に値を設定します。
void | setGlCompCode(String glCompCode, int index) G/L 勘定明細の会社コードに値を設定します。
void | setGlCostcenter(String glCostcenter, int index) G/L 勘定明細の原価センタに値を設定します。
void | setGlDocType(String glDocType, int index) G/L 勘定明細の伝票タイプに値を設定します。
void | setGlFiscYear(String glFiscYear, int index) G/L 勘定明細の会計年度に値を設定します。
void | setGlGlAccount(String glGlAccount, int index) G/L 勘定明細の総勘定元帳勘定に値を設定します。
void | setGlItemnoAcc(String glItemnoAcc, int index) G/L 勘定明細の会計伝票明細番号に値を設定します。
void | setGlItemText(String glItemText, int index) G/L 勘定明細の明細テキストに値を設定します。
void | setGlOrderid(String glOrderid, int index) G/L 勘定明細の指図番号に値を設定します。
void | setGlPstngDate(String glPstngDate, int index) G/L 勘定明細の伝票の転記日付に値を設定します。
void | setGlRefKey1(String glRefKey1, int index) G/L 勘定明細の取引先参照キーに値を設定します。
void | setGlTaxCode(String glTaxCode, int index) G/L 勘定明細の消費税コードに値を設定します。
void | setGlWbsElement(String glWbsElement, int index) G/L 勘定明細のWBS 要素に値を設定します。
void | setPaAllocNmbr(String paAllocNmbr, int index) 仕入先明細のソートキーに値を設定します。
void | setPaBlineDate(String paBlineDate, int index) 仕入先明細の期日計算の支払基準日に値を設定します。
void | setPaGlAccount(String paGlAccount, int index) 仕入先明細の総勘定元帳勘定に値を設定します。
void | setPaItemnoAcc(String paItemnoAcc, int index) 仕入先明細の会計伝票明細番号に値を設定します。
void | setPaItemText(String paItemText, int index) 仕入先明細の明細テキストに値を設定します。
void | setPaPymtMeth(String paPymtMeth, int index) 仕入先明細の支払方法に値を設定します。
void | setPaVendorNo(String paVendorNo, int index) 仕入先明細の仕入先または債権者の勘定コードに値を設定します。
void | setTaGlAccount(String taGlAccount, int index) 税明細の総勘定元帳勘定に値を設定します。
void | setTaItemnoAcc(String taItemnoAcc, int index) 税明細の会計伝票明細番号に値を設定します。
void | setTaTaxCode(String taTaxCode, int index) 税明細の消費税コードに値を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccEmployeePayPostController

public AccEmployeePayPostController()
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡

AccEmployeePayPostController

public AccEmployeePayPostController(ConnectionManager connetionManager)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connetionManager - コネクションマネージャー

AccEmployeePayPostController

public AccEmployeePayPostController(SapClient sapClient)
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingAppException,
                        SAPAccountingSystemException
BapiControllerにより会計伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingAppException - 会計業務アプリケーション例外
SAPAccountingSystemException - 会計業務システム例外

setDocObjType

public void setDocObjType(String docObjType)
伝票ヘッダの参照処理に値を設定します。

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
伝票ヘッダのオブジェクトキーに値を設定します。

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
伝票ヘッダのユーザ名に値を設定します。

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダの伝票ヘッダテキストに値を設定します。

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
伝票ヘッダの会社コードに値を設定します。

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
伝票ヘッダの会計伝票番号に値を設定します。

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
伝票ヘッダの会計年度に値を設定します。

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票ヘッダの伝票の伝票日付に値を設定します。

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票ヘッダの伝票の転記日付に値を設定します。

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
伝票ヘッダの会計期間に値を設定します。

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票ヘッダの伝票タイプに値を設定します。

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
伝票ヘッダの参照伝票番号に値を設定します。

パラメータ:
docRefDocNo - 参照伝票番号

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc,
                           int index)
仕入先明細の会計伝票明細番号に値を設定します。

パラメータ:
paItemnoAcc - 会計伝票明細番号
index - レコード番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo,
                          int index)
仕入先明細の仕入先または債権者の勘定コードに値を設定します。

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード
index - レコード番号

setPaGlAccount

public void setPaGlAccount(String paGlAccount,
                           int index)
仕入先明細の総勘定元帳勘定に値を設定します。

パラメータ:
paGlAccount - 総勘定元帳勘定
index - レコード番号

setPaBlineDate

public void setPaBlineDate(String paBlineDate,
                           int index)
仕入先明細の期日計算の支払基準日に値を設定します。

パラメータ:
paBlineDate - 期日計算の支払基準日
index - レコード番号

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth,
                          int index)
仕入先明細の支払方法に値を設定します。

パラメータ:
paPymtMeth - 支払方法
index - レコード番号

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr,
                           int index)
仕入先明細のソートキーに値を設定します。

パラメータ:
paAllocNmbr - ソートキー
index - レコード番号

setPaItemText

public void setPaItemText(String paItemText,
                          int index)
仕入先明細の明細テキストに値を設定します。

パラメータ:
paItemText - 明細テキスト
index - レコード番号

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc,
                           int index)
G/L 勘定明細の会計伝票明細番号に値を設定します。

パラメータ:
glItemnoAcc - 会計伝票明細番号
index - レコード番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount,
                           int index)
G/L 勘定明細の総勘定元帳勘定に値を設定します。

パラメータ:
glGlAccount - 総勘定元帳勘定
index - レコード番号

setGlCompCode

public void setGlCompCode(String glCompCode,
                          int index)
G/L 勘定明細の会社コードに値を設定します。

パラメータ:
glCompCode - 会社コード
index - レコード番号

setGlPstngDate

public void setGlPstngDate(String glPstngDate,
                           int index)
G/L 勘定明細の伝票の転記日付に値を設定します。

パラメータ:
glPstngDate - 伝票の転記日付
index - レコード番号

setGlDocType

public void setGlDocType(String glDocType,
                         int index)
G/L 勘定明細の伝票タイプに値を設定します。

パラメータ:
glDocType - 伝票タイプ
index - レコード番号

setGlFiscYear

public void setGlFiscYear(String glFiscYear,
                          int index)
G/L 勘定明細の会計年度に値を設定します。

パラメータ:
glFiscYear - 会計年度
index - レコード番号

setGlRefKey1

public void setGlRefKey1(String glRefKey1,
                         int index)
G/L 勘定明細の取引先参照キーに値を設定します。

パラメータ:
glRefKey1 - 取引先参照キー
index - レコード番号

setGlItemText

public void setGlItemText(String glItemText,
                          int index)
G/L 勘定明細の明細テキストに値を設定します。

パラメータ:
glItemText - 明細テキスト
index - レコード番号

setGlTaxCode

public void setGlTaxCode(String glTaxCode,
                         int index)
G/L 勘定明細の消費税コードに値を設定します。

パラメータ:
glTaxCode - 消費税コード
index - レコード番号

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr,
                           int index)
G/L 勘定明細のソートキーに値を設定します。

パラメータ:
glAllocNmbr - ソートキー
index - レコード番号

setGlBusArea

public void setGlBusArea(String glBusArea,
                         int index)
G/L 勘定明細の事業領域に値を設定します。

パラメータ:
glBusArea - 事業領域
index - レコード番号

setGlCostcenter

public void setGlCostcenter(String glCostcenter,
                            int index)
G/L 勘定明細の原価センタに値を設定します。

パラメータ:
glCostcenter - 原価センタ
index - レコード番号

setGlOrderid

public void setGlOrderid(String glOrderid,
                         int index)
G/L 勘定明細の指図番号に値を設定します。

パラメータ:
glOrderid - 指図番号
index - レコード番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement,
                            int index)
G/L 勘定明細のWBS 要素に値を設定します。

パラメータ:
glWbsElement - WBS 要素
index - レコード番号

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc,
                           int index)
税明細の会計伝票明細番号に値を設定します。

パラメータ:
taItemnoAcc - 会計伝票明細番号
index - レコード番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount,
                           int index)
税明細の総勘定元帳勘定に値を設定します。

パラメータ:
taGlAccount - 総勘定元帳勘定
index - レコード番号

setTaTaxCode

public void setTaTaxCode(String taTaxCode,
                         int index)
税明細の消費税コードに値を設定します。

パラメータ:
taTaxCode - 消費税コード
index - レコード番号

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc,
                           int index)
明細通貨項目の会計伝票明細番号に値を設定します。

パラメータ:
cuItemnoAcc - 会計伝票明細番号
index - レコード番号

setCuCurrency

public void setCuCurrency(String cuCurrency,
                          int index)
明細通貨項目の通貨コードに値を設定します。

パラメータ:
cuCurrency - 通貨コード
index - レコード番号

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur,
                           int index)
明細通貨項目の伝票通貨額に値を設定します。

パラメータ:
cuAmtDoccur - 伝票通貨額
index - レコード番号

setCuAmtBase

public void setCuAmtBase(String cuAmtBase,
                         int index)
明細通貨項目の課税基準額に値を設定します。

パラメータ:
cuAmtBase - 課税基準額
index - レコード番号

setDocumentHeader

public void setDocumentHeader(DocumentHeader documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setAccountPayableList

public void setAccountPayableList(ArrayList accountPayableList)
仕入先明細一覧を設定します｡

パラメータ:
accountPayableList - 仕入先明細一覧

setAccountGlList

public void setAccountGlList(ArrayList accountGlList)
G/L 勘定明細一覧を設定します｡

パラメータ:
accountGlList - G/L 勘定明細一覧

setAccountTaxList

public void setAccountTaxList(ArrayList accountTaxList)
税明細一覧を設定します｡

パラメータ:
accountTaxList - 税明細一覧

setCurrencyAmountList

public void setCurrencyAmountList(ArrayList currencyAmountList)
明細通貨項目一覧を設定します｡

パラメータ:
currencyAmountList - 明細通貨項目一覧

getDocumentHeader

public DocumentHeader getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader

getAccountPayableList

public ArrayList getAccountPayableList()
仕入先明細一覧を取得します｡

戻り値:
accountPayableList

getAccountGlList

public ArrayList getAccountGlList()
G/L 勘定明細一覧を取得します｡

戻り値:
accountGlList

getAccountTaxList

public ArrayList getAccountTaxList()
税明細一覧を取得します｡

戻り値:
accountTaxList

getCurrencyAmountList

public ArrayList getCurrencyAmountList()
明細通貨項目一覧を取得します｡

戻り値:
accountTaxList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AccountGl (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountGl

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountGl
すべての実装インタフェース:
Serializable
public class AccountGl
extends Object
implements Serializable

G/L 勘定明細クラス
機能は以下の通り

  • G/L 勘定明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountGl(int index)
G/L 勘定明細情報を作成します。
メソッドの概要
String | getGlAllocNmbr() ソートキーを取得します｡
String | getGlBusArea() 事業領域を取得します｡
String | getGlCompCode() 会社コードを取得します｡
String | getGlCostcenter() 原価センタを取得します｡
String | getGlDocType() 伝票タイプを取得します｡
String | getGlFiscYear() 会計年度を取得します｡
String | getGlGlAccount() 総勘定元帳勘定を取得します｡
int | getGlIndex() レコード番号を取得します｡
String | getGlItemnoAcc() 会計伝票明細番号を取得します｡
String | getGlItemText() 明細テキストを取得します｡
String | getGlOrderid() 指図番号を取得します｡
String | getGlPstngDate() 伝票の転記日付を取得します｡
String | getGlRefKey1() 取引先参照キーを取得します｡
String | getGlTaxCode() 消費税コードを取得します｡
String | getGlWbsElement() WBS 要素を取得します｡
void | setGlAllocNmbr(String glAllocNmbr) ソートキーコードを設定します｡
void | setGlBusArea(String glBusArea) 事業領域コードを設定します｡
void | setGlCompCode(String glCompCode) 会社コードコードを設定します｡
void | setGlCostcenter(String glCostcenter) 原価センタコードを設定します｡
void | setGlDocType(String glDocType) 伝票タイプコードを設定します｡
void | setGlFiscYear(String glFiscYear) 会計年度コードを設定します｡
void | setGlGlAccount(String glGlAccount) 総勘定元帳勘定コードを設定します｡
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGlItemnoAcc(String glItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setGlItemText(String glItemText) 明細テキストコードを設定します｡
void | setGlOrderid(String glOrderid) 指図番号コードを設定します｡
void | setGlPstngDate(String glPstngDate) 伝票の転記日付コードを設定します｡
void | setGlRefKey1(String glRefKey1) 取引先参照キーコードを設定します｡
void | setGlTaxCode(String glTaxCode) 消費税コードコードを設定します｡
void | setGlWbsElement(String glWbsElement) WBS 要素コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountGl

public AccountGl(int index)
G/L 勘定明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setGlItemnoAcc

public void setGlItemnoAcc(String glItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
glItemnoAcc - 会計伝票明細番号

setGlGlAccount

public void setGlGlAccount(String glGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
glGlAccount - 総勘定元帳勘定

setGlCompCode

public void setGlCompCode(String glCompCode)
会社コードコードを設定します｡

パラメータ:
glCompCode - 会社コード

setGlPstngDate

public void setGlPstngDate(String glPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
glPstngDate - 伝票の転記日付

setGlDocType

public void setGlDocType(String glDocType)
伝票タイプコードを設定します｡

パラメータ:
glDocType - 伝票タイプ

setGlFiscYear

public void setGlFiscYear(String glFiscYear)
会計年度コードを設定します｡

パラメータ:
glFiscYear - 会計年度

setGlRefKey1

public void setGlRefKey1(String glRefKey1)
取引先参照キーコードを設定します｡

パラメータ:
glRefKey1 - 取引先参照キー

setGlItemText

public void setGlItemText(String glItemText)
明細テキストコードを設定します｡

パラメータ:
glItemText - 明細テキスト

setGlTaxCode

public void setGlTaxCode(String glTaxCode)
消費税コードコードを設定します｡

パラメータ:
glTaxCode - 消費税コード

setGlAllocNmbr

public void setGlAllocNmbr(String glAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
glAllocNmbr - ソートキー

setGlBusArea

public void setGlBusArea(String glBusArea)
事業領域コードを設定します｡

パラメータ:
glBusArea - 事業領域

setGlCostcenter

public void setGlCostcenter(String glCostcenter)
原価センタコードを設定します｡

パラメータ:
glCostcenter - 原価センタ

setGlOrderid

public void setGlOrderid(String glOrderid)
指図番号コードを設定します｡

パラメータ:
glOrderid - 指図番号

setGlWbsElement

public void setGlWbsElement(String glWbsElement)
WBS 要素コードを設定します｡

パラメータ:
glWbsElement - WBS 要素

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

getGlItemnoAcc

public String getGlItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
glItemnoAcc

getGlGlAccount

public String getGlGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
glGlAccount

getGlCompCode

public String getGlCompCode()
会社コードを取得します｡

戻り値:
glCompCode

getGlPstngDate

public String getGlPstngDate()
伝票の転記日付を取得します｡

戻り値:
glPstngDate

getGlDocType

public String getGlDocType()
伝票タイプを取得します｡

戻り値:
glDocType

getGlFiscYear

public String getGlFiscYear()
会計年度を取得します｡

戻り値:
glFiscYear

getGlRefKey1

public String getGlRefKey1()
取引先参照キーを取得します｡

戻り値:
glRefKey1

getGlItemText

public String getGlItemText()
明細テキストを取得します｡

戻り値:
glItemText

getGlTaxCode

public String getGlTaxCode()
消費税コードを取得します｡

戻り値:
glTaxCode

getGlAllocNmbr

public String getGlAllocNmbr()
ソートキーを取得します｡

戻り値:
glAllocNmbr

getGlBusArea

public String getGlBusArea()
事業領域を取得します｡

戻り値:
glBusArea

getGlCostcenter

public String getGlCostcenter()
原価センタを取得します｡

戻り値:
glCostcenter

getGlOrderid

public String getGlOrderid()
指図番号を取得します｡

戻り値:
glOrderid

getGlWbsElement

public String getGlWbsElement()
WBS 要素を取得します｡

戻り値:
glWbsElement

getGlIndex

public int getGlIndex()
レコード番号を取得します｡

戻り値:
giIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountPayable (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountPayable

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable
すべての実装インタフェース:
Serializable
public class AccountPayable
extends Object
implements Serializable

仕入先明細クラス
機能は以下の通り

  • 仕入先明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountPayable(int index)
仕入先明細情報を作成します。
メソッドの概要
String | getPaAllocNmbr() ソートキーを取得します｡
String | getPaBlineDate() 期日計算の支払基準日を取得します｡
String | getPaGlAccount() 総勘定元帳勘定を取得します｡
int | getPaIndex() レコード番号を取得します｡
String | getPaItemnoAcc() 会計伝票明細番号を取得します｡
String | getPaItemText() 明細テキストを取得します｡
String | getPaPymtMeth() 支払方法を取得します｡
String | getPaVendorNo() 仕入先または債権者の勘定コードを取得します｡
void | setPaAllocNmbr(String paAllocNmbr) ソートキーコードを設定します｡
void | setPaBlineDate(String paBlineDate) 期日計算の支払基準日コードを設定します｡
void | setPaGlAccount(String paGlAccount) 総勘定元帳勘定コードを設定します｡
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPaItemnoAcc(String paItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setPaItemText(String paItemText) 明細テキストコードを設定します｡
void | setPaPymtMeth(String paPymtMeth) 支払方法を設定します｡
void | setPaVendorNo(String paVendorNo) 仕入先または債権者の勘定コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountPayable

public AccountPayable(int index)
仕入先明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setPaItemnoAcc

public void setPaItemnoAcc(String paItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
paItemnoAcc - 会計伝票明細番号

setPaVendorNo

public void setPaVendorNo(String paVendorNo)
仕入先または債権者の勘定コードコードを設定します｡

パラメータ:
paVendorNo - 仕入先または債権者の勘定コード

setPaGlAccount

public void setPaGlAccount(String paGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
paGlAccount - 総勘定元帳勘定

setPaBlineDate

public void setPaBlineDate(String paBlineDate)
期日計算の支払基準日コードを設定します｡

パラメータ:
paBlineDate - 期日計算の支払基準日

setPaPymtMeth

public void setPaPymtMeth(String paPymtMeth)
支払方法を設定します｡

パラメータ:
paPymtMeth - 支払方法

setPaAllocNmbr

public void setPaAllocNmbr(String paAllocNmbr)
ソートキーコードを設定します｡

パラメータ:
paAllocNmbr - ソートキー

setPaItemText

public void setPaItemText(String paItemText)
明細テキストコードを設定します｡

パラメータ:
paItemText - 明細テキスト

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

getPaItemnoAcc

public String getPaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
paItemnoAcc

getPaVendorNo

public String getPaVendorNo()
仕入先または債権者の勘定コードを取得します｡

戻り値:
paVendorNo

getPaGlAccount

public String getPaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
paGlAccount

getPaBlineDate

public String getPaBlineDate()
期日計算の支払基準日を取得します｡

戻り値:
paBlineDate

getPaPymtMeth

public String getPaPymtMeth()
支払方法を取得します｡

戻り値:
paPymtMeth

getPaAllocNmbr

public String getPaAllocNmbr()
ソートキーを取得します｡

戻り値:
paAllocNmbr

getPaItemText

public String getPaItemText()
明細テキストを取得します｡

戻り値:
paItemText

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


AccountTax (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス AccountTax

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.AccountTax
すべての実装インタフェース:
Serializable
public class AccountTax
extends Object
implements Serializable

税明細クラス
機能は以下の通り

  • 税明細の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡
メソッドの概要
String | getTaGlAccount() 総勘定元帳勘定を取得します｡
int | getTaIndex() レコード番号を取得します｡
String | getTaItemnoAcc() 会計伝票明細番号を取得します｡
String | getTaTaxCode() 消費税コードを取得します｡
void | setTaGlAccount(String taGlAccount) 総勘定元帳勘定コードを設定します｡
void | setTaIndex(int taIndex) レコード番号を設定します｡
void | setTaItemnoAcc(String taItemnoAcc) 会計伝票明細番号コードを設定します｡
void | setTaTaxCode(String taTaxCode) 消費税コードコードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AccountTax

public AccountTax(int index)
指定されたレコード番号でAccountTaxを作成します｡

パラメータ:
index - レコード番号
メソッドの詳細

setTaItemnoAcc

public void setTaItemnoAcc(String taItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
taItemnoAcc - 会計伝票明細番号

setTaGlAccount

public void setTaGlAccount(String taGlAccount)
総勘定元帳勘定コードを設定します｡

パラメータ:
taGlAccount - 総勘定元帳勘定

setTaTaxCode

public void setTaTaxCode(String taTaxCode)
消費税コードコードを設定します｡

パラメータ:
taTaxCode - 消費税コード

setTaIndex

public void setTaIndex(int taIndex)
レコード番号を設定します｡

パラメータ:
taIndex - レコード番号

getTaItemnoAcc

public String getTaItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
taItemnoAcc

getTaGlAccount

public String getTaGlAccount()
総勘定元帳勘定を取得します｡

戻り値:
taGlAccount

getTaTaxCode

public String getTaTaxCode()
消費税コードを取得します｡

戻り値:
taTaxCode

getTaIndex

public int getTaIndex()
レコード番号を取得します｡

戻り値:
tadex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Bank (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Bank

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Bank
すべての実装インタフェース:
Serializable
public class Bank
extends Object
implements Serializable

銀行情報クラス
機能は以下の通り

  • 銀行の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Bank()
銀行情報を作成します。
メソッドの概要
String | getBankKey() 銀行コードを取得します｡
String | getBankName() 銀行名を取得します｡
String | getCity() 市区町村名を取得します｡
void | setBankKey(String bankKey) 銀行コードを設定します｡
void | setBankName(String bankName) 銀行名を設定します｡
void | setCity(String city) 市区町村名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Bank

public Bank()
銀行情報を作成します。

メソッドの詳細

setBankKey

public void setBankKey(String bankKey)
銀行コードを設定します｡

パラメータ:
bankKey - 銀行コード

setBankName

public void setBankName(String bankName)
銀行名を設定します｡

パラメータ:
bankName - 銀行名

setCity

public void setCity(String city)
市区町村名を設定します｡

パラメータ:
city - 市区町村名

getBankKey

public String getBankKey()
銀行コードを取得します｡

戻り値:
bankKey

getBankName

public String getBankName()
銀行名を取得します｡

戻り値:
bankName

getCity

public String getCity()
市区町村名を取得します｡

戻り値:
city

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankController
すべての実装インタフェース:
Serializable
public class BankController
extends Object
implements Serializable

銀行コントローラクラス
機能は以下の通り

  • 銀行の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BankController()
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient sapClient)
BankListのコンストラクタを呼び出し銀行一覧を作成します。
メソッドの概要
BankList | getBaList() 銀行一覧を取得します｡
ArrayList | getBankList() 銀行一覧を取得します。
String | getBankName(String bankKey) 銀行コードを指定して銀行名を取得します。
String | getCity(String bankKey) 銀行コードを指定して市区町村名を取得します。
void | setBaList(BankList baList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankController

public BankController()
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BankController

public BankController(SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
BankListのコンストラクタを呼び出し銀行一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBankList

public ArrayList getBankList()
銀行一覧を取得します。

戻り値:
bankList 銀行一覧

getBankName

public String getBankName(String bankKey)
                   throws SAPAccountingSystemException
銀行コードを指定して銀行名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
bankName 銀行名
例外:
SAPAccountingSystemException - 会計業務システム例外

getCity

public String getCity(String bankKey)
               throws SAPAccountingSystemException
銀行コードを指定して市区町村名を取得します。

パラメータ:
bankKey - 銀行コード
戻り値:
city 市区町村名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBaList

public void setBaList(BankList baList)
銀行一覧を設定します｡

パラメータ:
baList - 銀行一覧

getBaList

public BankList getBaList()
銀行一覧を取得します｡

戻り値:
baList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BankList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BankList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.BankList
すべての実装インタフェース:
Serializable
public class BankList
extends ReferenceController
implements Serializable

銀行一覧クラス
機能は以下の通り

  • 銀行の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BankList(SapClient sapClient)
executeBapiを呼び出し銀行一覧を作成します。
メソッドの概要
ArrayList | getBankList() 銀行一覧を取得します｡
void | setBankList(ArrayList bankList) 銀行一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankList

public BankList(SapClient sapClient)
         throws SAPAuthAppException,
                SAPAuthSystemException,
                SAPGeneralAppException,
                SAPGeneralSystemException,
                SAPAccountingSystemException
executeBapiを呼び出し銀行一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBankList

public void setBankList(ArrayList bankList)
銀行一覧を設定します｡

パラメータ:
bankList - 銀行一覧

getBankList

public ArrayList getBankList()
銀行一覧を取得します｡

戻り値:
bankList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessArea (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea
すべての実装インタフェース:
Serializable
public class BusinessArea
extends Object
implements Serializable

事業領域情報クラス
機能は以下の通り

  • 事業領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessArea()
事業領域情報を作成します。
メソッドの概要
String | getBusArDes() 事業領域名を取得します｡
String | getBusArea() 事業領域を取得します｡
void | setBusArDes(String busArDes) 事業領域名を設定します｡
void | setBusArea(String busArea) 事業領域を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessArea

public BusinessArea()
事業領域情報を作成します。

メソッドの詳細

setBusArea

public void setBusArea(String busArea)
事業領域を設定します｡

パラメータ:
busArea - 事業領域

setBusArDes

public void setBusArDes(String busArDes)
事業領域名を設定します｡

パラメータ:
busArDes - 事業領域名

getBusArea

public String getBusArea()
事業領域を取得します｡

戻り値:
businessAreaCode

getBusArDes

public String getBusArDes()
事業領域名を取得します｡

戻り値:
busArDes

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController
すべての実装インタフェース:
Serializable
public class BusinessAreaController
extends Object
implements Serializable

事業領域コントローラクラス
機能は以下の通り

  • 事業領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
BusinessAreaController()
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient sapClient)
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
メソッドの概要
String | getBusArDes(String busArea) 事業領域を指定して事業領域名を取得します。
BusinessAreaList | getBusAreaList() 事業領域一覧を取得します｡
ArrayList | getBusinessAreaList() 事業領域一覧を取得します。
void | setBusAreaList(BusinessAreaList busAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaController

public BusinessAreaController()
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

BusinessAreaController

public BusinessAreaController(SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します。

戻り値:
businessAreaList 事業領域一覧

getBusArDes

public String getBusArDes(String busArea)
                   throws SAPAccountingSystemException
事業領域を指定して事業領域名を取得します。

パラメータ:
busArea - 事業領域
戻り値:
busArDes 事業領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setBusAreaList

public void setBusAreaList(BusinessAreaList busAreaList)
事業領域一覧を設定します｡

パラメータ:
busAreaList - 事業領域一覧

getBusAreaList

public BusinessAreaList getBusAreaList()
事業領域一覧を取得します｡

戻り値:
busAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BusinessAreaList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス BusinessAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList
すべての実装インタフェース:
Serializable
public class BusinessAreaList
extends ReferenceController
implements Serializable

事業領域一覧クラス
機能は以下の通り

  • 事業領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BusinessAreaList(SapClient sapClient)
executeBapiを呼び出し事業領域一覧を作成します。
メソッドの概要
ArrayList | getBusinessAreaList() 事業領域一覧を取得します｡
void | setBusinessAreaList(ArrayList businessAreaList) 事業領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BusinessAreaList

public BusinessAreaList(SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し事業領域一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setBusinessAreaList

public void setBusinessAreaList(ArrayList businessAreaList)
事業領域一覧を設定します｡

パラメータ:
businessAreaList - 事業領域一覧

getBusinessAreaList

public ArrayList getBusinessAreaList()
事業領域一覧を取得します｡

戻り値:
businessAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Company (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス Company

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.Company
すべての実装インタフェース:
Serializable
public class Company
extends Object
implements Serializable

会社情報クラス
機能は以下の通り

  • 会社の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Company()
会社情報を作成します。
メソッドの概要
String | getCompCode() 会社コードを取得します｡
String | getCompName() 会社名を取得します｡
void | setCompCode(String compCode) 会社コードを設定します｡
void | setCompName(String compName) 会社名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Company

public Company()
会社情報を作成します。

メソッドの詳細

setCompCode

public void setCompCode(String compCode)
会社コードを設定します｡

パラメータ:
compCode - 会社コード

setCompName

public void setCompName(String compName)
会社名を設定します｡

パラメータ:
compName - 会社名

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

getCompName

public String getCompName()
会社名を取得します｡

戻り値:
compName

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyController
すべての実装インタフェース:
Serializable
public class CompanyController
extends Object
implements Serializable

会社コントローラクラス
機能は以下の通り

  • 会社の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyController()
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient sapClient)
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します。
CompanyList | getCompList() 会社一覧を取得します｡
String | getCompName(String compCode) 会社コードを指定して会社名を取得します。
void | setCompList(CompanyList compList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyController

public CompanyController()
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CompanyController

public CompanyController(SapClient sapClient)
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPAccountingSystemException
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します。

戻り値:
companyList 会社一覧

getCompName

public String getCompName(String compCode)
                   throws SAPAccountingSystemException
会社コードを指定して会社名を取得します。

パラメータ:
compCode - 会社コード
戻り値:
compName 会社名
例外:
SAPAccountingSystemException - 会計業務システム例外

setCompList

public void setCompList(CompanyList compList)
会社一覧を設定します｡

パラメータ:
compList - 会社一覧

getCompList

public CompanyList getCompList()
会社一覧を取得します｡

戻り値:
compList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CompanyList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CompanyList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.CompanyList
すべての実装インタフェース:
Serializable
public class CompanyList
extends ReferenceController
implements Serializable

会社一覧クラス
機能は以下の通り

  • 会社の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CompanyList(SapClient sapClient)
executeBapiを呼び出し会社一覧を作成します。
メソッドの概要
ArrayList | getCompanyList() 会社一覧を取得します｡
void | setCompanyList(ArrayList companyList) 会社一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyList

public CompanyList(SapClient sapClient)
            throws SAPAuthAppException,
                   SAPAuthSystemException,
                   SAPGeneralAppException,
                   SAPGeneralSystemException,
                   SAPAccountingSystemException
executeBapiを呼び出し会社一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCompanyList

public void setCompanyList(ArrayList companyList)
会社一覧を設定します｡

パラメータ:
companyList - 会社一覧

getCompanyList

public ArrayList getCompanyList()
会社一覧を取得します｡

戻り値:
companyList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingArea (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingArea

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea
すべての実装インタフェース:
Serializable
public class ControllingArea
extends Object
implements Serializable

管理領域情報クラス
機能は以下の通り

  • 管理領域の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingArea()
管理領域情報を作成します。
メソッドの概要
String | getCoArea() 管理領域を取得します｡
String | getName() 管理領域名を取得します｡
void | setCoArea(String coArea) 管理領域を設定します｡
void | setName(String name) 管理領域名を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingArea

public ControllingArea()
管理領域情報を作成します。

メソッドの詳細

setCoArea

public void setCoArea(String coArea)
管理領域を設定します｡

パラメータ:
coArea - 管理領域

setName

public void setName(String name)
管理領域名を設定します｡

パラメータ:
name - 管理領域名

getCoArea

public String getCoArea()
管理領域を取得します｡

戻り値:
coArea

getName

public String getName()
管理領域名を取得します｡

戻り値:
name

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController
すべての実装インタフェース:
Serializable
public class ControllingAreaController
extends Object
implements Serializable

管理領域コントローラクラス
機能は以下の通り

  • 管理領域の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ControllingAreaController()
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient sapClient)
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
メソッドの概要
ControllingAreaList | getControllAreaList() 管理領域一覧を取得します｡
ArrayList | getControllingAreaList() 管理領域一覧を取得します。
String | getName(String coArea) 管理領域を指定して管理領域名を取得します。
void | setControllAreaList(ControllingAreaList controllAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaController

public ControllingAreaController()
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ControllingAreaController

public ControllingAreaController(SapClient sapClient)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPAccountingSystemException
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します。

戻り値:
controllingAreaList 管理領域一覧

getName

public String getName(String coArea)
               throws SAPAccountingSystemException
管理領域を指定して管理領域名を取得します。

パラメータ:
coArea - 管理領域
戻り値:
name 管理領域名
例外:
SAPAccountingSystemException - 会計業務システム例外

setControllAreaList

public void setControllAreaList(ControllingAreaList controllAreaList)
管理領域一覧を設定します｡

パラメータ:
controllAreaList - 管理領域一覧

getControllAreaList

public ControllingAreaList getControllAreaList()
管理領域一覧を取得します｡

戻り値:
controllAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ControllingAreaList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ControllingAreaList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList
すべての実装インタフェース:
Serializable
public class ControllingAreaList
extends ReferenceController
implements Serializable

管理領域一覧クラス
機能は以下の通り

  • 管理領域の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ControllingAreaList(SapClient sapClient)
executeBapiを呼び出し管理領域一覧を作成します。
メソッドの概要
ArrayList | getControllingAreaList() 管理領域一覧を取得します｡
void | setControllingAreaList(ArrayList controllingAreaList) 管理領域一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ControllingAreaList

public ControllingAreaList(SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPAccountingSystemException
executeBapiを呼び出し管理領域一覧を作成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setControllingAreaList

public void setControllingAreaList(ArrayList controllingAreaList)
管理領域一覧を設定します｡

パラメータ:
controllingAreaList - 管理領域一覧

getControllingAreaList

public ArrayList getControllingAreaList()
管理領域一覧を取得します｡

戻り値:
controllingAreaList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenter (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenter
すべての実装インタフェース:
Serializable
public class CostCenter
extends Object
implements Serializable

原価センタ情報クラス
機能は以下の通り

  • 原価センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenter()
原価センタ情報を取得します。
メソッドの概要
String | getControllingArea() 管理領域を取得します｡
String | getCostCenter() 原価センタを取得します｡
String | getDescript() テキストを取得します｡
String | getName() 一般名称を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setCostCenter(String costCenter) 原価センタを設定します｡
void | setDescript(String descript) テキストを設定します｡
void | setName(String name) 一般名称を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenter

public CostCenter()
原価センタ情報を取得します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setCostCenter

public void setCostCenter(String costCenter)
原価センタを設定します｡

パラメータ:
costCenter - 原価センタ

setName

public void setName(String name)
一般名称を設定します｡

パラメータ:
name - 一般名称

setDescript

public void setDescript(String descript)
テキストを設定します｡

パラメータ:
descript - テキスト

getControllingArea

public String getControllingArea()
管理領域を取得します｡

戻り値:
controllingArea

getCostCenter

public String getCostCenter()
原価センタを取得します｡

戻り値:
costCenter

getName

public String getName()
一般名称を取得します｡

戻り値:
name

getDescript

public String getDescript()
テキストを取得します｡

戻り値:
descript

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController
すべての実装インタフェース:
Serializable
public class CostCenterController
extends Object
implements Serializable

原価センタコントローラクラス
機能は以下の通り

  • 原価センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterController(String controllingArea)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, Date date, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String controllingArea, SapClient sapClient)
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します。
CostCenterList | getCostCentList() 原価センタ一覧を取得します｡
String | getDescript(String costCenter) 原価センタを指定してテキストを取得します。
String | getName(String costCenter) 原価センタを指定して一般名称を取得します。
void | setCostCentList(CostCenterList costCentList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterController

public CostCenterController(String controllingArea)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。

パラメータ:
controllingArea - 管理領域
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

CostCenterController

public CostCenterController(String controllingArea,
                            Date date,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPAccountingSystemException
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。 「有効期間: 開始」を引数より設定します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します。

戻り値:
costCenterList 原価センタ一覧

getName

public String getName(String costCenter)
               throws SAPAccountingSystemException
原価センタを指定して一般名称を取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
name 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getDescript

public String getDescript(String costCenter)
                   throws SAPAccountingSystemException
原価センタを指定してテキストを取得します。

パラメータ:
costCenter - 原価センタ
戻り値:
descript テキスト
例外:
SAPAccountingSystemException - 会計業務システム例外

setCostCentList

public void setCostCentList(CostCenterList costCentList)
原価センタ一覧を設定します｡

パラメータ:
costCentList - 原価センタ一覧

getCostCentList

public CostCenterList getCostCentList()
原価センタ一覧を取得します｡

戻り値:
costCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CostCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList
すべての実装インタフェース:
Serializable
public class CostCenterList
extends ReferenceController
implements Serializable

原価センタ一覧クラス
機能は以下の通り

  • 原価センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CostCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し原価センタ一覧を作成します。
メソッドの概要
ArrayList | getCostCenterList() 原価センタ一覧を取得します｡
void | setCostCenterList(ArrayList costCenterList) 原価センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterList

public CostCenterList(String controllingArea,
                      String date,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPAccountingSystemException
executeBapiを呼び出し原価センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 有効期間: 開始
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setCostCenterList

public void setCostCenterList(ArrayList costCenterList)
原価センタ一覧を設定します｡

パラメータ:
costCenterList - 原価センタ一覧

getCostCenterList

public ArrayList getCostCenterList()
原価センタ一覧を取得します｡

戻り値:
costCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CurrencyAmount (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス CurrencyAmount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount
すべての実装インタフェース:
Serializable
public class CurrencyAmount
extends Object
implements Serializable

明細通貨項目クラス
機能は以下の通り

  • 明細通貨項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。
メソッドの概要
String | getCuAmtBase() 課税基準額を取得します｡
String | getCuAmtDoccur() 伝票通貨額を取得します｡
String | getCuCurrency() 通貨コードを取得します｡
int | getCuIndex() レコード番号を取得します｡
String | getCuItemnoAcc() 会計伝票明細番号を取得します｡
void | setCuAmtBase(String cuAmtBase) 課税基準額を設定します｡
void | setCuAmtDoccur(String cuAmtDoccur) 伝票通貨額設定します｡
void | setCuCurrency(String cuCurrency) 通貨コードを設定します｡
void | setCuIndex(int cuIndex) レコード番号を設定します｡
void | setCuItemnoAcc(String cuItemnoAcc) 会計伝票明細番号コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CurrencyAmount

public CurrencyAmount(int index)
指定されたレコード番号でCurrencyAmountを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

setCuItemnoAcc

public void setCuItemnoAcc(String cuItemnoAcc)
会計伝票明細番号コードを設定します｡

パラメータ:
cuItemnoAcc - 会計伝票明細番号

setCuCurrency

public void setCuCurrency(String cuCurrency)
通貨コードを設定します｡

パラメータ:
cuCurrency - 通貨コード

setCuAmtDoccur

public void setCuAmtDoccur(String cuAmtDoccur)
伝票通貨額設定します｡

パラメータ:
cuAmtDoccur - 伝票通貨額

setCuAmtBase

public void setCuAmtBase(String cuAmtBase)
課税基準額を設定します｡

パラメータ:
cuAmtBase - 課税基準額

setCuIndex

public void setCuIndex(int cuIndex)
レコード番号を設定します｡

パラメータ:
cuIndex - レコード番号

getCuItemnoAcc

public String getCuItemnoAcc()
会計伝票明細番号を取得します｡

戻り値:
cuItemnoAcc

getCuCurrency

public String getCuCurrency()
通貨コードを取得します｡

戻り値:
cuCurrency

getCuAmtDoccur

public String getCuAmtDoccur()
伝票通貨額を取得します｡

戻り値:
cuAmtDoccur

getCuAmtBase

public String getCuAmtBase()
課税基準額を取得します｡

戻り値:
cuAmtBase

getCuIndex

public int getCuIndex()
レコード番号を取得します｡

戻り値:
cuindex

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DocumentHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス DocumentHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader
すべての実装インタフェース:
Serializable
public class DocumentHeader
extends Object
implements Serializable

伝票ヘッダクラス
機能は以下の通り

  • 伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DocumentHeader()
伝票ヘッダ情報を作成します。
メソッドの概要
String | getDocAcDocNo() 会計伝票番号を取得します｡
String | getDocCompCode() 会社コードを取得します｡
String | getDocDocDate() 伝票の伝票日付を取得します｡
String | getDocDocType() 伝票タイプを取得します｡
String | getDocFiscYear() 会計年度を取得します｡
String | getDocFisPeriod() 会計期間を取得します｡
String | getDocHeaderTxt() 伝票ヘッダテキストを取得します｡
String | getDocObjKey() オブジェクトキーを取得します｡
String | getDocObjType() 参照処理を取得します｡
String | getDocPstngDate() 伝票の転記日付を取得します｡
String | getDocRefDocNo() 参照伝票番号を取得します｡
String | getDocUsername() ユーザ名を取得します｡
void | setDocAcDocNo(String docAcDocNo) 会計伝票番号コードを設定します｡
void | setDocCompCode(String docCompCode) 会社コードコードを設定します｡
void | setDocDocDate(String docDocDate) 伝票の伝票日付コードを設定します｡
void | setDocDocType(String docDocType) 伝票タイプコードを設定します｡
void | setDocFiscYear(String docFiscYear) 会計年度コードを設定します｡
void | setDocFisPeriod(String docFisPeriod) 会計期間コードを設定します｡
void | setDocHeaderTxt(String docHeaderTxt) 伝票ヘッダテキストコードを設定します｡
void | setDocObjKey(String docObjKey) オブジェクトキーコードを設定します｡
void | setDocObjType(String docObjType) 参照処理コードを設定します｡
void | setDocPstngDate(String docPstngDate) 伝票の転記日付コードを設定します｡
void | setDocRefDocNo(String docRefDocNo) 参照伝票番号コードを設定します｡
void | setDocUsername(String docUsername) ユーザ名コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DocumentHeader

public DocumentHeader()
伝票ヘッダ情報を作成します。

メソッドの詳細

setDocObjType

public void setDocObjType(String docObjType)
参照処理コードを設定します｡

パラメータ:
docObjType - 参照処理

setDocObjKey

public void setDocObjKey(String docObjKey)
オブジェクトキーコードを設定します｡

パラメータ:
docObjKey - オブジェクトキー

setDocUsername

public void setDocUsername(String docUsername)
ユーザ名コードを設定します｡

パラメータ:
docUsername - ユーザ名

setDocHeaderTxt

public void setDocHeaderTxt(String docHeaderTxt)
伝票ヘッダテキストコードを設定します｡

パラメータ:
docHeaderTxt - 伝票ヘッダテキスト

setDocCompCode

public void setDocCompCode(String docCompCode)
会社コードコードを設定します｡

パラメータ:
docCompCode - 会社コード

setDocAcDocNo

public void setDocAcDocNo(String docAcDocNo)
会計伝票番号コードを設定します｡

パラメータ:
docAcDocNo - 会計伝票番号

setDocFiscYear

public void setDocFiscYear(String docFiscYear)
会計年度コードを設定します｡

パラメータ:
docFiscYear - 会計年度

setDocDocDate

public void setDocDocDate(String docDocDate)
伝票の伝票日付コードを設定します｡

パラメータ:
docDocDate - 伝票の伝票日付

setDocPstngDate

public void setDocPstngDate(String docPstngDate)
伝票の転記日付コードを設定します｡

パラメータ:
docPstngDate - 伝票の転記日付

setDocFisPeriod

public void setDocFisPeriod(String docFisPeriod)
会計期間コードを設定します｡

パラメータ:
docFisPeriod - 会計期間

setDocDocType

public void setDocDocType(String docDocType)
伝票タイプコードを設定します｡

パラメータ:
docDocType - 伝票タイプ

setDocRefDocNo

public void setDocRefDocNo(String docRefDocNo)
参照伝票番号コードを設定します｡

パラメータ:
docRefDocNo - 参照伝票番号

getDocObjType

public String getDocObjType()
参照処理を取得します｡

戻り値:
docObjType

getDocObjKey

public String getDocObjKey()
オブジェクトキーを取得します｡

戻り値:
docObjKey

getDocUsername

public String getDocUsername()
ユーザ名を取得します｡

戻り値:
docUsername

getDocHeaderTxt

public String getDocHeaderTxt()
伝票ヘッダテキストを取得します｡

戻り値:
docHeaderTxt

getDocCompCode

public String getDocCompCode()
会社コードを取得します｡

戻り値:
docCompCode

getDocAcDocNo

public String getDocAcDocNo()
会計伝票番号を取得します｡

戻り値:
docAcDocNo

getDocFiscYear

public String getDocFiscYear()
会計年度を取得します｡

戻り値:
docFiscYear

getDocDocDate

public String getDocDocDate()
伝票の伝票日付を取得します｡

戻り値:
docDocDate

getDocPstngDate

public String getDocPstngDate()
伝票の転記日付を取得します｡

戻り値:
docPstngDate

getDocFisPeriod

public String getDocFisPeriod()
会計期間を取得します｡

戻り値:
docFisPeriod

getDocDocType

public String getDocDocType()
伝票タイプを取得します｡

戻り値:
docDocType

getDocRefDocNo

public String getDocRefDocNo()
参照伝票番号を取得します｡

戻り値:
docRefDocNo

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAcc (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAcc

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAcc
すべての実装インタフェース:
Serializable
public class GlAcc
extends Object
implements Serializable

勘定項目情報クラス
機能は以下の通り

  • 勘定項目の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GlAcc()
勘定項目情報を作成します。
メソッドの概要
String | getCompanyCode() 会社コードを取得します｡
String | getGlAccount() G/L勘定コードを取得します｡
String | getLongText() 総勘定元帳勘定テキスト(長)を取得します｡
String | getShortText() G/L勘定コードテキスト(短)を取得します｡
void | setCompanyCode(String companyCode) 会社コードを設定します｡
void | setGlAccount(String glAccount) G/L勘定コードを設定します｡
void | setLongText(String longText) 総勘定元帳勘定テキスト(長)を設定します｡
void | setShortText(String shortText) G/L勘定コードテキスト(短)を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAcc

public GlAcc()
勘定項目情報を作成します。

メソッドの詳細

setCompanyCode

public void setCompanyCode(String companyCode)
会社コードを設定します｡

パラメータ:
companyCode - 会社コード

setGlAccount

public void setGlAccount(String glAccount)
G/L勘定コードを設定します｡

パラメータ:
glAccount - G/L勘定コード

setShortText

public void setShortText(String shortText)
G/L勘定コードテキスト(短)を設定します｡

パラメータ:
shortText - G/L勘定コードテキスト(短)

setLongText

public void setLongText(String longText)
総勘定元帳勘定テキスト(長)を設定します｡

パラメータ:
longText - 総勘定元帳勘定テキスト(長)

getCompanyCode

public String getCompanyCode()
会社コードを取得します｡

戻り値:
companyCode

getGlAccount

public String getGlAccount()
G/L勘定コードを取得します｡

戻り値:
glAccount

getShortText

public String getShortText()
G/L勘定コードテキスト(短)を取得します｡

戻り値:
shortText

getLongText

public String getLongText()
総勘定元帳勘定テキスト(長)を取得します｡

戻り値:
longText

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccController
すべての実装インタフェース:
Serializable
public class GlAccController
extends Object
implements Serializable

勘定科目コントローラクラス
機能は以下の通り

  • 勘定科目の情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
GlAccController(String companyCode)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String companyCode, SapClient sapClient)
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目情報一覧を取得します。
GlAccList | getGlList() 勘定科目一覧を取得します｡
String | getLongText(String glAccount) G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
String | getShortText(String glAccount) G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
void | setGlList(GlAccList glList) 勘定科目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccController

public GlAccController(String companyCode)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。

パラメータ:
companyCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

GlAccController

public GlAccController(String companyCode,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPAccountingSystemException
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
companyCode - 会社コード
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getGlAccList

public ArrayList getGlAccList()
勘定項目情報一覧を取得します。

戻り値:
glAccList 勘定項目情報一覧

getShortText

public String getShortText(String glAccount)
                    throws SAPAccountingSystemException
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
shortText G/L勘定コードテキスト(短)
例外:
SAPAccountingSystemException - 会計業務システム例外

getLongText

public String getLongText(String glAccount)
                   throws SAPAccountingSystemException
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。

パラメータ:
glAccount - G/L勘定コード
戻り値:
longText 総勘定元帳勘定テキスト(長)
例外:
SAPAccountingSystemException - 会計業務システム例外

setGlList

public void setGlList(GlAccList glList)
勘定科目一覧を設定します｡

パラメータ:
glList - 勘定科目一覧

getGlList

public GlAccList getGlList()
勘定科目一覧を取得します｡

戻り値:
glList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GlAccList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス GlAccList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.GlAccList
すべての実装インタフェース:
Serializable
public class GlAccList
extends ReferenceController
implements Serializable

勘定項目一覧クラス
機能は以下の通り

  • 勘定項目の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GlAccList(String companyCode, SapClient sapClient)
executeBapiを呼び出し勘定項目一覧を作成します。
メソッドの概要
ArrayList | getGlAccList() 勘定項目情報一覧を取得します｡
void | setGlAccList(ArrayList glAccList) 勘定項目一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GlAccList

public GlAccList(String companyCode,
                 SapClient sapClient)
          throws SAPAuthAppException,
                 SAPAuthSystemException,
                 SAPGeneralAppException,
                 SAPGeneralSystemException,
                 SAPAccountingSystemException
executeBapiを呼び出し勘定項目一覧を作成します。

パラメータ:
companyCode - 会社コード
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setGlAccList

public void setGlAccList(ArrayList glAccList)
勘定項目一覧を設定します｡

パラメータ:
glAccList - 勘定項目一覧

getGlAccList

public ArrayList getGlAccList()
勘定項目情報一覧を取得します｡

戻り値:
glAccList 勘定項目情報一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.accounting (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.accounting
クラス
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
Bank
BankController
BankList
BusinessArea
BusinessAreaController
BusinessAreaList
Company
CompanyController
CompanyList
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterList
CurrencyAmount
DocumentHeader
GlAcc
GlAccController
GlAccList
ProfitCenter
ProfitCenterController
ProfitCenterList


jp.co.intra_mart.foundation.sap.module.accounting (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

ＳＡＰ連携財務会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AccEmployeePayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
AccountGl | G/L 勘定明細クラス 機能は以下の通り G/L 勘定明細の情報を保持します。
AccountPayable | 仕入先明細クラス 機能は以下の通り 仕入先明細の情報を保持します。
AccountTax | 税明細クラス 機能は以下の通り 税明細の情報を保持します。
Bank | 銀行情報クラス 機能は以下の通り 銀行の情報を保持します。
BankController | 銀行コントローラクラス 機能は以下の通り 銀行の情報を取得します。
BankList | 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
BusinessArea | 事業領域情報クラス 機能は以下の通り 事業領域の情報を保持します。
BusinessAreaController | 事業領域コントローラクラス 機能は以下の通り 事業領域の情報を取得します。
BusinessAreaList | 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
Company | 会社情報クラス 機能は以下の通り 会社の情報を保持します。
CompanyController | 会社コントローラクラス 機能は以下の通り 会社の情報を取得します。
CompanyList | 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
ControllingArea | 管理領域情報クラス 機能は以下の通り 管理領域の情報を保持します。
ControllingAreaController | 管理領域コントローラクラス 機能は以下の通り 管理領域の情報を取得します。
ControllingAreaList | 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
CostCenter | 原価センタ情報クラス 機能は以下の通り 原価センタの情報を保持します。
CostCenterController | 原価センタコントローラクラス 機能は以下の通り 原価センタの情報を取得します。
CostCenterList | 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
CurrencyAmount | 明細通貨項目クラス 機能は以下の通り 明細通貨項目の情報を保持します。
DocumentHeader | 伝票ヘッダクラス 機能は以下の通り 伝票ヘッダの情報を保持します。
GlAcc | 勘定項目情報クラス 機能は以下の通り 勘定項目の情報を保持します。
GlAccController | 勘定科目コントローラクラス 機能は以下の通り 勘定科目の情報を取得します。
GlAccList | 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
ProfitCenter | 利益センタ情報クラス 機能は以下の通り 利益センタの情報を保持します。
ProfitCenterController | 利益センタコントローラクラス 機能は以下の通り 利益センタの情報を取得します。
ProfitCenterList | 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の説明

ＳＡＰ連携財務会計系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.accounting クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.accounting の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.accounting の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.accounting の使用

jp.co.intra_mart.foundation.sap.module.accounting を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting ＳＡＰ連携財務会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module.accounting のクラス
BankList
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BusinessAreaList
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
CompanyList
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
ControllingAreaList
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
CostCenterList
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
DocumentHeader
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
GlAccList
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
ProfitCenterList
利益センタ一覧クラス

機能は以下の通り
利益センタの情報を一覧形式で取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProfitCenter (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter
すべての実装インタフェース:
Serializable
public class ProfitCenter
extends Object
implements Serializable

利益センタ情報クラス
機能は以下の通り

  • 利益センタの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenter()
利益センタ情報を作成します。
メソッドの概要
String | getControllingArea() 管理領域コードを取得します｡
String | getInCharge() 利益センタ責任者を取得します｡
String | getPctrName() 一般名称を取得します｡
String | getProfitCtr() 利益センタを取得します｡
String | getValidTo() 有効終了日を取得します｡
void | setControllingArea(String controllingArea) 管理領域を設定します｡
void | setInCharge(String inCharge) 利益センタ責任者を設定します｡
void | setPctrName(String pctrName) 一般名称を設定します｡
void | setProfitCtr(String profitCtr) 利益センタを設定します｡
void | setValidTo(String validTo) 有効終了日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenter

public ProfitCenter()
利益センタ情報を作成します。

メソッドの詳細

setControllingArea

public void setControllingArea(String controllingArea)
管理領域を設定します｡

パラメータ:
controllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します｡

パラメータ:
profitCtr - 利益センタ

setValidTo

public void setValidTo(String validTo)
有効終了日を設定します｡

パラメータ:
validTo - 有効終了日

setPctrName

public void setPctrName(String pctrName)
一般名称を設定します｡

パラメータ:
pctrName - 一般名称

setInCharge

public void setInCharge(String inCharge)
利益センタ責任者を設定します｡

パラメータ:
inCharge - 利益センタ責任者

getControllingArea

public String getControllingArea()
管理領域コードを取得します｡

戻り値:
controllingArea

getProfitCtr

public String getProfitCtr()
利益センタを取得します｡

戻り値:
profitCtr

getValidTo

public String getValidTo()
有効終了日を取得します｡

戻り値:
validTo

getPctrName

public String getPctrName()
一般名称を取得します｡

戻り値:
pctrName

getInCharge

public String getInCharge()
利益センタ責任者を取得します｡

戻り値:
inCharge

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController
すべての実装インタフェース:
Serializable
public class ProfitCenterController
extends Object
implements Serializable

利益センタコントローラクラス
機能は以下の通り

  • 利益センタの情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterController(String controllingArea)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, Date date, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String controllingArea, SapClient sapClient)
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
メソッドの概要
String | getInCharge(String profitCtr) 利益センタを指定して利益センタ責任者を取得します。
String | getPctrName(String profitCtr) 利益センタを指定して一般名称を取得します。
ArrayList | getProfitCenterList() 利益センタ一覧を取得します。
ProfitCenterList | getProfitCentList() 利益センタ一覧を取得します｡
String | getValidTo(String profitCtr) 利益センタを指定して有効終了日を取得します。
void | setProfitCentList(ProfitCenterList profitCentList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterController

public ProfitCenterController(String controllingArea)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」をシステム日付より設定します。

パラメータ:
controllingArea - 管理領域
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外

ProfitCenterController

public ProfitCenterController(String controllingArea,
                              Date date,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPAccountingSystemException
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。 「日付」を引数より設定します。

パラメータ:
controllingArea - 管理領域
date - 日付
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します。

戻り値:
profitCenterList 管理領域一覧

getValidTo

public String getValidTo(String profitCtr)
                  throws SAPAccountingSystemException
利益センタを指定して有効終了日を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
validTo 有効終了日
例外:
SAPAccountingSystemException - 会計業務システム例外

getPctrName

public String getPctrName(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して一般名称を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
pctrName 一般名称
例外:
SAPAccountingSystemException - 会計業務システム例外

getInCharge

public String getInCharge(String profitCtr)
                   throws SAPAccountingSystemException
利益センタを指定して利益センタ責任者を取得します。

パラメータ:
profitCtr - 利益センタ
戻り値:
inCharge 利益センタ責任者
例外:
SAPAccountingSystemException - 会計業務システム例外

setProfitCentList

public void setProfitCentList(ProfitCenterList profitCentList)
利益センタ一覧を設定します｡

パラメータ:
profitCentList - 利益センタ一覧

getProfitCentList

public ProfitCenterList getProfitCentList()
利益センタ一覧を取得します｡

戻り値:
profitCentList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.accounting
クラス ProfitCenterList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList
すべての実装インタフェース:
Serializable
public class ProfitCenterList
extends ReferenceController
implements Serializable

利益センタ一覧クラス

機能は以下の通り

  • 利益センタの情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProfitCenterList(String controllingArea, String date, SapClient sapClient)
executeBapiを呼び出し利益センタ一覧を作成します。
メソッドの概要
ArrayList | getProfitCenterList() 利益センタ一覧を取得します｡
void | setProfitCenterList(ArrayList profitCenterList) 利益センタ一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterList

public ProfitCenterList(String controllingArea,
                        String date,
                        SapClient sapClient)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPAccountingSystemException
executeBapiを呼び出し利益センタ一覧を作成します。

パラメータ:
controllingArea - 管理領域
date - 日付
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPAccountingSystemException - 会計業務システム例外
メソッドの詳細

setProfitCenterList

public void setProfitCenterList(ArrayList profitCenterList)
利益センタ一覧を設定します｡

パラメータ:
profitCenterList - 利益センタ一覧

getProfitCenterList

public ArrayList getProfitCenterList()
利益センタ一覧を取得します｡

戻り値:
profitCenterList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.AbstractController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.AbstractController の使用

AbstractController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module での AbstractController の使用

jp.co.intra_mart.foundation.sap.module での AbstractController のサブクラス
class | ReferenceController 参照系モジュール共通コントローラ親クラス。
class | UpdateController 登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.accounting での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.accounting での AbstractController のサブクラス
class | AccEmployeePayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | BankList 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
class | BusinessAreaList 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
class | CompanyList 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
class | ControllingAreaList 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
class | CostCenterList 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
class | GlAccList 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
class | ProfitCenterList 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.financial での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.financial での AbstractController のサブクラス
class | CommonCenterGrpGetDetail 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | CreditorGetDetail 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
class | DebtorGetDetail 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
class | ExchangeRateGetDetail 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
class | InternalOrderGetDetail 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
class | InternalOrderGetList 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
class | ProjectGetInfo WBS情報取得クラス 機能は以下の通り WBS情報を取得します。

jp.co.intra_mart.foundation.sap.module.purchase での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase での AbstractController のサブクラス
class | GoodsMvtCreateController 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
class | GoodsMvtGetItemsController 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
class | MaterialAvailabilityController 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
class | MaterialGetAllController 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
class | MaterialGetList 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialGetListController 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialSaveReplicaController 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
class | PurchaseGetItemSrel 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
class | PurchaseOrderPayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
class | PurchaseRelease 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。
class | SupplierDetail 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
class | SupplierExistenceCheck 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での AbstractController のサブクラス
 class GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での AbstractController のサブクラス
 class GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での AbstractController のサブクラス
 class MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での AbstractController のサブクラス
 class MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での AbstractController のサブクラス
 class MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での AbstractController のサブクラス
 class StdMaterialGetIntNumberList
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.sales での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales での AbstractController のサブクラス
class | BillingDocCreateMultipleController 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
class | BillingDocGetListController 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
class | InquiryCreateFromData2Controller 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
class | QuotationCreateFromData2Controller 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
class | SalesOrderCreateFromDat2Controller 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。
class | SalesOrderGetListController 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
class | SalesOrderGetStatusController 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での AbstractController のサブクラス
 class BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での AbstractController のサブクラス
 class BillingDocGetDetail
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での AbstractController のサブクラス
 class BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での AbstractController のサブクラス
 class InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での AbstractController のサブクラス
 class QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での AbstractController のサブクラス
 class SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での AbstractController のサブクラス
 class SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での AbstractController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での AbstractController のサブクラス
 class SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.ReferenceController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.ReferenceController の使用

ReferenceController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module.accounting での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.accounting での ReferenceController のサブクラス
class | BankList 銀行一覧クラス 機能は以下の通り 銀行の情報を一覧形式で取得します。
class | BusinessAreaList 事業領域一覧クラス 機能は以下の通り 事業領域の情報を一覧形式で取得します。
class | CompanyList 会社一覧クラス 機能は以下の通り 会社の情報を一覧形式で取得します。
class | ControllingAreaList 管理領域一覧クラス 機能は以下の通り 管理領域の情報を一覧形式で取得します。
class | CostCenterList 原価センタ一覧クラス 機能は以下の通り 原価センタの情報を一覧形式で取得します。
class | GlAccList 勘定項目一覧クラス 機能は以下の通り 勘定項目の情報を一覧形式で取得します。
class | ProfitCenterList 利益センタ一覧クラス 機能は以下の通り 利益センタの情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.financial での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.financial での ReferenceController のサブクラス
class | CommonCenterGrpGetDetail 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | CreditorGetDetail 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
class | DebtorGetDetail 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
class | ExchangeRateGetDetail 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
class | InternalOrderGetDetail 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
class | InternalOrderGetList 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
class | ProjectGetInfo WBS情報取得クラス 機能は以下の通り WBS情報を取得します。

jp.co.intra_mart.foundation.sap.module.purchase での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase での ReferenceController のサブクラス
class | GoodsMvtGetItemsController 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
class | MaterialAvailabilityController 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
class | MaterialGetAllController 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
class | MaterialGetList 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
class | MaterialGetListController 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
class | PurchaseGetItemSrel 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
class | SupplierDetail 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
class | SupplierExistenceCheck 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems での ReferenceController のサブクラス
 class GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability での ReferenceController のサブクラス
 class MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ReferenceController のサブクラス
 class MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での ReferenceController のサブクラス
 class StdMaterialGetIntNumberList
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。

jp.co.intra_mart.foundation.sap.module.sales での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales での ReferenceController のサブクラス
class | BillingDocGetListController 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
class | SalesOrderGetListController 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
class | SalesOrderGetStatusController 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での ReferenceController のサブクラス
 class BillingDocGetDetail
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での ReferenceController のサブクラス
 class BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist での ReferenceController のサブクラス
 class SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での ReferenceController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus での ReferenceController のサブクラス
 class SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.UpdateController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.UpdateController の使用

UpdateController を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |

jp.co.intra_mart.foundation.sap.module.accounting での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.accounting での UpdateController のサブクラス
 class AccEmployeePayPostController
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。

jp.co.intra_mart.foundation.sap.module.purchase での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase での UpdateController のサブクラス
class | GoodsMvtCreateController 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
class | MaterialSaveReplicaController 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
class | PurchaseOrderPayPost 伝票登録クラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
class | PurchaseRelease 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での UpdateController のサブクラス
 class GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica での UpdateController のサブクラス
 class MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales での UpdateController のサブクラス
class | BillingDocCreateMultipleController 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
class | InquiryCreateFromData2Controller 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
class | QuotationCreateFromData2Controller 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
class | SalesOrderCreateFromDat2Controller 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での UpdateController のサブクラス
 class BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での UpdateController のサブクラス
 class InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での UpdateController のサブクラス
 class QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での UpdateController の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での UpdateController のサブクラス
 class SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module のメソッド
protected  void AbstractController.executeBapi(BapiController bapiController)
引数で指定された bapiController のexecuteBapiメソッドを実行します。

jp.co.intra_mart.foundation.sap.module.purchase での SAPBapiReturnErrMessageExistException の使用

SAPBapiReturnErrMessageExistException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseRelease.executeBapi(BapiController bapiController)
伝票承認取消処理を実行します。
 void PurchaseOrderPayPost.executeBapi(BapiController bapiController)
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException の使用

SAPModuleAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleAppException のサブクラス
 class SAPAccountingAppException
p 会計系APIアプリケーション例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleAppException のサブクラス
 class SAPFinancialAppException
会計系APIアプリケーション例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleAppException のサブクラス
 class SAPPurchaseAppException
購買系APIアプリケーション例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleAppException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleAppException のサブクラス
 class SAPSalesAppException
販売管理系APIアプリケーション例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException の使用

SAPModuleSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.accounting.exception での SAPModuleSystemException のサブクラス
 class SAPAccountingSystemException
会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.financial.exception での SAPModuleSystemException のサブクラス
 class SAPFinancialSystemException
会計系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception での SAPModuleSystemException のサブクラス
 class SAPPurchaseSystemException
購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleSystemException の使用

jp.co.intra_mart.foundation.sap.module.sales.exception での SAPModuleSystemException のサブクラス
 class SAPSalesSystemException
販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.exception
例外
SAPBapiReturnErrMessageExistException
SAPModuleAppException
SAPModuleSystemException


jp.co.intra_mart.foundation.sap.module.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.exception

例外の概要
SAPBapiReturnErrMessageExistException | BAPI実行結果例外クラス
SAPModuleAppException | モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException | モジュール用データ取得・追加・更新APIシステム例外クラス


jp.co.intra_mart.foundation.sap.module.exception クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.exception の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.exception の使用

jp.co.intra_mart.foundation.sap.module.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.sales.exception |

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.accounting.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.financial.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPBapiReturnErrMessageExistException
BAPI実行結果例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.exception により使用される jp.co.intra_mart.foundation.sap.module.exception のクラス
SAPModuleAppException
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleSystemException
モジュール用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPBapiReturnErrMessageExistException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPBapiReturnErrMessageExistException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
すべての実装インタフェース:
Serializable
public class SAPBapiReturnErrMessageExistException
extends SAPException

BAPI実行結果例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPBapiReturnErrMessageExistException(String message)
BAPI実行結果例外
SAPBapiReturnErrMessageExistException(String message, Throwable ex)
BAPI実行結果例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPBapiReturnErrMessageExistException

public SAPBapiReturnErrMessageExistException(String message,
                                             Throwable ex)
BAPI実行結果例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPBapiReturnErrMessageExistException

public SAPBapiReturnErrMessageExistException(String message)
BAPI実行結果例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPModuleAppException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPModuleAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAccountingAppException, SAPFinancialAppException, SAPPurchaseAppException, SAPSalesAppException
public class SAPModuleAppException
extends SAPException

モジュール用データ取得・追加・更新APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPModuleAppException(String message)
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleAppException(String message, Throwable ex)
モジュール用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPModuleAppException

public SAPModuleAppException(String message,
                             Throwable ex)
モジュール用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPModuleAppException

public SAPModuleAppException(String message)
モジュール用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SAPModuleSystemException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.exception
クラス SAPModuleSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAccountingSystemException, SAPFinancialSystemException, SAPPurchaseSystemException, SAPSalesSystemException
public class SAPModuleSystemException
extends SAPException

モジュール用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPModuleSystemException(String message)
モジュール用データ取得・追加・更新APIシステム例外
SAPModuleSystemException(String message, Throwable ex)
モジュール用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPModuleSystemException

public SAPModuleSystemException(String message,
                                Throwable ex)
モジュール用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPModuleSystemException

public SAPModuleSystemException(String message)
モジュール用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract の使用

jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail の使用

CommonCenterGrpGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CommonCenterGrpGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial での CommonCenterGrpGetDetail のサブクラス
class | CostCenterGroupGetDetail 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
class | ProfitCenterGrpGetDetail 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail の使用

CreditorGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での CreditorGetDetail の使用

CreditorGetDetail を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
 CreditorGetDetail CreditorGetDetailController.getCreditorGetDetail()
仕入先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail の使用

DebtorGetDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での DebtorGetDetail の使用

DebtorGetDetail を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
 DebtorGetDetail DebtorGetDetailController.getDebtorGetDetail()
得意先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExchRate の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExchRate の使用

ExchRate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での ExchRate の使用

ExchRate を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
ExchRate | ExchangeRateGetDetailController.getExchRate() 換算レート、係数 (通貨ペア)を取得します。
ExchRate | ExchangeRateGetDetail.getExchRate() 換算レート、係数 (通貨ペア)を取得します。

ExchRate 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ExchangeRateGetDetailController.setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。
void | ExchangeRateGetDetail.setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpActivity の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpActivity の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpActivity はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpMessage の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpMessage の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpMessage はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone の使用

jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes の使用

jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues の使用

jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement の使用

jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController の使用

jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.MasterData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.MasterData の使用

MasterData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での MasterData の使用

MasterData を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
MasterData | InternalOrderGetDetailController.getMasterData() 指図のマスタデータ構造を取得します。
MasterData | InternalOrderGetDetail.getMasterData() 指図のマスタデータ構造を取得します。

MasterData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | InternalOrderGetDetailController.setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。
void | InternalOrderGetDetail.setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.OrderList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.OrderList の使用

jp.co.intra_mart.foundation.sap.module.financial.OrderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail の使用

jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition の使用

ProjectDefinition を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での ProjectDefinition の使用

ProjectDefinition を返す jp.co.intra_mart.foundation.sap.module.financial のメソッド
ProjectDefinition | ProjectGetInfoController.getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。
ProjectDefinition | ProjectGetInfo.getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。

ProjectDefinition 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.financial のメソッド
void | ProjectGetInfoController.setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。
void | ProjectGetInfo.setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo の使用

jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController の使用

jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.SystemStatus の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.SystemStatus の使用

jp.co.intra_mart.foundation.sap.module.financial.SystemStatus はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.UserStatus の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.UserStatus の使用

jp.co.intra_mart.foundation.sap.module.financial.UserStatus はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException の使用

SAPFinancialAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での SAPFinancialAppException の使用

SAPFinancialAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。

SAPFinancialAppException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException の使用

SAPFinancialSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial での SAPFinancialSystemException の使用

SAPFinancialSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のメソッド
 void ProjectGetInfoController.executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 void ProjectGetInfoController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 String ProjectGetInfoController.getProjectDefinition()
プロジェクト定義を識別するキーを取得します。
 String ProjectGetInfoController.getWithActivities()
従属活動を取得します。
 String ProjectGetInfoController.getWithMilestones()
従属 WBS マイルストーンを取得します。
 String ProjectGetInfoController.getWithSubtree()
サブプロジェクトを取得します。
 void ProjectGetInfo.executeBapi()
BapiControllerによりWBSの詳細情報の検索します。
 void ProjectGetInfo.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void ProjectGetInfo.setImportParam(BapiController bapiController)
WEBの詳細情報を検索する条件ををセットします。
 void ProfitCenterGrpGetDetailController.executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 void ProfitCenterGrpGetDetail.executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
 void InternalOrderGetListController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 void InternalOrderGetList.executeBapi()
BapiControllerにより内部指図書（一覧）情報を検索します。
 void InternalOrderGetList.setImportParam(BapiController bapiController)
内部指図書（一覧）情報を検索する条件ををセットします。
 void InternalOrderGetDetailController.executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 void InternalOrderGetDetail.executeBapi()
BapiControllerにより内部指図書詳細情報を検索します。
 void InternalOrderGetDetail.setImportParam(BapiController bapiController)
内部指図書詳細情報を検索する条件ををセットします。
 void ExchangeRateGetDetailController.executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 void ExchangeRateGetDetail.executeBapi()
BapiControllerにより為替換算レート情報を検索します。
 void ExchangeRateGetDetail.setImportParam(BapiController bapiController)
為替換算レート情報を検索する条件ををセットします。
 void DebtorGetDetail.executeBapi()
BapiControllerにより得意先コードを検索します。
 void DebtorGetDetail.setImportParam(BapiController bapiController)
得意先コードの詳細情報を検索する条件ををセットします。
 void CreditorGetDetail.executeBapi()
BapiControllerにより仕入先コードを検索します。
 void CreditorGetDetail.setImportParam(BapiController bapiController)
仕入先コードの詳細情報を検索する条件ををセットします。
 void CostCenterGroupGetDetailController.executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 void CostCenterGroupGetDetail.executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
 void CommonCenterGrpGetDetail.setImportParam(BapiController bapiController)
センタグループを検索する条件ををセットします。

SAPFinancialSystemException をスローする jp.co.intra_mart.foundation.sap.module.financial のコンストラクタ
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.financial.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.financial.exception
例外
SAPFinancialAppException
SAPFinancialSystemException


jp.co.intra_mart.foundation.sap.module.financial.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception

ＳＡＰ連携管理会計系例外クラスを提供します。

参照:
説明

例外の概要
SAPFinancialAppException | 会計系APIアプリケーション例外クラス
SAPFinancialSystemException | 会計系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の説明

ＳＡＰ連携管理会計系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.financial.exception クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.financial.exception の使用

jp.co.intra_mart.foundation.sap.module.financial.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module.financial.exception のクラス
SAPFinancialAppException
会計系APIアプリケーション例外クラス
SAPFinancialSystemException
会計系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPFinancialAppException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial.exception
クラス SAPFinancialAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
すべての実装インタフェース:
Serializable
public class SAPFinancialAppException
extends SAPModuleAppException

会計系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPFinancialAppException(String message)
会計系APIアプリケーション例外
SAPFinancialAppException(String message, Throwable ex)
会計系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPFinancialAppException

public SAPFinancialAppException(String message,
                                Throwable ex)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPFinancialAppException

public SAPFinancialAppException(String message)
会計系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPFinancialSystemException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial.exception
クラス SAPFinancialSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException
すべての実装インタフェース:
Serializable
public class SAPFinancialSystemException
extends SAPModuleSystemException

会計系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPFinancialSystemException(String message, Throwable ex)
会計系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPFinancialSystemException

public SAPFinancialSystemException(String message,
                                   Throwable ex)
会計系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AllowedBusTract (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス AllowedBusTract

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract
すべての実装インタフェース:
Serializable
public class AllowedBusTract
extends Object
implements Serializable

使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り

  • 使用可能業務トランザクションのテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AllowedBusTract()
使用可能業務トランザクションのテーブルを作成します。
メソッドの概要
String | getDescript() テキスト (30 文字)を取得します。
String | getTrans() 取引を取得します。
void | setDescript(String strDescript) テキスト (30 文字)を設定します。
void | setTrans(String strTrans) 取引を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AllowedBusTract

public AllowedBusTract()
使用可能業務トランザクションのテーブルを作成します。

メソッドの詳細

getTrans

public String getTrans()
取引を取得します。

戻り値:
srtTrans 取引

getDescript

public String getDescript()
テキスト (30 文字)を取得します。

戻り値:
srtDescript テキスト (30 文字)

setTrans

public void setTrans(String strTrans)
取引を設定します。

パラメータ:
strTrans - 取引

setDescript

public void setDescript(String strDescript)
テキスト (30 文字)を設定します。

パラメータ:
strDescript - テキスト (30 文字)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CommonCenterGrpGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CommonCenterGrpGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
CostCenterGroupGetDetail, ProfitCenterGrpGetDetail
public class CommonCenterGrpGetDetail
extends ReferenceController
implements Serializable

原価・利益センタグループ情報取得共通クラス
機能は以下の通り

  • 原価・利益センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成
CommonCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
String | getControllingarea() 管理領域を取得します。
String | getGroupname() グループ名を取得します。
ArrayList | getHierarchyNodesList() 階層ノード一覧を取得します。
ArrayList | getHierarchyValuesList() 階層値一覧を取得します。
void | setControllingarea(String strControllingarea) 管理領域を設定します。
void | setExportParam(BapiController bapiController) センタグループ情報ををセットします。
void | setGroupname(String strGroupname) グループ名を設定します。
void | setHierarchyNodesList(ArrayList hierarchyNodesList) 階層ノード一覧を設定します。
void | setHierarchyValuesList(ArrayList hierarchyValuesList) 階層値一覧を設定します。
void | setImportParam(BapiController bapiController) センタグループを検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(SapClient sapClient)
センタグループ情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト

CommonCenterGrpGetDetail

public CommonCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
センタグループを検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
センタグループ情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterGroupGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CostCenterGroupGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
                拡張 jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail
すべての実装インタフェース:
Serializable
public class CostCenterGroupGetDetail
extends CommonCenterGrpGetDetail
implements Serializable

原価センタグループ情報取得クラス
機能は以下の通り

  • 原価センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成
CostCenterGroupGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
BapiControllerにより原価センタグループ検索を検索します。
クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail から継承したメソッド
getControllingarea, getGroupname, getHierarchyNodesList, getHierarchyValuesList, setControllingarea, setExportParam, setGroupname, setHierarchyNodesList, setHierarchyValuesList, setImportParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(SapClient sapClient)
原価センタグループ情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト

CostCenterGroupGetDetail

public CostCenterGroupGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納しているオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより原価センタグループ検索を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CostCenterGroupGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CostCenterGroupGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController
すべての実装インタフェース:
Serializable
public class CostCenterGroupGetDetailController
extends Object
implements Serializable

原価センタグループコントローラクラス
機能は以下の通り

  • 原価センタグループを取得します。

関連項目:
直列化された形式

コンストラクタの概要
CostCenterGroupGetDetailController()
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(String controllingarea, String groupname)
CostCenterGroupGetDetailController(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
 String getControllingarea()
管理領域を取得します。
 String getGroupname()
グループ名を取得します。
 ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。
 ArrayList getHierarchyValuesList()
階層値一覧を取得します。
 void setControllingarea(String strControllingarea)
管理領域を設定します。
 void setGroupname(String strGroupname)
グループ名を設定します。
 void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。
 void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(String controllingarea,
                                          String groupname,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController()
CostCenterGroupGetDetailControllerのコンストラクタを生成します。

CostCenterGroupGetDetailController

public CostCenterGroupGetDetailController(SapClient sapClient)
CostCenterGroupGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreditorGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CreditorGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail
すべての実装インタフェース:
Serializable
public class CreditorGetDetail
extends ReferenceController
implements Serializable

仕入先詳細情報取得クラス
機能は以下の通り

  • 仕入先詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成
CreditorGetDetail(String creditorid, String companycode, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより仕入先コードを検索します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getCreditorid() 仕入先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setCreditorid(String strCreditorid) 仕入先コードを設定します｡
void | setExportParam(BapiController bapiController) 仕入先コードの詳細情報ををセットします。
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setImportParam(BapiController bapiController) 仕入先コードの詳細情報を検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreditorGetDetail

public CreditorGetDetail(SapClient sapClient)
仕入先詳細情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

CreditorGetDetail

public CreditorGetDetail(String creditorid,
                         String companycode,
                         SapClient sapClient)
                  throws SAPAuthAppException,
                         SAPAuthSystemException,
                         SAPGeneralAppException,
                         SAPGeneralSystemException,
                         SAPFinancialAppException,
                         SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより仕入先コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
仕入先コードの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
仕入先コードの詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getCreditorid

public String getCreditorid()
仕入先コードを取得します｡

戻り値:
strCreditorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setCreditorid

public void setCreditorid(String strCreditorid)
仕入先コードを設定します｡

パラメータ:
strCreditorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreditorGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス CreditorGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController
すべての実装インタフェース:
Serializable
public class CreditorGetDetailController
extends Object
implements Serializable

仕入先詳細コントローラクラス
機能は以下の通り

  • 仕入先詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
CreditorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(String creditorid, String companycode)
CreditorGetDetailController(String creditorid, String companycode, SapClient sapClient)
メソッドの概要
ArrayList | getBankDataList() 銀行データ情報を取得します。
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
CreditorGetDetail | getCreditorGetDetail() 仕入先マスタ詳細情報を取得します｡
String | getCreditorid() 仕入先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strCreditorid) 仕入先コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreditorGetDetailController

public CreditorGetDetailController(String creditorid,
                                   String companycode)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPFinancialAppException,
                                   SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CreditorGetDetailController

public CreditorGetDetailController(String creditorid,
                                   String companycode,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPFinancialAppException,
                                   SAPFinancialSystemException
パラメータ:
creditorid - 仕入先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

CreditorGetDetailController

public CreditorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。

CreditorGetDetailController

public CreditorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setDebtorid

public void setDebtorid(String strCreditorid)
仕入先コードを設定します｡

パラメータ:
strCreditorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

getCreditorGetDetail

public CreditorGetDetail getCreditorGetDetail()
仕入先マスタ詳細情報を取得します｡

戻り値:
DebtorGetDetail

getCreditorid

public String getCreditorid()
仕入先コードを取得します｡

戻り値:
strCreditorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DebtorGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス DebtorGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail
すべての実装インタフェース:
Serializable
public class DebtorGetDetail
extends ReferenceController
implements Serializable

得意先詳細情報取得クラス
機能は以下の通り

  • 得意先詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成
DebtorGetDetail(String Debtorid, String Companycode, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより得意先コードを検索します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getDebtorid() 得意先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strDebtorid) 得意先コードを設定します｡
void | setExportParam(BapiController bapiController) 得意先コードの詳細情報ををセットします。
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setImportParam(BapiController bapiController) 得意先コードの詳細情報を検索する条件ををセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DebtorGetDetail

public DebtorGetDetail(SapClient sapClient)
得意先詳細情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

DebtorGetDetail

public DebtorGetDetail(String Debtorid,
                       String Companycode,
                       SapClient sapClient)
                throws SAPAuthAppException,
                       SAPAuthSystemException,
                       SAPGeneralAppException,
                       SAPGeneralSystemException,
                       SAPFinancialAppException,
                       SAPFinancialSystemException
パラメータ:
Debtorid - 得意先コード
Companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより得意先コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
得意先コードの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
得意先コードの詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getDebtorid

public String getDebtorid()
得意先コードを取得します｡

戻り値:
strDebtorid 仕入先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setDebtorid

public void setDebtorid(String strDebtorid)
得意先コードを設定します｡

パラメータ:
strDebtorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DebtorGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス DebtorGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController
すべての実装インタフェース:
Serializable
public class DebtorGetDetailController
extends Object
implements Serializable

得意先詳細コントローラクラス
機能は以下の通り

  • 得意先詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
DebtorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(String debtorid, String companycode)
DebtorGetDetailController(String debtorid, String companycode, SapClient sapClient)
メソッドの概要
ArrayList | getBankDataList() 銀行データ情報を取得します。
String | getCompanycode() 会社コードを取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
DebtorGetDetail | getDebtorGetDetail() 得意先マスタ詳細情報を取得します｡
String | getDebtorid() 得意先コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanycode(String strCompanycode) 会社コードを設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setDebtorid(String strDebtorid) 得意先コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DebtorGetDetailController

public DebtorGetDetailController(String debtorid,
                                 String companycode)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPFinancialAppException,
                                 SAPFinancialSystemException
パラメータ:
debtorid - 得意先コード
companycode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

DebtorGetDetailController

public DebtorGetDetailController(String debtorid,
                                 String companycode,
                                 SapClient sapClient)
                          throws SAPAuthAppException,
                                 SAPAuthSystemException,
                                 SAPGeneralAppException,
                                 SAPGeneralSystemException,
                                 SAPFinancialAppException,
                                 SAPFinancialSystemException
パラメータ:
debtorid - 得意先コード
companycode - 会社コード
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

DebtorGetDetailController

public DebtorGetDetailController()
DebtorGetDetailControllerのコンストラクタを生成します。

DebtorGetDetailController

public DebtorGetDetailController(SapClient sapClient)
DebtorGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setDebtorid

public void setDebtorid(String strDebtorid)
得意先コードを設定します｡

パラメータ:
strDebtorid - 仕入先コード

setCompanycode

public void setCompanycode(String strCompanycode)
会社コードを設定します｡

パラメータ:
strCompanycode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

getDebtorGetDetail

public DebtorGetDetail getDebtorGetDetail()
得意先マスタ詳細情報を取得します｡

戻り値:
DebtorGetDetail

getDebtorid

public String getDebtorid()
得意先コードを取得します｡

戻り値:
strDebtorid 得意先コード

getCompanycode

public String getCompanycode()
会社コードを取得します｡

戻り値:
strCompanycode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchangeRateGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchangeRateGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail
すべての実装インタフェース:
Serializable
public class ExchangeRateGetDetail
extends ReferenceController
implements Serializable

為替換算レート情報取得クラス
機能は以下の通り

  • 為替換算レート情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成
ExchangeRateGetDetail(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより為替換算レート情報を検索します。
String | getDate() 起算日を取得します。
ExchRate | getExchRate() 換算レート、係数 (通貨ペア)を取得します。
String | getFromCurr() 換算前通貨を取得します。
String | getRateType() 換算レートタイプを取得します。
String | getToCurrncy() 換算後通貨を取得します。
void | setDate(String strDate) 起算日を設定します。
void | setExchRate(ExchRate exchRate) 換算レート、係数 (通貨ペア)を設定します。
void | setExportParam(BapiController bapiController) 為替換算レート情報ををセットします。
void | setFromCurr(String strFromCurr) 換算前通貨を設定します。
void | setImportParam(BapiController bapiController) 為替換算レート情報を検索する条件ををセットします。
void | setRateType(String strRateType) 換算レートタイプを設定します。
void | setToCurrncy(String strToCurrncy) 換算後通貨を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExchangeRateGetDetail

public ExchangeRateGetDetail(SapClient sapClient)
為替換算レート情報を作成

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

ExchangeRateGetDetail

public ExchangeRateGetDetail(String rateType,
                             String fromCurr,
                             String toCurrncy,
                             String date,
                             SapClient sapClient)
                      throws SAPAuthAppException,
                             SAPAuthSystemException,
                             SAPGeneralAppException,
                             SAPGeneralSystemException,
                             SAPFinancialAppException,
                             SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより為替換算レート情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
為替換算レート情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
為替換算レート情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setDate

public void setDate(String strDate)
起算日を設定します。

パラメータ:
strDate - 起算日

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtTo_Currncy 換算後通貨

getDate

public String getDate()
起算日を取得します。

戻り値:
srtDate 起算日

setExchRate

public void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。

パラメータ:
exchRate - 換算レート、係数 (通貨ペア)

getExchRate

public ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。

戻り値:
exchRate 換算レート、係数 (通貨ペア)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchangeRateGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchangeRateGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController
すべての実装インタフェース:
Serializable
public class ExchangeRateGetDetailController
extends Object
implements Serializable

為替換算レートコントローラクラス
機能は以下の通り

  • 為替換算レートを取得します。

関連項目:
直列化された形式

コンストラクタの概要
ExchangeRateGetDetailController()
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date)
ExchangeRateGetDetailController(String rateType, String fromCurr, String toCurrncy, String date, SapClient sapClient)
メソッドの概要
 void executeBapi()
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
 String getDate()
起算日を取得します。
 ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。
 String getFromCurr()
換算前通貨を取得します。
 String getRateType()
換算レートタイプを取得します。
 String getToCurrncy()
換算後通貨を取得します。
 void setDate(String strDate)
起算日を設定します。
 void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。
 void setFromCurr(String strFromCurr)
換算前通貨を設定します。
 void setRateType(String strRateType)
換算レートタイプを設定します。
 void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(String rateType,
                                       String fromCurr,
                                       String toCurrncy,
                                       String date)
                                throws SAPAuthAppException,
                                       SAPAuthSystemException,
                                       SAPGeneralAppException,
                                       SAPGeneralSystemException,
                                       SAPFinancialAppException,
                                       SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(String rateType,
                                       String fromCurr,
                                       String toCurrncy,
                                       String date,
                                       SapClient sapClient)
                                throws SAPAuthAppException,
                                       SAPAuthSystemException,
                                       SAPGeneralAppException,
                                       SAPGeneralSystemException,
                                       SAPFinancialAppException,
                                       SAPFinancialSystemException
パラメータ:
rateType - 換算レートタイプ
fromCurr - 換算前通貨
toCurrncy - 換算後通貨
date - 起算日
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ExchangeRateGetDetailController

public ExchangeRateGetDetailController()
ExchangeRateGetDetailControllerのコンストラクタを生成します。

ExchangeRateGetDetailController

public ExchangeRateGetDetailController(SapClient sapClient)
ExchangeRateGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setDate

public void setDate(String strDate)
起算日を設定します。

パラメータ:
strDate - 起算日

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtTo_Currncy 換算後通貨

getDate

public String getDate()
起算日を取得します。

戻り値:
srtDate 起算日

setExchRate

public void setExchRate(ExchRate exchRate)
換算レート、係数 (通貨ペア)を設定します。

パラメータ:
exchRate - 換算レート、係数 (通貨ペア)

getExchRate

public ExchRate getExchRate()
換算レート、係数 (通貨ペア)を取得します。

戻り値:
exchRate 換算レート、係数 (通貨ペア)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExchRate (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExchRate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExchRate
すべての実装インタフェース:
Serializable
public class ExchRate
extends Object
implements Serializable

換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り

  • 換算レート、係数 (通貨ペア)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExchRate()
換算レート、係数 (通貨ペア)を作成します。
メソッドの概要
String | getExchRate() 直接呼び値換算レートを取得します。
String | getExchRateV() 間接呼び値換算レートを取得します。
String | getFromCurr() 換算前通貨を取得します。
String | getFromFactor() 換算前 通貨単位の係数を取得します。
String | getFromFactorV() 換算前 通貨単位の係数を取得します。
String | getRateType() 換算レートタイプを取得します。
String | getToCurrncy() 換算後通貨を取得します。
String | getToFactor() 換算後 通貨単位の係数を取得します。
String | getToFactorV() 換算後 通貨単位の係数を取得します。
String | getValidFrom() エントリの有効開始日を取得します。
void | setExchRate(String strExchRate) 直接呼び値換算レートを設定します。
void | setExchRateV(String strExchRateV) 間接呼び値換算レートを設定します。
void | setFromCurr(String strFromCurr) 換算前通貨を設定します。
void | setFromFactor(String strFromFactor) 換算前 通貨単位の係数を設定します。
void | setFromFactorV(String strFromFactorV) 換算前 通貨単位の係数を設定します。
void | setRateType(String strRateType) 換算レートタイプを設定します。
void | setToCurrncy(String strToCurrncy) 換算後通貨を設定します。
void | setToFactor(String strToFactor) 換算後 通貨単位の係数を設定します。
void | setToFactorV(String strToFactorV) 換算後 通貨単位の係数を設定します。
void | setValidFrom(String strValidFrom) エントリの有効開始日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExchRate

public ExchRate()
換算レート、係数 (通貨ペア)を作成します。

メソッドの詳細

getRateType

public String getRateType()
換算レートタイプを取得します。

戻り値:
srtRateType 換算レートタイプ

getFromCurr

public String getFromCurr()
換算前通貨を取得します。

戻り値:
srtFromCurr 換算前通貨

getToCurrncy

public String getToCurrncy()
換算後通貨を取得します。

戻り値:
srtToCurrncy 換算後通貨

getValidFrom

public String getValidFrom()
エントリの有効開始日を取得します。

戻り値:
srtValidFrom エントリの有効開始日

getExchRate

public String getExchRate()
直接呼び値換算レートを取得します。

戻り値:
srtExchRate 直接呼び値換算レート

getFromFactor

public String getFromFactor()
換算前 通貨単位の係数を取得します。

戻り値:
srtFromFactor 換算前 通貨単位の係数

getToFactor

public String getToFactor()
換算後 通貨単位の係数を取得します。

戻り値:
srtToFactor 換算後 通貨単位の係数

getExchRateV

public String getExchRateV()
間接呼び値換算レートを取得します。

戻り値:
srtExchRateV 間接呼び値換算レート

getFromFactorV

public String getFromFactorV()
換算前 通貨単位の係数を取得します。

戻り値:
srtFromFactorV 換算前 通貨単位の係数

getToFactorV

public String getToFactorV()
換算後 通貨単位の係数を取得します。

戻り値:
srtToFactorV 換算後 通貨単位の係数

setRateType

public void setRateType(String strRateType)
換算レートタイプを設定します。

パラメータ:
strRateType - 換算レートタイプ

setFromCurr

public void setFromCurr(String strFromCurr)
換算前通貨を設定します。

パラメータ:
strFromCurr - 換算前通貨

setToCurrncy

public void setToCurrncy(String strToCurrncy)
換算後通貨を設定します。

パラメータ:
strToCurrncy - 換算後通貨

setValidFrom

public void setValidFrom(String strValidFrom)
エントリの有効開始日を設定します。

パラメータ:
strValidFrom - エントリの有効開始日

setExchRate

public void setExchRate(String strExchRate)
直接呼び値換算レートを設定します。

パラメータ:
strExchRate - 直接呼び値換算レート

setFromFactor

public void setFromFactor(String strFromFactor)
換算前 通貨単位の係数を設定します。

パラメータ:
strFromFactor - 換算前 通貨単位の係数

setToFactor

public void setToFactor(String strToFactor)
換算後 通貨単位の係数を設定します。

パラメータ:
strToFactor - 換算後 通貨単位の係数

setExchRateV

public void setExchRateV(String strExchRateV)
間接呼び値換算レートを設定します。

パラメータ:
strExchRateV - 間接呼び値換算レート

setFromFactorV

public void setFromFactorV(String strFromFactorV)
換算前 通貨単位の係数を設定します。

パラメータ:
strFromFactorV - 換算前 通貨単位の係数

setToFactorV

public void setToFactorV(String strToFactorV)
換算後 通貨単位の係数を設定します。

パラメータ:
strToFactorV - 換算後 通貨単位の係数

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpActivity (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpActivity

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpActivity
すべての実装インタフェース:
Serializable
public class ExpActivity
extends Object
implements Serializable

活動に関する詳細情報クラス 機能は以下の通り

  • 活動に関する詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpActivity()
活動に関する詳細情報を作成します。
メソッドの概要
String | getActivity() ネットワーク/標準ネットワークの活動番号を取得します。
String | getActivityCosts() 活動の原価を取得します。
String | getActtype() 活動タイプを取得します。
String | getActualCost() 実際原価を取得します。
String | getActualFinishDate() 実績終了日: 実行 (日付)を取得します。
String | getActualStartDate() 実績開始日: 実行 (日付)を取得します。
String | getComplete() 最終確認の有効化を取得します。
String | getConstraintFinishDate() 活動の基準終了日に対する制約を取得します。
String | getConstraintFinishDateFc() 予測終了日付を取得します。
String | getConstraintFinishTime() 活動の基準終了時間を取得します。
String | getConstraintFinishTimeFc() 活動の予測終了時間を取得します。
String | getConstraintStartDate() 活動の基準開始日に対する制約を取得します。
String | getConstraintStartDateFc() 活動の予測開始日を取得します。
String | getConstraintStartTime() 活動の基準開始時間の制約を取得します。
String | getConstraintStartTimeFc() 活動の需要予測開始時間を取得します。
String | getConstraintTypeFinish() 活動の終了日に対する制約を取得します。
String | getConstraintTypeFinishFc() 活動終了の制約条件付き需要予測日付を取得します。
String | getConstraintTypeStart() 活動の基準開始日に対する制約を取得します。
String | getConstraintTypeStartFc() 活動開始の制約条件付き需要予測日付を取得します。
String | getControlKey() 管理キーを取得します。
String | getControllingAreaCurrency() 通貨コードを取得します。
String | getCostElem() 原価要素を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() 作業テキスト (短)を取得します。
String | getDistributingKey() 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。
String | getDurationConfirmFc() 確認の予測活動期間を取得します。
String | getDurationConfirmFcUnit() 確認の予測期間単位を取得します。
String | getDurationConfirmFcUnitIso() 単位の ISO コードを取得します。
String | getDurationMinimum() 最短活動期間を取得します。
String | getDurationMinimumFc() 活動の最小期間(需要予測より)を取得します。
String | getDurationMinimumFcUnit() 予測最短期間の単位を取得します。
String | getDurationMinimumFcUnitIso() 単位の ISO コードを取得します。
String | getDurationMinimumUnit() 最短期間の単位を取得します。
String | getDurationMinimumUnitIso() 単位の ISO コードを取得します。
String | getDurationNormal() 標準活動期間を取得します。
String | getDurationNormalFc() 標準活動期間 (予測)を取得します。
String | getDurationNormalFcUnit() 標準予測期間の単位を取得します。
String | getDurationNormalFcUnitIso() 単位の ISO コードを取得します。
String | getDurationNormalUnit() 標準期間/単位を取得します。
String | getDurationNormalUnitIso() 単位の ISO コードを取得します。
String | getDurationScheduled() 処理時間を取得します。
String | getDurationScheduledFc() 処理時間の長さ (予測値)を取得します。
String | getDurationScheduledUnit() 処理時間単位を取得します。
String | getDurationScheduledUnitIso() 単位の ISO コードを取得します。
String | getEarlyFinishDate() 最早計画終了: 実行 (日)を取得します。
String | getEarlyFinishDateFc() 最早計画終了日 (予測)を取得します。
String | getEarlyFinishTime() 最早計画終了: 実行 (時刻)を取得します。
String | getEarlyFinishTimeFc() 最早計画終了時間(需要予測)を取得します。
String | getEarlyStartDate() 最早計画開始: 実行 (日)を取得します。
String | getEarlyStartDateFc() 最早計画開始日付(需要予測)を取得します。
String | getEarlyStartTime() 最早計画開始: 作業実施(時間)を取得します。
String | getEarlyStartTimeFc() 最早計画開始時間(需要予測)を取得します。
String | getFactoryCalendar() 稼働日カレンダを取得します。
String | getFlexibleDuration() 区分: 可変期間を取得します。
String | getFloatFree() 自由余裕を取得します。
String | getFloatFreeFc() 自由余裕 (予測)を取得します。
String | getFloatTotal() 余裕合計を取得します。
String | getFloatTotalFc() 余裕合計 (予測)を取得します。
String | getForecastFinishDate() 予測終了日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getInfoRec() 購買情報番号を取得します。
String | getLatestFinishDate() 計画最遅終了: 作業(日付)を取得します。
String | getLatestFinishDateFc() 最遅計画済終了日付(需要予測)を取得します。
String | getLatestFinishTime() 計画最遅終了: 作業(時間)を取得します。
String | getLatestFinishTimeFc() 最遅計画終了時間 (予測)を取得します。
String | getLatestStartDate() 計画最遅開始: 作業(日付)を取得します。
String | getLatestStartDateFc() 最遅計画済開始日付(需要予測)を取得します。
String | getLatestStartTime() 計画最遅開始: 作業(時間)を取得します。
String | getLatestStartTimeFc() 最遅計画済開始時間(需要予測)を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMilestone() 用途を取得します。
String | getNetwork() ネットワーク番号を取得します。
String | getNotMrpApplicable() 区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。
String | getNumberOfCapacities() 所要能力数を取得します。
String | getObjectclass() オブジェクトクラス (言語非依存)を取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getOperationMeasureUnit() 活動単位を取得します。
String | getOperationMeasureUnitIso() 単位の ISO コードを取得します。
String | getPercentOfWork() 作業の比率 (%)を取得します。
String | getPlannedCost() 計画原価を取得します。
String | getPlant() プラントを取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPrice() 価格を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getPriority() 優先度を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjectSummarization() 区分: プロジェクト集計用に活動を考慮を取得します。
String | getPurchOrg() 購買組織を取得します。
String | getPurGroup() 購買グループを取得します。
String | getReferencePoint() BOM 転送の参照ポイントを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnWork() 作業単位を取得します。
String | getUnWorkIso() 単位の ISO コードを取得します。
String | getUserFieldChar10_1() ユーザ定義項目 (10 文字)を取得します。
String | getUserFieldChar10_2() ユーザ定義項目 (10 文字)を取得します。
String | getUserFieldChar20_1() 20 文字のユーザ項目を取得します。
String | getUserFieldChar20_2() 20 文字のユーザ項目を取得します。
String | getUserFieldCuky1() ユーザ項目: 値項目の単位を取得します。
String | getUserFieldCuky1Iso() ISO 通貨コードを取得します。
String | getUserFieldCuky2() ユーザ項目: 値項目の単位を取得します。
String | getUserFieldCuky2Iso() ISO 通貨コードを取得します。
String | getUserFieldCurr1() 値のユーザ定義項目 (長さ 10,3)を取得します。
String | getUserFieldCurr2() 値のユーザ定義項目 (長さ 10,3)を取得します。
String | getUserFieldDate1() 日付のユーザ項目を取得します。
String | getUserFieldDate2() 日付のユーザ項目を取得します。
String | getUserFieldFlag1() ユーザ定義項目: レポート区分を取得します。
String | getUserFieldFlag2() ユーザ定義項目: レポート区分を取得します。
String | getUserFieldKey() ユーザ定義項目のキーワード IDを取得します。
String | getUserFieldQuan1() 数量のユーザ項目 (長さ 10,3)を取得します。
String | getUserFieldQuan2() 数量のユーザ項目 (長さ 10,3)を取得します。
String | getUserFieldUnit1() ユーザ項目: 数量項目の単位を取得します。
String | getUserFieldUnit1Iso() 単位の ISO コードを取得します。
String | getUserFieldUnit2() ユーザ項目: 数量項目の単位を取得します。
String | getUserFieldUnit2Iso() 単位の ISO コードを取得します。
String | getVendorNo() 仕入先または債権者の勘定コードを取得します。
String | getWbsElement() WBS 要素を取得します。
String | getWorkActivity() 活動に含まれる作業を取得します。
String | getWorkActual() 実績作業を取得します。
String | getWorkCntr() 作業区を取得します。
String | getWorkForecast() 予測作業 (実績 + 残存)を取得します。
void | setActivity(String strActivity) ネットワーク/標準ネットワークの活動番号を設定します。
void | setActivityCosts(String strActivityCosts) 活動の原価を設定します。
void | setActtype(String strActtype) 活動タイプを設定します。
void | setActualCost(String strActualCost) 実際原価を設定します。
void | setActualFinishDate(String strActualFinishDate) 実績終了日: 実行 (日付)を設定します。
void | setActualStartDate(String strActualStartDate) 実績開始日: 実行 (日付)を設定します。
void | setComplete(String strComplete) 最終確認の有効化を設定します。
void | setConstraintFinishDate(String strConstraintFinishDate) 活動の基準終了日に対する制約を設定します。
void | setConstraintFinishDateFc(String strConstraintFinishDateFc) 予測終了日付を設定します。
void | setConstraintFinishTime(String strConstraintFinishTime) 活動の基準終了時間を設定します。
void | setConstraintFinishTimeFc(String strConstraintFinishTimeFc) 活動の予測終了時間を設定します。
void | setConstraintStartDate(String strConstraintStartDate) 活動の基準開始日に対する制約を設定します。
void | setConstraintStartDateFc(String strConstraintStartDateFc) 活動の予測開始日を設定します。
void | setConstraintStartTime(String strConstraintStartTime) 活動の基準開始時間の制約を設定します。
void | setConstraintStartTimeFc(String strConstraintStartTimeFc) 活動の需要予測開始時間を設定します。
void | setConstraintTypeFinish(String strConstraintTypeFinish) 活動の終了日に対する制約を設定します。
void | setConstraintTypeFinishFc(String strConstraintTypeFinishFc) 活動終了の制約条件付き需要予測日付を設定します。
void | setConstraintTypeStart(String strConstraintTypeStart) 活動の基準開始日に対する制約を設定します。
void | setConstraintTypeStartFc(String strConstraintTypeStartFc) 活動開始の制約条件付き需要予測日付を設定します。
void | setControlKey(String strControlKey) 管理キーを設定します。
void | setControllingAreaCurrency(String strControllingAreaCurrency) 通貨コードを設定します。
void | setCostElem(String strCostElem) 原価要素を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) 作業テキスト (短)を設定します。
void | setDistributingKey(String strDistributingKey) 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。
void | setDurationConfirmFc(String strDurationConfirmFc) 確認の予測活動期間を設定します。
void | setDurationConfirmFcUnit(String strDurationConfirmFcUnit) 確認の予測期間単位を設定します。
void | setDurationConfirmFcUnitIso(String strDurationConfirmFcUnitIso) 単位の ISO コードを設定します。
void | setDurationMinimum(String strDurationMinimum) 最短活動期間を設定します。
void | setDurationMinimumFc(String strDurationMinimumFc) 活動の最小期間(需要予測より)を設定します。
void | setDurationMinimumFcUnit(String strDurationMinimumFcUnit) 予測最短期間の単位を設定します。
void | setDurationMinimumFcUnitIso(String strDurationMinimumFcUnitIso) 単位の ISO コードを設定します。
void | setDurationMinimumUnit(String strDurationMinimumUnit) 最短期間の単位を設定します。
void | setDurationMinimumUnitIso(String strDurationMinimumUnitIso) 単位の ISO コードを設定します。
void | setDurationNormal(String strDurationNormal) 標準活動期間を設定します。
void | setDurationNormalFc(String strDurationNormalFc) 標準活動期間 (予測)を設定します。
void | setDurationNormalFcUnit(String strDurationNormalFcUnit) 標準予測期間の単位を設定します。
void | setDurationNormalFcUnitIso(String strDurationNormalFcUnitIso) 単位の ISO コードを設定します。
void | setDurationNormalUnit(String strDurationNormalUnit) 標準期間/単位を設定します。
void | setDurationNormalUnitIso(String strDurationNormalUnitIso) 単位の ISO コードを設定します。
void | setDurationScheduled(String strDurationScheduled) 処理時間を設定します。
void | setDurationScheduledFc(String strDurationScheduledFc) 処理時間の長さ (予測値)を設定します。
void | setDurationScheduledUnit(String strDurationScheduledUnit) 処理時間単位を設定します。
void | setDurationScheduledUnitIso(String strDurationScheduledUnitIso) 単位の ISO コードを設定します。
void | setEarlyFinishDate(String strEarlyFinishDate) 最早計画終了: 実行 (日)を設定します。
void | setEarlyFinishDateFc(String strEarlyFinishDateFc) 最早計画終了日 (予測)を設定します。
void | setEarlyFinishTime(String strEarlyFinishTime) 最早計画終了: 実行 (時刻)を設定します。
void | setEarlyFinishTimeFc(String strEarlyFinishTimeFc) 最早計画終了時間(需要予測)を設定します。
void | setEarlyStartDate(String strEarlyStartDate) 最早計画開始: 実行 (日)を設定します。
void | setEarlyStartDateFc(String strEarlyStartDateFc) 最早計画開始日付(需要予測)を設定します。
void | setEarlyStartTime(String strEarlyStartTime) 最早計画開始: 作業実施(時間)を設定します。
void | setEarlyStartTimeFc(String strEarlyStartTimeFc) 最早計画開始時間(需要予測)を設定します。
void | setFactoryCalendar(String strFactoryCalendar) 稼働日カレンダを設定します。
void | setFlexibleDuration(String strFlexibleDuration) 区分: 可変期間を設定します。
void | setFloatFree(String strFloatFree) 自由余裕を設定します。
void | setFloatFreeFc(String strFloatFreeFc) 自由余裕 (予測)を設定します。
void | setFloatTotal(String strFloatTotal) 余裕合計を設定します。
void | setFloatTotalFc(String strFloatTotalFc) 余裕合計 (予測)を設定します。
void | setForecastFinishDate(String strForecastFinishDate) 予測終了日を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setInfoRec(String strInfoRec) 購買情報番号を設定します。
void | setLatestFinishDate(String strLatestFinishDate) 計画最遅終了: 作業(日付)を設定します。
void | setLatestFinishDateFc(String strLatestFinishDateFc) 最遅計画済終了日付(需要予測)を設定します。
void | setLatestFinishTime(String strLatestFinishTime) 計画最遅終了: 作業(時間)を設定します。
void | setLatestFinishTimeFc(String strLatestFinishTimeFc) 最遅計画終了時間 (予測)を設定します。
void | setLatestStartDate(String strLatestStartDate) 計画最遅開始: 作業(日付)を設定します。
void | setLatestStartDateFc(String strLatestStartDateFc) 最遅計画済開始日付(需要予測)を設定します。
void | setLatestStartTime(String strLatestStartTime) 計画最遅開始: 作業(時間)を設定します。
void | setLatestStartTimeFc(String strLatestStartTimeFc) 最遅計画済開始時間(需要予測)を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setMilestone(String strMilestone) 用途を設定します。
void | setNetwork(String strNetwork) ネットワーク番号を設定します。
void | setNotMrpApplicable(String strNotMrpApplicable) 区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。
void | setNumberOfCapacities(String strNumberOfCapacities) 所要能力数を設定します。
void | setObjectclass(String strObjectclass) オブジェクトクラス (言語非依存)を設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setOperationMeasureUnit(String strOperationMeasureUnit) 活動単位を設定します。
void | setOperationMeasureUnitIso(String strOperationMeasureUnitIso) 単位の ISO コードを設定します。
void | setPercentOfWork(String strPercentOfWork) 作業の比率 (%)を設定します。
void | setPlannedCost(String strPlannedCost) 計画原価を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPlndDelry(String strPlndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPrice(String strPrice) 価格を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setPriority(String strPriority) 優先度を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjectSummarization(String strProjectSummarization) 区分: プロジェクト集計用に活動を考慮を設定します。
void | setPurchOrg(String strPurchOrg) 購買組織を設定します。
void | setPurGroup(String strPurGroup) 購買グループを設定します。
void | setReferencePoint(String strReferencePoint) BOM 転送の参照ポイントを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnWork(String strUnWork) 作業単位を設定します。
void | setUnWorkIso(String strUnWorkIso) 単位の ISO コードを設定します。
void | setUserFieldChar10_1(String strUserFieldChar101) ユーザ定義項目 (10 文字)を設定します。
void | setUserFieldChar10_2(String strUserFieldChar102) ユーザ定義項目 (10 文字)を設定します。
void | setUserFieldChar20_1(String strUserFieldChar201) 20 文字のユーザ項目を設定します。
void | setUserFieldChar20_2(String strUserFieldChar202) 20 文字のユーザ項目を設定します。
void | setUserFieldCuky1(String strUserFieldCuky1) ユーザ項目: 値項目の単位を設定します。
void | setUserFieldCuky1Iso(String strUserFieldCuky1Iso) ISO 通貨コードを設定します。
void | setUserFieldCuky2(String strUserFieldCuky2) ユーザ項目: 値項目の単位を設定します。
void | setUserFieldCuky2Iso(String strUserFieldCuky2Iso) ISO 通貨コードを設定します。
void | setUserFieldCurr1(String strUserFieldCurr1) 値のユーザ定義項目 (長さ 10,3)を設定します。
void | setUserFieldCurr2(String strUserFieldCurr2) 値のユーザ定義項目 (長さ 10,3)を設定します。
void | setUserFieldDate1(String strUserFieldDate1) 日付のユーザ項目を設定します。
void | setUserFieldDate2(String strUserFieldDate2) 日付のユーザ項目を設定します。
void | setUserFieldFlag1(String strUserFieldFlag1) ユーザ定義項目: レポート区分を設定します。
void | setUserFieldFlag2(String strUserFieldFlag2) ユーザ定義項目: レポート区分を設定します。
void | setUserFieldKey(String strUserFieldKey) ユーザ定義項目のキーワード IDを設定します。
void | setUserFieldQuan1(String strUserFieldQuan1) 数量のユーザ項目 (長さ 10,3)を設定します。
void | setUserFieldQuan2(String strUserFieldQuan2) 数量のユーザ項目 (長さ 10,3)を設定します。
void | setUserFieldUnit1(String strUserFieldUnit1) ユーザ項目: 数量項目の単位を設定します。
void | setUserFieldUnit1Iso(String strUserFieldUnit1Iso) 単位の ISO コードを設定します。
void | setUserFieldUnit2(String strUserFieldUnit2) ユーザ項目: 数量項目の単位を設定します。
void | setUserFieldUnit2Iso(String strUserFieldUnit2Iso) 単位の ISO コードを設定します。
void | setVendorNo(String strVendorNo) 仕入先または債権者の勘定コードを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
void | setWorkActivity(String strWorkActivity) 活動に含まれる作業を設定します。
void | setWorkActual(String strWorkActual) 実績作業を設定します。
void | setWorkCntr(String strWorkCntr) 作業区を設定します。
void | setWorkForecast(String strWorkForecast) 予測作業 (実績 + 残存)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpActivity

public ExpActivity()
活動に関する詳細情報を作成します。

メソッドの詳細

getNetwork

public String getNetwork()
ネットワーク番号を取得します。

戻り値:
srtNetwork ネットワーク番号

getActivity

public String getActivity()
ネットワーク/標準ネットワークの活動番号を取得します。

戻り値:
srtActivity ネットワーク/標準ネットワークの活動番号

getControlKey

public String getControlKey()
管理キーを取得します。

戻り値:
srtControlKey 管理キー

getWorkCntr

public String getWorkCntr()
作業区を取得します。

戻り値:
srtWorkCntr 作業区

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getDescription

public String getDescription()
作業テキスト (短)を取得します。

戻り値:
srtDescription 作業テキスト (短)

getVendorNo

public String getVendorNo()
仕入先または債権者の勘定コードを取得します。

戻り値:
srtVendorNo 仕入先または債権者の勘定コード

getPrice

public String getPrice()
価格を取得します。

戻り値:
srtPrice 価格

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
srtPriceUnit 価格単位

getCostElem

public String getCostElem()
原価要素を取得します。

戻り値:
srtCostElem 原価要素

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtCurrencyIso ISO 通貨コード

getInfoRec

public String getInfoRec()
購買情報番号を取得します。

戻り値:
srtInfoRec 購買情報番号

getPurchOrg

public String getPurchOrg()
購買組織を取得します。

戻り値:
srtPurchOrg 購買組織

getPurGroup

public String getPurGroup()
購買グループを取得します。

戻り値:
srtPurGroup 購買グループ

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getFlexibleDuration

public String getFlexibleDuration()
区分: 可変期間を取得します。

戻り値:
srtFlexibleDuration 区分: 可変期間

getNumberOfCapacities

public String getNumberOfCapacities()
所要能力数を取得します。

戻り値:
srtNumberOfCapacities 所要能力数

getPercentOfWork

public String getPercentOfWork()
作業の比率 (%)を取得します。

戻り値:
srtPercentOfWork 作業の比率 (%)

getMilestone

public String getMilestone()
用途を取得します。

戻り値:
srtMilestone 用途

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
srtActtype 活動タイプ

getActivityCosts

public String getActivityCosts()
活動の原価を取得します。

戻り値:
srtActivityCosts 活動の原価

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getFactoryCalendar

public String getFactoryCalendar()
稼働日カレンダを取得します。

戻り値:
srtFactoryCalendar 稼働日カレンダ

getDistributingKey

public String getDistributingKey()
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。

戻り値:
srtDistributingKey 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

getPriority

public String getPriority()
優先度を取得します。

戻り値:
srtPriority 優先度

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getObjectclass

public String getObjectclass()
オブジェクトクラス (言語非依存)を取得します。

戻り値:
srtObjectclass オブジェクトクラス (言語非依存)

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getNotMrpApplicable

public String getNotMrpApplicable()
区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。

戻り値:
srtNotMrpApplicable 区分: MRP への入出庫予定の適用不可と購買依頼未登録

getProjectSummarization

public String getProjectSummarization()
区分: プロジェクト集計用に活動を考慮を取得します。

戻り値:
srtProjectSummarization 区分: プロジェクト集計用に活動を考慮

getOperationMeasureUnit

public String getOperationMeasureUnit()
活動単位を取得します。

戻り値:
srtOperationMeasureUnit 活動単位

getOperationMeasureUnitIso

public String getOperationMeasureUnitIso()
単位の ISO コードを取得します。

戻り値:
srtOperationMeasureUnitIso 単位の ISO コード

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
srtPlndDelry 予定納入時間 (単位: 日)

getDurationNormal

public String getDurationNormal()
標準活動期間を取得します。

戻り値:
srtDurationNormal 標準活動期間

getDurationNormalUnit

public String getDurationNormalUnit()
標準期間/単位を取得します。

戻り値:
srtDurationNormalUnit 標準期間/単位

getDurationNormalUnitIso

public String getDurationNormalUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationNormalUnitIso 単位の ISO コード

getDurationMinimum

public String getDurationMinimum()
最短活動期間を取得します。

戻り値:
srtDurationMinimum 最短活動期間

getDurationMinimumUnit

public String getDurationMinimumUnit()
最短期間の単位を取得します。

戻り値:
srtDurationMinimumUnit 最短期間の単位

getDurationMinimumUnitIso

public String getDurationMinimumUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationMinimumUnitIso 単位の ISO コード

getConstraintTypeStart

public String getConstraintTypeStart()
活動の基準開始日に対する制約を取得します。

戻り値:
srtConstraintTypeStart 活動の基準開始日に対する制約

getConstraintTypeFinish

public String getConstraintTypeFinish()
活動の終了日に対する制約を取得します。

戻り値:
srtConstraintTypeFinish 活動の終了日に対する制約

getWorkActivity

public String getWorkActivity()
活動に含まれる作業を取得します。

戻り値:
srtWorkActivity 活動に含まれる作業

getUnWork

public String getUnWork()
作業単位を取得します。

戻り値:
srtUnWork 作業単位

getUnWorkIso

public String getUnWorkIso()
単位の ISO コードを取得します。

戻り値:
srtUnWorkIso 単位の ISO コード

getEarlyStartDate

public String getEarlyStartDate()
最早計画開始: 実行 (日)を取得します。

戻り値:
srtEarlyStartDate 最早計画開始: 実行 (日)

getEarlyStartTime

public String getEarlyStartTime()
最早計画開始: 作業実施(時間)を取得します。

戻り値:
srtEarlyStartTime 最早計画開始: 作業実施(時間)

getEarlyFinishDate

public String getEarlyFinishDate()
最早計画終了: 実行 (日)を取得します。

戻り値:
srtEarlyFinishDate 最早計画終了: 実行 (日)

getEarlyFinishTime

public String getEarlyFinishTime()
最早計画終了: 実行 (時刻)を取得します。

戻り値:
srtEarlyFinishTime 最早計画終了: 実行 (時刻)

getLatestStartDate

public String getLatestStartDate()
計画最遅開始: 作業(日付)を取得します。

戻り値:
srtLatestStartDate 計画最遅開始: 作業(日付)

getLatestStartTime

public String getLatestStartTime()
計画最遅開始: 作業(時間)を取得します。

戻り値:
srtLatestStartTime 計画最遅開始: 作業(時間)

getLatestFinishDate

public String getLatestFinishDate()
計画最遅終了: 作業(日付)を取得します。

戻り値:
srtLatestFinishDate 計画最遅終了: 作業(日付)

getLatestFinishTime

public String getLatestFinishTime()
計画最遅終了: 作業(時間)を取得します。

戻り値:
srtLatestFinishTime 計画最遅終了: 作業(時間)

getFloatFree

public String getFloatFree()
自由余裕を取得します。

戻り値:
srtFloatFree 自由余裕

getFloatTotal

public String getFloatTotal()
余裕合計を取得します。

戻り値:
srtFloatTotal 余裕合計

getConstraintStartDate

public String getConstraintStartDate()
活動の基準開始日に対する制約を取得します。

戻り値:
srtConstraintStartDate 活動の基準開始日に対する制約

getConstraintStartTime

public String getConstraintStartTime()
活動の基準開始時間の制約を取得します。

戻り値:
srtConstraintStartTime 活動の基準開始時間の制約

getConstraintFinishDate

public String getConstraintFinishDate()
活動の基準終了日に対する制約を取得します。

戻り値:
srtConstraintFinishDate 活動の基準終了日に対する制約

getConstraintFinishTime

public String getConstraintFinishTime()
活動の基準終了時間を取得します。

戻り値:
srtConstraintFinishTime 活動の基準終了時間

getUserFieldKey

public String getUserFieldKey()
ユーザ定義項目のキーワード IDを取得します。

戻り値:
srtUserFieldKey ユーザ定義項目のキーワード ID

getUserFieldChar20_1

public String getUserFieldChar20_1()
20 文字のユーザ項目を取得します。

戻り値:
srtUserFieldChar201 20 文字のユーザ項目

getUserFieldChar20_2

public String getUserFieldChar20_2()
20 文字のユーザ項目を取得します。

戻り値:
srtUserFieldChar202 20 文字のユーザ項目

getUserFieldChar10_1

public String getUserFieldChar10_1()
ユーザ定義項目 (10 文字)を取得します。

戻り値:
srtUserFieldChar101 ユーザ定義項目 (10 文字)

getUserFieldChar10_2

public String getUserFieldChar10_2()
ユーザ定義項目 (10 文字)を取得します。

戻り値:
srtUserFieldChar102 ユーザ定義項目 (10 文字)

getUserFieldQuan1

public String getUserFieldQuan1()
数量のユーザ項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldQuan1 数量のユーザ項目 (長さ 10,3)

getUserFieldUnit1

public String getUserFieldUnit1()
ユーザ項目: 数量項目の単位を取得します。

戻り値:
srtUserFieldUnit1 ユーザ項目: 数量項目の単位

getUserFieldUnit1Iso

public String getUserFieldUnit1Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit1Iso 単位の ISO コード

getUserFieldQuan2

public String getUserFieldQuan2()
数量のユーザ項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldQuan2 数量のユーザ項目 (長さ 10,3)

getUserFieldUnit2

public String getUserFieldUnit2()
ユーザ項目: 数量項目の単位を取得します。

戻り値:
srtUserFieldUnit2 ユーザ項目: 数量項目の単位

getUserFieldUnit2Iso

public String getUserFieldUnit2Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit2Iso 単位の ISO コード

getUserFieldCurr1

public String getUserFieldCurr1()
値のユーザ定義項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldCurr1 値のユーザ定義項目 (長さ 10,3)

getUserFieldCuky1

public String getUserFieldCuky1()
ユーザ項目: 値項目の単位を取得します。

戻り値:
srtUserFieldCuky1 ユーザ項目: 値項目の単位

getUserFieldCuky1Iso

public String getUserFieldCuky1Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky1Iso ISO 通貨コード

getUserFieldCurr2

public String getUserFieldCurr2()
値のユーザ定義項目 (長さ 10,3)を取得します。

戻り値:
srtUserFieldCurr2 値のユーザ定義項目 (長さ 10,3)

getUserFieldCuky2

public String getUserFieldCuky2()
ユーザ項目: 値項目の単位を取得します。

戻り値:
srtUserFieldCuky2 ユーザ項目: 値項目の単位

getUserFieldCuky2Iso

public String getUserFieldCuky2Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky2Iso ISO 通貨コード

getUserFieldDate1

public String getUserFieldDate1()
日付のユーザ項目を取得します。

戻り値:
srtUserFieldDate1 日付のユーザ項目

getUserFieldDate2

public String getUserFieldDate2()
日付のユーザ項目を取得します。

戻り値:
srtUserFieldDate2 日付のユーザ項目

getUserFieldFlag1

public String getUserFieldFlag1()
ユーザ定義項目: レポート区分を取得します。

戻り値:
srtUserFieldFlag1 ユーザ定義項目: レポート区分

getUserFieldFlag2

public String getUserFieldFlag2()
ユーザ定義項目: レポート区分を取得します。

戻り値:
srtUserFieldFlag2 ユーザ定義項目: レポート区分

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getDurationNormalFc

public String getDurationNormalFc()
標準活動期間 (予測)を取得します。

戻り値:
srtDurationNormalFc 標準活動期間 (予測)

getDurationNormalFcUnit

public String getDurationNormalFcUnit()
標準予測期間の単位を取得します。

戻り値:
srtDurationNormalFcUnit 標準予測期間の単位

getDurationNormalFcUnitIso

public String getDurationNormalFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationNormalFcUnitIso 単位の ISO コード

getDurationMinimumFc

public String getDurationMinimumFc()
活動の最小期間(需要予測より)を取得します。

戻り値:
srtDurationMinimumFc 活動の最小期間(需要予測より)

getDurationMinimumFcUnit

public String getDurationMinimumFcUnit()
予測最短期間の単位を取得します。

戻り値:
srtDurationMinimumFcUnit 予測最短期間の単位

getDurationMinimumFcUnitIso

public String getDurationMinimumFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationMinimumFcUnitIso 単位の ISO コード

getConstraintTypeFinishFc

public String getConstraintTypeFinishFc()
活動終了の制約条件付き需要予測日付を取得します。

戻り値:
srtConstraintTypeFinishFc 活動終了の制約条件付き需要予測日付

getConstraintTypeStartFc

public String getConstraintTypeStartFc()
活動開始の制約条件付き需要予測日付を取得します。

戻り値:
srtConstraintTypeStartFc 活動開始の制約条件付き需要予測日付

getConstraintStartDateFc

public String getConstraintStartDateFc()
活動の予測開始日を取得します。

戻り値:
srtConstraintStartDateFc 活動の予測開始日

getConstraintStartTimeFc

public String getConstraintStartTimeFc()
活動の需要予測開始時間を取得します。

戻り値:
srtConstraintStartTimeFc 活動の需要予測開始時間

getConstraintFinishDateFc

public String getConstraintFinishDateFc()
予測終了日付を取得します。

戻り値:
srtConstraintFinishDateFc 予測終了日付

getConstraintFinishTimeFc

public String getConstraintFinishTimeFc()
活動の予測終了時間を取得します。

戻り値:
srtConstraintFinishTimeFc 活動の予測終了時間

getEarlyStartDateFc

public String getEarlyStartDateFc()
最早計画開始日付(需要予測)を取得します。

戻り値:
srtEarlyStartDateFc 最早計画開始日付(需要予測)

getEarlyStartTimeFc

public String getEarlyStartTimeFc()
最早計画開始時間(需要予測)を取得します。

戻り値:
srtEarlyStartTimeFc 最早計画開始時間(需要予測)

getEarlyFinishDateFc

public String getEarlyFinishDateFc()
最早計画終了日 (予測)を取得します。

戻り値:
srtEarlyFinishDateFc 最早計画終了日 (予測)

getEarlyFinishTimeFc

public String getEarlyFinishTimeFc()
最早計画終了時間(需要予測)を取得します。

戻り値:
srtEarlyFinishTimeFc 最早計画終了時間(需要予測)

getLatestStartDateFc

public String getLatestStartDateFc()
最遅計画済開始日付(需要予測)を取得します。

戻り値:
srtLatestStartDateFc 最遅計画済開始日付(需要予測)

getLatestStartTimeFc

public String getLatestStartTimeFc()
最遅計画済開始時間(需要予測)を取得します。

戻り値:
srtLatestStartTimeFc 最遅計画済開始時間(需要予測)

getLatestFinishDateFc

public String getLatestFinishDateFc()
最遅計画済終了日付(需要予測)を取得します。

戻り値:
srtLatestFinishDateFc 最遅計画済終了日付(需要予測)

getLatestFinishTimeFc

public String getLatestFinishTimeFc()
最遅計画終了時間 (予測)を取得します。

戻り値:
srtLatestFinishTimeFc 最遅計画終了時間 (予測)

getFloatFreeFc

public String getFloatFreeFc()
自由余裕 (予測)を取得します。

戻り値:
srtFloatFreeFc 自由余裕 (予測)

getFloatTotalFc

public String getFloatTotalFc()
余裕合計 (予測)を取得します。

戻り値:
srtFloatTotalFc 余裕合計 (予測)

getWorkForecast

public String getWorkForecast()
予測作業 (実績 + 残存)を取得します。

戻り値:
srtWorkForecast 予測作業 (実績 + 残存)

getWorkActual

public String getWorkActual()
実績作業を取得します。

戻り値:
srtWorkActual 実績作業

getDurationScheduled

public String getDurationScheduled()
処理時間を取得します。

戻り値:
srtDurationScheduled 処理時間

getDurationScheduledFc

public String getDurationScheduledFc()
処理時間の長さ (予測値)を取得します。

戻り値:
srtDurationScheduledFc 処理時間の長さ (予測値)

getDurationScheduledUnit

public String getDurationScheduledUnit()
処理時間単位を取得します。

戻り値:
srtDurationScheduledUnit 処理時間単位

getDurationScheduledUnitIso

public String getDurationScheduledUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationScheduledUnitIso 単位の ISO コード

getDurationConfirmFc

public String getDurationConfirmFc()
確認の予測活動期間を取得します。

戻り値:
srtDurationConfirmFc 確認の予測活動期間

getDurationConfirmFcUnit

public String getDurationConfirmFcUnit()
確認の予測期間単位を取得します。

戻り値:
srtDurationConfirmFcUnit 確認の予測期間単位

getDurationConfirmFcUnitIso

public String getDurationConfirmFcUnitIso()
単位の ISO コードを取得します。

戻り値:
srtDurationConfirmFcUnitIso 単位の ISO コード

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getPlannedCost

public String getPlannedCost()
計画原価を取得します。

戻り値:
srtPlannedCost 計画原価

getActualCost

public String getActualCost()
実際原価を取得します。

戻り値:
srtActualCost 実際原価

getControllingAreaCurrency

public String getControllingAreaCurrency()
通貨コードを取得します。

戻り値:
srtControllingAreaCurrency 通貨コード

getActualStartDate

public String getActualStartDate()
実績開始日: 実行 (日付)を取得します。

戻り値:
srtActualStartDate 実績開始日: 実行 (日付)

getActualFinishDate

public String getActualFinishDate()
実績終了日: 実行 (日付)を取得します。

戻り値:
srtActualFinishDate 実績終了日: 実行 (日付)

getForecastFinishDate

public String getForecastFinishDate()
予測終了日を取得します。

戻り値:
srtForecastFinishDate 予測終了日

getComplete

public String getComplete()
最終確認の有効化を取得します。

戻り値:
srtComplete 最終確認の有効化

getReferencePoint

public String getReferencePoint()
BOM 転送の参照ポイントを取得します。

戻り値:
srtReferencePoint BOM 転送の参照ポイント

setNetwork

public void setNetwork(String strNetwork)
ネットワーク番号を設定します。

パラメータ:
strNetwork - ネットワーク番号

setActivity

public void setActivity(String strActivity)
ネットワーク/標準ネットワークの活動番号を設定します。

パラメータ:
strActivity - ネットワーク/標準ネットワークの活動番号

setControlKey

public void setControlKey(String strControlKey)
管理キーを設定します。

パラメータ:
strControlKey - 管理キー

setWorkCntr

public void setWorkCntr(String strWorkCntr)
作業区を設定します。

パラメータ:
strWorkCntr - 作業区

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setDescription

public void setDescription(String strDescription)
作業テキスト (短)を設定します。

パラメータ:
strDescription - 作業テキスト (短)

setVendorNo

public void setVendorNo(String strVendorNo)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendorNo - 仕入先または債権者の勘定コード

setPrice

public void setPrice(String strPrice)
価格を設定します。

パラメータ:
strPrice - 価格

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setCostElem

public void setCostElem(String strCostElem)
原価要素を設定します。

パラメータ:
strCostElem - 原価要素

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setInfoRec

public void setInfoRec(String strInfoRec)
購買情報番号を設定します。

パラメータ:
strInfoRec - 購買情報番号

setPurchOrg

public void setPurchOrg(String strPurchOrg)
購買組織を設定します。

パラメータ:
strPurchOrg - 購買組織

setPurGroup

public void setPurGroup(String strPurGroup)
購買グループを設定します。

パラメータ:
strPurGroup - 購買グループ

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setFlexibleDuration

public void setFlexibleDuration(String strFlexibleDuration)
区分: 可変期間を設定します。

パラメータ:
strFlexibleDuration - 区分: 可変期間

setNumberOfCapacities

public void setNumberOfCapacities(String strNumberOfCapacities)
所要能力数を設定します。

パラメータ:
strNumberOfCapacities - 所要能力数

setPercentOfWork

public void setPercentOfWork(String strPercentOfWork)
作業の比率 (%)を設定します。

パラメータ:
strPercentOfWork - 作業の比率 (%)

setMilestone

public void setMilestone(String strMilestone)
用途を設定します。

パラメータ:
strMilestone - 用途

setActtype

public void setActtype(String strActtype)
活動タイプを設定します。

パラメータ:
strActtype - 活動タイプ

setActivityCosts

public void setActivityCosts(String strActivityCosts)
活動の原価を設定します。

パラメータ:
strActivityCosts - 活動の原価

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setFactoryCalendar

public void setFactoryCalendar(String strFactoryCalendar)
稼働日カレンダを設定します。

パラメータ:
strFactoryCalendar - 稼働日カレンダ

setDistributingKey

public void setDistributingKey(String strDistributingKey)
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。

パラメータ:
strDistributingKey - 能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

setPriority

public void setPriority(String strPriority)
優先度を設定します。

パラメータ:
strPriority - 優先度

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setObjectclass

public void setObjectclass(String strObjectclass)
オブジェクトクラス (言語非依存)を設定します。

パラメータ:
strObjectclass - オブジェクトクラス (言語非依存)

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setNotMrpApplicable

public void setNotMrpApplicable(String strNotMrpApplicable)
区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。

パラメータ:
strNotMrpApplicable - 区分: MRP への入出庫予定の適用不可と購買依頼未登録

setProjectSummarization

public void setProjectSummarization(String strProjectSummarization)
区分: プロジェクト集計用に活動を考慮を設定します。

パラメータ:
strProjectSummarization - 区分: プロジェクト集計用に活動を考慮

setOperationMeasureUnit

public void setOperationMeasureUnit(String strOperationMeasureUnit)
活動単位を設定します。

パラメータ:
strOperationMeasureUnit - 活動単位

setOperationMeasureUnitIso

public void setOperationMeasureUnitIso(String strOperationMeasureUnitIso)
単位の ISO コードを設定します。

パラメータ:
strOperationMeasureUnitIso - 単位の ISO コード

setPlndDelry

public void setPlndDelry(String strPlndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
strPlndDelry - 予定納入時間 (単位: 日)

setDurationNormal

public void setDurationNormal(String strDurationNormal)
標準活動期間を設定します。

パラメータ:
strDurationNormal - 標準活動期間

setDurationNormalUnit

public void setDurationNormalUnit(String strDurationNormalUnit)
標準期間/単位を設定します。

パラメータ:
strDurationNormalUnit - 標準期間/単位

setDurationNormalUnitIso

public void setDurationNormalUnitIso(String strDurationNormalUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationNormalUnitIso - 単位の ISO コード

setDurationMinimum

public void setDurationMinimum(String strDurationMinimum)
最短活動期間を設定します。

パラメータ:
strDurationMinimum - 最短活動期間

setDurationMinimumUnit

public void setDurationMinimumUnit(String strDurationMinimumUnit)
最短期間の単位を設定します。

パラメータ:
strDurationMinimumUnit - 最短期間の単位

setDurationMinimumUnitIso

public void setDurationMinimumUnitIso(String strDurationMinimumUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationMinimumUnitIso - 単位の ISO コード

setConstraintTypeStart

public void setConstraintTypeStart(String strConstraintTypeStart)
活動の基準開始日に対する制約を設定します。

パラメータ:
strConstraintTypeStart - 活動の基準開始日に対する制約

setConstraintTypeFinish

public void setConstraintTypeFinish(String strConstraintTypeFinish)
活動の終了日に対する制約を設定します。

パラメータ:
strConstraintTypeFinish - 活動の終了日に対する制約

setWorkActivity

public void setWorkActivity(String strWorkActivity)
活動に含まれる作業を設定します。

パラメータ:
strWorkActivity - 活動に含まれる作業

setUnWork

public void setUnWork(String strUnWork)
作業単位を設定します。

パラメータ:
strUnWork - 作業単位

setUnWorkIso

public void setUnWorkIso(String strUnWorkIso)
単位の ISO コードを設定します。

パラメータ:
strUnWorkIso - 単位の ISO コード

setEarlyStartDate

public void setEarlyStartDate(String strEarlyStartDate)
最早計画開始: 実行 (日)を設定します。

パラメータ:
strEarlyStartDate - 最早計画開始: 実行 (日)

setEarlyStartTime

public void setEarlyStartTime(String strEarlyStartTime)
最早計画開始: 作業実施(時間)を設定します。

パラメータ:
strEarlyStartTime - 最早計画開始: 作業実施(時間)

setEarlyFinishDate

public void setEarlyFinishDate(String strEarlyFinishDate)
最早計画終了: 実行 (日)を設定します。

パラメータ:
strEarlyFinishDate - 最早計画終了: 実行 (日)

setEarlyFinishTime

public void setEarlyFinishTime(String strEarlyFinishTime)
最早計画終了: 実行 (時刻)を設定します。

パラメータ:
strEarlyFinishTime - 最早計画終了: 実行 (時刻)

setLatestStartDate

public void setLatestStartDate(String strLatestStartDate)
計画最遅開始: 作業(日付)を設定します。

パラメータ:
strLatestStartDate - 計画最遅開始: 作業(日付)

setLatestStartTime

public void setLatestStartTime(String strLatestStartTime)
計画最遅開始: 作業(時間)を設定します。

パラメータ:
strLatestStartTime - 計画最遅開始: 作業(時間)

setLatestFinishDate

public void setLatestFinishDate(String strLatestFinishDate)
計画最遅終了: 作業(日付)を設定します。

パラメータ:
strLatestFinishDate - 計画最遅終了: 作業(日付)

setLatestFinishTime

public void setLatestFinishTime(String strLatestFinishTime)
計画最遅終了: 作業(時間)を設定します。

パラメータ:
strLatestFinishTime - 計画最遅終了: 作業(時間)

setFloatFree

public void setFloatFree(String strFloatFree)
自由余裕を設定します。

パラメータ:
strFloatFree - 自由余裕

setFloatTotal

public void setFloatTotal(String strFloatTotal)
余裕合計を設定します。

パラメータ:
strFloatTotal - 余裕合計

setConstraintStartDate

public void setConstraintStartDate(String strConstraintStartDate)
活動の基準開始日に対する制約を設定します。

パラメータ:
strConstraintStartDate - 活動の基準開始日に対する制約

setConstraintStartTime

public void setConstraintStartTime(String strConstraintStartTime)
活動の基準開始時間の制約を設定します。

パラメータ:
strConstraintStartTime - 活動の基準開始時間の制約

setConstraintFinishDate

public void setConstraintFinishDate(String strConstraintFinishDate)
活動の基準終了日に対する制約を設定します。

パラメータ:
strConstraintFinishDate - 活動の基準終了日に対する制約

setConstraintFinishTime

public void setConstraintFinishTime(String strConstraintFinishTime)
活動の基準終了時間を設定します。

パラメータ:
strConstraintFinishTime - 活動の基準終了時間

setUserFieldKey

public void setUserFieldKey(String strUserFieldKey)
ユーザ定義項目のキーワード IDを設定します。

パラメータ:
strUserFieldKey - ユーザ定義項目のキーワード ID

setUserFieldChar20_1

public void setUserFieldChar20_1(String strUserFieldChar201)
20 文字のユーザ項目を設定します。

パラメータ:
strUserFieldChar201 - 20 文字のユーザ項目

setUserFieldChar20_2

public void setUserFieldChar20_2(String strUserFieldChar202)
20 文字のユーザ項目を設定します。

パラメータ:
strUserFieldChar202 - 20 文字のユーザ項目

setUserFieldChar10_1

public void setUserFieldChar10_1(String strUserFieldChar101)
ユーザ定義項目 (10 文字)を設定します。

パラメータ:
strUserFieldChar101 - ユーザ定義項目 (10 文字)

setUserFieldChar10_2

public void setUserFieldChar10_2(String strUserFieldChar102)
ユーザ定義項目 (10 文字)を設定します。

パラメータ:
strUserFieldChar102 - ユーザ定義項目 (10 文字)

setUserFieldQuan1

public void setUserFieldQuan1(String strUserFieldQuan1)
数量のユーザ項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldQuan1 - 数量のユーザ項目 (長さ 10,3)

setUserFieldUnit1

public void setUserFieldUnit1(String strUserFieldUnit1)
ユーザ項目: 数量項目の単位を設定します。

パラメータ:
strUserFieldUnit1 - ユーザ項目: 数量項目の単位

setUserFieldUnit1Iso

public void setUserFieldUnit1Iso(String strUserFieldUnit1Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit1Iso - 単位の ISO コード

setUserFieldQuan2

public void setUserFieldQuan2(String strUserFieldQuan2)
数量のユーザ項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldQuan2 - 数量のユーザ項目 (長さ 10,3)

setUserFieldUnit2

public void setUserFieldUnit2(String strUserFieldUnit2)
ユーザ項目: 数量項目の単位を設定します。

パラメータ:
strUserFieldUnit2 - ユーザ項目: 数量項目の単位

setUserFieldUnit2Iso

public void setUserFieldUnit2Iso(String strUserFieldUnit2Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit2Iso - 単位の ISO コード

setUserFieldCurr1

public void setUserFieldCurr1(String strUserFieldCurr1)
値のユーザ定義項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldCurr1 - 値のユーザ定義項目 (長さ 10,3)

setUserFieldCuky1

public void setUserFieldCuky1(String strUserFieldCuky1)
ユーザ項目: 値項目の単位を設定します。

パラメータ:
strUserFieldCuky1 - ユーザ項目: 値項目の単位

setUserFieldCuky1Iso

public void setUserFieldCuky1Iso(String strUserFieldCuky1Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky1Iso - ISO 通貨コード

setUserFieldCurr2

public void setUserFieldCurr2(String strUserFieldCurr2)
値のユーザ定義項目 (長さ 10,3)を設定します。

パラメータ:
strUserFieldCurr2 - 値のユーザ定義項目 (長さ 10,3)

setUserFieldCuky2

public void setUserFieldCuky2(String strUserFieldCuky2)
ユーザ項目: 値項目の単位を設定します。

パラメータ:
strUserFieldCuky2 - ユーザ項目: 値項目の単位

setUserFieldCuky2Iso

public void setUserFieldCuky2Iso(String strUserFieldCuky2Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky2Iso - ISO 通貨コード

setUserFieldDate1

public void setUserFieldDate1(String strUserFieldDate1)
日付のユーザ項目を設定します。

パラメータ:
strUserFieldDate1 - 日付のユーザ項目

setUserFieldDate2

public void setUserFieldDate2(String strUserFieldDate2)
日付のユーザ項目を設定します。

パラメータ:
strUserFieldDate2 - 日付のユーザ項目

setUserFieldFlag1

public void setUserFieldFlag1(String strUserFieldFlag1)
ユーザ定義項目: レポート区分を設定します。

パラメータ:
strUserFieldFlag1 - ユーザ定義項目: レポート区分

setUserFieldFlag2

public void setUserFieldFlag2(String strUserFieldFlag2)
ユーザ定義項目: レポート区分を設定します。

パラメータ:
strUserFieldFlag2 - ユーザ定義項目: レポート区分

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setDurationNormalFc

public void setDurationNormalFc(String strDurationNormalFc)
標準活動期間 (予測)を設定します。

パラメータ:
strDurationNormalFc - 標準活動期間 (予測)

setDurationNormalFcUnit

public void setDurationNormalFcUnit(String strDurationNormalFcUnit)
標準予測期間の単位を設定します。

パラメータ:
strDurationNormalFcUnit - 標準予測期間の単位

setDurationNormalFcUnitIso

public void setDurationNormalFcUnitIso(String strDurationNormalFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationNormalFcUnitIso - 単位の ISO コード

setDurationMinimumFc

public void setDurationMinimumFc(String strDurationMinimumFc)
活動の最小期間(需要予測より)を設定します。

パラメータ:
strDurationMinimumFc - 活動の最小期間(需要予測より)

setDurationMinimumFcUnit

public void setDurationMinimumFcUnit(String strDurationMinimumFcUnit)
予測最短期間の単位を設定します。

パラメータ:
strDurationMinimumFcUnit - 予測最短期間の単位

setDurationMinimumFcUnitIso

public void setDurationMinimumFcUnitIso(String strDurationMinimumFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationMinimumFcUnitIso - 単位の ISO コード

setConstraintTypeFinishFc

public void setConstraintTypeFinishFc(String strConstraintTypeFinishFc)
活動終了の制約条件付き需要予測日付を設定します。

パラメータ:
strConstraintTypeFinishFc - 活動終了の制約条件付き需要予測日付

setConstraintTypeStartFc

public void setConstraintTypeStartFc(String strConstraintTypeStartFc)
活動開始の制約条件付き需要予測日付を設定します。

パラメータ:
strConstraintTypeStartFc - 活動開始の制約条件付き需要予測日付

setConstraintStartDateFc

public void setConstraintStartDateFc(String strConstraintStartDateFc)
活動の予測開始日を設定します。

パラメータ:
strConstraintStartDateFc - 活動の予測開始日

setConstraintStartTimeFc

public void setConstraintStartTimeFc(String strConstraintStartTimeFc)
活動の需要予測開始時間を設定します。

パラメータ:
strConstraintStartTimeFc - 活動の需要予測開始時間

setConstraintFinishDateFc

public void setConstraintFinishDateFc(String strConstraintFinishDateFc)
予測終了日付を設定します。

パラメータ:
strConstraintFinishDateFc - 予測終了日付

setConstraintFinishTimeFc

public void setConstraintFinishTimeFc(String strConstraintFinishTimeFc)
活動の予測終了時間を設定します。

パラメータ:
strConstraintFinishTimeFc - 活動の予測終了時間

setEarlyStartDateFc

public void setEarlyStartDateFc(String strEarlyStartDateFc)
最早計画開始日付(需要予測)を設定します。

パラメータ:
strEarlyStartDateFc - 最早計画開始日付(需要予測)

setEarlyStartTimeFc

public void setEarlyStartTimeFc(String strEarlyStartTimeFc)
最早計画開始時間(需要予測)を設定します。

パラメータ:
strEarlyStartTimeFc - 最早計画開始時間(需要予測)

setEarlyFinishDateFc

public void setEarlyFinishDateFc(String strEarlyFinishDateFc)
最早計画終了日 (予測)を設定します。

パラメータ:
strEarlyFinishDateFc - 最早計画終了日 (予測)

setEarlyFinishTimeFc

public void setEarlyFinishTimeFc(String strEarlyFinishTimeFc)
最早計画終了時間(需要予測)を設定します。

パラメータ:
strEarlyFinishTimeFc - 最早計画終了時間(需要予測)

setLatestStartDateFc

public void setLatestStartDateFc(String strLatestStartDateFc)
最遅計画済開始日付(需要予測)を設定します。

パラメータ:
strLatestStartDateFc - 最遅計画済開始日付(需要予測)

setLatestStartTimeFc

public void setLatestStartTimeFc(String strLatestStartTimeFc)
最遅計画済開始時間(需要予測)を設定します。

パラメータ:
strLatestStartTimeFc - 最遅計画済開始時間(需要予測)

setLatestFinishDateFc

public void setLatestFinishDateFc(String strLatestFinishDateFc)
最遅計画済終了日付(需要予測)を設定します。

パラメータ:
strLatestFinishDateFc - 最遅計画済終了日付(需要予測)

setLatestFinishTimeFc

public void setLatestFinishTimeFc(String strLatestFinishTimeFc)
最遅計画終了時間 (予測)を設定します。

パラメータ:
strLatestFinishTimeFc - 最遅計画終了時間 (予測)

setFloatFreeFc

public void setFloatFreeFc(String strFloatFreeFc)
自由余裕 (予測)を設定します。

パラメータ:
strFloatFreeFc - 自由余裕 (予測)

setFloatTotalFc

public void setFloatTotalFc(String strFloatTotalFc)
余裕合計 (予測)を設定します。

パラメータ:
strFloatTotalFc - 余裕合計 (予測)

setWorkForecast

public void setWorkForecast(String strWorkForecast)
予測作業 (実績 + 残存)を設定します。

パラメータ:
strWorkForecast - 予測作業 (実績 + 残存)

setWorkActual

public void setWorkActual(String strWorkActual)
実績作業を設定します。

パラメータ:
strWorkActual - 実績作業

setDurationScheduled

public void setDurationScheduled(String strDurationScheduled)
処理時間を設定します。

パラメータ:
strDurationScheduled - 処理時間

setDurationScheduledFc

public void setDurationScheduledFc(String strDurationScheduledFc)
処理時間の長さ (予測値)を設定します。

パラメータ:
strDurationScheduledFc - 処理時間の長さ (予測値)

setDurationScheduledUnit

public void setDurationScheduledUnit(String strDurationScheduledUnit)
処理時間単位を設定します。

パラメータ:
strDurationScheduledUnit - 処理時間単位

setDurationScheduledUnitIso

public void setDurationScheduledUnitIso(String strDurationScheduledUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationScheduledUnitIso - 単位の ISO コード

setDurationConfirmFc

public void setDurationConfirmFc(String strDurationConfirmFc)
確認の予測活動期間を設定します。

パラメータ:
strDurationConfirmFc - 確認の予測活動期間

setDurationConfirmFcUnit

public void setDurationConfirmFcUnit(String strDurationConfirmFcUnit)
確認の予測期間単位を設定します。

パラメータ:
strDurationConfirmFcUnit - 確認の予測期間単位

setDurationConfirmFcUnitIso

public void setDurationConfirmFcUnitIso(String strDurationConfirmFcUnitIso)
単位の ISO コードを設定します。

パラメータ:
strDurationConfirmFcUnitIso - 単位の ISO コード

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setPlannedCost

public void setPlannedCost(String strPlannedCost)
計画原価を設定します。

パラメータ:
strPlannedCost - 計画原価

setActualCost

public void setActualCost(String strActualCost)
実際原価を設定します。

パラメータ:
strActualCost - 実際原価

setControllingAreaCurrency

public void setControllingAreaCurrency(String strControllingAreaCurrency)
通貨コードを設定します。

パラメータ:
strControllingAreaCurrency - 通貨コード

setActualStartDate

public void setActualStartDate(String strActualStartDate)
実績開始日: 実行 (日付)を設定します。

パラメータ:
strActualStartDate - 実績開始日: 実行 (日付)

setActualFinishDate

public void setActualFinishDate(String strActualFinishDate)
実績終了日: 実行 (日付)を設定します。

パラメータ:
strActualFinishDate - 実績終了日: 実行 (日付)

setForecastFinishDate

public void setForecastFinishDate(String strForecastFinishDate)
予測終了日を設定します。

パラメータ:
strForecastFinishDate - 予測終了日

setComplete

public void setComplete(String strComplete)
最終確認の有効化を設定します。

パラメータ:
strComplete - 最終確認の有効化

setReferencePoint

public void setReferencePoint(String strReferencePoint)
BOM 転送の参照ポイントを設定します。

パラメータ:
strReferencePoint - BOM 転送の参照ポイント

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpMessage (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpMessage

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpMessage
すべての実装インタフェース:
Serializable
public class ExpMessage
extends Object
implements Serializable

詳細情報を読み込みエラー情報クラス 機能は以下の通り

  • 詳細情報を読み込みエラー情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpMessage()
詳細情報を読み込みエラー情報を作成します。
メソッドの概要
String | getExternalObjectId() SAP 外部対象キーを取得します。
String | getInternalObjectId() SAP 内部対象キーを取得します。
String | getMessageId() メッセージ IDを取得します。
String | getMessageNumber() システムメッセージ番号を取得します。
String | getMessageText() メッセージのテキスト行を取得します。
String | getMessageType() メッセージタイプを取得します。
String | getMethod() メソッドを取得します。
String | getObjectType() オブジェクトタイプを取得します。
void | setExternalObjectId(String strExternalObjectId) SAP 外部対象キーを設定します。
void | setInternalObjectId(String strInternalObjectId) SAP 内部対象キーを設定します。
void | setMessageId(String strMessageId) メッセージ IDを設定します。
void | setMessageNumber(String strMessageNumber) システムメッセージ番号を設定します。
void | setMessageText(String strMessageText) メッセージのテキスト行を設定します。
void | setMessageType(String strMessageType) メッセージタイプを設定します。
void | setMethod(String strMethod) メソッドを設定します。
void | setObjectType(String strObjectType) オブジェクトタイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpMessage

public ExpMessage()
詳細情報を読み込みエラー情報を作成します。

メソッドの詳細

getMethod

public String getMethod()
メソッドを取得します。

戻り値:
srtMethod メソッド

getObjectType

public String getObjectType()
オブジェクトタイプを取得します。

戻り値:
srtObjectType オブジェクトタイプ

getInternalObjectId

public String getInternalObjectId()
SAP 内部対象キーを取得します。

戻り値:
srtInternalObjectId SAP 内部対象キー

getExternalObjectId

public String getExternalObjectId()
SAP 外部対象キーを取得します。

戻り値:
srtExternalObjectId SAP 外部対象キー

getMessageId

public String getMessageId()
メッセージ IDを取得します。

戻り値:
srtMessageId メッセージ ID

getMessageNumber

public String getMessageNumber()
システムメッセージ番号を取得します。

戻り値:
srtMessageNumber システムメッセージ番号

getMessageType

public String getMessageType()
メッセージタイプを取得します。

戻り値:
srtMessageType メッセージタイプ

getMessageText

public String getMessageText()
メッセージのテキスト行を取得します。

戻り値:
srtMessageText メッセージのテキスト行

setMethod

public void setMethod(String strMethod)
メソッドを設定します。

パラメータ:
strMethod - メソッド

setObjectType

public void setObjectType(String strObjectType)
オブジェクトタイプを設定します。

パラメータ:
strObjectType - オブジェクトタイプ

setInternalObjectId

public void setInternalObjectId(String strInternalObjectId)
SAP 内部対象キーを設定します。

パラメータ:
strInternalObjectId - SAP 内部対象キー

setExternalObjectId

public void setExternalObjectId(String strExternalObjectId)
SAP 外部対象キーを設定します。

パラメータ:
strExternalObjectId - SAP 外部対象キー

setMessageId

public void setMessageId(String strMessageId)
メッセージ IDを設定します。

パラメータ:
strMessageId - メッセージ ID

setMessageNumber

public void setMessageNumber(String strMessageNumber)
システムメッセージ番号を設定します。

パラメータ:
strMessageNumber - システムメッセージ番号

setMessageType

public void setMessageType(String strMessageType)
メッセージタイプを設定します。

パラメータ:
strMessageType - メッセージタイプ

setMessageText

public void setMessageText(String strMessageText)
メッセージのテキスト行を設定します。

パラメータ:
strMessageText - メッセージのテキスト行

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsElement (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsElement

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement
すべての実装インタフェース:
Serializable
public class ExpWbsElement
extends Object
implements Serializable

WBS 要素についての詳細情報クラス
機能は以下の通り

  • WBS 要素についての詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsElement()
WBS 要素についての詳細情報を作成します。
メソッドの概要
String | getApplicantNo() 申請者番号を取得します。
String | getBusArea() 事業領域を取得します。
String | getCalendar() 稼動日カレンダを取得します。
String | getChangeNo() 変更番号を取得します。
String | getCoArea() 管理領域を取得します。
String | getCompCode() 会社コードを取得します。
String | getCostingSheet() 原価計算表を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() PS: テキスト(短)(第一テキスト行)を取得します。
String | getEquipment() 設備番号を取得します。
String | getEquityType() 持分タイプを取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFunctionalLocation() 機能場所を取得します。
String | getIntProfile() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getInvestProfile() 設備投資案件プロファイルを取得します。
String | getJointVenture() ジョイントベンチャを取得します。
String | getJvJibClass() JIB/JIBE クラスを取得します。
String | getJvJibSubClassA() JIB/JIBE サブクラスAを取得します。
String | getJvObjectType() ジョイントベンチャ対象タイプを取得します。
String | getLocation() 場所を取得します。
String | getNetworkAssignment() ネットワーク割当を取得します。
String | getObjectclass() 対象クラスを取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getOverheadKey() 間接費キーを取得します。
String | getPlant() プラントを取得します。
String | getPriority() 優先度を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjType() プロジェクトタイプを取得します。
String | getRecoveryInd() リカバリフラグを取得します。
String | getRequestCctr() 申請原価センタを取得します。
String | getRequestCctrControllingArea() 依頼原価センタの管理領域を取得します。
String | getRequestCompCode() 会社コード要求を取得します。
String | getResAnalKey() 結果分析キーを取得します。
String | getResponsibleNo() 責任者番号 (プロジェクト責任者)を取得します。
String | getRespsblCctr() 責任原価センタを取得します。
String | getRespsblCctrControllingArea() 責任原価センタの管理領域を取得します。
String | getShortId() WBS 要素 ショート IDを取得します。
String | getStatistical() 統計 WBS 要素を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUserFieldChar10_1() 10 桁の第 3 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldChar10_2() 10 桁の第 4 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldChar20_1() 20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。
String | getUserFieldChar20_2() 20 桁の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldCuky1() 値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldCuky1Iso() ISO 通貨コードを取得します。
String | getUserFieldCuky2() 値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldCuky2Iso() ISO 通貨コードを取得します。
String | getUserFieldCurr1() 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldCurr2() 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldDate1() 日付の第 1 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldDate2() 日付の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldFlag1() '評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldFlag2() '評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。
String | getUserFieldKey() ユーザ定義項目のキーワード IDを取得します。
String | getUserFieldQuan1() 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldQuan2() 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
String | getUserFieldUnit1() 数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldUnit1Iso() 単位の ISO コードを取得します。
String | getUserFieldUnit2() 数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
String | getUserFieldUnit2Iso() 単位の ISO コードを取得します。
String | getWbsAccountAssignmentElement() 区分: 勘定設定要素を取得します。
String | getWbsActualDuration() WBS 要素の実績長(期間)を取得します。
String | getWbsActualDurUnit() 実績 WBS 要素日付の期間単位を取得します。
String | getWbsActualDurUnitIso() 単位の ISO コードを取得します。
String | getWbsActualFinishDate() WBS 要素の実績終了日を取得します。
String | getWbsActualStartDate() WBS 要素の実績開始日付を取得します。
String | getWbsBasicDuration() WBS 要素の基準日の長さ(期間)を取得します。
String | getWbsBasicDurUnit() 基準 WBS 要素日付の期間単位を取得します。
String | getWbsBasicDurUnitIso() 単位の ISO コードを取得します。
String | getWbsBasicFinishDate() WBS 要素: 基本終了日付を取得します。
String | getWbsBasicStartDate() WBS 要素: 基本開始日を取得します。
String | getWbsBillingElement() 区分: 請求要素を取得します。
String | getWbsCctrPostedActual() 原価が実際に転記される原価センタを取得します。
String | getWbsElement() WBS 要素を取得します。
String | getWbsForcastDurUnit() WBS 要素計画日付の単位を取得します。
String | getWbsForecastDuration() WBS 要素の予測期間を取得します。
String | getWbsForecastDurUnitIso() 単位の ISO コードを取得します。
String | getWbsForecastFinishDate() WBS 要素の予測済終了日付を取得します。
String | getWbsForecastStartDate() WBS 要素の予測開始日を取得します。
String | getWbsPlanningElement() 区分: 計画要素を取得します。
String | getWbsScdActualFinishDate() WBS 要素の仮実績終了日を取得します。
String | getWbsScdActualStartDate() WBS 要素の仮実績開始日を取得します。
String | getWbsScdBasicFinishDate() 最遅計画終了日 (基準)を取得します。
String | getWbsScdBasicStartDate() 最早計画開始日 (基準)を取得します。
String | getWbsScdForecastFinishDate() 最遅計画終了日 (予測)を取得します。
String | getWbsScdForecastStartDate() 計画開始日 (予測)を取得します。
void | setApplicantNo(String strApplicantNo) 申請者番号を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCalendar(String strCalendar) 稼動日カレンダを設定します。
void | setChangeNo(String strChangeNo) 変更番号を設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCostingSheet(String strCostingSheet) 原価計算表を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO 通貨コードを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) PS: テキスト(短)(第一テキスト行)を設定します。
void | setEquipment(String strEquipment) 設備番号を設定します。
void | setEquityType(String strEquityType) 持分タイプを設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFunctionalLocation(String strFunctionalLocation) 機能場所を設定します。
void | setIntProfile(String strIntProfile) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setInvestProfile(String strInvestProfile) 設備投資案件プロファイルを設定します。
void | setJointVenture(String strJointVenture) ジョイントベンチャを設定します。
void | setJvJibClass(String strJvJibClass) JIB/JIBE クラスを設定します。
void | setJvJibSubClassA(String strJvJibSubClassA) JIB/JIBE サブクラスAを設定します。
void | setJvObjectType(String strJvObjectType) ジョイントベンチャ対象タイプを設定します。
void | setLocation(String strLocation) 場所を設定します。
void | setNetworkAssignment(String strNetworkAssignment) ネットワーク割当を設定します。
void | setObjectclass(String strObjectclass) 対象クラスを設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setOverheadKey(String strOverheadKey) 間接費キーを設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPriority(String strPriority) 優先度を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjType(String strProjType) プロジェクトタイプを設定します。
void | setRecoveryInd(String strRecoveryInd) リカバリフラグを設定します。
void | setRequestCctr(String strRequestCctr) 申請原価センタを設定します。
void | setRequestCctrControllingArea(String strRequestCctrControllingArea) 依頼原価センタの管理領域を設定します。
void | setRequestCompCode(String strRequestCompCode) 会社コード要求を設定します。
void | setResAnalKey(String strResAnalKey) 結果分析キーを設定します。
void | setResponsibleNo(String strResponsibleNo) 責任者番号 (プロジェクト責任者)を設定します。
void | setRespsblCctr(String strRespsblCctr) 責任原価センタを設定します。
void | setRespsblCctrControllingArea(String strRespsblCctrControllingArea) 責任原価センタの管理領域を設定します。
void | setShortId(String strShortId) WBS 要素 ショート IDを設定します。
void | setStatistical(String strStatistical) 統計 WBS 要素を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUserFieldChar10_1(String strUserFieldChar101) 10 桁の第 3 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldChar10_2(String strUserFieldChar102) 10 桁の第 4 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldChar20_1(String strUserFieldChar201) 20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。
void | setUserFieldChar20_2(String strUserFieldChar202) 20 桁の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldCuky1(String strUserFieldCuky1) 値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldCuky1Iso(String strUserFieldCuky1Iso) ISO 通貨コードを設定します。
void | setUserFieldCuky2(String strUserFieldCuky2) 値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldCuky2Iso(String strUserFieldCuky2Iso) ISO 通貨コードを設定します。
void | setUserFieldCurr1(String strUserFieldCurr1) 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldCurr2(String strUserFieldCurr2) 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldDate1(String strUserFieldDate1) 日付の第 1 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldDate2(String strUserFieldDate2) 日付の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldFlag1(String strUserFieldFlag1) '評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldFlag2(String strUserFieldFlag2) '評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。
void | setUserFieldKey(String strUserFieldKey) ユーザ定義項目のキーワード IDを設定します。
void | setUserFieldQuan1(String strUserFieldQuan1) 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldQuan2(String strUserFieldQuan2) 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
void | setUserFieldUnit1(String strUserFieldUnit1) 数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldUnit1Iso(String strUserFieldUnit1Iso) 単位の ISO コードを設定します。
void | setUserFieldUnit2(String strUserFieldUnit2) 数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
void | setUserFieldUnit2Iso(String strUserFieldUnit2Iso) 単位の ISO コードを設定します。
void | setWbsAccountAssignmentElement(String strWbsAccountAssignmentElement) 区分: 勘定設定要素を設定します。
void | setWbsActualDuration(String strWbsActualDuration) WBS 要素の実績長(期間)を設定します。
void | setWbsActualDurUnit(String strWbsActualDurUnit) 実績 WBS 要素日付の期間単位を設定します。
void | setWbsActualDurUnitIso(String strWbsActualDurUnitIso) 単位の ISO コードを設定します。
void | setWbsActualFinishDate(String strWbsActualFinishDate) WBS 要素の実績終了日を設定します。
void | setWbsActualStartDate(String strWbsActualStartDate) WBS 要素の実績開始日付を設定します。
void | setWbsBasicDuration(String strWbsBasicDuration) WBS 要素の基準日の長さ(期間)を設定します。
void | setWbsBasicDurUnit(String strWbsBasicDurUnit) 基準 WBS 要素日付の期間単位を設定します。
void | setWbsBasicDurUnitIso(String strWbsBasicDurUnitIso) 単位の ISO コードを設定します。
void | setWbsBasicFinishDate(String strWbsBasicFinishDate) WBS 要素: 基本終了日付を設定します。
void | setWbsBasicStartDate(String strWbsBasicStartDate) WBS 要素: 基本開始日を設定します。
void | setWbsBillingElement(String strWbsBillingElement) 区分: 請求要素を設定します。
void | setWbsCctrPostedActual(String strWbsCctrPostedActual) 原価が実際に転記される原価センタを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
void | setWbsForcastDurUnit(String strWbsForcastDurUnit) WBS 要素計画日付の単位を設定します。
void | setWbsForecastDuration(String strWbsForecastDuration) WBS 要素の予測期間を設定します。
void | setWbsForecastDurUnitIso(String strWbsForecastDurUnitIso) 単位の ISO コードを設定します。
void | setWbsForecastFinishDate(String strWbsForecastFinishDate) WBS 要素の予測済終了日付を設定します。
void | setWbsForecastStartDate(String strWbsForecastStartDate) WBS 要素の予測開始日を設定します。
void | setWbsPlanningElement(String strWbsPlanningElement) 区分: 計画要素を設定します。
void | setWbsScdActualFinishDate(String strWbsScdActualFinishDate) WBS 要素の仮実績終了日を設定します。
void | setWbsScdActualStartDate(String strWbsScdActualStartDate) WBS 要素の仮実績開始日を設定します。
void | setWbsScdBasicFinishDate(String strWbsScdBasicFinishDate) 最遅計画終了日 (基準)を設定します。
void | setWbsScdBasicStartDate(String strWbsScdBasicStartDate) 最早計画開始日 (基準)を設定します。
void | setWbsScdForecastFinishDate(String strWbsScdForecastFinishDate) 最遅計画終了日 (予測)を設定します。
void | setWbsScdForecastStartDate(String strWbsScdForecastStartDate) 計画開始日 (予測)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsElement

public ExpWbsElement()
WBS 要素についての詳細情報を作成します。

メソッドの詳細

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getDescription

public String getDescription()
PS: テキスト(短)(第一テキスト行)を取得します。

戻り値:
srtDescription PS: テキスト(短)(第一テキスト行)

getShortId

public String getShortId()
WBS 要素 ショート IDを取得します。

戻り値:
srtShortId WBS 要素 ショート ID

getResponsibleNo

public String getResponsibleNo()
責任者番号 (プロジェクト責任者)を取得します。

戻り値:
srtResponsibleNo 責任者番号 (プロジェクト責任者)

getApplicantNo

public String getApplicantNo()
申請者番号を取得します。

戻り値:
srtApplicantNo 申請者番号

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getProjType

public String getProjType()
プロジェクトタイプを取得します。

戻り値:
srtProjType プロジェクトタイプ

getNetworkAssignment

public String getNetworkAssignment()
ネットワーク割当を取得します。

戻り値:
srtNetworkAssignment ネットワーク割当

getCostingSheet

public String getCostingSheet()
原価計算表を取得します。

戻り値:
srtCostingSheet 原価計算表

getOverheadKey

public String getOverheadKey()
間接費キーを取得します。

戻り値:
srtOverheadKey 間接費キー

getCalendar

public String getCalendar()
稼動日カレンダを取得します。

戻り値:
srtCalendar 稼動日カレンダ

getPriority

public String getPriority()
優先度を取得します。

戻り値:
srtPriority 優先度

getEquipment

public String getEquipment()
設備番号を取得します。

戻り値:
srtEquipment 設備番号

getFunctionalLocation

public String getFunctionalLocation()
機能場所を取得します。

戻り値:
srtFunctionalLocation 機能場所

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtCurrencyIso ISO 通貨コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getUserFieldKey

public String getUserFieldKey()
ユーザ定義項目のキーワード IDを取得します。

戻り値:
srtUserFieldKey ユーザ定義項目のキーワード ID

getUserFieldChar20_1

public String getUserFieldChar20_1()
20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。

戻り値:
srtUserFieldChar201 20 文字の第 1 ユーザ項目 - WBS 要素 -

getUserFieldChar20_2

public String getUserFieldChar20_2()
20 桁の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar202 20 桁の第 2 ユーザ項目 - WBS 要素

getUserFieldChar10_1

public String getUserFieldChar10_1()
10 桁の第 3 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar101 10 桁の第 3 ユーザ項目 - WBS 要素

getUserFieldChar10_2

public String getUserFieldChar10_2()
10 桁の第 4 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldChar102 10 桁の第 4 ユーザ項目 - WBS 要素

getUserFieldQuan1

public String getUserFieldQuan1()
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldQuan1 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldUnit1

public String getUserFieldUnit1()
数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldUnit1 数量項目単位の第１ユーザ定義項目 - WBS 要素

getUserFieldUnit1Iso

public String getUserFieldUnit1Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit1Iso 単位の ISO コード

getUserFieldQuan2

public String getUserFieldQuan2()
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldQuan2 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldUnit2

public String getUserFieldUnit2()
数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldUnit2 数量項目単位の第２ユーザ定義項目 - WBS 要素

getUserFieldUnit2Iso

public String getUserFieldUnit2Iso()
単位の ISO コードを取得します。

戻り値:
srtUserFieldUnit2Iso 単位の ISO コード

getUserFieldCurr1

public String getUserFieldCurr1()
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldCurr1 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldCuky1

public String getUserFieldCuky1()
値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldCuky1 値項目単位の第１ユーザ定義項目 - WBS 要素

getUserFieldCuky1Iso

public String getUserFieldCuky1Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky1Iso ISO 通貨コード

getUserFieldCurr2

public String getUserFieldCurr2()
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。

戻り値:
srtUserFieldCurr2 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

getUserFieldCuky2

public String getUserFieldCuky2()
値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。

戻り値:
srtUserFieldCuky2 値項目単位の第２ユーザ定義項目 - WBS 要素

getUserFieldCuky2Iso

public String getUserFieldCuky2Iso()
ISO 通貨コードを取得します。

戻り値:
srtUserFieldCuky2Iso ISO 通貨コード

getUserFieldDate1

public String getUserFieldDate1()
日付の第 1 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldDate1 日付の第 1 ユーザ項目 - WBS 要素

getUserFieldDate2

public String getUserFieldDate2()
日付の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldDate2 日付の第 2 ユーザ項目 - WBS 要素

getUserFieldFlag1

public String getUserFieldFlag1()
'評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldFlag1 '評価区分' の第 1 ユーザ項目 - WBS 要素

getUserFieldFlag2

public String getUserFieldFlag2()
'評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。

戻り値:
srtUserFieldFlag2 '評価区分' の第 2 ユーザ項目 - WBS 要素

getObjectclass

public String getObjectclass()
対象クラスを取得します。

戻り値:
srtObjectclass 対象クラス

getStatistical

public String getStatistical()
統計 WBS 要素を取得します。

戻り値:
srtStatistical 統計 WBS 要素

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getIntProfile

public String getIntProfile()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtIntProfile プロジェクト/指図金利計算の金利プロファイル

getJointVenture

public String getJointVenture()
ジョイントベンチャを取得します。

戻り値:
srtJointVenture ジョイントベンチャ

getRecoveryInd

public String getRecoveryInd()
リカバリフラグを取得します。

戻り値:
srtRecoveryInd リカバリフラグ

getEquityType

public String getEquityType()
持分タイプを取得します。

戻り値:
srtEquityType 持分タイプ

getJvObjectType

public String getJvObjectType()
ジョイントベンチャ対象タイプを取得します。

戻り値:
srtJvObjectType ジョイントベンチャ対象タイプ

getJvJibClass

public String getJvJibClass()
JIB/JIBE クラスを取得します。

戻り値:
srtJvJibClass JIB/JIBE クラス

getJvJibSubClassA

public String getJvJibSubClassA()
JIB/JIBE サブクラスAを取得します。

戻り値:
srtJvJibSubClassA JIB/JIBE サブクラスA

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getWbsPlanningElement

public String getWbsPlanningElement()
区分: 計画要素を取得します。

戻り値:
srtWbsPlanningElement 区分: 計画要素

getWbsAccountAssignmentElement

public String getWbsAccountAssignmentElement()
区分: 勘定設定要素を取得します。

戻り値:
srtWbsAccountAssignmentElement 区分: 勘定設定要素

getWbsBillingElement

public String getWbsBillingElement()
区分: 請求要素を取得します。

戻り値:
srtWbsBillingElement 区分: 請求要素

getRespsblCctr

public String getRespsblCctr()
責任原価センタを取得します。

戻り値:
srtRespsblCctr 責任原価センタ

getRespsblCctrControllingArea

public String getRespsblCctrControllingArea()
責任原価センタの管理領域を取得します。

戻り値:
srtRespsblCctrControllingArea 責任原価センタの管理領域

getRequestCctr

public String getRequestCctr()
申請原価センタを取得します。

戻り値:
srtRequestCctr 申請原価センタ

getRequestCompCode

public String getRequestCompCode()
会社コード要求を取得します。

戻り値:
srtRequestCompCode 会社コード要求

getRequestCctrControllingArea

public String getRequestCctrControllingArea()
依頼原価センタの管理領域を取得します。

戻り値:
srtRequestCctrControllingArea 依頼原価センタの管理領域

getLocation

public String getLocation()
場所を取得します。

戻り値:
srtLocation 場所

getChangeNo

public String getChangeNo()
変更番号を取得します。

戻り値:
srtChangeNo 変更番号

getInvestProfile

public String getInvestProfile()
設備投資案件プロファイルを取得します。

戻り値:
srtInvestProfile 設備投資案件プロファイル

getResAnalKey

public String getResAnalKey()
結果分析キーを取得します。

戻り値:
srtResAnalKey 結果分析キー

getWbsCctrPostedActual

public String getWbsCctrPostedActual()
原価が実際に転記される原価センタを取得します。

戻り値:
srtWbsCctrPostedActual 原価が実際に転記される原価センタ

getWbsBasicStartDate

public String getWbsBasicStartDate()
WBS 要素: 基本開始日を取得します。

戻り値:
srtWbsBasicStartDate WBS 要素: 基本開始日

getWbsBasicFinishDate

public String getWbsBasicFinishDate()
WBS 要素: 基本終了日付を取得します。

戻り値:
srtWbsBasicFinishDate WBS 要素: 基本終了日付

getWbsForecastStartDate

public String getWbsForecastStartDate()
WBS 要素の予測開始日を取得します。

戻り値:
srtWbsForecastStartDate WBS 要素の予測開始日

getWbsForecastFinishDate

public String getWbsForecastFinishDate()
WBS 要素の予測済終了日付を取得します。

戻り値:
srtWbsForecastFinishDate WBS 要素の予測済終了日付

getWbsActualStartDate

public String getWbsActualStartDate()
WBS 要素の実績開始日付を取得します。

戻り値:
srtWbsActualStartDate WBS 要素の実績開始日付

getWbsActualFinishDate

public String getWbsActualFinishDate()
WBS 要素の実績終了日を取得します。

戻り値:
srtWbsActualFinishDate WBS 要素の実績終了日

getWbsBasicDuration

public String getWbsBasicDuration()
WBS 要素の基準日の長さ(期間)を取得します。

戻り値:
srtWbsBasicDuration WBS 要素の基準日の長さ(期間)

getWbsBasicDurUnit

public String getWbsBasicDurUnit()
基準 WBS 要素日付の期間単位を取得します。

戻り値:
srtWbsBasicDurUnit 基準 WBS 要素日付の期間単位

getWbsBasicDurUnitIso

public String getWbsBasicDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsBasicDurUnitIso 単位の ISO コード

getWbsForecastDuration

public String getWbsForecastDuration()
WBS 要素の予測期間を取得します。

戻り値:
srtWbsForecastDuration WBS 要素の予測期間

getWbsForcastDurUnit

public String getWbsForcastDurUnit()
WBS 要素計画日付の単位を取得します。

戻り値:
srtWbsForcastDurUnit WBS 要素計画日付の単位

getWbsForecastDurUnitIso

public String getWbsForecastDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsForecastDurUnitIso 単位の ISO コード

getWbsActualDuration

public String getWbsActualDuration()
WBS 要素の実績長(期間)を取得します。

戻り値:
srtWbsActualDuration WBS 要素の実績長(期間)

getWbsActualDurUnit

public String getWbsActualDurUnit()
実績 WBS 要素日付の期間単位を取得します。

戻り値:
srtWbsActualDurUnit 実績 WBS 要素日付の期間単位

getWbsActualDurUnitIso

public String getWbsActualDurUnitIso()
単位の ISO コードを取得します。

戻り値:
srtWbsActualDurUnitIso 単位の ISO コード

getWbsScdBasicStartDate

public String getWbsScdBasicStartDate()
最早計画開始日 (基準)を取得します。

戻り値:
srtWbsScdBasicStartDate 最早計画開始日 (基準)

getWbsScdBasicFinishDate

public String getWbsScdBasicFinishDate()
最遅計画終了日 (基準)を取得します。

戻り値:
srtWbsScdBasicFinishDate 最遅計画終了日 (基準)

getWbsScdForecastStartDate

public String getWbsScdForecastStartDate()
計画開始日 (予測)を取得します。

戻り値:
srtWbsScdForecastStartDate 計画開始日 (予測)

getWbsScdForecastFinishDate

public String getWbsScdForecastFinishDate()
最遅計画終了日 (予測)を取得します。

戻り値:
srtWbsScdForecastFinishDate 最遅計画終了日 (予測)

getWbsScdActualStartDate

public String getWbsScdActualStartDate()
WBS 要素の仮実績開始日を取得します。

戻り値:
srtWbsScdActualStartDate WBS 要素の仮実績開始日

getWbsScdActualFinishDate

public String getWbsScdActualFinishDate()
WBS 要素の仮実績終了日を取得します。

戻り値:
srtWbsScdActualFinishDate WBS 要素の仮実績終了日

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setDescription

public void setDescription(String strDescription)
PS: テキスト(短)(第一テキスト行)を設定します。

パラメータ:
strDescription - PS: テキスト(短)(第一テキスト行)

setShortId

public void setShortId(String strShortId)
WBS 要素 ショート IDを設定します。

パラメータ:
strShortId - WBS 要素 ショート ID

setResponsibleNo

public void setResponsibleNo(String strResponsibleNo)
責任者番号 (プロジェクト責任者)を設定します。

パラメータ:
strResponsibleNo - 責任者番号 (プロジェクト責任者)

setApplicantNo

public void setApplicantNo(String strApplicantNo)
申請者番号を設定します。

パラメータ:
strApplicantNo - 申請者番号

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setProjType

public void setProjType(String strProjType)
プロジェクトタイプを設定します。

パラメータ:
strProjType - プロジェクトタイプ

setNetworkAssignment

public void setNetworkAssignment(String strNetworkAssignment)
ネットワーク割当を設定します。

パラメータ:
strNetworkAssignment - ネットワーク割当

setCostingSheet

public void setCostingSheet(String strCostingSheet)
原価計算表を設定します。

パラメータ:
strCostingSheet - 原価計算表

setOverheadKey

public void setOverheadKey(String strOverheadKey)
間接費キーを設定します。

パラメータ:
strOverheadKey - 間接費キー

setCalendar

public void setCalendar(String strCalendar)
稼動日カレンダを設定します。

パラメータ:
strCalendar - 稼動日カレンダ

setPriority

public void setPriority(String strPriority)
優先度を設定します。

パラメータ:
strPriority - 優先度

setEquipment

public void setEquipment(String strEquipment)
設備番号を設定します。

パラメータ:
strEquipment - 設備番号

setFunctionalLocation

public void setFunctionalLocation(String strFunctionalLocation)
機能場所を設定します。

パラメータ:
strFunctionalLocation - 機能場所

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strCurrencyIso - ISO 通貨コード

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setUserFieldKey

public void setUserFieldKey(String strUserFieldKey)
ユーザ定義項目のキーワード IDを設定します。

パラメータ:
strUserFieldKey - ユーザ定義項目のキーワード ID

setUserFieldChar20_1

public void setUserFieldChar20_1(String strUserFieldChar201)
20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。

パラメータ:
strUserFieldChar201 - 20 文字の第 1 ユーザ項目 - WBS 要素 -

setUserFieldChar20_2

public void setUserFieldChar20_2(String strUserFieldChar202)
20 桁の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar202 - 20 桁の第 2 ユーザ項目 - WBS 要素

setUserFieldChar10_1

public void setUserFieldChar10_1(String strUserFieldChar101)
10 桁の第 3 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar101 - 10 桁の第 3 ユーザ項目 - WBS 要素

setUserFieldChar10_2

public void setUserFieldChar10_2(String strUserFieldChar102)
10 桁の第 4 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldChar102 - 10 桁の第 4 ユーザ項目 - WBS 要素

setUserFieldQuan1

public void setUserFieldQuan1(String strUserFieldQuan1)
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldQuan1 - 数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldUnit1

public void setUserFieldUnit1(String strUserFieldUnit1)
数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldUnit1 - 数量項目単位の第１ユーザ定義項目 - WBS 要素

setUserFieldUnit1Iso

public void setUserFieldUnit1Iso(String strUserFieldUnit1Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit1Iso - 単位の ISO コード

setUserFieldQuan2

public void setUserFieldQuan2(String strUserFieldQuan2)
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldQuan2 - 数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldUnit2

public void setUserFieldUnit2(String strUserFieldUnit2)
数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldUnit2 - 数量項目単位の第２ユーザ定義項目 - WBS 要素

setUserFieldUnit2Iso

public void setUserFieldUnit2Iso(String strUserFieldUnit2Iso)
単位の ISO コードを設定します。

パラメータ:
strUserFieldUnit2Iso - 単位の ISO コード

setUserFieldCurr1

public void setUserFieldCurr1(String strUserFieldCurr1)
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldCurr1 - 値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldCuky1

public void setUserFieldCuky1(String strUserFieldCuky1)
値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldCuky1 - 値項目単位の第１ユーザ定義項目 - WBS 要素

setUserFieldCuky1Iso

public void setUserFieldCuky1Iso(String strUserFieldCuky1Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky1Iso - ISO 通貨コード

setUserFieldCurr2

public void setUserFieldCurr2(String strUserFieldCurr2)
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。

パラメータ:
strUserFieldCurr2 - 値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

setUserFieldCuky2

public void setUserFieldCuky2(String strUserFieldCuky2)
値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。

パラメータ:
strUserFieldCuky2 - 値項目単位の第２ユーザ定義項目 - WBS 要素

setUserFieldCuky2Iso

public void setUserFieldCuky2Iso(String strUserFieldCuky2Iso)
ISO 通貨コードを設定します。

パラメータ:
strUserFieldCuky2Iso - ISO 通貨コード

setUserFieldDate1

public void setUserFieldDate1(String strUserFieldDate1)
日付の第 1 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldDate1 - 日付の第 1 ユーザ項目 - WBS 要素

setUserFieldDate2

public void setUserFieldDate2(String strUserFieldDate2)
日付の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldDate2 - 日付の第 2 ユーザ項目 - WBS 要素

setUserFieldFlag1

public void setUserFieldFlag1(String strUserFieldFlag1)
'評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldFlag1 - '評価区分' の第 1 ユーザ項目 - WBS 要素

setUserFieldFlag2

public void setUserFieldFlag2(String strUserFieldFlag2)
'評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。

パラメータ:
strUserFieldFlag2 - '評価区分' の第 2 ユーザ項目 - WBS 要素

setObjectclass

public void setObjectclass(String strObjectclass)
対象クラスを設定します。

パラメータ:
strObjectclass - 対象クラス

setStatistical

public void setStatistical(String strStatistical)
統計 WBS 要素を設定します。

パラメータ:
strStatistical - 統計 WBS 要素

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setIntProfile

public void setIntProfile(String strIntProfile)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strIntProfile - プロジェクト/指図金利計算の金利プロファイル

setJointVenture

public void setJointVenture(String strJointVenture)
ジョイントベンチャを設定します。

パラメータ:
strJointVenture - ジョイントベンチャ

setRecoveryInd

public void setRecoveryInd(String strRecoveryInd)
リカバリフラグを設定します。

パラメータ:
strRecoveryInd - リカバリフラグ

setEquityType

public void setEquityType(String strEquityType)
持分タイプを設定します。

パラメータ:
strEquityType - 持分タイプ

setJvObjectType

public void setJvObjectType(String strJvObjectType)
ジョイントベンチャ対象タイプを設定します。

パラメータ:
strJvObjectType - ジョイントベンチャ対象タイプ

setJvJibClass

public void setJvJibClass(String strJvJibClass)
JIB/JIBE クラスを設定します。

パラメータ:
strJvJibClass - JIB/JIBE クラス

setJvJibSubClassA

public void setJvJibSubClassA(String strJvJibSubClassA)
JIB/JIBE サブクラスAを設定します。

パラメータ:
strJvJibSubClassA - JIB/JIBE サブクラスA

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setWbsPlanningElement

public void setWbsPlanningElement(String strWbsPlanningElement)
区分: 計画要素を設定します。

パラメータ:
strWbsPlanningElement - 区分: 計画要素

setWbsAccountAssignmentElement

public void setWbsAccountAssignmentElement(String strWbsAccountAssignmentElement)
区分: 勘定設定要素を設定します。

パラメータ:
strWbsAccountAssignmentElement - 区分: 勘定設定要素

setWbsBillingElement

public void setWbsBillingElement(String strWbsBillingElement)
区分: 請求要素を設定します。

パラメータ:
strWbsBillingElement - 区分: 請求要素

setRespsblCctr

public void setRespsblCctr(String strRespsblCctr)
責任原価センタを設定します。

パラメータ:
strRespsblCctr - 責任原価センタ

setRespsblCctrControllingArea

public void setRespsblCctrControllingArea(String strRespsblCctrControllingArea)
責任原価センタの管理領域を設定します。

パラメータ:
strRespsblCctrControllingArea - 責任原価センタの管理領域

setRequestCctr

public void setRequestCctr(String strRequestCctr)
申請原価センタを設定します。

パラメータ:
strRequestCctr - 申請原価センタ

setRequestCompCode

public void setRequestCompCode(String strRequestCompCode)
会社コード要求を設定します。

パラメータ:
strRequestCompCode - 会社コード要求

setRequestCctrControllingArea

public void setRequestCctrControllingArea(String strRequestCctrControllingArea)
依頼原価センタの管理領域を設定します。

パラメータ:
strRequestCctrControllingArea - 依頼原価センタの管理領域

setLocation

public void setLocation(String strLocation)
場所を設定します。

パラメータ:
strLocation - 場所

setChangeNo

public void setChangeNo(String strChangeNo)
変更番号を設定します。

パラメータ:
strChangeNo - 変更番号

setInvestProfile

public void setInvestProfile(String strInvestProfile)
設備投資案件プロファイルを設定します。

パラメータ:
strInvestProfile - 設備投資案件プロファイル

setResAnalKey

public void setResAnalKey(String strResAnalKey)
結果分析キーを設定します。

パラメータ:
strResAnalKey - 結果分析キー

setWbsCctrPostedActual

public void setWbsCctrPostedActual(String strWbsCctrPostedActual)
原価が実際に転記される原価センタを設定します。

パラメータ:
strWbsCctrPostedActual - 原価が実際に転記される原価センタ

setWbsBasicStartDate

public void setWbsBasicStartDate(String strWbsBasicStartDate)
WBS 要素: 基本開始日を設定します。

パラメータ:
strWbsBasicStartDate - WBS 要素: 基本開始日

setWbsBasicFinishDate

public void setWbsBasicFinishDate(String strWbsBasicFinishDate)
WBS 要素: 基本終了日付を設定します。

パラメータ:
strWbsBasicFinishDate - WBS 要素: 基本終了日付

setWbsForecastStartDate

public void setWbsForecastStartDate(String strWbsForecastStartDate)
WBS 要素の予測開始日を設定します。

パラメータ:
strWbsForecastStartDate - WBS 要素の予測開始日

setWbsForecastFinishDate

public void setWbsForecastFinishDate(String strWbsForecastFinishDate)
WBS 要素の予測済終了日付を設定します。

パラメータ:
strWbsForecastFinishDate - WBS 要素の予測済終了日付

setWbsActualStartDate

public void setWbsActualStartDate(String strWbsActualStartDate)
WBS 要素の実績開始日付を設定します。

パラメータ:
strWbsActualStartDate - WBS 要素の実績開始日付

setWbsActualFinishDate

public void setWbsActualFinishDate(String strWbsActualFinishDate)
WBS 要素の実績終了日を設定します。

パラメータ:
strWbsActualFinishDate - WBS 要素の実績終了日

setWbsBasicDuration

public void setWbsBasicDuration(String strWbsBasicDuration)
WBS 要素の基準日の長さ(期間)を設定します。

パラメータ:
strWbsBasicDuration - WBS 要素の基準日の長さ(期間)

setWbsBasicDurUnit

public void setWbsBasicDurUnit(String strWbsBasicDurUnit)
基準 WBS 要素日付の期間単位を設定します。

パラメータ:
strWbsBasicDurUnit - 基準 WBS 要素日付の期間単位

setWbsBasicDurUnitIso

public void setWbsBasicDurUnitIso(String strWbsBasicDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsBasicDurUnitIso - 単位の ISO コード

setWbsForecastDuration

public void setWbsForecastDuration(String strWbsForecastDuration)
WBS 要素の予測期間を設定します。

パラメータ:
strWbsForecastDuration - WBS 要素の予測期間

setWbsForcastDurUnit

public void setWbsForcastDurUnit(String strWbsForcastDurUnit)
WBS 要素計画日付の単位を設定します。

パラメータ:
strWbsForcastDurUnit - WBS 要素計画日付の単位

setWbsForecastDurUnitIso

public void setWbsForecastDurUnitIso(String strWbsForecastDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsForecastDurUnitIso - 単位の ISO コード

setWbsActualDuration

public void setWbsActualDuration(String strWbsActualDuration)
WBS 要素の実績長(期間)を設定します。

パラメータ:
strWbsActualDuration - WBS 要素の実績長(期間)

setWbsActualDurUnit

public void setWbsActualDurUnit(String strWbsActualDurUnit)
実績 WBS 要素日付の期間単位を設定します。

パラメータ:
strWbsActualDurUnit - 実績 WBS 要素日付の期間単位

setWbsActualDurUnitIso

public void setWbsActualDurUnitIso(String strWbsActualDurUnitIso)
単位の ISO コードを設定します。

パラメータ:
strWbsActualDurUnitIso - 単位の ISO コード

setWbsScdBasicStartDate

public void setWbsScdBasicStartDate(String strWbsScdBasicStartDate)
最早計画開始日 (基準)を設定します。

パラメータ:
strWbsScdBasicStartDate - 最早計画開始日 (基準)

setWbsScdBasicFinishDate

public void setWbsScdBasicFinishDate(String strWbsScdBasicFinishDate)
最遅計画終了日 (基準)を設定します。

パラメータ:
strWbsScdBasicFinishDate - 最遅計画終了日 (基準)

setWbsScdForecastStartDate

public void setWbsScdForecastStartDate(String strWbsScdForecastStartDate)
計画開始日 (予測)を設定します。

パラメータ:
strWbsScdForecastStartDate - 計画開始日 (予測)

setWbsScdForecastFinishDate

public void setWbsScdForecastFinishDate(String strWbsScdForecastFinishDate)
最遅計画終了日 (予測)を設定します。

パラメータ:
strWbsScdForecastFinishDate - 最遅計画終了日 (予測)

setWbsScdActualStartDate

public void setWbsScdActualStartDate(String strWbsScdActualStartDate)
WBS 要素の仮実績開始日を設定します。

パラメータ:
strWbsScdActualStartDate - WBS 要素の仮実績開始日

setWbsScdActualFinishDate

public void setWbsScdActualFinishDate(String strWbsScdActualFinishDate)
WBS 要素の仮実績終了日を設定します。

パラメータ:
strWbsScdActualFinishDate - WBS 要素の仮実績終了日

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsHierarchie (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsHierarchie

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie
すべての実装インタフェース:
Serializable
public class ExpWbsHierarchie
extends Object
implements Serializable

WBS 階層についての情報クラス 機能は以下の通り

  • WBS 階層についての情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsHierarchie()
WBS 階層についての情報を作成します。
メソッドの概要
String | getDown() WBS 要素を取得します。
String | getLeft() WBS 要素を取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getRight() WBS 要素を取得します。
String | getUp() WBS 要素を取得します。
String | getWbsElement() WBS 要素を取得します。
void | setDown(String strDown) WBS 要素を設定します。
void | setLeft(String strLeft) WBS 要素を設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setRight(String strRight) WBS 要素を設定します。
void | setUp(String strUp) WBS 要素を設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsHierarchie

public ExpWbsHierarchie()
WBS 階層についての情報を作成します。

メソッドの詳細

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getUp

public String getUp()
WBS 要素を取得します。

戻り値:
srtUp WBS 要素

getDown

public String getDown()
WBS 要素を取得します。

戻り値:
srtDown WBS 要素

getLeft

public String getLeft()
WBS 要素を取得します。

戻り値:
srtLeft WBS 要素

getRight

public String getRight()
WBS 要素を取得します。

戻り値:
srtRight WBS 要素

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setUp

public void setUp(String strUp)
WBS 要素を設定します。

パラメータ:
strUp - WBS 要素

setDown

public void setDown(String strDown)
WBS 要素を設定します。

パラメータ:
strDown - WBS 要素

setLeft

public void setLeft(String strLeft)
WBS 要素を設定します。

パラメータ:
strLeft - WBS 要素

setRight

public void setRight(String strRight)
WBS 要素を設定します。

パラメータ:
strRight - WBS 要素

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExpWbsMilestone (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ExpWbsMilestone

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone
すべての実装インタフェース:
Serializable
public class ExpWbsMilestone
extends Object
implements Serializable

WBS マイルストーンに関する詳細情報クラス 機能は以下の通り

  • WBS マイルストーンに関する詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExpWbsMilestone()
WBS マイルストーンに関する詳細情報を作成します。
メソッドの概要
String | getActualDate() 実績日付(マイルストーン通過)を取得します。
String | getActualTime() 実績日/時間(マイルストーン適合)を取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() テキストを取得します。
String | getEarnedValueIndicator() 進捗分析関連のマイルストーンを取得します。
String | getFixedMilestoneDateBasic() 固定マイルストーン日付(基準)を取得します。
String | getFixedMilestoneDateForecast() マイルストーン固定日付を取得します。
String | getFixedMilestoneTimeBasic() 固定マイルストーン時間(基準)を取得します。
String | getFixedMilestoneTimeForecast() マイルストーン固定時間 (F)を取得します。
String | getInvoicePercentage() 請求金額率 (%)を取得します。
String | getLatestDatesIndicator() 区分: 最遅日を取得します。
String | getMilestoneNumber() マイルストーン番号を取得します。
String | getMilestoneUsage() マイルストーン用途を取得します。
String | getOffsetMilestoneDate() マイルストーン日付のオフセットを取得します。
String | getOffsetMilestoneDateUnit() マイルストーンのオフセットのための時間単位を取得します。
String | getOffsetMilestoneDateUnitIso() 単位の ISO コードを取得します。
String | getOffsetPercentage() 活動日に対するマイルストーンの百分率によるオフセットを取得します。
String | getOffsetStartEndIndicator() 区分: オフセット用の参照（開始/終了活動日）を取得します。
String | getPercentageOfCompletion() 進捗度 (%)を取得します。
String | getSalesDocDateInidicator() 販売伝票の日付に関連するマイルストーンを取得します。
String | getSchedMilestoneDateBasic() マイルストーン計画日(基準)を取得します。
String | getSchedMilestoneDateForecast() マイルストーン計画日(予測)を取得します。
String | getSchedMilestoneTimeBasic() マイルストーン計画時間(基準)を取得します。
String | getSchedMilestoneTimeForecast() マイルストーン計画時間(予測)を取得します。
String | getTrendAnalysisIndicator() 傾向分析の関連マイルストーンを取得します。
String | getWbsElement() WBS 要素を取得します。
void | setActualDate(String strActualDate) 実績日付(マイルストーン通過)を設定します。
void | setActualTime(String strActualTime) 実績日/時間(マイルストーン適合)を設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) テキストを設定します。
void | setEarnedValueIndicator(String strEarnedValueIndicator) 進捗分析関連のマイルストーンを設定します。
void | setFixedMilestoneDateBasic(String strFixedMilestoneDateBasic) 固定マイルストーン日付(基準)を設定します。
void | setFixedMilestoneDateForecast(String strFixedMilestoneDateForecast) マイルストーン固定日付を設定します。
void | setFixedMilestoneTimeBasic(String strFixedMilestoneTimeBasic) 固定マイルストーン時間(基準)を設定します。
void | setFixedMilestoneTimeForecast(String strFixedMilestoneTimeForecast) マイルストーン固定時間 (F)を設定します。
void | setInvoicePercentage(String strInvoicePercentage) 請求金額率 (%)を設定します。
void | setLatestDatesIndicator(String strLatestDatesIndicator) 区分: 最遅日を設定します。
void | setMilestoneNumber(String strMilestoneNumber) マイルストーン番号を設定します。
void | setMilestoneUsage(String strMilestoneUsage) マイルストーン用途を設定します。
void | setOffsetMilestoneDate(String strOffsetMilestoneDate) マイルストーン日付のオフセットを設定します。
void | setOffsetMilestoneDateUnit(String strOffsetMilestoneDateUnit) マイルストーンのオフセットのための時間単位を設定します。
void | setOffsetMilestoneDateUnitIso(String strOffsetMilestoneDateUnitIso) 単位の ISO コードを設定します。
void | setOffsetPercentage(String strOffsetPercentage) 活動日に対するマイルストーンの百分率によるオフセットを設定します。
void | setOffsetStartEndIndicator(String strOffsetStartEndIndicator) 区分: オフセット用の参照（開始/終了活動日）を設定します。
void | setPercentageOfCompletion(String strPercentageOfCompletion) 進捗度 (%)を設定します。
void | setSalesDocDateInidicator(String strSalesDocDateInidicator) 販売伝票の日付に関連するマイルストーンを設定します。
void | setSchedMilestoneDateBasic(String strSchedMilestoneDateBasic) マイルストーン計画日(基準)を設定します。
void | setSchedMilestoneDateForecast(String strSchedMilestoneDateForecast) マイルストーン計画日(予測)を設定します。
void | setSchedMilestoneTimeBasic(String strSchedMilestoneTimeBasic) マイルストーン計画時間(基準)を設定します。
void | setSchedMilestoneTimeForecast(String strSchedMilestoneTimeForecast) マイルストーン計画時間(予測)を設定します。
void | setTrendAnalysisIndicator(String strTrendAnalysisIndicator) 傾向分析の関連マイルストーンを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExpWbsMilestone

public ExpWbsMilestone()
WBS マイルストーンに関する詳細情報を作成します。

メソッドの詳細

getMilestoneNumber

public String getMilestoneNumber()
マイルストーン番号を取得します。

戻り値:
srtMilestoneNumber マイルストーン番号

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getMilestoneUsage

public String getMilestoneUsage()
マイルストーン用途を取得します。

戻り値:
srtMilestoneUsage マイルストーン用途

getDescription

public String getDescription()
テキストを取得します。

戻り値:
srtDescription テキスト

getSchedMilestoneDateBasic

public String getSchedMilestoneDateBasic()
マイルストーン計画日(基準)を取得します。

戻り値:
srtSchedMilestoneDateBasic マイルストーン計画日(基準)

getSchedMilestoneTimeBasic

public String getSchedMilestoneTimeBasic()
マイルストーン計画時間(基準)を取得します。

戻り値:
srtSchedMilestoneTimeBasic マイルストーン計画時間(基準)

getSchedMilestoneDateForecast

public String getSchedMilestoneDateForecast()
マイルストーン計画日(予測)を取得します。

戻り値:
srtSchedMilestoneDateForecast マイルストーン計画日(予測)

getSchedMilestoneTimeForecast

public String getSchedMilestoneTimeForecast()
マイルストーン計画時間(予測)を取得します。

戻り値:
srtSchedMilestoneTimeForecast マイルストーン計画時間(予測)

getFixedMilestoneDateBasic

public String getFixedMilestoneDateBasic()
固定マイルストーン日付(基準)を取得します。

戻り値:
srtFixedMilestoneDateBasic 固定マイルストーン日付(基準)

getFixedMilestoneTimeBasic

public String getFixedMilestoneTimeBasic()
固定マイルストーン時間(基準)を取得します。

戻り値:
srtFixedMilestoneTimeBasic 固定マイルストーン時間(基準)

getFixedMilestoneDateForecast

public String getFixedMilestoneDateForecast()
マイルストーン固定日付を取得します。

戻り値:
srtFixedMilestoneDateForecast マイルストーン固定日付

getFixedMilestoneTimeForecast

public String getFixedMilestoneTimeForecast()
マイルストーン固定時間 (F)を取得します。

戻り値:
srtFixedMilestoneTimeForecast マイルストーン固定時間 (F)

getActualDate

public String getActualDate()
実績日付(マイルストーン通過)を取得します。

戻り値:
srtActualDate 実績日付(マイルストーン通過)

getActualTime

public String getActualTime()
実績日/時間(マイルストーン適合)を取得します。

戻り値:
srtActualTime 実績日/時間(マイルストーン適合)

getLatestDatesIndicator

public String getLatestDatesIndicator()
区分: 最遅日を取得します。

戻り値:
srtLatestDatesIndicator 区分: 最遅日

getOffsetStartEndIndicator

public String getOffsetStartEndIndicator()
区分: オフセット用の参照（開始/終了活動日）を取得します。

戻り値:
srtOffsetStartEndIndicator 区分: オフセット用の参照（開始/終了活動日）

getOffsetMilestoneDate

public String getOffsetMilestoneDate()
マイルストーン日付のオフセットを取得します。

戻り値:
srtOffsetMilestoneDate マイルストーン日付のオフセット

getOffsetMilestoneDateUnit

public String getOffsetMilestoneDateUnit()
マイルストーンのオフセットのための時間単位を取得します。

戻り値:
srtOffsetMilestoneDateUnit マイルストーンのオフセットのための時間単位

getOffsetMilestoneDateUnitIso

public String getOffsetMilestoneDateUnitIso()
単位の ISO コードを取得します。

戻り値:
srtOffsetMilestoneDateUnitIso 単位の ISO コード

getOffsetPercentage

public String getOffsetPercentage()
活動日に対するマイルストーンの百分率によるオフセットを取得します。

戻り値:
srtOffsetPercentage 活動日に対するマイルストーンの百分率によるオフセット

getTrendAnalysisIndicator

public String getTrendAnalysisIndicator()
傾向分析の関連マイルストーンを取得します。

戻り値:
srtTrendAnalysisIndicator 傾向分析の関連マイルストーン

getEarnedValueIndicator

public String getEarnedValueIndicator()
進捗分析関連のマイルストーンを取得します。

戻り値:
srtEarnedValueIndicator 進捗分析関連のマイルストーン

getPercentageOfCompletion

public String getPercentageOfCompletion()
進捗度 (%)を取得します。

戻り値:
srtPercentageOfCompletion 進捗度 (%)

getSalesDocDateInidicator

public String getSalesDocDateInidicator()
販売伝票の日付に関連するマイルストーンを取得します。

戻り値:
srtSalesDocDateInidicator 販売伝票の日付に関連するマイルストーン

getInvoicePercentage

public String getInvoicePercentage()
請求金額率 (%)を取得します。

戻り値:
srtInvoicePercentage 請求金額率 (%)

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

setMilestoneNumber

public void setMilestoneNumber(String strMilestoneNumber)
マイルストーン番号を設定します。

パラメータ:
strMilestoneNumber - マイルストーン番号

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setMilestoneUsage

public void setMilestoneUsage(String strMilestoneUsage)
マイルストーン用途を設定します。

パラメータ:
strMilestoneUsage - マイルストーン用途

setDescription

public void setDescription(String strDescription)
テキストを設定します。

パラメータ:
strDescription - テキスト

setSchedMilestoneDateBasic

public void setSchedMilestoneDateBasic(String strSchedMilestoneDateBasic)
マイルストーン計画日(基準)を設定します。

パラメータ:
strSchedMilestoneDateBasic - マイルストーン計画日(基準)

setSchedMilestoneTimeBasic

public void setSchedMilestoneTimeBasic(String strSchedMilestoneTimeBasic)
マイルストーン計画時間(基準)を設定します。

パラメータ:
strSchedMilestoneTimeBasic - マイルストーン計画時間(基準)

setSchedMilestoneDateForecast

public void setSchedMilestoneDateForecast(String strSchedMilestoneDateForecast)
マイルストーン計画日(予測)を設定します。

パラメータ:
strSchedMilestoneDateForecast - マイルストーン計画日(予測)

setSchedMilestoneTimeForecast

public void setSchedMilestoneTimeForecast(String strSchedMilestoneTimeForecast)
マイルストーン計画時間(予測)を設定します。

パラメータ:
strSchedMilestoneTimeForecast - マイルストーン計画時間(予測)

setFixedMilestoneDateBasic

public void setFixedMilestoneDateBasic(String strFixedMilestoneDateBasic)
固定マイルストーン日付(基準)を設定します。

パラメータ:
strFixedMilestoneDateBasic - 固定マイルストーン日付(基準)

setFixedMilestoneTimeBasic

public void setFixedMilestoneTimeBasic(String strFixedMilestoneTimeBasic)
固定マイルストーン時間(基準)を設定します。

パラメータ:
strFixedMilestoneTimeBasic - 固定マイルストーン時間(基準)

setFixedMilestoneDateForecast

public void setFixedMilestoneDateForecast(String strFixedMilestoneDateForecast)
マイルストーン固定日付を設定します。

パラメータ:
strFixedMilestoneDateForecast - マイルストーン固定日付

setFixedMilestoneTimeForecast

public void setFixedMilestoneTimeForecast(String strFixedMilestoneTimeForecast)
マイルストーン固定時間 (F)を設定します。

パラメータ:
strFixedMilestoneTimeForecast - マイルストーン固定時間 (F)

setActualDate

public void setActualDate(String strActualDate)
実績日付(マイルストーン通過)を設定します。

パラメータ:
strActualDate - 実績日付(マイルストーン通過)

setActualTime

public void setActualTime(String strActualTime)
実績日/時間(マイルストーン適合)を設定します。

パラメータ:
strActualTime - 実績日/時間(マイルストーン適合)

setLatestDatesIndicator

public void setLatestDatesIndicator(String strLatestDatesIndicator)
区分: 最遅日を設定します。

パラメータ:
strLatestDatesIndicator - 区分: 最遅日

setOffsetStartEndIndicator

public void setOffsetStartEndIndicator(String strOffsetStartEndIndicator)
区分: オフセット用の参照（開始/終了活動日）を設定します。

パラメータ:
strOffsetStartEndIndicator - 区分: オフセット用の参照（開始/終了活動日）

setOffsetMilestoneDate

public void setOffsetMilestoneDate(String strOffsetMilestoneDate)
マイルストーン日付のオフセットを設定します。

パラメータ:
strOffsetMilestoneDate - マイルストーン日付のオフセット

setOffsetMilestoneDateUnit

public void setOffsetMilestoneDateUnit(String strOffsetMilestoneDateUnit)
マイルストーンのオフセットのための時間単位を設定します。

パラメータ:
strOffsetMilestoneDateUnit - マイルストーンのオフセットのための時間単位

setOffsetMilestoneDateUnitIso

public void setOffsetMilestoneDateUnitIso(String strOffsetMilestoneDateUnitIso)
単位の ISO コードを設定します。

パラメータ:
strOffsetMilestoneDateUnitIso - 単位の ISO コード

setOffsetPercentage

public void setOffsetPercentage(String strOffsetPercentage)
活動日に対するマイルストーンの百分率によるオフセットを設定します。

パラメータ:
strOffsetPercentage - 活動日に対するマイルストーンの百分率によるオフセット

setTrendAnalysisIndicator

public void setTrendAnalysisIndicator(String strTrendAnalysisIndicator)
傾向分析の関連マイルストーンを設定します。

パラメータ:
strTrendAnalysisIndicator - 傾向分析の関連マイルストーン

setEarnedValueIndicator

public void setEarnedValueIndicator(String strEarnedValueIndicator)
進捗分析関連のマイルストーンを設定します。

パラメータ:
strEarnedValueIndicator - 進捗分析関連のマイルストーン

setPercentageOfCompletion

public void setPercentageOfCompletion(String strPercentageOfCompletion)
進捗度 (%)を設定します。

パラメータ:
strPercentageOfCompletion - 進捗度 (%)

setSalesDocDateInidicator

public void setSalesDocDateInidicator(String strSalesDocDateInidicator)
販売伝票の日付に関連するマイルストーンを設定します。

パラメータ:
strSalesDocDateInidicator - 販売伝票の日付に関連するマイルストーン

setInvoicePercentage

public void setInvoicePercentage(String strInvoicePercentage)
請求金額率 (%)を設定します。

パラメータ:
strInvoicePercentage - 請求金額率 (%)

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HierarchyNodes (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス HierarchyNodes

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes
すべての実装インタフェース:
Serializable
public class HierarchyNodes
extends Object
implements Serializable

階層ノード情報クラス 機能は以下の通り

  • 階層ノード情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HierarchyNodes()
階層ノードを作成します。
メソッドの概要
String | getDescript() グループテキスト (短)を取得します。
String | getGroupname() グループ名を取得します。
String | getHierlevel() 階層のエントリレベルを取得します。
String | getValcount() 階層ノード内の値の値数を取得します。
void | setDescript(String strDescript) グループテキスト (短)を設定します。
void | setGroupname(String strGroupname) グループ名を設定します。
void | setHierlevel(String strHierlevel) 階層のエントリレベルを設定します。
void | setValcount(String strValcount) 階層ノード内の値の値数を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HierarchyNodes

public HierarchyNodes()
階層ノードを作成します。

メソッドの詳細

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

getHierlevel

public String getHierlevel()
階層のエントリレベルを取得します。

戻り値:
srtHierlevel 階層のエントリレベル

getValcount

public String getValcount()
階層ノード内の値の値数を取得します。

戻り値:
srtValcount 階層ノード内の値の値数

getDescript

public String getDescript()
グループテキスト (短)を取得します。

戻り値:
srtDescript グループテキスト (短)

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

setHierlevel

public void setHierlevel(String strHierlevel)
階層のエントリレベルを設定します。

パラメータ:
strHierlevel - 階層のエントリレベル

setValcount

public void setValcount(String strValcount)
階層ノード内の値の値数を設定します。

パラメータ:
strValcount - 階層ノード内の値の値数

setDescript

public void setDescript(String strDescript)
グループテキスト (短)を設定します。

パラメータ:
strDescript - グループテキスト (短)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HierarchyValues (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス HierarchyValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues
すべての実装インタフェース:
Serializable
public class HierarchyValues
extends Object
implements Serializable

階層値情報クラス 機能は以下の通り

  • 階層値情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HierarchyValues()
階層値を作成します。
メソッドの概要
String | getValfrom() 原価センタ/利益センタを取得します。
String | getValto() 原価センタ/利益センタを取得します。
void | setValfrom(String strValfrom) 原価センタ/利益センタを設定します。
void | setValto(String strValto) 原価センタ/利益センタを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HierarchyValues

public HierarchyValues()
階層値を作成します。

メソッドの詳細

getValfrom

public String getValfrom()
原価センタ/利益センタを取得します。

戻り値:
srtValfrom 原価センタ/利益センタ

getValto

public String getValto()
原価センタ/利益センタを取得します。

戻り値:
srtValto 原価センタ/利益センタ

setValfrom

public void setValfrom(String strValfrom)
原価センタ/利益センタを設定します。

パラメータ:
strValfrom - 原価センタ/利益センタ

setValto

public void setValto(String strValto)
原価センタ/利益センタを設定します。

パラメータ:
strValto - 原価センタ/利益センタ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ImpWbsElement (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ImpWbsElement

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement
すべての実装インタフェース:
Serializable
public class ImpWbsElement
extends Object
implements Serializable

詳細情報を必要とする WBS 要素クラス 機能は以下の通り

  • 詳細情報を必要とする WBS 要素を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ImpWbsElement()
詳細情報を必要とする WBS 要素を作成します。
ImpWbsElement(int index)
詳細情報を必要とする WBS 要素を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getWbsElement() WBS 要素を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ImpWbsElement

public ImpWbsElement()
詳細情報を必要とする WBS 要素を作成します。

ImpWbsElement

public ImpWbsElement(int index)
詳細情報を必要とする WBS 要素を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail
すべての実装インタフェース:
Serializable
public class InternalOrderGetDetail
extends ReferenceController
implements Serializable

内部指図書詳細情報取得クラス
機能は以下の通り

  • 内部指図書詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String orderId, String language, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより内部指図書詳細情報を検索します。
ArrayList | getAllowedBusTractList() 使用可能業務トランザクションのテーブルを取得します。
String | getLanguage() ステータスおよび業務トランザクションテキストの言語を取得します。
MasterData | getMasterData() 指図のマスタデータ構造を取得します。
String | getOrderid() 指図番号を取得します。
ArrayList | getSystemStatusList() システムステータステーブルを取得します。
ArrayList | getUserStatusList() ユーザステータス/指図ステータステーブルを取得します。
void | setAllowedBusTractList(ArrayList allowedBusTractList) 使用可能業務トランザクションのテーブルを設定します。
void | setExportParam(BapiController bapiController) 内部指図書詳細情報ををセットします。
void | setImportParam(BapiController bapiController) 内部指図書詳細情報を検索する条件ををセットします。
void | setLanguage(String strLanguage) ステータスおよび業務トランザクションテキストの言語を設定します。
void | setMasterData(MasterData masterData) 指図のマスタデータ構造を設定します。
void | setOrderid(String strOrderid) 指図番号を設定します。
void | setSystemStatusList(ArrayList systemStatusList) システムステータステーブルを設定します。
void | setUserStatusList(ArrayList userStatusList) ユーザステータス/指図ステータステーブルを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternalOrderGetDetail

public InternalOrderGetDetail(SapClient sapClient)
内部指図書詳細情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

InternalOrderGetDetail

public InternalOrderGetDetail(String orderId,
                              String language,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPFinancialAppException,
                              SAPFinancialSystemException
パラメータ:
orderId - 指図番号
language - ステータス及び業務トランザクションテキストの言語
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより内部指図書詳細情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
内部指図書詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
内部指図書詳細情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setLanguage

public void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。

パラメータ:
strLanguage - ステータスおよび業務トランザクションテキストの言語

setMasterData

public void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。

パラメータ:
masterData - 指図のマスタデータ構造

setSystemStatusList

public void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。

パラメータ:
systemStatusList - システムステータステーブル

setUserStatusList

public void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。

パラメータ:
userStatusList - ユーザステータス/指図ステータステーブル

setAllowedBusTractList

public void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。

パラメータ:
allowedBusTractList - 使用可能業務トランザクションのテーブル

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getLanguage

public String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。

戻り値:
srtLanguage ステータスおよび業務トランザクションテキストの言語

getMasterData

public MasterData getMasterData()
指図のマスタデータ構造を取得します。

戻り値:
masterData 指図のマスタデータ構造

getSystemStatusList

public ArrayList getSystemStatusList()
システムステータステーブルを取得します。

戻り値:
systemStatusList システムステータステーブル

getUserStatusList

public ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。

戻り値:
userStatusList ユーザステータス/指図ステータステーブル

getAllowedBusTractList

public ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。

戻り値:
allowedBusTractList 使用可能業務トランザクションのテーブル

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController
すべての実装インタフェース:
Serializable
public class InternalOrderGetDetailController
extends Object
implements Serializable

内部指図書詳細コントローラクラス
機能は以下の通り

  • 内部指図書詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
InternalOrderGetDetailController()
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(String orderid, String language)
InternalOrderGetDetailController(String orderid, String language, SapClient sapClient)
メソッドの概要
 void executeBapi()
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
 ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。
 String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。
 MasterData getMasterData()
指図のマスタデータ構造を取得します。
 String getOrderid()
指図番号を取得します。
 ArrayList getSystemStatusList()
システムステータステーブルを取得します。
 ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。
 void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。
 void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。
 void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。
 void setOrderid(String strOrderid)
指図番号を設定します。
 void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。
 void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InternalOrderGetDetailController

public InternalOrderGetDetailController(String orderid,
                                        String language)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPFinancialAppException,
                                        SAPFinancialSystemException
パラメータ:
orderid - 指図番号
language - ステータスおよび業務トランザクションテキストの言語
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetDetailController

public InternalOrderGetDetailController(String orderid,
                                        String language,
                                        SapClient sapClient)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPFinancialAppException,
                                        SAPFinancialSystemException
パラメータ:
orderid - 指図番号
language - ステータスおよび業務トランザクションテキストの言語
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetDetailController

public InternalOrderGetDetailController()
InternalOrderGetDetailControllerのコンストラクタを生成します。

InternalOrderGetDetailController

public InternalOrderGetDetailController(SapClient sapClient)
InternalOrderGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setLanguage

public void setLanguage(String strLanguage)
ステータスおよび業務トランザクションテキストの言語を設定します。

パラメータ:
strLanguage - ステータスおよび業務トランザクションテキストの言語

setMasterData

public void setMasterData(MasterData masterData)
指図のマスタデータ構造を設定します。

パラメータ:
masterData - 指図のマスタデータ構造

setSystemStatusList

public void setSystemStatusList(ArrayList systemStatusList)
システムステータステーブルを設定します。

パラメータ:
systemStatusList - システムステータステーブル

setUserStatusList

public void setUserStatusList(ArrayList userStatusList)
ユーザステータス/指図ステータステーブルを設定します。

パラメータ:
userStatusList - ユーザステータス/指図ステータステーブル

setAllowedBusTractList

public void setAllowedBusTractList(ArrayList allowedBusTractList)
使用可能業務トランザクションのテーブルを設定します。

パラメータ:
allowedBusTractList - 使用可能業務トランザクションのテーブル

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getLanguage

public String getLanguage()
ステータスおよび業務トランザクションテキストの言語を取得します。

戻り値:
srtLanguage ステータスおよび業務トランザクションテキストの言語

getMasterData

public MasterData getMasterData()
指図のマスタデータ構造を取得します。

戻り値:
masterData 指図のマスタデータ構造

getSystemStatusList

public ArrayList getSystemStatusList()
システムステータステーブルを取得します。

戻り値:
systemStatusList システムステータステーブル

getUserStatusList

public ArrayList getUserStatusList()
ユーザステータス/指図ステータステーブルを取得します。

戻り値:
userStatusList ユーザステータス/指図ステータステーブル

getAllowedBusTractList

public ArrayList getAllowedBusTractList()
使用可能業務トランザクションのテーブルを取得します。

戻り値:
allowedBusTractList 使用可能業務トランザクションのテーブル
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList
すべての実装インタフェース:
Serializable
public class InternalOrderGetList
extends ReferenceController
implements Serializable

内部指図書（一覧）情報取得クラス
機能は以下の通り

  • 内部指図書（一覧）情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
メソッドの概要
void | executeBapi() BapiControllerにより内部指図書（一覧）情報を検索します。
String | getControllingArea() 管理領域を取得します。
String | getOrder() 指図番号 (個別値、または下限値)を取得します。
String | getOrderExternalNo() 外部指図番号 (個別値、または下限値)を取得します。
String | getOrderExternalNoTo() 外部指図番号 (上限値)を取得します。
ArrayList | getOrderListList() 選択指図一覧を取得します。
String | getOrderTo() 指図番号 (上限値)を取得します。
String | getOrderType() 指図タイプを取得します。
String | getRespCostCenter() 責任原価センタを取得します。
void | setControllingArea(String strControllingArea) 管理領域を設定します。
void | setExportParam(BapiController bapiController) 内部指図書（一覧）情報ををセットします。
void | setImportParam(BapiController bapiController) 内部指図書（一覧）情報を検索する条件ををセットします。
void | setOrder(String strOrder) 指図番号 (個別値、または下限値)を設定します。
void | setOrderExternalNo(String strOrderExternalNo) 外部指図番号 (個別値、または下限値)を設定します。
void | setOrderExternalNoTo(String strOrderExternalNoTo) 外部指図番号 (上限値)を設定します。
void | setOrderListList(ArrayList orderListList) 選択指図一覧を設定します。
void | setOrderTo(String strOrderTo) 指図番号 (上限値)を設定します。
void | setOrderType(String strOrderType) 指図タイプを設定します。
void | setRespCostCenter(String strRespCostCenter) 責任原価センタを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternalOrderGetList

public InternalOrderGetList(SapClient sapClient)
内部指図書（一覧）情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト

InternalOrderGetList

public InternalOrderGetList(String controllingArea,
                            String respCostCenter,
                            String orderType,
                            String order,
                            String orderTo,
                            String orderExternalNo,
                            String orderExternalNoTo,
                            SapClient sapClient)
                     throws SAPAuthAppException,
                            SAPAuthSystemException,
                            SAPGeneralAppException,
                            SAPGeneralSystemException,
                            SAPFinancialAppException,
                            SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより内部指図書（一覧）情報を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
内部指図書（一覧）情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
内部指図書（一覧）情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setRespCostCenter

public void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。

パラメータ:
strRespCostCenter - 責任原価センタ

setOrderType

public void setOrderType(String strOrderType)
指図タイプを設定します。

パラメータ:
strOrderType - 指図タイプ

setOrder

public void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrder - 指図番号 (個別値、または下限値)

setOrderTo

public void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。

パラメータ:
strOrderTo - 指図番号 (上限値)

setOrderExternalNo

public void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrderExternalNo - 外部指図番号 (個別値、または下限値)

setOrderExternalNoTo

public void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。

パラメータ:
strOrderExternalNoTo - 外部指図番号 (上限値)

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getRespCostCenter

public String getRespCostCenter()
責任原価センタを取得します。

戻り値:
srtRespCostCenter 責任原価センタ

getOrderType

public String getOrderType()
指図タイプを取得します。

戻り値:
srtOrderType 指図タイプ

getOrder

public String getOrder()
指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrder 指図番号 (個別値、または下限値)

getOrderTo

public String getOrderTo()
指図番号 (上限値)を取得します。

戻り値:
srtOrderTo 指図番号 (上限値)

getOrderExternalNo

public String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrderExternalNo 外部指図番号 (個別値、または下限値)

getOrderExternalNoTo

public String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。

戻り値:
srtOrderExternalNoTo 外部指図番号 (上限値)

setOrderListList

public void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。

パラメータ:
orderListList - 選択指図一覧

getOrderListList

public ArrayList getOrderListList()
選択指図一覧を取得します。

戻り値:
orderListList 選択指図一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternalOrderGetListController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス InternalOrderGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController
すべての実装インタフェース:
Serializable
public class InternalOrderGetListController
extends Object
implements Serializable

内部指図書一覧コントローラクラス
機能は以下の通り

  • 内部指図書一覧を取得します。

関連項目:
直列化された形式

コンストラクタの概要
InternalOrderGetListController()
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo)
InternalOrderGetListController(String controllingArea, String respCostCenter, String orderType, String order, String orderTo, String orderExternalNo, String orderExternalNoTo, SapClient sapClient)
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
 String getControllingArea()
管理領域を取得します。
 String getOrder()
指図番号 (個別値、または下限値)を取得します。
 String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。
 String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。
 ArrayList getOrderListList()
選択指図一覧を取得します。
 String getOrderTo()
指図番号 (上限値)を取得します。
 String getOrderType()
指図タイプを取得します。
 String getRespCostCenter()
責任原価センタを取得します。
 void setControllingArea(String strControllingArea)
管理領域を設定します。
 void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。
 void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。
 void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。
 void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。
 void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。
 void setOrderType(String strOrderType)
指図タイプを設定します。
 void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

InternalOrderGetListController

public InternalOrderGetListController(String controllingArea,
                                      String respCostCenter,
                                      String orderType,
                                      String order,
                                      String orderTo,
                                      String orderExternalNo,
                                      String orderExternalNoTo)
                               throws SAPAuthAppException,
                                      SAPAuthSystemException,
                                      SAPGeneralAppException,
                                      SAPGeneralSystemException,
                                      SAPFinancialAppException,
                                      SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetListController

public InternalOrderGetListController(String controllingArea,
                                      String respCostCenter,
                                      String orderType,
                                      String order,
                                      String orderTo,
                                      String orderExternalNo,
                                      String orderExternalNoTo,
                                      SapClient sapClient)
                               throws SAPAuthAppException,
                                      SAPAuthSystemException,
                                      SAPGeneralAppException,
                                      SAPGeneralSystemException,
                                      SAPFinancialAppException,
                                      SAPFinancialSystemException
パラメータ:
controllingArea - 管理領域
respCostCenter - 責任原価センタ
orderType - 指図タイプ
order - 指図番号 (個別値、または下限値)
orderTo - 指図番号 (上限値)
orderExternalNo - 外部指図番号 (個別値、または下限値)
orderExternalNoTo - 外部指図番号 (上限値)
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

InternalOrderGetListController

public InternalOrderGetListController()
InternalOrderGetListControllerのコンストラクタを生成します。

InternalOrderGetListController

public InternalOrderGetListController(SapClient sapClient)
InternalOrderGetListControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計系APIアプリケーション例外
SAPFinancialSystemException - 会計系APIシステム例外

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setRespCostCenter

public void setRespCostCenter(String strRespCostCenter)
責任原価センタを設定します。

パラメータ:
strRespCostCenter - 責任原価センタ

setOrderType

public void setOrderType(String strOrderType)
指図タイプを設定します。

パラメータ:
strOrderType - 指図タイプ

setOrder

public void setOrder(String strOrder)
指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrder - 指図番号 (個別値、または下限値)

setOrderTo

public void setOrderTo(String strOrderTo)
指図番号 (上限値)を設定します。

パラメータ:
strOrderTo - 指図番号 (上限値)

setOrderExternalNo

public void setOrderExternalNo(String strOrderExternalNo)
外部指図番号 (個別値、または下限値)を設定します。

パラメータ:
strOrderExternalNo - 外部指図番号 (個別値、または下限値)

setOrderExternalNoTo

public void setOrderExternalNoTo(String strOrderExternalNoTo)
外部指図番号 (上限値)を設定します。

パラメータ:
strOrderExternalNoTo - 外部指図番号 (上限値)

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getRespCostCenter

public String getRespCostCenter()
責任原価センタを取得します。

戻り値:
srtRespCostCenter 責任原価センタ

getOrderType

public String getOrderType()
指図タイプを取得します。

戻り値:
srtOrderType 指図タイプ

getOrder

public String getOrder()
指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrder 指図番号 (個別値、または下限値)

getOrderTo

public String getOrderTo()
指図番号 (上限値)を取得します。

戻り値:
srtOrderTo 指図番号 (上限値)

getOrderExternalNo

public String getOrderExternalNo()
外部指図番号 (個別値、または下限値)を取得します。

戻り値:
srtOrderExternalNo 外部指図番号 (個別値、または下限値)

getOrderExternalNoTo

public String getOrderExternalNoTo()
外部指図番号 (上限値)を取得します。

戻り値:
srtOrderExternalNoTo 外部指図番号 (上限値)

setOrderListList

public void setOrderListList(ArrayList orderListList)
選択指図一覧を設定します。

パラメータ:
orderListList - 選択指図一覧

getOrderListList

public ArrayList getOrderListList()
選択指図一覧を取得します。

戻り値:
orderListList 選択指図一覧
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MasterData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス MasterData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.MasterData
すべての実装インタフェース:
Serializable
public class MasterData
extends Object
implements Serializable

指図のマスタデータ構造情報クラス 機能は以下の通り

  • 指図のマスタデータ構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MasterData()
指図のマスタデータ構造を作成します。
メソッドの概要
String | getApplicant() 申請者を取得します。
String | getApplicantPhone() 申請者の電話番号を取得します。
String | getApplicationDate() 申請日を取得します。
String | getBusArea() 事業領域を取得します。
String | getCctrPosted() 原価が実際に転記された原価センタを取得します。
String | getCoArea() 管理領域を取得します。
String | getCompCode() 会社コードを取得します。
String | getCstgSheet() 原価計算表を取得します。
String | getCurrency() 購買発注通貨を取得します。
String | getDateWorkBegins() 作業開始を取得します。
String | getDateWorkEnds() 作業終了を取得します。
String | getDepartment() 部署を取得します。
String | getEstimatedCosts() 指図の見積原価合計を取得します。
String | getExtOrdNo() 外部指図番号を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getInterestProf() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getObjectNo() 対象番号を取得します。
String | getOrder() 指図番号を取得します。
String | getOrderName() テキストを取得します。
String | getOrderType() 販売伝票タイプを取得します。
String | getOverheadKey() 間接費キーを取得します。
String | getPersonResp() 責任者を取得します。
String | getPersonRespPhone() 責任者の電話番号を取得します。
String | getPlant() プラントを取得します。
String | getPlnClose() 計画終了日付を取得します。
String | getPlnCompletion() 計画完了日を取得します。
String | getPlnRelease() 計画リリース日付を取得します。
String | getProcessingGroup() 処理グループを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getRequCompCode() 会社コード要求を取得します。
String | getRequestCctr() 申請原価センタを取得します。
String | getRequestOrder() 申請指図を取得します。
String | getResAnalKey() 結果分析キーを取得します。
String | getRespcctr() 責任原価センタを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getWbsElem() 作業詳細項目要素 (WBS 要素)を取得します。
String | getWbsElementExt() WBS 要素を取得します。
String | getWorkPermit() 仕事許可済フラグを取得します。
void | setApplicant(String strApplicant) 申請者を設定します。
void | setApplicantPhone(String strApplicantPhone) 申請者の電話番号を設定します。
void | setApplicationDate(String strApplicationDate) 申請日を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCctrPosted(String strCctrPosted) 原価が実際に転記された原価センタを設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCstgSheet(String strCstgSheet) 原価計算表を設定します。
void | setCurrency(String strCurrency) 購買発注通貨を設定します。
void | setDateWorkBegins(String strDateWorkBegins) 作業開始を設定します。
void | setDateWorkEnds(String strDateWorkEnds) 作業終了を設定します。
void | setDepartment(String strDepartment) 部署を設定します。
void | setEstimatedCosts(String strEstimatedCosts) 指図の見積原価合計を設定します。
void | setExtOrdNo(String strExtOrdNo) 外部指図番号を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setInterestProf(String strInterestProf) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setObjectNo(String strObjectNo) 対象番号を設定します。
void | setOrder(String strOrder) 指図番号を設定します。
void | setOrderName(String strOrderName) テキストを設定します。
void | setOrderType(String strOrderType) 販売伝票タイプを設定します。
void | setOverheadKey(String strOverheadKey) 間接費キーを設定します。
void | setPersonResp(String strPersonResp) 責任者を設定します。
void | setPersonRespPhone(String strPersonRespPhone) 責任者の電話番号を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPlnClose(String strPlnClose) 計画終了日付を設定します。
void | setPlnCompletion(String strPlnCompletion) 計画完了日を設定します。
void | setPlnRelease(String strPlnRelease) 計画リリース日付を設定します。
void | setProcessingGroup(String strProcessingGroup) 処理グループを設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setRequCompCode(String strRequCompCode) 会社コード要求を設定します。
void | setRequestCctr(String strRequestCctr) 申請原価センタを設定します。
void | setRequestOrder(String strRequestOrder) 申請指図を設定します。
void | setResAnalKey(String strResAnalKey) 結果分析キーを設定します。
void | setRespcctr(String strRespcctr) 責任原価センタを設定します。
void | setSalesOrd(String strSalesOrd) 受注伝票番号を設定します。
void | setSOrdItem(String strSOrdItem) 受注明細番号を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setWbsElem(String strWbsElem) 作業詳細項目要素 (WBS 要素)を設定します。
void | setWbsElementExt(String strWbsElementExt) WBS 要素を設定します。
void | setWorkPermit(String strWorkPermit) 仕事許可済フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MasterData

public MasterData()
指図のマスタデータ構造を作成します。

メソッドの詳細

getOrder

public String getOrder()
指図番号を取得します。

戻り値:
srtOrder 指図番号

getOrderType

public String getOrderType()
販売伝票タイプを取得します。

戻り値:
srtOrderType 販売伝票タイプ

getOrderName

public String getOrderName()
テキストを取得します。

戻り値:
srtOrderName テキスト

getExtOrdNo

public String getExtOrdNo()
外部指図番号を取得します。

戻り値:
srtExtOrdNo 外部指図番号

getObjectNo

public String getObjectNo()
対象番号を取得します。

戻り値:
srtObjectNo 対象番号

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getRespcctr

public String getRespcctr()
責任原価センタを取得します。

戻り値:
srtRespcctr 責任原価センタ

getWbsElem

public String getWbsElem()
作業詳細項目要素 (WBS 要素)を取得します。

戻り値:
srtWbsElem 作業詳細項目要素 (WBS 要素)

getWbsElementExt

public String getWbsElementExt()
WBS 要素を取得します。

戻り値:
srtWbsElementExt WBS 要素

getRequestCctr

public String getRequestCctr()
申請原価センタを取得します。

戻り値:
srtRequestCctr 申請原価センタ

getRequCompCode

public String getRequCompCode()
会社コード要求を取得します。

戻り値:
srtRequCompCode 会社コード要求

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
srtSalesOrd 受注伝票番号

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
srtSOrdItem 受注明細番号

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getCctrPosted

public String getCctrPosted()
原価が実際に転記された原価センタを取得します。

戻り値:
srtCctrPosted 原価が実際に転記された原価センタ

getCurrency

public String getCurrency()
購買発注通貨を取得します。

戻り値:
srtCurrency 購買発注通貨

getCstgSheet

public String getCstgSheet()
原価計算表を取得します。

戻り値:
srtCstgSheet 原価計算表

getOverheadKey

public String getOverheadKey()
間接費キーを取得します。

戻り値:
srtOverheadKey 間接費キー

getResAnalKey

public String getResAnalKey()
結果分析キーを取得します。

戻り値:
srtResAnalKey 結果分析キー

getInterestProf

public String getInterestProf()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtInterestProf プロジェクト/指図金利計算の金利プロファイル

getApplicant

public String getApplicant()
申請者を取得します。

戻り値:
srtApplicant 申請者

getApplicantPhone

public String getApplicantPhone()
申請者の電話番号を取得します。

戻り値:
srtApplicantPhone 申請者の電話番号

getPersonResp

public String getPersonResp()
責任者を取得します。

戻り値:
srtPersonResp 責任者

getPersonRespPhone

public String getPersonRespPhone()
責任者の電話番号を取得します。

戻り値:
srtPersonRespPhone 責任者の電話番号

getEstimatedCosts

public String getEstimatedCosts()
指図の見積原価合計を取得します。

戻り値:
srtEstimatedCosts 指図の見積原価合計

getApplicationDate

public String getApplicationDate()
申請日を取得します。

戻り値:
srtApplicationDate 申請日

getDepartment

public String getDepartment()
部署を取得します。

戻り値:
srtDepartment 部署

getDateWorkBegins

public String getDateWorkBegins()
作業開始を取得します。

戻り値:
srtDateWorkBegins 作業開始

getDateWorkEnds

public String getDateWorkEnds()
作業終了を取得します。

戻り値:
srtDateWorkEnds 作業終了

getWorkPermit

public String getWorkPermit()
仕事許可済フラグを取得します。

戻り値:
srtWorkPermit 仕事許可済フラグ

getProcessingGroup

public String getProcessingGroup()
処理グループを取得します。

戻り値:
srtProcessingGroup 処理グループ

getPlnRelease

public String getPlnRelease()
計画リリース日付を取得します。

戻り値:
srtPlnRelease 計画リリース日付

getPlnCompletion

public String getPlnCompletion()
計画完了日を取得します。

戻り値:
srtPlnCompletion 計画完了日

getPlnClose

public String getPlnClose()
計画終了日付を取得します。

戻り値:
srtPlnClose 計画終了日付

getRequestOrder

public String getRequestOrder()
申請指図を取得します。

戻り値:
srtRequestOrder 申請指図

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setOrder

public void setOrder(String strOrder)
指図番号を設定します。

パラメータ:
strOrder - 指図番号

setOrderType

public void setOrderType(String strOrderType)
販売伝票タイプを設定します。

パラメータ:
strOrderType - 販売伝票タイプ

setOrderName

public void setOrderName(String strOrderName)
テキストを設定します。

パラメータ:
strOrderName - テキスト

setExtOrdNo

public void setExtOrdNo(String strExtOrdNo)
外部指図番号を設定します。

パラメータ:
strExtOrdNo - 外部指図番号

setObjectNo

public void setObjectNo(String strObjectNo)
対象番号を設定します。

パラメータ:
strObjectNo - 対象番号

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setRespcctr

public void setRespcctr(String strRespcctr)
責任原価センタを設定します。

パラメータ:
strRespcctr - 責任原価センタ

setWbsElem

public void setWbsElem(String strWbsElem)
作業詳細項目要素 (WBS 要素)を設定します。

パラメータ:
strWbsElem - 作業詳細項目要素 (WBS 要素)

setWbsElementExt

public void setWbsElementExt(String strWbsElementExt)
WBS 要素を設定します。

パラメータ:
strWbsElementExt - WBS 要素

setRequestCctr

public void setRequestCctr(String strRequestCctr)
申請原価センタを設定します。

パラメータ:
strRequestCctr - 申請原価センタ

setRequCompCode

public void setRequCompCode(String strRequCompCode)
会社コード要求を設定します。

パラメータ:
strRequCompCode - 会社コード要求

setSalesOrd

public void setSalesOrd(String strSalesOrd)
受注伝票番号を設定します。

パラメータ:
strSalesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String strSOrdItem)
受注明細番号を設定します。

パラメータ:
strSOrdItem - 受注明細番号

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setCctrPosted

public void setCctrPosted(String strCctrPosted)
原価が実際に転記された原価センタを設定します。

パラメータ:
strCctrPosted - 原価が実際に転記された原価センタ

setCurrency

public void setCurrency(String strCurrency)
購買発注通貨を設定します。

パラメータ:
strCurrency - 購買発注通貨

setCstgSheet

public void setCstgSheet(String strCstgSheet)
原価計算表を設定します。

パラメータ:
strCstgSheet - 原価計算表

setOverheadKey

public void setOverheadKey(String strOverheadKey)
間接費キーを設定します。

パラメータ:
strOverheadKey - 間接費キー

setResAnalKey

public void setResAnalKey(String strResAnalKey)
結果分析キーを設定します。

パラメータ:
strResAnalKey - 結果分析キー

setInterestProf

public void setInterestProf(String strInterestProf)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strInterestProf - プロジェクト/指図金利計算の金利プロファイル

setApplicant

public void setApplicant(String strApplicant)
申請者を設定します。

パラメータ:
strApplicant - 申請者

setApplicantPhone

public void setApplicantPhone(String strApplicantPhone)
申請者の電話番号を設定します。

パラメータ:
strApplicantPhone - 申請者の電話番号

setPersonResp

public void setPersonResp(String strPersonResp)
責任者を設定します。

パラメータ:
strPersonResp - 責任者

setPersonRespPhone

public void setPersonRespPhone(String strPersonRespPhone)
責任者の電話番号を設定します。

パラメータ:
strPersonRespPhone - 責任者の電話番号

setEstimatedCosts

public void setEstimatedCosts(String strEstimatedCosts)
指図の見積原価合計を設定します。

パラメータ:
strEstimatedCosts - 指図の見積原価合計

setApplicationDate

public void setApplicationDate(String strApplicationDate)
申請日を設定します。

パラメータ:
strApplicationDate - 申請日

setDepartment

public void setDepartment(String strDepartment)
部署を設定します。

パラメータ:
strDepartment - 部署

setDateWorkBegins

public void setDateWorkBegins(String strDateWorkBegins)
作業開始を設定します。

パラメータ:
strDateWorkBegins - 作業開始

setDateWorkEnds

public void setDateWorkEnds(String strDateWorkEnds)
作業終了を設定します。

パラメータ:
strDateWorkEnds - 作業終了

setWorkPermit

public void setWorkPermit(String strWorkPermit)
仕事許可済フラグを設定します。

パラメータ:
strWorkPermit - 仕事許可済フラグ

setProcessingGroup

public void setProcessingGroup(String strProcessingGroup)
処理グループを設定します。

パラメータ:
strProcessingGroup - 処理グループ

setPlnRelease

public void setPlnRelease(String strPlnRelease)
計画リリース日付を設定します。

パラメータ:
strPlnRelease - 計画リリース日付

setPlnCompletion

public void setPlnCompletion(String strPlnCompletion)
計画完了日を設定します。

パラメータ:
strPlnCompletion - 計画完了日

setPlnClose

public void setPlnClose(String strPlnClose)
計画終了日付を設定します。

パラメータ:
strPlnClose - 計画終了日付

setRequestOrder

public void setRequestOrder(String strRequestOrder)
申請指図を設定します。

パラメータ:
strRequestOrder - 申請指図

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


OrderList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス OrderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.OrderList
すべての実装インタフェース:
Serializable
public class OrderList
extends Object
implements Serializable

選択指図一覧情報クラス 機能は以下の通り

  • 選択指図一覧情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
OrderList()
選択指図一覧を作成します。
メソッドの概要
String | getObjectNo() 対象番号を取得します。
String | getOrder() 指図番号を取得します。
String | getOrderName() テキストを取得します。
String | getOrderType() 販売伝票タイプを取得します。
void | setObjectNo(String strObjectNo) 対象番号を設定します。
void | setOrder(String strOrder) 指図番号を設定します。
void | setOrderName(String strOrderName) テキストを設定します。
void | setOrderType(String strOrderType) 販売伝票タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

OrderList

public OrderList()
選択指図一覧を作成します。

メソッドの詳細

getOrder

public String getOrder()
指図番号を取得します。

戻り値:
srtOrder 指図番号

getObjectNo

public String getObjectNo()
対象番号を取得します。

戻り値:
srtObjectNo 対象番号

getOrderType

public String getOrderType()
販売伝票タイプを取得します。

戻り値:
srtOrderType 販売伝票タイプ

getOrderName

public String getOrderName()
テキストを取得します。

戻り値:
srtOrderName テキスト

setOrder

public void setOrder(String strOrder)
指図番号を設定します。

パラメータ:
strOrder - 指図番号

setObjectNo

public void setObjectNo(String strObjectNo)
対象番号を設定します。

パラメータ:
strObjectNo - 対象番号

setOrderType

public void setOrderType(String strOrderType)
販売伝票タイプを設定します。

パラメータ:
strOrderType - 販売伝票タイプ

setOrderName

public void setOrderName(String strOrderName)
テキストを設定します。

パラメータ:
strOrderName - テキスト

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.financial (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.financial
クラス
AllowedBusTract
CommonCenterGrpGetDetail
CostCenterGroupGetDetail
CostCenterGroupGetDetailController
CreditorGetDetail
CreditorGetDetailController
DebtorGetDetail
DebtorGetDetailController
ExchangeRateGetDetail
ExchangeRateGetDetailController
ExchRate
ExpActivity
ExpMessage
ExpWbsElement
ExpWbsHierarchie
ExpWbsMilestone
HierarchyNodes
HierarchyValues
ImpWbsElement
InternalOrderGetDetail
InternalOrderGetDetailController
InternalOrderGetList
InternalOrderGetListController
MasterData
OrderList
ProfitCenterGrpGetDetail
ProfitCenterGrpGetDetailController
ProjectDefinition
ProjectGetInfo
ProjectGetInfoController
SystemStatus
UserStatus


jp.co.intra_mart.foundation.sap.module.financial (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial

ＳＡＰ連携管理会計系に関するクラスを提供します。

参照:
説明

クラスの概要
AllowedBusTract | 使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り 使用可能業務トランザクションのテーブル情報を保持します。
CommonCenterGrpGetDetail | 原価・利益センタグループ情報取得共通クラス 機能は以下の通り 原価・利益センタグループ情報を取得します。
CostCenterGroupGetDetail | 原価センタグループ情報取得クラス 機能は以下の通り 原価センタグループ情報を取得します。
CostCenterGroupGetDetailController | 原価センタグループコントローラクラス 機能は以下の通り 原価センタグループを取得します。
CreditorGetDetail | 仕入先詳細情報取得クラス 機能は以下の通り 仕入先詳細情報を取得します。
CreditorGetDetailController | 仕入先詳細コントローラクラス 機能は以下の通り 仕入先詳細を取得します。
DebtorGetDetail | 得意先詳細情報取得クラス 機能は以下の通り 得意先詳細情報を取得します。
DebtorGetDetailController | 得意先詳細コントローラクラス 機能は以下の通り 得意先詳細を取得します。
ExchangeRateGetDetail | 為替換算レート情報取得クラス 機能は以下の通り 為替換算レート情報を取得します。
ExchangeRateGetDetailController | 為替換算レートコントローラクラス 機能は以下の通り 為替換算レートを取得します。
ExchRate | 換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り 換算レート、係数 (通貨ペア)情報を保持します。
ExpActivity | 活動に関する詳細情報クラス 機能は以下の通り 活動に関する詳細情報を保持します。
ExpMessage | 詳細情報を読み込みエラー情報クラス 機能は以下の通り 詳細情報を読み込みエラー情報を保持します。
ExpWbsElement | WBS 要素についての詳細情報クラス 機能は以下の通り WBS 要素についての詳細情報を保持します。
ExpWbsHierarchie | WBS 階層についての情報クラス 機能は以下の通り WBS 階層についての情報を保持します。
ExpWbsMilestone | WBS マイルストーンに関する詳細情報クラス 機能は以下の通り WBS マイルストーンに関する詳細情報を保持します。
HierarchyNodes | 階層ノード情報クラス 機能は以下の通り 階層ノード情報を保持します。
HierarchyValues | 階層値情報クラス 機能は以下の通り 階層値情報を保持します。
ImpWbsElement | 詳細情報を必要とする WBS 要素クラス 機能は以下の通り 詳細情報を必要とする WBS 要素を保持します。
InternalOrderGetDetail | 内部指図書詳細情報取得クラス 機能は以下の通り 内部指図書詳細情報を取得します。
InternalOrderGetDetailController | 内部指図書詳細コントローラクラス 機能は以下の通り 内部指図書詳細を取得します。
InternalOrderGetList | 内部指図書（一覧）情報取得クラス 機能は以下の通り 内部指図書（一覧）情報を取得します。
InternalOrderGetListController | 内部指図書一覧コントローラクラス 機能は以下の通り 内部指図書一覧を取得します。
MasterData | 指図のマスタデータ構造情報クラス 機能は以下の通り 指図のマスタデータ構造情報を保持します。
OrderList | 選択指図一覧情報クラス 機能は以下の通り 選択指図一覧情報を保持します。
ProfitCenterGrpGetDetail | 利益センタグループ情報取得クラス 機能は以下の通り 利益センタグループ情報を取得します。
ProfitCenterGrpGetDetailController | 利益センタグループコントローラクラス 機能は以下の通り 利益センタグループを取得します。
ProjectDefinition | プロジェクトについての詳細情報クラス 機能は以下の通り プロジェクトについての詳細情報を保持します。
ProjectGetInfo | WBS情報取得クラス 機能は以下の通り WBS情報を取得します。
ProjectGetInfoController | WBSの詳細コントローラクラス 機能は以下の通り WBSの詳細を取得します。
SystemStatus | システムステータステーブル情報クラス 機能は以下の通り システムステータステーブル情報を保持します。
UserStatus | ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り ユーザステータス/指図ステータステーブル情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.financial の説明

ＳＡＰ連携管理会計系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.financial クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.financial の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchRate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.MasterData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.OrderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.UserStatus (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.financial の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.financial の使用

jp.co.intra_mart.foundation.sap.module.financial を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.financial ＳＡＰ連携管理会計系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module.financial のクラス
CommonCenterGrpGetDetail
原価・利益センタグループ情報取得共通クラス
機能は以下の通り
原価・利益センタグループ情報を取得します。
CreditorGetDetail
仕入先詳細情報取得クラス
機能は以下の通り
仕入先詳細情報を取得します。
DebtorGetDetail
得意先詳細情報取得クラス
機能は以下の通り
得意先詳細情報を取得します。
ExchRate
換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り
換算レート、係数 (通貨ペア)情報を保持します。
MasterData
指図のマスタデータ構造情報クラス 機能は以下の通り
指図のマスタデータ構造情報を保持します。
ProjectDefinition
プロジェクトについての詳細情報クラス 機能は以下の通り
プロジェクトについての詳細情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProfitCenterGrpGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProfitCenterGrpGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail
                拡張 jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail
すべての実装インタフェース:
Serializable
public class ProfitCenterGrpGetDetail
extends CommonCenterGrpGetDetail
implements Serializable

利益センタグループ情報取得クラス
機能は以下の通り

  • 利益センタグループ情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
BapiControllerにより利益センタグループ検索を検索します。
クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail から継承したメソッド
getControllingarea, getGroupname, getHierarchyNodesList, getHierarchyValuesList, setControllingarea, setExportParam, setGroupname, setHierarchyNodesList, setHierarchyValuesList, setImportParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterGrpGetDetail

public ProfitCenterGrpGetDetail(SapClient sapClient)
利益センタグループ情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト

ProfitCenterGrpGetDetail

public ProfitCenterGrpGetDetail(String controllingarea,
                                String groupname,
                                SapClient sapClient)
                         throws SAPAuthAppException,
                                SAPAuthSystemException,
                                SAPGeneralAppException,
                                SAPGeneralSystemException,
                                SAPFinancialAppException,
                                SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerにより利益センタグループ検索を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitCenterGrpGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProfitCenterGrpGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController
すべての実装インタフェース:
Serializable
public class ProfitCenterGrpGetDetailController
extends Object
implements Serializable

利益センタグループコントローラクラス
機能は以下の通り

  • 利益センタグループを取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitCenterGrpGetDetailController()
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(String controllingarea, String groupname)
ProfitCenterGrpGetDetailController(String controllingarea, String groupname, SapClient sapClient)
メソッドの概要
 void executeBapi()
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
 String getControllingarea()
管理領域を取得します。
 String getGroupname()
グループ名を取得します。
 ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。
 ArrayList getHierarchyValuesList()
階層値一覧を取得します。
 void setControllingarea(String strControllingarea)
管理領域を設定します。
 void setGroupname(String strGroupname)
グループ名を設定します。
 void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。
 void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(String controllingarea,
                                          String groupname)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(String controllingarea,
                                          String groupname,
                                          SapClient sapClient)
                                   throws SAPAuthAppException,
                                          SAPAuthSystemException,
                                          SAPGeneralAppException,
                                          SAPGeneralSystemException,
                                          SAPFinancialAppException,
                                          SAPFinancialSystemException
パラメータ:
controllingarea - 管理領域
groupname - グループ名
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController()
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。

ProfitCenterGrpGetDetailController

public ProfitCenterGrpGetDetailController(SapClient sapClient)
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報を格納したオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setControllingarea

public void setControllingarea(String strControllingarea)
管理領域を設定します。

パラメータ:
strControllingarea - 管理領域

setGroupname

public void setGroupname(String strGroupname)
グループ名を設定します。

パラメータ:
strGroupname - グループ名

getControllingarea

public String getControllingarea()
管理領域を取得します。

戻り値:
srtControllingarea 管理領域

getGroupname

public String getGroupname()
グループ名を取得します。

戻り値:
srtGroupname グループ名

setHierarchyNodesList

public void setHierarchyNodesList(ArrayList hierarchyNodesList)
階層ノード一覧を設定します。

パラメータ:
hierarchyNodesList - 階層ノード一覧

setHierarchyValuesList

public void setHierarchyValuesList(ArrayList hierarchyValuesList)
階層値一覧を設定します。

パラメータ:
hierarchyValuesList - 階層値一覧

getHierarchyNodesList

public ArrayList getHierarchyNodesList()
階層ノード一覧を取得します。

戻り値:
hierarchyNodesList 階層ノード一覧

getHierarchyValuesList

public ArrayList getHierarchyValuesList()
階層値一覧を取得します。

戻り値:
hierarchyValuesList 階層値一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectDefinition (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectDefinition

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition
すべての実装インタフェース:
Serializable
public class ProjectDefinition
extends Object
implements Serializable

プロジェクトについての詳細情報クラス 機能は以下の通り

  • プロジェクトについての詳細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProjectDefinition()
プロジェクトについての詳細情報を作成します。
メソッドの概要
String | getApplicantNo() 申請者番号を取得します。
String | getBudgetProfile() 予算プロファイルを取得します。
String | getBusArea() 事業領域を取得します。
String | getCalendar() 稼動日カレンダを取得します。
String | getCompCode() 会社コードを取得します。
String | getControllingArea() 管理領域を取得します。
String | getCshBdgtProfile() 資金計画プロファイルを取得します。
String | getDeletionFlag() 削除フラグを取得します。
String | getDescription() PS: テキスト(短)(第一テキスト行)を取得します。
String | getEquityType() 持分タイプを取得します。
String | getFinish() プロジェクトの計画終了日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getIntProfile() プロジェクト/指図金利計算の金利プロファイルを取得します。
String | getJointVenture() ジョイントベンチャを取得します。
String | getJvJibClass() JIB/JIBE クラスを取得します。
String | getJvJibSubClassA() JIB/JIBE サブクラスAを取得します。
String | getJvObjectType() ジョイントベンチャ対象タイプを取得します。
String | getMaskId() WBS 要素 ID(短)の選択マスクを取得します。
String | getNetworkAssignment() ネットワーク割当を取得します。
String | getNetworkProfile() ネットワークプロファイルを取得します。
String | getObjectclass() 対象クラスを取得します。
String | getObjectclassExt() オブジェクトクラス、言語依存を取得します。
String | getPlanBasic() プロジェクト基準日付計画方法を取得します。
String | getPlanFcst() プロジェクト予測日付の計画方法を取得します。
String | getPlanProfile() 計画プロファイルを取得します。
String | getPlant() プラントを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProjectCurrency() WBS 通貨(プロジェクト定義)を取得します。
String | getProjectCurrencyIso() ISO 通貨コードを取得します。
String | getProjectDefinition() プロジェクト定義を取得します。
String | getProjectProfile() プロジェクトプロファイルを取得します。
String | getProjectStock() プロジェクト在庫を取得します。
String | getRecoveryInd() リカバリフラグを取得します。
String | getResponsibleNo() 責任者番号 (プロジェクト責任者)を取得します。
String | getStart() プロジェクト計画開始日付を取得します。
String | getStatistical() 統計 WBS 要素を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTimeUnit() 時間計画単位を取得します。
String | getTimeUnitIso() 単位の ISO コードを取得します。
String | getWbsSchedProfile() WBS 日程計画のプロファイルを取得します。
void | setApplicantNo(String strApplicantNo) 申請者番号を設定します。
void | setBudgetProfile(String strBudgetProfile) 予算プロファイルを設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCalendar(String strCalendar) 稼動日カレンダを設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setControllingArea(String strControllingArea) 管理領域を設定します。
void | setCshBdgtProfile(String strCshBdgtProfile) 資金計画プロファイルを設定します。
void | setDeletionFlag(String strDeletionFlag) 削除フラグを設定します。
void | setDescription(String strDescription) PS: テキスト(短)(第一テキスト行)を設定します。
void | setEquityType(String strEquityType) 持分タイプを設定します。
void | setFinish(String strFinish) プロジェクトの計画終了日を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setIntProfile(String strIntProfile) プロジェクト/指図金利計算の金利プロファイルを設定します。
void | setJointVenture(String strJointVenture) ジョイントベンチャを設定します。
void | setJvJibClass(String strJvJibClass) JIB/JIBE クラスを設定します。
void | setJvJibSubClassA(String strJvJibSubClassA) JIB/JIBE サブクラスAを設定します。
void | setJvObjectType(String strJvObjectType) ジョイントベンチャ対象タイプを設定します。
void | setMaskId(String strMaskId) WBS 要素 ID(短)の選択マスクを設定します。
void | setNetworkAssignment(String strNetworkAssignment) ネットワーク割当を設定します。
void | setNetworkProfile(String strNetworkProfile) ネットワークプロファイルを設定します。
void | setObjectclass(String strObjectclass) 対象クラスを設定します。
void | setObjectclassExt(String strObjectclassExt) オブジェクトクラス、言語依存を設定します。
void | setPlanBasic(String strPlanBasic) プロジェクト基準日付計画方法を設定します。
void | setPlanFcst(String strPlanFcst) プロジェクト予測日付の計画方法を設定します。
void | setPlanProfile(String strPlanProfile) 計画プロファイルを設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setProjectCurrency(String strProjectCurrency) WBS 通貨(プロジェクト定義)を設定します。
void | setProjectCurrencyIso(String strProjectCurrencyIso) ISO 通貨コードを設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を設定します。
void | setProjectProfile(String strProjectProfile) プロジェクトプロファイルを設定します。
void | setProjectStock(String strProjectStock) プロジェクト在庫を設定します。
void | setRecoveryInd(String strRecoveryInd) リカバリフラグを設定します。
void | setResponsibleNo(String strResponsibleNo) 責任者番号 (プロジェクト責任者)を設定します。
void | setStart(String strStart) プロジェクト計画開始日付を設定します。
void | setStatistical(String strStatistical) 統計 WBS 要素を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTimeUnit(String strTimeUnit) 時間計画単位を設定します。
void | setTimeUnitIso(String strTimeUnitIso) 単位の ISO コードを設定します。
void | setWbsSchedProfile(String strWbsSchedProfile) WBS 日程計画のプロファイルを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProjectDefinition

public ProjectDefinition()
プロジェクトについての詳細情報を作成します。

メソッドの詳細

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を取得します。

戻り値:
srtProjectDefinition プロジェクト定義

getDescription

public String getDescription()
PS: テキスト(短)(第一テキスト行)を取得します。

戻り値:
srtDescription PS: テキスト(短)(第一テキスト行)

getMaskId

public String getMaskId()
WBS 要素 ID(短)の選択マスクを取得します。

戻り値:
srtMaskId WBS 要素 ID(短)の選択マスク

getResponsibleNo

public String getResponsibleNo()
責任者番号 (プロジェクト責任者)を取得します。

戻り値:
srtResponsibleNo 責任者番号 (プロジェクト責任者)

getApplicantNo

public String getApplicantNo()
申請者番号を取得します。

戻り値:
srtApplicantNo 申請者番号

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
srtCompCode 会社コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getControllingArea

public String getControllingArea()
管理領域を取得します。

戻り値:
srtControllingArea 管理領域

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getProjectCurrency

public String getProjectCurrency()
WBS 通貨(プロジェクト定義)を取得します。

戻り値:
srtProjectCurrency WBS 通貨(プロジェクト定義)

getProjectCurrencyIso

public String getProjectCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
srtProjectCurrencyIso ISO 通貨コード

getNetworkAssignment

public String getNetworkAssignment()
ネットワーク割当を取得します。

戻り値:
srtNetworkAssignment ネットワーク割当

getStart

public String getStart()
プロジェクト計画開始日付を取得します。

戻り値:
srtStart プロジェクト計画開始日付

getFinish

public String getFinish()
プロジェクトの計画終了日を取得します。

戻り値:
srtFinish プロジェクトの計画終了日

getPlant

public String getPlant()
プラントを取得します。

戻り値:
srtPlant プラント

getCalendar

public String getCalendar()
稼動日カレンダを取得します。

戻り値:
srtCalendar 稼動日カレンダ

getPlanBasic

public String getPlanBasic()
プロジェクト基準日付計画方法を取得します。

戻り値:
srtPlanBasic プロジェクト基準日付計画方法

getPlanFcst

public String getPlanFcst()
プロジェクト予測日付の計画方法を取得します。

戻り値:
srtPlanFcst プロジェクト予測日付の計画方法

getTimeUnit

public String getTimeUnit()
時間計画単位を取得します。

戻り値:
srtTimeUnit 時間計画単位

getTimeUnitIso

public String getTimeUnitIso()
単位の ISO コードを取得します。

戻り値:
srtTimeUnitIso 単位の ISO コード

getNetworkProfile

public String getNetworkProfile()
ネットワークプロファイルを取得します。

戻り値:
srtNetworkProfile ネットワークプロファイル

getProjectProfile

public String getProjectProfile()
プロジェクトプロファイルを取得します。

戻り値:
srtProjectProfile プロジェクトプロファイル

getBudgetProfile

public String getBudgetProfile()
予算プロファイルを取得します。

戻り値:
srtBudgetProfile 予算プロファイル

getProjectStock

public String getProjectStock()
プロジェクト在庫を取得します。

戻り値:
srtProjectStock プロジェクト在庫

getObjectclass

public String getObjectclass()
対象クラスを取得します。

戻り値:
srtObjectclass 対象クラス

getStatistical

public String getStatistical()
統計 WBS 要素を取得します。

戻り値:
srtStatistical 統計 WBS 要素

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getIntProfile

public String getIntProfile()
プロジェクト/指図金利計算の金利プロファイルを取得します。

戻り値:
srtIntProfile プロジェクト/指図金利計算の金利プロファイル

getWbsSchedProfile

public String getWbsSchedProfile()
WBS 日程計画のプロファイルを取得します。

戻り値:
srtWbsSchedProfile WBS 日程計画のプロファイル

getCshBdgtProfile

public String getCshBdgtProfile()
資金計画プロファイルを取得します。

戻り値:
srtCshBdgtProfile 資金計画プロファイル

getPlanProfile

public String getPlanProfile()
計画プロファイルを取得します。

戻り値:
srtPlanProfile 計画プロファイル

getJointVenture

public String getJointVenture()
ジョイントベンチャを取得します。

戻り値:
srtJointVenture ジョイントベンチャ

getRecoveryInd

public String getRecoveryInd()
リカバリフラグを取得します。

戻り値:
srtRecoveryInd リカバリフラグ

getEquityType

public String getEquityType()
持分タイプを取得します。

戻り値:
srtEquityType 持分タイプ

getJvObjectType

public String getJvObjectType()
ジョイントベンチャ対象タイプを取得します。

戻り値:
srtJvObjectType ジョイントベンチャ対象タイプ

getJvJibClass

public String getJvJibClass()
JIB/JIBE クラスを取得します。

戻り値:
srtJvJibClass JIB/JIBE クラス

getJvJibSubClassA

public String getJvJibSubClassA()
JIB/JIBE サブクラスAを取得します。

戻り値:
srtJvJibSubClassA JIB/JIBE サブクラスA

getDeletionFlag

public String getDeletionFlag()
削除フラグを取得します。

戻り値:
srtDeletionFlag 削除フラグ

getObjectclassExt

public String getObjectclassExt()
オブジェクトクラス、言語依存を取得します。

戻り値:
srtObjectclassExt オブジェクトクラス、言語依存

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を設定します。

パラメータ:
strProjectDefinition - プロジェクト定義

setDescription

public void setDescription(String strDescription)
PS: テキスト(短)(第一テキスト行)を設定します。

パラメータ:
strDescription - PS: テキスト(短)(第一テキスト行)

setMaskId

public void setMaskId(String strMaskId)
WBS 要素 ID(短)の選択マスクを設定します。

パラメータ:
strMaskId - WBS 要素 ID(短)の選択マスク

setResponsibleNo

public void setResponsibleNo(String strResponsibleNo)
責任者番号 (プロジェクト責任者)を設定します。

パラメータ:
strResponsibleNo - 責任者番号 (プロジェクト責任者)

setApplicantNo

public void setApplicantNo(String strApplicantNo)
申請者番号を設定します。

パラメータ:
strApplicantNo - 申請者番号

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setControllingArea

public void setControllingArea(String strControllingArea)
管理領域を設定します。

パラメータ:
strControllingArea - 管理領域

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setProjectCurrency

public void setProjectCurrency(String strProjectCurrency)
WBS 通貨(プロジェクト定義)を設定します。

パラメータ:
strProjectCurrency - WBS 通貨(プロジェクト定義)

setProjectCurrencyIso

public void setProjectCurrencyIso(String strProjectCurrencyIso)
ISO 通貨コードを設定します。

パラメータ:
strProjectCurrencyIso - ISO 通貨コード

setNetworkAssignment

public void setNetworkAssignment(String strNetworkAssignment)
ネットワーク割当を設定します。

パラメータ:
strNetworkAssignment - ネットワーク割当

setStart

public void setStart(String strStart)
プロジェクト計画開始日付を設定します。

パラメータ:
strStart - プロジェクト計画開始日付

setFinish

public void setFinish(String strFinish)
プロジェクトの計画終了日を設定します。

パラメータ:
strFinish - プロジェクトの計画終了日

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setCalendar

public void setCalendar(String strCalendar)
稼動日カレンダを設定します。

パラメータ:
strCalendar - 稼動日カレンダ

setPlanBasic

public void setPlanBasic(String strPlanBasic)
プロジェクト基準日付計画方法を設定します。

パラメータ:
strPlanBasic - プロジェクト基準日付計画方法

setPlanFcst

public void setPlanFcst(String strPlanFcst)
プロジェクト予測日付の計画方法を設定します。

パラメータ:
strPlanFcst - プロジェクト予測日付の計画方法

setTimeUnit

public void setTimeUnit(String strTimeUnit)
時間計画単位を設定します。

パラメータ:
strTimeUnit - 時間計画単位

setTimeUnitIso

public void setTimeUnitIso(String strTimeUnitIso)
単位の ISO コードを設定します。

パラメータ:
strTimeUnitIso - 単位の ISO コード

setNetworkProfile

public void setNetworkProfile(String strNetworkProfile)
ネットワークプロファイルを設定します。

パラメータ:
strNetworkProfile - ネットワークプロファイル

setProjectProfile

public void setProjectProfile(String strProjectProfile)
プロジェクトプロファイルを設定します。

パラメータ:
strProjectProfile - プロジェクトプロファイル

setBudgetProfile

public void setBudgetProfile(String strBudgetProfile)
予算プロファイルを設定します。

パラメータ:
strBudgetProfile - 予算プロファイル

setProjectStock

public void setProjectStock(String strProjectStock)
プロジェクト在庫を設定します。

パラメータ:
strProjectStock - プロジェクト在庫

setObjectclass

public void setObjectclass(String strObjectclass)
対象クラスを設定します。

パラメータ:
strObjectclass - 対象クラス

setStatistical

public void setStatistical(String strStatistical)
統計 WBS 要素を設定します。

パラメータ:
strStatistical - 統計 WBS 要素

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setIntProfile

public void setIntProfile(String strIntProfile)
プロジェクト/指図金利計算の金利プロファイルを設定します。

パラメータ:
strIntProfile - プロジェクト/指図金利計算の金利プロファイル

setWbsSchedProfile

public void setWbsSchedProfile(String strWbsSchedProfile)
WBS 日程計画のプロファイルを設定します。

パラメータ:
strWbsSchedProfile - WBS 日程計画のプロファイル

setCshBdgtProfile

public void setCshBdgtProfile(String strCshBdgtProfile)
資金計画プロファイルを設定します。

パラメータ:
strCshBdgtProfile - 資金計画プロファイル

setPlanProfile

public void setPlanProfile(String strPlanProfile)
計画プロファイルを設定します。

パラメータ:
strPlanProfile - 計画プロファイル

setJointVenture

public void setJointVenture(String strJointVenture)
ジョイントベンチャを設定します。

パラメータ:
strJointVenture - ジョイントベンチャ

setRecoveryInd

public void setRecoveryInd(String strRecoveryInd)
リカバリフラグを設定します。

パラメータ:
strRecoveryInd - リカバリフラグ

setEquityType

public void setEquityType(String strEquityType)
持分タイプを設定します。

パラメータ:
strEquityType - 持分タイプ

setJvObjectType

public void setJvObjectType(String strJvObjectType)
ジョイントベンチャ対象タイプを設定します。

パラメータ:
strJvObjectType - ジョイントベンチャ対象タイプ

setJvJibClass

public void setJvJibClass(String strJvJibClass)
JIB/JIBE クラスを設定します。

パラメータ:
strJvJibClass - JIB/JIBE クラス

setJvJibSubClassA

public void setJvJibSubClassA(String strJvJibSubClassA)
JIB/JIBE サブクラスAを設定します。

パラメータ:
strJvJibSubClassA - JIB/JIBE サブクラスA

setDeletionFlag

public void setDeletionFlag(String strDeletionFlag)
削除フラグを設定します。

パラメータ:
strDeletionFlag - 削除フラグ

setObjectclassExt

public void setObjectclassExt(String strObjectclassExt)
オブジェクトクラス、言語依存を設定します。

パラメータ:
strObjectclassExt - オブジェクトクラス、言語依存

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectGetInfo (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectGetInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo
すべての実装インタフェース:
Serializable
public class ProjectGetInfo
extends ReferenceController
implements Serializable

WBS情報取得クラス
機能は以下の通り

  • WBS情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。
メソッドの概要
void | executeBapi() BapiControllerによりWBSの詳細情報の検索します。
ArrayList | getExpActivityList() 活動に関する詳細情報を取得します。
ArrayList | getExpMessageList() 詳細情報を読み込みエラーを取得します。
ArrayList | getExpWbsElementList() WBS 要素についての詳細情報を取得します。
ArrayList | getExpWbsHierarchieList() WBS 階層についての情報を取得します。
ArrayList | getExpWbsMilestoneList() WBS マイルストーンに関する詳細情報を取得します。
ArrayList | getImpWbsElementList() 詳細情報を必要とする WBS 要素を取得します。
String | getProjectDefinition() プロジェクト定義を識別するキーを取得します。
ProjectDefinition | getProjectDefinitionInfo() プロジェクトについての詳細情報を取得します。
String | getWithActivities() 従属活動を取得します。
String | getWithMilestones() 従属 WBS マイルストーンを取得します。
String | getWithSubtree() サブプロジェクトを取得します。
void | setExpActivityList(ArrayList expActivityList) 活動に関する詳細情報を設定します。
void | setExpMessageList(ArrayList expMessageList) 詳細情報を読み込みエラーを設定します。
void | setExportParam(BapiController bapiController) 登録された情報ををセットします。
void | setExpWbsElementList(ArrayList expWbsElementList) WBS 要素についての詳細情報を設定します。
void | setExpWbsHierarchieList(ArrayList expWbsHierarchieList) WBS 階層についての情報を設定します。
void | setExpWbsMilestoneList(ArrayList expWbsMilestoneList) WBS マイルストーンに関する詳細情報を設定します。
void | setImportParam(BapiController bapiController) WEBの詳細情報を検索する条件ををセットします。
void | setImpWbsElementList(ArrayList impWbsElementList) 詳細情報を必要とする WBS 要素を設定します。
void | setProjectDefinition(ProjectDefinition projectDefinition) プロジェクトについての詳細情報を設定します。
void | setProjectDefinition(String strProjectDefinition) プロジェクト定義を識別するキーを設定します。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setWithActivities(String strWithActivities) 従属活動を設定します。
void | setWithMilestones(String strWithMilestones) 従属 WBS マイルストーンを設定します。
void | setWithSubtree(String strWithSubtree) サブプロジェクトを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProjectGetInfo

public ProjectGetInfo(SapClient sapClient)
WBS情報を作成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
BapiControllerによりWBSの詳細情報の検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPFinancialSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPFinancialSystemException - 会計業務システム例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPFinancialSystemException
WEBの詳細情報を検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。

パラメータ:
strProjectDefinition - プロジェクト定義を識別するキー

setWithActivities

public void setWithActivities(String strWithActivities)
従属活動を設定します。

パラメータ:
strWithActivities - 従属活動がエクスポートされます

setWithMilestones

public void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。

パラメータ:
strWithMilestones - 従属 WBS マイルストーンがエクスポートされます

setWithSubtree

public void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。

パラメータ:
strWithSubtree - サブプロジェクトがエクスポートされます

getProjectDefinition

public String getProjectDefinition()
プロジェクト定義を識別するキーを取得します。

戻り値:
srtProjectDefinition プロジェクト定義を識別するキー

getWithActivities

public String getWithActivities()
従属活動を取得します。

戻り値:
srtWith_Activities 従属活動がエクスポートされます

getWithMilestones

public String getWithMilestones()
従属 WBS マイルストーンを取得します。

戻り値:
srtWithMilestones 従属 WBS マイルストーンがエクスポートされます

getWithSubtree

public String getWithSubtree()
サブプロジェクトを取得します。

戻り値:
srtWithSubtree サブプロジェクトがエクスポートされます

setProjectDefinition

public void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。

パラメータ:
projectDefinition - プロジェクトについての詳細情報

setImpWbsElementList

public void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。

パラメータ:
impWbsElementList - 詳細情報を必要とする WBS 要素

setExpWbsElementList

public void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。

パラメータ:
expWbsElementList - WBS 要素についての詳細情報

setExpWbsMilestoneList

public void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。

パラメータ:
expWbsMilestoneList - WBS マイルストーンに関する詳細情報

setExpWbsHierarchieList

public void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。

パラメータ:
expWbsHierarchieList - WBS 階層についての情報

setExpActivityList

public void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。

パラメータ:
expActivityList - 活動に関する詳細情報

setExpMessageList

public void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。

パラメータ:
expMessageList - 詳細情報を読み込みエラー

getProjectDefinitionInfo

public ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。

戻り値:
projectDefinition プロジェクトについての詳細情報

getImpWbsElementList

public ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。

戻り値:
impWbsElementList 詳細情報を必要とする WBS 要素

getExpWbsElementList

public ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。

戻り値:
expWbsElementList WBS 要素についての詳細情報

getExpWbsMilestoneList

public ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。

戻り値:
expWbsMilestoneList WBS マイルストーンに関する詳細情報

getExpWbsHierarchieList

public ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。

戻り値:
expWbsHierarchieList WBS 階層についての情報

getExpActivityList

public ArrayList getExpActivityList()
活動に関する詳細情報を取得します。

戻り値:
expActivityList 活動に関する詳細情報

getExpMessageList

public ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。

戻り値:
expMessageList 詳細情報を読み込みエラー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProjectGetInfoController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス ProjectGetInfoController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController
すべての実装インタフェース:
Serializable
public class ProjectGetInfoController
extends Object
implements Serializable

WBSの詳細コントローラクラス
機能は以下の通り

  • WBSの詳細を取得します。

関連項目:
直列化された形式

コンストラクタの概要
ProjectGetInfoController()
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
 ArrayList getExpActivityList()
活動に関する詳細情報を取得します。
 ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。
 ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。
 ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。
 ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。
 ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。
 String getProjectDefinition()
プロジェクト定義を識別するキーを取得します。
 ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。
 String getWithActivities()
従属活動を取得します。
 String getWithMilestones()
従属 WBS マイルストーンを取得します。
 String getWithSubtree()
サブプロジェクトを取得します。
 void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。
 void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。
 void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。
 void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。
 void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。
 void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。
 void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。
 void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void setWithActivities(String strWithActivities)
従属活動を設定します。
 void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。
 void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ProjectGetInfoController

public ProjectGetInfoController()
ProjectGetInfoControllerのコンストラクタを生成します。

ProjectGetInfoController

public ProjectGetInfoController(SapClient sapClient)
ProjectGetInfoControllerのコンストラクタを生成します。

パラメータ:
sapClient - SapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPFinancialAppException,
                        SAPFinancialSystemException
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPFinancialAppException - 会計業務アプリケーション例外
SAPFinancialSystemException - 会計業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPFinancialSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPFinancialSystemException - 会計業務システム例外

setProjectDefinition

public void setProjectDefinition(String strProjectDefinition)
プロジェクト定義を識別するキーを設定します。

パラメータ:
strProjectDefinition - プロジェクト定義を識別するキー

setWithActivities

public void setWithActivities(String strWithActivities)
従属活動を設定します。

パラメータ:
strWithActivities - 従属活動がエクスポートされます

setWithMilestones

public void setWithMilestones(String strWithMilestones)
従属 WBS マイルストーンを設定します。

パラメータ:
strWithMilestones - 従属 WBS マイルストーンがエクスポートされます

setWithSubtree

public void setWithSubtree(String strWithSubtree)
サブプロジェクトを設定します。

パラメータ:
strWithSubtree - サブプロジェクトがエクスポートされます

getProjectDefinition

public String getProjectDefinition()
                            throws SAPFinancialSystemException
プロジェクト定義を識別するキーを取得します。

戻り値:
srtProjectDefinition プロジェクト定義を識別するキー
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithActivities

public String getWithActivities()
                         throws SAPFinancialSystemException
従属活動を取得します。

戻り値:
srtWith_Activities 従属活動がエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithMilestones

public String getWithMilestones()
                         throws SAPFinancialSystemException
従属 WBS マイルストーンを取得します。

戻り値:
srtWithMilestones 従属 WBS マイルストーンがエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

getWithSubtree

public String getWithSubtree()
                      throws SAPFinancialSystemException
サブプロジェクトを取得します。

戻り値:
srtWithSubtree サブプロジェクトがエクスポートされます
例外:
SAPFinancialSystemException - 会計業務システム例外

setProjectDefinition

public void setProjectDefinition(ProjectDefinition projectDefinition)
プロジェクトについての詳細情報を設定します。

パラメータ:
projectDefinition - プロジェクトについての詳細情報

setImpWbsElementList

public void setImpWbsElementList(ArrayList impWbsElementList)
詳細情報を必要とする WBS 要素を設定します。

パラメータ:
impWbsElementList - 詳細情報を必要とする WBS 要素

setExpWbsElementList

public void setExpWbsElementList(ArrayList expWbsElementList)
WBS 要素についての詳細情報を設定します。

パラメータ:
expWbsElementList - WBS 要素についての詳細情報

setExpWbsMilestoneList

public void setExpWbsMilestoneList(ArrayList expWbsMilestoneList)
WBS マイルストーンに関する詳細情報を設定します。

パラメータ:
expWbsMilestoneList - WBS マイルストーンに関する詳細情報

setExpWbsHierarchieList

public void setExpWbsHierarchieList(ArrayList expWbsHierarchieList)
WBS 階層についての情報を設定します。

パラメータ:
expWbsHierarchieList - WBS 階層についての情報

setExpActivityList

public void setExpActivityList(ArrayList expActivityList)
活動に関する詳細情報を設定します。

パラメータ:
expActivityList - 活動に関する詳細情報

setExpMessageList

public void setExpMessageList(ArrayList expMessageList)
詳細情報を読み込みエラーを設定します。

パラメータ:
expMessageList - 詳細情報を読み込みエラー

getProjectDefinitionInfo

public ProjectDefinition getProjectDefinitionInfo()
プロジェクトについての詳細情報を取得します。

戻り値:
projectDefinition プロジェクトについての詳細情報

getImpWbsElementList

public ArrayList getImpWbsElementList()
詳細情報を必要とする WBS 要素を取得します。

戻り値:
impWbsElementList 詳細情報を必要とする WBS 要素

getExpWbsElementList

public ArrayList getExpWbsElementList()
WBS 要素についての詳細情報を取得します。

戻り値:
expWbsElementList WBS 要素についての詳細情報

getExpWbsMilestoneList

public ArrayList getExpWbsMilestoneList()
WBS マイルストーンに関する詳細情報を取得します。

戻り値:
expWbsMilestoneList WBS マイルストーンに関する詳細情報

getExpWbsHierarchieList

public ArrayList getExpWbsHierarchieList()
WBS 階層についての情報を取得します。

戻り値:
expWbsHierarchieList WBS 階層についての情報

getExpActivityList

public ArrayList getExpActivityList()
活動に関する詳細情報を取得します。

戻り値:
expActivityList 活動に関する詳細情報

getExpMessageList

public ArrayList getExpMessageList()
詳細情報を読み込みエラーを取得します。

戻り値:
expMessageList 詳細情報を読み込みエラー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SystemStatus (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス SystemStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.SystemStatus
すべての実装インタフェース:
Serializable
public class SystemStatus
extends Object
implements Serializable

システムステータステーブル情報クラス 機能は以下の通り

  • システムステータステーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SystemStatus()
システムステータステーブルを作成します。
メソッドの概要
String | getSysStatus() システムステータスを取得します。
String | getSyStDscr() オブジェクトステータスを取得します。
String | getSyStText() オブジェクトの個別ステータス (簡略形式)を取得します。
void | setSysStatus(String strSysStatus) システムステータスを設定します。
void | setSyStDscr(String strSyStDscr) オブジェクトステータスを設定します。
void | setSyStText(String strSyStText) オブジェクトの個別ステータス (簡略形式)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SystemStatus

public SystemStatus()
システムステータステーブルを作成します。

メソッドの詳細

getSysStatus

public String getSysStatus()
システムステータスを取得します。

戻り値:
srtSysStatus システムステータス

getSyStText

public String getSyStText()
オブジェクトの個別ステータス (簡略形式)を取得します。

戻り値:
srtSyStText オブジェクトの個別ステータス (簡略形式)

getSyStDscr

public String getSyStDscr()
オブジェクトステータスを取得します。

戻り値:
srtSyStDscr オブジェクトステータス

setSysStatus

public void setSysStatus(String strSysStatus)
システムステータスを設定します。

パラメータ:
strSysStatus - システムステータス

setSyStText

public void setSyStText(String strSyStText)
オブジェクトの個別ステータス (簡略形式)を設定します。

パラメータ:
strSyStText - オブジェクトの個別ステータス (簡略形式)

setSyStDscr

public void setSyStDscr(String strSyStDscr)
オブジェクトステータスを設定します。

パラメータ:
strSyStDscr - オブジェクトステータス

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserStatus (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.financial
クラス UserStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.financial.UserStatus
すべての実装インタフェース:
Serializable
public class UserStatus
extends Object
implements Serializable

ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り

  • ユーザステータス/指図ステータステーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UserStatus()
ユーザステータス/指図ステータステーブルを作成します。
メソッドの概要
String | getStatProf() ステータスプロファイルを取得します。
String | getUsrStatus() ユーザステータスを取得します。
String | getUsStDscr() オブジェクトステータスを取得します。
String | getUsStNumb() ステータス番号を取得します。
String | getUsStText() オブジェクトの個別ステータス (簡略形式)を取得します。
void | setStatProf(String strStatProf) ステータスプロファイルを設定します。
void | setUsrStatus(String strUsrStatus) ユーザステータスを設定します。
void | setUsStDscr(String strUsStDscr) オブジェクトステータスを設定します。
void | setUsStNumb(String strUsStNumb) ステータス番号を設定します。
void | setUsStText(String strUsStText) オブジェクトの個別ステータス (簡略形式)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserStatus

public UserStatus()
ユーザステータス/指図ステータステーブルを作成します。

メソッドの詳細

getStatProf

public String getStatProf()
ステータスプロファイルを取得します。

戻り値:
srtStatProf ステータスプロファイル

getUsrStatus

public String getUsrStatus()
ユーザステータスを取得します。

戻り値:
srtUsrStatus ユーザステータス

getUsStNumb

public String getUsStNumb()
ステータス番号を取得します。

戻り値:
srtUsStNumb ステータス番号

getUsStText

public String getUsStText()
オブジェクトの個別ステータス (簡略形式)を取得します。

戻り値:
srtUsStText オブジェクトの個別ステータス (簡略形式)

getUsStDscr

public String getUsStDscr()
オブジェクトステータスを取得します。

戻り値:
srtUsStDscr オブジェクトステータス

setStatProf

public void setStatProf(String strStatProf)
ステータスプロファイルを設定します。

パラメータ:
strStatProf - ステータスプロファイル

setUsrStatus

public void setUsrStatus(String strUsrStatus)
ユーザステータスを設定します。

パラメータ:
strUsrStatus - ユーザステータス

setUsStNumb

public void setUsStNumb(String strUsStNumb)
ステータス番号を設定します。

パラメータ:
strUsStNumb - ステータス番号

setUsStText

public void setUsStText(String strUsStText)
オブジェクトの個別ステータス (簡略形式)を設定します。

パラメータ:
strUsStText - オブジェクトの個別ステータス (簡略形式)

setUsStDscr

public void setUsStDscr(String strUsStDscr)
オブジェクトステータスを設定します。

パラメータ:
strUsStDscr - オブジェクトステータス

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.AllVersions の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.AllVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.AllVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Cond の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Cond の使用

jp.co.intra_mart.foundation.sap.module.purchase.Cond はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractService の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractService の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractService はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader の使用

ExportHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExportHeader の使用

ExportHeader を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExportHeader PurchaseOrderPayPost.getExportHeader()
貿易管理ヘッダを取得します｡

ExportHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setExportHeader(ExportHeader exportHeader) 貿易管理ヘッダを設定します｡
static void | ParamExportHeader.setImportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
static void | ParamExportHeader.setExportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ExportItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ExportItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Extension の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Extension の使用

jp.co.intra_mart.foundation.sap.module.purchase.Extension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController の使用

jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController の使用

jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Limits の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Limits の使用

jp.co.intra_mart.foundation.sap.module.purchase.Limits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb の使用

jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList の使用

MaterialGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetList の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetList のサブクラス
 class MaterialGetListController
品目コード検索コントローラクラス
機能は以下の通り
品目コード、テキストを検索します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel の使用

jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MatnrList の使用

jp.co.intra_mart.foundation.sap.module.purchase.MatnrList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の使用

jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Partner の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Partner の使用

jp.co.intra_mart.foundation.sap.module.purchase.Partner はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment の使用

jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel の使用

PurchaseGetItemSrel を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseGetItemSrel の使用

PurchaseGetItemSrel を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PurchaseGetItemSrel PurchaseGetItemSrelController.getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader の使用

PurchaseHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeader のサブクラス
class | PurchaseHeaderPost 購買発注伝票ヘッダ情報クラス 機能は以下の通り 購買発注伝票ヘッダの情報を保持します。
class | PurchaseHeaders 伝票の承認対象一覧ヘッダ情報クラス 機能は以下の通り 伝票の承認対象一覧ヘッダの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost の使用

PurchaseHeaderPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseHeaderPost の使用

PurchaseHeaderPost を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PurchaseHeaderPost PurchaseOrderPayPost.getDocumentHeader()
伝票ヘッダを取得します｡

PurchaseHeaderPost 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setDocumentHeader(PurchaseHeaderPost documentHeader) 伝票ヘッダを設定します｡
static void | ParamHeader.setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
static void | ParamHeader.setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem の使用

PurchaseItem を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseItem の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseItem のサブクラス
class | PurchaseItemPost 購買発注伝票明細情報クラス 機能は以下の通り 購買発注伝票明細情報を保持します。
class | PurchaseItems 伝票の承認対象明細情報クラス 機能は以下の通り 伝票の承認対象明細情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost の使用

PurchaseOrderPayPost を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseOrderPayPost の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseOrderPayPost のサブクラス
class | PurchaseOrderPayPostController 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
class | PurchaseOrderPostChangeController 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease の使用

PurchaseRelease を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseRelease の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseRelease のサブクラス
class | PurchaseReleaseController 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
class | PurchaseResetReleaseController 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule の使用

jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText の使用

PurchaseText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseText の使用

jp.co.intra_mart.foundation.sap.module.purchase での PurchaseText のサブクラス
 class ContractServiceText
外注サービステキスト情報クラス
機能は以下の通り
外注サービステキスト情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection の使用

jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Selection の使用

Selection を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での Selection の使用

jp.co.intra_mart.foundation.sap.module.purchase での Selection のサブクラス
class | DistributionChannelSelection 流通チャネルの選択オプションクラス 機能は以下の通り 流通チャネルの選択オプションの情報を保持します。
class | MaterialShortDescsel 品目テキストの選択オプションクラス 機能は以下の通り 品目テキストの選択オプションの情報を保持します。
class | MatnrSelection 品目コードの選択オプションクラス 機能は以下の通り 品目コードの選択オプションの情報を保持します。
class | PlantSelection プラントの選択オプションクラス 機能は以下の通り プラントの選択オプションの情報を保持します。
class | SalesOrganisationSelection 販売組織の選択オプションクラス 機能は以下の通り 販売組織の選択オプションの情報を保持します。
class | StorageLocationSelect 保管場所の選択オプションクラス 機能は以下の通り 保管場所の選択オプションの情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController の使用

jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect の使用

jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail の使用

SupplierDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SupplierDetail の使用

SupplierDetail を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SupplierDetail SupplierGetDetailController.getSupplierDetail()
仕入先マスタ詳細情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck の使用

SupplierExistenceCheck を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SupplierExistenceCheck の使用

SupplierExistenceCheck を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SupplierExistenceCheck SupplierExistenceCheckController.getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の使用

jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress の使用

VendorAddress を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での VendorAddress の使用

VendorAddress を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 VendorAddress PurchaseOrderPayPost.getSupplierInfo()
仕入先住所を取得します｡

VendorAddress 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void PurchaseOrderPayPost.setSupplierInfo(VendorAddress supplierInfo)
仕入先住所を設定します｡

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.Versions の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.Versions の使用

Versions を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での Versions の使用

Versions を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 Versions PurchaseOrderPayPost.getVersions()
バージョン管理を取得します｡

Versions 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase のメソッド
void | PurchaseOrderPayPost.setVersions(Versions versions) バージョン管理ヘッダを設定します｡
static void | ParamVersions.setImportParam(BapiController bapiController, Versions versions) バージョン管理に値をセットします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData の使用

ClientData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ClientData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ClientData のサブクラス
 class ClientDataList
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ClientData の使用

ClientData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ClientData MaterialGetAll.getClientData()
品目データ (クライアントレベル)を取得します。

ClientData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setClientData(ClientData clientData)
品目データ (クライアントレベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList の使用

ClientDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ClientDataList の使用

ClientDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ClientDataList MaterialSaveReplicaController.getClientDataList(int index)
品目データ (クライアントレベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters の使用

ForecastParameters を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ForecastParameters の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ForecastParameters のサブクラス
 class ForecastParametersList
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ForecastParameters の使用

ForecastParameters を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ForecastParameters MaterialGetAll.getForecastParameters()
予測パラメータを取得します。

ForecastParameters 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setForecastParameters(ForecastParameters forecastParameters)
予測パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList の使用

ForecastParametersList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ForecastParametersList の使用

ForecastParametersList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ForecastParametersList MaterialSaveReplicaController.getForecastParametersList(int index)
需要予測パラメータが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader の使用

GoodsMvtHeader を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.common.model での GoodsMvtHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での GoodsMvtHeader のサブクラス
 class GoodsMvtHeaderList
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。

GoodsMvtHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.common.model のメソッド
static void ParamGoodsMvtHeader.setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtHeader の使用

GoodsMvtHeader を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtHeader GoodsMvtCreate.getGoodsMvtHeader()
入出庫伝票ヘッダデータを取得します。

GoodsMvtHeader 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 void GoodsMvtCreate.setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription の使用

MaterialDescription を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialDescription の使用

MaterialDescription を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
MaterialDescription | MaterialSaveReplicaController.getMaterialDescription(int index) 品目テキストが既に存在するかチェックします。
MaterialDescription | MaterialGetAllController.getMaterialDescription(int index) 品目テキストオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData の使用

PlanningData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlanningData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlanningData のサブクラス
 class PlanningDataList
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での PlanningData の使用

PlanningData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 PlanningData MaterialGetAll.getPlanningData()
品目マスタ/製品グループの変更伝票構造を取得します。

PlanningData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setPlanningData(PlanningData planningData)
品目マスタ/製品グループの変更伝票構造を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList の使用

PlanningDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PlanningDataList の使用

PlanningDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PlanningDataList MaterialSaveReplicaController.getPlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData の使用

PlantData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlantData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での PlantData のサブクラス
 class PlantDataList
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での PlantData の使用

PlantData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 PlantData MaterialGetAll.getPlantData()
品目データ (プラントレベル)を取得します。

PlantData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setPlantData(PlantData plantData)
品目データ (プラントレベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList の使用

PlantDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PlantDataList の使用

PlantDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PlantDataList MaterialSaveReplicaController.getPlantDataList(int index)
品目データ (プラントレベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData の使用

SalesData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SalesData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での SalesData のサブクラス
 class SalesDataList
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での SalesData の使用

SalesData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 SalesData MaterialGetAll.getSalesData()
販売データを取得します。

SalesData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setSalesData(SalesData salesData)
販売データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList の使用

SalesDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での SalesDataList の使用

SalesDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 SalesDataList MaterialSaveReplicaController.getSalesDataList(int index)
販売データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData の使用

StorageLocationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageLocationData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageLocationData のサブクラス
 class StorageLocationDataList
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での StorageLocationData の使用

StorageLocationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 StorageLocationData MaterialGetAll.getStorageLocationData()
品目データ (保管場所レベル)を取得します。

StorageLocationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setStorageLocationData(StorageLocationData storageLocationData)
品目データ (保管場所レベル)を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList の使用

StorageLocationDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での StorageLocationDataList の使用

StorageLocationDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 StorageLocationDataList MaterialSaveReplicaController.getStorageLocationDataList(int index)
品目データ (保管場所レベル)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData の使用

StorageTypeData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageTypeData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での StorageTypeData のサブクラス
 class StorageTypeDataList
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での StorageTypeData の使用

StorageTypeData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 StorageTypeData MaterialGetAll.getStorageTypeData()
保管域タイプデータを取得します。

StorageTypeData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setStorageTypeData(StorageTypeData storageTypeData)
保管域タイプデータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList の使用

StorageTypeDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での StorageTypeDataList の使用

StorageTypeDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 StorageTypeDataList MaterialSaveReplicaController.getStorageTypeDataList(int index)
保管域タイプデータが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications の使用

TaxClassifications を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での TaxClassifications の使用

TaxClassifications を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
TaxClassifications | MaterialSaveReplicaController.getTaxClassifications(int index) 制御デ－タが既に存在するかチェックします。
TaxClassifications | MaterialGetAllController.getTaxClassifications(int index) 制御デ－タオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure の使用

UnitSofmeasure を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での UnitSofmeasure の使用

UnitSofmeasure を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
UnitSofmeasure | MaterialSaveReplicaController.getUnitSofmeasure(int index) 数量単位が既に存在するかチェックします。
UnitSofmeasure | MaterialGetAllController.getUnitSofmeasure(int index) 数量単位オブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData の使用

ValuationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ValuationData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での ValuationData のサブクラス
 class ValuationDataList
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ValuationData の使用

ValuationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ValuationData MaterialGetAll.getValuationData()
評価データを取得します。

ValuationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setValuationData(ValuationData valuationData)
評価データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList の使用

ValuationDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ValuationDataList の使用

ValuationDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ValuationDataList MaterialSaveReplicaController.getValuationDataList(int index)
評価データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData の使用

WarehouseNumberData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.common.model での WarehouseNumberData の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model での WarehouseNumberData のサブクラス
 class WarehouseNumberDataList
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での WarehouseNumberData の使用

WarehouseNumberData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 WarehouseNumberData MaterialGetAll.getWarehouseNumberData()
倉庫番号データを取得します。

WarehouseNumberData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setWarehouseNumberData(WarehouseNumberData warehouseNumberData)
倉庫番号データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList の使用

WarehouseNumberDataList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での WarehouseNumberDataList の使用

WarehouseNumberDataList を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 WarehouseNumberDataList MaterialSaveReplicaController.getWarehouseNumberDataList(int index)
倉庫番号データが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ClientData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ClientData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ClientDataList
public class ClientData
extends Object
implements Serializable

品目データ (クライアントレベル)情報クラス
機能は以下の通り

  • 品目データ (クライアントレベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ClientData()
品目データ (クライアントレベル)情報を作成します。
メソッドの概要
String | getAllowedWt() 許容梱包重量を取得します。
String | getAllwdVol() 許容梱包容積を取得します。
String | getAppdBRec() 区分: バッチ製造記録の承認必須を取得します。
String | getAuthoritygroup() 権限グループを取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBaseUomIso() ISO コードでの基本数量単位を取得します。
String | getBasicMatl() 主構成物質を取得します。
String | getBatchMgmt() ロット管理所要量区分を取得します。
String | getCadId() CAD 区分を取得します。
String | getCatprofile() カタログプロファイルを取得します。
String | getChangedBy() オブジェクトの変更者名を取得します。
String | getClosedBox() 完了した梱包材を取得します。
String | getCmRelevanceFlag() 構成管理関連を取得します。
String | getCompetitor() 競合会社を取得します。
String | getConfigured() 選定可能品目を取得します。
String | getConfMatl() プラント共通選定可能品目を取得します。
String | getContainer() 容器条件を取得します。
String | getCoProduct() 区分: 連産品としても使用可能な品目を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCreatedOn() 登録日付を取得します。
String | getDelFlag() クライアントレベルでの品目削除フラグを取得します。
String | getDivision() 製品部門を取得します。
String | getDocChgNo() 文書変更番号 (文書管理システム外)を取得します。
String | getDocFormat() 文書のページ書式 (文書管理システムによらない)を取得します。
String | getDocType() 文書タイプ (文書管理システムによらない)を取得します。
String | getDocument() 文書番号 (文書管理システムによらない)を取得します。
String | getDocVers() 文書バージョン (文書管理システムによらない)を取得します。
String | getDsnOffice() 研究室/設計室を取得します。
String | getEnvtRlvt() 区分: 環境関連を取得します。
String | getExtmatlgrp() 外部品目グループを取得します。
String | getFillLevel() 最大レベル (容積別)を取得します。
String | getFunction() BAPI 機能を取得します。
String | getGtinVariant() グローバルトレード明細番号バリアントを取得します。
String | getHazMatNo() 危険物コードを取得します。
String | getHazMatNoExternal() 項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
String | getHazMatNoGuid() 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
String | getHazMatNoVersion() 項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
String | getHazmatprof() 危険物インジケータプロファイルを取得します。
String | getHighVisc() 区分: 高粘性を取得します。
String | getIndSector() 産業コードを取得します。
String | getInvMatNo() 会社固有 (内部) 在庫管理品目コードを取得します。
String | getInvMatNoExternal() 項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
String | getInvMatNoGuid() 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
String | getInvMatNoVersion() 項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
String | getItemCat() 一般明細カテゴリグループを取得します。
String | getLabelForm() ラベル書式を取得します。
String | getLabelType() ラベルタイプを取得します。
String | getLastChnge() 最終変更日付を取得します。
String | getLooseorliq() 区分: バルク/液体を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getManufProf() 製造者製品プロファイルを取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMatcmpllvl() 品目完了レベルを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialFixed() ロックされている品目を取得します。
String | getMatGrpSm() 品目グループ: 梱包材を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatlType() 品目タイプを取得します。
String | getMatStatus() 品目更新完了ステータスを取得します。
String | getMfrNo() 製造者番号を取得します。
String | getMinremlife() 最低有効期間残を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNoSheets() 文書枚数 (文書管理システムによらない)を取得します。
String | getOldMatNo() 旧品目コードを取得します。
String | getPackVoUn() 容積単位 (許容梱包容積)を取得します。
String | getPackVoUnIso() ISO コードでの容積単位 (許容梱包容積)を取得します。
String | getPackWtUn() 重量単位 (許容梱包重量)を取得します。
String | getPackWtUnIso() ISO コードでの重量単位 (許容梱包重量)を取得します。
String | getPageformat() 製造メモのページ書式を取得します。
String | getPageNo() 文書ページ番号 (文書管理システムによらない)を取得します。
String | getParEff() 有効性パラメータへの値割当/変更番号よりも優先を取得します。
String | getPeriodIndExpirationDate() 有効期間期限日の期間区分を取得します。
String | getPlRefMat() 梱包方法が同じ品目の参照品目を取得します。
String | getPoUnit() 発注単位を取得します。
String | getPoUnitIso() ISO コードによる発注単位を取得します。
String | getProcRule() 調達規則を取得します。
String | getProdAlloc() 製品割当決定手順を取得します。
String | getProdCompositionOnPackaging() 区分: 梱包材にプリントされた生産構造を取得します。
String | getProdHier() 品目階層を取得します。
String | getProdMemo() 製造/検査メモを取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPurStatus() プラント共通品目ステータスを取得します。
String | getPurValkey() 購買許容値キーを取得します。
String | getPvalidfrom() プラント共通品目のステータス有効開始日付を取得します。
String | getQmProcmnt() 調達における品質管理有効を取得します。
String | getQtyGrGi() 数量: 印刷予定入出庫票数を取得します。
String | getQualDik() 無償納入による割引対象品目を取得します。
String | getRoundUpRuleExpirationDate() 有効期間期限日計算の丸め規則を取得します。
String | getSalStatus() 流通チェーン間品目ステータスを取得します。
String | getSeason() 季節カテゴリを取得します。
String | getSerializationLevel() シリアル番号の指定レベルを取得します。
String | getShelfLife() 総有効期間を取得します。
String | getShMatTyp() 梱包材タイプを取得します。
String | getSizeDim() サイズ/寸法を取得します。
String | getSledBbd() 有効期限を取得します。
String | getStackFact() 山積係数を取得します。
String | getStdDescr() 標準テキスト (ANSI、ISO など)を取得します。
String | getStorConds() 保管条件を取得します。
String | getStorPct() 残存有効期間割合 %を取得します。
String | getSupSource() 供給元を取得します。
String | getSvalidfrom() 流通チェーン間品目ステータスの有効開始日付を取得します。
String | getTempConds() 温度条件区分を取得します。
String | getTransGrp() 輸送グループを取得します。
String | getUnitOfWt() 重量単位を取得します。
String | getUnitOfWtIso() ISO コードでの重量単位を取得します。
String | getUomusage() 使用数量単位を取得します。
String | getVarOrdUn() 可変購買発注単位有効を取得します。
String | getVolTolLt() 荷役単位の容積超過許容量を取得します。
String | getWtTolLt() 荷役単位の重量超過許容量を取得します。
void | setAllowedWt(String allowedWt) 許容梱包重量を設定します。
void | setAllwdVol(String allwdVol) 許容梱包容積を設定します。
void | setAppdBRec(String appdBRec) 区分: バッチ製造記録の承認必須を設定します。
void | setAuthoritygroup(String authoritygroup) 権限グループを設定します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBaseUomIso(String baseUomIso) ISO コードでの基本数量単位を設定します。
void | setBasicMatl(String basicMatl) 主構成物質を設定します。
void | setBatchMgmt(String batchMgmt) ロット管理所要量区分を設定します。
void | setCadId(String cadId) CAD 区分を設定します。
void | setCatprofile(String catprofile) カタログプロファイルを設定します。
void | setChangedBy(String changedBy) オブジェクトの変更者名を設定します。
void | setClosedBox(String closedBox) 完了した梱包材を設定します。
void | setCmRelevanceFlag(String cmRelevanceFlag) 構成管理関連を設定します。
void | setCompetitor(String competitor) 競合会社を設定します。
void | setConfigured(String configured) 選定可能品目を設定します。
void | setConfMatl(String confMatl) プラント共通選定可能品目を設定します。
void | setContainer(String container) 容器条件を設定します。
void | setCoProduct(String coProduct) 区分: 連産品としても使用可能な品目を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCreatedOn(String createdOn) 登録日付を設定します。
void | setDelFlag(String delFlag) クライアントレベルでの品目削除フラグを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDocChgNo(String docChgNo) 文書変更番号 (文書管理システム外)を設定します。
void | setDocFormat(String docFormat) 文書のページ書式 (文書管理システムによらない)を設定します。
void | setDocType(String docType) 文書タイプ (文書管理システムによらない)を設定します。
void | setDocument(String document) 文書番号 (文書管理システムによらない)を設定します。
void | setDocVers(String docVers) 文書バージョン (文書管理システムによらない)を設定します。
void | setDsnOffice(String dsnOffice) 研究室/設計室を設定します。
void | setEnvtRlvt(String envtRlvt) 区分: 環境関連を設定します。
void | setExtmatlgrp(String extmatlgrp) 外部品目グループを設定します。
void | setFillLevel(String fillLevel) 最大レベル (容積別)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGtinVariant(String gtinVariant) グローバルトレード明細番号バリアントを設定します。
void | setHazMatNo(String hazMatNo) 危険物コードを設定します。
void | setHazMatNoExternal(String hazMatNoExternal) 項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
void | setHazMatNoGuid(String hazMatNoGuid) 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
void | setHazMatNoVersion(String hazMatNoVersion) 項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
void | setHazmatprof(String hazmatprof) 危険物インジケータプロファイルを設定します。
void | setHighVisc(String highVisc) 区分: 高粘性を設定します。
void | setIndSector(String indSector) 産業コードを設定します。
void | setInvMatNo(String invMatNo) 会社固有 (内部) 在庫管理品目コードを設定します。
void | setInvMatNoExternal(String invMatNoExternal) 項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
void | setInvMatNoGuid(String invMatNoGuid) 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
void | setInvMatNoVersion(String invMatNoVersion) 項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
void | setItemCat(String itemCat) 一般明細カテゴリグループを設定します。
void | setLabelForm(String labelForm) ラベル書式を設定します。
void | setLabelType(String labelType) ラベルタイプを設定します。
void | setLastChnge(String lastChnge) 最終変更日付を設定します。
void | setLooseorliq(String looseorliq) 区分: バルク/液体を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setManufProf(String manufProf) 製造者製品プロファイルを設定します。
void | setManuMat(String manuMat) 製造者製品コードを設定します。
void | setMatcmpllvl(String matcmpllvl) 品目完了レベルを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialFixed(String materialFixed) ロックされている品目を設定します。
void | setMatGrpSm(String matGrpSm) 品目グループ: 梱包材を設定します。
void | setMatlGroup(String matlGroup) 品目グループを設定します。
void | setMatlType(String matlType) 品目タイプを設定します。
void | setMatStatus(String matStatus) 品目更新完了ステータスを設定します。
void | setMfrNo(String mfrNo) 製造者番号を設定します。
void | setMinremlife(String minremlife) 最低有効期間残を設定します。
void | setNetWeight(String netWeight) 正味重量を設定します。
void | setNoSheets(String noSheets) 文書枚数 (文書管理システムによらない)を設定します。
void | setOldMatNo(String oldMatNo) 旧品目コードを設定します。
void | setPackVoUn(String packVoUn) 容積単位 (許容梱包容積)を設定します。
void | setPackVoUnIso(String packVoUnIso) ISO コードでの容積単位 (許容梱包容積)を設定します。
void | setPackWtUn(String packWtUn) 重量単位 (許容梱包重量)を設定します。
void | setPackWtUnIso(String packWtUnIso) ISO コードでの重量単位 (許容梱包重量)を設定します。
void | setPageformat(String pageformat) 製造メモのページ書式を設定します。
void | setPageNo(String pageNo) 文書ページ番号 (文書管理システムによらない)を設定します。
void | setParEff(String parEff) 有効性パラメータへの値割当/変更番号よりも優先を設定します。
void | setPeriodIndExpirationDate(String periodIndExpirationDate) 有効期間期限日の期間区分を設定します。
void | setPlRefMat(String plRefMat) 梱包方法が同じ品目の参照品目を設定します。
void | setPoUnit(String poUnit) 発注単位を設定します。
void | setPoUnitIso(String poUnitIso) ISO コードによる発注単位を設定します。
void | setProcRule(String procRule) 調達規則を設定します。
void | setProdAlloc(String prodAlloc) 製品割当決定手順を設定します。
void | setProdCompositionOnPackaging(String prodCompositionOnPackaging) 区分: 梱包材にプリントされた生産構造を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setProdMemo(String prodMemo) 製造/検査メモを設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPurStatus(String purStatus) プラント共通品目ステータスを設定します。
void | setPurValkey(String purValkey) 購買許容値キーを設定します。
void | setPvalidfrom(String pvalidfrom) プラント共通品目のステータス有効開始日付を設定します。
void | setQmProcmnt(String qmProcmnt) 調達における品質管理有効を設定します。
void | setQtyGrGi(String qtyGrGi) 数量: 印刷予定入出庫票数を設定します。
void | setQualDik(String qualDik) 無償納入による割引対象品目を設定します。
void | setRoundUpRuleExpirationDate(String roundUpRuleExpirationDate) 有効期間期限日計算の丸め規則を設定します。
void | setSalStatus(String salStatus) 流通チェーン間品目ステータスを設定します。
void | setSeason(String season) 季節カテゴリを設定します。
void | setSerializationLevel(String serializationLevel) シリアル番号の指定レベルを設定します。
void | setShelfLife(String shelfLife) 総有効期間を設定します。
void | setShMatTyp(String shMatTyp) 梱包材タイプを設定します。
void | setSizeDim(String sizeDim) サイズ/寸法を設定します。
void | setSledBbd(String sledBbd) 有効期限を設定します。
void | setStackFact(String stackFact) 山積係数を設定します。
void | setStdDescr(String stdDescr) 標準テキスト (ANSI、ISO など)を設定します。
void | setStorConds(String storConds) 保管条件を設定します。
void | setStorPct(String storPct) 残存有効期間割合 %を設定します。
void | setSupSource(String supSource) 供給元を設定します。
void | setSvalidfrom(String svalidfrom) 流通チェーン間品目ステータスの有効開始日付を設定します。
void | setTempConds(String tempConds) 温度条件区分を設定します。
void | setTransGrp(String transGrp) 輸送グループを設定します。
void | setUnitOfWt(String unitOfWt) 重量単位を設定します。
void | setUnitOfWtIso(String unitOfWtIso) ISO コードでの重量単位を設定します。
void | setUomusage(String uomusage) 使用数量単位を設定します。
void | setVarOrdUn(String varOrdUn) 可変購買発注単位有効を設定します。
void | setVolTolLt(String volTolLt) 荷役単位の容積超過許容量を設定します。
void | setWtTolLt(String wtTolLt) 荷役単位の重量超過許容量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ClientData

public ClientData()
品目データ (クライアントレベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getIndSector

public String getIndSector()
産業コードを取得します。

戻り値:
indSector 産業コード

getMatlType

public String getMatlType()
品目タイプを取得します。

戻り値:
matlType 品目タイプ

getCreatedOn

public String getCreatedOn()
登録日付を取得します。

戻り値:
createdOn 登録日付

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getLastChnge

public String getLastChnge()
最終変更日付を取得します。

戻り値:
lastChnge 最終変更日付

getChangedBy

public String getChangedBy()
オブジェクトの変更者名を取得します。

戻り値:
changedBy オブジェクトの変更者名

getMatStatus

public String getMatStatus()
品目更新完了ステータスを取得します。

戻り値:
matStatus 品目更新完了ステータス

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
クライアントレベルでの品目削除フラグを取得します。

戻り値:
delFlag クライアントレベルでの品目削除フラグ

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
matlGroup 品目グループ

getOldMatNo

public String getOldMatNo()
旧品目コードを取得します。

戻り値:
oldMatNo 旧品目コード

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getBaseUomIso

public String getBaseUomIso()
ISO コードでの基本数量単位を取得します。

戻り値:
baseUomIso ISO コードでの基本数量単位

getPoUnit

public String getPoUnit()
発注単位を取得します。

戻り値:
poUnit 発注単位

getPoUnitIso

public String getPoUnitIso()
ISO コードによる発注単位を取得します。

戻り値:
poUnitIso ISO コードによる発注単位

getDocument

public String getDocument()
文書番号 (文書管理システムによらない)を取得します。

戻り値:
document 文書番号 (文書管理システムによらない)

getDocType

public String getDocType()
文書タイプ (文書管理システムによらない)を取得します。

戻り値:
docType 文書タイプ (文書管理システムによらない)

getDocVers

public String getDocVers()
文書バージョン (文書管理システムによらない)を取得します。

戻り値:
docVers 文書バージョン (文書管理システムによらない)

getDocFormat

public String getDocFormat()
文書のページ書式 (文書管理システムによらない)を取得します。

戻り値:
docFormat 文書のページ書式 (文書管理システムによらない)

getDocChgNo

public String getDocChgNo()
文書変更番号 (文書管理システム外)を取得します。

戻り値:
docChgNo 文書変更番号 (文書管理システム外)

getPageNo

public String getPageNo()
文書ページ番号 (文書管理システムによらない)を取得します。

戻り値:
pageNo 文書ページ番号 (文書管理システムによらない)

getNoSheets

public String getNoSheets()
文書枚数 (文書管理システムによらない)を取得します。

戻り値:
noSheets 文書枚数 (文書管理システムによらない)

getProdMemo

public String getProdMemo()
製造/検査メモを取得します。

戻り値:
prodMemo 製造/検査メモ

getPageformat

public String getPageformat()
製造メモのページ書式を取得します。

戻り値:
pageformat 製造メモのページ書式

getSizeDim

public String getSizeDim()
サイズ/寸法を取得します。

戻り値:
sizeDim サイズ/寸法

getBasicMatl

public String getBasicMatl()
主構成物質を取得します。

戻り値:
basicMatl 主構成物質

getStdDescr

public String getStdDescr()
標準テキスト (ANSI、ISO など)を取得します。

戻り値:
stdDescr 標準テキスト (ANSI、ISO など)

getDsnOffice

public String getDsnOffice()
研究室/設計室を取得します。

戻り値:
dsnOffice 研究室/設計室

getPurValkey

public String getPurValkey()
購買許容値キーを取得します。

戻り値:
purValkey 購買許容値キー

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
netWeight 正味重量

getUnitOfWt

public String getUnitOfWt()
重量単位を取得します。

戻り値:
unitOfWt 重量単位

getUnitOfWtIso

public String getUnitOfWtIso()
ISO コードでの重量単位を取得します。

戻り値:
unitOfWtIso ISO コードでの重量単位

getContainer

public String getContainer()
容器条件を取得します。

戻り値:
container 容器条件

getStorConds

public String getStorConds()
保管条件を取得します。

戻り値:
storConds 保管条件

getTempConds

public String getTempConds()
温度条件区分を取得します。

戻り値:
tempConds 温度条件区分

getTransGrp

public String getTransGrp()
輸送グループを取得します。

戻り値:
transGrp 輸送グループ

getHazMatNo

public String getHazMatNo()
危険物コードを取得します。

戻り値:
hazMatNo 危険物コード

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getCompetitor

public String getCompetitor()
競合会社を取得します。

戻り値:
competitor 競合会社

getQtyGrGi

public String getQtyGrGi()
数量: 印刷予定入出庫票数を取得します。

戻り値:
qtyGrGi 数量: 印刷予定入出庫票数

getProcRule

public String getProcRule()
調達規則を取得します。

戻り値:
procRule 調達規則

getSupSource

public String getSupSource()
供給元を取得します。

戻り値:
supSource 供給元

getSeason

public String getSeason()
季節カテゴリを取得します。

戻り値:
season 季節カテゴリ

getLabelType

public String getLabelType()
ラベルタイプを取得します。

戻り値:
labelType ラベルタイプ

getLabelForm

public String getLabelForm()
ラベル書式を取得します。

戻り値:
labelForm ラベル書式

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getCadId

public String getCadId()
CAD 区分を取得します。

戻り値:
cadId CAD 区分

getAllowedWt

public String getAllowedWt()
許容梱包重量を取得します。

戻り値:
allowedWt 許容梱包重量

getPackWtUn

public String getPackWtUn()
重量単位 (許容梱包重量)を取得します。

戻り値:
packWtUn 重量単位 (許容梱包重量)

getPackWtUnIso

public String getPackWtUnIso()
ISO コードでの重量単位 (許容梱包重量)を取得します。

戻り値:
packWtUnIso ISO コードでの重量単位 (許容梱包重量)

getAllwdVol

public String getAllwdVol()
許容梱包容積を取得します。

戻り値:
allwdVol 許容梱包容積

getPackVoUn

public String getPackVoUn()
容積単位 (許容梱包容積)を取得します。

戻り値:
packVoUn 容積単位 (許容梱包容積)

getPackVoUnIso

public String getPackVoUnIso()
ISO コードでの容積単位 (許容梱包容積)を取得します。

戻り値:
packVoUnIso ISO コードでの容積単位 (許容梱包容積)

getWtTolLt

public String getWtTolLt()
荷役単位の重量超過許容量を取得します。

戻り値:
wtTolLt 荷役単位の重量超過許容量

getVolTolLt

public String getVolTolLt()
荷役単位の容積超過許容量を取得します。

戻り値:
volTolLt 荷役単位の容積超過許容量

getVarOrdUn

public String getVarOrdUn()
可変購買発注単位有効を取得します。

戻り値:
varOrdUn 可変購買発注単位有効

getConfigured

public String getConfigured()
選定可能品目を取得します。

戻り値:
configured 選定可能品目

getBatchMgmt

public String getBatchMgmt()
ロット管理所要量区分を取得します。

戻り値:
batchMgmt ロット管理所要量区分

getShMatTyp

public String getShMatTyp()
梱包材タイプを取得します。

戻り値:
shMatTyp 梱包材タイプ

getFillLevel

public String getFillLevel()
最大レベル (容積別)を取得します。

戻り値:
fillLevel 最大レベル (容積別)

getStackFact

public String getStackFact()
山積係数を取得します。

戻り値:
stackFact 山積係数

getMatGrpSm

public String getMatGrpSm()
品目グループ: 梱包材を取得します。

戻り値:
matGrpSm 品目グループ: 梱包材

getAuthoritygroup

public String getAuthoritygroup()
権限グループを取得します。

戻り値:
authoritygroup 権限グループ

getQmProcmnt

public String getQmProcmnt()
調達における品質管理有効を取得します。

戻り値:
qmProcmnt 調達における品質管理有効

getCatprofile

public String getCatprofile()
カタログプロファイルを取得します。

戻り値:
catprofile カタログプロファイル

getMinremlife

public String getMinremlife()
最低有効期間残を取得します。

戻り値:
minremlife 最低有効期間残

getShelfLife

public String getShelfLife()
総有効期間を取得します。

戻り値:
shelfLife 総有効期間

getStorPct

public String getStorPct()
残存有効期間割合 %を取得します。

戻り値:
storPct 残存有効期間割合 %

getConfMatl

public String getConfMatl()
プラント共通選定可能品目を取得します。

戻り値:
confMatl プラント共通選定可能品目

getCoProduct

public String getCoProduct()
区分: 連産品としても使用可能な品目を取得します。

戻り値:
coProduct 区分: 連産品としても使用可能な品目

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getPurStatus

public String getPurStatus()
プラント共通品目ステータスを取得します。

戻り値:
purStatus プラント共通品目ステータス

getSalStatus

public String getSalStatus()
流通チェーン間品目ステータスを取得します。

戻り値:
salStatus 流通チェーン間品目ステータス

getPvalidfrom

public String getPvalidfrom()
プラント共通品目のステータス有効開始日付を取得します。

戻り値:
pvalidfrom プラント共通品目のステータス有効開始日付

getSvalidfrom

public String getSvalidfrom()
流通チェーン間品目ステータスの有効開始日付を取得します。

戻り値:
svalidfrom 流通チェーン間品目ステータスの有効開始日付

getEnvtRlvt

public String getEnvtRlvt()
区分: 環境関連を取得します。

戻り値:
envtRlvt 区分: 環境関連

getProdAlloc

public String getProdAlloc()
製品割当決定手順を取得します。

戻り値:
prodAlloc 製品割当決定手順

getQualDik

public String getQualDik()
無償納入による割引対象品目を取得します。

戻り値:
qualDik 無償納入による割引対象品目

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
manuMat 製造者製品コード

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
mfrNo 製造者番号

getInvMatNo

public String getInvMatNo()
会社固有 (内部) 在庫管理品目コードを取得します。

戻り値:
invMatNo 会社固有 (内部) 在庫管理品目コード

getManufProf

public String getManufProf()
製造者製品プロファイルを取得します。

戻り値:
manufProf 製造者製品プロファイル

getHazmatprof

public String getHazmatprof()
危険物インジケータプロファイルを取得します。

戻り値:
hazmatprof 危険物インジケータプロファイル

getHighVisc

public String getHighVisc()
区分: 高粘性を取得します。

戻り値:
highVisc 区分: 高粘性

getLooseorliq

public String getLooseorliq()
区分: バルク/液体を取得します。

戻り値:
looseorliq 区分: バルク/液体

getClosedBox

public String getClosedBox()
完了した梱包材を取得します。

戻り値:
closedBox 完了した梱包材

getAppdBRec

public String getAppdBRec()
区分: バッチ製造記録の承認必須を取得します。

戻り値:
appdBRec 区分: バッチ製造記録の承認必須

getMatcmpllvl

public String getMatcmpllvl()
品目完了レベルを取得します。

戻り値:
matcmpllvl 品目完了レベル

getParEff

public String getParEff()
有効性パラメータへの値割当/変更番号よりも優先を取得します。

戻り値:
parEff 有効性パラメータへの値割当/変更番号よりも優先

getRoundUpRuleExpirationDate

public String getRoundUpRuleExpirationDate()
有効期間期限日計算の丸め規則を取得します。

戻り値:
roundUpRuleExpirationDate 有効期間期限日計算の丸め規則

getPeriodIndExpirationDate

public String getPeriodIndExpirationDate()
有効期間期限日の期間区分を取得します。

戻り値:
periodIndExpirationDate 有効期間期限日の期間区分

getProdCompositionOnPackaging

public String getProdCompositionOnPackaging()
区分: 梱包材にプリントされた生産構造を取得します。

戻り値:
prodCompositionOnPackaging 区分: 梱包材にプリントされた生産構造

getItemCat

public String getItemCat()
一般明細カテゴリグループを取得します。

戻り値:
itemCat 一般明細カテゴリグループ

getHazMatNoExternal

public String getHazMatNoExternal()
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
hazMatNoExternal 項目 HAZ_MAT_NO の品目コード (長) (今後の リリースで開発)

getHazMatNoGuid

public String getHazMatNoGuid()
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
hazMatNoGuid 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

getHazMatNoVersion

public String getHazMatNoVersion()
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
hazMatNoVersion 項目 HAZ_MAT_NO のバージョン番号 (今後の リリースで開発)

getInvMatNoExternal

public String getInvMatNoExternal()
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
invMatNoExternal 項目 INV_MAT_NO の品目コード (長) (今後の リリースで開発)

getInvMatNoGuid

public String getInvMatNoGuid()
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
invMatNoGuid 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

getInvMatNoVersion

public String getInvMatNoVersion()
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
invMatNoVersion 項目 INV_MAT_NO のバージョン番号 (今後の リリースで開発)

getMaterialFixed

public String getMaterialFixed()
ロックされている品目を取得します。

戻り値:
materialFixed ロックされている品目

getCmRelevanceFlag

public String getCmRelevanceFlag()
構成管理関連を取得します。

戻り値:
cmRelevanceFlag 構成管理関連

getSledBbd

public String getSledBbd()
有効期限を取得します。

戻り値:
sledBbd 有効期限

getGtinVariant

public String getGtinVariant()
グローバルトレード明細番号バリアントを取得します。

戻り値:
gtinVariant グローバルトレード明細番号バリアント

getSerializationLevel

public String getSerializationLevel()
シリアル番号の指定レベルを取得します。

戻り値:
serializationLevel シリアル番号の指定レベル

getPlRefMat

public String getPlRefMat()
梱包方法が同じ品目の参照品目を取得します。

戻り値:
plRefMat 梱包方法が同じ品目の参照品目

getExtmatlgrp

public String getExtmatlgrp()
外部品目グループを取得します。

戻り値:
extmatlgrp 外部品目グループ

getUomusage

public String getUomusage()
使用数量単位を取得します。

戻り値:
uomusage 使用数量単位

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setIndSector

public void setIndSector(String indSector)
産業コードを設定します。

パラメータ:
indSector - 産業コード

setMatlType

public void setMatlType(String matlType)
品目タイプを設定します。

パラメータ:
matlType - 品目タイプ

setCreatedOn

public void setCreatedOn(String createdOn)
登録日付を設定します。

パラメータ:
createdOn - 登録日付

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setLastChnge

public void setLastChnge(String lastChnge)
最終変更日付を設定します。

パラメータ:
lastChnge - 最終変更日付

setChangedBy

public void setChangedBy(String changedBy)
オブジェクトの変更者名を設定します。

パラメータ:
changedBy - オブジェクトの変更者名

setMatStatus

public void setMatStatus(String matStatus)
品目更新完了ステータスを設定します。

パラメータ:
matStatus - 品目更新完了ステータス

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
クライアントレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - クライアントレベルでの品目削除フラグ

setMatlGroup

public void setMatlGroup(String matlGroup)
品目グループを設定します。

パラメータ:
matlGroup - 品目グループ

setOldMatNo

public void setOldMatNo(String oldMatNo)
旧品目コードを設定します。

パラメータ:
oldMatNo - 旧品目コード

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setBaseUomIso

public void setBaseUomIso(String baseUomIso)
ISO コードでの基本数量単位を設定します。

パラメータ:
baseUomIso - ISO コードでの基本数量単位

setPoUnit

public void setPoUnit(String poUnit)
発注単位を設定します。

パラメータ:
poUnit - 発注単位

setPoUnitIso

public void setPoUnitIso(String poUnitIso)
ISO コードによる発注単位を設定します。

パラメータ:
poUnitIso - ISO コードによる発注単位

setDocument

public void setDocument(String document)
文書番号 (文書管理システムによらない)を設定します。

パラメータ:
document - 文書番号 (文書管理システムによらない)

setDocType

public void setDocType(String docType)
文書タイプ (文書管理システムによらない)を設定します。

パラメータ:
docType - 文書タイプ (文書管理システムによらない)

setDocVers

public void setDocVers(String docVers)
文書バージョン (文書管理システムによらない)を設定します。

パラメータ:
docVers - 文書バージョン (文書管理システムによらない)

setDocFormat

public void setDocFormat(String docFormat)
文書のページ書式 (文書管理システムによらない)を設定します。

パラメータ:
docFormat - 文書のページ書式 (文書管理システムによらない)

setDocChgNo

public void setDocChgNo(String docChgNo)
文書変更番号 (文書管理システム外)を設定します。

パラメータ:
docChgNo - 文書変更番号 (文書管理システム外)

setPageNo

public void setPageNo(String pageNo)
文書ページ番号 (文書管理システムによらない)を設定します。

パラメータ:
pageNo - 文書ページ番号 (文書管理システムによらない)

setNoSheets

public void setNoSheets(String noSheets)
文書枚数 (文書管理システムによらない)を設定します。

パラメータ:
noSheets - 文書枚数 (文書管理システムによらない)

setProdMemo

public void setProdMemo(String prodMemo)
製造/検査メモを設定します。

パラメータ:
prodMemo - 製造/検査メモ

setPageformat

public void setPageformat(String pageformat)
製造メモのページ書式を設定します。

パラメータ:
pageformat - 製造メモのページ書式

setSizeDim

public void setSizeDim(String sizeDim)
サイズ/寸法を設定します。

パラメータ:
sizeDim - サイズ/寸法

setBasicMatl

public void setBasicMatl(String basicMatl)
主構成物質を設定します。

パラメータ:
basicMatl - 主構成物質

setStdDescr

public void setStdDescr(String stdDescr)
標準テキスト (ANSI、ISO など)を設定します。

パラメータ:
stdDescr - 標準テキスト (ANSI、ISO など)

setDsnOffice

public void setDsnOffice(String dsnOffice)
研究室/設計室を設定します。

パラメータ:
dsnOffice - 研究室/設計室

setPurValkey

public void setPurValkey(String purValkey)
購買許容値キーを設定します。

パラメータ:
purValkey - 購買許容値キー

setNetWeight

public void setNetWeight(String netWeight)
正味重量を設定します。

パラメータ:
netWeight - 正味重量

setUnitOfWt

public void setUnitOfWt(String unitOfWt)
重量単位を設定します。

パラメータ:
unitOfWt - 重量単位

setUnitOfWtIso

public void setUnitOfWtIso(String unitOfWtIso)
ISO コードでの重量単位を設定します。

パラメータ:
unitOfWtIso - ISO コードでの重量単位

setContainer

public void setContainer(String container)
容器条件を設定します。

パラメータ:
container - 容器条件

setStorConds

public void setStorConds(String storConds)
保管条件を設定します。

パラメータ:
storConds - 保管条件

setTempConds

public void setTempConds(String tempConds)
温度条件区分を設定します。

パラメータ:
tempConds - 温度条件区分

setTransGrp

public void setTransGrp(String transGrp)
輸送グループを設定します。

パラメータ:
transGrp - 輸送グループ

setHazMatNo

public void setHazMatNo(String hazMatNo)
危険物コードを設定します。

パラメータ:
hazMatNo - 危険物コード

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setCompetitor

public void setCompetitor(String competitor)
競合会社を設定します。

パラメータ:
competitor - 競合会社

setQtyGrGi

public void setQtyGrGi(String qtyGrGi)
数量: 印刷予定入出庫票数を設定します。

パラメータ:
qtyGrGi - 数量: 印刷予定入出庫票数

setProcRule

public void setProcRule(String procRule)
調達規則を設定します。

パラメータ:
procRule - 調達規則

setSupSource

public void setSupSource(String supSource)
供給元を設定します。

パラメータ:
supSource - 供給元

setSeason

public void setSeason(String season)
季節カテゴリを設定します。

パラメータ:
season - 季節カテゴリ

setLabelType

public void setLabelType(String labelType)
ラベルタイプを設定します。

パラメータ:
labelType - ラベルタイプ

setLabelForm

public void setLabelForm(String labelForm)
ラベル書式を設定します。

パラメータ:
labelForm - ラベル書式

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setCadId

public void setCadId(String cadId)
CAD 区分を設定します。

パラメータ:
cadId - CAD 区分

setAllowedWt

public void setAllowedWt(String allowedWt)
許容梱包重量を設定します。

パラメータ:
allowedWt - 許容梱包重量

setPackWtUn

public void setPackWtUn(String packWtUn)
重量単位 (許容梱包重量)を設定します。

パラメータ:
packWtUn - 重量単位 (許容梱包重量)

setPackWtUnIso

public void setPackWtUnIso(String packWtUnIso)
ISO コードでの重量単位 (許容梱包重量)を設定します。

パラメータ:
packWtUnIso - ISO コードでの重量単位 (許容梱包重量)

setAllwdVol

public void setAllwdVol(String allwdVol)
許容梱包容積を設定します。

パラメータ:
allwdVol - 許容梱包容積

setPackVoUn

public void setPackVoUn(String packVoUn)
容積単位 (許容梱包容積)を設定します。

パラメータ:
packVoUn - 容積単位 (許容梱包容積)

setPackVoUnIso

public void setPackVoUnIso(String packVoUnIso)
ISO コードでの容積単位 (許容梱包容積)を設定します。

パラメータ:
packVoUnIso - ISO コードでの容積単位 (許容梱包容積)

setWtTolLt

public void setWtTolLt(String wtTolLt)
荷役単位の重量超過許容量を設定します。

パラメータ:
wtTolLt - 荷役単位の重量超過許容量

setVolTolLt

public void setVolTolLt(String volTolLt)
荷役単位の容積超過許容量を設定します。

パラメータ:
volTolLt - 荷役単位の容積超過許容量

setVarOrdUn

public void setVarOrdUn(String varOrdUn)
可変購買発注単位有効を設定します。

パラメータ:
varOrdUn - 可変購買発注単位有効

setConfigured

public void setConfigured(String configured)
選定可能品目を設定します。

パラメータ:
configured - 選定可能品目

setBatchMgmt

public void setBatchMgmt(String batchMgmt)
ロット管理所要量区分を設定します。

パラメータ:
batchMgmt - ロット管理所要量区分

setShMatTyp

public void setShMatTyp(String shMatTyp)
梱包材タイプを設定します。

パラメータ:
shMatTyp - 梱包材タイプ

setFillLevel

public void setFillLevel(String fillLevel)
最大レベル (容積別)を設定します。

パラメータ:
fillLevel - 最大レベル (容積別)

setStackFact

public void setStackFact(String stackFact)
山積係数を設定します。

パラメータ:
stackFact - 山積係数

setMatGrpSm

public void setMatGrpSm(String matGrpSm)
品目グループ: 梱包材を設定します。

パラメータ:
matGrpSm - 品目グループ: 梱包材

setAuthoritygroup

public void setAuthoritygroup(String authoritygroup)
権限グループを設定します。

パラメータ:
authoritygroup - 権限グループ

setQmProcmnt

public void setQmProcmnt(String qmProcmnt)
調達における品質管理有効を設定します。

パラメータ:
qmProcmnt - 調達における品質管理有効

setCatprofile

public void setCatprofile(String catprofile)
カタログプロファイルを設定します。

パラメータ:
catprofile - カタログプロファイル

setMinremlife

public void setMinremlife(String minremlife)
最低有効期間残を設定します。

パラメータ:
minremlife - 最低有効期間残

setShelfLife

public void setShelfLife(String shelfLife)
総有効期間を設定します。

パラメータ:
shelfLife - 総有効期間

setStorPct

public void setStorPct(String storPct)
残存有効期間割合 %を設定します。

パラメータ:
storPct - 残存有効期間割合 %

setConfMatl

public void setConfMatl(String confMatl)
プラント共通選定可能品目を設定します。

パラメータ:
confMatl - プラント共通選定可能品目

setCoProduct

public void setCoProduct(String coProduct)
区分: 連産品としても使用可能な品目を設定します。

パラメータ:
coProduct - 区分: 連産品としても使用可能な品目

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setPurStatus

public void setPurStatus(String purStatus)
プラント共通品目ステータスを設定します。

パラメータ:
purStatus - プラント共通品目ステータス

setSalStatus

public void setSalStatus(String salStatus)
流通チェーン間品目ステータスを設定します。

パラメータ:
salStatus - 流通チェーン間品目ステータス

setPvalidfrom

public void setPvalidfrom(String pvalidfrom)
プラント共通品目のステータス有効開始日付を設定します。

パラメータ:
pvalidfrom - プラント共通品目のステータス有効開始日付

setSvalidfrom

public void setSvalidfrom(String svalidfrom)
流通チェーン間品目ステータスの有効開始日付を設定します。

パラメータ:
svalidfrom - 流通チェーン間品目ステータスの有効開始日付

setEnvtRlvt

public void setEnvtRlvt(String envtRlvt)
区分: 環境関連を設定します。

パラメータ:
envtRlvt - 区分: 環境関連

setProdAlloc

public void setProdAlloc(String prodAlloc)
製品割当決定手順を設定します。

パラメータ:
prodAlloc - 製品割当決定手順

setQualDik

public void setQualDik(String qualDik)
無償納入による割引対象品目を設定します。

パラメータ:
qualDik - 無償納入による割引対象品目

setManuMat

public void setManuMat(String manuMat)
製造者製品コードを設定します。

パラメータ:
manuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String mfrNo)
製造者番号を設定します。

パラメータ:
mfrNo - 製造者番号

setInvMatNo

public void setInvMatNo(String invMatNo)
会社固有 (内部) 在庫管理品目コードを設定します。

パラメータ:
invMatNo - 会社固有 (内部) 在庫管理品目コード

setManufProf

public void setManufProf(String manufProf)
製造者製品プロファイルを設定します。

パラメータ:
manufProf - 製造者製品プロファイル

setHazmatprof

public void setHazmatprof(String hazmatprof)
危険物インジケータプロファイルを設定します。

パラメータ:
hazmatprof - 危険物インジケータプロファイル

setHighVisc

public void setHighVisc(String highVisc)
区分: 高粘性を設定します。

パラメータ:
highVisc - 区分: 高粘性

setLooseorliq

public void setLooseorliq(String looseorliq)
区分: バルク/液体を設定します。

パラメータ:
looseorliq - 区分: バルク/液体

setClosedBox

public void setClosedBox(String closedBox)
完了した梱包材を設定します。

パラメータ:
closedBox - 完了した梱包材

setAppdBRec

public void setAppdBRec(String appdBRec)
区分: バッチ製造記録の承認必須を設定します。

パラメータ:
appdBRec - 区分: バッチ製造記録の承認必須

setMatcmpllvl

public void setMatcmpllvl(String matcmpllvl)
品目完了レベルを設定します。

パラメータ:
matcmpllvl - 品目完了レベル

setParEff

public void setParEff(String parEff)
有効性パラメータへの値割当/変更番号よりも優先を設定します。

パラメータ:
parEff - 有効性パラメータへの値割当/変更番号よりも優先

setRoundUpRuleExpirationDate

public void setRoundUpRuleExpirationDate(String roundUpRuleExpirationDate)
有効期間期限日計算の丸め規則を設定します。

パラメータ:
roundUpRuleExpirationDate - 有効期間期限日計算の丸め規則

setPeriodIndExpirationDate

public void setPeriodIndExpirationDate(String periodIndExpirationDate)
有効期間期限日の期間区分を設定します。

パラメータ:
periodIndExpirationDate - 有効期間期限日の期間区分

setProdCompositionOnPackaging

public void setProdCompositionOnPackaging(String prodCompositionOnPackaging)
区分: 梱包材にプリントされた生産構造を設定します。

パラメータ:
prodCompositionOnPackaging - 区分: 梱包材にプリントされた生産構造

setItemCat

public void setItemCat(String itemCat)
一般明細カテゴリグループを設定します。

パラメータ:
itemCat - 一般明細カテゴリグループ

setHazMatNoExternal

public void setHazMatNoExternal(String hazMatNoExternal)
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoExternal - 項目 HAZ_MAT_NO の品目コード (長) (今後の リリースで開発)

setHazMatNoGuid

public void setHazMatNoGuid(String hazMatNoGuid)
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoGuid - 項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

setHazMatNoVersion

public void setHazMatNoVersion(String hazMatNoVersion)
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
hazMatNoVersion - 項目 HAZ_MAT_NO のバージョン番号 (今後の リリースで開発)

setInvMatNoExternal

public void setInvMatNoExternal(String invMatNoExternal)
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
invMatNoExternal - 項目 INV_MAT_NO の品目コード (長) (今後の リリースで開発)

setInvMatNoGuid

public void setInvMatNoGuid(String invMatNoGuid)
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
invMatNoGuid - 項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

setInvMatNoVersion

public void setInvMatNoVersion(String invMatNoVersion)
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
invMatNoVersion - 項目 INV_MAT_NO のバージョン番号 (今後の リリースで開発)

setMaterialFixed

public void setMaterialFixed(String materialFixed)
ロックされている品目を設定します。

パラメータ:
materialFixed - ロックされている品目

setCmRelevanceFlag

public void setCmRelevanceFlag(String cmRelevanceFlag)
構成管理関連を設定します。

パラメータ:
cmRelevanceFlag - 構成管理関連

setSledBbd

public void setSledBbd(String sledBbd)
有効期限を設定します。

パラメータ:
sledBbd - 有効期限

setGtinVariant

public void setGtinVariant(String gtinVariant)
グローバルトレード明細番号バリアントを設定します。

パラメータ:
gtinVariant - グローバルトレード明細番号バリアント

setSerializationLevel

public void setSerializationLevel(String serializationLevel)
シリアル番号の指定レベルを設定します。

パラメータ:
serializationLevel - シリアル番号の指定レベル

setPlRefMat

public void setPlRefMat(String plRefMat)
梱包方法が同じ品目の参照品目を設定します。

パラメータ:
plRefMat - 梱包方法が同じ品目の参照品目

setExtmatlgrp

public void setExtmatlgrp(String extmatlgrp)
外部品目グループを設定します。

パラメータ:
extmatlgrp - 外部品目グループ

setUomusage

public void setUomusage(String uomusage)
使用数量単位を設定します。

パラメータ:
uomusage - 使用数量単位

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ClientDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ClientDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList
すべての実装インタフェース:
Serializable
public class ClientDataList
extends ClientData
implements Serializable

品目データ (クライアントレベル)情報クラス
機能は以下の通り

  • 品目データ (クライアントレベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ClientDataList()
品目データ (クライアントレベル)情報を作成します。
ClientDataList(int index)
品目データ (クライアントレベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData から継承したメソッド
getAllowedWt, getAllwdVol, getAppdBRec, getAuthoritygroup, getBaseUom, getBaseUomIso, getBasicMatl, getBatchMgmt, getCadId, getCatprofile, getChangedBy, getClosedBox, getCmRelevanceFlag, getCompetitor, getConfigured, getConfMatl, getContainer, getCoProduct, getCreatedBy, getCreatedOn, getDelFlag, getDivision, getDocChgNo, getDocFormat, getDocType, getDocument, getDocVers, getDsnOffice, getEnvtRlvt, getExtmatlgrp, getFillLevel, getFunction, getGtinVariant, getHazMatNo, getHazMatNoExternal, getHazMatNoGuid, getHazMatNoVersion, getHazmatprof, getHighVisc, getIndSector, getInvMatNo, getInvMatNoExternal, getInvMatNoGuid, getInvMatNoVersion, getItemCat, getLabelForm, getLabelType, getLastChnge, getLooseorliq, getMaintStat, getManufProf, getManuMat, getMatcmpllvl, getMaterial, getMaterialFixed, getMatGrpSm, getMatlGroup, getMatlType, getMatStatus, getMfrNo, getMinremlife, getNetWeight, getNoSheets, getOldMatNo, getPackVoUn, getPackVoUnIso, getPackWtUn, getPackWtUnIso, getPageformat, getPageNo, getParEff, getPeriodIndExpirationDate, getPlRefMat, getPoUnit, getPoUnitIso, getProcRule, getProdAlloc, getProdCompositionOnPackaging, getProdHier, getProdMemo, getPrRefMat, getPurStatus, getPurValkey, getPvalidfrom, getQmProcmnt, getQtyGrGi, getQualDik, getRoundUpRuleExpirationDate, getSalStatus, getSeason, getSerializationLevel, getShelfLife, getShMatTyp, getSizeDim, getSledBbd, getStackFact, getStdDescr, getStorConds, getStorPct, getSupSource, getSvalidfrom, getTempConds, getTransGrp, getUnitOfWt, getUnitOfWtIso, getUomusage, getVarOrdUn, getVolTolLt, getWtTolLt, setAllowedWt, setAllwdVol, setAppdBRec, setAuthoritygroup, setBaseUom, setBaseUomIso, setBasicMatl, setBatchMgmt, setCadId, setCatprofile, setChangedBy, setClosedBox, setCmRelevanceFlag, setCompetitor, setConfigured, setConfMatl, setContainer, setCoProduct, setCreatedBy, setCreatedOn, setDelFlag, setDivision, setDocChgNo, setDocFormat, setDocType, setDocument, setDocVers, setDsnOffice, setEnvtRlvt, setExtmatlgrp, setFillLevel, setFunction, setGtinVariant, setHazMatNo, setHazMatNoExternal, setHazMatNoGuid, setHazMatNoVersion, setHazmatprof, setHighVisc, setIndSector, setInvMatNo, setInvMatNoExternal, setInvMatNoGuid, setInvMatNoVersion, setItemCat, setLabelForm, setLabelType, setLastChnge, setLooseorliq, setMaintStat, setManufProf, setManuMat, setMatcmpllvl, setMaterial, setMaterialFixed, setMatGrpSm, setMatlGroup, setMatlType, setMatStatus, setMfrNo, setMinremlife, setNetWeight, setNoSheets, setOldMatNo, setPackVoUn, setPackVoUnIso, setPackWtUn, setPackWtUnIso, setPageformat, setPageNo, setParEff, setPeriodIndExpirationDate, setPlRefMat, setPoUnit, setPoUnitIso, setProcRule, setProdAlloc, setProdCompositionOnPackaging, setProdHier, setProdMemo, setPrRefMat, setPurStatus, setPurValkey, setPvalidfrom, setQmProcmnt, setQtyGrGi, setQualDik, setRoundUpRuleExpirationDate, setSalStatus, setSeason, setSerializationLevel, setShelfLife, setShMatTyp, setSizeDim, setSledBbd, setStackFact, setStdDescr, setStorConds, setStorPct, setSupSource, setSvalidfrom, setTempConds, setTransGrp, setUnitOfWt, setUnitOfWtIso, setUomusage, setVarOrdUn, setVolTolLt, setWtTolLt, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ClientDataList

public ClientDataList()
品目データ (クライアントレベル)情報を作成します。

ClientDataList

public ClientDataList(int index)
品目データ (クライアントレベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastParameters (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ForecastParameters

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ForecastParametersList
public class ForecastParameters
extends Object
implements Serializable

予測パラメータ情報クラス
機能は以下の通り

  • 予測パラメータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastParameters()
予測パラメータ情報を作成します。
メソッドの概要
String | getAlphaFact() アルファ係数使用による基本値の平滑化を取得します。
String | getBasicValue() 基準値を取得します。
String | getBasicValue1() 第二指図の基準値を取得します。
String | getBasicValue2() 第二指図の基準値を取得します。
String | getBasicValuePp() 前期間の基準値を取得します。
String | getBasicValuePp1() 前期間における第二指図の基準値を取得します。
String | getBasicValuePp2() 前期間における第二指図の基準値を取得します。
String | getBetaFact() ベータ係数による傾向値平準化を取得します。
String | getCoeffTheil() タイル係数を取得します。
String | getDeltaFact() デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。
String | getErrorTotal() エラー合計を取得します。
String | getErrorTotalPp() 前期間のエラー合計を取得します。
String | getExceptList() 例外メッセージバーを取得します。
String | getExpostPds() 事後的需要予測に含む履歴値の数を取得します。
String | getFixedPds() 固定期間を取得します。
String | getForecFlowCont() 予測フロー管理を取得します。
String | getForeDate() 最終需要予測日を取得します。
String | getForeModel() 予測モデルを取得します。
String | getForePds() 需要予測期間を取得します。
String | getForeProf() 需要予測プロファイルを取得します。
String | getFunction() BAPI 機能を取得します。
String | getFyVariant() 会計年度バリアントを取得します。
String | getGammaFact() ガンマ係数使用の平滑化のための季節指数を取得します。
String | getHistVals() 履歴値の数を取得します。
String | getInitialize() 初期化区分を取得します。
String | getInitPds() 初期化で使用する履歴値の数を取得します。
String | getMaterial() 品目コードを取得します。
String | getMeanAbsolDev() 絶対平均偏差 (MAD)を取得します。
String | getMeanAbsolDevPp() 前期間の平均絶対偏差を取得します。
String | getModelSi() モデル選択区分を取得します。
String | getModelSp() モデル選択方式を取得します。
String | getOptimLev() 最適化レベルを取得します。
String | getParamOpt() パラメータ最適化用の区分を取得します。
String | getPeriodInd() 期間区分を取得します。
String | getPlant() プラントを取得します。
String | getSeasonPds() 季節周期ごとの期間数を取得します。
String | getTracklimit() 警告限界を取得します。
String | getTrendValue() 傾向値を取得します。
String | getTrendValuePp() 前期間の傾向値を取得します。
String | getWtgGroup() 加重グループを取得します。
void | setAlphaFact(String alphaFact) アルファ係数使用による基本値の平滑化を設定します。
void | setBasicValue(String basicValue) 基準値を設定します。
void | setBasicValue1(String basicValue1) 第二指図の基準値を設定します。
void | setBasicValue2(String basicValue2) 第二指図の基準値を設定します。
void | setBasicValuePp(String basicValuePp) 前期間の基準値を設定します。
void | setBasicValuePp1(String basicValuePp1) 前期間における第二指図の基準値を設定します。
void | setBasicValuePp2(String basicValuePp2) 前期間における第二指図の基準値を設定します。
void | setBetaFact(String betaFact) ベータ係数による傾向値平準化を設定します。
void | setCoeffTheil(String coeffTheil) タイル係数を設定します。
void | setDeltaFact(String deltaFact) デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。
void | setErrorTotal(String errorTotal) エラー合計を設定します。
void | setErrorTotalPp(String errorTotalPp) 前期間のエラー合計を設定します。
void | setExceptList(String exceptList) 例外メッセージバーを設定します。
void | setExpostPds(String expostPds) 事後的需要予測に含む履歴値の数を設定します。
void | setFixedPds(String fixedPds) 固定期間を設定します。
void | setForecFlowCont(String forecFlowCont) 予測フロー管理を設定します。
void | setForeDate(String foreDate) 最終需要予測日を設定します。
void | setForeModel(String foreModel) 予測モデルを設定します。
void | setForePds(String forePds) 需要予測期間を設定します。
void | setForeProf(String foreProf) 需要予測プロファイルを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFyVariant(String fyVariant) 会計年度バリアントを設定します。
void | setGammaFact(String gammaFact) ガンマ係数使用の平滑化のための季節指数を設定します。
void | setHistVals(String histVals) 履歴値の数を設定します。
void | setInitialize(String initialize) 初期化区分を設定します。
void | setInitPds(String initPds) 初期化で使用する履歴値の数を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMeanAbsolDev(String meanAbsolDev) 絶対平均偏差 (MAD)を設定します。
void | setMeanAbsolDevPp(String meanAbsolDevPp) 前期間の平均絶対偏差を設定します。
void | setModelSi(String modelSi) モデル選択区分を設定します。
void | setModelSp(String modelSp) モデル選択方式を設定します。
void | setOptimLev(String optimLev) 最適化レベルを設定します。
void | setParamOpt(String paramOpt) パラメータ最適化用の区分を設定します。
void | setPeriodInd(String periodInd) 期間区分を設定します。
void | setPlant(String plant) プラントを設定します。
void | setSeasonPds(String seasonPds) 季節周期ごとの期間数を設定します。
void | setTracklimit(String tracklimit) 警告限界を設定します。
void | setTrendValue(String trendValue) 傾向値を設定します。
void | setTrendValuePp(String trendValuePp) 前期間の傾向値を設定します。
void | setWtgGroup(String wtgGroup) 加重グループを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastParameters

public ForecastParameters()
予測パラメータ情報を作成します。 需要予測パラメータ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getForeProf

public String getForeProf()
需要予測プロファイルを取得します。

戻り値:
foreProf 需要予測プロファイル

getModelSi

public String getModelSi()
モデル選択区分を取得します。

戻り値:
modelSi モデル選択区分

getModelSp

public String getModelSp()
モデル選択方式を取得します。

戻り値:
modelSp モデル選択方式

getParamOpt

public String getParamOpt()
パラメータ最適化用の区分を取得します。

戻り値:
paramOpt パラメータ最適化用の区分

getOptimLev

public String getOptimLev()
最適化レベルを取得します。

戻り値:
optimLev 最適化レベル

getInitialize

public String getInitialize()
初期化区分を取得します。

戻り値:
initialize 初期化区分

getForeModel

public String getForeModel()
予測モデルを取得します。

戻り値:
foreModel 予測モデル

getAlphaFact

public String getAlphaFact()
アルファ係数使用による基本値の平滑化を取得します。

戻り値:
alphaFact アルファ係数使用による基本値の平滑化

getBetaFact

public String getBetaFact()
ベータ係数による傾向値平準化を取得します。

戻り値:
betaFact ベータ係数による傾向値平準化

getGammaFact

public String getGammaFact()
ガンマ係数使用の平滑化のための季節指数を取得します。

戻り値:
gammaFact ガンマ係数使用の平滑化のための季節指数

getDeltaFact

public String getDeltaFact()
デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。

戻り値:
deltaFact デルタ係数使用による MAD (絶対平均偏差) 平準化

getTracklimit

public String getTracklimit()
警告限界を取得します。

戻り値:
tracklimit 警告限界

getForeDate

public String getForeDate()
最終需要予測日を取得します。

戻り値:
foreDate 最終需要予測日

getHistVals

public String getHistVals()
履歴値の数を取得します。

戻り値:
histVals 履歴値の数

getInitPds

public String getInitPds()
初期化で使用する履歴値の数を取得します。

戻り値:
initPds 初期化で使用する履歴値の数

getSeasonPds

public String getSeasonPds()
季節周期ごとの期間数を取得します。

戻り値:
seasonPds 季節周期ごとの期間数

getExpostPds

public String getExpostPds()
事後的需要予測に含む履歴値の数を取得します。

戻り値:
expostPds 事後的需要予測に含む履歴値の数

getForePds

public String getForePds()
需要予測期間を取得します。

戻り値:
forePds 需要予測期間

getFixedPds

public String getFixedPds()
固定期間を取得します。

戻り値:
fixedPds 固定期間

getBasicValue

public String getBasicValue()
基準値を取得します。

戻り値:
basicValue 基準値

getBasicValue1

public String getBasicValue1()
第二指図の基準値を取得します。

戻り値:
basicValue1 第二指図の基準値

getBasicValue2

public String getBasicValue2()
第二指図の基準値を取得します。

戻り値:
basicValue2 第二指図の基準値

getBasicValuePp

public String getBasicValuePp()
前期間の基準値を取得します。

戻り値:
basicValuePp 前期間の基準値

getBasicValuePp1

public String getBasicValuePp1()
前期間における第二指図の基準値を取得します。

戻り値:
basicValuePp1 前期間における第二指図の基準値

getBasicValuePp2

public String getBasicValuePp2()
前期間における第二指図の基準値を取得します。

戻り値:
basicValuePp2 前期間における第二指図の基準値

getTrendValue

public String getTrendValue()
傾向値を取得します。

戻り値:
trendValue 傾向値

getTrendValuePp

public String getTrendValuePp()
前期間の傾向値を取得します。

戻り値:
trendValuePp 前期間の傾向値

getMeanAbsolDev

public String getMeanAbsolDev()
絶対平均偏差 (MAD)を取得します。

戻り値:
meanAbsolDev 絶対平均偏差 (MAD)

getMeanAbsolDevPp

public String getMeanAbsolDevPp()
前期間の平均絶対偏差を取得します。

戻り値:
meanAbsolDevPp 前期間の平均絶対偏差

getErrorTotal

public String getErrorTotal()
エラー合計を取得します。

戻り値:
errorTotal エラー合計

getErrorTotalPp

public String getErrorTotalPp()
前期間のエラー合計を取得します。

戻り値:
errorTotalPp 前期間のエラー合計

getWtgGroup

public String getWtgGroup()
加重グループを取得します。

戻り値:
wtgGroup 加重グループ

getCoeffTheil

public String getCoeffTheil()
タイル係数を取得します。

戻り値:
coeffTheil タイル係数

getExceptList

public String getExceptList()
例外メッセージバーを取得します。

戻り値:
exceptList 例外メッセージバー

getForecFlowCont

public String getForecFlowCont()
予測フロー管理を取得します。

戻り値:
forecFlowCont 予測フロー管理

getPeriodInd

public String getPeriodInd()
期間区分を取得します。

戻り値:
periodInd 期間区分

getFyVariant

public String getFyVariant()
会計年度バリアントを取得します。

戻り値:
fyVariant 会計年度バリアント

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setForeProf

public void setForeProf(String foreProf)
需要予測プロファイルを設定します。

パラメータ:
foreProf - 需要予測プロファイル

setModelSi

public void setModelSi(String modelSi)
モデル選択区分を設定します。

パラメータ:
modelSi - モデル選択区分

setModelSp

public void setModelSp(String modelSp)
モデル選択方式を設定します。

パラメータ:
modelSp - モデル選択方式

setParamOpt

public void setParamOpt(String paramOpt)
パラメータ最適化用の区分を設定します。

パラメータ:
paramOpt - パラメータ最適化用の区分

setOptimLev

public void setOptimLev(String optimLev)
最適化レベルを設定します。

パラメータ:
optimLev - 最適化レベル

setInitialize

public void setInitialize(String initialize)
初期化区分を設定します。

パラメータ:
initialize - 初期化区分

setForeModel

public void setForeModel(String foreModel)
予測モデルを設定します。

パラメータ:
foreModel - 予測モデル

setAlphaFact

public void setAlphaFact(String alphaFact)
アルファ係数使用による基本値の平滑化を設定します。

パラメータ:
alphaFact - アルファ係数使用による基本値の平滑化

setBetaFact

public void setBetaFact(String betaFact)
ベータ係数による傾向値平準化を設定します。

パラメータ:
betaFact - ベータ係数による傾向値平準化

setGammaFact

public void setGammaFact(String gammaFact)
ガンマ係数使用の平滑化のための季節指数を設定します。

パラメータ:
gammaFact - ガンマ係数使用の平滑化のための季節指数

setDeltaFact

public void setDeltaFact(String deltaFact)
デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。

パラメータ:
deltaFact - デルタ係数使用による MAD (絶対平均偏差) 平準化

setTracklimit

public void setTracklimit(String tracklimit)
警告限界を設定します。

パラメータ:
tracklimit - 警告限界

setForeDate

public void setForeDate(String foreDate)
最終需要予測日を設定します。

パラメータ:
foreDate - 最終需要予測日

setHistVals

public void setHistVals(String histVals)
履歴値の数を設定します。

パラメータ:
histVals - 履歴値の数

setInitPds

public void setInitPds(String initPds)
初期化で使用する履歴値の数を設定します。

パラメータ:
initPds - 初期化で使用する履歴値の数

setSeasonPds

public void setSeasonPds(String seasonPds)
季節周期ごとの期間数を設定します。

パラメータ:
seasonPds - 季節周期ごとの期間数

setExpostPds

public void setExpostPds(String expostPds)
事後的需要予測に含む履歴値の数を設定します。

パラメータ:
expostPds - 事後的需要予測に含む履歴値の数

setForePds

public void setForePds(String forePds)
需要予測期間を設定します。

パラメータ:
forePds - 需要予測期間

setFixedPds

public void setFixedPds(String fixedPds)
固定期間を設定します。

パラメータ:
fixedPds - 固定期間

setBasicValue

public void setBasicValue(String basicValue)
基準値を設定します。

パラメータ:
basicValue - 基準値

setBasicValue1

public void setBasicValue1(String basicValue1)
第二指図の基準値を設定します。

パラメータ:
basicValue1 - 第二指図の基準値

setBasicValue2

public void setBasicValue2(String basicValue2)
第二指図の基準値を設定します。

パラメータ:
basicValue2 - 第二指図の基準値

setBasicValuePp

public void setBasicValuePp(String basicValuePp)
前期間の基準値を設定します。

パラメータ:
basicValuePp - 前期間の基準値

setBasicValuePp1

public void setBasicValuePp1(String basicValuePp1)
前期間における第二指図の基準値を設定します。

パラメータ:
basicValuePp1 - 前期間における第二指図の基準値

setBasicValuePp2

public void setBasicValuePp2(String basicValuePp2)
前期間における第二指図の基準値を設定します。

パラメータ:
basicValuePp2 - 前期間における第二指図の基準値

setTrendValue

public void setTrendValue(String trendValue)
傾向値を設定します。

パラメータ:
trendValue - 傾向値

setTrendValuePp

public void setTrendValuePp(String trendValuePp)
前期間の傾向値を設定します。

パラメータ:
trendValuePp - 前期間の傾向値

setMeanAbsolDev

public void setMeanAbsolDev(String meanAbsolDev)
絶対平均偏差 (MAD)を設定します。

パラメータ:
meanAbsolDev - 絶対平均偏差 (MAD)

setMeanAbsolDevPp

public void setMeanAbsolDevPp(String meanAbsolDevPp)
前期間の平均絶対偏差を設定します。

パラメータ:
meanAbsolDevPp - 前期間の平均絶対偏差

setErrorTotal

public void setErrorTotal(String errorTotal)
エラー合計を設定します。

パラメータ:
errorTotal - エラー合計

setErrorTotalPp

public void setErrorTotalPp(String errorTotalPp)
前期間のエラー合計を設定します。

パラメータ:
errorTotalPp - 前期間のエラー合計

setWtgGroup

public void setWtgGroup(String wtgGroup)
加重グループを設定します。

パラメータ:
wtgGroup - 加重グループ

setCoeffTheil

public void setCoeffTheil(String coeffTheil)
タイル係数を設定します。

パラメータ:
coeffTheil - タイル係数

setExceptList

public void setExceptList(String exceptList)
例外メッセージバーを設定します。

パラメータ:
exceptList - 例外メッセージバー

setForecFlowCont

public void setForecFlowCont(String forecFlowCont)
予測フロー管理を設定します。

パラメータ:
forecFlowCont - 予測フロー管理

setPeriodInd

public void setPeriodInd(String periodInd)
期間区分を設定します。

パラメータ:
periodInd - 期間区分

setFyVariant

public void setFyVariant(String fyVariant)
会計年度バリアントを設定します。

パラメータ:
fyVariant - 会計年度バリアント

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastParametersList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ForecastParametersList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList
すべての実装インタフェース:
Serializable
public class ForecastParametersList
extends ForecastParameters
implements Serializable

需要予測パラメータ情報クラス
機能は以下の通り

  • 需要予測パラメータ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastParametersList()
需要予測パラメータ情報を作成します。
ForecastParametersList(int index)
需要予測パラメータ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters から継承したメソッド
getAlphaFact, getBasicValue, getBasicValue1, getBasicValue2, getBasicValuePp, getBasicValuePp1, getBasicValuePp2, getBetaFact, getCoeffTheil, getDeltaFact, getErrorTotal, getErrorTotalPp, getExceptList, getExpostPds, getFixedPds, getForecFlowCont, getForeDate, getForeModel, getForePds, getForeProf, getFunction, getFyVariant, getGammaFact, getHistVals, getInitialize, getInitPds, getMaterial, getMeanAbsolDev, getMeanAbsolDevPp, getModelSi, getModelSp, getOptimLev, getParamOpt, getPeriodInd, getPlant, getSeasonPds, getTracklimit, getTrendValue, getTrendValuePp, getWtgGroup, setAlphaFact, setBasicValue, setBasicValue1, setBasicValue2, setBasicValuePp, setBasicValuePp1, setBasicValuePp2, setBetaFact, setCoeffTheil, setDeltaFact, setErrorTotal, setErrorTotalPp, setExceptList, setExpostPds, setFixedPds, setForecFlowCont, setForeDate, setForeModel, setForePds, setForeProf, setFunction, setFyVariant, setGammaFact, setHistVals, setInitialize, setInitPds, setMaterial, setMeanAbsolDev, setMeanAbsolDevPp, setModelSi, setModelSp, setOptimLev, setParamOpt, setPeriodInd, setPlant, setSeasonPds, setTracklimit, setTrendValue, setTrendValuePp, setWtgGroup, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastParametersList

public ForecastParametersList()
需要予測パラメータ情報を作成します。

ForecastParametersList

public ForecastParametersList(int index)
需要予測パラメータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtHeaderList
public class GoodsMvtHeader
extends Object
implements Serializable

入出庫伝票ヘッダデータ情報クラス
機能は以下の通り

  • 入出庫伝票ヘッダデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeader()
入出庫伝票ヘッダデータ情報を作成します。
メソッドの概要
String | getBarCode() バーコードエントリを取得します。
String | getBillOfLading() 入庫時に登録した B/L 番号を取得します。
String | getBillOfLadingLong() 入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。
String | getDocDate() 伝票の伝票日付を取得します。
String | getDocYear() 入出庫伝票年度を取得します。
String | getEntryDate() 会計伝票登録日を取得します。
String | getEntryTime() 登録時刻を取得します。
String | getExpimpNo() 貿易データ番号: MM/SD 伝票を取得します。
String | getExtWms() 外部倉庫管理の転記の制御を取得します。
String | getGrGiSlipNo() 入出庫票番号を取得します。
String | getHeaderTxt() 伝票ヘッダテキストを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getPrUname() ユーザ名を取得します。
String | getPstngDate() 伝票の転記日付を取得します。
String | getRefDocNo() 参照伝票番号を取得します。
String | getRefDocNoLong() 参照伝票番号 (依存性についてはテキスト長参照)を取得します。
String | getTrEvType() トランザクション/イベントタイプを取得します。
String | getUsername() ユーザ名を取得します。
String | getVerGrGiSlip() 入出庫票の印刷バ－ジョンを取得します。
String | getVerGrGiSlipx() 関連ユーザデータ項目の更新情報を取得します。
void | setBarCode(String barCode) バーコードエントリを設定します。
void | setBillOfLading(String billOfLading) 入庫時に登録した B/L 番号を設定します。
void | setBillOfLadingLong(String billOfLadingLong) 入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。
void | setDocDate(String docDate) 伝票の伝票日付を設定します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setEntryDate(String entryDate) 会計伝票登録日を設定します。
void | setEntryTime(String entryTime) 登録時刻を設定します。
void | setExpimpNo(String expimpNo) 貿易データ番号: MM/SD 伝票を設定します。
void | setExtWms(String extWms) 外部倉庫管理の転記の制御を設定します。
void | setGrGiSlipNo(String grGiSlipNo) 入出庫票番号を設定します。
void | setHeaderTxt(String headerTxt) 伝票ヘッダテキストを設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
void | setPrUname(String prUname) ユーザ名を設定します。
void | setPstngDate(String pstngDate) 伝票の転記日付を設定します。
void | setRefDocNo(String refDocNo) 参照伝票番号を設定します。
void | setRefDocNoLong(String refDocNoLong) 参照伝票番号 (依存性についてはテキスト長参照)を設定します。
void | setTrEvType(String trEvType) トランザクション/イベントタイプを設定します。
void | setUsername(String username) ユーザ名を設定します。
void | setVerGrGiSlip(String verGrGiSlip) 入出庫票の印刷バ－ジョンを設定します。
void | setVerGrGiSlipx(String verGrGiSlipx) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeader

public GoodsMvtHeader()
入出庫伝票ヘッダデータ情報を作成します。

メソッドの詳細

getDocDate

public String getDocDate()
伝票の伝票日付を取得します。

戻り値:
docDate 伝票の伝票日付

getHeaderTxt

public String getHeaderTxt()
伝票ヘッダテキストを取得します。

戻り値:
headerTxt 伝票ヘッダテキスト

getPstngDate

public String getPstngDate()
伝票の転記日付を取得します。

戻り値:
pstngDate 伝票の転記日付

getRefDocNo

public String getRefDocNo()
参照伝票番号を取得します。

戻り値:
refDocNo 参照伝票番号

getRefDocNoLong

public String getRefDocNoLong()
参照伝票番号 (依存性についてはテキスト長参照)を取得します。

戻り値:
refDocNoLong 参照伝票番号 (依存性についてはテキスト長参照)

getVerGrGiSlip

public String getVerGrGiSlip()
入出庫票の印刷バ－ジョンを取得します。

戻り値:
verGrGiSlip 入出庫票の印刷バ－ジョン

getBillOfLading

public String getBillOfLading()
入庫時に登録した B/L 番号を取得します。

戻り値:
billOfLading 入庫時に登録した B/L 番号

getGrGiSlipNo

public String getGrGiSlipNo()
入出庫票番号を取得します。

戻り値:
grGiSlipNo 入出庫票番号

getPrUname

public String getPrUname()
ユーザ名を取得します。

戻り値:
prUname ユーザ名

getVerGrGiSlipx

public String getVerGrGiSlipx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
verGrGiSlipx 関連ユーザデータ項目の更新情報

getExtWms

public String getExtWms()
外部倉庫管理の転記の制御を取得します。

戻り値:
extWms 外部倉庫管理の転記の制御

getBillOfLadingLong

public String getBillOfLadingLong()
入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。

戻り値:
billOfLadingLong 入庫の船荷証券番号 (依存: テキスト (長) 参照)

getBarCode

public String getBarCode()
バーコードエントリを取得します。

戻り値:
barCode バーコードエントリ

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

getTrEvType

public String getTrEvType()
トランザクション/イベントタイプを取得します。

戻り値:
trEvType トランザクション/イベントタイプ

getEntryDate

public String getEntryDate()
会計伝票登録日を取得します。

戻り値:
entryDate 会計伝票登録日

getEntryTime

public String getEntryTime()
登録時刻を取得します。

戻り値:
entryTime 登録時刻

getUsername

public String getUsername()
ユーザ名を取得します。

戻り値:
username ユーザ名

getExpimpNo

public String getExpimpNo()
貿易データ番号: MM/SD 伝票を取得します。

戻り値:
expimpNo 貿易データ番号: MM/SD 伝票

setDocDate

public void setDocDate(String docDate)
伝票の伝票日付を設定します。

パラメータ:
docDate - 伝票の伝票日付

setHeaderTxt

public void setHeaderTxt(String headerTxt)
伝票ヘッダテキストを設定します。

パラメータ:
headerTxt - 伝票ヘッダテキスト

setPstngDate

public void setPstngDate(String pstngDate)
伝票の転記日付を設定します。

パラメータ:
pstngDate - 伝票の転記日付

setRefDocNo

public void setRefDocNo(String refDocNo)
参照伝票番号を設定します。

パラメータ:
refDocNo - 参照伝票番号

setRefDocNoLong

public void setRefDocNoLong(String refDocNoLong)
参照伝票番号 (依存性についてはテキスト長参照)を設定します。

パラメータ:
refDocNoLong - 参照伝票番号 (依存性についてはテキスト長参照)

setVerGrGiSlip

public void setVerGrGiSlip(String verGrGiSlip)
入出庫票の印刷バ－ジョンを設定します。

パラメータ:
verGrGiSlip - 入出庫票の印刷バ－ジョン

setBillOfLading

public void setBillOfLading(String billOfLading)
入庫時に登録した B/L 番号を設定します。

パラメータ:
billOfLading - 入庫時に登録した B/L 番号

setGrGiSlipNo

public void setGrGiSlipNo(String grGiSlipNo)
入出庫票番号を設定します。

パラメータ:
grGiSlipNo - 入出庫票番号

setPrUname

public void setPrUname(String prUname)
ユーザ名を設定します。

パラメータ:
prUname - ユーザ名

setVerGrGiSlipx

public void setVerGrGiSlipx(String verGrGiSlipx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
verGrGiSlipx - 関連ユーザデータ項目の更新情報

setExtWms

public void setExtWms(String extWms)
外部倉庫管理の転記の制御を設定します。

パラメータ:
extWms - 外部倉庫管理の転記の制御

setBillOfLadingLong

public void setBillOfLadingLong(String billOfLadingLong)
入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。

パラメータ:
billOfLadingLong - 入庫の船荷証券番号 (依存: テキスト (長) 参照)

setBarCode

public void setBarCode(String barCode)
バーコードエントリを設定します。

パラメータ:
barCode - バーコードエントリ

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

setTrEvType

public void setTrEvType(String trEvType)
トランザクション/イベントタイプを設定します。

パラメータ:
trEvType - トランザクション/イベントタイプ

setEntryDate

public void setEntryDate(String entryDate)
会計伝票登録日を設定します。

パラメータ:
entryDate - 会計伝票登録日

setEntryTime

public void setEntryTime(String entryTime)
登録時刻を設定します。

パラメータ:
entryTime - 登録時刻

setUsername

public void setUsername(String username)
ユーザ名を設定します。

パラメータ:
username - ユーザ名

setExpimpNo

public void setExpimpNo(String expimpNo)
貿易データ番号: MM/SD 伝票を設定します。

パラメータ:
expimpNo - 貿易データ番号: MM/SD 伝票

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeaderList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtHeaderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList
すべての実装インタフェース:
Serializable
public class GoodsMvtHeaderList
extends GoodsMvtHeader
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeaderList()
入出庫伝票明細情報を作成します。
GoodsMvtHeaderList(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
void | setIndex(int index) レコード番号を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader から継承したメソッド
getBarCode, getBillOfLading, getBillOfLadingLong, getDocDate, getDocYear, getEntryDate, getEntryTime, getExpimpNo, getExtWms, getGrGiSlipNo, getHeaderTxt, getMatDoc, getPrUname, getPstngDate, getRefDocNo, getRefDocNoLong, getTrEvType, getUsername, getVerGrGiSlip, getVerGrGiSlipx, setBarCode, setBillOfLading, setBillOfLadingLong, setDocDate, setDocYear, setEntryDate, setEntryTime, setExpimpNo, setExtWms, setGrGiSlipNo, setHeaderTxt, setMatDoc, setPrUname, setPstngDate, setRefDocNo, setRefDocNoLong, setTrEvType, setUsername, setVerGrGiSlip, setVerGrGiSlipx, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeaderList

public GoodsMvtHeaderList()
入出庫伝票明細情報を作成します。

GoodsMvtHeaderList

public GoodsMvtHeaderList(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtItems (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス GoodsMvtItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems
すべての実装インタフェース:
Serializable
public class GoodsMvtItems
extends Object
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtItems()
入出庫伝票明細情報を作成します。
GoodsMvtItems(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAmountLc() マニュアル入力による転記金額 (国内通貨)を取得します。
String | getAmountSv() 外部入力による販売金額 (国内通貨)を取得します。
String | getAssetNo() 資産番号を取得します。
String | getBatch() ロット番号を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCompShip() 出荷指示順守を取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostObj() 原価対象を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getCustomer() 得意先コードを取得します。
String | getDocYear() 入出庫伝票年度を取得します。
String | getEntryQnt() 入力単位での数量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 単位の ISO コードを取得します。
String | getExpirydate() 有効期間期限日を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrRcpt() 受領者を取得します。
int | getIndex() レコード番号を取得します｡
String | getItemText() 明細テキストを取得します。
String | getLineDepth() 伝票での明細行階層レベルを取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMoveBatch() 入庫/出庫ロットを取得します。
String | getMoveMat() 入庫/出庫品目を取得します。
String | getMoveMatExternal() 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getMoveMatGuid() 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getMoveMatVersion() 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getMovePlant() 入庫/出庫プラントを取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveStloc() 入庫/出庫保管場所を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getMoveValType() 転送ロットの評価タイプを取得します。
String | getMvtInd() 移動区分を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderItno() 指図明細番号を取得します。
String | getOrderprUn() 購買発注価格単位 (購買管理)を取得します。
String | getOrderprUnIso() 単位の ISO コードを取得します。
String | getParentId() 1 レベル上位の行 IDを取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買発注番号を取得します。
String | getPoPrQnt() 数量 (購買発注価格単位)を取得します。
String | getProdDate() ロット製造日付を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細番号を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getReservNo() 入出庫予定/従属所要量の番号を取得します。
String | getResItem() 入出庫予定/従属所要量の明細番号を取得します。
String | getResType() レコードタイプを取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSchedLine() 受注納入日程を取得します。
String | getShipping() 出荷指示を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getSpecStock() 特殊在庫区分を取得します。
String | getStckType() 在庫タイプを取得します。
String | getStgeLoc() 保管場所を取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getSupplVend() 供給仕入先を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getValSalesOrd() 評価受注在庫の受注番号を取得します。
String | getValSOrdItem() 評価受注在庫の受注明細を取得します。
String | getValType() 評価タイプを取得します。
String | getValWbsElem() WBS 要素を取得します。
String | getVendor() 仕入先勘定コードを取得します。
String | getWbsElem() WBS 要素を取得します。
String | getWithdrawn() 入出庫予定に対する出庫完了を取得します。
String | getXAutoCre() 自動登録済み明細を取得します。
void | setActivity(String activity) 作業番号を設定します。
void | setActtype(String acttype) 活動タイプを設定します。
void | setAmountLc(String amountLc) マニュアル入力による転記金額 (国内通貨)を設定します。
void | setAmountSv(String amountSv) 外部入力による販売金額 (国内通貨)を設定します。
void | setAssetNo(String assetNo) 資産番号を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCmmtItem(String cmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String cmmtItemLong) 資金予算コードを設定します。
void | setCoBusproc(String coBusproc) 業務プロセスを設定します。
void | setCompShip(String compShip) 出荷指示順守を設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCostObj(String costObj) 原価対象を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO 通貨コードを設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setEntryQnt(String entryQnt) 入力単位での数量を設定します。
void | setEntryUom(String entryUom) 入力単位を設定します。
void | setEntryUomIso(String entryUomIso) 単位の ISO コードを設定します。
void | setExpirydate(String expirydate) 有効期間期限日を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setFund(String fund) 会計区分を設定します。
void | setFundsCtr(String fundsCtr) 予算センタを設定します。
void | setGrantNbr(String grantNbr) 補助金を設定します。
void | setGrRcpt(String grRcpt) 受領者を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItemText(String itemText) 明細テキストを設定します。
void | setLineDepth(String lineDepth) 伝票での明細行階層レベルを設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
void | setMatdocItm(String matdocItm) 入出庫伝票の明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMoveBatch(String moveBatch) 入庫/出庫ロットを設定します。
void | setMoveMat(String moveMat) 入庫/出庫品目を設定します。
void | setMoveMatExternal(String moveMatExternal) 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setMoveMatGuid(String moveMatGuid) 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setMoveMatVersion(String moveMatVersion) 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setMovePlant(String movePlant) 入庫/出庫プラントを設定します。
void | setMoveReas(String moveReas) 移動理由を設定します。
void | setMoveStloc(String moveStloc) 入庫/出庫保管場所を設定します。
void | setMoveType(String moveType) 移動タイプ (在庫管理)を設定します。
void | setMoveValType(String moveValType) 転送ロットの評価タイプを設定します。
void | setMvtInd(String mvtInd) 移動区分を設定します。
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します。
void | setNoMoreGr(String noMoreGr) 納入完了 区分を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderItno(String orderItno) 指図明細番号を設定します。
void | setOrderprUn(String orderprUn) 購買発注価格単位 (購買管理)を設定します。
void | setOrderprUnIso(String orderprUnIso) 単位の ISO コードを設定します。
void | setParentId(String parentId) 1 レベル上位の行 IDを設定します。
void | setPartAcct(String partAcct) 取引先勘定コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPoItem(String poItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String poNumber) 購買発注番号を設定します。
void | setPoPrQnt(String poPrQnt) 数量 (購買発注価格単位)を設定します。
void | setProdDate(String prodDate) ロット製造日付を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setRefDate(String refDate) 決済の参照日付を設定します。
void | setRefDoc(String refDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String refDocIt) 参照伝票の明細番号を設定します。
void | setRefDocYr(String refDocYr) 参照伝票の会計年度を設定します。
void | setReservNo(String reservNo) 入出庫予定/従属所要量の番号を設定します。
void | setResItem(String resItem) 入出庫予定/従属所要量の明細番号を設定します。
void | setResType(String resType) レコードタイプを設定します。
void | setRlEstKey(String rlEstKey) 不動産管理対象の内部キーを設定します。
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します。
void | setSchedLine(String schedLine) 受注納入日程を設定します。
void | setShipping(String shipping) 出荷指示を設定します。
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します。
void | setSpecStock(String specStock) 特殊在庫区分を設定します。
void | setStckType(String stckType) 在庫タイプを設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setSubNumber(String subNumber) 資産補助番号を設定します。
void | setSupplVend(String supplVend) 供給仕入先を設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
void | setValSalesOrd(String valSalesOrd) 評価受注在庫の受注番号を設定します。
void | setValSOrdItem(String valSOrdItem) 評価受注在庫の受注明細を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setValWbsElem(String valWbsElem) WBS 要素を設定します。
void | setVendor(String vendor) 仕入先勘定コードを設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWithdrawn(String withdrawn) 入出庫予定に対する出庫完了を設定します。
void | setXAutoCre(String xAutoCre) 自動登録済み明細を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtItems

public GoodsMvtItems()
入出庫伝票明細情報を作成します。

GoodsMvtItems

public GoodsMvtItems(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
activity 作業番号

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
acttype 活動タイプ

getAmountLc

public String getAmountLc()
マニュアル入力による転記金額 (国内通貨)を取得します。

戻り値:
amountLc マニュアル入力による転記金額 (国内通貨)

getAmountSv

public String getAmountSv()
外部入力による販売金額 (国内通貨)を取得します。

戻り値:
amountSv 外部入力による販売金額 (国内通貨)

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
assetNo 資産番号

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
cmmtItem 資金予算コード

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
cmmtItemLong 資金予算コード

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
coBusproc 業務プロセス

getCompShip

public String getCompShip()
出荷指示順守を取得します。

戻り値:
compShip 出荷指示順守

getCostObj

public String getCostObj()
原価対象を取得します。

戻り値:
costObj 原価対象

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
currencyIso ISO 通貨コード

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

getEntryQnt

public String getEntryQnt()
入力単位での数量を取得します。

戻り値:
entryQnt 入力単位での数量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
entryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
単位の ISO コードを取得します。

戻り値:
entryUomIso 単位の ISO コード

getExpirydate

public String getExpirydate()
有効期間期限日を取得します。

戻り値:
expirydate 有効期間期限日

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getFund

public String getFund()
会計区分を取得します。

戻り値:
fund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
fundsCtr 予算センタ

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
grRcpt 受領者

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
grantNbr 補助金

getItemText

public String getItemText()
明細テキストを取得します。

戻り値:
itemText 明細テキスト

getLineDepth

public String getLineDepth()
伝票での明細行階層レベルを取得します。

戻り値:
lineDepth 伝票での明細行階層レベル

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
matdocItm 入出庫伝票の明細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getMoveBatch

public String getMoveBatch()
入庫/出庫ロットを取得します。

戻り値:
moveBatch 入庫/出庫ロット

getMoveMat

public String getMoveMat()
入庫/出庫品目を取得します。

戻り値:
moveMat 入庫/出庫品目

getMoveMatExternal

public String getMoveMatExternal()
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
moveMatExternal 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

getMoveMatGuid

public String getMoveMatGuid()
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
moveMatGuid 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

getMoveMatVersion

public String getMoveMatVersion()
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
moveMatVersion 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

getMovePlant

public String getMovePlant()
入庫/出庫プラントを取得します。

戻り値:
movePlant 入庫/出庫プラント

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
moveReas 移動理由

getMoveStloc

public String getMoveStloc()
入庫/出庫保管場所を取得します。

戻り値:
moveStloc 入庫/出庫保管場所

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
moveType 移動タイプ (在庫管理)

getMoveValType

public String getMoveValType()
転送ロットの評価タイプを取得します。

戻り値:
moveValType 転送ロットの評価タイプ

getMvtInd

public String getMvtInd()
移動区分を取得します。

戻り値:
mvtInd 移動区分

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
network 勘定割当のネットワーク番号

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
noMoreGr 納入完了 区分

getOrderItno

public String getOrderItno()
指図明細番号を取得します。

戻り値:
orderItno 指図明細番号

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getOrderprUn

public String getOrderprUn()
購買発注価格単位 (購買管理)を取得します。

戻り値:
orderprUn 購買発注価格単位 (購買管理)

getOrderprUnIso

public String getOrderprUnIso()
単位の ISO コードを取得します。

戻り値:
orderprUnIso 単位の ISO コード

getParentId

public String getParentId()
1 レベル上位の行 IDを取得します。

戻り値:
parentId 1 レベル上位の行 ID

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
partAcct 取引先勘定コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
poItem 購買伝票の明細番号

getPoNumber

public String getPoNumber()
購買発注番号を取得します。

戻り値:
poNumber 購買発注番号

getPoPrQnt

public String getPoPrQnt()
数量 (購買発注価格単位)を取得します。

戻り値:
poPrQnt 数量 (購買発注価格単位)

getProdDate

public String getProdDate()
ロット製造日付を取得します。

戻り値:
prodDate ロット製造日付

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
refDate 決済の参照日付

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
refDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細番号を取得します。

戻り値:
refDocIt 参照伝票の明細番号

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
refDocYr 参照伝票の会計年度

getResItem

public String getResItem()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
resItem 入出庫予定/従属所要量の明細番号

getResType

public String getResType()
レコードタイプを取得します。

戻り値:
resType レコードタイプ

getReservNo

public String getReservNo()
入出庫予定/従属所要量の番号を取得します。

戻り値:
reservNo 入出庫予定/従属所要量の番号

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
rlEstKey 不動産管理対象の内部キー

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
sOrdItem 受注明細番号

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
salesOrd 受注伝票番号

getSchedLine

public String getSchedLine()
受注納入日程を取得します。

戻り値:
schedLine 受注納入日程

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
shipping 出荷指示

getSpecStock

public String getSpecStock()
特殊在庫区分を取得します。

戻り値:
specStock 特殊在庫区分

getStckType

public String getStckType()
在庫タイプを取得します。

戻り値:
stckType 在庫タイプ

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
subNumber 資産補助番号

getSupplVend

public String getSupplVend()
供給仕入先を取得します。

戻り値:
supplVend 供給仕入先

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getValSOrdItem

public String getValSOrdItem()
評価受注在庫の受注明細を取得します。

戻り値:
valSOrdItem 評価受注在庫の受注明細

getValSalesOrd

public String getValSalesOrd()
評価受注在庫の受注番号を取得します。

戻り値:
valSalesOrd 評価受注在庫の受注番号

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getValWbsElem

public String getValWbsElem()
WBS 要素を取得します。

戻り値:
valWbsElem WBS 要素

getVendor

public String getVendor()
仕入先勘定コードを取得します。

戻り値:
vendor 仕入先勘定コード

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getWithdrawn

public String getWithdrawn()
入出庫予定に対する出庫完了を取得します。

戻り値:
withdrawn 入出庫予定に対する出庫完了

getXAutoCre

public String getXAutoCre()
自動登録済み明細を取得します。

戻り値:
xAutoCre 自動登録済み明細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setActivity

public void setActivity(String activity)
作業番号を設定します。

パラメータ:
activity - 作業番号

setActtype

public void setActtype(String acttype)
活動タイプを設定します。

パラメータ:
acttype - 活動タイプ

setAmountLc

public void setAmountLc(String amountLc)
マニュアル入力による転記金額 (国内通貨)を設定します。

パラメータ:
amountLc - マニュアル入力による転記金額 (国内通貨)

setAmountSv

public void setAmountSv(String amountSv)
外部入力による販売金額 (国内通貨)を設定します。

パラメータ:
amountSv - 外部入力による販売金額 (国内通貨)

setAssetNo

public void setAssetNo(String assetNo)
資産番号を設定します。

パラメータ:
assetNo - 資産番号

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

setCmmtItem

public void setCmmtItem(String cmmtItem)
資金予算コードを設定します。

パラメータ:
cmmtItem - 資金予算コード

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
資金予算コードを設定します。

パラメータ:
cmmtItemLong - 資金予算コード

setCoBusproc

public void setCoBusproc(String coBusproc)
業務プロセスを設定します。

パラメータ:
coBusproc - 業務プロセス

setCompShip

public void setCompShip(String compShip)
出荷指示順守を設定します。

パラメータ:
compShip - 出荷指示順守

setCostObj

public void setCostObj(String costObj)
原価対象を設定します。

パラメータ:
costObj - 原価対象

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO 通貨コードを設定します。

パラメータ:
currencyIso - ISO 通貨コード

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

setEntryQnt

public void setEntryQnt(String entryQnt)
入力単位での数量を設定します。

パラメータ:
entryQnt - 入力単位での数量

setEntryUom

public void setEntryUom(String entryUom)
入力単位を設定します。

パラメータ:
entryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String entryUomIso)
単位の ISO コードを設定します。

パラメータ:
entryUomIso - 単位の ISO コード

setExpirydate

public void setExpirydate(String expirydate)
有効期間期限日を設定します。

パラメータ:
expirydate - 有効期間期限日

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setFund

public void setFund(String fund)
会計区分を設定します。

パラメータ:
fund - 会計区分

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します。

パラメータ:
fundsCtr - 予算センタ

setGrRcpt

public void setGrRcpt(String grRcpt)
受領者を設定します。

パラメータ:
grRcpt - 受領者

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します。

パラメータ:
grantNbr - 補助金

setItemText

public void setItemText(String itemText)
明細テキストを設定します。

パラメータ:
itemText - 明細テキスト

setLineDepth

public void setLineDepth(String lineDepth)
伝票での明細行階層レベルを設定します。

パラメータ:
lineDepth - 伝票での明細行階層レベル

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setMatdocItm

public void setMatdocItm(String matdocItm)
入出庫伝票の明細を設定します。

パラメータ:
matdocItm - 入出庫伝票の明細

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setMoveBatch

public void setMoveBatch(String moveBatch)
入庫/出庫ロットを設定します。

パラメータ:
moveBatch - 入庫/出庫ロット

setMoveMat

public void setMoveMat(String moveMat)
入庫/出庫品目を設定します。

パラメータ:
moveMat - 入庫/出庫品目

setMoveMatExternal

public void setMoveMatExternal(String moveMatExternal)
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
moveMatExternal - 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

setMoveMatGuid

public void setMoveMatGuid(String moveMatGuid)
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
moveMatGuid - 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

setMoveMatVersion

public void setMoveMatVersion(String moveMatVersion)
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
moveMatVersion - 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

setMovePlant

public void setMovePlant(String movePlant)
入庫/出庫プラントを設定します。

パラメータ:
movePlant - 入庫/出庫プラント

setMoveReas

public void setMoveReas(String moveReas)
移動理由を設定します。

パラメータ:
moveReas - 移動理由

setMoveStloc

public void setMoveStloc(String moveStloc)
入庫/出庫保管場所を設定します。

パラメータ:
moveStloc - 入庫/出庫保管場所

setMoveType

public void setMoveType(String moveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
moveType - 移動タイプ (在庫管理)

setMoveValType

public void setMoveValType(String moveValType)
転送ロットの評価タイプを設定します。

パラメータ:
moveValType - 転送ロットの評価タイプ

setMvtInd

public void setMvtInd(String mvtInd)
移動区分を設定します。

パラメータ:
mvtInd - 移動区分

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します。

パラメータ:
network - 勘定割当のネットワーク番号

setNoMoreGr

public void setNoMoreGr(String noMoreGr)
納入完了 区分を設定します。

パラメータ:
noMoreGr - 納入完了 区分

setOrderItno

public void setOrderItno(String orderItno)
指図明細番号を設定します。

パラメータ:
orderItno - 指図明細番号

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setOrderprUn

public void setOrderprUn(String orderprUn)
購買発注価格単位 (購買管理)を設定します。

パラメータ:
orderprUn - 購買発注価格単位 (購買管理)

setOrderprUnIso

public void setOrderprUnIso(String orderprUnIso)
単位の ISO コードを設定します。

パラメータ:
orderprUnIso - 単位の ISO コード

setParentId

public void setParentId(String parentId)
1 レベル上位の行 IDを設定します。

パラメータ:
parentId - 1 レベル上位の行 ID

setPartAcct

public void setPartAcct(String partAcct)
取引先勘定コードを設定します。

パラメータ:
partAcct - 取引先勘定コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setPoItem

public void setPoItem(String poItem)
購買伝票の明細番号を設定します。

パラメータ:
poItem - 購買伝票の明細番号

setPoNumber

public void setPoNumber(String poNumber)
購買発注番号を設定します。

パラメータ:
poNumber - 購買発注番号

setPoPrQnt

public void setPoPrQnt(String poPrQnt)
数量 (購買発注価格単位)を設定します。

パラメータ:
poPrQnt - 数量 (購買発注価格単位)

setProdDate

public void setProdDate(String prodDate)
ロット製造日付を設定します。

パラメータ:
prodDate - ロット製造日付

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setRefDate

public void setRefDate(String refDate)
決済の参照日付を設定します。

パラメータ:
refDate - 決済の参照日付

setRefDoc

public void setRefDoc(String refDoc)
参照伝票の伝票番号を設定します。

パラメータ:
refDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照伝票の明細番号を設定します。

パラメータ:
refDocIt - 参照伝票の明細番号

setRefDocYr

public void setRefDocYr(String refDocYr)
参照伝票の会計年度を設定します。

パラメータ:
refDocYr - 参照伝票の会計年度

setResItem

public void setResItem(String resItem)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
resItem - 入出庫予定/従属所要量の明細番号

setResType

public void setResType(String resType)
レコードタイプを設定します。

パラメータ:
resType - レコードタイプ

setReservNo

public void setReservNo(String reservNo)
入出庫予定/従属所要量の番号を設定します。

パラメータ:
reservNo - 入出庫予定/従属所要量の番号

setRlEstKey

public void setRlEstKey(String rlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
rlEstKey - 不動産管理対象の内部キー

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します。

パラメータ:
sOrdItem - 受注明細番号

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します。

パラメータ:
salesOrd - 受注伝票番号

setSchedLine

public void setSchedLine(String schedLine)
受注納入日程を設定します。

パラメータ:
schedLine - 受注納入日程

setShipping

public void setShipping(String shipping)
出荷指示を設定します。

パラメータ:
shipping - 出荷指示

setSpecStock

public void setSpecStock(String specStock)
特殊在庫区分を設定します。

パラメータ:
specStock - 特殊在庫区分

setStckType

public void setStckType(String stckType)
在庫タイプを設定します。

パラメータ:
stckType - 在庫タイプ

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setSubNumber

public void setSubNumber(String subNumber)
資産補助番号を設定します。

パラメータ:
subNumber - 資産補助番号

setSupplVend

public void setSupplVend(String supplVend)
供給仕入先を設定します。

パラメータ:
supplVend - 供給仕入先

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setValSOrdItem

public void setValSOrdItem(String valSOrdItem)
評価受注在庫の受注明細を設定します。

パラメータ:
valSOrdItem - 評価受注在庫の受注明細

setValSalesOrd

public void setValSalesOrd(String valSalesOrd)
評価受注在庫の受注番号を設定します。

パラメータ:
valSalesOrd - 評価受注在庫の受注番号

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setValWbsElem

public void setValWbsElem(String valWbsElem)
WBS 要素を設定します。

パラメータ:
valWbsElem - WBS 要素

setVendor

public void setVendor(String vendor)
仕入先勘定コードを設定します。

パラメータ:
vendor - 仕入先勘定コード

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setWithdrawn

public void setWithdrawn(String withdrawn)
入出庫予定に対する出庫完了を設定します。

パラメータ:
withdrawn - 入出庫予定に対する出庫完了

setXAutoCre

public void setXAutoCre(String xAutoCre)
自動登録済み明細を設定します。

パラメータ:
xAutoCre - 自動登録済み明細

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialDescription (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス MaterialDescription

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription
すべての実装インタフェース:
Serializable
public class MaterialDescription
extends Object
implements Serializable

品目テキスト情報クラス
機能は以下の通り

  • 品目テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialDescription()
品目テキスト情報を作成します。
MaterialDescription(int index)
品目テキスト情報を作成します。
メソッドの概要
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatlDesc() 品目テキストを取得します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatlDesc(String matlDesc) 品目テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialDescription

public MaterialDescription()
品目テキスト情報を作成します。

MaterialDescription

public MaterialDescription(int index)
品目テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getMatlDesc

public String getMatlDesc()
品目テキストを取得します。

戻り値:
matlDesc 品目テキスト

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setMatlDesc

public void setMatlDesc(String matlDesc)
品目テキストを設定します。

パラメータ:
matlDesc - 品目テキスト

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.common.model (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス
ClientData
ClientDataList
ForecastParameters
ForecastParametersList
GoodsMvtHeader
GoodsMvtHeaderList
GoodsMvtItems
MaterialDescription
ParamGoodsMvtHeader
ParamGoodsMvtHeaderList
ParamGoodsMvtItems
PlanningData
PlanningDataList
PlantData
PlantDataList
SalesData
SalesDataList
StorageLocationData
StorageLocationDataList
StorageTypeData
StorageTypeDataList
TaxClassifications
UnitSofmeasure
ValuationData
ValuationDataList
WarehouseNumberData
WarehouseNumberDataList


jp.co.intra_mart.foundation.sap.module.purchase.common.model (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model

クラスの概要
ClientData | 品目データ (クライアントレベル)情報クラス 機能は以下の通り 品目データ (クライアントレベル)情報を保持します。
ClientDataList | 品目データ (クライアントレベル)情報クラス 機能は以下の通り 品目データ (クライアントレベル)情報をテーブル型で保持します。
ForecastParameters | 予測パラメータ情報クラス 機能は以下の通り 予測パラメータ情報を保持します。
ForecastParametersList | 需要予測パラメータ情報クラス 機能は以下の通り 需要予測パラメータ情報をテーブル型で保持します。
GoodsMvtHeader | 入出庫伝票ヘッダデータ情報クラス 機能は以下の通り 入出庫伝票ヘッダデータ情報を保持します。
GoodsMvtHeaderList | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
GoodsMvtItems | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
MaterialDescription | 品目テキスト情報クラス 機能は以下の通り 品目テキスト情報を保持します。
ParamGoodsMvtHeader | 入出庫伝票ヘッダデータ設定クラス 機能は以下の通り 入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtHeaderList | リターン構造、入出庫伝票ヘッダパラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票ヘッダのパラメータを設定します。
ParamGoodsMvtItems | リターン構造、入出庫伝票明細パラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票明細のパラメータを設定します。
PlanningData | 品目マスタ/製品グループの変更伝票構造情報クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningDataList | 品目マスタ/製品グループの変更伝票構造情報クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData | 品目データ (プラントレベル)情報クラス 機能は以下の通り 品目データ (プラントレベル)情報を保持します。
PlantDataList | 品目データ (プラントレベル)情報クラス 機能は以下の通り 品目データ (プラントレベル)情報をテーブル型で保持します。
SalesData | 販売データ情報クラス 機能は以下の通り 販売データ情報を保持します。
SalesDataList | 販売データ情報クラス 機能は以下の通り 販売データ情報をテーブル型で保持します。
StorageLocationData | 品目データ (保管場所レベル)情報クラス 機能は以下の通り 品目データ (保管場所レベル)情報を保持します。
StorageLocationDataList | 品目データ (保管場所レベル)情報クラス 機能は以下の通り 品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageTypeData | 保管域タイプデータ情報クラス 機能は以下の通り 保管域タイプデータ情報を保持します。
StorageTypeDataList | 保管域タイプデータ情報クラス 機能は以下の通り 保管域タイプデータ情報をテーブル型で保持します。
TaxClassifications | 制御デ－タ情報クラス 機能は以下の通り 制御デ－タ情報を保持します。
UnitSofmeasure | 数量単位情報クラス 機能は以下の通り 数量単位情報を保持します。
ValuationData | 評価データ情報クラス 機能は以下の通り 評価データ情報を保持します。
ValuationDataList | 評価データ情報クラス 機能は以下の通り 評価データ情報をテーブル型で保持します。
WarehouseNumberData | 倉庫番号データ情報クラス 機能は以下の通り 倉庫番号データ情報を保持します。
WarehouseNumberDataList | 倉庫番号データ情報クラス 機能は以下の通り 倉庫番号データ情報をテーブル型で保持します。


jp.co.intra_mart.foundation.sap.module.purchase.common.model クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.common.model の使用

jp.co.intra_mart.foundation.sap.module.purchase.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientDataList
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。
ForecastParametersList
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。
MaterialDescription
品目テキスト情報クラス
機能は以下の通り
品目テキスト情報を保持します。
PlanningDataList
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantDataList
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。
SalesDataList
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。
StorageLocationDataList
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageTypeDataList
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。
TaxClassifications
制御デ－タ情報クラス
機能は以下の通り
制御デ－タ情報を保持します。
UnitSofmeasure
数量単位情報クラス
機能は以下の通り
数量単位情報を保持します。
ValuationDataList
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。
WarehouseNumberDataList
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。

jp.co.intra_mart.foundation.sap.module.purchase.common.model により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientData
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ForecastParameters
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
GoodsMvtHeader
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。
PlanningData
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
SalesData
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
StorageLocationData
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageTypeData
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
ValuationData
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
WarehouseNumberData
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
GoodsMvtHeader
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module.purchase.common.model のクラス
ClientData
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ForecastParameters
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
PlanningData
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlantData
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
SalesData
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
StorageLocationData
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageTypeData
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
ValuationData
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
WarehouseNumberData
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamGoodsMvtHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeader
extends Object
implements Serializable

入出庫伝票ヘッダデータ設定クラス
機能は以下の通り

  • 入出庫伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | setImportParam(BapiController bapiController, GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtHeader goodsMvtHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入出庫伝票ヘッダデータに値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeader - GoodsMvtHeadrer
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtHeaderList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtHeaderList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeaderList
extends Object
implements Serializable

リターン構造、入出庫伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtHeaderList) table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtHeaderList)
                           throws SAPGeneralSystemException
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeaderList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtItems (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ParamGoodsMvtItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtItems
extends Object
implements Serializable

リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtItemsList) table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtItemsList) リターン構造、入出庫伝票明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtItemsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票明細に値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtItemsList)
                           throws SAPGeneralSystemException
table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlanningData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlanningData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PlanningDataList
public class PlanningData
extends Object
implements Serializable

品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlanningData()
品目マスタ/製品グループの変更伝票構造情報を作成します。
メソッドの概要
String | getConvfactor() 計画品目用変換係数を取得します。
String | getFunction() BAPI 機能を取得します。
String | getMaterial() 品目コードを取得します。
String | getPlant() プラントを取得します。
String | getPlngMatl() 計画品目を取得します。
String | getPlngMatlExternal() 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。
String | getPlngMatlGuid() 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。
String | getPlngMatlVersion() 項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlngPlant() 計画プラントを取得します。
void | setConvfactor(String convfactor) 計画品目用変換係数を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlngMatl(String plngMatl) 計画品目を設定します。
void | setPlngMatlExternal(String plngMatlExternal) 項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。
void | setPlngMatlGuid(String plngMatlGuid) 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。
void | setPlngMatlVersion(String plngMatlVersion) 項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlngPlant(String plngPlant) 計画プラントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlanningData

public PlanningData()
品目マスタ/製品グループの変更伝票構造情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getPlngMatl

public String getPlngMatl()
計画品目を取得します。

戻り値:
plngMatl 計画品目

getPlngPlant

public String getPlngPlant()
計画プラントを取得します。

戻り値:
plngPlant 計画プラント

getConvfactor

public String getConvfactor()
計画品目用変換係数を取得します。

戻り値:
convfactor 計画品目用変換係数

getPlngMatlExternal

public String getPlngMatlExternal()
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
plngMatlExternal 項目 PLNG_MATL の品目コード (長) (今後の リリースで開発)

getPlngMatlGuid

public String getPlngMatlGuid()
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
plngMatlGuid 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

getPlngMatlVersion

public String getPlngMatlVersion()
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
plngMatlVersion 項目 PLNG_MATL のバージョン番号 (今後の リリースで開発)

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setPlngMatl

public void setPlngMatl(String plngMatl)
計画品目を設定します。

パラメータ:
plngMatl - 計画品目

setPlngPlant

public void setPlngPlant(String plngPlant)
計画プラントを設定します。

パラメータ:
plngPlant - 計画プラント

setConvfactor

public void setConvfactor(String convfactor)
計画品目用変換係数を設定します。

パラメータ:
convfactor - 計画品目用変換係数

setPlngMatlExternal

public void setPlngMatlExternal(String plngMatlExternal)
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
plngMatlExternal - 項目 PLNG_MATL の品目コード (長) (今後の リリースで開発)

setPlngMatlGuid

public void setPlngMatlGuid(String plngMatlGuid)
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
plngMatlGuid - 項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

setPlngMatlVersion

public void setPlngMatlVersion(String plngMatlVersion)
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
plngMatlVersion - 項目 PLNG_MATL のバージョン番号 (今後の リリースで開発)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlanningDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlanningDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList
すべての実装インタフェース:
Serializable
public class PlanningDataList
extends PlanningData
implements Serializable

品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlanningDataList()
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
void | setIndex(int index) レコード番号を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData から継承したメソッド
getConvfactor, getFunction, getMaterial, getPlant, getPlngMatl, getPlngMatlExternal, getPlngMatlGuid, getPlngMatlVersion, getPlngPlant, setConvfactor, setFunction, setMaterial, setPlant, setPlngMatl, setPlngMatlExternal, setPlngMatlGuid, setPlngMatlVersion, setPlngPlant, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlanningDataList

public PlanningDataList()
品目マスタ/製品グループの変更伝票構造情報を作成します。

PlanningDataList

public PlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlantData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PlantDataList
public class PlantData
extends Object
implements Serializable

品目データ (プラントレベル)情報クラス
機能は以下の通り

  • 品目データ (プラントレベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantData()
品目データ (プラントレベル)情報を作成します。
メソッドの概要
String | getAbcId() ABC 区分を取得します。
String | getAccountView() 会計ビューを取得します。
String | getAltBomId() 代替 BOM 選択の方法を取得します。
String | getAlternativeBom() 代替 BOMを取得します。
String | getAssyScrap() 組立不良率を取得します。
String | getAutoPOrd() 区分: "購買発注自動生成"を取得します。
String | getAutoReset() 予測モデル自動リセットを取得します。
String | getAvailcheck() 利用可能在庫確認の確認グループを取得します。
String | getAvailCheckAllProjSegments() プロジェクト間品目区分を取得します。
String | getBackflush() 区分: バックフラッシュを取得します。
String | getBaseQty() 基本数量を取得します。
String | getBaseQtyPlan() 出荷の能力計画のための基本数量を取得します。
String | getBatchentry() 製造/プロセス指図でのロット入力設定を取得します。
String | getBatchMgmt() ロット管理所要量区分を取得します。
String | getBomUsage() BOM 用途を取得します。
String | getBulkMat() 区分: バルク品目を取得します。
String | getBwdCons() 消費期間: 後方を取得します。
String | getCasNo() CAS 番号： 薬事品目 - 貿易を取得します。
String | getCcFixed() 循環棚卸区分固定を取得します。
String | getCcPhInv() 循環棚卸の実地棚卸区分を取得します。
String | getCertType() 証明書タイプを取得します。
String | getCommCode() 貿易: 統計品目コード/輸入コード番号を取得します。
String | getCommCoUn() 物品コード (貿易) の数量単位を取得します。
String | getCommCoUnIso() ISO コードによる物品コード (貿易管理) の数量単位を取得します。
String | getCompScrap() 構成品目不良率を取得します。
String | getConsummode() 消費モードを取得します。
String | getCoProduct() 区分: 連産品としても使用可能な品目を取得します。
String | getCorrFact() 区分: 修正係数を需要予測値計算に使用を取得します。
String | getCostView() 原価計算ビューを取得します。
String | getCountryori() 品目の原産国を取得します。
String | getCountryoriIso() ISO コードでの品目原産国を取得します。
String | getCovprofile() 在庫日数プロファイルを取得します。
String | getCritPart() 区分: 重要品目を取得します。
String | getCtrlCode() 貿易: 消費税の管理コードを取得します。
String | getCtrlKey() 調達における品質管理の管理キーを取得します。
String | getCycleTime() タクトタイムを取得します。
String | getDeclStatFlag() 区分: 仕入先申告ありを取得します。
String | getDelFlag() プラントレベルでの品目削除フラグを取得します。
String | getDeployHoriz() 供給分配期間の日数を取得します。
String | getDepReqId() 個別所要量と包括所要量に対する従属所要量区分を取得します。
String | getDetermGrp() 在庫決定グループを取得します。
String | getDiscontinu() 打切区分を取得します。
String | getDistrProf() サイトの商品の物流プロファイルを取得します。
String | getDocReqd() 文書必須フラグを取得します。
String | getDToRefM() 消費データ参照の有効終了日を取得します。
String | getEffODay() 有効終了日を取得します。
String | getEuListNo() CAP: CAP 製品一覧番号を取得します。
String | getEuMatGrp() EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。
String | getExCertDt() 非該当証明書発行日を取得します。
String | getExCertId() 法令管理: 認定書区分を取得します。
String | getExCertNoNew() 非該当証明書番号 - 法令管理を取得します。
String | getExpimpgrp() 輸出/輸入品目グループを取得します。
String | getFairShareRule() 均等配賦ルールを取得します。
String | getFixedLot() 固定ロットサイズを取得します。
String | getFixLotSize() 需要供給の一致に対する固定ロットサイズを取得します。
String | getFollowUp() フォローアップ品目を取得します。
String | getFollowUpExternal() 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。
String | getFollowUpGuid() 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。
String | getFollowUpVersion() 項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。
String | getForecastView() 需要予測ビューを取得します。
String | getFunction() BAPI 機能を取得します。
String | getFwdCons() 消費期間: 前方を取得します。
String | getFxdPrice() 固定価格連産品を取得します。
String | getFyVariant() 会計年度バリアントを取得します。
String | getGrpReqmts() 区分: 所要量グループ化を取得します。
String | getGrPrTime() 入庫処理日数を取得します。
String | getHandlgGrp() ワークロード計算のロジスティクス処理グループを取得します。
String | getIndPostToInspStock() 品質検査中在庫への転記を取得します。
String | getInhseprodt() 内製日数を取得します。
String | getInspInt() 次回再検査までの間隔を取得します。
String | getInspSetupFlag() 品目/プラントに QM 検査データ設定を取得します。
String | getInterop() 移動時間を取得します。
String | getIssStLoc() 出庫保管場所を取得します。
String | getIssueUnit() 出庫単位を取得します。
String | getIssueUnitIso() ISO コードでの出庫単位を取得します。
String | getJitRelvt() 区分: JIT 納入日程の関連明細を取得します。
String | getLoadinggrp() 積載グループを取得します。
String | getLotIncrement() 需要と供給を一致させるためのロットサイズ増分を取得します。
String | getLotSize() 原価計算ロットサイズを取得します。
String | getLotsizekey() ロットサイズ (品目計画)を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMatCfop() 品目 CFOP カテゴリを取得します。
String | getMaterial() 品目コードを取得します。
String | getMatfrgtgrp() 品目運賃グループを取得します。
String | getMatGrpTrans() 段取替えマトリクスに対する品目のグループを取得します。
String | getMaxlotsize() 最大ロットサイズを取得します。
String | getMaxLotSize() 需要と供給を一致させるための最大ロットサイズを取得します。
String | getMaxStock() 最大在庫レベルを取得します。
String | getMilitId() ID: 武器を取得します。
String | getMinlotsize() 最小ロットサイズを取得します。
String | getMinLotSize() 需要と供給を一致させるための最小ロットサイズを取得します。
String | getMinSafetyStk() 最小安全在庫を取得します。
String | getMixedMrp() 二重 MRP 区分を取得します。
String | getMrpAreaExists() 区分: MRP エリア登録済を取得します。
String | getMrpCtrler() MRP 管理者を取得します。
String | getMrpGroup() MRP グループを取得します。
String | getMrpprofile() 品目: MRP プロファイルを取得します。
String | getMrpRelevancyDepRequirements() 従属所要量と MRP の関連性を取得します。
String | getMrpType() MRP タイプを取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getMultRefM() 消費データ参照品目の乗数を取得します。
String | getNegStocks() プラントにおけるマイナス在庫許可を取得します。
String | getNoCosting() 原価計算なしを取得します。
String | getOrdCosts() 発注原価 (BAPI インタフェース)を取得します。
String | getOriginalBatchFlag() 元ロット管理区分を取得します。
String | getOriginalBatchRefMaterial() 元ロットの参照品目を取得します。
String | getOverallprf() 指図変更管理の全体プロファイルを取得します。
String | getOverTol() 過剰納入許容範囲リミットを取得します。
String | getPeriodInd() 期間区分を取得します。
String | getPeriodProfileSafetyTime() 安全時間の期間プロファイルを取得します。
String | getPlanlistcnt() グループカウンタを取得します。
String | getPlanlistgrp() タスクリストグループのキーを取得します。
String | getPlanStrgp() 計画方針グループを取得します。
String | getPlant() プラントを取得します。
String | getPlndDelry() 予定納入時間 (単位: 日)を取得します。
String | getPlngCycle() 計画サイクルを取得します。
String | getPlordCtrl() アクション管理: 計画手配処理を取得します。
String | getPlTiFnce() 計画タイムフェンスを取得します。
String | getPpcPlCal() PPC 計画カレンダを取得します。
String | getPrefStatFlag() 区分: 特恵関税 - 輸出/輸入を取得します。
String | getProcTime() 処理時間を取得します。
String | getProcType() 調達タイプを取得します。
String | getProdcomNo() 生産統計: 貿易における PRODCOM コードを取得します。
String | getProdConvType() 生産値の変換タイプを取得します。
String | getProdprof() 製造計画プロファイルを取得します。
String | getProductionScheduler() 製造計画担当を取得します。
String | getProdUnit() 製造単位を取得します。
String | getProdUnitIso() 製造単位 (ISO コード)を取得します。
String | getProdverscs() 原価計算を行う製造バージョンを取得します。
String | getProfitCtr() 利益センタを取得します。
String | getPrtView() 生産資源/治工具 (PRT) ビューを取得します。
String | getPsConfMat() 選定可能品目を取得します。
String | getPurchView() 購買管理ビューを取得します。
String | getPurGroup() 購買グループを取得します。
String | getPurStatus() プラント特有品目ステータスを取得します。
String | getPushDistrib() 区分: プッシュ配賦を取得します。
String | getPvalidfrom() プラント品目ステータス有効期間開始日を取得します。
String | getQmAuthgrp() QM における活動の品目権限グループを取得します。
String | getQmRgmts() 仕入先の必須 QM システムを取得します。
String | getQualityView() 品質管理ビューを取得します。
String | getQuotausage() 供給量割当の使用を取得します。
String | getRefmatcons() 消費参照品目を取得します。
String | getRefmatconsExternal() 項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。
String | getRefmatconsGuid() 項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。
String | getRefmatconsVersion() 項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。
String | getRefpltcons() 消費参照プラントを取得します。
String | getRegionorig() 品目の原産地 (非特恵対象地区の原産)を取得します。
String | getReorderPt() 発注点を取得します。
String | getReplacePt() 取替部品を取得します。
String | getReplentime() 補充リードタイム合計 (稼動日数)を取得します。
String | getRepmanprof() 繰返生産プロファイルを取得します。
String | getRepManuf() 区分: 繰返生産許可を取得します。
String | getRotationDate() 原価計算ビューを取得します。
String | getRoundProf() 丸めプロファイルを取得します。
String | getRoundVal() 購買発注数量の丸め数量を取得します。
String | getSafetyStk() 安全在庫を取得します。
String | getSafetytime() 安全時間 (稼動日数)を取得します。
String | getSaftyTId() 安全時間区分（安全リードタイムあり/なし)を取得します。
String | getSalesView() 販売ビューを取得します。
String | getSernoProf() シリアル番号プロファイルを取得します。
String | getServLevel() サービスレベルを取得します。
String | getSetuptime() 段取時間と片付け時間を取得します。
String | getSetupTime() 出荷準備時間を取得します。
String | getShipProcTime() 出荷処理時間を取得します。
String | getSlocExprc() 外部調達の初期保管場所を取得します。
String | getSmKey() 日程計画余裕キーを取得します。
String | getSourcelist() 区分: 供給元一覧必須を取得します。
String | getSpecprocty() 原価計算の特殊調達タイプを取得します。
String | getSplitInd() 分割区分を取得します。
String | getSpproctype() 特殊調達タイプを取得します。
String | getStgePdUn() 最長保管期間の単位を取得します。
String | getStgePdUnIso() ISO コードでの最長保管期間単位を取得します。
String | getStgeperiod() 最長保管期間を取得します。
String | getStorageView() 保管ビューを取得します。
String | getStorCosts() 保管経費区分を取得します。
String | getSupplyArea() 品目マスタレコードで提案される供給場所を取得します。
String | getSupSource() 供給元を取得します。
String | getTaskListType() タスクリストタイプを取得します。
String | getUnderTol() 不足納入許容範囲リミットを取得します。
String | getUnitGroup() 数量単位グループを取得します。
String | getUnlimited() 区分: 無制限過剰納入可能を取得します。
String | getVarianceKey() 差異キーを取得します。
String | getVersionFlag() バージョン区分を取得します。
String | getWarehouseView() 倉庫管理ビューを取得します。
String | getWorkSchedView() 作業計画ビューを取得します。
void | setAbcId(String abcId) ABC 区分を設定します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setAltBomId(String altBomId) 代替 BOM 選択の方法を設定します。
void | setAlternativeBom(String alternativeBom) 代替 BOMを設定します。
void | setAssyScrap(String assyScrap) 組立不良率を設定します。
void | setAutoPOrd(String autoPOrd) 区分: "購買発注自動生成"を設定します。
void | setAutoReset(String autoReset) 予測モデル自動リセットを設定します。
void | setAvailcheck(String availcheck) 利用可能在庫確認の確認グループを設定します。
void | setAvailCheckAllProjSegments(String availCheckAllProjSegments) プロジェクト間品目区分を設定します。
void | setBackflush(String backflush) 区分: バックフラッシュを設定します。
void | setBaseQty(String baseQty) 基本数量を設定します。
void | setBaseQtyPlan(String baseQtyPlan) 出荷の能力計画のための基本数量を設定します。
void | setBatchentry(String batchentry) 製造/プロセス指図でのロット入力設定を設定します。
void | setBatchMgmt(String batchMgmt) ロット管理所要量区分を設定します。
void | setBomUsage(String bomUsage) BOM 用途を設定します。
void | setBulkMat(String bulkMat) 区分: バルク品目を設定します。
void | setBwdCons(String bwdCons) 消費期間: 後方を設定します。
void | setCasNo(String casNo) CAS 番号： 薬事品目 - 貿易を設定します。
void | setCcFixed(String ccFixed) 循環棚卸区分固定を設定します。
void | setCcPhInv(String ccPhInv) 循環棚卸の実地棚卸区分を設定します。
void | setCertType(String certType) 証明書タイプを設定します。
void | setCommCode(String commCode) 貿易: 統計品目コード/輸入コード番号を設定します。
void | setCommCoUn(String commCoUn) 物品コード (貿易) の数量単位を設定します。
void | setCommCoUnIso(String commCoUnIso) ISO コードによる物品コード (貿易管理) の数量単位を設定します。
void | setCompScrap(String compScrap) 構成品目不良率を設定します。
void | setConsummode(String consummode) 消費モードを設定します。
void | setCoProduct(String coProduct) 区分: 連産品としても使用可能な品目を設定します。
void | setCorrFact(String corrFact) 区分: 修正係数を需要予測値計算に使用を設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setCountryori(String countryori) 品目の原産国を設定します。
void | setCountryoriIso(String countryoriIso) ISO コードでの品目原産国を設定します。
void | setCovprofile(String covprofile) 在庫日数プロファイルを設定します。
void | setCritPart(String critPart) 区分: 重要品目を設定します。
void | setCtrlCode(String ctrlCode) 貿易: 消費税の管理コードを設定します。
void | setCtrlKey(String ctrlKey) 調達における品質管理の管理キーを設定します。
void | setCycleTime(String cycleTime) タクトタイムを設定します。
void | setDeclStatFlag(String declStatFlag) 区分: 仕入先申告ありを設定します。
void | setDelFlag(String delFlag) プラントレベルでの品目削除フラグを設定します。
void | setDeployHoriz(String deployHoriz) 供給分配期間の日数を設定します。
void | setDepReqId(String depReqId) 個別所要量と包括所要量に対する従属所要量区分を設定します。
void | setDetermGrp(String determGrp) 在庫決定グループを設定します。
void | setDiscontinu(String discontinu) 打切区分を設定します。
void | setDistrProf(String distrProf) サイトの商品の物流プロファイルを設定します。
void | setDocReqd(String docReqd) 文書必須フラグを設定します。
void | setDToRefM(String dToRefM) 消費データ参照の有効終了日を設定します。
void | setEffODay(String effODay) 有効終了日を設定します。
void | setEuListNo(String euListNo) CAP: CAP 製品一覧番号を設定します。
void | setEuMatGrp(String euMatGrp) EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。
void | setExCertDt(String exCertDt) 非該当証明書発行日を設定します。
void | setExCertId(String exCertId) 法令管理: 認定書区分を設定します。
void | setExCertNoNew(String exCertNoNew) 非該当証明書番号 - 法令管理を設定します。
void | setExpimpgrp(String expimpgrp) 輸出/輸入品目グループを設定します。
void | setFairShareRule(String fairShareRule) 均等配賦ルールを設定します。
void | setFixedLot(String fixedLot) 固定ロットサイズを設定します。
void | setFixLotSize(String fixLotSize) 需要供給の一致に対する固定ロットサイズを設定します。
void | setFollowUp(String followUp) フォローアップ品目を設定します。
void | setFollowUpExternal(String followUpExternal) 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。
void | setFollowUpGuid(String followUpGuid) 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。
void | setFollowUpVersion(String followUpVersion) 項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。
void | setForecastView(String forecastView) 需要予測ビューを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFwdCons(String fwdCons) 消費期間: 前方を設定します。
void | setFxdPrice(String fxdPrice) 固定価格連産品を設定します。
void | setFyVariant(String fyVariant) 会計年度バリアントを設定します。
void | setGrpReqmts(String grpReqmts) 区分: 所要量グループ化を設定します。
void | setGrPrTime(String grPrTime) 入庫処理日数を設定します。
void | setHandlgGrp(String handlgGrp) ワークロード計算のロジスティクス処理グループを設定します。
void | setIndPostToInspStock(String indPostToInspStock) 品質検査中在庫への転記を設定します。
void | setInhseprodt(String inhseprodt) 内製日数を設定します。
void | setInspInt(String inspInt) 次回再検査までの間隔を設定します。
void | setInspSetupFlag(String inspSetupFlag) 品目/プラントに QM 検査データ設定を設定します。
void | setInterop(String interop) 移動時間を設定します。
void | setIssStLoc(String issStLoc) 出庫保管場所を設定します。
void | setIssueUnit(String issueUnit) 出庫単位を設定します。
void | setIssueUnitIso(String issueUnitIso) ISO コードでの出庫単位を設定します。
void | setJitRelvt(String jitRelvt) 区分: JIT 納入日程の関連明細を設定します。
void | setLoadinggrp(String loadinggrp) 積載グループを設定します。
void | setLotIncrement(String lotIncrement) 需要と供給を一致させるためのロットサイズ増分を設定します。
void | setLotSize(String lotSize) 原価計算ロットサイズを設定します。
void | setLotsizekey(String lotsizekey) ロットサイズ (品目計画)を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMatCfop(String matCfop) 品目 CFOP カテゴリを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatfrgtgrp(String matfrgtgrp) 品目運賃グループを設定します。
void | setMatGrpTrans(String matGrpTrans) 段取替えマトリクスに対する品目のグループを設定します。
void | setMaxlotsize(String maxlotsize) 最大ロットサイズを設定します。
void | setMaxLotSize(String maxLotSize) 需要と供給を一致させるための最大ロットサイズを設定します。
void | setMaxStock(String maxStock) 最大在庫レベルを設定します。
void | setMilitId(String militId) ID: 武器を設定します。
void | setMinlotsize(String minlotsize) 最小ロットサイズを設定します。
void | setMinLotSize(String minLotSize) 需要と供給を一致させるための最小ロットサイズを設定します。
void | setMinSafetyStk(String minSafetyStk) 最小安全在庫を設定します。
void | setMixedMrp(String mixedMrp) 二重 MRP 区分を設定します。
void | setMrpAreaExists(String mrpAreaExists) 区分: MRP エリア登録済を設定します。
void | setMrpCtrler(String mrpCtrler) MRP 管理者を設定します。
void | setMrpGroup(String mrpGroup) MRP グループを設定します。
void | setMrpprofile(String mrpprofile) 品目: MRP プロファイルを設定します。
void | setMrpRelevancyDepRequirements(String mrpRelevancyDepRequirements) 従属所要量と MRP の関連性を設定します。
void | setMrpType(String mrpType) MRP タイプを設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setMultRefM(String multRefM) 消費データ参照品目の乗数を設定します。
void | setNegStocks(String negStocks) プラントにおけるマイナス在庫許可を設定します。
void | setNoCosting(String noCosting) 原価計算なしを設定します。
void | setOrdCosts(String ordCosts) 発注原価 (BAPI インタフェース)を設定します。
void | setOriginalBatchFlag(String originalBatchFlag) 元ロット管理区分を設定します。
void | setOriginalBatchRefMaterial(String originalBatchRefMaterial) 元ロットの参照品目を設定します。
void | setOverallprf(String overallprf) 指図変更管理の全体プロファイルを設定します。
void | setOverTol(String overTol) 過剰納入許容範囲リミットを設定します。
void | setPeriodInd(String periodInd) 期間区分を設定します。
void | setPeriodProfileSafetyTime(String periodProfileSafetyTime) 安全時間の期間プロファイルを設定します。
void | setPlanlistcnt(String planlistcnt) グループカウンタを設定します。
void | setPlanlistgrp(String planlistgrp) タスクリストグループのキーを設定します。
void | setPlanStrgp(String planStrgp) 計画方針グループを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlndDelry(String plndDelry) 予定納入時間 (単位: 日)を設定します。
void | setPlngCycle(String plngCycle) 計画サイクルを設定します。
void | setPlordCtrl(String plordCtrl) アクション管理: 計画手配処理を設定します。
void | setPlTiFnce(String plTiFnce) 計画タイムフェンスを設定します。
void | setPpcPlCal(String ppcPlCal) PPC 計画カレンダを設定します。
void | setPrefStatFlag(String prefStatFlag) 区分: 特恵関税 - 輸出/輸入を設定します。
void | setProcTime(String procTime) 処理時間を設定します。
void | setProcType(String procType) 調達タイプを設定します。
void | setProdcomNo(String prodcomNo) 生産統計: 貿易における PRODCOM コードを設定します。
void | setProdConvType(String prodConvType) 生産値の変換タイプを設定します。
void | setProdprof(String prodprof) 製造計画プロファイルを設定します。
void | setProductionScheduler(String productionScheduler) 製造計画担当を設定します。
void | setProdUnit(String prodUnit) 製造単位を設定します。
void | setProdUnitIso(String prodUnitIso) 製造単位 (ISO コード)を設定します。
void | setProdverscs(String prodverscs) 原価計算を行う製造バージョンを設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setPrtView(String prtView) 生産資源/治工具 (PRT) ビューを設定します。
void | setPsConfMat(String psConfMat) 選定可能品目を設定します。
void | setPurchView(String purchView) 購買管理ビューを設定します。
void | setPurGroup(String purGroup) 購買グループを設定します。
void | setPurStatus(String purStatus) プラント特有品目ステータスを設定します。
void | setPushDistrib(String pushDistrib) 区分: プッシュ配賦を設定します。
void | setPvalidfrom(String pvalidfrom) プラント品目ステータス有効期間開始日を設定します。
void | setQmAuthgrp(String qmAuthgrp) QM における活動の品目権限グループを設定します。
void | setQmRgmts(String qmRgmts) 仕入先の必須 QM システムを設定します。
void | setQualityView(String qualityView) 品質管理ビューを設定します。
void | setQuotausage(String quotausage) 供給量割当の使用を設定します。
void | setRefmatcons(String refmatcons) 消費参照品目を設定します。
void | setRefmatconsExternal(String refmatconsExternal) 項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。
void | setRefmatconsGuid(String refmatconsGuid) 項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。
void | setRefmatconsVersion(String refmatconsVersion) 項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。
void | setRefpltcons(String refpltcons) 消費参照プラントを設定します。
void | setRegionorig(String regionorig) 品目の原産地 (非特恵対象地区の原産)を設定します。
void | setReorderPt(String reorderPt) 発注点を設定します。
void | setReplacePt(String replacePt) 取替部品を設定します。
void | setReplentime(String replentime) 補充リードタイム合計 (稼動日数)を設定します。
void | setRepmanprof(String repmanprof) 繰返生産プロファイルを設定します。
void | setRepManuf(String repManuf) 区分: 繰返生産許可を設定します。
void | setRotationDate(String rotationDate) 原価計算ビューを設定します。
void | setRoundProf(String roundProf) 丸めプロファイルを設定します。
void | setRoundVal(String roundVal) 購買発注数量の丸め数量を設定します。
void | setSafetyStk(String safetyStk) 安全在庫を設定します。
void | setSafetytime(String safetytime) 安全時間 (稼動日数)を設定します。
void | setSaftyTId(String saftyTId) 安全時間区分（安全リードタイムあり/なし)を設定します。
void | setSalesView(String salesView) 販売ビューを設定します。
void | setSernoProf(String sernoProf) シリアル番号プロファイルを設定します。
void | setServLevel(String servLevel) サービスレベルを設定します。
void | setSetuptime(String setuptime) 段取時間と片付け時間を設定します。
void | setSetupTime(String setupTime) 出荷準備時間を設定します。
void | setShipProcTime(String shipProcTime) 出荷処理時間を設定します。
void | setSlocExprc(String slocExprc) 外部調達の初期保管場所を設定します。
void | setSmKey(String smKey) 日程計画余裕キーを設定します。
void | setSourcelist(String sourcelist) 区分: 供給元一覧必須を設定します。
void | setSpecprocty(String specprocty) 原価計算の特殊調達タイプを設定します。
void | setSplitInd(String splitInd) 分割区分を設定します。
void | setSpproctype(String spproctype) 特殊調達タイプを設定します。
void | setStgePdUn(String stgePdUn) 最長保管期間の単位を設定します。
void | setStgePdUnIso(String stgePdUnIso) ISO コードでの最長保管期間単位を設定します。
void | setStgeperiod(String stgeperiod) 最長保管期間を設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
void | setStorCosts(String storCosts) 保管経費区分を設定します。
void | setSupplyArea(String supplyArea) 品目マスタレコードで提案される供給場所を設定します。
void | setSupSource(String supSource) 供給元を設定します。
void | setTaskListType(String taskListType) タスクリストタイプを設定します。
void | setUnderTol(String underTol) 不足納入許容範囲リミットを設定します。
void | setUnitGroup(String unitGroup) 数量単位グループを設定します。
void | setUnlimited(String unlimited) 区分: 無制限過剰納入可能を設定します。
void | setVarianceKey(String varianceKey) 差異キーを設定します。
void | setVersionFlag(String versionFlag) バージョン区分を設定します。
void | setWarehouseView(String warehouseView) 倉庫管理ビューを設定します。
void | setWorkSchedView(String workSchedView) 作業計画ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantData

public PlantData()
品目データ (プラントレベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
プラントレベルでの品目削除フラグを取得します。

戻り値:
delFlag プラントレベルでの品目削除フラグ

getAbcId

public String getAbcId()
ABC 区分を取得します。

戻り値:
abcId ABC 区分

getCritPart

public String getCritPart()
区分: 重要品目を取得します。

戻り値:
critPart 区分: 重要品目

getPurGroup

public String getPurGroup()
購買グループを取得します。

戻り値:
purGroup 購買グループ

getIssueUnit

public String getIssueUnit()
出庫単位を取得します。

戻り値:
issueUnit 出庫単位

getIssueUnitIso

public String getIssueUnitIso()
ISO コードでの出庫単位を取得します。

戻り値:
issueUnitIso ISO コードでの出庫単位

getMrpprofile

public String getMrpprofile()
品目: MRP プロファイルを取得します。

戻り値:
mrpprofile 品目: MRP プロファイル

getMrpType

public String getMrpType()
MRP タイプを取得します。

戻り値:
mrpType MRP タイプ

getMrpCtrler

public String getMrpCtrler()
MRP 管理者を取得します。

戻り値:
mrpCtrler MRP 管理者

getPlndDelry

public String getPlndDelry()
予定納入時間 (単位: 日)を取得します。

戻り値:
plndDelry 予定納入時間 (単位: 日)

getGrPrTime

public String getGrPrTime()
入庫処理日数を取得します。

戻り値:
grPrTime 入庫処理日数

getPeriodInd

public String getPeriodInd()
期間区分を取得します。

戻り値:
periodInd 期間区分

getAssyScrap

public String getAssyScrap()
組立不良率を取得します。

戻り値:
assyScrap 組立不良率

getLotsizekey

public String getLotsizekey()
ロットサイズ (品目計画)を取得します。

戻り値:
lotsizekey ロットサイズ (品目計画)

getProcType

public String getProcType()
調達タイプを取得します。

戻り値:
procType 調達タイプ

getSpproctype

public String getSpproctype()
特殊調達タイプを取得します。

戻り値:
spproctype 特殊調達タイプ

getReorderPt

public String getReorderPt()
発注点を取得します。

戻り値:
reorderPt 発注点

getSafetyStk

public String getSafetyStk()
安全在庫を取得します。

戻り値:
safetyStk 安全在庫

getMinlotsize

public String getMinlotsize()
最小ロットサイズを取得します。

戻り値:
minlotsize 最小ロットサイズ

getMaxlotsize

public String getMaxlotsize()
最大ロットサイズを取得します。

戻り値:
maxlotsize 最大ロットサイズ

getFixedLot

public String getFixedLot()
固定ロットサイズを取得します。

戻り値:
fixedLot 固定ロットサイズ

getRoundVal

public String getRoundVal()
購買発注数量の丸め数量を取得します。

戻り値:
roundVal 購買発注数量の丸め数量

getMaxStock

public String getMaxStock()
最大在庫レベルを取得します。

戻り値:
maxStock 最大在庫レベル

getOrdCosts

public String getOrdCosts()
発注原価 (BAPI インタフェース)を取得します。

戻り値:
ordCosts 発注原価 (BAPI インタフェース)

getDepReqId

public String getDepReqId()
個別所要量と包括所要量に対する従属所要量区分を取得します。

戻り値:
depReqId 個別所要量と包括所要量に対する従属所要量区分

getStorCosts

public String getStorCosts()
保管経費区分を取得します。

戻り値:
storCosts 保管経費区分

getAltBomId

public String getAltBomId()
代替 BOM 選択の方法を取得します。

戻り値:
altBomId 代替 BOM 選択の方法

getDiscontinu

public String getDiscontinu()
打切区分を取得します。

戻り値:
discontinu 打切区分

getEffODay

public String getEffODay()
有効終了日を取得します。

戻り値:
effODay 有効終了日

getFollowUp

public String getFollowUp()
フォローアップ品目を取得します。

戻り値:
followUp フォローアップ品目

getGrpReqmts

public String getGrpReqmts()
区分: 所要量グループ化を取得します。

戻り値:
grpReqmts 区分: 所要量グループ化

getMixedMrp

public String getMixedMrp()
二重 MRP 区分を取得します。

戻り値:
mixedMrp 二重 MRP 区分

getSmKey

public String getSmKey()
日程計画余裕キーを取得します。

戻り値:
smKey 日程計画余裕キー

getBackflush

public String getBackflush()
区分: バックフラッシュを取得します。

戻り値:
backflush 区分: バックフラッシュ

getProductionScheduler

public String getProductionScheduler()
製造計画担当を取得します。

戻り値:
productionScheduler 製造計画担当

getProcTime

public String getProcTime()
処理時間を取得します。

戻り値:
procTime 処理時間

getSetuptime

public String getSetuptime()
段取時間と片付け時間を取得します。

戻り値:
setuptime 段取時間と片付け時間

getInterop

public String getInterop()
移動時間を取得します。

戻り値:
interop 移動時間

getBaseQty

public String getBaseQty()
基本数量を取得します。

戻り値:
baseQty 基本数量

getInhseprodt

public String getInhseprodt()
内製日数を取得します。

戻り値:
inhseprodt 内製日数

getStgeperiod

public String getStgeperiod()
最長保管期間を取得します。

戻り値:
stgeperiod 最長保管期間

getStgePdUn

public String getStgePdUn()
最長保管期間の単位を取得します。

戻り値:
stgePdUn 最長保管期間の単位

getStgePdUnIso

public String getStgePdUnIso()
ISO コードでの最長保管期間単位を取得します。

戻り値:
stgePdUnIso ISO コードでの最長保管期間単位

getOverTol

public String getOverTol()
過剰納入許容範囲リミットを取得します。

戻り値:
overTol 過剰納入許容範囲リミット

getUnlimited

public String getUnlimited()
区分: 無制限過剰納入可能を取得します。

戻り値:
unlimited 区分: 無制限過剰納入可能

getUnderTol

public String getUnderTol()
不足納入許容範囲リミットを取得します。

戻り値:
underTol 不足納入許容範囲リミット

getReplentime

public String getReplentime()
補充リードタイム合計 (稼動日数)を取得します。

戻り値:
replentime 補充リードタイム合計 (稼動日数)

getReplacePt

public String getReplacePt()
取替部品を取得します。

戻り値:
replacePt 取替部品

getIndPostToInspStock

public String getIndPostToInspStock()
品質検査中在庫への転記を取得します。

戻り値:
indPostToInspStock 品質検査中在庫への転記

getCtrlKey

public String getCtrlKey()
調達における品質管理の管理キーを取得します。

戻り値:
ctrlKey 調達における品質管理の管理キー

getDocReqd

public String getDocReqd()
文書必須フラグを取得します。

戻り値:
docReqd 文書必須フラグ

getLoadinggrp

public String getLoadinggrp()
積載グループを取得します。

戻り値:
loadinggrp 積載グループ

getBatchMgmt

public String getBatchMgmt()
ロット管理所要量区分を取得します。

戻り値:
batchMgmt ロット管理所要量区分

getQuotausage

public String getQuotausage()
供給量割当の使用を取得します。

戻り値:
quotausage 供給量割当の使用

getServLevel

public String getServLevel()
サービスレベルを取得します。

戻り値:
servLevel サービスレベル

getSplitInd

public String getSplitInd()
分割区分を取得します。

戻り値:
splitInd 分割区分

getAvailcheck

public String getAvailcheck()
利用可能在庫確認の確認グループを取得します。

戻り値:
availcheck 利用可能在庫確認の確認グループ

getFyVariant

public String getFyVariant()
会計年度バリアントを取得します。

戻り値:
fyVariant 会計年度バリアント

getCorrFact

public String getCorrFact()
区分: 修正係数を需要予測値計算に使用を取得します。

戻り値:
corrFact 区分: 修正係数を需要予測値計算に使用

getSetupTime

public String getSetupTime()
出荷準備時間を取得します。

戻り値:
setupTime 出荷準備時間

getBaseQtyPlan

public String getBaseQtyPlan()
出荷の能力計画のための基本数量を取得します。

戻り値:
baseQtyPlan 出荷の能力計画のための基本数量

getShipProcTime

public String getShipProcTime()
出荷処理時間を取得します。

戻り値:
shipProcTime 出荷処理時間

getSupSource

public String getSupSource()
供給元を取得します。

戻り値:
supSource 供給元

getAutoPOrd

public String getAutoPOrd()
区分: "購買発注自動生成"を取得します。

戻り値:
autoPOrd 区分: "購買発注自動生成"

getSourcelist

public String getSourcelist()
区分: 供給元一覧必須を取得します。

戻り値:
sourcelist 区分: 供給元一覧必須

getCommCode

public String getCommCode()
貿易: 統計品目コード/輸入コード番号を取得します。

戻り値:
commCode 貿易: 統計品目コード/輸入コード番号

getCountryori

public String getCountryori()
品目の原産国を取得します。

戻り値:
countryori 品目の原産国

getCountryoriIso

public String getCountryoriIso()
ISO コードでの品目原産国を取得します。

戻り値:
countryoriIso ISO コードでの品目原産国

getRegionorig

public String getRegionorig()
品目の原産地 (非特恵対象地区の原産)を取得します。

戻り値:
regionorig 品目の原産地 (非特恵対象地区の原産)

getCommCoUn

public String getCommCoUn()
物品コード (貿易) の数量単位を取得します。

戻り値:
commCoUn 物品コード (貿易) の数量単位

getCommCoUnIso

public String getCommCoUnIso()
ISO コードによる物品コード (貿易管理) の数量単位を取得します。

戻り値:
commCoUnIso ISO コードによる物品コード (貿易管理) の数量単位

getExpimpgrp

public String getExpimpgrp()
輸出/輸入品目グループを取得します。

戻り値:
expimpgrp 輸出/輸入品目グループ

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getPpcPlCal

public String getPpcPlCal()
PPC 計画カレンダを取得します。

戻り値:
ppcPlCal PPC 計画カレンダ

getRepManuf

public String getRepManuf()
区分: 繰返生産許可を取得します。

戻り値:
repManuf 区分: 繰返生産許可

getPlTiFnce

public String getPlTiFnce()
計画タイムフェンスを取得します。

戻り値:
plTiFnce 計画タイムフェンス

getConsummode

public String getConsummode()
消費モードを取得します。

戻り値:
consummode 消費モード

getBwdCons

public String getBwdCons()
消費期間: 後方を取得します。

戻り値:
bwdCons 消費期間: 後方

getFwdCons

public String getFwdCons()
消費期間: 前方を取得します。

戻り値:
fwdCons 消費期間: 前方

getVersionFlag

public String getVersionFlag()
バージョン区分を取得します。

戻り値:
versionFlag バージョン区分

getAlternativeBom

public String getAlternativeBom()
代替 BOMを取得します。

戻り値:
alternativeBom 代替 BOM

getBomUsage

public String getBomUsage()
BOM 用途を取得します。

戻り値:
bomUsage BOM 用途

getPlanlistgrp

public String getPlanlistgrp()
タスクリストグループのキーを取得します。

戻り値:
planlistgrp タスクリストグループのキー

getPlanlistcnt

public String getPlanlistcnt()
グループカウンタを取得します。

戻り値:
planlistcnt グループカウンタ

getLotSize

public String getLotSize()
原価計算ロットサイズを取得します。

戻り値:
lotSize 原価計算ロットサイズ

getSpecprocty

public String getSpecprocty()
原価計算の特殊調達タイプを取得します。

戻り値:
specprocty 原価計算の特殊調達タイプ

getProdUnit

public String getProdUnit()
製造単位を取得します。

戻り値:
prodUnit 製造単位

getProdUnitIso

public String getProdUnitIso()
製造単位 (ISO コード)を取得します。

戻り値:
prodUnitIso 製造単位 (ISO コード)

getIssStLoc

public String getIssStLoc()
出庫保管場所を取得します。

戻り値:
issStLoc 出庫保管場所

getMrpGroup

public String getMrpGroup()
MRP グループを取得します。

戻り値:
mrpGroup MRP グループ

getCompScrap

public String getCompScrap()
構成品目不良率を取得します。

戻り値:
compScrap 構成品目不良率

getCertType

public String getCertType()
証明書タイプを取得します。

戻り値:
certType 証明書タイプ

getCycleTime

public String getCycleTime()
タクトタイムを取得します。

戻り値:
cycleTime タクトタイム

getInspSetupFlag

public String getInspSetupFlag()
品目/プラントに QM 検査データ設定を取得します。

戻り値:
inspSetupFlag 品目/プラントに QM 検査データ設定

getCovprofile

public String getCovprofile()
在庫日数プロファイルを取得します。

戻り値:
covprofile 在庫日数プロファイル

getCcPhInv

public String getCcPhInv()
循環棚卸の実地棚卸区分を取得します。

戻り値:
ccPhInv 循環棚卸の実地棚卸区分

getVarianceKey

public String getVarianceKey()
差異キーを取得します。

戻り値:
varianceKey 差異キー

getSernoProf

public String getSernoProf()
シリアル番号プロファイルを取得します。

戻り値:
sernoProf シリアル番号プロファイル

getPsConfMat

public String getPsConfMat()
選定可能品目を取得します。

戻り値:
psConfMat 選定可能品目

getRepmanprof

public String getRepmanprof()
繰返生産プロファイルを取得します。

戻り値:
repmanprof 繰返生産プロファイル

getNegStocks

public String getNegStocks()
プラントにおけるマイナス在庫許可を取得します。

戻り値:
negStocks プラントにおけるマイナス在庫許可

getQmRgmts

public String getQmRgmts()
仕入先の必須 QM システムを取得します。

戻り値:
qmRgmts 仕入先の必須 QM システム

getPlngCycle

public String getPlngCycle()
計画サイクルを取得します。

戻り値:
plngCycle 計画サイクル

getRoundProf

public String getRoundProf()
丸めプロファイルを取得します。

戻り値:
roundProf 丸めプロファイル

getRefmatcons

public String getRefmatcons()
消費参照品目を取得します。

戻り値:
refmatcons 消費参照品目

getRefpltcons

public String getRefpltcons()
消費参照プラントを取得します。

戻り値:
refpltcons 消費参照プラント

getDToRefM

public String getDToRefM()
消費データ参照の有効終了日を取得します。

戻り値:
dToRefM 消費データ参照の有効終了日

getMultRefM

public String getMultRefM()
消費データ参照品目の乗数を取得します。

戻り値:
multRefM 消費データ参照品目の乗数

getAutoReset

public String getAutoReset()
予測モデル自動リセットを取得します。

戻り値:
autoReset 予測モデル自動リセット

getPrefStatFlag

public String getPrefStatFlag()
区分: 特恵関税 - 輸出/輸入を取得します。

戻り値:
prefStatFlag 区分: 特恵関税 - 輸出/輸入

getExCertId

public String getExCertId()
法令管理: 認定書区分を取得します。

戻り値:
exCertId 法令管理: 認定書区分

getExCertNoNew

public String getExCertNoNew()
非該当証明書番号 - 法令管理を取得します。

戻り値:
exCertNoNew 非該当証明書番号 - 法令管理

getExCertDt

public String getExCertDt()
非該当証明書発行日を取得します。

戻り値:
exCertDt 非該当証明書発行日

getDeclStatFlag

public String getDeclStatFlag()
区分: 仕入先申告ありを取得します。

戻り値:
declStatFlag 区分: 仕入先申告あり

getMilitId

public String getMilitId()
ID: 武器を取得します。

戻り値:
militId ID: 武器

getInspInt

public String getInspInt()
次回再検査までの間隔を取得します。

戻り値:
inspInt 次回再検査までの間隔

getCoProduct

public String getCoProduct()
区分: 連産品としても使用可能な品目を取得します。

戻り値:
coProduct 区分: 連産品としても使用可能な品目

getPlanStrgp

public String getPlanStrgp()
計画方針グループを取得します。

戻り値:
planStrgp 計画方針グループ

getSlocExprc

public String getSlocExprc()
外部調達の初期保管場所を取得します。

戻り値:
slocExprc 外部調達の初期保管場所

getBulkMat

public String getBulkMat()
区分: バルク品目を取得します。

戻り値:
bulkMat 区分: バルク品目

getCcFixed

public String getCcFixed()
循環棚卸区分固定を取得します。

戻り値:
ccFixed 循環棚卸区分固定

getDetermGrp

public String getDetermGrp()
在庫決定グループを取得します。

戻り値:
determGrp 在庫決定グループ

getQmAuthgrp

public String getQmAuthgrp()
QM における活動の品目権限グループを取得します。

戻り値:
qmAuthgrp QM における活動の品目権限グループ

getTaskListType

public String getTaskListType()
タスクリストタイプを取得します。

戻り値:
taskListType タスクリストタイプ

getPurStatus

public String getPurStatus()
プラント特有品目ステータスを取得します。

戻り値:
purStatus プラント特有品目ステータス

getProdprof

public String getProdprof()
製造計画プロファイルを取得します。

戻り値:
prodprof 製造計画プロファイル

getSaftyTId

public String getSaftyTId()
安全時間区分（安全リードタイムあり/なし)を取得します。

戻り値:
saftyTId 安全時間区分（安全リードタイムあり/なし)

getSafetytime

public String getSafetytime()
安全時間 (稼動日数)を取得します。

戻り値:
safetytime 安全時間 (稼動日数)

getPlordCtrl

public String getPlordCtrl()
アクション管理: 計画手配処理を取得します。

戻り値:
plordCtrl アクション管理: 計画手配処理

getBatchentry

public String getBatchentry()
製造/プロセス指図でのロット入力設定を取得します。

戻り値:
batchentry 製造/プロセス指図でのロット入力設定

getPvalidfrom

public String getPvalidfrom()
プラント品目ステータス有効期間開始日を取得します。

戻り値:
pvalidfrom プラント品目ステータス有効期間開始日

getMatfrgtgrp

public String getMatfrgtgrp()
品目運賃グループを取得します。

戻り値:
matfrgtgrp 品目運賃グループ

getProdverscs

public String getProdverscs()
原価計算を行う製造バージョンを取得します。

戻り値:
prodverscs 原価計算を行う製造バージョン

getMatCfop

public String getMatCfop()
品目 CFOP カテゴリを取得します。

戻り値:
matCfop 品目 CFOP カテゴリ

getEuListNo

public String getEuListNo()
CAP: CAP 製品一覧番号を取得します。

戻り値:
euListNo CAP: CAP 製品一覧番号

getEuMatGrp

public String getEuMatGrp()
EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。

戻り値:
euMatGrp EEC 農産物政策: CAP 生産品グループ - 貿易

getCasNo

public String getCasNo()
CAS 番号： 薬事品目 - 貿易を取得します。

戻り値:
casNo CAS 番号： 薬事品目 - 貿易

getProdcomNo

public String getProdcomNo()
生産統計: 貿易における PRODCOM コードを取得します。

戻り値:
prodcomNo 生産統計: 貿易における PRODCOM コード

getCtrlCode

public String getCtrlCode()
貿易: 消費税の管理コードを取得します。

戻り値:
ctrlCode 貿易: 消費税の管理コード

getJitRelvt

public String getJitRelvt()
区分: JIT 納入日程の関連明細を取得します。

戻り値:
jitRelvt 区分: JIT 納入日程の関連明細

getMatGrpTrans

public String getMatGrpTrans()
段取替えマトリクスに対する品目のグループを取得します。

戻り値:
matGrpTrans 段取替えマトリクスに対する品目のグループ

getHandlgGrp

public String getHandlgGrp()
ワークロード計算のロジスティクス処理グループを取得します。

戻り値:
handlgGrp ワークロード計算のロジスティクス処理グループ

getSupplyArea

public String getSupplyArea()
品目マスタレコードで提案される供給場所を取得します。

戻り値:
supplyArea 品目マスタレコードで提案される供給場所

getFairShareRule

public String getFairShareRule()
均等配賦ルールを取得します。

戻り値:
fairShareRule 均等配賦ルール

getPushDistrib

public String getPushDistrib()
区分: プッシュ配賦を取得します。

戻り値:
pushDistrib 区分: プッシュ配賦

getDeployHoriz

public String getDeployHoriz()
供給分配期間の日数を取得します。

戻り値:
deployHoriz 供給分配期間の日数

getMinLotSize

public String getMinLotSize()
需要と供給を一致させるための最小ロットサイズを取得します。

戻り値:
minLotSize 需要と供給を一致させるための最小ロットサイズ

getMaxLotSize

public String getMaxLotSize()
需要と供給を一致させるための最大ロットサイズを取得します。

戻り値:
maxLotSize 需要と供給を一致させるための最大ロットサイズ

getFixLotSize

public String getFixLotSize()
需要供給の一致に対する固定ロットサイズを取得します。

戻り値:
fixLotSize 需要供給の一致に対する固定ロットサイズ

getLotIncrement

public String getLotIncrement()
需要と供給を一致させるためのロットサイズ増分を取得します。

戻り値:
lotIncrement 需要と供給を一致させるためのロットサイズ増分

getProdConvType

public String getProdConvType()
生産値の変換タイプを取得します。

戻り値:
prodConvType 生産値の変換タイプ

getDistrProf

public String getDistrProf()
サイトの商品の物流プロファイルを取得します。

戻り値:
distrProf サイトの商品の物流プロファイル

getPeriodProfileSafetyTime

public String getPeriodProfileSafetyTime()
安全時間の期間プロファイルを取得します。

戻り値:
periodProfileSafetyTime 安全時間の期間プロファイル

getFxdPrice

public String getFxdPrice()
固定価格連産品を取得します。

戻り値:
fxdPrice 固定価格連産品

getAvailCheckAllProjSegments

public String getAvailCheckAllProjSegments()
プロジェクト間品目区分を取得します。

戻り値:
availCheckAllProjSegments プロジェクト間品目区分

getOverallprf

public String getOverallprf()
指図変更管理の全体プロファイルを取得します。

戻り値:
overallprf 指図変更管理の全体プロファイル

getMrpRelevancyDepRequirements

public String getMrpRelevancyDepRequirements()
従属所要量と MRP の関連性を取得します。

戻り値:
mrpRelevancyDepRequirements 従属所要量と MRP の関連性

getMrpAreaExists

public String getMrpAreaExists()
区分: MRP エリア登録済を取得します。

戻り値:
mrpAreaExists 区分: MRP エリア登録済

getMinSafetyStk

public String getMinSafetyStk()
最小安全在庫を取得します。

戻り値:
minSafetyStk 最小安全在庫

getNoCosting

public String getNoCosting()
原価計算なしを取得します。

戻り値:
noCosting 原価計算なし

getUnitGroup

public String getUnitGroup()
数量単位グループを取得します。

戻り値:
unitGroup 数量単位グループ

getFollowUpExternal

public String getFollowUpExternal()
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
followUpExternal 項目 FOLLOW_UP の品目コード (長) (今後の リリースで開発)

getFollowUpGuid

public String getFollowUpGuid()
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
followUpGuid 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

getFollowUpVersion

public String getFollowUpVersion()
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
followUpVersion 項目 FOLLOW_UP のバージョン番号 (今後の リリースで開発)

getRefmatconsExternal

public String getRefmatconsExternal()
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
refmatconsExternal 項目 REFMATCONS の品目コード (長) (今後の リリースで開発)

getRefmatconsGuid

public String getRefmatconsGuid()
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
refmatconsGuid 項目 REFMATCONS の外部 GUID (今後のリリースで開発)

getRefmatconsVersion

public String getRefmatconsVersion()
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
refmatconsVersion 項目 REFMATCONS のバージョン番号 (今後の リリースで開発)

getSalesView

public String getSalesView()
販売ビューを取得します。

戻り値:
salesView 販売ビュー

getPurchView

public String getPurchView()
購買管理ビューを取得します。

戻り値:
purchView 購買管理ビュー

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getForecastView

public String getForecastView()
需要予測ビューを取得します。

戻り値:
forecastView 需要予測ビュー

getWorkSchedView

public String getWorkSchedView()
作業計画ビューを取得します。

戻り値:
workSchedView 作業計画ビュー

getPrtView

public String getPrtView()
生産資源/治工具 (PRT) ビューを取得します。

戻り値:
prtView 生産資源/治工具 (PRT) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getWarehouseView

public String getWarehouseView()
倉庫管理ビューを取得します。

戻り値:
warehouseView 倉庫管理ビュー

getQualityView

public String getQualityView()
品質管理ビューを取得します。

戻り値:
qualityView 品質管理ビュー

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getRotationDate

public String getRotationDate()
原価計算ビューを取得します。

戻り値:
rotationDate 原価計算ビュー

getOriginalBatchFlag

public String getOriginalBatchFlag()
元ロット管理区分を取得します。

戻り値:
originalBatchFlag 元ロット管理区分

getOriginalBatchRefMaterial

public String getOriginalBatchRefMaterial()
元ロットの参照品目を取得します。

戻り値:
originalBatchRefMaterial 元ロットの参照品目

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
プラントレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - プラントレベルでの品目削除フラグ

setAbcId

public void setAbcId(String abcId)
ABC 区分を設定します。

パラメータ:
abcId - ABC 区分

setCritPart

public void setCritPart(String critPart)
区分: 重要品目を設定します。

パラメータ:
critPart - 区分: 重要品目

setPurGroup

public void setPurGroup(String purGroup)
購買グループを設定します。

パラメータ:
purGroup - 購買グループ

setIssueUnit

public void setIssueUnit(String issueUnit)
出庫単位を設定します。

パラメータ:
issueUnit - 出庫単位

setIssueUnitIso

public void setIssueUnitIso(String issueUnitIso)
ISO コードでの出庫単位を設定します。

パラメータ:
issueUnitIso - ISO コードでの出庫単位

setMrpprofile

public void setMrpprofile(String mrpprofile)
品目: MRP プロファイルを設定します。

パラメータ:
mrpprofile - 品目: MRP プロファイル

setMrpType

public void setMrpType(String mrpType)
MRP タイプを設定します。

パラメータ:
mrpType - MRP タイプ

setMrpCtrler

public void setMrpCtrler(String mrpCtrler)
MRP 管理者を設定します。

パラメータ:
mrpCtrler - MRP 管理者

setPlndDelry

public void setPlndDelry(String plndDelry)
予定納入時間 (単位: 日)を設定します。

パラメータ:
plndDelry - 予定納入時間 (単位: 日)

setGrPrTime

public void setGrPrTime(String grPrTime)
入庫処理日数を設定します。

パラメータ:
grPrTime - 入庫処理日数

setPeriodInd

public void setPeriodInd(String periodInd)
期間区分を設定します。

パラメータ:
periodInd - 期間区分

setAssyScrap

public void setAssyScrap(String assyScrap)
組立不良率を設定します。

パラメータ:
assyScrap - 組立不良率

setLotsizekey

public void setLotsizekey(String lotsizekey)
ロットサイズ (品目計画)を設定します。

パラメータ:
lotsizekey - ロットサイズ (品目計画)

setProcType

public void setProcType(String procType)
調達タイプを設定します。

パラメータ:
procType - 調達タイプ

setSpproctype

public void setSpproctype(String spproctype)
特殊調達タイプを設定します。

パラメータ:
spproctype - 特殊調達タイプ

setReorderPt

public void setReorderPt(String reorderPt)
発注点を設定します。

パラメータ:
reorderPt - 発注点

setSafetyStk

public void setSafetyStk(String safetyStk)
安全在庫を設定します。

パラメータ:
safetyStk - 安全在庫

setMinlotsize

public void setMinlotsize(String minlotsize)
最小ロットサイズを設定します。

パラメータ:
minlotsize - 最小ロットサイズ

setMaxlotsize

public void setMaxlotsize(String maxlotsize)
最大ロットサイズを設定します。

パラメータ:
maxlotsize - 最大ロットサイズ

setFixedLot

public void setFixedLot(String fixedLot)
固定ロットサイズを設定します。

パラメータ:
fixedLot - 固定ロットサイズ

setRoundVal

public void setRoundVal(String roundVal)
購買発注数量の丸め数量を設定します。

パラメータ:
roundVal - 購買発注数量の丸め数量

setMaxStock

public void setMaxStock(String maxStock)
最大在庫レベルを設定します。

パラメータ:
maxStock - 最大在庫レベル

setOrdCosts

public void setOrdCosts(String ordCosts)
発注原価 (BAPI インタフェース)を設定します。

パラメータ:
ordCosts - 発注原価 (BAPI インタフェース)

setDepReqId

public void setDepReqId(String depReqId)
個別所要量と包括所要量に対する従属所要量区分を設定します。

パラメータ:
depReqId - 個別所要量と包括所要量に対する従属所要量区分

setStorCosts

public void setStorCosts(String storCosts)
保管経費区分を設定します。

パラメータ:
storCosts - 保管経費区分

setAltBomId

public void setAltBomId(String altBomId)
代替 BOM 選択の方法を設定します。

パラメータ:
altBomId - 代替 BOM 選択の方法

setDiscontinu

public void setDiscontinu(String discontinu)
打切区分を設定します。

パラメータ:
discontinu - 打切区分

setEffODay

public void setEffODay(String effODay)
有効終了日を設定します。

パラメータ:
effODay - 有効終了日

setFollowUp

public void setFollowUp(String followUp)
フォローアップ品目を設定します。

パラメータ:
followUp - フォローアップ品目

setGrpReqmts

public void setGrpReqmts(String grpReqmts)
区分: 所要量グループ化を設定します。

パラメータ:
grpReqmts - 区分: 所要量グループ化

setMixedMrp

public void setMixedMrp(String mixedMrp)
二重 MRP 区分を設定します。

パラメータ:
mixedMrp - 二重 MRP 区分

setSmKey

public void setSmKey(String smKey)
日程計画余裕キーを設定します。

パラメータ:
smKey - 日程計画余裕キー

setBackflush

public void setBackflush(String backflush)
区分: バックフラッシュを設定します。

パラメータ:
backflush - 区分: バックフラッシュ

setProductionScheduler

public void setProductionScheduler(String productionScheduler)
製造計画担当を設定します。

パラメータ:
productionScheduler - 製造計画担当

setProcTime

public void setProcTime(String procTime)
処理時間を設定します。

パラメータ:
procTime - 処理時間

setSetuptime

public void setSetuptime(String setuptime)
段取時間と片付け時間を設定します。

パラメータ:
setuptime - 段取時間と片付け時間

setInterop

public void setInterop(String interop)
移動時間を設定します。

パラメータ:
interop - 移動時間

setBaseQty

public void setBaseQty(String baseQty)
基本数量を設定します。

パラメータ:
baseQty - 基本数量

setInhseprodt

public void setInhseprodt(String inhseprodt)
内製日数を設定します。

パラメータ:
inhseprodt - 内製日数

setStgeperiod

public void setStgeperiod(String stgeperiod)
最長保管期間を設定します。

パラメータ:
stgeperiod - 最長保管期間

setStgePdUn

public void setStgePdUn(String stgePdUn)
最長保管期間の単位を設定します。

パラメータ:
stgePdUn - 最長保管期間の単位

setStgePdUnIso

public void setStgePdUnIso(String stgePdUnIso)
ISO コードでの最長保管期間単位を設定します。

パラメータ:
stgePdUnIso - ISO コードでの最長保管期間単位

setOverTol

public void setOverTol(String overTol)
過剰納入許容範囲リミットを設定します。

パラメータ:
overTol - 過剰納入許容範囲リミット

setUnlimited

public void setUnlimited(String unlimited)
区分: 無制限過剰納入可能を設定します。

パラメータ:
unlimited - 区分: 無制限過剰納入可能

setUnderTol

public void setUnderTol(String underTol)
不足納入許容範囲リミットを設定します。

パラメータ:
underTol - 不足納入許容範囲リミット

setReplentime

public void setReplentime(String replentime)
補充リードタイム合計 (稼動日数)を設定します。

パラメータ:
replentime - 補充リードタイム合計 (稼動日数)

setReplacePt

public void setReplacePt(String replacePt)
取替部品を設定します。

パラメータ:
replacePt - 取替部品

setIndPostToInspStock

public void setIndPostToInspStock(String indPostToInspStock)
品質検査中在庫への転記を設定します。

パラメータ:
indPostToInspStock - 品質検査中在庫への転記

setCtrlKey

public void setCtrlKey(String ctrlKey)
調達における品質管理の管理キーを設定します。

パラメータ:
ctrlKey - 調達における品質管理の管理キー

setDocReqd

public void setDocReqd(String docReqd)
文書必須フラグを設定します。

パラメータ:
docReqd - 文書必須フラグ

setLoadinggrp

public void setLoadinggrp(String loadinggrp)
積載グループを設定します。

パラメータ:
loadinggrp - 積載グループ

setBatchMgmt

public void setBatchMgmt(String batchMgmt)
ロット管理所要量区分を設定します。

パラメータ:
batchMgmt - ロット管理所要量区分

setQuotausage

public void setQuotausage(String quotausage)
供給量割当の使用を設定します。

パラメータ:
quotausage - 供給量割当の使用

setServLevel

public void setServLevel(String servLevel)
サービスレベルを設定します。

パラメータ:
servLevel - サービスレベル

setSplitInd

public void setSplitInd(String splitInd)
分割区分を設定します。

パラメータ:
splitInd - 分割区分

setAvailcheck

public void setAvailcheck(String availcheck)
利用可能在庫確認の確認グループを設定します。

パラメータ:
availcheck - 利用可能在庫確認の確認グループ

setFyVariant

public void setFyVariant(String fyVariant)
会計年度バリアントを設定します。

パラメータ:
fyVariant - 会計年度バリアント

setCorrFact

public void setCorrFact(String corrFact)
区分: 修正係数を需要予測値計算に使用を設定します。

パラメータ:
corrFact - 区分: 修正係数を需要予測値計算に使用

setSetupTime

public void setSetupTime(String setupTime)
出荷準備時間を設定します。

パラメータ:
setupTime - 出荷準備時間

setBaseQtyPlan

public void setBaseQtyPlan(String baseQtyPlan)
出荷の能力計画のための基本数量を設定します。

パラメータ:
baseQtyPlan - 出荷の能力計画のための基本数量

setShipProcTime

public void setShipProcTime(String shipProcTime)
出荷処理時間を設定します。

パラメータ:
shipProcTime - 出荷処理時間

setSupSource

public void setSupSource(String supSource)
供給元を設定します。

パラメータ:
supSource - 供給元

setAutoPOrd

public void setAutoPOrd(String autoPOrd)
区分: "購買発注自動生成"を設定します。

パラメータ:
autoPOrd - 区分: "購買発注自動生成"

setSourcelist

public void setSourcelist(String sourcelist)
区分: 供給元一覧必須を設定します。

パラメータ:
sourcelist - 区分: 供給元一覧必須

setCommCode

public void setCommCode(String commCode)
貿易: 統計品目コード/輸入コード番号を設定します。

パラメータ:
commCode - 貿易: 統計品目コード/輸入コード番号

setCountryori

public void setCountryori(String countryori)
品目の原産国を設定します。

パラメータ:
countryori - 品目の原産国

setCountryoriIso

public void setCountryoriIso(String countryoriIso)
ISO コードでの品目原産国を設定します。

パラメータ:
countryoriIso - ISO コードでの品目原産国

setRegionorig

public void setRegionorig(String regionorig)
品目の原産地 (非特恵対象地区の原産)を設定します。

パラメータ:
regionorig - 品目の原産地 (非特恵対象地区の原産)

setCommCoUn

public void setCommCoUn(String commCoUn)
物品コード (貿易) の数量単位を設定します。

パラメータ:
commCoUn - 物品コード (貿易) の数量単位

setCommCoUnIso

public void setCommCoUnIso(String commCoUnIso)
ISO コードによる物品コード (貿易管理) の数量単位を設定します。

パラメータ:
commCoUnIso - ISO コードによる物品コード (貿易管理) の数量単位

setExpimpgrp

public void setExpimpgrp(String expimpgrp)
輸出/輸入品目グループを設定します。

パラメータ:
expimpgrp - 輸出/輸入品目グループ

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setPpcPlCal

public void setPpcPlCal(String ppcPlCal)
PPC 計画カレンダを設定します。

パラメータ:
ppcPlCal - PPC 計画カレンダ

setRepManuf

public void setRepManuf(String repManuf)
区分: 繰返生産許可を設定します。

パラメータ:
repManuf - 区分: 繰返生産許可

setPlTiFnce

public void setPlTiFnce(String plTiFnce)
計画タイムフェンスを設定します。

パラメータ:
plTiFnce - 計画タイムフェンス

setConsummode

public void setConsummode(String consummode)
消費モードを設定します。

パラメータ:
consummode - 消費モード

setBwdCons

public void setBwdCons(String bwdCons)
消費期間: 後方を設定します。

パラメータ:
bwdCons - 消費期間: 後方

setFwdCons

public void setFwdCons(String fwdCons)
消費期間: 前方を設定します。

パラメータ:
fwdCons - 消費期間: 前方

setVersionFlag

public void setVersionFlag(String versionFlag)
バージョン区分を設定します。

パラメータ:
versionFlag - バージョン区分

setAlternativeBom

public void setAlternativeBom(String alternativeBom)
代替 BOMを設定します。

パラメータ:
alternativeBom - 代替 BOM

setBomUsage

public void setBomUsage(String bomUsage)
BOM 用途を設定します。

パラメータ:
bomUsage - BOM 用途

setPlanlistgrp

public void setPlanlistgrp(String planlistgrp)
タスクリストグループのキーを設定します。

パラメータ:
planlistgrp - タスクリストグループのキー

setPlanlistcnt

public void setPlanlistcnt(String planlistcnt)
グループカウンタを設定します。

パラメータ:
planlistcnt - グループカウンタ

setLotSize

public void setLotSize(String lotSize)
原価計算ロットサイズを設定します。

パラメータ:
lotSize - 原価計算ロットサイズ

setSpecprocty

public void setSpecprocty(String specprocty)
原価計算の特殊調達タイプを設定します。

パラメータ:
specprocty - 原価計算の特殊調達タイプ

setProdUnit

public void setProdUnit(String prodUnit)
製造単位を設定します。

パラメータ:
prodUnit - 製造単位

setProdUnitIso

public void setProdUnitIso(String prodUnitIso)
製造単位 (ISO コード)を設定します。

パラメータ:
prodUnitIso - 製造単位 (ISO コード)

setIssStLoc

public void setIssStLoc(String issStLoc)
出庫保管場所を設定します。

パラメータ:
issStLoc - 出庫保管場所

setMrpGroup

public void setMrpGroup(String mrpGroup)
MRP グループを設定します。

パラメータ:
mrpGroup - MRP グループ

setCompScrap

public void setCompScrap(String compScrap)
構成品目不良率を設定します。

パラメータ:
compScrap - 構成品目不良率

setCertType

public void setCertType(String certType)
証明書タイプを設定します。

パラメータ:
certType - 証明書タイプ

setCycleTime

public void setCycleTime(String cycleTime)
タクトタイムを設定します。

パラメータ:
cycleTime - タクトタイム

setInspSetupFlag

public void setInspSetupFlag(String inspSetupFlag)
品目/プラントに QM 検査データ設定を設定します。

パラメータ:
inspSetupFlag - 品目/プラントに QM 検査データ設定

setCovprofile

public void setCovprofile(String covprofile)
在庫日数プロファイルを設定します。

パラメータ:
covprofile - 在庫日数プロファイル

setCcPhInv

public void setCcPhInv(String ccPhInv)
循環棚卸の実地棚卸区分を設定します。

パラメータ:
ccPhInv - 循環棚卸の実地棚卸区分

setVarianceKey

public void setVarianceKey(String varianceKey)
差異キーを設定します。

パラメータ:
varianceKey - 差異キー

setSernoProf

public void setSernoProf(String sernoProf)
シリアル番号プロファイルを設定します。

パラメータ:
sernoProf - シリアル番号プロファイル

setPsConfMat

public void setPsConfMat(String psConfMat)
選定可能品目を設定します。

パラメータ:
psConfMat - 選定可能品目

setRepmanprof

public void setRepmanprof(String repmanprof)
繰返生産プロファイルを設定します。

パラメータ:
repmanprof - 繰返生産プロファイル

setNegStocks

public void setNegStocks(String negStocks)
プラントにおけるマイナス在庫許可を設定します。

パラメータ:
negStocks - プラントにおけるマイナス在庫許可

setQmRgmts

public void setQmRgmts(String qmRgmts)
仕入先の必須 QM システムを設定します。

パラメータ:
qmRgmts - 仕入先の必須 QM システム

setPlngCycle

public void setPlngCycle(String plngCycle)
計画サイクルを設定します。

パラメータ:
plngCycle - 計画サイクル

setRoundProf

public void setRoundProf(String roundProf)
丸めプロファイルを設定します。

パラメータ:
roundProf - 丸めプロファイル

setRefmatcons

public void setRefmatcons(String refmatcons)
消費参照品目を設定します。

パラメータ:
refmatcons - 消費参照品目

setRefpltcons

public void setRefpltcons(String refpltcons)
消費参照プラントを設定します。

パラメータ:
refpltcons - 消費参照プラント

setDToRefM

public void setDToRefM(String dToRefM)
消費データ参照の有効終了日を設定します。

パラメータ:
dToRefM - 消費データ参照の有効終了日

setMultRefM

public void setMultRefM(String multRefM)
消費データ参照品目の乗数を設定します。

パラメータ:
multRefM - 消費データ参照品目の乗数

setAutoReset

public void setAutoReset(String autoReset)
予測モデル自動リセットを設定します。

パラメータ:
autoReset - 予測モデル自動リセット

setPrefStatFlag

public void setPrefStatFlag(String prefStatFlag)
区分: 特恵関税 - 輸出/輸入を設定します。

パラメータ:
prefStatFlag - 区分: 特恵関税 - 輸出/輸入

setExCertId

public void setExCertId(String exCertId)
法令管理: 認定書区分を設定します。

パラメータ:
exCertId - 法令管理: 認定書区分

setExCertNoNew

public void setExCertNoNew(String exCertNoNew)
非該当証明書番号 - 法令管理を設定します。

パラメータ:
exCertNoNew - 非該当証明書番号 - 法令管理

setExCertDt

public void setExCertDt(String exCertDt)
非該当証明書発行日を設定します。

パラメータ:
exCertDt - 非該当証明書発行日

setDeclStatFlag

public void setDeclStatFlag(String declStatFlag)
区分: 仕入先申告ありを設定します。

パラメータ:
declStatFlag - 区分: 仕入先申告あり

setMilitId

public void setMilitId(String militId)
ID: 武器を設定します。

パラメータ:
militId - ID: 武器

setInspInt

public void setInspInt(String inspInt)
次回再検査までの間隔を設定します。

パラメータ:
inspInt - 次回再検査までの間隔

setCoProduct

public void setCoProduct(String coProduct)
区分: 連産品としても使用可能な品目を設定します。

パラメータ:
coProduct - 区分: 連産品としても使用可能な品目

setPlanStrgp

public void setPlanStrgp(String planStrgp)
計画方針グループを設定します。

パラメータ:
planStrgp - 計画方針グループ

setSlocExprc

public void setSlocExprc(String slocExprc)
外部調達の初期保管場所を設定します。

パラメータ:
slocExprc - 外部調達の初期保管場所

setBulkMat

public void setBulkMat(String bulkMat)
区分: バルク品目を設定します。

パラメータ:
bulkMat - 区分: バルク品目

setCcFixed

public void setCcFixed(String ccFixed)
循環棚卸区分固定を設定します。

パラメータ:
ccFixed - 循環棚卸区分固定

setDetermGrp

public void setDetermGrp(String determGrp)
在庫決定グループを設定します。

パラメータ:
determGrp - 在庫決定グループ

setQmAuthgrp

public void setQmAuthgrp(String qmAuthgrp)
QM における活動の品目権限グループを設定します。

パラメータ:
qmAuthgrp - QM における活動の品目権限グループ

setTaskListType

public void setTaskListType(String taskListType)
タスクリストタイプを設定します。

パラメータ:
taskListType - タスクリストタイプ

setPurStatus

public void setPurStatus(String purStatus)
プラント特有品目ステータスを設定します。

パラメータ:
purStatus - プラント特有品目ステータス

setProdprof

public void setProdprof(String prodprof)
製造計画プロファイルを設定します。

パラメータ:
prodprof - 製造計画プロファイル

setSaftyTId

public void setSaftyTId(String saftyTId)
安全時間区分（安全リードタイムあり/なし)を設定します。

パラメータ:
saftyTId - 安全時間区分（安全リードタイムあり/なし)

setSafetytime

public void setSafetytime(String safetytime)
安全時間 (稼動日数)を設定します。

パラメータ:
safetytime - 安全時間 (稼動日数)

setPlordCtrl

public void setPlordCtrl(String plordCtrl)
アクション管理: 計画手配処理を設定します。

パラメータ:
plordCtrl - アクション管理: 計画手配処理

setBatchentry

public void setBatchentry(String batchentry)
製造/プロセス指図でのロット入力設定を設定します。

パラメータ:
batchentry - 製造/プロセス指図でのロット入力設定

setPvalidfrom

public void setPvalidfrom(String pvalidfrom)
プラント品目ステータス有効期間開始日を設定します。

パラメータ:
pvalidfrom - プラント品目ステータス有効期間開始日

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
品目運賃グループを設定します。

パラメータ:
matfrgtgrp - 品目運賃グループ

setProdverscs

public void setProdverscs(String prodverscs)
原価計算を行う製造バージョンを設定します。

パラメータ:
prodverscs - 原価計算を行う製造バージョン

setMatCfop

public void setMatCfop(String matCfop)
品目 CFOP カテゴリを設定します。

パラメータ:
matCfop - 品目 CFOP カテゴリ

setEuListNo

public void setEuListNo(String euListNo)
CAP: CAP 製品一覧番号を設定します。

パラメータ:
euListNo - CAP: CAP 製品一覧番号

setEuMatGrp

public void setEuMatGrp(String euMatGrp)
EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。

パラメータ:
euMatGrp - EEC 農産物政策: CAP 生産品グループ - 貿易

setCasNo

public void setCasNo(String casNo)
CAS 番号： 薬事品目 - 貿易を設定します。

パラメータ:
casNo - CAS 番号： 薬事品目 - 貿易

setProdcomNo

public void setProdcomNo(String prodcomNo)
生産統計: 貿易における PRODCOM コードを設定します。

パラメータ:
prodcomNo - 生産統計: 貿易における PRODCOM コード

setCtrlCode

public void setCtrlCode(String ctrlCode)
貿易: 消費税の管理コードを設定します。

パラメータ:
ctrlCode - 貿易: 消費税の管理コード

setJitRelvt

public void setJitRelvt(String jitRelvt)
区分: JIT 納入日程の関連明細を設定します。

パラメータ:
jitRelvt - 区分: JIT 納入日程の関連明細

setMatGrpTrans

public void setMatGrpTrans(String matGrpTrans)
段取替えマトリクスに対する品目のグループを設定します。

パラメータ:
matGrpTrans - 段取替えマトリクスに対する品目のグループ

setHandlgGrp

public void setHandlgGrp(String handlgGrp)
ワークロード計算のロジスティクス処理グループを設定します。

パラメータ:
handlgGrp - ワークロード計算のロジスティクス処理グループ

setSupplyArea

public void setSupplyArea(String supplyArea)
品目マスタレコードで提案される供給場所を設定します。

パラメータ:
supplyArea - 品目マスタレコードで提案される供給場所

setFairShareRule

public void setFairShareRule(String fairShareRule)
均等配賦ルールを設定します。

パラメータ:
fairShareRule - 均等配賦ルール

setPushDistrib

public void setPushDistrib(String pushDistrib)
区分: プッシュ配賦を設定します。

パラメータ:
pushDistrib - 区分: プッシュ配賦

setDeployHoriz

public void setDeployHoriz(String deployHoriz)
供給分配期間の日数を設定します。

パラメータ:
deployHoriz - 供給分配期間の日数

setMinLotSize

public void setMinLotSize(String minLotSize)
需要と供給を一致させるための最小ロットサイズを設定します。

パラメータ:
minLotSize - 需要と供給を一致させるための最小ロットサイズ

setMaxLotSize

public void setMaxLotSize(String maxLotSize)
需要と供給を一致させるための最大ロットサイズを設定します。

パラメータ:
maxLotSize - 需要と供給を一致させるための最大ロットサイズ

setFixLotSize

public void setFixLotSize(String fixLotSize)
需要供給の一致に対する固定ロットサイズを設定します。

パラメータ:
fixLotSize - 需要供給の一致に対する固定ロットサイズ

setLotIncrement

public void setLotIncrement(String lotIncrement)
需要と供給を一致させるためのロットサイズ増分を設定します。

パラメータ:
lotIncrement - 需要と供給を一致させるためのロットサイズ増分

setProdConvType

public void setProdConvType(String prodConvType)
生産値の変換タイプを設定します。

パラメータ:
prodConvType - 生産値の変換タイプ

setDistrProf

public void setDistrProf(String distrProf)
サイトの商品の物流プロファイルを設定します。

パラメータ:
distrProf - サイトの商品の物流プロファイル

setPeriodProfileSafetyTime

public void setPeriodProfileSafetyTime(String periodProfileSafetyTime)
安全時間の期間プロファイルを設定します。

パラメータ:
periodProfileSafetyTime - 安全時間の期間プロファイル

setFxdPrice

public void setFxdPrice(String fxdPrice)
固定価格連産品を設定します。

パラメータ:
fxdPrice - 固定価格連産品

setAvailCheckAllProjSegments

public void setAvailCheckAllProjSegments(String availCheckAllProjSegments)
プロジェクト間品目区分を設定します。

パラメータ:
availCheckAllProjSegments - プロジェクト間品目区分

setOverallprf

public void setOverallprf(String overallprf)
指図変更管理の全体プロファイルを設定します。

パラメータ:
overallprf - 指図変更管理の全体プロファイル

setMrpRelevancyDepRequirements

public void setMrpRelevancyDepRequirements(String mrpRelevancyDepRequirements)
従属所要量と MRP の関連性を設定します。

パラメータ:
mrpRelevancyDepRequirements - 従属所要量と MRP の関連性

setMrpAreaExists

public void setMrpAreaExists(String mrpAreaExists)
区分: MRP エリア登録済を設定します。

パラメータ:
mrpAreaExists - 区分: MRP エリア登録済

setMinSafetyStk

public void setMinSafetyStk(String minSafetyStk)
最小安全在庫を設定します。

パラメータ:
minSafetyStk - 最小安全在庫

setNoCosting

public void setNoCosting(String noCosting)
原価計算なしを設定します。

パラメータ:
noCosting - 原価計算なし

setUnitGroup

public void setUnitGroup(String unitGroup)
数量単位グループを設定します。

パラメータ:
unitGroup - 数量単位グループ

setFollowUpExternal

public void setFollowUpExternal(String followUpExternal)
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
followUpExternal - 項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)

setFollowUpGuid

public void setFollowUpGuid(String followUpGuid)
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
followUpGuid - 項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

setFollowUpVersion

public void setFollowUpVersion(String followUpVersion)
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
followUpVersion - 項目 FOLLOW_UP のバージョン番号 (今後の リリースで開発)

setRefmatconsExternal

public void setRefmatconsExternal(String refmatconsExternal)
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
refmatconsExternal - 項目 REFMATCONS の品目コード (長) (今後の リリースで開発)

setRefmatconsGuid

public void setRefmatconsGuid(String refmatconsGuid)
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
refmatconsGuid - 項目 REFMATCONS の外部 GUID (今後のリリースで開発)

setRefmatconsVersion

public void setRefmatconsVersion(String refmatconsVersion)
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
refmatconsVersion - 項目 REFMATCONS のバージョン番号 (今後の リリースで開発)

setSalesView

public void setSalesView(String salesView)
販売ビューを設定します。

パラメータ:
salesView - 販売ビュー

setPurchView

public void setPurchView(String purchView)
購買管理ビューを設定します。

パラメータ:
purchView - 購買管理ビュー

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setForecastView

public void setForecastView(String forecastView)
需要予測ビューを設定します。

パラメータ:
forecastView - 需要予測ビュー

setWorkSchedView

public void setWorkSchedView(String workSchedView)
作業計画ビューを設定します。

パラメータ:
workSchedView - 作業計画ビュー

setPrtView

public void setPrtView(String prtView)
生産資源/治工具 (PRT) ビューを設定します。

パラメータ:
prtView - 生産資源/治工具 (PRT) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setWarehouseView

public void setWarehouseView(String warehouseView)
倉庫管理ビューを設定します。

パラメータ:
warehouseView - 倉庫管理ビュー

setQualityView

public void setQualityView(String qualityView)
品質管理ビューを設定します。

パラメータ:
qualityView - 品質管理ビュー

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setRotationDate

public void setRotationDate(String rotationDate)
原価計算ビューを設定します。

パラメータ:
rotationDate - 原価計算ビュー

setOriginalBatchFlag

public void setOriginalBatchFlag(String originalBatchFlag)
元ロット管理区分を設定します。

パラメータ:
originalBatchFlag - 元ロット管理区分

setOriginalBatchRefMaterial

public void setOriginalBatchRefMaterial(String originalBatchRefMaterial)
元ロットの参照品目を設定します。

パラメータ:
originalBatchRefMaterial - 元ロットの参照品目

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス PlantDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList
すべての実装インタフェース:
Serializable
public class PlantDataList
extends PlantData
implements Serializable

品目データ (プラントレベル)情報クラス
機能は以下の通り

  • 品目データ (プラントレベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantDataList()
品目データ (プラントレベル)情報を作成します。
PlantDataList(int index)
品目データ (プラントレベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData から継承したメソッド
getAbcId, getAccountView, getAltBomId, getAlternativeBom, getAssyScrap, getAutoPOrd, getAutoReset, getAvailcheck, getAvailCheckAllProjSegments, getBackflush, getBaseQty, getBaseQtyPlan, getBatchentry, getBatchMgmt, getBomUsage, getBulkMat, getBwdCons, getCasNo, getCcFixed, getCcPhInv, getCertType, getCommCode, getCommCoUn, getCommCoUnIso, getCompScrap, getConsummode, getCoProduct, getCorrFact, getCostView, getCountryori, getCountryoriIso, getCovprofile, getCritPart, getCtrlCode, getCtrlKey, getCycleTime, getDeclStatFlag, getDelFlag, getDeployHoriz, getDepReqId, getDetermGrp, getDiscontinu, getDistrProf, getDocReqd, getDToRefM, getEffODay, getEuListNo, getEuMatGrp, getExCertDt, getExCertId, getExCertNoNew, getExpimpgrp, getFairShareRule, getFixedLot, getFixLotSize, getFollowUp, getFollowUpExternal, getFollowUpGuid, getFollowUpVersion, getForecastView, getFunction, getFwdCons, getFxdPrice, getFyVariant, getGrpReqmts, getGrPrTime, getHandlgGrp, getIndPostToInspStock, getInhseprodt, getInspInt, getInspSetupFlag, getInterop, getIssStLoc, getIssueUnit, getIssueUnitIso, getJitRelvt, getLoadinggrp, getLotIncrement, getLotSize, getLotsizekey, getMaintStat, getMatCfop, getMaterial, getMatfrgtgrp, getMatGrpTrans, getMaxlotsize, getMaxLotSize, getMaxStock, getMilitId, getMinlotsize, getMinLotSize, getMinSafetyStk, getMixedMrp, getMrpAreaExists, getMrpCtrler, getMrpGroup, getMrpprofile, getMrpRelevancyDepRequirements, getMrpType, getMrpView, getMultRefM, getNegStocks, getNoCosting, getOrdCosts, getOriginalBatchFlag, getOriginalBatchRefMaterial, getOverallprf, getOverTol, getPeriodInd, getPeriodProfileSafetyTime, getPlanlistcnt, getPlanlistgrp, getPlanStrgp, getPlant, getPlndDelry, getPlngCycle, getPlordCtrl, getPlTiFnce, getPpcPlCal, getPrefStatFlag, getProcTime, getProcType, getProdcomNo, getProdConvType, getProdprof, getProductionScheduler, getProdUnit, getProdUnitIso, getProdverscs, getProfitCtr, getPrtView, getPsConfMat, getPurchView, getPurGroup, getPurStatus, getPushDistrib, getPvalidfrom, getQmAuthgrp, getQmRgmts, getQualityView, getQuotausage, getRefmatcons, getRefmatconsExternal, getRefmatconsGuid, getRefmatconsVersion, getRefpltcons, getRegionorig, getReorderPt, getReplacePt, getReplentime, getRepmanprof, getRepManuf, getRotationDate, getRoundProf, getRoundVal, getSafetyStk, getSafetytime, getSaftyTId, getSalesView, getSernoProf, getServLevel, getSetuptime, getSetupTime, getShipProcTime, getSlocExprc, getSmKey, getSourcelist, getSpecprocty, getSplitInd, getSpproctype, getStgePdUn, getStgePdUnIso, getStgeperiod, getStorageView, getStorCosts, getSupplyArea, getSupSource, getTaskListType, getUnderTol, getUnitGroup, getUnlimited, getVarianceKey, getVersionFlag, getWarehouseView, getWorkSchedView, setAbcId, setAccountView, setAltBomId, setAlternativeBom, setAssyScrap, setAutoPOrd, setAutoReset, setAvailcheck, setAvailCheckAllProjSegments, setBackflush, setBaseQty, setBaseQtyPlan, setBatchentry, setBatchMgmt, setBomUsage, setBulkMat, setBwdCons, setCasNo, setCcFixed, setCcPhInv, setCertType, setCommCode, setCommCoUn, setCommCoUnIso, setCompScrap, setConsummode, setCoProduct, setCorrFact, setCostView, setCountryori, setCountryoriIso, setCovprofile, setCritPart, setCtrlCode, setCtrlKey, setCycleTime, setDeclStatFlag, setDelFlag, setDeployHoriz, setDepReqId, setDetermGrp, setDiscontinu, setDistrProf, setDocReqd, setDToRefM, setEffODay, setEuListNo, setEuMatGrp, setExCertDt, setExCertId, setExCertNoNew, setExpimpgrp, setFairShareRule, setFixedLot, setFixLotSize, setFollowUp, setFollowUpExternal, setFollowUpGuid, setFollowUpVersion, setForecastView, setFunction, setFwdCons, setFxdPrice, setFyVariant, setGrpReqmts, setGrPrTime, setHandlgGrp, setIndPostToInspStock, setInhseprodt, setInspInt, setInspSetupFlag, setInterop, setIssStLoc, setIssueUnit, setIssueUnitIso, setJitRelvt, setLoadinggrp, setLotIncrement, setLotSize, setLotsizekey, setMaintStat, setMatCfop, setMaterial, setMatfrgtgrp, setMatGrpTrans, setMaxlotsize, setMaxLotSize, setMaxStock, setMilitId, setMinlotsize, setMinLotSize, setMinSafetyStk, setMixedMrp, setMrpAreaExists, setMrpCtrler, setMrpGroup, setMrpprofile, setMrpRelevancyDepRequirements, setMrpType, setMrpView, setMultRefM, setNegStocks, setNoCosting, setOrdCosts, setOriginalBatchFlag, setOriginalBatchRefMaterial, setOverallprf, setOverTol, setPeriodInd, setPeriodProfileSafetyTime, setPlanlistcnt, setPlanlistgrp, setPlanStrgp, setPlant, setPlndDelry, setPlngCycle, setPlordCtrl, setPlTiFnce, setPpcPlCal, setPrefStatFlag, setProcTime, setProcType, setProdcomNo, setProdConvType, setProdprof, setProductionScheduler, setProdUnit, setProdUnitIso, setProdverscs, setProfitCtr, setPrtView, setPsConfMat, setPurchView, setPurGroup, setPurStatus, setPushDistrib, setPvalidfrom, setQmAuthgrp, setQmRgmts, setQualityView, setQuotausage, setRefmatcons, setRefmatconsExternal, setRefmatconsGuid, setRefmatconsVersion, setRefpltcons, setRegionorig, setReorderPt, setReplacePt, setReplentime, setRepmanprof, setRepManuf, setRotationDate, setRoundProf, setRoundVal, setSafetyStk, setSafetytime, setSaftyTId, setSalesView, setSernoProf, setServLevel, setSetuptime, setSetupTime, setShipProcTime, setSlocExprc, setSmKey, setSourcelist, setSpecprocty, setSplitInd, setSpproctype, setStgePdUn, setStgePdUnIso, setStgeperiod, setStorageView, setStorCosts, setSupplyArea, setSupSource, setTaskListType, setUnderTol, setUnitGroup, setUnlimited, setVarianceKey, setVersionFlag, setWarehouseView, setWorkSchedView, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantDataList

public PlantDataList()
品目データ (プラントレベル)情報を作成します。

PlantDataList

public PlantDataList(int index)
品目データ (プラントレベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス SalesData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesDataList
public class SalesData
extends Object
implements Serializable

販売データ情報クラス
機能は以下の通り

  • 販売データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesData()
販売データ情報を作成します。
メソッドの概要
String | getAcctAssgt() 品目の勘定設定グループを取得します。
String | getCashDisc() 現金値引区分を取得します。
String | getCommGroup() 手数料グループを取得します。
String | getDelFlag() 区分: 流通チャネルレベルでの品目削除フラグを取得します。
String | getDelygPlnt() 出荷プラントを取得します。
String | getDelyUnit() 出荷単位を取得します。
String | getDelyUom() 出荷数量単位を取得します。
String | getDelyUomIso() ISO コードでの出荷単位の数量単位を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getFunction() BAPI 機能を取得します。
String | getItemCat() 品目マスタの明細カテゴリグループを取得します。
String | getMaterial() 品目コードを取得します。
String | getMatlGrp1() 品目グループ 1を取得します。
String | getMatlGrp2() 品目グループ 2を取得します。
String | getMatlGrp3() 品目グループ 3を取得します。
String | getMatlGrp4() 品目グループ 4を取得します。
String | getMatlGrp5() 品目グループ 5を取得します。
String | getMatlStats() 品目統計グループを取得します。
String | getMatPrGrp() 品目価格設定グループを取得します。
String | getMinDely() 納品書処理時の最小納入数量を取得します。
String | getMinMto() 受注製造品最少受注数量を取得します。
String | getMinOrder() 基本数量単位での最小受注数量を取得します。
String | getProdAtt1() ID: 製品属性 1を取得します。
String | getProdAtt10() 品目属性 10 用 IDを取得します。
String | getProdAtt2() 品目属性 2 用 IDを取得します。
String | getProdAtt3() 品目属性 3 用 IDを取得します。
String | getProdAtt4() 品目属性 4 用 IDを取得します。
String | getProdAtt5() 品目属性 5 用 IDを取得します。
String | getProdAtt6() 品目属性 6 の IDを取得します。
String | getProdAtt7() 品目属性 7 用 IDを取得します。
String | getProdAtt8() 品目属性 8 用 IDを取得します。
String | getProdAtt9() 品目属性 9を取得します。
String | getProdHier() 品目階層を取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPrRefMatExternal() 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPrRefMatGuid() 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPrRefMatVersion() 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getRebateGrp() 取引量リベートグループを取得します。
String | getRoundProf() 丸めプロファイルを取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSalesUnitIso() ISO コードによる販売単位を取得します。
String | getSalStatus() 販売ビューからの品目ステータスを取得します。
String | getUnitGroup() 数量単位グループを取得します。
String | getValidFrom() 流通チェーン別品目ステータスの有効期間開始日を取得します。
String | getVarSalesUn() 可変販売単位の使用不可を取得します。
void | setAcctAssgt(String acctAssgt) 品目の勘定設定グループを設定します。
void | setCashDisc(String cashDisc) 現金値引区分を設定します。
void | setCommGroup(String commGroup) 手数料グループを設定します。
void | setDelFlag(String delFlag) 区分: 流通チャネルレベルでの品目削除フラグを設定します。
void | setDelygPlnt(String delygPlnt) 出荷プラントを設定します。
void | setDelyUnit(String delyUnit) 出荷単位を設定します。
void | setDelyUom(String delyUom) 出荷数量単位を設定します。
void | setDelyUomIso(String delyUomIso) ISO コードでの出荷単位の数量単位を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setItemCat(String itemCat) 品目マスタの明細カテゴリグループを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatlGrp1(String matlGrp1) 品目グループ 1を設定します。
void | setMatlGrp2(String matlGrp2) 品目グループ 2を設定します。
void | setMatlGrp3(String matlGrp3) 品目グループ 3を設定します。
void | setMatlGrp4(String matlGrp4) 品目グループ 4を設定します。
void | setMatlGrp5(String matlGrp5) 品目グループ 5を設定します。
void | setMatlStats(String matlStats) 品目統計グループを設定します。
void | setMatPrGrp(String matPrGrp) 品目価格設定グループを設定します。
void | setMinDely(String minDely) 納品書処理時の最小納入数量を設定します。
void | setMinMto(String minMto) 受注製造品最少受注数量を設定します。
void | setMinOrder(String minOrder) 基本数量単位での最小受注数量を設定します。
void | setProdAtt1(String prodAtt1) ID: 製品属性 1を設定します。
void | setProdAtt10(String prodAtt10) 品目属性 10 用 IDを設定します。
void | setProdAtt2(String prodAtt2) 品目属性 2 用 IDを設定します。
void | setProdAtt3(String prodAtt3) 品目属性 3 用 IDを設定します。
void | setProdAtt4(String prodAtt4) 品目属性 4 用 IDを設定します。
void | setProdAtt5(String prodAtt5) 品目属性 5 用 IDを設定します。
void | setProdAtt6(String prodAtt6) 品目属性 6 の IDを設定します。
void | setProdAtt7(String prodAtt7) 品目属性 7 用 IDを設定します。
void | setProdAtt8(String prodAtt8) 品目属性 8 用 IDを設定します。
void | setProdAtt9(String prodAtt9) 品目属性 9を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPrRefMatExternal(String prRefMatExternal) 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPrRefMatGuid(String prRefMatGuid) 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPrRefMatVersion(String prRefMatVersion) 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setRebateGrp(String rebateGrp) 取引量リベートグループを設定します。
void | setRoundProf(String roundProf) 丸めプロファイルを設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSalesUnitIso(String salesUnitIso) ISO コードによる販売単位を設定します。
void | setSalStatus(String salStatus) 販売ビューからの品目ステータスを設定します。
void | setUnitGroup(String unitGroup) 数量単位グループを設定します。
void | setValidFrom(String validFrom) 流通チェーン別品目ステータスの有効期間開始日を設定します。
void | setVarSalesUn(String varSalesUn) 可変販売単位の使用不可を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesData

public SalesData()
販売データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDelFlag

public String getDelFlag()
区分: 流通チャネルレベルでの品目削除フラグを取得します。

戻り値:
delFlag 区分: 流通チャネルレベルでの品目削除フラグ

getMatlStats

public String getMatlStats()
品目統計グループを取得します。

戻り値:
matlStats 品目統計グループ

getRebateGrp

public String getRebateGrp()
取引量リベートグループを取得します。

戻り値:
rebateGrp 取引量リベートグループ

getCommGroup

public String getCommGroup()
手数料グループを取得します。

戻り値:
commGroup 手数料グループ

getCashDisc

public String getCashDisc()
現金値引区分を取得します。

戻り値:
cashDisc 現金値引区分

getSalStatus

public String getSalStatus()
販売ビューからの品目ステータスを取得します。

戻り値:
salStatus 販売ビューからの品目ステータス

getValidFrom

public String getValidFrom()
流通チェーン別品目ステータスの有効期間開始日を取得します。

戻り値:
validFrom 流通チェーン別品目ステータスの有効期間開始日

getMinOrder

public String getMinOrder()
基本数量単位での最小受注数量を取得します。

戻り値:
minOrder 基本数量単位での最小受注数量

getMinDely

public String getMinDely()
納品書処理時の最小納入数量を取得します。

戻り値:
minDely 納品書処理時の最小納入数量

getMinMto

public String getMinMto()
受注製造品最少受注数量を取得します。

戻り値:
minMto 受注製造品最少受注数量

getDelyUnit

public String getDelyUnit()
出荷単位を取得します。

戻り値:
delyUnit 出荷単位

getDelyUom

public String getDelyUom()
出荷数量単位を取得します。

戻り値:
delyUom 出荷数量単位

getDelyUomIso

public String getDelyUomIso()
ISO コードでの出荷単位の数量単位を取得します。

戻り値:
delyUomIso ISO コードでの出荷単位の数量単位

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getSalesUnitIso

public String getSalesUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
salesUnitIso ISO コードによる販売単位

getItemCat

public String getItemCat()
品目マスタの明細カテゴリグループを取得します。

戻り値:
itemCat 品目マスタの明細カテゴリグループ

getDelygPlnt

public String getDelygPlnt()
出荷プラントを取得します。

戻り値:
delygPlnt 出荷プラント

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getMatPrGrp

public String getMatPrGrp()
品目価格設定グループを取得します。

戻り値:
matPrGrp 品目価格設定グループ

getAcctAssgt

public String getAcctAssgt()
品目の勘定設定グループを取得します。

戻り値:
acctAssgt 品目の勘定設定グループ

getMatlGrp1

public String getMatlGrp1()
品目グループ 1を取得します。

戻り値:
matlGrp1 品目グループ 1

getMatlGrp2

public String getMatlGrp2()
品目グループ 2を取得します。

戻り値:
matlGrp2 品目グループ 2

getMatlGrp3

public String getMatlGrp3()
品目グループ 3を取得します。

戻り値:
matlGrp3 品目グループ 3

getMatlGrp4

public String getMatlGrp4()
品目グループ 4を取得します。

戻り値:
matlGrp4 品目グループ 4

getMatlGrp5

public String getMatlGrp5()
品目グループ 5を取得します。

戻り値:
matlGrp5 品目グループ 5

getProdAtt1

public String getProdAtt1()
ID: 製品属性 1を取得します。

戻り値:
prodAtt1 ID: 製品属性 1

getProdAtt2

public String getProdAtt2()
品目属性 2 用 IDを取得します。

戻り値:
prodAtt2 品目属性 2 用 ID

getProdAtt3

public String getProdAtt3()
品目属性 3 用 IDを取得します。

戻り値:
prodAtt3 品目属性 3 用 ID

getProdAtt4

public String getProdAtt4()
品目属性 4 用 IDを取得します。

戻り値:
prodAtt4 品目属性 4 用 ID

getProdAtt5

public String getProdAtt5()
品目属性 5 用 IDを取得します。

戻り値:
prodAtt5 品目属性 5 用 ID

getProdAtt6

public String getProdAtt6()
品目属性 6 の IDを取得します。

戻り値:
prodAtt6 品目属性 6 の ID

getProdAtt7

public String getProdAtt7()
品目属性 7 用 IDを取得します。

戻り値:
prodAtt7 品目属性 7 用 ID

getProdAtt8

public String getProdAtt8()
品目属性 8 用 IDを取得します。

戻り値:
prodAtt8 品目属性 8 用 ID

getProdAtt9

public String getProdAtt9()
品目属性 9を取得します。

戻り値:
prodAtt9 品目属性 9

getProdAtt10

public String getProdAtt10()
品目属性 10 用 IDを取得します。

戻り値:
prodAtt10 品目属性 10 用 ID

getRoundProf

public String getRoundProf()
丸めプロファイルを取得します。

戻り値:
roundProf 丸めプロファイル

getVarSalesUn

public String getVarSalesUn()
可変販売単位の使用不可を取得します。

戻り値:
varSalesUn 可変販売単位の使用不可

getUnitGroup

public String getUnitGroup()
数量単位グループを取得します。

戻り値:
unitGroup 数量単位グループ

getPrRefMatExternal

public String getPrRefMatExternal()
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
prRefMatExternal 項目 PR_REF_MAT の品目コード (長) (今後の リリースで開発)

getPrRefMatGuid

public String getPrRefMatGuid()
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
prRefMatGuid 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

getPrRefMatVersion

public String getPrRefMatVersion()
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
prRefMatVersion 項目 PR_REF_MAT のバージョン番号 (今後の リリースで開発)

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDelFlag

public void setDelFlag(String delFlag)
区分: 流通チャネルレベルでの品目削除フラグを設定します。

パラメータ:
delFlag - 区分: 流通チャネルレベルでの品目削除フラグ

setMatlStats

public void setMatlStats(String matlStats)
品目統計グループを設定します。

パラメータ:
matlStats - 品目統計グループ

setRebateGrp

public void setRebateGrp(String rebateGrp)
取引量リベートグループを設定します。

パラメータ:
rebateGrp - 取引量リベートグループ

setCommGroup

public void setCommGroup(String commGroup)
手数料グループを設定します。

パラメータ:
commGroup - 手数料グループ

setCashDisc

public void setCashDisc(String cashDisc)
現金値引区分を設定します。

パラメータ:
cashDisc - 現金値引区分

setSalStatus

public void setSalStatus(String salStatus)
販売ビューからの品目ステータスを設定します。

パラメータ:
salStatus - 販売ビューからの品目ステータス

setValidFrom

public void setValidFrom(String validFrom)
流通チェーン別品目ステータスの有効期間開始日を設定します。

パラメータ:
validFrom - 流通チェーン別品目ステータスの有効期間開始日

setMinOrder

public void setMinOrder(String minOrder)
基本数量単位での最小受注数量を設定します。

パラメータ:
minOrder - 基本数量単位での最小受注数量

setMinDely

public void setMinDely(String minDely)
納品書処理時の最小納入数量を設定します。

パラメータ:
minDely - 納品書処理時の最小納入数量

setMinMto

public void setMinMto(String minMto)
受注製造品最少受注数量を設定します。

パラメータ:
minMto - 受注製造品最少受注数量

setDelyUnit

public void setDelyUnit(String delyUnit)
出荷単位を設定します。

パラメータ:
delyUnit - 出荷単位

setDelyUom

public void setDelyUom(String delyUom)
出荷数量単位を設定します。

パラメータ:
delyUom - 出荷数量単位

setDelyUomIso

public void setDelyUomIso(String delyUomIso)
ISO コードでの出荷単位の数量単位を設定します。

パラメータ:
delyUomIso - ISO コードでの出荷単位の数量単位

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setSalesUnitIso

public void setSalesUnitIso(String salesUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
salesUnitIso - ISO コードによる販売単位

setItemCat

public void setItemCat(String itemCat)
品目マスタの明細カテゴリグループを設定します。

パラメータ:
itemCat - 品目マスタの明細カテゴリグループ

setDelygPlnt

public void setDelygPlnt(String delygPlnt)
出荷プラントを設定します。

パラメータ:
delygPlnt - 出荷プラント

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
品目価格設定グループを設定します。

パラメータ:
matPrGrp - 品目価格設定グループ

setAcctAssgt

public void setAcctAssgt(String acctAssgt)
品目の勘定設定グループを設定します。

パラメータ:
acctAssgt - 品目の勘定設定グループ

setMatlGrp1

public void setMatlGrp1(String matlGrp1)
品目グループ 1を設定します。

パラメータ:
matlGrp1 - 品目グループ 1

setMatlGrp2

public void setMatlGrp2(String matlGrp2)
品目グループ 2を設定します。

パラメータ:
matlGrp2 - 品目グループ 2

setMatlGrp3

public void setMatlGrp3(String matlGrp3)
品目グループ 3を設定します。

パラメータ:
matlGrp3 - 品目グループ 3

setMatlGrp4

public void setMatlGrp4(String matlGrp4)
品目グループ 4を設定します。

パラメータ:
matlGrp4 - 品目グループ 4

setMatlGrp5

public void setMatlGrp5(String matlGrp5)
品目グループ 5を設定します。

パラメータ:
matlGrp5 - 品目グループ 5

setProdAtt1

public void setProdAtt1(String prodAtt1)
ID: 製品属性 1を設定します。

パラメータ:
prodAtt1 - ID: 製品属性 1

setProdAtt2

public void setProdAtt2(String prodAtt2)
品目属性 2 用 IDを設定します。

パラメータ:
prodAtt2 - 品目属性 2 用 ID

setProdAtt3

public void setProdAtt3(String prodAtt3)
品目属性 3 用 IDを設定します。

パラメータ:
prodAtt3 - 品目属性 3 用 ID

setProdAtt4

public void setProdAtt4(String prodAtt4)
品目属性 4 用 IDを設定します。

パラメータ:
prodAtt4 - 品目属性 4 用 ID

setProdAtt5

public void setProdAtt5(String prodAtt5)
品目属性 5 用 IDを設定します。

パラメータ:
prodAtt5 - 品目属性 5 用 ID

setProdAtt6

public void setProdAtt6(String prodAtt6)
品目属性 6 の IDを設定します。

パラメータ:
prodAtt6 - 品目属性 6 の ID

setProdAtt7

public void setProdAtt7(String prodAtt7)
品目属性 7 用 IDを設定します。

パラメータ:
prodAtt7 - 品目属性 7 用 ID

setProdAtt8

public void setProdAtt8(String prodAtt8)
品目属性 8 用 IDを設定します。

パラメータ:
prodAtt8 - 品目属性 8 用 ID

setProdAtt9

public void setProdAtt9(String prodAtt9)
品目属性 9を設定します。

パラメータ:
prodAtt9 - 品目属性 9

setProdAtt10

public void setProdAtt10(String prodAtt10)
品目属性 10 用 IDを設定します。

パラメータ:
prodAtt10 - 品目属性 10 用 ID

setRoundProf

public void setRoundProf(String roundProf)
丸めプロファイルを設定します。

パラメータ:
roundProf - 丸めプロファイル

setVarSalesUn

public void setVarSalesUn(String varSalesUn)
可変販売単位の使用不可を設定します。

パラメータ:
varSalesUn - 可変販売単位の使用不可

setUnitGroup

public void setUnitGroup(String unitGroup)
数量単位グループを設定します。

パラメータ:
unitGroup - 数量単位グループ

setPrRefMatExternal

public void setPrRefMatExternal(String prRefMatExternal)
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
prRefMatExternal - 項目 PR_REF_MAT の品目コード (長) (今後の リリースで開発)

setPrRefMatGuid

public void setPrRefMatGuid(String prRefMatGuid)
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
prRefMatGuid - 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

setPrRefMatVersion

public void setPrRefMatVersion(String prRefMatVersion)
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
prRefMatVersion - 項目 PR_REF_MAT のバージョン番号 (今後の リリースで開発)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス SalesDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList
すべての実装インタフェース:
Serializable
public class SalesDataList
extends SalesData
implements Serializable

販売データ情報クラス
機能は以下の通り

  • 販売データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesDataList()
販売データ情報を作成します。
SalesDataList(int index)
販売データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData から継承したメソッド
getAcctAssgt, getCashDisc, getCommGroup, getDelFlag, getDelygPlnt, getDelyUnit, getDelyUom, getDelyUomIso, getDistrChan, getFunction, getItemCat, getMaterial, getMatlGrp1, getMatlGrp2, getMatlGrp3, getMatlGrp4, getMatlGrp5, getMatlStats, getMatPrGrp, getMinDely, getMinMto, getMinOrder, getProdAtt1, getProdAtt10, getProdAtt2, getProdAtt3, getProdAtt4, getProdAtt5, getProdAtt6, getProdAtt7, getProdAtt8, getProdAtt9, getProdHier, getPrRefMat, getPrRefMatExternal, getPrRefMatGuid, getPrRefMatVersion, getRebateGrp, getRoundProf, getSalesOrg, getSalesUnit, getSalesUnitIso, getSalStatus, getUnitGroup, getValidFrom, getVarSalesUn, setAcctAssgt, setCashDisc, setCommGroup, setDelFlag, setDelygPlnt, setDelyUnit, setDelyUom, setDelyUomIso, setDistrChan, setFunction, setItemCat, setMaterial, setMatlGrp1, setMatlGrp2, setMatlGrp3, setMatlGrp4, setMatlGrp5, setMatlStats, setMatPrGrp, setMinDely, setMinMto, setMinOrder, setProdAtt1, setProdAtt10, setProdAtt2, setProdAtt3, setProdAtt4, setProdAtt5, setProdAtt6, setProdAtt7, setProdAtt8, setProdAtt9, setProdHier, setPrRefMat, setPrRefMatExternal, setPrRefMatGuid, setPrRefMatVersion, setRebateGrp, setRoundProf, setSalesOrg, setSalesUnit, setSalesUnitIso, setSalStatus, setUnitGroup, setValidFrom, setVarSalesUn, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesDataList

public SalesDataList()
販売データ情報を作成します。

SalesDataList

public SalesDataList(int index)
販売データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageLocationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
StorageLocationDataList
public class StorageLocationData
extends Object
implements Serializable

品目データ (保管場所レベル)情報クラス
機能は以下の通り

  • 品目データ (保管場所レベル)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationData()
品目データ (保管場所レベル)情報を作成します。
メソッドの概要
String | getCurrPeriod() 当期 (転記期間)を取得します。
String | getDelFlag() 保管場所レベルでの品目削除フラグを取得します。
String | getFiscYear() 当会計年度を取得します。
String | getFunction() BAPI 機能を取得します。
String | getInvCorrFac() 在庫修正係数を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMaterial() 品目コードを取得します。
String | getMrpInd() 保管場所 MRP 区分を取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getPickgArea() 簡易倉庫管理のピッキングエリアを取得します。
String | getPlant() プラントを取得します。
String | getReorderPt() 保管場所 MRP に対する発注点を取得します。
String | getReplQty() 保管場所 MRP に対する補充数量を取得します。
String | getSpecProc() 保管場所レベルでの特殊調達タイプを取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStorageView() 保管ビューを取得します。
void | setCurrPeriod(String currPeriod) 当期 (転記期間)を設定します。
void | setDelFlag(String delFlag) 保管場所レベルでの品目削除フラグを設定します。
void | setFiscYear(String fiscYear) 当会計年度を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setInvCorrFac(String invCorrFac) 在庫修正係数を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMrpInd(String mrpInd) 保管場所 MRP 区分を設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setPickgArea(String pickgArea) 簡易倉庫管理のピッキングエリアを設定します。
void | setPlant(String plant) プラントを設定します。
void | setReorderPt(String reorderPt) 保管場所 MRP に対する発注点を設定します。
void | setReplQty(String replQty) 保管場所 MRP に対する補充数量を設定します。
void | setSpecProc(String specProc) 保管場所レベルでの特殊調達タイプを設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationData

public StorageLocationData()
品目データ (保管場所レベル)情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
保管場所レベルでの品目削除フラグを取得します。

戻り値:
delFlag 保管場所レベルでの品目削除フラグ

getFiscYear

public String getFiscYear()
当会計年度を取得します。

戻り値:
fiscYear 当会計年度

getCurrPeriod

public String getCurrPeriod()
当期 (転記期間)を取得します。

戻り値:
currPeriod 当期 (転記期間)

getMrpInd

public String getMrpInd()
保管場所 MRP 区分を取得します。

戻り値:
mrpInd 保管場所 MRP 区分

getSpecProc

public String getSpecProc()
保管場所レベルでの特殊調達タイプを取得します。

戻り値:
specProc 保管場所レベルでの特殊調達タイプ

getReorderPt

public String getReorderPt()
保管場所 MRP に対する発注点を取得します。

戻り値:
reorderPt 保管場所 MRP に対する発注点

getReplQty

public String getReplQty()
保管場所 MRP に対する補充数量を取得します。

戻り値:
replQty 保管場所 MRP に対する補充数量

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getPickgArea

public String getPickgArea()
簡易倉庫管理のピッキングエリアを取得します。

戻り値:
pickgArea 簡易倉庫管理のピッキングエリア

getInvCorrFac

public String getInvCorrFac()
在庫修正係数を取得します。

戻り値:
invCorrFac 在庫修正係数

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
保管場所レベルでの品目削除フラグを設定します。

パラメータ:
delFlag - 保管場所レベルでの品目削除フラグ

setFiscYear

public void setFiscYear(String fiscYear)
当会計年度を設定します。

パラメータ:
fiscYear - 当会計年度

setCurrPeriod

public void setCurrPeriod(String currPeriod)
当期 (転記期間)を設定します。

パラメータ:
currPeriod - 当期 (転記期間)

setMrpInd

public void setMrpInd(String mrpInd)
保管場所 MRP 区分を設定します。

パラメータ:
mrpInd - 保管場所 MRP 区分

setSpecProc

public void setSpecProc(String specProc)
保管場所レベルでの特殊調達タイプを設定します。

パラメータ:
specProc - 保管場所レベルでの特殊調達タイプ

setReorderPt

public void setReorderPt(String reorderPt)
保管場所 MRP に対する発注点を設定します。

パラメータ:
reorderPt - 保管場所 MRP に対する発注点

setReplQty

public void setReplQty(String replQty)
保管場所 MRP に対する補充数量を設定します。

パラメータ:
replQty - 保管場所 MRP に対する補充数量

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setPickgArea

public void setPickgArea(String pickgArea)
簡易倉庫管理のピッキングエリアを設定します。

パラメータ:
pickgArea - 簡易倉庫管理のピッキングエリア

setInvCorrFac

public void setInvCorrFac(String invCorrFac)
在庫修正係数を設定します。

パラメータ:
invCorrFac - 在庫修正係数

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageLocationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList
すべての実装インタフェース:
Serializable
public class StorageLocationDataList
extends StorageLocationData
implements Serializable

品目データ (保管場所レベル)情報クラス
機能は以下の通り

  • 品目データ (保管場所レベル)情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationDataList()
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList(int index)
品目データ (保管場所レベル)情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData から継承したメソッド
getCurrPeriod, getDelFlag, getFiscYear, getFunction, getInvCorrFac, getMaintStat, getMaterial, getMrpInd, getMrpView, getPickgArea, getPlant, getReorderPt, getReplQty, getSpecProc, getStgeBin, getStgeLoc, getStorageView, setCurrPeriod, setDelFlag, setFiscYear, setFunction, setInvCorrFac, setMaintStat, setMaterial, setMrpInd, setMrpView, setPickgArea, setPlant, setReorderPt, setReplQty, setSpecProc, setStgeBin, setStgeLoc, setStorageView, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationDataList

public StorageLocationDataList()
品目データ (保管場所レベル)情報を作成します。

StorageLocationDataList

public StorageLocationDataList(int index)
品目データ (保管場所レベル)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageTypeData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageTypeData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
StorageTypeDataList
public class StorageTypeData
extends Object
implements Serializable

保管域タイプデータ情報クラス
機能は以下の通り

  • 保管域タイプデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageTypeData()
保管域タイプデータ情報を作成します。
メソッドの概要
String | getCtrlQty() 管理数量を取得します。
String | getDelFlag() 保管タイプに該当する全品目データ削除フラグを取得します。
String | getFunction() BAPI 機能を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaxSbQty() 最大棚番在庫数量を取得します。
String | getMinSbQty() 最小棚番在庫数量を取得します。
String | getPickArea() ピッキングエリアを取得します。
String | getReplenQty() 補充数量を取得します。
String | getRoundQty() 丸め数量を取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeType() 保管域タイプを取得します。
String | getWhseNo() 倉庫番号/複合倉庫を取得します。
void | setCtrlQty(String ctrlQty) 管理数量を設定します。
void | setDelFlag(String delFlag) 保管タイプに該当する全品目データ削除フラグを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaxSbQty(String maxSbQty) 最大棚番在庫数量を設定します。
void | setMinSbQty(String minSbQty) 最小棚番在庫数量を設定します。
void | setPickArea(String pickArea) ピッキングエリアを設定します。
void | setReplenQty(String replenQty) 補充数量を設定します。
void | setRoundQty(String roundQty) 丸め数量を設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeType(String stgeType) 保管域タイプを設定します。
void | setWhseNo(String whseNo) 倉庫番号/複合倉庫を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageTypeData

public StorageTypeData()
保管域タイプデータ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getWhseNo

public String getWhseNo()
倉庫番号/複合倉庫を取得します。

戻り値:
whseNo 倉庫番号/複合倉庫

getStgeType

public String getStgeType()
保管域タイプを取得します。

戻り値:
stgeType 保管域タイプ

getDelFlag

public String getDelFlag()
保管タイプに該当する全品目データ削除フラグを取得します。

戻り値:
delFlag 保管タイプに該当する全品目データ削除フラグ

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getMaxSbQty

public String getMaxSbQty()
最大棚番在庫数量を取得します。

戻り値:
maxSbQty 最大棚番在庫数量

getMinSbQty

public String getMinSbQty()
最小棚番在庫数量を取得します。

戻り値:
minSbQty 最小棚番在庫数量

getCtrlQty

public String getCtrlQty()
管理数量を取得します。

戻り値:
ctrlQty 管理数量

getReplenQty

public String getReplenQty()
補充数量を取得します。

戻り値:
replenQty 補充数量

getPickArea

public String getPickArea()
ピッキングエリアを取得します。

戻り値:
pickArea ピッキングエリア

getRoundQty

public String getRoundQty()
丸め数量を取得します。

戻り値:
roundQty 丸め数量

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setWhseNo

public void setWhseNo(String whseNo)
倉庫番号/複合倉庫を設定します。

パラメータ:
whseNo - 倉庫番号/複合倉庫

setStgeType

public void setStgeType(String stgeType)
保管域タイプを設定します。

パラメータ:
stgeType - 保管域タイプ

setDelFlag

public void setDelFlag(String delFlag)
保管タイプに該当する全品目データ削除フラグを設定します。

パラメータ:
delFlag - 保管タイプに該当する全品目データ削除フラグ

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setMaxSbQty

public void setMaxSbQty(String maxSbQty)
最大棚番在庫数量を設定します。

パラメータ:
maxSbQty - 最大棚番在庫数量

setMinSbQty

public void setMinSbQty(String minSbQty)
最小棚番在庫数量を設定します。

パラメータ:
minSbQty - 最小棚番在庫数量

setCtrlQty

public void setCtrlQty(String ctrlQty)
管理数量を設定します。

パラメータ:
ctrlQty - 管理数量

setReplenQty

public void setReplenQty(String replenQty)
補充数量を設定します。

パラメータ:
replenQty - 補充数量

setPickArea

public void setPickArea(String pickArea)
ピッキングエリアを設定します。

パラメータ:
pickArea - ピッキングエリア

setRoundQty

public void setRoundQty(String roundQty)
丸め数量を設定します。

パラメータ:
roundQty - 丸め数量

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageTypeDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス StorageTypeDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList
すべての実装インタフェース:
Serializable
public class StorageTypeDataList
extends StorageTypeData
implements Serializable

保管域タイプデータ情報クラス
機能は以下の通り

  • 保管域タイプデータ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageTypeDataList()
保管域タイプデータ情報を作成します。
StorageTypeDataList(int index)
保管域タイプデータ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData から継承したメソッド
getCtrlQty, getDelFlag, getFunction, getMaterial, getMaxSbQty, getMinSbQty, getPickArea, getReplenQty, getRoundQty, getStgeBin, getStgeType, getWhseNo, setCtrlQty, setDelFlag, setFunction, setMaterial, setMaxSbQty, setMinSbQty, setPickArea, setReplenQty, setRoundQty, setStgeBin, setStgeType, setWhseNo, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageTypeDataList

public StorageTypeDataList()
保管域タイプデータ情報を作成します。

StorageTypeDataList

public StorageTypeDataList(int index)
保管域タイプデータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TaxClassifications (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス TaxClassifications

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications
すべての実装インタフェース:
Serializable
public class TaxClassifications
extends Object
implements Serializable

制御デ－タ情報クラス
機能は以下の通り

  • 制御デ－タ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TaxClassifications()
制御デ－タ情報を作成します。
TaxClassifications(int index)
制御デ－タ情報を作成します。
メソッドの概要
String | getDepcountry() 出荷国 (商品発送国)を取得します。
String | getDepcountryIso() 出荷国の ISO コードを取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getTaxclass1() 品目の税分類を取得します。
String | getTaxclass2() 品目の税分類を取得します。
String | getTaxclass3() 品目の税分類を取得します。
String | getTaxclass4() 品目の税分類を取得します。
String | getTaxclass5() 品目の税分類を取得します。
String | getTaxclass6() 品目の税分類を取得します。
String | getTaxclass7() 品目の税分類を取得します。
String | getTaxclass8() 品目の税分類を取得します。
String | getTaxclass9() 品目の税分類を取得します。
String | getTaxInd() 税区分: 品目 (購買管理)を取得します。
String | getTaxType1() 税カテゴリ (消費税等)を取得します。
String | getTaxType2() 税カテゴリ (消費税等)を取得します。
String | getTaxType3() 税カテゴリ (消費税等)を取得します。
String | getTaxType4() 税カテゴリ (消費税等)を取得します。
String | getTaxType5() 税カテゴリ (消費税等)を取得します。
String | getTaxType6() 税カテゴリ (消費税等)を取得します。
String | getTaxType7() 税カテゴリ (消費税等)を取得します。
String | getTaxType8() 税カテゴリ (消費税等)を取得します。
String | getTaxType9() 税カテゴリ (消費税等)を取得します。
void | setDepcountry(String depcountry) 出荷国 (商品発送国)を設定します。
void | setDepcountryIso(String depcountryIso) 出荷国の ISO コードを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setTaxclass1(String taxclass1) 品目の税分類を設定します。
void | setTaxclass2(String taxclass2) 品目の税分類を設定します。
void | setTaxclass3(String taxclass3) 品目の税分類を設定します。
void | setTaxclass4(String taxclass4) 品目の税分類を設定します。
void | setTaxclass5(String taxclass5) 品目の税分類を設定します。
void | setTaxclass6(String taxclass6) 品目の税分類を設定します。
void | setTaxclass7(String taxclass7) 品目の税分類を設定します。
void | setTaxclass8(String taxclass8) 品目の税分類を設定します。
void | setTaxclass9(String taxclass9) 品目の税分類を設定します。
void | setTaxInd(String taxInd) 税区分: 品目 (購買管理)を設定します。
void | setTaxType1(String taxType1) 税カテゴリ (消費税等)を設定します。
void | setTaxType2(String taxType2) 税カテゴリ (消費税等)を設定します。
void | setTaxType3(String taxType3) 税カテゴリ (消費税等)を設定します。
void | setTaxType4(String taxType4) 税カテゴリ (消費税等)を設定します。
void | setTaxType5(String taxType5) 税カテゴリ (消費税等)を設定します。
void | setTaxType6(String taxType6) 税カテゴリ (消費税等)を設定します。
void | setTaxType7(String taxType7) 税カテゴリ (消費税等)を設定します。
void | setTaxType8(String taxType8) 税カテゴリ (消費税等)を設定します。
void | setTaxType9(String taxType9) 税カテゴリ (消費税等)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TaxClassifications

public TaxClassifications()
制御デ－タ情報を作成します。

TaxClassifications

public TaxClassifications(int index)
制御デ－タ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getDepcountry

public String getDepcountry()
出荷国 (商品発送国)を取得します。

戻り値:
depcountry 出荷国 (商品発送国)

getDepcountryIso

public String getDepcountryIso()
出荷国の ISO コードを取得します。

戻り値:
depcountryIso 出荷国の ISO コード

getTaxType1

public String getTaxType1()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType1 税カテゴリ (消費税等)

getTaxclass1

public String getTaxclass1()
品目の税分類を取得します。

戻り値:
taxclass1 品目の税分類

getTaxType2

public String getTaxType2()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType2 税カテゴリ (消費税等)

getTaxclass2

public String getTaxclass2()
品目の税分類を取得します。

戻り値:
taxclass2 品目の税分類

getTaxType3

public String getTaxType3()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType3 税カテゴリ (消費税等)

getTaxclass3

public String getTaxclass3()
品目の税分類を取得します。

戻り値:
taxclass3 品目の税分類

getTaxType4

public String getTaxType4()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType4 税カテゴリ (消費税等)

getTaxclass4

public String getTaxclass4()
品目の税分類を取得します。

戻り値:
taxclass4 品目の税分類

getTaxType5

public String getTaxType5()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType5 税カテゴリ (消費税等)

getTaxclass5

public String getTaxclass5()
品目の税分類を取得します。

戻り値:
taxclass5 品目の税分類

getTaxType6

public String getTaxType6()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType6 税カテゴリ (消費税等)

getTaxclass6

public String getTaxclass6()
品目の税分類を取得します。

戻り値:
taxclass6 品目の税分類

getTaxType7

public String getTaxType7()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType7 税カテゴリ (消費税等)

getTaxclass7

public String getTaxclass7()
品目の税分類を取得します。

戻り値:
taxclass7 品目の税分類

getTaxType8

public String getTaxType8()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType8 税カテゴリ (消費税等)

getTaxclass8

public String getTaxclass8()
品目の税分類を取得します。

戻り値:
taxclass8 品目の税分類

getTaxType9

public String getTaxType9()
税カテゴリ (消費税等)を取得します。

戻り値:
taxType9 税カテゴリ (消費税等)

getTaxclass9

public String getTaxclass9()
品目の税分類を取得します。

戻り値:
taxclass9 品目の税分類

getTaxInd

public String getTaxInd()
税区分: 品目 (購買管理)を取得します。

戻り値:
taxInd 税区分: 品目 (購買管理)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setDepcountry

public void setDepcountry(String depcountry)
出荷国 (商品発送国)を設定します。

パラメータ:
depcountry - 出荷国 (商品発送国)

setDepcountryIso

public void setDepcountryIso(String depcountryIso)
出荷国の ISO コードを設定します。

パラメータ:
depcountryIso - 出荷国の ISO コード

setTaxType1

public void setTaxType1(String taxType1)
税カテゴリ (消費税等)を設定します。

setTaxclass1

public void setTaxclass1(String taxclass1)
品目の税分類を設定します。

setTaxType2

public void setTaxType2(String taxType2)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType2 - 税カテゴリ (消費税等)

setTaxclass2

public void setTaxclass2(String taxclass2)
品目の税分類を設定します。

パラメータ:
taxclass2 - 品目の税分類

setTaxType3

public void setTaxType3(String taxType3)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType3 - 税カテゴリ (消費税等)

setTaxclass3

public void setTaxclass3(String taxclass3)
品目の税分類を設定します。

パラメータ:
taxclass3 - 品目の税分類

setTaxType4

public void setTaxType4(String taxType4)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType4 - 税カテゴリ (消費税等)

setTaxclass4

public void setTaxclass4(String taxclass4)
品目の税分類を設定します。

パラメータ:
taxclass4 - 品目の税分類

setTaxType5

public void setTaxType5(String taxType5)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType5 - 税カテゴリ (消費税等)

setTaxclass5

public void setTaxclass5(String taxclass5)
品目の税分類を設定します。

パラメータ:
taxclass5 - 品目の税分類

setTaxType6

public void setTaxType6(String taxType6)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType6 - 税カテゴリ (消費税等)

setTaxclass6

public void setTaxclass6(String taxclass6)
品目の税分類を設定します。

パラメータ:
taxclass6 - 品目の税分類

setTaxType7

public void setTaxType7(String taxType7)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType7 - 税カテゴリ (消費税等)

setTaxclass7

public void setTaxclass7(String taxclass7)
品目の税分類を設定します。

パラメータ:
taxclass7 - 品目の税分類

setTaxType8

public void setTaxType8(String taxType8)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType8 - 税カテゴリ (消費税等)

setTaxclass8

public void setTaxclass8(String taxclass8)
品目の税分類を設定します。

パラメータ:
taxclass8 - 品目の税分類

setTaxType9

public void setTaxType9(String taxType9)
税カテゴリ (消費税等)を設定します。

パラメータ:
taxType9 - 税カテゴリ (消費税等)

setTaxclass9

public void setTaxclass9(String taxclass9)
品目の税分類を設定します。

パラメータ:
taxclass9 - 品目の税分類

setTaxInd

public void setTaxInd(String taxInd)
税区分: 品目 (購買管理)を設定します。

パラメータ:
taxInd - 税区分: 品目 (購買管理)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnitSofmeasure (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス UnitSofmeasure

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure
すべての実装インタフェース:
Serializable
public class UnitSofmeasure
extends Object
implements Serializable

数量単位情報クラス
機能は以下の通り

  • 数量単位情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UnitSofmeasure()
数量単位情報を作成します。
UnitSofmeasure(int index)
数量単位情報を作成します。
メソッドの概要
String | getAltUnit() 在庫保管単位の代替数量単位を取得します。
String | getAltUnitIso() ISO コードによる在庫単位の代替数量単位を取得します。
String | getCharUnit() 特性の数量単位を取得します。
String | getCharUnitIso() 下位レベル数量単位 (ISO コード)を取得します。
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getDenominatr() 分母: 基本数量単位へ変換する場合を取得します。
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getFunction() BAPI 機能を取得します。
String | getGrossWt() 総重量を取得します。
String | getGtinVariant() グローバルトレード明細番号バリアントを取得します。
String | getHeight() 高さを取得します。
int | getIndex() レコード番号を取得します｡
String | getInternalChar() 内部特性を取得します。
String | getLeadinguom() 主要ロット特定数量単位を取得します。
String | getLength() 長さを取得します。
String | getMaterial() 品目コードを取得します。
String | getMeAnzSub() 下位レベル数量単位数を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNumerator() 基本数量単位への換算分子を取得します。
String | getSubUom() 梱包階層の下位レベル数量単位を取得します。
String | getSubUomIso() 下位レベル数量単位 (ISO コード)を取得します。
String | getUnitDim() 寸法単位 (長さ/幅/高さ)を取得します。
String | getUnitDimIso() ISO コードでの長さ、幅、高さの単位を取得します。
String | getUnitOfWt() 重量単位を取得します。
String | getUnitOfWtIso() ISO コードでの重量単位を取得します。
String | getUomsortnumber() 数量単位ソート番号を取得します。
String | getValueduom() ロット特定数量単位での評価を取得します。
String | getVolume() 容積を取得します。
String | getVolumeunit() 容積単位を取得します。
String | getVolumeunitIso() ISO コードでの容積単位を取得します。
String | getWidth() 幅を取得します。
void | setAltUnit(String altUnit) 在庫保管単位の代替数量単位を設定します。
void | setAltUnitIso(String altUnitIso) ISO コードによる在庫単位の代替数量単位を設定します。
void | setCharUnit(String charUnit) 特性の数量単位を設定します。
void | setCharUnitIso(String charUnitIso) 下位レベル数量単位 (ISO コード)を設定します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setDenominatr(String denominatr) 分母: 基本数量単位へ変換する場合を設定します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGrossWt(String grossWt) 総重量を設定します。
void | setGtinVariant(String gtinVariant) グローバルトレード明細番号バリアントを設定します。
void | setHeight(String height) 高さを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInternalChar(String internalChar) 内部特性を設定します。
void | setLeadinguom(String leadinguom) 主要ロット特定数量単位を設定します。
void | setLength(String length) 長さを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMeAnzSub(String meAnzSub) 下位レベル数量単位数を設定します。
void | setNetWeight(String netWeight) 正味重量を設定します。
void | setNumerator(String numerator) 基本数量単位への換算分子を設定します。
void | setSubUom(String subUom) 梱包階層の下位レベル数量単位を設定します。
void | setSubUomIso(String subUomIso) 下位レベル数量単位 (ISO コード)を設定します。
void | setUnitDim(String unitDim) 寸法単位 (長さ/幅/高さ)を設定します。
void | setUnitDimIso(String unitDimIso) ISO コードでの長さ、幅、高さの単位を設定します。
void | setUnitOfWt(String unitOfWt) 重量単位を設定します。
void | setUnitOfWtIso(String unitOfWtIso) ISO コードでの重量単位を設定します。
void | setUomsortnumber(String uomsortnumber) 数量単位ソート番号を設定します。
void | setValueduom(String valueduom) ロット特定数量単位での評価を設定します。
void | setVolume(String volume) 容積を設定します。
void | setVolumeunit(String volumeunit) 容積単位を設定します。
void | setVolumeunitIso(String volumeunitIso) ISO コードでの容積単位を設定します。
void | setWidth(String width) 幅を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnitSofmeasure

public UnitSofmeasure()
数量単位情報を作成します。

UnitSofmeasure

public UnitSofmeasure(int index)
数量単位情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getAltUnit

public String getAltUnit()
在庫保管単位の代替数量単位を取得します。

戻り値:
altUnit 在庫保管単位の代替数量単位

getAltUnitIso

public String getAltUnitIso()
ISO コードによる在庫単位の代替数量単位を取得します。

戻り値:
altUnitIso ISO コードによる在庫単位の代替数量単位

getNumerator

public String getNumerator()
基本数量単位への換算分子を取得します。

戻り値:
numerator 基本数量単位への換算分子

getDenominatr

public String getDenominatr()
分母: 基本数量単位へ変換する場合を取得します。

戻り値:
denominatr 分母: 基本数量単位へ変換する場合

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getLength

public String getLength()
長さを取得します。

戻り値:
length 長さ

getWidth

public String getWidth()
幅を取得します。

戻り値:
width 幅

getHeight

public String getHeight()
高さを取得します。

戻り値:
height 高さ

getUnitDim

public String getUnitDim()
寸法単位 (長さ/幅/高さ)を取得します。

戻り値:
unitDim 寸法単位 (長さ/幅/高さ)

getUnitDimIso

public String getUnitDimIso()
ISO コードでの長さ、幅、高さの単位を取得します。

戻り値:
unitDimIso ISO コードでの長さ、幅、高さの単位

getVolume

public String getVolume()
容積を取得します。

戻り値:
volume 容積

getVolumeunit

public String getVolumeunit()
容積単位を取得します。

戻り値:
volumeunit 容積単位

getVolumeunitIso

public String getVolumeunitIso()
ISO コードでの容積単位を取得します。

戻り値:
volumeunitIso ISO コードでの容積単位

getGrossWt

public String getGrossWt()
総重量を取得します。

戻り値:
grossWt 総重量

getUnitOfWt

public String getUnitOfWt()
重量単位を取得します。

戻り値:
unitOfWt 重量単位

getUnitOfWtIso

public String getUnitOfWtIso()
ISO コードでの重量単位を取得します。

戻り値:
unitOfWtIso ISO コードでの重量単位

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getSubUom

public String getSubUom()
梱包階層の下位レベル数量単位を取得します。

戻り値:
subUom 梱包階層の下位レベル数量単位

getSubUomIso

public String getSubUomIso()
下位レベル数量単位 (ISO コード)を取得します。

戻り値:
subUomIso 下位レベル数量単位 (ISO コード)

getInternalChar

public String getInternalChar()
内部特性を取得します。

戻り値:
internalChar 内部特性

getUomsortnumber

public String getUomsortnumber()
数量単位ソート番号を取得します。

戻り値:
uomsortnumber 数量単位ソート番号

getLeadinguom

public String getLeadinguom()
主要ロット特定数量単位を取得します。

戻り値:
leadinguom 主要ロット特定数量単位

getValueduom

public String getValueduom()
ロット特定数量単位での評価を取得します。

戻り値:
valueduom ロット特定数量単位での評価

getCharUnit

public String getCharUnit()
特性の数量単位を取得します。

戻り値:
charUnit 特性の数量単位

getCharUnitIso

public String getCharUnitIso()
下位レベル数量単位 (ISO コード)を取得します。

戻り値:
charUnitIso 下位レベル数量単位 (ISO コード)

getGtinVariant

public String getGtinVariant()
グローバルトレード明細番号バリアントを取得します。

戻り値:
gtinVariant グローバルトレード明細番号バリアント

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
netWeight 正味重量

getMeAnzSub

public String getMeAnzSub()
下位レベル数量単位数を取得します。

戻り値:
meAnzSub 下位レベル数量単位数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setAltUnit

public void setAltUnit(String altUnit)
在庫保管単位の代替数量単位を設定します。

パラメータ:
altUnit - 在庫保管単位の代替数量単位

setAltUnitIso

public void setAltUnitIso(String altUnitIso)
ISO コードによる在庫単位の代替数量単位を設定します。

パラメータ:
altUnitIso - ISO コードによる在庫単位の代替数量単位

setNumerator

public void setNumerator(String numerator)
基本数量単位への換算分子を設定します。

パラメータ:
numerator - 基本数量単位への換算分子

setDenominatr

public void setDenominatr(String denominatr)
分母: 基本数量単位へ変換する場合を設定します。

パラメータ:
denominatr - 分母: 基本数量単位へ変換する場合

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setLength

public void setLength(String length)
長さを設定します。

パラメータ:
length - 長さ

setWidth

public void setWidth(String width)
幅を設定します。

パラメータ:
width - 幅

setHeight

public void setHeight(String height)
高さを設定します。

パラメータ:
height - 高さ

setUnitDim

public void setUnitDim(String unitDim)
寸法単位 (長さ/幅/高さ)を設定します。

パラメータ:
unitDim - 寸法単位 (長さ/幅/高さ)

setUnitDimIso

public void setUnitDimIso(String unitDimIso)
ISO コードでの長さ、幅、高さの単位を設定します。

パラメータ:
unitDimIso - ISO コードでの長さ、幅、高さの単位

setVolume

public void setVolume(String volume)
容積を設定します。

パラメータ:
volume - 容積

setVolumeunit

public void setVolumeunit(String volumeunit)
容積単位を設定します。

パラメータ:
volumeunit - 容積単位

setVolumeunitIso

public void setVolumeunitIso(String volumeunitIso)
ISO コードでの容積単位を設定します。

パラメータ:
volumeunitIso - ISO コードでの容積単位

setGrossWt

public void setGrossWt(String grossWt)
総重量を設定します。

パラメータ:
grossWt - 総重量

setUnitOfWt

public void setUnitOfWt(String unitOfWt)
重量単位を設定します。

パラメータ:
unitOfWt - 重量単位

setUnitOfWtIso

public void setUnitOfWtIso(String unitOfWtIso)
ISO コードでの重量単位を設定します。

パラメータ:
unitOfWtIso - ISO コードでの重量単位

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setSubUom

public void setSubUom(String subUom)
梱包階層の下位レベル数量単位を設定します。

パラメータ:
subUom - 梱包階層の下位レベル数量単位

setSubUomIso

public void setSubUomIso(String subUomIso)
下位レベル数量単位 (ISO コード)を設定します。

パラメータ:
subUomIso - 下位レベル数量単位 (ISO コード)

setInternalChar

public void setInternalChar(String internalChar)
内部特性を設定します。

パラメータ:
internalChar - 内部特性

setUomsortnumber

public void setUomsortnumber(String uomsortnumber)
数量単位ソート番号を設定します。

パラメータ:
uomsortnumber - 数量単位ソート番号

setLeadinguom

public void setLeadinguom(String leadinguom)
主要ロット特定数量単位を設定します。

パラメータ:
leadinguom - 主要ロット特定数量単位

setValueduom

public void setValueduom(String valueduom)
ロット特定数量単位での評価を設定します。

パラメータ:
valueduom - ロット特定数量単位での評価

setCharUnit

public void setCharUnit(String charUnit)
特性の数量単位を設定します。

パラメータ:
charUnit - 特性の数量単位

setCharUnitIso

public void setCharUnitIso(String charUnitIso)
下位レベル数量単位 (ISO コード)を設定します。

パラメータ:
charUnitIso - 下位レベル数量単位 (ISO コード)

setGtinVariant

public void setGtinVariant(String gtinVariant)
グローバルトレード明細番号バリアントを設定します。

パラメータ:
gtinVariant - グローバルトレード明細番号バリアント

setNetWeight

public void setNetWeight(String netWeight)
正味重量を設定します。

パラメータ:
netWeight - 正味重量

setMeAnzSub

public void setMeAnzSub(String meAnzSub)
下位レベル数量単位数を設定します。

パラメータ:
meAnzSub - 下位レベル数量単位数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValuationData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ValuationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ValuationDataList
public class ValuationData
extends Object
implements Serializable

評価データ情報クラス
機能は以下の通り

  • 評価データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ValuationData()
評価データ情報を作成します。
メソッドの概要
String | getAccountView() 会計ビューを取得します。
String | getCommprice1() 商法による評価額: レベル 1を取得します。
String | getCommprice2() 商法による評価額: レベル 2を取得します。
String | getCommprice3() 商法基準評価額: レベル 3を取得します。
String | getCostView() 原価計算ビューを取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getCurrPeriod() 当期 (転記期間)を取得します。
String | getCurrPlanPrice() 税法基準評価額: レベル 2を取得します。
String | getDelFlag() 評価タイプに該当する全品目データ削除フラグを取得します。
String | getDevalInd() 低価法: 評価減区分を取得します。
String | getFijCurCostEst() 当期標準原価見積の会計年度を取得します。
String | getFijFutCostEst() 将来標準原価見積の会計年度を取得します。
String | getFijPreCostEst() 前期標準原価見積の会計年度を取得します。
String | getFiscYear() 当会計年度を取得します。
String | getFunction() BAPI 機能を取得します。
String | getFuturePr() 次期標準原価を取得します。
String | getInHouse() 内部生産を取得します。
String | getLifoFifo() LIFO/FIFO 関連を取得します。
String | getMaintStat() 更新ステータスを取得します。
String | getMaterial() 品目コードを取得します。
String | getMatlUsage() 品目の用途を取得します。
String | getMatOrigin() 品目の原産地を取得します。
String | getMlActive() 品目レベルで有効な品目元帳を取得します。
String | getMlSettle() 品目元帳決済: 管理を取得します。
String | getMovingPr() 移動平均原価/期間単位価格を取得します。
String | getMovPrPp() 前期移動平均原価/期間平均原価を取得します。
String | getMovPrPy() 前年度の移動平均原価/期間単価を取得します。
String | getOrigGroup() 発生源グループ (原価要素の下位区分)を取得します。
String | getOrigMat() 品目発生源を取得します。
String | getOverheadGrp() 原価計算間接費グループを取得します。
String | getPerCurCostEst() 現行標準原価見積期間を取得します。
String | getPerFutCostEst() 将来標準原価見積期間を取得します。
String | getPerPreCostEst() 前標準原価見積期間を取得します。
String | getPlndprdate1() 予定原価 1 の有効開始日を取得します。
String | getPlndprdate2() 予定原価 2 の有効開始日を取得します。
String | getPlndprdate3() 予定原価 3 の有効開始日を取得します。
String | getPlndPrice() 予定計画原価を取得します。
String | getPlndprice1() 予定計画原価 1を取得します。
String | getPlndprice2() 予定計画原価 2を取得します。
String | getPlndprice3() 予定計画原価 3を取得します。
String | getPoolnumber() LIFO 評価でのプール番号を取得します。
String | getPrCtrlPp() 前期間の原価管理区分を取得します。
String | getPrCtrlPy() 前年度の原価管理区分を取得します。
String | getPrevPlanPrice() 税法基準評価額: レベル 2を取得します。
String | getPriceCtrl() 原価管理区分を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getPrUnitPp() 前期価格単位を取得します。
String | getPrUnitPy() 前年度価格単位を取得します。
String | getQtyStruct() 数量構成により原価計算を行う品目を取得します。
String | getStdPrice() 標準原価を取得します。
String | getStdPrPp() 前期標準標準原価を取得します。
String | getStdPrPy() 前年度標準原価を取得します。
String | getTaxCmlUn() 税法/商法にもとづく評価額価格単位を取得します。
String | getTaxprice1() 税法による評価額: レベル 1を取得します。
String | getTaxprice2() 税法による評価額: レベル 2を取得します。
String | getTaxprice3() 税法基準評価額: レベル 3を取得します。
String | getValArea() 評価レベルを取得します。
String | getValCat() 評価カテゴリを取得します。
String | getValClass() 評価クラスを取得します。
String | getValidFrom() 原価有効開始日を取得します。
String | getValType() 評価タイプを取得します。
String | getVclassPp() 前期評価クラスを取得します。
String | getVclassPy() 前年度の評価クラスを取得します。
String | getVmPStock() プロジェクト在庫の評価クラスを取得します。
String | getVmSoStk() 受注在庫の評価クラスを取得します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setCommprice1(String commprice1) 商法による評価額: レベル 1を設定します。
void | setCommprice2(String commprice2) 商法による評価額: レベル 2を設定します。
void | setCommprice3(String commprice3) 商法基準評価額: レベル 3を設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setCurrPeriod(String currPeriod) 当期 (転記期間)を設定します。
void | setCurrPlanPrice(String currPlanPrice) 税法基準評価額: レベル 2を設定します。
void | setDelFlag(String delFlag) 評価タイプに該当する全品目データ削除フラグを設定します。
void | setDevalInd(String devalInd) 低価法: 評価減区分を設定します。
void | setFijCurCostEst(String fijCurCostEst) 当期標準原価見積の会計年度を設定します。
void | setFijFutCostEst(String fijFutCostEst) 将来標準原価見積の会計年度を設定します。
void | setFijPreCostEst(String fijPreCostEst) 前期標準原価見積の会計年度を設定します。
void | setFiscYear(String fiscYear) 当会計年度を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setFuturePr(String futurePr) 次期標準原価を設定します。
void | setInHouse(String inHouse) 内部生産を設定します。
void | setLifoFifo(String lifoFifo) LIFO/FIFO 関連を設定します。
void | setMaintStat(String maintStat) 更新ステータスを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatlUsage(String matlUsage) 品目の用途を設定します。
void | setMatOrigin(String matOrigin) 品目の原産地を設定します。
void | setMlActive(String mlActive) 品目レベルで有効な品目元帳を設定します。
void | setMlSettle(String mlSettle) 品目元帳決済: 管理を設定します。
void | setMovingPr(String movingPr) 移動平均原価/期間単位価格を設定します。
void | setMovPrPp(String movPrPp) 前期移動平均原価/期間平均原価を設定します。
void | setMovPrPy(String movPrPy) 前年度の移動平均原価/期間単価を設定します。
void | setOrigGroup(String origGroup) 発生源グループ (原価要素の下位区分)を設定します。
void | setOrigMat(String origMat) 品目発生源を設定します。
void | setOverheadGrp(String overheadGrp) 原価計算間接費グループを設定します。
void | setPerCurCostEst(String perCurCostEst) 現行標準原価見積期間を設定します。
void | setPerFutCostEst(String perFutCostEst) 将来標準原価見積期間を設定します。
void | setPerPreCostEst(String perPreCostEst) 前標準原価見積期間を設定します。
void | setPlndprdate1(String plndprdate1) 予定原価 1 の有効開始日を設定します。
void | setPlndprdate2(String plndprdate2) 予定原価 2 の有効開始日を設定します。
void | setPlndprdate3(String plndprdate3) 予定原価 3 の有効開始日を設定します。
void | setPlndPrice(String plndPrice) 予定計画原価を設定します。
void | setPlndprice1(String plndprice1) 予定計画原価 1を設定します。
void | setPlndprice2(String plndprice2) 予定計画原価 2を設定します。
void | setPlndprice3(String plndprice3) 予定計画原価 3を設定します。
void | setPoolnumber(String poolnumber) LIFO 評価でのプール番号を設定します。
void | setPrCtrlPp(String prCtrlPp) 前期間の原価管理区分を設定します。
void | setPrCtrlPy(String prCtrlPy) 前年度の原価管理区分を設定します。
void | setPrevPlanPrice(String prevPlanPrice) 税法基準評価額: レベル 2を設定します。
void | setPriceCtrl(String priceCtrl) 原価管理区分を設定します。
void | setPriceUnit(String priceUnit) 価格単位を設定します。
void | setPrUnitPp(String prUnitPp) 前期価格単位を設定します。
void | setPrUnitPy(String prUnitPy) 前年度価格単位を設定します。
void | setQtyStruct(String qtyStruct) 数量構成により原価計算を行う品目を設定します。
void | setStdPrice(String stdPrice) 標準原価を設定します。
void | setStdPrPp(String stdPrPp) 前期標準標準原価を設定します。
void | setStdPrPy(String stdPrPy) 前年度標準原価を設定します。
void | setTaxCmlUn(String taxCmlUn) 税法/商法にもとづく評価額価格単位を設定します。
void | setTaxprice1(String taxprice1) 税法による評価額: レベル 1を設定します。
void | setTaxprice2(String taxprice2) 税法による評価額: レベル 2を設定します。
void | setTaxprice3(String taxprice3) 税法基準評価額: レベル 3を設定します。
void | setValArea(String valArea) 評価レベルを設定します。
void | setValCat(String valCat) 評価カテゴリを設定します。
void | setValClass(String valClass) 評価クラスを設定します。
void | setValidFrom(String validFrom) 原価有効開始日を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setVclassPp(String vclassPp) 前期評価クラスを設定します。
void | setVclassPy(String vclassPy) 前年度の評価クラスを設定します。
void | setVmPStock(String vmPStock) プロジェクト在庫の評価クラスを設定します。
void | setVmSoStk(String vmSoStk) 受注在庫の評価クラスを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValuationData

public ValuationData()
評価データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getValArea

public String getValArea()
評価レベルを取得します。

戻り値:
valArea 評価レベル

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getMaintStat

public String getMaintStat()
更新ステータスを取得します。

戻り値:
maintStat 更新ステータス

getDelFlag

public String getDelFlag()
評価タイプに該当する全品目データ削除フラグを取得します。

戻り値:
delFlag 評価タイプに該当する全品目データ削除フラグ

getPriceCtrl

public String getPriceCtrl()
原価管理区分を取得します。

戻り値:
priceCtrl 原価管理区分

getMovingPr

public String getMovingPr()
移動平均原価/期間単位価格を取得します。

戻り値:
movingPr 移動平均原価/期間単位価格

getStdPrice

public String getStdPrice()
標準原価を取得します。

戻り値:
stdPrice 標準原価

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
priceUnit 価格単位

getValClass

public String getValClass()
評価クラスを取得します。

戻り値:
valClass 評価クラス

getPrCtrlPp

public String getPrCtrlPp()
前期間の原価管理区分を取得します。

戻り値:
prCtrlPp 前期間の原価管理区分

getMovPrPp

public String getMovPrPp()
前期移動平均原価/期間平均原価を取得します。

戻り値:
movPrPp 前期移動平均原価/期間平均原価

getStdPrPp

public String getStdPrPp()
前期標準標準原価を取得します。

戻り値:
stdPrPp 前期標準標準原価

getPrUnitPp

public String getPrUnitPp()
前期価格単位を取得します。

戻り値:
prUnitPp 前期価格単位

getVclassPp

public String getVclassPp()
前期評価クラスを取得します。

戻り値:
vclassPp 前期評価クラス

getPrCtrlPy

public String getPrCtrlPy()
前年度の原価管理区分を取得します。

戻り値:
prCtrlPy 前年度の原価管理区分

getMovPrPy

public String getMovPrPy()
前年度の移動平均原価/期間単価を取得します。

戻り値:
movPrPy 前年度の移動平均原価/期間単価

getStdPrPy

public String getStdPrPy()
前年度標準原価を取得します。

戻り値:
stdPrPy 前年度標準原価

getVclassPy

public String getVclassPy()
前年度の評価クラスを取得します。

戻り値:
vclassPy 前年度の評価クラス

getPrUnitPy

public String getPrUnitPy()
前年度価格単位を取得します。

戻り値:
prUnitPy 前年度価格単位

getFiscYear

public String getFiscYear()
当会計年度を取得します。

戻り値:
fiscYear 当会計年度

getCurrPeriod

public String getCurrPeriod()
当期 (転記期間)を取得します。

戻り値:
currPeriod 当期 (転記期間)

getValCat

public String getValCat()
評価カテゴリを取得します。

戻り値:
valCat 評価カテゴリ

getFuturePr

public String getFuturePr()
次期標準原価を取得します。

戻り値:
futurePr 次期標準原価

getValidFrom

public String getValidFrom()
原価有効開始日を取得します。

戻り値:
validFrom 原価有効開始日

getTaxprice1

public String getTaxprice1()
税法による評価額: レベル 1を取得します。

戻り値:
taxprice1 税法による評価額: レベル 1

getCommprice1

public String getCommprice1()
商法による評価額: レベル 1を取得します。

戻り値:
commprice1 商法による評価額: レベル 1

getTaxprice3

public String getTaxprice3()
税法基準評価額: レベル 3を取得します。

戻り値:
taxprice3 税法基準評価額: レベル 3

getCommprice3

public String getCommprice3()
商法基準評価額: レベル 3を取得します。

戻り値:
commprice3 商法基準評価額: レベル 3

getPlndPrice

public String getPlndPrice()
予定計画原価を取得します。

戻り値:
plndPrice 予定計画原価

getPlndprice1

public String getPlndprice1()
予定計画原価 1を取得します。

戻り値:
plndprice1 予定計画原価 1

getPlndprice2

public String getPlndprice2()
予定計画原価 2を取得します。

戻り値:
plndprice2 予定計画原価 2

getPlndprice3

public String getPlndprice3()
予定計画原価 3を取得します。

戻り値:
plndprice3 予定計画原価 3

getPlndprdate1

public String getPlndprdate1()
予定原価 1 の有効開始日を取得します。

戻り値:
plndprdate1 予定原価 1 の有効開始日

getPlndprdate2

public String getPlndprdate2()
予定原価 2 の有効開始日を取得します。

戻り値:
plndprdate2 予定原価 2 の有効開始日

getPlndprdate3

public String getPlndprdate3()
予定原価 3 の有効開始日を取得します。

戻り値:
plndprdate3 予定原価 3 の有効開始日

getLifoFifo

public String getLifoFifo()
LIFO/FIFO 関連を取得します。

戻り値:
lifoFifo LIFO/FIFO 関連

getPoolnumber

public String getPoolnumber()
LIFO 評価でのプール番号を取得します。

戻り値:
poolnumber LIFO 評価でのプール番号

getTaxprice2

public String getTaxprice2()
税法による評価額: レベル 2を取得します。

戻り値:
taxprice2 税法による評価額: レベル 2

getCommprice2

public String getCommprice2()
商法による評価額: レベル 2を取得します。

戻り値:
commprice2 商法による評価額: レベル 2

getDevalInd

public String getDevalInd()
低価法: 評価減区分を取得します。

戻り値:
devalInd 低価法: 評価減区分

getOrigGroup

public String getOrigGroup()
発生源グループ (原価要素の下位区分)を取得します。

戻り値:
origGroup 発生源グループ (原価要素の下位区分)

getOverheadGrp

public String getOverheadGrp()
原価計算間接費グループを取得します。

戻り値:
overheadGrp 原価計算間接費グループ

getPerFutCostEst

public String getPerFutCostEst()
将来標準原価見積期間を取得します。

戻り値:
perFutCostEst 将来標準原価見積期間

getPerCurCostEst

public String getPerCurCostEst()
現行標準原価見積期間を取得します。

戻り値:
perCurCostEst 現行標準原価見積期間

getPerPreCostEst

public String getPerPreCostEst()
前標準原価見積期間を取得します。

戻り値:
perPreCostEst 前標準原価見積期間

getFijFutCostEst

public String getFijFutCostEst()
将来標準原価見積の会計年度を取得します。

戻り値:
fijFutCostEst 将来標準原価見積の会計年度

getFijCurCostEst

public String getFijCurCostEst()
当期標準原価見積の会計年度を取得します。

戻り値:
fijCurCostEst 当期標準原価見積の会計年度

getFijPreCostEst

public String getFijPreCostEst()
前期標準原価見積の会計年度を取得します。

戻り値:
fijPreCostEst 前期標準原価見積の会計年度

getQtyStruct

public String getQtyStruct()
数量構成により原価計算を行う品目を取得します。

戻り値:
qtyStruct 数量構成により原価計算を行う品目

getPrevPlanPrice

public String getPrevPlanPrice()
税法基準評価額: レベル 2を取得します。

戻り値:
prevPlanPrice 税法基準評価額: レベル 2

getMlActive

public String getMlActive()
品目レベルで有効な品目元帳を取得します。

戻り値:
mlActive 品目レベルで有効な品目元帳

getMlSettle

public String getMlSettle()
品目元帳決済: 管理を取得します。

戻り値:
mlSettle 品目元帳決済: 管理

getCurrPlanPrice

public String getCurrPlanPrice()
税法基準評価額: レベル 2を取得します。

戻り値:
currPlanPrice 税法基準評価額: レベル 2

getOrigMat

public String getOrigMat()
品目発生源を取得します。

戻り値:
origMat 品目発生源

getVmSoStk

public String getVmSoStk()
受注在庫の評価クラスを取得します。

戻り値:
vmSoStk 受注在庫の評価クラス

getVmPStock

public String getVmPStock()
プロジェクト在庫の評価クラスを取得します。

戻り値:
vmPStock プロジェクト在庫の評価クラス

getMatlUsage

public String getMatlUsage()
品目の用途を取得します。

戻り値:
matlUsage 品目の用途

getMatOrigin

public String getMatOrigin()
品目の原産地を取得します。

戻り値:
matOrigin 品目の原産地

getInHouse

public String getInHouse()
内部生産を取得します。

戻り値:
inHouse 内部生産

getTaxCmlUn

public String getTaxCmlUn()
税法/商法にもとづく評価額価格単位を取得します。

戻り値:
taxCmlUn 税法/商法にもとづく評価額価格単位

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setValArea

public void setValArea(String valArea)
評価レベルを設定します。

パラメータ:
valArea - 評価レベル

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setMaintStat

public void setMaintStat(String maintStat)
更新ステータスを設定します。

パラメータ:
maintStat - 更新ステータス

setDelFlag

public void setDelFlag(String delFlag)
評価タイプに該当する全品目データ削除フラグを設定します。

パラメータ:
delFlag - 評価タイプに該当する全品目データ削除フラグ

setPriceCtrl

public void setPriceCtrl(String priceCtrl)
原価管理区分を設定します。

パラメータ:
priceCtrl - 原価管理区分

setMovingPr

public void setMovingPr(String movingPr)
移動平均原価/期間単位価格を設定します。

パラメータ:
movingPr - 移動平均原価/期間単位価格

setStdPrice

public void setStdPrice(String stdPrice)
標準原価を設定します。

パラメータ:
stdPrice - 標準原価

setPriceUnit

public void setPriceUnit(String priceUnit)
価格単位を設定します。

パラメータ:
priceUnit - 価格単位

setValClass

public void setValClass(String valClass)
評価クラスを設定します。

パラメータ:
valClass - 評価クラス

setPrCtrlPp

public void setPrCtrlPp(String prCtrlPp)
前期間の原価管理区分を設定します。

パラメータ:
prCtrlPp - 前期間の原価管理区分

setMovPrPp

public void setMovPrPp(String movPrPp)
前期移動平均原価/期間平均原価を設定します。

パラメータ:
movPrPp - 前期移動平均原価/期間平均原価

setStdPrPp

public void setStdPrPp(String stdPrPp)
前期標準標準原価を設定します。

パラメータ:
stdPrPp - 前期標準標準原価

setPrUnitPp

public void setPrUnitPp(String prUnitPp)
前期価格単位を設定します。

パラメータ:
prUnitPp - 前期価格単位

setVclassPp

public void setVclassPp(String vclassPp)
前期評価クラスを設定します。

パラメータ:
vclassPp - 前期評価クラス

setPrCtrlPy

public void setPrCtrlPy(String prCtrlPy)
前年度の原価管理区分を設定します。

パラメータ:
prCtrlPy - 前年度の原価管理区分

setMovPrPy

public void setMovPrPy(String movPrPy)
前年度の移動平均原価/期間単価を設定します。

パラメータ:
movPrPy - 前年度の移動平均原価/期間単価

setStdPrPy

public void setStdPrPy(String stdPrPy)
前年度標準原価を設定します。

パラメータ:
stdPrPy - 前年度標準原価

setVclassPy

public void setVclassPy(String vclassPy)
前年度の評価クラスを設定します。

パラメータ:
vclassPy - 前年度の評価クラス

setPrUnitPy

public void setPrUnitPy(String prUnitPy)
前年度価格単位を設定します。

パラメータ:
prUnitPy - 前年度価格単位

setFiscYear

public void setFiscYear(String fiscYear)
当会計年度を設定します。

パラメータ:
fiscYear - 当会計年度

setCurrPeriod

public void setCurrPeriod(String currPeriod)
当期 (転記期間)を設定します。

パラメータ:
currPeriod - 当期 (転記期間)

setValCat

public void setValCat(String valCat)
評価カテゴリを設定します。

パラメータ:
valCat - 評価カテゴリ

setFuturePr

public void setFuturePr(String futurePr)
次期標準原価を設定します。

パラメータ:
futurePr - 次期標準原価

setValidFrom

public void setValidFrom(String validFrom)
原価有効開始日を設定します。

パラメータ:
validFrom - 原価有効開始日

setTaxprice1

public void setTaxprice1(String taxprice1)
税法による評価額: レベル 1を設定します。

パラメータ:
taxprice1 - 税法による評価額: レベル 1

setCommprice1

public void setCommprice1(String commprice1)
商法による評価額: レベル 1を設定します。

パラメータ:
commprice1 - 商法による評価額: レベル 1

setTaxprice3

public void setTaxprice3(String taxprice3)
税法基準評価額: レベル 3を設定します。

パラメータ:
taxprice3 - 税法基準評価額: レベル 3

setCommprice3

public void setCommprice3(String commprice3)
商法基準評価額: レベル 3を設定します。

パラメータ:
commprice3 - 商法基準評価額: レベル 3

setPlndPrice

public void setPlndPrice(String plndPrice)
予定計画原価を設定します。

パラメータ:
plndPrice - 予定計画原価

setPlndprice1

public void setPlndprice1(String plndprice1)
予定計画原価 1を設定します。

パラメータ:
plndprice1 - 予定計画原価 1

setPlndprice2

public void setPlndprice2(String plndprice2)
予定計画原価 2を設定します。

パラメータ:
plndprice2 - 予定計画原価 2

setPlndprice3

public void setPlndprice3(String plndprice3)
予定計画原価 3を設定します。

パラメータ:
plndprice3 - 予定計画原価 3

setPlndprdate1

public void setPlndprdate1(String plndprdate1)
予定原価 1 の有効開始日を設定します。

パラメータ:
plndprdate1 - 予定原価 1 の有効開始日

setPlndprdate2

public void setPlndprdate2(String plndprdate2)
予定原価 2 の有効開始日を設定します。

パラメータ:
plndprdate2 - 予定原価 2 の有効開始日

setPlndprdate3

public void setPlndprdate3(String plndprdate3)
予定原価 3 の有効開始日を設定します。

パラメータ:
plndprdate3 - 予定原価 3 の有効開始日

setLifoFifo

public void setLifoFifo(String lifoFifo)
LIFO/FIFO 関連を設定します。

パラメータ:
lifoFifo - LIFO/FIFO 関連

setPoolnumber

public void setPoolnumber(String poolnumber)
LIFO 評価でのプール番号を設定します。

パラメータ:
poolnumber - LIFO 評価でのプール番号

setTaxprice2

public void setTaxprice2(String taxprice2)
税法による評価額: レベル 2を設定します。

パラメータ:
taxprice2 - 税法による評価額: レベル 2

setCommprice2

public void setCommprice2(String commprice2)
商法による評価額: レベル 2を設定します。

パラメータ:
commprice2 - 商法による評価額: レベル 2

setDevalInd

public void setDevalInd(String devalInd)
低価法: 評価減区分を設定します。

パラメータ:
devalInd - 低価法: 評価減区分

setOrigGroup

public void setOrigGroup(String origGroup)
発生源グループ (原価要素の下位区分)を設定します。

パラメータ:
origGroup - 発生源グループ (原価要素の下位区分)

setOverheadGrp

public void setOverheadGrp(String overheadGrp)
原価計算間接費グループを設定します。

パラメータ:
overheadGrp - 原価計算間接費グループ

setPerFutCostEst

public void setPerFutCostEst(String perFutCostEst)
将来標準原価見積期間を設定します。

パラメータ:
perFutCostEst - 将来標準原価見積期間

setPerCurCostEst

public void setPerCurCostEst(String perCurCostEst)
現行標準原価見積期間を設定します。

パラメータ:
perCurCostEst - 現行標準原価見積期間

setPerPreCostEst

public void setPerPreCostEst(String perPreCostEst)
前標準原価見積期間を設定します。

パラメータ:
perPreCostEst - 前標準原価見積期間

setFijFutCostEst

public void setFijFutCostEst(String fijFutCostEst)
将来標準原価見積の会計年度を設定します。

パラメータ:
fijFutCostEst - 将来標準原価見積の会計年度

setFijCurCostEst

public void setFijCurCostEst(String fijCurCostEst)
当期標準原価見積の会計年度を設定します。

パラメータ:
fijCurCostEst - 当期標準原価見積の会計年度

setFijPreCostEst

public void setFijPreCostEst(String fijPreCostEst)
前期標準原価見積の会計年度を設定します。

パラメータ:
fijPreCostEst - 前期標準原価見積の会計年度

setQtyStruct

public void setQtyStruct(String qtyStruct)
数量構成により原価計算を行う品目を設定します。

パラメータ:
qtyStruct - 数量構成により原価計算を行う品目

setPrevPlanPrice

public void setPrevPlanPrice(String prevPlanPrice)
税法基準評価額: レベル 2を設定します。

パラメータ:
prevPlanPrice - 税法基準評価額: レベル 2

setMlActive

public void setMlActive(String mlActive)
品目レベルで有効な品目元帳を設定します。

パラメータ:
mlActive - 品目レベルで有効な品目元帳

setMlSettle

public void setMlSettle(String mlSettle)
品目元帳決済: 管理を設定します。

パラメータ:
mlSettle - 品目元帳決済: 管理

setCurrPlanPrice

public void setCurrPlanPrice(String currPlanPrice)
税法基準評価額: レベル 2を設定します。

パラメータ:
currPlanPrice - 税法基準評価額: レベル 2

setOrigMat

public void setOrigMat(String origMat)
品目発生源を設定します。

パラメータ:
origMat - 品目発生源

setVmSoStk

public void setVmSoStk(String vmSoStk)
受注在庫の評価クラスを設定します。

パラメータ:
vmSoStk - 受注在庫の評価クラス

setVmPStock

public void setVmPStock(String vmPStock)
プロジェクト在庫の評価クラスを設定します。

パラメータ:
vmPStock - プロジェクト在庫の評価クラス

setMatlUsage

public void setMatlUsage(String matlUsage)
品目の用途を設定します。

パラメータ:
matlUsage - 品目の用途

setMatOrigin

public void setMatOrigin(String matOrigin)
品目の原産地を設定します。

パラメータ:
matOrigin - 品目の原産地

setInHouse

public void setInHouse(String inHouse)
内部生産を設定します。

パラメータ:
inHouse - 内部生産

setTaxCmlUn

public void setTaxCmlUn(String taxCmlUn)
税法/商法にもとづく評価額価格単位を設定します。

パラメータ:
taxCmlUn - 税法/商法にもとづく評価額価格単位

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ValuationDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス ValuationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList
すべての実装インタフェース:
Serializable
public class ValuationDataList
extends ValuationData
implements Serializable

評価データ情報クラス
機能は以下の通り

  • 評価データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
ValuationDataList()
評価データ情報を作成します。
ValuationDataList(int index)
評価データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData から継承したメソッド
getAccountView, getCommprice1, getCommprice2, getCommprice3, getCostView, getCurrency, getCurrencyIso, getCurrPeriod, getCurrPlanPrice, getDelFlag, getDevalInd, getFijCurCostEst, getFijFutCostEst, getFijPreCostEst, getFiscYear, getFunction, getFuturePr, getInHouse, getLifoFifo, getMaintStat, getMaterial, getMatlUsage, getMatOrigin, getMlActive, getMlSettle, getMovingPr, getMovPrPp, getMovPrPy, getOrigGroup, getOrigMat, getOverheadGrp, getPerCurCostEst, getPerFutCostEst, getPerPreCostEst, getPlndprdate1, getPlndprdate2, getPlndprdate3, getPlndPrice, getPlndprice1, getPlndprice2, getPlndprice3, getPoolnumber, getPrCtrlPp, getPrCtrlPy, getPrevPlanPrice, getPriceCtrl, getPriceUnit, getPrUnitPp, getPrUnitPy, getQtyStruct, getStdPrice, getStdPrPp, getStdPrPy, getTaxCmlUn, getTaxprice1, getTaxprice2, getTaxprice3, getValArea, getValCat, getValClass, getValidFrom, getValType, getVclassPp, getVclassPy, getVmPStock, getVmSoStk, setAccountView, setCommprice1, setCommprice2, setCommprice3, setCostView, setCurrency, setCurrencyIso, setCurrPeriod, setCurrPlanPrice, setDelFlag, setDevalInd, setFijCurCostEst, setFijFutCostEst, setFijPreCostEst, setFiscYear, setFunction, setFuturePr, setInHouse, setLifoFifo, setMaintStat, setMaterial, setMatlUsage, setMatOrigin, setMlActive, setMlSettle, setMovingPr, setMovPrPp, setMovPrPy, setOrigGroup, setOrigMat, setOverheadGrp, setPerCurCostEst, setPerFutCostEst, setPerPreCostEst, setPlndprdate1, setPlndprdate2, setPlndprdate3, setPlndPrice, setPlndprice1, setPlndprice2, setPlndprice3, setPoolnumber, setPrCtrlPp, setPrCtrlPy, setPrevPlanPrice, setPriceCtrl, setPriceUnit, setPrUnitPp, setPrUnitPy, setQtyStruct, setStdPrice, setStdPrPp, setStdPrPy, setTaxCmlUn, setTaxprice1, setTaxprice2, setTaxprice3, setValArea, setValCat, setValClass, setValidFrom, setValType, setVclassPp, setVclassPy, setVmPStock, setVmSoStk, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ValuationDataList

public ValuationDataList()
評価データ情報を作成します。

ValuationDataList

public ValuationDataList(int index)
評価データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WarehouseNumberData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス WarehouseNumberData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
WarehouseNumberDataList
public class WarehouseNumberData
extends Object
implements Serializable

倉庫番号データ情報クラス
機能は以下の通り

  • 倉庫番号データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
WarehouseNumberData()
倉庫番号データ情報を作成します。
メソッドの概要
String | getAddToStk() 既存在庫への追加許可を取得します。
String | getBlockStge() 平置保管域区分を取得します。
String | getCapyUsage() 保管容量使用を取得します。
String | getDelFlag() WM 倉庫内の全品目データ削除フラグを取得します。
String | getFunction() BAPI 機能を取得します。
String | getLEquip1() 積載装置数量 1を取得します。
String | getLEquip2() 積載装置数量 2を取得します。
String | getLEquip3() 積載装置数量 3を取得します。
String | getLeqUnit1() 積載装置数量 1 の数量単位を取得します。
String | getLeqUnit1Iso() ISO コードによる積載装置数量 1 の数量単位を取得します。
String | getLeqUnit2() 積載装置数量 2 の数量単位を取得します。
String | getLeqUnit2Iso() ISO コードによる積載装置数量 2 の数量単位を取得します。
String | getLeqUnit3() 積載装置数量 3 の数量単位を取得します。
String | getLeqUnit3Iso() ISO コードによる積載装置数量 3 の数量単位を取得します。
String | getMaterial() 品目コードを取得します。
String | getMsgToIm() 区分: 在庫管理への出力を取得します。
String | getPlacement() 在庫受入に対する保管域タイプ検索区分を取得します。
String | getProcureUn() 保管容量消費の数量単位を取得します。
String | getProcureUnIso() ISO コードでの保管容量消費の数量単位を取得します。
String | getRefUnit() 品目マスタレコードの数量単位初期値を取得します。
String | getSpecMvmt() 倉庫管理の特殊移動区分を取得します。
String | getStgesector() 保管区画区分を取得します。
String | getStgeType() 概略計画および詳細計画のピッキング保管域タイプを取得します。
String | getTwoStepPick() ツーステップピッキング適用品目を取得します。
String | getUnittype1() 第１保管単位タイプを取得します。
String | getUnittype2() 第２保管単位タイプを取得します。
String | getUnittype3() 第３保管単位タイプを取得します。
String | getWhseNo() 倉庫番号/複合倉庫を取得します。
String | getWithdrawal() 在庫払出に対する保管域タイプ区分を取得します。
String | getWmUnit() 倉庫管理の数量単位を取得します。
String | getWmUnitIso() ISO コードでの倉庫管理単位を取得します。
void | setAddToStk(String addToStk) 既存在庫への追加許可を設定します。
void | setBlockStge(String blockStge) 平置保管域区分を設定します。
void | setCapyUsage(String capyUsage) 保管容量使用を設定します。
void | setDelFlag(String delFlag) WM 倉庫内の全品目データ削除フラグを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setLEquip1(String lEquip1) 積載装置数量 1を設定します。
void | setLEquip2(String lEquip2) 積載装置数量 2を設定します。
void | setLEquip3(String lEquip3) 積載装置数量 3を設定します。
void | setLeqUnit1(String leqUnit1) 積載装置数量 1 の数量単位を設定します。
void | setLeqUnit1Iso(String leqUnit1Iso) ISO コードによる積載装置数量 1 の数量単位を設定します。
void | setLeqUnit2(String leqUnit2) 積載装置数量 2 の数量単位を設定します。
void | setLeqUnit2Iso(String leqUnit2Iso) ISO コードによる積載装置数量 2 の数量単位を設定します。
void | setLeqUnit3(String leqUnit3) 積載装置数量 3 の数量単位を設定します。
void | setLeqUnit3Iso(String leqUnit3Iso) ISO コードによる積載装置数量 3 の数量単位を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMsgToIm(String msgToIm) 区分: 在庫管理への出力を設定します。
void | setPlacement(String placement) 在庫受入に対する保管域タイプ検索区分を設定します。
void | setProcureUn(String procureUn) 保管容量消費の数量単位を設定します。
void | setProcureUnIso(String procureUnIso) ISO コードでの保管容量消費の数量単位を設定します。
void | setRefUnit(String refUnit) 品目マスタレコードの数量単位初期値を設定します。
void | setSpecMvmt(String specMvmt) 倉庫管理の特殊移動区分を設定します。
void | setStgesector(String stgesector) 保管区画区分を設定します。
void | setStgeType(String stgeType) 概略計画および詳細計画のピッキング保管域タイプを設定します。
void | setTwoStepPick(String twoStepPick) ツーステップピッキング適用品目を設定します。
void | setUnittype1(String unittype1) 第１保管単位タイプを設定します。
void | setUnittype2(String unittype2) 第２保管単位タイプを設定します。
void | setUnittype3(String unittype3) 第３保管単位タイプを設定します。
void | setWhseNo(String whseNo) 倉庫番号/複合倉庫を設定します。
void | setWithdrawal(String withdrawal) 在庫払出に対する保管域タイプ区分を設定します。
void | setWmUnit(String wmUnit) 倉庫管理の数量単位を設定します。
void | setWmUnitIso(String wmUnitIso) ISO コードでの倉庫管理単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WarehouseNumberData

public WarehouseNumberData()
倉庫番号データ情報を作成します。

メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getWhseNo

public String getWhseNo()
倉庫番号/複合倉庫を取得します。

戻り値:
whseNo 倉庫番号/複合倉庫

getDelFlag

public String getDelFlag()
WM 倉庫内の全品目データ削除フラグを取得します。

戻り値:
delFlag WM 倉庫内の全品目データ削除フラグ

getStgesector

public String getStgesector()
保管区画区分を取得します。

戻り値:
stgesector 保管区画区分

getPlacement

public String getPlacement()
在庫受入に対する保管域タイプ検索区分を取得します。

戻り値:
placement 在庫受入に対する保管域タイプ検索区分

getWithdrawal

public String getWithdrawal()
在庫払出に対する保管域タイプ区分を取得します。

戻り値:
withdrawal 在庫払出に対する保管域タイプ区分

getLEquip1

public String getLEquip1()
積載装置数量 1を取得します。

戻り値:
lEquip1 積載装置数量 1

getLEquip2

public String getLEquip2()
積載装置数量 2を取得します。

戻り値:
lEquip2 積載装置数量 2

getLEquip3

public String getLEquip3()
積載装置数量 3を取得します。

戻り値:
lEquip3 積載装置数量 3

getLeqUnit1

public String getLeqUnit1()
積載装置数量 1 の数量単位を取得します。

戻り値:
leqUnit1 積載装置数量 1 の数量単位

getLeqUnit1Iso

public String getLeqUnit1Iso()
ISO コードによる積載装置数量 1 の数量単位を取得します。

戻り値:
leqUnit1Iso ISO コードによる積載装置数量 1 の数量単位

getLeqUnit2

public String getLeqUnit2()
積載装置数量 2 の数量単位を取得します。

戻り値:
leqUnit2 積載装置数量 2 の数量単位

getLeqUnit2Iso

public String getLeqUnit2Iso()
ISO コードによる積載装置数量 2 の数量単位を取得します。

戻り値:
leqUnit2Iso ISO コードによる積載装置数量 2 の数量単位

getLeqUnit3

public String getLeqUnit3()
積載装置数量 3 の数量単位を取得します。

戻り値:
leqUnit3 積載装置数量 3 の数量単位

getLeqUnit3Iso

public String getLeqUnit3Iso()
ISO コードによる積載装置数量 3 の数量単位を取得します。

戻り値:
leqUnit3Iso ISO コードによる積載装置数量 3 の数量単位

getUnittype1

public String getUnittype1()
第１保管単位タイプを取得します。

戻り値:
unittype1 第１保管単位タイプ

getUnittype2

public String getUnittype2()
第２保管単位タイプを取得します。

戻り値:
unittype2 第２保管単位タイプ

getUnittype3

public String getUnittype3()
第３保管単位タイプを取得します。

戻り値:
unittype3 第３保管単位タイプ

getWmUnit

public String getWmUnit()
倉庫管理の数量単位を取得します。

戻り値:
wmUnit 倉庫管理の数量単位

getWmUnitIso

public String getWmUnitIso()
ISO コードでの倉庫管理単位を取得します。

戻り値:
wmUnitIso ISO コードでの倉庫管理単位

getAddToStk

public String getAddToStk()
既存在庫への追加許可を取得します。

戻り値:
addToStk 既存在庫への追加許可

getBlockStge

public String getBlockStge()
平置保管域区分を取得します。

戻り値:
blockStge 平置保管域区分

getMsgToIm

public String getMsgToIm()
区分: 在庫管理への出力を取得します。

戻り値:
msgToIm 区分: 在庫管理への出力

getSpecMvmt

public String getSpecMvmt()
倉庫管理の特殊移動区分を取得します。

戻り値:
specMvmt 倉庫管理の特殊移動区分

getCapyUsage

public String getCapyUsage()
保管容量使用を取得します。

戻り値:
capyUsage 保管容量使用

getProcureUn

public String getProcureUn()
保管容量消費の数量単位を取得します。

戻り値:
procureUn 保管容量消費の数量単位

getProcureUnIso

public String getProcureUnIso()
ISO コードでの保管容量消費の数量単位を取得します。

戻り値:
procureUnIso ISO コードでの保管容量消費の数量単位

getStgeType

public String getStgeType()
概略計画および詳細計画のピッキング保管域タイプを取得します。

戻り値:
stgeType 概略計画および詳細計画のピッキング保管域タイプ

getRefUnit

public String getRefUnit()
品目マスタレコードの数量単位初期値を取得します。

戻り値:
refUnit 品目マスタレコードの数量単位初期値

getTwoStepPick

public String getTwoStepPick()
ツーステップピッキング適用品目を取得します。

戻り値:
twoStepPick ツーステップピッキング適用品目

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setWhseNo

public void setWhseNo(String whseNo)
倉庫番号/複合倉庫を設定します。

パラメータ:
whseNo - 倉庫番号/複合倉庫

setDelFlag

public void setDelFlag(String delFlag)
WM 倉庫内の全品目データ削除フラグを設定します。

パラメータ:
delFlag - WM 倉庫内の全品目データ削除フラグ

setStgesector

public void setStgesector(String stgesector)
保管区画区分を設定します。

パラメータ:
stgesector - 保管区画区分

setPlacement

public void setPlacement(String placement)
在庫受入に対する保管域タイプ検索区分を設定します。

パラメータ:
placement - 在庫受入に対する保管域タイプ検索区分

setWithdrawal

public void setWithdrawal(String withdrawal)
在庫払出に対する保管域タイプ区分を設定します。

パラメータ:
withdrawal - 在庫払出に対する保管域タイプ区分

setLEquip1

public void setLEquip1(String lEquip1)
積載装置数量 1を設定します。

パラメータ:
lEquip1 - 積載装置数量 1

setLEquip2

public void setLEquip2(String lEquip2)
積載装置数量 2を設定します。

パラメータ:
lEquip2 - 積載装置数量 2

setLEquip3

public void setLEquip3(String lEquip3)
積載装置数量 3を設定します。

パラメータ:
lEquip3 - 積載装置数量 3

setLeqUnit1

public void setLeqUnit1(String leqUnit1)
積載装置数量 1 の数量単位を設定します。

パラメータ:
leqUnit1 - 積載装置数量 1 の数量単位

setLeqUnit1Iso

public void setLeqUnit1Iso(String leqUnit1Iso)
ISO コードによる積載装置数量 1 の数量単位を設定します。

パラメータ:
leqUnit1Iso - ISO コードによる積載装置数量 1 の数量単位

setLeqUnit2

public void setLeqUnit2(String leqUnit2)
積載装置数量 2 の数量単位を設定します。

パラメータ:
leqUnit2 - 積載装置数量 2 の数量単位

setLeqUnit2Iso

public void setLeqUnit2Iso(String leqUnit2Iso)
ISO コードによる積載装置数量 2 の数量単位を設定します。

パラメータ:
leqUnit2Iso - ISO コードによる積載装置数量 2 の数量単位

setLeqUnit3

public void setLeqUnit3(String leqUnit3)
積載装置数量 3 の数量単位を設定します。

パラメータ:
leqUnit3 - 積載装置数量 3 の数量単位

setLeqUnit3Iso

public void setLeqUnit3Iso(String leqUnit3Iso)
ISO コードによる積載装置数量 3 の数量単位を設定します。

パラメータ:
leqUnit3Iso - ISO コードによる積載装置数量 3 の数量単位

setUnittype1

public void setUnittype1(String unittype1)
第１保管単位タイプを設定します。

パラメータ:
unittype1 - 第１保管単位タイプ

setUnittype2

public void setUnittype2(String unittype2)
第２保管単位タイプを設定します。

パラメータ:
unittype2 - 第２保管単位タイプ

setUnittype3

public void setUnittype3(String unittype3)
第３保管単位タイプを設定します。

パラメータ:
unittype3 - 第３保管単位タイプ

setWmUnit

public void setWmUnit(String wmUnit)
倉庫管理の数量単位を設定します。

パラメータ:
wmUnit - 倉庫管理の数量単位

setWmUnitIso

public void setWmUnitIso(String wmUnitIso)
ISO コードでの倉庫管理単位を設定します。

パラメータ:
wmUnitIso - ISO コードでの倉庫管理単位

setAddToStk

public void setAddToStk(String addToStk)
既存在庫への追加許可を設定します。

パラメータ:
addToStk - 既存在庫への追加許可

setBlockStge

public void setBlockStge(String blockStge)
平置保管域区分を設定します。

パラメータ:
blockStge - 平置保管域区分

setMsgToIm

public void setMsgToIm(String msgToIm)
区分: 在庫管理への出力を設定します。

パラメータ:
msgToIm - 区分: 在庫管理への出力

setSpecMvmt

public void setSpecMvmt(String specMvmt)
倉庫管理の特殊移動区分を設定します。

パラメータ:
specMvmt - 倉庫管理の特殊移動区分

setCapyUsage

public void setCapyUsage(String capyUsage)
保管容量使用を設定します。

パラメータ:
capyUsage - 保管容量使用

setProcureUn

public void setProcureUn(String procureUn)
保管容量消費の数量単位を設定します。

パラメータ:
procureUn - 保管容量消費の数量単位

setProcureUnIso

public void setProcureUnIso(String procureUnIso)
ISO コードでの保管容量消費の数量単位を設定します。

パラメータ:
procureUnIso - ISO コードでの保管容量消費の数量単位

setStgeType

public void setStgeType(String stgeType)
概略計画および詳細計画のピッキング保管域タイプを設定します。

パラメータ:
stgeType - 概略計画および詳細計画のピッキング保管域タイプ

setRefUnit

public void setRefUnit(String refUnit)
品目マスタレコードの数量単位初期値を設定します。

パラメータ:
refUnit - 品目マスタレコードの数量単位初期値

setTwoStepPick

public void setTwoStepPick(String twoStepPick)
ツーステップピッキング適用品目を設定します。

パラメータ:
twoStepPick - ツーステップピッキング適用品目

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


WarehouseNumberDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.common.model
クラス WarehouseNumberDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList
すべての実装インタフェース:
Serializable
public class WarehouseNumberDataList
extends WarehouseNumberData
implements Serializable

倉庫番号データ情報クラス
機能は以下の通り

  • 倉庫番号データ情報をテーブル型で保持します。

関連項目:
直列化された形式

コンストラクタの概要
WarehouseNumberDataList()
倉庫番号データ情報を作成します。
WarehouseNumberDataList(int index)
倉庫番号データ情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData から継承したメソッド
getAddToStk, getBlockStge, getCapyUsage, getDelFlag, getFunction, getLEquip1, getLEquip2, getLEquip3, getLeqUnit1, getLeqUnit1Iso, getLeqUnit2, getLeqUnit2Iso, getLeqUnit3, getLeqUnit3Iso, getMaterial, getMsgToIm, getPlacement, getProcureUn, getProcureUnIso, getRefUnit, getSpecMvmt, getStgesector, getStgeType, getTwoStepPick, getUnittype1, getUnittype2, getUnittype3, getWhseNo, getWithdrawal, getWmUnit, getWmUnitIso, setAddToStk, setBlockStge, setCapyUsage, setDelFlag, setFunction, setLEquip1, setLEquip2, setLEquip3, setLeqUnit1, setLeqUnit1Iso, setLeqUnit2, setLeqUnit2Iso, setLeqUnit3, setLeqUnit3Iso, setMaterial, setMsgToIm, setPlacement, setProcureUn, setProcureUnIso, setRefUnit, setSpecMvmt, setStgesector, setStgeType, setTwoStepPick, setUnittype1, setUnittype2, setUnittype3, setWhseNo, setWithdrawal, setWmUnit, setWmUnitIso, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WarehouseNumberDataList

public WarehouseNumberDataList()
倉庫番号データ情報を作成します。

WarehouseNumberDataList

public WarehouseNumberDataList(int index)
倉庫番号データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException の使用

SAPPurchaseAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase での SAPPurchaseAppException の使用

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPPurchaseAppException の使用

SAPPurchaseAppException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException の使用

SAPPurchaseSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase での SAPPurchaseSystemException の使用

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 void SupplierGetDetailController.executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 void SupplierExistenceCheckController.executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 void SupplierExistenceCheck.executeBapi()
BapiControllerにより仕入先コード存在チェックを作成します。
 void SupplierDetail.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void PurchaseResetReleaseController.executeBapi()
伝票承認取消処理を実行します。
 void PurchaseReleaseController.executeBapi()
伝票承認処理を実行します。
 String PurchaseReleaseController.getRetCode()
リターン値、ABAP 命令後のリターン値を取得します。
 void PurchaseOrderPostChangeController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
 void PurchaseOrderPayPostController.executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
 ArrayList PurchaseOrderPayPost.getItemTextList()
明細テキスト一覧を取得します｡
 void PurchaseOrderPayPost.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void PurchaseOrderPayPost.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void PurchaseGetItemSrelController.executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 void PurchaseGetItemSrel.executeBapi()
BapiControllerにより仕入先マスタ詳細を作成します。
 void MaterialSaveReplicaController.executeBapi()
BapiControllerにより品目マスタを更新します。
 void MaterialSaveReplicaController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialGetList.setImportParam(BapiController bapiController)
品目コードを検索する条件ををセットします。
 void MaterialGetList.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialGetAllController.executeBapi()
BapiControllerにより品目マスタ照会を行います。
 void MaterialGetAllController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void MaterialAvailabilityController.executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void MaterialAvailabilityController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtGetItemsController.executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtGetItemsController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtCreateController.executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
 void GoodsMvtCreateController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void GoodsMvtCreateController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase のコンストラクタ
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber での SAPPurchaseSystemException の使用

SAPPurchaseSystemException をスローする jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber のコンストラクタ
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.purchase.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.exception
例外
SAPPurchaseAppException
SAPPurchaseSystemException


jp.co.intra_mart.foundation.sap.module.purchase.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception

ＳＡＰ連携経費購買系例外クラスを提供します。

参照:
説明

例外の概要
SAPPurchaseAppException | 購買系APIアプリケーション例外クラス
SAPPurchaseSystemException | 購買系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の説明

ＳＡＰ連携経費購買系例外クラスを提供します。


jp.co.intra_mart.foundation.sap.module.purchase.exception クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.exception の使用

jp.co.intra_mart.foundation.sap.module.purchase.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.exception のクラス
SAPPurchaseAppException
購買系APIアプリケーション例外クラス
SAPPurchaseSystemException
購買系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.module.purchase.exception のクラス
SAPPurchaseAppException
購買系APIアプリケーション例外クラス
SAPPurchaseSystemException
購買系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPPurchaseAppException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.exception
クラス SAPPurchaseAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
すべての実装インタフェース:
Serializable
public class SAPPurchaseAppException
extends SAPModuleAppException

購買系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPPurchaseAppException(String message)
購買系APIアプリケーション例外
SAPPurchaseAppException(String message, Throwable ex)
購買系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPPurchaseAppException

public SAPPurchaseAppException(String message,
                               Throwable ex)
購買系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPPurchaseAppException

public SAPPurchaseAppException(String message)
購買系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPPurchaseSystemException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.exception
クラス SAPPurchaseSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException
すべての実装インタフェース:
Serializable
public class SAPPurchaseSystemException
extends SAPModuleSystemException

購買系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPPurchaseSystemException(String message, Throwable ex)
購買系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPPurchaseSystemException

public SAPPurchaseSystemException(String message,
                                  Throwable ex)
購買系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode の使用

GoodsMvtCode を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtCode の使用

GoodsMvtCode を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtCode GoodsMvtCreate.getGoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当を取得します。

GoodsMvtCode 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtCode.setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当の値をセットします。
void | GoodsMvtCreate.setGoodsMvtCode(GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate の使用

GoodsMvtCreate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtCreate の使用

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtCreate のサブクラス
 class GoodsMvtCreateController
入庫伝票登録コントローラクラス
機能は以下の通り
入庫伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret の使用

GoodsMvtHeadret を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate での GoodsMvtHeadret の使用

GoodsMvtHeadret を返す jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
 GoodsMvtHeadret GoodsMvtCreate.getGoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度を取得します。

GoodsMvtHeadret 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のメソッド
static void | ParamGoodsMvtHeadret.setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票ヘッダデータの値をセットします。
void | GoodsMvtCreate.setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票番号/入出庫伝票会計年度を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


GoodsMvtCode (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtCode

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode
すべての実装インタフェース:
Serializable
public class GoodsMvtCode
extends Object
implements Serializable

在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り

  • 在庫移動に対するコードのトランザクションへの割当情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当情報を作成します。
メソッドの概要
String | getGmCode() BAPI 在庫移動トランザクションのコード割当を取得します。
void | setGmCode(String gmCode) BAPI 在庫移動トランザクションのコード割当を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCode

public GoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当情報を作成します。

メソッドの詳細

getGmCode

public String getGmCode()
BAPI 在庫移動トランザクションのコード割当を取得します。

戻り値:
gmCode BAPI 在庫移動トランザクションのコード割当

setGmCode

public void setGmCode(String gmCode)
BAPI 在庫移動トランザクションのコード割当を設定します。

パラメータ:
gmCode - BAPI 在庫移動トランザクションのコード割当

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCreate (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtCreate

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtCreateController
public class GoodsMvtCreate
extends UpdateController
implements Serializable

入出庫伝票登録情報クラス
機能は以下の通り

  • 入出庫伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtCreate()
コンストラクタ。
GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
GoodsMvtCode | getGoodsMvtCode() 在庫移動に対するコードのトランザクションへの割当を取得します。
GoodsMvtHeader | getGoodsMvtHeader() 入出庫伝票ヘッダデータを取得します。
GoodsMvtHeadret | getGoodsMvtHeadret() 入出庫伝票番号/入出庫伝票会計年度を取得します。
List | getGoodsMvtItemList() 入出庫伝票明細を取得します。
List | getGoodsMvtSerialNumberList() シリアル番号を取得します。
String | getMatdocumentyear() 入出庫伝票会計年度を取得します。
String | getMaterialdocument() 入出庫伝票番号を取得します。
String | getTestrun() 在庫移動シミュレーションを取得します。
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setGoodsMvtCode(GoodsMvtCode goodsMvtCode) 在庫移動に対するコードのトランザクションへの割当を設定します。
void | setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader) 入出庫伝票ヘッダデータを設定します。
void | setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret) 入出庫伝票番号/入出庫伝票会計年度を設定します。
void | setGoodsMvtItemList(List goodsMvtItemList) 入出庫伝票明細を設定します。
void | setGoodsMvtSerialNumberList(List goodsMvtSerialNumberList) シリアル番号を設定します。
void | setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | setMatdocumentyear(String matdocumentyear) 入出庫伝票会計年度を設定します。
void | setMaterialdocument(String materialdocument) 入出庫伝票番号を設定します。
void | setTestrun(String testrun) 在庫移動シミュレーションを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCreate

public GoodsMvtCreate()
コンストラクタ。

GoodsMvtCreate

public GoodsMvtCreate(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

GoodsMvtCreate

public GoodsMvtCreate(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
在庫移動シミュレーションを取得します。

戻り値:
testrun 在庫移動シミュレーション

getMatdocumentyear

public String getMatdocumentyear()
入出庫伝票会計年度を取得します。

戻り値:
matdocumentyear 入出庫伝票会計年度

getMaterialdocument

public String getMaterialdocument()
入出庫伝票番号を取得します。

戻り値:
materialdocument 入出庫伝票番号

getGoodsMvtCode

public GoodsMvtCode getGoodsMvtCode()
在庫移動に対するコードのトランザクションへの割当を取得します。

戻り値:
goodsMvtCode 在庫移動に対するコードのトランザクションへの割当

getGoodsMvtHeader

public GoodsMvtHeader getGoodsMvtHeader()
入出庫伝票ヘッダデータを取得します。

戻り値:
goodsMvtHeader 入出庫伝票ヘッダデータ

getGoodsMvtHeadret

public GoodsMvtHeadret getGoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度を取得します。

戻り値:
goodsMvtHeadret 入出庫伝票番号/入出庫伝票会計年度

getGoodsMvtItemList

public List getGoodsMvtItemList()
入出庫伝票明細を取得します。

戻り値:
goodsMvtItemList 入出庫伝票明細

getGoodsMvtSerialNumberList

public List getGoodsMvtSerialNumberList()
シリアル番号を取得します。

戻り値:
goodsMvtSerialNumberList シリアル番号

setTestrun

public void setTestrun(String testrun)
在庫移動シミュレーションを設定します。

パラメータ:
testrun - 在庫移動シミュレーション

setMatdocumentyear

public void setMatdocumentyear(String matdocumentyear)
入出庫伝票会計年度を設定します。

パラメータ:
matdocumentyear - 入出庫伝票会計年度

setMaterialdocument

public void setMaterialdocument(String materialdocument)
入出庫伝票番号を設定します。

パラメータ:
materialdocument - 入出庫伝票番号

setGoodsMvtCode

public void setGoodsMvtCode(GoodsMvtCode goodsMvtCode)
在庫移動に対するコードのトランザクションへの割当を設定します。

パラメータ:
goodsMvtCode - 在庫移動に対するコードのトランザクションへの割当

setGoodsMvtHeader

public void setGoodsMvtHeader(GoodsMvtHeader goodsMvtHeader)
入出庫伝票ヘッダデータを設定します。

パラメータ:
goodsMvtHeader - 入出庫伝票ヘッダデータ

setGoodsMvtHeadret

public void setGoodsMvtHeadret(GoodsMvtHeadret goodsMvtHeadret)
入出庫伝票番号/入出庫伝票会計年度を設定します。

パラメータ:
goodsMvtHeadret - 入出庫伝票番号/入出庫伝票会計年度

setGoodsMvtItemList

public void setGoodsMvtItemList(List goodsMvtItemList)
入出庫伝票明細を設定します。

パラメータ:
goodsMvtItemList - 入出庫伝票明細

setGoodsMvtSerialNumberList

public void setGoodsMvtSerialNumberList(List goodsMvtSerialNumberList)
シリアル番号を設定します。

パラメータ:
goodsMvtSerialNumberList - シリアル番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtHeadret (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtHeadret

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret
すべての実装インタフェース:
Serializable
public class GoodsMvtHeadret
extends Object
implements Serializable

入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り

  • 入出庫伝票番号/入出庫伝票会計年度情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度情報を作成します。
メソッドの概要
String | getDocYear() 入出庫伝票年度を取得します。
String | getMatDoc() 入出庫伝票番号を取得します。
void | setDocYear(String docYear) 入出庫伝票年度を設定します。
void | setMatDoc(String matDoc) 入出庫伝票番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtHeadret

public GoodsMvtHeadret()
入出庫伝票番号/入出庫伝票会計年度情報を作成します。

メソッドの詳細

getMatDoc

public String getMatDoc()
入出庫伝票番号を取得します。

戻り値:
matDoc 入出庫伝票番号

getDocYear

public String getDocYear()
入出庫伝票年度を取得します。

戻り値:
docYear 入出庫伝票年度

setMatDoc

public void setMatDoc(String matDoc)
入出庫伝票番号を設定します。

パラメータ:
matDoc - 入出庫伝票番号

setDocYear

public void setDocYear(String docYear)
入出庫伝票年度を設定します。

パラメータ:
docYear - 入出庫伝票年度

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem
すべての実装インタフェース:
Serializable
public class GoodsMvtItem
extends Object
implements Serializable

入出庫伝票明細情報クラス
機能は以下の通り

  • 入出庫伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtItem()
入出庫伝票明細情報を作成します。
GoodsMvtItem(int index)
入出庫伝票明細情報を作成します。
メソッドの概要
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAmountLc() マニュアル入力による転記金額 (国内通貨)を取得します。
String | getAmountSv() 外部入力による販売金額 (国内通貨)を取得します。
String | getAssetNo() 資産番号を取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBatch() ロット番号を取得します。
String | getCalcMotive() 計算区分を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCompShip() 出荷指示順守を取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostObj() 原価対象を取得します。
String | getCustomer() 得意先コードを取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivItemToSearch() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDelivNumbToSearch() 出荷伝票を取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getEntryQnt() 入力単位での数量を取得します。
String | getEntryUom() 入力単位を取得します。
String | getEntryUomIso() 単位の ISO コードを取得します。
String | getExpirydate() 有効期間期限日を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrNumber() 入庫番号を取得します。
String | getGrRcpt() 受領者を取得します。
String | getGrRcptx() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getIndProposeQuanx() 提案数量 (初期数量)を取得します。
String | getItemText() 明細テキストを取得します。
String | getLineDepth() 伝票での明細行階層レベルを取得します。
String | getLineId() 伝票明細行の一意 IDを取得します。
String | getMatdocTrCancel() 取消予定の転送要求の入出庫伝票番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatitemTrCancel() 取消予定の転送数量入出庫伝票明細を取得します。
String | getMatyearTrCancel() 取消予定の転送要求入出庫伝票年度を取得します。
String | getMoveBatch() 入庫/出庫ロットを取得します。
String | getMoveMat() 入庫/出庫品目を取得します。
String | getMoveMatExternal() 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getMoveMatGuid() 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getMoveMatVersion() 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getMovePlant() 入庫/出庫プラントを取得します。
String | getMoveReas() 移動理由を取得します。
String | getMoveStloc() 入庫/出庫保管場所を取得します。
String | getMoveType() 移動タイプ (在庫管理)を取得します。
String | getMoveValType() 転送ロットの評価タイプを取得します。
String | getMvtInd() 移動区分を取得します。
String | getNbSlips() 入庫/出庫票の印刷部数を取得します。
String | getNbSlipsx() 関連ユーザデータ項目の更新情報を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNoMoreGr() 納入完了 区分を取得します。
String | getNoPstChgnt() 区分: 振替要求通知登録禁止を取得します。
String | getNoTransferReq() 区分: 転送要求未登録を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderItno() 指図明細番号を取得します。
String | getOrderprUn() 購買発注価格単位 (購買管理)を取得します。
String | getOrderprUnIso() 単位の ISO コードを取得します。
String | getParCompco() 決済会社コードを取得します。
String | getParentId() 1 レベル上位の行 IDを取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買発注番号を取得します。
String | getPoPrQnt() 数量 (購買発注価格単位)を取得します。
String | getProdDate() ロット製造日付を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getQuantity() 数量を取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getRefDoc() 参照伝票の伝票番号を取得します。
String | getRefDocIt() 参照伝票の明細番号を取得します。
String | getRefDocYr() 参照伝票の会計年度を取得します。
String | getReservNo() 入出庫予定/従属所要量の番号を取得します。
String | getResItem() 入出庫予定/従属所要量の明細番号を取得します。
String | getResType() レコードタイプを取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSalesOrd() 受注伝票番号を取得します。
String | getSchedLine() 受注納入日程を取得します。
String | getSerialnoAutoNumberassignment() シリアル番号の自動登録を取得します。
String | getShipping() 出荷指示を取得します。
String | getSOrdItem() 受注明細番号を取得します。
String | getSpecMvmt() 倉庫管理の特殊移動区分を取得します。
String | getSpecStock() 特殊在庫区分を取得します。
String | getStckType() 在庫タイプを取得します。
String | getStgeBin() 棚番を取得します。
String | getStgeBinPc() 在庫転送棚番を取得します。
String | getStgeBinSt() 在庫転送棚番を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStgeType() 保管域タイプを取得します。
String | getStgeTypePc() 在庫転送の保管域タイプを取得します。
String | getStgeTypeSt() 在庫転送の保管域タイプを取得します。
String | getStUnQtyy1() 代替数量単位での在庫受入予定保管単位別数量を取得します。
String | getStUnQtyy1Iso() 単位の ISO コードを取得します。
String | getStUnQtyy2() 代替数量単位での在庫受入予定保管単位別数量を取得します。
String | getStUnQtyy2Iso() 単位の ISO コードを取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getSuPlStck1() 在庫受入予定の保管単位数を取得します。
String | getSuPlStck2() 在庫受入予定の保管単位数を取得します。
String | getSupplVend() 供給仕入先を取得します。
String | getTrPartBa() 取引会社事業領域を取得します。
String | getUnittype1() 保管単位タイプを取得します。
String | getUnittype2() 保管単位タイプを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getUnloadPtx() 関連ユーザデータ項目の更新情報を取得します。
String | getValSalesOrd() 評価受注在庫の受注番号を取得します。
String | getValSOrdItem() 評価受注在庫の受注明細を取得します。
String | getValType() 評価タイプを取得します。
String | getValWbsElem() WBS 要素を取得します。
String | getVendor() 仕入先勘定コードを取得します。
String | getVendrbatch() 仕入先ロット番号を取得します。
String | getWbsElem() WBS 要素を取得します。
String | getWithdrawn() 入出庫予定に対する出庫完了を取得します。
String | getXstob() 取消移動タイプ区分の使用を取得します。
void | setActivity(String activity) 作業番号を設定します。
void | setActtype(String acttype) 活動タイプを設定します。
void | setAmountLc(String amountLc) マニュアル入力による転記金額 (国内通貨)を設定します。
void | setAmountSv(String amountSv) 外部入力による販売金額 (国内通貨)を設定します。
void | setAssetNo(String assetNo) 資産番号を設定します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setCalcMotive(String calcMotive) 計算区分を設定します。
void | setCmmtItem(String cmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String cmmtItemLong) 資金予算コードを設定します。
void | setCoBusproc(String coBusproc) 業務プロセスを設定します。
void | setCompShip(String compShip) 出荷指示順守を設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCostObj(String costObj) 原価対象を設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivItemToSearch(String delivItemToSearch) 出荷明細を設定します。
void | setDelivNumb(String delivNumb) 出荷伝票を設定します。
void | setDelivNumbToSearch(String delivNumbToSearch) 出荷伝票を設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setEntryQnt(String entryQnt) 入力単位での数量を設定します。
void | setEntryUom(String entryUom) 入力単位を設定します。
void | setEntryUomIso(String entryUomIso) 単位の ISO コードを設定します。
void | setExpirydate(String expirydate) 有効期間期限日を設定します。
void | setFuncArea(String funcArea) 機能領域を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setFund(String fund) 会計区分を設定します。
void | setFundsCtr(String fundsCtr) 予算センタを設定します。
void | setGlAccount(String glAccount) G/L 勘定コードを設定します。
void | setGrantNbr(String grantNbr) 補助金を設定します。
void | setGrNumber(String grNumber) 入庫番号を設定します。
void | setGrRcpt(String grRcpt) 受領者を設定します。
void | setGrRcptx(String grRcptx) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIndProposeQuanx(String indProposeQuanx) 提案数量 (初期数量)を設定します。
void | setItemText(String itemText) 明細テキストを設定します。
void | setLineDepth(String lineDepth) 伝票での明細行階層レベルを設定します。
void | setLineId(String lineId) 伝票明細行の一意 IDを設定します。
void | setMatdocTrCancel(String matdocTrCancel) 取消予定の転送要求の入出庫伝票番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatitemTrCancel(String matitemTrCancel) 取消予定の転送数量入出庫伝票明細を設定します。
void | setMatyearTrCancel(String matyearTrCancel) 取消予定の転送要求入出庫伝票年度を設定します。
void | setMoveBatch(String moveBatch) 入庫/出庫ロットを設定します。
void | setMoveMat(String moveMat) 入庫/出庫品目を設定します。
void | setMoveMatExternal(String moveMatExternal) 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setMoveMatGuid(String moveMatGuid) 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setMoveMatVersion(String moveMatVersion) 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setMovePlant(String movePlant) 入庫/出庫プラントを設定します。
void | setMoveReas(String moveReas) 移動理由を設定します。
void | setMoveStloc(String moveStloc) 入庫/出庫保管場所を設定します。
void | setMoveType(String moveType) 移動タイプ (在庫管理)を設定します。
void | setMoveValType(String moveValType) 転送ロットの評価タイプを設定します。
void | setMvtInd(String mvtInd) 移動区分を設定します。
void | setNbSlips(String nbSlips) 入庫/出庫票の印刷部数を設定します。
void | setNbSlipsx(String nbSlipsx) 関連ユーザデータ項目の更新情報を設定します。
void | setNetwork(String network) 勘定割当のネットワーク番号を設定します。
void | setNoMoreGr(String noMoreGr) 納入完了 区分を設定します。
void | setNoPstChgnt(String noPstChgnt) 区分: 振替要求通知登録禁止を設定します。
void | setNoTransferReq(String noTransferReq) 区分: 転送要求未登録を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderItno(String orderItno) 指図明細番号を設定します。
void | setOrderprUn(String orderprUn) 購買発注価格単位 (購買管理)を設定します。
void | setOrderprUnIso(String orderprUnIso) 単位の ISO コードを設定します。
void | setParCompco(String parCompco) 決済会社コードを設定します。
void | setParentId(String parentId) 1 レベル上位の行 IDを設定します。
void | setPartAcct(String partAcct) 取引先勘定コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPoItem(String poItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String poNumber) 購買発注番号を設定します。
void | setPoPrQnt(String poPrQnt) 数量 (購買発注価格単位)を設定します。
void | setProdDate(String prodDate) ロット製造日付を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setQuantity(String quantity) 数量を設定します。
void | setRefDate(String refDate) 決済の参照日付を設定します。
void | setRefDoc(String refDoc) 参照伝票の伝票番号を設定します。
void | setRefDocIt(String refDocIt) 参照伝票の明細番号を設定します。
void | setRefDocYr(String refDocYr) 参照伝票の会計年度を設定します。
void | setReservNo(String reservNo) 入出庫予定/従属所要量の番号を設定します。
void | setResItem(String resItem) 入出庫予定/従属所要量の明細番号を設定します。
void | setResType(String resType) レコードタイプを設定します。
void | setRlEstKey(String rlEstKey) 不動産管理対象の内部キーを設定します。
void | setSalesOrd(String salesOrd) 受注伝票番号を設定します。
void | setSchedLine(String schedLine) 受注納入日程を設定します。
void | setSerialnoAutoNumberassignment(String serialnoAutoNumberassignment) シリアル番号の自動登録を設定します。
void | setShipping(String shipping) 出荷指示を設定します。
void | setSOrdItem(String sOrdItem) 受注明細番号を設定します。
void | setSpecMvmt(String specMvmt) 倉庫管理の特殊移動区分を設定します。
void | setSpecStock(String specStock) 特殊在庫区分を設定します。
void | setStckType(String stckType) 在庫タイプを設定します。
void | setStgeBin(String stgeBin) 棚番を設定します。
void | setStgeBinPc(String stgeBinPc) 在庫転送棚番を設定します。
void | setStgeBinSt(String stgeBinSt) 在庫転送棚番を設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStgeType(String stgeType) 保管域タイプを設定します。
void | setStgeTypePc(String stgeTypePc) 在庫転送の保管域タイプを設定します。
void | setStgeTypeSt(String stgeTypeSt) 在庫転送の保管域タイプを設定します。
void | setStUnQtyy1(String stUnQtyy1) 代替数量単位での在庫受入予定保管単位別数量を設定します。
void | setStUnQtyy1Iso(String stUnQtyy1Iso) 単位の ISO コードを設定します。
void | setStUnQtyy2(String stUnQtyy2) 代替数量単位での在庫受入予定保管単位別数量を設定します。
void | setStUnQtyy2Iso(String stUnQtyy2Iso) 単位の ISO コードを設定します。
void | setSubNumber(String subNumber) 資産補助番号を設定します。
void | setSuPlStck1(String suPlStck1) 在庫受入予定の保管単位数を設定します。
void | setSuPlStck2(String suPlStck2) 在庫受入予定の保管単位数を設定します。
void | setSupplVend(String supplVend) 供給仕入先を設定します。
void | setTrPartBa(String trPartBa) 取引会社事業領域を設定します。
void | setUnittype1(String unittype1) 保管単位タイプを設定します。
void | setUnittype2(String unittype2) 保管単位タイプを設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
void | setUnloadPtx(String unloadPtx) 関連ユーザデータ項目の更新情報を設定します。
void | setValSalesOrd(String valSalesOrd) 評価受注在庫の受注番号を設定します。
void | setValSOrdItem(String valSOrdItem) 評価受注在庫の受注明細を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setValWbsElem(String valWbsElem) WBS 要素を設定します。
void | setVendor(String vendor) 仕入先勘定コードを設定します。
void | setVendrbatch(String vendrbatch) 仕入先ロット番号を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWithdrawn(String withdrawn) 入出庫予定に対する出庫完了を設定します。
void | setXstob(String xstob) 取消移動タイプ区分の使用を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtItem

public GoodsMvtItem()
入出庫伝票明細情報を作成します。

GoodsMvtItem

public GoodsMvtItem(int index)
入出庫伝票明細情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getMoveType

public String getMoveType()
移動タイプ (在庫管理)を取得します。

戻り値:
moveType 移動タイプ (在庫管理)

getStckType

public String getStckType()
在庫タイプを取得します。

戻り値:
stckType 在庫タイプ

getSpecStock

public String getSpecStock()
特殊在庫区分を取得します。

戻り値:
specStock 特殊在庫区分

getVendor

public String getVendor()
仕入先勘定コードを取得します。

戻り値:
vendor 仕入先勘定コード

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getSalesOrd

public String getSalesOrd()
受注伝票番号を取得します。

戻り値:
salesOrd 受注伝票番号

getSOrdItem

public String getSOrdItem()
受注明細番号を取得します。

戻り値:
sOrdItem 受注明細番号

getSchedLine

public String getSchedLine()
受注納入日程を取得します。

戻り値:
schedLine 受注納入日程

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getEntryQnt

public String getEntryQnt()
入力単位での数量を取得します。

戻り値:
entryQnt 入力単位での数量

getEntryUom

public String getEntryUom()
入力単位を取得します。

戻り値:
entryUom 入力単位

getEntryUomIso

public String getEntryUomIso()
単位の ISO コードを取得します。

戻り値:
entryUomIso 単位の ISO コード

getPoPrQnt

public String getPoPrQnt()
数量 (購買発注価格単位)を取得します。

戻り値:
poPrQnt 数量 (購買発注価格単位)

getOrderprUn

public String getOrderprUn()
購買発注価格単位 (購買管理)を取得します。

戻り値:
orderprUn 購買発注価格単位 (購買管理)

getOrderprUnIso

public String getOrderprUnIso()
単位の ISO コードを取得します。

戻り値:
orderprUnIso 単位の ISO コード

getPoNumber

public String getPoNumber()
購買発注番号を取得します。

戻り値:
poNumber 購買発注番号

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
poItem 購買伝票の明細番号

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
shipping 出荷指示

getCompShip

public String getCompShip()
出荷指示順守を取得します。

戻り値:
compShip 出荷指示順守

getNoMoreGr

public String getNoMoreGr()
納入完了 区分を取得します。

戻り値:
noMoreGr 納入完了 区分

getItemText

public String getItemText()
明細テキストを取得します。

戻り値:
itemText 明細テキスト

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
grRcpt 受領者

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getOrderItno

public String getOrderItno()
指図明細番号を取得します。

戻り値:
orderItno 指図明細番号

getCalcMotive

public String getCalcMotive()
計算区分を取得します。

戻り値:
calcMotive 計算区分

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
assetNo 資産番号

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
subNumber 資産補助番号

getReservNo

public String getReservNo()
入出庫予定/従属所要量の番号を取得します。

戻り値:
reservNo 入出庫予定/従属所要量の番号

getResItem

public String getResItem()
入出庫予定/従属所要量の明細番号を取得します。

戻り値:
resItem 入出庫予定/従属所要量の明細番号

getResType

public String getResType()
レコードタイプを取得します。

戻り値:
resType レコードタイプ

getWithdrawn

public String getWithdrawn()
入出庫予定に対する出庫完了を取得します。

戻り値:
withdrawn 入出庫予定に対する出庫完了

getMoveMat

public String getMoveMat()
入庫/出庫品目を取得します。

戻り値:
moveMat 入庫/出庫品目

getMovePlant

public String getMovePlant()
入庫/出庫プラントを取得します。

戻り値:
movePlant 入庫/出庫プラント

getMoveStloc

public String getMoveStloc()
入庫/出庫保管場所を取得します。

戻り値:
moveStloc 入庫/出庫保管場所

getMoveBatch

public String getMoveBatch()
入庫/出庫ロットを取得します。

戻り値:
moveBatch 入庫/出庫ロット

getMoveValType

public String getMoveValType()
転送ロットの評価タイプを取得します。

戻り値:
moveValType 転送ロットの評価タイプ

getMvtInd

public String getMvtInd()
移動区分を取得します。

戻り値:
mvtInd 移動区分

getMoveReas

public String getMoveReas()
移動理由を取得します。

戻り値:
moveReas 移動理由

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
rlEstKey 不動産管理対象の内部キー

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
refDate 決済の参照日付

getCostObj

public String getCostObj()
原価対象を取得します。

戻り値:
costObj 原価対象

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
network 勘定割当のネットワーク番号

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
activity 作業番号

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
partAcct 取引先勘定コード

getAmountLc

public String getAmountLc()
マニュアル入力による転記金額 (国内通貨)を取得します。

戻り値:
amountLc マニュアル入力による転記金額 (国内通貨)

getAmountSv

public String getAmountSv()
外部入力による販売金額 (国内通貨)を取得します。

戻り値:
amountSv 外部入力による販売金額 (国内通貨)

getRefDocYr

public String getRefDocYr()
参照伝票の会計年度を取得します。

戻り値:
refDocYr 参照伝票の会計年度

getRefDoc

public String getRefDoc()
参照伝票の伝票番号を取得します。

戻り値:
refDoc 参照伝票の伝票番号

getRefDocIt

public String getRefDocIt()
参照伝票の明細番号を取得します。

戻り値:
refDocIt 参照伝票の明細番号

getExpirydate

public String getExpirydate()
有効期間期限日を取得します。

戻り値:
expirydate 有効期間期限日

getProdDate

public String getProdDate()
ロット製造日付を取得します。

戻り値:
prodDate ロット製造日付

getFund

public String getFund()
会計区分を取得します。

戻り値:
fund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
fundsCtr 予算センタ

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
cmmtItem 資金予算コード

getValSalesOrd

public String getValSalesOrd()
評価受注在庫の受注番号を取得します。

戻り値:
valSalesOrd 評価受注在庫の受注番号

getValSOrdItem

public String getValSOrdItem()
評価受注在庫の受注明細を取得します。

戻り値:
valSOrdItem 評価受注在庫の受注明細

getValWbsElem

public String getValWbsElem()
WBS 要素を取得します。

戻り値:
valWbsElem WBS 要素

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
glAccount G/L 勘定コード

getIndProposeQuanx

public String getIndProposeQuanx()
提案数量 (初期数量)を取得します。

戻り値:
indProposeQuanx 提案数量 (初期数量)

getXstob

public String getXstob()
取消移動タイプ区分の使用を取得します。

戻り値:
xstob 取消移動タイプ区分の使用

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getDelivNumbToSearch

public String getDelivNumbToSearch()
出荷伝票を取得します。

戻り値:
delivNumbToSearch 出荷伝票

getDelivItemToSearch

public String getDelivItemToSearch()
出荷明細を取得します。

戻り値:
delivItemToSearch 出荷明細

getSerialnoAutoNumberassignment

public String getSerialnoAutoNumberassignment()
シリアル番号の自動登録を取得します。

戻り値:
serialnoAutoNumberassignment シリアル番号の自動登録

getVendrbatch

public String getVendrbatch()
仕入先ロット番号を取得します。

戻り値:
vendrbatch 仕入先ロット番号

getStgeType

public String getStgeType()
保管域タイプを取得します。

戻り値:
stgeType 保管域タイプ

getStgeBin

public String getStgeBin()
棚番を取得します。

戻り値:
stgeBin 棚番

getSuPlStck1

public String getSuPlStck1()
在庫受入予定の保管単位数を取得します。

戻り値:
suPlStck1 在庫受入予定の保管単位数

getStUnQtyy1

public String getStUnQtyy1()
代替数量単位での在庫受入予定保管単位別数量を取得します。

戻り値:
stUnQtyy1 代替数量単位での在庫受入予定保管単位別数量

getStUnQtyy1Iso

public String getStUnQtyy1Iso()
単位の ISO コードを取得します。

戻り値:
stUnQtyy1Iso 単位の ISO コード

getUnittype1

public String getUnittype1()
保管単位タイプを取得します。

戻り値:
unittype1 保管単位タイプ

getSuPlStck2

public String getSuPlStck2()
在庫受入予定の保管単位数を取得します。

戻り値:
suPlStck2 在庫受入予定の保管単位数

getStUnQtyy2

public String getStUnQtyy2()
代替数量単位での在庫受入予定保管単位別数量を取得します。

戻り値:
stUnQtyy2 代替数量単位での在庫受入予定保管単位別数量

getStUnQtyy2Iso

public String getStUnQtyy2Iso()
単位の ISO コードを取得します。

戻り値:
stUnQtyy2Iso 単位の ISO コード

getUnittype2

public String getUnittype2()
保管単位タイプを取得します。

戻り値:
unittype2 保管単位タイプ

getStgeTypePc

public String getStgeTypePc()
在庫転送の保管域タイプを取得します。

戻り値:
stgeTypePc 在庫転送の保管域タイプ

getStgeBinPc

public String getStgeBinPc()
在庫転送棚番を取得します。

戻り値:
stgeBinPc 在庫転送棚番

getNoPstChgnt

public String getNoPstChgnt()
区分: 振替要求通知登録禁止を取得します。

戻り値:
noPstChgnt 区分: 振替要求通知登録禁止

getGrNumber

public String getGrNumber()
入庫番号を取得します。

戻り値:
grNumber 入庫番号

getStgeTypeSt

public String getStgeTypeSt()
在庫転送の保管域タイプを取得します。

戻り値:
stgeTypeSt 在庫転送の保管域タイプ

getStgeBinSt

public String getStgeBinSt()
在庫転送棚番を取得します。

戻り値:
stgeBinSt 在庫転送棚番

getMatdocTrCancel

public String getMatdocTrCancel()
取消予定の転送要求の入出庫伝票番号を取得します。

戻り値:
matdocTrCancel 取消予定の転送要求の入出庫伝票番号

getMatitemTrCancel

public String getMatitemTrCancel()
取消予定の転送数量入出庫伝票明細を取得します。

戻り値:
matitemTrCancel 取消予定の転送数量入出庫伝票明細

getMatyearTrCancel

public String getMatyearTrCancel()
取消予定の転送要求入出庫伝票年度を取得します。

戻り値:
matyearTrCancel 取消予定の転送要求入出庫伝票年度

getNoTransferReq

public String getNoTransferReq()
区分: 転送要求未登録を取得します。

戻り値:
noTransferReq 区分: 転送要求未登録

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
coBusproc 業務プロセス

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
acttype 活動タイプ

getSupplVend

public String getSupplVend()
供給仕入先を取得します。

戻り値:
supplVend 供給仕入先

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getMoveMatExternal

public String getMoveMatExternal()
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
moveMatExternal 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

getMoveMatGuid

public String getMoveMatGuid()
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
moveMatGuid 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

getMoveMatVersion

public String getMoveMatVersion()
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
moveMatVersion 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
funcArea 機能領域

getTrPartBa

public String getTrPartBa()
取引会社事業領域を取得します。

戻り値:
trPartBa 取引会社事業領域

getParCompco

public String getParCompco()
決済会社コードを取得します。

戻り値:
parCompco 決済会社コード

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
delivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getNbSlips

public String getNbSlips()
入庫/出庫票の印刷部数を取得します。

戻り値:
nbSlips 入庫/出庫票の印刷部数

getNbSlipsx

public String getNbSlipsx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
nbSlipsx 関連ユーザデータ項目の更新情報

getGrRcptx

public String getGrRcptx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
grRcptx 関連ユーザデータ項目の更新情報

getUnloadPtx

public String getUnloadPtx()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unloadPtx 関連ユーザデータ項目の更新情報

getSpecMvmt

public String getSpecMvmt()
倉庫管理の特殊移動区分を取得します。

戻り値:
specMvmt 倉庫管理の特殊移動区分

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
grantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
cmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getLineId

public String getLineId()
伝票明細行の一意 IDを取得します。

戻り値:
lineId 伝票明細行の一意 ID

getParentId

public String getParentId()
1 レベル上位の行 IDを取得します。

戻り値:
parentId 1 レベル上位の行 ID

getLineDepth

public String getLineDepth()
伝票での明細行階層レベルを取得します。

戻り値:
lineDepth 伝票での明細行階層レベル

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
quantity 数量

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setMoveType

public void setMoveType(String moveType)
移動タイプ (在庫管理)を設定します。

パラメータ:
moveType - 移動タイプ (在庫管理)

setStckType

public void setStckType(String stckType)
在庫タイプを設定します。

パラメータ:
stckType - 在庫タイプ

setSpecStock

public void setSpecStock(String specStock)
特殊在庫区分を設定します。

パラメータ:
specStock - 特殊在庫区分

setVendor

public void setVendor(String vendor)
仕入先勘定コードを設定します。

パラメータ:
vendor - 仕入先勘定コード

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setSalesOrd

public void setSalesOrd(String salesOrd)
受注伝票番号を設定します。

パラメータ:
salesOrd - 受注伝票番号

setSOrdItem

public void setSOrdItem(String sOrdItem)
受注明細番号を設定します。

パラメータ:
sOrdItem - 受注明細番号

setSchedLine

public void setSchedLine(String schedLine)
受注納入日程を設定します。

パラメータ:
schedLine - 受注納入日程

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setEntryQnt

public void setEntryQnt(String entryQnt)
入力単位での数量を設定します。

パラメータ:
entryQnt - 入力単位での数量

setEntryUom

public void setEntryUom(String entryUom)
入力単位を設定します。

パラメータ:
entryUom - 入力単位

setEntryUomIso

public void setEntryUomIso(String entryUomIso)
単位の ISO コードを設定します。

パラメータ:
entryUomIso - 単位の ISO コード

setPoPrQnt

public void setPoPrQnt(String poPrQnt)
数量 (購買発注価格単位)を設定します。

パラメータ:
poPrQnt - 数量 (購買発注価格単位)

setOrderprUn

public void setOrderprUn(String orderprUn)
購買発注価格単位 (購買管理)を設定します。

パラメータ:
orderprUn - 購買発注価格単位 (購買管理)

setOrderprUnIso

public void setOrderprUnIso(String orderprUnIso)
単位の ISO コードを設定します。

パラメータ:
orderprUnIso - 単位の ISO コード

setPoNumber

public void setPoNumber(String poNumber)
購買発注番号を設定します。

パラメータ:
poNumber - 購買発注番号

setPoItem

public void setPoItem(String poItem)
購買伝票の明細番号を設定します。

パラメータ:
poItem - 購買伝票の明細番号

setShipping

public void setShipping(String shipping)
出荷指示を設定します。

パラメータ:
shipping - 出荷指示

setCompShip

public void setCompShip(String compShip)
出荷指示順守を設定します。

パラメータ:
compShip - 出荷指示順守

setNoMoreGr

public void setNoMoreGr(String noMoreGr)
納入完了 区分を設定します。

パラメータ:
noMoreGr - 納入完了 区分

setItemText

public void setItemText(String itemText)
明細テキストを設定します。

パラメータ:
itemText - 明細テキスト

setGrRcpt

public void setGrRcpt(String grRcpt)
受領者を設定します。

パラメータ:
grRcpt - 受領者

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setOrderItno

public void setOrderItno(String orderItno)
指図明細番号を設定します。

パラメータ:
orderItno - 指図明細番号

setCalcMotive

public void setCalcMotive(String calcMotive)
計算区分を設定します。

パラメータ:
calcMotive - 計算区分

setAssetNo

public void setAssetNo(String assetNo)
資産番号を設定します。

パラメータ:
assetNo - 資産番号

setSubNumber

public void setSubNumber(String subNumber)
資産補助番号を設定します。

パラメータ:
subNumber - 資産補助番号

setReservNo

public void setReservNo(String reservNo)
入出庫予定/従属所要量の番号を設定します。

パラメータ:
reservNo - 入出庫予定/従属所要量の番号

setResItem

public void setResItem(String resItem)
入出庫予定/従属所要量の明細番号を設定します。

パラメータ:
resItem - 入出庫予定/従属所要量の明細番号

setResType

public void setResType(String resType)
レコードタイプを設定します。

パラメータ:
resType - レコードタイプ

setWithdrawn

public void setWithdrawn(String withdrawn)
入出庫予定に対する出庫完了を設定します。

パラメータ:
withdrawn - 入出庫予定に対する出庫完了

setMoveMat

public void setMoveMat(String moveMat)
入庫/出庫品目を設定します。

パラメータ:
moveMat - 入庫/出庫品目

setMovePlant

public void setMovePlant(String movePlant)
入庫/出庫プラントを設定します。

パラメータ:
movePlant - 入庫/出庫プラント

setMoveStloc

public void setMoveStloc(String moveStloc)
入庫/出庫保管場所を設定します。

パラメータ:
moveStloc - 入庫/出庫保管場所

setMoveBatch

public void setMoveBatch(String moveBatch)
入庫/出庫ロットを設定します。

パラメータ:
moveBatch - 入庫/出庫ロット

setMoveValType

public void setMoveValType(String moveValType)
転送ロットの評価タイプを設定します。

パラメータ:
moveValType - 転送ロットの評価タイプ

setMvtInd

public void setMvtInd(String mvtInd)
移動区分を設定します。

パラメータ:
mvtInd - 移動区分

setMoveReas

public void setMoveReas(String moveReas)
移動理由を設定します。

パラメータ:
moveReas - 移動理由

setRlEstKey

public void setRlEstKey(String rlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
rlEstKey - 不動産管理対象の内部キー

setRefDate

public void setRefDate(String refDate)
決済の参照日付を設定します。

パラメータ:
refDate - 決済の参照日付

setCostObj

public void setCostObj(String costObj)
原価対象を設定します。

パラメータ:
costObj - 原価対象

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setNetwork

public void setNetwork(String network)
勘定割当のネットワーク番号を設定します。

パラメータ:
network - 勘定割当のネットワーク番号

setActivity

public void setActivity(String activity)
作業番号を設定します。

パラメータ:
activity - 作業番号

setPartAcct

public void setPartAcct(String partAcct)
取引先勘定コードを設定します。

パラメータ:
partAcct - 取引先勘定コード

setAmountLc

public void setAmountLc(String amountLc)
マニュアル入力による転記金額 (国内通貨)を設定します。

パラメータ:
amountLc - マニュアル入力による転記金額 (国内通貨)

setAmountSv

public void setAmountSv(String amountSv)
外部入力による販売金額 (国内通貨)を設定します。

パラメータ:
amountSv - 外部入力による販売金額 (国内通貨)

setRefDocYr

public void setRefDocYr(String refDocYr)
参照伝票の会計年度を設定します。

パラメータ:
refDocYr - 参照伝票の会計年度

setRefDoc

public void setRefDoc(String refDoc)
参照伝票の伝票番号を設定します。

パラメータ:
refDoc - 参照伝票の伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照伝票の明細番号を設定します。

パラメータ:
refDocIt - 参照伝票の明細番号

setExpirydate

public void setExpirydate(String expirydate)
有効期間期限日を設定します。

パラメータ:
expirydate - 有効期間期限日

setProdDate

public void setProdDate(String prodDate)
ロット製造日付を設定します。

パラメータ:
prodDate - ロット製造日付

setFund

public void setFund(String fund)
会計区分を設定します。

パラメータ:
fund - 会計区分

setFundsCtr

public void setFundsCtr(String fundsCtr)
予算センタを設定します。

パラメータ:
fundsCtr - 予算センタ

setCmmtItem

public void setCmmtItem(String cmmtItem)
資金予算コードを設定します。

パラメータ:
cmmtItem - 資金予算コード

setValSalesOrd

public void setValSalesOrd(String valSalesOrd)
評価受注在庫の受注番号を設定します。

パラメータ:
valSalesOrd - 評価受注在庫の受注番号

setValSOrdItem

public void setValSOrdItem(String valSOrdItem)
評価受注在庫の受注明細を設定します。

パラメータ:
valSOrdItem - 評価受注在庫の受注明細

setValWbsElem

public void setValWbsElem(String valWbsElem)
WBS 要素を設定します。

パラメータ:
valWbsElem - WBS 要素

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します。

パラメータ:
glAccount - G/L 勘定コード

setIndProposeQuanx

public void setIndProposeQuanx(String indProposeQuanx)
提案数量 (初期数量)を設定します。

パラメータ:
indProposeQuanx - 提案数量 (初期数量)

setXstob

public void setXstob(String xstob)
取消移動タイプ区分の使用を設定します。

パラメータ:
xstob - 取消移動タイプ区分の使用

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setDelivNumbToSearch

public void setDelivNumbToSearch(String delivNumbToSearch)
出荷伝票を設定します。

パラメータ:
delivNumbToSearch - 出荷伝票

setDelivItemToSearch

public void setDelivItemToSearch(String delivItemToSearch)
出荷明細を設定します。

パラメータ:
delivItemToSearch - 出荷明細

setSerialnoAutoNumberassignment

public void setSerialnoAutoNumberassignment(String serialnoAutoNumberassignment)
シリアル番号の自動登録を設定します。

パラメータ:
serialnoAutoNumberassignment - シリアル番号の自動登録

setVendrbatch

public void setVendrbatch(String vendrbatch)
仕入先ロット番号を設定します。

パラメータ:
vendrbatch - 仕入先ロット番号

setStgeType

public void setStgeType(String stgeType)
保管域タイプを設定します。

パラメータ:
stgeType - 保管域タイプ

setStgeBin

public void setStgeBin(String stgeBin)
棚番を設定します。

パラメータ:
stgeBin - 棚番

setSuPlStck1

public void setSuPlStck1(String suPlStck1)
在庫受入予定の保管単位数を設定します。

パラメータ:
suPlStck1 - 在庫受入予定の保管単位数

setStUnQtyy1

public void setStUnQtyy1(String stUnQtyy1)
代替数量単位での在庫受入予定保管単位別数量を設定します。

パラメータ:
stUnQtyy1 - 代替数量単位での在庫受入予定保管単位別数量

setStUnQtyy1Iso

public void setStUnQtyy1Iso(String stUnQtyy1Iso)
単位の ISO コードを設定します。

パラメータ:
stUnQtyy1Iso - 単位の ISO コード

setUnittype1

public void setUnittype1(String unittype1)
保管単位タイプを設定します。

パラメータ:
unittype1 - 保管単位タイプ

setSuPlStck2

public void setSuPlStck2(String suPlStck2)
在庫受入予定の保管単位数を設定します。

パラメータ:
suPlStck2 - 在庫受入予定の保管単位数

setStUnQtyy2

public void setStUnQtyy2(String stUnQtyy2)
代替数量単位での在庫受入予定保管単位別数量を設定します。

パラメータ:
stUnQtyy2 - 代替数量単位での在庫受入予定保管単位別数量

setStUnQtyy2Iso

public void setStUnQtyy2Iso(String stUnQtyy2Iso)
単位の ISO コードを設定します。

パラメータ:
stUnQtyy2Iso - 単位の ISO コード

setUnittype2

public void setUnittype2(String unittype2)
保管単位タイプを設定します。

パラメータ:
unittype2 - 保管単位タイプ

setStgeTypePc

public void setStgeTypePc(String stgeTypePc)
在庫転送の保管域タイプを設定します。

パラメータ:
stgeTypePc - 在庫転送の保管域タイプ

setStgeBinPc

public void setStgeBinPc(String stgeBinPc)
在庫転送棚番を設定します。

パラメータ:
stgeBinPc - 在庫転送棚番

setNoPstChgnt

public void setNoPstChgnt(String noPstChgnt)
区分: 振替要求通知登録禁止を設定します。

パラメータ:
noPstChgnt - 区分: 振替要求通知登録禁止

setGrNumber

public void setGrNumber(String grNumber)
入庫番号を設定します。

パラメータ:
grNumber - 入庫番号

setStgeTypeSt

public void setStgeTypeSt(String stgeTypeSt)
在庫転送の保管域タイプを設定します。

パラメータ:
stgeTypeSt - 在庫転送の保管域タイプ

setStgeBinSt

public void setStgeBinSt(String stgeBinSt)
在庫転送棚番を設定します。

パラメータ:
stgeBinSt - 在庫転送棚番

setMatdocTrCancel

public void setMatdocTrCancel(String matdocTrCancel)
取消予定の転送要求の入出庫伝票番号を設定します。

パラメータ:
matdocTrCancel - 取消予定の転送要求の入出庫伝票番号

setMatitemTrCancel

public void setMatitemTrCancel(String matitemTrCancel)
取消予定の転送数量入出庫伝票明細を設定します。

パラメータ:
matitemTrCancel - 取消予定の転送数量入出庫伝票明細

setMatyearTrCancel

public void setMatyearTrCancel(String matyearTrCancel)
取消予定の転送要求入出庫伝票年度を設定します。

パラメータ:
matyearTrCancel - 取消予定の転送要求入出庫伝票年度

setNoTransferReq

public void setNoTransferReq(String noTransferReq)
区分: 転送要求未登録を設定します。

パラメータ:
noTransferReq - 区分: 転送要求未登録

setCoBusproc

public void setCoBusproc(String coBusproc)
業務プロセスを設定します。

パラメータ:
coBusproc - 業務プロセス

setActtype

public void setActtype(String acttype)
活動タイプを設定します。

パラメータ:
acttype - 活動タイプ

setSupplVend

public void setSupplVend(String supplVend)
供給仕入先を設定します。

パラメータ:
supplVend - 供給仕入先

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setMoveMatExternal

public void setMoveMatExternal(String moveMatExternal)
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
moveMatExternal - 項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

setMoveMatGuid

public void setMoveMatGuid(String moveMatGuid)
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
moveMatGuid - 項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

setMoveMatVersion

public void setMoveMatVersion(String moveMatVersion)
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
moveMatVersion - 項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

setFuncArea

public void setFuncArea(String funcArea)
機能領域を設定します。

パラメータ:
funcArea - 機能領域

setTrPartBa

public void setTrPartBa(String trPartBa)
取引会社事業領域を設定します。

パラメータ:
trPartBa - 取引会社事業領域

setParCompco

public void setParCompco(String parCompco)
決済会社コードを設定します。

パラメータ:
parCompco - 決済会社コード

setDelivNumb

public void setDelivNumb(String delivNumb)
出荷伝票を設定します。

パラメータ:
delivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setNbSlips

public void setNbSlips(String nbSlips)
入庫/出庫票の印刷部数を設定します。

パラメータ:
nbSlips - 入庫/出庫票の印刷部数

setNbSlipsx

public void setNbSlipsx(String nbSlipsx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
nbSlipsx - 関連ユーザデータ項目の更新情報

setGrRcptx

public void setGrRcptx(String grRcptx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
grRcptx - 関連ユーザデータ項目の更新情報

setUnloadPtx

public void setUnloadPtx(String unloadPtx)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unloadPtx - 関連ユーザデータ項目の更新情報

setSpecMvmt

public void setSpecMvmt(String specMvmt)
倉庫管理の特殊移動区分を設定します。

パラメータ:
specMvmt - 倉庫管理の特殊移動区分

setGrantNbr

public void setGrantNbr(String grantNbr)
補助金を設定します。

パラメータ:
grantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String cmmtItemLong)
資金予算コードを設定します。

パラメータ:
cmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setLineId

public void setLineId(String lineId)
伝票明細行の一意 IDを設定します。

パラメータ:
lineId - 伝票明細行の一意 ID

setParentId

public void setParentId(String parentId)
1 レベル上位の行 IDを設定します。

パラメータ:
parentId - 1 レベル上位の行 ID

setLineDepth

public void setLineDepth(String lineDepth)
伝票での明細行階層レベルを設定します。

パラメータ:
lineDepth - 伝票での明細行階層レベル

setQuantity

public void setQuantity(String quantity)
数量を設定します。

パラメータ:
quantity - 数量

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtSerialNumber (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス GoodsMvtSerialNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber
すべての実装インタフェース:
Serializable
public class GoodsMvtSerialNumber
extends Object
implements Serializable

シリアル番号情報クラス
機能は以下の通り

  • シリアル番号情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GoodsMvtSerialNumber()
シリアル番号情報を作成します。
GoodsMvtSerialNumber(int index)
シリアル番号情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getMatdocItm() 入出庫伝票の明細を取得します。
String | getSerialno() シリアル番号を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setMatdocItm(String matdocItm) 入出庫伝票の明細を設定します。
void | setSerialno(String serialno) シリアル番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtSerialNumber

public GoodsMvtSerialNumber()
シリアル番号情報を作成します。

GoodsMvtSerialNumber

public GoodsMvtSerialNumber(int index)
シリアル番号情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMatdocItm

public String getMatdocItm()
入出庫伝票の明細を取得します。

戻り値:
matdocItm 入出庫伝票の明細

getSerialno

public String getSerialno()
シリアル番号を取得します。

戻り値:
serialno シリアル番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setMatdocItm

public void setMatdocItm(String matdocItm)
入出庫伝票の明細を設定します。

パラメータ:
matdocItm - 入出庫伝票の明細

setSerialno

public void setSerialno(String serialno)
シリアル番号を設定します。

パラメータ:
serialno - シリアル番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス
GoodsMvtCode
GoodsMvtCreate
GoodsMvtHeadret
GoodsMvtItem
GoodsMvtSerialNumber
ParamGoodsMvtCode
ParamGoodsMvtHeadret
ParamGoodsMvtItem
ParamGoodsMvtSerialNumber


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

クラスの概要
GoodsMvtCode | 在庫移動に対するコードのトランザクションへの割当情報クラス 機能は以下の通り 在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtCreate | 入出庫伝票登録情報クラス 機能は以下の通り 入出庫伝票登録情報を保持します。
GoodsMvtHeadret | 入出庫伝票番号/入出庫伝票会計年度情報クラス 機能は以下の通り 入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtItem | 入出庫伝票明細情報クラス 機能は以下の通り 入出庫伝票明細情報を保持します。
GoodsMvtSerialNumber | シリアル番号情報クラス 機能は以下の通り シリアル番号情報を保持します。
ParamGoodsMvtCode | 在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス 機能は以下の通り 在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。
ParamGoodsMvtHeadret | 入出庫伝票ヘッダデータパラメータ設定クラス 機能は以下の通り 入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtItem | リターン構造、入出庫伝票明細パラメータ設定クラス 機能は以下の通り リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtSerialNumber | シリアル番号パラメータ設定クラス 機能は以下の通り シリアル番号のパラメータを設定します。


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のクラス
GoodsMvtCreate
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate のクラス
GoodsMvtCode
在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtHeadret
入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り
入出庫伝票番号/入出庫伝票会計年度情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamGoodsMvtCode (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtCode

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtCode
extends Object
implements Serializable

在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス
機能は以下の通り

  • 在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, GoodsMvtCode goodsMvtCode)
在庫移動に対するコードのトランザクションへの割当の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  GoodsMvtCode goodsMvtCode)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
在庫移動に対するコードのトランザクションへの割当の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtCode - GoodsMvtCode
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtHeadret (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtHeadret

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtHeadret
extends Object
implements Serializable

入出庫伝票ヘッダデータパラメータ設定クラス
機能は以下の通り

    入出庫伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, GoodsMvtHeadret goodsMvtHeadret)
入出庫伝票ヘッダデータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  GoodsMvtHeadret goodsMvtHeadret)
                           throws SAPGeneralSystemException
入出庫伝票ヘッダデータの値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtHeadret - GoodsMvtHeadret
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtItem
extends Object
implements Serializable

リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り

  • リターン構造、入出庫伝票明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtItemList) table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtItemList) リターン構造、入出庫伝票明細の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
リターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtItemList)
                           throws SAPGeneralSystemException
table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtItemList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamGoodsMvtSerialNumber (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
クラス ParamGoodsMvtSerialNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber
すべての実装インタフェース:
Serializable
public final class ParamGoodsMvtSerialNumber
extends Object
implements Serializable

シリアル番号パラメータ設定クラス
機能は以下の通り

  • シリアル番号のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List goodsMvtSerialNumberList) table(Export)情報からシリアル番号の値をセットします。
static void | setImportParam(BapiController bapiController, List goodsMvtSerialNumberList) シリアル番号の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List goodsMvtSerialNumberList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
シリアル番号の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtSerialNumberList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List goodsMvtSerialNumberList)
                           throws SAPGeneralSystemException
table(Export)情報からシリアル番号の値をセットします。

パラメータ:
bapiController - BapiController
goodsMvtSerialNumberList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems の使用

GoodsMvtGetItems を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtGetItems の使用

jp.co.intra_mart.foundation.sap.module.purchase での GoodsMvtGetItems のサブクラス
 class GoodsMvtGetItemsController
入出庫伝票一覧取得コントローラクラス
機能は以下の通り
入出庫伝票の一覧を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BatchRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス BatchRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa
すべての実装インタフェース:
Serializable
public class BatchRa
extends Object
implements Serializable

ロットの範囲情報クラス
機能は以下の通り

  • ロットの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BatchRa()
ロットの範囲情報を作成します。
BatchRa(int index)
ロットの範囲情報を作成します。
メソッドの概要
String | getHigh() ロット番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() ロット番号を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) ロット番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) ロット番号を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BatchRa

public BatchRa()
ロットの範囲情報を作成します。

BatchRa

public BatchRa(int index)
ロットの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
ロット番号を取得します。

戻り値:
low ロット番号

getHigh

public String getHigh()
ロット番号を取得します。

戻り値:
high ロット番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
ロット番号を設定します。

パラメータ:
low - ロット番号

setHigh

public void setHigh(String high)
ロット番号を設定します。

パラメータ:
high - ロット番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtGetItems (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス GoodsMvtGetItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
GoodsMvtGetItemsController
public class GoodsMvtGetItems
extends ReferenceController
implements Serializable

出庫確認一覧照会情報クラス
機能は以下の通り

  • 出庫確認一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。
メソッドの概要
List | getBatchRaList() ロットの範囲を取得します。
List | getGoodsMvtHeaderList() リターン構造、入出庫伝票ヘッダを取得します。
List | getGoodsMvtItemsList() リターン構造、入出庫伝票明細を取得します。
List | getMaterialRaList() 品目コードの範囲を取得します。
List | getMoveTypeRaList() 移動タイプの範囲を取得します。
List | getPlantRaList() プラントの範囲を取得します。
List | getPstngDateRaList() 登録日付の範囲を取得します。
List | getSpecStockRaList() 特殊在庫区分の範囲を取得します。
List | getStgeLocRaList() 保管場所の範囲を取得します。
List | getTrEvTypeRaList() トランザクション/イベントタイプの範囲を取得します。
List | getUserNameRaList() ユーザ名の範囲を取得します。
List | getVendorRaList() 仕入先の範囲を取得します。
void | setBatchRaList(List batchRaList) ロットの範囲を設定します。
void | setExportParam(BapiController bapiController) 返却された入出庫伝票照会情報をセットします。
void | setGoodsMvtHeaderList(List goodsMvtHeaderList) リターン構造、入出庫伝票ヘッダを設定します。
void | setGoodsMvtItemsList(List goodsMvtItemsList) リターン構造、入出庫伝票明細を設定します。
void | setImportParam(BapiController bapiController) 入出庫伝票一覧照会する情報をセットします。
void | setMaterialRaList(List materialRaList) 品目コードの範囲を設定します。
void | setMoveTypeRaList(List moveTypeRaList) 移動タイプの範囲を設定します。
void | setPlantRaList(List plantRaList) プラントの範囲を設定します。
void | setPstngDateRaList(List pstngDateRaList) 登録日付の範囲を設定します。
void | setSpecStockRaList(List specStockRaList) 特殊在庫区分の範囲を設定します。
void | setStgeLocRaList(List stgeLocRaList) 保管場所の範囲を設定します。
void | setTrEvTypeRaList(List trEvTypeRaList) トランザクション/イベントタイプの範囲を設定します。
void | setUserNameRaList(List userNameRaList) ユーザ名の範囲を設定します。
void | setVendorRaList(List vendorRaList) 仕入先の範囲を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtGetItems

public GoodsMvtGetItems(SapClient sapClient)
出庫確認一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
入出庫伝票一覧照会する情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された入出庫伝票照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getVendorRaList

public List getVendorRaList()
仕入先の範囲を取得します。

戻り値:
vendorRaList 仕入先の範囲

getUserNameRaList

public List getUserNameRaList()
ユーザ名の範囲を取得します。

戻り値:
userNameRaList ユーザ名の範囲

getTrEvTypeRaList

public List getTrEvTypeRaList()
トランザクション/イベントタイプの範囲を取得します。

戻り値:
trEvTypeRaList トランザクション/イベントタイプの範囲

getStgeLocRaList

public List getStgeLocRaList()
保管場所の範囲を取得します。

戻り値:
stgeLocRaList 保管場所の範囲

getSpecStockRaList

public List getSpecStockRaList()
特殊在庫区分の範囲を取得します。

戻り値:
specStockRaList 特殊在庫区分の範囲

getPstngDateRaList

public List getPstngDateRaList()
登録日付の範囲を取得します。

戻り値:
pstngDateRaList 登録日付の範囲

getPlantRaList

public List getPlantRaList()
プラントの範囲を取得します。

戻り値:
plantRaList プラントの範囲

getMoveTypeRaList

public List getMoveTypeRaList()
移動タイプの範囲を取得します。

戻り値:
moveTypeRaList 移動タイプの範囲

getMaterialRaList

public List getMaterialRaList()
品目コードの範囲を取得します。

戻り値:
materialRaList 品目コードの範囲

getGoodsMvtItemsList

public List getGoodsMvtItemsList()
リターン構造、入出庫伝票明細を取得します。

戻り値:
goodsMvtItemsList リターン構造、入出庫伝票明細

getGoodsMvtHeaderList

public List getGoodsMvtHeaderList()
リターン構造、入出庫伝票ヘッダを取得します。

戻り値:
goodsMvtHeaderList リターン構造、入出庫伝票ヘッダ

getBatchRaList

public List getBatchRaList()
ロットの範囲を取得します。

戻り値:
batchRaList ロットの範囲

setVendorRaList

public void setVendorRaList(List vendorRaList)
仕入先の範囲を設定します。

パラメータ:
vendorRaList - 仕入先の範囲

setUserNameRaList

public void setUserNameRaList(List userNameRaList)
ユーザ名の範囲を設定します。

パラメータ:
userNameRaList - ユーザ名の範囲

setTrEvTypeRaList

public void setTrEvTypeRaList(List trEvTypeRaList)
トランザクション/イベントタイプの範囲を設定します。

パラメータ:
trEvTypeRaList - トランザクション/イベントタイプの範囲

setStgeLocRaList

public void setStgeLocRaList(List stgeLocRaList)
保管場所の範囲を設定します。

パラメータ:
stgeLocRaList - 保管場所の範囲

setSpecStockRaList

public void setSpecStockRaList(List specStockRaList)
特殊在庫区分の範囲を設定します。

パラメータ:
specStockRaList - 特殊在庫区分の範囲

setPstngDateRaList

public void setPstngDateRaList(List pstngDateRaList)
登録日付の範囲を設定します。

パラメータ:
pstngDateRaList - 登録日付の範囲

setPlantRaList

public void setPlantRaList(List plantRaList)
プラントの範囲を設定します。

パラメータ:
plantRaList - プラントの範囲

setMoveTypeRaList

public void setMoveTypeRaList(List moveTypeRaList)
移動タイプの範囲を設定します。

パラメータ:
moveTypeRaList - 移動タイプの範囲

setMaterialRaList

public void setMaterialRaList(List materialRaList)
品目コードの範囲を設定します。

パラメータ:
materialRaList - 品目コードの範囲

setGoodsMvtItemsList

public void setGoodsMvtItemsList(List goodsMvtItemsList)
リターン構造、入出庫伝票明細を設定します。

パラメータ:
goodsMvtItemsList - リターン構造、入出庫伝票明細

setGoodsMvtHeaderList

public void setGoodsMvtHeaderList(List goodsMvtHeaderList)
リターン構造、入出庫伝票ヘッダを設定します。

パラメータ:
goodsMvtHeaderList - リターン構造、入出庫伝票ヘッダ

setBatchRaList

public void setBatchRaList(List batchRaList)
ロットの範囲を設定します。

パラメータ:
batchRaList - ロットの範囲

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス MaterialRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa
すべての実装インタフェース:
Serializable
public class MaterialRa
extends Object
implements Serializable

品目コードの範囲情報クラス
機能は以下の通り

  • 品目コードの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialRa()
品目コードの範囲情報を作成します。
MaterialRa(int index)
品目コードの範囲情報を作成します。
メソッドの概要
String | getHigh() 品目コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 品目コードを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 品目コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 品目コードを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialRa

public MaterialRa()
品目コードの範囲情報を作成します。

MaterialRa

public MaterialRa(int index)
品目コードの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
品目コードを取得します。

戻り値:
low 品目コード

getHigh

public String getHigh()
品目コードを取得します。

戻り値:
high 品目コード

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
品目コードを設定します。

パラメータ:
low - 品目コード

setHigh

public void setHigh(String high)
品目コードを設定します。

パラメータ:
high - 品目コード

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MoveTypeRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス MoveTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa
すべての実装インタフェース:
Serializable
public class MoveTypeRa
extends Object
implements Serializable

移動タイプの範囲情報クラス
機能は以下の通り

  • 移動タイプの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MoveTypeRa()
移動タイプの範囲情報を作成します。
MoveTypeRa(int index)
移動タイプの範囲情報を作成します。
メソッドの概要
String | getHigh() 移動タイプ (在庫管理)を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 移動タイプ (在庫管理)を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 移動タイプ (在庫管理)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 移動タイプ (在庫管理)を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MoveTypeRa

public MoveTypeRa()
移動タイプの範囲情報を作成します。

MoveTypeRa

public MoveTypeRa(int index)
移動タイプの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
移動タイプ (在庫管理)を取得します。

戻り値:
low 移動タイプ (在庫管理)

getHigh

public String getHigh()
移動タイプ (在庫管理)を取得します。

戻り値:
high 移動タイプ (在庫管理)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
移動タイプ (在庫管理)を設定します。

パラメータ:
low - 移動タイプ (在庫管理)

setHigh

public void setHigh(String high)
移動タイプ (在庫管理)を設定します。

パラメータ:
high - 移動タイプ (在庫管理)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス
BatchRa
GoodsMvtGetItems
MaterialRa
MoveTypeRa
ParamBatchRa
ParamMaterialRa
ParamMoveTypeRa
ParamPlantRa
ParamPstngDateRa
ParamSpecStockRa
ParamStgeLocRa
ParamTrEvTypeRa
ParamUserNameRa
ParamVendorRa
PlantRa
PstngDateRa
SpecStockRa
StgeLocRa
TrEvTypeRa
UserNameRa
VendorRa


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

クラスの概要
BatchRa | ロットの範囲情報クラス 機能は以下の通り ロットの範囲情報を保持します。
GoodsMvtGetItems | 出庫確認一覧照会情報クラス 機能は以下の通り 出庫確認一覧照会情報を保持します。
MaterialRa | 品目コードの範囲情報クラス 機能は以下の通り 品目コードの範囲情報を保持します。
MoveTypeRa | 移動タイプの範囲情報クラス 機能は以下の通り 移動タイプの範囲情報を保持します。
ParamBatchRa | ロットの範囲パラメータ設定クラス 機能は以下の通り ロットの範囲のパラメータを設定します。
ParamMaterialRa | 品目コードの範囲パラメータ設定クラス 機能は以下の通り 品目コードの範囲のパラメータを設定します。
ParamMoveTypeRa | 移動タイプの範囲パラメータ設定クラス 機能は以下の通り 移動タイプの範囲のパラメータを設定します。
ParamPlantRa | プラントの範囲パラメータ設定クラス 機能は以下の通り プラントの範囲のパラメータを設定します。
ParamPstngDateRa | 登録日付の範囲パラメータ設定クラス 機能は以下の通り 登録日付の範囲のパラメータを設定します。
ParamSpecStockRa | 特殊在庫区分の範囲パラメータ設定クラス 機能は以下の通り 特殊在庫区分の範囲のパラメータを設定します。
ParamStgeLocRa | 保管場所の範囲パラメータ設定クラス 機能は以下の通り 保管場所の範囲のパラメータを設定します。
ParamTrEvTypeRa | トランザクション/イベントタイプの範囲パラメータ設定クラス。
ParamUserNameRa | ユーザ名の範囲パラメータ設定クラス 機能は以下の通り ユーザ名の範囲のパラメータを設定します。
ParamVendorRa | 仕入先の範囲パラメータ設定クラス 機能は以下の通り 仕入先の範囲のパラメータを設定します。
PlantRa | プラントの範囲情報クラス 機能は以下の通り プラントの範囲情報を保持します。
PstngDateRa | 登録日付の範囲情報クラス 機能は以下の通り 登録日付の範囲情報を保持します。
SpecStockRa | 特殊在庫区分の範囲情報クラス 機能は以下の通り 特殊在庫区分の範囲情報を保持します。
StgeLocRa | 保管場所の範囲情報クラス 機能は以下の通り 保管場所の範囲情報を保持します。
TrEvTypeRa | トランザクション/イベントタイプの範囲情報クラス 機能は以下の通り トランザクション/イベントタイプの範囲情報を保持します。
UserNameRa | ユーザ名の範囲情報クラス 機能は以下の通り ユーザ名の範囲情報を保持します。
VendorRa | 仕入先の範囲情報クラス 機能は以下の通り 仕入先の範囲情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems の使用

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems のクラス
GoodsMvtGetItems
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBatchRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamBatchRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa
すべての実装インタフェース:
Serializable
public final class ParamBatchRa
extends Object
implements Serializable

ロットの範囲パラメータ設定クラス
機能は以下の通り

  • ロットの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List batchRaList) table(Export)情報からロットの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List batchRaList) ロットの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List batchRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ロットの範囲の値をセットします。

パラメータ:
bapiController - BapiController
batchRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List batchRaList)
                           throws SAPGeneralSystemException
table(Export)情報からロットの範囲の値をセットします。

パラメータ:
bapiController - BapiController
batchRaList - BatchRa
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamMaterialRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa
すべての実装インタフェース:
Serializable
public final class ParamMaterialRa
extends Object
implements Serializable

品目コードの範囲パラメータ設定クラス
機能は以下の通り

  • 品目コードの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialRaList) table(Export)情報から品目コードの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List materialRaList) 品目コードの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List materialRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
品目コードの範囲の値をセットします。

パラメータ:
bapiController - BapiController
materialRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialRaList)
                           throws SAPGeneralSystemException
table(Export)情報から品目コードの範囲の値をセットします。

パラメータ:
bapiController - BapiController
materialRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMoveTypeRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamMoveTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa
すべての実装インタフェース:
Serializable
public final class ParamMoveTypeRa
extends Object
implements Serializable

移動タイプの範囲パラメータ設定クラス
機能は以下の通り

  • 移動タイプの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List moveTypeRaList) table(Export)情報から移動タイプの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List moveTypeRaList) 移動タイプの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List moveTypeRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
移動タイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
moveTypeRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List moveTypeRaList)
                           throws SAPGeneralSystemException
table(Export)情報から移動タイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
moveTypeRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlantRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamPlantRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa
すべての実装インタフェース:
Serializable
public final class ParamPlantRa
extends Object
implements Serializable

プラントの範囲パラメータ設定クラス
機能は以下の通り

  • プラントの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List plantRaList) table(Export)情報からプラントの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List plantRaList) プラントの範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List plantRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
プラントの範囲の値をセットします。

パラメータ:
bapiController - BapiController
plantRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List plantRaList)
                           throws SAPGeneralSystemException
table(Export)情報からプラントの範囲の値をセットします。

パラメータ:
bapiController - BapiController
plantRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPstngDateRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamPstngDateRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa
すべての実装インタフェース:
Serializable
public final class ParamPstngDateRa
extends Object
implements Serializable

登録日付の範囲パラメータ設定クラス
機能は以下の通り

  • 登録日付の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List pstngDateRaList) table(Export)情報から登録日付の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List pstngDateRaList) 登録日付の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List pstngDateRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
登録日付の範囲の値をセットします。

パラメータ:
bapiController - BapiController
pstngDateRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List pstngDateRaList)
                           throws SAPGeneralSystemException
table(Export)情報から登録日付の範囲の値をセットします。

パラメータ:
bapiController - BapiController
pstngDateRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSpecStockRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamSpecStockRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa
すべての実装インタフェース:
Serializable
public final class ParamSpecStockRa
extends Object
implements Serializable

特殊在庫区分の範囲パラメータ設定クラス
機能は以下の通り

  • 特殊在庫区分の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List specStockRaList) table(Export)情報から特殊在庫区分の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List specStockRaList) 特殊在庫区分の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List specStockRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
特殊在庫区分の範囲の値をセットします。

パラメータ:
bapiController - BapiController
specStockRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List specStockRaList)
                           throws SAPGeneralSystemException
table(Export)情報から特殊在庫区分の範囲の値をセットします。

パラメータ:
bapiController - BapiController
specStockRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStgeLocRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamStgeLocRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa
すべての実装インタフェース:
Serializable
public final class ParamStgeLocRa
extends Object
implements Serializable

保管場所の範囲パラメータ設定クラス
機能は以下の通り

  • 保管場所の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeLocRaList) table(Export)情報から保管場所の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List stgeLocRaList) 保管場所の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List stgeLocRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
保管場所の範囲の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeLocRaList)
                           throws SAPGeneralSystemException
table(Export)情報から保管場所の範囲の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTrEvTypeRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamTrEvTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa
すべての実装インタフェース:
Serializable
public final class ParamTrEvTypeRa
extends Object
implements Serializable

トランザクション/イベントタイプの範囲パラメータ設定クラス。
機能は以下の通り。

  • トランザクション/イベントタイプの範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List trEvTypeRaList) table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List trEvTypeRaList) ParamTrEvTypeRaの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List trEvTypeRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ParamTrEvTypeRaの値をセットします。

パラメータ:
bapiController - BapiController
trEvTypeRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List trEvTypeRaList)
                           throws SAPGeneralSystemException
table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。

パラメータ:
bapiController - BapiController
trEvTypeRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUserNameRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamUserNameRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa
すべての実装インタフェース:
Serializable
public final class ParamUserNameRa
extends Object
implements Serializable

ユーザ名の範囲パラメータ設定クラス
機能は以下の通り

  • ユーザ名の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List userNameRaList) table(Export)情報からユーザ名の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List userNameRaList) ユーザ名の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List userNameRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ユーザ名の範囲の値をセットします。

パラメータ:
bapiController - BapiController
userNameRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List userNameRaList)
                           throws SAPGeneralSystemException
table(Export)情報からユーザ名の範囲の値をセットします。

パラメータ:
bapiController - BapiController
userNameRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVendorRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス ParamVendorRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa
すべての実装インタフェース:
Serializable
public final class ParamVendorRa
extends Object
implements Serializable

仕入先の範囲パラメータ設定クラス
機能は以下の通り

  • 仕入先の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List vendorRaList) table(Export)情報から仕入先の範囲の値をセットします。
static void | setImportParam(BapiController bapiController, List vendorRaList) 仕入先の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List vendorRaList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
仕入先の範囲の値をセットします。

パラメータ:
bapiController - BapiController
vendorRaList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List vendorRaList)
                           throws SAPGeneralSystemException
table(Export)情報から仕入先の範囲の値をセットします。

パラメータ:
bapiController - BapiController
vendorRaList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス PlantRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa
すべての実装インタフェース:
Serializable
public class PlantRa
extends Object
implements Serializable

プラントの範囲情報クラス
機能は以下の通り

  • プラントの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantRa()
プラントの範囲情報を作成します。
PlantRa(int index)
プラントの範囲情報を作成します。
メソッドの概要
String | getHigh() プラントを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() プラントを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) プラントを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) プラントを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantRa

public PlantRa()
プラントの範囲情報を作成します。

PlantRa

public PlantRa(int index)
プラントの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
プラントを取得します。

戻り値:
low プラント

getHigh

public String getHigh()
プラントを取得します。

戻り値:
high プラント

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
プラントを設定します。

パラメータ:
low - プラント

setHigh

public void setHigh(String high)
プラントを設定します。

パラメータ:
high - プラント

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PstngDateRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス PstngDateRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa
すべての実装インタフェース:
Serializable
public class PstngDateRa
extends Object
implements Serializable

登録日付の範囲情報クラス
機能は以下の通り

  • 登録日付の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PstngDateRa()
登録日付の範囲情報を作成します。
PstngDateRa(int index)
登録日付の範囲情報を作成します。
メソッドの概要
String | getHigh() 伝票の転記日付を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 伝票の転記日付を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 伝票の転記日付を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 伝票の転記日付を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PstngDateRa

public PstngDateRa()
登録日付の範囲情報を作成します。

PstngDateRa

public PstngDateRa(int index)
登録日付の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
伝票の転記日付を取得します。

戻り値:
low 伝票の転記日付

getHigh

public String getHigh()
伝票の転記日付を取得します。

戻り値:
high 伝票の転記日付

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
伝票の転記日付を設定します。

パラメータ:
low - 伝票の転記日付

setHigh

public void setHigh(String high)
伝票の転記日付を設定します。

パラメータ:
high - 伝票の転記日付

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SpecStockRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス SpecStockRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa
すべての実装インタフェース:
Serializable
public class SpecStockRa
extends Object
implements Serializable

特殊在庫区分の範囲情報クラス
機能は以下の通り

  • 特殊在庫区分の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SpecStockRa()
特殊在庫区分の範囲情報を作成します。
SpecStockRa(int index)
特殊在庫区分の範囲情報を作成します。
メソッドの概要
String | getHigh() 特殊在庫区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 特殊在庫区分を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 特殊在庫区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 特殊在庫区分を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SpecStockRa

public SpecStockRa()
特殊在庫区分の範囲情報を作成します。

SpecStockRa

public SpecStockRa(int index)
特殊在庫区分の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
特殊在庫区分を取得します。

戻り値:
low 特殊在庫区分

getHigh

public String getHigh()
特殊在庫区分を取得します。

戻り値:
high 特殊在庫区分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
特殊在庫区分を設定します。

パラメータ:
low - 特殊在庫区分

setHigh

public void setHigh(String high)
特殊在庫区分を設定します。

パラメータ:
high - 特殊在庫区分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StgeLocRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス StgeLocRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa
すべての実装インタフェース:
Serializable
public class StgeLocRa
extends Object
implements Serializable

保管場所の範囲情報クラス
機能は以下の通り

  • 保管場所の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StgeLocRa()
保管場所の範囲情報を作成します。
StgeLocRa(int index)
保管場所の範囲情報を作成します。
メソッドの概要
String | getHigh() 保管場所を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 保管場所を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 保管場所を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 保管場所を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StgeLocRa

public StgeLocRa()
保管場所の範囲情報を作成します。

StgeLocRa

public StgeLocRa(int index)
保管場所の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
保管場所を取得します。

戻り値:
low 保管場所

getHigh

public String getHigh()
保管場所を取得します。

戻り値:
high 保管場所

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
保管場所を設定します。

パラメータ:
low - 保管場所

setHigh

public void setHigh(String high)
保管場所を設定します。

パラメータ:
high - 保管場所

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TrEvTypeRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス TrEvTypeRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa
すべての実装インタフェース:
Serializable
public class TrEvTypeRa
extends Object
implements Serializable

トランザクション/イベントタイプの範囲情報クラス
機能は以下の通り

  • トランザクション/イベントタイプの範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TrEvTypeRa()
トランザクション/イベントタイプの範囲情報を作成します。
TrEvTypeRa(int index)
トランザクション/イベントタイプの範囲情報を作成します。
メソッドの概要
String | getHigh() トランザクション/イベントタイプを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() トランザクション/イベントタイプを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) トランザクション/イベントタイプを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) トランザクション/イベントタイプを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TrEvTypeRa

public TrEvTypeRa()
トランザクション/イベントタイプの範囲情報を作成します。

TrEvTypeRa

public TrEvTypeRa(int index)
トランザクション/イベントタイプの範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
トランザクション/イベントタイプを取得します。

戻り値:
low トランザクション/イベントタイプ

getHigh

public String getHigh()
トランザクション/イベントタイプを取得します。

戻り値:
high トランザクション/イベントタイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
トランザクション/イベントタイプを設定します。

パラメータ:
low - トランザクション/イベントタイプ

setHigh

public void setHigh(String high)
トランザクション/イベントタイプを設定します。

パラメータ:
high - トランザクション/イベントタイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UserNameRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス UserNameRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa
すべての実装インタフェース:
Serializable
public class UserNameRa
extends Object
implements Serializable

ユーザ名の範囲情報クラス
機能は以下の通り

  • ユーザ名の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UserNameRa()
ユーザ名の範囲情報を作成します。
UserNameRa(int index)
ユーザ名の範囲情報を作成します。
メソッドの概要
String | getHigh() ユーザ名を取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() ユーザ名を取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) ユーザ名を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) ユーザ名を設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UserNameRa

public UserNameRa()
ユーザ名の範囲情報を作成します。

UserNameRa

public UserNameRa(int index)
ユーザ名の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
ユーザ名を取得します。

戻り値:
low ユーザ名

getHigh

public String getHigh()
ユーザ名を取得します。

戻り値:
high ユーザ名

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
ユーザ名を設定します。

パラメータ:
low - ユーザ名

setHigh

public void setHigh(String high)
ユーザ名を設定します。

パラメータ:
high - ユーザ名

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VendorRa (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
クラス VendorRa

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa
すべての実装インタフェース:
Serializable
public class VendorRa
extends Object
implements Serializable

仕入先の範囲情報クラス
機能は以下の通り

  • 仕入先の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
VendorRa()
仕入先の範囲情報を作成します。
VendorRa(int index)
仕入先の範囲情報を作成します。
メソッドの概要
String | getHigh() 仕入先勘定コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getLow() 仕入先勘定コードを取得します。
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setHigh(String high) 仕入先勘定コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLow(String low) 仕入先勘定コードを設定します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

VendorRa

public VendorRa()
仕入先の範囲情報を作成します。

VendorRa

public VendorRa(int index)
仕入先の範囲情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getLow

public String getLow()
仕入先勘定コードを取得します。

戻り値:
low 仕入先勘定コード

getHigh

public String getHigh()
仕入先勘定コードを取得します。

戻り値:
high 仕入先勘定コード

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setLow

public void setLow(String low)
仕入先勘定コードを設定します。

パラメータ:
low - 仕入先勘定コード

setHigh

public void setHigh(String high)
仕入先勘定コードを設定します。

パラメータ:
high - 仕入先勘定コード

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability の使用

MaterialAvailability を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialAvailability の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialAvailability のサブクラス
 class MaterialAvailabilityController
品目在庫確認コントローラクラス
機能は以下の通り
在庫情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MaterialAvailability (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス MaterialAvailability

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialAvailabilityController
public class MaterialAvailability
extends ReferenceController
implements Serializable

品目在庫確認情報クラス
機能は以下の通り

  • 品目在庫確認情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。
メソッドの概要
String | getAvQtyPlt() プラントレベル利用可能数量を取得します。
String | getBatch() ロットを取得します。
String | getCheckRule() 確認規則を取得します。
String | getCustomer() 得意先コードを取得します。
String | getDecForRounding() 小数点位置 (その位置まで丸める)を取得します。
String | getDecForRoundingX() 関連ユーザデータ項目の更新情報を取得します。
String | getDialogflag() 区分 (X = 利用不可 /N = 確認なし)を取得します。
String | getDocNumber() 伝票番号を取得します。
String | getEndleadtme() 補充リードタイムの終了日付を取得します。
String | getItmNumber() 明細番号を取得します。
String | getMaterial() 品目コードを取得します。
String | getPlant() プラントを取得します。
String | getStgeLoc() 保管場所を取得します。
String | getStockInd() 特殊在庫区分を取得します。
String | getUnit() 表示数量単位を取得します。
String | getWbsElem() WBS 要素を取得します。
List | getWmdvexList() 出力テーブル (日付および ATP 数量)を取得します。
List | getWmdvsxList() 入力テーブル (日付/数量)を取得します。
void | setAvQtyPlt(String avQtyPlt) プラントレベル利用可能数量を設定します。
void | setBatch(String batch) ロットを設定します。
void | setCheckRule(String checkRule) 確認規則を設定します。
void | setCustomer(String customer) 得意先コードを設定します。
void | setDecForRounding(String decForRounding) 小数点位置 (その位置まで丸める)を設定します。
void | setDecForRoundingX(String decForRoundingX) 関連ユーザデータ項目の更新情報を設定します。
void | setDialogflag(String dialogflag) 区分 (X = 利用不可 /N = 確認なし)を設定します。
void | setDocNumber(String docNumber) 伝票番号を設定します。
void | setEndleadtme(String endleadtme) 補充リードタイムの終了日付を設定します。
void | setExportParam(BapiController bapiController) 取得した品目在庫確認情報をセットします。
void | setImportParam(BapiController bapiController) 品目在庫確認情報を取得する為の条件をセットします。
void | setItmNumber(String itmNumber) 明細番号を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setStgeLoc(String stgeLoc) 保管場所を設定します。
void | setStockInd(String stockInd) 特殊在庫区分を設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
void | setWmdvexList(List wmdvexList) 出力テーブル (日付および ATP 数量)を設定します。
void | setWmdvsxList(List wmdvsxList) 入力テーブル (日付/数量)を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialAvailability

public MaterialAvailability(SapClient sapClient)
品目在庫確認情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getStockInd

public String getStockInd()
特殊在庫区分を取得します。

戻り値:
stockInd 特殊在庫区分

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
stgeLoc 保管場所

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getItmNumber

public String getItmNumber()
明細番号を取得します。

戻り値:
itmNumber 明細番号

getDocNumber

public String getDocNumber()
伝票番号を取得します。

戻り値:
docNumber 伝票番号

getDecForRoundingX

public String getDecForRoundingX()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
decForRoundingX 関連ユーザデータ項目の更新情報

getDecForRounding

public String getDecForRounding()
小数点位置 (その位置まで丸める)を取得します。

戻り値:
decForRounding 小数点位置 (その位置まで丸める)

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
customer 得意先コード

getCheckRule

public String getCheckRule()
確認規則を取得します。

戻り値:
checkRule 確認規則

getBatch

public String getBatch()
ロットを取得します。

戻り値:
batch ロット

getEndleadtme

public String getEndleadtme()
補充リードタイムの終了日付を取得します。

戻り値:
endleadtme 補充リードタイムの終了日付

getDialogflag

public String getDialogflag()
区分 (X = 利用不可 /N = 確認なし)を取得します。

戻り値:
dialogflag 区分 (X = 利用不可 /N = 確認なし)

getAvQtyPlt

public String getAvQtyPlt()
プラントレベル利用可能数量を取得します。

戻り値:
avQtyPlt プラントレベル利用可能数量

getWmdvexList

public List getWmdvexList()
出力テーブル (日付および ATP 数量)を取得します。

戻り値:
wmdvexList 出力テーブル (日付および ATP 数量)

getWmdvsxList

public List getWmdvsxList()
入力テーブル (日付/数量)を取得します。

戻り値:
wmdvsxList 入力テーブル (日付/数量)

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setStockInd

public void setStockInd(String stockInd)
特殊在庫区分を設定します。

パラメータ:
stockInd - 特殊在庫区分

setStgeLoc

public void setStgeLoc(String stgeLoc)
保管場所を設定します。

パラメータ:
stgeLoc - 保管場所

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setItmNumber

public void setItmNumber(String itmNumber)
明細番号を設定します。

パラメータ:
itmNumber - 明細番号

setDocNumber

public void setDocNumber(String docNumber)
伝票番号を設定します。

パラメータ:
docNumber - 伝票番号

setDecForRoundingX

public void setDecForRoundingX(String decForRoundingX)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
decForRoundingX - 関連ユーザデータ項目の更新情報

setDecForRounding

public void setDecForRounding(String decForRounding)
小数点位置 (その位置まで丸める)を設定します。

パラメータ:
decForRounding - 小数点位置 (その位置まで丸める)

setCustomer

public void setCustomer(String customer)
得意先コードを設定します。

パラメータ:
customer - 得意先コード

setCheckRule

public void setCheckRule(String checkRule)
確認規則を設定します。

パラメータ:
checkRule - 確認規則

setBatch

public void setBatch(String batch)
ロットを設定します。

パラメータ:
batch - ロット

setEndleadtme

public void setEndleadtme(String endleadtme)
補充リードタイムの終了日付を設定します。

パラメータ:
endleadtme - 補充リードタイムの終了日付

setDialogflag

public void setDialogflag(String dialogflag)
区分 (X = 利用不可 /N = 確認なし)を設定します。

パラメータ:
dialogflag - 区分 (X = 利用不可 /N = 確認なし)

setAvQtyPlt

public void setAvQtyPlt(String avQtyPlt)
プラントレベル利用可能数量を設定します。

パラメータ:
avQtyPlt - プラントレベル利用可能数量

setWmdvexList

public void setWmdvexList(List wmdvexList)
出力テーブル (日付および ATP 数量)を設定します。

パラメータ:
wmdvexList - 出力テーブル (日付および ATP 数量)

setWmdvsxList

public void setWmdvsxList(List wmdvsxList)
入力テーブル (日付/数量)を設定します。

パラメータ:
wmdvsxList - 入力テーブル (日付/数量)

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目在庫確認情報を取得する為の条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用アプリケーション例外
SAPGeneralAppException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
取得した品目在庫確認情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス
MaterialAvailability
ParamWmdvex
ParamWmdvsx
Wmdvex
Wmdvsx


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

クラスの概要
MaterialAvailability | 品目在庫確認情報クラス 機能は以下の通り 品目在庫確認情報を保持します。
ParamWmdvex | 出力テーブル (日付および ATP 数量)パラメータ設定クラス 機能は以下の通り 出力テーブル (日付および ATP 数量)のパラメータを設定します。
ParamWmdvsx | 入力テーブル (日付/数量)パラメータ設定クラス 機能は以下の通り 入力テーブル (日付/数量)のパラメータを設定します。
Wmdvex | 出力テーブル (日付および ATP 数量)情報クラス 機能は以下の通り 出力テーブル (日付および ATP 数量)情報を保持します。
Wmdvsx | 入力テーブル (日付/数量)情報クラス 機能は以下の通り 入力テーブル (日付/数量)情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialavailability クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialavailability のクラス
MaterialAvailability
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamWmdvex (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス ParamWmdvex

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex
すべての実装インタフェース:
Serializable
public final class ParamWmdvex
extends Object
implements Serializable

出力テーブル (日付および ATP 数量)パラメータ設定クラス
機能は以下の通り

  • 出力テーブル (日付および ATP 数量)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List wmdvexList) table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
static void | setImportParam(BapiController bapiController, List wmdvexList) 出力テーブル (日付および ATP 数量)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List wmdvexList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
出力テーブル (日付および ATP 数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvexList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List wmdvexList)
                           throws SAPGeneralSystemException
table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvexList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamWmdvsx (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス ParamWmdvsx

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx
すべての実装インタフェース:
Serializable
public final class ParamWmdvsx
extends Object
implements Serializable

入力テーブル (日付/数量)パラメータ設定クラス
機能は以下の通り

  • 入力テーブル (日付/数量)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List wmdvsxList) table(Export)情報から入力テーブル (日付/数量)の値をセットします。
static void | setImportParam(BapiController bapiController, List wmdvsxList) 入力テーブル (日付/数量)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List wmdvsxList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入力テーブル (日付/数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvsxList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List wmdvsxList)
                           throws SAPGeneralSystemException
table(Export)情報から入力テーブル (日付/数量)の値をセットします。

パラメータ:
bapiController - BapiController
wmdvsxList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Wmdvex (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス Wmdvex

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex
すべての実装インタフェース:
Serializable
public class Wmdvex
extends Object
implements Serializable

出力テーブル (日付および ATP 数量)情報クラス
機能は以下の通り

  • 出力テーブル (日付および ATP 数量)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Wmdvex()
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvex(int index)
出力テーブル (日付および ATP 数量)情報を作成します。
メソッドの概要
String | getBdcnt() 5 文字数値 NUMCを取得します。
String | getComDate() 確認日を取得します。
String | getComQty() 確認数量を取得します。
int | getIndex() レコード番号を取得します｡
String | getReqDate() 所要日付を取得します。
String | getReqQty() 利用可能在庫確認の所要量を取得します。
void | setBdcnt(String bdcnt) 5 文字数値 NUMCを設定します。
void | setComDate(String comDate) 確認日を設定します。
void | setComQty(String comQty) 確認数量を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setReqDate(String reqDate) 所要日付を設定します。
void | setReqQty(String reqQty) 利用可能在庫確認の所要量を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Wmdvex

public Wmdvex()
出力テーブル (日付および ATP 数量)情報を作成します。

Wmdvex

public Wmdvex(int index)
出力テーブル (日付および ATP 数量)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getBdcnt

public String getBdcnt()
5 文字数値 NUMCを取得します。

戻り値:
bdcnt 5 文字数値 NUMC

getReqDate

public String getReqDate()
所要日付を取得します。

戻り値:
reqDate 所要日付

getReqQty

public String getReqQty()
利用可能在庫確認の所要量を取得します。

戻り値:
reqQty 利用可能在庫確認の所要量

getComDate

public String getComDate()
確認日を取得します。

戻り値:
comDate 確認日

getComQty

public String getComQty()
確認数量を取得します。

戻り値:
comQty 確認数量

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setBdcnt

public void setBdcnt(String bdcnt)
5 文字数値 NUMCを設定します。

パラメータ:
bdcnt - 5 文字数値 NUMC

setReqDate

public void setReqDate(String reqDate)
所要日付を設定します。

パラメータ:
reqDate - 所要日付

setReqQty

public void setReqQty(String reqQty)
利用可能在庫確認の所要量を設定します。

パラメータ:
reqQty - 利用可能在庫確認の所要量

setComDate

public void setComDate(String comDate)
確認日を設定します。

パラメータ:
comDate - 確認日

setComQty

public void setComQty(String comQty)
確認数量を設定します。

パラメータ:
comQty - 確認数量

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Wmdvsx (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
クラス Wmdvsx

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx
すべての実装インタフェース:
Serializable
public class Wmdvsx
extends Object
implements Serializable

入力テーブル (日付/数量)情報クラス
機能は以下の通り

  • 入力テーブル (日付/数量)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Wmdvsx()
入力テーブル (日付/数量)情報を作成します。
Wmdvsx(int index)
入力テーブル (日付/数量)情報を作成します。
メソッドの概要
String | getDelkz() MRP 要素区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getReqDate() 所要日付を取得します。
String | getReqQty() 所要量を取得します。
String | getYline() 内部テ－ブル処理の行索引を取得します。
void | setDelkz(String delkz) MRP 要素区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setReqDate(String reqDate) 所要日付を設定します。
void | setReqQty(String reqQty) 所要量を設定します。
void | setYline(String yline) 内部テ－ブル処理の行索引を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Wmdvsx

public Wmdvsx()
入力テーブル (日付/数量)情報を作成します。

Wmdvsx

public Wmdvsx(int index)
入力テーブル (日付/数量)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getReqDate

public String getReqDate()
所要日付を取得します。

戻り値:
reqDate 所要日付

getReqQty

public String getReqQty()
所要量を取得します。

戻り値:
reqQty 所要量

getDelkz

public String getDelkz()
MRP 要素区分を取得します。

戻り値:
delkz MRP 要素区分

getYline

public String getYline()
内部テ－ブル処理の行索引を取得します。

戻り値:
yline 内部テ－ブル処理の行索引

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setReqDate

public void setReqDate(String reqDate)
所要日付を設定します。

パラメータ:
reqDate - 所要日付

setReqQty

public void setReqQty(String reqQty)
所要量を設定します。

パラメータ:
reqQty - 所要量

setDelkz

public void setDelkz(String delkz)
MRP 要素区分を設定します。

パラメータ:
delkz - MRP 要素区分

setYline

public void setYline(String yline)
内部テ－ブル処理の行索引を設定します。

パラメータ:
yline - 内部テ－ブル処理の行索引

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut の使用

ExtensionOut を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionOut の使用

ExtensionOut を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionOut MaterialGetAllController.getExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers の使用

InternationArticleNumbers を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での InternationArticleNumbers の使用

InternationArticleNumbers を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 InternationArticleNumbers MaterialGetAllController.getInternationArticleNumbers(int index)
EANオブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData の使用

LifoValuationData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での LifoValuationData の使用

LifoValuationData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 LifoValuationData MaterialGetAll.getLifoValuationData()
LIFO 関連品目データを取得します。

LifoValuationData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setLifoValuationData(LifoValuationData lifoValuationData)
LIFO 関連品目データを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll の使用

MaterialGetAll を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetAll の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialGetAll のサブクラス
 class MaterialGetAllController
品目マスタ照会コントローラクラス
機能は以下の通り
品目マスタの情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText の使用

MaterialText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialText の使用

MaterialText を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 MaterialText MaterialGetAllController.getMaterialText(int index)
テキスト (長)オブジェクトが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData の使用

ProductionResourceToolData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall での ProductionResourceToolData の使用

ProductionResourceToolData を返す jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 ProductionResourceToolData MaterialGetAll.getProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

ProductionResourceToolData 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のメソッド
 void MaterialGetAll.setProductionResourceToolData(ProductionResourceToolData productionResourceToolData)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtensionOut (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス ExtensionOut

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut
すべての実装インタフェース:
Serializable
public class ExtensionOut
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionOut()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionOut

public ExtensionOut()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

ExtensionOut

public ExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart4 - BAPI 拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


InternationArticleNumbers (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス InternationArticleNumbers

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers
すべての実装インタフェース:
Serializable
public class InternationArticleNumbers
extends Object
implements Serializable

EAN情報クラス
機能は以下の通り

  • EAN情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
InternationArticleNumbers()
EAN情報を作成します。
InternationArticleNumbers(int index)
EAN情報を作成します。
メソッドの概要
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
int | getIndex() レコード番号を取得します｡
String | getMainEan() 区分: 主要 EANを取得します。
String | getUnit() 表示数量単位を取得します。
String | getUnitIso() ISO コードでの表示数量単位を取得します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMainEan(String mainEan) 区分: 主要 EANを設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setUnitIso(String unitIso) ISO コードでの表示数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternationArticleNumbers

public InternationArticleNumbers()
EAN情報を作成します。

InternationArticleNumbers

public InternationArticleNumbers(int index)
EAN情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getUnitIso

public String getUnitIso()
ISO コードでの表示数量単位を取得します。

戻り値:
unitIso ISO コードでの表示数量単位

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getMainEan

public String getMainEan()
区分: 主要 EANを取得します。

戻り値:
mainEan 区分: 主要 EAN

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setUnitIso

public void setUnitIso(String unitIso)
ISO コードでの表示数量単位を設定します。

パラメータ:
unitIso - ISO コードでの表示数量単位

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setMainEan

public void setMainEan(String mainEan)
区分: 主要 EANを設定します。

パラメータ:
mainEan - 区分: 主要 EAN

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LifoValuationData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス LifoValuationData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData
すべての実装インタフェース:
Serializable
public class LifoValuationData
extends Object
implements Serializable

LIFO 関連品目データ情報クラス
機能は以下の通り

  • LIFO 関連品目データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
LifoValuationData()
LIFO 関連品目データ情報を作成します。
メソッドの概要
String | getLifoValuationLevel() LIFO 評価レベルを取得します。
String | getPoolnumber() LIFO 評価でのプール番号を取得します。
void | setLifoValuationLevel(String lifoValuationLevel) LIFO 評価レベルを設定します。
void | setPoolnumber(String poolnumber) LIFO 評価でのプール番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LifoValuationData

public LifoValuationData()
LIFO 関連品目データ情報を作成します。

メソッドの詳細

getLifoValuationLevel

public String getLifoValuationLevel()
LIFO 評価レベルを取得します。

戻り値:
lifoValuationLevel LIFO 評価レベル

getPoolnumber

public String getPoolnumber()
LIFO 評価でのプール番号を取得します。

戻り値:
poolnumber LIFO 評価でのプール番号

setLifoValuationLevel

public void setLifoValuationLevel(String lifoValuationLevel)
LIFO 評価レベルを設定します。

パラメータ:
lifoValuationLevel - LIFO 評価レベル

setPoolnumber

public void setPoolnumber(String poolnumber)
LIFO 評価でのプール番号を設定します。

パラメータ:
poolnumber - LIFO 評価でのプール番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetAll (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス MaterialGetAll

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialGetAllController
public class MaterialGetAll
extends ReferenceController
implements Serializable

品目マスタ照会情報クラス
機能は以下の通り

  • 品目マスタ照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。
MaterialGetAll(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
品目マスタ照会情報を作成します。
メソッドの概要
ClientData | getClientData() 品目データ (クライアントレベル)を取得します。
String | getCompanycode() 会社コードを取得します。
String | getDistributionchannel() 流通チャネルを取得します。
List | getExtensionOutList() BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
ForecastParameters | getForecastParameters() 予測パラメータを取得します。
List | getInternationArticleNumbersList() EANを取得します。
LifoValuationData | getLifoValuationData() LIFO 関連品目データを取得します。
String | getLifovaluationlevel() LIFO 評価レベルを取得します。
String | getMaterial() 品目コードを取得します。
List | getMaterialDescriptionList() 品目テキストを取得します。
List | getMaterialTextList() テキスト (長)を取得します。
PlanningData | getPlanningData() 品目マスタ/製品グループの変更伝票構造を取得します。
String | getPlant() プラントを取得します。
PlantData | getPlantData() 品目データ (プラントレベル)を取得します。
ProductionResourceToolData | getProductionResourceToolData() 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
SalesData | getSalesData() 販売データを取得します。
String | getSalesorganisation() 販売組織を取得します。
String | getStoragelocation() 保管場所を取得します。
StorageLocationData | getStorageLocationData() 品目データ (保管場所レベル)を取得します。
String | getStoragetype() 保管域タイプを取得します。
StorageTypeData | getStorageTypeData() 保管域タイプデータを取得します。
List | getTaxClassificationsList() 制御デ－タを取得します。
List | getUnitSofmeasureList() 数量単位を取得します。
String | getValuationarea() 評価レベルを取得します。
ValuationData | getValuationData() 評価データを取得します。
String | getValuationtype() 評価タイプを取得します。
String | getWarehousenumber() 倉庫番号/複合倉庫を取得します。
WarehouseNumberData | getWarehouseNumberData() 倉庫番号データを取得します。
void | initMaterialGetAll() 品目マスタ照会情報を作成します。
void | setClientData(ClientData clientData) 品目データ (クライアントレベル)を設定します。
void | setCompanycode(String companycode) 会社コードを設定します。
void | setDistributionchannel(String distributionchannel) 流通チャネルを設定します。
void | setExpClientData(BapiController bapiController) structure(Export)情報から品目データ (クライアントレベル) を設定します。
void | setExpExtensionOut(BapiController bapiController) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。
void | setExpForecastParameters(BapiController bapiController) structure(Export)情報から予測データを設定します。
void | setExpInternationArticleNumbers(BapiController bapiController) table(Export)情報からEANを設定します。
void | setExpLifoValuationData(BapiController bapiController) structure(Export)情報からLIFO 関連品目データを設定します。
void | setExpMaterialDescription(BapiController bapiController) table(Export)情報から品目テキストを設定します。
void | setExpMaterialText(BapiController bapiController) table(Export)情報からテキスト (長) を設定します。
void | setExportParam(BapiController bapiController) 返却された品目マスタ照会情報をセットします。
void | setExpPlanningData(BapiController bapiController) structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
void | setExpPlantData(BapiController bapiController) structure(Export)情報から品目データ (プラントレベル) を設定します。
void | setExpProductionResourceToolData(BapiController bapiController) structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setExpSalesData(BapiController bapiController) structure(Export)情報から販売データを設定します。
void | setExpStorageLocationData(BapiController bapiController) structure(Export)情報から品目データ (保管場所レベル)を設定します。
void | setExpStorageTypeData(BapiController bapiController) structure(Export)情報から保管域タイプデータを設定します。
void | setExpTaxClassifications(BapiController bapiController) table(Export)情報から制御データを設定します。
void | setExpUnitSofmeasure(BapiController bapiController) table(Export)情報から数量単位を設定します。
void | setExpValuationData(BapiController bapiController) structure(Export)情報から評価データを設定します。
void | setExpWarehouseNumberData(BapiController bapiController) structure(Export)情報から倉庫番号データを設定します。
void | setExtensionOutList(List extensionOutList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
void | setForecastParameters(ForecastParameters forecastParameters) 予測パラメータを設定します。
void | setImpExtensionOut(BapiController bapiController) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
void | setImpInternationArticleNumbers(BapiController bapiController) EANからインポート情報を設定します。
void | setImpMaterialDescription(BapiController bapiController) 品目テキストからインポート情報を設定します。
void | setImpMaterialText(BapiController bapiController) テキスト (長) からインポート情報を設定します。
void | setImportParam(BapiController bapiController) 品目マスタ照会条件ををセットします。
void | setImpTaxClassifications(BapiController bapiController) 制御データからインポート情報を設定します。
void | setImpUnitSofmeasure(BapiController bapiController) 数量単位からインポート情報を設定します。
void | setInternationArticleNumbersList(List internationArticleNumbersList) EANを設定します。
void | setLifoValuationData(LifoValuationData lifoValuationData) LIFO 関連品目データを設定します。
void | setLifovaluationlevel(String lifovaluationlevel) LIFO 評価レベルを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialDescriptionList(List materialDescriptionList) 品目テキストを設定します。
void | setMaterialTextList(List materialTextList) テキスト (長)を設定します。
void | setPlanningData(PlanningData planningData) 品目マスタ/製品グループの変更伝票構造を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPlantData(PlantData plantData) 品目データ (プラントレベル)を設定します。
void | setProductionResourceToolData(ProductionResourceToolData productionResourceToolData) 品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setSalesData(SalesData salesData) 販売データを設定します。
void | setSalesorganisation(String salesorganisation) 販売組織を設定します。
void | setStoragelocation(String storagelocation) 保管場所を設定します。
void | setStorageLocationData(StorageLocationData storageLocationData) 品目データ (保管場所レベル)を設定します。
void | setStoragetype(String storagetype) 保管域タイプを設定します。
void | setStorageTypeData(StorageTypeData storageTypeData) 保管域タイプデータを設定します。
void | setTaxClassificationsList(List taxClassificationsList) 制御デ－タを設定します。
void | setUnitSofmeasureList(List unitSofmeasureList) 数量単位を設定します。
void | setValuationarea(String valuationarea) 評価レベルを設定します。
void | setValuationData(ValuationData valuationData) 評価データを設定します。
void | setValuationtype(String valuationtype) 評価タイプを設定します。
void | setWarehousenumber(String warehousenumber) 倉庫番号/複合倉庫を設定します。
void | setWarehouseNumberData(WarehouseNumberData warehouseNumberData) 倉庫番号データを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetAll

public MaterialGetAll(SapClient sapClient)
品目マスタ照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

MaterialGetAll

public MaterialGetAll(String material,
                      String companyCode,
                      String plant,
                      String storageLocation,
                      String salesOrganisation,
                      String distributionChannel,
                      SapClient sapClient)
品目マスタ照会情報を作成します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル
sapClient - SAPクライアント
メソッドの詳細

initMaterialGetAll

public void initMaterialGetAll()
品目マスタ照会情報を作成します。

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目マスタ照会条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された品目マスタ照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setImpMaterialDescription

public void setImpMaterialDescription(BapiController bapiController)
                               throws SAPGeneralSystemException,
                                      SAPGeneralAppException
品目テキストからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpUnitSofmeasure

public void setImpUnitSofmeasure(BapiController bapiController)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
数量単位からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpInternationArticleNumbers

public void setImpInternationArticleNumbers(BapiController bapiController)
                                     throws SAPGeneralSystemException,
                                            SAPGeneralAppException
EANからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpMaterialText

public void setImpMaterialText(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
テキスト (長) からインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpTaxClassifications

public void setImpTaxClassifications(BapiController bapiController)
                              throws SAPGeneralSystemException,
                                     SAPGeneralAppException
制御データからインポート情報を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setImpExtensionOut

public void setImpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException,
                               SAPGeneralAppException
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExpClientData

public void setExpClientData(BapiController bapiController)
                      throws SAPGeneralSystemException
structure(Export)情報から品目データ (クライアントレベル) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpPlantData

public void setExpPlantData(BapiController bapiController)
                     throws SAPGeneralSystemException
structure(Export)情報から品目データ (プラントレベル) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpForecastParameters

public void setExpForecastParameters(BapiController bapiController)
                              throws SAPGeneralSystemException
structure(Export)情報から予測データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpPlanningData

public void setExpPlanningData(BapiController bapiController)
                        throws SAPGeneralSystemException
structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpStorageLocationData

public void setExpStorageLocationData(BapiController bapiController)
                               throws SAPGeneralSystemException
structure(Export)情報から品目データ (保管場所レベル)を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpValuationData

public void setExpValuationData(BapiController bapiController)
                         throws SAPGeneralSystemException
structure(Export)情報から評価データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpWarehouseNumberData

public void setExpWarehouseNumberData(BapiController bapiController)
                               throws SAPGeneralSystemException
structure(Export)情報から倉庫番号データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpSalesData

public void setExpSalesData(BapiController bapiController)
                     throws SAPGeneralSystemException
structure(Export)情報から販売データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpStorageTypeData

public void setExpStorageTypeData(BapiController bapiController)
                           throws SAPGeneralSystemException
structure(Export)情報から保管域タイプデータを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpProductionResourceToolData

public void setExpProductionResourceToolData(BapiController bapiController)
                                      throws SAPGeneralSystemException
structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpLifoValuationData

public void setExpLifoValuationData(BapiController bapiController)
                             throws SAPGeneralSystemException
structure(Export)情報からLIFO 関連品目データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpMaterialDescription

public void setExpMaterialDescription(BapiController bapiController)
                               throws SAPGeneralSystemException
table(Export)情報から品目テキストを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpUnitSofmeasure

public void setExpUnitSofmeasure(BapiController bapiController)
                          throws SAPGeneralSystemException
table(Export)情報から数量単位を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpInternationArticleNumbers

public void setExpInternationArticleNumbers(BapiController bapiController)
                                     throws SAPGeneralSystemException
table(Export)情報からEANを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpMaterialText

public void setExpMaterialText(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からテキスト (長) を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpTaxClassifications

public void setExpTaxClassifications(BapiController bapiController)
                              throws SAPGeneralSystemException
table(Export)情報から制御データを設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setExpExtensionOut

public void setExpExtensionOut(BapiController bapiController)
                        throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesorganisation

public String getSalesorganisation()
販売組織を取得します。

戻り値:
salesorganisation 販売組織

getStoragelocation

public String getStoragelocation()
保管場所を取得します。

戻り値:
storagelocation 保管場所

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoragetype

public String getStoragetype()
保管域タイプを取得します。

戻り値:
storagetype 保管域タイプ

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getLifovaluationlevel

public String getLifovaluationlevel()
LIFO 評価レベルを取得します。

戻り値:
lifovaluationlevel LIFO 評価レベル

getValuationarea

public String getValuationarea()
評価レベルを取得します。

戻り値:
valuationarea 評価レベル

getValuationtype

public String getValuationtype()
評価タイプを取得します。

戻り値:
valuationtype 評価タイプ

getWarehousenumber

public String getWarehousenumber()
倉庫番号/複合倉庫を取得します。

戻り値:
warehousenumber 倉庫番号/複合倉庫

getDistributionchannel

public String getDistributionchannel()
流通チャネルを取得します。

戻り値:
distributionchannel 流通チャネル

getCompanycode

public String getCompanycode()
会社コードを取得します。

戻り値:
companycode 会社コード

getValuationData

public ValuationData getValuationData()
評価データを取得します。

戻り値:
valuationData 評価データ

getStorageTypeData

public StorageTypeData getStorageTypeData()
保管域タイプデータを取得します。

戻り値:
storageTypeData 保管域タイプデータ

getStorageLocationData

public StorageLocationData getStorageLocationData()
品目データ (保管場所レベル)を取得します。

戻り値:
storageLocationData 品目データ (保管場所レベル)

getWarehouseNumberData

public WarehouseNumberData getWarehouseNumberData()
倉庫番号データを取得します。

戻り値:
warehouseNumberData 倉庫番号データ

getSalesData

public SalesData getSalesData()
販売データを取得します。

戻り値:
salesData 販売データ

getClientData

public ClientData getClientData()
品目データ (クライアントレベル)を取得します。

戻り値:
clientData 品目データ (クライアントレベル)

getProductionResourceToolData

public ProductionResourceToolData getProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

戻り値:
productionResourceToolData 品目マスタの生産資源/治工具 (PRT) 項目

getPlantData

public PlantData getPlantData()
品目データ (プラントレベル)を取得します。

戻り値:
plantData 品目データ (プラントレベル)

getPlanningData

public PlanningData getPlanningData()
品目マスタ/製品グループの変更伝票構造を取得します。

戻り値:
planningData 品目マスタ/製品グループの変更伝票構造

getForecastParameters

public ForecastParameters getForecastParameters()
予測パラメータを取得します。

戻り値:
forecastParameters 予測パラメータ

getLifoValuationData

public LifoValuationData getLifoValuationData()
LIFO 関連品目データを取得します。

戻り値:
lifoValuationData LIFO 関連品目データ

getExtensionOutList

public List getExtensionOutList()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。

戻り値:
extensionOutList BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

getInternationArticleNumbersList

public List getInternationArticleNumbersList()
EANを取得します。

戻り値:
internationArticleNumbersList EAN

getUnitSofmeasureList

public List getUnitSofmeasureList()
数量単位を取得します。

戻り値:
unitSofmeasureList 数量単位

getTaxClassificationsList

public List getTaxClassificationsList()
制御デ－タを取得します。

戻り値:
taxClassificationsList 制御デ－タ

getMaterialDescriptionList

public List getMaterialDescriptionList()
品目テキストを取得します。

戻り値:
materialDescriptionList 品目テキスト

getMaterialTextList

public List getMaterialTextList()
テキスト (長)を取得します。

戻り値:
materialTextList テキスト (長)

setSalesorganisation

public void setSalesorganisation(String salesorganisation)
販売組織を設定します。

パラメータ:
salesorganisation - 販売組織

setStoragelocation

public void setStoragelocation(String storagelocation)
保管場所を設定します。

パラメータ:
storagelocation - 保管場所

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoragetype

public void setStoragetype(String storagetype)
保管域タイプを設定します。

パラメータ:
storagetype - 保管域タイプ

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setLifovaluationlevel

public void setLifovaluationlevel(String lifovaluationlevel)
LIFO 評価レベルを設定します。

パラメータ:
lifovaluationlevel - LIFO 評価レベル

setValuationarea

public void setValuationarea(String valuationarea)
評価レベルを設定します。

パラメータ:
valuationarea - 評価レベル

setValuationtype

public void setValuationtype(String valuationtype)
評価タイプを設定します。

パラメータ:
valuationtype - 評価タイプ

setWarehousenumber

public void setWarehousenumber(String warehousenumber)
倉庫番号/複合倉庫を設定します。

パラメータ:
warehousenumber - 倉庫番号/複合倉庫

setDistributionchannel

public void setDistributionchannel(String distributionchannel)
流通チャネルを設定します。

パラメータ:
distributionchannel - 流通チャネル

setCompanycode

public void setCompanycode(String companycode)
会社コードを設定します。

パラメータ:
companycode - 会社コード

setValuationData

public void setValuationData(ValuationData valuationData)
評価データを設定します。

パラメータ:
valuationData - 評価データ

setStorageTypeData

public void setStorageTypeData(StorageTypeData storageTypeData)
保管域タイプデータを設定します。

パラメータ:
storageTypeData - 保管域タイプデータ

setStorageLocationData

public void setStorageLocationData(StorageLocationData storageLocationData)
品目データ (保管場所レベル)を設定します。

パラメータ:
storageLocationData - 品目データ (保管場所レベル)

setWarehouseNumberData

public void setWarehouseNumberData(WarehouseNumberData warehouseNumberData)
倉庫番号データを設定します。

パラメータ:
warehouseNumberData - 倉庫番号データ

setSalesData

public void setSalesData(SalesData salesData)
販売データを設定します。

パラメータ:
salesData - 販売データ

setClientData

public void setClientData(ClientData clientData)
品目データ (クライアントレベル)を設定します。

パラメータ:
clientData - 品目データ (クライアントレベル)

setProductionResourceToolData

public void setProductionResourceToolData(ProductionResourceToolData productionResourceToolData)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
productionResourceToolData - 品目マスタの生産資源/治工具 (PRT) 項目

setPlantData

public void setPlantData(PlantData plantData)
品目データ (プラントレベル)を設定します。

パラメータ:
plantData - 品目データ (プラントレベル)

setPlanningData

public void setPlanningData(PlanningData planningData)
品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
planningData - 品目マスタ/製品グループの変更伝票構造

setForecastParameters

public void setForecastParameters(ForecastParameters forecastParameters)
予測パラメータを設定します。

パラメータ:
forecastParameters - 予測パラメータ

setLifoValuationData

public void setLifoValuationData(LifoValuationData lifoValuationData)
LIFO 関連品目データを設定します。

パラメータ:
lifoValuationData - LIFO 関連品目データ

setExtensionOutList

public void setExtensionOutList(List extensionOutList)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。

パラメータ:
extensionOutList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

setInternationArticleNumbersList

public void setInternationArticleNumbersList(List internationArticleNumbersList)
EANを設定します。

パラメータ:
internationArticleNumbersList - EAN

setUnitSofmeasureList

public void setUnitSofmeasureList(List unitSofmeasureList)
数量単位を設定します。

パラメータ:
unitSofmeasureList - 数量単位

setTaxClassificationsList

public void setTaxClassificationsList(List taxClassificationsList)
制御デ－タを設定します。

パラメータ:
taxClassificationsList - 制御デ－タ

setMaterialDescriptionList

public void setMaterialDescriptionList(List materialDescriptionList)
品目テキストを設定します。

パラメータ:
materialDescriptionList - 品目テキスト

setMaterialTextList

public void setMaterialTextList(List materialTextList)
テキスト (長)を設定します。

パラメータ:
materialTextList - テキスト (長)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス MaterialText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText
すべての実装インタフェース:
Serializable
public class MaterialText
extends Object
implements Serializable

テキスト (長)情報クラス
機能は以下の通り

  • テキスト (長)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialText()
テキスト (長)情報を作成します。
MaterialText(int index)
テキスト (長)情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getFormatCol() タグ列を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
String | getTextName() 名称を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
void | setTextName(String textName) 名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialText

public MaterialText()
テキスト (長)情報を作成します。

MaterialText

public MaterialText(int index)
テキスト (長)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextName

public String getTextName()
名称を取得します。

戻り値:
textName 名称

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextName

public void setTextName(String textName)
名称を設定します。

パラメータ:
textName - 名称

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス
ExtensionOut
InternationArticleNumbers
LifoValuationData
MaterialGetAll
MaterialText
ProductionResourceToolData


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

クラスの概要
ExtensionOut | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
InternationArticleNumbers | EAN情報クラス 機能は以下の通り EAN情報を保持します。
LifoValuationData | LIFO 関連品目データ情報クラス 機能は以下の通り LIFO 関連品目データ情報を保持します。
MaterialGetAll | 品目マスタ照会情報クラス 機能は以下の通り 品目マスタ照会情報を保持します。
MaterialText | テキスト (長)情報クラス 機能は以下の通り テキスト (長)情報を保持します。
ProductionResourceToolData | 品目マスタの生産資源/治工具 (PRT) 項目情報クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialgetall クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のクラス
ExtensionOut
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
InternationArticleNumbers
EAN情報クラス
機能は以下の通り
EAN情報を保持します。
MaterialGetAll
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。
MaterialText
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialgetall のクラス
LifoValuationData
LIFO 関連品目データ情報クラス
機能は以下の通り
LIFO 関連品目データ情報を保持します。
ProductionResourceToolData
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProductionResourceToolData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
クラス ProductionResourceToolData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData
すべての実装インタフェース:
Serializable
public class ProductionResourceToolData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
メソッドの概要
String | getCreateLoadRecs() 区分: 生産資源/治工具の負荷レコード登録を取得します。
String | getCtrlKey() 生産資源/治工具管理の管理キーを取得します。
String | getCtrlKeyNoChg() 管理キーは変更できませんを取得します。
String | getEndOffset() 生産資源/治工具用途の終了オフセットを取得します。
String | getEndOffsetNoChg() 終了オフセットは変更できませんを取得します。
String | getEndOffsetUnit() 生産資源/治工具使用終了オフセット単位を取得します。
String | getEndOffsetUnitIso() PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
String | getEndRefDate() 生産資源/治工具使用終了日の参照日付を取得します。
String | getEndRefDateNoChg() 終了参照日付は変更できませんを取得します。
String | getFormulaTotQty() 生産資源/治工具の合計数量の計算式を取得します。
String | getFormulaTotQtyNoChg() 合計数量の計算式は変更できませんを取得します。
String | getFormulaTotUsage() 生産資源/治工具の総用途値の計算式を取得します。
String | getFormulaTotUsageNoChg() すべての用途値を計算する計算式は変更できませんを取得します。
String | getGrpKey1() 生産資源/治工具のグループキー 1を取得します。
String | getGrpKey2() 生産資源/治工具のグループキー 2を取得します。
String | getPlant() プラントを取得します。
String | getPrtUsage() 生産資源/治工具用途を取得します。
String | getRefKeyNoChg() 参照キーは変更できませんを取得します。
String | getStartOffset() 生産資源/治工具使用の開始オフセットを取得します。
String | getStartOffsetNoChg() 開始オフセットは変更できませんを取得します。
String | getStartOffsetUnit() 生産資源/治工具使用開始のオフセット単位を取得します。
String | getStartOffsetUnitIso() PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
String | getStartRefDate() 生産資源/治工具使用開始の参照日付を取得します。
String | getStdTextKey() 生産資源/治工具の標準テキストキーを取得します。
String | getStRefDateNoChg() 開始参照日付は変更できませんを取得します。
void | setCreateLoadRecs(String createLoadRecs) 区分: 生産資源/治工具の負荷レコード登録を設定します。
void | setCtrlKey(String ctrlKey) 生産資源/治工具管理の管理キーを設定します。
void | setCtrlKeyNoChg(String ctrlKeyNoChg) 管理キーは変更できませんを設定します。
void | setEndOffset(String endOffset) 生産資源/治工具用途の終了オフセットを設定します。
void | setEndOffsetNoChg(String endOffsetNoChg) 終了オフセットは変更できませんを設定します。
void | setEndOffsetUnit(String endOffsetUnit) 生産資源/治工具使用終了オフセット単位を設定します。
void | setEndOffsetUnitIso(String endOffsetUnitIso) PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
void | setEndRefDate(String endRefDate) 生産資源/治工具使用終了日の参照日付を設定します。
void | setEndRefDateNoChg(String endRefDateNoChg) 終了参照日付は変更できませんを設定します。
void | setFormulaTotQty(String formulaTotQty) 生産資源/治工具の合計数量の計算式を設定します。
void | setFormulaTotQtyNoChg(String formulaTotQtyNoChg) 合計数量の計算式は変更できませんを設定します。
void | setFormulaTotUsage(String formulaTotUsage) 生産資源/治工具の総用途値の計算式を設定します。
void | setFormulaTotUsageNoChg(String formulaTotUsageNoChg) すべての用途値を計算する計算式は変更できませんを設定します。
void | setGrpKey1(String grpKey1) 生産資源/治工具のグループキー 1を設定します。
void | setGrpKey2(String grpKey2) 生産資源/治工具のグループキー 2を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPrtUsage(String prtUsage) 生産資源/治工具用途を設定します。
void | setRefKeyNoChg(String refKeyNoChg) 参照キーは変更できませんを設定します。
void | setStartOffset(String startOffset) 生産資源/治工具使用の開始オフセットを設定します。
void | setStartOffsetNoChg(String startOffsetNoChg) 開始オフセットは変更できませんを設定します。
void | setStartOffsetUnit(String startOffsetUnit) 生産資源/治工具使用開始のオフセット単位を設定します。
void | setStartOffsetUnitIso(String startOffsetUnitIso) PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
void | setStartRefDate(String startRefDate) 生産資源/治工具使用開始の参照日付を設定します。
void | setStdTextKey(String stdTextKey) 生産資源/治工具の標準テキストキーを設定します。
void | setStRefDateNoChg(String stRefDateNoChg) 開始参照日付は変更できませんを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProductionResourceToolData

public ProductionResourceToolData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

メソッドの詳細

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getCreateLoadRecs

public String getCreateLoadRecs()
区分: 生産資源/治工具の負荷レコード登録を取得します。

戻り値:
createLoadRecs 区分: 生産資源/治工具の負荷レコード登録

getCtrlKey

public String getCtrlKey()
生産資源/治工具管理の管理キーを取得します。

戻り値:
ctrlKey 生産資源/治工具管理の管理キー

getCtrlKeyNoChg

public String getCtrlKeyNoChg()
管理キーは変更できませんを取得します。

戻り値:
ctrlKeyNoChg 管理キーは変更できません

getGrpKey1

public String getGrpKey1()
生産資源/治工具のグループキー 1を取得します。

戻り値:
grpKey1 生産資源/治工具のグループキー 1

getGrpKey2

public String getGrpKey2()
生産資源/治工具のグループキー 2を取得します。

戻り値:
grpKey2 生産資源/治工具のグループキー 2

getPrtUsage

public String getPrtUsage()
生産資源/治工具用途を取得します。

戻り値:
prtUsage 生産資源/治工具用途

getStdTextKey

public String getStdTextKey()
生産資源/治工具の標準テキストキーを取得します。

戻り値:
stdTextKey 生産資源/治工具の標準テキストキー

getRefKeyNoChg

public String getRefKeyNoChg()
参照キーは変更できませんを取得します。

戻り値:
refKeyNoChg 参照キーは変更できません

getStartRefDate

public String getStartRefDate()
生産資源/治工具使用開始の参照日付を取得します。

戻り値:
startRefDate 生産資源/治工具使用開始の参照日付

getStRefDateNoChg

public String getStRefDateNoChg()
開始参照日付は変更できませんを取得します。

戻り値:
stRefDateNoChg 開始参照日付は変更できません

getStartOffset

public String getStartOffset()
生産資源/治工具使用の開始オフセットを取得します。

戻り値:
startOffset 生産資源/治工具使用の開始オフセット

getStartOffsetUnit

public String getStartOffsetUnit()
生産資源/治工具使用開始のオフセット単位を取得します。

戻り値:
startOffsetUnit 生産資源/治工具使用開始のオフセット単位

getStartOffsetUnitIso

public String getStartOffsetUnitIso()
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。

戻り値:
startOffsetUnitIso PRT 用途開始決定の間隔時間単位 (ISO)

getStartOffsetNoChg

public String getStartOffsetNoChg()
開始オフセットは変更できませんを取得します。

戻り値:
startOffsetNoChg 開始オフセットは変更できません

getEndRefDate

public String getEndRefDate()
生産資源/治工具使用終了日の参照日付を取得します。

戻り値:
endRefDate 生産資源/治工具使用終了日の参照日付

getEndRefDateNoChg

public String getEndRefDateNoChg()
終了参照日付は変更できませんを取得します。

戻り値:
endRefDateNoChg 終了参照日付は変更できません

getEndOffset

public String getEndOffset()
生産資源/治工具用途の終了オフセットを取得します。

戻り値:
endOffset 生産資源/治工具用途の終了オフセット

getEndOffsetUnit

public String getEndOffsetUnit()
生産資源/治工具使用終了オフセット単位を取得します。

戻り値:
endOffsetUnit 生産資源/治工具使用終了オフセット単位

getEndOffsetUnitIso

public String getEndOffsetUnitIso()
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。

戻り値:
endOffsetUnitIso PRT 用途終了決定の間隔時間単位 (ISO)

getEndOffsetNoChg

public String getEndOffsetNoChg()
終了オフセットは変更できませんを取得します。

戻り値:
endOffsetNoChg 終了オフセットは変更できません

getFormulaTotQty

public String getFormulaTotQty()
生産資源/治工具の合計数量の計算式を取得します。

戻り値:
formulaTotQty 生産資源/治工具の合計数量の計算式

getFormulaTotQtyNoChg

public String getFormulaTotQtyNoChg()
合計数量の計算式は変更できませんを取得します。

戻り値:
formulaTotQtyNoChg 合計数量の計算式は変更できません

getFormulaTotUsage

public String getFormulaTotUsage()
生産資源/治工具の総用途値の計算式を取得します。

戻り値:
formulaTotUsage 生産資源/治工具の総用途値の計算式

getFormulaTotUsageNoChg

public String getFormulaTotUsageNoChg()
すべての用途値を計算する計算式は変更できませんを取得します。

戻り値:
formulaTotUsageNoChg すべての用途値を計算する計算式は変更できません

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setCreateLoadRecs

public void setCreateLoadRecs(String createLoadRecs)
区分: 生産資源/治工具の負荷レコード登録を設定します。

パラメータ:
createLoadRecs - 区分: 生産資源/治工具の負荷レコード登録

setCtrlKey

public void setCtrlKey(String ctrlKey)
生産資源/治工具管理の管理キーを設定します。

パラメータ:
ctrlKey - 生産資源/治工具管理の管理キー

setCtrlKeyNoChg

public void setCtrlKeyNoChg(String ctrlKeyNoChg)
管理キーは変更できませんを設定します。

パラメータ:
ctrlKeyNoChg - 管理キーは変更できません

setGrpKey1

public void setGrpKey1(String grpKey1)
生産資源/治工具のグループキー 1を設定します。

パラメータ:
grpKey1 - 生産資源/治工具のグループキー 1

setGrpKey2

public void setGrpKey2(String grpKey2)
生産資源/治工具のグループキー 2を設定します。

パラメータ:
grpKey2 - 生産資源/治工具のグループキー 2

setPrtUsage

public void setPrtUsage(String prtUsage)
生産資源/治工具用途を設定します。

パラメータ:
prtUsage - 生産資源/治工具用途

setStdTextKey

public void setStdTextKey(String stdTextKey)
生産資源/治工具の標準テキストキーを設定します。

パラメータ:
stdTextKey - 生産資源/治工具の標準テキストキー

setRefKeyNoChg

public void setRefKeyNoChg(String refKeyNoChg)
参照キーは変更できませんを設定します。

パラメータ:
refKeyNoChg - 参照キーは変更できません

setStartRefDate

public void setStartRefDate(String startRefDate)
生産資源/治工具使用開始の参照日付を設定します。

パラメータ:
startRefDate - 生産資源/治工具使用開始の参照日付

setStRefDateNoChg

public void setStRefDateNoChg(String stRefDateNoChg)
開始参照日付は変更できませんを設定します。

パラメータ:
stRefDateNoChg - 開始参照日付は変更できません

setStartOffset

public void setStartOffset(String startOffset)
生産資源/治工具使用の開始オフセットを設定します。

パラメータ:
startOffset - 生産資源/治工具使用の開始オフセット

setStartOffsetUnit

public void setStartOffsetUnit(String startOffsetUnit)
生産資源/治工具使用開始のオフセット単位を設定します。

パラメータ:
startOffsetUnit - 生産資源/治工具使用開始のオフセット単位

setStartOffsetUnitIso

public void setStartOffsetUnitIso(String startOffsetUnitIso)
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。

パラメータ:
startOffsetUnitIso - PRT 用途開始決定の間隔時間単位 (ISO)

setStartOffsetNoChg

public void setStartOffsetNoChg(String startOffsetNoChg)
開始オフセットは変更できませんを設定します。

パラメータ:
startOffsetNoChg - 開始オフセットは変更できません

setEndRefDate

public void setEndRefDate(String endRefDate)
生産資源/治工具使用終了日の参照日付を設定します。

パラメータ:
endRefDate - 生産資源/治工具使用終了日の参照日付

setEndRefDateNoChg

public void setEndRefDateNoChg(String endRefDateNoChg)
終了参照日付は変更できませんを設定します。

パラメータ:
endRefDateNoChg - 終了参照日付は変更できません

setEndOffset

public void setEndOffset(String endOffset)
生産資源/治工具用途の終了オフセットを設定します。

パラメータ:
endOffset - 生産資源/治工具用途の終了オフセット

setEndOffsetUnit

public void setEndOffsetUnit(String endOffsetUnit)
生産資源/治工具使用終了オフセット単位を設定します。

パラメータ:
endOffsetUnit - 生産資源/治工具使用終了オフセット単位

setEndOffsetUnitIso

public void setEndOffsetUnitIso(String endOffsetUnitIso)
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。

パラメータ:
endOffsetUnitIso - PRT 用途終了決定の間隔時間単位 (ISO)

setEndOffsetNoChg

public void setEndOffsetNoChg(String endOffsetNoChg)
終了オフセットは変更できませんを設定します。

パラメータ:
endOffsetNoChg - 終了オフセットは変更できません

setFormulaTotQty

public void setFormulaTotQty(String formulaTotQty)
生産資源/治工具の合計数量の計算式を設定します。

パラメータ:
formulaTotQty - 生産資源/治工具の合計数量の計算式

setFormulaTotQtyNoChg

public void setFormulaTotQtyNoChg(String formulaTotQtyNoChg)
合計数量の計算式は変更できませんを設定します。

パラメータ:
formulaTotQtyNoChg - 合計数量の計算式は変更できません

setFormulaTotUsage

public void setFormulaTotUsage(String formulaTotUsage)
生産資源/治工具の総用途値の計算式を設定します。

パラメータ:
formulaTotUsage - 生産資源/治工具の総用途値の計算式

setFormulaTotUsageNoChg

public void setFormulaTotUsageNoChg(String formulaTotUsageNoChg)
すべての用途値を計算する計算式は変更できませんを設定します。

パラメータ:
formulaTotUsageNoChg - すべての用途値を計算する計算式は変更できません

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn の使用

ExtensionIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionIn の使用

ExtensionIn を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionIn MaterialSaveReplicaController.getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX の使用

ExtensionInX を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ExtensionInX の使用

ExtensionInX を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ExtensionInX MaterialSaveReplicaController.getExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues の使用

ForecastValues を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での ForecastValues の使用

ForecastValues を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 ForecastValues MaterialSaveReplicaController.getForecastValues(int index)
需要予測値のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData の使用

HeadData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での HeadData の使用

HeadData を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 HeadData MaterialSaveReplicaController.getHeadData(int index)
管理情報設定ヘッダセグメントが既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos の使用

InternationalArtnos を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での InternationalArtnos の使用

InternationalArtnos を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 InternationalArtnos MaterialSaveReplicaController.getInternationalArtnos(int index)
国際商品コード (EAN)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText の使用

MaterialLongText を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialLongText の使用

MaterialLongText を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 MaterialLongText MaterialSaveReplicaController.getMaterialLongText(int index)
テキスト (長)が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica の使用

MaterialSaveReplica を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での MaterialSaveReplica の使用

jp.co.intra_mart.foundation.sap.module.purchase での MaterialSaveReplica のサブクラス
 class MaterialSaveReplicaController
品目マスタ更新コントローラクラス
機能は以下の通り
品目マスタを更新します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData の使用

PrtData を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での PrtData の使用

PrtData を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 PrtData MaterialSaveReplicaController.getPrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption の使用

TotalConsumption を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での TotalConsumption の使用

TotalConsumption を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 TotalConsumption MaterialSaveReplicaController.getTotalConsumption(int index)
品目総消費量のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption の使用

UnplndConsumption を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase での UnplndConsumption の使用

UnplndConsumption を返す jp.co.intra_mart.foundation.sap.module.purchase のメソッド
 UnplndConsumption MaterialSaveReplicaController.getUnplndConsumption(int index)
計画外消費のデータ転送が既に存在するかチェックします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ExtensionIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
メソッドの概要
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() 長さ 229 の文字データのコンテナを取得します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) 長さ 229 の文字データのコンテナを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

ExtensionIn

public ExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
長さ 229 の文字データのコンテナを取得します。

戻り値:
valuepart4 長さ 229 の文字データのコンテナ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
長さ 229 の文字データのコンテナを設定します。

パラメータ:
valuepart4 - 長さ 229 の文字データのコンテナ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtensionInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ExtensionInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX
すべての実装インタフェース:
Serializable
public class ExtensionInX
extends Object
implements Serializable

拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り

  • 拡張イン/拡張アウトのチェックボックス構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionInX()
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
メソッドの概要
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() 長さ 229 の文字データのコンテナを取得します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) 長さ 229 の文字データのコンテナを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionInX

public ExtensionInX()
拡張イン/拡張アウトのチェックボックス構造情報を作成します。

ExtensionInX

public ExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
長さ 229 の文字データのコンテナを取得します。

戻り値:
valuepart4 長さ 229 の文字データのコンテナ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
長さ 229 の文字データのコンテナを設定します。

パラメータ:
valuepart4 - 長さ 229 の文字データのコンテナ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ForecastValues (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ForecastValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues
すべての実装インタフェース:
Serializable
public class ForecastValues
extends Object
implements Serializable

需要予測値のデータ転送情報クラス
機能は以下の通り

  • 需要予測値のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ForecastValues()
需要予測値のデータ転送情報を作成します。
ForecastValues(int index)
需要予測値のデータ転送情報を作成します。
メソッドの概要
String | getCorrValue() 需要予測に対する修正値を取得します。
String | getCvalueFxd() 区分: 消費金額の確定を取得します。
String | getExpostVal() 事後的需要予測値を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getForeValue() 予測値を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getSeasIndex() 季節指数を取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setCorrValue(String corrValue) 需要予測に対する修正値を設定します。
void | setCvalueFxd(String cvalueFxd) 区分: 消費金額の確定を設定します。
void | setExpostVal(String expostVal) 事後的需要予測値を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setForeValue(String foreValue) 予測値を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setSeasIndex(String seasIndex) 季節指数を設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ForecastValues

public ForecastValues()
需要予測値のデータ転送情報を作成します。

ForecastValues

public ForecastValues(int index)
需要予測値のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getForeValue

public String getForeValue()
予測値を取得します。

戻り値:
foreValue 予測値

getCorrValue

public String getCorrValue()
需要予測に対する修正値を取得します。

戻り値:
corrValue 需要予測に対する修正値

getSeasIndex

public String getSeasIndex()
季節指数を取得します。

戻り値:
seasIndex 季節指数

getCvalueFxd

public String getCvalueFxd()
区分: 消費金額の確定を取得します。

戻り値:
cvalueFxd 区分: 消費金額の確定

getExpostVal

public String getExpostVal()
事後的需要予測値を取得します。

戻り値:
expostVal 事後的需要予測値

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setForeValue

public void setForeValue(String foreValue)
予測値を設定します。

パラメータ:
foreValue - 予測値

setCorrValue

public void setCorrValue(String corrValue)
需要予測に対する修正値を設定します。

パラメータ:
corrValue - 需要予測に対する修正値

setSeasIndex

public void setSeasIndex(String seasIndex)
季節指数を設定します。

パラメータ:
seasIndex - 季節指数

setCvalueFxd

public void setCvalueFxd(String cvalueFxd)
区分: 消費金額の確定を設定します。

パラメータ:
cvalueFxd - 区分: 消費金額の確定

setExpostVal

public void setExpostVal(String expostVal)
事後的需要予測値を設定します。

パラメータ:
expostVal - 事後的需要予測値

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeadData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス HeadData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData
すべての実装インタフェース:
Serializable
public class HeadData
extends Object
implements Serializable

管理情報設定ヘッダセグメント情報クラス
機能は以下の通り

  • 管理情報設定ヘッダセグメント情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeadData()
管理情報設定ヘッダセグメント情報を作成します。
HeadData(int index)
管理情報設定ヘッダセグメント情報を作成します。
メソッドの概要
String | getAccountView() 会計ビューを取得します。
String | getBasicView() 基本データビューを取得します。
String | getCostView() 原価計算ビューを取得します。
String | getForecastView() 需要予測ビューを取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getIndSector() 産業コードを取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatlType() 品目タイプを取得します。
String | getMrpView() 資材所要量計画 (MRP) ビューを取得します。
String | getPrtView() 生産資源/治工具 (PRT) ビューを取得します。
String | getPurchaseView() 購買管理ビューを取得します。
String | getQualityView() 品質管理ビューを取得します。
String | getSalesView() 販売ビューを取得します。
String | getStorageView() 保管ビューを取得します。
String | getWarehouseView() 倉庫管理ビューを取得します。
String | getWorkSchedView() 作業計画ビューを取得します。
void | setAccountView(String accountView) 会計ビューを設定します。
void | setBasicView(String basicView) 基本データビューを設定します。
void | setCostView(String costView) 原価計算ビューを設定します。
void | setForecastView(String forecastView) 需要予測ビューを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIndSector(String indSector) 産業コードを設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatlType(String matlType) 品目タイプを設定します。
void | setMrpView(String mrpView) 資材所要量計画 (MRP) ビューを設定します。
void | setPrtView(String prtView) 生産資源/治工具 (PRT) ビューを設定します。
void | setPurchaseView(String purchaseView) 購買管理ビューを設定します。
void | setQualityView(String qualityView) 品質管理ビューを設定します。
void | setSalesView(String salesView) 販売ビューを設定します。
void | setStorageView(String storageView) 保管ビューを設定します。
void | setWarehouseView(String warehouseView) 倉庫管理ビューを設定します。
void | setWorkSchedView(String workSchedView) 作業計画ビューを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeadData

public HeadData()
管理情報設定ヘッダセグメント情報を作成します。

HeadData

public HeadData(int index)
管理情報設定ヘッダセグメント情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getIndSector

public String getIndSector()
産業コードを取得します。

戻り値:
indSector 産業コード

getMatlType

public String getMatlType()
品目タイプを取得します。

戻り値:
matlType 品目タイプ

getBasicView

public String getBasicView()
基本データビューを取得します。

戻り値:
basicView 基本データビュー

getSalesView

public String getSalesView()
販売ビューを取得します。

戻り値:
salesView 販売ビュー

getPurchaseView

public String getPurchaseView()
購買管理ビューを取得します。

戻り値:
purchaseView 購買管理ビュー

getMrpView

public String getMrpView()
資材所要量計画 (MRP) ビューを取得します。

戻り値:
mrpView 資材所要量計画 (MRP) ビュー

getForecastView

public String getForecastView()
需要予測ビューを取得します。

戻り値:
forecastView 需要予測ビュー

getWorkSchedView

public String getWorkSchedView()
作業計画ビューを取得します。

戻り値:
workSchedView 作業計画ビュー

getPrtView

public String getPrtView()
生産資源/治工具 (PRT) ビューを取得します。

戻り値:
prtView 生産資源/治工具 (PRT) ビュー

getStorageView

public String getStorageView()
保管ビューを取得します。

戻り値:
storageView 保管ビュー

getWarehouseView

public String getWarehouseView()
倉庫管理ビューを取得します。

戻り値:
warehouseView 倉庫管理ビュー

getQualityView

public String getQualityView()
品質管理ビューを取得します。

戻り値:
qualityView 品質管理ビュー

getAccountView

public String getAccountView()
会計ビューを取得します。

戻り値:
accountView 会計ビュー

getCostView

public String getCostView()
原価計算ビューを取得します。

戻り値:
costView 原価計算ビュー

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setIndSector

public void setIndSector(String indSector)
産業コードを設定します。

パラメータ:
indSector - 産業コード

setMatlType

public void setMatlType(String matlType)
品目タイプを設定します。

パラメータ:
matlType - 品目タイプ

setBasicView

public void setBasicView(String basicView)
基本データビューを設定します。

パラメータ:
basicView - 基本データビュー

setSalesView

public void setSalesView(String salesView)
販売ビューを設定します。

パラメータ:
salesView - 販売ビュー

setPurchaseView

public void setPurchaseView(String purchaseView)
購買管理ビューを設定します。

パラメータ:
purchaseView - 購買管理ビュー

setMrpView

public void setMrpView(String mrpView)
資材所要量計画 (MRP) ビューを設定します。

パラメータ:
mrpView - 資材所要量計画 (MRP) ビュー

setForecastView

public void setForecastView(String forecastView)
需要予測ビューを設定します。

パラメータ:
forecastView - 需要予測ビュー

setWorkSchedView

public void setWorkSchedView(String workSchedView)
作業計画ビューを設定します。

パラメータ:
workSchedView - 作業計画ビュー

setPrtView

public void setPrtView(String prtView)
生産資源/治工具 (PRT) ビューを設定します。

パラメータ:
prtView - 生産資源/治工具 (PRT) ビュー

setStorageView

public void setStorageView(String storageView)
保管ビューを設定します。

パラメータ:
storageView - 保管ビュー

setWarehouseView

public void setWarehouseView(String warehouseView)
倉庫管理ビューを設定します。

パラメータ:
warehouseView - 倉庫管理ビュー

setQualityView

public void setQualityView(String qualityView)
品質管理ビューを設定します。

パラメータ:
qualityView - 品質管理ビュー

setAccountView

public void setAccountView(String accountView)
会計ビューを設定します。

パラメータ:
accountView - 会計ビュー

setCostView

public void setCostView(String costView)
原価計算ビューを設定します。

パラメータ:
costView - 原価計算ビュー

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InternationalArtnos (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス InternationalArtnos

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos
すべての実装インタフェース:
Serializable
public class InternationalArtnos
extends Object
implements Serializable

国際商品コード (EAN)情報クラス
機能は以下の通り

  • 国際商品コード (EAN)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
InternationalArtnos()
国際商品コード (EAN)情報を作成します。
InternationalArtnos(int index)
国際商品コード (EAN)情報を作成します。
メソッドの概要
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getEanCat() 国際商品コード (EAN) のカテゴリを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getUnit() 表示数量単位を取得します。
String | getUnitIso() ISO コードでの表示数量単位を取得します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setEanCat(String eanCat) 国際商品コード (EAN) のカテゴリを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setUnit(String unit) 表示数量単位を設定します。
void | setUnitIso(String unitIso) ISO コードでの表示数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InternationalArtnos

public InternationalArtnos()
国際商品コード (EAN)情報を作成します。

InternationalArtnos

public InternationalArtnos(int index)
国際商品コード (EAN)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getUnit

public String getUnit()
表示数量単位を取得します。

戻り値:
unit 表示数量単位

getUnitIso

public String getUnitIso()
ISO コードでの表示数量単位を取得します。

戻り値:
unitIso ISO コードでの表示数量単位

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getEanCat

public String getEanCat()
国際商品コード (EAN) のカテゴリを取得します。

戻り値:
eanCat 国際商品コード (EAN) のカテゴリ

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setUnit

public void setUnit(String unit)
表示数量単位を設定します。

パラメータ:
unit - 表示数量単位

setUnitIso

public void setUnitIso(String unitIso)
ISO コードでの表示数量単位を設定します。

パラメータ:
unitIso - ISO コードでの表示数量単位

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setEanCat

public void setEanCat(String eanCat)
国際商品コード (EAN) のカテゴリを設定します。

パラメータ:
eanCat - 国際商品コード (EAN) のカテゴリ

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialLongText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス MaterialLongText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText
すべての実装インタフェース:
Serializable
public class MaterialLongText
extends Object
implements Serializable

テキスト (長)情報クラス
機能は以下の通り

  • テキスト (長)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialLongText()
テキスト (長)情報を作成します。
MaterialLongText(int index)
テキスト (長)情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getDelFlag() データレコード削除 (テーブル繰返し)を取得します。
String | getFormatCol() タグ列を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getMaterial() 品目コードを取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
String | getTextName() 名称を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setDelFlag(String delFlag) データレコード削除 (テーブル繰返し)を設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
void | setTextName(String textName) 名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialLongText

public MaterialLongText()
テキスト (長)情報を作成します。

MaterialLongText

public MaterialLongText(int index)
テキスト (長)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextName

public String getTextName()
名称を取得します。

戻り値:
textName 名称

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getDelFlag

public String getDelFlag()
データレコード削除 (テーブル繰返し)を取得します。

戻り値:
delFlag データレコード削除 (テーブル繰返し)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextName

public void setTextName(String textName)
名称を設定します。

パラメータ:
textName - 名称

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setDelFlag

public void setDelFlag(String delFlag)
データレコード削除 (テーブル繰返し)を設定します。

パラメータ:
delFlag - データレコード削除 (テーブル繰返し)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialSaveReplica (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス MaterialSaveReplica

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialSaveReplicaController
public class MaterialSaveReplica
extends UpdateController
implements Serializable

品目マスタ更新情報クラス
機能は以下の通り

  • 品目マスタ更新情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialSaveReplica()
品目マスタ更新情報を作成します。
MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。
MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。
メソッドの概要
List | getClientDataList() 品目データ (クライアントレベル)を取得します。
List | getExtensionInList() BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
List | getExtensionInXList() 拡張イン/拡張アウトのチェックボックス構造を取得します。
String | getFlagCadCall() CAD システムからコールを取得します。
List | getForecastParametersList() 需要予測パラメータを取得します。
List | getForecastValuesList() 需要予測値のデータ転送を取得します。
List | getHeadDataList() 管理情報設定ヘッダセグメントを取得します。
String | getInpfldcheck() 項目無効時の応答を取得します。
List | getInternationalArtnosList() 国際商品コード (EAN)を取得します。
List | getMaterialDescriptionList() 品目テキストを取得します。
List | getMaterialLongTextList() テキスト (長)を取得します。
String | getNoappllog() アプリケーションログ書込なしを取得します。
String | getNochangedoc() 変更伝票書込なしを取得します。
List | getPlanningDataList() 品目マスタ/製品グループの変更伝票構造を取得します。
List | getPlantDataList() 品目データ (プラントレベル)を取得します。
List | getPrtDataList() 品目マスタの生産資源/治工具 (PRT) 項目を取得します。
List | getReturnMessagesList() リターンパラメータ BAPIRET2 の代替構造を取得します。
List | getSalesDataList() 販売データを取得します。
List | getStorageLocationDataList() 品目データ (保管場所レベル)を取得します。
List | getStorageTypeDataList() 保管域タイプデータを取得します。
List | getTaxClassificationsList() 制御デ－タを取得します。
String | getTestrun() 書込 BAPI のシミュレーションセッションへの切替を取得します。
List | getTotalConsumptionList() 品目総消費量のデータ転送を取得します。
List | getUnitSofmeasureList() 数量単位を取得します。
List | getUnplndConsumptionList() 計画外消費のデータ転送を取得します。
List | getValuationDataList() 評価データを取得します。
List | getWarehouseNumberDataList() 倉庫番号データを取得します。
void | initMaterialSaveReplica() 品目マスタ更新情報の各種インスタンスを生成します。
void | setClientDataList(List clientDataList) 品目データ (クライアントレベル)を設定します。
void | setExportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | setExtensionInList(List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
void | setExtensionInXList(List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造を設定します。
void | setFlagCadCall(String flagCadCall) CAD システムからコールを設定します。
void | setForecastParametersList(List forecastParametersList) 需要予測パラメータを設定します。
void | setForecastValuesList(List forecastValuesList) 需要予測値のデータ転送を設定します。
void | setHeadDataList(List headDataList) 管理情報設定ヘッダセグメントを設定します。
void | setImportParam(BapiController bapiController) 品目マスタに登録する値ををセットします。
void | setInpfldcheck(String inpFldCheck) 項目無効時の応答を設定します。
void | setInternationalArtnosList(List internationalArtnosList) 国際商品コード (EAN)を設定します。
void | setMaterialDescriptionList(List materialDescriptionList) 品目テキストを設定します。
void | setMaterialLongTextList(List materialLongTextList) テキスト (長)を設定します。
void | setNoappllog(String noApplLog) アプリケーションログ書込なしを設定します。
void | setNochangedoc(String noChangeDoc) 変更伝票書込なしを設定します。
void | setPlanningDataList(List planningDataList) 品目マスタ/製品グループの変更伝票構造を設定します。
void | setPlantDataList(List plantDataList) 品目データ (プラントレベル)を設定します。
void | setPrtDataList(List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目を設定します。
void | setReturnMessagesList(List returnMessagesList) リターンパラメータ BAPIRET2 の代替構造を設定します。
void | setSalesDataList(List salesDataList) 販売データを設定します。
void | setStorageLocationDataList(List storageLocationDataList) 品目データ (保管場所レベル)を設定します。
void | setStorageTypeDataList(List storageTypeDataList) 保管域タイプデータを設定します。
void | setTaxClassificationsList(List taxClassificationsList) 制御デ－タを設定します。
void | setTestrun(String testRun) 書込 BAPI のシミュレーションセッションへの切替を設定します。
void | setTotalConsumptionList(List totalConsumptionList) 品目総消費量のデータ転送を設定します。
void | setUnitSofmeasureList(List unitSofmeasureList) 数量単位を設定します。
void | setUnplndConsumptionList(List unplndConsumptionList) 計画外消費のデータ転送を設定します。
void | setValuationDataList(List valuationDataList) 評価データを設定します。
void | setWarehouseNumberDataList(List warehouseNumberDataList) 倉庫番号データを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialSaveReplica

public MaterialSaveReplica()
品目マスタ更新情報を作成します。

MaterialSaveReplica

public MaterialSaveReplica(ConnectionManager connectionManager)
品目マスタ更新情報を作成します。

パラメータ:
connectionManager - コネクションオブジェクト

MaterialSaveReplica

public MaterialSaveReplica(SapClient sapClient)
品目マスタ更新情報を作成します。

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

initMaterialSaveReplica

public void initMaterialSaveReplica()
品目マスタ更新情報の各種インスタンスを生成します。

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
品目マスタに登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
品目マスタに登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getNochangedoc

public String getNochangedoc()
変更伝票書込なしを取得します。

戻り値:
nochangedoc 変更伝票書込なし

getNoappllog

public String getNoappllog()
アプリケーションログ書込なしを取得します。

戻り値:
noappllog アプリケーションログ書込なし

getTestrun

public String getTestrun()
書込 BAPI のシミュレーションセッションへの切替を取得します。

戻り値:
testrun 書込 BAPI のシミュレーションセッションへの切替

getInpfldcheck

public String getInpfldcheck()
項目無効時の応答を取得します。

戻り値:
inpfldcheck 項目無効時の応答

getFlagCadCall

public String getFlagCadCall()
CAD システムからコールを取得します。

戻り値:
flagCadCall CAD システムからコール

getHeadDataList

public List getHeadDataList()
管理情報設定ヘッダセグメントを取得します。

戻り値:
headDataList 管理情報設定ヘッダセグメント

getClientDataList

public List getClientDataList()
品目データ (クライアントレベル)を取得します。

戻り値:
clientDataList 品目データ (クライアントレベル)

getPlantDataList

public List getPlantDataList()
品目データ (プラントレベル)を取得します。

戻り値:
plantDataList 品目データ (プラントレベル)

getForecastParametersList

public List getForecastParametersList()
需要予測パラメータを取得します。

戻り値:
forecastParametersList 需要予測パラメータ

getPlanningDataList

public List getPlanningDataList()
品目マスタ/製品グループの変更伝票構造を取得します。

戻り値:
planningDataList 品目マスタ/製品グループの変更伝票構造

getStorageLocationDataList

public List getStorageLocationDataList()
品目データ (保管場所レベル)を取得します。

戻り値:
storageLocationDataList 品目データ (保管場所レベル)

getValuationDataList

public List getValuationDataList()
評価データを取得します。

戻り値:
valuationDataList 評価データ

getWarehouseNumberDataList

public List getWarehouseNumberDataList()
倉庫番号データを取得します。

戻り値:
warehouseNumberDataList 倉庫番号データ

getSalesDataList

public List getSalesDataList()
販売データを取得します。

戻り値:
salesDataList 販売データ

getStorageTypeDataList

public List getStorageTypeDataList()
保管域タイプデータを取得します。

戻り値:
storageTypeDataList 保管域タイプデータ

getMaterialDescriptionList

public List getMaterialDescriptionList()
品目テキストを取得します。

戻り値:
materialDescriptionList 品目テキスト

getUnitSofmeasureList

public List getUnitSofmeasureList()
数量単位を取得します。

戻り値:
unitSofmeasureList 数量単位

getInternationalArtnosList

public List getInternationalArtnosList()
国際商品コード (EAN)を取得します。

戻り値:
internationalArtnosList 国際商品コード (EAN)

getMaterialLongTextList

public List getMaterialLongTextList()
テキスト (長)を取得します。

戻り値:
materialLongTextList テキスト (長)

getTaxClassificationsList

public List getTaxClassificationsList()
制御デ－タを取得します。

戻り値:
taxClassificationsList 制御デ－タ

getPrtDataList

public List getPrtDataList()
品目マスタの生産資源/治工具 (PRT) 項目を取得します。

戻り値:
prtDataList 品目マスタの生産資源/治工具 (PRT) 項目

getExtensionInList

public List getExtensionInList()
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。

戻り値:
extensionInList BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

getExtensionInXList

public List getExtensionInXList()
拡張イン/拡張アウトのチェックボックス構造を取得します。

戻り値:
extensionInXList 拡張イン/拡張アウトのチェックボックス構造

getForecastValuesList

public List getForecastValuesList()
需要予測値のデータ転送を取得します。

戻り値:
forecastValuesList 需要予測値のデータ転送

getUnplndConsumptionList

public List getUnplndConsumptionList()
計画外消費のデータ転送を取得します。

戻り値:
unplndConsumptionList 計画外消費のデータ転送

getTotalConsumptionList

public List getTotalConsumptionList()
品目総消費量のデータ転送を取得します。

戻り値:
totalConsumptionList 品目総消費量のデータ転送

getReturnMessagesList

public List getReturnMessagesList()
リターンパラメータ BAPIRET2 の代替構造を取得します。

戻り値:
returnMessagesList リターンパラメータ BAPIRET2 の代替構造

setNochangedoc

public void setNochangedoc(String noChangeDoc)
変更伝票書込なしを設定します。

パラメータ:
noChangeDoc - 変更伝票書込なし

setNoappllog

public void setNoappllog(String noApplLog)
アプリケーションログ書込なしを設定します。

パラメータ:
noApplLog - アプリケーションログ書込なし

setTestrun

public void setTestrun(String testRun)
書込 BAPI のシミュレーションセッションへの切替を設定します。

パラメータ:
testRun - 書込 BAPI のシミュレーションセッションへの切替

setInpfldcheck

public void setInpfldcheck(String inpFldCheck)
項目無効時の応答を設定します。

パラメータ:
inpFldCheck - 項目無効時の応答

setFlagCadCall

public void setFlagCadCall(String flagCadCall)
CAD システムからコールを設定します。

パラメータ:
flagCadCall - CAD システムからコール

setHeadDataList

public void setHeadDataList(List headDataList)
管理情報設定ヘッダセグメントを設定します。

パラメータ:
headDataList - 管理情報設定ヘッダセグメント

setClientDataList

public void setClientDataList(List clientDataList)
品目データ (クライアントレベル)を設定します。

パラメータ:
clientDataList - 品目データ (クライアントレベル)

setPlantDataList

public void setPlantDataList(List plantDataList)
品目データ (プラントレベル)を設定します。

パラメータ:
plantDataList - 品目データ (プラントレベル)

setForecastParametersList

public void setForecastParametersList(List forecastParametersList)
需要予測パラメータを設定します。

パラメータ:
forecastParametersList - 需要予測パラメータ

setPlanningDataList

public void setPlanningDataList(List planningDataList)
品目マスタ/製品グループの変更伝票構造を設定します。

パラメータ:
planningDataList - 品目マスタ/製品グループの変更伝票構造

setStorageLocationDataList

public void setStorageLocationDataList(List storageLocationDataList)
品目データ (保管場所レベル)を設定します。

パラメータ:
storageLocationDataList - 品目データ (保管場所レベル)

setValuationDataList

public void setValuationDataList(List valuationDataList)
評価データを設定します。

パラメータ:
valuationDataList - 評価データ

setWarehouseNumberDataList

public void setWarehouseNumberDataList(List warehouseNumberDataList)
倉庫番号データを設定します。

パラメータ:
warehouseNumberDataList - 倉庫番号データ

setSalesDataList

public void setSalesDataList(List salesDataList)
販売データを設定します。

パラメータ:
salesDataList - 販売データ

setStorageTypeDataList

public void setStorageTypeDataList(List storageTypeDataList)
保管域タイプデータを設定します。

パラメータ:
storageTypeDataList - 保管域タイプデータ

setMaterialDescriptionList

public void setMaterialDescriptionList(List materialDescriptionList)
品目テキストを設定します。

パラメータ:
materialDescriptionList - 品目テキスト

setUnitSofmeasureList

public void setUnitSofmeasureList(List unitSofmeasureList)
数量単位を設定します。

パラメータ:
unitSofmeasureList - 数量単位

setInternationalArtnosList

public void setInternationalArtnosList(List internationalArtnosList)
国際商品コード (EAN)を設定します。

パラメータ:
internationalArtnosList - 国際商品コード (EAN)

setMaterialLongTextList

public void setMaterialLongTextList(List materialLongTextList)
テキスト (長)を設定します。

パラメータ:
materialLongTextList - テキスト (長)

setTaxClassificationsList

public void setTaxClassificationsList(List taxClassificationsList)
制御デ－タを設定します。

パラメータ:
taxClassificationsList - 制御デ－タ

setPrtDataList

public void setPrtDataList(List prtDataList)
品目マスタの生産資源/治工具 (PRT) 項目を設定します。

パラメータ:
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目

setExtensionInList

public void setExtensionInList(List extensionInList)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。

パラメータ:
extensionInList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の 参照構造

setExtensionInXList

public void setExtensionInXList(List extensionInXList)
拡張イン/拡張アウトのチェックボックス構造を設定します。

パラメータ:
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造

setForecastValuesList

public void setForecastValuesList(List forecastValuesList)
需要予測値のデータ転送を設定します。

パラメータ:
forecastValuesList - 需要予測値のデータ転送

setUnplndConsumptionList

public void setUnplndConsumptionList(List unplndConsumptionList)
計画外消費のデータ転送を設定します。

パラメータ:
unplndConsumptionList - 計画外消費のデータ転送

setTotalConsumptionList

public void setTotalConsumptionList(List totalConsumptionList)
品目総消費量のデータ転送を設定します。

パラメータ:
totalConsumptionList - 品目総消費量のデータ転送

setReturnMessagesList

public void setReturnMessagesList(List returnMessagesList)
リターンパラメータ BAPIRET2 の代替構造を設定します。

パラメータ:
returnMessagesList - リターンパラメータ BAPIRET2 の代替構造

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス
ExtensionIn
ExtensionInX
ForecastValues
HeadData
InternationalArtnos
MaterialLongText
MaterialSaveReplica
ParamClientDataList
ParamExtensionIn
ParamExtensionInX
ParamForecastParametersList
ParamForecastValues
ParamHeadData
ParamInternationalArtnos
ParamMaterialDescription
ParamMaterialLongText
ParamPlanningDataList
ParamPlantDataList
ParamPrtData
ParamReturnMessages
ParamSalesDataList
ParamStorageLocationDataList
ParamStorageTypeDataList
ParamTaxClassifications
ParamTotalConsumption
ParamUnitSofmeasure
ParamUnplndConsumption
ParamValuationDataList
ParamWarehouseNumberDataList
PrtData
ReturnMessages
TotalConsumption
UnplndConsumption


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

クラスの概要
ExtensionIn | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionInX | 拡張イン/拡張アウトのチェックボックス構造情報クラス 機能は以下の通り 拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ForecastValues | 需要予測値のデータ転送情報クラス 機能は以下の通り 需要予測値のデータ転送情報を保持します。
HeadData | 管理情報設定ヘッダセグメント情報クラス 機能は以下の通り 管理情報設定ヘッダセグメント情報を保持します。
InternationalArtnos | 国際商品コード (EAN)情報クラス 機能は以下の通り 国際商品コード (EAN)情報を保持します。
MaterialLongText | テキスト (長)情報クラス 機能は以下の通り テキスト (長)情報を保持します。
MaterialSaveReplica | 品目マスタ更新情報クラス 機能は以下の通り 品目マスタ更新情報を保持します。
ParamClientDataList | 品目データ (クライアントレベル)パラメータ設定クラス 機能は以下の通り 品目データ (クライアントレベル)パラメータを設定します。
ParamExtensionIn | BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス 機能は以下の通り BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。
ParamExtensionInX | 拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス 機能は以下の通り 拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。
ParamForecastParametersList | 需要予測パラメータ設定クラス 機能は以下の通り 需要予測パラメータのパラメータを設定します。
ParamForecastValues | 需要予測値のデータ転送パラメータ設定クラス 機能は以下の通り 需要予測値のデータ転送のパラメータを設定します。
ParamHeadData | 管理情報設定ヘッダセグメントパラメータ設定クラス 機能は以下の通り 管理情報設定ヘッダセグメントのパラメータを設定します。
ParamInternationalArtnos | 国際商品コード (EAN)パラメータ設定クラス 機能は以下の通り 国際商品コード (EAN)のパラメータを設定します。
ParamMaterialDescription | 品目テキストパラメータ設定クラス 機能は以下の通り 品目テキストのパラメータを設定します。
ParamMaterialLongText | テキスト (長)パラメータ設定クラス 機能は以下の通り テキスト (長)のパラメータを設定します。
ParamPlanningDataList | 品目マスタ/製品グループの変更伝票構造パラメータ設定クラス 機能は以下の通り 品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
ParamPlantDataList | 品目データ (プラントレベル)パラメータ設定クラス 機能は以下の通り 品目データ (プラントレベル)のパラメータを設定します。
ParamPrtData | 品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
ParamReturnMessages | リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス 機能は以下の通り リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。
ParamSalesDataList | 倉庫番号データパラメータ設定クラス 機能は以下の通り 倉庫番号データのパラメータを設定します。
ParamStorageLocationDataList | 品目データ (保管場所レベル)パラメータ設定クラス 機能は以下の通り 品目データ (保管場所レベル)のパラメータを設定します。
ParamStorageTypeDataList | 品目データ (保管場所レベル)パラメータ設定クラス 機能は以下の通り 品目データ (保管場所レベル)のパラメータを設定します。
ParamTaxClassifications | 制御デ－タパラメータ設定クラス 機能は以下の通り 制御デ－タのパラメータを設定します。
ParamTotalConsumption | 品目総消費量のデータ転送パラメータ設定クラス 機能は以下の通り 品目総消費量のデータ転送のパラメータを設定します。
ParamUnitSofmeasure | 数量単位パラメータ設定クラス 機能は以下の通り 数量単位のパラメータを設定します。
ParamUnplndConsumption | 計画外消費のデータ転送パラメータ設定クラス 機能は以下の通り 計画外消費のデータ転送のパラメータを設定します。
ParamValuationDataList | 評価データパラメータ設定クラス 機能は以下の通り 評価データのパラメータを設定します。
ParamWarehouseNumberDataList | 倉庫番号データパラメータ設定クラス 機能は以下の通り 倉庫番号データのパラメータを設定します。
PrtData | 品目マスタの生産資源/治工具 (PRT) 項目情報クラス 機能は以下の通り 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
ReturnMessages | リターンパラメータ BAPIRET2 の代替構造情報クラス 機能は以下の通り リターンパラメータ BAPIRET2 の代替構造情報を保持します。
TotalConsumption | 品目総消費量のデータ転送情報クラス 機能は以下の通り 品目総消費量のデータ転送情報を保持します。
UnplndConsumption | 計画外消費のデータ転送情報クラス 機能は以下の通り 計画外消費のデータ転送情報を保持します。


jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica の使用

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica のクラス
ExtensionIn
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionInX
拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ForecastValues
需要予測値のデータ転送情報クラス
機能は以下の通り
需要予測値のデータ転送情報を保持します。
HeadData
管理情報設定ヘッダセグメント情報クラス
機能は以下の通り
管理情報設定ヘッダセグメント情報を保持します。
InternationalArtnos
国際商品コード (EAN)情報クラス
機能は以下の通り
国際商品コード (EAN)情報を保持します。
MaterialLongText
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialSaveReplica
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。
PrtData
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
TotalConsumption
品目総消費量のデータ転送情報クラス
機能は以下の通り
品目総消費量のデータ転送情報を保持します。
UnplndConsumption
計画外消費のデータ転送情報クラス
機能は以下の通り
計画外消費のデータ転送情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamClientDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamClientDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList
すべての実装インタフェース:
Serializable
public final class ParamClientDataList
extends Object
implements Serializable

品目データ (クライアントレベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (クライアントレベル)パラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List clientDataList) table(Export)情報から品目データ (クライアントレベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List clientDataList) 品目データ (クライアントレベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List clientDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (クライアントレベル)の値をセットします。 CLIENTDATA の情報の更新の値をセットします。

パラメータ:
bapiController - BapiController
clientDataList - 品目データ (クライアントレベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List clientDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (クライアントレベル)の値をセットします。

パラメータ:
bapiController - BapiController
clientDataList - 品目データ (クライアントレベル)配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn
すべての実装インタフェース:
Serializable
public final class ParamExtensionIn
extends Object
implements Serializable

BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス
機能は以下の通り

  • BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
static void | setTableParam(BapiController bapiController, List extensionInList) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List extensionInList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - EXTENSIONIN/EXTENSIONOUT の参照構造配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamExtensionInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX
すべての実装インタフェース:
Serializable
public final class ParamExtensionInX
extends Object
implements Serializable

拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス
機能は以下の通り

  • 拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInXList) 実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
static void | setTableParam(BapiController bapiController, List extensionInXList) 拡張イン/拡張アウトのチェックボックス構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List extensionInXList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
拡張イン/拡張アウトのチェックボックス構造の値をセットします。

パラメータ:
bapiController - BapiController
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInXList)
                           throws SAPGeneralSystemException
実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。

パラメータ:
bapiController - BapiController
extensionInXList - 拡張イン/拡張アウトのチェックボックス構造配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamForecastParametersList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamForecastParametersList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList
すべての実装インタフェース:
Serializable
public final class ParamForecastParametersList
extends Object
implements Serializable

需要予測パラメータ設定クラス
機能は以下の通り

  • 需要予測パラメータのパラメータを設定します。
  • FORECASTDATA の情報の更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List forecastParametersList) table(Export)情報から需要予測パラメータの値をセットします。
static void | setTableParam(BapiController bapiController, List forecastParametersList) 需要予測パラメータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List forecastParametersList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
需要予測パラメータの値をセットします。 FORECASTDATA の情報の更新の値をセットします。

パラメータ:
bapiController - BapiController
forecastParametersList - 需要予測パラメータ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List forecastParametersList)
                           throws SAPGeneralSystemException
table(Export)情報から需要予測パラメータの値をセットします。

パラメータ:
bapiController - BapiController
forecastParametersList - 需要予測パラメータ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamForecastValues (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamForecastValues

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues
すべての実装インタフェース:
Serializable
public final class ParamForecastValues
extends Object
implements Serializable

需要予測値のデータ転送パラメータ設定クラス
機能は以下の通り

  • 需要予測値のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List forecastValuesList) table(Export)情報から需要予測値のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List forecastValuesList) 需要予測値のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List forecastValuesList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
需要予測値のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
forecastValuesList - 需要予測値のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List forecastValuesList)
                           throws SAPGeneralSystemException
table(Export)情報から需要予測値のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
forecastValuesList - 需要予測値のデータ転送配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeadData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamHeadData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData
すべての実装インタフェース:
Serializable
public final class ParamHeadData
extends Object
implements Serializable

管理情報設定ヘッダセグメントパラメータ設定クラス
機能は以下の通り

  • 管理情報設定ヘッダセグメントのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List headDataList) table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
static void | setTableParam(BapiController bapiController, List headDataList) 管理情報設定ヘッダセグメントの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List headDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
管理情報設定ヘッダセグメントの値をセットします。

パラメータ:
bapiController - BapiController
headDataList - 管理情報設定ヘッダセグメント配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List headDataList)
                           throws SAPGeneralSystemException
table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。

パラメータ:
bapiController - BapiController
headDataList - 管理情報設定ヘッダセグメント
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamInternationalArtnos (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamInternationalArtnos

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos
すべての実装インタフェース:
Serializable
public final class ParamInternationalArtnos
extends Object
implements Serializable

国際商品コード (EAN)パラメータ設定クラス
機能は以下の通り

  • 国際商品コード (EAN)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List internationalArtnosList) table(Export)情報から国際商品コード (EAN)の値をセットします。
static void | setTableParam(BapiController bapiController, List internationalArtnosList) 国際商品コード (EAN)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List internationalArtnosList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
国際商品コード (EAN)の値をセットします。

パラメータ:
bapiController - BapiController
internationalArtnosList - 国際商品コード (EAN)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List internationalArtnosList)
                           throws SAPGeneralSystemException
table(Export)情報から国際商品コード (EAN)の値をセットします。

パラメータ:
bapiController - BapiController
internationalArtnosList - 国際商品コード (EAN)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialDescription (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamMaterialDescription

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription
すべての実装インタフェース:
Serializable
public final class ParamMaterialDescription
extends Object
implements Serializable

品目テキストパラメータ設定クラス
機能は以下の通り

  • 品目テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialDescriptionList) table(Export)情報から品目テキストを設定します。
static void | setTableParam(BapiController bapiController, List materialDescriptionList) 品目テキストの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List materialDescriptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目テキストの値をセットします。

パラメータ:
bapiController - BapiController
materialDescriptionList - 品目テキスト配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialDescriptionList)
                           throws SAPGeneralSystemException
table(Export)情報から品目テキストを設定します。

パラメータ:
bapiController - BapiController
materialDescriptionList - 品目テキスト配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamMaterialLongText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamMaterialLongText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText
すべての実装インタフェース:
Serializable
public final class ParamMaterialLongText
extends Object
implements Serializable

テキスト (長)パラメータ設定クラス
機能は以下の通り

  • テキスト (長)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List materialLongTextList) table(Export)情報からテキスト (長)の値をセットします。
static void | setTableParam(BapiController bapiController, List list) テキスト (長)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List list)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
テキスト (長)の値をセットします。

パラメータ:
bapiController - BapiController
list - テキスト (長)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List materialLongTextList)
                           throws SAPGeneralSystemException
table(Export)情報からテキスト (長)の値をセットします。

パラメータ:
bapiController - BapiController
materialLongTextList - テキスト (長)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlanningDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPlanningDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList
すべての実装インタフェース:
Serializable
public final class ParamPlanningDataList
extends Object
implements Serializable

品目マスタ/製品グループの変更伝票構造パラメータ設定クラス
機能は以下の通り

  • 品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
  • PLANNINGDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List planningDataList) table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
static void | setTableParam(BapiController bapiController, List planningDataList) 品目マスタ/製品グループの変更伝票構造の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List planningDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目マスタ/製品グループの変更伝票構造の値をセットします。 PLANNINGDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
planningDataList - 品目マスタ/製品グループの変更伝票構造配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List planningDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。

パラメータ:
bapiController - BapiController
planningDataList - 品目マスタ/製品グループの変更伝票構造
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPlantDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPlantDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList
すべての実装インタフェース:
Serializable
public final class ParamPlantDataList
extends Object
implements Serializable

品目データ (プラントレベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (プラントレベル)のパラメータを設定します。
  • PLANTDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List plantDataList) table(Export)情報から品目データ (プラントレベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List plantDataList) 品目データ (プラントレベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List plantDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (プラントレベル)の値をセットします。 PLANTDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
plantDataList - 品目データ (プラントレベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List plantDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (プラントレベル)の値をセットします。

パラメータ:
bapiController - BapiController
plantDataList - 品目データ (プラントレベル)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPrtData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamPrtData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData
すべての実装インタフェース:
Serializable
public final class ParamPrtData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
  • PRTDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List prtDataList) table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
static void | setTableParam(BapiController bapiController, List prtDataList) 品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List prtDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。 PRTDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List prtDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。

パラメータ:
bapiController - BapiController
prtDataList - 品目マスタの生産資源/治工具 (PRT) 項目
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamReturnMessages (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamReturnMessages

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages
すべての実装インタフェース:
Serializable
public final class ParamReturnMessages
extends Object
implements Serializable

リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス
機能は以下の通り

  • リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, List returnMessages)
品目マスタ更新結果をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List returnMessages)
                           throws SAPGeneralSystemException
品目マスタ更新結果をセットします。

パラメータ:
bapiController - BapiController
returnMessages - リターンパラメータ BAPIRET2 の代替構造
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSalesDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamSalesDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList
すべての実装インタフェース:
Serializable
public final class ParamSalesDataList
extends Object
implements Serializable

倉庫番号データパラメータ設定クラス
機能は以下の通り

  • 倉庫番号データのパラメータを設定します。
  • WAREHOUSEDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List salesDataList) table(Export)情報から販売データの値をセットします。
static void | setTableParam(BapiController bapiController, List salesDataList) 販売データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List salesDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
販売データの値をセットします。 SALESDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
salesDataList - 販売データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List salesDataList)
                           throws SAPGeneralSystemException
table(Export)情報から販売データの値をセットします。

パラメータ:
bapiController - BapiController
salesDataList - 販売データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStorageLocationDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamStorageLocationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList
すべての実装インタフェース:
Serializable
public final class ParamStorageLocationDataList
extends Object
implements Serializable

品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (保管場所レベル)のパラメータを設定します。
  • STORAGELOCATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeLocDataList) table(Export)情報から品目データ (保管場所レベル)の値をセットします。
static void | setTableParam(BapiController bapiController, List storageLicationDataList) 品目データ (保管場所レベル)の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List storageLicationDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目データ (保管場所レベル)の値をセットします。 STORAGELOCATIONDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
storageLicationDataList - 品目データ (保管場所レベル)配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeLocDataList)
                           throws SAPGeneralSystemException
table(Export)情報から品目データ (保管場所レベル)の値をセットします。

パラメータ:
bapiController - BapiController
stgeLocDataList - 品目データ (保管場所レベル)
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamStorageTypeDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamStorageTypeDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList
すべての実装インタフェース:
Serializable
public final class ParamStorageTypeDataList
extends Object
implements Serializable

品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り

  • 品目データ (保管場所レベル)のパラメータを設定します。
  • STORAGELOCATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List stgeTypeDataList) table(Export)情報から保管域タイプデータの値をセットします。
static void | setTableParam(BapiController bapiController, List storageTypeDataList) 保管域タイプデータの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List storageTypeDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
保管域タイプデータの値をセットします。 STORAGETYPEDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
storageTypeDataList - 保管域タイプデータ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List stgeTypeDataList)
                           throws SAPGeneralSystemException
table(Export)情報から保管域タイプデータの値をセットします。

パラメータ:
bapiController - BapiController
stgeTypeDataList - 保管域タイプデータ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTaxClassifications (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamTaxClassifications

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications
すべての実装インタフェース:
Serializable
public final class ParamTaxClassifications
extends Object
implements Serializable

制御デ－タパラメータ設定クラス
機能は以下の通り

  • 制御デ－タのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List taxClassificationsList) table(Export)情報から制御データを設定します。
static void | setTableParam(BapiController bapiController, List taxClassificationsList) 制御デ－タの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List taxClassificationsList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
制御デ－タの値をセットします。

パラメータ:
bapiController - BapiController
taxClassificationsList - 制御デ－タ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List taxClassificationsList)
                           throws SAPGeneralSystemException
table(Export)情報から制御データを設定します。

パラメータ:
bapiController - BapiController
taxClassificationsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTotalConsumption (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamTotalConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption
すべての実装インタフェース:
Serializable
public final class ParamTotalConsumption
extends Object
implements Serializable

品目総消費量のデータ転送パラメータ設定クラス
機能は以下の通り

  • 品目総消費量のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List totalConsumptionList) table(Export)情報から品目総消費量のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List totalConsumptionList) 品目総消費量のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List totalConsumptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
品目総消費量のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
totalConsumptionList - 品目総消費量のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List totalConsumptionList)
                           throws SAPGeneralSystemException
table(Export)情報から品目総消費量のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
totalConsumptionList - 品目総消費量のデータ転送
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUnitSofmeasure (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamUnitSofmeasure

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure
すべての実装インタフェース:
Serializable
public final class ParamUnitSofmeasure
extends Object
implements Serializable

数量単位パラメータ設定クラス
機能は以下の通り

  • 数量単位のパラメータを設定します。
  • UNITSOFMEASURE の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List unitSofmeasureList) table(Export)情報から数量単位を設定します。
static void | setTableParam(BapiController bapiController, List unitSofmeasureList) 数量単位の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List unitSofmeasureList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
数量単位の値をセットします。 UNITSOFMEASURE の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
unitSofmeasureList - 数量単位配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List unitSofmeasureList)
                           throws SAPGeneralSystemException
table(Export)情報から数量単位を設定します。

パラメータ:
bapiController - BapiController
unitSofmeasureList - 数量単位配列
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamUnplndConsumption (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamUnplndConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption
すべての実装インタフェース:
Serializable
public final class ParamUnplndConsumption
extends Object
implements Serializable

計画外消費のデータ転送パラメータ設定クラス
機能は以下の通り

  • 計画外消費のデータ転送のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List unplndConsumptionList) table(Export)情報から計画外消費のデータ転送の値をセットします。
static void | setTableParam(BapiController bapiController, List unplndConsumptionList) 計画外消費のデータ転送の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List unplndConsumptionList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
計画外消費のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
unplndConsumptionList - 計画外消費のデータ転送配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List unplndConsumptionList)
                           throws SAPGeneralSystemException
table(Export)情報から計画外消費のデータ転送の値をセットします。

パラメータ:
bapiController - BapiController
unplndConsumptionList - 計画外消費のデータ転送
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamValuationDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamValuationDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList
すべての実装インタフェース:
Serializable
public final class ParamValuationDataList
extends Object
implements Serializable

評価データパラメータ設定クラス
機能は以下の通り

  • 評価データのパラメータを設定します。
  • VALUATIONDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List valuationDataList) table(Export)情報から評価データの値をセットします。
static void | setTableParam(BapiController bapiController, List valuationDataList) 評価データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List valuationDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
評価データの値をセットします。 VALUATIONDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
valuationDataList - 評価データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List valuationDataList)
                           throws SAPGeneralSystemException
table(Export)情報から評価データの値をセットします。

パラメータ:
bapiController - BapiController
valuationDataList - 評価データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamWarehouseNumberDataList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ParamWarehouseNumberDataList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList
すべての実装インタフェース:
Serializable
public final class ParamWarehouseNumberDataList
extends Object
implements Serializable

倉庫番号データパラメータ設定クラス
機能は以下の通り

  • 倉庫番号データのパラメータを設定します。
  • WAREHOUSEDATA の情報更新のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List whseNoDataList) table(Export)情報から倉庫番号データを設定します。
static void | setTableParam(BapiController bapiController, List warehouseNumberDataList) 倉庫番号データの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setTableParam

public static void setTableParam(BapiController bapiController,
                                 List warehouseNumberDataList)
                          throws SAPGeneralSystemException,
                                 SAPGeneralAppException
倉庫番号データの値をセットします。 WAREHOUSEDATA の情報更新の値をセットします。

パラメータ:
bapiController - BapiController
warehouseNumberDataList - 倉庫番号データ配列
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List whseNoDataList)
                           throws SAPGeneralSystemException
table(Export)情報から倉庫番号データを設定します。

パラメータ:
bapiController - BapiController
whseNoDataList - 倉庫番号データ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PrtData (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス PrtData

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData
すべての実装インタフェース:
Serializable
public class PrtData
extends Object
implements Serializable

品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り

  • 品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PrtData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
メソッドの概要
String | getCreateLoadRecs() 区分: 生産資源/治工具の負荷レコード登録を取得します。
String | getCtrlKey() 生産資源/治工具管理の管理キーを取得します。
String | getCtrlKeyNoChg() 管理キーは変更できませんを取得します。
String | getEndOffset() 生産資源/治工具用途の終了オフセットを取得します。
String | getEndOffsetNoChg() 終了オフセットは変更できませんを取得します。
String | getEndOffsetUnit() 生産資源/治工具使用終了オフセット単位を取得します。
String | getEndOffsetUnitIso() PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
String | getEndRefDate() 生産資源/治工具使用終了日の参照日付を取得します。
String | getEndRefDateNoChg() 終了参照日付は変更できませんを取得します。
String | getFormulaTotQty() 生産資源/治工具の合計数量の計算式を取得します。
String | getFormulaTotQtyNoChg() 合計数量の計算式は変更できませんを取得します。
String | getFormulaTotUsage() 生産資源/治工具の総用途値の計算式を取得します。
String | getFormulaTotUsageNoChg() すべての用途値を計算する計算式は変更できませんを取得します。
String | getFunction() BAPI 機能を取得します。
String | getGrpKey1() 生産資源/治工具のグループキー 1を取得します。
String | getGrpKey2() 生産資源/治工具のグループキー 2を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getPlant() プラントを取得します。
String | getPrtUsage() 生産資源/治工具用途を取得します。
String | getRefKeyNoChg() 参照キーは変更できませんを取得します。
String | getStartOffset() 生産資源/治工具使用の開始オフセットを取得します。
String | getStartOffsetNoChg() 開始オフセットは変更できませんを取得します。
String | getStartOffsetUnit() 生産資源/治工具使用開始のオフセット単位を取得します。
String | getStartOffsetUnitIso() PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
String | getStartRefDate() 生産資源/治工具使用開始の参照日付を取得します。
String | getStdTextKey() 生産資源/治工具の標準テキストキーを取得します。
String | getStRefDateNoChg() 開始参照日付は変更できませんを取得します。
void | setCreateLoadRecs(String createLoadRecs) 区分: 生産資源/治工具の負荷レコード登録を設定します。
void | setCtrlKey(String ctrlKey) 生産資源/治工具管理の管理キーを設定します。
void | setCtrlKeyNoChg(String ctrlKeyNoChg) 管理キーは変更できませんを設定します。
void | setEndOffset(String endOffset) 生産資源/治工具用途の終了オフセットを設定します。
void | setEndOffsetNoChg(String endOffsetNoChg) 終了オフセットは変更できませんを設定します。
void | setEndOffsetUnit(String endOffsetUnit) 生産資源/治工具使用終了オフセット単位を設定します。
void | setEndOffsetUnitIso(String endOffsetUnitIso) PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
void | setEndRefDate(String endRefDate) 生産資源/治工具使用終了日の参照日付を設定します。
void | setEndRefDateNoChg(String endRefDateNoChg) 終了参照日付は変更できませんを設定します。
void | setFormulaTotQty(String formulaTotQty) 生産資源/治工具の合計数量の計算式を設定します。
void | setFormulaTotQtyNoChg(String formulaTotQtyNoChg) 合計数量の計算式は変更できませんを設定します。
void | setFormulaTotUsage(String formulaTotUsage) 生産資源/治工具の総用途値の計算式を設定します。
void | setFormulaTotUsageNoChg(String formulaTotUsageNoChg) すべての用途値を計算する計算式は変更できませんを設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setGrpKey1(String grpKey1) 生産資源/治工具のグループキー 1を設定します。
void | setGrpKey2(String grpKey2) 生産資源/治工具のグループキー 2を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPrtUsage(String prtUsage) 生産資源/治工具用途を設定します。
void | setRefKeyNoChg(String refKeyNoChg) 参照キーは変更できませんを設定します。
void | setStartOffset(String startOffset) 生産資源/治工具使用の開始オフセットを設定します。
void | setStartOffsetNoChg(String startOffsetNoChg) 開始オフセットは変更できませんを設定します。
void | setStartOffsetUnit(String startOffsetUnit) 生産資源/治工具使用開始のオフセット単位を設定します。
void | setStartOffsetUnitIso(String startOffsetUnitIso) PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
void | setStartRefDate(String startRefDate) 生産資源/治工具使用開始の参照日付を設定します。
void | setStdTextKey(String stdTextKey) 生産資源/治工具の標準テキストキーを設定します。
void | setStRefDateNoChg(String stRefDateNoChg) 開始参照日付は変更できませんを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PrtData

public PrtData()
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

PrtData

public PrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getCreateLoadRecs

public String getCreateLoadRecs()
区分: 生産資源/治工具の負荷レコード登録を取得します。

戻り値:
createLoadRecs 区分: 生産資源/治工具の負荷レコード登録

getCtrlKey

public String getCtrlKey()
生産資源/治工具管理の管理キーを取得します。

戻り値:
ctrlKey 生産資源/治工具管理の管理キー

getCtrlKeyNoChg

public String getCtrlKeyNoChg()
管理キーは変更できませんを取得します。

戻り値:
ctrlKeyNoChg 管理キーは変更できません

getGrpKey1

public String getGrpKey1()
生産資源/治工具のグループキー 1を取得します。

戻り値:
grpKey_1 生産資源/治工具のグループキー 1

getGrpKey2

public String getGrpKey2()
生産資源/治工具のグループキー 2を取得します。

戻り値:
grpKey_2 生産資源/治工具のグループキー 2

getPrtUsage

public String getPrtUsage()
生産資源/治工具用途を取得します。

戻り値:
prtUsage 生産資源/治工具用途

getStdTextKey

public String getStdTextKey()
生産資源/治工具の標準テキストキーを取得します。

戻り値:
stdTextKey 生産資源/治工具の標準テキストキー

getRefKeyNoChg

public String getRefKeyNoChg()
参照キーは変更できませんを取得します。

戻り値:
refKeyNoChg 参照キーは変更できません

getStartRefDate

public String getStartRefDate()
生産資源/治工具使用開始の参照日付を取得します。

戻り値:
startRefDate 生産資源/治工具使用開始の参照日付

getStRefDateNoChg

public String getStRefDateNoChg()
開始参照日付は変更できませんを取得します。

戻り値:
stRefDateNoChg 開始参照日付は変更できません

getStartOffset

public String getStartOffset()
生産資源/治工具使用の開始オフセットを取得します。

戻り値:
startOffset 生産資源/治工具使用の開始オフセット

getStartOffsetUnit

public String getStartOffsetUnit()
生産資源/治工具使用開始のオフセット単位を取得します。

戻り値:
startOffsetUnit 生産資源/治工具使用開始のオフセット単位

getStartOffsetUnitIso

public String getStartOffsetUnitIso()
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。

戻り値:
startOffsetUnitIso PRT 用途開始決定の間隔時間単位 (ISO)

getStartOffsetNoChg

public String getStartOffsetNoChg()
開始オフセットは変更できませんを取得します。

戻り値:
startOffsetNoChg 開始オフセットは変更できません

getEndRefDate

public String getEndRefDate()
生産資源/治工具使用終了日の参照日付を取得します。

戻り値:
endRefDate 生産資源/治工具使用終了日の参照日付

getEndRefDateNoChg

public String getEndRefDateNoChg()
終了参照日付は変更できませんを取得します。

戻り値:
endRefDateNoChg 終了参照日付は変更できません

getEndOffset

public String getEndOffset()
生産資源/治工具用途の終了オフセットを取得します。

戻り値:
endOffset 生産資源/治工具用途の終了オフセット

getEndOffsetUnit

public String getEndOffsetUnit()
生産資源/治工具使用終了オフセット単位を取得します。

戻り値:
endOffsetUnit 生産資源/治工具使用終了オフセット単位

getEndOffsetUnitIso

public String getEndOffsetUnitIso()
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。

戻り値:
endOffsetUnitIso PRT 用途終了決定の間隔時間単位 (ISO)

getEndOffsetNoChg

public String getEndOffsetNoChg()
終了オフセットは変更できませんを取得します。

戻り値:
endOffsetNoChg 終了オフセットは変更できません

getFormulaTotQty

public String getFormulaTotQty()
生産資源/治工具の合計数量の計算式を取得します。

戻り値:
formulaTotQty 生産資源/治工具の合計数量の計算式

getFormulaTotQtyNoChg

public String getFormulaTotQtyNoChg()
合計数量の計算式は変更できませんを取得します。

戻り値:
formulaTotQtyNoChg 合計数量の計算式は変更できません

getFormulaTotUsage

public String getFormulaTotUsage()
生産資源/治工具の総用途値の計算式を取得します。

戻り値:
formulaTotUsage 生産資源/治工具の総用途値の計算式

getFormulaTotUsageNoChg

public String getFormulaTotUsageNoChg()
すべての用途値を計算する計算式は変更できませんを取得します。

戻り値:
formulaTotUsageNoChg すべての用途値を計算する計算式は変更できません

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setCreateLoadRecs

public void setCreateLoadRecs(String createLoadRecs)
区分: 生産資源/治工具の負荷レコード登録を設定します。

パラメータ:
createLoadRecs - 区分: 生産資源/治工具の負荷レコード登録

setCtrlKey

public void setCtrlKey(String ctrlKey)
生産資源/治工具管理の管理キーを設定します。

パラメータ:
ctrlKey - 生産資源/治工具管理の管理キー

setCtrlKeyNoChg

public void setCtrlKeyNoChg(String ctrlKeyNoChg)
管理キーは変更できませんを設定します。

パラメータ:
ctrlKeyNoChg - 管理キーは変更できません

setGrpKey1

public void setGrpKey1(String grpKey1)
生産資源/治工具のグループキー 1を設定します。

パラメータ:
grpKey1 - 生産資源/治工具のグループキー 1

setGrpKey2

public void setGrpKey2(String grpKey2)
生産資源/治工具のグループキー 2を設定します。

パラメータ:
grpKey2 - 生産資源/治工具のグループキー 2

setPrtUsage

public void setPrtUsage(String prtUsage)
生産資源/治工具用途を設定します。

パラメータ:
prtUsage - 生産資源/治工具用途

setStdTextKey

public void setStdTextKey(String stdTextKey)
生産資源/治工具の標準テキストキーを設定します。

パラメータ:
stdTextKey - 生産資源/治工具の標準テキストキー

setRefKeyNoChg

public void setRefKeyNoChg(String refKeyNoChg)
参照キーは変更できませんを設定します。

パラメータ:
refKeyNoChg - 参照キーは変更できません

setStartRefDate

public void setStartRefDate(String startRefDate)
生産資源/治工具使用開始の参照日付を設定します。

パラメータ:
startRefDate - 生産資源/治工具使用開始の参照日付

setStRefDateNoChg

public void setStRefDateNoChg(String stRefDateNoChg)
開始参照日付は変更できませんを設定します。

パラメータ:
stRefDateNoChg - 開始参照日付は変更できません

setStartOffset

public void setStartOffset(String startOffset)
生産資源/治工具使用の開始オフセットを設定します。

パラメータ:
startOffset - 生産資源/治工具使用の開始オフセット

setStartOffsetUnit

public void setStartOffsetUnit(String startOffsetUnit)
生産資源/治工具使用開始のオフセット単位を設定します。

パラメータ:
startOffsetUnit - 生産資源/治工具使用開始のオフセット単位

setStartOffsetUnitIso

public void setStartOffsetUnitIso(String startOffsetUnitIso)
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。

パラメータ:
startOffsetUnitIso - PRT 用途開始決定の間隔時間単位 (ISO)

setStartOffsetNoChg

public void setStartOffsetNoChg(String startOffsetNoChg)
開始オフセットは変更できませんを設定します。

パラメータ:
startOffsetNoChg - 開始オフセットは変更できません

setEndRefDate

public void setEndRefDate(String endRefDate)
生産資源/治工具使用終了日の参照日付を設定します。

パラメータ:
endRefDate - 生産資源/治工具使用終了日の参照日付

setEndRefDateNoChg

public void setEndRefDateNoChg(String endRefDateNoChg)
終了参照日付は変更できませんを設定します。

パラメータ:
endRefDateNoChg - 終了参照日付は変更できません

setEndOffset

public void setEndOffset(String endOffset)
生産資源/治工具用途の終了オフセットを設定します。

パラメータ:
endOffset - 生産資源/治工具用途の終了オフセット

setEndOffsetUnit

public void setEndOffsetUnit(String endOffsetUnit)
生産資源/治工具使用終了オフセット単位を設定します。

パラメータ:
endOffsetUnit - 生産資源/治工具使用終了オフセット単位

setEndOffsetUnitIso

public void setEndOffsetUnitIso(String endOffsetUnitIso)
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。

パラメータ:
endOffsetUnitIso - PRT 用途終了決定の間隔時間単位 (ISO)

setEndOffsetNoChg

public void setEndOffsetNoChg(String endOffsetNoChg)
終了オフセットは変更できませんを設定します。

パラメータ:
endOffsetNoChg - 終了オフセットは変更できません

setFormulaTotQty

public void setFormulaTotQty(String formulaTotQty)
生産資源/治工具の合計数量の計算式を設定します。

パラメータ:
formulaTotQty - 生産資源/治工具の合計数量の計算式

setFormulaTotQtyNoChg

public void setFormulaTotQtyNoChg(String formulaTotQtyNoChg)
合計数量の計算式は変更できませんを設定します。

パラメータ:
formulaTotQtyNoChg - 合計数量の計算式は変更できません

setFormulaTotUsage

public void setFormulaTotUsage(String formulaTotUsage)
生産資源/治工具の総用途値の計算式を設定します。

パラメータ:
formulaTotUsage - 生産資源/治工具の総用途値の計算式

setFormulaTotUsageNoChg

public void setFormulaTotUsageNoChg(String formulaTotUsageNoChg)
すべての用途値を計算する計算式は変更できませんを設定します。

パラメータ:
formulaTotUsageNoChg - すべての用途値を計算する計算式は変更できません

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReturnMessages (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス ReturnMessages

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages
すべての実装インタフェース:
Serializable
public class ReturnMessages
extends Object
implements Serializable

リターンパラメータ BAPIRET2 の代替構造情報クラス
機能は以下の通り

  • リターンパラメータ BAPIRET2 の代替構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ReturnMessages()
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReturnMessages(int index)
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
メソッドの概要
String | getField() パラメータの項目を取得します。
String | getId() メッセージ、メッセージクラスを取得します。
int | getIndex() レコード番号を取得します｡
String | getLogMsgNo() アプリケーションログ: メッセージシリアル番号を取得します。
String | getLogNo() アプリケーションログ: ログ番号を取得します。
String | getMessage() メッセージテキストを取得します。
String | getMessageV1() メッセージ、メッセージ変数を取得します。
String | getMessageV2() メッセージ、メッセージ変数を取得します。
String | getMessageV3() メッセージ、メッセージ変数を取得します。
String | getMessageV4() メッセージ、メッセージ変数を取得します。
String | getNumber() メッセージ、メッセージ番号を取得します。
String | getParameter() パラメータ名を取得します。
String | getRow() パラメータの行を取得します。
String | getSystem() メッセージが発行された論理システムを取得します。
String | getType() メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
void | setField(String field) パラメータの項目を設定します。
void | setId(String id) メッセージ、メッセージクラスを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLogMsgNo(String logMsgNo) アプリケーションログ: メッセージシリアル番号を設定します。
void | setLogNo(String logNo) アプリケーションログ: ログ番号を設定します。
void | setMessage(String message) メッセージテキストを設定します。
void | setMessageV1(String messageV1) メッセージ、メッセージ変数を設定します。
void | setMessageV2(String messageV2) メッセージ、メッセージ変数を設定します。
void | setMessageV3(String messageV3) メッセージ、メッセージ変数を設定します。
void | setMessageV4(String messageV4) メッセージ、メッセージ変数を設定します。
void | setNumber(String number) メッセージ、メッセージ番号を設定します。
void | setParameter(String parameter) パラメータ名を設定します。
void | setRow(String row) パラメータの行を設定します。
void | setSystem(String system) メッセージが発行された論理システムを設定します。
void | setType(String type) メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ReturnMessages

public ReturnMessages()
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

ReturnMessages

public ReturnMessages(int index)
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getType

public String getType()
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。

戻り値:
type メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

getId

public String getId()
メッセージ、メッセージクラスを取得します。

戻り値:
id メッセージ、メッセージクラス

getNumber

public String getNumber()
メッセージ、メッセージ番号を取得します。

戻り値:
number メッセージ、メッセージ番号

getMessage

public String getMessage()
メッセージテキストを取得します。

戻り値:
message メッセージテキスト

getLogNo

public String getLogNo()
アプリケーションログ: ログ番号を取得します。

戻り値:
logNo アプリケーションログ: ログ番号

getLogMsgNo

public String getLogMsgNo()
アプリケーションログ: メッセージシリアル番号を取得します。

戻り値:
logMsgNo アプリケーションログ: メッセージシリアル番号

getMessageV1

public String getMessageV1()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV1 メッセージ、メッセージ変数

getMessageV2

public String getMessageV2()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV2 メッセージ、メッセージ変数

getMessageV3

public String getMessageV3()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV3 メッセージ、メッセージ変数

getMessageV4

public String getMessageV4()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV4 メッセージ、メッセージ変数

getParameter

public String getParameter()
パラメータ名を取得します。

戻り値:
parameter パラメータ名

getRow

public String getRow()
パラメータの行を取得します。

戻り値:
row パラメータの行

getField

public String getField()
パラメータの項目を取得します。

戻り値:
field パラメータの項目

getSystem

public String getSystem()
メッセージが発行された論理システムを取得します。

戻り値:
system メッセージが発行された論理システム

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setType

public void setType(String type)
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。

パラメータ:
type - メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

setId

public void setId(String id)
メッセージ、メッセージクラスを設定します。

パラメータ:
id - メッセージ、メッセージクラス

setNumber

public void setNumber(String number)
メッセージ、メッセージ番号を設定します。

パラメータ:
number - メッセージ、メッセージ番号

setMessage

public void setMessage(String message)
メッセージテキストを設定します。

パラメータ:
message - メッセージテキスト

setLogNo

public void setLogNo(String logNo)
アプリケーションログ: ログ番号を設定します。

パラメータ:
logNo - アプリケーションログ: ログ番号

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
アプリケーションログ: メッセージシリアル番号を設定します。

パラメータ:
logMsgNo - アプリケーションログ: メッセージシリアル番号

setMessageV1

public void setMessageV1(String messageV1)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV1 - メッセージ、メッセージ変数

setMessageV2

public void setMessageV2(String messageV2)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV2 - メッセージ、メッセージ変数

setMessageV3

public void setMessageV3(String messageV3)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV3 - メッセージ、メッセージ変数

setMessageV4

public void setMessageV4(String messageV4)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV4 - メッセージ、メッセージ変数

setParameter

public void setParameter(String parameter)
パラメータ名を設定します。

パラメータ:
parameter - パラメータ名

setRow

public void setRow(String row)
パラメータの行を設定します。

パラメータ:
row - パラメータの行

setField

public void setField(String field)
パラメータの項目を設定します。

パラメータ:
field - パラメータの項目

setSystem

public void setSystem(String system)
メッセージが発行された論理システムを設定します。

パラメータ:
system - メッセージが発行された論理システム

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TotalConsumption (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス TotalConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption
すべての実装インタフェース:
Serializable
public class TotalConsumption
extends Object
implements Serializable

品目総消費量のデータ転送情報クラス
機能は以下の通り

  • 品目総消費量のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TotalConsumption()
品目総消費量のデータ転送情報を作成します。
TotalConsumption(int index)
品目総消費量のデータ転送情報を作成します。
メソッドの概要
String | getConsValue() 消費量を取得します。
String | getCorrValue() 修正消費量を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setConsValue(String consValue) 消費量を設定します。
void | setCorrValue(String corrValue) 修正消費量を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TotalConsumption

public TotalConsumption()
品目総消費量のデータ転送情報を作成します。

TotalConsumption

public TotalConsumption(int index)
品目総消費量のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getConsValue

public String getConsValue()
消費量を取得します。

戻り値:
consValue 消費量

getCorrValue

public String getCorrValue()
修正消費量を取得します。

戻り値:
corrValue 修正消費量

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setConsValue

public void setConsValue(String consValue)
消費量を設定します。

パラメータ:
consValue - 消費量

setCorrValue

public void setCorrValue(String corrValue)
修正消費量を設定します。

パラメータ:
corrValue - 修正消費量

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnplndConsumption (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
クラス UnplndConsumption

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption
すべての実装インタフェース:
Serializable
public class UnplndConsumption
extends Object
implements Serializable

計画外消費のデータ転送情報クラス
機能は以下の通り

  • 計画外消費のデータ転送情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
UnplndConsumption()
計画外消費のデータ転送情報を作成します。
UnplndConsumption(int index)
計画外消費のデータ転送情報を作成します。
メソッドの概要
String | getConsValue() 消費量を取得します。
String | getCorrValue() 修正消費量を取得します。
String | getFirstDay() 値参照期間の第一日目を取得します。
String | getFunction() BAPI 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getPlant() プラントを取得します。
String | getValRatio() 元値に対する修正値の比率 (修正値: 元値)を取得します。
void | setConsValue(String consValue) 消費量を設定します。
void | setCorrValue(String corrValue) 修正消費量を設定します。
void | setFirstDay(String firstDay) 値参照期間の第一日目を設定します。
void | setFunction(String function) BAPI 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setValRatio(String valRatio) 元値に対する修正値の比率 (修正値: 元値)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnplndConsumption

public UnplndConsumption()
計画外消費のデータ転送情報を作成します。

UnplndConsumption

public UnplndConsumption(int index)
計画外消費のデータ転送情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getFunction

public String getFunction()
BAPI 機能を取得します。

戻り値:
function BAPI 機能

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getFirstDay

public String getFirstDay()
値参照期間の第一日目を取得します。

戻り値:
firstDay 値参照期間の第一日目

getConsValue

public String getConsValue()
消費量を取得します。

戻り値:
consValue 消費量

getCorrValue

public String getCorrValue()
修正消費量を取得します。

戻り値:
corrValue 修正消費量

getValRatio

public String getValRatio()
元値に対する修正値の比率 (修正値: 元値)を取得します。

戻り値:
valRatio 元値に対する修正値の比率 (修正値: 元値)

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setFunction

public void setFunction(String function)
BAPI 機能を設定します。

パラメータ:
function - BAPI 機能

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setFirstDay

public void setFirstDay(String firstDay)
値参照期間の第一日目を設定します。

パラメータ:
firstDay - 値参照期間の第一日目

setConsValue

public void setConsValue(String consValue)
消費量を設定します。

パラメータ:
consValue - 消費量

setCorrValue

public void setCorrValue(String corrValue)
修正消費量を設定します。

パラメータ:
corrValue - 修正消費量

setValRatio

public void setValRatio(String valRatio)
元値に対する修正値の比率 (修正値: 元値)を設定します。

パラメータ:
valRatio - 元値に対する修正値の比率 (修正値: 元値)

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス
StdMaterialGetIntNumber
StdMaterialGetIntNumberList


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

クラスの概要
StdMaterialGetIntNumber | 品目コード割当済情報クラス 機能は以下の通り 品目コード割当済の情報を保持します。
StdMaterialGetIntNumberList | 品目コード割当済一覧クラス 機能は以下の通り 品目コード割当済の情報を一覧形式で取得します。


jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber の使用

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


StdMaterialGetIntNumber (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス StdMaterialGetIntNumber

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumber
extends Object
implements Serializable

品目コード割当済情報クラス
機能は以下の通り

  • 品目コード割当済の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StdMaterialGetIntNumber()
品目コード割当済情報を作成します。
メソッドの概要
String | getMaterial() 品目コードを取得します｡
String | getMaterialExternal() 項目 MATERIAL の品目コード (長)を取得します｡
String | getMaterialGuid() 項目 MATERIAL の外部 GUIDを取得します｡
String | getMaterialVersion() 項目 MATERIAL のバージョン番号を取得します｡
void | setMaterial(String material) 品目コードを設定します｡
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長)を設定します｡
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUIDを設定します｡
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumber

public StdMaterialGetIntNumber()
品目コード割当済情報を作成します。

メソッドの詳細

setMaterial

public void setMaterial(String material)
品目コードを設定します｡

パラメータ:
material - 品目コード

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長)を設定します｡

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUIDを設定します｡

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号を設定します｡

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号

getMaterial

public String getMaterial()
品目コードを取得します｡

戻り値:
material

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長)を取得します｡

戻り値:
materialExternal

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUIDを取得します｡

戻り値:
materialGuid

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号を取得します｡

戻り値:
materialVersion

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


StdMaterialGetIntNumberList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
クラス StdMaterialGetIntNumberList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumberList
extends ReferenceController
implements Serializable

品目コード割当済一覧クラス
機能は以下の通り

  • 品目コード割当済の情報を一覧形式で取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
StdMaterialGetIntNumberList(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
executeBapiを呼び出し品目コード割当済一覧を作成します。
メソッドの概要
List | getStdMaterialGetIntNumberList() 品目コード割当済一覧を取得します｡
void | setStdMaterialGetIntNumberList(List stdMaterialGetIntNumberList) 品目コード割当済一覧を設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumberList

public StdMaterialGetIntNumberList(String materialType,
                                   String industrySector,
                                   String requiredNumbers,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseSystemException,
                                   SAPPurchaseAppException
executeBapiを呼び出し品目コード割当済一覧を作成します。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外
メソッドの詳細

setStdMaterialGetIntNumberList

public void setStdMaterialGetIntNumberList(List stdMaterialGetIntNumberList)
品目コード割当済一覧を設定します｡

パラメータ:
stdMaterialGetIntNumberList - 品目コード割当済一覧

getStdMaterialGetIntNumberList

public List getStdMaterialGetIntNumberList()
品目コード割当済一覧を取得します｡

戻り値:
stdMaterialGetIntNumberList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AllVersions (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス AllVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.AllVersions
すべての実装インタフェース:
Serializable
public class AllVersions
extends Object
implements Serializable

全バージョン管理情報クラス
機能は以下の通り

  • 全バージョン管理情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
AllVersions()
バージョン管理を作成します。
メソッドの概要
String | getCompleted() ステータス "バージョン完了済"を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCrOn() レコード登録日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDescription() バージョンテキスト（長）を取得します。
String | getDocNumber() 購買管理におけるオブジェクト番号を取得します。
String | getDocType() 購買伝票カテゴリを取得します。
String | getItemNumber() 購買管理オブジェクト: 明細を取得します。
String | getNetValue() 購買発注通貨による正味発注額を取得します。
String | getPostDate() バージョンの転記日付を取得します。
String | getReason() 変更理由を取得します。
String | getRecTime() 登録時刻を取得します。
String | getReleasebyPur() 承認購買担当者名を取得します。
String | getReleaseDate() 承認日を取得します。
String | getReleasedatePur() 購買担当者承認日付を取得します。
String | getReleasedBy() 承認者名を取得します。
String | getReleaseTime() 承認時刻を取得します。
String | getReleasetimePur() 購買担当者承認時刻を取得します。
String | getReqBy() 変更を依頼した従業員を取得します。
String | getReqByExt() バージョンの外部変更番号を取得します。
String | getStatus() バージョンステータスを取得します。
String | getStatusDocOld() このバージョンの前の旧処理状況 (購買伝票内)を取得します。
String | getValueChanged() バージョンによる金額変更を取得します。
String | getVersion() 購買管理におけるバージョン番号を取得します。
void | setCompleted(String strCompleted) ステータス "バージョン完了済"を設定します。
void | setCreatedBy(String strCreatedBy) オブジェクト登録者名を設定します。
void | setCrOn(String strCrOn) レコード登録日を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO コード通貨を設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDescription(String strDescription) バージョンテキスト（長）を設定します。
void | setDocNumber(String strDocNumber) 購買管理におけるオブジェクト番号を設定します。
void | setDocType(String strDocType) 購買伝票カテゴリを設定します。
void | setItemNumber(String strItemNumber) 購買管理オブジェクト: 明細を設定します。
void | setNetValue(String strNetValue) 購買発注通貨による正味発注額を設定します。
void | setPostDate(String strPostDate) バージョンの転記日付を設定します。
void | setReason(String strReason) 変更理由を設定します。
void | setRecTime(String strRecTime) 登録時刻を設定します。
void | setReleasebyPur(String strReleasebyPur) 承認購買担当者名を設定します。
void | setReleaseDate(String strReleaseDate) 承認日を設定します。
void | setReleasedatePur(String strReleasedatePur) 購買担当者承認日付を設定します。
void | setReleasedBy(String strReleasedBy) 承認者名を設定します。
void | setReleaseTime(String strReleaseTime) 承認時刻を設定します。
void | setReleasetimePur(String strReleasetimePur) 購買担当者承認時刻を設定します。
void | setReqBy(String strReqBy) 変更を依頼した従業員を設定します。
void | setReqByExt(String strReqByExt) バージョンの外部変更番号を設定します。
void | setStatus(String strStatus) バージョンステータスを設定します。
void | setStatusDocOld(String strStatusDocOld) このバージョンの前の旧処理状況 (購買伝票内)を設定します。
void | setValueChanged(String strValueChanged) バージョンによる金額変更を設定します。
void | setVersion(String strVersion) 購買管理におけるバージョン番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

AllVersions

public AllVersions()
バージョン管理を作成します。

メソッドの詳細

getDocType

public String getDocType()
購買伝票カテゴリを取得します。

戻り値:
srtDocType 購買伝票カテゴリ

getDocNumber

public String getDocNumber()
購買管理におけるオブジェクト番号を取得します。

戻り値:
srtDocNumber 購買管理におけるオブジェクト番号

getItemNumber

public String getItemNumber()
購買管理オブジェクト: 明細を取得します。

戻り値:
srtItemNumber 購買管理オブジェクト: 明細

getVersion

public String getVersion()
購買管理におけるバージョン番号を取得します。

戻り値:
srtVersion 購買管理におけるバージョン番号

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
srtCreatedBy オブジェクト登録者名

getCrOn

public String getCrOn()
レコード登録日を取得します。

戻り値:
srtCrOn レコード登録日

getRecTime

public String getRecTime()
登録時刻を取得します。

戻り値:
srtRecTime 登録時刻

getReleasedBy

public String getReleasedBy()
承認者名を取得します。

戻り値:
srtReleasedBy 承認者名

getReleaseDate

public String getReleaseDate()
承認日を取得します。

戻り値:
srtReleaseDate 承認日

getReleaseTime

public String getReleaseTime()
承認時刻を取得します。

戻り値:
srtReleaseTime 承認時刻

getReleasebyPur

public String getReleasebyPur()
承認購買担当者名を取得します。

戻り値:
srtReleasebyPur 承認購買担当者名

getReleasedatePur

public String getReleasedatePur()
購買担当者承認日付を取得します。

戻り値:
srtReleasedatePur 購買担当者承認日付

getReleasetimePur

public String getReleasetimePur()
購買担当者承認時刻を取得します。

戻り値:
srtReleasetimePur 購買担当者承認時刻

getReason

public String getReason()
変更理由を取得します。

戻り値:
srtReason 変更理由

getDescription

public String getDescription()
バージョンテキスト（長）を取得します。

戻り値:
srtDescription バージョンテキスト（長）

getReqByExt

public String getReqByExt()
バージョンの外部変更番号を取得します。

戻り値:
srtReqByExt バージョンの外部変更番号

getReqBy

public String getReqBy()
変更を依頼した従業員を取得します。

戻り値:
srtReqBy 変更を依頼した従業員

getNetValue

public String getNetValue()
購買発注通貨による正味発注額を取得します。

戻り値:
srtNetValue 購買発注通貨による正味発注額

getValueChanged

public String getValueChanged()
バージョンによる金額変更を取得します。

戻り値:
srtValueChanged バージョンによる金額変更

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrencyIso ISO コード通貨

getPostDate

public String getPostDate()
バージョンの転記日付を取得します。

戻り値:
srtPostDate バージョンの転記日付

getCompleted

public String getCompleted()
ステータス "バージョン完了済"を取得します。

戻り値:
srtCompleted ステータス "バージョン完了済"

getStatus

public String getStatus()
バージョンステータスを取得します。

戻り値:
srtStatus バージョンステータス

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
srtDeleteInd 購買伝票の削除フラグ

getStatusDocOld

public String getStatusDocOld()
このバージョンの前の旧処理状況 (購買伝票内)を取得します。

戻り値:
srtStatusDocOld このバージョンの前の旧処理状況 (購買伝票内)

setDocType

public void setDocType(String strDocType)
購買伝票カテゴリを設定します。

パラメータ:
strDocType - 購買伝票カテゴリ

setDocNumber

public void setDocNumber(String strDocNumber)
購買管理におけるオブジェクト番号を設定します。

パラメータ:
strDocNumber - 購買管理におけるオブジェクト番号

setItemNumber

public void setItemNumber(String strItemNumber)
購買管理オブジェクト: 明細を設定します。

パラメータ:
strItemNumber - 購買管理オブジェクト: 明細

setVersion

public void setVersion(String strVersion)
購買管理におけるバージョン番号を設定します。

パラメータ:
strVersion - 購買管理におけるバージョン番号

setCreatedBy

public void setCreatedBy(String strCreatedBy)
オブジェクト登録者名を設定します。

パラメータ:
strCreatedBy - オブジェクト登録者名

setCrOn

public void setCrOn(String strCrOn)
レコード登録日を設定します。

パラメータ:
strCrOn - レコード登録日

setRecTime

public void setRecTime(String strRecTime)
登録時刻を設定します。

パラメータ:
strRecTime - 登録時刻

setReleasedBy

public void setReleasedBy(String strReleasedBy)
承認者名を設定します。

パラメータ:
strReleasedBy - 承認者名

setReleaseDate

public void setReleaseDate(String strReleaseDate)
承認日を設定します。

パラメータ:
strReleaseDate - 承認日

setReleaseTime

public void setReleaseTime(String strReleaseTime)
承認時刻を設定します。

パラメータ:
strReleaseTime - 承認時刻

setReleasebyPur

public void setReleasebyPur(String strReleasebyPur)
承認購買担当者名を設定します。

パラメータ:
strReleasebyPur - 承認購買担当者名

setReleasedatePur

public void setReleasedatePur(String strReleasedatePur)
購買担当者承認日付を設定します。

パラメータ:
strReleasedatePur - 購買担当者承認日付

setReleasetimePur

public void setReleasetimePur(String strReleasetimePur)
購買担当者承認時刻を設定します。

パラメータ:
strReleasetimePur - 購買担当者承認時刻

setReason

public void setReason(String strReason)
変更理由を設定します。

パラメータ:
strReason - 変更理由

setDescription

public void setDescription(String strDescription)
バージョンテキスト（長）を設定します。

パラメータ:
strDescription - バージョンテキスト（長）

setReqByExt

public void setReqByExt(String strReqByExt)
バージョンの外部変更番号を設定します。

パラメータ:
strReqByExt - バージョンの外部変更番号

setReqBy

public void setReqBy(String strReqBy)
変更を依頼した従業員を設定します。

パラメータ:
strReqBy - 変更を依頼した従業員

setNetValue

public void setNetValue(String strNetValue)
購買発注通貨による正味発注額を設定します。

パラメータ:
strNetValue - 購買発注通貨による正味発注額

setValueChanged

public void setValueChanged(String strValueChanged)
バージョンによる金額変更を設定します。

パラメータ:
strValueChanged - バージョンによる金額変更

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrencyIso - ISO コード通貨

setPostDate

public void setPostDate(String strPostDate)
バージョンの転記日付を設定します。

パラメータ:
strPostDate - バージョンの転記日付

setCompleted

public void setCompleted(String strCompleted)
ステータス "バージョン完了済"を設定します。

パラメータ:
strCompleted - ステータス "バージョン完了済"

setStatus

public void setStatus(String strStatus)
バージョンステータスを設定します。

パラメータ:
strStatus - バージョンステータス

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setStatusDocOld

public void setStatusDocOld(String strStatusDocOld)
このバージョンの前の旧処理状況 (購買伝票内)を設定します。

パラメータ:
strStatusDocOld - このバージョンの前の旧処理状況 (購買伝票内)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Cond (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Cond

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Cond
すべての実装インタフェース:
Serializable
public class Cond
extends Object
implements Serializable

条件情報クラス
機能は以下の通り

  • 条件情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Cond()
条件を作成します。
Cond(int index)
条件を作成します。
メソッドの概要
String | getAccessSeq() 検索順序 - 検索番号を取得します。
String | getAccruals() 見越額関連条件 (運賃など)を取得します。
String | getApplicatio() アプリケーションを取得します。
String | getCalctypcon() 条件計算タイプを取得します。
String | getChangeId() 変更タイプ(U、I、E、D)を取得します。
int | getCoIndex() レコード番号を取得します｡
String | getConbaseval() 条件基礎値を取得します。
String | getCondchaman() 条件 (マニュアル変更済)を取得します。
String | getCondclass() 条件クラスを取得します。
String | getCondcntrl() 条件管理を取得します。
String | getCondconfig() システム設定の条件を取得します。
String | getCondcount() 条件連続番号を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getCondincomp() 会社間請求の条件を取得します。
String | getCondisacti() 無効条件を取得します。
String | getConditionNo() 伝票条件番号を取得します。
String | getCondNo() 条件レコード番号を取得します。
String | getCondorigin() 条件生成区分を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondtype() 条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 条件単位を取得します。
String | getCondUnitIso() 条件数量単位 (ISO コード)を取得します。
String | getCondUpdat() 条件更新を取得します。
String | getCondValue() 条件レートを取得します。
String | getConexchrat() 現地通貨への換算レートに対する条件を取得します。
String | getConinvolst() 請求書一覧条件を取得します。
String | getConpricdat() 条件価格設定日付を取得します。
String | getCurrenckey() スケール通貨を取得します。
String | getCurrenckeyIso() ISO コード通貨を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDenominato() 条件単位を基本単位へ変換する分母を取得します。
String | getFactbasval() 条件基礎値に対する要因を取得します。
String | getGroupcond() グループ条件区分を取得します。
String | getItmNumber() 条件明細番号を取得します。
String | getNumconvert() 条件単位を基本単位へ変換する分子を取得します。
String | getScalbasval() 条件のスケール基準値を取得します。
String | getScalebasin() スケール基準区分を取得します。
String | getScaletype() スケールタイプを取得します。
String | getStatCon() 統計に適用する条件を取得します。
String | getUnitmeasur() 条件スケール単位を取得します。
String | getUnitmeasurIso() 単位の ISO コードを取得します。
void | setAccessSeq(String strAccessSeq) 検索順序 - 検索番号を設定します。
void | setAccruals(String strAccruals) 見越額関連条件 (運賃など)を設定します。
void | setApplicatio(String strApplicatio) アプリケーションを設定します。
void | setCalctypcon(String strCalctypcon) 条件計算タイプを設定します。
void | setChangeId(String strChangeId) 変更タイプ(U、I、E、D)を設定します。
void | setCoIndex(int coIndex) レコード番号を設定します｡
void | setConbaseval(String strConbaseval) 条件基礎値を設定します。
void | setCondchaman(String strCondchaman) 条件 (マニュアル変更済)を設定します。
void | setCondclass(String strCondclass) 条件クラスを設定します。
void | setCondcntrl(String strCondcntrl) 条件管理を設定します。
void | setCondconfig(String strCondconfig) システム設定の条件を設定します。
void | setCondcount(String strCondcount) 条件連続番号を設定します。
void | setCondCount(String strCondCount) 条件カウンタを設定します。
void | setCondincomp(String strCondincomp) 会社間請求の条件を設定します。
void | setCondisacti(String strCondisacti) 無効条件を設定します。
void | setConditionNo(String strConditionNo) 伝票条件番号を設定します。
void | setCondNo(String strCondNo) 条件レコード番号を設定します。
void | setCondorigin(String strCondorigin) 条件生成区分を設定します。
void | setCondPUnt(String strCondPUnt) 価格条件単位を設定します。
void | setCondStNo(String strCondStNo) ステップ番号を設定します。
void | setCondtype(String strCondtype) 条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
void | setCondType(String strCondType) 条件タイプを設定します。
void | setCondUnit(String strCondUnit) 条件単位を設定します。
void | setCondUnitIso(String strCondUnitIso) 条件数量単位 (ISO コード)を設定します。
void | setCondUpdat(String strCondUpdat) 条件更新を設定します。
void | setCondValue(String strCondValue) 条件レートを設定します。
void | setConexchrat(String strConexchrat) 現地通貨への換算レートに対する条件を設定します。
void | setConinvolst(String strConinvolst) 請求書一覧条件を設定します。
void | setConpricdat(String strConpricdat) 条件価格設定日付を設定します。
void | setCurrenckey(String strCurrenckey) スケール通貨を設定します。
void | setCurrenckeyIso(String strCurrenckeyIso) ISO コード通貨を設定します。
void | setCurrency(String strCurrency) 通貨コードを設定します。
void | setCurrencyIso(String strCurrencyIso) ISO コード通貨を設定します。
void | setDenominato(String strDenominato) 条件単位を基本単位へ変換する分母を設定します。
void | setFactbasval(String strFactbasval) 条件基礎値に対する要因を設定します。
void | setGroupcond(String strGroupcond) グループ条件区分を設定します。
void | setItmNumber(String strItmNumber) 条件明細番号を設定します。
void | setNumconvert(String strNumconvert) 条件単位を基本単位へ変換する分子を設定します。
void | setScalbasval(String strScalbasval) 条件のスケール基準値を設定します。
void | setScalebasin(String strScalebasin) スケール基準区分を設定します。
void | setScaletype(String strScaletype) スケールタイプを設定します。
void | setStatCon(String strStatCon) 統計に適用する条件を設定します。
void | setUnitmeasur(String strUnitmeasur) 条件スケール単位を設定します。
void | setUnitmeasurIso(String strUnitmeasurIso) 単位の ISO コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Cond

public Cond()
条件を作成します。

Cond

public Cond(int index)
条件を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConditionNo

public String getConditionNo()
伝票条件番号を取得します。

戻り値:
srtConditionNo 伝票条件番号

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
srtItmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
srtCondStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
srtCondCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
srtCondType 条件タイプ

getCondValue

public String getCondValue()
条件レートを取得します。

戻り値:
srtCondValue 条件レート

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
srtCurrency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrencyIso ISO コード通貨

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
srtCondUnit 条件単位

getCondUnitIso

public String getCondUnitIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
srtCondUnitIso 条件数量単位 (ISO コード)

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
srtCondPUnt 価格条件単位

getApplicatio

public String getApplicatio()
アプリケーションを取得します。

戻り値:
srtApplicatio アプリケーション

getConpricdat

public String getConpricdat()
条件価格設定日付を取得します。

戻り値:
srtConpricdat 条件価格設定日付

getCalctypcon

public String getCalctypcon()
条件計算タイプを取得します。

戻り値:
srtCalctypcon 条件計算タイプ

getConbaseval

public String getConbaseval()
条件基礎値を取得します。

戻り値:
srtConbaseval 条件基礎値

getConexchrat

public String getConexchrat()
現地通貨への換算レートに対する条件を取得します。

戻り値:
srtConexchrat 現地通貨への換算レートに対する条件

getNumconvert

public String getNumconvert()
条件単位を基本単位へ変換する分子を取得します。

戻り値:
srtNumconvert 条件単位を基本単位へ変換する分子

getDenominato

public String getDenominato()
条件単位を基本単位へ変換する分母を取得します。

戻り値:
srtDenominato 条件単位を基本単位へ変換する分母

getCondtype

public String getCondtype()
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。

戻り値:
srtCondtype 条件カテゴリ (例: 税、運賃、価格、原価)

getStatCon

public String getStatCon()
統計に適用する条件を取得します。

戻り値:
srtStatCon 統計に適用する条件

getScaletype

public String getScaletype()
スケールタイプを取得します。

戻り値:
srtScaletype スケールタイプ

getAccruals

public String getAccruals()
見越額関連条件 (運賃など)を取得します。

戻り値:
srtAccruals 見越額関連条件 (運賃など)

getConinvolst

public String getConinvolst()
請求書一覧条件を取得します。

戻り値:
srtConinvolst 請求書一覧条件

getCondorigin

public String getCondorigin()
条件生成区分を取得します。

戻り値:
srtCondorigin 条件生成区分

getGroupcond

public String getGroupcond()
グループ条件区分を取得します。

戻り値:
srtGroupcond グループ条件区分

getCondUpdat

public String getCondUpdat()
条件更新を取得します。

戻り値:
srtCondUpdat 条件更新

getAccessSeq

public String getAccessSeq()
検索順序 - 検索番号を取得します。

戻り値:
srtAccessSeq 検索順序 - 検索番号

getCondcount

public String getCondcount()
条件連続番号を取得します。

戻り値:
srtCondcount 条件連続番号

getCondcntrl

public String getCondcntrl()
条件管理を取得します。

戻り値:
srtCondcntrl 条件管理

getCondisacti

public String getCondisacti()
無効条件を取得します。

戻り値:
srtCondisacti 無効条件

getCondclass

public String getCondclass()
条件クラスを取得します。

戻り値:
srtCondclass 条件クラス

getFactbasval

public String getFactbasval()
条件基礎値に対する要因を取得します。

戻り値:
srtFactbasval 条件基礎値に対する要因

getScalebasin

public String getScalebasin()
スケール基準区分を取得します。

戻り値:
srtScalebasin スケール基準区分

getScalbasval

public String getScalbasval()
条件のスケール基準値を取得します。

戻り値:
srtScalbasval 条件のスケール基準値

getUnitmeasur

public String getUnitmeasur()
条件スケール単位を取得します。

戻り値:
srtUnitmeasur 条件スケール単位

getUnitmeasurIso

public String getUnitmeasurIso()
単位の ISO コードを取得します。

戻り値:
srtUnitmeasurIso 単位の ISO コード

getCurrenckey

public String getCurrenckey()
スケール通貨を取得します。

戻り値:
srtCurrenckey スケール通貨

getCurrenckeyIso

public String getCurrenckeyIso()
ISO コード通貨を取得します。

戻り値:
srtCurrenckeyIso ISO コード通貨

getCondincomp

public String getCondincomp()
会社間請求の条件を取得します。

戻り値:
srtCondincomp 会社間請求の条件

getCondconfig

public String getCondconfig()
システム設定の条件を取得します。

戻り値:
srtCondconfig システム設定の条件

getCondchaman

public String getCondchaman()
条件 (マニュアル変更済)を取得します。

戻り値:
srtCondchaman 条件 (マニュアル変更済)

getCondNo

public String getCondNo()
条件レコード番号を取得します。

戻り値:
srtCondNo 条件レコード番号

getChangeId

public String getChangeId()
変更タイプ(U、I、E、D)を取得します。

戻り値:
srtChangeId 変更タイプ(U、I、E、D)

getCoIndex

public int getCoIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setConditionNo

public void setConditionNo(String strConditionNo)
伝票条件番号を設定します。

パラメータ:
strConditionNo - 伝票条件番号

setItmNumber

public void setItmNumber(String strItmNumber)
条件明細番号を設定します。

パラメータ:
strItmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String strCondStNo)
ステップ番号を設定します。

パラメータ:
strCondStNo - ステップ番号

setCondCount

public void setCondCount(String strCondCount)
条件カウンタを設定します。

パラメータ:
strCondCount - 条件カウンタ

setCondType

public void setCondType(String strCondType)
条件タイプを設定します。

パラメータ:
strCondType - 条件タイプ

setCondValue

public void setCondValue(String strCondValue)
条件レートを設定します。

パラメータ:
strCondValue - 条件レート

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します。

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrencyIso - ISO コード通貨

setCondUnit

public void setCondUnit(String strCondUnit)
条件単位を設定します。

パラメータ:
strCondUnit - 条件単位

setCondUnitIso

public void setCondUnitIso(String strCondUnitIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
strCondUnitIso - 条件数量単位 (ISO コード)

setCondPUnt

public void setCondPUnt(String strCondPUnt)
価格条件単位を設定します。

パラメータ:
strCondPUnt - 価格条件単位

setApplicatio

public void setApplicatio(String strApplicatio)
アプリケーションを設定します。

パラメータ:
strApplicatio - アプリケーション

setConpricdat

public void setConpricdat(String strConpricdat)
条件価格設定日付を設定します。

パラメータ:
strConpricdat - 条件価格設定日付

setCalctypcon

public void setCalctypcon(String strCalctypcon)
条件計算タイプを設定します。

パラメータ:
strCalctypcon - 条件計算タイプ

setConbaseval

public void setConbaseval(String strConbaseval)
条件基礎値を設定します。

パラメータ:
strConbaseval - 条件基礎値

setConexchrat

public void setConexchrat(String strConexchrat)
現地通貨への換算レートに対する条件を設定します。

パラメータ:
strConexchrat - 現地通貨への換算レートに対する条件

setNumconvert

public void setNumconvert(String strNumconvert)
条件単位を基本単位へ変換する分子を設定します。

パラメータ:
strNumconvert - 条件単位を基本単位へ変換する分子

setDenominato

public void setDenominato(String strDenominato)
条件単位を基本単位へ変換する分母を設定します。

パラメータ:
strDenominato - 条件単位を基本単位へ変換する分母

setCondtype

public void setCondtype(String strCondtype)
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。

パラメータ:
strCondtype - 条件カテゴリ (例: 税、運賃、価格、原価)

setStatCon

public void setStatCon(String strStatCon)
統計に適用する条件を設定します。

パラメータ:
strStatCon - 統計に適用する条件

setScaletype

public void setScaletype(String strScaletype)
スケールタイプを設定します。

パラメータ:
strScaletype - スケールタイプ

setAccruals

public void setAccruals(String strAccruals)
見越額関連条件 (運賃など)を設定します。

パラメータ:
strAccruals - 見越額関連条件 (運賃など)

setConinvolst

public void setConinvolst(String strConinvolst)
請求書一覧条件を設定します。

パラメータ:
strConinvolst - 請求書一覧条件

setCondorigin

public void setCondorigin(String strCondorigin)
条件生成区分を設定します。

パラメータ:
strCondorigin - 条件生成区分

setGroupcond

public void setGroupcond(String strGroupcond)
グループ条件区分を設定します。

パラメータ:
strGroupcond - グループ条件区分

setCondUpdat

public void setCondUpdat(String strCondUpdat)
条件更新を設定します。

パラメータ:
strCondUpdat - 条件更新

setAccessSeq

public void setAccessSeq(String strAccessSeq)
検索順序 - 検索番号を設定します。

パラメータ:
strAccessSeq - 検索順序 - 検索番号

setCondcount

public void setCondcount(String strCondcount)
条件連続番号を設定します。

パラメータ:
strCondcount - 条件連続番号

setCondcntrl

public void setCondcntrl(String strCondcntrl)
条件管理を設定します。

パラメータ:
strCondcntrl - 条件管理

setCondisacti

public void setCondisacti(String strCondisacti)
無効条件を設定します。

パラメータ:
strCondisacti - 無効条件

setCondclass

public void setCondclass(String strCondclass)
条件クラスを設定します。

パラメータ:
strCondclass - 条件クラス

setFactbasval

public void setFactbasval(String strFactbasval)
条件基礎値に対する要因を設定します。

パラメータ:
strFactbasval - 条件基礎値に対する要因

setScalebasin

public void setScalebasin(String strScalebasin)
スケール基準区分を設定します。

パラメータ:
strScalebasin - スケール基準区分

setScalbasval

public void setScalbasval(String strScalbasval)
条件のスケール基準値を設定します。

パラメータ:
strScalbasval - 条件のスケール基準値

setUnitmeasur

public void setUnitmeasur(String strUnitmeasur)
条件スケール単位を設定します。

パラメータ:
strUnitmeasur - 条件スケール単位

setUnitmeasurIso

public void setUnitmeasurIso(String strUnitmeasurIso)
単位の ISO コードを設定します。

パラメータ:
strUnitmeasurIso - 単位の ISO コード

setCurrenckey

public void setCurrenckey(String strCurrenckey)
スケール通貨を設定します。

パラメータ:
strCurrenckey - スケール通貨

setCurrenckeyIso

public void setCurrenckeyIso(String strCurrenckeyIso)
ISO コード通貨を設定します。

パラメータ:
strCurrenckeyIso - ISO コード通貨

setCondincomp

public void setCondincomp(String strCondincomp)
会社間請求の条件を設定します。

パラメータ:
strCondincomp - 会社間請求の条件

setCondconfig

public void setCondconfig(String strCondconfig)
システム設定の条件を設定します。

パラメータ:
strCondconfig - システム設定の条件

setCondchaman

public void setCondchaman(String strCondchaman)
条件 (マニュアル変更済)を設定します。

パラメータ:
strCondchaman - 条件 (マニュアル変更済)

setCondNo

public void setCondNo(String strCondNo)
条件レコード番号を設定します。

パラメータ:
strCondNo - 条件レコード番号

setChangeId

public void setChangeId(String strChangeId)
変更タイプ(U、I、E、D)を設定します。

パラメータ:
strChangeId - 変更タイプ(U、I、E、D)

setCoIndex

public void setCoIndex(int coIndex)
レコード番号を設定します｡

パラメータ:
coIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractLimits (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits
すべての実装インタフェース:
Serializable
public class ContractLimits
extends Object
implements Serializable

外注基本契約制限情報クラス
機能は以下の通り

  • 外注基本契約情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractLimits()
外注基本契約を作成します。
ContractLimits(int index)
外注基本契約を作成します。
メソッドの概要
int | getClIndex() レコード番号を取得します｡
String | getConItem() 明細番号、契約を取得します。
String | getConNumber() 基本契約番号を取得します。
String | getDeleteInd() 削除フラグを取得します。
String | getLimit() 全体制限を取得します。
String | getLineNo() 制限の内部明細番号を取得します。
String | getNoLimit() 制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getShortText() テキスト 1 (短)を取得します。
void | setClIndex(int clIndex) レコード番号を設定します｡
void | setConItem(String strConItem) 明細番号、契約を設定します。
void | setConNumber(String strConNumber) 基本契約番号を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します。
void | setLimit(String strLimit) 全体制限を設定します。
void | setLineNo(String strLineNo) 制限の内部明細番号を設定します。
void | setNoLimit(String strNoLimit) 制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setShortText(String strShortText) テキスト 1 (短)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractLimits

public ContractLimits()
外注基本契約を作成します。

ContractLimits

public ContractLimits(int index)
外注基本契約を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
制限の内部明細番号を取得します。

戻り値:
srtLineNo 制限の内部明細番号

getConNumber

public String getConNumber()
基本契約番号を取得します。

戻り値:
srtConNumber 基本契約番号

getConItem

public String getConItem()
明細番号、契約を取得します。

戻り値:
srtConItem 明細番号、契約

getLimit

public String getLimit()
全体制限を取得します。

戻り値:
srtLimit 全体制限

getNoLimit

public String getNoLimit()
制限なしを取得します。

戻り値:
srtNoLimit 制限なし

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getShortText

public String getShortText()
テキスト 1 (短)を取得します。

戻り値:
srtShortText テキスト 1 (短)

getDeleteInd

public String getDeleteInd()
削除フラグを取得します。

戻り値:
srtDeleteInd 削除フラグ

getClIndex

public int getClIndex()
レコード番号を取得します｡

戻り値:
clIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
制限の内部明細番号を設定します。

パラメータ:
strLineNo - 制限の内部明細番号

setConNumber

public void setConNumber(String strConNumber)
基本契約番号を設定します。

パラメータ:
strConNumber - 基本契約番号

setConItem

public void setConItem(String strConItem)
明細番号、契約を設定します。

パラメータ:
strConItem - 明細番号、契約

setLimit

public void setLimit(String strLimit)
全体制限を設定します。

パラメータ:
strLimit - 全体制限

setNoLimit

public void setNoLimit(String strNoLimit)
制限なしを設定します。

パラメータ:
strNoLimit - 制限なし

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setShortText

public void setShortText(String strShortText)
テキスト 1 (短)を設定します。

パラメータ:
strShortText - テキスト 1 (短)

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します。

パラメータ:
strDeleteInd - 削除フラグ

setClIndex

public void setClIndex(int clIndex)
レコード番号を設定します｡

パラメータ:
clIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractService (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractService

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractService
すべての実装インタフェース:
Serializable
public class ContractService
extends Object
implements Serializable

外注サービス情報クラス
機能は以下の通り

  • 外注サービス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractService()
外注サービスを作成します。
ContractService(int index)
外注サービスを作成します。
メソッドの概要
String | getAlternat() 代替明細を取得します。
String | getBaseUom() 基本数量単位を取得します。
String | getBasicLine() 基本明細を取得します。
String | getBaslineNo() 代替: 基本明細参照を取得します。
String | getBegintime() 開始時刻を取得します。
String | getBidder() 入札者の明細を取得します。
String | getBlanket() 包括明細を取得します。
String | getConLine() 入力: 基本契約の計画外を取得します。
String | getConPckg() 入力: 基本契約の計画外を取得します。
int | getCsIndex() レコード番号を取得します｡
String | getDate() 日付を取得します。
String | getDeleteInd() 削除フラグを取得します。
String | getDistrib() 複数勘定設定の配賦区分を取得します。
String | getEdition() サービスタイプのバージョンを取得します。
String | getEndtime() 終了時刻を取得します。
String | getEventual() 偶発的明細を取得します。
String | getExtLine() 明細番号を取得します。
String | getExtpersNo() 外部従業員番号を取得します。
String | getExtrefkey() サービスの外部参照キーを取得します。
String | getExtServ() 仕入先のサービス番号を取得します。
String | getFormula() 計算式番号を取得します。
String | getFormVal1() 計算式値を取得します。
String | getFormVal2() 計算式値を取得します。
String | getFormVal3() 計算式値を取得します。
String | getFormVal4() 計算式値を取得します。
String | getFormVal5() 計算式値を取得します。
String | getFromLine() 下限を取得します。
String | getGrPrice() 基準額を取得します。
String | getHiLineNo() 上位階層明細番号を取得します。
String | getInform() 情報行を取得します。
String | getLimitLine() 入力: 計画外、明細制限を取得します。
String | getLineNo() 内部明細番号を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getOpenQty() 未処理数量のある明細を取得します。
String | getOutlInd() 区分: 出力行を取得します。
String | getOutlLevel() グループの階層レベルを取得します。
String | getOutlNo() アウトラインレベルを取得します。
String | getOvfTol() 超過許容値を取得します。
String | getOvfUnlim() 契約外サービス制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPersNo() 従業員番号を取得します。
String | getPlnLine() 入力: 計画梱包明細行を取得します。
String | getPlnPckg() パッケージ番号供給元一覧を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getQuantity() +/- 記号あり/なし数量を取得します。
String | getService() 活動番号を取得します。
String | getServType() サービスタイプのテキスト (短)を取得します。
String | getShortText() テキスト(短)を取得します。
String | getSscItem() 標準サービスカタログ: 明細を取得します。
String | getSscLim() 標準サービスカタログ制限参照のサービス行を取得します。
String | getSubpckgNo() サブパッケージ番号を取得します。
String | getSuppLine() 補足明細を取得します。
String | getTargetVal() 目標値を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTmpLine() 入力: モデル仕様からの計画外サービスを取得します。
String | getTmpPckg() 入力: モデル仕様からの計画外サービスを取得します。
String | getToLine() 上限を取得します。
String | getUomIso() 単位の ISO コードを取得します。
String | getUserf1Num() ユーザ定義項目を取得します。
String | getUserf1Txt() ユーザ定義項目を取得します。
String | getUserf2Num() ユーザ定義項目を取得します。
String | getUserf2Txt() ユーザ定義項目を取得します。
String | getWagetype() ウェイジタイプを取得します。
void | setAlternat(String strAlternat) 代替明細を設定します。
void | setBaseUom(String strBaseUom) 基本数量単位を設定します。
void | setBasicLine(String strBasicLine) 基本明細を設定します。
void | setBaslineNo(String strBaslineNo) 代替: 基本明細参照を設定します。
void | setBegintime(String strBegintime) 開始時刻を設定します。
void | setBidder(String strBidder) 入札者の明細を設定します。
void | setBlanket(String strBlanket) 包括明細を設定します。
void | setConLine(String strConLine) 入力: 基本契約の計画外を設定します。
void | setConPckg(String strConPckg) 入力: 基本契約の計画外を設定します。
void | setCsIndex(int csIndex) レコード番号を設定します｡
void | setDate(String strDate) 日付を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します。
void | setDistrib(String strDistrib) 複数勘定設定の配賦区分を設定します。
void | setEdition(String strEdition) サービスタイプのバージョンを設定します。
void | setEndtime(String strEndtime) 終了時刻を設定します。
void | setEventual(String strEventual) 偶発的明細を設定します。
void | setExtLine(String strExtLine) 明細番号を設定します。
void | setExtpersNo(String strExtpersNo) 外部従業員番号を設定します。
void | setExtrefkey(String strExtrefkey) サービスの外部参照キーを設定します。
void | setExtServ(String strExtServ) 仕入先のサービス番号を設定します。
void | setFormula(String strFormula) 計算式番号を設定します。
void | setFormVal1(String strFormVal1) 計算式値を設定します。
void | setFormVal2(String strFormVal2) 計算式値を設定します。
void | setFormVal3(String strFormVal3) 計算式値を設定します。
void | setFormVal4(String strFormVal4) 計算式値を設定します。
void | setFormVal5(String strFormVal5) 計算式値を設定します。
void | setFromLine(String strFromLine) 下限を設定します。
void | setGrPrice(String strGrPrice) 基準額を設定します。
void | setHiLineNo(String strHiLineNo) 上位階層明細番号を設定します。
void | setInform(String strInform) 情報行を設定します。
void | setLimitLine(String strLimitLine) 入力: 計画外、明細制限を設定します。
void | setLineNo(String strLineNo) 内部明細番号を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setOpenQty(String strOpenQty) 未処理数量のある明細を設定します。
void | setOutlInd(String strOutlInd) 区分: 出力行を設定します。
void | setOutlLevel(String strOutlLevel) グループの階層レベルを設定します。
void | setOutlNo(String strOutlNo) アウトラインレベルを設定します。
void | setOvfTol(String strOvfTol) 超過許容値を設定します。
void | setOvfUnlim(String strOvfUnlim) 契約外サービス制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPersNo(String strPersNo) 従業員番号を設定します。
void | setPlnLine(String strPlnLine) 入力: 計画梱包明細行を設定します。
void | setPlnPckg(String strPlnPckg) パッケージ番号供給元一覧を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setQuantity(String strQuantity) +/- 記号あり/なし数量を設定します。
void | setService(String strService) 活動番号を設定します。
void | setServType(String strServType) サービスタイプのテキスト (短)を設定します。
void | setShortText(String strShortText) テキスト(短)を設定します。
void | setSscItem(String strSscItem) 標準サービスカタログ: 明細を設定します。
void | setSscLim(String strSscLim) 標準サービスカタログ制限参照のサービス行を設定します。
void | setSubpckgNo(String strSubpckgNo) サブパッケージ番号を設定します。
void | setSuppLine(String strSuppLine) 補足明細を設定します。
void | setTargetVal(String strTargetVal) 目標値を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTmpLine(String strTmpLine) 入力: モデル仕様からの計画外サービスを設定します。
void | setTmpPckg(String strTmpPckg) 入力: モデル仕様からの計画外サービスを設定します。
void | setToLine(String strToLine) 上限を設定します。
void | setUomIso(String strUomIso) 単位の ISO コードを設定します。
void | setUserf1Num(String strUserf1Num) ユーザ定義項目を設定します。
void | setUserf1Txt(String strUserf1Txt) ユーザ定義項目を設定します。
void | setUserf2Num(String strUserf2Num) ユーザ定義項目を設定します。
void | setUserf2Txt(String strUserf2Txt) ユーザ定義項目を設定します。
void | setWagetype(String strWagetype) ウェイジタイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractService

public ContractService()
外注サービスを作成します。

ContractService

public ContractService(int index)
外注サービスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
内部明細番号を取得します。

戻り値:
srtLineNo 内部明細番号

getExtLine

public String getExtLine()
明細番号を取得します。

戻り値:
srtExtLine 明細番号

getOutlLevel

public String getOutlLevel()
グループの階層レベルを取得します。

戻り値:
srtOutlLevel グループの階層レベル

getOutlNo

public String getOutlNo()
アウトラインレベルを取得します。

戻り値:
srtOutlNo アウトラインレベル

getOutlInd

public String getOutlInd()
区分: 出力行を取得します。

戻り値:
srtOutlInd 区分: 出力行

getSubpckgNo

public String getSubpckgNo()
サブパッケージ番号を取得します。

戻り値:
srtSubpckgNo サブパッケージ番号

getService

public String getService()
活動番号を取得します。

戻り値:
srtService 活動番号

getServType

public String getServType()
サービスタイプのテキスト (短)を取得します。

戻り値:
srtServType サービスタイプのテキスト (短)

getEdition

public String getEdition()
サービスタイプのバージョンを取得します。

戻り値:
srtEdition サービスタイプのバージョン

getSscItem

public String getSscItem()
標準サービスカタログ: 明細を取得します。

戻り値:
srtSscItem 標準サービスカタログ: 明細

getExtServ

public String getExtServ()
仕入先のサービス番号を取得します。

戻り値:
srtExtServ 仕入先のサービス番号

getQuantity

public String getQuantity()
+/- 記号あり/なし数量を取得します。

戻り値:
srtQuantity +/- 記号あり/なし数量

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
srtBaseUom 基本数量単位

getUomIso

public String getUomIso()
単位の ISO コードを取得します。

戻り値:
srtUomIso 単位の ISO コード

getOvfTol

public String getOvfTol()
超過許容値を取得します。

戻り値:
srtOvfTol 超過許容値

getOvfUnlim

public String getOvfUnlim()
契約外サービス制限なしを取得します。

戻り値:
srtOvfUnlim 契約外サービス制限なし

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
srtPriceUnit 価格単位

getGrPrice

public String getGrPrice()
基準額を取得します。

戻り値:
srtGrPrice 基準額

getFromLine

public String getFromLine()
下限を取得します。

戻り値:
srtFromLine 下限

getToLine

public String getToLine()
上限を取得します。

戻り値:
srtToLine 上限

getShortText

public String getShortText()
テキスト(短)を取得します。

戻り値:
srtShortText テキスト(短)

getDistrib

public String getDistrib()
複数勘定設定の配賦区分を取得します。

戻り値:
srtDistrib 複数勘定設定の配賦区分

getPersNo

public String getPersNo()
従業員番号を取得します。

戻り値:
srtPersNo 従業員番号

getWagetype

public String getWagetype()
ウェイジタイプを取得します。

戻り値:
srtWagetype ウェイジタイプ

getPlnPckg

public String getPlnPckg()
パッケージ番号供給元一覧を取得します。

戻り値:
srtPlnPckg パッケージ番号供給元一覧

getPlnLine

public String getPlnLine()
入力: 計画梱包明細行を取得します。

戻り値:
srtPlnLine 入力: 計画梱包明細行

getConPckg

public String getConPckg()
入力: 基本契約の計画外を取得します。

戻り値:
srtConPckg 入力: 基本契約の計画外

getConLine

public String getConLine()
入力: 基本契約の計画外を取得します。

戻り値:
srtConLine 入力: 基本契約の計画外

getTmpPckg

public String getTmpPckg()
入力: モデル仕様からの計画外サービスを取得します。

戻り値:
srtTmpPckg 入力: モデル仕様からの計画外サービス

getTmpLine

public String getTmpLine()
入力: モデル仕様からの計画外サービスを取得します。

戻り値:
srtTmpLine 入力: モデル仕様からの計画外サービス

getSscLim

public String getSscLim()
標準サービスカタログ制限参照のサービス行を取得します。

戻り値:
srtSscLim 標準サービスカタログ制限参照のサービス行

getLimitLine

public String getLimitLine()
入力: 計画外、明細制限を取得します。

戻り値:
srtLimitLine 入力: 計画外、明細制限

getTargetVal

public String getTargetVal()
目標値を取得します。

戻り値:
srtTargetVal 目標値

getBaslineNo

public String getBaslineNo()
代替: 基本明細参照を取得します。

戻り値:
srtBaslineNo 代替: 基本明細参照

getBasicLine

public String getBasicLine()
基本明細を取得します。

戻り値:
srtBasicLine 基本明細

getAlternat

public String getAlternat()
代替明細を取得します。

戻り値:
srtAlternat 代替明細

getBidder

public String getBidder()
入札者の明細を取得します。

戻り値:
srtBidder 入札者の明細

getSuppLine

public String getSuppLine()
補足明細を取得します。

戻り値:
srtSuppLine 補足明細

getOpenQty

public String getOpenQty()
未処理数量のある明細を取得します。

戻り値:
srtOpenQty 未処理数量のある明細

getInform

public String getInform()
情報行を取得します。

戻り値:
srtInform 情報行

getBlanket

public String getBlanket()
包括明細を取得します。

戻り値:
srtBlanket 包括明細

getEventual

public String getEventual()
偶発的明細を取得します。

戻り値:
srtEventual 偶発的明細

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
srtTaxCode 消費税コード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getDate

public String getDate()
日付を取得します。

戻り値:
srtDate 日付

getBegintime

public String getBegintime()
開始時刻を取得します。

戻り値:
srtBegintime 開始時刻

getEndtime

public String getEndtime()
終了時刻を取得します。

戻り値:
srtEndtime 終了時刻

getExtpersNo

public String getExtpersNo()
外部従業員番号を取得します。

戻り値:
srtExtpersNo 外部従業員番号

getFormula

public String getFormula()
計算式番号を取得します。

戻り値:
srtFormula 計算式番号

getFormVal1

public String getFormVal1()
計算式値を取得します。

戻り値:
srtFormVal1 計算式値

getFormVal2

public String getFormVal2()
計算式値を取得します。

戻り値:
srtFormVal2 計算式値

getFormVal3

public String getFormVal3()
計算式値を取得します。

戻り値:
srtFormVal3 計算式値

getFormVal4

public String getFormVal4()
計算式値を取得します。

戻り値:
srtFormVal4 計算式値

getFormVal5

public String getFormVal5()
計算式値を取得します。

戻り値:
srtFormVal5 計算式値

getUserf1Num

public String getUserf1Num()
ユーザ定義項目を取得します。

戻り値:
srtUserf1Num ユーザ定義項目

getUserf2Num

public String getUserf2Num()
ユーザ定義項目を取得します。

戻り値:
srtUserf2Num ユーザ定義項目

getUserf1Txt

public String getUserf1Txt()
ユーザ定義項目を取得します。

戻り値:
srtUserf1Txt ユーザ定義項目

getUserf2Txt

public String getUserf2Txt()
ユーザ定義項目を取得します。

戻り値:
srtUserf2Txt ユーザ定義項目

getHiLineNo

public String getHiLineNo()
上位階層明細番号を取得します。

戻り値:
srtHiLineNo 上位階層明細番号

getExtrefkey

public String getExtrefkey()
サービスの外部参照キーを取得します。

戻り値:
srtExtrefkey サービスの外部参照キー

getDeleteInd

public String getDeleteInd()
削除フラグを取得します。

戻り値:
srtDeleteInd 削除フラグ

getCsIndex

public int getCsIndex()
レコード番号を取得します｡

戻り値:
csIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
内部明細番号を設定します。

パラメータ:
strLineNo - 内部明細番号

setExtLine

public void setExtLine(String strExtLine)
明細番号を設定します。

パラメータ:
strExtLine - 明細番号

setOutlLevel

public void setOutlLevel(String strOutlLevel)
グループの階層レベルを設定します。

パラメータ:
strOutlLevel - グループの階層レベル

setOutlNo

public void setOutlNo(String strOutlNo)
アウトラインレベルを設定します。

パラメータ:
strOutlNo - アウトラインレベル

setOutlInd

public void setOutlInd(String strOutlInd)
区分: 出力行を設定します。

パラメータ:
strOutlInd - 区分: 出力行

setSubpckgNo

public void setSubpckgNo(String strSubpckgNo)
サブパッケージ番号を設定します。

パラメータ:
strSubpckgNo - サブパッケージ番号

setService

public void setService(String strService)
活動番号を設定します。

パラメータ:
strService - 活動番号

setServType

public void setServType(String strServType)
サービスタイプのテキスト (短)を設定します。

パラメータ:
strServType - サービスタイプのテキスト (短)

setEdition

public void setEdition(String strEdition)
サービスタイプのバージョンを設定します。

パラメータ:
strEdition - サービスタイプのバージョン

setSscItem

public void setSscItem(String strSscItem)
標準サービスカタログ: 明細を設定します。

パラメータ:
strSscItem - 標準サービスカタログ: 明細

setExtServ

public void setExtServ(String strExtServ)
仕入先のサービス番号を設定します。

パラメータ:
strExtServ - 仕入先のサービス番号

setQuantity

public void setQuantity(String strQuantity)
+/- 記号あり/なし数量を設定します。

パラメータ:
strQuantity - +/- 記号あり/なし数量

setBaseUom

public void setBaseUom(String strBaseUom)
基本数量単位を設定します。

パラメータ:
strBaseUom - 基本数量単位

setUomIso

public void setUomIso(String strUomIso)
単位の ISO コードを設定します。

パラメータ:
strUomIso - 単位の ISO コード

setOvfTol

public void setOvfTol(String strOvfTol)
超過許容値を設定します。

パラメータ:
strOvfTol - 超過許容値

setOvfUnlim

public void setOvfUnlim(String strOvfUnlim)
契約外サービス制限なしを設定します。

パラメータ:
strOvfUnlim - 契約外サービス制限なし

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setGrPrice

public void setGrPrice(String strGrPrice)
基準額を設定します。

パラメータ:
strGrPrice - 基準額

setFromLine

public void setFromLine(String strFromLine)
下限を設定します。

パラメータ:
strFromLine - 下限

setToLine

public void setToLine(String strToLine)
上限を設定します。

パラメータ:
strToLine - 上限

setShortText

public void setShortText(String strShortText)
テキスト(短)を設定します。

パラメータ:
strShortText - テキスト(短)

setDistrib

public void setDistrib(String strDistrib)
複数勘定設定の配賦区分を設定します。

パラメータ:
strDistrib - 複数勘定設定の配賦区分

setPersNo

public void setPersNo(String strPersNo)
従業員番号を設定します。

パラメータ:
strPersNo - 従業員番号

setWagetype

public void setWagetype(String strWagetype)
ウェイジタイプを設定します。

パラメータ:
strWagetype - ウェイジタイプ

setPlnPckg

public void setPlnPckg(String strPlnPckg)
パッケージ番号供給元一覧を設定します。

パラメータ:
strPlnPckg - パッケージ番号供給元一覧

setPlnLine

public void setPlnLine(String strPlnLine)
入力: 計画梱包明細行を設定します。

パラメータ:
strPlnLine - 入力: 計画梱包明細行

setConPckg

public void setConPckg(String strConPckg)
入力: 基本契約の計画外を設定します。

パラメータ:
strConPckg - 入力: 基本契約の計画外

setConLine

public void setConLine(String strConLine)
入力: 基本契約の計画外を設定します。

パラメータ:
strConLine - 入力: 基本契約の計画外

setTmpPckg

public void setTmpPckg(String strTmpPckg)
入力: モデル仕様からの計画外サービスを設定します。

パラメータ:
strTmpPckg - 入力: モデル仕様からの計画外サービス

setTmpLine

public void setTmpLine(String strTmpLine)
入力: モデル仕様からの計画外サービスを設定します。

パラメータ:
strTmpLine - 入力: モデル仕様からの計画外サービス

setSscLim

public void setSscLim(String strSscLim)
標準サービスカタログ制限参照のサービス行を設定します。

パラメータ:
strSscLim - 標準サービスカタログ制限参照のサービス行

setLimitLine

public void setLimitLine(String strLimitLine)
入力: 計画外、明細制限を設定します。

パラメータ:
strLimitLine - 入力: 計画外、明細制限

setTargetVal

public void setTargetVal(String strTargetVal)
目標値を設定します。

パラメータ:
strTargetVal - 目標値

setBaslineNo

public void setBaslineNo(String strBaslineNo)
代替: 基本明細参照を設定します。

パラメータ:
strBaslineNo - 代替: 基本明細参照

setBasicLine

public void setBasicLine(String strBasicLine)
基本明細を設定します。

パラメータ:
strBasicLine - 基本明細

setAlternat

public void setAlternat(String strAlternat)
代替明細を設定します。

パラメータ:
strAlternat - 代替明細

setBidder

public void setBidder(String strBidder)
入札者の明細を設定します。

パラメータ:
strBidder - 入札者の明細

setSuppLine

public void setSuppLine(String strSuppLine)
補足明細を設定します。

パラメータ:
strSuppLine - 補足明細

setOpenQty

public void setOpenQty(String strOpenQty)
未処理数量のある明細を設定します。

パラメータ:
strOpenQty - 未処理数量のある明細

setInform

public void setInform(String strInform)
情報行を設定します。

パラメータ:
strInform - 情報行

setBlanket

public void setBlanket(String strBlanket)
包括明細を設定します。

パラメータ:
strBlanket - 包括明細

setEventual

public void setEventual(String strEventual)
偶発的明細を設定します。

パラメータ:
strEventual - 偶発的明細

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setDate

public void setDate(String strDate)
日付を設定します。

パラメータ:
strDate - 日付

setBegintime

public void setBegintime(String strBegintime)
開始時刻を設定します。

パラメータ:
strBegintime - 開始時刻

setEndtime

public void setEndtime(String strEndtime)
終了時刻を設定します。

パラメータ:
strEndtime - 終了時刻

setExtpersNo

public void setExtpersNo(String strExtpersNo)
外部従業員番号を設定します。

パラメータ:
strExtpersNo - 外部従業員番号

setFormula

public void setFormula(String strFormula)
計算式番号を設定します。

パラメータ:
strFormula - 計算式番号

setFormVal1

public void setFormVal1(String strFormVal1)
計算式値を設定します。

パラメータ:
strFormVal1 - 計算式値

setFormVal2

public void setFormVal2(String strFormVal2)
計算式値を設定します。

パラメータ:
strFormVal2 - 計算式値

setFormVal3

public void setFormVal3(String strFormVal3)
計算式値を設定します。

パラメータ:
strFormVal3 - 計算式値

setFormVal4

public void setFormVal4(String strFormVal4)
計算式値を設定します。

パラメータ:
strFormVal4 - 計算式値

setFormVal5

public void setFormVal5(String strFormVal5)
計算式値を設定します。

パラメータ:
strFormVal5 - 計算式値

setUserf1Num

public void setUserf1Num(String strUserf1Num)
ユーザ定義項目を設定します。

パラメータ:
strUserf1Num - ユーザ定義項目

setUserf2Num

public void setUserf2Num(String strUserf2Num)
ユーザ定義項目を設定します。

パラメータ:
strUserf2Num - ユーザ定義項目

setUserf1Txt

public void setUserf1Txt(String strUserf1Txt)
ユーザ定義項目を設定します。

パラメータ:
strUserf1Txt - ユーザ定義項目

setUserf2Txt

public void setUserf2Txt(String strUserf2Txt)
ユーザ定義項目を設定します。

パラメータ:
strUserf2Txt - ユーザ定義項目

setHiLineNo

public void setHiLineNo(String strHiLineNo)
上位階層明細番号を設定します。

パラメータ:
strHiLineNo - 上位階層明細番号

setExtrefkey

public void setExtrefkey(String strExtrefkey)
サービスの外部参照キーを設定します。

パラメータ:
strExtrefkey - サービスの外部参照キー

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します。

パラメータ:
strDeleteInd - 削除フラグ

setCsIndex

public void setCsIndex(int csIndex)
レコード番号を設定します｡

パラメータ:
csIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractServiceAccount (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractServiceAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount
すべての実装インタフェース:
Serializable
public class ContractServiceAccount
extends Object
implements Serializable

外注サービス勘定設定情報クラス
機能は以下の通り

  • 外注サービス勘定設定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractServiceAccount()
外注サービス勘定設定を作成します。
ContractServiceAccount(int index)
外注サービス勘定設定を作成します。
メソッドの概要
String | getLineNo() 明細行番号を取得します。
String | getNetValue() 明細の正味額を取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPercentage() 勘定設定金額配賦のパーセントを取得します。
String | getQuantity() +/- 記号あり/なし数量を取得します。
int | getSaIndex() レコード番号を取得します｡
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getSernoLine() 勘定コード設定のシリアル番号、サービス明細を取得します。
void | setLineNo(String strLineNo) 明細行番号を設定します。
void | setNetValue(String strNetValue) 明細の正味額を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPercentage(String strPercentage) 勘定設定金額配賦のパーセントを設定します。
void | setQuantity(String strQuantity) +/- 記号あり/なし数量を設定します。
void | setSaIndex(int saIndex) レコード番号を設定します｡
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setSernoLine(String strSernoLine) 勘定コード設定のシリアル番号、サービス明細を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractServiceAccount

public ContractServiceAccount()
外注サービス勘定設定を作成します。

ContractServiceAccount

public ContractServiceAccount(int index)
外注サービス勘定設定を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
明細行番号を取得します。

戻り値:
srtLineNo 明細行番号

getSernoLine

public String getSernoLine()
勘定コード設定のシリアル番号、サービス明細を取得します。

戻り値:
srtSernoLine 勘定コード設定のシリアル番号、サービス明細

getPercentage

public String getPercentage()
勘定設定金額配賦のパーセントを取得します。

戻り値:
srtPercentage 勘定設定金額配賦のパーセント

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getQuantity

public String getQuantity()
+/- 記号あり/なし数量を取得します。

戻り値:
srtQuantity +/- 記号あり/なし数量

getNetValue

public String getNetValue()
明細の正味額を取得します。

戻り値:
srtNetValue 明細の正味額

getSaIndex

public int getSaIndex()
レコード番号を取得します｡

戻り値:
saIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
明細行番号を設定します。

パラメータ:
strLineNo - 明細行番号

setSernoLine

public void setSernoLine(String strSernoLine)
勘定コード設定のシリアル番号、サービス明細を設定します。

パラメータ:
strSernoLine - 勘定コード設定のシリアル番号、サービス明細

setPercentage

public void setPercentage(String strPercentage)
勘定設定金額配賦のパーセントを設定します。

パラメータ:
strPercentage - 勘定設定金額配賦のパーセント

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setQuantity

public void setQuantity(String strQuantity)
+/- 記号あり/なし数量を設定します。

パラメータ:
strQuantity - +/- 記号あり/なし数量

setNetValue

public void setNetValue(String strNetValue)
明細の正味額を設定します。

パラメータ:
strNetValue - 明細の正味額

setSaIndex

public void setSaIndex(int saIndex)
レコード番号を設定します｡

パラメータ:
saIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContractServiceText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ContractServiceText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
すべての実装インタフェース:
Serializable
public class ContractServiceText
extends PurchaseText

外注サービステキスト情報クラス
機能は以下の通り

  • 外注サービステキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ContractServiceText()
外注サービステキストを作成します。
ContractServiceText(int index)
外注サービステキストを作成します。
メソッドの概要
String | getFormatCol() タグ列を取得します。
String | getLineNo() 内部明細番号を取得します。
String | getPckgNo() パッケージ番号を取得します。
void | setFormatCol(String strFormatCol) タグ列を設定します。
void | setLineNo(String strLineNo) 内部明細番号を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText から継承したメソッド
getPoItem, getPoNumber, getTeIndex, getTextForm, getTextId, getTextLine, setPoItem, setPoNumber, setTeIndex, setTextForm, setTextId, setTextLine
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ContractServiceText

public ContractServiceText()
外注サービステキストを作成します。

ContractServiceText

public ContractServiceText(int index)
外注サービステキストを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLineNo

public String getLineNo()
内部明細番号を取得します。

戻り値:
srtLineNo 内部明細番号

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
srtFormatCol タグ列

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLineNo

public void setLineNo(String strLineNo)
内部明細番号を設定します。

パラメータ:
strLineNo - 内部明細番号

setFormatCol

public void setFormatCol(String strFormatCol)
タグ列を設定します。

パラメータ:
strFormatCol - タグ列

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseText 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DeliveryAddress (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス DeliveryAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress
すべての実装インタフェース:
Serializable
public class DeliveryAddress
extends Object
implements Serializable

入荷伝票アドレス情報クラス
機能は以下の通り

  • 入荷伝票アドレス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DeliveryAddress()
入荷伝票アドレスを作成します。
DeliveryAddress(int index)
入荷伝票アドレスを作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCity() 市区町村を取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
int | getDeIndex() レコード番号を取得します｡
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getDistrict() 所在地を取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getFormofaddr() 敬称テキストを取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getLocation() 地名 5を取得します。
String | getName_2() 名称 2を取得します。
String | getName_3() 名称 3を取得します。
String | getName_4() 名称 4を取得します。
String | getName() 名称 1を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPoBox() 私書箱を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreet() 地名を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String strAddrNo) アドレス番号を設定します。
void | setAdrNotes(String strAdrNotes) 住所注記を設定します。
void | setBuilding(String strBuilding) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String strBuildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String strChckstatus) 市区町村ファイルテストステータスを設定します。
void | setCity(String strCity) 市区町村を設定します。
void | setCityNo(String strCityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String strCommType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String strCOName) 気付を設定します。
void | setCountry(String strCountry) 国コードを設定します。
void | setCountryiso(String strCountryiso) ISO 国コードを設定します。
void | setDeIndex(int deIndex) レコード番号を設定します｡
void | setDelivDis(String strDelivDis) 郵便配達地域を設定します。
void | setDistrctNo(String strDistrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setDistrict(String strDistrict) 所在地を設定します。
void | setEMail(String strEMail) 電子メールアドレスを設定します。
void | setFaxExtens(String strFaxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String strFaxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String strFloor) 建物の階を設定します。
void | setFormofaddr(String strFormofaddr) 敬称テキストを設定します。
void | setHouseNo(String strHouseNo) 番地-号を設定します。
void | setHouseNo2(String strHouseNo2) 番地補足を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) ISO 639 準拠の言語を設定します。
void | setLocation(String strLocation) 地名 5を設定します。
void | setName_2(String strName2) 名称 2を設定します。
void | setName_3(String strName3) 名称 3を設定します。
void | setName_4(String strName4) 名称 4を設定します。
void | setName(String strName) 名称 1を設定します。
void | setPboxcitNo(String strPboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPoBox(String strPoBox) 私書箱を設定します。
void | setPoBoxCit(String strPoBoxCit) 私書箱住所を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPostlCod1(String strPostlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String strPostlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String strPostlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setRegiogroup(String strRegiogroup) 地域構造グループ化を設定します。
void | setRegion(String strRegion) 地域 (都道府県)を設定します。
void | setRoomNo(String strRoomNo) 部屋/アパート番号を設定します。
void | setSort1(String strSort1) 検索条件 1を設定します。
void | setSort2(String strSort2) 検索条件 2を設定します。
void | setStrAbbr(String strStrAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreet(String strStreet) 地名を設定します。
void | setStreetLng(String strStreetLng) 地名を設定します。
void | setStreetNo(String strStreetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strStrSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strStrSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strStrSuppl3) 地名 4を設定します。
void | setTaxjurcode(String strTaxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String strTel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String strTel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String strTimeZone) アドレスタイムゾーンを設定します。
void | setTitle(String strTitle) タイトル (敬称)を設定します。
void | setTranspzone(String strTranspzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DeliveryAddress

public DeliveryAddress()
入荷伝票アドレスを作成します。

DeliveryAddress

public DeliveryAddress(int index)
入荷伝票アドレスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
srtAddrNo アドレス番号

getFormofaddr

public String getFormofaddr()
敬称テキストを取得します。

戻り値:
srtFormofaddr 敬称テキスト

getName

public String getName()
名称 1を取得します。

戻り値:
srtName 名称 1

getName_2

public String getName_2()
名称 2を取得します。

戻り値:
srtName2 名称 2

getName_3

public String getName_3()
名称 3を取得します。

戻り値:
srtName3 名称 3

getName_4

public String getName_4()
名称 4を取得します。

戻り値:
srtName4 名称 4

getCOName

public String getCOName()
気付を取得します。

戻り値:
srtCOName 気付

getCity

public String getCity()
市区町村を取得します。

戻り値:
srtCity 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
srtDistrict 所在地

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
srtCityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
srtPostlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
srtPostlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
srtPostlCod3 会社郵便番号 (大規模なユーザ用)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
srtPoBox 私書箱

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
srtPoBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
srtDelivDis 郵便配達地域

getStreet

public String getStreet()
地名を取得します。

戻り値:
srtStreet 地名

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
srtStreetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
srtStrAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
srtHouseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
srtStrSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
srtStrSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
srtLocation 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
srtBuilding 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
srtFloor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
srtRoomNo 部屋/アパート番号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
srtCountry 国コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
srtRegion 地域 (都道府県)

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
srtSort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
srtSort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
srtTimeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
srtTaxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
srtAdrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
srtCommType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
srtTel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
srtTel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
srtFaxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
srtFaxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
srtStreetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
srtDistrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
srtChckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
srtPboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
srtTranspzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
srtHouseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
srtEMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
srtStrSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
srtTitle タイトル (敬称)

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
srtCountryiso ISO 国コード

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
srtLanguIso ISO 639 準拠の言語

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
srtBuildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
srtRegiogroup 地域構造グループ化

getDeIndex

public int getDeIndex()
レコード番号を取得します｡

戻り値:
deIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setAddrNo

public void setAddrNo(String strAddrNo)
アドレス番号を設定します。

パラメータ:
strAddrNo - アドレス番号

setFormofaddr

public void setFormofaddr(String strFormofaddr)
敬称テキストを設定します。

パラメータ:
strFormofaddr - 敬称テキスト

setName

public void setName(String strName)
名称 1を設定します。

パラメータ:
strName - 名称 1

setName_2

public void setName_2(String strName2)
名称 2を設定します。

パラメータ:
strName2 - 名称 2

setName_3

public void setName_3(String strName3)
名称 3を設定します。

パラメータ:
strName3 - 名称 3

setName_4

public void setName_4(String strName4)
名称 4を設定します。

パラメータ:
strName4 - 名称 4

setCOName

public void setCOName(String strCOName)
気付を設定します。

パラメータ:
strCOName - 気付

setCity

public void setCity(String strCity)
市区町村を設定します。

パラメータ:
strCity - 市区町村

setDistrict

public void setDistrict(String strDistrict)
所在地を設定します。

パラメータ:
strDistrict - 所在地

setCityNo

public void setCityNo(String strCityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
strCityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String strPostlCod1)
市区町村の郵便番号を設定します。

パラメータ:
strPostlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String strPostlCod2)
私書箱郵便番号を設定します。

パラメータ:
strPostlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String strPostlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
strPostlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBox

public void setPoBox(String strPoBox)
私書箱を設定します。

パラメータ:
strPoBox - 私書箱

setPoBoxCit

public void setPoBoxCit(String strPoBoxCit)
私書箱住所を設定します。

パラメータ:
strPoBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String strDelivDis)
郵便配達地域を設定します。

パラメータ:
strDelivDis - 郵便配達地域

setStreet

public void setStreet(String strStreet)
地名を設定します。

パラメータ:
strStreet - 地名

setStreetNo

public void setStreetNo(String strStreetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
strStreetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strStrAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strStrAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String strHouseNo)
番地-号を設定します。

パラメータ:
strHouseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strStrSuppl1)
地名 2を設定します。

パラメータ:
strStrSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strStrSuppl2)
地名 3を設定します。

パラメータ:
strStrSuppl2 - 地名 3

setLocation

public void setLocation(String strLocation)
地名 5を設定します。

パラメータ:
strLocation - 地名 5

setBuilding

public void setBuilding(String strBuilding)
旧: 建物 (番号または略称)を設定します。

パラメータ:
strBuilding - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String strFloor)
建物の階を設定します。

パラメータ:
strFloor - 建物の階

setRoomNo

public void setRoomNo(String strRoomNo)
部屋/アパート番号を設定します。

パラメータ:
strRoomNo - 部屋/アパート番号

setCountry

public void setCountry(String strCountry)
国コードを設定します。

パラメータ:
strCountry - 国コード

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setRegion

public void setRegion(String strRegion)
地域 (都道府県)を設定します。

パラメータ:
strRegion - 地域 (都道府県)

setSort1

public void setSort1(String strSort1)
検索条件 1を設定します。

パラメータ:
strSort1 - 検索条件 1

setSort2

public void setSort2(String strSort2)
検索条件 2を設定します。

パラメータ:
strSort2 - 検索条件 2

setTimeZone

public void setTimeZone(String strTimeZone)
アドレスタイムゾーンを設定します。

パラメータ:
strTimeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String strAdrNotes)
住所注記を設定します。

パラメータ:
strAdrNotes - 住所注記

setCommType

public void setCommType(String strCommType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
strCommType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String strTel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
strTel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String strTel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
strTel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String strFaxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
strFaxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String strFaxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
strFaxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String strStreetLng)
地名を設定します。

パラメータ:
strStreetLng - 地名

setDistrctNo

public void setDistrctNo(String strDistrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
strDistrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String strChckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
strChckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String strPboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
strPboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String strTranspzone)
商品の納入区域を設定します。

パラメータ:
strTranspzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String strHouseNo2)
番地補足を設定します。

パラメータ:
strHouseNo2 - 番地補足

setEMail

public void setEMail(String strEMail)
電子メールアドレスを設定します。

パラメータ:
strEMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strStrSuppl3)
地名 4を設定します。

パラメータ:
strStrSuppl3 - 地名 4

setTitle

public void setTitle(String strTitle)
タイトル (敬称)を設定します。

パラメータ:
strTitle - タイトル (敬称)

setCountryiso

public void setCountryiso(String strCountryiso)
ISO 国コードを設定します。

パラメータ:
strCountryiso - ISO 国コード

setLanguIso

public void setLanguIso(String strLanguIso)
ISO 639 準拠の言語を設定します。

パラメータ:
strLanguIso - ISO 639 準拠の言語

setBuildLong

public void setBuildLong(String strBuildLong)
建物 (番号またはコード)を設定します。

パラメータ:
strBuildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String strRegiogroup)
地域構造グループ化を設定します。

パラメータ:
strRegiogroup - 地域構造グループ化

setDeIndex

public void setDeIndex(int deIndex)
レコード番号を設定します｡

パラメータ:
deIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DistributionChannelSelection (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス DistributionChannelSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection
すべての実装インタフェース:
Serializable
public class DistributionChannelSelection
extends Selection
implements Serializable

流通チャネルの選択オプションクラス
機能は以下の通り

  • 流通チャネルの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
DistributionChannelSelection()
流通チャネルの選択オプション情報を作成します。
DistributionChannelSelection(int index)
流通チャネルの選択オプション情報を作成します。
メソッドの概要
String | getDistrChanHigh() 流通チャネルの範囲終了を取得します。
String | getDistrChanLow() 流通チャネルの範囲開始を取得します。
int | getIndex() レコード番号を取得します。
void | setDistrChanHigh(String strDistrChanHigh) 流通チャネルの範囲終了を設定します。
void | setDistrChanLow(String strDistrChanLow) 流通チャネルの範囲開始を設定します。
void | setIndex(int index) レコード番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

DistributionChannelSelection

public DistributionChannelSelection()
流通チャネルの選択オプション情報を作成します。

DistributionChannelSelection

public DistributionChannelSelection(int index)
流通チャネルの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDistrChanLow

public String getDistrChanLow()
流通チャネルの範囲開始を取得します。

戻り値:
srtDistrChanLow

getDistrChanHigh

public String getDistrChanHigh()
流通チャネルの範囲終了を取得します。

戻り値:
srtDistrChanHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index

setDistrChanLow

public void setDistrChanLow(String strDistrChanLow)
流通チャネルの範囲開始を設定します。

パラメータ:
strDistrChanLow - 流通チャネルの範囲開始

setDistrChanHigh

public void setDistrChanHigh(String strDistrChanHigh)
流通チャネルの範囲終了を設定します。

パラメータ:
strDistrChanHigh - 流通チャネルの範囲終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExportHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ExportHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader
すべての実装インタフェース:
Serializable
public class ExportHeader
extends Object
implements Serializable

貿易管理ヘッダ情報クラス
機能は以下の通り

  • 貿易管理ヘッダ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExportHeader()
貿易管理明細を作成します。
メソッドの概要
String | getCustoms() 税関: 税関 (出国時)を取得します。
String | getTransportMode() 貿易管理の輸送モードを取得します。
void | setCustoms(String strCustoms) 税関: 税関 (出国時)を設定します。
void | setTransportMode(String strTransportMode) 貿易管理の輸送モードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportHeader

public ExportHeader()
貿易管理明細を作成します。

メソッドの詳細

getTransportMode

public String getTransportMode()
貿易管理の輸送モードを取得します。

戻り値:
srtTransportMode 貿易管理の輸送モード

getCustoms

public String getCustoms()
税関: 税関 (出国時)を取得します。

戻り値:
srtCustoms 税関: 税関 (出国時)

setTransportMode

public void setTransportMode(String strTransportMode)
貿易管理の輸送モードを設定します。

パラメータ:
strTransportMode - 貿易管理の輸送モード

setCustoms

public void setCustoms(String strCustoms)
税関: 税関 (出国時)を設定します。

パラメータ:
strCustoms - 税関: 税関 (出国時)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExportItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ExportItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ExportItem
すべての実装インタフェース:
Serializable
public class ExportItem
extends Object
implements Serializable

貿易管理明細情報クラス
機能は以下の通り

  • 貿易管理明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExportItem()
貿易管理明細を作成します。
ExportItem(int index)
貿易管理明細を作成します。
メソッドの概要
String | getBusinessTransactionType() 貿易管理の取引タイプを取得します。
String | getCommCode() 貿易: 統計品目コード/輸入コード番号を取得します。
String | getCountryori() 品目の原産国を取得します。
String | getCountryoriIso() ISO 国コードを取得します。
int | getEiIndex() レコード番号を取得します｡
String | getExportImportProcedure() 貿易の輸出入手続を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getRegionorig() 品目の原産地 (非特恵対象地区の原産)を取得します。
String | getShippingCountry() 貿易: 出荷国を取得します。
String | getShippingCountryIso() ISO 国コードを取得します。
void | setBusinessTransactionType(String strBusinessTransactionType) 貿易管理の取引タイプを設定します。
void | setCommCode(String strCommCode) 貿易: 統計品目コード/輸入コード番号を設定します。
void | setCountryori(String strCountryori) 品目の原産国を設定します。
void | setCountryoriIso(String strCountryoriIso) ISO 国コードを設定します。
void | setEiIndex(int eiIndex) レコード番号を設定します｡
void | setExportImportProcedure(String strExportImportProcedure) 貿易の輸出入手続を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setRegionorig(String strRegionorig) 品目の原産地 (非特恵対象地区の原産)を設定します。
void | setShippingCountry(String strShippingCountry) 貿易: 出荷国を設定します。
void | setShippingCountryIso(String strShippingCountryIso) ISO 国コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExportItem

public ExportItem()
貿易管理明細を作成します。

ExportItem

public ExportItem(int index)
貿易管理明細を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getBusinessTransactionType

public String getBusinessTransactionType()
貿易管理の取引タイプを取得します。

戻り値:
srtBusinessTransactionType 貿易管理の取引タイプ

getExportImportProcedure

public String getExportImportProcedure()
貿易の輸出入手続を取得します。

戻り値:
srtExportImportProcedure 貿易の輸出入手続

getCountryori

public String getCountryori()
品目の原産国を取得します。

戻り値:
srtCountryori 品目の原産国

getCountryoriIso

public String getCountryoriIso()
ISO 国コードを取得します。

戻り値:
srtCountryoriIso ISO 国コード

getRegionorig

public String getRegionorig()
品目の原産地 (非特恵対象地区の原産)を取得します。

戻り値:
srtRegionorig 品目の原産地 (非特恵対象地区の原産)

getCommCode

public String getCommCode()
貿易: 統計品目コード/輸入コード番号を取得します。

戻り値:
srtCommCode 貿易: 統計品目コード/輸入コード番号

getShippingCountry

public String getShippingCountry()
貿易: 出荷国を取得します。

戻り値:
srtShippingCountry 貿易: 出荷国

getShippingCountryIso

public String getShippingCountryIso()
ISO 国コードを取得します。

戻り値:
srtShippingCountryIso ISO 国コード

getEiIndex

public int getEiIndex()
レコード番号を取得します｡

戻り値:
eiIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setBusinessTransactionType

public void setBusinessTransactionType(String strBusinessTransactionType)
貿易管理の取引タイプを設定します。

パラメータ:
strBusinessTransactionType - 貿易管理の取引タイプ

setExportImportProcedure

public void setExportImportProcedure(String strExportImportProcedure)
貿易の輸出入手続を設定します。

パラメータ:
strExportImportProcedure - 貿易の輸出入手続

setCountryori

public void setCountryori(String strCountryori)
品目の原産国を設定します。

パラメータ:
strCountryori - 品目の原産国

setCountryoriIso

public void setCountryoriIso(String strCountryoriIso)
ISO 国コードを設定します。

パラメータ:
strCountryoriIso - ISO 国コード

setRegionorig

public void setRegionorig(String strRegionorig)
品目の原産地 (非特恵対象地区の原産)を設定します。

パラメータ:
strRegionorig - 品目の原産地 (非特恵対象地区の原産)

setCommCode

public void setCommCode(String strCommCode)
貿易: 統計品目コード/輸入コード番号を設定します。

パラメータ:
strCommCode - 貿易: 統計品目コード/輸入コード番号

setShippingCountry

public void setShippingCountry(String strShippingCountry)
貿易: 出荷国を設定します。

パラメータ:
strShippingCountry - 貿易: 出荷国

setShippingCountryIso

public void setShippingCountryIso(String strShippingCountryIso)
ISO 国コードを設定します。

パラメータ:
strShippingCountryIso - ISO 国コード

setEiIndex

public void setEiIndex(int eiIndex)
レコード番号を設定します｡

パラメータ:
eiIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Extension (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Extension

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Extension
すべての実装インタフェース:
Serializable
public class Extension
extends Object
implements Serializable

拡張得意先項目情報クラス
機能は以下の通り

  • 拡張得意先項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Extension()
拡張得意先項目を作成します。
Extension(int index)
拡張得意先項目アドレスを作成します。
メソッドの概要
int | getExIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setExIndex(int exIndex) レコード番号を設定します｡
void | setStructure(String strStructure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String strValuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String strValuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String strValuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String strValuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Extension

public Extension()
拡張得意先項目を作成します。

Extension

public Extension(int index)
拡張得意先項目アドレスを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
srtStructure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
srtValuepart4 BAPI 拡張パラメータのデータ部分

getExIndex

public int getExIndex()
レコード番号を取得します｡

戻り値:
exIndex レコード番号

setStructure

public void setStructure(String strStructure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
strStructure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String strValuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String strValuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String strValuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String strValuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
strValuepart4 - BAPI 拡張パラメータのデータ部分

setExIndex

public void setExIndex(int exIndex)
レコード番号を設定します｡

パラメータ:
exIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtCreateController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス GoodsMvtCreateController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController
すべての実装インタフェース:
Serializable
public class GoodsMvtCreateController
extends GoodsMvtCreate
implements Serializable

入庫伝票登録コントローラクラス
機能は以下の通り

  • 入庫伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtCreateController()
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate から継承したメソッド
getGoodsMvtCode, getGoodsMvtHeader, getGoodsMvtHeadret, getGoodsMvtItemList, getGoodsMvtSerialNumberList, getMatdocumentyear, getMaterialdocument, getTestrun, setExportParam, setGoodsMvtCode, setGoodsMvtHeader, setGoodsMvtHeadret, setGoodsMvtItemList, setGoodsMvtSerialNumberList, setImportParam, setMatdocumentyear, setMaterialdocument, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtCreateController

public GoodsMvtCreateController()
GoodsMvtCreateControllerのコンストラクタを生成します。

GoodsMvtCreateController

public GoodsMvtCreateController(ConnectionManager connectionManager)
GoodsMvtCreateControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

GoodsMvtCreateController

public GoodsMvtCreateController(SapClient sapClient)
GoodsMvtCreateControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPPurchaseSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GoodsMvtGetItemsController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス GoodsMvtGetItemsController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController
すべての実装インタフェース:
Serializable
public class GoodsMvtGetItemsController
extends GoodsMvtGetItems
implements Serializable

入出庫伝票一覧取得コントローラクラス
機能は以下の通り

  • 入出庫伝票の一覧を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
GoodsMvtGetItemsController()
コンストラクタ生成
GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems から継承したメソッド
getBatchRaList, getGoodsMvtHeaderList, getGoodsMvtItemsList, getMaterialRaList, getMoveTypeRaList, getPlantRaList, getPstngDateRaList, getSpecStockRaList, getStgeLocRaList, getTrEvTypeRaList, getUserNameRaList, getVendorRaList, setBatchRaList, setExportParam, setGoodsMvtHeaderList, setGoodsMvtItemsList, setImportParam, setMaterialRaList, setMoveTypeRaList, setPlantRaList, setPstngDateRaList, setSpecStockRaList, setStgeLocRaList, setTrEvTypeRaList, setUserNameRaList, setVendorRaList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GoodsMvtGetItemsController

public GoodsMvtGetItemsController()
コンストラクタ生成

GoodsMvtGetItemsController

public GoodsMvtGetItemsController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Limits (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Limits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Limits
すべての実装インタフェース:
Serializable
public class Limits
extends Object
implements Serializable

外注制限情報クラス
機能は以下の通り

  • 外注制限情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Limits()
外注制限を作成します。
Limits(int index)
外注制限を作成します。
メソッドの概要
String | getConExist() 基本契約明細の制限を取得します。
String | getContPerc() 価格決定率を取得します。
String | getEdition() サービスタイプのバージョンを取得します。
String | getExpValue() 見込金額を取得します。
String | getFreeLimit() 自由制限を取得します。
int | getLiIndex() レコード番号を取得します｡
String | getLimit() 全体制限を取得します。
String | getNoFrlimit() 制限なしを取得します。
String | getNoLimit() 制限なしを取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPriceChg() 入力シートの価格変更を取得します。
String | getServType() サービスタイプのテキスト (短)を取得します。
String | getSscExist() サービスタイプの制限を取得します。
String | getSscLimit() サービスタイプの金額制限を取得します。
String | getSscNolim() 標準サービスタイプの制限なしを取得します。
String | getSscPerc() 価格決定率を取得します。
String | getSscPrschg() 入力シートの価格変更を取得します。
String | getTmpExist() サービスパッケージの制限を取得します。
String | getTmpLimit() モデルサービス明細制限を取得します。
String | getTmpNolim() モデル仕様の制限なしを取得します。
String | getTmpNumber() モデルサービス明細セット番号を取得します。
String | getTmpPerc() 価格決定率を取得します。
String | getTmpPrschg() 入力シートの価格変更を取得します。
void | setConExist(String strConExist) 基本契約明細の制限を設定します。
void | setContPerc(String strContPerc) 価格決定率を設定します。
void | setEdition(String strEdition) サービスタイプのバージョンを設定します。
void | setExpValue(String strExpValue) 見込金額を設定します。
void | setFreeLimit(String strFreeLimit) 自由制限を設定します。
void | setLiIndex(int liIndex) レコード番号を設定します｡
void | setLimit(String strLimit) 全体制限を設定します。
void | setNoFrlimit(String strNoFrlimit) 制限なしを設定します。
void | setNoLimit(String strNoLimit) 制限なしを設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPriceChg(String strPriceChg) 入力シートの価格変更を設定します。
void | setServType(String strServType) サービスタイプのテキスト (短)を設定します。
void | setSscExist(String strSscExist) サービスタイプの制限を設定します。
void | setSscLimit(String strSscLimit) サービスタイプの金額制限を設定します。
void | setSscNolim(String strSscNolim) 標準サービスタイプの制限なしを設定します。
void | setSscPerc(String strSscPerc) 価格決定率を設定します。
void | setSscPrschg(String strSscPrschg) 入力シートの価格変更を設定します。
void | setTmpExist(String strTmpExist) サービスパッケージの制限を設定します。
void | setTmpLimit(String strTmpLimit) モデルサービス明細制限を設定します。
void | setTmpNolim(String strTmpNolim) モデル仕様の制限なしを設定します。
void | setTmpNumber(String strTmpNumber) モデルサービス明細セット番号を設定します。
void | setTmpPerc(String strTmpPerc) 価格決定率を設定します。
void | setTmpPrschg(String strTmpPrschg) 入力シートの価格変更を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Limits

public Limits()
外注制限を作成します。

Limits

public Limits(int index)
外注制限を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
srtPckgNo パッケージ番号

getLimit

public String getLimit()
全体制限を取得します。

戻り値:
srtLimit 全体制限

getNoLimit

public String getNoLimit()
制限なしを取得します。

戻り値:
srtNoLimit 制限なし

getExpValue

public String getExpValue()
見込金額を取得します。

戻り値:
srtExpValue 見込金額

getSscExist

public String getSscExist()
サービスタイプの制限を取得します。

戻り値:
srtSscExist サービスタイプの制限

getConExist

public String getConExist()
基本契約明細の制限を取得します。

戻り値:
srtConExist 基本契約明細の制限

getTmpExist

public String getTmpExist()
サービスパッケージの制限を取得します。

戻り値:
srtTmpExist サービスパッケージの制限

getPriceChg

public String getPriceChg()
入力シートの価格変更を取得します。

戻り値:
srtPriceChg 入力シートの価格変更

getFreeLimit

public String getFreeLimit()
自由制限を取得します。

戻り値:
srtFreeLimit 自由制限

getNoFrlimit

public String getNoFrlimit()
制限なしを取得します。

戻り値:
srtNoFrlimit 制限なし

getServType

public String getServType()
サービスタイプのテキスト (短)を取得します。

戻り値:
srtServType サービスタイプのテキスト (短)

getEdition

public String getEdition()
サービスタイプのバージョンを取得します。

戻り値:
srtEdition サービスタイプのバージョン

getSscLimit

public String getSscLimit()
サービスタイプの金額制限を取得します。

戻り値:
srtSscLimit サービスタイプの金額制限

getSscNolim

public String getSscNolim()
標準サービスタイプの制限なしを取得します。

戻り値:
srtSscNolim 標準サービスタイプの制限なし

getSscPrschg

public String getSscPrschg()
入力シートの価格変更を取得します。

戻り値:
srtSscPrschg 入力シートの価格変更

getSscPerc

public String getSscPerc()
価格決定率を取得します。

戻り値:
srtSscPerc 価格決定率

getTmpNumber

public String getTmpNumber()
モデルサービス明細セット番号を取得します。

戻り値:
srtTmpNumber モデルサービス明細セット番号

getTmpLimit

public String getTmpLimit()
モデルサービス明細制限を取得します。

戻り値:
srtTmpLimit モデルサービス明細制限

getTmpNolim

public String getTmpNolim()
モデル仕様の制限なしを取得します。

戻り値:
srtTmpNolim モデル仕様の制限なし

getTmpPrschg

public String getTmpPrschg()
入力シートの価格変更を取得します。

戻り値:
srtTmpPrschg 入力シートの価格変更

getTmpPerc

public String getTmpPerc()
価格決定率を取得します。

戻り値:
srtTmpPerc 価格決定率

getContPerc

public String getContPerc()
価格決定率を取得します。

戻り値:
srtContPerc 価格決定率

getLiIndex

public int getLiIndex()
レコード番号を取得します｡

戻り値:
liIndex レコード番号

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setLimit

public void setLimit(String strLimit)
全体制限を設定します。

パラメータ:
strLimit - 全体制限

setNoLimit

public void setNoLimit(String strNoLimit)
制限なしを設定します。

パラメータ:
strNoLimit - 制限なし

setExpValue

public void setExpValue(String strExpValue)
見込金額を設定します。

パラメータ:
strExpValue - 見込金額

setSscExist

public void setSscExist(String strSscExist)
サービスタイプの制限を設定します。

パラメータ:
strSscExist - サービスタイプの制限

setConExist

public void setConExist(String strConExist)
基本契約明細の制限を設定します。

パラメータ:
strConExist - 基本契約明細の制限

setTmpExist

public void setTmpExist(String strTmpExist)
サービスパッケージの制限を設定します。

パラメータ:
strTmpExist - サービスパッケージの制限

setPriceChg

public void setPriceChg(String strPriceChg)
入力シートの価格変更を設定します。

パラメータ:
strPriceChg - 入力シートの価格変更

setFreeLimit

public void setFreeLimit(String strFreeLimit)
自由制限を設定します。

パラメータ:
strFreeLimit - 自由制限

setNoFrlimit

public void setNoFrlimit(String strNoFrlimit)
制限なしを設定します。

パラメータ:
strNoFrlimit - 制限なし

setServType

public void setServType(String strServType)
サービスタイプのテキスト (短)を設定します。

パラメータ:
strServType - サービスタイプのテキスト (短)

setEdition

public void setEdition(String strEdition)
サービスタイプのバージョンを設定します。

パラメータ:
strEdition - サービスタイプのバージョン

setSscLimit

public void setSscLimit(String strSscLimit)
サービスタイプの金額制限を設定します。

パラメータ:
strSscLimit - サービスタイプの金額制限

setSscNolim

public void setSscNolim(String strSscNolim)
標準サービスタイプの制限なしを設定します。

パラメータ:
strSscNolim - 標準サービスタイプの制限なし

setSscPrschg

public void setSscPrschg(String strSscPrschg)
入力シートの価格変更を設定します。

パラメータ:
strSscPrschg - 入力シートの価格変更

setSscPerc

public void setSscPerc(String strSscPerc)
価格決定率を設定します。

パラメータ:
strSscPerc - 価格決定率

setTmpNumber

public void setTmpNumber(String strTmpNumber)
モデルサービス明細セット番号を設定します。

パラメータ:
strTmpNumber - モデルサービス明細セット番号

setTmpLimit

public void setTmpLimit(String strTmpLimit)
モデルサービス明細制限を設定します。

パラメータ:
strTmpLimit - モデルサービス明細制限

setTmpNolim

public void setTmpNolim(String strTmpNolim)
モデル仕様の制限なしを設定します。

パラメータ:
strTmpNolim - モデル仕様の制限なし

setTmpPrschg

public void setTmpPrschg(String strTmpPrschg)
入力シートの価格変更を設定します。

パラメータ:
strTmpPrschg - 入力シートの価格変更

setTmpPerc

public void setTmpPerc(String strTmpPerc)
価格決定率を設定します。

パラメータ:
strTmpPerc - 価格決定率

setContPerc

public void setContPerc(String strContPerc)
価格決定率を設定します。

パラメータ:
strContPerc - 価格決定率

setLiIndex

public void setLiIndex(int liIndex)
レコード番号を設定します｡

パラメータ:
liIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ManufacturerPartNumb (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ManufacturerPartNumb

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb
すべての実装インタフェース:
Serializable
public class ManufacturerPartNumb
extends Object
implements Serializable

製造業者と製造者製品コードクラス
機能は以下の通り

  • 製造業者と製造者製品コードの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ManufacturerPartNumb()
製造業者と製造者製品コード情報を作成します。
ManufacturerPartNumb(int index)
製造業者と製造者製品コード情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMfrNo() 製造者番号を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setManuMat(String strManuMat) 製造者製品コードを設定します。
void | setMfrNo(String strMfrNo) 製造者番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ManufacturerPartNumb

public ManufacturerPartNumb()
製造業者と製造者製品コード情報を作成します。

ManufacturerPartNumb

public ManufacturerPartNumb(int index)
製造業者と製造者製品コード情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
srtManuMat 製造者製品コード

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
srtMfrNo 製造者番号

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setManuMat

public void setManuMat(String strManuMat)
製造者製品コードを設定します。

パラメータ:
strManuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String strMfrNo)
製造者番号を設定します。

パラメータ:
strMfrNo - 製造者番号

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialAvailabilityController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialAvailabilityController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController
すべての実装インタフェース:
Serializable
public class MaterialAvailabilityController
extends MaterialAvailability
implements Serializable

品目在庫確認コントローラクラス
機能は以下の通り

  • 在庫情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialAvailabilityController()
コンストラクタ生成
MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability から継承したメソッド
getAvQtyPlt, getBatch, getCheckRule, getCustomer, getDecForRounding, getDecForRoundingX, getDialogflag, getDocNumber, getEndleadtme, getItmNumber, getMaterial, getPlant, getStgeLoc, getStockInd, getUnit, getWbsElem, getWmdvexList, getWmdvsxList, setAvQtyPlt, setBatch, setCheckRule, setCustomer, setDecForRounding, setDecForRoundingX, setDialogflag, setDocNumber, setEndleadtme, setExportParam, setImportParam, setItmNumber, setMaterial, setPlant, setStgeLoc, setStockInd, setUnit, setWbsElem, setWmdvexList, setWmdvsxList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialAvailabilityController

public MaterialAvailabilityController()
コンストラクタ生成

MaterialAvailabilityController

public MaterialAvailabilityController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetAllController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetAllController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController
すべての実装インタフェース:
Serializable
public class MaterialGetAllController
extends MaterialGetAll
implements Serializable

品目マスタ照会コントローラクラス
機能は以下の通り

  • 品目マスタの情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetAllController()
コンストラクタ生成
MaterialGetAllController(SapClient sapClient)
コンストラクタ生成
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetAllController(String material, String companyCode, String plant, String storageLocation, String salesOrganisation, String distributionChannel, SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
メソッドの概要
void | executeBapi() BapiControllerにより品目マスタ照会を行います。
ExtensionOut | getExtensionOut(int index) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
InternationArticleNumbers | getInternationArticleNumbers(int index) EANオブジェクトが既に存在するかチェックします。
MaterialDescription | getMaterialDescription(int index) 品目テキストオブジェクトが既に存在するかチェックします。
MaterialText | getMaterialText(int index) テキスト (長)オブジェクトが既に存在するかチェックします。
TaxClassifications | getTaxClassifications(int index) 制御デ－タオブジェクトが既に存在するかチェックします。
UnitSofmeasure | getUnitSofmeasure(int index) 数量単位オブジェクトが既に存在するかチェックします。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll から継承したメソッド
getClientData, getCompanycode, getDistributionchannel, getExtensionOutList, getForecastParameters, getInternationArticleNumbersList, getLifoValuationData, getLifovaluationlevel, getMaterial, getMaterialDescriptionList, getMaterialTextList, getPlanningData, getPlant, getPlantData, getProductionResourceToolData, getSalesData, getSalesorganisation, getStoragelocation, getStorageLocationData, getStoragetype, getStorageTypeData, getTaxClassificationsList, getUnitSofmeasureList, getValuationarea, getValuationData, getValuationtype, getWarehousenumber, getWarehouseNumberData, initMaterialGetAll, setClientData, setCompanycode, setDistributionchannel, setExpClientData, setExpExtensionOut, setExpForecastParameters, setExpInternationArticleNumbers, setExpLifoValuationData, setExpMaterialDescription, setExpMaterialText, setExportParam, setExpPlanningData, setExpPlantData, setExpProductionResourceToolData, setExpSalesData, setExpStorageLocationData, setExpStorageTypeData, setExpTaxClassifications, setExpUnitSofmeasure, setExpValuationData, setExpWarehouseNumberData, setExtensionOutList, setForecastParameters, setImpExtensionOut, setImpInternationArticleNumbers, setImpMaterialDescription, setImpMaterialText, setImportParam, setImpTaxClassifications, setImpUnitSofmeasure, setInternationArticleNumbersList, setLifoValuationData, setLifovaluationlevel, setMaterial, setMaterialDescriptionList, setMaterialTextList, setPlanningData, setPlant, setPlantData, setProductionResourceToolData, setSalesData, setSalesorganisation, setStoragelocation, setStorageLocationData, setStoragetype, setStorageTypeData, setTaxClassificationsList, setUnitSofmeasureList, setValuationarea, setValuationData, setValuationtype, setWarehousenumber, setWarehouseNumberData, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetAllController

public MaterialGetAllController()
コンストラクタ生成

MaterialGetAllController

public MaterialGetAllController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

MaterialGetAllController

public MaterialGetAllController(String material,
                                String companyCode,
                                String plant,
                                String storageLocation,
                                String salesOrganisation,
                                String distributionChannel)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル

MaterialGetAllController

public MaterialGetAllController(String material,
                                String companyCode,
                                String plant,
                                String storageLocation,
                                String salesOrganisation,
                                String distributionChannel,
                                SapClient sapClient)
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。

パラメータ:
material - 品目コード
companyCode - 会社コード
plant - プラント
storageLocation - 保管場所
salesOrganisation - 販売組織
distributionChannel - 流通チャネル
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより品目マスタ照会を行います。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getMaterialDescription

public MaterialDescription getMaterialDescription(int index)
品目テキストオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
materialDescription 品目テキストオブジェクト

getUnitSofmeasure

public UnitSofmeasure getUnitSofmeasure(int index)
数量単位オブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
unitSofmeasure 数量単位オブジェクト

getInternationArticleNumbers

public InternationArticleNumbers getInternationArticleNumbers(int index)
EANオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
internationArticleNumbers EANオブジェクト

getMaterialText

public MaterialText getMaterialText(int index)
テキスト (長)オブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
materialText テキスト (長)オブジェクト

getTaxClassifications

public TaxClassifications getTaxClassifications(int index)
制御デ－タオブジェクトが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
taxClassifications 制御デ－タオブジェクト

getExtensionOut

public ExtensionOut getExtensionOut(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
extensionOut EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
MaterialGetListController
public class MaterialGetList
extends ReferenceController
implements Serializable

品目コード検索クラス
機能は以下の通り

  • 品目コード、テキストを検索します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
メソッドの概要
ArrayList | getDistributionChannelSelectionList() 流通チャネルの選択オプション一覧を取得します｡
ArrayList | getManufacturerPartNumbList() 製造業者と製造者製品コード一覧を取得します｡
ArrayList | getMaterialShortDescselList() 品目テキストの選択オプション一覧を取得します｡
ArrayList | getMatnrListList() 品目コードと品目テキストの一覧を取得します｡
ArrayList | getMatnrSelectionList() 品目コードの選択オプション一覧を取得します｡
String | getMaxRows() 選択予定品目の最大数を取得します｡
ArrayList | getPlantSelectionList() プラントの選択オプション一覧を取得します｡
ArrayList | getSalesOrganisationSelectionList() 販売組織の選択オプション一覧を取得します｡
ArrayList | getStorageLocationselectList() 保管場所の選択オプション一覧を取得します｡
void | setDistributionChannelSelectionList(ArrayList distributionChannelSelectionList) 流通チャネルの選択オプション一覧を設定します｡
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setImportParam(BapiController bapiController) 品目コードを検索する条件ををセットします。
void | setManufacturerPartNumbList(ArrayList manufacturerPartNumbList) 製造業者と製造者製品コード一覧を設定します｡
void | setMaterialShortDescselList(ArrayList materialShortDescselList) 品目テキストの選択オプション一覧を設定します。
void | setMatnrListList(ArrayList matnrListList) 品目コードと品目テキスト一覧を設定します｡
void | setMatnrSelectionList(ArrayList matnrSelectionList) 品目コードの選択オプション一覧を設定します。
void | setMaxRows(String strMaxRows) 選択予定品目の最大数を設定します。
void | setPlantSelectionList(ArrayList plantSelectionList) プラントの選択オプション一覧を設定します｡
void | setSalesOrganisationSelectionList(ArrayList salesOrganisationSelectionList) 販売組織の選択オプション一覧を設定します｡
void | setStoragelocationselectList(ArrayList storageLocationselectList) 保管場所の選択オプション一覧を設定します｡
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetList

public MaterialGetList(SapClient sapClient)
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPPurchaseSystemException
品目コードを検索する条件ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setMaxRows

public void setMaxRows(String strMaxRows)
選択予定品目の最大数を設定します。

パラメータ:
strMaxRows - 選択予定品目の最大数

setMatnrSelectionList

public void setMatnrSelectionList(ArrayList matnrSelectionList)
品目コードの選択オプション一覧を設定します。

パラメータ:
matnrSelectionList - 品目コードの選択オプション一覧

setMaterialShortDescselList

public void setMaterialShortDescselList(ArrayList materialShortDescselList)
品目テキストの選択オプション一覧を設定します。

パラメータ:
materialShortDescselList - 品目テキストの選択オプション一覧

setManufacturerPartNumbList

public void setManufacturerPartNumbList(ArrayList manufacturerPartNumbList)
製造業者と製造者製品コード一覧を設定します｡

パラメータ:
manufacturerPartNumbList - 製造業者と製造者製品コード一覧

setPlantSelectionList

public void setPlantSelectionList(ArrayList plantSelectionList)
プラントの選択オプション一覧を設定します｡

パラメータ:
plantSelectionList - プラントの選択オプション一覧

setStoragelocationselectList

public void setStoragelocationselectList(ArrayList storageLocationselectList)
保管場所の選択オプション一覧を設定します｡

パラメータ:
storageLocationselectList - 保管場所の選択オプション一覧

setSalesOrganisationSelectionList

public void setSalesOrganisationSelectionList(ArrayList salesOrganisationSelectionList)
販売組織の選択オプション一覧を設定します｡

パラメータ:
salesOrganisationSelectionList - 販売組織の選択オプション一覧

setDistributionChannelSelectionList

public void setDistributionChannelSelectionList(ArrayList distributionChannelSelectionList)
流通チャネルの選択オプション一覧を設定します｡

パラメータ:
distributionChannelSelectionList - 流通チャネルの選択オプション一覧

setMatnrListList

public void setMatnrListList(ArrayList matnrListList)
品目コードと品目テキスト一覧を設定します｡

パラメータ:
matnrListList - 品目コードと品目テキスト一覧

getMaxRows

public String getMaxRows()
選択予定品目の最大数を取得します｡

戻り値:
strMaxRows 選択予定品目の最大数

getMatnrSelectionList

public ArrayList getMatnrSelectionList()
品目コードの選択オプション一覧を取得します｡

戻り値:
matnrSelectionList 品目コードの選択オプション一覧

getMaterialShortDescselList

public ArrayList getMaterialShortDescselList()
品目テキストの選択オプション一覧を取得します｡

戻り値:
materialShortDescselList 品目テキストの選択オプション一覧

getManufacturerPartNumbList

public ArrayList getManufacturerPartNumbList()
製造業者と製造者製品コード一覧を取得します｡

戻り値:
manufacturerPartNoList 製造業者と製造者製品コード一覧

getPlantSelectionList

public ArrayList getPlantSelectionList()
プラントの選択オプション一覧を取得します｡

戻り値:
plantSelectionList プラントの選択オプション一覧

getStorageLocationselectList

public ArrayList getStorageLocationselectList()
保管場所の選択オプション一覧を取得します｡

戻り値:
storagelocationselectList 保管場所の選択オプション一覧

getSalesOrganisationSelectionList

public ArrayList getSalesOrganisationSelectionList()
販売組織の選択オプション一覧を取得します｡

戻り値:
salesOrganisationSelectionList 販売組織の選択オプション一覧

getDistributionChannelSelectionList

public ArrayList getDistributionChannelSelectionList()
流通チャネルの選択オプション一覧を取得します｡

戻り値:
distributionChannelSelectionList 流通チャネルの選択オプション一覧

getMatnrListList

public ArrayList getMatnrListList()
品目コードと品目テキストの一覧を取得します｡

戻り値:
matnrListList 品目コードと品目テキストの一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialGetListController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController
すべての実装インタフェース:
Serializable
public class MaterialGetListController
extends MaterialGetList
implements Serializable

品目コード検索コントローラクラス
機能は以下の通り

  • 品目コード、テキストを検索します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialGetListController()
MaterialGetListのコンストラクタを生成します。
MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList から継承したメソッド
getDistributionChannelSelectionList, getManufacturerPartNumbList, getMaterialShortDescselList, getMatnrListList, getMatnrSelectionList, getMaxRows, getPlantSelectionList, getSalesOrganisationSelectionList, getStorageLocationselectList, setDistributionChannelSelectionList, setExportParam, setImportParam, setManufacturerPartNumbList, setMaterialShortDescselList, setMatnrListList, setMatnrSelectionList, setMaxRows, setPlantSelectionList, setSalesOrganisationSelectionList, setStoragelocationselectList, setTblParam, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialGetListController

public MaterialGetListController()
MaterialGetListのコンストラクタを生成します。

MaterialGetListController

public MaterialGetListController(SapClient sapClient)
MaterialGetListのコンストラクタを生成します。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialSaveReplicaController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialSaveReplicaController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController
すべての実装インタフェース:
Serializable
public class MaterialSaveReplicaController
extends MaterialSaveReplica
implements Serializable

品目マスタ更新コントローラクラス
機能は以下の通り

  • 品目マスタを更新します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
MaterialSaveReplicaController()
コンストラクタ生成
MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成
MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成
メソッドの概要
void | executeBapi() BapiControllerにより品目マスタを更新します。
ClientDataList | getClientDataList(int index) 品目データ (クライアントレベル)が既に存在するかチェックします。
ExtensionIn | getExtensionIn(int index) BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。
ExtensionInX | getExtensionInX(int index) 拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。
ForecastParametersList | getForecastParametersList(int index) 需要予測パラメータが既に存在するかチェックします。
ForecastValues | getForecastValues(int index) 需要予測値のデータ転送が既に存在するかチェックします。
HeadData | getHeadData(int index) 管理情報設定ヘッダセグメントが既に存在するかチェックします。
InternationalArtnos | getInternationalArtnos(int index) 国際商品コード (EAN)が既に存在するかチェックします。
MaterialDescription | getMaterialDescription(int index) 品目テキストが既に存在するかチェックします。
MaterialLongText | getMaterialLongText(int index) テキスト (長)が既に存在するかチェックします。
PlanningDataList | getPlanningDataList(int index) 品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。
PlantDataList | getPlantDataList(int index) 品目データ (プラントレベル)が既に存在するかチェックします。
PrtData | getPrtData(int index) 品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。
SalesDataList | getSalesDataList(int index) 販売データが既に存在するかチェックします。
StorageLocationDataList | getStorageLocationDataList(int index) 品目データ (保管場所レベル)が既に存在するかチェックします。
StorageTypeDataList | getStorageTypeDataList(int index) 保管域タイプデータが既に存在するかチェックします。
TaxClassifications | getTaxClassifications(int index) 制御デ－タが既に存在するかチェックします。
TotalConsumption | getTotalConsumption(int index) 品目総消費量のデータ転送が既に存在するかチェックします。
UnitSofmeasure | getUnitSofmeasure(int index) 数量単位が既に存在するかチェックします。
UnplndConsumption | getUnplndConsumption(int index) 計画外消費のデータ転送が既に存在するかチェックします。
ValuationDataList | getValuationDataList(int index) 評価データが既に存在するかチェックします。
WarehouseNumberDataList | getWarehouseNumberDataList(int index) 倉庫番号データが既に存在するかチェックします。
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica から継承したメソッド
getClientDataList, getExtensionInList, getExtensionInXList, getFlagCadCall, getForecastParametersList, getForecastValuesList, getHeadDataList, getInpfldcheck, getInternationalArtnosList, getMaterialDescriptionList, getMaterialLongTextList, getNoappllog, getNochangedoc, getPlanningDataList, getPlantDataList, getPrtDataList, getReturnMessagesList, getSalesDataList, getStorageLocationDataList, getStorageTypeDataList, getTaxClassificationsList, getTestrun, getTotalConsumptionList, getUnitSofmeasureList, getUnplndConsumptionList, getValuationDataList, getWarehouseNumberDataList, initMaterialSaveReplica, setClientDataList, setExportParam, setExtensionInList, setExtensionInXList, setFlagCadCall, setForecastParametersList, setForecastValuesList, setHeadDataList, setImportParam, setInpfldcheck, setInternationalArtnosList, setMaterialDescriptionList, setMaterialLongTextList, setNoappllog, setNochangedoc, setPlanningDataList, setPlantDataList, setPrtDataList, setReturnMessagesList, setSalesDataList, setStorageLocationDataList, setStorageTypeDataList, setTaxClassificationsList, setTestrun, setTotalConsumptionList, setUnitSofmeasureList, setUnplndConsumptionList, setValuationDataList, setWarehouseNumberDataList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialSaveReplicaController

public MaterialSaveReplicaController()
コンストラクタ生成

MaterialSaveReplicaController

public MaterialSaveReplicaController(ConnectionManager connectionManager)
コンストラクタ生成

パラメータ:
connectionManager - コネクションオブジェクト

MaterialSaveReplicaController

public MaterialSaveReplicaController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより品目マスタを更新します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getHeadData

public HeadData getHeadData(int index)
管理情報設定ヘッダセグメントが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 管理情報設定ヘッダセグメントオブジェクト

getClientDataList

public ClientDataList getClientDataList(int index)
品目データ (クライアントレベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (クライアントレベル) オブジェクト

getPlantDataList

public PlantDataList getPlantDataList(int index)
品目データ (プラントレベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (プラントレベル) オブジェクト

getForecastParametersList

public ForecastParametersList getForecastParametersList(int index)
需要予測パラメータが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 需要予測パラメータオブジェクト

getPlanningDataList

public PlanningDataList getPlanningDataList(int index)
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目マスタ/製品グループの変更伝票構造オブジェクト

getStorageLocationDataList

public StorageLocationDataList getStorageLocationDataList(int index)
品目データ (保管場所レベル)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目データ (保管場所レベル) オブジェクト

getValuationDataList

public ValuationDataList getValuationDataList(int index)
評価データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 評価データオブジェクト

getWarehouseNumberDataList

public WarehouseNumberDataList getWarehouseNumberDataList(int index)
倉庫番号データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 倉庫番号データオブジェクト

getSalesDataList

public SalesDataList getSalesDataList(int index)
販売データが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 販売データオブジェクト

getStorageTypeDataList

public StorageTypeDataList getStorageTypeDataList(int index)
保管域タイプデータが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 保管域タイプデータオブジェクト

getMaterialDescription

public MaterialDescription getMaterialDescription(int index)
品目テキストが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目テキストオブジェクト

getUnitSofmeasure

public UnitSofmeasure getUnitSofmeasure(int index)
数量単位が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 数量単位オブジェクト

getInternationalArtnos

public InternationalArtnos getInternationalArtnos(int index)
国際商品コード (EAN)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 国際商品コード (EAN)オブジェクト

getMaterialLongText

public MaterialLongText getMaterialLongText(int index)
テキスト (長)が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj テキスト (長)オブジェクト

getTaxClassifications

public TaxClassifications getTaxClassifications(int index)
制御デ－タが既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 制御デ－タオブジェクト

getPrtData

public PrtData getPrtData(int index)
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目マスタの生産資源/治工具 (PRT) 項目オブジェクト

getExtensionIn

public ExtensionIn getExtensionIn(int index)
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 オブジェクト

getExtensionInX

public ExtensionInX getExtensionInX(int index)
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 拡張イン/拡張アウトのチェックボックス構造オブジェクト

getForecastValues

public ForecastValues getForecastValues(int index)
需要予測値のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 需要予測値のデータ転送オブジェクト

getUnplndConsumption

public UnplndConsumption getUnplndConsumption(int index)
計画外消費のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 計画外消費のデータ転送オブジェクト

getTotalConsumption

public TotalConsumption getTotalConsumption(int index)
品目総消費量のデータ転送が既に存在するかチェックします。 存在しなければオブジェクトを作成します。

パラメータ:
index - レコード番号
戻り値:
returnObj 品目総消費量のデータ転送オブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MaterialShortDescsel (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MaterialShortDescsel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel
すべての実装インタフェース:
Serializable
public class MaterialShortDescsel
extends Selection
implements Serializable

品目テキストの選択オプションクラス
機能は以下の通り

  • 品目テキストの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MaterialShortDescsel()
品目テキストの選択オプション情報を作成します。
MaterialShortDescsel(int index)
品目テキストの選択オプション情報を作成します。
メソッドの概要
String | getDescrHigh() 終了品目テキストを取得します。
String | getDescrLow() 開始品目テキストを取得します。
int | getIndex() レコード番号を取得します。
void | setDescrHigh(String strDescrHigh) 終了品目テキストを設定します。
void | setDescrLow(String strDescrLow) 開始品目テキストを設定します。
void | setIndex(int index) レコード番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MaterialShortDescsel

public MaterialShortDescsel()
品目テキストの選択オプション情報を作成します。

MaterialShortDescsel

public MaterialShortDescsel(int index)
品目テキストの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDescrLow

public String getDescrLow()
開始品目テキストを取得します。

戻り値:
srtDescrLow 開始品目テキスト

getDescrHigh

public String getDescrHigh()
終了品目テキストを取得します。

戻り値:
srtDescrHigh 品目テキスト

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setDescrLow

public void setDescrLow(String strDescrLow)
開始品目テキストを設定します。

パラメータ:
strDescrLow - 開始品目テキスト

setDescrHigh

public void setDescrHigh(String strDescrHigh)
終了品目テキストを設定します。

パラメータ:
strDescrHigh - 品目テキスト

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MatnrList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MatnrList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.MatnrList
すべての実装インタフェース:
Serializable
public class MatnrList
extends Object
implements Serializable

品目コードと品目テキストの一覧クラス
機能は以下の通り

  • 品目コードと品目テキストの一覧の情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MatnrList()
品目コードと品目テキストの一覧情報を作成します。
メソッドの概要
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMatlDesc() 品目テキストを取得します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String strMaterialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String strMaterialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMatlDesc(String strMatlDesc) 品目テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MatnrList

public MatnrList()
品目コードと品目テキストの一覧情報を作成します。

メソッドの詳細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
srtMaterial

getMatlDesc

public String getMatlDesc()
品目テキストを取得します。

戻り値:
srtMatlDesc

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
srtMaterialExternal

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
srtMaterialGuid

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
srtMaterialVersion

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setMatlDesc

public void setMatlDesc(String strMatlDesc)
品目テキストを設定します。

パラメータ:
strMatlDesc - 品目テキスト

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
strMaterialExternal - 項目 MATERIAL の品目コード (長)

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
strMaterialGuid - 項目 MATERIAL の外部 GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
strMaterialVersion - 項目 MATERIAL のバージョン番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


MatnrSelection (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス MatnrSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection
すべての実装インタフェース:
Serializable
public class MatnrSelection
extends Selection
implements Serializable

品目コードの選択オプションクラス
機能は以下の通り

  • 品目コードの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
MatnrSelection()
品目コードの選択オプション情報を作成します。
MatnrSelection(int index)
品目コードの選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getMatnrHigh() 終了品目コードを取得します。
String | getMatnrLow() 開始品目コードを取得します。
void | setIndex(int index) レコード番号を設定します。
void | setMatnrHigh(String strMatnrHigh) 終了品目コードを設定します。
void | setMatnrLow(String strMatnrLow) 開始品目コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

MatnrSelection

public MatnrSelection()
品目コードの選択オプション情報を作成します。

MatnrSelection

public MatnrSelection(int index)
品目コードの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getMatnrLow

public String getMatnrLow()
開始品目コードを取得します。

戻り値:
srtMatnrLow 開始品目コード

getMatnrHigh

public String getMatnrHigh()
終了品目コードを取得します。

戻り値:
srtMatnrHigh 終了品目コード

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setMatnrLow

public void setMatnrLow(String strMatnrLow)
開始品目コードを設定します。

パラメータ:
strMatnrLow - 開始品目コード

setMatnrHigh

public void setMatnrHigh(String strMatnrHigh)
終了品目コードを設定します。

パラメータ:
strMatnrHigh - 終了品目コード

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.purchase (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.purchase
クラス
AllVersions
Cond
ContractLimits
ContractService
ContractServiceAccount
ContractServiceText
DeliveryAddress
DistributionChannelSelection
ExportHeader
ExportItem
Extension
GoodsMvtCreateController
GoodsMvtGetItemsController
Limits
ManufacturerPartNumb
MaterialAvailabilityController
MaterialGetAllController
MaterialGetList
MaterialGetListController
MaterialSaveReplicaController
MaterialShortDescsel
MatnrList
MatnrSelection
ParamAllVersions
ParamCondHeader
ParamCondItem
ParamContractLimits
ParamContractService
ParamContractServiceAccount
ParamContractServiceText
ParamDeliveryAddress
ParamExportHeader
ParamExportItem
ParamExtension
ParamHeader
ParamHeaderText
ParamItem
ParamItemText
ParamLimits
ParamPartner
ParamProfitSegment
ParamPurchaseAccount
ParamPurchaseSchedule
ParamVendorAddress
ParamVersions
Partner
PlantSelection
ProfitSegment
PurchaseAccount
PurchaseGetItemSrel
PurchaseGetItemSrelController
PurchaseHeader
PurchaseHeaderPost
PurchaseHeaders
PurchaseItem
PurchaseItemPost
PurchaseItems
PurchaseOrderPayPost
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseRelease
PurchaseReleaseController
PurchaseResetReleaseController
PurchaseSchedule
PurchaseText
SalesOrganisationSelection
Selection
StdMaterialGetIntNumberController
StorageLocationSelect
SupplierDetail
SupplierExistenceCheck
SupplierExistenceCheckController
SupplierGetDetailController
VendorAddress
Versions


jp.co.intra_mart.foundation.sap.module.purchase (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase

ＳＡＰ連携経費購買系に関するクラスを提供します。

参照:
説明

クラスの概要
AllVersions | 全バージョン管理情報クラス 機能は以下の通り 全バージョン管理情報を保持します。
Cond | 条件情報クラス 機能は以下の通り 条件情報を保持します。
ContractLimits | 外注基本契約制限情報クラス 機能は以下の通り 外注基本契約情報を保持します。
ContractService | 外注サービス情報クラス 機能は以下の通り 外注サービス情報を保持します。
ContractServiceAccount | 外注サービス勘定設定情報クラス 機能は以下の通り 外注サービス勘定設定情報を保持します。
ContractServiceText | 外注サービステキスト情報クラス 機能は以下の通り 外注サービステキスト情報を保持します。
DeliveryAddress | 入荷伝票アドレス情報クラス 機能は以下の通り 入荷伝票アドレス情報を保持します。
DistributionChannelSelection | 流通チャネルの選択オプションクラス 機能は以下の通り 流通チャネルの選択オプションの情報を保持します。
ExportHeader | 貿易管理ヘッダ情報クラス 機能は以下の通り 貿易管理ヘッダ情報を保持します。
ExportItem | 貿易管理明細情報クラス 機能は以下の通り 貿易管理明細情報を保持します。
Extension | 拡張得意先項目情報クラス 機能は以下の通り 拡張得意先項目情報を保持します。
GoodsMvtCreateController | 入庫伝票登録コントローラクラス 機能は以下の通り 入庫伝票を登録します。
GoodsMvtGetItemsController | 入出庫伝票一覧取得コントローラクラス 機能は以下の通り 入出庫伝票の一覧を取得します。
Limits | 外注制限情報クラス 機能は以下の通り 外注制限情報を保持します。
ManufacturerPartNumb | 製造業者と製造者製品コードクラス 機能は以下の通り 製造業者と製造者製品コードの情報を保持します。
MaterialAvailabilityController | 品目在庫確認コントローラクラス 機能は以下の通り 在庫情報を取得します。
MaterialGetAllController | 品目マスタ照会コントローラクラス 機能は以下の通り 品目マスタの情報を取得します。
MaterialGetList | 品目コード検索クラス 機能は以下の通り 品目コード、テキストを検索します。
MaterialGetListController | 品目コード検索コントローラクラス 機能は以下の通り 品目コード、テキストを検索します。
MaterialSaveReplicaController | 品目マスタ更新コントローラクラス 機能は以下の通り 品目マスタを更新します。
MaterialShortDescsel | 品目テキストの選択オプションクラス 機能は以下の通り 品目テキストの選択オプションの情報を保持します。
MatnrList | 品目コードと品目テキストの一覧クラス 機能は以下の通り 品目コードと品目テキストの一覧の情報を保持します。
MatnrSelection | 品目コードの選択オプションクラス 機能は以下の通り 品目コードの選択オプションの情報を保持します。
ParamAllVersions | 全バージョンパラメータ設定クラス 機能は以下の通り 全バージョンのパラメータを設定します。
ParamCondHeader | 条件ヘッダパラメータ設定クラス 機能は以下の通り 条件ヘッダのパラメータを設定します。
ParamCondItem | 条件明細パラメータ設定ラクラス 機能は以下の通り 条件明細のパラメータを設定します。
ParamContractLimits | 外注基本契約制限パラメータ設定クラス 機能は以下の通り 外注基本契約制限のパラメータを設定します。
ParamContractService | 外注サービスパラメータ設定クラス 機能は以下の通り 外注サービスのパラメータを設定します。
ParamContractServiceAccount | 外注サービス勘定設定パラメータ設定クラス 機能は以下の通り 外注サービス勘定設定のパラメータを設定します。
ParamContractServiceText | 外注サービステキストパラメータ設定クラス 機能は以下の通り 外注サービステキストのパラメータを設定します。
ParamDeliveryAddress | 入荷伝票アドレスパラメータ設定ラクラス 機能は以下の通り 入荷伝票アドレスのパラメータを設定します。
ParamExportHeader | 貿易管理ヘッダパラメータ設定ラクラス 機能は以下の通り 貿易管理ヘッダのパラメータを設定します。
ParamExportItem | 貿易管理明細インポートパラメータ設定クラス 機能は以下の通り 貿易管理明細のパラメータを設定します。
ParamExtension | 拡張得意先項目パラメータ設定クラス 機能は以下の通り 拡張得意先項目のパラメータを設定します。
ParamHeader | 伝票ヘッダパラメータ設定クラス 機能は以下の通り 伝票ヘッダのインポートパラメータを設定します。
ParamHeaderText | ヘッダテキストパラメータ設定クラス 機能は以下の通り ヘッダテキストのパラメータを設定します。
ParamItem | 明細パラメータ設定クラス 機能は以下の通り 明細のパラメータを設定します。
ParamItemText | 明細テキストパラメータ設定クラス 機能は以下の通り 明細テキストのパラメータを設定します。
ParamLimits | 外注制限パラメータ設定クラス 機能は以下の通り 外注制限のパラメータを設定します。
ParamPartner | 得意先インポートパラメータ設定クラス 機能は以下の通り 得意先のパラメータを設定します。
ParamProfitSegment | 入出庫予定パラメータ設定クラス 機能は以下の通り 入出庫予定のパラメータを設定します。
ParamPurchaseAccount | 勘定設定パラメータ設定クラス 機能は以下の通り 勘定設定のパラメータを設定します。
ParamPurchaseSchedule | 納入日程パラメータ設定クラス 機能は以下の通り 納入日程のパラメータを設定します。
ParamVendorAddress | 仕入先住所パラメータ設定クラス 機能は以下の通り 仕入先住所のパラメータを設定します。
ParamVersions | バージョン管理パラメータ設定ラクラス 機能は以下の通り バージョン管理のパラメータを設定します。
Partner | 取引先情報クラス 機能は以下の通り 取引先情報を保持します。
PlantSelection | プラントの選択オプションクラス 機能は以下の通り プラントの選択オプションの情報を保持します。
ProfitSegment | 入出庫予定情報クラス 機能は以下の通り 入出庫予定情報を保持します。
PurchaseAccount | 購買発注伝票勘定情報クラス 機能は以下の通り 購買発注伝票勘定情報を保持します。
PurchaseGetItemSrel | 伝票承認対象一覧情報クラス 機能は以下の通り 伝票承認対象一覧を取得します。
PurchaseGetItemSrelController | 伝票の承認対象一覧取得コントローラクラス 機能は以下の通り 伝票の承認対象一覧を取得します。
PurchaseHeader | 購買発注ヘッダ情報スーパークラス 機能は以下の通り 購買発注のヘッダ情報を保持します。
PurchaseHeaderPost | 購買発注伝票ヘッダ情報クラス 機能は以下の通り 購買発注伝票ヘッダの情報を保持します。
PurchaseHeaders | 伝票の承認対象一覧ヘッダ情報クラス 機能は以下の通り 伝票の承認対象一覧ヘッダの情報を保持します。
PurchaseItem | 購買発注明細情報スーパークラス 機能は以下の通り 購買発注の明細情報を保持します。
PurchaseItemPost | 購買発注伝票明細情報クラス 機能は以下の通り 購買発注伝票明細情報を保持します。
PurchaseItems | 伝票の承認対象明細情報クラス 機能は以下の通り 伝票の承認対象明細情報を保持します。
PurchaseOrderPayPost | 伝票登録クラス 機能は以下の通り 伝票を登録します。
PurchaseOrderPayPostController | 伝票登録コントローラクラス 機能は以下の通り 伝票を登録します。
PurchaseOrderPostChangeController | 伝票登録変更コントローラクラス 機能は以下の通り 伝票を変更します。
PurchaseRelease | 承認情報スーパークラス 機能は以下の通り 承認情報を保持します。
PurchaseReleaseController | 伝票承認コントローラクラス 機能は以下の通り 伝票を承認します。
PurchaseResetReleaseController | 伝票承認取消コントローラクラス 機能は以下の通り 伝票の承認取消します。
PurchaseSchedule | 購買発注伝票納入日程情報クラス 機能は以下の通り 購買発注伝票納入日程情報を保持します。
PurchaseText | 購買発注伝票テキストクラス 機能は以下の通り 購買発注伝テキストを保持します。
SalesOrganisationSelection | 販売組織の選択オプションクラス 機能は以下の通り 販売組織の選択オプションの情報を保持します。
Selection | 選択オプションクラス 機能は以下の通り 選択オプションの情報を保持します。
StdMaterialGetIntNumberController | 品目コード割当済照会コントローラクラス。
StorageLocationSelect | 保管場所の選択オプションクラス 機能は以下の通り 保管場所の選択オプションの情報を保持します。
SupplierDetail | 仕入先マスタ詳細情報クラス 機能は以下の通り 仕入先マスタの詳細情報を取得します。
SupplierExistenceCheck | 仕入先コード存在チェッククラス 機能は以下の通り 仕入先コード存在チェック結果を取得します。
SupplierExistenceCheckController | 仕入先コード存在チェックコントローラ 機能は以下の通り 仕入先コード存在チェックを行います。
SupplierGetDetailController | 仕入先マスタの詳細情報取得コントローラ 機能は以下の通り 仕入先マスタの詳細情報を取得します。
VendorAddress | 仕入先住所情報クラス 機能は以下の通り 仕入先住所を保持します。
Versions | バージョン管理情報クラス 機能は以下の通り バージョン管理情報を保持します。

パッケージ jp.co.intra_mart.foundation.sap.module.purchase の説明

ＳＡＰ連携経費購買系に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.module.purchase クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.purchase の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Cond (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Extension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
    • class jp.co.intra_mart.foundation.sap.module.purchase.Limits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Partner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
    • class jp.co.intra_mart.foundation.sap.module.purchase.Selection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Versions (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.purchase の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.purchase の使用

jp.co.intra_mart.foundation.sap.module.purchase を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.purchase ＳＡＰ連携経費購買系に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module.purchase のクラス
ExportHeader
貿易管理ヘッダ情報クラス
機能は以下の通り
貿易管理ヘッダ情報を保持します。
MaterialGetList
品目コード検索クラス
機能は以下の通り
品目コード、テキストを検索します。
PurchaseGetItemSrel
伝票承認対象一覧情報クラス
機能は以下の通り
伝票承認対象一覧を取得します。
PurchaseHeader
購買発注ヘッダ情報スーパークラス
機能は以下の通り
購買発注のヘッダ情報を保持します。
PurchaseHeaderPost
購買発注伝票ヘッダ情報クラス
機能は以下の通り
購買発注伝票ヘッダの情報を保持します。
PurchaseItem
購買発注明細情報スーパークラス
機能は以下の通り
購買発注の明細情報を保持します。
PurchaseOrderPayPost
伝票登録クラス
機能は以下の通り
伝票を登録します。
PurchaseRelease
承認情報スーパークラス
機能は以下の通り
承認情報を保持します。
PurchaseText
購買発注伝票テキストクラス
機能は以下の通り
購買発注伝テキストを保持します。
Selection
選択オプションクラス
機能は以下の通り
選択オプションの情報を保持します。
SupplierDetail
仕入先マスタ詳細情報クラス
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierExistenceCheck
仕入先コード存在チェッククラス
機能は以下の通り
仕入先コード存在チェック結果を取得します。
VendorAddress
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。
Versions
バージョン管理情報クラス
機能は以下の通り
バージョン管理情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamAllVersions (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamAllVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions
すべての実装インタフェース:
Serializable
public final class ParamAllVersions
extends Object
implements Serializable

全バージョンパラメータ設定クラス
機能は以下の通り

  • 全バージョンのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setExportParam(BapiController bapiController, List allVersionsList)
全バージョンに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List allVersionsList)
                           throws SAPGeneralSystemException
全バージョンに値をセットします。

パラメータ:
bapiController - BapiController
allVersionsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCondHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamCondHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader
すべての実装インタフェース:
Serializable
public final class ParamCondHeader
extends Object
implements Serializable

条件ヘッダパラメータ設定クラス
機能は以下の通り

  • 条件ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List condHeaderList)
条件ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List condHeaderList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
condHeaderList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCondItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamCondItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem
すべての実装インタフェース:
Serializable
public final class ParamCondItem
extends Object
implements Serializable

条件明細パラメータ設定ラクラス
機能は以下の通り

  • 条件明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List condItemList)
条件明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List condItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件明細に値をセットします。

パラメータ:
bapiController - BapiController
condItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractLimits (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits
すべての実装インタフェース:
Serializable
public final class ParamContractLimits
extends Object
implements Serializable

外注基本契約制限パラメータ設定クラス
機能は以下の通り

  • 外注基本契約制限のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractLimitsList)
外注基本契約制限に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractLimitsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注基本契約制限に値をセットします。

パラメータ:
bapiController - BapiController
contractLimitsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractService (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractService

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService
すべての実装インタフェース:
Serializable
public final class ParamContractService
extends Object
implements Serializable

外注サービスパラメータ設定クラス
機能は以下の通り

  • 外注サービスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceList)
外注サービスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービスに値をセットします。

パラメータ:
bapiController - BapiController
contractServiceList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractServiceAccount (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractServiceAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount
すべての実装インタフェース:
Serializable
public final class ParamContractServiceAccount
extends Object
implements Serializable

外注サービス勘定設定パラメータ設定クラス
機能は以下の通り

  • 外注サービス勘定設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceAccountList)
外注サービス勘定設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceAccountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービス勘定設定に値をセットします。

パラメータ:
bapiController - BapiController
contractServiceAccountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamContractServiceText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamContractServiceText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText
すべての実装インタフェース:
Serializable
public final class ParamContractServiceText
extends Object
implements Serializable

外注サービステキストパラメータ設定クラス
機能は以下の通り

  • 外注サービステキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List contractServiceTextList)
外注サービステキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List contractServiceTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注サービステキストに値をセットします。

パラメータ:
bapiController - BapiController
contractServiceTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamDeliveryAddress (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamDeliveryAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress
すべての実装インタフェース:
Serializable
public final class ParamDeliveryAddress
extends Object
implements Serializable

入荷伝票アドレスパラメータ設定ラクラス
機能は以下の通り

  • 入荷伝票アドレスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List deliveryAddressList)
入荷伝票アドレスヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List deliveryAddressList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入荷伝票アドレスヘッダに値をセットします。

パラメータ:
bapiController - BapiController
deliveryAddressList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExportHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExportHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader
すべての実装インタフェース:
Serializable
public final class ParamExportHeader
extends Object
implements Serializable

貿易管理ヘッダパラメータ設定ラクラス
機能は以下の通り

  • 貿易管理ヘッダのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
static void | setImportParam(BapiController bapiController, ExportHeader exportHeader) 貿易管理ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  ExportHeader exportHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
貿易管理ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
exportHeader - ExportHeader
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  ExportHeader exportHeader)
                           throws SAPGeneralSystemException
貿易管理ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
exportHeader - ExportHeader
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExportItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExportItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem
すべての実装インタフェース:
Serializable
public final class ParamExportItem
extends Object
implements Serializable

貿易管理明細インポートパラメータ設定クラス
機能は以下の通り

  • 貿易管理明細のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List exportItemList)
貿易管理明細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List exportItemList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
貿易管理明細に値をセットします。

パラメータ:
bapiController - BapiController
exportItemList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtension (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamExtension

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension
すべての実装インタフェース:
Serializable
public final class ParamExtension
extends Object
implements Serializable

拡張得意先項目パラメータ設定クラス
機能は以下の通り

  • 拡張得意先項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionList) 拡張得意先項目に値をセットします。
static void | setImportParam(BapiController bapiController, List extensionList) 拡張得意先項目に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensionList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
拡張得意先項目に値をセットします。

パラメータ:
bapiController - BapiController
extensionList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionList)
                           throws SAPGeneralSystemException
拡張得意先項目に値をセットします。

パラメータ:
bapiController - BapiController
extensionList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader
すべての実装インタフェース:
Serializable
public final class ParamHeader
extends Object
implements Serializable

伝票ヘッダパラメータ設定クラス
機能は以下の通り

  • 伝票ヘッダのインポートパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
static void | setImportParam(BapiController bapiController, PurchaseHeaderPost documentHeader) 伝票ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  PurchaseHeaderPost documentHeader)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  PurchaseHeaderPost documentHeader)
                           throws SAPGeneralSystemException
伝票ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
documentHeader - PurchaseHeaderPost
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamHeaderText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText
すべての実装インタフェース:
Serializable
public final class ParamHeaderText
extends Object
implements Serializable

ヘッダテキストパラメータ設定クラス
機能は以下の通り

  • ヘッダテキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List headerTextList)
ヘッダテキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List headerTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ヘッダテキストに値をセットします。

パラメータ:
bapiController - BapiController
headerTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamItem
すべての実装インタフェース:
Serializable
public final class ParamItem
extends Object
implements Serializable

明細パラメータ設定クラス
機能は以下の通り

  • 明細のパラメータを設定します。

関連項目:
直列化された形式

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamItemText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText
すべての実装インタフェース:
Serializable
public final class ParamItemText
extends Object
implements Serializable

明細テキストパラメータ設定クラス
機能は以下の通り

  • 明細テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List itemTextList)
明細テキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemTextList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細テキストに値をセットします。

パラメータ:
bapiController - BapiController
itemTextList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamLimits (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamLimits

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits
すべての実装インタフェース:
Serializable
public final class ParamLimits
extends Object
implements Serializable

外注制限パラメータ設定クラス
機能は以下の通り

  • 外注制限のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List limitsList)
外注制限に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List limitsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
外注制限に値をセットします。

パラメータ:
bapiController - BapiController
limitsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartner (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPartner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner
すべての実装インタフェース:
Serializable
public final class ParamPartner
extends Object
implements Serializable

得意先インポートパラメータ設定クラス
機能は以下の通り

  • 得意先のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List partnerList)
得意先に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnerList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
得意先に値をセットします。

パラメータ:
bapiController - BapiController
partnerList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamProfitSegment (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamProfitSegment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment
すべての実装インタフェース:
Serializable
public final class ParamProfitSegment
extends Object
implements Serializable

入出庫予定パラメータ設定クラス
機能は以下の通り

  • 入出庫予定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List profitSegmentList)
入出庫予定ヘッダに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List profitSegmentList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
入出庫予定ヘッダに値をセットします。

パラメータ:
bapiController - BapiController
profitSegmentList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseAccount (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount
すべての実装インタフェース:
Serializable
public final class ParamPurchaseAccount
extends Object
implements Serializable

勘定設定パラメータ設定クラス
機能は以下の通り

  • 勘定設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List purchaseAccountList)
勘定設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseAccountList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
勘定設定に値をセットします。

パラメータ:
bapiController - BapiController
purchaseAccountList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPurchaseSchedule (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamPurchaseSchedule

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule
すべての実装インタフェース:
Serializable
public final class ParamPurchaseSchedule
extends Object
implements Serializable

納入日程パラメータ設定クラス
機能は以下の通り

  • 納入日程のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, List purchaseScheduleList)
納入日程に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List purchaseScheduleList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程に値をセットします。

パラメータ:
bapiController - BapiController
purchaseScheduleList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVendorAddress (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamVendorAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress
すべての実装インタフェース:
Serializable
public final class ParamVendorAddress
extends Object
implements Serializable

仕入先住所パラメータ設定クラス
機能は以下の通り

  • 仕入先住所のパラメータを設定します。

関連項目:
直列化された形式

クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamVersions (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ParamVersions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions
すべての実装インタフェース:
Serializable
public final class ParamVersions
extends Object
implements Serializable

バージョン管理パラメータ設定ラクラス
機能は以下の通り

  • バージョン管理のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, Versions versions)
バージョン管理に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  Versions versions)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
バージョン管理に値をセットします。

パラメータ:
bapiController - BapiController
versions - Versions
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Partner (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Partner

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Partner
すべての実装インタフェース:
Serializable
public class Partner
extends Object
implements Serializable

取引先情報クラス
機能は以下の通り

  • 取引先情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Partner()
取引先を作成します。
Partner(int index)
取引先を作成します。
メソッドの概要
String | getBuspartno() 取引先の仕入先マスタコードを取得します。
String | getLangu() 言語キーを取得します。
int | getPaIndex() レコード番号を取得します｡
String | getPartnerdesc() 言語別取引先機能テキストを取得します。
void | setBuspartno(String strBuspartno) 取引先の仕入先マスタコードを設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setPaIndex(int paIndex) レコード番号を設定します｡
void | setPartnerdesc(String strPartnerdesc) 言語別取引先機能テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Partner

public Partner()
取引先を作成します。

Partner

public Partner(int index)
取引先を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPartnerdesc

public String getPartnerdesc()
言語別取引先機能テキストを取得します。

戻り値:
srtPartnerdesc 言語別取引先機能テキスト

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getBuspartno

public String getBuspartno()
取引先の仕入先マスタコードを取得します。

戻り値:
srtBuspartno 取引先の仕入先マスタコード

getPaIndex

public int getPaIndex()
レコード番号を取得します｡

戻り値:
paIndex レコード番号

setPartnerdesc

public void setPartnerdesc(String strPartnerdesc)
言語別取引先機能テキストを設定します。

パラメータ:
strPartnerdesc - 言語別取引先機能テキスト

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setBuspartno

public void setBuspartno(String strBuspartno)
取引先の仕入先マスタコードを設定します。

パラメータ:
strBuspartno - 取引先の仕入先マスタコード

setPaIndex

public void setPaIndex(int paIndex)
レコード番号を設定します｡

パラメータ:
paIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PlantSelection (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PlantSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection
すべての実装インタフェース:
Serializable
public class PlantSelection
extends Selection
implements Serializable

プラントの選択オプションクラス
機能は以下の通り

  • プラントの選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PlantSelection()
プラントの選択オプション情報を作成します。
PlantSelection(int index)
Sプラントの選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getPlantHigh() 対象プラント 終了を取得します。
String | getPlantLow() 対象プラント 開始を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setPlantHigh(String strPlantHigh) 対象プラント 終了を設定します。
void | setPlantLow(String strPlantLow) 対象プラント 開始を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PlantSelection

public PlantSelection()
プラントの選択オプション情報を作成します。

PlantSelection

public PlantSelection(int index)
Sプラントの選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPlantLow

public String getPlantLow()
対象プラント 開始を取得します。

戻り値:
srtPlantLow 対象プラント 開始

getPlantHigh

public String getPlantHigh()
対象プラント 終了を取得します。

戻り値:
srtPlantHigh 対象プラント 終了

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setPlantLow

public void setPlantLow(String strPlantLow)
対象プラント 開始を設定します。

パラメータ:
strPlantLow - 対象プラント 開始

setPlantHigh

public void setPlantHigh(String strPlantHigh)
対象プラント 終了を設定します。

パラメータ:
strPlantHigh - 対象プラント 終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ProfitSegment (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス ProfitSegment

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment
すべての実装インタフェース:
Serializable
public class ProfitSegment
extends Object
implements Serializable

入出庫予定情報クラス
機能は以下の通り

  • 入出庫予定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ProfitSegment()
入出庫予定を作成します。
ProfitSegment(int index)
入出庫予定を作成します。
メソッドの概要
String | getFieldname() 項目名を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
int | getPrIndex() レコード番号を取得します｡
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getValue() CO-PA 特性値を取得します。
void | setFieldname(String strFieldname) 項目名を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPrIndex(int prIndex) レコード番号を設定します｡
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setValue(String strValue) CO-PA 特性値を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ProfitSegment

public ProfitSegment()
入出庫予定を作成します。

ProfitSegment

public ProfitSegment(int index)
入出庫予定を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getFieldname

public String getFieldname()
項目名を取得します。

戻り値:
srtFieldname 項目名

getValue

public String getValue()
CO-PA 特性値を取得します。

戻り値:
srtValue CO-PA 特性値

getPrIndex

public int getPrIndex()
レコード番号を取得します｡

戻り値:
prIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setFieldname

public void setFieldname(String strFieldname)
項目名を設定します。

パラメータ:
strFieldname - 項目名

setValue

public void setValue(String strValue)
CO-PA 特性値を設定します。

パラメータ:
strValue - CO-PA 特性値

setPrIndex

public void setPrIndex(int prIndex)
レコード番号を設定します｡

パラメータ:
prIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseAccount (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseAccount

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount
すべての実装インタフェース:
Serializable
public class PurchaseAccount
extends Object
implements Serializable

購買発注伝票勘定情報クラス
機能は以下の通り

  • 購買発注伝票勘定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseAccount()
購買発注伝票明細を作成します。
PurchaseAccount(int index)
購買発注伝票明細を作成します。
メソッドの概要
int | getAcIndex() レコード番号を取得します｡
String | getActivity() 作業番号を取得します。
String | getActtype() 活動タイプを取得します。
String | getAssetNo() 資産番号を取得します。
String | getBusArea() 事業領域を取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCoArea() 管理領域を取得します。
String | getCoBusproc() 業務プロセスを取得します。
String | getCostcenter() 原価センタを取得します。
String | getCostobject() 原価対象を取得します。
String | getCreatDate() レコード登録日を取得します。
String | getDeleteInd() 削除フラグ: 購買伝票勘定設定を取得します。
String | getDistrPerc() 配賦率 % (複数勘定設定)を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
String | getGlAccount() G/L 勘定コードを取得します。
String | getGrantNbr() 補助金を取得します。
String | getGrRcpt() 受領者を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getNetValue() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getNetwork() 勘定割当のネットワーク番号を取得します。
String | getNondItax() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getOrderid() 指図番号を取得します。
String | getPartAcct() 取引先勘定コードを取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getQuantity() 数量を取得します。
String | getRecInd() リカバリフラグを取得します。
String | getRefDate() 決済の参照日付を取得します。
String | getResDoc() 用途指定予算の伝票番号を取得します。
String | getResItem() 用途指定予算: 伝票明細を取得します。
String | getRlEstKey() 不動産管理対象の内部キーを取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSdDoc() 販売管理伝票番号を取得します。
String | getSerialNo() 勘定設定の連続番号を取得します。
String | getSubNumber() 資産補助番号を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
String | getWbsElement() WBS 要素を取得します。
void | setAcIndex(int acIndex) レコード番号を設定します｡
void | setActivity(String strActivity) 作業番号を設定します。
void | setActtype(String strActtype) 活動タイプを設定します。
void | setAssetNo(String strAssetNo) 資産番号を設定します。
void | setBusArea(String strBusArea) 事業領域を設定します。
void | setCmmtItem(String strCmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String strCmmtItemLong) 資金予算コードを設定します。
void | setCoArea(String strCoArea) 管理領域を設定します。
void | setCoBusproc(String strCoBusproc) 業務プロセスを設定します。
void | setCostcenter(String strCostcenter) 原価センタを設定します。
void | setCostobject(String strCostobject) 原価対象を設定します。
void | setCreatDate(String strCreatDate) レコード登録日を設定します。
void | setDeleteInd(String strDeleteInd) 削除フラグ: 購買伝票勘定設定を設定します。
void | setDistrPerc(String strDistrPerc) 配賦率 % (複数勘定設定)を設定します。
void | setFuncArea(String strFuncArea) 機能領域を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFund(String strFund) 会計区分を設定します。
void | setFundsCtr(String strFundsCtr) 予算センタを設定します。
void | setGlAccount(String strGlAccount) G/L 勘定コードを設定します。
void | setGrantNbr(String strGrantNbr) 補助金を設定します。
void | setGrRcpt(String strGrRcpt) 受領者を設定します。
void | setItmNumber(String strItmNumber) 販売伝票明細を設定します。
void | setNetValue(String strNetValue) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setNetwork(String strNetwork) 勘定割当のネットワーク番号を設定します。
void | setNondItax(String strNondItax) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setOrderid(String strOrderid) 指図番号を設定します。
void | setPartAcct(String strPartAcct) 取引先勘定コードを設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setProfitCtr(String strProfitCtr) 利益センタを設定します。
void | setQuantity(String strQuantity) 数量を設定します。
void | setRecInd(String strRecInd) リカバリフラグを設定します。
void | setRefDate(String strRefDate) 決済の参照日付を設定します。
void | setResDoc(String strResDoc) 用途指定予算の伝票番号を設定します。
void | setResItem(String strResItem) 用途指定予算: 伝票明細を設定します。
void | setRlEstKey(String strRlEstKey) 不動産管理対象の内部キーを設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
void | setSdDoc(String strSdDoc) 販売管理伝票番号を設定します。
void | setSerialNo(String strSerialNo) 勘定設定の連続番号を設定します。
void | setSubNumber(String strSubNumber) 資産補助番号を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnloadPt(String strUnloadPt) 荷渡ポイントを設定します。
void | setWbsElement(String strWbsElement) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseAccount

public PurchaseAccount()
購買発注伝票明細を作成します。

PurchaseAccount

public PurchaseAccount(int index)
購買発注伝票明細を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSerialNo

public String getSerialNo()
勘定設定の連続番号を取得します。

戻り値:
srtSerialNo 勘定設定の連続番号

getDeleteInd

public String getDeleteInd()
削除フラグ: 購買伝票勘定設定を取得します。

戻り値:
srtDeleteInd 削除フラグ: 購買伝票勘定設定

getCreatDate

public String getCreatDate()
レコード登録日を取得します。

戻り値:
srtCreatDate レコード登録日

getQuantity

public String getQuantity()
数量を取得します。

戻り値:
srtQuantity 数量

getDistrPerc

public String getDistrPerc()
配賦率 % (複数勘定設定)を取得します。

戻り値:
srtDistrPerc 配賦率 % (複数勘定設定)

getNetValue

public String getNetValue()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
srtNetValue BAPI の通貨額 (小数点以下９桁)

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
srtGlAccount G/L 勘定コード

getBusArea

public String getBusArea()
事業領域を取得します。

戻り値:
srtBusArea 事業領域

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
srtCostcenter 原価センタ

getSdDoc

public String getSdDoc()
販売管理伝票番号を取得します。

戻り値:
srtSdDoc 販売管理伝票番号

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
srtItmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
srtSchedLine 納入日程行

getAssetNo

public String getAssetNo()
資産番号を取得します。

戻り値:
srtAssetNo 資産番号

getSubNumber

public String getSubNumber()
資産補助番号を取得します。

戻り値:
srtSubNumber 資産補助番号

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
srtOrderid 指図番号

getGrRcpt

public String getGrRcpt()
受領者を取得します。

戻り値:
srtGrRcpt 受領者

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
srtUnloadPt 荷渡ポイント

getCoArea

public String getCoArea()
管理領域を取得します。

戻り値:
srtCoArea 管理領域

getCostobject

public String getCostobject()
原価対象を取得します。

戻り値:
srtCostobject 原価対象

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
srtProfitCtr 利益センタ

getWbsElement

public String getWbsElement()
WBS 要素を取得します。

戻り値:
srtWbsElement WBS 要素

getNetwork

public String getNetwork()
勘定割当のネットワーク番号を取得します。

戻り値:
srtNetwork 勘定割当のネットワーク番号

getRlEstKey

public String getRlEstKey()
不動産管理対象の内部キーを取得します。

戻り値:
srtRlEstKey 不動産管理対象の内部キー

getPartAcct

public String getPartAcct()
取引先勘定コードを取得します。

戻り値:
srtPartAcct 取引先勘定コード

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
srtCmmtItem 資金予算コード

getRecInd

public String getRecInd()
リカバリフラグを取得します。

戻り値:
srtRecInd リカバリフラグ

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
srtFundsCtr 予算センタ

getFund

public String getFund()
会計区分を取得します。

戻り値:
srtFund 会計区分

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
srtFuncArea 機能領域

getRefDate

public String getRefDate()
決済の参照日付を取得します。

戻り値:
srtRefDate 決済の参照日付

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
srtTaxCode 消費税コード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getNondItax

public String getNondItax()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
srtNondItax BAPI の通貨額 (小数点以下９桁)

getActtype

public String getActtype()
活動タイプを取得します。

戻り値:
srtActtype 活動タイプ

getCoBusproc

public String getCoBusproc()
業務プロセスを取得します。

戻り値:
srtCoBusproc 業務プロセス

getResDoc

public String getResDoc()
用途指定予算の伝票番号を取得します。

戻り値:
srtResDoc 用途指定予算の伝票番号

getResItem

public String getResItem()
用途指定予算: 伝票明細を取得します。

戻り値:
srtResItem 用途指定予算: 伝票明細

getActivity

public String getActivity()
作業番号を取得します。

戻り値:
srtActivity 作業番号

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
srtGrantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
srtCmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getAcIndex

public int getAcIndex()
レコード番号を取得します｡

戻り値:
acIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSerialNo

public void setSerialNo(String strSerialNo)
勘定設定の連続番号を設定します。

パラメータ:
strSerialNo - 勘定設定の連続番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグ: 購買伝票勘定設定を設定します。

パラメータ:
strDeleteInd - 削除フラグ: 購買伝票勘定設定

setCreatDate

public void setCreatDate(String strCreatDate)
レコード登録日を設定します。

パラメータ:
strCreatDate - レコード登録日

setQuantity

public void setQuantity(String strQuantity)
数量を設定します。

パラメータ:
strQuantity - 数量

setDistrPerc

public void setDistrPerc(String strDistrPerc)
配賦率 % (複数勘定設定)を設定します。

パラメータ:
strDistrPerc - 配賦率 % (複数勘定設定)

setNetValue

public void setNetValue(String strNetValue)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
strNetValue - BAPI の通貨額 (小数点以下９桁)

setGlAccount

public void setGlAccount(String strGlAccount)
G/L 勘定コードを設定します。

パラメータ:
strGlAccount - G/L 勘定コード

setBusArea

public void setBusArea(String strBusArea)
事業領域を設定します。

パラメータ:
strBusArea - 事業領域

setCostcenter

public void setCostcenter(String strCostcenter)
原価センタを設定します。

パラメータ:
strCostcenter - 原価センタ

setSdDoc

public void setSdDoc(String strSdDoc)
販売管理伝票番号を設定します。

パラメータ:
strSdDoc - 販売管理伝票番号

setItmNumber

public void setItmNumber(String strItmNumber)
販売伝票明細を設定します。

パラメータ:
strItmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setAssetNo

public void setAssetNo(String strAssetNo)
資産番号を設定します。

パラメータ:
strAssetNo - 資産番号

setSubNumber

public void setSubNumber(String strSubNumber)
資産補助番号を設定します。

パラメータ:
strSubNumber - 資産補助番号

setOrderid

public void setOrderid(String strOrderid)
指図番号を設定します。

パラメータ:
strOrderid - 指図番号

setGrRcpt

public void setGrRcpt(String strGrRcpt)
受領者を設定します。

パラメータ:
strGrRcpt - 受領者

setUnloadPt

public void setUnloadPt(String strUnloadPt)
荷渡ポイントを設定します。

パラメータ:
strUnloadPt - 荷渡ポイント

setCoArea

public void setCoArea(String strCoArea)
管理領域を設定します。

パラメータ:
strCoArea - 管理領域

setCostobject

public void setCostobject(String strCostobject)
原価対象を設定します。

パラメータ:
strCostobject - 原価対象

setProfitCtr

public void setProfitCtr(String strProfitCtr)
利益センタを設定します。

パラメータ:
strProfitCtr - 利益センタ

setWbsElement

public void setWbsElement(String strWbsElement)
WBS 要素を設定します。

パラメータ:
strWbsElement - WBS 要素

setNetwork

public void setNetwork(String strNetwork)
勘定割当のネットワーク番号を設定します。

パラメータ:
strNetwork - 勘定割当のネットワーク番号

setRlEstKey

public void setRlEstKey(String strRlEstKey)
不動産管理対象の内部キーを設定します。

パラメータ:
strRlEstKey - 不動産管理対象の内部キー

setPartAcct

public void setPartAcct(String strPartAcct)
取引先勘定コードを設定します。

パラメータ:
strPartAcct - 取引先勘定コード

setCmmtItem

public void setCmmtItem(String strCmmtItem)
資金予算コードを設定します。

パラメータ:
strCmmtItem - 資金予算コード

setRecInd

public void setRecInd(String strRecInd)
リカバリフラグを設定します。

パラメータ:
strRecInd - リカバリフラグ

setFundsCtr

public void setFundsCtr(String strFundsCtr)
予算センタを設定します。

パラメータ:
strFundsCtr - 予算センタ

setFund

public void setFund(String strFund)
会計区分を設定します。

パラメータ:
strFund - 会計区分

setFuncArea

public void setFuncArea(String strFuncArea)
機能領域を設定します。

パラメータ:
strFuncArea - 機能領域

setRefDate

public void setRefDate(String strRefDate)
決済の参照日付を設定します。

パラメータ:
strRefDate - 決済の参照日付

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setNondItax

public void setNondItax(String strNondItax)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
strNondItax - BAPI の通貨額 (小数点以下９桁)

setActtype

public void setActtype(String strActtype)
活動タイプを設定します。

パラメータ:
strActtype - 活動タイプ

setCoBusproc

public void setCoBusproc(String strCoBusproc)
業務プロセスを設定します。

パラメータ:
strCoBusproc - 業務プロセス

setResDoc

public void setResDoc(String strResDoc)
用途指定予算の伝票番号を設定します。

パラメータ:
strResDoc - 用途指定予算の伝票番号

setResItem

public void setResItem(String strResItem)
用途指定予算: 伝票明細を設定します。

パラメータ:
strResItem - 用途指定予算: 伝票明細

setActivity

public void setActivity(String strActivity)
作業番号を設定します。

パラメータ:
strActivity - 作業番号

setGrantNbr

public void setGrantNbr(String strGrantNbr)
補助金を設定します。

パラメータ:
strGrantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String strCmmtItemLong)
資金予算コードを設定します。

パラメータ:
strCmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setAcIndex

public void setAcIndex(int acIndex)
レコード番号を設定します｡

パラメータ:
acIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseGetItemSrel (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseGetItemSrel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel
すべての実装インタフェース:
Serializable
public class PurchaseGetItemSrel
extends ReferenceController
implements Serializable

伝票承認対象一覧情報クラス
機能は以下の通り

  • 伝票承認対象一覧を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrel(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
承認対象一覧を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先マスタ詳細を作成します。
String | getItemsForRelease() 区分: 承認待ち購買発注のみ照会を取得します。
ArrayList | getPurchaseHeadersList() 伝票ヘッダ一覧を取得します｡
ArrayList | getPurchaseItemsList() 伝票明細一覧を取得します｡
String | getRelCode() 承認コードを取得します。
String | getRelGroup() 承認グループを取得します。
void | setItemsForRelease(String strItemsForRelease) 区分: 承認待ち購買発注のみ照会を設定します。
void | setPurchaseHeadersList(ArrayList purchaseHeadersList) 伝票ヘッダ一覧を取得します｡を設定します。
void | setPurchaseItemsList(ArrayList purchaseItemsList) 伝票明細一覧を取得します｡を設定します。
void | setRelCode(String strRelCode) 承認コードを設定します。
void | setRelGroup(String strRelGroup) 承認グループを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseGetItemSrel

public PurchaseGetItemSrel(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

PurchaseGetItemSrel

public PurchaseGetItemSrel(String relGroup,
                           String relCode,
                           String itemsForRelease,
                           SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPPurchaseAppException,
                           SAPPurchaseSystemException
承認対象一覧を作成します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先マスタ詳細を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelCode

public void setRelCode(String strRelCode)
承認コードを設定します。

パラメータ:
strRelCode - 承認コード

setItemsForRelease

public void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。

パラメータ:
strItemsForRelease - 区分: 承認待ち購買発注のみ照会

setPurchaseHeadersList

public void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を取得します｡を設定します。

パラメータ:
purchaseHeadersList - 伝票ヘッダ一覧を取得します｡

setPurchaseItemsList

public void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を取得します｡を設定します。

パラメータ:
purchaseItemsList - 伝票明細一覧を取得します｡

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup 承認グループ

getRelCode

public String getRelCode()
承認コードを取得します。

戻り値:
srtRelCode 承認コード

getItemsForRelease

public String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。

戻り値:
srtItemsForRelease 区分: 承認待ち購買発注のみ照会

getPurchaseHeadersList

public ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

getPurchaseItemsList

public ArrayList getPurchaseItemsList()
伝票明細一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseGetItemSrelController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseGetItemSrelController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController
すべての実装インタフェース:
Serializable
public class PurchaseGetItemSrelController
extends Object
implements Serializable

伝票の承認対象一覧取得コントローラクラス
機能は以下の通り

  • 伝票の承認対象一覧を取得します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseGetItemSrelController()
コンストラクタ生成
PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String relGroup, String relCode, String itemsForRelease, SapClient sapClient)
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
メソッドの概要
 void executeBapi()
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
 String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。
 PurchaseGetItemSrel getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡
 ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します。
 ArrayList getPurchaseItemsList()
伝票明細一覧を取得します。
 String getRelCode()
承認コードを取得します。
 String getRelGroup()
承認グループを取得します。
 void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。
 void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を設定します。
 void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を設定します。
 void setRelCode(String strRelCode)
承認コードを設定します。
 void setRelGroup(String strRelGroup)
承認グループを設定します。
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseGetItemSrelController

public PurchaseGetItemSrelController()
コンストラクタ生成

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(String relGroup,
                                     String relCode,
                                     String itemsForRelease)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPPurchaseAppException,
                                     SAPPurchaseSystemException
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分 「X」：承認可能な購買発注のみ照会 「ブランク」：すでに承認された購買発注のみ照会
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

PurchaseGetItemSrelController

public PurchaseGetItemSrelController(String relGroup,
                                     String relCode,
                                     String itemsForRelease,
                                     SapClient sapClient)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPPurchaseAppException,
                                     SAPPurchaseSystemException
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。

パラメータ:
relGroup - 承認グループ
relCode - 承認コード
itemsForRelease - 照会区分
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト 「X」：承認可能な購買発注のみ照会 「ブランク」：すでに承認された購買発注のみ照会
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelCode

public void setRelCode(String strRelCode)
承認コードを設定します。

パラメータ:
strRelCode - 承認コード

setItemsForRelease

public void setItemsForRelease(String strItemsForRelease)
区分: 承認待ち購買発注のみ照会を設定します。

パラメータ:
strItemsForRelease - 区分: 承認待ち購買発注のみ照会

setPurchaseHeadersList

public void setPurchaseHeadersList(ArrayList purchaseHeadersList)
伝票ヘッダ一覧を設定します。

パラメータ:
purchaseHeadersList - 伝票ヘッダ一覧

setPurchaseItemsList

public void setPurchaseItemsList(ArrayList purchaseItemsList)
伝票明細一覧を設定します。

パラメータ:
purchaseItemsList - 伝票明細一覧

getPurchaseGetItemSrel

public PurchaseGetItemSrel getPurchaseGetItemSrel()
承認対象一覧情報を取得します｡

戻り値:
SupplierDetail

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup 承認グループ

getRelCode

public String getRelCode()
承認コードを取得します。

戻り値:
srtRelCode 承認コード

getItemsForRelease

public String getItemsForRelease()
区分: 承認待ち購買発注のみ照会を取得します。

戻り値:
srtItemsForRelease 区分: 承認待ち購買発注のみ照会

getPurchaseHeadersList

public ArrayList getPurchaseHeadersList()
伝票ヘッダ一覧を取得します。

戻り値:
ArrayList 伝票ヘッダ一覧

getPurchaseItemsList

public ArrayList getPurchaseItemsList()
伝票明細一覧を取得します。

戻り値:
ArrayList 伝票明細一覧

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeader (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeader

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseHeaderPost, PurchaseHeaders
public class PurchaseHeader
extends Object
implements Serializable

購買発注ヘッダ情報スーパークラス
機能は以下の通り

  • 購買発注のヘッダ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeader()
購買発注伝票ヘッダを作成します。
メソッドの概要
String | getAgreement() 購買契約番号を取得します｡
String | getCreatedBy() 登録者名を取得します｡
String | getCurrency() 通貨コードを取得します｡
String | getCurrencyIso() ISO通貨コードを取得します｡
String | getCustomer() 得意先コード1を取得します｡
String | getDeleteInd() 削除フラグを取得します｡
String | getDiffInv() 仕入先と請求元が異なる場合の供給元のコードを取得します｡
String | getDocDate() 購買伝票日付を取得します｡
String | getDocType() 伝票タイプを取得します｡
String | getDscnt1To() 現金割引日数1を取得します｡
String | getDscnt2To() 現金割引日数2を取得します｡
String | getDscnt3To() 現金割引日数3を取得します｡
String | getExchRate() 換算レートを取得します｡
String | getExRateFx() 換算レート固定区分を取得します｡
String | getGrMessage() 入庫メッセージ区分を取得します｡
String | getIncoterms1() インコタームズ1を取得します｡
String | getIncoterms2() インコタームズ2を取得します｡
String | getItemIntvl() 明細番号間隔を取得します｡
String | getLogsystem() 論理システムを取得します｡
String | getOurRef() 社内参照番号を取得します｡
String | getPmnttrms() 支払条件キーを取得します｡
String | getPoNumber() 購買伝票を取得します｡
String | getPurchOrg() 購買組織を取得します｡
String | getPurGroup() 購買グループを取得します｡
String | getQuotation() 見積番号を取得します｡
String | getQuotDate() 見積提出日を取得します｡
String | getRef_1() 得意先/仕入先の内部参照コードを取得します｡
String | getRelStatus() 承認状況を取得します｡
String | getSalesPers() 仕入先営業担当者を取得します｡
String | getStatus() 伝票ステータスを取得します｡
String | getSubitemint() 副明細の明細間隔を取得します｡
String | getSupplPlnt() 在庫転送オーダーにおける供給(出庫)プラントを取得します｡
String | getSupplVend() 供給仕入先を取得します｡
String | getTelephone() 仕入先電話番号を取得します｡
String | getVendor() 仕入先勘定コードを取得します｡
String | getVperEnd() 有効期間終了日を取得します｡
String | getVperStart() 有効期間開始日を取得します｡
String | getWarranty() 保証日を取得します｡
void | setAgreement(String strAgreement) 購買契約番号を設定します｡
void | setCreatedBy(String strCreatedBy) 登録者名を設定します｡
void | setCurrency(String strCurrency) 通貨コードを設定します｡
void | setCurrencyIso(String strCurrencyIso) ISO通貨コードを設定します｡
void | setCustomer(String strCustomer) 得意先コード1を設定します｡
void | setDeleteInd(String strDeleteInd) 削除フラグを設定します｡
void | setDiffInv(String strDiffInv) 仕入先と請求元が異なる場合の請求元コードを設定します｡
void | setDocDate(String strDocDate) 購買伝票日付を設定します｡
void | setDocType(String strDocType) 伝票タイプを設定します｡
void | setDscnt1To(String strDscnt1To) 現金割引日数1を設定します｡
void | setDscnt2To(String strDscnt2To) 現金割引日数2を設定します｡
void | setDscnt3To(String strDscnt3To) 現金割引日数3を設定します｡
void | setExchRate(String strExchRate) 換算レートを設定します｡
void | setExRateFx(String strExRateFx) 換算レート固定区分を設定します｡
void | setGrMessage(String strGrMessage) 入庫メッセージ区分を設定します｡
void | setIncoterms1(String strIncoterms1) インコタームズ1を設定します｡
void | setIncoterms2(String strIncoterms2) インコタームズ2を設定します｡
void | setItemIntvl(String strItemIntvl) 明細番号間隔を設定します｡
void | setLogsystem(String strLogsystem) 論理システムを設定します｡
void | setOurRef(String strOurRef) 社内参照番号を設定します｡
void | setPmnttrms(String strPmnttrms) 支払条件キーを設定します｡
void | setPoNumber(String strPonNmber) 購買伝票番号を設定します｡
void | setPurchOrg(String strPurchOrg) 購買組織を設定します｡
void | setPurGroup(String strPurGroup) 購買グループを設定します｡
void | setQuotation(String strQuotation) 見積番号を設定します｡
void | setQuotDate(String strQuotDate) 見積提出日を設定します｡
void | setRef_1(String strRef1) 得意先/仕入先の内部参照コードを設定します｡
void | setRelStatus(String strRelStatus) 承認状況を設定します｡
void | setSalesPers(String strSalesPers) 仕入先営業担当者を設定します｡
void | setStatus(String strStatus) ステータスを設定します｡
void | setSubitemint(String strSubitemint) 副明細の明細間隔を設定します｡
void | setSupplPlnt(String strSupplPlnt) 在庫転送オーダーにおける供給(出庫)プラントを設定します｡
void | setSupplVend(String strSupplVend) 供給仕入先を設定します｡
void | setTelephone(String strTelephone) 仕入先電話番号を設定します｡
void | setVendor(String strVendor) 仕入先勘定コードを設定します｡
void | setVperEnd(String strVperEnd) 有効期間終了日を設定します｡
void | setVperStart(String strVperStart) 有効期間開始日を設定します｡
void | setWarranty(String strWarranty) 保証日を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeader

public PurchaseHeader()
購買発注伝票ヘッダを作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票を取得します｡

戻り値:
strPoNumber

getDocType

public String getDocType()
伝票タイプを取得します｡

戻り値:
strDocType

getDeleteInd

public String getDeleteInd()
削除フラグを取得します｡

戻り値:
strDeleteInd

getStatus

public String getStatus()
伝票ステータスを取得します｡

戻り値:
strStatus

getCreatedBy

public String getCreatedBy()
登録者名を取得します｡

戻り値:
strCreatedBy

getItemIntvl

public String getItemIntvl()
明細番号間隔を取得します｡

戻り値:
strItemIntvl

getVendor

public String getVendor()
仕入先勘定コードを取得します｡

戻り値:
strVendor

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します｡

戻り値:
strPmnttrms

getDscnt1To

public String getDscnt1To()
現金割引日数1を取得します｡

戻り値:
strDscnt1To

getDscnt2To

public String getDscnt2To()
現金割引日数2を取得します｡

戻り値:
strDscnt2to

getDscnt3To

public String getDscnt3To()
現金割引日数3を取得します｡

戻り値:
strDscnt3To

getPurchOrg

public String getPurchOrg()
購買組織を取得します｡

戻り値:
strPutchOrg

getPurGroup

public String getPurGroup()
購買グループを取得します｡

戻り値:
strPurGroup

getCurrency

public String getCurrency()
通貨コードを取得します｡

戻り値:
strCurrency

getCurrencyIso

public String getCurrencyIso()
ISO通貨コードを取得します｡

戻り値:
strCurrencyIso

getExchRate

public String getExchRate()
換算レートを取得します｡

戻り値:
strExchRate

getExRateFx

public String getExRateFx()
換算レート固定区分を取得します｡

戻り値:
strExRateFx

getDocDate

public String getDocDate()
購買伝票日付を取得します｡

戻り値:
strDocDate

getVperStart

public String getVperStart()
有効期間開始日を取得します｡

戻り値:
strVperStart

getVperEnd

public String getVperEnd()
有効期間終了日を取得します｡

戻り値:
strVperEnd

getWarranty

public String getWarranty()
保証日を取得します｡

戻り値:
strWarranty

getQuotation

public String getQuotation()
見積番号を取得します｡

戻り値:
strQuotation

getQuotDate

public String getQuotDate()
見積提出日を取得します｡

戻り値:
strQuotDate

getRef_1

public String getRef_1()
得意先/仕入先の内部参照コードを取得します｡

戻り値:
strRef1

getSalesPers

public String getSalesPers()
仕入先営業担当者を取得します｡

戻り値:
strSalesPers

getTelephone

public String getTelephone()
仕入先電話番号を取得します｡

戻り値:
strTelephone

getSupplVend

public String getSupplVend()
供給仕入先を取得します｡

戻り値:
strSupplVend

getCustomer

public String getCustomer()
得意先コード1を取得します｡

戻り値:
strCustomer

getAgreement

public String getAgreement()
購買契約番号を取得します｡

戻り値:
strAgreement

getGrMessage

public String getGrMessage()
入庫メッセージ区分を取得します｡

戻り値:
strGrMessage

getSupplPlnt

public String getSupplPlnt()
在庫転送オーダーにおける供給(出庫)プラントを取得します｡

戻り値:
strSupplPlnt

getIncoterms1

public String getIncoterms1()
インコタームズ1を取得します｡

戻り値:
strIncoterms1

getIncoterms2

public String getIncoterms2()
インコタームズ2を取得します｡

戻り値:
strIncoterms2

getDiffInv

public String getDiffInv()
仕入先と請求元が異なる場合の供給元のコードを取得します｡

戻り値:
strDiffInv

getOurRef

public String getOurRef()
社内参照番号を取得します｡

戻り値:
strOurRef

getLogsystem

public String getLogsystem()
論理システムを取得します｡

戻り値:
strLogsystem

getSubitemint

public String getSubitemint()
副明細の明細間隔を取得します｡

戻り値:
strSubitemint

getRelStatus

public String getRelStatus()
承認状況を取得します｡

戻り値:
strRelStatus

setPoNumber

public void setPoNumber(String strPonNmber)
購買伝票番号を設定します｡

パラメータ:
strPonNmber - 購買伝票番号

setDocType

public void setDocType(String strDocType)
伝票タイプを設定します｡

パラメータ:
strDocType - 伝票タイプ

setDeleteInd

public void setDeleteInd(String strDeleteInd)
削除フラグを設定します｡

パラメータ:
strDeleteInd - 削除フラグ

setStatus

public void setStatus(String strStatus)
ステータスを設定します｡

パラメータ:
strStatus - ステータス

setCreatedBy

public void setCreatedBy(String strCreatedBy)
登録者名を設定します｡

パラメータ:
strCreatedBy - 登録者名

setItemIntvl

public void setItemIntvl(String strItemIntvl)
明細番号間隔を設定します｡

パラメータ:
strItemIntvl - 明細番号間隔

setVendor

public void setVendor(String strVendor)
仕入先勘定コードを設定します｡

パラメータ:
strVendor - 仕入先勘定コード

setPmnttrms

public void setPmnttrms(String strPmnttrms)
支払条件キーを設定します｡

パラメータ:
strPmnttrms - 支払条件キー

setDscnt1To

public void setDscnt1To(String strDscnt1To)
現金割引日数1を設定します｡

パラメータ:
strDscnt1To - 現金割引日数1

setDscnt2To

public void setDscnt2To(String strDscnt2To)
現金割引日数2を設定します｡

パラメータ:
strDscnt2To - 現金割引日数2

setDscnt3To

public void setDscnt3To(String strDscnt3To)
現金割引日数3を設定します｡

パラメータ:
strDscnt3To - 現金割引日数3

setPurchOrg

public void setPurchOrg(String strPurchOrg)
購買組織を設定します｡

パラメータ:
strPurchOrg - 購買組織

setPurGroup

public void setPurGroup(String strPurGroup)
購買グループを設定します｡

パラメータ:
strPurGroup - 購買グループ

setCurrency

public void setCurrency(String strCurrency)
通貨コードを設定します｡

パラメータ:
strCurrency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String strCurrencyIso)
ISO通貨コードを設定します｡

パラメータ:
strCurrencyIso - ISO通貨コード

setExchRate

public void setExchRate(String strExchRate)
換算レートを設定します｡

パラメータ:
strExchRate - 換算レート

setExRateFx

public void setExRateFx(String strExRateFx)
換算レート固定区分を設定します｡

パラメータ:
strExRateFx - 換算レート固定区分

setDocDate

public void setDocDate(String strDocDate)
購買伝票日付を設定します｡

パラメータ:
strDocDate - 購買伝票日付

setVperStart

public void setVperStart(String strVperStart)
有効期間開始日を設定します｡

パラメータ:
strVperStart - 有効期間開始日

setVperEnd

public void setVperEnd(String strVperEnd)
有効期間終了日を設定します｡

パラメータ:
strVperEnd - 有効期間終了日

setWarranty

public void setWarranty(String strWarranty)
保証日を設定します｡

パラメータ:
strWarranty - 保証日

setQuotation

public void setQuotation(String strQuotation)
見積番号を設定します｡

パラメータ:
strQuotation - 見積番号

setQuotDate

public void setQuotDate(String strQuotDate)
見積提出日を設定します｡

パラメータ:
strQuotDate - 見積提出日

setRef_1

public void setRef_1(String strRef1)
得意先/仕入先の内部参照コードを設定します｡

パラメータ:
strRef1 - 得意先/仕入先の内部参照コード

setSalesPers

public void setSalesPers(String strSalesPers)
仕入先営業担当者を設定します｡

パラメータ:
strSalesPers - 仕入先営業担当者

setTelephone

public void setTelephone(String strTelephone)
仕入先電話番号を設定します｡

パラメータ:
strTelephone - 仕入先電話番号

setSupplVend

public void setSupplVend(String strSupplVend)
供給仕入先を設定します｡

パラメータ:
strSupplVend - 供給仕入先

setCustomer

public void setCustomer(String strCustomer)
得意先コード1を設定します｡

パラメータ:
strCustomer - 得意先コード1

setAgreement

public void setAgreement(String strAgreement)
購買契約番号を設定します｡

パラメータ:
strAgreement - 購買契約番号

setGrMessage

public void setGrMessage(String strGrMessage)
入庫メッセージ区分を設定します｡

パラメータ:
strGrMessage - 入庫メッセージ区分

setSupplPlnt

public void setSupplPlnt(String strSupplPlnt)
在庫転送オーダーにおける供給(出庫)プラントを設定します｡

パラメータ:
strSupplPlnt - 在庫転送オーダーにおける供給(出庫)プラント

setIncoterms1

public void setIncoterms1(String strIncoterms1)
インコタームズ1を設定します｡

パラメータ:
strIncoterms1 - インコタームズ1

setIncoterms2

public void setIncoterms2(String strIncoterms2)
インコタームズ2を設定します｡

パラメータ:
strIncoterms2 - インコタームズ2

setDiffInv

public void setDiffInv(String strDiffInv)
仕入先と請求元が異なる場合の請求元コードを設定します｡

パラメータ:
strDiffInv - 仕入先と請求元が異なる場合の請求元コード

setOurRef

public void setOurRef(String strOurRef)
社内参照番号を設定します｡

パラメータ:
strOurRef - 社内参照番号

setLogsystem

public void setLogsystem(String strLogsystem)
論理システムを設定します｡

パラメータ:
strLogsystem - 論理システム

setSubitemint

public void setSubitemint(String strSubitemint)
副明細の明細間隔を設定します｡

パラメータ:
strSubitemint - 副明細の明細間隔

setRelStatus

public void setRelStatus(String strRelStatus)
承認状況を設定します｡

パラメータ:
strRelStatus - 承認状況

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeaderPost (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeaderPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost
すべての実装インタフェース:
Serializable
public class PurchaseHeaderPost
extends PurchaseHeader
implements Serializable

購買発注伝票ヘッダ情報クラス
機能は以下の通り

  • 購買発注伝票ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeaderPost()
購買発注伝票ヘッダを作成します。
メソッドの概要
String | getCollectNo() 一括番号を取得します。
String | getCompCode() 会社コードを取得します｡
String | getCreatDate() レコード登録日を取得します。
String | getDsctPct1() 割引率 1を取得します。
String | getDsctPct2() 割引率 2を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() 言語キーの ISO コードを取得します。
String | getPoRelInd() 承認区分: 購買伝票を取得します。
String | getReasonCancel() 取消理由を取得します。
String | getVatCntry() 売上税 ID 番号国を取得します。
String | getVatCntryIso() 消費税登録番号の ISO 国コードを取得します。
void | setCollectNo(String strCollectNo) 一括番号を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します｡
void | setCreatDate(String strCreatDate) レコード登録日を設定します。
void | setDsctPct1(String strDsctPct1) 割引率 1を設定します。
void | setDsctPct2(String strDsctPct2) 割引率 2を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) 言語キーの ISO コードを設定します。
void | setPoRelInd(String strPoRelInd) 承認区分: 購買伝票を設定します。
void | setReasonCancel(String strReasonCancel) 取消理由を設定します。
void | setVatCntry(String strVatCntry) 売上税 ID 番号国を設定します。
void | setVatCntryIso(String strVatCntryIso) 消費税登録番号の ISO 国コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader から継承したメソッド
getAgreement, getCreatedBy, getCurrency, getCurrencyIso, getCustomer, getDeleteInd, getDiffInv, getDocDate, getDocType, getDscnt1To, getDscnt2To, getDscnt3To, getExchRate, getExRateFx, getGrMessage, getIncoterms1, getIncoterms2, getItemIntvl, getLogsystem, getOurRef, getPmnttrms, getPoNumber, getPurchOrg, getPurGroup, getQuotation, getQuotDate, getRef_1, getRelStatus, getSalesPers, getStatus, getSubitemint, getSupplPlnt, getSupplVend, getTelephone, getVendor, getVperEnd, getVperStart, getWarranty, setAgreement, setCreatedBy, setCurrency, setCurrencyIso, setCustomer, setDeleteInd, setDiffInv, setDocDate, setDocType, setDscnt1To, setDscnt2To, setDscnt3To, setExchRate, setExRateFx, setGrMessage, setIncoterms1, setIncoterms2, setItemIntvl, setLogsystem, setOurRef, setPmnttrms, setPoNumber, setPurchOrg, setPurGroup, setQuotation, setQuotDate, setRef_1, setRelStatus, setSalesPers, setStatus, setSubitemint, setSupplPlnt, setSupplVend, setTelephone, setVendor, setVperEnd, setVperStart, setWarranty
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeaderPost

public PurchaseHeaderPost()
購買発注伝票ヘッダを作成します。

メソッドの詳細

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompCode

getCreatDate

public String getCreatDate()
レコード登録日を取得します。

戻り値:
srtCreatDate レコード登録日

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
srtLangu 言語キー

getLanguIso

public String getLanguIso()
言語キーの ISO コードを取得します。

戻り値:
srtLanguIso 言語キーの ISO コード

getDsctPct1

public String getDsctPct1()
割引率 1を取得します。

戻り値:
srtDsctPct1 割引率 1

getDsctPct2

public String getDsctPct2()
割引率 2を取得します。

戻り値:
srtDsctPct2 割引率 2

getCollectNo

public String getCollectNo()
一括番号を取得します。

戻り値:
srtCollectNo 一括番号

getPoRelInd

public String getPoRelInd()
承認区分: 購買伝票を取得します。

戻り値:
srtPoRelInd 承認区分: 購買伝票

getVatCntry

public String getVatCntry()
売上税 ID 番号国を取得します。

戻り値:
srtVatCntry 売上税 ID 番号国

getVatCntryIso

public String getVatCntryIso()
消費税登録番号の ISO 国コードを取得します。

戻り値:
srtVatCntryIso 消費税登録番号の ISO 国コード

getReasonCancel

public String getReasonCancel()
取消理由を取得します。

戻り値:
srtReasonCancel 取消理由

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCreatDate

public void setCreatDate(String strCreatDate)
レコード登録日を設定します。

パラメータ:
strCreatDate - レコード登録日

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
言語キーの ISO コードを設定します。

パラメータ:
strLanguIso - 言語キーの ISO コード

setDsctPct1

public void setDsctPct1(String strDsctPct1)
割引率 1を設定します。

パラメータ:
strDsctPct1 - 割引率 1

setDsctPct2

public void setDsctPct2(String strDsctPct2)
割引率 2を設定します。

パラメータ:
strDsctPct2 - 割引率 2

setCollectNo

public void setCollectNo(String strCollectNo)
一括番号を設定します。

パラメータ:
strCollectNo - 一括番号

setPoRelInd

public void setPoRelInd(String strPoRelInd)
承認区分: 購買伝票を設定します。

パラメータ:
strPoRelInd - 承認区分: 購買伝票

setVatCntry

public void setVatCntry(String strVatCntry)
売上税 ID 番号国を設定します。

パラメータ:
strVatCntry - 売上税 ID 番号国

setVatCntryIso

public void setVatCntryIso(String strVatCntryIso)
消費税登録番号の ISO 国コードを設定します。

パラメータ:
strVatCntryIso - 消費税登録番号の ISO 国コード

setReasonCancel

public void setReasonCancel(String strReasonCancel)
取消理由を設定します。

パラメータ:
strReasonCancel - 取消理由

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseHeader 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseHeaders (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseHeaders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders
すべての実装インタフェース:
Serializable
public class PurchaseHeaders
extends PurchaseHeader
implements Serializable

伝票の承認対象一覧ヘッダ情報クラス
機能は以下の通り

  • 伝票の承認対象一覧ヘッダの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseHeaders()
伝票の承認対象一覧ヘッダを作成します。
メソッドの概要
String | getApplicBy() 見積提出期限を取得します。
String | getBidinvNo() 見積管理番号を取得します。
String | getBindgPer() 見積有効期間を取得します。
String | getCashDisc1() 割引率 1を取得します。
String | getCashDisc2() 割引率 2を取得します。
String | getCntrlInd() 購買伝票タイプに対する管理区分を取得します。
String | getCoCode() 会社コードを取得します。
String | getCollNo() 一括番号を取得します。
String | getComplDlv() 全購買発注に対する一括納入指定を取得します。
String | getCreatedOn() レコード登録日を取得します。
String | getDocCat() 購買伝票カテゴリを取得します。
String | getDocCond() 伝票条件番号を取得します。
String | getExchRateCm() 間接呼び値換算レートを取得します。
String | getExportNo() 貿易データ番号: MM/SD 伝票を取得します。
String | getHold() 購買発注の不完全を取得します。
String | getLanguage() 言語キーを取得します。
String | getLastItem() 最終明細番号を取得します。
String | getMastCond() 期間依存条件伝票を取得します。
String | getProcedure() 決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。
String | getQuotDead() 見積提出期限を取得します。
String | getRcvgVend() 未使用項目を取得します。
String | getRejReason() 見積および受注の拒否理由を取得します。
String | getRelGroup() 承認グループを取得します。
String | getRelInd() 承認区分: 購買伝票を取得します。
String | getRelStrat() 承認方針を取得します。
String | getSchedInd() 分納契約のリリース伝票区分を取得します。
String | getSubjToR() 承認未完了を取得します。
String | getTargetVal() 累積計画金額を取得します。
String | getTaxrCntry() 納税申告書の国を取得します。
String | getUpdateGrp() 統計更新の更新グループを取得します。
String | getVendName() 名称 1を取得します。
void | setApplicBy(String strApplicBy) 見積提出期限を設定します。
void | setBidinvNo(String strBidinvNo) 見積管理番号を設定します。
void | setBindgPer(String strBindgPer) 見積有効期間を設定します。
void | setCashDisc1(String strCashDisc1) 割引率 1を設定します。
void | setCashDisc2(String strCashDisc2) 割引率 2を設定します。
void | setCntrlInd(String strCntrlInd) 購買伝票タイプに対する管理区分を設定します。
void | setCoCode(String strCoCode) 会社コードを設定します。
void | setCollNo(String strCollNo) 一括番号を設定します。
void | setComplDlv(String strComplDlv) 全購買発注に対する一括納入指定を設定します。
void | setCreatedOn(String strCreatedOn) レコード登録日を設定します。
void | setDocCat(String strDocCat) 購買伝票カテゴリを設定します。
void | setDocCond(String strDocCond) 伝票条件番号を設定します。
void | setExchRateCm(String strExchRateCm) 間接呼び値換算レートを設定します。
void | setExportNo(String strExportNo) 貿易データ番号: MM/SD 伝票を設定します。
void | setHold(String strHold) 購買発注の不完全を設定します。
void | setLanguage(String strLanguage) 言語キーを設定します。
void | setLastItem(String strLastItem) 最終明細番号を設定します。
void | setMastCond(String strMastCond) 期間依存条件伝票を設定します。
void | setProcedure(String strProcedure) 決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。
void | setQuotDead(String strQuotDead) 見積提出期限を設定します。
void | setRcvgVend(String strRcvgVend) 未使用項目を設定します。
void | setRejReason(String strRejReason) 見積および受注の拒否理由を設定します。
void | setRelGroup(String strRelGroup) 承認グループを設定します。
void | setRelInd(String strRelInd) 承認区分: 購買伝票を設定します。
void | setRelStrat(String strRelStrat) 承認方針を設定します。
void | setSchedInd(String strSchedInd) 分納契約のリリース伝票区分を設定します。
void | setSubjToR(String strSubjToR) 承認未完了を設定します。
void | setTargetVal(String strTargetVal) 累積計画金額を設定します。
void | setTaxrCntry(String strTaxrCntry) 納税申告書の国を設定します。
void | setUpdateGrp(String strUpdateGrp) 統計更新の更新グループを設定します。
void | setVendName(String strVendName) 名称 1を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader から継承したメソッド
getAgreement, getCreatedBy, getCurrency, getCurrencyIso, getCustomer, getDeleteInd, getDiffInv, getDocDate, getDocType, getDscnt1To, getDscnt2To, getDscnt3To, getExchRate, getExRateFx, getGrMessage, getIncoterms1, getIncoterms2, getItemIntvl, getLogsystem, getOurRef, getPmnttrms, getPoNumber, getPurchOrg, getPurGroup, getQuotation, getQuotDate, getRef_1, getRelStatus, getSalesPers, getStatus, getSubitemint, getSupplPlnt, getSupplVend, getTelephone, getVendor, getVperEnd, getVperStart, getWarranty, setAgreement, setCreatedBy, setCurrency, setCurrencyIso, setCustomer, setDeleteInd, setDiffInv, setDocDate, setDocType, setDscnt1To, setDscnt2To, setDscnt3To, setExchRate, setExRateFx, setGrMessage, setIncoterms1, setIncoterms2, setItemIntvl, setLogsystem, setOurRef, setPmnttrms, setPoNumber, setPurchOrg, setPurGroup, setQuotation, setQuotDate, setRef_1, setRelStatus, setSalesPers, setStatus, setSubitemint, setSupplPlnt, setSupplVend, setTelephone, setVendor, setVperEnd, setVperStart, setWarranty
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseHeaders

public PurchaseHeaders()
伝票の承認対象一覧ヘッダを作成します。

メソッドの詳細

getCoCode

public String getCoCode()
会社コードを取得します。

戻り値:
srtCoCode

getDocCat

public String getDocCat()
購買伝票カテゴリを取得します。

戻り値:
srtDocCat

getCntrlInd

public String getCntrlInd()
購買伝票タイプに対する管理区分を取得します。

戻り値:
srtCntrlInd

getCreatedOn

public String getCreatedOn()
レコード登録日を取得します。

戻り値:
srtCreatedOn

getLastItem

public String getLastItem()
最終明細番号を取得します。

戻り値:
srtLastItem

getLanguage

public String getLanguage()
言語キーを取得します。

戻り値:
srtLanguage

getCashDisc1

public String getCashDisc1()
割引率 1を取得します。

戻り値:
srtCashDisc1

getCashDisc2

public String getCashDisc2()
割引率 2を取得します。

戻り値:
srtCashDisc2

getApplicBy

public String getApplicBy()
見積提出期限を取得します。

戻り値:
srtApplicBy

getQuotDead

public String getQuotDead()
見積提出期限を取得します。

戻り値:
srtQuotDead

getBindgPer

public String getBindgPer()
見積有効期間を取得します。

戻り値:
srtBindgPer

getBidinvNo

public String getBidinvNo()
見積管理番号を取得します。

戻り値:
srtBidinvNo

getRejReason

public String getRejReason()
見積および受注の拒否理由を取得します。

戻り値:
srtRejReason

getComplDlv

public String getComplDlv()
全購買発注に対する一括納入指定を取得します。

戻り値:
srtComplDlv

getRcvgVend

public String getRcvgVend()
未使用項目を取得します。

戻り値:
srtRcvgVend

getTargetVal

public String getTargetVal()
累積計画金額を取得します。

戻り値:
srtTargetVal

getCollNo

public String getCollNo()
一括番号を取得します。

戻り値:
srtCollNo

getDocCond

public String getDocCond()
伝票条件番号を取得します。

戻り値:
srtDocCond

getProcedure

public String getProcedure()
決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。

戻り値:
srtProcedure

getUpdateGrp

public String getUpdateGrp()
統計更新の更新グループを取得します。

戻り値:
srtUpdateGrp

getExportNo

public String getExportNo()
貿易データ番号: MM/SD 伝票を取得します。

戻り値:
srtExportNo

getMastCond

public String getMastCond()
期間依存条件伝票を取得します。

戻り値:
srtMastCond

getRelGroup

public String getRelGroup()
承認グループを取得します。

戻り値:
srtRelGroup

getRelStrat

public String getRelStrat()
承認方針を取得します。

戻り値:
srtRelStrat

getRelInd

public String getRelInd()
承認区分: 購買伝票を取得します。

戻り値:
srtRelInd

getSubjToR

public String getSubjToR()
承認未完了を取得します。

戻り値:
srtSubjToR

getTaxrCntry

public String getTaxrCntry()
納税申告書の国を取得します。

戻り値:
srtTaxrCntry

getSchedInd

public String getSchedInd()
分納契約のリリース伝票区分を取得します。

戻り値:
srtSchedInd

getVendName

public String getVendName()
名称 1を取得します。

戻り値:
srtVendName

getExchRateCm

public String getExchRateCm()
間接呼び値換算レートを取得します。

戻り値:
srtExchRateCm

getHold

public String getHold()
購買発注の不完全を取得します。

戻り値:
srtHold

setCoCode

public void setCoCode(String strCoCode)
会社コードを設定します。

パラメータ:
strCoCode - 会社コード

setDocCat

public void setDocCat(String strDocCat)
購買伝票カテゴリを設定します。

パラメータ:
strDocCat - 購買伝票カテゴリ

setCntrlInd

public void setCntrlInd(String strCntrlInd)
購買伝票タイプに対する管理区分を設定します。

パラメータ:
strCntrlInd - 購買伝票タイプに対する管理区分

setCreatedOn

public void setCreatedOn(String strCreatedOn)
レコード登録日を設定します。

パラメータ:
strCreatedOn - レコード登録日

setLastItem

public void setLastItem(String strLastItem)
最終明細番号を設定します。

パラメータ:
strLastItem - 最終明細番号

setLanguage

public void setLanguage(String strLanguage)
言語キーを設定します。

パラメータ:
strLanguage - 言語キー

setCashDisc1

public void setCashDisc1(String strCashDisc1)
割引率 1を設定します。

パラメータ:
strCashDisc1 - 割引率 1

setCashDisc2

public void setCashDisc2(String strCashDisc2)
割引率 2を設定します。

パラメータ:
strCashDisc2 - 割引率 2

setApplicBy

public void setApplicBy(String strApplicBy)
見積提出期限を設定します。

パラメータ:
strApplicBy - 見積提出期限

setQuotDead

public void setQuotDead(String strQuotDead)
見積提出期限を設定します。

パラメータ:
strQuotDead - 見積提出期限

setBindgPer

public void setBindgPer(String strBindgPer)
見積有効期間を設定します。

パラメータ:
strBindgPer - 見積有効期間

setBidinvNo

public void setBidinvNo(String strBidinvNo)
見積管理番号を設定します。

パラメータ:
strBidinvNo - 見積管理番号

setRejReason

public void setRejReason(String strRejReason)
見積および受注の拒否理由を設定します。

パラメータ:
strRejReason - 見積および受注の拒否理由

setComplDlv

public void setComplDlv(String strComplDlv)
全購買発注に対する一括納入指定を設定します。

パラメータ:
strComplDlv - 全購買発注に対する一括納入指定

setRcvgVend

public void setRcvgVend(String strRcvgVend)
未使用項目を設定します。

パラメータ:
strRcvgVend - 未使用項目

setTargetVal

public void setTargetVal(String strTargetVal)
累積計画金額を設定します。

パラメータ:
strTargetVal - 累積計画金額

setCollNo

public void setCollNo(String strCollNo)
一括番号を設定します。

パラメータ:
strCollNo - 一括番号

setDocCond

public void setDocCond(String strDocCond)
伝票条件番号を設定します。

パラメータ:
strDocCond - 伝票条件番号

setProcedure

public void setProcedure(String strProcedure)
決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。

パラメータ:
strProcedure - 決定表 (価格設定/出力管理/勘定設定/原価計算など)

setUpdateGrp

public void setUpdateGrp(String strUpdateGrp)
統計更新の更新グループを設定します。

パラメータ:
strUpdateGrp - 統計更新の更新グループ

setExportNo

public void setExportNo(String strExportNo)
貿易データ番号: MM/SD 伝票を設定します。

パラメータ:
strExportNo - 貿易データ番号: MM/SD 伝票

setMastCond

public void setMastCond(String strMastCond)
期間依存条件伝票を設定します。

パラメータ:
strMastCond - 期間依存条件伝票

setRelGroup

public void setRelGroup(String strRelGroup)
承認グループを設定します。

パラメータ:
strRelGroup - 承認グループ

setRelStrat

public void setRelStrat(String strRelStrat)
承認方針を設定します。

パラメータ:
strRelStrat - 承認方針

setRelInd

public void setRelInd(String strRelInd)
承認区分: 購買伝票を設定します。

パラメータ:
strRelInd - 承認区分: 購買伝票

setSubjToR

public void setSubjToR(String strSubjToR)
承認未完了を設定します。

パラメータ:
strSubjToR - 承認未完了

setTaxrCntry

public void setTaxrCntry(String strTaxrCntry)
納税申告書の国を設定します。

パラメータ:
strTaxrCntry - 納税申告書の国

setSchedInd

public void setSchedInd(String strSchedInd)
分納契約のリリース伝票区分を設定します。

パラメータ:
strSchedInd - 分納契約のリリース伝票区分

setVendName

public void setVendName(String strVendName)
名称 1を設定します。

パラメータ:
strVendName - 名称 1

setExchRateCm

public void setExchRateCm(String strExchRateCm)
間接呼び値換算レートを設定します。

パラメータ:
strExchRateCm - 間接呼び値換算レート

setHold

public void setHold(String strHold)
購買発注の不完全を設定します。

パラメータ:
strHold - 購買発注の不完全

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseHeader 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItem (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItem

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseItemPost, PurchaseItems
public class PurchaseItem
extends Object
implements Serializable

購買発注明細情報スーパークラス
機能は以下の通り

  • 購買発注の明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItem()
購買発注伝票明細を作成します。
メソッドの概要
String | getAcctasscat() 勘定設定カテゴリを取得します。
String | getAcknReqd() 購買発注請求書依頼を取得します。
String | getAgmtItem() 購買契約の明細番号を取得します。
String | getAgreement() 購買契約番号を取得します。
String | getAtRelev() 適当テーブル関連を取得します。
String | getConvDen1() 購買価格単位から購買発注単位への変換分母を取得します。
String | getConvNum1() 購買価格単位から購買発注単位への変換分子を取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDistrib() 複数勘定設定の配賦区分を取得します。
String | getInfoRec() 購買情報番号を取得します。
String | getItemCat() 購買伝票の明細カテゴリを取得します。
String | getKanbanInd() かんばん区分を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 品目コード（長）を取得します。
String | getMaterialGuid() 品目コードの外部GUIDを取得します。
String | getMaterialVersion() 品目コードのバージョン番号を取得します。
String | getNetPrice() 通貨額を取得します。
String | getNoMoreGr() 納入完了区分を取得します。
String | getNoRounding() 購買発注明細での非表示丸めを取得します。
String | getOrderprUn() 購買発注価格単位を取得します。
String | getOrderprUnIso() 購買発注価格のISOコードを取得します。
String | getPartInv() 一部請求区分を取得します。
String | getPckgNo() パッケージ番号を取得します。
String | getPlanDel() 予定納入日数を取得します。
String | getPlant() プラントを取得します。
String | getPoItem() 明細番号を取得します。
String | getPoPrice() 価格採用区分を取得します。
String | getPoUnitIso() ISOコードによる発注単位を取得します。
String | getPreqName() 購買依頼者名/要求者名を取得します。
String | getPriceUnit() 価格単位を取得します。
String | getQualInsp() 在庫タイプを取得します。
String | getRetItem() 返品明細を取得します。
String | getShipping() 出荷指示を取得します。
String | getShortText() 品目コードテキスト（短）を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getTrackingno() 購買依頼追跡番号を取得します。
String | getValType() 評価タイプを取得します。
String | getVendMat() 仕入先が使用している品目コードを取得します。
void | setAcctasscat(String strAcctasscat) 勘定設定カテゴリを設定します。
void | setAcknReqd(String strAcknReqd) 購買発注請求書依頼を設定します。
void | setAgmtItem(String strAgmtItem) 購買契約の明細番号を設定します。
void | setAgreement(String strAgreement) 購買契約番号を設定します。
void | setAtRelev(String strAtRelev) 適当テーブル関連を設定します。
void | setConvDen1(String strConvDen1) 購買価格単位から購買発注単位への変換分母を設定します。
void | setConvNum1(String strConvNum1) 購買価格単位から購買発注単位への変換分子を設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDistrib(String strDistrib) 複数勘定設定の配賦区分を設定します。
void | setInfoRec(String strInfoRec) 購買情報番号を設定します。
void | setItemCat(String strItemCat) 購買伝票の明細カテゴリを設定します。
void | setKanbanInd(String strKanbanInd) かんばん区分を設定します。
void | setMaterial(String strMaterial) 品目コードを設定します。
void | setMaterialExternal(String strMaterialExternal) 品目コード（長）を設定します。
void | setMaterialGuid(String strMaterialGuid) 品目コードの外部GUIDを設定します。
void | setMaterialVersion(String strMaterialVersion) 品目コードのバージョン番号を設定します。
void | setNetPrice(String strNetPrice) 通貨額を設定します。
void | setNoMoreGr(String strNoMoreGr) 納入完了区分を設定します。
void | setNoRounding(String strNoRounding) 購買発注明細での非表示丸めを設定します。
void | setOrderprUn(String strOrderprUn) 購買発注価格単位を設定します。
void | setOrderprUnIso(String strOrderprUnIso) 購買発注価格のISOコードを設定します。
void | setPartInv(String strPartInv) 一部請求区分を設定します。
void | setPckgNo(String strPckgNo) パッケージ番号を設定します。
void | setPlanDel(String strPlanDel) 予定納入日数を設定します。
void | setPlant(String strPlant) プラントを設定します。
void | setPoItem(String strPoItem) 明細番号を設定します。
void | setPoPrice(String strPoPrice) 価格採用区分を設定します。
void | setPoUnitIso(String strPoUnitIso) ISOコードによる発注単位を設定します。
void | setPreqName(String strPreqName) 購買依頼者名/要求者名を設定します。
void | setPriceUnit(String strPriceUnit) 価格単位を設定します。
void | setQualInsp(String strQualInsp) 在庫タイプを設定します。
void | setRetItem(String strRetItem) 返品明細を設定します。
void | setShipping(String strShipping) 出荷指示を設定します。
void | setShortText(String strShortText) 品目コードテキスト（短）を設定します。
void | setTaxCode(String strTaxCode) 消費税コードを設定します。
void | setTrackingno(String strTrackingno) 購買依頼追跡番号を設定します。
void | setValType(String strValType) 評価タイプを設定します。
void | setVendMat(String strVendMat) 仕入先が使用している品目コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItem

public PurchaseItem()
購買発注伝票明細を作成します。

メソッドの詳細

getPoItem

public String getPoItem()
明細番号を取得します。

戻り値:
strPoItem

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
strDeleteInd

getShortText

public String getShortText()
品目コードテキスト（短）を取得します。

戻り値:
strShortText

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
strMaterial

getMaterialExternal

public String getMaterialExternal()
品目コード（長）を取得します。

戻り値:
strMaterialExternal

getMaterialGuid

public String getMaterialGuid()
品目コードの外部GUIDを取得します。

戻り値:
strMaterialGuid

getMaterialVersion

public String getMaterialVersion()
品目コードのバージョン番号を取得します。

戻り値:
strMaterialVersion

getPlant

public String getPlant()
プラントを取得します。

戻り値:
strPlant

getTrackingno

public String getTrackingno()
購買依頼追跡番号を取得します。

戻り値:
strTrackingno

getInfoRec

public String getInfoRec()
購買情報番号を取得します。

戻り値:
strInfoRec

getVendMat

public String getVendMat()
仕入先が使用している品目コードを取得します。

戻り値:
strVendMat

getPoUnitIso

public String getPoUnitIso()
ISOコードによる発注単位を取得します。

戻り値:
strPoUnitIso

getOrderprUn

public String getOrderprUn()
購買発注価格単位を取得します。

戻り値:
strOrderprUn

getOrderprUnIso

public String getOrderprUnIso()
購買発注価格のISOコードを取得します。

戻り値:
strOrderprUnIso

getConvNum1

public String getConvNum1()
購買価格単位から購買発注単位への変換分子を取得します。

戻り値:
strConvNum1

getConvDen1

public String getConvDen1()
購買価格単位から購買発注単位への変換分母を取得します。

戻り値:
strConvDen1

getNetPrice

public String getNetPrice()
通貨額を取得します。

戻り値:
strNetPrice

getPriceUnit

public String getPriceUnit()
価格単位を取得します。

戻り値:
strPriceUnit

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
strTaxCode

getQualInsp

public String getQualInsp()
在庫タイプを取得します。

戻り値:
strQualInsp

getValType

public String getValType()
評価タイプを取得します。

戻り値:
strValType

getNoMoreGr

public String getNoMoreGr()
納入完了区分を取得します。

戻り値:
strNoMoreGr

getItemCat

public String getItemCat()
購買伝票の明細カテゴリを取得します。

戻り値:
strItemCat

getAcctasscat

public String getAcctasscat()
勘定設定カテゴリを取得します。

戻り値:
strAcctasscat

getDistrib

public String getDistrib()
複数勘定設定の配賦区分を取得します。

戻り値:
strDistrib

getPartInv

public String getPartInv()
一部請求区分を取得します。

戻り値:
strPartInv

getAcknReqd

public String getAcknReqd()
購買発注請求書依頼を取得します。

戻り値:
strAcknReqd

getAgreement

public String getAgreement()
購買契約番号を取得します。

戻り値:
strAgreement

getAgmtItem

public String getAgmtItem()
購買契約の明細番号を取得します。

戻り値:
strAgmtItem

getShipping

public String getShipping()
出荷指示を取得します。

戻り値:
strShipping

getPlanDel

public String getPlanDel()
予定納入日数を取得します。

戻り値:
strPlanDel

getKanbanInd

public String getKanbanInd()
かんばん区分を取得します。

戻り値:
strKanbanInd

getRetItem

public String getRetItem()
返品明細を取得します。

戻り値:
strRetItem

getAtRelev

public String getAtRelev()
適当テーブル関連を取得します。

戻り値:
strAtRelev

getPreqName

public String getPreqName()
購買依頼者名/要求者名を取得します。

戻り値:
strPreqName

getPckgNo

public String getPckgNo()
パッケージ番号を取得します。

戻り値:
strPckgNo

getNoRounding

public String getNoRounding()
購買発注明細での非表示丸めを取得します。

戻り値:
strNoRounding

getPoPrice

public String getPoPrice()
価格採用区分を取得します。

戻り値:
strPoPrice

setPoItem

public void setPoItem(String strPoItem)
明細番号を設定します。

パラメータ:
strPoItem - 明細番号

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setShortText

public void setShortText(String strShortText)
品目コードテキスト（短）を設定します。

パラメータ:
strShortText - 品目コードテキスト（短）

setMaterial

public void setMaterial(String strMaterial)
品目コードを設定します。

パラメータ:
strMaterial - 品目コード

setMaterialExternal

public void setMaterialExternal(String strMaterialExternal)
品目コード（長）を設定します。

パラメータ:
strMaterialExternal - 品目コード（長）

setMaterialGuid

public void setMaterialGuid(String strMaterialGuid)
品目コードの外部GUIDを設定します。

パラメータ:
strMaterialGuid - 品目コードの外部GUID

setMaterialVersion

public void setMaterialVersion(String strMaterialVersion)
品目コードのバージョン番号を設定します。

パラメータ:
strMaterialVersion - 品目コードのバージョン番号

setPlant

public void setPlant(String strPlant)
プラントを設定します。

パラメータ:
strPlant - プラント

setTrackingno

public void setTrackingno(String strTrackingno)
購買依頼追跡番号を設定します。

パラメータ:
strTrackingno - 購買依頼追跡番号

setInfoRec

public void setInfoRec(String strInfoRec)
購買情報番号を設定します。

パラメータ:
strInfoRec - 購買情報番号

setVendMat

public void setVendMat(String strVendMat)
仕入先が使用している品目コードを設定します。

パラメータ:
strVendMat - 仕入先が使用している品目コード

setPoUnitIso

public void setPoUnitIso(String strPoUnitIso)
ISOコードによる発注単位を設定します。

パラメータ:
strPoUnitIso - ISOコードによる発注単位

setOrderprUn

public void setOrderprUn(String strOrderprUn)
購買発注価格単位を設定します。

パラメータ:
strOrderprUn - 購買発注価格単位

setOrderprUnIso

public void setOrderprUnIso(String strOrderprUnIso)
購買発注価格のISOコードを設定します。

パラメータ:
strOrderprUnIso - 購買発注価格のISOコード

setConvNum1

public void setConvNum1(String strConvNum1)
購買価格単位から購買発注単位への変換分子を設定します。

パラメータ:
strConvNum1 - 購買価格単位から購買発注単位への変換分子

setConvDen1

public void setConvDen1(String strConvDen1)
購買価格単位から購買発注単位への変換分母を設定します。

パラメータ:
strConvDen1 - 購買価格単位から購買発注単位への変換分母

setNetPrice

public void setNetPrice(String strNetPrice)
通貨額を設定します。

パラメータ:
strNetPrice - 通貨額

setPriceUnit

public void setPriceUnit(String strPriceUnit)
価格単位を設定します。

パラメータ:
strPriceUnit - 価格単位

setTaxCode

public void setTaxCode(String strTaxCode)
消費税コードを設定します。

パラメータ:
strTaxCode - 消費税コード

setQualInsp

public void setQualInsp(String strQualInsp)
在庫タイプを設定します。

パラメータ:
strQualInsp - 在庫タイプ

setValType

public void setValType(String strValType)
評価タイプを設定します。

パラメータ:
strValType - 評価タイプ

setNoMoreGr

public void setNoMoreGr(String strNoMoreGr)
納入完了区分を設定します。

パラメータ:
strNoMoreGr - 納入完了区分

setItemCat

public void setItemCat(String strItemCat)
購買伝票の明細カテゴリを設定します。

パラメータ:
strItemCat - 購買伝票の明細カテゴリ

setAcctasscat

public void setAcctasscat(String strAcctasscat)
勘定設定カテゴリを設定します。

パラメータ:
strAcctasscat - 勘定設定カテゴリ

setDistrib

public void setDistrib(String strDistrib)
複数勘定設定の配賦区分を設定します。

パラメータ:
strDistrib - 複数勘定設定の配賦区分

setPartInv

public void setPartInv(String strPartInv)
一部請求区分を設定します。

パラメータ:
strPartInv - 一部請求区分

setAcknReqd

public void setAcknReqd(String strAcknReqd)
購買発注請求書依頼を設定します。

パラメータ:
strAcknReqd - 購買発注請求書依頼

setAgreement

public void setAgreement(String strAgreement)
購買契約番号を設定します。

パラメータ:
strAgreement - 購買契約番号

setAgmtItem

public void setAgmtItem(String strAgmtItem)
購買契約の明細番号を設定します。

パラメータ:
strAgmtItem - 購買契約の明細番号

setShipping

public void setShipping(String strShipping)
出荷指示を設定します。

パラメータ:
strShipping - 出荷指示

setPlanDel

public void setPlanDel(String strPlanDel)
予定納入日数を設定します。

パラメータ:
strPlanDel - 予定納入日数

setKanbanInd

public void setKanbanInd(String strKanbanInd)
かんばん区分を設定します。

パラメータ:
strKanbanInd - かんばん区分

setRetItem

public void setRetItem(String strRetItem)
返品明細を設定します。

パラメータ:
strRetItem - 返品明細

setAtRelev

public void setAtRelev(String strAtRelev)
適当テーブル関連を設定します。

パラメータ:
strAtRelev - 適当テーブル関連

setPreqName

public void setPreqName(String strPreqName)
購買依頼者名/要求者名を設定します。

パラメータ:
strPreqName - 購買依頼者名/要求者名

setPckgNo

public void setPckgNo(String strPckgNo)
パッケージ番号を設定します。

パラメータ:
strPckgNo - パッケージ番号

setNoRounding

public void setNoRounding(String strNoRounding)
購買発注明細での非表示丸めを設定します。

パラメータ:
strNoRounding - 購買発注明細での非表示丸め

setPoPrice

public void setPoPrice(String strPoPrice)
価格採用区分を設定します。

パラメータ:
strPoPrice - 価格採用区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItemPost (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItemPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost
すべての実装インタフェース:
Serializable
public class PurchaseItemPost
extends PurchaseItem
implements Serializable

購買発注伝票明細情報クラス
機能は以下の通り

  • 購買発注伝票明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItemPost()
購買発注伝票明細を作成します。
PurchaseItemPost(int index)
購買発注伝票明細を作成します。
メソッドの概要
String | getAcknowlNo() 購買発注請書番号を取得します。
String | getBatch() ロット番号を取得します。
String | getBonGrp1() 決済グループ1を取得します。
String | getBonGrp2() 決済グループ 2 (リベート決済、購買)を取得します。
String | getBonGrp3() 決済グループ 3 (リベート決済、購買)を取得します。
String | getBrasNbm() Brazilian NCM Codeを取得します。
String | getCalctype() 価格設定タイプを取得します。
String | getCmmtItem() 資金予算コードを取得します。
String | getCmmtItemLong() 資金予算コードを取得します。
String | getCondGroup() 仕入先条件グループを取得します。
String | getConfCtrl() 確認管理キーを取得します。
String | getCtrlKey() 調達における品質管理の管理キーを取得します。
String | getCustomer() 得意先コードを取得します。
String | getDelivCompl() 出荷完了 区分を取得します。
String | getEmaterial() 品目コードを取得します。
String | getEmaterialExternal() 品目コード（長）を取得します。
String | getEmaterialGuid() 品目コードの外部GUIDを取得します。
String | getEmaterialVersion() 品目コードのバージョン番号を取得します。
String | getErs() ERS（入庫/請求自動決済）を取得します。
String | getEstPrice() 概算価格区分を取得します。
String | getFinalInv() 請求書処理完了区分を取得します。
String | getFreeItem() 無償明細を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getFund() 会計区分を取得します。
String | getFundsCtr() 予算センタを取得します。
int | getGlIndex() レコード番号を設定します｡
String | getGrantNbr() 補助金を取得します。
String | getGrBasediv() 入庫基準の請求書照合区分を取得します。
String | getGrInd() 入庫区分を取得します。
String | getGrNonVal() 非評価入庫を取得します。
String | getGrossWt() 総重量を取得します。
String | getGrPrTime() 入庫処理日数を取得します。
String | getGrToDate() 納入最終期限を取得します。
String | getHlItem() 購買伝票中の上位明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
String | getIndus3() 品目 CFOP カテゴリを取得します。
String | getInfIndex() インフレーション指数を取得します。
String | getInfoUpd() 購買情報更新区分を取得します。
String | getInHouse() 内部生産を取得します。
String | getIntObjNo() 選定 (内部オブジェクト番号)を取得します。
String | getIrInd() 請求書受領区分を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatlUsage() 品目の用途を取得します。
String | getMatOrigin() 品目の原産地を取得します。
String | getMinremlife() 最低有効期間残を取得します。
String | getNetWeight() 正味重量を取得します。
String | getNoDisct() 現金値引対象外明細を取得します。
String | getOrderReason() 発注理由を取得します。
String | getOverDlvTol() 過剰納入許容範囲を取得します。
String | getPartDeliv() 明細レベルでの分割納入 (在庫転送)を取得します。
String | getPeriodIndExpirationDate() 有効期間期限日の期間区分を取得します。
String | getPoints() リベートポイント数を取得します。
String | getPointUnit() ポイント単位を取得します。
String | getPointUnitIso() ポイント単位の ISO コードを取得します。
String | getPoUnit() 発注単位を取得します。
String | getPreqItem() 購買依頼の明細番号を取得します。
String | getPreqNo() 購買依頼番号を取得します。
String | getPreVendor() 製造元/販売元を取得します。
String | getPricedate() 価格設定日カテゴリ (価格設定日管理)を取得します。
String | getPriceDate() 価格設定日を取得します。
String | getPrntPrice() 価格印刷を取得します。
String | getQuantity() 購買発注数量を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefItem() 参照伝票の明細を取得します。
String | getReminder1() 第一回催促状/督促状の日数を取得します。
String | getReminder2() 第二回催促状/督促状の日数を取得します。
String | getReminder3() 第三回催促状/督促状の日数を取得します。
String | getRevLev() 改訂レベルを取得します。
String | getRfqItem() 見積依頼明細番号を取得します。
String | getRfqNo() 見積依頼番号を取得します。
String | getRPromo() プロモーションを取得します。
String | getScVendor() 外注仕入先を取得します。
String | getSeason() 季節カテゴリを取得します。
String | getSeasonYr() シーズン年度を取得します。
String | getSettItem() リベート (期末) 決済対象の明細を取得します。
String | getShipBlocked() SD 出荷伝票の明細ブロックを取得します。
String | getSiCat() 補助明細カテゴリ、購買伝票を取得します。
String | getStgeLoc() 保管場所を取得します。
String | getSupplStloc() 出庫保管場所: 在庫転送オーダーを取得します。
String | getSuppVendor() 供給仕入先/仕入入庫を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getUnderDlvTol() 不足納入許容範囲リミットを取得します。
String | getUnlimitedDlv() 区分: 無制限過剰納入可能を取得します。
String | getUntilDate() インフレーション指数日付を取得します。
String | getVendPart() 仕入先部門を取得します。
String | getVendrbatch() 仕入先ロット番号を取得します。
String | getVolume() 容積を取得します。
String | getVolumeunit() 容積単位を取得します。
String | getVolumeunitIso() ISO コードでの容積単位を取得します。
String | getWeightunit() 重量単位を取得します。
String | getWeightunitIso() 重量単位のISOコードを取得します。
void | setAcknowlNo(String strAcknowlNo) 購買発注請書番号を設定します。
void | setBatch(String strBatch) ロット番号を設定します。
void | setBonGrp1(String strBonGrp1) 決済グループ1を設定します。
void | setBonGrp2(String strBonGrp2) 決済グループ 2 (リベート決済、購買)を設定します。
void | setBonGrp3(String strBonGrp3) 決済グループ 3 (リベート決済、購買)を設定します。
void | setBrasNbm(String strBrasNbm) Brazilian NCM Codeを設定します。
void | setCalctype(String strCalctype) 価格設定タイプを設定します。
void | setCmmtItem(String strCmmtItem) 資金予算コードを設定します。
void | setCmmtItemLong(String strCmmtItemLong) 資金予算コードを設定します。
void | setCondGroup(String strCondGroup) 仕入先条件グループを設定します。
void | setConfCtrl(String strConfCtrl) 確認管理キーを設定します。
void | setCtrlKey(String strCtrlKey) 調達における品質管理の管理キーを設定します。
void | setCustomer(String strCustomer) 得意先コードを設定します。
void | setDelivCompl(String strDelivCompl) 出荷完了 区分を設定します。
void | setEmaterial(String strEmaterial) 品目コードを設定します。
void | setEmaterialExternal(String strEmaterialExternal) 品目コード（長）を設定します。
void | setEmaterialGuid(String strEmaterialGuid) 品目コードの外部GUIDを設定します。
void | setEmaterialVersion(String strEmaterialVersion) 品目コードのバージョン番号を設定します。
void | setErs(String strErs) ERS（入庫/請求自動決済）を設定します。
void | setEstPrice(String strEstPrice) 概算価格区分を設定します。
void | setFinalInv(String strFinalInv) 請求書処理完了区分を設定します。
void | setFreeItem(String strFreeItem) 無償明細を設定します。
void | setFuncAreaLong(String strFuncAreaLong) 機能領域を設定します。
void | setFund(String strFund) 会計区分を設定します。
void | setFundsCtr(String strFundsCtr) 予算センタを設定します。
void | setGlIndex(int glIndex) レコード番号を設定します｡
void | setGrantNbr(String strGrantNbr) 補助金を設定します。
void | setGrBasediv(String strGrBasediv) 入庫基準の請求書照合区分を設定します。
void | setGrInd(String strGrInd) 入庫区分を設定します。
void | setGrNonVal(String strGrNonVal) 非評価入庫を設定します。
void | setGrossWt(String strGrossWt) 総重量を設定します。
void | setGrPrTime(String strGrPrTime) 入庫処理日数を設定します。
void | setGrToDate(String strGrToDate) 納入最終期限を設定します。
void | setHlItem(String strHlItem) 購買伝票中の上位明細を設定します。
void | setIncoterms1(String strIncoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String strIncoterms2) インコタームズ 2を設定します。
void | setIndus3(String strIndus3) 品目 CFOP カテゴリを設定します。
void | setInfIndex(String strInfIndex) インフレーション指数を設定します。
void | setInfoUpd(String strInfoUpd) 購買情報更新区分を設定します。
void | setInHouse(String strInHouse) 内部生産を設定します。
void | setIntObjNo(String strIntObjNo) 選定 (内部オブジェクト番号)を設定します。
void | setIrInd(String strIrInd) 請求書受領区分を設定します。
void | setMatlGroup(String strMatlGroup) 品目グループを設定します。
void | setMatlUsage(String strMatlUsage) 品目の用途を設定します。
void | setMatOrigin(String strMatOrigin) 品目の原産地を設定します。
void | setMinremlife(String strMinremlife) 最低有効期間残を設定します。
void | setNetWeight(String strNetWeight) 正味重量を設定します。
void | setNoDisct(String strNoDisct) 現金値引対象外明細を設定します。
void | setOrderReason(String strOrderReason) 発注理由を設定します。
void | setOverDlvTol(String strOverDlvTol) 過剰納入許容範囲を設定します。
void | setPartDeliv(String strPartDeliv) 明細レベルでの分割納入 (在庫転送)を設定します。
void | setPeriodIndExpirationDate(String strPeriodIndExpirationDate) 有効期間期限日の期間区分を設定します。
void | setPoints(String strPoints) リベートポイント数を設定します。
void | setPointUnit(String strPointUnit) ポイント単位を設定します。
void | setPointUnitIso(String strPointUnitIso) ポイント単位の ISO コードを設定します。
void | setPoUnit(String strPoUnit) 発注単位を設定します。
void | setPreqItem(String strPreqItem) 購買依頼の明細番号を設定します。
void | setPreqNo(String strPreqNo) 購買依頼番号を設定します。
void | setPreVendor(String strPreVendor) 製造元/販売元を設定します。
void | setPricedate(String strPricedate) 価格設定日カテゴリ (価格設定日管理)を設定します。
void | setPriceDate(String strPriceDate) 価格設定日を設定します。
void | setPrntPrice(String strPrntPrice) 価格印刷を設定します。
void | setQuantity(String strQuantity) 購買発注数量を設定します。
void | setRefDoc(String strRefDoc) 参照伝票番号を設定します。
void | setRefItem(String strRefItem) 参照伝票の明細を設定します。
void | setReminder1(String strReminder1) 第一回催促状/督促状の日数を設定します。
void | setReminder2(String strReminder2) 第二回催促状/督促状の日数を設定します。
void | setReminder3(String strReminder3) 第三回催促状/督促状の日数を設定します。
void | setRevLev(String strRevLev) 改訂レベルを設定します。
void | setRfqItem(String strRfqItem) 見積依頼明細番号を設定します。
void | setRfqNo(String strRfqNo) 見積依頼番号を設定します。
void | setRPromo(String strRPromo) プロモーションを設定します。
void | setScVendor(String strScVendor) 外注仕入先を設定します。
void | setSeason(String strSeason) 季節カテゴリを設定します。
void | setSeasonYr(String strSeasonYr) シーズン年度を設定します。
void | setSettItem(String strSettItem) リベート (期末) 決済対象の明細を設定します。
void | setShipBlocked(String strShipBlocked) SD 出荷伝票の明細ブロックを設定します。
void | setSiCat(String strSiCat) 補助明細カテゴリ、購買伝票を設定します。
void | setStgeLoc(String strStgeLoc) 保管場所を設定します。
void | setSupplStloc(String strSupplStloc) 出庫保管場所: 在庫転送オーダーを設定します。
void | setSuppVendor(String strSuppVendor) 供給仕入先/仕入入庫を設定します。
void | setTaxjurcode(String strTaxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setUnderDlvTol(String strUnderDlvTol) 不足納入許容範囲リミットを設定します。
void | setUnlimitedDlv(String strUnlimitedDlv) 区分: 無制限過剰納入可能を設定します。
void | setUntilDate(String strUntilDate) インフレーション指数日付を設定します。
void | setVendPart(String strVendPart) 仕入先部門を設定します。
void | setVendrbatch(String strVendrbatch) 仕入先ロット番号を設定します。
void | setVolume(String strVolume) 容積を設定します。
void | setVolumeunit(String strVolumeunit) 容積単位を設定します。
void | setVolumeunitIso(String strVolumeunitIso) ISO コードでの容積単位を設定します。
void | setWeightunit(String strWeightunit) 重量単位を設定します。
void | setWeightunitIso(String strWeightunitIso) 重量単位のISOコードを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem から継承したメソッド
getAcctasscat, getAcknReqd, getAgmtItem, getAgreement, getAtRelev, getConvDen1, getConvNum1, getDeleteInd, getDistrib, getInfoRec, getItemCat, getKanbanInd, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getNetPrice, getNoMoreGr, getNoRounding, getOrderprUn, getOrderprUnIso, getPartInv, getPckgNo, getPlanDel, getPlant, getPoItem, getPoPrice, getPoUnitIso, getPreqName, getPriceUnit, getQualInsp, getRetItem, getShipping, getShortText, getTaxCode, getTrackingno, getValType, getVendMat, setAcctasscat, setAcknReqd, setAgmtItem, setAgreement, setAtRelev, setConvDen1, setConvNum1, setDeleteInd, setDistrib, setInfoRec, setItemCat, setKanbanInd, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setNetPrice, setNoMoreGr, setNoRounding, setOrderprUn, setOrderprUnIso, setPartInv, setPckgNo, setPlanDel, setPlant, setPoItem, setPoPrice, setPoUnitIso, setPreqName, setPriceUnit, setQualInsp, setRetItem, setShipping, setShortText, setTaxCode, setTrackingno, setValType, setVendMat
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItemPost

public PurchaseItemPost()
購買発注伝票明細を作成します。

PurchaseItemPost

public PurchaseItemPost(int index)
購買発注伝票明細を作成します。

パラメータ:
index - レコード件数
メソッドの詳細

getEmaterial

public String getEmaterial()
品目コードを取得します。

戻り値:
srtEmaterial 品目コード

getEmaterialExternal

public String getEmaterialExternal()
品目コード（長）を取得します。

戻り値:
srtEmaterialExternal 品目コード（長）

getEmaterialGuid

public String getEmaterialGuid()
品目コードの外部GUIDを取得します。

戻り値:
srtEmaterialGuid 品目コードの外部GUID

getEmaterialVersion

public String getEmaterialVersion()
品目コードのバージョン番号を取得します。

戻り値:
srtEmaterialVersion 品目コードのバージョン番号

getStgeLoc

public String getStgeLoc()
保管場所を取得します。

戻り値:
srtStgeLoc 保管場所

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
srtMatlGroup 品目グループ

getQuantity

public String getQuantity()
購買発注数量を取得します。

戻り値:
srtQuantity 購買発注数量

getPoUnit

public String getPoUnit()
発注単位を取得します。

戻り値:
srtPoUnit 発注単位

getGrPrTime

public String getGrPrTime()
入庫処理日数を取得します。

戻り値:
srtGrPrTime 入庫処理日数

getBonGrp1

public String getBonGrp1()
決済グループ1を取得します。

戻り値:
srtBonGrp1 決済グループ1

getInfoUpd

public String getInfoUpd()
購買情報更新区分を取得します。

戻り値:
srtInfoUpd 購買情報更新区分

getPrntPrice

public String getPrntPrice()
価格印刷を取得します。

戻り値:
srtPrntPrice 価格印刷

getEstPrice

public String getEstPrice()
概算価格区分を取得します。

戻り値:
srtEstPrice 概算価格区分

getReminder1

public String getReminder1()
第一回催促状/督促状の日数を取得します。

戻り値:
srtReminder1 第一回催促状/督促状の日数

getReminder2

public String getReminder2()
第二回催促状/督促状の日数を取得します。

戻り値:
srtReminder2 第二回催促状/督促状の日数

getReminder3

public String getReminder3()
第三回催促状/督促状の日数を取得します。

戻り値:
srtReminder3 第三回催促状/督促状の日数

getOverDlvTol

public String getOverDlvTol()
過剰納入許容範囲を取得します。

戻り値:
srtOverDlvTol 過剰納入許容範囲

getUnlimitedDlv

public String getUnlimitedDlv()
区分: 無制限過剰納入可能を取得します。

戻り値:
srtUnlimitedDlv 区分: 無制限過剰納入可能

getUnderDlvTol

public String getUnderDlvTol()
不足納入許容範囲リミットを取得します。

戻り値:
srtUnderDlvTol 不足納入許容範囲リミット

getFinalInv

public String getFinalInv()
請求書処理完了区分を取得します。

戻り値:
srtFinalInv 請求書処理完了区分

getGrInd

public String getGrInd()
入庫区分を取得します。

戻り値:
srtGrInd 入庫区分

getGrNonVal

public String getGrNonVal()
非評価入庫を取得します。

戻り値:
srtGrNonVal 非評価入庫

getIrInd

public String getIrInd()
請求書受領区分を取得します。

戻り値:
srtIrInd 請求書受領区分

getFreeItem

public String getFreeItem()
無償明細を取得します。

戻り値:
srtFreeItem 無償明細

getGrBasediv

public String getGrBasediv()
入庫基準の請求書照合区分を取得します。

戻り値:
srtGrBasediv 入庫基準の請求書照合区分

getAcknowlNo

public String getAcknowlNo()
購買発注請書番号を取得します。

戻り値:
srtAcknowlNo 購買発注請書番号

getCustomer

public String getCustomer()
得意先コードを取得します。

戻り値:
srtCustomer 得意先コード

getCondGroup

public String getCondGroup()
仕入先条件グループを取得します。

戻り値:
srtCondGroup 仕入先条件グループ

getNoDisct

public String getNoDisct()
現金値引対象外明細を取得します。

戻り値:
srtNoDisct 現金値引対象外明細

getNetWeight

public String getNetWeight()
正味重量を取得します。

戻り値:
srtNetWeight 正味重量

getWeightunit

public String getWeightunit()
重量単位を取得します。

戻り値:
srtWeightunit 重量単位

getWeightunitIso

public String getWeightunitIso()
重量単位のISOコードを取得します。

戻り値:
srtWeightunitIso 重量単位のISOコード

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
srtTaxjurcode 税計算管轄コード - 税管轄コード

getCtrlKey

public String getCtrlKey()
調達における品質管理の管理キーを取得します。

戻り値:
srtCtrlKey 調達における品質管理の管理キー

getConfCtrl

public String getConfCtrl()
確認管理キーを取得します。

戻り値:
srtConfCtrl 確認管理キー

getRevLev

public String getRevLev()
改訂レベルを取得します。

戻り値:
srtRevLev 改訂レベル

getFund

public String getFund()
会計区分を取得します。

戻り値:
srtFund 会計区分

getFundsCtr

public String getFundsCtr()
予算センタを取得します。

戻り値:
srtFundsCtr 予算センタ

getCmmtItem

public String getCmmtItem()
資金予算コードを取得します。

戻り値:
srtCmmtItem 資金予算コード

getPricedate

public String getPricedate()
価格設定日カテゴリ (価格設定日管理)を取得します。

戻り値:
srtPricedate 価格設定日カテゴリ (価格設定日管理)

getPriceDate

public String getPriceDate()
価格設定日を取得します。

戻り値:
srtPriceDate 価格設定日

getGrossWt

public String getGrossWt()
総重量を取得します。

戻り値:
srtGrossWt 総重量

getVolume

public String getVolume()
容積を取得します。

戻り値:
srtVolume 容積

getVolumeunit

public String getVolumeunit()
容積単位を取得します。

戻り値:
srtVolumeunit 容積単位

getVolumeunitIso

public String getVolumeunitIso()
ISO コードでの容積単位を取得します。

戻り値:
srtVolumeunitIso ISO コードでの容積単位

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
srtIncoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
srtIncoterms2 インコタームズ 2

getPreVendor

public String getPreVendor()
製造元/販売元を取得します。

戻り値:
srtPreVendor 製造元/販売元

getVendPart

public String getVendPart()
仕入先部門を取得します。

戻り値:
srtVendPart 仕入先部門

getHlItem

public String getHlItem()
購買伝票中の上位明細を取得します。

戻り値:
srtHlItem 購買伝票中の上位明細

getGrToDate

public String getGrToDate()
納入最終期限を取得します。

戻り値:
srtGrToDate 納入最終期限

getSuppVendor

public String getSuppVendor()
供給仕入先/仕入入庫を取得します。

戻り値:
srtSuppVendor 供給仕入先/仕入入庫

getScVendor

public String getScVendor()
外注仕入先を取得します。

戻り値:
srtScVendor 外注仕入先

getErs

public String getErs()
ERS（入庫/請求自動決済）を取得します。

戻り値:
srtErs ERS（入庫/請求自動決済）

getRPromo

public String getRPromo()
プロモーションを取得します。

戻り値:
srtRPromo プロモーション

getPoints

public String getPoints()
リベートポイント数を取得します。

戻り値:
srtPoints リベートポイント数

getPointUnit

public String getPointUnit()
ポイント単位を取得します。

戻り値:
srtPointUnit ポイント単位

getPointUnitIso

public String getPointUnitIso()
ポイント単位の ISO コードを取得します。

戻り値:
srtPointUnitIso ポイント単位の ISO コード

getSeason

public String getSeason()
季節カテゴリを取得します。

戻り値:
srtSeason 季節カテゴリ

getSeasonYr

public String getSeasonYr()
シーズン年度を取得します。

戻り値:
srtSeasonYr シーズン年度

getBonGrp2

public String getBonGrp2()
決済グループ 2 (リベート決済、購買)を取得します。

戻り値:
srtBonGrp2 決済グループ 2 (リベート決済、購買)

getBonGrp3

public String getBonGrp3()
決済グループ 3 (リベート決済、購買)を取得します。

戻り値:
srtBonGrp3 決済グループ 3 (リベート決済、購買)

getSettItem

public String getSettItem()
リベート (期末) 決済対象の明細を取得します。

戻り値:
srtSettItem リベート (期末) 決済対象の明細

getMinremlife

public String getMinremlife()
最低有効期間残を取得します。

戻り値:
srtMinremlife 最低有効期間残

getRfqNo

public String getRfqNo()
見積依頼番号を取得します。

戻り値:
srtRfqNo 見積依頼番号

getRfqItem

public String getRfqItem()
見積依頼明細番号を取得します。

戻り値:
srtRfqItem 見積依頼明細番号

getPreqNo

public String getPreqNo()
購買依頼番号を取得します。

戻り値:
srtPreqNo 購買依頼番号

getPreqItem

public String getPreqItem()
購買依頼の明細番号を取得します。

戻り値:
srtPreqItem 購買依頼の明細番号

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
srtRefDoc 参照伝票番号

getRefItem

public String getRefItem()
参照伝票の明細を取得します。

戻り値:
srtRefItem 参照伝票の明細

getSiCat

public String getSiCat()
補助明細カテゴリ、購買伝票を取得します。

戻り値:
srtSiCat 補助明細カテゴリ、購買伝票

getOrderReason

public String getOrderReason()
発注理由を取得します。

戻り値:
srtOrderReason 発注理由

getBrasNbm

public String getBrasNbm()
Brazilian NCM Codeを取得します。

戻り値:
srtBrasNbm Brazilian NCM Code

getMatlUsage

public String getMatlUsage()
品目の用途を取得します。

戻り値:
srtMatlUsage 品目の用途

getMatOrigin

public String getMatOrigin()
品目の原産地を取得します。

戻り値:
srtMatOrigin 品目の原産地

getInHouse

public String getInHouse()
内部生産を取得します。

戻り値:
srtInHouse 内部生産

getIndus3

public String getIndus3()
品目 CFOP カテゴリを取得します。

戻り値:
srtIndus3 品目 CFOP カテゴリ

getInfIndex

public String getInfIndex()
インフレーション指数を取得します。

戻り値:
srtInfIndex インフレーション指数

getUntilDate

public String getUntilDate()
インフレーション指数日付を取得します。

戻り値:
srtUntilDate インフレーション指数日付

getDelivCompl

public String getDelivCompl()
出荷完了 区分を取得します。

戻り値:
srtDelivCompl 出荷完了 区分

getPartDeliv

public String getPartDeliv()
明細レベルでの分割納入 (在庫転送)を取得します。

戻り値:
srtPartDeliv 明細レベルでの分割納入 (在庫転送)

getShipBlocked

public String getShipBlocked()
SD 出荷伝票の明細ブロックを取得します。

戻り値:
srtShipBlocked SD 出荷伝票の明細ブロック

getPeriodIndExpirationDate

public String getPeriodIndExpirationDate()
有効期間期限日の期間区分を取得します。

戻り値:
srtPeriodIndExpirationDate 有効期間期限日の期間区分

getIntObjNo

public String getIntObjNo()
選定 (内部オブジェクト番号)を取得します。

戻り値:
srtIntObjNo 選定 (内部オブジェクト番号)

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
srtBatch ロット番号

getVendrbatch

public String getVendrbatch()
仕入先ロット番号を取得します。

戻り値:
srtVendrbatch 仕入先ロット番号

getCalctype

public String getCalctype()
価格設定タイプを取得します。

戻り値:
srtCalctype 価格設定タイプ

getGrantNbr

public String getGrantNbr()
補助金を取得します。

戻り値:
srtGrantNbr 補助金

getCmmtItemLong

public String getCmmtItemLong()
資金予算コードを取得します。

戻り値:
srtCmmtItemLong 資金予算コード

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
srtFuncAreaLong 機能領域

getSupplStloc

public String getSupplStloc()
出庫保管場所: 在庫転送オーダーを取得します。

戻り値:
srtSupplStloc 出庫保管場所: 在庫転送オーダー

getGlIndex

public int getGlIndex()
レコード番号を設定します｡

戻り値:
glIndex レコード番号

setEmaterial

public void setEmaterial(String strEmaterial)
品目コードを設定します。

パラメータ:
strEmaterial - 品目コード

setEmaterialExternal

public void setEmaterialExternal(String strEmaterialExternal)
品目コード（長）を設定します。

パラメータ:
strEmaterialExternal - 品目コード（長）

setEmaterialGuid

public void setEmaterialGuid(String strEmaterialGuid)
品目コードの外部GUIDを設定します。

パラメータ:
strEmaterialGuid - 品目コードの外部GUID

setEmaterialVersion

public void setEmaterialVersion(String strEmaterialVersion)
品目コードのバージョン番号を設定します。

パラメータ:
strEmaterialVersion - 品目コードのバージョン番号

setStgeLoc

public void setStgeLoc(String strStgeLoc)
保管場所を設定します。

パラメータ:
strStgeLoc - 保管場所

setMatlGroup

public void setMatlGroup(String strMatlGroup)
品目グループを設定します。

パラメータ:
strMatlGroup - 品目グループ

setQuantity

public void setQuantity(String strQuantity)
購買発注数量を設定します。

パラメータ:
strQuantity - 購買発注数量

setPoUnit

public void setPoUnit(String strPoUnit)
発注単位を設定します。

パラメータ:
strPoUnit - 発注単位

setGrPrTime

public void setGrPrTime(String strGrPrTime)
入庫処理日数を設定します。

パラメータ:
strGrPrTime - 入庫処理日数

setBonGrp1

public void setBonGrp1(String strBonGrp1)
決済グループ1を設定します。

パラメータ:
strBonGrp1 - 決済グループ1

setInfoUpd

public void setInfoUpd(String strInfoUpd)
購買情報更新区分を設定します。

パラメータ:
strInfoUpd - 購買情報更新区分

setPrntPrice

public void setPrntPrice(String strPrntPrice)
価格印刷を設定します。

パラメータ:
strPrntPrice - 価格印刷

setEstPrice

public void setEstPrice(String strEstPrice)
概算価格区分を設定します。

パラメータ:
strEstPrice - 概算価格区分

setReminder1

public void setReminder1(String strReminder1)
第一回催促状/督促状の日数を設定します。

パラメータ:
strReminder1 - 第一回催促状/督促状の日数

setReminder2

public void setReminder2(String strReminder2)
第二回催促状/督促状の日数を設定します。

パラメータ:
strReminder2 - 第二回催促状/督促状の日数

setReminder3

public void setReminder3(String strReminder3)
第三回催促状/督促状の日数を設定します。

パラメータ:
strReminder3 - 第三回催促状/督促状の日数

setOverDlvTol

public void setOverDlvTol(String strOverDlvTol)
過剰納入許容範囲を設定します。

パラメータ:
strOverDlvTol - 過剰納入許容範囲

setUnlimitedDlv

public void setUnlimitedDlv(String strUnlimitedDlv)
区分: 無制限過剰納入可能を設定します。

パラメータ:
strUnlimitedDlv - 区分: 無制限過剰納入可能

setUnderDlvTol

public void setUnderDlvTol(String strUnderDlvTol)
不足納入許容範囲リミットを設定します。

パラメータ:
strUnderDlvTol - 不足納入許容範囲リミット

setFinalInv

public void setFinalInv(String strFinalInv)
請求書処理完了区分を設定します。

パラメータ:
strFinalInv - 請求書処理完了区分

setGrInd

public void setGrInd(String strGrInd)
入庫区分を設定します。

パラメータ:
strGrInd - 入庫区分

setGrNonVal

public void setGrNonVal(String strGrNonVal)
非評価入庫を設定します。

パラメータ:
strGrNonVal - 非評価入庫

setIrInd

public void setIrInd(String strIrInd)
請求書受領区分を設定します。

パラメータ:
strIrInd - 請求書受領区分

setFreeItem

public void setFreeItem(String strFreeItem)
無償明細を設定します。

パラメータ:
strFreeItem - 無償明細

setGrBasediv

public void setGrBasediv(String strGrBasediv)
入庫基準の請求書照合区分を設定します。

パラメータ:
strGrBasediv - 入庫基準の請求書照合区分

setAcknowlNo

public void setAcknowlNo(String strAcknowlNo)
購買発注請書番号を設定します。

パラメータ:
strAcknowlNo - 購買発注請書番号

setCustomer

public void setCustomer(String strCustomer)
得意先コードを設定します。

パラメータ:
strCustomer - 得意先コード

setCondGroup

public void setCondGroup(String strCondGroup)
仕入先条件グループを設定します。

パラメータ:
strCondGroup - 仕入先条件グループ

setNoDisct

public void setNoDisct(String strNoDisct)
現金値引対象外明細を設定します。

パラメータ:
strNoDisct - 現金値引対象外明細

setNetWeight

public void setNetWeight(String strNetWeight)
正味重量を設定します。

パラメータ:
strNetWeight - 正味重量

setWeightunit

public void setWeightunit(String strWeightunit)
重量単位を設定します。

パラメータ:
strWeightunit - 重量単位

setWeightunitIso

public void setWeightunitIso(String strWeightunitIso)
重量単位のISOコードを設定します。

パラメータ:
strWeightunitIso - 重量単位のISOコード

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税計算管轄コード - 税管轄コード

setCtrlKey

public void setCtrlKey(String strCtrlKey)
調達における品質管理の管理キーを設定します。

パラメータ:
strCtrlKey - 調達における品質管理の管理キー

setConfCtrl

public void setConfCtrl(String strConfCtrl)
確認管理キーを設定します。

パラメータ:
strConfCtrl - 確認管理キー

setRevLev

public void setRevLev(String strRevLev)
改訂レベルを設定します。

パラメータ:
strRevLev - 改訂レベル

setFund

public void setFund(String strFund)
会計区分を設定します。

パラメータ:
strFund - 会計区分

setFundsCtr

public void setFundsCtr(String strFundsCtr)
予算センタを設定します。

パラメータ:
strFundsCtr - 予算センタ

setCmmtItem

public void setCmmtItem(String strCmmtItem)
資金予算コードを設定します。

パラメータ:
strCmmtItem - 資金予算コード

setPricedate

public void setPricedate(String strPricedate)
価格設定日カテゴリ (価格設定日管理)を設定します。

パラメータ:
strPricedate - 価格設定日カテゴリ (価格設定日管理)

setPriceDate

public void setPriceDate(String strPriceDate)
価格設定日を設定します。

パラメータ:
strPriceDate - 価格設定日

setGrossWt

public void setGrossWt(String strGrossWt)
総重量を設定します。

パラメータ:
strGrossWt - 総重量

setVolume

public void setVolume(String strVolume)
容積を設定します。

パラメータ:
strVolume - 容積

setVolumeunit

public void setVolumeunit(String strVolumeunit)
容積単位を設定します。

パラメータ:
strVolumeunit - 容積単位

setVolumeunitIso

public void setVolumeunitIso(String strVolumeunitIso)
ISO コードでの容積単位を設定します。

パラメータ:
strVolumeunitIso - ISO コードでの容積単位

setIncoterms1

public void setIncoterms1(String strIncoterms1)
インコタームズ (1)を設定します。

パラメータ:
strIncoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String strIncoterms2)
インコタームズ 2を設定します。

パラメータ:
strIncoterms2 - インコタームズ 2

setPreVendor

public void setPreVendor(String strPreVendor)
製造元/販売元を設定します。

パラメータ:
strPreVendor - 製造元/販売元

setVendPart

public void setVendPart(String strVendPart)
仕入先部門を設定します。

パラメータ:
strVendPart - 仕入先部門

setHlItem

public void setHlItem(String strHlItem)
購買伝票中の上位明細を設定します。

パラメータ:
strHlItem - 購買伝票中の上位明細

setGrToDate

public void setGrToDate(String strGrToDate)
納入最終期限を設定します。

パラメータ:
strGrToDate - 納入最終期限

setSuppVendor

public void setSuppVendor(String strSuppVendor)
供給仕入先/仕入入庫を設定します。

パラメータ:
strSuppVendor - 供給仕入先/仕入入庫

setScVendor

public void setScVendor(String strScVendor)
外注仕入先を設定します。

パラメータ:
strScVendor - 外注仕入先

setErs

public void setErs(String strErs)
ERS（入庫/請求自動決済）を設定します。

パラメータ:
strErs - ERS（入庫/請求自動決済）

setRPromo

public void setRPromo(String strRPromo)
プロモーションを設定します。

パラメータ:
strRPromo - プロモーション

setPoints

public void setPoints(String strPoints)
リベートポイント数を設定します。

パラメータ:
strPoints - リベートポイント数

setPointUnit

public void setPointUnit(String strPointUnit)
ポイント単位を設定します。

パラメータ:
strPointUnit - ポイント単位

setPointUnitIso

public void setPointUnitIso(String strPointUnitIso)
ポイント単位の ISO コードを設定します。

パラメータ:
strPointUnitIso - ポイント単位の ISO コード

setSeason

public void setSeason(String strSeason)
季節カテゴリを設定します。

パラメータ:
strSeason - 季節カテゴリ

setSeasonYr

public void setSeasonYr(String strSeasonYr)
シーズン年度を設定します。

パラメータ:
strSeasonYr - シーズン年度

setBonGrp2

public void setBonGrp2(String strBonGrp2)
決済グループ 2 (リベート決済、購買)を設定します。

パラメータ:
strBonGrp2 - 決済グループ 2 (リベート決済、購買)

setBonGrp3

public void setBonGrp3(String strBonGrp3)
決済グループ 3 (リベート決済、購買)を設定します。

パラメータ:
strBonGrp3 - 決済グループ 3 (リベート決済、購買)

setSettItem

public void setSettItem(String strSettItem)
リベート (期末) 決済対象の明細を設定します。

パラメータ:
strSettItem - リベート (期末) 決済対象の明細

setMinremlife

public void setMinremlife(String strMinremlife)
最低有効期間残を設定します。

パラメータ:
strMinremlife - 最低有効期間残

setRfqNo

public void setRfqNo(String strRfqNo)
見積依頼番号を設定します。

パラメータ:
strRfqNo - 見積依頼番号

setRfqItem

public void setRfqItem(String strRfqItem)
見積依頼明細番号を設定します。

パラメータ:
strRfqItem - 見積依頼明細番号

setPreqNo

public void setPreqNo(String strPreqNo)
購買依頼番号を設定します。

パラメータ:
strPreqNo - 購買依頼番号

setPreqItem

public void setPreqItem(String strPreqItem)
購買依頼の明細番号を設定します。

パラメータ:
strPreqItem - 購買依頼の明細番号

setRefDoc

public void setRefDoc(String strRefDoc)
参照伝票番号を設定します。

パラメータ:
strRefDoc - 参照伝票番号

setRefItem

public void setRefItem(String strRefItem)
参照伝票の明細を設定します。

パラメータ:
strRefItem - 参照伝票の明細

setSiCat

public void setSiCat(String strSiCat)
補助明細カテゴリ、購買伝票を設定します。

パラメータ:
strSiCat - 補助明細カテゴリ、購買伝票

setOrderReason

public void setOrderReason(String strOrderReason)
発注理由を設定します。

パラメータ:
strOrderReason - 発注理由

setBrasNbm

public void setBrasNbm(String strBrasNbm)
Brazilian NCM Codeを設定します。

パラメータ:
strBrasNbm - Brazilian NCM Code

setMatlUsage

public void setMatlUsage(String strMatlUsage)
品目の用途を設定します。

パラメータ:
strMatlUsage - 品目の用途

setMatOrigin

public void setMatOrigin(String strMatOrigin)
品目の原産地を設定します。

パラメータ:
strMatOrigin - 品目の原産地

setInHouse

public void setInHouse(String strInHouse)
内部生産を設定します。

パラメータ:
strInHouse - 内部生産

setIndus3

public void setIndus3(String strIndus3)
品目 CFOP カテゴリを設定します。

パラメータ:
strIndus3 - 品目 CFOP カテゴリ

setInfIndex

public void setInfIndex(String strInfIndex)
インフレーション指数を設定します。

パラメータ:
strInfIndex - インフレーション指数

setUntilDate

public void setUntilDate(String strUntilDate)
インフレーション指数日付を設定します。

パラメータ:
strUntilDate - インフレーション指数日付

setDelivCompl

public void setDelivCompl(String strDelivCompl)
出荷完了 区分を設定します。

パラメータ:
strDelivCompl - 出荷完了 区分

setPartDeliv

public void setPartDeliv(String strPartDeliv)
明細レベルでの分割納入 (在庫転送)を設定します。

パラメータ:
strPartDeliv - 明細レベルでの分割納入 (在庫転送)

setShipBlocked

public void setShipBlocked(String strShipBlocked)
SD 出荷伝票の明細ブロックを設定します。

パラメータ:
strShipBlocked - SD 出荷伝票の明細ブロック

setPeriodIndExpirationDate

public void setPeriodIndExpirationDate(String strPeriodIndExpirationDate)
有効期間期限日の期間区分を設定します。

パラメータ:
strPeriodIndExpirationDate - 有効期間期限日の期間区分

setIntObjNo

public void setIntObjNo(String strIntObjNo)
選定 (内部オブジェクト番号)を設定します。

パラメータ:
strIntObjNo - 選定 (内部オブジェクト番号)

setBatch

public void setBatch(String strBatch)
ロット番号を設定します。

パラメータ:
strBatch - ロット番号

setVendrbatch

public void setVendrbatch(String strVendrbatch)
仕入先ロット番号を設定します。

パラメータ:
strVendrbatch - 仕入先ロット番号

setCalctype

public void setCalctype(String strCalctype)
価格設定タイプを設定します。

パラメータ:
strCalctype - 価格設定タイプ

setGrantNbr

public void setGrantNbr(String strGrantNbr)
補助金を設定します。

パラメータ:
strGrantNbr - 補助金

setCmmtItemLong

public void setCmmtItemLong(String strCmmtItemLong)
資金予算コードを設定します。

パラメータ:
strCmmtItemLong - 資金予算コード

setFuncAreaLong

public void setFuncAreaLong(String strFuncAreaLong)
機能領域を設定します。

パラメータ:
strFuncAreaLong - 機能領域

setSupplStloc

public void setSupplStloc(String strSupplStloc)
出庫保管場所: 在庫転送オーダーを設定します。

パラメータ:
strSupplStloc - 出庫保管場所: 在庫転送オーダー

setGlIndex

public void setGlIndex(int glIndex)
レコード番号を設定します｡

パラメータ:
glIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseItem 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseItems (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseItems

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems
すべての実装インタフェース:
Serializable
public class PurchaseItems
extends PurchaseItem
implements Serializable

伝票の承認対象明細情報クラス
機能は以下の通り

  • 伝票の承認対象明細情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseItems()
伝票の承認対象明細を作成します。
メソッドの概要
String | getAddress() 住所を取得します。
String | getAllocTbl() 商品配分表番号を取得します。
String | getAtItem() 割当テーブルの明細番号を取得します。
String | getDispQuan() 購買発注数量: 表示目的全納入日程合計を取得します。
String | getItemCatExt() 購買伝票の明細カテゴリを取得します。
String | getManufProf() 製造者製品プロファイルを取得します。
String | getManuMat() 製造者製品コードを取得します。
String | getMatGrp() 品目グループを取得します。
String | getMfrNo() 製造者番号を取得します。
String | getMfrNoExt() 外部製造者コード名または番号を取得します。
String | getPoNumber() 購買伝票番号を取得します。
String | getPrClosed() 購買依頼処理済を取得します。
String | getPromotion() プロモーションを取得します。
String | getPurMat() 品目コードを取得します。
String | getPurMatExternal() 項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPurMatGuid() 項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPurMatVersion() 項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getUnit() 発注単位を取得します。
void | setAddress(String strAddress) 住所を設定します。
void | setAllocTbl(String strAllocTbl) 商品配分表番号を設定します。
void | setAtItem(String strAtItem) 割当テーブルの明細番号を設定します。
void | setDispQuan(String strDispQuan) 購買発注数量: 表示目的全納入日程合計を設定します。
void | setItemCatExt(String strItemCatExt) 購買伝票の明細カテゴリを設定します。
void | setManufProf(String strManufProf) 製造者製品プロファイルを設定します。
void | setManuMat(String strManuMat) 製造者製品コードを設定します。
void | setMatGrp(String strMatGrp) 品目グループを設定します。
void | setMfrNo(String strMfrNo) 製造者番号を設定します。
void | setMfrNoExt(String strMfrNoExt) 外部製造者コード名または番号を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setPrClosed(String strPrClosed) 購買依頼処理済を設定します。
void | setPromotion(String strPromotion) プロモーションを設定します。
void | setPurMat(String strPurMat) 品目コードを設定します。
void | setPurMatExternal(String strPurMatExternal) 項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPurMatGuid(String strPurMatGuid) 項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPurMatVersion(String strPurMatVersion) 項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setStoreLoc(String strStoreLoc) 保管場所を設定します。
void | setUnit(String strUnit) 発注単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem から継承したメソッド
getAcctasscat, getAcknReqd, getAgmtItem, getAgreement, getAtRelev, getConvDen1, getConvNum1, getDeleteInd, getDistrib, getInfoRec, getItemCat, getKanbanInd, getMaterial, getMaterialExternal, getMaterialGuid, getMaterialVersion, getNetPrice, getNoMoreGr, getNoRounding, getOrderprUn, getOrderprUnIso, getPartInv, getPckgNo, getPlanDel, getPlant, getPoItem, getPoPrice, getPoUnitIso, getPreqName, getPriceUnit, getQualInsp, getRetItem, getShipping, getShortText, getTaxCode, getTrackingno, getValType, getVendMat, setAcctasscat, setAcknReqd, setAgmtItem, setAgreement, setAtRelev, setConvDen1, setConvNum1, setDeleteInd, setDistrib, setInfoRec, setItemCat, setKanbanInd, setMaterial, setMaterialExternal, setMaterialGuid, setMaterialVersion, setNetPrice, setNoMoreGr, setNoRounding, setOrderprUn, setOrderprUnIso, setPartInv, setPckgNo, setPlanDel, setPlant, setPoItem, setPoPrice, setPoUnitIso, setPreqName, setPriceUnit, setQualInsp, setRetItem, setShipping, setShortText, setTaxCode, setTrackingno, setValType, setVendMat
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseItems

public PurchaseItems()
伝票の承認対象明細を作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber

getAddress

public String getAddress()
住所を取得します。

戻り値:
srtAddress

getPurMat

public String getPurMat()
品目コードを取得します。

戻り値:
srtPurMat

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
srtStoreLoc

getMatGrp

public String getMatGrp()
品目グループを取得します。

戻り値:
srtMatGrp

getAllocTbl

public String getAllocTbl()
商品配分表番号を取得します。

戻り値:
srtAllocTbl

getAtItem

public String getAtItem()
割当テーブルの明細番号を取得します。

戻り値:
srtAtItem

getUnit

public String getUnit()
発注単位を取得します。

戻り値:
srtUnit

getPromotion

public String getPromotion()
プロモーションを取得します。

戻り値:
srtPromotion

getManufProf

public String getManufProf()
製造者製品プロファイルを取得します。

戻り値:
srtManufProf

getManuMat

public String getManuMat()
製造者製品コードを取得します。

戻り値:
srtManuMat

getMfrNo

public String getMfrNo()
製造者番号を取得します。

戻り値:
srtMfrNo

getMfrNoExt

public String getMfrNoExt()
外部製造者コード名または番号を取得します。

戻り値:
srtMfrNoExt

getItemCatExt

public String getItemCatExt()
購買伝票の明細カテゴリを取得します。

戻り値:
srtItemCatExt

getDispQuan

public String getDispQuan()
購買発注数量: 表示目的全納入日程合計を取得します。

戻り値:
srtDispQuan

getPurMatExternal

public String getPurMatExternal()
項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
srtPurMatExternal

getPurMatGuid

public String getPurMatGuid()
項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
srtPurMatGuid

getPurMatVersion

public String getPurMatVersion()
項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
srtPurMatVersion

getPrClosed

public String getPrClosed()
購買依頼処理済を取得します。

戻り値:
srtPrClosed

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setAddress

public void setAddress(String strAddress)
住所を設定します。

パラメータ:
strAddress - 住所

setPurMat

public void setPurMat(String strPurMat)
品目コードを設定します。

パラメータ:
strPurMat - 品目コード

setStoreLoc

public void setStoreLoc(String strStoreLoc)
保管場所を設定します。

パラメータ:
strStoreLoc - 保管場所

setMatGrp

public void setMatGrp(String strMatGrp)
品目グループを設定します。

パラメータ:
strMatGrp - 品目グループ

setAllocTbl

public void setAllocTbl(String strAllocTbl)
商品配分表番号を設定します。

パラメータ:
strAllocTbl - 商品配分表番号

setAtItem

public void setAtItem(String strAtItem)
割当テーブルの明細番号を設定します。

パラメータ:
strAtItem - 割当テーブルの明細番号

setUnit

public void setUnit(String strUnit)
発注単位を設定します。

パラメータ:
strUnit - 発注単位

setPromotion

public void setPromotion(String strPromotion)
プロモーションを設定します。

パラメータ:
strPromotion - プロモーション

setManufProf

public void setManufProf(String strManufProf)
製造者製品プロファイルを設定します。

パラメータ:
strManufProf - 製造者製品プロファイル

setManuMat

public void setManuMat(String strManuMat)
製造者製品コードを設定します。

パラメータ:
strManuMat - 製造者製品コード

setMfrNo

public void setMfrNo(String strMfrNo)
製造者番号を設定します。

パラメータ:
strMfrNo - 製造者番号

setMfrNoExt

public void setMfrNoExt(String strMfrNoExt)
外部製造者コード名または番号を設定します。

パラメータ:
strMfrNoExt - 外部製造者コード名または番号

setItemCatExt

public void setItemCatExt(String strItemCatExt)
購買伝票の明細カテゴリを設定します。

パラメータ:
strItemCatExt - 購買伝票の明細カテゴリ

setDispQuan

public void setDispQuan(String strDispQuan)
購買発注数量: 表示目的全納入日程合計を設定します。

パラメータ:
strDispQuan - 購買発注数量: 表示目的全納入日程合計

setPurMatExternal

public void setPurMatExternal(String strPurMatExternal)
項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
strPurMatExternal - 項目 PURMAT の品目コード (長)

setPurMatGuid

public void setPurMatGuid(String strPurMatGuid)
項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
strPurMatGuid - 項目 PURMAT の外部 GUID

setPurMatVersion

public void setPurMatVersion(String strPurMatVersion)
項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
strPurMatVersion - 項目 PURMAT のバージョン番号

setPrClosed

public void setPrClosed(String strPrClosed)
購買依頼処理済を設定します。

パラメータ:
strPrClosed - 購買依頼処理済

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス PurchaseItem 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPayPost (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPayPost

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseOrderPayPostController, PurchaseOrderPostChangeController
public class PurchaseOrderPayPost
extends UpdateController
implements Serializable

伝票登録クラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPayPost()
コンストラクタ。
PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
void | executeBapi(BapiController bapiController) 購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
ArrayList | getAllVersionsList() 全バージョン一覧を取得します｡
ArrayList | getCondHeaderList() 条件ヘッダ一覧を取得します｡
ArrayList | getCondItemList() 条件明細一覧を取得します｡
ArrayList | getContractLimitsList() 外注基本契約制限一覧を取得します｡
ArrayList | getContractServiceAccountList() 外注サービス勘定設定一覧を取得します｡
ArrayList | getContractServiceList() 外注サービス一覧を取得します｡
ArrayList | getContractServiceTextList() 外注サービステキスト一覧を取得します｡
ArrayList | getDeliverryAddressList() 出荷伝票アドレス一覧を取得します｡
PurchaseHeaderPost | getDocumentHeader() 伝票ヘッダを取得します｡
ExportHeader | getExportHeader() 貿易管理ヘッダを取得します｡
ArrayList | getExportItemList() 貿易管理明細一覧を取得します｡
ArrayList | getExtensionList() 拡張得意先項目一覧を取得します｡
ArrayList | getHeaderTextList() ヘッダテキスト一覧を取得します｡
ArrayList | getItemTextList() 明細テキスト一覧を取得します｡
ArrayList | getLimitsList() 外注制限一覧を取得します｡
String | getMemoryComplete() エラーがない場合に購買発注を保留にする区分を取得します｡
String | getMemoryUnComplete() エラーがある場合に購買発注を保留にする区分を取得します｡
String | getNoAuthority() 権限チェックなし区分を取得します｡
String | getNoMessageReq() メッセージ不要区分を取得します｡
String | getNoMessaging() 出力決定なし区分を取得します｡
String | getNoPriceFromPo() 最終伝票からの価格転送なし区分を取得します｡
ArrayList | getPartnerList() 得意先一覧を取得します｡
String | getPoNumber() 購買伝票番号を取得します｡
ArrayList | getProfitSegmentList() 入出庫予定一覧を取得します｡
ArrayList | getPurchaseAccountList() 勘定設定一覧を取得します｡
ArrayList | getPurchaseItemPostList() 明細一覧を取得します｡
ArrayList | getPurchaseScheduleList() 納入日程一覧を取得します｡
VendorAddress | getSupplierInfo() 仕入先住所を取得します｡
String | getTestRun() テスト区分を取得します｡
Versions | getVersions() バージョン管理を取得します｡
void | setAllVersionsList(ArrayList allVersionsList) 全バージョン一覧を設定します｡
void | setCondHeaderList(ArrayList condHeaderList) 条件ヘッダ一覧を設定します｡
void | setCondItemList(ArrayList condItemList) 条件明細一覧を設定します｡
void | setContractLimitsList(ArrayList contractLimitsList) 外注基本契約制限一覧を設定します｡
void | setContractServiceAccountList(ArrayList contractServiceAccountList) 外注サービス勘定設定一覧を設定します｡
void | setContractServiceList(ArrayList contractServiceList) 外注サービス一覧を設定します｡
void | setContractServiceTextList(ArrayList contractServiceTextList) 外注サービステキスト一覧を設定します｡
void | setDeliveryAddressList(ArrayList deliveryAddressList) 入荷伝票アドレス一覧を設定します｡
void | setDocumentHeader(PurchaseHeaderPost documentHeader) 伝票ヘッダを設定します｡
void | setExportHeader(ExportHeader exportHeader) 貿易管理ヘッダを設定します｡
void | setExportItemList(ArrayList exportItemList) 貿易管理明細を設定します｡
void | setExportParam(BapiController bapiController) 伝票に登録された情報ををセットします。
void | setExtensionList(ArrayList extensionList) 拡張得意先項目を設定します｡
void | setHeaderTextList(ArrayList headerTextList) ヘッダテキスト一覧を設定します｡
void | setImportParam(BapiController bapiController) 伝票に登録する値ををセットします。
void | setItemTextList(ArrayList itemTextList) 明細テキスト一覧を設定します｡
void | setLimitsList(ArrayList limitsList) 外注制限一覧を設定します｡
void | setMemoryComplete(String memoryComplete) エラーがない場合に購買発注を保留する区分を設定します｡
void | setMemoryUnComplete(String memoryUnComplete) エラーがある場合に購買発注を保留する区分を設定します｡
void | setNoAuthority(String noAuthority) 権限チェックなし区分に購買発注を保留する区分を設定します｡
void | setNoMessage(String noMessaging) 出力決定なし区分に購買発注を保留する区分を設定します｡
void | setNoMessageReq(String noMessageReq) メッセージ不要区分を設定します｡
void | setNoPriceFromPo(String noPriceFromPo) 最終伝票からの価格転送なし区分を設定します｡
void | setPartnerList(ArrayList partnerList) 取引先一覧を設定します｡
void | setPoNumber(String poNumber) 購買伝票番号に値を設定します。
void | setProfitSegmentList(ArrayList profitSegmentList) 入出庫予定一覧を設定します｡
void | setPurchaseAccountList(ArrayList purchaseAccountList) 勘定設定一覧を設定します｡
void | setPurchaseItemPostList(ArrayList purchaseItemPostList) 明細一覧を設定します｡
void | setPurchaseScheduleList(ArrayList purchaseScheduleList) 納入日程一覧を設定します｡
void | setStrParam(String paramStr, String paramName, String value) 構造型の項目に値をセットします。
void | setSupplierInfo(VendorAddress supplierInfo) 仕入先住所を設定します｡
void | setTblParam(String paramTable, String paramName, String value, int index) テーブル型の項目に値をセットします。
void | setTestRun(String testRun) テスト区分を設定します｡
void | setVersions(Versions versions) バージョン管理ヘッダを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPayPost

public PurchaseOrderPayPost()
コンストラクタ。

PurchaseOrderPayPost

public PurchaseOrderPayPost(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

PurchaseOrderPayPost

public PurchaseOrderPayPost(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
伝票に登録された情報ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

setPoNumber

public void setPoNumber(String poNumber)
購買伝票番号に値を設定します。

パラメータ:
poNumber - 購買伝票番号

setTestRun

public void setTestRun(String testRun)
テスト区分を設定します｡

パラメータ:
testRun - テスト区分

setMemoryUnComplete

public void setMemoryUnComplete(String memoryUnComplete)
エラーがある場合に購買発注を保留する区分を設定します｡

パラメータ:
memoryUnComplete - エラーがある場合に購買発注を保留する区分

setMemoryComplete

public void setMemoryComplete(String memoryComplete)
エラーがない場合に購買発注を保留する区分を設定します｡

パラメータ:
memoryComplete - エラーがない場合に購買発注を保留する区分

setNoMessage

public void setNoMessage(String noMessaging)
出力決定なし区分に購買発注を保留する区分を設定します｡

パラメータ:
noMessaging - 出力決定なし区分

setNoMessageReq

public void setNoMessageReq(String noMessageReq)
メッセージ不要区分を設定します｡

パラメータ:
noMessageReq - メッセージ不要区分

setNoAuthority

public void setNoAuthority(String noAuthority)
権限チェックなし区分に購買発注を保留する区分を設定します｡

パラメータ:
noAuthority - 権限チェックなし区分

setNoPriceFromPo

public void setNoPriceFromPo(String noPriceFromPo)
最終伝票からの価格転送なし区分を設定します｡

パラメータ:
noPriceFromPo - 最終伝票からの価格転送なし区分

setDocumentHeader

public void setDocumentHeader(PurchaseHeaderPost documentHeader)
伝票ヘッダを設定します｡

パラメータ:
documentHeader - 伝票ヘッダ

setSupplierInfo

public void setSupplierInfo(VendorAddress supplierInfo)
仕入先住所を設定します｡

パラメータ:
supplierInfo - 仕入先住所

setExportHeader

public void setExportHeader(ExportHeader exportHeader)
貿易管理ヘッダを設定します｡

パラメータ:
exportHeader - 貿易管理ヘッダ

setVersions

public void setVersions(Versions versions)
バージョン管理ヘッダを設定します｡

パラメータ:
versions - バージョン管理ヘッダ

setPurchaseItemPostList

public void setPurchaseItemPostList(ArrayList purchaseItemPostList)
明細一覧を設定します｡

パラメータ:
purchaseItemPostList - 明細一覧

setDeliveryAddressList

public void setDeliveryAddressList(ArrayList deliveryAddressList)
入荷伝票アドレス一覧を設定します｡

パラメータ:
deliveryAddressList - 入荷伝票アドレス一覧

setPurchaseScheduleList

public void setPurchaseScheduleList(ArrayList purchaseScheduleList)
納入日程一覧を設定します｡

パラメータ:
purchaseScheduleList - 納入日程一覧

setProfitSegmentList

public void setProfitSegmentList(ArrayList profitSegmentList)
入出庫予定一覧を設定します｡

パラメータ:
profitSegmentList - 入出庫予定一覧

setPurchaseAccountList

public void setPurchaseAccountList(ArrayList purchaseAccountList)
勘定設定一覧を設定します｡

パラメータ:
purchaseAccountList - 勘定設定一覧

setCondHeaderList

public void setCondHeaderList(ArrayList condHeaderList)
条件ヘッダ一覧を設定します｡

パラメータ:
condHeaderList - 条件ヘッダ一覧

setCondItemList

public void setCondItemList(ArrayList condItemList)
条件明細一覧を設定します｡

パラメータ:
condItemList - 条件明細一覧

setLimitsList

public void setLimitsList(ArrayList limitsList)
外注制限一覧を設定します｡

パラメータ:
limitsList - 外注制限一覧

setContractLimitsList

public void setContractLimitsList(ArrayList contractLimitsList)
外注基本契約制限一覧を設定します｡

パラメータ:
contractLimitsList - 外注基本契約制限一覧

setContractServiceList

public void setContractServiceList(ArrayList contractServiceList)
外注サービス一覧を設定します｡

パラメータ:
contractServiceList - 外注サービス一覧

setContractServiceAccountList

public void setContractServiceAccountList(ArrayList contractServiceAccountList)
外注サービス勘定設定一覧を設定します｡

パラメータ:
contractServiceAccountList - 外注サービス勘定設定一覧

setContractServiceTextList

public void setContractServiceTextList(ArrayList contractServiceTextList)
外注サービステキスト一覧を設定します｡

パラメータ:
contractServiceTextList - 外注サービステキスト一覧

setExtensionList

public void setExtensionList(ArrayList extensionList)
拡張得意先項目を設定します｡

パラメータ:
extensionList - 拡張得意先項目

setExportItemList

public void setExportItemList(ArrayList exportItemList)
貿易管理明細を設定します｡

パラメータ:
exportItemList - 貿易管理明細

setHeaderTextList

public void setHeaderTextList(ArrayList headerTextList)
ヘッダテキスト一覧を設定します｡

パラメータ:
headerTextList - ヘッダテキスト一覧

setItemTextList

public void setItemTextList(ArrayList itemTextList)
明細テキスト一覧を設定します｡

パラメータ:
itemTextList - 明細テキスト一覧

setPartnerList

public void setPartnerList(ArrayList partnerList)
取引先一覧を設定します｡

パラメータ:
partnerList - 取引先一覧

setAllVersionsList

public void setAllVersionsList(ArrayList allVersionsList)
全バージョン一覧を設定します｡

パラメータ:
allVersionsList - 全バージョン一覧

getPoNumber

public String getPoNumber()
購買伝票番号を取得します｡

戻り値:
poNumber 購買伝票番号

getTestRun

public String getTestRun()
テスト区分を取得します｡

戻り値:
testRun テスト区分

getMemoryUnComplete

public String getMemoryUnComplete()
エラーがある場合に購買発注を保留にする区分を取得します｡

戻り値:
memoryUnComplete エラーがある場合に購買発注を保留にする区分

getMemoryComplete

public String getMemoryComplete()
エラーがない場合に購買発注を保留にする区分を取得します｡

戻り値:
memoryComplete エラーがない場合に購買発注を保留にする区分

getNoMessageReq

public String getNoMessageReq()
メッセージ不要区分を取得します｡

戻り値:
noMessageReq メッセージ不要区分

getNoAuthority

public String getNoAuthority()
権限チェックなし区分を取得します｡

戻り値:
noAuthority 権限チェックなし区分

getNoMessaging

public String getNoMessaging()
出力決定なし区分を取得します｡

戻り値:
noMessaging 出力決定なし区分

getNoPriceFromPo

public String getNoPriceFromPo()
最終伝票からの価格転送なし区分を取得します｡

戻り値:
noPriceFromPo 最終伝票からの価格転送なし区分

getDocumentHeader

public PurchaseHeaderPost getDocumentHeader()
伝票ヘッダを取得します｡

戻り値:
documentHeader 伝票ヘッダ

getSupplierInfo

public VendorAddress getSupplierInfo()
仕入先住所を取得します｡

戻り値:
VendorAddress 仕入先住所

getExportHeader

public ExportHeader getExportHeader()
貿易管理ヘッダを取得します｡

戻り値:
exportHeader 貿易管理ヘッダ

getVersions

public Versions getVersions()
バージョン管理を取得します｡

戻り値:
versions バージョン管理

getPurchaseItemPostList

public ArrayList getPurchaseItemPostList()
明細一覧を取得します｡

戻り値:
purchaseItemPostList 明細一覧

getDeliverryAddressList

public ArrayList getDeliverryAddressList()
出荷伝票アドレス一覧を取得します｡

戻り値:
deliveryAddressList 出荷伝票アドレス一覧

getPurchaseScheduleList

public ArrayList getPurchaseScheduleList()
納入日程一覧を取得します｡

戻り値:
purchaseScheduleList 納入日程一覧

getPurchaseAccountList

public ArrayList getPurchaseAccountList()
勘定設定一覧を取得します｡

戻り値:
purchaseAccountList 勘定設定一覧

getProfitSegmentList

public ArrayList getProfitSegmentList()
入出庫予定一覧を取得します｡

戻り値:
profitSegmentList 入出庫予定一覧

getCondHeaderList

public ArrayList getCondHeaderList()
条件ヘッダ一覧を取得します｡

戻り値:
condHeaderList 条件ヘッダ一覧

getCondItemList

public ArrayList getCondItemList()
条件明細一覧を取得します｡

戻り値:
condItemList 条件明細一覧

getLimitsList

public ArrayList getLimitsList()
外注制限一覧を取得します｡

戻り値:
limitsList 外注制限一覧

getContractLimitsList

public ArrayList getContractLimitsList()
外注基本契約制限一覧を取得します｡

戻り値:
contractLimitsList 外注基本契約制限一覧

getContractServiceList

public ArrayList getContractServiceList()
外注サービス一覧を取得します｡

戻り値:
contractServiceList 外注サービス一覧

getContractServiceAccountList

public ArrayList getContractServiceAccountList()
外注サービス勘定設定一覧を取得します｡

戻り値:
contractServiceAccountList 外注サービス勘定設定一覧

getContractServiceTextList

public ArrayList getContractServiceTextList()
外注サービステキスト一覧を取得します｡

戻り値:
contractServiceTextList 外注サービステキスト一覧

getExtensionList

public ArrayList getExtensionList()
拡張得意先項目一覧を取得します｡

戻り値:
extensionList 拡張得意先項目一覧

getExportItemList

public ArrayList getExportItemList()
貿易管理明細一覧を取得します｡

戻り値:
exportItemList 貿易管理明細一覧

getHeaderTextList

public ArrayList getHeaderTextList()
ヘッダテキスト一覧を取得します｡

戻り値:
headerTextList ヘッダテキスト一覧

getItemTextList

public ArrayList getItemTextList()
                          throws SAPPurchaseSystemException
明細テキスト一覧を取得します｡

戻り値:
itemTextList 明細テキスト一覧
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

getPartnerList

public ArrayList getPartnerList()
得意先一覧を取得します｡

戻り値:
partnerList 得意先一覧

getAllVersionsList

public ArrayList getAllVersionsList()
全バージョン一覧を取得します｡

戻り値:
allVersionsList 全バージョン一覧

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPPurchaseSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPPurchaseSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPayPostController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPayPostController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController
すべての実装インタフェース:
Serializable
public class PurchaseOrderPayPostController
extends PurchaseOrderPayPost
implements Serializable

伝票登録コントローラクラス
機能は以下の通り

  • 伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPayPostController()
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost から継承したメソッド
executeBapi, getAllVersionsList, getCondHeaderList, getCondItemList, getContractLimitsList, getContractServiceAccountList, getContractServiceList, getContractServiceTextList, getDeliverryAddressList, getDocumentHeader, getExportHeader, getExportItemList, getExtensionList, getHeaderTextList, getItemTextList, getLimitsList, getMemoryComplete, getMemoryUnComplete, getNoAuthority, getNoMessageReq, getNoMessaging, getNoPriceFromPo, getPartnerList, getPoNumber, getProfitSegmentList, getPurchaseAccountList, getPurchaseItemPostList, getPurchaseScheduleList, getSupplierInfo, getTestRun, getVersions, setAllVersionsList, setCondHeaderList, setCondItemList, setContractLimitsList, setContractServiceAccountList, setContractServiceList, setContractServiceTextList, setDeliveryAddressList, setDocumentHeader, setExportHeader, setExportItemList, setExportParam, setExtensionList, setHeaderTextList, setImportParam, setItemTextList, setLimitsList, setMemoryComplete, setMemoryUnComplete, setNoAuthority, setNoMessage, setNoMessageReq, setNoPriceFromPo, setPartnerList, setPoNumber, setProfitSegmentList, setPurchaseAccountList, setPurchaseItemPostList, setPurchaseScheduleList, setStrParam, setSupplierInfo, setTblParam, setTestRun, setVersions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPayPostController

public PurchaseOrderPayPostController()
PurchaseOrderPayPostControllerのコンストラクタを生成します。

PurchaseOrderPayPostController

public PurchaseOrderPayPostController(ConnectionManager connectionManager)
PurchaseOrderPayPostControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

PurchaseOrderPayPostController

public PurchaseOrderPayPostController(SapClient sapClient)
PurchaseOrderPayPostControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseOrderPostChangeController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseOrderPostChangeController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController
すべての実装インタフェース:
Serializable
public class PurchaseOrderPostChangeController
extends PurchaseOrderPayPost
implements Serializable

伝票登録変更コントローラクラス
機能は以下の通り

  • 伝票を変更します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseOrderPostChangeController()
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost から継承したメソッド
executeBapi, getAllVersionsList, getCondHeaderList, getCondItemList, getContractLimitsList, getContractServiceAccountList, getContractServiceList, getContractServiceTextList, getDeliverryAddressList, getDocumentHeader, getExportHeader, getExportItemList, getExtensionList, getHeaderTextList, getItemTextList, getLimitsList, getMemoryComplete, getMemoryUnComplete, getNoAuthority, getNoMessageReq, getNoMessaging, getNoPriceFromPo, getPartnerList, getPoNumber, getProfitSegmentList, getPurchaseAccountList, getPurchaseItemPostList, getPurchaseScheduleList, getSupplierInfo, getTestRun, getVersions, setAllVersionsList, setCondHeaderList, setCondItemList, setContractLimitsList, setContractServiceAccountList, setContractServiceList, setContractServiceTextList, setDeliveryAddressList, setDocumentHeader, setExportHeader, setExportItemList, setExportParam, setExtensionList, setHeaderTextList, setImportParam, setItemTextList, setLimitsList, setMemoryComplete, setMemoryUnComplete, setNoAuthority, setNoMessage, setNoMessageReq, setNoPriceFromPo, setPartnerList, setPoNumber, setProfitSegmentList, setPurchaseAccountList, setPurchaseItemPostList, setPurchaseScheduleList, setStrParam, setSupplierInfo, setTblParam, setTestRun, setVersions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController()
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController(ConnectionManager connectionManager)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

PurchaseOrderPostChangeController

public PurchaseOrderPostChangeController(SapClient sapClient)
PurchaseOrderPostChangeControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseRelease (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseRelease

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
PurchaseReleaseController, PurchaseResetReleaseController
public class PurchaseRelease
extends UpdateController
implements Serializable

承認情報スーパークラス
機能は以下の通り

  • 承認情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseRelease()
伝票承認を作成します。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
コンストラクタ生成。
PurchaseRelease(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
コンストラクタ生成。
メソッドの概要
void | executeBapi(BapiController bapiController) 伝票承認取消処理を実行します。
String | getPoRelCode() 承認コードを取得します。
String | getPurchaseorder() 購買発注番号を取得します。
String | getRelIndicatorNew() 返却規承認区分を取得します。
String | getRelStatusNew() 返却承認状況を取得します。
String | getUseExceptions() 例外メッセージ設定とエラーメッセージ出力を取得します。
void | setExportParam(BapiController bapiController) 実行結果を取得します。
void | setPoRelCode(String strPoRelCode) 承認コードを設定します。
void | setPurchaseorder(String strPurchaseorder) 購買発注番号を設定します。
void | setRelIndicatorNew(String strRelIndicatorNew) 返却承認区分を設定します。
void | setRelStatusNew(String strRelStatusNew) 返却承認状況を設定します。
void | setUseExceptions(String strUseExceptions) 例外メッセージ設定とエラーメッセージ出力を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseRelease

public PurchaseRelease()
伝票承認を作成します。

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       ConnectionManager connectionManager)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
connectionManager - コネクションマネージャー

PurchaseRelease

public PurchaseRelease(String purchaseorder,
                       String poRelCode,
                       String useExceptions,
                       SapClient sapClient)
コンストラクタ生成。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ出力区分
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi(BapiController bapiController)
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPBapiReturnErrMessageExistException
伝票承認取消処理を実行します。

オーバーライド:
クラス AbstractController 内の executeBapi
パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
実行結果を取得します。

パラメータ:
bapiController - BAPIコントローラー
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

getPurchaseorder

public String getPurchaseorder()
購買発注番号を取得します。

戻り値:
srtPurchaseorder

getPoRelCode

public String getPoRelCode()
承認コードを取得します。

戻り値:
srtPoRelCode

getUseExceptions

public String getUseExceptions()
例外メッセージ設定とエラーメッセージ出力を取得します。

戻り値:
srtUseExceptions

getRelStatusNew

public String getRelStatusNew()
返却承認状況を取得します。

戻り値:
srtRelStatusNew

getRelIndicatorNew

public String getRelIndicatorNew()
返却規承認区分を取得します。

戻り値:
srtRelIndicatorNew

setPurchaseorder

public void setPurchaseorder(String strPurchaseorder)
購買発注番号を設定します。

パラメータ:
strPurchaseorder - 購買発注番号

setPoRelCode

public void setPoRelCode(String strPoRelCode)
承認コードを設定します。

パラメータ:
strPoRelCode - 承認コード

setUseExceptions

public void setUseExceptions(String strUseExceptions)
例外メッセージ設定とエラーメッセージ出力を設定します。

パラメータ:
strUseExceptions - 例外メッセージ設定とエラーメッセージ出力

setRelStatusNew

public void setRelStatusNew(String strRelStatusNew)
返却承認状況を設定します。

パラメータ:
strRelStatusNew - 返却承認状況

setRelIndicatorNew

public void setRelIndicatorNew(String strRelIndicatorNew)
返却承認区分を設定します。

パラメータ:
strRelIndicatorNew - 返却規承認区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseReleaseController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseReleaseController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController
すべての実装インタフェース:
Serializable
public class PurchaseReleaseController
extends PurchaseRelease
implements Serializable

伝票承認コントローラクラス
機能は以下の通り

  • 伝票を承認します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
メソッドの概要
void | executeBapi() 伝票承認処理を実行します。
String | getRetCode() リターン値、ABAP 命令後のリターン値を取得します。
void | setRetCode(String strRetCode) リターン値、ABAP 命令後のリターン値を設定します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease から継承したメソッド
executeBapi, getPoRelCode, getPurchaseorder, getRelIndicatorNew, getRelStatusNew, getUseExceptions, setExportParam, setPoRelCode, setPurchaseorder, setRelIndicatorNew, setRelStatusNew, setUseExceptions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
connectionManager - コネクションマネージャー

PurchaseReleaseController

public PurchaseReleaseController(String purchaseorder,
                                 String poRelCode,
                                 String useExceptions,
                                 SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
伝票承認処理を実行します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

getRetCode

public String getRetCode()
                  throws SAPPurchaseSystemException
リターン値、ABAP 命令後のリターン値を取得します。

戻り値:
srtRetCode
例外:
SAPPurchaseSystemException - 購買発注業務システム例外

setRetCode

public void setRetCode(String strRetCode)
リターン値、ABAP 命令後のリターン値を設定します。

パラメータ:
strRetCode - リターン値、ABAP 命令後のリターン値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseResetReleaseController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseResetReleaseController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease
                拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController
すべての実装インタフェース:
Serializable
public class PurchaseResetReleaseController
extends PurchaseRelease
implements Serializable

伝票承認取消コントローラクラス
機能は以下の通り

  • 伝票の承認取消します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String purchaseorder, String poRelCode, String useExceptions, SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
メソッドの概要
 void executeBapi()
伝票承認取消処理を実行します。
クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease から継承したメソッド
executeBapi, getPoRelCode, getPurchaseorder, getRelIndicatorNew, getRelStatusNew, getUseExceptions, setExportParam, setPoRelCode, setPurchaseorder, setRelIndicatorNew, setRelStatusNew, setUseExceptions, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

【重要】標準BAPIでは、BAPI内部でコミット処理が実行されます。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions,
                                      ConnectionManager connectionManager)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RESET_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
connectionManager - コネクションマネージャー

PurchaseResetReleaseController

public PurchaseResetReleaseController(String purchaseorder,
                                      String poRelCode,
                                      String useExceptions,
                                      SapClient sapClient)
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】このAPIが使用する標準のBAPI(BAPI_PO_RESET_RELEASE)では、BAPI実行時にコミット処理が実行されます。 つまり、executeBapi()実行後にここまでのコネクションマネージャーで実行したすべての処理がコミットされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
purchaseorder - 購買発注番号
poRelCode - 承認コード
useExceptions - 例外メッセージ設定とエラーメッセージ出力
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
伝票承認取消処理を実行します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseSchedule (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseSchedule

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule
すべての実装インタフェース:
Serializable
public class PurchaseSchedule
extends Object
implements Serializable

購買発注伝票納入日程情報クラス
機能は以下の通り

  • 購買発注伝票納入日程情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseSchedule()
購買発注伝票納入日程を作成します。
PurchaseSchedule(int index)
購買発注伝票納入日程を作成します。
メソッドの概要
String | getDelDatcatExt() 納入期日カテゴリを取得します。
String | getDeleteInd() 購買伝票の削除フラグを取得します。
String | getDeliveryDate() 納入期日を取得します。
String | getDelivTime() 納入期日における指定時間を取得します。
String | getGiDate() 出庫日付を取得します。
String | getGiTime() 出庫時刻 (現地時間 - プラント参照)を取得します。
String | getLoadDate() 積載日付を取得します。
String | getLoadTime() 積載時刻 (現地時間: 出荷ポイント)を取得します。
String | getMsDate() 品目利用可能日を取得します。
String | getMsTime() 品目供給ステージ (現地時刻: プラント参照)を取得します。
String | getPoDate() 納入日程の購買発注日付を取得します。
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPreqItem() 購買依頼の明細番号を取得します。
String | getPreqNo() 購買依頼番号を取得します。
String | getQuantity() 計画数量を取得します。
String | getRoutesched() 輸送経路計画を取得します。
String | getSchedLine() 納入日程行を取得します。
int | getScIndex() レコード番号を取得します｡
String | getStatDate() 統計的納入期日を取得します。
String | getTpDate() 輸送計画日付を取得します。
String | getTpTime() 輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
void | setDelDatcatExt(String strDelDatcatExt) 納入期日カテゴリを設定します。
void | setDeleteInd(String strDeleteInd) 購買伝票の削除フラグを設定します。
void | setDeliveryDate(String strDeliveryDate) 納入期日を設定します。
void | setDelivTime(String strDelivTime) 納入期日における指定時間を設定します。
void | setGiDate(String strGiDate) 出庫日付を設定します。
void | setGiTime(String strGiTime) 出庫時刻 (現地時間 - プラント参照)を設定します。
void | setLoadDate(String strLoadDate) 積載日付を設定します。
void | setLoadTime(String strLoadTime) 積載時刻 (現地時間: 出荷ポイント)を設定します。
void | setMsDate(String strMsDate) 品目利用可能日を設定します。
void | setMsTime(String strMsTime) 品目供給ステージ (現地時刻: プラント参照)を設定します。
void | setPoDate(String strPoDate) 納入日程の購買発注日付を設定します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPreqItem(String strPreqItem) 購買依頼の明細番号を設定します。
void | setPreqNo(String strPreqNo) 購買依頼番号を設定します。
void | setQuantity(String strQuantity) 計画数量を設定します。
void | setRoutesched(String strRoutesched) 輸送経路計画を設定します。
void | setSchedLine(String strSchedLine) 納入日程行を設定します。
void | setScIndex(int scIndex) レコード番号を設定します｡
void | setStatDate(String strStatDate) 統計的納入期日を設定します。
void | setTpDate(String strTpDate) 輸送計画日付を設定します。
void | setTpTime(String strTpTime) 輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseSchedule

public PurchaseSchedule()
購買発注伝票納入日程を作成します。

PurchaseSchedule

public PurchaseSchedule(int index)
購買発注伝票納入日程を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
srtSchedLine 納入日程行

getDelDatcatExt

public String getDelDatcatExt()
納入期日カテゴリを取得します。

戻り値:
srtDelDatcatExt 納入期日カテゴリ

getDeliveryDate

public String getDeliveryDate()
納入期日を取得します。

戻り値:
srtDeliveryDate 納入期日

getQuantity

public String getQuantity()
計画数量を取得します。

戻り値:
srtQuantity 計画数量

getDelivTime

public String getDelivTime()
納入期日における指定時間を取得します。

戻り値:
srtDelivTime 納入期日における指定時間

getStatDate

public String getStatDate()
統計的納入期日を取得します。

戻り値:
srtStatDate 統計的納入期日

getPreqNo

public String getPreqNo()
購買依頼番号を取得します。

戻り値:
srtPreqNo 購買依頼番号

getPreqItem

public String getPreqItem()
購買依頼の明細番号を取得します。

戻り値:
srtPreqItem 購買依頼の明細番号

getPoDate

public String getPoDate()
納入日程の購買発注日付を取得します。

戻り値:
srtPoDate 納入日程の購買発注日付

getRoutesched

public String getRoutesched()
輸送経路計画を取得します。

戻り値:
srtRoutesched 輸送経路計画

getMsDate

public String getMsDate()
品目利用可能日を取得します。

戻り値:
srtMsDate 品目利用可能日

getMsTime

public String getMsTime()
品目供給ステージ (現地時刻: プラント参照)を取得します。

戻り値:
srtMsTime 品目供給ステージ (現地時刻: プラント参照)

getLoadDate

public String getLoadDate()
積載日付を取得します。

戻り値:
srtLoadDate 積載日付

getLoadTime

public String getLoadTime()
積載時刻 (現地時間: 出荷ポイント)を取得します。

戻り値:
srtLoadTime 積載時刻 (現地時間: 出荷ポイント)

getTpDate

public String getTpDate()
輸送計画日付を取得します。

戻り値:
srtTpDate 輸送計画日付

getTpTime

public String getTpTime()
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。

戻り値:
srtTpTime 輸送計画 - 時間 (現地時間/出荷ポイント参照)

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
srtGiDate 出庫日付

getGiTime

public String getGiTime()
出庫時刻 (現地時間 - プラント参照)を取得します。

戻り値:
srtGiTime 出庫時刻 (現地時間 - プラント参照)

getDeleteInd

public String getDeleteInd()
購買伝票の削除フラグを取得します。

戻り値:
srtDeleteInd 購買伝票の削除フラグ

getScIndex

public int getScIndex()
レコード番号を取得します｡

戻り値:
scIndex レコード番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setSchedLine

public void setSchedLine(String strSchedLine)
納入日程行を設定します。

パラメータ:
strSchedLine - 納入日程行

setDelDatcatExt

public void setDelDatcatExt(String strDelDatcatExt)
納入期日カテゴリを設定します。

パラメータ:
strDelDatcatExt - 納入期日カテゴリ

setDeliveryDate

public void setDeliveryDate(String strDeliveryDate)
納入期日を設定します。

パラメータ:
strDeliveryDate - 納入期日

setQuantity

public void setQuantity(String strQuantity)
計画数量を設定します。

パラメータ:
strQuantity - 計画数量

setDelivTime

public void setDelivTime(String strDelivTime)
納入期日における指定時間を設定します。

パラメータ:
strDelivTime - 納入期日における指定時間

setStatDate

public void setStatDate(String strStatDate)
統計的納入期日を設定します。

パラメータ:
strStatDate - 統計的納入期日

setPreqNo

public void setPreqNo(String strPreqNo)
購買依頼番号を設定します。

パラメータ:
strPreqNo - 購買依頼番号

setPreqItem

public void setPreqItem(String strPreqItem)
購買依頼の明細番号を設定します。

パラメータ:
strPreqItem - 購買依頼の明細番号

setPoDate

public void setPoDate(String strPoDate)
納入日程の購買発注日付を設定します。

パラメータ:
strPoDate - 納入日程の購買発注日付

setRoutesched

public void setRoutesched(String strRoutesched)
輸送経路計画を設定します。

パラメータ:
strRoutesched - 輸送経路計画

setMsDate

public void setMsDate(String strMsDate)
品目利用可能日を設定します。

パラメータ:
strMsDate - 品目利用可能日

setMsTime

public void setMsTime(String strMsTime)
品目供給ステージ (現地時刻: プラント参照)を設定します。

パラメータ:
strMsTime - 品目供給ステージ (現地時刻: プラント参照)

setLoadDate

public void setLoadDate(String strLoadDate)
積載日付を設定します。

パラメータ:
strLoadDate - 積載日付

setLoadTime

public void setLoadTime(String strLoadTime)
積載時刻 (現地時間: 出荷ポイント)を設定します。

パラメータ:
strLoadTime - 積載時刻 (現地時間: 出荷ポイント)

setTpDate

public void setTpDate(String strTpDate)
輸送計画日付を設定します。

パラメータ:
strTpDate - 輸送計画日付

setTpTime

public void setTpTime(String strTpTime)
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。

パラメータ:
strTpTime - 輸送計画 - 時間 (現地時間/出荷ポイント参照)

setGiDate

public void setGiDate(String strGiDate)
出庫日付を設定します。

パラメータ:
strGiDate - 出庫日付

setGiTime

public void setGiTime(String strGiTime)
出庫時刻 (現地時間 - プラント参照)を設定します。

パラメータ:
strGiTime - 出庫時刻 (現地時間 - プラント参照)

setDeleteInd

public void setDeleteInd(String strDeleteInd)
購買伝票の削除フラグを設定します。

パラメータ:
strDeleteInd - 購買伝票の削除フラグ

setScIndex

public void setScIndex(int scIndex)
レコード番号を設定します｡

パラメータ:
scIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PurchaseText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス PurchaseText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ContractServiceText
public class PurchaseText
extends Object
implements Serializable

購買発注伝票テキストクラス
機能は以下の通り

  • 購買発注伝テキストを保持します。

関連項目:
直列化された形式

コンストラクタの概要
PurchaseText()
購買発注伝票テキストを作成します。
PurchaseText(int index)
購買発注伝票テキストを作成します。
メソッドの概要
String | getPoItem() 購買伝票の明細番号を取得します。
String | getPoNumber() 購買伝票番号を取得します。
int | getTeIndex() レコード番号を取得します｡
String | getTextForm() タグ列を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setPoItem(String strPoItem) 購買伝票の明細番号を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setTeIndex(int teIndex) レコード番号を設定します｡
void | setTextForm(String strTextForm) タグ列を設定します。
void | setTextId(String strTextId) テキスト IDを設定します。
void | setTextLine(String strTextLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PurchaseText

public PurchaseText()
購買発注伝票テキストを作成します。

PurchaseText

public PurchaseText(int index)
購買発注伝票テキストを作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber 購買伝票番号

getPoItem

public String getPoItem()
購買伝票の明細番号を取得します。

戻り値:
srtPoItem 購買伝票の明細番号

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
srtTextId テキスト ID

getTextForm

public String getTextForm()
タグ列を取得します。

戻り値:
srtTextForm タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
srtTextLine テキスト行

getTeIndex

public int getTeIndex()
レコード番号を取得します｡

戻り値:
teIndex レコード番号

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setPoItem

public void setPoItem(String strPoItem)
購買伝票の明細番号を設定します。

パラメータ:
strPoItem - 購買伝票の明細番号

setTextId

public void setTextId(String strTextId)
テキスト IDを設定します。

パラメータ:
strTextId - テキスト ID

setTextForm

public void setTextForm(String strTextForm)
タグ列を設定します。

パラメータ:
strTextForm - タグ列

setTextLine

public void setTextLine(String strTextLine)
テキスト行を設定します。

パラメータ:
strTextLine - テキスト行

setTeIndex

public void setTeIndex(int teIndex)
レコード番号を設定します｡

パラメータ:
teIndex - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrganisationSelection (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SalesOrganisationSelection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection
すべての実装インタフェース:
Serializable
public class SalesOrganisationSelection
extends Selection
implements Serializable

販売組織の選択オプションクラス
機能は以下の通り

  • 販売組織の選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesOrganisationSelection()
販売組織の選択オプション情報を作成します。
SalesOrganisationSelection(int index)
販売組織の選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getSalesorgHigh() 販売組織の範囲終了を取得します。
String | getSalesorgLow() 販売組織の範囲開始を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setSalesorgHigh(String strSalesorgHigh) 販売組織の範囲終了を設定します。
void | setSalesorgLow(String strSalesorgLow) 販売組織の範囲開始を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrganisationSelection

public SalesOrganisationSelection()
販売組織の選択オプション情報を作成します。

SalesOrganisationSelection

public SalesOrganisationSelection(int index)
販売組織の選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSalesorgLow

public String getSalesorgLow()
販売組織の範囲開始を取得します。

戻り値:
srtSalesorgLow 販売組織の範囲開始

getSalesorgHigh

public String getSalesorgHigh()
販売組織の範囲終了を取得します。

戻り値:
srtSalesorgHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index レコード番号

setSalesorgLow

public void setSalesorgLow(String strSalesorgLow)
販売組織の範囲開始を設定します。

パラメータ:
strSalesorgLow - 販売組織の範囲開始

setSalesorgHigh

public void setSalesorgHigh(String strSalesorgHigh)
販売組織の範囲終了を設定します。

パラメータ:
strSalesorgHigh - 販売組織の範囲終了

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Selection (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Selection

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
DistributionChannelSelection, MaterialShortDescsel, MatnrSelection, PlantSelection, SalesOrganisationSelection, StorageLocationSelect
public class Selection
extends Object
implements Serializable

選択オプションクラス
機能は以下の通り

  • 選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Selection()
選択オプション情報を作成します。
メソッドの概要
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setOption(String strOption) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setSign(String strSign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Selection

public Selection()
選択オプション情報を作成します。

メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
srtSign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
srtOption 選択演算子 OPTION (範囲テーブル)

setSign

public void setSign(String strSign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
strSign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String strOption)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
strOption - 選択演算子 OPTION (範囲テーブル)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StdMaterialGetIntNumberController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス StdMaterialGetIntNumberController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController
すべての実装インタフェース:
Serializable
public class StdMaterialGetIntNumberController
extends Object
implements Serializable

品目コード割当済照会コントローラクラス。
機能は以下の通り

  • 品目コード割当済情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String materialType, String industrySector, String requiredNumbers, SapClient sapClient)
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
メソッドの概要
List | getStdMaterialGetIntNumberList() 品目コード割当済一覧(結果)を取得します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StdMaterialGetIntNumberController

public StdMaterialGetIntNumberController(String materialType,
                                         String industrySector,
                                         String requiredNumbers)
                                  throws SAPAuthAppException,
                                         SAPAuthSystemException,
                                         SAPGeneralAppException,
                                         SAPGeneralSystemException,
                                         SAPPurchaseSystemException,
                                         SAPPurchaseAppException
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外

StdMaterialGetIntNumberController

public StdMaterialGetIntNumberController(String materialType,
                                         String industrySector,
                                         String requiredNumbers,
                                         SapClient sapClient)
                                  throws SAPAuthAppException,
                                         SAPAuthSystemException,
                                         SAPGeneralAppException,
                                         SAPGeneralSystemException,
                                         SAPPurchaseSystemException,
                                         SAPPurchaseAppException
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバ接続が可能となります。

パラメータ:
materialType - 品目タイプ
industrySector - 産業コード
requiredNumbers - 必須品目コードの設定
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseSystemException - 購買系業務システム例外
SAPPurchaseAppException - 購買系業務アプリケーション例外
メソッドの詳細

getStdMaterialGetIntNumberList

public List getStdMaterialGetIntNumberList()
品目コード割当済一覧(結果)を取得します。

戻り値:
stdMaterialGetIntNumberList 品目コード割当済一覧(結果)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StorageLocationSelect (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス StorageLocationSelect

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Selection
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect
すべての実装インタフェース:
Serializable
public class StorageLocationSelect
extends Selection
implements Serializable

保管場所の選択オプションクラス
機能は以下の通り

  • 保管場所の選択オプションの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StorageLocationSelect()
保管場所の選択オプション情報を作成します。
StorageLocationSelect(int index)
保管場所の選択オプション情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します。
String | getStlocHigh() 終了保管場所を取得します。
String | getStlocLow() 開始保管場所を取得します。
void | setIndex(int index) レコード番号を設定します。
void | setStlocHigh(String strStlocHigh) 終了保管場所を設定します。
void | setStlocLow(String strStlocLow) 開始保管場所を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection から継承したメソッド
getOption, getSign, setOption, setSign
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StorageLocationSelect

public StorageLocationSelect()
保管場所の選択オプション情報を作成します。

StorageLocationSelect

public StorageLocationSelect(int index)
保管場所の選択オプション情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStlocLow

public String getStlocLow()
開始保管場所を取得します。

戻り値:
srtStlocLow

getStlocHigh

public String getStlocHigh()
終了保管場所を取得します。

戻り値:
srtStlocHigh

getIndex

public int getIndex()
レコード番号を取得します。

戻り値:
index

setStlocLow

public void setStlocLow(String strStlocLow)
開始保管場所を設定します。

パラメータ:
strStlocLow - 開始保管場所

setStlocHigh

public void setStlocHigh(String strStlocHigh)
終了保管場所を設定します。

パラメータ:
strStlocHigh - 終了保管場所

setIndex

public void setIndex(int index)
レコード番号を設定します。

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス Selection 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail
すべての実装インタフェース:
Serializable
public class SupplierDetail
extends ReferenceController
implements Serializable

仕入先マスタ詳細情報クラス
機能は以下の通り

  • 仕入先マスタの詳細情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierDetail(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先マスタ詳細を作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先マスタ詳細を作成します。
ArrayList | getBankDataInfoList() 銀行データ情報一覧を取得します｡
CompanyDataInfo | getCompanyDataInfo() 会社コード依存データ情報を取得します｡
String | getCompCode() 会社コードを取得します｡
GeneralDataInfo | getGeneralDataInfo() 一般データ情報を取得します｡
String | getVendor() 仕入先コードを取得します｡
void | setBankDataInfoList(ArrayList bankDataInfoList) 銀行データ情報を設定します｡
void | setCompanyDataInfo(CompanyDataInfo companyDataInfo) 会社依存データ情報を設定します｡
void | setCompCode(String strCompode) 会社コードを設定します｡
void | setGeneralDataInfo(GeneralDataInfo generalDataInfo) 一般データ情報を設定します｡
void | setVendor(String strVendor) 仕入先コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierDetail

public SupplierDetail(SapClient sapClient)
仕入先詳細情報クラスを取得します

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierDetail

public SupplierDetail(String vendor,
                      String compCode,
                      SapClient sapClient)
               throws SAPAuthAppException,
                      SAPAuthSystemException,
                      SAPGeneralAppException,
                      SAPGeneralSystemException,
                      SAPPurchaseAppException,
                      SAPPurchaseSystemException
executeBapiを呼び出し仕入先マスタ詳細を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先マスタ詳細を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
strVendor 仕入先コード

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompode 会社コード

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
generalDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
companyDataInfo

getBankDataInfoList

public ArrayList getBankDataInfoList()
銀行データ情報一覧を取得します｡

戻り値:
bankDataInfoList

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompode)
会社コードを設定します｡

パラメータ:
strCompode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierExistenceCheck (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierExistenceCheck

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck
すべての実装インタフェース:
Serializable
public class SupplierExistenceCheck
extends ReferenceController
implements Serializable

仕入先コード存在チェッククラス
機能は以下の通り

  • 仕入先コード存在チェック結果を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String vendor, String compCode, SapClient sapClient)
executeBapiを呼び出し仕入先コード存在チェックを作成します。
メソッドの概要
void | executeBapi() BapiControllerにより仕入先コード存在チェックを作成します。
String | getCheckReturn() 結果を取得します｡
String | getCompCode() 会社コードを取得します｡
String | getVendor() 仕入先コードを取得します｡
void | setCheckReturn(String checkReturn) 結果を設定します｡
void | setCompCode(String strCompCode) 会社コードを設定します｡
void | setVendor(String strVendor) 仕入先コードを設定します｡
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierExistenceCheck

public SupplierExistenceCheck(SapClient sapClient)
仕入先詳細情報クラスを取得します

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierExistenceCheck

public SupplierExistenceCheck(String vendor,
                              String compCode,
                              SapClient sapClient)
                       throws SAPAuthAppException,
                              SAPAuthSystemException,
                              SAPGeneralAppException,
                              SAPGeneralSystemException,
                              SAPPurchaseAppException,
                              SAPPurchaseSystemException
executeBapiを呼び出し仕入先コード存在チェックを作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
BapiControllerにより仕入先コード存在チェックを作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 会計業務システム例外

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
strVendor 仕入先コード

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
strCompCode 会社コード

getCheckReturn

public String getCheckReturn()
結果を取得します｡

戻り値:
checkReturn 結果

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCheckReturn

public void setCheckReturn(String checkReturn)
結果を設定します｡

パラメータ:
checkReturn - 結果

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierExistenceCheckController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierExistenceCheckController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController
すべての実装インタフェース:
Serializable
public class SupplierExistenceCheckController
extends Object
implements Serializable

仕入先コード存在チェックコントローラ
機能は以下の通り

  • 仕入先コード存在チェックを行います。

関連項目:
直列化された形式

コンストラクタの概要
SupplierExistenceCheckController()
コンストラクタ生成
SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成
SupplierExistenceCheckController(String vendor, String compCode)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String vendor, String compCode, SapClient sapClient)
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
メソッドの概要
 void executeBapi()
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
 String getCheckReturn()
結果情報を取得します｡
 String getCompCode()
会社コードを取得します｡
 SupplierExistenceCheck getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡
 String getVendor()
仕入先コードを取得します｡
static void setCheckReturn(String checkReturn)
結果を設定します｡
 void setCompCode(String strCompCode)
会社コードを設定します｡
 void setVendor(String strVendor)
仕入先コードを設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierExistenceCheckController

public SupplierExistenceCheckController()
コンストラクタ生成

SupplierExistenceCheckController

public SupplierExistenceCheckController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierExistenceCheckController

public SupplierExistenceCheckController(String vendor,
                                        String compCode)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPPurchaseAppException,
                                        SAPPurchaseSystemException
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

SupplierExistenceCheckController

public SupplierExistenceCheckController(String vendor,
                                        String compCode,
                                        SapClient sapClient)
                                 throws SAPAuthAppException,
                                        SAPAuthSystemException,
                                        SAPGeneralAppException,
                                        SAPGeneralSystemException,
                                        SAPPurchaseAppException,
                                        SAPPurchaseSystemException
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します｡

パラメータ:
strCompCode - 会社コード

setCheckReturn

public static void setCheckReturn(String checkReturn)
結果を設定します｡

パラメータ:
checkReturn - 結果

getSupplierExistenceCheck

public SupplierExistenceCheck getSupplierExistenceCheck()
仕入先コードチェック情報を取得します｡

戻り値:
supplierExistenceCheck

getCheckReturn

public String getCheckReturn()
結果情報を取得します｡

戻り値:
checkReturn

getVendor

public String getVendor()
仕入先コードを取得します｡

戻り値:
vendor

getCompCode

public String getCompCode()
会社コードを取得します｡

戻り値:
compCode

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SupplierGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス SupplierGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController
すべての実装インタフェース:
Serializable
public class SupplierGetDetailController
extends Object
implements Serializable

仕入先マスタの詳細情報取得コントローラ
機能は以下の通り

  • 仕入先マスタの詳細情報を取得します。

関連項目:
直列化された形式

コンストラクタの概要
SupplierGetDetailController()
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String vendor, String compCode, SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
メソッドの概要
 void executeBapi()
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
 ArrayList getBankDataList()
銀行データ情報を取得します。
 CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡
 GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡
 SupplierDetail getSupplierDetail()
仕入先マスタ詳細情報を取得します｡
 void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡
 void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡
 void setCompCode(String strCompode)
会社コードを設定します｡
 void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡
 void setVendor(String strVendor)
仕入先コードを設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SupplierGetDetailController

public SupplierGetDetailController()
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

SupplierGetDetailController

public SupplierGetDetailController(SapClient sapClient)
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト

SupplierGetDetailController

public SupplierGetDetailController(String vendor,
                                   String compCode)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseAppException,
                                   SAPPurchaseSystemException
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

SupplierGetDetailController

public SupplierGetDetailController(String vendor,
                                   String compCode,
                                   SapClient sapClient)
                            throws SAPAuthAppException,
                                   SAPAuthSystemException,
                                   SAPGeneralAppException,
                                   SAPGeneralSystemException,
                                   SAPPurchaseAppException,
                                   SAPPurchaseSystemException
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。

パラメータ:
vendor - 仕入先コード
compCode - 会社コード
sapClient - sapClient SAPへの接続情報が格納されたオブジェクト
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPPurchaseAppException,
                        SAPPurchaseSystemException
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPPurchaseAppException - 購買発注業務アプリケーション例外
SAPPurchaseSystemException - 購買発注業務システム例外

getSupplierDetail

public SupplierDetail getSupplierDetail()
仕入先マスタ詳細情報を取得します｡

戻り値:
SupplierDetail

getGeneralDataInfo

public GeneralDataInfo getGeneralDataInfo()
一般データ情報を取得します｡

戻り値:
GeneralDataInfo

getCompanyDataInfo

public CompanyDataInfo getCompanyDataInfo()
会社コード依存データ情報を取得します｡

戻り値:
CompanyDataInfo

getBankDataList

public ArrayList getBankDataList()
銀行データ情報を取得します。

戻り値:
String 銀行国コード(銀行データ情報)

setVendor

public void setVendor(String strVendor)
仕入先コードを設定します｡

パラメータ:
strVendor - 仕入先コード

setCompCode

public void setCompCode(String strCompode)
会社コードを設定します｡

パラメータ:
strCompode - 会社コード

setGeneralDataInfo

public void setGeneralDataInfo(GeneralDataInfo generalDataInfo)
一般データ情報を設定します｡

パラメータ:
generalDataInfo - 一般データ情報

setCompanyDataInfo

public void setCompanyDataInfo(CompanyDataInfo companyDataInfo)
会社依存データ情報を設定します｡

パラメータ:
companyDataInfo - 会社依存データ情報

setBankDataInfoList

public void setBankDataInfoList(ArrayList bankDataInfoList)
銀行データ情報を設定します｡

パラメータ:
bankDataInfoList - 銀行データ情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VendorAddress (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス VendorAddress

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo
        拡張 jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
すべての実装インタフェース:
Serializable
public class VendorAddress
extends GeneralDataInfo

仕入先住所情報クラス
機能は以下の通り

  • 仕入先住所を保持します。

関連項目:
直列化された形式

コンストラクタの概要
VendorAddress()
入出庫予定を作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getLocation() 地名 5を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoNumber() 購買伝票番号を取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String strAddrNo) アドレス番号を設定します。
void | setAdrNotes(String strAdrNotes) 住所注記を設定します。
void | setBuilding(String strBuilding) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String strBuildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String strChckstatus) 市区町村ファイルテストステータスを設定します。
void | setCityNo(String strCityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String strCommType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String strCOName) 気付を設定します。
void | setDelivDis(String strDelivDis) 郵便配達地域を設定します。
void | setDistrctNo(String strDistrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setEMail(String strEMail) 電子メールアドレスを設定します。
void | setFaxExtens(String strFaxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String strFaxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String strFloor) 建物の階を設定します。
void | setHouseNo(String strHouseNo) 番地-号を設定します。
void | setHouseNo2(String strHouseNo2) 番地補足を設定します。
void | setLocation(String strLocation) 地名 5を設定します。
void | setPboxcitNo(String strPboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPoBoxCit(String strPoBoxCit) 私書箱住所を設定します。
void | setPoNumber(String strPoNumber) 購買伝票番号を設定します。
void | setPostlCod1(String strPostlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String strPostlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String strPostlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setRegiogroup(String strRegiogroup) 地域構造グループ化を設定します。
void | setRoomNo(String strRoomNo) 部屋/アパート番号を設定します。
void | setSort1(String strSort1) 検索条件 1を設定します。
void | setSort2(String strSort2) 検索条件 2を設定します。
void | setStrAbbr(String strStrAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreetLng(String strStreetLng) 地名を設定します。
void | setStreetNo(String strStreetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strStrSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strStrSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strStrSuppl3) 地名 4を設定します。
void | setTaxjurcode(String strTaxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String strTel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String strTel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String strTimeZone) アドレスタイムゾーンを設定します。
void | setTitle(String strTitle) タイトル (敬称)を設定します。
void | setTranspzone(String strTranspzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo から継承したメソッド
getCity, getCityCode, getCountry, getCountryiso, getCountycode, getCustomer, getDistrict, getFax1, getFormofaddr, getLangu, getLanguIso, getName_2, getName_3, getName_4, getName, getPoBox, getPobxCty, getPobxPcd, getPostlCode, getRegion, getStreet, getTelephone, getTelephone2, getVendor, setCity, setCityCode, setCountry, setCountryiso, setCountycode, setCustomer, setDistrict, setFax1, setFormofaddr, setLangu, setLanguIso, setName_2, setName_3, setName_4, setName, setPoBox, setPobxCty, setPobxPcd, setPostlCode, setRegion, setStreet, setTelephone, setTelephone2, setVendor
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

VendorAddress

public VendorAddress()
入出庫予定を作成します。

メソッドの詳細

getPoNumber

public String getPoNumber()
購買伝票番号を取得します。

戻り値:
srtPoNumber 購買伝票番号

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
srtAddrNo アドレス番号

getCOName

public String getCOName()
気付を取得します。

戻り値:
srtCOName 気付

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
srtCityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
srtPostlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
srtPostlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
srtPostlCod3 会社郵便番号 (大規模なユーザ用)

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
srtPoBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
srtDelivDis 郵便配達地域

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
srtStreetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
srtStrAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
srtHouseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
srtStrSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
srtStrSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
srtLocation 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
srtBuilding 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
srtFloor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
srtRoomNo 部屋/アパート番号

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
srtSort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
srtSort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
srtTimeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
srtTaxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
srtAdrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
srtCommType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
srtTel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
srtTel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
srtFaxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
srtFaxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
srtStreetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
srtDistrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
srtChckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
srtPboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
srtTranspzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
srtHouseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
srtEMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
srtStrSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
srtTitle タイトル (敬称)

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
srtBuildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
srtRegiogroup 地域構造グループ化

setPoNumber

public void setPoNumber(String strPoNumber)
購買伝票番号を設定します。

パラメータ:
strPoNumber - 購買伝票番号

setAddrNo

public void setAddrNo(String strAddrNo)
アドレス番号を設定します。

パラメータ:
strAddrNo - アドレス番号

setCOName

public void setCOName(String strCOName)
気付を設定します。

パラメータ:
strCOName - 気付

setCityNo

public void setCityNo(String strCityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
strCityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String strPostlCod1)
市区町村の郵便番号を設定します。

パラメータ:
strPostlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String strPostlCod2)
私書箱郵便番号を設定します。

パラメータ:
strPostlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String strPostlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
strPostlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBoxCit

public void setPoBoxCit(String strPoBoxCit)
私書箱住所を設定します。

パラメータ:
strPoBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String strDelivDis)
郵便配達地域を設定します。

パラメータ:
strDelivDis - 郵便配達地域

setStreetNo

public void setStreetNo(String strStreetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
strStreetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strStrAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strStrAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String strHouseNo)
番地-号を設定します。

パラメータ:
strHouseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strStrSuppl1)
地名 2を設定します。

パラメータ:
strStrSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strStrSuppl2)
地名 3を設定します。

パラメータ:
strStrSuppl2 - 地名 3

setLocation

public void setLocation(String strLocation)
地名 5を設定します。

パラメータ:
strLocation - 地名 5

setBuilding

public void setBuilding(String strBuilding)
旧: 建物 (番号または略称)を設定します。

パラメータ:
strBuilding - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String strFloor)
建物の階を設定します。

パラメータ:
strFloor - 建物の階

setRoomNo

public void setRoomNo(String strRoomNo)
部屋/アパート番号を設定します。

パラメータ:
strRoomNo - 部屋/アパート番号

setSort1

public void setSort1(String strSort1)
検索条件 1を設定します。

パラメータ:
strSort1 - 検索条件 1

setSort2

public void setSort2(String strSort2)
検索条件 2を設定します。

パラメータ:
strSort2 - 検索条件 2

setTimeZone

public void setTimeZone(String strTimeZone)
アドレスタイムゾーンを設定します。

パラメータ:
strTimeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String strTaxjurcode)
税管轄コードを設定します。

パラメータ:
strTaxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String strAdrNotes)
住所注記を設定します。

パラメータ:
strAdrNotes - 住所注記

setCommType

public void setCommType(String strCommType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
strCommType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String strTel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
strTel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String strTel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
strTel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String strFaxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
strFaxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String strFaxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
strFaxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String strStreetLng)
地名を設定します。

パラメータ:
strStreetLng - 地名

setDistrctNo

public void setDistrctNo(String strDistrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
strDistrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String strChckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
strChckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String strPboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
strPboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String strTranspzone)
商品の納入区域を設定します。

パラメータ:
strTranspzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String strHouseNo2)
番地補足を設定します。

パラメータ:
strHouseNo2 - 番地補足

setEMail

public void setEMail(String strEMail)
電子メールアドレスを設定します。

パラメータ:
strEMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strStrSuppl3)
地名 4を設定します。

パラメータ:
strStrSuppl3 - 地名 4

setTitle

public void setTitle(String strTitle)
タイトル (敬称)を設定します。

パラメータ:
strTitle - タイトル (敬称)

setBuildLong

public void setBuildLong(String strBuildLong)
建物 (番号またはコード)を設定します。

パラメータ:
strBuildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String strRegiogroup)
地域構造グループ化を設定します。

パラメータ:
strRegiogroup - 地域構造グループ化

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Versions (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.purchase
クラス Versions

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.purchase.Versions
すべての実装インタフェース:
Serializable
public class Versions
extends Object
implements Serializable

バージョン管理情報クラス
機能は以下の通り

  • バージョン管理情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Versions()
バージョン管理を作成します。
メソッドの概要
String | getActivity() 処理タイプ - R/3 Enterprise で使用不可能を取得します。
String | getCompleted() ステータス "バージョン完了済"を取得します。
String | getDescription() バージョンテキスト（長）を取得します。
String | getPostDate() バージョンの転記日付を取得します。
String | getReason() 変更理由を取得します。
String | getReqBy() 変更を依頼した従業員を取得します。
String | getReqByExt() バージョンの外部変更番号を取得します。
void | setActivity(String strActivity) 処理タイプ - R/3 Enterprise で使用不可能を設定します。
void | setCompleted(String strCompleted) ステータス "バージョン完了済"を設定します。
void | setDescription(String strDescription) バージョンテキスト（長）を設定します。
void | setPostDate(String strPostDate) バージョンの転記日付を設定します。
void | setReason(String strReason) 変更理由を設定します。
void | setReqBy(String strReqBy) 変更を依頼した従業員を設定します。
void | setReqByExt(String strReqByExt) バージョンの外部変更番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Versions

public Versions()
バージョン管理を作成します。

メソッドの詳細

getPostDate

public String getPostDate()
バージョンの転記日付を取得します。

戻り値:
srtPostDate バージョンの転記日付

getCompleted

public String getCompleted()
ステータス "バージョン完了済"を取得します。

戻り値:
srtCompleted ステータス "バージョン完了済"

getReason

public String getReason()
変更理由を取得します。

戻り値:
srtReason 変更理由

getDescription

public String getDescription()
バージョンテキスト（長）を取得します。

戻り値:
srtDescription バージョンテキスト（長）

getReqBy

public String getReqBy()
変更を依頼した従業員を取得します。

戻り値:
srtReqBy 変更を依頼した従業員

getReqByExt

public String getReqByExt()
バージョンの外部変更番号を取得します。

戻り値:
srtReqByExt バージョンの外部変更番号

getActivity

public String getActivity()
処理タイプ - R/3 Enterprise で使用不可能を取得します。

戻り値:
srtActivity 処理タイプ - R/3 Enterprise で使用不可能

setPostDate

public void setPostDate(String strPostDate)
バージョンの転記日付を設定します。

パラメータ:
strPostDate - バージョンの転記日付

setCompleted

public void setCompleted(String strCompleted)
ステータス "バージョン完了済"を設定します。

パラメータ:
strCompleted - ステータス "バージョン完了済"

setReason

public void setReason(String strReason)
変更理由を設定します。

パラメータ:
strReason - 変更理由

setDescription

public void setDescription(String strDescription)
バージョンテキスト（長）を設定します。

パラメータ:
strDescription - バージョンテキスト（長）

setReqBy

public void setReqBy(String strReqBy)
変更を依頼した従業員を設定します。

パラメータ:
strReqBy - 変更を依頼した従業員

setReqByExt

public void setReqByExt(String strReqByExt)
バージョンの外部変更番号を設定します。

パラメータ:
strReqByExt - バージョンの外部変更番号

setActivity

public void setActivity(String strActivity)
処理タイプ - R/3 Enterprise で使用不可能を設定します。

パラメータ:
strActivity - 処理タイプ - R/3 Enterprise で使用不可能

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple の使用

BillingDocCreateMultiple を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での BillingDocCreateMultiple の使用

jp.co.intra_mart.foundation.sap.module.sales での BillingDocCreateMultiple のサブクラス
 class BillingDocCreateMultipleController
請求伝票登録コントローラクラス
機能は以下の通り
請求伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn の使用

CreatorDataIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple での CreatorDataIn の使用

CreatorDataIn を返す jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
 CreatorDataIn BillingDocCreateMultiple.getCreatorDataIn()
取り込まれる日付の順序を取得します。

CreatorDataIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のメソッド
static void | ParamCreatorDataIn.setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn) 取り込まれる日付の順序の値をセットします。
void | BillingDocCreateMultiple.setCreatorDataIn(CreatorDataIn creatorDataIn) 取り込まれる日付の順序を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス BillingDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn
すべての実装インタフェース:
Serializable
public class BillingDataIn
extends Object
implements Serializable

処理予定明細データのテーブル情報クラス
機能は以下の通り

  • 処理予定明細データのテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDataIn()
処理予定明細データのテーブル情報を作成します。
BillingDataIn(int index)
処理予定明細データのテーブル情報を作成します。
メソッドの概要
String | getAcctasgnmt() 品目の勘定設定グループを取得します。
String | getAddrNo() アドレス: アドレス番号を取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillTo() 請求先を取得します。
String | getCity() 市区町村を取得します。
String | getConsumctry() 消費者の国キーを取得します。
String | getCostcenter() 原価センタを取得します。
String | getCountry() 出荷国 (商品発送国)を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDistrict() 所在地を取得します。
String | getDivision() 製品部門を取得します。
String | getDocNumber() 販売伝票を取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getExchangeRate() 価格設定/統計用換算レートを取得します。
String | getHgLvItem() BOM 構成の上位レベル明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ (2)を取得します。
int | getIndex() レコード番号を取得します｡
String | getItem() 開始明細を取得します。
String | getItemCateg() 明細カテゴリ (販売伝票)を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getNoMatmast() 品目マスタ確認禁止を取得します。
String | getOrdbilltyp() 受注関連請求伝票に対する提案請求伝票タイプを取得します。
String | getOrderid() 指図番号を取得します。
String | getOrigindoc() 開始伝票を取得します。
String | getPayer() 支払人を取得します。
String | getPaymentTerms() 支払条件キーを取得します。
String | getPlant() プラントを取得します。
String | getPostlCode() 郵便番号を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getProdHier() 品目階層を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getProfitSegmNo() 収益性セグメント番号 (CO-PA)を取得します。
String | getPurchOrd() 出荷先発注番号を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocCa() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefItem() 参照明細番号を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesorg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getShipTo() 出荷先を取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSoldTo() 受注先を取得します。
String | getStatGroup() 統計グループを取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTaxcl1Mat() 品目の税分類を取得します。
String | getTaxDepartCty() 税出荷国を取得します。
String | getTaxDestCty() 税仕向国を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTitle() 敬称を取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAcctasgnmt(String acctasgnmt) 品目の勘定設定グループを設定します。
void | setAddrNo(String addrNo) アドレス: アドレス番号を設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillTo(String billTo) 請求先を設定します。
void | setCity(String city) 市区町村を設定します。
void | setConsumctry(String consumctry) 消費者の国キーを設定します。
void | setCostcenter(String costcenter) 原価センタを設定します。
void | setCountry(String country) 出荷国 (商品発送国)を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setExchangeRate(String exchangeRate) 価格設定/統計用換算レートを設定します。
void | setHgLvItem(String hgLvItem) BOM 構成の上位レベル明細を設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ (2)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItem(String item) 開始明細を設定します。
void | setItemCateg(String itemCateg) 明細カテゴリ (販売伝票)を設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setNoMatmast(String noMatmast) 品目マスタ確認禁止を設定します。
void | setOrdbilltyp(String ordbilltyp) 受注関連請求伝票に対する提案請求伝票タイプを設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrigindoc(String origindoc) 開始伝票を設定します。
void | setPayer(String payer) 支払人を設定します。
void | setPaymentTerms(String paymentTerms) 支払条件キーを設定します。
void | setPlant(String plant) プラントを設定します。
void | setPostlCode(String postlCode) 郵便番号を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setProdHier(String prodHier) 品目階層を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setProfitSegmNo(String profitSegmNo) 収益性セグメント番号 (CO-PA)を設定します。
void | setPurchOrd(String purchOrd) 出荷先発注番号を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocCa(String refDocCa) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefItem(String refItem) 参照明細番号を設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesorg(String salesorg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setShipTo(String shipTo) 出荷先を設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSoldTo(String soldTo) 受注先を設定します。
void | setStatGroup(String statGroup) 統計グループを設定します。
void | setStreet(String street) 地名/番地-号を設定します。
void | setTaxcl1Mat(String taxcl1Mat) 品目の税分類を設定します。
void | setTaxDepartCty(String taxDepartCty) 税出荷国を設定します。
void | setTaxDestCty(String taxDestCty) 税仕向国を設定します。
void | setTaxjurcode(String taxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTitle(String title) 敬称を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDataIn

public BillingDataIn()
処理予定明細データのテーブル情報を作成します。

BillingDataIn

public BillingDataIn(int index)
処理予定明細データのテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSalesorg

public String getSalesorg()
販売組織を取得します。

戻り値:
salesorg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getOrdbilltyp

public String getOrdbilltyp()
受注関連請求伝票に対する提案請求伝票タイプを取得します。

戻り値:
ordbilltyp 受注関連請求伝票に対する提案請求伝票タイプ

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
soldTo 受注先

getItemCateg

public String getItemCateg()
明細カテゴリ (販売伝票)を取得します。

戻り値:
itemCateg 明細カテゴリ (販売伝票)

getAcctasgnmt

public String getAcctasgnmt()
品目の勘定設定グループを取得します。

戻り値:
acctasgnmt 品目の勘定設定グループ

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getCountry

public String getCountry()
出荷国 (商品発送国)を取得します。

戻り値:
country 出荷国 (商品発送国)

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getBillTo

public String getBillTo()
請求先を取得します。

戻り値:
billTo 請求先

getPayer

public String getPayer()
支払人を取得します。

戻り値:
payer 支払人

getShipTo

public String getShipTo()
出荷先を取得します。

戻り値:
shipTo 出荷先

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getTaxcl1Mat

public String getTaxcl1Mat()
品目の税分類を取得します。

戻り値:
taxcl1Mat 品目の税分類

getRefItem

public String getRefItem()
参照明細番号を取得します。

戻り値:
refItem 参照明細番号

getStatGroup

public String getStatGroup()
統計グループを取得します。

戻り値:
statGroup 統計グループ

getNoMatmast

public String getNoMatmast()
品目マスタ確認禁止を取得します。

戻り値:
noMatmast 品目マスタ確認禁止

getAddrNo

public String getAddrNo()
アドレス: アドレス番号を取得します。

戻り値:
addrNo アドレス: アドレス番号

getTitle

public String getTitle()
敬称を取得します。

戻り値:
title 敬称

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
postlCode 郵便番号

getConsumctry

public String getConsumctry()
消費者の国キーを取得します。

戻り値:
consumctry 消費者の国キー

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
street 地名/番地-号

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getProdHier

public String getProdHier()
品目階層を取得します。

戻り値:
prodHier 品目階層

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
taxjurcode 税計算管轄コード - 税管轄コード

getPurchOrd

public String getPurchOrd()
出荷先発注番号を取得します。

戻り値:
purchOrd 出荷先発注番号

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getOrigindoc

public String getOrigindoc()
開始伝票を取得します。

戻り値:
origindoc 開始伝票

getItem

public String getItem()
開始明細を取得します。

戻り値:
item 開始明細

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ (2)を取得します。

戻り値:
incoterms2 インコタームズ (2)

getExchangeRate

public String getExchangeRate()
価格設定/統計用換算レートを取得します。

戻り値:
exchangeRate 価格設定/統計用換算レート

getPaymentTerms

public String getPaymentTerms()
支払条件キーを取得します。

戻り値:
paymentTerms 支払条件キー

getHgLvItem

public String getHgLvItem()
BOM 構成の上位レベル明細を取得します。

戻り値:
hgLvItem BOM 構成の上位レベル明細

getRefDocCa

public String getRefDocCa()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refDocCa 先行販売管理伝票の伝票カテゴリ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getProfitSegmNo

public String getProfitSegmNo()
収益性セグメント番号 (CO-PA)を取得します。

戻り値:
profitSegmNo 収益性セグメント番号 (CO-PA)

getCostcenter

public String getCostcenter()
原価センタを取得します。

戻り値:
costcenter 原価センタ

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getTaxDepartCty

public String getTaxDepartCty()
税出荷国を取得します。

戻り値:
taxDepartCty 税出荷国

getTaxDestCty

public String getTaxDestCty()
税仕向国を取得します。

戻り値:
taxDestCty 税仕向国

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSalesorg

public void setSalesorg(String salesorg)
販売組織を設定します。

パラメータ:
salesorg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setOrdbilltyp

public void setOrdbilltyp(String ordbilltyp)
受注関連請求伝票に対する提案請求伝票タイプを設定します。

パラメータ:
ordbilltyp - 受注関連請求伝票に対する提案請求伝票タイプ

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setSoldTo

public void setSoldTo(String soldTo)
受注先を設定します。

パラメータ:
soldTo - 受注先

setItemCateg

public void setItemCateg(String itemCateg)
明細カテゴリ (販売伝票)を設定します。

パラメータ:
itemCateg - 明細カテゴリ (販売伝票)

setAcctasgnmt

public void setAcctasgnmt(String acctasgnmt)
品目の勘定設定グループを設定します。

パラメータ:
acctasgnmt - 品目の勘定設定グループ

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setCountry

public void setCountry(String country)
出荷国 (商品発送国)を設定します。

パラメータ:
country - 出荷国 (商品発送国)

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setBillTo

public void setBillTo(String billTo)
請求先を設定します。

パラメータ:
billTo - 請求先

setPayer

public void setPayer(String payer)
支払人を設定します。

パラメータ:
payer - 支払人

setShipTo

public void setShipTo(String shipTo)
出荷先を設定します。

パラメータ:
shipTo - 出荷先

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setTaxcl1Mat

public void setTaxcl1Mat(String taxcl1Mat)
品目の税分類を設定します。

パラメータ:
taxcl1Mat - 品目の税分類

setRefItem

public void setRefItem(String refItem)
参照明細番号を設定します。

パラメータ:
refItem - 参照明細番号

setStatGroup

public void setStatGroup(String statGroup)
統計グループを設定します。

パラメータ:
statGroup - 統計グループ

setNoMatmast

public void setNoMatmast(String noMatmast)
品目マスタ確認禁止を設定します。

パラメータ:
noMatmast - 品目マスタ確認禁止

setAddrNo

public void setAddrNo(String addrNo)
アドレス: アドレス番号を設定します。

パラメータ:
addrNo - アドレス: アドレス番号

setTitle

public void setTitle(String title)
敬称を設定します。

パラメータ:
title - 敬称

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setPostlCode

public void setPostlCode(String postlCode)
郵便番号を設定します。

パラメータ:
postlCode - 郵便番号

setConsumctry

public void setConsumctry(String consumctry)
消費者の国キーを設定します。

パラメータ:
consumctry - 消費者の国キー

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setStreet

public void setStreet(String street)
地名/番地-号を設定します。

パラメータ:
street - 地名/番地-号

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setProdHier

public void setProdHier(String prodHier)
品目階層を設定します。

パラメータ:
prodHier - 品目階層

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
taxjurcode - 税計算管轄コード - 税管轄コード

setPurchOrd

public void setPurchOrd(String purchOrd)
出荷先発注番号を設定します。

パラメータ:
purchOrd - 出荷先発注番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setOrigindoc

public void setOrigindoc(String origindoc)
開始伝票を設定します。

パラメータ:
origindoc - 開始伝票

setItem

public void setItem(String item)
開始明細を設定します。

パラメータ:
item - 開始明細

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ (2)を設定します。

パラメータ:
incoterms2 - インコタームズ (2)

setExchangeRate

public void setExchangeRate(String exchangeRate)
価格設定/統計用換算レートを設定します。

パラメータ:
exchangeRate - 価格設定/統計用換算レート

setPaymentTerms

public void setPaymentTerms(String paymentTerms)
支払条件キーを設定します。

パラメータ:
paymentTerms - 支払条件キー

setHgLvItem

public void setHgLvItem(String hgLvItem)
BOM 構成の上位レベル明細を設定します。

パラメータ:
hgLvItem - BOM 構成の上位レベル明細

setRefDocCa

public void setRefDocCa(String refDocCa)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refDocCa - 先行販売管理伝票の伝票カテゴリ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setProfitSegmNo

public void setProfitSegmNo(String profitSegmNo)
収益性セグメント番号 (CO-PA)を設定します。

パラメータ:
profitSegmNo - 収益性セグメント番号 (CO-PA)

setCostcenter

public void setCostcenter(String costcenter)
原価センタを設定します。

パラメータ:
costcenter - 原価センタ

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setTaxDepartCty

public void setTaxDepartCty(String taxDepartCty)
税出荷国を設定します。

パラメータ:
taxDepartCty - 税出荷国

setTaxDestCty

public void setTaxDestCty(String taxDestCty)
税仕向国を設定します。

パラメータ:
taxDestCty - 税仕向国

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocCreateMultiple (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス BillingDocCreateMultiple

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocCreateMultipleController
public class BillingDocCreateMultiple
extends UpdateController
implements Serializable

請求伝票登録情報クラス
機能は以下の通り

  • 請求伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocCreateMultiple()
請求伝票登録情報を作成します。
BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
List | getBillingDataInList() 処理予定明細データのテーブルを取得します。
List | getCCardDataInList() 処理予定支払方法のテーブルを取得します。
List | getConditionDataInList() 処理予定条件のテーブルを取得します。
CreatorDataIn | getCreatorDataIn() 取り込まれる日付の順序を取得します。
List | getErrorsList() 前明細の不正処理に関する情報を取得します。
List | getSuccessList() 正常に処理された明細のテーブルを取得します。
String | getTestrun() シミュレーション実行 ('X')、更新実行 (' ')を取得します。
List | getTextDataInList() 請求インタフェースの通信構造テキストを取得します。
void | setBillingDataInList(List billingDataInList) 処理予定明細データのテーブルを設定します。
void | setCCardDataInList(List cCardDataInList) 処理予定支払方法のテーブルを設定します。
void | setConditionDataInList(List conditionDataInList) 処理予定条件のテーブルを設定します。
void | setCreatorDataIn(CreatorDataIn creatorDataIn) 取り込まれる日付の順序を設定します。
void | setErrorsList(List errorsList) 前明細の不正処理に関する情報を設定します。
void | setExportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | setImportParam(BapiController bapiController) 請求伝票に登録する値ををセットします。
void | setSuccessList(List successList) 正常に処理された明細のテーブルを設定します。
void | setTestrun(String testrun) シミュレーション実行 ('X')、更新実行 (' ')を設定します。
void | setTextDataInList(List textDataInList) 請求インタフェースの通信構造テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocCreateMultiple

public BillingDocCreateMultiple()
請求伝票登録情報を作成します。

BillingDocCreateMultiple

public BillingDocCreateMultiple(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

BillingDocCreateMultiple

public BillingDocCreateMultiple(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
請求伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
請求伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
シミュレーション実行 ('X')、更新実行 (' ')を取得します。

戻り値:
testrun シミュレーション実行 ('X')、更新実行 (' ')

getCreatorDataIn

public CreatorDataIn getCreatorDataIn()
取り込まれる日付の順序を取得します。

戻り値:
creatorDataIn 取り込まれる日付の順序

getBillingDataInList

public List getBillingDataInList()
処理予定明細データのテーブルを取得します。

戻り値:
billingDataInList 処理予定明細データのテーブル

getCCardDataInList

public List getCCardDataInList()
処理予定支払方法のテーブルを取得します。

戻り値:
cCardDataInList 処理予定支払方法のテーブル

getConditionDataInList

public List getConditionDataInList()
処理予定条件のテーブルを取得します。

戻り値:
conditionDataInList 処理予定条件のテーブル

getErrorsList

public List getErrorsList()
前明細の不正処理に関する情報を取得します。

戻り値:
errorsList 前明細の不正処理に関する情報

getSuccessList

public List getSuccessList()
正常に処理された明細のテーブルを取得します。

戻り値:
successList 正常に処理された明細のテーブル

getTextDataInList

public List getTextDataInList()
請求インタフェースの通信構造テキストを取得します。

戻り値:
textDataInList 請求インタフェースの通信構造テキスト

setTestrun

public void setTestrun(String testrun)
シミュレーション実行 ('X')、更新実行 (' ')を設定します。

パラメータ:
testrun - シミュレーション実行 ('X')、更新実行 (' ')

setCreatorDataIn

public void setCreatorDataIn(CreatorDataIn creatorDataIn)
取り込まれる日付の順序を設定します。

パラメータ:
creatorDataIn - 取り込まれる日付の順序

setBillingDataInList

public void setBillingDataInList(List billingDataInList)
処理予定明細データのテーブルを設定します。

パラメータ:
billingDataInList - 処理予定明細データのテーブル

setCCardDataInList

public void setCCardDataInList(List cCardDataInList)
処理予定支払方法のテーブルを設定します。

パラメータ:
cCardDataInList - 処理予定支払方法のテーブル

setConditionDataInList

public void setConditionDataInList(List conditionDataInList)
処理予定条件のテーブルを設定します。

パラメータ:
conditionDataInList - 処理予定条件のテーブル

setErrorsList

public void setErrorsList(List errorsList)
前明細の不正処理に関する情報を設定します。

パラメータ:
errorsList - 前明細の不正処理に関する情報

setSuccessList

public void setSuccessList(List successList)
正常に処理された明細のテーブルを設定します。

パラメータ:
successList - 正常に処理された明細のテーブル

setTextDataInList

public void setTextDataInList(List textDataInList)
請求インタフェースの通信構造テキストを設定します。

パラメータ:
textDataInList - 請求インタフェースの通信構造テキスト

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CCardDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス CCardDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn
すべての実装インタフェース:
Serializable
public class CCardDataIn
extends Object
implements Serializable

処理予定支払方法のテーブル情報クラス
機能は以下の通り

  • 処理予定支払方法のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CCardDataIn()
処理予定支払方法のテーブル情報を作成します。
CCardDataIn(int index)
処理予定支払方法のテーブル情報を作成します。
メソッドの概要
String | getAuthamount() 支払カード: 承認額を取得します。
String | getAuthDate() 支払カード: 承認日を取得します。
String | getAuthFlag() 支払カード: 振替権限を取得します。
String | getAuthRefno() 支払カード: 決済代行会社の権限参照コードを取得します。
String | getAuthTime() 支払カード: 承認時刻を取得します。
String | getBillPlan() 請求計画番号を取得します。
String | getBillPlani() 明細: 請求計画/支払計画/支払カードを取得します。
String | getBillValue() 請求金額: 請求計画に請求日付が指定されている場合を取得します。
String | getCcAuthNo() 支払カード: 承認番号を取得します。
String | getCcLocId() 支払カード: トランザクション (入庫時点)を取得します。
String | getCcName() 支払カード: カード所有者の氏名を取得します。
String | getCcNumber() 支払カード: カード番号を取得します。
String | getCcSeqNo() 支払カード: 支払カード - 接尾辞を取得します。
String | getCcSettled() 支払カード: 決済終了を取得します。
String | getCcType() 支払カードタイプ: カードタイプを取得します。
String | getCcValidF() 支払カード: 使用有効開始日付を取得します。
String | getCcValidT() 支払カード: 有効終了日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getDataorigin() 支払カード: 入力モードを取得します。
int | getIndex() レコード番号を取得します｡
String | getMerchidcl() 支払カード: 決済代行会社のマーチャント IDを取得します。
String | getPaytype() 支払手段: 支払カード計画の明細分類を取得します。
String | getTerminal() 支払カード: 端末を取得します。
void | setAuthamount(String authamount) 支払カード: 承認額を設定します。
void | setAuthDate(String authDate) 支払カード: 承認日を設定します。
void | setAuthFlag(String authFlag) 支払カード: 振替権限を設定します。
void | setAuthRefno(String authRefno) 支払カード: 決済代行会社の権限参照コードを設定します。
void | setAuthTime(String authTime) 支払カード: 承認時刻を設定します。
void | setBillPlan(String billPlan) 請求計画番号を設定します。
void | setBillPlani(String billPlani) 明細: 請求計画/支払計画/支払カードを設定します。
void | setBillValue(String billValue) 請求金額: 請求計画に請求日付が指定されている場合を設定します。
void | setCcAuthNo(String ccAuthNo) 支払カード: 承認番号を設定します。
void | setCcLocId(String ccLocId) 支払カード: トランザクション (入庫時点)を設定します。
void | setCcName(String ccName) 支払カード: カード所有者の氏名を設定します。
void | setCcNumber(String ccNumber) 支払カード: カード番号を設定します。
void | setCcSeqNo(String ccSeqNo) 支払カード: 支払カード - 接尾辞を設定します。
void | setCcSettled(String ccSettled) 支払カード: 決済終了を設定します。
void | setCcType(String ccType) 支払カードタイプ: カードタイプを設定します。
void | setCcValidF(String ccValidF) 支払カード: 使用有効開始日付を設定します。
void | setCcValidT(String ccValidT) 支払カード: 有効終了日を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setDataorigin(String dataorigin) 支払カード: 入力モードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMerchidcl(String merchidcl) 支払カード: 決済代行会社のマーチャント IDを設定します。
void | setPaytype(String paytype) 支払手段: 支払カード計画の明細分類を設定します。
void | setTerminal(String terminal) 支払カード: 端末を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CCardDataIn

public CCardDataIn()
処理予定支払方法のテーブル情報を作成します。

CCardDataIn

public CCardDataIn(int index)
処理予定支払方法のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPaytype

public String getPaytype()
支払手段: 支払カード計画の明細分類を取得します。

戻り値:
paytype 支払手段: 支払カード計画の明細分類

getCcType

public String getCcType()
支払カードタイプ: カードタイプを取得します。

戻り値:
ccType 支払カードタイプ: カードタイプ

getCcNumber

public String getCcNumber()
支払カード: カード番号を取得します。

戻り値:
ccNumber 支払カード: カード番号

getCcSeqNo

public String getCcSeqNo()
支払カード: 支払カード - 接尾辞を取得します。

戻り値:
ccSeqNo 支払カード: 支払カード - 接尾辞

getCcValidF

public String getCcValidF()
支払カード: 使用有効開始日付を取得します。

戻り値:
ccValidF 支払カード: 使用有効開始日付

getCcValidT

public String getCcValidT()
支払カード: 有効終了日を取得します。

戻り値:
ccValidT 支払カード: 有効終了日

getCcName

public String getCcName()
支払カード: カード所有者の氏名を取得します。

戻り値:
ccName 支払カード: カード所有者の氏名

getAuthamount

public String getAuthamount()
支払カード: 承認額を取得します。

戻り値:
authamount 支払カード: 承認額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getAuthFlag

public String getAuthFlag()
支払カード: 振替権限を取得します。

戻り値:
authFlag 支払カード: 振替権限

getAuthDate

public String getAuthDate()
支払カード: 承認日を取得します。

戻り値:
authDate 支払カード: 承認日

getAuthTime

public String getAuthTime()
支払カード: 承認時刻を取得します。

戻り値:
authTime 支払カード: 承認時刻

getCcAuthNo

public String getCcAuthNo()
支払カード: 承認番号を取得します。

戻り値:
ccAuthNo 支払カード: 承認番号

getAuthRefno

public String getAuthRefno()
支払カード: 決済代行会社の権限参照コードを取得します。

戻り値:
authRefno 支払カード: 決済代行会社の権限参照コード

getMerchidcl

public String getMerchidcl()
支払カード: 決済代行会社のマーチャント IDを取得します。

戻り値:
merchidcl 支払カード: 決済代行会社のマーチャント ID

getTerminal

public String getTerminal()
支払カード: 端末を取得します。

戻り値:
terminal 支払カード: 端末

getDataorigin

public String getDataorigin()
支払カード: 入力モードを取得します。

戻り値:
dataorigin 支払カード: 入力モード

getCcSettled

public String getCcSettled()
支払カード: 決済終了を取得します。

戻り値:
ccSettled 支払カード: 決済終了

getCcLocId

public String getCcLocId()
支払カード: トランザクション (入庫時点)を取得します。

戻り値:
ccLocId 支払カード: トランザクション (入庫時点)

getBillPlan

public String getBillPlan()
請求計画番号を取得します。

戻り値:
billPlan 請求計画番号

getBillPlani

public String getBillPlani()
明細: 請求計画/支払計画/支払カードを取得します。

戻り値:
billPlani 明細: 請求計画/支払計画/支払カード

getBillValue

public String getBillValue()
請求金額: 請求計画に請求日付が指定されている場合を取得します。

戻り値:
billValue 請求金額: 請求計画に請求日付が指定されている場合

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPaytype

public void setPaytype(String paytype)
支払手段: 支払カード計画の明細分類を設定します。

パラメータ:
paytype - 支払手段: 支払カード計画の明細分類

setCcType

public void setCcType(String ccType)
支払カードタイプ: カードタイプを設定します。

パラメータ:
ccType - 支払カードタイプ: カードタイプ

setCcNumber

public void setCcNumber(String ccNumber)
支払カード: カード番号を設定します。

パラメータ:
ccNumber - 支払カード: カード番号

setCcSeqNo

public void setCcSeqNo(String ccSeqNo)
支払カード: 支払カード - 接尾辞を設定します。

パラメータ:
ccSeqNo - 支払カード: 支払カード - 接尾辞

setCcValidF

public void setCcValidF(String ccValidF)
支払カード: 使用有効開始日付を設定します。

パラメータ:
ccValidF - 支払カード: 使用有効開始日付

setCcValidT

public void setCcValidT(String ccValidT)
支払カード: 有効終了日を設定します。

パラメータ:
ccValidT - 支払カード: 有効終了日

setCcName

public void setCcName(String ccName)
支払カード: カード所有者の氏名を設定します。

パラメータ:
ccName - 支払カード: カード所有者の氏名

setAuthamount

public void setAuthamount(String authamount)
支払カード: 承認額を設定します。

パラメータ:
authamount - 支払カード: 承認額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setAuthFlag

public void setAuthFlag(String authFlag)
支払カード: 振替権限を設定します。

パラメータ:
authFlag - 支払カード: 振替権限

setAuthDate

public void setAuthDate(String authDate)
支払カード: 承認日を設定します。

パラメータ:
authDate - 支払カード: 承認日

setAuthTime

public void setAuthTime(String authTime)
支払カード: 承認時刻を設定します。

パラメータ:
authTime - 支払カード: 承認時刻

setCcAuthNo

public void setCcAuthNo(String ccAuthNo)
支払カード: 承認番号を設定します。

パラメータ:
ccAuthNo - 支払カード: 承認番号

setAuthRefno

public void setAuthRefno(String authRefno)
支払カード: 決済代行会社の権限参照コードを設定します。

パラメータ:
authRefno - 支払カード: 決済代行会社の権限参照コード

setMerchidcl

public void setMerchidcl(String merchidcl)
支払カード: 決済代行会社のマーチャント IDを設定します。

パラメータ:
merchidcl - 支払カード: 決済代行会社のマーチャント ID

setTerminal

public void setTerminal(String terminal)
支払カード: 端末を設定します。

パラメータ:
terminal - 支払カード: 端末

setDataorigin

public void setDataorigin(String dataorigin)
支払カード: 入力モードを設定します。

パラメータ:
dataorigin - 支払カード: 入力モード

setCcSettled

public void setCcSettled(String ccSettled)
支払カード: 決済終了を設定します。

パラメータ:
ccSettled - 支払カード: 決済終了

setCcLocId

public void setCcLocId(String ccLocId)
支払カード: トランザクション (入庫時点)を設定します。

パラメータ:
ccLocId - 支払カード: トランザクション (入庫時点)

setBillPlan

public void setBillPlan(String billPlan)
請求計画番号を設定します。

パラメータ:
billPlan - 請求計画番号

setBillPlani

public void setBillPlani(String billPlani)
明細: 請求計画/支払計画/支払カードを設定します。

パラメータ:
billPlani - 明細: 請求計画/支払計画/支払カード

setBillValue

public void setBillValue(String billValue)
請求金額: 請求計画に請求日付が指定されている場合を設定します。

パラメータ:
billValue - 請求金額: 請求計画に請求日付が指定されている場合

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ConditionDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn
すべての実装インタフェース:
Serializable
public class ConditionDataIn
extends Object
implements Serializable

処理予定条件のテーブル情報クラス
機能は以下の通り

  • 処理予定条件のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionDataIn()
処理予定条件のテーブル情報を作成します。
ConditionDataIn(int index)
処理予定条件のテーブル情報を作成します。
メソッドの概要
String | getCondCurr() 条件通貨 (累積項目用)を取得します。
String | getCondDUnt() 伝票の条件単位を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondValue() 条件金額/率を取得します。
String | getDataIndex() 別の構成のテーブル入力へのポインタを取得します。
int | getIndex() レコード番号を取得します｡
void | setCondCurr(String condCurr) 条件通貨 (累積項目用)を設定します。
void | setCondDUnt(String condDUnt) 伝票の条件単位を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondValue(String condValue) 条件金額/率を設定します。
void | setDataIndex(String dataIndex) 別の構成のテーブル入力へのポインタを設定します。
void | setIndex(int index) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionDataIn

public ConditionDataIn()
処理予定条件のテーブル情報を作成します。

ConditionDataIn

public ConditionDataIn(int index)
処理予定条件のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDataIndex

public String getDataIndex()
別の構成のテーブル入力へのポインタを取得します。

戻り値:
dataIndex 別の構成のテーブル入力へのポインタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getCondValue

public String getCondValue()
条件金額/率を取得します。

戻り値:
condValue 条件金額/率

getCondCurr

public String getCondCurr()
条件通貨 (累積項目用)を取得します。

戻り値:
condCurr 条件通貨 (累積項目用)

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondDUnt

public String getCondDUnt()
伝票の条件単位を取得します。

戻り値:
condDUnt 伝票の条件単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDataIndex

public void setDataIndex(String dataIndex)
別の構成のテーブル入力へのポインタを設定します。

パラメータ:
dataIndex - 別の構成のテーブル入力へのポインタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setCondValue

public void setCondValue(String condValue)
条件金額/率を設定します。

パラメータ:
condValue - 条件金額/率

setCondCurr

public void setCondCurr(String condCurr)
条件通貨 (累積項目用)を設定します。

パラメータ:
condCurr - 条件通貨 (累積項目用)

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondDUnt

public void setCondDUnt(String condDUnt)
伝票の条件単位を設定します。

パラメータ:
condDUnt - 伝票の条件単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreatorDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス CreatorDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn
すべての実装インタフェース:
Serializable
public class CreatorDataIn
extends Object
implements Serializable

取り込まれる日付の順序情報クラス
機能は以下の通り

  • 取り込まれる日付の順序情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CreatorDataIn()
取り込まれる日付の順序情報を作成します。
メソッドの概要
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCreatedOn() レコード登録日を取得します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCreatedOn(String createdOn) レコード登録日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CreatorDataIn

public CreatorDataIn()
取り込まれる日付の順序情報を作成します。

メソッドの詳細

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getCreatedOn

public String getCreatedOn()
レコード登録日を取得します。

戻り値:
createdOn レコード登録日

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setCreatedOn

public void setCreatedOn(String createdOn)
レコード登録日を設定します。

パラメータ:
createdOn - レコード登録日

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Errors (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス Errors

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors
すべての実装インタフェース:
Serializable
public class Errors
extends Object
implements Serializable

前明細の不正処理に関する情報情報クラス
機能は以下の通り

  • 前明細の不正処理に関する情報情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Errors()
前明細の不正処理に関する情報情報を作成します。
Errors(int index)
前明細の不正処理に関する情報情報を作成します。
メソッドの概要
String | getId() メッセージ、メッセージクラスを取得します。
int | getIndex() レコード番号を取得します｡
String | getLogMsgNo() アプリケーションログ: メッセージシリアル番号を取得します。
String | getLogNo() アプリケーションログ: ログ番号を取得します。
String | getMessage() メッセージテキストを取得します。
String | getMessageV1() メッセージ、メッセージ変数を取得します。
String | getMessageV2() メッセージ、メッセージ変数を取得します。
String | getMessageV3() メッセージ、メッセージ変数を取得します。
String | getMessageV4() メッセージ、メッセージ変数を取得します。
String | getNumber() メッセージ、メッセージ番号を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocItem() 参照明細番号を取得します。
String | getType() メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
void | setId(String id) メッセージ、メッセージクラスを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLogMsgNo(String logMsgNo) アプリケーションログ: メッセージシリアル番号を設定します。
void | setLogNo(String logNo) アプリケーションログ: ログ番号を設定します。
void | setMessage(String message) メッセージテキストを設定します。
void | setMessageV1(String messageV1) メッセージ、メッセージ変数を設定します。
void | setMessageV2(String messageV2) メッセージ、メッセージ変数を設定します。
void | setMessageV3(String messageV3) メッセージ、メッセージ変数を設定します。
void | setMessageV4(String messageV4) メッセージ、メッセージ変数を設定します。
void | setNumber(String number) メッセージ、メッセージ番号を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocItem(String refDocItem) 参照明細番号を設定します。
void | setType(String type) メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Errors

public Errors()
前明細の不正処理に関する情報情報を作成します。

Errors

public Errors(int index)
前明細の不正処理に関する情報情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocItem

public String getRefDocItem()
参照明細番号を取得します。

戻り値:
refDocItem 参照明細番号

getType

public String getType()
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。

戻り値:
type メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

getId

public String getId()
メッセージ、メッセージクラスを取得します。

戻り値:
id メッセージ、メッセージクラス

getNumber

public String getNumber()
メッセージ、メッセージ番号を取得します。

戻り値:
number メッセージ、メッセージ番号

getMessage

public String getMessage()
メッセージテキストを取得します。

戻り値:
message メッセージテキスト

getLogNo

public String getLogNo()
アプリケーションログ: ログ番号を取得します。

戻り値:
logNo アプリケーションログ: ログ番号

getLogMsgNo

public String getLogMsgNo()
アプリケーションログ: メッセージシリアル番号を取得します。

戻り値:
logMsgNo アプリケーションログ: メッセージシリアル番号

getMessageV1

public String getMessageV1()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV1 メッセージ、メッセージ変数

getMessageV2

public String getMessageV2()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV2 メッセージ、メッセージ変数

getMessageV3

public String getMessageV3()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV3 メッセージ、メッセージ変数

getMessageV4

public String getMessageV4()
メッセージ、メッセージ変数を取得します。

戻り値:
messageV4 メッセージ、メッセージ変数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocItem

public void setRefDocItem(String refDocItem)
参照明細番号を設定します。

パラメータ:
refDocItem - 参照明細番号

setType

public void setType(String type)
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。

パラメータ:
type - メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

setId

public void setId(String id)
メッセージ、メッセージクラスを設定します。

パラメータ:
id - メッセージ、メッセージクラス

setNumber

public void setNumber(String number)
メッセージ、メッセージ番号を設定します。

パラメータ:
number - メッセージ、メッセージ番号

setMessage

public void setMessage(String message)
メッセージテキストを設定します。

パラメータ:
message - メッセージテキスト

setLogNo

public void setLogNo(String logNo)
アプリケーションログ: ログ番号を設定します。

パラメータ:
logNo - アプリケーションログ: ログ番号

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
アプリケーションログ: メッセージシリアル番号を設定します。

パラメータ:
logMsgNo - アプリケーションログ: メッセージシリアル番号

setMessageV1

public void setMessageV1(String messageV1)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV1 - メッセージ、メッセージ変数

setMessageV2

public void setMessageV2(String messageV2)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV2 - メッセージ、メッセージ変数

setMessageV3

public void setMessageV3(String messageV3)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV3 - メッセージ、メッセージ変数

setMessageV4

public void setMessageV4(String messageV4)
メッセージ、メッセージ変数を設定します。

パラメータ:
messageV4 - メッセージ、メッセージ変数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス
BillingDataIn
BillingDocCreateMultiple
CCardDataIn
ConditionDataIn
CreatorDataIn
Errors
ParamBillingDataIn
ParamCCardDataIn
ParamConditionDataIn
ParamCreatorDataIn
ParamErrors
ParamTextDataIn
TextDataIn


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

クラスの概要
BillingDataIn | 処理予定明細データのテーブル情報クラス 機能は以下の通り 処理予定明細データのテーブル情報を保持します。
BillingDocCreateMultiple | 請求伝票登録情報クラス 機能は以下の通り 請求伝票登録情報を保持します。
CCardDataIn | 処理予定支払方法のテーブル情報クラス 機能は以下の通り 処理予定支払方法のテーブル情報を保持します。
ConditionDataIn | 処理予定条件のテーブル情報クラス 機能は以下の通り 処理予定条件のテーブル情報を保持します。
CreatorDataIn | 取り込まれる日付の順序情報クラス 機能は以下の通り 取り込まれる日付の順序情報を保持します。
Errors | 前明細の不正処理に関する情報情報クラス 機能は以下の通り 前明細の不正処理に関する情報情報を保持します。
ParamBillingDataIn | 処理予定明細データのテーブルパラメータ設定クラス 機能は以下の通り 処理予定明細データのテーブルパラメータを設定します。
ParamCCardDataIn | 処理予定支払方法のテーブルパラメータ設定クラス 機能は以下の通り 処理予定支払方法のテーブルパラメータを設定します。
ParamConditionDataIn | 処理予定条件のテーブルパラメータ設定クラス 機能は以下の通り 処理予定条件のテーブルのパラメータを設定します。
ParamCreatorDataIn | 取り込まれる日付の順序パラメータ設定クラス 機能は以下の通り 取り込まれる日付の順序のパラメータを設定します。
ParamErrors | 前明細の不正処理に関する情報パラメータ設定クラス 機能は以下の通り 前明細の不正処理に関する情報のパラメータを設定します。
ParamTextDataIn | 請求インタフェースの通信構造テキストパラメータ設定クラス 機能は以下の通り 請求インタフェースの通信構造テキストのパラメータを設定します。
TextDataIn | 請求インタフェースの通信構造テキスト情報クラス 機能は以下の通り 請求インタフェースの通信構造テキスト情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のクラス
BillingDocCreateMultiple
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple のクラス
CreatorDataIn
取り込まれる日付の順序情報クラス
機能は以下の通り
取り込まれる日付の順序情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBillingDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamBillingDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn
すべての実装インタフェース:
Serializable
public final class ParamBillingDataIn
extends Object
implements Serializable

処理予定明細データのテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定明細データのテーブルパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List billingDataInList) table(Export)情報から処理予定明細データのテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List billingDataInList) 処理予定明細データのテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List billingDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定明細データのテーブルの値をセットします。

パラメータ:
bapiController - BapiController
billingDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List billingDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から処理予定明細データのテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
billingDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCCardDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamCCardDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn
すべての実装インタフェース:
Serializable
public final class ParamCCardDataIn
extends Object
implements Serializable

処理予定支払方法のテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定支払方法のテーブルパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cCardDataInList) table(Export)情報から理予定支払方法のテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List cCardDataInList) 処理予定支払方法のテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cCardDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定支払方法のテーブルの値をセットします。

パラメータ:
bapiController - BapiController
cCardDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cCardDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から理予定支払方法のテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cCardDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamConditionDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn
すべての実装インタフェース:
Serializable
public final class ParamConditionDataIn
extends Object
implements Serializable

処理予定条件のテーブルパラメータ設定クラス
機能は以下の通り

  • 処理予定条件のテーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionDataInList) table(Export)情報から処理予定条件のテーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List conditionDataInList) 処理予定条件のテーブルの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
処理予定条件のテーブルの値をセットします。

パラメータ:
bapiController - BapiController
conditionDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から処理予定条件のテーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCreatorDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamCreatorDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn
すべての実装インタフェース:
Serializable
public final class ParamCreatorDataIn
extends Object
implements Serializable

取り込まれる日付の順序パラメータ設定クラス
機能は以下の通り

  • 取り込まれる日付の順序のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, CreatorDataIn creatorDataIn)
取り込まれる日付の順序の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  CreatorDataIn creatorDataIn)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
取り込まれる日付の順序の値をセットします。

パラメータ:
bapiController - BapiController
creatorDataIn - CreatorDataIn
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamErrors (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamErrors

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors
すべての実装インタフェース:
Serializable
public final class ParamErrors
extends Object
implements Serializable

前明細の不正処理に関する情報パラメータ設定クラス
機能は以下の通り

  • 前明細の不正処理に関する情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List errorsList) table(Export)情報から前明細の不正処理に関する情報の値をセットします。
static void | setImportParam(BapiController bapiController, List errorsList) 前明細の不正処理に関する情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List errorsList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
前明細の不正処理に関する情報の値をセットします。

パラメータ:
bapiController - BapiController
errorsList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List errorsList)
                           throws SAPGeneralSystemException
table(Export)情報から前明細の不正処理に関する情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
errorsList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamTextDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス ParamTextDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn
すべての実装インタフェース:
Serializable
public final class ParamTextDataIn
extends Object
implements Serializable

請求インタフェースの通信構造テキストパラメータ設定クラス
機能は以下の通り

  • 請求インタフェースの通信構造テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List textDataInList) table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
static void | setImportParam(BapiController bapiController, List textDataInList) 請求インタフェースの通信構造テキストの値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List textDataInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
請求インタフェースの通信構造テキストの値をセットします。

パラメータ:
bapiController - BapiController
textDataInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List textDataInList)
                           throws SAPGeneralSystemException
table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
textDataInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TextDataIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
クラス TextDataIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn
すべての実装インタフェース:
Serializable
public class TextDataIn
extends Object
implements Serializable

請求インタフェースの通信構造テキスト情報クラス
機能は以下の通り

  • 請求インタフェースの通信構造テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
TextDataIn()
請求インタフェースの通信構造テキスト情報を作成します。
TextDataIn(int index)
請求インタフェースの通信構造テキスト情報を作成します。
メソッドの概要
String | getApplobject() テキスト: アプリケーションオブジェクトを取得します。
String | getFormatCol() タグ列を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefItem() 参照明細番号を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setApplobject(String applobject) テキスト: アプリケーションオブジェクトを設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefItem(String refItem) 参照明細番号を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

TextDataIn

public TextDataIn()
請求インタフェースの通信構造テキスト情報を作成します。

TextDataIn

public TextDataIn(int index)
請求インタフェースの通信構造テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefItem

public String getRefItem()
参照明細番号を取得します。

戻り値:
refItem 参照明細番号

getApplobject

public String getApplobject()
テキスト: アプリケーションオブジェクトを取得します。

戻り値:
applobject テキスト: アプリケーションオブジェクト

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefItem

public void setRefItem(String refItem)
参照明細番号を設定します。

パラメータ:
refItem - 参照明細番号

setApplobject

public void setApplobject(String applobject)
テキスト: アプリケーションオブジェクトを設定します。

パラメータ:
applobject - テキスト: アプリケーションオブジェクト

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocGetDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
クラス BillingDocGetDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail
すべての実装インタフェース:
Serializable
public class BillingDocGetDetail
extends ReferenceController
implements Serializable

請求伝票詳細照会情報クラス
機能は以下の通り

  • 請求伝票詳細照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。
メソッドの概要
 void executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。
 String getBillingdocument()
処理予定の請求伝票数を取得します。
 BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。
 void setBillingdocument(String billingdocument)
処理予定の請求伝票数を設定します。
 void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。
 void setExportParam(BapiController bapiController)
返却された請求伝票詳細照会情報をセットします。
 String toString()
デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetDetail

public BillingDocGetDetail(String billingdocument,
                           SapClient sapClient)
                    throws SAPAuthAppException,
                           SAPAuthSystemException,
                           SAPGeneralAppException,
                           SAPGeneralSystemException,
                           SAPSalesAppException,
                           SAPSalesSystemException
請求伝票詳細照会情報を作成します。

パラメータ:
sapClient - SapClient SAPクライアント
billingdocument - String 請求伝票
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された請求伝票詳細照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getBillingdocument

public String getBillingdocument()
処理予定の請求伝票数を取得します。

戻り値:
billingdocument 処理予定の請求伝票数

getBillingDocumentDetail

public BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

戻り値:
billingDocumentDetail 請求伝票に関する詳細情報

setBillingdocument

public void setBillingdocument(String billingdocument)
処理予定の請求伝票数を設定します。

パラメータ:
billingdocument - 処理予定の請求伝票数

setBillingDocumentDetail

public void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

パラメータ:
billingDocumentDetail - 請求伝票に関する詳細情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
クラス
BillingDocGetDetail


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

クラスの概要
BillingDocGetDetail 請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList の使用

BillingDocGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での BillingDocGetList の使用

jp.co.intra_mart.foundation.sap.module.sales での BillingDocGetList のサブクラス
 class BillingDocGetListController
請求伝票一覧照会情報コントローラクラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange の使用

RefDocRange を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist での RefDocRange の使用

RefDocRange を返す jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
 RefDocRange BillingDocGetList.getRefDocRange()
前伝票の範囲を取得します。

RefDocRange 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のメソッド
static void | ParamRefDocRange.setImportParam(BapiController bapiController, RefDocRange refDocRange) 前伝票の範囲の値をセットします。
void | BillingDocGetList.setRefDocRange(RefDocRange refDocRange) 前伝票の範囲を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocGetList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス BillingDocGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocGetListController
public class BillingDocGetList
extends ReferenceController
implements Serializable

請求伝票一覧照会情報クラス
機能は以下の通り

  • 請求伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。
BillingDocGetList(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
請求伝票一覧照会情報を作成します。
メソッドの概要
List | getBillingDocumentDetailListList() 後続請求伝票のテーブルを取得します。
RefDocRange | getRefDocRange() 前伝票の範囲を取得します。
List | getSuccessList() 後続請求伝票の明細テーブルを取得します。
void | setBillingDocumentDetailListList(ArrayList billingDocumentDetailListList) 後続請求伝票のテーブルを設定します。
void | setExportParam(BapiController bapiController) 取得した請求伝票一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
void | setRefDocRange(RefDocRange refDocRange) 前伝票の範囲を設定します。
void | setSuccessList(ArrayList successList) 後続請求伝票の明細テーブルを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetList

public BillingDocGetList(SapClient sapClient)
請求伝票一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

BillingDocGetList

public BillingDocGetList(String sign,
                         String option,
                         String refDocRow,
                         String refDocHigh,
                         SapClient sapClient)
請求伝票一覧照会情報を作成します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号
sapClient - SAPクライアント
メソッドの詳細

getRefDocRange

public RefDocRange getRefDocRange()
前伝票の範囲を取得します。

戻り値:
refDocRange 前伝票の範囲

getBillingDocumentDetailListList

public List getBillingDocumentDetailListList()
後続請求伝票のテーブルを取得します。

戻り値:
billingDocumentDetailListList 後続請求伝票のテーブル

getSuccessList

public List getSuccessList()
後続請求伝票の明細テーブルを取得します。

戻り値:
successList 後続請求伝票の明細テーブル

setRefDocRange

public void setRefDocRange(RefDocRange refDocRange)
前伝票の範囲を設定します。

パラメータ:
refDocRange - 前伝票の範囲

setBillingDocumentDetailListList

public void setBillingDocumentDetailListList(ArrayList billingDocumentDetailListList)
後続請求伝票のテーブルを設定します。

パラメータ:
billingDocumentDetailListList - 後続請求伝票のテーブル

setSuccessList

public void setSuccessList(ArrayList successList)
後続請求伝票の明細テーブルを設定します。

パラメータ:
successList - 後続請求伝票の明細テーブル

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralAppException,
                           SAPGeneralSystemException
請求伝票一覧照会情報を、取得する為に必要な情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
取得した請求伝票一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス
BillingDocGetList
ParamRefDocRange
RefDocRange


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

クラスの概要
BillingDocGetList | 請求伝票一覧照会情報クラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
ParamRefDocRange | 前伝票の範囲パラメータ設定クラス 機能は以下の通り 前伝票の範囲のパラメータを設定します。
RefDocRange | 前伝票の範囲情報クラス 機能は以下の通り 前伝票の範囲情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist の使用

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のクラス
BillingDocGetList
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist のクラス
RefDocRange
前伝票の範囲情報クラス
機能は以下の通り
前伝票の範囲情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamRefDocRange (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス ParamRefDocRange

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange
すべての実装インタフェース:
Serializable
public final class ParamRefDocRange
extends Object
implements Serializable

前伝票の範囲パラメータ設定クラス
機能は以下の通り

  • 前伝票の範囲のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, RefDocRange refDocRange)
前伝票の範囲の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  RefDocRange refDocRange)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
前伝票の範囲の値をセットします。

パラメータ:
bapiController - BapiController
refDocRange - RefDocRange
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RefDocRange (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
クラス RefDocRange

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange
すべての実装インタフェース:
Serializable
public class RefDocRange
extends Object
implements Serializable

前伝票の範囲情報クラス
機能は以下の通り

  • 前伝票の範囲情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
RefDocRange()
前伝票の範囲情報を作成します。
メソッドの概要
String | getOption() 選択演算子 OPTION (範囲テーブル)を取得します。
String | getRefDocHigh() 前伝票の終了伝票番号を取得します。
String | getRefDocLow() 前伝票の開始伝票番号を取得します。
String | getSign() 選択演算子 SIGN (テーブル範囲)を取得します。
void | setOption(String option) 選択演算子 OPTION (範囲テーブル)を設定します。
void | setRefDocHigh(String refDocHigh) 前伝票の終了伝票番号を設定します。
void | setRefDocLow(String refDocLow) 前伝票の開始伝票番号を設定します。
void | setSign(String sign) 選択演算子 SIGN (テーブル範囲)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

RefDocRange

public RefDocRange()
前伝票の範囲情報を作成します。

メソッドの詳細

getSign

public String getSign()
選択演算子 SIGN (テーブル範囲)を取得します。

戻り値:
sign 選択演算子 SIGN (テーブル範囲)

getOption

public String getOption()
選択演算子 OPTION (範囲テーブル)を取得します。

戻り値:
option 選択演算子 OPTION (範囲テーブル)

getRefDocLow

public String getRefDocLow()
前伝票の開始伝票番号を取得します。

戻り値:
refDocLow 前伝票の開始伝票番号

getRefDocHigh

public String getRefDocHigh()
前伝票の終了伝票番号を取得します。

戻り値:
refDocHigh 前伝票の終了伝票番号

setSign

public void setSign(String sign)
選択演算子 SIGN (テーブル範囲)を設定します。

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)

setOption

public void setOption(String option)
選択演算子 OPTION (範囲テーブル)を設定します。

パラメータ:
option - 選択演算子 OPTION (範囲テーブル)

setRefDocLow

public void setRefDocLow(String refDocLow)
前伝票の開始伝票番号を設定します。

パラメータ:
refDocLow - 前伝票の開始伝票番号

setRefDocHigh

public void setRefDocHigh(String refDocHigh)
前伝票の終了伝票番号を設定します。

パラメータ:
refDocHigh - 前伝票の終了伝票番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController の使用

jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController の使用

jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail の使用

BillingDocumentDetail を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.common.model

jp.co.intra_mart.foundation.sap.module.sales での BillingDocumentDetail の使用

BillingDocumentDetail を返す jp.co.intra_mart.foundation.sap.module.sales のメソッド
 BillingDocumentDetail BillingDocGetDetailController.getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

BillingDocumentDetail 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void BillingDocGetDetailController.setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での BillingDocumentDetail の使用

BillingDocumentDetail を返す jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 BillingDocumentDetail BillingDocGetDetail.getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

BillingDocumentDetail 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

jp.co.intra_mart.foundation.sap.module.sales.common.model での BillingDocumentDetail の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model での BillingDocumentDetail のサブクラス
 class BillingDocumentDetailList
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn の使用

HeaderIn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での HeaderIn の使用

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamHeaderIn.setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType)
販売伝票ヘッダデータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 HeaderIn InquiryCreateFromData2.getInquiryHeaderIn()
引合伝票ヘッダデータを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setInquiryHeaderIn(HeaderIn inquiryHeaderIn)
引合伝票ヘッダデータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 HeaderIn QuotationCreateFromData2.getQuotationHeaderIn()
伝票ヘッダデータを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setQuotationHeaderIn(HeaderIn quotationHeaderIn)
伝票ヘッダデータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での HeaderIn の使用

HeaderIn を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 HeaderIn SalesOrderCreateFromDat2.getOrderHeaderIn()
受注伝票ヘッダを取得します。

HeaderIn 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setOrderHeaderIn(HeaderIn orderHeaderIn)
受注伝票ヘッダを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX の使用

HeaderInX を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での HeaderInX の使用

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamHeaderInX.setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType)
ヘッダデータチェックボックスに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 HeaderInX InquiryCreateFromData2.getInquiryHeaderInX()
ヘッダデータチェックボックスを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setInquiryHeaderInX(HeaderInX inquiryHeaderInX)
ヘッダデータチェックボックスを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 HeaderInX QuotationCreateFromData2.getQuotationHeaderInX()
伝票ヘッダチェックボックスを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setQuotationHeaderInX(HeaderInX quotationHeaderInX)
伝票ヘッダチェックボックスを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での HeaderInX の使用

HeaderInX を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 HeaderInX SalesOrderCreateFromDat2.getOrderHeaderInX()
受注伝票チェックリストを取得します。

HeaderInX 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setOrderHeaderInX(HeaderInX orderHeaderInX)
受注伝票チェックリストを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch の使用

LogicSwitch を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での LogicSwitch の使用

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamLogicSwitch.setImportParam(BapiController bapiController, LogicSwitch logicSwitch)
内部制御パラメータに値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 LogicSwitch InquiryCreateFromData2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 LogicSwitch QuotationCreateFromData2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での LogicSwitch の使用

LogicSwitch を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 LogicSwitch SalesOrderCreateFromDat2.getLogicSwitch()
内部制御パラメータを取得します。

LogicSwitch 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender の使用

Sender を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.common.model での Sender の使用

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.common.model のメソッド
static void ParamSender.setImportParam(BapiController bapiController, Sender sender)
論理システム - 送信者に値をセットします。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 Sender InquiryCreateFromData2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のメソッド
 void InquiryCreateFromData2.setSender(Sender sender)
論理システム - 送信者を設定します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 Sender QuotationCreateFromData2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のメソッド
 void QuotationCreateFromData2.setSender(Sender sender)
論理システム - 送信者を設定します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 での Sender の使用

Sender を返す jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 Sender SalesOrderCreateFromDat2.getSender()
論理システム - 送信者を取得します。

Sender 型のパラメータを持つ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のメソッド
 void SalesOrderCreateFromDat2.setSender(Sender sender)
論理システム - 送信者を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Success の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Success の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Success はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Text の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.common.model.Text の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model.Text はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BillingDocumentDetail (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス BillingDocumentDetail

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BillingDocumentDetailList
public class BillingDocumentDetail
extends Object
implements Serializable

後続請求伝票のテーブル情報クラス
機能は以下の通り

  • 後続請求伝票のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocumentDetail()
後続請求伝票のテーブル情報を作成します。
メソッドの概要
String | getAcctstatus() 会計への転記ステータスを取得します。
String | getBillcateg() 請求カテゴリを取得します。
String | getBillingdoc() 請求伝票を取得します。
String | getBillType() 請求タイプを取得します。
String | getCancelled() 中止区分を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrencyIso() ISO 通貨コードを取得します。
String | getNetValue() 正味金額を取得します。
String | getSdDocCat() 販売管理伝票カテゴリを取得します。
String | getTaxValue() 税額を取得します。
void | setAcctstatus(String acctstatus) 会計への転記ステータスを設定します。
void | setBillcateg(String billcateg) 請求カテゴリを設定します。
void | setBillingdoc(String billingdoc) 請求伝票を設定します。
void | setBillType(String billType) 請求タイプを設定します。
void | setCancelled(String cancelled) 中止区分を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrencyIso(String currencyIso) ISO 通貨コードを設定します。
void | setNetValue(String netValue) 正味金額を設定します。
void | setSdDocCat(String sdDocCat) 販売管理伝票カテゴリを設定します。
void | setTaxValue(String taxValue) 税額を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocumentDetail

public BillingDocumentDetail()
後続請求伝票のテーブル情報を作成します。

メソッドの詳細

getBillingdoc

public String getBillingdoc()
請求伝票を取得します。

戻り値:
billingdoc 請求伝票

getBillType

public String getBillType()
請求タイプを取得します。

戻り値:
billType 請求タイプ

getBillcateg

public String getBillcateg()
請求カテゴリを取得します。

戻り値:
billcateg 請求カテゴリ

getSdDocCat

public String getSdDocCat()
販売管理伝票カテゴリを取得します。

戻り値:
sdDocCat 販売管理伝票カテゴリ

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrencyIso

public String getCurrencyIso()
ISO 通貨コードを取得します。

戻り値:
currencyIso ISO 通貨コード

getAcctstatus

public String getAcctstatus()
会計への転記ステータスを取得します。

戻り値:
acctstatus 会計への転記ステータス

getNetValue

public String getNetValue()
正味金額を取得します。

戻り値:
netValue 正味金額

getTaxValue

public String getTaxValue()
税額を取得します。

戻り値:
taxValue 税額

getCancelled

public String getCancelled()
中止区分を取得します。

戻り値:
cancelled 中止区分

setBillingdoc

public void setBillingdoc(String billingdoc)
請求伝票を設定します。

パラメータ:
billingdoc - 請求伝票

setBillType

public void setBillType(String billType)
請求タイプを設定します。

パラメータ:
billType - 請求タイプ

setBillcateg

public void setBillcateg(String billcateg)
請求カテゴリを設定します。

パラメータ:
billcateg - 請求カテゴリ

setSdDocCat

public void setSdDocCat(String sdDocCat)
販売管理伝票カテゴリを設定します。

パラメータ:
sdDocCat - 販売管理伝票カテゴリ

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO 通貨コードを設定します。

パラメータ:
currencyIso - ISO 通貨コード

setAcctstatus

public void setAcctstatus(String acctstatus)
会計への転記ステータスを設定します。

パラメータ:
acctstatus - 会計への転記ステータス

setNetValue

public void setNetValue(String netValue)
正味金額を設定します。

パラメータ:
netValue - 正味金額

setTaxValue

public void setTaxValue(String taxValue)
税額を設定します。

パラメータ:
taxValue - 税額

setCancelled

public void setCancelled(String cancelled)
中止区分を設定します。

パラメータ:
cancelled - 中止区分

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocumentDetailList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス BillingDocumentDetailList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail
        拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList
すべての実装インタフェース:
Serializable
public class BillingDocumentDetailList
extends BillingDocumentDetail
implements Serializable

後続請求伝票のテーブル情報クラス
機能は以下の通り

  • 後続請求伝票のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocumentDetailList()
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList(int index)
後続請求伝票のテーブル情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
void | setIndex(int index) レコード番号を設定します｡
クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail から継承したメソッド
getAcctstatus, getBillcateg, getBillingdoc, getBillType, getCancelled, getCurrency, getCurrencyIso, getNetValue, getSdDocCat, getTaxValue, setAcctstatus, setBillcateg, setBillingdoc, setBillType, setCancelled, setCurrency, setCurrencyIso, setNetValue, setSdDocCat, setTaxValue, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocumentDetailList

public BillingDocumentDetailList()
後続請求伝票のテーブル情報を作成します。

BillingDocumentDetailList

public BillingDocumentDetailList(int index)
後続請求伝票のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsBlob (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsBlob

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob
すべての実装インタフェース:
Serializable
public class CfgsBlob
extends Object
implements Serializable

選定: BLOB 内部データ (SCE)情報クラス
機能は以下の通り

  • 選定: BLOB 内部データ (SCE)情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsBlob()
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsBlob(int index)
選定: BLOB 内部データ (SCE)情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getContext() CU: 選定の BLOB (SCE)を取得します。
int | getIndex() レコード番号を取得します｡
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setContext(String context) CU: 選定の BLOB (SCE)を設定します。
void | setIndex(int index) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsBlob

public CfgsBlob()
選定: BLOB 内部データ (SCE)情報を作成します。

CfgsBlob

public CfgsBlob(int index)
選定: BLOB 内部データ (SCE)情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getContext

public String getContext()
CU: 選定の BLOB (SCE)を取得します。

戻り値:
context CU: 選定の BLOB (SCE)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setContext

public void setContext(String context)
CU: 選定の BLOB (SCE)を設定します。

パラメータ:
context - CU: 選定の BLOB (SCE)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsInst (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst
すべての実装インタフェース:
Serializable
public class CfgsInst
extends Object
implements Serializable

選定: インスタンス情報クラス
機能は以下の通り

  • 選定: インスタンス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsInst()
選定: インスタンス情報を作成します。
CfgsInst(int index)
選定: インスタンス情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getClassType() クラスタイプを取得します。
String | getComplete() 一般区分を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getConsistent() 一般区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getObjectGuid() インスタンス用 TYPE_OF ステートメントの GUIDを取得します。
String | getObjKey() 対象キーを取得します。
String | getObjTxt() 言語依存対象テキストを取得します。
String | getObjType() 対象タイプを取得します。
String | getPersistId() インスタンス番号 (固定)を取得します。
String | getPersistIdType() インスタンス番号タイプ (固定)を取得します。
String | getQuantity() インスタンス数量を取得します。
String | getQuantityUnit() 数量単位を取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setClassType(String classType) クラスタイプを設定します。
void | setComplete(String complete) 一般区分を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setConsistent(String consistent) 一般区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setObjectGuid(String objectGuid) インスタンス用 TYPE_OF ステートメントの GUIDを設定します。
void | setObjKey(String objKey) 対象キーを設定します。
void | setObjTxt(String objTxt) 言語依存対象テキストを設定します。
void | setObjType(String objType) 対象タイプを設定します。
void | setPersistId(String persistId) インスタンス番号 (固定)を設定します。
void | setPersistIdType(String persistIdType) インスタンス番号タイプ (固定)を設定します。
void | setQuantity(String quantity) インスタンス数量を設定します。
void | setQuantityUnit(String quantityUnit) 数量単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsInst

public CfgsInst()
選定: インスタンス情報を作成します。

CfgsInst

public CfgsInst(int index)
選定: インスタンス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getObjType

public String getObjType()
対象タイプを取得します。

戻り値:
objType 対象タイプ

getClassType

public String getClassType()
クラスタイプを取得します。

戻り値:
classType クラスタイプ

getObjKey

public String getObjKey()
対象キーを取得します。

戻り値:
objKey 対象キー

getObjTxt

public String getObjTxt()
言語依存対象テキストを取得します。

戻り値:
objTxt 言語依存対象テキスト

getQuantity

public String getQuantity()
インスタンス数量を取得します。

戻り値:
quantity インスタンス数量

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getQuantityUnit

public String getQuantityUnit()
数量単位を取得します。

戻り値:
quantityUnit 数量単位

getComplete

public String getComplete()
一般区分を取得します。

戻り値:
complete 一般区分

getConsistent

public String getConsistent()
一般区分を取得します。

戻り値:
consistent 一般区分

getObjectGuid

public String getObjectGuid()
インスタンス用 TYPE_OF ステートメントの GUIDを取得します。

戻り値:
objectGuid インスタンス用 TYPE_OF ステートメントの GUID

getPersistId

public String getPersistId()
インスタンス番号 (固定)を取得します。

戻り値:
persistId インスタンス番号 (固定)

getPersistIdType

public String getPersistIdType()
インスタンス番号タイプ (固定)を取得します。

戻り値:
persistIdType インスタンス番号タイプ (固定)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setObjType

public void setObjType(String objType)
対象タイプを設定します。

パラメータ:
objType - 対象タイプ

setClassType

public void setClassType(String classType)
クラスタイプを設定します。

パラメータ:
classType - クラスタイプ

setObjKey

public void setObjKey(String objKey)
対象キーを設定します。

パラメータ:
objKey - 対象キー

setObjTxt

public void setObjTxt(String objTxt)
言語依存対象テキストを設定します。

パラメータ:
objTxt - 言語依存対象テキスト

setQuantity

public void setQuantity(String quantity)
インスタンス数量を設定します。

パラメータ:
quantity - インスタンス数量

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setQuantityUnit

public void setQuantityUnit(String quantityUnit)
数量単位を設定します。

パラメータ:
quantityUnit - 数量単位

setComplete

public void setComplete(String complete)
一般区分を設定します。

パラメータ:
complete - 一般区分

setConsistent

public void setConsistent(String consistent)
一般区分を設定します。

パラメータ:
consistent - 一般区分

setObjectGuid

public void setObjectGuid(String objectGuid)
インスタンス用 TYPE_OF ステートメントの GUIDを設定します。

パラメータ:
objectGuid - インスタンス用 TYPE_OF ステートメントの GUID

setPersistId

public void setPersistId(String persistId)
インスタンス番号 (固定)を設定します。

パラメータ:
persistId - インスタンス番号 (固定)

setPersistIdType

public void setPersistIdType(String persistIdType)
インスタンス番号タイプ (固定)を設定します。

パラメータ:
persistIdType - インスタンス番号タイプ (固定)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsPartOf (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsPartOf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf
すべての実装インタフェース:
Serializable
public class CfgsPartOf
extends Object
implements Serializable

選定: 部分設定情報クラス
機能は以下の通り

  • 選定: 部分設定情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsPartOf()
選定: 部分設定情報を作成します。
CfgsPartOf(int index)
選定: 部分設定情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getClassType() クラスタイプを取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getObjKey() 対象キーを取得します。
String | getObjType() 対象タイプを取得します。
String | getParentId() 選定におけるインスタンス番号を取得します。
String | getPartOfGuid() インスタンス用 PART_OF ステートメントの GUIDを取得します。
String | getPartOfNo() Part_of 明細番号を取得します。
String | getSalesRelevant() この部品は販売に関連していますを取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setClassType(String classType) クラスタイプを設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setObjKey(String objKey) 対象キーを設定します。
void | setObjType(String objType) 対象タイプを設定します。
void | setParentId(String parentId) 選定におけるインスタンス番号を設定します。
void | setPartOfGuid(String partOfGuid) インスタンス用 PART_OF ステートメントの GUIDを設定します。
void | setPartOfNo(String partOfNo) Part_of 明細番号を設定します。
void | setSalesRelevant(String salesRelevant) この部品は販売に関連していますを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsPartOf

public CfgsPartOf()
選定: 部分設定情報を作成します。

CfgsPartOf

public CfgsPartOf(int index)
選定: 部分設定情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getParentId

public String getParentId()
選定におけるインスタンス番号を取得します。

戻り値:
parentId 選定におけるインスタンス番号

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getPartOfNo

public String getPartOfNo()
Part_of 明細番号を取得します。

戻り値:
partOfNo Part_of 明細番号

getObjType

public String getObjType()
対象タイプを取得します。

戻り値:
objType 対象タイプ

getClassType

public String getClassType()
クラスタイプを取得します。

戻り値:
classType クラスタイプ

getObjKey

public String getObjKey()
対象キーを取得します。

戻り値:
objKey 対象キー

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getSalesRelevant

public String getSalesRelevant()
この部品は販売に関連していますを取得します。

戻り値:
salesRelevant この部品は販売に関連しています

getPartOfGuid

public String getPartOfGuid()
インスタンス用 PART_OF ステートメントの GUIDを取得します。

戻り値:
partOfGuid インスタンス用 PART_OF ステートメントの GUID

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setParentId

public void setParentId(String parentId)
選定におけるインスタンス番号を設定します。

パラメータ:
parentId - 選定におけるインスタンス番号

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setPartOfNo

public void setPartOfNo(String partOfNo)
Part_of 明細番号を設定します。

パラメータ:
partOfNo - Part_of 明細番号

setObjType

public void setObjType(String objType)
対象タイプを設定します。

パラメータ:
objType - 対象タイプ

setClassType

public void setClassType(String classType)
クラスタイプを設定します。

パラメータ:
classType - クラスタイプ

setObjKey

public void setObjKey(String objKey)
対象キーを設定します。

パラメータ:
objKey - 対象キー

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setSalesRelevant

public void setSalesRelevant(String salesRelevant)
この部品は販売に関連していますを設定します。

パラメータ:
salesRelevant - この部品は販売に関連しています

setPartOfGuid

public void setPartOfGuid(String partOfGuid)
インスタンス用 PART_OF ステートメントの GUIDを設定します。

パラメータ:
partOfGuid - インスタンス用 PART_OF ステートメントの GUID

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsRef (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsRef

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef
すべての実装インタフェース:
Serializable
public class CfgsRef
extends Object
implements Serializable

選定: 参照データ情報クラス
機能は以下の通り

  • 選定: 参照データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsRef()
選定: 参照データ情報を作成します。
CfgsRef(int index)
選定: 参照データ情報を作成します。
メソッドの概要
String | getCbaseId() インスタンス番号 (固定)を取得します。
String | getCbaseIdType() インスタンス番号タイプ (固定)を取得します。
String | getCfginfo() CU: 選定の BLOB (SCE)を取得します。
String | getComplete() 一般区分を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getConsistent() 一般区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getKblanguage() システム設定の言語を取得します。
String | getKbname() ナレッジベースオブジェクトを取得します。
String | getKbprofile() ナレッジベースプロファイルを取得します。
String | getKbversion() SCE ナレッジベースの実行時バージョンを取得します。
String | getPosex() 外部明細番号を取得します。
String | getRootId() 選定におけるインスタンス番号を取得します。
String | getSce() CUX: 選定タイプを取得します。
void | setCbaseId(String cbaseId) インスタンス番号 (固定)を設定します。
void | setCbaseIdType(String cbaseIdType) インスタンス番号タイプ (固定)を設定します。
void | setCfginfo(String cfginfo) CU: 選定の BLOB (SCE)を設定します。
void | setComplete(String complete) 一般区分を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setConsistent(String consistent) 一般区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setKblanguage(String kblanguage) システム設定の言語を設定します。
void | setKbname(String kbname) ナレッジベースオブジェクトを設定します。
void | setKbprofile(String kbprofile) ナレッジベースプロファイルを設定します。
void | setKbversion(String kbversion) SCE ナレッジベースの実行時バージョンを設定します。
void | setPosex(String posex) 外部明細番号を設定します。
void | setRootId(String rootId) 選定におけるインスタンス番号を設定します。
void | setSce(String sce) CUX: 選定タイプを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsRef

public CfgsRef()
選定: 参照データ情報を作成します。

CfgsRef

public CfgsRef(int index)
選定: 参照データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPosex

public String getPosex()
外部明細番号を取得します。

戻り値:
posex 外部明細番号

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getRootId

public String getRootId()
選定におけるインスタンス番号を取得します。

戻り値:
rootId 選定におけるインスタンス番号

getSce

public String getSce()
CUX: 選定タイプを取得します。

戻り値:
sce CUX: 選定タイプ

getKbname

public String getKbname()
ナレッジベースオブジェクトを取得します。

戻り値:
kbname ナレッジベースオブジェクト

getKbversion

public String getKbversion()
SCE ナレッジベースの実行時バージョンを取得します。

戻り値:
kbversion SCE ナレッジベースの実行時バージョン

getComplete

public String getComplete()
一般区分を取得します。

戻り値:
complete 一般区分

getConsistent

public String getConsistent()
一般区分を取得します。

戻り値:
consistent 一般区分

getCfginfo

public String getCfginfo()
CU: 選定の BLOB (SCE)を取得します。

戻り値:
cfginfo CU: 選定の BLOB (SCE)

getKbprofile

public String getKbprofile()
ナレッジベースプロファイルを取得します。

戻り値:
kbprofile ナレッジベースプロファイル

getKblanguage

public String getKblanguage()
システム設定の言語を取得します。

戻り値:
kblanguage システム設定の言語

getCbaseId

public String getCbaseId()
インスタンス番号 (固定)を取得します。

戻り値:
cbaseId インスタンス番号 (固定)

getCbaseIdType

public String getCbaseIdType()
インスタンス番号タイプ (固定)を取得します。

戻り値:
cbaseIdType インスタンス番号タイプ (固定)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPosex

public void setPosex(String posex)
外部明細番号を設定します。

パラメータ:
posex - 外部明細番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setRootId

public void setRootId(String rootId)
選定におけるインスタンス番号を設定します。

パラメータ:
rootId - 選定におけるインスタンス番号

setSce

public void setSce(String sce)
CUX: 選定タイプを設定します。

パラメータ:
sce - CUX: 選定タイプ

setKbname

public void setKbname(String kbname)
ナレッジベースオブジェクトを設定します。

パラメータ:
kbname - ナレッジベースオブジェクト

setKbversion

public void setKbversion(String kbversion)
SCE ナレッジベースの実行時バージョンを設定します。

パラメータ:
kbversion - SCE ナレッジベースの実行時バージョン

setComplete

public void setComplete(String complete)
一般区分を設定します。

パラメータ:
complete - 一般区分

setConsistent

public void setConsistent(String consistent)
一般区分を設定します。

パラメータ:
consistent - 一般区分

setCfginfo

public void setCfginfo(String cfginfo)
CU: 選定の BLOB (SCE)を設定します。

パラメータ:
cfginfo - CU: 選定の BLOB (SCE)

setKbprofile

public void setKbprofile(String kbprofile)
ナレッジベースプロファイルを設定します。

パラメータ:
kbprofile - ナレッジベースプロファイル

setKblanguage

public void setKblanguage(String kblanguage)
システム設定の言語を設定します。

パラメータ:
kblanguage - システム設定の言語

setCbaseId

public void setCbaseId(String cbaseId)
インスタンス番号 (固定)を設定します。

パラメータ:
cbaseId - インスタンス番号 (固定)

setCbaseIdType

public void setCbaseIdType(String cbaseIdType)
インスタンス番号タイプ (固定)を設定します。

パラメータ:
cbaseIdType - インスタンス番号タイプ (固定)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsRefInst (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsRefInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst
すべての実装インタフェース:
Serializable
public class CfgsRefInst
extends Object
implements Serializable

選定: 参照明細/インスタンス情報クラス
機能は以下の通り

  • 選定: 参照明細/インスタンス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsRefInst()
選定: 参照明細/インスタンス情報を作成します。
CfgsRefInst(int index)
選定: 参照明細/インスタンス情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getPosex() 外部明細番号を取得します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setPosex(String posex) 外部明細番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsRefInst

public CfgsRefInst()
選定: 参照明細/インスタンス情報を作成します。

CfgsRefInst

public CfgsRefInst(int index)
選定: 参照明細/インスタンス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPosex

public String getPosex()
外部明細番号を取得します。

戻り値:
posex 外部明細番号

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPosex

public void setPosex(String posex)
外部明細番号を設定します。

パラメータ:
posex - 外部明細番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsValue (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsValue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue
すべての実装インタフェース:
Serializable
public class CfgsValue
extends Object
implements Serializable

選定: 特性値情報クラス
機能は以下の通り

  • 選定: 特性値情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsValue()
選定: 特性値情報を作成します。
CfgsValue(int index)
選定: 特性値情報を作成します。
メソッドの概要
String | getAuthor() 報告書提案済を取得します。
String | getCharc() 特性名を取得します。
String | getCharcTxt() 言語依存特性テキストを取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getValcode() 値タイプ: 範囲制限 - 単一値を取得します。
String | getValue() 特性値を取得します。
String | getValueTo() 特性値を取得します。
String | getValueTxt() 特性値の言語依存テキストを取得します。
void | setAuthor(String author) 報告書提案済を設定します。
void | setCharc(String charc) 特性名を設定します。
void | setCharcTxt(String charcTxt) 言語依存特性テキストを設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setValcode(String valcode) 値タイプ: 範囲制限 - 単一値を設定します。
void | setValue(String value) 特性値を設定します。
void | setValueTo(String valueTo) 特性値を設定します。
void | setValueTxt(String valueTxt) 特性値の言語依存テキストを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsValue

public CfgsValue()
選定: 特性値情報を作成します。

CfgsValue

public CfgsValue(int index)
選定: 特性値情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getCharc

public String getCharc()
特性名を取得します。

戻り値:
charc 特性名

getCharcTxt

public String getCharcTxt()
言語依存特性テキストを取得します。

戻り値:
charcTxt 言語依存特性テキスト

getValue

public String getValue()
特性値を取得します。

戻り値:
value 特性値

getValueTxt

public String getValueTxt()
特性値の言語依存テキストを取得します。

戻り値:
valueTxt 特性値の言語依存テキスト

getAuthor

public String getAuthor()
報告書提案済を取得します。

戻り値:
author 報告書提案済

getValueTo

public String getValueTo()
特性値を取得します。

戻り値:
valueTo 特性値

getValcode

public String getValcode()
値タイプ: 範囲制限 - 単一値を取得します。

戻り値:
valcode 値タイプ: 範囲制限 - 単一値

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setCharc

public void setCharc(String charc)
特性名を設定します。

パラメータ:
charc - 特性名

setCharcTxt

public void setCharcTxt(String charcTxt)
言語依存特性テキストを設定します。

パラメータ:
charcTxt - 言語依存特性テキスト

setValue

public void setValue(String value)
特性値を設定します。

パラメータ:
value - 特性値

setValueTxt

public void setValueTxt(String valueTxt)
特性値の言語依存テキストを設定します。

パラメータ:
valueTxt - 特性値の言語依存テキスト

setAuthor

public void setAuthor(String author)
報告書提案済を設定します。

パラメータ:
author - 報告書提案済

setValueTo

public void setValueTo(String valueTo)
特性値を設定します。

パラメータ:
valueTo - 特性値

setValcode

public void setValcode(String valcode)
値タイプ: 範囲制限 - 単一値を設定します。

パラメータ:
valcode - 値タイプ: 範囲制限 - 単一値

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CfgsVk (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス CfgsVk

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk
すべての実装インタフェース:
Serializable
public class CfgsVk
extends Object
implements Serializable

選定: バリアント条件キー情報クラス
機能は以下の通り

  • 選定: バリアント条件キー情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CfgsVk()
選定: バリアント条件キー情報を作成します。
CfgsVk(int index)
選定: バリアント条件キー情報を作成します。
メソッドの概要
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getFactor() バリアント条件の加重係数を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getVkey() バリアント条件名を取得します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setFactor(String factor) バリアント条件の加重係数を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setVkey(String vkey) バリアント条件名を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CfgsVk

public CfgsVk()
選定: バリアント条件キー情報を作成します。

CfgsVk

public CfgsVk(int index)
選定: バリアント条件キー情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getVkey

public String getVkey()
バリアント条件名を取得します。

戻り値:
vkey バリアント条件名

getFactor

public String getFactor()
バリアント条件の加重係数を取得します。

戻り値:
factor バリアント条件の加重係数

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setVkey

public void setVkey(String vkey)
バリアント条件名を設定します。

パラメータ:
vkey - バリアント条件名

setFactor

public void setFactor(String factor)
バリアント条件の加重係数を設定します。

パラメータ:
factor - バリアント条件の加重係数

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionsIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ConditionsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn
すべての実装インタフェース:
Serializable
public class ConditionsIn
extends Object
implements Serializable

条件情報クラス
機能は以下の通り

  • 条件情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionsIn()
条件情報を作成します。
ConditionsIn(int index)
条件情報を作成します。
メソッドの概要
String | getAccessSeq() 検索順序 - 検索番号を取得します。
String | getAccountKe() 勘定キー 見越/引当を取得します。
String | getAccountkey() 勘定キーを取得します。
String | getAccruals() 見越額関連条件 (運賃など)を取得します。
String | getApplicatio() アプリケーションを取得します。
String | getCalctypcon() 条件計算タイプを取得します。
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getConbaseval() 条件基礎値を取得します。
String | getCondchaman() 条件 (マニュアル変更済)を取得します。
String | getCondclass() 条件クラスを取得します。
String | getCondcntrl() 条件管理を取得します。
String | getCondcoinhd() 条件カウンタ (ヘッダ条件)を取得します。
String | getCondconfig() システム設定の条件を取得します。
String | getCondcount() 条件連続番号を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getCondincomp() 会社間請求の条件を取得します。
String | getCondisacti() 無効条件を取得します。
String | getCondNo() 条件レコード番号を取得します。
String | getCondorigin() 条件生成区分を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondtype() 条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 条件単位を取得します。
String | getCondUpdat() 条件更新を取得します。
String | getCondvalue() 条件金額を取得します。
String | getCondValue() 条件レートを取得します。
String | getConexchrat() 現地通貨への換算レートに対する条件を取得します。
String | getConinvolst() 請求書一覧条件を取得します。
String | getConpricdat() 条件価格設定日付を取得します。
String | getCurrenckey() スケール通貨を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrency2() 販売伝票通貨を取得します。
String | getCurreniso() ISO コード通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCurrIso2() ISO コード通貨を取得します。
String | getDenominato() 条件単位を基本単位へ変換する分母を取得します。
String | getFactbasval() 条件基礎値に対する要因を取得します。
String | getFactconbas() 条件基準の係数 (期間)を取得します。
String | getGroupcond() グループ条件区分を取得します。
int | getIndex() レコード番号を取得します｡
String | getIsoUnit() 単位の ISO コードを取得します。
String | getItmNumber() 条件明細番号を取得します。
String | getNumconvert() 条件単位を基本単位へ変換する分子を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRoundoffdi() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getScalbasval() 条件のスケール基準値を取得します。
String | getScalebasin() スケール基準区分を取得します。
String | getScaletype() スケールタイプを取得します。
String | getStatCon() 統計に適用する条件を取得します。
String | getStructcond() 構造条件を取得します。
String | getTaxCode() 消費税コードを取得します。
String | getUnitmeasur() 条件スケール単位を取得します。
String | getVarcond() バリアント条件を取得します。
String | getWtWithcd() 源泉徴収税コードを取得します。
void | setAccessSeq(String accessSeq) 検索順序 - 検索番号を設定します。
void | setAccountKe(String accountKe) 勘定キー 見越/引当を設定します。
void | setAccountkey(String accountkey) 勘定キーを設定します。
void | setAccruals(String accruals) 見越額関連条件 (運賃など)を設定します。
void | setApplicatio(String applicatio) アプリケーションを設定します。
void | setCalctypcon(String calctypcon) 条件計算タイプを設定します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setConbaseval(String conbaseval) 条件基礎値を設定します。
void | setCondchaman(String condchaman) 条件 (マニュアル変更済)を設定します。
void | setCondclass(String condclass) 条件クラスを設定します。
void | setCondcntrl(String condcntrl) 条件管理を設定します。
void | setCondcoinhd(String condcoinhd) 条件カウンタ (ヘッダ条件)を設定します。
void | setCondconfig(String condconfig) システム設定の条件を設定します。
void | setCondcount(String condcount) 条件連続番号を設定します。
void | setCondCount(String condCount) 条件カウンタを設定します。
void | setCondincomp(String condincomp) 会社間請求の条件を設定します。
void | setCondisacti(String condisacti) 無効条件を設定します。
void | setCondNo(String condNo) 条件レコード番号を設定します。
void | setCondorigin(String condorigin) 条件生成区分を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondtype(String condtype) 条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCondUpdat(String condUpdat) 条件更新を設定します。
void | setCondvalue(String condvalue) 条件金額を設定します。
void | setCondValue(String condValue) 条件レートを設定します。
void | setConexchrat(String conexchrat) 現地通貨への換算レートに対する条件を設定します。
void | setConinvolst(String coninvolst) 請求書一覧条件を設定します。
void | setConpricdat(String conpricdat) 条件価格設定日付を設定します。
void | setCurrenckey(String currenckey) スケール通貨を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrency2(String currency2) 販売伝票通貨を設定します。
void | setCurreniso(String curreniso) ISO コード通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCurrIso2(String currIso2) ISO コード通貨を設定します。
void | setDenominato(String denominato) 条件単位を基本単位へ変換する分母を設定します。
void | setFactbasval(String factbasval) 条件基礎値に対する要因を設定します。
void | setFactconbas(String factconbas) 条件基準の係数 (期間)を設定します。
void | setGroupcond(String groupcond) グループ条件区分を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setIsoUnit(String isoUnit) 単位の ISO コードを設定します。
void | setItmNumber(String itmNumber) 条件明細番号を設定します。
void | setNumconvert(String numconvert) 条件単位を基本単位へ変換する分子を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRoundoffdi(String roundoffdi) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setScalbasval(String scalbasval) 条件のスケール基準値を設定します。
void | setScalebasin(String scalebasin) スケール基準区分を設定します。
void | setScaletype(String scaletype) スケールタイプを設定します。
void | setStatCon(String statCon) 統計に適用する条件を設定します。
void | setStructcond(String structcond) 構造条件を設定します。
void | setTaxCode(String taxCode) 消費税コードを設定します。
void | setUnitmeasur(String unitmeasur) 条件スケール単位を設定します。
void | setVarcond(String varcond) バリアント条件を設定します。
void | setWtWithcd(String wtWithcd) 源泉徴収税コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionsIn

public ConditionsIn()
条件情報を作成します。

ConditionsIn

public ConditionsIn(int index)
条件情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
itmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
condCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getCondValue

public String getCondValue()
条件レートを取得します。

戻り値:
condValue 条件レート

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getApplicatio

public String getApplicatio()
アプリケーションを取得します。

戻り値:
applicatio アプリケーション

getConpricdat

public String getConpricdat()
条件価格設定日付を取得します。

戻り値:
conpricdat 条件価格設定日付

getCalctypcon

public String getCalctypcon()
条件計算タイプを取得します。

戻り値:
calctypcon 条件計算タイプ

getConbaseval

public String getConbaseval()
条件基礎値を取得します。

戻り値:
conbaseval 条件基礎値

getConexchrat

public String getConexchrat()
現地通貨への換算レートに対する条件を取得します。

戻り値:
conexchrat 現地通貨への換算レートに対する条件

getNumconvert

public String getNumconvert()
条件単位を基本単位へ変換する分子を取得します。

戻り値:
numconvert 条件単位を基本単位へ変換する分子

getDenominato

public String getDenominato()
条件単位を基本単位へ変換する分母を取得します。

戻り値:
denominato 条件単位を基本単位へ変換する分母

getCondtype

public String getCondtype()
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。

戻り値:
condtype 条件カテゴリ (例: 税、運賃、価格、原価)

getStatCon

public String getStatCon()
統計に適用する条件を取得します。

戻り値:
statCon 統計に適用する条件

getScaletype

public String getScaletype()
スケールタイプを取得します。

戻り値:
scaletype スケールタイプ

getAccruals

public String getAccruals()
見越額関連条件 (運賃など)を取得します。

戻り値:
accruals 見越額関連条件 (運賃など)

getConinvolst

public String getConinvolst()
請求書一覧条件を取得します。

戻り値:
coninvolst 請求書一覧条件

getCondorigin

public String getCondorigin()
条件生成区分を取得します。

戻り値:
condorigin 条件生成区分

getGroupcond

public String getGroupcond()
グループ条件区分を取得します。

戻り値:
groupcond グループ条件区分

getCondUpdat

public String getCondUpdat()
条件更新を取得します。

戻り値:
condUpdat 条件更新

getAccessSeq

public String getAccessSeq()
検索順序 - 検索番号を取得します。

戻り値:
accessSeq 検索順序 - 検索番号

getCondcount

public String getCondcount()
条件連続番号を取得します。

戻り値:
condcount 条件連続番号

getRoundoffdi

public String getRoundoffdi()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
roundoffdi BAPI の通貨額 (小数点以下９桁)

getCondvalue

public String getCondvalue()
条件金額を取得します。

戻り値:
condvalue 条件金額

getCurrency2

public String getCurrency2()
販売伝票通貨を取得します。

戻り値:
currency2 販売伝票通貨

getCurrIso2

public String getCurrIso2()
ISO コード通貨を取得します。

戻り値:
currIso2 ISO コード通貨

getCondcntrl

public String getCondcntrl()
条件管理を取得します。

戻り値:
condcntrl 条件管理

getCondisacti

public String getCondisacti()
無効条件を取得します。

戻り値:
condisacti 無効条件

getCondclass

public String getCondclass()
条件クラスを取得します。

戻り値:
condclass 条件クラス

getFactbasval

public String getFactbasval()
条件基礎値に対する要因を取得します。

戻り値:
factbasval 条件基礎値に対する要因

getScalebasin

public String getScalebasin()
スケール基準区分を取得します。

戻り値:
scalebasin スケール基準区分

getScalbasval

public String getScalbasval()
条件のスケール基準値を取得します。

戻り値:
scalbasval 条件のスケール基準値

getUnitmeasur

public String getUnitmeasur()
条件スケール単位を取得します。

戻り値:
unitmeasur 条件スケール単位

getIsoUnit

public String getIsoUnit()
単位の ISO コードを取得します。

戻り値:
isoUnit 単位の ISO コード

getCurrenckey

public String getCurrenckey()
スケール通貨を取得します。

戻り値:
currenckey スケール通貨

getCurreniso

public String getCurreniso()
ISO コード通貨を取得します。

戻り値:
curreniso ISO コード通貨

getCondincomp

public String getCondincomp()
会社間請求の条件を取得します。

戻り値:
condincomp 会社間請求の条件

getCondconfig

public String getCondconfig()
システム設定の条件を取得します。

戻り値:
condconfig システム設定の条件

getCondchaman

public String getCondchaman()
条件 (マニュアル変更済)を取得します。

戻り値:
condchaman 条件 (マニュアル変更済)

getCondNo

public String getCondNo()
条件レコード番号を取得します。

戻り値:
condNo 条件レコード番号

getTaxCode

public String getTaxCode()
消費税コードを取得します。

戻り値:
taxCode 消費税コード

getVarcond

public String getVarcond()
バリアント条件を取得します。

戻り値:
varcond バリアント条件

getAccountkey

public String getAccountkey()
勘定キーを取得します。

戻り値:
accountkey 勘定キー

getAccountKe

public String getAccountKe()
勘定キー 見越/引当を取得します。

戻り値:
accountKe 勘定キー 見越/引当

getWtWithcd

public String getWtWithcd()
源泉徴収税コードを取得します。

戻り値:
wtWithcd 源泉徴収税コード

getStructcond

public String getStructcond()
構造条件を取得します。

戻り値:
structcond 構造条件

getFactconbas

public String getFactconbas()
条件基準の係数 (期間)を取得します。

戻り値:
factconbas 条件基準の係数 (期間)

getCondcoinhd

public String getCondcoinhd()
条件カウンタ (ヘッダ条件)を取得します。

戻り値:
condcoinhd 条件カウンタ (ヘッダ条件)

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
条件明細番号を設定します。

パラメータ:
itmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件カウンタを設定します。

パラメータ:
condCount - 条件カウンタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setCondValue

public void setCondValue(String condValue)
条件レートを設定します。

パラメータ:
condValue - 条件レート

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setApplicatio

public void setApplicatio(String applicatio)
アプリケーションを設定します。

パラメータ:
applicatio - アプリケーション

setConpricdat

public void setConpricdat(String conpricdat)
条件価格設定日付を設定します。

パラメータ:
conpricdat - 条件価格設定日付

setCalctypcon

public void setCalctypcon(String calctypcon)
条件計算タイプを設定します。

パラメータ:
calctypcon - 条件計算タイプ

setConbaseval

public void setConbaseval(String conbaseval)
条件基礎値を設定します。

パラメータ:
conbaseval - 条件基礎値

setConexchrat

public void setConexchrat(String conexchrat)
現地通貨への換算レートに対する条件を設定します。

パラメータ:
conexchrat - 現地通貨への換算レートに対する条件

setNumconvert

public void setNumconvert(String numconvert)
条件単位を基本単位へ変換する分子を設定します。

パラメータ:
numconvert - 条件単位を基本単位へ変換する分子

setDenominato

public void setDenominato(String denominato)
条件単位を基本単位へ変換する分母を設定します。

パラメータ:
denominato - 条件単位を基本単位へ変換する分母

setCondtype

public void setCondtype(String condtype)
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。

パラメータ:
condtype - 条件カテゴリ (例: 税、運賃、価格、原価)

setStatCon

public void setStatCon(String statCon)
統計に適用する条件を設定します。

パラメータ:
statCon - 統計に適用する条件

setScaletype

public void setScaletype(String scaletype)
スケールタイプを設定します。

パラメータ:
scaletype - スケールタイプ

setAccruals

public void setAccruals(String accruals)
見越額関連条件 (運賃など)を設定します。

パラメータ:
accruals - 見越額関連条件 (運賃など)

setConinvolst

public void setConinvolst(String coninvolst)
請求書一覧条件を設定します。

パラメータ:
coninvolst - 請求書一覧条件

setCondorigin

public void setCondorigin(String condorigin)
条件生成区分を設定します。

パラメータ:
condorigin - 条件生成区分

setGroupcond

public void setGroupcond(String groupcond)
グループ条件区分を設定します。

パラメータ:
groupcond - グループ条件区分

setCondUpdat

public void setCondUpdat(String condUpdat)
条件更新を設定します。

パラメータ:
condUpdat - 条件更新

setAccessSeq

public void setAccessSeq(String accessSeq)
検索順序 - 検索番号を設定します。

パラメータ:
accessSeq - 検索順序 - 検索番号

setCondcount

public void setCondcount(String condcount)
条件連続番号を設定します。

パラメータ:
condcount - 条件連続番号

setRoundoffdi

public void setRoundoffdi(String roundoffdi)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
roundoffdi - BAPI の通貨額 (小数点以下９桁)

setCondvalue

public void setCondvalue(String condvalue)
条件金額を設定します。

パラメータ:
condvalue - 条件金額

setCurrency2

public void setCurrency2(String currency2)
販売伝票通貨を設定します。

パラメータ:
currency2 - 販売伝票通貨

setCurrIso2

public void setCurrIso2(String currIso2)
ISO コード通貨を設定します。

パラメータ:
currIso2 - ISO コード通貨

setCondcntrl

public void setCondcntrl(String condcntrl)
条件管理を設定します。

パラメータ:
condcntrl - 条件管理

setCondisacti

public void setCondisacti(String condisacti)
無効条件を設定します。

パラメータ:
condisacti - 無効条件

setCondclass

public void setCondclass(String condclass)
条件クラスを設定します。

パラメータ:
condclass - 条件クラス

setFactbasval

public void setFactbasval(String factbasval)
条件基礎値に対する要因を設定します。

パラメータ:
factbasval - 条件基礎値に対する要因

setScalebasin

public void setScalebasin(String scalebasin)
スケール基準区分を設定します。

パラメータ:
scalebasin - スケール基準区分

setScalbasval

public void setScalbasval(String scalbasval)
条件のスケール基準値を設定します。

パラメータ:
scalbasval - 条件のスケール基準値

setUnitmeasur

public void setUnitmeasur(String unitmeasur)
条件スケール単位を設定します。

パラメータ:
unitmeasur - 条件スケール単位

setIsoUnit

public void setIsoUnit(String isoUnit)
単位の ISO コードを設定します。

パラメータ:
isoUnit - 単位の ISO コード

setCurrenckey

public void setCurrenckey(String currenckey)
スケール通貨を設定します。

パラメータ:
currenckey - スケール通貨

setCurreniso

public void setCurreniso(String curreniso)
ISO コード通貨を設定します。

パラメータ:
curreniso - ISO コード通貨

setCondincomp

public void setCondincomp(String condincomp)
会社間請求の条件を設定します。

パラメータ:
condincomp - 会社間請求の条件

setCondconfig

public void setCondconfig(String condconfig)
システム設定の条件を設定します。

パラメータ:
condconfig - システム設定の条件

setCondchaman

public void setCondchaman(String condchaman)
条件 (マニュアル変更済)を設定します。

パラメータ:
condchaman - 条件 (マニュアル変更済)

setCondNo

public void setCondNo(String condNo)
条件レコード番号を設定します。

パラメータ:
condNo - 条件レコード番号

setTaxCode

public void setTaxCode(String taxCode)
消費税コードを設定します。

パラメータ:
taxCode - 消費税コード

setVarcond

public void setVarcond(String varcond)
バリアント条件を設定します。

パラメータ:
varcond - バリアント条件

setAccountkey

public void setAccountkey(String accountkey)
勘定キーを設定します。

パラメータ:
accountkey - 勘定キー

setAccountKe

public void setAccountKe(String accountKe)
勘定キー 見越/引当を設定します。

パラメータ:
accountKe - 勘定キー 見越/引当

setWtWithcd

public void setWtWithcd(String wtWithcd)
源泉徴収税コードを設定します。

パラメータ:
wtWithcd - 源泉徴収税コード

setStructcond

public void setStructcond(String structcond)
構造条件を設定します。

パラメータ:
structcond - 構造条件

setFactconbas

public void setFactconbas(String factconbas)
条件基準の係数 (期間)を設定します。

パラメータ:
factconbas - 条件基準の係数 (期間)

setCondcoinhd

public void setCondcoinhd(String condcoinhd)
条件カウンタ (ヘッダ条件)を設定します。

パラメータ:
condcoinhd - 条件カウンタ (ヘッダ条件)

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConditionsInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ConditionsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX
すべての実装インタフェース:
Serializable
public class ConditionsInX
extends Object
implements Serializable

受注における条件更新の通信項目情報クラス
機能は以下の通り

  • 受注における条件更新の通信項目情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ConditionsInX()
受注における条件更新の通信項目情報を作成します。
ConditionsInX(int index)
受注における条件更新の通信項目情報を作成します。
メソッドの概要
String | getCondCount() 条件連続番号を取得します。
String | getCondPUnt() 関連ユーザデータ項目の更新情報を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondType() 条件タイプを取得します。
String | getCondUnit() 関連ユーザデータ項目の更新情報を取得します。
String | getCondValue() 関連ユーザデータ項目の更新情報を取得します。
String | getCurrency() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 条件明細番号を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getVarcond() バリアント条件を取得します。
void | setCondCount(String condCount) 条件連続番号を設定します。
void | setCondPUnt(String condPUnt) 関連ユーザデータ項目の更新情報を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setCondUnit(String condUnit) 関連ユーザデータ項目の更新情報を設定します。
void | setCondValue(String condValue) 関連ユーザデータ項目の更新情報を設定します。
void | setCurrency(String currency) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 条件明細番号を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setVarcond(String varcond) バリアント条件を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConditionsInX

public ConditionsInX()
受注における条件更新の通信項目情報を作成します。

ConditionsInX

public ConditionsInX(int index)
受注における条件更新の通信項目情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
条件明細番号を取得します。

戻り値:
itmNumber 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件連続番号を取得します。

戻り値:
condCount 条件連続番号

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getCondValue

public String getCondValue()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condValue 関連ユーザデータ項目の更新情報

getCurrency

public String getCurrency()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
currency 関連ユーザデータ項目の更新情報

getCondUnit

public String getCondUnit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condUnit 関連ユーザデータ項目の更新情報

getCondPUnt

public String getCondPUnt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
condPUnt 関連ユーザデータ項目の更新情報

getVarcond

public String getVarcond()
バリアント条件を取得します。

戻り値:
varcond バリアント条件

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
条件明細番号を設定します。

パラメータ:
itmNumber - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件連続番号を設定します。

パラメータ:
condCount - 条件連続番号

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setCondValue

public void setCondValue(String condValue)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condValue - 関連ユーザデータ項目の更新情報

setCurrency

public void setCurrency(String currency)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
currency - 関連ユーザデータ項目の更新情報

setCondUnit

public void setCondUnit(String condUnit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condUnit - 関連ユーザデータ項目の更新情報

setCondPUnt

public void setCondPUnt(String condPUnt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
condPUnt - 関連ユーザデータ項目の更新情報

setVarcond

public void setVarcond(String varcond)
バリアント条件を設定します。

パラメータ:
varcond - バリアント条件

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ExtensionIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn
すべての実装インタフェース:
Serializable
public class ExtensionIn
extends Object
implements Serializable

VBAK、VBAP、VBEP のカスタマ拡張情報クラス
機能は以下の通り

  • VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ExtensionIn()
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionIn(int index)
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
メソッドの概要
int | getIndex() レコード番号を取得します｡
String | getStructure() BAPI テーブル拡張の構造名を取得します。
String | getValuepart1() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart2() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart3() BAPI 拡張パラメータのデータ部分を取得します。
String | getValuepart4() BAPI 拡張パラメータのデータ部分を取得します。
void | setIndex(int index) レコード番号を設定します｡
void | setStructure(String structure) BAPI テーブル拡張の構造名を設定します。
void | setValuepart1(String valuepart1) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart2(String valuepart2) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart3(String valuepart3) BAPI 拡張パラメータのデータ部分を設定します。
void | setValuepart4(String valuepart4) BAPI 拡張パラメータのデータ部分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ExtensionIn

public ExtensionIn()
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。

ExtensionIn

public ExtensionIn(int index)
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getStructure

public String getStructure()
BAPI テーブル拡張の構造名を取得します。

戻り値:
structure BAPI テーブル拡張の構造名

getValuepart1

public String getValuepart1()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart1 BAPI 拡張パラメータのデータ部分

getValuepart2

public String getValuepart2()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart2 BAPI 拡張パラメータのデータ部分

getValuepart3

public String getValuepart3()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart3 BAPI 拡張パラメータのデータ部分

getValuepart4

public String getValuepart4()
BAPI 拡張パラメータのデータ部分を取得します。

戻り値:
valuepart4 BAPI 拡張パラメータのデータ部分

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setStructure

public void setStructure(String structure)
BAPI テーブル拡張の構造名を設定します。

パラメータ:
structure - BAPI テーブル拡張の構造名

setValuepart1

public void setValuepart1(String valuepart1)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart1 - BAPI 拡張パラメータのデータ部分

setValuepart2

public void setValuepart2(String valuepart2)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart2 - BAPI 拡張パラメータのデータ部分

setValuepart3

public void setValuepart3(String valuepart3)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart3 - BAPI 拡張パラメータのデータ部分

setValuepart4

public void setValuepart4(String valuepart4)
BAPI 拡張パラメータのデータ部分を設定します。

パラメータ:
valuepart4 - BAPI 拡張パラメータのデータ部分

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeaderIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス HeaderIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn
すべての実装インタフェース:
Serializable
public class HeaderIn
extends Object
implements Serializable

販売伝票ヘッダデータ情報クラス
機能は以下の通り

  • 販売伝票ヘッダデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeaderIn()
販売伝票ヘッダデータ情報を作成します。
メソッドの概要
String | getAccntAsgn() 得意先の勘定設定グループを取得します。
String | getAddValDy() 有効日からの日数を取得します。
String | getAlttaxCls() 代替税分類を取得します。
String | getAssNumber() 割当番号を取得します。
String | getBillBlock() 販売管理伝票の請求ブロックを取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillSched() 請求日程 (稼働日カレンダ指定)を取得します。
String | getCampaign() 総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
String | getChkprtauth() 取引先権限チェックを取得します。
String | getCmlqtyDat() 累積出荷数量日付を取得します。
String | getCollectNo() 一括番号を取得します。
String | getCompCdeB() 請求対象会社コードを取得します。
String | getComplDlv() 一括納入区分を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCstcndgrp1() 得意先条件グループ１を取得します。
String | getCstcndgrp2() 得意先条件グループ２を取得します。
String | getCstcndgrp3() 得意先条件グループ３を取得します。
String | getCstcndgrp4() 得意先条件グループ４を取得します。
String | getCstcndgrp5() 得意先条件グループ５を取得します。
String | getCtValidF() 有効開始日付 (販売契約/品目提案)を取得します。
String | getCtValidT() 有効終了日付 (販売契約/品目提案)を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCustGroup() 得意先グループを取得します。
String | getCustGrp1() 得意先グループ 1を取得します。
String | getCustGrp2() 得意先グループ 2を取得します。
String | getCustGrp3() 得意先グループ 3を取得します。
String | getCustGrp4() 得意先グループ 4を取得します。
String | getCustGrp5() 得意先グループ 5を取得します。
String | getDateType() 提案日付タイプを取得します。
String | getDepartmNo() 部門コードを取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvschduse() 用途区分を取得します。
String | getDlvTime() 契約出荷期間を取得します。
String | getDocClass() リリースおよびトランザクション管理を備えた元システムを取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocNumFi() ドキュメンタリクレジット処理: 内部番号を取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getDunCount() 得意先商談回数を取得します。
String | getDunDate() 得意先との前回の商談日を取得します。
String | getDunnBlock() 督促処理保留を取得します。
String | getDunnKey() 督促処理キーを取得します。
String | getEutriDeal() フラグ: EC 内三角取引を取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getExchRateFiV() FI 転記の換算レート (間接相場)を取得します。
String | getExrateFi() FI 転記の換算レート (直接相場)を取得します。
String | getFixValDy() 有効日日付を取得します。
String | getFkkConacct() 長さ 12 の文字項目を取得します。
String | getHCurr() 通貨コードを取得します。
String | getHCurrIso() ISO 通貨コードを取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
String | getInvoSched() 請求書一覧日程 (稼働日カレンダ指定)を取得します。
String | getMastContr() グループマスタ契約番号を取得します。
String | getMnInvoice() マニュアル請求書更新を取得します。
String | getName() 発注者名称を取得します。
String | getNotifNo() 通知番号を取得します。
String | getOrdcombIn() 受注結合出荷区分を取得します。
String | getOrdReason() 受注理由 (取引理由)を取得します。
String | getPldlvstyp() MRP: 出荷計画タイプを取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getPmtgarPro() 支払保証決定表を取得します。
String | getPoDatS() 出荷先の出荷先発注日付を取得します。
String | getPoMethod() 得意先発注タイプを取得します。
String | getPoMethS() 出荷先の出荷先発注タイプを取得します。
String | getPoSupplem() 得意先発注番号補足を取得します。
String | getPpSearch() 品目提案検索条件を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getPriceGrp() 価格グループ (得意先)を取得します。
String | getPriceList() 価格表タイプを取得します。
String | getPurchDate() 得意先発注日付を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getPurchNoS() 出荷先の得意先発注番号を取得します。
String | getPymtMeth() 支払方法を取得します。
String | getQtValidF() 見積/引合有効開始日を取得します。
String | getQtValidT() 見積の有効終了日を取得します。
String | getRecPoint() 入荷ポイントを取得します。
String | getRef1() 得意先/仕入先の内部参照コードを取得します。
String | getRef1S() 出荷先文字を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefdocCat() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefDocL() 参照伝票番号を取得します。
String | getRefDocLLong() 参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。
String | getRefdoctype() 参照オブジェクトの伝票タイプを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRefProc() 参照限定条件: 決定区分を取得します。
String | getReqDateH() 指定納入期日を取得します。
String | getSalesDist() 販売地域を取得します。
String | getSalesGrp() 営業グループを取得します。
String | getSalesOff() 営業所を取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSdDocCat() 販売管理伝票カテゴリを取得します。
String | getServDate() サービス提供日を取得します。
String | getShipCond() 出荷条件を取得します。
String | getShipType() 出荷タイプを取得します。
String | getSProcInd() 特別処理区分を取得します。
String | getTaxClass2() 得意先税分類 2を取得します。
String | getTaxClass3() 得意先税分類 3を取得します。
String | getTaxClass4() 得意先に対する税クラス 4を取得します。
String | getTaxClass5() 得意先に対する税クラス 5を取得します。
String | getTaxClass6() 得意先に対する税クラス 6を取得します。
String | getTaxClass7() 得意先に対する税クラス 7を取得します。
String | getTaxClass8() 得意先に対する税クラス 8を取得します。
String | getTaxClass9() 得意先に対する税クラス 9を取得します。
String | getTaxdepCty() 税出荷国を取得します。
String | getTaxdstCty() 税仕向国を取得します。
String | getTelephone() 電話番号を取得します。
String | getVersion() 販売伝票バージョン番号を取得します。
String | getWarDate() 保証期間の開始日付を取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAccntAsgn(String accntAsgn) 得意先の勘定設定グループを設定します。
void | setAddValDy(String addValDy) 有効日からの日数を設定します。
void | setAlttaxCls(String alttaxCls) 代替税分類を設定します。
void | setAssNumber(String assNumber) 割当番号を設定します。
void | setBillBlock(String billBlock) 販売管理伝票の請求ブロックを設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillSched(String billSched) 請求日程 (稼働日カレンダ指定)を設定します。
void | setCampaign(String campaign) 総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
void | setChkprtauth(String chkprtauth) 取引先権限チェックを設定します。
void | setCmlqtyDat(String cmlqtyDat) 累積出荷数量日付を設定します。
void | setCollectNo(String collectNo) 一括番号を設定します。
void | setCompCdeB(String compCdeB) 請求対象会社コードを設定します。
void | setComplDlv(String complDlv) 一括納入区分を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCstcndgrp1(String cstcndgrp1) 得意先条件グループ１を設定します。
void | setCstcndgrp2(String cstcndgrp2) 得意先条件グループ２を設定します。
void | setCstcndgrp3(String cstcndgrp3) 得意先条件グループ３を設定します。
void | setCstcndgrp4(String cstcndgrp4) 得意先条件グループ４を設定します。
void | setCstcndgrp5(String cstcndgrp5) 得意先条件グループ５を設定します。
void | setCtValidF(String ctValidF) 有効開始日付 (販売契約/品目提案)を設定します。
void | setCtValidT(String ctValidT) 有効終了日付 (販売契約/品目提案)を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCustGroup(String custGroup) 得意先グループを設定します。
void | setCustGrp1(String custGrp1) 得意先グループ 1を設定します。
void | setCustGrp2(String custGrp2) 得意先グループ 2を設定します。
void | setCustGrp3(String custGrp3) 得意先グループ 3を設定します。
void | setCustGrp4(String custGrp4) 得意先グループ 4を設定します。
void | setCustGrp5(String custGrp5) 得意先グループ 5を設定します。
void | setDateType(String dateType) 提案日付タイプを設定します。
void | setDepartmNo(String departmNo) 部門コードを設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvschduse(String dlvschduse) 用途区分を設定します。
void | setDlvTime(String dlvTime) 契約出荷期間を設定します。
void | setDocClass(String docClass) リリースおよびトランザクション管理を備えた元システムを設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocNumFi(String docNumFi) ドキュメンタリクレジット処理: 内部番号を設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setDunCount(String dunCount) 得意先商談回数を設定します。
void | setDunDate(String dunDate) 得意先との前回の商談日を設定します。
void | setDunnBlock(String dunnBlock) 督促処理保留を設定します。
void | setDunnKey(String dunnKey) 督促処理キーを設定します。
void | setEutriDeal(String eutriDeal) フラグ: EC 内三角取引を設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setExchRateFiV(String exchRateFiV) FI 転記の換算レート (間接相場)を設定します。
void | setExrateFi(String exrateFi) FI 転記の換算レート (直接相場)を設定します。
void | setFixValDy(String fixValDy) 有効日日付を設定します。
void | setFkkConacct(String fkkConacct) 長さ 12 の文字項目を設定します。
void | setHCurr(String hCurr) 通貨コードを設定します。
void | setHCurrIso(String hCurrIso) ISO 通貨コードを設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ 2を設定します。
void | setInvoSched(String invoSched) 請求書一覧日程 (稼働日カレンダ指定)を設定します。
void | setMastContr(String mastContr) グループマスタ契約番号を設定します。
void | setMnInvoice(String mnInvoice) マニュアル請求書更新を設定します。
void | setName(String name) 発注者名称を設定します。
void | setNotifNo(String notifNo) 通知番号を設定します。
void | setOrdcombIn(String ordcombIn) 受注結合出荷区分を設定します。
void | setOrdReason(String ordReason) 受注理由 (取引理由)を設定します。
void | setPldlvstyp(String pldlvstyp) MRP: 出荷計画タイプを設定します。
void | setPmnttrms(String pmnttrms) 支払条件キーを設定します。
void | setPmtgarPro(String pmtgarPro) 支払保証決定表を設定します。
void | setPoDatS(String poDatS) 出荷先の出荷先発注日付を設定します。
void | setPoMethod(String poMethod) 得意先発注タイプを設定します。
void | setPoMethS(String poMethS) 出荷先の出荷先発注タイプを設定します。
void | setPoSupplem(String poSupplem) 得意先発注番号補足を設定します。
void | setPpSearch(String ppSearch) 品目提案検索条件を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setPriceGrp(String priceGrp) 価格グループ (得意先)を設定します。
void | setPriceList(String priceList) 価格表タイプを設定します。
void | setPurchDate(String purchDate) 得意先発注日付を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setPurchNoS(String purchNoS) 出荷先の得意先発注番号を設定します。
void | setPymtMeth(String pymtMeth) 支払方法を設定します。
void | setQtValidF(String qtValidF) 見積/引合有効開始日を設定します。
void | setQtValidT(String qtValidT) 見積の有効終了日を設定します。
void | setRecPoint(String recPoint) 入荷ポイントを設定します。
void | setRef1(String ref1) 得意先/仕入先の内部参照コードを設定します。
void | setRef1S(String ref1S) 出荷先文字を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefdocCat(String refdocCat) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefDocL(String refDocL) 参照伝票番号を設定します。
void | setRefDocLLong(String refDocLLong) 参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。
void | setRefdoctype(String refdoctype) 参照オブジェクトの伝票タイプを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRefProc(String refProc) 参照限定条件: 決定区分を設定します。
void | setReqDateH(String reqDateH) 指定納入期日を設定します。
void | setSalesDist(String salesDist) 販売地域を設定します。
void | setSalesGrp(String salesGrp) 営業グループを設定します。
void | setSalesOff(String salesOff) 営業所を設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSdDocCat(String sdDocCat) 販売管理伝票カテゴリを設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipCond(String shipCond) 出荷条件を設定します。
void | setShipType(String shipType) 出荷タイプを設定します。
void | setSProcInd(String sProcInd) 特別処理区分を設定します。
void | setTaxClass2(String taxClass2) 得意先税分類 2を設定します。
void | setTaxClass3(String taxClass3) 得意先税分類 3を設定します。
void | setTaxClass4(String taxClass4) 得意先に対する税クラス 4を設定します。
void | setTaxClass5(String taxClass5) 得意先に対する税クラス 5を設定します。
void | setTaxClass6(String taxClass6) 得意先に対する税クラス 6を設定します。
void | setTaxClass7(String taxClass7) 得意先に対する税クラス 7を設定します。
void | setTaxClass8(String taxClass8) 得意先に対する税クラス 8を設定します。
void | setTaxClass9(String taxClass9) 得意先に対する税クラス 9を設定します。
void | setTaxdepCty(String taxdepCty) 税出荷国を設定します。
void | setTaxdstCty(String taxdstCty) 税仕向国を設定します。
void | setTelephone(String telephone) 電話番号を設定します。
void | setVersion(String version) 販売伝票バージョン番号を設定します。
void | setWarDate(String warDate) 保証期間の開始日付を設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeaderIn

public HeaderIn()
販売伝票ヘッダデータ情報を作成します。

メソッドの詳細

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getRefdoctype

public String getRefdoctype()
参照オブジェクトの伝票タイプを取得します。

戻り値:
refdoctype 参照オブジェクトの伝票タイプ

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getCollectNo

public String getCollectNo()
一括番号を取得します。

戻り値:
collectNo 一括番号

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getSalesGrp

public String getSalesGrp()
営業グループを取得します。

戻り値:
salesGrp 営業グループ

getSalesOff

public String getSalesOff()
営業所を取得します。

戻り値:
salesOff 営業所

getReqDateH

public String getReqDateH()
指定納入期日を取得します。

戻り値:
reqDateH 指定納入期日

getDateType

public String getDateType()
提案日付タイプを取得します。

戻り値:
dateType 提案日付タイプ

getPurchDate

public String getPurchDate()
得意先発注日付を取得します。

戻り値:
purchDate 得意先発注日付

getPoMethod

public String getPoMethod()
得意先発注タイプを取得します。

戻り値:
poMethod 得意先発注タイプ

getPoSupplem

public String getPoSupplem()
得意先発注番号補足を取得します。

戻り値:
poSupplem 得意先発注番号補足

getRef1

public String getRef1()
得意先/仕入先の内部参照コードを取得します。

戻り値:
ref1 得意先/仕入先の内部参照コード

getName

public String getName()
発注者名称を取得します。

戻り値:
name 発注者名称

getTelephone

public String getTelephone()
電話番号を取得します。

戻り値:
telephone 電話番号

getPriceGrp

public String getPriceGrp()
価格グループ (得意先)を取得します。

戻り値:
priceGrp 価格グループ (得意先)

getCustGroup

public String getCustGroup()
得意先グループを取得します。

戻り値:
custGroup 得意先グループ

getSalesDist

public String getSalesDist()
販売地域を取得します。

戻り値:
salesDist 販売地域

getPriceList

public String getPriceList()
価格表タイプを取得します。

戻り値:
priceList 価格表タイプ

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
incoterms2 インコタームズ 2

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
pmnttrms 支払条件キー

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getBillBlock

public String getBillBlock()
販売管理伝票の請求ブロックを取得します。

戻り値:
billBlock 販売管理伝票の請求ブロック

getOrdReason

public String getOrdReason()
受注理由 (取引理由)を取得します。

戻り値:
ordReason 受注理由 (取引理由)

getComplDlv

public String getComplDlv()
一括納入区分を取得します。

戻り値:
complDlv 一括納入区分

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getQtValidF

public String getQtValidF()
見積/引合有効開始日を取得します。

戻り値:
qtValidF 見積/引合有効開始日

getQtValidT

public String getQtValidT()
見積の有効終了日を取得します。

戻り値:
qtValidT 見積の有効終了日

getCtValidF

public String getCtValidF()
有効開始日付 (販売契約/品目提案)を取得します。

戻り値:
ctValidF 有効開始日付 (販売契約/品目提案)

getCtValidT

public String getCtValidT()
有効終了日付 (販売契約/品目提案)を取得します。

戻り値:
ctValidT 有効終了日付 (販売契約/品目提案)

getCustGrp1

public String getCustGrp1()
得意先グループ 1を取得します。

戻り値:
custGrp1 得意先グループ 1

getCustGrp2

public String getCustGrp2()
得意先グループ 2を取得します。

戻り値:
custGrp2 得意先グループ 2

getCustGrp3

public String getCustGrp3()
得意先グループ 3を取得します。

戻り値:
custGrp3 得意先グループ 3

getCustGrp4

public String getCustGrp4()
得意先グループ 4を取得します。

戻り値:
custGrp4 得意先グループ 4

getCustGrp5

public String getCustGrp5()
得意先グループ 5を取得します。

戻り値:
custGrp5 得意先グループ 5

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getPurchNoS

public String getPurchNoS()
出荷先の得意先発注番号を取得します。

戻り値:
purchNoS 出荷先の得意先発注番号

getPoDatS

public String getPoDatS()
出荷先の出荷先発注日付を取得します。

戻り値:
poDatS 出荷先の出荷先発注日付

getPoMethS

public String getPoMethS()
出荷先の出荷先発注タイプを取得します。

戻り値:
poMethS 出荷先の出荷先発注タイプ

getRef1S

public String getRef1S()
出荷先文字を取得します。

戻り値:
ref1S 出荷先文字

getSdDocCat

public String getSdDocCat()
販売管理伝票カテゴリを取得します。

戻り値:
sdDocCat 販売管理伝票カテゴリ

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getWarDate

public String getWarDate()
保証期間の開始日付を取得します。

戻り値:
warDate 保証期間の開始日付

getShipCond

public String getShipCond()
出荷条件を取得します。

戻り値:
shipCond 出荷条件

getPpSearch

public String getPpSearch()
品目提案検索条件を取得します。

戻り値:
ppSearch 品目提案検索条件

getDunCount

public String getDunCount()
得意先商談回数を取得します。

戻り値:
dunCount 得意先商談回数

getDunDate

public String getDunDate()
得意先との前回の商談日を取得します。

戻り値:
dunDate 得意先との前回の商談日

getDlvschduse

public String getDlvschduse()
用途区分を取得します。

戻り値:
dlvschduse 用途区分

getPldlvstyp

public String getPldlvstyp()
MRP: 出荷計画タイプを取得します。

戻り値:
pldlvstyp MRP: 出荷計画タイプ

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getCompCdeB

public String getCompCdeB()
請求対象会社コードを取得します。

戻り値:
compCdeB 請求対象会社コード

getAlttaxCls

public String getAlttaxCls()
代替税分類を取得します。

戻り値:
alttaxCls 代替税分類

getTaxClass2

public String getTaxClass2()
得意先税分類 2を取得します。

戻り値:
taxClass2 得意先税分類 2

getTaxClass3

public String getTaxClass3()
得意先税分類 3を取得します。

戻り値:
taxClass3 得意先税分類 3

getTaxClass4

public String getTaxClass4()
得意先に対する税クラス 4を取得します。

戻り値:
taxClass4 得意先に対する税クラス 4

getTaxClass5

public String getTaxClass5()
得意先に対する税クラス 5を取得します。

戻り値:
taxClass5 得意先に対する税クラス 5

getTaxClass6

public String getTaxClass6()
得意先に対する税クラス 6を取得します。

戻り値:
taxClass6 得意先に対する税クラス 6

getTaxClass7

public String getTaxClass7()
得意先に対する税クラス 7を取得します。

戻り値:
taxClass7 得意先に対する税クラス 7

getTaxClass8

public String getTaxClass8()
得意先に対する税クラス 8を取得します。

戻り値:
taxClass8 得意先に対する税クラス 8

getTaxClass9

public String getTaxClass9()
得意先に対する税クラス 9を取得します。

戻り値:
taxClass9 得意先に対する税クラス 9

getRefDocL

public String getRefDocL()
参照伝票番号を取得します。

戻り値:
refDocL 参照伝票番号

getAssNumber

public String getAssNumber()
割当番号を取得します。

戻り値:
assNumber 割当番号

getRefdocCat

public String getRefdocCat()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refdocCat 先行販売管理伝票の伝票カテゴリ

getOrdcombIn

public String getOrdcombIn()
受注結合出荷区分を取得します。

戻り値:
ordcombIn 受注結合出荷区分

getBillSched

public String getBillSched()
請求日程 (稼働日カレンダ指定)を取得します。

戻り値:
billSched 請求日程 (稼働日カレンダ指定)

getInvoSched

public String getInvoSched()
請求書一覧日程 (稼働日カレンダ指定)を取得します。

戻り値:
invoSched 請求書一覧日程 (稼働日カレンダ指定)

getMnInvoice

public String getMnInvoice()
マニュアル請求書更新を取得します。

戻り値:
mnInvoice マニュアル請求書更新

getExrateFi

public String getExrateFi()
FI 転記の換算レート (直接相場)を取得します。

戻り値:
exrateFi FI 転記の換算レート (直接相場)

getAddValDy

public String getAddValDy()
有効日からの日数を取得します。

戻り値:
addValDy 有効日からの日数

getFixValDy

public String getFixValDy()
有効日日付を取得します。

戻り値:
fixValDy 有効日日付

getPymtMeth

public String getPymtMeth()
支払方法を取得します。

戻り値:
pymtMeth 支払方法

getAccntAsgn

public String getAccntAsgn()
得意先の勘定設定グループを取得します。

戻り値:
accntAsgn 得意先の勘定設定グループ

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getDunnKey

public String getDunnKey()
督促処理キーを取得します。

戻り値:
dunnKey 督促処理キー

getDunnBlock

public String getDunnBlock()
督促処理保留を取得します。

戻り値:
dunnBlock 督促処理保留

getPmtgarPro

public String getPmtgarPro()
支払保証決定表を取得します。

戻り値:
pmtgarPro 支払保証決定表

getDepartmNo

public String getDepartmNo()
部門コードを取得します。

戻り値:
departmNo 部門コード

getRecPoint

public String getRecPoint()
入荷ポイントを取得します。

戻り値:
recPoint 入荷ポイント

getDocNumFi

public String getDocNumFi()
ドキュメンタリクレジット処理: 内部番号を取得します。

戻り値:
docNumFi ドキュメンタリクレジット処理: 内部番号

getCstcndgrp1

public String getCstcndgrp1()
得意先条件グループ１を取得します。

戻り値:
cstcndgrp1 得意先条件グループ１

getCstcndgrp2

public String getCstcndgrp2()
得意先条件グループ２を取得します。

戻り値:
cstcndgrp2 得意先条件グループ２

getCstcndgrp3

public String getCstcndgrp3()
得意先条件グループ３を取得します。

戻り値:
cstcndgrp3 得意先条件グループ３

getCstcndgrp4

public String getCstcndgrp4()
得意先条件グループ４を取得します。

戻り値:
cstcndgrp4 得意先条件グループ４

getCstcndgrp5

public String getCstcndgrp5()
得意先条件グループ５を取得します。

戻り値:
cstcndgrp5 得意先条件グループ５

getDlvTime

public String getDlvTime()
契約出荷期間を取得します。

戻り値:
dlvTime 契約出荷期間

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getTaxdepCty

public String getTaxdepCty()
税出荷国を取得します。

戻り値:
taxdepCty 税出荷国

getTaxdstCty

public String getTaxdstCty()
税仕向国を取得します。

戻り値:
taxdstCty 税仕向国

getEutriDeal

public String getEutriDeal()
フラグ: EC 内三角取引を取得します。

戻り値:
eutriDeal フラグ: EC 内三角取引

getMastContr

public String getMastContr()
グループマスタ契約番号を取得します。

戻り値:
mastContr グループマスタ契約番号

getRefProc

public String getRefProc()
参照限定条件: 決定区分を取得します。

戻り値:
refProc 参照限定条件: 決定区分

getChkprtauth

public String getChkprtauth()
取引先権限チェックを取得します。

戻り値:
chkprtauth 取引先権限チェック

getCmlqtyDat

public String getCmlqtyDat()
累積出荷数量日付を取得します。

戻り値:
cmlqtyDat 累積出荷数量日付

getVersion

public String getVersion()
販売伝票バージョン番号を取得します。

戻り値:
version 販売伝票バージョン番号

getNotifNo

public String getNotifNo()
通知番号を取得します。

戻り値:
notifNo 通知番号

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getExchRateFiV

public String getExchRateFiV()
FI 転記の換算レート (間接相場)を取得します。

戻り値:
exchRateFiV FI 転記の換算レート (間接相場)

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getFkkConacct

public String getFkkConacct()
長さ 12 の文字項目を取得します。

戻り値:
fkkConacct 長さ 12 の文字項目

getCampaign

public String getCampaign()
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。

戻り値:
campaign 総括プロジェクト計画: 外部 R/3 システムの GUID

getDocClass

public String getDocClass()
リリースおよびトランザクション管理を備えた元システムを取得します。

戻り値:
docClass リリースおよびトランザクション管理を備えた元システム

getHCurr

public String getHCurr()
通貨コードを取得します。

戻り値:
hCurr 通貨コード

getHCurrIso

public String getHCurrIso()
ISO 通貨コードを取得します。

戻り値:
hCurrIso ISO 通貨コード

getShipType

public String getShipType()
出荷タイプを取得します。

戻り値:
shipType 出荷タイプ

getSProcInd

public String getSProcInd()
特別処理区分を取得します。

戻り値:
sProcInd 特別処理区分

getRefDocLLong

public String getRefDocLLong()
参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。

戻り値:
refDocLLong 参照伝票番号 (依存関係についてはテキスト (長) を参照)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setRefdoctype

public void setRefdoctype(String refdoctype)
参照オブジェクトの伝票タイプを設定します。

パラメータ:
refdoctype - 参照オブジェクトの伝票タイプ

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setCollectNo

public void setCollectNo(String collectNo)
一括番号を設定します。

パラメータ:
collectNo - 一括番号

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setSalesGrp

public void setSalesGrp(String salesGrp)
営業グループを設定します。

パラメータ:
salesGrp - 営業グループ

setSalesOff

public void setSalesOff(String salesOff)
営業所を設定します。

パラメータ:
salesOff - 営業所

setReqDateH

public void setReqDateH(String reqDateH)
指定納入期日を設定します。

パラメータ:
reqDateH - 指定納入期日

setDateType

public void setDateType(String dateType)
提案日付タイプを設定します。

パラメータ:
dateType - 提案日付タイプ

setPurchDate

public void setPurchDate(String purchDate)
得意先発注日付を設定します。

パラメータ:
purchDate - 得意先発注日付

setPoMethod

public void setPoMethod(String poMethod)
得意先発注タイプを設定します。

パラメータ:
poMethod - 得意先発注タイプ

setPoSupplem

public void setPoSupplem(String poSupplem)
得意先発注番号補足を設定します。

パラメータ:
poSupplem - 得意先発注番号補足

setRef1

public void setRef1(String ref1)
得意先/仕入先の内部参照コードを設定します。

パラメータ:
ref1 - 得意先/仕入先の内部参照コード

setName

public void setName(String name)
発注者名称を設定します。

パラメータ:
name - 発注者名称

setTelephone

public void setTelephone(String telephone)
電話番号を設定します。

パラメータ:
telephone - 電話番号

setPriceGrp

public void setPriceGrp(String priceGrp)
価格グループ (得意先)を設定します。

パラメータ:
priceGrp - 価格グループ (得意先)

setCustGroup

public void setCustGroup(String custGroup)
得意先グループを設定します。

パラメータ:
custGroup - 得意先グループ

setSalesDist

public void setSalesDist(String salesDist)
販売地域を設定します。

パラメータ:
salesDist - 販売地域

setPriceList

public void setPriceList(String priceList)
価格表タイプを設定します。

パラメータ:
priceList - 価格表タイプ

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ 2を設定します。

パラメータ:
incoterms2 - インコタームズ 2

setPmnttrms

public void setPmnttrms(String pmnttrms)
支払条件キーを設定します。

パラメータ:
pmnttrms - 支払条件キー

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setBillBlock

public void setBillBlock(String billBlock)
販売管理伝票の請求ブロックを設定します。

パラメータ:
billBlock - 販売管理伝票の請求ブロック

setOrdReason

public void setOrdReason(String ordReason)
受注理由 (取引理由)を設定します。

パラメータ:
ordReason - 受注理由 (取引理由)

setComplDlv

public void setComplDlv(String complDlv)
一括納入区分を設定します。

パラメータ:
complDlv - 一括納入区分

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setQtValidF

public void setQtValidF(String qtValidF)
見積/引合有効開始日を設定します。

パラメータ:
qtValidF - 見積/引合有効開始日

setQtValidT

public void setQtValidT(String qtValidT)
見積の有効終了日を設定します。

パラメータ:
qtValidT - 見積の有効終了日

setCtValidF

public void setCtValidF(String ctValidF)
有効開始日付 (販売契約/品目提案)を設定します。

パラメータ:
ctValidF - 有効開始日付 (販売契約/品目提案)

setCtValidT

public void setCtValidT(String ctValidT)
有効終了日付 (販売契約/品目提案)を設定します。

パラメータ:
ctValidT - 有効終了日付 (販売契約/品目提案)

setCustGrp1

public void setCustGrp1(String custGrp1)
得意先グループ 1を設定します。

パラメータ:
custGrp1 - 得意先グループ 1

setCustGrp2

public void setCustGrp2(String custGrp2)
得意先グループ 2を設定します。

パラメータ:
custGrp2 - 得意先グループ 2

setCustGrp3

public void setCustGrp3(String custGrp3)
得意先グループ 3を設定します。

パラメータ:
custGrp3 - 得意先グループ 3

setCustGrp4

public void setCustGrp4(String custGrp4)
得意先グループ 4を設定します。

パラメータ:
custGrp4 - 得意先グループ 4

setCustGrp5

public void setCustGrp5(String custGrp5)
得意先グループ 5を設定します。

パラメータ:
custGrp5 - 得意先グループ 5

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setPurchNoS

public void setPurchNoS(String purchNoS)
出荷先の得意先発注番号を設定します。

パラメータ:
purchNoS - 出荷先の得意先発注番号

setPoDatS

public void setPoDatS(String poDatS)
出荷先の出荷先発注日付を設定します。

パラメータ:
poDatS - 出荷先の出荷先発注日付

setPoMethS

public void setPoMethS(String poMethS)
出荷先の出荷先発注タイプを設定します。

パラメータ:
poMethS - 出荷先の出荷先発注タイプ

setRef1S

public void setRef1S(String ref1S)
出荷先文字を設定します。

パラメータ:
ref1S - 出荷先文字

setSdDocCat

public void setSdDocCat(String sdDocCat)
販売管理伝票カテゴリを設定します。

パラメータ:
sdDocCat - 販売管理伝票カテゴリ

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setWarDate

public void setWarDate(String warDate)
保証期間の開始日付を設定します。

パラメータ:
warDate - 保証期間の開始日付

setShipCond

public void setShipCond(String shipCond)
出荷条件を設定します。

パラメータ:
shipCond - 出荷条件

setPpSearch

public void setPpSearch(String ppSearch)
品目提案検索条件を設定します。

パラメータ:
ppSearch - 品目提案検索条件

setDunCount

public void setDunCount(String dunCount)
得意先商談回数を設定します。

パラメータ:
dunCount - 得意先商談回数

setDunDate

public void setDunDate(String dunDate)
得意先との前回の商談日を設定します。

パラメータ:
dunDate - 得意先との前回の商談日

setDlvschduse

public void setDlvschduse(String dlvschduse)
用途区分を設定します。

パラメータ:
dlvschduse - 用途区分

setPldlvstyp

public void setPldlvstyp(String pldlvstyp)
MRP: 出荷計画タイプを設定します。

パラメータ:
pldlvstyp - MRP: 出荷計画タイプ

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setCompCdeB

public void setCompCdeB(String compCdeB)
請求対象会社コードを設定します。

パラメータ:
compCdeB - 請求対象会社コード

setAlttaxCls

public void setAlttaxCls(String alttaxCls)
代替税分類を設定します。

パラメータ:
alttaxCls - 代替税分類

setTaxClass2

public void setTaxClass2(String taxClass2)
得意先税分類 2を設定します。

パラメータ:
taxClass2 - 得意先税分類 2

setTaxClass3

public void setTaxClass3(String taxClass3)
得意先税分類 3を設定します。

パラメータ:
taxClass3 - 得意先税分類 3

setTaxClass4

public void setTaxClass4(String taxClass4)
得意先に対する税クラス 4を設定します。

パラメータ:
taxClass4 - 得意先に対する税クラス 4

setTaxClass5

public void setTaxClass5(String taxClass5)
得意先に対する税クラス 5を設定します。

パラメータ:
taxClass5 - 得意先に対する税クラス 5

setTaxClass6

public void setTaxClass6(String taxClass6)
得意先に対する税クラス 6を設定します。

パラメータ:
taxClass6 - 得意先に対する税クラス 6

setTaxClass7

public void setTaxClass7(String taxClass7)
得意先に対する税クラス 7を設定します。

パラメータ:
taxClass7 - 得意先に対する税クラス 7

setTaxClass8

public void setTaxClass8(String taxClass8)
得意先に対する税クラス 8を設定します。

パラメータ:
taxClass8 - 得意先に対する税クラス 8

setTaxClass9

public void setTaxClass9(String taxClass9)
得意先に対する税クラス 9を設定します。

パラメータ:
taxClass9 - 得意先に対する税クラス 9

setRefDocL

public void setRefDocL(String refDocL)
参照伝票番号を設定します。

パラメータ:
refDocL - 参照伝票番号

setAssNumber

public void setAssNumber(String assNumber)
割当番号を設定します。

パラメータ:
assNumber - 割当番号

setRefdocCat

public void setRefdocCat(String refdocCat)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refdocCat - 先行販売管理伝票の伝票カテゴリ

setOrdcombIn

public void setOrdcombIn(String ordcombIn)
受注結合出荷区分を設定します。

パラメータ:
ordcombIn - 受注結合出荷区分

setBillSched

public void setBillSched(String billSched)
請求日程 (稼働日カレンダ指定)を設定します。

パラメータ:
billSched - 請求日程 (稼働日カレンダ指定)

setInvoSched

public void setInvoSched(String invoSched)
請求書一覧日程 (稼働日カレンダ指定)を設定します。

パラメータ:
invoSched - 請求書一覧日程 (稼働日カレンダ指定)

setMnInvoice

public void setMnInvoice(String mnInvoice)
マニュアル請求書更新を設定します。

パラメータ:
mnInvoice - マニュアル請求書更新

setExrateFi

public void setExrateFi(String exrateFi)
FI 転記の換算レート (直接相場)を設定します。

パラメータ:
exrateFi - FI 転記の換算レート (直接相場)

setAddValDy

public void setAddValDy(String addValDy)
有効日からの日数を設定します。

パラメータ:
addValDy - 有効日からの日数

setFixValDy

public void setFixValDy(String fixValDy)
有効日日付を設定します。

パラメータ:
fixValDy - 有効日日付

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します。

パラメータ:
pymtMeth - 支払方法

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
得意先の勘定設定グループを設定します。

パラメータ:
accntAsgn - 得意先の勘定設定グループ

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setDunnKey

public void setDunnKey(String dunnKey)
督促処理キーを設定します。

パラメータ:
dunnKey - 督促処理キー

setDunnBlock

public void setDunnBlock(String dunnBlock)
督促処理保留を設定します。

パラメータ:
dunnBlock - 督促処理保留

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
支払保証決定表を設定します。

パラメータ:
pmtgarPro - 支払保証決定表

setDepartmNo

public void setDepartmNo(String departmNo)
部門コードを設定します。

パラメータ:
departmNo - 部門コード

setRecPoint

public void setRecPoint(String recPoint)
入荷ポイントを設定します。

パラメータ:
recPoint - 入荷ポイント

setDocNumFi

public void setDocNumFi(String docNumFi)
ドキュメンタリクレジット処理: 内部番号を設定します。

パラメータ:
docNumFi - ドキュメンタリクレジット処理: 内部番号

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
得意先条件グループ１を設定します。

パラメータ:
cstcndgrp1 - 得意先条件グループ１

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
得意先条件グループ２を設定します。

パラメータ:
cstcndgrp2 - 得意先条件グループ２

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
得意先条件グループ３を設定します。

パラメータ:
cstcndgrp3 - 得意先条件グループ３

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
得意先条件グループ４を設定します。

パラメータ:
cstcndgrp4 - 得意先条件グループ４

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
得意先条件グループ５を設定します。

パラメータ:
cstcndgrp5 - 得意先条件グループ５

setDlvTime

public void setDlvTime(String dlvTime)
契約出荷期間を設定します。

パラメータ:
dlvTime - 契約出荷期間

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setTaxdepCty

public void setTaxdepCty(String taxdepCty)
税出荷国を設定します。

パラメータ:
taxdepCty - 税出荷国

setTaxdstCty

public void setTaxdstCty(String taxdstCty)
税仕向国を設定します。

パラメータ:
taxdstCty - 税仕向国

setEutriDeal

public void setEutriDeal(String eutriDeal)
フラグ: EC 内三角取引を設定します。

パラメータ:
eutriDeal - フラグ: EC 内三角取引

setMastContr

public void setMastContr(String mastContr)
グループマスタ契約番号を設定します。

パラメータ:
mastContr - グループマスタ契約番号

setRefProc

public void setRefProc(String refProc)
参照限定条件: 決定区分を設定します。

パラメータ:
refProc - 参照限定条件: 決定区分

setChkprtauth

public void setChkprtauth(String chkprtauth)
取引先権限チェックを設定します。

パラメータ:
chkprtauth - 取引先権限チェック

setCmlqtyDat

public void setCmlqtyDat(String cmlqtyDat)
累積出荷数量日付を設定します。

パラメータ:
cmlqtyDat - 累積出荷数量日付

setVersion

public void setVersion(String version)
販売伝票バージョン番号を設定します。

パラメータ:
version - 販売伝票バージョン番号

setNotifNo

public void setNotifNo(String notifNo)
通知番号を設定します。

パラメータ:
notifNo - 通知番号

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
FI 転記の換算レート (間接相場)を設定します。

パラメータ:
exchRateFiV - FI 転記の換算レート (間接相場)

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setFkkConacct

public void setFkkConacct(String fkkConacct)
長さ 12 の文字項目を設定します。

パラメータ:
fkkConacct - 長さ 12 の文字項目

setCampaign

public void setCampaign(String campaign)
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。

パラメータ:
campaign - 総括プロジェクト計画: 外部 R/3 システムの GUID

setDocClass

public void setDocClass(String docClass)
リリースおよびトランザクション管理を備えた元システムを設定します。

パラメータ:
docClass - リリースおよびトランザクション管理を備えた元システム

setHCurr

public void setHCurr(String hCurr)
通貨コードを設定します。

パラメータ:
hCurr - 通貨コード

setHCurrIso

public void setHCurrIso(String hCurrIso)
ISO 通貨コードを設定します。

パラメータ:
hCurrIso - ISO 通貨コード

setShipType

public void setShipType(String shipType)
出荷タイプを設定します。

パラメータ:
shipType - 出荷タイプ

setSProcInd

public void setSProcInd(String sProcInd)
特別処理区分を設定します。

パラメータ:
sProcInd - 特別処理区分

setRefDocLLong

public void setRefDocLLong(String refDocLLong)
参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。

パラメータ:
refDocLLong - 参照伝票番号 (依存関係についてはテキスト (長) を参照)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


HeaderInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス HeaderInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX
すべての実装インタフェース:
Serializable
public class HeaderInX
extends Object
implements Serializable

ヘッダデータチェックボックス情報クラス
機能は以下の通り

  • ヘッダデータチェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
HeaderInX()
ヘッダデータチェックボックス情報を作成します。
メソッドの概要
String | getAccntAsgn() 関連ユーザデータ項目の更新情報を取得します。
String | getAddValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getAlttaxCls() 関連ユーザデータ項目の更新情報を取得します。
String | getAssNumber() 関連ユーザデータ項目の更新情報を取得します。
String | getBillBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getBillDate() 関連ユーザデータ項目の更新情報を取得します。
String | getBillSched() 関連ユーザデータ項目の更新情報を取得します。
String | getCampaign() 関連ユーザデータ項目の更新情報を取得します。
String | getChkprtauth() 関連ユーザデータ項目の更新情報を取得します。
String | getCmlqtyDat() 関連ユーザデータ項目の更新情報を取得します。
String | getCollectNo() 関連ユーザデータ項目の更新情報を取得します。
String | getCompCdeB() 関連ユーザデータ項目の更新情報を取得します。
String | getComplDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getCtValidF() 関連ユーザデータ項目の更新情報を取得します。
String | getCtValidT() 関連ユーザデータ項目の更新情報を取得します。
String | getCurrency() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getDateType() 関連ユーザデータ項目の更新情報を取得します。
String | getDepartmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getDistrChan() 関連ユーザデータ項目の更新情報を取得します。
String | getDivision() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvschduse() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getDocClass() 関連ユーザデータ項目の更新情報を取得します。
String | getDocDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDocNumFi() 関連ユーザデータ項目の更新情報を取得します。
String | getDocType() 関連ユーザデータ項目の更新情報を取得します。
String | getDunCount() 関連ユーザデータ項目の更新情報を取得します。
String | getDunDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnKey() 関連ユーザデータ項目の更新情報を取得します。
String | getEutriDeal() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRate() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRateV() 関連ユーザデータ項目の更新情報を取得します。
String | getExchRateFiV() 関連ユーザデータ項目の更新情報を取得します。
String | getExrateFi() 関連ユーザデータ項目の更新情報を取得します。
String | getFixValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getFkkConacct() 関連ユーザデータ項目の更新情報を取得します。
String | getHCurr() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms1() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms2() 関連ユーザデータ項目の更新情報を取得します。
String | getInvoSched() 関連ユーザデータ項目の更新情報を取得します。
String | getMastContr() 関連ユーザデータ項目の更新情報を取得します。
String | getMnInvoice() 関連ユーザデータ項目の更新情報を取得します。
String | getName() 関連ユーザデータ項目の更新情報を取得します。
String | getNotifNo() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdcombIn() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdReason() 関連ユーザデータ項目の更新情報を取得します。
String | getPldlvstyp() 関連ユーザデータ項目の更新情報を取得します。
String | getPmnttrms() 関連ユーザデータ項目の更新情報を取得します。
String | getPmtgarPro() 関連ユーザデータ項目の更新情報を取得します。
String | getPoDatS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoitmNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethod() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoSupplem() 関連ユーザデータ項目の更新情報を取得します。
String | getPpSearch() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceList() 関連ユーザデータ項目の更新情報を取得します。
String | getPromotion() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoC() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPymtMeth() 関連ユーザデータ項目の更新情報を取得します。
String | getQtValidF() 関連ユーザデータ項目の更新情報を取得します。
String | getQtValidT() 関連ユーザデータ項目の更新情報を取得します。
String | getRecPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1S() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDoc() 関連ユーザデータ項目の更新情報を取得します。
String | getRefdocCat() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocL() 関連ユーザデータ項目の更新情報を取得します。
String | getRefProc() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDateH() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesDist() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesOff() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesOrg() 関連ユーザデータ項目の更新情報を取得します。
String | getSdDocCat() 関連ユーザデータ項目の更新情報を取得します。
String | getServDate() 関連ユーザデータ項目の更新情報を取得します。
String | getShipCond() 関連ユーザデータ項目の更新情報を取得します。
String | getShipType() 関連ユーザデータ項目の更新情報を取得します。
String | getSProcInd() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass2() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass3() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass4() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass5() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass6() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass7() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass8() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass9() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxdepCty() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxdstCty() 関連ユーザデータ項目の更新情報を取得します。
String | getTelephone() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getVersion() 関連ユーザデータ項目の更新情報を取得します。
String | getWarDate() 関連ユーザデータ項目の更新情報を取得します。
String | getWbsElem() 関連ユーザデータ項目の更新情報を取得します。
void | setAccntAsgn(String accntAsgn) 関連ユーザデータ項目の更新情報を設定します。
void | setAddValDy(String addValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setAlttaxCls(String alttaxCls) 関連ユーザデータ項目の更新情報を設定します。
void | setAssNumber(String assNumber) 関連ユーザデータ項目の更新情報を設定します。
void | setBillBlock(String billBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setBillDate(String billDate) 関連ユーザデータ項目の更新情報を設定します。
void | setBillSched(String billSched) 関連ユーザデータ項目の更新情報を設定します。
void | setCampaign(String campaign) 関連ユーザデータ項目の更新情報を設定します。
void | setChkprtauth(String chkprtauth) 関連ユーザデータ項目の更新情報を設定します。
void | setCmlqtyDat(String cmlqtyDat) 関連ユーザデータ項目の更新情報を設定します。
void | setCollectNo(String collectNo) 関連ユーザデータ項目の更新情報を設定します。
void | setCompCdeB(String compCdeB) 関連ユーザデータ項目の更新情報を設定します。
void | setComplDlv(String complDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp1(String cstcndgrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp2(String cstcndgrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp3(String cstcndgrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp4(String cstcndgrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp5(String cstcndgrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setCtValidF(String ctValidF) 関連ユーザデータ項目の更新情報を設定します。
void | setCtValidT(String ctValidT) 関連ユーザデータ項目の更新情報を設定します。
void | setCurrency(String currency) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGroup(String custGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp1(String custGrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp2(String custGrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp3(String custGrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp4(String custGrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGrp5(String custGrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setDateType(String dateType) 関連ユーザデータ項目の更新情報を設定します。
void | setDepartmNo(String departmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setDistrChan(String distrChan) 関連ユーザデータ項目の更新情報を設定します。
void | setDivision(String division) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvBlock(String dlvBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvschduse(String dlvschduse) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setDocClass(String docClass) 関連ユーザデータ項目の更新情報を設定します。
void | setDocDate(String docDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDocNumFi(String docNumFi) 関連ユーザデータ項目の更新情報を設定します。
void | setDocType(String docType) 関連ユーザデータ項目の更新情報を設定します。
void | setDunCount(String dunCount) 関連ユーザデータ項目の更新情報を設定します。
void | setDunDate(String dunDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnBlock(String dunnBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnKey(String dunnKey) 関連ユーザデータ項目の更新情報を設定します。
void | setEutriDeal(String eutriDeal) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRate(String exchgRate) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRateV(String exchgRateV) 関連ユーザデータ項目の更新情報を設定します。
void | setExchRateFiV(String exchRateFiV) 関連ユーザデータ項目の更新情報を設定します。
void | setExrateFi(String exrateFi) 関連ユーザデータ項目の更新情報を設定します。
void | setFixValDy(String fixValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setFkkConacct(String fkkConacct) 関連ユーザデータ項目の更新情報を設定します。
void | setHCurr(String hCurr) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms1(String incoterms1) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms2(String incoterms2) 関連ユーザデータ項目の更新情報を設定します。
void | setInvoSched(String invoSched) 関連ユーザデータ項目の更新情報を設定します。
void | setMastContr(String mastContr) 関連ユーザデータ項目の更新情報を設定します。
void | setMnInvoice(String mnInvoice) 関連ユーザデータ項目の更新情報を設定します。
void | setName(String name) 関連ユーザデータ項目の更新情報を設定します。
void | setNotifNo(String notifNo) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdcombIn(String ordcombIn) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdReason(String ordReason) 関連ユーザデータ項目の更新情報を設定します。
void | setPldlvstyp(String pldlvstyp) 関連ユーザデータ項目の更新情報を設定します。
void | setPmnttrms(String pmnttrms) 関連ユーザデータ項目の更新情報を設定します。
void | setPmtgarPro(String pmtgarPro) 関連ユーザデータ項目の更新情報を設定します。
void | setPoDatS(String poDatS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoitmNoS(String poitmNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethod(String poMethod) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethS(String poMethS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoSupplem(String poSupplem) 関連ユーザデータ項目の更新情報を設定します。
void | setPpSearch(String ppSearch) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceDate(String priceDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceGrp(String priceGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceList(String priceList) 関連ユーザデータ項目の更新情報を設定します。
void | setPromotion(String promotion) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchDate(String purchDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoC(String purchNoC) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoS(String purchNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPymtMeth(String pymtMeth) 関連ユーザデータ項目の更新情報を設定します。
void | setQtValidF(String qtValidF) 関連ユーザデータ項目の更新情報を設定します。
void | setQtValidT(String qtValidT) 関連ユーザデータ項目の更新情報を設定します。
void | setRecPoint(String recPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1(String ref1) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1S(String ref1S) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDoc(String refDoc) 関連ユーザデータ項目の更新情報を設定します。
void | setRefdocCat(String refdocCat) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocL(String refDocL) 関連ユーザデータ項目の更新情報を設定します。
void | setRefProc(String refProc) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDateH(String reqDateH) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesDist(String salesDist) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesGrp(String salesGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesOff(String salesOff) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesOrg(String salesOrg) 関連ユーザデータ項目の更新情報を設定します。
void | setSdDocCat(String sdDocCat) 関連ユーザデータ項目の更新情報を設定します。
void | setServDate(String servDate) 関連ユーザデータ項目の更新情報を設定します。
void | setShipCond(String shipCond) 関連ユーザデータ項目の更新情報を設定します。
void | setShipType(String shipType) 関連ユーザデータ項目の更新情報を設定します。
void | setSProcInd(String sProcInd) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass2(String taxClass2) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass3(String taxClass3) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass4(String taxClass4) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass5(String taxClass5) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass6(String taxClass6) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass7(String taxClass7) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass8(String taxClass8) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass9(String taxClass9) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxdepCty(String taxdepCty) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxdstCty(String taxdstCty) 関連ユーザデータ項目の更新情報を設定します。
void | setTelephone(String telephone) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setVersion(String version) 関連ユーザデータ項目の更新情報を設定します。
void | setWarDate(String warDate) 関連ユーザデータ項目の更新情報を設定します。
void | setWbsElem(String wbsElem) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

HeaderInX

public HeaderInX()
ヘッダデータチェックボックス情報を作成します。

メソッドの詳細

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getDocType

public String getDocType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docType 関連ユーザデータ項目の更新情報

getCollectNo

public String getCollectNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
collectNo 関連ユーザデータ項目の更新情報

getSalesOrg

public String getSalesOrg()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesOrg 関連ユーザデータ項目の更新情報

getDistrChan

public String getDistrChan()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
distrChan 関連ユーザデータ項目の更新情報

getDivision

public String getDivision()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
division 関連ユーザデータ項目の更新情報

getSalesGrp

public String getSalesGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesGrp 関連ユーザデータ項目の更新情報

getSalesOff

public String getSalesOff()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesOff 関連ユーザデータ項目の更新情報

getReqDateH

public String getReqDateH()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDateH 関連ユーザデータ項目の更新情報

getDateType

public String getDateType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dateType 関連ユーザデータ項目の更新情報

getPurchDate

public String getPurchDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchDate 関連ユーザデータ項目の更新情報

getPoMethod

public String getPoMethod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethod 関連ユーザデータ項目の更新情報

getPoSupplem

public String getPoSupplem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poSupplem 関連ユーザデータ項目の更新情報

getRef1

public String getRef1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1 関連ユーザデータ項目の更新情報

getName

public String getName()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
name 関連ユーザデータ項目の更新情報

getTelephone

public String getTelephone()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
telephone 関連ユーザデータ項目の更新情報

getPriceGrp

public String getPriceGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceGrp 関連ユーザデータ項目の更新情報

getCustGroup

public String getCustGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGroup 関連ユーザデータ項目の更新情報

getSalesDist

public String getSalesDist()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesDist 関連ユーザデータ項目の更新情報

getPriceList

public String getPriceList()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceList 関連ユーザデータ項目の更新情報

getIncoterms1

public String getIncoterms1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms1 関連ユーザデータ項目の更新情報

getIncoterms2

public String getIncoterms2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms2 関連ユーザデータ項目の更新情報

getPmnttrms

public String getPmnttrms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmnttrms 関連ユーザデータ項目の更新情報

getDlvBlock

public String getDlvBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvBlock 関連ユーザデータ項目の更新情報

getBillBlock

public String getBillBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billBlock 関連ユーザデータ項目の更新情報

getOrdReason

public String getOrdReason()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordReason 関連ユーザデータ項目の更新情報

getComplDlv

public String getComplDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
complDlv 関連ユーザデータ項目の更新情報

getPriceDate

public String getPriceDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceDate 関連ユーザデータ項目の更新情報

getQtValidF

public String getQtValidF()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
qtValidF 関連ユーザデータ項目の更新情報

getQtValidT

public String getQtValidT()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
qtValidT 関連ユーザデータ項目の更新情報

getCtValidF

public String getCtValidF()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ctValidF 関連ユーザデータ項目の更新情報

getCtValidT

public String getCtValidT()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ctValidT 関連ユーザデータ項目の更新情報

getCustGrp1

public String getCustGrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp1 関連ユーザデータ項目の更新情報

getCustGrp2

public String getCustGrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp2 関連ユーザデータ項目の更新情報

getCustGrp3

public String getCustGrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp3 関連ユーザデータ項目の更新情報

getCustGrp4

public String getCustGrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp4 関連ユーザデータ項目の更新情報

getCustGrp5

public String getCustGrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGrp5 関連ユーザデータ項目の更新情報

getPurchNoC

public String getPurchNoC()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoC 関連ユーザデータ項目の更新情報

getPurchNoS

public String getPurchNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoS 関連ユーザデータ項目の更新情報

getPoDatS

public String getPoDatS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poDatS 関連ユーザデータ項目の更新情報

getPoMethS

public String getPoMethS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethS 関連ユーザデータ項目の更新情報

getRef1S

public String getRef1S()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1S 関連ユーザデータ項目の更新情報

getSdDocCat

public String getSdDocCat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sdDocCat 関連ユーザデータ項目の更新情報

getDocDate

public String getDocDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docDate 関連ユーザデータ項目の更新情報

getWarDate

public String getWarDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
warDate 関連ユーザデータ項目の更新情報

getShipCond

public String getShipCond()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipCond 関連ユーザデータ項目の更新情報

getPpSearch

public String getPpSearch()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ppSearch 関連ユーザデータ項目の更新情報

getDunCount

public String getDunCount()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunCount 関連ユーザデータ項目の更新情報

getDunDate

public String getDunDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunDate 関連ユーザデータ項目の更新情報

getDlvschduse

public String getDlvschduse()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvschduse 関連ユーザデータ項目の更新情報

getPldlvstyp

public String getPldlvstyp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pldlvstyp 関連ユーザデータ項目の更新情報

getRefDoc

public String getRefDoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDoc 関連ユーザデータ項目の更新情報

getCompCdeB

public String getCompCdeB()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
compCdeB 関連ユーザデータ項目の更新情報

getAlttaxCls

public String getAlttaxCls()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
alttaxCls 関連ユーザデータ項目の更新情報

getTaxClass2

public String getTaxClass2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass2 関連ユーザデータ項目の更新情報

getTaxClass3

public String getTaxClass3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass3 関連ユーザデータ項目の更新情報

getTaxClass4

public String getTaxClass4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass4 関連ユーザデータ項目の更新情報

getTaxClass5

public String getTaxClass5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass5 関連ユーザデータ項目の更新情報

getTaxClass6

public String getTaxClass6()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass6 関連ユーザデータ項目の更新情報

getTaxClass7

public String getTaxClass7()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass7 関連ユーザデータ項目の更新情報

getTaxClass8

public String getTaxClass8()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass8 関連ユーザデータ項目の更新情報

getTaxClass9

public String getTaxClass9()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass9 関連ユーザデータ項目の更新情報

getRefDocL

public String getRefDocL()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocL 関連ユーザデータ項目の更新情報

getAssNumber

public String getAssNumber()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
assNumber 関連ユーザデータ項目の更新情報

getRefdocCat

public String getRefdocCat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refdocCat 関連ユーザデータ項目の更新情報

getOrdcombIn

public String getOrdcombIn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordcombIn 関連ユーザデータ項目の更新情報

getBillSched

public String getBillSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billSched 関連ユーザデータ項目の更新情報

getInvoSched

public String getInvoSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
invoSched 関連ユーザデータ項目の更新情報

getMnInvoice

public String getMnInvoice()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mnInvoice 関連ユーザデータ項目の更新情報

getExrateFi

public String getExrateFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exrateFi 関連ユーザデータ項目の更新情報

getAddValDy

public String getAddValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
addValDy 関連ユーザデータ項目の更新情報

getFixValDy

public String getFixValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixValDy 関連ユーザデータ項目の更新情報

getPymtMeth

public String getPymtMeth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pymtMeth 関連ユーザデータ項目の更新情報

getAccntAsgn

public String getAccntAsgn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
accntAsgn 関連ユーザデータ項目の更新情報

getExchgRate

public String getExchgRate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRate 関連ユーザデータ項目の更新情報

getBillDate

public String getBillDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billDate 関連ユーザデータ項目の更新情報

getServDate

public String getServDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
servDate 関連ユーザデータ項目の更新情報

getDunnKey

public String getDunnKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnKey 関連ユーザデータ項目の更新情報

getDunnBlock

public String getDunnBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnBlock 関連ユーザデータ項目の更新情報

getPromotion

public String getPromotion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
promotion 関連ユーザデータ項目の更新情報

getPmtgarPro

public String getPmtgarPro()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmtgarPro 関連ユーザデータ項目の更新情報

getDepartmNo

public String getDepartmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
departmNo 関連ユーザデータ項目の更新情報

getRecPoint

public String getRecPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
recPoint 関連ユーザデータ項目の更新情報

getPoitmNoS

public String getPoitmNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poitmNoS 関連ユーザデータ項目の更新情報

getDocNumFi

public String getDocNumFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docNumFi 関連ユーザデータ項目の更新情報

getCstcndgrp1

public String getCstcndgrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp1 関連ユーザデータ項目の更新情報

getCstcndgrp2

public String getCstcndgrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp2 関連ユーザデータ項目の更新情報

getCstcndgrp3

public String getCstcndgrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp3 関連ユーザデータ項目の更新情報

getCstcndgrp4

public String getCstcndgrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp4 関連ユーザデータ項目の更新情報

getCstcndgrp5

public String getCstcndgrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp5 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getCurrency

public String getCurrency()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
currency 関連ユーザデータ項目の更新情報

getTaxdepCty

public String getTaxdepCty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxdepCty 関連ユーザデータ項目の更新情報

getTaxdstCty

public String getTaxdstCty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxdstCty 関連ユーザデータ項目の更新情報

getEutriDeal

public String getEutriDeal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
eutriDeal 関連ユーザデータ項目の更新情報

getMastContr

public String getMastContr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mastContr 関連ユーザデータ項目の更新情報

getRefProc

public String getRefProc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refProc 関連ユーザデータ項目の更新情報

getChkprtauth

public String getChkprtauth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
chkprtauth 関連ユーザデータ項目の更新情報

getCmlqtyDat

public String getCmlqtyDat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cmlqtyDat 関連ユーザデータ項目の更新情報

getVersion

public String getVersion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
version 関連ユーザデータ項目の更新情報

getNotifNo

public String getNotifNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
notifNo 関連ユーザデータ項目の更新情報

getWbsElem

public String getWbsElem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
wbsElem 関連ユーザデータ項目の更新情報

getExchRateFiV

public String getExchRateFiV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchRateFiV 関連ユーザデータ項目の更新情報

getExchgRateV

public String getExchgRateV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRateV 関連ユーザデータ項目の更新情報

getFkkConacct

public String getFkkConacct()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fkkConacct 関連ユーザデータ項目の更新情報

getCampaign

public String getCampaign()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
campaign 関連ユーザデータ項目の更新情報

getDocClass

public String getDocClass()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docClass 関連ユーザデータ項目の更新情報

getHCurr

public String getHCurr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
hCurr 関連ユーザデータ項目の更新情報

getShipType

public String getShipType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipType 関連ユーザデータ項目の更新情報

getSProcInd

public String getSProcInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sProcInd 関連ユーザデータ項目の更新情報

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setDocType

public void setDocType(String docType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docType - 関連ユーザデータ項目の更新情報

setCollectNo

public void setCollectNo(String collectNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
collectNo - 関連ユーザデータ項目の更新情報

setSalesOrg

public void setSalesOrg(String salesOrg)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesOrg - 関連ユーザデータ項目の更新情報

setDistrChan

public void setDistrChan(String distrChan)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
distrChan - 関連ユーザデータ項目の更新情報

setDivision

public void setDivision(String division)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
division - 関連ユーザデータ項目の更新情報

setSalesGrp

public void setSalesGrp(String salesGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesGrp - 関連ユーザデータ項目の更新情報

setSalesOff

public void setSalesOff(String salesOff)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesOff - 関連ユーザデータ項目の更新情報

setReqDateH

public void setReqDateH(String reqDateH)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDateH - 関連ユーザデータ項目の更新情報

setDateType

public void setDateType(String dateType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dateType - 関連ユーザデータ項目の更新情報

setPurchDate

public void setPurchDate(String purchDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchDate - 関連ユーザデータ項目の更新情報

setPoMethod

public void setPoMethod(String poMethod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethod - 関連ユーザデータ項目の更新情報

setPoSupplem

public void setPoSupplem(String poSupplem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poSupplem - 関連ユーザデータ項目の更新情報

setRef1

public void setRef1(String ref1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1 - 関連ユーザデータ項目の更新情報

setName

public void setName(String name)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
name - 関連ユーザデータ項目の更新情報

setTelephone

public void setTelephone(String telephone)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
telephone - 関連ユーザデータ項目の更新情報

setPriceGrp

public void setPriceGrp(String priceGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceGrp - 関連ユーザデータ項目の更新情報

setCustGroup

public void setCustGroup(String custGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGroup - 関連ユーザデータ項目の更新情報

setSalesDist

public void setSalesDist(String salesDist)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesDist - 関連ユーザデータ項目の更新情報

setPriceList

public void setPriceList(String priceList)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceList - 関連ユーザデータ項目の更新情報

setIncoterms1

public void setIncoterms1(String incoterms1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms1 - 関連ユーザデータ項目の更新情報

setIncoterms2

public void setIncoterms2(String incoterms2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms2 - 関連ユーザデータ項目の更新情報

setPmnttrms

public void setPmnttrms(String pmnttrms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmnttrms - 関連ユーザデータ項目の更新情報

setDlvBlock

public void setDlvBlock(String dlvBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvBlock - 関連ユーザデータ項目の更新情報

setBillBlock

public void setBillBlock(String billBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billBlock - 関連ユーザデータ項目の更新情報

setOrdReason

public void setOrdReason(String ordReason)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordReason - 関連ユーザデータ項目の更新情報

setComplDlv

public void setComplDlv(String complDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
complDlv - 関連ユーザデータ項目の更新情報

setPriceDate

public void setPriceDate(String priceDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceDate - 関連ユーザデータ項目の更新情報

setQtValidF

public void setQtValidF(String qtValidF)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
qtValidF - 関連ユーザデータ項目の更新情報

setQtValidT

public void setQtValidT(String qtValidT)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
qtValidT - 関連ユーザデータ項目の更新情報

setCtValidF

public void setCtValidF(String ctValidF)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ctValidF - 関連ユーザデータ項目の更新情報

setCtValidT

public void setCtValidT(String ctValidT)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ctValidT - 関連ユーザデータ項目の更新情報

setCustGrp1

public void setCustGrp1(String custGrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp1 - 関連ユーザデータ項目の更新情報

setCustGrp2

public void setCustGrp2(String custGrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp2 - 関連ユーザデータ項目の更新情報

setCustGrp3

public void setCustGrp3(String custGrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp3 - 関連ユーザデータ項目の更新情報

setCustGrp4

public void setCustGrp4(String custGrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp4 - 関連ユーザデータ項目の更新情報

setCustGrp5

public void setCustGrp5(String custGrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGrp5 - 関連ユーザデータ項目の更新情報

setPurchNoC

public void setPurchNoC(String purchNoC)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoC - 関連ユーザデータ項目の更新情報

setPurchNoS

public void setPurchNoS(String purchNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoS - 関連ユーザデータ項目の更新情報

setPoDatS

public void setPoDatS(String poDatS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poDatS - 関連ユーザデータ項目の更新情報

setPoMethS

public void setPoMethS(String poMethS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethS - 関連ユーザデータ項目の更新情報

setRef1S

public void setRef1S(String ref1S)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1S - 関連ユーザデータ項目の更新情報

setSdDocCat

public void setSdDocCat(String sdDocCat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sdDocCat - 関連ユーザデータ項目の更新情報

setDocDate

public void setDocDate(String docDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docDate - 関連ユーザデータ項目の更新情報

setWarDate

public void setWarDate(String warDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
warDate - 関連ユーザデータ項目の更新情報

setShipCond

public void setShipCond(String shipCond)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipCond - 関連ユーザデータ項目の更新情報

setPpSearch

public void setPpSearch(String ppSearch)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ppSearch - 関連ユーザデータ項目の更新情報

setDunCount

public void setDunCount(String dunCount)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunCount - 関連ユーザデータ項目の更新情報

setDunDate

public void setDunDate(String dunDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunDate - 関連ユーザデータ項目の更新情報

setDlvschduse

public void setDlvschduse(String dlvschduse)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvschduse - 関連ユーザデータ項目の更新情報

setPldlvstyp

public void setPldlvstyp(String pldlvstyp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pldlvstyp - 関連ユーザデータ項目の更新情報

setRefDoc

public void setRefDoc(String refDoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDoc - 関連ユーザデータ項目の更新情報

setCompCdeB

public void setCompCdeB(String compCdeB)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
compCdeB - 関連ユーザデータ項目の更新情報

setAlttaxCls

public void setAlttaxCls(String alttaxCls)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
alttaxCls - 関連ユーザデータ項目の更新情報

setTaxClass2

public void setTaxClass2(String taxClass2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass2 - 関連ユーザデータ項目の更新情報

setTaxClass3

public void setTaxClass3(String taxClass3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass3 - 関連ユーザデータ項目の更新情報

setTaxClass4

public void setTaxClass4(String taxClass4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass4 - 関連ユーザデータ項目の更新情報

setTaxClass5

public void setTaxClass5(String taxClass5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass5 - 関連ユーザデータ項目の更新情報

setTaxClass6

public void setTaxClass6(String taxClass6)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass6 - 関連ユーザデータ項目の更新情報

setTaxClass7

public void setTaxClass7(String taxClass7)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass7 - 関連ユーザデータ項目の更新情報

setTaxClass8

public void setTaxClass8(String taxClass8)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass8 - 関連ユーザデータ項目の更新情報

setTaxClass9

public void setTaxClass9(String taxClass9)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass9 - 関連ユーザデータ項目の更新情報

setRefDocL

public void setRefDocL(String refDocL)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocL - 関連ユーザデータ項目の更新情報

setAssNumber

public void setAssNumber(String assNumber)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
assNumber - 関連ユーザデータ項目の更新情報

setRefdocCat

public void setRefdocCat(String refdocCat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refdocCat - 関連ユーザデータ項目の更新情報

setOrdcombIn

public void setOrdcombIn(String ordcombIn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordcombIn - 関連ユーザデータ項目の更新情報

setBillSched

public void setBillSched(String billSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billSched - 関連ユーザデータ項目の更新情報

setInvoSched

public void setInvoSched(String invoSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
invoSched - 関連ユーザデータ項目の更新情報

setMnInvoice

public void setMnInvoice(String mnInvoice)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mnInvoice - 関連ユーザデータ項目の更新情報

setExrateFi

public void setExrateFi(String exrateFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exrateFi - 関連ユーザデータ項目の更新情報

setAddValDy

public void setAddValDy(String addValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
addValDy - 関連ユーザデータ項目の更新情報

setFixValDy

public void setFixValDy(String fixValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixValDy - 関連ユーザデータ項目の更新情報

setPymtMeth

public void setPymtMeth(String pymtMeth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pymtMeth - 関連ユーザデータ項目の更新情報

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
accntAsgn - 関連ユーザデータ項目の更新情報

setExchgRate

public void setExchgRate(String exchgRate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRate - 関連ユーザデータ項目の更新情報

setBillDate

public void setBillDate(String billDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billDate - 関連ユーザデータ項目の更新情報

setServDate

public void setServDate(String servDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
servDate - 関連ユーザデータ項目の更新情報

setDunnKey

public void setDunnKey(String dunnKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnKey - 関連ユーザデータ項目の更新情報

setDunnBlock

public void setDunnBlock(String dunnBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnBlock - 関連ユーザデータ項目の更新情報

setPromotion

public void setPromotion(String promotion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
promotion - 関連ユーザデータ項目の更新情報

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmtgarPro - 関連ユーザデータ項目の更新情報

setDepartmNo

public void setDepartmNo(String departmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
departmNo - 関連ユーザデータ項目の更新情報

setRecPoint

public void setRecPoint(String recPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
recPoint - 関連ユーザデータ項目の更新情報

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poitmNoS - 関連ユーザデータ項目の更新情報

setDocNumFi

public void setDocNumFi(String docNumFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docNumFi - 関連ユーザデータ項目の更新情報

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp1 - 関連ユーザデータ項目の更新情報

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp2 - 関連ユーザデータ項目の更新情報

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp3 - 関連ユーザデータ項目の更新情報

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp4 - 関連ユーザデータ項目の更新情報

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp5 - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setCurrency

public void setCurrency(String currency)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
currency - 関連ユーザデータ項目の更新情報

setTaxdepCty

public void setTaxdepCty(String taxdepCty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxdepCty - 関連ユーザデータ項目の更新情報

setTaxdstCty

public void setTaxdstCty(String taxdstCty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxdstCty - 関連ユーザデータ項目の更新情報

setEutriDeal

public void setEutriDeal(String eutriDeal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
eutriDeal - 関連ユーザデータ項目の更新情報

setMastContr

public void setMastContr(String mastContr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mastContr - 関連ユーザデータ項目の更新情報

setRefProc

public void setRefProc(String refProc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refProc - 関連ユーザデータ項目の更新情報

setChkprtauth

public void setChkprtauth(String chkprtauth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
chkprtauth - 関連ユーザデータ項目の更新情報

setCmlqtyDat

public void setCmlqtyDat(String cmlqtyDat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cmlqtyDat - 関連ユーザデータ項目の更新情報

setVersion

public void setVersion(String version)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
version - 関連ユーザデータ項目の更新情報

setNotifNo

public void setNotifNo(String notifNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
notifNo - 関連ユーザデータ項目の更新情報

setWbsElem

public void setWbsElem(String wbsElem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
wbsElem - 関連ユーザデータ項目の更新情報

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchRateFiV - 関連ユーザデータ項目の更新情報

setExchgRateV

public void setExchgRateV(String exchgRateV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRateV - 関連ユーザデータ項目の更新情報

setFkkConacct

public void setFkkConacct(String fkkConacct)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fkkConacct - 関連ユーザデータ項目の更新情報

setCampaign

public void setCampaign(String campaign)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
campaign - 関連ユーザデータ項目の更新情報

setDocClass

public void setDocClass(String docClass)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docClass - 関連ユーザデータ項目の更新情報

setHCurr

public void setHCurr(String hCurr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
hCurr - 関連ユーザデータ項目の更新情報

setShipType

public void setShipType(String shipType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipType - 関連ユーザデータ項目の更新情報

setSProcInd

public void setSProcInd(String sProcInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sProcInd - 関連ユーザデータ項目の更新情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemsIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ItemsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn
すべての実装インタフェース:
Serializable
public class ItemsIn
extends Object
implements Serializable

明細データ情報クラス
機能は以下の通り

  • 明細データ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ItemsIn()
明細データ情報を作成します。
ItemsIn(int index)
明細データ情報を作成します。
メソッドの概要
String | getAccntAsgn() 得意先の勘定設定グループを取得します。
String | getAddValDy() 有効日からの日数を取得します。
String | getAlternBom() 代替 BOMを取得します。
String | getAltToItm() 代替明細を取得します。
String | getAssortMod() 品揃モジュールを取得します。
String | getBatch() ロット番号を取得します。
String | getBegdemPer() 見越期間の提案開始日付を取得します。
String | getBilForm() 請求書式を取得します。
String | getBillBlock() ブロックを取得します。
String | getBillDate() 請求索引および印刷に対する請求日を取得します。
String | getBillRel() 請求関連 (CRM)を取得します。
String | getBillSched() 請求日程 (稼働日カレンダ指定)を取得します。
String | getBomexplNo() BOM 展開番号を取得します。
String | getBusTranst() 貿易管理の取引タイプを取得します。
String | getCampaign() 総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
String | getCfopCode() CFOP code and extension (old 5 char version)を取得します。
String | getCfopLong() CFOP code and extensionを取得します。
String | getCompQuant() 構成品目数量を取得します。
String | getConfigId() 外部選定 ID (仮)を取得します。
String | getCreatedBy() オブジェクト登録者名を取得します。
String | getCstcndgrp1() 得意先条件グループ１を取得します。
String | getCstcndgrp2() 得意先条件グループ２を取得します。
String | getCstcndgrp3() 得意先条件グループ３を取得します。
String | getCstcndgrp4() 得意先条件グループ４を取得します。
String | getCstcndgrp5() 得意先条件グループ５を取得します。
String | getCstgSheet() 原価計算表を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getCustGroup() 得意先グループを取得します。
String | getCustMat22() 得意先品目コード (無効)を取得します。
String | getCustMat35() 得意先品目を取得します。
String | getDepartmNo() 部門コードを取得します。
String | getDeprecPer() ドキュメンタリクレジット処理に関する償却率 (%)を取得します。
String | getDivision() 製品部門を取得します。
String | getDliProfil() 動的明細プロセッサプロファイルを取得します。
String | getDlvGroup() 出荷グループ (明細一括出荷)を取得します。
String | getDlvPrio() 出荷優先順位を取得します。
String | getDlvschduse() 用途区分を取得します。
String | getDlvTime() 契約出荷期間を取得します。
String | getDocNumFi() ドキュメンタリクレジット処理: 内部番号を取得します。
String | getDunnBlock() 督促処理保留を取得します。
String | getDunnKey() 督促処理キーを取得します。
String | getEanUpc() 国際商品コード (EAN/UPC)を取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getExchRateFiV() FI 転記の換算レート (間接相場)を取得します。
String | getExRateFi() FI 転記の換算レート (直接相場)を取得します。
String | getFixdatQty() 納期と出荷数量の固定を取得します。
String | getFixedQuan() 数量固定区分を取得します。
String | getFixValDy() 有効日日付を取得します。
String | getFkkConacct() 長さ 12 の文字項目を取得します。
String | getFuncArea() 機能領域を取得します。
String | getFuncAreaLong() 機能領域を取得します。
String | getGrossWght() 明細の総重量を取得します。
String | getHgLvItem() 上位レベル明細を取得します。
String | getIncoterms1() インコタームズ (1)を取得します。
String | getIncoterms2() インコタームズ 2を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 選定におけるインスタンス番号を取得します。
String | getInvoSched() 請求書一覧日程 (稼働日カレンダ指定)を取得します。
String | getItemCateg() 明細カテゴリ (販売伝票)を取得します。
String | getItemguidAtp() ATP: 暗号 - DELNR および DELPSを取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getItmTypeUsage() 明細用途を取得します。
String | getLogSystemOwn() 論理システムを取得します。
String | getMatEntrd() 入力品目を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatExt() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMatfrgtgrp() 品目運賃グループを取得します。
String | getMatGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMatlGroup() 品目グループを取得します。
String | getMatPrGrp() 品目価格設定グループを取得します。
String | getMatVers() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getMaxdevamnt() 数量に関する許容偏差 (絶対値)を取得します。
String | getMaxdevDay() シフト所要日数を取得します。
String | getMaxdevper() 数量に関する許容偏差 (%)を取得します。
String | getMaxPlDlv() 明細ごとの分割納入可能な最大回数を取得します。
String | getMnInvoice() マニュアル請求書更新を取得します。
String | getNetWeight() 明細の正味重量を取得します。
String | getNoGrPost() 得意先が入庫を転記していませんを取得します。
String | getOrdcompIn() 受注結合出荷区分を取得します。
String | getOrderid() 指図番号を取得します。
String | getOrderProb() 明細の受注可能性を取得します。
String | getOverdlvtol() 過剰納入許容範囲を取得します。
String | getOverhdKey() 間接費キーを取得します。
String | getPartDlv() 明細レベルの分納納入を取得します。
String | getPlant() プラントを取得します。
String | getPldlvshdin() 出荷計画に関する指示を取得します。
String | getPMatExt() 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
String | getPMatGuid() 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
String | getPMatVers() 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getPmtgarPro() 支払保証決定表を取得します。
String | getPoDatS() 出荷先の出荷先発注日付を取得します。
String | getPoItmNo() 元となる購買発注の明細番号を取得します。
String | getPoitmNoS() 元となる購買発注の明細番号を取得します。
String | getPoMethod() 得意先発注タイプを取得します。
String | getPoMethS() 出荷先の出荷先発注タイプを取得します。
String | getPrcGroup1() 品目グループ 1を取得します。
String | getPrcGroup2() 品目グループ 2を取得します。
String | getPrcGroup3() 品目グループ 3を取得します。
String | getPrcGroup4() 品目グループ 4を取得します。
String | getPrcGroup5() 品目グループ 5を取得します。
String | getPriceDate() 価格設定/外貨換算の実行日付を取得します。
String | getPriceGrp() 価格グループ (得意先)を取得します。
String | getPriceList() 価格表タイプを取得します。
String | getProdcat() 製品カタログ番号を取得します。
String | getProdHiera() 品目階層を取得します。
String | getProfitCtr() 利益センタを取得します。
String | getPromotion() プロモーションを取得します。
String | getPrRefMat() 価格設定参照品目を取得します。
String | getPurchDate() 得意先発注日付を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getPurchNoS() 出荷先の得意先発注番号を取得します。
String | getPymtMeth() 支払方法を取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getRecPoint() 入荷ポイントを取得します。
String | getRef1() 得意先/仕入先の内部参照コードを取得します。
String | getRef1S() 出荷先文字を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocCa() 先行販売管理伝票の伝票カテゴリを取得します。
String | getRefDocIt() 参照明細番号を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getReqmtsTyp() 所要量タイプを取得します。
String | getResanalkey() 結果分析キーを取得します。
String | getRevType() 収益承認カテゴリを取得します。
String | getRnddlvQty() 丸め数量: 出荷を取得します。
String | getRoute() 輸送経路を取得します。
String | getSalesDist() 販売地域を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSalqtyden() 販売数量単位を SKU に換算するための分母 (除数)を取得します。
String | getSalqtynum() 販売数量単位から基本数量単位への変換係数の分子を取得します。
String | getSdTaxcode() を取得します。
String | getSelection() 選択 ID (永続)を取得します。
String | getSeqNo() KANBAN/連続番号を取得します。
String | getServDate() サービス提供日を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getShipType() 出荷タイプを取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSProcInd() 特別処理区分を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getSUnitIso() 単位の ISO コードを取得します。
String | getTargetQty() 目標数量（販売単位）を取得します。
String | getTargetQu() 目標数量 (数量単位)を取得します。
String | getTargetVal() BAPI の通貨額 (小数点以下９桁)を取得します。
String | getTaxClass1() 品目の税分類を取得します。
String | getTaxClass2() 品目の税分類を取得します。
String | getTaxClass3() 品目の税分類を取得します。
String | getTaxClass4() 品目の税分類を取得します。
String | getTaxClass5() 品目の税分類を取得します。
String | getTaxClass6() 品目の税分類を取得します。
String | getTaxClass7() 品目の税分類を取得します。
String | getTaxClass8() 品目の税分類を取得します。
String | getTaxClass9() 品目の税分類を取得します。
String | getTaxlawicms() 税法: ICMSを取得します。
String | getTaxlawipi() 税法: IPIを取得します。
String | getTrgqtyDen() 販売単位から基本単位への換算係数を取得します。
String | getTrgQtyNo() 販売単位から基本単位への換算係数を取得します。
String | getTUnitIso() 目標数量単位 (ISO コード)を取得します。
String | getUnddlvTol() 不足納入許容範囲リミットを取得します。
String | getUnlmtDlv() 区分: 無制限過剰納入可能を取得します。
String | getUnofWtiso() ISO コードでの重量単位を取得します。
String | getUntofWght() 重量単位を取得します。
String | getUsageInd() 未使用 - 予約長 3を取得します。
String | getValConI() 金額契約明細を取得します。
String | getValContr() 金額契約番号を取得します。
String | getValType() 評価タイプを取得します。
String | getVolume() 明細の総数量を取得します。
String | getVolunit() 容積単位を取得します。
String | getVolunitiso() ISO コードでの容積単位を取得します。
String | getVwUepos() 上位レベル明細用途 IDを取得します。
String | getWbsElem() WBS 要素を取得します。
void | setAccntAsgn(String accntAsgn) 得意先の勘定設定グループを設定します。
void | setAddValDy(String addValDy) 有効日からの日数を設定します。
void | setAlternBom(String alternBom) 代替 BOMを設定します。
void | setAltToItm(String altToItm) 代替明細を設定します。
void | setAssortMod(String assortMod) 品揃モジュールを設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setBegdemPer(String begdemPer) 見越期間の提案開始日付を設定します。
void | setBilForm(String bilForm) 請求書式を設定します。
void | setBillBlock(String billBlock) ブロックを設定します。
void | setBillDate(String billDate) 請求索引および印刷に対する請求日を設定します。
void | setBillRel(String billRel) 請求関連 (CRM)を設定します。
void | setBillSched(String billSched) 請求日程 (稼働日カレンダ指定)を設定します。
void | setBomexplNo(String bomexplNo) BOM 展開番号を設定します。
void | setBusTranst(String busTranst) 貿易管理の取引タイプを設定します。
void | setCampaign(String campaign) 総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
void | setCfopCode(String cfopCode) CFOP code and extension (old 5 char version)を設定します。
void | setCfopLong(String cfopLong) CFOP code and extensionを設定します。
void | setCompQuant(String compQuant) 構成品目数量を設定します。
void | setConfigId(String configId) 外部選定 ID (仮)を設定します。
void | setCreatedBy(String createdBy) オブジェクト登録者名を設定します。
void | setCstcndgrp1(String cstcndgrp1) 得意先条件グループ１を設定します。
void | setCstcndgrp2(String cstcndgrp2) 得意先条件グループ２を設定します。
void | setCstcndgrp3(String cstcndgrp3) 得意先条件グループ３を設定します。
void | setCstcndgrp4(String cstcndgrp4) 得意先条件グループ４を設定します。
void | setCstcndgrp5(String cstcndgrp5) 得意先条件グループ５を設定します。
void | setCstgSheet(String cstgSheet) 原価計算表を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setCustGroup(String custGroup) 得意先グループを設定します。
void | setCustMat22(String custMat22) 得意先品目コード (無効)を設定します。
void | setCustMat35(String custMat35) 得意先品目を設定します。
void | setDepartmNo(String departmNo) 部門コードを設定します。
void | setDeprecPer(String deprecPer) ドキュメンタリクレジット処理に関する償却率 (%)を設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDliProfil(String dliProfil) 動的明細プロセッサプロファイルを設定します。
void | setDlvGroup(String dlvGroup) 出荷グループ (明細一括出荷)を設定します。
void | setDlvPrio(String dlvPrio) 出荷優先順位を設定します。
void | setDlvschduse(String dlvschduse) 用途区分を設定します。
void | setDlvTime(String dlvTime) 契約出荷期間を設定します。
void | setDocNumFi(String docNumFi) ドキュメンタリクレジット処理: 内部番号を設定します。
void | setDunnBlock(String dunnBlock) 督促処理保留を設定します。
void | setDunnKey(String dunnKey) 督促処理キーを設定します。
void | setEanUpc(String eanUpc) 国際商品コード (EAN/UPC)を設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setExchRateFiV(String exchRateFiV) FI 転記の換算レート (間接相場)を設定します。
void | setExRateFi(String exRateFi) FI 転記の換算レート (直接相場)を設定します。
void | setFixdatQty(String fixdatQty) 納期と出荷数量の固定を設定します。
void | setFixedQuan(String fixedQuan) 数量固定区分を設定します。
void | setFixValDy(String fixValDy) 有効日日付を設定します。
void | setFkkConacct(String fkkConacct) 長さ 12 の文字項目を設定します。
void | setFuncArea(String funcArea) 機能領域を設定します。
void | setFuncAreaLong(String funcAreaLong) 機能領域を設定します。
void | setGrossWght(String grossWght) 明細の総重量を設定します。
void | setHgLvItem(String hgLvItem) 上位レベル明細を設定します。
void | setIncoterms1(String incoterms1) インコタームズ (1)を設定します。
void | setIncoterms2(String incoterms2) インコタームズ 2を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 選定におけるインスタンス番号を設定します。
void | setInvoSched(String invoSched) 請求書一覧日程 (稼働日カレンダ指定)を設定します。
void | setItemCateg(String itemCateg) 明細カテゴリ (販売伝票)を設定します。
void | setItemguidAtp(String itemguidAtp) ATP: 暗号 - DELNR および DELPSを設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setItmTypeUsage(String itmTypeUsage) 明細用途を設定します。
void | setLogSystemOwn(String logSystemOwn) 論理システムを設定します。
void | setMatEntrd(String matEntrd) 入力品目を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatExt(String matExt) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 品目運賃グループを設定します。
void | setMatGuid(String matGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMatlGroup(String matlGroup) 品目グループを設定します。
void | setMatPrGrp(String matPrGrp) 品目価格設定グループを設定します。
void | setMatVers(String matVers) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setMaxdevamnt(String maxdevamnt) 数量に関する許容偏差 (絶対値)を設定します。
void | setMaxdevDay(String maxdevDay) シフト所要日数を設定します。
void | setMaxdevper(String maxdevper) 数量に関する許容偏差 (%)を設定します。
void | setMaxPlDlv(String maxPlDlv) 明細ごとの分割納入可能な最大回数を設定します。
void | setMnInvoice(String mnInvoice) マニュアル請求書更新を設定します。
void | setNetWeight(String netWeight) 明細の正味重量を設定します。
void | setNoGrPost(String noGrPost) 得意先が入庫を転記していませんを設定します。
void | setOrdcompIn(String ordcompIn) 受注結合出荷区分を設定します。
void | setOrderid(String orderid) 指図番号を設定します。
void | setOrderProb(String orderProb) 明細の受注可能性を設定します。
void | setOverdlvtol(String overdlvtol) 過剰納入許容範囲を設定します。
void | setOverhdKey(String overhdKey) 間接費キーを設定します。
void | setPartDlv(String partDlv) 明細レベルの分納納入を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPldlvshdin(String pldlvshdin) 出荷計画に関する指示を設定します。
void | setPMatExt(String pMatExt) 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
void | setPMatGuid(String pMatGuid) 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
void | setPMatVers(String pMatVers) 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
void | setPmnttrms(String pmnttrms) 支払条件キーを設定します。
void | setPmtgarPro(String pmtgarPro) 支払保証決定表を設定します。
void | setPoDatS(String poDatS) 出荷先の出荷先発注日付を設定します。
void | setPoItmNo(String poItmNo) 元となる購買発注の明細番号を設定します。
void | setPoitmNoS(String poitmNoS) 元となる購買発注の明細番号を設定します。
void | setPoMethod(String poMethod) 得意先発注タイプを設定します。
void | setPoMethS(String poMethS) 出荷先の出荷先発注タイプを設定します。
void | setPrcGroup1(String prcGroup1) 品目グループ 1を設定します。
void | setPrcGroup2(String prcGroup2) 品目グループ 2を設定します。
void | setPrcGroup3(String prcGroup3) 品目グループ 3を設定します。
void | setPrcGroup4(String prcGroup4) 品目グループ 4を設定します。
void | setPrcGroup5(String prcGroup5) 品目グループ 5を設定します。
void | setPriceDate(String priceDate) 価格設定/外貨換算の実行日付を設定します。
void | setPriceGrp(String priceGrp) 価格グループ (得意先)を設定します。
void | setPriceList(String priceList) 価格表タイプを設定します。
void | setProdcat(String prodcat) 製品カタログ番号を設定します。
void | setProdHiera(String prodHiera) 品目階層を設定します。
void | setProfitCtr(String profitCtr) 利益センタを設定します。
void | setPromotion(String promotion) プロモーションを設定します。
void | setPrRefMat(String prRefMat) 価格設定参照品目を設定します。
void | setPurchDate(String purchDate) 得意先発注日付を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setPurchNoS(String purchNoS) 出荷先の得意先発注番号を設定します。
void | setPymtMeth(String pymtMeth) 支払方法を設定します。
void | setReasonRej(String reasonRej) 見積および受注の拒否理由を設定します。
void | setRecPoint(String recPoint) 入荷ポイントを設定します。
void | setRef1(String ref1) 得意先/仕入先の内部参照コードを設定します。
void | setRef1S(String ref1S) 出荷先文字を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocCa(String refDocCa) 先行販売管理伝票の伝票カテゴリを設定します。
void | setRefDocIt(String refDocIt) 参照明細番号を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setReqmtsTyp(String reqmtsTyp) 所要量タイプを設定します。
void | setResanalkey(String resanalkey) 結果分析キーを設定します。
void | setRevType(String revType) 収益承認カテゴリを設定します。
void | setRnddlvQty(String rnddlvQty) 丸め数量: 出荷を設定します。
void | setRoute(String route) 輸送経路を設定します。
void | setSalesDist(String salesDist) 販売地域を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSalqtyden(String salqtyden) 販売数量単位を SKU に換算するための分母 (除数)を設定します。
void | setSalqtynum(String salqtynum) 販売数量単位から基本数量単位への変換係数の分子を設定します。
void | setSdTaxcode(String sdTaxcode) 0を設定します。
void | setSelection(String selection) 選択 ID (永続)を設定します。
void | setSeqNo(String seqNo) KANBAN/連続番号を設定します。
void | setServDate(String servDate) サービス提供日を設定します。
void | setShipPoint(String shipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setShipType(String shipType) 出荷タイプを設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSProcInd(String sProcInd) 特別処理区分を設定します。
void | setStoreLoc(String storeLoc) 保管場所を設定します。
void | setSUnitIso(String sUnitIso) 単位の ISO コードを設定します。
void | setTargetQty(String targetQty) 目標数量（販売単位）を設定します。
void | setTargetQu(String targetQu) 目標数量 (数量単位)を設定します。
void | setTargetVal(String targetVal) BAPI の通貨額 (小数点以下９桁)を設定します。
void | setTaxClass1(String taxClass1) 品目の税分類を設定します。
void | setTaxClass2(String taxClass2) 品目の税分類を設定します。
void | setTaxClass3(String taxClass3) 品目の税分類を設定します。
void | setTaxClass4(String taxClass4) 品目の税分類を設定します。
void | setTaxClass5(String taxClass5) 品目の税分類を設定します。
void | setTaxClass6(String taxClass6) 品目の税分類を設定します。
void | setTaxClass7(String taxClass7) 品目の税分類を設定します。
void | setTaxClass8(String taxClass8) 品目の税分類を設定します。
void | setTaxClass9(String taxClass9) 品目の税分類を設定します。
void | setTaxlawicms(String taxlawicms) 税法: ICMSを設定します。
void | setTaxlawipi(String taxlawipi) 税法: IPIを設定します。
void | setTrgqtyDen(String trgqtyDen) 販売単位から基本単位への換算係数を設定します。
void | setTrgQtyNo(String trgQtyNo) 販売単位から基本単位への換算係数を設定します。
void | setTUnitIso(String tUnitIso) 目標数量単位 (ISO コード)を設定します。
void | setUnddlvTol(String unddlvTol) 不足納入許容範囲リミットを設定します。
void | setUnlmtDlv(String unlmtDlv) 区分: 無制限過剰納入可能を設定します。
void | setUnofWtiso(String unofWtiso) ISO コードでの重量単位を設定します。
void | setUntofWght(String untofWght) 重量単位を設定します。
void | setUsageInd(String usageInd) 未使用 - 予約長 3を設定します。
void | setValConI(String valConI) 金額契約明細を設定します。
void | setValContr(String valContr) 金額契約番号を設定します。
void | setValType(String valType) 評価タイプを設定します。
void | setVolume(String volume) 明細の総数量を設定します。
void | setVolunit(String volunit) 容積単位を設定します。
void | setVolunitiso(String volunitiso) ISO コードでの容積単位を設定します。
void | setVwUepos(String vwUepos) 上位レベル明細用途 IDを設定します。
void | setWbsElem(String wbsElem) WBS 要素を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ItemsIn

public ItemsIn()
明細データ情報を作成します。

ItemsIn

public ItemsIn(int index)
明細データ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getHgLvItem

public String getHgLvItem()
上位レベル明細を取得します。

戻り値:
hgLvItem 上位レベル明細

getPoItmNo

public String getPoItmNo()
元となる購買発注の明細番号を取得します。

戻り値:
poItmNo 元となる購買発注の明細番号

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getAltToItm

public String getAltToItm()
代替明細を取得します。

戻り値:
altToItm 代替明細

getCustMat22

public String getCustMat22()
得意先品目コード (無効)を取得します。

戻り値:
custMat22 得意先品目コード (無効)

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getDlvGroup

public String getDlvGroup()
出荷グループ (明細一括出荷)を取得します。

戻り値:
dlvGroup 出荷グループ (明細一括出荷)

getPartDlv

public String getPartDlv()
明細レベルの分納納入を取得します。

戻り値:
partDlv 明細レベルの分納納入

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
reasonRej 見積および受注の拒否理由

getBillBlock

public String getBillBlock()
ブロックを取得します。

戻り値:
billBlock ブロック

getBillDate

public String getBillDate()
請求索引および印刷に対する請求日を取得します。

戻り値:
billDate 請求索引および印刷に対する請求日

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
storeLoc 保管場所

getTargetQty

public String getTargetQty()
目標数量（販売単位）を取得します。

戻り値:
targetQty 目標数量（販売単位）

getTargetQu

public String getTargetQu()
目標数量 (数量単位)を取得します。

戻り値:
targetQu 目標数量 (数量単位)

getTUnitIso

public String getTUnitIso()
目標数量単位 (ISO コード)を取得します。

戻り値:
tUnitIso 目標数量単位 (ISO コード)

getItemCateg

public String getItemCateg()
明細カテゴリ (販売伝票)を取得します。

戻り値:
itemCateg 明細カテゴリ (販売伝票)

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getPrcGroup1

public String getPrcGroup1()
品目グループ 1を取得します。

戻り値:
prcGroup1 品目グループ 1

getPrcGroup2

public String getPrcGroup2()
品目グループ 2を取得します。

戻り値:
prcGroup2 品目グループ 2

getPrcGroup3

public String getPrcGroup3()
品目グループ 3を取得します。

戻り値:
prcGroup3 品目グループ 3

getPrcGroup4

public String getPrcGroup4()
品目グループ 4を取得します。

戻り値:
prcGroup4 品目グループ 4

getPrcGroup5

public String getPrcGroup5()
品目グループ 5を取得します。

戻り値:
prcGroup5 品目グループ 5

getProdHiera

public String getProdHiera()
品目階層を取得します。

戻り値:
prodHiera 品目階層

getMatlGroup

public String getMatlGroup()
品目グループを取得します。

戻り値:
matlGroup 品目グループ

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getPurchDate

public String getPurchDate()
得意先発注日付を取得します。

戻り値:
purchDate 得意先発注日付

getPoMethod

public String getPoMethod()
得意先発注タイプを取得します。

戻り値:
poMethod 得意先発注タイプ

getRef1

public String getRef1()
得意先/仕入先の内部参照コードを取得します。

戻り値:
ref1 得意先/仕入先の内部参照コード

getPurchNoS

public String getPurchNoS()
出荷先の得意先発注番号を取得します。

戻り値:
purchNoS 出荷先の得意先発注番号

getPoDatS

public String getPoDatS()
出荷先の出荷先発注日付を取得します。

戻り値:
poDatS 出荷先の出荷先発注日付

getPoMethS

public String getPoMethS()
出荷先の出荷先発注タイプを取得します。

戻り値:
poMethS 出荷先の出荷先発注タイプ

getRef1S

public String getRef1S()
出荷先文字を取得します。

戻り値:
ref1S 出荷先文字

getPoitmNoS

public String getPoitmNoS()
元となる購買発注の明細番号を取得します。

戻り値:
poitmNoS 元となる購買発注の明細番号

getPriceGrp

public String getPriceGrp()
価格グループ (得意先)を取得します。

戻り値:
priceGrp 価格グループ (得意先)

getCustGroup

public String getCustGroup()
得意先グループを取得します。

戻り値:
custGroup 得意先グループ

getSalesDist

public String getSalesDist()
販売地域を取得します。

戻り値:
salesDist 販売地域

getPriceList

public String getPriceList()
価格表タイプを取得します。

戻り値:
priceList 価格表タイプ

getIncoterms1

public String getIncoterms1()
インコタームズ (1)を取得します。

戻り値:
incoterms1 インコタームズ (1)

getIncoterms2

public String getIncoterms2()
インコタームズ 2を取得します。

戻り値:
incoterms2 インコタームズ 2

getOrdcompIn

public String getOrdcompIn()
受注結合出荷区分を取得します。

戻り値:
ordcompIn 受注結合出荷区分

getBillSched

public String getBillSched()
請求日程 (稼働日カレンダ指定)を取得します。

戻り値:
billSched 請求日程 (稼働日カレンダ指定)

getInvoSched

public String getInvoSched()
請求書一覧日程 (稼働日カレンダ指定)を取得します。

戻り値:
invoSched 請求書一覧日程 (稼働日カレンダ指定)

getMnInvoice

public String getMnInvoice()
マニュアル請求書更新を取得します。

戻り値:
mnInvoice マニュアル請求書更新

getExRateFi

public String getExRateFi()
FI 転記の換算レート (直接相場)を取得します。

戻り値:
exRateFi FI 転記の換算レート (直接相場)

getAddValDy

public String getAddValDy()
有効日からの日数を取得します。

戻り値:
addValDy 有効日からの日数

getFixValDy

public String getFixValDy()
有効日日付を取得します。

戻り値:
fixValDy 有効日日付

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
pmnttrms 支払条件キー

getPymtMeth

public String getPymtMeth()
支払方法を取得します。

戻り値:
pymtMeth 支払方法

getAccntAsgn

public String getAccntAsgn()
得意先の勘定設定グループを取得します。

戻り値:
accntAsgn 得意先の勘定設定グループ

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getPriceDate

public String getPriceDate()
価格設定/外貨換算の実行日付を取得します。

戻り値:
priceDate 価格設定/外貨換算の実行日付

getServDate

public String getServDate()
サービス提供日を取得します。

戻り値:
servDate サービス提供日

getDunnKey

public String getDunnKey()
督促処理キーを取得します。

戻り値:
dunnKey 督促処理キー

getDunnBlock

public String getDunnBlock()
督促処理保留を取得します。

戻り値:
dunnBlock 督促処理保留

getPromotion

public String getPromotion()
プロモーションを取得します。

戻り値:
promotion プロモーション

getPmtgarPro

public String getPmtgarPro()
支払保証決定表を取得します。

戻り値:
pmtgarPro 支払保証決定表

getDocNumFi

public String getDocNumFi()
ドキュメンタリクレジット処理: 内部番号を取得します。

戻り値:
docNumFi ドキュメンタリクレジット処理: 内部番号

getDepartmNo

public String getDepartmNo()
部門コードを取得します。

戻り値:
departmNo 部門コード

getRecPoint

public String getRecPoint()
入荷ポイントを取得します。

戻り値:
recPoint 入荷ポイント

getCstcndgrp1

public String getCstcndgrp1()
得意先条件グループ１を取得します。

戻り値:
cstcndgrp1 得意先条件グループ１

getCstcndgrp2

public String getCstcndgrp2()
得意先条件グループ２を取得します。

戻り値:
cstcndgrp2 得意先条件グループ２

getCstcndgrp3

public String getCstcndgrp3()
得意先条件グループ３を取得します。

戻り値:
cstcndgrp3 得意先条件グループ３

getCstcndgrp4

public String getCstcndgrp4()
得意先条件グループ４を取得します。

戻り値:
cstcndgrp4 得意先条件グループ４

getCstcndgrp5

public String getCstcndgrp5()
得意先条件グループ５を取得します。

戻り値:
cstcndgrp5 得意先条件グループ５

getDlvTime

public String getDlvTime()
契約出荷期間を取得します。

戻り値:
dlvTime 契約出荷期間

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getSUnitIso

public String getSUnitIso()
単位の ISO コードを取得します。

戻り値:
sUnitIso 単位の ISO コード

getTrgQtyNo

public String getTrgQtyNo()
販売単位から基本単位への換算係数を取得します。

戻り値:
trgQtyNo 販売単位から基本単位への換算係数

getTrgqtyDen

public String getTrgqtyDen()
販売単位から基本単位への換算係数を取得します。

戻り値:
trgqtyDen 販売単位から基本単位への換算係数

getRnddlvQty

public String getRnddlvQty()
丸め数量: 出荷を取得します。

戻り値:
rnddlvQty 丸め数量: 出荷

getMaxdevamnt

public String getMaxdevamnt()
数量に関する許容偏差 (絶対値)を取得します。

戻り値:
maxdevamnt 数量に関する許容偏差 (絶対値)

getMaxdevper

public String getMaxdevper()
数量に関する許容偏差 (%)を取得します。

戻り値:
maxdevper 数量に関する許容偏差 (%)

getMaxdevDay

public String getMaxdevDay()
シフト所要日数を取得します。

戻り値:
maxdevDay シフト所要日数

getUsageInd

public String getUsageInd()
未使用 - 予約長 3を取得します。

戻り値:
usageInd 未使用 - 予約長 3

getFixedQuan

public String getFixedQuan()
数量固定区分を取得します。

戻り値:
fixedQuan 数量固定区分

getUnlmtDlv

public String getUnlmtDlv()
区分: 無制限過剰納入可能を取得します。

戻り値:
unlmtDlv 区分: 無制限過剰納入可能

getOverdlvtol

public String getOverdlvtol()
過剰納入許容範囲を取得します。

戻り値:
overdlvtol 過剰納入許容範囲

getUnddlvTol

public String getUnddlvTol()
不足納入許容範囲リミットを取得します。

戻り値:
unddlvTol 不足納入許容範囲リミット

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getSalqtynum

public String getSalqtynum()
販売数量単位から基本数量単位への変換係数の分子を取得します。

戻り値:
salqtynum 販売数量単位から基本数量単位への変換係数の分子

getSalqtyden

public String getSalqtyden()
販売数量単位を SKU に換算するための分母 (除数)を取得します。

戻り値:
salqtyden 販売数量単位を SKU に換算するための分母 (除数)

getGrossWght

public String getGrossWght()
明細の総重量を取得します。

戻り値:
grossWght 明細の総重量

getNetWeight

public String getNetWeight()
明細の正味重量を取得します。

戻り値:
netWeight 明細の正味重量

getUntofWght

public String getUntofWght()
重量単位を取得します。

戻り値:
untofWght 重量単位

getUnofWtiso

public String getUnofWtiso()
ISO コードでの重量単位を取得します。

戻り値:
unofWtiso ISO コードでの重量単位

getVolume

public String getVolume()
明細の総数量を取得します。

戻り値:
volume 明細の総数量

getVolunit

public String getVolunit()
容積単位を取得します。

戻り値:
volunit 容積単位

getVolunitiso

public String getVolunitiso()
ISO コードでの容積単位を取得します。

戻り値:
volunitiso ISO コードでの容積単位

getDlvPrio

public String getDlvPrio()
出荷優先順位を取得します。

戻り値:
dlvPrio 出荷優先順位

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
shipPoint 出荷ポイント/入荷ポイント

getRoute

public String getRoute()
輸送経路を取得します。

戻り値:
route 輸送経路

getCreatedBy

public String getCreatedBy()
オブジェクト登録者名を取得します。

戻り値:
createdBy オブジェクト登録者名

getTaxClass1

public String getTaxClass1()
品目の税分類を取得します。

戻り値:
taxClass1 品目の税分類

getTaxClass2

public String getTaxClass2()
品目の税分類を取得します。

戻り値:
taxClass2 品目の税分類

getTaxClass3

public String getTaxClass3()
品目の税分類を取得します。

戻り値:
taxClass3 品目の税分類

getTaxClass4

public String getTaxClass4()
品目の税分類を取得します。

戻り値:
taxClass4 品目の税分類

getTaxClass5

public String getTaxClass5()
品目の税分類を取得します。

戻り値:
taxClass5 品目の税分類

getTaxClass6

public String getTaxClass6()
品目の税分類を取得します。

戻り値:
taxClass6 品目の税分類

getTaxClass7

public String getTaxClass7()
品目の税分類を取得します。

戻り値:
taxClass7 品目の税分類

getTaxClass8

public String getTaxClass8()
品目の税分類を取得します。

戻り値:
taxClass8 品目の税分類

getTaxClass9

public String getTaxClass9()
品目の税分類を取得します。

戻り値:
taxClass9 品目の税分類

getMatPrGrp

public String getMatPrGrp()
品目価格設定グループを取得します。

戻り値:
matPrGrp 品目価格設定グループ

getValType

public String getValType()
評価タイプを取得します。

戻り値:
valType 評価タイプ

getFixdatQty

public String getFixdatQty()
納期と出荷数量の固定を取得します。

戻り値:
fixdatQty 納期と出荷数量の固定

getBomexplNo

public String getBomexplNo()
BOM 展開番号を取得します。

戻り値:
bomexplNo BOM 展開番号

getResanalkey

public String getResanalkey()
結果分析キーを取得します。

戻り値:
resanalkey 結果分析キー

getReqmtsTyp

public String getReqmtsTyp()
所要量タイプを取得します。

戻り値:
reqmtsTyp 所要量タイプ

getNoGrPost

public String getNoGrPost()
得意先が入庫を転記していませんを取得します。

戻り値:
noGrPost 得意先が入庫を転記していません

getBusTranst

public String getBusTranst()
貿易管理の取引タイプを取得します。

戻り値:
busTranst 貿易管理の取引タイプ

getOverhdKey

public String getOverhdKey()
間接費キーを取得します。

戻り値:
overhdKey 間接費キー

getCstgSheet

public String getCstgSheet()
原価計算表を取得します。

戻り値:
cstgSheet 原価計算表

getMatfrgtgrp

public String getMatfrgtgrp()
品目運賃グループを取得します。

戻り値:
matfrgtgrp 品目運賃グループ

getPldlvshdin

public String getPldlvshdin()
出荷計画に関する指示を取得します。

戻り値:
pldlvshdin 出荷計画に関する指示

getSeqNo

public String getSeqNo()
KANBAN/連続番号を取得します。

戻り値:
seqNo KANBAN/連続番号

getBilForm

public String getBilForm()
請求書式を取得します。

戻り値:
bilForm 請求書式

getDliProfil

public String getDliProfil()
動的明細プロセッサプロファイルを取得します。

戻り値:
dliProfil 動的明細プロセッサプロファイル

getRevType

public String getRevType()
収益承認カテゴリを取得します。

戻り値:
revType 収益承認カテゴリ

getBegdemPer

public String getBegdemPer()
見越期間の提案開始日付を取得します。

戻り値:
begdemPer 見越期間の提案開始日付

getPrRefMat

public String getPrRefMat()
価格設定参照品目を取得します。

戻り値:
prRefMat 価格設定参照品目

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getOrderProb

public String getOrderProb()
明細の受注可能性を取得します。

戻り値:
orderProb 明細の受注可能性

getMaxPlDlv

public String getMaxPlDlv()
明細ごとの分割納入可能な最大回数を取得します。

戻り値:
maxPlDlv 明細ごとの分割納入可能な最大回数

getCfopCode

public String getCfopCode()
CFOP code and extension (old 5 char version)を取得します。

戻り値:
cfopCode CFOP code and extension (old 5 char version)

getTaxlawicms

public String getTaxlawicms()
税法: ICMSを取得します。

戻り値:
taxlawicms 税法: ICMS

getTaxlawipi

public String getTaxlawipi()
税法: IPIを取得します。

戻り値:
taxlawipi 税法: IPI

getSdTaxcode

public String getSdTaxcode()
を取得します。

戻り値:
sdTaxcode

getAssortMod

public String getAssortMod()
品揃モジュールを取得します。

戻り値:
assortMod 品揃モジュール

getCompQuant

public String getCompQuant()
構成品目数量を取得します。

戻り値:
compQuant 構成品目数量

getTargetVal

public String getTargetVal()
BAPI の通貨額 (小数点以下９桁)を取得します。

戻り値:
targetVal BAPI の通貨額 (小数点以下９桁)

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getProfitCtr

public String getProfitCtr()
利益センタを取得します。

戻り値:
profitCtr 利益センタ

getOrderid

public String getOrderid()
指図番号を取得します。

戻り値:
orderid 指図番号

getWbsElem

public String getWbsElem()
WBS 要素を取得します。

戻り値:
wbsElem WBS 要素

getDeprecPer

public String getDeprecPer()
ドキュメンタリクレジット処理に関する償却率 (%)を取得します。

戻り値:
deprecPer ドキュメンタリクレジット処理に関する償却率 (%)

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocIt

public String getRefDocIt()
参照明細番号を取得します。

戻り値:
refDocIt 参照明細番号

getRefDocCa

public String getRefDocCa()
先行販売管理伝票の伝票カテゴリを取得します。

戻り値:
refDocCa 先行販売管理伝票の伝票カテゴリ

getCustMat35

public String getCustMat35()
得意先品目を取得します。

戻り値:
custMat35 得意先品目

getExchRateFiV

public String getExchRateFiV()
FI 転記の換算レート (間接相場)を取得します。

戻り値:
exchRateFiV FI 転記の換算レート (間接相場)

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getItemguidAtp

public String getItemguidAtp()
ATP: 暗号 - DELNR および DELPSを取得します。

戻り値:
itemguidAtp ATP: 暗号 - DELNR および DELPS

getValContr

public String getValContr()
金額契約番号を取得します。

戻り値:
valContr 金額契約番号

getValConI

public String getValConI()
金額契約明細を取得します。

戻り値:
valConI 金額契約明細

getConfigId

public String getConfigId()
外部選定 ID (仮)を取得します。

戻り値:
configId 外部選定 ID (仮)

getInstId

public String getInstId()
選定におけるインスタンス番号を取得します。

戻り値:
instId 選定におけるインスタンス番号

getMatExt

public String getMatExt()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
matExt 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMatGuid

public String getMatGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
matGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMatVers

public String getMatVers()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
matVers 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getPMatExt

public String getPMatExt()
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
pMatExt 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

getPMatGuid

public String getPMatGuid()
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
pMatGuid 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

getPMatVers

public String getPMatVers()
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
pMatVers 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

getFuncArea

public String getFuncArea()
機能領域を取得します。

戻り値:
funcArea 機能領域

getAlternBom

public String getAlternBom()
代替 BOMを取得します。

戻り値:
alternBom 代替 BOM

getFkkConacct

public String getFkkConacct()
長さ 12 の文字項目を取得します。

戻り値:
fkkConacct 長さ 12 の文字項目

getEanUpc

public String getEanUpc()
国際商品コード (EAN/UPC)を取得します。

戻り値:
eanUpc 国際商品コード (EAN/UPC)

getProdcat

public String getProdcat()
製品カタログ番号を取得します。

戻り値:
prodcat 製品カタログ番号

getShipType

public String getShipType()
出荷タイプを取得します。

戻り値:
shipType 出荷タイプ

getSProcInd

public String getSProcInd()
特別処理区分を取得します。

戻り値:
sProcInd 特別処理区分

getFuncAreaLong

public String getFuncAreaLong()
機能領域を取得します。

戻り値:
funcAreaLong 機能領域

getBillRel

public String getBillRel()
請求関連 (CRM)を取得します。

戻り値:
billRel 請求関連 (CRM)

getVwUepos

public String getVwUepos()
上位レベル明細用途 IDを取得します。

戻り値:
vwUepos 上位レベル明細用途 ID

getCampaign

public String getCampaign()
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。

戻り値:
campaign 総括プロジェクト計画: 外部 R/3 システムの GUID

getDlvschduse

public String getDlvschduse()
用途区分を取得します。

戻り値:
dlvschduse 用途区分

getCfopLong

public String getCfopLong()
CFOP code and extensionを取得します。

戻り値:
cfopLong CFOP code and extension

getSelection

public String getSelection()
選択 ID (永続)を取得します。

戻り値:
selection 選択 ID (永続)

getMatEntrd

public String getMatEntrd()
入力品目を取得します。

戻り値:
matEntrd 入力品目

getLogSystemOwn

public String getLogSystemOwn()
論理システムを取得します。

戻り値:
logSystemOwn 論理システム

getItmTypeUsage

public String getItmTypeUsage()
明細用途を取得します。

戻り値:
itmTypeUsage 明細用途

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setHgLvItem

public void setHgLvItem(String hgLvItem)
上位レベル明細を設定します。

パラメータ:
hgLvItem - 上位レベル明細

setPoItmNo

public void setPoItmNo(String poItmNo)
元となる購買発注の明細番号を設定します。

パラメータ:
poItmNo - 元となる購買発注の明細番号

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setAltToItm

public void setAltToItm(String altToItm)
代替明細を設定します。

パラメータ:
altToItm - 代替明細

setCustMat22

public void setCustMat22(String custMat22)
得意先品目コード (無効)を設定します。

パラメータ:
custMat22 - 得意先品目コード (無効)

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setDlvGroup

public void setDlvGroup(String dlvGroup)
出荷グループ (明細一括出荷)を設定します。

パラメータ:
dlvGroup - 出荷グループ (明細一括出荷)

setPartDlv

public void setPartDlv(String partDlv)
明細レベルの分納納入を設定します。

パラメータ:
partDlv - 明細レベルの分納納入

setReasonRej

public void setReasonRej(String reasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
reasonRej - 見積および受注の拒否理由

setBillBlock

public void setBillBlock(String billBlock)
ブロックを設定します。

パラメータ:
billBlock - ブロック

setBillDate

public void setBillDate(String billDate)
請求索引および印刷に対する請求日を設定します。

パラメータ:
billDate - 請求索引および印刷に対する請求日

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoreLoc

public void setStoreLoc(String storeLoc)
保管場所を設定します。

パラメータ:
storeLoc - 保管場所

setTargetQty

public void setTargetQty(String targetQty)
目標数量（販売単位）を設定します。

パラメータ:
targetQty - 目標数量（販売単位）

setTargetQu

public void setTargetQu(String targetQu)
目標数量 (数量単位)を設定します。

パラメータ:
targetQu - 目標数量 (数量単位)

setTUnitIso

public void setTUnitIso(String tUnitIso)
目標数量単位 (ISO コード)を設定します。

パラメータ:
tUnitIso - 目標数量単位 (ISO コード)

setItemCateg

public void setItemCateg(String itemCateg)
明細カテゴリ (販売伝票)を設定します。

パラメータ:
itemCateg - 明細カテゴリ (販売伝票)

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setPrcGroup1

public void setPrcGroup1(String prcGroup1)
品目グループ 1を設定します。

パラメータ:
prcGroup1 - 品目グループ 1

setPrcGroup2

public void setPrcGroup2(String prcGroup2)
品目グループ 2を設定します。

パラメータ:
prcGroup2 - 品目グループ 2

setPrcGroup3

public void setPrcGroup3(String prcGroup3)
品目グループ 3を設定します。

パラメータ:
prcGroup3 - 品目グループ 3

setPrcGroup4

public void setPrcGroup4(String prcGroup4)
品目グループ 4を設定します。

パラメータ:
prcGroup4 - 品目グループ 4

setPrcGroup5

public void setPrcGroup5(String prcGroup5)
品目グループ 5を設定します。

パラメータ:
prcGroup5 - 品目グループ 5

setProdHiera

public void setProdHiera(String prodHiera)
品目階層を設定します。

パラメータ:
prodHiera - 品目階層

setMatlGroup

public void setMatlGroup(String matlGroup)
品目グループを設定します。

パラメータ:
matlGroup - 品目グループ

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setPurchDate

public void setPurchDate(String purchDate)
得意先発注日付を設定します。

パラメータ:
purchDate - 得意先発注日付

setPoMethod

public void setPoMethod(String poMethod)
得意先発注タイプを設定します。

パラメータ:
poMethod - 得意先発注タイプ

setRef1

public void setRef1(String ref1)
得意先/仕入先の内部参照コードを設定します。

パラメータ:
ref1 - 得意先/仕入先の内部参照コード

setPurchNoS

public void setPurchNoS(String purchNoS)
出荷先の得意先発注番号を設定します。

パラメータ:
purchNoS - 出荷先の得意先発注番号

setPoDatS

public void setPoDatS(String poDatS)
出荷先の出荷先発注日付を設定します。

パラメータ:
poDatS - 出荷先の出荷先発注日付

setPoMethS

public void setPoMethS(String poMethS)
出荷先の出荷先発注タイプを設定します。

パラメータ:
poMethS - 出荷先の出荷先発注タイプ

setRef1S

public void setRef1S(String ref1S)
出荷先文字を設定します。

パラメータ:
ref1S - 出荷先文字

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
元となる購買発注の明細番号を設定します。

パラメータ:
poitmNoS - 元となる購買発注の明細番号

setPriceGrp

public void setPriceGrp(String priceGrp)
価格グループ (得意先)を設定します。

パラメータ:
priceGrp - 価格グループ (得意先)

setCustGroup

public void setCustGroup(String custGroup)
得意先グループを設定します。

パラメータ:
custGroup - 得意先グループ

setSalesDist

public void setSalesDist(String salesDist)
販売地域を設定します。

パラメータ:
salesDist - 販売地域

setPriceList

public void setPriceList(String priceList)
価格表タイプを設定します。

パラメータ:
priceList - 価格表タイプ

setIncoterms1

public void setIncoterms1(String incoterms1)
インコタームズ (1)を設定します。

パラメータ:
incoterms1 - インコタームズ (1)

setIncoterms2

public void setIncoterms2(String incoterms2)
インコタームズ 2を設定します。

パラメータ:
incoterms2 - インコタームズ 2

setOrdcompIn

public void setOrdcompIn(String ordcompIn)
受注結合出荷区分を設定します。

パラメータ:
ordcompIn - 受注結合出荷区分

setBillSched

public void setBillSched(String billSched)
請求日程 (稼働日カレンダ指定)を設定します。

パラメータ:
billSched - 請求日程 (稼働日カレンダ指定)

setInvoSched

public void setInvoSched(String invoSched)
請求書一覧日程 (稼働日カレンダ指定)を設定します。

パラメータ:
invoSched - 請求書一覧日程 (稼働日カレンダ指定)

setMnInvoice

public void setMnInvoice(String mnInvoice)
マニュアル請求書更新を設定します。

パラメータ:
mnInvoice - マニュアル請求書更新

setExRateFi

public void setExRateFi(String exRateFi)
FI 転記の換算レート (直接相場)を設定します。

パラメータ:
exRateFi - FI 転記の換算レート (直接相場)

setAddValDy

public void setAddValDy(String addValDy)
有効日からの日数を設定します。

パラメータ:
addValDy - 有効日からの日数

setFixValDy

public void setFixValDy(String fixValDy)
有効日日付を設定します。

パラメータ:
fixValDy - 有効日日付

setPmnttrms

public void setPmnttrms(String pmnttrms)
支払条件キーを設定します。

パラメータ:
pmnttrms - 支払条件キー

setPymtMeth

public void setPymtMeth(String pymtMeth)
支払方法を設定します。

パラメータ:
pymtMeth - 支払方法

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
得意先の勘定設定グループを設定します。

パラメータ:
accntAsgn - 得意先の勘定設定グループ

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setPriceDate

public void setPriceDate(String priceDate)
価格設定/外貨換算の実行日付を設定します。

パラメータ:
priceDate - 価格設定/外貨換算の実行日付

setServDate

public void setServDate(String servDate)
サービス提供日を設定します。

パラメータ:
servDate - サービス提供日

setDunnKey

public void setDunnKey(String dunnKey)
督促処理キーを設定します。

パラメータ:
dunnKey - 督促処理キー

setDunnBlock

public void setDunnBlock(String dunnBlock)
督促処理保留を設定します。

パラメータ:
dunnBlock - 督促処理保留

setPromotion

public void setPromotion(String promotion)
プロモーションを設定します。

パラメータ:
promotion - プロモーション

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
支払保証決定表を設定します。

パラメータ:
pmtgarPro - 支払保証決定表

setDocNumFi

public void setDocNumFi(String docNumFi)
ドキュメンタリクレジット処理: 内部番号を設定します。

パラメータ:
docNumFi - ドキュメンタリクレジット処理: 内部番号

setDepartmNo

public void setDepartmNo(String departmNo)
部門コードを設定します。

パラメータ:
departmNo - 部門コード

setRecPoint

public void setRecPoint(String recPoint)
入荷ポイントを設定します。

パラメータ:
recPoint - 入荷ポイント

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
得意先条件グループ１を設定します。

パラメータ:
cstcndgrp1 - 得意先条件グループ１

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
得意先条件グループ２を設定します。

パラメータ:
cstcndgrp2 - 得意先条件グループ２

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
得意先条件グループ３を設定します。

パラメータ:
cstcndgrp3 - 得意先条件グループ３

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
得意先条件グループ４を設定します。

パラメータ:
cstcndgrp4 - 得意先条件グループ４

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
得意先条件グループ５を設定します。

パラメータ:
cstcndgrp5 - 得意先条件グループ５

setDlvTime

public void setDlvTime(String dlvTime)
契約出荷期間を設定します。

パラメータ:
dlvTime - 契約出荷期間

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setSUnitIso

public void setSUnitIso(String sUnitIso)
単位の ISO コードを設定します。

パラメータ:
sUnitIso - 単位の ISO コード

setTrgQtyNo

public void setTrgQtyNo(String trgQtyNo)
販売単位から基本単位への換算係数を設定します。

パラメータ:
trgQtyNo - 販売単位から基本単位への換算係数

setTrgqtyDen

public void setTrgqtyDen(String trgqtyDen)
販売単位から基本単位への換算係数を設定します。

パラメータ:
trgqtyDen - 販売単位から基本単位への換算係数

setRnddlvQty

public void setRnddlvQty(String rnddlvQty)
丸め数量: 出荷を設定します。

パラメータ:
rnddlvQty - 丸め数量: 出荷

setMaxdevamnt

public void setMaxdevamnt(String maxdevamnt)
数量に関する許容偏差 (絶対値)を設定します。

パラメータ:
maxdevamnt - 数量に関する許容偏差 (絶対値)

setMaxdevper

public void setMaxdevper(String maxdevper)
数量に関する許容偏差 (%)を設定します。

パラメータ:
maxdevper - 数量に関する許容偏差 (%)

setMaxdevDay

public void setMaxdevDay(String maxdevDay)
シフト所要日数を設定します。

パラメータ:
maxdevDay - シフト所要日数

setUsageInd

public void setUsageInd(String usageInd)
未使用 - 予約長 3を設定します。

パラメータ:
usageInd - 未使用 - 予約長 3

setFixedQuan

public void setFixedQuan(String fixedQuan)
数量固定区分を設定します。

パラメータ:
fixedQuan - 数量固定区分

setUnlmtDlv

public void setUnlmtDlv(String unlmtDlv)
区分: 無制限過剰納入可能を設定します。

パラメータ:
unlmtDlv - 区分: 無制限過剰納入可能

setOverdlvtol

public void setOverdlvtol(String overdlvtol)
過剰納入許容範囲を設定します。

パラメータ:
overdlvtol - 過剰納入許容範囲

setUnddlvTol

public void setUnddlvTol(String unddlvTol)
不足納入許容範囲リミットを設定します。

パラメータ:
unddlvTol - 不足納入許容範囲リミット

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setSalqtynum

public void setSalqtynum(String salqtynum)
販売数量単位から基本数量単位への変換係数の分子を設定します。

パラメータ:
salqtynum - 販売数量単位から基本数量単位への変換係数の分子

setSalqtyden

public void setSalqtyden(String salqtyden)
販売数量単位を SKU に換算するための分母 (除数)を設定します。

パラメータ:
salqtyden - 販売数量単位を SKU に換算するための分母 (除数)

setGrossWght

public void setGrossWght(String grossWght)
明細の総重量を設定します。

パラメータ:
grossWght - 明細の総重量

setNetWeight

public void setNetWeight(String netWeight)
明細の正味重量を設定します。

パラメータ:
netWeight - 明細の正味重量

setUntofWght

public void setUntofWght(String untofWght)
重量単位を設定します。

パラメータ:
untofWght - 重量単位

setUnofWtiso

public void setUnofWtiso(String unofWtiso)
ISO コードでの重量単位を設定します。

パラメータ:
unofWtiso - ISO コードでの重量単位

setVolume

public void setVolume(String volume)
明細の総数量を設定します。

パラメータ:
volume - 明細の総数量

setVolunit

public void setVolunit(String volunit)
容積単位を設定します。

パラメータ:
volunit - 容積単位

setVolunitiso

public void setVolunitiso(String volunitiso)
ISO コードでの容積単位を設定します。

パラメータ:
volunitiso - ISO コードでの容積単位

setDlvPrio

public void setDlvPrio(String dlvPrio)
出荷優先順位を設定します。

パラメータ:
dlvPrio - 出荷優先順位

setShipPoint

public void setShipPoint(String shipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
shipPoint - 出荷ポイント/入荷ポイント

setRoute

public void setRoute(String route)
輸送経路を設定します。

パラメータ:
route - 輸送経路

setCreatedBy

public void setCreatedBy(String createdBy)
オブジェクト登録者名を設定します。

パラメータ:
createdBy - オブジェクト登録者名

setTaxClass1

public void setTaxClass1(String taxClass1)
品目の税分類を設定します。

パラメータ:
taxClass1 - 品目の税分類

setTaxClass2

public void setTaxClass2(String taxClass2)
品目の税分類を設定します。

パラメータ:
taxClass2 - 品目の税分類

setTaxClass3

public void setTaxClass3(String taxClass3)
品目の税分類を設定します。

パラメータ:
taxClass3 - 品目の税分類

setTaxClass4

public void setTaxClass4(String taxClass4)
品目の税分類を設定します。

パラメータ:
taxClass4 - 品目の税分類

setTaxClass5

public void setTaxClass5(String taxClass5)
品目の税分類を設定します。

パラメータ:
taxClass5 - 品目の税分類

setTaxClass6

public void setTaxClass6(String taxClass6)
品目の税分類を設定します。

パラメータ:
taxClass6 - 品目の税分類

setTaxClass7

public void setTaxClass7(String taxClass7)
品目の税分類を設定します。

パラメータ:
taxClass7 - 品目の税分類

setTaxClass8

public void setTaxClass8(String taxClass8)
品目の税分類を設定します。

パラメータ:
taxClass8 - 品目の税分類

setTaxClass9

public void setTaxClass9(String taxClass9)
品目の税分類を設定します。

パラメータ:
taxClass9 - 品目の税分類

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
品目価格設定グループを設定します。

パラメータ:
matPrGrp - 品目価格設定グループ

setValType

public void setValType(String valType)
評価タイプを設定します。

パラメータ:
valType - 評価タイプ

setFixdatQty

public void setFixdatQty(String fixdatQty)
納期と出荷数量の固定を設定します。

パラメータ:
fixdatQty - 納期と出荷数量の固定

setBomexplNo

public void setBomexplNo(String bomexplNo)
BOM 展開番号を設定します。

パラメータ:
bomexplNo - BOM 展開番号

setResanalkey

public void setResanalkey(String resanalkey)
結果分析キーを設定します。

パラメータ:
resanalkey - 結果分析キー

setReqmtsTyp

public void setReqmtsTyp(String reqmtsTyp)
所要量タイプを設定します。

パラメータ:
reqmtsTyp - 所要量タイプ

setNoGrPost

public void setNoGrPost(String noGrPost)
得意先が入庫を転記していませんを設定します。

パラメータ:
noGrPost - 得意先が入庫を転記していません

setBusTranst

public void setBusTranst(String busTranst)
貿易管理の取引タイプを設定します。

パラメータ:
busTranst - 貿易管理の取引タイプ

setOverhdKey

public void setOverhdKey(String overhdKey)
間接費キーを設定します。

パラメータ:
overhdKey - 間接費キー

setCstgSheet

public void setCstgSheet(String cstgSheet)
原価計算表を設定します。

パラメータ:
cstgSheet - 原価計算表

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
品目運賃グループを設定します。

パラメータ:
matfrgtgrp - 品目運賃グループ

setPldlvshdin

public void setPldlvshdin(String pldlvshdin)
出荷計画に関する指示を設定します。

パラメータ:
pldlvshdin - 出荷計画に関する指示

setSeqNo

public void setSeqNo(String seqNo)
KANBAN/連続番号を設定します。

パラメータ:
seqNo - KANBAN/連続番号

setBilForm

public void setBilForm(String bilForm)
請求書式を設定します。

パラメータ:
bilForm - 請求書式

setDliProfil

public void setDliProfil(String dliProfil)
動的明細プロセッサプロファイルを設定します。

パラメータ:
dliProfil - 動的明細プロセッサプロファイル

setRevType

public void setRevType(String revType)
収益承認カテゴリを設定します。

パラメータ:
revType - 収益承認カテゴリ

setBegdemPer

public void setBegdemPer(String begdemPer)
見越期間の提案開始日付を設定します。

パラメータ:
begdemPer - 見越期間の提案開始日付

setPrRefMat

public void setPrRefMat(String prRefMat)
価格設定参照品目を設定します。

パラメータ:
prRefMat - 価格設定参照品目

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setOrderProb

public void setOrderProb(String orderProb)
明細の受注可能性を設定します。

パラメータ:
orderProb - 明細の受注可能性

setMaxPlDlv

public void setMaxPlDlv(String maxPlDlv)
明細ごとの分割納入可能な最大回数を設定します。

パラメータ:
maxPlDlv - 明細ごとの分割納入可能な最大回数

setCfopCode

public void setCfopCode(String cfopCode)
CFOP code and extension (old 5 char version)を設定します。

パラメータ:
cfopCode - CFOP code and extension (old 5 char version)

setTaxlawicms

public void setTaxlawicms(String taxlawicms)
税法: ICMSを設定します。

パラメータ:
taxlawicms - 税法: ICMS

setTaxlawipi

public void setTaxlawipi(String taxlawipi)
税法: IPIを設定します。

パラメータ:
taxlawipi - 税法: IPI

setSdTaxcode

public void setSdTaxcode(String sdTaxcode)
0を設定します。

パラメータ:
sdTaxcode - 0

setAssortMod

public void setAssortMod(String assortMod)
品揃モジュールを設定します。

パラメータ:
assortMod - 品揃モジュール

setCompQuant

public void setCompQuant(String compQuant)
構成品目数量を設定します。

パラメータ:
compQuant - 構成品目数量

setTargetVal

public void setTargetVal(String targetVal)
BAPI の通貨額 (小数点以下９桁)を設定します。

パラメータ:
targetVal - BAPI の通貨額 (小数点以下９桁)

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setProfitCtr

public void setProfitCtr(String profitCtr)
利益センタを設定します。

パラメータ:
profitCtr - 利益センタ

setOrderid

public void setOrderid(String orderid)
指図番号を設定します。

パラメータ:
orderid - 指図番号

setWbsElem

public void setWbsElem(String wbsElem)
WBS 要素を設定します。

パラメータ:
wbsElem - WBS 要素

setDeprecPer

public void setDeprecPer(String deprecPer)
ドキュメンタリクレジット処理に関する償却率 (%)を設定します。

パラメータ:
deprecPer - ドキュメンタリクレジット処理に関する償却率 (%)

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocIt

public void setRefDocIt(String refDocIt)
参照明細番号を設定します。

パラメータ:
refDocIt - 参照明細番号

setRefDocCa

public void setRefDocCa(String refDocCa)
先行販売管理伝票の伝票カテゴリを設定します。

パラメータ:
refDocCa - 先行販売管理伝票の伝票カテゴリ

setCustMat35

public void setCustMat35(String custMat35)
得意先品目を設定します。

パラメータ:
custMat35 - 得意先品目

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
FI 転記の換算レート (間接相場)を設定します。

パラメータ:
exchRateFiV - FI 転記の換算レート (間接相場)

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setItemguidAtp

public void setItemguidAtp(String itemguidAtp)
ATP: 暗号 - DELNR および DELPSを設定します。

パラメータ:
itemguidAtp - ATP: 暗号 - DELNR および DELPS

setValContr

public void setValContr(String valContr)
金額契約番号を設定します。

パラメータ:
valContr - 金額契約番号

setValConI

public void setValConI(String valConI)
金額契約明細を設定します。

パラメータ:
valConI - 金額契約明細

setConfigId

public void setConfigId(String configId)
外部選定 ID (仮)を設定します。

パラメータ:
configId - 外部選定 ID (仮)

setInstId

public void setInstId(String instId)
選定におけるインスタンス番号を設定します。

パラメータ:
instId - 選定におけるインスタンス番号

setMatExt

public void setMatExt(String matExt)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
matExt - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMatGuid

public void setMatGuid(String matGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
matGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMatVers

public void setMatVers(String matVers)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
matVers - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setPMatExt

public void setPMatExt(String pMatExt)
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
pMatExt - 項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

setPMatGuid

public void setPMatGuid(String pMatGuid)
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
pMatGuid - 項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

setPMatVers

public void setPMatVers(String pMatVers)
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
pMatVers - 項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

setFuncArea

public void setFuncArea(String funcArea)
機能領域を設定します。

パラメータ:
funcArea - 機能領域

setAlternBom

public void setAlternBom(String alternBom)
代替 BOMを設定します。

パラメータ:
alternBom - 代替 BOM

setFkkConacct

public void setFkkConacct(String fkkConacct)
長さ 12 の文字項目を設定します。

パラメータ:
fkkConacct - 長さ 12 の文字項目

setEanUpc

public void setEanUpc(String eanUpc)
国際商品コード (EAN/UPC)を設定します。

パラメータ:
eanUpc - 国際商品コード (EAN/UPC)

setProdcat

public void setProdcat(String prodcat)
製品カタログ番号を設定します。

パラメータ:
prodcat - 製品カタログ番号

setShipType

public void setShipType(String shipType)
出荷タイプを設定します。

パラメータ:
shipType - 出荷タイプ

setSProcInd

public void setSProcInd(String sProcInd)
特別処理区分を設定します。

パラメータ:
sProcInd - 特別処理区分

setFuncAreaLong

public void setFuncAreaLong(String funcAreaLong)
機能領域を設定します。

パラメータ:
funcAreaLong - 機能領域

setBillRel

public void setBillRel(String billRel)
請求関連 (CRM)を設定します。

パラメータ:
billRel - 請求関連 (CRM)

setVwUepos

public void setVwUepos(String vwUepos)
上位レベル明細用途 IDを設定します。

パラメータ:
vwUepos - 上位レベル明細用途 ID

setCampaign

public void setCampaign(String campaign)
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。

パラメータ:
campaign - 総括プロジェクト計画: 外部 R/3 システムの GUID

setDlvschduse

public void setDlvschduse(String dlvschduse)
用途区分を設定します。

パラメータ:
dlvschduse - 用途区分

setCfopLong

public void setCfopLong(String cfopLong)
CFOP code and extensionを設定します。

パラメータ:
cfopLong - CFOP code and extension

setSelection

public void setSelection(String selection)
選択 ID (永続)を設定します。

パラメータ:
selection - 選択 ID (永続)

setMatEntrd

public void setMatEntrd(String matEntrd)
入力品目を設定します。

パラメータ:
matEntrd - 入力品目

setLogSystemOwn

public void setLogSystemOwn(String logSystemOwn)
論理システムを設定します。

パラメータ:
logSystemOwn - 論理システム

setItmTypeUsage

public void setItmTypeUsage(String itmTypeUsage)
明細用途を設定します。

パラメータ:
itmTypeUsage - 明細用途

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ItemsInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ItemsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX
すべての実装インタフェース:
Serializable
public class ItemsInX
extends Object
implements Serializable

明細データチェックボックス情報クラス
機能は以下の通り

  • 明細データチェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
ItemsInX()
明細データチェックボックス情報を作成します。
ItemsInX(int index)
明細データチェックボックス情報を作成します。
メソッドの概要
String | getAccntAsgn() 関連ユーザデータ項目の更新情報を取得します。
String | getAddValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getAlternBom() 関連ユーザデータ項目の更新情報を取得します。
String | getAltToItm() 関連ユーザデータ項目の更新情報を取得します。
String | getAssortMod() 関連ユーザデータ項目の更新情報を取得します。
String | getBatch() 関連ユーザデータ項目の更新情報を取得します。
String | getBegdemPer() 関連ユーザデータ項目の更新情報を取得します。
String | getBilForm() 関連ユーザデータ項目の更新情報を取得します。
String | getBillBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getBillDate() 関連ユーザデータ項目の更新情報を取得します。
String | getBillRel() 関連ユーザデータ項目の更新情報を取得します。
String | getBillSched() 関連ユーザデータ項目の更新情報を取得します。
String | getBomexplNo() 関連ユーザデータ項目の更新情報を取得します。
String | getBusTranst() 関連ユーザデータ項目の更新情報を取得します。
String | getCampaign() 関連ユーザデータ項目の更新情報を取得します。
String | getCfopCode() 関連ユーザデータ項目の更新情報を取得します。
String | getCompQuant() 関連ユーザデータ項目の更新情報を取得します。
String | getConfigId() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp1() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp2() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp3() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp4() 関連ユーザデータ項目の更新情報を取得します。
String | getCstcndgrp5() 関連ユーザデータ項目の更新情報を取得します。
String | getCstgSheet() 関連ユーザデータ項目の更新情報を取得します。
String | getCustGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getCustMat22() 関連ユーザデータ項目の更新情報を取得します。
String | getCustMat35() 関連ユーザデータ項目の更新情報を取得します。
String | getDepartmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getDeprecPer() 関連ユーザデータ項目の更新情報を取得します。
String | getDivision() 関連ユーザデータ項目の更新情報を取得します。
String | getDliProfil() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvPrio() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvschduse() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getDocNumFi() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnBlock() 関連ユーザデータ項目の更新情報を取得します。
String | getDunnKey() 関連ユーザデータ項目の更新情報を取得します。
String | getEanUpc() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRate() 関連ユーザデータ項目の更新情報を取得します。
String | getExchgRateV() 関連ユーザデータ項目の更新情報を取得します。
String | getExchRateFiV() 関連ユーザデータ項目の更新情報を取得します。
String | getExRateFi() 関連ユーザデータ項目の更新情報を取得します。
String | getFixdatQty() 関連ユーザデータ項目の更新情報を取得します。
String | getFixedQuan() 関連ユーザデータ項目の更新情報を取得します。
String | getFixValDy() 関連ユーザデータ項目の更新情報を取得します。
String | getFkkConacct() 関連ユーザデータ項目の更新情報を取得します。
String | getFuncArea() 関連ユーザデータ項目の更新情報を取得します。
String | getGrossWght() 関連ユーザデータ項目の更新情報を取得します。
String | getHgLvItem() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms1() 関連ユーザデータ項目の更新情報を取得します。
String | getIncoterms2() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getInstId() 関連ユーザデータ項目の更新情報を取得します。
String | getInvoSched() 関連ユーザデータ項目の更新情報を取得します。
String | getItemCateg() 関連ユーザデータ項目の更新情報を取得します。
String | getItemguidAtp() 関連ユーザデータ項目の更新情報を取得します。
String | getItmNumber() 販売伝票明細を取得します。
String | getItmTypeUsage() 関連ユーザデータ項目の更新情報を取得します。
String | getLogSystemOwn() 関連ユーザデータ項目の更新情報を取得します。
String | getMatEntrd() 関連ユーザデータ項目の更新情報を取得します。
String | getMaterial() 関連ユーザデータ項目の更新情報を取得します。
String | getMatExt() 関連ユーザデータ項目の更新情報を取得します。
String | getMatfrgtgrp() 関連ユーザデータ項目の更新情報を取得します。
String | getMatGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getMatlGroup() 関連ユーザデータ項目の更新情報を取得します。
String | getMatPrGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getMatVers() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevamnt() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevDay() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxdevper() 関連ユーザデータ項目の更新情報を取得します。
String | getMaxPlDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getMnInvoice() 関連ユーザデータ項目の更新情報を取得します。
String | getNetWeight() 関連ユーザデータ項目の更新情報を取得します。
String | getNoGrPost() 関連ユーザデータ項目の更新情報を取得します。
String | getOrdcompIn() 関連ユーザデータ項目の更新情報を取得します。
String | getOrderid() 関連ユーザデータ項目の更新情報を取得します。
String | getOrderProb() 関連ユーザデータ項目の更新情報を取得します。
String | getOverdlvtol() 関連ユーザデータ項目の更新情報を取得します。
String | getOverhdKey() 関連ユーザデータ項目の更新情報を取得します。
String | getPartDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getPlant() 関連ユーザデータ項目の更新情報を取得します。
String | getPldlvshdin() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatExt() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatGuid() 関連ユーザデータ項目の更新情報を取得します。
String | getPMatVers() 関連ユーザデータ項目の更新情報を取得します。
String | getPmnttrms() 関連ユーザデータ項目の更新情報を取得します。
String | getPmtgarPro() 関連ユーザデータ項目の更新情報を取得します。
String | getPoDatS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoItmNo() 関連ユーザデータ項目の更新情報を取得します。
String | getPoitmNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethod() 関連ユーザデータ項目の更新情報を取得します。
String | getPoMethS() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup1() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup2() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup3() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup4() 関連ユーザデータ項目の更新情報を取得します。
String | getPrcGroup5() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceGrp() 関連ユーザデータ項目の更新情報を取得します。
String | getPriceList() 関連ユーザデータ項目の更新情報を取得します。
String | getProdcat() 関連ユーザデータ項目の更新情報を取得します。
String | getProdHiera() 関連ユーザデータ項目の更新情報を取得します。
String | getProfitCtr() 関連ユーザデータ項目の更新情報を取得します。
String | getPromotion() 関連ユーザデータ項目の更新情報を取得します。
String | getPrRefMat() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchDate() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoC() 関連ユーザデータ項目の更新情報を取得します。
String | getPurchNoS() 関連ユーザデータ項目の更新情報を取得します。
String | getPymtMeth() 関連ユーザデータ項目の更新情報を取得します。
String | getReasonRej() 関連ユーザデータ項目の更新情報を取得します。
String | getRecPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1() 関連ユーザデータ項目の更新情報を取得します。
String | getRef1S() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDoc() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocCa() 関連ユーザデータ項目の更新情報を取得します。
String | getRefDocIt() 関連ユーザデータ項目の更新情報を取得します。
String | getReflogsys() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjkey() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjtype() 関連ユーザデータ項目の更新情報を取得します。
String | getReqmtsTyp() 関連ユーザデータ項目の更新情報を取得します。
String | getResanalkey() 関連ユーザデータ項目の更新情報を取得します。
String | getRevType() 関連ユーザデータ項目の更新情報を取得します。
String | getRnddlvQty() 関連ユーザデータ項目の更新情報を取得します。
String | getRoute() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesDist() 関連ユーザデータ項目の更新情報を取得します。
String | getSalesUnit() 関連ユーザデータ項目の更新情報を取得します。
String | getSalqtyden() 関連ユーザデータ項目の更新情報を取得します。
String | getSalqtynum() 関連ユーザデータ項目の更新情報を取得します。
String | getSdTaxcode() 関連ユーザデータ項目の更新情報を取得します。
String | getSelection() 関連ユーザデータ項目の更新情報を取得します。
String | getSeqNo() 関連ユーザデータ項目の更新情報を取得します。
String | getServDate() 関連ユーザデータ項目の更新情報を取得します。
String | getShipPoint() 関連ユーザデータ項目の更新情報を取得します。
String | getShipType() 関連ユーザデータ項目の更新情報を取得します。
String | getShortText() 関連ユーザデータ項目の更新情報を取得します。
String | getSProcInd() 関連ユーザデータ項目の更新情報を取得します。
String | getStoreLoc() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetQty() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetQu() 関連ユーザデータ項目の更新情報を取得します。
String | getTargetVal() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass1() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass2() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass3() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass4() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass5() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass6() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass7() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass8() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxClass9() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxlawicms() 関連ユーザデータ項目の更新情報を取得します。
String | getTaxlawipi() 関連ユーザデータ項目の更新情報を取得します。
String | getTrgqtyDen() 関連ユーザデータ項目の更新情報を取得します。
String | getTrgQtyNo() 関連ユーザデータ項目の更新情報を取得します。
String | getTUnitIso() 関連ユーザデータ項目の更新情報を取得します。
String | getUnddlvTol() 関連ユーザデータ項目の更新情報を取得します。
String | getUnlmtDlv() 関連ユーザデータ項目の更新情報を取得します。
String | getUntofWght() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
String | getUsageInd() 関連ユーザデータ項目の更新情報を取得します。
String | getValConI() 関連ユーザデータ項目の更新情報を取得します。
String | getValContr() 関連ユーザデータ項目の更新情報を取得します。
String | getValType() 関連ユーザデータ項目の更新情報を取得します。
String | getVolume() 関連ユーザデータ項目の更新情報を取得します。
String | getVolunit() 関連ユーザデータ項目の更新情報を取得します。
String | getVwUepos() 関連ユーザデータ項目の更新情報を取得します。
String | getWbsElem() 関連ユーザデータ項目の更新情報を取得します。
void | setAccntAsgn(String accntAsgn) 関連ユーザデータ項目の更新情報を設定します。
void | setAddValDy(String addValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setAlternBom(String alternBom) 関連ユーザデータ項目の更新情報を設定します。
void | setAltToItm(String altToItm) 関連ユーザデータ項目の更新情報を設定します。
void | setAssortMod(String assortMod) 関連ユーザデータ項目の更新情報を設定します。
void | setBatch(String batch) 関連ユーザデータ項目の更新情報を設定します。
void | setBegdemPer(String begdemPer) 関連ユーザデータ項目の更新情報を設定します。
void | setBilForm(String bilForm) 関連ユーザデータ項目の更新情報を設定します。
void | setBillBlock(String billBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setBillDate(String billDate) 関連ユーザデータ項目の更新情報を設定します。
void | setBillRel(String billRel) 関連ユーザデータ項目の更新情報を設定します。
void | setBillSched(String billSched) 関連ユーザデータ項目の更新情報を設定します。
void | setBomexplNo(String bomexplNo) 関連ユーザデータ項目の更新情報を設定します。
void | setBusTranst(String busTranst) 関連ユーザデータ項目の更新情報を設定します。
void | setCampaign(String campaign) 関連ユーザデータ項目の更新情報を設定します。
void | setCfopCode(String cfopCode) 関連ユーザデータ項目の更新情報を設定します。
void | setCompQuant(String compQuant) 関連ユーザデータ項目の更新情報を設定します。
void | setConfigId(String configId) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp1(String cstcndgrp1) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp2(String cstcndgrp2) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp3(String cstcndgrp3) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp4(String cstcndgrp4) 関連ユーザデータ項目の更新情報を設定します。
void | setCstcndgrp5(String cstcndgrp5) 関連ユーザデータ項目の更新情報を設定します。
void | setCstgSheet(String cstgSheet) 関連ユーザデータ項目の更新情報を設定します。
void | setCustGroup(String custGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setCustMat22(String custMat22) 関連ユーザデータ項目の更新情報を設定します。
void | setCustMat35(String custMat35) 関連ユーザデータ項目の更新情報を設定します。
void | setDepartmNo(String departmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setDeprecPer(String deprecPer) 関連ユーザデータ項目の更新情報を設定します。
void | setDivision(String division) 関連ユーザデータ項目の更新情報を設定します。
void | setDliProfil(String dliProfil) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvGroup(String dlvGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvPrio(String dlvPrio) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvschduse(String dlvschduse) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setDocNumFi(String docNumFi) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnBlock(String dunnBlock) 関連ユーザデータ項目の更新情報を設定します。
void | setDunnKey(String dunnKey) 関連ユーザデータ項目の更新情報を設定します。
void | setEanUpc(String eanUpc) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRate(String exchgRate) 関連ユーザデータ項目の更新情報を設定します。
void | setExchgRateV(String exchgRateV) 関連ユーザデータ項目の更新情報を設定します。
void | setExchRateFiV(String exchRateFiV) 関連ユーザデータ項目の更新情報を設定します。
void | setExRateFi(String exRateFi) 関連ユーザデータ項目の更新情報を設定します。
void | setFixdatQty(String fixdatQty) 関連ユーザデータ項目の更新情報を設定します。
void | setFixedQuan(String fixedQuan) 関連ユーザデータ項目の更新情報を設定します。
void | setFixValDy(String fixValDy) 関連ユーザデータ項目の更新情報を設定します。
void | setFkkConacct(String fkkConacct) 関連ユーザデータ項目の更新情報を設定します。
void | setFuncArea(String funcArea) 関連ユーザデータ項目の更新情報を設定します。
void | setGrossWght(String grossWght) 関連ユーザデータ項目の更新情報を設定します。
void | setHgLvItem(String hgLvItem) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms1(String incoterms1) 関連ユーザデータ項目の更新情報を設定します。
void | setIncoterms2(String incoterms2) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setInstId(String instId) 関連ユーザデータ項目の更新情報を設定します。
void | setInvoSched(String invoSched) 関連ユーザデータ項目の更新情報を設定します。
void | setItemCateg(String itemCateg) 関連ユーザデータ項目の更新情報を設定します。
void | setItemguidAtp(String itemguidAtp) 関連ユーザデータ項目の更新情報を設定します。
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setItmTypeUsage(String itmTypeUsage) 関連ユーザデータ項目の更新情報を設定します。
void | setLogSystemOwn(String logSystemOwn) 関連ユーザデータ項目の更新情報を設定します。
void | setMatEntrd(String matEntrd) 関連ユーザデータ項目の更新情報を設定します。
void | setMaterial(String material) 関連ユーザデータ項目の更新情報を設定します。
void | setMatExt(String matExt) 関連ユーザデータ項目の更新情報を設定します。
void | setMatfrgtgrp(String matfrgtgrp) 関連ユーザデータ項目の更新情報を設定します。
void | setMatGuid(String matGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setMatlGroup(String matlGroup) 関連ユーザデータ項目の更新情報を設定します。
void | setMatPrGrp(String matPrGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setMatVers(String matVers) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevamnt(String maxdevamnt) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevDay(String maxdevDay) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxdevper(String maxdevper) 関連ユーザデータ項目の更新情報を設定します。
void | setMaxPlDlv(String maxPlDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setMnInvoice(String mnInvoice) 関連ユーザデータ項目の更新情報を設定します。
void | setNetWeight(String netWeight) 関連ユーザデータ項目の更新情報を設定します。
void | setNoGrPost(String noGrPost) 関連ユーザデータ項目の更新情報を設定します。
void | setOrdcompIn(String ordcompIn) 関連ユーザデータ項目の更新情報を設定します。
void | setOrderid(String orderid) 関連ユーザデータ項目の更新情報を設定します。
void | setOrderProb(String orderProb) 関連ユーザデータ項目の更新情報を設定します。
void | setOverdlvtol(String overdlvtol) 関連ユーザデータ項目の更新情報を設定します。
void | setOverhdKey(String overhdKey) 関連ユーザデータ項目の更新情報を設定します。
void | setPartDlv(String partDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setPlant(String plant) 関連ユーザデータ項目の更新情報を設定します。
void | setPldlvshdin(String pldlvshdin) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatExt(String pMatExt) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatGuid(String pMatGuid) 関連ユーザデータ項目の更新情報を設定します。
void | setPMatVers(String pMatVers) 関連ユーザデータ項目の更新情報を設定します。
void | setPmnttrms(String pmnttrms) 関連ユーザデータ項目の更新情報を設定します。
void | setPmtgarPro(String pmtgarPro) 関連ユーザデータ項目の更新情報を設定します。
void | setPoDatS(String poDatS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoItmNo(String poItmNo) 関連ユーザデータ項目の更新情報を設定します。
void | setPoitmNoS(String poitmNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethod(String poMethod) 関連ユーザデータ項目の更新情報を設定します。
void | setPoMethS(String poMethS) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup1(String prcGroup1) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup2(String prcGroup2) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup3(String prcGroup3) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup4(String prcGroup4) 関連ユーザデータ項目の更新情報を設定します。
void | setPrcGroup5(String prcGroup5) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceDate(String priceDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceGrp(String priceGrp) 関連ユーザデータ項目の更新情報を設定します。
void | setPriceList(String priceList) 関連ユーザデータ項目の更新情報を設定します。
void | setProdcat(String prodcat) 関連ユーザデータ項目の更新情報を設定します。
void | setProdHiera(String prodHiera) 関連ユーザデータ項目の更新情報を設定します。
void | setProfitCtr(String profitCtr) 関連ユーザデータ項目の更新情報を設定します。
void | setPromotion(String promotion) 関連ユーザデータ項目の更新情報を設定します。
void | setPrRefMat(String prRefMat) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchDate(String purchDate) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoC(String purchNoC) 関連ユーザデータ項目の更新情報を設定します。
void | setPurchNoS(String purchNoS) 関連ユーザデータ項目の更新情報を設定します。
void | setPymtMeth(String pymtMeth) 関連ユーザデータ項目の更新情報を設定します。
void | setReasonRej(String reasonRej) 関連ユーザデータ項目の更新情報を設定します。
void | setRecPoint(String recPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1(String ref1) 関連ユーザデータ項目の更新情報を設定します。
void | setRef1S(String ref1S) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDoc(String refDoc) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocCa(String refDocCa) 関連ユーザデータ項目の更新情報を設定します。
void | setRefDocIt(String refDocIt) 関連ユーザデータ項目の更新情報を設定します。
void | setReflogsys(String reflogsys) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjkey(String refobjkey) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjtype(String refobjtype) 関連ユーザデータ項目の更新情報を設定します。
void | setReqmtsTyp(String reqmtsTyp) 関連ユーザデータ項目の更新情報を設定します。
void | setResanalkey(String resanalkey) 関連ユーザデータ項目の更新情報を設定します。
void | setRevType(String revType) 関連ユーザデータ項目の更新情報を設定します。
void | setRnddlvQty(String rnddlvQty) 関連ユーザデータ項目の更新情報を設定します。
void | setRoute(String route) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesDist(String salesDist) 関連ユーザデータ項目の更新情報を設定します。
void | setSalesUnit(String salesUnit) 関連ユーザデータ項目の更新情報を設定します。
void | setSalqtyden(String salqtyden) 関連ユーザデータ項目の更新情報を設定します。
void | setSalqtynum(String salqtynum) 関連ユーザデータ項目の更新情報を設定します。
void | setSdTaxcode(String sdTaxcode) 関連ユーザデータ項目の更新情報を設定します。
void | setSelection(String selection) 関連ユーザデータ項目の更新情報を設定します。
void | setSeqNo(String seqNo) 関連ユーザデータ項目の更新情報を設定します。
void | setServDate(String servDate) 関連ユーザデータ項目の更新情報を設定します。
void | setShipPoint(String shipPoint) 関連ユーザデータ項目の更新情報を設定します。
void | setShipType(String shipType) 関連ユーザデータ項目の更新情報を設定します。
void | setShortText(String shortText) 関連ユーザデータ項目の更新情報を設定します。
void | setSProcInd(String sProcInd) 関連ユーザデータ項目の更新情報を設定します。
void | setStoreLoc(String storeLoc) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetQty(String targetQty) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetQu(String targetQu) 関連ユーザデータ項目の更新情報を設定します。
void | setTargetVal(String targetVal) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass1(String taxClass1) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass2(String taxClass2) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass3(String taxClass3) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass4(String taxClass4) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass5(String taxClass5) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass6(String taxClass6) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass7(String taxClass7) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass8(String taxClass8) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxClass9(String taxClass9) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxlawicms(String taxlawicms) 関連ユーザデータ項目の更新情報を設定します。
void | setTaxlawipi(String taxlawipi) 関連ユーザデータ項目の更新情報を設定します。
void | setTrgqtyDen(String trgqtyDen) 関連ユーザデータ項目の更新情報を設定します。
void | setTrgQtyNo(String trgQtyNo) 関連ユーザデータ項目の更新情報を設定します。
void | setTUnitIso(String tUnitIso) 関連ユーザデータ項目の更新情報を設定します。
void | setUnddlvTol(String unddlvTol) 関連ユーザデータ項目の更新情報を設定します。
void | setUnlmtDlv(String unlmtDlv) 関連ユーザデータ項目の更新情報を設定します。
void | setUntofWght(String untofWght) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
void | setUsageInd(String usageInd) 関連ユーザデータ項目の更新情報を設定します。
void | setValConI(String valConI) 関連ユーザデータ項目の更新情報を設定します。
void | setValContr(String valContr) 関連ユーザデータ項目の更新情報を設定します。
void | setValType(String valType) 関連ユーザデータ項目の更新情報を設定します。
void | setVolume(String volume) 関連ユーザデータ項目の更新情報を設定します。
void | setVolunit(String volunit) 関連ユーザデータ項目の更新情報を設定します。
void | setVwUepos(String vwUepos) 関連ユーザデータ項目の更新情報を設定します。
void | setWbsElem(String wbsElem) 関連ユーザデータ項目の更新情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ItemsInX

public ItemsInX()
明細データチェックボックス情報を作成します。

ItemsInX

public ItemsInX(int index)
明細データチェックボックス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getHgLvItem

public String getHgLvItem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
hgLvItem 関連ユーザデータ項目の更新情報

getPoItmNo

public String getPoItmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poItmNo 関連ユーザデータ項目の更新情報

getMaterial

public String getMaterial()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
material 関連ユーザデータ項目の更新情報

getAltToItm

public String getAltToItm()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
altToItm 関連ユーザデータ項目の更新情報

getCustMat22

public String getCustMat22()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custMat22 関連ユーザデータ項目の更新情報

getBatch

public String getBatch()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
batch 関連ユーザデータ項目の更新情報

getDlvGroup

public String getDlvGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvGroup 関連ユーザデータ項目の更新情報

getPartDlv

public String getPartDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
partDlv 関連ユーザデータ項目の更新情報

getReasonRej

public String getReasonRej()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reasonRej 関連ユーザデータ項目の更新情報

getBillBlock

public String getBillBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billBlock 関連ユーザデータ項目の更新情報

getBillDate

public String getBillDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billDate 関連ユーザデータ項目の更新情報

getPlant

public String getPlant()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
plant 関連ユーザデータ項目の更新情報

getStoreLoc

public String getStoreLoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
storeLoc 関連ユーザデータ項目の更新情報

getTargetQty

public String getTargetQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetQty 関連ユーザデータ項目の更新情報

getTargetQu

public String getTargetQu()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetQu 関連ユーザデータ項目の更新情報

getTUnitIso

public String getTUnitIso()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tUnitIso 関連ユーザデータ項目の更新情報

getItemCateg

public String getItemCateg()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itemCateg 関連ユーザデータ項目の更新情報

getShortText

public String getShortText()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shortText 関連ユーザデータ項目の更新情報

getPrcGroup1

public String getPrcGroup1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup1 関連ユーザデータ項目の更新情報

getPrcGroup2

public String getPrcGroup2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup2 関連ユーザデータ項目の更新情報

getPrcGroup3

public String getPrcGroup3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup3 関連ユーザデータ項目の更新情報

getPrcGroup4

public String getPrcGroup4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup4 関連ユーザデータ項目の更新情報

getPrcGroup5

public String getPrcGroup5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prcGroup5 関連ユーザデータ項目の更新情報

getProdHiera

public String getProdHiera()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prodHiera 関連ユーザデータ項目の更新情報

getMatlGroup

public String getMatlGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matlGroup 関連ユーザデータ項目の更新情報

getPurchNoC

public String getPurchNoC()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoC 関連ユーザデータ項目の更新情報

getPurchDate

public String getPurchDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchDate 関連ユーザデータ項目の更新情報

getPoMethod

public String getPoMethod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethod 関連ユーザデータ項目の更新情報

getRef1

public String getRef1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1 関連ユーザデータ項目の更新情報

getPurchNoS

public String getPurchNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
purchNoS 関連ユーザデータ項目の更新情報

getPoDatS

public String getPoDatS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poDatS 関連ユーザデータ項目の更新情報

getPoMethS

public String getPoMethS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poMethS 関連ユーザデータ項目の更新情報

getRef1S

public String getRef1S()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ref1S 関連ユーザデータ項目の更新情報

getPoitmNoS

public String getPoitmNoS()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
poitmNoS 関連ユーザデータ項目の更新情報

getPriceGrp

public String getPriceGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceGrp 関連ユーザデータ項目の更新情報

getCustGroup

public String getCustGroup()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custGroup 関連ユーザデータ項目の更新情報

getSalesDist

public String getSalesDist()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesDist 関連ユーザデータ項目の更新情報

getPriceList

public String getPriceList()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceList 関連ユーザデータ項目の更新情報

getIncoterms1

public String getIncoterms1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms1 関連ユーザデータ項目の更新情報

getIncoterms2

public String getIncoterms2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
incoterms2 関連ユーザデータ項目の更新情報

getOrdcompIn

public String getOrdcompIn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
ordcompIn 関連ユーザデータ項目の更新情報

getBillSched

public String getBillSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billSched 関連ユーザデータ項目の更新情報

getInvoSched

public String getInvoSched()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
invoSched 関連ユーザデータ項目の更新情報

getMnInvoice

public String getMnInvoice()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
mnInvoice 関連ユーザデータ項目の更新情報

getExRateFi

public String getExRateFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exRateFi 関連ユーザデータ項目の更新情報

getAddValDy

public String getAddValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
addValDy 関連ユーザデータ項目の更新情報

getFixValDy

public String getFixValDy()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixValDy 関連ユーザデータ項目の更新情報

getPmnttrms

public String getPmnttrms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmnttrms 関連ユーザデータ項目の更新情報

getPymtMeth

public String getPymtMeth()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pymtMeth 関連ユーザデータ項目の更新情報

getAccntAsgn

public String getAccntAsgn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
accntAsgn 関連ユーザデータ項目の更新情報

getExchgRate

public String getExchgRate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRate 関連ユーザデータ項目の更新情報

getPriceDate

public String getPriceDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
priceDate 関連ユーザデータ項目の更新情報

getServDate

public String getServDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
servDate 関連ユーザデータ項目の更新情報

getDunnKey

public String getDunnKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnKey 関連ユーザデータ項目の更新情報

getDunnBlock

public String getDunnBlock()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dunnBlock 関連ユーザデータ項目の更新情報

getPromotion

public String getPromotion()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
promotion 関連ユーザデータ項目の更新情報

getPmtgarPro

public String getPmtgarPro()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pmtgarPro 関連ユーザデータ項目の更新情報

getDocNumFi

public String getDocNumFi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
docNumFi 関連ユーザデータ項目の更新情報

getDepartmNo

public String getDepartmNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
departmNo 関連ユーザデータ項目の更新情報

getRecPoint

public String getRecPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
recPoint 関連ユーザデータ項目の更新情報

getCstcndgrp1

public String getCstcndgrp1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp1 関連ユーザデータ項目の更新情報

getCstcndgrp2

public String getCstcndgrp2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp2 関連ユーザデータ項目の更新情報

getCstcndgrp3

public String getCstcndgrp3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp3 関連ユーザデータ項目の更新情報

getCstcndgrp4

public String getCstcndgrp4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp4 関連ユーザデータ項目の更新情報

getCstcndgrp5

public String getCstcndgrp5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstcndgrp5 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getSalesUnit

public String getSalesUnit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salesUnit 関連ユーザデータ項目の更新情報

getTrgQtyNo

public String getTrgQtyNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
trgQtyNo 関連ユーザデータ項目の更新情報

getTrgqtyDen

public String getTrgqtyDen()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
trgqtyDen 関連ユーザデータ項目の更新情報

getRnddlvQty

public String getRnddlvQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
rnddlvQty 関連ユーザデータ項目の更新情報

getMaxdevamnt

public String getMaxdevamnt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevamnt 関連ユーザデータ項目の更新情報

getMaxdevper

public String getMaxdevper()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevper 関連ユーザデータ項目の更新情報

getMaxdevDay

public String getMaxdevDay()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxdevDay 関連ユーザデータ項目の更新情報

getUsageInd

public String getUsageInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
usageInd 関連ユーザデータ項目の更新情報

getFixedQuan

public String getFixedQuan()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixedQuan 関連ユーザデータ項目の更新情報

getUnlmtDlv

public String getUnlmtDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unlmtDlv 関連ユーザデータ項目の更新情報

getOverdlvtol

public String getOverdlvtol()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
overdlvtol 関連ユーザデータ項目の更新情報

getUnddlvTol

public String getUnddlvTol()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
unddlvTol 関連ユーザデータ項目の更新情報

getDivision

public String getDivision()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
division 関連ユーザデータ項目の更新情報

getSalqtynum

public String getSalqtynum()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salqtynum 関連ユーザデータ項目の更新情報

getSalqtyden

public String getSalqtyden()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
salqtyden 関連ユーザデータ項目の更新情報

getGrossWght

public String getGrossWght()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
grossWght 関連ユーザデータ項目の更新情報

getNetWeight

public String getNetWeight()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
netWeight 関連ユーザデータ項目の更新情報

getUntofWght

public String getUntofWght()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
untofWght 関連ユーザデータ項目の更新情報

getVolume

public String getVolume()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
volume 関連ユーザデータ項目の更新情報

getVolunit

public String getVolunit()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
volunit 関連ユーザデータ項目の更新情報

getDlvPrio

public String getDlvPrio()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvPrio 関連ユーザデータ項目の更新情報

getShipPoint

public String getShipPoint()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipPoint 関連ユーザデータ項目の更新情報

getRoute

public String getRoute()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
route 関連ユーザデータ項目の更新情報

getTaxClass1

public String getTaxClass1()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass1 関連ユーザデータ項目の更新情報

getTaxClass2

public String getTaxClass2()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass2 関連ユーザデータ項目の更新情報

getTaxClass3

public String getTaxClass3()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass3 関連ユーザデータ項目の更新情報

getTaxClass4

public String getTaxClass4()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass4 関連ユーザデータ項目の更新情報

getTaxClass5

public String getTaxClass5()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass5 関連ユーザデータ項目の更新情報

getTaxClass6

public String getTaxClass6()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass6 関連ユーザデータ項目の更新情報

getTaxClass7

public String getTaxClass7()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass7 関連ユーザデータ項目の更新情報

getTaxClass8

public String getTaxClass8()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass8 関連ユーザデータ項目の更新情報

getTaxClass9

public String getTaxClass9()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxClass9 関連ユーザデータ項目の更新情報

getMatPrGrp

public String getMatPrGrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matPrGrp 関連ユーザデータ項目の更新情報

getValType

public String getValType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valType 関連ユーザデータ項目の更新情報

getFixdatQty

public String getFixdatQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fixdatQty 関連ユーザデータ項目の更新情報

getBomexplNo

public String getBomexplNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
bomexplNo 関連ユーザデータ項目の更新情報

getResanalkey

public String getResanalkey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
resanalkey 関連ユーザデータ項目の更新情報

getReqmtsTyp

public String getReqmtsTyp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqmtsTyp 関連ユーザデータ項目の更新情報

getNoGrPost

public String getNoGrPost()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
noGrPost 関連ユーザデータ項目の更新情報

getBusTranst

public String getBusTranst()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
busTranst 関連ユーザデータ項目の更新情報

getOverhdKey

public String getOverhdKey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
overhdKey 関連ユーザデータ項目の更新情報

getCstgSheet

public String getCstgSheet()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cstgSheet 関連ユーザデータ項目の更新情報

getMatfrgtgrp

public String getMatfrgtgrp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matfrgtgrp 関連ユーザデータ項目の更新情報

getPldlvshdin

public String getPldlvshdin()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pldlvshdin 関連ユーザデータ項目の更新情報

getSeqNo

public String getSeqNo()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
seqNo 関連ユーザデータ項目の更新情報

getBilForm

public String getBilForm()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
bilForm 関連ユーザデータ項目の更新情報

getDliProfil

public String getDliProfil()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dliProfil 関連ユーザデータ項目の更新情報

getRevType

public String getRevType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
revType 関連ユーザデータ項目の更新情報

getBegdemPer

public String getBegdemPer()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
begdemPer 関連ユーザデータ項目の更新情報

getPrRefMat

public String getPrRefMat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prRefMat 関連ユーザデータ項目の更新情報

getRefobjtype

public String getRefobjtype()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refobjtype 関連ユーザデータ項目の更新情報

getRefobjkey

public String getRefobjkey()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refobjkey 関連ユーザデータ項目の更新情報

getReflogsys

public String getReflogsys()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reflogsys 関連ユーザデータ項目の更新情報

getOrderProb

public String getOrderProb()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
orderProb 関連ユーザデータ項目の更新情報

getMaxPlDlv

public String getMaxPlDlv()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
maxPlDlv 関連ユーザデータ項目の更新情報

getCfopCode

public String getCfopCode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
cfopCode 関連ユーザデータ項目の更新情報

getTaxlawicms

public String getTaxlawicms()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxlawicms 関連ユーザデータ項目の更新情報

getTaxlawipi

public String getTaxlawipi()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
taxlawipi 関連ユーザデータ項目の更新情報

getSdTaxcode

public String getSdTaxcode()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sdTaxcode 関連ユーザデータ項目の更新情報

getAssortMod

public String getAssortMod()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
assortMod 関連ユーザデータ項目の更新情報

getCompQuant

public String getCompQuant()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
compQuant 関連ユーザデータ項目の更新情報

getTargetVal

public String getTargetVal()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
targetVal 関連ユーザデータ項目の更新情報

getProfitCtr

public String getProfitCtr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
profitCtr 関連ユーザデータ項目の更新情報

getOrderid

public String getOrderid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
orderid 関連ユーザデータ項目の更新情報

getWbsElem

public String getWbsElem()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
wbsElem 関連ユーザデータ項目の更新情報

getDeprecPer

public String getDeprecPer()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
deprecPer 関連ユーザデータ項目の更新情報

getRefDoc

public String getRefDoc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDoc 関連ユーザデータ項目の更新情報

getRefDocIt

public String getRefDocIt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocIt 関連ユーザデータ項目の更新情報

getRefDocCa

public String getRefDocCa()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
refDocCa 関連ユーザデータ項目の更新情報

getCustMat35

public String getCustMat35()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
custMat35 関連ユーザデータ項目の更新情報

getExchRateFiV

public String getExchRateFiV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchRateFiV 関連ユーザデータ項目の更新情報

getExchgRateV

public String getExchgRateV()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
exchgRateV 関連ユーザデータ項目の更新情報

getItemguidAtp

public String getItemguidAtp()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itemguidAtp 関連ユーザデータ項目の更新情報

getValContr

public String getValContr()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valContr 関連ユーザデータ項目の更新情報

getValConI

public String getValConI()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
valConI 関連ユーザデータ項目の更新情報

getConfigId

public String getConfigId()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
configId 関連ユーザデータ項目の更新情報

getInstId

public String getInstId()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
instId 関連ユーザデータ項目の更新情報

getMatExt

public String getMatExt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matExt 関連ユーザデータ項目の更新情報

getMatGuid

public String getMatGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matGuid 関連ユーザデータ項目の更新情報

getMatVers

public String getMatVers()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matVers 関連ユーザデータ項目の更新情報

getPMatExt

public String getPMatExt()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatExt 関連ユーザデータ項目の更新情報

getPMatGuid

public String getPMatGuid()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatGuid 関連ユーザデータ項目の更新情報

getPMatVers

public String getPMatVers()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
pMatVers 関連ユーザデータ項目の更新情報

getFuncArea

public String getFuncArea()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
funcArea 関連ユーザデータ項目の更新情報

getAlternBom

public String getAlternBom()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
alternBom 関連ユーザデータ項目の更新情報

getFkkConacct

public String getFkkConacct()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
fkkConacct 関連ユーザデータ項目の更新情報

getEanUpc

public String getEanUpc()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
eanUpc 関連ユーザデータ項目の更新情報

getProdcat

public String getProdcat()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
prodcat 関連ユーザデータ項目の更新情報

getShipType

public String getShipType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
shipType 関連ユーザデータ項目の更新情報

getSProcInd

public String getSProcInd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
sProcInd 関連ユーザデータ項目の更新情報

getBillRel

public String getBillRel()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
billRel 関連ユーザデータ項目の更新情報

getVwUepos

public String getVwUepos()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
vwUepos 関連ユーザデータ項目の更新情報

getCampaign

public String getCampaign()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
campaign 関連ユーザデータ項目の更新情報

getDlvschduse

public String getDlvschduse()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvschduse 関連ユーザデータ項目の更新情報

getSelection

public String getSelection()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
selection 関連ユーザデータ項目の更新情報

getMatEntrd

public String getMatEntrd()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
matEntrd 関連ユーザデータ項目の更新情報

getLogSystemOwn

public String getLogSystemOwn()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
logSystemOwn 関連ユーザデータ項目の更新情報

getItmTypeUsage

public String getItmTypeUsage()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
itmTypeUsage 関連ユーザデータ項目の更新情報

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setHgLvItem

public void setHgLvItem(String hgLvItem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
hgLvItem - 関連ユーザデータ項目の更新情報

setPoItmNo

public void setPoItmNo(String poItmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poItmNo - 関連ユーザデータ項目の更新情報

setMaterial

public void setMaterial(String material)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
material - 関連ユーザデータ項目の更新情報

setAltToItm

public void setAltToItm(String altToItm)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
altToItm - 関連ユーザデータ項目の更新情報

setCustMat22

public void setCustMat22(String custMat22)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custMat22 - 関連ユーザデータ項目の更新情報

setBatch

public void setBatch(String batch)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
batch - 関連ユーザデータ項目の更新情報

setDlvGroup

public void setDlvGroup(String dlvGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvGroup - 関連ユーザデータ項目の更新情報

setPartDlv

public void setPartDlv(String partDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
partDlv - 関連ユーザデータ項目の更新情報

setReasonRej

public void setReasonRej(String reasonRej)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reasonRej - 関連ユーザデータ項目の更新情報

setBillBlock

public void setBillBlock(String billBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billBlock - 関連ユーザデータ項目の更新情報

setBillDate

public void setBillDate(String billDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billDate - 関連ユーザデータ項目の更新情報

setPlant

public void setPlant(String plant)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
plant - 関連ユーザデータ項目の更新情報

setStoreLoc

public void setStoreLoc(String storeLoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
storeLoc - 関連ユーザデータ項目の更新情報

setTargetQty

public void setTargetQty(String targetQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetQty - 関連ユーザデータ項目の更新情報

setTargetQu

public void setTargetQu(String targetQu)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetQu - 関連ユーザデータ項目の更新情報

setTUnitIso

public void setTUnitIso(String tUnitIso)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tUnitIso - 関連ユーザデータ項目の更新情報

setItemCateg

public void setItemCateg(String itemCateg)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itemCateg - 関連ユーザデータ項目の更新情報

setShortText

public void setShortText(String shortText)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shortText - 関連ユーザデータ項目の更新情報

setPrcGroup1

public void setPrcGroup1(String prcGroup1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup1 - 関連ユーザデータ項目の更新情報

setPrcGroup2

public void setPrcGroup2(String prcGroup2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup2 - 関連ユーザデータ項目の更新情報

setPrcGroup3

public void setPrcGroup3(String prcGroup3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup3 - 関連ユーザデータ項目の更新情報

setPrcGroup4

public void setPrcGroup4(String prcGroup4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup4 - 関連ユーザデータ項目の更新情報

setPrcGroup5

public void setPrcGroup5(String prcGroup5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prcGroup5 - 関連ユーザデータ項目の更新情報

setProdHiera

public void setProdHiera(String prodHiera)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prodHiera - 関連ユーザデータ項目の更新情報

setMatlGroup

public void setMatlGroup(String matlGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matlGroup - 関連ユーザデータ項目の更新情報

setPurchNoC

public void setPurchNoC(String purchNoC)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoC - 関連ユーザデータ項目の更新情報

setPurchDate

public void setPurchDate(String purchDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchDate - 関連ユーザデータ項目の更新情報

setPoMethod

public void setPoMethod(String poMethod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethod - 関連ユーザデータ項目の更新情報

setRef1

public void setRef1(String ref1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1 - 関連ユーザデータ項目の更新情報

setPurchNoS

public void setPurchNoS(String purchNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
purchNoS - 関連ユーザデータ項目の更新情報

setPoDatS

public void setPoDatS(String poDatS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poDatS - 関連ユーザデータ項目の更新情報

setPoMethS

public void setPoMethS(String poMethS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poMethS - 関連ユーザデータ項目の更新情報

setRef1S

public void setRef1S(String ref1S)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ref1S - 関連ユーザデータ項目の更新情報

setPoitmNoS

public void setPoitmNoS(String poitmNoS)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
poitmNoS - 関連ユーザデータ項目の更新情報

setPriceGrp

public void setPriceGrp(String priceGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceGrp - 関連ユーザデータ項目の更新情報

setCustGroup

public void setCustGroup(String custGroup)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custGroup - 関連ユーザデータ項目の更新情報

setSalesDist

public void setSalesDist(String salesDist)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesDist - 関連ユーザデータ項目の更新情報

setPriceList

public void setPriceList(String priceList)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceList - 関連ユーザデータ項目の更新情報

setIncoterms1

public void setIncoterms1(String incoterms1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms1 - 関連ユーザデータ項目の更新情報

setIncoterms2

public void setIncoterms2(String incoterms2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
incoterms2 - 関連ユーザデータ項目の更新情報

setOrdcompIn

public void setOrdcompIn(String ordcompIn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
ordcompIn - 関連ユーザデータ項目の更新情報

setBillSched

public void setBillSched(String billSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billSched - 関連ユーザデータ項目の更新情報

setInvoSched

public void setInvoSched(String invoSched)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
invoSched - 関連ユーザデータ項目の更新情報

setMnInvoice

public void setMnInvoice(String mnInvoice)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
mnInvoice - 関連ユーザデータ項目の更新情報

setExRateFi

public void setExRateFi(String exRateFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exRateFi - 関連ユーザデータ項目の更新情報

setAddValDy

public void setAddValDy(String addValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
addValDy - 関連ユーザデータ項目の更新情報

setFixValDy

public void setFixValDy(String fixValDy)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixValDy - 関連ユーザデータ項目の更新情報

setPmnttrms

public void setPmnttrms(String pmnttrms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmnttrms - 関連ユーザデータ項目の更新情報

setPymtMeth

public void setPymtMeth(String pymtMeth)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pymtMeth - 関連ユーザデータ項目の更新情報

setAccntAsgn

public void setAccntAsgn(String accntAsgn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
accntAsgn - 関連ユーザデータ項目の更新情報

setExchgRate

public void setExchgRate(String exchgRate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRate - 関連ユーザデータ項目の更新情報

setPriceDate

public void setPriceDate(String priceDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
priceDate - 関連ユーザデータ項目の更新情報

setServDate

public void setServDate(String servDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
servDate - 関連ユーザデータ項目の更新情報

setDunnKey

public void setDunnKey(String dunnKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnKey - 関連ユーザデータ項目の更新情報

setDunnBlock

public void setDunnBlock(String dunnBlock)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dunnBlock - 関連ユーザデータ項目の更新情報

setPromotion

public void setPromotion(String promotion)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
promotion - 関連ユーザデータ項目の更新情報

setPmtgarPro

public void setPmtgarPro(String pmtgarPro)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pmtgarPro - 関連ユーザデータ項目の更新情報

setDocNumFi

public void setDocNumFi(String docNumFi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
docNumFi - 関連ユーザデータ項目の更新情報

setDepartmNo

public void setDepartmNo(String departmNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
departmNo - 関連ユーザデータ項目の更新情報

setRecPoint

public void setRecPoint(String recPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
recPoint - 関連ユーザデータ項目の更新情報

setCstcndgrp1

public void setCstcndgrp1(String cstcndgrp1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp1 - 関連ユーザデータ項目の更新情報

setCstcndgrp2

public void setCstcndgrp2(String cstcndgrp2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp2 - 関連ユーザデータ項目の更新情報

setCstcndgrp3

public void setCstcndgrp3(String cstcndgrp3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp3 - 関連ユーザデータ項目の更新情報

setCstcndgrp4

public void setCstcndgrp4(String cstcndgrp4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp4 - 関連ユーザデータ項目の更新情報

setCstcndgrp5

public void setCstcndgrp5(String cstcndgrp5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstcndgrp5 - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setSalesUnit

public void setSalesUnit(String salesUnit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salesUnit - 関連ユーザデータ項目の更新情報

setTrgQtyNo

public void setTrgQtyNo(String trgQtyNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
trgQtyNo - 関連ユーザデータ項目の更新情報

setTrgqtyDen

public void setTrgqtyDen(String trgqtyDen)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
trgqtyDen - 関連ユーザデータ項目の更新情報

setRnddlvQty

public void setRnddlvQty(String rnddlvQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
rnddlvQty - 関連ユーザデータ項目の更新情報

setMaxdevamnt

public void setMaxdevamnt(String maxdevamnt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevamnt - 関連ユーザデータ項目の更新情報

setMaxdevper

public void setMaxdevper(String maxdevper)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevper - 関連ユーザデータ項目の更新情報

setMaxdevDay

public void setMaxdevDay(String maxdevDay)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxdevDay - 関連ユーザデータ項目の更新情報

setUsageInd

public void setUsageInd(String usageInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
usageInd - 関連ユーザデータ項目の更新情報

setFixedQuan

public void setFixedQuan(String fixedQuan)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixedQuan - 関連ユーザデータ項目の更新情報

setUnlmtDlv

public void setUnlmtDlv(String unlmtDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unlmtDlv - 関連ユーザデータ項目の更新情報

setOverdlvtol

public void setOverdlvtol(String overdlvtol)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
overdlvtol - 関連ユーザデータ項目の更新情報

setUnddlvTol

public void setUnddlvTol(String unddlvTol)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
unddlvTol - 関連ユーザデータ項目の更新情報

setDivision

public void setDivision(String division)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
division - 関連ユーザデータ項目の更新情報

setSalqtynum

public void setSalqtynum(String salqtynum)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salqtynum - 関連ユーザデータ項目の更新情報

setSalqtyden

public void setSalqtyden(String salqtyden)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
salqtyden - 関連ユーザデータ項目の更新情報

setGrossWght

public void setGrossWght(String grossWght)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
grossWght - 関連ユーザデータ項目の更新情報

setNetWeight

public void setNetWeight(String netWeight)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
netWeight - 関連ユーザデータ項目の更新情報

setUntofWght

public void setUntofWght(String untofWght)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
untofWght - 関連ユーザデータ項目の更新情報

setVolume

public void setVolume(String volume)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
volume - 関連ユーザデータ項目の更新情報

setVolunit

public void setVolunit(String volunit)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
volunit - 関連ユーザデータ項目の更新情報

setDlvPrio

public void setDlvPrio(String dlvPrio)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvPrio - 関連ユーザデータ項目の更新情報

setShipPoint

public void setShipPoint(String shipPoint)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipPoint - 関連ユーザデータ項目の更新情報

setRoute

public void setRoute(String route)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
route - 関連ユーザデータ項目の更新情報

setTaxClass1

public void setTaxClass1(String taxClass1)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass1 - 関連ユーザデータ項目の更新情報

setTaxClass2

public void setTaxClass2(String taxClass2)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass2 - 関連ユーザデータ項目の更新情報

setTaxClass3

public void setTaxClass3(String taxClass3)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass3 - 関連ユーザデータ項目の更新情報

setTaxClass4

public void setTaxClass4(String taxClass4)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass4 - 関連ユーザデータ項目の更新情報

setTaxClass5

public void setTaxClass5(String taxClass5)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass5 - 関連ユーザデータ項目の更新情報

setTaxClass6

public void setTaxClass6(String taxClass6)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass6 - 関連ユーザデータ項目の更新情報

setTaxClass7

public void setTaxClass7(String taxClass7)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass7 - 関連ユーザデータ項目の更新情報

setTaxClass8

public void setTaxClass8(String taxClass8)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass8 - 関連ユーザデータ項目の更新情報

setTaxClass9

public void setTaxClass9(String taxClass9)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxClass9 - 関連ユーザデータ項目の更新情報

setMatPrGrp

public void setMatPrGrp(String matPrGrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matPrGrp - 関連ユーザデータ項目の更新情報

setValType

public void setValType(String valType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valType - 関連ユーザデータ項目の更新情報

setFixdatQty

public void setFixdatQty(String fixdatQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fixdatQty - 関連ユーザデータ項目の更新情報

setBomexplNo

public void setBomexplNo(String bomexplNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
bomexplNo - 関連ユーザデータ項目の更新情報

setResanalkey

public void setResanalkey(String resanalkey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
resanalkey - 関連ユーザデータ項目の更新情報

setReqmtsTyp

public void setReqmtsTyp(String reqmtsTyp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqmtsTyp - 関連ユーザデータ項目の更新情報

setNoGrPost

public void setNoGrPost(String noGrPost)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
noGrPost - 関連ユーザデータ項目の更新情報

setBusTranst

public void setBusTranst(String busTranst)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
busTranst - 関連ユーザデータ項目の更新情報

setOverhdKey

public void setOverhdKey(String overhdKey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
overhdKey - 関連ユーザデータ項目の更新情報

setCstgSheet

public void setCstgSheet(String cstgSheet)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cstgSheet - 関連ユーザデータ項目の更新情報

setMatfrgtgrp

public void setMatfrgtgrp(String matfrgtgrp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matfrgtgrp - 関連ユーザデータ項目の更新情報

setPldlvshdin

public void setPldlvshdin(String pldlvshdin)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pldlvshdin - 関連ユーザデータ項目の更新情報

setSeqNo

public void setSeqNo(String seqNo)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
seqNo - 関連ユーザデータ項目の更新情報

setBilForm

public void setBilForm(String bilForm)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
bilForm - 関連ユーザデータ項目の更新情報

setDliProfil

public void setDliProfil(String dliProfil)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dliProfil - 関連ユーザデータ項目の更新情報

setRevType

public void setRevType(String revType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
revType - 関連ユーザデータ項目の更新情報

setBegdemPer

public void setBegdemPer(String begdemPer)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
begdemPer - 関連ユーザデータ項目の更新情報

setPrRefMat

public void setPrRefMat(String prRefMat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prRefMat - 関連ユーザデータ項目の更新情報

setRefobjtype

public void setRefobjtype(String refobjtype)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refobjtype - 関連ユーザデータ項目の更新情報

setRefobjkey

public void setRefobjkey(String refobjkey)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refobjkey - 関連ユーザデータ項目の更新情報

setReflogsys

public void setReflogsys(String reflogsys)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reflogsys - 関連ユーザデータ項目の更新情報

setOrderProb

public void setOrderProb(String orderProb)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
orderProb - 関連ユーザデータ項目の更新情報

setMaxPlDlv

public void setMaxPlDlv(String maxPlDlv)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
maxPlDlv - 関連ユーザデータ項目の更新情報

setCfopCode

public void setCfopCode(String cfopCode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
cfopCode - 関連ユーザデータ項目の更新情報

setTaxlawicms

public void setTaxlawicms(String taxlawicms)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxlawicms - 関連ユーザデータ項目の更新情報

setTaxlawipi

public void setTaxlawipi(String taxlawipi)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
taxlawipi - 関連ユーザデータ項目の更新情報

setSdTaxcode

public void setSdTaxcode(String sdTaxcode)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sdTaxcode - 関連ユーザデータ項目の更新情報

setAssortMod

public void setAssortMod(String assortMod)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
assortMod - 関連ユーザデータ項目の更新情報

setCompQuant

public void setCompQuant(String compQuant)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
compQuant - 関連ユーザデータ項目の更新情報

setTargetVal

public void setTargetVal(String targetVal)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
targetVal - 関連ユーザデータ項目の更新情報

setProfitCtr

public void setProfitCtr(String profitCtr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
profitCtr - 関連ユーザデータ項目の更新情報

setOrderid

public void setOrderid(String orderid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
orderid - 関連ユーザデータ項目の更新情報

setWbsElem

public void setWbsElem(String wbsElem)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
wbsElem - 関連ユーザデータ項目の更新情報

setDeprecPer

public void setDeprecPer(String deprecPer)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
deprecPer - 関連ユーザデータ項目の更新情報

setRefDoc

public void setRefDoc(String refDoc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDoc - 関連ユーザデータ項目の更新情報

setRefDocIt

public void setRefDocIt(String refDocIt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocIt - 関連ユーザデータ項目の更新情報

setRefDocCa

public void setRefDocCa(String refDocCa)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
refDocCa - 関連ユーザデータ項目の更新情報

setCustMat35

public void setCustMat35(String custMat35)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
custMat35 - 関連ユーザデータ項目の更新情報

setExchRateFiV

public void setExchRateFiV(String exchRateFiV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchRateFiV - 関連ユーザデータ項目の更新情報

setExchgRateV

public void setExchgRateV(String exchgRateV)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
exchgRateV - 関連ユーザデータ項目の更新情報

setItemguidAtp

public void setItemguidAtp(String itemguidAtp)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itemguidAtp - 関連ユーザデータ項目の更新情報

setValContr

public void setValContr(String valContr)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valContr - 関連ユーザデータ項目の更新情報

setValConI

public void setValConI(String valConI)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
valConI - 関連ユーザデータ項目の更新情報

setConfigId

public void setConfigId(String configId)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
configId - 関連ユーザデータ項目の更新情報

setInstId

public void setInstId(String instId)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
instId - 関連ユーザデータ項目の更新情報

setMatExt

public void setMatExt(String matExt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matExt - 関連ユーザデータ項目の更新情報

setMatGuid

public void setMatGuid(String matGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matGuid - 関連ユーザデータ項目の更新情報

setMatVers

public void setMatVers(String matVers)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matVers - 関連ユーザデータ項目の更新情報

setPMatExt

public void setPMatExt(String pMatExt)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatExt - 関連ユーザデータ項目の更新情報

setPMatGuid

public void setPMatGuid(String pMatGuid)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatGuid - 関連ユーザデータ項目の更新情報

setPMatVers

public void setPMatVers(String pMatVers)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
pMatVers - 関連ユーザデータ項目の更新情報

setFuncArea

public void setFuncArea(String funcArea)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
funcArea - 関連ユーザデータ項目の更新情報

setAlternBom

public void setAlternBom(String alternBom)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
alternBom - 関連ユーザデータ項目の更新情報

setFkkConacct

public void setFkkConacct(String fkkConacct)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
fkkConacct - 関連ユーザデータ項目の更新情報

setEanUpc

public void setEanUpc(String eanUpc)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
eanUpc - 関連ユーザデータ項目の更新情報

setProdcat

public void setProdcat(String prodcat)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
prodcat - 関連ユーザデータ項目の更新情報

setShipType

public void setShipType(String shipType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
shipType - 関連ユーザデータ項目の更新情報

setSProcInd

public void setSProcInd(String sProcInd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
sProcInd - 関連ユーザデータ項目の更新情報

setBillRel

public void setBillRel(String billRel)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
billRel - 関連ユーザデータ項目の更新情報

setVwUepos

public void setVwUepos(String vwUepos)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
vwUepos - 関連ユーザデータ項目の更新情報

setCampaign

public void setCampaign(String campaign)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
campaign - 関連ユーザデータ項目の更新情報

setDlvschduse

public void setDlvschduse(String dlvschduse)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvschduse - 関連ユーザデータ項目の更新情報

setSelection

public void setSelection(String selection)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
selection - 関連ユーザデータ項目の更新情報

setMatEntrd

public void setMatEntrd(String matEntrd)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
matEntrd - 関連ユーザデータ項目の更新情報

setLogSystemOwn

public void setLogSystemOwn(String logSystemOwn)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
logSystemOwn - 関連ユーザデータ項目の更新情報

setItmTypeUsage

public void setItmTypeUsage(String itmTypeUsage)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
itmTypeUsage - 関連ユーザデータ項目の更新情報

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Keys (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Keys

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys
すべての実装インタフェース:
Serializable
public class Keys
extends Object
implements Serializable

参照キーの出力テーブル情報クラス
機能は以下の通り

  • 参照キーの出力テーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Keys()
参照キーの出力テーブル情報を作成します。
Keys(int index)
参照キーの出力テーブル情報を作成します。
メソッドの概要
String | getAbart() 承認タイプを取得します。
String | getAbrli() 内部納入日程番号を取得します。
String | getAddress() 住所を取得します。
String | getCondCount() 条件カウンタを取得します。
String | getConditemno() 条件明細番号を取得します。
String | getCondNo() 伝票条件番号を取得します。
String | getCondStNo() ステップ番号を取得します。
String | getCondType() 条件タイプを取得します。
String | getDocNumber() 販売管理伝票番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobject() オブジェクト名を取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtyp() オブジェクトタイプを取得します。
String | getSchedLin() 納入日程行を取得します。
String | getStatus() 単一文字フラグを取得します。
String | getTindex() 数値項目: 長さ 6を取得します。
void | setAbart(String abart) 承認タイプを設定します。
void | setAbrli(String abrli) 内部納入日程番号を設定します。
void | setAddress(String address) 住所を設定します。
void | setCondCount(String condCount) 条件カウンタを設定します。
void | setConditemno(String conditemno) 条件明細番号を設定します。
void | setCondNo(String condNo) 伝票条件番号を設定します。
void | setCondStNo(String condStNo) ステップ番号を設定します。
void | setCondType(String condType) 条件タイプを設定します。
void | setDocNumber(String docNumber) 販売管理伝票番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobject(String refobject) オブジェクト名を設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtyp(String refobjtyp) オブジェクトタイプを設定します。
void | setSchedLin(String schedLin) 納入日程行を設定します。
void | setStatus(String status) 単一文字フラグを設定します。
void | setTindex(String tindex) 数値項目: 長さ 6を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Keys

public Keys()
参照キーの出力テーブル情報を作成します。

Keys

public Keys(int index)
参照キーの出力テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefobjtyp

public String getRefobjtyp()
オブジェクトタイプを取得します。

戻り値:
refobjtyp オブジェクトタイプ

getRefobject

public String getRefobject()
オブジェクト名を取得します。

戻り値:
refobject オブジェクト名

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getDocNumber

public String getDocNumber()
販売管理伝票番号を取得します。

戻り値:
docNumber 販売管理伝票番号

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLin

public String getSchedLin()
納入日程行を取得します。

戻り値:
schedLin 納入日程行

getCondNo

public String getCondNo()
伝票条件番号を取得します。

戻り値:
condNo 伝票条件番号

getConditemno

public String getConditemno()
条件明細番号を取得します。

戻り値:
conditemno 条件明細番号

getCondStNo

public String getCondStNo()
ステップ番号を取得します。

戻り値:
condStNo ステップ番号

getCondCount

public String getCondCount()
条件カウンタを取得します。

戻り値:
condCount 条件カウンタ

getCondType

public String getCondType()
条件タイプを取得します。

戻り値:
condType 条件タイプ

getStatus

public String getStatus()
単一文字フラグを取得します。

戻り値:
status 単一文字フラグ

getTindex

public String getTindex()
数値項目: 長さ 6を取得します。

戻り値:
tindex 数値項目: 長さ 6

getAddress

public String getAddress()
住所を取得します。

戻り値:
address 住所

getAbrli

public String getAbrli()
内部納入日程番号を取得します。

戻り値:
abrli 内部納入日程番号

getAbart

public String getAbart()
承認タイプを取得します。

戻り値:
abart 承認タイプ

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefobjtyp

public void setRefobjtyp(String refobjtyp)
オブジェクトタイプを設定します。

パラメータ:
refobjtyp - オブジェクトタイプ

setRefobject

public void setRefobject(String refobject)
オブジェクト名を設定します。

パラメータ:
refobject - オブジェクト名

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setDocNumber

public void setDocNumber(String docNumber)
販売管理伝票番号を設定します。

パラメータ:
docNumber - 販売管理伝票番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLin

public void setSchedLin(String schedLin)
納入日程行を設定します。

パラメータ:
schedLin - 納入日程行

setCondNo

public void setCondNo(String condNo)
伝票条件番号を設定します。

パラメータ:
condNo - 伝票条件番号

setConditemno

public void setConditemno(String conditemno)
条件明細番号を設定します。

パラメータ:
conditemno - 条件明細番号

setCondStNo

public void setCondStNo(String condStNo)
ステップ番号を設定します。

パラメータ:
condStNo - ステップ番号

setCondCount

public void setCondCount(String condCount)
条件カウンタを設定します。

パラメータ:
condCount - 条件カウンタ

setCondType

public void setCondType(String condType)
条件タイプを設定します。

パラメータ:
condType - 条件タイプ

setStatus

public void setStatus(String status)
単一文字フラグを設定します。

パラメータ:
status - 単一文字フラグ

setTindex

public void setTindex(String tindex)
数値項目: 長さ 6を設定します。

パラメータ:
tindex - 数値項目: 長さ 6

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所

setAbrli

public void setAbrli(String abrli)
内部納入日程番号を設定します。

パラメータ:
abrli - 内部納入日程番号

setAbart

public void setAbart(String abart)
承認タイプを設定します。

パラメータ:
abart - 承認タイプ

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LogicSwitch (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス LogicSwitch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch
すべての実装インタフェース:
Serializable
public class LogicSwitch
extends Object
implements Serializable

内部制御パラメータ情報クラス
機能は以下の通り

  • 内部制御パラメータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
LogicSwitch()
内部制御パラメータ情報を作成します。
メソッドの概要
String | getAtpWrkmod() ATP セッション: 結果取得/新規決定 APO-ATPを取得します。
String | getCondHandl() 選択: 条件行処理 (SD 伝票変更)を取得します。
String | getNostructure() チェックボックスを取得します。
String | getPricing() 価格設定タイプを取得します。
String | getScheduling() 単一文字フラグを取得します。
void | setAtpWrkmod(String atpWrkmod) ATP セッション: 結果取得/新規決定 APO-ATPを設定します。
void | setCondHandl(String condHandl) 選択: 条件行処理 (SD 伝票変更)を設定します。
void | setNostructure(String nostructure) チェックボックスを設定します。
void | setPricing(String pricing) 価格設定タイプを設定します。
void | setScheduling(String scheduling) 単一文字フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LogicSwitch

public LogicSwitch()
内部制御パラメータ情報を作成します。

メソッドの詳細

getPricing

public String getPricing()
価格設定タイプを取得します。

戻り値:
pricing 価格設定タイプ

getAtpWrkmod

public String getAtpWrkmod()
ATP セッション: 結果取得/新規決定 APO-ATPを取得します。

戻り値:
atpWrkmod ATP セッション: 結果取得/新規決定 APO-ATP

getScheduling

public String getScheduling()
単一文字フラグを取得します。

戻り値:
scheduling 単一文字フラグ

getNostructure

public String getNostructure()
チェックボックスを取得します。

戻り値:
nostructure チェックボックス

getCondHandl

public String getCondHandl()
選択: 条件行処理 (SD 伝票変更)を取得します。

戻り値:
condHandl 選択: 条件行処理 (SD 伝票変更)

setPricing

public void setPricing(String pricing)
価格設定タイプを設定します。

パラメータ:
pricing - 価格設定タイプ

setAtpWrkmod

public void setAtpWrkmod(String atpWrkmod)
ATP セッション: 結果取得/新規決定 APO-ATPを設定します。

パラメータ:
atpWrkmod - ATP セッション: 結果取得/新規決定 APO-ATP

setScheduling

public void setScheduling(String scheduling)
単一文字フラグを設定します。

パラメータ:
scheduling - 単一文字フラグ

setNostructure

public void setNostructure(String nostructure)
チェックボックスを設定します。

パラメータ:
nostructure - チェックボックス

setCondHandl

public void setCondHandl(String condHandl)
選択: 条件行処理 (SD 伝票変更)を設定します。

パラメータ:
condHandl - 選択: 条件行処理 (SD 伝票変更)

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.common.model (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス
BillingDocumentDetail
BillingDocumentDetailList
CfgsBlob
CfgsInst
CfgsPartOf
CfgsRef
CfgsRefInst
CfgsValue
CfgsVk
ConditionsIn
ConditionsInX
ExtensionIn
HeaderIn
HeaderInX
ItemsIn
ItemsInX
Keys
LogicSwitch
ParamBillingDocumentDetailList
ParamCfgsBlob
ParamCfgsInst
ParamCfgsPartOf
ParamCfgsRef
ParamCfgsRefInst
ParamCfgsValue
ParamCfgsVk
ParamConditionsIn
ParamConditionsInX
ParamExtensionIn
ParamHeaderIn
ParamHeaderInX
ParamItemsIn
ParamItemsInX
ParamKeys
ParamLogicSwitch
ParamPartnerAddresses
ParamPartners
ParamSchedulesIn
ParamSchedulesInX
ParamSender
ParamSuccess
ParamText
PartnerAddresses
Partners
SchedulesIn
SchedulesInX
Sender
Success
Text


jp.co.intra_mart.foundation.sap.module.sales.common.model (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model

クラスの概要
BillingDocumentDetail | 後続請求伝票のテーブル情報クラス 機能は以下の通り 後続請求伝票のテーブル情報を保持します。
BillingDocumentDetailList | 後続請求伝票のテーブル情報クラス 機能は以下の通り 後続請求伝票のテーブル情報を保持します。
CfgsBlob | 選定: BLOB 内部データ (SCE)情報クラス 機能は以下の通り 選定: BLOB 内部データ (SCE)情報を保持します。
CfgsInst | 選定: インスタンス情報クラス 機能は以下の通り 選定: インスタンス情報を保持します。
CfgsPartOf | 選定: 部分設定情報クラス 機能は以下の通り 選定: 部分設定情報を保持します。
CfgsRef | 選定: 参照データ情報クラス 機能は以下の通り 選定: 参照データ情報を保持します。
CfgsRefInst | 選定: 参照明細/インスタンス情報クラス 機能は以下の通り 選定: 参照明細/インスタンス情報を保持します。
CfgsValue | 選定: 特性値情報クラス 機能は以下の通り 選定: 特性値情報を保持します。
CfgsVk | 選定: バリアント条件キー情報クラス 機能は以下の通り 選定: バリアント条件キー情報を保持します。
ConditionsIn | 条件情報クラス 機能は以下の通り 条件情報を保持します。
ConditionsInX | 受注における条件更新の通信項目情報クラス 機能は以下の通り 受注における条件更新の通信項目情報を保持します。
ExtensionIn | VBAK、VBAP、VBEP のカスタマ拡張情報クラス 機能は以下の通り VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。
HeaderIn | 販売伝票ヘッダデータ情報クラス 機能は以下の通り 販売伝票ヘッダデータ情報を保持します。
HeaderInX | ヘッダデータチェックボックス情報クラス 機能は以下の通り ヘッダデータチェックボックス情報を保持します。
ItemsIn | 明細データ情報クラス 機能は以下の通り 明細データ情報を保持します。
ItemsInX | 明細データチェックボックス情報クラス 機能は以下の通り 明細データチェックボックス情報を保持します。
Keys | 参照キーの出力テーブル情報クラス 機能は以下の通り 参照キーの出力テーブル情報を保持します。
LogicSwitch | 内部制御パラメータ情報クラス 機能は以下の通り 内部制御パラメータ情報を保持します。
ParamBillingDocumentDetailList | 後続請求伝票のテーブルパラメータ設定クラス 機能は以下の通り 後続請求伝票のテーブルのパラメータを設定します。
ParamCfgsBlob | 選定: BLOB 内部データ (SCE)パラメータ設定クラス 機能は以下の通り 選定: BLOB 内部データ (SCE)のパラメータを設定します。
ParamCfgsInst | 選定: インスタンスパラメータ設定クラス 機能は以下の通り 選定: インスタンスのパラメータを設定します。
ParamCfgsPartOf | 選定: 部分設定パラメータ設定クラス 機能は以下の通り 選定: 部分設定のパラメータを設定します。
ParamCfgsRef | 選定: 参照データパラメータ設定クラス 機能は以下の通り 選定: 参照データのパラメータを設定します。
ParamCfgsRefInst | 選定: 参照明細/インスタンスパラメータ設定クラス 機能は以下の通り 選定: 参照明細/インスタンスのパラメータを設定します。
ParamCfgsValue | 選定: 特性値パラメータ設定クラス 機能は以下の通り 選定: 特性値のパラメータを設定します。
ParamCfgsVk | 選定: バリアント条件キーパラメータ設定クラス 機能は以下の通り 選定: バリアント条件キーのパラメータを設定します。
ParamConditionsIn | 条件パラメータ設定クラス 機能は以下の通り 条件のパラメータを設定します。
ParamConditionsInX | 受注における条件更新の通信項目パラメータ設定クラス 機能は以下の通り 受注における条件更新の通信項目のパラメータを設定します。
ParamExtensionIn | VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス 機能は以下の通り VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。
ParamHeaderIn | 販売伝票ヘッダデータセグメントパラメータ設定クラス 機能は以下の通り 販売伝票ヘッダデータのパラメータを設定します。
ParamHeaderInX | ヘッダデータチェックボックスパラメータ設定クラス 機能は以下の通り ヘッダデータチェックボックスのパラメータを設定します。
ParamItemsIn | 明細データパラメータ設定クラス 機能は以下の通り 明細データのパラメータを設定します。
ParamItemsInX | 明細データチェックボックス のパラメータ設定クラス 機能は以下の通り 明細データチェックボックスのパラメータを設定します。
ParamKeys | 参照キーパラメータ設定クラス 機能は以下の通り 参照キーのパラメータを設定します。
ParamLogicSwitch | 内部制御パラメータパラメータ設定クラス 機能は以下の通り 内部制御パラメータのパラメータを設定します。
ParamPartnerAddresses | アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス 機能は以下の通り アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。
ParamPartners | 伝票取引先パラメータ設定クラス 機能は以下の通り 伝票取引先のパラメータを設定します。
ParamSchedulesIn | 納入日程行パラメータ設定クラス 機能は以下の通り 納入日程行のパラメータを設定します。
ParamSchedulesInX | 納入日程行チェックボックスパラメータ設定クラス 機能は以下の通り 納入日程行チェックボックスのパラメータを設定します。
ParamSender | 論理システム - 送信者セグメントパラメータ設定クラス 機能は以下の通り 論理システム - 送信者のパラメータを設定します。
ParamSuccess | 後続請求伝票の明細テーブルパラメータ設定クラス 機能は以下の通り 後続請求伝票の明細テーブルのパラメータを設定します。
ParamText | テキストパラメータ設定クラス 機能は以下の通り テキストのパラメータを設定します。
PartnerAddresses | アドレス (組織/会社) 用 BAPI 参照構造情報クラス 機能は以下の通り アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。
Partners | 伝票取引先情報クラス 機能は以下の通り 伝票取引先情報を保持します。
SchedulesIn | 納入日程行情報クラス 機能は以下の通り 納入日程行情報を保持します。
SchedulesInX | 納入日程行チェックボックス情報クラス 機能は以下の通り 納入日程行チェックボックス情報を保持します。
Sender | 論理システム - 送信者情報クラス 機能は以下の通り 論理システム - 送信者情報を保持します。
Success | 正常に処理された明細のテーブル情報クラス 機能は以下の通り 正常に処理された明細のテーブル情報を保持します。
Text | テキスト情報クラス 機能は以下の通り テキスト情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.common.model クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.common.model の使用

jp.co.intra_mart.foundation.sap.module.sales.common.model を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.common.model により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
BillingDocumentDetail
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module.sales.common.model のクラス
HeaderIn
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderInX
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
LogicSwitch
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
Sender
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamBillingDocumentDetailList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamBillingDocumentDetailList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList
すべての実装インタフェース:
Serializable
public final class ParamBillingDocumentDetailList
extends Object
implements Serializable

後続請求伝票のテーブルパラメータ設定クラス
機能は以下の通り

    後続請求伝票のテーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List billingDocumentDetailListList) table(Export)情報から請求伝票詳細の値をセットします。
static void | setImportParam(BapiController bapiController, List billingDocumentDetailListList) 請求伝票詳細に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List billingDocumentDetailListList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
請求伝票詳細に値をセットします。

パラメータ:
bapiController - BapiController
billingDocumentDetailListList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List billingDocumentDetailListList)
                           throws SAPGeneralSystemException
table(Export)情報から請求伝票詳細の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
billingDocumentDetailListList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsBlob (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsBlob

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob
すべての実装インタフェース:
Serializable
public final class ParamCfgsBlob
extends Object
implements Serializable

選定: BLOB 内部データ (SCE)パラメータ設定クラス
機能は以下の通り

  • 選定: BLOB 内部データ (SCE)のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsBlobList, String paramType) table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsBlobList, String paramType) 選定: BLOB 内部データ (SCE)に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsBlobList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: BLOB 内部データ (SCE)に値をセットします。

パラメータ:
bapiController - BapiController
cfgsBlobList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsBlobList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsBlobList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsInst (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst
すべての実装インタフェース:
Serializable
public final class ParamCfgsInst
extends Object
implements Serializable

選定: インスタンスパラメータ設定クラス
機能は以下の通り

  • 選定: インスタンスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsInstList, String paramType) table(Export)情報から選定: インスタンスの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsInstList, String paramType) 選定: インスタンスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsInstList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: インスタンスに値をセットします。

パラメータ:
bapiController - BapiController
cfgsInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsInstList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: インスタンスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsPartOf (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsPartOf

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf
すべての実装インタフェース:
Serializable
public final class ParamCfgsPartOf
extends Object
implements Serializable

選定: 部分設定パラメータ設定クラス
機能は以下の通り

  • 選定: 部分設定のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsPartOfList, String paramType) table(Export)情報から選定: 部分設定の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsPartOfList, String paramType) 選定: 部分設定に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsPartOfList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 部分設定に値をセットします。

パラメータ:
bapiController - BapiController
cfgsPartOfList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsPartOfList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 部分設定の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsPartOfList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsRef (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsRef

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef
すべての実装インタフェース:
Serializable
public final class ParamCfgsRef
extends Object
implements Serializable

選定: 参照データパラメータ設定クラス
機能は以下の通り

  • 選定: 参照データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsRefList, String paramType) table(Export)情報から選定: 参照データの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsRefList, String paramType) 選定: 参照データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsRefList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 参照データに値をセットします。

パラメータ:
bapiController - BapiController
cfgsRefList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsRefList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 参照データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsRefList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsRefInst (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsRefInst

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst
すべての実装インタフェース:
Serializable
public final class ParamCfgsRefInst
extends Object
implements Serializable

選定: 参照明細/インスタンスパラメータ設定クラス
機能は以下の通り

  • 選定: 参照明細/インスタンスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsRefInstList, String paramType) table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsRefInstList, String paramType) 選定: 参照明細/インスタンスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsRefInstList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 参照明細/インスタンスに値をセットします。

パラメータ:
bapiController - BapiController
cfgsRefInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsRefInstList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 参照明細/インスタンスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsRefInstList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsValue (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsValue

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue
すべての実装インタフェース:
Serializable
public final class ParamCfgsValue
extends Object
implements Serializable

選定: 特性値パラメータ設定クラス
機能は以下の通り

  • 選定: 特性値のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsValueList, String paramType) table(Export)情報から選定: 特性値の値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsValueList, String paramType) 選定: 特性値に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsValueList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: 特性値に値をセットします。

パラメータ:
bapiController - BapiController
cfgsValueList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsValueList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から選定: 特性値の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsValueList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamCfgsVk (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamCfgsVk

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk
すべての実装インタフェース:
Serializable
public final class ParamCfgsVk
extends Object
implements Serializable

選定: バリアント条件キーパラメータ設定クラス
機能は以下の通り

  • 選定: バリアント条件キーのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List cfgsVkList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List cfgsVkList, String paramType) 選定: バリアント条件キーに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List cfgsVkList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
選定: バリアント条件キーに値をセットします。

パラメータ:
bapiController - BapiController
cfgsVkList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List cfgsVkList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
cfgsVkList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionsIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamConditionsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn
すべての実装インタフェース:
Serializable
public final class ParamConditionsIn
extends Object
implements Serializable

条件パラメータ設定クラス
機能は以下の通り

  • 条件のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionsInList, String paramType) table(Export)情報から条件の値をセットします。
static void | setImportParam(BapiController bapiController, List conditionsInList, String paramType) 条件に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionsInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
条件に値をセットします。

パラメータ:
bapiController - BapiController
conditionsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionsInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から条件の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamConditionsInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamConditionsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX
すべての実装インタフェース:
Serializable
public final class ParamConditionsInX
extends Object
implements Serializable

受注における条件更新の通信項目パラメータ設定クラス
機能は以下の通り

  • 受注における条件更新の通信項目のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List conditionsInXList, String paramType) table(Export)情報から受注における条件更新の通信項目の値をセットします。
static void | setImportParam(BapiController bapiController, List conditionsInXList, String paramType) 受注における条件更新の通信項目に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List conditionsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
受注における条件更新の通信項目に値をセットします。

パラメータ:
bapiController - BapiController
conditionsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List conditionsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から受注における条件更新の通信項目の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
conditionsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamExtensionIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamExtensionIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn
すべての実装インタフェース:
Serializable
public final class ParamExtensionIn
extends Object
implements Serializable

VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス
機能は以下の通り

  • VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List extensionInList) table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
static void | setImportParam(BapiController bapiController, List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。

パラメータ:
bapiController - BapiController
extensionInList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List extensionInList)
                           throws SAPGeneralSystemException
table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
extensionInList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamHeaderIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn
すべての実装インタフェース:
Serializable
public final class ParamHeaderIn
extends Object
implements Serializable

販売伝票ヘッダデータセグメントパラメータ設定クラス
機能は以下の通り

  • 販売伝票ヘッダデータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, HeaderIn headerIn, String paramType)
販売伝票ヘッダデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  HeaderIn headerIn,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
販売伝票ヘッダデータに値をセットします。

パラメータ:
bapiController - BapiController
headerIn - HeaderIn
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamHeaderInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamHeaderInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX
すべての実装インタフェース:
Serializable
public final class ParamHeaderInX
extends Object
implements Serializable

ヘッダデータチェックボックスパラメータ設定クラス
機能は以下の通り

  • ヘッダデータチェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, HeaderInX headerInX, String paramType)
ヘッダデータチェックボックスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  HeaderInX headerInX,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ヘッダデータチェックボックスに値をセットします。

パラメータ:
bapiController - BapiController
headerInX - HeaderInX
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemsIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamItemsIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn
すべての実装インタフェース:
Serializable
public final class ParamItemsIn
extends Object
implements Serializable

明細データパラメータ設定クラス
機能は以下の通り

  • 明細データのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List itemsInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List itemsInList, String paramType) 明細データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemsInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細データに値をセットします。

パラメータ:
bapiController - BapiController
itemsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List itemsInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
itemsInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamItemsInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamItemsInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX
すべての実装インタフェース:
Serializable
public final class ParamItemsInX
extends Object
implements Serializable

明細データチェックボックス のパラメータ設定クラス
機能は以下の通り

  • 明細データチェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List itemsInXList, String paramType) table(Export)情報から明細データチェックボックスの値をセットします。
static void | setImportParam(BapiController bapiController, List itemsInXList, String paramType) 明細データに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List itemsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
明細データに値をセットします。

パラメータ:
bapiController - BapiController
itemsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List itemsInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データチェックボックスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
itemsInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamKeys (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamKeys

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys
すべての実装インタフェース:
Serializable
public final class ParamKeys
extends Object
implements Serializable

参照キーパラメータ設定クラス
機能は以下の通り

  • 参照キーのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List keysList, String paramType) table(Export)情報から参照キーの出力テーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List keysList, String paramType) 参照キーの出力テーブルに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List keysList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
参照キーの出力テーブルに値をセットします。

パラメータ:
bapiController - BapiController
keysList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List keysList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から参照キーの出力テーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
keysList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamLogicSwitch (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamLogicSwitch

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch
すべての実装インタフェース:
Serializable
public final class ParamLogicSwitch
extends Object
implements Serializable

内部制御パラメータパラメータ設定クラス
機能は以下の通り

  • 内部制御パラメータのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, LogicSwitch logicSwitch)
内部制御パラメータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  LogicSwitch logicSwitch)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
内部制御パラメータに値をセットします。

パラメータ:
bapiController - BapiController
logicSwitch - LogicSwitch
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartnerAddresses (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamPartnerAddresses

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses
すべての実装インタフェース:
Serializable
public final class ParamPartnerAddresses
extends Object
implements Serializable

アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス
機能は以下の通り

  • アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List partnerAddressesList) table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
static void | setImportParam(BapiController bapiController, List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnerAddressesList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。

パラメータ:
bapiController - BapiController
partnerAddressesList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List partnerAddressesList)
                           throws SAPGeneralSystemException
table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
partnerAddressesList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamPartners (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamPartners

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners
すべての実装インタフェース:
Serializable
public final class ParamPartners
extends Object
implements Serializable

伝票取引先パラメータ設定クラス
機能は以下の通り

  • 伝票取引先のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List partnersList, String paramType) table(Export)情報から伝票取引先の値をセットします。
static void | setImportParam(BapiController bapiController, List partnersList, String paramType) 伝票取引先に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List partnersList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
伝票取引先に値をセットします。

パラメータ:
bapiController - BapiController
partnersList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List partnersList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から伝票取引先の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
partnersList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSchedulesIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSchedulesIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn
すべての実装インタフェース:
Serializable
public final class ParamSchedulesIn
extends Object
implements Serializable

納入日程行パラメータ設定クラス
機能は以下の通り

  • 納入日程行のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List schedulesInList, String paramType) table(Export)情報から明細データの値をセットします。
static void | setImportParam(BapiController bapiController, List schedulesInList, String paramType) 納入日程行に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List schedulesInList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程行に値をセットします。

パラメータ:
bapiController - BapiController
schedulesInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List schedulesInList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から明細データの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
schedulesInList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSchedulesInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSchedulesInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX
すべての実装インタフェース:
Serializable
public final class ParamSchedulesInX
extends Object
implements Serializable

納入日程行チェックボックスパラメータ設定クラス
機能は以下の通り

  • 納入日程行チェックボックスのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List schedulesInXList, String paramType) table(Export)情報から納入日程行チェックボックスの値をセットします。
static void | setImportParam(BapiController bapiController, List schedulesInXList, String paramType) 納入日程行チェックボックスに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List schedulesInXList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
納入日程行チェックボックスに値をセットします。

パラメータ:
bapiController - BapiController
schedulesInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List schedulesInXList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報から納入日程行チェックボックスの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
schedulesInXList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSender (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender
すべての実装インタフェース:
Serializable
public final class ParamSender
extends Object
implements Serializable

論理システム - 送信者セグメントパラメータ設定クラス
機能は以下の通り

  • 論理システム - 送信者のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void setImportParam(BapiController bapiController, Sender sender)
論理システム - 送信者に値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  Sender sender)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
論理システム - 送信者に値をセットします。

パラメータ:
bapiController - BapiController
sender - Sender
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamSuccess (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamSuccess

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess
すべての実装インタフェース:
Serializable
public final class ParamSuccess
extends Object
implements Serializable

後続請求伝票の明細テーブルパラメータ設定クラス
機能は以下の通り

  • 後続請求伝票の明細テーブルのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List successList) table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
static void | setImportParam(BapiController bapiController, List successList) 後続請求伝票の明細テーブルに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List successList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
後続請求伝票の明細テーブルに値をセットします。

パラメータ:
bapiController - BapiController
successList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List successList)
                           throws SAPGeneralSystemException
table(Export)情報から後続請求伝票の明細テーブルの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
successList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ParamText (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス ParamText

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText
すべての実装インタフェース:
Serializable
public final class ParamText
extends Object
implements Serializable

テキストパラメータ設定クラス
機能は以下の通り

  • テキストのパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List textList, String paramType) table(Export)情報からテキストの値をセットします。
static void | setImportParam(BapiController bapiController, List textList, String paramType) テキストに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List textList,
                                  String paramType)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
テキストに値をセットします。

パラメータ:
bapiController - BapiController
textList - List
paramType - String パラメータタイプ
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List textList,
                                  String paramType)
                           throws SAPGeneralSystemException
table(Export)情報からテキストの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
textList - List
paramType - String パラメータタイプ
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


PartnerAddresses (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス PartnerAddresses

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses
すべての実装インタフェース:
Serializable
public class PartnerAddresses
extends Object
implements Serializable

アドレス (組織/会社) 用 BAPI 参照構造情報クラス
機能は以下の通り

  • アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
PartnerAddresses()
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
PartnerAddresses(int index)
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
メソッドの概要
String | getAddrNo() アドレス番号を取得します。
String | getAdrNotes() 住所注記を取得します。
String | getBuilding() 旧: 建物 (番号または略称)を取得します。
String | getBuildLong() 建物 (番号またはコード)を取得します。
String | getChckstatus() 市区町村ファイルテストステータスを取得します。
String | getCity() 市区町村を取得します。
String | getCityNo() 市区町村/地名ファイルの市区町村コードを取得します。
String | getCommType() 通信方法 (キー) (アドレス管理)を取得します。
String | getCOName() 気付を取得します。
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
String | getDelivDis() 郵便配達地域を取得します。
String | getDistrctNo() 市区町村/地名ファイルの所在地コードを取得します。
String | getDistrict() 所在地を取得します。
String | getDontUseP() 私書箱住所配達不可フラグを取得します。
String | getDontUseS() 地名住所配達不可フラグを取得します。
String | getEMail() 電子メールアドレスを取得します。
String | getFaxExtens() 第一 FAX 番号: 内線を取得します。
String | getFaxNumber() 第一 FAX 番号: ダイヤルコード + 番号を取得します。
String | getFloor() 建物の階を取得します。
String | getFormofaddr() 敬称テキストを取得します。
String | getHomeCity() 市区町村 (郵便用市区町村と異なる場合)を取得します。
String | getHomecityno() 別の市区町村 (市区町村/地名ファイル)を取得します。
String | getHomepage() URI 例: ホームページ、FTP アドレスを取得します。
String | getHouseNo() 番地-号を取得します。
String | getHouseNo2() 番地補足を取得します。
String | getHouseNo3() 番地範囲を取得します。
int | getIndex() レコード番号を取得します｡
String | getLangu() 言語キーを取得します。
String | getLanguCr() アドレスレコード登録オリジナル言語を取得します。
String | getLangucriso() ISO 639 準拠の言語を取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getLocation() 地名 5を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getName3() 名称 3を取得します。
String | getName4() 名称 4を取得します。
String | getPboxcitNo() 市区町村私書箱コード (市ファイル)を取得します。
String | getPcode1Ext() 市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。
String | getPcode2Ext() 私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。
String | getPcode3Ext() 主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。
String | getPoBox() 私書箱を取得します。
String | getPoBoxCit() 私書箱住所を取得します。
String | getPoboxCtry() 私書箱の国指定を取得します。
String | getPoBoxReg() 私書箱の地域 (国、都道府県、地域、...)を取得します。
String | getPoCtryiso() ISO 国コードを取得します。
String | getPostlCod1() 市区町村の郵便番号を取得します。
String | getPostlCod2() 私書箱郵便番号を取得します。
String | getPostlCod3() 会社郵便番号 (大規模なユーザ用)を取得します。
String | getPoWONo() フラグ: 郵便私書箱 (番号なし)を取得します。
String | getRegiogroup() 地域構造グループ化を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getRoomNo() 部屋/アパート番号を取得します。
String | getSort1() 検索条件 1を取得します。
String | getSort2() 検索条件 2を取得します。
String | getStrAbbr() 地名の略称 (例: スペイン)を取得します。
String | getStreet() 地名を取得します。
String | getStreetLng() 地名を取得します。
String | getStreetNo() 市区町村/地名ファイルの地名コードを取得します。
String | getStrSuppl1() 地名 2を取得します。
String | getStrSuppl2() 地名 3を取得します。
String | getStrSuppl3() 地名 4を取得します。
String | getTaxjurcode() 税管轄コードを取得します。
String | getTel1Ext() 第 1 電話番号: 内線を取得します。
String | getTel1Numbr() 第一電話番号: ダイヤルコード + 番号を取得します。
String | getTimeZone() アドレスタイムゾーンを取得します。
String | getTitle() タイトル (敬称)を取得します。
String | getTranspzone() 商品の納入区域を取得します。
void | setAddrNo(String addrNo) アドレス番号を設定します。
void | setAdrNotes(String adrNotes) 住所注記を設定します。
void | setBuilding(String building) 旧: 建物 (番号または略称)を設定します。
void | setBuildLong(String buildLong) 建物 (番号またはコード)を設定します。
void | setChckstatus(String chckstatus) 市区町村ファイルテストステータスを設定します。
void | setCity(String city) 市区町村を設定します。
void | setCityNo(String cityNo) 市区町村/地名ファイルの市区町村コードを設定します。
void | setCommType(String commType) 通信方法 (キー) (アドレス管理)を設定します。
void | setCOName(String cOName) 気付を設定します。
void | setCountry(String country) 国コードを設定します。
void | setCountryiso(String countryiso) ISO 国コードを設定します。
void | setDelivDis(String delivDis) 郵便配達地域を設定します。
void | setDistrctNo(String distrctNo) 市区町村/地名ファイルの所在地コードを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setDontUseP(String dontUseP) 私書箱住所配達不可フラグを設定します。
void | setDontUseS(String dontUseS) 地名住所配達不可フラグを設定します。
void | setEMail(String eMail) 電子メールアドレスを設定します。
void | setFaxExtens(String faxExtens) 第一 FAX 番号: 内線を設定します。
void | setFaxNumber(String faxNumber) 第一 FAX 番号: ダイヤルコード + 番号を設定します。
void | setFloor(String floor) 建物の階を設定します。
void | setFormofaddr(String formofaddr) 敬称テキストを設定します。
void | setHomeCity(String homeCity) 市区町村 (郵便用市区町村と異なる場合)を設定します。
void | setHomecityno(String homecityno) 別の市区町村 (市区町村/地名ファイル)を設定します。
void | setHomepage(String homepage) URI 例: ホームページ、FTP アドレスを設定します。
void | setHouseNo(String houseNo) 番地-号を設定します。
void | setHouseNo2(String houseNo2) 番地補足を設定します。
void | setHouseNo3(String houseNo3) 番地範囲を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setLangu(String langu) 言語キーを設定します。
void | setLanguCr(String languCr) アドレスレコード登録オリジナル言語を設定します。
void | setLangucriso(String langucriso) ISO 639 準拠の言語を設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setLocation(String location) 地名 5を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setName3(String name3) 名称 3を設定します。
void | setName4(String name4) 名称 4を設定します。
void | setPboxcitNo(String pboxcitNo) 市区町村私書箱コード (市ファイル)を設定します。
void | setPcode1Ext(String pcode1Ext) 市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。
void | setPcode2Ext(String pcode2Ext) 私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。
void | setPcode3Ext(String pcode3Ext) 主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。
void | setPoBox(String poBox) 私書箱を設定します。
void | setPoBoxCit(String poBoxCit) 私書箱住所を設定します。
void | setPoboxCtry(String poboxCtry) 私書箱の国指定を設定します。
void | setPoBoxReg(String poBoxReg) 私書箱の地域 (国、都道府県、地域、...)を設定します。
void | setPoCtryiso(String poCtryiso) ISO 国コードを設定します。
void | setPostlCod1(String postlCod1) 市区町村の郵便番号を設定します。
void | setPostlCod2(String postlCod2) 私書箱郵便番号を設定します。
void | setPostlCod3(String postlCod3) 会社郵便番号 (大規模なユーザ用)を設定します。
void | setPoWONo(String poWONo) フラグ: 郵便私書箱 (番号なし)を設定します。
void | setRegiogroup(String regiogroup) 地域構造グループ化を設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setRoomNo(String roomNo) 部屋/アパート番号を設定します。
void | setSort1(String sort1) 検索条件 1を設定します。
void | setSort2(String sort2) 検索条件 2を設定します。
void | setStrAbbr(String strAbbr) 地名の略称 (例: スペイン)を設定します。
void | setStreet(String street) 地名を設定します。
void | setStreetLng(String streetLng) 地名を設定します。
void | setStreetNo(String streetNo) 市区町村/地名ファイルの地名コードを設定します。
void | setStrSuppl1(String strSuppl1) 地名 2を設定します。
void | setStrSuppl2(String strSuppl2) 地名 3を設定します。
void | setStrSuppl3(String strSuppl3) 地名 4を設定します。
void | setTaxjurcode(String taxjurcode) 税管轄コードを設定します。
void | setTel1Ext(String tel1Ext) 第 1 電話番号: 内線を設定します。
void | setTel1Numbr(String tel1Numbr) 第一電話番号: ダイヤルコード + 番号を設定します。
void | setTimeZone(String timeZone) アドレスタイムゾーンを設定します。
void | setTitle(String title) タイトル (敬称)を設定します。
void | setTranspzone(String transpzone) 商品の納入区域を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PartnerAddresses

public PartnerAddresses()
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。

PartnerAddresses

public PartnerAddresses(int index)
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getAddrNo

public String getAddrNo()
アドレス番号を取得します。

戻り値:
addrNo アドレス番号

getFormofaddr

public String getFormofaddr()
敬称テキストを取得します。

戻り値:
formofaddr 敬称テキスト

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getName3

public String getName3()
名称 3を取得します。

戻り値:
name3 名称 3

getName4

public String getName4()
名称 4を取得します。

戻り値:
name4 名称 4

getCOName

public String getCOName()
気付を取得します。

戻り値:
cOName 気付

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getCityNo

public String getCityNo()
市区町村/地名ファイルの市区町村コードを取得します。

戻り値:
cityNo 市区町村/地名ファイルの市区町村コード

getPostlCod1

public String getPostlCod1()
市区町村の郵便番号を取得します。

戻り値:
postlCod1 市区町村の郵便番号

getPostlCod2

public String getPostlCod2()
私書箱郵便番号を取得します。

戻り値:
postlCod2 私書箱郵便番号

getPostlCod3

public String getPostlCod3()
会社郵便番号 (大規模なユーザ用)を取得します。

戻り値:
postlCod3 会社郵便番号 (大規模なユーザ用)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
poBox 私書箱

getPoBoxCit

public String getPoBoxCit()
私書箱住所を取得します。

戻り値:
poBoxCit 私書箱住所

getDelivDis

public String getDelivDis()
郵便配達地域を取得します。

戻り値:
delivDis 郵便配達地域

getStreet

public String getStreet()
地名を取得します。

戻り値:
street 地名

getStreetNo

public String getStreetNo()
市区町村/地名ファイルの地名コードを取得します。

戻り値:
streetNo 市区町村/地名ファイルの地名コード

getStrAbbr

public String getStrAbbr()
地名の略称 (例: スペイン)を取得します。

戻り値:
strAbbr 地名の略称 (例: スペイン)

getHouseNo

public String getHouseNo()
番地-号を取得します。

戻り値:
houseNo 番地-号

getStrSuppl1

public String getStrSuppl1()
地名 2を取得します。

戻り値:
strSuppl1 地名 2

getStrSuppl2

public String getStrSuppl2()
地名 3を取得します。

戻り値:
strSuppl2 地名 3

getLocation

public String getLocation()
地名 5を取得します。

戻り値:
location 地名 5

getBuilding

public String getBuilding()
旧: 建物 (番号または略称)を取得します。

戻り値:
building 旧: 建物 (番号または略称)

getFloor

public String getFloor()
建物の階を取得します。

戻り値:
floor 建物の階

getRoomNo

public String getRoomNo()
部屋/アパート番号を取得します。

戻り値:
roomNo 部屋/アパート番号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
country 国コード

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getSort1

public String getSort1()
検索条件 1を取得します。

戻り値:
sort1 検索条件 1

getSort2

public String getSort2()
検索条件 2を取得します。

戻り値:
sort2 検索条件 2

getTimeZone

public String getTimeZone()
アドレスタイムゾーンを取得します。

戻り値:
timeZone アドレスタイムゾーン

getTaxjurcode

public String getTaxjurcode()
税管轄コードを取得します。

戻り値:
taxjurcode 税管轄コード

getAdrNotes

public String getAdrNotes()
住所注記を取得します。

戻り値:
adrNotes 住所注記

getCommType

public String getCommType()
通信方法 (キー) (アドレス管理)を取得します。

戻り値:
commType 通信方法 (キー) (アドレス管理)

getTel1Numbr

public String getTel1Numbr()
第一電話番号: ダイヤルコード + 番号を取得します。

戻り値:
tel1Numbr 第一電話番号: ダイヤルコード + 番号

getTel1Ext

public String getTel1Ext()
第 1 電話番号: 内線を取得します。

戻り値:
tel1Ext 第 1 電話番号: 内線

getFaxNumber

public String getFaxNumber()
第一 FAX 番号: ダイヤルコード + 番号を取得します。

戻り値:
faxNumber 第一 FAX 番号: ダイヤルコード + 番号

getFaxExtens

public String getFaxExtens()
第一 FAX 番号: 内線を取得します。

戻り値:
faxExtens 第一 FAX 番号: 内線

getStreetLng

public String getStreetLng()
地名を取得します。

戻り値:
streetLng 地名

getDistrctNo

public String getDistrctNo()
市区町村/地名ファイルの所在地コードを取得します。

戻り値:
distrctNo 市区町村/地名ファイルの所在地コード

getChckstatus

public String getChckstatus()
市区町村ファイルテストステータスを取得します。

戻り値:
chckstatus 市区町村ファイルテストステータス

getPboxcitNo

public String getPboxcitNo()
市区町村私書箱コード (市ファイル)を取得します。

戻り値:
pboxcitNo 市区町村私書箱コード (市ファイル)

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
transpzone 商品の納入区域

getHouseNo2

public String getHouseNo2()
番地補足を取得します。

戻り値:
houseNo2 番地補足

getEMail

public String getEMail()
電子メールアドレスを取得します。

戻り値:
eMail 電子メールアドレス

getStrSuppl3

public String getStrSuppl3()
地名 4を取得します。

戻り値:
strSuppl3 地名 4

getTitle

public String getTitle()
タイトル (敬称)を取得します。

戻り値:
title タイトル (敬称)

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
countryiso ISO 国コード

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getBuildLong

public String getBuildLong()
建物 (番号またはコード)を取得します。

戻り値:
buildLong 建物 (番号またはコード)

getRegiogroup

public String getRegiogroup()
地域構造グループ化を取得します。

戻り値:
regiogroup 地域構造グループ化

getHomeCity

public String getHomeCity()
市区町村 (郵便用市区町村と異なる場合)を取得します。

戻り値:
homeCity 市区町村 (郵便用市区町村と異なる場合)

getHomecityno

public String getHomecityno()
別の市区町村 (市区町村/地名ファイル)を取得します。

戻り値:
homecityno 別の市区町村 (市区町村/地名ファイル)

getPcode1Ext

public String getPcode1Ext()
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode1Ext 市区町村郵便番号の拡張子 例: 郵便番号 +4+2

getPcode2Ext

public String getPcode2Ext()
私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode2Ext 私書箱郵便番号拡張子 例: 郵便番号 +4+2

getPcode3Ext

public String getPcode3Ext()
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。

戻り値:
pcode3Ext 主要得意先郵便番号拡張子 例: 郵便番号 +4+2

getPoWONo

public String getPoWONo()
フラグ: 郵便私書箱 (番号なし)を取得します。

戻り値:
poWONo フラグ: 郵便私書箱 (番号なし)

getPoBoxReg

public String getPoBoxReg()
私書箱の地域 (国、都道府県、地域、...)を取得します。

戻り値:
poBoxReg 私書箱の地域 (国、都道府県、地域、...)

getPoboxCtry

public String getPoboxCtry()
私書箱の国指定を取得します。

戻り値:
poboxCtry 私書箱の国指定

getPoCtryiso

public String getPoCtryiso()
ISO 国コードを取得します。

戻り値:
poCtryiso ISO 国コード

getHomepage

public String getHomepage()
URI 例: ホームページ、FTP アドレスを取得します。

戻り値:
homepage URI 例: ホームページ、FTP アドレス

getDontUseS

public String getDontUseS()
地名住所配達不可フラグを取得します。

戻り値:
dontUseS 地名住所配達不可フラグ

getDontUseP

public String getDontUseP()
私書箱住所配達不可フラグを取得します。

戻り値:
dontUseP 私書箱住所配達不可フラグ

getHouseNo3

public String getHouseNo3()
番地範囲を取得します。

戻り値:
houseNo3 番地範囲

getLanguCr

public String getLanguCr()
アドレスレコード登録オリジナル言語を取得します。

戻り値:
languCr アドレスレコード登録オリジナル言語

getLangucriso

public String getLangucriso()
ISO 639 準拠の言語を取得します。

戻り値:
langucriso ISO 639 準拠の言語

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setAddrNo

public void setAddrNo(String addrNo)
アドレス番号を設定します。

パラメータ:
addrNo - アドレス番号

setFormofaddr

public void setFormofaddr(String formofaddr)
敬称テキストを設定します。

パラメータ:
formofaddr - 敬称テキスト

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setName3

public void setName3(String name3)
名称 3を設定します。

パラメータ:
name3 - 名称 3

setName4

public void setName4(String name4)
名称 4を設定します。

パラメータ:
name4 - 名称 4

setCOName

public void setCOName(String cOName)
気付を設定します。

パラメータ:
cOName - 気付

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setCityNo

public void setCityNo(String cityNo)
市区町村/地名ファイルの市区町村コードを設定します。

パラメータ:
cityNo - 市区町村/地名ファイルの市区町村コード

setPostlCod1

public void setPostlCod1(String postlCod1)
市区町村の郵便番号を設定します。

パラメータ:
postlCod1 - 市区町村の郵便番号

setPostlCod2

public void setPostlCod2(String postlCod2)
私書箱郵便番号を設定します。

パラメータ:
postlCod2 - 私書箱郵便番号

setPostlCod3

public void setPostlCod3(String postlCod3)
会社郵便番号 (大規模なユーザ用)を設定します。

パラメータ:
postlCod3 - 会社郵便番号 (大規模なユーザ用)

setPoBox

public void setPoBox(String poBox)
私書箱を設定します。

パラメータ:
poBox - 私書箱

setPoBoxCit

public void setPoBoxCit(String poBoxCit)
私書箱住所を設定します。

パラメータ:
poBoxCit - 私書箱住所

setDelivDis

public void setDelivDis(String delivDis)
郵便配達地域を設定します。

パラメータ:
delivDis - 郵便配達地域

setStreet

public void setStreet(String street)
地名を設定します。

パラメータ:
street - 地名

setStreetNo

public void setStreetNo(String streetNo)
市区町村/地名ファイルの地名コードを設定します。

パラメータ:
streetNo - 市区町村/地名ファイルの地名コード

setStrAbbr

public void setStrAbbr(String strAbbr)
地名の略称 (例: スペイン)を設定します。

パラメータ:
strAbbr - 地名の略称 (例: スペイン)

setHouseNo

public void setHouseNo(String houseNo)
番地-号を設定します。

パラメータ:
houseNo - 番地-号

setStrSuppl1

public void setStrSuppl1(String strSuppl1)
地名 2を設定します。

パラメータ:
strSuppl1 - 地名 2

setStrSuppl2

public void setStrSuppl2(String strSuppl2)
地名 3を設定します。

パラメータ:
strSuppl2 - 地名 3

setLocation

public void setLocation(String location)
地名 5を設定します。

パラメータ:
location - 地名 5

setBuilding

public void setBuilding(String building)
旧: 建物 (番号または略称)を設定します。

パラメータ:
building - 旧: 建物 (番号または略称)

setFloor

public void setFloor(String floor)
建物の階を設定します。

パラメータ:
floor - 建物の階

setRoomNo

public void setRoomNo(String roomNo)
部屋/アパート番号を設定します。

パラメータ:
roomNo - 部屋/アパート番号

setCountry

public void setCountry(String country)
国コードを設定します。

パラメータ:
country - 国コード

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setSort1

public void setSort1(String sort1)
検索条件 1を設定します。

パラメータ:
sort1 - 検索条件 1

setSort2

public void setSort2(String sort2)
検索条件 2を設定します。

パラメータ:
sort2 - 検索条件 2

setTimeZone

public void setTimeZone(String timeZone)
アドレスタイムゾーンを設定します。

パラメータ:
timeZone - アドレスタイムゾーン

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税管轄コードを設定します。

パラメータ:
taxjurcode - 税管轄コード

setAdrNotes

public void setAdrNotes(String adrNotes)
住所注記を設定します。

パラメータ:
adrNotes - 住所注記

setCommType

public void setCommType(String commType)
通信方法 (キー) (アドレス管理)を設定します。

パラメータ:
commType - 通信方法 (キー) (アドレス管理)

setTel1Numbr

public void setTel1Numbr(String tel1Numbr)
第一電話番号: ダイヤルコード + 番号を設定します。

パラメータ:
tel1Numbr - 第一電話番号: ダイヤルコード + 番号

setTel1Ext

public void setTel1Ext(String tel1Ext)
第 1 電話番号: 内線を設定します。

パラメータ:
tel1Ext - 第 1 電話番号: 内線

setFaxNumber

public void setFaxNumber(String faxNumber)
第一 FAX 番号: ダイヤルコード + 番号を設定します。

パラメータ:
faxNumber - 第一 FAX 番号: ダイヤルコード + 番号

setFaxExtens

public void setFaxExtens(String faxExtens)
第一 FAX 番号: 内線を設定します。

パラメータ:
faxExtens - 第一 FAX 番号: 内線

setStreetLng

public void setStreetLng(String streetLng)
地名を設定します。

パラメータ:
streetLng - 地名

setDistrctNo

public void setDistrctNo(String distrctNo)
市区町村/地名ファイルの所在地コードを設定します。

パラメータ:
distrctNo - 市区町村/地名ファイルの所在地コード

setChckstatus

public void setChckstatus(String chckstatus)
市区町村ファイルテストステータスを設定します。

パラメータ:
chckstatus - 市区町村ファイルテストステータス

setPboxcitNo

public void setPboxcitNo(String pboxcitNo)
市区町村私書箱コード (市ファイル)を設定します。

パラメータ:
pboxcitNo - 市区町村私書箱コード (市ファイル)

setTranspzone

public void setTranspzone(String transpzone)
商品の納入区域を設定します。

パラメータ:
transpzone - 商品の納入区域

setHouseNo2

public void setHouseNo2(String houseNo2)
番地補足を設定します。

パラメータ:
houseNo2 - 番地補足

setEMail

public void setEMail(String eMail)
電子メールアドレスを設定します。

パラメータ:
eMail - 電子メールアドレス

setStrSuppl3

public void setStrSuppl3(String strSuppl3)
地名 4を設定します。

パラメータ:
strSuppl3 - 地名 4

setTitle

public void setTitle(String title)
タイトル (敬称)を設定します。

パラメータ:
title - タイトル (敬称)

setCountryiso

public void setCountryiso(String countryiso)
ISO 国コードを設定します。

パラメータ:
countryiso - ISO 国コード

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setBuildLong

public void setBuildLong(String buildLong)
建物 (番号またはコード)を設定します。

パラメータ:
buildLong - 建物 (番号またはコード)

setRegiogroup

public void setRegiogroup(String regiogroup)
地域構造グループ化を設定します。

パラメータ:
regiogroup - 地域構造グループ化

setHomeCity

public void setHomeCity(String homeCity)
市区町村 (郵便用市区町村と異なる場合)を設定します。

パラメータ:
homeCity - 市区町村 (郵便用市区町村と異なる場合)

setHomecityno

public void setHomecityno(String homecityno)
別の市区町村 (市区町村/地名ファイル)を設定します。

パラメータ:
homecityno - 別の市区町村 (市区町村/地名ファイル)

setPcode1Ext

public void setPcode1Ext(String pcode1Ext)
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode1Ext - 市区町村郵便番号の拡張子 例: 郵便番号 +4+2

setPcode2Ext

public void setPcode2Ext(String pcode2Ext)
私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode2Ext - 私書箱郵便番号拡張子 例: 郵便番号 +4+2

setPcode3Ext

public void setPcode3Ext(String pcode3Ext)
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。

パラメータ:
pcode3Ext - 主要得意先郵便番号拡張子 例: 郵便番号 +4+2

setPoWONo

public void setPoWONo(String poWONo)
フラグ: 郵便私書箱 (番号なし)を設定します。

パラメータ:
poWONo - フラグ: 郵便私書箱 (番号なし)

setPoBoxReg

public void setPoBoxReg(String poBoxReg)
私書箱の地域 (国、都道府県、地域、...)を設定します。

パラメータ:
poBoxReg - 私書箱の地域 (国、都道府県、地域、...)

setPoboxCtry

public void setPoboxCtry(String poboxCtry)
私書箱の国指定を設定します。

パラメータ:
poboxCtry - 私書箱の国指定

setPoCtryiso

public void setPoCtryiso(String poCtryiso)
ISO 国コードを設定します。

パラメータ:
poCtryiso - ISO 国コード

setHomepage

public void setHomepage(String homepage)
URI 例: ホームページ、FTP アドレスを設定します。

パラメータ:
homepage - URI 例: ホームページ、FTP アドレス

setDontUseS

public void setDontUseS(String dontUseS)
地名住所配達不可フラグを設定します。

パラメータ:
dontUseS - 地名住所配達不可フラグ

setDontUseP

public void setDontUseP(String dontUseP)
私書箱住所配達不可フラグを設定します。

パラメータ:
dontUseP - 私書箱住所配達不可フラグ

setHouseNo3

public void setHouseNo3(String houseNo3)
番地範囲を設定します。

パラメータ:
houseNo3 - 番地範囲

setLanguCr

public void setLanguCr(String languCr)
アドレスレコード登録オリジナル言語を設定します。

パラメータ:
languCr - アドレスレコード登録オリジナル言語

setLangucriso

public void setLangucriso(String langucriso)
ISO 639 準拠の言語を設定します。

パラメータ:
langucriso - ISO 639 準拠の言語

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Partners (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Partners

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners
すべての実装インタフェース:
Serializable
public class Partners
extends Object
implements Serializable

伝票取引先情報クラス
機能は以下の通り

  • 伝票取引先情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Partners()
伝票取引先情報を作成します。
Partners(int index)
伝票取引先情報を作成します。
メソッドの概要
String | getAddress() 住所を取得します。
String | getAddrLink() 住所コードへのリンクを取得します。
String | getAddrOrig() コピー元住所を取得します。
String | getAddrType() アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。
String | getCity() 市区町村を取得します。
String | getCountrIso() 国キー (ISO コード)を取得します。
String | getCountry() 国コードを取得します。
String | getDistrict() 所在地を取得します。
String | getFaxNumber() FAX 番号を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 明細番号 (販売管理伝票)を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getName() 名称 1を取得します。
String | getName2() 名称 2を取得します。
String | getName3() 名称 3を取得します。
String | getName4() 名称 4を取得します。
String | getPartnNumb() 得意先コード 1を取得します。
String | getPartnRole() 取引先機能を取得します。
String | getPoBox() 私書箱を取得します。
String | getPobxCty() 私書箱住所を取得します。
String | getPobxPcd() 私書箱番号を取得します。
String | getPostlCode() 郵便番号を取得します。
String | getPrivAddr() 自宅住所を取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTaxjurcode() 税計算管轄コード - 税管轄コードを取得します。
String | getTelebox() テレボックス番号を取得します。
String | getTelephone() 電話番号 1を取得します。
String | getTelephone2() 電話番号 2を取得します。
String | getTeletexNo() テレテクス番号を取得します。
String | getTelexNo() テレックス番号を取得します。
String | getTitle() 敬称を取得します。
String | getTranspzone() 商品の納入区域を取得します。
String | getUnloadPt() 荷渡ポイントを取得します。
void | setAddress(String address) 住所を設定します。
void | setAddrLink(String addrLink) 住所コードへのリンクを設定します。
void | setAddrOrig(String addrOrig) コピー元住所を設定します。
void | setAddrType(String addrType) アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。
void | setCity(String city) 市区町村を設定します。
void | setCountrIso(String countrIso) 国キー (ISO コード)を設定します。
void | setCountry(String country) 国コードを設定します。
void | setDistrict(String district) 所在地を設定します。
void | setFaxNumber(String faxNumber) FAX 番号を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 明細番号 (販売管理伝票)を設定します。
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setName(String name) 名称 1を設定します。
void | setName2(String name2) 名称 2を設定します。
void | setName3(String name3) 名称 3を設定します。
void | setName4(String name4) 名称 4を設定します。
void | setPartnNumb(String partnNumb) 得意先コード 1を設定します。
void | setPartnRole(String partnRole) 取引先機能を設定します。
void | setPoBox(String poBox) 私書箱を設定します。
void | setPobxCty(String pobxCty) 私書箱住所を設定します。
void | setPobxPcd(String pobxPcd) 私書箱番号を設定します。
void | setPostlCode(String postlCode) 郵便番号を設定します。
void | setPrivAddr(String privAddr) 自宅住所を設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRegion(String region) 地域 (都道府県)を設定します。
void | setStreet(String street) 地名/番地-号を設定します。
void | setTaxjurcode(String taxjurcode) 税計算管轄コード - 税管轄コードを設定します。
void | setTelebox(String telebox) テレボックス番号を設定します。
void | setTelephone(String telephone) 電話番号 1を設定します。
void | setTelephone2(String telephone2) 電話番号 2を設定します。
void | setTeletexNo(String teletexNo) テレテクス番号を設定します。
void | setTelexNo(String telexNo) テレックス番号を設定します。
void | setTitle(String title) 敬称を設定します。
void | setTranspzone(String transpzone) 商品の納入区域を設定します。
void | setUnloadPt(String unloadPt) 荷渡ポイントを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Partners

public Partners()
伝票取引先情報を作成します。

Partners

public Partners(int index)
伝票取引先情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getPartnRole

public String getPartnRole()
取引先機能を取得します。

戻り値:
partnRole 取引先機能

getPartnNumb

public String getPartnNumb()
得意先コード 1を取得します。

戻り値:
partnNumb 得意先コード 1

getItmNumber

public String getItmNumber()
明細番号 (販売管理伝票)を取得します。

戻り値:
itmNumber 明細番号 (販売管理伝票)

getTitle

public String getTitle()
敬称を取得します。

戻り値:
title 敬称

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getName2

public String getName2()
名称 2を取得します。

戻り値:
name2 名称 2

getName3

public String getName3()
名称 3を取得します。

戻り値:
name3 名称 3

getName4

public String getName4()
名称 4を取得します。

戻り値:
name4 名称 4

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
street 地名/番地-号

getCountry

public String getCountry()
国コードを取得します。

戻り値:
country 国コード

getCountrIso

public String getCountrIso()
国キー (ISO コード)を取得します。

戻り値:
countrIso 国キー (ISO コード)

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
postlCode 郵便番号

getPobxPcd

public String getPobxPcd()
私書箱番号を取得します。

戻り値:
pobxPcd 私書箱番号

getPobxCty

public String getPobxCty()
私書箱住所を取得します。

戻り値:
pobxCty 私書箱住所

getCity

public String getCity()
市区町村を取得します。

戻り値:
city 市区町村

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
district 所在地

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
region 地域 (都道府県)

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
poBox 私書箱

getTelephone

public String getTelephone()
電話番号 1を取得します。

戻り値:
telephone 電話番号 1

getTelephone2

public String getTelephone2()
電話番号 2を取得します。

戻り値:
telephone2 電話番号 2

getTelebox

public String getTelebox()
テレボックス番号を取得します。

戻り値:
telebox テレボックス番号

getFaxNumber

public String getFaxNumber()
FAX 番号を取得します。

戻り値:
faxNumber FAX 番号

getTeletexNo

public String getTeletexNo()
テレテクス番号を取得します。

戻り値:
teletexNo テレテクス番号

getTelexNo

public String getTelexNo()
テレックス番号を取得します。

戻り値:
telexNo テレックス番号

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getUnloadPt

public String getUnloadPt()
荷渡ポイントを取得します。

戻り値:
unloadPt 荷渡ポイント

getTranspzone

public String getTranspzone()
商品の納入区域を取得します。

戻り値:
transpzone 商品の納入区域

getTaxjurcode

public String getTaxjurcode()
税計算管轄コード - 税管轄コードを取得します。

戻り値:
taxjurcode 税計算管轄コード - 税管轄コード

getAddress

public String getAddress()
住所を取得します。

戻り値:
address 住所

getPrivAddr

public String getPrivAddr()
自宅住所を取得します。

戻り値:
privAddr 自宅住所

getAddrType

public String getAddrType()
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。

戻り値:
addrType アドレスタイプ (1=組織、2=個人、3=取引先担当者)

getAddrOrig

public String getAddrOrig()
コピー元住所を取得します。

戻り値:
addrOrig コピー元住所

getAddrLink

public String getAddrLink()
住所コードへのリンクを取得します。

戻り値:
addrLink 住所コードへのリンク

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setPartnRole

public void setPartnRole(String partnRole)
取引先機能を設定します。

パラメータ:
partnRole - 取引先機能

setPartnNumb

public void setPartnNumb(String partnNumb)
得意先コード 1を設定します。

パラメータ:
partnNumb - 得意先コード 1

setItmNumber

public void setItmNumber(String itmNumber)
明細番号 (販売管理伝票)を設定します。

パラメータ:
itmNumber - 明細番号 (販売管理伝票)

setTitle

public void setTitle(String title)
敬称を設定します。

パラメータ:
title - 敬称

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setName2

public void setName2(String name2)
名称 2を設定します。

パラメータ:
name2 - 名称 2

setName3

public void setName3(String name3)
名称 3を設定します。

パラメータ:
name3 - 名称 3

setName4

public void setName4(String name4)
名称 4を設定します。

パラメータ:
name4 - 名称 4

setStreet

public void setStreet(String street)
地名/番地-号を設定します。

パラメータ:
street - 地名/番地-号

setCountry

public void setCountry(String country)
国コードを設定します。

パラメータ:
country - 国コード

setCountrIso

public void setCountrIso(String countrIso)
国キー (ISO コード)を設定します。

パラメータ:
countrIso - 国キー (ISO コード)

setPostlCode

public void setPostlCode(String postlCode)
郵便番号を設定します。

パラメータ:
postlCode - 郵便番号

setPobxPcd

public void setPobxPcd(String pobxPcd)
私書箱番号を設定します。

パラメータ:
pobxPcd - 私書箱番号

setPobxCty

public void setPobxCty(String pobxCty)
私書箱住所を設定します。

パラメータ:
pobxCty - 私書箱住所

setCity

public void setCity(String city)
市区町村を設定します。

パラメータ:
city - 市区町村

setDistrict

public void setDistrict(String district)
所在地を設定します。

パラメータ:
district - 所在地

setRegion

public void setRegion(String region)
地域 (都道府県)を設定します。

パラメータ:
region - 地域 (都道府県)

setPoBox

public void setPoBox(String poBox)
私書箱を設定します。

パラメータ:
poBox - 私書箱

setTelephone

public void setTelephone(String telephone)
電話番号 1を設定します。

パラメータ:
telephone - 電話番号 1

setTelephone2

public void setTelephone2(String telephone2)
電話番号 2を設定します。

パラメータ:
telephone2 - 電話番号 2

setTelebox

public void setTelebox(String telebox)
テレボックス番号を設定します。

パラメータ:
telebox - テレボックス番号

setFaxNumber

public void setFaxNumber(String faxNumber)
FAX 番号を設定します。

パラメータ:
faxNumber - FAX 番号

setTeletexNo

public void setTeletexNo(String teletexNo)
テレテクス番号を設定します。

パラメータ:
teletexNo - テレテクス番号

setTelexNo

public void setTelexNo(String telexNo)
テレックス番号を設定します。

パラメータ:
telexNo - テレックス番号

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setUnloadPt

public void setUnloadPt(String unloadPt)
荷渡ポイントを設定します。

パラメータ:
unloadPt - 荷渡ポイント

setTranspzone

public void setTranspzone(String transpzone)
商品の納入区域を設定します。

パラメータ:
transpzone - 商品の納入区域

setTaxjurcode

public void setTaxjurcode(String taxjurcode)
税計算管轄コード - 税管轄コードを設定します。

パラメータ:
taxjurcode - 税計算管轄コード - 税管轄コード

setAddress

public void setAddress(String address)
住所を設定します。

パラメータ:
address - 住所

setPrivAddr

public void setPrivAddr(String privAddr)
自宅住所を設定します。

パラメータ:
privAddr - 自宅住所

setAddrType

public void setAddrType(String addrType)
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。

パラメータ:
addrType - アドレスタイプ (1=組織、2=個人、3=取引先担当者)

setAddrOrig

public void setAddrOrig(String addrOrig)
コピー元住所を設定します。

パラメータ:
addrOrig - コピー元住所

setAddrLink

public void setAddrLink(String addrLink)
住所コードへのリンクを設定します。

パラメータ:
addrLink - 住所コードへのリンク

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SchedulesIn (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス SchedulesIn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn
すべての実装インタフェース:
Serializable
public class SchedulesIn
extends Object
implements Serializable

納入日程行情報クラス
機能は以下の通り

  • 納入日程行情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SchedulesIn()
納入日程行情報を作成します。
SchedulesIn(int index)
納入日程行情報を作成します。
メソッドの概要
String | getDateType() 日付タイプ (日、週、月、期間)を取得します。
String | getDlvDate() 納入日程日付を取得します。
String | getDlvTime() 納入時間を取得します。
String | getGiDate() 出庫日付を取得します。
String | getGiTime() 出庫時刻 (現地時間 - プラント参照)を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLoadDate() 積載日付を取得します。
String | getLoadTime() 積載時刻 (現地時間: 出荷ポイント)を取得します。
String | getMsDate() 品目利用可能日を取得します。
String | getMsTime() 品目供給ステージ (現地時刻: プラント参照)を取得します。
String | getPlanSchedType() 納入日程行タイプ EDIを取得します。
String | getReflogsys() 論理システムを取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRelType() 承認タイプを取得します。
String | getReqDate() 納入日程日付を取得します。
String | getReqDlvBl() 出荷ブロック中の納入日程行を取得します。
String | getReqQty() 販売単位による受注数量を取得します。
String | getReqTime() 納入時間を取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSchedType() 納入日程カテゴリを取得します。
String | getTpDate() 輸送計画日付を取得します。
String | getTpTime() 輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
void | setDateType(String dateType) 日付タイプ (日、週、月、期間)を設定します。
void | setDlvDate(String dlvDate) 納入日程日付を設定します。
void | setDlvTime(String dlvTime) 納入時間を設定します。
void | setGiDate(String giDate) 出庫日付を設定します。
void | setGiTime(String giTime) 出庫時刻 (現地時間 - プラント参照)を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLoadDate(String loadDate) 積載日付を設定します。
void | setLoadTime(String loadTime) 積載時刻 (現地時間: 出荷ポイント)を設定します。
void | setMsDate(String msDate) 品目利用可能日を設定します。
void | setMsTime(String msTime) 品目供給ステージ (現地時刻: プラント参照)を設定します。
void | setPlanSchedType(String planSchedType) 納入日程行タイプ EDIを設定します。
void | setReflogsys(String reflogsys) 論理システムを設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRelType(String relType) 承認タイプを設定します。
void | setReqDate(String reqDate) 納入日程日付を設定します。
void | setReqDlvBl(String reqDlvBl) 出荷ブロック中の納入日程行を設定します。
void | setReqQty(String reqQty) 販売単位による受注数量を設定します。
void | setReqTime(String reqTime) 納入時間を設定します。
void | setSchedLine(String schedLine) 納入日程行を設定します。
void | setSchedType(String schedType) 納入日程カテゴリを設定します。
void | setTpDate(String tpDate) 輸送計画日付を設定します。
void | setTpTime(String tpTime) 輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SchedulesIn

public SchedulesIn()
納入日程行情報を作成します。

SchedulesIn

public SchedulesIn(int index)
納入日程行情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
schedLine 納入日程行

getReqDate

public String getReqDate()
納入日程日付を取得します。

戻り値:
reqDate 納入日程日付

getDateType

public String getDateType()
日付タイプ (日、週、月、期間)を取得します。

戻り値:
dateType 日付タイプ (日、週、月、期間)

getReqTime

public String getReqTime()
納入時間を取得します。

戻り値:
reqTime 納入時間

getReqQty

public String getReqQty()
販売単位による受注数量を取得します。

戻り値:
reqQty 販売単位による受注数量

getReqDlvBl

public String getReqDlvBl()
出荷ブロック中の納入日程行を取得します。

戻り値:
reqDlvBl 出荷ブロック中の納入日程行

getSchedType

public String getSchedType()
納入日程カテゴリを取得します。

戻り値:
schedType 納入日程カテゴリ

getTpDate

public String getTpDate()
輸送計画日付を取得します。

戻り値:
tpDate 輸送計画日付

getMsDate

public String getMsDate()
品目利用可能日を取得します。

戻り値:
msDate 品目利用可能日

getLoadDate

public String getLoadDate()
積載日付を取得します。

戻り値:
loadDate 積載日付

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
giDate 出庫日付

getTpTime

public String getTpTime()
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。

戻り値:
tpTime 輸送計画 - 時間 (現地時間/出荷ポイント参照)

getMsTime

public String getMsTime()
品目供給ステージ (現地時刻: プラント参照)を取得します。

戻り値:
msTime 品目供給ステージ (現地時刻: プラント参照)

getLoadTime

public String getLoadTime()
積載時刻 (現地時間: 出荷ポイント)を取得します。

戻り値:
loadTime 積載時刻 (現地時間: 出荷ポイント)

getGiTime

public String getGiTime()
出庫時刻 (現地時間 - プラント参照)を取得します。

戻り値:
giTime 出庫時刻 (現地時間 - プラント参照)

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getReflogsys

public String getReflogsys()
論理システムを取得します。

戻り値:
reflogsys 論理システム

getDlvDate

public String getDlvDate()
納入日程日付を取得します。

戻り値:
dlvDate 納入日程日付

getDlvTime

public String getDlvTime()
納入時間を取得します。

戻り値:
dlvTime 納入時間

getRelType

public String getRelType()
承認タイプを取得します。

戻り値:
relType 承認タイプ

getPlanSchedType

public String getPlanSchedType()
納入日程行タイプ EDIを取得します。

戻り値:
planSchedType 納入日程行タイプ EDI

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String schedLine)
納入日程行を設定します。

パラメータ:
schedLine - 納入日程行

setReqDate

public void setReqDate(String reqDate)
納入日程日付を設定します。

パラメータ:
reqDate - 納入日程日付

setDateType

public void setDateType(String dateType)
日付タイプ (日、週、月、期間)を設定します。

パラメータ:
dateType - 日付タイプ (日、週、月、期間)

setReqTime

public void setReqTime(String reqTime)
納入時間を設定します。

パラメータ:
reqTime - 納入時間

setReqQty

public void setReqQty(String reqQty)
販売単位による受注数量を設定します。

パラメータ:
reqQty - 販売単位による受注数量

setReqDlvBl

public void setReqDlvBl(String reqDlvBl)
出荷ブロック中の納入日程行を設定します。

パラメータ:
reqDlvBl - 出荷ブロック中の納入日程行

setSchedType

public void setSchedType(String schedType)
納入日程カテゴリを設定します。

パラメータ:
schedType - 納入日程カテゴリ

setTpDate

public void setTpDate(String tpDate)
輸送計画日付を設定します。

パラメータ:
tpDate - 輸送計画日付

setMsDate

public void setMsDate(String msDate)
品目利用可能日を設定します。

パラメータ:
msDate - 品目利用可能日

setLoadDate

public void setLoadDate(String loadDate)
積載日付を設定します。

パラメータ:
loadDate - 積載日付

setGiDate

public void setGiDate(String giDate)
出庫日付を設定します。

パラメータ:
giDate - 出庫日付

setTpTime

public void setTpTime(String tpTime)
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。

パラメータ:
tpTime - 輸送計画 - 時間 (現地時間/出荷ポイント参照)

setMsTime

public void setMsTime(String msTime)
品目供給ステージ (現地時刻: プラント参照)を設定します。

パラメータ:
msTime - 品目供給ステージ (現地時刻: プラント参照)

setLoadTime

public void setLoadTime(String loadTime)
積載時刻 (現地時間: 出荷ポイント)を設定します。

パラメータ:
loadTime - 積載時刻 (現地時間: 出荷ポイント)

setGiTime

public void setGiTime(String giTime)
出庫時刻 (現地時間 - プラント参照)を設定します。

パラメータ:
giTime - 出庫時刻 (現地時間 - プラント参照)

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setReflogsys

public void setReflogsys(String reflogsys)
論理システムを設定します。

パラメータ:
reflogsys - 論理システム

setDlvDate

public void setDlvDate(String dlvDate)
納入日程日付を設定します。

パラメータ:
dlvDate - 納入日程日付

setDlvTime

public void setDlvTime(String dlvTime)
納入時間を設定します。

パラメータ:
dlvTime - 納入時間

setRelType

public void setRelType(String relType)
承認タイプを設定します。

パラメータ:
relType - 承認タイプ

setPlanSchedType

public void setPlanSchedType(String planSchedType)
納入日程行タイプ EDIを設定します。

パラメータ:
planSchedType - 納入日程行タイプ EDI

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SchedulesInX (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス SchedulesInX

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX
すべての実装インタフェース:
Serializable
public class SchedulesInX
extends Object
implements Serializable

納入日程行チェックボックス情報クラス
機能は以下の通り

  • 納入日程行チェックボックス情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SchedulesInX()
納入日程行チェックボックス情報を作成します。
SchedulesInX(int index)
納入日程行チェックボックス情報を作成します。
メソッドの概要
String | getDateType() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvDate() 関連ユーザデータ項目の更新情報を取得します。
String | getDlvTime() 関連ユーザデータ項目の更新情報を取得します。
String | getGiDate() 関連ユーザデータ項目の更新情報を取得します。
String | getGiTime() 関連ユーザデータ項目の更新情報を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLoadDate() 関連ユーザデータ項目の更新情報を取得します。
String | getLoadTime() 関連ユーザデータ項目の更新情報を取得します。
String | getMsDate() 関連ユーザデータ項目の更新情報を取得します。
String | getMsTime() 関連ユーザデータ項目の更新情報を取得します。
String | getPlanSchedType() 関連ユーザデータ項目の更新情報を取得します。
String | getRefobjkey() オブジェクトキーを取得します。
String | getRefobjtype() オブジェクトタイプを取得します。
String | getRelType() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDate() 関連ユーザデータ項目の更新情報を取得します。
String | getReqDlvBl() 関連ユーザデータ項目の更新情報を取得します。
String | getReqQty() 関連ユーザデータ項目の更新情報を取得します。
String | getReqTime() 関連ユーザデータ項目の更新情報を取得します。
String | getSchedLine() 納入日程行を取得します。
String | getSchedType() 関連ユーザデータ項目の更新情報を取得します。
String | getTpDate() 関連ユーザデータ項目の更新情報を取得します。
String | getTpTime() 関連ユーザデータ項目の更新情報を取得します。
String | getUpdateflag() 更新区分を取得します。
void | setDateType(String dateType) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvDate(String dlvDate) 関連ユーザデータ項目の更新情報を設定します。
void | setDlvTime(String dlvTime) 関連ユーザデータ項目の更新情報を設定します。
void | setGiDate(String giDate) 関連ユーザデータ項目の更新情報を設定します。
void | setGiTime(String giTime) 関連ユーザデータ項目の更新情報を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLoadDate(String loadDate) 関連ユーザデータ項目の更新情報を設定します。
void | setLoadTime(String loadTime) 関連ユーザデータ項目の更新情報を設定します。
void | setMsDate(String msDate) 関連ユーザデータ項目の更新情報を設定します。
void | setMsTime(String msTime) 関連ユーザデータ項目の更新情報を設定します。
void | setPlanSchedType(String planSchedType) 関連ユーザデータ項目の更新情報を設定します。
void | setRefobjkey(String refobjkey) オブジェクトキーを設定します。
void | setRefobjtype(String refobjtype) オブジェクトタイプを設定します。
void | setRelType(String relType) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDate(String reqDate) 関連ユーザデータ項目の更新情報を設定します。
void | setReqDlvBl(String reqDlvBl) 関連ユーザデータ項目の更新情報を設定します。
void | setReqQty(String reqQty) 関連ユーザデータ項目の更新情報を設定します。
void | setReqTime(String reqTime) 関連ユーザデータ項目の更新情報を設定します。
void | setSchedLine(String schedLine) 納入日程行を設定します。
void | setSchedType(String schedType) 関連ユーザデータ項目の更新情報を設定します。
void | setTpDate(String tpDate) 関連ユーザデータ項目の更新情報を設定します。
void | setTpTime(String tpTime) 関連ユーザデータ項目の更新情報を設定します。
void | setUpdateflag(String updateflag) 更新区分を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SchedulesInX

public SchedulesInX()
納入日程行チェックボックス情報を作成します。

SchedulesInX

public SchedulesInX(int index)
納入日程行チェックボックス情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getSchedLine

public String getSchedLine()
納入日程行を取得します。

戻り値:
schedLine 納入日程行

getUpdateflag

public String getUpdateflag()
更新区分を取得します。

戻り値:
updateflag 更新区分

getReqDate

public String getReqDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDate 関連ユーザデータ項目の更新情報

getDateType

public String getDateType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dateType 関連ユーザデータ項目の更新情報

getReqTime

public String getReqTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqTime 関連ユーザデータ項目の更新情報

getReqQty

public String getReqQty()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqQty 関連ユーザデータ項目の更新情報

getReqDlvBl

public String getReqDlvBl()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
reqDlvBl 関連ユーザデータ項目の更新情報

getSchedType

public String getSchedType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
schedType 関連ユーザデータ項目の更新情報

getTpDate

public String getTpDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tpDate 関連ユーザデータ項目の更新情報

getMsDate

public String getMsDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
msDate 関連ユーザデータ項目の更新情報

getLoadDate

public String getLoadDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
loadDate 関連ユーザデータ項目の更新情報

getGiDate

public String getGiDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
giDate 関連ユーザデータ項目の更新情報

getTpTime

public String getTpTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
tpTime 関連ユーザデータ項目の更新情報

getMsTime

public String getMsTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
msTime 関連ユーザデータ項目の更新情報

getLoadTime

public String getLoadTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
loadTime 関連ユーザデータ項目の更新情報

getGiTime

public String getGiTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
giTime 関連ユーザデータ項目の更新情報

getRefobjtype

public String getRefobjtype()
オブジェクトタイプを取得します。

戻り値:
refobjtype オブジェクトタイプ

getRefobjkey

public String getRefobjkey()
オブジェクトキーを取得します。

戻り値:
refobjkey オブジェクトキー

getDlvDate

public String getDlvDate()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvDate 関連ユーザデータ項目の更新情報

getDlvTime

public String getDlvTime()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
dlvTime 関連ユーザデータ項目の更新情報

getRelType

public String getRelType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
relType 関連ユーザデータ項目の更新情報

getPlanSchedType

public String getPlanSchedType()
関連ユーザデータ項目の更新情報を取得します。

戻り値:
planSchedType 関連ユーザデータ項目の更新情報

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setSchedLine

public void setSchedLine(String schedLine)
納入日程行を設定します。

パラメータ:
schedLine - 納入日程行

setUpdateflag

public void setUpdateflag(String updateflag)
更新区分を設定します。

パラメータ:
updateflag - 更新区分

setReqDate

public void setReqDate(String reqDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDate - 関連ユーザデータ項目の更新情報

setDateType

public void setDateType(String dateType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dateType - 関連ユーザデータ項目の更新情報

setReqTime

public void setReqTime(String reqTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqTime - 関連ユーザデータ項目の更新情報

setReqQty

public void setReqQty(String reqQty)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqQty - 関連ユーザデータ項目の更新情報

setReqDlvBl

public void setReqDlvBl(String reqDlvBl)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
reqDlvBl - 関連ユーザデータ項目の更新情報

setSchedType

public void setSchedType(String schedType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
schedType - 関連ユーザデータ項目の更新情報

setTpDate

public void setTpDate(String tpDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tpDate - 関連ユーザデータ項目の更新情報

setMsDate

public void setMsDate(String msDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
msDate - 関連ユーザデータ項目の更新情報

setLoadDate

public void setLoadDate(String loadDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
loadDate - 関連ユーザデータ項目の更新情報

setGiDate

public void setGiDate(String giDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
giDate - 関連ユーザデータ項目の更新情報

setTpTime

public void setTpTime(String tpTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
tpTime - 関連ユーザデータ項目の更新情報

setMsTime

public void setMsTime(String msTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
msTime - 関連ユーザデータ項目の更新情報

setLoadTime

public void setLoadTime(String loadTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
loadTime - 関連ユーザデータ項目の更新情報

setGiTime

public void setGiTime(String giTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
giTime - 関連ユーザデータ項目の更新情報

setRefobjtype

public void setRefobjtype(String refobjtype)
オブジェクトタイプを設定します。

パラメータ:
refobjtype - オブジェクトタイプ

setRefobjkey

public void setRefobjkey(String refobjkey)
オブジェクトキーを設定します。

パラメータ:
refobjkey - オブジェクトキー

setDlvDate

public void setDlvDate(String dlvDate)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvDate - 関連ユーザデータ項目の更新情報

setDlvTime

public void setDlvTime(String dlvTime)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
dlvTime - 関連ユーザデータ項目の更新情報

setRelType

public void setRelType(String relType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
relType - 関連ユーザデータ項目の更新情報

setPlanSchedType

public void setPlanSchedType(String planSchedType)
関連ユーザデータ項目の更新情報を設定します。

パラメータ:
planSchedType - 関連ユーザデータ項目の更新情報

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Sender (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Sender

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender
すべての実装インタフェース:
Serializable
public class Sender
extends Object
implements Serializable

論理システム - 送信者情報クラス
機能は以下の通り

  • 論理システム - 送信者情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Sender()
論理システム - 送信者情報を作成します。
メソッドの概要
String | getLogSystem() 論理システムを取得します。
void | setLogSystem(String logSystem) 論理システムを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Sender

public Sender()
論理システム - 送信者情報を作成します。

メソッドの詳細

getLogSystem

public String getLogSystem()
論理システムを取得します。

戻り値:
logSystem 論理システム

setLogSystem

public void setLogSystem(String logSystem)
論理システムを設定します。

パラメータ:
logSystem - 論理システム

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Success (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Success

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Success
すべての実装インタフェース:
Serializable
public class Success
extends Object
implements Serializable

正常に処理された明細のテーブル情報クラス
機能は以下の通り

  • 正常に処理された明細のテーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Success()
正常に処理された明細のテーブル情報を作成します。
Success(int index)
正常に処理された明細のテーブル情報を作成します。
メソッドの概要
String | getBillDoc() 請求伝票を取得します。
String | getBillDocItem() 請求伝票明細を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrencyIso() ISO コード通貨を取得します。
String | getGroValueItem() 総額を取得します。
int | getIndex() レコード番号を取得します｡
String | getNetValue() 正味金額を取得します。
String | getNetValueItem() 正味金額を取得します。
String | getRefDoc() 参照伝票番号を取得します。
String | getRefDocItem() 参照明細番号を取得します。
String | getTaxValue() 税額を取得します。
String | getTaxValueItem() 税額を取得します。
void | setBillDoc(String billDoc) 請求伝票を設定します。
void | setBillDocItem(String billDocItem) 請求伝票明細を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrencyIso(String currencyIso) ISO コード通貨を設定します。
void | setGroValueItem(String groValueItem) 総額を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setNetValue(String netValue) 正味金額を設定します。
void | setNetValueItem(String netValueItem) 正味金額を設定します。
void | setRefDoc(String refDoc) 参照伝票番号を設定します。
void | setRefDocItem(String refDocItem) 参照明細番号を設定します。
void | setTaxValue(String taxValue) 税額を設定します。
void | setTaxValueItem(String taxValueItem) 税額を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Success

public Success()
正常に処理された明細のテーブル情報を作成します。

Success

public Success(int index)
正常に処理された明細のテーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getRefDoc

public String getRefDoc()
参照伝票番号を取得します。

戻り値:
refDoc 参照伝票番号

getRefDocItem

public String getRefDocItem()
参照明細番号を取得します。

戻り値:
refDocItem 参照明細番号

getBillDoc

public String getBillDoc()
請求伝票を取得します。

戻り値:
billDoc 請求伝票

getBillDocItem

public String getBillDocItem()
請求伝票明細を取得します。

戻り値:
billDocItem 請求伝票明細

getNetValue

public String getNetValue()
正味金額を取得します。

戻り値:
netValue 正味金額

getTaxValue

public String getTaxValue()
税額を取得します。

戻り値:
taxValue 税額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrencyIso

public String getCurrencyIso()
ISO コード通貨を取得します。

戻り値:
currencyIso ISO コード通貨

getNetValueItem

public String getNetValueItem()
正味金額を取得します。

戻り値:
netValueItem 正味金額

getTaxValueItem

public String getTaxValueItem()
税額を取得します。

戻り値:
taxValueItem 税額

getGroValueItem

public String getGroValueItem()
総額を取得します。

戻り値:
groValueItem 総額

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setRefDoc

public void setRefDoc(String refDoc)
参照伝票番号を設定します。

パラメータ:
refDoc - 参照伝票番号

setRefDocItem

public void setRefDocItem(String refDocItem)
参照明細番号を設定します。

パラメータ:
refDocItem - 参照明細番号

setBillDoc

public void setBillDoc(String billDoc)
請求伝票を設定します。

パラメータ:
billDoc - 請求伝票

setBillDocItem

public void setBillDocItem(String billDocItem)
請求伝票明細を設定します。

パラメータ:
billDocItem - 請求伝票明細

setNetValue

public void setNetValue(String netValue)
正味金額を設定します。

パラメータ:
netValue - 正味金額

setTaxValue

public void setTaxValue(String taxValue)
税額を設定します。

パラメータ:
taxValue - 税額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrencyIso

public void setCurrencyIso(String currencyIso)
ISO コード通貨を設定します。

パラメータ:
currencyIso - ISO コード通貨

setNetValueItem

public void setNetValueItem(String netValueItem)
正味金額を設定します。

パラメータ:
netValueItem - 正味金額

setTaxValueItem

public void setTaxValueItem(String taxValueItem)
税額を設定します。

パラメータ:
taxValueItem - 税額

setGroValueItem

public void setGroValueItem(String groValueItem)
総額を設定します。

パラメータ:
groValueItem - 総額

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Text (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.common.model
クラス Text

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.common.model.Text
すべての実装インタフェース:
Serializable
public class Text
extends Object
implements Serializable

テキスト情報クラス
機能は以下の通り

  • テキスト情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
Text()
テキスト情報を作成します。
Text(int index)
テキスト情報を作成します。
メソッドの概要
String | getDocNumber() 販売伝票を取得します。
String | getFormatCol() タグ列を取得します。
String | getFunction() 機能を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getTextId() テキスト IDを取得します。
String | getTextLine() テキスト行を取得します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setFormatCol(String formatCol) タグ列を設定します。
void | setFunction(String function) 機能を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setLangu(String langu) 言語キーを設定します。
void | setLanguIso(String languIso) ISO 639 準拠の言語を設定します。
void | setTextId(String textId) テキスト IDを設定します。
void | setTextLine(String textLine) テキスト行を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

Text

public Text()
テキスト情報を作成します。

Text

public Text(int index)
テキスト情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getTextId

public String getTextId()
テキスト IDを取得します。

戻り値:
textId テキスト ID

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
langu 言語キー

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
languIso ISO 639 準拠の言語

getFormatCol

public String getFormatCol()
タグ列を取得します。

戻り値:
formatCol タグ列

getTextLine

public String getTextLine()
テキスト行を取得します。

戻り値:
textLine テキスト行

getFunction

public String getFunction()
機能を取得します。

戻り値:
function 機能

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setTextId

public void setTextId(String textId)
テキスト IDを設定します。

パラメータ:
textId - テキスト ID

setLangu

public void setLangu(String langu)
言語キーを設定します。

パラメータ:
langu - 言語キー

setLanguIso

public void setLanguIso(String languIso)
ISO 639 準拠の言語を設定します。

パラメータ:
languIso - ISO 639 準拠の言語

setFormatCol

public void setFormatCol(String formatCol)
タグ列を設定します。

パラメータ:
formatCol - タグ列

setTextLine

public void setTextLine(String textLine)
テキスト行を設定します。

パラメータ:
textLine - テキスト行

setFunction

public void setFunction(String function)
機能を設定します。

パラメータ:
function - 機能

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException の使用

SAPSalesAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales での SAPSalesAppException の使用

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPSalesAppException の使用

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPSalesAppException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException の使用

SAPSalesSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のメソッド
 void SalesOrderGetStatusController.executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void SalesOrderGetStatusController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void SalesOrderGetListController.executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void SalesOrderGetListController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void SalesOrderCreateFromDat2Controller.executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void SalesOrderCreateFromDat2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void SalesOrderCreateFromDat2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void QuotationCreateFromData2Controller.executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void QuotationCreateFromData2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void QuotationCreateFromData2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void InquiryCreateFromData2Controller.executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void InquiryCreateFromData2Controller.setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void InquiryCreateFromData2Controller.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void BillingDocGetListController.executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void BillingDocGetListController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void BillingDocGetListController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
 void BillingDocCreateMultipleController.executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
 void BillingDocCreateMultipleController.setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void BillingDocCreateMultipleController.setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales のコンストラクタ
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail での SAPSalesSystemException の使用

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のメソッド
 void BillingDocGetDetail.executeBapi()
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

SAPSalesSystemException をスローする jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail のコンストラクタ
BillingDocGetDetail(String billingdocument, SapClient sapClient)
請求伝票詳細照会情報を作成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.exception
例外
SAPSalesAppException
SAPSalesSystemException


jp.co.intra_mart.foundation.sap.module.sales.exception (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception

例外の概要
SAPSalesAppException | 販売管理系APIアプリケーション例外クラス
SAPSalesSystemException | 販売管理系APIシステム例外クラス


jp.co.intra_mart.foundation.sap.module.sales.exception クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException


パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.exception の使用

jp.co.intra_mart.foundation.sap.module.sales.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesAppException
販売管理系APIアプリケーション例外クラス
SAPSalesSystemException
販売管理系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module.sales.exception のクラス
SAPSalesAppException
販売管理系APIアプリケーション例外クラス
SAPSalesSystemException
販売管理系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPSalesAppException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.exception
クラス SAPSalesAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
                    拡張 jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
すべての実装インタフェース:
Serializable
public class SAPSalesAppException
extends SAPModuleAppException

販売管理系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPSalesAppException(String message)
販売管理系APIアプリケーション例外
SAPSalesAppException(String message, Throwable ex)
販売管理系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPSalesAppException

public SAPSalesAppException(String message,
                            Throwable ex)
販売管理系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPSalesAppException

public SAPSalesAppException(String message)
販売管理系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPSalesSystemException (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.exception
クラス SAPSalesSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
                    拡張 jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException
すべての実装インタフェース:
Serializable
public class SAPSalesSystemException
extends SAPModuleSystemException

販売管理系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPSalesSystemException(String message, Throwable ex)
販売管理系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPSalesSystemException

public SAPSalesSystemException(String message,
                               Throwable ex)
販売管理系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 の使用

InquiryCreateFromData2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での InquiryCreateFromData2 の使用

jp.co.intra_mart.foundation.sap.module.sales での InquiryCreateFromData2 のサブクラス
 class InquiryCreateFromData2Controller
引合伝票登録コントローラクラス
機能は以下の通り
引合伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


InquiryCreateFromData2 (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
クラス InquiryCreateFromData2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
InquiryCreateFromData2Controller
public class InquiryCreateFromData2
extends UpdateController
implements Serializable

引合伝票登録情報クラス
機能は以下の通り

  • 引合伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InquiryCreateFromData2()
コンストラクタ。
InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 変換: 取引先機能 + 受注伝票タイプを取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
List | getInquiryCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getInquiryCfgsInstList() 選定: インスタンスを取得します。
List | getInquiryCfgsPartOfList() 選定: 部分設定を取得します。
List | getInquiryCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getInquiryCfgsRefList() 選定: 参照データを取得します。
List | getInquiryCfgsValueList() 選定: 特性値を取得します。
List | getInquiryCfgsVkList() 選定: バリアント条件キーを取得します。
List | getInquiryConditionsInList() 条件を取得します。
List | getInquiryConditionsInXList() 受注における条件更新の通信項目を取得します。
HeaderIn | getInquiryHeaderIn() 引合伝票ヘッダデータを取得します。
HeaderInX | getInquiryHeaderInX() ヘッダデータチェックボックスを取得します。
List | getInquiryItemsInList() 明細データを取得します。
List | getInquiryItemsInXList() 明細データチェックボックスを取得します。
List | getInquiryKeysList() 参照キーの出力テーブルを取得します。
List | getInquiryPartnersList() 伝票取引先を取得します。
List | getInquirySchedulesInList() 納入日程行を取得します。
List | getInquirySchedulesInXList() 納入日程行チェックボックスを取得します。
List | getInquiryTextList() テキストを取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
String | getSalesdocument() 販売伝票番号を取得します。
String | getSalesdocumentin() 販売管理伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 変換: 取引先機能 + 受注伝票タイプを設定します。
void | setExportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 引合伝票に登録する値ををセットします。
void | setInquiryCfgsBlobList(List inquiryCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setInquiryCfgsInstList(List inquiryCfgsInstList) 選定: インスタンスを設定します。
void | setInquiryCfgsPartOfList(List inquiryCfgsPartOfList) 選定: 部分設定を設定します。
void | setInquiryCfgsRefInstList(List inquiryCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setInquiryCfgsRefList(List inquiryCfgsRefList) 選定: 参照データを設定します。
void | setInquiryCfgsValueList(List inquiryCfgsValueList) 選定: 特性値を設定します。
void | setInquiryCfgsVkList(List inquiryCfgsVkList) 選定: バリアント条件キーを設定します。
void | setInquiryConditionsInList(List inquiryConditionsInList) 条件を設定します。
void | setInquiryConditionsInXList(List inquiryConditionsInXList) 受注における条件更新の通信項目を設定します。
void | setInquiryHeaderIn(HeaderIn inquiryHeaderIn) 引合伝票ヘッダデータを設定します。
void | setInquiryHeaderInX(HeaderInX inquiryHeaderInX) ヘッダデータチェックボックスを設定します。
void | setInquiryItemsInList(List inquiryItemsInList) 明細データを設定します。
void | setInquiryItemsInXList(List inquiryItemsInXList) 明細データチェックボックスを設定します。
void | setInquiryKeysList(List inquiryKeysList) 参照キーの出力テーブルを設定します。
void | setInquiryPartnersList(List inquiryPartnersList) 伝票取引先を設定します。
void | setInquirySchedulesInList(List inquirySchedulesInList) 納入日程行を設定します。
void | setInquirySchedulesInXList(List inquirySchedulesInXList) 納入日程行チェックボックスを設定します。
void | setInquiryTextList(List inquiryTextList) テキストを設定します。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setSalesdocument(String salesdocument) 販売伝票番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 販売管理伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InquiryCreateFromData2

public InquiryCreateFromData2()
コンストラクタ。

InquiryCreateFromData2

public InquiryCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

InquiryCreateFromData2

public InquiryCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引合伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
引合伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getSalesdocumentin

public String getSalesdocumentin()
販売管理伝票番号を取得します。

戻り値:
salesdocumentin 販売管理伝票番号

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getConvert

public String getConvert()
変換: 取引先機能 + 受注伝票タイプを取得します。

戻り値:
convert 変換: 取引先機能 + 受注伝票タイプ

getSalesdocument

public String getSalesdocument()
販売伝票番号を取得します。

戻り値:
salesdocument 販売伝票番号

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getInquiryHeaderInX

public HeaderInX getInquiryHeaderInX()
ヘッダデータチェックボックスを取得します。

戻り値:
inquiryHeaderInX ヘッダデータチェックボックス

getInquiryHeaderIn

public HeaderIn getInquiryHeaderIn()
引合伝票ヘッダデータを取得します。

戻り値:
inquiryHeaderIn 引合伝票ヘッダデータ

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

getInquiryCfgsBlobList

public List getInquiryCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
inquiryCfgsBlobList 選定: BLOB 内部データ (SCE)

getInquiryTextList

public List getInquiryTextList()
テキストを取得します。

戻り値:
inquiryTextList テキスト

getInquirySchedulesInXList

public List getInquirySchedulesInXList()
納入日程行チェックボックスを取得します。

戻り値:
inquirySchedulesInXList 納入日程行チェックボックス

getInquirySchedulesInList

public List getInquirySchedulesInList()
納入日程行を取得します。

戻り値:
inquirySchedulesInList 納入日程行

getInquiryPartnersList

public List getInquiryPartnersList()
伝票取引先を取得します。

戻り値:
inquiryPartnersList 伝票取引先

getInquiryKeysList

public List getInquiryKeysList()
参照キーの出力テーブルを取得します。

戻り値:
inquiryKeysList 参照キーの出力テーブル

getInquiryItemsInXList

public List getInquiryItemsInXList()
明細データチェックボックスを取得します。

戻り値:
inquiryItemsInXList 明細データチェックボックス

getInquiryItemsInList

public List getInquiryItemsInList()
明細データを取得します。

戻り値:
inquiryItemsInList 明細データ

getInquiryCfgsInstList

public List getInquiryCfgsInstList()
選定: インスタンスを取得します。

戻り値:
inquiryCfgsInstList 選定: インスタンス

getInquiryCfgsPartOfList

public List getInquiryCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
inquiryCfgsPartOfList 選定: 部分設定

getInquiryConditionsInXList

public List getInquiryConditionsInXList()
受注における条件更新の通信項目を取得します。

戻り値:
inquiryConditionsInXList 受注における条件更新の通信項目

getInquiryConditionsInList

public List getInquiryConditionsInList()
条件を取得します。

戻り値:
inquiryConditionsInList 条件

getInquiryCfgsVkList

public List getInquiryCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
inquiryCfgsVkList 選定: バリアント条件キー

getInquiryCfgsValueList

public List getInquiryCfgsValueList()
選定: 特性値を取得します。

戻り値:
inquiryCfgsValueList 選定: 特性値

getInquiryCfgsRefInstList

public List getInquiryCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
inquiryCfgsRefInstList 選定: 参照明細/インスタンス

getInquiryCfgsRefList

public List getInquiryCfgsRefList()
選定: 参照データを取得します。

戻り値:
inquiryCfgsRefList 選定: 参照データ

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
販売管理伝票番号を設定します。

パラメータ:
salesdocumentin - 販売管理伝票番号

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setConvert

public void setConvert(String convert)
変換: 取引先機能 + 受注伝票タイプを設定します。

パラメータ:
convert - 変換: 取引先機能 + 受注伝票タイプ

setSalesdocument

public void setSalesdocument(String salesdocument)
販売伝票番号を設定します。

パラメータ:
salesdocument - 販売伝票番号

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setInquiryHeaderInX

public void setInquiryHeaderInX(HeaderInX inquiryHeaderInX)
ヘッダデータチェックボックスを設定します。

パラメータ:
inquiryHeaderInX - ヘッダデータチェックボックス

setInquiryHeaderIn

public void setInquiryHeaderIn(HeaderIn inquiryHeaderIn)
引合伝票ヘッダデータを設定します。

パラメータ:
inquiryHeaderIn - 引合伝票ヘッダデータ

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

setInquiryCfgsBlobList

public void setInquiryCfgsBlobList(List inquiryCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
inquiryCfgsBlobList - 選定: BLOB 内部データ (SCE)

setInquiryTextList

public void setInquiryTextList(List inquiryTextList)
テキストを設定します。

パラメータ:
inquiryTextList - テキスト

setInquirySchedulesInXList

public void setInquirySchedulesInXList(List inquirySchedulesInXList)
納入日程行チェックボックスを設定します。

パラメータ:
inquirySchedulesInXList - 納入日程行チェックボックス

setInquirySchedulesInList

public void setInquirySchedulesInList(List inquirySchedulesInList)
納入日程行を設定します。

パラメータ:
inquirySchedulesInList - 納入日程行

setInquiryPartnersList

public void setInquiryPartnersList(List inquiryPartnersList)
伝票取引先を設定します。

パラメータ:
inquiryPartnersList - 伝票取引先

setInquiryKeysList

public void setInquiryKeysList(List inquiryKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
inquiryKeysList - 参照キーの出力テーブル

setInquiryItemsInXList

public void setInquiryItemsInXList(List inquiryItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
inquiryItemsInXList - 明細データチェックボックス

setInquiryItemsInList

public void setInquiryItemsInList(List inquiryItemsInList)
明細データを設定します。

パラメータ:
inquiryItemsInList - 明細データ

setInquiryCfgsInstList

public void setInquiryCfgsInstList(List inquiryCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
inquiryCfgsInstList - 選定: インスタンス

setInquiryCfgsPartOfList

public void setInquiryCfgsPartOfList(List inquiryCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
inquiryCfgsPartOfList - 選定: 部分設定

setInquiryConditionsInXList

public void setInquiryConditionsInXList(List inquiryConditionsInXList)
受注における条件更新の通信項目を設定します。

パラメータ:
inquiryConditionsInXList - 受注における条件更新の通信項目

setInquiryConditionsInList

public void setInquiryConditionsInList(List inquiryConditionsInList)
条件を設定します。

パラメータ:
inquiryConditionsInList - 条件

setInquiryCfgsVkList

public void setInquiryCfgsVkList(List inquiryCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
inquiryCfgsVkList - 選定: バリアント条件キー

setInquiryCfgsValueList

public void setInquiryCfgsValueList(List inquiryCfgsValueList)
選定: 特性値を設定します。

パラメータ:
inquiryCfgsValueList - 選定: 特性値

setInquiryCfgsRefInstList

public void setInquiryCfgsRefInstList(List inquiryCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
inquiryCfgsRefInstList - 選定: 参照明細/インスタンス

setInquiryCfgsRefList

public void setInquiryCfgsRefList(List inquiryCfgsRefList)
選定: 参照データを設定します。

パラメータ:
inquiryCfgsRefList - 選定: 参照データ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
クラス
InquiryCreateFromData2


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

クラスの概要
InquiryCreateFromData2 引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 のクラス
InquiryCreateFromData2
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 の使用

QuotationCreateFromData2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での QuotationCreateFromData2 の使用

jp.co.intra_mart.foundation.sap.module.sales での QuotationCreateFromData2 のサブクラス
 class QuotationCreateFromData2Controller
見積伝票登録情報コントローラクラス
機能は以下の通り
見積伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
クラス
QuotationCreateFromData2


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

クラスの概要
QuotationCreateFromData2 見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 のクラス
QuotationCreateFromData2
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


QuotationCreateFromData2 (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
クラス QuotationCreateFromData2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
QuotationCreateFromData2Controller
public class QuotationCreateFromData2
extends UpdateController
implements Serializable

見積伝票登録情報クラス
機能は以下の通り

  • 見積伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
QuotationCreateFromData2()
コンストラクタ。
QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 取引先機能/受注伝票タイプの変換を取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
List | getQuotationCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getQuotationCfgsInstList() 選定: インスタンスを取得します。
List | getQuotationCfgsPartOfList() 選定: 部分設定を取得します。
List | getQuotationCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getQuotationCfgsRefList() 選定: 参照データを取得します。
List | getQuotationCfgsValueList() 選定: 特性値を取得します。
List | getQuotationCfgsVkList() 選定: バリアント条件キーを取得します。
List | getQuotationConditionsInList() 条件を取得します。
List | getQuotationConditionsInXList() 受注における条件更新の通信項目を取得します。
HeaderIn | getQuotationHeaderIn() 伝票ヘッダデータを取得します。
HeaderInX | getQuotationHeaderInX() 伝票ヘッダチェックボックスを取得します。
List | getQuotationItemsInList() 明細データを取得します。
List | getQuotationItemsInXList() 明細データチェックボックスを取得します。
List | getQuotationKeysList() 参照キーの出力テーブルを取得します。
List | getQuotationPartnersList() 伝票取引先を取得します。
List | getQuotationSchedulesInList() 納入日程行データを取得します。
List | getQuotationSchedulesInXList() 納入日程行データチェックボックスを取得します。
List | getQuotationTextList() テキストを取得します。
String | getSalesdocument() 販売管理伝票番号を取得します。
String | getSalesdocumentin() 見積伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 取引先機能/受注伝票タイプの変換を設定します。
void | setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setQuotationCfgsBlobList(List quotationCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setQuotationCfgsInstList(List quotationCfgsInstList) 選定: インスタンスを設定します。
void | setQuotationCfgsPartOfList(List quotationCfgsPartOfList) 選定: 部分設定を設定します。
void | setQuotationCfgsRefInstList(List quotationCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setQuotationCfgsRefList(List quotationCfgsRefList) 選定: 参照データを設定します。
void | setQuotationCfgsValueList(List quotationCfgsValueList) 選定: 特性値を設定します。
void | setQuotationCfgsVkList(List quotationCfgsVkList) 選定: バリアント条件キーを設定します。
void | setQuotationConditionsInList(List quotationConditionsInList) 条件を設定します。
void | setQuotationConditionsInXList(List quotationConditionsInXList) 受注における条件更新の通信項目を設定します。
void | setQuotationHeaderIn(HeaderIn quotationHeaderIn) 伝票ヘッダデータを設定します。
void | setQuotationHeaderInX(HeaderInX quotationHeaderInX) 伝票ヘッダチェックボックスを設定します。
void | setQuotationItemsInList(List quotationItemsInList) 明細データを設定します。
void | setQuotationItemsInXList(List quotationItemsInXList) 明細データチェックボックスを設定します。
void | setQuotationKeysList(List quotationKeysList) 参照キーの出力テーブルを設定します。
void | setQuotationPartnersList(List quotationPartnersList) 伝票取引先を設定します。
void | setQuotationSchedulesInList(List quotationSchedulesInList) 納入日程行データを設定します。
void | setQuotationSchedulesInXList(List quotationSchedulesInXList) 納入日程行データチェックボックスを設定します。
void | setQuotationTextList(List quotationTextList) テキストを設定します。
void | setSalesdocument(String salesdocument) 販売管理伝票番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 見積伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

QuotationCreateFromData2

public QuotationCreateFromData2()
コンストラクタ。

QuotationCreateFromData2

public QuotationCreateFromData2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

QuotationCreateFromData2

public QuotationCreateFromData2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getConvert

public String getConvert()
取引先機能/受注伝票タイプの変換を取得します。

戻り値:
convert 取引先機能/受注伝票タイプの変換

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getSalesdocumentin

public String getSalesdocumentin()
見積伝票番号を取得します。

戻り値:
salesdocumentin 見積伝票番号

getSalesdocument

public String getSalesdocument()
販売管理伝票番号を取得します。

戻り値:
salesdocument 販売管理伝票番号

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getQuotationHeaderInX

public HeaderInX getQuotationHeaderInX()
伝票ヘッダチェックボックスを取得します。

戻り値:
quotationHeaderInX 伝票ヘッダチェックボックス

getQuotationHeaderIn

public HeaderIn getQuotationHeaderIn()
伝票ヘッダデータを取得します。

戻り値:
quotationHeaderIn 伝票ヘッダデータ

getQuotationTextList

public List getQuotationTextList()
テキストを取得します。

戻り値:
quotationTextList テキスト

getQuotationSchedulesInXList

public List getQuotationSchedulesInXList()
納入日程行データチェックボックスを取得します。

戻り値:
quotationSchedulesInXList 納入日程行データチェックボックス

getQuotationSchedulesInList

public List getQuotationSchedulesInList()
納入日程行データを取得します。

戻り値:
quotationSchedulesInList 納入日程行データ

getQuotationPartnersList

public List getQuotationPartnersList()
伝票取引先を取得します。

戻り値:
quotationPartnersList 伝票取引先

getQuotationKeysList

public List getQuotationKeysList()
参照キーの出力テーブルを取得します。

戻り値:
quotationKeysList 参照キーの出力テーブル

getQuotationItemsInXList

public List getQuotationItemsInXList()
明細データチェックボックスを取得します。

戻り値:
quotationItemsInXList 明細データチェックボックス

getQuotationItemsInList

public List getQuotationItemsInList()
明細データを取得します。

戻り値:
quotationItemsInList 明細データ

getQuotationConditionsInXList

public List getQuotationConditionsInXList()
受注における条件更新の通信項目を取得します。

戻り値:
quotationConditionsInXList 受注における条件更新の通信項目

getQuotationConditionsInList

public List getQuotationConditionsInList()
条件を取得します。

戻り値:
quotationConditionsInList 条件

getQuotationCfgsVkList

public List getQuotationCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
quotationCfgsVkList 選定: バリアント条件キー

getQuotationCfgsValueList

public List getQuotationCfgsValueList()
選定: 特性値を取得します。

戻り値:
quotationCfgsValueList 選定: 特性値

getQuotationCfgsRefInstList

public List getQuotationCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
quotationCfgsRefInstList 選定: 参照明細/インスタンス

getQuotationCfgsRefList

public List getQuotationCfgsRefList()
選定: 参照データを取得します。

戻り値:
quotationCfgsRefList 選定: 参照データ

getQuotationCfgsPartOfList

public List getQuotationCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
quotationCfgsPartOfList 選定: 部分設定

getQuotationCfgsInstList

public List getQuotationCfgsInstList()
選定: インスタンスを取得します。

戻り値:
quotationCfgsInstList 選定: インスタンス

getQuotationCfgsBlobList

public List getQuotationCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
quotationCfgsBlobList 選定: BLOB 内部データ (SCE)

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setConvert

public void setConvert(String convert)
取引先機能/受注伝票タイプの変換を設定します。

パラメータ:
convert - 取引先機能/受注伝票タイプの変換

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
見積伝票番号を設定します。

パラメータ:
salesdocumentin - 見積伝票番号

setSalesdocument

public void setSalesdocument(String salesdocument)
販売管理伝票番号を設定します。

パラメータ:
salesdocument - 販売管理伝票番号

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setQuotationHeaderInX

public void setQuotationHeaderInX(HeaderInX quotationHeaderInX)
伝票ヘッダチェックボックスを設定します。

パラメータ:
quotationHeaderInX - 伝票ヘッダチェックボックス

setQuotationHeaderIn

public void setQuotationHeaderIn(HeaderIn quotationHeaderIn)
伝票ヘッダデータを設定します。

パラメータ:
quotationHeaderIn - 伝票ヘッダデータ

setQuotationTextList

public void setQuotationTextList(List quotationTextList)
テキストを設定します。

パラメータ:
quotationTextList - テキスト

setQuotationSchedulesInXList

public void setQuotationSchedulesInXList(List quotationSchedulesInXList)
納入日程行データチェックボックスを設定します。

パラメータ:
quotationSchedulesInXList - 納入日程行データチェックボックス

setQuotationSchedulesInList

public void setQuotationSchedulesInList(List quotationSchedulesInList)
納入日程行データを設定します。

パラメータ:
quotationSchedulesInList - 納入日程行データ

setQuotationPartnersList

public void setQuotationPartnersList(List quotationPartnersList)
伝票取引先を設定します。

パラメータ:
quotationPartnersList - 伝票取引先

setQuotationKeysList

public void setQuotationKeysList(List quotationKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
quotationKeysList - 参照キーの出力テーブル

setQuotationItemsInXList

public void setQuotationItemsInXList(List quotationItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
quotationItemsInXList - 明細データチェックボックス

setQuotationItemsInList

public void setQuotationItemsInList(List quotationItemsInList)
明細データを設定します。

パラメータ:
quotationItemsInList - 明細データ

setQuotationConditionsInXList

public void setQuotationConditionsInXList(List quotationConditionsInXList)
受注における条件更新の通信項目を設定します。

パラメータ:
quotationConditionsInXList - 受注における条件更新の通信項目

setQuotationConditionsInList

public void setQuotationConditionsInList(List quotationConditionsInList)
条件を設定します。

パラメータ:
quotationConditionsInList - 条件

setQuotationCfgsVkList

public void setQuotationCfgsVkList(List quotationCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
quotationCfgsVkList - 選定: バリアント条件キー

setQuotationCfgsValueList

public void setQuotationCfgsValueList(List quotationCfgsValueList)
選定: 特性値を設定します。

パラメータ:
quotationCfgsValueList - 選定: 特性値

setQuotationCfgsRefInstList

public void setQuotationCfgsRefInstList(List quotationCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
quotationCfgsRefInstList - 選定: 参照明細/インスタンス

setQuotationCfgsRefList

public void setQuotationCfgsRefList(List quotationCfgsRefList)
選定: 参照データを設定します。

パラメータ:
quotationCfgsRefList - 選定: 参照データ

setQuotationCfgsPartOfList

public void setQuotationCfgsPartOfList(List quotationCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
quotationCfgsPartOfList - 選定: 部分設定

setQuotationCfgsInstList

public void setQuotationCfgsInstList(List quotationCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
quotationCfgsInstList - 選定: インスタンス

setQuotationCfgsBlobList

public void setQuotationCfgsBlobList(List quotationCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
quotationCfgsBlobList - 選定: BLOB 内部データ (SCE)

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 の使用

SalesOrderCreateFromDat2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderCreateFromDat2 の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderCreateFromDat2 のサブクラス
 class SalesOrderCreateFromDat2Controller
受注伝票登録コントローラクラス
機能は以下の通り
受注伝票を登録します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


OrderCcard (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス OrderCcard

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard
すべての実装インタフェース:
Serializable
public class OrderCcard
extends Object
implements Serializable

クレジットカードデータ情報クラス
機能は以下の通り

  • クレジットカードデータ情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
OrderCcard()
クレジットカードデータ情報を作成します。
OrderCcard(int index)
クレジットカードデータ情報を作成します。
メソッドの概要
String | getAuthamount() 支払カード: 承認額を取得します。
String | getAuthCcNo() 支払カード: 承認番号を取得します。
String | getAuthDate() 支払カード: 承認日を取得します。
String | getAuthFlag() 支払カード: 振替権限を取得します。
String | getAuthRefno() 支払カード: 決済代行会社の権限参照コードを取得します。
String | getAuthTime() 支払カード: 承認時刻を取得します。
String | getBillamount() 請求金額: 請求計画に請求日付が指定されている場合を取得します。
String | getCcName() 支払カード: カード所有者の氏名を取得します。
String | getCcNumber() 支払カード: カード番号を取得します。
String | getCcReact() 支払カード: 権限確認に対する応答を取得します。
String | getCcReactT() 支払カード: 結果テキストを取得します。
String | getCcReAmount() BAPI インタフェースの通貨金額を取得します。
String | getCcStatEx() 支払カード: 外部システム呼出時のステータスを取得します。
String | getCcType() 支払カードタイプ: カードタイプを取得します。
String | getCcValidT() 支払カード: 有効終了日を取得します。
String | getCurrency() 通貨コードを取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getGlAccount() G/L 勘定コードを取得します。
int | getIndex() レコード番号を取得します｡
String | getMerchidcl() 支払カード: 決済代行会社のマーチャント IDを取得します。
String | getVirtCard() チェックボックスを取得します。
void | setAuthamount(String authamount) 支払カード: 承認額を設定します。
void | setAuthCcNo(String authCcNo) 支払カード: 承認番号を設定します。
void | setAuthDate(String authDate) 支払カード: 承認日を設定します。
void | setAuthFlag(String authFlag) 支払カード: 振替権限を設定します。
void | setAuthRefno(String authRefno) 支払カード: 決済代行会社の権限参照コードを設定します。
void | setAuthTime(String authTime) 支払カード: 承認時刻を設定します。
void | setBillamount(String billamount) 請求金額: 請求計画に請求日付が指定されている場合を設定します。
void | setCcName(String ccName) 支払カード: カード所有者の氏名を設定します。
void | setCcNumber(String ccNumber) 支払カード: カード番号を設定します。
void | setCcReact(String ccReact) 支払カード: 権限確認に対する応答を設定します。
void | setCcReactT(String ccReactT) 支払カード: 結果テキストを設定します。
void | setCcReAmount(String ccReAmount) BAPI インタフェースの通貨金額を設定します。
void | setCcStatEx(String ccStatEx) 支払カード: 外部システム呼出時のステータスを設定します。
void | setCcType(String ccType) 支払カードタイプ: カードタイプを設定します。
void | setCcValidT(String ccValidT) 支払カード: 有効終了日を設定します。
void | setCurrency(String currency) 通貨コードを設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setGlAccount(String glAccount) G/L 勘定コードを設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setMerchidcl(String merchidcl) 支払カード: 決済代行会社のマーチャント IDを設定します。
void | setVirtCard(String virtCard) チェックボックスを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

OrderCcard

public OrderCcard()
クレジットカードデータ情報を作成します。

OrderCcard

public OrderCcard(int index)
クレジットカードデータ情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getCcType

public String getCcType()
支払カードタイプ: カードタイプを取得します。

戻り値:
ccType 支払カードタイプ: カードタイプ

getCcNumber

public String getCcNumber()
支払カード: カード番号を取得します。

戻り値:
ccNumber 支払カード: カード番号

getCcValidT

public String getCcValidT()
支払カード: 有効終了日を取得します。

戻り値:
ccValidT 支払カード: 有効終了日

getCcName

public String getCcName()
支払カード: カード所有者の氏名を取得します。

戻り値:
ccName 支払カード: カード所有者の氏名

getBillamount

public String getBillamount()
請求金額: 請求計画に請求日付が指定されている場合を取得します。

戻り値:
billamount 請求金額: 請求計画に請求日付が指定されている場合

getAuthFlag

public String getAuthFlag()
支払カード: 振替権限を取得します。

戻り値:
authFlag 支払カード: 振替権限

getAuthamount

public String getAuthamount()
支払カード: 承認額を取得します。

戻り値:
authamount 支払カード: 承認額

getCurrency

public String getCurrency()
通貨コードを取得します。

戻り値:
currency 通貨コード

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getAuthDate

public String getAuthDate()
支払カード: 承認日を取得します。

戻り値:
authDate 支払カード: 承認日

getAuthTime

public String getAuthTime()
支払カード: 承認時刻を取得します。

戻り値:
authTime 支払カード: 承認時刻

getAuthCcNo

public String getAuthCcNo()
支払カード: 承認番号を取得します。

戻り値:
authCcNo 支払カード: 承認番号

getAuthRefno

public String getAuthRefno()
支払カード: 決済代行会社の権限参照コードを取得します。

戻り値:
authRefno 支払カード: 決済代行会社の権限参照コード

getCcReact

public String getCcReact()
支払カード: 権限確認に対する応答を取得します。

戻り値:
ccReact 支払カード: 権限確認に対する応答

getCcReAmount

public String getCcReAmount()
BAPI インタフェースの通貨金額を取得します。

戻り値:
ccReAmount BAPI インタフェースの通貨金額

getGlAccount

public String getGlAccount()
G/L 勘定コードを取得します。

戻り値:
glAccount G/L 勘定コード

getCcStatEx

public String getCcStatEx()
支払カード: 外部システム呼出時のステータスを取得します。

戻り値:
ccStatEx 支払カード: 外部システム呼出時のステータス

getCcReactT

public String getCcReactT()
支払カード: 結果テキストを取得します。

戻り値:
ccReactT 支払カード: 結果テキスト

getVirtCard

public String getVirtCard()
チェックボックスを取得します。

戻り値:
virtCard チェックボックス

getMerchidcl

public String getMerchidcl()
支払カード: 決済代行会社のマーチャント IDを取得します。

戻り値:
merchidcl 支払カード: 決済代行会社のマーチャント ID

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setCcType

public void setCcType(String ccType)
支払カードタイプ: カードタイプを設定します。

パラメータ:
ccType - 支払カードタイプ: カードタイプ

setCcNumber

public void setCcNumber(String ccNumber)
支払カード: カード番号を設定します。

パラメータ:
ccNumber - 支払カード: カード番号

setCcValidT

public void setCcValidT(String ccValidT)
支払カード: 有効終了日を設定します。

パラメータ:
ccValidT - 支払カード: 有効終了日

setCcName

public void setCcName(String ccName)
支払カード: カード所有者の氏名を設定します。

パラメータ:
ccName - 支払カード: カード所有者の氏名

setBillamount

public void setBillamount(String billamount)
請求金額: 請求計画に請求日付が指定されている場合を設定します。

パラメータ:
billamount - 請求金額: 請求計画に請求日付が指定されている場合

setAuthFlag

public void setAuthFlag(String authFlag)
支払カード: 振替権限を設定します。

パラメータ:
authFlag - 支払カード: 振替権限

setAuthamount

public void setAuthamount(String authamount)
支払カード: 承認額を設定します。

パラメータ:
authamount - 支払カード: 承認額

setCurrency

public void setCurrency(String currency)
通貨コードを設定します。

パラメータ:
currency - 通貨コード

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setAuthDate

public void setAuthDate(String authDate)
支払カード: 承認日を設定します。

パラメータ:
authDate - 支払カード: 承認日

setAuthTime

public void setAuthTime(String authTime)
支払カード: 承認時刻を設定します。

パラメータ:
authTime - 支払カード: 承認時刻

setAuthCcNo

public void setAuthCcNo(String authCcNo)
支払カード: 承認番号を設定します。

パラメータ:
authCcNo - 支払カード: 承認番号

setAuthRefno

public void setAuthRefno(String authRefno)
支払カード: 決済代行会社の権限参照コードを設定します。

パラメータ:
authRefno - 支払カード: 決済代行会社の権限参照コード

setCcReact

public void setCcReact(String ccReact)
支払カード: 権限確認に対する応答を設定します。

パラメータ:
ccReact - 支払カード: 権限確認に対する応答

setCcReAmount

public void setCcReAmount(String ccReAmount)
BAPI インタフェースの通貨金額を設定します。

パラメータ:
ccReAmount - BAPI インタフェースの通貨金額

setGlAccount

public void setGlAccount(String glAccount)
G/L 勘定コードを設定します。

パラメータ:
glAccount - G/L 勘定コード

setCcStatEx

public void setCcStatEx(String ccStatEx)
支払カード: 外部システム呼出時のステータスを設定します。

パラメータ:
ccStatEx - 支払カード: 外部システム呼出時のステータス

setCcReactT

public void setCcReactT(String ccReactT)
支払カード: 結果テキストを設定します。

パラメータ:
ccReactT - 支払カード: 結果テキスト

setVirtCard

public void setVirtCard(String virtCard)
チェックボックスを設定します。

パラメータ:
virtCard - チェックボックス

setMerchidcl

public void setMerchidcl(String merchidcl)
支払カード: 決済代行会社のマーチャント IDを設定します。

パラメータ:
merchidcl - 支払カード: 決済代行会社のマーチャント ID

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス
OrderCcard
ParamOrderCcard
SalesOrderCreateFromDat2


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

クラスの概要
OrderCcard | クレジットカードデータ情報クラス 機能は以下の通り クレジットカードデータ情報を保持します。
ParamOrderCcard | クレジットカードデータ情報パラメータ設定クラス 機能は以下の通り クレジットカードデータ情報のパラメータを設定します。
SalesOrderCreateFromDat2 | 受注伝票登録情報クラス 機能は以下の通り 受注伝票登録情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 のクラス
SalesOrderCreateFromDat2
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamOrderCcard (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス ParamOrderCcard

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard
すべての実装インタフェース:
Serializable
public final class ParamOrderCcard
extends Object
implements Serializable

クレジットカードデータ情報パラメータ設定クラス
機能は以下の通り

  • クレジットカードデータ情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List orderCcardList) table(Export)情報からクレジットカードデータの値をセットします。
static void | setImportParam(BapiController bapiController, List orderCcardList) クレジットカードデータに値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List orderCcardList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
クレジットカードデータに値をセットします。

パラメータ:
bapiController - BapiController
orderCcardList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List orderCcardList)
                           throws SAPGeneralSystemException
table(Export)情報からクレジットカードデータの値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
orderCcardList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderCreateFromDat2 (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
クラス SalesOrderCreateFromDat2

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderCreateFromDat2Controller
public class SalesOrderCreateFromDat2
extends UpdateController
implements Serializable

受注伝票登録情報クラス
機能は以下の通り

  • 受注伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderCreateFromDat2()
コンストラクタ。
SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。
SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
メソッドの概要
String | getBehaveWhenError() エラー処理を取得します。
String | getBinaryRelationshiptype() バイナリ関連タイプ (専用)を取得します。
String | getConvert() 変換: 取引先機能 + 受注伝票タイプを取得します。
List | getExtensionInList() VBAK、VBAP、VBEP のカスタマ拡張を取得します。
String | getIntNumberAssignment() 明細番号内部採番を取得します。
LogicSwitch | getLogicSwitch() 内部制御パラメータを取得します。
List | getOrderCcardList() クレジットカードデータを取得します。
List | getOrderCfgsBlobList() 選定: BLOB 内部データ (SCE)を取得します。
List | getOrderCfgsInstList() 選定: インスタンスを取得します。
List | getOrderCfgsPartOfList() 選定: 部分設定を取得します。
List | getOrderCfgsRefInstList() 選定: 参照明細/インスタンスを取得します。
List | getOrderCfgsRefList() 選定: 参照データを取得します。
List | getOrderCfgsValueList() 選定: 特性値を取得します。
List | getOrderCfgsVkList() 選定: バリアント条件キーを取得します。
List | getOrderConditionsInList() 条件を取得します。
List | getOrderConditionsInXList() 条件チェックボックスを取得します。
HeaderIn | getOrderHeaderIn() 受注伝票ヘッダを取得します。
HeaderInX | getOrderHeaderInX() 受注伝票チェックリストを取得します。
List | getOrderItemsInList() 明細データを取得します。
List | getOrderItemsInXList() 明細データチェックボックスを取得します。
List | getOrderKeysList() 参照キーの出力テーブルを取得します。
List | getOrderPartnersList() 伝票取引先を取得します。
List | getOrderSchedulesInList() 納入日程行データを取得します。
List | getOrderSchedulesInXList() 納入日程行データチェックボックスを取得します。
List | getOrderTextList() テキストを取得します。
List | getPartnerAddressesList() アドレス (組織/会社) 用 BAPI 参照構造を取得します。
String | getSalesdocument() 生成された伝票の番号を取得します。
String | getSalesdocumentin() 販売管理伝票番号を取得します。
Sender | getSender() 論理システム - 送信者を取得します。
String | getTestrun() テスト実行を取得します。
void | setBehaveWhenError(String behaveWhenError) エラー処理を設定します。
void | setBinaryRelationshiptype(String binaryRelationshiptype) バイナリ関連タイプ (専用)を設定します。
void | setConvert(String convert) 変換: 取引先機能 + 受注伝票タイプを設定します。
void | setExportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setExtensionInList(List extensionInList) VBAK、VBAP、VBEP のカスタマ拡張を設定します。
void | setImportParam(BapiController bapiController) 見積伝票に登録する値ををセットします。
void | setIntNumberAssignment(String intNumberAssignment) 明細番号内部採番を設定します。
void | setLogicSwitch(LogicSwitch logicSwitch) 内部制御パラメータを設定します。
void | setOrderCcardList(List orderCcardList) クレジットカードデータを設定します。
void | setOrderCfgsBlobList(List orderCfgsBlobList) 選定: BLOB 内部データ (SCE)を設定します。
void | setOrderCfgsInstList(List orderCfgsInstList) 選定: インスタンスを設定します。
void | setOrderCfgsPartOfList(List orderCfgsPartOfList) 選定: 部分設定を設定します。
void | setOrderCfgsRefInstList(List orderCfgsRefInstList) 選定: 参照明細/インスタンスを設定します。
void | setOrderCfgsRefList(List orderCfgsRefList) 選定: 参照データを設定します。
void | setOrderCfgsValueList(List orderCfgsValueList) 選定: 特性値を設定します。
void | setOrderCfgsVkList(List orderCfgsVkList) 選定: バリアント条件キーを設定します。
void | setOrderConditionsInList(List orderConditionsInList) 条件を設定します。
void | setOrderConditionsInXList(List orderConditionsInXList) 条件チェックボックスを設定します。
void | setOrderHeaderIn(HeaderIn orderHeaderIn) 受注伝票ヘッダを設定します。
void | setOrderHeaderInX(HeaderInX orderHeaderInX) 受注伝票チェックリストを設定します。
void | setOrderItemsInList(List orderItemsInList) 明細データを設定します。
void | setOrderItemsInXList(List orderItemsInXList) 明細データチェックボックスを設定します。
void | setOrderKeysList(List orderKeysList) 参照キーの出力テーブルを設定します。
void | setOrderPartnersList(List orderPartnersList) 伝票取引先を設定します。
void | setOrderSchedulesInList(List orderSchedulesInList) 納入日程行データを設定します。
void | setOrderSchedulesInXList(List orderSchedulesInXList) 納入日程行データチェックボックスを設定します。
void | setOrderTextList(List orderTextList) テキストを設定します。
void | setPartnerAddressesList(List partnerAddressesList) アドレス (組織/会社) 用 BAPI 参照構造を設定します。
void | setSalesdocument(String salesdocument) 生成された伝票の番号を設定します。
void | setSalesdocumentin(String salesdocumentin) 販売管理伝票番号を設定します。
void | setSender(Sender sender) 論理システム - 送信者を設定します。
void | setTestrun(String testrun) テスト実行を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2()
コンストラクタ。

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2(ConnectionManager conectionManager)
コネクションマネージャーを引数に持つコンストラクタ。

パラメータ:
conectionManager - コネクションマネージャー

SalesOrderCreateFromDat2

public SalesOrderCreateFromDat2(SapClient sapClient)
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
見積伝票に登録する値ををセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesdocumentin

public String getSalesdocumentin()
販売管理伝票番号を取得します。

戻り値:
salesdocumentin 販売管理伝票番号

getIntNumberAssignment

public String getIntNumberAssignment()
明細番号内部採番を取得します。

戻り値:
intNumberAssignment 明細番号内部採番

getTestrun

public String getTestrun()
テスト実行を取得します。

戻り値:
testrun テスト実行

getConvert

public String getConvert()
変換: 取引先機能 + 受注伝票タイプを取得します。

戻り値:
convert 変換: 取引先機能 + 受注伝票タイプ

getBinaryRelationshiptype

public String getBinaryRelationshiptype()
バイナリ関連タイプ (専用)を取得します。

戻り値:
binaryRelationshiptype バイナリ関連タイプ (専用)

getBehaveWhenError

public String getBehaveWhenError()
エラー処理を取得します。

戻り値:
behaveWhenError エラー処理

getSalesdocument

public String getSalesdocument()
生成された伝票の番号を取得します。

戻り値:
salesdocument 生成された伝票の番号

getOrderHeaderIn

public HeaderIn getOrderHeaderIn()
受注伝票ヘッダを取得します。

戻り値:
orderHeaderIn 受注伝票ヘッダ

getOrderHeaderInX

public HeaderInX getOrderHeaderInX()
受注伝票チェックリストを取得します。

戻り値:
orderHeaderInX 受注伝票チェックリスト

getSender

public Sender getSender()
論理システム - 送信者を取得します。

戻り値:
sender 論理システム - 送信者

getLogicSwitch

public LogicSwitch getLogicSwitch()
内部制御パラメータを取得します。

戻り値:
logicSwitch 内部制御パラメータ

getOrderItemsInXList

public List getOrderItemsInXList()
明細データチェックボックスを取得します。

戻り値:
orderItemsInXList 明細データチェックボックス

getOrderKeysList

public List getOrderKeysList()
参照キーの出力テーブルを取得します。

戻り値:
orderKeysList 参照キーの出力テーブル

getOrderPartnersList

public List getOrderPartnersList()
伝票取引先を取得します。

戻り値:
orderPartnersList 伝票取引先

getOrderSchedulesInList

public List getOrderSchedulesInList()
納入日程行データを取得します。

戻り値:
orderSchedulesInList 納入日程行データ

getOrderSchedulesInXList

public List getOrderSchedulesInXList()
納入日程行データチェックボックスを取得します。

戻り値:
orderSchedulesInXList 納入日程行データチェックボックス

getOrderTextList

public List getOrderTextList()
テキストを取得します。

戻り値:
orderTextList テキスト

getPartnerAddressesList

public List getPartnerAddressesList()
アドレス (組織/会社) 用 BAPI 参照構造を取得します。

戻り値:
partnerAddressesList アドレス (組織/会社) 用 BAPI 参照構造

getExtensionInList

public List getExtensionInList()
VBAK、VBAP、VBEP のカスタマ拡張を取得します。

戻り値:
extensionInList VBAK、VBAP、VBEP のカスタマ拡張

getOrderCcardList

public List getOrderCcardList()
クレジットカードデータを取得します。

戻り値:
orderCcardList クレジットカードデータ

getOrderCfgsBlobList

public List getOrderCfgsBlobList()
選定: BLOB 内部データ (SCE)を取得します。

戻り値:
orderCfgsBlobList 選定: BLOB 内部データ (SCE)

getOrderCfgsInstList

public List getOrderCfgsInstList()
選定: インスタンスを取得します。

戻り値:
orderCfgsInstList 選定: インスタンス

getOrderCfgsPartOfList

public List getOrderCfgsPartOfList()
選定: 部分設定を取得します。

戻り値:
orderCfgsPartOfList 選定: 部分設定

getOrderCfgsRefList

public List getOrderCfgsRefList()
選定: 参照データを取得します。

戻り値:
orderCfgsRefList 選定: 参照データ

getOrderCfgsRefInstList

public List getOrderCfgsRefInstList()
選定: 参照明細/インスタンスを取得します。

戻り値:
orderCfgsRefInstList 選定: 参照明細/インスタンス

getOrderCfgsValueList

public List getOrderCfgsValueList()
選定: 特性値を取得します。

戻り値:
orderCfgsValueList 選定: 特性値

getOrderCfgsVkList

public List getOrderCfgsVkList()
選定: バリアント条件キーを取得します。

戻り値:
orderCfgsVkList 選定: バリアント条件キー

getOrderConditionsInList

public List getOrderConditionsInList()
条件を取得します。

戻り値:
orderConditionsInList 条件

getOrderConditionsInXList

public List getOrderConditionsInXList()
条件チェックボックスを取得します。

戻り値:
orderConditionsInXList 条件チェックボックス

getOrderItemsInList

public List getOrderItemsInList()
明細データを取得します。

戻り値:
orderItemsInList 明細データ

setSalesdocumentin

public void setSalesdocumentin(String salesdocumentin)
販売管理伝票番号を設定します。

パラメータ:
salesdocumentin - 販売管理伝票番号

setIntNumberAssignment

public void setIntNumberAssignment(String intNumberAssignment)
明細番号内部採番を設定します。

パラメータ:
intNumberAssignment - 明細番号内部採番

setTestrun

public void setTestrun(String testrun)
テスト実行を設定します。

パラメータ:
testrun - テスト実行

setConvert

public void setConvert(String convert)
変換: 取引先機能 + 受注伝票タイプを設定します。

パラメータ:
convert - 変換: 取引先機能 + 受注伝票タイプ

setBinaryRelationshiptype

public void setBinaryRelationshiptype(String binaryRelationshiptype)
バイナリ関連タイプ (専用)を設定します。

パラメータ:
binaryRelationshiptype - バイナリ関連タイプ (専用)

setBehaveWhenError

public void setBehaveWhenError(String behaveWhenError)
エラー処理を設定します。

パラメータ:
behaveWhenError - エラー処理

setSalesdocument

public void setSalesdocument(String salesdocument)
生成された伝票の番号を設定します。

パラメータ:
salesdocument - 生成された伝票の番号

setOrderHeaderIn

public void setOrderHeaderIn(HeaderIn orderHeaderIn)
受注伝票ヘッダを設定します。

パラメータ:
orderHeaderIn - 受注伝票ヘッダ

setOrderHeaderInX

public void setOrderHeaderInX(HeaderInX orderHeaderInX)
受注伝票チェックリストを設定します。

パラメータ:
orderHeaderInX - 受注伝票チェックリスト

setSender

public void setSender(Sender sender)
論理システム - 送信者を設定します。

パラメータ:
sender - 論理システム - 送信者

setLogicSwitch

public void setLogicSwitch(LogicSwitch logicSwitch)
内部制御パラメータを設定します。

パラメータ:
logicSwitch - 内部制御パラメータ

setOrderItemsInXList

public void setOrderItemsInXList(List orderItemsInXList)
明細データチェックボックスを設定します。

パラメータ:
orderItemsInXList - 明細データチェックボックス

setOrderKeysList

public void setOrderKeysList(List orderKeysList)
参照キーの出力テーブルを設定します。

パラメータ:
orderKeysList - 参照キーの出力テーブル

setOrderPartnersList

public void setOrderPartnersList(List orderPartnersList)
伝票取引先を設定します。

パラメータ:
orderPartnersList - 伝票取引先

setOrderSchedulesInList

public void setOrderSchedulesInList(List orderSchedulesInList)
納入日程行データを設定します。

パラメータ:
orderSchedulesInList - 納入日程行データ

setOrderSchedulesInXList

public void setOrderSchedulesInXList(List orderSchedulesInXList)
納入日程行データチェックボックスを設定します。

パラメータ:
orderSchedulesInXList - 納入日程行データチェックボックス

setOrderTextList

public void setOrderTextList(List orderTextList)
テキストを設定します。

パラメータ:
orderTextList - テキスト

setPartnerAddressesList

public void setPartnerAddressesList(List partnerAddressesList)
アドレス (組織/会社) 用 BAPI 参照構造を設定します。

パラメータ:
partnerAddressesList - アドレス (組織/会社) 用 BAPI 参照構造

setExtensionInList

public void setExtensionInList(List extensionInList)
VBAK、VBAP、VBEP のカスタマ拡張を設定します。

パラメータ:
extensionInList - VBAK、VBAP、VBEP のカスタマ拡張

setOrderCcardList

public void setOrderCcardList(List orderCcardList)
クレジットカードデータを設定します。

パラメータ:
orderCcardList - クレジットカードデータ

setOrderCfgsBlobList

public void setOrderCfgsBlobList(List orderCfgsBlobList)
選定: BLOB 内部データ (SCE)を設定します。

パラメータ:
orderCfgsBlobList - 選定: BLOB 内部データ (SCE)

setOrderCfgsInstList

public void setOrderCfgsInstList(List orderCfgsInstList)
選定: インスタンスを設定します。

パラメータ:
orderCfgsInstList - 選定: インスタンス

setOrderCfgsPartOfList

public void setOrderCfgsPartOfList(List orderCfgsPartOfList)
選定: 部分設定を設定します。

パラメータ:
orderCfgsPartOfList - 選定: 部分設定

setOrderCfgsRefList

public void setOrderCfgsRefList(List orderCfgsRefList)
選定: 参照データを設定します。

パラメータ:
orderCfgsRefList - 選定: 参照データ

setOrderCfgsRefInstList

public void setOrderCfgsRefInstList(List orderCfgsRefInstList)
選定: 参照明細/インスタンスを設定します。

パラメータ:
orderCfgsRefInstList - 選定: 参照明細/インスタンス

setOrderCfgsValueList

public void setOrderCfgsValueList(List orderCfgsValueList)
選定: 特性値を設定します。

パラメータ:
orderCfgsValueList - 選定: 特性値

setOrderCfgsVkList

public void setOrderCfgsVkList(List orderCfgsVkList)
選定: バリアント条件キーを設定します。

パラメータ:
orderCfgsVkList - 選定: バリアント条件キー

setOrderConditionsInList

public void setOrderConditionsInList(List orderConditionsInList)
条件を設定します。

パラメータ:
orderConditionsInList - 条件

setOrderConditionsInXList

public void setOrderConditionsInXList(List orderConditionsInXList)
条件チェックボックスを設定します。

パラメータ:
orderConditionsInXList - 条件チェックボックス

setOrderItemsInList

public void setOrderItemsInList(List orderItemsInList)
明細データを設定します。

パラメータ:
orderItemsInList - 明細データ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList の使用

SalesOrderGetList を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetList の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetList のサブクラス
 class SalesOrderGetListController
販売伝票一覧照会コントローラクラス
機能は以下の通り
販売伝票一覧の情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス
ParamSalesOrders
SalesOrderGetList
SalesOrders


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

クラスの概要
ParamSalesOrders | 得意先受注テーブル情報パラメータ設定クラス 機能は以下の通り 得意先受注テーブル情報のパラメータを設定します。
SalesOrderGetList | 販売伝票一覧照会情報クラス 機能は以下の通り 販売伝票一覧照会情報を保持します。
SalesOrders | 得意先受注テーブル情報クラス 機能は以下の通り 得意先受注テーブル情報を保持します。


jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist のクラス
SalesOrderGetList
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamSalesOrders (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス ParamSalesOrders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders
すべての実装インタフェース:
Serializable
public final class ParamSalesOrders
extends Object
implements Serializable

得意先受注テーブル情報パラメータ設定クラス
機能は以下の通り

  • 得意先受注テーブル情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List salesOrdersList) table(Export)情報から得意先受注テーブル情報の値をセットします。
static void | setImportParam(BapiController bapiController, List salesOrdersList) 得意先受注テーブル情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List salesOrdersList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
得意先受注テーブル情報の値をセットします。

パラメータ:
bapiController - BapiController
salesOrdersList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List salesOrdersList)
                           throws SAPGeneralSystemException
table(Export)情報から得意先受注テーブル情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
salesOrdersList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetList (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス SalesOrderGetList

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderGetListController
public class SalesOrderGetList
extends ReferenceController
implements Serializable

販売伝票一覧照会情報クラス
機能は以下の通り

  • 販売伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
販売伝票一覧照会情報を作成します。
メソッドの概要
String | getCustomerNumber() 得意先コードを取得します。
String | getDocumentDate() 登録日付を取得します。
String | getDocumentDateTo() 入力日付 (以前/以降)を取得します。
String | getMaterial() 品目コードを取得します。
String | getPurchaseOrder() 得意先発注番号を取得します。
String | getPurchaseOrderNumber() 得意先発注番号1を取得します。
List | getSalesOrdersList() 得意先受注テーブルを取得します。
String | getSalesOrganization() 販売組織を取得します。
String | getTransactionGroup() 一文字フラグを取得します。
void | setCustomerNumber(String customerNumber) 得意先コードを設定します。
void | setDocumentDate(String documentDate) 登録日付を設定します。
void | setDocumentDateTo(String documentDateTo) 入力日付 (以前/以降)を設定します。
void | setExportParam(BapiController bapiController) 返却された販売伝票一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 販売伝票一覧の検索条件をセットします。
void | setMaterial(String material) 品目コードを設定します。
void | setPurchaseOrder(String purchaseOrder) 得意先発注番号を設定します。
void | setPurchaseOrderNumber(String purchaseOrderNumber) 得意先発注番号1を設定します。
void | setSalesOrdersList(List salesOrdersList) 得意先受注テーブルを設定します。
void | setSalesOrganization(String salesOrganization) 販売組織を設定します。
void | setTransactionGroup(String transactionGroup) 一文字フラグを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetList

public SalesOrderGetList(SapClient sapClient)
販売伝票一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

SalesOrderGetList

public SalesOrderGetList(String customerNumber,
                         String salesOrganisation,
                         String material,
                         String purchaseOrder,
                         String transactionGroup,
                         SapClient sapClient)
販売伝票一覧照会情報を作成します。

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ
sapClient - SAPクライアント
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
販売伝票一覧の検索条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された販売伝票一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getCustomerNumber

public String getCustomerNumber()
得意先コードを取得します。

戻り値:
customerNumber 得意先コード

getDocumentDate

public String getDocumentDate()
登録日付を取得します。

戻り値:
documentDate 登録日付

getDocumentDateTo

public String getDocumentDateTo()
入力日付 (以前/以降)を取得します。

戻り値:
documentDateTo 入力日付 (以前/以降)

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getPurchaseOrder

public String getPurchaseOrder()
得意先発注番号を取得します。

戻り値:
purchaseOrder 得意先発注番号

getPurchaseOrderNumber

public String getPurchaseOrderNumber()
得意先発注番号1を取得します。

戻り値:
purchaseOrderNumber 得意先発注番号1

getSalesOrganization

public String getSalesOrganization()
販売組織を取得します。

戻り値:
salesOrganization 販売組織

getTransactionGroup

public String getTransactionGroup()
一文字フラグを取得します。

戻り値:
transactionGroup 一文字フラグ

getSalesOrdersList

public List getSalesOrdersList()
得意先受注テーブルを取得します。

戻り値:
salesOrdersList 得意先受注テーブル

setCustomerNumber

public void setCustomerNumber(String customerNumber)
得意先コードを設定します。

パラメータ:
customerNumber - 得意先コード

setDocumentDate

public void setDocumentDate(String documentDate)
登録日付を設定します。

パラメータ:
documentDate - 登録日付

setDocumentDateTo

public void setDocumentDateTo(String documentDateTo)
入力日付 (以前/以降)を設定します。

パラメータ:
documentDateTo - 入力日付 (以前/以降)

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setPurchaseOrder

public void setPurchaseOrder(String purchaseOrder)
得意先発注番号を設定します。

パラメータ:
purchaseOrder - 得意先発注番号

setPurchaseOrderNumber

public void setPurchaseOrderNumber(String purchaseOrderNumber)
得意先発注番号1を設定します。

パラメータ:
purchaseOrderNumber - 得意先発注番号1

setSalesOrganization

public void setSalesOrganization(String salesOrganization)
販売組織を設定します。

パラメータ:
salesOrganization - 販売組織

setTransactionGroup

public void setTransactionGroup(String transactionGroup)
一文字フラグを設定します。

パラメータ:
transactionGroup - 一文字フラグ

setSalesOrdersList

public void setSalesOrdersList(List salesOrdersList)
得意先受注テーブルを設定します。

パラメータ:
salesOrdersList - 得意先受注テーブル

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrders (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
クラス SalesOrders

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders
すべての実装インタフェース:
Serializable
public class SalesOrders
extends Object
implements Serializable

得意先受注テーブル情報クラス
機能は以下の通り

  • 得意先受注テーブル情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
SalesOrders()
得意先受注テーブル情報を作成します。
SalesOrders(int index)
得意先受注テーブル情報を作成します。
メソッドの概要
String | getBaseUom() 基本数量単位を取得します。
String | getBatch() ロット番号を取得します。
String | getBillBlock() 販売管理伝票の請求ブロックを取得します。
String | getBUomIso() ISO コードでの基本数量単位を取得します。
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondUnit() 条件単位を取得します。
String | getCreationDate() レコード登録日を取得します。
String | getCreationTime() 登録時刻を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDistrChan() 流通チャネルを取得します。
String | getDivision() 製品部門を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvQty() 出荷数量実績 (販売単位)を取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocStatus() 伝票ステータスを取得します。
String | getDocType() 販売伝票タイプを取得します。
String | getExchgRate() 価格設定/統計の換算レート (直接引用)を取得します。
String | getExchgRateV() 価格設定/統計の換算レート (間接引用)を取得します。
String | getGiDate() 出庫日付を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 明細番号 (販売管理伝票)を取得します。
String | getMaterial() 品目コードを取得します。
String | getMatExt() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMatGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMatVers() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getName() 名称 1を取得します。
String | getNetPrice() 正味価格を取得します。
String | getNetValHd() 受注正味額 (伝票通貨)を取得します。
String | getNetValue() 伝票通貨による正味額を取得します。
String | getOrdReason() 受注理由 (取引理由)を取得します。
String | getPlant() プラントを取得します。
String | getPurchNo() 得意先発注番号を取得します。
String | getPurchNoC() 出荷先発注番号を取得します。
String | getReasonRej() 見積および受注の拒否理由を取得します。
String | getReqDate() 指定納期を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesGrp() 営業グループを取得します。
String | getSalesOff() 営業所を取得します。
String | getSalesOrg() 販売組織を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getSdDoc() 販売管理伝票番号を取得します。
String | getShipPoint() 出荷ポイント/入荷ポイントを取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSoldTo() 受注先を取得します。
String | getStoreLoc() 保管場所を取得します。
String | getSUnitIso() ISO コードによる販売単位を取得します。
String | getValidFrom() 見積または基本契約の有効開始日を取得します。
String | getValidTo() 見積または基本契約有効終了日を取得します。
void | setBaseUom(String baseUom) 基本数量単位を設定します。
void | setBatch(String batch) ロット番号を設定します。
void | setBillBlock(String billBlock) 販売管理伝票の請求ブロックを設定します。
void | setBUomIso(String bUomIso) ISO コードでの基本数量単位を設定します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCreationDate(String creationDate) レコード登録日を設定します。
void | setCreationTime(String creationTime) 登録時刻を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDistrChan(String distrChan) 流通チャネルを設定します。
void | setDivision(String division) 製品部門を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvQty(String dlvQty) 出荷数量実績 (販売単位)を設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocStatus(String docStatus) 伝票ステータスを設定します。
void | setDocType(String docType) 販売伝票タイプを設定します。
void | setExchgRate(String exchgRate) 価格設定/統計の換算レート (直接引用)を設定します。
void | setExchgRateV(String exchgRateV) 価格設定/統計の換算レート (間接引用)を設定します。
void | setGiDate(String giDate) 出庫日付を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 明細番号 (販売管理伝票)を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMatExt(String matExt) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMatGuid(String matGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMatVers(String matVers) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setName(String name) 名称 1を設定します。
void | setNetPrice(String netPrice) 正味価格を設定します。
void | setNetValHd(String netValHd) 受注正味額 (伝票通貨)を設定します。
void | setNetValue(String netValue) 伝票通貨による正味額を設定します。
void | setOrdReason(String ordReason) 受注理由 (取引理由)を設定します。
void | setPlant(String plant) プラントを設定します。
void | setPurchNo(String purchNo) 得意先発注番号を設定します。
void | setPurchNoC(String purchNoC) 出荷先発注番号を設定します。
void | setReasonRej(String reasonRej) 見積および受注の拒否理由を設定します。
void | setReqDate(String reqDate) 指定納期を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesGrp(String salesGrp) 営業グループを設定します。
void | setSalesOff(String salesOff) 営業所を設定します。
void | setSalesOrg(String salesOrg) 販売組織を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setSdDoc(String sdDoc) 販売管理伝票番号を設定します。
void | setShipPoint(String shipPoint) 出荷ポイント/入荷ポイントを設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSoldTo(String soldTo) 受注先を設定します。
void | setStoreLoc(String storeLoc) 保管場所を設定します。
void | setSUnitIso(String sUnitIso) ISO コードによる販売単位を設定します。
void | setValidFrom(String validFrom) 見積または基本契約の有効開始日を設定します。
void | setValidTo(String validTo) 見積または基本契約有効終了日を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrders

public SalesOrders()
得意先受注テーブル情報を作成します。

SalesOrders

public SalesOrders(int index)
得意先受注テーブル情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getSdDoc

public String getSdDoc()
販売管理伝票番号を取得します。

戻り値:
sdDoc 販売管理伝票番号

getItmNumber

public String getItmNumber()
明細番号 (販売管理伝票)を取得します。

戻り値:
itmNumber 明細番号 (販売管理伝票)

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getDocType

public String getDocType()
販売伝票タイプを取得します。

戻り値:
docType 販売伝票タイプ

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getReqDate

public String getReqDate()
指定納期を取得します。

戻り値:
reqDate 指定納期

getPurchNo

public String getPurchNo()
得意先発注番号を取得します。

戻り値:
purchNo 得意先発注番号

getBatch

public String getBatch()
ロット番号を取得します。

戻り値:
batch ロット番号

getValidFrom

public String getValidFrom()
見積または基本契約の有効開始日を取得します。

戻り値:
validFrom 見積または基本契約の有効開始日

getValidTo

public String getValidTo()
見積または基本契約有効終了日を取得します。

戻り値:
validTo 見積または基本契約有効終了日

getBillBlock

public String getBillBlock()
販売管理伝票の請求ブロックを取得します。

戻り値:
billBlock 販売管理伝票の請求ブロック

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getSoldTo

public String getSoldTo()
受注先を取得します。

戻り値:
soldTo 受注先

getName

public String getName()
名称 1を取得します。

戻り値:
name 名称 1

getExchgRate

public String getExchgRate()
価格設定/統計の換算レート (直接引用)を取得します。

戻り値:
exchgRate 価格設定/統計の換算レート (直接引用)

getDlvQty

public String getDlvQty()
出荷数量実績 (販売単位)を取得します。

戻り値:
dlvQty 出荷数量実績 (販売単位)

getBaseUom

public String getBaseUom()
基本数量単位を取得します。

戻り値:
baseUom 基本数量単位

getNetPrice

public String getNetPrice()
正味価格を取得します。

戻り値:
netPrice 正味価格

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getNetValHd

public String getNetValHd()
受注正味額 (伝票通貨)を取得します。

戻り値:
netValHd 受注正味額 (伝票通貨)

getNetValue

public String getNetValue()
伝票通貨による正味額を取得します。

戻り値:
netValue 伝票通貨による正味額

getDivision

public String getDivision()
製品部門を取得します。

戻り値:
division 製品部門

getDocStatus

public String getDocStatus()
伝票ステータスを取得します。

戻り値:
docStatus 伝票ステータス

getSalesGrp

public String getSalesGrp()
営業グループを取得します。

戻り値:
salesGrp 営業グループ

getSalesOff

public String getSalesOff()
営業所を取得します。

戻り値:
salesOff 営業所

getSalesOrg

public String getSalesOrg()
販売組織を取得します。

戻り値:
salesOrg 販売組織

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getShipPoint

public String getShipPoint()
出荷ポイント/入荷ポイントを取得します。

戻り値:
shipPoint 出荷ポイント/入荷ポイント

getDistrChan

public String getDistrChan()
流通チャネルを取得します。

戻り値:
distrChan 流通チャネル

getGiDate

public String getGiDate()
出庫日付を取得します。

戻り値:
giDate 出庫日付

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getPlant

public String getPlant()
プラントを取得します。

戻り値:
plant プラント

getStoreLoc

public String getStoreLoc()
保管場所を取得します。

戻り値:
storeLoc 保管場所

getOrdReason

public String getOrdReason()
受注理由 (取引理由)を取得します。

戻り値:
ordReason 受注理由 (取引理由)

getReasonRej

public String getReasonRej()
見積および受注の拒否理由を取得します。

戻り値:
reasonRej 見積および受注の拒否理由

getBUomIso

public String getBUomIso()
ISO コードでの基本数量単位を取得します。

戻り値:
bUomIso ISO コードでの基本数量単位

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getSUnitIso

public String getSUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
sUnitIso ISO コードによる販売単位

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getPurchNoC

public String getPurchNoC()
出荷先発注番号を取得します。

戻り値:
purchNoC 出荷先発注番号

getExchgRateV

public String getExchgRateV()
価格設定/統計の換算レート (間接引用)を取得します。

戻り値:
exchgRateV 価格設定/統計の換算レート (間接引用)

getMatExt

public String getMatExt()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
matExt 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMatGuid

public String getMatGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
matGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMatVers

public String getMatVers()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
matVers 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getCreationDate

public String getCreationDate()
レコード登録日を取得します。

戻り値:
creationDate レコード登録日

getCreationTime

public String getCreationTime()
登録時刻を取得します。

戻り値:
creationTime 登録時刻

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setSdDoc

public void setSdDoc(String sdDoc)
販売管理伝票番号を設定します。

パラメータ:
sdDoc - 販売管理伝票番号

setItmNumber

public void setItmNumber(String itmNumber)
明細番号 (販売管理伝票)を設定します。

パラメータ:
itmNumber - 明細番号 (販売管理伝票)

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setDocType

public void setDocType(String docType)
販売伝票タイプを設定します。

パラメータ:
docType - 販売伝票タイプ

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setReqDate

public void setReqDate(String reqDate)
指定納期を設定します。

パラメータ:
reqDate - 指定納期

setPurchNo

public void setPurchNo(String purchNo)
得意先発注番号を設定します。

パラメータ:
purchNo - 得意先発注番号

setBatch

public void setBatch(String batch)
ロット番号を設定します。

パラメータ:
batch - ロット番号

setValidFrom

public void setValidFrom(String validFrom)
見積または基本契約の有効開始日を設定します。

パラメータ:
validFrom - 見積または基本契約の有効開始日

setValidTo

public void setValidTo(String validTo)
見積または基本契約有効終了日を設定します。

パラメータ:
validTo - 見積または基本契約有効終了日

setBillBlock

public void setBillBlock(String billBlock)
販売管理伝票の請求ブロックを設定します。

パラメータ:
billBlock - 販売管理伝票の請求ブロック

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setSoldTo

public void setSoldTo(String soldTo)
受注先を設定します。

パラメータ:
soldTo - 受注先

setName

public void setName(String name)
名称 1を設定します。

パラメータ:
name - 名称 1

setExchgRate

public void setExchgRate(String exchgRate)
価格設定/統計の換算レート (直接引用)を設定します。

パラメータ:
exchgRate - 価格設定/統計の換算レート (直接引用)

setDlvQty

public void setDlvQty(String dlvQty)
出荷数量実績 (販売単位)を設定します。

パラメータ:
dlvQty - 出荷数量実績 (販売単位)

setBaseUom

public void setBaseUom(String baseUom)
基本数量単位を設定します。

パラメータ:
baseUom - 基本数量単位

setNetPrice

public void setNetPrice(String netPrice)
正味価格を設定します。

パラメータ:
netPrice - 正味価格

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setNetValHd

public void setNetValHd(String netValHd)
受注正味額 (伝票通貨)を設定します。

パラメータ:
netValHd - 受注正味額 (伝票通貨)

setNetValue

public void setNetValue(String netValue)
伝票通貨による正味額を設定します。

パラメータ:
netValue - 伝票通貨による正味額

setDivision

public void setDivision(String division)
製品部門を設定します。

パラメータ:
division - 製品部門

setDocStatus

public void setDocStatus(String docStatus)
伝票ステータスを設定します。

パラメータ:
docStatus - 伝票ステータス

setSalesGrp

public void setSalesGrp(String salesGrp)
営業グループを設定します。

パラメータ:
salesGrp - 営業グループ

setSalesOff

public void setSalesOff(String salesOff)
営業所を設定します。

パラメータ:
salesOff - 営業所

setSalesOrg

public void setSalesOrg(String salesOrg)
販売組織を設定します。

パラメータ:
salesOrg - 販売組織

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setShipPoint

public void setShipPoint(String shipPoint)
出荷ポイント/入荷ポイントを設定します。

パラメータ:
shipPoint - 出荷ポイント/入荷ポイント

setDistrChan

public void setDistrChan(String distrChan)
流通チャネルを設定します。

パラメータ:
distrChan - 流通チャネル

setGiDate

public void setGiDate(String giDate)
出庫日付を設定します。

パラメータ:
giDate - 出庫日付

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setPlant

public void setPlant(String plant)
プラントを設定します。

パラメータ:
plant - プラント

setStoreLoc

public void setStoreLoc(String storeLoc)
保管場所を設定します。

パラメータ:
storeLoc - 保管場所

setOrdReason

public void setOrdReason(String ordReason)
受注理由 (取引理由)を設定します。

パラメータ:
ordReason - 受注理由 (取引理由)

setReasonRej

public void setReasonRej(String reasonRej)
見積および受注の拒否理由を設定します。

パラメータ:
reasonRej - 見積および受注の拒否理由

setBUomIso

public void setBUomIso(String bUomIso)
ISO コードでの基本数量単位を設定します。

パラメータ:
bUomIso - ISO コードでの基本数量単位

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setSUnitIso

public void setSUnitIso(String sUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
sUnitIso - ISO コードによる販売単位

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setPurchNoC

public void setPurchNoC(String purchNoC)
出荷先発注番号を設定します。

パラメータ:
purchNoC - 出荷先発注番号

setExchgRateV

public void setExchgRateV(String exchgRateV)
価格設定/統計の換算レート (間接引用)を設定します。

パラメータ:
exchgRateV - 価格設定/統計の換算レート (間接引用)

setMatExt

public void setMatExt(String matExt)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
matExt - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMatGuid

public void setMatGuid(String matGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
matGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMatVers

public void setMatVers(String matVers)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
matVers - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setCreationDate

public void setCreationDate(String creationDate)
レコード登録日を設定します。

パラメータ:
creationDate - レコード登録日

setCreationTime

public void setCreationTime(String creationTime)
登録時刻を設定します。

パラメータ:
creationTime - 登録時刻

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus の使用

SalesOrderGetStatus を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetStatus の使用

jp.co.intra_mart.foundation.sap.module.sales での SalesOrderGetStatus のサブクラス
 class SalesOrderGetStatusController
販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り
販売伝票ステータス一覧の情報を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス
ParamStatusInfo
SalesOrderGetStatus
StatusInfo


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラスの概要
ParamStatusInfo | ステータス情報パラメータ設定クラス 機能は以下の通り ステータス情報のパラメータを設定します。
SalesOrderGetStatus | 販売伝票ステータス一覧照会情報クラス 機能は以下の通り 販売伝票ステータス一覧照会情報を保持します。
StatusInfo | ステータス情報情報クラス 機能は以下の通り ステータス情報情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus の使用

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus のクラス
SalesOrderGetStatus
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamStatusInfo (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス ParamStatusInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo
すべての実装インタフェース:
Serializable
public final class ParamStatusInfo
extends Object
implements Serializable

ステータス情報パラメータ設定クラス
機能は以下の通り

  • ステータス情報のパラメータを設定します。

関連項目:
直列化された形式

メソッドの概要
static void | setExportParam(BapiController bapiController, List statusInfoList) table(Export)情報からステータス情報の値をセットします。
static void | setImportParam(BapiController bapiController, List statusInfoList) ステータス情報の値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

setImportParam

public static void setImportParam(BapiController bapiController,
                                  List statusInfoList)
                           throws SAPGeneralSystemException,
                                  SAPGeneralAppException
ステータス情報の値をセットします。

パラメータ:
bapiController - BapiController
statusInfoList - List
例外:
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外

setExportParam

public static void setExportParam(BapiController bapiController,
                                  List statusInfoList)
                           throws SAPGeneralSystemException
table(Export)情報からステータス情報の値をセットします。 返却された販売伝票情報をセットします。

パラメータ:
bapiController - BapiController
statusInfoList - List
例外:
SAPGeneralSystemException - 汎用システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetStatus (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス SalesOrderGetStatus

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SalesOrderGetStatusController
public class SalesOrderGetStatus
extends ReferenceController
implements Serializable

販売伝票ステータス一覧照会情報クラス
機能は以下の通り

  • 販売伝票ステータス一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String salesdocument, SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。
メソッドの概要
String | getSalesdocument() 販売管理伝票番号を取得します。
ArrayList | getStatusInfoList() ステータス情報を取得します。
void | setExportParam(BapiController bapiController) 返却された販売伝票ステータス一覧照会情報をセットします。
void | setImportParam(BapiController bapiController) 販売伝票ステータス一覧の検索条件をセットします。
void | setSalesdocument(String salesdocument) 販売管理伝票番号を設定します。
void | setStatusInfoList(ArrayList statusInfoList) ステータス情報を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetStatus

public SalesOrderGetStatus(SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント

SalesOrderGetStatus

public SalesOrderGetStatus(String salesdocument,
                           SapClient sapClient)
販売伝票ステータス一覧照会情報を作成します。

パラメータ:
sapClient - SAPクライアント
salesdocument - 販売管理伝票番号
メソッドの詳細

setImportParam

public void setImportParam(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
販売伝票ステータス一覧の検索条件をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外
SAPGeneralAppException - 汎用アプリケーション例外

setExportParam

public void setExportParam(BapiController bapiController)
                    throws SAPGeneralSystemException
返却された販売伝票ステータス一覧照会情報をセットします。

パラメータ:
bapiController - BapiController
例外:
SAPGeneralSystemException - 汎用システム例外

getSalesdocument

public String getSalesdocument()
販売管理伝票番号を取得します。

戻り値:
salesdocument 販売管理伝票番号

getStatusInfoList

public ArrayList getStatusInfoList()
ステータス情報を取得します。

戻り値:
statusInfoList ステータス情報

setSalesdocument

public void setSalesdocument(String salesdocument)
販売管理伝票番号を設定します。

パラメータ:
salesdocument - 販売管理伝票番号

setStatusInfoList

public void setStatusInfoList(ArrayList statusInfoList)
ステータス情報を設定します。

パラメータ:
statusInfoList - ステータス情報

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


StatusInfo (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus
クラス StatusInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo
すべての実装インタフェース:
Serializable
public class StatusInfo
extends Object
implements Serializable

ステータス情報情報クラス
機能は以下の通り

  • ステータス情報情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
StatusInfo()
ステータス情報情報を作成します。
StatusInfo(int index)
ステータス情報情報を作成します。
メソッドの概要
String | getCdUntIso() 条件数量単位 (ISO コード)を取得します。
String | getCondPUnt() 価格条件単位を取得します。
String | getCondUnit() 条件単位を取得します。
String | getCreationDate() レコード登録日を取得します。
String | getCreationTime() 登録時刻を取得します。
String | getCumCfQty() 累積確認数量 (販売数量単位)を取得します。
String | getCurrency() 販売伝票通貨を取得します。
String | getCurrIso() ISO コード通貨を取得します。
String | getDelivDate() 納入期日を取得します。
String | getDelivItem() 出荷明細を取得します。
String | getDelivNumb() 出荷伝票を取得します。
String | getDlvBlock() 出荷ブロック (伝票ヘッダ)を取得します。
String | getDlvQty() 出荷数量実績 (販売単位)を取得します。
String | getDlvStatH() 全明細の出荷ステータスを取得します。
String | getDlvStatI() 明細の全体出荷ステータスを取得します。
String | getDlvUnitIso() ISO コードでの出荷単位の数量単位を取得します。
String | getDocDate() 伝票日付 (受信日/送信日)を取得します。
String | getDocNumber() 販売伝票を取得します。
int | getIndex() レコード番号を取得します｡
String | getItmNumber() 販売伝票明細を取得します。
String | getMaterial() 品目コードを取得します。
String | getMaterialExternal() 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
String | getMaterialGuid() 項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
String | getMaterialVersion() 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
String | getNetPrice() 正味価格を取得します。
String | getNetValue() 伝票通貨での受注明細正味額を取得します。
String | getPoItmNo() 元となる購買発注の明細番号を取得します。
String | getPrcStatH() 伝票の全処理ステータスを取得します。
String | getPurchNo() 得意先発注番号を取得します。
String | getRefQty() 基本数量単位による参照数量を取得します。
String | getReqDate() 納入日程日付を取得します。
String | getReqDateH() 指定納入期日を取得します。
String | getReqQty() 累積受注数量 (販売単位)を取得します。
String | getSalesUnit() 販売単位を取得します。
String | getShortText() テキスト (短): 受注明細を取得します。
String | getSUnitDlv() 出荷単位を取得します。
String | getSUnitIso() ISO コードによる販売単位を取得します。
void | setCdUntIso(String cdUntIso) 条件数量単位 (ISO コード)を設定します。
void | setCondPUnt(String condPUnt) 価格条件単位を設定します。
void | setCondUnit(String condUnit) 条件単位を設定します。
void | setCreationDate(String creationDate) レコード登録日を設定します。
void | setCreationTime(String creationTime) 登録時刻を設定します。
void | setCumCfQty(String cumCfQty) 累積確認数量 (販売数量単位)を設定します。
void | setCurrency(String currency) 販売伝票通貨を設定します。
void | setCurrIso(String currIso) ISO コード通貨を設定します。
void | setDelivDate(String delivDate) 納入期日を設定します。
void | setDelivItem(String delivItem) 出荷明細を設定します。
void | setDelivNumb(String delivNumb) 出荷伝票を設定します。
void | setDlvBlock(String dlvBlock) 出荷ブロック (伝票ヘッダ)を設定します。
void | setDlvQty(String dlvQty) 出荷数量実績 (販売単位)を設定します。
void | setDlvStatH(String dlvStatH) 全明細の出荷ステータスを設定します。
void | setDlvStatI(String dlvStatI) 明細の全体出荷ステータスを設定します。
void | setDlvUnitIso(String dlvUnitIso) ISO コードでの出荷単位の数量単位を設定します。
void | setDocDate(String docDate) 伝票日付 (受信日/送信日)を設定します。
void | setDocNumber(String docNumber) 販売伝票を設定します。
void | setIndex(int index) レコード番号を設定します｡
void | setItmNumber(String itmNumber) 販売伝票明細を設定します。
void | setMaterial(String material) 品目コードを設定します。
void | setMaterialExternal(String materialExternal) 項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
void | setMaterialGuid(String materialGuid) 項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
void | setMaterialVersion(String materialVersion) 項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
void | setNetPrice(String netPrice) 正味価格を設定します。
void | setNetValue(String netValue) 伝票通貨での受注明細正味額を設定します。
void | setPoItmNo(String poItmNo) 元となる購買発注の明細番号を設定します。
void | setPrcStatH(String prcStatH) 伝票の全処理ステータスを設定します。
void | setPurchNo(String purchNo) 得意先発注番号を設定します。
void | setRefQty(String refQty) 基本数量単位による参照数量を設定します。
void | setReqDate(String reqDate) 納入日程日付を設定します。
void | setReqDateH(String reqDateH) 指定納入期日を設定します。
void | setReqQty(String reqQty) 累積受注数量 (販売単位)を設定します。
void | setSalesUnit(String salesUnit) 販売単位を設定します。
void | setShortText(String shortText) テキスト (短): 受注明細を設定します。
void | setSUnitDlv(String sUnitDlv) 出荷単位を設定します。
void | setSUnitIso(String sUnitIso) ISO コードによる販売単位を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

StatusInfo

public StatusInfo()
ステータス情報情報を作成します。

StatusInfo

public StatusInfo(int index)
ステータス情報情報を作成します。

パラメータ:
index - レコード番号
メソッドの詳細

getDocNumber

public String getDocNumber()
販売伝票を取得します。

戻り値:
docNumber 販売伝票

getDocDate

public String getDocDate()
伝票日付 (受信日/送信日)を取得します。

戻り値:
docDate 伝票日付 (受信日/送信日)

getPurchNo

public String getPurchNo()
得意先発注番号を取得します。

戻り値:
purchNo 得意先発注番号

getPrcStatH

public String getPrcStatH()
伝票の全処理ステータスを取得します。

戻り値:
prcStatH 伝票の全処理ステータス

getDlvStatH

public String getDlvStatH()
全明細の出荷ステータスを取得します。

戻り値:
dlvStatH 全明細の出荷ステータス

getReqDateH

public String getReqDateH()
指定納入期日を取得します。

戻り値:
reqDateH 指定納入期日

getDlvBlock

public String getDlvBlock()
出荷ブロック (伝票ヘッダ)を取得します。

戻り値:
dlvBlock 出荷ブロック (伝票ヘッダ)

getItmNumber

public String getItmNumber()
販売伝票明細を取得します。

戻り値:
itmNumber 販売伝票明細

getMaterial

public String getMaterial()
品目コードを取得します。

戻り値:
material 品目コード

getShortText

public String getShortText()
テキスト (短): 受注明細を取得します。

戻り値:
shortText テキスト (短): 受注明細

getReqDate

public String getReqDate()
納入日程日付を取得します。

戻り値:
reqDate 納入日程日付

getReqQty

public String getReqQty()
累積受注数量 (販売単位)を取得します。

戻り値:
reqQty 累積受注数量 (販売単位)

getCumCfQty

public String getCumCfQty()
累積確認数量 (販売数量単位)を取得します。

戻り値:
cumCfQty 累積確認数量 (販売数量単位)

getSalesUnit

public String getSalesUnit()
販売単位を取得します。

戻り値:
salesUnit 販売単位

getNetValue

public String getNetValue()
伝票通貨での受注明細正味額を取得します。

戻り値:
netValue 伝票通貨での受注明細正味額

getCurrency

public String getCurrency()
販売伝票通貨を取得します。

戻り値:
currency 販売伝票通貨

getNetPrice

public String getNetPrice()
正味価格を取得します。

戻り値:
netPrice 正味価格

getCondPUnt

public String getCondPUnt()
価格条件単位を取得します。

戻り値:
condPUnt 価格条件単位

getCondUnit

public String getCondUnit()
条件単位を取得します。

戻り値:
condUnit 条件単位

getDlvStatI

public String getDlvStatI()
明細の全体出荷ステータスを取得します。

戻り値:
dlvStatI 明細の全体出荷ステータス

getDelivNumb

public String getDelivNumb()
出荷伝票を取得します。

戻り値:
delivNumb 出荷伝票

getDelivItem

public String getDelivItem()
出荷明細を取得します。

戻り値:
delivItem 出荷明細

getDelivDate

public String getDelivDate()
納入期日を取得します。

戻り値:
delivDate 納入期日

getDlvQty

public String getDlvQty()
出荷数量実績 (販売単位)を取得します。

戻り値:
dlvQty 出荷数量実績 (販売単位)

getRefQty

public String getRefQty()
基本数量単位による参照数量を取得します。

戻り値:
refQty 基本数量単位による参照数量

getSUnitIso

public String getSUnitIso()
ISO コードによる販売単位を取得します。

戻り値:
sUnitIso ISO コードによる販売単位

getCdUntIso

public String getCdUntIso()
条件数量単位 (ISO コード)を取得します。

戻り値:
cdUntIso 条件数量単位 (ISO コード)

getCurrIso

public String getCurrIso()
ISO コード通貨を取得します。

戻り値:
currIso ISO コード通貨

getMaterialExternal

public String getMaterialExternal()
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。

戻り値:
materialExternal 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

getMaterialGuid

public String getMaterialGuid()
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。

戻り値:
materialGuid 項目 MATERIAL の外部 GUID (今後のリリースで開発)

getMaterialVersion

public String getMaterialVersion()
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。

戻り値:
materialVersion 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

getPoItmNo

public String getPoItmNo()
元となる購買発注の明細番号を取得します。

戻り値:
poItmNo 元となる購買発注の明細番号

getCreationDate

public String getCreationDate()
レコード登録日を取得します。

戻り値:
creationDate レコード登録日

getCreationTime

public String getCreationTime()
登録時刻を取得します。

戻り値:
creationTime 登録時刻

getSUnitDlv

public String getSUnitDlv()
出荷単位を取得します。

戻り値:
sUnitDlv 出荷単位

getDlvUnitIso

public String getDlvUnitIso()
ISO コードでの出荷単位の数量単位を取得します。

戻り値:
dlvUnitIso ISO コードでの出荷単位の数量単位

getIndex

public int getIndex()
レコード番号を取得します｡

戻り値:
index レコード番号

setDocNumber

public void setDocNumber(String docNumber)
販売伝票を設定します。

パラメータ:
docNumber - 販売伝票

setDocDate

public void setDocDate(String docDate)
伝票日付 (受信日/送信日)を設定します。

パラメータ:
docDate - 伝票日付 (受信日/送信日)

setPurchNo

public void setPurchNo(String purchNo)
得意先発注番号を設定します。

パラメータ:
purchNo - 得意先発注番号

setPrcStatH

public void setPrcStatH(String prcStatH)
伝票の全処理ステータスを設定します。

パラメータ:
prcStatH - 伝票の全処理ステータス

setDlvStatH

public void setDlvStatH(String dlvStatH)
全明細の出荷ステータスを設定します。

パラメータ:
dlvStatH - 全明細の出荷ステータス

setReqDateH

public void setReqDateH(String reqDateH)
指定納入期日を設定します。

パラメータ:
reqDateH - 指定納入期日

setDlvBlock

public void setDlvBlock(String dlvBlock)
出荷ブロック (伝票ヘッダ)を設定します。

パラメータ:
dlvBlock - 出荷ブロック (伝票ヘッダ)

setItmNumber

public void setItmNumber(String itmNumber)
販売伝票明細を設定します。

パラメータ:
itmNumber - 販売伝票明細

setMaterial

public void setMaterial(String material)
品目コードを設定します。

パラメータ:
material - 品目コード

setShortText

public void setShortText(String shortText)
テキスト (短): 受注明細を設定します。

パラメータ:
shortText - テキスト (短): 受注明細

setReqDate

public void setReqDate(String reqDate)
納入日程日付を設定します。

パラメータ:
reqDate - 納入日程日付

setReqQty

public void setReqQty(String reqQty)
累積受注数量 (販売単位)を設定します。

パラメータ:
reqQty - 累積受注数量 (販売単位)

setCumCfQty

public void setCumCfQty(String cumCfQty)
累積確認数量 (販売数量単位)を設定します。

パラメータ:
cumCfQty - 累積確認数量 (販売数量単位)

setSalesUnit

public void setSalesUnit(String salesUnit)
販売単位を設定します。

パラメータ:
salesUnit - 販売単位

setNetValue

public void setNetValue(String netValue)
伝票通貨での受注明細正味額を設定します。

パラメータ:
netValue - 伝票通貨での受注明細正味額

setCurrency

public void setCurrency(String currency)
販売伝票通貨を設定します。

パラメータ:
currency - 販売伝票通貨

setNetPrice

public void setNetPrice(String netPrice)
正味価格を設定します。

パラメータ:
netPrice - 正味価格

setCondPUnt

public void setCondPUnt(String condPUnt)
価格条件単位を設定します。

パラメータ:
condPUnt - 価格条件単位

setCondUnit

public void setCondUnit(String condUnit)
条件単位を設定します。

パラメータ:
condUnit - 条件単位

setDlvStatI

public void setDlvStatI(String dlvStatI)
明細の全体出荷ステータスを設定します。

パラメータ:
dlvStatI - 明細の全体出荷ステータス

setDelivNumb

public void setDelivNumb(String delivNumb)
出荷伝票を設定します。

パラメータ:
delivNumb - 出荷伝票

setDelivItem

public void setDelivItem(String delivItem)
出荷明細を設定します。

パラメータ:
delivItem - 出荷明細

setDelivDate

public void setDelivDate(String delivDate)
納入期日を設定します。

パラメータ:
delivDate - 納入期日

setDlvQty

public void setDlvQty(String dlvQty)
出荷数量実績 (販売単位)を設定します。

パラメータ:
dlvQty - 出荷数量実績 (販売単位)

setRefQty

public void setRefQty(String refQty)
基本数量単位による参照数量を設定します。

パラメータ:
refQty - 基本数量単位による参照数量

setSUnitIso

public void setSUnitIso(String sUnitIso)
ISO コードによる販売単位を設定します。

パラメータ:
sUnitIso - ISO コードによる販売単位

setCdUntIso

public void setCdUntIso(String cdUntIso)
条件数量単位 (ISO コード)を設定します。

パラメータ:
cdUntIso - 条件数量単位 (ISO コード)

setCurrIso

public void setCurrIso(String currIso)
ISO コード通貨を設定します。

パラメータ:
currIso - ISO コード通貨

setMaterialExternal

public void setMaterialExternal(String materialExternal)
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。

パラメータ:
materialExternal - 項目 MATERIAL の品目コード (長) (今後のリリースで開発)

setMaterialGuid

public void setMaterialGuid(String materialGuid)
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。

パラメータ:
materialGuid - 項目 MATERIAL の外部 GUID (今後のリリースで開発)

setMaterialVersion

public void setMaterialVersion(String materialVersion)
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。

パラメータ:
materialVersion - 項目 MATERIAL のバージョン番号 (今後のリリースで開発)

setPoItmNo

public void setPoItmNo(String poItmNo)
元となる購買発注の明細番号を設定します。

パラメータ:
poItmNo - 元となる購買発注の明細番号

setCreationDate

public void setCreationDate(String creationDate)
レコード登録日を設定します。

パラメータ:
creationDate - レコード登録日

setCreationTime

public void setCreationTime(String creationTime)
登録時刻を設定します。

パラメータ:
creationTime - 登録時刻

setSUnitDlv

public void setSUnitDlv(String sUnitDlv)
出荷単位を設定します。

パラメータ:
sUnitDlv - 出荷単位

setDlvUnitIso

public void setDlvUnitIso(String dlvUnitIso)
ISO コードでの出荷単位の数量単位を設定します。

パラメータ:
dlvUnitIso - ISO コードでの出荷単位の数量単位

setIndex

public void setIndex(int index)
レコード番号を設定します｡

パラメータ:
index - レコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocCreateMultipleController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocCreateMultipleController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple
                拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController
すべての実装インタフェース:
Serializable
public class BillingDocCreateMultipleController
extends BillingDocCreateMultiple
implements Serializable

請求伝票登録コントローラクラス
機能は以下の通り

  • 請求伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocCreateMultipleController()
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple から継承したメソッド
getBillingDataInList, getCCardDataInList, getConditionDataInList, getCreatorDataIn, getErrorsList, getSuccessList, getTestrun, getTextDataInList, setBillingDataInList, setCCardDataInList, setConditionDataInList, setCreatorDataIn, setErrorsList, setExportParam, setImportParam, setSuccessList, setTestrun, setTextDataInList, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocCreateMultipleController

public BillingDocCreateMultipleController()
BillingDocCreateMultipleControllerのコンストラクタを生成します。

BillingDocCreateMultipleController

public BillingDocCreateMultipleController(ConnectionManager connectionManager)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

BillingDocCreateMultipleController

public BillingDocCreateMultipleController(SapClient sapClient)
BillingDocCreateMultipleControllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BillingDocGetDetailController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocGetDetailController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController
すべての実装インタフェース:
Serializable
public class BillingDocGetDetailController
extends Object
implements Serializable

請求伝票詳細照会情報コントローラクラス
機能は以下の通り

  • 請求伝票詳細照会情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BillingDocGetDetailController(String billingDocument)
コンストラクタ生成
BillingDocGetDetailController(String billingDocument, SapClient sapClient)
コンストラクタ生成
メソッドの概要
String | getBapiReturnErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage() 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
BillingDocumentDetail | getBillingDocumentDetail() 請求伝票に関する詳細情報を取得します。
void | setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail) 請求伝票に関する詳細情報を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BillingDocGetDetailController

public BillingDocGetDetailController(String billingDocument)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPSalesAppException,
                                     SAPSalesSystemException
コンストラクタ生成

パラメータ:
billingDocument - 処理予定の請求伝票数
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

BillingDocGetDetailController

public BillingDocGetDetailController(String billingDocument,
                                     SapClient sapClient)
                              throws SAPAuthAppException,
                                     SAPAuthSystemException,
                                     SAPGeneralAppException,
                                     SAPGeneralSystemException,
                                     SAPSalesAppException,
                                     SAPSalesSystemException
コンストラクタ生成

パラメータ:
billingDocument - 処理予定の請求伝票数
sapClient - SAPクライアント
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外
メソッドの詳細

getBillingDocumentDetail

public BillingDocumentDetail getBillingDocumentDetail()
請求伝票に関する詳細情報を取得します。

戻り値:
billingDocumentDetail 請求伝票に関する詳細情報

setBillingDocumentDetail

public void setBillingDocumentDetail(BillingDocumentDetail billingDocumentDetail)
請求伝票に関する詳細情報を設定します。

パラメータ:
billingDocumentDetail - 請求伝票に関する詳細情報

getBapiReturnMessage

public String getBapiReturnMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getMessage()をご参照ください。

戻り値:
BAPI実行結果のすべてのメッセージ情報

getBapiReturnErrMessage

public String getBapiReturnErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getErrMessage()をご参照ください。

戻り値:
BAPI実行結果エラーとなった全てのメッセージ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BillingDocGetListController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス BillingDocGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList
                拡張 jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController
すべての実装インタフェース:
Serializable
public class BillingDocGetListController
extends BillingDocGetList
implements Serializable

請求伝票一覧照会情報コントローラクラス
機能は以下の通り

  • 請求伝票一覧照会情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
BillingDocGetListController()
コンストラクタ生成
BillingDocGetListController(SapClient sapClient)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh)
コンストラクタ生成
BillingDocGetListController(String sign, String option, String refDocRow, String refDocHigh, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
 void setStrParam(String paramStr, String paramName, String value)
構造型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList から継承したメソッド
getBillingDocumentDetailListList, getRefDocRange, getSuccessList, setBillingDocumentDetailListList, setExportParam, setImportParam, setRefDocRange, setSuccessList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BillingDocGetListController

public BillingDocGetListController()
コンストラクタ生成

BillingDocGetListController

public BillingDocGetListController(String sign,
                                   String option,
                                   String refDocRow,
                                   String refDocHigh)
コンストラクタ生成

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号

BillingDocGetListController

public BillingDocGetListController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

BillingDocGetListController

public BillingDocGetListController(String sign,
                                   String option,
                                   String refDocRow,
                                   String refDocHigh,
                                   SapClient sapClient)
コンストラクタ生成

パラメータ:
sign - 選択演算子 SIGN (テーブル範囲)
option - 選択演算子 OPTION (範囲テーブル)
refDocRow - 前伝票の開始伝票番号
refDocHigh - 前伝票の終了伝票番号
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造型の項目に値をセットします。

パラメータ:
paramStr - 構造名
paramName - 項目名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


InquiryCreateFromData2Controller (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス InquiryCreateFromData2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller
すべての実装インタフェース:
Serializable
public class InquiryCreateFromData2Controller
extends InquiryCreateFromData2
implements Serializable

引合伝票登録コントローラクラス
機能は以下の通り

  • 引合伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
InquiryCreateFromData2Controller()
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getInquiryCfgsBlobList, getInquiryCfgsInstList, getInquiryCfgsPartOfList, getInquiryCfgsRefInstList, getInquiryCfgsRefList, getInquiryCfgsValueList, getInquiryCfgsVkList, getInquiryConditionsInList, getInquiryConditionsInXList, getInquiryHeaderIn, getInquiryHeaderInX, getInquiryItemsInList, getInquiryItemsInXList, getInquiryKeysList, getInquiryPartnersList, getInquirySchedulesInList, getInquirySchedulesInXList, getInquiryTextList, getIntNumberAssignment, getLogicSwitch, getPartnerAddressesList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setInquiryCfgsBlobList, setInquiryCfgsInstList, setInquiryCfgsPartOfList, setInquiryCfgsRefInstList, setInquiryCfgsRefList, setInquiryCfgsValueList, setInquiryCfgsVkList, setInquiryConditionsInList, setInquiryConditionsInXList, setInquiryHeaderIn, setInquiryHeaderInX, setInquiryItemsInList, setInquiryItemsInXList, setInquiryKeysList, setInquiryPartnersList, setInquirySchedulesInList, setInquirySchedulesInXList, setInquiryTextList, setIntNumberAssignment, setLogicSwitch, setPartnerAddressesList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller()
InquiryCreateFromData2Controllerのコンストラクタを生成します。

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller(ConnectionManager connectionManager)
InquiryCreateFromData2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

InquiryCreateFromData2Controller

public InquiryCreateFromData2Controller(SapClient sapClient)
InquiryCreateFromData2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module.sales (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module.sales
クラス
BillingDocCreateMultipleController
BillingDocGetDetailController
BillingDocGetListController
InquiryCreateFromData2Controller
QuotationCreateFromData2Controller
SalesOrderCreateFromDat2Controller
SalesOrderGetListController
SalesOrderGetStatusController


jp.co.intra_mart.foundation.sap.module.sales (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales

クラスの概要
BillingDocCreateMultipleController | 請求伝票登録コントローラクラス 機能は以下の通り 請求伝票を登録します。
BillingDocGetDetailController | 請求伝票詳細照会情報コントローラクラス 機能は以下の通り 請求伝票詳細照会情報を保持します。
BillingDocGetListController | 請求伝票一覧照会情報コントローラクラス 機能は以下の通り 請求伝票一覧照会情報を保持します。
InquiryCreateFromData2Controller | 引合伝票登録コントローラクラス 機能は以下の通り 引合伝票を登録します。
QuotationCreateFromData2Controller | 見積伝票登録情報コントローラクラス 機能は以下の通り 見積伝票登録情報を保持します。
SalesOrderCreateFromDat2Controller | 受注伝票登録コントローラクラス 機能は以下の通り 受注伝票を登録します。
SalesOrderGetListController | 販売伝票一覧照会コントローラクラス 機能は以下の通り 販売伝票一覧の情報を取得します。
SalesOrderGetStatusController | 販売伝票ステータス一覧照会コントローラクラス 機能は以下の通り 販売伝票ステータス一覧の情報を取得します。


jp.co.intra_mart.foundation.sap.module.sales クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module.sales の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.module.sales の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module.sales の使用

jp.co.intra_mart.foundation.sap.module.sales はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


QuotationCreateFromData2Controller (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス QuotationCreateFromData2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller
すべての実装インタフェース:
Serializable
public class QuotationCreateFromData2Controller
extends QuotationCreateFromData2
implements Serializable

見積伝票登録情報コントローラクラス
機能は以下の通り

  • 見積伝票登録情報を保持します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
QuotationCreateFromData2Controller()
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getIntNumberAssignment, getLogicSwitch, getPartnerAddressesList, getQuotationCfgsBlobList, getQuotationCfgsInstList, getQuotationCfgsPartOfList, getQuotationCfgsRefInstList, getQuotationCfgsRefList, getQuotationCfgsValueList, getQuotationCfgsVkList, getQuotationConditionsInList, getQuotationConditionsInXList, getQuotationHeaderIn, getQuotationHeaderInX, getQuotationItemsInList, getQuotationItemsInXList, getQuotationKeysList, getQuotationPartnersList, getQuotationSchedulesInList, getQuotationSchedulesInXList, getQuotationTextList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setIntNumberAssignment, setLogicSwitch, setPartnerAddressesList, setQuotationCfgsBlobList, setQuotationCfgsInstList, setQuotationCfgsPartOfList, setQuotationCfgsRefInstList, setQuotationCfgsRefList, setQuotationCfgsValueList, setQuotationCfgsVkList, setQuotationConditionsInList, setQuotationConditionsInXList, setQuotationHeaderIn, setQuotationHeaderInX, setQuotationItemsInList, setQuotationItemsInXList, setQuotationKeysList, setQuotationPartnersList, setQuotationSchedulesInList, setQuotationSchedulesInXList, setQuotationTextList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller()
QuotationCreateFromData2Controllerのコンストラクタを生成します。

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller(ConnectionManager connectionManager)
QuotationCreateFromData2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

QuotationCreateFromData2Controller

public QuotationCreateFromData2Controller(SapClient sapClient)
QuotationCreateFromData2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderCreateFromDat2Controller (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderCreateFromDat2Controller

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller
すべての実装インタフェース:
Serializable
public class SalesOrderCreateFromDat2Controller
extends SalesOrderCreateFromDat2
implements Serializable

受注伝票登録コントローラクラス
機能は以下の通り

  • 受注伝票を登録します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したフィールド
connectionManager
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderCreateFromDat2Controller()
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
メソッドの概要
 void executeBapi()
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
 void setStrParam(String paramStr, String paramName, String value)
構造体型の項目に値をセットします。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 から継承したメソッド
getBehaveWhenError, getBinaryRelationshiptype, getConvert, getExtensionInList, getIntNumberAssignment, getLogicSwitch, getOrderCcardList, getOrderCfgsBlobList, getOrderCfgsInstList, getOrderCfgsPartOfList, getOrderCfgsRefInstList, getOrderCfgsRefList, getOrderCfgsValueList, getOrderCfgsVkList, getOrderConditionsInList, getOrderConditionsInXList, getOrderHeaderIn, getOrderHeaderInX, getOrderItemsInList, getOrderItemsInXList, getOrderKeysList, getOrderPartnersList, getOrderSchedulesInList, getOrderSchedulesInXList, getOrderTextList, getPartnerAddressesList, getSalesdocument, getSalesdocumentin, getSender, getTestrun, setBehaveWhenError, setBinaryRelationshiptype, setConvert, setExportParam, setExtensionInList, setImportParam, setIntNumberAssignment, setLogicSwitch, setOrderCcardList, setOrderCfgsBlobList, setOrderCfgsInstList, setOrderCfgsPartOfList, setOrderCfgsRefInstList, setOrderCfgsRefList, setOrderCfgsValueList, setOrderCfgsVkList, setOrderConditionsInList, setOrderConditionsInXList, setOrderHeaderIn, setOrderHeaderInX, setOrderItemsInList, setOrderItemsInXList, setOrderKeysList, setOrderPartnersList, setOrderSchedulesInList, setOrderSchedulesInXList, setOrderTextList, setPartnerAddressesList, setSalesdocument, setSalesdocumentin, setSender, setTestrun, toString
クラス jp.co.intra_mart.foundation.sap.module.UpdateController から継承したメソッド
createBapiController
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller()
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller(ConnectionManager connectionManager)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

パラメータ:
connectionManager - コネクションマネージャー

SalesOrderCreateFromDat2Controller

public SalesOrderCreateFromDat2Controller(SapClient sapClient)
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setStrParam

public void setStrParam(String paramStr,
                        String paramName,
                        String value)
                 throws SAPSalesSystemException
構造体型の項目に値をセットします。

パラメータ:
paramStr - 構造体名
paramName - パラメータ名
value - セットする値
例外:
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - パラメータ名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理業務システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetListController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderGetListController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController
すべての実装インタフェース:
Serializable
public class SalesOrderGetListController
extends SalesOrderGetList
implements Serializable

販売伝票一覧照会コントローラクラス
機能は以下の通り

  • 販売伝票一覧の情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetListController()
コンストラクタ生成
SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup)
コンストラクタ生成
SalesOrderGetListController(String customerNumber, String salesOrganisation, String material, String purchaseOrder, String transactionGroup, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList から継承したメソッド
getCustomerNumber, getDocumentDate, getDocumentDateTo, getMaterial, getPurchaseOrder, getPurchaseOrderNumber, getSalesOrdersList, getSalesOrganization, getTransactionGroup, setCustomerNumber, setDocumentDate, setDocumentDateTo, setExportParam, setImportParam, setMaterial, setPurchaseOrder, setPurchaseOrderNumber, setSalesOrdersList, setSalesOrganization, setTransactionGroup, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetListController

public SalesOrderGetListController()
コンストラクタ生成

SalesOrderGetListController

public SalesOrderGetListController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

SalesOrderGetListController

public SalesOrderGetListController(String customerNumber,
                                   String salesOrganisation,
                                   String material,
                                   String purchaseOrder,
                                   String transactionGroup)
コンストラクタ生成

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ

SalesOrderGetListController

public SalesOrderGetListController(String customerNumber,
                                   String salesOrganisation,
                                   String material,
                                   String purchaseOrder,
                                   String transactionGroup,
                                   SapClient sapClient)
コンストラクタ生成

パラメータ:
customerNumber - 得意先コード
salesOrganisation - 販売組織
material - 品目コード
purchaseOrder - 得意先発注番号
transactionGroup - 一文字フラグ
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理アプリケーション例外
SAPSalesSystemException - 販売管理システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SalesOrderGetStatusController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module.sales
クラス SalesOrderGetStatusController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
            拡張 jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus
                拡張 jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController
すべての実装インタフェース:
Serializable
public class SalesOrderGetStatusController
extends SalesOrderGetStatus
implements Serializable

販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り

  • 販売伝票ステータス一覧の情報を取得します。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
SalesOrderGetStatusController()
コンストラクタ生成
SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument)
コンストラクタ生成
SalesOrderGetStatusController(String salesdocument, SapClient sapClient)
コンストラクタ生成
メソッドの概要
 void executeBapi()
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
 void setTblParam(String paramTable, String paramName, String value, int index)
テーブル型の項目に値をセットします。
クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus から継承したメソッド
getSalesdocument, getStatusInfoList, setExportParam, setImportParam, setSalesdocument, setStatusInfoList, toString
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SalesOrderGetStatusController

public SalesOrderGetStatusController()
コンストラクタ生成

SalesOrderGetStatusController

public SalesOrderGetStatusController(String salesdocument)
コンストラクタ生成

パラメータ:
salesdocument - 販売管理伝票番号

SalesOrderGetStatusController

public SalesOrderGetStatusController(SapClient sapClient)
コンストラクタ生成

パラメータ:
sapClient - SAPクライアント

SalesOrderGetStatusController

public SalesOrderGetStatusController(String salesdocument,
                                     SapClient sapClient)
コンストラクタ生成

パラメータ:
salesdocument - 販売管理伝票番号
sapClient - SAPクライアント
メソッドの詳細

executeBapi

public void executeBapi()
                 throws SAPAuthAppException,
                        SAPAuthSystemException,
                        SAPGeneralAppException,
                        SAPGeneralSystemException,
                        SAPSalesAppException,
                        SAPSalesSystemException
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。

例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
SAPGeneralAppException - 汎用アプリケーション例外
SAPGeneralSystemException - 汎用システム例外
SAPSalesAppException - 販売管理業務アプリケーション例外
SAPSalesSystemException - 販売管理業務システム例外

setTblParam

public void setTblParam(String paramTable,
                        String paramName,
                        String value,
                        int index)
                 throws SAPSalesSystemException
テーブル型の項目に値をセットします。

パラメータ:
paramTable - テーブル名
paramName - 項目名
value - セットする値
index - レコード番号
例外:
SAPSalesSystemException - 販売管理システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AbstractController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス AbstractController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ReferenceController, UpdateController
public class AbstractController
extends Object
implements Serializable

モジュール共通抽象コントローラクラス。

機能は以下の通り

  • BapiControllerの取得用メソッド
  • BAPI実行メッセージのセットするBapiController.executeBapi()実行メソッド
  • セットされたBAPI実行メッセージの取得

関連項目:
直列化された形式

フィールドの概要
protected String | bapiReturnErrMessage BAPI実行エラーメッセージ
protected String | bapiReturnMessage BAPI実行結果メッセージ
protected SapClient | sapClient SAPクライアント
コンストラクタの概要
protected | AbstractController() コンストラクタ。
protected | AbstractController(SapClient sapClient) コンストラクタ。
メソッドの概要
protected BapiController | createBapiController(String propertyFileName) 引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
protected void | executeBapi(BapiController bapiController) 引数で指定された bapiController のexecuteBapiメソッドを実行します。
String | getBapiReturnErrMessage() ＢＡＰＩの実行結果のエラーメッセージを取得します。
String | getBapiReturnMessage() 設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

sapClient

protected SapClient sapClient
SAPクライアント

bapiReturnErrMessage

protected String bapiReturnErrMessage
BAPI実行エラーメッセージ

bapiReturnMessage

protected String bapiReturnMessage
BAPI実行結果メッセージ

コンストラクタの詳細

AbstractController

protected AbstractController()
コンストラクタ。

AbstractController

protected AbstractController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

createBapiController

protected BapiController createBapiController(String propertyFileName)
                                       throws SAPGeneralSystemException,
                                              SAPAuthSystemException,
                                              SAPGeneralAppException
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

パラメータ:
propertyFileName - プロパティファイル名
戻り値:
BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

executeBapi

protected void executeBapi(BapiController bapiController)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException,
                           SAPAuthSystemException,
                           SAPAuthAppException,
                           SAPBapiReturnErrMessageExistException
引数で指定された bapiController のexecuteBapiメソッドを実行します。

引数で指定された bapiController のメソッドBapiController.executeBapi()を実行し、 実行後、BAPI実行エラーメッセージ、BAPI実行結果メッセージをセットします。 これらの値は getBapiReturnErrMessage()、 getBapiReturnMessage()で取得できます。 BAPI実行エラーメッセージが存在する場合、 SAPBapiReturnErrMessageExistExceptionがスローされます。

その他のスローされる例外やConnectionManagerを指定した場合の注意点等については、 BapiController.executeBapi()を参照して下さい。

パラメータ:
bapiController - BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
SAPAuthSystemException - 認証系システム例外処理
SAPAuthAppException - 認証系APIアプリケーション例外
SAPBapiReturnErrMessageExistException - BAPI実行結果例外

getBapiReturnErrMessage

public String getBapiReturnErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getErrMessage()をご参照ください。

戻り値:
BAPI実行結果エラーとなった全てのメッセージ情報

getBapiReturnMessage

public String getBapiReturnMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List), BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
メッセージの形式等の詳細は、BapiController.getMessage()をご参照ください。

戻り値:
BAPI実行結果のすべてのメッセージ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.module (imsap_bapi_for_r3enterprise 6.1.14 API)

 jp.co.intra_mart.foundation.sap.module
クラス
AbstractController
ReferenceController
UpdateController


jp.co.intra_mart.foundation.sap.module (imsap_bapi_for_r3enterprise 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module

クラスの概要
AbstractController | モジュール共通抽象コントローラクラス。
ReferenceController | 参照系モジュール共通コントローラ親クラス。
UpdateController | 登録・更新系モジュール共通コントローラ親クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.module クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.module の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.module の使用 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.module の使用

jp.co.intra_mart.foundation.sap.module を使用しているパッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

jp.co.intra_mart.foundation.sap.module により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。

jp.co.intra_mart.foundation.sap.module.accounting により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.financial により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
UpdateController
登録・更新系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus により使用される jp.co.intra_mart.foundation.sap.module のクラス
AbstractController
モジュール共通抽象コントローラクラス。
ReferenceController
参照系モジュール共通コントローラ親クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ReferenceController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス ReferenceController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.ReferenceController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
BankList, BillingDocGetDetail, BillingDocGetList, BusinessAreaList, CommonCenterGrpGetDetail, CompanyList, ControllingAreaList, CostCenterList, CreditorGetDetail, DebtorGetDetail, ExchangeRateGetDetail, GlAccList, GoodsMvtGetItems, InternalOrderGetDetail, InternalOrderGetList, MaterialAvailability, MaterialGetAll, MaterialGetList, ProfitCenterList, ProjectGetInfo, PurchaseGetItemSrel, SalesOrderGetList, SalesOrderGetStatus, StdMaterialGetIntNumberList, SupplierDetail, SupplierExistenceCheck
public class ReferenceController
extends AbstractController
implements Serializable

参照系モジュール共通コントローラ親クラス。

このクラスは参照系モジュールに継承されることを期待しています。

関連項目:
直列化された形式

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
protected | ReferenceController() コンストラクタ。
protected | ReferenceController(SapClient sapClient) コンストラクタ。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
createBapiController, executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ReferenceController

protected ReferenceController()
コンストラクタ。

ReferenceController

protected ReferenceController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UpdateController (imsap_bapi_for_r3enterprise 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.module
クラス UpdateController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.module.AbstractController
        拡張 jp.co.intra_mart.foundation.sap.module.UpdateController
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
AccEmployeePayPostController, BillingDocCreateMultiple, GoodsMvtCreate, InquiryCreateFromData2, MaterialSaveReplica, PurchaseOrderPayPost, PurchaseRelease, QuotationCreateFromData2, SalesOrderCreateFromDat2
public class UpdateController
extends AbstractController
implements Serializable

登録・更新系モジュール共通コントローラ親クラス。

このクラスは登録・更新系モジュールに継承されることを期待しています。

関連項目:
直列化された形式

フィールドの概要
protected  ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したフィールド
bapiReturnErrMessage, bapiReturnMessage, sapClient
コンストラクタの概要
protected | UpdateController() コンストラクタ。
protected | UpdateController(ConnectionManager connectionManager) コンストラクタ。
protected | UpdateController(SapClient sapClient) コンストラクタ。
メソッドの概要
protected  BapiController createBapiController(String propertyFileName)
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
クラス jp.co.intra_mart.foundation.sap.module.AbstractController から継承したメソッド
executeBapi, getBapiReturnErrMessage, getBapiReturnMessage
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

connectionManager

protected ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

コンストラクタの詳細

UpdateController

protected UpdateController()
コンストラクタ。

UpdateController

protected UpdateController(SapClient sapClient)
コンストラクタ。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト

UpdateController

protected UpdateController(ConnectionManager connectionManager)
コンストラクタ。

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
なお、AbstractController.executeBapi(jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController)実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でR/3へのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】トランザクション処理が記述されているBAPIもあります。 その場合、AbstractController.executeBapi(BapiController)実行後に ここまでのコネクションマネージャーで実行したすべての処理がcommitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
connectionManager - コネクションマネージャー
メソッドの詳細

createBapiController

protected BapiController createBapiController(String propertyFileName)
                                       throws SAPGeneralSystemException,
                                              SAPAuthSystemException,
                                              SAPGeneralAppException
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

オーバーライド:
クラス AbstractController 内の createBapiController
パラメータ:
propertyFileName - プロパティファイル名
戻り値:
BapiControllerインスタンス
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (imsap_bapi_for_r3enterprise 6.1.14 API)

 すべてのクラス
AbstractController
AccEmployeePayPostController
AccountGl
AccountPayable
AccountTax
AllVersions
AllowedBusTract
Bank
BankController
BankList
BatchRa
BillingDataIn
BillingDocCreateMultiple
BillingDocCreateMultipleController
BillingDocGetDetail
BillingDocGetDetailController
BillingDocGetList
BillingDocGetListController
BillingDocumentDetail
BillingDocumentDetailList
BusinessArea
BusinessAreaController
BusinessAreaList
CCardDataIn
CfgsBlob
CfgsInst
CfgsPartOf
CfgsRef
CfgsRefInst
CfgsValue
CfgsVk
ClientData
ClientDataList
CommonCenterGrpGetDetail
Company
CompanyController
CompanyList
Cond
ConditionDataIn
ConditionsIn
ConditionsInX
ContractLimits
ContractService
ContractServiceAccount
ContractServiceText
ControllingArea
ControllingAreaController
ControllingAreaList
CostCenter
CostCenterController
CostCenterGroupGetDetail
CostCenterGroupGetDetailController
CostCenterList
CreatorDataIn
CreditorGetDetail
CreditorGetDetailController
CurrencyAmount
DebtorGetDetail
DebtorGetDetailController
DeliveryAddress
DistributionChannelSelection
DocumentHeader
Errors
ExchRate
ExchangeRateGetDetail
ExchangeRateGetDetailController
ExpActivity
ExpMessage
ExpWbsElement
ExpWbsHierarchie
ExpWbsMilestone
ExportHeader
ExportItem
Extension
ExtensionIn
ExtensionIn
ExtensionInX
ExtensionOut
ForecastParameters
ForecastParametersList
ForecastValues
GlAcc
GlAccController
GlAccList
GoodsMvtCode
GoodsMvtCreate
GoodsMvtCreateController
GoodsMvtGetItems
GoodsMvtGetItemsController
GoodsMvtHeader
GoodsMvtHeaderList
GoodsMvtHeadret
GoodsMvtItem
GoodsMvtItems
GoodsMvtSerialNumber
HeadData
HeaderIn
HeaderInX
HierarchyNodes
HierarchyValues
ImpWbsElement
InquiryCreateFromData2
InquiryCreateFromData2Controller
InternalOrderGetDetail
InternalOrderGetDetailController
InternalOrderGetList
InternalOrderGetListController
InternationArticleNumbers
InternationalArtnos
ItemsIn
ItemsInX
Keys
LifoValuationData
Limits
LogicSwitch
ManufacturerPartNumb
MasterData
MaterialAvailability
MaterialAvailabilityController
MaterialDescription
MaterialGetAll
MaterialGetAllController
MaterialGetList
MaterialGetListController
MaterialLongText
MaterialRa
MaterialSaveReplica
MaterialSaveReplicaController
MaterialShortDescsel
MaterialText
MatnrList
MatnrSelection
MoveTypeRa
OrderCcard
OrderList
ParamAllVersions
ParamBatchRa
ParamBillingDataIn
ParamBillingDocumentDetailList
ParamCCardDataIn
ParamCfgsBlob
ParamCfgsInst
ParamCfgsPartOf
ParamCfgsRef
ParamCfgsRefInst
ParamCfgsValue
ParamCfgsVk
ParamClientDataList
ParamCondHeader
ParamCondItem
ParamConditionDataIn
ParamConditionsIn
ParamConditionsInX
ParamContractLimits
ParamContractService
ParamContractServiceAccount
ParamContractServiceText
ParamCreatorDataIn
ParamDeliveryAddress
ParamErrors
ParamExportHeader
ParamExportItem
ParamExtension
ParamExtensionIn
ParamExtensionIn
ParamExtensionInX
ParamForecastParametersList
ParamForecastValues
ParamGoodsMvtCode
ParamGoodsMvtHeader
ParamGoodsMvtHeaderList
ParamGoodsMvtHeadret
ParamGoodsMvtItem
ParamGoodsMvtItems
ParamGoodsMvtSerialNumber
ParamHeadData
ParamHeader
ParamHeaderIn
ParamHeaderInX
ParamHeaderText
ParamInternationalArtnos
ParamItem
ParamItemText
ParamItemsIn
ParamItemsInX
ParamKeys
ParamLimits
ParamLogicSwitch
ParamMaterialDescription
ParamMaterialLongText
ParamMaterialRa
ParamMoveTypeRa
ParamOrderCcard
ParamPartner
ParamPartnerAddresses
ParamPartners
ParamPlanningDataList
ParamPlantDataList
ParamPlantRa
ParamProfitSegment
ParamPrtData
ParamPstngDateRa
ParamPurchaseAccount
ParamPurchaseSchedule
ParamRefDocRange
ParamReturnMessages
ParamSalesDataList
ParamSalesOrders
ParamSchedulesIn
ParamSchedulesInX
ParamSender
ParamSpecStockRa
ParamStatusInfo
ParamStgeLocRa
ParamStorageLocationDataList
ParamStorageTypeDataList
ParamSuccess
ParamTaxClassifications
ParamText
ParamTextDataIn
ParamTotalConsumption
ParamTrEvTypeRa
ParamUnitSofmeasure
ParamUnplndConsumption
ParamUserNameRa
ParamValuationDataList
ParamVendorAddress
ParamVendorRa
ParamVersions
ParamWarehouseNumberDataList
ParamWmdvex
ParamWmdvsx
Partner
PartnerAddresses
Partners
PlanningData
PlanningDataList
PlantData
PlantDataList
PlantRa
PlantSelection
ProductionResourceToolData
ProfitCenter
ProfitCenterController
ProfitCenterGrpGetDetail
ProfitCenterGrpGetDetailController
ProfitCenterList
ProfitSegment
ProjectDefinition
ProjectGetInfo
ProjectGetInfoController
PrtData
PstngDateRa
PurchaseAccount
PurchaseGetItemSrel
PurchaseGetItemSrelController
PurchaseHeader
PurchaseHeaderPost
PurchaseHeaders
PurchaseItem
PurchaseItemPost
PurchaseItems
PurchaseOrderPayPost
PurchaseOrderPayPostController
PurchaseOrderPostChangeController
PurchaseRelease
PurchaseReleaseController
PurchaseResetReleaseController
PurchaseSchedule
PurchaseText
QuotationCreateFromData2
QuotationCreateFromData2Controller
RefDocRange
ReferenceController
ReturnMessages
SAPAccountingAppException
SAPAccountingSystemException
SAPBapiReturnErrMessageExistException
SAPFinancialAppException
SAPFinancialSystemException
SAPModuleAppException
SAPModuleSystemException
SAPPurchaseAppException
SAPPurchaseSystemException
SAPSalesAppException
SAPSalesSystemException
SalesData
SalesDataList
SalesOrderCreateFromDat2
SalesOrderCreateFromDat2Controller
SalesOrderGetList
SalesOrderGetListController
SalesOrderGetStatus
SalesOrderGetStatusController
SalesOrders
SalesOrganisationSelection
SchedulesIn
SchedulesInX
Selection
Sender
SpecStockRa
StatusInfo
StdMaterialGetIntNumber
StdMaterialGetIntNumberController
StdMaterialGetIntNumberList
StgeLocRa
StorageLocationData
StorageLocationDataList
StorageLocationSelect
StorageTypeData
StorageTypeDataList
Success
SupplierDetail
SupplierExistenceCheck
SupplierExistenceCheckController
SupplierGetDetailController
SystemStatus
TaxClassifications
Text
TextDataIn
TotalConsumption
TrEvTypeRa
UnitSofmeasure
UnplndConsumption
UpdateController
UserNameRa
UserStatus
ValuationData
ValuationDataList
VendorAddress
VendorRa
Versions
WarehouseNumberData
WarehouseNumberDataList
Wmdvex
Wmdvsx


定数フィールド値 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (imsap_bapi_for_r3enterprise 6.1.14 API)

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし

A B C D E F G H I J K L M O P Q R S T U V W

A

AbstractController - class jp.co.intra_mart.foundation.sap.module.AbstractController.
モジュール共通抽象コントローラクラス。
AbstractController() - class jp.co.intra_mart.foundation.sap.module.AbstractController のコンストラクタ
コンストラクタ。
AbstractController(SapClient) - class jp.co.intra_mart.foundation.sap.module.AbstractController のコンストラクタ
コンストラクタ。
AccEmployeePayPostController - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
AccEmployeePayPostController() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、 明細通貨項目一覧を作成します｡
AccEmployeePayPostController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

ConnectionManagerを使用することで、ConnectionManagerから トランザクションを制御でき、 たとえば同一トランザクション内で複数の登録処理を実行することができます。
AccEmployeePayPostController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のコンストラクタ
伝票ヘッダ、仕入先明細一覧、G/L 勘定明細一覧、税明細一覧、明細通貨項目一覧を作成します｡

SapClientを使用することで、SapClientにて指定した R/3アプリケーションサーバへデータを登録することが可能です。
AccountGl - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl.
G/L 勘定明細クラス
機能は以下の通り
G/L 勘定明細の情報を保持します。
AccountGl(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のコンストラクタ
G/L 勘定明細情報を作成します。
AccountPayable - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable.
仕入先明細クラス
機能は以下の通り
仕入先明細の情報を保持します。
AccountPayable(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のコンストラクタ
仕入先明細情報を作成します。
AccountTax - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax.
税明細クラス
機能は以下の通り
税明細の情報を保持します。
AccountTax(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のコンストラクタ
指定されたレコード番号でAccountTaxを作成します｡
AllVersions - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions.
全バージョン管理情報クラス
機能は以下の通り
全バージョン管理情報を保持します。
AllVersions() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のコンストラクタ
バージョン管理を作成します。
AllowedBusTract - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract.
使用可能業務トランザクションのテーブル情報クラス 機能は以下の通り
使用可能業務トランザクションのテーブル情報を保持します。
AllowedBusTract() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のコンストラクタ
使用可能業務トランザクションのテーブルを作成します。

B

Bank - class jp.co.intra_mart.foundation.sap.module.accounting.Bank.
銀行情報クラス
機能は以下の通り
銀行の情報を保持します。
Bank() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のコンストラクタ
銀行情報を作成します。
BankController - class jp.co.intra_mart.foundation.sap.module.accounting.BankController.
銀行コントローラクラス
機能は以下の通り
銀行の情報を取得します。
BankController() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のコンストラクタ
BankListのコンストラクタを呼び出し銀行一覧を作成します。
BankList - class jp.co.intra_mart.foundation.sap.module.accounting.BankList.
銀行一覧クラス
機能は以下の通り
銀行の情報を一覧形式で取得します。
BankList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のコンストラクタ
executeBapiを呼び出し銀行一覧を作成します。
BatchRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa.
ロットの範囲情報クラス
機能は以下の通り
ロットの範囲情報を保持します。
BatchRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のコンストラクタ
ロットの範囲情報を作成します。
BatchRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のコンストラクタ
ロットの範囲情報を作成します。
BillingDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn.
処理予定明細データのテーブル情報クラス
機能は以下の通り
処理予定明細データのテーブル情報を保持します。
BillingDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のコンストラクタ
処理予定明細データのテーブル情報を作成します。
BillingDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のコンストラクタ
処理予定明細データのテーブル情報を作成します。
BillingDocCreateMultiple - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple.
請求伝票登録情報クラス
機能は以下の通り
請求伝票登録情報を保持します。
BillingDocCreateMultiple() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
請求伝票登録情報を作成します。
BillingDocCreateMultiple(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
BillingDocCreateMultiple(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
BillingDocCreateMultipleController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController.
請求伝票登録コントローラクラス
機能は以下の通り
請求伝票を登録します。
BillingDocCreateMultipleController() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocCreateMultipleController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のコンストラクタ
BillingDocCreateMultipleControllerのコンストラクタを生成します。
BillingDocGetDetail - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail.
請求伝票詳細照会情報クラス
機能は以下の通り
請求伝票詳細照会情報を保持します。
BillingDocGetDetail(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のコンストラクタ
請求伝票詳細照会情報を作成します。
BillingDocGetDetailController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController.
請求伝票詳細照会情報コントローラクラス
機能は以下の通り
請求伝票詳細照会情報を保持します。
BillingDocGetDetailController(String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のコンストラクタ
コンストラクタ生成
BillingDocGetDetailController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のコンストラクタ
コンストラクタ生成
BillingDocGetList - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList.
請求伝票一覧照会情報クラス
機能は以下の通り
請求伝票一覧照会情報を保持します。
BillingDocGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のコンストラクタ
請求伝票一覧照会情報を作成します。
BillingDocGetList(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のコンストラクタ
請求伝票一覧照会情報を作成します。
BillingDocGetListController - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController.
請求伝票一覧照会情報コントローラクラス
機能は以下の通り
請求伝票一覧照会情報を保持します。
BillingDocGetListController() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocGetListController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のコンストラクタ
コンストラクタ生成
BillingDocumentDetail - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail.
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
BillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList.
後続請求伝票のテーブル情報クラス
機能は以下の通り
後続請求伝票のテーブル情報を保持します。
BillingDocumentDetailList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BillingDocumentDetailList(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のコンストラクタ
後続請求伝票のテーブル情報を作成します。
BusinessArea - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea.
事業領域情報クラス
機能は以下の通り
事業領域の情報を保持します。
BusinessArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のコンストラクタ
事業領域情報を作成します。
BusinessAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController.
事業領域コントローラクラス
機能は以下の通り
事業領域の情報を取得します。
BusinessAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のコンストラクタ
BusinessAreaListのコンストラクタを呼び出し事業領域一覧を作成します。
BusinessAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList.
事業領域一覧クラス
機能は以下の通り
事業領域の情報を一覧形式で取得します。
BusinessAreaList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のコンストラクタ
executeBapiを呼び出し事業領域一覧を作成します。
bapiReturnErrMessage - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
BAPI実行エラーメッセージ
bapiReturnMessage - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
BAPI実行結果メッセージ

C

CCardDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn.
処理予定支払方法のテーブル情報クラス
機能は以下の通り
処理予定支払方法のテーブル情報を保持します。
CCardDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のコンストラクタ
処理予定支払方法のテーブル情報を作成します。
CCardDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のコンストラクタ
処理予定支払方法のテーブル情報を作成します。
CfgsBlob - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob.
選定: BLOB 内部データ (SCE)情報クラス
機能は以下の通り
選定: BLOB 内部データ (SCE)情報を保持します。
CfgsBlob() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のコンストラクタ
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsBlob(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のコンストラクタ
選定: BLOB 内部データ (SCE)情報を作成します。
CfgsInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst.
選定: インスタンス情報クラス
機能は以下の通り
選定: インスタンス情報を保持します。
CfgsInst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のコンストラクタ
選定: インスタンス情報を作成します。
CfgsInst(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のコンストラクタ
選定: インスタンス情報を作成します。
CfgsPartOf - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf.
選定: 部分設定情報クラス
機能は以下の通り
選定: 部分設定情報を保持します。
CfgsPartOf() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のコンストラクタ
選定: 部分設定情報を作成します。
CfgsPartOf(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のコンストラクタ
選定: 部分設定情報を作成します。
CfgsRef - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef.
選定: 参照データ情報クラス
機能は以下の通り
選定: 参照データ情報を保持します。
CfgsRef() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のコンストラクタ
選定: 参照データ情報を作成します。
CfgsRef(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のコンストラクタ
選定: 参照データ情報を作成します。
CfgsRefInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst.
選定: 参照明細/インスタンス情報クラス
機能は以下の通り
選定: 参照明細/インスタンス情報を保持します。
CfgsRefInst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のコンストラクタ
選定: 参照明細/インスタンス情報を作成します。
CfgsRefInst(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のコンストラクタ
選定: 参照明細/インスタンス情報を作成します。
CfgsValue - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue.
選定: 特性値情報クラス
機能は以下の通り
選定: 特性値情報を保持します。
CfgsValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のコンストラクタ
選定: 特性値情報を作成します。
CfgsValue(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のコンストラクタ
選定: 特性値情報を作成します。
CfgsVk - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk.
選定: バリアント条件キー情報クラス
機能は以下の通り
選定: バリアント条件キー情報を保持します。
CfgsVk() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のコンストラクタ
選定: バリアント条件キー情報を作成します。
CfgsVk(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のコンストラクタ
選定: バリアント条件キー情報を作成します。
ClientData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData.
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報を保持します。
ClientData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList.
品目データ (クライアントレベル)情報クラス
機能は以下の通り
品目データ (クライアントレベル)情報をテーブル型で保持します。
ClientDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
ClientDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のコンストラクタ
品目データ (クライアントレベル)情報を作成します。
CommonCenterGrpGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail.
原価・利益センタグループ情報取得共通クラス
機能は以下の通り
原価・利益センタグループ情報を取得します。
CommonCenterGrpGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ
センタグループ情報を作成
CommonCenterGrpGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のコンストラクタ

Company - class jp.co.intra_mart.foundation.sap.module.accounting.Company.
会社情報クラス
機能は以下の通り
会社の情報を保持します。
Company() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のコンストラクタ
会社情報を作成します。
CompanyController - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController.
会社コントローラクラス
機能は以下の通り
会社の情報を取得します。
CompanyController() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のコンストラクタ
CompanyListのコンストラクタを呼び出し会社一覧を作成します。
CompanyList - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList.
会社一覧クラス
機能は以下の通り
会社の情報を一覧形式で取得します。
CompanyList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のコンストラクタ
executeBapiを呼び出し会社一覧を作成します。
Cond - class jp.co.intra_mart.foundation.sap.module.purchase.Cond.
条件情報クラス
機能は以下の通り
条件情報を保持します。
Cond() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のコンストラクタ
条件を作成します。
Cond(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のコンストラクタ
条件を作成します。
ConditionDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn.
処理予定条件のテーブル情報クラス
機能は以下の通り
処理予定条件のテーブル情報を保持します。
ConditionDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のコンストラクタ
処理予定条件のテーブル情報を作成します。
ConditionDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のコンストラクタ
処理予定条件のテーブル情報を作成します。
ConditionsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn.
条件情報クラス
機能は以下の通り
条件情報を保持します。
ConditionsIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のコンストラクタ
条件情報を作成します。
ConditionsIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のコンストラクタ
条件情報を作成します。
ConditionsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX.
受注における条件更新の通信項目情報クラス
機能は以下の通り
受注における条件更新の通信項目情報を保持します。
ConditionsInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のコンストラクタ
受注における条件更新の通信項目情報を作成します。
ConditionsInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のコンストラクタ
受注における条件更新の通信項目情報を作成します。
ContractLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits.
外注基本契約制限情報クラス
機能は以下の通り
外注基本契約情報を保持します。
ContractLimits() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のコンストラクタ
外注基本契約を作成します。
ContractLimits(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のコンストラクタ
外注基本契約を作成します。
ContractService - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService.
外注サービス情報クラス
機能は以下の通り
外注サービス情報を保持します。
ContractService() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のコンストラクタ
外注サービスを作成します。
ContractService(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のコンストラクタ
外注サービスを作成します。
ContractServiceAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount.
外注サービス勘定設定情報クラス
機能は以下の通り
外注サービス勘定設定情報を保持します。
ContractServiceAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のコンストラクタ
外注サービス勘定設定を作成します。
ContractServiceAccount(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のコンストラクタ
外注サービス勘定設定を作成します。
ContractServiceText - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText.
外注サービステキスト情報クラス
機能は以下の通り
外注サービステキスト情報を保持します。
ContractServiceText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のコンストラクタ
外注サービステキストを作成します。
ContractServiceText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のコンストラクタ
外注サービステキストを作成します。
ControllingArea - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea.
管理領域情報クラス
機能は以下の通り
管理領域の情報を保持します。
ControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のコンストラクタ
管理領域情報を作成します。
ControllingAreaController - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController.
管理領域コントローラクラス
機能は以下の通り
管理領域の情報を取得します。
ControllingAreaController() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のコンストラクタ
ControllingAreaListのコンストラクタを呼び出し管理領域一覧を作成します。
ControllingAreaList - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList.
管理領域一覧クラス
機能は以下の通り
管理領域の情報を一覧形式で取得します。
ControllingAreaList(SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のコンストラクタ
executeBapiを呼び出し管理領域一覧を作成します。
CostCenter - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter.
原価センタ情報クラス
機能は以下の通り
原価センタの情報を保持します。
CostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のコンストラクタ
原価センタ情報を取得します。
CostCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController.
原価センタコントローラクラス
機能は以下の通り
原価センタの情報を取得します。
CostCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterController(String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のコンストラクタ
CostCenterListのコンストラクタを呼び出し原価センタ一覧を作成します。
CostCenterGroupGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail.
原価センタグループ情報取得クラス
機能は以下の通り
原価センタグループ情報を取得します。
CostCenterGroupGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ
原価センタグループ情報を作成
CostCenterGroupGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のコンストラクタ

CostCenterGroupGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController.
原価センタグループコントローラクラス
機能は以下の通り
原価センタグループを取得します。
CostCenterGroupGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ

CostCenterGroupGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterGroupGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のコンストラクタ
CostCenterGroupGetDetailControllerのコンストラクタを生成します。
CostCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList.
原価センタ一覧クラス
機能は以下の通り
原価センタの情報を一覧形式で取得します。
CostCenterList(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のコンストラクタ
executeBapiを呼び出し原価センタ一覧を作成します。
CreatorDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn.
取り込まれる日付の順序情報クラス
機能は以下の通り
取り込まれる日付の順序情報を保持します。
CreatorDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のコンストラクタ
取り込まれる日付の順序情報を作成します。
CreditorGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail.
仕入先詳細情報取得クラス
機能は以下の通り
仕入先詳細情報を取得します。
CreditorGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のコンストラクタ
仕入先詳細情報を作成
CreditorGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のコンストラクタ

CreditorGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController.
仕入先詳細コントローラクラス
機能は以下の通り
仕入先詳細を取得します。
CreditorGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ

CreditorGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ

CreditorGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
CreditorGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
CurrencyAmount - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount.
明細通貨項目クラス
機能は以下の通り
明細通貨項目の情報を保持します。
CurrencyAmount(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のコンストラクタ
指定されたレコード番号でCurrencyAmountを作成します。
connectionManager - class jp.co.intra_mart.foundation.sap.module.UpdateController の変数
コネクション(トランザクション)オブジェクト
createBapiController(String) - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。
createBapiController(String) - class jp.co.intra_mart.foundation.sap.module.UpdateController のメソッド
引数で指定されたプロパティファイル名から構成されるBapiControllerを新規に作成します。

D

DebtorGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail.
得意先詳細情報取得クラス
機能は以下の通り
得意先詳細情報を取得します。
DebtorGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のコンストラクタ
得意先詳細情報を作成
DebtorGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のコンストラクタ

DebtorGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController.
得意先詳細コントローラクラス
機能は以下の通り
得意先詳細を取得します。
DebtorGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ

DebtorGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ

DebtorGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
DebtorGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のコンストラクタ
DebtorGetDetailControllerのコンストラクタを生成します。
DeliveryAddress - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress.
入荷伝票アドレス情報クラス
機能は以下の通り
入荷伝票アドレス情報を保持します。
DeliveryAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のコンストラクタ
入荷伝票アドレスを作成します。
DeliveryAddress(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のコンストラクタ
入荷伝票アドレスを作成します。
DistributionChannelSelection - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection.
流通チャネルの選択オプションクラス
機能は以下の通り
流通チャネルの選択オプションの情報を保持します。
DistributionChannelSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のコンストラクタ
流通チャネルの選択オプション情報を作成します。
DistributionChannelSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のコンストラクタ
流通チャネルの選択オプション情報を作成します。
DocumentHeader - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader.
伝票ヘッダクラス
機能は以下の通り
伝票ヘッダの情報を保持します。
DocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のコンストラクタ
伝票ヘッダ情報を作成します。

E

Errors - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors.
前明細の不正処理に関する情報情報クラス
機能は以下の通り
前明細の不正処理に関する情報情報を保持します。
Errors() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のコンストラクタ
前明細の不正処理に関する情報情報を作成します。
Errors(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のコンストラクタ
前明細の不正処理に関する情報情報を作成します。
ExchRate - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate.
換算レート、係数 (通貨ペア)情報クラス 機能は以下の通り
換算レート、係数 (通貨ペア)情報を保持します。
ExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のコンストラクタ
換算レート、係数 (通貨ペア)を作成します。
ExchangeRateGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail.
為替換算レート情報取得クラス
機能は以下の通り
為替換算レート情報を取得します。
ExchangeRateGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のコンストラクタ
為替換算レート情報を作成
ExchangeRateGetDetail(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のコンストラクタ

ExchangeRateGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController.
為替換算レートコントローラクラス
機能は以下の通り
為替換算レートを取得します。
ExchangeRateGetDetailController(String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ

ExchangeRateGetDetailController(String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ

ExchangeRateGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExchangeRateGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のコンストラクタ
ExchangeRateGetDetailControllerのコンストラクタを生成します。
ExpActivity - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity.
活動に関する詳細情報クラス 機能は以下の通り
活動に関する詳細情報を保持します。
ExpActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のコンストラクタ
活動に関する詳細情報を作成します。
ExpMessage - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage.
詳細情報を読み込みエラー情報クラス 機能は以下の通り
詳細情報を読み込みエラー情報を保持します。
ExpMessage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のコンストラクタ
詳細情報を読み込みエラー情報を作成します。
ExpWbsElement - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement.
WBS 要素についての詳細情報クラス
機能は以下の通り
WBS 要素についての詳細情報を保持します。
ExpWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のコンストラクタ
WBS 要素についての詳細情報を作成します。
ExpWbsHierarchie - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie.
WBS 階層についての情報クラス 機能は以下の通り
WBS 階層についての情報を保持します。
ExpWbsHierarchie() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のコンストラクタ
WBS 階層についての情報を作成します。
ExpWbsMilestone - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone.
WBS マイルストーンに関する詳細情報クラス 機能は以下の通り
WBS マイルストーンに関する詳細情報を保持します。
ExpWbsMilestone() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のコンストラクタ
WBS マイルストーンに関する詳細情報を作成します。
ExportHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader.
貿易管理ヘッダ情報クラス
機能は以下の通り
貿易管理ヘッダ情報を保持します。
ExportHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のコンストラクタ
貿易管理明細を作成します。
ExportItem - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem.
貿易管理明細情報クラス
機能は以下の通り
貿易管理明細情報を保持します。
ExportItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のコンストラクタ
貿易管理明細を作成します。
ExportItem(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のコンストラクタ
貿易管理明細を作成します。
Extension - class jp.co.intra_mart.foundation.sap.module.purchase.Extension.
拡張得意先項目情報クラス
機能は以下の通り
拡張得意先項目情報を保持します。
Extension() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のコンストラクタ
拡張得意先項目を作成します。
Extension(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のコンストラクタ
拡張得意先項目アドレスを作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn.
VBAK、VBAP、VBEP のカスタマ拡張情報クラス
機能は以下の通り
VBAK、VBAP、VBEP のカスタマ拡張情報を保持します。
ExtensionIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のコンストラクタ
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のコンストラクタ
VBAK、VBAP、VBEP のカスタマ拡張情報を作成します。
ExtensionInX - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX.
拡張イン/拡張アウトのチェックボックス構造情報クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造情報を保持します。
ExtensionInX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のコンストラクタ
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionInX(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のコンストラクタ
拡張イン/拡張アウトのチェックボックス構造情報を作成します。
ExtensionOut - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を保持します。
ExtensionOut() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
ExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のコンストラクタ
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造情報を作成します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
引数で指定された bapiController のexecuteBapiメソッドを実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
BapiControllerにより会計伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail のメソッド
BapiControllerにより原価センタグループ検索を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
CostCenterGroupGetDetailのexecuteBapi()を呼び出し原価センタグループを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
BapiControllerにより仕入先コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
BapiControllerにより得意先コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
BapiControllerにより為替換算レート情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
ExchangeRateGetDetailのexecuteBapi()を呼び出し為替換算レートを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
BapiControllerにより内部指図書詳細情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
InternalOrderGetDetailのexecuteBapi()を呼び出し内部指図書詳細を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
BapiControllerにより内部指図書（一覧）情報を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し内部指図書一覧を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のメソッド
BapiControllerにより利益センタグループ検索を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
ProfitCenterGrpGetDetailのexecuteBapi()を呼び出し利益センタグループを取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
BapiControllerによりWBSの詳細情報の検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
ProjectGetInfoのexecuteBapi()を呼び出しWBSの詳細を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
GoodsMvtCreateのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のメソッド
GoodsMvtGetItemsのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
MaterialAvailabilityのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
BapiControllerにより品目マスタ照会を行います。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のメソッド
ReferenceControllerのexecuteBapi()を呼び出し品目コードを検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
BapiControllerにより品目マスタを更新します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
BapiControllerにより仕入先マスタ詳細を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
PurchaseGetItemSrelのexecuteBapi()を呼び出し伝票承認対象一覧を取得します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買発注伝票の登録及び変更に共通で使用する項目に値をセットした後、 AbstractController#executeBapi()を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のメソッド
PurchaseOrderPayPostのexecuteBapi()を呼び出し購買伝票を変更します。
executeBapi(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
伝票承認取消処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
伝票承認処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のメソッド
伝票承認取消処理を実行します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
BapiControllerにより仕入先マスタ詳細を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
BapiControllerにより仕入先コード存在チェックを作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
SupplierExistenceCheckのexecuteBapi()を呼び出し仕入先コード存在チェックを行います。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
SupplierDetailのexecuteBapi()を呼び出し仕入先マスタ詳細情報を作成します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
BillingDocCreateMultipleのexecuteBapi()を呼び出し請求伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
BillingDocGetListのexecuteBapi()を呼び出し請求伝票一覧を検索します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
InquiryCreateFromData2のexecuteBapi()を呼び出し引合伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
QuotationCreateFromData2のexecuteBapi()を呼び出し見積伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
SalesOrderCreateFromDat2のexecuteBapi()を呼び出し販売伝票を登録します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
ReferenceControllerのexecuteBapi()を呼び出し販売伝票一覧を取得します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のメソッド
SalesOrderGetStatusのexecuteBapi()を呼び出し販売伝票ステータス一覧を照会します。
executeBapi() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
BillingDocGetDetailのexecuteBapi()を呼び出し請求伝票を検索します。

F

ForecastParameters - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters.
予測パラメータ情報クラス
機能は以下の通り
予測パラメータ情報を保持します。
ForecastParameters() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のコンストラクタ
予測パラメータ情報を作成します。
ForecastParametersList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList.
需要予測パラメータ情報クラス
機能は以下の通り
需要予測パラメータ情報をテーブル型で保持します。
ForecastParametersList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のコンストラクタ
需要予測パラメータ情報を作成します。
ForecastParametersList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のコンストラクタ
需要予測パラメータ情報を作成します。
ForecastValues - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues.
需要予測値のデータ転送情報クラス
機能は以下の通り
需要予測値のデータ転送情報を保持します。
ForecastValues() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のコンストラクタ
需要予測値のデータ転送情報を作成します。
ForecastValues(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のコンストラクタ
需要予測値のデータ転送情報を作成します。

G

GlAcc - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc.
勘定項目情報クラス
機能は以下の通り
勘定項目の情報を保持します。
GlAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のコンストラクタ
勘定項目情報を作成します。
GlAccController - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController.
勘定科目コントローラクラス
機能は以下の通り
勘定科目の情報を取得します。
GlAccController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のコンストラクタ
GlAccListのコンストラクタを呼び出し勘定科目一覧を作成します。
GlAccList - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList.
勘定項目一覧クラス
機能は以下の通り
勘定項目の情報を一覧形式で取得します。
GlAccList(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のコンストラクタ
executeBapiを呼び出し勘定項目一覧を作成します。
GoodsMvtCode - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode.
在庫移動に対するコードのトランザクションへの割当情報クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当情報を保持します。
GoodsMvtCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のコンストラクタ
在庫移動に対するコードのトランザクションへの割当情報を作成します。
GoodsMvtCreate - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate.
入出庫伝票登録情報クラス
機能は以下の通り
入出庫伝票登録情報を保持します。
GoodsMvtCreate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
コンストラクタ。
GoodsMvtCreate(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
GoodsMvtCreate(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
GoodsMvtCreateController - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController.
入庫伝票登録コントローラクラス
機能は以下の通り
入庫伝票を登録します。
GoodsMvtCreateController() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtCreateController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のコンストラクタ
GoodsMvtCreateControllerのコンストラクタを生成します。
GoodsMvtGetItems - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems.
出庫確認一覧照会情報クラス
機能は以下の通り
出庫確認一覧照会情報を保持します。
GoodsMvtGetItems(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のコンストラクタ
出庫確認一覧照会情報を作成します。
GoodsMvtGetItemsController - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController.
入出庫伝票一覧取得コントローラクラス
機能は以下の通り
入出庫伝票の一覧を取得します。
GoodsMvtGetItemsController() - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のコンストラクタ
コンストラクタ生成
GoodsMvtGetItemsController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のコンストラクタ
コンストラクタ生成
GoodsMvtHeader - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader.
入出庫伝票ヘッダデータ情報クラス
機能は以下の通り
入出庫伝票ヘッダデータ情報を保持します。
GoodsMvtHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のコンストラクタ
入出庫伝票ヘッダデータ情報を作成します。
GoodsMvtHeaderList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtHeaderList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtHeadret - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret.
入出庫伝票番号/入出庫伝票会計年度情報クラス
機能は以下の通り
入出庫伝票番号/入出庫伝票会計年度情報を保持します。
GoodsMvtHeadret() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のコンストラクタ
入出庫伝票番号/入出庫伝票会計年度情報を作成します。
GoodsMvtItem - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItem(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItems - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems.
入出庫伝票明細情報クラス
機能は以下の通り
入出庫伝票明細情報を保持します。
GoodsMvtItems() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtItems(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のコンストラクタ
入出庫伝票明細情報を作成します。
GoodsMvtSerialNumber - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber.
シリアル番号情報クラス
機能は以下の通り
シリアル番号情報を保持します。
GoodsMvtSerialNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のコンストラクタ
シリアル番号情報を作成します。
GoodsMvtSerialNumber(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のコンストラクタ
シリアル番号情報を作成します。
getAbart() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
承認タイプを取得します。
getAbcId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ABC 区分を取得します。
getAbrli() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
内部納入日程番号を取得します。
getAcIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード番号を取得します｡
getAccessSeq() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
検索順序 - 検索番号を取得します。
getAccessSeq() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
検索順序 - 検索番号を取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先の勘定設定グループを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先の勘定設定グループを取得します。
getAccntAsgn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAccountGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を取得します｡
getAccountKe() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キー 見越/引当を取得します。
getAccountPayableList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を取得します｡
getAccountTaxList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を取得します｡
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計ビューを取得します。
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
会計ビューを取得します。
getAccountView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
会計ビューを取得します。
getAccountkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キーを取得します。
getAccruals() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
見越額関連条件 (運賃など)を取得します。
getAccruals() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
見越額関連条件 (運賃など)を取得します。
getAcctAssgt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目の勘定設定グループを取得します。
getAcctasgnmt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の勘定設定グループを取得します。
getAcctasscat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
勘定設定カテゴリを取得します。
getAcctstatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
会計への転記ステータスを取得します。
getAcknReqd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注請求書依頼を取得します。
getAcknowlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注請書番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク/標準ネットワークの活動番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
作業番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
処理タイプ - R/3 Enterprise で使用不可能を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
作業番号を取得します。
getActivity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
作業番号を取得します。
getActivityCosts() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の原価を取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
活動タイプを取得します。
getActtype() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
活動タイプを取得します。
getActualCost() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実際原価を取得します。
getActualDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日付(マイルストーン通過)を取得します。
getActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績終了日: 実行 (日付)を取得します。
getActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績開始日: 実行 (日付)を取得します。
getActualTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日/時間(マイルストーン適合)を取得します。
getAddToStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
既存在庫への追加許可を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日からの日数を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日からの日数を取得します。
getAddValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAddrLink() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所コードへのリンクを取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
アドレス: アドレス番号を取得します。
getAddrNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレス番号を取得します。
getAddrOrig() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
コピー元住所を取得します。
getAddrType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
住所を取得します。
getAddress() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
住所注記を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
住所注記を取得します。
getAdrNotes() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
住所注記を取得します。
getAgmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約の明細番号を取得します。
getAgreement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買契約番号を取得します｡
getAgreement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約番号を取得します。
getAllVersionsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
全バージョン一覧を取得します｡
getAllocTbl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
商品配分表番号を取得します。
getAllowedBusTractList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
使用可能業務トランザクションのテーブルを取得します。
getAllowedBusTractList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
使用可能業務トランザクションのテーブルを取得します。
getAllowedWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包重量を取得します。
getAllwdVol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包容積を取得します。
getAlphaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
アルファ係数使用による基本値の平滑化を取得します。
getAltBomId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOM 選択の方法を取得します。
getAltToItm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替明細を取得します。
getAltToItm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAltUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
在庫保管単位の代替数量単位を取得します。
getAltUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードによる在庫単位の代替数量単位を取得します。
getAlternBom() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替 BOMを取得します。
getAlternBom() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAlternat() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替明細を取得します。
getAlternativeBom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOMを取得します。
getAlttaxCls() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
代替税分類を取得します。
getAlttaxCls() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAmountLc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
マニュアル入力による転記金額 (国内通貨)を取得します。
getAmountLc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
マニュアル入力による転記金額 (国内通貨)を取得します。
getAmountSv() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
外部入力による販売金額 (国内通貨)を取得します。
getAmountSv() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
外部入力による販売金額 (国内通貨)を取得します。
getAppdBRec() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バッチ製造記録の承認必須を取得します。
getApplicBy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を取得します。
getApplicant() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者を取得します。
getApplicantNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請者番号を取得します。
getApplicantNo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
申請者番号を取得します。
getApplicantPhone() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者の電話番号を取得します。
getApplicatio() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
アプリケーションを取得します。
getApplicatio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
アプリケーションを取得します。
getApplicationDate() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請日を取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getApplobject() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト: アプリケーションオブジェクトを取得します。
getAssNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
割当番号を取得します。
getAssNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産番号を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産番号を取得します。
getAssetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産番号を取得します。
getAssortMod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品揃モジュールを取得します。
getAssortMod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getAssyScrap() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
組立不良率を取得します。
getAtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
割当テーブルの明細番号を取得します。
getAtRelev() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
適当テーブル関連を取得します。
getAtpWrkmod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
ATP セッション: 結果取得/新規決定 APO-ATPを取得します。
getAuthCcNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認番号を取得します。
getAuthDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認日を取得します。
getAuthDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認日を取得します。
getAuthFlag() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 振替権限を取得します。
getAuthFlag() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 振替権限を取得します。
getAuthRefno() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社の権限参照コードを取得します。
getAuthRefno() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社の権限参照コードを取得します。
getAuthTime() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認時刻を取得します。
getAuthTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認時刻を取得します。
getAuthamount() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認額を取得します。
getAuthamount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認額を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
報告書提案済を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
報告書提案済を取得します。
getAuthor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
報告書提案済を取得します。
getAuthoritygroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
権限グループを取得します。
getAutoPOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: "購買発注自動生成"を取得します。
getAutoReset() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予測モデル自動リセットを取得します。
getAvQtyPlt() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントレベル利用可能数量を取得します。
getAvailCheckAllProjSegments() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プロジェクト間品目区分を取得します。
getAvailcheck() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利用可能在庫確認の確認グループを取得します。
getBUomIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードでの基本数量単位を取得します。
getBaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します｡
getBackflush() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バックフラッシュを取得します。
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataInfoList() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
銀行データ情報一覧を取得します｡
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
銀行データ情報を取得します。
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
銀行データ情報を取得します。
getBankDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
銀行データ情報を取得します。
getBankKey() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを取得します｡
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を取得します。
getBankList() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を取得します｡
getBankName() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を取得します｡
getBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して銀行名を取得します。
getBapiReturnErrMessage() - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getBapiReturnErrMessage() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getBapiReturnMessage() - class jp.co.intra_mart.foundation.sap.module.AbstractController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getBapiReturnMessage() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getBarCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
バーコードエントリを取得します。
getBaseQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
基本数量を取得します。
getBaseQtyPlan() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷の能力計画のための基本数量を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
基本数量単位を取得します。
getBaseUom() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
基本数量単位を取得します。
getBaseUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの基本数量単位を取得します。
getBasicLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本明細を取得します。
getBasicMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
主構成物質を取得します。
getBasicValue() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
基準値を取得します。
getBasicValue1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を取得します。
getBasicValue2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を取得します。
getBasicValuePp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の基準値を取得します。
getBasicValuePp1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を取得します。
getBasicValuePp2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を取得します。
getBasicView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
基本データビューを取得します。
getBaslineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替: 基本明細参照を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
ロットを取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ロット番号を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBatch() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ロット番号を取得します。
getBatchMgmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロット管理所要量区分を取得します。
getBatchMgmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロット管理所要量区分を取得します。
getBatchRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ロットの範囲を取得します。
getBatchentry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造/プロセス指図でのロット入力設定を取得します。
getBdcnt() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
5 文字数値 NUMCを取得します。
getBegdemPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見越期間の提案開始日付を取得します。
getBegdemPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBegintime() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
開始時刻を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
エラー処理を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
エラー処理を取得します。
getBehaveWhenError() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
エラー処理を取得します。
getBetaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ベータ係数による傾向値平準化を取得します。
getBidder() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入札者の明細を取得します。
getBidinvNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積管理番号を取得します。
getBilForm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書式を取得します。
getBilForm() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票の請求ブロックを取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ブロックを取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票の請求ブロックを取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求索引および印刷に対する請求日を取得します。
getBillDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票を取得します。
getBillDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票明細を取得します。
getBillOfLading() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫時に登録した B/L 番号を取得します。
getBillOfLadingLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫の船荷証券番号 (依存: テキスト (長) 参照)を取得します。
getBillPlan() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求計画番号を取得します。
getBillPlani() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
明細: 請求計画/支払計画/支払カードを取得します。
getBillRel() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求関連 (CRM)を取得します。
getBillRel() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求日程 (稼働日カレンダ指定)を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求日程 (稼働日カレンダ指定)を取得します。
getBillSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBillTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求先を取得します。
getBillType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求タイプを取得します。
getBillValue() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求金額: 請求計画に請求日付が指定されている場合を取得します。
getBillamount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
請求金額: 請求計画に請求日付が指定されている場合を取得します。
getBillcateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求カテゴリを取得します。
getBillingDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定明細データのテーブルを取得します。
getBillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
請求伝票に関する詳細情報を取得します。
getBillingDocumentDetail() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
請求伝票に関する詳細情報を取得します。
getBillingDocumentDetailListList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票のテーブルを取得します。
getBillingdoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求伝票を取得します。
getBillingdocument() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
処理予定の請求伝票数を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBinaryRelationshiptype() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
バイナリ関連タイプ (専用)を取得します。
getBindgPer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積有効期間を取得します。
getBlanket() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
包括明細を取得します。
getBlockStge() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
平置保管域区分を取得します。
getBomUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BOM 用途を取得します。
getBomexplNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BOM 展開番号を取得します。
getBomexplNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBonGrp1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ1を取得します。
getBonGrp2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 2 (リベート決済、購買)を取得します。
getBonGrp3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 3 (リベート決済、購買)を取得します。
getBrasNbm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Brazilian NCM Codeを取得します。
getBudgetProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
予算プロファイルを取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物 (番号またはコード)を取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物 (番号またはコード)を取得します。
getBuildLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物 (番号またはコード)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
旧: 建物 (番号または略称)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
旧: 建物 (番号または略称)を取得します。
getBuilding() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
旧: 建物 (番号または略称)を取得します。
getBulkMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バルク品目を取得します。
getBusArDes() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を取得します｡
getBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域を指定して事業領域名を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を取得します｡
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
事業領域を取得します。
getBusArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
事業領域を取得します。
getBusAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します｡
getBusTranst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
貿易管理の取引タイプを取得します。
getBusTranst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を取得します。
getBusinessAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を取得します｡
getBusinessTransactionType() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易管理の取引タイプを取得します。
getBuspartno() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
取引先の仕入先マスタコードを取得します。
getBwdCons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 後方を取得します。
getCCardDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定支払方法のテーブルを取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
気付を取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
気付を取得します。
getCOName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
気付を取得します。
getCadId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
CAD 区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
計算区分を取得します。
getCalcMotive() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
計算区分を取得します。
getCalctypcon() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件計算タイプを取得します。
getCalctypcon() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件計算タイプを取得します。
getCalctype() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定タイプを取得します。
getCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
稼動日カレンダを取得します。
getCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
稼動日カレンダを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを取得します。
getCampaign() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCancelled() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
中止区分を取得します。
getCapyUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量使用を取得します。
getCasNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAS 番号： 薬事品目 - 貿易を取得します。
getCashDisc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
現金値引区分を取得します。
getCashDisc1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 1を取得します。
getCashDisc2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 2を取得します。
getCatprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
カタログプロファイルを取得します。
getCbaseId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号 (固定)を取得します。
getCbaseIdType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号タイプ (固定)を取得します。
getCcAuthNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認番号を取得します。
getCcFixed() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸区分固定を取得します。
getCcLocId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: トランザクション (入庫時点)を取得します。
getCcName() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード所有者の氏名を取得します。
getCcName() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード所有者の氏名を取得します。
getCcNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード番号を取得します。
getCcNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード番号を取得します。
getCcPhInv() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸の実地棚卸区分を取得します。
getCcReAmount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
BAPI インタフェースの通貨金額を取得します。
getCcReact() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 権限確認に対する応答を取得します。
getCcReactT() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 結果テキストを取得します。
getCcSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 支払カード - 接尾辞を取得します。
getCcSettled() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済終了を取得します。
getCcStatEx() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 外部システム呼出時のステータスを取得します。
getCcType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カードタイプ: カードタイプを取得します。
getCcType() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カードタイプ: カードタイプを取得します。
getCcValidF() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 使用有効開始日付を取得します。
getCcValidT() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 有効終了日を取得します。
getCcValidT() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 有効終了日を取得します。
getCctrPosted() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価が実際に転記された原価センタを取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件数量単位 (ISO コード)を取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件数量単位 (ISO コード)を取得します。
getCdUntIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件数量単位 (ISO コード)を取得します。
getCertType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
証明書タイプを取得します。
getCfginfo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CU: 選定の BLOB (SCE)を取得します。
getCfopCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extension (old 5 char version)を取得します。
getCfopCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCfopLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extensionを取得します。
getChangeId() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
変更タイプ(U、I、E、D)を取得します。
getChangeNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
変更番号を取得します。
getChangedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクトの変更者名を取得します。
getCharUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
特性の数量単位を取得します。
getCharUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を取得します。
getCharc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性名を取得します。
getCharcTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
言語依存特性テキストを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村ファイルテストステータスを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村ファイルテストステータスを取得します。
getChckstatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村ファイルテストステータスを取得します。
getCheckReturn() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
結果を取得します｡
getCheckReturn() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
結果情報を取得します｡
getCheckRule() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
確認規則を取得します。
getChkprtauth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
取引先権限チェックを取得します。
getChkprtauth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を取得します｡
getCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行コードを指定して市区町村名を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村を取得します。
getCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
市区町村を取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getCityNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの市区町村コードを取得します。
getClIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
レコード番号を取得します｡
getClassType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
クラスタイプを取得します。
getClassType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
クラスタイプを取得します。
getClientData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (クライアントレベル)を取得します。
getClientDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (クライアントレベル)が既に存在するかチェックします。
getClientDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (クライアントレベル)を取得します。
getClosedBox() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
完了した梱包材を取得します。
getCmRelevanceFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
構成管理関連を取得します。
getCmlqtyDat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
累積出荷数量日付を取得します。
getCmlqtyDat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを取得します。
getCmmtItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを取得します。
getCmmtItemLong() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを取得します。
getCntrlInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票タイプに対する管理区分を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を取得します｡
getCoArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
管理領域を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
管理領域を取得します。
getCoArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
管理領域を取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
業務プロセスを取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
業務プロセスを取得します。
getCoBusproc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
業務プロセスを取得します。
getCoCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
会社コードを取得します。
getCoIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
レコード番号を取得します｡
getCoProduct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 連産品としても使用可能な品目を取得します。
getCoProduct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 連産品としても使用可能な品目を取得します。
getCoeffTheil() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
タイル係数を取得します。
getCollNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括番号を取得します。
getCollectNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getComDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認日を取得します。
getComQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認数量を取得します。
getCommCoUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
物品コード (貿易) の数量単位を取得します。
getCommCoUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードによる物品コード (貿易管理) の数量単位を取得します。
getCommCode() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 統計品目コード/輸入コード番号を取得します。
getCommCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 統計品目コード/輸入コード番号を取得します。
getCommGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
手数料グループを取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
通信方法 (キー) (アドレス管理)を取得します。
getCommprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 1を取得します。
getCommprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 2を取得します。
getCommprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法基準評価額: レベル 3を取得します。
getCompCdeB() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求対象会社コードを取得します。
getCompCdeB() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
会社コードを取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
会社コードを取得します｡
getCompCode() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
会社コードを取得します｡
getCompList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します｡
getCompName() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を取得します｡
getCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社コードを指定して会社名を取得します。
getCompQuant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
構成品目数量を取得します。
getCompQuant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCompScrap() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
構成品目不良率を取得します。
getCompShip() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示順守を取得します。
getCompShip() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示順守を取得します。
getCompanyCode() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コード依存データ情報を取得します｡
getCompanyDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社コード依存データ情報を取得します｡
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を取得します。
getCompanyList() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コードを取得します｡
getCompanycode() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
会社コードを取得します。
getCompetitor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
競合会社を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
全購買発注に対する一括納入指定を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括納入区分を取得します。
getComplDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最終確認の有効化を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を取得します。
getComplete() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を取得します。
getCompleted() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ステータス "バージョン完了済"を取得します。
getCompleted() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
ステータス "バージョン完了済"を取得します。
getConExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
基本契約明細の制限を取得します。
getConItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
明細番号、契約を取得します。
getConLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を取得します。
getConNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
基本契約番号を取得します。
getConPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を取得します。
getConbaseval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値を取得します。
getConbaseval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値を取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カウンタを取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタを取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件連続番号を取得します。
getCondCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件カウンタを取得します。
getCondCurr() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件通貨 (累積項目用)を取得します。
getCondDUnt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
伝票の条件単位を取得します。
getCondGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先条件グループを取得します。
getCondHandl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
選択: 条件行処理 (SD 伝票変更)を取得します。
getCondHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件ヘッダ一覧を取得します｡
getCondItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件明細一覧を取得します｡
getCondNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レコード番号を取得します。
getCondNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レコード番号を取得します。
getCondNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
伝票条件番号を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格条件単位を取得します。
getCondPUnt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
価格条件単位を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
ステップ番号を取得します。
getCondStNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
ステップ番号を取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件タイプを取得します。
getCondType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件タイプを取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件単位を取得します。
getCondUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件単位を取得します。
getCondUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件数量単位 (ISO コード)を取得します。
getCondUpdat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件更新を取得します。
getCondUpdat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件更新を取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レートを取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件金額/率を取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レートを取得します。
getCondValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCondchaman() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件 (マニュアル変更済)を取得します。
getCondchaman() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件 (マニュアル変更済)を取得します。
getCondclass() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件クラスを取得します。
getCondclass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件クラスを取得します。
getCondcntrl() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件管理を取得します。
getCondcntrl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件管理を取得します。
getCondcoinhd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタ (ヘッダ条件)を取得します。
getCondconfig() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
システム設定の条件を取得します。
getCondconfig() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
システム設定の条件を取得します。
getCondcount() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件連続番号を取得します。
getCondcount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件連続番号を取得します。
getCondincomp() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
会社間請求の条件を取得します。
getCondincomp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
会社間請求の条件を取得します。
getCondisacti() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
無効条件を取得します。
getCondisacti() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
無効条件を取得します。
getConditemno() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件明細番号を取得します。
getConditionDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定条件のテーブルを取得します。
getConditionNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
伝票条件番号を取得します。
getCondorigin() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件生成区分を取得します。
getCondorigin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件生成区分を取得します。
getCondtype() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
getCondtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を取得します。
getCondvalue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件金額を取得します。
getConexchrat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
現地通貨への換算レートに対する条件を取得します。
getConexchrat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
現地通貨への換算レートに対する条件を取得します。
getConfCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
確認管理キーを取得します。
getConfMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通選定可能品目を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
外部選定 ID (仮)を取得します。
getConfigId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getConfigured() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
選定可能品目を取得します。
getConinvolst() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
請求書一覧条件を取得します。
getConinvolst() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
請求書一覧条件を取得します。
getConpricdat() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件価格設定日付を取得します。
getConpricdat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件価格設定日付を取得します。
getConsValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
消費量を取得します。
getConsValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
消費量を取得します。
getConsistent() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を取得します。
getConsistent() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を取得します。
getConstraintFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了日に対する制約を取得します。
getConstraintFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日付を取得します。
getConstraintFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了時間を取得します。
getConstraintFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測終了時間を取得します。
getConstraintStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を取得します。
getConstraintStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測開始日を取得します。
getConstraintStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始時間の制約を取得します。
getConstraintStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の需要予測開始時間を取得します。
getConstraintTypeFinish() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の終了日に対する制約を取得します。
getConstraintTypeFinishFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動終了の制約条件付き需要予測日付を取得します。
getConstraintTypeStart() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を取得します。
getConstraintTypeStartFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動開始の制約条件付き需要予測日付を取得します。
getConsumctry() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
消費者の国キーを取得します。
getConsummode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費モードを取得します。
getContPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getContainer() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容器条件を取得します。
getContext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
CU: 選定の BLOB (SCE)を取得します。
getContractLimitsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注基本契約制限一覧を取得します｡
getContractServiceAccountList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス勘定設定一覧を取得します｡
getContractServiceList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス一覧を取得します｡
getContractServiceTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービステキスト一覧を取得します｡
getControlKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
管理キーを取得します。
getControllAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域コードを取得します｡
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
管理領域を取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
管理領域を取得します。
getControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
管理領域を取得します。
getControllingAreaCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を取得します。
getControllingAreaList() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を取得します｡
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
管理領域を取得します。
getControllingarea() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
管理領域を取得します。
getConvDen1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分母を取得します。
getConvNum1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分子を取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
変換: 取引先機能 + 受注伝票タイプを取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
取引先機能/受注伝票タイプの変換を取得します。
getConvert() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
変換: 取引先機能 + 受注伝票タイプを取得します。
getConvfactor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目用変換係数を取得します。
getCorrFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 修正係数を需要予測値計算に使用を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
需要予測に対する修正値を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
修正消費量を取得します。
getCorrValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
修正消費量を取得します。
getCostCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します｡
getCostCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを取得します｡
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を取得します。
getCostCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を取得します｡
getCostElem() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
原価要素を取得します。
getCostObj() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価対象を取得します。
getCostObj() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価対象を取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算ビューを取得します。
getCostView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
原価計算ビューを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価センタを取得します。
getCostcenter() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
原価センタを取得します。
getCostingSheet() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価計算表を取得します。
getCostobject() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価対象を取得します。
getCountrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国キー (ISO コード)を取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷国 (商品発送国)を取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
国コードを取得します。
getCountry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを取得します。
getCountryori() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産国を取得します。
getCountryori() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産国を取得します。
getCountryoriIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを取得します。
getCountryoriIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの品目原産国を取得します。
getCovprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫日数プロファイルを取得します。
getCrOn() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード登録日を取得します。
getCreatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード登録日を取得します。
getCreatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
レコード登録日を取得します。
getCreateLoadRecs() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
区分: 生産資源/治工具の負荷レコード登録を取得します。
getCreateLoadRecs() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
区分: 生産資源/治工具の負荷レコード登録を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
登録者名を取得します｡
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクト登録者名を取得します。
getCreatedBy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクト登録者名を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
レコード登録日を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
登録日付を取得します。
getCreatedOn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
レコード登録日を取得します。
getCreationDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード登録日を取得します。
getCreationDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード登録日を取得します。
getCreationTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
登録時刻を取得します。
getCreationTime() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
登録時刻を取得します。
getCreatorDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
取り込まれる日付の順序を取得します。
getCreditorGetDetail() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先マスタ詳細情報を取得します｡
getCreditorid() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードを取得します｡
getCreditorid() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先コードを取得します｡
getCritPart() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 重要品目を取得します。
getCsIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
レコード番号を取得します｡
getCshBdgtProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
資金計画プロファイルを取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ１を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ１を取得します。
getCstcndgrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ２を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ２を取得します。
getCstcndgrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ３を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ３を取得します。
getCstcndgrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ４を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ４を取得します。
getCstcndgrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ５を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ５を取得します。
getCstcndgrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価計算表を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
原価計算表を取得します。
getCstgSheet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効開始日付 (販売契約/品目提案)を取得します。
getCtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効終了日付 (販売契約/品目提案)を取得します。
getCtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCtrlCode() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 消費税の管理コードを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
調達における品質管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達における品質管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具管理の管理キーを取得します。
getCtrlKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具管理の管理キーを取得します。
getCtrlKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
管理キーは変更できませんを取得します。
getCtrlKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
管理キーは変更できませんを取得します。
getCtrlQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
管理数量を取得します。
getCuAmtBase() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を取得します｡
getCuAmtDoccur() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額を取得します｡
getCuCurrency() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを取得します｡
getCuIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を取得します｡
getCuItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号を取得します｡
getCumCfQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積確認数量 (販売数量単位)を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コード通貨を取得します。
getCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コード通貨を取得します。
getCurrIso2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCurrPeriod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当期 (転記期間)を取得します。
getCurrPeriod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期 (転記期間)を取得します。
getCurrPlanPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を取得します。
getCurrenckey() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール通貨を取得します。
getCurrenckey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール通貨を取得します。
getCurrenckeyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
購買発注通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
通貨コードを取得します｡
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
通貨コードを取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票通貨を取得します。
getCurrency() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票通貨を取得します。
getCurrency2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
販売伝票通貨を取得します。
getCurrencyAmountList() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ISO通貨コードを取得します｡
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
ISO コード通貨を取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
ISO 通貨コードを取得します。
getCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
ISO コード通貨を取得します。
getCurreniso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループを取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先グループを取得します。
getCustGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 1を取得します。
getCustGrp1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 2を取得します。
getCustGrp2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 3を取得します。
getCustGrp3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 4を取得します。
getCustGrp4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustGrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 5を取得します。
getCustGrp5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustMat22() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目コード (無効)を取得します。
getCustMat22() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustMat35() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目を取得します。
getCustMat35() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先コード1を取得します｡
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
得意先コードを取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
得意先コードを取得します。
getCustomerNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先コードを取得します。
getCustoms() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
税関: 税関 (出国時)を取得します。
getCvalueFxd() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
区分: 消費金額の確定を取得します。
getCycleTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タクトタイムを取得します。
getDToRefM() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照の有効終了日を取得します。
getDataIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
別の構成のテーブル入力へのポインタを取得します。
getDataorigin() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 入力モードを取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
起算日を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
起算日を取得します。
getDate() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
日付を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
提案日付タイプを取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
日付タイプ (日、週、月、期間)を取得します。
getDateType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDateWorkBegins() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業開始を取得します。
getDateWorkEnds() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業終了を取得します。
getDeIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
レコード番号を取得します｡
getDebtorGetDetail() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先マスタ詳細情報を取得します｡
getDebtorid() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードを取得します｡
getDebtorid() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先コードを取得します｡
getDecForRounding() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
小数点位置 (その位置まで丸める)を取得します。
getDecForRoundingX() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDeclStatFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 仕入先申告ありを取得します。
getDelDatcatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日カテゴリを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
クライアントレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
区分: 流通チャネルレベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの品目削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管タイプに該当する全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプに該当する全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
WM 倉庫内の全品目データ削除フラグを取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDelFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
データレコード削除 (テーブル繰返し)を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票の削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
削除フラグ: 購買伝票勘定設定を取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
削除フラグを取得します｡
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の削除フラグを取得します。
getDeleteInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
削除フラグを取得します。
getDeletionFlag() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
削除フラグを取得します。
getDelivCompl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出荷完了 区分を取得します。
getDelivDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入期日を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
郵便配達地域を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
郵便配達地域を取得します。
getDelivDis() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
郵便配達地域を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を取得します。
getDelivItem() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷明細を取得します。
getDelivItemToSearch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を取得します。
getDelivNumb() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷伝票を取得します。
getDelivNumbToSearch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を取得します。
getDelivTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日における指定時間を取得します。
getDeliverryAddressList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出荷伝票アドレス一覧を取得します｡
getDeliveryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日を取得します。
getDelkz() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
MRP 要素区分を取得します。
getDeltaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デルタ係数使用による MAD (絶対平均偏差) 平準化を取得します。
getDelyUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷単位を取得します。
getDelyUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷数量単位を取得します。
getDelyUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードでの出荷単位の数量単位を取得します。
getDelygPlnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷プラントを取得します。
getDenominato() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分母を取得します。
getDenominato() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分母を取得します。
getDenominatr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
分母: 基本数量単位へ変換する場合を取得します。
getDepReqId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
個別所要量と包括所要量に対する従属所要量区分を取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
部門コードを取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
部門コードを取得します。
getDepartmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDepartment() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
部署を取得します。
getDepcountry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国 (商品発送国)を取得します。
getDepcountryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国の ISO コードを取得します。
getDeployHoriz() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給分配期間の日数を取得します。
getDeprecPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理に関する償却率 (%)を取得します。
getDeprecPer() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDescrHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
終了品目テキストを取得します。
getDescrLow() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
開始品目テキストを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを取得します｡
getDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定してテキストを取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
テキスト (30 文字)を取得します。
getDescript() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループテキスト (短)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業テキスト (短)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
PS: テキスト(短)(第一テキスト行)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
テキストを取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
PS: テキスト(短)(第一テキスト行)を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンテキスト（長）を取得します。
getDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンテキスト（長）を取得します。
getDetermGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫決定グループを取得します。
getDevalInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
低価法: 評価減区分を取得します。
getDialogflag() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
区分 (X = 利用不可 /N = 確認なし)を取得します。
getDiffInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先と請求元が異なる場合の供給元のコードを取得します｡
getDiscontinu() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
打切区分を取得します。
getDispQuan() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注数量: 表示目的全納入日程合計を取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
流通チャネルを取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDistrChan() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
流通チャネルを取得します。
getDistrChanHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲終了を取得します。
getDistrChanLow() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲開始を取得します。
getDistrPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
配賦率 % (複数勘定設定)を取得します。
getDistrProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サイトの商品の物流プロファイルを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrctNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの所在地コードを取得します。
getDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
複数勘定設定の配賦区分を取得します。
getDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
複数勘定設定の配賦区分を取得します。
getDistributingKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を取得します。
getDistributionChannelSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
流通チャネルの選択オプション一覧を取得します｡
getDistributionchannel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
流通チャネルを取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
所在地を取得します。
getDistrict() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
所在地を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品部門を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDivision() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
製品部門を取得します。
getDliProfil() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
動的明細プロセッサプロファイルを取得します。
getDliProfil() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvBlock() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷ブロック (伝票ヘッダ)を取得します。
getDlvDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を取得します。
getDlvDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷グループ (明細一括出荷)を取得します。
getDlvGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷優先順位を取得します。
getDlvPrio() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷数量実績 (販売単位)を取得します。
getDlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷数量実績 (販売単位)を取得します。
getDlvStatH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
全明細の出荷ステータスを取得します。
getDlvStatI() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
明細の全体出荷ステータスを取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
契約出荷期間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
契約出荷期間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を取得します。
getDlvTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードでの出荷単位の数量単位を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
用途区分を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
用途区分を取得します。
getDlvschduse() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocAcDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号を取得します｡
getDocCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票カテゴリを取得します。
getDocChgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書変更番号 (文書管理システム外)を取得します。
getDocClass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
リリースおよびトランザクション管理を備えた元システムを取得します。
getDocClass() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードを取得します｡
getDocCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
伝票条件番号を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票日付を取得します｡
getDocDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の伝票日付を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票日付 (受信日/送信日)を取得します。
getDocDocDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付を取得します｡
getDocDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプを取得します｡
getDocFisPeriod() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間を取得します｡
getDocFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度を取得します｡
getDocFormat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書のページ書式 (文書管理システムによらない)を取得します。
getDocHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストを取得します｡
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ドキュメンタリクレジット処理: 内部番号を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理: 内部番号を取得します。
getDocNumFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるオブジェクト番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
伝票番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売管理伝票番号を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票を取得します。
getDocNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票を取得します。
getDocObjKey() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーを取得します｡
getDocObjType() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理を取得します｡
getDocPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付を取得します｡
getDocRefDocNo() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号を取得します｡
getDocReqd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
文書必須フラグを取得します。
getDocStatus() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票ステータスを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票カテゴリを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票タイプを取得します｡
getDocType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書タイプ (文書管理システムによらない)を取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票タイプを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票タイプを取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDocType() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票タイプを取得します。
getDocUsername() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名を取得します｡
getDocVers() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書バージョン (文書管理システムによらない)を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票年度を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票年度を取得します。
getDocYear() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票年度を取得します。
getDocument() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書番号 (文書管理システムによらない)を取得します。
getDocumentDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
登録日付を取得します。
getDocumentDateTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
入力日付 (以前/以降)を取得します。
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを取得します｡
getDocumentHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票ヘッダを取得します｡
getDontUseP() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所配達不可フラグを取得します。
getDontUseS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名住所配達不可フラグを取得します。
getDown() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getDscnt1To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数1を取得します｡
getDscnt2To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数2を取得します｡
getDscnt3To() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数3を取得します｡
getDsctPct1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 1を取得します。
getDsctPct2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 2を取得します。
getDsnOffice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
研究室/設計室を取得します。
getDunCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先商談回数を取得します。
getDunCount() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先との前回の商談日を取得します。
getDunDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理保留を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理保留を取得します。
getDunnBlock() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理キーを取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理キーを取得します。
getDunnKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getDurationConfirmFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測活動期間を取得します。
getDurationConfirmFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測期間単位を取得します。
getDurationConfirmFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationMinimum() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短活動期間を取得します。
getDurationMinimumFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の最小期間(需要予測より)を取得します。
getDurationMinimumFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測最短期間の単位を取得します。
getDurationMinimumFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationMinimumUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短期間の単位を取得します。
getDurationMinimumUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationNormal() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間を取得します。
getDurationNormalFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間 (予測)を取得します。
getDurationNormalFcUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準予測期間の単位を取得します。
getDurationNormalFcUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationNormalUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準期間/単位を取得します。
getDurationNormalUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getDurationScheduled() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間を取得します。
getDurationScheduledFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間の長さ (予測値)を取得します。
getDurationScheduledUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間単位を取得します。
getDurationScheduledUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
電子メールアドレスを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
電子メールアドレスを取得します。
getEMail() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
電子メールアドレスを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanCat() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN) のカテゴリを取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
国際商品コード (EAN/UPC)を取得します。
getEanUpc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getEarlyFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (日)を取得します。
getEarlyFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了日 (予測)を取得します。
getEarlyFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (時刻)を取得します。
getEarlyFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了時間(需要予測)を取得します。
getEarlyStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 実行 (日)を取得します。
getEarlyStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始日付(需要予測)を取得します。
getEarlyStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 作業実施(時間)を取得します。
getEarlyStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始時間(需要予測)を取得します。
getEarnedValueIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗分析関連のマイルストーンを取得します。
getEdition() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのバージョンを取得します。
getEdition() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのバージョンを取得します。
getEffODay() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
有効終了日を取得します。
getEiIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
レコード番号を取得します｡
getEmaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードを取得します。
getEmaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コード（長）を取得します。
getEmaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードの外部GUIDを取得します。
getEmaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードのバージョン番号を取得します。
getEndOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途の終了オフセットを取得します。
getEndOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途の終了オフセットを取得します。
getEndOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了オフセットは変更できませんを取得します。
getEndOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了オフセットは変更できませんを取得します。
getEndOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了オフセット単位を取得します。
getEndOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了オフセット単位を取得します。
getEndOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
getEndOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を取得します。
getEndRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了日の参照日付を取得します。
getEndRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了日の参照日付を取得します。
getEndRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了参照日付は変更できませんを取得します。
getEndRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了参照日付は変更できませんを取得します。
getEndleadtme() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
補充リードタイムの終了日付を取得します。
getEndtime() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
終了時刻を取得します。
getEntryDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
会計伝票登録日を取得します。
getEntryQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位での数量を取得します。
getEntryQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位での数量を取得します。
getEntryTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
登録時刻を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位を取得します。
getEntryUom() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位を取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを取得します。
getEntryUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getEnvtRlvt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 環境関連を取得します。
getEquipment() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備番号を取得します。
getEquityType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
持分タイプを取得します。
getEquityType() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
持分タイプを取得します。
getErrorTotal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
エラー合計を取得します。
getErrorTotalPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間のエラー合計を取得します。
getErrorsList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
前明細の不正処理に関する情報を取得します。
getErs() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ERS（入庫/請求自動決済）を取得します。
getEstPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
概算価格区分を取得します。
getEstimatedCosts() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図の見積原価合計を取得します。
getEuListNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAP: CAP 製品一覧番号を取得します。
getEuMatGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
EEC 農産物政策: CAP 生産品グループ - 貿易を取得します。
getEutriDeal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
フラグ: EC 内三角取引を取得します。
getEutriDeal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getEventual() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
偶発的明細を取得します。
getExCertDt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書発行日を取得します。
getExCertId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
法令管理: 認定書区分を取得します。
getExCertNoNew() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書番号 - 法令管理を取得します。
getExIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
レコード番号を取得します｡
getExRateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (直接相場)を取得します。
getExRateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExRateFx() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レート固定区分を取得します｡
getExceptList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
例外メッセージバーを取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
直接呼び値換算レートを取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レート、係数 (通貨ペア)を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レート、係数 (通貨ペア)を取得します。
getExchRate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レートを取得します｡
getExchRateCm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
間接呼び値換算レートを取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (間接相場)を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (間接相場)を取得します。
getExchRateFiV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchRateV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
間接呼び値換算レートを取得します。
getExchangeRate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/統計用換算レートを取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (直接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExchgRateV() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (間接引用)を取得します。
getExpActivityList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
活動に関する詳細情報を取得します。
getExpActivityList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
活動に関する詳細情報を取得します。
getExpMessageList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を読み込みエラーを取得します。
getExpMessageList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を読み込みエラーを取得します。
getExpValue() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
見込金額を取得します。
getExpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 要素についての詳細情報を取得します。
getExpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 要素についての詳細情報を取得します。
getExpWbsHierarchieList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 階層についての情報を取得します。
getExpWbsHierarchieList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 階層についての情報を取得します。
getExpWbsMilestoneList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS マイルストーンに関する詳細情報を取得します。
getExpWbsMilestoneList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS マイルストーンに関する詳細情報を取得します。
getExpimpNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
貿易データ番号: MM/SD 伝票を取得します。
getExpimpgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
輸出/輸入品目グループを取得します。
getExpirydate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
有効期間期限日を取得します。
getExpirydate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
有効期間期限日を取得します。
getExportHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理ヘッダを取得します｡
getExportImportProcedure() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易の輸出入手続を取得します。
getExportItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理明細一覧を取得します｡
getExportNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
貿易データ番号: MM/SD 伝票を取得します。
getExpostPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
事後的需要予測に含む履歴値の数を取得します。
getExpostVal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
事後的需要予測値を取得します。
getExrateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (直接相場)を取得します。
getExrateFi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getExtLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
明細番号を取得します。
getExtOrdNo() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
外部指図番号を取得します。
getExtServ() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
仕入先のサービス番号を取得します。
getExtWms() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
外部倉庫管理の転記の制御を取得します。
getExtensionIn(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造が既に存在するか チェックします。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を取得します。
getExtensionInX(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
拡張イン/拡張アウトのチェックボックス構造が既に存在するかチェックします。
getExtensionInXList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
拡張イン/拡張アウトのチェックボックス構造を取得します。
getExtensionList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
拡張得意先項目一覧を取得します｡
getExtensionOut(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造オブジェクトが既に 存在するかチェックします。
getExtensionOutList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を取得します。
getExternalObjectId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 外部対象キーを取得します。
getExtmatlgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
外部品目グループを取得します。
getExtpersNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
外部従業員番号を取得します。
getExtrefkey() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスの外部参照キーを取得します。
getFactbasval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値に対する要因を取得します。
getFactbasval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値に対する要因を取得します。
getFactconbas() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基準の係数 (期間)を取得します。
getFactor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件の加重係数を取得します。
getFactoryCalendar() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
稼働日カレンダを取得します。
getFairShareRule() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
均等配賦ルールを取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: 内線を取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: 内線を取得します。
getFaxExtens() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: 内線を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: ダイヤルコード + 番号を取得します。
getFaxNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
FAX 番号を取得します。
getField() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの項目を取得します。
getFieldname() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
項目名を取得します。
getFijCurCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期標準原価見積の会計年度を取得します。
getFijFutCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積の会計年度を取得します。
getFijPreCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準原価見積の会計年度を取得します。
getFillLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最大レベル (容積別)を取得します。
getFinalInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書処理完了区分を取得します。
getFinish() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトの計画終了日を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
値参照期間の第一日目を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
値参照期間の第一日目を取得します。
getFirstDay() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
値参照期間の第一日目を取得します。
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当会計年度を取得します。
getFiscYear() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当会計年度を取得します。
getFixLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要供給の一致に対する固定ロットサイズを取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日日付を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日日付を取得します。
getFixValDy() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixdatQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
納期と出荷数量の固定を取得します。
getFixdatQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFixedLot() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定ロットサイズを取得します。
getFixedMilestoneDateBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン日付(基準)を取得します。
getFixedMilestoneDateForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定日付を取得します。
getFixedMilestoneTimeBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン時間(基準)を取得します。
getFixedMilestoneTimeForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定時間 (F)を取得します。
getFixedPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
固定期間を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量固定区分を取得します。
getFixedQuan() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
長さ 12 の文字項目を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
長さ 12 の文字項目を取得します。
getFkkConacct() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFlagCadCall() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
CAD システムからコールを取得します。
getFlexibleDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: 可変期間を取得します。
getFloatFree() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕を取得します。
getFloatFreeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕 (予測)を取得します。
getFloatTotal() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計を取得します。
getFloatTotalFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計 (予測)を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物の階を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物の階を取得します。
getFloor() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物の階を取得します。
getFollowUp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
フォローアップ品目を取得します。
getFollowUpExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を取得します。
getFollowUpGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を取得します。
getFollowUpVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を取得します。
getForeDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最終需要予測日を取得します。
getForeModel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測モデルを取得します。
getForePds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測期間を取得します。
getForeProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測プロファイルを取得します。
getForeValue() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
予測値を取得します。
getForecFlowCont() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測フロー管理を取得します。
getForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日を取得します。
getForecastParameters() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
予測パラメータを取得します。
getForecastParametersList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
需要予測パラメータが既に存在するかチェックします。
getForecastParametersList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測パラメータを取得します。
getForecastValues(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
需要予測値のデータ転送が既に存在するかチェックします。
getForecastValuesList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測値のデータ転送を取得します。
getForecastView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要予測ビューを取得します。
getForecastView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
需要予測ビューを取得します。
getFormVal1() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal2() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal3() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal4() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormVal5() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
タグ列を取得します。
getFormatCol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
タグ列を取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
敬称テキストを取得します。
getFormofaddr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
敬称テキストを取得します。
getFormula() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式番号を取得します。
getFormulaTotQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の合計数量の計算式を取得します。
getFormulaTotQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の合計数量の計算式を取得します。
getFormulaTotQtyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
合計数量の計算式は変更できませんを取得します。
getFormulaTotQtyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
合計数量の計算式は変更できませんを取得します。
getFormulaTotUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の総用途値の計算式を取得します。
getFormulaTotUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の総用途値の計算式を取得します。
getFormulaTotUsageNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
すべての用途値を計算する計算式は変更できませんを取得します。
getFormulaTotUsageNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
すべての用途値を計算する計算式は変更できませんを取得します。
getFreeItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
無償明細を取得します。
getFreeLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
自由制限を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前通貨を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算前通貨を取得します。
getFromCurr() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算前通貨を取得します。
getFromFactor() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を取得します。
getFromFactorV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を取得します。
getFromLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
下限を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を取得します。
getFuncArea() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を取得します。
getFuncAreaLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
BAPI 機能を取得します。
getFunction() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
機能を取得します。
getFunctionalLocation() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能場所を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
会計区分を取得します。
getFund() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
会計区分を取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
予算センタを取得します。
getFundsCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
予算センタを取得します。
getFuturePr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
次期標準原価を取得します。
getFwdCons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 前方を取得します。
getFxdPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定価格連産品を取得します。
getFyVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
会計年度バリアントを取得します。
getFyVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計年度バリアントを取得します。
getGammaFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ガンマ係数使用の平滑化のための季節指数を取得します。
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
一般データ情報を取得します｡
getGeneralDataInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
一般データ情報を取得します｡
getGiDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫日付を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫日付を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGiDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出庫日付を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫時刻 (現地時間 - プラント参照)を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫時刻 (現地時間 - プラント参照)を取得します。
getGiTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定項目情報一覧を取得します。
getGlAccList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目情報一覧を取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを取得します｡
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
G/L 勘定コードを取得します。
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
G/L 勘定コードを取得します。
getGlAccount() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
G/L 勘定コードを取得します。
getGlAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーを取得します｡
getGlBusArea() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域を取得します｡
getGlCompCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードを取得します｡
getGlCostcenter() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタを取得します｡
getGlDocType() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプを取得します｡
getGlFiscYear() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度を取得します｡
getGlGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を取得します｡
getGlIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
レコード番号を設定します｡
getGlItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストを取得します｡
getGlItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号を取得します｡
getGlList() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を取得します｡
getGlOrderid() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号を取得します｡
getGlPstngDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付を取得します｡
getGlRefKey1() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーを取得します｡
getGlTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードを取得します｡
getGlWbsElement() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素を取得します｡
getGmCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
BAPI 在庫移動トランザクションのコード割当を取得します。
getGoodsMvtCode() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動に対するコードのトランザクションへの割当を取得します。
getGoodsMvtHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票ヘッダデータを取得します。
getGoodsMvtHeaderList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票ヘッダを取得します。
getGoodsMvtHeadret() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号/入出庫伝票会計年度を取得します。
getGoodsMvtItemList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票明細を取得します。
getGoodsMvtItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票明細を取得します。
getGoodsMvtSerialNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
シリアル番号を取得します。
getGrBasediv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫基準の請求書照合区分を取得します。
getGrGiSlipNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票番号を取得します。
getGrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫区分を取得します。
getGrMessage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
入庫メッセージ区分を取得します｡
getGrNonVal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
非評価入庫を取得します。
getGrNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫番号を取得します。
getGrPrTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫処理日数を取得します。
getGrPrTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
入庫処理日数を取得します。
getGrPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基準額を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
受領者を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受領者を取得します。
getGrRcpt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受領者を取得します。
getGrRcptx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGrToDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
納入最終期限を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
補助金を取得します。
getGrantNbr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
補助金を取得します。
getGroValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
総額を取得します。
getGrossWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総重量を取得します。
getGrossWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getGrossWt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
総重量を取得します。
getGrossWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
総重量を取得します。
getGroupcond() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
グループ条件区分を取得します。
getGroupcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
グループ条件区分を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループ名を取得します。
getGroupname() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
グループ名を取得します。
getGrpKey1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 1を取得します。
getGrpKey1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 1を取得します。
getGrpKey2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 2を取得します。
getGrpKey2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 2を取得します。
getGrpReqmts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 所要量グループ化を取得します。
getGtinVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
グローバルトレード明細番号バリアントを取得します。
getGtinVariant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
グローバルトレード明細番号バリアントを取得します。
getHCurr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通貨コードを取得します。
getHCurr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getHCurrIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO 通貨コードを取得します。
getHandlgGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ワークロード計算のロジスティクス処理グループを取得します。
getHazMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物コードを取得します。
getHazMatNoExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
getHazMatNoGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
getHazMatNoVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
getHazmatprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物インジケータプロファイルを取得します。
getHeadData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
管理情報設定ヘッダセグメントが既に存在するかチェックします。
getHeadDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
管理情報設定ヘッダセグメントを取得します。
getHeaderTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
ヘッダテキスト一覧を取得します｡
getHeaderTxt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票ヘッダテキストを取得します。
getHeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
高さを取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
BOM 構成の上位レベル明細を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細を取得します。
getHgLvItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getHiLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上位階層明細番号を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層ノード一覧を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層ノード一覧を取得します。
getHierarchyNodesList() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層ノード一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層値一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層値一覧を取得します。
getHierarchyValuesList() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層値一覧を取得します。
getHierlevel() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層のエントリレベルを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を取得します。
getHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを取得します。
getHighVisc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 高粘性を取得します。
getHistVals() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
履歴値の数を取得します。
getHlItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買伝票中の上位明細を取得します。
getHold() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買発注の不完全を取得します。
getHomeCity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村 (郵便用市区町村と異なる場合)を取得します。
getHomecityno() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
別の市区町村 (市区町村/地名ファイル)を取得します。
getHomepage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
URI 例: ホームページ、FTP アドレスを取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地-号を取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地-号を取得します。
getHouseNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地-号を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地補足を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地補足を取得します。
getHouseNo2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地補足を取得します。
getHouseNo3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地範囲を取得します。
getId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージクラスを取得します。
getId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージクラスを取得します。
getImpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を必要とする WBS 要素を取得します。
getImpWbsElementList() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を必要とする WBS 要素を取得します。
getInCharge() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を取得します｡
getInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して利益センタ責任者を取得します。
getInHouse() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
内部生産を取得します。
getInHouse() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
内部生産を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ1を取得します｡
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ (1)を取得します。
getIncoterms1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ2を取得します｡
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (2)を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ 2を取得します。
getIncoterms2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIndPostToInspStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質検査中在庫への転記を取得します。
getIndProposeQuanx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
提案数量 (初期数量)を取得します。
getIndSector() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
産業コードを取得します。
getIndSector() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
産業コードを取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のメソッド
レコード番号を取得します。
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード番号を取得します｡
getIndex() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード番号を取得します｡
getIndus3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目 CFOP カテゴリを取得します。
getInfIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数を取得します。
getInfoRec() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買情報番号を取得します。
getInfoRec() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買情報番号を取得します。
getInfoUpd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買情報更新区分を取得します。
getInform() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
情報行を取得します。
getInhseprodt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
内製日数を取得します。
getInitPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化で使用する履歴値の数を取得します。
getInitialize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化区分を取得します。
getInpfldcheck() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
項目無効時の応答を取得します。
getInquiryCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getInquiryCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: インスタンスを取得します。
getInquiryCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 部分設定を取得します。
getInquiryCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照明細/インスタンスを取得します。
getInquiryCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照データを取得します。
getInquiryCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 特性値を取得します。
getInquiryCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: バリアント条件キーを取得します。
getInquiryConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
条件を取得します。
getInquiryConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
受注における条件更新の通信項目を取得します。
getInquiryHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票ヘッダデータを取得します。
getInquiryHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
ヘッダデータチェックボックスを取得します。
getInquiryItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データを取得します。
getInquiryItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データチェックボックスを取得します。
getInquiryKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
参照キーの出力テーブルを取得します。
getInquiryPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
伝票取引先を取得します。
getInquirySchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行を取得します。
getInquirySchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行チェックボックスを取得します。
getInquiryTextList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テキストを取得します。
getInspInt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
次回再検査までの間隔を取得します。
getInspSetupFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目/プラントに QM 検査データ設定を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選定におけるインスタンス番号を取得します。
getInstId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細番号内部採番を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細番号内部採番を取得します。
getIntNumberAssignment() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細番号内部採番を取得します。
getIntObjNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
選定 (内部オブジェクト番号)を取得します。
getIntProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getIntProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getInterestProf() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プロジェクト/指図金利計算の金利プロファイルを取得します。
getInternalChar() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
内部特性を取得します。
getInternalObjectId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 内部対象キーを取得します。
getInternationArticleNumbers(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
EANオブジェクトが既に存在するかチェックします。
getInternationArticleNumbersList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANを取得します。
getInternationalArtnos(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
国際商品コード (EAN)が既に存在するかチェックします。
getInternationalArtnosList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
国際商品コード (EAN)を取得します。
getInterop() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
移動時間を取得します。
getInvCorrFac() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
在庫修正係数を取得します。
getInvMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
会社固有 (内部) 在庫管理品目コードを取得します。
getInvMatNoExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を取得します。
getInvMatNoGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を取得します。
getInvMatNoVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を取得します。
getInvestProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備投資案件プロファイルを取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を取得します。
getInvoSched() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getInvoicePercentage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
請求金額率 (%)を取得します。
getIrInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書受領区分を取得します。
getIsoUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
単位の ISO コードを取得します。
getIssStLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫保管場所を取得します。
getIssueUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫単位を取得します。
getIssueUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの出庫単位を取得します。
getItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始明細を取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の明細カテゴリを取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
一般明細カテゴリグループを取得します。
getItemCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目マスタの明細カテゴリグループを取得します。
getItemCatExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票の明細カテゴリを取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
明細カテゴリ (販売伝票)を取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細カテゴリ (販売伝票)を取得します。
getItemCateg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getItemIntvl() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
明細番号間隔を取得します｡
getItemNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理オブジェクト: 明細を取得します。
getItemText() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
明細テキストを取得します。
getItemText() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
明細テキストを取得します。
getItemTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細テキスト一覧を取得します｡
getItemguidAtp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ATP: 暗号 - DELNR および DELPSを取得します。
getItemguidAtp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getItemsForRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
区分: 承認待ち購買発注のみ照会を取得します。
getItemsForRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
区分: 承認待ち購買発注のみ照会を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件明細番号を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
明細番号 (販売管理伝票)を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票明細を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
明細番号 (販売管理伝票)を取得します。
getItmNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票明細を取得します。
getItmTypeUsage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細用途を取得します。
getItmTypeUsage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getJitRelvt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: JIT 納入日程の関連明細を取得します。
getJointVenture() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャを取得します。
getJointVenture() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャを取得します。
getJvJibClass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE クラスを取得します。
getJvJibClass() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE クラスを取得します。
getJvJibSubClassA() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE サブクラスAを取得します。
getJvJibSubClassA() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE サブクラスAを取得します。
getJvObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャ対象タイプを取得します。
getJvObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャ対象タイプを取得します。
getKanbanInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
かんばん区分を取得します。
getKblanguage() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
システム設定の言語を取得します。
getKbname() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースオブジェクトを取得します。
getKbprofile() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースプロファイルを取得します。
getKbversion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
SCE ナレッジベースの実行時バージョンを取得します。
getLEquip1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1を取得します。
getLEquip2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2を取得します。
getLEquip3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3を取得します。
getLabelForm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベル書式を取得します。
getLabelType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベルタイプを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
言語キーを取得します。
getLangu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
言語キーを取得します。
getLanguCr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスレコード登録オリジナル言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーの ISO コードを取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
ISO 639 準拠の言語を取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
ISO 639 準拠の言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ステータスおよび業務トランザクションテキストの言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ステータスおよび業務トランザクションテキストの言語を取得します。
getLanguage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
言語キーを取得します。
getLangucriso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を取得します。
getLastChnge() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最終変更日付を取得します。
getLastItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
最終明細番号を取得します。
getLatestDatesIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: 最遅日を取得します。
getLatestFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(日付)を取得します。
getLatestFinishDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済終了日付(需要予測)を取得します。
getLatestFinishTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(時間)を取得します。
getLatestFinishTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画終了時間 (予測)を取得します。
getLatestStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(日付)を取得します。
getLatestStartDateFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始日付(需要予測)を取得します。
getLatestStartTime() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(時間)を取得します。
getLatestStartTimeFc() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始時間(需要予測)を取得します。
getLeadinguom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
主要ロット特定数量単位を取得します。
getLeft() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getLength() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
長さを取得します。
getLeqUnit1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1 の数量単位を取得します。
getLeqUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 1 の数量単位を取得します。
getLeqUnit2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2 の数量単位を取得します。
getLeqUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 2 の数量単位を取得します。
getLeqUnit3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3 の数量単位を取得します。
getLeqUnit3Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 3 の数量単位を取得します。
getLiIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
レコード番号を取得します｡
getLifoFifo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO/FIFO 関連を取得します。
getLifoValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 関連品目データを取得します。
getLifoValuationLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価レベルを取得します。
getLifovaluationlevel() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 評価レベルを取得します。
getLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
全体制限を取得します。
getLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
全体制限を取得します。
getLimitLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画外、明細制限を取得します。
getLimitsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注制限一覧を取得します｡
getLineDepth() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票での明細行階層レベルを取得します。
getLineDepth() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票での明細行階層レベルを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票明細行の一意 IDを取得します。
getLineId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票明細行の一意 IDを取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限の内部明細番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
内部明細番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細行番号を取得します。
getLineNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
内部明細番号を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載日付を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載日付を取得します。
getLoadDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載時刻 (現地時間: 出荷ポイント)を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載時刻 (現地時間: 出荷ポイント)を取得します。
getLoadTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLoadinggrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
積載グループを取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
場所を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 5を取得します。
getLocation() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 5を取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: メッセージシリアル番号を取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: メッセージシリアル番号を取得します。
getLogNo() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: ログ番号を取得します。
getLogNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: ログ番号を取得します。
getLogSystem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
論理システムを取得します。
getLogSystemOwn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを取得します。
getLogSystemOwn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
内部制御パラメータを取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
内部制御パラメータを取得します。
getLogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
内部制御パラメータを取得します。
getLogsystem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
論理システムを取得します｡
getLongText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を取得します｡
getLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定して総勘定元帳勘定テキスト(長)を取得します。
getLooseorliq() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バルク/液体を取得します。
getLotIncrement() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるためのロットサイズ増分を取得します。
getLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ロットサイズを取得します。
getLotsizekey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロットサイズ (品目計画)を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を取得します。
getLow() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを取得します。
getMainEan() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
区分: 主要 EANを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
更新ステータスを取得します。
getMaintStat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
更新ステータスを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者製品コードを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品コードを取得します。
getManuMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品コードを取得します。
getManufProf() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品プロファイルを取得します。
getManufProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品プロファイルを取得します。
getManufacturerPartNumbList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
製造業者と製造者製品コード一覧を取得します｡
getMaskId() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 要素 ID(短)の選択マスクを取得します。
getMastCond() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
期間依存条件伝票を取得します。
getMastContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
グループマスタ契約番号を取得します。
getMastContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMasterData() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図のマスタデータ構造を取得します。
getMasterData() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図のマスタデータ構造を取得します。
getMatCfop() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目 CFOP カテゴリを取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票番号を取得します。
getMatDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票番号を取得します。
getMatEntrd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入力品目を取得します。
getMatEntrd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMatGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目グループを取得します。
getMatGrpSm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループ: 梱包材を取得します。
getMatGrpTrans() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取替えマトリクスに対する品目のグループを取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMatOrigin() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の原産地を取得します。
getMatOrigin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の原産地を取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目価格設定グループを取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目価格設定グループを取得します。
getMatPrGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目更新完了ステータスを取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMatcmpllvl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目完了レベルを取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票の明細を取得します。
getMatdocItm() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
入出庫伝票の明細を取得します。
getMatdocTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求の入出庫伝票番号を取得します。
getMatdocumentyear() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票会計年度を取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
品目コードを取得します｡
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
品目コードを取得します。
getMaterial() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
品目コードを取得します。
getMaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
品目テキストオブジェクトが既に存在するかチェックします。
getMaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目テキストが既に存在するかチェックします。
getMaterialDescriptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストを取得します。
getMaterialDescriptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目テキストを取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コード（長）を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の品目コード (長)を取得します｡
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialExternal() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を取得します。
getMaterialFixed() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロックされている品目を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードの外部GUIDを取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の外部 GUIDを取得します｡
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialGuid() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を取得します。
getMaterialLongText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
テキスト (長)が既に存在するかチェックします。
getMaterialLongTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
テキスト (長)を取得します。
getMaterialRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
品目コードの範囲を取得します。
getMaterialShortDescselList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目テキストの選択オプション一覧を取得します｡
getMaterialText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
テキスト (長)オブジェクトが既に存在するかチェックします。
getMaterialTextList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードのバージョン番号を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL のバージョン番号を取得します｡
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialVersion() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を取得します。
getMaterialdocument() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号を取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目運賃グループを取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目運賃グループを取得します。
getMatfrgtgrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatitemTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送数量入出庫伝票明細を取得します。
getMatlDesc() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目テキストを取得します。
getMatlDesc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目テキストを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループを取得します。
getMatlGroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMatlGrp1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 1を取得します。
getMatlGrp2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 2を取得します。
getMatlGrp3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 3を取得します。
getMatlGrp4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 4を取得します。
getMatlGrp5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 5を取得します。
getMatlStats() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目統計グループを取得します。
getMatlType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目タイプを取得します。
getMatlType() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目タイプを取得します。
getMatlUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の用途を取得します。
getMatlUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の用途を取得します。
getMatnrHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
終了品目コードを取得します。
getMatnrListList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードと品目テキストの一覧を取得します｡
getMatnrLow() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
開始品目コードを取得します。
getMatnrSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードの選択オプション一覧を取得します｡
getMatyearTrCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求入出庫伝票年度を取得します。
getMaxLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最大ロットサイズを取得します。
getMaxPlDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細ごとの分割納入可能な最大回数を取得します。
getMaxPlDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxRows() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
選択予定品目の最大数を取得します｡
getMaxSbQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最大棚番在庫数量を取得します。
getMaxStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大在庫レベルを取得します。
getMaxdevDay() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
シフト所要日数を取得します。
getMaxdevDay() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxdevamnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (絶対値)を取得します。
getMaxdevamnt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxdevper() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (%)を取得します。
getMaxdevper() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMaxlotsize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大ロットサイズを取得します。
getMeAnzSub() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位数を取得します。
getMeanAbsolDev() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
絶対平均偏差 (MAD)を取得します。
getMeanAbsolDevPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の平均絶対偏差を取得します。
getMemoryComplete() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがない場合に購買発注を保留にする区分を取得します｡
getMemoryUnComplete() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがある場合に購買発注を保留にする区分を取得します｡
getMerchidcl() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社のマーチャント IDを取得します。
getMerchidcl() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社のマーチャント IDを取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージテキストを取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージテキストを取得します。
getMessageId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージ IDを取得します。
getMessageNumber() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
システムメッセージ番号を取得します。
getMessageText() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージのテキスト行を取得します。
getMessageType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージタイプを取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV3() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を取得します。
getMessageV4() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を取得します。
getMethod() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メソッドを取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者番号を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者番号を取得します。
getMfrNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者番号を取得します。
getMfrNoExt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
外部製造者コード名または番号を取得します。
getMilestone() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
用途を取得します。
getMilestoneNumber() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン番号を取得します。
getMilestoneUsage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン用途を取得します。
getMilitId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ID: 武器を取得します。
getMinDely() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
納品書処理時の最小納入数量を取得します。
getMinLotSize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最小ロットサイズを取得します。
getMinMto() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
受注製造品最少受注数量を取得します。
getMinOrder() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
基本数量単位での最小受注数量を取得します。
getMinSafetyStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小安全在庫を取得します。
getMinSbQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最小棚番在庫数量を取得します。
getMinlotsize() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小ロットサイズを取得します。
getMinremlife() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
最低有効期間残を取得します。
getMinremlife() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最低有効期間残を取得します。
getMixedMrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
二重 MRP 区分を取得します。
getMlActive() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目レベルで有効な品目元帳を取得します。
getMlSettle() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目元帳決済: 管理を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
マニュアル請求書更新を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
マニュアル請求書更新を取得します。
getMnInvoice() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getModelSi() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択区分を取得します。
getModelSp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択方式を取得します。
getMovPrPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期移動平均原価/期間平均原価を取得します。
getMovPrPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の移動平均原価/期間単価を取得します。
getMoveBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫ロットを取得します。
getMoveBatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫ロットを取得します。
getMoveMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫品目を取得します。
getMoveMat() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫品目を取得します。
getMoveMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getMoveMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getMoveMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
getMoveMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を取得します。
getMoveMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getMoveMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getMovePlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫プラントを取得します。
getMovePlant() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫プラントを取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動理由を取得します。
getMoveReas() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動理由を取得します。
getMoveStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫保管場所を取得します。
getMoveStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫保管場所を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動タイプ (在庫管理)を取得します。
getMoveType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動タイプ (在庫管理)を取得します。
getMoveTypeRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
移動タイプの範囲を取得します。
getMoveValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
転送ロットの評価タイプを取得します。
getMoveValType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
転送ロットの評価タイプを取得します。
getMovingPr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
移動平均原価/期間単位価格を取得します。
getMrpAreaExists() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: MRP エリア登録済を取得します。
getMrpCtrler() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP 管理者を取得します。
getMrpGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP グループを取得します。
getMrpInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP 区分を取得します。
getMrpRelevancyDepRequirements() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
従属所要量と MRP の関連性を取得します。
getMrpType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP タイプを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
資材所要量計画 (MRP) ビューを取得します。
getMrpprofile() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目: MRP プロファイルを取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目利用可能日を取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目利用可能日を取得します。
getMsDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目供給ステージ (現地時刻: プラント参照)を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目供給ステージ (現地時刻: プラント参照)を取得します。
getMsTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getMsgToIm() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
区分: 在庫管理への出力を取得します。
getMultRefM() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照品目の乗数を取得します。
getMvtInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動区分を取得します。
getMvtInd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動区分を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域を指定して管理領域名を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を取得します｡
getName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタを指定して一般名称を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
発注者名称を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 1を取得します。
getName() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
名称 1を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 2を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 2を取得します。
getName2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 2を取得します。
getName3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 3を取得します。
getName3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 3を取得します。
getName4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 4を取得します。
getName4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 4を取得します。
getName_2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 2を取得します。
getName_3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 3を取得します。
getName_4() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 4を取得します。
getNbSlips() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫票の印刷部数を取得します。
getNbSlipsx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNegStocks() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントにおけるマイナス在庫許可を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
通貨額を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
正味価格を取得します。
getNetPrice() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
正味価格を取得します。
getNetValHd() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注正味額 (伝票通貨)を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買発注通貨による正味発注額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細の正味額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
正味金額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票通貨による正味額を取得します。
getNetValue() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票通貨での受注明細正味額を取得します。
getNetValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の正味重量を取得します。
getNetWeight() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定割当のネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
勘定割当のネットワーク番号を取得します。
getNetwork() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
勘定割当のネットワーク番号を取得します。
getNetworkAssignment() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ネットワーク割当を取得します。
getNetworkAssignment() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワーク割当を取得します。
getNetworkProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワークプロファイルを取得します。
getNoAuthority() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
権限チェックなし区分を取得します｡
getNoCosting() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算なしを取得します。
getNoDisct() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
現金値引対象外明細を取得します。
getNoFrlimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを取得します。
getNoGrPost() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先が入庫を転記していませんを取得します。
getNoGrPost() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNoLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限なしを取得します。
getNoLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを取得します。
getNoMatmast() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目マスタ確認禁止を取得します。
getNoMessageReq() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
メッセージ不要区分を取得します｡
getNoMessaging() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出力決定なし区分を取得します｡
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
納入完了区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
納入完了 区分を取得します。
getNoMoreGr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
納入完了 区分を取得します。
getNoPriceFromPo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
最終伝票からの価格転送なし区分を取得します｡
getNoPstChgnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 振替要求通知登録禁止を取得します。
getNoRounding() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注明細での非表示丸めを取得します。
getNoSheets() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書枚数 (文書管理システムによらない)を取得します。
getNoTransferReq() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 転送要求未登録を取得します。
getNoappllog() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
アプリケーションログ書込なしを取得します。
getNochangedoc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
変更伝票書込なしを取得します。
getNondItax() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getNostructure() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
チェックボックスを取得します。
getNotMrpApplicable() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: MRP への入出庫予定の適用不可と購買依頼未登録を取得します。
getNotifNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通知番号を取得します。
getNotifNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ番号を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ番号を取得します。
getNumberOfCapacities() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
所要能力数を取得します。
getNumconvert() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分子を取得します。
getNumconvert() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分子を取得します。
getNumerator() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
基本数量単位への換算分子を取得します。
getObjKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象キーを取得します。
getObjKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象キーを取得します。
getObjTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
言語依存対象テキストを取得します。
getObjType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象タイプを取得します。
getObjType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象タイプを取得します。
getObjectGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス用 TYPE_OF ステートメントの GUIDを取得します。
getObjectNo() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
対象番号を取得します。
getObjectNo() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
対象番号を取得します。
getObjectType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
オブジェクトタイプを取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス (言語非依存)を取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
対象クラスを取得します。
getObjectclass() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
対象クラスを取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス、言語依存を取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
オブジェクトクラス、言語依存を取得します。
getObjectclassExt() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
オブジェクトクラス、言語依存を取得します。
getOffsetMilestoneDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン日付のオフセットを取得します。
getOffsetMilestoneDateUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーンのオフセットのための時間単位を取得します。
getOffsetMilestoneDateUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
単位の ISO コードを取得します。
getOffsetPercentage() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
活動日に対するマイルストーンの百分率によるオフセットを取得します。
getOffsetStartEndIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: オフセット用の参照（開始/終了活動日）を取得します。
getOldMatNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
旧品目コードを取得します。
getOpenQty() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
未処理数量のある明細を取得します。
getOperationMeasureUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動単位を取得します。
getOperationMeasureUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getOptimLev() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最適化レベルを取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOption() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 OPTION (範囲テーブル)を取得します。
getOrdCosts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注原価 (BAPI インタフェース)を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注理由 (取引理由)を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrdReason() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注理由 (取引理由)を取得します。
getOrdbilltyp() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注関連請求伝票に対する提案請求伝票タイプを取得します。
getOrdcombIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注結合出荷区分を取得します。
getOrdcombIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrdcompIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
受注結合出荷区分を取得します。
getOrdcompIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (個別値、または下限値)を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (個別値、または下限値)を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図番号を取得します。
getOrder() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
指図番号を取得します。
getOrderCcardList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
クレジットカードデータを取得します。
getOrderCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getOrderCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: インスタンスを取得します。
getOrderCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 部分設定を取得します。
getOrderCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照明細/インスタンスを取得します。
getOrderCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照データを取得します。
getOrderCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 特性値を取得します。
getOrderCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: バリアント条件キーを取得します。
getOrderConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件を取得します。
getOrderConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件チェックボックスを取得します。
getOrderExternalNo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (個別値、または下限値)を取得します。
getOrderExternalNo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (個別値、または下限値)を取得します。
getOrderExternalNoTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (上限値)を取得します。
getOrderExternalNoTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (上限値)を取得します。
getOrderHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票ヘッダを取得します。
getOrderHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票チェックリストを取得します。
getOrderItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データを取得します。
getOrderItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データチェックボックスを取得します。
getOrderItno() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図明細番号を取得します。
getOrderItno() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図明細番号を取得します。
getOrderKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
参照キーの出力テーブルを取得します。
getOrderListList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
選択指図一覧を取得します。
getOrderListList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
選択指図一覧を取得します。
getOrderName() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
テキストを取得します。
getOrderName() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
テキストを取得します。
getOrderPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
伝票取引先を取得します。
getOrderProb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の受注可能性を取得します。
getOrderProb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrderReason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注理由を取得します。
getOrderSchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データを取得します。
getOrderSchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データチェックボックスを取得します。
getOrderTextList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テキストを取得します。
getOrderTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (上限値)を取得します。
getOrderTo() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (上限値)を取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
販売伝票タイプを取得します。
getOrderType() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
販売伝票タイプを取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
指図番号を取得します。
getOrderid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格単位を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注価格単位 (購買管理)を取得します。
getOrderprUn() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注価格単位 (購買管理)を取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格のISOコードを取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを取得します。
getOrderprUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getOrigGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
発生源グループ (原価要素の下位区分)を取得します。
getOrigMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目発生源を取得します。
getOriginalBatchFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロット管理区分を取得します。
getOriginalBatchRefMaterial() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロットの参照品目を取得します。
getOrigindoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始伝票を取得します。
getOurRef() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
社内参照番号を取得します｡
getOutlInd() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
区分: 出力行を取得します。
getOutlLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
グループの階層レベルを取得します。
getOutlNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
アウトラインレベルを取得します。
getOverDlvTol() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
過剰納入許容範囲を取得します。
getOverTol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
過剰納入許容範囲リミットを取得します。
getOverallprf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
指図変更管理の全体プロファイルを取得します。
getOverdlvtol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
過剰納入許容範囲を取得します。
getOverdlvtol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOverhdKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
間接費キーを取得します。
getOverhdKey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getOverheadGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算間接費グループを取得します。
getOverheadKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
間接費キーを取得します。
getOverheadKey() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
間接費キーを取得します。
getOvfTol() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
超過許容値を取得します。
getOvfUnlim() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
契約外サービス制限なしを取得します。
getPMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getPMatExt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
getPMatGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getPMatVers() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPaAllocNmbr() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーを取得します｡
getPaBlineDate() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日を取得します｡
getPaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を取得します｡
getPaIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
レコード番号を取得します｡
getPaItemText() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストを取得します｡
getPaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号を取得します｡
getPaPymtMeth() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を取得します｡
getPaVendorNo() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードを取得します｡
getPackVoUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容積単位 (許容梱包容積)を取得します。
getPackVoUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの容積単位 (許容梱包容積)を取得します。
getPackWtUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位 (許容梱包重量)を取得します。
getPackWtUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位 (許容梱包重量)を取得します。
getPageNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書ページ番号 (文書管理システムによらない)を取得します。
getPageformat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造メモのページ書式を取得します。
getParCompco() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済会社コードを取得します。
getParEff() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効性パラメータへの値割当/変更番号よりも優先を取得します。
getParamOpt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
パラメータ最適化用の区分を取得します。
getParameter() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータ名を取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
1 レベル上位の行 IDを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
1 レベル上位の行 IDを取得します。
getParentId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
取引先勘定コードを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
取引先勘定コードを取得します。
getPartAcct() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引先勘定コードを取得します。
getPartDeliv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
明細レベルでの分割納入 (在庫転送)を取得します。
getPartDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細レベルの分納納入を取得します。
getPartDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPartInv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
一部請求区分を取得します。
getPartOfGuid() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
インスタンス用 PART_OF ステートメントの GUIDを取得します。
getPartOfNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
Part_of 明細番号を取得します。
getPartnNumb() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
得意先コード 1を取得します。
getPartnRole() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
取引先機能を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerAddressesList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を取得します。
getPartnerList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
得意先一覧を取得します｡
getPartnerdesc() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語別取引先機能テキストを取得します。
getPayer() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払人を取得します。
getPaymentTerms() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払条件キーを取得します。
getPaytype() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払手段: 支払カード計画の明細分類を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPboxcitNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村私書箱コード (市ファイル)を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
パッケージ番号を取得します。
getPckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
パッケージ番号を取得します。
getPcode1Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を取得します。
getPcode2Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号拡張子 例: 郵便番号 +4+2を取得します。
getPcode3Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を取得します。
getPctrName() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を取得します｡
getPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して一般名称を取得します。
getPerCurCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
現行標準原価見積期間を取得します。
getPerFutCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積期間を取得します。
getPerPreCostEst() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前標準原価見積期間を取得します。
getPercentOfWork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業の比率 (%)を取得します。
getPercentage() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定金額配賦のパーセントを取得します。
getPercentageOfCompletion() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗度 (%)を取得します。
getPeriodInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
期間区分を取得します。
getPeriodInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
期間区分を取得します。
getPeriodIndExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
有効期間期限日の期間区分を取得します。
getPeriodIndExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日の期間区分を取得します。
getPeriodProfileSafetyTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間の期間プロファイルを取得します。
getPersNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
従業員番号を取得します。
getPersistId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号 (固定)を取得します。
getPersistIdType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号タイプ (固定)を取得します。
getPersonResp() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者を取得します。
getPersonRespPhone() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者の電話番号を取得します。
getPickArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
ピッキングエリアを取得します。
getPickgArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
簡易倉庫管理のピッキングエリアを取得します。
getPlRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包方法が同じ品目の参照品目を取得します。
getPlTiFnce() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画タイムフェンスを取得します。
getPlacement() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫受入に対する保管域タイプ検索区分を取得します。
getPlanBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト基準日付計画方法を取得します。
getPlanDel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
予定納入日数を取得します。
getPlanFcst() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト予測日付の計画方法を取得します。
getPlanProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
計画プロファイルを取得します。
getPlanSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行タイプ EDIを取得します。
getPlanSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlanStrgp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画方針グループを取得します。
getPlanlistcnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
グループカウンタを取得します。
getPlanlistgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストグループのキーを取得します。
getPlannedCost() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画原価を取得します。
getPlanningData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ/製品グループの変更伝票構造を取得します。
getPlanningDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目マスタ/製品グループの変更伝票構造が既に存在するかチェックします。
getPlanningDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ/製品グループの変更伝票構造を取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プラントを取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlant() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
プラントを取得します。
getPlantData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (プラントレベル)を取得します。
getPlantDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (プラントレベル)が既に存在するかチェックします。
getPlantDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (プラントレベル)を取得します。
getPlantHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 終了を取得します。
getPlantLow() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 開始を取得します。
getPlantRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
プラントの範囲を取得します。
getPlantSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
プラントの選択オプション一覧を取得します｡
getPldlvshdin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷計画に関する指示を取得します。
getPldlvshdin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPldlvstyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
MRP: 出荷計画タイプを取得します。
getPldlvstyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPlnClose() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画終了日付を取得します。
getPlnCompletion() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画完了日を取得します。
getPlnLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画梱包明細行を取得します。
getPlnPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号供給元一覧を取得します。
getPlnRelease() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画リリース日付を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndDelry() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予定納入時間 (単位: 日)を取得します。
getPlndPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価を取得します。
getPlndprdate1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 1 の有効開始日を取得します。
getPlndprdate2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 2 の有効開始日を取得します。
getPlndprdate3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 3 の有効開始日を取得します。
getPlndprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 1を取得します。
getPlndprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 2を取得します。
getPlndprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 3を取得します。
getPlngCycle() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画サイクルを取得します。
getPlngMatl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目を取得します。
getPlngMatlExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を取得します。
getPlngMatlGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を取得します。
getPlngMatlVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を取得します。
getPlngPlant() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画プラントを取得します。
getPlordCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
アクション管理: 計画手配処理を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
支払条件キーを取得します｡
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払条件キーを取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払保証決定表を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払保証決定表を取得します。
getPmtgarPro() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱を取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱住所を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱住所を取得します。
getPoBoxCit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所を取得します。
getPoBoxReg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の地域 (国、都道府県、地域、...)を取得します。
getPoCtryiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注日付を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注日付を取得します。
getPoDatS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程の購買発注日付を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買伝票の明細番号を取得します。
getPoItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買伝票の明細番号を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoItmNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
元となる購買発注の明細番号を取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注タイプを取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注タイプを取得します。
getPoMethS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注タイプを取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注タイプを取得します。
getPoMethod() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票を取得します｡
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買伝票番号を取得します｡
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
購買伝票番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注番号を取得します。
getPoNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注番号を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
数量 (購買発注価格単位)を取得します。
getPoPrQnt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量 (購買発注価格単位)を取得します。
getPoPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格採用区分を取得します。
getPoRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
承認コードを取得します。
getPoRelInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
承認区分: 購買伝票を取得します。
getPoSupplem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注番号補足を取得します。
getPoSupplem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注単位を取得します。
getPoUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
発注単位を取得します。
getPoUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
ISOコードによる発注単位を取得します。
getPoUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードによる発注単位を取得します。
getPoWONo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
フラグ: 郵便私書箱 (番号なし)を取得します。
getPoboxCtry() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の国指定を取得します。
getPobxCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱住所を取得します。
getPobxPcd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱番号を取得します。
getPointUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位を取得します。
getPointUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位の ISO コードを取得します。
getPoints() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベートポイント数を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を取得します。
getPoitmNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPoolnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO 評価でのプール番号を取得します。
getPoolnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価でのプール番号を取得します。
getPosex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部明細番号を取得します。
getPosex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部明細番号を取得します。
getPostDate() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの転記日付を取得します。
getPostDate() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの転記日付を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村の郵便番号を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村の郵便番号を取得します。
getPostlCod1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村の郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱郵便番号を取得します。
getPostlCod2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCod3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
会社郵便番号 (大規模なユーザ用)を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
郵便番号を取得します。
getPostlCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
郵便番号を取得します。
getPpSearch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
品目提案検索条件を取得します。
getPpSearch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPpcPlCal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PPC 計画カレンダを取得します。
getPrClosed() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買依頼処理済を取得します。
getPrCtrlPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期間の原価管理区分を取得します。
getPrCtrlPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の原価管理区分を取得します。
getPrIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
レコード番号を取得します｡
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定参照品目を取得します。
getPrRefMat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrRefMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を取得します。
getPrRefMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を取得します。
getPrRefMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を取得します。
getPrUname() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を取得します。
getPrUnitPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期価格単位を取得します。
getPrUnitPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度価格単位を取得します。
getPrcGroup1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 1を取得します。
getPrcGroup1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 2を取得します。
getPrcGroup2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 3を取得します。
getPrcGroup3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 4を取得します。
getPrcGroup4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcGroup5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 5を取得します。
getPrcGroup5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrcStatH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票の全処理ステータスを取得します。
getPreVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
製造元/販売元を取得します。
getPrefStatFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 特恵関税 - 輸出/輸入を取得します。
getPreqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼の明細番号を取得します。
getPreqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼の明細番号を取得します。
getPreqName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼者名/要求者名を取得します。
getPreqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼番号を取得します。
getPreqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼番号を取得します。
getPrevPlanPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を取得します。
getPrice() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
入力シートの価格変更を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力シートの価格変更を取得します。
getPriceChg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getPriceCtrl() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価管理区分を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/外貨換算の実行日付を取得します。
getPriceDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格グループ (得意先)を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格グループ (得意先)を取得します。
getPriceGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格表タイプを取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格表タイプを取得します。
getPriceList() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格単位を取得します。
getPriceUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
価格単位を取得します。
getPricedate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日カテゴリ (価格設定日管理)を取得します。
getPricing() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
価格設定タイプを取得します。
getPriority() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
優先度を取得します。
getPriority() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
優先度を取得します。
getPrivAddr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
自宅住所を取得します。
getPrntPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格印刷を取得します。
getProcRule() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達規則を取得します。
getProcTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
処理時間を取得します。
getProcType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達タイプを取得します。
getProcedure() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
決定表 (価格設定/出力管理/勘定設定/原価計算など)を取得します。
getProcessingGroup() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
処理グループを取得します。
getProcureUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量消費の数量単位を取得します。
getProcureUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの保管容量消費の数量単位を取得します。
getProdAlloc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品割当決定手順を取得します。
getProdAtt1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ID: 製品属性 1を取得します。
getProdAtt10() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 10 用 IDを取得します。
getProdAtt2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 2 用 IDを取得します。
getProdAtt3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 3 用 IDを取得します。
getProdAtt4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 4 用 IDを取得します。
getProdAtt5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 5 用 IDを取得します。
getProdAtt6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 6 の IDを取得します。
getProdAtt7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 7 用 IDを取得します。
getProdAtt8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 8 用 IDを取得します。
getProdAtt9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 9を取得します。
getProdCompositionOnPackaging() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 梱包材にプリントされた生産構造を取得します。
getProdConvType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産値の変換タイプを取得します。
getProdDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット製造日付を取得します。
getProdDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット製造日付を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目階層を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目階層を取得します。
getProdHier() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目階層を取得します。
getProdHiera() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目階層を取得します。
getProdHiera() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProdMemo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造/検査メモを取得します。
getProdUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位を取得します。
getProdUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位 (ISO コード)を取得します。
getProdcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品カタログ番号を取得します。
getProdcat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProdcomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産統計: 貿易における PRODCOM コードを取得します。
getProdprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画プロファイルを取得します。
getProductionResourceToolData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を取得します。
getProductionScheduler() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画担当を取得します。
getProdverscs() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算を行う製造バージョンを取得します。
getProfitCentList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します｡
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を取得します。
getProfitCenterList() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを取得します｡
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
利益センタを取得します。
getProfitCtr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmNo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
収益性セグメント番号 (CO-PA)を取得します。
getProfitSegmentList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入出庫予定一覧を取得します｡
getProjType() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクトタイプを取得します。
getProjectCurrency() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 通貨(プロジェクト定義)を取得します。
getProjectCurrencyIso() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ISO 通貨コードを取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト定義を取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクト定義を識別するキーを取得します。
getProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクト定義を識別するキーを取得します。
getProjectDefinitionInfo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクトについての詳細情報を取得します。
getProjectDefinitionInfo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクトについての詳細情報を取得します。
getProjectProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトプロファイルを取得します。
getProjectStock() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト在庫を取得します。
getProjectSummarization() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: プロジェクト集計用に活動を考慮を取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
プロモーションを取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プロモーションを取得します。
getPromotion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPrtData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目マスタの生産資源/治工具 (PRT) 項目が既に存在するかチェックします。
getPrtDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を取得します。
getPrtUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途を取得します。
getPrtUsage() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途を取得します。
getPrtView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産資源/治工具 (PRT) ビューを取得します。
getPrtView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
生産資源/治工具 (PRT) ビューを取得します。
getPsConfMat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
選定可能品目を取得します。
getPstngDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の転記日付を取得します。
getPstngDateRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
登録日付の範囲を取得します。
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買グループを取得します。
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買グループを取得します｡
getPurGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買グループを取得します。
getPurMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目コードを取得します。
getPurMatExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の品目コード (長) (今後のリリースで開発)を取得します。
getPurMatGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の外部 GUID (今後のリリースで開発)を取得します。
getPurMatVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT のバージョン番号 (今後のリリースで開発)を取得します。
getPurStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目ステータスを取得します。
getPurStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント特有品目ステータスを取得します。
getPurValkey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
購買許容値キーを取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注日付を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注日付を取得します。
getPurchDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
得意先発注番号を取得します。
getPurchNo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先発注番号を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoC() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の得意先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の得意先発注番号を取得します。
getPurchNoS() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPurchOrd() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先発注番号を取得します。
getPurchOrg() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買組織を取得します。
getPurchOrg() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買組織を取得します｡
getPurchView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買管理ビューを取得します。
getPurchaseAccountList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
勘定設定一覧を取得します｡
getPurchaseGetItemSrel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認対象一覧情報を取得します｡
getPurchaseHeadersList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票ヘッダ一覧を取得します｡
getPurchaseHeadersList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票ヘッダ一覧を取得します。
getPurchaseItemPostList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細一覧を取得します｡
getPurchaseItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票明細一覧を取得します｡
getPurchaseItemsList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票明細一覧を取得します。
getPurchaseOrder() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号を取得します。
getPurchaseOrderNumber() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号1を取得します。
getPurchaseScheduleList() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
納入日程一覧を取得します｡
getPurchaseView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
購買管理ビューを取得します。
getPurchaseorder() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
購買発注番号を取得します。
getPushDistrib() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: プッシュ配賦を取得します。
getPvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目のステータス有効開始日付を取得します。
getPvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント品目ステータス有効期間開始日を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払方法を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払方法を取得します。
getPymtMeth() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQmAuthgrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
QM における活動の品目権限グループを取得します。
getQmProcmnt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達における品質管理有効を取得します。
getQmRgmts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
仕入先の必須 QM システムを取得します。
getQtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積/引合有効開始日を取得します。
getQtValidF() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積の有効終了日を取得します。
getQtValidT() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getQtyGrGi() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
数量: 印刷予定入出庫票数を取得します。
getQtyStruct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
数量構成により原価計算を行う品目を取得します。
getQualDik() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
無償納入による割引対象品目を取得します。
getQualInsp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
在庫タイプを取得します。
getQualityView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質管理ビューを取得します。
getQualityView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品質管理ビューを取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
+/- 記号あり/なし数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
+/- 記号あり/なし数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
計画数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量を取得します。
getQuantity() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス数量を取得します。
getQuantityUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
数量単位を取得します。
getQuotDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積提出日を取得します｡
getQuotDead() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を取得します。
getQuotation() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積番号を取得します｡
getQuotationCfgsBlobList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を取得します。
getQuotationCfgsInstList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: インスタンスを取得します。
getQuotationCfgsPartOfList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 部分設定を取得します。
getQuotationCfgsRefInstList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照明細/インスタンスを取得します。
getQuotationCfgsRefList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照データを取得します。
getQuotationCfgsValueList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 特性値を取得します。
getQuotationCfgsVkList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: バリアント条件キーを取得します。
getQuotationConditionsInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
条件を取得します。
getQuotationConditionsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
受注における条件更新の通信項目を取得します。
getQuotationHeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダデータを取得します。
getQuotationHeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダチェックボックスを取得します。
getQuotationItemsInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データを取得します。
getQuotationItemsInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データチェックボックスを取得します。
getQuotationKeysList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
参照キーの出力テーブルを取得します。
getQuotationPartnersList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票取引先を取得します。
getQuotationSchedulesInList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データを取得します。
getQuotationSchedulesInXList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データチェックボックスを取得します。
getQuotationTextList() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テキストを取得します。
getQuotausage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給量割当の使用を取得します。
getRPromo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
プロモーションを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算レートタイプを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レートタイプを取得します。
getRateType() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レートタイプを取得します。
getRcvgVend() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
未使用項目を取得します。
getReason() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更理由を取得します。
getReason() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更理由を取得します。
getReasonCancel() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
取消理由を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見積および受注の拒否理由を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReasonRej() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積および受注の拒否理由を取得します。
getRebateGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
取引量リベートグループを取得します。
getRecInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
リカバリフラグを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
入荷ポイントを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入荷ポイントを取得します。
getRecPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRecTime() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
登録時刻を取得します。
getRecoveryInd() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
リカバリフラグを取得します。
getRecoveryInd() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
リカバリフラグを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先/仕入先の内部参照コードを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先/仕入先の内部参照コードを取得します。
getRef1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先文字を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先文字を取得します。
getRef1S() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
決済の参照日付を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
決済の参照日付を取得します。
getRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済の参照日付を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照伝票番号を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照伝票番号を取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefDocCa() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocHigh() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の終了伝票番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照明細番号を取得します。
getRefDocIt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照明細番号を取得します。
getRefDocItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照明細番号を取得します。
getRefDocL() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を取得します。
getRefDocL() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefDocLLong() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号 (依存関係についてはテキスト (長) を参照)を取得します。
getRefDocLow() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の開始伝票番号を取得します。
getRefDocNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号を取得します。
getRefDocNoLong() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を取得します。
getRefDocRange() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
前伝票の範囲を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の会計年度を取得します。
getRefDocYr() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の会計年度を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票の明細を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照明細番号を取得します。
getRefItem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照明細番号を取得します。
getRefKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
参照キーは変更できませんを取得します。
getRefKeyNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
参照キーは変更できませんを取得します。
getRefProc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照限定条件: 決定区分を取得します。
getRefProc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
基本数量単位による参照数量を取得します。
getRefUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目マスタレコードの数量単位初期値を取得します。
getRef_1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先/仕入先の内部参照コードを取得します｡
getRefdocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
先行販売管理伝票の伝票カテゴリを取得します。
getRefdocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefdoctype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照オブジェクトの伝票タイプを取得します。
getReferencePoint() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
BOM 転送の参照ポイントを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
論理システムを取得します。
getReflogsys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
論理システムを取得します。
getRefmatcons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照品目を取得します。
getRefmatconsExternal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を取得します。
getRefmatconsGuid() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を取得します。
getRefmatconsVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を取得します。
getRefobject() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクト名を取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトキーを取得します。
getRefobjkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトキーを取得します。
getRefobjtyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトタイプを取得します。
getRefobjtype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトタイプを取得します。
getRefpltcons() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照プラントを取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域構造グループ化を取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地域構造グループ化を取得します。
getRegiogroup() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域構造グループ化を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域 (都道府県)を取得します。
getRegion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地域 (都道府県)を取得します。
getRegionorig() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産地 (非特恵対象地区の原産)を取得します。
getRegionorig() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産地 (非特恵対象地区の原産)を取得します。
getRejReason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積および受注の拒否理由を取得します。
getRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認コードを取得します。
getRelCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認コードを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認グループを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認グループを取得します。
getRelGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認グループを取得します。
getRelInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認区分: 購買伝票を取得します。
getRelIndicatorNew() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却規承認区分を取得します。
getRelStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
承認状況を取得します｡
getRelStatusNew() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認状況を取得します。
getRelStrat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認方針を取得します。
getRelType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
承認タイプを取得します。
getRelType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReleaseDate() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認日を取得します。
getReleaseTime() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認時刻を取得します。
getReleasebyPur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認購買担当者名を取得します。
getReleasedBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認者名を取得します。
getReleasedatePur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認日付を取得します。
getReleasetimePur() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認時刻を取得します。
getReminder1() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第一回催促状/督促状の日数を取得します。
getReminder2() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第二回催促状/督促状の日数を取得します。
getReminder3() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第三回催促状/督促状の日数を取得します。
getReorderPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注点を取得します。
getReorderPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する発注点を取得します。
getRepManuf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 繰返生産許可を取得します。
getReplQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する補充数量を取得します。
getReplacePt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
取替部品を取得します。
getReplenQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
補充数量を取得します。
getReplentime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
補充リードタイム合計 (稼動日数)を取得します。
getRepmanprof() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
繰返生産プロファイルを取得します。
getReqBy() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更を依頼した従業員を取得します。
getReqBy() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更を依頼した従業員を取得します。
getReqByExt() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの外部変更番号を取得します。
getReqByExt() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの外部変更番号を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
指定納期を取得します。
getReqDate() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入日程日付を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
指定納入期日を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqDateH() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
指定納入期日を取得します。
getReqDlvBl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出荷ブロック中の納入日程行を取得します。
getReqDlvBl() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
利用可能在庫確認の所要量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
累積受注数量 (販売単位)を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売単位による受注数量を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
累積受注数量 (販売単位)を取得します。
getReqQty() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積受注数量 (販売単位)を取得します。
getReqTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を取得します。
getReqTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReqmtsTyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所要量タイプを取得します。
getReqmtsTyp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRequCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コード要求を取得します。
getRequestCctr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請原価センタを取得します。
getRequestCctr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請原価センタを取得します。
getRequestCctrControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
依頼原価センタの管理領域を取得します。
getRequestCompCode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コード要求を取得します。
getRequestOrder() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請指図を取得します。
getResAnalKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
結果分析キーを取得します。
getResAnalKey() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
結果分析キーを取得します。
getResDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算の伝票番号を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算: 伝票明細を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getResItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の明細番号を取得します。
getResType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコードタイプを取得します。
getResType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコードタイプを取得します。
getResanalkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
結果分析キーを取得します。
getResanalkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getReservNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の番号を取得します。
getReservNo() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の番号を取得します。
getRespCostCenter() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
責任原価センタを取得します。
getRespCostCenter() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
責任原価センタを取得します。
getRespcctr() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任原価センタを取得します。
getResponsibleNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任者番号 (プロジェクト責任者)を取得します。
getResponsibleNo() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
責任者番号 (プロジェクト責任者)を取得します。
getRespsblCctr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタを取得します。
getRespsblCctrControllingArea() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタの管理領域を取得します。
getRetCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
リターン値、ABAP 命令後のリターン値を取得します。
getRetItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
返品明細を取得します。
getReturnMessagesList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
リターンパラメータ BAPIRET2 の代替構造を取得します。
getRevLev() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
改訂レベルを取得します。
getRevType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
収益承認カテゴリを取得します。
getRevType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRfqItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼明細番号を取得します。
getRfqNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼番号を取得します。
getRight() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
不動産管理対象の内部キーを取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
不動産管理対象の内部キーを取得します。
getRlEstKey() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
不動産管理対象の内部キーを取得します。
getRnddlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
丸め数量: 出荷を取得します。
getRnddlvQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
部屋/アパート番号を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
部屋/アパート番号を取得します。
getRoomNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
部屋/アパート番号を取得します。
getRootId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
選定におけるインスタンス番号を取得します。
getRotationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを取得します。
getRoundProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
丸めプロファイルを取得します。
getRoundProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
丸めプロファイルを取得します。
getRoundQty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
丸め数量を取得します。
getRoundUpRuleExpirationDate() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日計算の丸め規則を取得します。
getRoundVal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買発注数量の丸め数量を取得します。
getRoundoffdi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
輸送経路を取得します。
getRoute() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getRoutesched() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送経路計画を取得します。
getRow() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの行を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注明細番号を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注明細番号を取得します。
getSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注明細番号を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
特別処理区分を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
特別処理区分を取得します。
getSProcInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSUnitDlv() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷単位を取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
単位の ISO コードを取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードによる販売単位を取得します。
getSUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードによる販売単位を取得します。
getSaIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
レコード番号を取得します｡
getSafetyStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全在庫を取得します。
getSafetytime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間 (稼動日数)を取得します。
getSaftyTId() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間区分（安全リードタイムあり/なし)を取得します。
getSalStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスを取得します。
getSalStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売ビューからの品目ステータスを取得します。
getSalesData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売データを取得します。
getSalesDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
販売データが既に存在するかチェックします。
getSalesDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
販売データを取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売地域を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売地域を取得します。
getSalesDist() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesDocDateInidicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
販売伝票の日付に関連するマイルストーンを取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業グループを取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesGrp() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業グループを取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業所を取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesOff() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業所を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注伝票番号を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注伝票番号を取得します。
getSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注伝票番号を取得します。
getSalesOrdersList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先受注テーブルを取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売組織を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売組織を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesOrg() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売組織を取得します。
getSalesOrganisationSelectionList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
販売組織の選択オプション一覧を取得します｡
getSalesOrganization() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売組織を取得します。
getSalesPers() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先営業担当者を取得します｡
getSalesRelevant() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
この部品は販売に関連していますを取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売単位を取得します。
getSalesUnit() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売単位を取得します。
getSalesUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードによる販売単位を取得します。
getSalesView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
販売ビューを取得します。
getSalesView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
販売ビューを取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売伝票番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
販売管理伝票番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
生成された伝票の番号を取得します。
getSalesdocument() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売管理伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売管理伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票番号を取得します。
getSalesdocumentin() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
販売管理伝票番号を取得します。
getSalesorg() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売組織を取得します。
getSalesorgHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲終了を取得します。
getSalesorgLow() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲開始を取得します。
getSalesorganisation() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売組織を取得します。
getSalqtyden() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位を SKU に換算するための分母 (除数)を取得します。
getSalqtyden() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSalqtynum() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位から基本数量単位への変換係数の分子を取得します。
getSalqtynum() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getScIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
レコード番号を取得します｡
getScVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
外注仕入先を取得します。
getScalbasval() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件のスケール基準値を取得します。
getScalbasval() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件のスケール基準値を取得します。
getScalebasin() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール基準区分を取得します。
getScalebasin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール基準区分を取得します。
getScaletype() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケールタイプを取得します。
getScaletype() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケールタイプを取得します。
getSce() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CUX: 選定タイプを取得します。
getSchedInd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
分納契約のリリース伝票区分を取得します。
getSchedLin() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注納入日程を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注納入日程を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行を取得します。
getSchedLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
納入日程行を取得します。
getSchedMilestoneDateBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(基準)を取得します。
getSchedMilestoneDateForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(予測)を取得します。
getSchedMilestoneTimeBasic() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(基準)を取得します。
getSchedMilestoneTimeForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(予測)を取得します。
getSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程カテゴリを取得します。
getSchedType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getScheduling() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
単一文字フラグを取得します。
getSdDoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売管理伝票番号を取得します。
getSdDoc() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票番号を取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売管理伝票カテゴリを取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票カテゴリを取得します。
getSdDocCat() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSdTaxcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
を取得します。
getSdTaxcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSeasIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
季節指数を取得します。
getSeason() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
季節カテゴリを取得します。
getSeason() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
季節カテゴリを取得します。
getSeasonPds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
季節周期ごとの期間数を取得します。
getSeasonYr() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
シーズン年度を取得します。
getSelection() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選択 ID (永続)を取得します。
getSelection() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
論理システム - 送信者を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
論理システム - 送信者を取得します。
getSender() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
論理システム - 送信者を取得します。
getSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
KANBAN/連続番号を取得します。
getSeqNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
勘定設定の連続番号を取得します。
getSerialNo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定設定の連続番号を取得します。
getSerializationLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
シリアル番号の指定レベルを取得します。
getSerialno() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
シリアル番号を取得します。
getSerialnoAutoNumberassignment() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
シリアル番号の自動登録を取得します。
getSernoLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定コード設定のシリアル番号、サービス明細を取得します。
getSernoProf() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
シリアル番号プロファイルを取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
サービス提供日を取得します。
getServDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getServLevel() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サービスレベルを取得します。
getServType() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのテキスト (短)を取得します。
getServType() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのテキスト (短)を取得します。
getService() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
活動番号を取得します。
getSettItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベート (期末) 決済対象の明細を取得します。
getSetupTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷準備時間を取得します。
getSetuptime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取時間と片付け時間を取得します。
getShMatTyp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包材タイプを取得します。
getShelfLife() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
総有効期間を取得します。
getShipBlocked() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
SD 出荷伝票の明細ブロックを取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷条件を取得します。
getShipCond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipPoint() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ポイント/入荷ポイントを取得します。
getShipProcTime() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷処理時間を取得します。
getShipTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先を取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷タイプを取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷タイプを取得します。
getShipType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
出荷指示を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示を取得します。
getShipping() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示を取得します。
getShippingCountry() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 出荷国を取得します。
getShippingCountryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを取得します。
getShortId() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素 ショート IDを取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を取得します｡
getShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
G/L勘定コードを指定してG/L勘定コードテキスト(短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
テキスト 1 (短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
テキスト(短)を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードテキスト（短）を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
テキスト (短): 受注明細を取得します。
getShortText() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
テキスト (短): 受注明細を取得します。
getSiCat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助明細カテゴリ、購買伝票を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSign() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 SIGN (テーブル範囲)を取得します。
getSizeDim() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
サイズ/寸法を取得します。
getSledBbd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期限を取得します。
getSlocExprc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
外部調達の初期保管場所を取得します。
getSmKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
日程計画余裕キーを取得します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注先を取得します。
getSoldTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注先を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 1を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 1を取得します。
getSort1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 1を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 2を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 2を取得します。
getSort2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 2を取得します。
getSourcelist() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 供給元一覧必須を取得します。
getSpecMvmt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の特殊移動区分を取得します。
getSpecMvmt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
倉庫管理の特殊移動区分を取得します。
getSpecProc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの特殊調達タイプを取得します。
getSpecStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
特殊在庫区分を取得します。
getSpecStock() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
特殊在庫区分を取得します。
getSpecStockRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
特殊在庫区分の範囲を取得します。
getSpecprocty() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算の特殊調達タイプを取得します。
getSplitInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
分割区分を取得します。
getSpproctype() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
特殊調達タイプを取得します。
getSscExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの制限を取得します。
getSscItem() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ: 明細を取得します。
getSscLim() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ制限参照のサービス行を取得します。
getSscLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの金額制限を取得します。
getSscNolim() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
標準サービスタイプの制限なしを取得します。
getSscPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getSscPrschg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getStRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始参照日付は変更できませんを取得します。
getStRefDateNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始参照日付は変更できませんを取得します。
getStUnQtyy1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を取得します。
getStUnQtyy1Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getStUnQtyy2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を取得します。
getStUnQtyy2Iso() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを取得します。
getStackFact() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
山積係数を取得します。
getStart() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト計画開始日付を取得します。
getStartOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用の開始オフセットを取得します。
getStartOffset() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用の開始オフセットを取得します。
getStartOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始オフセットは変更できませんを取得します。
getStartOffsetNoChg() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始オフセットは変更できませんを取得します。
getStartOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始のオフセット単位を取得します。
getStartOffsetUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始のオフセット単位を取得します。
getStartOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
getStartOffsetUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を取得します。
getStartRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始の参照日付を取得します。
getStartRefDate() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始の参照日付を取得します。
getStatCon() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
統計に適用する条件を取得します。
getStatCon() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
統計に適用する条件を取得します。
getStatDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
統計的納入期日を取得します。
getStatGroup() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
統計グループを取得します。
getStatProf() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータスプロファイルを取得します。
getStatistical() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
統計 WBS 要素を取得します。
getStatistical() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
統計 WBS 要素を取得します。
getStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンステータスを取得します。
getStatus() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票ステータスを取得します｡
getStatus() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
単一文字フラグを取得します。
getStatusDocOld() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
このバージョンの前の旧処理状況 (購買伝票内)を取得します。
getStatusInfoList() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
ステータス情報を取得します。
getStckType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
在庫タイプを取得します。
getStckType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫タイプを取得します。
getStdDescr() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
標準テキスト (ANSI、ISO など)を取得します。
getStdMaterialGetIntNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のメソッド
品目コード割当済一覧(結果)を取得します。
getStdMaterialGetIntNumberList() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
品目コード割当済一覧を取得します｡
getStdPrPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準標準原価を取得します。
getStdPrPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度標準原価を取得します。
getStdPrice() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
標準原価を取得します。
getStdTextKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の標準テキストキーを取得します。
getStdTextKey() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の標準テキストキーを取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
棚番を取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
棚番を取得します。
getStgeBin() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
棚番を取得します。
getStgeBinPc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を取得します。
getStgeBinSt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管場所を取得します。
getStgeLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
保管場所を取得します。
getStgeLocRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
保管場所の範囲を取得します。
getStgePdUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間の単位を取得します。
getStgePdUnIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの最長保管期間単位を取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管域タイプを取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
概略計画および詳細計画のピッキング保管域タイプを取得します。
getStgeType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管域タイプを取得します。
getStgeTypePc() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを取得します。
getStgeTypeSt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを取得します。
getStgeperiod() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間を取得します。
getStgesector() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管区画区分を取得します。
getStlocHigh() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
終了保管場所を取得します。
getStlocLow() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
開始保管場所を取得します。
getStockInd() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
特殊在庫区分を取得します。
getStorConds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
保管条件を取得します。
getStorCosts() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管経費区分を取得します。
getStorPct() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
残存有効期間割合 %を取得します。
getStorageLocationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (保管場所レベル)を取得します。
getStorageLocationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目データ (保管場所レベル)が既に存在するかチェックします。
getStorageLocationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (保管場所レベル)を取得します。
getStorageLocationselectList() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
保管場所の選択オプション一覧を取得します｡
getStorageTypeData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプデータを取得します。
getStorageTypeDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
保管域タイプデータが既に存在するかチェックします。
getStorageTypeDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
保管域タイプデータを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管ビューを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管ビューを取得します。
getStorageView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
保管ビューを取得します。
getStoragelocation() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管場所を取得します。
getStoragetype() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプを取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
保管場所を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
保管場所を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getStoreLoc() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
保管場所を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名の略称 (例: スペイン)を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名の略称 (例: スペイン)を取得します。
getStrAbbr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名の略称 (例: スペイン)を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 2を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 2を取得します。
getStrSuppl1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 2を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 3を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 3を取得します。
getStrSuppl2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 3を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 4を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 4を取得します。
getStrSuppl3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 4を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地名/番地-号を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を取得します。
getStreet() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地名/番地-号を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名を取得します。
getStreetLng() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStreetNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの地名コードを取得します。
getStructcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
構造条件を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI テーブル拡張の構造名を取得します。
getStructure() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を取得します。
getSuPlStck1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を取得します。
getSuPlStck2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産補助番号を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産補助番号を取得します。
getSubNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産補助番号を取得します。
getSubUom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
梱包階層の下位レベル数量単位を取得します。
getSubUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を取得します。
getSubitemint() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
副明細の明細間隔を取得します｡
getSubjToR() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認未完了を取得します。
getSubpckgNo() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サブパッケージ番号を取得します。
getSuccessList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
正常に処理された明細のテーブルを取得します。
getSuccessList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票の明細テーブルを取得します。
getSupSource() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
供給元を取得します。
getSupSource() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給元を取得します。
getSuppLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
補足明細を取得します。
getSuppVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
供給仕入先/仕入入庫を取得します。
getSupplPlnt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
在庫転送オーダーにおける供給(出庫)プラントを取得します｡
getSupplStloc() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出庫保管場所: 在庫転送オーダーを取得します。
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
供給仕入先を取得します｡
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
供給仕入先を取得します。
getSupplVend() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
供給仕入先を取得します。
getSupplierDetail() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
仕入先マスタ詳細情報を取得します｡
getSupplierExistenceCheck() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードチェック情報を取得します｡
getSupplierInfo() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
仕入先住所を取得します｡
getSupplyArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目マスタレコードで提案される供給場所を取得します。
getSvalidfrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスの有効開始日付を取得します。
getSyStDscr() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトステータスを取得します。
getSyStText() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を取得します。
getSysStatus() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
システムステータスを取得します。
getSystem() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージが発行された論理システムを取得します。
getSystemStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
システムステータステーブルを取得します。
getSystemStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
システムステータステーブルを取得します。
getTUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量単位 (ISO コード)を取得します。
getTUnitIso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaGlAccount() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定を取得します｡
getTaIndex() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を取得します｡
getTaItemnoAcc() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号を取得します｡
getTaTaxCode() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードを取得します｡
getTargetQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量（販売単位）を取得します。
getTargetQty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTargetQu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量 (数量単位)を取得します。
getTargetQu() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
目標値を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
累積計画金額を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を取得します。
getTargetVal() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaskListType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストタイプを取得します。
getTaxClass1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 2を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 3を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 4を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 5を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass5() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 6を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass6() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 7を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass7() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 8を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass8() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 9を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を取得します。
getTaxClass9() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
制御デ－タオブジェクトが既に存在するかチェックします。
getTaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
制御デ－タが既に存在するかチェックします。
getTaxClassificationsList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御デ－タを取得します。
getTaxClassificationsList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
制御デ－タを取得します。
getTaxCmlUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法/商法にもとづく評価額価格単位を取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
消費税コードを取得します。
getTaxCode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
消費税コードを取得します。
getTaxDepartCty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税出荷国を取得します。
getTaxDestCty() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税仕向国を取得します。
getTaxInd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税区分: 品目 (購買管理)を取得します。
getTaxType1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxType9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を取得します。
getTaxValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
税額を取得します。
getTaxValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を取得します。
getTaxValueItem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を取得します。
getTaxcl1Mat() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の税分類を取得します。
getTaxclass1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass4() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass5() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass6() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass7() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass8() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxclass9() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を取得します。
getTaxdepCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税出荷国を取得します。
getTaxdepCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxdstCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税仕向国を取得します。
getTaxdstCty() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
税管轄コードを取得します。
getTaxjurcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
税計算管轄コード - 税管轄コードを取得します。
getTaxlawicms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: ICMSを取得します。
getTaxlawicms() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxlawipi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: IPIを取得します。
getTaxlawipi() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTaxprice1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 1を取得します。
getTaxprice2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 2を取得します。
getTaxprice3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 3を取得します。
getTaxrCntry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
納税申告書の国を取得します。
getTeIndex() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
レコード番号を取得します｡
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第 1 電話番号: 内線を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第 1 電話番号: 内線を取得します。
getTel1Ext() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第 1 電話番号: 内線を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTel1Numbr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一電話番号: ダイヤルコード + 番号を取得します。
getTelebox() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレボックス番号を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先電話番号を取得します｡
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
電話番号を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 1を取得します。
getTelephone2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 2を取得します。
getTeletexNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレテクス番号を取得します。
getTelexNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレックス番号を取得します。
getTempConds() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
温度条件区分を取得します。
getTerminal() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 端末を取得します。
getTestRun() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テスト区分を取得します｡
getTestrun() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動シミュレーションを取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
書込 BAPI のシミュレーションセッションへの切替を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
シミュレーション実行 ('X')、更新実行 (' ')を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テスト実行を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テスト実行を取得します。
getTestrun() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テスト実行を取得します。
getTextDataInList() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求インタフェースの通信構造テキストを取得します。
getTextForm() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
タグ列を取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト IDを取得します。
getTextId() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト IDを取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト行を取得します。
getTextLine() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト行を取得します。
getTextName() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
名称を取得します。
getTextName() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
名称を取得します。
getTimeUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
時間計画単位を取得します。
getTimeUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
単位の ISO コードを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレスタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレスタイムゾーンを取得します。
getTimeZone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスタイムゾーンを取得します。
getTindex() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
数値項目: 長さ 6を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
敬称を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
タイトル (敬称)を取得します。
getTitle() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
敬称を取得します。
getTmpExist() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスパッケージの制限を取得します。
getTmpLimit() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細制限を取得します。
getTmpLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを取得します。
getTmpNolim() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデル仕様の制限なしを取得します。
getTmpNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細セット番号を取得します。
getTmpPckg() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを取得します。
getTmpPerc() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を取得します。
getTmpPrschg() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後通貨を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算後通貨を取得します。
getToCurrncy() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算後通貨を取得します。
getToFactor() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を取得します。
getToFactorV() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を取得します。
getToLine() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上限を取得します。
getTotalConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
品目総消費量のデータ転送が既に存在するかチェックします。
getTotalConsumptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目総消費量のデータ転送を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画日付を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画日付を取得します。
getTpDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を取得します。
getTpTime() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTrEvType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
トランザクション/イベントタイプを取得します。
getTrEvTypeRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
トランザクション/イベントタイプの範囲を取得します。
getTrPartBa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引会社事業領域を取得します。
getTrackingno() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼追跡番号を取得します。
getTracklimit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
警告限界を取得します。
getTrans() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
取引を取得します。
getTransGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
輸送グループを取得します。
getTransactionGroup() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
一文字フラグを取得します。
getTransportMode() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
貿易管理の輸送モードを取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
商品の納入区域を取得します。
getTranspzone() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
商品の納入区域を取得します。
getTrendAnalysisIndicator() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
傾向分析の関連マイルストーンを取得します。
getTrendValue() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
傾向値を取得します。
getTrendValuePp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の傾向値を取得します。
getTrgQtyNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を取得します。
getTrgQtyNo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTrgqtyDen() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を取得します。
getTrgqtyDen() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getTwoStepPick() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ツーステップピッキング適用品目を取得します。
getType() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
getType() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を取得します。
getUnWork() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業単位を取得します。
getUnWorkIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUnddlvTol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
不足納入許容範囲リミットを取得します。
getUnddlvTol() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnderDlvTol() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
不足納入許容範囲リミットを取得します。
getUnderTol() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
不足納入許容範囲リミットを取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
発注単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
表示数量単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
表示数量単位を取得します。
getUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
表示数量単位を取得します。
getUnitDim() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
寸法単位 (長さ/幅/高さ)を取得します。
getUnitDimIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの長さ、幅、高さの単位を取得します。
getUnitGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
数量単位グループを取得します。
getUnitGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
数量単位グループを取得します。
getUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
ISO コードでの表示数量単位を取得します。
getUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
ISO コードでの表示数量単位を取得します。
getUnitOfWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位を取得します。
getUnitOfWt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
重量単位を取得します。
getUnitOfWtIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位を取得します。
getUnitOfWtIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの重量単位を取得します。
getUnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
数量単位オブジェクトが既に存在するかチェックします。
getUnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
数量単位が既に存在するかチェックします。
getUnitSofmeasureList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位を取得します。
getUnitSofmeasureList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
数量単位を取得します。
getUnitmeasur() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件スケール単位を取得します。
getUnitmeasur() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件スケール単位を取得します。
getUnitmeasurIso() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
単位の ISO コードを取得します。
getUnittype1() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第１保管単位タイプを取得します。
getUnittype1() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを取得します。
getUnittype2() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第２保管単位タイプを取得します。
getUnittype2() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを取得します。
getUnittype3() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第３保管単位タイプを取得します。
getUnlimited() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlimitedDlv() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlmtDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
区分: 無制限過剰納入可能を取得します。
getUnlmtDlv() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
荷渡ポイントを取得します。
getUnloadPt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
荷渡ポイントを取得します。
getUnloadPtx() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUnofWtiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの重量単位を取得します。
getUnplndConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
計画外消費のデータ転送が既に存在するかチェックします。
getUnplndConsumptionList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
計画外消費のデータ転送を取得します。
getUntilDate() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数日付を取得します。
getUntofWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
重量単位を取得します。
getUntofWght() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUomIso() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
単位の ISO コードを取得します。
getUomsortnumber() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
数量単位ソート番号を取得します。
getUomusage() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
使用数量単位を取得します。
getUp() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getUpdateGrp() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
統計更新の更新グループを取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
更新区分を取得します。
getUpdateflag() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
更新区分を取得します。
getUsStDscr() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトステータスを取得します。
getUsStNumb() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータス番号を取得します。
getUsStText() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を取得します。
getUsageInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
未使用 - 予約長 3を取得します。
getUsageInd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getUseExceptions() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
例外メッセージ設定とエラーメッセージ出力を取得します。
getUserFieldChar10_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を取得します。
getUserFieldChar10_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 3 ユーザ項目 - WBS 要素を取得します。
getUserFieldChar10_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を取得します。
getUserFieldChar10_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 4 ユーザ項目 - WBS 要素を取得します。
getUserFieldChar20_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を取得します。
getUserFieldChar20_1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 文字の第 1 ユーザ項目 - WBS 要素 -を取得します。
getUserFieldChar20_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を取得します。
getUserFieldChar20_2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 桁の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldCuky1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を取得します。
getUserFieldCuky1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
getUserFieldCuky1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を取得します。
getUserFieldCuky2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
getUserFieldCuky2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを取得します。
getUserFieldCuky2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを取得します。
getUserFieldCurr1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を取得します。
getUserFieldCurr1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldCurr2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を取得します。
getUserFieldCurr2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldDate1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を取得します。
getUserFieldDate1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 1 ユーザ項目 - WBS 要素を取得します。
getUserFieldDate2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を取得します。
getUserFieldDate2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldFlag1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を取得します。
getUserFieldFlag1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 1 ユーザ項目 - WBS 要素を取得します。
getUserFieldFlag2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を取得します。
getUserFieldFlag2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 2 ユーザ項目 - WBS 要素を取得します。
getUserFieldKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目のキーワード IDを取得します。
getUserFieldKey() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ユーザ定義項目のキーワード IDを取得します。
getUserFieldQuan1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を取得します。
getUserFieldQuan1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldQuan2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を取得します。
getUserFieldQuan2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を取得します。
getUserFieldUnit1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を取得します。
getUserFieldUnit1() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第１ユーザ定義項目 - WBS 要素を取得します。
getUserFieldUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUserFieldUnit1Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getUserFieldUnit2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を取得します。
getUserFieldUnit2() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第２ユーザ定義項目 - WBS 要素を取得します。
getUserFieldUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを取得します。
getUserFieldUnit2Iso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getUserNameRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ユーザ名の範囲を取得します。
getUserStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ユーザステータス/指図ステータステーブルを取得します。
getUserStatusList() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ユーザステータス/指図ステータステーブルを取得します。
getUserf1Num() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf1Txt() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf2Num() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUserf2Txt() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を取得します。
getUsername() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を取得します。
getUsrStatus() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ユーザステータスを取得します。
getValArea() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価レベルを取得します。
getValCat() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価カテゴリを取得します。
getValClass() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価クラスを取得します。
getValConI() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約明細を取得します。
getValConI() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約番号を取得します。
getValContr() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValRatio() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を取得します。
getValSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注明細を取得します。
getValSOrdItem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注明細を取得します。
getValSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注番号を取得します。
getValSalesOrd() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注番号を取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
評価タイプを取得します。
getValType() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getValWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を取得します。
getValWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を取得します。
getValcode() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
値タイプ: 範囲制限 - 単一値を取得します。
getValcount() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層ノード内の値の値数を取得します。
getValfrom() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
エントリの有効開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チェーン別品目ステータスの有効期間開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価有効開始日を取得します。
getValidFrom() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約の有効開始日を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を取得します｡
getValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタを指定して有効終了日を取得します。
getValidTo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約有効終了日を取得します。
getValto() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを取得します。
getValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価データを取得します。
getValuationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
評価データが既に存在するかチェックします。
getValuationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
評価データを取得します。
getValuationarea() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価レベルを取得します。
getValuationtype() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価タイプを取得します。
getValue() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
CO-PA 特性値を取得します。
getValue() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を取得します。
getValueChanged() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンによる金額変更を取得します。
getValueTo() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を取得します。
getValueTxt() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値の言語依存テキストを取得します。
getValueduom() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ロット特定数量単位での評価を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart1() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart2() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart3() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
長さ 229 の文字データのコンテナを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
長さ 229 の文字データのコンテナを取得します。
getValuepart4() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を取得します。
getVarOrdUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
可変購買発注単位有効を取得します。
getVarSalesUn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
可変販売単位の使用不可を取得します。
getVarcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
バリアント条件を取得します。
getVarcond() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
バリアント条件を取得します。
getVarianceKey() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
差異キーを取得します。
getVatCntry() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
売上税 ID 番号国を取得します。
getVatCntryIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
消費税登録番号の ISO 国コードを取得します。
getVclassPp() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期評価クラスを取得します。
getVclassPy() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の評価クラスを取得します。
getVendMat() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
仕入先が使用している品目コードを取得します。
getVendName() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
名称 1を取得します。
getVendPart() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先部門を取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先勘定コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードを取得します｡
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
仕入先勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先勘定コードを取得します。
getVendorNo() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
仕入先または債権者の勘定コードを取得します。
getVendorRaList() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
仕入先の範囲を取得します。
getVendrbatch() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先ロット番号を取得します。
getVendrbatch() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先ロット番号を取得します。
getVerGrGiSlip() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票の印刷バ－ジョンを取得します。
getVerGrGiSlipx() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるバージョン番号を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票バージョン番号を取得します。
getVersion() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVersionFlag() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
バージョン区分を取得します。
getVersions() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
バージョン管理を取得します｡
getVirtCard() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
チェックボックスを取得します。
getVkey() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件名を取得します。
getVmPStock() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
プロジェクト在庫の評価クラスを取得します。
getVmSoStk() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
受注在庫の評価クラスを取得します。
getVolTolLt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の容積超過許容量を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総数量を取得します。
getVolume() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVolumeunit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積単位を取得します。
getVolumeunit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積単位を取得します。
getVolumeunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ISO コードでの容積単位を取得します。
getVolumeunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの容積単位を取得します。
getVolunit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
容積単位を取得します。
getVolunit() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getVolunitiso() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの容積単位を取得します。
getVperEnd() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間終了日を取得します｡
getVperStart() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間開始日を取得します｡
getVwUepos() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細用途 IDを取得します。
getVwUepos() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWagetype() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ウェイジタイプを取得します。
getWarDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
保証期間の開始日付を取得します。
getWarDate() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWarehouseNumberData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号データを取得します。
getWarehouseNumberDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
倉庫番号データが既に存在するかチェックします。
getWarehouseNumberDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
倉庫番号データを取得します。
getWarehouseView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
倉庫管理ビューを取得します。
getWarehouseView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
倉庫管理ビューを取得します。
getWarehousenumber() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号/複合倉庫を取得します。
getWarranty() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
保証日を取得します｡
getWbsAccountAssignmentElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 勘定設定要素を取得します。
getWbsActualDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
実績 WBS 要素日付の期間単位を取得します。
getWbsActualDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsActualDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績長(期間)を取得します。
getWbsActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績終了日を取得します。
getWbsActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績開始日付を取得します。
getWbsBasicDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
基準 WBS 要素日付の期間単位を取得します。
getWbsBasicDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsBasicDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の基準日の長さ(期間)を取得します。
getWbsBasicFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本終了日付を取得します。
getWbsBasicStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本開始日を取得します。
getWbsBillingElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 請求要素を取得します。
getWbsCctrPostedActual() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価が実際に転記される原価センタを取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業詳細項目要素 (WBS 要素)を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
WBS 要素を取得します。
getWbsElem() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
WBS 要素を取得します。
getWbsElement() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
WBS 要素を取得します。
getWbsElementExt() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
WBS 要素を取得します。
getWbsForcastDurUnit() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素計画日付の単位を取得します。
getWbsForecastDurUnitIso() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを取得します。
getWbsForecastDuration() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測期間を取得します。
getWbsForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測済終了日付を取得します。
getWbsForecastStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測開始日を取得します。
getWbsPlanningElement() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 計画要素を取得します。
getWbsScdActualFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績終了日を取得します。
getWbsScdActualStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績開始日を取得します。
getWbsScdBasicFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (基準)を取得します。
getWbsScdBasicStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最早計画開始日 (基準)を取得します。
getWbsScdForecastFinishDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (予測)を取得します。
getWbsScdForecastStartDate() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
計画開始日 (予測)を取得します。
getWbsSchedProfile() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 日程計画のプロファイルを取得します。
getWeightunit() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位を取得します。
getWeightunitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位のISOコードを取得します。
getWhseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
倉庫番号/複合倉庫を取得します。
getWhseNo() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫番号/複合倉庫を取得します。
getWidth() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
幅を取得します。
getWithActivities() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属活動を取得します。
getWithActivities() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属活動を取得します。
getWithMilestones() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属 WBS マイルストーンを取得します。
getWithMilestones() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属 WBS マイルストーンを取得します。
getWithSubtree() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
サブプロジェクトを取得します。
getWithSubtree() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
サブプロジェクトを取得します。
getWithdrawal() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫払出に対する保管域タイプ区分を取得します。
getWithdrawn() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定に対する出庫完了を取得します。
getWithdrawn() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定に対する出庫完了を取得します。
getWmUnit() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の数量単位を取得します。
getWmUnitIso() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの倉庫管理単位を取得します。
getWmdvexList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
出力テーブル (日付および ATP 数量)を取得します。
getWmdvsxList() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
入力テーブル (日付/数量)を取得します。
getWorkActivity() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動に含まれる作業を取得します。
getWorkActual() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績作業を取得します。
getWorkCntr() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業区を取得します。
getWorkForecast() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測作業 (実績 + 残存)を取得します。
getWorkPermit() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
仕事許可済フラグを取得します。
getWorkSchedView() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
作業計画ビューを取得します。
getWorkSchedView() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
作業計画ビューを取得します。
getWtTolLt() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の重量超過許容量を取得します。
getWtWithcd() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
源泉徴収税コードを取得します。
getWtgGroup() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
加重グループを取得します。
getXAutoCre() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
自動登録済み明細を取得します。
getXstob() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消移動タイプ区分の使用を取得します。
getYline() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
内部テ－ブル処理の行索引を取得します。

H

HeadData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData.
管理情報設定ヘッダセグメント情報クラス
機能は以下の通り
管理情報設定ヘッダセグメント情報を保持します。
HeadData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のコンストラクタ
管理情報設定ヘッダセグメント情報を作成します。
HeadData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のコンストラクタ
管理情報設定ヘッダセグメント情報を作成します。
HeaderIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn.
販売伝票ヘッダデータ情報クラス
機能は以下の通り
販売伝票ヘッダデータ情報を保持します。
HeaderIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のコンストラクタ
販売伝票ヘッダデータ情報を作成します。
HeaderInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX.
ヘッダデータチェックボックス情報クラス
機能は以下の通り
ヘッダデータチェックボックス情報を保持します。
HeaderInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のコンストラクタ
ヘッダデータチェックボックス情報を作成します。
HierarchyNodes - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes.
階層ノード情報クラス 機能は以下の通り
階層ノード情報を保持します。
HierarchyNodes() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のコンストラクタ
階層ノードを作成します。
HierarchyValues - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues.
階層値情報クラス 機能は以下の通り
階層値情報を保持します。
HierarchyValues() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のコンストラクタ
階層値を作成します。

I

ImpWbsElement - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement.
詳細情報を必要とする WBS 要素クラス 機能は以下の通り
詳細情報を必要とする WBS 要素を保持します。
ImpWbsElement() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のコンストラクタ
詳細情報を必要とする WBS 要素を作成します。
ImpWbsElement(int) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のコンストラクタ
詳細情報を必要とする WBS 要素を作成します。
InquiryCreateFromData2 - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2.
引合伝票登録情報クラス
機能は以下の通り
引合伝票登録情報を保持します。
InquiryCreateFromData2() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
コンストラクタ。
InquiryCreateFromData2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
InquiryCreateFromData2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
InquiryCreateFromData2Controller - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller.
引合伝票登録コントローラクラス
機能は以下の通り
引合伝票を登録します。
InquiryCreateFromData2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InquiryCreateFromData2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のコンストラクタ
InquiryCreateFromData2Controllerのコンストラクタを生成します。
InternalOrderGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail.
内部指図書詳細情報取得クラス
機能は以下の通り
内部指図書詳細情報を取得します。
InternalOrderGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のコンストラクタ
内部指図書詳細情報を作成します。
InternalOrderGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のコンストラクタ

InternalOrderGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController.
内部指図書詳細コントローラクラス
機能は以下の通り
内部指図書詳細を取得します。
InternalOrderGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ

InternalOrderGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ

InternalOrderGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のコンストラクタ
InternalOrderGetDetailControllerのコンストラクタを生成します。
InternalOrderGetList - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList.
内部指図書（一覧）情報取得クラス
機能は以下の通り
内部指図書（一覧）情報を取得します。
InternalOrderGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のコンストラクタ
内部指図書（一覧）情報を作成します。
InternalOrderGetList(String, String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のコンストラクタ

InternalOrderGetListController - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController.
内部指図書一覧コントローラクラス
機能は以下の通り
内部指図書一覧を取得します。
InternalOrderGetListController(String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ

InternalOrderGetListController(String, String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ

InternalOrderGetListController() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ
InternalOrderGetListControllerのコンストラクタを生成します。
InternalOrderGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のコンストラクタ
InternalOrderGetListControllerのコンストラクタを生成します。
InternationArticleNumbers - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers.
EAN情報クラス
機能は以下の通り
EAN情報を保持します。
InternationArticleNumbers() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のコンストラクタ
EAN情報を作成します。
InternationArticleNumbers(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のコンストラクタ
EAN情報を作成します。
InternationalArtnos - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos.
国際商品コード (EAN)情報クラス
機能は以下の通り
国際商品コード (EAN)情報を保持します。
InternationalArtnos() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のコンストラクタ
国際商品コード (EAN)情報を作成します。
InternationalArtnos(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のコンストラクタ
国際商品コード (EAN)情報を作成します。
ItemsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn.
明細データ情報クラス
機能は以下の通り
明細データ情報を保持します。
ItemsIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のコンストラクタ
明細データ情報を作成します。
ItemsIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のコンストラクタ
明細データ情報を作成します。
ItemsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX.
明細データチェックボックス情報クラス
機能は以下の通り
明細データチェックボックス情報を保持します。
ItemsInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のコンストラクタ
明細データチェックボックス情報を作成します。
ItemsInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のコンストラクタ
明細データチェックボックス情報を作成します。
initMaterialGetAll() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ照会情報を作成します。
initMaterialSaveReplica() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ更新情報の各種インスタンスを生成します。

J

jp.co.intra_mart.foundation.sap.module - package jp.co.intra_mart.foundation.sap.module

jp.co.intra_mart.foundation.sap.module.accounting - package jp.co.intra_mart.foundation.sap.module.accounting
ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception - package jp.co.intra_mart.foundation.sap.module.accounting.exception
ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception - package jp.co.intra_mart.foundation.sap.module.exception

jp.co.intra_mart.foundation.sap.module.financial - package jp.co.intra_mart.foundation.sap.module.financial
ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception - package jp.co.intra_mart.foundation.sap.module.financial.exception
ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase - package jp.co.intra_mart.foundation.sap.module.purchase
ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model - package jp.co.intra_mart.foundation.sap.module.purchase.common.model

jp.co.intra_mart.foundation.sap.module.purchase.exception - package jp.co.intra_mart.foundation.sap.module.purchase.exception
ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate - package jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems - package jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

jp.co.intra_mart.foundation.sap.module.purchase.materialavailability - package jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

jp.co.intra_mart.foundation.sap.module.purchase.materialgetall - package jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica - package jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber - package jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

jp.co.intra_mart.foundation.sap.module.sales - package jp.co.intra_mart.foundation.sap.module.sales

jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple - package jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail - package jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist - package jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

jp.co.intra_mart.foundation.sap.module.sales.common.model - package jp.co.intra_mart.foundation.sap.module.sales.common.model

jp.co.intra_mart.foundation.sap.module.sales.exception - package jp.co.intra_mart.foundation.sap.module.sales.exception

jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 - package jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist - package jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus - package jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

K

Keys - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys.
参照キーの出力テーブル情報クラス
機能は以下の通り
参照キーの出力テーブル情報を保持します。
Keys() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のコンストラクタ
参照キーの出力テーブル情報を作成します。
Keys(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のコンストラクタ
参照キーの出力テーブル情報を作成します。

L

LifoValuationData - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData.
LIFO 関連品目データ情報クラス
機能は以下の通り
LIFO 関連品目データ情報を保持します。
LifoValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のコンストラクタ
LIFO 関連品目データ情報を作成します。
Limits - class jp.co.intra_mart.foundation.sap.module.purchase.Limits.
外注制限情報クラス
機能は以下の通り
外注制限情報を保持します。
Limits() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のコンストラクタ
外注制限を作成します。
Limits(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のコンストラクタ
外注制限を作成します。
LogicSwitch - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch.
内部制御パラメータ情報クラス
機能は以下の通り
内部制御パラメータ情報を保持します。
LogicSwitch() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のコンストラクタ
内部制御パラメータ情報を作成します。

M

ManufacturerPartNumb - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb.
製造業者と製造者製品コードクラス
機能は以下の通り
製造業者と製造者製品コードの情報を保持します。
ManufacturerPartNumb() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のコンストラクタ
製造業者と製造者製品コード情報を作成します。
ManufacturerPartNumb(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のコンストラクタ
製造業者と製造者製品コード情報を作成します。
MasterData - class jp.co.intra_mart.foundation.sap.module.financial.MasterData.
指図のマスタデータ構造情報クラス 機能は以下の通り
指図のマスタデータ構造情報を保持します。
MasterData() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のコンストラクタ
指図のマスタデータ構造を作成します。
MaterialAvailability - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability.
品目在庫確認情報クラス
機能は以下の通り
品目在庫確認情報を保持します。
MaterialAvailability(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のコンストラクタ
品目在庫確認情報を作成します。
MaterialAvailabilityController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController.
品目在庫確認コントローラクラス
機能は以下の通り
在庫情報を取得します。
MaterialAvailabilityController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のコンストラクタ
コンストラクタ生成
MaterialAvailabilityController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のコンストラクタ
コンストラクタ生成
MaterialDescription - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription.
品目テキスト情報クラス
機能は以下の通り
品目テキスト情報を保持します。
MaterialDescription() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のコンストラクタ
品目テキスト情報を作成します。
MaterialDescription(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のコンストラクタ
品目テキスト情報を作成します。
MaterialGetAll - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll.
品目マスタ照会情報クラス
機能は以下の通り
品目マスタ照会情報を保持します。
MaterialGetAll(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のコンストラクタ
品目マスタ照会情報を作成します。
MaterialGetAll(String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のコンストラクタ
品目マスタ照会情報を作成します。
MaterialGetAllController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController.
品目マスタ照会コントローラクラス
機能は以下の通り
品目マスタの情報を取得します。
MaterialGetAllController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
コンストラクタ生成
MaterialGetAllController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
コンストラクタ生成
MaterialGetAllController(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetAllController(String, String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のコンストラクタ
MaterialGetallのコンストラクタを呼び出し品目マスタ照会情報を取得します。
MaterialGetList - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList.
品目コード検索クラス
機能は以下の通り
品目コード、テキストを検索します。
MaterialGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のコンストラクタ
品目コードの選択オプション一覧、品目テキストの選択オプション一覧、 製造業者と製造者製品コード一覧、プラントの選択オプション一覧、 保管場所の選択オプション一覧、販売組織の選択オプション一覧、 流通チャネルの選択オプション一覧、品目コードと品目テキスト一覧を作成します｡
MaterialGetListController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController.
品目コード検索コントローラクラス
機能は以下の通り
品目コード、テキストを検索します。
MaterialGetListController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のコンストラクタ
MaterialGetListのコンストラクタを生成します。
MaterialGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController のコンストラクタ
MaterialGetListのコンストラクタを生成します。
MaterialLongText - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText.
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialLongText() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のコンストラクタ
テキスト (長)情報を作成します。
MaterialLongText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のコンストラクタ
テキスト (長)情報を作成します。
MaterialRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa.
品目コードの範囲情報クラス
機能は以下の通り
品目コードの範囲情報を保持します。
MaterialRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のコンストラクタ
品目コードの範囲情報を作成します。
MaterialRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のコンストラクタ
品目コードの範囲情報を作成します。
MaterialSaveReplica - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica.
品目マスタ更新情報クラス
機能は以下の通り
品目マスタ更新情報を保持します。
MaterialSaveReplica() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplica(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplica(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のコンストラクタ
品目マスタ更新情報を作成します。
MaterialSaveReplicaController - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController.
品目マスタ更新コントローラクラス
機能は以下の通り
品目マスタを更新します。
MaterialSaveReplicaController() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialSaveReplicaController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialSaveReplicaController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のコンストラクタ
コンストラクタ生成
MaterialShortDescsel - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel.
品目テキストの選択オプションクラス
機能は以下の通り
品目テキストの選択オプションの情報を保持します。
MaterialShortDescsel() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のコンストラクタ
品目テキストの選択オプション情報を作成します。
MaterialShortDescsel(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のコンストラクタ
品目テキストの選択オプション情報を作成します。
MaterialText - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText.
テキスト (長)情報クラス
機能は以下の通り
テキスト (長)情報を保持します。
MaterialText() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のコンストラクタ
テキスト (長)情報を作成します。
MaterialText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のコンストラクタ
テキスト (長)情報を作成します。
MatnrList - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList.
品目コードと品目テキストの一覧クラス
機能は以下の通り
品目コードと品目テキストの一覧の情報を保持します。
MatnrList() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のコンストラクタ
品目コードと品目テキストの一覧情報を作成します。
MatnrSelection - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection.
品目コードの選択オプションクラス
機能は以下の通り
品目コードの選択オプションの情報を保持します。
MatnrSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のコンストラクタ
品目コードの選択オプション情報を作成します。
MatnrSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のコンストラクタ
品目コードの選択オプション情報を作成します。
MoveTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa.
移動タイプの範囲情報クラス
機能は以下の通り
移動タイプの範囲情報を保持します。
MoveTypeRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のコンストラクタ
移動タイプの範囲情報を作成します。
MoveTypeRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のコンストラクタ
移動タイプの範囲情報を作成します。

O

OrderCcard - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard.
クレジットカードデータ情報クラス
機能は以下の通り
クレジットカードデータ情報を保持します。
OrderCcard() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のコンストラクタ
クレジットカードデータ情報を作成します。
OrderCcard(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のコンストラクタ
クレジットカードデータ情報を作成します。
OrderList - class jp.co.intra_mart.foundation.sap.module.financial.OrderList.
選択指図一覧情報クラス 機能は以下の通り
選択指図一覧情報を保持します。
OrderList() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のコンストラクタ
選択指図一覧を作成します。

P

ParamAllVersions - class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions.
全バージョンパラメータ設定クラス
機能は以下の通り
全バージョンのパラメータを設定します。
ParamBatchRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa.
ロットの範囲パラメータ設定クラス
機能は以下の通り
ロットの範囲のパラメータを設定します。
ParamBillingDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn.
処理予定明細データのテーブルパラメータ設定クラス
機能は以下の通り
処理予定明細データのテーブルパラメータを設定します。
ParamBillingDocumentDetailList - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList.
後続請求伝票のテーブルパラメータ設定クラス
機能は以下の通り
後続請求伝票のテーブルのパラメータを設定します。
ParamCCardDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn.
処理予定支払方法のテーブルパラメータ設定クラス
機能は以下の通り
処理予定支払方法のテーブルパラメータを設定します。
ParamCfgsBlob - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob.
選定: BLOB 内部データ (SCE)パラメータ設定クラス
機能は以下の通り
選定: BLOB 内部データ (SCE)のパラメータを設定します。
ParamCfgsInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst.
選定: インスタンスパラメータ設定クラス
機能は以下の通り
選定: インスタンスのパラメータを設定します。
ParamCfgsPartOf - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf.
選定: 部分設定パラメータ設定クラス
機能は以下の通り
選定: 部分設定のパラメータを設定します。
ParamCfgsRef - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef.
選定: 参照データパラメータ設定クラス
機能は以下の通り
選定: 参照データのパラメータを設定します。
ParamCfgsRefInst - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst.
選定: 参照明細/インスタンスパラメータ設定クラス
機能は以下の通り
選定: 参照明細/インスタンスのパラメータを設定します。
ParamCfgsValue - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue.
選定: 特性値パラメータ設定クラス
機能は以下の通り
選定: 特性値のパラメータを設定します。
ParamCfgsVk - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk.
選定: バリアント条件キーパラメータ設定クラス
機能は以下の通り
選定: バリアント条件キーのパラメータを設定します。
ParamClientDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList.
品目データ (クライアントレベル)パラメータ設定クラス
機能は以下の通り
品目データ (クライアントレベル)パラメータを設定します。
ParamCondHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader.
条件ヘッダパラメータ設定クラス
機能は以下の通り
条件ヘッダのパラメータを設定します。
ParamCondItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem.
条件明細パラメータ設定ラクラス
機能は以下の通り
条件明細のパラメータを設定します。
ParamConditionDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn.
処理予定条件のテーブルパラメータ設定クラス
機能は以下の通り
処理予定条件のテーブルのパラメータを設定します。
ParamConditionsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn.
条件パラメータ設定クラス
機能は以下の通り
条件のパラメータを設定します。
ParamConditionsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX.
受注における条件更新の通信項目パラメータ設定クラス
機能は以下の通り
受注における条件更新の通信項目のパラメータを設定します。
ParamContractLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits.
外注基本契約制限パラメータ設定クラス
機能は以下の通り
外注基本契約制限のパラメータを設定します。
ParamContractService - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService.
外注サービスパラメータ設定クラス
機能は以下の通り
外注サービスのパラメータを設定します。
ParamContractServiceAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount.
外注サービス勘定設定パラメータ設定クラス
機能は以下の通り
外注サービス勘定設定のパラメータを設定します。
ParamContractServiceText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText.
外注サービステキストパラメータ設定クラス
機能は以下の通り
外注サービステキストのパラメータを設定します。
ParamCreatorDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn.
取り込まれる日付の順序パラメータ設定クラス
機能は以下の通り
取り込まれる日付の順序のパラメータを設定します。
ParamDeliveryAddress - class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress.
入荷伝票アドレスパラメータ設定ラクラス
機能は以下の通り
入荷伝票アドレスのパラメータを設定します。
ParamErrors - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors.
前明細の不正処理に関する情報パラメータ設定クラス
機能は以下の通り
前明細の不正処理に関する情報のパラメータを設定します。
ParamExportHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader.
貿易管理ヘッダパラメータ設定ラクラス
機能は以下の通り
貿易管理ヘッダのパラメータを設定します。
ParamExportItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem.
貿易管理明細インポートパラメータ設定クラス
機能は以下の通り
貿易管理明細のパラメータを設定します。
ParamExtension - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension.
拡張得意先項目パラメータ設定クラス
機能は以下の通り
拡張得意先項目のパラメータを設定します。
ParamExtensionIn - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn.
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造パラメータ設定クラス
機能は以下の通り
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造のパラメータを設定します。
ParamExtensionIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn.
VBAK、VBAP、VBEP のカスタマ拡張パラメータ設定クラス
機能は以下の通り
VBAK、VBAP、VBEP のカスタマ拡張のパラメータを設定します。
ParamExtensionInX - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX.
拡張イン/拡張アウトのチェックボックス構造パラメータ設定クラス
機能は以下の通り
拡張イン/拡張アウトのチェックボックス構造のパラメータを設定します。
ParamForecastParametersList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList.
需要予測パラメータ設定クラス
機能は以下の通り
需要予測パラメータのパラメータを設定します。
ParamForecastValues - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues.
需要予測値のデータ転送パラメータ設定クラス
機能は以下の通り
需要予測値のデータ転送のパラメータを設定します。
ParamGoodsMvtCode - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode.
在庫移動に対するコードのトランザクションへの割当パラメータ設定クラス
機能は以下の通り
在庫移動に対するコードのトランザクションへの割当のパラメータを設定します。
ParamGoodsMvtHeader - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader.
入出庫伝票ヘッダデータ設定クラス
機能は以下の通り
入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtHeaderList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList.
リターン構造、入出庫伝票ヘッダパラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票ヘッダのパラメータを設定します。
ParamGoodsMvtHeadret - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret.
入出庫伝票ヘッダデータパラメータ設定クラス
機能は以下の通り
入出庫伝票ヘッダデータのパラメータを設定します。
ParamGoodsMvtItem - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem.
リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtItems - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems.
リターン構造、入出庫伝票明細パラメータ設定クラス
機能は以下の通り
リターン構造、入出庫伝票明細のパラメータを設定します。
ParamGoodsMvtSerialNumber - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber.
シリアル番号パラメータ設定クラス
機能は以下の通り
シリアル番号のパラメータを設定します。
ParamHeadData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData.
管理情報設定ヘッダセグメントパラメータ設定クラス
機能は以下の通り
管理情報設定ヘッダセグメントのパラメータを設定します。
ParamHeader - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader.
伝票ヘッダパラメータ設定クラス
機能は以下の通り
伝票ヘッダのインポートパラメータを設定します。
ParamHeaderIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn.
販売伝票ヘッダデータセグメントパラメータ設定クラス
機能は以下の通り
販売伝票ヘッダデータのパラメータを設定します。
ParamHeaderInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX.
ヘッダデータチェックボックスパラメータ設定クラス
機能は以下の通り
ヘッダデータチェックボックスのパラメータを設定します。
ParamHeaderText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText.
ヘッダテキストパラメータ設定クラス
機能は以下の通り
ヘッダテキストのパラメータを設定します。
ParamInternationalArtnos - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos.
国際商品コード (EAN)パラメータ設定クラス
機能は以下の通り
国際商品コード (EAN)のパラメータを設定します。
ParamItem - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem.
明細パラメータ設定クラス
機能は以下の通り
明細のパラメータを設定します。
ParamItemText - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText.
明細テキストパラメータ設定クラス
機能は以下の通り
明細テキストのパラメータを設定します。
ParamItemsIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn.
明細データパラメータ設定クラス
機能は以下の通り
明細データのパラメータを設定します。
ParamItemsInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX.
明細データチェックボックス のパラメータ設定クラス
機能は以下の通り
明細データチェックボックスのパラメータを設定します。
ParamKeys - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys.
参照キーパラメータ設定クラス
機能は以下の通り
参照キーのパラメータを設定します。
ParamLimits - class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits.
外注制限パラメータ設定クラス
機能は以下の通り
外注制限のパラメータを設定します。
ParamLogicSwitch - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch.
内部制御パラメータパラメータ設定クラス
機能は以下の通り
内部制御パラメータのパラメータを設定します。
ParamMaterialDescription - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription.
品目テキストパラメータ設定クラス
機能は以下の通り
品目テキストのパラメータを設定します。
ParamMaterialLongText - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText.
テキスト (長)パラメータ設定クラス
機能は以下の通り
テキスト (長)のパラメータを設定します。
ParamMaterialRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa.
品目コードの範囲パラメータ設定クラス
機能は以下の通り
品目コードの範囲のパラメータを設定します。
ParamMoveTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa.
移動タイプの範囲パラメータ設定クラス
機能は以下の通り
移動タイプの範囲のパラメータを設定します。
ParamOrderCcard - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard.
クレジットカードデータ情報パラメータ設定クラス
機能は以下の通り
クレジットカードデータ情報のパラメータを設定します。
ParamPartner - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner.
得意先インポートパラメータ設定クラス
機能は以下の通り
得意先のパラメータを設定します。
ParamPartnerAddresses - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses.
アドレス (組織/会社) 用 BAPI 参照構造パラメータ設定クラス
機能は以下の通り
アドレス (組織/会社) 用 BAPI 参照構造のパラメータを設定します。
ParamPartners - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners.
伝票取引先パラメータ設定クラス
機能は以下の通り
伝票取引先のパラメータを設定します。
ParamPlanningDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList.
品目マスタ/製品グループの変更伝票構造パラメータ設定クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造のパラメータを設定します。
ParamPlantDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList.
品目データ (プラントレベル)パラメータ設定クラス
機能は以下の通り
品目データ (プラントレベル)のパラメータを設定します。
ParamPlantRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa.
プラントの範囲パラメータ設定クラス
機能は以下の通り
プラントの範囲のパラメータを設定します。
ParamProfitSegment - class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment.
入出庫予定パラメータ設定クラス
機能は以下の通り
入出庫予定のパラメータを設定します。
ParamPrtData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData.
品目マスタの生産資源/治工具 (PRT) 項目パラメータ設定クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目のパラメータを設定します。
ParamPstngDateRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa.
登録日付の範囲パラメータ設定クラス
機能は以下の通り
登録日付の範囲のパラメータを設定します。
ParamPurchaseAccount - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount.
勘定設定パラメータ設定クラス
機能は以下の通り
勘定設定のパラメータを設定します。
ParamPurchaseSchedule - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule.
納入日程パラメータ設定クラス
機能は以下の通り
納入日程のパラメータを設定します。
ParamRefDocRange - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange.
前伝票の範囲パラメータ設定クラス
機能は以下の通り
前伝票の範囲のパラメータを設定します。
ParamReturnMessages - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages.
リターンパラメータ BAPIRET2 の代替構造項目パラメータ設定クラス
機能は以下の通り
リターンパラメータ BAPIRET2 の代替構造項目のパラメータをセットします。
ParamSalesDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList.
倉庫番号データパラメータ設定クラス
機能は以下の通り
倉庫番号データのパラメータを設定します。
ParamSalesOrders - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders.
得意先受注テーブル情報パラメータ設定クラス
機能は以下の通り
得意先受注テーブル情報のパラメータを設定します。
ParamSchedulesIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn.
納入日程行パラメータ設定クラス
機能は以下の通り
納入日程行のパラメータを設定します。
ParamSchedulesInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX.
納入日程行チェックボックスパラメータ設定クラス
機能は以下の通り
納入日程行チェックボックスのパラメータを設定します。
ParamSender - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender.
論理システム - 送信者セグメントパラメータ設定クラス
機能は以下の通り
論理システム - 送信者のパラメータを設定します。
ParamSpecStockRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa.
特殊在庫区分の範囲パラメータ設定クラス
機能は以下の通り
特殊在庫区分の範囲のパラメータを設定します。
ParamStatusInfo - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo.
ステータス情報パラメータ設定クラス
機能は以下の通り
ステータス情報のパラメータを設定します。
ParamStgeLocRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa.
保管場所の範囲パラメータ設定クラス
機能は以下の通り
保管場所の範囲のパラメータを設定します。
ParamStorageLocationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList.
品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り
品目データ (保管場所レベル)のパラメータを設定します。
ParamStorageTypeDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList.
品目データ (保管場所レベル)パラメータ設定クラス
機能は以下の通り
品目データ (保管場所レベル)のパラメータを設定します。
ParamSuccess - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess.
後続請求伝票の明細テーブルパラメータ設定クラス
機能は以下の通り
後続請求伝票の明細テーブルのパラメータを設定します。
ParamTaxClassifications - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications.
制御デ－タパラメータ設定クラス
機能は以下の通り
制御デ－タのパラメータを設定します。
ParamText - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText.
テキストパラメータ設定クラス
機能は以下の通り
テキストのパラメータを設定します。
ParamTextDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn.
請求インタフェースの通信構造テキストパラメータ設定クラス
機能は以下の通り
請求インタフェースの通信構造テキストのパラメータを設定します。
ParamTotalConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption.
品目総消費量のデータ転送パラメータ設定クラス
機能は以下の通り
品目総消費量のデータ転送のパラメータを設定します。
ParamTrEvTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa.
トランザクション/イベントタイプの範囲パラメータ設定クラス。
ParamUnitSofmeasure - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure.
数量単位パラメータ設定クラス
機能は以下の通り
数量単位のパラメータを設定します。
ParamUnplndConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption.
計画外消費のデータ転送パラメータ設定クラス
機能は以下の通り
計画外消費のデータ転送のパラメータを設定します。
ParamUserNameRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa.
ユーザ名の範囲パラメータ設定クラス
機能は以下の通り
ユーザ名の範囲のパラメータを設定します。
ParamValuationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList.
評価データパラメータ設定クラス
機能は以下の通り
評価データのパラメータを設定します。
ParamVendorAddress - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress.
仕入先住所パラメータ設定クラス
機能は以下の通り
仕入先住所のパラメータを設定します。
ParamVendorRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa.
仕入先の範囲パラメータ設定クラス
機能は以下の通り
仕入先の範囲のパラメータを設定します。
ParamVersions - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions.
バージョン管理パラメータ設定ラクラス
機能は以下の通り
バージョン管理のパラメータを設定します。
ParamWarehouseNumberDataList - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList.
倉庫番号データパラメータ設定クラス
機能は以下の通り
倉庫番号データのパラメータを設定します。
ParamWmdvex - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex.
出力テーブル (日付および ATP 数量)パラメータ設定クラス
機能は以下の通り
出力テーブル (日付および ATP 数量)のパラメータを設定します。
ParamWmdvsx - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx.
入力テーブル (日付/数量)パラメータ設定クラス
機能は以下の通り
入力テーブル (日付/数量)のパラメータを設定します。
Partner - class jp.co.intra_mart.foundation.sap.module.purchase.Partner.
取引先情報クラス
機能は以下の通り
取引先情報を保持します。
Partner() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のコンストラクタ
取引先を作成します。
Partner(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のコンストラクタ
取引先を作成します。
PartnerAddresses - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses.
アドレス (組織/会社) 用 BAPI 参照構造情報クラス
機能は以下の通り
アドレス (組織/会社) 用 BAPI 参照構造情報を保持します。
PartnerAddresses() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のコンストラクタ
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
PartnerAddresses(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のコンストラクタ
アドレス (組織/会社) 用 BAPI 参照構造情報を作成します。
Partners - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners.
伝票取引先情報クラス
機能は以下の通り
伝票取引先情報を保持します。
Partners() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のコンストラクタ
伝票取引先情報を作成します。
Partners(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のコンストラクタ
伝票取引先情報を作成します。
PlanningData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData.
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList.
品目マスタ/製品グループの変更伝票構造情報クラス
機能は以下の通り
品目マスタ/製品グループの変更伝票構造情報を保持します。
PlanningDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlanningDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のコンストラクタ
品目マスタ/製品グループの変更伝票構造情報を作成します。
PlantData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData.
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報を保持します。
PlantData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList.
品目データ (プラントレベル)情報クラス
機能は以下の通り
品目データ (プラントレベル)情報をテーブル型で保持します。
PlantDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のコンストラクタ
品目データ (プラントレベル)情報を作成します。
PlantRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa.
プラントの範囲情報クラス
機能は以下の通り
プラントの範囲情報を保持します。
PlantRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のコンストラクタ
プラントの範囲情報を作成します。
PlantRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のコンストラクタ
プラントの範囲情報を作成します。
PlantSelection - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection.
プラントの選択オプションクラス
機能は以下の通り
プラントの選択オプションの情報を保持します。
PlantSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のコンストラクタ
プラントの選択オプション情報を作成します。
PlantSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のコンストラクタ
Sプラントの選択オプション情報を作成します。
ProductionResourceToolData - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData.
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
ProductionResourceToolData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
ProfitCenter - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter.
利益センタ情報クラス
機能は以下の通り
利益センタの情報を保持します。
ProfitCenter() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のコンストラクタ
利益センタ情報を作成します。
ProfitCenterController - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController.
利益センタコントローラクラス
機能は以下の通り
利益センタの情報を取得します。
ProfitCenterController(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterController(String, Date, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のコンストラクタ
ProfitCenterListのコンストラクタを呼び出し利益センタ一覧を作成します。
ProfitCenterGrpGetDetail - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail.
利益センタグループ情報取得クラス
機能は以下の通り
利益センタグループ情報を取得します。
ProfitCenterGrpGetDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のコンストラクタ
利益センタグループ情報を作成します。
ProfitCenterGrpGetDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail のコンストラクタ

ProfitCenterGrpGetDetailController - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController.
利益センタグループコントローラクラス
機能は以下の通り
利益センタグループを取得します。
ProfitCenterGrpGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ

ProfitCenterGrpGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ

ProfitCenterGrpGetDetailController() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterGrpGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のコンストラクタ
ProfitCenterGrpGetDetailControllerのコンストラクタを生成します。
ProfitCenterList - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList.
利益センタ一覧クラス

機能は以下の通り
利益センタの情報を一覧形式で取得します。
ProfitCenterList(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のコンストラクタ
executeBapiを呼び出し利益センタ一覧を作成します。
ProfitSegment - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment.
入出庫予定情報クラス
機能は以下の通り
入出庫予定情報を保持します。
ProfitSegment() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のコンストラクタ
入出庫予定を作成します。
ProfitSegment(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のコンストラクタ
入出庫予定を作成します。
ProjectDefinition - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition.
プロジェクトについての詳細情報クラス 機能は以下の通り
プロジェクトについての詳細情報を保持します。
ProjectDefinition() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のコンストラクタ
プロジェクトについての詳細情報を作成します。
ProjectGetInfo - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo.
WBS情報取得クラス
機能は以下の通り
WBS情報を取得します。
ProjectGetInfo(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のコンストラクタ
WBS情報を作成します。
ProjectGetInfoController - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController.
WBSの詳細コントローラクラス
機能は以下の通り
WBSの詳細を取得します。
ProjectGetInfoController() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のコンストラクタ
ProjectGetInfoControllerのコンストラクタを生成します。
ProjectGetInfoController(SapClient) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のコンストラクタ
ProjectGetInfoControllerのコンストラクタを生成します。
PrtData - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData.
品目マスタの生産資源/治工具 (PRT) 項目情報クラス
機能は以下の通り
品目マスタの生産資源/治工具 (PRT) 項目情報を保持します。
PrtData() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PrtData(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のコンストラクタ
品目マスタの生産資源/治工具 (PRT) 項目情報を作成します。
PstngDateRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa.
登録日付の範囲情報クラス
機能は以下の通り
登録日付の範囲情報を保持します。
PstngDateRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のコンストラクタ
登録日付の範囲情報を作成します。
PstngDateRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のコンストラクタ
登録日付の範囲情報を作成します。
PurchaseAccount - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount.
購買発注伝票勘定情報クラス
機能は以下の通り
購買発注伝票勘定情報を保持します。
PurchaseAccount() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のコンストラクタ
購買発注伝票明細を作成します。
PurchaseAccount(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のコンストラクタ
購買発注伝票明細を作成します。
PurchaseGetItemSrel - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel.
伝票承認対象一覧情報クラス
機能は以下の通り
伝票承認対象一覧を取得します。
PurchaseGetItemSrel(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrel(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のコンストラクタ
承認対象一覧を作成します。
PurchaseGetItemSrelController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController.
伝票の承認対象一覧取得コントローラクラス
機能は以下の通り
伝票の承認対象一覧を取得します。
PurchaseGetItemSrelController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrelController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
コンストラクタ生成
PurchaseGetItemSrelController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseGetItemSrelController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のコンストラクタ
PurchaseGetItemSrelのコンストラクタを呼び出し伝票承認対象一覧を取得します。
PurchaseHeader - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader.
購買発注ヘッダ情報スーパークラス
機能は以下の通り
購買発注のヘッダ情報を保持します。
PurchaseHeader() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のコンストラクタ
購買発注伝票ヘッダを作成します。
PurchaseHeaderPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost.
購買発注伝票ヘッダ情報クラス
機能は以下の通り
購買発注伝票ヘッダの情報を保持します。
PurchaseHeaderPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のコンストラクタ
購買発注伝票ヘッダを作成します。
PurchaseHeaders - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders.
伝票の承認対象一覧ヘッダ情報クラス
機能は以下の通り
伝票の承認対象一覧ヘッダの情報を保持します。
PurchaseHeaders() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のコンストラクタ
伝票の承認対象一覧ヘッダを作成します。
PurchaseItem - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem.
購買発注明細情報スーパークラス
機能は以下の通り
購買発注の明細情報を保持します。
PurchaseItem() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItemPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost.
購買発注伝票明細情報クラス
機能は以下の通り
購買発注伝票明細情報を保持します。
PurchaseItemPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItemPost(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のコンストラクタ
購買発注伝票明細を作成します。
PurchaseItems - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems.
伝票の承認対象明細情報クラス
機能は以下の通り
伝票の承認対象明細情報を保持します。
PurchaseItems() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のコンストラクタ
伝票の承認対象明細を作成します。
PurchaseOrderPayPost - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost.
伝票登録クラス
機能は以下の通り
伝票を登録します。
PurchaseOrderPayPost() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
コンストラクタ。
PurchaseOrderPayPost(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
PurchaseOrderPayPost(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
PurchaseOrderPayPostController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController.
伝票登録コントローラクラス
機能は以下の通り
伝票を登録します。
PurchaseOrderPayPostController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPayPostController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController のコンストラクタ
PurchaseOrderPayPostControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController.
伝票登録変更コントローラクラス
機能は以下の通り
伝票を変更します。
PurchaseOrderPostChangeController() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseOrderPostChangeController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController のコンストラクタ
PurchaseOrderPostChangeControllerのコンストラクタを生成します。
PurchaseRelease - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease.
承認情報スーパークラス
機能は以下の通り
承認情報を保持します。
PurchaseRelease() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
伝票承認を作成します。
PurchaseRelease(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseRelease(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のコンストラクタ
コンストラクタ生成。
PurchaseReleaseController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController.
伝票承認コントローラクラス
機能は以下の通り
伝票を承認します。
PurchaseReleaseController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseReleaseController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認情報を作成します。
PurchaseResetReleaseController - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController.
伝票承認取消コントローラクラス
機能は以下の通り
伝票の承認取消します。
PurchaseResetReleaseController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String, String, String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseResetReleaseController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController のコンストラクタ
PurchaseReleaseのコンストラクタを呼び出し伝票承認取消情報を作成します。
PurchaseSchedule - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule.
購買発注伝票納入日程情報クラス
機能は以下の通り
購買発注伝票納入日程情報を保持します。
PurchaseSchedule() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のコンストラクタ
購買発注伝票納入日程を作成します。
PurchaseSchedule(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のコンストラクタ
購買発注伝票納入日程を作成します。
PurchaseText - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText.
購買発注伝票テキストクラス
機能は以下の通り
購買発注伝テキストを保持します。
PurchaseText() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のコンストラクタ
購買発注伝票テキストを作成します。
PurchaseText(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のコンストラクタ
購買発注伝票テキストを作成します。

Q

QuotationCreateFromData2 - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2.
見積伝票登録情報クラス
機能は以下の通り
見積伝票登録情報を保持します。
QuotationCreateFromData2() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
コンストラクタ。
QuotationCreateFromData2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
QuotationCreateFromData2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
QuotationCreateFromData2Controller - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller.
見積伝票登録情報コントローラクラス
機能は以下の通り
見積伝票登録情報を保持します。
QuotationCreateFromData2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。
QuotationCreateFromData2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のコンストラクタ
QuotationCreateFromData2Controllerのコンストラクタを生成します。

R

RefDocRange - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange.
前伝票の範囲情報クラス
機能は以下の通り
前伝票の範囲情報を保持します。
RefDocRange() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のコンストラクタ
前伝票の範囲情報を作成します。
ReferenceController - class jp.co.intra_mart.foundation.sap.module.ReferenceController.
参照系モジュール共通コントローラ親クラス。
ReferenceController() - class jp.co.intra_mart.foundation.sap.module.ReferenceController のコンストラクタ
コンストラクタ。
ReferenceController(SapClient) - class jp.co.intra_mart.foundation.sap.module.ReferenceController のコンストラクタ
コンストラクタ。
ReturnMessages - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages.
リターンパラメータ BAPIRET2 の代替構造情報クラス
機能は以下の通り
リターンパラメータ BAPIRET2 の代替構造情報を保持します。
ReturnMessages() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のコンストラクタ
リターンパラメータ BAPIRET2 の代替構造情報を作成します。
ReturnMessages(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のコンストラクタ
リターンパラメータ BAPIRET2 の代替構造情報を作成します。

S

SAPAccountingAppException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException.
p 会計系APIアプリケーション例外クラス
SAPAccountingAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingAppException(String) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException のコンストラクタ
会計系APIアプリケーション例外
SAPAccountingSystemException - exception jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException.
会計系APIシステム例外クラス
SAPAccountingSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException のコンストラクタ
会計系APIシステム例外
SAPBapiReturnErrMessageExistException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException.
BAPI実行結果例外クラス
SAPBapiReturnErrMessageExistException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException のコンストラクタ
BAPI実行結果例外
SAPBapiReturnErrMessageExistException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException のコンストラクタ
BAPI実行結果例外
SAPFinancialAppException - exception jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException.
会計系APIアプリケーション例外クラス
SAPFinancialAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException のコンストラクタ
会計系APIアプリケーション例外
SAPFinancialAppException(String) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException のコンストラクタ
会計系APIアプリケーション例外
SAPFinancialSystemException - exception jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException.
会計系APIシステム例外クラス
SAPFinancialSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException のコンストラクタ
会計系APIシステム例外
SAPModuleAppException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException.
モジュール用データ取得・追加・更新APIアプリケーション例外クラス
SAPModuleAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException のコンストラクタ
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleAppException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException のコンストラクタ
モジュール用データ取得・追加・更新APIアプリケーション例外
SAPModuleSystemException - exception jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException.
モジュール用データ取得・追加・更新APIシステム例外クラス
SAPModuleSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException のコンストラクタ
モジュール用データ取得・追加・更新APIシステム例外
SAPModuleSystemException(String) - class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException のコンストラクタ
モジュール用データ取得・追加・更新APIシステム例外
SAPPurchaseAppException - exception jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException.
購買系APIアプリケーション例外クラス
SAPPurchaseAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException のコンストラクタ
購買系APIアプリケーション例外
SAPPurchaseAppException(String) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException のコンストラクタ
購買系APIアプリケーション例外
SAPPurchaseSystemException - exception jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException.
購買系APIシステム例外クラス
SAPPurchaseSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException のコンストラクタ
購買系APIシステム例外
SAPSalesAppException - exception jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException.
販売管理系APIアプリケーション例外クラス
SAPSalesAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException のコンストラクタ
販売管理系APIアプリケーション例外
SAPSalesAppException(String) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException のコンストラクタ
販売管理系APIアプリケーション例外
SAPSalesSystemException - exception jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException.
販売管理系APIシステム例外クラス
SAPSalesSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException のコンストラクタ
販売管理系APIシステム例外
SalesData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData.
販売データ情報クラス
機能は以下の通り
販売データ情報を保持します。
SalesData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のコンストラクタ
販売データ情報を作成します。
SalesDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList.
販売データ情報クラス
機能は以下の通り
販売データ情報をテーブル型で保持します。
SalesDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のコンストラクタ
販売データ情報を作成します。
SalesDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のコンストラクタ
販売データ情報を作成します。
SalesOrderCreateFromDat2 - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2.
受注伝票登録情報クラス
機能は以下の通り
受注伝票登録情報を保持します。
SalesOrderCreateFromDat2() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
コンストラクタ。
SalesOrderCreateFromDat2(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
コネクションマネージャーを引数に持つコンストラクタ。
SalesOrderCreateFromDat2(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のコンストラクタ
SAPへの接続情報が格納されたオブジェクトを引数に持つコンストラクタ。
SalesOrderCreateFromDat2Controller - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller.
受注伝票登録コントローラクラス
機能は以下の通り
受注伝票を登録します。
SalesOrderCreateFromDat2Controller() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderCreateFromDat2Controller(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のコンストラクタ
SalesOrderCreateFromDat2Controllerのコンストラクタを生成します。
SalesOrderGetList - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList.
販売伝票一覧照会情報クラス
機能は以下の通り
販売伝票一覧照会情報を保持します。
SalesOrderGetList(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のコンストラクタ
販売伝票一覧照会情報を作成します。
SalesOrderGetList(String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のコンストラクタ
販売伝票一覧照会情報を作成します。
SalesOrderGetListController - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController.
販売伝票一覧照会コントローラクラス
機能は以下の通り
販売伝票一覧の情報を取得します。
SalesOrderGetListController() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetListController(String, String, String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatus - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus.
販売伝票ステータス一覧照会情報クラス
機能は以下の通り
販売伝票ステータス一覧照会情報を保持します。
SalesOrderGetStatus(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のコンストラクタ
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatus(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のコンストラクタ
販売伝票ステータス一覧照会情報を作成します。
SalesOrderGetStatusController - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController.
販売伝票ステータス一覧照会コントローラクラス
機能は以下の通り
販売伝票ステータス一覧の情報を取得します。
SalesOrderGetStatusController() - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrderGetStatusController(String, SapClient) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のコンストラクタ
コンストラクタ生成
SalesOrders - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders.
得意先受注テーブル情報クラス
機能は以下の通り
得意先受注テーブル情報を保持します。
SalesOrders() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のコンストラクタ
得意先受注テーブル情報を作成します。
SalesOrders(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のコンストラクタ
得意先受注テーブル情報を作成します。
SalesOrganisationSelection - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection.
販売組織の選択オプションクラス
機能は以下の通り
販売組織の選択オプションの情報を保持します。
SalesOrganisationSelection() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のコンストラクタ
販売組織の選択オプション情報を作成します。
SalesOrganisationSelection(int) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のコンストラクタ
販売組織の選択オプション情報を作成します。
SchedulesIn - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn.
納入日程行情報クラス
機能は以下の通り
納入日程行情報を保持します。
SchedulesIn() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のコンストラクタ
納入日程行情報を作成します。
SchedulesIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のコンストラクタ
納入日程行情報を作成します。
SchedulesInX - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX.
納入日程行チェックボックス情報クラス
機能は以下の通り
納入日程行チェックボックス情報を保持します。
SchedulesInX() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のコンストラクタ
納入日程行チェックボックス情報を作成します。
SchedulesInX(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のコンストラクタ
納入日程行チェックボックス情報を作成します。
Selection - class jp.co.intra_mart.foundation.sap.module.purchase.Selection.
選択オプションクラス
機能は以下の通り
選択オプションの情報を保持します。
Selection() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のコンストラクタ
選択オプション情報を作成します。
Sender - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender.
論理システム - 送信者情報クラス
機能は以下の通り
論理システム - 送信者情報を保持します。
Sender() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のコンストラクタ
論理システム - 送信者情報を作成します。
SpecStockRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa.
特殊在庫区分の範囲情報クラス
機能は以下の通り
特殊在庫区分の範囲情報を保持します。
SpecStockRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のコンストラクタ
特殊在庫区分の範囲情報を作成します。
SpecStockRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のコンストラクタ
特殊在庫区分の範囲情報を作成します。
StatusInfo - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo.
ステータス情報情報クラス
機能は以下の通り
ステータス情報情報を保持します。
StatusInfo() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のコンストラクタ
ステータス情報情報を作成します。
StatusInfo(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のコンストラクタ
ステータス情報情報を作成します。
StdMaterialGetIntNumber - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber.
品目コード割当済情報クラス
機能は以下の通り
品目コード割当済の情報を保持します。
StdMaterialGetIntNumber() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のコンストラクタ
品目コード割当済情報を作成します。
StdMaterialGetIntNumberController - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController.
品目コード割当済照会コントローラクラス。
StdMaterialGetIntNumberController(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のコンストラクタ
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberController(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のコンストラクタ
StdMaterialGetIntNumberListのコンストラクタを呼び出し品目コード割当済一覧を作成します。
StdMaterialGetIntNumberList - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList.
品目コード割当済一覧クラス
機能は以下の通り
品目コード割当済の情報を一覧形式で取得します。
StdMaterialGetIntNumberList(String, String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のコンストラクタ
executeBapiを呼び出し品目コード割当済一覧を作成します。
StgeLocRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa.
保管場所の範囲情報クラス
機能は以下の通り
保管場所の範囲情報を保持します。
StgeLocRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のコンストラクタ
保管場所の範囲情報を作成します。
StgeLocRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のコンストラクタ
保管場所の範囲情報を作成します。
StorageLocationData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData.
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報を保持します。
StorageLocationData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList.
品目データ (保管場所レベル)情報クラス
機能は以下の通り
品目データ (保管場所レベル)情報をテーブル型で保持します。
StorageLocationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のコンストラクタ
品目データ (保管場所レベル)情報を作成します。
StorageLocationSelect - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect.
保管場所の選択オプションクラス
機能は以下の通り
保管場所の選択オプションの情報を保持します。
StorageLocationSelect() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のコンストラクタ
保管場所の選択オプション情報を作成します。
StorageLocationSelect(int) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のコンストラクタ
保管場所の選択オプション情報を作成します。
StorageTypeData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData.
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報を保持します。
StorageTypeData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のコンストラクタ
保管域タイプデータ情報を作成します。
StorageTypeDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList.
保管域タイプデータ情報クラス
機能は以下の通り
保管域タイプデータ情報をテーブル型で保持します。
StorageTypeDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のコンストラクタ
保管域タイプデータ情報を作成します。
StorageTypeDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のコンストラクタ
保管域タイプデータ情報を作成します。
Success - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success.
正常に処理された明細のテーブル情報クラス
機能は以下の通り
正常に処理された明細のテーブル情報を保持します。
Success() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のコンストラクタ
正常に処理された明細のテーブル情報を作成します。
Success(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のコンストラクタ
正常に処理された明細のテーブル情報を作成します。
SupplierDetail - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail.
仕入先マスタ詳細情報クラス
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierDetail(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のコンストラクタ
仕入先詳細情報クラスを取得します
SupplierDetail(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のコンストラクタ
executeBapiを呼び出し仕入先マスタ詳細を作成します。
SupplierExistenceCheck - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck.
仕入先コード存在チェッククラス
機能は以下の通り
仕入先コード存在チェック結果を取得します。
SupplierExistenceCheck(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のコンストラクタ
仕入先詳細情報クラスを取得します
SupplierExistenceCheck(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のコンストラクタ
executeBapiを呼び出し仕入先コード存在チェックを作成します。
SupplierExistenceCheckController - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController.
仕入先コード存在チェックコントローラ
機能は以下の通り
仕入先コード存在チェックを行います。
SupplierExistenceCheckController() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
コンストラクタ生成
SupplierExistenceCheckController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
コンストラクタ生成
SupplierExistenceCheckController(String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierExistenceCheckController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のコンストラクタ
SupplierExistenceCheckのコンストラクタを呼び出し仕入先コード存在チェックを行います。
SupplierGetDetailController - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController.
仕入先マスタの詳細情報取得コントローラ
機能は以下の通り
仕入先マスタの詳細情報を取得します。
SupplierGetDetailController() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SupplierGetDetailController(String, String, SapClient) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のコンストラクタ
SupplierDetailのコンストラクタを呼び出し仕入先マスタ詳細情報を作成します。
SystemStatus - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus.
システムステータステーブル情報クラス 機能は以下の通り
システムステータステーブル情報を保持します。
SystemStatus() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のコンストラクタ
システムステータステーブルを作成します。
sapClient - class jp.co.intra_mart.foundation.sap.module.AbstractController の変数
SAPクライアント
setAbart(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
承認タイプを設定します。
setAbcId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ABC 区分を設定します。
setAbrli(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
内部納入日程番号を設定します。
setAcIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード番号を設定します｡
setAccessSeq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
検索順序 - 検索番号を設定します。
setAccessSeq(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
検索順序 - 検索番号を設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先の勘定設定グループを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先の勘定設定グループを設定します。
setAccntAsgn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAccountGlList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細一覧を設定します｡
setAccountKe(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キー 見越/引当を設定します。
setAccountPayableList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細一覧を設定します｡
setAccountTaxList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細一覧を設定します｡
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計ビューを設定します。
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
会計ビューを設定します。
setAccountView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
会計ビューを設定します。
setAccountkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
勘定キーを設定します。
setAccruals(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
見越額関連条件 (運賃など)を設定します。
setAccruals(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
見越額関連条件 (運賃など)を設定します。
setAcctAssgt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目の勘定設定グループを設定します。
setAcctasgnmt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の勘定設定グループを設定します。
setAcctasscat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
勘定設定カテゴリを設定します。
setAcctstatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
会計への転記ステータスを設定します。
setAcknReqd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注請求書依頼を設定します。
setAcknowlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注請書番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク/標準ネットワークの活動番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
作業番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
処理タイプ - R/3 Enterprise で使用不可能を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
作業番号を設定します。
setActivity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
作業番号を設定します。
setActivityCosts(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の原価を設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
活動タイプを設定します。
setActtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
活動タイプを設定します。
setActualCost(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実際原価を設定します。
setActualDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日付(マイルストーン通過)を設定します。
setActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績終了日: 実行 (日付)を設定します。
setActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績開始日: 実行 (日付)を設定します。
setActualTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
実績日/時間(マイルストーン適合)を設定します。
setAddToStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
既存在庫への追加許可を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日からの日数を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日からの日数を設定します。
setAddValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAddrLink(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所コードへのリンクを設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
アドレス: アドレス番号を設定します。
setAddrNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレス番号を設定します。
setAddrOrig(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
コピー元住所を設定します。
setAddrType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
アドレスタイプ (1=組織、2=個人、3=取引先担当者)を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
住所を設定します。
setAddress(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
住所を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
住所注記を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
住所注記を設定します。
setAdrNotes(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
住所注記を設定します。
setAgmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約の明細番号を設定します。
setAgreement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買契約番号を設定します｡
setAgreement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買契約番号を設定します。
setAllVersionsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
全バージョン一覧を設定します｡
setAllocTbl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
商品配分表番号を設定します。
setAllowedBusTractList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
使用可能業務トランザクションのテーブルを設定します。
setAllowedBusTractList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
使用可能業務トランザクションのテーブルを設定します。
setAllowedWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包重量を設定します。
setAllwdVol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
許容梱包容積を設定します。
setAlphaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
アルファ係数使用による基本値の平滑化を設定します。
setAltBomId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOM 選択の方法を設定します。
setAltToItm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替明細を設定します。
setAltToItm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAltUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
在庫保管単位の代替数量単位を設定します。
setAltUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードによる在庫単位の代替数量単位を設定します。
setAlternBom(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
代替 BOMを設定します。
setAlternBom(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAlternat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替明細を設定します。
setAlternativeBom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
代替 BOMを設定します。
setAlttaxCls(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
代替税分類を設定します。
setAlttaxCls(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAmountLc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
マニュアル入力による転記金額 (国内通貨)を設定します。
setAmountLc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
マニュアル入力による転記金額 (国内通貨)を設定します。
setAmountSv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
外部入力による販売金額 (国内通貨)を設定します。
setAmountSv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
外部入力による販売金額 (国内通貨)を設定します。
setAppdBRec(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バッチ製造記録の承認必須を設定します。
setApplicBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を設定します。
setApplicant(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者を設定します。
setApplicantNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請者番号を設定します。
setApplicantNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
申請者番号を設定します。
setApplicantPhone(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請者の電話番号を設定します。
setApplicatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
アプリケーションを設定します。
setApplicatio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
アプリケーションを設定します。
setApplicationDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請日を設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setApplobject(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト: アプリケーションオブジェクトを設定します。
setAssNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
割当番号を設定します。
setAssNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産番号を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産番号を設定します。
setAssetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産番号を設定します。
setAssortMod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品揃モジュールを設定します。
setAssortMod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setAssyScrap(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
組立不良率を設定します。
setAtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
割当テーブルの明細番号を設定します。
setAtRelev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
適当テーブル関連を設定します。
setAtpWrkmod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
ATP セッション: 結果取得/新規決定 APO-ATPを設定します。
setAuthCcNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認番号を設定します。
setAuthDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認日を設定します。
setAuthDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認日を設定します。
setAuthFlag(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 振替権限を設定します。
setAuthFlag(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 振替権限を設定します。
setAuthRefno(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社の権限参照コードを設定します。
setAuthRefno(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社の権限参照コードを設定します。
setAuthTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認時刻を設定します。
setAuthTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認時刻を設定します。
setAuthamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認額を設定します。
setAuthamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 承認額を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
報告書提案済を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
報告書提案済を設定します。
setAuthor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
報告書提案済を設定します。
setAuthoritygroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
権限グループを設定します。
setAutoPOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: "購買発注自動生成"を設定します。
setAutoReset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予測モデル自動リセットを設定します。
setAvQtyPlt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントレベル利用可能数量を設定します。
setAvailCheckAllProjSegments(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プロジェクト間品目区分を設定します。
setAvailcheck(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利用可能在庫確認の確認グループを設定します。
setBUomIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードでの基本数量単位を設定します。
setBaList(BankList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
銀行一覧を設定します｡
setBackflush(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バックフラッシュを設定します。
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
銀行データ情報を設定します｡
setBankDataInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
銀行データ情報を設定します｡
setBankKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行コードを設定します｡
setBankList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
銀行一覧を設定します｡
setBankName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
銀行名を設定します｡
setBarCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
バーコードエントリを設定します。
setBaseQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
基本数量を設定します。
setBaseQtyPlan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷の能力計画のための基本数量を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
基本数量単位を設定します。
setBaseUom(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
基本数量単位を設定します。
setBaseUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの基本数量単位を設定します。
setBasicLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基本明細を設定します。
setBasicMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
主構成物質を設定します。
setBasicValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
基準値を設定します。
setBasicValue1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を設定します。
setBasicValue2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
第二指図の基準値を設定します。
setBasicValuePp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の基準値を設定します。
setBasicValuePp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を設定します。
setBasicValuePp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間における第二指図の基準値を設定します。
setBasicView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
基本データビューを設定します。
setBaslineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
代替: 基本明細参照を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
ロットを設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ロット番号を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBatch(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ロット番号を設定します。
setBatchMgmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロット管理所要量区分を設定します。
setBatchMgmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロット管理所要量区分を設定します。
setBatchRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ロットの範囲を設定します。
setBatchentry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造/プロセス指図でのロット入力設定を設定します。
setBdcnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
5 文字数値 NUMCを設定します。
setBegdemPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見越期間の提案開始日付を設定します。
setBegdemPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBegintime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
開始時刻を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
エラー処理を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
エラー処理を設定します。
setBehaveWhenError(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
エラー処理を設定します。
setBetaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ベータ係数による傾向値平準化を設定します。
setBidder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入札者の明細を設定します。
setBidinvNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積管理番号を設定します。
setBilForm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書式を設定します。
setBilForm(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票の請求ブロックを設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ブロックを設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票の請求ブロックを設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求索引および印刷に対する請求日を設定します。
setBillDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票を設定します。
setBillDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
請求伝票明細を設定します。
setBillOfLading(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫時に登録した B/L 番号を設定します。
setBillOfLadingLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入庫の船荷証券番号 (依存: テキスト (長) 参照)を設定します。
setBillPlan(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求計画番号を設定します。
setBillPlani(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
明細: 請求計画/支払計画/支払カードを設定します。
setBillRel(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求関連 (CRM)を設定します。
setBillRel(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求日程 (稼働日カレンダ指定)を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求日程 (稼働日カレンダ指定)を設定します。
setBillSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBillTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
請求先を設定します。
setBillType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求タイプを設定します。
setBillValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
請求金額: 請求計画に請求日付が指定されている場合を設定します。
setBillamount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
請求金額: 請求計画に請求日付が指定されている場合を設定します。
setBillcateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求カテゴリを設定します。
setBillingDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定明細データのテーブルを設定します。
setBillingDocumentDetail(BillingDocumentDetail) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController のメソッド
請求伝票に関する詳細情報を設定します。
setBillingDocumentDetail(BillingDocumentDetail) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
請求伝票に関する詳細情報を設定します。
setBillingDocumentDetailListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票のテーブルを設定します。
setBillingdoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
請求伝票を設定します。
setBillingdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
処理予定の請求伝票数を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBinaryRelationshiptype(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
バイナリ関連タイプ (専用)を設定します。
setBindgPer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積有効期間を設定します。
setBlanket(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
包括明細を設定します。
setBlockStge(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
平置保管域区分を設定します。
setBomUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BOM 用途を設定します。
setBomexplNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BOM 展開番号を設定します。
setBomexplNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBonGrp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ1を設定します。
setBonGrp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 2 (リベート決済、購買)を設定します。
setBonGrp3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
決済グループ 3 (リベート決済、購買)を設定します。
setBrasNbm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
Brazilian NCM Codeを設定します。
setBudgetProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
予算プロファイルを設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物 (番号またはコード)を設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物 (番号またはコード)を設定します。
setBuildLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物 (番号またはコード)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
旧: 建物 (番号または略称)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
旧: 建物 (番号または略称)を設定します。
setBuilding(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
旧: 建物 (番号または略称)を設定します。
setBulkMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: バルク品目を設定します。
setBusArDes(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域名を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
事業領域を設定します｡
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
事業領域を設定します。
setBusArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
事業領域を設定します。
setBusAreaList(BusinessAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
事業領域一覧を設定します｡
setBusTranst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
貿易管理の取引タイプを設定します。
setBusTranst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setBusinessAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
事業領域一覧を設定します｡
setBusinessTransactionType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易管理の取引タイプを設定します。
setBuspartno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
取引先の仕入先マスタコードを設定します。
setBwdCons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 後方を設定します。
setCCardDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定支払方法のテーブルを設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
気付を設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
気付を設定します。
setCOName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
気付を設定します。
setCadId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
CAD 区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
計算区分を設定します。
setCalcMotive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
計算区分を設定します。
setCalctypcon(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件計算タイプを設定します。
setCalctypcon(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件計算タイプを設定します。
setCalctype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定タイプを設定します。
setCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
稼動日カレンダを設定します。
setCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
稼動日カレンダを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
総括プロジェクト計画: 外部 R/3 システムの GUIDを設定します。
setCampaign(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCancelled(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
中止区分を設定します。
setCapyUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量使用を設定します。
setCasNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAS 番号： 薬事品目 - 貿易を設定します。
setCashDisc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
現金値引区分を設定します。
setCashDisc1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 1を設定します。
setCashDisc2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
割引率 2を設定します。
setCatprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
カタログプロファイルを設定します。
setCbaseId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号 (固定)を設定します。
setCbaseIdType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
インスタンス番号タイプ (固定)を設定します。
setCcAuthNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 承認番号を設定します。
setCcFixed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸区分固定を設定します。
setCcLocId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: トランザクション (入庫時点)を設定します。
setCcName(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード所有者の氏名を設定します。
setCcName(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード所有者の氏名を設定します。
setCcNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: カード番号を設定します。
setCcNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: カード番号を設定します。
setCcPhInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
循環棚卸の実地棚卸区分を設定します。
setCcReAmount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
BAPI インタフェースの通貨金額を設定します。
setCcReact(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 権限確認に対する応答を設定します。
setCcReactT(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 結果テキストを設定します。
setCcSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 支払カード - 接尾辞を設定します。
setCcSettled(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済終了を設定します。
setCcStatEx(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 外部システム呼出時のステータスを設定します。
setCcType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カードタイプ: カードタイプを設定します。
setCcType(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カードタイプ: カードタイプを設定します。
setCcValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 使用有効開始日付を設定します。
setCcValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 有効終了日を設定します。
setCcValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 有効終了日を設定します。
setCctrPosted(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価が実際に転記された原価センタを設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件数量単位 (ISO コード)を設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件数量単位 (ISO コード)を設定します。
setCdUntIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件数量単位 (ISO コード)を設定します。
setCertType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
証明書タイプを設定します。
setCfginfo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CU: 選定の BLOB (SCE)を設定します。
setCfopCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extension (old 5 char version)を設定します。
setCfopCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCfopLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
CFOP code and extensionを設定します。
setChangeId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
変更タイプ(U、I、E、D)を設定します。
setChangeNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
変更番号を設定します。
setChangedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクトの変更者名を設定します。
setCharUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
特性の数量単位を設定します。
setCharUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を設定します。
setCharc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性名を設定します。
setCharcTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
言語依存特性テキストを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村ファイルテストステータスを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村ファイルテストステータスを設定します。
setChckstatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村ファイルテストステータスを設定します。
setCheckReturn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
結果を設定します｡
setCheckReturn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController の static メソッド
結果を設定します｡
setCheckRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
確認規則を設定します。
setChkprtauth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
取引先権限チェックを設定します。
setChkprtauth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
市区町村名を設定します｡
setCity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村を設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
市区町村を設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setCityNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの市区町村コードを設定します。
setClIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
レコード番号を設定します｡
setClassType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
クラスタイプを設定します。
setClassType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
クラスタイプを設定します。
setClientData(ClientData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (クライアントレベル)を設定します。
setClientDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (クライアントレベル)を設定します。
setClosedBox(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
完了した梱包材を設定します。
setCmRelevanceFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
構成管理関連を設定します。
setCmlqtyDat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
累積出荷数量日付を設定します。
setCmlqtyDat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを設定します。
setCmmtItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資金予算コードを設定します。
setCmmtItemLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資金予算コードを設定します。
setCntrlInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票タイプに対する管理区分を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域を設定します｡
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
管理領域を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
管理領域を設定します。
setCoArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
管理領域を設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
業務プロセスを設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
業務プロセスを設定します。
setCoBusproc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
業務プロセスを設定します。
setCoCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
会社コードを設定します。
setCoIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
レコード番号を設定します｡
setCoProduct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 連産品としても使用可能な品目を設定します。
setCoProduct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 連産品としても使用可能な品目を設定します。
setCoeffTheil(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
タイル係数を設定します。
setCollNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括番号を設定します。
setCollectNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setComDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認日を設定します。
setComQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
確認数量を設定します。
setCommCoUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
物品コード (貿易) の数量単位を設定します。
setCommCoUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードによる物品コード (貿易管理) の数量単位を設定します。
setCommCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 統計品目コード/輸入コード番号を設定します。
setCommCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 統計品目コード/輸入コード番号を設定します。
setCommGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
手数料グループを設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
通信方法 (キー) (アドレス管理)を設定します。
setCommprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 1を設定します。
setCommprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法による評価額: レベル 2を設定します。
setCommprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
商法基準評価額: レベル 3を設定します。
setCompCdeB(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求対象会社コードを設定します。
setCompCdeB(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
会社コードを設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
会社コードを設定します｡
setCompCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社コードを設定します｡
setCompList(CompanyList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
会社一覧を設定します｡
setCompName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
会社名を設定します｡
setCompQuant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
構成品目数量を設定します。
setCompQuant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCompScrap(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
構成品目不良率を設定します。
setCompShip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示順守を設定します。
setCompShip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示順守を設定します。
setCompanyCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
会社コードを設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
会社依存データ情報を設定します｡
setCompanyDataInfo(CompanyDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
会社依存データ情報を設定します｡
setCompanyList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
会社一覧を設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
会社コードを設定します｡
setCompanycode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
会社コードを設定します。
setCompetitor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
競合会社を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
全購買発注に対する一括納入指定を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
一括納入区分を設定します。
setComplDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最終確認の有効化を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を設定します。
setComplete(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を設定します。
setCompleted(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ステータス "バージョン完了済"を設定します。
setCompleted(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
ステータス "バージョン完了済"を設定します。
setConExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
基本契約明細の制限を設定します。
setConItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
明細番号、契約を設定します。
setConLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を設定します。
setConNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
基本契約番号を設定します。
setConPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 基本契約の計画外を設定します。
setConbaseval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値を設定します。
setConbaseval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値を設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カウンタを設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタを設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件連続番号を設定します。
setCondCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件カウンタを設定します。
setCondCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件通貨 (累積項目用)を設定します。
setCondDUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
伝票の条件単位を設定します。
setCondGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先条件グループを設定します。
setCondHandl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
選択: 条件行処理 (SD 伝票変更)を設定します。
setCondHeaderList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件ヘッダ一覧を設定します｡
setCondItemList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
条件明細一覧を設定します｡
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レコード番号を設定します。
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レコード番号を設定します。
setCondNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
伝票条件番号を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格条件単位を設定します。
setCondPUnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
価格条件単位を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
ステップ番号を設定します。
setCondStNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
ステップ番号を設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件タイプを設定します。
setCondType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件タイプを設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
条件単位を設定します。
setCondUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
条件単位を設定します。
setCondUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件数量単位 (ISO コード)を設定します。
setCondUpdat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件更新を設定します。
setCondUpdat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件更新を設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件レートを設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
条件金額/率を設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件レートを設定します。
setCondValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCondchaman(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件 (マニュアル変更済)を設定します。
setCondchaman(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件 (マニュアル変更済)を設定します。
setCondclass(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件クラスを設定します。
setCondclass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件クラスを設定します。
setCondcntrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件管理を設定します。
setCondcntrl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件管理を設定します。
setCondcoinhd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カウンタ (ヘッダ条件)を設定します。
setCondconfig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
システム設定の条件を設定します。
setCondconfig(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
システム設定の条件を設定します。
setCondcount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件連続番号を設定します。
setCondcount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件連続番号を設定します。
setCondincomp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
会社間請求の条件を設定します。
setCondincomp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
会社間請求の条件を設定します。
setCondisacti(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
無効条件を設定します。
setCondisacti(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
無効条件を設定します。
setConditemno(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
条件明細番号を設定します。
setConditionDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
処理予定条件のテーブルを設定します。
setConditionNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
伝票条件番号を設定します。
setCondorigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件生成区分を設定します。
setCondorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件生成区分を設定します。
setCondtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
setCondtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件カテゴリ (例: 税、運賃、価格、原価)を設定します。
setCondvalue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件金額を設定します。
setConexchrat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
現地通貨への換算レートに対する条件を設定します。
setConexchrat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
現地通貨への換算レートに対する条件を設定します。
setConfCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
確認管理キーを設定します。
setConfMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通選定可能品目を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
外部選定 ID (仮)を設定します。
setConfigId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setConfigured(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
選定可能品目を設定します。
setConinvolst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
請求書一覧条件を設定します。
setConinvolst(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
請求書一覧条件を設定します。
setConpricdat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件価格設定日付を設定します。
setConpricdat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件価格設定日付を設定します。
setConsValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
消費量を設定します。
setConsValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
消費量を設定します。
setConsistent(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
一般区分を設定します。
setConsistent(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
一般区分を設定します。
setConstraintFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了日に対する制約を設定します。
setConstraintFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日付を設定します。
setConstraintFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準終了時間を設定します。
setConstraintFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測終了時間を設定します。
setConstraintStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を設定します。
setConstraintStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の予測開始日を設定します。
setConstraintStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始時間の制約を設定します。
setConstraintStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の需要予測開始時間を設定します。
setConstraintTypeFinish(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の終了日に対する制約を設定します。
setConstraintTypeFinishFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動終了の制約条件付き需要予測日付を設定します。
setConstraintTypeStart(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の基準開始日に対する制約を設定します。
setConstraintTypeStartFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動開始の制約条件付き需要予測日付を設定します。
setConsumctry(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
消費者の国キーを設定します。
setConsummode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費モードを設定します。
setContPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setContainer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容器条件を設定します。
setContext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
CU: 選定の BLOB (SCE)を設定します。
setContractLimitsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注基本契約制限一覧を設定します｡
setContractServiceAccountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス勘定設定一覧を設定します｡
setContractServiceList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービス一覧を設定します｡
setContractServiceTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注サービステキスト一覧を設定します｡
setControlKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
管理キーを設定します。
setControllAreaList(ControllingAreaList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
管理領域一覧を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
管理領域を設定します｡
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
管理領域を設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
管理領域を設定します。
setControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
管理領域を設定します。
setControllingAreaCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを設定します。
setControllingAreaList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
管理領域一覧を設定します｡
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
管理領域を設定します。
setControllingarea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
管理領域を設定します。
setConvDen1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分母を設定します。
setConvNum1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買価格単位から購買発注単位への変換分子を設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
変換: 取引先機能 + 受注伝票タイプを設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
取引先機能/受注伝票タイプの変換を設定します。
setConvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
変換: 取引先機能 + 受注伝票タイプを設定します。
setConvfactor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目用変換係数を設定します。
setCorrFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 修正係数を需要予測値計算に使用を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
需要予測に対する修正値を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
修正消費量を設定します。
setCorrValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
修正消費量を設定します。
setCostCentList(CostCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
原価センタ一覧を設定します｡
setCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
原価センタを設定します｡
setCostCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
原価センタ一覧を設定します｡
setCostElem(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
原価要素を設定します。
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価対象を設定します。
setCostObj(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価対象を設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算ビューを設定します。
setCostView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
原価計算ビューを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
原価センタを設定します。
setCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
原価センタを設定します。
setCostingSheet(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価計算表を設定します。
setCostobject(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
原価対象を設定します。
setCountrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国キー (ISO コード)を設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷国 (商品発送国)を設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
国コードを設定します。
setCountry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを設定します。
setCountryori(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産国を設定します。
setCountryori(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産国を設定します。
setCountryoriIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを設定します。
setCountryoriIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの品目原産国を設定します。
setCovprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫日数プロファイルを設定します。
setCrOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
レコード登録日を設定します。
setCreatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
レコード登録日を設定します。
setCreatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
レコード登録日を設定します。
setCreateLoadRecs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
区分: 生産資源/治工具の負荷レコード登録を設定します。
setCreateLoadRecs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
区分: 生産資源/治工具の負荷レコード登録を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
登録者名を設定します｡
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクト登録者名を設定します。
setCreatedBy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクト登録者名を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
レコード登録日を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
登録日付を設定します。
setCreatedOn(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
レコード登録日を設定します。
setCreationDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード登録日を設定します。
setCreationDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード登録日を設定します。
setCreationTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
登録時刻を設定します。
setCreationTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
登録時刻を設定します。
setCreatorDataIn(CreatorDataIn) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
取り込まれる日付の順序を設定します。
setCreditorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードを設定します｡
setCritPart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 重要品目を設定します。
setCsIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
レコード番号を設定します｡
setCshBdgtProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
資金計画プロファイルを設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ１を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ１を設定します。
setCstcndgrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ２を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ２を設定します。
setCstcndgrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ３を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ３を設定します。
setCstcndgrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ４を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ４を設定します。
setCstcndgrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先条件グループ５を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先条件グループ５を設定します。
setCstcndgrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
原価計算表を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
原価計算表を設定します。
setCstgSheet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効開始日付 (販売契約/品目提案)を設定します。
setCtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効終了日付 (販売契約/品目提案)を設定します。
setCtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCtrlCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
貿易: 消費税の管理コードを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
調達における品質管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達における品質管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具管理の管理キーを設定します。
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具管理の管理キーを設定します。
setCtrlKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
管理キーは変更できませんを設定します。
setCtrlKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
管理キーは変更できませんを設定します。
setCtrlQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
管理数量を設定します。
setCuAmtBase(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の課税基準額に値を設定します。
setCuAmtBase(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
課税基準額を設定します｡
setCuAmtDoccur(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の伝票通貨額に値を設定します。
setCuAmtDoccur(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
伝票通貨額設定します｡
setCuCurrency(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の通貨コードに値を設定します。
setCuCurrency(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
通貨コードを設定します｡
setCuIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
レコード番号を設定します｡
setCuItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目の会計伝票明細番号に値を設定します。
setCuItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
会計伝票明細番号コードを設定します｡
setCumCfQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積確認数量 (販売数量単位)を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コード通貨を設定します。
setCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コード通貨を設定します。
setCurrIso2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCurrPeriod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当期 (転記期間)を設定します。
setCurrPeriod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期 (転記期間)を設定します。
setCurrPlanPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を設定します。
setCurrenckey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール通貨を設定します。
setCurrenckey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール通貨を設定します。
setCurrenckeyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
購買発注通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
通貨コードを設定します｡
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
通貨コードを設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票通貨を設定します。
setCurrency(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票通貨を設定します。
setCurrency2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
販売伝票通貨を設定します。
setCurrencyAmountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
明細通貨項目一覧を設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ISO通貨コードを設定します｡
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
ISO コード通貨を設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
ISO 通貨コードを設定します。
setCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
ISO コード通貨を設定します。
setCurreniso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
ISO コード通貨を設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループを設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先グループを設定します。
setCustGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 1を設定します。
setCustGrp1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 2を設定します。
setCustGrp2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 3を設定します。
setCustGrp3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 4を設定します。
setCustGrp4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustGrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先グループ 5を設定します。
setCustGrp5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustMat22(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目コード (無効)を設定します。
setCustMat22(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustMat35(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先品目を設定します。
setCustMat35(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先コード1を設定します｡
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
得意先コードを設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
得意先コードを設定します。
setCustomerNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先コードを設定します。
setCustoms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
税関: 税関 (出国時)を設定します。
setCvalueFxd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
区分: 消費金額の確定を設定します。
setCycleTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タクトタイムを設定します。
setDToRefM(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照の有効終了日を設定します。
setDataIndex(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
別の構成のテーブル入力へのポインタを設定します。
setDataorigin(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 入力モードを設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
起算日を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
起算日を設定します。
setDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
日付を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
提案日付タイプを設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
日付タイプ (日、週、月、期間)を設定します。
setDateType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDateWorkBegins(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業開始を設定します。
setDateWorkEnds(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業終了を設定します。
setDeIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
レコード番号を設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
仕入先コードを設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードを設定します｡
setDebtorid(String) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
得意先コードを設定します｡
setDecForRounding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
小数点位置 (その位置まで丸める)を設定します。
setDecForRoundingX(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDeclStatFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 仕入先申告ありを設定します。
setDelDatcatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日カテゴリを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
クライアントレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
区分: 流通チャネルレベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの品目削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管タイプに該当する全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプに該当する全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
WM 倉庫内の全品目データ削除フラグを設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDelFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
データレコード削除 (テーブル繰返し)を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票の削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
削除フラグ: 購買伝票勘定設定を設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
削除フラグを設定します｡
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の削除フラグを設定します。
setDeleteInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
削除フラグを設定します。
setDeletionFlag(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
削除フラグを設定します。
setDelivCompl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出荷完了 区分を設定します。
setDelivDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入期日を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
郵便配達地域を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
郵便配達地域を設定します。
setDelivDis(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
郵便配達地域を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を設定します。
setDelivItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷明細を設定します。
setDelivItemToSearch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷明細を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を設定します。
setDelivNumb(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷伝票を設定します。
setDelivNumbToSearch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷伝票を設定します。
setDelivTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日における指定時間を設定します。
setDeliveryAddressList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入荷伝票アドレス一覧を設定します｡
setDeliveryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入期日を設定します。
setDelkz(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
MRP 要素区分を設定します。
setDeltaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デルタ係数使用による MAD (絶対平均偏差) 平準化を設定します。
setDelyUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷単位を設定します。
setDelyUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷数量単位を設定します。
setDelyUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードでの出荷単位の数量単位を設定します。
setDelygPlnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
出荷プラントを設定します。
setDenominato(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分母を設定します。
setDenominato(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分母を設定します。
setDenominatr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
分母: 基本数量単位へ変換する場合を設定します。
setDepReqId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
個別所要量と包括所要量に対する従属所要量区分を設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
部門コードを設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
部門コードを設定します。
setDepartmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDepartment(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
部署を設定します。
setDepcountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国 (商品発送国)を設定します。
setDepcountryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
出荷国の ISO コードを設定します。
setDeployHoriz(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給分配期間の日数を設定します。
setDeprecPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理に関する償却率 (%)を設定します。
setDeprecPer(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDescrHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
終了品目テキストを設定します。
setDescrLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
開始品目テキストを設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
テキストを設定します｡
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
テキスト (30 文字)を設定します。
setDescript(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループテキスト (短)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業テキスト (短)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
PS: テキスト(短)(第一テキスト行)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
テキストを設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
PS: テキスト(短)(第一テキスト行)を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンテキスト（長）を設定します。
setDescription(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンテキスト（長）を設定します。
setDetermGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
在庫決定グループを設定します。
setDevalInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
低価法: 評価減区分を設定します。
setDialogflag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
区分 (X = 利用不可 /N = 確認なし)を設定します。
setDiffInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先と請求元が異なる場合の請求元コードを設定します｡
setDiscontinu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
打切区分を設定します。
setDispQuan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買発注数量: 表示目的全納入日程合計を設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
流通チャネルを設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDistrChan(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
流通チャネルを設定します。
setDistrChanHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲終了を設定します。
setDistrChanLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
流通チャネルの範囲開始を設定します。
setDistrPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
配賦率 % (複数勘定設定)を設定します。
setDistrProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サイトの商品の物流プロファイルを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrctNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの所在地コードを設定します。
setDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
複数勘定設定の配賦区分を設定します。
setDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
複数勘定設定の配賦区分を設定します。
setDistributingKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)を設定します。
setDistributionChannelSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
流通チャネルの選択オプション一覧を設定します｡
setDistributionchannel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
流通チャネルを設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
所在地を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
所在地を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品部門を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDivision(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
製品部門を設定します。
setDliProfil(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
動的明細プロセッサプロファイルを設定します。
setDliProfil(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷ブロック (伝票ヘッダ)を設定します。
setDlvDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を設定します。
setDlvDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷グループ (明細一括出荷)を設定します。
setDlvGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷優先順位を設定します。
setDlvPrio(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷数量実績 (販売単位)を設定します。
setDlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷数量実績 (販売単位)を設定します。
setDlvStatH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
全明細の出荷ステータスを設定します。
setDlvStatI(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
明細の全体出荷ステータスを設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
契約出荷期間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
契約出荷期間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を設定します。
setDlvTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードでの出荷単位の数量単位を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
用途区分を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
用途区分を設定します。
setDlvschduse(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計伝票番号に値を設定します。
setDocAcDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計伝票番号コードを設定します｡
setDocCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買伝票カテゴリを設定します。
setDocChgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書変更番号 (文書管理システム外)を設定します。
setDocClass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
リリースおよびトランザクション管理を備えた元システムを設定します。
setDocClass(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会社コードに値を設定します。
setDocCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会社コードコードを設定します｡
setDocCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
伝票条件番号を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票日付を設定します｡
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の伝票日付を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票日付 (受信日/送信日)を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の伝票日付に値を設定します。
setDocDocDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の伝票日付コードを設定します｡
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票タイプに値を設定します。
setDocDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票タイプコードを設定します｡
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計期間に値を設定します。
setDocFisPeriod(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計期間コードを設定します｡
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの会計年度に値を設定します。
setDocFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
会計年度コードを設定します｡
setDocFormat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書のページ書式 (文書管理システムによらない)を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票ヘッダテキストに値を設定します。
setDocHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票ヘッダテキストコードを設定します｡
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ドキュメンタリクレジット処理: 内部番号を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ドキュメンタリクレジット処理: 内部番号を設定します。
setDocNumFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるオブジェクト番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
伝票番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売管理伝票番号を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票を設定します。
setDocNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのオブジェクトキーに値を設定します。
setDocObjKey(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
オブジェクトキーコードを設定します｡
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照処理に値を設定します。
setDocObjType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照処理コードを設定します｡
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの伝票の転記日付に値を設定します。
setDocPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
伝票の転記日付コードを設定します｡
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダの参照伝票番号に値を設定します。
setDocRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
参照伝票番号コードを設定します｡
setDocReqd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
文書必須フラグを設定します。
setDocStatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票ステータスを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買伝票カテゴリを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
伝票タイプを設定します｡
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書タイプ (文書管理システムによらない)を設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票タイプを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票タイプを設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDocType(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売伝票タイプを設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダのユーザ名に値を設定します。
setDocUsername(String) - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
ユーザ名コードを設定します｡
setDocVers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書バージョン (文書管理システムによらない)を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票年度を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票年度を設定します。
setDocYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票年度を設定します。
setDocument(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書番号 (文書管理システムによらない)を設定します。
setDocumentDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
登録日付を設定します。
setDocumentDateTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
入力日付 (以前/以降)を設定します。
setDocumentHeader(DocumentHeader) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
伝票ヘッダを設定します｡
setDocumentHeader(PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票ヘッダを設定します｡
setDontUseP(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所配達不可フラグを設定します。
setDontUseS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名住所配達不可フラグを設定します。
setDown(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setDscnt1To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数1を設定します｡
setDscnt2To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数2を設定します｡
setDscnt3To(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
現金割引日数3を設定します｡
setDsctPct1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 1を設定します。
setDsctPct2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
割引率 2を設定します。
setDsnOffice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
研究室/設計室を設定します。
setDunCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先商談回数を設定します。
setDunCount(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先との前回の商談日を設定します。
setDunDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理保留を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理保留を設定します。
setDunnBlock(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
督促処理キーを設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
督促処理キーを設定します。
setDunnKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setDurationConfirmFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測活動期間を設定します。
setDurationConfirmFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
確認の予測期間単位を設定します。
setDurationConfirmFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationMinimum(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短活動期間を設定します。
setDurationMinimumFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動の最小期間(需要予測より)を設定します。
setDurationMinimumFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測最短期間の単位を設定します。
setDurationMinimumFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationMinimumUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最短期間の単位を設定します。
setDurationMinimumUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationNormal(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間を設定します。
setDurationNormalFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準活動期間 (予測)を設定します。
setDurationNormalFcUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準予測期間の単位を設定します。
setDurationNormalFcUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationNormalUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
標準期間/単位を設定します。
setDurationNormalUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setDurationScheduled(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間を設定します。
setDurationScheduledFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間の長さ (予測値)を設定します。
setDurationScheduledUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
処理時間単位を設定します。
setDurationScheduledUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
電子メールアドレスを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
電子メールアドレスを設定します。
setEMail(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
電子メールアドレスを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN) のカテゴリを設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
国際商品コード (EAN/UPC)を設定します。
setEanUpc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setEarlyFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (日)を設定します。
setEarlyFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了日 (予測)を設定します。
setEarlyFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了: 実行 (時刻)を設定します。
setEarlyFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画終了時間(需要予測)を設定します。
setEarlyStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 実行 (日)を設定します。
setEarlyStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始日付(需要予測)を設定します。
setEarlyStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始: 作業実施(時間)を設定します。
setEarlyStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最早計画開始時間(需要予測)を設定します。
setEarnedValueIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗分析関連のマイルストーンを設定します。
setEdition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのバージョンを設定します。
setEdition(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのバージョンを設定します。
setEffODay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
有効終了日を設定します。
setEiIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
レコード番号を設定します｡
setEmaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードを設定します。
setEmaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コード（長）を設定します。
setEmaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードの外部GUIDを設定します。
setEmaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目コードのバージョン番号を設定します。
setEndOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途の終了オフセットを設定します。
setEndOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途の終了オフセットを設定します。
setEndOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了オフセットは変更できませんを設定します。
setEndOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了オフセットは変更できませんを設定します。
setEndOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了オフセット単位を設定します。
setEndOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了オフセット単位を設定します。
setEndOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
setEndOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途終了決定の間隔時間単位 (ISO)を設定します。
setEndRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用終了日の参照日付を設定します。
setEndRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用終了日の参照日付を設定します。
setEndRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
終了参照日付は変更できませんを設定します。
setEndRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
終了参照日付は変更できませんを設定します。
setEndleadtme(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
補充リードタイムの終了日付を設定します。
setEndtime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
終了時刻を設定します。
setEntryDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
会計伝票登録日を設定します。
setEntryQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位での数量を設定します。
setEntryQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位での数量を設定します。
setEntryTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
登録時刻を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入力単位を設定します。
setEntryUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入力単位を設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを設定します。
setEntryUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setEnvtRlvt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 環境関連を設定します。
setEquipment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備番号を設定します。
setEquityType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
持分タイプを設定します。
setEquityType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
持分タイプを設定します。
setErrorTotal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
エラー合計を設定します。
setErrorTotalPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間のエラー合計を設定します。
setErrorsList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
前明細の不正処理に関する情報を設定します。
setErs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ERS（入庫/請求自動決済）を設定します。
setEstPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
概算価格区分を設定します。
setEstimatedCosts(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図の見積原価合計を設定します。
setEuListNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
CAP: CAP 製品一覧番号を設定します。
setEuMatGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
EEC 農産物政策: CAP 生産品グループ - 貿易を設定します。
setEutriDeal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
フラグ: EC 内三角取引を設定します。
setEutriDeal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setEventual(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
偶発的明細を設定します。
setExCertDt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書発行日を設定します。
setExCertId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
法令管理: 認定書区分を設定します。
setExCertNoNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
非該当証明書番号 - 法令管理を設定します。
setExIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
レコード番号を設定します｡
setExRateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (直接相場)を設定します。
setExRateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExRateFx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レート固定区分を設定します｡
setExceptList(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
例外メッセージバーを設定します。
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
直接呼び値換算レートを設定します。
setExchRate(ExchRate) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レート、係数 (通貨ペア)を設定します。
setExchRate(ExchRate) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レート、係数 (通貨ペア)を設定します。
setExchRate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
換算レートを設定します｡
setExchRateCm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
間接呼び値換算レートを設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (間接相場)を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
FI 転記の換算レート (間接相場)を設定します。
setExchRateFiV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchRateV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
間接呼び値換算レートを設定します。
setExchangeRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/統計用換算レートを設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (直接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExchgRateV(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
価格設定/統計の換算レート (間接引用)を設定します。
setExpActivityList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
活動に関する詳細情報を設定します。
setExpActivityList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
活動に関する詳細情報を設定します。
setExpClientData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (クライアントレベル) を設定します。
setExpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 を設定します。
setExpForecastParameters(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から予測データを設定します。
setExpInternationArticleNumbers(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からEANを設定します。
setExpLifoValuationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報からLIFO 関連品目データを設定します。
setExpMaterialDescription(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から品目テキストを設定します。
setExpMaterialText(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報からテキスト (長) を設定します。
setExpMessageList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を読み込みエラーを設定します。
setExpMessageList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を読み込みエラーを設定します。
setExpPlanningData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目マスタ/製品グループの変更伝票構造を設定します。
setExpPlantData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (プラントレベル) を設定します。
setExpProductionResourceToolData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setExpSalesData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から販売データを設定します。
setExpStorageLocationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から品目データ (保管場所レベル)を設定します。
setExpStorageTypeData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から保管域タイプデータを設定します。
setExpTaxClassifications(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から制御データを設定します。
setExpUnitSofmeasure(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
table(Export)情報から数量単位を設定します。
setExpValuationData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から評価データを設定します。
setExpValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
見込金額を設定します。
setExpWarehouseNumberData(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
structure(Export)情報から倉庫番号データを設定します。
setExpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 要素についての詳細情報を設定します。
setExpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 要素についての詳細情報を設定します。
setExpWbsHierarchieList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS 階層についての情報を設定します。
setExpWbsHierarchieList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS 階層についての情報を設定します。
setExpWbsMilestoneList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WBS マイルストーンに関する詳細情報を設定します。
setExpWbsMilestoneList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
WBS マイルストーンに関する詳細情報を設定します。
setExpimpNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
貿易データ番号: MM/SD 伝票を設定します。
setExpimpgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
輸出/輸入品目グループを設定します。
setExpirydate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
有効期間期限日を設定します。
setExpirydate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
有効期間期限日を設定します。
setExportHeader(ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理ヘッダを設定します｡
setExportImportProcedure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易の輸出入手続を設定します。
setExportItemList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
貿易管理明細を設定します｡
setExportNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
貿易データ番号: MM/SD 伝票を設定します。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
センタグループ情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードの詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードの詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
為替換算レート情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
内部指図書詳細情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
内部指図書（一覧）情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
登録された情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions の static メソッド
全バージョンに値をセットします。
setExportParam(BapiController, ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の static メソッド
貿易管理ヘッダに値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の static メソッド
拡張得意先項目に値をセットします。
setExportParam(BapiController, PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の static メソッド
伝票ヘッダに値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
実行結果を取得します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の static メソッド
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の static メソッド
table(Export)情報から入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の static メソッド
table(Export)情報からリターン構造、入出庫伝票明細の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
伝票に登録された情報ををセットします。
setExportParam(BapiController, GoodsMvtHeadret) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret の static メソッド
入出庫伝票ヘッダデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の static メソッド
table(Export)情報から返却されたリターン構造、入出庫伝票明細の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の static メソッド
table(Export)情報からシリアル番号の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
返却された入出庫伝票照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の static メソッド
table(Export)情報からロットの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の static メソッド
table(Export)情報から品目コードの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の static メソッド
table(Export)情報から移動タイプの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の static メソッド
table(Export)情報からプラントの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の static メソッド
table(Export)情報から登録日付の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の static メソッド
table(Export)情報から特殊在庫区分の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の static メソッド
table(Export)情報から保管場所の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の static メソッド
table(Export)情報からトランザクション/イベントタイプの範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の static メソッド
table(Export)情報からユーザ名の範囲の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の static メソッド
table(Export)情報から仕入先の範囲の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
取得した品目在庫確認情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の static メソッド
table(Export)情報から出力テーブル (日付および ATP 数量)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の static メソッド
table(Export)情報から入力テーブル (日付/数量)の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
返却された品目マスタ照会情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタに登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の static メソッド
table(Export)情報から品目データ (クライアントレベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の static メソッド
table(Export)情報からBAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造 の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の static メソッド
実行結果の拡張イン/拡張アウトのチェックボックス構造をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の static メソッド
table(Export)情報から需要予測パラメータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の static メソッド
table(Export)情報から需要予測値のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の static メソッド
table(Export)情報から管理情報設定ヘッダセグメントの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の static メソッド
table(Export)情報から国際商品コード (EAN)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の static メソッド
table(Export)情報から品目テキストを設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の static メソッド
table(Export)情報からテキスト (長)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の static メソッド
table(Export)情報から品目マスタ/製品グループの変更伝票構造の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の static メソッド
table(Export)情報から品目データ (プラントレベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の static メソッド
table(Export)情報から品目マスタの生産資源/治工具 (PRT) 項目の値を セットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages の static メソッド
品目マスタ更新結果をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の static メソッド
table(Export)情報から販売データの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の static メソッド
table(Export)情報から品目データ (保管場所レベル)の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の static メソッド
table(Export)情報から保管域タイプデータの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の static メソッド
table(Export)情報から制御データを設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の static メソッド
table(Export)情報から品目総消費量のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の static メソッド
table(Export)情報から数量単位を設定します。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の static メソッド
table(Export)情報から計画外消費のデータ転送の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の static メソッド
table(Export)情報から評価データの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の static メソッド
table(Export)情報から倉庫番号データを設定します。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の static メソッド
table(Export)情報から処理予定明細データのテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の static メソッド
table(Export)情報から理予定支払方法のテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の static メソッド
table(Export)情報から処理予定条件のテーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の static メソッド
table(Export)情報から前明細の不正処理に関する情報の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の static メソッド
table(Export)情報から請求インタフェースの通信構造テキストの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
返却された請求伝票詳細照会情報をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
取得した請求伝票一覧照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の static メソッド
table(Export)情報から請求伝票詳細の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の static メソッド
table(Export)情報から選定: BLOB 内部データ (SCE)の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の static メソッド
table(Export)情報から選定: インスタンスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の static メソッド
table(Export)情報から選定: 部分設定の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の static メソッド
table(Export)情報から選定: 参照データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の static メソッド
table(Export)情報から選定: 参照明細/インスタンスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の static メソッド
table(Export)情報から選定: 特性値の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の static メソッド
table(Export)情報から条件の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の static メソッド
table(Export)情報から受注における条件更新の通信項目の値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の static メソッド
table(Export)情報からVBAK、VBAP、VBEP のカスタマ拡張の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の static メソッド
table(Export)情報から明細データチェックボックスの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の static メソッド
table(Export)情報から参照キーの出力テーブルの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の static メソッド
table(Export)情報からアドレス (組織/会社) 用 BAPI 参照構造の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の static メソッド
table(Export)情報から伝票取引先の値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の static メソッド
table(Export)情報から明細データの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の static メソッド
table(Export)情報から納入日程行チェックボックスの値をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の static メソッド
table(Export)情報から後続請求伝票の明細テーブルの値をセットします。
setExportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の static メソッド
table(Export)情報からテキストの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票に登録する値ををセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の static メソッド
table(Export)情報からクレジットカードデータの値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
見積伝票に登録する値ををセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の static メソッド
table(Export)情報から得意先受注テーブル情報の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
返却された販売伝票一覧照会情報をセットします。
setExportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の static メソッド
table(Export)情報からステータス情報の値をセットします。
setExportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
返却された販売伝票ステータス一覧照会情報をセットします。
setExpostPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
事後的需要予測に含む履歴値の数を設定します。
setExpostVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
事後的需要予測値を設定します。
setExrateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
FI 転記の換算レート (直接相場)を設定します。
setExrateFi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setExtLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
明細番号を設定します。
setExtOrdNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
外部指図番号を設定します。
setExtServ(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
仕入先のサービス番号を設定します。
setExtWms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
外部倉庫管理の転記の制御を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
VBAK、VBAP、VBEP のカスタマ拡張を設定します。
setExtensionInXList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
拡張イン/拡張アウトのチェックボックス構造を設定します。
setExtensionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
拡張得意先項目を設定します｡
setExtensionOutList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造を設定します。
setExternalObjectId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 外部対象キーを設定します。
setExtmatlgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
外部品目グループを設定します。
setExtpersNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
外部従業員番号を設定します。
setExtrefkey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスの外部参照キーを設定します。
setFactbasval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件基礎値に対する要因を設定します。
setFactbasval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基礎値に対する要因を設定します。
setFactconbas(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件基準の係数 (期間)を設定します。
setFactor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件の加重係数を設定します。
setFactoryCalendar(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
稼働日カレンダを設定します。
setFairShareRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
均等配賦ルールを設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: 内線を設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: 内線を設定します。
setFaxExtens(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: 内線を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一 FAX 番号: ダイヤルコード + 番号を設定します。
setFaxNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
FAX 番号を設定します。
setField(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの項目を設定します。
setFieldname(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
項目名を設定します。
setFijCurCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当期標準原価見積の会計年度を設定します。
setFijFutCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積の会計年度を設定します。
setFijPreCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準原価見積の会計年度を設定します。
setFillLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最大レベル (容積別)を設定します。
setFinalInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書処理完了区分を設定します。
setFinish(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトの計画終了日を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
値参照期間の第一日目を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
値参照期間の第一日目を設定します。
setFirstDay(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
値参照期間の第一日目を設定します。
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
当会計年度を設定します。
setFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
当会計年度を設定します。
setFixLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要供給の一致に対する固定ロットサイズを設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
有効日日付を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
有効日日付を設定します。
setFixValDy(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixdatQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
納期と出荷数量の固定を設定します。
setFixdatQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFixedLot(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定ロットサイズを設定します。
setFixedMilestoneDateBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン日付(基準)を設定します。
setFixedMilestoneDateForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定日付を設定します。
setFixedMilestoneTimeBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
固定マイルストーン時間(基準)を設定します。
setFixedMilestoneTimeForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン固定時間 (F)を設定します。
setFixedPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
固定期間を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量固定区分を設定します。
setFixedQuan(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
長さ 12 の文字項目を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
長さ 12 の文字項目を設定します。
setFkkConacct(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFlagCadCall(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
CAD システムからコールを設定します。
setFlexibleDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: 可変期間を設定します。
setFloatFree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕を設定します。
setFloatFreeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
自由余裕 (予測)を設定します。
setFloatTotal(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計を設定します。
setFloatTotalFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
余裕合計 (予測)を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
建物の階を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
建物の階を設定します。
setFloor(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
建物の階を設定します。
setFollowUp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
フォローアップ品目を設定します。
setFollowUpExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)を設定します。
setFollowUpGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)を設定します。
setFollowUpVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)を設定します。
setForeDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最終需要予測日を設定します。
setForeModel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測モデルを設定します。
setForePds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測期間を設定します。
setForeProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
需要予測プロファイルを設定します。
setForeValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
予測値を設定します。
setForecFlowCont(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
予測フロー管理を設定します。
setForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測終了日を設定します。
setForecastParameters(ForecastParameters) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
予測パラメータを設定します。
setForecastParametersList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測パラメータを設定します。
setForecastValuesList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
需要予測値のデータ転送を設定します。
setForecastView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要予測ビューを設定します。
setForecastView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
需要予測ビューを設定します。
setFormVal1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormVal5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式値を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
タグ列を設定します。
setFormatCol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
タグ列を設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
敬称テキストを設定します。
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
敬称テキストを設定します。
setFormula(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
計算式番号を設定します。
setFormulaTotQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の合計数量の計算式を設定します。
setFormulaTotQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の合計数量の計算式を設定します。
setFormulaTotQtyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
合計数量の計算式は変更できませんを設定します。
setFormulaTotQtyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
合計数量の計算式は変更できませんを設定します。
setFormulaTotUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の総用途値の計算式を設定します。
setFormulaTotUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の総用途値の計算式を設定します。
setFormulaTotUsageNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
すべての用途値を計算する計算式は変更できませんを設定します。
setFormulaTotUsageNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
すべての用途値を計算する計算式は変更できませんを設定します。
setFreeItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
無償明細を設定します。
setFreeLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
自由制限を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前通貨を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算前通貨を設定します。
setFromCurr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算前通貨を設定します。
setFromFactor(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を設定します。
setFromFactorV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算前 通貨単位の係数を設定します。
setFromLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
下限を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を設定します。
setFuncArea(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
機能領域を設定します。
setFuncAreaLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
機能領域を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
BAPI 機能を設定します。
setFunction(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
機能を設定します。
setFunctionalLocation(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
機能場所を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
会計区分を設定します。
setFund(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
会計区分を設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
予算センタを設定します。
setFundsCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
予算センタを設定します。
setFuturePr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
次期標準原価を設定します。
setFwdCons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費期間: 前方を設定します。
setFxdPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
固定価格連産品を設定します。
setFyVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
会計年度バリアントを設定します。
setFyVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
会計年度バリアントを設定します。
setGammaFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
ガンマ係数使用の平滑化のための季節指数を設定します。
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
一般データ情報を設定します｡
setGeneralDataInfo(GeneralDataInfo) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
一般データ情報を設定します｡
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫日付を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫日付を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGiDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出庫日付を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
出庫時刻 (現地時間 - プラント参照)を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出庫時刻 (現地時間 - プラント参照)を設定します。
setGiTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGlAccList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
勘定項目一覧を設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードを設定します｡
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
G/L 勘定コードを設定します。
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
G/L 勘定コードを設定します。
setGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
G/L 勘定コードを設定します。
setGlAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のソートキーに値を設定します。
setGlAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
ソートキーコードを設定します｡
setGlBusArea(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の事業領域に値を設定します。
setGlBusArea(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
事業領域コードを設定します｡
setGlCompCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会社コードに値を設定します。
setGlCompCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会社コードコードを設定します｡
setGlCostcenter(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の原価センタに値を設定します。
setGlCostcenter(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
原価センタコードを設定します｡
setGlDocType(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票タイプに値を設定します。
setGlDocType(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票タイプコードを設定します｡
setGlFiscYear(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計年度に値を設定します。
setGlFiscYear(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計年度コードを設定します｡
setGlGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の総勘定元帳勘定に値を設定します。
setGlGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
総勘定元帳勘定コードを設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
レコード番号を設定します｡
setGlIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
レコード番号を設定します｡
setGlItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の明細テキストに値を設定します。
setGlItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
明細テキストコードを設定します｡
setGlItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の会計伝票明細番号に値を設定します。
setGlItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
会計伝票明細番号コードを設定します｡
setGlList(GlAccList) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
勘定科目一覧を設定します｡
setGlOrderid(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の指図番号に値を設定します。
setGlOrderid(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
指図番号コードを設定します｡
setGlPstngDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の伝票の転記日付に値を設定します。
setGlPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
伝票の転記日付コードを設定します｡
setGlRefKey1(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の取引先参照キーに値を設定します。
setGlRefKey1(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
取引先参照キーコードを設定します｡
setGlTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細の消費税コードに値を設定します。
setGlTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
消費税コードコードを設定します｡
setGlWbsElement(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
G/L 勘定明細のWBS 要素に値を設定します。
setGlWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
WBS 要素コードを設定します｡
setGmCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
BAPI 在庫移動トランザクションのコード割当を設定します。
setGoodsMvtCode(GoodsMvtCode) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動に対するコードのトランザクションへの割当を設定します。
setGoodsMvtHeader(GoodsMvtHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票ヘッダデータを設定します。
setGoodsMvtHeaderList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票ヘッダを設定します。
setGoodsMvtHeadret(GoodsMvtHeadret) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号/入出庫伝票会計年度を設定します。
setGoodsMvtItemList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票明細を設定します。
setGoodsMvtItemsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
リターン構造、入出庫伝票明細を設定します。
setGoodsMvtSerialNumberList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
シリアル番号を設定します。
setGrBasediv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫基準の請求書照合区分を設定します。
setGrGiSlipNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票番号を設定します。
setGrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫区分を設定します。
setGrMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
入庫メッセージ区分を設定します｡
setGrNonVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
非評価入庫を設定します。
setGrNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫番号を設定します。
setGrPrTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
入庫処理日数を設定します。
setGrPrTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
入庫処理日数を設定します。
setGrPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
基準額を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
受領者を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受領者を設定します。
setGrRcpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受領者を設定します。
setGrRcptx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGrToDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
納入最終期限を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
補助金を設定します。
setGrantNbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
補助金を設定します。
setGroValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
総額を設定します。
setGrossWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総重量を設定します。
setGrossWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setGrossWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
総重量を設定します。
setGrossWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
総重量を設定します。
setGroupcond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
グループ条件区分を設定します。
setGroupcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
グループ条件区分を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
グループ名を設定します。
setGroupname(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
グループ名を設定します。
setGrpKey1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 1を設定します。
setGrpKey1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 1を設定します。
setGrpKey2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具のグループキー 2を設定します。
setGrpKey2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具のグループキー 2を設定します。
setGrpReqmts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 所要量グループ化を設定します。
setGtinVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
グローバルトレード明細番号バリアントを設定します。
setGtinVariant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
グローバルトレード明細番号バリアントを設定します。
setHCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通貨コードを設定します。
setHCurr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setHCurrIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
ISO 通貨コードを設定します。
setHandlgGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ワークロード計算のロジスティクス処理グループを設定します。
setHazMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物コードを設定します。
setHazMatNoExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
setHazMatNoGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
setHazMatNoVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
setHazmatprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
危険物インジケータプロファイルを設定します。
setHeadDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
管理情報設定ヘッダセグメントを設定します。
setHeaderTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
ヘッダテキスト一覧を設定します｡
setHeaderTxt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票ヘッダテキストを設定します。
setHeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
高さを設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
BOM 構成の上位レベル明細を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細を設定します。
setHgLvItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setHiLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上位階層明細番号を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層ノード一覧を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層ノード一覧を設定します。
setHierarchyNodesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層ノード一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
階層値一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
階層値一覧を設定します。
setHierarchyValuesList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
階層値一覧を設定します。
setHierlevel(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層のエントリレベルを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を設定します。
setHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを設定します。
setHighVisc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 高粘性を設定します。
setHistVals(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
履歴値の数を設定します。
setHlItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買伝票中の上位明細を設定します。
setHold(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
購買発注の不完全を設定します。
setHomeCity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村 (郵便用市区町村と異なる場合)を設定します。
setHomecityno(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
別の市区町村 (市区町村/地名ファイル)を設定します。
setHomepage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
URI 例: ホームページ、FTP アドレスを設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地-号を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地-号を設定します。
setHouseNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地-号を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
番地補足を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
番地補足を設定します。
setHouseNo2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地補足を設定します。
setHouseNo3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
番地範囲を設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージクラスを設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージクラスを設定します。
setImpExtensionOut(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造からインポート情報を 設定します。
setImpInternationArticleNumbers(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANからインポート情報を設定します。
setImpMaterialDescription(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストからインポート情報を設定します。
setImpMaterialText(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長) からインポート情報を設定します。
setImpTaxClassifications(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御データからインポート情報を設定します。
setImpUnitSofmeasure(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位からインポート情報を設定します。
setImpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
詳細情報を必要とする WBS 要素を設定します。
setImpWbsElementList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
詳細情報を必要とする WBS 要素を設定します。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
センタグループを検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
仕入先コードの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
得意先コードの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
為替換算レート情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
内部指図書詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
内部指図書（一覧）情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
WEBの詳細情報を検索する条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードを検索する条件ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader の static メソッド
条件ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem の static メソッド
条件明細に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits の static メソッド
外注基本契約制限に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService の static メソッド
外注サービスに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount の static メソッド
外注サービス勘定設定に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText の static メソッド
外注サービステキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress の static メソッド
入荷伝票アドレスヘッダに値をセットします。
setImportParam(BapiController, ExportHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader の static メソッド
貿易管理ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem の static メソッド
貿易管理明細に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension の static メソッド
拡張得意先項目に値をセットします。
setImportParam(BapiController, PurchaseHeaderPost) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader の static メソッド
伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText の static メソッド
ヘッダテキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText の static メソッド
明細テキストに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits の static メソッド
外注制限に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner の static メソッド
得意先に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment の static メソッド
入出庫予定ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount の static メソッド
勘定設定に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule の static メソッド
納入日程に値をセットします。
setImportParam(BapiController, Versions) - class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions の static メソッド
バージョン管理に値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
伝票に登録する値ををセットします。
setImportParam(BapiController, GoodsMvtHeader) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader の static メソッド
入出庫伝票ヘッダデータに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList の static メソッド
リターン構造、入出庫伝票ヘッダに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems の static メソッド
リターン構造、入出庫伝票明細に値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
伝票に登録する値ををセットします。
setImportParam(BapiController, GoodsMvtCode) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode の static メソッド
在庫移動に対するコードのトランザクションへの割当の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem の static メソッド
リターン構造、入出庫伝票明細の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber の static メソッド
シリアル番号の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
入出庫伝票一覧照会する情報をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa の static メソッド
ロットの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa の static メソッド
品目コードの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa の static メソッド
移動タイプの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa の static メソッド
プラントの範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa の static メソッド
登録日付の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa の static メソッド
特殊在庫区分の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa の static メソッド
保管場所の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa の static メソッド
ParamTrEvTypeRaの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa の static メソッド
ユーザ名の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa の static メソッド
仕入先の範囲の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目在庫確認情報を取得する為の条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex の static メソッド
出力テーブル (日付および ATP 数量)の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx の static メソッド
入力テーブル (日付/数量)の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ照会条件ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタに登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn の static メソッド
処理予定明細データのテーブルの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn の static メソッド
処理予定支払方法のテーブルの値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn の static メソッド
処理予定条件のテーブルの値をセットします。
setImportParam(BapiController, CreatorDataIn) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn の static メソッド
取り込まれる日付の順序の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors の static メソッド
前明細の不正処理に関する情報の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn の static メソッド
請求インタフェースの通信構造テキストの値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
請求伝票一覧照会情報を、取得する為に必要な情報をセットします。
setImportParam(BapiController, RefDocRange) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange の static メソッド
前伝票の範囲の値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList の static メソッド
請求伝票詳細に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob の static メソッド
選定: BLOB 内部データ (SCE)に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst の static メソッド
選定: インスタンスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf の static メソッド
選定: 部分設定に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef の static メソッド
選定: 参照データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst の static メソッド
選定: 参照明細/インスタンスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue の static メソッド
選定: 特性値に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk の static メソッド
選定: バリアント条件キーに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn の static メソッド
条件に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX の static メソッド
受注における条件更新の通信項目に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn の static メソッド
VBAK、VBAP、VBEP のカスタマ拡張に値をセットします。
setImportParam(BapiController, HeaderIn, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn の static メソッド
販売伝票ヘッダデータに値をセットします。
setImportParam(BapiController, HeaderInX, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX の static メソッド
ヘッダデータチェックボックスに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn の static メソッド
明細データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX の static メソッド
明細データに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys の static メソッド
参照キーの出力テーブルに値をセットします。
setImportParam(BapiController, LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch の static メソッド
内部制御パラメータに値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses の static メソッド
アドレス (組織/会社) 用 BAPI 参照構造に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners の static メソッド
伝票取引先に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn の static メソッド
納入日程行に値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX の static メソッド
納入日程行チェックボックスに値をセットします。
setImportParam(BapiController, Sender) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender の static メソッド
論理システム - 送信者に値をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess の static メソッド
後続請求伝票の明細テーブルに値をセットします。
setImportParam(BapiController, List, String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText の static メソッド
テキストに値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票に登録する値ををセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard の static メソッド
クレジットカードデータに値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
見積伝票に登録する値ををセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders の static メソッド
得意先受注テーブル情報の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売伝票一覧の検索条件をセットします。
setImportParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo の static メソッド
ステータス情報の値をセットします。
setImportParam(BapiController) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売伝票ステータス一覧の検索条件をセットします。
setInCharge(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタ責任者を設定します｡
setInHouse(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
内部生産を設定します。
setInHouse(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
内部生産を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ1を設定します｡
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ (1)を設定します。
setIncoterms1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
インコタームズ2を設定します｡
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
インコタームズ (2)を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
インコタームズ 2を設定します。
setIncoterms2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIndPostToInspStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質検査中在庫への転記を設定します。
setIndProposeQuanx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
提案数量 (初期数量)を設定します。
setIndSector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
産業コードを設定します。
setIndSector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
産業コードを設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList のメソッド
レコード番号を設定します。
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
レコード番号を設定します｡
setIndex(int) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
レコード番号を設定します｡
setIndus3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目 CFOP カテゴリを設定します。
setInfIndex(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数を設定します。
setInfoRec(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買情報番号を設定します。
setInfoRec(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買情報番号を設定します。
setInfoUpd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買情報更新区分を設定します。
setInform(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
情報行を設定します。
setInhseprodt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
内製日数を設定します。
setInitPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化で使用する履歴値の数を設定します。
setInitialize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
初期化区分を設定します。
setInpfldcheck(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
項目無効時の応答を設定します。
setInquiryCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setInquiryCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: インスタンスを設定します。
setInquiryCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 部分設定を設定します。
setInquiryCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照明細/インスタンスを設定します。
setInquiryCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 参照データを設定します。
setInquiryCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: 特性値を設定します。
setInquiryCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
選定: バリアント条件キーを設定します。
setInquiryConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
条件を設定します。
setInquiryConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
受注における条件更新の通信項目を設定します。
setInquiryHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
引合伝票ヘッダデータを設定します。
setInquiryHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
ヘッダデータチェックボックスを設定します。
setInquiryItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データを設定します。
setInquiryItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細データチェックボックスを設定します。
setInquiryKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
参照キーの出力テーブルを設定します。
setInquiryPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
伝票取引先を設定します。
setInquirySchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行を設定します。
setInquirySchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
納入日程行チェックボックスを設定します。
setInquiryTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テキストを設定します。
setInspInt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
次回再検査までの間隔を設定します。
setInspSetupFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目/プラントに QM 検査データ設定を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選定におけるインスタンス番号を設定します。
setInstId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
明細番号内部採番を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細番号内部採番を設定します。
setIntNumberAssignment(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細番号内部採番を設定します。
setIntObjNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
選定 (内部オブジェクト番号)を設定します。
setIntProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setIntProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setInterestProf(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プロジェクト/指図金利計算の金利プロファイルを設定します。
setInternalChar(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
内部特性を設定します。
setInternalObjectId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
SAP 内部対象キーを設定します。
setInternationArticleNumbersList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
EANを設定します。
setInternationalArtnosList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
国際商品コード (EAN)を設定します。
setInterop(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
移動時間を設定します。
setInvCorrFac(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
在庫修正係数を設定します。
setInvMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
会社固有 (内部) 在庫管理品目コードを設定します。
setInvMatNoExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)を設定します。
setInvMatNoGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)を設定します。
setInvMatNoVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)を設定します。
setInvestProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
設備投資案件プロファイルを設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
請求書一覧日程 (稼働日カレンダ指定)を設定します。
setInvoSched(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setInvoicePercentage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
請求金額率 (%)を設定します。
setIrInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
請求書受領区分を設定します。
setIsoUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
単位の ISO コードを設定します。
setIssStLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫保管場所を設定します。
setIssueUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出庫単位を設定します。
setIssueUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの出庫単位を設定します。
setItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始明細を設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買伝票の明細カテゴリを設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
一般明細カテゴリグループを設定します。
setItemCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目マスタの明細カテゴリグループを設定します。
setItemCatExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票の明細カテゴリを設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
明細カテゴリ (販売伝票)を設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細カテゴリ (販売伝票)を設定します。
setItemCateg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setItemIntvl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
明細番号間隔を設定します｡
setItemNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理オブジェクト: 明細を設定します。
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
明細テキストを設定します。
setItemText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
明細テキストを設定します。
setItemTextList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細テキスト一覧を設定します｡
setItemguidAtp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ATP: 暗号 - DELNR および DELPSを設定します。
setItemguidAtp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setItemsForRelease(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
区分: 承認待ち購買発注のみ照会を設定します。
setItemsForRelease(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
区分: 承認待ち購買発注のみ照会を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
条件明細番号を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
明細番号 (販売管理伝票)を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
販売伝票明細を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
明細番号 (販売管理伝票)を設定します。
setItmNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売伝票明細を設定します。
setItmTypeUsage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細用途を設定します。
setItmTypeUsage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setJitRelvt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: JIT 納入日程の関連明細を設定します。
setJointVenture(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャを設定します。
setJointVenture(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャを設定します。
setJvJibClass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE クラスを設定します。
setJvJibClass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE クラスを設定します。
setJvJibSubClassA(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
JIB/JIBE サブクラスAを設定します。
setJvJibSubClassA(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
JIB/JIBE サブクラスAを設定します。
setJvObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ジョイントベンチャ対象タイプを設定します。
setJvObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ジョイントベンチャ対象タイプを設定します。
setKanbanInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
かんばん区分を設定します。
setKblanguage(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
システム設定の言語を設定します。
setKbname(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースオブジェクトを設定します。
setKbprofile(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
ナレッジベースプロファイルを設定します。
setKbversion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
SCE ナレッジベースの実行時バージョンを設定します。
setLEquip1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1を設定します。
setLEquip2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2を設定します。
setLEquip3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3を設定します。
setLabelForm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベル書式を設定します。
setLabelType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ラベルタイプを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
言語キーを設定します。
setLangu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
言語キーを設定します。
setLanguCr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスレコード登録オリジナル言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
言語キーの ISO コードを設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
ISO 639 準拠の言語を設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
ISO 639 準拠の言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ステータスおよび業務トランザクションテキストの言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ステータスおよび業務トランザクションテキストの言語を設定します。
setLanguage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
言語キーを設定します。
setLangucriso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 639 準拠の言語を設定します。
setLastChnge(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最終変更日付を設定します。
setLastItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
最終明細番号を設定します。
setLatestDatesIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: 最遅日を設定します。
setLatestFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(日付)を設定します。
setLatestFinishDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済終了日付(需要予測)を設定します。
setLatestFinishTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅終了: 作業(時間)を設定します。
setLatestFinishTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画終了時間 (予測)を設定します。
setLatestStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(日付)を設定します。
setLatestStartDateFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始日付(需要予測)を設定します。
setLatestStartTime(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画最遅開始: 作業(時間)を設定します。
setLatestStartTimeFc(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
最遅計画済開始時間(需要予測)を設定します。
setLeadinguom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
主要ロット特定数量単位を設定します。
setLeft(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setLength(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
長さを設定します。
setLeqUnit1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 1 の数量単位を設定します。
setLeqUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 1 の数量単位を設定します。
setLeqUnit2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 2 の数量単位を設定します。
setLeqUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 2 の数量単位を設定します。
setLeqUnit3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
積載装置数量 3 の数量単位を設定します。
setLeqUnit3Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードによる積載装置数量 3 の数量単位を設定します。
setLiIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
レコード番号を設定します｡
setLifoFifo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO/FIFO 関連を設定します。
setLifoValuationData(LifoValuationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 関連品目データを設定します。
setLifoValuationLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価レベルを設定します。
setLifovaluationlevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
LIFO 評価レベルを設定します。
setLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
全体制限を設定します。
setLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
全体制限を設定します。
setLimitLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画外、明細制限を設定します。
setLimitsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
外注制限一覧を設定します｡
setLineDepth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票での明細行階層レベルを設定します。
setLineDepth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票での明細行階層レベルを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
伝票明細行の一意 IDを設定します。
setLineId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
伝票明細行の一意 IDを設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限の内部明細番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
内部明細番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細行番号を設定します。
setLineNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
内部明細番号を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載日付を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載日付を設定します。
setLoadDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
積載時刻 (現地時間: 出荷ポイント)を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
積載時刻 (現地時間: 出荷ポイント)を設定します。
setLoadTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLoadinggrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
積載グループを設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
場所を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 5を設定します。
setLocation(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 5を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: メッセージシリアル番号を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: メッセージシリアル番号を設定します。
setLogNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
アプリケーションログ: ログ番号を設定します。
setLogNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
アプリケーションログ: ログ番号を設定します。
setLogSystem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
論理システムを設定します。
setLogSystemOwn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを設定します。
setLogSystemOwn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
内部制御パラメータを設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
内部制御パラメータを設定します。
setLogicSwitch(LogicSwitch) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
内部制御パラメータを設定します。
setLogsystem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
論理システムを設定します｡
setLongText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
総勘定元帳勘定テキスト(長)を設定します｡
setLooseorliq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: バルク/液体を設定します。
setLotIncrement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるためのロットサイズ増分を設定します。
setLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ロットサイズを設定します。
setLotsizekey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ロットサイズ (品目計画)を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
ロット番号を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
品目コードを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
移動タイプ (在庫管理)を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
プラントを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
伝票の転記日付を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
特殊在庫区分を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
保管場所を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
トランザクション/イベントタイプを設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
ユーザ名を設定します。
setLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
仕入先勘定コードを設定します。
setMainEan(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
区分: 主要 EANを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
更新ステータスを設定します。
setMaintStat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
更新ステータスを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者製品コードを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品コードを設定します。
setManuMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品コードを設定します。
setManufProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者製品プロファイルを設定します。
setManufProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者製品プロファイルを設定します。
setManufacturerPartNumbList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
製造業者と製造者製品コード一覧を設定します｡
setMaskId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 要素 ID(短)の選択マスクを設定します。
setMastCond(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
期間依存条件伝票を設定します。
setMastContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
グループマスタ契約番号を設定します。
setMastContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMasterData(MasterData) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図のマスタデータ構造を設定します。
setMasterData(MasterData) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図のマスタデータ構造を設定します。
setMatCfop(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目 CFOP カテゴリを設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票番号を設定します。
setMatDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
入出庫伝票番号を設定します。
setMatEntrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入力品目を設定します。
setMatEntrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMatGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目グループを設定します。
setMatGrpSm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループ: 梱包材を設定します。
setMatGrpTrans(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取替えマトリクスに対する品目のグループを設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMatOrigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の原産地を設定します。
setMatOrigin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の原産地を設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目価格設定グループを設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目価格設定グループを設定します。
setMatPrGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目更新完了ステータスを設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMatcmpllvl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目完了レベルを設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫伝票の明細を設定します。
setMatdocItm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
入出庫伝票の明細を設定します。
setMatdocTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求の入出庫伝票番号を設定します。
setMatdocumentyear(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票会計年度を設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
品目コードを設定します｡
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
品目コードを設定します。
setMaterial(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
品目コードを設定します。
setMaterialDescriptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目テキストを設定します。
setMaterialDescriptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目テキストを設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コード（長）を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の品目コード (長)を設定します｡
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialExternal(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の品目コード (長) (今後のリリースで開発)を設定します。
setMaterialFixed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ロックされている品目を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードの外部GUIDを設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL の外部 GUIDを設定します｡
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL の外部 GUID (今後のリリースで開発)を設定します。
setMaterialLongTextList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
テキスト (長)を設定します。
setMaterialRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
品目コードの範囲を設定します。
setMaterialShortDescselList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目テキストの選択オプション一覧を設定します。
setMaterialTextList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
テキスト (長)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードのバージョン番号を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
項目 MATERIAL のバージョン番号を設定します｡
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
項目 MATERIAL のバージョン番号 (今後のリリースで開発)を設定します。
setMaterialdocument(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
入出庫伝票番号を設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目運賃グループを設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目運賃グループを設定します。
setMatfrgtgrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatitemTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送数量入出庫伝票明細を設定します。
setMatlDesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
品目テキストを設定します。
setMatlDesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
品目テキストを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループを設定します。
setMatlGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMatlGrp1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 1を設定します。
setMatlGrp2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 2を設定します。
setMatlGrp3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 3を設定します。
setMatlGrp4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 4を設定します。
setMatlGrp5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目グループ 5を設定します。
setMatlStats(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目統計グループを設定します。
setMatlType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目タイプを設定します。
setMatlType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品目タイプを設定します。
setMatlUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
品目の用途を設定します。
setMatlUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目の用途を設定します。
setMatnrHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
終了品目コードを設定します。
setMatnrListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードと品目テキスト一覧を設定します｡
setMatnrLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
開始品目コードを設定します。
setMatnrSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
品目コードの選択オプション一覧を設定します。
setMatyearTrCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消予定の転送要求入出庫伝票年度を設定します。
setMaxLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最大ロットサイズを設定します。
setMaxPlDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細ごとの分割納入可能な最大回数を設定します。
setMaxPlDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxRows(String) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
選択予定品目の最大数を設定します。
setMaxSbQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最大棚番在庫数量を設定します。
setMaxStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大在庫レベルを設定します。
setMaxdevDay(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
シフト所要日数を設定します。
setMaxdevDay(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxdevamnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (絶対値)を設定します。
setMaxdevamnt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxdevper(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
数量に関する許容偏差 (%)を設定します。
setMaxdevper(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMaxlotsize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最大ロットサイズを設定します。
setMeAnzSub(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位数を設定します。
setMeanAbsolDev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
絶対平均偏差 (MAD)を設定します。
setMeanAbsolDevPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の平均絶対偏差を設定します。
setMemoryComplete(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがない場合に購買発注を保留する区分を設定します｡
setMemoryUnComplete(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
エラーがある場合に購買発注を保留する区分を設定します｡
setMerchidcl(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 決済代行会社のマーチャント IDを設定します。
setMerchidcl(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
支払カード: 決済代行会社のマーチャント IDを設定します。
setMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージテキストを設定します。
setMessage(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージテキストを設定します。
setMessageId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージ IDを設定します。
setMessageNumber(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
システムメッセージ番号を設定します。
setMessageText(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージのテキスト行を設定します。
setMessageType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メッセージタイプを設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ変数を設定します。
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ変数を設定します。
setMethod(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
メソッドを設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
製造者番号を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
製造者番号を設定します。
setMfrNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造者番号を設定します。
setMfrNoExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
外部製造者コード名または番号を設定します。
setMilestone(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
用途を設定します。
setMilestoneNumber(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン番号を設定します。
setMilestoneUsage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン用途を設定します。
setMilitId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ID: 武器を設定します。
setMinDely(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
納品書処理時の最小納入数量を設定します。
setMinLotSize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
需要と供給を一致させるための最小ロットサイズを設定します。
setMinMto(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
受注製造品最少受注数量を設定します。
setMinOrder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
基本数量単位での最小受注数量を設定します。
setMinSafetyStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小安全在庫を設定します。
setMinSbQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
最小棚番在庫数量を設定します。
setMinlotsize(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最小ロットサイズを設定します。
setMinremlife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
最低有効期間残を設定します。
setMinremlife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
最低有効期間残を設定します。
setMixedMrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
二重 MRP 区分を設定します。
setMlActive(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目レベルで有効な品目元帳を設定します。
setMlSettle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目元帳決済: 管理を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
マニュアル請求書更新を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
マニュアル請求書更新を設定します。
setMnInvoice(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setModelSi(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択区分を設定します。
setModelSp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
モデル選択方式を設定します。
setMovPrPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期移動平均原価/期間平均原価を設定します。
setMovPrPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の移動平均原価/期間単価を設定します。
setMoveBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫ロットを設定します。
setMoveBatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫ロットを設定します。
setMoveMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫品目を設定します。
setMoveMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫品目を設定します。
setMoveMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setMoveMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setMoveMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
setMoveMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)を設定します。
setMoveMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setMoveMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setMovePlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫プラントを設定します。
setMovePlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫プラントを設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動理由を設定します。
setMoveReas(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動理由を設定します。
setMoveStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入庫/出庫保管場所を設定します。
setMoveStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫保管場所を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動タイプ (在庫管理)を設定します。
setMoveType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動タイプ (在庫管理)を設定します。
setMoveTypeRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
移動タイプの範囲を設定します。
setMoveValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
転送ロットの評価タイプを設定します。
setMoveValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
転送ロットの評価タイプを設定します。
setMovingPr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
移動平均原価/期間単位価格を設定します。
setMrpAreaExists(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: MRP エリア登録済を設定します。
setMrpCtrler(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP 管理者を設定します。
setMrpGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP グループを設定します。
setMrpInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP 区分を設定します。
setMrpRelevancyDepRequirements(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
従属所要量と MRP の関連性を設定します。
setMrpType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
MRP タイプを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
資材所要量計画 (MRP) ビューを設定します。
setMrpprofile(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目: MRP プロファイルを設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目利用可能日を設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目利用可能日を設定します。
setMsDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
品目供給ステージ (現地時刻: プラント参照)を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
品目供給ステージ (現地時刻: プラント参照)を設定します。
setMsTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setMsgToIm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
区分: 在庫管理への出力を設定します。
setMultRefM(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費データ参照品目の乗数を設定します。
setMvtInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
移動区分を設定します。
setMvtInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
移動区分を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
管理領域名を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
一般名称を設定します｡
setName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
発注者名称を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 1を設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
名称 1を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
名称 2を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 2を設定します。
setName2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 2を設定します。
setName3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 3を設定します。
setName3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 3を設定します。
setName4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
名称 4を設定します。
setName4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
名称 4を設定します。
setName_2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 2を設定します。
setName_3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 3を設定します。
setName_4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
名称 4を設定します。
setNbSlips(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入庫/出庫票の印刷部数を設定します。
setNbSlipsx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNegStocks(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントにおけるマイナス在庫許可を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
通貨額を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
正味価格を設定します。
setNetPrice(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
正味価格を設定します。
setNetValHd(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注正味額 (伝票通貨)を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買発注通貨による正味発注額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
明細の正味額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
正味金額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
伝票通貨による正味額を設定します。
setNetValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票通貨での受注明細正味額を設定します。
setNetValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
正味金額を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の正味重量を設定します。
setNetWeight(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定割当のネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
勘定割当のネットワーク番号を設定します。
setNetwork(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
勘定割当のネットワーク番号を設定します。
setNetworkAssignment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ネットワーク割当を設定します。
setNetworkAssignment(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワーク割当を設定します。
setNetworkProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ネットワークプロファイルを設定します。
setNoAuthority(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
権限チェックなし区分に購買発注を保留する区分を設定します｡
setNoCosting(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算なしを設定します。
setNoDisct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
現金値引対象外明細を設定します。
setNoFrlimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを設定します。
setNoGrPost(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先が入庫を転記していませんを設定します。
setNoGrPost(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNoLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
制限なしを設定します。
setNoLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
制限なしを設定します。
setNoMatmast(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目マスタ確認禁止を設定します。
setNoMessage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
出力決定なし区分に購買発注を保留する区分を設定します｡
setNoMessageReq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
メッセージ不要区分を設定します｡
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
納入完了区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
納入完了 区分を設定します。
setNoMoreGr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
納入完了 区分を設定します。
setNoPriceFromPo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
最終伝票からの価格転送なし区分を設定します｡
setNoPstChgnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 振替要求通知登録禁止を設定します。
setNoRounding(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注明細での非表示丸めを設定します。
setNoSheets(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書枚数 (文書管理システムによらない)を設定します。
setNoTransferReq(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
区分: 転送要求未登録を設定します。
setNoappllog(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
アプリケーションログ書込なしを設定します。
setNochangedoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
変更伝票書込なしを設定します。
setNondItax(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setNostructure(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
チェックボックスを設定します。
setNotMrpApplicable(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: MRP への入出庫予定の適用不可と購買依頼未登録を設定します。
setNotifNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
通知番号を設定します。
setNotifNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージ、メッセージ番号を設定します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージ、メッセージ番号を設定します。
setNumberOfCapacities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
所要能力数を設定します。
setNumconvert(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件単位を基本単位へ変換する分子を設定します。
setNumconvert(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件単位を基本単位へ変換する分子を設定します。
setNumerator(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
基本数量単位への換算分子を設定します。
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象キーを設定します。
setObjKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象キーを設定します。
setObjTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
言語依存対象テキストを設定します。
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
対象タイプを設定します。
setObjType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
対象タイプを設定します。
setObjectGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス用 TYPE_OF ステートメントの GUIDを設定します。
setObjectNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
対象番号を設定します。
setObjectNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
対象番号を設定します。
setObjectType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
オブジェクトタイプを設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス (言語非依存)を設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
対象クラスを設定します。
setObjectclass(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
対象クラスを設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
オブジェクトクラス、言語依存を設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
オブジェクトクラス、言語依存を設定します。
setObjectclassExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
オブジェクトクラス、言語依存を設定します。
setOffsetMilestoneDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン日付のオフセットを設定します。
setOffsetMilestoneDateUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーンのオフセットのための時間単位を設定します。
setOffsetMilestoneDateUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
単位の ISO コードを設定します。
setOffsetPercentage(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
活動日に対するマイルストーンの百分率によるオフセットを設定します。
setOffsetStartEndIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
区分: オフセット用の参照（開始/終了活動日）を設定します。
setOldMatNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
旧品目コードを設定します。
setOpenQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
未処理数量のある明細を設定します。
setOperationMeasureUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動単位を設定します。
setOperationMeasureUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setOptimLev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
最適化レベルを設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOption(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 OPTION (範囲テーブル)を設定します。
setOrdCosts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注原価 (BAPI インタフェース)を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注理由 (取引理由)を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrdReason(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注理由 (取引理由)を設定します。
setOrdbilltyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注関連請求伝票に対する提案請求伝票タイプを設定します。
setOrdcombIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
受注結合出荷区分を設定します。
setOrdcombIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrdcompIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
受注結合出荷区分を設定します。
setOrdcompIn(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (個別値、または下限値)を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (個別値、または下限値)を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
指図番号を設定します。
setOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
指図番号を設定します。
setOrderCcardList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
クレジットカードデータを設定します。
setOrderCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setOrderCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: インスタンスを設定します。
setOrderCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 部分設定を設定します。
setOrderCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照明細/インスタンスを設定します。
setOrderCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 参照データを設定します。
setOrderCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: 特性値を設定します。
setOrderCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
選定: バリアント条件キーを設定します。
setOrderConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件を設定します。
setOrderConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
条件チェックボックスを設定します。
setOrderExternalNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (個別値、または下限値)を設定します。
setOrderExternalNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (個別値、または下限値)を設定します。
setOrderExternalNoTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
外部指図番号 (上限値)を設定します。
setOrderExternalNoTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
外部指図番号 (上限値)を設定します。
setOrderHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票ヘッダを設定します。
setOrderHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
受注伝票チェックリストを設定します。
setOrderItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データを設定します。
setOrderItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
明細データチェックボックスを設定します。
setOrderItno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図明細番号を設定します。
setOrderItno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図明細番号を設定します。
setOrderKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
参照キーの出力テーブルを設定します。
setOrderListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
選択指図一覧を設定します。
setOrderListList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
選択指図一覧を設定します。
setOrderName(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
テキストを設定します。
setOrderName(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
テキストを設定します。
setOrderPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
伝票取引先を設定します。
setOrderProb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の受注可能性を設定します。
setOrderProb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrderReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注理由を設定します。
setOrderSchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データを設定します。
setOrderSchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
納入日程行データチェックボックスを設定します。
setOrderTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テキストを設定します。
setOrderTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図番号 (上限値)を設定します。
setOrderTo(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図番号 (上限値)を設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
指図タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
指図タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
販売伝票タイプを設定します。
setOrderType(String) - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
販売伝票タイプを設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
指図番号を設定します。
setOrderid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格単位を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注価格単位 (購買管理)を設定します。
setOrderprUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注価格単位 (購買管理)を設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買発注価格のISOコードを設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
単位の ISO コードを設定します。
setOrderprUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setOrigGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
発生源グループ (原価要素の下位区分)を設定します。
setOrigMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
品目発生源を設定します。
setOriginalBatchFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロット管理区分を設定します。
setOriginalBatchRefMaterial(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
元ロットの参照品目を設定します。
setOrigindoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
開始伝票を設定します。
setOurRef(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
社内参照番号を設定します｡
setOutlInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
区分: 出力行を設定します。
setOutlLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
グループの階層レベルを設定します。
setOutlNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
アウトラインレベルを設定します。
setOverDlvTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
過剰納入許容範囲を設定します。
setOverTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
過剰納入許容範囲リミットを設定します。
setOverallprf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
指図変更管理の全体プロファイルを設定します。
setOverdlvtol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
過剰納入許容範囲を設定します。
setOverdlvtol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOverhdKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
間接費キーを設定します。
setOverhdKey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setOverheadGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価計算間接費グループを設定します。
setOverheadKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
間接費キーを設定します。
setOverheadKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
間接費キーを設定します。
setOvfTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
超過許容値を設定します。
setOvfUnlim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
契約外サービス制限なしを設定します。
setPMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setPMatExt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
setPMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setPMatVers(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPaAllocNmbr(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細のソートキーに値を設定します。
setPaAllocNmbr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
ソートキーコードを設定します｡
setPaBlineDate(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の期日計算の支払基準日に値を設定します。
setPaBlineDate(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
期日計算の支払基準日コードを設定します｡
setPaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の総勘定元帳勘定に値を設定します。
setPaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
総勘定元帳勘定コードを設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
レコード番号を設定します｡
setPaIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
レコード番号を設定します｡
setPaItemText(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の明細テキストに値を設定します。
setPaItemText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
明細テキストコードを設定します｡
setPaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の会計伝票明細番号に値を設定します。
setPaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
会計伝票明細番号コードを設定します｡
setPaPymtMeth(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の支払方法に値を設定します。
setPaPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
支払方法を設定します｡
setPaVendorNo(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
仕入先明細の仕入先または債権者の勘定コードに値を設定します。
setPaVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
仕入先または債権者の勘定コードコードを設定します｡
setPackVoUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
容積単位 (許容梱包容積)を設定します。
setPackVoUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの容積単位 (許容梱包容積)を設定します。
setPackWtUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位 (許容梱包重量)を設定します。
setPackWtUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位 (許容梱包重量)を設定します。
setPageNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
文書ページ番号 (文書管理システムによらない)を設定します。
setPageformat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造メモのページ書式を設定します。
setParCompco(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済会社コードを設定します。
setParEff(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効性パラメータへの値割当/変更番号よりも優先を設定します。
setParamOpt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
パラメータ最適化用の区分を設定します。
setParameter(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータ名を設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
1 レベル上位の行 IDを設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
1 レベル上位の行 IDを設定します。
setParentId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
選定におけるインスタンス番号を設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
取引先勘定コードを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
取引先勘定コードを設定します。
setPartAcct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引先勘定コードを設定します。
setPartDeliv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
明細レベルでの分割納入 (在庫転送)を設定します。
setPartDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細レベルの分納納入を設定します。
setPartDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPartInv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
一部請求区分を設定します。
setPartOfGuid(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
インスタンス用 PART_OF ステートメントの GUIDを設定します。
setPartOfNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
Part_of 明細番号を設定します。
setPartnNumb(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
得意先コード 1を設定します。
setPartnRole(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
取引先機能を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerAddressesList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
アドレス (組織/会社) 用 BAPI 参照構造を設定します。
setPartnerList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
取引先一覧を設定します｡
setPartnerdesc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
言語別取引先機能テキストを設定します。
setPayer(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払人を設定します。
setPaymentTerms(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
支払条件キーを設定します。
setPaytype(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払手段: 支払カード計画の明細分類を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPboxcitNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村私書箱コード (市ファイル)を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
パッケージ番号を設定します。
setPckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
パッケージ番号を設定します。
setPcode1Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村郵便番号の拡張子 例: 郵便番号 +4+2を設定します。
setPcode2Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号拡張子 例: 郵便番号 +4+2を設定します。
setPcode3Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
主要得意先郵便番号拡張子 例: 郵便番号 +4+2を設定します。
setPctrName(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
一般名称を設定します｡
setPerCurCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
現行標準原価見積期間を設定します。
setPerFutCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
将来標準原価見積期間を設定します。
setPerPreCostEst(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前標準原価見積期間を設定します。
setPercentOfWork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業の比率 (%)を設定します。
setPercentage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定金額配賦のパーセントを設定します。
setPercentageOfCompletion(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
進捗度 (%)を設定します。
setPeriodInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
期間区分を設定します。
setPeriodInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
期間区分を設定します。
setPeriodIndExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
有効期間期限日の期間区分を設定します。
setPeriodIndExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日の期間区分を設定します。
setPeriodProfileSafetyTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間の期間プロファイルを設定します。
setPersNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
従業員番号を設定します。
setPersistId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号 (固定)を設定します。
setPersistIdType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス番号タイプ (固定)を設定します。
setPersonResp(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者を設定します。
setPersonRespPhone(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任者の電話番号を設定します。
setPickArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
ピッキングエリアを設定します。
setPickgArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
簡易倉庫管理のピッキングエリアを設定します。
setPlRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包方法が同じ品目の参照品目を設定します。
setPlTiFnce(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画タイムフェンスを設定します。
setPlacement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫受入に対する保管域タイプ検索区分を設定します。
setPlanBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト基準日付計画方法を設定します。
setPlanDel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
予定納入日数を設定します。
setPlanFcst(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト予測日付の計画方法を設定します。
setPlanProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
計画プロファイルを設定します。
setPlanSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行タイプ EDIを設定します。
setPlanSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlanStrgp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画方針グループを設定します。
setPlanlistcnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
グループカウンタを設定します。
setPlanlistgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストグループのキーを設定します。
setPlannedCost(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
計画原価を設定します。
setPlanningData(PlanningData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタ/製品グループの変更伝票構造を設定します。
setPlanningDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタ/製品グループの変更伝票構造を設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プラントを設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlant(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
プラントを設定します。
setPlantData(PlantData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (プラントレベル)を設定します。
setPlantDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (プラントレベル)を設定します。
setPlantHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 終了を設定します。
setPlantLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
対象プラント 開始を設定します。
setPlantRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
プラントの範囲を設定します。
setPlantSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
プラントの選択オプション一覧を設定します｡
setPldlvshdin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷計画に関する指示を設定します。
setPldlvshdin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPldlvstyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
MRP: 出荷計画タイプを設定します。
setPldlvstyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPlnClose(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画終了日付を設定します。
setPlnCompletion(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画完了日を設定します。
setPlnLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: 計画梱包明細行を設定します。
setPlnPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
パッケージ番号供給元一覧を設定します。
setPlnRelease(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
計画リリース日付を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndDelry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
予定納入時間 (単位: 日)を設定します。
setPlndPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価を設定します。
setPlndprdate1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 1 の有効開始日を設定します。
setPlndprdate2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 2 の有効開始日を設定します。
setPlndprdate3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定原価 3 の有効開始日を設定します。
setPlndprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 1を設定します。
setPlndprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 2を設定します。
setPlndprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
予定計画原価 3を設定します。
setPlngCycle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
計画サイクルを設定します。
setPlngMatl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画品目を設定します。
setPlngMatlExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)を設定します。
setPlngMatlGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)を設定します。
setPlngMatlVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)を設定します。
setPlngPlant(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
計画プラントを設定します。
setPlordCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
アクション管理: 計画手配処理を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
支払条件キーを設定します｡
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払条件キーを設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払保証決定表を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払保証決定表を設定します。
setPmtgarPro(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱を設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱住所を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱住所を設定します。
setPoBoxCit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱住所を設定します。
setPoBoxReg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の地域 (国、都道府県、地域、...)を設定します。
setPoCtryiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
ISO 国コードを設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注日付を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注日付を設定します。
setPoDatS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程の購買発注日付を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買伝票の明細番号を設定します。
setPoItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買伝票の明細番号を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoItmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
元となる購買発注の明細番号を設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の出荷先発注タイプを設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の出荷先発注タイプを設定します。
setPoMethS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注タイプを設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注タイプを設定します。
setPoMethod(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買伝票番号を設定します｡
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
購買伝票番号に値を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
購買伝票番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
購買発注番号を設定します。
setPoNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
購買発注番号を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
数量 (購買発注価格単位)を設定します。
setPoPrQnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量 (購買発注価格単位)を設定します。
setPoPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格採用区分を設定します。
setPoRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
承認コードを設定します。
setPoRelInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
承認区分: 購買伝票を設定します。
setPoSupplem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注番号補足を設定します。
setPoSupplem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
発注単位を設定します。
setPoUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
発注単位を設定します。
setPoUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
ISOコードによる発注単位を設定します。
setPoUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードによる発注単位を設定します。
setPoWONo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
フラグ: 郵便私書箱 (番号なし)を設定します。
setPoboxCtry(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱の国指定を設定します。
setPobxCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱住所を設定します。
setPobxPcd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
私書箱番号を設定します。
setPointUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位を設定します。
setPointUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ポイント単位の ISO コードを設定します。
setPoints(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベートポイント数を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
元となる購買発注の明細番号を設定します。
setPoitmNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPoolnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
LIFO 評価でのプール番号を設定します。
setPoolnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
LIFO 評価でのプール番号を設定します。
setPosex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
外部明細番号を設定します。
setPosex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
外部明細番号を設定します。
setPostDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの転記日付を設定します。
setPostDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの転記日付を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村の郵便番号を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村の郵便番号を設定します。
setPostlCod1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村の郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
私書箱郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
私書箱郵便番号を設定します。
setPostlCod2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
私書箱郵便番号を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCod3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
会社郵便番号 (大規模なユーザ用)を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
郵便番号を設定します。
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
郵便番号を設定します。
setPpSearch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
品目提案検索条件を設定します。
setPpSearch(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPpcPlCal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
PPC 計画カレンダを設定します。
setPrClosed(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
購買依頼処理済を設定します。
setPrCtrlPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期間の原価管理区分を設定します。
setPrCtrlPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の原価管理区分を設定します。
setPrIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
レコード番号を設定します｡
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定参照品目を設定します。
setPrRefMat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrRefMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)を設定します。
setPrRefMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)を設定します。
setPrRefMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)を設定します。
setPrUname(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を設定します。
setPrUnitPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期価格単位を設定します。
setPrUnitPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度価格単位を設定します。
setPrcGroup1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 1を設定します。
setPrcGroup1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 2を設定します。
setPrcGroup2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 3を設定します。
setPrcGroup3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 4を設定します。
setPrcGroup4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcGroup5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目グループ 5を設定します。
setPrcGroup5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrcStatH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
伝票の全処理ステータスを設定します。
setPreVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
製造元/販売元を設定します。
setPrefStatFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 特恵関税 - 輸出/輸入を設定します。
setPreqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼の明細番号を設定します。
setPreqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼の明細番号を設定します。
setPreqName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼者名/要求者名を設定します。
setPreqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買依頼番号を設定します。
setPreqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
購買依頼番号を設定します。
setPrevPlanPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 2を設定します。
setPrice(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
入力シートの価格変更を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力シートの価格変更を設定します。
setPriceChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setPriceCtrl(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価管理区分を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格設定/外貨換算の実行日付を設定します。
setPriceDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格グループ (得意先)を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格グループ (得意先)を設定します。
setPriceGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
価格表タイプを設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
価格表タイプを設定します。
setPriceList(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
価格単位を設定します。
setPriceUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
価格単位を設定します。
setPricedate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格設定日カテゴリ (価格設定日管理)を設定します。
setPricing(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
価格設定タイプを設定します。
setPriority(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
優先度を設定します。
setPriority(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
優先度を設定します。
setPrivAddr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
自宅住所を設定します。
setPrntPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
価格印刷を設定します。
setProcRule(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達規則を設定します。
setProcTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
処理時間を設定します。
setProcType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
調達タイプを設定します。
setProcedure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
決定表 (価格設定/出力管理/勘定設定/原価計算など)を設定します。
setProcessingGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
処理グループを設定します。
setProcureUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管容量消費の数量単位を設定します。
setProcureUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの保管容量消費の数量単位を設定します。
setProdAlloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製品割当決定手順を設定します。
setProdAtt1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ID: 製品属性 1を設定します。
setProdAtt10(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 10 用 IDを設定します。
setProdAtt2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 2 用 IDを設定します。
setProdAtt3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 3 用 IDを設定します。
setProdAtt4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 4 用 IDを設定します。
setProdAtt5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 5 用 IDを設定します。
setProdAtt6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 6 の IDを設定します。
setProdAtt7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 7 用 IDを設定します。
setProdAtt8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 8 用 IDを設定します。
setProdAtt9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目属性 9を設定します。
setProdCompositionOnPackaging(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
区分: 梱包材にプリントされた生産構造を設定します。
setProdConvType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産値の変換タイプを設定します。
setProdDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
ロット製造日付を設定します。
setProdDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
ロット製造日付を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
品目階層を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
品目階層を設定します。
setProdHier(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目階層を設定します。
setProdHiera(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目階層を設定します。
setProdHiera(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProdMemo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
製造/検査メモを設定します。
setProdUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位を設定します。
setProdUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造単位 (ISO コード)を設定します。
setProdcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
製品カタログ番号を設定します。
setProdcat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProdcomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産統計: 貿易における PRODCOM コードを設定します。
setProdprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画プロファイルを設定します。
setProductionResourceToolData(ProductionResourceToolData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setProductionScheduler(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
製造計画担当を設定します。
setProdverscs(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算を行う製造バージョンを設定します。
setProfitCentList(ProfitCenterList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
利益センタ一覧を設定します｡
setProfitCenterList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
利益センタ一覧を設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
利益センタを設定します｡
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
利益センタを設定します。
setProfitCtr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
収益性セグメント番号 (CO-PA)を設定します。
setProfitSegmentList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
入出庫予定一覧を設定します｡
setProjType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクトタイプを設定します。
setProjectCurrency(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 通貨(プロジェクト定義)を設定します。
setProjectCurrencyIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
ISO 通貨コードを設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト定義を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクト定義を識別するキーを設定します。
setProjectDefinition(ProjectDefinition) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
プロジェクトについての詳細情報を設定します。
setProjectDefinition(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクト定義を識別するキーを設定します。
setProjectDefinition(ProjectDefinition) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
プロジェクトについての詳細情報を設定します。
setProjectProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクトプロファイルを設定します。
setProjectStock(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト在庫を設定します。
setProjectSummarization(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
区分: プロジェクト集計用に活動を考慮を設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
プロモーションを設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
プロモーションを設定します。
setPromotion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPrtDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目マスタの生産資源/治工具 (PRT) 項目を設定します。
setPrtUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具用途を設定します。
setPrtUsage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具用途を設定します。
setPrtView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
生産資源/治工具 (PRT) ビューを設定します。
setPrtView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
生産資源/治工具 (PRT) ビューを設定します。
setPsConfMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
選定可能品目を設定します。
setPstngDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
伝票の転記日付を設定します。
setPstngDateRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
登録日付の範囲を設定します。
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買グループを設定します。
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買グループを設定します｡
setPurGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買グループを設定します。
setPurMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
品目コードを設定します。
setPurMatExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の品目コード (長) (今後のリリースで開発)を設定します。
setPurMatGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT の外部 GUID (今後のリリースで開発)を設定します。
setPurMatVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
項目 PURMAT のバージョン番号 (今後のリリースで開発)を設定します。
setPurStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目ステータスを設定します。
setPurStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント特有品目ステータスを設定します。
setPurValkey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
購買許容値キーを設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先発注日付を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先発注日付を設定します。
setPurchDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
得意先発注番号を設定します。
setPurchNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
得意先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先発注番号を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoC(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先の得意先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先の得意先発注番号を設定します。
setPurchNoS(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPurchOrd(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先発注番号を設定します。
setPurchOrg(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
購買組織を設定します。
setPurchOrg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
購買組織を設定します｡
setPurchView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買管理ビューを設定します。
setPurchaseAccountList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
勘定設定一覧を設定します｡
setPurchaseHeadersList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票ヘッダ一覧を取得します｡を設定します。
setPurchaseHeadersList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票ヘッダ一覧を設定します。
setPurchaseItemPostList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
明細一覧を設定します｡
setPurchaseItemsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
伝票明細一覧を取得します｡を設定します。
setPurchaseItemsList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
伝票明細一覧を設定します。
setPurchaseOrder(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号を設定します。
setPurchaseOrderNumber(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先発注番号1を設定します。
setPurchaseScheduleList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
納入日程一覧を設定します｡
setPurchaseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
購買管理ビューを設定します。
setPurchaseorder(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
購買発注番号を設定します。
setPushDistrib(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: プッシュ配賦を設定します。
setPvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
プラント共通品目のステータス有効開始日付を設定します。
setPvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
プラント品目ステータス有効期間開始日を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
支払方法を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
支払方法を設定します。
setPymtMeth(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQmAuthgrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
QM における活動の品目権限グループを設定します。
setQmProcmnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
調達における品質管理有効を設定します。
setQmRgmts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
仕入先の必須 QM システムを設定します。
setQtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積/引合有効開始日を設定します。
setQtValidF(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
見積の有効終了日を設定します。
setQtValidT(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setQtyGrGi(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
数量: 印刷予定入出庫票数を設定します。
setQtyStruct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
数量構成により原価計算を行う品目を設定します。
setQualDik(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
無償納入による割引対象品目を設定します。
setQualInsp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
在庫タイプを設定します。
setQualityView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品質管理ビューを設定します。
setQualityView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
品質管理ビューを設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
+/- 記号あり/なし数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
+/- 記号あり/なし数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
購買発注数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
計画数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
数量を設定します。
setQuantity(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
インスタンス数量を設定します。
setQuantityUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
数量単位を設定します。
setQuotDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積提出日を設定します｡
setQuotDead(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積提出期限を設定します。
setQuotation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
見積番号を設定します｡
setQuotationCfgsBlobList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: BLOB 内部データ (SCE)を設定します。
setQuotationCfgsInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: インスタンスを設定します。
setQuotationCfgsPartOfList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 部分設定を設定します。
setQuotationCfgsRefInstList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照明細/インスタンスを設定します。
setQuotationCfgsRefList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 参照データを設定します。
setQuotationCfgsValueList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: 特性値を設定します。
setQuotationCfgsVkList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
選定: バリアント条件キーを設定します。
setQuotationConditionsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
条件を設定します。
setQuotationConditionsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
受注における条件更新の通信項目を設定します。
setQuotationHeaderIn(HeaderIn) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダデータを設定します。
setQuotationHeaderInX(HeaderInX) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票ヘッダチェックボックスを設定します。
setQuotationItemsInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データを設定します。
setQuotationItemsInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
明細データチェックボックスを設定します。
setQuotationKeysList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
参照キーの出力テーブルを設定します。
setQuotationPartnersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
伝票取引先を設定します。
setQuotationSchedulesInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データを設定します。
setQuotationSchedulesInXList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
納入日程行データチェックボックスを設定します。
setQuotationTextList(List) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テキストを設定します。
setQuotausage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給量割当の使用を設定します。
setRPromo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
プロモーションを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算レートタイプを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算レートタイプを設定します。
setRateType(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算レートタイプを設定します。
setRcvgVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
未使用項目を設定します。
setReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更理由を設定します。
setReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更理由を設定します。
setReasonCancel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
取消理由を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
見積および受注の拒否理由を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReasonRej(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積および受注の拒否理由を設定します。
setRebateGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
取引量リベートグループを設定します。
setRecInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
リカバリフラグを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
入荷ポイントを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
入荷ポイントを設定します。
setRecPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRecTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
登録時刻を設定します。
setRecoveryInd(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
リカバリフラグを設定します。
setRecoveryInd(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
リカバリフラグを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先/仕入先の内部参照コードを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
得意先/仕入先の内部参照コードを設定します。
setRef1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷先文字を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷先文字を設定します。
setRef1S(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
決済の参照日付を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
決済の参照日付を設定します。
setRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
決済の参照日付を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照伝票番号を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照伝票番号を設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefDocCa(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocHigh(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の終了伝票番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
参照明細番号を設定します。
setRefDocIt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
参照明細番号を設定します。
setRefDocItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
参照明細番号を設定します。
setRefDocL(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号を設定します。
setRefDocL(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefDocLLong(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照伝票番号 (依存関係についてはテキスト (長) を参照)を設定します。
setRefDocLow(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
前伝票の開始伝票番号を設定します。
setRefDocNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号を設定します。
setRefDocNoLong(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
参照伝票番号 (依存性についてはテキスト長参照)を設定します。
setRefDocRange(RefDocRange) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
前伝票の範囲を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
参照伝票の会計年度を設定します。
setRefDocYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
参照伝票の会計年度を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
参照伝票の明細を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
参照明細番号を設定します。
setRefItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
参照明細番号を設定します。
setRefKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
参照キーは変更できませんを設定します。
setRefKeyNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
参照キーは変更できませんを設定します。
setRefProc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照限定条件: 決定区分を設定します。
setRefProc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
基本数量単位による参照数量を設定します。
setRefUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
品目マスタレコードの数量単位初期値を設定します。
setRef_1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
得意先/仕入先の内部参照コードを設定します｡
setRefdocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
先行販売管理伝票の伝票カテゴリを設定します。
setRefdocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefdoctype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
参照オブジェクトの伝票タイプを設定します。
setReferencePoint(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
BOM 転送の参照ポイントを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
論理システムを設定します。
setReflogsys(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
論理システムを設定します。
setRefmatcons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照品目を設定します。
setRefmatconsExternal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)を設定します。
setRefmatconsGuid(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS の外部 GUID (今後のリリースで開発)を設定します。
setRefmatconsVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)を設定します。
setRefobject(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクト名を設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトキーを設定します。
setRefobjkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトキーを設定します。
setRefobjtyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
オブジェクトタイプを設定します。
setRefobjtype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
オブジェクトタイプを設定します。
setRefpltcons(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
消費参照プラントを設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域構造グループ化を設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地域構造グループ化を設定します。
setRegiogroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域構造グループ化を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地域 (都道府県)を設定します。
setRegion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地域 (都道府県)を設定します。
setRegionorig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
品目の原産地 (非特恵対象地区の原産)を設定します。
setRegionorig(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目の原産地 (非特恵対象地区の原産)を設定します。
setRejReason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
見積および受注の拒否理由を設定します。
setRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認コードを設定します。
setRelCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認コードを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
承認グループを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
承認グループを設定します。
setRelGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認グループを設定します。
setRelInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認区分: 購買伝票を設定します。
setRelIndicatorNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認区分を設定します。
setRelStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
承認状況を設定します｡
setRelStatusNew(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
返却承認状況を設定します。
setRelStrat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認方針を設定します。
setRelType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
承認タイプを設定します。
setRelType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReleaseDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認日を設定します。
setReleaseTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認時刻を設定します。
setReleasebyPur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認購買担当者名を設定します。
setReleasedBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
承認者名を設定します。
setReleasedatePur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認日付を設定します。
setReleasetimePur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買担当者承認時刻を設定します。
setReminder1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第一回催促状/督促状の日数を設定します。
setReminder2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第二回催促状/督促状の日数を設定します。
setReminder3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
第三回催促状/督促状の日数を設定します。
setReorderPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
発注点を設定します。
setReorderPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する発注点を設定します。
setRepManuf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 繰返生産許可を設定します。
setReplQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所 MRP に対する補充数量を設定します。
setReplacePt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
取替部品を設定します。
setReplenQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
補充数量を設定します。
setReplentime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
補充リードタイム合計 (稼動日数)を設定します。
setRepmanprof(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
繰返生産プロファイルを設定します。
setReqBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
変更を依頼した従業員を設定します。
setReqBy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
変更を依頼した従業員を設定します。
setReqByExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンの外部変更番号を設定します。
setReqByExt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
バージョンの外部変更番号を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程日付を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
指定納期を設定します。
setReqDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
納入日程日付を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
指定納入期日を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqDateH(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
指定納入期日を設定します。
setReqDlvBl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
出荷ブロック中の納入日程行を設定します。
setReqDlvBl(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
利用可能在庫確認の所要量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
所要量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
累積受注数量 (販売単位)を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
販売単位による受注数量を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
累積受注数量 (販売単位)を設定します。
setReqQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
累積受注数量 (販売単位)を設定します。
setReqTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入時間を設定します。
setReqTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReqmtsTyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
所要量タイプを設定します。
setReqmtsTyp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRequCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
会社コード要求を設定します。
setRequestCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
申請原価センタを設定します。
setRequestCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請原価センタを設定します。
setRequestCctrControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
依頼原価センタの管理領域を設定します。
setRequestCompCode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
会社コード要求を設定します。
setRequestOrder(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
申請指図を設定します。
setResAnalKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
結果分析キーを設定します。
setResAnalKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
結果分析キーを設定します。
setResDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算の伝票番号を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
用途指定予算: 伝票明細を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setResItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の明細番号を設定します。
setResType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
レコードタイプを設定します。
setResType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
レコードタイプを設定します。
setResanalkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
結果分析キーを設定します。
setResanalkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setReservNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定/従属所要量の番号を設定します。
setReservNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定/従属所要量の番号を設定します。
setRespCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
責任原価センタを設定します。
setRespCostCenter(String) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController のメソッド
責任原価センタを設定します。
setRespcctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
責任原価センタを設定します。
setResponsibleNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任者番号 (プロジェクト責任者)を設定します。
setResponsibleNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
責任者番号 (プロジェクト責任者)を設定します。
setRespsblCctr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタを設定します。
setRespsblCctrControllingArea(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
責任原価センタの管理領域を設定します。
setRetCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController のメソッド
リターン値、ABAP 命令後のリターン値を設定します。
setRetItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
返品明細を設定します。
setReturnMessagesList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
リターンパラメータ BAPIRET2 の代替構造を設定します。
setRevLev(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
改訂レベルを設定します。
setRevType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
収益承認カテゴリを設定します。
setRevType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRfqItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼明細番号を設定します。
setRfqNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
見積依頼番号を設定します。
setRight(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
不動産管理対象の内部キーを設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
不動産管理対象の内部キーを設定します。
setRlEstKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
不動産管理対象の内部キーを設定します。
setRnddlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
丸め数量: 出荷を設定します。
setRnddlvQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
部屋/アパート番号を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
部屋/アパート番号を設定します。
setRoomNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
部屋/アパート番号を設定します。
setRootId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
選定におけるインスタンス番号を設定します。
setRotationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算ビューを設定します。
setRoundProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
丸めプロファイルを設定します。
setRoundProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
丸めプロファイルを設定します。
setRoundQty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
丸め数量を設定します。
setRoundUpRuleExpirationDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期間期限日計算の丸め規則を設定します。
setRoundVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
購買発注数量の丸め数量を設定します。
setRoundoffdi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
輸送経路を設定します。
setRoute(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setRoutesched(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送経路計画を設定します。
setRow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
パラメータの行を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注明細番号を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注明細番号を設定します。
setSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注明細番号を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
特別処理区分を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
特別処理区分を設定します。
setSProcInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSUnitDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
出荷単位を設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
単位の ISO コードを設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
ISO コードによる販売単位を設定します。
setSUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
ISO コードによる販売単位を設定します。
setSaIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
レコード番号を設定します｡
setSafetyStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全在庫を設定します。
setSafetytime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間 (稼動日数)を設定します。
setSaftyTId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
安全時間区分（安全リードタイムあり/なし)を設定します。
setSalStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスを設定します。
setSalStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売ビューからの品目ステータスを設定します。
setSalesData(SalesData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売データを設定します。
setSalesDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
販売データを設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売地域を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売地域を設定します。
setSalesDist(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesDocDateInidicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
販売伝票の日付に関連するマイルストーンを設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業グループを設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesGrp(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業グループを設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
営業所を設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesOff(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
営業所を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
受注伝票番号を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注伝票番号を設定します。
setSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注伝票番号を設定します。
setSalesOrdersList(List) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
得意先受注テーブルを設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売組織を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売組織を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesOrg(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売組織を設定します。
setSalesOrganisationSelectionList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
販売組織の選択オプション一覧を設定します｡
setSalesOrganization(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
販売組織を設定します。
setSalesPers(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先営業担当者を設定します｡
setSalesRelevant(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
この部品は販売に関連していますを設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売単位を設定します。
setSalesUnit(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
販売単位を設定します。
setSalesUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
ISO コードによる販売単位を設定します。
setSalesView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
販売ビューを設定します。
setSalesView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
販売ビューを設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売伝票番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
販売管理伝票番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
生成された伝票の番号を設定します。
setSalesdocument(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
販売管理伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
販売管理伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
見積伝票番号を設定します。
setSalesdocumentin(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
販売管理伝票番号を設定します。
setSalesorg(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
販売組織を設定します。
setSalesorgHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲終了を設定します。
setSalesorgLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
販売組織の範囲開始を設定します。
setSalesorganisation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
販売組織を設定します。
setSalqtyden(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位を SKU に換算するための分母 (除数)を設定します。
setSalqtyden(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSalqtynum(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売数量単位から基本数量単位への変換係数の分子を設定します。
setSalqtynum(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setScIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
レコード番号を設定します｡
setScVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
外注仕入先を設定します。
setScalbasval(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件のスケール基準値を設定します。
setScalbasval(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件のスケール基準値を設定します。
setScalebasin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケール基準区分を設定します。
setScalebasin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケール基準区分を設定します。
setScaletype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
スケールタイプを設定します。
setScaletype(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
スケールタイプを設定します。
setSce(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
CUX: 選定タイプを設定します。
setSchedInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
分納契約のリリース伝票区分を設定します。
setSchedLin(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
受注納入日程を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
受注納入日程を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程行を設定します。
setSchedLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
納入日程行を設定します。
setSchedMilestoneDateBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(基準)を設定します。
setSchedMilestoneDateForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画日(予測)を設定します。
setSchedMilestoneTimeBasic(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(基準)を設定します。
setSchedMilestoneTimeForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
マイルストーン計画時間(予測)を設定します。
setSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
納入日程カテゴリを設定します。
setSchedType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setScheduling(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
単一文字フラグを設定します。
setSdDoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
販売管理伝票番号を設定します。
setSdDoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
販売管理伝票番号を設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
販売管理伝票カテゴリを設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売管理伝票カテゴリを設定します。
setSdDocCat(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSdTaxcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
0を設定します。
setSdTaxcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSeasIndex(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
季節指数を設定します。
setSeason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
季節カテゴリを設定します。
setSeason(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
季節カテゴリを設定します。
setSeasonPds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
季節周期ごとの期間数を設定します。
setSeasonYr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
シーズン年度を設定します。
setSelection(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
選択 ID (永続)を設定します。
setSelection(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
論理システム - 送信者を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
論理システム - 送信者を設定します。
setSender(Sender) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
論理システム - 送信者を設定します。
setSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
KANBAN/連続番号を設定します。
setSeqNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
勘定設定の連続番号を設定します。
setSerialNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
勘定設定の連続番号を設定します。
setSerializationLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
シリアル番号の指定レベルを設定します。
setSerialno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
シリアル番号を設定します。
setSerialnoAutoNumberassignment(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
シリアル番号の自動登録を設定します。
setSernoLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
勘定コード設定のシリアル番号、サービス明細を設定します。
setSernoProf(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
シリアル番号プロファイルを設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
サービス提供日を設定します。
setServDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setServLevel(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
サービスレベルを設定します。
setServType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サービスタイプのテキスト (短)を設定します。
setServType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプのテキスト (短)を設定します。
setService(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
活動番号を設定します。
setSettItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
リベート (期末) 決済対象の明細を設定します。
setSetupTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷準備時間を設定します。
setSetuptime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
段取時間と片付け時間を設定します。
setShMatTyp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
梱包材タイプを設定します。
setShelfLife(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
総有効期間を設定します。
setShipBlocked(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
SD 出荷伝票の明細ブロックを設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷条件を設定します。
setShipCond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipPoint(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
出荷ポイント/入荷ポイントを設定します。
setShipProcTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
出荷処理時間を設定します。
setShipTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
出荷先を設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
出荷タイプを設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
出荷タイプを設定します。
setShipType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
出荷指示を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
出荷指示を設定します。
setShipping(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
出荷指示を設定します。
setShippingCountry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
貿易: 出荷国を設定します。
setShippingCountryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
ISO 国コードを設定します。
setShortId(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素 ショート IDを設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
G/L勘定コードテキスト(短)を設定します｡
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
テキスト 1 (短)を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
テキスト(短)を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
品目コードテキスト（短）を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
テキスト (短): 受注明細を設定します。
setShortText(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
テキスト (短): 受注明細を設定します。
setSiCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
補助明細カテゴリ、購買伝票を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSign(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
選択演算子 SIGN (テーブル範囲)を設定します。
setSizeDim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
サイズ/寸法を設定します。
setSledBbd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
有効期限を設定します。
setSlocExprc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
外部調達の初期保管場所を設定します。
setSmKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
日程計画余裕キーを設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
受注先を設定します。
setSoldTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
受注先を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 1を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 1を設定します。
setSort1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 1を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
検索条件 2を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
検索条件 2を設定します。
setSort2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
検索条件 2を設定します。
setSourcelist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 供給元一覧必須を設定します。
setSpecMvmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の特殊移動区分を設定します。
setSpecMvmt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
倉庫管理の特殊移動区分を設定します。
setSpecProc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所レベルでの特殊調達タイプを設定します。
setSpecStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
特殊在庫区分を設定します。
setSpecStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
特殊在庫区分を設定します。
setSpecStockRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
特殊在庫区分の範囲を設定します。
setSpecprocty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
原価計算の特殊調達タイプを設定します。
setSplitInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
分割区分を設定します。
setSpproctype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
特殊調達タイプを設定します。
setSscExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの制限を設定します。
setSscItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ: 明細を設定します。
setSscLim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
標準サービスカタログ制限参照のサービス行を設定します。
setSscLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスタイプの金額制限を設定します。
setSscNolim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
標準サービスタイプの制限なしを設定します。
setSscPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setSscPrschg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setStRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始参照日付は変更できませんを設定します。
setStRefDateNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始参照日付は変更できませんを設定します。
setStUnQtyy1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を設定します。
setStUnQtyy1Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setStUnQtyy2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
代替数量単位での在庫受入予定保管単位別数量を設定します。
setStUnQtyy2Iso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
単位の ISO コードを設定します。
setStackFact(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
山積係数を設定します。
setStart(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
プロジェクト計画開始日付を設定します。
setStartOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用の開始オフセットを設定します。
setStartOffset(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用の開始オフセットを設定します。
setStartOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
開始オフセットは変更できませんを設定します。
setStartOffsetNoChg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
開始オフセットは変更できませんを設定します。
setStartOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始のオフセット単位を設定します。
setStartOffsetUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始のオフセット単位を設定します。
setStartOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
setStartOffsetUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
PRT 用途開始決定の間隔時間単位 (ISO)を設定します。
setStartRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具使用開始の参照日付を設定します。
setStartRefDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具使用開始の参照日付を設定します。
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
統計に適用する条件を設定します。
setStatCon(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
統計に適用する条件を設定します。
setStatDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
統計的納入期日を設定します。
setStatGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
統計グループを設定します。
setStatProf(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータスプロファイルを設定します。
setStatistical(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
統計 WBS 要素を設定します。
setStatistical(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
統計 WBS 要素を設定します。
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンステータスを設定します。
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
ステータスを設定します｡
setStatus(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
単一文字フラグを設定します。
setStatusDocOld(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
このバージョンの前の旧処理状況 (購買伝票内)を設定します。
setStatusInfoList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
ステータス情報を設定します。
setStckType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
在庫タイプを設定します。
setStckType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫タイプを設定します。
setStdDescr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
標準テキスト (ANSI、ISO など)を設定します。
setStdMaterialGetIntNumberList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
品目コード割当済一覧を設定します｡
setStdPrPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期標準標準原価を設定します。
setStdPrPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度標準原価を設定します。
setStdPrice(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
標準原価を設定します。
setStdTextKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
生産資源/治工具の標準テキストキーを設定します。
setStdTextKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
生産資源/治工具の標準テキストキーを設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
棚番を設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
棚番を設定します。
setStgeBin(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
棚番を設定します。
setStgeBinPc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を設定します。
setStgeBinSt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送棚番を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管場所を設定します。
setStgeLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
保管場所を設定します。
setStgeLocRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
保管場所の範囲を設定します。
setStgePdUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間の単位を設定します。
setStgePdUnIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
ISO コードでの最長保管期間単位を設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
保管域タイプを設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
概略計画および詳細計画のピッキング保管域タイプを設定します。
setStgeType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管域タイプを設定します。
setStgeTypePc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを設定します。
setStgeTypeSt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫転送の保管域タイプを設定します。
setStgeperiod(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
最長保管期間を設定します。
setStgesector(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
保管区画区分を設定します。
setStlocHigh(String) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
終了保管場所を設定します。
setStlocLow(String) - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
開始保管場所を設定します。
setStockInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
特殊在庫区分を設定します。
setStorConds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
保管条件を設定します。
setStorCosts(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管経費区分を設定します。
setStorPct(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
残存有効期間割合 %を設定します。
setStorageLocationData(StorageLocationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
品目データ (保管場所レベル)を設定します。
setStorageLocationDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目データ (保管場所レベル)を設定します。
setStorageTypeData(StorageTypeData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプデータを設定します。
setStorageTypeDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
保管域タイプデータを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
保管ビューを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
保管ビューを設定します。
setStorageView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
保管ビューを設定します。
setStoragelocation(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管場所を設定します。
setStoragelocationselectList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
保管場所の選択オプション一覧を設定します｡
setStoragetype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
保管域タイプを設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
保管場所を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
保管場所を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setStoreLoc(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
保管場所を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名の略称 (例: スペイン)を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名の略称 (例: スペイン)を設定します。
setStrAbbr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名の略称 (例: スペイン)を設定します。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
構造型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
構造体型の項目に値をセットします。
setStrParam(String, String, String) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
構造体型の項目に値をセットします。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 2を設定します。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 2を設定します。
setStrSuppl1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 2を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 3を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 3を設定します。
setStrSuppl2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 3を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名 4を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名 4を設定します。
setStrSuppl3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名 4を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
地名/番地-号を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を設定します。
setStreet(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
地名/番地-号を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
地名を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
地名を設定します。
setStreetLng(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
地名を設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStreetNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
市区町村/地名ファイルの地名コードを設定します。
setStructcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
構造条件を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI テーブル拡張の構造名を設定します。
setStructure(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI テーブル拡張の構造名を設定します。
setSuPlStck1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を設定します。
setSuPlStck2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
在庫受入予定の保管単位数を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
資産補助番号を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
資産補助番号を設定します。
setSubNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
資産補助番号を設定します。
setSubUom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
梱包階層の下位レベル数量単位を設定します。
setSubUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
下位レベル数量単位 (ISO コード)を設定します。
setSubitemint(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
副明細の明細間隔を設定します｡
setSubjToR(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
承認未完了を設定します。
setSubpckgNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
サブパッケージ番号を設定します。
setSuccessList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
正常に処理された明細のテーブルを設定します。
setSuccessList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
後続請求伝票の明細テーブルを設定します。
setSupSource(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
供給元を設定します。
setSupSource(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
供給元を設定します。
setSuppLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
補足明細を設定します。
setSuppVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
供給仕入先/仕入入庫を設定します。
setSupplPlnt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
在庫転送オーダーにおける供給(出庫)プラントを設定します｡
setSupplStloc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
出庫保管場所: 在庫転送オーダーを設定します。
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
供給仕入先を設定します｡
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
供給仕入先を設定します。
setSupplVend(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
供給仕入先を設定します。
setSupplierInfo(VendorAddress) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
仕入先住所を設定します｡
setSupplyArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
品目マスタレコードで提案される供給場所を設定します。
setSvalidfrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
流通チェーン間品目ステータスの有効開始日付を設定します。
setSyStDscr(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトステータスを設定します。
setSyStText(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を設定します。
setSysStatus(String) - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
システムステータスを設定します。
setSystem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージが発行された論理システムを設定します。
setSystemStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
システムステータステーブルを設定します。
setSystemStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
システムステータステーブルを設定します。
setTUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量単位 (ISO コード)を設定します。
setTUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaGlAccount(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の総勘定元帳勘定に値を設定します。
setTaGlAccount(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
総勘定元帳勘定コードを設定します｡
setTaIndex(int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
レコード番号を設定します｡
setTaItemnoAcc(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の会計伝票明細番号に値を設定します。
setTaItemnoAcc(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
会計伝票明細番号コードを設定します｡
setTaTaxCode(String, int) - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
税明細の消費税コードに値を設定します。
setTaTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
消費税コードコードを設定します｡
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList の static メソッド
品目データ (クライアントレベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn の static メソッド
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX の static メソッド
拡張イン/拡張アウトのチェックボックス構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList の static メソッド
需要予測パラメータの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues の static メソッド
需要予測値のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData の static メソッド
管理情報設定ヘッダセグメントの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos の static メソッド
国際商品コード (EAN)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription の static メソッド
品目テキストの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText の static メソッド
テキスト (長)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList の static メソッド
品目マスタ/製品グループの変更伝票構造の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList の static メソッド
品目データ (プラントレベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData の static メソッド
品目マスタの生産資源/治工具 (PRT) 項目の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList の static メソッド
販売データの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList の static メソッド
品目データ (保管場所レベル)の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList の static メソッド
保管域タイプデータの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications の static メソッド
制御デ－タの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption の static メソッド
品目総消費量のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure の static メソッド
数量単位の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption の static メソッド
計画外消費のデータ転送の値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList の static メソッド
評価データの値をセットします。
setTableParam(BapiController, List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList の static メソッド
倉庫番号データの値をセットします。
setTargetQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量（販売単位）を設定します。
setTargetQty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTargetQu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
目標数量 (数量単位)を設定します。
setTargetQu(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
目標値を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
累積計画金額を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
BAPI の通貨額 (小数点以下９桁)を設定します。
setTargetVal(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaskListType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
タスクリストタイプを設定します。
setTaxClass1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 2を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先税分類 3を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 4を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 5を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass5(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 6を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass6(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 7を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass7(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 8を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass8(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
得意先に対する税クラス 9を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
品目の税分類を設定します。
setTaxClass9(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxClassificationsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
制御デ－タを設定します。
setTaxClassificationsList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
制御デ－タを設定します。
setTaxCmlUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法/商法にもとづく評価額価格単位を設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
消費税コードを設定します。
setTaxCode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
消費税コードを設定します。
setTaxDepartCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税出荷国を設定します。
setTaxDestCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税仕向国を設定します。
setTaxInd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税区分: 品目 (購買管理)を設定します。
setTaxType1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxType9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
税カテゴリ (消費税等)を設定します。
setTaxValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
税額を設定します。
setTaxValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を設定します。
setTaxValueItem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
税額を設定します。
setTaxcl1Mat(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
品目の税分類を設定します。
setTaxclass1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass5(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass6(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass7(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass8(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxclass9(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
品目の税分類を設定します。
setTaxdepCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税出荷国を設定します。
setTaxdepCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxdstCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
税仕向国を設定します。
setTaxdstCty(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
税管轄コードを設定します。
setTaxjurcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
税計算管轄コード - 税管轄コードを設定します。
setTaxlawicms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: ICMSを設定します。
setTaxlawicms(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxlawipi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
税法: IPIを設定します。
setTaxlawipi(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTaxprice1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 1を設定します。
setTaxprice2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法による評価額: レベル 2を設定します。
setTaxprice3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
税法基準評価額: レベル 3を設定します。
setTaxrCntry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
納税申告書の国を設定します。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController のメソッド
テーブル型の項目に値をセットします。
setTblParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController のメソッド
テーブル型の項目に値をセットします。
setTeIndex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
レコード番号を設定します｡
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第 1 電話番号: 内線を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第 1 電話番号: 内線を設定します。
setTel1Ext(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第 1 電話番号: 内線を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTel1Numbr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
第一電話番号: ダイヤルコード + 番号を設定します。
setTelebox(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレボックス番号を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先電話番号を設定します｡
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
電話番号を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 1を設定します。
setTelephone2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
電話番号 2を設定します。
setTeletexNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレテクス番号を設定します。
setTelexNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
テレックス番号を設定します。
setTempConds(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
温度条件区分を設定します。
setTerminal(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
支払カード: 端末を設定します。
setTestRun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
テスト区分を設定します｡
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
在庫移動シミュレーションを設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
書込 BAPI のシミュレーションセッションへの切替を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
シミュレーション実行 ('X')、更新実行 (' ')を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
テスト実行を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
テスト実行を設定します。
setTestrun(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
テスト実行を設定します。
setTextDataInList(List) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
請求インタフェースの通信構造テキストを設定します。
setTextForm(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
タグ列を設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト IDを設定します。
setTextId(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト IDを設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
テキスト行を設定します。
setTextLine(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
テキスト行を設定します。
setTextName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
名称を設定します。
setTextName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
名称を設定します。
setTimeUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
時間計画単位を設定します。
setTimeUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
単位の ISO コードを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
アドレスタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
アドレスタイムゾーンを設定します。
setTimeZone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
アドレスタイムゾーンを設定します。
setTindex(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
数値項目: 長さ 6を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
敬称を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
タイトル (敬称)を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
敬称を設定します。
setTmpExist(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
サービスパッケージの制限を設定します。
setTmpLimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細制限を設定します。
setTmpLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを設定します。
setTmpNolim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデル仕様の制限なしを設定します。
setTmpNumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
モデルサービス明細セット番号を設定します。
setTmpPckg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
入力: モデル仕様からの計画外サービスを設定します。
setTmpPerc(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
価格決定率を設定します。
setTmpPrschg(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
入力シートの価格変更を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後通貨を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
換算後通貨を設定します。
setToCurrncy(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController のメソッド
換算後通貨を設定します。
setToFactor(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を設定します。
setToFactorV(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
換算後 通貨単位の係数を設定します。
setToLine(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
上限を設定します。
setTotalConsumptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
品目総消費量のデータ転送を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画日付を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画日付を設定します。
setTpDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
輸送計画 - 時間 (現地時間/出荷ポイント参照)を設定します。
setTpTime(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTrEvType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
トランザクション/イベントタイプを設定します。
setTrEvTypeRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
トランザクション/イベントタイプの範囲を設定します。
setTrPartBa(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取引会社事業領域を設定します。
setTrackingno(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
購買依頼追跡番号を設定します。
setTracklimit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
警告限界を設定します。
setTrans(String) - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
取引を設定します。
setTransGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
輸送グループを設定します。
setTransactionGroup(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
一文字フラグを設定します。
setTransportMode(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
貿易管理の輸送モードを設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
商品の納入区域を設定します。
setTranspzone(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
商品の納入区域を設定します。
setTrendAnalysisIndicator(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
傾向分析の関連マイルストーンを設定します。
setTrendValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
傾向値を設定します。
setTrendValuePp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
前期間の傾向値を設定します。
setTrgQtyNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を設定します。
setTrgQtyNo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTrgqtyDen(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
販売単位から基本単位への換算係数を設定します。
setTrgqtyDen(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setTwoStepPick(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ツーステップピッキング適用品目を設定します。
setType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
setType(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了を設定します。
setUnWork(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業単位を設定します。
setUnWorkIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUnddlvTol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
不足納入許容範囲リミットを設定します。
setUnddlvTol(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnderDlvTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
不足納入許容範囲リミットを設定します。
setUnderTol(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
不足納入許容範囲リミットを設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
発注単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
表示数量単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
表示数量単位を設定します。
setUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
表示数量単位を設定します。
setUnitDim(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
寸法単位 (長さ/幅/高さ)を設定します。
setUnitDimIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの長さ、幅、高さの単位を設定します。
setUnitGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
数量単位グループを設定します。
setUnitGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
数量単位グループを設定します。
setUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
ISO コードでの表示数量単位を設定します。
setUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
ISO コードでの表示数量単位を設定します。
setUnitOfWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
重量単位を設定します。
setUnitOfWt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
重量単位を設定します。
setUnitOfWtIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
ISO コードでの重量単位を設定します。
setUnitOfWtIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの重量単位を設定します。
setUnitSofmeasureList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
数量単位を設定します。
setUnitSofmeasureList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
数量単位を設定します。
setUnitmeasur(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
条件スケール単位を設定します。
setUnitmeasur(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
条件スケール単位を設定します。
setUnitmeasurIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
単位の ISO コードを設定します。
setUnittype1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第１保管単位タイプを設定します。
setUnittype1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを設定します。
setUnittype2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第２保管単位タイプを設定します。
setUnittype2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
保管単位タイプを設定します。
setUnittype3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
第３保管単位タイプを設定します。
setUnlimited(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlimitedDlv(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlmtDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
区分: 無制限過剰納入可能を設定します。
setUnlmtDlv(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
荷渡ポイントを設定します。
setUnloadPt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
荷渡ポイントを設定します。
setUnloadPtx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUnofWtiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの重量単位を設定します。
setUnplndConsumptionList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
計画外消費のデータ転送を設定します。
setUntilDate(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
インフレーション指数日付を設定します。
setUntofWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
重量単位を設定します。
setUntofWght(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUomIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
単位の ISO コードを設定します。
setUomsortnumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
数量単位ソート番号を設定します。
setUomusage(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
使用数量単位を設定します。
setUp(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setUpdateGrp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
統計更新の更新グループを設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
更新区分を設定します。
setUpdateflag(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
更新区分を設定します。
setUsStDscr(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトステータスを設定します。
setUsStNumb(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ステータス番号を設定します。
setUsStText(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
オブジェクトの個別ステータス (簡略形式)を設定します。
setUsageInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
未使用 - 予約長 3を設定します。
setUsageInd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setUseExceptions(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
例外メッセージ設定とエラーメッセージ出力を設定します。
setUserFieldChar10_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を設定します。
setUserFieldChar10_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 3 ユーザ項目 - WBS 要素を設定します。
setUserFieldChar10_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目 (10 文字)を設定します。
setUserFieldChar10_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
10 桁の第 4 ユーザ項目 - WBS 要素を設定します。
setUserFieldChar20_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を設定します。
setUserFieldChar20_1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 文字の第 1 ユーザ項目 - WBS 要素 -を設定します。
setUserFieldChar20_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
20 文字のユーザ項目を設定します。
setUserFieldChar20_2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
20 桁の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldCuky1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を設定します。
setUserFieldCuky1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
setUserFieldCuky1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 値項目の単位を設定します。
setUserFieldCuky2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
setUserFieldCuky2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ISO 通貨コードを設定します。
setUserFieldCuky2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ISO 通貨コードを設定します。
setUserFieldCurr1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を設定します。
setUserFieldCurr1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldCurr2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
値のユーザ定義項目 (長さ 10,3)を設定します。
setUserFieldCurr2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldDate1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を設定します。
setUserFieldDate1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 1 ユーザ項目 - WBS 要素を設定します。
setUserFieldDate2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
日付のユーザ項目を設定します。
setUserFieldDate2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
日付の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldFlag1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を設定します。
setUserFieldFlag1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 1 ユーザ項目 - WBS 要素を設定します。
setUserFieldFlag2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目: レポート区分を設定します。
setUserFieldFlag2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
'評価区分' の第 2 ユーザ項目 - WBS 要素を設定します。
setUserFieldKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ定義項目のキーワード IDを設定します。
setUserFieldKey(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
ユーザ定義項目のキーワード IDを設定します。
setUserFieldQuan1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を設定します。
setUserFieldQuan1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldQuan2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
数量のユーザ項目 (長さ 10,3)を設定します。
setUserFieldQuan2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素を設定します。
setUserFieldUnit1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を設定します。
setUserFieldUnit1(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第１ユーザ定義項目 - WBS 要素を設定します。
setUserFieldUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUserFieldUnit1Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setUserFieldUnit2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
ユーザ項目: 数量項目の単位を設定します。
setUserFieldUnit2(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
数量項目単位の第２ユーザ定義項目 - WBS 要素を設定します。
setUserFieldUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
単位の ISO コードを設定します。
setUserFieldUnit2Iso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setUserNameRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
ユーザ名の範囲を設定します。
setUserStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
ユーザステータス/指図ステータステーブルを設定します。
setUserStatusList(ArrayList) - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController のメソッド
ユーザステータス/指図ステータステーブルを設定します。
setUserf1Num(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf1Txt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf2Num(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUserf2Txt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ユーザ定義項目を設定します。
setUsername(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
ユーザ名を設定します。
setUsrStatus(String) - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
ユーザステータスを設定します。
setValArea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価レベルを設定します。
setValCat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価カテゴリを設定します。
setValClass(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価クラスを設定します。
setValConI(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約明細を設定します。
setValConI(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
金額契約番号を設定します。
setValContr(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValRatio(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
元値に対する修正値の比率 (修正値: 元値)を設定します。
setValSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注明細を設定します。
setValSOrdItem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注明細を設定します。
setValSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価受注在庫の受注番号を設定します。
setValSalesOrd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価受注在庫の受注番号を設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
評価タイプを設定します。
setValType(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setValWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を設定します。
setValWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を設定します。
setValcode(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
値タイプ: 範囲制限 - 単一値を設定します。
setValcount(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
階層ノード内の値の値数を設定します。
setValfrom(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
エントリの有効開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
流通チェーン別品目ステータスの有効期間開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
原価有効開始日を設定します。
setValidFrom(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約の有効開始日を設定します。
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
有効終了日を設定します｡
setValidTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
見積または基本契約有効終了日を設定します。
setValto(String) - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
原価センタ/利益センタを設定します。
setValuationData(ValuationData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価データを設定します。
setValuationDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
評価データを設定します。
setValuationarea(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価レベルを設定します。
setValuationtype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
評価タイプを設定します。
setValue(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
CO-PA 特性値を設定します。
setValue(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を設定します。
setValueChanged(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
バージョンによる金額変更を設定します。
setValueTo(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値を設定します。
setValueTxt(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
特性値の言語依存テキストを設定します。
setValueduom(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ロット特定数量単位での評価を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart1(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart2(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart3(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
長さ 229 の文字データのコンテナを設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
長さ 229 の文字データのコンテナを設定します。
setValuepart4(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
BAPI 拡張パラメータのデータ部分を設定します。
setVarOrdUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
可変購買発注単位有効を設定します。
setVarSalesUn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
可変販売単位の使用不可を設定します。
setVarcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
バリアント条件を設定します。
setVarcond(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
バリアント条件を設定します。
setVarianceKey(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
差異キーを設定します。
setVatCntry(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
売上税 ID 番号国を設定します。
setVatCntryIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
消費税登録番号の ISO 国コードを設定します。
setVclassPp(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前期評価クラスを設定します。
setVclassPy(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
前年度の評価クラスを設定します。
setVendMat(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
仕入先が使用している品目コードを設定します。
setVendName(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
名称 1を設定します。
setVendPart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先部門を設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
仕入先勘定コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
仕入先コードを設定します｡
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
仕入先勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先勘定コードを設定します。
setVendorNo(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
仕入先または債権者の勘定コードを設定します。
setVendorRaList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
仕入先の範囲を設定します。
setVendrbatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
仕入先ロット番号を設定します。
setVendrbatch(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
仕入先ロット番号を設定します。
setVerGrGiSlip(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
入出庫票の印刷バ－ジョンを設定します。
setVerGrGiSlipx(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
購買管理におけるバージョン番号を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
販売伝票バージョン番号を設定します。
setVersion(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVersionFlag(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
バージョン区分を設定します。
setVersions(Versions) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
バージョン管理ヘッダを設定します｡
setVirtCard(String) - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
チェックボックスを設定します。
setVkey(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
バリアント条件名を設定します。
setVmPStock(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
プロジェクト在庫の評価クラスを設定します。
setVmSoStk(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
受注在庫の評価クラスを設定します。
setVolTolLt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の容積超過許容量を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
明細の総数量を設定します。
setVolume(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVolumeunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
容積単位を設定します。
setVolumeunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
容積単位を設定します。
setVolumeunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
ISO コードでの容積単位を設定します。
setVolumeunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
ISO コードでの容積単位を設定します。
setVolunit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
容積単位を設定します。
setVolunit(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setVolunitiso(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
ISO コードでの容積単位を設定します。
setVperEnd(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間終了日を設定します｡
setVperStart(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
有効期間開始日を設定します｡
setVwUepos(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
上位レベル明細用途 IDを設定します。
setVwUepos(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWagetype(String) - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
ウェイジタイプを設定します。
setWarDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
保証期間の開始日付を設定します。
setWarDate(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWarehouseNumberData(WarehouseNumberData) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号データを設定します。
setWarehouseNumberDataList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
倉庫番号データを設定します。
setWarehouseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
倉庫管理ビューを設定します。
setWarehouseView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
倉庫管理ビューを設定します。
setWarehousenumber(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
倉庫番号/複合倉庫を設定します。
setWarranty(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
保証日を設定します｡
setWbsAccountAssignmentElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 勘定設定要素を設定します。
setWbsActualDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
実績 WBS 要素日付の期間単位を設定します。
setWbsActualDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsActualDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績長(期間)を設定します。
setWbsActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績終了日を設定します。
setWbsActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の実績開始日付を設定します。
setWbsBasicDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
基準 WBS 要素日付の期間単位を設定します。
setWbsBasicDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsBasicDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の基準日の長さ(期間)を設定します。
setWbsBasicFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本終了日付を設定します。
setWbsBasicStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素: 基本開始日を設定します。
setWbsBillingElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 請求要素を設定します。
setWbsCctrPostedActual(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
原価が実際に転記される原価センタを設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
作業詳細項目要素 (WBS 要素)を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
WBS 要素を設定します。
setWbsElem(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
関連ユーザデータ項目の更新情報を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
WBS 要素を設定します。
setWbsElement(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
WBS 要素を設定します。
setWbsElementExt(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
WBS 要素を設定します。
setWbsForcastDurUnit(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素計画日付の単位を設定します。
setWbsForecastDurUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
単位の ISO コードを設定します。
setWbsForecastDuration(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測期間を設定します。
setWbsForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測済終了日付を設定します。
setWbsForecastStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の予測開始日を設定します。
setWbsPlanningElement(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
区分: 計画要素を設定します。
setWbsScdActualFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績終了日を設定します。
setWbsScdActualStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
WBS 要素の仮実績開始日を設定します。
setWbsScdBasicFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (基準)を設定します。
setWbsScdBasicStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最早計画開始日 (基準)を設定します。
setWbsScdForecastFinishDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
最遅計画終了日 (予測)を設定します。
setWbsScdForecastStartDate(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
計画開始日 (予測)を設定します。
setWbsSchedProfile(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
WBS 日程計画のプロファイルを設定します。
setWeightunit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位を設定します。
setWeightunitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
重量単位のISOコードを設定します。
setWhseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
倉庫番号/複合倉庫を設定します。
setWhseNo(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫番号/複合倉庫を設定します。
setWidth(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
幅を設定します。
setWithActivities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属活動を設定します。
setWithActivities(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属活動を設定します。
setWithMilestones(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
従属 WBS マイルストーンを設定します。
setWithMilestones(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
従属 WBS マイルストーンを設定します。
setWithSubtree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
サブプロジェクトを設定します。
setWithSubtree(String) - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController のメソッド
サブプロジェクトを設定します。
setWithdrawal(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
在庫払出に対する保管域タイプ区分を設定します。
setWithdrawn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
入出庫予定に対する出庫完了を設定します。
setWithdrawn(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
入出庫予定に対する出庫完了を設定します。
setWmUnit(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
倉庫管理の数量単位を設定します。
setWmUnitIso(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
ISO コードでの倉庫管理単位を設定します。
setWmdvexList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
出力テーブル (日付および ATP 数量)を設定します。
setWmdvsxList(List) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
入力テーブル (日付/数量)を設定します。
setWorkActivity(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
活動に含まれる作業を設定します。
setWorkActual(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
実績作業を設定します。
setWorkCntr(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
作業区を設定します。
setWorkForecast(String) - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
予測作業 (実績 + 残存)を設定します。
setWorkPermit(String) - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
仕事許可済フラグを設定します。
setWorkSchedView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
作業計画ビューを設定します。
setWorkSchedView(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
作業計画ビューを設定します。
setWtTolLt(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
荷役単位の重量超過許容量を設定します。
setWtWithcd(String) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
源泉徴収税コードを設定します。
setWtgGroup(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
加重グループを設定します。
setXAutoCre(String) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
自動登録済み明細を設定します。
setXstob(String) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
取消移動タイプ区分の使用を設定します。
setYline(String) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
内部テ－ブル処理の行索引を設定します。

T

TaxClassifications - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications.
制御デ－タ情報クラス
機能は以下の通り
制御デ－タ情報を保持します。
TaxClassifications() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のコンストラクタ
制御デ－タ情報を作成します。
TaxClassifications(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のコンストラクタ
制御デ－タ情報を作成します。
Text - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text.
テキスト情報クラス
機能は以下の通り
テキスト情報を保持します。
Text() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のコンストラクタ
テキスト情報を作成します。
Text(int) - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のコンストラクタ
テキスト情報を作成します。
TextDataIn - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn.
請求インタフェースの通信構造テキスト情報クラス
機能は以下の通り
請求インタフェースの通信構造テキスト情報を保持します。
TextDataIn() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のコンストラクタ
請求インタフェースの通信構造テキスト情報を作成します。
TextDataIn(int) - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のコンストラクタ
請求インタフェースの通信構造テキスト情報を作成します。
TotalConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption.
品目総消費量のデータ転送情報クラス
機能は以下の通り
品目総消費量のデータ転送情報を保持します。
TotalConsumption() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のコンストラクタ
品目総消費量のデータ転送情報を作成します。
TotalConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のコンストラクタ
品目総消費量のデータ転送情報を作成します。
TrEvTypeRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa.
トランザクション/イベントタイプの範囲情報クラス
機能は以下の通り
トランザクション/イベントタイプの範囲情報を保持します。
TrEvTypeRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のコンストラクタ
トランザクション/イベントタイプの範囲情報を作成します。
TrEvTypeRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のコンストラクタ
トランザクション/イベントタイプの範囲情報を作成します。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Bank のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BankList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.Company のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExchRate のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.MasterData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.OrderList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Cond のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractService のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Extension のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Limits のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Partner のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Selection のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo のメソッド
デバッグ用のメソッドです。

U

UnitSofmeasure - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure.
数量単位情報クラス
機能は以下の通り
数量単位情報を保持します。
UnitSofmeasure() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のコンストラクタ
数量単位情報を作成します。
UnitSofmeasure(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure のコンストラクタ
数量単位情報を作成します。
UnplndConsumption - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption.
計画外消費のデータ転送情報クラス
機能は以下の通り
計画外消費のデータ転送情報を保持します。
UnplndConsumption() - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のコンストラクタ
計画外消費のデータ転送情報を作成します。
UnplndConsumption(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption のコンストラクタ
計画外消費のデータ転送情報を作成します。
UpdateController - class jp.co.intra_mart.foundation.sap.module.UpdateController.
登録・更新系モジュール共通コントローラ親クラス。
UpdateController() - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateController(SapClient) - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UpdateController(ConnectionManager) - class jp.co.intra_mart.foundation.sap.module.UpdateController のコンストラクタ
コンストラクタ。
UserNameRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa.
ユーザ名の範囲情報クラス
機能は以下の通り
ユーザ名の範囲情報を保持します。
UserNameRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のコンストラクタ
ユーザ名の範囲情報を作成します。
UserNameRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa のコンストラクタ
ユーザ名の範囲情報を作成します。
UserStatus - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus.
ユーザステータス/指図ステータステーブル情報クラス 機能は以下の通り
ユーザステータス/指図ステータステーブル情報を保持します。
UserStatus() - class jp.co.intra_mart.foundation.sap.module.financial.UserStatus のコンストラクタ
ユーザステータス/指図ステータステーブルを作成します。

V

ValuationData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData.
評価データ情報クラス
機能は以下の通り
評価データ情報を保持します。
ValuationData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData のコンストラクタ
評価データ情報を作成します。
ValuationDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList.
評価データ情報クラス
機能は以下の通り
評価データ情報をテーブル型で保持します。
ValuationDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のコンストラクタ
評価データ情報を作成します。
ValuationDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList のコンストラクタ
評価データ情報を作成します。
VendorAddress - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress.
仕入先住所情報クラス
機能は以下の通り
仕入先住所を保持します。
VendorAddress() - class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress のコンストラクタ
入出庫予定を作成します。
VendorRa - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa.
仕入先の範囲情報クラス
機能は以下の通り
仕入先の範囲情報を保持します。
VendorRa() - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のコンストラクタ
仕入先の範囲情報を作成します。
VendorRa(int) - class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa のコンストラクタ
仕入先の範囲情報を作成します。
Versions - class jp.co.intra_mart.foundation.sap.module.purchase.Versions.
バージョン管理情報クラス
機能は以下の通り
バージョン管理情報を保持します。
Versions() - class jp.co.intra_mart.foundation.sap.module.purchase.Versions のコンストラクタ
バージョン管理を作成します。

W

WarehouseNumberData - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData.
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報を保持します。
WarehouseNumberData() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData のコンストラクタ
倉庫番号データ情報を作成します。
WarehouseNumberDataList - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList.
倉庫番号データ情報クラス
機能は以下の通り
倉庫番号データ情報をテーブル型で保持します。
WarehouseNumberDataList() - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のコンストラクタ
倉庫番号データ情報を作成します。
WarehouseNumberDataList(int) - class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList のコンストラクタ
倉庫番号データ情報を作成します。
Wmdvex - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex.
出力テーブル (日付および ATP 数量)情報クラス
機能は以下の通り
出力テーブル (日付および ATP 数量)情報を保持します。
Wmdvex() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のコンストラクタ
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvex(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex のコンストラクタ
出力テーブル (日付および ATP 数量)情報を作成します。
Wmdvsx - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx.
入力テーブル (日付/数量)情報クラス
機能は以下の通り
入力テーブル (日付/数量)情報を保持します。
Wmdvsx() - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のコンストラクタ
入力テーブル (日付/数量)情報を作成します。
Wmdvsx(int) - class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx のコンストラクタ
入力テーブル (日付/数量)情報を作成します。
A B C D E F G H I J K L M O P Q R S T U V W

概要

パッケージ

クラス

使用

階層ツリー

非推奨 API

索引

ヘルプ

intra-mart 6.1.14

前 次

フレームあり フレームなし


imsap_bapi_for_r3enterprise 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (imsap_bapi_for_r3enterprise 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.sap.module
jp.co.intra_mart.foundation.sap.module.accounting
jp.co.intra_mart.foundation.sap.module.accounting.exception
jp.co.intra_mart.foundation.sap.module.exception
jp.co.intra_mart.foundation.sap.module.financial
jp.co.intra_mart.foundation.sap.module.financial.exception
jp.co.intra_mart.foundation.sap.module.purchase
jp.co.intra_mart.foundation.sap.module.purchase.common.model
jp.co.intra_mart.foundation.sap.module.purchase.exception
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber
jp.co.intra_mart.foundation.sap.module.sales
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist
jp.co.intra_mart.foundation.sap.module.sales.common.model
jp.co.intra_mart.foundation.sap.module.sales.exception
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus


概要 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_sap_bapi (R/3 Enterprise) API Specifications

パッケージ
jp.co.intra_mart.foundation.sap.module |
jp.co.intra_mart.foundation.sap.module.accounting | ＳＡＰ連携財務会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.accounting.exception | ＳＡＰ連携財務会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.exception |
jp.co.intra_mart.foundation.sap.module.financial | ＳＡＰ連携管理会計系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.financial.exception | ＳＡＰ連携管理会計系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase | ＳＡＰ連携経費購買系に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.common.model |
jp.co.intra_mart.foundation.sap.module.purchase.exception | ＳＡＰ連携経費購買系例外クラスを提供します。
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate |
jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems |
jp.co.intra_mart.foundation.sap.module.purchase.materialavailability |
jp.co.intra_mart.foundation.sap.module.purchase.materialgetall |
jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica |
jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber |
jp.co.intra_mart.foundation.sap.module.sales |
jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail |
jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist |
jp.co.intra_mart.foundation.sap.module.sales.common.model |
jp.co.intra_mart.foundation.sap.module.sales.exception |
jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2 |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist |
jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.sap.module, jp.co.intra_mart.foundation.sap.module.accounting, jp.co.intra_mart.foundation.sap.module.accounting.exception, jp.co.intra_mart.foundation.sap.module.exception, jp.co.intra_mart.foundation.sap.module.financial, jp.co.intra_mart.foundation.sap.module.financial.exception, jp.co.intra_mart.foundation.sap.module.purchase, jp.co.intra_mart.foundation.sap.module.purchase.common.model, jp.co.intra_mart.foundation.sap.module.purchase.exception, jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate, jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems, jp.co.intra_mart.foundation.sap.module.purchase.materialavailability, jp.co.intra_mart.foundation.sap.module.purchase.materialgetall, jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica, jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber, jp.co.intra_mart.foundation.sap.module.sales, jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple, jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail, jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist, jp.co.intra_mart.foundation.sap.module.sales.common.model, jp.co.intra_mart.foundation.sap.module.sales.exception, jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2, jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist, jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.module.AbstractController (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.ReferenceController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BankList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.UpdateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller (implements java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 (implements java.io.Serializable)
          • class jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountGl (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.AccountTax (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.AllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Bank (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BankController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.Company (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CompanyController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Cond (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExchRate (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpActivity (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpMessage (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Extension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAcc (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.GlAccController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Limits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.MasterData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.OrderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItem (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Partner (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Selection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Success (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.SystemStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.common.model.Text (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn (implements java.io.Serializable)
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException
          • class jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException
            • class jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException
            • class jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException
            • class jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException
            • class jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.financial.UserStatus (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.Versions (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx (implements java.io.Serializable)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(imsap_bapi_for_r3enterprise 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (imsap_bapi_for_r3enterprise 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.sap.module

クラス jp.co.intra_mart.foundation.sap.module.AbstractController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sapClient

SapClient sapClient
SAPクライアント

bapiReturnErrMessage

String bapiReturnErrMessage
BAPI実行エラーメッセージ

bapiReturnMessage

String bapiReturnMessage
BAPI実行結果メッセージ

クラス jp.co.intra_mart.foundation.sap.module.ReferenceController は AbstractController を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.UpdateController は AbstractController を拡張し、Serializable を実装しています

直列化されたフィールド

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

パッケージ jp.co.intra_mart.foundation.sap.module.accounting

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccEmployeePayPostController は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

documentHeader

DocumentHeader documentHeader
伝票ヘッダ

accountPayableList

ArrayList accountPayableList
仕入先明細一覧

accountGlList

ArrayList accountGlList
G/L 勘定明細一覧

accountTaxList

ArrayList accountTaxList
税明細一覧

currencyAmountList

ArrayList currencyAmountList
明細通貨項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountGl は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glItemnoAcc

String glItemnoAcc
会計伝票明細番号

glGlAccount

String glGlAccount
総勘定元帳勘定

glCompCode

String glCompCode
会社コード

glPstngDate

String glPstngDate
伝票の転記日付

glDocType

String glDocType
伝票タイプ

glFiscYear

String glFiscYear
会計年度

glRefKey1

String glRefKey1
取引先参照キー

glItemText

String glItemText
明細テキスト

glTaxCode

String glTaxCode
消費税コード

glAllocNmbr

String glAllocNmbr
ソートキー

glBusArea

String glBusArea
事業領域

glCostcenter

String glCostcenter
原価センタ

glOrderid

String glOrderid
指図番号

glWbsElement

String glWbsElement
WBS 要素

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountPayable は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paItemnoAcc

String paItemnoAcc
会計伝票明細番号

paVendorNo

String paVendorNo
仕入先または債権者の勘定コード

paGlAccount

String paGlAccount
総勘定元帳勘定

paBlineDate

String paBlineDate
期日計算の支払基準日

paPymtMeth

String paPymtMeth
支払方法

paAllocNmbr

String paAllocNmbr
ソートキー

paItemText

String paItemText
明細テキスト

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.AccountTax は Object を拡張し、Serializable を実装しています

直列化されたフィールド

taItemnoAcc

String taItemnoAcc
会計伝票明細番号

taGlAccount

String taGlAccount
総勘定元帳勘定

taTaxCode

String taTaxCode
消費税コード

taIndex

int taIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.Bank は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bankKey

String bankKey
銀行コード

bankName

String bankName
銀行名

city

String city
市区町村名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

baList

BankList baList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BankList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

bankList

ArrayList bankList
銀行一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busArea

String busArea
事業領域

busArDes

String busArDes
事業領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

busAreaList

BusinessAreaList busAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.BusinessAreaList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

businessAreaList

ArrayList businessAreaList
事業領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.Company は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compCode

String compCode
会社コード

compName

String compName
会社名

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

compList

CompanyList compList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CompanyList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

companyList

ArrayList companyList
会社一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingArea は Object を拡張し、Serializable を実装しています

直列化されたフィールド

coArea

String coArea
管理領域

name

String name
管理領域名

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllAreaList

ControllingAreaList controllAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ControllingAreaList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

controllingAreaList

ArrayList controllingAreaList
管理領域一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

costCenter

String costCenter
原価センタ

name

String name
一般名称

descript

String descript
テキスト

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCentList

CostCenterList costCentList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CostCenterList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterList

ArrayList costCenterList
原価センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.CurrencyAmount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

cuItemnoAcc

String cuItemnoAcc
会計伝票明細番号

cuCurrency

String cuCurrency
通貨コード

cuAmtDoccur

String cuAmtDoccur
伝票通貨額

cuAmtBase

String cuAmtBase
課税基準額

cuIndex

int cuIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.DocumentHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docObjType

String docObjType
参照処理

docObjKey

String docObjKey
オブジェクトキー

docUsername

String docUsername
ユーザ名

docHeaderTxt

String docHeaderTxt
伝票ヘッダテキスト

docCompCode

String docCompCode
会社コード

docAcDocNo

String docAcDocNo
会計伝票番号

docFiscYear

String docFiscYear
会計年度

docDocDate

String docDocDate
伝票の伝票日付

docPstngDate

String docPstngDate
伝票の転記日付

docFisPeriod

String docFisPeriod
会計期間

docDocType

String docDocType
伝票タイプ

docRefDocNo

String docRefDocNo
参照伝票番号

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAcc は Object を拡張し、Serializable を実装しています

直列化されたフィールド

companyCode

String companyCode
会社コード

glAccount

String glAccount
G/L勘定コード

shortText

String shortText
G/L勘定コードテキスト(短)

longText

String longText
総勘定元帳勘定テキスト(長)

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

glList

GlAccList glList
勘定科目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.GlAccList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

glAccList

ArrayList glAccList
勘定項目一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenter は Object を拡張し、Serializable を実装しています

直列化されたフィールド

controllingArea

String controllingArea
管理領域

profitCtr

String profitCtr
利益センタ

validTo

String validTo
有効終了日

pctrName

String pctrName
一般名称

inCharge

String inCharge
利益センタ責任者

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCentList

ProfitCenterList profitCentList
利益センタ一覧

クラス jp.co.intra_mart.foundation.sap.module.accounting.ProfitCenterList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterList

ArrayList profitCenterList
利益センタ一覧

パッケージ jp.co.intra_mart.foundation.sap.module.accounting.exception

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.accounting.exception.SAPAccountingSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.exception

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPBapiReturnErrMessageExistException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.exception.SAPModuleSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.financial

クラス jp.co.intra_mart.foundation.sap.module.financial.AllowedBusTract は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strTrans

String strTrans
取引

strDescript

String strDescript
テキスト (30 文字)

クラス jp.co.intra_mart.foundation.sap.module.financial.CommonCenterGrpGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strControllingarea

String strControllingarea
管理領域

strGroupname

String strGroupname
グループ名

hierarchyNodesList

ArrayList hierarchyNodesList
階層ノード一覧

hierarchyValuesList

ArrayList hierarchyValuesList
階層値一覧

クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetail は CommonCenterGrpGetDetail を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.CostCenterGroupGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

costCenterGroupGetDetail

CostCenterGroupGetDetail costCenterGroupGetDetail
原価センタグループ情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strCreditorid

String strCreditorid
仕入先コード

strCompanycode

String strCompanycode
会社コード

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.financial.CreditorGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

creditorGetDetail

CreditorGetDetail creditorGetDetail
仕入先コード詳細情報

クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strDebtorid

String strDebtorid
得意先コード

strCompanycode

String strCompanycode
会社コード

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.financial.DebtorGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

debtorGetDetail

DebtorGetDetail debtorGetDetail
得意先コード詳細情報

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strRateType

String strRateType
換算レートタイプ

strFromCurr

String strFromCurr
換算前通貨

strToCurrncy

String strToCurrncy
換算後通貨

strDate

String strDate
起算日

exchRate

ExchRate exchRate
換算レート、係数 (通貨ペア)

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchangeRateGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

exchangeRateGetDetail

ExchangeRateGetDetail exchangeRateGetDetail
為替換算レート情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.ExchRate は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strRateType

String strRateType
換算レートタイプ

strFromCurr

String strFromCurr
換算前通貨

strToCurrncy

String strToCurrncy
換算後通貨

strValidFrom

String strValidFrom
エントリの有効開始日

strExchRate

String strExchRate
直接呼び値換算レート

strFromFactor

String strFromFactor
換算前 通貨単位の係数

strToFactor

String strToFactor
換算後 通貨単位の係数

strExchRateV

String strExchRateV
間接呼び値換算レート

strFromFactorV

String strFromFactorV
換算前 通貨単位の係数

strToFactorV

String strToFactorV
換算後 通貨単位の係数

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpActivity は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strNetwork

String strNetwork
ネットワーク番号

strActivity

String strActivity
ネットワーク/標準ネットワークの活動番号

strControlKey

String strControlKey
管理キー

strWorkCntr

String strWorkCntr
作業区

strPlant

String strPlant
プラント

strDescription

String strDescription
作業テキスト (短)

strVendorNo

String strVendorNo
仕入先または債権者の勘定コード

strPrice

String strPrice
価格

strPriceUnit

String strPriceUnit
価格単位

strCostElem

String strCostElem
原価要素

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strInfoRec

String strInfoRec
購買情報番号

strPurchOrg

String strPurchOrg
購買組織

strPurGroup

String strPurGroup
購買グループ

strMatlGroup

String strMatlGroup
品目グループ

strFlexibleDuration

String strFlexibleDuration
区分: 可変期間

strNumberOfCapacities

String strNumberOfCapacities
所要能力数

strPercentOfWork

String strPercentOfWork
作業の比率 (%)

strMilestone

String strMilestone
用途

strActtype

String strActtype
活動タイプ

strActivityCosts

String strActivityCosts
活動の原価

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strWbsElement

String strWbsElement
WBS 要素

strFactoryCalendar

String strFactoryCalendar
稼働日カレンダ

strDistributingKey

String strDistributingKey
能力所要量の配賦 (プラント保全、プロセス指図、ネットワーク)

strPriority

String strPriority
優先度

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strObjectclass

String strObjectclass
オブジェクトクラス (言語非依存)

strProfitCtr

String strProfitCtr
利益センタ

strNotMrpApplicable

String strNotMrpApplicable
区分: MRP への入出庫予定の適用不可と購買依頼未登録

strProjectSummarization

String strProjectSummarization
区分: プロジェクト集計用に活動を考慮

strOperationMeasureUnit

String strOperationMeasureUnit
活動単位

strOperationMeasureUnitIso

String strOperationMeasureUnitIso
単位の ISO コード

strPlndDelry

String strPlndDelry
予定納入時間 (単位: 日)

strDurationNormal

String strDurationNormal
標準活動期間

strDurationNormalUnit

String strDurationNormalUnit
標準期間/単位

strDurationNormalUnitIso

String strDurationNormalUnitIso
単位の ISO コード

strDurationMinimum

String strDurationMinimum
最短活動期間

strDurationMinimumUnit

String strDurationMinimumUnit
最短期間の単位

strDurationMinimumUnitIso

String strDurationMinimumUnitIso
単位の ISO コード

strConstraintTypeStart

String strConstraintTypeStart
活動の基準開始日に対する制約

strConstraintTypeFinish

String strConstraintTypeFinish
活動の終了日に対する制約

strWorkActivity

String strWorkActivity
活動に含まれる作業

strUnWork

String strUnWork
作業単位

strUnWorkIso

String strUnWorkIso
単位の ISO コード

strEarlyStartDate

String strEarlyStartDate
最早計画開始: 実行 (日)

strEarlyStartTime

String strEarlyStartTime
最早計画開始: 作業実施(時間)

strEarlyFinishDate

String strEarlyFinishDate
最早計画終了: 実行 (日)

strEarlyFinishTime

String strEarlyFinishTime
最早計画終了: 実行 (時刻)

strLatestStartDate

String strLatestStartDate
計画最遅開始: 作業(日付)

strLatestStartTime

String strLatestStartTime
計画最遅開始: 作業(時間)

strLatestFinishDate

String strLatestFinishDate
計画最遅終了: 作業(日付)

strLatestFinishTime

String strLatestFinishTime
計画最遅終了: 作業(時間)

strFloatFree

String strFloatFree
自由余裕

strFloatTotal

String strFloatTotal
余裕合計

strConstraintStartDate

String strConstraintStartDate
活動の基準開始日に対する制約

strConstraintStartTime

String strConstraintStartTime
活動の基準開始時間の制約

strConstraintFinishDate

String strConstraintFinishDate
活動の基準終了日に対する制約

strConstraintFinishTime

String strConstraintFinishTime
活動の基準終了時間

strUserFieldKey

String strUserFieldKey
ユーザ定義項目のキーワード ID

strUserFieldChar201

String strUserFieldChar201
20 文字のユーザ項目

strUserFieldChar202

String strUserFieldChar202
20 文字のユーザ項目

strUserFieldChar101

String strUserFieldChar101
ユーザ定義項目 (10 文字)

strUserFieldChar102

String strUserFieldChar102
ユーザ定義項目 (10 文字)

strUserFieldQuan1

String strUserFieldQuan1
数量のユーザ項目 (長さ 10,3)

strUserFieldUnit1

String strUserFieldUnit1
ユーザ項目: 数量項目の単位

strUserFieldUnit1Iso

String strUserFieldUnit1Iso
単位の ISO コード

strUserFieldQuan2

String strUserFieldQuan2
数量のユーザ項目 (長さ 10,3)

strUserFieldUnit2

String strUserFieldUnit2
ユーザ項目: 数量項目の単位

strUserFieldUnit2Iso

String strUserFieldUnit2Iso
単位の ISO コード

strUserFieldCurr1

String strUserFieldCurr1
値のユーザ定義項目 (長さ 10,3)

strUserFieldCuky1

String strUserFieldCuky1
ユーザ項目: 値項目の単位

strUserFieldCuky1Iso

String strUserFieldCuky1Iso
ISO 通貨コード

strUserFieldCurr2

String strUserFieldCurr2
値のユーザ定義項目 (長さ 10,3)

strUserFieldCuky2

String strUserFieldCuky2
ユーザ項目: 値項目の単位

strUserFieldCuky2Iso

String strUserFieldCuky2Iso
ISO 通貨コード

strUserFieldDate1

String strUserFieldDate1
日付のユーザ項目

strUserFieldDate2

String strUserFieldDate2
日付のユーザ項目

strUserFieldFlag1

String strUserFieldFlag1
ユーザ定義項目: レポート区分

strUserFieldFlag2

String strUserFieldFlag2
ユーザ定義項目: レポート区分

strDeletionFlag

String strDeletionFlag
削除フラグ

strDurationNormalFc

String strDurationNormalFc
標準活動期間 (予測)

strDurationNormalFcUnit

String strDurationNormalFcUnit
標準予測期間の単位

strDurationNormalFcUnitIso

String strDurationNormalFcUnitIso
単位の ISO コード

strDurationMinimumFc

String strDurationMinimumFc
活動の最小期間(需要予測より)

strDurationMinimumFcUnit

String strDurationMinimumFcUnit
予測最短期間の単位

strDurationMinimumFcUnitIso

String strDurationMinimumFcUnitIso
単位の ISO コード

strConstraintTypeFinishFc

String strConstraintTypeFinishFc
活動終了の制約条件付き需要予測日付

strConstraintTypeStartFc

String strConstraintTypeStartFc
活動開始の制約条件付き需要予測日付

strConstraintStartDateFc

String strConstraintStartDateFc
活動の予測開始日

strConstraintStartTimeFc

String strConstraintStartTimeFc
活動の需要予測開始時間

strConstraintFinishDateFc

String strConstraintFinishDateFc
予測終了日付

strConstraintFinishTimeFc

String strConstraintFinishTimeFc
活動の予測終了時間

strEarlyStartDateFc

String strEarlyStartDateFc
最早計画開始日付(需要予測)

strEarlyStartTimeFc

String strEarlyStartTimeFc
最早計画開始時間(需要予測)

strEarlyFinishDateFc

String strEarlyFinishDateFc
最早計画終了日 (予測)

strEarlyFinishTimeFc

String strEarlyFinishTimeFc
最早計画終了時間(需要予測)

strLatestStartDateFc

String strLatestStartDateFc
最遅計画済開始日付(需要予測)

strLatestStartTimeFc

String strLatestStartTimeFc
最遅計画済開始時間(需要予測)

strLatestFinishDateFc

String strLatestFinishDateFc
最遅計画済終了日付(需要予測)

strLatestFinishTimeFc

String strLatestFinishTimeFc
最遅計画終了時間 (予測)

strFloatFreeFc

String strFloatFreeFc
自由余裕 (予測)

strFloatTotalFc

String strFloatTotalFc
余裕合計 (予測)

strWorkForecast

String strWorkForecast
予測作業 (実績 + 残存)

strWorkActual

String strWorkActual
実績作業

strDurationScheduled

String strDurationScheduled
処理時間

strDurationScheduledFc

String strDurationScheduledFc
処理時間の長さ (予測値)

strDurationScheduledUnit

String strDurationScheduledUnit
処理時間単位

strDurationScheduledUnitIso

String strDurationScheduledUnitIso
単位の ISO コード

strDurationConfirmFc

String strDurationConfirmFc
確認の予測活動期間

strDurationConfirmFcUnit

String strDurationConfirmFcUnit
確認の予測期間単位

strDurationConfirmFcUnitIso

String strDurationConfirmFcUnitIso
単位の ISO コード

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

strPlannedCost

String strPlannedCost
計画原価

strActualCost

String strActualCost
実際原価

strControllingAreaCurrency

String strControllingAreaCurrency
通貨コード

strActualStartDate

String strActualStartDate
実績開始日: 実行 (日付)

strActualFinishDate

String strActualFinishDate
実績終了日: 実行 (日付)

strForecastFinishDate

String strForecastFinishDate
予測終了日

strComplete

String strComplete
最終確認の有効化

strReferencePoint

String strReferencePoint
BOM 転送の参照ポイント

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpMessage は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMethod

String strMethod
メソッド

strObjectType

String strObjectType
オブジェクトタイプ

strInternalObjectId

String strInternalObjectId
SAP 内部対象キー

strExternalObjectId

String strExternalObjectId
SAP 外部対象キー

strMessageId

String strMessageId
メッセージ ID

strMessageNumber

String strMessageNumber
システムメッセージ番号

strMessageType

String strMessageType
メッセージタイプ

strMessageText

String strMessageText
メッセージのテキスト行

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsElement は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strDescription

String strDescription
PS: テキスト(短)(第一テキスト行)

strShortId

String strShortId
WBS 要素 ショート ID

strResponsibleNo

String strResponsibleNo
責任者番号 (プロジェクト責任者)

strApplicantNo

String strApplicantNo
申請者番号

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strCoArea

String strCoArea
管理領域

strProfitCtr

String strProfitCtr
利益センタ

strProjType

String strProjType
プロジェクトタイプ

strNetworkAssignment

String strNetworkAssignment
ネットワーク割当

strCostingSheet

String strCostingSheet
原価計算表

strOverheadKey

String strOverheadKey
間接費キー

strCalendar

String strCalendar
稼動日カレンダ

strPriority

String strPriority
優先度

strEquipment

String strEquipment
設備番号

strFunctionalLocation

String strFunctionalLocation
機能場所

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO 通貨コード

strPlant

String strPlant
プラント

strUserFieldKey

String strUserFieldKey
ユーザ定義項目のキーワード ID

strUserFieldChar201

String strUserFieldChar201
20 文字の第 1 ユーザ項目 - WBS 要素 -

strUserFieldChar202

String strUserFieldChar202
20 桁の第 2 ユーザ項目 - WBS 要素

strUserFieldChar101

String strUserFieldChar101
10 桁の第 3 ユーザ項目 - WBS 要素

strUserFieldChar102

String strUserFieldChar102
10 桁の第 4 ユーザ項目 - WBS 要素

strUserFieldQuan1

String strUserFieldQuan1
数量の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldUnit1

String strUserFieldUnit1
数量項目単位の第１ユーザ定義項目 - WBS 要素

strUserFieldUnit1Iso

String strUserFieldUnit1Iso
単位の ISO コード

strUserFieldQuan2

String strUserFieldQuan2
数量の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldUnit2

String strUserFieldUnit2
数量項目単位の第２ユーザ定義項目 - WBS 要素

strUserFieldUnit2Iso

String strUserFieldUnit2Iso
単位の ISO コード

strUserFieldCurr1

String strUserFieldCurr1
値の第 1 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldCuky1

String strUserFieldCuky1
値項目単位の第１ユーザ定義項目 - WBS 要素

strUserFieldCuky1Iso

String strUserFieldCuky1Iso
ISO 通貨コード

strUserFieldCurr2

String strUserFieldCurr2
値の第 2 ユーザ項目 (長さ 10,3) - WBS 要素

strUserFieldCuky2

String strUserFieldCuky2
値項目単位の第２ユーザ定義項目 - WBS 要素

strUserFieldCuky2Iso

String strUserFieldCuky2Iso
ISO 通貨コード

strUserFieldDate1

String strUserFieldDate1
日付の第 1 ユーザ項目 - WBS 要素

strUserFieldDate2

String strUserFieldDate2
日付の第 2 ユーザ項目 - WBS 要素

strUserFieldFlag1

String strUserFieldFlag1
'評価区分' の第 1 ユーザ項目 - WBS 要素

strUserFieldFlag2

String strUserFieldFlag2
'評価区分' の第 2 ユーザ項目 - WBS 要素

strObjectclass

String strObjectclass
対象クラス

strStatistical

String strStatistical
統計 WBS 要素

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strIntProfile

String strIntProfile
プロジェクト/指図金利計算の金利プロファイル

strJointVenture

String strJointVenture
ジョイントベンチャ

strRecoveryInd

String strRecoveryInd
リカバリフラグ

strEquityType

String strEquityType
持分タイプ

strJvObjectType

String strJvObjectType
ジョイントベンチャ対象タイプ

strJvJibClass

String strJvJibClass
JIB/JIBE クラス

strJvJibSubClassA

String strJvJibSubClassA
JIB/JIBE サブクラスA

strDeletionFlag

String strDeletionFlag
削除フラグ

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strWbsPlanningElement

String strWbsPlanningElement
区分: 計画要素

strWbsAccountAssignmentElement

String strWbsAccountAssignmentElement
区分: 勘定設定要素

strWbsBillingElement

String strWbsBillingElement
区分: 請求要素

strRespsblCctr

String strRespsblCctr
責任原価センタ

strRespsblCctrControllingArea

String strRespsblCctrControllingArea
責任原価センタの管理領域

strRequestCctr

String strRequestCctr
申請原価センタ

strRequestCompCode

String strRequestCompCode
会社コード要求

strRequestCctrControllingArea

String strRequestCctrControllingArea
依頼原価センタの管理領域

strLocation

String strLocation
場所

strChangeNo

String strChangeNo
変更番号

strInvestProfile

String strInvestProfile
設備投資案件プロファイル

strResAnalKey

String strResAnalKey
結果分析キー

strWbsCctrPostedActual

String strWbsCctrPostedActual
原価が実際に転記される原価センタ

strWbsBasicStartDate

String strWbsBasicStartDate
WBS 要素: 基本開始日

strWbsBasicFinishDate

String strWbsBasicFinishDate
WBS 要素: 基本終了日付

strWbsForecastStartDate

String strWbsForecastStartDate
WBS 要素の予測開始日

strWbsForecastFinishDate

String strWbsForecastFinishDate
WBS 要素の予測済終了日付

strWbsActualStartDate

String strWbsActualStartDate
WBS 要素の実績開始日付

strWbsActualFinishDate

String strWbsActualFinishDate
WBS 要素の実績終了日

strWbsBasicDuration

String strWbsBasicDuration
WBS 要素の基準日の長さ(期間)

strWbsBasicDurUnit

String strWbsBasicDurUnit
基準 WBS 要素日付の期間単位

strWbsBasicDurUnitIso

String strWbsBasicDurUnitIso
単位の ISO コード

strWbsForecastDuration

String strWbsForecastDuration
WBS 要素の予測期間

strWbsForcastDurUnit

String strWbsForcastDurUnit
WBS 要素計画日付の単位

strWbsForecastDurUnitIso

String strWbsForecastDurUnitIso
単位の ISO コード

strWbsActualDuration

String strWbsActualDuration
WBS 要素の実績長(期間)

strWbsActualDurUnit

String strWbsActualDurUnit
実績 WBS 要素日付の期間単位

strWbsActualDurUnitIso

String strWbsActualDurUnitIso
単位の ISO コード

strWbsScdBasicStartDate

String strWbsScdBasicStartDate
最早計画開始日 (基準)

strWbsScdBasicFinishDate

String strWbsScdBasicFinishDate
最遅計画終了日 (基準)

strWbsScdForecastStartDate

String strWbsScdForecastStartDate
計画開始日 (予測)

strWbsScdForecastFinishDate

String strWbsScdForecastFinishDate
最遅計画終了日 (予測)

strWbsScdActualStartDate

String strWbsScdActualStartDate
WBS 要素の仮実績開始日

strWbsScdActualFinishDate

String strWbsScdActualFinishDate
WBS 要素の仮実績終了日

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsHierarchie は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strUp

String strUp
WBS 要素

strDown

String strDown
WBS 要素

strLeft

String strLeft
WBS 要素

strRight

String strRight
WBS 要素

クラス jp.co.intra_mart.foundation.sap.module.financial.ExpWbsMilestone は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMilestoneNumber

String strMilestoneNumber
マイルストーン番号

strWbsElement

String strWbsElement
WBS 要素

strMilestoneUsage

String strMilestoneUsage
マイルストーン用途

strDescription

String strDescription
テキスト

strSchedMilestoneDateBasic

String strSchedMilestoneDateBasic
マイルストーン計画日(基準)

strSchedMilestoneTimeBasic

String strSchedMilestoneTimeBasic
マイルストーン計画時間(基準)

strSchedMilestoneDateForecast

String strSchedMilestoneDateForecast
マイルストーン計画日(予測)

strSchedMilestoneTimeForecast

String strSchedMilestoneTimeForecast
マイルストーン計画時間(予測)

strFixedMilestoneDateBasic

String strFixedMilestoneDateBasic
固定マイルストーン日付(基準)

strFixedMilestoneTimeBasic

String strFixedMilestoneTimeBasic
固定マイルストーン時間(基準)

strFixedMilestoneDateForecast

String strFixedMilestoneDateForecast
マイルストーン固定日付

strFixedMilestoneTimeForecast

String strFixedMilestoneTimeForecast
マイルストーン固定時間 (F)

strActualDate

String strActualDate
実績日付(マイルストーン通過)

strActualTime

String strActualTime
実績日/時間(マイルストーン適合)

strLatestDatesIndicator

String strLatestDatesIndicator
区分: 最遅日

strOffsetStartEndIndicator

String strOffsetStartEndIndicator
区分: オフセット用の参照（開始/終了活動日）

strOffsetMilestoneDate

String strOffsetMilestoneDate
マイルストーン日付のオフセット

strOffsetMilestoneDateUnit

String strOffsetMilestoneDateUnit
マイルストーンのオフセットのための時間単位

strOffsetMilestoneDateUnitIso

String strOffsetMilestoneDateUnitIso
単位の ISO コード

strOffsetPercentage

String strOffsetPercentage
活動日に対するマイルストーンの百分率によるオフセット

strTrendAnalysisIndicator

String strTrendAnalysisIndicator
傾向分析の関連マイルストーン

strEarnedValueIndicator

String strEarnedValueIndicator
進捗分析関連のマイルストーン

strPercentageOfCompletion

String strPercentageOfCompletion
進捗度 (%)

strSalesDocDateInidicator

String strSalesDocDateInidicator
販売伝票の日付に関連するマイルストーン

strInvoicePercentage

String strInvoicePercentage
請求金額率 (%)

strDeletionFlag

String strDeletionFlag
削除フラグ

クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyNodes は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strGroupname

String strGroupname
グループ名

strHierlevel

String strHierlevel
階層のエントリレベル

strValcount

String strValcount
階層ノード内の値の値数

strDescript

String strDescript
グループテキスト (短)

クラス jp.co.intra_mart.foundation.sap.module.financial.HierarchyValues は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strValfrom

String strValfrom
原価センタ/利益センタ

strValto

String strValto
原価センタ/利益センタ

クラス jp.co.intra_mart.foundation.sap.module.financial.ImpWbsElement は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strWbsElement

String strWbsElement
WBS 要素

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strOrderid

String strOrderid
指図番号

strLanguage

String strLanguage
ステータスおよび業務トランザクションテキストの言語

masterData

MasterData masterData
指図のマスタデータ構造

systemStatusList

ArrayList systemStatusList
システムステータステーブル

userStatusList

ArrayList userStatusList
ユーザステータス/指図ステータステーブル

allowedBusTractList

ArrayList allowedBusTractList
使用可能業務トランザクションのテーブル

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

internalOrderGetDetail

InternalOrderGetDetail internalOrderGetDetail
内部指図書詳細情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strControllingArea

String strControllingArea
管理領域

strRespCostCenter

String strRespCostCenter
責任原価センタ

strOrderType

String strOrderType
指図タイプ

strOrder

String strOrder
指図番号 (個別値、または下限値)

strOrderTo

String strOrderTo
指図番号 (上限値)

strOrderExternalNo

String strOrderExternalNo
外部指図番号 (個別値、または下限値)

strOrderExternalNoTo

String strOrderExternalNoTo
外部指図番号 (上限値)

orderListList

ArrayList orderListList
選択指図一覧

クラス jp.co.intra_mart.foundation.sap.module.financial.InternalOrderGetListController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

internalOrderGetList

InternalOrderGetList internalOrderGetList
内部指図書一覧情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.MasterData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strOrder

String strOrder
指図番号

strOrderType

String strOrderType
販売伝票タイプ

strOrderName

String strOrderName
テキスト

strExtOrdNo

String strExtOrdNo
外部指図番号

strObjectNo

String strObjectNo
対象番号

strCoArea

String strCoArea
管理領域

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strPlant

String strPlant
プラント

strProfitCtr

String strProfitCtr
利益センタ

strRespcctr

String strRespcctr
責任原価センタ

strWbsElem

String strWbsElem
作業詳細項目要素 (WBS 要素)

strWbsElementExt

String strWbsElementExt
WBS 要素

strRequestCctr

String strRequestCctr
申請原価センタ

strRequCompCode

String strRequCompCode
会社コード要求

strSalesOrd

String strSalesOrd
受注伝票番号

strSOrdItem

String strSOrdItem
受注明細番号

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strCctrPosted

String strCctrPosted
原価が実際に転記された原価センタ

strCurrency

String strCurrency
購買発注通貨

strCstgSheet

String strCstgSheet
原価計算表

strOverheadKey

String strOverheadKey
間接費キー

strResAnalKey

String strResAnalKey
結果分析キー

strInterestProf

String strInterestProf
プロジェクト/指図金利計算の金利プロファイル

strApplicant

String strApplicant
申請者

strApplicantPhone

String strApplicantPhone
申請者の電話番号

strPersonResp

String strPersonResp
責任者

strPersonRespPhone

String strPersonRespPhone
責任者の電話番号

strEstimatedCosts

String strEstimatedCosts
指図の見積原価合計

strApplicationDate

String strApplicationDate
申請日

strDepartment

String strDepartment
部署

strDateWorkBegins

String strDateWorkBegins
作業開始

strDateWorkEnds

String strDateWorkEnds
作業終了

strWorkPermit

String strWorkPermit
仕事許可済フラグ

strProcessingGroup

String strProcessingGroup
処理グループ

strPlnRelease

String strPlnRelease
計画リリース日付

strPlnCompletion

String strPlnCompletion
計画完了日

strPlnClose

String strPlnClose
計画終了日付

strRequestOrder

String strRequestOrder
申請指図

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.OrderList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strOrder

String strOrder
指図番号

strObjectNo

String strObjectNo
対象番号

strOrderType

String strOrderType
販売伝票タイプ

strOrderName

String strOrderName
テキスト

クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetail は CommonCenterGrpGetDetail を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.ProfitCenterGrpGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

profitCenterGrpGetDetail

ProfitCenterGrpGetDetail profitCenterGrpGetDetail
利益センタグループ情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectDefinition は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strDescription

String strDescription
PS: テキスト(短)(第一テキスト行)

strMaskId

String strMaskId
WBS 要素 ID(短)の選択マスク

strResponsibleNo

String strResponsibleNo
責任者番号 (プロジェクト責任者)

strApplicantNo

String strApplicantNo
申請者番号

strCompCode

String strCompCode
会社コード

strBusArea

String strBusArea
事業領域

strControllingArea

String strControllingArea
管理領域

strProfitCtr

String strProfitCtr
利益センタ

strProjectCurrency

String strProjectCurrency
WBS 通貨(プロジェクト定義)

strProjectCurrencyIso

String strProjectCurrencyIso
ISO 通貨コード

strNetworkAssignment

String strNetworkAssignment
ネットワーク割当

strStart

String strStart
プロジェクト計画開始日付

strFinish

String strFinish
プロジェクトの計画終了日

strPlant

String strPlant
プラント

strCalendar

String strCalendar
稼動日カレンダ

strPlanBasic

String strPlanBasic
プロジェクト基準日付計画方法

strPlanFcst

String strPlanFcst
プロジェクト予測日付の計画方法

strTimeUnit

String strTimeUnit
時間計画単位

strTimeUnitIso

String strTimeUnitIso
単位の ISO コード

strNetworkProfile

String strNetworkProfile
ネットワークプロファイル

strProjectProfile

String strProjectProfile
プロジェクトプロファイル

strBudgetProfile

String strBudgetProfile
予算プロファイル

strProjectStock

String strProjectStock
プロジェクト在庫

strObjectclass

String strObjectclass
対象クラス

strStatistical

String strStatistical
統計 WBS 要素

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strIntProfile

String strIntProfile
プロジェクト/指図金利計算の金利プロファイル

strWbsSchedProfile

String strWbsSchedProfile
WBS 日程計画のプロファイル

strCshBdgtProfile

String strCshBdgtProfile
資金計画プロファイル

strPlanProfile

String strPlanProfile
計画プロファイル

strJointVenture

String strJointVenture
ジョイントベンチャ

strRecoveryInd

String strRecoveryInd
リカバリフラグ

strEquityType

String strEquityType
持分タイプ

strJvObjectType

String strJvObjectType
ジョイントベンチャ対象タイプ

strJvJibClass

String strJvJibClass
JIB/JIBE クラス

strJvJibSubClassA

String strJvJibSubClassA
JIB/JIBE サブクラスA

strDeletionFlag

String strDeletionFlag
削除フラグ

strObjectclassExt

String strObjectclassExt
オブジェクトクラス、言語依存

strFuncArea

String strFuncArea
機能領域

strFuncAreaLong

String strFuncAreaLong
機能領域

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfo は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strProjectDefinition

String strProjectDefinition
プロジェクト定義

strWithActivities

String strWithActivities
区分: 活動があるプロジェクト

strWithMilestones

String strWithMilestones
マイルストーンがあるプロジェクトの出力

strWithSubtree

String strWithSubtree
WBS 要素サブツリーの出力

impWbsElementList

ArrayList impWbsElementList
WBS 要素

projectDefinition

ProjectDefinition projectDefinition
プロジェクトについての詳細情報

expWbsElementList

ArrayList expWbsElementList
WBS 要素についての詳細情報

expWbsMilestoneList

ArrayList expWbsMilestoneList
WBS マイルストーンに関する詳細情報

expWbsHierarchieList

ArrayList expWbsHierarchieList
WBS 階層についての情報

expActivityList

ArrayList expActivityList
活動に関する詳細情報

expMessageList

ArrayList expMessageList
詳細情報を読み込みエラー

クラス jp.co.intra_mart.foundation.sap.module.financial.ProjectGetInfoController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

projectGetInfo

ProjectGetInfo projectGetInfo
WBSの詳細情報クラス

クラス jp.co.intra_mart.foundation.sap.module.financial.SystemStatus は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strSysStatus

String strSysStatus
システムステータス

strSyStText

String strSyStText
オブジェクトの個別ステータス (簡略形式)

strSyStDscr

String strSyStDscr
オブジェクトステータス

クラス jp.co.intra_mart.foundation.sap.module.financial.UserStatus は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strStatProf

String strStatProf
ステータスプロファイル

strUsrStatus

String strUsrStatus
ユーザステータス

strUsStNumb

String strUsStNumb
ステータス番号

strUsStText

String strUsStText
オブジェクトの個別ステータス (簡略形式)

strUsStDscr

String strUsStDscr
オブジェクトステータス

パッケージ jp.co.intra_mart.foundation.sap.module.financial.exception

クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.financial.exception.SAPFinancialSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase

クラス jp.co.intra_mart.foundation.sap.module.purchase.AllVersions は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strDocType

String strDocType
購買伝票カテゴリ

strDocNumber

String strDocNumber
購買管理におけるオブジェクト番号

strItemNumber

String strItemNumber
購買管理オブジェクト: 明細

strVersion

String strVersion
購買管理におけるバージョン番号

strCreatedBy

String strCreatedBy
オブジェクト登録者名

strCrOn

String strCrOn
レコード登録日

strRecTime

String strRecTime
登録時刻

strReleasedBy

String strReleasedBy
承認者名

strReleaseDate

String strReleaseDate
承認日

strReleaseTime

String strReleaseTime
承認時刻

strReleasebyPur

String strReleasebyPur
承認購買担当者名

strReleasedatePur

String strReleasedatePur
購買担当者承認日付

strReleasetimePur

String strReleasetimePur
購買担当者承認時刻

strReason

String strReason
変更理由

strDescription

String strDescription
バージョンテキスト（長）

strReqByExt

String strReqByExt
バージョンの外部変更番号

strReqBy

String strReqBy
変更を依頼した従業員

strNetValue

String strNetValue
購買発注通貨による正味発注額

strValueChanged

String strValueChanged
バージョンによる金額変更

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO コード通貨

strPostDate

String strPostDate
バージョンの転記日付

strCompleted

String strCompleted
ステータス "バージョン完了済"

strStatus

String strStatus
バージョンステータス

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strStatusDocOld

String strStatusDocOld
このバージョンの前の旧処理状況 (購買伝票内)

クラス jp.co.intra_mart.foundation.sap.module.purchase.Cond は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strConditionNo

String strConditionNo
伝票条件番号

strItmNumber

String strItmNumber
条件明細番号

strCondStNo

String strCondStNo
ステップ番号

strCondCount

String strCondCount
条件カウンタ

strCondType

String strCondType
条件タイプ

strCondValue

String strCondValue
条件レート

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO コード通貨

strCondUnit

String strCondUnit
条件単位

strCondUnitIso

String strCondUnitIso
条件数量単位 (ISO コード)

strCondPUnt

String strCondPUnt
価格条件単位

strApplicatio

String strApplicatio
アプリケーション

strConpricdat

String strConpricdat
条件価格設定日付

strCalctypcon

String strCalctypcon
条件計算タイプ

strConbaseval

String strConbaseval
条件基礎値

strConexchrat

String strConexchrat
現地通貨への換算レートに対する条件

strNumconvert

String strNumconvert
条件単位を基本単位へ変換する分子

strDenominato

String strDenominato
条件単位を基本単位へ変換する分母

strCondtype

String strCondtype
条件カテゴリ (例: 税、運賃、価格、原価)

strStatCon

String strStatCon
統計に適用する条件

strScaletype

String strScaletype
スケールタイプ

strAccruals

String strAccruals
見越額関連条件 (運賃など)

strConinvolst

String strConinvolst
請求書一覧条件

strCondorigin

String strCondorigin
条件生成区分

strGroupcond

String strGroupcond
グループ条件区分

strCondUpdat

String strCondUpdat
条件更新

strAccessSeq

String strAccessSeq
検索順序 - 検索番号

strCondcount

String strCondcount
条件連続番号

strCondcntrl

String strCondcntrl
条件管理

strCondisacti

String strCondisacti
無効条件

strCondclass

String strCondclass
条件クラス

strFactbasval

String strFactbasval
条件基礎値に対する要因

strScalebasin

String strScalebasin
スケール基準区分

strScalbasval

String strScalbasval
条件のスケール基準値

strUnitmeasur

String strUnitmeasur
条件スケール単位

strUnitmeasurIso

String strUnitmeasurIso
単位の ISO コード

strCurrenckey

String strCurrenckey
スケール通貨

strCurrenckeyIso

String strCurrenckeyIso
ISO コード通貨

strCondincomp

String strCondincomp
会社間請求の条件

strCondconfig

String strCondconfig
システム設定の条件

strCondchaman

String strCondchaman
条件 (マニュアル変更済)

strCondNo

String strCondNo
条件レコード番号

strChangeId

String strChangeId
変更タイプ(U、I、E、D)

coIndex

int coIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractLimits は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
制限の内部明細番号

strConNumber

String strConNumber
基本契約番号

strConItem

String strConItem
明細番号、契約

strLimit

String strLimit
全体制限

strNoLimit

String strNoLimit
制限なし

strPriceChg

String strPriceChg
入力シートの価格変更

strShortText

String strShortText
テキスト 1 (短)

strDeleteInd

String strDeleteInd
削除フラグ

clIndex

int clIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractService は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
内部明細番号

strExtLine

String strExtLine
明細番号

strOutlLevel

String strOutlLevel
グループの階層レベル

strOutlNo

String strOutlNo
アウトラインレベル

strOutlInd

String strOutlInd
区分: 出力行

strSubpckgNo

String strSubpckgNo
サブパッケージ番号

strService

String strService
活動番号

strServType

String strServType
サービスタイプのテキスト (短)

strEdition

String strEdition
サービスタイプのバージョン

strSscItem

String strSscItem
標準サービスカタログ: 明細

strExtServ

String strExtServ
仕入先のサービス番号

strQuantity

String strQuantity
+/- 記号あり/なし数量

strBaseUom

String strBaseUom
基本数量単位

strUomIso

String strUomIso
単位の ISO コード

strOvfTol

String strOvfTol
超過許容値

strOvfUnlim

String strOvfUnlim
契約外サービス制限なし

strPriceUnit

String strPriceUnit
価格単位

strGrPrice

String strGrPrice
基準額

strFromLine

String strFromLine
下限

strToLine

String strToLine
上限

strShortText

String strShortText
テキスト(短)

strDistrib

String strDistrib
複数勘定設定の配賦区分

strPersNo

String strPersNo
従業員番号

strWagetype

String strWagetype
ウェイジタイプ

strPlnPckg

String strPlnPckg
パッケージ番号供給元一覧

strPlnLine

String strPlnLine
入力: 計画梱包明細行

strConPckg

String strConPckg
入力: 基本契約の計画外

strConLine

String strConLine
入力: 基本契約の計画外

strTmpPckg

String strTmpPckg
入力: モデル仕様からの計画外サービス

strTmpLine

String strTmpLine
入力: モデル仕様からの計画外サービス

strSscLim

String strSscLim
標準サービスカタログ制限参照のサービス行

strLimitLine

String strLimitLine
入力: 計画外、明細制限

strTargetVal

String strTargetVal
目標値

strBaslineNo

String strBaslineNo
代替: 基本明細参照

strBasicLine

String strBasicLine
基本明細

strAlternat

String strAlternat
代替明細

strBidder

String strBidder
入札者の明細

strSuppLine

String strSuppLine
補足明細

strOpenQty

String strOpenQty
未処理数量のある明細

strInform

String strInform
情報行

strBlanket

String strBlanket
包括明細

strEventual

String strEventual
偶発的明細

strTaxCode

String strTaxCode
消費税コード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strPriceChg

String strPriceChg
入力シートの価格変更

strMatlGroup

String strMatlGroup
品目グループ

strDate

String strDate
日付

strBegintime

String strBegintime
開始時刻

strEndtime

String strEndtime
終了時刻

strExtpersNo

String strExtpersNo
外部従業員番号

strFormula

String strFormula
計算式番号

strFormVal1

String strFormVal1
計算式値

strFormVal2

String strFormVal2
計算式値

strFormVal3

String strFormVal3
計算式値

strFormVal4

String strFormVal4
計算式値

strFormVal5

String strFormVal5
計算式値

strUserf1Num

String strUserf1Num
ユーザ定義項目

strUserf2Num

String strUserf2Num
ユーザ定義項目

strUserf1Txt

String strUserf1Txt
ユーザ定義項目

strUserf2Txt

String strUserf2Txt
ユーザ定義項目

strHiLineNo

String strHiLineNo
上位階層明細番号

strExtrefkey

String strExtrefkey
サービスの外部参照キー

strDeleteInd

String strDeleteInd
削除フラグ

csIndex

int csIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceAccount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
明細行番号

strSernoLine

String strSernoLine
勘定コード設定のシリアル番号、サービス明細

strPercentage

String strPercentage
勘定設定金額配賦のパーセント

strSerialNo

String strSerialNo
勘定設定の連続番号

strQuantity

String strQuantity
+/- 記号あり/なし数量

strNetValue

String strNetValue
明細の正味額

saIndex

int saIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ContractServiceText は PurchaseText を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLineNo

String strLineNo
内部明細番号

strFormatCol

String strFormatCol
タグ列

クラス jp.co.intra_mart.foundation.sap.module.purchase.DeliveryAddress は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strAddrNo

String strAddrNo
アドレス番号

strFormofaddr

String strFormofaddr
敬称テキスト

strName

String strName
名称 1

strName2

String strName2
名称 2

strName3

String strName3
名称 3

strName4

String strName4
名称 4

strCOName

String strCOName
気付

strCity

String strCity
市区町村

strDistrict

String strDistrict
所在地

strCityNo

String strCityNo
市区町村/地名ファイルの市区町村コード

strPostlCod1

String strPostlCod1
市区町村の郵便番号

strPostlCod2

String strPostlCod2
私書箱郵便番号

strPostlCod3

String strPostlCod3
会社郵便番号 (大規模なユーザ用)

strPoBox

String strPoBox
私書箱

strPoBoxCit

String strPoBoxCit
私書箱住所

strDelivDis

String strDelivDis
郵便配達地域

strStreet

String strStreet
地名

strStreetNo

String strStreetNo
市区町村/地名ファイルの地名コード

strStrAbbr

String strStrAbbr
地名の略称 (例: スペイン)

strHouseNo

String strHouseNo
番地-号

strStrSuppl1

String strStrSuppl1
地名 2

strStrSuppl2

String strStrSuppl2
地名 3

strLocation

String strLocation
地名 5

strBuilding

String strBuilding
旧: 建物 (番号または略称)

strFloor

String strFloor
建物の階

strRoomNo

String strRoomNo
部屋/アパート番号

strCountry

String strCountry
国コード

strLangu

String strLangu
言語キー

strRegion

String strRegion
地域 (都道府県)

strSort1

String strSort1
検索条件 1

strSort2

String strSort2
検索条件 2

strTimeZone

String strTimeZone
アドレスタイムゾーン

strTaxjurcode

String strTaxjurcode
税管轄コード

strAdrNotes

String strAdrNotes
住所注記

strCommType

String strCommType
通信方法 (キー) (アドレス管理)

strTel1Numbr

String strTel1Numbr
第一電話番号: ダイヤルコード + 番号

strTel1Ext

String strTel1Ext
第 1 電話番号: 内線

strFaxNumber

String strFaxNumber
第一 FAX 番号: ダイヤルコード + 番号

strFaxExtens

String strFaxExtens
第一 FAX 番号: 内線

strStreetLng

String strStreetLng
地名

strDistrctNo

String strDistrctNo
市区町村/地名ファイルの所在地コード

strChckstatus

String strChckstatus
市区町村ファイルテストステータス

strPboxcitNo

String strPboxcitNo
市区町村私書箱コード (市ファイル)

strTranspzone

String strTranspzone
商品の納入区域

strHouseNo2

String strHouseNo2
番地補足

strEMail

String strEMail
電子メールアドレス

strStrSuppl3

String strStrSuppl3
地名 4

strTitle

String strTitle
タイトル (敬称)

strCountryiso

String strCountryiso
ISO 国コード

strLanguIso

String strLanguIso
ISO 639 準拠の言語

strBuildLong

String strBuildLong
建物 (番号またはコード)

strRegiogroup

String strRegiogroup
地域構造グループ化

deIndex

int deIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.DistributionChannelSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strDistrChanLow

String strDistrChanLow
流通チャネルの範囲開始

strDistrChanHigh

String strDistrChanHigh
流通チャネルの範囲終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strTransportMode

String strTransportMode
貿易管理の輸送モード

strCustoms

String strCustoms
税関: 税関 (出国時)

クラス jp.co.intra_mart.foundation.sap.module.purchase.ExportItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strBusinessTransactionType

String strBusinessTransactionType
貿易管理の取引タイプ

strExportImportProcedure

String strExportImportProcedure
貿易の輸出入手続

strCountryori

String strCountryori
品目の原産国

strCountryoriIso

String strCountryoriIso
ISO 国コード

strRegionorig

String strRegionorig
品目の原産地 (非特恵対象地区の原産)

strCommCode

String strCommCode
貿易: 統計品目コード/輸入コード番号

strShippingCountry

String strShippingCountry
貿易: 出荷国

strShippingCountryIso

String strShippingCountryIso
ISO 国コード

eiIndex

int eiIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Extension は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strStructure

String strStructure
BAPI テーブル拡張の構造名

strValuepart1

String strValuepart1
BAPI 拡張パラメータのデータ部分

strValuepart2

String strValuepart2
BAPI 拡張パラメータのデータ部分

strValuepart3

String strValuepart3
BAPI 拡張パラメータのデータ部分

strValuepart4

String strValuepart4
BAPI 拡張パラメータのデータ部分

exIndex

int exIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtCreateController は GoodsMvtCreate を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.GoodsMvtGetItemsController は GoodsMvtGetItems を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.Limits は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPckgNo

String strPckgNo
パッケージ番号

strLimit

String strLimit
全体制限

strNoLimit

String strNoLimit
制限なし

strExpValue

String strExpValue
見込金額

strSscExist

String strSscExist
サービスタイプの制限

strConExist

String strConExist
基本契約明細の制限

strTmpExist

String strTmpExist
サービスパッケージの制限

strPriceChg

String strPriceChg
入力シートの価格変更

strFreeLimit

String strFreeLimit
自由制限

strNoFrlimit

String strNoFrlimit
制限なし

strServType

String strServType
サービスタイプのテキスト (短)

strEdition

String strEdition
サービスタイプのバージョン

strSscLimit

String strSscLimit
サービスタイプの金額制限

strSscNolim

String strSscNolim
標準サービスタイプの制限なし

strSscPrschg

String strSscPrschg
入力シートの価格変更

strSscPerc

String strSscPerc
価格決定率

strTmpNumber

String strTmpNumber
モデルサービス明細セット番号

strTmpLimit

String strTmpLimit
モデルサービス明細制限

strTmpNolim

String strTmpNolim
モデル仕様の制限なし

strTmpPrschg

String strTmpPrschg
入力シートの価格変更

strTmpPerc

String strTmpPerc
価格決定率

strContPerc

String strContPerc
価格決定率

liIndex

int liIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ManufacturerPartNumb は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strManuMat

String strManuMat
製造者製品コード

strMfrNo

String strMfrNo
製造者番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialAvailabilityController は MaterialAvailability を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetAllController は MaterialGetAll を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strMaxRows

String strMaxRows
選択予定品目の最大数

matnrSelectionList

ArrayList matnrSelectionList
品目コードの選択オプション一覧

materialShortDescselList

ArrayList materialShortDescselList
品目テキストの選択オプション一覧

manufacturerPartNumbList

ArrayList manufacturerPartNumbList
製造業者と製造者製品コード一覧

plantSelectionList

ArrayList plantSelectionList
プラントの選択オプション一覧

storageLocationselectList

ArrayList storageLocationselectList
保管場所の選択オプション一覧

salesOrganisationSelectionList

ArrayList salesOrganisationSelectionList
販売組織の選択オプション一覧

distributionChannelSelectionList

ArrayList distributionChannelSelectionList
流通チャネルの選択オプション一覧

matnrListList

ArrayList matnrListList
品目コードと品目テキスト一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialGetListController は MaterialGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialSaveReplicaController は MaterialSaveReplica を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.MaterialShortDescsel は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strDescrLow

String strDescrLow
開始品目テキスト

strDescrHigh

String strDescrHigh
品目テキスト

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrList は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strMaterial

String strMaterial
品目コード

strMatlDesc

String strMatlDesc
品目テキスト

strMaterialExternal

String strMaterialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

strMaterialGuid

String strMaterialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

strMaterialVersion

String strMaterialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.MatnrSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strMatnrLow

String strMatnrLow
開始品目コード

strMatnrHigh

String strMatnrHigh
終了品目コード

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamAllVersions は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamCondItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractLimits は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractService は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceAccount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamContractServiceText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamDeliveryAddress は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExportItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamExtension は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamHeaderText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamItemText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamLimits は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPartner は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamProfitSegment は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseAccount は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamPurchaseSchedule は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVendorAddress は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.ParamVersions は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.Partner は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPartnerdesc

String strPartnerdesc
言語別取引先機能テキスト

strLangu

String strLangu
言語キー

strBuspartno

String strBuspartno
取引先の仕入先マスタコード

paIndex

int paIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PlantSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strPlantLow

String strPlantLow
対象プラント 開始

strPlantHigh

String strPlantHigh
対象プラント 終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.ProfitSegment は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strFieldname

String strFieldname
項目名

strValue

String strValue
CO-PA 特性値

prIndex

int prIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseAccount は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSerialNo

String strSerialNo
勘定設定の連続番号

strDeleteInd

String strDeleteInd
削除フラグ: 購買伝票勘定設定

strCreatDate

String strCreatDate
レコード登録日

strQuantity

String strQuantity
数量

strDistrPerc

String strDistrPerc
配賦率 % (複数勘定設定)

strNetValue

String strNetValue
BAPI の通貨額 (小数点以下９桁)

strGlAccount

String strGlAccount
G/L 勘定コード

strBusArea

String strBusArea
事業領域

strCostcenter

String strCostcenter
原価センタ

strSdDoc

String strSdDoc
販売管理伝票番号

strItmNumber

String strItmNumber
販売伝票明細

strSchedLine

String strSchedLine
納入日程行

strAssetNo

String strAssetNo
資産番号

strSubNumber

String strSubNumber
資産補助番号

strOrderid

String strOrderid
指図番号

strGrRcpt

String strGrRcpt
受領者

strUnloadPt

String strUnloadPt
荷渡ポイント

strCoArea

String strCoArea
管理領域

strCostobject

String strCostobject
原価対象

strProfitCtr

String strProfitCtr
利益センタ

strWbsElement

String strWbsElement
WBS 要素

strNetwork

String strNetwork
勘定割当のネットワーク番号

strRlEstKey

String strRlEstKey
不動産管理対象の内部キー

strPartAcct

String strPartAcct
取引先勘定コード

strCmmtItem

String strCmmtItem
資金予算コード

strRecInd

String strRecInd
リカバリフラグ

strFundsCtr

String strFundsCtr
予算センタ

strFund

String strFund
会計区分

strFuncArea

String strFuncArea
機能領域

strRefDate

String strRefDate
決済の参照日付

strTaxCode

String strTaxCode
消費税コード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strNondItax

String strNondItax
BAPI の通貨額 (小数点以下９桁)

strActtype

String strActtype
活動タイプ

strCoBusproc

String strCoBusproc
業務プロセス

strResDoc

String strResDoc
用途指定予算の伝票番号

strResItem

String strResItem
用途指定予算: 伝票明細

strActivity

String strActivity
作業番号

strGrantNbr

String strGrantNbr
補助金

strCmmtItemLong

String strCmmtItemLong
資金予算コード

strFuncAreaLong

String strFuncAreaLong
機能領域

acIndex

int acIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrel は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strRelGroup

String strRelGroup
承認グループ

strRelCode

String strRelCode
承認コード

strItemsForRelease

String strItemsForRelease
区分: 承認待ち購買発注のみ照会

purchaseHeadersList

ArrayList purchaseHeadersList
ヘッダ一覧

purchaseItemsList

ArrayList purchaseItemsList
明細一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseGetItemSrelController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

purchaseGetItemSrel

PurchaseGetItemSrel purchaseGetItemSrel
購買承認対象一覧情報クラス

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strDocType

String strDocType
伝票タイプ

strDeleteInd

String strDeleteInd
削除フラグ

strStatus

String strStatus
ステータス

strCreatedBy

String strCreatedBy
登録者名

strItemIntvl

String strItemIntvl
明細番号間隔

strVendor

String strVendor
仕入先勘定コード

strPmnttrms

String strPmnttrms
支払条件キー

strDscnt1To

String strDscnt1To
現金割引日数1

strDscnt2To

String strDscnt2To
現金割引日数2

strDscnt3To

String strDscnt3To
現金割引日数3

strPurchOrg

String strPurchOrg
購買組織

strPurGroup

String strPurGroup
購買グループ

strCurrency

String strCurrency
通貨コード

strCurrencyIso

String strCurrencyIso
ISO通貨コード

strExchRate

String strExchRate
換算レート

strExRateFx

String strExRateFx
換算レート固定区分

strDocDate

String strDocDate
購買伝票日付

strVperStart

String strVperStart
有効期間開始日

strVperEnd

String strVperEnd
有効期間終了日

strWarranty

String strWarranty
保証日

strQuotation

String strQuotation
見積番号

strQuotDate

String strQuotDate
見積提出日

strRef1

String strRef1
得意先/仕入先の内部参照コード

strSalesPers

String strSalesPers
仕入先営業担当者

strTelephone

String strTelephone
仕入先電話番号

strSupplVend

String strSupplVend
供給仕入先

strCustomer

String strCustomer
得意先コード1

strAgreement

String strAgreement
購買契約番号

strGrMessage

String strGrMessage
入庫メッセージ区分

strSupplPlnt

String strSupplPlnt
在庫転送オーダーにおける供給(出庫)プラント

strIncoterms1

String strIncoterms1
インコタームズ1

strIncoterms2

String strIncoterms2
インコタームズ2

strDiffInv

String strDiffInv
仕入先と請求元が異なる場合の請求書元コード

strOurRef

String strOurRef
社内参照番号

strLogsystem

String strLogsystem
論理システム

strSubitemint

String strSubitemint
副明細の明細間隔

strRelStatus

String strRelStatus
承認状況

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaderPost は PurchaseHeader を拡張し、Serializable を実装しています

直列化されたフィールド

strCompCode

String strCompCode
会社コード

strCreatDate

String strCreatDate
レコード登録日

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
言語キーの ISO コード

strDsctPct1

String strDsctPct1
割引率 1

strDsctPct2

String strDsctPct2
割引率 2

strCollectNo

String strCollectNo
一括番号

strPoRelInd

String strPoRelInd
承認区分: 購買伝票

strVatCntry

String strVatCntry
売上税 ID 番号国

strVatCntryIso

String strVatCntryIso
消費税登録番号の ISO 国コード

strReasonCancel

String strReasonCancel
取消理由

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseHeaders は PurchaseHeader を拡張し、Serializable を実装しています

直列化されたフィールド

strCoCode

String strCoCode
会社コード

strDocCat

String strDocCat
購買伝票カテゴリ

strCntrlInd

String strCntrlInd
購買伝票タイプに対する管理区分

strCreatedOn

String strCreatedOn
レコード登録日

strLastItem

String strLastItem
最終明細番号

strLanguage

String strLanguage
言語キー

strCashDisc1

String strCashDisc1
割引率 1

strCashDisc2

String strCashDisc2
割引率 2

strApplicBy

String strApplicBy
見積提出期限

strQuotDead

String strQuotDead
見積提出期限

strBindgPer

String strBindgPer
見積有効期間

strBidinvNo

String strBidinvNo
見積管理番号

strRejReason

String strRejReason
見積および受注の拒否理由

strComplDlv

String strComplDlv
全購買発注に対する一括納入指定

strRcvgVend

String strRcvgVend
未使用項目

strTargetVal

String strTargetVal
累積計画金額

strCollNo

String strCollNo
一括番号

strDocCond

String strDocCond
伝票条件番号

strProcedure

String strProcedure
決定表 (価格設定/出力管理/勘定設定/原価計算など)

strUpdateGrp

String strUpdateGrp
統計更新の更新グループ

strExportNo

String strExportNo
貿易データ番号: MM/SD 伝票

strMastCond

String strMastCond
期間依存条件伝票

strRelGroup

String strRelGroup
承認グループ

strRelStrat

String strRelStrat
承認方針

strRelInd

String strRelInd
承認区分: 購買伝票

strSubjToR

String strSubjToR
承認未完了

strTaxrCntry

String strTaxrCntry
納税申告書の国

strSchedInd

String strSchedInd
分納契約のリリース伝票区分

strVendName

String strVendName
名称 1

strExchRateCm

String strExchRateCm
間接呼び値換算レート

strHold

String strHold
購買発注の不完全

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
明細番号

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

strShortText

String strShortText
品目コードテキスト（短）

strMaterial

String strMaterial
品目コード

strMaterialExternal

String strMaterialExternal
品目コード（長）

strMaterialGuid

String strMaterialGuid
品目コードの外部GUID

strMaterialVersion

String strMaterialVersion
品目コードのバージョン番号

strPlant

String strPlant
プラント

strTrackingno

String strTrackingno
購買依頼追跡番号

strInfoRec

String strInfoRec
購買情報番号

strVendMat

String strVendMat
仕入先が使用している品目コード

strPoUnitIso

String strPoUnitIso
ISOコードによる発注単位

strOrderprUn

String strOrderprUn
購買発注価格単位

strOrderprUnIso

String strOrderprUnIso
購買発注価格のISOコード

strConvNum1

String strConvNum1
購買価格単位から購買発注単位への変換分子

strConvDen1

String strConvDen1
購買価格単位から購買発注単位への変換分母

strNetPrice

String strNetPrice
通貨額

strPriceUnit

String strPriceUnit
価格単位

strTaxCode

String strTaxCode
消費税コード

strQualInsp

String strQualInsp
在庫タイプ

strValType

String strValType
評価タイプ

strNoMoreGr

String strNoMoreGr
納入完了区分

strItemCat

String strItemCat
購買伝票の明細カテゴリ

strAcctasscat

String strAcctasscat
勘定設定カテゴリ

strDistrib

String strDistrib
複数勘定設定の配賦区分

strPartInv

String strPartInv
一部請求区分

strAcknReqd

String strAcknReqd
購買発注請求書依頼

strAgreement

String strAgreement
購買契約番号

strAgmtItem

String strAgmtItem
購買契約の明細番号

strShipping

String strShipping
出荷指示

strPlanDel

String strPlanDel
予定納入日数

strKanbanInd

String strKanbanInd
かんばん区分

strRetItem

String strRetItem
返品明細

strAtRelev

String strAtRelev
適当テーブル関連

strPreqName

String strPreqName
購買依頼者名/要求者名

strPckgNo

String strPckgNo
パッケージ番号

strNoRounding

String strNoRounding
購買発注明細での非表示丸め

strPoPrice

String strPoPrice
価格採用区分

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItemPost は PurchaseItem を拡張し、Serializable を実装しています

直列化されたフィールド

strEmaterial

String strEmaterial
品目コード

strEmaterialExternal

String strEmaterialExternal
品目コード（長）

strEmaterialGuid

String strEmaterialGuid
品目コードの外部GUID

strEmaterialVersion

String strEmaterialVersion
品目コードのバージョン番号

strStgeLoc

String strStgeLoc
保管場所

strMatlGroup

String strMatlGroup
品目グループ

strQuantity

String strQuantity
購買発注数量

strPoUnit

String strPoUnit
発注単位

strGrPrTime

String strGrPrTime
入庫処理日数

strBonGrp1

String strBonGrp1
決済グループ1

strInfoUpd

String strInfoUpd
購買情報更新区分

strPrntPrice

String strPrntPrice
価格印刷

strEstPrice

String strEstPrice
概算価格区分

strReminder1

String strReminder1
第一回催促状/督促状の日数

strReminder2

String strReminder2
第二回催促状/督促状の日数

strReminder3

String strReminder3
第三回催促状/督促状の日数

strOverDlvTol

String strOverDlvTol
過剰納入許容範囲

strUnlimitedDlv

String strUnlimitedDlv
区分: 無制限過剰納入可能

strUnderDlvTol

String strUnderDlvTol
不足納入許容範囲リミット

strFinalInv

String strFinalInv
請求書処理完了区分

strGrInd

String strGrInd
入庫区分

strGrNonVal

String strGrNonVal
非評価入庫

strIrInd

String strIrInd
請求書受領区分

strFreeItem

String strFreeItem
無償明細

strGrBasediv

String strGrBasediv
入庫基準の請求書照合区分

strAcknowlNo

String strAcknowlNo
購買発注請書番号

strCustomer

String strCustomer
得意先コード

strCondGroup

String strCondGroup
仕入先条件グループ

strNoDisct

String strNoDisct
現金値引対象外明細

strNetWeight

String strNetWeight
正味重量

strWeightunit

String strWeightunit
重量単位

strWeightunitIso

String strWeightunitIso
重量単位のISOコード

strTaxjurcode

String strTaxjurcode
税計算管轄コード - 税管轄コード

strCtrlKey

String strCtrlKey
調達における品質管理の管理キー

strConfCtrl

String strConfCtrl
確認管理キー

strRevLev

String strRevLev
改訂レベル

strFund

String strFund
会計区分

strFundsCtr

String strFundsCtr
予算センタ

strCmmtItem

String strCmmtItem
資金予算コード

strPricedate

String strPricedate
価格設定日カテゴリ (価格設定日管理)

strPriceDate

String strPriceDate
価格設定日

strGrossWt

String strGrossWt
総重量

strVolume

String strVolume
容積

strVolumeunit

String strVolumeunit
容積単位

strVolumeunitIso

String strVolumeunitIso
ISO コードでの容積単位

strIncoterms1

String strIncoterms1
インコタームズ (1)

strIncoterms2

String strIncoterms2
インコタームズ 2

strPreVendor

String strPreVendor
製造元/販売元

strVendPart

String strVendPart
仕入先部門

strHlItem

String strHlItem
購買伝票中の上位明細

strGrToDate

String strGrToDate
納入最終期限

strSuppVendor

String strSuppVendor
供給仕入先/仕入入庫

strScVendor

String strScVendor
外注仕入先

strErs

String strErs
ERS（入庫/請求自動決済）

strRPromo

String strRPromo
プロモーション

strPoints

String strPoints
リベートポイント数

strPointUnit

String strPointUnit
ポイント単位

strPointUnitIso

String strPointUnitIso
ポイント単位の ISO コード

strSeason

String strSeason
季節カテゴリ

strSeasonYr

String strSeasonYr
シーズン年度

strBonGrp2

String strBonGrp2
決済グループ 2 (リベート決済、購買)

strBonGrp3

String strBonGrp3
決済グループ 3 (リベート決済、購買)

strSettItem

String strSettItem
リベート (期末) 決済対象の明細

strMinremlife

String strMinremlife
最低有効期間残

strRfqNo

String strRfqNo
見積依頼番号

strRfqItem

String strRfqItem
見積依頼明細番号

strPreqNo

String strPreqNo
購買依頼番号

strPreqItem

String strPreqItem
購買依頼の明細番号

strRefDoc

String strRefDoc
参照伝票番号

strRefItem

String strRefItem
参照伝票の明細

strSiCat

String strSiCat
補助明細カテゴリ、購買伝票

strOrderReason

String strOrderReason
発注理由

strBrasNbm

String strBrasNbm
Brazilian NCM Code

strMatlUsage

String strMatlUsage
品目の用途

strMatOrigin

String strMatOrigin
品目の原産地

strInHouse

String strInHouse
内部生産

strIndus3

String strIndus3
品目 CFOP カテゴリ

strInfIndex

String strInfIndex
インフレーション指数

strUntilDate

String strUntilDate
インフレーション指数日付

strDelivCompl

String strDelivCompl
出荷完了 区分

strPartDeliv

String strPartDeliv
明細レベルでの分割納入 (在庫転送)

strShipBlocked

String strShipBlocked
SD 出荷伝票の明細ブロック

strPeriodIndExpirationDate

String strPeriodIndExpirationDate
有効期間期限日の期間区分

strIntObjNo

String strIntObjNo
選定 (内部オブジェクト番号)

strBatch

String strBatch
ロット番号

strVendrbatch

String strVendrbatch
仕入先ロット番号

strCalctype

String strCalctype
価格設定タイプ

strGrantNbr

String strGrantNbr
補助金

strCmmtItemLong

String strCmmtItemLong
資金予算コード

strFuncAreaLong

String strFuncAreaLong
機能領域

strSupplStloc

String strSupplStloc
出庫保管場所: 在庫転送オーダー

glIndex

int glIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseItems は PurchaseItem を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strAddress

String strAddress
住所

strPurMat

String strPurMat
品目コード

strStoreLoc

String strStoreLoc
保管場所

strMatGrp

String strMatGrp
品目グループ

strAllocTbl

String strAllocTbl
商品配分表番号

strAtItem

String strAtItem
割当テーブルの明細番号

strUnit

String strUnit
発注単位

strPromotion

String strPromotion
プロモーション

strManufProf

String strManufProf
製造者製品プロファイル

strManuMat

String strManuMat
製造者製品コード

strMfrNo

String strMfrNo
製造者番号

strMfrNoExt

String strMfrNoExt
外部製造者コード名または番号

strItemCatExt

String strItemCatExt
購買伝票の明細カテゴリ

strDispQuan

String strDispQuan
購買発注数量: 表示目的全納入日程合計

strPurMatExternal

String strPurMatExternal
項目 PURMAT の品目コード (長) (今後のリリースで開発)

strPurMatGuid

String strPurMatGuid
項目 PURMAT の外部 GUID (今後のリリースで開発)

strPurMatVersion

String strPurMatVersion
項目 PURMAT のバージョン番号 (今後のリリースで開発)

strPrClosed

String strPrClosed
購買依頼処理済

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPost は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

poNumber

String poNumber
購買伝票番号

testRun

String testRun
テスト区分

memoryUnComplete

String memoryUnComplete
エラーがある場合に購買発注を保留する区分

memoryComplete

String memoryComplete
エラーがない場合に購買発注を保留する区分

noMessaging

String noMessaging
出力決定なし区分

noMessageReq

String noMessageReq
メッセージ不要区分

noAuthority

String noAuthority
権限チェックなし区分

noPriceFromPo

String noPriceFromPo
最終伝票からの価格転送なし区分

documentHeader

PurchaseHeaderPost documentHeader
伝票ヘッダ

supplierInfo

VendorAddress supplierInfo
仕入先住所

exportHeader

ExportHeader exportHeader
貿易管理ヘッダ

versions

Versions versions
バージョン管理

purchaseItemPostList

ArrayList purchaseItemPostList
明細一覧

deliveryAddressList

ArrayList deliveryAddressList
入荷伝票アドレス一覧

purchaseScheduleList

ArrayList purchaseScheduleList
納入日程一覧

purchaseAccountList

ArrayList purchaseAccountList
勘定設定一覧

profitSegmentList

ArrayList profitSegmentList
入出庫予定一覧

condHeaderList

ArrayList condHeaderList
条件ヘッダ一覧

condItemList

ArrayList condItemList
条件明細一覧

limitsList

ArrayList limitsList
外注制限一覧

contractLimitsList

ArrayList contractLimitsList
外注基本契約制限一覧

contractServiceList

ArrayList contractServiceList
外注サービス一覧

contractServiceAccountList

ArrayList contractServiceAccountList
外注サービス勘定設定一覧

contractServiceTextList

ArrayList contractServiceTextList
外注サービステキスト一覧

extensionList

ArrayList extensionList
拡張得意先項目一覧

exportItemList

ArrayList exportItemList
貿易管理明細一覧

headerTextList

ArrayList headerTextList
ヘッダテキスト一覧

itemTextList

ArrayList itemTextList
明細テキスト一覧

partnerList

ArrayList partnerList
取引先一覧

allVersionsList

ArrayList allVersionsList
全バージョン一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPayPostController は PurchaseOrderPayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseOrderPostChangeController は PurchaseOrderPayPost を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseRelease は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

strPurchaseorder

String strPurchaseorder
購買発注番号

strPoRelCode

String strPoRelCode
承認コード

strUseExceptions

String strUseExceptions
例外メッセージ設定とエラーメッセージ出力

strRelStatusNew

String strRelStatusNew
返却承認状況

strRelIndicatorNew

String strRelIndicatorNew
返却規承認区分

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseReleaseController は PurchaseRelease を拡張し、Serializable を実装しています

直列化されたフィールド

strRetCode

String strRetCode
リターン値、ABAP 命令後のリターン値

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseResetReleaseController は PurchaseRelease を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseSchedule は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoItem

String strPoItem
購買伝票の明細番号

strSchedLine

String strSchedLine
納入日程行

strDelDatcatExt

String strDelDatcatExt
納入期日カテゴリ

strDeliveryDate

String strDeliveryDate
納入期日

strQuantity

String strQuantity
計画数量

strDelivTime

String strDelivTime
納入期日における指定時間

strStatDate

String strStatDate
統計的納入期日

strPreqNo

String strPreqNo
購買依頼番号

strPreqItem

String strPreqItem
購買依頼の明細番号

strPoDate

String strPoDate
納入日程の購買発注日付

strRoutesched

String strRoutesched
輸送経路計画

strMsDate

String strMsDate
品目利用可能日

strMsTime

String strMsTime
品目供給ステージ (現地時刻: プラント参照)

strLoadDate

String strLoadDate
積載日付

strLoadTime

String strLoadTime
積載時刻 (現地時間: 出荷ポイント)

strTpDate

String strTpDate
輸送計画日付

strTpTime

String strTpTime
輸送計画 - 時間 (現地時間/出荷ポイント参照)

strGiDate

String strGiDate
出庫日付

strGiTime

String strGiTime
出庫時刻 (現地時間 - プラント参照)

strDeleteInd

String strDeleteInd
購買伝票の削除フラグ

scIndex

int scIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.PurchaseText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strPoItem

String strPoItem
購買伝票の明細番号

strTextId

String strTextId
テキスト ID

strTextForm

String strTextForm
タグ列

strTextLine

String strTextLine
テキスト行

teIndex

int teIndex
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.SalesOrganisationSelection は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strSalesorgLow

String strSalesorgLow
販売組織の範囲開始

strSalesorgHigh

String strSalesorgHigh
販売組織の範囲終了

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.Selection は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strSign

String strSign
選択演算子 SIGN (テーブル範囲)

strOption

String strOption
選択演算子 OPTION (範囲テーブル)

クラス jp.co.intra_mart.foundation.sap.module.purchase.StdMaterialGetIntNumberController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

stdIntNumList

StdMaterialGetIntNumberList stdIntNumList
品目コード割当済一覧

クラス jp.co.intra_mart.foundation.sap.module.purchase.StorageLocationSelect は Selection を拡張し、Serializable を実装しています

直列化されたフィールド

strStlocLow

String strStlocLow
開始保管場所

strStlocHigh

String strStlocHigh
終了保管場所

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
実行パラメータ(仕入先コード)

strCompode

String strCompode
実行パラメータ(会社コード)

generalDataInfo

GeneralDataInfo generalDataInfo
一般データ情報

companyDataInfo

CompanyDataInfo companyDataInfo
会社コード依存データ情報

bankDataInfoList

ArrayList bankDataInfoList
銀行データ情報

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheck は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
実行パラメータ(仕入先コード)

strCompCode

String strCompCode
実行パラメータ(会社コード)

checkReturn

String checkReturn
返却値

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierExistenceCheckController は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.SupplierGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

supplierDetail

SupplierDetail supplierDetail
仕入先マスタ詳細情報

クラス jp.co.intra_mart.foundation.sap.module.purchase.VendorAddress は GeneralDataInfo を拡張し、Serializable を実装しています

直列化されたフィールド

strPoNumber

String strPoNumber
購買伝票番号

strAddrNo

String strAddrNo
アドレス番号

strCOName

String strCOName
気付

strCityNo

String strCityNo
市区町村/地名ファイルの市区町村コード

strPostlCod1

String strPostlCod1
市区町村の郵便番号

strPostlCod2

String strPostlCod2
私書箱郵便番号

strPostlCod3

String strPostlCod3
会社郵便番号 (大規模なユーザ用)

strPoBoxCit

String strPoBoxCit
私書箱住所

strDelivDis

String strDelivDis
郵便配達地域

strStreetNo

String strStreetNo
市区町村/地名ファイルの地名コード

strStrAbbr

String strStrAbbr
地名の略称 (例: スペイン)

strHouseNo

String strHouseNo
番地-号

strStrSuppl1

String strStrSuppl1
地名 2

strStrSuppl2

String strStrSuppl2
地名 3

strLocation

String strLocation
地名 5

strBuilding

String strBuilding
旧: 建物 (番号または略称)

strFloor

String strFloor
建物の階

strRoomNo

String strRoomNo
部屋/アパート番号

strSort1

String strSort1
検索条件 1

strSort2

String strSort2
検索条件 2

strTimeZone

String strTimeZone
アドレスタイムゾーン

strTaxjurcode

String strTaxjurcode
税管轄コード

strAdrNotes

String strAdrNotes
住所注記

strCommType

String strCommType
通信方法 (キー) (アドレス管理)

strTel1Numbr

String strTel1Numbr
第一電話番号: ダイヤルコード + 番号

strTel1Ext

String strTel1Ext
第 1 電話番号: 内線

strFaxNumber

String strFaxNumber
第一 FAX 番号: ダイヤルコード + 番号

strFaxExtens

String strFaxExtens
第一 FAX 番号: 内線

strStreetLng

String strStreetLng
地名

strDistrctNo

String strDistrctNo
市区町村/地名ファイルの所在地コード

strChckstatus

String strChckstatus
市区町村ファイルテストステータス

strPboxcitNo

String strPboxcitNo
市区町村私書箱コード (市ファイル)

strTranspzone

String strTranspzone
商品の納入区域

strHouseNo2

String strHouseNo2
番地補足

strEMail

String strEMail
電子メールアドレス

strStrSuppl3

String strStrSuppl3
地名 4

strTitle

String strTitle
タイトル (敬称)

strBuildLong

String strBuildLong
建物 (番号またはコード)

strRegiogroup

String strRegiogroup
地域構造グループ化

クラス jp.co.intra_mart.foundation.sap.module.purchase.Versions は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strPostDate

String strPostDate
バージョンの転記日付

strCompleted

String strCompleted
ステータス "バージョン完了済"

strReason

String strReason
変更理由

strDescription

String strDescription
バージョンテキスト（長）

strReqBy

String strReqBy
変更を依頼した従業員

strReqByExt

String strReqByExt
バージョンの外部変更番号

strActivity

String strActivity
処理タイプ - R/3 Enterprise で使用不可能

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.common.model

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

indSector

String indSector
産業コード

matlType

String matlType
品目タイプ

createdOn

String createdOn
登録日付

createdBy

String createdBy
オブジェクト登録者名

lastChnge

String lastChnge
最終変更日付

changedBy

String changedBy
オブジェクトの変更者名

matStatus

String matStatus
品目更新完了ステータス

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
クライアントレベルでの品目削除フラグ

matlGroup

String matlGroup
品目グループ

oldMatNo

String oldMatNo
旧品目コード

baseUom

String baseUom
基本数量単位

baseUomIso

String baseUomIso
ISO コードでの基本数量単位

poUnit

String poUnit
発注単位

poUnitIso

String poUnitIso
ISO コードによる発注単位

document

String document
文書番号 (文書管理システムによらない)

docType

String docType
文書タイプ (文書管理システムによらない)

docVers

String docVers
文書バージョン (文書管理システムによらない)

docFormat

String docFormat
文書のページ書式 (文書管理システムによらない)

docChgNo

String docChgNo
文書変更番号 (文書管理システム外)

pageNo

String pageNo
文書ページ番号 (文書管理システムによらない)

noSheets

String noSheets
文書枚数 (文書管理システムによらない)

prodMemo

String prodMemo
製造/検査メモ

pageformat

String pageformat
製造メモのページ書式

sizeDim

String sizeDim
サイズ/寸法

basicMatl

String basicMatl
主構成物質

stdDescr

String stdDescr
標準テキスト (ANSI、ISO など)

dsnOffice

String dsnOffice
研究室/設計室

purValkey

String purValkey
購買許容値キー

netWeight

String netWeight
正味重量

unitOfWt

String unitOfWt
重量単位

unitOfWtIso

String unitOfWtIso
ISO コードでの重量単位

container

String container
容器条件

storConds

String storConds
保管条件

tempConds

String tempConds
温度条件区分

transGrp

String transGrp
輸送グループ

hazMatNo

String hazMatNo
危険物コード

division

String division
製品部門

competitor

String competitor
競合会社

qtyGrGi

String qtyGrGi
数量: 印刷予定入出庫票数

procRule

String procRule
調達規則

supSource

String supSource
供給元

season

String season
季節カテゴリ

labelType

String labelType
ラベルタイプ

labelForm

String labelForm
ラベル書式

prodHier

String prodHier
品目階層

cadId

String cadId
CAD 区分

allowedWt

String allowedWt
許容梱包重量

packWtUn

String packWtUn
重量単位 (許容梱包重量)

packWtUnIso

String packWtUnIso
ISO コードでの重量単位 (許容梱包重量)

allwdVol

String allwdVol
許容梱包容積

packVoUn

String packVoUn
容積単位 (許容梱包容積)

packVoUnIso

String packVoUnIso
ISO コードでの容積単位 (許容梱包容積)

wtTolLt

String wtTolLt
荷役単位の重量超過許容量

volTolLt

String volTolLt
荷役単位の容積超過許容量

varOrdUn

String varOrdUn
可変購買発注単位有効

configured

String configured
選定可能品目

batchMgmt

String batchMgmt
ロット管理所要量区分

shMatTyp

String shMatTyp
梱包材タイプ

fillLevel

String fillLevel
最大レベル (容積別)

stackFact

String stackFact
山積係数

matGrpSm

String matGrpSm
品目グループ: 梱包材

authoritygroup

String authoritygroup
権限グループ

qmProcmnt

String qmProcmnt
調達における品質管理有効

catprofile

String catprofile
カタログプロファイル

minremlife

String minremlife
最低有効期間残

shelfLife

String shelfLife
総有効期間

storPct

String storPct
残存有効期間割合 %

confMatl

String confMatl
プラント共通選定可能品目

coProduct

String coProduct
区分: 連産品としても使用可能な品目

prRefMat

String prRefMat
価格設定参照品目

purStatus

String purStatus
プラント共通品目ステータス

salStatus

String salStatus
流通チェーン間品目ステータス

pvalidfrom

String pvalidfrom
プラント共通品目のステータス有効開始日付

svalidfrom

String svalidfrom
流通チェーン間品目ステータスの有効開始日付

envtRlvt

String envtRlvt
区分: 環境関連

prodAlloc

String prodAlloc
製品割当決定手順

qualDik

String qualDik
無償納入による割引対象品目

manuMat

String manuMat
製造者製品コード

mfrNo

String mfrNo
製造者番号

invMatNo

String invMatNo
会社固有 (内部) 在庫管理品目コード

manufProf

String manufProf
製造者製品プロファイル

hazmatprof

String hazmatprof
危険物インジケータプロファイル

highVisc

String highVisc
区分: 高粘性

looseorliq

String looseorliq
区分: バルク/液体

closedBox

String closedBox
完了した梱包材

appdBRec

String appdBRec
区分: バッチ製造記録の承認必須

matcmpllvl

String matcmpllvl
品目完了レベル

parEff

String parEff
有効性パラメータへの値割当/変更番号よりも優先

roundUpRuleExpirationDate

String roundUpRuleExpirationDate
有効期間期限日計算の丸め規則

periodIndExpirationDate

String periodIndExpirationDate
有効期間期限日の期間区分

prodCompositionOnPackaging

String prodCompositionOnPackaging
区分: 梱包材にプリントされた生産構造

itemCat

String itemCat
一般明細カテゴリグループ

hazMatNoExternal

String hazMatNoExternal
項目 HAZ_MAT_NO の品目コード (長) (今後のリリースで開発)

hazMatNoGuid

String hazMatNoGuid
項目 HAZ_MAT_NO の外部 GUID (今後のリリースで開発)

hazMatNoVersion

String hazMatNoVersion
項目 HAZ_MAT_NO のバージョン番号 (今後のリリースで開発)

invMatNoExternal

String invMatNoExternal
項目 INV_MAT_NO の品目コード (長) (今後のリリースで開発)

invMatNoGuid

String invMatNoGuid
項目 INV_MAT_NO の外部 GUID (今後のリリースで開発)

invMatNoVersion

String invMatNoVersion
項目 INV_MAT_NO のバージョン番号 (今後のリリースで開発)

materialFixed

String materialFixed
ロックされている品目

cmRelevanceFlag

String cmRelevanceFlag
構成管理関連

sledBbd

String sledBbd
有効期限

gtinVariant

String gtinVariant
グローバルトレード明細番号バリアント

serializationLevel

String serializationLevel
シリアル番号の指定レベル

plRefMat

String plRefMat
梱包方法が同じ品目の参照品目

extmatlgrp

String extmatlgrp
外部品目グループ

uomusage

String uomusage
使用数量単位

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ClientDataList は ClientData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParameters は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

foreProf

String foreProf
需要予測プロファイル

modelSi

String modelSi
モデル選択区分

modelSp

String modelSp
モデル選択方式

paramOpt

String paramOpt
パラメータ最適化用の区分

optimLev

String optimLev
最適化レベル

initialize

String initialize
初期化区分

foreModel

String foreModel
予測モデル

alphaFact

String alphaFact
アルファ係数使用による基本値の平滑化

betaFact

String betaFact
ベータ係数による傾向値平準化

gammaFact

String gammaFact
ガンマ係数使用の平滑化のための季節指数

deltaFact

String deltaFact
デルタ係数使用による MAD (絶対平均偏差) 平準化

tracklimit

String tracklimit
警告限界

foreDate

String foreDate
最終需要予測日

histVals

String histVals
履歴値の数

initPds

String initPds
初期化で使用する履歴値の数

seasonPds

String seasonPds
季節周期ごとの期間数

expostPds

String expostPds
事後的需要予測に含む履歴値の数

forePds

String forePds
需要予測期間

fixedPds

String fixedPds
固定期間

basicValue

String basicValue
基準値

basicValue1

String basicValue1
第二指図の基準値

basicValue2

String basicValue2
第二指図の基準値

basicValuePp

String basicValuePp
前期間の基準値

basicValuePp1

String basicValuePp1
前期間における第二指図の基準値

basicValuePp2

String basicValuePp2
前期間における第二指図の基準値

trendValue

String trendValue
傾向値

trendValuePp

String trendValuePp
前期間の傾向値

meanAbsolDev

String meanAbsolDev
絶対平均偏差 (MAD)

meanAbsolDevPp

String meanAbsolDevPp
前期間の平均絶対偏差

errorTotal

String errorTotal
エラー合計

errorTotalPp

String errorTotalPp
前期間のエラー合計

wtgGroup

String wtgGroup
加重グループ

coeffTheil

String coeffTheil
タイル係数

exceptList

String exceptList
例外メッセージバー

forecFlowCont

String forecFlowCont
予測フロー管理

periodInd

String periodInd
期間区分

fyVariant

String fyVariant
会計年度バリアント

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ForecastParametersList は ForecastParameters を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeader は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docDate

String docDate
伝票の伝票日付

headerTxt

String headerTxt
伝票ヘッダテキスト

pstngDate

String pstngDate
伝票の転記日付

refDocNo

String refDocNo
参照伝票番号

refDocNoLong

String refDocNoLong
参照伝票番号 (依存性についてはテキスト長参照)

verGrGiSlip

String verGrGiSlip
入出庫票の印刷バ－ジョン

billOfLading

String billOfLading
入庫時に登録した B/L 番号

grGiSlipNo

String grGiSlipNo
入出庫票番号

prUname

String prUname
ユーザ名

verGrGiSlipx

String verGrGiSlipx
関連ユーザデータ項目の更新情報

extWms

String extWms
外部倉庫管理の転記の制御

billOfLadingLong

String billOfLadingLong
入庫の船荷証券番号 (依存: テキスト (長) 参照)

barCode

String barCode
バーコードエントリ

matDoc

String matDoc
入出庫伝票番号

docYear

String docYear
入出庫伝票年度

trEvType

String trEvType
トランザクション/イベントタイプ

entryDate

String entryDate
会計伝票登録日

entryTime

String entryTime
登録時刻

username

String username
ユーザ名

expimpNo

String expimpNo
貿易データ番号: MM/SD 伝票

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtHeaderList は GoodsMvtHeader を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.GoodsMvtItems は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activity

String activity
作業番号

acttype

String acttype
活動タイプ

amountLc

String amountLc
マニュアル入力による転記金額 (国内通貨)

amountSv

String amountSv
外部入力による販売金額 (国内通貨)

assetNo

String assetNo
資産番号

batch

String batch
ロット番号

calcMotive

String calcMotive
計算区分

cmmtItem

String cmmtItem
資金予算コード

cmmtItemLong

String cmmtItemLong
資金予算コード

coBusproc

String coBusproc
業務プロセス

compShip

String compShip
出荷指示順守

costObj

String costObj
原価対象

costcenter

String costcenter
原価センタ

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO 通貨コード

customer

String customer
得意先コード

docYear

String docYear
入出庫伝票年度

entryQnt

String entryQnt
入力単位での数量

entryUom

String entryUom
入力単位

entryUomIso

String entryUomIso
単位の ISO コード

expirydate

String expirydate
有効期間期限日

funcAreaLong

String funcAreaLong
機能領域

fund

String fund
会計区分

fundsCtr

String fundsCtr
予算センタ

grRcpt

String grRcpt
受領者

grantNbr

String grantNbr
補助金

itemText

String itemText
明細テキスト

lineDepth

String lineDepth
伝票での明細行階層レベル

lineId

String lineId
伝票明細行の一意 ID

matDoc

String matDoc
入出庫伝票番号

matdocItm

String matdocItm
入出庫伝票の明細

material

String material
品目コード

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

moveBatch

String moveBatch
入庫/出庫ロット

moveMat

String moveMat
入庫/出庫品目

moveMatExternal

String moveMatExternal
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

moveMatGuid

String moveMatGuid
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

moveMatVersion

String moveMatVersion
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

movePlant

String movePlant
入庫/出庫プラント

moveReas

String moveReas
移動理由

moveStloc

String moveStloc
入庫/出庫保管場所

moveType

String moveType
移動タイプ (在庫管理)

moveValType

String moveValType
転送ロットの評価タイプ

mvtInd

String mvtInd
移動区分

network

String network
勘定割当のネットワーク番号

noMoreGr

String noMoreGr
納入完了 区分

orderItno

String orderItno
指図明細番号

orderid

String orderid
指図番号

orderprUn

String orderprUn
購買発注価格単位 (購買管理)

orderprUnIso

String orderprUnIso
単位の ISO コード

parentId

String parentId
1 レベル上位の行 ID

partAcct

String partAcct
取引先勘定コード

plant

String plant
プラント

poItem

String poItem
購買伝票の明細番号

poNumber

String poNumber
購買発注番号

poPrQnt

String poPrQnt
数量 (購買発注価格単位)

prodDate

String prodDate
ロット製造日付

profitCtr

String profitCtr
利益センタ

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

refDate

String refDate
決済の参照日付

refDoc

String refDoc
参照伝票の伝票番号

refDocIt

String refDocIt
参照伝票の明細番号

refDocYr

String refDocYr
参照伝票の会計年度

resItem

String resItem
入出庫予定/従属所要量の明細番号

resType

String resType
レコードタイプ

reservNo

String reservNo
入出庫予定/従属所要量の番号

rlEstKey

String rlEstKey
不動産管理対象の内部キー

sOrdItem

String sOrdItem
受注明細番号

salesOrd

String salesOrd
受注伝票番号

schedLine

String schedLine
受注納入日程

shipping

String shipping
出荷指示

specStock

String specStock
特殊在庫区分

stckType

String stckType
在庫タイプ

stgeLoc

String stgeLoc
保管場所

subNumber

String subNumber
資産補助番号

supplVend

String supplVend
供給仕入先

unloadPt

String unloadPt
荷渡ポイント

valSOrdItem

String valSOrdItem
評価受注在庫の受注明細

valSalesOrd

String valSalesOrd
評価受注在庫の受注番号

valType

String valType
評価タイプ

valWbsElem

String valWbsElem
WBS 要素

vendor

String vendor
仕入先勘定コード

wbsElem

String wbsElem
WBS 要素

withdrawn

String withdrawn
入出庫予定に対する出庫完了

xAutoCre

String xAutoCre
自動登録済み明細

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.MaterialDescription は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

matlDesc

String matlDesc
品目テキスト

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeader は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtHeaderList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ParamGoodsMvtItems は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

plngMatl

String plngMatl
計画品目

plngPlant

String plngPlant
計画プラント

convfactor

String convfactor
計画品目用変換係数

plngMatlExternal

String plngMatlExternal
項目 PLNG_MATL の品目コード (長) (今後のリリースで開発)

plngMatlGuid

String plngMatlGuid
項目 PLNG_MATL の外部 GUID (今後のリリースで開発)

plngMatlVersion

String plngMatlVersion
項目 PLNG_MATL のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlanningDataList は PlanningData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
プラントレベルでの品目削除フラグ

abcId

String abcId
ABC 区分

critPart

String critPart
区分: 重要品目

purGroup

String purGroup
購買グループ

issueUnit

String issueUnit
出庫単位

issueUnitIso

String issueUnitIso
ISO コードでの出庫単位

mrpprofile

String mrpprofile
品目: MRP プロファイル

mrpType

String mrpType
MRP タイプ

mrpCtrler

String mrpCtrler
MRP 管理者

plndDelry

String plndDelry
予定納入時間 (単位: 日)

grPrTime

String grPrTime
入庫処理日数

periodInd

String periodInd
期間区分

assyScrap

String assyScrap
組立不良率

lotsizekey

String lotsizekey
ロットサイズ (品目計画)

procType

String procType
調達タイプ

spproctype

String spproctype
特殊調達タイプ

reorderPt

String reorderPt
発注点

safetyStk

String safetyStk
安全在庫

minlotsize

String minlotsize
最小ロットサイズ

maxlotsize

String maxlotsize
最大ロットサイズ

fixedLot

String fixedLot
固定ロットサイズ

roundVal

String roundVal
購買発注数量の丸め数量

maxStock

String maxStock
最大在庫レベル

ordCosts

String ordCosts
発注原価 (BAPI インタフェース)

depReqId

String depReqId
個別所要量と包括所要量に対する従属所要量区分

storCosts

String storCosts
保管経費区分

altBomId

String altBomId
代替 BOM 選択の方法

discontinu

String discontinu
打切区分

effODay

String effODay
有効終了日

followUp

String followUp
フォローアップ品目

grpReqmts

String grpReqmts
区分: 所要量グループ化

mixedMrp

String mixedMrp
二重 MRP 区分

smKey

String smKey
日程計画余裕キー

backflush

String backflush
区分: バックフラッシュ

productionScheduler

String productionScheduler
製造計画担当

procTime

String procTime
処理時間

setuptime

String setuptime
段取時間と片付け時間

interop

String interop
移動時間

baseQty

String baseQty
基本数量

inhseprodt

String inhseprodt
内製日数

stgeperiod

String stgeperiod
最長保管期間

stgePdUn

String stgePdUn
最長保管期間の単位

stgePdUnIso

String stgePdUnIso
ISO コードでの最長保管期間単位

overTol

String overTol
過剰納入許容範囲リミット

unlimited

String unlimited
区分: 無制限過剰納入可能

underTol

String underTol
不足納入許容範囲リミット

replentime

String replentime
補充リードタイム合計 (稼動日数)

replacePt

String replacePt
取替部品

indPostToInspStock

String indPostToInspStock
品質検査中在庫への転記

ctrlKey

String ctrlKey
調達における品質管理の管理キー

docReqd

String docReqd
文書必須フラグ

loadinggrp

String loadinggrp
積載グループ

batchMgmt

String batchMgmt
ロット管理所要量区分

quotausage

String quotausage
供給量割当の使用

servLevel

String servLevel
サービスレベル

splitInd

String splitInd
分割区分

availcheck

String availcheck
利用可能在庫確認の確認グループ

fyVariant

String fyVariant
会計年度バリアント

corrFact

String corrFact
区分: 修正係数を需要予測値計算に使用

setupTime

String setupTime
出荷準備時間

baseQtyPlan

String baseQtyPlan
出荷の能力計画のための基本数量

shipProcTime

String shipProcTime
出荷処理時間

supSource

String supSource
供給元

autoPOrd

String autoPOrd
区分: "購買発注自動生成"

sourcelist

String sourcelist
区分: 供給元一覧必須

commCode

String commCode
貿易: 統計品目コード/輸入コード番号

countryori

String countryori
品目の原産国

countryoriIso

String countryoriIso
ISO コードでの品目原産国

regionorig

String regionorig
品目の原産地 (非特恵対象地区の原産)

commCoUn

String commCoUn
物品コード (貿易) の数量単位

commCoUnIso

String commCoUnIso
ISO コードによる物品コード (貿易管理) の数量単位

expimpgrp

String expimpgrp
輸出/輸入品目グループ

profitCtr

String profitCtr
利益センタ

ppcPlCal

String ppcPlCal
PPC 計画カレンダ

repManuf

String repManuf
区分: 繰返生産許可

plTiFnce

String plTiFnce
計画タイムフェンス

consummode

String consummode
消費モード

bwdCons

String bwdCons
消費期間: 後方

fwdCons

String fwdCons
消費期間: 前方

versionFlag

String versionFlag
バージョン区分

alternativeBom

String alternativeBom
代替 BOM

bomUsage

String bomUsage
BOM 用途

planlistgrp

String planlistgrp
タスクリストグループのキー

planlistcnt

String planlistcnt
グループカウンタ

lotSize

String lotSize
原価計算ロットサイズ

specprocty

String specprocty
原価計算の特殊調達タイプ

prodUnit

String prodUnit
製造単位

prodUnitIso

String prodUnitIso
製造単位 (ISO コード)

issStLoc

String issStLoc
出庫保管場所

mrpGroup

String mrpGroup
MRP グループ

compScrap

String compScrap
構成品目不良率

certType

String certType
証明書タイプ

cycleTime

String cycleTime
タクトタイム

inspSetupFlag

String inspSetupFlag
品目/プラントに QM 検査データ設定

covprofile

String covprofile
在庫日数プロファイル

ccPhInv

String ccPhInv
循環棚卸の実地棚卸区分

varianceKey

String varianceKey
差異キー

sernoProf

String sernoProf
シリアル番号プロファイル

psConfMat

String psConfMat
選定可能品目

repmanprof

String repmanprof
繰返生産プロファイル

negStocks

String negStocks
プラントにおけるマイナス在庫許可

qmRgmts

String qmRgmts
仕入先の必須 QM システム

plngCycle

String plngCycle
計画サイクル

roundProf

String roundProf
丸めプロファイル

refmatcons

String refmatcons
消費参照品目

refpltcons

String refpltcons
消費参照プラント

dToRefM

String dToRefM
消費データ参照の有効終了日

multRefM

String multRefM
消費データ参照品目の乗数

autoReset

String autoReset
予測モデル自動リセット

prefStatFlag

String prefStatFlag
区分: 特恵関税 - 輸出/輸入

exCertId

String exCertId
法令管理: 認定書区分

exCertNoNew

String exCertNoNew
非該当証明書番号 - 法令管理

exCertDt

String exCertDt
非該当証明書発行日

declStatFlag

String declStatFlag
区分: 仕入先申告あり

militId

String militId
ID: 武器

inspInt

String inspInt
次回再検査までの間隔

coProduct

String coProduct
区分: 連産品としても使用可能な品目

planStrgp

String planStrgp
計画方針グループ

slocExprc

String slocExprc
外部調達の初期保管場所

bulkMat

String bulkMat
区分: バルク品目

ccFixed

String ccFixed
循環棚卸区分固定

determGrp

String determGrp
在庫決定グループ

qmAuthgrp

String qmAuthgrp
QM における活動の品目権限グループ

taskListType

String taskListType
タスクリストタイプ

purStatus

String purStatus
プラント特有品目ステータス

prodprof

String prodprof
製造計画プロファイル

saftyTId

String saftyTId
安全時間区分（安全リードタイムあり/なし)

safetytime

String safetytime
安全時間 (稼動日数)

plordCtrl

String plordCtrl
アクション管理: 計画手配処理

batchentry

String batchentry
製造/プロセス指図でのロット入力設定

pvalidfrom

String pvalidfrom
プラント品目ステータス有効期間開始日

matfrgtgrp

String matfrgtgrp
品目運賃グループ

prodverscs

String prodverscs
原価計算を行う製造バージョン

matCfop

String matCfop
品目 CFOP カテゴリ

euListNo

String euListNo
CAP: CAP 製品一覧番号

euMatGrp

String euMatGrp
EEC 農産物政策: CAP 生産品グループ - 貿易

casNo

String casNo
CAS 番号： 薬事品目 - 貿易

prodcomNo

String prodcomNo
生産統計: 貿易における PRODCOM コード

ctrlCode

String ctrlCode
貿易: 消費税の管理コード

jitRelvt

String jitRelvt
区分: JIT 納入日程の関連明細

matGrpTrans

String matGrpTrans
段取替えマトリクスに対する品目のグループ

handlgGrp

String handlgGrp
ワークロード計算のロジスティクス処理グループ

supplyArea

String supplyArea
品目マスタレコードで提案される供給場所

fairShareRule

String fairShareRule
均等配賦ルール

pushDistrib

String pushDistrib
区分: プッシュ配賦

deployHoriz

String deployHoriz
供給分配期間の日数

minLotSize

String minLotSize
需要と供給を一致させるための最小ロットサイズ

maxLotSize

String maxLotSize
需要と供給を一致させるための最大ロットサイズ

fixLotSize

String fixLotSize
需要供給の一致に対する固定ロットサイズ

lotIncrement

String lotIncrement
需要と供給を一致させるためのロットサイズ増分

prodConvType

String prodConvType
生産値の変換タイプ

distrProf

String distrProf
サイトの商品の物流プロファイル

periodProfileSafetyTime

String periodProfileSafetyTime
安全時間の期間プロファイル

fxdPrice

String fxdPrice
固定価格連産品

availCheckAllProjSegments

String availCheckAllProjSegments
プロジェクト間品目区分

overallprf

String overallprf
指図変更管理の全体プロファイル

mrpRelevancyDepRequirements

String mrpRelevancyDepRequirements
従属所要量と MRP の関連性

mrpAreaExists

String mrpAreaExists
区分: MRP エリア登録済

minSafetyStk

String minSafetyStk
最小安全在庫

noCosting

String noCosting
原価計算なし

unitGroup

String unitGroup
数量単位グループ

followUpExternal

String followUpExternal
項目 FOLLOW_UP の品目コード (長) (今後のリリースで開発)

followUpGuid

String followUpGuid
項目 FOLLOW_UP の外部 GUID (今後のリリースで開発)

followUpVersion

String followUpVersion
項目 FOLLOW_UP のバージョン番号 (今後のリリースで開発)

refmatconsExternal

String refmatconsExternal
項目 REFMATCONS の品目コード (長) (今後のリリースで開発)

refmatconsGuid

String refmatconsGuid
項目 REFMATCONS の外部 GUID (今後のリリースで開発)

refmatconsVersion

String refmatconsVersion
項目 REFMATCONS のバージョン番号 (今後のリリースで開発)

salesView

String salesView
販売ビュー

purchView

String purchView
購買管理ビュー

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

forecastView

String forecastView
需要予測ビュー

workSchedView

String workSchedView
作業計画ビュー

prtView

String prtView
生産資源/治工具 (PRT) ビュー

storageView

String storageView
保管ビュー

warehouseView

String warehouseView
倉庫管理ビュー

qualityView

String qualityView
品質管理ビュー

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

rotationDate

String rotationDate
原価計算ビュー

originalBatchFlag

String originalBatchFlag
元ロット管理区分

originalBatchRefMaterial

String originalBatchRefMaterial
元ロットの参照品目

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.PlantDataList は PlantData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

salesOrg

String salesOrg
販売組織

distrChan

String distrChan
流通チャネル

delFlag

String delFlag
区分: 流通チャネルレベルでの品目削除フラグ

matlStats

String matlStats
品目統計グループ

rebateGrp

String rebateGrp
取引量リベートグループ

commGroup

String commGroup
手数料グループ

cashDisc

String cashDisc
現金値引区分

salStatus

String salStatus
販売ビューからの品目ステータス

validFrom

String validFrom
流通チェーン別品目ステータスの有効期間開始日

minOrder

String minOrder
基本数量単位での最小受注数量

minDely

String minDely
納品書処理時の最小納入数量

minMto

String minMto
受注製造品最少受注数量

delyUnit

String delyUnit
出荷単位

delyUom

String delyUom
出荷数量単位

delyUomIso

String delyUomIso
ISO コードでの出荷単位の数量単位

salesUnit

String salesUnit
販売単位

salesUnitIso

String salesUnitIso
ISO コードによる販売単位

itemCat

String itemCat
品目マスタの明細カテゴリグループ

delygPlnt

String delygPlnt
出荷プラント

prodHier

String prodHier
品目階層

prRefMat

String prRefMat
価格設定参照品目

matPrGrp

String matPrGrp
品目価格設定グループ

acctAssgt

String acctAssgt
品目の勘定設定グループ

matlGrp1

String matlGrp1
品目グループ 1

matlGrp2

String matlGrp2
品目グループ 2

matlGrp3

String matlGrp3
品目グループ 3

matlGrp4

String matlGrp4
品目グループ 4

matlGrp5

String matlGrp5
品目グループ 5

prodAtt1

String prodAtt1
ID: 製品属性 1

prodAtt2

String prodAtt2
品目属性 2 用 ID

prodAtt3

String prodAtt3
品目属性 3 用 ID

prodAtt4

String prodAtt4
品目属性 4 用 ID

prodAtt5

String prodAtt5
品目属性 5 用 ID

prodAtt6

String prodAtt6
品目属性 6 の ID

prodAtt7

String prodAtt7
品目属性 7 用 ID

prodAtt8

String prodAtt8
品目属性 8 用 ID

prodAtt9

String prodAtt9
品目属性 9

prodAtt10

String prodAtt10
品目属性 10 用 ID

roundProf

String roundProf
丸めプロファイル

varSalesUn

String varSalesUn
可変販売単位の使用不可

unitGroup

String unitGroup
数量単位グループ

prRefMatExternal

String prRefMatExternal
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

prRefMatGuid

String prRefMatGuid
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

prRefMatVersion

String prRefMatVersion
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.SalesDataList は SalesData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

stgeLoc

String stgeLoc
保管場所

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
保管場所レベルでの品目削除フラグ

fiscYear

String fiscYear
当会計年度

currPeriod

String currPeriod
当期 (転記期間)

mrpInd

String mrpInd
保管場所 MRP 区分

specProc

String specProc
保管場所レベルでの特殊調達タイプ

reorderPt

String reorderPt
保管場所 MRP に対する発注点

replQty

String replQty
保管場所 MRP に対する補充数量

stgeBin

String stgeBin
棚番

pickgArea

String pickgArea
簡易倉庫管理のピッキングエリア

invCorrFac

String invCorrFac
在庫修正係数

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

storageView

String storageView
保管ビュー

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageLocationDataList は StorageLocationData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

whseNo

String whseNo
倉庫番号/複合倉庫

stgeType

String stgeType
保管域タイプ

delFlag

String delFlag
保管タイプに該当する全品目データ削除フラグ

stgeBin

String stgeBin
棚番

maxSbQty

String maxSbQty
最大棚番在庫数量

minSbQty

String minSbQty
最小棚番在庫数量

ctrlQty

String ctrlQty
管理数量

replenQty

String replenQty
補充数量

pickArea

String pickArea
ピッキングエリア

roundQty

String roundQty
丸め数量

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.StorageTypeDataList は StorageTypeData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.TaxClassifications は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

depcountry

String depcountry
出荷国 (商品発送国)

depcountryIso

String depcountryIso
出荷国の ISO コード

taxType1

String taxType1
税カテゴリ (消費税等)

taxclass1

String taxclass1
品目の税分類

taxType2

String taxType2
税カテゴリ (消費税等)

taxclass2

String taxclass2
品目の税分類

taxType3

String taxType3
税カテゴリ (消費税等)

taxclass3

String taxclass3
品目の税分類

taxType4

String taxType4
税カテゴリ (消費税等)

taxclass4

String taxclass4
品目の税分類

taxType5

String taxType5
税カテゴリ (消費税等)

taxclass5

String taxclass5
品目の税分類

taxType6

String taxType6
税カテゴリ (消費税等)

taxclass6

String taxclass6
品目の税分類

taxType7

String taxType7
税カテゴリ (消費税等)

taxclass7

String taxclass7
品目の税分類

taxType8

String taxType8
税カテゴリ (消費税等)

taxclass8

String taxclass8
品目の税分類

taxType9

String taxType9
税カテゴリ (消費税等)

taxclass9

String taxclass9
品目の税分類

taxInd

String taxInd
税区分: 品目 (購買管理)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.UnitSofmeasure は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

altUnit

String altUnit
在庫保管単位の代替数量単位

altUnitIso

String altUnitIso
ISO コードによる在庫単位の代替数量単位

numerator

String numerator
基本数量単位への換算分子

denominatr

String denominatr
分母: 基本数量単位へ変換する場合

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

length

String length
長さ

width

String width
幅

height

String height
高さ

unitDim

String unitDim
寸法単位 (長さ/幅/高さ)

unitDimIso

String unitDimIso
ISO コードでの長さ、幅、高さの単位

volume

String volume
容積

volumeunit

String volumeunit
容積単位

volumeunitIso

String volumeunitIso
ISO コードでの容積単位

grossWt

String grossWt
総重量

unitOfWt

String unitOfWt
重量単位

unitOfWtIso

String unitOfWtIso
ISO コードでの重量単位

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

subUom

String subUom
梱包階層の下位レベル数量単位

subUomIso

String subUomIso
下位レベル数量単位 (ISO コード)

internalChar

String internalChar
内部特性

uomsortnumber

String uomsortnumber
数量単位ソート番号

leadinguom

String leadinguom
主要ロット特定数量単位

valueduom

String valueduom
ロット特定数量単位での評価

charUnit

String charUnit
特性の数量単位

charUnitIso

String charUnitIso
下位レベル数量単位 (ISO コード)

gtinVariant

String gtinVariant
グローバルトレード明細番号バリアント

netWeight

String netWeight
正味重量

meAnzSub

String meAnzSub
下位レベル数量単位数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

valArea

String valArea
評価レベル

valType

String valType
評価タイプ

maintStat

String maintStat
更新ステータス

delFlag

String delFlag
評価タイプに該当する全品目データ削除フラグ

priceCtrl

String priceCtrl
原価管理区分

movingPr

String movingPr
移動平均原価/期間単位価格

stdPrice

String stdPrice
標準原価

priceUnit

String priceUnit
価格単位

valClass

String valClass
評価クラス

prCtrlPp

String prCtrlPp
前期間の原価管理区分

movPrPp

String movPrPp
前期移動平均原価/期間平均原価

stdPrPp

String stdPrPp
前期標準標準原価

prUnitPp

String prUnitPp
前期価格単位

vclassPp

String vclassPp
前期評価クラス

prCtrlPy

String prCtrlPy
前年度の原価管理区分

movPrPy

String movPrPy
前年度の移動平均原価/期間単価

stdPrPy

String stdPrPy
前年度標準原価

vclassPy

String vclassPy
前年度の評価クラス

prUnitPy

String prUnitPy
前年度価格単位

fiscYear

String fiscYear
当会計年度

currPeriod

String currPeriod
当期 (転記期間)

valCat

String valCat
評価カテゴリ

futurePr

String futurePr
次期標準原価

validFrom

String validFrom
原価有効開始日

taxprice1

String taxprice1
税法による評価額: レベル 1

commprice1

String commprice1
商法による評価額: レベル 1

taxprice3

String taxprice3
税法基準評価額: レベル 3

commprice3

String commprice3
商法基準評価額: レベル 3

plndPrice

String plndPrice
予定計画原価

plndprice1

String plndprice1
予定計画原価 1

plndprice2

String plndprice2
予定計画原価 2

plndprice3

String plndprice3
予定計画原価 3

plndprdate1

String plndprdate1
予定原価 1 の有効開始日

plndprdate2

String plndprdate2
予定原価 2 の有効開始日

plndprdate3

String plndprdate3
予定原価 3 の有効開始日

lifoFifo

String lifoFifo
LIFO/FIFO 関連

poolnumber

String poolnumber
LIFO 評価でのプール番号

taxprice2

String taxprice2
税法による評価額: レベル 2

commprice2

String commprice2
商法による評価額: レベル 2

devalInd

String devalInd
低価法: 評価減区分

origGroup

String origGroup
発生源グループ (原価要素の下位区分)

overheadGrp

String overheadGrp
原価計算間接費グループ

perFutCostEst

String perFutCostEst
将来標準原価見積期間

perCurCostEst

String perCurCostEst
現行標準原価見積期間

perPreCostEst

String perPreCostEst
前標準原価見積期間

fijFutCostEst

String fijFutCostEst
将来標準原価見積の会計年度

fijCurCostEst

String fijCurCostEst
当期標準原価見積の会計年度

fijPreCostEst

String fijPreCostEst
前期標準原価見積の会計年度

qtyStruct

String qtyStruct
数量構成により原価計算を行う品目

prevPlanPrice

String prevPlanPrice
税法基準評価額: レベル 2

mlActive

String mlActive
品目レベルで有効な品目元帳

mlSettle

String mlSettle
品目元帳決済: 管理

currPlanPrice

String currPlanPrice
税法基準評価額: レベル 2

origMat

String origMat
品目発生源

vmSoStk

String vmSoStk
受注在庫の評価クラス

vmPStock

String vmPStock
プロジェクト在庫の評価クラス

matlUsage

String matlUsage
品目の用途

matOrigin

String matOrigin
品目の原産地

inHouse

String inHouse
内部生産

taxCmlUn

String taxCmlUn
税法/商法にもとづく評価額価格単位

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.ValuationDataList は ValuationData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

whseNo

String whseNo
倉庫番号/複合倉庫

delFlag

String delFlag
WM 倉庫内の全品目データ削除フラグ

stgesector

String stgesector
保管区画区分

placement

String placement
在庫受入に対する保管域タイプ検索区分

withdrawal

String withdrawal
在庫払出に対する保管域タイプ区分

lEquip1

String lEquip1
積載装置数量 1

lEquip2

String lEquip2
積載装置数量 2

lEquip3

String lEquip3
積載装置数量 3

leqUnit1

String leqUnit1
積載装置数量 1 の数量単位

leqUnit1Iso

String leqUnit1Iso
ISO コードによる積載装置数量 1 の数量単位

leqUnit2

String leqUnit2
積載装置数量 2 の数量単位

leqUnit2Iso

String leqUnit2Iso
ISO コードによる積載装置数量 2 の数量単位

leqUnit3

String leqUnit3
積載装置数量 3 の数量単位

leqUnit3Iso

String leqUnit3Iso
ISO コードによる積載装置数量 3 の数量単位

unittype1

String unittype1
第１保管単位タイプ

unittype2

String unittype2
第２保管単位タイプ

unittype3

String unittype3
第３保管単位タイプ

wmUnit

String wmUnit
倉庫管理の数量単位

wmUnitIso

String wmUnitIso
ISO コードでの倉庫管理単位

addToStk

String addToStk
既存在庫への追加許可

blockStge

String blockStge
平置保管域区分

msgToIm

String msgToIm
区分: 在庫管理への出力

specMvmt

String specMvmt
倉庫管理の特殊移動区分

capyUsage

String capyUsage
保管容量使用

procureUn

String procureUn
保管容量消費の数量単位

procureUnIso

String procureUnIso
ISO コードでの保管容量消費の数量単位

stgeType

String stgeType
概略計画および詳細計画のピッキング保管域タイプ

refUnit

String refUnit
品目マスタレコードの数量単位初期値

twoStepPick

String twoStepPick
ツーステップピッキング適用品目

クラス jp.co.intra_mart.foundation.sap.module.purchase.common.model.WarehouseNumberDataList は WarehouseNumberData を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.exception

クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.exception.SAPPurchaseSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCode は Object を拡張し、Serializable を実装しています

直列化されたフィールド

gmCode

String gmCode
BAPI 在庫移動トランザクションのコード割当

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtCreate は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
在庫移動シミュレーション

matdocumentyear

String matdocumentyear
入出庫伝票会計年度

materialdocument

String materialdocument
入出庫伝票番号

goodsMvtCode

GoodsMvtCode goodsMvtCode
在庫移動に対するコードのトランザクションへの割当

goodsMvtHeader

GoodsMvtHeader goodsMvtHeader
入出庫伝票ヘッダデータ

goodsMvtHeadret

GoodsMvtHeadret goodsMvtHeadret
入出庫伝票番号/入出庫伝票会計年度

goodsMvtItemList

List goodsMvtItemList
入出庫伝票明細

goodsMvtSerialNumberList

List goodsMvtSerialNumberList
シリアル番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtHeadret は Object を拡張し、Serializable を実装しています

直列化されたフィールド

matDoc

String matDoc
入出庫伝票番号

docYear

String docYear
入出庫伝票年度

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtItem は Object を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

plant

String plant
プラント

stgeLoc

String stgeLoc
保管場所

batch

String batch
ロット番号

moveType

String moveType
移動タイプ (在庫管理)

stckType

String stckType
在庫タイプ

specStock

String specStock
特殊在庫区分

vendor

String vendor
仕入先勘定コード

customer

String customer
得意先コード

salesOrd

String salesOrd
受注伝票番号

sOrdItem

String sOrdItem
受注明細番号

schedLine

String schedLine
受注納入日程

valType

String valType
評価タイプ

entryQnt

String entryQnt
入力単位での数量

entryUom

String entryUom
入力単位

entryUomIso

String entryUomIso
単位の ISO コード

poPrQnt

String poPrQnt
数量 (購買発注価格単位)

orderprUn

String orderprUn
購買発注価格単位 (購買管理)

orderprUnIso

String orderprUnIso
単位の ISO コード

poNumber

String poNumber
購買発注番号

poItem

String poItem
購買伝票の明細番号

shipping

String shipping
出荷指示

compShip

String compShip
出荷指示順守

noMoreGr

String noMoreGr
納入完了 区分

itemText

String itemText
明細テキスト

grRcpt

String grRcpt
受領者

unloadPt

String unloadPt
荷渡ポイント

costcenter

String costcenter
原価センタ

orderid

String orderid
指図番号

orderItno

String orderItno
指図明細番号

calcMotive

String calcMotive
計算区分

assetNo

String assetNo
資産番号

subNumber

String subNumber
資産補助番号

reservNo

String reservNo
入出庫予定/従属所要量の番号

resItem

String resItem
入出庫予定/従属所要量の明細番号

resType

String resType
レコードタイプ

withdrawn

String withdrawn
入出庫予定に対する出庫完了

moveMat

String moveMat
入庫/出庫品目

movePlant

String movePlant
入庫/出庫プラント

moveStloc

String moveStloc
入庫/出庫保管場所

moveBatch

String moveBatch
入庫/出庫ロット

moveValType

String moveValType
転送ロットの評価タイプ

mvtInd

String mvtInd
移動区分

moveReas

String moveReas
移動理由

rlEstKey

String rlEstKey
不動産管理対象の内部キー

refDate

String refDate
決済の参照日付

costObj

String costObj
原価対象

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

profitCtr

String profitCtr
利益センタ

wbsElem

String wbsElem
WBS 要素

network

String network
勘定割当のネットワーク番号

activity

String activity
作業番号

partAcct

String partAcct
取引先勘定コード

amountLc

String amountLc
マニュアル入力による転記金額 (国内通貨)

amountSv

String amountSv
外部入力による販売金額 (国内通貨)

refDocYr

String refDocYr
参照伝票の会計年度

refDoc

String refDoc
参照伝票の伝票番号

refDocIt

String refDocIt
参照伝票の明細番号

expirydate

String expirydate
有効期間期限日

prodDate

String prodDate
ロット製造日付

fund

String fund
会計区分

fundsCtr

String fundsCtr
予算センタ

cmmtItem

String cmmtItem
資金予算コード

valSalesOrd

String valSalesOrd
評価受注在庫の受注番号

valSOrdItem

String valSOrdItem
評価受注在庫の受注明細

valWbsElem

String valWbsElem
WBS 要素

glAccount

String glAccount
G/L 勘定コード

indProposeQuanx

String indProposeQuanx
提案数量 (初期数量)

xstob

String xstob
取消移動タイプ区分の使用

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

delivNumbToSearch

String delivNumbToSearch
出荷伝票

delivItemToSearch

String delivItemToSearch
出荷明細

serialnoAutoNumberassignment

String serialnoAutoNumberassignment
シリアル番号の自動登録

vendrbatch

String vendrbatch
仕入先ロット番号

stgeType

String stgeType
保管域タイプ

stgeBin

String stgeBin
棚番

suPlStck1

String suPlStck1
在庫受入予定の保管単位数

stUnQtyy1

String stUnQtyy1
代替数量単位での在庫受入予定保管単位別数量

stUnQtyy1Iso

String stUnQtyy1Iso
単位の ISO コード

unittype1

String unittype1
保管単位タイプ

suPlStck2

String suPlStck2
在庫受入予定の保管単位数

stUnQtyy2

String stUnQtyy2
代替数量単位での在庫受入予定保管単位別数量

stUnQtyy2Iso

String stUnQtyy2Iso
単位の ISO コード

unittype2

String unittype2
保管単位タイプ

stgeTypePc

String stgeTypePc
在庫転送の保管域タイプ

stgeBinPc

String stgeBinPc
在庫転送棚番

noPstChgnt

String noPstChgnt
区分: 振替要求通知登録禁止

grNumber

String grNumber
入庫番号

stgeTypeSt

String stgeTypeSt
在庫転送の保管域タイプ

stgeBinSt

String stgeBinSt
在庫転送棚番

matdocTrCancel

String matdocTrCancel
取消予定の転送要求の入出庫伝票番号

matitemTrCancel

String matitemTrCancel
取消予定の転送数量入出庫伝票明細

matyearTrCancel

String matyearTrCancel
取消予定の転送要求入出庫伝票年度

noTransferReq

String noTransferReq
区分: 転送要求未登録

coBusproc

String coBusproc
業務プロセス

acttype

String acttype
活動タイプ

supplVend

String supplVend
供給仕入先

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

moveMatExternal

String moveMatExternal
項目 MOVE_MAT の品目コード (長) (今後のリリースで開発)

moveMatGuid

String moveMatGuid
項目 MOVE_MAT の外部 GUID (今後のリリースで開発)

moveMatVersion

String moveMatVersion
項目 MOVE_MAT のバージョン番号 (今後のリリースで開発)

funcArea

String funcArea
機能領域

trPartBa

String trPartBa
取引会社事業領域

parCompco

String parCompco
決済会社コード

delivNumb

String delivNumb
出荷伝票

delivItem

String delivItem
出荷明細

nbSlips

String nbSlips
入庫/出庫票の印刷部数

nbSlipsx

String nbSlipsx
関連ユーザデータ項目の更新情報

grRcptx

String grRcptx
関連ユーザデータ項目の更新情報

unloadPtx

String unloadPtx
関連ユーザデータ項目の更新情報

specMvmt

String specMvmt
倉庫管理の特殊移動区分

grantNbr

String grantNbr
補助金

cmmtItemLong

String cmmtItemLong
資金予算コード

funcAreaLong

String funcAreaLong
機能領域

lineId

String lineId
伝票明細行の一意 ID

parentId

String parentId
1 レベル上位の行 ID

lineDepth

String lineDepth
伝票での明細行階層レベル

quantity

String quantity
数量

baseUom

String baseUom
基本数量単位

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.GoodsMvtSerialNumber は Object を拡張し、Serializable を実装しています

直列化されたフィールド

matdocItm

String matdocItm
入出庫伝票の明細

serialno

String serialno
シリアル番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtCode は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtHeadret は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtItem は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtcreate.ParamGoodsMvtSerialNumber は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.BatchRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
ロット番号

high

String high
ロット番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.GoodsMvtGetItems は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

vendorRaList

List vendorRaList
仕入先の範囲

userNameRaList

List userNameRaList
ユーザ名の範囲

trEvTypeRaList

List trEvTypeRaList
トランザクション/イベントタイプの範囲

stgeLocRaList

List stgeLocRaList
保管場所の範囲

specStockRaList

List specStockRaList
特殊在庫区分の範囲

pstngDateRaList

List pstngDateRaList
登録日付の範囲

plantRaList

List plantRaList
プラントの範囲

moveTypeRaList

List moveTypeRaList
移動タイプの範囲

materialRaList

List materialRaList
品目コードの範囲

goodsMvtItemsList

List goodsMvtItemsList
リターン構造、入出庫伝票明細

goodsMvtHeaderList

List goodsMvtHeaderList
リターン構造、入出庫伝票ヘッダ

batchRaList

List batchRaList
ロットの範囲

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MaterialRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
品目コード

high

String high
品目コード

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.MoveTypeRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
移動タイプ (在庫管理)

high

String high
移動タイプ (在庫管理)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamBatchRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMaterialRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamMoveTypeRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPlantRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamPstngDateRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamSpecStockRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamStgeLocRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamTrEvTypeRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamUserNameRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.ParamVendorRa は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PlantRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
プラント

high

String high
プラント

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.PstngDateRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
伝票の転記日付

high

String high
伝票の転記日付

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.SpecStockRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
特殊在庫区分

high

String high
特殊在庫区分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.StgeLocRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
保管場所

high

String high
保管場所

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.TrEvTypeRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
トランザクション/イベントタイプ

high

String high
トランザクション/イベントタイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.UserNameRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
ユーザ名

high

String high
ユーザ名

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.goodsmvtgetitems.VendorRa は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

low

String low
仕入先勘定コード

high

String high
仕入先勘定コード

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialavailability

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.MaterialAvailability は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

wbsElem

String wbsElem
WBS 要素

unit

String unit
表示数量単位

stockInd

String stockInd
特殊在庫区分

stgeLoc

String stgeLoc
保管場所

plant

String plant
プラント

material

String material
品目コード

itmNumber

String itmNumber
明細番号

docNumber

String docNumber
伝票番号

decForRoundingX

String decForRoundingX
関連ユーザデータ項目の更新情報

decForRounding

String decForRounding
小数点位置 (その位置まで丸める)

customer

String customer
得意先コード

checkRule

String checkRule
確認規則

batch

String batch
ロット

endleadtme

String endleadtme
補充リードタイムの終了日付

dialogflag

String dialogflag
区分 (X = 利用不可 /N = 確認なし)

avQtyPlt

String avQtyPlt
プラントレベル利用可能数量

wmdvexList

List wmdvexList
出力テーブル (日付および ATP 数量)

wmdvsxList

List wmdvsxList
入力テーブル (日付/数量)

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvex は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.ParamWmdvsx は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvex は Object を拡張し、Serializable を実装しています

直列化されたフィールド

bdcnt

String bdcnt
5 文字数値 NUMC

reqDate

String reqDate
所要日付

reqQty

String reqQty
利用可能在庫確認の所要量

comDate

String comDate
確認日

comQty

String comQty
確認数量

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialavailability.Wmdvsx は Object を拡張し、Serializable を実装しています

直列化されたフィールド

reqDate

String reqDate
所要日付

reqQty

String reqQty
所要量

delkz

String delkz
MRP 要素区分

yline

String yline
内部テ－ブル処理の行索引

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialgetall

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ExtensionOut は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.InternationArticleNumbers は Object を拡張し、Serializable を実装しています

直列化されたフィールド

unit

String unit
表示数量単位

unitIso

String unitIso
ISO コードでの表示数量単位

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

mainEan

String mainEan
区分: 主要 EAN

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.LifoValuationData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

lifoValuationLevel

String lifoValuationLevel
LIFO 評価レベル

poolnumber

String poolnumber
LIFO 評価でのプール番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialGetAll は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

companycode

String companycode
会社コード

valuationarea

String valuationarea
評価レベル

valuationtype

String valuationtype
評価タイプ

plant

String plant
プラント

storagelocation

String storagelocation
保管場所

salesorganisation

String salesorganisation
販売組織

distributionchannel

String distributionchannel
流通チャネル

warehousenumber

String warehousenumber
倉庫番号/複合倉庫

storagetype

String storagetype
保管域タイプ

lifovaluationlevel

String lifovaluationlevel
LIFO 評価レベル

clientData

ClientData clientData
品目データ (クライアントレベル)

plantData

PlantData plantData
品目データ (プラントレベル)

forecastParameters

ForecastParameters forecastParameters
予測パラメータ

planningData

PlanningData planningData
品目マスタ/製品グループの変更伝票構造

storageLocationData

StorageLocationData storageLocationData
品目データ (保管場所レベル)

valuationData

ValuationData valuationData
評価データ

warehouseNumberData

WarehouseNumberData warehouseNumberData
倉庫番号データ

salesData

SalesData salesData
販売データ

storageTypeData

StorageTypeData storageTypeData
保管域タイプデータ

productionResourceToolData

ProductionResourceToolData productionResourceToolData
品目マスタの生産資源/治工具 (PRT) 項目

lifoValuationData

LifoValuationData lifoValuationData
LIFO 関連品目データ

materialDescriptionList

List materialDescriptionList
品目テキスト

unitSofmeasureList

List unitSofmeasureList
数量単位

internationArticleNumbersList

List internationArticleNumbersList
EAN

materialTextList

List materialTextList
テキスト (長)

taxClassificationsList

List taxClassificationsList
制御デ－タ

extensionOutList

List extensionOutList
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.MaterialText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

applobject

String applobject
テキスト: アプリケーションオブジェクト

textName

String textName
名称

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialgetall.ProductionResourceToolData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

plant

String plant
プラント

createLoadRecs

String createLoadRecs
区分: 生産資源/治工具の負荷レコード登録

ctrlKey

String ctrlKey
生産資源/治工具管理の管理キー

ctrlKeyNoChg

String ctrlKeyNoChg
管理キーは変更できません

grpKey1

String grpKey1
生産資源/治工具のグループキー 1

grpKey2

String grpKey2
生産資源/治工具のグループキー 2

prtUsage

String prtUsage
生産資源/治工具用途

stdTextKey

String stdTextKey
生産資源/治工具の標準テキストキー

refKeyNoChg

String refKeyNoChg
参照キーは変更できません

startRefDate

String startRefDate
生産資源/治工具使用開始の参照日付

stRefDateNoChg

String stRefDateNoChg
開始参照日付は変更できません

startOffset

String startOffset
生産資源/治工具使用の開始オフセット

startOffsetUnit

String startOffsetUnit
生産資源/治工具使用開始のオフセット単位

startOffsetUnitIso

String startOffsetUnitIso
PRT 用途開始決定の間隔時間単位 (ISO)

startOffsetNoChg

String startOffsetNoChg
開始オフセットは変更できません

endRefDate

String endRefDate
生産資源/治工具使用終了日の参照日付

endRefDateNoChg

String endRefDateNoChg
終了参照日付は変更できません

endOffset

String endOffset
生産資源/治工具用途の終了オフセット

endOffsetUnit

String endOffsetUnit
生産資源/治工具使用終了オフセット単位

endOffsetUnitIso

String endOffsetUnitIso
PRT 用途終了決定の間隔時間単位 (ISO)

endOffsetNoChg

String endOffsetNoChg
終了オフセットは変更できません

formulaTotQty

String formulaTotQty
生産資源/治工具の合計数量の計算式

formulaTotQtyNoChg

String formulaTotQtyNoChg
合計数量の計算式は変更できません

formulaTotUsage

String formulaTotUsage
生産資源/治工具の総用途値の計算式

formulaTotUsageNoChg

String formulaTotUsageNoChg
すべての用途値を計算する計算式は変更できません

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
長さ 229 の文字データのコンテナ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ExtensionInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
長さ 229 の文字データのコンテナ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ForecastValues は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

foreValue

String foreValue
予測値

corrValue

String corrValue
需要予測に対する修正値

seasIndex

String seasIndex
季節指数

cvalueFxd

String cvalueFxd
区分: 消費金額の確定

expostVal

String expostVal
事後的需要予測値

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.HeadData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

indSector

String indSector
産業コード

matlType

String matlType
品目タイプ

basicView

String basicView
基本データビュー

salesView

String salesView
販売ビュー

purchaseView

String purchaseView
購買管理ビュー

mrpView

String mrpView
資材所要量計画 (MRP) ビュー

forecastView

String forecastView
需要予測ビュー

workSchedView

String workSchedView
作業計画ビュー

prtView

String prtView
生産資源/治工具 (PRT) ビュー

storageView

String storageView
保管ビュー

warehouseView

String warehouseView
倉庫管理ビュー

qualityView

String qualityView
品質管理ビュー

accountView

String accountView
会計ビュー

costView

String costView
原価計算ビュー

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.InternationalArtnos は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

unit

String unit
表示数量単位

unitIso

String unitIso
ISO コードでの表示数量単位

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

eanCat

String eanCat
国際商品コード (EAN) のカテゴリ

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialLongText は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

applobject

String applobject
テキスト: アプリケーションオブジェクト

textName

String textName
名称

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

delFlag

String delFlag
データレコード削除 (テーブル繰返し)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.MaterialSaveReplica は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

nochangedoc

String nochangedoc
変更伝票書込なし

noappllog

String noappllog
アプリケーションログ書込なし

testrun

String testrun
書込 BAPI のシミュレーションセッションへの切替

inpfldcheck

String inpfldcheck
項目無効時の応答

flagCadCall

String flagCadCall
CAD システムからコール

headDataList

List headDataList
管理情報設定ヘッダセグメント

clientDataList

List clientDataList
品目データ (クライアントレベル)

plantDataList

List plantDataList
品目データ (プラントレベル)

forecastParametersList

List forecastParametersList
需要予測パラメータ

planningDataList

List planningDataList
品目マスタ/製品グループの変更伝票構造

storageLocationDataList

List storageLocationDataList
品目データ (保管場所レベル)

valuationDataList

List valuationDataList
評価データ

warehouseNumberDataList

List warehouseNumberDataList
倉庫番号データ

salesDataList

List salesDataList
販売データ

storageTypeDataList

List storageTypeDataList
保管域タイプデータ

materialDescriptionList

List materialDescriptionList
品目テキスト

unitSofmeasureList

List unitSofmeasureList
数量単位

internationalArtnosList

List internationalArtnosList
国際商品コード (EAN)

materialLongTextList

List materialLongTextList
テキスト (長)

taxClassificationsList

List taxClassificationsList
制御デ－タ

prtDataList

List prtDataList
品目マスタの生産資源/治工具 (PRT) 項目

extensionInList

List extensionInList
BAPI パラメータ EXTENSIONIN/EXTENSIONOUT の参照構造

extensionInXList

List extensionInXList
拡張イン/拡張アウトのチェックボックス構造

forecastValuesList

List forecastValuesList
需要予測値のデータ転送

unplndConsumptionList

List unplndConsumptionList
計画外消費のデータ転送

totalConsumptionList

List totalConsumptionList
品目総消費量のデータ転送

returnMessagesList

List returnMessagesList
リターンパラメータ BAPIRET2 の代替構造

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamClientDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamExtensionInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastParametersList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamForecastValues は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamHeadData は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamInternationalArtnos は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialDescription は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamMaterialLongText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlanningDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPlantDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamPrtData は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamReturnMessages は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamSalesDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageLocationDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamStorageTypeDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTaxClassifications は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamTotalConsumption は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnitSofmeasure は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamUnplndConsumption は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamValuationDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ParamWarehouseNumberDataList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.PrtData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

createLoadRecs

String createLoadRecs
区分: 生産資源/治工具の負荷レコード登録

ctrlKey

String ctrlKey
生産資源/治工具管理の管理キー

ctrlKeyNoChg

String ctrlKeyNoChg
管理キーは変更できません

grpKey1

String grpKey1
生産資源/治工具のグループキー 1

grpKey2

String grpKey2
生産資源/治工具のグループキー 2

prtUsage

String prtUsage
生産資源/治工具用途

stdTextKey

String stdTextKey
生産資源/治工具の標準テキストキー

refKeyNoChg

String refKeyNoChg
参照キーは変更できません

startRefDate

String startRefDate
生産資源/治工具使用開始の参照日付

stRefDateNoChg

String stRefDateNoChg
開始参照日付は変更できません

startOffset

String startOffset
生産資源/治工具使用の開始オフセット

startOffsetUnit

String startOffsetUnit
生産資源/治工具使用開始のオフセット単位

startOffsetUnitIso

String startOffsetUnitIso
PRT 用途開始決定の間隔時間単位 (ISO)

startOffsetNoChg

String startOffsetNoChg
開始オフセットは変更できません

endRefDate

String endRefDate
生産資源/治工具使用終了日の参照日付

endRefDateNoChg

String endRefDateNoChg
終了参照日付は変更できません

endOffset

String endOffset
生産資源/治工具用途の終了オフセット

endOffsetUnit

String endOffsetUnit
生産資源/治工具使用終了オフセット単位

endOffsetUnitIso

String endOffsetUnitIso
PRT 用途終了決定の間隔時間単位 (ISO)

endOffsetNoChg

String endOffsetNoChg
終了オフセットは変更できません

formulaTotQty

String formulaTotQty
生産資源/治工具の合計数量の計算式

formulaTotQtyNoChg

String formulaTotQtyNoChg
合計数量の計算式は変更できません

formulaTotUsage

String formulaTotUsage
生産資源/治工具の総用途値の計算式

formulaTotUsageNoChg

String formulaTotUsageNoChg
すべての用途値を計算する計算式は変更できません

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.ReturnMessages は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

id

String id
メッセージ、メッセージクラス

number

String number
メッセージ、メッセージ番号

message

String message
メッセージテキスト

logNo

String logNo
アプリケーションログ: ログ番号

logMsgNo

String logMsgNo
アプリケーションログ: メッセージシリアル番号

messageV1

String messageV1
メッセージ、メッセージ変数

messageV2

String messageV2
メッセージ、メッセージ変数

messageV3

String messageV3
メッセージ、メッセージ変数

messageV4

String messageV4
メッセージ、メッセージ変数

parameter

String parameter
パラメータ名

row

String row
パラメータの行

field

String field
パラメータの項目

system

String system
メッセージが発行された論理システム

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.TotalConsumption は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

consValue

String consValue
消費量

corrValue

String corrValue
修正消費量

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.materialsavereplica.UnplndConsumption は Object を拡張し、Serializable を実装しています

直列化されたフィールド

function

String function
BAPI 機能

material

String material
品目コード

plant

String plant
プラント

firstDay

String firstDay
値参照期間の第一日目

consValue

String consValue
消費量

corrValue

String corrValue
修正消費量

valRatio

String valRatio
元値に対する修正値の比率 (修正値: 元値)

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber

クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumber は Object を拡張し、Serializable を実装しています

直列化されたフィールド

material

String material
品目コード

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号

クラス jp.co.intra_mart.foundation.sap.module.purchase.stdmaterialgetintnumber.StdMaterialGetIntNumberList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

stdMaterialGetIntNumberList

List stdMaterialGetIntNumberList
品目コード割当済一覧

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

salesorg

String salesorg
販売組織

distrChan

String distrChan
流通チャネル

division

String division
製品部門

docType

String docType
販売伝票タイプ

ordbilltyp

String ordbilltyp
受注関連請求伝票に対する提案請求伝票タイプ

billDate

String billDate
請求索引および印刷に対する請求日

soldTo

String soldTo
受注先

itemCateg

String itemCateg
明細カテゴリ (販売伝票)

acctasgnmt

String acctasgnmt
品目の勘定設定グループ

priceDate

String priceDate
価格設定/外貨換算の実行日付

country

String country
出荷国 (商品発送国)

plant

String plant
プラント

billTo

String billTo
請求先

payer

String payer
支払人

shipTo

String shipTo
出荷先

refDoc

String refDoc
参照伝票番号

material

String material
品目コード

reqQty

String reqQty
累積受注数量 (販売単位)

currency

String currency
販売伝票通貨

shortText

String shortText
テキスト (短): 受注明細

taxcl1Mat

String taxcl1Mat
品目の税分類

refItem

String refItem
参照明細番号

statGroup

String statGroup
統計グループ

noMatmast

String noMatmast
品目マスタ確認禁止

addrNo

String addrNo
アドレス: アドレス番号

title

String title
敬称

name

String name
名称 1

name2

String name2
名称 2

postlCode

String postlCode
郵便番号

consumctry

String consumctry
消費者の国キー

city

String city
市区町村

district

String district
所在地

street

String street
地名/番地-号

region

String region
地域 (都道府県)

prodHier

String prodHier
品目階層

salesUnit

String salesUnit
販売単位

profitCtr

String profitCtr
利益センタ

taxjurcode

String taxjurcode
税計算管轄コード - 税管轄コード

purchOrd

String purchOrd
出荷先発注番号

docNumber

String docNumber
販売伝票

itmNumber

String itmNumber
販売伝票明細

origindoc

String origindoc
開始伝票

item

String item
開始明細

createdBy

String createdBy
オブジェクト登録者名

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ (2)

exchangeRate

String exchangeRate
価格設定/統計用換算レート

paymentTerms

String paymentTerms
支払条件キー

hgLvItem

String hgLvItem
BOM 構成の上位レベル明細

refDocCa

String refDocCa
先行販売管理伝票の伝票カテゴリ

orderid

String orderid
指図番号

profitSegmNo

String profitSegmNo
収益性セグメント番号 (CO-PA)

costcenter

String costcenter
原価センタ

wbsElem

String wbsElem
WBS 要素

taxDepartCty

String taxDepartCty
税出荷国

taxDestCty

String taxDestCty
税仕向国

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.BillingDocCreateMultiple は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
シミュレーション実行 ('X')、更新実行 (' ')

creatorDataIn

CreatorDataIn creatorDataIn
取り込まれる日付の順序

billingDataInList

List billingDataInList
処理予定明細データのテーブル

cCardDataInList

List cCardDataInList
処理予定支払方法のテーブル

conditionDataInList

List conditionDataInList
処理予定条件のテーブル

errorsList

List errorsList
前明細の不正処理に関する情報

successList

List successList
正常に処理された明細のテーブル

textDataInList

List textDataInList
請求インタフェースの通信構造テキスト

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CCardDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

paytype

String paytype
支払手段: 支払カード計画の明細分類

ccType

String ccType
支払カードタイプ: カードタイプ

ccNumber

String ccNumber
支払カード: カード番号

ccSeqNo

String ccSeqNo
支払カード: 支払カード - 接尾辞

ccValidF

String ccValidF
支払カード: 使用有効開始日付

ccValidT

String ccValidT
支払カード: 有効終了日

ccName

String ccName
支払カード: カード所有者の氏名

authamount

String authamount
支払カード: 承認額

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

authFlag

String authFlag
支払カード: 振替権限

authDate

String authDate
支払カード: 承認日

authTime

String authTime
支払カード: 承認時刻

ccAuthNo

String ccAuthNo
支払カード: 承認番号

authRefno

String authRefno
支払カード: 決済代行会社の権限参照コード

merchidcl

String merchidcl
支払カード: 決済代行会社のマーチャント ID

terminal

String terminal
支払カード: 端末

dataorigin

String dataorigin
支払カード: 入力モード

ccSettled

String ccSettled
支払カード: 決済終了

ccLocId

String ccLocId
支払カード: トランザクション (入庫時点)

billPlan

String billPlan
請求計画番号

billPlani

String billPlani
明細: 請求計画/支払計画/支払カード

billValue

String billValue
請求金額: 請求計画に請求日付が指定されている場合

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ConditionDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

dataIndex

String dataIndex
別の構成のテーブル入力へのポインタ

condType

String condType
条件タイプ

condValue

String condValue
条件金額/率

condCurr

String condCurr
条件通貨 (累積項目用)

condPUnt

String condPUnt
価格条件単位

condDUnt

String condDUnt
伝票の条件単位

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.CreatorDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

createdBy

String createdBy
オブジェクト登録者名

createdOn

String createdOn
レコード登録日

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.Errors は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refDocItem

String refDocItem
参照明細番号

type

String type
メッセージType: S 正常、E エラー、W 警告、I 通知、A 強制終了

id

String id
メッセージ、メッセージクラス

number

String number
メッセージ、メッセージ番号

message

String message
メッセージテキスト

logNo

String logNo
アプリケーションログ: ログ番号

logMsgNo

String logMsgNo
アプリケーションログ: メッセージシリアル番号

messageV1

String messageV1
メッセージ、メッセージ変数

messageV2

String messageV2
メッセージ、メッセージ変数

messageV3

String messageV3
メッセージ、メッセージ変数

messageV4

String messageV4
メッセージ、メッセージ変数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamBillingDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCCardDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamConditionDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamCreatorDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamErrors は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.ParamTextDataIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdoccreatemultiple.TextDataIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refItem

String refItem
参照明細番号

applobject

String applobject
テキスト: アプリケーションオブジェクト

textId

String textId
テキスト ID

langu

String langu
言語キー

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocCreateMultipleController は BillingDocCreateMultiple を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetDetailController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

billingDocGetDetail

BillingDocGetDetail billingDocGetDetail
請求伝票詳細照会情報クラス

クラス jp.co.intra_mart.foundation.sap.module.sales.BillingDocGetListController は BillingDocGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.InquiryCreateFromData2Controller は InquiryCreateFromData2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.QuotationCreateFromData2Controller は QuotationCreateFromData2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderCreateFromDat2Controller は SalesOrderCreateFromDat2 を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetListController は SalesOrderGetList を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.SalesOrderGetStatusController は SalesOrderGetStatus を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetdetail.BillingDocGetDetail は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

billingdocument

String billingdocument
処理予定の請求伝票数

billingDocumentDetail

BillingDocumentDetail billingDocumentDetail
請求伝票に関する詳細情報

パッケージ jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.BillingDocGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

refDocRange

RefDocRange refDocRange
前伝票の範囲

billingDocumentDetailListList

List billingDocumentDetailListList
後続請求伝票のテーブル

successList

List successList
後続請求伝票の明細テーブル

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.ParamRefDocRange は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.billingdocgetlist.RefDocRange は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sign

String sign
選択演算子 SIGN (テーブル範囲)

option

String option
選択演算子 OPTION (範囲テーブル)

refDocLow

String refDocLow
前伝票の開始伝票番号

refDocHigh

String refDocHigh
前伝票の終了伝票番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.common.model

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetail は Object を拡張し、Serializable を実装しています

直列化されたフィールド

billingdoc

String billingdoc
請求伝票

billType

String billType
請求タイプ

billcateg

String billcateg
請求カテゴリ

sdDocCat

String sdDocCat
販売管理伝票カテゴリ

currency

String currency
販売伝票通貨

currencyIso

String currencyIso
ISO 通貨コード

acctstatus

String acctstatus
会計への転記ステータス

netValue

String netValue
正味金額

taxValue

String taxValue
税額

cancelled

String cancelled
中止区分

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.BillingDocumentDetailList は BillingDocumentDetail を拡張し、Serializable を実装しています

直列化されたフィールド

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsBlob は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

context

String context
CU: 選定の BLOB (SCE)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsInst は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

objType

String objType
対象タイプ

classType

String classType
クラスタイプ

objKey

String objKey
対象キー

objTxt

String objTxt
言語依存対象テキスト

quantity

String quantity
インスタンス数量

author

String author
報告書提案済

quantityUnit

String quantityUnit
数量単位

complete

String complete
一般区分

consistent

String consistent
一般区分

objectGuid

String objectGuid
インスタンス用 TYPE_OF ステートメントの GUID

persistId

String persistId
インスタンス番号 (固定)

persistIdType

String persistIdType
インスタンス番号タイプ (固定)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsPartOf は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

parentId

String parentId
選定におけるインスタンス番号

instId

String instId
選定におけるインスタンス番号

partOfNo

String partOfNo
Part_of 明細番号

objType

String objType
対象タイプ

classType

String classType
クラスタイプ

objKey

String objKey
対象キー

author

String author
報告書提案済

salesRelevant

String salesRelevant
この部品は販売に関連しています

partOfGuid

String partOfGuid
インスタンス用 PART_OF ステートメントの GUID

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRef は Object を拡張し、Serializable を実装しています

直列化されたフィールド

posex

String posex
外部明細番号

configId

String configId
外部選定 ID (仮)

rootId

String rootId
選定におけるインスタンス番号

sce

String sce
CUX: 選定タイプ

kbname

String kbname
ナレッジベースオブジェクト

kbversion

String kbversion
SCE ナレッジベースの実行時バージョン

complete

String complete
一般区分

consistent

String consistent
一般区分

cfginfo

String cfginfo
CU: 選定の BLOB (SCE)

kbprofile

String kbprofile
ナレッジベースプロファイル

kblanguage

String kblanguage
システム設定の言語

cbaseId

String cbaseId
インスタンス番号 (固定)

cbaseIdType

String cbaseIdType
インスタンス番号タイプ (固定)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsRefInst は Object を拡張し、Serializable を実装しています

直列化されたフィールド

posex

String posex
外部明細番号

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsValue は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

charc

String charc
特性名

charcTxt

String charcTxt
言語依存特性テキスト

value

String value
特性値

valueTxt

String valueTxt
特性値の言語依存テキスト

author

String author
報告書提案済

valueTo

String valueTo
特性値

valcode

String valcode
値タイプ: 範囲制限 - 単一値

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.CfgsVk は Object を拡張し、Serializable を実装しています

直列化されたフィールド

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

vkey

String vkey
バリアント条件名

factor

String factor
バリアント条件の加重係数

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件カウンタ

condType

String condType
条件タイプ

condValue

String condValue
条件レート

currency

String currency
通貨コード

condUnit

String condUnit
条件単位

condPUnt

String condPUnt
価格条件単位

currIso

String currIso
ISO コード通貨

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

applicatio

String applicatio
アプリケーション

conpricdat

String conpricdat
条件価格設定日付

calctypcon

String calctypcon
条件計算タイプ

conbaseval

String conbaseval
条件基礎値

conexchrat

String conexchrat
現地通貨への換算レートに対する条件

numconvert

String numconvert
条件単位を基本単位へ変換する分子

denominato

String denominato
条件単位を基本単位へ変換する分母

condtype

String condtype
条件カテゴリ (例: 税、運賃、価格、原価)

statCon

String statCon
統計に適用する条件

scaletype

String scaletype
スケールタイプ

accruals

String accruals
見越額関連条件 (運賃など)

coninvolst

String coninvolst
請求書一覧条件

condorigin

String condorigin
条件生成区分

groupcond

String groupcond
グループ条件区分

condUpdat

String condUpdat
条件更新

accessSeq

String accessSeq
検索順序 - 検索番号

condcount

String condcount
条件連続番号

roundoffdi

String roundoffdi
BAPI の通貨額 (小数点以下９桁)

condvalue

String condvalue
条件金額

currency2

String currency2
販売伝票通貨

currIso2

String currIso2
ISO コード通貨

condcntrl

String condcntrl
条件管理

condisacti

String condisacti
無効条件

condclass

String condclass
条件クラス

factbasval

String factbasval
条件基礎値に対する要因

scalebasin

String scalebasin
スケール基準区分

scalbasval

String scalbasval
条件のスケール基準値

unitmeasur

String unitmeasur
条件スケール単位

isoUnit

String isoUnit
単位の ISO コード

currenckey

String currenckey
スケール通貨

curreniso

String curreniso
ISO コード通貨

condincomp

String condincomp
会社間請求の条件

condconfig

String condconfig
システム設定の条件

condchaman

String condchaman
条件 (マニュアル変更済)

condNo

String condNo
条件レコード番号

taxCode

String taxCode
消費税コード

varcond

String varcond
バリアント条件

accountkey

String accountkey
勘定キー

accountKe

String accountKe
勘定キー 見越/引当

wtWithcd

String wtWithcd
源泉徴収税コード

structcond

String structcond
構造条件

factconbas

String factconbas
条件基準の係数 (期間)

condcoinhd

String condcoinhd
条件カウンタ (ヘッダ条件)

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ConditionsInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件連続番号

condType

String condType
条件タイプ

updateflag

String updateflag
更新区分

condValue

String condValue
関連ユーザデータ項目の更新情報

currency

String currency
関連ユーザデータ項目の更新情報

condUnit

String condUnit
関連ユーザデータ項目の更新情報

condPUnt

String condPUnt
関連ユーザデータ項目の更新情報

varcond

String varcond
バリアント条件

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ExtensionIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

structure

String structure
BAPI テーブル拡張の構造名

valuepart1

String valuepart1
BAPI 拡張パラメータのデータ部分

valuepart2

String valuepart2
BAPI 拡張パラメータのデータ部分

valuepart3

String valuepart3
BAPI 拡張パラメータのデータ部分

valuepart4

String valuepart4
BAPI 拡張パラメータのデータ部分

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

refdoctype

String refdoctype
参照オブジェクトの伝票タイプ

docType

String docType
販売伝票タイプ

collectNo

String collectNo
一括番号

salesOrg

String salesOrg
販売組織

distrChan

String distrChan
流通チャネル

division

String division
製品部門

salesGrp

String salesGrp
営業グループ

salesOff

String salesOff
営業所

reqDateH

String reqDateH
指定納入期日

dateType

String dateType
提案日付タイプ

purchDate

String purchDate
得意先発注日付

poMethod

String poMethod
得意先発注タイプ

poSupplem

String poSupplem
得意先発注番号補足

ref1

String ref1
得意先/仕入先の内部参照コード

name

String name
発注者名称

telephone

String telephone
電話番号

priceGrp

String priceGrp
価格グループ (得意先)

custGroup

String custGroup
得意先グループ

salesDist

String salesDist
販売地域

priceList

String priceList
価格表タイプ

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ 2

pmnttrms

String pmnttrms
支払条件キー

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

billBlock

String billBlock
販売管理伝票の請求ブロック

ordReason

String ordReason
受注理由 (取引理由)

complDlv

String complDlv
一括納入区分

priceDate

String priceDate
価格設定/外貨換算の実行日付

qtValidF

String qtValidF
見積/引合有効開始日

qtValidT

String qtValidT
見積の有効終了日

ctValidF

String ctValidF
有効開始日付 (販売契約/品目提案)

ctValidT

String ctValidT
有効終了日付 (販売契約/品目提案)

custGrp1

String custGrp1
得意先グループ 1

custGrp2

String custGrp2
得意先グループ 2

custGrp3

String custGrp3
得意先グループ 3

custGrp4

String custGrp4
得意先グループ 4

custGrp5

String custGrp5
得意先グループ 5

purchNoC

String purchNoC
出荷先発注番号

purchNoS

String purchNoS
出荷先の得意先発注番号

poDatS

String poDatS
出荷先の出荷先発注日付

poMethS

String poMethS
出荷先の出荷先発注タイプ

ref1S

String ref1S
出荷先文字

sdDocCat

String sdDocCat
販売管理伝票カテゴリ

docDate

String docDate
伝票日付 (受信日/送信日)

warDate

String warDate
保証期間の開始日付

shipCond

String shipCond
出荷条件

ppSearch

String ppSearch
品目提案検索条件

dunCount

String dunCount
得意先商談回数

dunDate

String dunDate
得意先との前回の商談日

dlvschduse

String dlvschduse
用途区分

pldlvstyp

String pldlvstyp
MRP: 出荷計画タイプ

refDoc

String refDoc
参照伝票番号

compCdeB

String compCdeB
請求対象会社コード

alttaxCls

String alttaxCls
代替税分類

taxClass2

String taxClass2
得意先税分類 2

taxClass3

String taxClass3
得意先税分類 3

taxClass4

String taxClass4
得意先に対する税クラス 4

taxClass5

String taxClass5
得意先に対する税クラス 5

taxClass6

String taxClass6
得意先に対する税クラス 6

taxClass7

String taxClass7
得意先に対する税クラス 7

taxClass8

String taxClass8
得意先に対する税クラス 8

taxClass9

String taxClass9
得意先に対する税クラス 9

refDocL

String refDocL
参照伝票番号

assNumber

String assNumber
割当番号

refdocCat

String refdocCat
先行販売管理伝票の伝票カテゴリ

ordcombIn

String ordcombIn
受注結合出荷区分

billSched

String billSched
請求日程 (稼働日カレンダ指定)

invoSched

String invoSched
請求書一覧日程 (稼働日カレンダ指定)

mnInvoice

String mnInvoice
マニュアル請求書更新

exrateFi

String exrateFi
FI 転記の換算レート (直接相場)

addValDy

String addValDy
有効日からの日数

fixValDy

String fixValDy
有効日日付

pymtMeth

String pymtMeth
支払方法

accntAsgn

String accntAsgn
得意先の勘定設定グループ

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

billDate

String billDate
請求索引および印刷に対する請求日

servDate

String servDate
サービス提供日

dunnKey

String dunnKey
督促処理キー

dunnBlock

String dunnBlock
督促処理保留

pmtgarPro

String pmtgarPro
支払保証決定表

departmNo

String departmNo
部門コード

recPoint

String recPoint
入荷ポイント

docNumFi

String docNumFi
ドキュメンタリクレジット処理: 内部番号

cstcndgrp1

String cstcndgrp1
得意先条件グループ１

cstcndgrp2

String cstcndgrp2
得意先条件グループ２

cstcndgrp3

String cstcndgrp3
得意先条件グループ３

cstcndgrp4

String cstcndgrp4
得意先条件グループ４

cstcndgrp5

String cstcndgrp5
得意先条件グループ５

dlvTime

String dlvTime
契約出荷期間

currency

String currency
販売伝票通貨

currIso

String currIso
ISO コード通貨

createdBy

String createdBy
オブジェクト登録者名

taxdepCty

String taxdepCty
税出荷国

taxdstCty

String taxdstCty
税仕向国

eutriDeal

String eutriDeal
フラグ: EC 内三角取引

mastContr

String mastContr
グループマスタ契約番号

refProc

String refProc
参照限定条件: 決定区分

chkprtauth

String chkprtauth
取引先権限チェック

cmlqtyDat

String cmlqtyDat
累積出荷数量日付

version

String version
販売伝票バージョン番号

notifNo

String notifNo
通知番号

wbsElem

String wbsElem
WBS 要素

exchRateFiV

String exchRateFiV
FI 転記の換算レート (間接相場)

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

fkkConacct

String fkkConacct
長さ 12 の文字項目

campaign

String campaign
総括プロジェクト計画: 外部 R/3 システムの GUID

docClass

String docClass
リリースおよびトランザクション管理を備えた元システム

hCurr

String hCurr
通貨コード

hCurrIso

String hCurrIso
ISO 通貨コード

shipType

String shipType
出荷タイプ

sProcInd

String sProcInd
特別処理区分

refDocLLong

String refDocLLong
参照伝票番号 (依存関係についてはテキスト (長) を参照)

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.HeaderInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

updateflag

String updateflag
更新区分

docType

String docType
関連ユーザデータ項目の更新情報

collectNo

String collectNo
関連ユーザデータ項目の更新情報

salesOrg

String salesOrg
関連ユーザデータ項目の更新情報

distrChan

String distrChan
関連ユーザデータ項目の更新情報

division

String division
関連ユーザデータ項目の更新情報

salesGrp

String salesGrp
関連ユーザデータ項目の更新情報

salesOff

String salesOff
関連ユーザデータ項目の更新情報

reqDateH

String reqDateH
関連ユーザデータ項目の更新情報

dateType

String dateType
関連ユーザデータ項目の更新情報

purchDate

String purchDate
関連ユーザデータ項目の更新情報

poMethod

String poMethod
関連ユーザデータ項目の更新情報

poSupplem

String poSupplem
関連ユーザデータ項目の更新情報

ref1

String ref1
関連ユーザデータ項目の更新情報

name

String name
関連ユーザデータ項目の更新情報

telephone

String telephone
関連ユーザデータ項目の更新情報

priceGrp

String priceGrp
関連ユーザデータ項目の更新情報

custGroup

String custGroup
関連ユーザデータ項目の更新情報

salesDist

String salesDist
関連ユーザデータ項目の更新情報

priceList

String priceList
関連ユーザデータ項目の更新情報

incoterms1

String incoterms1
関連ユーザデータ項目の更新情報

incoterms2

String incoterms2
関連ユーザデータ項目の更新情報

pmnttrms

String pmnttrms
関連ユーザデータ項目の更新情報

dlvBlock

String dlvBlock
関連ユーザデータ項目の更新情報

billBlock

String billBlock
関連ユーザデータ項目の更新情報

ordReason

String ordReason
関連ユーザデータ項目の更新情報

complDlv

String complDlv
関連ユーザデータ項目の更新情報

priceDate

String priceDate
関連ユーザデータ項目の更新情報

qtValidF

String qtValidF
関連ユーザデータ項目の更新情報

qtValidT

String qtValidT
関連ユーザデータ項目の更新情報

ctValidF

String ctValidF
関連ユーザデータ項目の更新情報

ctValidT

String ctValidT
関連ユーザデータ項目の更新情報

custGrp1

String custGrp1
関連ユーザデータ項目の更新情報

custGrp2

String custGrp2
関連ユーザデータ項目の更新情報

custGrp3

String custGrp3
関連ユーザデータ項目の更新情報

custGrp4

String custGrp4
関連ユーザデータ項目の更新情報

custGrp5

String custGrp5
関連ユーザデータ項目の更新情報

purchNoC

String purchNoC
関連ユーザデータ項目の更新情報

purchNoS

String purchNoS
関連ユーザデータ項目の更新情報

poDatS

String poDatS
関連ユーザデータ項目の更新情報

poMethS

String poMethS
関連ユーザデータ項目の更新情報

ref1S

String ref1S
関連ユーザデータ項目の更新情報

sdDocCat

String sdDocCat
関連ユーザデータ項目の更新情報

docDate

String docDate
関連ユーザデータ項目の更新情報

warDate

String warDate
関連ユーザデータ項目の更新情報

shipCond

String shipCond
関連ユーザデータ項目の更新情報

ppSearch

String ppSearch
関連ユーザデータ項目の更新情報

dunCount

String dunCount
関連ユーザデータ項目の更新情報

dunDate

String dunDate
関連ユーザデータ項目の更新情報

dlvschduse

String dlvschduse
関連ユーザデータ項目の更新情報

pldlvstyp

String pldlvstyp
関連ユーザデータ項目の更新情報

refDoc

String refDoc
関連ユーザデータ項目の更新情報

compCdeB

String compCdeB
関連ユーザデータ項目の更新情報

alttaxCls

String alttaxCls
関連ユーザデータ項目の更新情報

taxClass2

String taxClass2
関連ユーザデータ項目の更新情報

taxClass3

String taxClass3
関連ユーザデータ項目の更新情報

taxClass4

String taxClass4
関連ユーザデータ項目の更新情報

taxClass5

String taxClass5
関連ユーザデータ項目の更新情報

taxClass6

String taxClass6
関連ユーザデータ項目の更新情報

taxClass7

String taxClass7
関連ユーザデータ項目の更新情報

taxClass8

String taxClass8
関連ユーザデータ項目の更新情報

taxClass9

String taxClass9
関連ユーザデータ項目の更新情報

refDocL

String refDocL
関連ユーザデータ項目の更新情報

assNumber

String assNumber
関連ユーザデータ項目の更新情報

refdocCat

String refdocCat
関連ユーザデータ項目の更新情報

ordcombIn

String ordcombIn
関連ユーザデータ項目の更新情報

billSched

String billSched
関連ユーザデータ項目の更新情報

invoSched

String invoSched
関連ユーザデータ項目の更新情報

mnInvoice

String mnInvoice
関連ユーザデータ項目の更新情報

exrateFi

String exrateFi
関連ユーザデータ項目の更新情報

addValDy

String addValDy
関連ユーザデータ項目の更新情報

fixValDy

String fixValDy
関連ユーザデータ項目の更新情報

pymtMeth

String pymtMeth
関連ユーザデータ項目の更新情報

accntAsgn

String accntAsgn
関連ユーザデータ項目の更新情報

exchgRate

String exchgRate
関連ユーザデータ項目の更新情報

billDate

String billDate
関連ユーザデータ項目の更新情報

servDate

String servDate
関連ユーザデータ項目の更新情報

dunnKey

String dunnKey
関連ユーザデータ項目の更新情報

dunnBlock

String dunnBlock
関連ユーザデータ項目の更新情報

promotion

String promotion
関連ユーザデータ項目の更新情報

pmtgarPro

String pmtgarPro
関連ユーザデータ項目の更新情報

departmNo

String departmNo
関連ユーザデータ項目の更新情報

recPoint

String recPoint
関連ユーザデータ項目の更新情報

poitmNoS

String poitmNoS
関連ユーザデータ項目の更新情報

docNumFi

String docNumFi
関連ユーザデータ項目の更新情報

cstcndgrp1

String cstcndgrp1
関連ユーザデータ項目の更新情報

cstcndgrp2

String cstcndgrp2
関連ユーザデータ項目の更新情報

cstcndgrp3

String cstcndgrp3
関連ユーザデータ項目の更新情報

cstcndgrp4

String cstcndgrp4
関連ユーザデータ項目の更新情報

cstcndgrp5

String cstcndgrp5
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

currency

String currency
関連ユーザデータ項目の更新情報

taxdepCty

String taxdepCty
関連ユーザデータ項目の更新情報

taxdstCty

String taxdstCty
関連ユーザデータ項目の更新情報

eutriDeal

String eutriDeal
関連ユーザデータ項目の更新情報

mastContr

String mastContr
関連ユーザデータ項目の更新情報

refProc

String refProc
関連ユーザデータ項目の更新情報

chkprtauth

String chkprtauth
関連ユーザデータ項目の更新情報

cmlqtyDat

String cmlqtyDat
関連ユーザデータ項目の更新情報

version

String version
関連ユーザデータ項目の更新情報

notifNo

String notifNo
関連ユーザデータ項目の更新情報

wbsElem

String wbsElem
関連ユーザデータ項目の更新情報

exchRateFiV

String exchRateFiV
関連ユーザデータ項目の更新情報

exchgRateV

String exchgRateV
関連ユーザデータ項目の更新情報

fkkConacct

String fkkConacct
関連ユーザデータ項目の更新情報

campaign

String campaign
関連ユーザデータ項目の更新情報

docClass

String docClass
関連ユーザデータ項目の更新情報

hCurr

String hCurr
関連ユーザデータ項目の更新情報

shipType

String shipType
関連ユーザデータ項目の更新情報

sProcInd

String sProcInd
関連ユーザデータ項目の更新情報

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

hgLvItem

String hgLvItem
上位レベル明細

poItmNo

String poItmNo
元となる購買発注の明細番号

material

String material
品目コード

altToItm

String altToItm
代替明細

custMat22

String custMat22
得意先品目コード (無効)

batch

String batch
ロット番号

dlvGroup

String dlvGroup
出荷グループ (明細一括出荷)

partDlv

String partDlv
明細レベルの分納納入

reasonRej

String reasonRej
見積および受注の拒否理由

billBlock

String billBlock
ブロック

billDate

String billDate
請求索引および印刷に対する請求日

plant

String plant
プラント

storeLoc

String storeLoc
保管場所

targetQty

String targetQty
目標数量（販売単位）

targetQu

String targetQu
目標数量 (数量単位)

tUnitIso

String tUnitIso
目標数量単位 (ISO コード)

itemCateg

String itemCateg
明細カテゴリ (販売伝票)

shortText

String shortText
テキスト (短): 受注明細

prcGroup1

String prcGroup1
品目グループ 1

prcGroup2

String prcGroup2
品目グループ 2

prcGroup3

String prcGroup3
品目グループ 3

prcGroup4

String prcGroup4
品目グループ 4

prcGroup5

String prcGroup5
品目グループ 5

prodHiera

String prodHiera
品目階層

matlGroup

String matlGroup
品目グループ

purchNoC

String purchNoC
出荷先発注番号

purchDate

String purchDate
得意先発注日付

poMethod

String poMethod
得意先発注タイプ

ref1

String ref1
得意先/仕入先の内部参照コード

purchNoS

String purchNoS
出荷先の得意先発注番号

poDatS

String poDatS
出荷先の出荷先発注日付

poMethS

String poMethS
出荷先の出荷先発注タイプ

ref1S

String ref1S
出荷先文字

poitmNoS

String poitmNoS
元となる購買発注の明細番号

priceGrp

String priceGrp
価格グループ (得意先)

custGroup

String custGroup
得意先グループ

salesDist

String salesDist
販売地域

priceList

String priceList
価格表タイプ

incoterms1

String incoterms1
インコタームズ (1)

incoterms2

String incoterms2
インコタームズ 2

ordcompIn

String ordcompIn
受注結合出荷区分

billSched

String billSched
請求日程 (稼働日カレンダ指定)

invoSched

String invoSched
請求書一覧日程 (稼働日カレンダ指定)

mnInvoice

String mnInvoice
マニュアル請求書更新

exRateFi

String exRateFi
FI 転記の換算レート (直接相場)

addValDy

String addValDy
有効日からの日数

fixValDy

String fixValDy
有効日日付

pmnttrms

String pmnttrms
支払条件キー

pymtMeth

String pymtMeth
支払方法

accntAsgn

String accntAsgn
得意先の勘定設定グループ

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

priceDate

String priceDate
価格設定/外貨換算の実行日付

servDate

String servDate
サービス提供日

dunnKey

String dunnKey
督促処理キー

dunnBlock

String dunnBlock
督促処理保留

promotion

String promotion
プロモーション

pmtgarPro

String pmtgarPro
支払保証決定表

docNumFi

String docNumFi
ドキュメンタリクレジット処理: 内部番号

departmNo

String departmNo
部門コード

recPoint

String recPoint
入荷ポイント

cstcndgrp1

String cstcndgrp1
得意先条件グループ１

cstcndgrp2

String cstcndgrp2
得意先条件グループ２

cstcndgrp3

String cstcndgrp3
得意先条件グループ３

cstcndgrp4

String cstcndgrp4
得意先条件グループ４

cstcndgrp5

String cstcndgrp5
得意先条件グループ５

dlvTime

String dlvTime
契約出荷期間

salesUnit

String salesUnit
販売単位

sUnitIso

String sUnitIso
単位の ISO コード

trgQtyNo

String trgQtyNo
販売単位から基本単位への換算係数

trgqtyDen

String trgqtyDen
販売単位から基本単位への換算係数

rnddlvQty

String rnddlvQty
丸め数量: 出荷

maxdevamnt

String maxdevamnt
数量に関する許容偏差 (絶対値)

maxdevper

String maxdevper
数量に関する許容偏差 (%)

maxdevDay

String maxdevDay
シフト所要日数

usageInd

String usageInd
未使用 - 予約長 3

fixedQuan

String fixedQuan
数量固定区分

unlmtDlv

String unlmtDlv
区分: 無制限過剰納入可能

overdlvtol

String overdlvtol
過剰納入許容範囲

unddlvTol

String unddlvTol
不足納入許容範囲リミット

division

String division
製品部門

salqtynum

String salqtynum
販売数量単位から基本数量単位への変換係数の分子

salqtyden

String salqtyden
販売数量単位を SKU に換算するための分母 (除数)

grossWght

String grossWght
明細の総重量

netWeight

String netWeight
明細の正味重量

untofWght

String untofWght
重量単位

unofWtiso

String unofWtiso
ISO コードでの重量単位

volume

String volume
明細の総数量

volunit

String volunit
容積単位

volunitiso

String volunitiso
ISO コードでの容積単位

dlvPrio

String dlvPrio
出荷優先順位

shipPoint

String shipPoint
出荷ポイント/入荷ポイント

route

String route
輸送経路

createdBy

String createdBy
オブジェクト登録者名

taxClass1

String taxClass1
品目の税分類

taxClass2

String taxClass2
品目の税分類

taxClass3

String taxClass3
品目の税分類

taxClass4

String taxClass4
品目の税分類

taxClass5

String taxClass5
品目の税分類

taxClass6

String taxClass6
品目の税分類

taxClass7

String taxClass7
品目の税分類

taxClass8

String taxClass8
品目の税分類

taxClass9

String taxClass9
品目の税分類

matPrGrp

String matPrGrp
品目価格設定グループ

valType

String valType
評価タイプ

fixdatQty

String fixdatQty
納期と出荷数量の固定

bomexplNo

String bomexplNo
BOM 展開番号

resanalkey

String resanalkey
結果分析キー

reqmtsTyp

String reqmtsTyp
所要量タイプ

noGrPost

String noGrPost
得意先が入庫を転記していません

busTranst

String busTranst
貿易管理の取引タイプ

overhdKey

String overhdKey
間接費キー

cstgSheet

String cstgSheet
原価計算表

matfrgtgrp

String matfrgtgrp
品目運賃グループ

pldlvshdin

String pldlvshdin
出荷計画に関する指示

seqNo

String seqNo
KANBAN/連続番号

bilForm

String bilForm
請求書式

dliProfil

String dliProfil
動的明細プロセッサプロファイル

revType

String revType
収益承認カテゴリ

begdemPer

String begdemPer
見越期間の提案開始日付

prRefMat

String prRefMat
価格設定参照品目

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

orderProb

String orderProb
明細の受注可能性

maxPlDlv

String maxPlDlv
明細ごとの分割納入可能な最大回数

cfopCode

String cfopCode
CFOP code and extension (old 5 char version)

taxlawicms

String taxlawicms
税法: ICMS

taxlawipi

String taxlawipi
税法: IPI

sdTaxcode

String sdTaxcode
0

assortMod

String assortMod
品揃モジュール

compQuant

String compQuant
構成品目数量

targetVal

String targetVal
BAPI の通貨額 (小数点以下９桁)

currency

String currency
販売伝票通貨

currIso

String currIso
ISO コード通貨

profitCtr

String profitCtr
利益センタ

orderid

String orderid
指図番号

wbsElem

String wbsElem
WBS 要素

deprecPer

String deprecPer
ドキュメンタリクレジット処理に関する償却率 (%)

refDoc

String refDoc
参照伝票番号

refDocIt

String refDocIt
参照明細番号

refDocCa

String refDocCa
先行販売管理伝票の伝票カテゴリ

custMat35

String custMat35
得意先品目

exchRateFiV

String exchRateFiV
FI 転記の換算レート (間接相場)

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

itemguidAtp

String itemguidAtp
ATP: 暗号 - DELNR および DELPS

valContr

String valContr
金額契約番号

valConI

String valConI
金額契約明細

configId

String configId
外部選定 ID (仮)

instId

String instId
選定におけるインスタンス番号

matExt

String matExt
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

matGuid

String matGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

matVers

String matVers
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

pMatExt

String pMatExt
項目 PR_REF_MAT の品目コード (長) (今後のリリースで開発)

pMatGuid

String pMatGuid
項目 PR_REF_MAT の外部 GUID (今後のリリースで開発)

pMatVers

String pMatVers
項目 PR_REF_MAT のバージョン番号 (今後のリリースで開発)

funcArea

String funcArea
機能領域

alternBom

String alternBom
代替 BOM

fkkConacct

String fkkConacct
長さ 12 の文字項目

eanUpc

String eanUpc
国際商品コード (EAN/UPC)

prodcat

String prodcat
製品カタログ番号

shipType

String shipType
出荷タイプ

sProcInd

String sProcInd
特別処理区分

funcAreaLong

String funcAreaLong
機能領域

billRel

String billRel
請求関連 (CRM)

vwUepos

String vwUepos
上位レベル明細用途 ID

campaign

String campaign
総括プロジェクト計画: 外部 R/3 システムの GUID

dlvschduse

String dlvschduse
用途区分

cfopLong

String cfopLong
CFOP code and extension

selection

String selection
選択 ID (永続)

matEntrd

String matEntrd
入力品目

logSystemOwn

String logSystemOwn
論理システム

itmTypeUsage

String itmTypeUsage
明細用途

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ItemsInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

updateflag

String updateflag
更新区分

hgLvItem

String hgLvItem
関連ユーザデータ項目の更新情報

poItmNo

String poItmNo
関連ユーザデータ項目の更新情報

material

String material
関連ユーザデータ項目の更新情報

altToItm

String altToItm
関連ユーザデータ項目の更新情報

custMat22

String custMat22
関連ユーザデータ項目の更新情報

batch

String batch
関連ユーザデータ項目の更新情報

dlvGroup

String dlvGroup
関連ユーザデータ項目の更新情報

partDlv

String partDlv
関連ユーザデータ項目の更新情報

reasonRej

String reasonRej
関連ユーザデータ項目の更新情報

billBlock

String billBlock
関連ユーザデータ項目の更新情報

billDate

String billDate
関連ユーザデータ項目の更新情報

plant

String plant
関連ユーザデータ項目の更新情報

storeLoc

String storeLoc
関連ユーザデータ項目の更新情報

targetQty

String targetQty
関連ユーザデータ項目の更新情報

targetQu

String targetQu
関連ユーザデータ項目の更新情報

tUnitIso

String tUnitIso
関連ユーザデータ項目の更新情報

itemCateg

String itemCateg
関連ユーザデータ項目の更新情報

shortText

String shortText
関連ユーザデータ項目の更新情報

prcGroup1

String prcGroup1
関連ユーザデータ項目の更新情報

prcGroup2

String prcGroup2
関連ユーザデータ項目の更新情報

prcGroup3

String prcGroup3
関連ユーザデータ項目の更新情報

prcGroup4

String prcGroup4
関連ユーザデータ項目の更新情報

prcGroup5

String prcGroup5
関連ユーザデータ項目の更新情報

prodHiera

String prodHiera
関連ユーザデータ項目の更新情報

matlGroup

String matlGroup
関連ユーザデータ項目の更新情報

purchNoC

String purchNoC
関連ユーザデータ項目の更新情報

purchDate

String purchDate
関連ユーザデータ項目の更新情報

poMethod

String poMethod
関連ユーザデータ項目の更新情報

ref1

String ref1
関連ユーザデータ項目の更新情報

purchNoS

String purchNoS
関連ユーザデータ項目の更新情報

poDatS

String poDatS
関連ユーザデータ項目の更新情報

poMethS

String poMethS
関連ユーザデータ項目の更新情報

ref1S

String ref1S
関連ユーザデータ項目の更新情報

poitmNoS

String poitmNoS
関連ユーザデータ項目の更新情報

priceGrp

String priceGrp
関連ユーザデータ項目の更新情報

custGroup

String custGroup
関連ユーザデータ項目の更新情報

salesDist

String salesDist
関連ユーザデータ項目の更新情報

priceList

String priceList
関連ユーザデータ項目の更新情報

incoterms1

String incoterms1
関連ユーザデータ項目の更新情報

incoterms2

String incoterms2
関連ユーザデータ項目の更新情報

ordcompIn

String ordcompIn
関連ユーザデータ項目の更新情報

billSched

String billSched
関連ユーザデータ項目の更新情報

invoSched

String invoSched
関連ユーザデータ項目の更新情報

mnInvoice

String mnInvoice
関連ユーザデータ項目の更新情報

exRateFi

String exRateFi
関連ユーザデータ項目の更新情報

addValDy

String addValDy
関連ユーザデータ項目の更新情報

fixValDy

String fixValDy
関連ユーザデータ項目の更新情報

pmnttrms

String pmnttrms
関連ユーザデータ項目の更新情報

pymtMeth

String pymtMeth
関連ユーザデータ項目の更新情報

accntAsgn

String accntAsgn
関連ユーザデータ項目の更新情報

exchgRate

String exchgRate
関連ユーザデータ項目の更新情報

priceDate

String priceDate
関連ユーザデータ項目の更新情報

servDate

String servDate
関連ユーザデータ項目の更新情報

dunnKey

String dunnKey
関連ユーザデータ項目の更新情報

dunnBlock

String dunnBlock
関連ユーザデータ項目の更新情報

promotion

String promotion
関連ユーザデータ項目の更新情報

pmtgarPro

String pmtgarPro
関連ユーザデータ項目の更新情報

docNumFi

String docNumFi
関連ユーザデータ項目の更新情報

departmNo

String departmNo
関連ユーザデータ項目の更新情報

recPoint

String recPoint
関連ユーザデータ項目の更新情報

cstcndgrp1

String cstcndgrp1
関連ユーザデータ項目の更新情報

cstcndgrp2

String cstcndgrp2
関連ユーザデータ項目の更新情報

cstcndgrp3

String cstcndgrp3
関連ユーザデータ項目の更新情報

cstcndgrp4

String cstcndgrp4
関連ユーザデータ項目の更新情報

cstcndgrp5

String cstcndgrp5
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

salesUnit

String salesUnit
関連ユーザデータ項目の更新情報

trgQtyNo

String trgQtyNo
関連ユーザデータ項目の更新情報

trgqtyDen

String trgqtyDen
関連ユーザデータ項目の更新情報

rnddlvQty

String rnddlvQty
関連ユーザデータ項目の更新情報

maxdevamnt

String maxdevamnt
関連ユーザデータ項目の更新情報

maxdevper

String maxdevper
関連ユーザデータ項目の更新情報

maxdevDay

String maxdevDay
関連ユーザデータ項目の更新情報

usageInd

String usageInd
関連ユーザデータ項目の更新情報

fixedQuan

String fixedQuan
関連ユーザデータ項目の更新情報

unlmtDlv

String unlmtDlv
関連ユーザデータ項目の更新情報

overdlvtol

String overdlvtol
関連ユーザデータ項目の更新情報

unddlvTol

String unddlvTol
関連ユーザデータ項目の更新情報

division

String division
関連ユーザデータ項目の更新情報

salqtynum

String salqtynum
関連ユーザデータ項目の更新情報

salqtyden

String salqtyden
関連ユーザデータ項目の更新情報

grossWght

String grossWght
関連ユーザデータ項目の更新情報

netWeight

String netWeight
関連ユーザデータ項目の更新情報

untofWght

String untofWght
関連ユーザデータ項目の更新情報

volume

String volume
関連ユーザデータ項目の更新情報

volunit

String volunit
関連ユーザデータ項目の更新情報

dlvPrio

String dlvPrio
関連ユーザデータ項目の更新情報

shipPoint

String shipPoint
関連ユーザデータ項目の更新情報

route

String route
関連ユーザデータ項目の更新情報

taxClass1

String taxClass1
関連ユーザデータ項目の更新情報

taxClass2

String taxClass2
関連ユーザデータ項目の更新情報

taxClass3

String taxClass3
関連ユーザデータ項目の更新情報

taxClass4

String taxClass4
関連ユーザデータ項目の更新情報

taxClass5

String taxClass5
関連ユーザデータ項目の更新情報

taxClass6

String taxClass6
関連ユーザデータ項目の更新情報

taxClass7

String taxClass7
関連ユーザデータ項目の更新情報

taxClass8

String taxClass8
関連ユーザデータ項目の更新情報

taxClass9

String taxClass9
関連ユーザデータ項目の更新情報

matPrGrp

String matPrGrp
関連ユーザデータ項目の更新情報

valType

String valType
関連ユーザデータ項目の更新情報

fixdatQty

String fixdatQty
関連ユーザデータ項目の更新情報

bomexplNo

String bomexplNo
関連ユーザデータ項目の更新情報

resanalkey

String resanalkey
関連ユーザデータ項目の更新情報

reqmtsTyp

String reqmtsTyp
関連ユーザデータ項目の更新情報

noGrPost

String noGrPost
関連ユーザデータ項目の更新情報

busTranst

String busTranst
関連ユーザデータ項目の更新情報

overhdKey

String overhdKey
関連ユーザデータ項目の更新情報

cstgSheet

String cstgSheet
関連ユーザデータ項目の更新情報

matfrgtgrp

String matfrgtgrp
関連ユーザデータ項目の更新情報

pldlvshdin

String pldlvshdin
関連ユーザデータ項目の更新情報

seqNo

String seqNo
関連ユーザデータ項目の更新情報

bilForm

String bilForm
関連ユーザデータ項目の更新情報

dliProfil

String dliProfil
関連ユーザデータ項目の更新情報

revType

String revType
関連ユーザデータ項目の更新情報

begdemPer

String begdemPer
関連ユーザデータ項目の更新情報

prRefMat

String prRefMat
関連ユーザデータ項目の更新情報

refobjtype

String refobjtype
関連ユーザデータ項目の更新情報

refobjkey

String refobjkey
関連ユーザデータ項目の更新情報

reflogsys

String reflogsys
関連ユーザデータ項目の更新情報

orderProb

String orderProb
関連ユーザデータ項目の更新情報

maxPlDlv

String maxPlDlv
関連ユーザデータ項目の更新情報

cfopCode

String cfopCode
関連ユーザデータ項目の更新情報

taxlawicms

String taxlawicms
関連ユーザデータ項目の更新情報

taxlawipi

String taxlawipi
関連ユーザデータ項目の更新情報

sdTaxcode

String sdTaxcode
関連ユーザデータ項目の更新情報

assortMod

String assortMod
関連ユーザデータ項目の更新情報

compQuant

String compQuant
関連ユーザデータ項目の更新情報

targetVal

String targetVal
関連ユーザデータ項目の更新情報

profitCtr

String profitCtr
関連ユーザデータ項目の更新情報

orderid

String orderid
関連ユーザデータ項目の更新情報

wbsElem

String wbsElem
関連ユーザデータ項目の更新情報

deprecPer

String deprecPer
関連ユーザデータ項目の更新情報

refDoc

String refDoc
関連ユーザデータ項目の更新情報

refDocIt

String refDocIt
関連ユーザデータ項目の更新情報

refDocCa

String refDocCa
関連ユーザデータ項目の更新情報

custMat35

String custMat35
関連ユーザデータ項目の更新情報

exchRateFiV

String exchRateFiV
関連ユーザデータ項目の更新情報

exchgRateV

String exchgRateV
関連ユーザデータ項目の更新情報

itemguidAtp

String itemguidAtp
関連ユーザデータ項目の更新情報

valContr

String valContr
関連ユーザデータ項目の更新情報

valConI

String valConI
関連ユーザデータ項目の更新情報

configId

String configId
関連ユーザデータ項目の更新情報

instId

String instId
関連ユーザデータ項目の更新情報

matExt

String matExt
関連ユーザデータ項目の更新情報

matGuid

String matGuid
関連ユーザデータ項目の更新情報

matVers

String matVers
関連ユーザデータ項目の更新情報

pMatExt

String pMatExt
関連ユーザデータ項目の更新情報

pMatGuid

String pMatGuid
関連ユーザデータ項目の更新情報

pMatVers

String pMatVers
関連ユーザデータ項目の更新情報

funcArea

String funcArea
関連ユーザデータ項目の更新情報

alternBom

String alternBom
関連ユーザデータ項目の更新情報

fkkConacct

String fkkConacct
関連ユーザデータ項目の更新情報

eanUpc

String eanUpc
関連ユーザデータ項目の更新情報

prodcat

String prodcat
関連ユーザデータ項目の更新情報

shipType

String shipType
関連ユーザデータ項目の更新情報

sProcInd

String sProcInd
関連ユーザデータ項目の更新情報

billRel

String billRel
関連ユーザデータ項目の更新情報

vwUepos

String vwUepos
関連ユーザデータ項目の更新情報

campaign

String campaign
関連ユーザデータ項目の更新情報

dlvschduse

String dlvschduse
関連ユーザデータ項目の更新情報

selection

String selection
関連ユーザデータ項目の更新情報

matEntrd

String matEntrd
関連ユーザデータ項目の更新情報

logSystemOwn

String logSystemOwn
関連ユーザデータ項目の更新情報

itmTypeUsage

String itmTypeUsage
関連ユーザデータ項目の更新情報

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Keys は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refobjtyp

String refobjtyp
オブジェクトタイプ

refobject

String refobject
オブジェクト名

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

docNumber

String docNumber
販売管理伝票番号

itmNumber

String itmNumber
販売伝票明細

schedLin

String schedLin
納入日程行

condNo

String condNo
伝票条件番号

conditemno

String conditemno
条件明細番号

condStNo

String condStNo
ステップ番号

condCount

String condCount
条件カウンタ

condType

String condType
条件タイプ

status

String status
単一文字フラグ

tindex

String tindex
数値項目: 長さ 6

address

String address
住所

abrli

String abrli
内部納入日程番号

abart

String abart
承認タイプ

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.LogicSwitch は Object を拡張し、Serializable を実装しています

直列化されたフィールド

pricing

String pricing
価格設定タイプ

atpWrkmod

String atpWrkmod
ATP セッション: 結果取得/新規決定 APO-ATP

scheduling

String scheduling
単一文字フラグ

nostructure

String nostructure
チェックボックス

condHandl

String condHandl
選択: 条件行処理 (SD 伝票変更)

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamBillingDocumentDetailList は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsBlob は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsInst は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsPartOf は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRef は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsRefInst は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsValue は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamCfgsVk は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamConditionsInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamExtensionIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamHeaderInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamItemsInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamKeys は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamLogicSwitch は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartnerAddresses は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamPartners は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesIn は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSchedulesInX は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSender は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamSuccess は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.ParamText は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.PartnerAddresses は Object を拡張し、Serializable を実装しています

直列化されたフィールド

addrNo

String addrNo
アドレス番号

formofaddr

String formofaddr
敬称テキスト

name

String name
名称 1

name2

String name2
名称 2

name3

String name3
名称 3

name4

String name4
名称 4

cOName

String cOName
気付

city

String city
市区町村

district

String district
所在地

cityNo

String cityNo
市区町村/地名ファイルの市区町村コード

postlCod1

String postlCod1
市区町村の郵便番号

postlCod2

String postlCod2
私書箱郵便番号

postlCod3

String postlCod3
会社郵便番号 (大規模なユーザ用)

poBox

String poBox
私書箱

poBoxCit

String poBoxCit
私書箱住所

delivDis

String delivDis
郵便配達地域

street

String street
地名

streetNo

String streetNo
市区町村/地名ファイルの地名コード

strAbbr

String strAbbr
地名の略称 (例: スペイン)

houseNo

String houseNo
番地-号

strSuppl1

String strSuppl1
地名 2

strSuppl2

String strSuppl2
地名 3

location

String location
地名 5

building

String building
旧: 建物 (番号または略称)

floor

String floor
建物の階

roomNo

String roomNo
部屋/アパート番号

country

String country
国コード

langu

String langu
言語キー

region

String region
地域 (都道府県)

sort1

String sort1
検索条件 1

sort2

String sort2
検索条件 2

timeZone

String timeZone
アドレスタイムゾーン

taxjurcode

String taxjurcode
税管轄コード

adrNotes

String adrNotes
住所注記

commType

String commType
通信方法 (キー) (アドレス管理)

tel1Numbr

String tel1Numbr
第一電話番号: ダイヤルコード + 番号

tel1Ext

String tel1Ext
第 1 電話番号: 内線

faxNumber

String faxNumber
第一 FAX 番号: ダイヤルコード + 番号

faxExtens

String faxExtens
第一 FAX 番号: 内線

streetLng

String streetLng
地名

distrctNo

String distrctNo
市区町村/地名ファイルの所在地コード

chckstatus

String chckstatus
市区町村ファイルテストステータス

pboxcitNo

String pboxcitNo
市区町村私書箱コード (市ファイル)

transpzone

String transpzone
商品の納入区域

houseNo2

String houseNo2
番地補足

eMail

String eMail
電子メールアドレス

strSuppl3

String strSuppl3
地名 4

title

String title
タイトル (敬称)

countryiso

String countryiso
ISO 国コード

languIso

String languIso
ISO 639 準拠の言語

buildLong

String buildLong
建物 (番号またはコード)

regiogroup

String regiogroup
地域構造グループ化

homeCity

String homeCity
市区町村 (郵便用市区町村と異なる場合)

homecityno

String homecityno
別の市区町村 (市区町村/地名ファイル)

pcode1Ext

String pcode1Ext
市区町村郵便番号の拡張子 例: 郵便番号 +4+2

pcode2Ext

String pcode2Ext
私書箱郵便番号拡張子 例: 郵便番号 +4+2

pcode3Ext

String pcode3Ext
主要得意先郵便番号拡張子 例: 郵便番号 +4+2

poWONo

String poWONo
フラグ: 郵便私書箱 (番号なし)

poBoxReg

String poBoxReg
私書箱の地域 (国、都道府県、地域、...)

poboxCtry

String poboxCtry
私書箱の国指定

poCtryiso

String poCtryiso
ISO 国コード

homepage

String homepage
URI 例: ホームページ、FTP アドレス

dontUseS

String dontUseS
地名住所配達不可フラグ

dontUseP

String dontUseP
私書箱住所配達不可フラグ

houseNo3

String houseNo3
番地範囲

languCr

String languCr
アドレスレコード登録オリジナル言語

langucriso

String langucriso
ISO 639 準拠の言語

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Partners は Object を拡張し、Serializable を実装しています

直列化されたフィールド

partnRole

String partnRole
取引先機能

partnNumb

String partnNumb
得意先コード 1

itmNumber

String itmNumber
明細番号 (販売管理伝票)

title

String title
敬称

name

String name
名称 1

name2

String name2
名称 2

name3

String name3
名称 3

name4

String name4
名称 4

street

String street
地名/番地-号

country

String country
国コード

countrIso

String countrIso
国キー (ISO コード)

postlCode

String postlCode
郵便番号

pobxPcd

String pobxPcd
私書箱番号

pobxCty

String pobxCty
私書箱住所

city

String city
市区町村

district

String district
所在地

region

String region
地域 (都道府県)

poBox

String poBox
私書箱

telephone

String telephone
電話番号 1

telephone2

String telephone2
電話番号 2

telebox

String telebox
テレボックス番号

faxNumber

String faxNumber
FAX 番号

teletexNo

String teletexNo
テレテクス番号

telexNo

String telexNo
テレックス番号

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

unloadPt

String unloadPt
荷渡ポイント

transpzone

String transpzone
商品の納入区域

taxjurcode

String taxjurcode
税計算管轄コード - 税管轄コード

address

String address
住所

privAddr

String privAddr
自宅住所

addrType

String addrType
アドレスタイプ (1=組織、2=個人、3=取引先担当者)

addrOrig

String addrOrig
コピー元住所

addrLink

String addrLink
住所コードへのリンク

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesIn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

schedLine

String schedLine
納入日程行

reqDate

String reqDate
納入日程日付

dateType

String dateType
日付タイプ (日、週、月、期間)

reqTime

String reqTime
納入時間

reqQty

String reqQty
販売単位による受注数量

reqDlvBl

String reqDlvBl
出荷ブロック中の納入日程行

schedType

String schedType
納入日程カテゴリ

tpDate

String tpDate
輸送計画日付

msDate

String msDate
品目利用可能日

loadDate

String loadDate
積載日付

giDate

String giDate
出庫日付

tpTime

String tpTime
輸送計画 - 時間 (現地時間/出荷ポイント参照)

msTime

String msTime
品目供給ステージ (現地時刻: プラント参照)

loadTime

String loadTime
積載時刻 (現地時間: 出荷ポイント)

giTime

String giTime
出庫時刻 (現地時間 - プラント参照)

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

reflogsys

String reflogsys
論理システム

dlvDate

String dlvDate
納入日程日付

dlvTime

String dlvTime
納入時間

relType

String relType
承認タイプ

planSchedType

String planSchedType
納入日程行タイプ EDI

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.SchedulesInX は Object を拡張し、Serializable を実装しています

直列化されたフィールド

itmNumber

String itmNumber
販売伝票明細

schedLine

String schedLine
納入日程行

updateflag

String updateflag
更新区分

reqDate

String reqDate
関連ユーザデータ項目の更新情報

dateType

String dateType
関連ユーザデータ項目の更新情報

reqTime

String reqTime
関連ユーザデータ項目の更新情報

reqQty

String reqQty
関連ユーザデータ項目の更新情報

reqDlvBl

String reqDlvBl
関連ユーザデータ項目の更新情報

schedType

String schedType
関連ユーザデータ項目の更新情報

tpDate

String tpDate
関連ユーザデータ項目の更新情報

msDate

String msDate
関連ユーザデータ項目の更新情報

loadDate

String loadDate
関連ユーザデータ項目の更新情報

giDate

String giDate
関連ユーザデータ項目の更新情報

tpTime

String tpTime
関連ユーザデータ項目の更新情報

msTime

String msTime
関連ユーザデータ項目の更新情報

loadTime

String loadTime
関連ユーザデータ項目の更新情報

giTime

String giTime
関連ユーザデータ項目の更新情報

refobjtype

String refobjtype
オブジェクトタイプ

refobjkey

String refobjkey
オブジェクトキー

dlvDate

String dlvDate
関連ユーザデータ項目の更新情報

dlvTime

String dlvTime
関連ユーザデータ項目の更新情報

relType

String relType
関連ユーザデータ項目の更新情報

planSchedType

String planSchedType
関連ユーザデータ項目の更新情報

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Sender は Object を拡張し、Serializable を実装しています

直列化されたフィールド

logSystem

String logSystem
論理システム

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Success は Object を拡張し、Serializable を実装しています

直列化されたフィールド

refDoc

String refDoc
参照伝票番号

refDocItem

String refDocItem
参照明細番号

billDoc

String billDoc
請求伝票

billDocItem

String billDocItem
請求伝票明細

netValue

String netValue
正味金額

taxValue

String taxValue
税額

currency

String currency
通貨コード

currencyIso

String currencyIso
ISO コード通貨

netValueItem

String netValueItem
正味金額

taxValueItem

String taxValueItem
税額

groValueItem

String groValueItem
総額

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.common.model.Text は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docNumber

String docNumber
販売伝票

itmNumber

String itmNumber
販売伝票明細

textId

String textId
テキスト ID

langu

String langu
言語キー

languIso

String languIso
ISO 639 準拠の言語

formatCol

String formatCol
タグ列

textLine

String textLine
テキスト行

function

String function
機能

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.exception

クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesAppException は SAPModuleAppException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.exception.SAPSalesSystemException は SAPModuleSystemException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.inquirycreatefromdata2.InquiryCreateFromData2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

testrun

String testrun
テスト実行

salesdocumentin

String salesdocumentin
販売管理伝票番号

intNumberAssignment

String intNumberAssignment
明細番号内部採番

behaveWhenError

String behaveWhenError
エラー処理

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

convert

String convert
変換: 取引先機能 + 受注伝票タイプ

salesdocument

String salesdocument
販売伝票番号

sender

Sender sender
論理システム - 送信者

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

inquiryHeaderInX

HeaderInX inquiryHeaderInX
ヘッダデータチェックボックス

inquiryHeaderIn

HeaderIn inquiryHeaderIn
引合伝票ヘッダデータ

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

inquiryCfgsBlobList

List inquiryCfgsBlobList
選定: BLOB 内部データ (SCE)

inquiryTextList

List inquiryTextList
テキスト

inquirySchedulesInXList

List inquirySchedulesInXList
納入日程行チェックボックス

inquirySchedulesInList

List inquirySchedulesInList
納入日程行

inquiryPartnersList

List inquiryPartnersList
伝票取引先

inquiryKeysList

List inquiryKeysList
参照キーの出力テーブル

inquiryItemsInXList

List inquiryItemsInXList
明細データチェックボックス

inquiryItemsInList

List inquiryItemsInList
明細データ

inquiryCfgsInstList

List inquiryCfgsInstList
選定: インスタンス

inquiryCfgsPartOfList

List inquiryCfgsPartOfList
選定: 部分設定

inquiryConditionsInXList

List inquiryConditionsInXList
受注における条件更新の通信項目

inquiryConditionsInList

List inquiryConditionsInList
条件

inquiryCfgsVkList

List inquiryCfgsVkList
選定: バリアント条件キー

inquiryCfgsValueList

List inquiryCfgsValueList
選定: 特性値

inquiryCfgsRefInstList

List inquiryCfgsRefInstList
選定: 参照明細/インスタンス

inquiryCfgsRefList

List inquiryCfgsRefList
選定: 参照データ

パッケージ jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.quotationcreatefromdata2.QuotationCreateFromData2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

behaveWhenError

String behaveWhenError
エラー処理

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

convert

String convert
取引先機能/受注伝票タイプの変換

testrun

String testrun
テスト実行

intNumberAssignment

String intNumberAssignment
明細番号内部採番

salesdocumentin

String salesdocumentin
見積伝票番号

salesdocument

String salesdocument
販売管理伝票番号

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

sender

Sender sender
論理システム - 送信者

quotationHeaderInX

HeaderInX quotationHeaderInX
伝票ヘッダチェックボックス

quotationHeaderIn

HeaderIn quotationHeaderIn
伝票ヘッダデータ

quotationTextList

List quotationTextList
テキスト

quotationSchedulesInXList

List quotationSchedulesInXList
納入日程行データチェックボックス

quotationSchedulesInList

List quotationSchedulesInList
納入日程行データ

quotationPartnersList

List quotationPartnersList
伝票取引先

quotationKeysList

List quotationKeysList
参照キーの出力テーブル

quotationItemsInXList

List quotationItemsInXList
明細データチェックボックス

quotationItemsInList

List quotationItemsInList
明細データ

quotationConditionsInXList

List quotationConditionsInXList
受注における条件更新の通信項目

quotationConditionsInList

List quotationConditionsInList
条件

quotationCfgsVkList

List quotationCfgsVkList
選定: バリアント条件キー

quotationCfgsValueList

List quotationCfgsValueList
選定: 特性値

quotationCfgsRefInstList

List quotationCfgsRefInstList
選定: 参照明細/インスタンス

quotationCfgsRefList

List quotationCfgsRefList
選定: 参照データ

quotationCfgsPartOfList

List quotationCfgsPartOfList
選定: 部分設定

quotationCfgsInstList

List quotationCfgsInstList
選定: インスタンス

quotationCfgsBlobList

List quotationCfgsBlobList
選定: BLOB 内部データ (SCE)

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.OrderCcard は Object を拡張し、Serializable を実装しています

直列化されたフィールド

ccType

String ccType
支払カードタイプ: カードタイプ

ccNumber

String ccNumber
支払カード: カード番号

ccValidT

String ccValidT
支払カード: 有効終了日

ccName

String ccName
支払カード: カード所有者の氏名

billamount

String billamount
請求金額: 請求計画に請求日付が指定されている場合

authFlag

String authFlag
支払カード: 振替権限

authamount

String authamount
支払カード: 承認額

currency

String currency
通貨コード

currIso

String currIso
ISO コード通貨

authDate

String authDate
支払カード: 承認日

authTime

String authTime
支払カード: 承認時刻

authCcNo

String authCcNo
支払カード: 承認番号

authRefno

String authRefno
支払カード: 決済代行会社の権限参照コード

ccReact

String ccReact
支払カード: 権限確認に対する応答

ccReAmount

String ccReAmount
BAPI インタフェースの通貨金額

glAccount

String glAccount
G/L 勘定コード

ccStatEx

String ccStatEx
支払カード: 外部システム呼出時のステータス

ccReactT

String ccReactT
支払カード: 結果テキスト

virtCard

String virtCard
チェックボックス

merchidcl

String merchidcl
支払カード: 決済代行会社のマーチャント ID

index

int index
レコード番号

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.ParamOrderCcard は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordercreatefromdata2.SalesOrderCreateFromDat2 は UpdateController を拡張し、Serializable を実装しています

直列化されたフィールド

salesdocumentin

String salesdocumentin
販売管理伝票番号

intNumberAssignment

String intNumberAssignment
明細番号内部採番

testrun

String testrun
テスト実行

convert

String convert
変換: 取引先機能 + 受注伝票タイプ

binaryRelationshiptype

String binaryRelationshiptype
バイナリ関連タイプ (専用)

behaveWhenError

String behaveWhenError
エラー処理

salesdocument

String salesdocument
生成された伝票の番号

orderHeaderIn

HeaderIn orderHeaderIn
受注伝票ヘッダ

orderHeaderInX

HeaderInX orderHeaderInX
受注伝票チェックリスト

sender

Sender sender
論理システム - 送信者

logicSwitch

LogicSwitch logicSwitch
内部制御パラメータ

orderItemsInXList

List orderItemsInXList
明細データチェックボックス

orderKeysList

List orderKeysList
参照キーの出力テーブル

orderPartnersList

List orderPartnersList
伝票取引先

orderSchedulesInList

List orderSchedulesInList
納入日程行データ

orderSchedulesInXList

List orderSchedulesInXList
納入日程行データチェックボックス

orderTextList

List orderTextList
テキスト

partnerAddressesList

List partnerAddressesList
アドレス (組織/会社) 用 BAPI 参照構造

extensionInList

List extensionInList
VBAK、VBAP、VBEP のカスタマ拡張

orderCcardList

List orderCcardList
クレジットカードデータ

orderCfgsBlobList

List orderCfgsBlobList
選定: BLOB 内部データ (SCE)

orderCfgsInstList

List orderCfgsInstList
選定: インスタンス

orderCfgsPartOfList

List orderCfgsPartOfList
選定: 部分設定

orderCfgsRefList

List orderCfgsRefList
選定: 参照データ

orderCfgsRefInstList

List orderCfgsRefInstList
選定: 参照明細/インスタンス

orderCfgsValueList

List orderCfgsValueList
選定: 特性値

orderCfgsVkList

List orderCfgsVkList
選定: バリアント条件キー

orderConditionsInList

List orderConditionsInList
条件

orderConditionsInXList

List orderConditionsInXList
条件チェックボックス

orderItemsInList

List orderItemsInList
明細データ

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.ParamSalesOrders は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrderGetList は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

customerNumber

String customerNumber
得意先コード

documentDate

String documentDate
登録日付

documentDateTo

String documentDateTo
入力日付 (以前/以降)

material

String material
品目コード

purchaseOrder

String purchaseOrder
得意先発注番号

purchaseOrderNumber

String purchaseOrderNumber
得意先発注番号1

salesOrganization

String salesOrganization
販売組織

transactionGroup

String transactionGroup
一文字フラグ

salesOrdersList

List salesOrdersList
得意先受注テーブル

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetlist.SalesOrders は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sdDoc

String sdDoc
販売管理伝票番号

itmNumber

String itmNumber
明細番号 (販売管理伝票)

material

String material
品目コード

shortText

String shortText
テキスト (短): 受注明細

docType

String docType
販売伝票タイプ

docDate

String docDate
伝票日付 (受信日/送信日)

reqQty

String reqQty
累積受注数量 (販売単位)

reqDate

String reqDate
指定納期

purchNo

String purchNo
得意先発注番号

batch

String batch
ロット番号

validFrom

String validFrom
見積または基本契約の有効開始日

validTo

String validTo
見積または基本契約有効終了日

billBlock

String billBlock
販売管理伝票の請求ブロック

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

soldTo

String soldTo
受注先

name

String name
名称 1

exchgRate

String exchgRate
価格設定/統計の換算レート (直接引用)

dlvQty

String dlvQty
出荷数量実績 (販売単位)

baseUom

String baseUom
基本数量単位

netPrice

String netPrice
正味価格

condPUnt

String condPUnt
価格条件単位

condUnit

String condUnit
条件単位

netValHd

String netValHd
受注正味額 (伝票通貨)

netValue

String netValue
伝票通貨による正味額

division

String division
製品部門

docStatus

String docStatus
伝票ステータス

salesGrp

String salesGrp
営業グループ

salesOff

String salesOff
営業所

salesOrg

String salesOrg
販売組織

salesUnit

String salesUnit
販売単位

shipPoint

String shipPoint
出荷ポイント/入荷ポイント

distrChan

String distrChan
流通チャネル

giDate

String giDate
出庫日付

currency

String currency
販売伝票通貨

plant

String plant
プラント

storeLoc

String storeLoc
保管場所

ordReason

String ordReason
受注理由 (取引理由)

reasonRej

String reasonRej
見積および受注の拒否理由

bUomIso

String bUomIso
ISO コードでの基本数量単位

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

sUnitIso

String sUnitIso
ISO コードによる販売単位

currIso

String currIso
ISO コード通貨

purchNoC

String purchNoC
出荷先発注番号

exchgRateV

String exchgRateV
価格設定/統計の換算レート (間接引用)

matExt

String matExt
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

matGuid

String matGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

matVers

String matVers
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

creationDate

String creationDate
レコード登録日

creationTime

String creationTime
登録時刻

index

int index
レコード番号

パッケージ jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.ParamStatusInfo は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.SalesOrderGetStatus は ReferenceController を拡張し、Serializable を実装しています

直列化されたフィールド

salesdocument

String salesdocument
販売管理伝票番号

statusInfoList

ArrayList statusInfoList
ステータス情報

クラス jp.co.intra_mart.foundation.sap.module.sales.salesordergetstatus.StatusInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

docNumber

String docNumber
販売伝票

docDate

String docDate
伝票日付 (受信日/送信日)

purchNo

String purchNo
得意先発注番号

prcStatH

String prcStatH
伝票の全処理ステータス

dlvStatH

String dlvStatH
全明細の出荷ステータス

reqDateH

String reqDateH
指定納入期日

dlvBlock

String dlvBlock
出荷ブロック (伝票ヘッダ)

itmNumber

String itmNumber
販売伝票明細

material

String material
品目コード

shortText

String shortText
テキスト (短): 受注明細

reqDate

String reqDate
納入日程日付

reqQty

String reqQty
累積受注数量 (販売単位)

cumCfQty

String cumCfQty
累積確認数量 (販売数量単位)

salesUnit

String salesUnit
販売単位

netValue

String netValue
伝票通貨での受注明細正味額

currency

String currency
販売伝票通貨

netPrice

String netPrice
正味価格

condPUnt

String condPUnt
価格条件単位

condUnit

String condUnit
条件単位

dlvStatI

String dlvStatI
明細の全体出荷ステータス

delivNumb

String delivNumb
出荷伝票

delivItem

String delivItem
出荷明細

delivDate

String delivDate
納入期日

dlvQty

String dlvQty
出荷数量実績 (販売単位)

refQty

String refQty
基本数量単位による参照数量

sUnitIso

String sUnitIso
ISO コードによる販売単位

cdUntIso

String cdUntIso
条件数量単位 (ISO コード)

currIso

String currIso
ISO コード通貨

materialExternal

String materialExternal
項目 MATERIAL の品目コード (長) (今後のリリースで開発)

materialGuid

String materialGuid
項目 MATERIAL の外部 GUID (今後のリリースで開発)

materialVersion

String materialVersion
項目 MATERIAL のバージョン番号 (今後のリリースで開発)

poItmNo

String poItmNo
元となる購買発注の明細番号

creationDate

String creationDate
レコード登録日

creationTime

String creationTime
登録時刻

sUnitDlv

String sUnitDlv
出荷単位

dlvUnitIso

String dlvUnitIso
ISO コードでの出荷単位の数量単位

index

int index
レコード番号

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の使用

jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClient の使用

SapClient を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SapClient の使用

jp.co.intra_mart.foundation.sap.common.auth での SapClient のサブクラス
class | SapClientNoLoadBalancing SapClientNoLoadBalancingクラス。
class | SapClientPool SAPClientPoolクラス。
class | SapClientPoolNoLoadBalancing SAPClientPoolクラス。
class | SapClientPoolWithLoadBalancing SAPClientPoolクラス。
class | SapClientWithLoadBalancing SAPClientPoolクラス。

SapClient を返す jp.co.intra_mart.foundation.sap.common.auth のメソッド
static SapClient | SapClientManager.getSapClient() 接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
static SapClient | SapClientManager.getSapClient(String serverType) 引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository SapRepositoryManager.getJCORepository(SapClient sapClient)
Repository情報を生成もしくは、取得します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SapClient の使用

SapClient 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
ConnectionManager(SapClient sapClient)
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPool の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPool の使用

SapClientPool を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SapClientPool の使用

jp.co.intra_mart.foundation.sap.common.auth での SapClientPool のサブクラス
class | SapClientPoolNoLoadBalancing SAPClientPoolクラス。
class | SapClientPoolWithLoadBalancing SAPClientPoolクラス。

SapClientPool 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.auth のメソッド
protected com.sap.mw.jco.JCO.Pool | SapClientPoolWithLoadBalancing.createPool(SapClientPool sapClientPool) コネクションプールを生成します。
protected com.sap.mw.jco.JCO.Pool | SapClientPoolNoLoadBalancing.createPool(SapClientPool sapClientPool) コネクションプールを生成します。
static void | SapClientPoolManager.createPool(SapClientPool sapClientPool) コネクションプール方式を用いて、JCOコネクションの取得を行います。
protected abstract com.sap.mw.jco.JCO.Pool | SapClientPool.createPool(SapClientPool sapClientPool) JCOコネクションプールを生成します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing の使用

jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapConnector の使用

jp.co.intra_mart.foundation.sap.common.auth.SapConnector はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の使用

jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException の使用

SAPAuthAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector(String serverType)
推奨されていません。 プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthAppException の使用

SAPAuthAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPIを実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException の使用

SAPAuthSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のメソッド
static com.sap.mw.jco.JCO.Repository | SapRepositoryManager.getJCORepository(SapClient sapClient) Repository情報を生成もしくは、取得します。
com.sap.mw.jco.JCO.Client | SapConnector.useConnection() 推奨されていません。 コネクションを生成します。
static void | SapConnector.releaseConnection(com.sap.mw.jco.JCO.Client connection) 推奨されていません。 コネクションをリリースします。
static SapClient | SapClientManager.getSapClient() 接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
static SapClient | SapClientManager.getSapClient(String serverType) 引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
void | SapClient.release() JCOコネクションの開放を行います。
com.sap.mw.jco.JCO.Client | SapClient.getJCOClient() JCOコネクションの取得を行います。
static String | SapAuthInfoBundle.getProperty(String propertyName) 引数で指定されたプロパティの値を返却します。
static String | SapAuthInfoBundle.getProperty(String serverType, String propertyName) 引数で指定されたプロパティの値を返却します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.auth のコンストラクタ
SapConnector()
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
推奨されていません。 プロパティファイルを読込み属性に値をセットします。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void BapiController.executeBapi()
BAPIを実行します。

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.common.util.data での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String ExtendedParamConverter.changeToUpperParam(String param, String propertyName, String paramType)
入力された項目名をプロパティファイルの項目名に変換します。

jp.co.intra_mart.foundation.sap.common.util.file での SAPAuthSystemException の使用

SAPAuthSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.file のコンストラクタ
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.auth.exception (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.auth.exception
例外
SAPAuthAppException
SAPAuthSystemException


jp.co.intra_mart.foundation.sap.common.auth.exception (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

ＳＡＰ連携に関する例外クラスを提供します。

参照:
説明

例外の概要
SAPAuthAppException | 認証系APIアプリケーション例外クラス
SAPAuthSystemException | 認証系APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の説明

ＳＡＰ連携に関する例外クラスを提供します。


jp.co.intra_mart.foundation.sap.common.auth.exception クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException


パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception の使用

jp.co.intra_mart.foundation.sap.common.auth.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthAppException
認証系APIアプリケーション例外クラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthSystemException
認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.file により使用される jp.co.intra_mart.foundation.sap.common.auth.exception のクラス
SAPAuthSystemException
認証系APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPAuthAppException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
すべての実装インタフェース:
Serializable
public class SAPAuthAppException
extends SAPException

認証系APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthAppException(String message)
認証系APIアプリケーション例外
SAPAuthAppException(String message, Throwable ex)
認証系APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthAppException

public SAPAuthAppException(String message,
                           Throwable ex)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPAuthAppException

public SAPAuthAppException(String message)
認証系APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPAuthSystemException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth.exception
クラス SAPAuthSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
すべての実装インタフェース:
Serializable
public class SAPAuthSystemException
extends SAPException

認証系APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPAuthSystemException(String message)
認証系APIシステム例外
SAPAuthSystemException(String message, Throwable ex)
認証系APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPAuthSystemException

public SAPAuthSystemException(String message)
認証系APIシステム例外

パラメータ:
message - エラーメッセージ

SAPAuthSystemException

public SAPAuthSystemException(String message,
                              Throwable ex)
認証系APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.auth (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.auth
クラス
SapAuthInfoBundle
SapClient
SapClientManager
SapClientNoLoadBalancing
SapClientPool
SapClientPoolManager
SapClientPoolNoLoadBalancing
SapClientPoolWithLoadBalancing
SapClientWithLoadBalancing
SapConnector
SapRepositoryManager


jp.co.intra_mart.foundation.sap.common.auth (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
SapAuthInfoBundle | 接続情報初期値取得クラス。
SapClient | SAPクライアント抽象クラス。
SapClientManager | SAPクライアントマネージャークラス。
SapClientNoLoadBalancing | SapClientNoLoadBalancingクラス。
SapClientPool | SAPClientPoolクラス。
SapClientPoolManager | SAPクライアントプールマネージャークラス。
SapClientPoolNoLoadBalancing | SAPClientPoolクラス。
SapClientPoolWithLoadBalancing | SAPClientPoolクラス。
SapClientWithLoadBalancing | SAPClientPoolクラス。
SapConnector | 推奨されていません。 本クラスは現在、標準では使用されておりません。
SapRepositoryManager | JCO.Repository を管理クラス。

パッケージ jp.co.intra_mart.foundation.sap.common.auth の説明

ＳＡＰ連携に関するクラスを提供します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.auth クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.auth の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClient
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.common.auth の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.auth の使用

jp.co.intra_mart.foundation.sap.common.auth を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。
SapClientPool
SAPClientPoolクラス。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.auth のクラス
SapClient
SAPクライアント抽象クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SapAuthInfoBundle (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapAuthInfoBundle

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle
public class SapAuthInfoBundle
extends Object

接続情報初期値取得クラス。
機能は以下の通り。

  • sap_auth_info.property内にて定義されている接続情報の取得を行います。
  • 取得の際は、プロパティ名及び、必要に応じてサーバータイプを用いて、
    指定された情報の取得を行います。

バージョン:
1.0

メソッドの概要
static String | getProperty(String propertyName) 引数で指定されたプロパティの値を返却します。
static String | getProperty(String serverType, String propertyName) 引数で指定されたプロパティの値を返却します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getProperty

public static String getProperty(String propertyName)
                          throws SAPAuthSystemException
引数で指定されたプロパティの値を返却します。

また、プロパティが存在しない場合、nullを返却します。

パラメータ:
propertyName - プロパティ名
戻り値:
プロパティ値またはnull
例外:
SAPAuthSystemException - 認証系システム例外処理

getProperty

public static String getProperty(String serverType,
                                 String propertyName)
                          throws SAPAuthSystemException
引数で指定されたプロパティの値を返却します。

プロパティが存在しない場合、nullを返却します。

パラメータ:
serverType - サーバタイプ
propertyName - プロパティ名
戻り値:
プロパティ値またはnull
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SapClient (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClient

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
直系の既知のサブクラス:
SapClientNoLoadBalancing, SapClientPool, SapClientWithLoadBalancing
public abstract class SapClient
extends Object

SAPクライアント抽象クラス。
機能は以下の通り。

  • SAP APサーバーへの接続情報を保持する為の抽象クラス。
  • JCOコネクションの取得に必要な抽象メソッドを用意しています。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
protected  com.sap.mw.jco.JCO.Client connection
JCOコネクション
コンストラクタの概要
protected SapClient(String serverType, String client, String user, String passwd, String lang)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected abstract com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行う為の抽象メソッドです。
String | getClient() クライアントを取得します。
abstract String | getHost() 接続先IPアドレスを取得する為の抽象メソッド
String | getIdentifier() コネクションの識別子を取得します。
com.sap.mw.jco.JCO.Client | getJCOClient() JCOコネクションの取得を行います。
String | getLang() 言語を取得します。
String | getPasswd() パスワードを取得します。
String | getServerType() 設定されているサーバータイプを取得します。
String | getUser() ユーザーを取得します。
void | release() JCOコネクションの開放を行います。
protected abstract void | releaseConnection() JCOコネクションの開放をを行う為の抽象メソッドです。
void | setClient(String client) クライアントを設定します。
void | setLang(String lang) 言語を設定します。
void | setPasswd(String passwd) パスワードを設定します。
void | setUser(String user) ユーザーを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

connection

protected com.sap.mw.jco.JCO.Client connection
JCOコネクション

コンストラクタの詳細

SapClient

protected SapClient(String serverType,
                    String client,
                    String user,
                    String passwd,
                    String lang)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
メソッドの詳細

createClient

protected abstract com.sap.mw.jco.JCO.Client createClient()
                                                   throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行う為の抽象メソッドです。

戻り値:
JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected abstract void releaseConnection()
                                   throws com.sap.mw.jco.JCO.Exception
JCOコネクションの開放をを行う為の抽象メソッドです。

例外:
JCO.Exception - JCO例外

release

public void release()
             throws SAPAuthSystemException
JCOコネクションの開放を行います。

例外:
SAPAuthSystemException - 認証系システム例外

getJCOClient

public com.sap.mw.jco.JCO.Client getJCOClient()
                                       throws SAPAuthSystemException
JCOコネクションの取得を行います。

戻り値:
JCO.Client JCOコネクション
例外:
SAPAuthSystemException - 認証系システム例外

getLang

public String getLang()
言語を取得します。

戻り値:
lang 設定した言語

setLang

public void setLang(String lang)
言語を設定します。

パラメータ:
lang - 設定する言語

getPasswd

public String getPasswd()
パスワードを取得します。

戻り値:
passwd 設定したパスワード

setPasswd

public void setPasswd(String passwd)
パスワードを設定します。

パラメータ:
passwd - 設定するパスワード

getUser

public String getUser()
ユーザーを取得します。

戻り値:
user 設定したユーザー

setUser

public void setUser(String user)
ユーザーを設定します。

パラメータ:
user - 設定するユーザー

getClient

public String getClient()
クライアントを取得します。

戻り値:
client 設定したクライアント

setClient

public void setClient(String client)
クライアントを設定します。

パラメータ:
client - 設定するクライアント

getHost

public abstract String getHost()
接続先IPアドレスを取得する為の抽象メソッド

戻り値:
String 接続先IPアドレス

getIdentifier

public String getIdentifier()
コネクションの識別子を取得します。

戻り値:
identifier コネクションの識別子

getServerType

public String getServerType()
設定されているサーバータイプを取得します。

戻り値:
serverType サーバータイプ

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientManager (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientManager
public class SapClientManager
extends Object

SAPクライアントマネージャークラス。

機能は以下の通り。

  • 接続情報初期値を保持したSAPクライアントオブジェクトを取得します。
接続情報設定ファイル sap_auth_info.properties で定義した サーバタイプ をキーに SAPクライアントオブジェクトSapClient を取得します。
以下、接続情報設定ファイル sap_auth_info.properties での定義方法を示します。

現在、以下の２つのコネクションに対応しています。
  • プールコネクション(Pool Connection)
  • ダイレクトコネクション(Direct Connection)
それぞれのコネクションにおいて、非負荷分散環境(No Load Balancing)と負荷分散環境(Load Balancing)への接続設定を行うプロパティは異なります。
以下その４パターンについて設定するプロパティを示します。

[備考]
※接続先が１接続の場合、.サーバタイプ を省略することができます。
※接続先が複数存在する場合は、.サーバタイプ を利用して、複数の接続先を定義することができます。
Pool Connection (No Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.ashost.サーバタイプ | SAPにログインする際に使用する接続先サーバのIPアドレス（ホスト名）
jco.client.sysnr.サーバタイプ | SAPにログインする際に使用するシステム番号
jco.client.poolsize.サーバタイプ | SAPにログインする際に使用できる、指定したプール内のコネクション数
jco.client.poolname.サーバタイプ | SAPにログインする際に使用する任意のプール名称
jco.client.waittime.サーバタイプ | プール内のコネクションが全て使用中の際に、リリースされたコネクションを取得するために待機する時間(単位:ミリ秒)
jco.client.connectiontimeout.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際の未使用時間(単位:ミリ秒)
jco.client.timeoutcheckperiod.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際に、未使用時間をチェックする間隔(単位:ミリ秒)

Direct Connection (No Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.ashost.サーバタイプ | SAPにログインする際に使用する接続先サーバのIPアドレス（ホスト名）
jco.client.sysnr.サーバタイプ | SAPにログインする際に使用するシステム番号

Pool Connection (Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.mshost.サーバタイプ | SAPにログインする際に使用する接続先メッセージサーバIPアドレス（ホスト名）
jco.client.r3name.サーバタイプ | SAPにログインする際に使用するSAP名称
jco.client.group.サーバタイプ | SAPにログインする際に使用するグループID
jco.client.poolsize.サーバタイプ | SAPにログインする際に使用できる、指定したプール内のコネクション数
jco.client.poolname.サーバタイプ | SAPにログインする際に使用する任意のプール名称
jco.client.waittime.サーバタイプ | プール内のコネクションが全て使用中の際に、リリースされたコネクションを取得するために待機する時間(単位:ミリ秒)
jco.client.connectiontimeout.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際の未使用時間(単位:ミリ秒)
jco.client.timeoutcheckperiod.サーバタイプ | プール内で一定時間使用されていないコネクションを自動的にクローズする際に、未使用時間をチェックする間隔(単位:ミリ秒)

Direct Connection (Load Balancing)
パラメータ名 | 説明
jco.client.client.サーバタイプ | SAPにログインする際に使用するクライアント
jco.client.user.サーバタイプ | SAPにログインする際に使用するユーザ
jco.client.passwd.サーバタイプ | SAPにログインする際に使用するパスワード
jco.client.lang.サーバタイプ | SAPにログインする際に使用する言語
jco.client.mshost.サーバタイプ | SAPにログインする際に使用する接続先メッセージサーバIPアドレス（ホスト名）
jco.client.r3name.サーバタイプ | SAPにログインする際に使用するSAP名称
jco.client.group.サーバタイプ | SAPにログインする際に使用するグループID

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
static SapClient | getSapClient() 接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
static SapClient | getSapClient(String serverType) 引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getSapClient

public static SapClient getSapClient()
                              throws SAPAuthSystemException
接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。

戻り値:
SapClient SAPクライアントオブジェクト
例外:
SAPAuthSystemException - 認証系システム例外処理

getSapClient

public static SapClient getSapClient(String serverType)
                              throws SAPAuthSystemException
引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
また引数にnull値もしくは、空文字("")を設定した場合、 serverTypeが指定されていない接続情報を保持したSAPクライアントオブジェクトを 取得します。

パラメータ:
serverType - サーバータイプ
戻り値:
SapClient SAPクライアントオブジェクト
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientNoLoadBalancing (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientNoLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing
public class SapClientNoLoadBalancing
extends SapClient

SapClientNoLoadBalancingクラス。
機能は以下の通り。

  • 非負荷分散環境にて構築されたSAP APサーバーと、 DirectConnection方式を用いた接続を行うクラスです。
  • JCOコネクションの取得に必要なメソッドを用意しています。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientNoLoadBalancing(String serverType, String client, String user, String passwd, String lang, String ashost, String sysnr)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行います。
String | getAshost() 接続先アプリケーションサーバIPアドレスを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getSysnr() システム番号を取得します。
protected void | releaseConnection() 取得したJCOコネクションの開放を行います。
void | setAshost(String ashost) 接続先アプリケーションサーバIPアドレスを設定します。
void | setSysnr(String sysnr) システム番号を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release, setClient, setLang, setPasswd, setUser
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientNoLoadBalancing

protected SapClientNoLoadBalancing(String serverType,
                                   String client,
                                   String user,
                                   String passwd,
                                   String lang,
                                   String ashost,
                                   String sysnr)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
ashost - 接続先アプリケーションサーバIPアドレス
sysnr - システム番号
メソッドの詳細

getAshost

public String getAshost()
接続先アプリケーションサーバIPアドレスを取得します。

戻り値:
ashost 設定した接続先アプリケーションサーバIPアドレス

setAshost

public void setAshost(String ashost)
接続先アプリケーションサーバIPアドレスを設定します。

パラメータ:
ashost - 設定する接続先アプリケーションサーバIPアドレス

createClient

protected com.sap.mw.jco.JCO.Client createClient()
                                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行います。

定義:
クラス SapClient 内の createClient
戻り値:
JCO.Client JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected void releaseConnection()
                          throws com.sap.mw.jco.JCO.Exception
取得したJCOコネクションの開放を行います。

定義:
クラス SapClient 内の releaseConnection
例外:
JCO.Exception - JCO例外

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
String 接続先IPアドレス

getSysnr

public String getSysnr()
システム番号を取得します。

戻り値:
sysnr 設定したシステム番号

setSysnr

public void setSysnr(String sysnr)
システム番号を設定します。

パラメータ:
sysnr - 設定するシステム番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClient 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPool (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPool

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
直系の既知のサブクラス:
SapClientPoolNoLoadBalancing, SapClientPoolWithLoadBalancing
public abstract class SapClientPool
extends SapClient

SAPClientPoolクラス。
機能は以下の通り。

  • SAP APサーバーへConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要な抽象メソッドを用意しています。
  • JCOコネクションプールの接続先の設定は、プロパティファイルからのみ設定できます。
    メソッドで変更することはできません。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientPool(String serverType, String client, String user, String passwd, String lang, String poolName, int poolSize, long waitTime, long connectionTimeout, long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行います。
protected abstract com.sap.mw.jco.JCO.Pool | createPool(SapClientPool sapClientPool) JCOコネクションプールを生成します。
long | getConnectionTimeout() コネクションのタイムアウト時間を取得します。
String | getPoolName() プール名称を取得します。
int | getPoolSize() プール内のコネクション数を取得します。
long | getTimeoutCheckPeriod() コネクションのタイムアウトのチェック間隔を取得します。
long | getWaitTime() コネクション取得の待機時間を取得します。
protected void | releaseConnection() JCOコネクションの開放を行います。
void | setClient(String client) クライアントを設定します。
void | setLang(String lang) 言語を設定します。
void | setPasswd(String passwd) パスワードを設定します。
void | setUser(String user) ユーザーを設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getHost, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientPool

protected SapClientPool(String serverType,
                        String client,
                        String user,
                        String passwd,
                        String lang,
                        String poolName,
                        int poolSize,
                        long waitTime,
                        long connectionTimeout,
                        long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
poolName - プール名称
poolSize - プール内のコネクション数
waitTime - コネクション取得の待機時間
connectionTimeout - コネクションのタイムアウト
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔
メソッドの詳細

createClient

protected com.sap.mw.jco.JCO.Client createClient()
                                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行います。

定義:
クラス SapClient 内の createClient
戻り値:
JCO.Client JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected void releaseConnection()
                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの開放を行います。

定義:
クラス SapClient 内の releaseConnection
例外:
JCO.Exception - JCO例外

createPool

protected abstract com.sap.mw.jco.JCO.Pool createPool(SapClientPool sapClientPool)
                                               throws com.sap.mw.jco.JCO.Exception
JCOコネクションプールを生成します。

パラメータ:
sapClientPool - SapClientPoolオブジェクト
戻り値:
JCO.Pool JCO.Poolオブジェクト
例外:
JCO.Exception - JCO例外

getConnectionTimeout

public long getConnectionTimeout()
コネクションのタイムアウト時間を取得します。

戻り値:
connectionTimeout 取得したいコネクションのタイムアウト時間

getPoolName

public String getPoolName()
プール名称を取得します。

戻り値:
poolName 設定したプール名称

getPoolSize

public int getPoolSize()
プール内のコネクション数を取得します。

戻り値:
poolSize 設定したプール内のコネクション数

getTimeoutCheckPeriod

public long getTimeoutCheckPeriod()
コネクションのタイムアウトのチェック間隔を取得します。

戻り値:
timeoutCheckPeriod 設定したコネクションのタイムアウトのチェック間隔

getWaitTime

public long getWaitTime()
コネクション取得の待機時間を取得します。

戻り値:
waitTime 設定したコネクション取得の待機時間

setLang

public void setLang(String lang)
言語を設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setLang
パラメータ:
lang - 設定する言語

setPasswd

public void setPasswd(String passwd)
パスワードを設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setPasswd
パラメータ:
passwd - 設定するパスワード

setUser

public void setUser(String user)
ユーザーを設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setUser
パラメータ:
user - 設定するユーザー

setClient

public void setClient(String client)
クライアントを設定します。

※本処理は無視されます。

オーバーライド:
クラス SapClient 内の setClient
パラメータ:
client - 設定するクライアント

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClient 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPoolManager (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPoolManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager
public class SapClientPoolManager
extends Object

SAPクライアントプールマネージャークラス。
機能は以下の通り。

  • コネクションプール方式を用いて、JCOコネクションを取得します。
  • またコネクションの待機時間、タイムアウト時間、タイムアウトのチェック間隔の
    設定も行います。

導入されたバージョン:
6.1
バージョン:
1.0

メソッドの概要
static void | createPool(SapClientPool sapClientPool) コネクションプール方式を用いて、JCOコネクションの取得を行います。
static boolean | hasPool(String poolName) コネクションプール内に、引数にて渡されたJCOコネクション名が存在しているか判定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

createPool

public static void createPool(SapClientPool sapClientPool)
                       throws com.sap.mw.jco.JCO.Exception
コネクションプール方式を用いて、JCOコネクションの取得を行います。

パラメータ:
sapClientPool - SAPクライアントオブジェクト
例外:
JCO.Exception - JCO例外

hasPool

public static boolean hasPool(String poolName)
コネクションプール内に、引数にて渡されたJCOコネクション名が存在しているか判定します。

パラメータ:
poolName - プールされるJCOコネクション名
戻り値:
boolean 判定結果
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPoolNoLoadBalancing (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPoolNoLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
            拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing
public class SapClientPoolNoLoadBalancing
extends SapClientPool

SAPClientPoolクラス。
機能は以下の通り。

  • 非負荷分散環境にて構築されたSAP APサーバーへ
    ConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要なメソッドを用意しています。
  • JCOコネクションプールの接続先の設定は、プロパティファイルからのみ設定できます。
    メソッドで変更することはできません。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientPoolNoLoadBalancing(String serverType, String client, String user, String passwd, String lang, String ashost, String sysnr, String poolName, int poolSize, long waitTime, long connectionTimeout, long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Pool | createPool(SapClientPool sapClientPool) コネクションプールを生成します。
String | getAshost() 接続先サーバIPアドレスを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getSysnr() システム番号を取得します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPool から継承したメソッド
createClient, getConnectionTimeout, getPoolName, getPoolSize, getTimeoutCheckPeriod, getWaitTime, releaseConnection, setClient, setLang, setPasswd, setUser
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientPoolNoLoadBalancing

protected SapClientPoolNoLoadBalancing(String serverType,
                                       String client,
                                       String user,
                                       String passwd,
                                       String lang,
                                       String ashost,
                                       String sysnr,
                                       String poolName,
                                       int poolSize,
                                       long waitTime,
                                       long connectionTimeout,
                                       long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
ashost - 接続先サーバIPアドレス
sysnr - システム番号
poolName - プール名称
poolSize - プール内のコネクション数
waitTime - コネクション取得の待機時間
connectionTimeout - コネクションのタイムアウト
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔
メソッドの詳細

createPool

protected com.sap.mw.jco.JCO.Pool createPool(SapClientPool sapClientPool)
                                      throws com.sap.mw.jco.JCO.Exception
コネクションプールを生成します。

定義:
クラス SapClientPool 内の createPool
パラメータ:
sapClientPool - SapClientPoolオブジェクト
戻り値:
Pool Poolオブジェクト
例外:
JCO.Exception - JCO例外

getAshost

public String getAshost()
接続先サーバIPアドレスを取得します。

戻り値:
ashost 設定した接続先サーバIPアドレス

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
host 接続先IPアドレス

getSysnr

public String getSysnr()
システム番号を取得します。

戻り値:
sysnr 設定したシステム番号

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClientPool 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientPoolWithLoadBalancing (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientPoolWithLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
            拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing
public class SapClientPoolWithLoadBalancing
extends SapClientPool

SAPClientPoolクラス。
機能は以下の通り。

  • 負荷分散環境にて構築されたSAP APサーバーへ
    ConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要なメソッドを用意しています。
  • JCOコネクションプールの接続先の設定は、プロパティファイルからのみ設定できます。
    メソッドで変更することはできません。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientPoolWithLoadBalancing(String serverType, String client, String user, String passwd, String lang, String mshost, String r3name, String group, String poolName, int poolSize, long waitTime, long connectionTimeout, long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Pool | createPool(SapClientPool sapClientPool) コネクションプールを生成します。
String | getGroup() グループIDを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getMshost() 接続先メッセージサーバIPアドレスを取得します。
String | getR3name() SAPシステム名称を取得します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClientPool から継承したメソッド
createClient, getConnectionTimeout, getPoolName, getPoolSize, getTimeoutCheckPeriod, getWaitTime, releaseConnection, setClient, setLang, setPasswd, setUser
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientPoolWithLoadBalancing

protected SapClientPoolWithLoadBalancing(String serverType,
                                         String client,
                                         String user,
                                         String passwd,
                                         String lang,
                                         String mshost,
                                         String r3name,
                                         String group,
                                         String poolName,
                                         int poolSize,
                                         long waitTime,
                                         long connectionTimeout,
                                         long timeoutCheckPeriod)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
mshost - 接続先メッセージサーバIPアドレス
r3name - SAPシステム名称
group - グループID
poolName - プール名称
poolSize - プール内のコネクション数
waitTime - コネクション取得の待機時間
connectionTimeout - コネクションのタイムアウト
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔
メソッドの詳細

createPool

protected com.sap.mw.jco.JCO.Pool createPool(SapClientPool sapClientPool)
                                      throws com.sap.mw.jco.JCO.Exception
コネクションプールを生成します。

定義:
クラス SapClientPool 内の createPool
パラメータ:
sapClientPool - SapClientPoolオブジェクト
戻り値:
Pool Poolオブジェクト
例外:
JCO.Exception - JCO例外

getMshost

public String getMshost()
接続先メッセージサーバIPアドレスを取得します。

戻り値:
mshome 設定した接続先メッセージサーバIPアドレス

getR3name

public String getR3name()
SAPシステム名称を取得します。

戻り値:
r3name 設定したSAPシステム名称

getGroup

public String getGroup()
グループIDを取得します。

戻り値:
group 設定したグループID

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
接続先IPアドレス

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClientPool 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapClientWithLoadBalancing (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapClientWithLoadBalancing

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClient
        拡張 jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing
public class SapClientWithLoadBalancing
extends SapClient

SAPClientPoolクラス。
機能は以下の通り。

  • 負荷分散環境にて構築されたSAP APサーバーへ
    ConnectionPool方式を用いた接続を行うクラスです。
  • JCOコネクションプールの生成に必要なメソッドを用意しています。
本クラスのインスタンスは、SapClientManagerから生成することができます。

導入されたバージョン:
6.1
バージョン:
1.0

フィールドの概要
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したフィールド
connection
コンストラクタの概要
protected SapClientWithLoadBalancing(String serverType, String client, String user, String passwd, String lang, String mshost, String r3name, String group)
引数にて受け取った接続情報を属性にセットします。
メソッドの概要
protected com.sap.mw.jco.JCO.Client | createClient() JCOコネクションの生成を行います。
String | getGroup() グループIDを取得します。
String | getHost() 接続先IPアドレスを取得します。
String | getMshost() 接続先メッセージサーバIPアドレスを取得します。
String | getR3name() SAPシステム名称を取得します。
protected void | releaseConnection() 取得したJCOコネクションの開放を行います。
void | setGroup(String group) グループIDを設定します。
void | setMshost(String mshost) 接続先メッセージサーバIPアドレスを設定します。
void | setR3name(String r3name) SAPシステム名称を設定します。
String | toString() デバッグ用のメソッドです。
クラス jp.co.intra_mart.foundation.sap.common.auth.SapClient から継承したメソッド
getClient, getIdentifier, getJCOClient, getLang, getPasswd, getServerType, getUser, release, setClient, setLang, setPasswd, setUser
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapClientWithLoadBalancing

protected SapClientWithLoadBalancing(String serverType,
                                     String client,
                                     String user,
                                     String passwd,
                                     String lang,
                                     String mshost,
                                     String r3name,
                                     String group)
引数にて受け取った接続情報を属性にセットします。

パラメータ:
serverType - サーバータイプ
client - クライアント
user - ユーザー
passwd - パスワード
lang - 言語
mshost - 接続先メッセージサーバIPアドレス
r3name - SAPシステム名称
group - グループID
メソッドの詳細

getMshost

public String getMshost()
接続先メッセージサーバIPアドレスを取得します。

戻り値:
mshome 設定した接続先メッセージサーバIPアドレス

setMshost

public void setMshost(String mshost)
接続先メッセージサーバIPアドレスを設定します。

パラメータ:
mshost - 設定する接続先メッセージサーバIPアドレス

getR3name

public String getR3name()
SAPシステム名称を取得します。

戻り値:
r3name 設定したSAPシステム名称

setR3name

public void setR3name(String r3name)
SAPシステム名称を設定します。

パラメータ:
r3name - 設定するSAPシステム名称

getGroup

public String getGroup()
グループIDを取得します。

戻り値:
group 設定したグループID

setGroup

public void setGroup(String group)
グループIDを設定します。

パラメータ:
group - 設定するグループID

createClient

protected com.sap.mw.jco.JCO.Client createClient()
                                          throws com.sap.mw.jco.JCO.Exception
JCOコネクションの生成を行います。

定義:
クラス SapClient 内の createClient
戻り値:
JCO.Client JCOコネクション
例外:
JCO.Exception - JCO例外

releaseConnection

protected void releaseConnection()
                          throws com.sap.mw.jco.JCO.Exception
取得したJCOコネクションの開放を行います。

定義:
クラス SapClient 内の releaseConnection
例外:
JCO.Exception - JCO例外

getHost

public String getHost()
接続先IPアドレスを取得します。

定義:
クラス SapClient 内の getHost
戻り値:
host 接続先IPアドレス

toString

public String toString()
デバッグ用のメソッドです。

オーバーライド:
クラス SapClient 内の toString
戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapConnector (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapConnector

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapConnector
すべての実装インタフェース:
Serializable
推奨されていません。 本クラスは現在、標準では使用されておりません。
本機能はクラス SapClientManager に置き換えられました。

public class SapConnector
extends Object
implements Serializable

SAPコネクタークラス。
機能は以下の通り。

  • 単一ユーザIDで任意のコネクションプールを作成し、SAPにログインします。
  • 接続先のSAPサーバが複数存在する場合でも、任意のSAPサーバに接続可能です。

関連項目:
直列化された形式

コンストラクタの概要
SapConnector()
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapConnector(String serverType)
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
メソッドの概要
String | getAshost() 推奨されていません。 接続先サーバIPアドレスを取得します｡
String | getClient() 推奨されていません。 クライアントを取得します｡
long | getConnectionTimeout() 推奨されていません。 コネクションのタイムアウトを取得します｡
String | getLang() 推奨されていません。 言語を取得します｡
String | getPasswd() 推奨されていません。 パスワードを取得します｡
String | getPoolName() 推奨されていません。 プール名称を取得します｡
int | getPoolSize() 推奨されていません。 プール内のコネクション数を取得します｡
String | getServerType() 推奨されていません。 サーバタイプを取得します｡
String | getSysnr() 推奨されていません。 システム番号を取得します｡
long | getTimeoutCheckPeriod() 推奨されていません。 コネクションのタイムアウトのチェック間隔を取得します｡
String | getUser() 推奨されていません。 ユーザを取得します｡
long | getWaitTime() 推奨されていません。 コネクション取得の待機時間を取得します｡
static void | releaseConnection(com.sap.mw.jco.JCO.Client connection) 推奨されていません。 コネクションをリリースします。
void | setAshost(String ashost) 推奨されていません。 接続先サーバIPアドレスを設定します｡
void | setClient(String client) 推奨されていません。 クライアントを設定します｡
void | setConnectionTimeout(long connectionTimeout) 推奨されていません。 コネクションのタイムアウトを設定します｡
void | setLang(String lang) 推奨されていません。 言語を設定します｡
void | setPasswd(String passwd) 推奨されていません。 パスワードを設定します｡
void | setPoolName(String poolName) 推奨されていません。 プール名称を設定します｡
void | setPoolSize(int poolSize) 推奨されていません。 プール内のコネクション数を設定します｡
void | setServerType(String serverType) 推奨されていません。 サーバタイプを設定します｡
void | setSysnr(String sysnr) 推奨されていません。 システム番号を設定します｡
void | setTimeoutCheckPeriod(long timeoutCheckPeriod) 推奨されていません。 コネクションのタイムアウトのチェック間隔を設定します｡
void | setUser(String user) 推奨されていません。 ユーザを設定します｡
void | setWaitTime(long waitTime) 推奨されていません。 コネクション取得の待機時間を設定します｡
String | toString() 推奨されていません。 デバッグ用のメソッドです。
com.sap.mw.jco.JCO.Client | useConnection() 推奨されていません。 コネクションを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SapConnector

public SapConnector()
             throws SAPAuthSystemException
推奨されていません。
プロパティファイルを読込み属性に値をセットします。 接続先が１つの場合に使用します。

例外:
SAPAuthSystemException - 認証系システム例外

SapConnector

public SapConnector(String serverType)
             throws SAPAuthAppException,
                    SAPAuthSystemException
推奨されていません。
プロパティファイルを読込み属性に値をセットします。 接続先が複数の場合に使用します。

パラメータ:
serverType - サーバタイプ
例外:
SAPAuthAppException - 認証系アプリケーション例外
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setServerType

public void setServerType(String serverType)
推奨されていません。
サーバタイプを設定します｡

パラメータ:
serverType - サーバタイプ

setClient

public void setClient(String client)
推奨されていません。
クライアントを設定します｡

パラメータ:
client - クライアント

setUser

public void setUser(String user)
推奨されていません。
ユーザを設定します｡

パラメータ:
user - ユーザ

setPasswd

public void setPasswd(String passwd)
推奨されていません。
パスワードを設定します｡

パラメータ:
passwd - パスワード

setLang

public void setLang(String lang)
推奨されていません。
言語を設定します｡

パラメータ:
lang - 言語

setSysnr

public void setSysnr(String sysnr)
推奨されていません。
システム番号を設定します｡

パラメータ:
sysnr - システム番号

setAshost

public void setAshost(String ashost)
推奨されていません。
接続先サーバIPアドレスを設定します｡

パラメータ:
ashost - 接続先サーバIPアドレス

setPoolName

public void setPoolName(String poolName)
推奨されていません。
プール名称を設定します｡

パラメータ:
poolName - プール名称

setPoolSize

public void setPoolSize(int poolSize)
推奨されていません。
プール内のコネクション数を設定します｡

パラメータ:
poolSize - プール内のコネクション数

setWaitTime

public void setWaitTime(long waitTime)
推奨されていません。
コネクション取得の待機時間を設定します｡

パラメータ:
waitTime - コネクション取得の待機時間

setConnectionTimeout

public void setConnectionTimeout(long connectionTimeout)
推奨されていません。
コネクションのタイムアウトを設定します｡

パラメータ:
connectionTimeout - コネクションのタイムアウト

setTimeoutCheckPeriod

public void setTimeoutCheckPeriod(long timeoutCheckPeriod)
推奨されていません。
コネクションのタイムアウトのチェック間隔を設定します｡

パラメータ:
timeoutCheckPeriod - コネクションのタイムアウトのチェック間隔

getServerType

public String getServerType()
推奨されていません。
サーバタイプを取得します｡

戻り値:
serverType

getClient

public String getClient()
推奨されていません。
クライアントを取得します｡

戻り値:
client

getUser

public String getUser()
推奨されていません。
ユーザを取得します｡

戻り値:
user

getPasswd

public String getPasswd()
推奨されていません。
パスワードを取得します｡

戻り値:
passwd

getLang

public String getLang()
推奨されていません。
言語を取得します｡

戻り値:
lang

getSysnr

public String getSysnr()
推奨されていません。
システム番号を取得します｡

戻り値:
sysnr

getAshost

public String getAshost()
推奨されていません。
接続先サーバIPアドレスを取得します｡

戻り値:
ashost

getPoolName

public String getPoolName()
推奨されていません。
プール名称を取得します｡

戻り値:
poolName

getPoolSize

public int getPoolSize()
推奨されていません。
プール内のコネクション数を取得します｡

戻り値:
poolSize

getWaitTime

public long getWaitTime()
推奨されていません。
コネクション取得の待機時間を取得します｡

戻り値:
waitTime

getConnectionTimeout

public long getConnectionTimeout()
推奨されていません。
コネクションのタイムアウトを取得します｡

戻り値:
connectionTimeout

getTimeoutCheckPeriod

public long getTimeoutCheckPeriod()
推奨されていません。
コネクションのタイムアウトのチェック間隔を取得します｡

戻り値:
timeoutCheckPeriod

useConnection

public com.sap.mw.jco.JCO.Client useConnection()
                                        throws SAPAuthSystemException
推奨されていません。
コネクションを生成します。

戻り値:
connection
例外:
SAPAuthSystemException - 認証系システム例外

releaseConnection

public static void releaseConnection(com.sap.mw.jco.JCO.Client connection)
                              throws SAPAuthSystemException
推奨されていません。
コネクションをリリースします。

パラメータ:
connection - コネクション
例外:
SAPAuthSystemException - 認証系システム例外

toString

public String toString()
推奨されていません。
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


SapRepositoryManager (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.auth
クラス SapRepositoryManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
public class SapRepositoryManager
extends Object

JCO.Repository を管理クラス。

SapClient インスタンスから JCO.Repository を返却するメソッド getJCORepository(SapClient)を提供します。
接続設定ファイルで設定されたPool用の各ServerTypeごとに JCO.Repository を管理します。
ただし、以下の場合は都度、新しい JCO.Repository インスタンスを生成し、本インスタンスは管理しません。

  • 引数がSapClientPool又は、SapClientPoolを継承した子クラスのインスタンスでない場合。

メソッドの概要
static com.sap.mw.jco.JCO.Repository getJCORepository(SapClient sapClient)
Repository情報を生成もしくは、取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getJCORepository

public static com.sap.mw.jco.JCO.Repository getJCORepository(SapClient sapClient)
                                                      throws SAPAuthSystemException
Repository情報を生成もしくは、取得します。
・ConnectionPool方式で且つ、プロパティファイル内に定義された接続情報を使用する場合
    キャッシュ内にRepository情報がある場合は、キャッシュよりRepository情報を取得します。
    キャッシュ内にRepository情報がない場合は、Repository情報を生成します。
・ConnectionPool方式で且つ、プロパティファイル内に定義された接続情報を変更した場合
又は、DirectConnection方式を用いたBapiの実行を行う場合
    Repository情報を生成します。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
戻り値:
JCO.Repository 生成及び、取得したRepository情報
例外:
SAPAuthSystemException - 認証系システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.exception.SAPException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.exception.SAPException の使用

SAPException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.common.auth.exception での SAPException のサブクラス
class | SAPAuthAppException 認証系APIアプリケーション例外クラス
class | SAPAuthSystemException 認証系APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.general_purpose.exception での SAPException の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.exception での SAPException のサブクラス
class | SAPGeneralAppException 共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
class | SAPGeneralSystemException 共通API/汎用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException の使用

SAPRuntimeException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.exception

jp.co.intra_mart.foundation.sap.common.exception での SAPRuntimeException の使用

jp.co.intra_mart.foundation.sap.common.exception での SAPRuntimeException のサブクラス
 class UnsupportedProductEditionException
SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException の使用

jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.exception (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.exception
例外
SAPException
SAPRuntimeException
UnsupportedProductEditionException


jp.co.intra_mart.foundation.sap.common.exception (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.exception

例外の概要
SAPException | SAP連携モジュールの基本となる例外クラス。
SAPRuntimeException | SAP連携モジュールの基本となるランタイム例外クラス。
UnsupportedProductEditionException | SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス


jp.co.intra_mart.foundation.sap.common.exception クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
            • class jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException


パッケージ jp.co.intra_mart.foundation.sap.common.exception の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.exception の使用

jp.co.intra_mart.foundation.sap.common.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.exception |
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.auth.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

jp.co.intra_mart.foundation.sap.common.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPRuntimeException
SAP連携モジュールの基本となるランタイム例外クラス。

jp.co.intra_mart.foundation.sap.common.general_purpose.exception により使用される jp.co.intra_mart.foundation.sap.common.exception のクラス
SAPException
SAP連携モジュールの基本となる例外クラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.exception
クラス SAPException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
SAPAuthAppException, SAPAuthSystemException, SAPGeneralAppException, SAPGeneralSystemException
public class SAPException
extends Exception

SAP連携モジュールの基本となる例外クラス。

関連項目:
直列化された形式

コンストラクタの概要
SAPException()
SAP連携モジュール基本例外
SAPException(String message)
SAP連携モジュール基本例外
SAPException(String message, Throwable cause)
SAP連携モジュール基本例外
SAPException(Throwable cause)
SAP連携モジュール基本例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPException

public SAPException()
SAP連携モジュール基本例外

SAPException

public SAPException(String message)
SAP連携モジュール基本例外

パラメータ:
message - エラーメッセージ

SAPException

public SAPException(String message,
                    Throwable cause)
SAP連携モジュール基本例外

パラメータ:
message - エラーメッセージ
cause - 原因となる例外

SAPException

public SAPException(Throwable cause)
SAP連携モジュール基本例外

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPRuntimeException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.exception
クラス SAPRuntimeException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
UnsupportedProductEditionException
public class SAPRuntimeException
extends RuntimeException

SAP連携モジュールの基本となるランタイム例外クラス。

関連項目:
直列化された形式

コンストラクタの概要
SAPRuntimeException()
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String message)
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String message, Throwable cause)
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(Throwable cause)
SAP連携モジュール基本ランタイム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPRuntimeException

public SAPRuntimeException()
SAP連携モジュール基本ランタイム例外

SAPRuntimeException

public SAPRuntimeException(String message)
SAP連携モジュール基本ランタイム例外

パラメータ:
message - エラーメッセージ

SAPRuntimeException

public SAPRuntimeException(String message,
                           Throwable cause)
SAP連携モジュール基本ランタイム例外

パラメータ:
message - エラーメッセージ
cause - 原因となる例外

SAPRuntimeException

public SAPRuntimeException(Throwable cause)
SAP連携モジュール基本ランタイム例外

パラメータ:
cause - 原因となる例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


UnsupportedProductEditionException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.exception
クラス UnsupportedProductEditionException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 java.lang.RuntimeException
                拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
                    拡張 jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException
すべての実装インタフェース:
Serializable
public class UnsupportedProductEditionException
extends SAPRuntimeException

SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス

関連項目:
直列化された形式

コンストラクタの概要
UnsupportedProductEditionException()
コンストラクタ。
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

UnsupportedProductEditionException

public UnsupportedProductEditionException()
コンストラクタ。

SAPリアルタイム連携APIがサポートされていないintra-mart製品で 使用された場合にスローされます。
SAPリアルタイム連携APIを利用できるのは、 intra-mart Enterprise版またはデバックサーバ版のみです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn の使用

BapiReturn を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での BapiReturn の使用

BapiReturn を返す jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 BapiReturn BapiController.getReturn()
ＢＡＰＩ実行結果を取得します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager の使用

ConnectionManager を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での ConnectionManager の使用

ConnectionManager 型のパラメータを持つ jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException の使用

SAPGeneralAppException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
String | LineProperty.getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | BapiController.putImportParam(String key, String val) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
void | BapiController.putStructParam(String key, String val, String structName) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
void | BapiController.putTableParam(String key, String val, String tableName, int recordNo) 引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
void | BapiController.executeBapi() BAPIを実行します。

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.common.util.data での SAPGeneralAppException の使用

SAPGeneralAppException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String ExtendedParamConverter.changeToUpperParam(String param, String propertyName, String paramType)
入力された項目名をプロパティファイルの項目名に変換します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException の使用

SAPGeneralSystemException を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のメソッド
 void ConnectionManager.commit()
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

実行後にコネクションが開放されます。
 void ConnectionManager.rollback()
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

実行後にコネクションが開放されます。
 void BapiController.putImportParam(String key, String val)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
 void BapiController.putStructParam(String key, String val, String structName)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
 void BapiController.putTableParam(String key, String val, String tableName, int recordNo)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
 void BapiController.executeBapi()
BAPIを実行します。
 boolean BapiController.isSuccess()
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List)、 BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。
 String BapiController.getErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。
 String BapiController.getMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
 String BapiController.getMessage(String type)
引数に一致したType情報のメッセージ情報全て取得します。
 String BapiController.getExportParam(String propKey)
export(Export)情報を返します。
 HashMap BapiController.getStructureParam(String paramName)
structure(Export)情報を返します。
 Iterator BapiController.getTableParam(String paramName)
table(Export)情報を返します。
 void BapiController.setAutoCommitConditions(List autoCommitConditions)
推奨されていません。 BapiController.setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
 void BapiController.setIgnoreErrMsgReturnTypes(List ignoreErrMsgReturnTypes)
エラーメッセージを無視するRETURN-TYPEを設定します。

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.general_purpose のコンストラクタ
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

jp.co.intra_mart.foundation.sap.common.util.data での SAPGeneralSystemException の使用

SAPGeneralSystemException をスローする jp.co.intra_mart.foundation.sap.common.util.data のメソッド
static String | ExtendedParamConverter.changeToUpperParam(String param, String propertyName, String paramType) 入力された項目名をプロパティファイルの項目名に変換します。
static String | Convertor.convJCOdata(int typ, int len, Object val) BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.general_purpose.exception
例外
SAPGeneralAppException
SAPGeneralSystemException


jp.co.intra_mart.foundation.sap.common.general_purpose.exception (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

例外の概要
SAPGeneralAppException | 共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException | 共通API/汎用データ取得・追加・更新APIシステム例外クラス

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の説明

ＳＡＰ連携に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.general_purpose.exception クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose.exception の使用

jp.co.intra_mart.foundation.sap.common.general_purpose.exception を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.general_purpose.exception のクラス
SAPGeneralAppException
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralSystemException
共通API/汎用データ取得・追加・更新APIシステム例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPGeneralAppException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralAppException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
すべての実装インタフェース:
Serializable
public class SAPGeneralAppException
extends SAPException

共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralAppException

public SAPGeneralAppException(String message,
                              Throwable ex)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPGeneralAppException

public SAPGeneralAppException(String message)
共通API/汎用データ取得・追加・更新APIアプリケーション例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


SAPGeneralSystemException (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose.exception
クラス SAPGeneralSystemException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.foundation.sap.common.exception.SAPException
                拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
すべての実装インタフェース:
Serializable
public class SAPGeneralSystemException
extends SAPException

共通API/汎用データ取得・追加・更新APIシステム例外クラス

関連項目:
直列化された形式

コンストラクタの概要
SAPGeneralSystemException(String message)
共通API/汎用データ取得・追加・更新APIシステム例外
SAPGeneralSystemException(String message, Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

SAPGeneralSystemException

public SAPGeneralSystemException(String message,
                                 Throwable ex)
共通API/汎用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
ex - 例外

SAPGeneralSystemException

public SAPGeneralSystemException(String message)
共通API/汎用データ取得・追加・更新APIシステム例外

パラメータ:
message - エラーメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiController (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiController

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController
すべての実装インタフェース:
Serializable
public class BapiController
extends Object
implements Serializable

BAPIコントローラクラス。
機能は以下の通り。

  • ソリューション特化型APIにて設定されたBAPI処理実行パラメータを保持し、 BAPI実行時はプロパティファイル設定の内容に従ってJCOパラメータに展開します｡
  • 展開後、BAPI処理を実行し、実行結果を保持する｡ソリューション特化型APIは、 実行結果を当クラスの公開メソッドを使用して取得します｡

バージョン:
1.2
関連項目:
直列化された形式

フィールドの概要
static String[] DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES
エラーメッセージを無視するRETURN-TYPEの設定。
コンストラクタの概要
BapiController(String propertyName)
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String propertyName, ConnectionManager connectionManager)
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String propertyName, SapClient sapClient)
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。
メソッドの概要
 void addAutoCommitCondition(String autoCommitConditon)
推奨されていません。 addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。
 void addIgnoreErrMsgReturnType(String ignoreErrMsgReturnType)
エラーメッセージを無視するRETURN-TYPEを追加します。
 void clear()
セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
 void executeBapi()
BAPIを実行します。
 List getAutoCommitConditions()
推奨されていません。 getIgnoreErrMsgReturnTypes()に置き換えられました。
 ArrayList getBapiHashList()
BapiHashの一覧を取得します。
 ArrayList getBapiReturnList()
BapiReturnの一覧を取得します｡
 String getErrMessage()
ＢＡＰＩの実行結果のエラーメッセージを取得します。
 ArrayList getExpExpList()
プロパティ情報(export(Export))の一覧を取得します｡
 String getExportParam(String propKey)
export(Export)情報を返します。
 ArrayList getExpStrList()
プロパティ情報(structure(Export))の一覧を取得します｡
 ArrayList getExpTblList()
プロパティ情報(table(Export))の一覧を取得します｡
 List getIgnoreErrMsgReturnTypes()
エラーメッセージを無視するRETURN-TYPEを取得します。
 ArrayList getImpImpList()
プロパティ情報(import(Import))の一覧を取得します。
 ArrayList getImpStrList()
プロパティ情報(structure(Import))一覧を取得します。
 ArrayList getImpTblList()
プロパティ情報(table(Import))の一覧を取得します｡
 String getMessage()
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
 String getMessage(String type)
引数に一致したType情報のメッセージ情報全て取得します。
 Properties getProperty()
プロパティファイル情報を取得します。
 String getPropertyName()
プロパティファイル名を取得します。
 BapiReturn getReturn()
ＢＡＰＩ実行結果を取得します。
 Iterator getReturnCodeTypes()
BapiReturn のType情報を取得します。
 Iterator getReturnList()
ＢＡＰＩ実行結果の一覧を取得します。
 HashMap getStructureParam(String paramName)
structure(Export)情報を返します。
 Iterator getTableParam(String paramName)
table(Export)情報を返します。
 boolean isSuccess()
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List)、 addIgnoreErrMsgReturnType(String)でカスタマイズできます。
 void putImportParam(String key, String val)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
 void putStructParam(String key, String val, String structName)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
 void putTableParam(String key, String val, String tableName, int recordNo)
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡
 void setAutoCommitConditions(List autoCommitConditions)
推奨されていません。 setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
 void setBapiHashList(ArrayList bapiHashList)
BapiHashの一覧を設定します｡
 void setBapiReturnList(ArrayList bapiReturnList)
BapiReturnの一覧を設定します｡
 void setExpExpList(ArrayList expExpList)
プロパティ情報(export(Export))の一覧を設定します｡
 void setExpStrList(ArrayList expStrList)
プロパティ情報(structure(Export))の一覧を設定します｡
 void setExpTblList(ArrayList expTblList)
プロパティ情報(table(Export))の一覧を設定します｡
 void setIgnoreErrMsgReturnTypes(List ignoreErrMsgReturnTypes)
エラーメッセージを無視するRETURN-TYPEを設定します。
 void setImpImpList(ArrayList impImpList)
プロパティ情報(import(Import))の一覧を設定します｡
 void setImpStrList(ArrayList impStrList)
プロパティ情報(structure(Import))の一覧を設定します｡
 void setImpTblList(ArrayList impTblList)
プロパティ情報(table(Import))の一覧を設定します｡
 void setProperty(Properties property)
プロパティファイル情報を設定します｡
 void setPropertyName(String propertyName)
プロパティファイル名を設定します｡
 String toString()
デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

フィールドの詳細

DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES

public static final String[] DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES
エラーメッセージを無視するRETURN-TYPEの設定。

エラーメッセージを無視させる BapiReturn のType情報のデフォルト値を "S" または空文字 "" とします。

コンストラクタの詳細

BapiController

public BapiController(String propertyName)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

BapiController

public BapiController(String propertyName,
                      ConnectionManager connectionManager)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
なお、executeBapi()実行後に必ずConnectionManager.commit() またはConnectionManager.rollback()を 実行してください。
上記2メソッド内でSAPへのコネクションの開放も実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

【注意】トランザクション処理が記述されているBAPIもあります。 その場合、executeBapi()実行後にここまでの コネクションマネージャーで実行したすべての処理がcommitまたは rollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
connectionManager - 生成したConnectionManagerオブジェクト
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外

BapiController

public BapiController(String propertyName,
                      SapClient sapClient)
               throws SAPGeneralSystemException,
                      SAPAuthSystemException,
                      SAPGeneralAppException
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。

パラメータ:
propertyName - BAPIコントローラが使用するプロパティファイル名
sapClient - SAPへの接続情報が格納されたオブジェクト
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外
メソッドの詳細

putImportParam

public void putImportParam(String key,
                           String val)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putStructParam

public void putStructParam(String key,
                           String val,
                           String structName)
                    throws SAPGeneralSystemException,
                           SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
structName - BapiHashに設定するparamTypeの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

putTableParam

public void putTableParam(String key,
                          String val,
                          String tableName,
                          int recordNo)
                   throws SAPGeneralSystemException,
                          SAPGeneralAppException
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

パラメータ:
key - BapiHashに設定するHashMapのキー
val - BapiHashに設定するHashMapの値
tableName - BapiHashに設定するparamTypeの値
recordNo - BapiHashに設定するrecordNoの値
例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理

executeBapi

public void executeBapi()
                 throws SAPGeneralSystemException,
                        SAPGeneralAppException,
                        SAPAuthSystemException,
                        SAPAuthAppException
BAPIを実行します。

JCO.Connectionを生成し､JCO.Functionの生成、 BAPI引渡しパラメータの生成を行いBAPI実行を行います｡またBAPI実行結果から BapiHashオブジェクトの生成とBapiHashListへの追加、 BapiReturnオブジェクトの生成とBapiReturnListへの追加を行います｡
なお、このクラスのコンストラクタ呼び出し時にConnectionManagerを指定した場合、 トランザクション処理は自動的に実行されません。呼び出し側で明示的にConnectionManager.commit() またはConnectionManager.rollback()を実行する必要があります。また、SAPとのコネクションも 上記2メソッド内で行われますので、確実に呼び出すように実装しなくてはなりません。

【注意】ConnectionManagerを指定した場合の注意点

トランザクション処理が記述されているBAPIもあります。 その場合、本メソッド実行後にここまでのコネクションマネージャーで実行したすべての処理がcommitまたはrollbackされます。
※ただし、コネクションはリリースされませんので、リリースされるようにConnectionManager.commit()または ConnectionManager.rollback()を実行してください。
この振る舞いを変更するには、BAPI自体をカスタマイズする必要があります。

例外:
SAPGeneralSystemException - 汎用系システム例外処理
SAPAuthSystemException - 認証系システム例外処理
SAPGeneralAppException - 汎用系アプリケーション例外処理
SAPAuthAppException - 認証系アプリケーション例外処理

isSuccess

public boolean isSuccess()
                  throws SAPGeneralSystemException
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List)、 addIgnoreErrMsgReturnType(String)でカスタマイズできます。

戻り値:
bapiSuccess BAPI実行結果
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getErrMessage

public String getErrMessage()
                     throws SAPGeneralSystemException
ＢＡＰＩの実行結果のエラーメッセージを取得します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")以外のBapiReturn オブジェクトのメッセージ情報を全て返します。 全て正常の場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List), addIgnoreErrMsgReturnType(String)でカスタマイズできます。

戻り値:
buffer BAPI実行結果エラーとなった全てのメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getMessage

public String getMessage()
                  throws SAPGeneralSystemException
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。

ＢＡＰＩ実行結果であるBapiReturnのType情報が正常(デフォルト値: "S" / "")と 判断されたType情報のメッセージ情報を全て返します。 メッセージが存在しない場合はnullが返却されます｡ 正常と判断させる条件はプロパティファイル、 またはsetIgnoreErrMsgReturnTypes(List), addIgnoreErrMsgReturnType(String)でカスタマイズできます。

戻り値:
buffer オートコミット条件に一致したType情報のメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getMessage

public String getMessage(String type)
                  throws SAPGeneralSystemException
引数に一致したType情報のメッセージ情報全て取得します。

ＢＡＰＩの実行結果において、引数に一致するType情報のメッセージ情報を全て返します。 メッセージは、以下のように、一致したType情報の各メッセージが MESSAGE1, MESSAGE2と改行文字で区切られた形式になります。

MESSAGE1 : メッセージ1
MESSAGE2 : メッセージ2
:
メッセージがない場合、nullが返却されます｡

引数に指定するType情報は、一般に以下のようになります。
  • S：正常終了
  • W：警告
  • I：情報
  • E：エラー
※上記のType情報は、BAPIに依存します。

パラメータ:
type - エラーコードタイプ
戻り値:
BAPI実行時の全てのメッセージ情報
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getExportParam

public String getExportParam(String propKey)
                      throws SAPGeneralSystemException
export(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名、 プロパティファイルのキー情報で一覧から該当するBapiHashオブジェクト を検索して、値を返します｡

パラメータ:
propKey - 検索条件となるPropertyKey
戻り値:
rtnVal 引数のキーに対応する値
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getStructureParam

public HashMap getStructureParam(String paramName)
                          throws SAPGeneralSystemException
structure(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getTableParam

public Iterator getTableParam(String paramName)
                       throws SAPGeneralSystemException
table(Export)情報を返します。入力／出力区分、パラメータ属性、パラメータ名 で一覧から該当するBapiHashオブジェクトを検索し、一覧に格納して返します｡

パラメータ:
paramName - 検索条件となるParamName
戻り値:
retMap 検索結果となるBapiHash
例外:
SAPGeneralSystemException - 汎用系システム例外処理

getReturnList

public Iterator getReturnList()
ＢＡＰＩ実行結果の一覧を取得します。(Table用)

戻り値:
bapiReturnList

getReturn

public BapiReturn getReturn()
ＢＡＰＩ実行結果を取得します。(Structure用)

戻り値:
bapiRet

getBapiHashList

public ArrayList getBapiHashList()
BapiHashの一覧を取得します。

戻り値:
bapiHashList

getProperty

public Properties getProperty()
プロパティファイル情報を取得します。

戻り値:
property

getPropertyName

public String getPropertyName()
プロパティファイル名を取得します。

戻り値:
propertyName

getImpImpList

public ArrayList getImpImpList()
プロパティ情報(import(Import))の一覧を取得します。

戻り値:
impImpList

getImpStrList

public ArrayList getImpStrList()
プロパティ情報(structure(Import))一覧を取得します。

戻り値:
impStrList

getImpTblList

public ArrayList getImpTblList()
プロパティ情報(table(Import))の一覧を取得します｡

戻り値:
impTblList

getExpExpList

public ArrayList getExpExpList()
プロパティ情報(export(Export))の一覧を取得します｡

戻り値:
expExpList

getExpStrList

public ArrayList getExpStrList()
プロパティ情報(structure(Export))の一覧を取得します｡

戻り値:
expStrList

getExpTblList

public ArrayList getExpTblList()
プロパティ情報(table(Export))の一覧を取得します｡

戻り値:
expTblList

getBapiReturnList

public ArrayList getBapiReturnList()
BapiReturnの一覧を取得します｡

戻り値:
bapiReturnList

setBapiHashList

public void setBapiHashList(ArrayList bapiHashList)
BapiHashの一覧を設定します｡

パラメータ:
bapiHashList - BapiHashList

setProperty

public void setProperty(Properties property)
プロパティファイル情報を設定します｡

パラメータ:
property - Property

setPropertyName

public void setPropertyName(String propertyName)
プロパティファイル名を設定します｡

パラメータ:
propertyName - propertyName

setImpImpList

public void setImpImpList(ArrayList impImpList)
プロパティ情報(import(Import))の一覧を設定します｡

パラメータ:
impImpList - impImpList

setImpStrList

public void setImpStrList(ArrayList impStrList)
プロパティ情報(structure(Import))の一覧を設定します｡

パラメータ:
impStrList - impStrList

setImpTblList

public void setImpTblList(ArrayList impTblList)
プロパティ情報(table(Import))の一覧を設定します｡

パラメータ:
impTblList - impTblList

setExpExpList

public void setExpExpList(ArrayList expExpList)
プロパティ情報(export(Export))の一覧を設定します｡

パラメータ:
expExpList - expExpList

setExpStrList

public void setExpStrList(ArrayList expStrList)
プロパティ情報(structure(Export))の一覧を設定します｡

パラメータ:
expStrList - expStrList

setExpTblList

public void setExpTblList(ArrayList expTblList)
プロパティ情報(table(Export))の一覧を設定します｡

パラメータ:
expTblList - expTblList

setBapiReturnList

public void setBapiReturnList(ArrayList bapiReturnList)
BapiReturnの一覧を設定します｡

パラメータ:
bapiReturnList - bapiReturnList

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値

clear

public void clear()

セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。

BapiControllerを複数回使用する場合、一度putImportParam()などを実行した後に 同じパラメータをセットする前に実行する必要があります。

実行例は次のようになります。

 BapiController bapiController = new BapiController(...);
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

 //クリア
 bapiController.clear();

 //BapiControllerを再利用する
 bapiController.putImportParam(...);
 bapiController.putStructParam(...);
 ...
 executeBapi();

getAutoCommitConditions

public List getAutoCommitConditions()
推奨されていません。 getIgnoreErrMsgReturnTypes()に置き換えられました。

オートコミットさせる条件を取得します。

BapiReturn のType情報に対して、オートコミットさせる文字列からなる条件を取得します。

戻り値:
オートコミットさせる条件(String型の要素からなるListオブジェクト)
導入されたバージョン:
5.1.5

addAutoCommitCondition

public void addAutoCommitCondition(String autoCommitConditon)
推奨されていません。 addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。

オートコミットさせる条件を追加します。

BapiReturn のType情報に対して、オートコミットさせる文字列の条件を設定します。

パラメータ:
autoCommitConditon - オートコミットさせる条件
導入されたバージョン:
5.1.5

setAutoCommitConditions

public void setAutoCommitConditions(List autoCommitConditions)
                             throws SAPGeneralSystemException
推奨されていません。 setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。

オートコミットさせる条件を指定します。

BapiReturn のType情報に対して、オートコミットさせる文字列条件を設定します。 List の要素は文字列 String で登録します。

パラメータ:
autoCommitConditions - オートコミットさせる条件リスト
例外:
SAPGeneralSystemException - 引数にString型以外の要素が 含まれている場合にスローされます。
導入されたバージョン:
5.1.5

getIgnoreErrMsgReturnTypes

public List getIgnoreErrMsgReturnTypes()
エラーメッセージを無視するRETURN-TYPEを取得します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを取得します。

戻り値:
エラーメッセージを無視するRETURN-TYPE値のリスト
導入されたバージョン:
6.0

addIgnoreErrMsgReturnType

public void addIgnoreErrMsgReturnType(String ignoreErrMsgReturnType)
エラーメッセージを無視するRETURN-TYPEを追加します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを設定します。

パラメータ:
ignoreErrMsgReturnType - エラーメッセージを無視するRETURN-TYPE値
導入されたバージョン:
6.0

setIgnoreErrMsgReturnTypes

public void setIgnoreErrMsgReturnTypes(List ignoreErrMsgReturnTypes)
                                throws SAPGeneralSystemException
エラーメッセージを無視するRETURN-TYPEを設定します。

BapiReturn のType情報に対して、エラーメッセージを無視するRETURN-TYPEを設定します。 この設定を変更することで、たとえば警告時にもコミットさせることができます。 List の要素は文字列 String で登録します。

パラメータ:
ignoreErrMsgReturnTypes - エラーメッセージを無視するRETURN-TYPE値のリスト
例外:
SAPGeneralSystemException - 引数にString型以外の要素が 含まれている場合にスローされます。
導入されたバージョン:
6.0

getReturnCodeTypes

public Iterator getReturnCodeTypes()
BapiReturn のType情報を取得します。

BapiReturn のType情報をString型の要素からなる Iteratorオブジェクトを取得します。
BapiReturn のType情報は、一般的に以下となります。
  • S：正常終了
  • W：警告
  • I：情報
  • E：エラー
※上記のBapiReturn のType情報は、BAPIに依存します。

戻り値:
BapiReturn のType情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


BapiHash (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiHash

java.lang.Object
    拡張 java.util.AbstractMap
        拡張 java.util.HashMap
            拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash
すべての実装インタフェース:
Cloneable, Map, Serializable
public class BapiHash
extends HashMap
implements Serializable

BapiHashクラス
機能は以下の通り

  • 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡
  • SAPのBAPI処理にて使用されるパラメータの値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiHash(String impExpType, String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String impExpType, String paramType, String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String impExpType, String paramType, String paramName, int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
メソッドの概要
String | getImpExpType() 入力／出力区分を取得します｡
String | getParamName() パラメタ名を取得します｡
String | getParamType() パラメタ属性を取得します｡
int | getRecordNo() レコード番号を取得します｡
void | setImpExpType(String impExpType) 入力／出力区分を設定します｡
void | setParamName(String paramName) パラメタ名を設定します｡
void | setParamType(String paramType) パラメタ属性を設定します｡
void | setRecordNo(int recordNo) レコード番号を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.util.HashMap から継承したメソッド
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, put, putAll, remove, size, values
クラス java.util.AbstractMap から継承したメソッド
equals, hashCode
クラス java.lang.Object から継承したメソッド
finalize, getClass, notify, notifyAll, wait, wait, wait
インタフェース java.util.Map から継承したメソッド
equals, hashCode

コンストラクタの詳細

BapiHash

public BapiHash(String impExpType,
                String paramType)
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName)
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名

BapiHash

public BapiHash(String impExpType,
                String paramType,
                String paramName,
                int recordNo)
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。

パラメータ:
impExpType - BapiHashの入力／出力区分
paramType - BapiHashのパラメタ属性
paramName - BapiHashのパラメタ名
recordNo - BapiHashのレコード番号
メソッドの詳細

getImpExpType

public String getImpExpType()
入力／出力区分を取得します｡

戻り値:
impExpType

getParamName

public String getParamName()
パラメタ名を取得します｡

戻り値:
paramName

getParamType

public String getParamType()
パラメタ属性を取得します｡

戻り値:
paramType

getRecordNo

public int getRecordNo()
レコード番号を取得します｡

戻り値:
recordNo

setImpExpType

public void setImpExpType(String impExpType)
入力／出力区分を設定します｡

パラメータ:
impExpType - BapiHashの入出力区分

setParamName

public void setParamName(String paramName)
パラメタ名を設定します｡

パラメータ:
paramName - Importのパラメタ名

setParamType

public void setParamType(String paramType)
パラメタ属性を設定します｡

パラメータ:
paramType - Importのパラメタ属性

setRecordNo

public void setRecordNo(int recordNo)
レコード番号を設定します｡

パラメータ:
recordNo - Importのレコード番号

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


BapiReturn (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス BapiReturn

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn
すべての実装インタフェース:
Serializable
public class BapiReturn
extends Object
implements Serializable

BapiReturnクラス
機能は以下の通り

  • SAPのBAPI処理の実行結果に関する値を保持します。
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
BapiReturn(com.sap.mw.jco.JCO.Structure str)
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(com.sap.mw.jco.JCO.Table tbl)
指定されたJCO.Table情報でBapiReturnを作成します。
メソッドの概要
String | getCode() コードを取得します｡
String | getField() フィールドを取得します｡
String | getId() ＩＤを取得します｡
String | getLogMsgNo() ログメッセージナンバーを取得します｡
String | getLogNo() ログナンバーを取得します｡
String | getMessage() メッセージを取得します｡
String | getMessageV1() メッセージＶ１を取得します｡
String | getMessageV2() メッセージＶ２を取得します｡
String | getMessageV3() メッセージＶ３を取得します｡
String | getMessageV4() メッセージＶ４を取得します｡
String | getNumber() ナンバーを取得します｡
String | getParameter() パラメーターを取得します｡
String | getRow() 行番号を取得します｡
String | getSystem() ＩＤを取得します｡
String | getType() タイプを取得します｡
void | setCode(String code) コードを設定します｡
void | setField(String field) フィールドを設定します｡
void | setId(String id) ＩＤを設定します｡
void | setLogMsgNo(String logMsgNo) ログメッセージナンバーを設定します｡
void | setLogNo(String logNo) ログナンバーを設定します｡
void | setMessage(String message) メッセージを設定します｡
void | setMessageV1(String messageV1) メッセージＶ１を設定します｡
void | setMessageV2(String messageV2) メッセージＶ２を設定します｡
void | setMessageV3(String messageV3) メッセージＶ３を設定します｡
void | setMessageV4(String messageV4) メッセージＶ４を設定します｡
void | setNumber(String number) ナンバーを設定します｡
void | setParameter(String parameter) パラメーターを設定します｡
void | setRow(String row) 行番号を設定します｡
void | setSystem(String system) システムを設定します｡
void | setType(String type) タイプを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Structure str)
           throws SAPGeneralSystemException
指定されたJCO.Structure情報でBapiReturnを作成します。 引数のBAPI RETURN(Structure)情報から属性に値をセットします｡

パラメータ:
str - JCO.Structure
例外:
SAPGeneralSystemException - システム例外処理

BapiReturn

public BapiReturn(com.sap.mw.jco.JCO.Table tbl)
           throws SAPGeneralSystemException
指定されたJCO.Table情報でBapiReturnを作成します。 引数のBAPI RETURN(Table)情報から属性に値をセットします｡

パラメータ:
tbl - JCO.Table
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getField

public String getField()
フィールドを取得します｡

戻り値:
field

getId

public String getId()
ＩＤを取得します｡

戻り値:
id

getCode

public String getCode()
コードを取得します｡

戻り値:
code

getLogMsgNo

public String getLogMsgNo()
ログメッセージナンバーを取得します｡

戻り値:
logMsgNo

getLogNo

public String getLogNo()
ログナンバーを取得します｡

戻り値:
logNo

getMessage

public String getMessage()
メッセージを取得します｡

戻り値:
message

getMessageV1

public String getMessageV1()
メッセージＶ１を取得します｡

戻り値:
messageV1

getMessageV2

public String getMessageV2()
メッセージＶ２を取得します｡

戻り値:
messageV2

getMessageV3

public String getMessageV3()
メッセージＶ３を取得します｡

戻り値:
messageV3

getMessageV4

public String getMessageV4()
メッセージＶ４を取得します｡

戻り値:
messageV4

getNumber

public String getNumber()
ナンバーを取得します｡

戻り値:
number

getParameter

public String getParameter()
パラメーターを取得します｡

戻り値:
parameter

getRow

public String getRow()
行番号を取得します｡

戻り値:
row

getSystem

public String getSystem()
ＩＤを取得します｡

戻り値:
tableList

getType

public String getType()
タイプを取得します｡

戻り値:
type

setField

public void setField(String field)
フィールドを設定します｡

パラメータ:
field - BapiReturnのfieldの値

setId

public void setId(String id)
ＩＤを設定します｡

パラメータ:
id - BapiReturnのidの値

setLogMsgNo

public void setLogMsgNo(String logMsgNo)
ログメッセージナンバーを設定します｡

パラメータ:
logMsgNo - BapiReturnのlogMsgNoの値

setLogNo

public void setLogNo(String logNo)
ログナンバーを設定します｡

パラメータ:
logNo - BapiReturnのlogNoの値

setMessage

public void setMessage(String message)
メッセージを設定します｡

パラメータ:
message - BapiReturnのmessageの値

setMessageV1

public void setMessageV1(String messageV1)
メッセージＶ１を設定します｡

パラメータ:
messageV1 - BapiReturnのmessageV1の値

setMessageV2

public void setMessageV2(String messageV2)
メッセージＶ２を設定します｡

パラメータ:
messageV2 - BapiReturnのmessageV2の値

setMessageV3

public void setMessageV3(String messageV3)
メッセージＶ３を設定します｡

パラメータ:
messageV3 - BapiReturnのmessageV3の値

setMessageV4

public void setMessageV4(String messageV4)
メッセージＶ４を設定します｡

パラメータ:
messageV4 - BapiReturnのmessageV4の値

setNumber

public void setNumber(String number)
ナンバーを設定します｡

パラメータ:
number - BapiReturnのnumberの値

setParameter

public void setParameter(String parameter)
パラメーターを設定します｡

パラメータ:
parameter - BapiReturnのparameterの値

setRow

public void setRow(String row)
行番号を設定します｡

パラメータ:
row - BapiReturnのrowの値

setSystem

public void setSystem(String system)
システムを設定します｡

パラメータ:
system - BapiReturnのsystemの値

setType

public void setType(String type)
タイプを設定します｡

パラメータ:
type - BapiReturnのtypeの値

setCode

public void setCode(String code)
コードを設定します｡

パラメータ:
code - BapiReturnのcodeの値

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ConnectionManager (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス ConnectionManager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager
すべての実装インタフェース:
Serializable
public class ConnectionManager
extends Object
implements Serializable

ConnectionManagerクラス。
機能は以下の通り。

SAPへのコネクション(トランザクション)を管理するクラスです。 commitとrollbackの2つのパブリックメソッドを持ち、業務ロジックの最後に実行することで SAPへの変更を確定/取り消しすることができます。
なお、SAPへのコネクションの開放も上記2メソッド内で実行されるので確実にどちらかの メソッドを呼ぶようにコーディングする必要があります。

関連項目:
直列化された形式

コンストラクタの概要
ConnectionManager()
コンストラクタ。
ConnectionManager(SapClient sapClient)
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。
メソッドの概要
void | commit() ＢＡＰＩ実行結果のCOMMIT処理を行います｡ 実行後にコネクションが開放されます。
void | rollback() ＢＡＰＩ実行結果のROLLBACK処理を行います｡ 実行後にコネクションが開放されます。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

ConnectionManager

public ConnectionManager()
コンストラクタ。

ConnectionManager

public ConnectionManager(SapClient sapClient)
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。

パラメータ:
sapClient - SAPへの接続情報が格納されたオブジェクト
メソッドの詳細

commit

public void commit()
            throws SAPGeneralSystemException
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

実行後にコネクションが開放されます。

例外:
SAPGeneralSystemException - 汎用系システム例外処理

rollback

public void rollback()
              throws SAPGeneralSystemException
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

実行後にコネクションが開放されます。

例外:
SAPGeneralSystemException - 汎用系システム例外処理

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


LineProperty (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.general_purpose
クラス LineProperty

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty
すべての実装インタフェース:
Serializable
public class LineProperty
extends Object
implements Serializable

LinePropertyクラス
機能は以下の通り

  • Propertyファイル１行ごとの情報を保持します｡
  • 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

関連項目:
直列化された形式

コンストラクタの概要
LineProperty(String propertyKey, String propertyValue)
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。
メソッドの概要
String[] | getPropertyKeyPart() プロパティのキーを取得します｡
String | getPropertyValue() プロパティの値を取得します｡
String | getSeparateKey(int partIndex) 指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
void | setPropertyKeyPart(String[] propertyKeyPart) プロパティのキーを設定します｡
void | setPropertyValue(String propertyValue) プロパティの値を設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

LineProperty

public LineProperty(String propertyKey,
                    String propertyValue)
             throws SAPGeneralSystemException
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。

パラメータ:
propertyKey - PropertyKey
propertyValue - PropertyValue
例外:
SAPGeneralSystemException - システム例外処理
メソッドの詳細

getSeparateKey

public String getSeparateKey(int partIndex)
                      throws SAPGeneralAppException
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
引数 = 0 の場合：入力／出力区分("import"/"export")
引数 = 1 の場合：パラメータ属性("import(export)"/"structure"/"table")
引数 = 2 の場合：パラメータ名
引数 = 3 の場合：コンポーネント名

パラメータ:
partIndex - propertyKeyPart（分割値の格納用配列）の要素を指定する添字
戻り値:
propertyKeyPart[]
例外:
SAPGeneralAppException - アプリケーション例外処理

getPropertyValue

public String getPropertyValue()
プロパティの値を取得します｡

戻り値:
propertyValue

getPropertyKeyPart

public String[] getPropertyKeyPart()
プロパティのキーを取得します｡

戻り値:
propertyKeyPart

setPropertyValue

public void setPropertyValue(String propertyValue)
プロパティの値を設定します｡

パラメータ:
propertyValue - PropertyValue

setPropertyKeyPart

public void setPropertyKeyPart(String[] propertyKeyPart)
プロパティのキーを設定します｡

パラメータ:
propertyKeyPart - propertyKeyPart

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.general_purpose (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.general_purpose
クラス
BapiController
BapiHash
BapiReturn
ConnectionManager
LineProperty


jp.co.intra_mart.foundation.sap.common.general_purpose (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

ＳＡＰ連携に関するクラスを提供します。

参照:
説明

クラスの概要
BapiController | BAPIコントローラクラス。
BapiHash | BapiHashクラス 機能は以下の通り 汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ SAPのBAPI処理にて使用されるパラメータの値を保持します。
BapiReturn | BapiReturnクラス 機能は以下の通り SAPのBAPI処理の実行結果に関する値を保持します。
ConnectionManager | ConnectionManagerクラス。
LineProperty | LinePropertyクラス 機能は以下の通り Propertyファイル１行ごとの情報を保持します｡ 上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の説明

ＳＡＰ連携に関するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.general_purpose クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose の使用

jp.co.intra_mart.foundation.sap.common.general_purpose を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.general_purpose ＳＡＰ連携に関するクラスを提供します。

jp.co.intra_mart.foundation.sap.common.general_purpose により使用される jp.co.intra_mart.foundation.sap.common.general_purpose のクラス
BapiReturn
BapiReturnクラス
機能は以下の通り
SAPのBAPI処理の実行結果に関する値を保持します。
ConnectionManager
ConnectionManagerクラス。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.model.BankDataInfo の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.model.BankDataInfo の使用

jp.co.intra_mart.foundation.sap.common.model.BankDataInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo の使用

jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo の使用

jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BankDataInfo (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.model
クラス BankDataInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.BankDataInfo
すべての実装インタフェース:
Serializable
public class BankDataInfo
extends Object
implements Serializable

銀行データ情報クラス
機能は以下の通り

  • 銀行データの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
BankDataInfo()
銀行データ情報を作成します。
メソッドの概要
String | getBankAcct() 口座番号を取得します。
String | getBankCtry() 銀行国コードを取得します。
String | getBankKey() 銀行コードを取得します。
String | getBankRef() 銀行詳細の参照詳細を取得します。
String | getCollAuth() フラグ: 回収権限を取得します。
String | getCtrlKey() 預金種別を取得します。
String | getCustomer() 得意先コードを取得します
String | getPartnerBk() 取引先銀行タイプを取得します。
String | getVendor() 仕入先または債権者の勘定コードを取得します。
void | setBankAcct(String strBankAcct) 口座番号を設定します。
void | setBankCtry(String strBankCtry) 銀行国コードを設定します。
void | setBankKey(String strBankKey) 銀行コードを設定します。
void | setBankRef(String strBankRef) 銀行詳細の参照詳細を設定します。
void | setCollAuth(String strCollAuth) フラグ: 回収権限を設定します。
void | setCtrlKey(String strCtrlKey) 預金種別を設定します。
void | setCustomer(String string) 得意先コードを設定します
void | setPartnerBk(String strPartnerBk) 取引先銀行タイプを設定します。
void | setVendor(String strVendor) 仕入先または債権者の勘定コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

BankDataInfo

public BankDataInfo()
銀行データ情報を作成します。

メソッドの詳細

getVendor

public String getVendor()
仕入先または債権者の勘定コードを取得します。

戻り値:
ｓｔｒVendor

getBankCtry

public String getBankCtry()
銀行国コードを取得します。

戻り値:
ｓｔｒBankCtry

getBankKey

public String getBankKey()
銀行コードを取得します。

戻り値:
ｓｔｒBankKey

getBankAcct

public String getBankAcct()
口座番号を取得します。

戻り値:
ｓｔｒBankAcct

getCtrlKey

public String getCtrlKey()
預金種別を取得します。

戻り値:
ｓｔｒCtrlKey

getPartnerBk

public String getPartnerBk()
取引先銀行タイプを取得します。

戻り値:
ｓｔｒPartnerBk

getCollAuth

public String getCollAuth()
フラグ: 回収権限を取得します。

戻り値:
ｓｔｒCollAuth

getBankRef

public String getBankRef()
銀行詳細の参照詳細を取得します。

戻り値:
ｓｔｒBankRef

setVendor

public void setVendor(String strVendor)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendor - 仕入先または債権者の勘定コード

setBankCtry

public void setBankCtry(String strBankCtry)
銀行国コードを設定します。

パラメータ:
strBankCtry - 銀行国コード

setBankKey

public void setBankKey(String strBankKey)
銀行コードを設定します。

パラメータ:
strBankKey - 銀行コード

setBankAcct

public void setBankAcct(String strBankAcct)
口座番号を設定します。

パラメータ:
strBankAcct - 口座番号

setCtrlKey

public void setCtrlKey(String strCtrlKey)
預金種別を設定します。

パラメータ:
strCtrlKey - 預金種別

setPartnerBk

public void setPartnerBk(String strPartnerBk)
取引先銀行タイプを設定します。

パラメータ:
strPartnerBk - 取引先銀行タイプ

setCollAuth

public void setCollAuth(String strCollAuth)
フラグ: 回収権限を設定します。

パラメータ:
strCollAuth - フラグ: 回収権限

setBankRef

public void setBankRef(String strBankRef)
銀行詳細の参照詳細を設定します。

パラメータ:
strBankRef - 銀行詳細の参照詳細

getCustomer

public String getCustomer()
得意先コードを取得します

戻り値:
得意先コード

setCustomer

public void setCustomer(String string)
得意先コードを設定します

パラメータ:
string - 得意先コード

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


CompanyDataInfo (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.model
クラス CompanyDataInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo
すべての実装インタフェース:
Serializable
public class CompanyDataInfo
extends Object
implements Serializable

会社コード依存データ情報クラス
機能は以下の通り

  • 会社コード依存データの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
CompanyDataInfo()
会社コード依存データ情報を作成します。
メソッドの概要
String | getActAtCus() 得意先での自社勘定コードを取得します。
String | getActAtVen() 仕入先での自社勘定コードを取得します。
String | getAltPayee() 代理受取人勘定コードを取得します。
String | getAltPayer() 代理支払人の勘定コードを取得します。
String | getBuyingGrp() 購買グループの勘定コードを取得します。
String | getClerk() 記帳担当者を取得します。
String | getCompCode() 会社コードを取得します。
String | getCustomer() 得意先コードを取得します
String | getCustUser() 得意先担当者を取得します。
String | getCuvdClear() フラグ: 得意先と仕入先間の相殺決済を取得します。
String | getFax() 得意先/仕入先の経理担当者のファックス No.を取得します。
String | getHdOffice() 本店勘定コードを取得します。
String | getInternet() 関係会社担当者のインターネットアドレスを取得します。
String | getNextPayee() 次受取人を取得します。
String | getPaymentMethods() 考慮される支払方法一覧を取得します。
String | getPmnttrms() 支払条件キーを取得します。
String | getTel() 取引先での記帳担当者電話番号を取得します。
String | getVendor() 仕入先または債権者の勘定コードを取得します。
String | getVendUser() 仕入先担当者を取得します。
void | setActAtCus(String string) 得意先での自社勘定コードを設定します。
void | setActAtVen(String strActAtVen) 仕入先での自社勘定コードを設定します。
void | setAltPayee(String strAltPayee) 代理受取人勘定コードを設定します。
void | setAltPayer(String string) 代理支払人の勘定コードを設定します。
void | setBuyingGrp(String string) 購買グループの勘定コードを設定します。
void | setClerk(String strClerk) 記帳担当者を設定します。
void | setCompCode(String strCompCode) 会社コードを設定します。
void | setCustomer(String string) 得意先コードを設定します
void | setCustUser(String string) 得意先担当者を設定します。
void | setCuvdClear(String strCuvdClear) フラグ: 得意先と仕入先間の相殺決済を設定します。
void | setFax(String strFax) 得意先/仕入先の経理担当者のファックス No.を設定します。
void | setHdOffice(String strHdOffice) 本店勘定コードを設定します。
void | setInternet(String strInternet) 関係会社担当者のインターネットアドレスを設定します。
void | setNextPayee(String string) 次受取人を設定します。
void | setPaymentMethods(String strPaymentMethods) 考慮される支払方法一覧を設定します。
void | setPmnttrms(String strPmnttrms) 支払条件キーを設定します。
void | setTel(String strTel) 取引先での記帳担当者電話番号を設定します。
void | setVendor(String strVendor) 仕入先または債権者の勘定コードを設定します。
void | setVendUser(String strVendUser) 仕入先担当者を設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

CompanyDataInfo

public CompanyDataInfo()
会社コード依存データ情報を作成します。

メソッドの詳細

getVendor

public String getVendor()
仕入先または債権者の勘定コードを取得します。

戻り値:
strVendor

getCompCode

public String getCompCode()
会社コードを取得します。

戻り値:
strCompCode

getClerk

public String getClerk()
記帳担当者を取得します。

戻り値:
strClerk

getHdOffice

public String getHdOffice()
本店勘定コードを取得します。

戻り値:
strHdOffice

getAltPayee

public String getAltPayee()
代理受取人勘定コードを取得します。

戻り値:
strAltPayee

getCuvdClear

public String getCuvdClear()
フラグ: 得意先と仕入先間の相殺決済を取得します。

戻り値:
strCuvdClear

getPmnttrms

public String getPmnttrms()
支払条件キーを取得します。

戻り値:
strPmnttrms

getActAtVen

public String getActAtVen()
仕入先での自社勘定コードを取得します。

戻り値:
strActAtVen

getVendUser

public String getVendUser()
仕入先担当者を取得します。

戻り値:
strVendUser

getInternet

public String getInternet()
関係会社担当者のインターネットアドレスを取得します。

戻り値:
strInternet

getFax

public String getFax()
得意先/仕入先の経理担当者のファックス No.を取得します。

戻り値:
strFax

getPaymentMethods

public String getPaymentMethods()
考慮される支払方法一覧を取得します。

戻り値:
strPaymentMethods

getTel

public String getTel()
取引先での記帳担当者電話番号を取得します。

戻り値:
strTel

setVendor

public void setVendor(String strVendor)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendor - 仕入先または債権者の勘定コード

setCompCode

public void setCompCode(String strCompCode)
会社コードを設定します。

パラメータ:
strCompCode - 会社コード

setClerk

public void setClerk(String strClerk)
記帳担当者を設定します。

パラメータ:
strClerk - 記帳担当者

setHdOffice

public void setHdOffice(String strHdOffice)
本店勘定コードを設定します。

パラメータ:
strHdOffice - 本店勘定コード

setAltPayee

public void setAltPayee(String strAltPayee)
代理受取人勘定コードを設定します。

パラメータ:
strAltPayee - 代理受取人勘定コード

setCuvdClear

public void setCuvdClear(String strCuvdClear)
フラグ: 得意先と仕入先間の相殺決済を設定します。

パラメータ:
strCuvdClear - フラグ: 得意先と仕入先間の相殺決済

setPmnttrms

public void setPmnttrms(String strPmnttrms)
支払条件キーを設定します。

パラメータ:
strPmnttrms - 支払条件キー

setActAtVen

public void setActAtVen(String strActAtVen)
仕入先での自社勘定コードを設定します。

パラメータ:
strActAtVen - 仕入先での自社勘定コード

setVendUser

public void setVendUser(String strVendUser)
仕入先担当者を設定します。

パラメータ:
strVendUser - 仕入先担当者

setInternet

public void setInternet(String strInternet)
関係会社担当者のインターネットアドレスを設定します。

パラメータ:
strInternet - 関係会社担当者のインターネットアドレス

setFax

public void setFax(String strFax)
得意先/仕入先の経理担当者のファックス No.を設定します。

パラメータ:
strFax - 得意先/仕入先の経理担当者のファックス No.

setPaymentMethods

public void setPaymentMethods(String strPaymentMethods)
考慮される支払方法一覧を設定します。

パラメータ:
strPaymentMethods - 考慮される支払方法一覧

setTel

public void setTel(String strTel)
取引先での記帳担当者電話番号を設定します。

パラメータ:
strTel - 取引先での記帳担当者電話番号

getCustomer

public String getCustomer()
得意先コードを取得します

戻り値:
得意先コード

setCustomer

public void setCustomer(String string)
得意先コードを設定します

パラメータ:
string - 得意先コード

getActAtCus

public String getActAtCus()
得意先での自社勘定コードを取得します。

戻り値:
得意先での自社勘定コード

getAltPayer

public String getAltPayer()
代理支払人の勘定コードを取得します。

戻り値:
代理支払人の勘定コード

getBuyingGrp

public String getBuyingGrp()
購買グループの勘定コードを取得します。

戻り値:
購買グループの勘定コード

getNextPayee

public String getNextPayee()
次受取人を取得します。

戻り値:
次受取人

setActAtCus

public void setActAtCus(String string)
得意先での自社勘定コードを設定します。

パラメータ:
string - 得意先での自社勘定コード

setAltPayer

public void setAltPayer(String string)
代理支払人の勘定コードを設定します。

パラメータ:
string - 代理支払人の勘定コード

setBuyingGrp

public void setBuyingGrp(String string)
購買グループの勘定コードを設定します。

パラメータ:
string - 購買グループの勘定コード

setNextPayee

public void setNextPayee(String string)
次受取人を設定します。

パラメータ:
string - 次受取人

getCustUser

public String getCustUser()
得意先担当者を取得します。

戻り値:
得意先担当者

setCustUser

public void setCustUser(String string)
得意先担当者を設定します。

パラメータ:
string - 得意先担当者

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


GeneralDataInfo (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.model
クラス GeneralDataInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo
すべての実装インタフェース:
Serializable
public class GeneralDataInfo
extends Object
implements Serializable

一般データ情報クラス
機能は以下の通り

  • 一般データの情報を保持します。

関連項目:
直列化された形式

コンストラクタの概要
GeneralDataInfo()
一般データ情報を作成します。
メソッドの概要
String | getCity() 市区町村を取得します。
String | getCityCode() 市区町村コードを取得します
String | getCountry() 国コードを取得します。
String | getCountryiso() ISO 国コードを取得します。
String | getCountycode() 地域コードを取得します
String | getCustomer() 得意先コードを取得します
String | getDistrict() 所在地を取得します。
String | getFax1() FAX 1を取得します｡
String | getFormofaddr() 敬称を取得します。
String | getLangu() 言語キーを取得します。
String | getLanguIso() ISO 639 準拠の言語を取得します。
String | getName_2() 名称 2を取得します。
String | getName_3() 名称 3を取得します。
String | getName_4() 名称 4を取得します。
String | getName() 名称 1を取得します。
String | getPoBox() 私書箱を取得します。
String | getPobxCty() 私書箱住所を取得します。
String | getPobxPcd() 私書箱番号を取得します。
String | getPostlCode() 郵便番号を取得します。
String | getRegion() 地域 (都道府県)を取得します。
String | getStreet() 地名/番地-号を取得します。
String | getTelephone() 電話番号 1を取得します。
String | getTelephone2() 電話番号 2を取得します。
String | getVendor() 仕入先または債権者の勘定コードを取得します。
void | setCity(String strCity) 市区町村を設定します。
void | setCityCode(String string) 市区町村コードを設定します
void | setCountry(String strCountry) 国コードを設定します。
void | setCountryiso(String strCountryiso) ISO 国コードを設定します。
void | setCountycode(String string) 地域コードを設定します
void | setCustomer(String string) 得意先コードを設定します
void | setDistrict(String strDistrict) 所在地を設定します。
void | setFax1(String strFax1) FAX 1を設定します｡
void | setFormofaddr(String strFormofaddr) 敬称を設定します。
void | setLangu(String strLangu) 言語キーを設定します。
void | setLanguIso(String strLanguIso) ISO 639 準拠の言語を設定します。
void | setName_2(String strName2) 名称 2を設定します。
void | setName_3(String strName3) 名称 3を設定します。
void | setName_4(String strName4) 名称 4を設定します。
void | setName(String strName) 名称 1を設定します。
void | setPoBox(String strPoBox) 私書箱を設定します。
void | setPobxCty(String strPobxCty) 私書箱住所を設定します。
void | setPobxPcd(String strPobxPcd) 私書箱番号を設定します。
void | setPostlCode(String strPostlCode) 郵便番号を設定します。
void | setRegion(String strRegion) 地域 (都道府県)を設定します。
void | setStreet(String strStreet) 地名/番地-号を設定します。
void | setTelephone(String strTelephone) 電話番号 1を設定します。
void | setTelephone2(String strTelephone2) 電話番号 2を設定します。
void | setVendor(String strVendor) 仕入先または債権者の勘定コードを設定します。
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

GeneralDataInfo

public GeneralDataInfo()
一般データ情報を作成します。

メソッドの詳細

getVendor

public String getVendor()
仕入先または債権者の勘定コードを取得します。

戻り値:
ｓｔｒVendor

getName

public String getName()
名称 1を取得します。

戻り値:
ｓｔｒName

getName_2

public String getName_2()
名称 2を取得します。

戻り値:
ｓｔｒName2

getName_3

public String getName_3()
名称 3を取得します。

戻り値:
ｓｔｒName3

getName_4

public String getName_4()
名称 4を取得します。

戻り値:
ｓｔｒName4

getCity

public String getCity()
市区町村を取得します。

戻り値:
ｓｔｒCity

getDistrict

public String getDistrict()
所在地を取得します。

戻り値:
ｓｔｒDistrict

getPoBox

public String getPoBox()
私書箱を取得します。

戻り値:
ｓｔｒPoBox

getPobxPcd

public String getPobxPcd()
私書箱番号を取得します。

戻り値:
ｓｔｒPobxPcd

getPostlCode

public String getPostlCode()
郵便番号を取得します。

戻り値:
ｓｔｒPostlCode

getRegion

public String getRegion()
地域 (都道府県)を取得します。

戻り値:
ｓｔｒRegion

getStreet

public String getStreet()
地名/番地-号を取得します。

戻り値:
ｓｔｒStreet

getCountry

public String getCountry()
国コードを取得します。

戻り値:
ｓｔｒCountry

getCountryiso

public String getCountryiso()
ISO 国コードを取得します。

戻り値:
ｓｔｒCountryiso

getPobxCty

public String getPobxCty()
私書箱住所を取得します。

戻り値:
ｓｔｒPobxCty

getLangu

public String getLangu()
言語キーを取得します。

戻り値:
ｓｔｒLangu

getLanguIso

public String getLanguIso()
ISO 639 準拠の言語を取得します。

戻り値:
ｓｔｒLanguIso

getTelephone

public String getTelephone()
電話番号 1を取得します。

戻り値:
ｓｔｒTelephone

getFormofaddr

public String getFormofaddr()
敬称を取得します。

戻り値:
ｓｔｒFormofaddr

getTelephone2

public String getTelephone2()
電話番号 2を取得します。

戻り値:
ｓｔｒTelephone2

getFax1

public String getFax1()
FAX 1を取得します｡

戻り値:
strFax1

setVendor

public void setVendor(String strVendor)
仕入先または債権者の勘定コードを設定します。

パラメータ:
strVendor - 仕入先または債権者の勘定コード

setName

public void setName(String strName)
名称 1を設定します。

パラメータ:
strName - 名称 1

setName_2

public void setName_2(String strName2)
名称 2を設定します。

パラメータ:
strName2 - 名称 2

setName_3

public void setName_3(String strName3)
名称 3を設定します。

パラメータ:
strName3 - 名称 3

setName_4

public void setName_4(String strName4)
名称 4を設定します。

パラメータ:
strName4 - 名称 4

setCity

public void setCity(String strCity)
市区町村を設定します。

パラメータ:
strCity - 市区町村

setDistrict

public void setDistrict(String strDistrict)
所在地を設定します。

パラメータ:
strDistrict - 所在地

setPoBox

public void setPoBox(String strPoBox)
私書箱を設定します。

パラメータ:
strPoBox - 私書箱

setPobxPcd

public void setPobxPcd(String strPobxPcd)
私書箱番号を設定します。

パラメータ:
strPobxPcd - 私書箱番号

setPostlCode

public void setPostlCode(String strPostlCode)
郵便番号を設定します。

パラメータ:
strPostlCode - 郵便番号

setRegion

public void setRegion(String strRegion)
地域 (都道府県)を設定します。

パラメータ:
strRegion - 地域 (都道府県)

setStreet

public void setStreet(String strStreet)
地名/番地-号を設定します。

パラメータ:
strStreet - 地名/番地-号

setCountry

public void setCountry(String strCountry)
国コードを設定します。

パラメータ:
strCountry - 国コード

setCountryiso

public void setCountryiso(String strCountryiso)
ISO 国コードを設定します。

パラメータ:
strCountryiso - SO 国コード

setPobxCty

public void setPobxCty(String strPobxCty)
私書箱住所を設定します。

パラメータ:
strPobxCty - 私書箱住所

setLangu

public void setLangu(String strLangu)
言語キーを設定します。

パラメータ:
strLangu - 言語キー

setLanguIso

public void setLanguIso(String strLanguIso)
ISO 639 準拠の言語を設定します。

パラメータ:
strLanguIso - ISO 639 準拠の言語

setTelephone

public void setTelephone(String strTelephone)
電話番号 1を設定します。

パラメータ:
strTelephone - 電話番号 1

setFormofaddr

public void setFormofaddr(String strFormofaddr)
敬称を設定します。

パラメータ:
strFormofaddr - 敬称

setTelephone2

public void setTelephone2(String strTelephone2)
電話番号 2を設定します。

パラメータ:
strTelephone2 - 電話番号 2

setFax1

public void setFax1(String strFax1)
FAX 1を設定します｡

パラメータ:
strFax1 - FAX 1

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値

getCityCode

public String getCityCode()
市区町村コードを取得します

戻り値:
市区町村コード

getCountycode

public String getCountycode()
地域コードを取得します

戻り値:
地域コード

getCustomer

public String getCustomer()
得意先コードを取得します

戻り値:
得意先コード

setCityCode

public void setCityCode(String string)
市区町村コードを設定します

パラメータ:
string - 市区町村コード

setCountycode

public void setCountycode(String string)
地域コードを設定します

パラメータ:
string - 地域コード

setCustomer

public void setCustomer(String string)
得意先コードを設定します

パラメータ:
string - 得意先コード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.model (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.model
クラス
BankDataInfo
CompanyDataInfo
GeneralDataInfo


jp.co.intra_mart.foundation.sap.common.model (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.model

クラスの概要
BankDataInfo | 銀行データ情報クラス 機能は以下の通り 銀行データの情報を保持します。
CompanyDataInfo | 会社コード依存データ情報クラス 機能は以下の通り 会社コード依存データの情報を保持します。
GeneralDataInfo | 一般データ情報クラス 機能は以下の通り 一般データの情報を保持します。


jp.co.intra_mart.foundation.sap.common.model クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.model の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.model の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.model の使用

jp.co.intra_mart.foundation.sap.common.model はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の使用

jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.Convertor の使用

jp.co.intra_mart.foundation.sap.common.util.data.Convertor はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の使用

jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の使用

ParamConverter を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.util.data ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.util.data での ParamConverter の使用

jp.co.intra_mart.foundation.sap.common.util.data での ParamConverter のサブクラス
 class ExtendedParamConverter
共通APIのパラメータ変換クラス２。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Convertor (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス Convertor

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.Convertor
すべての実装インタフェース:
Serializable
public final class Convertor
extends Object
implements Serializable

Converterクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static String convJCOdata(int typ, int len, Object val)
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

convJCOdata

public static String convJCOdata(int typ,
                                 int len,
                                 Object val)
                          throws SAPGeneralSystemException
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。それ以外のパラメータ属性の場合は無変換で 文字列を返します｡
ただし、valがnullの場合、nullを返却します。

パラメータ:
typ - 設定する項目の属性
len - 設定する項目の項目長
val - 変換対象オブジェクト
戻り値:
retVal 変換後文字列
例外:
SAPGeneralSystemException - システム例外処理
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ExtendedParamConverter (im_sap_connect 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス ExtendedParamConverter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter
        拡張 jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter
すべての実装インタフェース:
Serializable
public final class ExtendedParamConverter
extends ParamConverter
implements Serializable

共通APIのパラメータ変換クラス２。
機能は以下の通り。

  • 共通APIのパラメータの項目、値を変換します。

関連項目:
直列化された形式

メソッドの概要
static String | changeParam(String param) 入力された項目名を変換します。
static String | changeToUpperParam(String param, String propertyName, String paramType) 入力された項目名をプロパティファイルの項目名に変換します。
static boolean | ioInvoke(Object obj, String paramName, String value, PropertyDescriptor[] props) パラメータ名からsetterメソッドを取得し、値をセットします。
クラス jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter から継承したメソッド
changeToUpperParam, checkFlg, checkNull
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

changeParam

public static String changeParam(String param)
入力された項目名を変換します。
例）COMP_CODE → compCode

ParamConverterのchangeParamとの相違点は以下の通り。

例）COMP_CODE2（Bapi項目名に数字が含まれている場合）。
ParamConverterの場合　 COMP_CODE2 → compCode_2
ParamConverter2の場合　COMP_CODE2 → compCode2

パラメータ:
param - 入力された項目名
戻り値:
string 変換された項目名

ioInvoke

public static boolean ioInvoke(Object obj,
                               String paramName,
                               String value,
                               PropertyDescriptor[] props)
パラメータ名からsetterメソッドを取得し、値をセットします。

ParamConverterのioInvokeとの相違点は以下の通り。

例）COMP_CODE2（Bapi項目名に数字が含まれている場合）
ParamConverterの場合　 COMP_CODE2 → setCompCode_2
ParamConverter2の場合　COMP_CODE2 → setCompCode2

パラメータ:
obj - 項目をセットするオブジェクト
paramName - 項目名
value - セットする値
props - プロパティ情報
戻り値:
boolean セット可否

changeToUpperParam

public static String changeToUpperParam(String param,
                                        String propertyName,
                                        String paramType)
                                 throws SAPAuthSystemException,
                                        SAPGeneralSystemException,
                                        SAPGeneralAppException
入力された項目名をプロパティファイルの項目名に変換します。

ParamConverterのchangeToUpperParamとの相違点は以下の通り。

ParamConverterの場合 文字操作による文字変換
ParamConverter2の場合 プロパティファイルの項目名へ文字変換

パラメータ:
param - String 変換する項目名
propertyName - String 検索するプロパティファイル名
paramType - String 検索するパラメータ属性(structure)
戻り値:
string 変換された項目名
例外:
SAPAuthSystemException
SAPAuthSystemException
SAPGeneralSystemException
SAPGeneralAppException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.data (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.data
クラス
Convertor
ExtendedParamConverter
ParamConverter


jp.co.intra_mart.foundation.sap.common.util.data (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

ＳＡＰ連携にて使用するデータ変換クラスを提供します。

参照:
説明

クラスの概要
Convertor | Converterクラス 機能は以下の通り SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。
ExtendedParamConverter | 共通APIのパラメータ変換クラス２。
ParamConverter | パラメータ変換クラス 機能は以下の通り パラメータの項目、値を変換します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の説明

ＳＡＰ連携にて使用するデータ変換クラスを提供します。


jp.co.intra_mart.foundation.sap.common.util.data クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.util.data の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.data の使用

jp.co.intra_mart.foundation.sap.common.util.data を使用しているパッケージ
jp.co.intra_mart.foundation.sap.common.util.data ＳＡＰ連携にて使用するデータ変換クラスを提供します。

jp.co.intra_mart.foundation.sap.common.util.data により使用される jp.co.intra_mart.foundation.sap.common.util.data のクラス
ParamConverter
パラメータ変換クラス
機能は以下の通り
パラメータの項目、値を変換します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ParamConverter (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.data
クラス ParamConverter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter
すべての実装インタフェース:
Serializable
直系の既知のサブクラス:
ExtendedParamConverter
public class ParamConverter
extends Object
implements Serializable

パラメータ変換クラス
機能は以下の通り

  • パラメータの項目、値を変換します。

関連項目:
直列化された形式

コンストラクタの概要
protected ParamConverter()
ParamConvertorのコンストラクタを呼び出し
メソッドの概要
static String | changeParam(String param) 入力された項目名を変換します。
static String | changeToUpperParam(String param) 入力された項目名を変換します。
static String | checkFlg(String param) 項目に値が入っているかチェックします。
static String | checkNull(String string) 項目がnullかどうかチェックします。
static boolean | ioInvoke(Object obj, String paramName, String value, PropertyDescriptor[] props) パラメータ名からsetterメソッドを取得し、値をセットします。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ParamConverter

protected ParamConverter()
ParamConvertorのコンストラクタを呼び出し

メソッドの詳細

checkNull

public static String checkNull(String string)
項目がnullかどうかチェックします。

パラメータ:
string - 項目の値
戻り値:
string 値有：X 値無：ブランク

checkFlg

public static String checkFlg(String param)
項目に値が入っているかチェックします。

パラメータ:
param - 項目の値
戻り値:
string 値有：X 値無：ブランク

changeParam

public static String changeParam(String param)
入力された項目名を変換します。 例）COMP_CODE → compCode

パラメータ:
param - 入力された項目名
戻り値:
string 変換された項目名

changeToUpperParam

public static String changeToUpperParam(String param)
入力された項目名を変換します。 例）compCode → COMP_CODE

パラメータ:
param - 入力された項目名
戻り値:
string 変換された項目名

ioInvoke

public static boolean ioInvoke(Object obj,
                               String paramName,
                               String value,
                               PropertyDescriptor[] props)
パラメータ名からsetterメソッドを取得し、値をセットします。

パラメータ:
obj - 項目をセットするオブジェクト
paramName - 項目名
value - セットする値
props - プロパティ情報
戻り値:
boolean セット可否
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の使用

jp.co.intra_mart.foundation.sap.common.util.date.DateHandler はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DateHandler (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.date
クラス DateHandler

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.date.DateHandler
すべての実装インタフェース:
Serializable
public final class DateHandler
extends Object
implements Serializable

DateHandlerクラス
機能は以下の通り

  • SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

関連項目:
直列化された形式

メソッドの概要
static Date | getDateValue(String strValue) 日付書式[YYYYMMDD]の文字列をDate型に変換します。
static String | getStringDate(Date date) Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
static String | getSysdate() システム日付を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getSysdate

public static String getSysdate()
システム日付を取得します。

戻り値:
nowDate システム日付[YYYYMMDD]

getStringDate

public static String getStringDate(Date date)
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。

パラメータ:
date - 日付書式変換前Date型オブジェクト
戻り値:
date 日付書式変換後文字列[YYYYMMDD]

getDateValue

public static Date getDateValue(String strValue)
                         throws ParseException
日付書式[YYYYMMDD]の文字列をDate型に変換します。

パラメータ:
strValue - 日付書式[YYYYMMDD]の文字列
戻り値:
dateValue Date型に変換後の値
例外:
ParseException - 日付変換システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util.date (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.date
クラス
DateHandler


jp.co.intra_mart.foundation.sap.common.util.date (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

ＳＡＰ連携にて使用する日付操作クラスを提供します。

参照:
説明

クラスの概要
DateHandler DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の説明

ＳＡＰ連携にて使用する日付操作クラスを提供します。


jp.co.intra_mart.foundation.sap.common.util.date クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.date の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.util.date の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.date の使用

jp.co.intra_mart.foundation.sap.common.util.date はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile の使用

jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.file (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.file
クラス
PropertiesFile


jp.co.intra_mart.foundation.sap.common.util.file (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。

参照:
説明

クラスの概要
PropertiesFile プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の説明

ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。


jp.co.intra_mart.foundation.sap.common.util.file クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.file の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)


パッケージ jp.co.intra_mart.foundation.sap.common.util.file の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.file の使用

jp.co.intra_mart.foundation.sap.common.util.file はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertiesFile (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.file
クラス PropertiesFile

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile
すべての実装インタフェース:
Serializable
public class PropertiesFile
extends Object
implements Serializable

プロパティファイルクラス
機能は以下の通り

  • ファイル名を指定してプロパティファイルを呼び出します。

関連項目:
直列化された形式

コンストラクタの概要
PropertiesFile(String fileName)
ファイル名を指定してプロパティファイルを取得します。
メソッドの概要
Properties | getProperties() プロパティを取得します｡
void | setPropeties(Properties properties) プロパティを設定します｡
String | toString() デバッグ用のメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

PropertiesFile

public PropertiesFile(String fileName)
               throws SAPAuthSystemException
ファイル名を指定してプロパティファイルを取得します。

パラメータ:
fileName - ファイル名
例外:
SAPAuthSystemException - 認証系システム例外
メソッドの詳細

setPropeties

public void setPropeties(Properties properties)
プロパティを設定します｡

パラメータ:
properties - プロパティ

getProperties

public Properties getProperties()
プロパティを取得します｡

戻り値:
properties

toString

public String toString()
デバッグ用のメソッドです。

戻り値:
value すべての属性の値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の使用

jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.message (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util.message
クラス
SAPConnectorMessageBundle


jp.co.intra_mart.foundation.sap.common.util.message (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.message

クラスの概要
SAPConnectorMessageBundle SAPリアルタイム連携APIメッセージリソースクラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.sap.common.util.message クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util.message の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.sap.common.util.message の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util.message の使用

jp.co.intra_mart.foundation.sap.common.util.message はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SAPConnectorMessageBundle (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util.message
クラス SAPConnectorMessageBundle

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle
public class SAPConnectorMessageBundle
extends Object

SAPリアルタイム連携APIメッセージリソースクラス

メソッドの概要
static String | getMessage(Locale locale, String key) SAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String[] args) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(Locale locale, String key, String arg1, String arg2, String arg3) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key) SAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String arg) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String[] args) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
static String | getMessage(String key, String arg1, String arg2, String arg3) 置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getMessage

public static String getMessage(Locale locale,
                                String key)
SAPリアルタイム連携APIメッセージを取得します。

パラメータ:
locale - ロケール
key - メッセージID
戻り値:
SAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
arg3 - 置換文字列3
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(Locale locale,
                                String key,
                                String[] args)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
locale - ロケール
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key)
SAPリアルタイム連携APIメッセージを取得します。

パラメータ:
key - メッセージID
戻り値:
SAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String arg)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg - 置換文字列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String arg1,
                                String arg2,
                                String arg3)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
arg1 - 置換文字列1
arg2 - 置換文字列2
arg3 - 置換文字列3
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ

getMessage

public static String getMessage(String key,
                                String[] args)
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。

置換文字列の挿入は MessageFormat.format(java.lang.String, java.lang.Object[])に準じます。

パラメータ:
key - メッセージID
args - 置換文字列の配列
戻り値:
置換文字列を挿入したSAPリアルタイム連携APIメッセージ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.sap.common.util (im_sap_connect 6.1.14 API)

 jp.co.intra_mart.foundation.sap.common.util
クラス
PropertyDescriptorBox


jp.co.intra_mart.foundation.sap.common.util (im_sap_connect 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util

クラスの概要
PropertyDescriptorBox JavaBeansクラスから取得するPropertyDescriptorをキャッシュするためのクラスです。


jp.co.intra_mart.foundation.sap.common.util クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.sap.common.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox


パッケージ jp.co.intra_mart.foundation.sap.common.util の使用 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.sap.common.util の使用

jp.co.intra_mart.foundation.sap.common.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


PropertyDescriptorBox (im_sap_connect 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.sap.common.util
クラス PropertyDescriptorBox

java.lang.Object
    拡張 jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox
public class PropertyDescriptorBox
extends Object

JavaBeansクラスから取得するPropertyDescriptorをキャッシュするためのクラスです。

メソッドの概要
static void | clear() キャッシュしたPropertyDescriptorをクリアします。
static PropertyDescriptor[] | getPropertyDescriptor(Object beanObject) 引数JavaBeansオブジェクトのPropertyDescriptor[]を取得します。
static PropertyDescriptor[] | getPropertyDescriptor(String beanClassPath) 引数JavaBeansクラス名からPropertyDescriptor[]を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

getPropertyDescriptor

public static PropertyDescriptor[] getPropertyDescriptor(String beanClassPath)
                                                  throws IntrospectionException,
                                                         ClassNotFoundException
引数JavaBeansクラス名からPropertyDescriptor[]を取得します。

パラメータ:
beanClassPath - JavaBeansクラス名
戻り値:
引数beanClassPathで指定したJavaBeansクラス名のPropertyDescriptor[]
例外:
IntrospectionException - イントロスペクション中に例外が発生した場合にスローされます。
ClassNotFoundException - 引数で指定したクラスが見つからない場合にスローされます。

getPropertyDescriptor

public static PropertyDescriptor[] getPropertyDescriptor(Object beanObject)
                                                  throws IntrospectionException
引数JavaBeansオブジェクトのPropertyDescriptor[]を取得します。

パラメータ:
beanObject - PropertyDescriptor[]を取得したい BeanObject
戻り値:
引数JavaBeansオブジェクトのPropertyDescriptor[]
例外:
IntrospectionException - イントロスペクション中に例外が発生した場合にスローされます。

clear

public static void clear()
キャッシュしたPropertyDescriptorをクリアします。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (im_sap_connect 6.1.14 API)

 すべてのクラス
BankDataInfo
BapiController
BapiHash
BapiReturn
CompanyDataInfo
ConnectionManager
Convertor
DateHandler
ExtendedParamConverter
GeneralDataInfo
LineProperty
ParamConverter
PropertiesFile
PropertyDescriptorBox
SAPAuthAppException
SAPAuthSystemException
SAPConnectorMessageBundle
SAPException
SAPGeneralAppException
SAPGeneralSystemException
SAPRuntimeException
SapAuthInfoBundle
SapClient
SapClientManager
SapClientNoLoadBalancing
SapClientPool
SapClientPoolManager
SapClientPoolNoLoadBalancing
SapClientPoolWithLoadBalancing
SapClientWithLoadBalancing
SapConnector
SapRepositoryManager
UnsupportedProductEditionException


定数フィールド値 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないクラス
jp.co.intra_mart.foundation.sap.common.auth.SapConnector
本クラスは現在、標準では使用されておりません。
本機能はクラス SapClientManager に置き換えられました。

推奨されていないメソッド
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.addAutoCommitCondition(String)
BapiController.addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.getAutoCommitConditions()
BapiController.getIgnoreErrMsgReturnTypes()に置き換えられました。
jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.setAutoCommitConditions(List)
BapiController.setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし
A B C D E G H I J L P R S T U

A

addAutoCommitCondition(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
推奨されていません。 BapiController.addIgnoreErrMsgReturnType(java.lang.String)に置き換えられました。
addIgnoreErrMsgReturnType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
エラーメッセージを無視するRETURN-TYPEを追加します。

B

BankDataInfo - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo.
銀行データ情報クラス
機能は以下の通り
銀行データの情報を保持します。
BankDataInfo() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のコンストラクタ
銀行データ情報を作成します。
BapiController - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController.
BAPIコントローラクラス。
BapiController(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
プロパティファイル名のメンバ変数への設定、プロパティファイルの読込と 各PropertyListの生成処理を行います｡
BapiController(String, ConnectionManager) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
コネクションマネージャのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

ConnectionManagerを使用することで、 ConnectionManagerからトランザクションを制御でき、 たとえば同一トランザクション内で複数の登録・更新処理を実行することができます。
BapiController(String, SapClient) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のコンストラクタ
サップクライアントのセット、プロパティファイル名のメンバ変数への設定、 プロパティファイルの読込と各PropertyListの生成処理を行います｡

SapClientを使用することで、SapClientにて指定した SAPアプリケーションサーバ接続が可能となります。
BapiHash - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash.
BapiHashクラス
機能は以下の通り
汎用モジュールAPIを呼び出すソリューション特化型APIが、BAPIを実行する為に 使用するパラメータ値を設定する｡ SAPのBAPI処理にて使用されるパラメータの値を保持します。
BapiHash(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
指定された入力／出力区分、パラメータ属性でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"import" / "export"の場合に使用します｡ パラメータ名は""が設定されます｡
BapiHash(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名でBapiHashオブジェクトを生成します｡ このコンストラクタはパラメタ属性が"structure"の場合に使用します。
BapiHash(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のコンストラクタ
入力／出力区分、パラメータ属性、パラメータ名、レコード番号でBapiHash オブジェクトを生成します｡このコンストラクタはパラメタ属性が"table"の場合 に使用します。
BapiReturn - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn.
BapiReturnクラス
機能は以下の通り
SAPのBAPI処理の実行結果に関する値を保持します。
BapiReturn(JCO.Structure) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Structure情報でBapiReturnを作成します。
BapiReturn(JCO.Table) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のコンストラクタ
指定されたJCO.Table情報でBapiReturnを作成します。

C

CompanyDataInfo - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo.
会社コード依存データ情報クラス
機能は以下の通り
会社コード依存データの情報を保持します。
CompanyDataInfo() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のコンストラクタ
会社コード依存データ情報を作成します。
ConnectionManager - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager.
ConnectionManagerクラス。
ConnectionManager() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のコンストラクタ
コンストラクタ。
ConnectionManager(SapClient) - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のコンストラクタ
受け取ったサップクライアントに格納されている接続情報を 用いて、SAPへの接続を行います。
Convertor - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor.
Converterクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用するデータ変換機能を提供します。
changeParam(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の static メソッド
入力された項目名を変換します。
changeParam(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
入力された項目名を変換します。
changeToUpperParam(String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の static メソッド
入力された項目名をプロパティファイルの項目名に変換します。
changeToUpperParam(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
入力された項目名を変換します。
checkFlg(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
項目に値が入っているかチェックします。
checkNull(String) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
項目がnullかどうかチェックします。
clear() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
セットしたパラメータ、ストラクチャ、テーブル、BAPIの実行結果をクリアします。
clear() - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の static メソッド
キャッシュしたPropertyDescriptorをクリアします。
commit() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のCOMMIT処理を行います｡

実行後にコネクションが開放されます。
connection - class jp.co.intra_mart.foundation.sap.common.auth.SapClient の変数
JCOコネクション
convJCOdata(int, int, Object) - class jp.co.intra_mart.foundation.sap.common.util.data.Convertor の static メソッド
BAPIパラメータに設定する値でパラメータ属性が"JCO.TYPE_NUM"の場合は 0パディングした文字列を返します。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの生成を行う為の抽象メソッドです。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
JCOコネクションの生成を行います。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
JCOコネクションの生成を行います。
createClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
JCOコネクションの生成を行います。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
JCOコネクションプールを生成します。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の static メソッド
コネクションプール方式を用いて、JCOコネクションの取得を行います。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
コネクションプールを生成します。
createPool(SapClientPool) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
コネクションプールを生成します。

D

DEFAULT_IGNORE_ERR_MSG_RETURN_TYPES - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController の static 変数
エラーメッセージを無視するRETURN-TYPEの設定。
DateHandler - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler.
DateHandlerクラス
機能は以下の通り
SAPリアルタイム連携APIにて使用する共通Date関連機能を提供します。

E

ExtendedParamConverter - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter.
共通APIのパラメータ変換クラス２。
executeBapi() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BAPIを実行します。

G

GeneralDataInfo - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo.
一般データ情報クラス
機能は以下の通り
一般データの情報を保持します。
GeneralDataInfo() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のコンストラクタ
一般データ情報を作成します。
getActAtCus() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先での自社勘定コードを取得します。
getActAtVen() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先での自社勘定コードを取得します。
getAltPayee() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理受取人勘定コードを取得します。
getAltPayer() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理支払人の勘定コードを取得します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
接続先アプリケーションサーバIPアドレスを取得します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
接続先サーバIPアドレスを取得します。
getAshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 接続先サーバIPアドレスを取得します｡
getAutoCommitConditions() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
推奨されていません。 BapiController.getIgnoreErrMsgReturnTypes()に置き換えられました。
getBankAcct() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
口座番号を取得します。
getBankCtry() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行国コードを取得します。
getBankKey() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行コードを取得します。
getBankRef() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行詳細の参照詳細を取得します。
getBapiHashList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を取得します。
getBapiReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を取得します｡
getBuyingGrp() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
購買グループの勘定コードを取得します。
getCity() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村を取得します。
getCityCode() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村コードを取得します
getClerk() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
記帳担当者を取得します。
getClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
クライアントを取得します。
getClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 クライアントを取得します｡
getCode() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを取得します｡
getCollAuth() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
フラグ: 回収権限を取得します。
getCompCode() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
会社コードを取得します。
getConnectionTimeout() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
コネクションのタイムアウト時間を取得します。
getConnectionTimeout() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトを取得します｡
getCountry() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
国コードを取得します。
getCountryiso() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 国コードを取得します。
getCountycode() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域コードを取得します
getCtrlKey() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
預金種別を取得します。
getCustUser() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先担当者を取得します。
getCustomer() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
得意先コードを取得します
getCustomer() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先コードを取得します
getCustomer() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
得意先コードを取得します
getCuvdClear() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
フラグ: 得意先と仕入先間の相殺決済を取得します。
getDateValue(String) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
日付書式[YYYYMMDD]の文字列をDate型に変換します。
getDistrict() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
所在地を取得します。
getErrMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩの実行結果のエラーメッセージを取得します。
getExpExpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を取得します｡
getExpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を取得します｡
getExpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を取得します｡
getExportParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
export(Export)情報を返します。
getFax() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先/仕入先の経理担当者のファックス No.を取得します。
getFax1() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
FAX 1を取得します｡
getField() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを取得します｡
getFormofaddr() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
敬称を取得します。
getGroup() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
グループIDを取得します。
getGroup() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
グループIDを取得します。
getHdOffice() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
本店勘定コードを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
接続先IPアドレスを取得する為の抽象メソッド

getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
接続先IPアドレスを取得します。
getHost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
接続先IPアドレスを取得します。
getId() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getIdentifier() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
コネクションの識別子を取得します。
getIgnoreErrMsgReturnTypes() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
エラーメッセージを無視するRETURN-TYPEを取得します。
getImpExpType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を取得します｡
getImpImpList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を取得します。
getImpStrList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))一覧を取得します。
getImpTblList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を取得します｡
getInternet() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
関係会社担当者のインターネットアドレスを取得します。
getJCOClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの取得を行います。
getJCORepository(SapClient) - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager の static メソッド
Repository情報を生成もしくは、取得します。
getLang() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
言語を取得します。
getLang() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 言語を取得します｡
getLangu() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
言語キーを取得します。
getLanguIso() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 639 準拠の言語を取得します。
getLogMsgNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを取得します｡
getLogNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを取得します｡
getMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
設定されたエラーメッセージを無視するRETURN-TYPE情報に一致したメッセージ情報を全て返します。
getMessage(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に一致したType情報のメッセージ情報全て取得します。
getMessage() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを取得します｡
getMessage(Locale, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
SAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(Locale, String, String[]) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
SAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessage(String, String[]) - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle の static メソッド
置換文字列を挿入したSAPリアルタイム連携APIメッセージを取得します。
getMessageV1() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を取得します｡
getMessageV2() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を取得します｡
getMessageV3() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を取得します｡
getMessageV4() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を取得します｡
getMshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
接続先メッセージサーバIPアドレスを取得します。
getMshost() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
接続先メッセージサーバIPアドレスを取得します。
getName() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 1を取得します。
getName_2() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 2を取得します。
getName_3() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 3を取得します。
getName_4() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 4を取得します。
getNextPayee() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
次受取人を取得します。
getNumber() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを取得します｡
getParamName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を取得します｡
getParamType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を取得します｡
getParameter() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを取得します｡
getPartnerBk() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
取引先銀行タイプを取得します。
getPasswd() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
パスワードを取得します。
getPasswd() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 パスワードを取得します｡
getPaymentMethods() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
考慮される支払方法一覧を取得します。
getPmnttrms() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
支払条件キーを取得します。
getPoBox() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱を取得します。
getPobxCty() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱住所を取得します。
getPobxPcd() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱番号を取得します。
getPoolName() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
プール名称を取得します。
getPoolName() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール名称を取得します｡
getPoolSize() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
プール内のコネクション数を取得します。
getPoolSize() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール内のコネクション数を取得します｡
getPostlCode() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
郵便番号を取得します。
getProperties() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを取得します｡
getProperty(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の static メソッド
引数で指定されたプロパティの値を返却します。
getProperty(String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle の static メソッド
引数で指定されたプロパティの値を返却します。
getProperty() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を取得します。
getPropertyDescriptor(String) - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の static メソッド
引数JavaBeansクラス名からPropertyDescriptor[]を取得します。
getPropertyDescriptor(Object) - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox の static メソッド
引数JavaBeansオブジェクトのPropertyDescriptor[]を取得します。
getPropertyKeyPart() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを取得します｡
getPropertyName() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を取得します。
getPropertyValue() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を取得します｡
getR3name() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
SAPシステム名称を取得します。
getR3name() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
SAPシステム名称を取得します。
getRecordNo() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を取得します｡
getRegion() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域 (都道府県)を取得します。
getReturn() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果を取得します。
getReturnCodeTypes() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturn のType情報を取得します。
getReturnList() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行結果の一覧を取得します。
getRow() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を取得します｡
getSapClient() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の static メソッド
接続情報初期値を保持したSAPクライアントオブジェクトの取得を行います。
getSapClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager の static メソッド
引数にて受け取ったサーバータイプに紐付く接続情報初期値を保持した SAPクライアントオブジェクトを取得します。
getSeparateKey(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
指定された添字に該当するプロパティファイルのキー情報（配列）の要素を 返します。
getServerType() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
設定されているサーバータイプを取得します。
getServerType() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 サーバタイプを取得します｡
getStreet() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地名/番地-号を取得します。
getStringDate(Date) - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
Date型オブジェクトを日付書式[YYYYMMDD]の文字列に変換して返します。
getStructureParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
structure(Export)情報を返します。
getSysdate() - class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler の static メソッド
システム日付を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
システム番号を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
システム番号を取得します。
getSysnr() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 システム番号を取得します｡
getSystem() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを取得します｡
getTableParam(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
table(Export)情報を返します。
getTel() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
取引先での記帳担当者電話番号を取得します。
getTelephone() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 1を取得します。
getTelephone2() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 2を取得します。
getTimeoutCheckPeriod() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
コネクションのタイムアウトのチェック間隔を取得します。
getTimeoutCheckPeriod() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトのチェック間隔を取得します｡
getType() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを取得します｡
getUser() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
ユーザーを取得します。
getUser() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 ユーザを取得します｡
getVendUser() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先担当者を取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
仕入先または債権者の勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先または債権者の勘定コードを取得します。
getVendor() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
仕入先または債権者の勘定コードを取得します。
getWaitTime() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
コネクション取得の待機時間を取得します。
getWaitTime() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクション取得の待機時間を取得します｡

H

hasPool(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager の static メソッド
コネクションプール内に、引数にて渡されたJCOコネクション名が存在しているか判定します。

I

ioInvoke(Object, String, String, PropertyDescriptor[]) - class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter の static メソッド
パラメータ名からsetterメソッドを取得し、値をセットします。
ioInvoke(Object, String, String, PropertyDescriptor[]) - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter の static メソッド
パラメータ名からsetterメソッドを取得し、値をセットします。
isSuccess() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
ＢＡＰＩ実行が正常に行われたか判定します｡

ＢＡＰＩ実行結果であるBapiReturndのType情報が 正常(デフォルト値: "S" / "")であった場合"true"をそれ以外は"false"を返します｡ 正常と判断させる条件はプロパティファイル、 またはBapiController.setIgnoreErrMsgReturnTypes(List)、 BapiController.addIgnoreErrMsgReturnType(String)でカスタマイズできます。

J

jp.co.intra_mart.foundation.sap.common.auth - package jp.co.intra_mart.foundation.sap.common.auth
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception - package jp.co.intra_mart.foundation.sap.common.auth.exception
ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.exception - package jp.co.intra_mart.foundation.sap.common.exception
jp.co.intra_mart.foundation.sap.common.general_purpose - package jp.co.intra_mart.foundation.sap.common.general_purpose
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception - package jp.co.intra_mart.foundation.sap.common.general_purpose.exception
ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.model - package jp.co.intra_mart.foundation.sap.common.model
jp.co.intra_mart.foundation.sap.common.util - package jp.co.intra_mart.foundation.sap.common.util
jp.co.intra_mart.foundation.sap.common.util.data - package jp.co.intra_mart.foundation.sap.common.util.data
ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date - package jp.co.intra_mart.foundation.sap.common.util.date
ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file - package jp.co.intra_mart.foundation.sap.common.util.file
ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.message - package jp.co.intra_mart.foundation.sap.common.util.message

L

LineProperty - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty.
LinePropertyクラス
機能は以下の通り
Propertyファイル１行ごとの情報を保持します｡
上記のインスタンス変数の設定と取得のためにアクセサ・メソッドを提供します。
LineProperty(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のコンストラクタ
指定されたプロパティファイルのキー情報と値でLinePropertyオブジェクト を生成します。

P

ParamConverter - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter.
パラメータ変換クラス
機能は以下の通り
パラメータの項目、値を変換します。
ParamConverter() - class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter のコンストラクタ
ParamConvertorのコンストラクタを呼び出し
PropertiesFile - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile.
プロパティファイルクラス
機能は以下の通り
ファイル名を指定してプロパティファイルを呼び出します。
PropertiesFile(String) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のコンストラクタ
ファイル名を指定してプロパティファイルを取得します。
PropertyDescriptorBox - class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox.
JavaBeansクラスから取得するPropertyDescriptorをキャッシュするためのクラスです。
putImportParam(String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="import")を生成し､一覧に格納します｡
putStructParam(String, String, String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="structure",パラメタ名=第３引数)を生成し､一覧に格納します｡
putTableParam(String, String, String, int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
引数に指定された条件でBapiHashオブジェクト(入力／出力区分="import", パラメタ属性="table",パラメタ名=第３引数,レコード番号=第４引数)を生成し､ 一覧に格納します｡

R

release() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの開放を行います。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
JCOコネクションの開放をを行う為の抽象メソッドです。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
取得したJCOコネクションの開放を行います。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
JCOコネクションの開放を行います。
releaseConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
取得したJCOコネクションの開放を行います。
releaseConnection(JCO.Client) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector の static メソッド
推奨されていません。 コネクションをリリースします。
rollback() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
ＢＡＰＩ実行結果のROLLBACK処理を行います｡

実行後にコネクションが開放されます。

S

SAPAuthAppException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException.
認証系APIアプリケーション例外クラス
SAPAuthAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthAppException(String) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException のコンストラクタ
認証系APIアプリケーション例外
SAPAuthSystemException - exception jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException.
認証系APIシステム例外クラス
SAPAuthSystemException(String) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException のコンストラクタ
認証系APIシステム例外
SAPAuthSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException のコンストラクタ
認証系APIシステム例外
SAPConnectorMessageBundle - class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle.
SAPリアルタイム連携APIメッセージリソースクラス
SAPException - exception jp.co.intra_mart.foundation.sap.common.exception.SAPException.
SAP連携モジュールの基本となる例外クラス。
SAPException() - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPException(String) - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPException(Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPException のコンストラクタ
SAP連携モジュール基本例外
SAPGeneralAppException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException.
共通API/汎用データ取得・追加・更新APIアプリケーション例外クラス
SAPGeneralAppException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralAppException(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException のコンストラクタ
共通API/汎用データ取得・追加・更新APIアプリケーション例外
SAPGeneralSystemException - exception jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException.
共通API/汎用データ取得・追加・更新APIシステム例外クラス
SAPGeneralSystemException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException のコンストラクタ
共通API/汎用データ取得・追加・更新APIシステム例外
SAPGeneralSystemException(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException のコンストラクタ
共通API/汎用データ取得・追加・更新APIシステム例外
SAPRuntimeException - exception jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException.
SAP連携モジュールの基本となるランタイム例外クラス。
SAPRuntimeException() - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String) - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(String, Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SAPRuntimeException(Throwable) - class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException のコンストラクタ
SAP連携モジュール基本ランタイム例外
SapAuthInfoBundle - class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle.
接続情報初期値取得クラス。
SapClient - class jp.co.intra_mart.foundation.sap.common.auth.SapClient.
SAPクライアント抽象クラス。
SapClient(String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientManager - class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager.
SAPクライアントマネージャークラス。
SapClientNoLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing.
SapClientNoLoadBalancingクラス。
SapClientNoLoadBalancing(String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientPool - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool.
SAPClientPoolクラス。
SapClientPool(String, String, String, String, String, String, int, long, long, long) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientPoolManager - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager.
SAPクライアントプールマネージャークラス。
SapClientPoolNoLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing.
SAPClientPoolクラス。
SapClientPoolNoLoadBalancing(String, String, String, String, String, String, String, String, int, long, long, long) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientPoolWithLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing.
SAPClientPoolクラス。
SapClientPoolWithLoadBalancing(String, String, String, String, String, String, String, String, String, int, long, long, long) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapClientWithLoadBalancing - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing.
SAPClientPoolクラス。
SapClientWithLoadBalancing(String, String, String, String, String, String, String, String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のコンストラクタ
引数にて受け取った接続情報を属性にセットします。
SapConnector - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector.
推奨されていません。 本クラスは現在、標準では使用されておりません。
本機能はクラス SapClientManager に置き換えられました。
SapConnector() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapConnector(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のコンストラクタ
推奨されていません。 プロパティファイルを読込み属性に値をセットします。
SapRepositoryManager - class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager.
JCO.Repository を管理クラス。
setActAtCus(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先での自社勘定コードを設定します。
setActAtVen(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先での自社勘定コードを設定します。
setAltPayee(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理受取人勘定コードを設定します。
setAltPayer(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
代理支払人の勘定コードを設定します。
setAshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
接続先アプリケーションサーバIPアドレスを設定します。
setAshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 接続先サーバIPアドレスを設定します｡
setAutoCommitConditions(List) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
推奨されていません。 BapiController.setIgnoreErrMsgReturnTypes(java.util.List)に置き換えられました。
setBankAcct(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
口座番号を設定します。
setBankCtry(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行国コードを設定します。
setBankKey(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行コードを設定します。
setBankRef(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
銀行詳細の参照詳細を設定します。
setBapiHashList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiHashの一覧を設定します｡
setBapiReturnList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
BapiReturnの一覧を設定します｡
setBuyingGrp(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
購買グループの勘定コードを設定します。
setCity(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村を設定します。
setCityCode(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
市区町村コードを設定します
setClerk(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
記帳担当者を設定します。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
クライアントを設定します。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
クライアントを設定します。
setClient(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 クライアントを設定します｡
setCode(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
コードを設定します｡
setCollAuth(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
フラグ: 回収権限を設定します。
setCompCode(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
会社コードを設定します。
setConnectionTimeout(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトを設定します｡
setCountry(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
国コードを設定します。
setCountryiso(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 国コードを設定します。
setCountycode(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域コードを設定します
setCtrlKey(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
預金種別を設定します。
setCustUser(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先担当者を設定します。
setCustomer(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
得意先コードを設定します
setCustomer(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先コードを設定します
setCustomer(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
得意先コードを設定します
setCuvdClear(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
フラグ: 得意先と仕入先間の相殺決済を設定します。
setDistrict(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
所在地を設定します。
setExpExpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(export(Export))の一覧を設定します｡
setExpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Export))の一覧を設定します｡
setExpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Export))の一覧を設定します｡
setFax(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
得意先/仕入先の経理担当者のファックス No.を設定します。
setFax1(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
FAX 1を設定します｡
setField(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
フィールドを設定します｡
setFormofaddr(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
敬称を設定します。
setGroup(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
グループIDを設定します。
setHdOffice(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
本店勘定コードを設定します。
setId(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ＩＤを設定します｡
setIgnoreErrMsgReturnTypes(List) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
エラーメッセージを無視するRETURN-TYPEを設定します。
setImpExpType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
入力／出力区分を設定します｡
setImpImpList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(import(Import))の一覧を設定します｡
setImpStrList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(structure(Import))の一覧を設定します｡
setImpTblList(ArrayList) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティ情報(table(Import))の一覧を設定します｡
setInternet(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
関係会社担当者のインターネットアドレスを設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
言語を設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
言語を設定します。
setLang(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 言語を設定します｡
setLangu(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
言語キーを設定します。
setLanguIso(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
ISO 639 準拠の言語を設定します。
setLogMsgNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログメッセージナンバーを設定します｡
setLogNo(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ログナンバーを設定します｡
setMessage(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージを設定します｡
setMessageV1(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ１を設定します｡
setMessageV2(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ２を設定します｡
setMessageV3(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ３を設定します｡
setMessageV4(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
メッセージＶ４を設定します｡
setMshost(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
接続先メッセージサーバIPアドレスを設定します。
setName(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 1を設定します。
setName_2(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 2を設定します。
setName_3(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 3を設定します。
setName_4(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
名称 4を設定します。
setNextPayee(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
次受取人を設定します。
setNumber(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
ナンバーを設定します｡
setParamName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ名を設定します｡
setParamType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
パラメタ属性を設定します｡
setParameter(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
パラメーターを設定します｡
setPartnerBk(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
取引先銀行タイプを設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
パスワードを設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
パスワードを設定します。
setPasswd(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 パスワードを設定します｡
setPaymentMethods(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
考慮される支払方法一覧を設定します。
setPmnttrms(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
支払条件キーを設定します。
setPoBox(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱を設定します。
setPobxCty(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱住所を設定します。
setPobxPcd(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
私書箱番号を設定します。
setPoolName(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール名称を設定します｡
setPoolSize(int) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 プール内のコネクション数を設定します｡
setPostlCode(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
郵便番号を設定します。
setProperty(Properties) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル情報を設定します｡
setPropertyKeyPart(String[]) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティのキーを設定します｡
setPropertyName(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
プロパティファイル名を設定します｡
setPropertyValue(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
プロパティの値を設定します｡
setPropeties(Properties) - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
プロパティを設定します｡
setR3name(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
SAPシステム名称を設定します。
setRecordNo(int) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
レコード番号を設定します｡
setRegion(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地域 (都道府県)を設定します。
setRow(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
行番号を設定します｡
setServerType(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 サーバタイプを設定します｡
setStreet(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
地名/番地-号を設定します。
setSysnr(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
システム番号を設定します。
setSysnr(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 システム番号を設定します｡
setSystem(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
システムを設定します｡
setTel(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
取引先での記帳担当者電話番号を設定します。
setTelephone(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 1を設定します。
setTelephone2(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
電話番号 2を設定します。
setTimeoutCheckPeriod(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションのタイムアウトのチェック間隔を設定します｡
setType(String) - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
タイプを設定します｡
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
ユーザーを設定します。
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
ユーザーを設定します。
setUser(String) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 ユーザを設定します｡
setVendUser(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先担当者を設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
仕入先または債権者の勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
仕入先または債権者の勘定コードを設定します。
setVendor(String) - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
仕入先または債権者の勘定コードを設定します。
setWaitTime(long) - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクション取得の待機時間を設定します｡

T

toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClient のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo のメソッド
デバッグ用のメソッドです。
toString() - class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile のメソッド
デバッグ用のメソッドです。

U

UnsupportedProductEditionException - exception jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException.
SAPリアルタイム連携APIがサポートされていないintra-mart製品で使用された場合にスローされる例外クラス
UnsupportedProductEditionException() - class jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException のコンストラクタ
コンストラクタ。
useConnection() - class jp.co.intra_mart.foundation.sap.common.auth.SapConnector のメソッド
推奨されていません。 コネクションを生成します。
A B C D E G H I J L P R S T U
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


im_sap_connect 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (im_sap_connect 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.sap.common.auth
jp.co.intra_mart.foundation.sap.common.auth.exception
jp.co.intra_mart.foundation.sap.common.exception
jp.co.intra_mart.foundation.sap.common.general_purpose
jp.co.intra_mart.foundation.sap.common.general_purpose.exception
jp.co.intra_mart.foundation.sap.common.model
jp.co.intra_mart.foundation.sap.common.util
jp.co.intra_mart.foundation.sap.common.util.data
jp.co.intra_mart.foundation.sap.common.util.date
jp.co.intra_mart.foundation.sap.common.util.file
jp.co.intra_mart.foundation.sap.common.util.message


概要 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 im_sap_connect API Specifications

パッケージ
jp.co.intra_mart.foundation.sap.common.auth | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.auth.exception | ＳＡＰ連携に関する例外クラスを提供します。
jp.co.intra_mart.foundation.sap.common.exception |
jp.co.intra_mart.foundation.sap.common.general_purpose | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.general_purpose.exception | ＳＡＰ連携に関するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.model |
jp.co.intra_mart.foundation.sap.common.util |
jp.co.intra_mart.foundation.sap.common.util.data | ＳＡＰ連携にて使用するデータ変換クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.date | ＳＡＰ連携にて使用する日付操作クラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.file | ＳＡＰ連携にて使用するプロパティを操作するクラスを提供します。
jp.co.intra_mart.foundation.sap.common.util.message |

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.sap.common.auth, jp.co.intra_mart.foundation.sap.common.auth.exception, jp.co.intra_mart.foundation.sap.common.exception, jp.co.intra_mart.foundation.sap.common.general_purpose, jp.co.intra_mart.foundation.sap.common.general_purpose.exception, jp.co.intra_mart.foundation.sap.common.model, jp.co.intra_mart.foundation.sap.common.util, jp.co.intra_mart.foundation.sap.common.util.data, jp.co.intra_mart.foundation.sap.common.util.date, jp.co.intra_mart.foundation.sap.common.util.file, jp.co.intra_mart.foundation.sap.common.util.message

クラス階層

  • class java.lang.Object
    • class java.util.AbstractMap (implements java.util.Map)
      • class java.util.HashMap (implements java.lang.Cloneable, java.util.Map, java.io.Serializable)
        • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.BankDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.Convertor (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.date.DateHandler (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.PropertyDescriptorBox
    • class jp.co.intra_mart.foundation.sap.common.auth.SapAuthInfoBundle
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClient
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientNoLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPool
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolNoLoadBalancing
        • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolWithLoadBalancing
      • class jp.co.intra_mart.foundation.sap.common.auth.SapClientWithLoadBalancing
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapClientPoolManager
    • class jp.co.intra_mart.foundation.sap.common.auth.SapConnector (implements java.io.Serializable)
    • class jp.co.intra_mart.foundation.sap.common.util.message.SAPConnectorMessageBundle
    • class jp.co.intra_mart.foundation.sap.common.auth.SapRepositoryManager
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class java.lang.RuntimeException
          • class jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException
            • class jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException
        • class jp.co.intra_mart.foundation.sap.common.exception.SAPException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException
          • class jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException
          • class jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(im_sap_connect 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (im_sap_connect 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.sap.common.auth.exception

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.auth.exception.SAPAuthSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.auth

クラス jp.co.intra_mart.foundation.sap.common.auth.SapConnector は Object を拡張し、Serializable を実装しています

直列化されたフィールド

serverType

String serverType
推奨されていません。
サーバタイプ

client

String client
推奨されていません。
クライアント

user

String user
推奨されていません。
ユーザ

passwd

String passwd
推奨されていません。
パスワード

lang

String lang
推奨されていません。
言語

sysnr

String sysnr
推奨されていません。
システム番号

ashost

String ashost
推奨されていません。
接続先サーバIPアドレス

poolName

String poolName
推奨されていません。
プール名称

poolSize

int poolSize
推奨されていません。
プール内のコネクション数

waitTime

long waitTime
推奨されていません。
コネクション取得の待機時間

connectionTimeout

long connectionTimeout
推奨されていません。
コネクションのタイムアウト

timeoutCheckPeriod

long timeoutCheckPeriod
推奨されていません。
コネクションのタイムアウトのチェック間隔

パッケージ jp.co.intra_mart.foundation.sap.common.exception

クラス jp.co.intra_mart.foundation.sap.common.exception.SAPException は Exception を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.exception.SAPRuntimeException は RuntimeException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.exception.UnsupportedProductEditionException は SAPRuntimeException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiController は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyName

String propertyName
プロパティファイル名

property

Properties property
プロパティファイル

bapiHashList

ArrayList bapiHashList
BapiHashオブジェクトの一覧

impImpList

ArrayList impImpList
プロパティ情報(import(Import))一覧

impStrList

ArrayList impStrList
プロパティ情報(structure(Import))一覧

impTblList

ArrayList impTblList
プロパティ情報(table(Import))一覧

expExpList

ArrayList expExpList
プロパティ情報(export(Export))一覧

expStrList

ArrayList expStrList
プロパティ情報(structure(Export))一覧

expTblList

ArrayList expTblList
プロパティ情報(table(Export))一覧

bapiReturnList

ArrayList bapiReturnList
ＢＡＰＩ処理実行結果

hasTransaction

boolean hasTransaction
コネクション(トランザクション)保持フラグ

connectionManager

ConnectionManager connectionManager
コネクション(トランザクション)オブジェクト

ignoreErrMsgReturnTypes

List ignoreErrMsgReturnTypes
エラーメッセージを無視するRETURN-TYPE

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiHash は HashMap を拡張し、Serializable を実装しています

直列化されたフィールド

impExpType

String impExpType
入力／出力区分

paramType

String paramType
パラメタ属性

paramName

String paramName
パラメタ名

recordNo

int recordNo
レコード番号

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.BapiReturn は Object を拡張し、Serializable を実装しています

直列化されたフィールド

type

String type
TYPE

id

String id
ID

code

String code
Code

number

String number
NUMBER

message

String message
MESSAGE

logNo

String logNo
LOG NO

logMsgNo

String logMsgNo
LOG MSG NO

messageV1

String messageV1
MESSAGE V1

messageV2

String messageV2
MESSAGE V2

messageV3

String messageV3
MESSAGE V3

messageV4

String messageV4
MESSAGE V4

parameter

String parameter
PARAMETER

row

String row
ROW

field

String field
FIELD

system

String system
SYSTEM

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.ConnectionManager は Object を拡張し、Serializable を実装しています

直列化されたフィールド

sapClient

SapClient sapClient
SAPへのクライアント

hasSapClient

boolean hasSapClient
SapClientオブジェクト保持フラグ

serverType

String serverType
使用したサーバータイプ退避用変数

commitOnServerTypeSwitch

boolean commitOnServerTypeSwitch
同一サーバータイプにおける各APIにて保持しているcommitプロパティ

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.LineProperty は Object を拡張し、Serializable を実装しています

直列化されたフィールド

propertyValue

String propertyValue
プロパティの値

propertyKeyPart

String[] propertyKeyPart
プロパティのキー

パッケージ jp.co.intra_mart.foundation.sap.common.general_purpose.exception

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralAppException は SAPException を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.general_purpose.exception.SAPGeneralSystemException は SAPException を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.model

クラス jp.co.intra_mart.foundation.sap.common.model.BankDataInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
仕入先または債権者の勘定コード

strCustomer

String strCustomer
得意先または債権者の勘定コード

strBankCtry

String strBankCtry
銀行国コード

strBankKey

String strBankKey
銀行コード

strBankAcct

String strBankAcct
口座番号

strCtrlKey

String strCtrlKey
預金種別

strPartnerBk

String strPartnerBk
取引先銀行タイプ

strCollAuth

String strCollAuth
フラグ: 回収権限

strBankRef

String strBankRef
銀行詳細の参照詳細

クラス jp.co.intra_mart.foundation.sap.common.model.CompanyDataInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
仕入先または債権者の勘定コード

strCustomer

String strCustomer
得意先または債権者の勘定コード

strCompCode

String strCompCode
会社コード

strClerk

String strClerk
記帳担当者

strHdOffice

String strHdOffice
本店勘定コード

strAltPayee

String strAltPayee
代理受取人勘定コード

strAltPayer

String strAltPayer
代理支払人勘定コード

strCuvdClear

String strCuvdClear
フラグ: 得意先と仕入先間の相殺決済

strPmnttrms

String strPmnttrms
支払条件キー

strActAtVen

String strActAtVen
仕入先での自社勘定コード

strActAtCus

String strActAtCus
得意先での自社勘定コード

strVendUser

String strVendUser
仕入先担当者

strCustUser

String strCustUser
得意先担当者

strNextPayee

String strNextPayee
次受取人

strBuyingGrp

String strBuyingGrp
購買グループの勘定コード

strInternet

String strInternet
関係会社担当者のインターネットアドレス

strFax

String strFax
得意先/仕入先の経理担当者のファックス No.

strPaymentMethods

String strPaymentMethods
考慮される支払方法一覧

strTel

String strTel
取引先での記帳担当者電話番号

クラス jp.co.intra_mart.foundation.sap.common.model.GeneralDataInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

strVendor

String strVendor
仕入先または債権者の勘定コード

strCustomer

String strCustomer
得意先または債権者の勘定コード

strName

String strName
名称 1

strName2

String strName2
名称 2

strName3

String strName3
名称 3

strName4

String strName4
名称 4

strCity

String strCity
市区町村

strDistrict

String strDistrict
所在地

strPoBox

String strPoBox
私書箱

strPobxPcd

String strPobxPcd
私書箱番号

strPostlCode

String strPostlCode
郵便番号

strRegion

String strRegion
地域 (都道府県)

strCountycode

String strCountycode
地域コード

strCityCode

String strCityCode
市区町村コード

strStreet

String strStreet
地名/番地-号

strCountry

String strCountry
国コード

strCountryiso

String strCountryiso
ISO 国コード

strPobxCty

String strPobxCty
私書箱住所

strLangu

String strLangu
言語キー

strLanguIso

String strLanguIso
ISO 639 準拠の言語

strTelephone

String strTelephone
電話番号 1

strFormofaddr

String strFormofaddr
敬称

strTelephone2

String strTelephone2
電話番号 2

strFax1

String strFax1
FAX1

パッケージ jp.co.intra_mart.foundation.sap.common.util.data

クラス jp.co.intra_mart.foundation.sap.common.util.data.Convertor は Object を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.util.data.ExtendedParamConverter は ParamConverter を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.sap.common.util.data.ParamConverter は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.date

クラス jp.co.intra_mart.foundation.sap.common.util.date.DateHandler は Object を拡張し、Serializable を実装しています

パッケージ jp.co.intra_mart.foundation.sap.common.util.file

クラス jp.co.intra_mart.foundation.sap.common.util.file.PropertiesFile は Object を拡張し、Serializable を実装しています

直列化されたフィールド

properties

Properties properties
プロパティ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


※フィルターについて

各APIには、指定可能なフィルターと指定不可のフィルターがあります。
（詳細は各APIを参照ください。）

フィルターは下記のタスクに分類されます。
    ・未処理タスク   [GO]
    ・引き戻しタスク [PULLBACK]
    ・差し戻しタスク [SENDBACK]
    ・完了タスク     [COMPLETE]

また、タスクは下記の処理に分類されます。
    ・本人処理
    ・代理元処理不可
    ・代理元処理可

 | 本人処理 | 代理元処理不可 | 代理元処理可
未処理タスク | GO_FILTER | AGT_GO_FILTER | CLT_AGT_GO_FILTER
引き戻しタスク | PULLBACK_FILTER | AGT_PULLBACK_FILTER | CLT_AGT_PULLBACK_FILTER
差し戻しタスク | SENDBACK_FILTER | AGT_SENDBACK_FILTER | CLT_AGT_SENDBACK_FILTER
完了タスク | COMPLETE_FILTER | AGT_COMPLETE_FILTER | CLT_AGT_COMPLETE_FILTER

「GO_FILTER」と「AGT_GO_FILTER」のように、同タスクのフィルターは同時に指定可能
でますが、「GO_FILTER」と「COMPLETE_FILTER」のように、タスクが異なるフィルター
を同時に指定することは出来ません。

指定不可のフィルターを設定した場合は、検索結果が0件となります。

クラス Manager

※フィルターについて
メソッド getProcessList
未処理タスク | GO_FILTER | ○
 | AGT_GO_FILTER | －
 | CLT_AGT_GO_FILTER | －
引き戻しタスク | PULLBACK_FILTER | ○
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | ○
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | ○
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －

○：指定可能なフィルター
－：指定不可のフィルター

クラス Reference

※フィルターについて
メソッド getReferTaskList
未処理タスク | GO_FILTER | ○
 | AGT_GO_FILTER | －
 | CLT_AGT_GO_FILTER | －
引き戻しタスク | PULLBACK_FILTER | －
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | －
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | ○
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －

○：指定可能なフィルター
－：指定不可のフィルター

クラス Drafter

※フィルターについて
メソッド getActivityProcessDefList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | －
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | －
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | －
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －
メソッド getEndProcessList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | △
 | AGT_PULLBACK_FILTER | ○
 | CLT_AGT_PULLBACK_FILTER | ○
差し戻しタスク | SENDBACK_FILTER | △
 | AGT_SENDBACK_FILTER | ○
 | CLT_AGT_SENDBACK_FILTER | ○
完了タスク | COMPLETE_FILTER | △
 | AGT_COMPLETE_FILTER | ○
 | CLT_AGT_COMPLETE_FILTER | ○

○：指定可能なフィルター
△：本人インスタンス生成時は可能／代理人インスタンス生成時は不可のフィルター
－：指定不可のフィルター

クラス Approver

※フィルターについて
メソッド getActivityTaskList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | △
 | AGT_PULLBACK_FILTER | ○
 | CLT_AGT_PULLBACK_FILTER | ○
差し戻しタスク | SENDBACK_FILTER | △
 | AGT_SENDBACK_FILTER | ○
 | CLT_AGT_SENDBACK_FILTER | ○
完了タスク | COMPLETE_FILTER | －
 | AGT_COMPLETE_FILTER | －
 | CLT_AGT_COMPLETE_FILTER | －
メソッド getEndTaskList
未処理タスク | GO_FILTER | △
 | AGT_GO_FILTER | ○
 | CLT_AGT_GO_FILTER | ○
引き戻しタスク | PULLBACK_FILTER | －
 | AGT_PULLBACK_FILTER | －
 | CLT_AGT_PULLBACK_FILTER | －
差し戻しタスク | SENDBACK_FILTER | －
 | AGT_SENDBACK_FILTER | －
 | CLT_AGT_SENDBACK_FILTER | －
完了タスク | COMPLETE_FILTER | △
 | AGT_COMPLETE_FILTER | ○
 | CLT_AGT_COMPLETE_FILTER | ○

○：指定可能なフィルター
△：本人インスタンス生成時は可能／代理人インスタンス生成時は不可のフィルター
－：指定不可のフィルター


Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


i ntra-mart The Power for Enterprise Web Solution


プロセス種別コード
ビジネスプロセスワークフロー | 0
ドキュメントワークフロー | 1
申請者ルート作成ワークフロー | 2

ページ種別
プレゼンテーションページ | 1
サーブレット | 2
JavaEEフレームワーク | 4

コンテンツフレーム種別
標準 | 0
カスタム | 1

絞込み条件
処理権限 | 0
編集権限 | 1
なし | 2

プロセスステータス
アクティブ | 1
完了 | 4

プロセス終了ステータス
審議中/通常終了 | 0
否認 | 1
取り止め | 2
途中終了 | 3

アクティビティステータス
準備中 | 0
アクティブ | 1
保留中 | 2
取り消し中 | 3
完了 | 4

承認種別
申請 | DRAFT
再申請 | RETRY
承認 | APPROVAL
否認 | REJECTION
申請者へ差し戻し | RETURN_START
承認者へ差し戻し | RETURN_BEFORE
任意の処理者へ差し戻し | RETURN_TASK
引戻し | RETURN_PULL
保留 | SUSPENTION
取り止め | CANCEL
振替 | DELEGATE_TASK
対象者自動パス | TARGET_AUTOPASS
プロセス操作 | PROCESS_OPERATION

到達種別
未到達 | 00
通常到達 | 01
引戻し | 20
被引戻し | 21
差戻し | 30
被差戻し | 31
被差戻し | 32

処理結果
申請 | 0
再申請 | 1
承認 | 2
棄却 | 3
申請者へ差戻し | 4
前処理者へ差戻し | 5
引き戻し | 6
保留 | 7
取り止め | 8
対象者自動パス | 9
任意の処理者へ差し戻し | 11
プロセス操作 | 99

現在の状態
【本人・代理設定なし】
通常 | 000 | 通常到達にてアクティブ
引戻し | 005 | 引戻しにてアクティブ
差戻し | 006 | 差戻しにてアクティブ
通常(保留) | 010 | 通常到達にてアクティブ後の保留
引戻し(保留) | 015 | 引戻しにてアクティブ後の保留
差戻し(保留) | 016 | 差戻しにてアクティブの保留
【代理設定有り・本人決済可】
通常 | 100 | 通常到達にてアクティブ
引戻し | 105 | 引戻しにてアクティブ
差戻し | 106 | 差戻しにてアクティブ
通常(保留) | 110 | 通常到達にてアクティブ後の保留
引戻し(保留) | 115 | 引戻しにてアクティブ後の保留
差戻し(保留) | 116 | 差戻しにてアクティブの保留
【代理設定有り・本人決不可】
通常 | 200 | 通常到達にてアクティブ
引戻し | 205 | 引戻しにてアクティブ
差戻し | 206 | 差戻しにてアクティブ
通常(保留) | 210 | 通常到達にてアクティブ後の保留
引戻し(保留) | 215 | 引戻しにてアクティブ後の保留
差戻し(保留) | 216 | 差戻しにてアクティブの保留
【共通】
完了 | 999 | 完了

アクティビティ種別
手動タスク | EMPTY
同期タスク | FLOW
自動実行タスク | INVOKE_AUTO
イベント実行タスク | INVOKE_EVENT
サブプロセスタスク | INVOKE_PROCESS
プロセスタスク | PROCESS
処理タスク | RECEIVE
シーケンスタスク (ルート情報を構成するための管理データ) | SEQUENCE
分岐タスク | SWITCH
ルート選択タスク | MULTI
終了タスク | TERMINATE

アクティビティ種別
処理タスク | 1
プロセス呼出(サブプロセス) | 2
自動呼出(自動実行タスク) | 3
フロー(同期タスク) | 5
ターミネート(終了タスク) | 6
エンプティ(手動タスク) | 7
スイッチ(分岐タスク) | 8
イベント(イベント実行) | 9
ルート選択タスク | A

対象者種別
ユーザ | user
組織 | orgn
オフィシャルグループ | official
ロール | role
実行時選択 | executive
所属組織 | attch_orgn
上位組織 | high_orgn
申請者 | drafter
処理者定義 (ルート作成タスク) | sub

処理結果ID
プロセス定義新規登録 | 1
バージョン追加 | 2
プロセス定義更新 | 3

メールテンプレートキー
申請時承認依頼メールテンプレート | MAIL_FILE_APPLY
再申請依頼メールテンプレート | MAIL_FILE_RETRY
承認時メールテンプレート | MAIL_FILE_OK
申請者に差し戻しメールテンプレート | MAIL_FILE_RETURN_START
承認者に差し戻しメールテンプレート | MAIL_FILE_RETURN_BEFORE
引戻しメールテンプレート | MAIL_FILE_PULLBACK
取り止めメールテンプレート | MAIL_FILE_CANCEL
否認メールテンプレートファイル | MAIL_FILE_REJECTION
対象者自動パスメールテンプトファイル | MAIL_FILE_TARGETPASS
最終結果通知メールテンプレートファイル | MAIL_FILE_END_FLOW


クラス Manager
メソッド　getProcessList（プロセス一覧情報を取得）

    // パラメータの設定
    String userId  = "ログインユーザーコード";
    String groupCd = "ログイングループID";

    // 検索条件(未処理タスクを取得)
    SearchCondition searchCondition = new SearchCondition();
    Map searchConditionMap          = new HashMap();
    searchConditionMap.put( SearchCondition.GO_FILTER , new Boolean(true) );
    searchCondition.setCondition( searchConditionMap );

    // ソートを指定(昇順)
    Sort[] sortKey = new Sort[5];
    sortKey[0]     = new Sort();
    sortKey[1]     = new Sort();
    sortKey[2]     = new Sort();
    sortKey[3]     = new Sort();
    sortKey[4]     = new Sort();
    sortKey[0].setAscending( "category_cd" );
    sortKey[1].setAscending( "process_def_cd" );
    sortKey[2].setAscending( "version_cd" );
    sortKey[3].setAscending( "process_cd" );
    sortKey[4].setAscending( "activity_cd" );

    // フェッチ開始位置を指定
    int start = 0;

    // フェッチ件数を指定
    int amount = 10;

    // 絞り込み条件(絞込み：なし)
    String authority = Manager.AUTHORITY_READ;

    // コンストラクタの生成
    Manager manager = new Manager( userId , groupCd );

    // プロセス一覧情報を取得
    List processList = manager.getProcessList( searchCondition , sortKey , start , amount , authority );

クラス Process
メソッド　getTaskResultInfo（タスク処理結果情報を取得）

    // パラメータの設定
    String groupCd      = "ログイングループID";
    String processDefCd = "プロセス定義コード";
    String versionCd    = "バージョンコード";
    String processCd    = "プロセスコード";
    String activityCd   = "アクティビティコード";

    // コンストラクタの生成
    Process process = new Process( processDefCd , versionCd , processCd , groupCd );

    // タスク処理結果情報を取得
    Map taskResultInfoMap = process.getTaskResultInfo( activityCd );

クラス FlowInfo
メソッド　getNext（次タスクのフロー情報を取得）

    // パラメータの設定
    String userId       = "ログインユーザーコード";
    String groupCd      = "ログイングループID";
    String processDefCd = "プロセス定義コード";
    String versionCd    = "バージョンコード";
    String activityCd   = "アクティビティコード";
    String authority    = "絞り込み条件";

    // コンストラクタの生成
    Manager manager   = new Manager( userId , groupCd );
    FlowInfo flowinfo = manager.getFlowInfo( processDefCd , versionCd , activityCd , authority );

    // 次タスクのフロー情報を取得
    List nextFlowInfo = flowinfo.getNext();

クラス Reference
メソッド　getReferTaskList（参照可能案件一覧を取得）

    // パラメータの設定
    String userId  = "ログインユーザーコード";
    String groupCd = "ログイングループID";

    // 検索条件(完了タスクを取得)
    SearchCondition searchCondition = new SearchCondition();
    Map searchConditionMap          = new HashMap();
    searchConditionMap.put( SearchCondition.COMPLETE_FILTER , new Boolean(true) );
    searchCondition.setCondition( searchConditionMap );

    // コンストラクタの生成
    Reference reference = new Reference( userId , groupCd );

    // 参照可能案件一覧を取得
    List referTaskListList = reference.getReferTaskList( searchCondition , (Sort[])null , 0 , 0 );

クラス Drafter
メソッド　draft（申請処理）

    // パラメータの設定
    String userId                   = "ログインユーザーコード";
    String groupCd                  = "ログイングループID";

    String processDefCd             = "プロセス定義コード";
    String versionCd                = "バージョンコード";
    String processTemporaryCd       = "一時プロセスID";
    String processName              = "プロセス名";
    ArrayList appKey                = new ArrayList();
    String draftAppointDate         = "起票指定日";
    String compCd                   = "起票会社コード";
    String orgnCd                   = "起票組織コード";
    String comment                  = "起票コメント";
    NegoModel nego                  = new NegoModel();
    RunExecutiveInfoModel executant = new RunExecutiveInfoModel();
    RunUserInfoModel executant      = new RunUserInfoModel();
    String routeSelectCd            = "ルート選択番号";
    String locale                   = "ロケール";
    CreateRouteInfoModel routeInfo  = "ルート作成情報";

/*------------------------------------------------------------------*/
    // アプリケーションキーの設定
    appKey.add( 0 , "" );
    appKey.add( 1 , "要素1" );
    appKey.add( 2 , "要素2" );
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // RunExecutiveInfoModelとRunUserInfoModelは同時には使用できません。

    // 実行時選択時 - 組織設定の場合
    executant.setCompanyCd( "会社コード" );
    executant.setPostCd( "組織コード" );

    // 実行時選択時 - ユーザー設定の場合
    executant.setUserCd( "ユーザーコード" );

    // 実行時選択ではない場合
    executant = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    ArrayList userList = new ArrayList();
    Map map            = new HashMap();
    map.put( "cd" , "送信先ユーザコード" );
    userList.add( map );

    nego.setUserList( userList );    // 根回しメール送信者リスト
    nego.setTitle( "根回しメールタイトル" );
    nego.setComment( "根回しメール本文" );

    // 根回しメールを送信しない場合
    nego = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    Drafter drafter = new Drafter( userId , groupCd );

    // 申請処理
    ProcessInfoModel processInfoModel = drafter.draft(
        processDefCd,
        versionCd,
        processTemporaryCd,
        processName,
        appKey,
        draftAppointDate,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd,
        locale,
        routeInfo
    );

クラス Approver
メソッド　Approver（承認処理）

    // パラメータの設定
    String userId                   = "ログインユーザーコード";
    String groupCd                  = "ログイングループID";

    String processDefCd             = "プロセス定義コード";
    String versionCd                = "バージョンコード";
    String processCd                = "プロセスコード";
    String activityCd               = "アクティビティコード";
    Boolean isFinish                = "途中終了フラグ";
    String compCd                   = "承認会社コード";
    String orgnCd                   = "承認組織コード";
    String comment                  = "承認コメント";
    NegoModel nego                  = new NegoModel();
    RunExecutiveInfoModel executant = new RunExecutiveInfoModel();
    RunUserInfoModel executant      = new RunUserInfoModel();
    String routeSelectCd            = "ルート選択番号";
    CreateRouteInfoModel routeInfo  = "ルート作成情報";

/*------------------------------------------------------------------*/
    // RunExecutiveInfoModelとRunUserInfoModelは同時には使用できません。

    // 実行時選択時 - 組織設定の場合
    executant.setCompanyCd( "会社コード" );
    executant.setPostCd( "組織コード" );

    // 実行時選択時 - ユーザー設定の場合
    executant.setUserCd( "ユーザーコード" );

    // 実行時選択ではない場合
    executant = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    ArrayList userList = new ArrayList();
    Map map            = new HashMap();
    map.put( "cd" , "送信先ユーザコード" );
    userList.add( map );

    nego.setUserList( userList );    // 根回しメール送信者リスト
    nego.setTitle( "根回しメールタイトル" );
    nego.setComment( "根回しメール本文" );

    // 根回しメールを送信しない場合
    nego = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    Approver approver = new Approver( userId , groupCd );

    // 承認処理
    approver.approve(
        processDefCd,
        versionCd,
        processCd,
        activityCd,
        isFinish,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd,
        routeInfo
    );


WkfManager オブジェクト
メソッド　getProcessList（プロセス一覧情報を取得）

    // パラメータの設定
    var userId  = "ログインユーザーコード";
    var groupCd = "ログイングループID";

    // 検索条件(未処理タスクを取得)
    var conditionKey       = new Object();
    conditionKey.go_filter = true;
    var wkfSearchCondition = new WkfSearchCondition();
    wkfSearchCondition.setCondition( conditionKey );

    // ソートを指定(昇順)
    var sortKey = new Array();
    var wkfSort = null;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "category_cd" );
    sortKey[0]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "process_def_cd" );
    sortKey[1]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "version_cd" );
    sortKey[2]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "process_cd" );
    sortKey[3]  = wkfSort;
    wkfSort     = new WkfSort();
    wkfSort.setAscending( "activity_cd" );
    sortKey[4]  = wkfSort;

    // フェッチ開始位置を指定
    var start = 0;

    // フェッチ件数を指定
    var amount = 10;

    // 絞り込み条件(絞込み：なし)
    var authority = "2";

    // コンストラクタの生成
    var wkfManager = new WkfManager( userId , groupCd );

    // プロセス一覧情報を取得
    var processList = wkfManager.getProcessList( wkfSearchCondition , sortKey , start , amount , authority );

WkfProcess オブジェクト
メソッド　getTaskResultInfo（タスク処理結果情報を取得）

    // パラメータの設定
    var groupCd      = "ログイングループID";
    var processDefCd = "プロセス定義コード";
    var versionCd    = "バージョンコード";
    var processCd    = "プロセスコード";
    var activityCd   = "アクティビティコード";

    // コンストラクタの生成
    var wkfProcess = new WkfProcess( processDefCd , versionCd , processCd , groupCd );

    // タスク処理結果情報を取得
    var taskResultInfo = wkfProcess.getTaskResultInfo( activityCd );

WkfFlowInfo オブジェクト
メソッド　getNext（次タスクのフロー情報を取得）

    // パラメータの設定
    var userId       = "ログインユーザーコード";
    var groupCd      = "ログイングループID";
    var processDefCd = "プロセス定義コード";
    var versionCd    = "バージョンコード";
    var activityCd   = "アクティビティコード";
    var authority    = "絞り込み条件";

    // コンストラクタの生成
    var wkfManager  = new WkfManager( userId , groupCd );
    var flowInfo    = wkfManager.getFlowInfo( processDefCd , versionCd , activityCd , authority );

    //フロー情報オブジェクトの設定
    var wkfFlowInfo = new WkfFlowInfo( flowInfo );

    // 次タスクのフロー情報を取得
    var wkfFlowInfoNext = wkfFlowInfo.getNext();

メソッド　getPrev（最終タスクのフロー情報を取得）

    // パラメータの設定
    var userId       = "ログインユーザーコード";
    var groupCd      = "ログイングループID";
    var processDefCd = "プロセス定義コード";
    var versionCd    = "バージョンコード";
    var activityCd   = "アクティビティコード";

    // コンストラクタの生成
    var wkfManager  = new WkfManager( userId , groupCd );
    var flowInfo    = wkfManager.getFlowInfo( processDefCd , versionCd , activityCd );

    //フロー情報オブジェクトの設定
    var wkfFlowInfo = new WkfFlowInfo( flowInfo );

    // ENDタスクのフロー情報を取得
    var wkfFlowInfoLast = wkfFlowInfo.getLast();

    // 最終処理タスク（ENDのひとつ前のタスク）のフロー情報を取得
    var wkfFlowInfoLastTask = wkfFlowInfoLast.getPrev();
    var flowinfoLastTask = wkfFlowInfoLastTask.get(0);

WkfReference オブジェクト
メソッド　getReferTaskList（参照可能案件一覧を取得）

    // パラメータの設定
    var userId  = "ログインユーザーコード";
    var groupCd = "ログイングループID";

    // 検索条件(完了タスクを取得)
    var conditionKey             = new Object();
    conditionKey.complete_filter = true;
    var wkfSearchCondition       = new WkfSearchCondition();
    wkfSearchCondition.setCondition( conditionKey );

    // コンストラクタの生成
    var wkfReference = new WkfReference( userId , groupCd );

    // 参照可能案件一覧を取得
    var referTaskList = wkfReference.getReferTaskList( wkfSearchCondition , null , 0 , 0 );

WkfDrafter オブジェクト
メソッド　draft（申請処理）

    // パラメータの設定
    var userId             = "ログインユーザーコード";
    var groupCd            = "ログイングループID";

    var processDefCd       = "プロセス定義コード";
    var versionCd          = "バージョンコード";
    var processTemporaryCd = "一時プロセスID";
    var processName        = "プロセス名";
    var appKey             = new Array();
    var draftAppointDate   = "起票指定日";
    var compCd             = "起票会社コード";
    var orgnCd             = "起票組織コード";
    var comment            = "起票コメント";
    var nego               = new Object();
    var executant          = new Object();
    var routeSelectCd      = "ルート選択番号";
    var locale             = "ロケール";
    var routeInfo          = "ルート作成情報";

/*------------------------------------------------------------------*/
    // アプリケーションキーの設定
    appKey[0] = "要素1";
    appKey[1] = "要素2";
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 実行時選択時 - 組織設定の場合
    executant.type    = "orgn";
    executant.comp_cd = "会社コード";
    executant.cd      = "組織コード";

    // 実行時選択時 - ユーザー設定の場合
    executant.type    = "user";
    executant.cd      = "ユーザーコード";

    // 実行時選択ではない場合
    executant         = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    nego.userList          = new Array();
    nego.userList[0]       = new Object();
    nego.userList[0].cd    = "送信先ユーザコード";
    nego.title             = "根回しメールタイトル";
    nego.comment           = "根回しメール本文";

    // 根回しメールを送信しない場合
    nego                   = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    var wkfDrafter = new WkfDrafter( userId , groupCd );

    // 申請処理
    var draft = wkfDrafter.draft(
        processDefCd,
        versionCd,
        processTemporaryCd,
        processName,
        appKey,
        draftAppointDate,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd,
        locale,
        routeInfo
    );

WkfApprover オブジェクト
メソッド　Approver（承認処理）

    // パラメータの設定
    var userId             = "ログインユーザーコード";
    var groupCd            = "ログイングループID";

    var processDefCd       = "プロセス定義コード";
    var versionCd          = "バージョンコード";
    var processCd          = "プロセスコード";
    var activityCd         = "アクティビティコード";
    var isFinish           = "途中終了フラグ";
    var compCd             = "承認会社コード";
    var orgnCd             = "承認組織コード";
    var comment            = "承認コメント";
    var nego               = new Object();
    var executant          = new Object();
    var routeSelectCd      = "ルート選択番号";
    var routeInfo          = "ルート作成情報";

/*------------------------------------------------------------------*/
    // 実行時選択時 - 組織設定の場合
    executant.type    = "orgn";
    executant.comp_cd = "会社コード";
    executant.cd      = "組織コード";

    // 実行時選択時 - ユーザー設定の場合
    executant.type    = "user";
    executant.cd      = "ユーザーコード";

    // 実行時選択ではない場合
    executant         = null;
/*------------------------------------------------------------------*/

/*------------------------------------------------------------------*/
    // 根回しメール設定
    nego.userList          = new Array();
    nego.userList[0]       = new Object();
    nego.userList[0].cd    = "送信先ユーザコード";
    nego.title             = "根回しメールタイトル";
    nego.comment           = "根回しメール本文";

    // 根回しメールを送信しない場合
    nego                   = null;
/*------------------------------------------------------------------*/

    // コンストラクタの生成
    var wkfApprover  = new WkfApprover( userId , groupCd );

    // 承認処理
    var approve = wkfApprover.approve(
        processDefCd,
        versionCd,
        processCd,
        activityCd,
        isFinish,
        compCd,
        orgnCd,
        comment,
        nego,
        executant,
        routeSelectCd,
        routeInfo
    );


インタフェース jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の使用

jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException の使用

WKFApplicationException を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での WKFApplicationException の使用

WKFApplicationException をスローする jp.co.intra_mart.foundation.wkf のメソッド
void | Util.sendMail(String template_path, String process_def_cd, String version_cd, String process_cd, String activity_cd, ArrayList to, ArrayList cc, ArrayList bcc) メール送信処理を行います。
void | Util.autoPass(String category_cd, String process_def_cd, String version_cd, int date) 案件の自動パス(バッチ起動)処理を行います。
void | Util.autoPress(String category_cd, String process_def_cd, String version_cd, int date) 案件の自動催促(バッチ起動)処理を行います。
void | TaskInfo.changeRunUser(String process_def_cd, String version_cd, String process_cd, String activity_cd, TargetInfoModel target_info) 指定された案件内の指定タスクの処理者を変更します。
Map | Process.getTaskResultInfo(String activity_cd) タスク処理結果情報を取得します。
byte[] | Manager.exportProcessDef(ArrayList process_def_cd) プロセス定義(Excel形式)をエクスポートします。
FlowInfo | Manager.getFlowInfo(String processDefCd, String versionCd, String activityCd) 推奨されていません。 getFlowInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件:AUTHORITY_ALLで情報を取得します。
FlowInfo | Manager.getFlowInfo(String processDefCd, String versionCd, String activityCd, String authority) 特定のタスクの位置情報を保持して、フロー情報を取得する。
List | Manager.getFlowInfoByTargetNo(String processDefCd, String versionCd, int targetTaskNo, String authority) 特定のタスクの位置情報を保持して、フロー情報を取得する。
Map | Manager.getProcessDefInfo(String process_def_cd) 推奨されていません。 getProcessDefInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | Manager.getProcessDefInfo(String process_def_cd, String authority) プロセス定義コード、絞込み条件をキーにしてプロセス定義情報を取得します。
List | Manager.getProcessDefInfoByName(String process_def_name) 推奨されていません。 getProcessDefInfoByNameメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
List | Manager.getProcessDefInfoByName(String process_def_name, String authority) プロセス定義名、絞込み条件をキーにしてプロセス定義情報を取得します。
Map | Manager.getProcessDefInfoByVersion(String process_def_cd, String version_cd) 推奨されていません。 getProcessDefInfoByVersionを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | Manager.getProcessDefInfoByVersion(String process_def_cd, String version_cd, String authority) プロセス定義コード、バージョンコード、絞込み条件をキーにしてプロセス定義情報を取得します。
List | Manager.getProcessDefInfoByCategory(String category_cd, String authority) カテゴリコード、絞込み条件をキーにしてプロセス定義情報配列を取得します。
List | Manager.importProcessDef(Object xls_file) プロセス定義(Excel形式)をインポートします。
void | Manager.removeProcess(String process_def_cd, String version_cd, String process_cd, Boolean xml_out_flg) 案件を削除を実行します。
void | Manager.controlProcess(String process_def_cd, String version_cd, String process_cd, String target_activity_cd) プロセス操作を実行します。
Map | Manager.registProcessDef(String category_cd, String process_def_name, String process_def_notes, String version_notes, String process_class_code, boolean sub_process_flag, boolean attachment_flag, String effective_date, String end_date, ContentsPathModel process_contents_path, List root_info) 推奨されていません。
Map | Manager.addVersion(String process_def_cd, String version_notes, String effective_date, String end_date, ContentsPathModel process_contents_path, List root_info) 推奨されていません。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.cancel(String process_def_cd, String version_cd, String process_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 取り止め処理を実行します。
void | Drafter.pullBack(String process_def_cd, String version_cd, String process_cd) 引戻し処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | Approver.denial(String process_def_cd, String version_cd, String process_cd, String activity_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 否認処理を実行します。
void | Approver.suspend(String process_def_cd, String version_cd, String process_cd, String activity_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 保留処理を実行します。
void | Approver.sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, NegoModel nego) 推奨されていません。 sendBack メソッドを使用してください。
void | Approver.sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, NegoModel nego, String send_back_process_def_cd, String send_back_version_cd, String send_back_process_cd, String send_back_activity_cd) 差し戻し処理を実行します。
void | Approver.pullBack(String process_def_cd, String version_cd, String process_cd, String activity_cd) 引き戻し処理を実行します。
TransferInfoModel | AgentSetting.getTransferInfo(String process_def_cd, String version_cd, String activity_cd, String target_date) 指定された日付に有効な代理設定情報を返却します。
List | AgentSetting.getTransferProcessDefList(String category_cd) プロセス定義委譲情報一覧を取得します。
List | AgentSetting.getTransferVersionList(String process_def_cd) バージョン委譲情報一覧を取得します。
List | AgentSetting.getTransferActivityList(String process_def_cd, String version_cd) タスク委譲情報一覧を取得します。
void | AgentSetting.setAgent(TransferInfoModel transferInfo) 代理設定を設定します。
void | AgentSetting.cancelAgent(TransferInfoModel transferInfo) 代理設定を解除します。

WKFApplicationException をスローする jp.co.intra_mart.foundation.wkf のコンストラクタ
Util(String login_group_id)
コンストラクタ
TaskInfo(String user_cd, String login_group_id)
コンストラクタ
Reference(String user_cd, String login_group_id)
コンストラクタ
Process(String process_def_cd, String version_cd, String process_cd, String login_group_id)
コンストラクタ
Manager(String user_cd, String login_group_id)
コンストラクタ
Drafter(String user_cd, String login_group_id)
コンストラクタ１(本人用)
Drafter(String agent_user_cd, String user_cd, String login_group_id)
コンストラクタ２(代理人用)。
Approver(String user_cd, String login_group_id)
コンストラクタ１(本人用)
Approver(String agent_user_cd, String user_cd, String login_group_id)
コンストラクタ２(代理人用)。
AgentSetting(String user_cd, String login_group_id)
コンストラクタ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の使用

jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BPWErrorCodeIF (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.exception
インタフェース BPWErrorCodeIF

public interface BPWErrorCodeIF

ＢＰＷで利用される例外エラーコードインタフェース定義

フィールドの概要
static String | BPW_C_ALREADY_EXIST_TRANSFER 処理委譲できません。
static String | BPW_C_ALREADY_SUSPEND 既に保留されている可能性があります。
static String | BPW_C_AUTO_EXECUTE_FAULT 自動実行処理が異常復帰しました。
static String | BPW_C_CAN_NOT_START_JAVASCRIPT JavaScriptが起動できません。
static String | BPW_C_CATEGORY_DISAGREEMENT カテゴリコードの設定に誤りがあります。
static String | BPW_C_CHANGE_AGENTSETTING 他のユーザにより変更された可能性があります。
static String | BPW_C_CHANGE_INFO 他のユーザに情報が変更されました。
static String | BPW_C_CHANGING_NOW 関連する情報が修正中であり反映できません。
static String | BPW_C_DATA_NOT_FOUND データが存在しません。
static String | BPW_C_DUPLICATE_CATEGORY カテゴリコードが重複しています。
static String | BPW_C_DUPLICATE_NAME 名称が重複しています。
static String | BPW_C_EXIST_PROCESS_DEF 有効なプロセス定義が存在します。
static String | BPW_C_FAILED_GET_HTTP_EXCEL_STREAM Excelファイルストリーム取得に失敗しました。
static String | BPW_C_FAILED_READ_EXCEL_STREAM Excelファイルストリーム読み込みに失敗しました。
static String | BPW_C_FOUND_AUTO_PASS_TABLE 関連付く自動パス情報が存在します。
static String | BPW_C_FOUND_PROCESS 関連付くプロセス情報が存在します。
static String | BPW_C_FOUND_RECEIVE_MASTER レシーブマスタ情報が存在しません。
static String | BPW_C_FOUND_RECEIVE_TABLE 関連付くレシーブ情報が存在します。
static String | BPW_C_FOUND_RUN_USER_TABLE 関連付く実行主体ユーザ情報が存在します。
static String | BPW_C_FOUND_RUNNING_PROCESS 実行中のプロセスが存在します。
static String | BPW_C_FOUND_VERSION 関連付く履歴情報が存在します。
static String | BPW_C_HAVE_NOT_AUTHORITY 権限がありません。
static String | BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND 権限、及び権限に関連する情報がありません。
static String | BPW_C_ILLIGAL_STATUS ステータスが異常です。
static String | BPW_C_ILLIGAL_STATUS_CHG ステータス遷移が異常です。
static String | BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER 実行時選択のレシーブは指定できません。
static String | BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD プロセス種別の設定が不正です。
static String | BPW_C_IMPORT_DUPLICATE_APPROVAL_CD 承認対象コードが重複しています。
static String | BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE コンテンツ種別が重複して指定されています。
static String | BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION シート内でプロセス定義名が重複しています。
static String | BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID ルート定義IDが重複して指定されています。
static String | BPW_C_IMPORT_DUPLICATE_TASK_ID タスクIDが重複しています。
static String | BPW_C_IMPORT_INVALID_ACTIVITY_TYPE アクティビティ種別の設定が不正です。
static String | BPW_C_IMPORT_INVALID_APPLICATION_ID アプリケーションIDが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN アプリケーションID長が不正です。
static String | BPW_C_IMPORT_INVALID_APPROVAL 承認対象種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG 承認対象種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_APPROVAL_FOCUS 承認対象が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_ATTACHMENT_FLAG 添付ファイルフラグが不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD 自動パス役職コードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND 自動パス役職種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_FLG 自動パス処理フラグが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS 自動パス対象が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM 自動パス期限が不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN 自動パス期限長が不正です。
static String | BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD 自動パスユーザコードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD 呼び出しプロセス定義コードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN 呼び出しプロセス定義コード長が不正です。
static String | BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN 実行クラス長が不正です。
static String | BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN カテゴリコード長が不正です。
static String | BPW_C_IMPORT_INVALID_CODE_KIND コード種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CODE_KIND_VALUE コード種別が不正です。
static String | BPW_C_IMPORT_INVALID_COMPULSION_END_FLG 強制終了可否フラグが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CONDITION_CALSS 条件クラスが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN 条件クラス長が不正です。
static String | BPW_C_IMPORT_INVALID_CONTENTS_FRAME_TYPE コンテンツフレーム種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CONTENTS_PATH コンテンツパスが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN コンテンツパス長が不正です。
static String | BPW_C_IMPORT_INVALID_CONTENTSTYPE コンテンツ種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND 起票タイプが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_DRAFTER_TASK_LOCATION ルート定義内のタスクの位置の入力が不正です。
static String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE 有効日付が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN 有効日付長が不正です。
static String | BPW_C_IMPORT_INVALID_END_DATE 終了日付が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_END_DATE_LEN 終了日付長が不正です。
static String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID イベントサービスIDが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN イベントサービスID長が不正です。
static String | BPW_C_IMPORT_INVALID_FUNCTION_KBN 処理区分が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN 催促メール内容定義長が不正です。
static String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT 催促メール猶予日数が不正です。
static String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN 催促メール猶予日長が不正です。
static String | BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN 催促メール表題定義長が不正です。
static String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION 催促メール対象種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN 催促メール対象種別長が不正です。
static String | BPW_C_IMPORT_INVALID_PAGBE_KIND ページ種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY 実行時選択前アクティビティ種別の設定が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID アプリケーションIDが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN アプリケーションID長が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD プロセス種別が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH コンテンツパスが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN コンテンツパス長が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE コンテンツ種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN プロセス定義コード長が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT アクティビティ種別設定数が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND ページ種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT アクティビティ種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID サービスIDが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN サービスID長が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESS_SWITCH アクティビティ種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW プロセス種別とサブプロセス識別フラグの設定が不正です。
static String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW プロセス種別とサブプロセス識別フラグの設定が不正です。
static String | BPW_C_IMPORT_INVALID_REFER_FOCUS 参照対象が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_REFER_USER_CD 参照者ユーザコードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RETURN_PULL_FLG 引戻し・差戻しフラグが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG 引戻し・差戻しメール送信フラグが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG ルート定義が不正です。
static String | BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW フロー情報のルート定義入力が不正です。
static String | BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別の設定が不正です。
static String | BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE ルート選択の前アクティビティ種別の設定が不正です。
static String | BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE 実行時選択の前アクティビティ種別の設定が不正です。
static String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD 実効アクティビティコードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN 実効アクティビティコード長が不正です。
static String | BPW_C_IMPORT_INVALID_RUN_CLASS 実行クラスが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD 会社CDが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD 実行主体役職コードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND 実行主体役職種別が指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RUN_USER_CD 実行主体ユーザコードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION ルート定義ないのタスクの位置の入力が不正です。
static String | BPW_C_IMPORT_INVALID_SECOND_APPROVAL 承認対象種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN 選択ルートコード長が不正です。
static String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN 選択ルート名長が不正です。
static String | BPW_C_IMPORT_INVALID_SERVECE_ID サービスIDが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_SERVICE_ID_LEN サービスID長が不正です。
static String | BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG 最短終了フラグが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW 最短終了フラグの設定が不正です。
static String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW 最短終了フラグの設定が不正です。
static String | BPW_C_IMPORT_INVALID_START_ACTIVITY ルートの開始アクティビティ種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_SUB_PROCESS サブプロセスの設定が不正です。
static String | BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG サブプロセス識別フラグが不正です。
static String | BPW_C_IMPORT_INVALID_TASK_ID タスク定義に存在しないタスクIDが指定されました。
static String | BPW_C_IMPORT_INVALID_TASK_TYPE タスクタイプが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_TOP_ACTIVITY ルートの先頭アクティビティ種別設定が不正です。
static String | BPW_C_IMPORT_INVALID_VERSION_CD 履歴コードが指定されていない、または不正です。
static String | BPW_C_IMPORT_INVALID_VERSION_CD_LEN 履歴コード長が不正です。
static String | BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER オートアダプタマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER 自動パス役職マスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_AUTO_PASS_INFO 自動パス情報が設定されてません。
static String | BPW_C_IMPORT_NO_AUTO_PASS_MASTER 自動パスマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_AUTO_PASS_USER_CD 自動パスユーザコードが存在しません。
static String | BPW_C_IMPORT_NO_CONTENTS_MASTER コンテンツマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER イベントアダプタマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT 承認対象種別設定が不正です。
static String | BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD 自動パス役職コードが存在しません。
static String | BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD 参照者組織コードが存在しません。
static String | BPW_C_IMPORT_NO_EXIST_REFER_USER_CD 参照者ユーザコードが存在しません。
static String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD 会社CDが存在しません。
static String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD 実行主体役職コードが存在しません。
static String | BPW_C_IMPORT_NO_EXIST_RUN_USER_CD 実行主体ユーザコードが存在しません。
static String | BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS 始めの条件クラスが指定されていません。
static String | BPW_C_IMPORT_NO_FIRST_TASK_ID 始めのタスクIDが指定されていません。
static String | BPW_C_IMPORT_NO_FLOW_INNER_MASTER フロー内容マスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY フロー内容マスタ情報の実行アクティビティが設定されていません。
static String | BPW_C_IMPORT_NO_LICENSE 指定されたプロセス種別に対するライセンスがありません。
static String | BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER オートアダプタ・イベントアダプタ情報を設定するライセンスがありません。
static String | BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW スイッチ・フロー情報を設定するライセンスがありません。
static String | BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER プロセスアダプタマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE 最初のシーケンスにレシーブが存在しません。
static String | BPW_C_IMPORT_NO_RECEIVE_MASTER レシーブマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER ルート選択マスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER 実行主体役職マスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_RUN_USER_MASTER 実行主体ユーザマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_SELECT_ROUTE_CD ルート選択マスタ情報の選択ルートコードが設定されていません。
static String | BPW_C_IMPORT_NO_SELECT_ROUTE_NAME ルート選択マスタ情報の選択ルート名が設定されていません。
static String | BPW_C_IMPORT_NO_SEQUENCE_MASTER シーケンス内容マスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY シーケンスマスタ情報の実行アクティビティが設定されていません。
static String | BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE フローのサブルートが存在しません。
static String | BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT ルート選択のサブルートが存在しません。
static String | BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH スイッチのサブルートが存在しません。
static String | BPW_C_IMPORT_NO_SWITCH_MASTER スイッチマスタ情報が設定されてません。
static String | BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY スイッチマスタ情報の実行アクティビティが設定されていません。
static String | BPW_C_IMPORT_NO_TASK_DEF タスク定義が指定されていません。
static String | BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF ルート定義内のタスクIDがタスク定義に指定されていません。
static String | BPW_C_IMPORT_OVER_ATTACHMENT_FLAG_LEN 添付ファイルフラグ文字列長が最大文字列長を超えています。
static String | BPW_C_IMPORT_OVER_NOTE_LEN 備考文字列長が最大文字列長を超えています。
static String | BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN プロセス種別文字列長が最大文字列長を超えています。
static String | BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN プロセス定義名長が最大文字列長を超えています。
static String | BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN プロセス定義備考文字列長が最大文字列長を超えています。
static String | BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN サブプロセス識別フラグ文字列長が最大文字列長を超えています。
static String | BPW_C_IMPORT_PLURAL_APPROVAL 起案タスク以外は、複数対象者の設定をすることはできません。
static String | BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO この履歴情報は使用できません。
static String | BPW_C_INPOSSIBLE_GET_ROOT_INFO アクティビティルート取得イベントに失敗しました。
static String | BPW_C_INPOSSIBLE_GET_USER_APP_KEY ユーザアプリケーションキー取得イベントに失敗しました。
static String | BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND メールテンプレートの送信に失敗しました。
static String | BPW_C_INPOSSIBLE_SET_MAIL_INFORMATION_REMOVE
static String | BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY 予約メール依頼の設定に失敗しました。
static String | BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY テンプレートメール送信抑止の設定に失敗しました。
static String | BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY メールテンプレートの設定に失敗しました。
static String | BPW_C_INVALID_ACTIVITY_STATUS アクティビティステータスが不正です。
static String | BPW_C_INVALID_ACTIVITY_TYPE アクティビティ種別が不正です。
static String | BPW_C_INVALID_ADAPTER_TYPE アダプタ種別が不正です。
static String | BPW_C_INVALID_APPROVAL_TYPE 承認種別が不正です。
static String | BPW_C_INVALID_APPROVAL_USER 承認ユーザコードが不正です。
static String | BPW_C_INVALID_CATEGORY 関連付けるカテゴリ情報が存在しない、または無効です。
static String | BPW_C_INVALID_CATEGORY_CODE カテゴリコードが指定されていない、または不正です。
static String | BPW_C_INVALID_CATEGORY_NAME カテゴリ名称が指定されていない、または不正です。
static String | BPW_C_INVALID_CONDITION_TYPE 分岐種別が不正です。
static String | BPW_C_INVALID_DB_PRIMARY_KEY 指定情報のデータベースプライマリキー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。
static String | BPW_C_INVALID_LOGIN_GROUP_ID ログイングループIDが指定されていない、または不正です。
static String | BPW_C_INVALID_LOGIN_USER_ID ログインユーザIDが指定されていない、または不正です。
static String | BPW_C_INVALID_NECESSARY_KEY 指定情報の入力必須キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static String | BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY 検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static String | BPW_C_INVALID_PROCESS_DEF_NAME プロセス定義名称が指定されていない、または不正です。
static String | BPW_C_INVALID_PROCESSDEF 関連付けるプロセス定義情報が存在しない、または無効です。
static String | BPW_C_INVALID_REFER_FLAG 参照権限フラグが不正です。
static String | BPW_C_INVALID_REMINDER_TYPE 催促メール対象種別が不正です。
static String | BPW_C_INVALID_RETURN_FLG 引戻し／差戻しは行えません。
static String | BPW_C_INVALID_RETURN_START_RUN_USER_INFO 申請者への差し戻しイベントに失敗しました。
static String | BPW_C_INVALID_ROOT_NAME 申請できません。
static String | BPW_C_INVALID_RUN_EXECUTIVE_TYPE 実行主体種別が不正です。
static String | BPW_C_INVALID_SELECT_CONDITION_PHRASE 条件句の指定が不正です。
static String | BPW_C_INVALID_SELECT_IN_PHRASE IN指定は他の条件と複合して設定不可能です。
static String | BPW_C_INVALID_TRANSFER_CD_KIND 代理承認者コード種別が不正です。
static String | BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY 検索実行時のプライマリキー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
static String | BPW_C_MAGICAL_ACTIVE_ACTIVITY 強制活性化に失敗しました。
static String | BPW_C_MAGICAL_DEACTIVE_PROCESS 強制活性化に失敗しました。
static String | BPW_C_MAGICAL_PLURAL_RUN_USER 強制活性化に失敗しました。
static String | BPW_C_MAGICAL_RUN_USER 強制活性化に失敗しました。
static String | BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND メールテンプレートの取得に失敗しました。
static String | BPW_C_MOVE_ACTIVITY_RETURN_PULL この案件は引戻し出来ません。
static String | BPW_C_NO_ATTACH_POSITION_GROUP 申請できません。
static String | BPW_C_NO_ATTACH_POSITION_GROUP_AGENT 申請できません。
static String | BPW_C_NO_EVENT_ADAPTER イベント実行情報が存在しない。
static String | BPW_C_NO_EXECUTE_ADAPTER 外部実行クラスが存在しません。
static String | BPW_C_NO_EXECUTIVE_GROUP 実行主体役職マスタに対象グループが登録されていません。
static String | BPW_C_NO_FLOW_MASTER_INFO フロー内容マスタ情報が設定されていません。
static String | BPW_C_NO_INSERT_VALUE 更新情報が設定されていません。
static String | BPW_C_NO_PROCESS_ADAPTER 実行プロセスが存在しません。
static String | BPW_C_NO_ROUTE_SELECT_MASTER ルート選択マスタ情報が設定されてません。
static String | BPW_C_NO_RUN_SELECT_ACTIVITY 実行時選択可能なアクティビティではありません。
static String | BPW_C_NO_RUN_SELECT_USER 実行時選択ユーザが指定されていません。
static String | BPW_C_NO_RUNUSER_EXCUTIVE_INFO 実行主体役職マスタ情報が設定されていません。
static String | BPW_C_NO_RUNUSER_MASTER_INFO 実行主体ユーザマスタ情報が設定されていません。
static String | BPW_C_NO_SELECTED_TARGET_TASK 申請できません。
static String | BPW_C_NO_SEQUENCE_MASTER_INFO シーケンス内容マスタ情報が設定されていません。
static String | BPW_C_NO_SWHITCH_MASTER_INFO スイッチマスタ情報が設定されていません。
static String | BPW_C_NO_TRANSFER_AUTHORITY 代理申請権限がありません。
static String | BPW_C_NO_USER_CD ユーザコードが存在しません。
static String | BPW_C_NOT_ACTIVITY 関連付けるアクティビティ情報が存在しません。
static String | BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL メール送信送信対象アクティビティ情報が存在しません。
static String | BPW_C_NOT_ACTIVITY_MASTER アクティビティマスタ情報が存在しません。
static String | BPW_C_NOT_BACK_IN_FLOW 同期処理内より、処理外への引戻し／差戻しは行えません。
static String | BPW_C_NOT_DELEGATE_AGENT 振替が出来ません。
static String | BPW_C_NOT_DELEGATE_AGENT_SET 振替が出来ません。
static String | BPW_C_NOT_DELEGATE_ALREADY 振替が出来ません。
static String | BPW_C_NOT_DELEGATE_ALREADY_RIGHT 振替が出来ません。
static String | BPW_C_NOT_DELEGATE_BACK 振替が出来ません。
static String | BPW_C_NOT_DELEGATE_CIRCULATION 振替が出来ません。
static String | BPW_C_NOT_DELETE_VERSION_LASTRECORD 履歴情報を削除できません。
static String | BPW_C_NOT_EFFECTIVE_DATE 現在日は有効な日付ではありません。
static String | BPW_C_NOT_EXIST_ROLE ロールIDが不正です。
static String | BPW_C_NOT_GET_PROCESS_CODE 案件番号の取得に失敗しました。
static String | BPW_C_NOT_GROUP_TABLE 関連付ける実行主体グループテーブルが存在しません。
static String | BPW_C_NOT_INSERT_HISTORY_TABLE_INFO 処理履歴情報の登録に失敗しました。
static String | BPW_C_NOT_INSERT_MONITORING_TABLE_INFO モニタリング情報の登録に失敗しました。
static String | BPW_C_NOT_NUMBER_CATEGORY カテゴリコードが不正です。
static String | BPW_C_NOT_PROCESS 関連付けるプロセス情報が存在しません。
static String | BPW_C_NOT_PROCESSDEF 関連付けるプロセス定義情報が存在しません。
static String | BPW_C_NOT_PULL_DRAFT_ACTIVITY 引き戻し先アクティビティが存在しません。
static String | BPW_C_NOT_RECEIVE_TABLE 関連付くレシーブ情報が存在しません。
static String | BPW_C_NOT_RETURN_ACTIVITY アクティビティが存在しません。
static String | BPW_C_NOT_ROOT_HISTORY_INFO ルート作成履歴情報が存在しません。
static String | BPW_C_NOT_RUN_EXECUTIVE_MASTER 指定された実行主体役職マスタ情報が存在しません。
static String | BPW_C_NOT_RUN_USER_AUTHORITY 権限がありません。
static String | BPW_C_NOT_RUN_USER_INFO 既に他のユーザに処理された可能性があります。
static String | BPW_C_NOT_RUN_USER_MASTER 実行主体ユーザマスタ情報が存在しません。
static String | BPW_C_NOT_RUN_USER_TABLE 実行主体ユーザ情報が存在しません。
static String | BPW_C_NOT_SET_INVALID_FLAG 論理削除されているデータを更新しようとした場合に発生するエラーです。
static String | BPW_C_NOT_SYNCRONIZED 同期情報が設定されていません。
static String | BPW_C_NOT_TRANSFER_PROCESS_DEF_DATA 代理設定対象プロセス定義情報が取得できませんでした。
static String | BPW_C_NOT_TRANSFER_TASK_DATA 代理設定対象タスク情報が取得できませんでした。
static String | BPW_C_NOT_TRANSFER_VERSION_DATA 代理設定対象バージョン情報が取得できませんでした。
static String | BPW_C_NOT_VERSION 関連付ける履歴情報が存在しません。
static String | BPW_C_PRAM_ERROR パラメータエラーです。
static String | BPW_C_PROCESS_COUNT_FILE_NOT_FOUND 案件番号の採番処理に失敗しました。
static String | BPW_C_PROCESS_COUNT_FILE_READ_ONLY 案件番号の採番処理に失敗しました。
static String | BPW_C_REPEAT_ORDER_BY_VALUE ORDER BY句に指定されたカラム名が重複しています。
static String | BPW_C_SHIFT_REFER_DUPLICATION 参照者マスタ移行が出来ません。
static String | BPW_C_ZERO_MEMBER_COMPANY 指定された組織に属するユーザが存在しません。
static String | BPW_CORE_FAILED_GET_FILESTREAM ファイルストリーム取得に失敗しました。
static String | BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW プロセス定義種別がビジネスプロセスワークフローの場合、コンテンツフレーム種別にカスタムを設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE サブプロセスに申請者/承認者ルート作成ワークフローが設定されているタスクの直前に 申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CUSTOM サブプロセスに申請者/承認者ルート作成ワークフローが設定されている場合、 直前のタスクのコンテンツフレーム種別にカスタムを設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW 同期の開始・結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH 分岐の開始直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE 起票タスクのタスク種別に誤りがあります。
static String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH 承認者種別が実行時選択のタスクを 同期・分岐・ルート選択の開始直後に設定する事はできません。
static String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK 起票タスクに動的承認者は設定できません。
static String | BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER 同期タスクの結合直後に動的な対象者を設定する事はできません。
static String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT 分岐内に1ルートしか設定されていません。
static String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT 分岐内のタスク設定に誤りがあります。
static String | BPW_CORE_IMPORT_INVALID_INVOKE_TASK プロセス種別がビジネスプロセスワークフロー以外の場合、自動実行タスク、イベント実行タスクを設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE ルート選択内に処理タスクがない場合、ルート選択結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_PARALLEL_SWITCH_AFTER_DYNAMIC_USER 複数ルートの分岐タスクの結合直後に動的な対象者を設定する事はできません。
static String | BPW_CORE_IMPORT_INVALID_ROOT_SETTING ルート定義に誤りがあります。
static String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE ルート選択タスクの直前に申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW 同期の開始・結合直後にルート選択タスクを設定することはできません。
static String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH 分岐・ルート選択の開始直後にルート選択タスクを設定する事はできません。
static String | BPW_CORE_IMPORT_NO_RECEIVE_TASK 起票(処理)タスクが設定されていない可能性があります。
static String | BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO サブプロセス設定情報が設定されていません。
static String | BPW_CORE_NUMBERING_INVALID_PARAMETER 採番処理にて指定したパラメータに誤りがあります。
static String | BPW_CORE_USER_SETTING_PATTERN 対象データはユーザに選択されている可能性があります。
static String | BPW_FLOWINFO_INVALID_PARAMETER フローアイコンを取得する際の入力パラメータ不正です。
static String | BPW_FLOWINFO_NO_EXIST_FLOWICON フローアイコンが存在しません。
static String | BPW_INVALID_DRAFT_COMMENT_LENGTH 申請コメントの入力文字数が制限を越えています。
static String | BPW_INVALID_PROCESS_NAME_LENGTH プロセス名の入力文字数が制限を越えています。
static String | BPW_INVALID_RECEIVE_COMMENT_LENGTH 審議コメントの入力文字数が制限を越えています。
static String | BPW_UT_FAILED_TO_BEGIN ユーザトランザクションの開始に失敗しました。
static String | BPW_UT_FAILED_TO_CLOSE ユーザトランザクションの終了に失敗しました。
static String | BPW_UT_FAILED_TO_COMMIT ユーザトランザクションのコミットに失敗しました。
static String | BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION トランザクションが開始していないためコミットに失敗しました。
static String | BPW_UT_FAILED_TO_GET_STATUS ユーザトランザクションのステータスの取得に失敗しました。
static String | BPW_UT_FAILED_TO_LOCK ユーザアプリケーションロックの解除に失敗しました。
static String | BPW_UT_FAILED_TO_ROLLBACK ユーザトランザクションのロールバックに失敗しました。
static String | BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION トランザクションが開始していないためロールバックに失敗しました。
static String | BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY ユーザトランザクションのロールバックオンリーの設定に失敗しました。
static String | BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT ユーザトランザクションのトランザクションタイムアウトの設定に失敗しました。
static String | BPW_UT_FAILED_TO_UNLOCK ユーザアプリケーションロックの解除に失敗しました。

フィールドの詳細

BPW_C_PRAM_ERROR

public static final String BPW_C_PRAM_ERROR
パラメータエラーです。

関連項目:
定数フィールド値

BPW_C_HAVE_NOT_AUTHORITY

public static final String BPW_C_HAVE_NOT_AUTHORITY
権限がありません。 このエラーコードは参照・更新要求時に対象データに対する権限がない場合に発生します。 処理委譲を行っている場合も該当します。

関連項目:
定数フィールド値

BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND

public static final String BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND
権限、及び権限に関連する情報がありません。 このエラーコードは履歴情報取得時に発生します。 権限情報そのものが存在しない、及び権限に関連するプロセス定義情報、 または履歴情報が存在しない可能性があります。

関連項目:
定数フィールド値

BPW_C_DATA_NOT_FOUND

public static final String BPW_C_DATA_NOT_FOUND
データが存在しません。 このエラーコードは取得要求時ではなく、更新・削除要求時に対象データが 既に削除されて存在しない場合に発生します。 再度情報の取得を実施してデータが存在するか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_CHANGE_INFO

public static final String BPW_C_CHANGE_INFO
他のユーザに情報が変更されました。 修正・削除対象のデータは、他のユーザによって変更されています。 再度情報を取得した後に修正・削除を行う必要があります。

関連項目:
定数フィールド値

BPW_C_CHANGE_AGENTSETTING

public static final String BPW_C_CHANGE_AGENTSETTING
他のユーザにより変更された可能性があります。 該当の代理設定は既に他のユーザによって変更された可能性があります。 最新の情報を確認後、必要に応じて設定を行ってください。

関連項目:
定数フィールド値

BPW_C_CHANGING_NOW

public static final String BPW_C_CHANGING_NOW
関連する情報が修正中であり反映できません。 要求された操作を行うと整合性エラーが発生する可能性があるため、反映できません。 しばらくしてから、再度実行する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CATEGORY

public static final String BPW_C_INVALID_CATEGORY
関連付けるカテゴリ情報が存在しない、または無効です。 履歴情報に関連付けようとしたカテゴリ情報が存在しないか、または無効です。 カテゴリ情報が存在し、かつ無効でないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_PROCESSDEF

public static final String BPW_C_NOT_PROCESSDEF
関連付けるプロセス定義情報が存在しません。 履歴情報を登録する際にのみ発生し、履歴情報に関連付けようとしたプロセス定義情報が存在しません。 プロセス定義情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_PROCESSDEF

public static final String BPW_C_INVALID_PROCESSDEF
関連付けるプロセス定義情報が存在しない、または無効です。 履歴情報に関連付けようとしたプロセス定義情報が存在しないか、または無効です。 プロセス定義情報が存在し、かつ無効でないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_VERSION

public static final String BPW_C_NOT_VERSION
関連付ける履歴情報が存在しません。 プロセス、もしくはワークフロー情報を登録する際に発生します。 それぞれの情報に関連付けようとした履歴情報が存在しません。 履歴情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_GROUP_TABLE

public static final String BPW_C_NOT_GROUP_TABLE
関連付ける実行主体グループテーブルが存在しません。 実行主体グループテーブルが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_VERSION

public static final String BPW_C_FOUND_VERSION
関連付く履歴情報が存在します。 プロセス定義、もしくはカテゴリ情報を削除する際に発生します。 それぞれの情報に関連付けた履歴情報が存在するため削除できません。 関連のある履歴情報を削除した後に削除する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_PROCESS

public static final String BPW_C_NOT_PROCESS
関連付けるプロセス情報が存在しません。 アクティビティ情報を登録、更新、削除する際に発生します。 アクティビティ情報に関連付けるプロセス情報が存在しません。 プロセス情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_ACTIVITY

public static final String BPW_C_NOT_ACTIVITY
関連付けるアクティビティ情報が存在しません。 アクティビティ情報に関連付く実行主体ユーザ情報、自動パス情報、レシーブ情報を 登録、更新する際に関連付くアクティビティ情報が存在しないか、もしくは他の処理時に必要なアクティビティ情報を 検索した際に発生します。 アクティビティ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL

public static final String BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL
メール送信送信対象アクティビティ情報が存在しません。 メール送信送信対象のアクティビティ情報を検索した際に発生します。 メール送信送信対象のアクティビティ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_RUN_USER_TABLE

public static final String BPW_C_FOUND_RUN_USER_TABLE
関連付く実行主体ユーザ情報が存在します。 アクティビティ情報に関連付いた実行主体ユーザ情報が存在するため、削除できません。 関連のある実行主体ユーザ情報を削除した後、削除する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_TABLE

public static final String BPW_C_NOT_RUN_USER_TABLE
実行主体ユーザ情報が存在しません。 実行主体ユーザ情報を検索した際に発生します。 指定した実行主体ユーザ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_MASTER

public static final String BPW_C_NOT_RUN_USER_MASTER
実行主体ユーザマスタ情報が存在しません。 実行主体ユーザマスタ情報を検索した際に発生します。 指定した実行主体ユーザマスタ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_AUTO_PASS_TABLE

public static final String BPW_C_FOUND_AUTO_PASS_TABLE
関連付く自動パス情報が存在します。 アクティビティ情報に関連付いた自動パス情報が存在するために削除できません。 関連のある自動パス情報を削除した後、削除する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_RECEIVE_TABLE

public static final String BPW_C_FOUND_RECEIVE_TABLE
関連付くレシーブ情報が存在します。 アクティビティ情報に関連付いたレシーブ情報が存在するために削除できません。 関連のあるレシーブ情報を削除した後、レシーブ情報を削除する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RECEIVE_TABLE

public static final String BPW_C_NOT_RECEIVE_TABLE
関連付くレシーブ情報が存在しません。 アクティビティ情報に関連付いたレシーブ情報が存在しない場合に発生します。 関連のあるレシーブ情報が削除されていないか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_FOUND_RECEIVE_MASTER

public static final String BPW_C_FOUND_RECEIVE_MASTER
レシーブマスタ情報が存在しません。 必要なレシーブマスタ情報を検索した際、レシーブマスタ情報が存在しない場合に発生します。 レシーブマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_FOUND_PROCESS

public static final String BPW_C_FOUND_PROCESS
関連付くプロセス情報が存在します。 履歴情報に関連付いたプロセスが存在するために削除できません。 関連のあるプロセスを削除した後、履歴情報を削除する必要があります。

関連項目:
定数フィールド値

BPW_C_EXIST_PROCESS_DEF

public static final String BPW_C_EXIST_PROCESS_DEF
有効なプロセス定義が存在します。 関連付いたプロセス定義が有効なため、更新・削除ができません。

関連項目:
定数フィールド値

BPW_C_FOUND_RUNNING_PROCESS

public static final String BPW_C_FOUND_RUNNING_PROCESS
実行中のプロセスが存在します。 関連付いたプロセスが実行中であるため、更新・削除ができません。

関連項目:
定数フィールド値

BPW_C_NOT_ACTIVITY_MASTER

public static final String BPW_C_NOT_ACTIVITY_MASTER
アクティビティマスタ情報が存在しません。 処理に必要なアクティビティマスタ情報を検索した際に発生します。 アクティビティマスタ情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_EXECUTIVE_MASTER

public static final String BPW_C_NOT_RUN_EXECUTIVE_MASTER
指定された実行主体役職マスタ情報が存在しません。 実行主体役職マスタ情報を参照した際に、指定された実行主体役職マスタ情報が存在しない場合に発生します。 実行主体役職マスタ情報が定義されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_SYNCRONIZED

public static final String BPW_C_NOT_SYNCRONIZED
同期情報が設定されていません。 更新・削除実施時に指定するべき同期情報が指定されていないか、誤った同期情報が指定されています。 例えば、履歴情報の更新・削除をＷＥＢ層より実行する際は、一旦対象の履歴情報を参照し、 取得した同期情報を指定する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_DELETE_VERSION_LASTRECORD

public static final String BPW_C_NOT_DELETE_VERSION_LASTRECORD
履歴情報を削除できません。 履歴情報を削除する際に削除対象レコードが最後の１件である場合に発生します。 履歴情報の最後の１件を削除するには、プロセス定義より削除する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CATEGORY_NAME

public static final String BPW_C_INVALID_CATEGORY_NAME
カテゴリ名称が指定されていない、または不正です。 カテゴリ情報登録時にカテゴリ名称が指定されていないか、または不正な場合に発生します。 正しくカテゴリ名称を指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_PROCESS_DEF_NAME

public static final String BPW_C_INVALID_PROCESS_DEF_NAME
プロセス定義名称が指定されていない、または不正です。 プロセス定義情報登録時にプロセス定義名称が指定されていないか、または不正な場合に発生します。 正しくプロセス定義名称を指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_CATEGORY_CODE

public static final String BPW_C_INVALID_CATEGORY_CODE
カテゴリコードが指定されていない、または不正です。 プロセス定義情報登録時にカテゴリコードが指定されていないか、または不正な場合に発生します。 正しくカテゴリコードを指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_LOGIN_USER_ID

public static final String BPW_C_INVALID_LOGIN_USER_ID
ログインユーザIDが指定されていない、または不正です。 正しいログインユーザIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_LOGIN_GROUP_ID

public static final String BPW_C_INVALID_LOGIN_GROUP_ID
ログイングループIDが指定されていない、または不正です。 正しいログイングループIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_DB_PRIMARY_KEY

public static final String BPW_C_INVALID_DB_PRIMARY_KEY
指定情報のデータベースプライマリキー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。 データベースの更新・削除時に発生します。 プライマリキー値がすべて指定されている、もしくは正しいプライマリキーが 指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY

public static final String BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY
検索実行時のプライマリキー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 ワークフロー情報の検索時に発生します。 検索対象として指定するワークフロー情報のプライマリキー値がすべて指定されている、 もしくは正しいプライマリキーが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_NECESSARY_KEY

public static final String BPW_C_INVALID_NECESSARY_KEY
指定情報の入力必須キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 データベースの更新・削除時に発生します。 プライマリキー値、およびログインユーザID・ログイングループIDがすべて指定されている、 もしくは正しい値が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY

public static final String BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY
検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。 プロセスコンテンツマスタ情報の検索時に発生します。 検索対象として指定するプロセスコンテンツマスタ情報の指定キー値がすべて指定されている、 もしくは正しい指定キーが指定されていることを確認する必要があります。 指定キーは、プロセス定義コード、履歴コード、アクティビティコードです。

関連項目:
定数フィールド値

BPW_C_INVALID_SELECT_IN_PHRASE

public static final String BPW_C_INVALID_SELECT_IN_PHRASE
IN指定は他の条件と複合して設定不可能です。 IN指定が他の条件と複合して設定された場合に発生します。 カラムの検索条件にIN句を指定した場合は、他の条件句(イコール等)は指定できません。 他の条件句を指定していないか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_SELECT_CONDITION_PHRASE

public static final String BPW_C_INVALID_SELECT_CONDITION_PHRASE
条件句の指定が不正です。 カラムの検索条件にサポート外の条件句が指定された場合に発生します。 サポート外の条件句を指定していないか確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_INSERT_VALUE

public static final String BPW_C_NO_INSERT_VALUE
更新情報が設定されていません。 更新情報が設定されていない場合に発生します。 UPDATE対象とする更新情報が設定されている確認する必要があります。

関連項目:
定数フィールド値

BPW_C_REPEAT_ORDER_BY_VALUE

public static final String BPW_C_REPEAT_ORDER_BY_VALUE
ORDER BY句に指定されたカラム名が重複しています。 ORDER BY句に重複したカラム名を設定した場合に発生します。 同一カラム名をORDER BY句に複数指定することはできません。

関連項目:
定数フィールド値

BPW_C_INVALID_ACTIVITY_STATUS

public static final String BPW_C_INVALID_ACTIVITY_STATUS
アクティビティステータスが不正です。 取得したアクティビティステータスが想定外のステータスであった場合に発生します。 正しいアクティビティステータスが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_ACTIVITY_TYPE

public static final String BPW_C_INVALID_ACTIVITY_TYPE
アクティビティ種別が不正です。 取得したアクティビティ種別が想定外の種別であった場合に発生します。 正しいアクティビティ種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_TRANSFER_CD_KIND

public static final String BPW_C_INVALID_TRANSFER_CD_KIND
代理承認者コード種別が不正です。 取得した代理承認者コード種別が想定外の種別であった場合に発生します。 正しい代理承認者コード種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_REMINDER_TYPE

public static final String BPW_C_INVALID_REMINDER_TYPE
催促メール対象種別が不正です。 取得した催促メール対象種別が想定外の種別であった場合に発生します。 正しい催促メール対象種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_REFER_FLAG

public static final String BPW_C_INVALID_REFER_FLAG
参照権限フラグが不正です。 アクティビティテーブルの検索時に指定された参照権限フラグが想定外の値であった場合に発生します。 正しい参照権限フラグ値が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_APPROVAL_TYPE

public static final String BPW_C_INVALID_APPROVAL_TYPE
承認種別が不正です。 指定された承認種別が想定外の値であった場合に発生します。 正しい承認種別が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_APPROVAL_USER

public static final String BPW_C_INVALID_APPROVAL_USER
承認ユーザコードが不正です。 指定された承認ユーザコードが想定外の値であった場合に発生します。 正しい承認ユーザコードが設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_RUN_EXECUTIVE_TYPE

public static final String BPW_C_INVALID_RUN_EXECUTIVE_TYPE
実行主体種別が不正です。 取得した実行主体種別が想定外の値であった場合に発生します。 正しい実行主体種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_ADAPTER_TYPE

public static final String BPW_C_INVALID_ADAPTER_TYPE
アダプタ種別が不正です。 取得したアダプタ種別が想定外の値であった場合に発生します。 正しいアダプタ種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_TRANSFER_AUTHORITY

public static final String BPW_C_NO_TRANSFER_AUTHORITY
代理申請権限がありません。 代理申請指定された際に代理申請権限がない場合に発生します。 指定したユーザに代理申請権限があることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_RETURN_ACTIVITY

public static final String BPW_C_NOT_RETURN_ACTIVITY
アクティビティが存在しません。 指定されたアクティビティのアクティビティが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_PULL_DRAFT_ACTIVITY

public static final String BPW_C_NOT_PULL_DRAFT_ACTIVITY
引き戻し先アクティビティが存在しません。 指定されたアクティビティの引き戻し先アクティビティが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_NO_RUN_SELECT_USER

public static final String BPW_C_NO_RUN_SELECT_USER
実行時選択ユーザが指定されていません。 実行時選択ユーザ登録時に実行時選択ユーザが指定されていない場合に発生します。 実行時選択ユーザが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_RUN_SELECT_ACTIVITY

public static final String BPW_C_NO_RUN_SELECT_ACTIVITY
実行時選択可能なアクティビティではありません。 実行時選択対象でないアクティビティに対し実行時選択指定を行った場合に発生します。 実行時選択可能アクティビティであることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_EXECUTIVE_GROUP

public static final String BPW_C_NO_EXECUTIVE_GROUP
実行主体役職マスタに対象グループが登録されていません。 実行主体役職マスタにコード種別がグループのデータが登録されていない場合に発生します。 コード種別がグループのデータが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_USER_CD

public static final String BPW_C_NO_USER_CD
ユーザコードが存在しません。 実行主体役職マスタに登録されているコードに該当するユーザコードが存在しない場合に発生します。 実行主体役職マスタに登録されているコードが正しいことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_EXECUTE_ADAPTER

public static final String BPW_C_NO_EXECUTE_ADAPTER
外部実行クラスが存在しません。 オートアダプタ情報の検索時に該当する情報が存在しない場合に発生します。 該当するオートアダプタ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_PROCESS_ADAPTER

public static final String BPW_C_NO_PROCESS_ADAPTER
実行プロセスが存在しません。 プロセスアダプタ情報の検索時に該当する情報が存在しない場合に発生します。 該当するプロセスアダプタ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_EVENT_ADAPTER

public static final String BPW_C_NO_EVENT_ADAPTER
イベント実行情報が存在しない。 イベントアダプタ情報の検索時に該当する情報が存在しない場合に発生します。 該当するイベントアダプタ情報が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NOT_EFFECTIVE_DATE

public static final String BPW_C_NOT_EFFECTIVE_DATE
現在日は有効な日付ではありません。 プロセス登録の際に現在日が有効日付より過去の場合に発生します。 プロセスの登録は有効日付以降に可能となります。

関連項目:
定数フィールド値

BPW_C_ILLIGAL_STATUS

public static final String BPW_C_ILLIGAL_STATUS
ステータスが異常です。 プロセス、アクティビティ・ステータスの異常により発生します。

関連項目:
定数フィールド値

BPW_C_ILLIGAL_STATUS_CHG

public static final String BPW_C_ILLIGAL_STATUS_CHG
ステータス遷移が異常です。 プロセス、アクティビティ・ステータスの遷移異常により発生します。

関連項目:
定数フィールド値

BPW_C_NO_RUNUSER_MASTER_INFO

public static final String BPW_C_NO_RUNUSER_MASTER_INFO
実行主体ユーザマスタ情報が設定されていません。 ワークフロー情報の登録時に実行主体ユーザマスタ情報が設定されていない場合に発生します。 実行主体ユーザマスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_RUNUSER_EXCUTIVE_INFO

public static final String BPW_C_NO_RUNUSER_EXCUTIVE_INFO
実行主体役職マスタ情報が設定されていません。 ワークフロー情報の登録時に実行主体役職マスタ情報が設定されていない場合に発生します。 実行主体役職マスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_SEQUENCE_MASTER_INFO

public static final String BPW_C_NO_SEQUENCE_MASTER_INFO
シーケンス内容マスタ情報が設定されていません。 ワークフロー情報の登録時にシーケンス内容マスタ情報が設定されていない場合に発生します。 シーケンス内容マスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_FLOW_MASTER_INFO

public static final String BPW_C_NO_FLOW_MASTER_INFO
フロー内容マスタ情報が設定されていません。 ワークフロー情報の登録時にフロー内容マスタ情報が設定されていない場合に発生します。 フロー内容マスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_SWHITCH_MASTER_INFO

public static final String BPW_C_NO_SWHITCH_MASTER_INFO
スイッチマスタ情報が設定されていません。 ワークフロー情報の登録時にスイッチマスタ情報が設定されていない場合に発生します。 スイッチマスタ情報が設定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_ALREADY_EXIST_TRANSFER

public static final String BPW_C_ALREADY_EXIST_TRANSFER
処理委譲できません。 処理委譲設定時に該当アクティビティステータスがアクティブの場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_ACTIVE_ACTIVITY

public static final String BPW_C_MAGICAL_ACTIVE_ACTIVITY
強制活性化に失敗しました。 強制的に活性化しようとしたアクティビティが、既に活性化済みの場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_DEACTIVE_PROCESS

public static final String BPW_C_MAGICAL_DEACTIVE_PROCESS
強制活性化に失敗しました。 強制的に活性化しようとしたアクティビティを保有するプロセスが、活性化状態で場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_RUN_USER

public static final String BPW_C_MAGICAL_RUN_USER
強制活性化に失敗しました。 強制的に活性化しようとしたアクティビティが実行時選択ユーザである場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAGICAL_PLURAL_RUN_USER

public static final String BPW_C_MAGICAL_PLURAL_RUN_USER
強制活性化に失敗しました。 強制移動するタスク内に複数処理対象者が存在する場合に発生します。。

関連項目:
定数フィールド値

BPW_C_CAN_NOT_START_JAVASCRIPT

public static final String BPW_C_CAN_NOT_START_JAVASCRIPT
JavaScriptが起動できません。 JavaScriptの起動に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_DUPLICATE_NAME

public static final String BPW_C_DUPLICATE_NAME
名称が重複しています。 カテゴリ名、プロセス定義名の重複登録時に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_SET_INVALID_FLAG

public static final String BPW_C_NOT_SET_INVALID_FLAG
論理削除されているデータを更新しようとした場合に発生するエラーです。 更新制御時、論理削除フラグＯＮの場合に発生します。

関連項目:
定数フィールド値

BPW_C_AUTO_EXECUTE_FAULT

public static final String BPW_C_AUTO_EXECUTE_FAULT
自動実行処理が異常復帰しました。

関連項目:
定数フィールド値

BPW_C_MOVE_ACTIVITY_RETURN_PULL

public static final String BPW_C_MOVE_ACTIVITY_RETURN_PULL
この案件は引戻し出来ません。 もう一度、表示しなおして下さい。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_BACK

public static final String BPW_C_NOT_DELEGATE_BACK
振替が出来ません。 差戻しルート上の処理対象者を振替ることは出来ません。 処理対象者へは振替える事が出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_AGENT

public static final String BPW_C_NOT_DELEGATE_AGENT
振替が出来ません。 代理処理者を振替ることは出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_AGENT_SET

public static final String BPW_C_NOT_DELEGATE_AGENT_SET
振替が出来ません。 代理者が設定されている処理者を振替ることは出来ません。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_ALREADY

public static final String BPW_C_NOT_DELEGATE_ALREADY
振替が出来ません。 対象者は既に振替処理を実施済みです。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_ALREADY_RIGHT

public static final String BPW_C_NOT_DELEGATE_ALREADY_RIGHT
振替が出来ません。 振替先指定者は既に承認権限を有しています。

関連項目:
定数フィールド値

BPW_C_NOT_DELEGATE_CIRCULATION

public static final String BPW_C_NOT_DELEGATE_CIRCULATION
振替が出来ません。 既に同様な設定が行われ、かつ振替先は再度振替られています。

関連項目:
定数フィールド値

BPW_C_ZERO_MEMBER_COMPANY

public static final String BPW_C_ZERO_MEMBER_COMPANY
指定された組織に属するユーザが存在しません。 もう一度ユーザか組織を選択してください。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_GET_USER_APP_KEY

public static final String BPW_C_INPOSSIBLE_GET_USER_APP_KEY
ユーザアプリケーションキー取得イベントに失敗しました。 ユーザアプリケーションキー取得イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN

public static final String BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN
プロセス定義コード長が不正です。 プロセス定義コード長が不正な場合に発生します。 プロセス定義コード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN

public static final String BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN
カテゴリコード長が不正です。 カテゴリコード長が不正な場合に発生します。 カテゴリコード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN

public static final String BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN
プロセス定義名長が最大文字列長を超えています。 プロセス定義名長が最大文字列長を超えている場合に発生します。 プロセス定義名長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_NOTE_LEN

public static final String BPW_C_IMPORT_OVER_NOTE_LEN
備考文字列長が最大文字列長を超えています。 備考文字列長が最大文字列長を超えている場合に発生します。 備考文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD

public static final String BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD
プロセス種別が不正です。 プロセス種別が想定外の値であった場合に発生します。 正しいプロセス種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EFFECTIVE_DATE

public static final String BPW_C_IMPORT_INVALID_EFFECTIVE_DATE
有効日付が指定されていない、または不正です。 有効日付が指定されていないか、または不正な場合に発生します。 正しい有効日付が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_END_DATE

public static final String BPW_C_IMPORT_INVALID_END_DATE
終了日付が指定されていない、または不正です。 終了日付が指定されていないか、または不正な場合に発生します。 正しい終了日付が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN

public static final String BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN
プロセス種別文字列長が最大文字列長を超えています。 プロセス種別文字列長が最大文字列長を超えている場合に発生します。 プロセス種別文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN

public static final String BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN
有効日付長が不正です。 有効日付長が不正な場合に発生します。 有効日付長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_END_DATE_LEN

public static final String BPW_C_IMPORT_INVALID_END_DATE_LEN
終了日付長が不正です。 終了日付長が不正な場合に発生します。 終了日付長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN

public static final String BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN
プロセス定義備考文字列長が最大文字列長を超えています。 プロセス定義備考文字列長が最大文字列長を超えている場合に発生します。 プロセス定義備考文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_VERSION_CD_LEN

public static final String BPW_C_IMPORT_INVALID_VERSION_CD_LEN
履歴コード長が不正です。 履歴コード長が不正な場合に発生します。 履歴コード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_VERSION_CD

public static final String BPW_C_IMPORT_INVALID_VERSION_CD
履歴コードが指定されていない、または不正です。 履歴コードが指定されていないか、または不正な場合に発生します。 正しい履歴コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE

public static final String BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE
コンテンツ種別が指定されていない、または不正です。 コンテンツ種別が指定されていないか、または不正な場合に発生します。 正しいコンテンツ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND

public static final String BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND
ページ種別が指定されていない、または不正です。 ページ種別が指定されていないか、または不正な場合に発生します。 正しいページ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID

public static final String BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID
アプリケーションIDが指定されていない、または不正です。 アプリケーションIDが指定されていないか、または不正な場合に発生します。 正しいアプリケーションIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID

public static final String BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID
サービスIDが指定されていない、または不正です。 サービスIDが指定されていないか、または不正な場合に発生します。 正しいサービスIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN

public static final String BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN
アプリケーションID長が不正です。 アプリケーションID長が不正な場合に発生します。 アプリケーションID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN

public static final String BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN
サービスID長が不正です。 サービスID長が不正な場合に発生します。 サービスID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH

public static final String BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH
コンテンツパスが指定されていない、または不正です。 コンテンツパスが指定されていないか、または不正な場合に発生します。 正しいコンテンツパスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN

public static final String BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN
コンテンツパス長が不正です。 コンテンツパス長が不正な場合に発生します。 コンテンツパス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID

public static final String BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID
ルート定義IDが重複して指定されています。 ルート定義IDが著服して指定されている場合に発生します。 ルート定義IDが重複して指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_LICENSE

public static final String BPW_C_IMPORT_NO_LICENSE
指定されたプロセス種別に対するライセンスがありません。 指定されたプロセス種別に対するライセンスがない場合に発生します。 ライセンスに応じたプロセス種別を指定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_TASK_DEF

public static final String BPW_C_IMPORT_NO_TASK_DEF
タスク定義が指定されていません。 タスク定義が指定されていない場合に発生します。 タスク定義が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_COMPULSION_END_FLG

public static final String BPW_C_IMPORT_INVALID_COMPULSION_END_FLG
強制終了可否フラグが指定されていない、または不正です。 強制終了可否フラグが指定されていないか、または不正な場合に発生します。 正しい強制終了可否フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RETURN_PULL_FLG

public static final String BPW_C_IMPORT_INVALID_RETURN_PULL_FLG
引戻し・差戻しフラグが指定されていない、または不正です。 引戻し・差戻しフラグが指定されていないか、または不正な場合に発生します。 正しい引戻し・差戻しフラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG

public static final String BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG
引戻し・差戻しメール送信フラグが指定されていない、または不正です。 引戻し・差戻しメール送信フラグが指定されていないか、または不正な場合に発生します。 正しい引戻し・差戻しメール送信フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG

public static final String BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG
最短終了フラグが指定されていない、または不正です。 最短終了フラグが指定されていないか、または不正な場合に発生します。 正しい最短終了フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION

public static final String BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION
シート内でプロセス定義名が重複しています。 シート内で同一のプロセス定義名が存在する場合に発生します。 重複しないプロセス定義名を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_FLG

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_FLG
自動パス処理フラグが指定されていない、または不正です。 自動パス処理フラグが指定されていないか、または不正な場合に発生します。 正しい自動パス処理フラグが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_TERM

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_TERM
自動パス期限が不正です。 自動パス期限が数字以外な場合に発生します。 自動パス期限が数字で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN
自動パス期限長が不正です。 自動パス期限長が不正な場合に発生します。 自動パス期限長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RECEIVE_MASTER

public static final String BPW_C_IMPORT_NO_RECEIVE_MASTER
レシーブマスタ情報が設定されてません。 ワークフロー登録時に、レシーブマスタ情報が存在しない場合に発生します。 レシーブマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RUN_USER_MASTER

public static final String BPW_C_IMPORT_NO_RUN_USER_MASTER
実行主体ユーザマスタ情報が設定されてません。 ワークフロー登録時に、実行主体ユーザマスタ情報が存在しない場合に発生します。 実行主体ユーザマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER

public static final String BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER
実行主体役職マスタ情報が設定されてません。 ワークフロー登録時に、実行主体役職マスタ情報が存在しない場合に発生します。 実行主体役職マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER

public static final String BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER
プロセスアダプタマスタ情報が設定されてません。 ワークフロー登録時に、プロセスアダプタマスタ情報が存在しない場合に発生します。 プロセスアダプタマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER

public static final String BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER
オートアダプタマスタ情報が設定されてません。 ワークフロー登録時に、オートアダプタマスタ情報が存在しない場合に発生します。 オートアダプタマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER

public static final String BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER
イベントアダプタマスタ情報が設定されてません。 ワークフロー登録時に、イベントアダプタマスタ情報が存在しない場合に発生します。 イベントアダプタマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FLOW_INNER_MASTER

public static final String BPW_C_IMPORT_NO_FLOW_INNER_MASTER
フロー内容マスタ情報が設定されてません。 ワークフロー登録時に、フロー内容マスタ情報が存在しない場合に発生します。 フロー内容マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SWITCH_MASTER

public static final String BPW_C_IMPORT_NO_SWITCH_MASTER
スイッチマスタ情報が設定されてません。 ワークフロー登録時に、スイッチマスタ情報が存在しない場合に発生します。 スイッチマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER

public static final String BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER
ルート選択マスタ情報が設定されてません。 ワークフロー登録時に、ルート選択マスタ情報が存在しない場合に発生します。 ルート選択マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT

public static final String BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT
催促メール猶予日数が不正です。 催促メール猶予日数が数字以外な場合に発生します。 催促メール猶予日数が数字で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION

public static final String BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION
催促メール対象種別が指定されていない、または不正です。 催促メール対象種別が指定されていないか、または不正な場合に発生します。 正しい催促メール対象種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN

public static final String BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN
催促メール猶予日長が不正です。 催促メール猶予日長が不正な場合に発生します。 催促メール猶予日長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN

public static final String BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN
催促メール対象種別長が不正です。 催促メール対象種別長が不正な場合に発生します。 催促メール対象種別長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN

public static final String BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN
催促メール表題定義長が不正です。 催促メール表題定義長が不正な場合に発生します。 催促メール表題定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN

public static final String BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN
催促メール内容定義長が不正です。 催促メール内容定義長が不正な場合に発生します。 催促メール内容定義長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_INFO

public static final String BPW_C_IMPORT_NO_AUTO_PASS_INFO
自動パス情報が設定されてません。 ワークフロー登録時に、自動パス情報が存在しない場合に発生します。 自動パス情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_MASTER

public static final String BPW_C_IMPORT_NO_AUTO_PASS_MASTER
自動パスマスタ情報が設定されてません。 ワークフロー登録時に、自動パスマスタ情報が存在しない場合に発生します。 自動パスマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER

public static final String BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER
自動パス役職マスタ情報が設定されてません。 ワークフロー登録時に、自動パス役職マスタ情報が存在しない場合に発生します。 自動パス役職マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_CONTENTS_MASTER

public static final String BPW_C_IMPORT_NO_CONTENTS_MASTER
コンテンツマスタ情報が設定されてません。 ワークフロー登録時に、コンテンツマスタ情報が存在しない場合に発生します。 コンテンツマスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER

public static final String BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER
オートアダプタ・イベントアダプタ情報を設定するライセンスがありません。 BPWライセンスを有していない場合に発生します。 オートアダプタ・イベントアダプタ情報は指定できません。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW

public static final String BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW
スイッチ・フロー情報を設定するライセンスがありません。 ライセンスを有していない場合に発生します。 スイッチ・フロー情報は指定できません。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTSTYPE

public static final String BPW_C_IMPORT_INVALID_CONTENTSTYPE
コンテンツ種別が指定されていない、または不正です。 コンテンツ種別が指定されていないか、または不正な場合に発生します。 正しいコンテンツ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE

public static final String BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE
コンテンツ種別が重複して指定されています。 コンテンツ種別が重複して指定されている場合に発生します。 コンテンツ種別が重複して指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PAGBE_KIND

public static final String BPW_C_IMPORT_INVALID_PAGBE_KIND
ページ種別が指定されていない、または不正です。 ページ種別が指定されていないか、または不正な場合に発生します。 正しいページ種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPLICATION_ID

public static final String BPW_C_IMPORT_INVALID_APPLICATION_ID
アプリケーションIDが指定されていない、または不正です。 アプリケーションIDが指定されていないか、または不正な場合に発生します。 正しいアプリケーションIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SERVECE_ID

public static final String BPW_C_IMPORT_INVALID_SERVECE_ID
サービスIDが指定されていない、または不正です。 サービスIDが指定されていないか、または不正な場合に発生します。 正しいサービスIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN

public static final String BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN
アプリケーションID長が不正です。 アプリケーションID長が不正な場合に発生します。 アプリケーションID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SERVICE_ID_LEN

public static final String BPW_C_IMPORT_INVALID_SERVICE_ID_LEN
サービスID長が不正です。 サービスID長が不正な場合に発生します。 サービスID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTS_PATH

public static final String BPW_C_IMPORT_INVALID_CONTENTS_PATH
コンテンツパスが指定されていない、または不正です。 コンテンツパスが指定されていないか、または不正な場合に発生します。 正しいコンテンツパスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN

public static final String BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN
コンテンツパス長が不正です。 コンテンツパス長が不正な場合に発生します。 コンテンツパス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD

public static final String BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD
呼び出しプロセス定義コードが指定されていない、または不正です。 呼び出しプロセス定義コードが指定されていないか、または不正な場合に発生します。 正しい呼び出しプロセス定義コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND

public static final String BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND
起票タイプが指定されていない、または不正です。 起票タイプが指定されていないか、または不正な場合に発生します。 正しい呼び出し起票タイプが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN

public static final String BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN
呼び出しプロセス定義コード長が不正です。 呼び出しプロセス定義コード長が不正な場合に発生します。 呼び出しプロセス定義コード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_CLASS

public static final String BPW_C_IMPORT_INVALID_RUN_CLASS
実行クラスが指定されていない、または不正です。 実行クラスが指定されていないか、または不正な場合に発生します。 正しい呼び出し実行クラスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN

public static final String BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN
実行クラス長が不正です。 実行クラス長が不正な場合に発生します。 実行クラス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID

public static final String BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID
イベントサービスIDが指定されていない、または不正です。 イベントサービスIDが指定されていないか、または不正な場合に発生します。 正しい呼び出しイベントサービスIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN

public static final String BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN
イベントサービスID長が不正です。 イベントサービスID長が不正な場合に発生します。 イベントサービスID長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONDITION_CALSS

public static final String BPW_C_IMPORT_INVALID_CONDITION_CALSS
条件クラスが指定されていない、または不正です。 条件クラスが指定されていないか、または不正な場合に発生します。 正しい呼び出し条件クラスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN

public static final String BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN
条件クラス長が不正です。 条件クラス長が不正な場合に発生します。 条件クラス長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD

public static final String BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD
実効アクティビティコードが指定されていない、または不正です。 実効アクティビティコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し実効アクティビティコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN

public static final String BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN
実効アクティビティコード長が不正です。 実効アクティビティコード長が不正な場合に発生します。 実効アクティビティコード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_USER_CD

public static final String BPW_C_IMPORT_INVALID_RUN_USER_CD
実行主体ユーザコードが指定されていない、または不正です。 実行主体ユーザコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し実行主体ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_RUN_USER_CD

public static final String BPW_C_IMPORT_NO_EXIST_RUN_USER_CD
実行主体ユーザコードが存在しません。 存在しない実行主体ユーザコードが指定されてた場合に発生します。 存在する実行主体ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND

public static final String BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND
実行主体役職種別が指定されていない、または不正です。 実行主体役職種別が指定されていないか、または不正な場合に発生します。 正しい実行主体役職種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD

public static final String BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD
実行主体役職コードが指定されていない、または不正です。 実行主体役職コードが指定されていないか、または不正な場合に発生します。 正しい実行主体役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD

public static final String BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD
実行主体役職コードが存在しません。 存在しない実行主体役職コードが指定されてた場合に発生します。 存在する実行主体役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_REFER_USER_CD

public static final String BPW_C_IMPORT_INVALID_REFER_USER_CD
参照者ユーザコードが指定されていない、または不正です。 参照者ユーザコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し参照者ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CODE_KIND

public static final String BPW_C_IMPORT_INVALID_CODE_KIND
コード種別が指定されていない、または不正です。 コード種別が指定されていないか、または不正な場合に発生します。 正しい呼び出しコード種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_REFER_USER_CD

public static final String BPW_C_IMPORT_NO_EXIST_REFER_USER_CD
参照者ユーザコードが存在しません。 存在しない参照者ユーザコードが指定されてた場合に発生します。 存在する参照者ユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD

public static final String BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD
参照者組織コードが存在しません。 存在しない参照者組織コードが指定されてた場合に発生します。 存在する参照者組織コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD
自動パスユーザコードが指定されていない、または不正です。 自動パスユーザコードが指定されていないか、または不正な場合に発生します。 正しい呼び出し自動パスユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_AUTO_PASS_USER_CD

public static final String BPW_C_IMPORT_NO_AUTO_PASS_USER_CD
自動パスユーザコードが存在しません。 存在しない自動パスユーザコードが指定されてた場合に発生します。 存在する自動パスユーザコードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND
自動パス役職種別が指定されていない、または不正です。 自動パス役職種別が指定されていないか、または不正な場合に発生します。 正しい自動パス役職種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD
自動パス役職コードが指定されていない、または不正です。 自動パス役職コードが指定されていないか、または不正な場合に発生します。 正しい自動パス役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD

public static final String BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD
自動パス役職コードが存在しません。 存在しない自動パス役職コードが指定されてた場合に発生します。 存在する自動パス役職コードが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SEQUENCE_MASTER

public static final String BPW_C_IMPORT_NO_SEQUENCE_MASTER
シーケンス内容マスタ情報が設定されてません。 ワークフロー登録時に、シーケンス内容マスタ情報が存在しない場合に発生します。 シーケンス内容マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY

public static final String BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY
フロー内容マスタ情報の実行アクティビティが設定されていません。 フロー内容マスタ情報の実行アクティビティが設定されていない場合に発生します。 フロー内容マスタ情報の実行アクティビティ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY

public static final String BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY
スイッチマスタ情報の実行アクティビティが設定されていません。 スイッチマスタ情報の実行アクティビティが設定されていない場合に発生します。 スイッチマスタ情報の実行アクティビティ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SELECT_ROUTE_NAME

public static final String BPW_C_IMPORT_NO_SELECT_ROUTE_NAME
ルート選択マスタ情報の選択ルート名が設定されていません。 ルート選択マスタ情報の選択ルート名が設定されていない場合に発生します。 ルート選択マスタマスタ情報の選択ルート名の情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SELECT_ROUTE_CD

public static final String BPW_C_IMPORT_NO_SELECT_ROUTE_CD
ルート選択マスタ情報の選択ルートコードが設定されていません。 ルート選択マスタ情報の選択ルートコードが設定されていない場合に発生します。 ルート選択マスタマスタ情報の選択ルートコードの情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY

public static final String BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY
シーケンスマスタ情報の実行アクティビティが設定されていません。 シーケンスマスタ情報の実行アクティビティが設定されていない場合に発生します。 シーケンスマスタ情報の実行アクティビティ情報が必要です。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_TOP_ACTIVITY

public static final String BPW_C_IMPORT_INVALID_TOP_ACTIVITY
ルートの先頭アクティビティ種別設定が不正です。 ルートの先頭アクティビティ種別設定がシーケンス以外の場合に発生します。 正しいアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_START_ACTIVITY

public static final String BPW_C_IMPORT_INVALID_START_ACTIVITY
ルートの開始アクティビティ種別設定が不正です。 ルートの開始アクティビティ種別設定が不正な場合に発生します。 正しいアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY

public static final String BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY
実行時選択前アクティビティ種別の設定が不正です。 実行時選択前アクティビティ種別にフローが設定された場合に発生します。 フロー以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_SWITCH

public static final String BPW_C_IMPORT_INVALID_PROCESS_SWITCH
アクティビティ種別設定が不正です。 申請者ルート作成ワークフロー選択時、アクティビティ種別にスイッチが設定された場合に発生します。 スイッチ以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT

public static final String BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT
アクティビティ種別設定数が不正です。 申請者ルート作成ワークフロー選択時、フローのアクティビティ種別が複数設定された場合に発生します。 フローのアクティビティ種別が複数設定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SECOND_APPROVAL

public static final String BPW_C_IMPORT_INVALID_SECOND_APPROVAL
承認対象種別設定が不正です。 申請者ルート作成ワークフロー選択時、起票タスクの次タスクに実行時選択の承認対象種別が設定された場合に発生します。 実行時選択以外の承認対象種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT

public static final String BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT
承認対象種別設定が不正です。 申請者ルート作成ワークフロー選択時、承認対象種別に申請者定義が設定されていない場合に発生します。 申請者定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG

public static final String BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG
承認対象種別設定が不正です。 申請者ルート作成ワークフロー選択時、必須選択最終タスク以降の承認対象種別に申請者定義以外が設定された場合に発生します。 申請者定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW

public static final String BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW
最短終了フラグの設定が不正です。 申請者ルート作成ワークフロー選択時、フロー内で最短終了フラグが設定された場合に発生します。 最短終了フラグが設定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW

public static final String BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW
最短終了フラグの設定が不正です。 申請者ルート作成ワークフロー選択時、フローのアクティビティ種別前に最短終了フラグが設定された場合に発生します。 フローのアクティビティ種別より後に最短終了フラグを設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG

public static final String BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG
ルート定義が不正です。 申請者ルート作成ワークフロー選択時、必須選択最終タスク以降に申請者タスク以外が設定された場合に発生します。 必須選択最終タスク以降は申請者タスクを設定する必要があります。

関連項目:
定数フィールド値

BPW_C_FAILED_GET_HTTP_EXCEL_STREAM

public static final String BPW_C_FAILED_GET_HTTP_EXCEL_STREAM
Excelファイルストリーム取得に失敗しました。 HTTPリクエストからのExcelファイルストリーム取得に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_FAILED_READ_EXCEL_STREAM

public static final String BPW_C_FAILED_READ_EXCEL_STREAM
Excelファイルストリーム読み込みに失敗しました。 HTTPリクエストからのExcelファイルストリーム読み込みに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_FUNCTION_KBN

public static final String BPW_C_IMPORT_INVALID_FUNCTION_KBN
処理区分が指定されていない、または不正です。 処理区分が指定されていないか、または不正な場合に発生します。 正しい処理区分が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_TASK_ID

public static final String BPW_C_IMPORT_INVALID_TASK_ID
タスク定義に存在しないタスクIDが指定されました。 タスク定義に存在しないタスクIDが指定された場合に発生します。 正しいタスクIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_TASK_TYPE

public static final String BPW_C_IMPORT_INVALID_TASK_TYPE
タスクタイプが指定されていない、または不正です。 タスクタイプが指定されていないか、または不正な場合に発生します。 正しいタスクタイプが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE

public static final String BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE
フローのサブルートが存在しません。 フローのサブルートが存在しない場合に発生します。 フローのサブルートが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH

public static final String BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH
スイッチのサブルートが存在しません。 スイッチのサブルートが存在しない場合に発生します。 スイッチのサブルートが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL_FOCUS

public static final String BPW_C_IMPORT_INVALID_APPROVAL_FOCUS
承認対象が指定されていない、または不正です。 承認対象が指定されていないか、または不正な場合に発生します。 正しい承認対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_APPROVAL_CD

public static final String BPW_C_IMPORT_DUPLICATE_APPROVAL_CD
承認対象コードが重複しています。 承認対象コードが重複している場合に発生します。 重複した承認対象コードが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_PLURAL_APPROVAL

public static final String BPW_C_IMPORT_PLURAL_APPROVAL
起案タスク以外は、複数対象者の設定をすることはできません。 起案タスク以外に、複数対象者が設定されている場合に発生します。 起案タスク以外に、複数対象者が設定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_REFER_FOCUS

public static final String BPW_C_IMPORT_INVALID_REFER_FOCUS
参照対象が指定されていない、または不正です。 参照対象が指定されていないか、または不正な場合に発生します。 正しい参照対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS

public static final String BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS
自動パス対象が指定されていない、または不正です。 自動パス対象が指定されていないか、または不正な場合に発生します。 正しい自動パス対象が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FIRST_TASK_ID

public static final String BPW_C_IMPORT_NO_FIRST_TASK_ID
始めのタスクIDが指定されていません。 始めのタスクIDが指定されていない場合に発生します。 始めのタスクIDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_DUPLICATE_TASK_ID

public static final String BPW_C_IMPORT_DUPLICATE_TASK_ID
タスクIDが重複しています。 タスクIDが重複している場合に発生します。 重複したタスクIDが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER

public static final String BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER
実行時選択のレシーブは指定できません。 実行時選択のレシーブが指定できない場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE

public static final String BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE
最初のシーケンスにレシーブが存在しません。 最初のシーケンスにレシーブが存在しない場合に発生します。 最初のシーケンスにレシーブが存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF

public static final String BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF
ルート定義内のタスクIDがタスク定義に指定されていません。 ルート定義内のタスクIDがタスク定義に指定されていない場合に発生します。 ルート定義内のタスクIDがタスク定義に指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW

public static final String BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW
フロー情報のルート定義入力が不正です。 フローの右にタスクIDが指定された場合に発生します。 フローの右にタスクIDが指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION

public static final String BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION
ルート定義ないのタスクの位置の入力が不正です。 承認対象種別が実行時選択であるタスクの左に何もない場合に発生します。 ルート定義の左にタスクを持たないタスクの承認対象種別が実行時選択が指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_DRAFTER_TASK_LOCATION

public static final String BPW_C_IMPORT_INVALID_DRAFTER_TASK_LOCATION
ルート定義内のタスクの位置の入力が不正です。 承認対象種別が申請者であるタスクの左に何もない場合に発生します。 ルート定義の左にタスクを持たないタスクの承認対象種別に申請者が指定されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CONTENTS_FRAME_TYPE

public static final String BPW_C_IMPORT_INVALID_CONTENTS_FRAME_TYPE
コンテンツフレーム種別が指定されていない、または不正です。 コンテンツフレーム種別が指定されていないか、または不正な場合に発生します。 正しいコンテンツフレーム種別が指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_GET_ROOT_INFO

public static final String BPW_C_INPOSSIBLE_GET_ROOT_INFO
アクティビティルート取得イベントに失敗しました。 アクティビティルート取得イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_ROOT_HISTORY_INFO

public static final String BPW_C_NOT_ROOT_HISTORY_INFO
ルート作成履歴情報が存在しません。 プロセス定義情報が存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_SELECTED_TARGET_TASK

public static final String BPW_C_NO_SELECTED_TARGET_TASK
申請できません。 未設定のタスクがあります。 必要な設定を行ってから再度「申請」ボタンを押下してください。

関連項目:
定数フィールド値

BPW_C_INVALID_ROOT_NAME

public static final String BPW_C_INVALID_ROOT_NAME
申請できません。 呼び出した履歴データに対して変更されています。 申請ルート名を変更してください。

関連項目:
定数フィールド値

BPW_C_SHIFT_REFER_DUPLICATION

public static final String BPW_C_SHIFT_REFER_DUPLICATION
参照者マスタ移行が出来ません。 既に、移行処理済の場合に発生します。

関連項目:
定数フィールド値

BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO

public static final String BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO
この履歴情報は使用できません。 ルート作成後、プロセス定義情報が変更されていないことを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT

public static final String BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT
アクティビティ種別設定が不正です。 申請者ルート作成ワークフロー選択時、アクティビティ種別にルート選択が設定された場合に発生します。 ルート選択以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG

public static final String BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG
サブプロセス識別フラグが不正です。 サブプロセス識別フラグが想定外の値であった場合に発生します。 正しいサブプロセス識別フラグが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN

public static final String BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN
サブプロセス識別フラグ文字列長が最大文字列長を超えています。 サブプロセス識別フラグ文字列長が最大文字列長を超えている場合に発生します。 サブプロセス識別フラグ文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ATTACHMENT_FLAG

public static final String BPW_C_IMPORT_INVALID_ATTACHMENT_FLAG
添付ファイルフラグが不正です。 添付ファイルフラグが想定外の値であった場合に発生します。 正しい添付ファイルフラグが登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_OVER_ATTACHMENT_FLAG_LEN

public static final String BPW_C_IMPORT_OVER_ATTACHMENT_FLAG_LEN
添付ファイルフラグ文字列長が最大文字列長を超えています。 添付ファイルフラグ文字列長が最大文字列長を超えている場合に発生します。 添付ファイルフラグ文字列長が最大文字列長以内で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_FLOWINFO_NO_EXIST_FLOWICON

public static final String BPW_FLOWINFO_NO_EXIST_FLOWICON
フローアイコンが存在しません。Storage配下にフローアイコンが存在することを確認する必要があります。 フローアイコンがStorage配下に存在しない場合に発生します。 Storage配下にフローアイコンが存在することを確認する必要があります。

関連項目:
定数フィールド値

BPW_FLOWINFO_INVALID_PARAMETER

public static final String BPW_FLOWINFO_INVALID_PARAMETER
フローアイコンを取得する際の入力パラメータ不正です。 不正な入力パラメータの場合に発生します。 有効な入力パラメータを渡す必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW

public static final String BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW
プロセス種別とサブプロセス識別フラグの設定が不正です。 プロセス種別が申請者/承認者ルート作成ワークフローの時、サブプロセス識別フラグに通常のプロセス定義が設定された場合に発生します。 サブプロセス識別フラグにサブプロセスとしてのプロセス定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW

public static final String BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW
プロセス種別とサブプロセス識別フラグの設定が不正です。 プロセス種別がビジネスプロセスワークフローの時、サブプロセス識別フラグにサブプロセスとしてのプロセス定義が設定された場合に発生します。 サブプロセス識別フラグに通常のプロセス定義を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD

public static final String BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD
会社CDが指定されていない、または不正です。 会社CDが指定されていないか、または不正な場合に発生します。 正しい会社CDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD

public static final String BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD
会社CDが存在しません。 存在しない会社CDが指定されてた場合に発生します。 存在する会社CDが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_CODE_KIND_VALUE

public static final String BPW_C_IMPORT_INVALID_CODE_KIND_VALUE
コード種別が不正です。 取得したコード種別が想定外の種別であった場合に発生します。 正しいコード種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT

public static final String BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT
ルート選択のサブルートが存在しません。 ルート選択のサブルートが存在しない場合に発生します。 ルート選択のサブルートが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_APPROVAL

public static final String BPW_C_IMPORT_INVALID_APPROVAL
承認対象種別設定が不正です。 申請者／承認者ルート作成ワークフロー選択以外の時、申請者定義の承認対象種別が設定された場合に発生します。 申請者定義以外の承認対象種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE

public static final String BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE
ルート選択の前アクティビティ種別の設定が不正です。 ルート選択の前アクティビティ種別に処理タスク以外が設定された場合に発生します。 処理タスクのアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE

public static final String BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE
サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別の設定が不正です。 サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別に処理タスク以外が設定された場合に発生します。 処理タスクのアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN

public static final String BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN
選択ルート名長が不正です。 選択ルート名長が不正な場合に発生します。 選択ルート名長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN

public static final String BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN
選択ルートコード長が不正です。 選択ルートコード長が不正な場合に発生します。 選択ルートコード長が適切な文字数で指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ACTIVITY_TYPE

public static final String BPW_C_IMPORT_INVALID_ACTIVITY_TYPE
アクティビティ種別の設定が不正です。 ドキュメントワークフロー選択以外の時、ルート選択のアクティビティ種別が設定された場合に発生します。 ルート選択以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_SUB_PROCESS

public static final String BPW_C_IMPORT_INVALID_SUB_PROCESS
サブプロセスの設定が不正です。 プロセス種別が申請者／承認者ルート作成ワークフロー選択の時、サブプロセス（申請者／承認者ルート作成ワークフロー）が設定された場合に発生します。 申請者／承認者ルート作成ワークフロー以外のサブプロセスを設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD

public static final String BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD
プロセス種別の設定が不正です。 プロセス種別が申請者／承認者ルート作成ワークフローの変更時、プロセス種別（申請者／承認者ルート作成ワークフロー）以外が設定された場合に発生します。 変更時は申請者／承認者ルート作成ワークフローのプロセス種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE

public static final String BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE
実行時選択の前アクティビティ種別の設定が不正です。 実行時選択の前アクティビティ種別にサブプロセス（申請者／承認者ルート作成ワークフロー）が設定された場合に発生します。 サブプロセス（申請者／承認者ルート作成ワークフロー）以外のアクティビティ種別を設定する必要があります。

関連項目:
定数フィールド値

BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS

public static final String BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS
始めの条件クラスが指定されていません。 始めの条件クラスが指定されていない場合に発生します。 始めの条件クラスが指定されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_NO_ROUTE_SELECT_MASTER

public static final String BPW_C_NO_ROUTE_SELECT_MASTER
ルート選択マスタ情報が設定されてません。 フロー制御時に、ルート選択マスタ情報が存在しない場合に発生します。 ルート選択マスタ情報が必要です。

関連項目:
定数フィールド値

BPW_C_NOT_BACK_IN_FLOW

public static final String BPW_C_NOT_BACK_IN_FLOW
同期処理内より、処理外への引戻し／差戻しは行えません。 同期処理内より、処理外への引戻し／差戻しを実行した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INVALID_RETURN_FLG

public static final String BPW_C_INVALID_RETURN_FLG
引戻し／差戻しは行えません。（引戻し／差戻し可否フラグ＝ＯＦＦ） 引戻し／差戻し可否フラグ＝ＯＦＦの場合に引戻し／差戻しを実行した場合に発生します。

関連項目:
定数フィールド値

BPW_INVALID_PROCESS_NAME_LENGTH

public static final String BPW_INVALID_PROCESS_NAME_LENGTH
プロセス名の入力文字数が制限を越えています。

関連項目:
定数フィールド値

BPW_INVALID_DRAFT_COMMENT_LENGTH

public static final String BPW_INVALID_DRAFT_COMMENT_LENGTH
申請コメントの入力文字数が制限を越えています。

関連項目:
定数フィールド値

BPW_INVALID_RECEIVE_COMMENT_LENGTH

public static final String BPW_INVALID_RECEIVE_COMMENT_LENGTH
審議コメントの入力文字数が制限を越えています。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY

public static final String BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY
予約メール依頼の設定に失敗しました。 リザーブキーの設定に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY

public static final String BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY
テンプレートメール送信抑止の設定に失敗しました。 リザーブキーの設定に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND

public static final String BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND
メールテンプレートの取得に失敗しました。 指定されたパスに該当するメールテンプレートが存在しない場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY

public static final String BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY
メールテンプレートの設定に失敗しました。 メールテンプレートの設定に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND

public static final String BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND
メールテンプレートの送信に失敗しました。 メールテンプレートの送信に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_INPOSSIBLE_SET_MAIL_INFORMATION_REMOVE

public static final String BPW_C_INPOSSIBLE_SET_MAIL_INFORMATION_REMOVE
関連項目:
定数フィールド値

BPW_C_NO_ATTACH_POSITION_GROUP

public static final String BPW_C_NO_ATTACH_POSITION_GROUP
申請できません。 選択した所属組織の有効期間と「起票を行いたい日付」が一致していません。
再度処理を行ってください。それでも現象が改善されない場合は管理者にご連絡ください。

関連項目:
定数フィールド値

BPW_C_NO_ATTACH_POSITION_GROUP_AGENT

public static final String BPW_C_NO_ATTACH_POSITION_GROUP_AGENT
申請できません。 選択した代理元の所属組織に誤りがあります。
再度処理を行ってください。それでも現象が改善されない場合は管理者にご連絡ください。

関連項目:
定数フィールド値

BPW_C_NOT_TRANSFER_PROCESS_DEF_DATA

public static final String BPW_C_NOT_TRANSFER_PROCESS_DEF_DATA
代理設定対象プロセス定義情報が取得できませんでした。 代理設定を行おうとしたプロセス定義が削除された可能性があります。
最新の情報を確認後、設定しなおしてください。

関連項目:
定数フィールド値

BPW_C_NOT_TRANSFER_VERSION_DATA

public static final String BPW_C_NOT_TRANSFER_VERSION_DATA
代理設定対象バージョン情報が取得できませんでした。 代理設定を行おうとしたバージョンが削除された可能性があります。
最新の情報を確認後、設定しなおしてください。

関連項目:
定数フィールド値

BPW_C_NOT_TRANSFER_TASK_DATA

public static final String BPW_C_NOT_TRANSFER_TASK_DATA
代理設定対象タスク情報が取得できませんでした。 代理設定を行おうとしたタスクの対象者になっていない可能性があります。
最新の情報を確認後、設定しなおしてください。

関連項目:
定数フィールド値

BPW_C_CATEGORY_DISAGREEMENT

public static final String BPW_C_CATEGORY_DISAGREEMENT
カテゴリコードの設定に誤りがあります。 カテゴリコードは他のバージョンのカテゴリコードと同一カテゴリコードでなければいけません。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_BEGIN

public static final String BPW_UT_FAILED_TO_BEGIN
ユーザトランザクションの開始に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_COMMIT

public static final String BPW_UT_FAILED_TO_COMMIT
ユーザトランザクションのコミットに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_ROLLBACK

public static final String BPW_UT_FAILED_TO_ROLLBACK
ユーザトランザクションのロールバックに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_GET_STATUS

public static final String BPW_UT_FAILED_TO_GET_STATUS
ユーザトランザクションのステータスの取得に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_CLOSE

public static final String BPW_UT_FAILED_TO_CLOSE
ユーザトランザクションの終了に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY

public static final String BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY
ユーザトランザクションのロールバックオンリーの設定に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT

public static final String BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT
ユーザトランザクションのトランザクションタイムアウトの設定に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION

public static final String BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION
トランザクションが開始していないためコミットに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION

public static final String BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION
トランザクションが開始していないためロールバックに失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_LOCK

public static final String BPW_UT_FAILED_TO_LOCK
ユーザアプリケーションロックの解除に失敗しました。

関連項目:
定数フィールド値

BPW_UT_FAILED_TO_UNLOCK

public static final String BPW_UT_FAILED_TO_UNLOCK
ユーザアプリケーションロックの解除に失敗しました。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE

public static final String BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE
起票タスクのタスク種別に誤りがあります。
起票タスクの設定を確認してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROOT_SETTING

public static final String BPW_CORE_IMPORT_INVALID_ROOT_SETTING
ルート定義に誤りがあります。
ルート定義を設定しなおしてください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO

public static final String BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO
サブプロセス設定情報が設定されていません。
サブプロセスの設定情報を見直してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK

public static final String BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK
起票タスクに動的承認者は設定できません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_NO_RECEIVE_TASK

public static final String BPW_CORE_IMPORT_NO_RECEIVE_TASK
起票(処理)タスクが設定されていない可能性があります。
起票(処理)タスクは必ず1つ以上設定してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER

public static final String BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER
同期タスクの結合直後に動的な対象者を設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_PARALLEL_SWITCH_AFTER_DYNAMIC_USER

public static final String BPW_CORE_IMPORT_INVALID_PARALLEL_SWITCH_AFTER_DYNAMIC_USER
複数ルートの分岐タスクの結合直後に動的な対象者を設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH

public static final String BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH
承認者種別が実行時選択のタスクを
同期・分岐・ルート選択の開始直後に設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CUSTOM

public static final String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CUSTOM
サブプロセスに申請者/承認者ルート作成ワークフローが設定されている場合、
直前のタスクのコンテンツフレーム種別にカスタムを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE

public static final String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE
サブプロセスに申請者/承認者ルート作成ワークフローが設定されているタスクの直前に
申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW

public static final String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW
同期の開始・結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH

public static final String BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH
分岐の開始直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW

public static final String BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW
同期の開始・結合直後にルート選択タスクを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE

public static final String BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE
ルート選択タスクの直前に申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH

public static final String BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH
分岐・ルート選択の開始直後にルート選択タスクを設定する事はできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT

public static final String BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT
分岐内のタスク設定に誤りがあります。
ルート定義を設定しなおしてください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW

public static final String BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW
プロセス定義種別がビジネスプロセスワークフローの場合、コンテンツフレーム種別にカスタムを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT

public static final String BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT
分岐内に1ルートしか設定されていません。分岐内のルートは必ず2ルート以上作成してください。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE

public static final String BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE
ルート選択内に処理タスクがない場合、ルート選択結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_IMPORT_INVALID_INVOKE_TASK

public static final String BPW_CORE_IMPORT_INVALID_INVOKE_TASK
プロセス種別がビジネスプロセスワークフロー以外の場合、自動実行タスク、イベント実行タスクを設定することはできません。

関連項目:
定数フィールド値

BPW_CORE_USER_SETTING_PATTERN

public static final String BPW_CORE_USER_SETTING_PATTERN
対象データはユーザに選択されている可能性があります。 ユーザに選択されているパターンは削除する事ができません。
設定状況を確認し再度処理を行ってください。

関連項目:
定数フィールド値

BPW_CORE_FAILED_GET_FILESTREAM

public static final String BPW_CORE_FAILED_GET_FILESTREAM
ファイルストリーム取得に失敗しました。 HTTPリクエストからのファイルストリーム取得に失敗した場合に発生します。

関連項目:
定数フィールド値

BPW_C_DUPLICATE_CATEGORY

public static final String BPW_C_DUPLICATE_CATEGORY
カテゴリコードが重複しています。

関連項目:
定数フィールド値

BPW_C_NOT_NUMBER_CATEGORY

public static final String BPW_C_NOT_NUMBER_CATEGORY
カテゴリコードが不正です。 カテゴリコードは1以上の半角数値で指定してください。

関連項目:
定数フィールド値

BPW_C_NOT_EXIST_ROLE

public static final String BPW_C_NOT_EXIST_ROLE
ロールIDが不正です。 指定されたロールIDが存在しない可能性があります。

関連項目:
定数フィールド値

BPW_C_ALREADY_SUSPEND

public static final String BPW_C_ALREADY_SUSPEND
既に保留されている可能性があります。 該当案件の状態を確認し再度処理を行ってください。

関連項目:
定数フィールド値

BPW_C_INVALID_CONDITION_TYPE

public static final String BPW_C_INVALID_CONDITION_TYPE
分岐種別が不正です。 取得した分岐種別が想定外の値であった場合に発生します。 正しい分岐種別が登録されていることを確認する必要があります。

関連項目:
定数フィールド値

BPW_C_INVALID_RETURN_START_RUN_USER_INFO

public static final String BPW_C_INVALID_RETURN_START_RUN_USER_INFO
申請者への差し戻しイベントに失敗しました。 差し戻し先ユーザ情報が不正な場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_INSERT_HISTORY_TABLE_INFO

public static final String BPW_C_NOT_INSERT_HISTORY_TABLE_INFO
処理履歴情報の登録に失敗しました。

関連項目:
定数フィールド値

BPW_C_NOT_INSERT_MONITORING_TABLE_INFO

public static final String BPW_C_NOT_INSERT_MONITORING_TABLE_INFO
モニタリング情報の登録に失敗しました。

関連項目:
定数フィールド値

BPW_CORE_NUMBERING_INVALID_PARAMETER

public static final String BPW_CORE_NUMBERING_INVALID_PARAMETER
採番処理にて指定したパラメータに誤りがあります。 任意の採番処理でパラメータに誤りがあった場合に発生します。

関連項目:
定数フィールド値

BPW_C_NOT_GET_PROCESS_CODE

public static final String BPW_C_NOT_GET_PROCESS_CODE
案件番号の取得に失敗しました。 案件番号の採番ロジックで予期せぬエラーが発生しました。

関連項目:
定数フィールド値

BPW_C_PROCESS_COUNT_FILE_NOT_FOUND

public static final String BPW_C_PROCESS_COUNT_FILE_NOT_FOUND
案件番号の採番処理に失敗しました。 採番用のコードカウントファイルが存在しない可能性があります。

関連項目:
定数フィールド値

BPW_C_PROCESS_COUNT_FILE_READ_ONLY

public static final String BPW_C_PROCESS_COUNT_FILE_READ_ONLY
案件番号の採番処理に失敗しました。 採番用のコードカウントファイルが書き込み禁止になっている可能性があります。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_INFO

public static final String BPW_C_NOT_RUN_USER_INFO
既に他のユーザに処理された可能性があります。 この案件は既に他のユーザに処理されているか、処理権限がない可能性があります。
一覧画面より最新の情報を確認してください。

関連項目:
定数フィールド値

BPW_C_NOT_RUN_USER_AUTHORITY

public static final String BPW_C_NOT_RUN_USER_AUTHORITY
権限がありません。 この案件は代理設定、もしくは振り替え処理を行っている為、処理できません。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.bpw.exception (bpw 6.1.14 API)

 jp.co.intra_mart.foundation.bpw.exception
インタフェース
BPWErrorCodeIF
WKFErrorCodeIF
例外
WKFApplicationException


jp.co.intra_mart.foundation.bpw.exception (bpw 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.exception

インタフェースの概要
BPWErrorCodeIF | ＢＰＷで利用される例外エラーコードインタフェース定義
WKFErrorCodeIF | ＢＰＷで利用される例外エラーコードインタフェース定義

例外の概要
WKFApplicationException ＢＰＷのアプリケーション例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.bpw.exception クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.exception の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException

インタフェース階層

  • interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF
  • interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.bpw.exception の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.bpw.exception の使用

jp.co.intra_mart.foundation.bpw.exception を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.bpw.exception のクラス
WKFApplicationException
ＢＰＷのアプリケーション例外クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


WKFApplicationException (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.exception
クラス WKFApplicationException

java.lang.Object
    拡張 java.lang.Throwable
        拡張 java.lang.Exception
            拡張 jp.co.intra_mart.framework.system.exception.FrameworkException
                拡張 jp.co.intra_mart.framework.system.exception.ApplicationException
                    拡張 jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException
すべての実装インタフェース:
Serializable
public class WKFApplicationException
extends jp.co.intra_mart.framework.system.exception.ApplicationException

ＢＰＷのアプリケーション例外クラス

関連項目:
直列化された形式

コンストラクタの概要
WKFApplicationException()
コンストラクタ
WKFApplicationException(String code)
エラーコードを保持した例外を生成します。
WKFApplicationException(String code, String message)
エラーコードと詳細メッセージを保持した例外を生成します。
WKFApplicationException(String code, String message, Throwable e)
エラーコード、詳細メッセージと例外の発生原因となる例外を保持した例外を生成します。
WKFApplicationException(String code, Throwable e)
エラーコードと例外の発生原因となる例外を保持した例外を生成します。
メソッドの概要
 String getErrorCode()
エラーコードを返却します。
クラス jp.co.intra_mart.framework.system.exception.FrameworkException から継承したメソッド
getException, printStackTrace, printStackTrace, printStackTrace
クラス java.lang.Throwable から継承したメソッド
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, setStackTrace, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

WKFApplicationException

public WKFApplicationException()
コンストラクタ

WKFApplicationException

public WKFApplicationException(String code)
エラーコードを保持した例外を生成します。

パラメータ:
code - エラーコード

WKFApplicationException

public WKFApplicationException(String code,
                               String message)
エラーコードと詳細メッセージを保持した例外を生成します。

パラメータ:
code - エラーコード
message - エラーメッセージ

WKFApplicationException

public WKFApplicationException(String code,
                               Throwable e)
エラーコードと例外の発生原因となる例外を保持した例外を生成します。

パラメータ:
code - エラーコード
e - 例外発生原因

WKFApplicationException

public WKFApplicationException(String code,
                               String message,
                               Throwable e)
エラーコード、詳細メッセージと例外の発生原因となる例外を保持した例外を生成します。

パラメータ:
code - エラーコード
message - エラーメッセージ
e - 例外発生原因
メソッドの詳細

getErrorCode

public String getErrorCode()
エラーコードを返却します。

戻り値:
エラーコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


WKFErrorCodeIF (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.exception
インタフェース WKFErrorCodeIF

public interface WKFErrorCodeIF

ＢＰＷで利用される例外エラーコードインタフェース定義

フィールドの概要
static String | WFK_C_NOT_TEMPLATE_PATH 指定されたメールテンプレートが不正です。
static String | WKF_C_ALREADY_STATUS_COMPLETE 指定されたタスクは既に承認されています。
static String | WKF_C_APPROVAL_TYPE 承認種別の取得に失敗しました。
static String | WKF_C_ATTACHMENT_UNABLE 指定されたタスクの添付ファイル機能が利用できません。
static String | WKF_C_AUTO_PASS 自動パスの処理に失敗しました。
static String | WKF_C_AUTO_PRESS 自動催促の処理に失敗しました。
static String | WKF_C_DATA_ACQUISITION_FAILURE データ取得に失敗しました。
static String | WKF_C_DEPARTMENT_INFO_ERROR 所属組織情報が不正です。
static String | WKF_C_DRAFT_ACTIVITY_CD 起票アクティビティコードの取得に失敗しました。
static String | WKF_C_DRAFT_APPOINT_DATE 起票指定日の取得に失敗しました。
static String | WKF_C_DUPLICATE_AUTO_PASS_USER_CD 指定された自動パス対象者コードが重複しています。
static String | WKF_C_DUPLICATE_CREATE_ROUTE_TARGET_INFO ルート作成プロセス内の同一タスクに複数の対象者情報を設定することは出来ません。
static String | WKF_C_DUPLICATE_REFER_USER_CD 指定された参照者コードが重複しています。
static String | WKF_C_DUPLICATE_RUN_USER_CD 指定された対象者コードが重複しています。
static String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_PROCESS_DEF ルート作成情報のプロセス定義・バージョン情報が指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_ACTIVITY ルート作成プロセスの対象アクティビティコードが指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_CD ルート作成プロセスの対象コードが指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_GROUP_CD ルート作成プロセスの対象グループコードが指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_INFO ルート作成プロセスの対象者情報が指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_TYPE ルート作成プロセスの対象者種別が指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD ルート選択番号が指定されていない、または不正です。
static String | WKF_C_IMPORT_INVALID_NEXT_ROUTE_INFO ルート作成情報が指定されていない、または不正です。
static String | WKF_C_INPOSSIBLE_DRAFT_ACTIVITY 申請イベントに失敗しました。
static String | WKF_C_INPOSSIBLE_PULL_ACTIVITY 引き戻しイベントに失敗しました。
static String | WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY 承認イベントに失敗しました。
static String | WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY 承認者への差し戻しイベントに失敗しました。
static String | WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY 申請者への差し戻しイベントに失敗しました。
static String | WKF_C_INPOSSIBLE_RETURN_TASK_ACTIVITY 任意の処理者への差し戻しイベントに失敗しました。
static String | WKF_C_INVALID_ACTIVITY_INFO タスク詳細情報の指定が不正です。
static String | WKF_C_INVALID_ACTIVITY_TYPE アクティビティ種別が不正です。
static String | WKF_C_INVALID_AUTO_PASS_USER_TYPE 自動パス対象者種別の指定が不正です。
static String | WKF_C_INVALID_CONTENTS_FRAME_TYPE コンテンツフレーム種別の指定が不正です。
static String | WKF_C_INVALID_DRAFT_TASK_DYNAMIC 起票タスクに動的承認者を設定することはできません。
static String | WKF_C_INVALID_EFFECTIVE_DATE 開始日付が指定されていない、または不正です。
static String | WKF_C_INVALID_END_DATE 終了日付の指定が不正です。
static String | WKF_C_INVALID_OFFICIAL_RESTRICT 対象種別がオフィシャルグループの場合、役職絞込みコードを指定することはできません。
static String | WKF_C_INVALID_ORGN_RESTRICT 役職絞込みコード･ロール絞込みコードの両方が同時に指定されています。
static String | WKF_C_INVALID_PROCESS_CONTENTS_PATH プロセスコンテンツパスの指定が不正です。
static String | WKF_C_INVALID_PROCESS_STATUS 指定された案件を既に完了しています。
static String | WKF_C_INVALID_REFER_USER_TYPE 参照者種別の指定が不正です。
static String | WKF_C_INVALID_ROLE_RESTRICT 対象種別がロールの場合、絞り込みコードを指定することはできません。
static String | WKF_C_INVALID_ROOT_INFO ルート情報の指定が不正です。
static String | WKF_C_INVALID_RUN_USER_DYNAMIC 対象者種別に動的承認者を指定した場合、同一タスクに複数の対象者を指定することはできません。
static String | WKF_C_INVALID_RUN_USER_INFO 対象者情報の指定が不正です。
static String | WKF_C_INVALID_RUN_USER_TYPE 対象者種別の指定が不正です。
static String | WKF_C_INVALID_TARGET_ACTIVITY_TYPE 指定されたアクティビティは承認タスクではありません。
static String | WKF_C_INVALID_TARGET_TYPE 対象者種別が不正
static String | WKF_C_INVALID_TRANSFER_DATE 代理期間開始日が代理期間終了日より未来の日付になっています。
static String | WKF_C_INVALID_TRANSFER_STATUS_ALL プロセス定義コードに全てが指定されている場合はプロセス定義委譲以外行えません。
static String | WKF_C_NOT_ACTIVITY アクティビティ情報が存在しません。
static String | WKF_C_NOT_ACTIVITY_INFO タスク詳細情報が指定されていません。
static String | WKF_C_NOT_ACTIVITY_NAME タスク名が指定されていません。
static String | WKF_C_NOT_ACTIVITY_TYPE タスク種別が設定されていません。
static String | WKF_C_NOT_AGENT_SETTING 指定された代理設定は設定されていません。
static String | WKF_C_NOT_APPLICATION_KEY アプリケーションキーが設定されていない、または不正です。
static String | WKF_C_NOT_AUTHORITY_ACTIVITY 指定されたタスクが存在しない、または権限がない可能性があります。
static String | WKF_C_NOT_AUTHORITY_CATEGORY 指定されたカテゴリが存在しない、または権限がない可能性があります。
static String | WKF_C_NOT_AUTHORITY_PROCESS_DEF 指定されたプロセス定義が存在しない、または権限がない可能性があります。
static String | WKF_C_NOT_AUTO_PASS_TARGET 自動パス対象者情報が指定されていません。
static String | WKF_C_NOT_AUTO_PASS_USER_CODE 自動パス対象者コードが指定されていません。
static String | WKF_C_NOT_AUTO_PASS_USER_GROUP_CD 自動パス対象者グループコードが指定されていません。
static String | WKF_C_NOT_AUTO_PASS_USER_TYPE 自動パス対象者種別が指定されていません。
static String | WKF_C_NOT_CATEGORY_CD カテゴリコードが指定されていません。
static String | WKF_C_NOT_CREATE_ROUTE_PROCESS_INFO ルート作成プロセス情報の取得に失敗しました。
static String | WKF_C_NOT_DEPARTMENT_INFO 所属組織情報の取得に失敗しました。
static String | WKF_C_NOT_FOUND_LAST_VERSION 指定されたプロセス定義の最終バージョンの取得に失敗しました。
static String | WKF_C_NOT_FOUND_PROCESS_CONTENTS_INFO 指定されたプロセス定義のプロセスコンテンツパス情報の取得に失敗しました。
static String | WKF_C_NOT_MAIL_POSTPONEMENT 催促猶予日数が指定されていません。
static String | WKF_C_NOT_PLURAL_APPROVER 起票タスク以外のタスクに複数対象者を設定することはできません。
static String | WKF_C_NOT_POST_PROCESSING_PROGRAM 後処理クラス名が指定されていません。
static String | WKF_C_NOT_PROCESS_CLASS_CD プロセス種別コードが指定されていません。
static String | WKF_C_NOT_PROCESS_CONTENTS_PATH プロセスコンテンツパスが指定されていません。
static String | WKF_C_NOT_PROCESS_DEF_CD プロセス定義コードが指定されていません。
static String | WKF_C_NOT_PROCESS_DEF_NAME プロセス定義名が指定されていません。
static String | WKF_C_NOT_PROCESS_INFO プロセス情報の取得に失敗しました。
static String | WKF_C_NOT_RECEIVE 指定されたタスクのタスクの対象者種別情報が取得できません。
static String | WKF_C_NOT_REFER_USER_CODE 参照者コードが指定されていません。
static String | WKF_C_NOT_REFER_USER_GROUP_CD 参照者グループコードが指定されていません。
static String | WKF_C_NOT_REFER_USER_TYPE 参照者種別が指定されていません。
static String | WKF_C_NOT_REGIST_TYPE 起票タスクの対象者に指定されていない、または不正です。
static String | WKF_C_NOT_ROOT_INFO ルート情報が指定されていません。
static String | WKF_C_NOT_RUN_USER_CODE 対象者コードが指定されていません。
static String | WKF_C_NOT_RUN_USER_GROUP_CD 対象者グループコードが指定されていません。
static String | WKF_C_NOT_RUN_USER_INFO 対象者情報が指定されていません。
static String | WKF_C_NOT_RUN_USER_TYPE 対象者種別が指定されていません。
static String | WKF_C_NOT_TARGET_ACTIVITY 指定されたアクティビティは存在しない、または処理タスク以外のアクティビティである可能性があります。
static String | WKF_C_NOT_TARGET_CD 対象者コードが指定されていません。
static String | WKF_C_NOT_TARGET_GROUP_CD 対象者グループコードが指定されていません。
static String | WKF_C_NOT_TARGET_NO_ACTIVITY 指定されたタスク番号のタスクは存在しません。
static String | WKF_C_NOT_TRANSFER_ACTIVITY プロセス定義コード・バージョンコード・アクティビティコードのいずれかが指定されていません。
static String | WKF_C_NOT_TRANSFER_ATTACH_USER 代理先ユーザ/組織に設定された組織に所属するユーザが存在しない可能性があります。
static String | WKF_C_NOT_TRANSFER_AUTHORITY 指定された代理依頼先ユーザは処理権限がない可能性があります。
static String | WKF_C_NOT_TRANSFER_CODE_TYPE 代理設定種別が指定されていない、または不正です。
static String | WKF_C_NOT_TRANSFER_END_DATE 代理期間(終了日)が指定されていない、または不正です。
static String | WKF_C_NOT_TRANSFER_PROCESS_DEF プロセス定義コードが指定されていません。
static String | WKF_C_NOT_TRANSFER_START_DATE 代理期間(開始日)が指定されていない、または不正です。
static String | WKF_C_NOT_TRANSFER_TARGET_DATE 代理指定日付が指定されていない、または不正です。
static String | WKF_C_NOT_TRANSFER_VERSION プロセス定義コード・バージョンコードのいずれかが指定されていません。
static String | WKF_C_NOT_VERSION 履歴情報が存在しません。
static String | WKF_C_PRAM_AGT_ALL 代理元ユーザが不正です。
static String | WKF_C_PRAM_ERROR パラメータが不正です。
static String | WKF_C_PROCESS_INFO プロセス情報の取得に失敗しました。
static String | WKF_C_REMOVE_PROCESS プロセスの削除に失敗しました。
static String | WKF_C_SEND_MAIL メール送信に失敗しました。
static String | WKF_C_SYSTEM_ERROR システムエラーが発生しました。

フィールドの詳細

WKF_C_PRAM_ERROR

public static final String WKF_C_PRAM_ERROR
パラメータが不正です。

関連項目:
定数フィールド値

WKF_C_PRAM_AGT_ALL

public static final String WKF_C_PRAM_AGT_ALL
代理元ユーザが不正です。代理元ユーザにAGT_ALLが設定されています。

関連項目:
定数フィールド値

WKF_C_SEND_MAIL

public static final String WKF_C_SEND_MAIL
メール送信に失敗しました。

関連項目:
定数フィールド値

WFK_C_NOT_TEMPLATE_PATH

public static final String WFK_C_NOT_TEMPLATE_PATH
指定されたメールテンプレートが不正です。

関連項目:
定数フィールド値

WKF_C_AUTO_PASS

public static final String WKF_C_AUTO_PASS
自動パスの処理に失敗しました。

関連項目:
定数フィールド値

WKF_C_AUTO_PRESS

public static final String WKF_C_AUTO_PRESS
自動催促の処理に失敗しました。

関連項目:
定数フィールド値

WKF_C_REMOVE_PROCESS

public static final String WKF_C_REMOVE_PROCESS
プロセスの削除に失敗しました。

関連項目:
定数フィールド値

WKF_C_DRAFT_ACTIVITY_CD

public static final String WKF_C_DRAFT_ACTIVITY_CD
起票アクティビティコードの取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_PROCESS_INFO

public static final String WKF_C_PROCESS_INFO
プロセス情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_DRAFT_APPOINT_DATE

public static final String WKF_C_DRAFT_APPOINT_DATE
起票指定日の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_APPROVAL_TYPE

public static final String WKF_C_APPROVAL_TYPE
承認種別の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_PROCESS_INFO

public static final String WKF_C_NOT_PROCESS_INFO
プロセス情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_PULL_ACTIVITY

public static final String WKF_C_INPOSSIBLE_PULL_ACTIVITY
引き戻しイベントに失敗しました。 引き戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY

public static final String WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY
申請者への差し戻しイベントに失敗しました。 申請者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY

public static final String WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY
承認者への差し戻しイベントに失敗しました。 承認者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RETURN_TASK_ACTIVITY

public static final String WKF_C_INPOSSIBLE_RETURN_TASK_ACTIVITY
任意の処理者への差し戻しイベントに失敗しました。 任意の処理者への差し戻しイベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_DRAFT_ACTIVITY

public static final String WKF_C_INPOSSIBLE_DRAFT_ACTIVITY
申請イベントに失敗しました。 申請イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY

public static final String WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY
承認イベントに失敗しました。 承認イベントに失敗した場合に発生します。

関連項目:
定数フィールド値

WKF_C_NOT_ACTIVITY

public static final String WKF_C_NOT_ACTIVITY
アクティビティ情報が存在しません。 アクティビティ情報が存在しない場合に発生します。

関連項目:
定数フィールド値

WKF_C_NOT_VERSION

public static final String WKF_C_NOT_VERSION
履歴情報が存在しません。 履歴情報が存在しない場合に発生します。

関連項目:
定数フィールド値

WKF_C_NOT_DEPARTMENT_INFO

public static final String WKF_C_NOT_DEPARTMENT_INFO
所属組織情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_REGIST_TYPE

public static final String WKF_C_NOT_REGIST_TYPE
起票タスクの対象者に指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_DEPARTMENT_INFO_ERROR

public static final String WKF_C_DEPARTMENT_INFO_ERROR
所属組織情報が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_APPLICATION_KEY

public static final String WKF_C_NOT_APPLICATION_KEY
アプリケーションキーが設定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD

public static final String WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD
ルート選択番号が指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_NEXT_ROUTE_INFO

public static final String WKF_C_IMPORT_INVALID_NEXT_ROUTE_INFO
ルート作成情報が指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_CREATE_ROUTE_PROCESS_DEF

public static final String WKF_C_IMPORT_INVALID_CREATE_ROUTE_PROCESS_DEF
ルート作成情報のプロセス定義・バージョン情報が指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_INFO

public static final String WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_INFO
ルート作成プロセスの対象者情報が指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_DUPLICATE_CREATE_ROUTE_TARGET_INFO

public static final String WKF_C_DUPLICATE_CREATE_ROUTE_TARGET_INFO
ルート作成プロセス内の同一タスクに複数の対象者情報を設定することは出来ません。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_TYPE

public static final String WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_TYPE
ルート作成プロセスの対象者種別が指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_ACTIVITY

public static final String WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_ACTIVITY
ルート作成プロセスの対象アクティビティコードが指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_CD

public static final String WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_CD
ルート作成プロセスの対象コードが指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_GROUP_CD

public static final String WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_GROUP_CD
ルート作成プロセスの対象グループコードが指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_NOT_CREATE_ROUTE_PROCESS_INFO

public static final String WKF_C_NOT_CREATE_ROUTE_PROCESS_INFO
ルート作成プロセス情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_RECEIVE

public static final String WKF_C_NOT_RECEIVE
指定されたタスクのタスクの対象者種別情報が取得できません。

関連項目:
定数フィールド値

WKF_C_ATTACHMENT_UNABLE

public static final String WKF_C_ATTACHMENT_UNABLE
指定されたタスクの添付ファイル機能が利用できません。

関連項目:
定数フィールド値

WKF_C_SYSTEM_ERROR

public static final String WKF_C_SYSTEM_ERROR
システムエラーが発生しました。

関連項目:
定数フィールド値

WKF_C_DATA_ACQUISITION_FAILURE

public static final String WKF_C_DATA_ACQUISITION_FAILURE
データ取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_ACTIVITY_TYPE

public static final String WKF_C_NOT_ACTIVITY_TYPE
タスク種別が設定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_ACTIVITY_TYPE

public static final String WKF_C_INVALID_ACTIVITY_TYPE
アクティビティ種別が不正です。

関連項目:
定数フィールド値

WKF_C_INVALID_PROCESS_CONTENTS_PATH

public static final String WKF_C_INVALID_PROCESS_CONTENTS_PATH
プロセスコンテンツパスの指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_ROOT_INFO

public static final String WKF_C_NOT_ROOT_INFO
ルート情報が指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_ROOT_INFO

public static final String WKF_C_INVALID_ROOT_INFO
ルート情報の指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_POST_PROCESSING_PROGRAM

public static final String WKF_C_NOT_POST_PROCESSING_PROGRAM
後処理クラス名が指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_AUTO_PASS_TARGET

public static final String WKF_C_NOT_AUTO_PASS_TARGET
自動パス対象者情報が指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_MAIL_POSTPONEMENT

public static final String WKF_C_NOT_MAIL_POSTPONEMENT
催促猶予日数が指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_ACTIVITY_NAME

public static final String WKF_C_NOT_ACTIVITY_NAME
タスク名が指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_ACTIVITY_INFO

public static final String WKF_C_NOT_ACTIVITY_INFO
タスク詳細情報が指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_ACTIVITY_INFO

public static final String WKF_C_INVALID_ACTIVITY_INFO
タスク詳細情報の指定が不正です。

関連項目:
定数フィールド値

WKF_C_INVALID_CONTENTS_FRAME_TYPE

public static final String WKF_C_INVALID_CONTENTS_FRAME_TYPE
コンテンツフレーム種別の指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_RUN_USER_INFO

public static final String WKF_C_NOT_RUN_USER_INFO
対象者情報が指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_RUN_USER_INFO

public static final String WKF_C_INVALID_RUN_USER_INFO
対象者情報の指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_PLURAL_APPROVER

public static final String WKF_C_NOT_PLURAL_APPROVER
起票タスク以外のタスクに複数対象者を設定することはできません。

関連項目:
定数フィールド値

WKF_C_DUPLICATE_RUN_USER_CD

public static final String WKF_C_DUPLICATE_RUN_USER_CD
指定された対象者コードが重複しています。

関連項目:
定数フィールド値

WKF_C_NOT_RUN_USER_TYPE

public static final String WKF_C_NOT_RUN_USER_TYPE
対象者種別が指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_RUN_USER_TYPE

public static final String WKF_C_INVALID_RUN_USER_TYPE
対象者種別の指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_RUN_USER_CODE

public static final String WKF_C_NOT_RUN_USER_CODE
対象者コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_RUN_USER_GROUP_CD

public static final String WKF_C_NOT_RUN_USER_GROUP_CD
対象者グループコードが指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_ORGN_RESTRICT

public static final String WKF_C_INVALID_ORGN_RESTRICT
役職絞込みコード･ロール絞込みコードの両方が同時に指定されています。別々に指定してください。

関連項目:
定数フィールド値

WKF_C_INVALID_OFFICIAL_RESTRICT

public static final String WKF_C_INVALID_OFFICIAL_RESTRICT
対象種別がオフィシャルグループの場合、役職絞込みコードを指定することはできません。

関連項目:
定数フィールド値

WKF_C_INVALID_ROLE_RESTRICT

public static final String WKF_C_INVALID_ROLE_RESTRICT
対象種別がロールの場合、絞り込みコードを指定することはできません。

関連項目:
定数フィールド値

WKF_C_INVALID_RUN_USER_DYNAMIC

public static final String WKF_C_INVALID_RUN_USER_DYNAMIC
対象者種別に動的承認者を指定した場合、同一タスクに複数の対象者を指定することはできません。

関連項目:
定数フィールド値

WKF_C_INVALID_DRAFT_TASK_DYNAMIC

public static final String WKF_C_INVALID_DRAFT_TASK_DYNAMIC
起票タスクに動的承認者を設定することはできません。

関連項目:
定数フィールド値

WKF_C_DUPLICATE_REFER_USER_CD

public static final String WKF_C_DUPLICATE_REFER_USER_CD
指定された参照者コードが重複しています。

関連項目:
定数フィールド値

WKF_C_NOT_REFER_USER_TYPE

public static final String WKF_C_NOT_REFER_USER_TYPE
参照者種別が指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_REFER_USER_TYPE

public static final String WKF_C_INVALID_REFER_USER_TYPE
参照者種別の指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_REFER_USER_CODE

public static final String WKF_C_NOT_REFER_USER_CODE
参照者コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_REFER_USER_GROUP_CD

public static final String WKF_C_NOT_REFER_USER_GROUP_CD
参照者グループコードが指定されていません。

関連項目:
定数フィールド値

WKF_C_DUPLICATE_AUTO_PASS_USER_CD

public static final String WKF_C_DUPLICATE_AUTO_PASS_USER_CD
指定された自動パス対象者コードが重複しています。

関連項目:
定数フィールド値

WKF_C_NOT_AUTO_PASS_USER_TYPE

public static final String WKF_C_NOT_AUTO_PASS_USER_TYPE
自動パス対象者種別が指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_AUTO_PASS_USER_TYPE

public static final String WKF_C_INVALID_AUTO_PASS_USER_TYPE
自動パス対象者種別の指定が不正です。

関連項目:
定数フィールド値

WKF_C_NOT_AUTO_PASS_USER_CODE

public static final String WKF_C_NOT_AUTO_PASS_USER_CODE
自動パス対象者コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_AUTO_PASS_USER_GROUP_CD

public static final String WKF_C_NOT_AUTO_PASS_USER_GROUP_CD
自動パス対象者グループコードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_FOUND_LAST_VERSION

public static final String WKF_C_NOT_FOUND_LAST_VERSION
指定されたプロセス定義の最終バージョンの取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_INVALID_EFFECTIVE_DATE

public static final String WKF_C_INVALID_EFFECTIVE_DATE
開始日付が指定されていない、または不正です。yyyy/MM/ddの形式で指定してください。

関連項目:
定数フィールド値

WKF_C_INVALID_END_DATE

public static final String WKF_C_INVALID_END_DATE
終了日付の指定が不正です。yyyy/MM/ddの形式で指定してください。

関連項目:
定数フィールド値

WKF_C_NOT_FOUND_PROCESS_CONTENTS_INFO

public static final String WKF_C_NOT_FOUND_PROCESS_CONTENTS_INFO
指定されたプロセス定義のプロセスコンテンツパス情報の取得に失敗しました。

関連項目:
定数フィールド値

WKF_C_NOT_PROCESS_DEF_CD

public static final String WKF_C_NOT_PROCESS_DEF_CD
プロセス定義コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_PROCESS_DEF_NAME

public static final String WKF_C_NOT_PROCESS_DEF_NAME
プロセス定義名が指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_CATEGORY_CD

public static final String WKF_C_NOT_CATEGORY_CD
カテゴリコードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_PROCESS_CLASS_CD

public static final String WKF_C_NOT_PROCESS_CLASS_CD
プロセス種別コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_PROCESS_CONTENTS_PATH

public static final String WKF_C_NOT_PROCESS_CONTENTS_PATH
プロセスコンテンツパスが指定されていません。

関連項目:
定数フィールド値

WKF_C_INVALID_TARGET_TYPE

public static final String WKF_C_INVALID_TARGET_TYPE
対象者種別が不正

関連項目:
定数フィールド値

WKF_C_NOT_TARGET_CD

public static final String WKF_C_NOT_TARGET_CD
対象者コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_TARGET_GROUP_CD

public static final String WKF_C_NOT_TARGET_GROUP_CD
対象者グループコードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_AUTHORITY_CATEGORY

public static final String WKF_C_NOT_AUTHORITY_CATEGORY
指定されたカテゴリが存在しない、または権限がない可能性があります。

関連項目:
定数フィールド値

WKF_C_NOT_AUTHORITY_PROCESS_DEF

public static final String WKF_C_NOT_AUTHORITY_PROCESS_DEF
指定されたプロセス定義が存在しない、または権限がない可能性があります。

関連項目:
定数フィールド値

WKF_C_NOT_AUTHORITY_ACTIVITY

public static final String WKF_C_NOT_AUTHORITY_ACTIVITY
指定されたタスクが存在しない、または権限がない可能性があります。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_CODE_TYPE

public static final String WKF_C_NOT_TRANSFER_CODE_TYPE
代理設定種別が指定されていない、または不正です。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_PROCESS_DEF

public static final String WKF_C_NOT_TRANSFER_PROCESS_DEF
プロセス定義コードが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_VERSION

public static final String WKF_C_NOT_TRANSFER_VERSION
プロセス定義コード・バージョンコードのいずれかが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_ACTIVITY

public static final String WKF_C_NOT_TRANSFER_ACTIVITY
プロセス定義コード・バージョンコード・アクティビティコードのいずれかが指定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_START_DATE

public static final String WKF_C_NOT_TRANSFER_START_DATE
代理期間(開始日)が指定されていない、または不正です。yyyy/MM/dd|HH:mm:ssの形式で指定してください。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_END_DATE

public static final String WKF_C_NOT_TRANSFER_END_DATE
代理期間(終了日)が指定されていない、または不正です。yyyy/MM/dd|HH:mm:ssの形式で指定してください。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_TARGET_DATE

public static final String WKF_C_NOT_TRANSFER_TARGET_DATE
代理指定日付が指定されていない、または不正です。yyyy/MM/dd|HH:mm:ssの形式で指定してください。

関連項目:
定数フィールド値

WKF_C_NOT_AGENT_SETTING

public static final String WKF_C_NOT_AGENT_SETTING
指定された代理設定は設定されていません。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_AUTHORITY

public static final String WKF_C_NOT_TRANSFER_AUTHORITY
指定された代理依頼先ユーザは処理権限がない可能性があります。

関連項目:
定数フィールド値

WKF_C_NOT_TRANSFER_ATTACH_USER

public static final String WKF_C_NOT_TRANSFER_ATTACH_USER
代理先ユーザ/組織に設定された組織に所属するユーザが存在しない可能性があります。

関連項目:
定数フィールド値

WKF_C_INVALID_PROCESS_STATUS

public static final String WKF_C_INVALID_PROCESS_STATUS
指定された案件を既に完了しています。完了済みの案件に対するプロセス操作はできません。

関連項目:
定数フィールド値

WKF_C_INVALID_TARGET_ACTIVITY_TYPE

public static final String WKF_C_INVALID_TARGET_ACTIVITY_TYPE
指定されたアクティビティは承認タスクではありません。承認タスク以外のタスクへのプロセス操作はできません。

関連項目:
定数フィールド値

WKF_C_INVALID_TRANSFER_STATUS_ALL

public static final String WKF_C_INVALID_TRANSFER_STATUS_ALL
プロセス定義コードに全てが指定されている場合はプロセス定義委譲以外行えません。

関連項目:
定数フィールド値

WKF_C_INVALID_TRANSFER_DATE

public static final String WKF_C_INVALID_TRANSFER_DATE
代理期間開始日が代理期間終了日より未来の日付になっています。

関連項目:
定数フィールド値

WKF_C_ALREADY_STATUS_COMPLETE

public static final String WKF_C_ALREADY_STATUS_COMPLETE
指定されたタスクは既に承認されています。承認されたタスクの対象者を変更することは出来ません。

関連項目:
定数フィールド値

WKF_C_NOT_TARGET_NO_ACTIVITY

public static final String WKF_C_NOT_TARGET_NO_ACTIVITY
指定されたタスク番号のタスクは存在しません。

関連項目:
定数フィールド値

WKF_C_NOT_TARGET_ACTIVITY

public static final String WKF_C_NOT_TARGET_ACTIVITY
指定されたアクティビティは存在しない、または処理タスク以外のアクティビティである可能性があります。

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic の使用

jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter の使用

jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の使用

jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


BPWExecuteLogic (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.data
クラス BPWExecuteLogic

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic
public abstract class BPWExecuteLogic
extends Object

外部プログラム実行抽象クラス。
ワークフロー上で後処理、自動処理で指定した外部プログラムの呼出を実施する際に、
呼び出されるプログラムが継承するクラスです。
外部プログラムはこの抽象化クラスを必ず継承して下さい。

コンストラクタの概要
BPWExecuteLogic()
コンストラクタ
メソッドの概要
String | compulsion(String processDef, String version, String process, String activity, String groupID, String userID) ここで終了後後処理実行メソッド。
boolean | deleteProcess(String processDef, String version, String groupID, String userID) プロセス定義・バージョンの削除処理実行メソッド。
boolean | deleteProcess(String processDef, String version, String process, String groupID, String userID) 案件の削除処理実行メソッド。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ユーザ情報返却メソッド
Map | optionalRegistProcessCd(String processDef, String version, ArrayList userAppList, String groupID, String userID) プロセスCD任意採番処理実行メソッド。
String | proceed(String processDef, String version, String process, String activity, String groupID, String userID) 処理実行メソッド。
String | pullDraft(String processDef, String version, String process, String activity, String groupID, String userID) 引戻し後処理実行メソッド。
String | rejection(String processDef, String version, String process, String activity, String groupID, String userID) 否認後後処理実行メソッド。
String | returnDraft(String processDef, String version, String process, String activity, String groupID, String userID) 処理者へ差戻し後処理実行メソッド。
String | returnStart(String processDef, String version, String process, String activity, String groupID, String userID) 申請者へ差戻し後処理実行メソッド。
String | returnTask(String processDef, String version, String process, String activity, String groupID, String userID) 任意の処理者へ差戻し後処理実行メソッド。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo userInfo) ユーザ情報設定メソッド
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

BPWExecuteLogic

public BPWExecuteLogic()
コンストラクタ

メソッドの詳細

proceed

public String proceed(String processDef,
                      String version,
                      String process,
                      String activity,
                      String groupID,
                      String userID)
               throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                      jp.co.intra_mart.framework.system.exception.SystemException
処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

pullDraft

public String pullDraft(String processDef,
                        String version,
                        String process,
                        String activity,
                        String groupID,
                        String userID)
                 throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                        jp.co.intra_mart.framework.system.exception.SystemException
引戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

returnDraft

public String returnDraft(String processDef,
                          String version,
                          String process,
                          String activity,
                          String groupID,
                          String userID)
                   throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                          jp.co.intra_mart.framework.system.exception.SystemException
処理者へ差戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

returnStart

public String returnStart(String processDef,
                          String version,
                          String process,
                          String activity,
                          String groupID,
                          String userID)
                   throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                          jp.co.intra_mart.framework.system.exception.SystemException
申請者へ差戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

returnTask

public String returnTask(String processDef,
                         String version,
                         String process,
                         String activity,
                         String groupID,
                         String userID)
                  throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                         jp.co.intra_mart.framework.system.exception.SystemException
任意の処理者へ差戻し後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

rejection

public String rejection(String processDef,
                        String version,
                        String process,
                        String activity,
                        String groupID,
                        String userID)
                 throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                        jp.co.intra_mart.framework.system.exception.SystemException
否認後後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

compulsion

public String compulsion(String processDef,
                         String version,
                         String process,
                         String activity,
                         String groupID,
                         String userID)
                  throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                         jp.co.intra_mart.framework.system.exception.SystemException
ここで終了後後処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

deleteProcess

public boolean deleteProcess(String processDef,
                             String version,
                             String process,
                             String groupID,
                             String userID)
                      throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                             jp.co.intra_mart.framework.system.exception.SystemException
案件の削除処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合はtrue、完了していない場合はfalseを指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

deleteProcess

public boolean deleteProcess(String processDef,
                             String version,
                             String groupID,
                             String userID)
                      throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                             jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義・バージョンの削除処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合はtrue、完了していない場合はfalseを指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

optionalRegistProcessCd

public Map optionalRegistProcessCd(String processDef,
                                   String version,
                                   ArrayList userAppList,
                                   String groupID,
                                   String userID)
                            throws jp.co.intra_mart.framework.system.exception.ApplicationException,
                                   jp.co.intra_mart.framework.system.exception.SystemException
プロセスCD任意採番処理実行メソッド。
外部プログラムのロジックはこのメソッドより記述して下さい。
返却値には呼び出し先の処理が完了した場合は「STATUS_COMPLETED」、 処理に時間がかかる若しくはバッチ処理後に処理完了する場合は「STATUS_ACTIVE」、 障害発生の場合は「STATUS_FAULT」を指定してください。
また、障害が発生した場合はBPWに例外をthrowします。
BPWは例外を受けることでトランザクションの制御を実施します。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo userInfo)
ユーザ情報設定メソッド

パラメータ:
userInfo -

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ユーザ情報返却メソッド

戻り値:
ユーザ情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ConditionAdapter (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.data
クラス ConditionAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.data.Condition
        拡張 jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter
public abstract class ConditionAdapter
extends jp.co.intra_mart.foundation.bpw.model.data.Condition

外部プログラム実行抽象クラス。
ワークフロー上で条件分岐、結合条件で指定した外部プログラムの呼出を実施する際に、
呼び出されるプログラムが継承するクラスです。
外部プログラムはこの抽象化クラスを必ず継承して下さい。

フィールドの概要
クラス jp.co.intra_mart.foundation.bpw.model.data.Condition から継承したフィールド
conditionModel
コンストラクタの概要
ConditionAdapter(ConditionModel model)
コンストラクタ
メソッドの概要
abstract boolean | execute(String processDef, String version, String process, String activity, String groupID, String userID) 条件問い合わせを実行するメソッド 条件分岐および、条件結合の判定を行う場合はこのメソッドを継承してください。
boolean | isSatisfied() 条件問い合わせ
クラス jp.co.intra_mart.foundation.bpw.model.data.Condition から継承したメソッド
getLoginUserInfo, setLoginUserInfo
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConditionAdapter

public ConditionAdapter(ConditionModel model)
コンストラクタ

メソッドの詳細

isSatisfied

public final boolean isSatisfied()
                          throws jp.co.intra_mart.framework.system.exception.SystemException
条件問い合わせ

戻り値:
条件結果
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生

execute

public abstract boolean execute(String processDef,
                                String version,
                                String process,
                                String activity,
                                String groupID,
                                String userID)
                         throws jp.co.intra_mart.framework.system.exception.SystemException
条件問い合わせを実行するメソッド
条件分岐および、条件結合の判定を行う場合はこのメソッドを継承してください。

パラメータ:
processDef - 呼出プロセス定義コード
version - 呼出履歴コード
process - 呼出プロセスコード
activity - 呼出アクティビティコード
groupID - 呼出時ログイングループコード
userID - 呼出時ログインユーザコード
戻り値:
処理結果
例外:
jp.co.intra_mart.framework.system.exception.SystemException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


EISModelStaticIF (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.data
インタフェース EISModelStaticIF

public interface EISModelStaticIF

アクティビティの状態等を定義するインタフェース。
アクティビティ種別
アクティビティステータス
アクティビティ到達種別
を定義する。

フィールドの概要
static String | ACTIVITY_ID_EMPTY エンプティの処理タイプID
static String | ACTIVITY_ID_FLOW フローの処理タイプID
static String | ACTIVITY_ID_INVOKE_AUTO インボーク(自動呼出)の処理タイプID
static String | ACTIVITY_ID_INVOKE_EVENT インボーク(イベント)の処理タイプID
static String | ACTIVITY_ID_INVOKE_PROCESS インボーク(プロセス呼出)の処理タイプID
static String | ACTIVITY_ID_PROCESS プロセスの処理タイプID
static String | ACTIVITY_ID_RECEIVE レシーブの処理タイプID
static String | ACTIVITY_ID_ROUTE_SELECT ルート選択の処理タイプID
static String | ACTIVITY_ID_SEQUENCE シーケンスの処理タイプID
static String | ACTIVITY_ID_SWITCH スイッチの処理タイプID
static String | ACTIVITY_ID_TERMINATE ターミネートの処理タイプID
static String | ATTAINMENT_NORMAL アクティビティは通常に処理が到達した。
static String | ATTAINMENT_NOT アクティビティには処理が到達していない。
static String | ATTAINMENT_PULL_ACTIVE 引き戻し（Active)
static String | ATTAINMENT_PULL_READY 被・引き戻し（Ready)
static String | ATTAINMENT_RETURN_ACTIVE 差し戻し（Active)
static String | ATTAINMENT_RETURN_READY 被・差し戻し（Complete→Ready)
static String | ATTAINMENT_RETURN_READY_ACTIVE 被・差し戻し（Active→Ready)
static int | EIS_INIT 初期値（数値）
static String | EIS_METHOD_ACTIVED リフレクト・メソッド（開始）
static String | EIS_METHOD_CANCELED リフレクト・メソッド（取消）
static String | EIS_METHOD_CLOSED リフレクト・メソッド（閉じる）
static String | EIS_METHOD_COMPENSATED リフレクト・メソッド（補完）
static String | EIS_METHOD_COMPLETED リフレクト・メソッド（完了）
static String | EIS_METHOD_COMPULSION リフレクト・メソッド（強制完了）
static String | EIS_METHOD_EXITED リフレクト・メソッド（終了）
static String | EIS_METHOD_FAULTED リフレクト・メソッド（障害）
static String | EIS_METHOD_SUSPENDED リフレクト・メソッド（保留中）
static String | END_STATUS_CANCEL 完了ステータス：取り止め
static String | END_STATUS_COMPULSION 完了ステータス：途中終了
static String | END_STATUS_NORMAL 完了ステータス：通常
static String | END_STATUS_REJECTION 完了ステータス：否認
static String | FLG_OFF フラグOFF
static String | FLG_ON フラグON
static String | STATUS_ACTIVE 有効な状態であることを示すステータス
static String | STATUS_AUTOCLOSING 自動終了を示すステータス
static String | STATUS_CANCELING 取消中であることを示すステータス
static String | STATUS_CLOSING 終了したことを示すステータス
static String | STATUS_COMPENSATING 補完中であることを示すステータス
static String | STATUS_COMPLETED 完了したことを示すステータス
static String | STATUS_EXIT 処理が終了したことを示すステータス
static String | STATUS_FAULT 障害が発生したことを示すステータス
static String | STATUS_NONE 有効なステータスではない
static String | STATUS_READY 準備完了を示すステータス
static String | STATUS_SUSPEND 保留中であることを示すステータス
static String | STR_INIT 初期値（文字列）
static String | STR_NULL 空文字

フィールドの詳細

ACTIVITY_ID_PROCESS

public static final String ACTIVITY_ID_PROCESS
プロセスの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_RECEIVE

public static final String ACTIVITY_ID_RECEIVE
レシーブの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_INVOKE_PROCESS

public static final String ACTIVITY_ID_INVOKE_PROCESS
インボーク(プロセス呼出)の処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_INVOKE_AUTO

public static final String ACTIVITY_ID_INVOKE_AUTO
インボーク(自動呼出)の処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_SEQUENCE

public static final String ACTIVITY_ID_SEQUENCE
シーケンスの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_FLOW

public static final String ACTIVITY_ID_FLOW
フローの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_TERMINATE

public static final String ACTIVITY_ID_TERMINATE
ターミネートの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_EMPTY

public static final String ACTIVITY_ID_EMPTY
エンプティの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_SWITCH

public static final String ACTIVITY_ID_SWITCH
スイッチの処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_INVOKE_EVENT

public static final String ACTIVITY_ID_INVOKE_EVENT
インボーク(イベント)の処理タイプID

関連項目:
定数フィールド値

ACTIVITY_ID_ROUTE_SELECT

public static final String ACTIVITY_ID_ROUTE_SELECT
ルート選択の処理タイプID

関連項目:
定数フィールド値

STATUS_NONE

public static final String STATUS_NONE
有効なステータスではない

関連項目:
定数フィールド値

STATUS_READY

public static final String STATUS_READY
準備完了を示すステータス

関連項目:
定数フィールド値

STATUS_ACTIVE

public static final String STATUS_ACTIVE
有効な状態であることを示すステータス

関連項目:
定数フィールド値

STATUS_SUSPEND

public static final String STATUS_SUSPEND
保留中であることを示すステータス

関連項目:
定数フィールド値

STATUS_CANCELING

public static final String STATUS_CANCELING
取消中であることを示すステータス

関連項目:
定数フィールド値

STATUS_COMPLETED

public static final String STATUS_COMPLETED
完了したことを示すステータス

関連項目:
定数フィールド値

STATUS_COMPENSATING

public static final String STATUS_COMPENSATING
補完中であることを示すステータス

関連項目:
定数フィールド値

STATUS_CLOSING

public static final String STATUS_CLOSING
終了したことを示すステータス

関連項目:
定数フィールド値

STATUS_FAULT

public static final String STATUS_FAULT
障害が発生したことを示すステータス

関連項目:
定数フィールド値

STATUS_EXIT

public static final String STATUS_EXIT
処理が終了したことを示すステータス

関連項目:
定数フィールド値

STATUS_AUTOCLOSING

public static final String STATUS_AUTOCLOSING
自動終了を示すステータス

関連項目:
定数フィールド値

END_STATUS_NORMAL

public static final String END_STATUS_NORMAL
完了ステータス：通常

関連項目:
定数フィールド値

END_STATUS_REJECTION

public static final String END_STATUS_REJECTION
完了ステータス：否認

関連項目:
定数フィールド値

END_STATUS_CANCEL

public static final String END_STATUS_CANCEL
完了ステータス：取り止め

関連項目:
定数フィールド値

END_STATUS_COMPULSION

public static final String END_STATUS_COMPULSION
完了ステータス：途中終了

関連項目:
定数フィールド値

EIS_METHOD_ACTIVED

public static final String EIS_METHOD_ACTIVED
リフレクト・メソッド（開始）

関連項目:
定数フィールド値

EIS_METHOD_SUSPENDED

public static final String EIS_METHOD_SUSPENDED
リフレクト・メソッド（保留中）

関連項目:
定数フィールド値

EIS_METHOD_COMPLETED

public static final String EIS_METHOD_COMPLETED
リフレクト・メソッド（完了）

関連項目:
定数フィールド値

EIS_METHOD_COMPULSION

public static final String EIS_METHOD_COMPULSION
リフレクト・メソッド（強制完了）

関連項目:
定数フィールド値

EIS_METHOD_FAULTED

public static final String EIS_METHOD_FAULTED
リフレクト・メソッド（障害）

関連項目:
定数フィールド値

EIS_METHOD_EXITED

public static final String EIS_METHOD_EXITED
リフレクト・メソッド（終了）

関連項目:
定数フィールド値

EIS_METHOD_COMPENSATED

public static final String EIS_METHOD_COMPENSATED
リフレクト・メソッド（補完）

関連項目:
定数フィールド値

EIS_METHOD_CANCELED

public static final String EIS_METHOD_CANCELED
リフレクト・メソッド（取消）

関連項目:
定数フィールド値

EIS_METHOD_CLOSED

public static final String EIS_METHOD_CLOSED
リフレクト・メソッド（閉じる）

関連項目:
定数フィールド値

ATTAINMENT_NOT

public static final String ATTAINMENT_NOT
アクティビティには処理が到達していない。

関連項目:
定数フィールド値

ATTAINMENT_NORMAL

public static final String ATTAINMENT_NORMAL
アクティビティは通常に処理が到達した。

関連項目:
定数フィールド値

ATTAINMENT_PULL_ACTIVE

public static final String ATTAINMENT_PULL_ACTIVE
引き戻し（Active)

関連項目:
定数フィールド値

ATTAINMENT_PULL_READY

public static final String ATTAINMENT_PULL_READY
被・引き戻し（Ready)

関連項目:
定数フィールド値

ATTAINMENT_RETURN_ACTIVE

public static final String ATTAINMENT_RETURN_ACTIVE
差し戻し（Active)

関連項目:
定数フィールド値

ATTAINMENT_RETURN_READY

public static final String ATTAINMENT_RETURN_READY
被・差し戻し（Complete→Ready)

関連項目:
定数フィールド値

ATTAINMENT_RETURN_READY_ACTIVE

public static final String ATTAINMENT_RETURN_READY_ACTIVE
被・差し戻し（Active→Ready)

関連項目:
定数フィールド値

FLG_ON

public static final String FLG_ON
フラグON

関連項目:
定数フィールド値

FLG_OFF

public static final String FLG_OFF
フラグOFF

関連項目:
定数フィールド値

STR_NULL

public static final String STR_NULL
空文字

関連項目:
定数フィールド値

STR_INIT

public static final String STR_INIT
初期値（文字列）

関連項目:
定数フィールド値

EIS_INIT

public static final int EIS_INIT
初期値（数値）

関連項目:
定数フィールド値
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.bpw.model.data (bpw 6.1.14 API)

 jp.co.intra_mart.foundation.bpw.model.data
インタフェース
EISModelStaticIF
クラス
BPWExecuteLogic
ConditionAdapter


jp.co.intra_mart.foundation.bpw.model.data (bpw 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.data

インタフェースの概要
EISModelStaticIF アクティビティの状態等を定義するインタフェース。

クラスの概要
BPWExecuteLogic | 外部プログラム実行抽象クラス。
ConditionAdapter | 外部プログラム実行抽象クラス。


jp.co.intra_mart.foundation.bpw.model.data クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.data の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic
    • class jp.co.intra_mart.foundation.bpw.model.data.Condition
      • class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter

インタフェース階層

  • interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF


パッケージ jp.co.intra_mart.foundation.bpw.model.data の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.bpw.model.data の使用

jp.co.intra_mart.foundation.bpw.model.data はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の使用

ActivityInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object

jp.co.intra_mart.foundation.bpw.model.object での ActivityInfoModel の使用

ActivityInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunUserInfoModel(ActivityInfoModel src)
RunExecutiveInfoModel(ActivityInfoModel src)
RecognitionInfoModel(ActivityInfoModel src)
ConditionModel(ActivityInfoModel src)
ActivityInfoModel(ActivityInfoModel src)

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.ConditionModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.ConditionModel の使用

ConditionModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.data

jp.co.intra_mart.foundation.bpw.model.data での ConditionModel の使用

ConditionModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.data のコンストラクタ
ConditionAdapter(ConditionModel model)
コンストラクタ

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の使用

ProcessInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.object での ProcessInfoModel の使用

ProcessInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunUserInfoModel(ProcessInfoModel src)
RecognitionInfoModel(ProcessInfoModel src)

jp.co.intra_mart.foundation.wkf での ProcessInfoModel の使用

ProcessInfoModel を返す jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の使用

jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の使用

RunExecutiveInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.object での RunExecutiveInfoModel の使用

RunExecutiveInfoModel を返す jp.co.intra_mart.foundation.bpw.model.object のメソッド
 RunExecutiveInfoModel RecognitionInfoModel.getRunExecuteInfoModel()
実行主体ユーザマスタ情報を返却します。

RunExecutiveInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のメソッド
 void RecognitionInfoModel.setRunExecuteInfoModel(RunExecutiveInfoModel model)
実行時選択時実行主体役職マスタテーブルを設定します。

RunExecutiveInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunExecutiveInfoModel(RunExecutiveInfoModel src)

jp.co.intra_mart.foundation.wkf での RunExecutiveInfoModel の使用

RunExecutiveInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の使用

RunUserInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.object での RunUserInfoModel の使用

RunUserInfoModel を返す jp.co.intra_mart.foundation.bpw.model.object のメソッド
 RunUserInfoModel RecognitionInfoModel.getRunUserInfoModel()
実行主体役職マスタ情報を返却します。

RunUserInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のメソッド
void | RecognitionInfoModel.setRunUserInfoModel(RunUserInfoModel model) 実行時選択時実行主体ユーザマスタ情報を設定します。
void | ActivityInfoModel.addRunuserlist(RunUserInfoModel model) 実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。

RunUserInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.bpw.model.object のコンストラクタ
RunUserInfoModel(RunUserInfoModel src)

jp.co.intra_mart.foundation.wkf での RunUserInfoModel の使用

RunUserInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の使用

jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ActivityInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス ActivityInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, Cloneable, Serializable
public class ActivityInfoModel
extends Object
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, Cloneable, Serializable

アクティビティ情報を保持するクラス
アクティビティ情報を保持します。

関連項目:
直列化された形式

フィールドの概要
static String | END_TASK_OFF 非終了タスク
static String | END_TASK_ON 終了タスク
static String | PROCESSING_COMPLETED 【共通】完了
static String | PROCESSING_NORMALL 【本人・代理設定なし】通常(通常到達にて活性化)
static String | PROCESSING_PSN_NORMALL 【代理設定有り・本人決済可】通常(通常到達にて活性化)
static String | PROCESSING_PSN_PULL_BACK 【代理設定有り・本人決済可】引戻し(引戻しにて活性化)
static String | PROCESSING_PSN_PULL_SUSPEND 【代理設定有り・本人決済可】引戻し(引戻しにて活性化後の保留)
static String | PROCESSING_PSN_SEND_BACK 【代理設定有り・本人決済可】差戻し(差戻しにて活性化)
static String | PROCESSING_PSN_SEND_SUSPEND 【代理設定有り・本人決済可】差戻し(差戻しにて活性化後の保留)
static String | PROCESSING_PSN_SUSPEND 【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
static String | PROCESSING_PULL_BACK 【本人・代理設定なし】引戻し(引戻しにて活性化)
static String | PROCESSING_PULL_SUSPEND 【本人・代理設定なし】引戻し(引戻しにて活性化後の保留)
static String | PROCESSING_SEND_BACK 【本人・代理設定なし】差戻し(差戻しにて活性化)
static String | PROCESSING_SEND_SUSPEND 【本人・代理設定なし】差戻し(差戻しにて活性化後の保留)
static String | PROCESSING_SUB_NORMALL 【代理設定有り・本人決不可】通常(通常到達にて活性化)
static String | PROCESSING_SUB_PULL_BACK 【代理設定有り・本人決不可】引戻し(引戻しにて活性化)
static String | PROCESSING_SUB_PULL_SUSPEND 【代理設定有り・本人決不可】引戻し(引戻しにて活性化後の保留)
static String | PROCESSING_SUB_SEND_BACK 【代理設定有り・本人決不可】差戻し(差戻しにて活性化)
static String | PROCESSING_SUB_SEND_SUSPEND 【代理設定有り・本人決不可】差戻し(差戻しにて活性化後の保留)
static String | PROCESSING_SUB_SUSPEND 【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
static String | PROCESSING_SUSPEND 【本人・代理設定なし】通常(通常到達にて活性化後の保留)
static String | PULL_ACTIVITY_OFF 引き戻し不可
static String | PULL_ACTIVITY_ON 引き戻し可
static String | REFER_ALL 参照者若しくは承認者として関連図けられたアクティビティ
static String | REFER_NONE 参照者・承認者を考慮しない
static String | REFER_READ 参照者として関連図けられたアクティビティ
static String | REFER_RECOGNITION 承認者として関連図けられたアクティビティ
static String | RETURN_ACTIVITY_OFF 差し戻し不可
static String | RETURN_ACTIVITY_ON 差し戻し可
static String | RETURN_MAIL_OFF 差し戻しメール送信なし
static String | RETURN_MAIL_ON 差し戻しメール送信あり
static String | RUN_AUTH_ALL 処理権限・代理権限供にあるアクティビティ
static String | RUN_AUTH_NOT 処理権限がないアクティビティ
static String | RUN_AUTH_RUN 処理権限があるアクティビティ
static String | RUN_AUTH_TRANSFER 代理処理権限があるアクティビティ
static String | RUN_SELECT_OFF 実行時選択OFF
static String | RUN_SELECT_ON 実行時選択ON
static String | TRANSFER_OFF 代理承認者なし
static String | TRANSFER_ON 代理承認者あり
コンストラクタの概要
ActivityInfoModel()
コンストラクタ
ActivityInfoModel(ActivityInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.EditTransferTableInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.SwitchInfoModel src)
ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel src)
メソッドの概要
void | addAutopasslist(jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoModel model) 自動パスリスト情報に新たに自動パス情報を追加します。
void | addReceivelist(jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoModel model) レシーブリスト情報に新たにレシーブ情報を追加します。
void | addRunuserlist(RunUserInfoModel model) 実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。
void | addUserAppliKey(int i, jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
Object | clone() クローン
static String | convertEndTaskFlag(String shortestEndFlg) 最短終了タスク値を最終タスクフラグに変換します。
String | getActivityCd() アクティビティコードを返却します。
String | getActivityName() アクティビティ名を返却します。
String | getActivityStatus() アクティビティステータスを返却します。
String | getActivityType() アクティビティ種別を返却します。
String | getAttainmentClass() 到達種別を返却します。
String | getAutoPassFlag() 自動パス処理フラグを返却します。
List | getAutoPasslist() 自動パスのリスト情報を返却します。
String | getAutoPassTerm() 自動パス期限を返却します。
String | getBefActiCd() 前処理アクティビティ名を返却します。
String | getBefActiName() 前処理アクティビティ名を返却します。
String | getBefActiUserCd() 前処理者CDを返却します。
String | getBefActiUserName() 前処理者名を返却します。
String | getCallActivityCd() 呼出アクティビティコードを返却します。
String | getCallActivityType() 呼出アクティビティ種別を返却します。
String | getCompulsionEndFlag() 強制終了可否フラグを返却します。
String | getConditionType() 分岐種別を返却します。
String | getEndTaskFlag() 終了タスクフラグを返却します。
String | getEndTaskProgram() END時実行クラスを返却します。
String | getLoginGroupID() ログイングループIDを返却します。
String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
String | getPreActivityCd() 処理契機アクティビティコードを返却します。
String | getPreProcessCd() 処理契機プロセスコードを返却します。
String | getPreProcessDefCd() 処理契機プロセス定義コードを返却します。
String | getPresentProcess() 現処理を返却します。
String | getPreVersionCd() 処理契機履歴コードを返却します。
String | getProcessCd() プロセスコードを返却します。
String | getProcessDefCd() プロセス定義コードを返却します。
String | getProcessTermDate() 処理期限日付を返却します。
List | getReceivelist() レシーブのリスト情報を返却します。
String | getReceptionDate() 受信日付を返却します。
String | getReturnFlag() 引戻し・差戻しフラグを返却します。
String | getReturnHistoryCd() 差し戻し履歴コードを返却します。
String | getReturnMailFlag() 引戻し・差戻しメール送信フラグを返却します。
String | getRunSelectFlg() 実行時選択フラグを返却します。
List | getRunuserlist() 実行主体ユーザのリスト情報を返却します。
String | getSelectRouteNo() 選択ルート番号を返却します。
String | getStatusEndedDate() ステータス完了日付を返却します。
jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel | getUserAppliKey(int i) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を 返却します。
Map | getUserApplikeyList() ユーザアプリケーションキーテーブル情報リストを返却します。
String | getVersionCd() 履歴コードを返却します。
void | setActivityCd(String string) アクティビティコードを設定します。
void | setActivityName(String string) アクティビティ名を設定します。
void | setActivityStatus(String string) アクティビティステータスを設定します。
void | setActivityType(String string) アクティビティ種別を設定します。
void | setAttainmentClass(String string) 到達種別を設定します。
void | setAutoPassFlag(String string) 自動パス処理フラグを設定します。
void | setAutoPassTerm(String string) 自動パス期限を設定します。
void | setBefActiCd(String string) 前処理アクティビティコードを設定します。
void | setBefActiName(String string) 前処理アクティビティ名を設定します。
void | setBefActiUserCd(String string) 前処理者CDを設定します。
void | setBefActiUserName(String string) 前処理者名を設定します。
void | setCallActivityCd(String string) 呼出アクティビティコードを設定します。
void | setCallActivityType(String string) 呼出アクティビティ種別を設定します。
void | setCompulsionEndFlag(String string) 強制終了可否フラグを設定します。
void | setConditionType(String string) 分岐種別を設定します。
void | setEndTaskFlag(String string) 終了タスクフラグを設定します。
void | setEndTaskProgram(String string) END時実行クラスを設定します。
void | setLoginGroupID(String string) ログイングループIDを設定します。
void | setLoginUserID(String string) ログインユーザIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setPreActivityCd(String string) 処理契機アクティビティコードを設定します。
void | setPreProcessCd(String string) 処理契機プロセスコードを設定します。
void | setPreProcessDefCd(String string) 処理契機プロセス定義コードを設定します。
void | setPresentProcess(String string) 現処理を設定します。
void | setPreVersionCd(String string) 処理契機履歴コードを設定します。
void | setProcessCd(String string) 検索条件とするプロセスコードを設定します。
void | setProcessDefCd(String string) 検索条件とするプロセス定義コードを設定します。
void | setProcessTermDate(String string) 検索条件とするプロセスコードを設定します。
void | setReceptionDate(String string) 受信日付をを設定します。
void | setReturnFlag(String string) 引戻し・差戻しフラグを設定します。
void | setReturnHistoryCd(String string) 差し戻し履歴コードを設定します。
void | setReturnMailFlag(String string) 引戻し・差戻しメール送信フラグ設定します。
void | setRunSelectFlg(String string) 実行時選択フラグを設定します。
void | setSelectRouteNo(String string) 選択ルート番を設定します。
void | setStatusEndedDate(String string) ステータス完了日付を設定します。
void | setVersionCd(String string) 検索条件とする履歴コードを設定します。
クラス java.lang.Object から継承したメソッド
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REFER_ALL

public static final String REFER_ALL
参照者若しくは承認者として関連図けられたアクティビティ

関連項目:
定数フィールド値

REFER_READ

public static final String REFER_READ
参照者として関連図けられたアクティビティ

関連項目:
定数フィールド値

REFER_RECOGNITION

public static final String REFER_RECOGNITION
承認者として関連図けられたアクティビティ

関連項目:
定数フィールド値

REFER_NONE

public static final String REFER_NONE
参照者・承認者を考慮しない

関連項目:
定数フィールド値

RUN_AUTH_NOT

public static final String RUN_AUTH_NOT
処理権限がないアクティビティ

関連項目:
定数フィールド値

RUN_AUTH_RUN

public static final String RUN_AUTH_RUN
処理権限があるアクティビティ

関連項目:
定数フィールド値

RUN_AUTH_TRANSFER

public static final String RUN_AUTH_TRANSFER
代理処理権限があるアクティビティ

関連項目:
定数フィールド値

RUN_AUTH_ALL

public static final String RUN_AUTH_ALL
処理権限・代理権限供にあるアクティビティ

関連項目:
定数フィールド値

RUN_SELECT_ON

public static final String RUN_SELECT_ON
実行時選択ON

関連項目:
定数フィールド値

RUN_SELECT_OFF

public static final String RUN_SELECT_OFF
実行時選択OFF

関連項目:
定数フィールド値

TRANSFER_ON

public static final String TRANSFER_ON
代理承認者あり

関連項目:
定数フィールド値

TRANSFER_OFF

public static final String TRANSFER_OFF
代理承認者なし

関連項目:
定数フィールド値

PULL_ACTIVITY_ON

public static final String PULL_ACTIVITY_ON
引き戻し可

関連項目:
定数フィールド値

PULL_ACTIVITY_OFF

public static final String PULL_ACTIVITY_OFF
引き戻し不可

関連項目:
定数フィールド値

RETURN_ACTIVITY_ON

public static final String RETURN_ACTIVITY_ON
差し戻し可

関連項目:
定数フィールド値

RETURN_ACTIVITY_OFF

public static final String RETURN_ACTIVITY_OFF
差し戻し不可

関連項目:
定数フィールド値

RETURN_MAIL_ON

public static final String RETURN_MAIL_ON
差し戻しメール送信あり

関連項目:
定数フィールド値

RETURN_MAIL_OFF

public static final String RETURN_MAIL_OFF
差し戻しメール送信なし

関連項目:
定数フィールド値

END_TASK_ON

public static final String END_TASK_ON
終了タスク

関連項目:
定数フィールド値

END_TASK_OFF

public static final String END_TASK_OFF
非終了タスク

関連項目:
定数フィールド値

PROCESSING_NORMALL

public static final String PROCESSING_NORMALL
【本人・代理設定なし】通常(通常到達にて活性化)

関連項目:
定数フィールド値

PROCESSING_PULL_BACK

public static final String PROCESSING_PULL_BACK
【本人・代理設定なし】引戻し(引戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SEND_BACK

public static final String PROCESSING_SEND_BACK
【本人・代理設定なし】差戻し(差戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SUSPEND

public static final String PROCESSING_SUSPEND
【本人・代理設定なし】通常(通常到達にて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PULL_SUSPEND

public static final String PROCESSING_PULL_SUSPEND
【本人・代理設定なし】引戻し(引戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SEND_SUSPEND

public static final String PROCESSING_SEND_SUSPEND
【本人・代理設定なし】差戻し(差戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PSN_NORMALL

public static final String PROCESSING_PSN_NORMALL
【代理設定有り・本人決済可】通常(通常到達にて活性化)

関連項目:
定数フィールド値

PROCESSING_PSN_PULL_BACK

public static final String PROCESSING_PSN_PULL_BACK
【代理設定有り・本人決済可】引戻し(引戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_PSN_SEND_BACK

public static final String PROCESSING_PSN_SEND_BACK
【代理設定有り・本人決済可】差戻し(差戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_PSN_SUSPEND

public static final String PROCESSING_PSN_SUSPEND
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PSN_PULL_SUSPEND

public static final String PROCESSING_PSN_PULL_SUSPEND
【代理設定有り・本人決済可】引戻し(引戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_PSN_SEND_SUSPEND

public static final String PROCESSING_PSN_SEND_SUSPEND
【代理設定有り・本人決済可】差戻し(差戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SUB_NORMALL

public static final String PROCESSING_SUB_NORMALL
【代理設定有り・本人決不可】通常(通常到達にて活性化)

関連項目:
定数フィールド値

PROCESSING_SUB_PULL_BACK

public static final String PROCESSING_SUB_PULL_BACK
【代理設定有り・本人決不可】引戻し(引戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SUB_SEND_BACK

public static final String PROCESSING_SUB_SEND_BACK
【代理設定有り・本人決不可】差戻し(差戻しにて活性化)

関連項目:
定数フィールド値

PROCESSING_SUB_SUSPEND

public static final String PROCESSING_SUB_SUSPEND
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SUB_PULL_SUSPEND

public static final String PROCESSING_SUB_PULL_SUSPEND
【代理設定有り・本人決不可】引戻し(引戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_SUB_SEND_SUSPEND

public static final String PROCESSING_SUB_SEND_SUSPEND
【代理設定有り・本人決不可】差戻し(差戻しにて活性化後の保留)

関連項目:
定数フィールド値

PROCESSING_COMPLETED

public static final String PROCESSING_COMPLETED
【共通】完了

関連項目:
定数フィールド値
コンストラクタの詳細

ActivityInfoModel

public ActivityInfoModel()
コンストラクタ

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.SwitchInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.EditTransferTableInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)

ActivityInfoModel

public ActivityInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)

ActivityInfoModel

public ActivityInfoModel(ActivityInfoModel src)
メソッドの詳細

clone

public Object clone()
             throws CloneNotSupportedException
クローン

例外:
CloneNotSupportedException

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義コード

getVersionCd

public String getVersionCd()
履歴コードを返却します。 システムで利用されるメソッドです。

戻り値:
履歴コード

getProcessCd

public String getProcessCd()
プロセスコードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセスコード

getActivityCd

public String getActivityCd()
アクティビティコードを返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティコード

getActivityName

public String getActivityName()
アクティビティ名を返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティ名

getActivityType

public String getActivityType()
アクティビティ種別を返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティ種別

getActivityStatus

public String getActivityStatus()
アクティビティステータスを返却します。 システムで利用されるメソッドです。

戻り値:
アクティビティステータス

getStatusEndedDate

public String getStatusEndedDate()
ステータス完了日付を返却します。 システムで利用されるメソッドです。

戻り値:
ステータス完了日付

getCallActivityCd

public String getCallActivityCd()
呼出アクティビティコードを返却します。 システムで利用されるメソッドです。

戻り値:
呼出アクティビティコード

getCallActivityType

public String getCallActivityType()
呼出アクティビティ種別を返却します。 システムで利用されるメソッドです。

戻り値:
呼出アクティビティ種別

getAutoPassTerm

public String getAutoPassTerm()
自動パス期限を返却します。 システムで利用されるメソッドです。

戻り値:
自動パス期限

getAutoPassFlag

public String getAutoPassFlag()
自動パス処理フラグを返却します。 システムで利用されるメソッドです。

戻り値:
自動パス処理フラグ

getAttainmentClass

public String getAttainmentClass()
到達種別を返却します。

戻り値:
到達種別

getReceptionDate

public String getReceptionDate()
受信日付を返却します。 システムで利用されるメソッドです。

戻り値:
受信日付

getProcessTermDate

public String getProcessTermDate()
処理期限日付を返却します。

戻り値:
処理期限日付

getPresentProcess

public String getPresentProcess()
現処理を返却します。

戻り値:
現処理

getBefActiCd

public String getBefActiCd()
前処理アクティビティ名を返却します。

戻り値:
前処理アクティビティ名

getBefActiName

public String getBefActiName()
前処理アクティビティ名を返却します。

戻り値:
前処理アクティビティ名

getBefActiUserCd

public String getBefActiUserCd()
前処理者CDを返却します。

戻り値:
前処理者CD

getBefActiUserName

public String getBefActiUserName()
前処理者名を返却します。

戻り値:
前処理者名

getCompulsionEndFlag

public String getCompulsionEndFlag()
強制終了可否フラグを返却します。

戻り値:
強制終了可否フラグ
関連項目:
強制終了：可, 強制終了：不可

getReturnMailFlag

public String getReturnMailFlag()
引戻し・差戻しメール送信フラグを返却します。

戻り値:
引戻し・差戻しメール送信フラグ

getReturnFlag

public String getReturnFlag()
引戻し・差戻しフラグを返却します。

戻り値:
引戻し・差戻しフラグ

getPreProcessDefCd

public String getPreProcessDefCd()
処理契機プロセス定義コードを返却します。

戻り値:
処理契機プロセス定義コード

getPreVersionCd

public String getPreVersionCd()
処理契機履歴コードを返却します。

戻り値:
処理契機履歴コード

getPreProcessCd

public String getPreProcessCd()
処理契機プロセスコードを返却します。

戻り値:
処理契機プロセスコード

getPreActivityCd

public String getPreActivityCd()
処理契機アクティビティコードを返却します。

戻り値:
処理契機アクティビティコード

getEndTaskFlag

public String getEndTaskFlag()
終了タスクフラグを返却します。

戻り値:
終了タスクフラグ

getSelectRouteNo

public String getSelectRouteNo()
選択ルート番号を返却します。

戻り値:
選択ルート番号

getEndTaskProgram

public String getEndTaskProgram()
END時実行クラスを返却します。

戻り値:
END時実行クラス

getConditionType

public String getConditionType()
分岐種別を返却します。

戻り値:
分岐種別

getReturnHistoryCd

public String getReturnHistoryCd()
差し戻し履歴コードを返却します。

戻り値:
差し戻し履歴コード

getRunuserlist

public List getRunuserlist()
実行主体ユーザのリスト情報を返却します。 システムで利用されるメソッドです。

戻り値:
実行主体ユーザのリスト情報

getReceivelist

public List getReceivelist()
レシーブのリスト情報を返却します。 システムで利用されるメソッドです。

戻り値:
レシーブのリスト情報

getAutoPasslist

public List getAutoPasslist()
自動パスのリスト情報を返却します。 システムで利用されるメソッドです。

戻り値:
自動パスのリスト情報

getRunSelectFlg

public String getRunSelectFlg()
実行時選択フラグを返却します。

戻り値:
実行時選択フラグ
関連項目:
実行時選択ON, 実行時選択OFF

getUserAppliKey

public jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel getUserAppliKey(int i)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を 返却します。

パラメータ:
i - パラメータ番号
戻り値:
ユーザアプリケーションキーテーブル情報

getUserApplikeyList

public Map getUserApplikeyList()
ユーザアプリケーションキーテーブル情報リストを返却します。

戻り値:
ユーザアプリケーションキーテーブル情報リスト

setProcessDefCd

public void setProcessDefCd(String string)
検索条件とするプロセス定義コードを設定します。

パラメータ:
string - 検索値

setVersionCd

public void setVersionCd(String string)
検索条件とする履歴コードを設定します。

パラメータ:
string - 検索値

setProcessCd

public void setProcessCd(String string)
検索条件とするプロセスコードを設定します。

パラメータ:
string - 検索値

setActivityCd

public void setActivityCd(String string)
アクティビティコードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - アクティビティコード

setActivityName

public void setActivityName(String string)
アクティビティ名を設定します。

パラメータ:
string - アクティビティ名

setActivityType

public void setActivityType(String string)
アクティビティ種別を設定します。 システムで利用されるメソッドです。

パラメータ:
string - アクティビティ種別

setActivityStatus

public void setActivityStatus(String string)
アクティビティステータスを設定します。

パラメータ:
string - アクティビティステータス

setStatusEndedDate

public void setStatusEndedDate(String string)
ステータス完了日付を設定します。 システムで利用されるメソッドです。

パラメータ:
string - ステータス完了日付

setCallActivityCd

public void setCallActivityCd(String string)
呼出アクティビティコードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出アクティビティコード

setCallActivityType

public void setCallActivityType(String string)
呼出アクティビティ種別を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出アクティビティ種別

setAutoPassTerm

public void setAutoPassTerm(String string)
自動パス期限を設定します。

パラメータ:
string - 自動パス期限

setAutoPassFlag

public void setAutoPassFlag(String string)
自動パス処理フラグを設定します。

パラメータ:
string - 自動パス処理フラグ

setAttainmentClass

public void setAttainmentClass(String string)
到達種別を設定します。

パラメータ:
string - 到達種別

setReceptionDate

public void setReceptionDate(String string)
受信日付をを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 受信日付

setProcessTermDate

public void setProcessTermDate(String string)
検索条件とするプロセスコードを設定します。

パラメータ:
string - 処理期限日付

setPresentProcess

public void setPresentProcess(String string)
現処理を設定します。

パラメータ:
string - 現処理

setBefActiCd

public void setBefActiCd(String string)
前処理アクティビティコードを設定します。

パラメータ:
string - 前処理アクティビティコード

setBefActiName

public void setBefActiName(String string)
前処理アクティビティ名を設定します。

パラメータ:
string - 前処理アクティビティ名

setBefActiUserCd

public void setBefActiUserCd(String string)
前処理者CDを設定します。

パラメータ:
string - 前処理者CD

setBefActiUserName

public void setBefActiUserName(String string)
前処理者名を設定します。

パラメータ:
string - 前処理者名

setCompulsionEndFlag

public void setCompulsionEndFlag(String string)
強制終了可否フラグを設定します。

パラメータ:
string - 強制終了可否フラグ

setReturnMailFlag

public void setReturnMailFlag(String string)
引戻し・差戻しメール送信フラグ設定します。

パラメータ:
string - 引戻し・差戻しメール送信フラグ
関連項目:
差し戻しメール送信あり, 差し戻しメール送信なし

setReturnFlag

public void setReturnFlag(String string)
引戻し・差戻しフラグを設定します。

パラメータ:
string - 引戻し・差戻しフラグ
関連項目:
差し戻し可, 差し戻し不可

setPreProcessDefCd

public void setPreProcessDefCd(String string)
処理契機プロセス定義コードを設定します。

パラメータ:
string - 処理契機プロセス定義コード

setPreVersionCd

public void setPreVersionCd(String string)
処理契機履歴コードを設定します。

パラメータ:
string - 処理契機履歴コード

setPreProcessCd

public void setPreProcessCd(String string)
処理契機プロセスコードを設定します。

パラメータ:
string - 処理契機プロセスコード

setPreActivityCd

public void setPreActivityCd(String string)
処理契機アクティビティコードを設定します。

パラメータ:
string - 処理契機アクティビティコード

setEndTaskFlag

public void setEndTaskFlag(String string)
終了タスクフラグを設定します。

パラメータ:
string - 終了タスクフラグ

setSelectRouteNo

public void setSelectRouteNo(String string)
選択ルート番を設定します。

パラメータ:
string - 選択ルート番

setEndTaskProgram

public void setEndTaskProgram(String string)
END時実行クラスを設定します。

パラメータ:
string - END時実行クラス

setConditionType

public void setConditionType(String string)
分岐種別を設定します。

パラメータ:
string - 分岐種別

setReturnHistoryCd

public void setReturnHistoryCd(String string)
差し戻し履歴コードを設定します。

パラメータ:
string - 差し戻し履歴コード

addRunuserlist

public void addRunuserlist(RunUserInfoModel model)
実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。

パラメータ:
model - 実行主体ユーザ情報

addReceivelist

public void addReceivelist(jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoModel model)
レシーブリスト情報に新たにレシーブ情報を追加します。

パラメータ:
model - レシーブ情報

addAutopasslist

public void addAutopasslist(jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoModel model)
自動パスリスト情報に新たに自動パス情報を追加します。

パラメータ:
model - 自動パス情報

setRunSelectFlg

public void setRunSelectFlg(String string)
実行時選択フラグを設定します。

パラメータ:
string -
関連項目:
実行時選択ON, 実行時選択OFF

addUserAppliKey

public void addUserAppliKey(int i,
                            jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

パラメータ:
i - パラメータ番号
model - ユーザアプリケーションキーテーブル情報

convertEndTaskFlag

public static String convertEndTaskFlag(String shortestEndFlg)
最短終了タスク値を最終タスクフラグに変換します。

パラメータ:
shortestEndFlg - 最終タスクフラグ値

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(String string)
ログインユーザIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ConditionModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス ConditionModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ExternalModel
        拡張 jp.co.intra_mart.foundation.bpw.model.object.ConditionModel
public class ConditionModel
extends jp.co.intra_mart.foundation.bpw.model.object.ExternalModel

外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、
ログインユーザ情報が取得できます。

コンストラクタの概要
ConditionModel()
コンストラクタ
ConditionModel(ActivityInfoModel src)
メソッドの概要
Locale | getLocale() ロケールを返却します。
String | getLoginGroupId() ログイングループＩＤを返却します。
String | getLoginUserId() ログインユーザＩＤを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
void | setLoginGroupID(String string) ログイングループIDを設定します。
void | setLoginUserID(String string) ログインユーザIDを設定します。
クラス jp.co.intra_mart.foundation.bpw.model.object.ExternalModel から継承したメソッド
getActivityCd, getActivityName, getActivityStatus, getActivityType, getAttainmentClass, getAutoPassFlag, getAutoPassTerm, getBefActiCd, getBefActiName, getBefActiUserCd, getBefActiUserName, getCallActivityCd, getCallActivityType, getPresentProcess, getProcessCd, getProcessDefCd, getProcessTermDate, getReceptionDate, getStatusEndedDate, getVersionCd, setActivityCd, setActivityName, setActivityStatus, setActivityType, setAttainmentClass, setAutoPassFlag, setAutoPassTerm, setBefActiCd, setBefActiName, setBefActiUserCd, setBefActiUserName, setCallActivityCd, setCallActivityType, setPresentProcess, setProcessCd, setProcessDefCd, setProcessTermDate, setReceptionDate, setStatusEndedDate, setVersionCd
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ConditionModel

public ConditionModel()
コンストラクタ

ConditionModel

public ConditionModel(ActivityInfoModel src)
メソッドの詳細

getLoginUserId

public String getLoginUserId()
ログインユーザＩＤを返却します。

戻り値:
ログインユーザＩＤ

getLoginGroupId

public String getLoginGroupId()
ログイングループＩＤを返却します。

戻り値:
ログイングループＩＤ

getLocale

public Locale getLocale()
ロケールを返却します。

戻り値:
ロケール

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。

戻り値:
ログインユーザ情報

setLoginUserID

public void setLoginUserID(String string)
ログインユーザIDを設定します。

パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(String string)
ログイングループIDを設定します。

パラメータ:
string - ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.bpw.model.object (bpw 6.1.14 API)

 jp.co.intra_mart.foundation.bpw.model.object
クラス
ActivityInfoModel
ConditionModel
ProcessInfoModel
RecognitionInfoModel
RunExecutiveInfoModel
RunUserInfoModel
VersionInfoModel


jp.co.intra_mart.foundation.bpw.model.object (bpw 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.object

クラスの概要
ActivityInfoModel | アクティビティ情報を保持するクラス アクティビティ情報を保持します。
ConditionModel | 外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、 ログインユーザ情報が取得できます。
ProcessInfoModel | プロセス情報を保持する情報クラス
RecognitionInfoModel | 処理要求時情報モデル。
RunExecutiveInfoModel | 実行主体役職マスタの情報保持クラス 次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunUserInfoModel | 実行主体ユーザ情報を保持する情報クラス
VersionInfoModel | 履歴情報を保持する情報クラス


jp.co.intra_mart.foundation.bpw.model.object クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.bpw.model.object の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.io.Serializable)
    • class jp.co.intra_mart.foundation.bpw.model.object.ExternalModel
      • class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel
    • class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable)
    • class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
    • class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF)


パッケージ jp.co.intra_mart.foundation.bpw.model.object の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.bpw.model.object の使用

jp.co.intra_mart.foundation.bpw.model.object を使用しているパッケージ
jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.bpw.model.data により使用される jp.co.intra_mart.foundation.bpw.model.object のクラス
ConditionModel
外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、
ログインユーザ情報が取得できます。

jp.co.intra_mart.foundation.bpw.model.object により使用される jp.co.intra_mart.foundation.bpw.model.object のクラス
ActivityInfoModel
アクティビティ情報を保持するクラス
アクティビティ情報を保持します。
ProcessInfoModel
プロセス情報を保持する情報クラス
RunExecutiveInfoModel
実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunUserInfoModel
実行主体ユーザ情報を保持する情報クラス

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.bpw.model.object のクラス
ProcessInfoModel
プロセス情報を保持する情報クラス
RunExecutiveInfoModel
実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunUserInfoModel
実行主体ユーザ情報を保持する情報クラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


ProcessInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス ProcessInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, Cloneable
public class ProcessInfoModel
extends Object
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, Cloneable

プロセス情報を保持する情報クラス

フィールドの概要
static String | TRANSFER_OFF 申請者(申請者)
static String | TRANSFER_ON 申請者(代理申請者)
コンストラクタの概要
ProcessInfoModel()
コンストラクタ
メソッドの概要
void | addUserAppliKey(int i, jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
Object | clone() クローン
String | getCallProcessCd() 呼出プロセスコードを返却します。
String | getCallProcessDefCd() 呼び出しプロセス定義コードを返却します。
String | getCallVersionCd() 呼び出し履歴コードを返却します。
String | getCodeValue() コード値を返却します。
String | getCompanyCd() 会社コードを返却します。
Object | getConvertLong(String string) 数値型変換後に返却します。
String | getCreateDate() 作成日時を返却します。
String | getCreateUserCd() 作成者コードを返却します。
String | getCreateUserName() 作成者名を返却します。
String | getDraftComment() 起票時コメントを返却します。
String | getDraftDate() 起票日を返却します。
String | getDraftUserCd() 起票者コードを返却します。
String | getDraftUserName() 起票者名を返却します。
String | getExtensionA() 拡張エリアＡを返却します。
String | getExtensionB() 拡張エリアＢを返却します。
String | getExtensionC() 拡張エリアＣを返却します。
String | getExtensionD() 拡張エリアＤを返却します。
String | getExtensionE() 拡張エリアＥを返却します。
String | getExtensionF() 拡張エリアＦを返却します。
String | getExtensionG() 拡張エリアＧを返却します。
String | getExtensionH() 拡張エリアＨを返却します。
String | getGroupName() グループ名を返却します。
String | getLastManualActivityCd() 最終手動処理コードを返却します。
String | getLastManualActivityResult() 最終手動アクティビティ承認結果種別を返却します。
String | getLocaleId() 処理者ロケールIDを返却します。
String | getLoginGroupID() ログイングループIDを返却します。
String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
String | getParallelNestCnt() 同期処理階層カウンタを返却します。
String | getPresentDisplayInfo() 現処理表示情報を返却します。
String | getProcessCallActivityCd() 呼出処理コードを返却します。
String | getProcessCd() プロセスコードを返却します。
String | getProcessDefCd() プロセス定義コードを返却します。
String | getProcessEndStatus() 完了プロセスステータスを返却します。
String | getProcessingStatus() 処理状態識別を返却します。
String | getProcessName() プロセス名を返却します。
String | getProcessNestCnt() サブプロセス呼出カウンタを返却します。
String | getProcessStatus() プロセスステータスを返却します。
String | getRecordDate() 最終更新日時を返却します。
String | getRecordUserCd() 最終更新者コードを返却します。
String | getRecordUserName() 最終更新者名を返却します。
String | getRequiredTerm() 所要日数を返却します。
jp.co.intra_mart.system.bpw.SyncronizedInfo | getSyncronizedInfo() 同期情報を返却します。
String | getTargetMasterDate() 対象マスタ日付を返却します。
String | getTransactorCd() 処理者コードを返却します。
String | getTransactorName() 処理者名を返却します。
String | getTransferFlg() 代理フラグを返却します。
Map | getUserApplikeyList() ユーザアプリケーションキーテーブル情報リストを返却します。
String | getVersionCd() 履歴コードを返却します。
void | setCallProcessCd(String string) 呼出案件コードを設定します。
void | setCallProcessDefCd(String string) 呼び出しプロセス定義コードを設定します。
void | setCallVersionCd(String string) 呼び出し履歴コードを設定します。
void | setCodeValue(String string) コード値を設定します。
void | setCompanyCd(String string) 会社コードを設定します。
void | setCreateDate(String string) 作成日時を設定します。
void | setCreateUserCd(String string) 作成者コードを設定します。
void | setCreateUserName(String string) 作成者名を設定します。
void | setDraftComment(String string) 起票時コメントを設定します。
void | setDraftDate(String string) 起票日を設定します。
void | setDraftUserCd(String string) 起票者コードを設定します。
void | setDraftUserName(String string) 起票者名を設定します。
void | setExtensionA(String string) 拡張エリアＡを設定します。
void | setExtensionB(String string) 拡張エリアＢを設定します。
void | setExtensionC(String string) 拡張エリアＣを設定します。
void | setExtensionD(String string) 拡張エリアＤを設定します。
void | setExtensionE(String string) 拡張エリアＥを設定します。
void | setExtensionF(String string) 拡張エリアＦを設定します。
void | setExtensionG(String string) 拡張エリアＧを設定します。
void | setExtensionH(String string) 拡張エリアＨを設定します。
void | setGroupName(String string) グループ名を設定します。
void | setLastManualActivityCd(String string) 最終手動処理コードを設定します。
void | setLastManualActivityResult(String string) 最終手動処理コードを設定します。
void | setLocaleId(String string) 処理者ロケールIDを設定します。
void | setLoginGroupID(String string) ログイングループIDを設定します。
void | setLoginUserID(String string) ログインユーザIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setParallelNestCnt(String string) 同期処理階層カウンタを設定します。
void | setPresentDisplayInfo(String string) 現処理表示情報を設定します。
void | setProcessCallActivityCd(String string) 呼出処理コードを設定します。
void | setProcessCd(String string) 検索条件とするプロセスコードを設定します。
void | setProcessDefCd(String string) 検索条件とするプロセス定義コードを設定します。
void | setProcessEndStatus(String string) 完了プロセスステータスを設定します。
void | setProcessingStatus(String string) 処理状態識別を設定します。
void | setProcessName(String string) プロセス名を設定します。
void | setProcessNestCnt(String string) サブプロセス呼出カウンタを設定します。
void | setProcessStatus(String string) プロセスステータスを設定します。
void | setRecordDate(String string) 最終更新日時を設定します。
void | setRecordUserCd(String string) 最終更新者コードを設定します。
void | setRecordUserName(String string) 最終更新者名を設定します。
void | setRequiredTerm(String string) 所要日数を設定します。
void | setSyncronizedInfo(jp.co.intra_mart.system.bpw.SyncronizedInfo info) 同期情報を設定します。
void | setTargetMasterDate(String string) 対象マスタ日付を設定します。
void | setTransactorCd(String string) 処理者コードを設定します。
void | setTransactorName(String string) 処理者名を設定します。
void | setTransferFlg(String string) 代理フラグを設定します。
void | setUserApplikeyList(Map ketList) ユーザアプリケーションキーテーブル情報リストを設定します。
void | setVersionCd(String string) 検索条件とする履歴コードを設定します。
クラス java.lang.Object から継承したメソッド
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TRANSFER_OFF

public static final String TRANSFER_OFF
申請者(申請者)

関連項目:
定数フィールド値

TRANSFER_ON

public static final String TRANSFER_ON
申請者(代理申請者)

関連項目:
定数フィールド値
コンストラクタの詳細

ProcessInfoModel

public ProcessInfoModel()
コンストラクタ

メソッドの詳細

clone

public Object clone()
             throws CloneNotSupportedException
クローン

例外:
CloneNotSupportedException

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義コード

getVersionCd

public String getVersionCd()
履歴コードを返却します。 システムで利用されるメソッドです。

戻り値:
履歴コード

getProcessCd

public String getProcessCd()
プロセスコードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセスコード

getProcessName

public String getProcessName()
プロセス名を返却します。 システムで利用されるメソッドです。

戻り値:
プロセス名

getDraftDate

public String getDraftDate()
起票日を返却します。 システムで利用されるメソッドです。

戻り値:
起票日

getDraftUserCd

public String getDraftUserCd()
起票者コードを返却します。 システムで利用されるメソッドです。

戻り値:
起票者コード

getDraftUserName

public String getDraftUserName()
起票者名を返却します。 システムで利用されるメソッドです。

戻り値:
起票者名

getDraftComment

public String getDraftComment()
起票時コメントを返却します。 システムで利用されるメソッドです。

戻り値:
起票時コメント

getCompanyCd

public String getCompanyCd()
会社コードを返却します。 システムで利用されるメソッドです。

戻り値:
会社コード

getCodeValue

public String getCodeValue()
コード値を返却します。 システムで利用されるメソッドです。

戻り値:
コード値

getGroupName

public String getGroupName()
グループ名を返却します。 システムで利用されるメソッドです。

戻り値:
グループ名

getTargetMasterDate

public String getTargetMasterDate()
対象マスタ日付を返却します。 システムで利用されるメソッドです。

戻り値:
対象マスタ日付

getTransactorCd

public String getTransactorCd()
処理者コードを返却します。 システムで利用されるメソッドです。

戻り値:
処理者コード

getTransactorName

public String getTransactorName()
処理者名を返却します。 システムで利用されるメソッドです。

戻り値:
処理者名

getLocaleId

public String getLocaleId()
処理者ロケールIDを返却します。 システムで利用されるメソッドです。

戻り値:
処理者ロケールID

getProcessStatus

public String getProcessStatus()
プロセスステータスを返却します。 システムで利用されるメソッドです。

戻り値:
プロセスステータス

getProcessEndStatus

public String getProcessEndStatus()
完了プロセスステータスを返却します。 システムで利用されるメソッドです。

戻り値:
完了プロセスステータス

getRequiredTerm

public String getRequiredTerm()
所要日数を返却します。 システムで利用されるメソッドです。

戻り値:
所要日数

getLastManualActivityCd

public String getLastManualActivityCd()
最終手動処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
最終手動処理コード

getLastManualActivityResult

public String getLastManualActivityResult()
最終手動アクティビティ承認結果種別を返却します。 システムで利用されるメソッドです。

戻り値:
最終手動アクティビティ承認結果種別

getCallProcessDefCd

public String getCallProcessDefCd()
呼び出しプロセス定義コードを返却します。

戻り値:
呼び出しプロセス定義コード

getCallVersionCd

public String getCallVersionCd()
呼び出し履歴コードを返却します。

戻り値:
呼び出し履歴コード

getCallProcessCd

public String getCallProcessCd()
呼出プロセスコードを返却します。 システムで利用されるメソッドです。

戻り値:
呼出プロセスコード

getProcessCallActivityCd

public String getProcessCallActivityCd()
呼出処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
呼出処理コード

getProcessingStatus

public String getProcessingStatus()
処理状態識別を返却します。 システムで利用されるメソッドです。

戻り値:
処理状態識別

getProcessNestCnt

public String getProcessNestCnt()
サブプロセス呼出カウンタを返却します。 システムで利用されるメソッドです。

戻り値:
サブプロセス呼出カウンタ

getParallelNestCnt

public String getParallelNestCnt()
同期処理階層カウンタを返却します。 システムで利用されるメソッドです。

戻り値:
同期処理階層カウンタ

getPresentDisplayInfo

public String getPresentDisplayInfo()
現処理表示情報を返却します。 システムで利用されるメソッドです。

戻り値:
現処理表示情報

getExtensionA

public String getExtensionA()
拡張エリアＡを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＡ

getExtensionB

public String getExtensionB()
拡張エリアＢを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＢ

getExtensionC

public String getExtensionC()
拡張エリアＣを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＣ

getExtensionD

public String getExtensionD()
拡張エリアＤを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＤ

getExtensionE

public String getExtensionE()
拡張エリアＥを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＥ

getExtensionF

public String getExtensionF()
拡張エリアＦを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＦ

getExtensionG

public String getExtensionG()
拡張エリアＧを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＧ

getExtensionH

public String getExtensionH()
拡張エリアＨを返却します。 システムで利用されるメソッドです。

戻り値:
拡張エリアＨ

getConvertLong

public Object getConvertLong(String string)
数値型変換後に返却します。 システムで利用されるメソッドです。

パラメータ:
string - 文字列
戻り値:
Long

getCreateDate

public String getCreateDate()
作成日時を返却します。 システムで利用されるメソッドです。

戻り値:
作成日時

getCreateUserCd

public String getCreateUserCd()
作成者コードを返却します。 システムで利用されるメソッドです。

戻り値:
作成者コード

getCreateUserName

public String getCreateUserName()
作成者名を返却します。 システムで利用されるメソッドです。

戻り値:
作成者名

getRecordDate

public String getRecordDate()
最終更新日時を返却します。 システムで利用されるメソッドです。

戻り値:
最終更新日時

getRecordUserCd

public String getRecordUserCd()
最終更新者コードを返却します。 システムで利用されるメソッドです。

戻り値:
最終更新者コード

getRecordUserName

public String getRecordUserName()
最終更新者名を返却します。 システムで利用されるメソッドです。

戻り値:
最終更新者名

getUserApplikeyList

public Map getUserApplikeyList()
ユーザアプリケーションキーテーブル情報リストを返却します。

戻り値:
ユーザアプリケーションキーテーブル情報リスト

getTransferFlg

public String getTransferFlg()
代理フラグを返却します。

戻り値:
代理フラグ

getSyncronizedInfo

public jp.co.intra_mart.system.bpw.SyncronizedInfo getSyncronizedInfo()
同期情報を返却します。

戻り値:
同期情報

setProcessDefCd

public void setProcessDefCd(String string)
検索条件とするプロセス定義コードを設定します。

パラメータ:
string - 検索値

setVersionCd

public void setVersionCd(String string)
検索条件とする履歴コードを設定します。

パラメータ:
string - 検索値

setProcessCd

public void setProcessCd(String string)
検索条件とするプロセスコードを設定します。

パラメータ:
string - 検索値

setProcessName

public void setProcessName(String string)
プロセス名を設定します。

パラメータ:
string - プロセス名

setDraftDate

public void setDraftDate(String string)
起票日を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 起票日

setDraftUserCd

public void setDraftUserCd(String string)
起票者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 起票者コード

setDraftUserName

public void setDraftUserName(String string)
起票者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 起票者名

setDraftComment

public void setDraftComment(String string)
起票時コメントを設定します。

パラメータ:
string - 起票時コメント

setCompanyCd

public void setCompanyCd(String string)
会社コードを設定します。

パラメータ:
string - 会社コード

setCodeValue

public void setCodeValue(String string)
コード値を設定します。

パラメータ:
string - コード値

setGroupName

public void setGroupName(String string)
グループ名を設定します。

パラメータ:
string - グループ名

setTargetMasterDate

public void setTargetMasterDate(String string)
対象マスタ日付を設定します。

パラメータ:
string - 対象マスタ日付

setTransactorCd

public void setTransactorCd(String string)
処理者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理者コード

setTransactorName

public void setTransactorName(String string)
処理者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理者名

setLocaleId

public void setLocaleId(String string)
処理者ロケールIDを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理者ロケールID

setProcessStatus

public void setProcessStatus(String string)
プロセスステータスを設定します。 システムで利用されるメソッドです。

パラメータ:
string - プロセスステータス

setProcessEndStatus

public void setProcessEndStatus(String string)
完了プロセスステータスを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 完了プロセスステータス

setRequiredTerm

public void setRequiredTerm(String string)
所要日数を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 所要日数

setLastManualActivityCd

public void setLastManualActivityCd(String string)
最終手動処理コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終手動処理コード

setLastManualActivityResult

public void setLastManualActivityResult(String string)
最終手動処理コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終手動処理コード

setCallProcessDefCd

public void setCallProcessDefCd(String string)
呼び出しプロセス定義コードを設定します。

パラメータ:
string - 呼び出しプロセス定義コード

setCallVersionCd

public void setCallVersionCd(String string)
呼び出し履歴コードを設定します。

パラメータ:
string - 呼び出し履歴コード

setCallProcessCd

public void setCallProcessCd(String string)
呼出案件コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出案件コード

setProcessCallActivityCd

public void setProcessCallActivityCd(String string)
呼出処理コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 呼出処理コード

setProcessingStatus

public void setProcessingStatus(String string)
処理状態識別を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 処理状態識別

setProcessNestCnt

public void setProcessNestCnt(String string)
サブプロセス呼出カウンタを設定します。 システムで利用されるメソッドです。

パラメータ:
string - サブプロセス呼出カウンタ

setParallelNestCnt

public void setParallelNestCnt(String string)
同期処理階層カウンタを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 同期処理階層カウンタ

setPresentDisplayInfo

public void setPresentDisplayInfo(String string)
現処理表示情報を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 現処理表示情報

setExtensionA

public void setExtensionA(String string)
拡張エリアＡを設定します。

パラメータ:
string - 拡張エリアＡ

setExtensionB

public void setExtensionB(String string)
拡張エリアＢを設定します。

パラメータ:
string - 拡張エリアＢ

setExtensionC

public void setExtensionC(String string)
拡張エリアＣを設定します。

パラメータ:
string - 拡張エリアＣ

setExtensionD

public void setExtensionD(String string)
拡張エリアＤを設定します。

パラメータ:
string - 拡張エリアＤ

setExtensionE

public void setExtensionE(String string)
拡張エリアＥを設定します。

パラメータ:
string - 拡張エリアＥ

setExtensionF

public void setExtensionF(String string)
拡張エリアＦを設定します。

パラメータ:
string - 拡張エリアＦ

setExtensionG

public void setExtensionG(String string)
拡張エリアＧを設定します。

パラメータ:
string - 拡張エリアＧ

setExtensionH

public void setExtensionH(String string)
拡張エリアＨを設定します。

パラメータ:
string - 拡張エリアＨ

setCreateDate

public void setCreateDate(String string)
作成日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成日時

setCreateUserCd

public void setCreateUserCd(String string)
作成者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者コード

setCreateUserName

public void setCreateUserName(String string)
作成者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者名

setRecordDate

public void setRecordDate(String string)
最終更新日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新日時

setRecordUserCd

public void setRecordUserCd(String string)
最終更新者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者コード

setRecordUserName

public void setRecordUserName(String string)
最終更新者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者名

setUserApplikeyList

public void setUserApplikeyList(Map ketList)
ユーザアプリケーションキーテーブル情報リストを設定します。

パラメータ:
ketList - ユーザアプリケーションキーテーブル情報リスト

addUserAppliKey

public void addUserAppliKey(int i,
                            jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。

パラメータ:
i - パラメータ番号
model - ユーザアプリケーションキーテーブル情報

setTransferFlg

public void setTransferFlg(String string)
代理フラグを設定します。 申請時に申請するユーザ区分を設定します。初期値は正規の申請者に設定されているので、 代理申請を要求する際にTRANSFER_ONを設定してください。

パラメータ:
string - 代理フラグ

setSyncronizedInfo

public void setSyncronizedInfo(jp.co.intra_mart.system.bpw.SyncronizedInfo info)
同期情報を設定します。 システムで利用されるメソッドです。

パラメータ:
info - 同期情報

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(String string)
ログインユーザIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RecognitionInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス RecognitionInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
public class RecognitionInfoModel
extends Object

処理要求時情報モデル。
アクティブなアクティビティに対して、承認処理要求を行う際に指定する情報クラスです。 処理要求として、
  申請：申請はプロセスの登録要求で実装してください。
  再申請：差戻し等で再申請が必要な場合に指定してください。再申請されます。
  承認：現在のアクティビティは完了され、次のアクティビティが処理されます。
  棄却：現在のアクティビティでプロセスが終了します。
が指定可能です。承認種別にこのクラスに定義されたフィールド値を設定して下さい。
指定必須項目[プロセス定義コード・履歴コード・プロセスコード・ アクティビティコード・承認種別・承認者コード]

フィールドの概要
static String | APPLY 承認種別：申請
static String | CANCEL 承認種別：取り止め
static String | DELEGATE_TASK 承認種別：振り替え
static String | MAGICAL_HAND 承認種別：強制操作
static String | RECOGNITION 承認種別：承認
static String | REJECTION 承認種別：棄却
static String | RETRY 承認種別：再申請
static String | RETURN_BEFORE 承認種別：承認者へ差し戻す
static String | RETURN_PULL 承認種別：引き戻し
static String | RETURN_START 承認種別：申請者へ差し戻す
static String | RETURN_TASK 承認種別：任意の処理者へ差し戻す
static String | ROLL_SELECT_OFF ロール絞込み指定ON
static String | ROLL_SELECT_ON ロール絞込み指定OFF
static String | SUSPENSION 承認種別：保留
static String | TARGET_AUTOPASS 承認種別：対象者自動パス
コンストラクタの概要
RecognitionInfoModel()
コンストラクタ
RecognitionInfoModel(ActivityInfoModel src)
RecognitionInfoModel(ProcessInfoModel src)
メソッドの概要
void | addUserAppliKey(int i, jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model) 指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
String | getActivityCd() アクティビティコードを返却します。
String | getActivityName() アクティビティ名を返却します。
String | getAgentUserCd() 代理元ユーザCDを返却します。
String | getApprovalType() 承認種別を返却します。
String | getApprovalUserCd() 承認者コードを返却します。
String | getApprovalUserName() 承認者名を返却します。
jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel | getAttachPosition() 所属立場を返却します。
String | getDraftCd() 起票アクティビティコードを取得します。
String | getPreApprovalType() 前承認種別を返却します。
String | getProcessCd() プロセスコードを返却します。
String | getProcessDefCd() プロセス定義コードを返却します。
String | getProcessName() プロセス名(サブプロセス申請用)を返却します。
String | getReceiveComment() 承認時コメントを返却します。
String | getRollSelectFlg() ロール絞込み指定フラグを返却します。
jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel | getRouteInfoModel() 申請者/承認者ルート作成-ルート情報を取得します。
RunExecutiveInfoModel | getRunExecuteInfoModel() 実行主体ユーザマスタ情報を返却します。
RunUserInfoModel | getRunUserInfoModel() 実行主体役職マスタ情報を返却します。
String | getSelectRouteNo() 選択ルート番号を返却します。
String | getTargetMasterDate() 対象指定日を返却します。
String | getTransferFlg() 代理フラグを返却します。
jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel | getTransferInfoModel() 処理委譲情報を取得します。
Map | getUserAppliKeyList() ユーザアプリケーションキーテーブル情報リストを返却します。
String | getVersionCd() 履歴コードを返却します。
String | getVersionName() プロセス定義（履歴名）を取得します。
boolean | isAutoPassFlag() 自動パスフラグを返却します。
void | setActivityCd(String string) アクティビティコードを設定します。
void | setActivityName(String string) アクティビティ名を設定します。
void | setAgentUserCd(String string) 代理元ユーザCDを設定します。
void | setApprovalType(String string) 承認種別を設定します。
void | setApprovalUserCd(String string) 承認者コードを設定します。
void | setApprovalUserName(String string) 承認者名を設定します。
void | setAttachPosition(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model) 所属立場を設定します。
void | setAutoPassFlag(boolean value) 自動パスフラグを設定します。
void | setDraftCd(String string) * 起票アクティビティコードを設定します。
void | setPreApprovalType(String string) 前承認種別を設定します。
void | setProcessCd(String string) プロセスコードを設定します。
void | setProcessDefCd(String string) プロセス定義コードを設定します。
void | setProcessName(String string) プロセス名(サブプロセス申請用)を設定します。
void | setReceiveComment(String string) 承認時コメントを設定します。
void | setRollSelectFlg(String string) ロール絞込み指定フラグを設定します。
void | setRouteInfoModel(jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel model) 申請者/承認者ルート作成-ルート情報設定します。
void | setRunExecuteInfoModel(RunExecutiveInfoModel model) 実行時選択時実行主体役職マスタテーブルを設定します。
void | setRunUserInfoModel(RunUserInfoModel model) 実行時選択時実行主体ユーザマスタ情報を設定します。
void | setSelectRouteNo(String string) 選択ルート番号を設定します。
void | setTargetMasterDate(String string) 対象指定日を設定します。
void | setTransferFlg(String string) 代理フラグを設定します。
void | setTransferInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel model) 処理委譲情報を設定します。
void | setVersionCd(String string) 履歴コードを設定します。
void | setVersionName(String string) プロセス定義（履歴名）を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

APPLY

public static final String APPLY
承認種別：申請

関連項目:
定数フィールド値

RETRY

public static final String RETRY
承認種別：再申請

関連項目:
定数フィールド値

RECOGNITION

public static final String RECOGNITION
承認種別：承認

関連項目:
定数フィールド値

REJECTION

public static final String REJECTION
承認種別：棄却

関連項目:
定数フィールド値

RETURN_START

public static final String RETURN_START
承認種別：申請者へ差し戻す

関連項目:
定数フィールド値

RETURN_BEFORE

public static final String RETURN_BEFORE
承認種別：承認者へ差し戻す

関連項目:
定数フィールド値

RETURN_PULL

public static final String RETURN_PULL
承認種別：引き戻し

関連項目:
定数フィールド値

SUSPENSION

public static final String SUSPENSION
承認種別：保留

関連項目:
定数フィールド値

CANCEL

public static final String CANCEL
承認種別：取り止め

関連項目:
定数フィールド値

TARGET_AUTOPASS

public static final String TARGET_AUTOPASS
承認種別：対象者自動パス

関連項目:
定数フィールド値

DELEGATE_TASK

public static final String DELEGATE_TASK
承認種別：振り替え

関連項目:
定数フィールド値

RETURN_TASK

public static final String RETURN_TASK
承認種別：任意の処理者へ差し戻す

関連項目:
定数フィールド値

MAGICAL_HAND

public static final String MAGICAL_HAND
承認種別：強制操作

関連項目:
定数フィールド値

ROLL_SELECT_ON

public static final String ROLL_SELECT_ON
ロール絞込み指定OFF

関連項目:
定数フィールド値

ROLL_SELECT_OFF

public static final String ROLL_SELECT_OFF
ロール絞込み指定ON

関連項目:
定数フィールド値
コンストラクタの詳細

RecognitionInfoModel

public RecognitionInfoModel()
コンストラクタ

RecognitionInfoModel

public RecognitionInfoModel(ProcessInfoModel src)

RecognitionInfoModel

public RecognitionInfoModel(ActivityInfoModel src)
メソッドの詳細

getReceiveComment

public String getReceiveComment()
承認時コメントを返却します。

戻り値:
承認時コメント

getApprovalUserCd

public String getApprovalUserCd()
承認者コードを返却します。

戻り値:
承認者コード

getApprovalUserName

public String getApprovalUserName()
承認者名を返却します。

戻り値:
承認者名

getApprovalType

public String getApprovalType()
承認種別を返却します。

戻り値:
承認種別
関連項目:
申請, 再申請, 承認, 棄却

getActivityCd

public String getActivityCd()
アクティビティコードを返却します。

戻り値:
アクティビティコード

getActivityName

public String getActivityName()
アクティビティ名を返却します。

戻り値:
アクティビティ名

getProcessCd

public String getProcessCd()
プロセスコードを返却します。

戻り値:
プロセスコード

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを返却します。

戻り値:
プロセス定義コード

getVersionCd

public String getVersionCd()
履歴コードを返却します。

戻り値:
履歴コード

getRollSelectFlg

public String getRollSelectFlg()
ロール絞込み指定フラグを返却します。

戻り値:
ロール絞込み指定フラグ

getRunExecuteInfoModel

public RunExecutiveInfoModel getRunExecuteInfoModel()
実行主体ユーザマスタ情報を返却します。

戻り値:
実行主体ユーザマスタ情報

getRunUserInfoModel

public RunUserInfoModel getRunUserInfoModel()
実行主体役職マスタ情報を返却します。

戻り値:
実行主体役職マスタ情報

getUserAppliKeyList

public Map getUserAppliKeyList()
ユーザアプリケーションキーテーブル情報リストを返却します。

戻り値:
ユーザアプリケーションキーテーブル情報リスト

getTransferFlg

public String getTransferFlg()
代理フラグを返却します。

戻り値:
代理フラグ

isAutoPassFlag

public boolean isAutoPassFlag()
自動パスフラグを返却します。

戻り値:
自動パスフラグ

getVersionName

public String getVersionName()
プロセス定義（履歴名）を取得します。

戻り値:
versionName

getDraftCd

public String getDraftCd()
起票アクティビティコードを取得します。

戻り値:
RootInfoModel

getRouteInfoModel

public jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel getRouteInfoModel()
申請者/承認者ルート作成-ルート情報を取得します。

戻り値:
RootInfoModel

getTransferInfoModel

public jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel getTransferInfoModel()
処理委譲情報を取得します。

戻り値:
RootInfoModel

getSelectRouteNo

public String getSelectRouteNo()
選択ルート番号を返却します。

戻り値:
選択ルート番号

getAttachPosition

public jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel getAttachPosition()
所属立場を返却します。

戻り値:
所属立場

getTargetMasterDate

public String getTargetMasterDate()
対象指定日を返却します。

戻り値:
対象指定日

getAgentUserCd

public String getAgentUserCd()
代理元ユーザCDを返却します。

戻り値:
代理元ユーザCD

getProcessName

public String getProcessName()
プロセス名(サブプロセス申請用)を返却します。

戻り値:
プロセス名(サブプロセス申請用)

getPreApprovalType

public String getPreApprovalType()
前承認種別を返却します。

戻り値:
前承認種別

setReceiveComment

public void setReceiveComment(String string)
承認時コメントを設定します。

パラメータ:
string - 承認時コメント

setApprovalUserCd

public void setApprovalUserCd(String string)
承認者コードを設定します。 代理による再申請、代理による承認の場合は実際に処理したユーザの ユーザコードを設定して下さい。

パラメータ:
string - 承認者コード

setApprovalUserName

public void setApprovalUserName(String string)
承認者名を設定します。 ＢＰＷ内部で設定されます。 通常は設定しないで下さい。

パラメータ:
string - 承認者名

setApprovalType

public void setApprovalType(String string)
承認種別を設定します。

パラメータ:
string - 承認種別
関連項目:
申請, 再申請, 承認, 棄却

setActivityCd

public void setActivityCd(String string)
アクティビティコードを設定します。

パラメータ:
string - アクティビティコード

setActivityName

public void setActivityName(String string)
アクティビティ名を設定します。

パラメータ:
string - アクティビティ名

setProcessCd

public void setProcessCd(String string)
プロセスコードを設定します。

パラメータ:
string - プロセスコード

setProcessDefCd

public void setProcessDefCd(String string)
プロセス定義コードを設定します。

パラメータ:
string - プロセス定義コード

setVersionCd

public void setVersionCd(String string)
履歴コードを設定します。

パラメータ:
string - 履歴コード

setRollSelectFlg

public void setRollSelectFlg(String string)
ロール絞込み指定フラグを設定します。

パラメータ:
string - ロール絞込み指定フラグ

setRunExecuteInfoModel

public void setRunExecuteInfoModel(RunExecutiveInfoModel model)
実行時選択時実行主体役職マスタテーブルを設定します。 実行時選択時に、登録する実行主体役職情報を設定してください。

パラメータ:
model - 実行主体役職マスタテーブル

setRunUserInfoModel

public void setRunUserInfoModel(RunUserInfoModel model)
実行時選択時実行主体ユーザマスタ情報を設定します。 実行時選択時に、登録する実行主体ユーザ情報を設定してください。

パラメータ:
model - 実行主体ユーザマスタ情報

addUserAppliKey

public void addUserAppliKey(int i,
                            jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel model)
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。 指定されたパラメータ番号でユーザアプリケーションキーテーブル情報リストにマップします。

パラメータ:
i - パラメータ番号
model - ユーザアプリケーションキーテーブル情報

setTransferFlg

public void setTransferFlg(String string)
代理フラグを設定します。

パラメータ:
string - 代理フラグ

setAutoPassFlag

public void setAutoPassFlag(boolean value)
自動パスフラグを設定します。

パラメータ:
value - 自動パスフラグ

setVersionName

public void setVersionName(String string)
プロセス定義（履歴名）を設定します。

パラメータ:
string - プロセス定義（履歴名）

setDraftCd

public void setDraftCd(String string)
* 起票アクティビティコードを設定します。

パラメータ:
string - 起票アクティビティコード

setSelectRouteNo

public void setSelectRouteNo(String string)
選択ルート番号を設定します。

パラメータ:
string - 選択ルート番号

setTransferInfoModel

public void setTransferInfoModel(jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel model)
処理委譲情報を設定します。

パラメータ:
model - 処理委譲情報

setRouteInfoModel

public void setRouteInfoModel(jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel model)
申請者/承認者ルート作成-ルート情報設定します。

パラメータ:
model -

setAttachPosition

public void setAttachPosition(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model)
所属立場を設定します。

パラメータ:
model - 所属立場

setTargetMasterDate

public void setTargetMasterDate(String string)
対象指定日を設定します。

パラメータ:
string - 対象指定日

setAgentUserCd

public void setAgentUserCd(String string)
代理元ユーザCDを設定します。

パラメータ:
string - 代理元ユーザCD

setProcessName

public void setProcessName(String string)
プロセス名(サブプロセス申請用)を設定します。

パラメータ:
string - プロセス名(サブプロセス申請用)

setPreApprovalType

public void setPreApprovalType(String string)
前承認種別を設定します。

パラメータ:
string - 前承認種別
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RunExecutiveInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス RunExecutiveInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
        拡張 jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel
すべての実装インタフェース:
Serializable
public class RunExecutiveInfoModel
extends jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
implements Serializable

実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。 実行時選択には【ユーザ】、【組織】のみが指定できます。 【パブリックグループ】また、【ロール】、【役職】の絞込み指定はできません。

関連項目:
直列化された形式

フィールドの概要
static String | CD_KIND_OFFICIAL 指定されたコードがパブリックグループ
static String | CD_KIND_ORG 指定されたコードが組織コード
static String | CD_KIND_ROLE 指定されたコードがロール
static String | CD_KIND_USER 指定されたコードがユーザコード
static String | NO_PAIR ペアNOがペアではない
static String | NON_BILONGING 無所属時のダミーコード
static String | OLD_DATA 旧データ （旧データ：ペアＮＯのデフォルト値）
static String | POST_TYPE_POSITION 指定されたコードが役職コード （絞込み）
static String | POST_TYPE_ROLE 指定されたコードがロール （絞込み）
コンストラクタの概要
RunExecutiveInfoModel()
RunExecutiveInfoModel(ActivityInfoModel src)
RunExecutiveInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)
RunExecutiveInfoModel(RunExecutiveInfoModel src)
メソッドの概要
String | getCompanyCd() 会社コードを返却します。
String | getPairNo() ペアNOを返却します。
String | getPostCd() 役職コードを返却します。
String | getPostCdKind() 役職コード種別を返却します。
void | inputCheck(Connection connection, String targetDate, jp.co.intra_mart.framework.base.util.UserInfo userInfo) 実行主体役職マスタ入力情報をチェックするメソッドです。
void | setCompanyCd(String string) 会社コードを設定します。
void | setPairNo(String string) ペアNOを設定します。
void | setPostCd(String string) 役職コードを設定します。
void | setPostCdKind(String string) 役職コード種別を設定します。
クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey から継承したメソッド
getActivityCd, getProcessDefCd, getVersionCd, setActivityCd, setProcessDefCd, setVersionCd
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CD_KIND_USER

public static final String CD_KIND_USER
指定されたコードがユーザコード

関連項目:
定数フィールド値

CD_KIND_ORG

public static final String CD_KIND_ORG
指定されたコードが組織コード

関連項目:
定数フィールド値

CD_KIND_OFFICIAL

public static final String CD_KIND_OFFICIAL
指定されたコードがパブリックグループ

関連項目:
定数フィールド値

CD_KIND_ROLE

public static final String CD_KIND_ROLE
指定されたコードがロール

関連項目:
定数フィールド値

POST_TYPE_ROLE

public static final String POST_TYPE_ROLE
指定されたコードがロール （絞込み）

関連項目:
定数フィールド値

POST_TYPE_POSITION

public static final String POST_TYPE_POSITION
指定されたコードが役職コード （絞込み）

関連項目:
定数フィールド値

NON_BILONGING

public static final String NON_BILONGING
無所属時のダミーコード

関連項目:
定数フィールド値

NO_PAIR

public static final String NO_PAIR
ペアNOがペアではない

関連項目:
定数フィールド値

OLD_DATA

public static final String OLD_DATA
旧データ （旧データ：ペアＮＯのデフォルト値）

関連項目:
定数フィールド値
コンストラクタの詳細

RunExecutiveInfoModel

public RunExecutiveInfoModel()

RunExecutiveInfoModel

public RunExecutiveInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)

RunExecutiveInfoModel

public RunExecutiveInfoModel(ActivityInfoModel src)

RunExecutiveInfoModel

public RunExecutiveInfoModel(RunExecutiveInfoModel src)
メソッドの詳細

getPostCd

public String getPostCd()
役職コードを返却します。

戻り値:
役職コード

getPostCdKind

public String getPostCdKind()
役職コード種別を返却します。

戻り値:
役職コード種別

setPostCd

public void setPostCd(String string)
役職コードを設定します。

パラメータ:
string - 役職コード

setPostCdKind

public void setPostCdKind(String string)
役職コード種別を設定します。

パラメータ:
string - 役職コード種別

getPairNo

public String getPairNo()
ペアNOを返却します。

戻り値:
ペアNO

setPairNo

public void setPairNo(String string)
ペアNOを設定します。

パラメータ:
string - ペアNO

getCompanyCd

public String getCompanyCd()
会社コードを返却します。

戻り値:
会社コード

setCompanyCd

public void setCompanyCd(String string)
会社コードを設定します。

パラメータ:
string - 会社コード

inputCheck

public void inputCheck(Connection connection,
                       String targetDate,
                       jp.co.intra_mart.framework.base.util.UserInfo userInfo)
                throws jp.co.intra_mart.framework.system.exception.SystemException,
                       jp.co.intra_mart.framework.system.exception.ApplicationException
実行主体役職マスタ入力情報をチェックするメソッドです。

パラメータ:
connection - Connection
targetDate - 対象日付
userInfo - ユーザ情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


RunUserInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス RunUserInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
        拡張 jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, Serializable
public class RunUserInfoModel
extends jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, Serializable

実行主体ユーザ情報を保持する情報クラス

関連項目:
直列化された形式

フィールドの概要
static String | ARBITRARY_CHANGE_FLAG_OFF 任意指定フラグ：任意指定なし
static String | ARBITRARY_CHANGE_FLAG_ON 任意指定フラグ：任意指定あり
static String | RIGHT_DELEGATE 承認可否種別：振替・本人決済可（振替(02)の承認種別CDでのみ有効）
static String | RIGHT_INIT 承認可否種別：初期値（全ての承認種別CDで有効）
static String | RIGHT_NOT_DELEGATE 承認可否種別：振替・本人決済不可（振替(02)の承認種別CDでのみ有効）
static String | RIGHT_NOT_PERSON 承認可否種別：代理・本人決済不可（本人(00)の承認種別CDでのみ有効）
static String | RIGHT_PERSON 承認可否種別：代理・本人決済可（本人(00)の承認種別CDでのみ有効）
static String | STATUS_COMPLETE 承認ステータス：処理済（全ての承認種別CDで有効）
static String | STATUS_DELEGATE_COMPLETE 承認ステータス：振替処理済（本人(00), 振替(02)の承認種別CDでのみ有効）
static String | STATUS_INIT 承認ステータス：初期値（全ての承認種別CDで有効）
static String | STATUS_SAID_COMPLETE 承認ステータス：代理処理済（本人(00)の承認種別CDでのみ有効）
static String | TYPE_DELEGATE 承認対象種別コード：振替
static String | TYPE_PERSON 承認対象種別コード：本人
static String | TYPE_SAID_PERSON 承認対象種別コード：代理
コンストラクタの概要
RunUserInfoModel()
コンストラクタ
RunUserInfoModel(ActivityInfoModel src)
RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)
RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
RunUserInfoModel(ProcessInfoModel src)
RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)
RunUserInfoModel(RunUserInfoModel src)
メソッドの概要
void | addGroupList(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model) グループ情報リストを追加します。
static void | existUserCd(Connection connection, String userCd, String targetDate, String invalidErrCd, String noExistErrCd) ユーザコード入力情報をチェックするメソッドです。
String | getApprovalRightType() 承認可否種別を返却します。
String | getApprovalTypeCd() 承認種別CDを返却します。
String | getArbitraryChangeFlag() 任意指定フラグを返却します。
String | getAuthorityFlg() 処理権限フラグを返却します。
String | getDemandReceiptCd() 依頼要求／受付CDを返却します。
String | getDemandReceiptName() 依頼要求／受付名を返却します。
jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel | getGroupList() グループ情報リストを返却します。
String | getLoginGroupID() ログイングループIDを返却します。
String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
String | getNoticeMailFlg() 代理元メール通知フラグを返却します。
String | getProcessCd() プロセスコードを返却します。
String | getRecognitionStatus() 承認ステータスを返却します。
String | getRepresentationType() 代理コード種別を返却します。
String | getTransferUserCd() 振替先ユーザCDを返却します。
String | getTransferUserName() 振替先ユーザ名を返却します。
String | getUserCd() ユーザコードを返却します。
String | getUserName() ユーザ名を返却します。
void | inputCheck(Connection connection, String targetDate) 実行主体ユーザ入力情報をチェックするメソッドです。
void | setApprovalRightType(String string) 承認可否種別を設定します。
void | setApprovalTypeCd(String string) 承認種別CDを設定します。
void | setArbitraryChangeFlag(String string) 任意指定フラグを設定します。
void | setAuthorityFlg(String string) 処理権限フラグを設定します。
void | setDemandReceiptCd(String string) 依頼要求／受付CDを設定します。
void | setDemandReceiptName(String string) 依頼要求／受付名を設定します。
void | setLoginGroupID(String string) ログイングループIDを設定します。
void | setLoginUserID(String string) ログインユーザIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setNoticeMailFlg(String string) 代理元メール通知フラグを設定します。
void | setProcessCd(String string) プロセスコードを設定します。
void | setRecognitionStatus(String string) 承認ステータスを設定します。
void | setRepresentationType(String string) 代理コード種別を設定します。
void | setTransferUserCd(String string) 振替先ユーザCDを設定します。
void | setTransferUserName(String string) 振替先ユーザ名を設定します。
void | setUserCd(String string) ユーザコードを設定します。
void | setUserName(String string) ユーザ名を設定します。
クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey から継承したメソッド
getActivityCd, getProcessDefCd, getVersionCd, setActivityCd, setProcessDefCd, setVersionCd
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TYPE_PERSON

public static final String TYPE_PERSON
承認対象種別コード：本人

関連項目:
定数フィールド値

TYPE_SAID_PERSON

public static final String TYPE_SAID_PERSON
承認対象種別コード：代理

関連項目:
定数フィールド値

TYPE_DELEGATE

public static final String TYPE_DELEGATE
承認対象種別コード：振替

関連項目:
定数フィールド値

RIGHT_INIT

public static final String RIGHT_INIT
承認可否種別：初期値（全ての承認種別CDで有効）

関連項目:
定数フィールド値

RIGHT_PERSON

public static final String RIGHT_PERSON
承認可否種別：代理・本人決済可（本人(00)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

RIGHT_NOT_PERSON

public static final String RIGHT_NOT_PERSON
承認可否種別：代理・本人決済不可（本人(00)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

RIGHT_DELEGATE

public static final String RIGHT_DELEGATE
承認可否種別：振替・本人決済可（振替(02)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

RIGHT_NOT_DELEGATE

public static final String RIGHT_NOT_DELEGATE
承認可否種別：振替・本人決済不可（振替(02)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

STATUS_INIT

public static final String STATUS_INIT
承認ステータス：初期値（全ての承認種別CDで有効）

関連項目:
定数フィールド値

STATUS_COMPLETE

public static final String STATUS_COMPLETE
承認ステータス：処理済（全ての承認種別CDで有効）

関連項目:
定数フィールド値

STATUS_SAID_COMPLETE

public static final String STATUS_SAID_COMPLETE
承認ステータス：代理処理済（本人(00)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

STATUS_DELEGATE_COMPLETE

public static final String STATUS_DELEGATE_COMPLETE
承認ステータス：振替処理済（本人(00), 振替(02)の承認種別CDでのみ有効）

関連項目:
定数フィールド値

ARBITRARY_CHANGE_FLAG_OFF

public static final String ARBITRARY_CHANGE_FLAG_OFF
任意指定フラグ：任意指定なし

関連項目:
定数フィールド値

ARBITRARY_CHANGE_FLAG_ON

public static final String ARBITRARY_CHANGE_FLAG_ON
任意指定フラグ：任意指定あり

関連項目:
定数フィールド値
コンストラクタの詳細

RunUserInfoModel

public RunUserInfoModel()
コンストラクタ

RunUserInfoModel

public RunUserInfoModel(ProcessInfoModel src)

RunUserInfoModel

public RunUserInfoModel(ActivityInfoModel src)

RunUserInfoModel

public RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel src)

RunUserInfoModel

public RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel src)

RunUserInfoModel

public RunUserInfoModel(RunUserInfoModel src)

RunUserInfoModel

public RunUserInfoModel(jp.co.intra_mart.foundation.bpw.model.object.DelegateUserInfoModel src)
メソッドの詳細

getUserCd

public String getUserCd()
ユーザコードを返却します。

戻り値:
ユーザコード

getUserName

public String getUserName()
ユーザ名を返却します。

戻り値:
ユーザ名

getProcessCd

public String getProcessCd()
プロセスコードを返却します。

戻り値:
プロセスコード

getGroupList

public jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel getGroupList()
グループ情報リストを返却します。

戻り値:
グループ情報リスト

getAuthorityFlg

public String getAuthorityFlg()
処理権限フラグを返却します。

戻り値:
処理権限フラグ
関連項目:
参照権限, 管理権限

getDemandReceiptCd

public String getDemandReceiptCd()
依頼要求／受付CDを返却します。

戻り値:
依頼要求／受付CD

getDemandReceiptName

public String getDemandReceiptName()
依頼要求／受付名を返却します。

戻り値:
依頼要求／受付名

getApprovalTypeCd

public String getApprovalTypeCd()
承認種別CDを返却します。

戻り値:
承認種別CD

getApprovalRightType

public String getApprovalRightType()
承認可否種別を返却します。

戻り値:
承認可否種別

getRepresentationType

public String getRepresentationType()
代理コード種別を返却します。

戻り値:
承認可否種別

getTransferUserCd

public String getTransferUserCd()
振替先ユーザCDを返却します。

戻り値:
振替先ユーザCD

getTransferUserName

public String getTransferUserName()
振替先ユーザ名を返却します。

戻り値:
振替先ユーザ名

getRecognitionStatus

public String getRecognitionStatus()
承認ステータスを返却します。

戻り値:
承認ステータス

getNoticeMailFlg

public String getNoticeMailFlg()
代理元メール通知フラグを返却します。

戻り値:
代理元メール通知フラグ

getArbitraryChangeFlag

public String getArbitraryChangeFlag()
任意指定フラグを返却します。

戻り値:
任意指定フラグ

setUserCd

public void setUserCd(String string)
ユーザコードを設定します。

パラメータ:
string - ユーザコード

setUserName

public void setUserName(String string)
ユーザ名を設定します。

パラメータ:
string - ユーザ名

setProcessCd

public void setProcessCd(String string)
プロセスコードを設定します。

パラメータ:
string - プロセスコード

addGroupList

public void addGroupList(jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel model)
グループ情報リストを追加します。

パラメータ:
model - グループ情報

setAuthorityFlg

public void setAuthorityFlg(String string)
処理権限フラグを設定します。

パラメータ:
string - 処理権限フラグ
関連項目:
参照権限, 管理権限

setDemandReceiptCd

public void setDemandReceiptCd(String string)
依頼要求／受付CDを設定します。

パラメータ:
string - 依頼要求／受付CD

setDemandReceiptName

public void setDemandReceiptName(String string)
依頼要求／受付名を設定します。

パラメータ:
string - 依頼要求／受付名

inputCheck

public void inputCheck(Connection connection,
                       String targetDate)
                throws jp.co.intra_mart.framework.system.exception.SystemException,
                       jp.co.intra_mart.framework.system.exception.ApplicationException
実行主体ユーザ入力情報をチェックするメソッドです。

パラメータ:
connection - DbsConnection
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生

existUserCd

public static void existUserCd(Connection connection,
                               String userCd,
                               String targetDate,
                               String invalidErrCd,
                               String noExistErrCd)
                        throws jp.co.intra_mart.framework.system.exception.SystemException,
                               jp.co.intra_mart.framework.system.exception.ApplicationException
ユーザコード入力情報をチェックするメソッドです。

パラメータ:
connection - DbsConnection
userCd - ユーザコード
targetDate - チェック対象日付
invalidErrCd - コード不正時エラーコード
noExistErrCd - コード未存在時エラーコード
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外が発生
jp.co.intra_mart.framework.system.exception.ApplicationException - アプリケーション例外が発生

setApprovalTypeCd

public void setApprovalTypeCd(String string)
承認種別CDを設定します。

パラメータ:
string - 承認種別CD

setApprovalRightType

public void setApprovalRightType(String string)
承認可否種別を設定します。

パラメータ:
string - 承認可否種別

setRepresentationType

public void setRepresentationType(String string)
代理コード種別を設定します。

パラメータ:
string - 承認可否種別

setTransferUserCd

public void setTransferUserCd(String string)
振替先ユーザCDを設定します。

パラメータ:
string - 振替先ユーザCD

setTransferUserName

public void setTransferUserName(String string)
振替先ユーザ名を設定します。

パラメータ:
string - 振替先ユーザ名

setRecognitionStatus

public void setRecognitionStatus(String string)
承認ステータスを設定します。

パラメータ:
string - 承認ステータス

setNoticeMailFlg

public void setNoticeMailFlg(String string)
代理元メール通知フラグを設定します。

パラメータ:
string - 代理元メール通知フラグ

setArbitraryChangeFlag

public void setArbitraryChangeFlag(String string)
任意指定フラグを設定します。

パラメータ:
string - 任意指定フラグ

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(String string)
ログインユーザIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


VersionInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.bpw.model.object
クラス VersionInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel
すべての実装インタフェース:
jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF
public class VersionInfoModel
extends Object
implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF

履歴情報を保持する情報クラス

フィールドの概要
static String | ATTACHMENT_ABLE 添付ファイルフラグ : 添付ファイルを使用する
static String | ATTACHMENT_UNABLE 添付ファイルフラグ : 添付機能を使用しない
static String | PROCESS_CLASS_BPW プロセス種別コード : ビジネスプロセスワークフロー
static String | PROCESS_CLASS_DRW プロセス種別コード : 申請者／承認者ルート作成ワークフロー
static String | PROCESS_CLASS_DW プロセス種別コード : ドキュメントワークフロー
static String | SUB_PROCESS_INIT サブプロセス識別フラグ : 通常／サブ利用可能プロセス
static String | SUB_PROCESS_ONLY サブプロセス識別フラグ : サブ利用特化プロセス
コンストラクタの概要
VersionInfoModel()
コンストラクタ
メソッドの概要
protected boolean | checkLicenseForProcessClass(String licenseFlg, String processClassCode) プロセス種別に対するライセンスのチェックを行う。
String | getAttachmentFlag()
boolean | getAttachmentFlagFlag()
String | getCategoryCode() カテゴリコードを返却します。
String | getDraftActivityCd() 起票処理コードを返却します。
String | getEffectiveDate() 有効日付を返却します。
String | getEndDate() 終了日付を返却します。
String | getExtensionNameA() 拡張定義名Ａを返却します。
boolean | getExtensionNameAFlag() 拡張定義名Ａ更新対象フラグを返却します。
String | getExtensionNameB() 拡張定義名Ｂを返却します。
boolean | getExtensionNameBFlag() 拡張定義名Ｂ更新対象フラグを返却します。
String | getExtensionNameC() 拡張定義名Ｃを返却します。
boolean | getExtensionNameCFlag() 拡張定義名Ｃ更新対象フラグを返却します。
String | getExtensionNameD() 拡張定義名Ｄを返却します。
boolean | getExtensionNameDFlag() 拡張定義名Ｄ更新対象フラグを返却します。
String | getExtensionNameE() 拡張定義名Ｅを返却します。
boolean | getExtensionNameEFlag() 拡張定義名Ｅ更新対象フラグを返却します。
String | getExtensionNameF() 拡張定義名Ｆを返却します。
boolean | getExtensionNameFFlag() 拡張定義名Ｆ更新対象フラグを返却します。
String | getExtensionNameG() 拡張定義名Ｇを返却します。
boolean | getExtensionNameGFlag() 拡張定義名Ｇ更新対象フラグを返却します。
String | getExtensionNameH() 拡張定義名Ｈを返却します。
boolean | getExtensionNameHFlag() 拡張定義名Ｈ更新対象フラグを返却します。
static String | getLicense() ライセンスを取得します。
String | getLoginGroupID() ログイングループIDを返却します。
String | getLoginUserID() ログインユーザIDを返却します。
jp.co.intra_mart.framework.base.util.UserInfo | getLoginUserInfo() ログインユーザ情報を返却します。
String | getNote() 備考を返却します。
String | getProcessClassCode() プロセス種別コードを返却します。
boolean | getProcessClassCodeFlag() プロセス種別コード更新対象フラグを返却します。
String | getProcessDefCd() プロセス定義コードを返却します。
String | getProcessDefName() プロセス定義名を返却します。
String | getProcessDefNote() プロセス定義備考を返却します。
String | getRecordUserCd() 最終更新者コードを返却します。
String | getStartActivityCd() 開始処理コードを返却します。
boolean | getStartActivityCdFlag() 開始処理コード更新対象フラグを返却します。
String | getSubProcessFlag() サブプロセス識別フラグを返却します。
boolean | getSubProcessFlagFlag() サブプロセス識別フラグ更新対象フラグを返却します。
String | getVersionCd() 履歴コードを返却します。
String | getVersionName() 履歴名を返却します。
boolean | getVersionNameFlag() 履歴名更新対象フラグを返却します。
void | inputCheck(Connection connection, String processDefName) 履歴マスタ入力情報をチェックするメソッドです。
void | setAttachmentFlag(String string)
void | setCategoryCode(String string) カテゴリコードを設定します。
void | setCreateDate(String string) 作成日時を設定します。
void | setCreateUserCd(String string) 作成者コードを設定します。
void | setCreateUserName(String string) 作成者名を設定します。
void | setDraftActivityCd(String string) 起票処理コードを設定します。
void | setEffectiveDate(String string) 有効日付を設定します。
void | setEndDate(String string) 終了日付を設定します。
void | setExtensionNameA(String string) 拡張定義名Ａを設定します。
void | setExtensionNameB(String string) 拡張定義名Ｂを設定します。
void | setExtensionNameC(String string) 拡張定義名Ｃを設定します。
void | setExtensionNameD(String string) 拡張定義名Ｄを設定します。
void | setExtensionNameE(String string) 拡張定義名Ｅを設定します。
void | setExtensionNameF(String string) 拡張定義名Ｆを設定します。
void | setExtensionNameG(String string) 拡張定義名Ｇを設定します。
void | setExtensionNameH(String string) 拡張定義名Ｈを設定します。
void | setLoginGroupID(String string) ログイングループIDを設定します。
void | setLoginUserID(String string) ログイングループIDを設定します。
void | setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info) ログイン情報を設定します。
void | setNote(String string) 備考を設定します。
void | setProcessClassCode(String string) プロセス種別コードを設定します。
void | setProcessDefCd(String string) プロセス定義コードを設定します。
void | setProcessDefName(String string) プロセス定義名を設定します。
void | setProcessDefNote(String string) プロセス定義備考を設定します。
void | setRecordDate(String string) 最終更新日時を設定します。
void | setRecordUserCd(String string) 最終更新者コードを設定します。
void | setRecordUserName(String string) 最終更新者名を設定します。
void | setStartActivityCd(String string) 開始処理コードを設定します。
void | setSubProcessFlag(String string) サブプロセス識別フラグを設定します。
void | setVersionCd(String string) 履歴コードを設定します。
void | setVersionName(String string) 履歴名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PROCESS_CLASS_BPW

public static final String PROCESS_CLASS_BPW
プロセス種別コード : ビジネスプロセスワークフロー

関連項目:
定数フィールド値

PROCESS_CLASS_DW

public static final String PROCESS_CLASS_DW
プロセス種別コード : ドキュメントワークフロー

関連項目:
定数フィールド値

PROCESS_CLASS_DRW

public static final String PROCESS_CLASS_DRW
プロセス種別コード : 申請者／承認者ルート作成ワークフロー

関連項目:
定数フィールド値

SUB_PROCESS_INIT

public static final String SUB_PROCESS_INIT
サブプロセス識別フラグ : 通常／サブ利用可能プロセス

関連項目:
定数フィールド値

SUB_PROCESS_ONLY

public static final String SUB_PROCESS_ONLY
サブプロセス識別フラグ : サブ利用特化プロセス

関連項目:
定数フィールド値

ATTACHMENT_UNABLE

public static final String ATTACHMENT_UNABLE
添付ファイルフラグ : 添付機能を使用しない

関連項目:
定数フィールド値

ATTACHMENT_ABLE

public static final String ATTACHMENT_ABLE
添付ファイルフラグ : 添付ファイルを使用する

関連項目:
定数フィールド値
コンストラクタの詳細

VersionInfoModel

public VersionInfoModel()
コンストラクタ

メソッドの詳細

getDraftActivityCd

public String getDraftActivityCd()
起票処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
起票処理コード

getVersionNameFlag

public boolean getVersionNameFlag()
履歴名更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
履歴名更新対象フラグ

getStartActivityCdFlag

public boolean getStartActivityCdFlag()
開始処理コード更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
開始処理コード更新対象フラグ

getProcessClassCodeFlag

public boolean getProcessClassCodeFlag()
プロセス種別コード更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス種別コード更新対象フラグ

getSubProcessFlagFlag

public boolean getSubProcessFlagFlag()
サブプロセス識別フラグ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
サブプロセス識別フラグ更新対象フラグ

getExtensionNameAFlag

public boolean getExtensionNameAFlag()
拡張定義名Ａ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ａ更新対象フラグ

getExtensionNameBFlag

public boolean getExtensionNameBFlag()
拡張定義名Ｂ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｂ更新対象フラグ

getExtensionNameCFlag

public boolean getExtensionNameCFlag()
拡張定義名Ｃ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｃ更新対象フラグ

getExtensionNameDFlag

public boolean getExtensionNameDFlag()
拡張定義名Ｄ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｄ更新対象フラグ

getExtensionNameEFlag

public boolean getExtensionNameEFlag()
拡張定義名Ｅ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｅ更新対象フラグ

getExtensionNameFFlag

public boolean getExtensionNameFFlag()
拡張定義名Ｆ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｆ更新対象フラグ

getExtensionNameGFlag

public boolean getExtensionNameGFlag()
拡張定義名Ｇ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｇ更新対象フラグ

getExtensionNameHFlag

public boolean getExtensionNameHFlag()
拡張定義名Ｈ更新対象フラグを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｈ更新対象フラグ

getExtensionNameA

public String getExtensionNameA()
拡張定義名Ａを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ａ

getExtensionNameB

public String getExtensionNameB()
拡張定義名Ｂを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｂ

getExtensionNameC

public String getExtensionNameC()
拡張定義名Ｃを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｃ

getExtensionNameD

public String getExtensionNameD()
拡張定義名Ｄを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｄ

getExtensionNameE

public String getExtensionNameE()
拡張定義名Ｅを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｅ

getExtensionNameF

public String getExtensionNameF()
拡張定義名Ｆを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｆ

getExtensionNameG

public String getExtensionNameG()
拡張定義名Ｇを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｇ

getExtensionNameH

public String getExtensionNameH()
拡張定義名Ｈを返却します。 システムで利用されるメソッドです。

戻り値:
拡張定義名Ｈ

getCategoryCode

public String getCategoryCode()
カテゴリコードを返却します。 システムで利用されるメソッドです。

戻り値:
カテゴリコード

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義コード

getProcessDefName

public String getProcessDefName()
プロセス定義名を返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義名

getProcessDefNote

public String getProcessDefNote()
プロセス定義備考を返却します。 システムで利用されるメソッドです。

戻り値:
プロセス定義備考

getEffectiveDate

public String getEffectiveDate()
有効日付を返却します。 システムで利用されるメソッドです。

戻り値:
有効日付

getEndDate

public String getEndDate()
終了日付を返却します。 システムで利用されるメソッドです。

戻り値:
終了日付

getNote

public String getNote()
備考を返却します。 システムで利用されるメソッドです。

戻り値:
備考

getProcessClassCode

public String getProcessClassCode()
プロセス種別コードを返却します。 システムで利用されるメソッドです。

戻り値:
プロセス種別コード

getSubProcessFlag

public String getSubProcessFlag()
サブプロセス識別フラグを返却します。 システムで利用されるメソッドです。

戻り値:
サブプロセス識別フラグ

getRecordUserCd

public String getRecordUserCd()
最終更新者コードを返却します。 システムで利用されるメソッドです。

戻り値:
最終更新者コード

getStartActivityCd

public String getStartActivityCd()
開始処理コードを返却します。 システムで利用されるメソッドです。

戻り値:
開始処理コード

getVersionCd

public String getVersionCd()
履歴コードを返却します。 システムで利用されるメソッドです。

戻り値:
履歴コード

getVersionName

public String getVersionName()
履歴名を返却します。 システムで利用されるメソッドです。

戻り値:
履歴名

setDraftActivityCd

public void setDraftActivityCd(String string)
起票処理コードを設定します。

パラメータ:
string - 起票処理コード

setExtensionNameA

public void setExtensionNameA(String string)
拡張定義名Ａを設定します。

パラメータ:
string - 拡張定義名Ａ

setExtensionNameB

public void setExtensionNameB(String string)
拡張定義名Ｂを設定します。

パラメータ:
string - 拡張定義名Ｂ

setExtensionNameC

public void setExtensionNameC(String string)
拡張定義名Ｃを設定します。

パラメータ:
string - 拡張定義名Ｃ

setExtensionNameD

public void setExtensionNameD(String string)
拡張定義名Ｄを設定します。

パラメータ:
string - 拡張定義名Ｄ

setExtensionNameE

public void setExtensionNameE(String string)
拡張定義名Ｅを設定します。

パラメータ:
string - 拡張定義名Ｅ

setExtensionNameF

public void setExtensionNameF(String string)
拡張定義名Ｆを設定します。

パラメータ:
string - 拡張定義名Ｆ

setExtensionNameG

public void setExtensionNameG(String string)
拡張定義名Ｇを設定します。

パラメータ:
string - 拡張定義名Ｇ

setExtensionNameH

public void setExtensionNameH(String string)
拡張定義名Ｈを設定します。

パラメータ:
string - 拡張定義名Ｈ

setCategoryCode

public void setCategoryCode(String string)
カテゴリコードを設定します。

パラメータ:
string - カテゴリコード

setProcessDefCd

public void setProcessDefCd(String string)
プロセス定義コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - プロセス定義コード

setProcessDefName

public void setProcessDefName(String string)
プロセス定義名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - プロセス定義名

setProcessDefNote

public void setProcessDefNote(String string)
プロセス定義備考を設定します。 システムで利用されるメソッドです。

パラメータ:
string - プロセス定義備考

setCreateDate

public void setCreateDate(String string)
作成日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成日時

setCreateUserCd

public void setCreateUserCd(String string)
作成者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者コード

setCreateUserName

public void setCreateUserName(String string)
作成者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 作成者名

setEffectiveDate

public void setEffectiveDate(String string)
有効日付を設定します。

パラメータ:
string - 有効日付

setEndDate

public void setEndDate(String string)
終了日付を設定します。

パラメータ:
string - 終了日付

setNote

public void setNote(String string)
備考を設定します。

パラメータ:
string - 備考

setProcessClassCode

public void setProcessClassCode(String string)
プロセス種別コードを設定します。

パラメータ:
string - プロセス種別コード

setSubProcessFlag

public void setSubProcessFlag(String string)
サブプロセス識別フラグを設定します。

パラメータ:
string - サブプロセス識別フラグ

setRecordDate

public void setRecordDate(String string)
最終更新日時を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新日時

setRecordUserCd

public void setRecordUserCd(String string)
最終更新者コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者コード

setRecordUserName

public void setRecordUserName(String string)
最終更新者名を設定します。 システムで利用されるメソッドです。

パラメータ:
string - 最終更新者名

setStartActivityCd

public void setStartActivityCd(String string)
開始処理コードを設定します。

パラメータ:
string - 開始処理コード

setVersionCd

public void setVersionCd(String string)
履歴コードを設定します。 システムで利用されるメソッドです。

パラメータ:
string - 履歴コード

setVersionName

public void setVersionName(String string)
履歴名を設定します。

パラメータ:
string - 履歴名

getLoginUserInfo

public jp.co.intra_mart.framework.base.util.UserInfo getLoginUserInfo()
ログインユーザ情報を返却します。 システムで利用されるメソッドです。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserInfo
戻り値:
ログインユーザ情報

setLoginUserInfo

public void setLoginUserInfo(jp.co.intra_mart.framework.base.util.UserInfo info)
ログイン情報を設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserInfo
パラメータ:
info - ログインユーザ情報

setLoginUserID

public void setLoginUserID(String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginUserID
パラメータ:
string - ログインユーザID

setLoginGroupID

public void setLoginGroupID(String string)
ログイングループIDを設定します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の setLoginGroupID
パラメータ:
string - ログイングループID

getLoginUserID

public String getLoginUserID()
ログインユーザIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginUserID
戻り値:
ログインユーザID

getLoginGroupID

public String getLoginGroupID()
ログイングループIDを返却します。

定義:
インタフェース jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF 内の getLoginGroupID
戻り値:
ログイングループID

getAttachmentFlag

public String getAttachmentFlag()
戻り値:
添付ファイル使用可否フラグ

setAttachmentFlag

public void setAttachmentFlag(String string)

getAttachmentFlagFlag

public boolean getAttachmentFlagFlag()
戻り値:
添付ファイル使用可否フラグ更新対象フラグ

inputCheck

public void inputCheck(Connection connection,
                       String processDefName)
                throws jp.co.intra_mart.framework.system.exception.SystemException,
                       jp.co.intra_mart.framework.system.exception.ApplicationException
履歴マスタ入力情報をチェックするメソッドです。

パラメータ:
connection - DBコネクション
processDefName - プロセス定義名
例外:
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

checkLicenseForProcessClass

protected boolean checkLicenseForProcessClass(String licenseFlg,
                                              String processClassCode)
プロセス種別に対するライセンスのチェックを行う。

パラメータ:
licenseFlg - ライセンス
processClassCode - プロセス種別
戻り値:
boolean

getLicense

public static String getLicense()
ライセンスを取得します。

戻り値:
ライセンス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.wkf.ActivityTaskModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.ActivityTaskModel の使用

ActivityTaskModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での ActivityTaskModel の使用

jp.co.intra_mart.foundation.wkf での ActivityTaskModel のサブクラス
 class ReceiveTaskModel
処理タスク設定情報を保持するクラス

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.AgentSetting の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.AgentSetting の使用

jp.co.intra_mart.foundation.wkf.AgentSetting はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.Approver の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Approver の使用

jp.co.intra_mart.foundation.wkf.Approver はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel の使用

ContentsPathDetailModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での ContentsPathDetailModel の使用

ContentsPathDetailModel を返す jp.co.intra_mart.foundation.wkf のメソッド
ContentsPathDetailModel | ContentsPathModel.getApplyPath() 通常コンテンツパスを返却します。
ContentsPathDetailModel | ContentsPathModel.getDetailPath() 詳細コンテンツパスを返却します。
ContentsPathDetailModel | ContentsPathModel.getPullPath() 引戻しコンテンツパスを返却します。
ContentsPathDetailModel | ContentsPathModel.getReferPath() 参照コンテンツパスを返却します。
ContentsPathDetailModel | ContentsPathModel.getReturnPath() 差戻しコンテンツパスを返却します。

ContentsPathDetailModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
void | ContentsPathModel.setApplyPath(ContentsPathDetailModel apply_path) 通常コンテンツパスを設定します。
void | ContentsPathModel.setDetailPath(ContentsPathDetailModel detail_path) 詳細コンテンツパスを設定します。
void | ContentsPathModel.setPullPath(ContentsPathDetailModel pull_path) 引戻しコンテンツパスを設定します。
void | ContentsPathModel.setReferPath(ContentsPathDetailModel refer_path) 参照コンテンツパスを設定します。
void | ContentsPathModel.setReturnPath(ContentsPathDetailModel return_path) 差戻しコンテンツパスを設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.ContentsPathModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.ContentsPathModel の使用

ContentsPathModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での ContentsPathModel の使用

ContentsPathModel を返す jp.co.intra_mart.foundation.wkf のメソッド
 ContentsPathModel ReceiveTaskModel.getContentsPath()
コンテンツパス情報を返却します。

ContentsPathModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
void | ReceiveTaskModel.setContentsPath(ContentsPathModel contents_path) コンテンツパス情報を設定します。
Map | Manager.registProcessDef(String category_cd, String process_def_name, String process_def_notes, String version_notes, String process_class_code, boolean sub_process_flag, boolean attachment_flag, String effective_date, String end_date, ContentsPathModel process_contents_path, List root_info) 推奨されていません。
Map | Manager.addVersion(String process_def_cd, String version_notes, String effective_date, String end_date, ContentsPathModel process_contents_path, List root_info) 推奨されていません。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel の使用

CreateRouteInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での CreateRouteInfoModel の使用

CreateRouteInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel の使用

CreateRouteTargetInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での CreateRouteTargetInfoModel の使用

CreateRouteTargetInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
 void CreateRouteInfoModel.addCreateRouteTargetList(CreateRouteTargetInfoModel info)
対象者情報を追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.Drafter の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Drafter の使用

jp.co.intra_mart.foundation.wkf.Drafter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.FlowInfo の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.FlowInfo の使用

FlowInfo を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での FlowInfo の使用

FlowInfo を返す jp.co.intra_mart.foundation.wkf のメソッド
FlowInfo | Manager.getFlowInfo(String processDefCd, String versionCd, String activityCd) 推奨されていません。 getFlowInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件:AUTHORITY_ALLで情報を取得します。
FlowInfo | Manager.getFlowInfo(String processDefCd, String versionCd, String activityCd, String authority) 特定のタスクの位置情報を保持して、フロー情報を取得する。
FlowInfo | FlowInfo.getFirst() 自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる
FlowInfo | FlowInfo.getLast() 自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.Manager の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Manager の使用

jp.co.intra_mart.foundation.wkf.Manager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.NegoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.NegoModel の使用

NegoModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での NegoModel の使用

NegoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | Drafter.draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | Drafter.retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | Drafter.cancel(String process_def_cd, String version_cd, String process_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 取り止め処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | Drafter.subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | Approver.approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | Approver.denial(String process_def_cd, String version_cd, String process_cd, String activity_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 否認処理を実行します。
void | Approver.suspend(String process_def_cd, String version_cd, String process_cd, String activity_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 保留処理を実行します。
void | Approver.sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, NegoModel nego) 推奨されていません。 sendBack メソッドを使用してください。
void | Approver.sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, NegoModel nego, String send_back_process_def_cd, String send_back_version_cd, String send_back_process_cd, String send_back_activity_cd) 差し戻し処理を実行します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.Process の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Process の使用

jp.co.intra_mart.foundation.wkf.Process はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.ReceiveTaskModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.ReceiveTaskModel の使用

jp.co.intra_mart.foundation.wkf.ReceiveTaskModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.Reference の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Reference の使用

jp.co.intra_mart.foundation.wkf.Reference はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TargetAutoPassModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TargetAutoPassModel の使用

TargetAutoPassModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での TargetAutoPassModel の使用

TargetAutoPassModel を返す jp.co.intra_mart.foundation.wkf のメソッド
 TargetAutoPassModel ReceiveTaskModel.getAutoPassExecutive()
対象者自動パス設定情報を取得します。

TargetAutoPassModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
 void ReceiveTaskModel.setAutoPassExecutive(TargetAutoPassModel auto_pass_executive)
対象者自動パス設定情報を設定します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TargetInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TargetInfoModel の使用

TargetInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での TargetInfoModel の使用

TargetInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
void | TaskInfo.changeRunUser(String process_def_cd, String version_cd, String process_cd, String activity_cd, TargetInfoModel target_info) 指定された案件内の指定タスクの処理者を変更します。
void | TargetAutoPassModel.addAutoPassTarget(TargetInfoModel target_info) 自動パス対象者情報を追加します。
void | ReceiveTaskModel.addRunUser(TargetInfoModel target_info) 対象者情報を追加します。
void | ReceiveTaskModel.addReferUser(TargetInfoModel target_info) 参照者情報を追加します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TaskInfo の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TaskInfo の使用

jp.co.intra_mart.foundation.wkf.TaskInfo はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TransferActivityModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TransferActivityModel の使用

jp.co.intra_mart.foundation.wkf.TransferActivityModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TransferInfoModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TransferInfoModel の使用

TransferInfoModel を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での TransferInfoModel の使用

TransferInfoModel を返す jp.co.intra_mart.foundation.wkf のメソッド
 TransferInfoModel AgentSetting.getTransferInfo(String process_def_cd, String version_cd, String activity_cd, String target_date)
指定された日付に有効な代理設定情報を返却します。

TransferInfoModel 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
void | AgentSetting.setAgent(TransferInfoModel transferInfo) 代理設定を設定します。
void | AgentSetting.cancelAgent(TransferInfoModel transferInfo) 代理設定を解除します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TransferProcessDefModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TransferProcessDefModel の使用

jp.co.intra_mart.foundation.wkf.TransferProcessDefModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.TransferVersionModel の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.TransferVersionModel の使用

jp.co.intra_mart.foundation.wkf.TransferVersionModel はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.Util の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.Util の使用

jp.co.intra_mart.foundation.wkf.Util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.support.SearchCondition の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.support.SearchCondition の使用

SearchCondition を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での SearchCondition の使用

SearchCondition 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
List | Reference.getReferTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 参照可能案件一覧を取得します。
List | Manager.getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 推奨されていません。 getProcessListメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
List | Manager.getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, String authority) プロセス一覧情報を取得します。
List | Drafter.getActivityProcessDefList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, String locale) 起票可能プロセス一覧を取得します。
List | Drafter.getEndProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 起票済み案件を取得します。
List | Approver.getActivityTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理可能案件(未処理案件)一覧の取得を行います。
List | Approver.getEndTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理済案件一覧の取得を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.wkf.support.Sort の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.wkf.support.Sort の使用

Sort を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf での Sort の使用

Sort 型のパラメータを持つ jp.co.intra_mart.foundation.wkf のメソッド
List | Reference.getReferTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 参照可能案件一覧を取得します。
List | Manager.getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 推奨されていません。 getProcessListメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
List | Manager.getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, String authority) プロセス一覧情報を取得します。
List | Drafter.getActivityProcessDefList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, String locale) 起票可能プロセス一覧を取得します。
List | Drafter.getEndProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 起票済み案件を取得します。
List | Approver.getActivityTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理可能案件(未処理案件)一覧の取得を行います。
List | Approver.getEndTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理済案件一覧の取得を行います。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.wkf.support (bpw 6.1.14 API)

 jp.co.intra_mart.foundation.wkf.support
クラス
SearchCondition
Sort


jp.co.intra_mart.foundation.wkf.support (bpw 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf.support

クラスの概要
SearchCondition | プログラムサポート/検索条件設定オブジェクト。
Sort | プログラムサポート/ソート指定オブジェクト。


jp.co.intra_mart.foundation.wkf.support クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf.support の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.wkf.support.SearchCondition
    • class jp.co.intra_mart.foundation.wkf.support.Sort


パッケージ jp.co.intra_mart.foundation.wkf.support の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.wkf.support の使用

jp.co.intra_mart.foundation.wkf.support を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.wkf.support のクラス
SearchCondition
プログラムサポート/検索条件設定オブジェクト。
Sort
プログラムサポート/ソート指定オブジェクト。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


SearchCondition (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf.support
クラス SearchCondition

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.support.SearchCondition
public class SearchCondition
extends Object

プログラムサポート/検索条件設定オブジェクト。
指定できる検索条件は各検索メソッドの戻り値に指定されている項目のみとなります。

検索キーに起票指定日キーを指定する場合は、日付フォーマット（yyyy/MM/dd）にて指定するようにしてください。
起票指定日を除く日付関連のキーを指定する場合には、intra-mart日付フォーマット（yyyy/MM/dd|HH:mm:ss）にて、
指定するようにしてください。
各検索項目キーは以下のフィールドを参照してください。

※フィルターについて

フィールドの概要
static String | ACTIVITY_CD 処理タスクコードキー
static String | ACTIVITY_NAME 処理タスク名キー
static String | AGENT_USER_CD 代理依頼元ユーザコードキー
static String | AGENT_USER_NAME 代理依頼元ユーザ名キー
static String | AGT_COMPLETE_FILTER 完了タスク表示(委譲)キー
static String | AGT_GO_FILTER 未処理タスク表示(委譲)キー
static String | AGT_PULLBACK_FILTER 引き戻しタスク表示(委譲)キー
static String | AGT_SENDBACK_FILTER 差し戻しタスク表示(委譲)キー
static String | APPROVAL_COMP_CD 処理者の会社コードキー
static String | APPROVAL_DATE_END 処理日(検索範囲終了日)キー
static String | APPROVAL_DATE_START 処理日(検索範囲開始日)キー
static String | APPROVAL_ORGN_CD 処理者の組織コードキー
static String | APPROVAL_ORGN_NAME 処理者の組織名キー
static String | APPROVAL_USER_CD 処理者ユーザコードキー
static String | APPROVAL_USER_NAME 処理者ユーザ名キー
static String | ARRIVE_DATE_END 到達日(検索範囲終了日)キー
static String | ARRIVE_DATE_START 到達日(検索範囲開始日)キー
static String | CATEGORY_CD カテゴリコードキー
static String | CATEGORY_NAME カテゴリ名キー
static String | CLT_AGT_COMPLETE_FILTER 完了タスク表示(代理元承認可委譲)キー
static String | CLT_AGT_GO_FILTER 未処理タスク表示(代理元承認可委譲)キー
static String | CLT_AGT_PULLBACK_FILTER 引き戻しタスク表示(代理元承認可委譲)キー
static String | CLT_AGT_SENDBACK_FILTER 差し戻しタスク表示(代理元承認可委譲)キー
static String | COMPLETE_FILTER 完了タスク表示キー
static String | DRAFT_APPOINT_DATE 起票指定日キー
static String | DRAFT_COMP_CD 起票者の起票会社コードキー
static String | DRAFT_DATE_END 起票日(検索範囲終了)キー
static String | DRAFT_DATE_START 起票日(検索範囲開始日)キー
static String | DRAFT_ORGN_CD 起票者の起票組織コードキー
static String | DRAFT_USER_CD 起票ユーザコードキー
static String | DRAFT_USER_NAME 起票ユーザ名キー
static String | GO_FILTER 未処理タスク表示キー
static String | LIMIT_DATE_END 処理期限日(検索範囲終了日)キー
static String | LIMIT_DATE_START 処理期限日(検索範囲開始日)キー
static String | PROCESS_CD プロセスコードキー
static String | PROCESS_DEF_CD プロセス定義コードキー
static String | PROCESS_DEF_NAME プロセス定義名キー
static String | PROCESS_NAME プロセス名キー
static String | PULLBACK_FILTER 引き戻しタスク表示キー
static String | SENDBACK_FILTER 差し戻しタスク表示キー
static String | VERSION_CD バージョンコードキー
コンストラクタの概要
SearchCondition()
コンストラクタ

メソッドの概要
String | getActivityCd() 処理タスクコードを返却します。
String | getActivityName() 処理タスク名を返却します。
String | getAgentUserCd() 代理依頼元ユーザコードを返却します。
String | getAgentUserName() 代理依頼元ユーザ名を返却します。
boolean | getAgtCompFilter() 完了タスク表示(委譲)を返却します。
boolean | getAgtGoFilter() 未処理タスク表示(委譲)を返却します。
boolean | getAgtPullbackFilter() 引戻しタスク表示(委譲)を返却します。
boolean | getAgtSendbackFilter() 差し戻しタスク表示(委譲)を返却します。
String | getApprovalCompCd() 処理者の会社コードを返却します。
String | getApprovalDateEnd() 処理日(検索範囲終了日)を返却します。
String | getApprovalDateStart() 処理日(検索範囲開始日)を返却します。
String | getApprovalOrgnCd() 処理者の会社組織コードを返却します。
String | getApprovalOrgnName() 処理者の会社組織名を返却します。
String | getApprovalUserCd() 処理者ユーザコードを返却します。
String | getApprovalUserName() 処理者ユーザ名を返却します。
String | getArriveDateEnd() 到達日(検索範囲終了日)を返却します。
String | getArriveDateStart() 到達日(検索範囲開始日)を返却します。
String | getBeforeUserCd() 前処理者ユーザコードを返却します。
String | getBeforeUserName() 前処理者ユーザ名を返却します。
String | getCategoryCd() カテゴリコードを返却します。
String | getCategoryName() カテゴリ名を返却します。
boolean | getCltAgtCompFilter() 完了タスク表示(代理元処理可委譲)を返却します。
boolean | getCltAgtGoFilter() 未処理タスク表示(代理元処理可委譲)を返却します。
boolean | getCltAgtPullbackFilter() 引戻しタスク表示(代理元処理可委譲)を返却します。
boolean | getCltAgtSendbackFilter() 差し戻しタスク表示(代理元処理可委譲)を返却します。
boolean | getCompFilter() 完了タスク表示を返却します。
String | getDraftAppointDate() 起票指定日を返却します。
String | getDraftCompCd() 起票者の会社コードを返却します。
String | getDraftDateEnd() 起票日(検索範囲終了日)を返却します。
String | getDraftDateStart() 起票日(検索範囲開始日)を返却します。
String | getDraftOrgnCd() 起票者の会社組織コードを返却します。
String | getDraftUserCd() 起票者ユーザコードを返却します。
String | getDraftUserName() 起票者ユーザ名を返却します。
boolean | getGoFilter() 未処理タスク表示を返却します。
String | getLimitDateEnd() 処理期限日(検索範囲終了日)を返却します。
String | getLimitDateStart() 処理期限日(検索範囲開始日)を返却します。
String | getProcessCd() プロセスコードを返却します。
String | getProcessDefCd() プロセス定義コードを返却します。
String | getProcessDefName() プロセス定義名を返却します。
String | getProcessName() プロセス名を返却します。
boolean | getPullbackFilter() 引戻しタスク表示を返却します。
boolean | getSendbackFilter() 差し戻しタスク表示を返却します。
String | getVersionCd() バージョンコードを返却します。
void | setCondition(Map conditionMap) 検索条件を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

GO_FILTER

public static String GO_FILTER
未処理タスク表示キー

AGT_GO_FILTER

public static String AGT_GO_FILTER
未処理タスク表示(委譲)キー

CLT_AGT_GO_FILTER

public static String CLT_AGT_GO_FILTER
未処理タスク表示(代理元承認可委譲)キー

PULLBACK_FILTER

public static String PULLBACK_FILTER
引き戻しタスク表示キー

AGT_PULLBACK_FILTER

public static String AGT_PULLBACK_FILTER
引き戻しタスク表示(委譲)キー

CLT_AGT_PULLBACK_FILTER

public static String CLT_AGT_PULLBACK_FILTER
引き戻しタスク表示(代理元承認可委譲)キー

SENDBACK_FILTER

public static String SENDBACK_FILTER
差し戻しタスク表示キー

AGT_SENDBACK_FILTER

public static String AGT_SENDBACK_FILTER
差し戻しタスク表示(委譲)キー

CLT_AGT_SENDBACK_FILTER

public static String CLT_AGT_SENDBACK_FILTER
差し戻しタスク表示(代理元承認可委譲)キー

COMPLETE_FILTER

public static String COMPLETE_FILTER
完了タスク表示キー

AGT_COMPLETE_FILTER

public static String AGT_COMPLETE_FILTER
完了タスク表示(委譲)キー

CLT_AGT_COMPLETE_FILTER

public static String CLT_AGT_COMPLETE_FILTER
完了タスク表示(代理元承認可委譲)キー

CATEGORY_CD

public static String CATEGORY_CD
カテゴリコードキー

CATEGORY_NAME

public static String CATEGORY_NAME
カテゴリ名キー

PROCESS_DEF_CD

public static String PROCESS_DEF_CD
プロセス定義コードキー

PROCESS_DEF_NAME

public static String PROCESS_DEF_NAME
プロセス定義名キー

VERSION_CD

public static String VERSION_CD
バージョンコードキー

PROCESS_CD

public static String PROCESS_CD
プロセスコードキー

PROCESS_NAME

public static String PROCESS_NAME
プロセス名キー

ACTIVITY_CD

public static String ACTIVITY_CD
処理タスクコードキー

ACTIVITY_NAME

public static String ACTIVITY_NAME
処理タスク名キー

DRAFT_USER_CD

public static String DRAFT_USER_CD
起票ユーザコードキー

DRAFT_USER_NAME

public static String DRAFT_USER_NAME
起票ユーザ名キー

DRAFT_COMP_CD

public static String DRAFT_COMP_CD
起票者の起票会社コードキー

DRAFT_ORGN_CD

public static String DRAFT_ORGN_CD
起票者の起票組織コードキー

DRAFT_APPOINT_DATE

public static String DRAFT_APPOINT_DATE
起票指定日キー

DRAFT_DATE_START

public static String DRAFT_DATE_START
起票日(検索範囲開始日)キー

DRAFT_DATE_END

public static String DRAFT_DATE_END
起票日(検索範囲終了)キー

APPROVAL_USER_CD

public static String APPROVAL_USER_CD
処理者ユーザコードキー

APPROVAL_USER_NAME

public static String APPROVAL_USER_NAME
処理者ユーザ名キー

APPROVAL_COMP_CD

public static String APPROVAL_COMP_CD
処理者の会社コードキー

APPROVAL_ORGN_CD

public static String APPROVAL_ORGN_CD
処理者の組織コードキー

APPROVAL_ORGN_NAME

public static String APPROVAL_ORGN_NAME
処理者の組織名キー

APPROVAL_DATE_START

public static String APPROVAL_DATE_START
処理日(検索範囲開始日)キー

APPROVAL_DATE_END

public static String APPROVAL_DATE_END
処理日(検索範囲終了日)キー

AGENT_USER_CD

public static String AGENT_USER_CD
代理依頼元ユーザコードキー

AGENT_USER_NAME

public static String AGENT_USER_NAME
代理依頼元ユーザ名キー

ARRIVE_DATE_START

public static String ARRIVE_DATE_START
到達日(検索範囲開始日)キー

ARRIVE_DATE_END

public static String ARRIVE_DATE_END
到達日(検索範囲終了日)キー

LIMIT_DATE_START

public static String LIMIT_DATE_START
処理期限日(検索範囲開始日)キー

LIMIT_DATE_END

public static String LIMIT_DATE_END
処理期限日(検索範囲終了日)キー

コンストラクタの詳細

SearchCondition

public SearchCondition()
コンストラクタ

メソッドの詳細

setCondition

public void setCondition(Map conditionMap)
検索条件を設定します。

パラメータ:
conditionMap - 検索条件オブジェクト
conditionMap 検索条件オブジェクト
├go_filter(Boolean) 未処理タスクの表示(本人)
├agt_go_filter(Boolean) 未処理タスクの表示(代理元承認不可)
├clt_agt_go_filter(Boolean) 未処理タスクの表示(代理元承認可)
├pullback_filter(Boolean) 引き戻しタスクの表示(本人)
├agt_pullback_filter(Boolean) 引き戻しタスクの表示(代理元承認不可)
├clt_agt_pullback_filter(Boolean) 引き戻しタスクの表示(代理元承認可)
├sendback_filter(Boolean) 差し戻しタスクの表示(本人)
├agt_sendback_filter(Boolean) 差し戻しタスクの表示(代理元承認不可)
├clt_agt_sendback_filter(Boolean) 差し戻しタスクの表示(代理元承認可)
├complete_filter(Boolean) 完了タスクの表示(本人)
├agt_complete_filter(Boolean) 完了タスクの表示(代理元承認不可)
├clt_agt_complete_filter(Boolean) 完了タスクの表示(代理元承認可)
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_comp_cd(String) 起票者の起票会社コード
├draft_orgn_cd(String) 起票者の起票組織コード
├draft_appoint_date(String) 起票指定日
├draft_date_start(String) 起票日(検索範囲開始日)
├draft_date_end(String) 起票日(検索範囲終了日)
├approval_user_cd(String) 処理者ユーザコード
├approval_user_name(String) 処理者ユーザ名
├approval_comp_cd(String) 処理者の会社コード
├approval_orgn_cd(String) 処理者の会社組織コード
├approval_orgn_name(String) 処理者の会社組織名
├approval_date_start(String) 処理日(検索範囲開始日)
├approval_date_end(String) 処理日(検索範囲終了日)
├agent_user_cd(String) 代理依頼元ユーザコード
├agent_user_name(String) 代理依頼元ユーザ名
├arrive_date_start(String) 到達日(検索範囲開始日)
├arrive_date_end(String) 到達日(検索範囲終了日)
├limit_date_start(String) 処理期限日(検索範囲開始日)
└limit_date_end(String) 処理期限日(検索範囲終了日)

getGoFilter

public boolean getGoFilter()
未処理タスク表示を返却します。

戻り値:
未処理タスク表示

getAgtGoFilter

public boolean getAgtGoFilter()
未処理タスク表示(委譲)を返却します。

戻り値:
未処理タスク表示(委譲)

getCltAgtGoFilter

public boolean getCltAgtGoFilter()
未処理タスク表示(代理元処理可委譲)を返却します。

戻り値:
未処理タスク表示(代理元処理可委譲)

getPullbackFilter

public boolean getPullbackFilter()
引戻しタスク表示を返却します。

戻り値:
引戻しタスク表示

getAgtPullbackFilter

public boolean getAgtPullbackFilter()
引戻しタスク表示(委譲)を返却します。

戻り値:
引戻しタスク表示(委譲)

getCltAgtPullbackFilter

public boolean getCltAgtPullbackFilter()
引戻しタスク表示(代理元処理可委譲)を返却します。

戻り値:
引戻しタスク表示(代理元処理可委譲)

getSendbackFilter

public boolean getSendbackFilter()
差し戻しタスク表示を返却します。

戻り値:
差し戻しタスク表示

getAgtSendbackFilter

public boolean getAgtSendbackFilter()
差し戻しタスク表示(委譲)を返却します。

戻り値:
未処理タスク表示(委譲)

getCltAgtSendbackFilter

public boolean getCltAgtSendbackFilter()
差し戻しタスク表示(代理元処理可委譲)を返却します。

戻り値:
未処理タスク表示(代理元処理可委譲)

getCompFilter

public boolean getCompFilter()
完了タスク表示を返却します。

戻り値:
完了タスク表示

getAgtCompFilter

public boolean getAgtCompFilter()
完了タスク表示(委譲)を返却します。

戻り値:
完了タスク表示(委譲)

getCltAgtCompFilter

public boolean getCltAgtCompFilter()
完了タスク表示(代理元処理可委譲)を返却します。

戻り値:
完了タスク表示(代理元処理可委譲)

getCategoryCd

public String getCategoryCd()
カテゴリコードを返却します。

戻り値:
カテゴリコード

getCategoryName

public String getCategoryName()
カテゴリ名を返却します。

戻り値:
カテゴリ名

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを返却します。

戻り値:
プロセス定義コード

getProcessDefName

public String getProcessDefName()
プロセス定義名を返却します。

戻り値:
プロセス定義名

getVersionCd

public String getVersionCd()
バージョンコードを返却します。

戻り値:
バージョンコード

getProcessCd

public String getProcessCd()
プロセスコードを返却します。

戻り値:
プロセスコード

getProcessName

public String getProcessName()
プロセス名を返却します。

戻り値:
プロセス名

getActivityCd

public String getActivityCd()
処理タスクコードを返却します。

戻り値:
処理タスクコード

getActivityName

public String getActivityName()
処理タスク名を返却します。

戻り値:
処理タスク名

getDraftUserCd

public String getDraftUserCd()
起票者ユーザコードを返却します。

戻り値:
起票者ユーザコード

getDraftUserName

public String getDraftUserName()
起票者ユーザ名を返却します。

戻り値:
起票者ユーザ名

getDraftCompCd

public String getDraftCompCd()
起票者の会社コードを返却します。

戻り値:
起票者の会社コード

getDraftOrgnCd

public String getDraftOrgnCd()
起票者の会社組織コードを返却します。

戻り値:
起票者の会社組織コード

getDraftAppointDate

public String getDraftAppointDate()
起票指定日を返却します。

戻り値:
起票指定日

getDraftDateStart

public String getDraftDateStart()
起票日(検索範囲開始日)を返却します。

戻り値:
起票日(検索範囲開始日)

getDraftDateEnd

public String getDraftDateEnd()
起票日(検索範囲終了日)を返却します。

戻り値:
起票日(検索範囲終了日)

getBeforeUserCd

public String getBeforeUserCd()
前処理者ユーザコードを返却します。

戻り値:
前処理者ユーザコード

getBeforeUserName

public String getBeforeUserName()
前処理者ユーザ名を返却します。

戻り値:
前処理者ユーザ名

getApprovalUserCd

public String getApprovalUserCd()
処理者ユーザコードを返却します。

戻り値:
処理者ユーザコード

getApprovalUserName

public String getApprovalUserName()
処理者ユーザ名を返却します。

戻り値:
処理者ユーザ名

getApprovalCompCd

public String getApprovalCompCd()
処理者の会社コードを返却します。

戻り値:
処理者の会社コード

getApprovalOrgnCd

public String getApprovalOrgnCd()
処理者の会社組織コードを返却します。

戻り値:
処理者の会社組織コード

getApprovalOrgnName

public String getApprovalOrgnName()
処理者の会社組織名を返却します。

戻り値:
処理者の会社組織名

getApprovalDateStart

public String getApprovalDateStart()
処理日(検索範囲開始日)を返却します。

戻り値:
処理日(検索範囲開始日)

getApprovalDateEnd

public String getApprovalDateEnd()
処理日(検索範囲終了日)を返却します。

戻り値:
処理日(検索範囲終了日)

getAgentUserCd

public String getAgentUserCd()
代理依頼元ユーザコードを返却します。

戻り値:
代理依頼元ユーザコード

getAgentUserName

public String getAgentUserName()
代理依頼元ユーザ名を返却します。

戻り値:
代理依頼元ユーザ名

getArriveDateStart

public String getArriveDateStart()
到達日(検索範囲開始日)を返却します。

戻り値:
到達日(検索範囲開始日)

getArriveDateEnd

public String getArriveDateEnd()
到達日(検索範囲終了日)を返却します。

戻り値:
検索範囲終了日

getLimitDateStart

public String getLimitDateStart()
処理期限日(検索範囲開始日)を返却します。

戻り値:
処理期限日(検索範囲開始日)

getLimitDateEnd

public String getLimitDateEnd()
処理期限日(検索範囲終了日)を返却します。

戻り値:
処理期限日(検索範囲終了日)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


Sort (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf.support
クラス Sort

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.support.Sort
public class Sort
extends Object

プログラムサポート/ソート指定オブジェクト。
ソート対象は各検索メソッドの戻り値がソート対象となります。

コンストラクタの概要
Sort()
コンストラクタ

メソッドの概要
String | getAscending() 昇順ソートキーを返却します。
String | getDescending() 降順ソートキーを返却します。
void | setAscending(String sort_key) 昇順ソートキーを設定します。
void | setDescending(String sort_key) 降順ソートキーを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Sort

public Sort()
コンストラクタ

メソッドの詳細

getAscending

public String getAscending()
昇順ソートキーを返却します。

戻り値:
昇順ソートキー

setAscending

public void setAscending(String sort_key)
昇順ソートキーを設定します。
ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを昇順ソートキーとする場合、setAscending(”category_cd”)と記述してください。

パラメータ:
sort_key - 昇順ソートキー

getDescending

public String getDescending()
降順ソートキーを返却します。

戻り値:
降順ソートキー

setDescending

public void setDescending(String sort_key)
降順ソートキーを設定します。
ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを降順ソートキーとする場合、setDescending(”category_cd”)と記述してください。

パラメータ:
sort_key - 降順ソートキー
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


ActivityTaskModel (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス ActivityTaskModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.ActivityTaskModel
直系の既知のサブクラス:
ReceiveTaskModel
public class ActivityTaskModel
extends Object

タスク情報を保持するクラス

フィールドの概要
static String | ACTIVITY_TYPE_EMPTY タスク種別：手動タスク
static String | ACTIVITY_TYPE_FLOW タスク種別：同期タスク（ワークフローデザイナー、BPW）
static String | ACTIVITY_TYPE_INVOKE_AUTO タスク種別：自動実行タスク（BPWのみ）
static String | ACTIVITY_TYPE_INVOKE_EVENT タスク種別：イベント実行タスク（BPWのみ）
static String | ACTIVITY_TYPE_INVOKE_PROCESS タスク種別：サブプロセス呼出タスク
static String | ACTIVITY_TYPE_RECEIVE タスク種別：処理(申請・承認)タスク
static String | ACTIVITY_TYPE_ROUTE_SELECT タスク種別：ルート選択タスク
static String | ACTIVITY_TYPE_SWITCH タスク種別：分岐タスク（ワークフローデザイナー、BPW）
コンストラクタの概要
ActivityTaskModel()
コンストラクタ

メソッドの概要
String | getActivityName() タスク名を取得します。
String | getActivityType() タスク種別を取得します。
void | setActivityName(String activity_name) タスク名を設定します。
void | setActivityType(String activity_type) タスク種別を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ACTIVITY_TYPE_RECEIVE

public static final String ACTIVITY_TYPE_RECEIVE
タスク種別：処理(申請・承認)タスク

関連項目:
定数フィールド値

ACTIVITY_TYPE_INVOKE_PROCESS

public static final String ACTIVITY_TYPE_INVOKE_PROCESS
タスク種別：サブプロセス呼出タスク

関連項目:
定数フィールド値

ACTIVITY_TYPE_INVOKE_EVENT

public static final String ACTIVITY_TYPE_INVOKE_EVENT
タスク種別：イベント実行タスク（BPWのみ）

関連項目:
定数フィールド値

ACTIVITY_TYPE_INVOKE_AUTO

public static final String ACTIVITY_TYPE_INVOKE_AUTO
タスク種別：自動実行タスク（BPWのみ）

関連項目:
定数フィールド値

ACTIVITY_TYPE_FLOW

public static final String ACTIVITY_TYPE_FLOW
タスク種別：同期タスク（ワークフローデザイナー、BPW）

関連項目:
定数フィールド値

ACTIVITY_TYPE_SWITCH

public static final String ACTIVITY_TYPE_SWITCH
タスク種別：分岐タスク（ワークフローデザイナー、BPW）

関連項目:
定数フィールド値

ACTIVITY_TYPE_EMPTY

public static final String ACTIVITY_TYPE_EMPTY
タスク種別：手動タスク

関連項目:
定数フィールド値

ACTIVITY_TYPE_ROUTE_SELECT

public static final String ACTIVITY_TYPE_ROUTE_SELECT
タスク種別：ルート選択タスク

関連項目:
定数フィールド値
コンストラクタの詳細

ActivityTaskModel

public ActivityTaskModel()
コンストラクタ

メソッドの詳細

getActivityName

public String getActivityName()
タスク名を取得します。

戻り値:
タスク名

setActivityName

public void setActivityName(String activity_name)
タスク名を設定します。

パラメータ:
activity_name - タスク名

getActivityType

public String getActivityType()
タスク種別を取得します。

戻り値:
タスク種別

setActivityType

public void setActivityType(String activity_type)
タスク種別を設定します。

パラメータ:
activity_type - タスク種別
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


AgentSetting (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス AgentSetting

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.AgentSetting
public class AgentSetting
extends Object

代理設定関連のAPI
代理設定関連処理で使用されるクラスです。

コンストラクタの概要
AgentSetting(String user_cd, String login_group_id)
コンストラクタ

メソッドの概要
void | cancelAgent(TransferInfoModel transferInfo) 代理設定を解除します。
List | getTransferActivityList(String process_def_cd, String version_cd) タスク委譲情報一覧を取得します。
TransferInfoModel | getTransferInfo(String process_def_cd, String version_cd, String activity_cd, String target_date) 指定された日付に有効な代理設定情報を返却します。
List | getTransferProcessDefList(String category_cd) プロセス定義委譲情報一覧を取得します。
List | getTransferVersionList(String process_def_cd) バージョン委譲情報一覧を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
void | setAgent(TransferInfoModel transferInfo) 代理設定を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

AgentSetting

public AgentSetting(String user_cd,
                    String login_group_id)
             throws WKFApplicationException
コンストラクタ

パラメータ:
user_cd - ユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。

getTransferInfo

public TransferInfoModel getTransferInfo(String process_def_cd,
                                         String version_cd,
                                         String activity_cd,
                                         String target_date)
                                  throws WKFApplicationException
指定された日付に有効な代理設定情報を返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
activity_cd - アクティビティコード(必須)
target_date - 代理対象日付(必須)
戻り値:
TransferInfoModel 代理設定情報モデル
例外:
WKFApplicationException

getTransferProcessDefList

public List getTransferProcessDefList(String category_cd)
                               throws WKFApplicationException
プロセス定義委譲情報一覧を取得します。

パラメータ:
category_cd - カテゴリコード
戻り値:
List プロセス定義委譲情報配列
例外:
WKFApplicationException

getTransferVersionList

public List getTransferVersionList(String process_def_cd)
                            throws WKFApplicationException
バージョン委譲情報一覧を取得します。

パラメータ:
process_def_cd - プロセス定義コード
戻り値:
List バージョン委譲情報配列
例外:
WKFApplicationException

getTransferActivityList

public List getTransferActivityList(String process_def_cd,
                                    String version_cd)
                             throws WKFApplicationException
タスク委譲情報一覧を取得します。

パラメータ:
process_def_cd - プロセス定義コード
version_cd - バージョンコード
戻り値:
List タスク委譲情報配列
例外:
WKFApplicationException

setAgent

public void setAgent(TransferInfoModel transferInfo)
              throws WKFApplicationException
代理設定を設定します。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。

パラメータ:
transferInfo - 代理設定情報モデル
例外:
WKFApplicationException

cancelAgent

public void cancelAgent(TransferInfoModel transferInfo)
                 throws WKFApplicationException
代理設定を解除します。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。

パラメータ:
transferInfo - 代理設定情報モデル
例外:
WKFApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Approver (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Approver

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Approver
public class Approver
extends Object

承認関連のAPI
承認関連の処理に使用されるクラスです。

<サンプル>

フィールドの概要
static String | AGT_ALL 代理依頼されたもの全て表示(代理のみ使用)
static String | RETURN_TYPE_BEFORE 差戻し種別：前処理者へ差戻し
static String | RETURN_TYPE_START 差戻し種別：申請者へ差戻し
static String | RETURN_TYPE_TASK 差戻し種別：任意の処理者へ差戻し
コンストラクタの概要
Approver(String user_cd, String login_group_id)
コンストラクタ１(本人用)
Approver(String agent_user_cd, String user_cd, String login_group_id)
コンストラクタ２(代理人用)。
メソッドの概要
void | approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 approve メソッドを使用してください。
void | approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) 承認処理を実行します。
void | denial(String process_def_cd, String version_cd, String process_cd, String activity_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 否認処理を実行します。
List | getActivityTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理可能案件(未処理案件)一覧の取得を行います。
List | getEndTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 処理済案件一覧の取得を行います。
List | getTargetDepartment(String process_def_cd, String version_cd, String process_cd, String activity_cd) 所属組織を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
void | pullBack(String process_def_cd, String version_cd, String process_cd, String activity_cd) 引き戻し処理を実行します。
void | sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, NegoModel nego) 推奨されていません。 sendBack メソッドを使用してください。
void | sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, NegoModel nego, String send_back_process_def_cd, String send_back_version_cd, String send_back_process_cd, String send_back_activity_cd) 差し戻し処理を実行します。
void | suspend(String process_def_cd, String version_cd, String process_cd, String activity_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 保留処理を実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

AGT_ALL

public static final String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)

関連項目:
定数フィールド値

RETURN_TYPE_START

public static final String RETURN_TYPE_START
差戻し種別：申請者へ差戻し

関連項目:
定数フィールド値

RETURN_TYPE_BEFORE

public static final String RETURN_TYPE_BEFORE
差戻し種別：前処理者へ差戻し

関連項目:
定数フィールド値

RETURN_TYPE_TASK

public static final String RETURN_TYPE_TASK
差戻し種別：任意の処理者へ差戻し

関連項目:
定数フィールド値
コンストラクタの詳細

Approver

public Approver(String user_cd,
                String login_group_id)
         throws WKFApplicationException
コンストラクタ１(本人用)

パラメータ:
user_cd - 承認者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード

Approver

public Approver(String agent_user_cd,
                String user_cd,
                String login_group_id)
         throws WKFApplicationException
コンストラクタ２(代理人用)。
代理依頼されたもの全てを表示する際は、user_cdに「Approver.AGT_ALL」を指定してください。
ただし、AGT_ALLを指定すると承認などの一覧検索以外のメソッドは使えません。

パラメータ:
agent_user_cd - 代理承認者のユーザID(必須)
user_cd - 本来の処理者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。

approve

public void approve(String process_def_cd,
                    String version_cd,
                    String process_cd,
                    String activity_cd,
                    Boolean isFinish,
                    String comp_cd,
                    String orgn_cd,
                    String comment,
                    NegoModel nego,
                    RunExecutiveInfoModel executant,
                    String route_select_cd)
             throws WKFApplicationException
推奨されていません。 approve メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
isFinish - 途中終了フラグ(任意：未指定時は途中終了しない)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

approve

public void approve(String process_def_cd,
                    String version_cd,
                    String process_cd,
                    String activity_cd,
                    Boolean isFinish,
                    String comp_cd,
                    String orgn_cd,
                    String comment,
                    NegoModel nego,
                    RunExecutiveInfoModel executant,
                    String route_select_cd,
                    CreateRouteInfoModel route_info)
             throws WKFApplicationException
承認処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合の使用します。
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
isFinish - 途中終了フラグ(任意：未指定時は途中終了しない)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
route_info - ルート作成情報(次タスクがルート作成時)
例外:
WKFApplicationException - エラーコード

approve

public void approve(String process_def_cd,
                    String version_cd,
                    String process_cd,
                    String activity_cd,
                    Boolean isFinish,
                    String comp_cd,
                    String orgn_cd,
                    String comment,
                    NegoModel nego,
                    RunUserInfoModel executant,
                    String route_select_cd)
             throws WKFApplicationException
推奨されていません。 approve メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
isFinish - 途中終了フラグ(任意：未指定時は途中終了しない)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

approve

public void approve(String process_def_cd,
                    String version_cd,
                    String process_cd,
                    String activity_cd,
                    Boolean isFinish,
                    String comp_cd,
                    String orgn_cd,
                    String comment,
                    NegoModel nego,
                    RunUserInfoModel executant,
                    String route_select_cd,
                    CreateRouteInfoModel route_info)
             throws WKFApplicationException
承認処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合に使用します。
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
isFinish - 途中終了フラグ(任意：未指定時は途中終了しない)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
route_info - ルート作成情報(次タスクがルート作成時)
例外:
WKFApplicationException - エラーコード

denial

public void denial(String process_def_cd,
                   String version_cd,
                   String process_cd,
                   String activity_cd,
                   String comp_cd,
                   String orgn_cd,
                   String comment,
                   NegoModel nego)
            throws WKFApplicationException
否認処理を実行します。
処理失敗時は、Exceptionを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

suspend

public void suspend(String process_def_cd,
                    String version_cd,
                    String process_cd,
                    String activity_cd,
                    String comp_cd,
                    String orgn_cd,
                    String comment,
                    NegoModel nego)
             throws WKFApplicationException
保留処理を実行します。
処理失敗時は、Exceptiopnを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

sendBack

public void sendBack(String process_def_cd,
                     String version_cd,
                     String process_cd,
                     String activity_cd,
                     String type,
                     String comp_cd,
                     String orgn_cd,
                     String comment,
                     NegoModel nego)
              throws WKFApplicationException
推奨されていません。 sendBack メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
type - 差戻し先(必須 start:申請者,before:前処理者)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

sendBack

public void sendBack(String process_def_cd,
                     String version_cd,
                     String process_cd,
                     String activity_cd,
                     String type,
                     String comp_cd,
                     String orgn_cd,
                     String comment,
                     NegoModel nego,
                     String send_back_process_def_cd,
                     String send_back_version_cd,
                     String send_back_process_cd,
                     String send_back_activity_cd)
              throws WKFApplicationException
差し戻し処理を実行します。
処理失敗時は、Exceptiopnを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
type - 差戻し先(必須 start:申請者,before:前処理者,task:任意の処理者)
comp_cd - ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment - 承認コメント(任意)
nego - 根回しメールオブジェクト(任意)
send_back_process_def_cd - 差し戻し先プロセス定義コード(任意：任意の処理者へ差し戻しの場合に必須)
send_back_version_cd - 差し戻し先バージョンコード(任意：任意の処理者へ差し戻しの場合に必須)
send_back_process_cd - 差し戻し先プロセスコード(任意：任意の処理者へ差し戻しの場合に必須)
send_back_activity_cd - 差し戻し先アクティビティコード(任意：任意の処理者へ差し戻しの場合に必須)
例外:
WKFApplicationException - エラーコード

pullBack

public void pullBack(String process_def_cd,
                     String version_cd,
                     String process_cd,
                     String activity_cd)
              throws WKFApplicationException
引き戻し処理を実行します。
処理失敗時は、Exceptiopnを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
例外:
WKFApplicationException - エラーコード

getActivityTaskList

public List getActivityTaskList(SearchCondition condition_key,
                                Sort[] sort_key,
                                int start,
                                int amount)
処理可能案件(未処理案件)一覧の取得を行います。
処理可能案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 処理可能案件情報オブジェクト配列
Map 処理可能案件オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_status(String) アクティビティステータス
├attainment_class(String) 到達種別
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├reception_date(String) 受信日付
├process_term_date(String) 処理期限日付
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
├client_user_cd(String) 代理依頼元ユーザコード(代理人用でインスタンス作成時)
├client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)
├next_activity_type(String) 次タスクのタスク種別
└compulsion_end_flg(Boolean) 強制終了可否フラグ

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getEndTaskList

public List getEndTaskList(SearchCondition condition_key,
                           Sort[] sort_key,
                           int start,
                           int amount)
処理済案件一覧の取得を行います。
処理済案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 処理済案件情報オブジェクト配列
Map 処理済案件情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├process_end_status(String) プロセス終了ステータス
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_user_comp_cd(String) 起票者の処理時の会社コード
├draft_user_orgn_cd(String) 起票者の処理時の組織コード
├draft_user_main_flg(String) 主・副所属フラグ
├isJunction(Boolean) ルートが同期していればtrue
├approval_type(String) 処理結果
├approval_user_cd(String) 処理ユーザコード
├approval_user_name(String) 処理ユーザ名
├approval_date(String) 処理日
├approval_transfer_flg(Boolean) 承認結果履歴代理フラグ
├processing_status(String) 現在の状態
├approval_agent_user_cd(String) 承認代理元ユーザコード(代理人用でインスタンス作成時)
├approval_agent_user_name(String) 承認代理元ユーザ名(代理人用でインスタンス作成時)
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
└pull_activity_flg(Boolean) 引き戻し可否フラグ(true:可/false:不可)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getTargetDepartment

public List getTargetDepartment(String process_def_cd,
                                String version_cd,
                                String process_cd,
                                String activity_cd)
所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
審議時など、既にプロセスコードがふられているに使用します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
戻り値:
所属組織情報オブジェクト配列 Map 所属組織情報オブジェクト
├company_cd(String) 会社コード
├department_cd(String) 組織コード
└department_name(String) 組織名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContentsPathDetailModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス ContentsPathDetailModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel
public class ContentsPathDetailModel
extends Object

コンテンツパス詳細情報を保持するクラス

フィールドの概要
static String | PAGE_KIND_FRAME_WORK ページ種別：J2EEフレームワーク
static String | PAGE_KIND_PRESENTAION_PAGE ページ種別：プレゼンテーションページ
static String | PAGE_KIND_SERVLET ページ種別：サーブレット
コンストラクタの概要
ContentsPathDetailModel()
コンストラクタ

メソッドの概要
String | getApplicationId() アプリケーションIDを取得します。
String | getContentsPath() コンテンツパスを取得します。
String | getPageKind() ページ種別を取得します。
String | getServiceId() サービスIDを取得します。
void | setApplicationId(String application_id) アプリケーションIDを設定します。
void | setContentsPath(String contents_path) コンテンツパスを設定します。
void | setPageKind(String page_kind) ページ種別を設定します。
void | setServiceId(String service_id) サービスIDを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PAGE_KIND_PRESENTAION_PAGE

public static final String PAGE_KIND_PRESENTAION_PAGE
ページ種別：プレゼンテーションページ

関連項目:
定数フィールド値

PAGE_KIND_SERVLET

public static final String PAGE_KIND_SERVLET
ページ種別：サーブレット

関連項目:
定数フィールド値

PAGE_KIND_FRAME_WORK

public static final String PAGE_KIND_FRAME_WORK
ページ種別：J2EEフレームワーク

関連項目:
定数フィールド値
コンストラクタの詳細

ContentsPathDetailModel

public ContentsPathDetailModel()
コンストラクタ

メソッドの詳細

getApplicationId

public String getApplicationId()
アプリケーションIDを取得します。

戻り値:
アプリケーションID

setApplicationId

public void setApplicationId(String application_id)
アプリケーションIDを設定します。

パラメータ:
application_id - アプリケーションID

getContentsPath

public String getContentsPath()
コンテンツパスを取得します。

戻り値:
コンテンツパス

setContentsPath

public void setContentsPath(String contents_path)
コンテンツパスを設定します。

パラメータ:
contents_path - コンテンツパス

getPageKind

public String getPageKind()
ページ種別を取得します。

戻り値:
ページ種別

setPageKind

public void setPageKind(String page_kind)
ページ種別を設定します。

パラメータ:
page_kind - ページ種別

getServiceId

public String getServiceId()
サービスIDを取得します。

戻り値:
サービスID

setServiceId

public void setServiceId(String service_id)
サービスIDを設定します。

パラメータ:
service_id - サービスID
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ContentsPathModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス ContentsPathModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.ContentsPathModel
public class ContentsPathModel
extends Object

コンテンツパス設定情報を保持するクラス

コンストラクタの概要
ContentsPathModel()
コンストラクタ

メソッドの概要
ContentsPathDetailModel | getApplyPath() 通常コンテンツパスを返却します。
ContentsPathDetailModel | getDetailPath() 詳細コンテンツパスを返却します。
ContentsPathDetailModel | getPullPath() 引戻しコンテンツパスを返却します。
ContentsPathDetailModel | getReferPath() 参照コンテンツパスを返却します。
ContentsPathDetailModel | getReturnPath() 差戻しコンテンツパスを返却します。
void | setApplyPath(ContentsPathDetailModel apply_path) 通常コンテンツパスを設定します。
void | setDetailPath(ContentsPathDetailModel detail_path) 詳細コンテンツパスを設定します。
void | setPullPath(ContentsPathDetailModel pull_path) 引戻しコンテンツパスを設定します。
void | setReferPath(ContentsPathDetailModel refer_path) 参照コンテンツパスを設定します。
void | setReturnPath(ContentsPathDetailModel return_path) 差戻しコンテンツパスを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

ContentsPathModel

public ContentsPathModel()
コンストラクタ

メソッドの詳細

getApplyPath

public ContentsPathDetailModel getApplyPath()
通常コンテンツパスを返却します。

戻り値:
通常コンテンツパス

setApplyPath

public void setApplyPath(ContentsPathDetailModel apply_path)
通常コンテンツパスを設定します。

パラメータ:
apply_path - 通常コンテンツパス

getDetailPath

public ContentsPathDetailModel getDetailPath()
詳細コンテンツパスを返却します。

戻り値:
詳細コンテンツパス

setDetailPath

public void setDetailPath(ContentsPathDetailModel detail_path)
詳細コンテンツパスを設定します。
プロセスコンテンツパスを指定する時に使用します。

パラメータ:
detail_path - 詳細コンテンツパス

getPullPath

public ContentsPathDetailModel getPullPath()
引戻しコンテンツパスを返却します。

戻り値:
引戻しコンテンツパス

setPullPath

public void setPullPath(ContentsPathDetailModel pull_path)
引戻しコンテンツパスを設定します。

パラメータ:
pull_path - 引戻しコンテンツパス

getReferPath

public ContentsPathDetailModel getReferPath()
参照コンテンツパスを返却します。

戻り値:
参照コンテンツパス

setReferPath

public void setReferPath(ContentsPathDetailModel refer_path)
参照コンテンツパスを設定します。
プロセスコンテンツパスを指定する時に使用します。

パラメータ:
refer_path - 参照コンテンツパス

getReturnPath

public ContentsPathDetailModel getReturnPath()
差戻しコンテンツパスを返却します。

戻り値:
差戻しコンテンツパス

setReturnPath

public void setReturnPath(ContentsPathDetailModel return_path)
差戻しコンテンツパスを設定します。

パラメータ:
return_path - 差戻しコンテンツパス
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreateRouteInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス CreateRouteInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel
public class CreateRouteInfoModel
extends Object

コンストラクタの概要
CreateRouteInfoModel()
メソッドの概要
void | addCreateRouteTargetList(CreateRouteTargetInfoModel info) 対象者情報を追加します。
ArrayList | getCreateRouteTargetList() 対象者情報配列を返却します。
String | getProcessDefCd() プロセス定義コードを取得します。
String | getVersionCd() バージョンコードを取得します。
void | setProcessDefCd(String processDefCd) プロセス定義コードを設定します。
void | setVersionCd(String versionCd) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

CreateRouteInfoModel

public CreateRouteInfoModel()
メソッドの詳細

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを取得します。

戻り値:
プロセス定義コード

setProcessDefCd

public void setProcessDefCd(String processDefCd)
プロセス定義コードを設定します。

パラメータ:
processDefCd - プロセス定義コード

getVersionCd

public String getVersionCd()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCd

public void setVersionCd(String versionCd)
バージョンコードを設定します。

パラメータ:
versionCd - バージョンコード

getCreateRouteTargetList

public ArrayList getCreateRouteTargetList()
対象者情報配列を返却します。

戻り値:
対象者情報配列

addCreateRouteTargetList

public void addCreateRouteTargetList(CreateRouteTargetInfoModel info)
対象者情報を追加します。

パラメータ:
info - 対象者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


CreateRouteTargetInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス CreateRouteTargetInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel
public class CreateRouteTargetInfoModel
extends Object

ルート作成時、設定情報を保持するクラス

フィールドの概要
static String | TARGET_TYPE_OFFICIAL 対象者種別：オフィシャルグループ
static String | TARGET_TYPE_ORGN 対象者種別：組織
static String | TARGET_TYPE_USER 対象者種別：ユーザ
コンストラクタの概要
CreateRouteTargetInfoModel()
メソッドの概要
String | getActivityCd() アクティビティコードを取得します。
String | getNarrowPostCd() 絞り込み役職コードを取得します。
String | getTargetCd() 対象者コードを取得します。
String | getTargetGroupCd() 対象者グループコードを取得します。
String | getTargetType() 対象者種別を設定します。
void | setActivityCd(String activityCd) アクティビティコードを設定します。
void | setNarrowPostCd(String narrowPostCd) 絞り込み役職コードを設定します。
void | setTargetCd(String targetCd) 対象者コードを設定します。
void | setTargetGroupCd(String targetGroupCd) 対象者グループコードを設定します。
void | setTargetType(String targetType) 対象者種別を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TARGET_TYPE_USER

public static final String TARGET_TYPE_USER
対象者種別：ユーザ

関連項目:
定数フィールド値

TARGET_TYPE_ORGN

public static final String TARGET_TYPE_ORGN
対象者種別：組織

関連項目:
定数フィールド値

TARGET_TYPE_OFFICIAL

public static final String TARGET_TYPE_OFFICIAL
対象者種別：オフィシャルグループ

関連項目:
定数フィールド値
コンストラクタの詳細

CreateRouteTargetInfoModel

public CreateRouteTargetInfoModel()
メソッドの詳細

getActivityCd

public String getActivityCd()
アクティビティコードを取得します。

戻り値:
アクティビティコード

setActivityCd

public void setActivityCd(String activityCd)
アクティビティコードを設定します。

パラメータ:
activityCd - アクティビティコード

getNarrowPostCd

public String getNarrowPostCd()
絞り込み役職コードを取得します。

戻り値:
絞り込み役職コード

setNarrowPostCd

public void setNarrowPostCd(String narrowPostCd)
絞り込み役職コードを設定します。

パラメータ:
narrowPostCd - 絞り込み役職コード

getTargetCd

public String getTargetCd()
対象者コードを取得します。

戻り値:
対象者コード

setTargetCd

public void setTargetCd(String targetCd)
対象者コードを設定します。

パラメータ:
targetCd - 対象者コード

getTargetGroupCd

public String getTargetGroupCd()
対象者グループコードを取得します。

戻り値:
対象者グループコード

setTargetGroupCd

public void setTargetGroupCd(String targetGroupCd)
対象者グループコードを設定します。

パラメータ:
targetGroupCd - 対象者グループコード

getTargetType

public String getTargetType()
対象者種別を設定します。

戻り値:
対象者種別

setTargetType

public void setTargetType(String targetType)
対象者種別を設定します。

パラメータ:
targetType - 対象者種別
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Drafter (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Drafter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Drafter
public class Drafter
extends Object

起票関連のAPI
起票関連の処理に使用されるクラスです。

<サンプル>

フィールドの概要
static String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)
コンストラクタの概要
Drafter(String user_cd, String login_group_id)
コンストラクタ１(本人用)
Drafter(String agent_user_cd, String user_cd, String login_group_id)
コンストラクタ２(代理人用)。
メソッドの概要
void | cancel(String process_def_cd, String version_cd, String process_cd, String comp_cd, String orgn_cd, String comment, NegoModel nego) 取り止め処理を実行します。
ProcessInfoModel | draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
ProcessInfoModel | draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 draft メソッドを使用してください。
ProcessInfoModel | draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 起票処理を実行します。
List | getActivityProcessDefList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, String locale) 起票可能プロセス一覧を取得します。
List | getEndProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 起票済み案件を取得します。
List | getTargetDepartment(String process_def_cd, String version_cd, String activity_cd, String target_date) 所属組織を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
void | pullBack(String process_def_cd, String version_cd, String process_cd) 引戻し処理を実行します。
void | retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale) 推奨されていません。 retry メソッドを使用してください。
void | retry(String process_def_cd, String version_cd, String process_cd, String process_name, List app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, String locale, CreateRouteInfoModel route_info) 再起票処理を実行します。
void | subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunExecutiveInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
void | subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd) 推奨されていません。 subProcessDraft メソッドを使用してください。
void | subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, List app_key, String comp_cd, String orgn_cd, String comment, NegoModel nego, RunUserInfoModel executant, String route_select_cd, CreateRouteInfoModel route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

AGT_ALL

public static final String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)

関連項目:
定数フィールド値
コンストラクタの詳細

Drafter

public Drafter(String user_cd,
               String login_group_id)
        throws WKFApplicationException
コンストラクタ１(本人用)

パラメータ:
user_cd - 起票者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード

Drafter

public Drafter(String agent_user_cd,
               String user_cd,
               String login_group_id)
        throws WKFApplicationException
コンストラクタ２(代理人用)。
代理依頼されたもの全てを表示する際は、user_cdに「Drafter.AGT_ALL」を指定してください。
ただし、AGT_ALLを指定すると承認などの一覧検索以外のメソッドは使えません。

パラメータ:
agent_user_cd - 代理起票者のユーザID(必須)
user_cd - 本来の起票者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。

draft

public ProcessInfoModel draft(String process_def_cd,
                              String version_cd,
                              String process_temporary_cd,
                              String process_name,
                              List app_key,
                              String draft_appoint_date,
                              String comp_cd,
                              String orgn_cd,
                              String comment,
                              NegoModel nego,
                              RunExecutiveInfoModel executant,
                              String route_select_cd,
                              String locale)
                       throws WKFApplicationException
推奨されていません。 draft メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：未指定時は起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
戻り値:
ProcessInfoModel プロセス情報
例外:
WKFApplicationException - エラーコード

draft

public ProcessInfoModel draft(String process_def_cd,
                              String version_cd,
                              String process_temporary_cd,
                              String process_name,
                              List app_key,
                              String draft_appoint_date,
                              String comp_cd,
                              String orgn_cd,
                              String comment,
                              NegoModel nego,
                              RunExecutiveInfoModel executant,
                              String route_select_cd,
                              String locale,
                              CreateRouteInfoModel route_info)
                       throws WKFApplicationException
起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：未指定時は起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
route_info - ルート作成情報(次タスクがルート作成時)
戻り値:
ProcessInfoModel プロセス情報
例外:
WKFApplicationException - エラーコード

draft

public ProcessInfoModel draft(String process_def_cd,
                              String version_cd,
                              String process_temporary_cd,
                              String process_name,
                              List app_key,
                              String draft_appoint_date,
                              String comp_cd,
                              String orgn_cd,
                              String comment,
                              NegoModel nego,
                              RunUserInfoModel executant,
                              String route_select_cd,
                              String locale)
                       throws WKFApplicationException
推奨されていません。 draft メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：未指定時は起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
戻り値:
ProcessInfoModel プロセス情報
例外:
WKFApplicationException - エラーコード

draft

public ProcessInfoModel draft(String process_def_cd,
                              String version_cd,
                              String process_temporary_cd,
                              String process_name,
                              List app_key,
                              String draft_appoint_date,
                              String comp_cd,
                              String orgn_cd,
                              String comment,
                              NegoModel nego,
                              RunUserInfoModel executant,
                              String route_select_cd,
                              String locale,
                              CreateRouteInfoModel route_info)
                       throws WKFApplicationException
起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：未指定時は起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
route_info - ルート作成情報(次タスクがルート作成時)
戻り値:
ProcessInfoModel プロセス情報
例外:
WKFApplicationException - エラーコード

retry

public void retry(String process_def_cd,
                  String version_cd,
                  String process_cd,
                  String process_name,
                  List app_key,
                  String draft_appoint_date,
                  String comp_cd,
                  String orgn_cd,
                  String comment,
                  NegoModel nego,
                  RunExecutiveInfoModel executant,
                  String route_select_cd,
                  String locale)
           throws WKFApplicationException
推奨されていません。 retry メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 再起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd - ルート選択番号(引戻しされたタスクで、次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
例外:
WKFApplicationException - エラーコード

retry

public void retry(String process_def_cd,
                  String version_cd,
                  String process_cd,
                  String process_name,
                  List app_key,
                  String draft_appoint_date,
                  String comp_cd,
                  String orgn_cd,
                  String comment,
                  NegoModel nego,
                  RunExecutiveInfoModel executant,
                  String route_select_cd,
                  String locale,
                  CreateRouteInfoModel route_info)
           throws WKFApplicationException
再起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合の使用します。
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 再起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd - ルート選択番号(引戻しされたタスクで、次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
route_info - ルート作成情報(次タスクがルート作成時)
例外:
WKFApplicationException - エラーコード

retry

public void retry(String process_def_cd,
                  String version_cd,
                  String process_cd,
                  String process_name,
                  List app_key,
                  String draft_appoint_date,
                  String comp_cd,
                  String orgn_cd,
                  String comment,
                  NegoModel nego,
                  RunUserInfoModel executant,
                  String route_select_cd,
                  String locale)
           throws WKFApplicationException
推奨されていません。 retry メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 再起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd - ルート選択番号(引戻しされたタスクで、次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
例外:
WKFApplicationException - エラーコード

retry

public void retry(String process_def_cd,
                  String version_cd,
                  String process_cd,
                  String process_name,
                  List app_key,
                  String draft_appoint_date,
                  String comp_cd,
                  String orgn_cd,
                  String comment,
                  NegoModel nego,
                  RunUserInfoModel executant,
                  String route_select_cd,
                  String locale,
                  CreateRouteInfoModel route_info)
           throws WKFApplicationException
再起票処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合の使用します。
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
draft_appoint_date - 起票指定日(任意：起票日と同日)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 再起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd - ルート選択番号(引戻しされたタスクで、次タスクがユーザ選択時)
locale - ロケール(任意：なければデフォルトロケールを使用)
route_info - ルート作成情報(次タスクがルート作成時)
例外:
WKFApplicationException - エラーコード

cancel

public void cancel(String process_def_cd,
                   String version_cd,
                   String process_cd,
                   String comp_cd,
                   String orgn_cd,
                   String comment,
                   NegoModel nego)
            throws WKFApplicationException
取り止め処理を実行します。
処理失敗時は、Exceptionを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 取り止めコメント(任意)
nego - 根回しメールオブジェクト(任意)
例外:
WKFApplicationException - エラーコード

pullBack

public void pullBack(String process_def_cd,
                     String version_cd,
                     String process_cd)
              throws WKFApplicationException
引戻し処理を実行します。
処理失敗時は、Exceptionを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
例外:
WKFApplicationException - エラーコード

getActivityProcessDefList

public List getActivityProcessDefList(SearchCondition condition_key,
                                      Sort[] sort_key,
                                      int start,
                                      int amount,
                                      String locale)
起票可能プロセス一覧を取得します。
起票可能プロセスオブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
起票指定日を指定する場合は検索条件オブジェクトの「draft_appoint_date」に起票指定日を設定してください。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
locale - ロケール(任意：なければデフォルトロケールを使用)
戻り値:
List 起票可能プロセスオブジェクト配列
Map 起票可能プロセスオブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) 起票可能な最新バージョンコード
├version_name(String) 起票可能な最新バージョン名
├version_note(String) 起票可能な最新バージョンの備考
├effective_date(String) 有効日付
├end_date(String) 終了日付
├process_cls_cd(String) プロセス種別コード
├activity_cd(String) 起票タスクのアクティビティコード
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_comp_cd(String) 代理依頼先会社コード(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
├narrow_post_cd(String) 代理依頼先役職絞り込みコード(本人用でインスタンス作成時)
├narrow_post_name(String) 代理依頼先役職絞り込み名(本人用でインスタンス作成時)
├client_user_cd(String) 代理依頼元ユーザコード(代理人用でインスタンス作成時)
└client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getEndProcessList

public List getEndProcessList(SearchCondition condition_key,
                              Sort[] sort_key,
                              int start,
                              int amount)
起票済み案件を取得します。
起票済み案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 起票済み案件情報オブジェクト配列
Map 起票済み案件情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├process_end_status(String) プロセス終了ステータス
├activity_cd(String) アクティビティコード(isJunction=trueのときはnull)
├activity_name(String) アクティビティ名(isJunction=trueのときはnull)
├activity_status(String) アクティビティステータス(isJunction=trueのときはnull)
├attainment_class(String) 到達種別(isJunction=trueのときはnull)
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_user_comp_cd(String) 起票者の処理時の会社コード
├draft_user_orgn_cd(String) 起票者の処理時の組織コード
├draft_user_main_flg(String) 主・副所属フラグ
├isJunction(Boolean) ルートが同期していればtrue
├now_approval_name(String) 現処理ユーザ/組織/オフィシャルG/ロール名(isJunction=trueのときはnull)
├reception_date(String) 受信日付
├process_term_date(String) 処理期限日付
├transfer_flg(Boolean) 代理起票フラグ
├client_auth_flg(Boolean) 代理元承認可否フラグ
├agent_target(String) 代理依頼先対象(本人用でインスタンス作成時)
├agent_cd(String) 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)
├agent_name(String) 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)
├client_user_cd(String) 代理依頼元ユーザコード(代理人用でインスタンス作成時)
├client_user_name(String) 代理依頼元ユーザ名(代理人用でインスタンス作成時)
└pull_activity_flg(Boolean) 引き戻し可否フラグ(true:可/false:不可)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

subProcessDraft

public void subProcessDraft(String process_def_cd,
                            String version_cd,
                            String process_cd,
                            String activity_cd,
                            String process_temporary_cd,
                            String process_name,
                            List app_key,
                            String comp_cd,
                            String orgn_cd,
                            String comment,
                            NegoModel nego,
                            RunExecutiveInfoModel executant,
                            String route_select_cd)
                     throws WKFApplicationException
推奨されていません。 subProcessDraft メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

subProcessDraft

public void subProcessDraft(String process_def_cd,
                            String version_cd,
                            String process_cd,
                            String activity_cd,
                            String process_temporary_cd,
                            String process_name,
                            List app_key,
                            String comp_cd,
                            String orgn_cd,
                            String comment,
                            NegoModel nego,
                            RunExecutiveInfoModel executant,
                            String route_select_cd,
                            CreateRouteInfoModel route_info)
                     throws WKFApplicationException
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「組織」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunExecutiveInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
route_info - ルート作成情報(次タスクがルート作成時)
例外:
WKFApplicationException - エラーコード

subProcessDraft

public void subProcessDraft(String process_def_cd,
                            String version_cd,
                            String process_cd,
                            String activity_cd,
                            String process_temporary_cd,
                            String process_name,
                            List app_key,
                            String comp_cd,
                            String orgn_cd,
                            String comment,
                            NegoModel nego,
                            RunUserInfoModel executant,
                            String route_select_cd)
                     throws WKFApplicationException
推奨されていません。 subProcessDraft メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
例外:
WKFApplicationException - エラーコード

subProcessDraft

public void subProcessDraft(String process_def_cd,
                            String version_cd,
                            String process_cd,
                            String activity_cd,
                            String process_temporary_cd,
                            String process_name,
                            List app_key,
                            String comp_cd,
                            String orgn_cd,
                            String comment,
                            NegoModel nego,
                            RunUserInfoModel executant,
                            String route_select_cd,
                            CreateRouteInfoModel route_info)
                     throws WKFApplicationException
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
処理失敗時は、Exceptionを返却します。
次承認者に「ユーザ」を指定した場合に使用します。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
次承認者が実行時選択になっていない場合は、
  RunUserInfoModel model = null; として、次承認者オブジェクトに“model”を指定してください。
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素１から指定してください。
要素０には空文字を入力して置いてください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
process_temporary_cd - 一時プロセスID(任意：添付ファイル利用時)
process_name - プロセス名(必須)
app_key - アプリケーションキー配列(任意：１～９要素まで)
comp_cd - ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd - ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment - 起票コメント(任意)
nego - 根回しメールオブジェクト(任意)
executant - 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd - ルート選択番号(次タスクがユーザ選択時)
route_info - ルート作成情報(次タスクがルート作成時)
例外:
WKFApplicationException - エラーコード

getTargetDepartment

public List getTargetDepartment(String process_def_cd,
                                String version_cd,
                                String activity_cd,
                                String target_date)
所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
起票時など、プロセスコードがふられていない時に使用します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
activity_cd - アクティビティコード(必須)
target_date - 起票指定日(任意：指定なしの場合はシステム日付)
戻り値:
所属組織情報オブジェクト配列 Map 所属組織情報オブジェクト
├company_cd(String) 会社コード
├department_cd(String) 組織コード
└department_name(String) 組織名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


FlowInfo (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス FlowInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.FlowInfo
public class FlowInfo
extends Object

フロー情報オブジェクト
特定のタスクの位置情報を保持した、フロー情報を取得する。

<サンプル>

コンストラクタの概要
FlowInfo()
コンストラクタ
メソッドの概要
String | getActivityCd() アクティビティコードを返却します。
String | getActivityType() アクティビティ種別を返却します。
boolean | getEndFlg() 分岐終了フラグを返却します。
FlowInfo | getFirst() 自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる
boolean | getIsSubProcess() サブプロセスフラグを返却します。
FlowInfo | getLast() 自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる
List | getNext() 自分自身のオブジェクトを、次のタスクに位置している状態に遷移させる。
List | getPrev() 自分自身のオブジェクトを、前のタスクに位置している状態に遷移させる。
String | getProcessDefCd() プロセス定義コードを返却します。
String | getVersionCd() バージョンコードを返却します。
boolean | hasNext() 次のタスクが存在するかどうかを返却する。
boolean | hasPrev() 前のタスクが存在するかどうかを返却する。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

FlowInfo

public FlowInfo()
コンストラクタ

メソッドの詳細

hasNext

public boolean hasNext()
次のタスクが存在するかどうかを返却する。

戻り値:
boolean 存在:true 存在しない:false

hasPrev

public boolean hasPrev()
前のタスクが存在するかどうかを返却する。

戻り値:
boolean 存在:true 存在しない:false

getNext

public List getNext()
             throws jp.co.intra_mart.framework.system.exception.SystemException,
                    jp.co.intra_mart.framework.system.exception.ApplicationException
自分自身のオブジェクトを、次のタスクに位置している状態に遷移させる。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に次タスクに状態遷移する）

戻り値:
List FlowInfoオブジェクト配列
例外:
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

getPrev

public List getPrev()
             throws jp.co.intra_mart.framework.system.exception.SystemException,
                    jp.co.intra_mart.framework.system.exception.ApplicationException
自分自身のオブジェクトを、前のタスクに位置している状態に遷移させる。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に次タスクに状態遷移する）

戻り値:
List FlowInfoオブジェクト配列
例外:
jp.co.intra_mart.framework.system.exception.SystemException
jp.co.intra_mart.framework.system.exception.ApplicationException

getFirst

public FlowInfo getFirst()
自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる

戻り値:
FlowInfo 最初のタスクオブジェクト

getLast

public FlowInfo getLast()
自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる

戻り値:
FlowInfo 最後のタスクオブジェクト

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを返却します。

戻り値:
String プロセス定義コード

getVersionCd

public String getVersionCd()
バージョンコードを返却します。

戻り値:
String バージョンコード

getActivityCd

public String getActivityCd()
アクティビティコードを返却します。

戻り値:
String アクティビティコード

getActivityType

public String getActivityType()
アクティビティ種別を返却します。

戻り値:
String アクティビティ種別

getEndFlg

public boolean getEndFlg()
分岐終了フラグを返却します。

戻り値:
boolean 分岐終了フラグ(分岐と同期の終わる時点を表示するフラグ)

getIsSubProcess

public boolean getIsSubProcess()
サブプロセスフラグを返却します。

戻り値:
boolean サブプロセスフラグ(サブプロセスの場合true)
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Manager (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Manager

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Manager
public class Manager
extends Object

マスタ関連のAPI
マスタメンテナンス関連処理で使用されるクラスです。

<サンプル>

フィールドの概要
static String | AUTHORITY_ALL 絞込み：なし
static String | AUTHORITY_EDIT 絞込み：編集権限
static String | AUTHORITY_READ 絞込み：処理権限
コンストラクタの概要
Manager(String user_cd, String login_group_id)
コンストラクタ

メソッドの概要
Map | addVersion(String process_def_cd, String version_notes, String effective_date, String end_date, ContentsPathModel process_contents_path, List root_info) 推奨されていません。
void | controlProcess(String process_def_cd, String version_cd, String process_cd, String target_activity_cd) プロセス操作を実行します。
byte[] | exportProcessDef(ArrayList process_def_cd) プロセス定義(Excel形式)をエクスポートします。
Map | getActivityInfo(String process_def_cd, String version_cd, String activity_cd) 推奨されていません。 getActivityInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | getActivityInfo(String process_def_cd, String version_cd, String activity_cd, String authority) プロセス定義コード、バージョンコード、アクティビティコード、絞込み条件をキーに タスク(アクティビティ)情報を取得します。
Map | getCategoryInfo(String category_cd) 推奨されていません。 getCategoryInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | getCategoryInfo(String category_cd, String authority) カテゴリコード、絞込み条件をキーにしてカテゴリ情報を取得します。
List | getCategoryInfoByName(String category_name) 推奨されていません。 getCategoryInfoByNameメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
List | getCategoryInfoByName(String category_name, String authority) カテゴリ名、絞込み条件をキーにしてカテゴリ情報を取得します。
FlowInfo | getFlowInfo(String processDefCd, String versionCd, String activityCd) 推奨されていません。 getFlowInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件:AUTHORITY_ALLで情報を取得します。
FlowInfo | getFlowInfo(String processDefCd, String versionCd, String activityCd, String authority) 特定のタスクの位置情報を保持して、フロー情報を取得する。
List | getFlowInfoByTargetNo(String processDefCd, String versionCd, int targetTaskNo, String authority) 特定のタスクの位置情報を保持して、フロー情報を取得する。
Map | getProcessDefInfo(String process_def_cd) 推奨されていません。 getProcessDefInfoメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | getProcessDefInfo(String process_def_cd, String authority) プロセス定義コード、絞込み条件をキーにしてプロセス定義情報を取得します。
List | getProcessDefInfoByCategory(String category_cd, String authority) カテゴリコード、絞込み条件をキーにしてプロセス定義情報配列を取得します。
List | getProcessDefInfoByName(String process_def_name) 推奨されていません。 getProcessDefInfoByNameメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
List | getProcessDefInfoByName(String process_def_name, String authority) プロセス定義名、絞込み条件をキーにしてプロセス定義情報を取得します。
Map | getProcessDefInfoByVersion(String process_def_cd, String version_cd) 推奨されていません。 getProcessDefInfoByVersionを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | getProcessDefInfoByVersion(String process_def_cd, String version_cd, String authority) プロセス定義コード、バージョンコード、絞込み条件をキーにしてプロセス定義情報を取得します。
List | getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount) 推奨されていません。 getProcessListメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
List | getProcessList(SearchCondition condition_key, Sort[] sort_key, int start, int amount, String authority) プロセス一覧情報を取得します。
Map | getVersionInfo(String process_def_cd, String version_cd) 推奨されていません。 getVersionメソッドを使用してください。 ※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
Map | getVersionInfo(String process_def_cd, String version_cd, String authority) バージョン(ルート)情報を取得します。
List | importProcessDef(Object xls_file) プロセス定義(Excel形式)をインポートします。
void | noTransaction() データベーストランザクションを未使用にする。
Map | registProcessDef(String category_cd, String process_def_name, String process_def_notes, String version_notes, String process_class_code, boolean sub_process_flag, boolean attachment_flag, String effective_date, String end_date, ContentsPathModel process_contents_path, List root_info) 推奨されていません。
void | removeProcess(String process_def_cd, String version_cd, String process_cd, Boolean xml_out_flg) 案件を削除を実行します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

AUTHORITY_EDIT

public static final String AUTHORITY_EDIT
絞込み：編集権限

関連項目:
定数フィールド値

AUTHORITY_READ

public static final String AUTHORITY_READ
絞込み：処理権限

関連項目:
定数フィールド値

AUTHORITY_ALL

public static final String AUTHORITY_ALL
絞込み：なし

関連項目:
定数フィールド値
コンストラクタの詳細

Manager

public Manager(String user_cd,
               String login_group_id)
        throws WKFApplicationException
コンストラクタ

パラメータ:
user_cd - ユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

exportProcessDef

public byte[] exportProcessDef(ArrayList process_def_cd)
                        throws WKFApplicationException
プロセス定義(Excel形式)をエクスポートします。
エクセルデータファイルを返却します。

パラメータ:
process_def_cd - プロセス定義コード配列(必須)
戻り値:
byte[] エクセルデータファイル
例外:
WKFApplicationException

getActivityInfo

public Map getActivityInfo(String process_def_cd,
                           String version_cd,
                           String activity_cd)
推奨されていません。 getActivityInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

getActivityInfo

public Map getActivityInfo(String process_def_cd,
                           String version_cd,
                           String activity_cd,
                           String authority)
プロセス定義コード、バージョンコード、アクティビティコード、絞込み条件をキーに
タスク(アクティビティ)情報を取得します。
タスク(アクティビティ)情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須：０マスクしないで指定)
activity_cd - アクティビティコード(必須)
authority - 絞込み条件(必須)
戻り値:
Object タスク情報オブジェクト Map タスク情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├activity_cd(String) アクティビティコード
├activiyty_name(String) アクティビティ名
├activity_type_cd(String) アクティビティ種別

(アクティビティ種別がRECEIVEの場合)
├compulsion_end_flag(Boolean) 終了可能フラグ
├return_flag(Boolean) 差し戻し/引き戻しフラグ
├return_mail_flag(Boolean) 差し戻しメールフラグ
├post_processing_flg(Boolean) 後処理使用フラグ
├post_processing_program(String) 後処理プログラム名
├contents_frame_type(String) コンテンツフレーム種別
├run_user(List) 対象者情報(MapObjectの配列)
      ├run_type(String) 対象者種別
      ├run_cd(String) 対象者コード
      ├run_group_cd(String) 対象グループコード(対象者種別が組織の場合)
      ├run_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
      └run_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
├refer_user(List) 参照者情報(MapObjectの配列)
      ├run_type(String) 対象者種別
      ├run_cd(String) 対象者コード
      ├run_group_cd(String) 対象グループコード(対象者種別が組織の場合)
      ├run_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
      └run_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
├contents_path(Map) コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
├pull_back_contents_path(Map) 引き戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
├return_contents_path(Map) 差し戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
├auto_pass(Int) 期日による自動パス設定の日数
├auto_pass_executive(Map) 対象者による自動パス設定情報
      ├executive_flg(Boolean) 自動パスフラグ
      └executive_user(List) 自動パス対象者情報配列(MapObjectの配列)
            ├executive_type(String) 対象者種別
            ├executive_cd(String) 対象者コード
            ├executive_group_cd(String) 対象グループコード(対象者種別が組織の場合)
            ├executive_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
            └executive_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
├reminder(Map) 催促メール情報
      ├reminder_flg(Boolean) 催促メール使用フラグ
      └reminder_date(String) 催促猶予日数

(アクティビティ種別がFLOWの場合)
├combine_class(String) 条件結合クラス

(アクティビティ種別がINVOKE_AUTOの場合)
├run_class(String) 自動実行クラス

(アクティビティ種別がINVOKE_EVENTの場合)
├event_id(String) イベントID

(アクティビティ種別がINVOKE_PROCESSの場合)
├call_process_def_cd(String) 呼出しプロセス定義コード
├draft_type_kind(String) 起票タイプ

(アクティビティ種別がSWITCHの場合)
├condition_type(String) 分岐種別(単一ルート:0/複数ルート:1)
├switch_info(List) 実行クラス情報(MapObjectの配列。配列の順番に評価されます。)
      ├condition_no(Int) 実行比較番号(配列の要素番号と同じ)
      ├run_activity_cd(String) 次に実行されるタスクのアクティビティコード
      └run_class(String) 実行クラス

(アクティビティ種別がMULTIの場合)
├route_info(List) ルート情報(MapObjectの配列。)
      ├select_route_no(String) ルート選択番号
      ├select_route_name(String) ルート名
      ├select_route_cd(String) 呼出先のアクティビティコード
      └isCreateRoute(Boolean) 次タスクがルート作成かどうかを取得します。(true:ルート作成/false:その他)

(アクティビティ種別がTERMINATEの場合)
└end_task_program(String) END時実行プログラム
戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getCategoryInfo

public Map getCategoryInfo(String category_cd)
推奨されていません。 getCategoryInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

getCategoryInfo

public Map getCategoryInfo(String category_cd,
                           String authority)
カテゴリコード、絞込み条件をキーにしてカテゴリ情報を取得します。
カテゴリ情報オブジェクトを返却します。

パラメータ:
category_cd - カテゴリコード(必須)
authority - 絞込み条件(必須)
戻り値:
Object カテゴリ情報オブジェクト Map カテゴリ情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├category_note(String) 備考
├edit_athorities(List) 編集権限リスト。(各要素はロールIDの文字列(String))
└processing_authorities(List) 処理権限リスト。(各要素はロールIDの文字列(String))

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getCategoryInfoByName

public List getCategoryInfoByName(String category_name)
推奨されていません。 getCategoryInfoByNameメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

getCategoryInfoByName

public List getCategoryInfoByName(String category_name,
                                  String authority)
カテゴリ名、絞込み条件をキーにしてカテゴリ情報を取得します。
カテゴリ情報オブジェクト配列を返却します。
パラメータにnull または "" を指定するとカテゴリ情報の一覧が取得できます。

パラメータ:
category_name - カテゴリ名(任意)
authority - 絞込み条件(必須)
戻り値:
List カテゴリ情報オブジェクト配列 Map カテゴリ情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├category_note(String) 備考
├edit_authorities(List) 編集権限リスト。(各要素はロールIDの文字列(String))
└processing_authorities(List) 処理権限リスト。(各要素はロールIDの文字列(String))

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getFlowInfo

public FlowInfo getFlowInfo(String processDefCd,
                            String versionCd,
                            String activityCd)
                     throws WKFApplicationException
推奨されていません。 getFlowInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件:AUTHORITY_ALLで情報を取得します。

例外:
WKFApplicationException

getFlowInfo

public FlowInfo getFlowInfo(String processDefCd,
                            String versionCd,
                            String activityCd,
                            String authority)
                     throws WKFApplicationException
特定のタスクの位置情報を保持して、フロー情報を取得する。
フロー情報オブジェクトについては、FlowInfoクラスを参照してください。

パラメータ:
processDefCd - プロセス定義コード
versionCd - バージョンコード
activityCd - アクティビティコード（NULL可）
authority - 絞込み条件(必須)
戻り値:
object(FlowInfo)　フロー情報オブジェクト
例外:
WKFApplicationException

getFlowInfoByTargetNo

public List getFlowInfoByTargetNo(String processDefCd,
                                  String versionCd,
                                  int targetTaskNo,
                                  String authority)
                           throws WKFApplicationException
特定のタスクの位置情報を保持して、フロー情報を取得する。
フロー情報オブジェクトについては、FlowInfoクラスを参照してください。
フロー上の先頭タスク情報を取得する場合は対象タスク番号に0を指定してください。

パラメータ:
processDefCd - プロセス定義コード
versionCd - バージョンコード
targetTaskNo - 対象タスク番号
authority - 絞込み条件
戻り値:
object(FlowInfo)　フロー情報オブジェクト
例外:
WKFApplicationException

getProcessDefInfo

public Map getProcessDefInfo(String process_def_cd)
                      throws WKFApplicationException,
                             jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 getProcessDefInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfo

public Map getProcessDefInfo(String process_def_cd,
                             String authority)
                      throws WKFApplicationException,
                             jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義コード、絞込み条件をキーにしてプロセス定義情報を取得します。
プロセス定義情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
authority - 絞込み条件(必須)
戻り値:
Object プロセス定義オブジェクト
Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├new_version_cd(String) 最新バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByName

public List getProcessDefInfoByName(String process_def_name)
                             throws WKFApplicationException,
                                    jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 getProcessDefInfoByNameメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByName

public List getProcessDefInfoByName(String process_def_name,
                                    String authority)
                             throws WKFApplicationException,
                                    jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義名、絞込み条件をキーにしてプロセス定義情報を取得します。
プロセス定義情報オブジェクト配列を返却します。
パラメータにnull または "" を指定するとプロセス定義情報の一覧が取得できます。

パラメータ:
process_def_name - プロセス定義名(任意)
authority - 絞込み条件(必須)
戻り値:
List プロセス定義情報オブジェクト配列 Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├new_version_cd(String) 最新バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByVersion

public Map getProcessDefInfoByVersion(String process_def_cd,
                                      String version_cd)
                               throws WKFApplicationException,
                                      jp.co.intra_mart.framework.system.exception.SystemException
推奨されていません。 getProcessDefInfoByVersionを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByVersion

public Map getProcessDefInfoByVersion(String process_def_cd,
                                      String version_cd,
                                      String authority)
                               throws WKFApplicationException,
                                      jp.co.intra_mart.framework.system.exception.SystemException
プロセス定義コード、バージョンコード、絞込み条件をキーにしてプロセス定義情報を取得します。
プロセス定義情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
authority - 絞込み条件(必須)
戻り値:
Map プロセス定義情報オブジェクト Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├version_cd(String) バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessDefInfoByCategory

public List getProcessDefInfoByCategory(String category_cd,
                                        String authority)
                                 throws WKFApplicationException,
                                        jp.co.intra_mart.framework.system.exception.SystemException
カテゴリコード、絞込み条件をキーにしてプロセス定義情報配列を取得します。
プロセス定義情報オブジェクト配列を返却します。

パラメータ:
category_cd - カテゴリコード(必須)
authority - 絞込み条件(必須)
戻り値:
List プロセス定義情報オブジェクト配列 Map プロセス定義オブジェクト
├category_cd(String) カテゴリコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├note(String) 備考
├new_version_cd(String) 最新バージョンコード
├process_count(Int) プロセス数
└activity_process_count(Int) アクティブなプロセス数
例外:
WKFApplicationException
jp.co.intra_mart.framework.system.exception.SystemException

getProcessList

public List getProcessList(SearchCondition condition_key,
                           Sort[] sort_key,
                           int start,
                           int amount)
推奨されていません。 getProcessListメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

getProcessList

public List getProcessList(SearchCondition condition_key,
                           Sort[] sort_key,
                           int start,
                           int amount,
                           String authority)
プロセス一覧情報を取得します。
プロセス情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
authority - 絞込み条件(必須)
戻り値:
List プロセス情報オブジェクト配列
Map プロセス情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls_cd(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├process_end_status(String) プロセス終了ステータス
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_status(String) アクティビティステータス
├attainment_class(String) 到達種別
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├now_approval_name(String) 現処理ユーザ/組織名
├reception_date(String) 受信日付
└process_term_date(String) 処理期限日付

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getVersionInfo

public Map getVersionInfo(String process_def_cd,
                          String version_cd)
推奨されていません。 getVersionメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。

getVersionInfo

public Map getVersionInfo(String process_def_cd,
                          String version_cd,
                          String authority)
バージョン(ルート)情報を取得します。
バージョン情報オブジェクトを返却します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
authority - 絞込み条件(必須)
戻り値:
Object バージョン情報オブジェクト
Map バージョン情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├note(String) 備考
├start_date(String) 開始日付
├end_date(String) 終了日付
├root_type(String) ルート種別
├sub_process_flag(String) サブプロセス識別フラグ
├attachment_flag(String) 添付ファイル使用可否フラグ
├contents_path(Map) コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
├pull_back_contents_path(Map) 引き戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
├return_contents_path(Map) 差し戻しコンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
├refer_contents_path(Map) 参照コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)
└detail_contents_path(Map) 詳細コンテンツパス
      ├page_kind(String) ページ種別
      ├contents_path(String) コンテンツパス
      ├application_id(String) アプリケーションID(page_kindがframeworkの場合)
      └service_id(String) サービスID(page_kindがframeworkの場合)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

importProcessDef

public List importProcessDef(Object xls_file)
                      throws WKFApplicationException
プロセス定義(Excel形式)をインポートします。
処理ステータスオブジェクトを返却します。

パラメータ:
xls_file - ファイルオブジェクト(必須)
戻り値:
List 処理ステータスオブジェクト配列
Map 処理ステータスオブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_def_name(String) プロセス定義名
├sheet_name(String) シート名（Excelのシート名）
├status(String) 処理結果ID
└message(String) 処理結果メッセージ
例外:
WKFApplicationException

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。

removeProcess

public void removeProcess(String process_def_cd,
                          String version_cd,
                          String process_cd,
                          Boolean xml_out_flg)
                   throws WKFApplicationException
案件を削除を実行します。
このAPIを使用した場合、案件の状態に関係なく削除を行います。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
xml_out_flg - XML出力フラグ(必須)
例外:
WKFApplicationException - エラーコード

controlProcess

public void controlProcess(String process_def_cd,
                           String version_cd,
                           String process_cd,
                           String target_activity_cd)
                    throws WKFApplicationException
プロセス操作を実行します。
プロセス操作では一度処理が到達したタスクにのみ処理を戻すことが出来ます。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
target_activity_cd - 遷移先アクティビティコード(必須)
例外:
WKFApplicationException - エラーコード

registProcessDef

public Map registProcessDef(String category_cd,
                            String process_def_name,
                            String process_def_notes,
                            String version_notes,
                            String process_class_code,
                            boolean sub_process_flag,
                            boolean attachment_flag,
                            String effective_date,
                            String end_date,
                            ContentsPathModel process_contents_path,
                            List root_info)
                     throws WKFApplicationException
推奨されていません。

新規プロセス定義の登録を行います。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
本APIで登録可能なルート情報は、処理タスクのみです。
分岐・同期・サブプロセス等のタスクには対応しておりません。

パラメータ:
category_cd - カテゴリコード(必須)
process_def_name - プロセス定義名(必須)
process_def_notes - プロセス定義備考(任意)
version_notes - バージョン備考(任意)
process_class_code - プロセス種別コード(必須)
sub_process_flag - サブプロセスフラグ(必須)
attachment_flag - 添付ファイル使用フラグ(必須)
effective_date - 開始日付(必須)
end_date - 終了日付(任意)
process_contents_path - プロセスコンテンツパス(必須)
root_info - ルート情報(必須:タスク情報配列)
戻り値:
Map 処理結果オブジェクト Map 処理ステータスオブジェクト
├process_def_cd(String) プロセス定義コード
└version_cd(String) バージョンコード
例外:
WKFApplicationException - エラーコード

addVersion

public Map addVersion(String process_def_cd,
                      String version_notes,
                      String effective_date,
                      String end_date,
                      ContentsPathModel process_contents_path,
                      List root_info)
               throws WKFApplicationException
推奨されていません。

指定されたプロセス定義に新規バージョンを追加します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
ルート情報を指定する場合、本APIで登録可能なルート情報は、処理タスクのみです。
分岐・同期・サブプロセス等のタスクには対応しておりません。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_notes - バージョン備考(任意)
effective_date - 開始日付(必須)
end_date - 終了日付(任意)
process_contents_path - プロセスコンテンツパス(任意)
root_info - ルート情報(任意:タスク情報配列)
戻り値:
Map 処理結果オブジェクト Map 処理ステータスオブジェクト
├process_def_cd(String) プロセス定義コード
└version_cd(String) バージョンコード
例外:
WKFApplicationException - エラーコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NegoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス NegoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.NegoModel
public class NegoModel
extends Object

BPWModelIFを保持するリストクラス

フィールドの概要
static String | MAIL_USER_ADDRESS
static String | MAIL_USER_CD 送信先ユーザコードキー
static String | MAIL_USER_NAME
コンストラクタの概要
NegoModel()
コンストラクタ

メソッドの概要
void | addUserList(Map map) 根回しメール送信者リストに情報を追加します。
String | getComment() 根回しメール本文を返却します。
String | getTitle() 根回しメールタイトルを返却します。
ArrayList | getUserList() 根回しメール送信者リストを返却します。
void | setComment(String string) 根回しメール本文を設定します。
void | setTitle(String string) 根回しメールタイトルを設定します。
void | setUserList(ArrayList list) 根回しメール送信者リストを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

MAIL_USER_CD

public static final String MAIL_USER_CD
送信先ユーザコードキー

関連項目:
定数フィールド値

MAIL_USER_ADDRESS

public static final String MAIL_USER_ADDRESS
関連項目:
定数フィールド値

MAIL_USER_NAME

public static final String MAIL_USER_NAME
関連項目:
定数フィールド値
コンストラクタの詳細

NegoModel

public NegoModel()
コンストラクタ

メソッドの詳細

getUserList

public ArrayList getUserList()
根回しメール送信者リストを返却します。

戻り値:
根回しメール送信者リスト

addUserList

public void addUserList(Map map)
根回しメール送信者リストに情報を追加します。
システムで利用されるメソッドです。

パラメータ:
map - メール送信者情報 Map メール送信者情報オブジェクト
└cd(String) 送信先ユーザコード

getTitle

public String getTitle()
根回しメールタイトルを返却します。

戻り値:
根回しメールタイトル

setUserList

public void setUserList(ArrayList list)
根回しメール送信者リストを設定します。

パラメータ:
list - メール送信者情報配列 Map メール送信者情報オブジェクト
└cd(String) 送信先ユーザコード

setTitle

public void setTitle(String string)
根回しメールタイトルを設定します。

パラメータ:
string - タイトル

setComment

public void setComment(String string)
根回しメール本文を設定します。

パラメータ:
string - 本文

getComment

public String getComment()
根回しメール本文を返却します。

戻り値:
根回しメール本文
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.wkf (bpw 6.1.14 API)

 jp.co.intra_mart.foundation.wkf
クラス
ActivityTaskModel
AgentSetting
Approver
ContentsPathDetailModel
ContentsPathModel
CreateRouteInfoModel
CreateRouteTargetInfoModel
Drafter
FlowInfo
Manager
NegoModel
Process
ReceiveTaskModel
Reference
TargetAutoPassModel
TargetInfoModel
TaskInfo
TransferActivityModel
TransferInfoModel
TransferProcessDefModel
TransferVersionModel
Util


jp.co.intra_mart.foundation.wkf (bpw 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf

クラスの概要
ActivityTaskModel | タスク情報を保持するクラス
AgentSetting | 代理設定関連のAPI 代理設定関連処理で使用されるクラスです。
Approver | 承認関連のAPI 承認関連の処理に使用されるクラスです。
ContentsPathDetailModel | コンテンツパス詳細情報を保持するクラス
ContentsPathModel | コンテンツパス設定情報を保持するクラス
CreateRouteInfoModel |
CreateRouteTargetInfoModel | ルート作成時、設定情報を保持するクラス
Drafter | 起票関連のAPI 起票関連の処理に使用されるクラスです。
FlowInfo | フロー情報オブジェクト 特定のタスクの位置情報を保持した、フロー情報を取得する。
Manager | マスタ関連のAPI マスタメンテナンス関連処理で使用されるクラスです。
NegoModel | BPWModelIFを保持するリストクラス
Process | 案件関連のAPI 案件関連の情報取得などに使用されるクラスです。
ReceiveTaskModel | 処理タスク設定情報を保持するクラス
Reference | 参照関連のAPI 参照案件の取得などに使用されるクラスです。
TargetAutoPassModel | 対象者自動パス設定情報を保持するクラス
TargetInfoModel | 対象者情報を保持するクラス
TaskInfo | タスク情報関連のAPI タスク情報関連処理で使用されるクラスです。
TransferActivityModel |
TransferInfoModel |
TransferProcessDefModel |
TransferVersionModel |
Util | ユーティリティ バッチ起動用クラス


jp.co.intra_mart.foundation.wkf クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.wkf の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.wkf.ActivityTaskModel
      • class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel
    • class jp.co.intra_mart.foundation.wkf.AgentSetting
    • class jp.co.intra_mart.foundation.wkf.Approver
    • class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel
    • class jp.co.intra_mart.foundation.wkf.ContentsPathModel
    • class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel
    • class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel
    • class jp.co.intra_mart.foundation.wkf.Drafter
    • class jp.co.intra_mart.foundation.wkf.FlowInfo
    • class jp.co.intra_mart.foundation.wkf.Manager
    • class jp.co.intra_mart.foundation.wkf.NegoModel
    • class jp.co.intra_mart.foundation.wkf.Process
    • class jp.co.intra_mart.foundation.wkf.Reference
    • class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel
    • class jp.co.intra_mart.foundation.wkf.TargetInfoModel
    • class jp.co.intra_mart.foundation.wkf.TaskInfo
    • class jp.co.intra_mart.foundation.wkf.TransferActivityModel
    • class jp.co.intra_mart.foundation.wkf.TransferInfoModel
    • class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel
    • class jp.co.intra_mart.foundation.wkf.TransferVersionModel
    • class jp.co.intra_mart.foundation.wkf.Util


パッケージ jp.co.intra_mart.foundation.wkf の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.wkf の使用

jp.co.intra_mart.foundation.wkf を使用しているパッケージ
jp.co.intra_mart.foundation.wkf

jp.co.intra_mart.foundation.wkf により使用される jp.co.intra_mart.foundation.wkf のクラス
ActivityTaskModel
タスク情報を保持するクラス
ContentsPathDetailModel
コンテンツパス詳細情報を保持するクラス
ContentsPathModel
コンテンツパス設定情報を保持するクラス
CreateRouteInfoModel
CreateRouteTargetInfoModel
ルート作成時、設定情報を保持するクラス
FlowInfo
フロー情報オブジェクト
特定のタスクの位置情報を保持した、フロー情報を取得する。
NegoModel
BPWModelIFを保持するリストクラス
TargetAutoPassModel
対象者自動パス設定情報を保持するクラス
TargetInfoModel
対象者情報を保持するクラス
TransferInfoModel

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


Process (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Process

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Process
public class Process
extends Object

案件関連のAPI
案件関連の情報取得などに使用されるクラスです。

<サンプル>

コンストラクタの概要
Process(String process_def_cd, String version_cd, String process_cd, String login_group_id)
コンストラクタ
メソッドの概要
List | getApplicationKeys() 指定したプロセスのアプリケーションキーを取得します。
List | getFileList() 添付ファイル一覧を取得します。
List | getFlow() プロセス上の現在位置を取得します。
Iterator | getProcessHistory() 案件の処理履歴を取得します。
Map | getProcessInfo() プロセス情報を取得します。
Map | getTaskResultInfo(String activity_cd) タスク処理結果情報を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Process

public Process(String process_def_cd,
               String version_cd,
               String process_cd,
               String login_group_id)
        throws WKFApplicationException
コンストラクタ

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

getFileList

public List getFileList()
添付ファイル一覧を取得します。
添付ファイル一覧を返却します。

戻り値:
List 添付ファイルオブジェクト
Map 添付ファイルオブジェクト
├path(String) ファイルパス(storageからの相対パス)
├file_cd(String) ファイルID
├file_name(String) ファイル名（論理ファイル名）
└file_size(Int) ファイルサイズ(バイト)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getProcessHistory

public Iterator getProcessHistory()
案件の処理履歴を取得します。
案件の処理履歴オブジェクトを返却します。

戻り値:
Iterator 案件の処理履歴情報オブジェクト配列
Map 処理履歴情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_status(String) アクティビティステータス
├activity_type(String) アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)
├call_process_cd(String) 親プロセスコード
├status_ended_date(String) ステータス完了日付
├approval_date(String) 承認日
├approval_user_cd(String) 承認者コード
├approval_user_name(String) 承認者名
├approval_type(String) 承認種別
├comp_cd(String) 処理者の処理時の会社コード
├orgn_cd(String) 処理者の処理時の組織コード
├orgn_name(String) 処理者の処理時の組織名
├main_flg(Boolean) 主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）
├commnet(String) 承認時のコメント
├agent_tran_flg(String) 代理_振替えフラグ
├agent_tran_user_cd(String) 代理_振替元ユーザコード
└agent_tran_user_name(String) 代理_振替元ユーザ名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getFlow

public List getFlow()
プロセス上の現在位置を取得します。
現在位置情報オブジェクトを返却します。

戻り値:
List 現在位置情報オブジェクト配列
Map 現在位置情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
└activity_cd(String) アクティビティコード

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getProcessInfo

public Map getProcessInfo()
プロセス情報を取得します。
プロセス情報オブジェクトを返却します。

戻り値:
Object プロセス情報オブジェクト
Map プロセス情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├parent_activity_cd(String) 親アクティビティコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├process_end_status(String) 　　プロセス終了ステータス
├last_man_activity(String) 最終手動アクティビティコード
├last_man_activity_result(String) 最終手動アクティビティ承認結果種別
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
├draft_user_name(String) 起票者名
├draft_comment(String) 起票時コメント
└app_key(List) アプリケーションキー配列(StringObjectの配列)

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getTaskResultInfo

public Map getTaskResultInfo(String activity_cd)
                      throws WKFApplicationException
タスク処理結果情報を取得します。
タスク処理結果情報オブジェクトを返却します。

パラメータ:
activity_cd - アクティビティコード(必須)
戻り値:
Object タスク処理結果情報オブジェクト
Map タスク処理結果情報オブジェクト
├process_def_cd(String) プロセス定義コード
├version_cd(String) バージョンコード
├process_cd(String) プロセスコード
├activity_cd(String) アクティビティコード
├activity_name(String) アクティビティ名
├activity_type(String) アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)
├activity_status(String) アクティビティステータス
├attainment_class(String) 到達種別
├activity_status_comp_date(String) ステータス完了日付
├reception_date(String) 受信日付
├process_term_date(String) 処理期限日付
├approval_type(String) 処理結果
├approval_user_cd(String) 処理ユーザコード
├approval_user_name(String) 処理ユーザ名
├approval_comment(String) 処理時コメント
├approval_date(String) 処理日
├auto_pass_term(String) 自動パス（バッチ）期限
├auto_pass_flag(String) 自動パス（バッチ）処理フラグ
├present_process(String) 現処理表示文字
├transfer_flg(String) 代理依頼フラグ
├delegate_flag(String) 振り替えフラグ
├agent_target(String) 代理依頼先対象(ユーザ/会社組織)
├agent_cd(String) 代理依頼先ユーザ/組織コード
├agent_name(String) 代理依頼先ユーザ/組織名
├client_user_cd(String) 代理依頼元ユーザコード
├client_user_name(String) 代理依頼元ユーザ名
├comp_cd(String) 処理者の処理時の会社コード
├orgn_cd(String) 処理者の処理時の組織コード
└main_flg(Boolean) 主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）
例外:
WKFApplicationException

getApplicationKeys

public List getApplicationKeys()
指定したプロセスのアプリケーションキーを取得します。
指定されたプロセスにアプリケーションキーが設定されておらず、
親プロセスがある場合は、親プロセスのアプリケーションキーを返却します。

戻り値:
List アプリケーションキー情報オブジェクト配列
Map アプリケーションキー情報オブジェクト
├parameter_no(String) パラメータ番号
└parameter_cd(String) パラメータコード

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


ReceiveTaskModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス ReceiveTaskModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.ActivityTaskModel
        拡張 jp.co.intra_mart.foundation.wkf.ReceiveTaskModel
public class ReceiveTaskModel
extends ActivityTaskModel

処理タスク設定情報を保持するクラス

フィールドの概要
static String | CONTENTS_FRAME_TYPE_CUSTOM コンテンツフレーム種別：カスタム
static String | CONTENTS_FRAME_TYPE_DEFAULT コンテンツフレーム種別：ノーマル
クラス jp.co.intra_mart.foundation.wkf.ActivityTaskModel から継承したフィールド
ACTIVITY_TYPE_EMPTY, ACTIVITY_TYPE_FLOW, ACTIVITY_TYPE_INVOKE_AUTO, ACTIVITY_TYPE_INVOKE_EVENT, ACTIVITY_TYPE_INVOKE_PROCESS, ACTIVITY_TYPE_RECEIVE, ACTIVITY_TYPE_ROUTE_SELECT, ACTIVITY_TYPE_SWITCH
コンストラクタの概要
ReceiveTaskModel()
コンストラクタ

メソッドの概要
void | addReferUser(TargetInfoModel target_info) 参照者情報を追加します。
void | addRunUser(TargetInfoModel target_info) 対象者情報を追加します。
String | getAutoPass() 期日による自動パス設定の日数を返却します。
TargetAutoPassModel | getAutoPassExecutive() 対象者自動パス設定情報を取得します。
String | getContentsFrameType() コンテンツフレーム種別を返却します。
ContentsPathModel | getContentsPath() コンテンツパス情報を返却します。
String | getMailPostponement() 催促猶予日数を返却します。
String | getPostProcessingProgram() 後処理クラス名を返却します。
ArrayList | getReferUser() 参照者情報を取得します。
ArrayList | getRunUser() 対象者情報を取得します。
boolean | isCompulsionEndFlag() 途中終了フラグを返却します。
boolean | isMailSendFlag() 催促メール使用フラグを返却します。
boolean | isPostProcessingFlag() 後処理使用フラグを返却します。
boolean | isReturnFlag() 差し戻し/引き戻しフラグを返却します。
boolean | isReturnMailFlag() 差し戻しメールフラグを返却します。
boolean | isShortestEndFlag() 必須選択最終タスクフラグを返却します。
void | setAutoPass(String auto_pass) 期日による自動パス設定の日数を設定します。
void | setAutoPassExecutive(TargetAutoPassModel auto_pass_executive) 対象者自動パス設定情報を設定します。
void | setCompulsionEndFlag(boolean compulsion_end_flag) 途中終了フラグを設定します。
void | setContentsFrameType(String contents_frame_type) コンテンツフレーム種別を設定します。
void | setContentsPath(ContentsPathModel contents_path) コンテンツパス情報を設定します。
void | setMailPostponement(String mail_postponement) 催促猶予日数を設定します。
void | setMailSendFlag(boolean mail_send_flag) 催促メール使用フラグを設定します。
void | setPostProcessingFlag(boolean post_processing_flag) 後処理使用フラグを設定します。
void | setPostProcessingProgram(String post_processing_program) 後処理クラス名を設定します。
void | setReturnFlag(boolean return_flag) 差し戻し/引き戻しフラグを設定します。
void | setReturnMailFlag(boolean return_mail_flag) 差し戻しメールフラグを設定します。
void | setShortestEndFlag(boolean shortest_end_flag) 必須選択最終タスクフラグを設定します。
クラス jp.co.intra_mart.foundation.wkf.ActivityTaskModel から継承したメソッド
getActivityName, getActivityType, setActivityName, setActivityType
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

CONTENTS_FRAME_TYPE_DEFAULT

public static final String CONTENTS_FRAME_TYPE_DEFAULT
コンテンツフレーム種別：ノーマル

関連項目:
定数フィールド値

CONTENTS_FRAME_TYPE_CUSTOM

public static final String CONTENTS_FRAME_TYPE_CUSTOM
コンテンツフレーム種別：カスタム

関連項目:
定数フィールド値
コンストラクタの詳細

ReceiveTaskModel

public ReceiveTaskModel()
コンストラクタ

メソッドの詳細

getAutoPass

public String getAutoPass()
期日による自動パス設定の日数を返却します。

戻り値:
期日による自動パス設定の日数

setAutoPass

public void setAutoPass(String auto_pass)
期日による自動パス設定の日数を設定します。

パラメータ:
auto_pass - 期日による自動パス設定の日数

getAutoPassExecutive

public TargetAutoPassModel getAutoPassExecutive()
対象者自動パス設定情報を取得します。

戻り値:
対象者自動パス設定情報

setAutoPassExecutive

public void setAutoPassExecutive(TargetAutoPassModel auto_pass_executive)
対象者自動パス設定情報を設定します。

パラメータ:
auto_pass_executive - 対象者自動パス設定情報

isCompulsionEndFlag

public boolean isCompulsionEndFlag()
途中終了フラグを返却します。

戻り値:
途中終了フラグ

setCompulsionEndFlag

public void setCompulsionEndFlag(boolean compulsion_end_flag)
途中終了フラグを設定します。
初期値はfalseになっています。

パラメータ:
compulsion_end_flag - 途中終了フラグ

getContentsFrameType

public String getContentsFrameType()
コンテンツフレーム種別を返却します。

戻り値:
コンテンツフレーム種別

setContentsFrameType

public void setContentsFrameType(String contents_frame_type)
コンテンツフレーム種別を設定します。

パラメータ:
contents_frame_type - コンテンツフレーム種別

getContentsPath

public ContentsPathModel getContentsPath()
コンテンツパス情報を返却します。

戻り値:
コンテンツパス情報

setContentsPath

public void setContentsPath(ContentsPathModel contents_path)
コンテンツパス情報を設定します。

パラメータ:
contents_path - コンテンツパス情報

getMailPostponement

public String getMailPostponement()
催促猶予日数を返却します。

戻り値:
催促猶予日数

setMailPostponement

public void setMailPostponement(String mail_postponement)
催促猶予日数を設定します。

パラメータ:
mail_postponement - 催促猶予日数

isMailSendFlag

public boolean isMailSendFlag()
催促メール使用フラグを返却します。

戻り値:
催促メール使用フラグ

setMailSendFlag

public void setMailSendFlag(boolean mail_send_flag)
催促メール使用フラグを設定します。
初期値はfalseになっています。

パラメータ:
mail_send_flag - 催促メール使用フラグ

getRunUser

public ArrayList getRunUser()
対象者情報を取得します。

戻り値:
対象者情報

addRunUser

public void addRunUser(TargetInfoModel target_info)
対象者情報を追加します。

パラメータ:
target_info - 対象者情報

getReferUser

public ArrayList getReferUser()
参照者情報を取得します。

戻り値:
参照者情報

addReferUser

public void addReferUser(TargetInfoModel target_info)
参照者情報を追加します。

パラメータ:
target_info - 参照者情報

isPostProcessingFlag

public boolean isPostProcessingFlag()
後処理使用フラグを返却します。

戻り値:
後処理使用フラグ

setPostProcessingFlag

public void setPostProcessingFlag(boolean post_processing_flag)
後処理使用フラグを設定します。
初期値はfalseになっています。

パラメータ:
post_processing_flag - 後処理使用フラグ

getPostProcessingProgram

public String getPostProcessingProgram()
後処理クラス名を返却します。

戻り値:
後処理クラス名

setPostProcessingProgram

public void setPostProcessingProgram(String post_processing_program)
後処理クラス名を設定します。

パラメータ:
post_processing_program - 後処理クラス名

isReturnFlag

public boolean isReturnFlag()
差し戻し/引き戻しフラグを返却します。

戻り値:
差し戻し/引き戻しフラグ

setReturnFlag

public void setReturnFlag(boolean return_flag)
差し戻し/引き戻しフラグを設定します。 初期値はfalseになっています。

パラメータ:
return_flag - 差し戻し/引き戻しフラグ

isReturnMailFlag

public boolean isReturnMailFlag()
差し戻しメールフラグを返却します。

戻り値:
差し戻しメールフラグ

setReturnMailFlag

public void setReturnMailFlag(boolean return_mail_flag)
差し戻しメールフラグを設定します。
初期値はfalseになっています。

パラメータ:
return_mail_flag - 差し戻しメールフラグ

isShortestEndFlag

public boolean isShortestEndFlag()
必須選択最終タスクフラグを返却します。

戻り値:
必須選択最終タスクフラグ

setShortestEndFlag

public void setShortestEndFlag(boolean shortest_end_flag)
必須選択最終タスクフラグを設定します。
初期値はfalseになっています。

パラメータ:
shortest_end_flag - 必須選択最終タスクフラグ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Reference (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Reference

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Reference
public class Reference
extends Object

参照関連のAPI
参照案件の取得などに使用されるクラスです。

<サンプル>

コンストラクタの概要
Reference(String user_cd, String login_group_id)
コンストラクタ
メソッドの概要
 List getReferTaskList(SearchCondition condition_key, Sort[] sort_key, int start, int amount)
参照可能案件一覧を取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Reference

public Reference(String user_cd,
                 String login_group_id)
          throws WKFApplicationException
コンストラクタ

パラメータ:
user_cd - 参照者のユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

getReferTaskList

public List getReferTaskList(SearchCondition condition_key,
                             Sort[] sort_key,
                             int start,
                             int amount)
参照可能案件一覧を取得します。
参照可能案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。

パラメータ:
condition_key - 検索条件オブジェクト配列(必須。必ずフィルターをセットしてください)
sort_key - ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start - フェッチ開始位置(任意。指定しない場合は0を指定)
amount - フェッチ件数(任意。指定しない場合は0を指定)
戻り値:
List 参照可能案件情報オブジェクト配列
Map 参照可能案件情報オブジェクト
├category_cd(String) カテゴリコード
├category_name(String) カテゴリ名
├parent_process_def_cd(String) 親プロセス定義コード
├parent_version_cd(String) 親プロセスバージョンコード
├parent_process_cd(String) 親プロセスコード
├process_def_cd(String) プロセス定義コード
├process_def_name(String) プロセス定義名
├version_cd(String) バージョンコード
├version_name(String) バージョン名
├process_cls(String) プロセス種別コード
├process_cd(String) プロセスコード
├process_name(String) プロセス名
├process_status(String) プロセスステータス
├process_end_status(String) プロセス終了ステータス
├draft_appoint_date(String) 起票指定日
├draft_date(String) 起票日
├draft_user_cd(String) 起票者コード
└draft_user_name(String) 起票者名

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TargetAutoPassModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TargetAutoPassModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TargetAutoPassModel
public class TargetAutoPassModel
extends Object

対象者自動パス設定情報を保持するクラス

コンストラクタの概要
TargetAutoPassModel()
コンストラクタ

メソッドの概要
void | addAutoPassTarget(TargetInfoModel target_info) 自動パス対象者情報を追加します。
ArrayList | getAutoPassTarget() 自動パス対象者情報を取得します。
boolean | isAutoPassFlag() 自動パスフラグを取得します。
void | setAutoPassFlag(boolean auto_pass_flag) 自動パスフラグを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TargetAutoPassModel

public TargetAutoPassModel()
コンストラクタ

メソッドの詳細

isAutoPassFlag

public boolean isAutoPassFlag()
自動パスフラグを取得します。

戻り値:
自動パスフラグ

setAutoPassFlag

public void setAutoPassFlag(boolean auto_pass_flag)
自動パスフラグを設定します。
初期値はfalseになっています。

パラメータ:
auto_pass_flag - 自動パスフラグ

getAutoPassTarget

public ArrayList getAutoPassTarget()
自動パス対象者情報を取得します。

戻り値:
自動パス対象者情報

addAutoPassTarget

public void addAutoPassTarget(TargetInfoModel target_info)
自動パス対象者情報を追加します。

パラメータ:
target_info - 自動パス対象者情報
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TargetInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TargetInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TargetInfoModel
public class TargetInfoModel
extends Object

対象者情報を保持するクラス

フィールドの概要
static String | TARGET_TYPE_ATTACH_ORGN 対象者種別：所属組織
static String | TARGET_TYPE_DRAFTER 対象者種別：申請者
static String | TARGET_TYPE_EXECUTIVE 対象者種別：実行時選択
static String | TARGET_TYPE_HIGH_ORGN 対象者種別：上位組織
static String | TARGET_TYPE_OFFICIAL 対象者種別：パブリックグループ
static String | TARGET_TYPE_ORGN 対象者種別：組織
static String | TARGET_TYPE_ROLE 対象者種別：ロール
static String | TARGET_TYPE_SUB 対象者種別：処理者定義
static String | TARGET_TYPE_USER 対象者種別：ユーザ
コンストラクタの概要
TargetInfoModel()
コンストラクタ

メソッドの概要
String | getCode() 対象者コードを返却します。
String | getGroupCd() 対象者グループコードを返却します。
String | getPostRestrict() 役職絞込みコードを返却します。
String | getRoleRestrict() ロール絞込みIDを返却します。
String | getType() 対象者種別を返却します。
void | setCode(String code) 対象者コードを設定します。
void | setGroupCd(String group_cd) 対象者グループコードを設定します。
void | setPostRestrict(String post_restrict) 役職絞込みコードを設定します。
void | setRoleRestrict(String role_restrict) ロール絞込みIDを設定します。
void | setType(String type) 対象者種別を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

TARGET_TYPE_USER

public static final String TARGET_TYPE_USER
対象者種別：ユーザ

関連項目:
定数フィールド値

TARGET_TYPE_ORGN

public static final String TARGET_TYPE_ORGN
対象者種別：組織

関連項目:
定数フィールド値

TARGET_TYPE_OFFICIAL

public static final String TARGET_TYPE_OFFICIAL
対象者種別：パブリックグループ

関連項目:
定数フィールド値

TARGET_TYPE_ROLE

public static final String TARGET_TYPE_ROLE
対象者種別：ロール

関連項目:
定数フィールド値

TARGET_TYPE_EXECUTIVE

public static final String TARGET_TYPE_EXECUTIVE
対象者種別：実行時選択

関連項目:
定数フィールド値

TARGET_TYPE_ATTACH_ORGN

public static final String TARGET_TYPE_ATTACH_ORGN
対象者種別：所属組織

関連項目:
定数フィールド値

TARGET_TYPE_HIGH_ORGN

public static final String TARGET_TYPE_HIGH_ORGN
対象者種別：上位組織

関連項目:
定数フィールド値

TARGET_TYPE_SUB

public static final String TARGET_TYPE_SUB
対象者種別：処理者定義

関連項目:
定数フィールド値

TARGET_TYPE_DRAFTER

public static final String TARGET_TYPE_DRAFTER
対象者種別：申請者

関連項目:
定数フィールド値
コンストラクタの詳細

TargetInfoModel

public TargetInfoModel()
コンストラクタ

メソッドの詳細

getCode

public String getCode()
対象者コードを返却します。

戻り値:
対象者コード

setCode

public void setCode(String code)
対象者コードを設定します。

パラメータ:
code - 対象者コード

getGroupCd

public String getGroupCd()
対象者グループコードを返却します。

戻り値:
対象者グループコード

setGroupCd

public void setGroupCd(String group_cd)
対象者グループコードを設定します。
対象者種別が組織、パブリックグループの場合に使用します。

対象者種別が組織の場合は会社コードを設定します。
対象者種別がパブリックグループの場合はパブリックグループセットのグループセットコードを設定します。

パラメータ:
group_cd - 対象者グループコード

getPostRestrict

public String getPostRestrict()
役職絞込みコードを返却します。

戻り値:
役職絞込みコード

setPostRestrict

public void setPostRestrict(String post_restrict)
役職絞込みコードを設定します。
対象者種別が組織の場合に使用します。

パラメータ:
post_restrict - 役職絞込みコード

getRoleRestrict

public String getRoleRestrict()
ロール絞込みIDを返却します。

戻り値:
ロール絞込みID

setRoleRestrict

public void setRoleRestrict(String role_restrict)
ロール絞込みIDを設定します。 対象者種別が組織、パブリックグループの場合に使用します。

パラメータ:
role_restrict - ロール絞込みID

getType

public String getType()
対象者種別を返却します。

戻り値:
対象者種別

setType

public void setType(String type)
対象者種別を設定します。

パラメータ:
type - 対象者種別
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TaskInfo (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TaskInfo

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TaskInfo
public class TaskInfo
extends Object

タスク情報関連のAPI
タスク情報関連処理で使用されるクラスです。

コンストラクタの概要
TaskInfo(String user_cd, String login_group_id)
コンストラクタ

メソッドの概要
void | changeRunUser(String process_def_cd, String version_cd, String process_cd, String activity_cd, TargetInfoModel target_info) 指定された案件内の指定タスクの処理者を変更します。
List | getTargetReferInfo(String process_def_cd, String version_cd, String activity_cd) 指定されたタスクに設定された参照者情報を取得します。
List | getTargetRunInfo(String process_def_cd, String version_cd, String activity_cd) 指定されたタスクに設定された対象者情報を取得します。
void | noTransaction() データベーストランザクションを未使用にする。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TaskInfo

public TaskInfo(String user_cd,
                String login_group_id)
         throws WKFApplicationException
コンストラクタ

パラメータ:
user_cd - ユーザID(必須)
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

noTransaction

public void noTransaction()
データベーストランザクションを未使用にする。

getTargetRunInfo

public List getTargetRunInfo(String process_def_cd,
                             String version_cd,
                             String activity_cd)
指定されたタスクに設定された対象者情報を取得します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
activity_cd - アクティビティコード(必須)
戻り値:
List 対象者情報オブジェクト配列
Map 対象者情報オブジェクト
├run_type(String) 対象者種別
├run_group_cd(String) 対象者グループコード
├run_cd(String) 対象者コード
├role_restrict(String) 絞込みロールID
└post_restrict(String) 絞込み役職コード

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

getTargetReferInfo

public List getTargetReferInfo(String process_def_cd,
                               String version_cd,
                               String activity_cd)
指定されたタスクに設定された参照者情報を取得します。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
activity_cd - アクティビティコード(必須)
戻り値:
List 参照者情報オブジェクト配列
Map 参照者情報オブジェクト
├refer_type(String) 参照者種別
├refer_group_cd(String) 参照者グループコード
├refer_cd(String) 参照者コード
├role_restrict(String) 絞込みロールID
└post_restrict(String) 絞込み役職コード

戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。

changeRunUser

public void changeRunUser(String process_def_cd,
                          String version_cd,
                          String process_cd,
                          String activity_cd,
                          TargetInfoModel target_info)
                   throws WKFApplicationException
指定された案件内の指定タスクの処理者を変更します。
処理対象者には、ユーザ・組織・オフィシャルグループ・ロールが指定できます。
既に処理が終了しているタスクの処理者を変更することは出来ません。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。

パラメータ:
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
target_info - 対象者オブジェクト(必須)
例外:
WKFApplicationException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransferActivityModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TransferActivityModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TransferActivityModel
public class TransferActivityModel
extends Object

コンストラクタの概要
TransferActivityModel()
コンストラクタ
メソッドの概要
String | getActivityCd() アクティビティコードを取得します。
String | getActivityName() タスク名を取得します。
String | getNarrowPostCd() 絞り込み役職コードを取得します。
String | getNarrowPostName() 絞り込み役職名を取得します。
String | getProcessDefCd() プロセス定義コードを取得します。
String | getTransferCd() 代理依頼先コードを取得します。
String | getTransferCdType() 代理依頼先種別を取得します。
String | getTransferEndDate() 代理期間(終了日)を取得します。
String | getTransferGroupCd() 代理依頼先グループコードを取得します。
String | getTransferName() 代理依頼先名を取得します。
String | getTransferStartDate() 代理期間(開始日)を取得します。
String | getTransferStatus() 代理設定種別を取得します。
String | getVersionCd() バージョンコードを取得します。
boolean | isDynamicTaskFlag() 動的承認者フラグを取得します。
void | setActivityCd(String activityCd) アクティビティコードを設定します。
void | setActivityName(String activityName) タスク名を設定します。
void | setDynamicTaskFlag(boolean dynamicTaskFlag) 動的承認者フラグを設定します。
void | setNarrowPostCd(String narrowPostCd) 絞り込み役職コードを設定します。
void | setNarrowPostName(String narrowPostName) 絞り込み役職名を設定します。
void | setProcessDefCd(String processDefCd) プロセス定義コードを設定します。
void | setTransferCd(String transferCd) 代理依頼先コードを設定します。
void | setTransferCdType(String transferCdType) 代理依頼先種別を設定します。
void | setTransferEndDate(String transferEndDate) 代理期間(終了日)を設定します。
void | setTransferGroupCd(String transferGroupCd) 代理依頼先グループコードを設定します。
void | setTransferName(String transferName) 代理依頼先名を設定します。
void | setTransferStartDate(String transferStartDate) 代理期間(開始日)を設定します。
void | setTransferStatus(String transferStatus) 代理設定種別を設定します。
void | setVersionCd(String versionCd) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TransferActivityModel

public TransferActivityModel()
コンストラクタ

メソッドの詳細

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを取得します。

戻り値:
プロセス定義コード

setProcessDefCd

public void setProcessDefCd(String processDefCd)
プロセス定義コードを設定します。

パラメータ:
processDefCd - プロセス定義コード

getVersionCd

public String getVersionCd()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCd

public void setVersionCd(String versionCd)
バージョンコードを設定します。

パラメータ:
versionCd - バージョンコード

getActivityCd

public String getActivityCd()
アクティビティコードを取得します。

戻り値:
アクティビティコード

setActivityCd

public void setActivityCd(String activityCd)
アクティビティコードを設定します。

パラメータ:
activityCd - アクティビティコード

getActivityName

public String getActivityName()
タスク名を取得します。

戻り値:
タスク名

setActivityName

public void setActivityName(String activityName)
タスク名を設定します。

パラメータ:
activityName - タスク名

getTransferEndDate

public String getTransferEndDate()
代理期間(終了日)を取得します。

戻り値:
代理期間(終了日)

setTransferEndDate

public void setTransferEndDate(String transferEndDate)
代理期間(終了日)を設定します。

パラメータ:
transferEndDate - 代理期間(終了日)

getTransferStartDate

public String getTransferStartDate()
代理期間(開始日)を取得します。

戻り値:
代理期間(開始日)

setTransferStartDate

public void setTransferStartDate(String transferStartDate)
代理期間(開始日)を設定します。

パラメータ:
transferStartDate - 代理期間(開始日)

getTransferCdType

public String getTransferCdType()
代理依頼先種別を取得します。

戻り値:
代理依頼先種別

setTransferCdType

public void setTransferCdType(String transferCdType)
代理依頼先種別を設定します。

パラメータ:
transferCdType - 代理依頼先種別

getTransferGroupCd

public String getTransferGroupCd()
代理依頼先グループコードを取得します。

戻り値:
代理依頼先グループコード

setTransferGroupCd

public void setTransferGroupCd(String transferGroupCd)
代理依頼先グループコードを設定します。

パラメータ:
transferGroupCd - 代理依頼先グループコード

getTransferCd

public String getTransferCd()
代理依頼先コードを取得します。

戻り値:
代理依頼先コード

setTransferCd

public void setTransferCd(String transferCd)
代理依頼先コードを設定します。

パラメータ:
transferCd - 代理依頼先コード

getTransferName

public String getTransferName()
代理依頼先名を取得します。

戻り値:
代理依頼先名

setTransferName

public void setTransferName(String transferName)
代理依頼先名を設定します。

パラメータ:
transferName - 代理依頼先名

getNarrowPostCd

public String getNarrowPostCd()
絞り込み役職コードを取得します。

戻り値:
絞り込み役職コード

setNarrowPostCd

public void setNarrowPostCd(String narrowPostCd)
絞り込み役職コードを設定します。

パラメータ:
narrowPostCd - 絞り込み役職コード

getNarrowPostName

public String getNarrowPostName()
絞り込み役職名を取得します。

戻り値:
絞り込み役職名

setNarrowPostName

public void setNarrowPostName(String narrowPostName)
絞り込み役職名を設定します。

パラメータ:
narrowPostName - 絞り込み役職名

getTransferStatus

public String getTransferStatus()
代理設定種別を取得します。

戻り値:
代理設定種別

setTransferStatus

public void setTransferStatus(String transferStatus)
代理設定種別を設定します。

パラメータ:
transferStatus - 代理設定種別

isDynamicTaskFlag

public boolean isDynamicTaskFlag()
動的承認者フラグを取得します。

戻り値:
動的承認者フラグ

setDynamicTaskFlag

public void setDynamicTaskFlag(boolean dynamicTaskFlag)
動的承認者フラグを設定します。

パラメータ:
dynamicTaskFlag - 動的承認者フラグ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransferInfoModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TransferInfoModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TransferInfoModel
public class TransferInfoModel
extends Object

フィールドの概要
static String | CD_KIND_OFFICIAL 代理依頼先種別：オフィシャルグループ
static String | CD_KIND_ORG 代理依頼先種別：組織
static String | CD_KIND_PRIVATE 代理依頼先種別：プライベートグループ
static String | CD_KIND_USER 代理依頼先種別：ユーザ
static String | PROCESS_DEF_ALL プロセス定義コード：全て (全プロセス定義にプロセス定義委譲を行いたい場合に使用します。)
static String | STATUS_ACTIVITY 代理設定種別：タスク委譲
static String | STATUS_PROCESS_DEF 代理設定種別：プロセス定義委譲
static String | STATUS_VERSION 代理設定種別：バージョン委譲
コンストラクタの概要
TransferInfoModel()
コンストラクタ
メソッドの概要
String | getActivityCd() アクティビティコードを取得します。
String | getNarrowPostCd() 絞り込み役職コードを取得します。
String | getNarrowPostName() 絞り込み役職名を取得します。
String | getProcessDefCd() プロセス定義コードを取得します。
String | getTransferCd() 代理依頼先コードを取得します。
String | getTransferCdType() 代理依頼先種別を取得します。
String | getTransferComment() 代理コメントを取得します。
String | getTransferEndDate() 代理期間(終了日)を取得します。
String | getTransferGroupCd() 代理依頼先グループコードを取得します。
String | getTransferName() 代理依頼先名を取得します。
String | getTransferStartDate() 代理期間(開始日)を取得します。
String | getTransferStatus() 代理設定種別を取得します。
String | getVersionCd() バージョンコードを取得します。
boolean | isNoticeMailFlag() 代理元メール通知フラグを取得します。
boolean | isSendMailFlag() メール通知フラグを取得します。
boolean | isSubRecognitionFlag() 代理元承認可否フラグを取得します。
void | setActivityCd(String activityCd) アクティビティコードを設定します。
void | setNarrowPostCd(String narrowPostCd) 絞り込み役職コードを設定します。
void | setNarrowPostName(String narrowPostName) 絞り込み役職名を設定します。
void | setNoticeMailFlag(boolean noticeMailFlag) 代理元メール通知フラグを設定します。
void | setProcessDefCd(String processDefCd) プロセス定義コードを設定します。
void | setSendMailFlag(boolean sendMailFlag) メール通知フラグを設定します。
void | setSubRecognitionFlag(boolean subRecognitionFlag) 代理元承認可否フラグを設定します。
void | setTransferCd(String transferCd) 代理依頼先コードを設定します。
void | setTransferCdType(String transferCdType) 代理依頼先種別を設定します。
void | setTransferComment(String transferComment) 代理コメントを設定します。
void | setTransferEndDate(String transferEndDate) 代理期間(終了日)を設定します。
void | setTransferGroupCd(String transferGroupCd) 代理依頼先グループコードを設定します。
void | setTransferName(String transferName) 代理依頼先名を設定します。
void | setTransferStartDate(String transferStartDate) 代理期間(開始日)を設定します。
void | setTransferStatus(String transferStatus) 代理設定種別を設定します。
void | setVersionCd(String versionCd) バージョンコードを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

PROCESS_DEF_ALL

public static final String PROCESS_DEF_ALL
プロセス定義コード：全て
(全プロセス定義にプロセス定義委譲を行いたい場合に使用します。)

関連項目:
定数フィールド値

CD_KIND_USER

public static final String CD_KIND_USER
代理依頼先種別：ユーザ

関連項目:
定数フィールド値

CD_KIND_ORG

public static final String CD_KIND_ORG
代理依頼先種別：組織

関連項目:
定数フィールド値

CD_KIND_OFFICIAL

public static final String CD_KIND_OFFICIAL
代理依頼先種別：オフィシャルグループ

関連項目:
定数フィールド値

CD_KIND_PRIVATE

public static final String CD_KIND_PRIVATE
代理依頼先種別：プライベートグループ

関連項目:
定数フィールド値

STATUS_PROCESS_DEF

public static final String STATUS_PROCESS_DEF
代理設定種別：プロセス定義委譲

関連項目:
定数フィールド値

STATUS_VERSION

public static final String STATUS_VERSION
代理設定種別：バージョン委譲

関連項目:
定数フィールド値

STATUS_ACTIVITY

public static final String STATUS_ACTIVITY
代理設定種別：タスク委譲

関連項目:
定数フィールド値
コンストラクタの詳細

TransferInfoModel

public TransferInfoModel()
コンストラクタ

メソッドの詳細

getTransferEndDate

public String getTransferEndDate()
代理期間(終了日)を取得します。

戻り値:
代理期間(終了日)

setTransferEndDate

public void setTransferEndDate(String transferEndDate)
代理期間(終了日)を設定します。

パラメータ:
transferEndDate - 代理期間(終了日)

getTransferStartDate

public String getTransferStartDate()
代理期間(開始日)を取得します。

戻り値:
代理期間(開始日)

setTransferStartDate

public void setTransferStartDate(String transferStartDate)
代理期間(開始日)を設定します。

パラメータ:
transferStartDate - 代理期間(開始日)

getActivityCd

public String getActivityCd()
アクティビティコードを取得します。

戻り値:
アクティビティコード

setActivityCd

public void setActivityCd(String activityCd)
アクティビティコードを設定します。

パラメータ:
activityCd - アクティビティコード

getNarrowPostCd

public String getNarrowPostCd()
絞り込み役職コードを取得します。

戻り値:
絞り込み役職コード

setNarrowPostCd

public void setNarrowPostCd(String narrowPostCd)
絞り込み役職コードを設定します。

パラメータ:
narrowPostCd - 絞り込み役職コード

getNarrowPostName

public String getNarrowPostName()
絞り込み役職名を取得します。

戻り値:
絞り込み役職名

setNarrowPostName

public void setNarrowPostName(String narrowPostName)
絞り込み役職名を設定します。

パラメータ:
narrowPostName - 絞り込み役職名

isNoticeMailFlag

public boolean isNoticeMailFlag()
代理元メール通知フラグを取得します。

戻り値:
代理元メール通知フラグ

setNoticeMailFlag

public void setNoticeMailFlag(boolean noticeMailFlag)
代理元メール通知フラグを設定します。

パラメータ:
noticeMailFlag - 代理元メール通知フラグ

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを取得します。

戻り値:
プロセス定義コード

setProcessDefCd

public void setProcessDefCd(String processDefCd)
プロセス定義コードを設定します。

パラメータ:
processDefCd - プロセス定義コード

isSendMailFlag

public boolean isSendMailFlag()
メール通知フラグを取得します。

戻り値:
メール通知フラグ

setSendMailFlag

public void setSendMailFlag(boolean sendMailFlag)
メール通知フラグを設定します。

パラメータ:
sendMailFlag - メール通知フラグ

isSubRecognitionFlag

public boolean isSubRecognitionFlag()
代理元承認可否フラグを取得します。

戻り値:
代理元承認可否フラグ

setSubRecognitionFlag

public void setSubRecognitionFlag(boolean subRecognitionFlag)
代理元承認可否フラグを設定します。

パラメータ:
subRecognitionFlag - 代理元承認可否フラグ

getTransferCd

public String getTransferCd()
代理依頼先コードを取得します。

戻り値:
代理依頼先コード

setTransferCd

public void setTransferCd(String transferCd)
代理依頼先コードを設定します。

パラメータ:
transferCd - 代理依頼先コード

getTransferCdType

public String getTransferCdType()
代理依頼先種別を取得します。

戻り値:
代理依頼先種別

setTransferCdType

public void setTransferCdType(String transferCdType)
代理依頼先種別を設定します。

パラメータ:
transferCdType - 代理依頼先種別

getTransferComment

public String getTransferComment()
代理コメントを取得します。

戻り値:
代理コメント

setTransferComment

public void setTransferComment(String transferComment)
代理コメントを設定します。

パラメータ:
transferComment - 代理コメント

getTransferGroupCd

public String getTransferGroupCd()
代理依頼先グループコードを取得します。

戻り値:
代理依頼先グループコード

setTransferGroupCd

public void setTransferGroupCd(String transferGroupCd)
代理依頼先グループコードを設定します。

パラメータ:
transferGroupCd - 代理依頼先グループコード

getTransferName

public String getTransferName()
代理依頼先名を取得します。

戻り値:
代理依頼先名

setTransferName

public void setTransferName(String transferName)
代理依頼先名を設定します。

パラメータ:
transferName - 代理依頼先名

getTransferStatus

public String getTransferStatus()
代理設定種別を取得します。

戻り値:
代理設定種別

setTransferStatus

public void setTransferStatus(String transferStatus)
代理設定種別を設定します。

パラメータ:
transferStatus - 代理設定種別

getVersionCd

public String getVersionCd()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCd

public void setVersionCd(String versionCd)
バージョンコードを設定します。

パラメータ:
versionCd - バージョンコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransferProcessDefModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TransferProcessDefModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TransferProcessDefModel
public class TransferProcessDefModel
extends Object

コンストラクタの概要
TransferProcessDefModel()
コンストラクタ
メソッドの概要
String | getNarrowPostCd() 絞り込み役職コードを取得します。
String | getNarrowPostName() 絞り込み役職名を取得します。
String | getProcessDefCd() プロセス定義コードを取得します。
String | getProcessDefName() プロセス定義名を取得します。
String | getTransferCd() 代理依頼先コードを取得します。
String | getTransferCdType() 代理依頼先種別を取得します。
String | getTransferEndDate() 代理期間(終了日)を取得します。
String | getTransferGroupCd() 代理依頼先グループコードを取得します。
String | getTransferName() 代理依頼先名を取得します。
String | getTransferStartDate() 代理期間(開始日)を取得します。
String | getTransferStatus() 代理設定種別を取得します。
boolean | isTransferActivityFlag() タスク委譲フラグを取得します。
boolean | isTransferVersionFlag() バージョン委譲フラグを取得します。
void | setNarrowPostCd(String narrowPostCd) 絞り込み役職コードを設定します。
void | setNarrowPostName(String narrowPostName) 絞り込み役職名を設定します。
void | setProcessDefCd(String processDefCd) プロセス定義コードを設定します。
void | setProcessDefName(String processDefName) プロセス定義名を設定します。
void | setTransferActivityFlag(boolean transferActivityFlag) タスク委譲フラグを設定します。
void | setTransferCd(String transferCd) 代理依頼先コードを設定します。
void | setTransferCdType(String transferCdType) 代理依頼先種別を設定します。
void | setTransferEndDate(String transferEndDate) 代理期間(終了日)を設定します。
void | setTransferGroupCd(String transferGroupCd) 代理依頼先グループコードを設定します。
void | setTransferName(String transferName) 代理依頼先名を設定します。
void | setTransferStartDate(String transferStartDate) 代理期間(開始日)を設定します。
void | setTransferStatus(String transferStatus) 代理設定種別を設定します。
void | setTransferVersionFlag(boolean transferVersionFlag) バージョン委譲フラグを設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TransferProcessDefModel

public TransferProcessDefModel()
コンストラクタ

メソッドの詳細

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを取得します。

戻り値:
プロセス定義コード

setProcessDefCd

public void setProcessDefCd(String processDefCd)
プロセス定義コードを設定します。

パラメータ:
processDefCd - プロセス定義コード

getProcessDefName

public String getProcessDefName()
プロセス定義名を取得します。

戻り値:
プロセス定義名

setProcessDefName

public void setProcessDefName(String processDefName)
プロセス定義名を設定します。

パラメータ:
processDefName - プロセス定義名

getTransferEndDate

public String getTransferEndDate()
代理期間(終了日)を取得します。

戻り値:
代理期間(終了日)

setTransferEndDate

public void setTransferEndDate(String transferEndDate)
代理期間(終了日)を設定します。

パラメータ:
transferEndDate - 代理期間(終了日)

getTransferStartDate

public String getTransferStartDate()
代理期間(開始日)を取得します。

戻り値:
代理期間(開始日)

setTransferStartDate

public void setTransferStartDate(String transferStartDate)
代理期間(開始日)を設定します。

パラメータ:
transferStartDate - 代理期間(開始日)

getTransferCdType

public String getTransferCdType()
代理依頼先種別を取得します。

戻り値:
代理依頼先種別

setTransferCdType

public void setTransferCdType(String transferCdType)
代理依頼先種別を設定します。

パラメータ:
transferCdType - 代理依頼先種別

getTransferGroupCd

public String getTransferGroupCd()
代理依頼先グループコードを取得します。

戻り値:
代理依頼先グループコード

setTransferGroupCd

public void setTransferGroupCd(String transferGroupCd)
代理依頼先グループコードを設定します。

パラメータ:
transferGroupCd - 代理依頼先グループコード

getTransferCd

public String getTransferCd()
代理依頼先コードを取得します。

戻り値:
代理依頼先コード

setTransferCd

public void setTransferCd(String transferCd)
代理依頼先コードを設定します。

パラメータ:
transferCd - 代理依頼先コード

getTransferName

public String getTransferName()
代理依頼先名を取得します。

戻り値:
代理依頼先名

setTransferName

public void setTransferName(String transferName)
代理依頼先名を設定します。

パラメータ:
transferName - 代理依頼先名

getNarrowPostCd

public String getNarrowPostCd()
絞り込み役職コードを取得します。

戻り値:
絞り込み役職コード

setNarrowPostCd

public void setNarrowPostCd(String narrowPostCd)
絞り込み役職コードを設定します。

パラメータ:
narrowPostCd - 絞り込み役職コード

getNarrowPostName

public String getNarrowPostName()
絞り込み役職名を取得します。

戻り値:
絞り込み役職名

setNarrowPostName

public void setNarrowPostName(String narrowPostName)
絞り込み役職名を設定します。

パラメータ:
narrowPostName - 絞り込み役職名

getTransferStatus

public String getTransferStatus()
代理設定種別を取得します。

戻り値:
代理設定種別

setTransferStatus

public void setTransferStatus(String transferStatus)
代理設定種別を設定します。

パラメータ:
transferStatus - 代理設定種別

isTransferActivityFlag

public boolean isTransferActivityFlag()
タスク委譲フラグを取得します。

戻り値:
タスク委譲フラグ

setTransferActivityFlag

public void setTransferActivityFlag(boolean transferActivityFlag)
タスク委譲フラグを設定します。

パラメータ:
transferActivityFlag - タスク委譲フラグ

isTransferVersionFlag

public boolean isTransferVersionFlag()
バージョン委譲フラグを取得します。

戻り値:
バージョン委譲フラグ

setTransferVersionFlag

public void setTransferVersionFlag(boolean transferVersionFlag)
バージョン委譲フラグを設定します。

パラメータ:
transferVersionFlag - バージョン委譲フラグ
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


TransferVersionModel (bpw 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス TransferVersionModel

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.TransferVersionModel
public class TransferVersionModel
extends Object

コンストラクタの概要
TransferVersionModel()
メソッドの概要
String | getEffctiveDate() 有効日付を取得します。
String | getEndDate() 終了日付を取得します。
String | getNarrowPostCd() 絞り込み役職コードを取得します。
String | getNarrowPostName() 絞り込み役職名を取得します。
String | getProcessDefCd() プロセス定義コードを取得します。
String | getTransferCd() 代理依頼先コードを取得します。
String | getTransferCdType() 代理依頼先種別を取得します。
String | getTransferEndDate() 代理期間(終了日)を取得します。
String | getTransferGroupCd() 代理依頼先グループコードを取得します。
String | getTransferName() 代理依頼先名を取得します。
String | getTransferStartDate() 代理期間(開始日)を取得します。
String | getTransferStatus() 代理設定種別を取得します。
String | getVersionCd() バージョンコードを取得します。
String | getVersionName() バージョン名を取得します。
boolean | isTransferActivityFlag() タスク委譲フラグを取得します。
void | setEffctiveDate(String effctiveDate) 有効日付を設定します。
void | setEndDate(String endDate) 終了日付を設定します。
void | setNarrowPostCd(String narrowPostCd) 絞り込み役職コードを設定します。
void | setNarrowPostName(String narrowPostName) 絞り込み役職名を設定します。
void | setProcessDefCd(String processDefCd) プロセス定義コードを設定します。
void | setTransferActivityFlag(boolean transferActivityFlag) タスク委譲フラグを設定します。
void | setTransferCd(String transferCd) 代理依頼先コードを設定します。
void | setTransferCdType(String transferCdType) 代理依頼先種別を設定します。
void | setTransferEndDate(String transferEndDate) 代理期間(終了日)を設定します。
void | setTransferGroupCd(String transferGroupCd) 代理依頼先グループコードを設定します。
void | setTransferName(String transferName) 代理依頼先名を設定します。
void | setTransferStartDate(String transferStartDate) 代理期間(開始日)を設定します。
void | setTransferStatus(String transferStatus) 代理設定種別を設定します。
void | setVersionCd(String versionCd) バージョンコードを設定します。
void | setVersionName(String versionName) バージョン名を設定します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

TransferVersionModel

public TransferVersionModel()
メソッドの詳細

getProcessDefCd

public String getProcessDefCd()
プロセス定義コードを取得します。

戻り値:
プロセス定義コード

setProcessDefCd

public void setProcessDefCd(String processDefCd)
プロセス定義コードを設定します。

パラメータ:
processDefCd - プロセス定義コード

getVersionCd

public String getVersionCd()
バージョンコードを取得します。

戻り値:
バージョンコード

setVersionCd

public void setVersionCd(String versionCd)
バージョンコードを設定します。

パラメータ:
versionCd - バージョンコード

getVersionName

public String getVersionName()
バージョン名を取得します。

戻り値:
バージョン名

setVersionName

public void setVersionName(String versionName)
バージョン名を設定します。

パラメータ:
versionName - バージョン名

getTransferEndDate

public String getTransferEndDate()
代理期間(終了日)を取得します。

戻り値:
代理期間(終了日)

setTransferEndDate

public void setTransferEndDate(String transferEndDate)
代理期間(終了日)を設定します。

パラメータ:
transferEndDate - 代理期間(終了日)

getTransferStartDate

public String getTransferStartDate()
代理期間(開始日)を取得します。

戻り値:
代理期間(開始日)

setTransferStartDate

public void setTransferStartDate(String transferStartDate)
代理期間(開始日)を設定します。

パラメータ:
transferStartDate - 代理期間(開始日)

getTransferCdType

public String getTransferCdType()
代理依頼先種別を取得します。

戻り値:
代理依頼先種別

setTransferCdType

public void setTransferCdType(String transferCdType)
代理依頼先種別を設定します。

パラメータ:
transferCdType - 代理依頼先種別

getTransferGroupCd

public String getTransferGroupCd()
代理依頼先グループコードを取得します。

戻り値:
代理依頼先グループコード

setTransferGroupCd

public void setTransferGroupCd(String transferGroupCd)
代理依頼先グループコードを設定します。

パラメータ:
transferGroupCd - 代理依頼先グループコード

getTransferCd

public String getTransferCd()
代理依頼先コードを取得します。

戻り値:
代理依頼先コード

setTransferCd

public void setTransferCd(String transferCd)
代理依頼先コードを設定します。

パラメータ:
transferCd - 代理依頼先コード

getTransferName

public String getTransferName()
代理依頼先名を取得します。

戻り値:
代理依頼先名

setTransferName

public void setTransferName(String transferName)
代理依頼先名を設定します。

パラメータ:
transferName - 代理依頼先名

getNarrowPostCd

public String getNarrowPostCd()
絞り込み役職コードを取得します。

戻り値:
絞り込み役職コード

setNarrowPostCd

public void setNarrowPostCd(String narrowPostCd)
絞り込み役職コードを設定します。

パラメータ:
narrowPostCd - 絞り込み役職コード

getNarrowPostName

public String getNarrowPostName()
絞り込み役職名を取得します。

戻り値:
絞り込み役職名

setNarrowPostName

public void setNarrowPostName(String narrowPostName)
絞り込み役職名を設定します。

パラメータ:
narrowPostName - 絞り込み役職名

getTransferStatus

public String getTransferStatus()
代理設定種別を取得します。

戻り値:
代理設定種別

setTransferStatus

public void setTransferStatus(String transferStatus)
代理設定種別を設定します。

パラメータ:
transferStatus - 代理設定種別

isTransferActivityFlag

public boolean isTransferActivityFlag()
タスク委譲フラグを取得します。

戻り値:
タスク委譲フラグ

setTransferActivityFlag

public void setTransferActivityFlag(boolean transferActivityFlag)
タスク委譲フラグを設定します。

パラメータ:
transferActivityFlag - タスク委譲フラグ

getEffctiveDate

public String getEffctiveDate()
有効日付を取得します。

戻り値:
有効日付

setEffctiveDate

public void setEffctiveDate(String effctiveDate)
有効日付を設定します。

パラメータ:
effctiveDate - 有効日付

getEndDate

public String getEndDate()
終了日付を取得します。

戻り値:
終了日付

setEndDate

public void setEndDate(String endDate)
終了日付を設定します。

パラメータ:
endDate - 終了日付
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


Util (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.wkf
クラス Util

java.lang.Object
    拡張 jp.co.intra_mart.foundation.wkf.Util
public class Util
extends Object

ユーティリティ バッチ起動用クラス

コンストラクタの概要
Util(String login_group_id)
コンストラクタ
メソッドの概要
void | autoPass(String category_cd, String process_def_cd, String version_cd, int date) 案件の自動パス(バッチ起動)処理を行います。
void | autoPress(String category_cd, String process_def_cd, String version_cd, int date) 案件の自動催促(バッチ起動)処理を行います。
void | sendMail(String template_path, String process_def_cd, String version_cd, String process_cd, String activity_cd, ArrayList to, ArrayList cc, ArrayList bcc) メール送信処理を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

Util

public Util(String login_group_id)
     throws WKFApplicationException
コンストラクタ

パラメータ:
login_group_id - ログイングループID(必須)
例外:
WKFApplicationException - エラーコード
メソッドの詳細

sendMail

public void sendMail(String template_path,
                     String process_def_cd,
                     String version_cd,
                     String process_cd,
                     String activity_cd,
                     ArrayList to,
                     ArrayList cc,
                     ArrayList bcc)
              throws WKFApplicationException
メール送信処理を行います。
メール送信結果を返却します。

パラメータ:
template_path - テンプレートパス(必須)
process_def_cd - プロセス定義コード(必須)
version_cd - バージョンコード(必須)
process_cd - プロセスコード(必須)
activity_cd - アクティビティコード(必須)
to - Toメールアドレス配列
cc - Ccメールアドレス配列
bcc - Bccメールアドレス配列
例外:
WKFApplicationException - エラーコード

autoPass

public void autoPass(String category_cd,
                     String process_def_cd,
                     String version_cd,
                     int date)
              throws WKFApplicationException
案件の自動パス(バッチ起動)処理を行います。

パラメータ:
category_cd - カテゴリコード(任意：未指定時全カテゴリ)
process_def_cd - プロセス定義コード(任意：未指定時全プロセス定義)
version_cd - 履歴コード(任意：未指定時全バージョン)
date - 承認期限の延長日数(任意)
例外:
WKFApplicationException - エラーコード

autoPress

public void autoPress(String category_cd,
                      String process_def_cd,
                      String version_cd,
                      int date)
               throws WKFApplicationException
案件の自動催促(バッチ起動)処理を行います。

パラメータ:
category_cd - カテゴリコード(任意：未指定時全カテゴリ)
process_def_cd - プロセス定義コード(任意：未指定時全プロセス定義)
version_cd - 履歴コード(任意：未指定時全バージョン)
date - 承認期限の延長日数(任意)
例外:
WKFApplicationException - エラーコード
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.system.bpw.WfeResultMailManager の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.system.bpw.WfeResultMailManager の使用

jp.co.intra_mart.system.bpw.WfeResultMailManager はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.system.bpw (bpw 6.1.14 API)

 jp.co.intra_mart.system.bpw
クラス
WfeResultMailManager


jp.co.intra_mart.system.bpw (bpw 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.system.bpw

クラスの概要
WfeResultMailManager ワークフローエンジン内にて結果送信メール（テンプレート）の送信情報の管理保持を行う。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.system.bpw クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.system.bpw の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.system.bpw.WfeResultMailManager
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.system.bpw の使用 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.system.bpw の使用

jp.co.intra_mart.system.bpw はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


WfeResultMailManager (bpw 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.system.bpw
クラス WfeResultMailManager

java.lang.Object
    拡張 jp.co.intra_mart.system.bpw.WfeResultMailManager
public class WfeResultMailManager
extends Object

ワークフローエンジン内にて結果送信メール（テンプレート）の送信情報の管理保持を行う。

コンストラクタの概要
WfeResultMailManager()
メソッドの概要
static void | addReserveInfo(ArrayList info) 送信メール情報を追加設定します。
static boolean | chkStopMailList(String key) 停止対象となるテンプレートメールのチェックを行います。
static HashMap | getMailTamplate() 設定されたメールテンプレートを取得します。
static ArrayList | getReserveInfo() 送信されるメール内容情報を取得します。
static boolean | isReserve() メール予約機能使用有無を判定します。
static boolean | isStop() テンプレートメールの送信抑止を判定します。
static void | removeInfo() 処理失敗時にWfeResultMailManagerを使用し設定された情報を削除する為に使用します。
static void | reserveCancel() メール予約機能の使用を取消します。
static void | reserveRequest() メール予約機能の使用を依頼します。
static void | send() メールの送信を実行します。
static void | setMailTamplate(HashMap template) メールテンプレートの設定を行います。
static void | setReserveInfo(ArrayList infoList) 送信メール情報を設定します。
static void | setStopMail(String key) 停止対象となるテンプレートメール情報を保持します。
static void | setTamplateRequest(String templatePath) メールテンプレートの設定を行います。
static void | stopCancel() テンプレートメールの送信停止を取り止めます。
static void | stopRequest() 同一スレッド内のテンプレートメールの標準送信を停止させます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

WfeResultMailManager

public WfeResultMailManager()
メソッドの詳細

isReserve

public static boolean isReserve()
                         throws jp.co.intra_mart.framework.system.exception.SystemException
メール予約機能使用有無を判定します。

戻り値:
boolean true(予約機能を使用する)/false(使用しない)
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

reserveRequest

public static void reserveRequest()
                           throws jp.co.intra_mart.framework.system.exception.SystemException
メール予約機能の使用を依頼します。
処理が正常終了した場合にのみテンプレートメールが送信されるように、メール予約を行います。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

reserveCancel

public static void reserveCancel()
                          throws jp.co.intra_mart.framework.system.exception.SystemException
メール予約機能の使用を取消します。
reserveRequest()を使用してメール予約の設定をしてある場合、そのメール予約を取り消します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

isStop

public static boolean isStop()
                      throws jp.co.intra_mart.framework.system.exception.SystemException
テンプレートメールの送信抑止を判定します。

戻り値:
boolean true(抑止あり)/false(なし)
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

stopRequest

public static void stopRequest()
                        throws jp.co.intra_mart.framework.system.exception.SystemException
同一スレッド内のテンプレートメールの標準送信を停止させます。
テンプレートメールの標準送信機能を停止させたい場合に使用します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

stopCancel

public static void stopCancel()
                       throws jp.co.intra_mart.framework.system.exception.SystemException
テンプレートメールの送信停止を取り止めます。
stopRequest()を使用してテンプレートメールの送信停止の設定をしてある場合、
その送信停止の設定を取り止め、解除します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

getMailTamplate

public static HashMap getMailTamplate()
                               throws jp.co.intra_mart.framework.system.exception.SystemException
設定されたメールテンプレートを取得します。
メールテンプレートの設定が行われている場合に、設定されたメールテンプレートを取得します。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

setTamplateRequest

public static void setTamplateRequest(String templatePath)
                               throws jp.co.intra_mart.framework.system.exception.SystemException
メールテンプレートの設定を行います。
テンプレートメールの送信時に送信されるメールのテンプレートを変更したいときに使用します。
StorageService からのメールテンプレート相対パスを指定してください。

パラメータ:
templatePath - テンプレートパス
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

setMailTamplate

public static void setMailTamplate(HashMap template)
                            throws jp.co.intra_mart.framework.system.exception.SystemException
メールテンプレートの設定を行います。
テンプレートメールの送信時に送信されるメールのテンプレートを変更したいときに使用します。

パラメータ:
template - テンプレートファイル情報
例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

getReserveInfo

public static ArrayList getReserveInfo()
                                throws jp.co.intra_mart.framework.system.exception.SystemException
送信されるメール内容情報を取得します。
システム内で利用されるメソッドとなります。
このメソッドはアプリケーションで使用する必要はありません。

例外:
jp.co.intra_mart.framework.system.exception.SystemException

addReserveInfo

public static void addReserveInfo(ArrayList info)
                           throws jp.co.intra_mart.framework.system.exception.SystemException
送信メール情報を追加設定します。
システム内で利用されるメソッドとなります。
このメソッドはアプリケーションで使用する必要はありません。

例外:
jp.co.intra_mart.framework.system.exception.SystemException

setReserveInfo

public static void setReserveInfo(ArrayList infoList)
                           throws jp.co.intra_mart.framework.system.exception.SystemException
送信メール情報を設定します。
システム内で利用されるメソッドとなります。
このメソッドはアプリケーションで使用する必要はありません。

例外:
jp.co.intra_mart.framework.system.exception.SystemException

setStopMail

public static void setStopMail(String key)
                        throws jp.co.intra_mart.framework.system.exception.SystemException
停止対象となるテンプレートメール情報を保持します。
停止対象のテンプレート判別情報をExtenelMemoryで保持します。
引数には停止対象となるメールテンプレートキーを指定してください。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

chkStopMailList

public static boolean chkStopMailList(String key)
                               throws jp.co.intra_mart.framework.system.exception.SystemException
停止対象となるテンプレートメールのチェックを行います。
システム内で利用されるメソッドとなります。
このメソッドはアプリケーションで使用する必要はありません。

例外:
jp.co.intra_mart.framework.system.exception.SystemException

send

public static void send()
                 throws jp.co.intra_mart.framework.system.exception.SystemException
メールの送信を実行します。
送信予約されているメールがある場合に、そのメールの送信を行います。
APIを使用して申請等の処理を行っている場合に、使用します。
WfeResultMailManagerを使用する場合は処理が正常終了した後に
必ず実行してください。
また、処理が失敗した場合はremove()を実行してください。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外

removeInfo

public static void removeInfo()
                       throws jp.co.intra_mart.framework.system.exception.SystemException
処理失敗時にWfeResultMailManagerを使用し設定された情報を削除する為に使用します。
申請/承認等の処理が失敗した場合にこのメソッドを実行してください。
このメソッドが実行されなかった場合、設定された情報が残ってしまい、
予期しない動作を起こす可能性があります。

例外:
jp.co.intra_mart.framework.system.exception.SystemException - システム例外
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


すべてのクラス (bpw 6.1.14 API)

 すべてのクラス
ActivityInfoModel
ActivityTaskModel
AgentSetting
Approver
BPWErrorCodeIF
BPWExecuteLogic
ConditionAdapter
ConditionModel
ContentsPathDetailModel
ContentsPathModel
CreateRouteInfoModel
CreateRouteTargetInfoModel
Drafter
EISModelStaticIF
FlowInfo
Manager
NegoModel
Process
ProcessInfoModel
ReceiveTaskModel
RecognitionInfoModel
Reference
RunExecutiveInfoModel
RunUserInfoModel
SearchCondition
Sort
TargetAutoPassModel
TargetInfoModel
TaskInfo
TransferActivityModel
TransferInfoModel
TransferProcessDefModel
TransferVersionModel
Util
VersionInfoModel
WKFApplicationException
WKFErrorCodeIF
WfeResultMailManager


定数フィールド値 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

定数フィールド値

コンテンツ
  • jp.co.*
jp.co.*

jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF
public static final String | BPW_C_ALREADY_EXIST_TRANSFER | "BPW_Core_Alredy_Exist_Transfer"
public static final String | BPW_C_ALREADY_SUSPEND | "BPW_Core_Already_Suspend"
public static final String | BPW_C_AUTO_EXECUTE_FAULT | "BPW_Core_Auto_Execute_Fault"
public static final String | BPW_C_CAN_NOT_START_JAVASCRIPT | "BPW_Core_Can_Not_Start_JavaScript"
public static final String | BPW_C_CATEGORY_DISAGREEMENT | "BPW_Core_Category_Disagreement"
public static final String | BPW_C_CHANGE_AGENTSETTING | "BPW_Core_Change_AgentSetting"
public static final String | BPW_C_CHANGE_INFO | "BPW_Core_Chenge_Info"
public static final String | BPW_C_CHANGING_NOW | "BPW_Core_Changing_Now"
public static final String | BPW_C_DATA_NOT_FOUND | "BPW_Core_Data_Not_Found"
public static final String | BPW_C_DUPLICATE_CATEGORY | "BPW_Core_Duplicate_Category"
public static final String | BPW_C_DUPLICATE_NAME | "BPW_Core_Duplicate_Name"
public static final String | BPW_C_EXIST_PROCESS_DEF | "BPW_Core_Exist_ProcessDef"
public static final String | BPW_C_FAILED_GET_HTTP_EXCEL_STREAM | "BPW_Core_Failed_Get_ExcelFileStream"
public static final String | BPW_C_FAILED_READ_EXCEL_STREAM | "BPW_Core_Failed_Get_ExcelFileStream"
public static final String | BPW_C_FOUND_AUTO_PASS_TABLE | "BPW_Core_Found_AutoPassTable"
public static final String | BPW_C_FOUND_PROCESS | "BPW_Core_Found_Process"
public static final String | BPW_C_FOUND_RECEIVE_MASTER | "BPW_Core_Found_ReceiveMaster"
public static final String | BPW_C_FOUND_RECEIVE_TABLE | "BPW_Core_Found_ReceiveTable"
public static final String | BPW_C_FOUND_RUN_USER_TABLE | "BPW_Core_Found_RunUserTable"
public static final String | BPW_C_FOUND_RUNNING_PROCESS | "BPW_Core_Found_Running_Process"
public static final String | BPW_C_FOUND_VERSION | "BPW_Core_Found_Version"
public static final String | BPW_C_HAVE_NOT_AUTHORITY | "BPW_Core_Have_Not_Authority"
public static final String | BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND | "BPW_Core_Have_Not_Authority_or_Data_Not_Found"
public static final String | BPW_C_ILLIGAL_STATUS | "BPW_Core_Illigal_Status"
public static final String | BPW_C_ILLIGAL_STATUS_CHG | "BPW_Core_Illigal_Status_Change"
public static final String | BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER | "BPW_Core_Import_Can_Not_Set_Run_Refer"
public static final String | BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD | "BPW_Core_Import_Change_ProcessClassCd"
public static final String | BPW_C_IMPORT_DUPLICATE_APPROVAL_CD | "BPW_Core_Import_Duplicate_Approval_Cd"
public static final String | BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE | "BPW_Core_Import_Cuplicate_ContentsType"
public static final String | BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION | "BPW_Core_Import_Duplicate_ProcessDefinition"
public static final String | BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID | "BPW_Core_Import_Cuplicate_RootDefId"
public static final String | BPW_C_IMPORT_DUPLICATE_TASK_ID | "BPW_Core_Import_Duplicate_Task_Id"
public static final String | BPW_C_IMPORT_INVALID_ACTIVITY_TYPE | "BPW_Core_Import_Invalid_Activity_Type"
public static final String | BPW_C_IMPORT_INVALID_APPLICATION_ID | "BPW_Core_Import_Invalid_ApplitionID"
public static final String | BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN | "BPW_Core_Import_Invalid_ApplicationID_Len"
public static final String | BPW_C_IMPORT_INVALID_APPROVAL | "BPW_Core_Import_Invalid_Approval"
public static final String | BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG | "BPW_Core_Import_Invalid_Approval_After_ShortestEndFlag"
public static final String | BPW_C_IMPORT_INVALID_APPROVAL_FOCUS | "BPW_Core_Import_Invalid_Approval_Focus"
public static final String | BPW_C_IMPORT_INVALID_ATTACHMENT_FLAG | "BPW_Core_Import_Invalid_AttachmentFlag"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD | "BPW_Core_Import_Invalid_AutoPassExecutivePostCd"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND | "BPW_Core_Import_Invalid_AutoPassExecutivePostCdKind"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_FLG | "BPW_Core_Import_Invalid_AutoPassFlag"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS | "BPW_Core_Import_Invalid_AutoPass_Focus"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM | "BPW_Core_Import_Invalid_AutoPassTerm"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN | "BPW_Core_Import_Invalid_AutoPassTermLen"
public static final String | BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD | "BPW_Core_Import_Invalid_AutoPassUserCd"
public static final String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD | "BPW_Core_Import_Invalid_CallProcessDefCd"
public static final String | BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN | "BPW_Core_Import_Invalid_CallProcessDefCd_Len"
public static final String | BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN | "BPW_Core_Import_Invalid_RunClass_Len"
public static final String | BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN | "BPW_Core_Import_Invalid_Category_Cd_Len"
public static final String | BPW_C_IMPORT_INVALID_CODE_KIND | "BPW_Core_Import_Invalid_CodeKind"
public static final String | BPW_C_IMPORT_INVALID_CODE_KIND_VALUE | "BPW_Core_Import_Invalid_CodeKind_Value"
public static final String | BPW_C_IMPORT_INVALID_COMPULSION_END_FLG | "BPW_Core_Import_Invalid_CompulsionEndFlag"
public static final String | BPW_C_IMPORT_INVALID_CONDITION_CALSS | "BPW_Core_Import_Invalid_ConditionClass"
public static final String | BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN | "BPW_Core_Import_ConditionClass_Len"
public static final String | BPW_C_IMPORT_INVALID_CONTENTS_FRAME_TYPE | "BPW_Core_Import_Invalid_Contents_Frame_Type"
public static final String | BPW_C_IMPORT_INVALID_CONTENTS_PATH | "BPW_Core_Import_Invalid_ContentsPath"
public static final String | BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN | "BPW_Core_Import_Invalid_ContentsPath_Len"
public static final String | BPW_C_IMPORT_INVALID_CONTENTSTYPE | "BPW_Core_Import_Invalid_ContentsType"
public static final String | BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND | "BPW_Core_Import_Invalid_DraftTypeKind"
public static final String | BPW_C_IMPORT_INVALID_DRAFTER_TASK_LOCATION | "BPW_Core_Import_Invalid_Drafter_Task_Location"
public static final String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE | "BPW_Core_Import_Invalid_EffectiveDate"
public static final String | BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN | "BPW_Core_Import_Invalid_EffectiveDate_Len"
public static final String | BPW_C_IMPORT_INVALID_END_DATE | "BPW_Core_Import_Invalid_EndDate"
public static final String | BPW_C_IMPORT_INVALID_END_DATE_LEN | "BPW_Core_Import_Invalid_EndDate_Len"
public static final String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID | "BPW_Core_Import_Invalid_EventServiceID"
public static final String | BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN | "BPW_Core_Import_EventServiceID_Len"
public static final String | BPW_C_IMPORT_INVALID_FUNCTION_KBN | "BPW_Core_Import_Invalid_Function_Kbn"
public static final String | BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN | "BPW_Core_Import_Invalid_MailContentsDef_Len"
public static final String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT | "BPW_Core_Import_Invalid_MailPostPonement"
public static final String | BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN | "BPW_Core_Import_Invalid_MailPostPonement_Len"
public static final String | BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN | "BPW_Core_Import_Invalid_MailTitleDef_Len"
public static final String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION | "BPW_Core_Import_Invalid_MailToClassification"
public static final String | BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN | "BPW_Core_Import_Invalid_MailToClassification_Len"
public static final String | BPW_C_IMPORT_INVALID_PAGBE_KIND | "BPW_Core_Import_Invalid_PageKind"
public static final String | BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY | "BPW_Core_Import_Invalid_Pre_RunRefer_Activity"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID | "BPW_Core_Import_Invalid_ProcessApplitionID"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN | "BPW_Core_Import_Invalid_ProcessApplicationID_Len"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD | "BPW_Core_Import_Invalid_ProcessClassCd"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH | "BPW_Core_Import_Invalid_ProcessContentsPath"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN | "BPW_Core_Import_Invalid_ProcessContentsPath_Len"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE | "BPW_Core_Import_Invalid_ProcessContentsType"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN | "BPW_Core_Import_Invalid_Processdef_Cd_Len"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT | "BPW_Core_Import_Invalid_Process_Flow_Count"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND | "BPW_Core_Import_Invalid_ProcessPageKind"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT | "BPW_Core_Import_Invalid_Process_Route_Select"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID | "BPW_Core_Import_Invalid_ProcessServiceID"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN | "BPW_Core_Import_Invalid_ProcessServiceID_Len"
public static final String | BPW_C_IMPORT_INVALID_PROCESS_SWITCH | "BPW_Core_Import_Invalid_Process_Switch"
public static final String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW | "BPW_Core_Import_Invalid_ProcessClassCd_And_SubProcessFlag_Bpw"
public static final String | BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW | "BPW_Core_Import_Invalid_ProcessClassCd_And_SubProcessFlag_Drw"
public static final String | BPW_C_IMPORT_INVALID_REFER_FOCUS | "BPW_Core_Import_Invalid_Refer_Focus"
public static final String | BPW_C_IMPORT_INVALID_REFER_USER_CD | "BPW_Core_Import_Invalid_ReferUserCd"
public static final String | BPW_C_IMPORT_INVALID_RETURN_PULL_FLG | "BPW_Core_Import_Invalid_ReturnPullFlag"
public static final String | BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG | "BPW_Core_Import_Invalid_ReturnPullMailFlag"
public static final String | BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG | "BPW_Core_Import_Invalid_Root_After_ShortestEndFlag"
public static final String | BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW | "BPW_Core_Import_Invalid_Root_Def_Of_Flow"
public static final String | BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE | "BPW_Core_Import_Invalid_Root_Of_Invoke_Process_Before_Receive"
public static final String | BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE | "BPW_Core_Import_Invalid_Root_Of_Route_Select_Before_Receive"
public static final String | BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE | "BPW_Core_Import_Invalid_Root_Of_Run_Select_User_Before_Task"
public static final String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD | "BPW_Core_Import_Invalid_RunActivityCd"
public static final String | BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN | "BPW_Core_Import_RunActivityCd_Len"
public static final String | BPW_C_IMPORT_INVALID_RUN_CLASS | "BPW_Core_Import_Invalid_RunClass"
public static final String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD | "BPW_Core_Import_Invalid_RunExecutiveCompanyCd"
public static final String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD | "BPW_Core_Import_Invalid_RunExecutivePostCd"
public static final String | BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND | "BPW_Core_Import_Invalid_RunExecutivePostCdKind"
public static final String | BPW_C_IMPORT_INVALID_RUN_USER_CD | "BPW_Core_Import_Invalid_RunUserCd"
public static final String | BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION | "BPW_Core_Import_Invalid_RunSelect_Task_Location"
public static final String | BPW_C_IMPORT_INVALID_SECOND_APPROVAL | "BPW_Core_Import_Invalid_Second_Approval"
public static final String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN | "BPW_Core_Import_Select_Route_Cd_Len"
public static final String | BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN | "BPW_Core_Import_Select_Route_Name_Len"
public static final String | BPW_C_IMPORT_INVALID_SERVECE_ID | "BPW_Core_Import_Invalid_ServiceID"
public static final String | BPW_C_IMPORT_INVALID_SERVICE_ID_LEN | "BPW_Core_Import_Invalid_ServiceID_Len"
public static final String | BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG | "BPW_Core_Import_Invalid_ShortestEndFlag"
public static final String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW | "BPW_Core_Import_Invalid_ShortestEndFlag_Before_Flow"
public static final String | BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW | "BPW_Core_Import_Invalid_ShortestEndFlag_In_Flow"
public static final String | BPW_C_IMPORT_INVALID_START_ACTIVITY | "BPW_Core_Import_Invalid_Start_Activity"
public static final String | BPW_C_IMPORT_INVALID_SUB_PROCESS | "BPW_Core_Import_Invalid_Sub_Process"
public static final String | BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG | "BPW_Core_Import_Invalid_SubProcessFlag"
public static final String | BPW_C_IMPORT_INVALID_TASK_ID | "BPW_Core_Import_Invalid_Task_Id"
public static final String | BPW_C_IMPORT_INVALID_TASK_TYPE | "BPW_Core_Import_Invalid_Task_Type"
public static final String | BPW_C_IMPORT_INVALID_TOP_ACTIVITY | "BPW_Core_Import_Invalid_Top_Activity"
public static final String | BPW_C_IMPORT_INVALID_VERSION_CD | "BPW_Core_Import_Invalid_VersionCd"
public static final String | BPW_C_IMPORT_INVALID_VERSION_CD_LEN | "BPW_Core_Import_Invalid_VersionCd_Len"
public static final String | BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER | "BPW_Core_Import_No_AutoAdapterMaster"
public static final String | BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER | "BPW_Core_Import_No_AoutPassExecutiveMaster"
public static final String | BPW_C_IMPORT_NO_AUTO_PASS_INFO | "BPW_Core_Import_No_AoutPassInfo"
public static final String | BPW_C_IMPORT_NO_AUTO_PASS_MASTER | "BPW_Core_Import_No_AoutPassMaster"
public static final String | BPW_C_IMPORT_NO_AUTO_PASS_USER_CD | "BPW_Core_Import_NoExist_AutoPassUserCd"
public static final String | BPW_C_IMPORT_NO_CONTENTS_MASTER | "BPW_Core_Import_No_ContentsMaster"
public static final String | BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER | "BPW_Core_Import_No_EventAdapterMaster"
public static final String | BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT | "BPW_Core_Import_No_Exist_Approval_Draft"
public static final String | BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD | "BPW_Core_Import_NoExist_AutoPassExecutivePostCd"
public static final String | BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD | "BPW_Core_Import_NoExist_ReferGroupingCd"
public static final String | BPW_C_IMPORT_NO_EXIST_REFER_USER_CD | "BPW_Core_Import_NoExist_ReferUserCd"
public static final String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD | "BPW_Core_Import_NoExist_RunExecutiveCompanyCd"
public static final String | BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD | "BPW_Core_Import_NoExist_RunExecutivePostCd"
public static final String | BPW_C_IMPORT_NO_EXIST_RUN_USER_CD | "BPW_Core_Import_NoExist_RunUserCd"
public static final String | BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS | "BPW_Core_Import_No_First_Condition_Class"
public static final String | BPW_C_IMPORT_NO_FIRST_TASK_ID | "BPW_Core_Import_No_First_Task_Id"
public static final String | BPW_C_IMPORT_NO_FLOW_INNER_MASTER | "BPW_Core_Import_No_FlowInnerMaster"
public static final String | BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY | "BPW_Core_Import_No_FlowRunActivity"
public static final String | BPW_C_IMPORT_NO_LICENSE | "BPW_Core_Import_No_License"
public static final String | BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER | "BPW_Core_Import_No_License_Auto_Event_Adapter"
public static final String | BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW | "BPW_Core_Import_No_FlowSwitch"
public static final String | BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER | "BPW_Core_Import_No_ProcessAdapterMaster"
public static final String | BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE | "BPW_Core_Import_No_Receive_In_First_Sequence"
public static final String | BPW_C_IMPORT_NO_RECEIVE_MASTER | "BPW_Core_Import_No_ReceiveMaster"
public static final String | BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER | "BPW_Core_Import_No_RouteSelectMaster"
public static final String | BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER | "BPW_Core_Import_Found_RunExecutiveMaster"
public static final String | BPW_C_IMPORT_NO_RUN_USER_MASTER | "BPW_Core_Import_Found_RunUserMaster"
public static final String | BPW_C_IMPORT_NO_SELECT_ROUTE_CD | "BPW_Core_Import_No_SelectRouteCd"
public static final String | BPW_C_IMPORT_NO_SELECT_ROUTE_NAME | "BPW_Core_Import_No_SelectRouteName"
public static final String | BPW_C_IMPORT_NO_SEQUENCE_MASTER | "BPW_Core_Import_No_SequenceMaster"
public static final String | BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY | "BPW_Core_Import_No_SequenceRunActivity"
public static final String | BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE | "BPW_Core_Import_No_SubRoot_Of_Flow"
public static final String | BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT | "BPW_Core_Import_No_SubRoot_Of_RouteSelect"
public static final String | BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH | "BPW_Core_Import_No_SubRoot_Of_Switch"
public static final String | BPW_C_IMPORT_NO_SWITCH_MASTER | "BPW_Core_Import_No_SwitchMaster"
public static final String | BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY | "BPW_Core_Import_No_SwitchRunActivity"
public static final String | BPW_C_IMPORT_NO_TASK_DEF | "BPW_Core_Import_Invalid_TaskDef"
public static final String | BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF | "BPW_Core_Import_No_Task_Id_In_Root_Def"
public static final String | BPW_C_IMPORT_OVER_ATTACHMENT_FLAG_LEN | "BPW_Core_Import_Over_AttachmentFlag_Len"
public static final String | BPW_C_IMPORT_OVER_NOTE_LEN | "BPW_Core_Import_Over_Note_Cd_Len"
public static final String | BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN | "BPW_Core_Import_Over_ProcessClassCd_Len"
public static final String | BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN | "BPW_Core_Import_Over_Processdef_Name_Len"
public static final String | BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN | "BPW_Core_Import_Over_ProcessDefNote_Cd_Len"
public static final String | BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN | "BPW_Core_Import_Over_SubProcessFlag_Len"
public static final String | BPW_C_IMPORT_PLURAL_APPROVAL | "BPW_Core_Import_Plural_Approval"
public static final String | BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO | "BPW_Core_Impossible_Root_History_info"
public static final String | BPW_C_INPOSSIBLE_GET_ROOT_INFO | "BPW_Core_Impossible_Get_RootInfo"
public static final String | BPW_C_INPOSSIBLE_GET_USER_APP_KEY | "BPW_Core_Impossible_Get_User_App_key"
public static final String | BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND | "BPW_Core_Impossible_Mail_Template_Send"
public static final String | BPW_C_INPOSSIBLE_SET_MAIL_INFORMATION_REMOVE | "BPW_Core_Impossible_Set_Mail_Information_Remove"
public static final String | BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY | "BPW_Core_Impossible_Set_Mail_Reserve_key"
public static final String | BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY | "BPW_Core_Impossible_Set_Mail_Stop_key"
public static final String | BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY | "BPW_Core_Impossible_Mail_Template_key"
public static final String | BPW_C_INVALID_ACTIVITY_STATUS | "BPW_Core_Invalid_Activity_Status"
public static final String | BPW_C_INVALID_ACTIVITY_TYPE | "BPW_Core_Invalid_Activity_Type"
public static final String | BPW_C_INVALID_ADAPTER_TYPE | "BPW_Core_Invalid_AdapterType"
public static final String | BPW_C_INVALID_APPROVAL_TYPE | "BPW_Core_Invalid_ApprovalType"
public static final String | BPW_C_INVALID_APPROVAL_USER | "BPW_Core_Invalid_ApprovalUser"
public static final String | BPW_C_INVALID_CATEGORY | "BPW_Core_Invalid_Category"
public static final String | BPW_C_INVALID_CATEGORY_CODE | "BPW_Core_Invalid_Categorycode"
public static final String | BPW_C_INVALID_CATEGORY_NAME | "BPW_Core_Invalid_Category_Name"
public static final String | BPW_C_INVALID_CONDITION_TYPE | "BPW_Core_Invalid_Condition_Type"
public static final String | BPW_C_INVALID_DB_PRIMARY_KEY | "BPW_Core_Invalid_DB_Primary_Key"
public static final String | BPW_C_INVALID_LOGIN_GROUP_ID | "BPW_Core_Invalid_LoginGroupID"
public static final String | BPW_C_INVALID_LOGIN_USER_ID | "BPW_Core_Invalid_LoginUserID"
public static final String | BPW_C_INVALID_NECESSARY_KEY | "BPW_Core_Invalid_Necessary_Key"
public static final String | BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY | "BPW_Core_Invalid_ProcessContentsMaster_Select_Key"
public static final String | BPW_C_INVALID_PROCESS_DEF_NAME | "BPW_Core_Invalid_Processdef_Name"
public static final String | BPW_C_INVALID_PROCESSDEF | "BPW_Core_Invalid_Processdef"
public static final String | BPW_C_INVALID_REFER_FLAG | "BPW_Core_Invalid_ReferFlag"
public static final String | BPW_C_INVALID_REMINDER_TYPE | "BPW_Core_Invalid_Reminder_Type"
public static final String | BPW_C_INVALID_RETURN_FLG | "BPW_Core_Invalid_Return_Flag"
public static final String | BPW_C_INVALID_RETURN_START_RUN_USER_INFO | "BPW_Core_Invalid_Return_Start_Run_User_Info"
public static final String | BPW_C_INVALID_ROOT_NAME | "BPW_Core_Invalid_Root_Name"
public static final String | BPW_C_INVALID_RUN_EXECUTIVE_TYPE | "BPW_Core_Invalid_Run_ExecutiveType"
public static final String | BPW_C_INVALID_SELECT_CONDITION_PHRASE | "BPW_Core_Invalid_Select_Condition_Phrase"
public static final String | BPW_C_INVALID_SELECT_IN_PHRASE | "BPW_Core_Invalid_Select_Inphrase"
public static final String | BPW_C_INVALID_TRANSFER_CD_KIND | "BPW_Core_Invalid_TransferCode_Kind"
public static final String | BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY | "BPW_Core_Invalid_Workflow_Select_Primary_Key"
public static final String | BPW_C_MAGICAL_ACTIVE_ACTIVITY | "BPW_Core_Alredy_Active_Activity"
public static final String | BPW_C_MAGICAL_DEACTIVE_PROCESS | "BPW_Core_DeActive_Process"
public static final String | BPW_C_MAGICAL_PLURAL_RUN_USER | "BPW_Core_Plural_Run_User"
public static final String | BPW_C_MAGICAL_RUN_USER | "BPW_Core_Run_User"
public static final String | BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND | "BPW_Core_Mail_Tamplate_Path_Not_Found"
public static final String | BPW_C_MOVE_ACTIVITY_RETURN_PULL | "BPW_Core_Move_Activity_Return_Pull"
public static final String | BPW_C_NO_ATTACH_POSITION_GROUP | "BPW_Core_No_Attach_Position_Group"
public static final String | BPW_C_NO_ATTACH_POSITION_GROUP_AGENT | "BPW_Core_No_Attach_Position_Group_Agent"
public static final String | BPW_C_NO_EVENT_ADAPTER | "BPW_Core_No_Event_Adapter"
public static final String | BPW_C_NO_EXECUTE_ADAPTER | "BPW_Core_No_Execute_Adapter"
public static final String | BPW_C_NO_EXECUTIVE_GROUP | "BPW_Core_No_Executive_Group"
public static final String | BPW_C_NO_FLOW_MASTER_INFO | "BPW_Core_No_FlowMaster_Info"
public static final String | BPW_C_NO_INSERT_VALUE | "BPW_Core_Not_Insert_Value"
public static final String | BPW_C_NO_PROCESS_ADAPTER | "BPW_Core_No_Process_Adapter"
public static final String | BPW_C_NO_ROUTE_SELECT_MASTER | "BPW_Core_No_Route_Select_Master"
public static final String | BPW_C_NO_RUN_SELECT_ACTIVITY | "BPW_Core_No_Run_Select_Activity"
public static final String | BPW_C_NO_RUN_SELECT_USER | "BPW_Core_No_Run_Select_User"
public static final String | BPW_C_NO_RUNUSER_EXCUTIVE_INFO | "BPW_Core_No_RunExcutiveMaster_Info"
public static final String | BPW_C_NO_RUNUSER_MASTER_INFO | "BPW_Core_No_RunUserMaster_Info"
public static final String | BPW_C_NO_SELECTED_TARGET_TASK | "BPW_Core_No_Selected_Target_Task"
public static final String | BPW_C_NO_SEQUENCE_MASTER_INFO | "BPW_Core_No_SequenceMaster_Info"
public static final String | BPW_C_NO_SWHITCH_MASTER_INFO | "BPW_Core_No_SwitchMaster_Info"
public static final String | BPW_C_NO_TRANSFER_AUTHORITY | "BPW_Core_Not_Transefer_Authority"
public static final String | BPW_C_NO_USER_CD | "BPW_Core_No_UserCode"
public static final String | BPW_C_NOT_ACTIVITY | "BPW_Core_Not_Activity"
public static final String | BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL | "BPW_Core_Not_Activity_For_SendMail"
public static final String | BPW_C_NOT_ACTIVITY_MASTER | "BPW_Core_Not_Activity_Master"
public static final String | BPW_C_NOT_BACK_IN_FLOW | "BPW_Core_Not_Back_In_Flow"
public static final String | BPW_C_NOT_DELEGATE_AGENT | "BPW_Core_Not_Delegate_Agent"
public static final String | BPW_C_NOT_DELEGATE_AGENT_SET | "BPW_Core_Not_Delegate_Agent_Set"
public static final String | BPW_C_NOT_DELEGATE_ALREADY | "BPW_Core_Not_Delegate_Already"
public static final String | BPW_C_NOT_DELEGATE_ALREADY_RIGHT | "BPW_Core_Not_Delegate_Already_Right"
public static final String | BPW_C_NOT_DELEGATE_BACK | "BPW_Core_Not_Delegate_Back"
public static final String | BPW_C_NOT_DELEGATE_CIRCULATION | "BPW_Core_Not_Delegate_Circulation"
public static final String | BPW_C_NOT_DELETE_VERSION_LASTRECORD | "BPW_Core_Not_Delete_Version_Last_Record"
public static final String | BPW_C_NOT_EFFECTIVE_DATE | "BPW_Core_Not_Effective_Date"
public static final String | BPW_C_NOT_EXIST_ROLE | "BPW_Core_Not_Exist_Role"
public static final String | BPW_C_NOT_GET_PROCESS_CODE | "BPW_Core_Not_Get_Process_Code"
public static final String | BPW_C_NOT_GROUP_TABLE | "BPW_Core_Not_Group_Table"
public static final String | BPW_C_NOT_INSERT_HISTORY_TABLE_INFO | "BPW_Core_Not_Insert_History_Table_Info"
public static final String | BPW_C_NOT_INSERT_MONITORING_TABLE_INFO | "BPW_Core_Not_Insert_Monitoring_Table_Info"
public static final String | BPW_C_NOT_NUMBER_CATEGORY | "BPW_Core_Not_Number_Category"
public static final String | BPW_C_NOT_PROCESS | "BPW_Core_Not_Process"
public static final String | BPW_C_NOT_PROCESSDEF | "BPW_Core_Not_Processdef"
public static final String | BPW_C_NOT_PULL_DRAFT_ACTIVITY | "BPW_Core_Not_PullDraft_Activity"
public static final String | BPW_C_NOT_RECEIVE_TABLE | "BPW_Core_Not_ReceiveTable"
public static final String | BPW_C_NOT_RETURN_ACTIVITY | "BPW_Core_Not_Return_Activity"
public static final String | BPW_C_NOT_ROOT_HISTORY_INFO | "BPW_Core_Not_Root_History"
public static final String | BPW_C_NOT_RUN_EXECUTIVE_MASTER | "BPW_Core_Not_Run_Executive_Master"
public static final String | BPW_C_NOT_RUN_USER_AUTHORITY | "BPW_Core_Not_Run_User_Authority"
public static final String | BPW_C_NOT_RUN_USER_INFO | "BPW_Core_Not_Run_User_Info"
public static final String | BPW_C_NOT_RUN_USER_MASTER | "BPW_Core_Not_RunuserMaster"
public static final String | BPW_C_NOT_RUN_USER_TABLE | "BPW_Core_Not_RunUserTable"
public static final String | BPW_C_NOT_SET_INVALID_FLAG | "BPW_Core_Not_Set_InvalidFlag"
public static final String | BPW_C_NOT_SYNCRONIZED | "BPW_Core_Not_Syncronized"
public static final String | BPW_C_NOT_TRANSFER_PROCESS_DEF_DATA | "BPW_Core_Not_Transfer_Process_Def_Data"
public static final String | BPW_C_NOT_TRANSFER_TASK_DATA | "BPW_Core_Not_Transfer_Task_Data"
public static final String | BPW_C_NOT_TRANSFER_VERSION_DATA | "BPW_Core_Not_Transfer_Version_Data"
public static final String | BPW_C_NOT_VERSION | "BPW_Core_Not_Version"
public static final String | BPW_C_PRAM_ERROR | "BPW_Core_Invalid_Parameter"
public static final String | BPW_C_PROCESS_COUNT_FILE_NOT_FOUND | "BPW_Core_Process_Count_File_Not_Found"
public static final String | BPW_C_PROCESS_COUNT_FILE_READ_ONLY | "BPW_Core_Process_Count_File_Read_Only"
public static final String | BPW_C_REPEAT_ORDER_BY_VALUE | "BPW_Core_Repeat_OrderBy_Value"
public static final String | BPW_C_SHIFT_REFER_DUPLICATION | "BPW_Core_Shift_Refer_Duplication"
public static final String | BPW_C_ZERO_MEMBER_COMPANY | "BPW_Core_Zero_Member_Company"
public static final String | BPW_CORE_FAILED_GET_FILESTREAM | "BPW_Core_Failed_Get_FileStream"
public static final String | BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW | "BPW_Core_Import_Invalid_Contents_Frame_Type_For_BPW"
public static final String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE | "BPW_Core_Import_Invalid_Create_Route_Before_Create_Route"
public static final String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CUSTOM | "BPW_Core_Import_Invalid_Create_Route_Before_Custom"
public static final String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW | "BPW_Core_Import_Invalid_Create_Route_Before_Flow"
public static final String | BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH | "BPW_Core_Import_Invalid_Create_Route_Before_Switch"
public static final String | BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE | "BPW_Core_Import_Invalid_Draft_Task_Not_Receive"
public static final String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH | "BPW_Core_Import_Invalid_Dynamic_User_Before_Switch"
public static final String | BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK | "BPW_Core_Import_Invalid_Dynamic_User_For_Draft_Task"
public static final String | BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER | "BPW_Core_Import_Invalid_Flow_After_Dynamic_User"
public static final String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT | "BPW_Core_Import_Invalid_Flow_Inner_One_Root"
public static final String | BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT | "BPW_Core_Import_Invalid_Flow_Inner_Root"
public static final String | BPW_CORE_IMPORT_INVALID_INVOKE_TASK | "BPW_Core_Import_Invalid_Invoke_task"
public static final String | BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE | "BPW_Core_Import_Invalid_Not_Route_Select_Inner_Receive"
public static final String | BPW_CORE_IMPORT_INVALID_PARALLEL_SWITCH_AFTER_DYNAMIC_USER | "BPW_Core_Import_Invalid_Parallel_Switch_After_Dynamic_User"
public static final String | BPW_CORE_IMPORT_INVALID_ROOT_SETTING | "BPW_Core_Import_Invalid_Root_Setting"
public static final String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE | "BPW_Core_Import_Invalid_Route_Select_Before_Create_Route"
public static final String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW | "BPW_Core_Import_Invalid_Route_Select_Before_Flow"
public static final String | BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH | "BPW_Core_Import_Invalid_Route_Select_Before_Switch"
public static final String | BPW_CORE_IMPORT_NO_RECEIVE_TASK | "BPW_Core_Import_No_Receive_Task"
public static final String | BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO | "BPW_Core_Import_No_Sub_Process_Info"
public static final String | BPW_CORE_NUMBERING_INVALID_PARAMETER | "BPW_Core_Numbering_Invalid_Parameter"
public static final String | BPW_CORE_USER_SETTING_PATTERN | "BPW_Core_User_Setting_Pattern"
public static final String | BPW_FLOWINFO_INVALID_PARAMETER | "BPW_FlowInfo_Invalid_Parameter"
public static final String | BPW_FLOWINFO_NO_EXIST_FLOWICON | "BPW_FlowInfo_No_Exist_FlowIcon"
public static final String | BPW_INVALID_DRAFT_COMMENT_LENGTH | "bpw_invalid_draft_comment_length"
public static final String | BPW_INVALID_PROCESS_NAME_LENGTH | "bpw_invalid_process_name_length"
public static final String | BPW_INVALID_RECEIVE_COMMENT_LENGTH | "bpw_invalid_receive_comment_length"
public static final String | BPW_UT_FAILED_TO_BEGIN | "Bpw_ut_Failed_To_Begin"
public static final String | BPW_UT_FAILED_TO_CLOSE | "Bpw_ut_Failed_To_Close"
public static final String | BPW_UT_FAILED_TO_COMMIT | "Bpw_ut_Failed_To_Commit"
public static final String | BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION | "Bpw_Ut_Failed_To_Commit_Outside_Of_Transaction"
public static final String | BPW_UT_FAILED_TO_GET_STATUS | "Bpw_ut_Failed_To_Get_status"
public static final String | BPW_UT_FAILED_TO_LOCK | "Bpw_Ut_Failed_To_Lock"
public static final String | BPW_UT_FAILED_TO_ROLLBACK | "Bpw_ut_Failed_To_Rollback"
public static final String | BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION | "Bpw_Ut_Failed_To_Rolleback_Outside_Of_Transaction"
public static final String | BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY | "Bpw_ut_Failed_To_Set_Rollback_Only"
public static final String | BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT | "Bpw_ut_Failed_To_Set_Transaction_Time_Out"
public static final String | BPW_UT_FAILED_TO_UNLOCK | "Bpw_Ut_Failed_To_Unlock"

jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF
public static final String | WFK_C_NOT_TEMPLATE_PATH | "WKF_Core_Not_Template_path"
public static final String | WKF_C_ALREADY_STATUS_COMPLETE | "WKF_Core_Already_Status_Complete"
public static final String | WKF_C_APPROVAL_TYPE | "WKF_Core_Approval_Type"
public static final String | WKF_C_ATTACHMENT_UNABLE | "WKF_Core_Attachment_Unable"
public static final String | WKF_C_AUTO_PASS | "WKF_Core_Auto_Pass"
public static final String | WKF_C_AUTO_PRESS | "WKF_Core_Auto_Press"
public static final String | WKF_C_DATA_ACQUISITION_FAILURE | "WKF_Core_Data_Acquisition_Failure"
public static final String | WKF_C_DEPARTMENT_INFO_ERROR | "WKF_Core_Invalid_Department_Info"
public static final String | WKF_C_DRAFT_ACTIVITY_CD | "WKF_Core_Draft_Activity_Cd"
public static final String | WKF_C_DRAFT_APPOINT_DATE | "WKF_Core_Draft_Appoint_Date"
public static final String | WKF_C_DUPLICATE_AUTO_PASS_USER_CD | "WKF_Core_Duplicate_Auto_Pass_User_Cd"
public static final String | WKF_C_DUPLICATE_CREATE_ROUTE_TARGET_INFO | "WKF_Core_Duplicate_Create_Route_Target_Info"
public static final String | WKF_C_DUPLICATE_REFER_USER_CD | "WKF_Core_Duplicate_Refer_User_Cd"
public static final String | WKF_C_DUPLICATE_RUN_USER_CD | "WKF_Core_Duplicate_Run_User_Cd"
public static final String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_PROCESS_DEF | "WKF_Core_Import_Invalid_Create_Route_Process_Def"
public static final String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_ACTIVITY | "WKF_Core_Import_Invalid_Create_Route_Target_Activity"
public static final String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_CD | "WKF_Core_Import_Invalid_Create_Route_Target_Cd"
public static final String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_GROUP_CD | "WKF_Core_Import_Invalid_Create_Route_Target_Group_Cd"
public static final String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_INFO | "WKF_Core_Import_Invalid_Create_Route_Target_Info"
public static final String | WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_TYPE | "WKF_Core_Import_Invalid_Create_Route_Target_Type"
public static final String | WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD | "WKF_Core_Import_Invalid_Next_Activity_Cd"
public static final String | WKF_C_IMPORT_INVALID_NEXT_ROUTE_INFO | "WKF_Core_Import_Invalid_Next_Route_Info"
public static final String | WKF_C_INPOSSIBLE_DRAFT_ACTIVITY | "WKF_Core_Impossible_Draft_Activity"
public static final String | WKF_C_INPOSSIBLE_PULL_ACTIVITY | "WKF_Core_Impossible_Pull_Activity"
public static final String | WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY | "WKF_Core_Impossible_Recognition_Activity"
public static final String | WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY | "WKF_Core_Impossible_Return_Before_Activity"
public static final String | WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY | "WKF_Core_Impossible_Return_Start_Activity"
public static final String | WKF_C_INPOSSIBLE_RETURN_TASK_ACTIVITY | "WKF_Core_Impossible_Return_Task_Activity"
public static final String | WKF_C_INVALID_ACTIVITY_INFO | "WKF_Core_Invalid_Activity_Info"
public static final String | WKF_C_INVALID_ACTIVITY_TYPE | "WKF_Core_Invalid_Activity_Type"
public static final String | WKF_C_INVALID_AUTO_PASS_USER_TYPE | "WKF_Core_Invalid_Auto_Pass_User_Type"
public static final String | WKF_C_INVALID_CONTENTS_FRAME_TYPE | "WKF_Core_Invalid_Contents_Frame_Type"
public static final String | WKF_C_INVALID_DRAFT_TASK_DYNAMIC | "WKF_Core_Invalid_Draft_Task_Dynamic"
public static final String | WKF_C_INVALID_EFFECTIVE_DATE | "WKF_Core_Invalid_Effective_Date"
public static final String | WKF_C_INVALID_END_DATE | "WKF_Core_Invalid_End_Date"
public static final String | WKF_C_INVALID_OFFICIAL_RESTRICT | "WKF_Core_Invalid_Official_Restrict"
public static final String | WKF_C_INVALID_ORGN_RESTRICT | "WKF_Core_Invalid_Orgn_Restrict"
public static final String | WKF_C_INVALID_PROCESS_CONTENTS_PATH | "WKF_Core_Invalid_Process_Contents_Path"
public static final String | WKF_C_INVALID_PROCESS_STATUS | "WKF_Core_Invalid_Process_Status"
public static final String | WKF_C_INVALID_REFER_USER_TYPE | "WKF_Core_Invalid_Refer_User_Type"
public static final String | WKF_C_INVALID_ROLE_RESTRICT | "WKF_Core_Invalid_Role_Restrict"
public static final String | WKF_C_INVALID_ROOT_INFO | "WKF_Core_Invalid_Root_Info"
public static final String | WKF_C_INVALID_RUN_USER_DYNAMIC | "WKF_Core_Invalid_Run_User_Dynamic"
public static final String | WKF_C_INVALID_RUN_USER_INFO | "WKF_Core_Invalid_Run_User_Info"
public static final String | WKF_C_INVALID_RUN_USER_TYPE | "WKF_Core_Invalid_Run_User_Type"
public static final String | WKF_C_INVALID_TARGET_ACTIVITY_TYPE | "WKF_Core_Invalid_Target_Activity_Type"
public static final String | WKF_C_INVALID_TARGET_TYPE | "WKF_Core_Invalid_Target_Type"
public static final String | WKF_C_INVALID_TRANSFER_DATE | "WKF_Core_Invalid_Transfer_Date"
public static final String | WKF_C_INVALID_TRANSFER_STATUS_ALL | "WKF_Core_Invalid_Transfer_Status_All"
public static final String | WKF_C_NOT_ACTIVITY | "WKF_Core_Not_Activity"
public static final String | WKF_C_NOT_ACTIVITY_INFO | "WKF_Core_Not_Activity_Info"
public static final String | WKF_C_NOT_ACTIVITY_NAME | "WKF_Core_Not_Activity_Name"
public static final String | WKF_C_NOT_ACTIVITY_TYPE | "WKF_Core_Not_Activity_Type"
public static final String | WKF_C_NOT_AGENT_SETTING | "WKF_Core_Not_Agent_Setting"
public static final String | WKF_C_NOT_APPLICATION_KEY | "WKF_Core_Not_Application_Key"
public static final String | WKF_C_NOT_AUTHORITY_ACTIVITY | "WkfError.WKF_Core_Not_Authority_activity"
public static final String | WKF_C_NOT_AUTHORITY_CATEGORY | "WKF_Core_Not_Authority_category"
public static final String | WKF_C_NOT_AUTHORITY_PROCESS_DEF | "WKF_Core_Not_Authority_process_def"
public static final String | WKF_C_NOT_AUTO_PASS_TARGET | "WKF_Core_Not_Auto_Pass_Target"
public static final String | WKF_C_NOT_AUTO_PASS_USER_CODE | "WKF_Core_Not_Auto_Pass_User_Code"
public static final String | WKF_C_NOT_AUTO_PASS_USER_GROUP_CD | "WKF_Core_Not_Auto_Pass_User_Group_Cd"
public static final String | WKF_C_NOT_AUTO_PASS_USER_TYPE | "WKF_Core_Not_Auto_Pass_User_Type"
public static final String | WKF_C_NOT_CATEGORY_CD | "WKF_Core_Not_Category_Cd"
public static final String | WKF_C_NOT_CREATE_ROUTE_PROCESS_INFO | "WKF_Core_Not_Create_Route_Process_Info"
public static final String | WKF_C_NOT_DEPARTMENT_INFO | "WKF_Core_Not_Department_Info"
public static final String | WKF_C_NOT_FOUND_LAST_VERSION | "WKF_Core_Not_Found_Last_Version"
public static final String | WKF_C_NOT_FOUND_PROCESS_CONTENTS_INFO | "WKF_Core_Not_Found_Process_Contents_Info"
public static final String | WKF_C_NOT_MAIL_POSTPONEMENT | "WKF_Core_Not_Mail_Postponement"
public static final String | WKF_C_NOT_PLURAL_APPROVER | "WKF_Core_Not_Plural_Approver"
public static final String | WKF_C_NOT_POST_PROCESSING_PROGRAM | "WKF_Core_Not_Post_Processing_Program"
public static final String | WKF_C_NOT_PROCESS_CLASS_CD | "WKF_Core_Not_Process_Class_Cd"
public static final String | WKF_C_NOT_PROCESS_CONTENTS_PATH | "WKF_Core_Not_Process_Contents_Path"
public static final String | WKF_C_NOT_PROCESS_DEF_CD | "WKF_Core_Not_Process_Def_Cd"
public static final String | WKF_C_NOT_PROCESS_DEF_NAME | "WKF_Core_Not_Process_Def_Name"
public static final String | WKF_C_NOT_PROCESS_INFO | "WKF_Core_Not_Process_Info"
public static final String | WKF_C_NOT_RECEIVE | "WKF_Core_Not_Receive"
public static final String | WKF_C_NOT_REFER_USER_CODE | "WKF_Core_Not_Refer_User_Code"
public static final String | WKF_C_NOT_REFER_USER_GROUP_CD | "WKF_Core_Not_Refer_User_Group_Cd"
public static final String | WKF_C_NOT_REFER_USER_TYPE | "WKF_Core_Not_Refer_User_Type"
public static final String | WKF_C_NOT_REGIST_TYPE | "WKF_Core_Not_Regist_Type"
public static final String | WKF_C_NOT_ROOT_INFO | "WKF_Core_Not_Root_Info"
public static final String | WKF_C_NOT_RUN_USER_CODE | "WKF_Core_Not_Run_User_Code"
public static final String | WKF_C_NOT_RUN_USER_GROUP_CD | "WKF_Core_Not_Run_User_Group_Cd"
public static final String | WKF_C_NOT_RUN_USER_INFO | "WKF_Core_Not_Run_User_Info"
public static final String | WKF_C_NOT_RUN_USER_TYPE | "WKF_Core_Not_Run_User_Type"
public static final String | WKF_C_NOT_TARGET_ACTIVITY | "WKF_Core_Not_Target_Activity"
public static final String | WKF_C_NOT_TARGET_CD | "WKF_Core_Not_Target_Cd"
public static final String | WKF_C_NOT_TARGET_GROUP_CD | "WKF_Core_Not_Target_Group_Cd"
public static final String | WKF_C_NOT_TARGET_NO_ACTIVITY | "WKF_Core_Not_Target_No_Activity"
public static final String | WKF_C_NOT_TRANSFER_ACTIVITY | "WkfError.WKF_Core_Not_Transfer_Activity"
public static final String | WKF_C_NOT_TRANSFER_ATTACH_USER | "WKF_Core_Not_Transfer_Attach_User"
public static final String | WKF_C_NOT_TRANSFER_AUTHORITY | "WKF_Core_Not_Transfer_Authority"
public static final String | WKF_C_NOT_TRANSFER_CODE_TYPE | "WKF_Core_Not_Transfer_Code_Type"
public static final String | WKF_C_NOT_TRANSFER_END_DATE | "WKF_Core_Not_Transfer_End_Date"
public static final String | WKF_C_NOT_TRANSFER_PROCESS_DEF | "WKF_Core_Not_Transfer_Process_Def"
public static final String | WKF_C_NOT_TRANSFER_START_DATE | "WKF_Core_Not_Transfer_Start_Date"
public static final String | WKF_C_NOT_TRANSFER_TARGET_DATE | "WKF_Core_Not_Transfer_Target_Date"
public static final String | WKF_C_NOT_TRANSFER_VERSION | "WkfError.WKF_Core_Not_Transfer_Version"
public static final String | WKF_C_NOT_VERSION | "WKF_Core_Not_Version"
public static final String | WKF_C_PRAM_AGT_ALL | "WKF_Core_Parameter_Agent_All"
public static final String | WKF_C_PRAM_ERROR | "WKF_Core_Invalid_Parameter"
public static final String | WKF_C_PROCESS_INFO | "WKF_Core_Process_Info"
public static final String | WKF_C_REMOVE_PROCESS | "WKF_Core_Remove_Process"
public static final String | WKF_C_SEND_MAIL | "WKF_Core_Send_Mail"
public static final String | WKF_C_SYSTEM_ERROR | "WKF_Core_System_Error"

jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF
public static final String | ACTIVITY_ID_EMPTY | "7"
public static final String | ACTIVITY_ID_FLOW | "5"
public static final String | ACTIVITY_ID_INVOKE_AUTO | "3"
public static final String | ACTIVITY_ID_INVOKE_EVENT | "9"
public static final String | ACTIVITY_ID_INVOKE_PROCESS | "2"
public static final String | ACTIVITY_ID_PROCESS | "0"
public static final String | ACTIVITY_ID_RECEIVE | "1"
public static final String | ACTIVITY_ID_ROUTE_SELECT | "A"
public static final String | ACTIVITY_ID_SEQUENCE | "4"
public static final String | ACTIVITY_ID_SWITCH | "8"
public static final String | ACTIVITY_ID_TERMINATE | "6"
public static final String | ATTAINMENT_NORMAL | "01"
public static final String | ATTAINMENT_NOT | "00"
public static final String | ATTAINMENT_PULL_ACTIVE | "20"
public static final String | ATTAINMENT_PULL_READY | "21"
public static final String | ATTAINMENT_RETURN_ACTIVE | "30"
public static final String | ATTAINMENT_RETURN_READY | "31"
public static final String | ATTAINMENT_RETURN_READY_ACTIVE | "32"
public static final int | EIS_INIT | 0
public static final String | EIS_METHOD_ACTIVED | "actived"
public static final String | EIS_METHOD_CANCELED | "canceled"
public static final String | EIS_METHOD_CLOSED | "closed"
public static final String | EIS_METHOD_COMPENSATED | "compensated"
public static final String | EIS_METHOD_COMPLETED | "completed"
public static final String | EIS_METHOD_COMPULSION | "compulsion"
public static final String | EIS_METHOD_EXITED | "terminated"
public static final String | EIS_METHOD_FAULTED | "faulted"
public static final String | EIS_METHOD_SUSPENDED | "suspended"
public static final String | END_STATUS_CANCEL | "2"
public static final String | END_STATUS_COMPULSION | "3"
public static final String | END_STATUS_NORMAL | "0"
public static final String | END_STATUS_REJECTION | "1"
public static final String | FLG_OFF | "0"
public static final String | FLG_ON | "1"
public static final String | STATUS_ACTIVE | "1"
public static final String | STATUS_AUTOCLOSING | "9"
public static final String | STATUS_CANCELING | "3"
public static final String | STATUS_CLOSING | "6"
public static final String | STATUS_COMPENSATING | "5"
public static final String | STATUS_COMPLETED | "4"
public static final String | STATUS_EXIT | "8"
public static final String | STATUS_FAULT | "7"
public static final String | STATUS_NONE | "-1"
public static final String | STATUS_READY | "0"
public static final String | STATUS_SUSPEND | "2"
public static final String | STR_INIT | "0"
public static final String | STR_NULL | ""

jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel
public static final String | END_TASK_OFF | "0"
public static final String | END_TASK_ON | "1"
public static final String | PROCESSING_COMPLETED | "999"
public static final String | PROCESSING_NORMALL | "000"
public static final String | PROCESSING_PSN_NORMALL | "100"
public static final String | PROCESSING_PSN_PULL_BACK | "105"
public static final String | PROCESSING_PSN_PULL_SUSPEND | "115"
public static final String | PROCESSING_PSN_SEND_BACK | "106"
public static final String | PROCESSING_PSN_SEND_SUSPEND | "116"
public static final String | PROCESSING_PSN_SUSPEND | "110"
public static final String | PROCESSING_PULL_BACK | "005"
public static final String | PROCESSING_PULL_SUSPEND | "015"
public static final String | PROCESSING_SEND_BACK | "006"
public static final String | PROCESSING_SEND_SUSPEND | "016"
public static final String | PROCESSING_SUB_NORMALL | "200"
public static final String | PROCESSING_SUB_PULL_BACK | "205"
public static final String | PROCESSING_SUB_PULL_SUSPEND | "215"
public static final String | PROCESSING_SUB_SEND_BACK | "206"
public static final String | PROCESSING_SUB_SEND_SUSPEND | "216"
public static final String | PROCESSING_SUB_SUSPEND | "210"
public static final String | PROCESSING_SUSPEND | "010"
public static final String | PULL_ACTIVITY_OFF | "0"
public static final String | PULL_ACTIVITY_ON | "1"
public static final String | REFER_ALL | "0"
public static final String | REFER_NONE | "-1"
public static final String | REFER_READ | "1"
public static final String | REFER_RECOGNITION | "2"
public static final String | RETURN_ACTIVITY_OFF | "0"
public static final String | RETURN_ACTIVITY_ON | "1"
public static final String | RETURN_MAIL_OFF | "0"
public static final String | RETURN_MAIL_ON | "1"
public static final String | RUN_AUTH_ALL | "3"
public static final String | RUN_AUTH_NOT | "0"
public static final String | RUN_AUTH_RUN | "1"
public static final String | RUN_AUTH_TRANSFER | "2"
public static final String | RUN_SELECT_OFF | "0"
public static final String | RUN_SELECT_ON | "1"
public static final String | TRANSFER_OFF | "0"
public static final String | TRANSFER_ON | "1"

jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel
public static final String | TRANSFER_OFF | "0"
public static final String | TRANSFER_ON | "1"

jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
public static final String | APPLY | "0"
public static final String | CANCEL | "8"
public static final String | DELEGATE_TASK | "10"
public static final String | MAGICAL_HAND | "99"
public static final String | RECOGNITION | "2"
public static final String | REJECTION | "3"
public static final String | RETRY | "1"
public static final String | RETURN_BEFORE | "5"
public static final String | RETURN_PULL | "6"
public static final String | RETURN_START | "4"
public static final String | RETURN_TASK | "11"
public static final String | ROLL_SELECT_OFF | "0"
public static final String | ROLL_SELECT_ON | "1"
public static final String | SUSPENSION | "7"
public static final String | TARGET_AUTOPASS | "9"

jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel
public static final String | CD_KIND_OFFICIAL | "02"
public static final String | CD_KIND_ORG | "01"
public static final String | CD_KIND_ROLE | "03"
public static final String | CD_KIND_USER | "00"
public static final String | NO_PAIR | "no_pair"
public static final String | NON_BILONGING | "#non_belonging#"
public static final String | OLD_DATA | "0"
public static final String | POST_TYPE_POSITION | "14"
public static final String | POST_TYPE_ROLE | "13"

jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel
public static final String | ARBITRARY_CHANGE_FLAG_OFF | "0"
public static final String | ARBITRARY_CHANGE_FLAG_ON | "1"
public static final String | RIGHT_DELEGATE | "02"
public static final String | RIGHT_INIT | "00"
public static final String | RIGHT_NOT_DELEGATE | "20"
public static final String | RIGHT_NOT_PERSON | "10"
public static final String | RIGHT_PERSON | "01"
public static final String | STATUS_COMPLETE | "01"
public static final String | STATUS_DELEGATE_COMPLETE | "03"
public static final String | STATUS_INIT | "00"
public static final String | STATUS_SAID_COMPLETE | "02"
public static final String | TYPE_DELEGATE | "02"
public static final String | TYPE_PERSON | "00"
public static final String | TYPE_SAID_PERSON | "01"

jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel
public static final String | ATTACHMENT_ABLE | "1"
public static final String | ATTACHMENT_UNABLE | "0"
public static final String | PROCESS_CLASS_BPW | "0"
public static final String | PROCESS_CLASS_DRW | "2"
public static final String | PROCESS_CLASS_DW | "1"
public static final String | SUB_PROCESS_INIT | "0"
public static final String | SUB_PROCESS_ONLY | "1"

jp.co.intra_mart.foundation.wkf.ActivityTaskModel
public static final String | ACTIVITY_TYPE_EMPTY | "7"
public static final String | ACTIVITY_TYPE_FLOW | "5"
public static final String | ACTIVITY_TYPE_INVOKE_AUTO | "4"
public static final String | ACTIVITY_TYPE_INVOKE_EVENT | "3"
public static final String | ACTIVITY_TYPE_INVOKE_PROCESS | "2"
public static final String | ACTIVITY_TYPE_RECEIVE | "1"
public static final String | ACTIVITY_TYPE_ROUTE_SELECT | "8"
public static final String | ACTIVITY_TYPE_SWITCH | "6"

jp.co.intra_mart.foundation.wkf.Approver
public static final String | AGT_ALL | "1"
public static final String | RETURN_TYPE_BEFORE | "before"
public static final String | RETURN_TYPE_START | "start"
public static final String | RETURN_TYPE_TASK | "task"

jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel
public static final String | PAGE_KIND_FRAME_WORK | "4"
public static final String | PAGE_KIND_PRESENTAION_PAGE | "1"
public static final String | PAGE_KIND_SERVLET | "2"

jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel
public static final String | TARGET_TYPE_OFFICIAL | "official"
public static final String | TARGET_TYPE_ORGN | "orgn"
public static final String | TARGET_TYPE_USER | "user"

jp.co.intra_mart.foundation.wkf.Drafter
public static final String AGT_ALL "1"

jp.co.intra_mart.foundation.wkf.Manager
public static final String | AUTHORITY_ALL | "2"
public static final String | AUTHORITY_EDIT | "1"
public static final String | AUTHORITY_READ | "0"

jp.co.intra_mart.foundation.wkf.NegoModel
public static final String | MAIL_USER_ADDRESS | "mail"
public static final String | MAIL_USER_CD | "cd"
public static final String | MAIL_USER_NAME | "name"

jp.co.intra_mart.foundation.wkf.ReceiveTaskModel
public static final String | CONTENTS_FRAME_TYPE_CUSTOM | "1"
public static final String | CONTENTS_FRAME_TYPE_DEFAULT | "0"

jp.co.intra_mart.foundation.wkf.TargetInfoModel
public static final String | TARGET_TYPE_ATTACH_ORGN | "attch_orgn"
public static final String | TARGET_TYPE_DRAFTER | "drafter"
public static final String | TARGET_TYPE_EXECUTIVE | "executive"
public static final String | TARGET_TYPE_HIGH_ORGN | "high_orgn"
public static final String | TARGET_TYPE_OFFICIAL | "official"
public static final String | TARGET_TYPE_ORGN | "orgn"
public static final String | TARGET_TYPE_ROLE | "role"
public static final String | TARGET_TYPE_SUB | "sub"
public static final String | TARGET_TYPE_USER | "user"

jp.co.intra_mart.foundation.wkf.TransferInfoModel
public static final String | CD_KIND_OFFICIAL | "02"
public static final String | CD_KIND_ORG | "01"
public static final String | CD_KIND_PRIVATE | "04"
public static final String | CD_KIND_USER | "00"
public static final String | PROCESS_DEF_ALL | "all_process_def_cd"
public static final String | STATUS_ACTIVITY | "2"
public static final String | STATUS_PROCESS_DEF | "0"
public static final String | STATUS_VERSION | "1"

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


非推奨 API のリスト (bpw 6.1.14 API)

前 次 フレームあり フレームなし

推奨されていない API

推奨されていないメソッド
jp.co.intra_mart.foundation.wkf.Manager.addVersion(String, String, String, String, ContentsPathModel, List)
jp.co.intra_mart.foundation.wkf.Approver.approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunExecutiveInfoModel, String)
approve メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Approver.approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunUserInfoModel, String)
approve メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Drafter.draft(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String)
draft メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Drafter.draft(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String)
draft メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Manager.getActivityInfo(String, String, String)
getActivityInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getCategoryInfo(String)
getCategoryInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getCategoryInfoByName(String)
getCategoryInfoByNameメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getFlowInfo(String, String, String)
getFlowInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件:AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getProcessDefInfo(String)
getProcessDefInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getProcessDefInfoByName(String)
getProcessDefInfoByNameメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getProcessDefInfoByVersion(String, String)
getProcessDefInfoByVersionを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getProcessList(SearchCondition, Sort[], int, int)
getProcessListメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.getVersionInfo(String, String)
getVersionメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
jp.co.intra_mart.foundation.wkf.Manager.registProcessDef(String, String, String, String, String, boolean, boolean, String, String, ContentsPathModel, List)
jp.co.intra_mart.foundation.wkf.Drafter.retry(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String)
retry メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Drafter.retry(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String)
retry メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Approver.sendBack(String, String, String, String, String, String, String, String, NegoModel)
sendBack メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Drafter.subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunExecutiveInfoModel, String)
subProcessDraft メソッドを使用してください。
jp.co.intra_mart.foundation.wkf.Drafter.subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunUserInfoModel, String)
subProcessDraft メソッドを使用してください。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


API ヘルプ (bpw 6.1.14 API)

前 次 フレームあり フレームなし

API ドキュメントの構成

この API (Application Programming Interface) ドキュメントには、次に説明するナビゲーションバーにある項目に対応するページが含まれます。

概要

概要 ページは API ドキュメントのフロントページで、各パッケージの概要を含む全パッケージの一覧が表示されます。一連のパッケージの概要説明も表示されます。

パッケージ

各パッケージは、そのパッケージのクラスとインタフェースへのリンクを含むページを持ちます。このページは 4 つのカテゴリで構成されます:

  • インタフェース (イタリック)
  • クラス
  • 例外
  • エラー

クラスまたはインタフェース

各クラス、インタフェース、入れ子クラス、および入れ子インタフェースは個別のページを持ちます。各ページには次のように、クラスまたはインタフェースの説明と、概要テーブル、およびメンバの詳細説明が含まれます:

  • クラス階層表示
  • 直系のサブクラス
  • 既知のサブインタフェースの一覧
  • 既知の実装クラスの一覧
  • クラスまたはインタフェースの宣言
  • クラスまたはインタフェースの記述

  • 入れ子クラスの概要
  • フィールドの概要
  • コンストラクタの概要
  • メソッドの概要

  • フィールドの詳細
  • コンストラクタの詳細
  • メソッドの詳細
各概要エントリには、その項目の詳細な記述の中から 1 行目の文が表示されます。詳細な記述はソースコードに現われる順に並べられますが、概要エントリはアルファベット順に並べられます。これによって、プログラマが設定した論理的なグループ分けが保持されます。

使用

各ドキュメント化されたパッケージ、クラス、およびインタフェースはそれぞれ [使用] ページを持っています。このページには、どのようなパッケージ、クラス、メソッド、コンストラクタ、およびフィールドが、特定のクラスまたはパッケージの一部を使用しているかが記述されています。たとえば、クラス A またはインタフェース A の場合、その [使用] ページには、A のサブクラス、A として宣言されるフィールド、A を返すメソッド、および、型 A を持つメソッドとコンストラクタが含まれます。このページにアクセスするには、まずそのパッケージ、クラス、またはインタフェースに移動し、ナビゲーションバーの [使用] リンクをクリックしてください。

階層ツリー (クラス階層)

すべてのパッケージには クラス階層 ページがあり、さらに各パッケージの階層があります。各階層ページは、クラスのリストとインタフェースのリストを含みます。クラスは java.lang.Object を開始点とする継承構造で編成されます。インタフェースは、java.lang.Object からは継承しません。
  • 概要ページを表示しているときに [ツリー] をクリックすると、全パッケージの階層が表示されます。
  • 特定のパッケージ、クラス、またはインタフェースを表示しているときに [ツリー] をクリックすると、該当するパッケージだけの階層が表示されます。

推奨されていない API

推奨されていない API ページは、推奨されていないすべての API のリストを表示します。非推奨 API とは、機能改良などの理由から使用をお勧めできなくなった API のことで、通常はそれに代わる API が提供されます。非推奨 API は今後の実装で削除される可能性があります。

索引

索引 には、すべてのクラス、インタフェース、コンストラクタ、メソッド、およびフィールドのアルファベット順のリストが含まれます。

前/次

これらのリンクにより、前または次のクラス、インタフェース、パッケージ、または関連ページへ移動できます。

フレームあり/フレームなし

これらのリンクは HTML フレームを表示したり隠したりします。すべてのページはフレームありでも、フレームなしでも表示できます。

直列化された形式

直列化可能、または外部化可能な各クラスは、直列化フィールドとメソッドの記述を含みます。この情報は、API を使用する開発者ではなく、再実装を行う担当者に役立ちます。ナビゲーションバーにリンクがない場合、直列化されたクラスに移動して、クラス記述の [関連項目] セクションにある [直列化された形式] をクリックすることにより、この情報を表示できます。

このヘルプファイルは、標準の doclet によって生成された API ドキュメントに適用されます。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


索引 (bpw 6.1.14 API)

前 次 フレームあり フレームなし
A B C D E F G H I J L M N O P R S T U V W

A

ACTIVITY_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理タスクコードキー
ACTIVITY_ID_EMPTY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
エンプティの処理タイプID
ACTIVITY_ID_FLOW - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
フローの処理タイプID
ACTIVITY_ID_INVOKE_AUTO - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
インボーク(自動呼出)の処理タイプID
ACTIVITY_ID_INVOKE_EVENT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
インボーク(イベント)の処理タイプID
ACTIVITY_ID_INVOKE_PROCESS - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
インボーク(プロセス呼出)の処理タイプID
ACTIVITY_ID_PROCESS - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
プロセスの処理タイプID
ACTIVITY_ID_RECEIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
レシーブの処理タイプID
ACTIVITY_ID_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
ルート選択の処理タイプID
ACTIVITY_ID_SEQUENCE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
シーケンスの処理タイプID
ACTIVITY_ID_SWITCH - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
スイッチの処理タイプID
ACTIVITY_ID_TERMINATE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
ターミネートの処理タイプID
ACTIVITY_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理タスク名キー
ACTIVITY_TYPE_EMPTY - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：手動タスク
ACTIVITY_TYPE_FLOW - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：同期タスク（ワークフローデザイナー、BPW）
ACTIVITY_TYPE_INVOKE_AUTO - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：自動実行タスク（BPWのみ）
ACTIVITY_TYPE_INVOKE_EVENT - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：イベント実行タスク（BPWのみ）
ACTIVITY_TYPE_INVOKE_PROCESS - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：サブプロセス呼出タスク
ACTIVITY_TYPE_RECEIVE - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：処理(申請・承認)タスク
ACTIVITY_TYPE_ROUTE_SELECT - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：ルート選択タスク
ACTIVITY_TYPE_SWITCH - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel の static 変数
タスク種別：分岐タスク（ワークフローデザイナー、BPW）
AGENT_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
代理依頼元ユーザコードキー
AGENT_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
代理依頼元ユーザ名キー
AGT_ALL - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
代理依頼されたもの全て表示(代理のみ使用)
AGT_ALL - class jp.co.intra_mart.foundation.wkf.Drafter の static 変数
代理依頼されたもの全て表示(代理のみ使用)
AGT_COMPLETE_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
完了タスク表示(委譲)キー
AGT_GO_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
未処理タスク表示(委譲)キー
AGT_PULLBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
引き戻しタスク表示(委譲)キー
AGT_SENDBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
差し戻しタスク表示(委譲)キー
APPLY - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：申請
APPROVAL_COMP_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者の会社コードキー
APPROVAL_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理日(検索範囲終了日)キー
APPROVAL_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理日(検索範囲開始日)キー
APPROVAL_ORGN_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者の組織コードキー
APPROVAL_ORGN_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者の組織名キー
APPROVAL_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者ユーザコードキー
APPROVAL_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理者ユーザ名キー
ARBITRARY_CHANGE_FLAG_OFF - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
任意指定フラグ：任意指定なし
ARBITRARY_CHANGE_FLAG_ON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
任意指定フラグ：任意指定あり
ARRIVE_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
到達日(検索範囲終了日)キー
ARRIVE_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
到達日(検索範囲開始日)キー
ATTACHMENT_ABLE - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
添付ファイルフラグ : 添付ファイルを使用する
ATTACHMENT_UNABLE - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
添付ファイルフラグ : 添付機能を使用しない
ATTAINMENT_NORMAL - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
アクティビティは通常に処理が到達した。
ATTAINMENT_NOT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
アクティビティには処理が到達していない。
ATTAINMENT_PULL_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
引き戻し（Active)
ATTAINMENT_PULL_READY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
被・引き戻し（Ready)
ATTAINMENT_RETURN_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
差し戻し（Active)
ATTAINMENT_RETURN_READY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
被・差し戻し（Complete→Ready)
ATTAINMENT_RETURN_READY_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
被・差し戻し（Active→Ready)
AUTHORITY_ALL - class jp.co.intra_mart.foundation.wkf.Manager の static 変数
絞込み：なし
AUTHORITY_EDIT - class jp.co.intra_mart.foundation.wkf.Manager の static 変数
絞込み：編集権限
AUTHORITY_READ - class jp.co.intra_mart.foundation.wkf.Manager の static 変数
絞込み：処理権限
ActivityInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel.
アクティビティ情報を保持するクラス
アクティビティ情報を保持します。
ActivityInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
コンストラクタ
ActivityInfoModel(ActivityMasterUnitModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(ActivityMasterInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(SwitchInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(EditTransferTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(TransferTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(DelegateUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(ReceiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のコンストラクタ
ActivityTaskModel - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel.
タスク情報を保持するクラス
ActivityTaskModel() - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel のコンストラクタ
コンストラクタ
AgentSetting - class jp.co.intra_mart.foundation.wkf.AgentSetting.
代理設定関連のAPI
代理設定関連処理で使用されるクラスです。
AgentSetting(String, String) - class jp.co.intra_mart.foundation.wkf.AgentSetting のコンストラクタ
コンストラクタ
Approver - class jp.co.intra_mart.foundation.wkf.Approver.
承認関連のAPI
承認関連の処理に使用されるクラスです。
Approver(String, String) - class jp.co.intra_mart.foundation.wkf.Approver のコンストラクタ
コンストラクタ１(本人用)
Approver(String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のコンストラクタ
コンストラクタ２(代理人用)。
addAutoPassTarget(TargetInfoModel) - class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel のメソッド
自動パス対象者情報を追加します。
addAutopasslist(AutoPassInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パスリスト情報に新たに自動パス情報を追加します。
addCreateRouteTargetList(CreateRouteTargetInfoModel) - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のメソッド
対象者情報を追加します。
addGroupList(RunGroupInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
グループ情報リストを追加します。
addReceivelist(ReceiveTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
レシーブリスト情報に新たにレシーブ情報を追加します。
addReferUser(TargetInfoModel) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
参照者情報を追加します。
addReserveInfo(ArrayList) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
送信メール情報を追加設定します。
addRunUser(TargetInfoModel) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
対象者情報を追加します。
addRunuserlist(RunUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行主体ユーザリスト情報に新たに実行主体ユーザ情報を追加します。
addUserAppliKey(int, UserApplicationKeyInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
addUserAppliKey(int, UserApplicationKeyInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
addUserAppliKey(int, UserApplicationKeyInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を設定します。
addUserList(Map) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール送信者リストに情報を追加します。
addVersion(String, String, String, String, ContentsPathModel, List) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。
approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunExecutiveInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
推奨されていません。 approve メソッドを使用してください。
approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunExecutiveInfoModel, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
承認処理を実行します。
approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunUserInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
推奨されていません。 approve メソッドを使用してください。
approve(String, String, String, String, Boolean, String, String, String, NegoModel, RunUserInfoModel, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
承認処理を実行します。
autoPass(String, String, String, int) - class jp.co.intra_mart.foundation.wkf.Util のメソッド
案件の自動パス(バッチ起動)処理を行います。
autoPress(String, String, String, int) - class jp.co.intra_mart.foundation.wkf.Util のメソッド
案件の自動催促(バッチ起動)処理を行います。

B

BPWErrorCodeIF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF.
ＢＰＷで利用される例外エラーコードインタフェース定義
BPWExecuteLogic - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic.
外部プログラム実行抽象クラス。
BPWExecuteLogic() - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のコンストラクタ
コンストラクタ
BPW_CORE_FAILED_GET_FILESTREAM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ファイルストリーム取得に失敗しました。
BPW_CORE_IMPORT_INVALID_CONTENTS_FRAME_TYPE_FOR_BPW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義種別がビジネスプロセスワークフローの場合、コンテンツフレーム種別にカスタムを設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CREATE_ROUTE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセスに申請者/承認者ルート作成ワークフローが設定されているタスクの直前に
申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_CUSTOM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセスに申請者/承認者ルート作成ワークフローが設定されている場合、
直前のタスクのコンテンツフレーム種別にカスタムを設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期の開始・結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
BPW_CORE_IMPORT_INVALID_CREATE_ROUTE_BEFORE_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐の開始直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
BPW_CORE_IMPORT_INVALID_DRAFT_TASK_NOT_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票タスクのタスク種別に誤りがあります。
BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_BEFORE_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認者種別が実行時選択のタスクを
同期・分岐・ルート選択の開始直後に設定する事はできません。
BPW_CORE_IMPORT_INVALID_DYNAMIC_USER_FOR_DRAFT_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票タスクに動的承認者は設定できません。
BPW_CORE_IMPORT_INVALID_FLOW_AFTER_DYNAMIC_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期タスクの結合直後に動的な対象者を設定する事はできません。
BPW_CORE_IMPORT_INVALID_FLOW_INNER_ONE_ROOT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐内に1ルートしか設定されていません。
BPW_CORE_IMPORT_INVALID_FLOW_INNER_ROOT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐内のタスク設定に誤りがあります。
BPW_CORE_IMPORT_INVALID_INVOKE_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別がビジネスプロセスワークフロー以外の場合、自動実行タスク、イベント実行タスクを設定することはできません。
BPW_CORE_IMPORT_INVALID_NOT_ROUTE_SELECT_INNER_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択内に処理タスクがない場合、ルート選択結合直後にサブプロセス(申請者/承認者ルート作成ワークフロー)を設定することはできません。
BPW_CORE_IMPORT_INVALID_PARALLEL_SWITCH_AFTER_DYNAMIC_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
複数ルートの分岐タスクの結合直後に動的な対象者を設定する事はできません。
BPW_CORE_IMPORT_INVALID_ROOT_SETTING - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義に誤りがあります。
BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_CREATE_ROUTE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択タスクの直前に申請者/承認者ルート作成ワークフローのサブプロセスを設定することはできません。
BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期の開始・結合直後にルート選択タスクを設定することはできません。
BPW_CORE_IMPORT_INVALID_ROUTE_SELECT_BEFORE_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐・ルート選択の開始直後にルート選択タスクを設定する事はできません。
BPW_CORE_IMPORT_NO_RECEIVE_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票(処理)タスクが設定されていない可能性があります。
BPW_CORE_IMPORT_NO_SUB_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス設定情報が設定されていません。
BPW_CORE_NUMBERING_INVALID_PARAMETER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
採番処理にて指定したパラメータに誤りがあります。
BPW_CORE_USER_SETTING_PATTERN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
対象データはユーザに選択されている可能性があります。
BPW_C_ALREADY_EXIST_TRANSFER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
処理委譲できません。
BPW_C_ALREADY_SUSPEND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
既に保留されている可能性があります。
BPW_C_AUTO_EXECUTE_FAULT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動実行処理が異常復帰しました。
BPW_C_CAN_NOT_START_JAVASCRIPT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
JavaScriptが起動できません。
BPW_C_CATEGORY_DISAGREEMENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコードの設定に誤りがあります。
BPW_C_CHANGE_AGENTSETTING - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
他のユーザにより変更された可能性があります。
BPW_C_CHANGE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
他のユーザに情報が変更されました。
BPW_C_CHANGING_NOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連する情報が修正中であり反映できません。
BPW_C_DATA_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
データが存在しません。
BPW_C_DUPLICATE_CATEGORY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコードが重複しています。
BPW_C_DUPLICATE_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
名称が重複しています。
BPW_C_EXIST_PROCESS_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
有効なプロセス定義が存在します。
BPW_C_FAILED_GET_HTTP_EXCEL_STREAM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
Excelファイルストリーム取得に失敗しました。
BPW_C_FAILED_READ_EXCEL_STREAM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
Excelファイルストリーム読み込みに失敗しました。
BPW_C_FOUND_AUTO_PASS_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付く自動パス情報が存在します。
BPW_C_FOUND_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付くプロセス情報が存在します。
BPW_C_FOUND_RECEIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
レシーブマスタ情報が存在しません。
BPW_C_FOUND_RECEIVE_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付くレシーブ情報が存在します。
BPW_C_FOUND_RUNNING_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行中のプロセスが存在します。
BPW_C_FOUND_RUN_USER_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付く実行主体ユーザ情報が存在します。
BPW_C_FOUND_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付く履歴情報が存在します。
BPW_C_HAVE_NOT_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
権限がありません。
BPW_C_HAVE_NOT_AUTHORITY_OR_DATA_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
権限、及び権限に関連する情報がありません。
BPW_C_ILLIGAL_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ステータスが異常です。
BPW_C_ILLIGAL_STATUS_CHG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ステータス遷移が異常です。
BPW_C_IMPORT_CAN_NOT_SET_RUN_REFER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択のレシーブは指定できません。
BPW_C_IMPORT_CHANGE_PROCESS_CLASS_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別の設定が不正です。
BPW_C_IMPORT_DUPLICATE_APPROVAL_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象コードが重複しています。
BPW_C_IMPORT_DUPLICATE_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が重複して指定されています。
BPW_C_IMPORT_DUPLICATE_PROCESS_DEFINITION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シート内でプロセス定義名が重複しています。
BPW_C_IMPORT_DUPLICATE_ROOTDEF_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義IDが重複して指定されています。
BPW_C_IMPORT_DUPLICATE_TASK_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスクIDが重複しています。
BPW_C_IMPORT_INVALID_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_APPLICATION_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_APPLICATION_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションID長が不正です。
BPW_C_IMPORT_INVALID_APPROVAL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_INVALID_APPROVAL_AFTER_SHORTESTENDFLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_INVALID_APPROVAL_FOCUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_ATTACHMENT_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
添付ファイルフラグが不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_EXECUTIVE_POST_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス処理フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_FOCUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス対象が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_TERM - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス期限が不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_TERM_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス期限長が不正です。
BPW_C_IMPORT_INVALID_AUTO_PASS_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスユーザコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
呼び出しプロセス定義コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CALL_PROCESS_DEF_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
呼び出しプロセス定義コード長が不正です。
BPW_C_IMPORT_INVALID_CALL_RUN_CLASS_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行クラス長が不正です。
BPW_C_IMPORT_INVALID_CATEGORY_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコード長が不正です。
BPW_C_IMPORT_INVALID_CODE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コード種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CODE_KIND_VALUE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コード種別が不正です。
BPW_C_IMPORT_INVALID_COMPULSION_END_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制終了可否フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONDITION_CALSS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
条件クラスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONDITION_CALSS_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
条件クラス長が不正です。
BPW_C_IMPORT_INVALID_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONTENTS_FRAME_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツフレーム種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONTENTS_PATH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_CONTENTS_PATH_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパス長が不正です。
BPW_C_IMPORT_INVALID_DRAFTER_TASK_LOCATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義内のタスクの位置の入力が不正です。
BPW_C_IMPORT_INVALID_DRAFT_TYPE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起票タイプが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_EFFECTIVE_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
有効日付が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_EFFECTIVE_DATE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
有効日付長が不正です。
BPW_C_IMPORT_INVALID_END_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
終了日付が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_END_DATE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
終了日付長が不正です。
BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベントサービスIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_EVENT_SERVICE_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベントサービスID長が不正です。
BPW_C_IMPORT_INVALID_FUNCTION_KBN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
処理区分が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_MAIL_CONTENTS_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール内容定義長が不正です。
BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール猶予日数が不正です。
BPW_C_IMPORT_INVALID_MAIL_POST_PONEMENT_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール猶予日長が不正です。
BPW_C_IMPORT_INVALID_MAIL_TITLE_DEF_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール表題定義長が不正です。
BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール対象種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_MAIL_TO_CLASSIFICATION_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール対象種別長が不正です。
BPW_C_IMPORT_INVALID_PAGBE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ページ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PRE_RUNREFER_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_BPW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別とサブプロセス識別フラグの設定が不正です。
BPW_C_IMPORT_INVALID_PROCESSCLASSCD_AND_SUBPROCESSFLAG_DRW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別とサブプロセス識別フラグの設定が不正です。
BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_APPLICATION_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アプリケーションID長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_CLASS_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別が不正です。
BPW_C_IMPORT_INVALID_PROCESS_CONTENTSTYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_CONTENTS_PATH_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツパス長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_DEF_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義コード長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_FLOW_COUNT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別設定数が不正です。
BPW_C_IMPORT_INVALID_PROCESS_PAGBE_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ページ種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_PROCESS_SERVECE_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_PROCESS_SERVICE_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスID長が不正です。
BPW_C_IMPORT_INVALID_PROCESS_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_REFER_FOCUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照対象が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_REFER_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者ユーザコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RETURN_PULL_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引戻し・差戻しフラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RETURN_PULL_MAIL_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引戻し・差戻しメール送信フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_ROOT_AFTER_SHORTESTENDFLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義が不正です。
BPW_C_IMPORT_INVALID_ROOT_DEF_OF_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー情報のルート定義入力が不正です。
BPW_C_IMPORT_INVALID_ROOT_OF_INVOKE_PROCESS_BEFORE_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス（申請者／承認者ルート作成ワークフロー）の前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_ROOT_OF_ROUTE_SELECT_BEFORE_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択の前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_ROOT_OF_RUN_SELECT_USER_BEFORE_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択の前アクティビティ種別の設定が不正です。
BPW_C_IMPORT_INVALID_RUNSELECT_TASK_LOCATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義ないのタスクの位置の入力が不正です。
BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実効アクティビティコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_ACTIVITY_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実効アクティビティコード長が不正です。
BPW_C_IMPORT_INVALID_RUN_CLASS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行クラスが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_COMPANY_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
会社CDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_EXECUTIVE_POST_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職種別が指定されていない、または不正です。
BPW_C_IMPORT_INVALID_RUN_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザコードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_SECOND_APPROVAL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_INVALID_SELECT_ROUTE_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
選択ルートコード長が不正です。
BPW_C_IMPORT_INVALID_SELECT_ROUTE_NAME_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
選択ルート名長が不正です。
BPW_C_IMPORT_INVALID_SERVECE_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスIDが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_SERVICE_ID_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サービスID長が不正です。
BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_BEFORE_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最短終了フラグの設定が不正です。
BPW_C_IMPORT_INVALID_SHORTESTENDFLAG_IN_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最短終了フラグの設定が不正です。
BPW_C_IMPORT_INVALID_SHORTEST_END_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最短終了フラグが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_START_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルートの開始アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_SUB_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセスの設定が不正です。
BPW_C_IMPORT_INVALID_SUB_PROCESS_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス識別フラグが不正です。
BPW_C_IMPORT_INVALID_TASK_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスク定義に存在しないタスクIDが指定されました。
BPW_C_IMPORT_INVALID_TASK_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスクタイプが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_TOP_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルートの先頭アクティビティ種別設定が不正です。
BPW_C_IMPORT_INVALID_VERSION_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
履歴コードが指定されていない、または不正です。
BPW_C_IMPORT_INVALID_VERSION_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
履歴コード長が不正です。
BPW_C_IMPORT_NO_AUTO_ADAPTER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
オートアダプタマスタ情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職マスタ情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスマスタ情報が設定されてません。
BPW_C_IMPORT_NO_AUTO_PASS_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パスユーザコードが存在しません。
BPW_C_IMPORT_NO_CONTENTS_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
コンテンツマスタ情報が設定されてません。
BPW_C_IMPORT_NO_EVENT_ADAPTER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベントアダプタマスタ情報が設定されてません。
BPW_C_IMPORT_NO_EXIST_APPROVAL_DRAFT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認対象種別設定が不正です。
BPW_C_IMPORT_NO_EXIST_AUTO_PASS_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
自動パス役職コードが存在しません。
BPW_C_IMPORT_NO_EXIST_REFER_GROUPING_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者組織コードが存在しません。
BPW_C_IMPORT_NO_EXIST_REFER_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者ユーザコードが存在しません。
BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_COMPANY_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
会社CDが存在しません。
BPW_C_IMPORT_NO_EXIST_RUN_EXECUTIVE_POST_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職コードが存在しません。
BPW_C_IMPORT_NO_EXIST_RUN_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザコードが存在しません。
BPW_C_IMPORT_NO_FIRST_CONDITION_CLASS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
始めの条件クラスが指定されていません。
BPW_C_IMPORT_NO_FIRST_TASK_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
始めのタスクIDが指定されていません。
BPW_C_IMPORT_NO_FLOW_INNER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー内容マスタ情報が設定されてません。
BPW_C_IMPORT_NO_FLOW_RUN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー内容マスタ情報の実行アクティビティが設定されていません。
BPW_C_IMPORT_NO_LICENSE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定されたプロセス種別に対するライセンスがありません。
BPW_C_IMPORT_NO_LICENSE_AUTO_EVENT_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
オートアダプタ・イベントアダプタ情報を設定するライセンスがありません。
BPW_C_IMPORT_NO_LICENSE_SWITCH_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチ・フロー情報を設定するライセンスがありません。
BPW_C_IMPORT_NO_PROCESS_ADAPTER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセスアダプタマスタ情報が設定されてません。
BPW_C_IMPORT_NO_RECEIVE_IN_FIRST_SEQUENCE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
最初のシーケンスにレシーブが存在しません。
BPW_C_IMPORT_NO_RECEIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
レシーブマスタ情報が設定されてません。
BPW_C_IMPORT_NO_ROUTE_SELECT_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報が設定されてません。
BPW_C_IMPORT_NO_RUN_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職マスタ情報が設定されてません。
BPW_C_IMPORT_NO_RUN_USER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザマスタ情報が設定されてません。
BPW_C_IMPORT_NO_SELECT_ROUTE_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報の選択ルートコードが設定されていません。
BPW_C_IMPORT_NO_SELECT_ROUTE_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報の選択ルート名が設定されていません。
BPW_C_IMPORT_NO_SEQUENCE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シーケンス内容マスタ情報が設定されてません。
BPW_C_IMPORT_NO_SEQUENCE_RUN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シーケンスマスタ情報の実行アクティビティが設定されていません。
BPW_C_IMPORT_NO_SUB_ROOT_OF_FLOWE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フローのサブルートが存在しません。
BPW_C_IMPORT_NO_SUB_ROOT_OF_ROUTE_SELECT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択のサブルートが存在しません。
BPW_C_IMPORT_NO_SUB_ROOT_OF_SWITCH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチのサブルートが存在しません。
BPW_C_IMPORT_NO_SWITCH_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチマスタ情報が設定されてません。
BPW_C_IMPORT_NO_SWITCH_RUN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチマスタ情報の実行アクティビティが設定されていません。
BPW_C_IMPORT_NO_TASK_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
タスク定義が指定されていません。
BPW_C_IMPORT_NO_TASK_ID_IN_ROOT_DEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート定義内のタスクIDがタスク定義に指定されていません。
BPW_C_IMPORT_OVER_ATTACHMENT_FLAG_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
添付ファイルフラグ文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_NOTE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
備考文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_PROCESS_CLASS_CD_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス種別文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_PROCESS_DEF_NAME_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義名長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_PROCESS_DEF_NOTE_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義備考文字列長が最大文字列長を超えています。
BPW_C_IMPORT_OVER_SUB_PROCESS_FLAG_LEN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
サブプロセス識別フラグ文字列長が最大文字列長を超えています。
BPW_C_IMPORT_PLURAL_APPROVAL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
起案タスク以外は、複数対象者の設定をすることはできません。
BPW_C_IMPOSSIBLE_ROOT_HISTORY_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
この履歴情報は使用できません。
BPW_C_INPOSSIBLE_GET_ROOT_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティルート取得イベントに失敗しました。
BPW_C_INPOSSIBLE_GET_USER_APP_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションキー取得イベントに失敗しました。
BPW_C_INPOSSIBLE_MAIL_TEMPLATE_SEND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メールテンプレートの送信に失敗しました。
BPW_C_INPOSSIBLE_SET_MAIL_INFORMATION_REMOVE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
BPW_C_INPOSSIBLE_SET_MAIL_RESERVE_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
予約メール依頼の設定に失敗しました。
BPW_C_INPOSSIBLE_SET_MAIL_STOP_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
テンプレートメール送信抑止の設定に失敗しました。
BPW_C_INPOSSIBLE_SET_MAIL_TEMPLATE_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メールテンプレートの設定に失敗しました。
BPW_C_INVALID_ACTIVITY_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティステータスが不正です。
BPW_C_INVALID_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティ種別が不正です。
BPW_C_INVALID_ADAPTER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アダプタ種別が不正です。
BPW_C_INVALID_APPROVAL_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認種別が不正です。
BPW_C_INVALID_APPROVAL_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
承認ユーザコードが不正です。
BPW_C_INVALID_CATEGORY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるカテゴリ情報が存在しない、または無効です。
BPW_C_INVALID_CATEGORY_CODE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコードが指定されていない、または不正です。
BPW_C_INVALID_CATEGORY_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリ名称が指定されていない、または不正です。
BPW_C_INVALID_CONDITION_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
分岐種別が不正です。
BPW_C_INVALID_DB_PRIMARY_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定情報のデータベースプライマリキー値に値が指定されていないものが存在する、 もしくは指定された値が不正です。
BPW_C_INVALID_LOGIN_GROUP_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ログイングループIDが指定されていない、または不正です。
BPW_C_INVALID_LOGIN_USER_ID - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ログインユーザIDが指定されていない、または不正です。
BPW_C_INVALID_NECESSARY_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定情報の入力必須キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_INVALID_PROCESSDEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるプロセス定義情報が存在しない、または無効です。
BPW_C_INVALID_PROCESS_DEF_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス定義名称が指定されていない、または不正です。
BPW_C_INVALID_PROC_CONTENTS_M_SELECT_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
検索実行時の指定キー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_INVALID_REFER_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照権限フラグが不正です。
BPW_C_INVALID_REMINDER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
催促メール対象種別が不正です。
BPW_C_INVALID_RETURN_FLG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引戻し／差戻しは行えません。
BPW_C_INVALID_RETURN_START_RUN_USER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請者への差し戻しイベントに失敗しました。
BPW_C_INVALID_ROOT_NAME - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_INVALID_RUN_EXECUTIVE_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体種別が不正です。
BPW_C_INVALID_SELECT_CONDITION_PHRASE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
条件句の指定が不正です。
BPW_C_INVALID_SELECT_IN_PHRASE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
IN指定は他の条件と複合して設定不可能です。
BPW_C_INVALID_TRANSFER_CD_KIND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理承認者コード種別が不正です。
BPW_C_INVALID_WORKFLOW_SELECT_PRIMARY_KEY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
検索実行時のプライマリキー値に値が指定されていないものが存在する、もしくは指定された値が不正です。
BPW_C_MAGICAL_ACTIVE_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAGICAL_DEACTIVE_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAGICAL_PLURAL_RUN_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAGICAL_RUN_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
強制活性化に失敗しました。
BPW_C_MAIL_TAMPLATE_PATH_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メールテンプレートの取得に失敗しました。
BPW_C_MOVE_ACTIVITY_RETURN_PULL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
この案件は引戻し出来ません。
BPW_C_NOT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるアクティビティ情報が存在しません。
BPW_C_NOT_ACTIVITY_FOR_SEND_MAIL - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
メール送信送信対象アクティビティ情報が存在しません。
BPW_C_NOT_ACTIVITY_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティマスタ情報が存在しません。
BPW_C_NOT_BACK_IN_FLOW - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期処理内より、処理外への引戻し／差戻しは行えません。
BPW_C_NOT_DELEGATE_AGENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_AGENT_SET - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_ALREADY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_ALREADY_RIGHT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_BACK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELEGATE_CIRCULATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
振替が出来ません。
BPW_C_NOT_DELETE_VERSION_LASTRECORD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
履歴情報を削除できません。
BPW_C_NOT_EFFECTIVE_DATE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
現在日は有効な日付ではありません。
BPW_C_NOT_EXIST_ROLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ロールIDが不正です。
BPW_C_NOT_GET_PROCESS_CODE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
案件番号の取得に失敗しました。
BPW_C_NOT_GROUP_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付ける実行主体グループテーブルが存在しません。
BPW_C_NOT_INSERT_HISTORY_TABLE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
処理履歴情報の登録に失敗しました。
BPW_C_NOT_INSERT_MONITORING_TABLE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
モニタリング情報の登録に失敗しました。
BPW_C_NOT_NUMBER_CATEGORY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
カテゴリコードが不正です。
BPW_C_NOT_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるプロセス情報が存在しません。
BPW_C_NOT_PROCESSDEF - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付けるプロセス定義情報が存在しません。
BPW_C_NOT_PULL_DRAFT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
引き戻し先アクティビティが存在しません。
BPW_C_NOT_RECEIVE_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付くレシーブ情報が存在しません。
BPW_C_NOT_RETURN_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
アクティビティが存在しません。
BPW_C_NOT_ROOT_HISTORY_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート作成履歴情報が存在しません。
BPW_C_NOT_RUN_EXECUTIVE_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定された実行主体役職マスタ情報が存在しません。
BPW_C_NOT_RUN_USER_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
権限がありません。
BPW_C_NOT_RUN_USER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
既に他のユーザに処理された可能性があります。
BPW_C_NOT_RUN_USER_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザマスタ情報が存在しません。
BPW_C_NOT_RUN_USER_TABLE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザ情報が存在しません。
BPW_C_NOT_SET_INVALID_FLAG - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
論理削除されているデータを更新しようとした場合に発生するエラーです。
BPW_C_NOT_SYNCRONIZED - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
同期情報が設定されていません。
BPW_C_NOT_TRANSFER_PROCESS_DEF_DATA - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理設定対象プロセス定義情報が取得できませんでした。
BPW_C_NOT_TRANSFER_TASK_DATA - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理設定対象タスク情報が取得できませんでした。
BPW_C_NOT_TRANSFER_VERSION_DATA - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理設定対象バージョン情報が取得できませんでした。
BPW_C_NOT_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
関連付ける履歴情報が存在しません。
BPW_C_NO_ATTACH_POSITION_GROUP - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_NO_ATTACH_POSITION_GROUP_AGENT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_NO_EVENT_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
イベント実行情報が存在しない。
BPW_C_NO_EXECUTE_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
外部実行クラスが存在しません。
BPW_C_NO_EXECUTIVE_GROUP - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職マスタに対象グループが登録されていません。
BPW_C_NO_FLOW_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フロー内容マスタ情報が設定されていません。
BPW_C_NO_INSERT_VALUE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
更新情報が設定されていません。
BPW_C_NO_PROCESS_ADAPTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行プロセスが存在しません。
BPW_C_NO_ROUTE_SELECT_MASTER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ルート選択マスタ情報が設定されてません。
BPW_C_NO_RUNUSER_EXCUTIVE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体役職マスタ情報が設定されていません。
BPW_C_NO_RUNUSER_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行主体ユーザマスタ情報が設定されていません。
BPW_C_NO_RUN_SELECT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択可能なアクティビティではありません。
BPW_C_NO_RUN_SELECT_USER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
実行時選択ユーザが指定されていません。
BPW_C_NO_SELECTED_TARGET_TASK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請できません。
BPW_C_NO_SEQUENCE_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
シーケンス内容マスタ情報が設定されていません。
BPW_C_NO_SWHITCH_MASTER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
スイッチマスタ情報が設定されていません。
BPW_C_NO_TRANSFER_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
代理申請権限がありません。
BPW_C_NO_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザコードが存在しません。
BPW_C_PRAM_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
パラメータエラーです。
BPW_C_PROCESS_COUNT_FILE_NOT_FOUND - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
案件番号の採番処理に失敗しました。
BPW_C_PROCESS_COUNT_FILE_READ_ONLY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
案件番号の採番処理に失敗しました。
BPW_C_REPEAT_ORDER_BY_VALUE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ORDER BY句に指定されたカラム名が重複しています。
BPW_C_SHIFT_REFER_DUPLICATION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
参照者マスタ移行が出来ません。
BPW_C_ZERO_MEMBER_COMPANY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
指定された組織に属するユーザが存在しません。
BPW_FLOWINFO_INVALID_PARAMETER - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フローアイコンを取得する際の入力パラメータ不正です。
BPW_FLOWINFO_NO_EXIST_FLOWICON - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
フローアイコンが存在しません。
BPW_INVALID_DRAFT_COMMENT_LENGTH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
申請コメントの入力文字数が制限を越えています。
BPW_INVALID_PROCESS_NAME_LENGTH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
プロセス名の入力文字数が制限を越えています。
BPW_INVALID_RECEIVE_COMMENT_LENGTH - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
審議コメントの入力文字数が制限を越えています。
BPW_UT_FAILED_TO_BEGIN - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションの開始に失敗しました。
BPW_UT_FAILED_TO_CLOSE - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションの終了に失敗しました。
BPW_UT_FAILED_TO_COMMIT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのコミットに失敗しました。
BPW_UT_FAILED_TO_COMMIT_OUTSIDE_OF_TRANSACTION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
トランザクションが開始していないためコミットに失敗しました。
BPW_UT_FAILED_TO_GET_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのステータスの取得に失敗しました。
BPW_UT_FAILED_TO_LOCK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションロックの解除に失敗しました。
BPW_UT_FAILED_TO_ROLLBACK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのロールバックに失敗しました。
BPW_UT_FAILED_TO_ROLLEBACK_OUTSIDE_OF_TRANSACTION - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
トランザクションが開始していないためロールバックに失敗しました。
BPW_UT_FAILED_TO_SET_ROLLBACK_ONLY - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのロールバックオンリーの設定に失敗しました。
BPW_UT_FAILED_TO_SET_TRANSACTION_TIME_OUT - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザトランザクションのトランザクションタイムアウトの設定に失敗しました。
BPW_UT_FAILED_TO_UNLOCK - interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF の static 変数
ユーザアプリケーションロックの解除に失敗しました。

C

CANCEL - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：取り止め
CATEGORY_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
カテゴリコードキー
CATEGORY_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
カテゴリ名キー
CD_KIND_OFFICIAL - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがパブリックグループ
CD_KIND_OFFICIAL - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理依頼先種別：オフィシャルグループ
CD_KIND_ORG - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードが組織コード
CD_KIND_ORG - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理依頼先種別：組織
CD_KIND_PRIVATE - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理依頼先種別：プライベートグループ
CD_KIND_ROLE - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがロール
CD_KIND_USER - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがユーザコード
CD_KIND_USER - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理依頼先種別：ユーザ
CLT_AGT_COMPLETE_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
完了タスク表示(代理元承認可委譲)キー
CLT_AGT_GO_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
未処理タスク表示(代理元承認可委譲)キー
CLT_AGT_PULLBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
引き戻しタスク表示(代理元承認可委譲)キー
CLT_AGT_SENDBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
差し戻しタスク表示(代理元承認可委譲)キー
COMPLETE_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
完了タスク表示キー
CONTENTS_FRAME_TYPE_CUSTOM - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel の static 変数
コンテンツフレーム種別：カスタム
CONTENTS_FRAME_TYPE_DEFAULT - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel の static 変数
コンテンツフレーム種別：ノーマル
ConditionAdapter - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter.
外部プログラム実行抽象クラス。
ConditionAdapter(ConditionModel) - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter のコンストラクタ
コンストラクタ
ConditionModel - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel.
外部条件クラス（条件分岐, 結合条件)用、パラメータクラス ワークフロー上で条件分岐、結合条件で指定した外部プログラム内で実装する事により、
ログインユーザ情報が取得できます。
ConditionModel() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のコンストラクタ
コンストラクタ
ConditionModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のコンストラクタ
ContentsPathDetailModel - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel.
コンテンツパス詳細情報を保持するクラス
ContentsPathDetailModel() - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のコンストラクタ
コンストラクタ
ContentsPathModel - class jp.co.intra_mart.foundation.wkf.ContentsPathModel.
コンテンツパス設定情報を保持するクラス
ContentsPathModel() - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のコンストラクタ
コンストラクタ
CreateRouteInfoModel - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel.
CreateRouteInfoModel() - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のコンストラクタ
CreateRouteTargetInfoModel - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel.
ルート作成時、設定情報を保持するクラス
CreateRouteTargetInfoModel() - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のコンストラクタ
cancel(String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
取り止め処理を実行します。
cancelAgent(TransferInfoModel) - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
代理設定を解除します。
changeRunUser(String, String, String, String, TargetInfoModel) - class jp.co.intra_mart.foundation.wkf.TaskInfo のメソッド
指定された案件内の指定タスクの処理者を変更します。
checkLicenseForProcessClass(String, String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別に対するライセンスのチェックを行う。
chkStopMailList(String) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
停止対象となるテンプレートメールのチェックを行います。
clone() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
クローン
clone() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
クローン
compulsion(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
ここで終了後後処理実行メソッド。
controlProcess(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス操作を実行します。
convertEndTaskFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static メソッド
最短終了タスク値を最終タスクフラグに変換します。

D

DELEGATE_TASK - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：振り替え
DRAFT_APPOINT_DATE - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票指定日キー
DRAFT_COMP_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票者の起票会社コードキー
DRAFT_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票日(検索範囲終了)キー
DRAFT_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票日(検索範囲開始日)キー
DRAFT_ORGN_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票者の起票組織コードキー
DRAFT_USER_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票ユーザコードキー
DRAFT_USER_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
起票ユーザ名キー
Drafter - class jp.co.intra_mart.foundation.wkf.Drafter.
起票関連のAPI
起票関連の処理に使用されるクラスです。
Drafter(String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のコンストラクタ
コンストラクタ１(本人用)
Drafter(String, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のコンストラクタ
コンストラクタ２(代理人用)。
deleteProcess(String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
案件の削除処理実行メソッド。
deleteProcess(String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
プロセス定義・バージョンの削除処理実行メソッド。
denial(String, String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
否認処理を実行します。
draft(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
推奨されていません。 draft メソッドを使用してください。
draft(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票処理を実行します。
draft(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
推奨されていません。 draft メソッドを使用してください。
draft(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票処理を実行します。

E

EISModelStaticIF - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF.
アクティビティの状態等を定義するインタフェース。
EIS_INIT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
初期値（数値）
EIS_METHOD_ACTIVED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（開始）
EIS_METHOD_CANCELED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（取消）
EIS_METHOD_CLOSED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（閉じる）
EIS_METHOD_COMPENSATED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（補完）
EIS_METHOD_COMPLETED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（完了）
EIS_METHOD_COMPULSION - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（強制完了）
EIS_METHOD_EXITED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（終了）
EIS_METHOD_FAULTED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（障害）
EIS_METHOD_SUSPENDED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
リフレクト・メソッド（保留中）
END_STATUS_CANCEL - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
完了ステータス：取り止め
END_STATUS_COMPULSION - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
完了ステータス：途中終了
END_STATUS_NORMAL - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
完了ステータス：通常
END_STATUS_REJECTION - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
完了ステータス：否認
END_TASK_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
非終了タスク
END_TASK_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
終了タスク
execute(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter のメソッド
条件問い合わせを実行するメソッド
条件分岐および、条件結合の判定を行う場合はこのメソッドを継承してください。
existUserCd(Connection, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static メソッド
ユーザコード入力情報をチェックするメソッドです。
exportProcessDef(ArrayList) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義(Excel形式)をエクスポートします。

F

FLG_OFF - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
フラグOFF
FLG_ON - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
フラグON
FlowInfo - class jp.co.intra_mart.foundation.wkf.FlowInfo.
フロー情報オブジェクト
特定のタスクの位置情報を保持した、フロー情報を取得する。
FlowInfo() - class jp.co.intra_mart.foundation.wkf.FlowInfo のコンストラクタ
コンストラクタ

G

GO_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
未処理タスク表示キー
getActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティコードを返却します。
getActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティコードを返却します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
アクティビティコードを取得します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
アクティビティコードを返却します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
アクティビティコードを取得します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
アクティビティコードを取得します。
getActivityCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理タスクコードを返却します。
getActivityInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getActivityInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getActivityInfo(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義コード、バージョンコード、アクティビティコード、絞込み条件をキーに
タスク(アクティビティ)情報を取得します。
getActivityName() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ名を返却します。
getActivityName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティ名を返却します。
getActivityName() - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel のメソッド
タスク名を取得します。
getActivityName() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
タスク名を取得します。
getActivityName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理タスク名を返却します。
getActivityProcessDefList(SearchCondition, Sort[], int, int, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票可能プロセス一覧を取得します。
getActivityStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティステータスを返却します。
getActivityTaskList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
処理可能案件(未処理案件)一覧の取得を行います。
getActivityType() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ種別を返却します。
getActivityType() - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel のメソッド
タスク種別を取得します。
getActivityType() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
アクティビティ種別を返却します。
getAgentUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理元ユーザCDを返却します。
getAgentUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
代理依頼元ユーザコードを返却します。
getAgentUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
代理依頼元ユーザ名を返却します。
getAgtCompFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
完了タスク表示(委譲)を返却します。
getAgtGoFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
未処理タスク表示(委譲)を返却します。
getAgtPullbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
引戻しタスク表示(委譲)を返却します。
getAgtSendbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
差し戻しタスク表示(委譲)を返却します。
getApplicationId() - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
アプリケーションIDを取得します。
getApplicationKeys() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
指定したプロセスのアプリケーションキーを取得します。
getApplyPath() - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
通常コンテンツパスを返却します。
getApprovalCompCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者の会社コードを返却します。
getApprovalDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理日(検索範囲終了日)を返却します。
getApprovalDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理日(検索範囲開始日)を返却します。
getApprovalOrgnCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者の会社組織コードを返却します。
getApprovalOrgnName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者の会社組織名を返却します。
getApprovalRightType() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認可否種別を返却します。
getApprovalType() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認種別を返却します。
getApprovalTypeCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認種別CDを返却します。
getApprovalUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者コードを返却します。
getApprovalUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者ユーザコードを返却します。
getApprovalUserName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者名を返却します。
getApprovalUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理者ユーザ名を返却します。
getArbitraryChangeFlag() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
任意指定フラグを返却します。
getArriveDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
到達日(検索範囲終了日)を返却します。
getArriveDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
到達日(検索範囲開始日)を返却します。
getAscending() - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
昇順ソートキーを返却します。
getAttachPosition() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
所属立場を返却します。
getAttachmentFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
getAttachmentFlagFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
getAttainmentClass() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
到達種別を返却します。
getAuthorityFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
処理権限フラグを返却します。
getAutoPass() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
期日による自動パス設定の日数を返却します。
getAutoPassExecutive() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
対象者自動パス設定情報を取得します。
getAutoPassFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス処理フラグを返却します。
getAutoPassTarget() - class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel のメソッド
自動パス対象者情報を取得します。
getAutoPassTerm() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス期限を返却します。
getAutoPasslist() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パスのリスト情報を返却します。
getBefActiCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティ名を返却します。
getBefActiName() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティ名を返却します。
getBefActiUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者CDを返却します。
getBefActiUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者名を返却します。
getBeforeUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
前処理者ユーザコードを返却します。
getBeforeUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
前処理者ユーザ名を返却します。
getCallActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティコードを返却します。
getCallActivityType() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティ種別を返却します。
getCallProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出プロセスコードを返却します。
getCallProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出しプロセス定義コードを返却します。
getCallVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出し履歴コードを返却します。
getCategoryCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
カテゴリコードを返却します。
getCategoryCode() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
カテゴリコードを返却します。
getCategoryInfo(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getCategoryInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getCategoryInfo(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
カテゴリコード、絞込み条件をキーにしてカテゴリ情報を取得します。
getCategoryInfoByName(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getCategoryInfoByNameメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getCategoryInfoByName(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
カテゴリ名、絞込み条件をキーにしてカテゴリ情報を取得します。
getCategoryName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
カテゴリ名を返却します。
getCltAgtCompFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
完了タスク表示(代理元処理可委譲)を返却します。
getCltAgtGoFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
未処理タスク表示(代理元処理可委譲)を返却します。
getCltAgtPullbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
引戻しタスク表示(代理元処理可委譲)を返却します。
getCltAgtSendbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
差し戻しタスク表示(代理元処理可委譲)を返却します。
getCode() - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
対象者コードを返却します。
getCodeValue() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
コード値を返却します。
getComment() - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール本文を返却します。
getCompFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
完了タスク表示を返却します。
getCompanyCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
会社コードを返却します。
getCompanyCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
会社コードを返却します。
getCompulsionEndFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
強制終了可否フラグを返却します。
getConditionType() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
分岐種別を返却します。
getContentsFrameType() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
コンテンツフレーム種別を返却します。
getContentsPath() - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
コンテンツパスを取得します。
getContentsPath() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
コンテンツパス情報を返却します。
getConvertLong(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
数値型変換後に返却します。
getCreateDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成日時を返却します。
getCreateRouteTargetList() - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のメソッド
対象者情報配列を返却します。
getCreateUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者コードを返却します。
getCreateUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者名を返却します。
getDemandReceiptCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付CDを返却します。
getDemandReceiptName() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付名を返却します。
getDescending() - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
降順ソートキーを返却します。
getDetailPath() - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
詳細コンテンツパスを返却します。
getDraftActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
起票処理コードを返却します。
getDraftAppointDate() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票指定日を返却します。
getDraftCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
起票アクティビティコードを取得します。
getDraftComment() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票時コメントを返却します。
getDraftCompCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者の会社コードを返却します。
getDraftDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票日を返却します。
getDraftDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票日(検索範囲終了日)を返却します。
getDraftDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票日(検索範囲開始日)を返却します。
getDraftOrgnCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者の会社組織コードを返却します。
getDraftUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者コードを返却します。
getDraftUserCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者ユーザコードを返却します。
getDraftUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者名を返却します。
getDraftUserName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
起票者ユーザ名を返却します。
getEffctiveDate() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
有効日付を取得します。
getEffectiveDate() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
有効日付を返却します。
getEndDate() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
終了日付を返却します。
getEndDate() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
終了日付を取得します。
getEndFlg() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
分岐終了フラグを返却します。
getEndProcessList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
起票済み案件を取得します。
getEndTaskFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
終了タスクフラグを返却します。
getEndTaskList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
処理済案件一覧の取得を行います。
getEndTaskProgram() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
END時実行クラスを返却します。
getErrorCode() - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のメソッド
エラーコードを返却します。
getExtensionA() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＡを返却します。
getExtensionB() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＢを返却します。
getExtensionC() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＣを返却します。
getExtensionD() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＤを返却します。
getExtensionE() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＥを返却します。
getExtensionF() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＦを返却します。
getExtensionG() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＧを返却します。
getExtensionH() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＨを返却します。
getExtensionNameA() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ａを返却します。
getExtensionNameAFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ａ更新対象フラグを返却します。
getExtensionNameB() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｂを返却します。
getExtensionNameBFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｂ更新対象フラグを返却します。
getExtensionNameC() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｃを返却します。
getExtensionNameCFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｃ更新対象フラグを返却します。
getExtensionNameD() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｄを返却します。
getExtensionNameDFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｄ更新対象フラグを返却します。
getExtensionNameE() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｅを返却します。
getExtensionNameEFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｅ更新対象フラグを返却します。
getExtensionNameF() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｆを返却します。
getExtensionNameFFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｆ更新対象フラグを返却します。
getExtensionNameG() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｇを返却します。
getExtensionNameGFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｇ更新対象フラグを返却します。
getExtensionNameH() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｈを返却します。
getExtensionNameHFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｈ更新対象フラグを返却します。
getFileList() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
添付ファイル一覧を取得します。
getFirst() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、最初のタスクに位置している状態に遷移させる
getFlow() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
プロセス上の現在位置を取得します。
getFlowInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getFlowInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件:AUTHORITY_ALLで情報を取得します。
getFlowInfo(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
特定のタスクの位置情報を保持して、フロー情報を取得する。
getFlowInfoByTargetNo(String, String, int, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
特定のタスクの位置情報を保持して、フロー情報を取得する。
getGoFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
未処理タスク表示を返却します。
getGroupCd() - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
対象者グループコードを返却します。
getGroupList() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
グループ情報リストを返却します。
getGroupName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
グループ名を返却します。
getIsSubProcess() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
サブプロセスフラグを返却します。
getLast() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、最後のタスクに位置している状態に遷移させる
getLastManualActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動処理コードを返却します。
getLastManualActivityResult() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動アクティビティ承認結果種別を返却します。
getLicense() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static メソッド
ライセンスを取得します。
getLimitDateEnd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理期限日(検索範囲終了日)を返却します。
getLimitDateStart() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
処理期限日(検索範囲開始日)を返却します。
getLocale() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ロケールを返却します。
getLocaleId() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者ロケールIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupID() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイングループIDを返却します。
getLoginGroupId() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログイングループＩＤを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserID() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログインユーザIDを返却します。
getLoginUserId() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログインユーザＩＤを返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
ユーザ情報返却メソッド
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログインユーザ情報を返却します。
getLoginUserInfo() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログインユーザ情報を返却します。
getMailPostponement() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
催促猶予日数を返却します。
getMailTamplate() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
設定されたメールテンプレートを取得します。
getNarrowPostCd() - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
絞り込み役職コードを取得します。
getNarrowPostCd() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
絞り込み役職コードを取得します。
getNarrowPostCd() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
絞り込み役職コードを取得します。
getNarrowPostCd() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
絞り込み役職コードを取得します。
getNarrowPostCd() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
絞り込み役職コードを取得します。
getNarrowPostName() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
絞り込み役職名を取得します。
getNarrowPostName() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
絞り込み役職名を取得します。
getNarrowPostName() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
絞り込み役職名を取得します。
getNarrowPostName() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
絞り込み役職名を取得します。
getNext() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、次のタスクに位置している状態に遷移させる。
getNote() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
備考を返却します。
getNoticeMailFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
代理元メール通知フラグを返却します。
getPageKind() - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
ページ種別を取得します。
getPairNo() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
ペアNOを返却します。
getParallelNestCnt() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期処理階層カウンタを返却します。
getPostCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コードを返却します。
getPostCdKind() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コード種別を返却します。
getPostProcessingProgram() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
後処理クラス名を返却します。
getPostRestrict() - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
役職絞込みコードを返却します。
getPreActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機アクティビティコードを返却します。
getPreApprovalType() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
前承認種別を返却します。
getPreProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセスコードを返却します。
getPreProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセス定義コードを返却します。
getPreVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機履歴コードを返却します。
getPresentDisplayInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
現処理表示情報を返却します。
getPresentProcess() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
現処理を返却します。
getPrev() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
自分自身のオブジェクトを、前のタスクに位置している状態に遷移させる。
getProcessCallActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出処理コードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
プロセスコードを返却します。
getProcessCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセスコードを返却します。
getProcessClassCode() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別コードを返却します。
getProcessClassCodeFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別コード更新対象フラグを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のメソッド
プロセス定義コードを取得します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
プロセス定義コードを返却します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
プロセス定義コードを取得します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
プロセス定義コードを取得します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
プロセス定義コードを取得します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
プロセス定義コードを取得します。
getProcessDefCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセス定義コードを返却します。
getProcessDefInfo(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getProcessDefInfoメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getProcessDefInfo(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義コード、絞込み条件をキーにしてプロセス定義情報を取得します。
getProcessDefInfoByCategory(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
カテゴリコード、絞込み条件をキーにしてプロセス定義情報配列を取得します。
getProcessDefInfoByName(String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getProcessDefInfoByNameメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getProcessDefInfoByName(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義名、絞込み条件をキーにしてプロセス定義情報を取得します。
getProcessDefInfoByVersion(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getProcessDefInfoByVersionを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getProcessDefInfoByVersion(String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義コード、バージョンコード、絞込み条件をキーにしてプロセス定義情報を取得します。
getProcessDefName() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義名を返却します。
getProcessDefName() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
プロセス定義名を取得します。
getProcessDefName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセス定義名を返却します。
getProcessDefNote() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義備考を返却します。
getProcessEndStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
完了プロセスステータスを返却します。
getProcessHistory() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
案件の処理履歴を取得します。
getProcessInfo() - class jp.co.intra_mart.foundation.wkf.Process のメソッド
プロセス情報を取得します。
getProcessList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getProcessListメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getProcessList(SearchCondition, Sort[], int, int, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス一覧情報を取得します。
getProcessName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセス名を返却します。
getProcessName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス名(サブプロセス申請用)を返却します。
getProcessName() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
プロセス名を返却します。
getProcessNestCnt() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
サブプロセス呼出カウンタを返却します。
getProcessStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセスステータスを返却します。
getProcessTermDate() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理期限日付を返却します。
getProcessingStatus() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理状態識別を返却します。
getPullPath() - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
引戻しコンテンツパスを返却します。
getPullbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
引戻しタスク表示を返却します。
getReceiveComment() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認時コメントを返却します。
getReceivelist() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
レシーブのリスト情報を返却します。
getReceptionDate() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
受信日付を返却します。
getRecognitionStatus() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認ステータスを返却します。
getRecordDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新日時を返却します。
getRecordUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者コードを返却します。
getRecordUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新者コードを返却します。
getRecordUserName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者名を返却します。
getReferPath() - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
参照コンテンツパスを返却します。
getReferTaskList(SearchCondition, Sort[], int, int) - class jp.co.intra_mart.foundation.wkf.Reference のメソッド
参照可能案件一覧を取得します。
getReferUser() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
参照者情報を取得します。
getRepresentationType() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
代理コード種別を返却します。
getRequiredTerm() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
所要日数を返却します。
getReserveInfo() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
送信されるメール内容情報を取得します。
getReturnFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しフラグを返却します。
getReturnHistoryCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
差し戻し履歴コードを返却します。
getReturnMailFlag() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しメール送信フラグを返却します。
getReturnPath() - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
差戻しコンテンツパスを返却します。
getRoleRestrict() - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
ロール絞込みIDを返却します。
getRollSelectFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
ロール絞込み指定フラグを返却します。
getRouteInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
申請者/承認者ルート作成-ルート情報を取得します。
getRunExecuteInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行主体ユーザマスタ情報を返却します。
getRunSelectFlg() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行時選択フラグを返却します。
getRunUser() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
対象者情報を取得します。
getRunUserInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行主体役職マスタ情報を返却します。
getRunuserlist() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行主体ユーザのリスト情報を返却します。
getSelectRouteNo() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
選択ルート番号を返却します。
getSelectRouteNo() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
選択ルート番号を返却します。
getSendbackFilter() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
差し戻しタスク表示を返却します。
getServiceId() - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
サービスIDを取得します。
getStartActivityCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
開始処理コードを返却します。
getStartActivityCdFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
開始処理コード更新対象フラグを返却します。
getStatusEndedDate() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ステータス完了日付を返却します。
getSubProcessFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
サブプロセス識別フラグを返却します。
getSubProcessFlagFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
サブプロセス識別フラグ更新対象フラグを返却します。
getSyncronizedInfo() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期情報を返却します。
getTargetCd() - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
対象者コードを取得します。
getTargetDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
所属組織を取得します。
getTargetDepartment(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
所属組織を取得します。
getTargetGroupCd() - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
対象者グループコードを取得します。
getTargetMasterDate() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
対象マスタ日付を返却します。
getTargetMasterDate() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
対象指定日を返却します。
getTargetReferInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.TaskInfo のメソッド
指定されたタスクに設定された参照者情報を取得します。
getTargetRunInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.TaskInfo のメソッド
指定されたタスクに設定された対象者情報を取得します。
getTargetType() - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
対象者種別を設定します。
getTaskResultInfo(String) - class jp.co.intra_mart.foundation.wkf.Process のメソッド
タスク処理結果情報を取得します。
getTitle() - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメールタイトルを返却します。
getTransactorCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者コードを返却します。
getTransactorName() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者名を返却します。
getTransferActivityList(String, String) - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
タスク委譲情報一覧を取得します。
getTransferCd() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先コードを取得します。
getTransferCd() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先コードを取得します。
getTransferCd() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先コードを取得します。
getTransferCd() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先コードを取得します。
getTransferCdType() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先種別を取得します。
getTransferCdType() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先種別を取得します。
getTransferCdType() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先種別を取得します。
getTransferCdType() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先種別を取得します。
getTransferComment() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理コメントを取得します。
getTransferEndDate() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理期間(終了日)を取得します。
getTransferEndDate() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理期間(終了日)を取得します。
getTransferEndDate() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理期間(終了日)を取得します。
getTransferEndDate() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理期間(終了日)を取得します。
getTransferFlg() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
代理フラグを返却します。
getTransferFlg() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理フラグを返却します。
getTransferGroupCd() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先グループコードを取得します。
getTransferGroupCd() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先グループコードを取得します。
getTransferGroupCd() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先グループコードを取得します。
getTransferGroupCd() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先グループコードを取得します。
getTransferInfo(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
指定された日付に有効な代理設定情報を返却します。
getTransferInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
処理委譲情報を取得します。
getTransferName() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先名を取得します。
getTransferName() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先名を取得します。
getTransferName() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先名を取得します。
getTransferName() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先名を取得します。
getTransferProcessDefList(String) - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
プロセス定義委譲情報一覧を取得します。
getTransferStartDate() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理期間(開始日)を取得します。
getTransferStartDate() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理期間(開始日)を取得します。
getTransferStartDate() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理期間(開始日)を取得します。
getTransferStartDate() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理期間(開始日)を取得します。
getTransferStatus() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理設定種別を取得します。
getTransferStatus() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理設定種別を取得します。
getTransferStatus() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理設定種別を取得します。
getTransferStatus() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理設定種別を取得します。
getTransferUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザCDを返却します。
getTransferUserName() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザ名を返却します。
getTransferVersionList(String) - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
バージョン委譲情報一覧を取得します。
getType() - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
対象者種別を返却します。
getUserAppliKey(int) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
指定されたパラメータ番号のユーザアプリケーションキーテーブル情報を 返却します。
getUserAppliKeyList() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを返却します。
getUserApplikeyList() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを返却します。
getUserApplikeyList() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを返却します。
getUserCd() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザコードを返却します。
getUserList() - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール送信者リストを返却します。
getUserName() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザ名を返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴コードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のメソッド
バージョンコードを取得します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
バージョンコードを返却します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
バージョンコードを取得します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
バージョンコードを取得します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
バージョンコードを取得します。
getVersionCd() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
バージョンコードを返却します。
getVersionInfo(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。 getVersionメソッドを使用してください。
※ このメソッドを使用すると、絞込み条件：AUTHORITY_ALLで情報を取得します。
getVersionInfo(String, String, String) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
バージョン(ルート)情報を取得します。
getVersionName() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義（履歴名）を取得します。
getVersionName() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴名を返却します。
getVersionName() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
バージョン名を取得します。
getVersionNameFlag() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴名更新対象フラグを返却します。

H

hasNext() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
次のタスクが存在するかどうかを返却する。
hasPrev() - class jp.co.intra_mart.foundation.wkf.FlowInfo のメソッド
前のタスクが存在するかどうかを返却する。

I

importProcessDef(Object) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
プロセス定義(Excel形式)をインポートします。
inputCheck(Connection, String, UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
実行主体役職マスタ入力情報をチェックするメソッドです。
inputCheck(Connection, String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
実行主体ユーザ入力情報をチェックするメソッドです。
inputCheck(Connection, String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴マスタ入力情報をチェックするメソッドです。
isAutoPassFlag() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
自動パスフラグを返却します。
isAutoPassFlag() - class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel のメソッド
自動パスフラグを取得します。
isCompulsionEndFlag() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
途中終了フラグを返却します。
isDynamicTaskFlag() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
動的承認者フラグを取得します。
isMailSendFlag() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
催促メール使用フラグを返却します。
isNoticeMailFlag() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理元メール通知フラグを取得します。
isPostProcessingFlag() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
後処理使用フラグを返却します。
isReserve() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メール予約機能使用有無を判定します。
isReturnFlag() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
差し戻し/引き戻しフラグを返却します。
isReturnMailFlag() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
差し戻しメールフラグを返却します。
isSatisfied() - class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter のメソッド
条件問い合わせ
isSendMailFlag() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
メール通知フラグを取得します。
isShortestEndFlag() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
必須選択最終タスクフラグを返却します。
isStop() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
テンプレートメールの送信抑止を判定します。
isSubRecognitionFlag() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理元承認可否フラグを取得します。
isTransferActivityFlag() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
タスク委譲フラグを取得します。
isTransferActivityFlag() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
タスク委譲フラグを取得します。
isTransferVersionFlag() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
バージョン委譲フラグを取得します。

J

jp.co.intra_mart.foundation.bpw.exception - package jp.co.intra_mart.foundation.bpw.exception
jp.co.intra_mart.foundation.bpw.model.data - package jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object - package jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf - package jp.co.intra_mart.foundation.wkf
jp.co.intra_mart.foundation.wkf.support - package jp.co.intra_mart.foundation.wkf.support
jp.co.intra_mart.system.bpw - package jp.co.intra_mart.system.bpw

L

LIMIT_DATE_END - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理期限日(検索範囲終了日)キー
LIMIT_DATE_START - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
処理期限日(検索範囲開始日)キー

M

MAGICAL_HAND - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：強制操作
MAIL_USER_ADDRESS - class jp.co.intra_mart.foundation.wkf.NegoModel の static 変数
MAIL_USER_CD - class jp.co.intra_mart.foundation.wkf.NegoModel の static 変数
送信先ユーザコードキー
MAIL_USER_NAME - class jp.co.intra_mart.foundation.wkf.NegoModel の static 変数
Manager - class jp.co.intra_mart.foundation.wkf.Manager.
マスタ関連のAPI
マスタメンテナンス関連処理で使用されるクラスです。
Manager(String, String) - class jp.co.intra_mart.foundation.wkf.Manager のコンストラクタ
コンストラクタ

N

NON_BILONGING - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
無所属時のダミーコード
NO_PAIR - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
ペアNOがペアではない
NegoModel - class jp.co.intra_mart.foundation.wkf.NegoModel.
BPWModelIFを保持するリストクラス
NegoModel() - class jp.co.intra_mart.foundation.wkf.NegoModel のコンストラクタ
コンストラクタ
noTransaction() - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
データベーストランザクションを未使用にする。
noTransaction() - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
データベーストランザクションを未使用にする。
noTransaction() - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
データベーストランザクションを未使用にする。
noTransaction() - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
データベーストランザクションを未使用にする。
noTransaction() - class jp.co.intra_mart.foundation.wkf.TaskInfo のメソッド
データベーストランザクションを未使用にする。

O

OLD_DATA - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
旧データ （旧データ：ペアＮＯのデフォルト値）
optionalRegistProcessCd(String, String, ArrayList, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
プロセスCD任意採番処理実行メソッド。

P

PAGE_KIND_FRAME_WORK - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel の static 変数
ページ種別：J2EEフレームワーク
PAGE_KIND_PRESENTAION_PAGE - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel の static 変数
ページ種別：プレゼンテーションページ
PAGE_KIND_SERVLET - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel の static 変数
ページ種別：サーブレット
POST_TYPE_POSITION - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードが役職コード （絞込み）
POST_TYPE_ROLE - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel の static 変数
指定されたコードがロール （絞込み）
PROCESSING_COMPLETED - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【共通】完了
PROCESSING_NORMALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】通常(通常到達にて活性化)
PROCESSING_PSN_NORMALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】通常(通常到達にて活性化)
PROCESSING_PSN_PULL_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】引戻し(引戻しにて活性化)
PROCESSING_PSN_PULL_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】引戻し(引戻しにて活性化後の保留)
PROCESSING_PSN_SEND_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】差戻し(差戻しにて活性化)
PROCESSING_PSN_SEND_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】差戻し(差戻しにて活性化後の保留)
PROCESSING_PSN_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
PROCESSING_PULL_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】引戻し(引戻しにて活性化)
PROCESSING_PULL_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】引戻し(引戻しにて活性化後の保留)
PROCESSING_SEND_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】差戻し(差戻しにて活性化)
PROCESSING_SEND_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】差戻し(差戻しにて活性化後の保留)
PROCESSING_SUB_NORMALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】通常(通常到達にて活性化)
PROCESSING_SUB_PULL_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】引戻し(引戻しにて活性化)
PROCESSING_SUB_PULL_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】引戻し(引戻しにて活性化後の保留)
PROCESSING_SUB_SEND_BACK - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】差戻し(差戻しにて活性化)
PROCESSING_SUB_SEND_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決不可】差戻し(差戻しにて活性化後の保留)
PROCESSING_SUB_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【代理設定有り・本人決済可】通常(通常到達にて活性化後の保留)
PROCESSING_SUSPEND - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
【本人・代理設定なし】通常(通常到達にて活性化後の保留)
PROCESS_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセスコードキー
PROCESS_CLASS_BPW - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
プロセス種別コード : ビジネスプロセスワークフロー
PROCESS_CLASS_DRW - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
プロセス種別コード : 申請者／承認者ルート作成ワークフロー
PROCESS_CLASS_DW - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
プロセス種別コード : ドキュメントワークフロー
PROCESS_DEF_ALL - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
プロセス定義コード：全て
(全プロセス定義にプロセス定義委譲を行いたい場合に使用します。)
PROCESS_DEF_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセス定義コードキー
PROCESS_DEF_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセス定義名キー
PROCESS_NAME - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
プロセス名キー
PULLBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
引き戻しタスク表示キー
PULL_ACTIVITY_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
引き戻し不可
PULL_ACTIVITY_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
引き戻し可
Process - class jp.co.intra_mart.foundation.wkf.Process.
案件関連のAPI
案件関連の情報取得などに使用されるクラスです。
Process(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Process のコンストラクタ
コンストラクタ
ProcessInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel.
プロセス情報を保持する情報クラス
ProcessInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のコンストラクタ
コンストラクタ
proceed(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
処理実行メソッド。
pullBack(String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
引き戻し処理を実行します。
pullBack(String, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
引戻し処理を実行します。
pullDraft(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
引戻し後処理実行メソッド。

R

RECOGNITION - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：承認
REFER_ALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
参照者若しくは承認者として関連図けられたアクティビティ
REFER_NONE - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
参照者・承認者を考慮しない
REFER_READ - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
参照者として関連図けられたアクティビティ
REFER_RECOGNITION - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
承認者として関連図けられたアクティビティ
REJECTION - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：棄却
RETRY - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：再申請
RETURN_ACTIVITY_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻し不可
RETURN_ACTIVITY_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻し可
RETURN_BEFORE - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：承認者へ差し戻す
RETURN_MAIL_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻しメール送信なし
RETURN_MAIL_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
差し戻しメール送信あり
RETURN_PULL - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：引き戻し
RETURN_START - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：申請者へ差し戻す
RETURN_TASK - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：任意の処理者へ差し戻す
RETURN_TYPE_BEFORE - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
差戻し種別：前処理者へ差戻し
RETURN_TYPE_START - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
差戻し種別：申請者へ差戻し
RETURN_TYPE_TASK - class jp.co.intra_mart.foundation.wkf.Approver の static 変数
差戻し種別：任意の処理者へ差戻し
RIGHT_DELEGATE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：振替・本人決済可（振替(02)の承認種別CDでのみ有効）
RIGHT_INIT - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：初期値（全ての承認種別CDで有効）
RIGHT_NOT_DELEGATE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：振替・本人決済不可（振替(02)の承認種別CDでのみ有効）
RIGHT_NOT_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：代理・本人決済不可（本人(00)の承認種別CDでのみ有効）
RIGHT_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認可否種別：代理・本人決済可（本人(00)の承認種別CDでのみ有効）
ROLL_SELECT_OFF - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
ロール絞込み指定ON
ROLL_SELECT_ON - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
ロール絞込み指定OFF
RUN_AUTH_ALL - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
処理権限・代理権限供にあるアクティビティ
RUN_AUTH_NOT - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
処理権限がないアクティビティ
RUN_AUTH_RUN - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
処理権限があるアクティビティ
RUN_AUTH_TRANSFER - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
代理処理権限があるアクティビティ
RUN_SELECT_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
実行時選択OFF
RUN_SELECT_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
実行時選択ON
ReceiveTaskModel - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel.
処理タスク設定情報を保持するクラス
ReceiveTaskModel() - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のコンストラクタ
コンストラクタ
RecognitionInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel.
処理要求時情報モデル。
RecognitionInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のコンストラクタ
コンストラクタ
RecognitionInfoModel(ProcessInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のコンストラクタ
RecognitionInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のコンストラクタ
Reference - class jp.co.intra_mart.foundation.wkf.Reference.
参照関連のAPI
参照案件の取得などに使用されるクラスです。
Reference(String, String) - class jp.co.intra_mart.foundation.wkf.Reference のコンストラクタ
コンストラクタ
RunExecutiveInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel.
実行主体役職マスタの情報保持クラス
次タスクが実行時選択の場合に、次承認者情報オブジェクトを扱います。
RunExecutiveInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunExecutiveInfoModel(ReceiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunExecutiveInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunExecutiveInfoModel(RunExecutiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のコンストラクタ
RunUserInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel.
実行主体ユーザ情報を保持する情報クラス
RunUserInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
コンストラクタ
RunUserInfoModel(ProcessInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(ActivityInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(ActivityMasterUnitModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(ReceiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(RunUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
RunUserInfoModel(DelegateUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のコンストラクタ
registProcessDef(String, String, String, String, String, boolean, boolean, String, String, ContentsPathModel, List) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
推奨されていません。
rejection(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
否認後後処理実行メソッド。
removeInfo() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
処理失敗時にWfeResultMailManagerを使用し設定された情報を削除する為に使用します。
removeProcess(String, String, String, Boolean) - class jp.co.intra_mart.foundation.wkf.Manager のメソッド
案件を削除を実行します。
reserveCancel() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メール予約機能の使用を取消します。
reserveRequest() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メール予約機能の使用を依頼します。
retry(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
推奨されていません。 retry メソッドを使用してください。
retry(String, String, String, String, List, String, String, String, String, NegoModel, RunExecutiveInfoModel, String, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
再起票処理を実行します。
retry(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
推奨されていません。 retry メソッドを使用してください。
retry(String, String, String, String, List, String, String, String, String, NegoModel, RunUserInfoModel, String, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
再起票処理を実行します。
returnDraft(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
処理者へ差戻し後処理実行メソッド。
returnStart(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
申請者へ差戻し後処理実行メソッド。
returnTask(String, String, String, String, String, String) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
任意の処理者へ差戻し後処理実行メソッド。

S

SENDBACK_FILTER - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
差し戻しタスク表示キー
STATUS_ACTIVE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
有効な状態であることを示すステータス
STATUS_ACTIVITY - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理設定種別：タスク委譲
STATUS_AUTOCLOSING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
自動終了を示すステータス
STATUS_CANCELING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
取消中であることを示すステータス
STATUS_CLOSING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
終了したことを示すステータス
STATUS_COMPENSATING - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
補完中であることを示すステータス
STATUS_COMPLETE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：処理済（全ての承認種別CDで有効）
STATUS_COMPLETED - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
完了したことを示すステータス
STATUS_DELEGATE_COMPLETE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：振替処理済（本人(00), 振替(02)の承認種別CDでのみ有効）
STATUS_EXIT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
処理が終了したことを示すステータス
STATUS_FAULT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
障害が発生したことを示すステータス
STATUS_INIT - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：初期値（全ての承認種別CDで有効）
STATUS_NONE - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
有効なステータスではない
STATUS_PROCESS_DEF - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理設定種別：プロセス定義委譲
STATUS_READY - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
準備完了を示すステータス
STATUS_SAID_COMPLETE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認ステータス：代理処理済（本人(00)の承認種別CDでのみ有効）
STATUS_SUSPEND - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
保留中であることを示すステータス
STATUS_VERSION - class jp.co.intra_mart.foundation.wkf.TransferInfoModel の static 変数
代理設定種別：バージョン委譲
STR_INIT - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
初期値（文字列）
STR_NULL - interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF の static 変数
空文字
SUB_PROCESS_INIT - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
サブプロセス識別フラグ : 通常／サブ利用可能プロセス
SUB_PROCESS_ONLY - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel の static 変数
サブプロセス識別フラグ : サブ利用特化プロセス
SUSPENSION - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：保留
SearchCondition - class jp.co.intra_mart.foundation.wkf.support.SearchCondition.
プログラムサポート/検索条件設定オブジェクト。
SearchCondition() - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のコンストラクタ
コンストラクタ
Sort - class jp.co.intra_mart.foundation.wkf.support.Sort.
プログラムサポート/ソート指定オブジェクト。
Sort() - class jp.co.intra_mart.foundation.wkf.support.Sort のコンストラクタ
コンストラクタ
send() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メールの送信を実行します。
sendBack(String, String, String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
推奨されていません。 sendBack メソッドを使用してください。
sendBack(String, String, String, String, String, String, String, String, NegoModel, String, String, String, String) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
差し戻し処理を実行します。
sendMail(String, String, String, String, String, ArrayList, ArrayList, ArrayList) - class jp.co.intra_mart.foundation.wkf.Util のメソッド
メール送信処理を行います。
setActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティコードを設定します。
setActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティコードを設定します。
setActivityCd(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
アクティビティコードを設定します。
setActivityCd(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
アクティビティコードを設定します。
setActivityCd(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
アクティビティコードを設定します。
setActivityName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ名を設定します。
setActivityName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
アクティビティ名を設定します。
setActivityName(String) - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel のメソッド
タスク名を設定します。
setActivityName(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
タスク名を設定します。
setActivityStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティステータスを設定します。
setActivityType(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
アクティビティ種別を設定します。
setActivityType(String) - class jp.co.intra_mart.foundation.wkf.ActivityTaskModel のメソッド
タスク種別を設定します。
setAgent(TransferInfoModel) - class jp.co.intra_mart.foundation.wkf.AgentSetting のメソッド
代理設定を設定します。
setAgentUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理元ユーザCDを設定します。
setApplicationId(String) - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
アプリケーションIDを設定します。
setApplyPath(ContentsPathDetailModel) - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
通常コンテンツパスを設定します。
setApprovalRightType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認可否種別を設定します。
setApprovalType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認種別を設定します。
setApprovalTypeCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認種別CDを設定します。
setApprovalUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者コードを設定します。
setApprovalUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認者名を設定します。
setArbitraryChangeFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
任意指定フラグを設定します。
setAscending(String) - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
昇順ソートキーを設定します。
setAttachPosition(RunGroupInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
所属立場を設定します。
setAttachmentFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
setAttainmentClass(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
到達種別を設定します。
setAuthorityFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
処理権限フラグを設定します。
setAutoPass(String) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
期日による自動パス設定の日数を設定します。
setAutoPassExecutive(TargetAutoPassModel) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
対象者自動パス設定情報を設定します。
setAutoPassFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス処理フラグを設定します。
setAutoPassFlag(boolean) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
自動パスフラグを設定します。
setAutoPassFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel のメソッド
自動パスフラグを設定します。
setAutoPassTerm(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
自動パス期限を設定します。
setBefActiCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティコードを設定します。
setBefActiName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理アクティビティ名を設定します。
setBefActiUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者CDを設定します。
setBefActiUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
前処理者名を設定します。
setCallActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティコードを設定します。
setCallActivityType(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
呼出アクティビティ種別を設定します。
setCallProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出案件コードを設定します。
setCallProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出しプロセス定義コードを設定します。
setCallVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼び出し履歴コードを設定します。
setCategoryCode(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
カテゴリコードを設定します。
setCode(String) - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
対象者コードを設定します。
setCodeValue(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
コード値を設定します。
setComment(String) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール本文を設定します。
setCompanyCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
会社コードを設定します。
setCompanyCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
会社コードを設定します。
setCompulsionEndFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
強制終了可否フラグを設定します。
setCompulsionEndFlag(boolean) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
途中終了フラグを設定します。
setCondition(Map) - class jp.co.intra_mart.foundation.wkf.support.SearchCondition のメソッド
検索条件を設定します。
setConditionType(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
分岐種別を設定します。
setContentsFrameType(String) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
コンテンツフレーム種別を設定します。
setContentsPath(String) - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
コンテンツパスを設定します。
setContentsPath(ContentsPathModel) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
コンテンツパス情報を設定します。
setCreateDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成日時を設定します。
setCreateDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
作成日時を設定します。
setCreateUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者コードを設定します。
setCreateUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
作成者コードを設定します。
setCreateUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
作成者名を設定します。
setCreateUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
作成者名を設定します。
setDemandReceiptCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付CDを設定します。
setDemandReceiptName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
依頼要求／受付名を設定します。
setDescending(String) - class jp.co.intra_mart.foundation.wkf.support.Sort のメソッド
降順ソートキーを設定します。
setDetailPath(ContentsPathDetailModel) - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
詳細コンテンツパスを設定します。
setDraftActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
起票処理コードを設定します。
setDraftCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
* 起票アクティビティコードを設定します。
setDraftComment(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票時コメントを設定します。
setDraftDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票日を設定します。
setDraftUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者コードを設定します。
setDraftUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
起票者名を設定します。
setDynamicTaskFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
動的承認者フラグを設定します。
setEffctiveDate(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
有効日付を設定します。
setEffectiveDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
有効日付を設定します。
setEndDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
終了日付を設定します。
setEndDate(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
終了日付を設定します。
setEndTaskFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
終了タスクフラグを設定します。
setEndTaskProgram(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
END時実行クラスを設定します。
setExtensionA(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＡを設定します。
setExtensionB(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＢを設定します。
setExtensionC(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＣを設定します。
setExtensionD(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＤを設定します。
setExtensionE(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＥを設定します。
setExtensionF(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＦを設定します。
setExtensionG(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＧを設定します。
setExtensionH(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
拡張エリアＨを設定します。
setExtensionNameA(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ａを設定します。
setExtensionNameB(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｂを設定します。
setExtensionNameC(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｃを設定します。
setExtensionNameD(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｄを設定します。
setExtensionNameE(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｅを設定します。
setExtensionNameF(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｆを設定します。
setExtensionNameG(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｇを設定します。
setExtensionNameH(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
拡張定義名Ｈを設定します。
setGroupCd(String) - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
対象者グループコードを設定します。
setGroupName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
グループ名を設定します。
setLastManualActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動処理コードを設定します。
setLastManualActivityResult(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終手動処理コードを設定します。
setLocaleId(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者ロケールIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログイングループIDを設定します。
setLoginGroupID(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイングループIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログインユーザIDを設定します。
setLoginUserID(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイングループIDを設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic のメソッド
ユーザ情報設定メソッド
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ログイン情報を設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ログイン情報を設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ログイン情報を設定します。
setLoginUserInfo(UserInfo) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
ログイン情報を設定します。
setMailPostponement(String) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
催促猶予日数を設定します。
setMailSendFlag(boolean) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
催促メール使用フラグを設定します。
setMailTamplate(HashMap) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メールテンプレートの設定を行います。
setNarrowPostCd(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
絞り込み役職コードを設定します。
setNarrowPostCd(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
絞り込み役職コードを設定します。
setNarrowPostCd(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
絞り込み役職コードを設定します。
setNarrowPostCd(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
絞り込み役職コードを設定します。
setNarrowPostCd(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
絞り込み役職コードを設定します。
setNarrowPostName(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
絞り込み役職名を設定します。
setNarrowPostName(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
絞り込み役職名を設定します。
setNarrowPostName(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
絞り込み役職名を設定します。
setNarrowPostName(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
絞り込み役職名を設定します。
setNote(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
備考を設定します。
setNoticeMailFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理元メール通知フラグを設定します。
setNoticeMailFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
代理元メール通知フラグを設定します。
setPageKind(String) - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
ページ種別を設定します。
setPairNo(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
ペアNOを設定します。
setParallelNestCnt(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期処理階層カウンタを設定します。
setPostCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コードを設定します。
setPostCdKind(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel のメソッド
役職コード種別を設定します。
setPostProcessingFlag(boolean) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
後処理使用フラグを設定します。
setPostProcessingProgram(String) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
後処理クラス名を設定します。
setPostRestrict(String) - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
役職絞込みコードを設定します。
setPreActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機アクティビティコードを設定します。
setPreApprovalType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
前承認種別を設定します。
setPreProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセスコードを設定します。
setPreProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機プロセス定義コードを設定します。
setPreVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
処理契機履歴コードを設定します。
setPresentDisplayInfo(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
現処理表示情報を設定します。
setPresentProcess(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
現処理を設定します。
setProcessCallActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
呼出処理コードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とするプロセスコードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
検索条件とするプロセスコードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセスコードを設定します。
setProcessCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
プロセスコードを設定します。
setProcessClassCode(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス種別コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とするプロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
検索条件とするプロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
プロセス定義コードを設定します。
setProcessDefCd(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
プロセス定義コードを設定します。
setProcessDefName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義名を設定します。
setProcessDefName(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
プロセス定義名を設定します。
setProcessDefNote(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
プロセス定義備考を設定します。
setProcessEndStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
完了プロセスステータスを設定します。
setProcessName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセス名を設定します。
setProcessName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス名(サブプロセス申請用)を設定します。
setProcessNestCnt(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
サブプロセス呼出カウンタを設定します。
setProcessStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
プロセスステータスを設定します。
setProcessTermDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とするプロセスコードを設定します。
setProcessingStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理状態識別を設定します。
setPullPath(ContentsPathDetailModel) - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
引戻しコンテンツパスを設定します。
setReceiveComment(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
承認時コメントを設定します。
setReceptionDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
受信日付をを設定します。
setRecognitionStatus(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
承認ステータスを設定します。
setRecordDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新日時を設定します。
setRecordDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新日時を設定します。
setRecordUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者コードを設定します。
setRecordUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新者コードを設定します。
setRecordUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
最終更新者名を設定します。
setRecordUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
最終更新者名を設定します。
setReferPath(ContentsPathDetailModel) - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
参照コンテンツパスを設定します。
setRepresentationType(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
代理コード種別を設定します。
setRequiredTerm(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
所要日数を設定します。
setReserveInfo(ArrayList) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
送信メール情報を設定します。
setReturnFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しフラグを設定します。
setReturnFlag(boolean) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
差し戻し/引き戻しフラグを設定します。
setReturnHistoryCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
差し戻し履歴コードを設定します。
setReturnMailFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
引戻し・差戻しメール送信フラグ設定します。
setReturnMailFlag(boolean) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
差し戻しメールフラグを設定します。
setReturnPath(ContentsPathDetailModel) - class jp.co.intra_mart.foundation.wkf.ContentsPathModel のメソッド
差戻しコンテンツパスを設定します。
setRoleRestrict(String) - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
ロール絞込みIDを設定します。
setRollSelectFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
ロール絞込み指定フラグを設定します。
setRouteInfoModel(RouteInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
申請者/承認者ルート作成-ルート情報設定します。
setRunExecuteInfoModel(RunExecutiveInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行時選択時実行主体役職マスタテーブルを設定します。
setRunSelectFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
実行時選択フラグを設定します。
setRunUserInfoModel(RunUserInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
実行時選択時実行主体ユーザマスタ情報を設定します。
setSelectRouteNo(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
選択ルート番を設定します。
setSelectRouteNo(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
選択ルート番号を設定します。
setSendMailFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
メール通知フラグを設定します。
setServiceId(String) - class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel のメソッド
サービスIDを設定します。
setShortestEndFlag(boolean) - class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel のメソッド
必須選択最終タスクフラグを設定します。
setStartActivityCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
開始処理コードを設定します。
setStatusEndedDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
ステータス完了日付を設定します。
setStopMail(String) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
停止対象となるテンプレートメール情報を保持します。
setSubProcessFlag(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
サブプロセス識別フラグを設定します。
setSubRecognitionFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理元承認可否フラグを設定します。
setSyncronizedInfo(SyncronizedInfo) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
同期情報を設定します。
setTamplateRequest(String) - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
メールテンプレートの設定を行います。
setTargetCd(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
対象者コードを設定します。
setTargetGroupCd(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
対象者グループコードを設定します。
setTargetMasterDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
対象マスタ日付を設定します。
setTargetMasterDate(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
対象指定日を設定します。
setTargetType(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel のメソッド
対象者種別を設定します。
setTitle(String) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメールタイトルを設定します。
setTransactorCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者コードを設定します。
setTransactorName(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
処理者名を設定します。
setTransferActivityFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
タスク委譲フラグを設定します。
setTransferActivityFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
タスク委譲フラグを設定します。
setTransferCd(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先コードを設定します。
setTransferCd(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先コードを設定します。
setTransferCd(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先コードを設定します。
setTransferCd(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先コードを設定します。
setTransferCdType(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先種別を設定します。
setTransferCdType(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先種別を設定します。
setTransferCdType(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先種別を設定します。
setTransferCdType(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先種別を設定します。
setTransferComment(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理コメントを設定します。
setTransferEndDate(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理期間(終了日)を設定します。
setTransferEndDate(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理期間(終了日)を設定します。
setTransferEndDate(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理期間(終了日)を設定します。
setTransferEndDate(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理期間(終了日)を設定します。
setTransferFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
代理フラグを設定します。
setTransferFlg(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
代理フラグを設定します。
setTransferGroupCd(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先グループコードを設定します。
setTransferGroupCd(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先グループコードを設定します。
setTransferGroupCd(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先グループコードを設定します。
setTransferGroupCd(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先グループコードを設定します。
setTransferInfoModel(TransferTableInfoModel) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
処理委譲情報を設定します。
setTransferName(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理依頼先名を設定します。
setTransferName(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理依頼先名を設定します。
setTransferName(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理依頼先名を設定します。
setTransferName(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理依頼先名を設定します。
setTransferStartDate(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理期間(開始日)を設定します。
setTransferStartDate(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理期間(開始日)を設定します。
setTransferStartDate(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理期間(開始日)を設定します。
setTransferStartDate(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理期間(開始日)を設定します。
setTransferStatus(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
代理設定種別を設定します。
setTransferStatus(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
代理設定種別を設定します。
setTransferStatus(String) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
代理設定種別を設定します。
setTransferStatus(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
代理設定種別を設定します。
setTransferUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザCDを設定します。
setTransferUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
振替先ユーザ名を設定します。
setTransferVersionFlag(boolean) - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のメソッド
バージョン委譲フラグを設定します。
setType(String) - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のメソッド
対象者種別を設定します。
setUserApplikeyList(Map) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
ユーザアプリケーションキーテーブル情報リストを設定します。
setUserCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザコードを設定します。
setUserList(ArrayList) - class jp.co.intra_mart.foundation.wkf.NegoModel のメソッド
根回しメール送信者リストを設定します。
setUserName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel のメソッド
ユーザ名を設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel のメソッド
検索条件とする履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel のメソッド
検索条件とする履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴コードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel のメソッド
バージョンコードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のメソッド
バージョンコードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のメソッド
バージョンコードを設定します。
setVersionCd(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
バージョンコードを設定します。
setVersionName(String) - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel のメソッド
プロセス定義（履歴名）を設定します。
setVersionName(String) - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のメソッド
履歴名を設定します。
setVersionName(String) - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のメソッド
バージョン名を設定します。
stopCancel() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
テンプレートメールの送信停止を取り止めます。
stopRequest() - class jp.co.intra_mart.system.bpw.WfeResultMailManager の static メソッド
同一スレッド内のテンプレートメールの標準送信を停止させます。
subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunExecutiveInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
推奨されていません。 subProcessDraft メソッドを使用してください。
subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunExecutiveInfoModel, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunUserInfoModel, String) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
推奨されていません。 subProcessDraft メソッドを使用してください。
subProcessDraft(String, String, String, String, String, String, List, String, String, String, NegoModel, RunUserInfoModel, String, CreateRouteInfoModel) - class jp.co.intra_mart.foundation.wkf.Drafter のメソッド
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
suspend(String, String, String, String, String, String, String, NegoModel) - class jp.co.intra_mart.foundation.wkf.Approver のメソッド
保留処理を実行します。

T

TARGET_AUTOPASS - class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel の static 変数
承認種別：対象者自動パス
TARGET_TYPE_ATTACH_ORGN - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：所属組織
TARGET_TYPE_DRAFTER - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：申請者
TARGET_TYPE_EXECUTIVE - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：実行時選択
TARGET_TYPE_HIGH_ORGN - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：上位組織
TARGET_TYPE_OFFICIAL - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel の static 変数
対象者種別：オフィシャルグループ
TARGET_TYPE_OFFICIAL - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：パブリックグループ
TARGET_TYPE_ORGN - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel の static 変数
対象者種別：組織
TARGET_TYPE_ORGN - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：組織
TARGET_TYPE_ROLE - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：ロール
TARGET_TYPE_SUB - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：処理者定義
TARGET_TYPE_USER - class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel の static 変数
対象者種別：ユーザ
TARGET_TYPE_USER - class jp.co.intra_mart.foundation.wkf.TargetInfoModel の static 変数
対象者種別：ユーザ
TRANSFER_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
代理承認者なし
TRANSFER_OFF - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の static 変数
申請者(申請者)
TRANSFER_ON - class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel の static 変数
代理承認者あり
TRANSFER_ON - class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel の static 変数
申請者(代理申請者)
TYPE_DELEGATE - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認対象種別コード：振替
TYPE_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認対象種別コード：本人
TYPE_SAID_PERSON - class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel の static 変数
承認対象種別コード：代理
TargetAutoPassModel - class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel.
対象者自動パス設定情報を保持するクラス
TargetAutoPassModel() - class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel のコンストラクタ
コンストラクタ
TargetInfoModel - class jp.co.intra_mart.foundation.wkf.TargetInfoModel.
対象者情報を保持するクラス
TargetInfoModel() - class jp.co.intra_mart.foundation.wkf.TargetInfoModel のコンストラクタ
コンストラクタ
TaskInfo - class jp.co.intra_mart.foundation.wkf.TaskInfo.
タスク情報関連のAPI
タスク情報関連処理で使用されるクラスです。
TaskInfo(String, String) - class jp.co.intra_mart.foundation.wkf.TaskInfo のコンストラクタ
コンストラクタ
TransferActivityModel - class jp.co.intra_mart.foundation.wkf.TransferActivityModel.
TransferActivityModel() - class jp.co.intra_mart.foundation.wkf.TransferActivityModel のコンストラクタ
コンストラクタ
TransferInfoModel - class jp.co.intra_mart.foundation.wkf.TransferInfoModel.
TransferInfoModel() - class jp.co.intra_mart.foundation.wkf.TransferInfoModel のコンストラクタ
コンストラクタ
TransferProcessDefModel - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel.
TransferProcessDefModel() - class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel のコンストラクタ
コンストラクタ
TransferVersionModel - class jp.co.intra_mart.foundation.wkf.TransferVersionModel.
TransferVersionModel() - class jp.co.intra_mart.foundation.wkf.TransferVersionModel のコンストラクタ

U

Util - class jp.co.intra_mart.foundation.wkf.Util.
ユーティリティ バッチ起動用クラス
Util(String) - class jp.co.intra_mart.foundation.wkf.Util のコンストラクタ
コンストラクタ

V

VERSION_CD - class jp.co.intra_mart.foundation.wkf.support.SearchCondition の static 変数
バージョンコードキー
VersionInfoModel - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel.
履歴情報を保持する情報クラス
VersionInfoModel() - class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel のコンストラクタ
コンストラクタ

W

WFK_C_NOT_TEMPLATE_PATH - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたメールテンプレートが不正です。
WKFApplicationException - exception jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException.
ＢＰＷのアプリケーション例外クラス
WKFApplicationException() - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
コンストラクタ
WKFApplicationException(String) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコードを保持した例外を生成します。
WKFApplicationException(String, String) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコードと詳細メッセージを保持した例外を生成します。
WKFApplicationException(String, Throwable) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコードと例外の発生原因となる例外を保持した例外を生成します。
WKFApplicationException(String, String, Throwable) - class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException のコンストラクタ
エラーコード、詳細メッセージと例外の発生原因となる例外を保持した例外を生成します。
WKFErrorCodeIF - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF.
ＢＰＷで利用される例外エラーコードインタフェース定義
WKF_C_ALREADY_STATUS_COMPLETE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたタスクは既に承認されています。
WKF_C_APPROVAL_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
承認種別の取得に失敗しました。
WKF_C_ATTACHMENT_UNABLE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたタスクの添付ファイル機能が利用できません。
WKF_C_AUTO_PASS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パスの処理に失敗しました。
WKF_C_AUTO_PRESS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動催促の処理に失敗しました。
WKF_C_DATA_ACQUISITION_FAILURE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
データ取得に失敗しました。
WKF_C_DEPARTMENT_INFO_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
所属組織情報が不正です。
WKF_C_DRAFT_ACTIVITY_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票アクティビティコードの取得に失敗しました。
WKF_C_DRAFT_APPOINT_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票指定日の取得に失敗しました。
WKF_C_DUPLICATE_AUTO_PASS_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定された自動パス対象者コードが重複しています。
WKF_C_DUPLICATE_CREATE_ROUTE_TARGET_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセス内の同一タスクに複数の対象者情報を設定することは出来ません。
WKF_C_DUPLICATE_REFER_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定された参照者コードが重複しています。
WKF_C_DUPLICATE_RUN_USER_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定された対象者コードが重複しています。
WKF_C_IMPORT_INVALID_CREATE_ROUTE_PROCESS_DEF - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成情報のプロセス定義・バージョン情報が指定されていない、または不正です。
WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセスの対象アクティビティコードが指定されていない、または不正です。
WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセスの対象コードが指定されていない、または不正です。
WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_GROUP_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセスの対象グループコードが指定されていない、または不正です。
WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセスの対象者情報が指定されていない、または不正です。
WKF_C_IMPORT_INVALID_CREATE_ROUTE_TARGET_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセスの対象者種別が指定されていない、または不正です。
WKF_C_IMPORT_INVALID_NEXT_ACTIVITY_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート選択番号が指定されていない、または不正です。
WKF_C_IMPORT_INVALID_NEXT_ROUTE_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成情報が指定されていない、または不正です。
WKF_C_INPOSSIBLE_DRAFT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
申請イベントに失敗しました。
WKF_C_INPOSSIBLE_PULL_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
引き戻しイベントに失敗しました。
WKF_C_INPOSSIBLE_RECOGNITION_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
承認イベントに失敗しました。
WKF_C_INPOSSIBLE_RETURN_BEFORE_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
承認者への差し戻しイベントに失敗しました。
WKF_C_INPOSSIBLE_RETURN_START_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
申請者への差し戻しイベントに失敗しました。
WKF_C_INPOSSIBLE_RETURN_TASK_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
任意の処理者への差し戻しイベントに失敗しました。
WKF_C_INVALID_ACTIVITY_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
タスク詳細情報の指定が不正です。
WKF_C_INVALID_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
アクティビティ種別が不正です。
WKF_C_INVALID_AUTO_PASS_USER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パス対象者種別の指定が不正です。
WKF_C_INVALID_CONTENTS_FRAME_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
コンテンツフレーム種別の指定が不正です。
WKF_C_INVALID_DRAFT_TASK_DYNAMIC - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票タスクに動的承認者を設定することはできません。
WKF_C_INVALID_EFFECTIVE_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
開始日付が指定されていない、または不正です。
WKF_C_INVALID_END_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
終了日付の指定が不正です。
WKF_C_INVALID_OFFICIAL_RESTRICT - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象種別がオフィシャルグループの場合、役職絞込みコードを指定することはできません。
WKF_C_INVALID_ORGN_RESTRICT - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
役職絞込みコード･ロール絞込みコードの両方が同時に指定されています。
WKF_C_INVALID_PROCESS_CONTENTS_PATH - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセスコンテンツパスの指定が不正です。
WKF_C_INVALID_PROCESS_STATUS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定された案件を既に完了しています。
WKF_C_INVALID_REFER_USER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
参照者種別の指定が不正です。
WKF_C_INVALID_ROLE_RESTRICT - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象種別がロールの場合、絞り込みコードを指定することはできません。
WKF_C_INVALID_ROOT_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート情報の指定が不正です。
WKF_C_INVALID_RUN_USER_DYNAMIC - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者種別に動的承認者を指定した場合、同一タスクに複数の対象者を指定することはできません。
WKF_C_INVALID_RUN_USER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者情報の指定が不正です。
WKF_C_INVALID_RUN_USER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者種別の指定が不正です。
WKF_C_INVALID_TARGET_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたアクティビティは承認タスクではありません。
WKF_C_INVALID_TARGET_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者種別が不正
WKF_C_INVALID_TRANSFER_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理期間開始日が代理期間終了日より未来の日付になっています。
WKF_C_INVALID_TRANSFER_STATUS_ALL - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス定義コードに全てが指定されている場合はプロセス定義委譲以外行えません。
WKF_C_NOT_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
アクティビティ情報が存在しません。
WKF_C_NOT_ACTIVITY_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
タスク詳細情報が指定されていません。
WKF_C_NOT_ACTIVITY_NAME - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
タスク名が指定されていません。
WKF_C_NOT_ACTIVITY_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
タスク種別が設定されていません。
WKF_C_NOT_AGENT_SETTING - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定された代理設定は設定されていません。
WKF_C_NOT_APPLICATION_KEY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
アプリケーションキーが設定されていない、または不正です。
WKF_C_NOT_AUTHORITY_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたタスクが存在しない、または権限がない可能性があります。
WKF_C_NOT_AUTHORITY_CATEGORY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたカテゴリが存在しない、または権限がない可能性があります。
WKF_C_NOT_AUTHORITY_PROCESS_DEF - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたプロセス定義が存在しない、または権限がない可能性があります。
WKF_C_NOT_AUTO_PASS_TARGET - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パス対象者情報が指定されていません。
WKF_C_NOT_AUTO_PASS_USER_CODE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パス対象者コードが指定されていません。
WKF_C_NOT_AUTO_PASS_USER_GROUP_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パス対象者グループコードが指定されていません。
WKF_C_NOT_AUTO_PASS_USER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
自動パス対象者種別が指定されていません。
WKF_C_NOT_CATEGORY_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
カテゴリコードが指定されていません。
WKF_C_NOT_CREATE_ROUTE_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート作成プロセス情報の取得に失敗しました。
WKF_C_NOT_DEPARTMENT_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
所属組織情報の取得に失敗しました。
WKF_C_NOT_FOUND_LAST_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたプロセス定義の最終バージョンの取得に失敗しました。
WKF_C_NOT_FOUND_PROCESS_CONTENTS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたプロセス定義のプロセスコンテンツパス情報の取得に失敗しました。
WKF_C_NOT_MAIL_POSTPONEMENT - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
催促猶予日数が指定されていません。
WKF_C_NOT_PLURAL_APPROVER - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票タスク以外のタスクに複数対象者を設定することはできません。
WKF_C_NOT_POST_PROCESSING_PROGRAM - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
後処理クラス名が指定されていません。
WKF_C_NOT_PROCESS_CLASS_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス種別コードが指定されていません。
WKF_C_NOT_PROCESS_CONTENTS_PATH - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセスコンテンツパスが指定されていません。
WKF_C_NOT_PROCESS_DEF_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス定義コードが指定されていません。
WKF_C_NOT_PROCESS_DEF_NAME - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス定義名が指定されていません。
WKF_C_NOT_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス情報の取得に失敗しました。
WKF_C_NOT_RECEIVE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたタスクのタスクの対象者種別情報が取得できません。
WKF_C_NOT_REFER_USER_CODE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
参照者コードが指定されていません。
WKF_C_NOT_REFER_USER_GROUP_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
参照者グループコードが指定されていません。
WKF_C_NOT_REFER_USER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
参照者種別が指定されていません。
WKF_C_NOT_REGIST_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
起票タスクの対象者に指定されていない、または不正です。
WKF_C_NOT_ROOT_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
ルート情報が指定されていません。
WKF_C_NOT_RUN_USER_CODE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者コードが指定されていません。
WKF_C_NOT_RUN_USER_GROUP_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者グループコードが指定されていません。
WKF_C_NOT_RUN_USER_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者情報が指定されていません。
WKF_C_NOT_RUN_USER_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者種別が指定されていません。
WKF_C_NOT_TARGET_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたアクティビティは存在しない、または処理タスク以外のアクティビティである可能性があります。
WKF_C_NOT_TARGET_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者コードが指定されていません。
WKF_C_NOT_TARGET_GROUP_CD - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
対象者グループコードが指定されていません。
WKF_C_NOT_TARGET_NO_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定されたタスク番号のタスクは存在しません。
WKF_C_NOT_TRANSFER_ACTIVITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス定義コード・バージョンコード・アクティビティコードのいずれかが指定されていません。
WKF_C_NOT_TRANSFER_ATTACH_USER - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理先ユーザ/組織に設定された組織に所属するユーザが存在しない可能性があります。
WKF_C_NOT_TRANSFER_AUTHORITY - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
指定された代理依頼先ユーザは処理権限がない可能性があります。
WKF_C_NOT_TRANSFER_CODE_TYPE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理設定種別が指定されていない、または不正です。
WKF_C_NOT_TRANSFER_END_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理期間(終了日)が指定されていない、または不正です。
WKF_C_NOT_TRANSFER_PROCESS_DEF - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス定義コードが指定されていません。
WKF_C_NOT_TRANSFER_START_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理期間(開始日)が指定されていない、または不正です。
WKF_C_NOT_TRANSFER_TARGET_DATE - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理指定日付が指定されていない、または不正です。
WKF_C_NOT_TRANSFER_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス定義コード・バージョンコードのいずれかが指定されていません。
WKF_C_NOT_VERSION - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
履歴情報が存在しません。
WKF_C_PRAM_AGT_ALL - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
代理元ユーザが不正です。
WKF_C_PRAM_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
パラメータが不正です。
WKF_C_PROCESS_INFO - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセス情報の取得に失敗しました。
WKF_C_REMOVE_PROCESS - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
プロセスの削除に失敗しました。
WKF_C_SEND_MAIL - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
メール送信に失敗しました。
WKF_C_SYSTEM_ERROR - interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF の static 変数
システムエラーが発生しました。
WfeResultMailManager - class jp.co.intra_mart.system.bpw.WfeResultMailManager.
ワークフローエンジン内にて結果送信メール（テンプレート）の送信情報の管理保持を行う。
WfeResultMailManager() - class jp.co.intra_mart.system.bpw.WfeResultMailManager のコンストラクタ
A B C D E F G H I J L M N O P R S T U V W
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


bpw 6.1.14 API

フレーム関連の警告

このドキュメントはフレーム機能を使って表示するように作られています。フレームを表示できない Web クライアントの場合にこのメッセージが表示されます。
リンク先フレームなしのバージョン


概要 (bpw 6.1.14 API)

すべてのクラス

パッケージ
jp.co.intra_mart.foundation.bpw.exception
jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf
jp.co.intra_mart.foundation.wkf.support
jp.co.intra_mart.system.bpw


概要 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

intra-mart 6.1.14 Workflow API Specifications

パッケージ
jp.co.intra_mart.foundation.bpw.exception
jp.co.intra_mart.foundation.bpw.model.data
jp.co.intra_mart.foundation.bpw.model.object
jp.co.intra_mart.foundation.wkf
jp.co.intra_mart.foundation.wkf.support
jp.co.intra_mart.system.bpw

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス階層 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

すべてのパッケージの階層

パッケージ階層:
jp.co.intra_mart.foundation.bpw.exception, jp.co.intra_mart.foundation.bpw.model.data, jp.co.intra_mart.foundation.bpw.model.object, jp.co.intra_mart.foundation.wkf, jp.co.intra_mart.foundation.wkf.support, jp.co.intra_mart.system.bpw

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable, java.io.Serializable)
    • class jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel (implements java.io.Serializable)
      • class jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.io.Serializable)
    • class jp.co.intra_mart.foundation.wkf.ActivityTaskModel
      • class jp.co.intra_mart.foundation.wkf.ReceiveTaskModel
    • class jp.co.intra_mart.foundation.wkf.AgentSetting
    • class jp.co.intra_mart.foundation.wkf.Approver
    • class jp.co.intra_mart.foundation.bpw.model.data.BPWExecuteLogic
    • class jp.co.intra_mart.foundation.bpw.model.data.Condition
      • class jp.co.intra_mart.foundation.bpw.model.data.ConditionAdapter
    • class jp.co.intra_mart.foundation.wkf.ContentsPathDetailModel
    • class jp.co.intra_mart.foundation.wkf.ContentsPathModel
    • class jp.co.intra_mart.foundation.wkf.CreateRouteInfoModel
    • class jp.co.intra_mart.foundation.wkf.CreateRouteTargetInfoModel
    • class jp.co.intra_mart.foundation.wkf.Drafter
    • class jp.co.intra_mart.foundation.bpw.model.object.ExternalModel
      • class jp.co.intra_mart.foundation.bpw.model.object.ConditionModel
    • class jp.co.intra_mart.foundation.wkf.FlowInfo
    • class jp.co.intra_mart.foundation.wkf.Manager
    • class jp.co.intra_mart.foundation.wkf.NegoModel
    • class jp.co.intra_mart.foundation.wkf.Process
    • class jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF, java.lang.Cloneable)
    • class jp.co.intra_mart.foundation.bpw.model.object.RecognitionInfoModel
    • class jp.co.intra_mart.foundation.wkf.Reference
    • class jp.co.intra_mart.foundation.wkf.support.SearchCondition
    • class jp.co.intra_mart.foundation.wkf.support.Sort
    • class jp.co.intra_mart.foundation.wkf.TargetAutoPassModel
    • class jp.co.intra_mart.foundation.wkf.TargetInfoModel
    • class jp.co.intra_mart.foundation.wkf.TaskInfo
    • class java.lang.Throwable (implements java.io.Serializable)
      • class java.lang.Exception
        • class jp.co.intra_mart.framework.system.exception.FrameworkException
          • class jp.co.intra_mart.framework.system.exception.ApplicationException
            • class jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException
    • class jp.co.intra_mart.foundation.wkf.TransferActivityModel
    • class jp.co.intra_mart.foundation.wkf.TransferInfoModel
    • class jp.co.intra_mart.foundation.wkf.TransferProcessDefModel
    • class jp.co.intra_mart.foundation.wkf.TransferVersionModel
    • class jp.co.intra_mart.foundation.wkf.Util
    • class jp.co.intra_mart.foundation.bpw.model.object.VersionInfoModel (implements jp.co.intra_mart.foundation.bpw.model.object.BPWModelIF)
    • class jp.co.intra_mart.system.bpw.WfeResultMailManager

インタフェース階層

  • interface jp.co.intra_mart.foundation.bpw.exception.BPWErrorCodeIF
  • interface jp.co.intra_mart.foundation.bpw.model.data.EISModelStaticIF
  • interface jp.co.intra_mart.foundation.bpw.exception.WKFErrorCodeIF
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


(bpw 6.1.14 API)

フロントページが変更されました。次を参照してください:
フレームありのバージョン
フレームなしのバージョン


直列化された形式 (bpw 6.1.14 API)

前 次 フレームあり フレームなし

直列化された形式

パッケージ jp.co.intra_mart.foundation.bpw.exception

クラス jp.co.intra_mart.foundation.bpw.exception.BPWApplicationException は jp.co.intra_mart.framework.system.exception.ApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

errorCode

String errorCode

クラス jp.co.intra_mart.foundation.bpw.exception.BPWProcessDefException は jp.co.intra_mart.foundation.bpw.exception.BPWApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

processDefName

String processDefName

クラス jp.co.intra_mart.foundation.bpw.exception.WKFApplicationException は jp.co.intra_mart.framework.system.exception.ApplicationException を拡張し、Serializable を実装しています

直列化されたフィールド

errorCode

String errorCode
例外内容を特定する為のエラーコード

パッケージ jp.co.intra_mart.foundation.bpw.model.data

クラス jp.co.intra_mart.foundation.bpw.model.data.RootInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

parent

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel parent

childList

ArrayList childList

クラス jp.co.intra_mart.foundation.bpw.model.data.RouteDetailInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

dynamicTask

boolean dynamicTask

indispensable

boolean indispensable

displayTask

String displayTask

displayModel

ActivityInfoModel displayModel

クラス jp.co.intra_mart.foundation.bpw.model.data.RouteInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

detailMap

Map detailMap

displaySize

Point displaySize

displayInfo

ArrayList displayInfo

activityMap

Map activityMap

rootInfo

jp.co.intra_mart.foundation.bpw.model.data.RootInfoModel rootInfo

pullActivityFlag

boolean pullActivityFlag

draftCreateRootFlag

boolean draftCreateRootFlag

draftHistoryModel

jp.co.intra_mart.foundation.bpw.model.object.DraftRootHistoryInfoModel draftHistoryModel

draftDetailList

jp.co.intra_mart.foundation.bpw.model.object.DraftRootDetailListModel draftDetailList

processDefCd

String processDefCd

versionCd

String versionCd

processCd

String processCd

parentProcessCd

String parentProcessCd

パッケージ jp.co.intra_mart.foundation.bpw.model.object

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityCoreListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityName

Object activityName

activityType

Object activityType

activityStatus

Object activityStatus

statusEndedDate

Object statusEndedDate

callActivityCd

Object callActivityCd

callActivityType

Object callActivityType

autoPassTerm

Object autoPassTerm

autoPassFlag

Object autoPassFlag

attainmentClass

Object attainmentClass

receptionDate

Object receptionDate

processTermDate

Object processTermDate

presentProcess

Object presentProcess

befActiCd

Object befActiCd

befActiName

Object befActiName

befActiUserCd

Object befActiUserCd

befActiUserName

Object befActiUserName

compulsionEndFlag

Object compulsionEndFlag

returnMailFlag

Object returnMailFlag

returnFlag

Object returnFlag

preProcessDefCd

Object preProcessDefCd

preVersionCd

Object preVersionCd

preProcessCd

Object preProcessCd

preActivityCd

Object preActivityCd

endTaskFlag

Object endTaskFlag

selectRouteNo

Object selectRouteNo

endTaskProgram

Object endTaskProgram

conditionType

Object conditionType

returnHistoryCd

Object returnHistoryCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoAcknowledgeViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

otherAgentFlag

String otherAgentFlag

myAgentFlag

String myAgentFlag

transferUserCd

String transferUserCd

transferCdType

String transferCdType

approvalObject

String approvalObject

runActivityCd

String runActivityCd

hasNextUserFlag

String hasNextUserFlag

nextFlowType

String nextFlowType

demandUserCd

String demandUserCd

demandUserName

String demandUserName

approvalRightType

String approvalRightType

nextAttainmentClass

String nextAttainmentClass

contentsFrameType

String contentsFrameType

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityKey activityKey
アクティビティＫｅｙ

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityData activityData
アクティビティＤａｔａ

runuserlist

ArrayList runuserlist
実行主体ユーザ情報

receivelist

ArrayList receivelist
レシーブ情報

autopasslist

ArrayList autopasslist
自動パス情報

runSelectFlg

String runSelectFlg
実行時選択フラグ

userApplikeyList

Map userApplikeyList
ユーザアプリケーションキーテーブル情報リスト

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo
ログインユーザ情報

loginUserID

String loginUserID
ログインユーザID

loginGroupID

String loginGroupID
ログイングループID

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityKey activityKey

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityData activityData

cotentsMasterList

ArrayList cotentsMasterList

userApplikeyList

Map userApplikeyList

receiveTableList

ArrayList receiveTableList

myTransferTableList

ArrayList myTransferTableList

otherTransferedTableList

ArrayList otherTransferedTableList

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

referAuthFlg

String referAuthFlg

searchCount

int searchCount

transferFlg

String transferFlg

otherTransferFlg

String otherTransferFlg

pullActivityFlg

String pullActivityFlg

returnActivityFlg

String returnActivityFlg

runSelectFlg

String runSelectFlg

existRunUserFlg

String existRunUserFlg

myTransferRunTableList

ArrayList myTransferRunTableList

otherTransferedRunTableList

ArrayList otherTransferedRunTableList

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

otherAgentFlag

String otherAgentFlag

myAgentFlag

String myAgentFlag

transferUserCd

String transferUserCd

transferCdType

String transferCdType

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityKey は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

Object processDefCd

versionCd

Object versionCd

processCd

Object processCd

activityCd

Object activityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityName

Object activityName

activityTypeCd

Object activityTypeCd

runReferTypeCd

Object runReferTypeCd

autoPassTerm

Object autoPassTerm

autoPassFlag

Object autoPassFlag

compulsionEndFlag

Object compulsionEndFlag

returnMailFlag

Object returnMailFlag

returnFlag

Object returnFlag

shortestEndFlag

Object shortestEndFlag

endTaskProgram

Object endTaskProgram

conditionType

Object conditionType

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterKey activityKey

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

referList

ArrayList referList

runUserList

ArrayList runUserList

runExecutiveList

ArrayList runExecutiveList

autoPassList

ArrayList autoPassList

autoPassExecutiveList

ArrayList autoPassExecutiveList

contentsList

ArrayList contentsList

receiveInfoModel

jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel receiveInfoModel

sequenceInnerList

ArrayList sequenceInnerList

flowInnerList

ArrayList flowInnerList

switchList

ArrayList switchList

routeSelectList

ArrayList routeSelectList

processAdapterInfoModel

jp.co.intra_mart.foundation.bpw.model.object.ProcessAdapterInfoModel processAdapterInfoModel

executeAdapterInfoModel

jp.co.intra_mart.foundation.bpw.model.object.ExecuteAdapterInfoModel executeAdapterInfoModel

eventAdapterInfoModel

jp.co.intra_mart.foundation.bpw.model.object.EventAdapterInfoModel eventAdapterInfoModel

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoResult は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterKey activityKey

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

myTransferTableList

ArrayList myTransferTableList

otherTransferedTableList

ArrayList otherTransferedTableList

cotentsMasterList

ArrayList cotentsMasterList

receiveMasterList

ArrayList receiveMasterList

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterKey は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

Object processDefCd

versionCd

Object versionCd

activityCd

Object activityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterUnitModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

activityData

jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterData activityData

userApplikeyList

Map userApplikeyList

targetUserCd

String targetUserCd

クラス jp.co.intra_mart.foundation.bpw.model.object.AgentSettingListInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

transferModel

jp.co.intra_mart.foundation.bpw.model.object.TransferTableViewModel transferModel

dynamicFlg

String dynamicFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.AgentSettingListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.AuthorityInfoResult は Object を拡張し、Serializable を実装しています

直列化されたフィールド

groupingCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult groupingCd

authorityFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult authorityFlag

groupingName

String groupingName

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassExecutiveInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

postCd

String postCd

postCdKind

String postCdKind

pairNo

String pairNo

companyCd

String companyCd

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassExecutiveListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

String processCd

userCd

String userCd

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

String userCd

userName

String userName

processCd

String processCd

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

authorityFlg

String authorityFlg

loginUserID

String loginUserID

loginGroupID

String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.AutoPassListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.BPWFieldFunctionResult は Object を拡張し、Serializable を実装しています

直列化されたフィールド

count

String count

maximum

String maximum

minimum

String minimum

sumTotal

String sumTotal

average

String average

クラス jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult は Object を拡張し、Serializable を実装しています

直列化されたフィールド

value

String value

function

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldFunctionResult function

クラス jp.co.intra_mart.foundation.bpw.model.object.BPWSendMailInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

templateKey

String templateKey

sendTo

ArrayList sendTo

from

String from

subject

String subject

body

String body

sendCc

ArrayList sendCc

sendBcc

ArrayList sendBcc

replyTo

String replyTo

mailLocale

Locale mailLocale

クラス jp.co.intra_mart.foundation.bpw.model.object.CategoryInfoResult は Object を拡張し、Serializable を実装しています

直列化されたフィールド

categoryCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult categoryCd

categoryName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult categoryName

categoryNote

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult categoryNote

invalidFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult invalidFlag

createDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createDate

createUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserCd

createUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserName

recordDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordDate

recordUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserCd

recordUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserName

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

authlist

ArrayList authlist

クラス jp.co.intra_mart.foundation.bpw.model.object.CategoryListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ConsentedInfoViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

approvalType

String approvalType

approvalRightType

String approvalRightType

recognitionStatus

String recognitionStatus

approvalUserCd

String approvalUserCd

agentUserCd

String agentUserCd

approvalComment

String approvalComment

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

String contentsType

pageKind

String pageKind

contentsPath

String contentsPath

applicationId

String applicationId

serviceId

String serviceId

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsInfoSelectKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

String contentsType

pageKind

String pageKind

contentsPath

String contentsPath

applicationId

String applicationId

serviceId

String serviceId

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

authorityFlg

String authorityFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ContentsSelectListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DeleteAllProcessListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DispFlowInfoTaskInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

taskWidth

int taskWidth

taskHeight

int taskHeight

frameColor

Color frameColor

taskName

String taskName

imageIcon

BufferedImage imageIcon

taskDisposer

List taskDisposer

クラス jp.co.intra_mart.foundation.bpw.model.object.DisplayItemListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootDetailInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

rootCd

String rootCd

selectedCodeKind

String selectedCodeKind

selectedUserCd

String selectedUserCd

pairNo

String pairNo

userInfo

jp.co.intra_mart.framework.base.util.UserInfo userInfo

companyCd

String companyCd

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootDetailListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootHistoryInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

String processDefCd

versionCd

String versionCd

rootCd

String rootCd

userCd

String userCd

rootName

String rootName

recordDate

String recordDate

userInfo

jp.co.intra_mart.framework.base.util.UserInfo userInfo

クラス jp.co.intra_mart.foundation.bpw.model.object.DraftRootHistoryListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.EventAdapterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

serviceId

String serviceId

クラス jp.co.intra_mart.foundation.bpw.model.object.EventAdapterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ExecuteAdapterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

runClass

String runClass

クラス jp.co.intra_mart.foundation.bpw.model.object.ExecuteAdapterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.FlowInnerInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

runId

String runId

runActivityCd

String runActivityCd

conditionClass

String conditionClass

クラス jp.co.intra_mart.foundation.bpw.model.object.FlowInnerListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.HistoryTableInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

callProcessCd

String callProcessCd

ackHistoryCd

String ackHistoryCd

processDefCd

String processDefCd

versionCd

String versionCd

processCd

String processCd

activityCd

String activityCd

approvalType

String approvalType

approvalUserCd

String approvalUserCd

approvalUserName

String approvalUserName

companyCd

String companyCd

approvalGroupCd

String approvalGroupCd

approvalGroupName

String approvalGroupName

affiliationFlag

String affiliationFlag

approvalDate

String approvalDate

approvalComment

String approvalComment

agentTranFlag

String agentTranFlag

agentTranUserCd

String agentTranUserCd

agentTranUserName

String agentTranUserName

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.HistoryTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

callProcessCd

String callProcessCd

ackHistoryCd

String ackHistoryCd

processDefCd

String processDefCd

versionCd

String versionCd

processCd

String processCd

activityCd

String activityCd

approvalType

String approvalType

approvalUserCd

String approvalUserCd

approvalUserName

String approvalUserName

companyCd

String companyCd

approvalGroupCd

String approvalGroupCd

approvalGroupName

String approvalGroupName

affiliationFlag

String affiliationFlag

approvalDate

String approvalDate

approvalComment

String approvalComment

agentTranFlag

String agentTranFlag

agentTranUserCd

String agentTranUserCd

agentTranUserName

String agentTranUserName

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

activityName

String activityName

processDefName

String processDefName

クラス jp.co.intra_mart.foundation.bpw.model.object.HistoryTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.LinkInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

linkActivityCd

String linkActivityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.LinkListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ListModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

count

int count

list

ArrayList list

クラス jp.co.intra_mart.foundation.bpw.model.object.MonitoringCountInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

completeCount

int completeCount

normalCount

int normalCount

compulsionCount

int compulsionCount

cancelCount

int cancelCount

rejectionCount

int rejectionCount

completeAvrReqTerm

String completeAvrReqTerm

normalAvrReqTerm

String normalAvrReqTerm

compulsionAvrReqTerm

String compulsionAvrReqTerm

cancelAvrReqTerm

String cancelAvrReqTerm

rejectionAvrReqTerm

String rejectionAvrReqTerm

activeCount

int activeCount

totalCount

int totalCount

クラス jp.co.intra_mart.foundation.bpw.model.object.MonitoringTableInfoKey は Object を拡張し、Serializable を実装しています

直列化されたフィールド

trnHistoryCd

String trnHistoryCd

processDefCd

String processDefCd

versionCd

String versionCd

processCd

String processCd

activityCd

String activityCd

draftDate

String draftDate

targetMasterDate

String targetMasterDate

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

クラス jp.co.intra_mart.foundation.bpw.model.object.MonitoringTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.MonitoringTableInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

activityName

String activityName

receptionDate

String receptionDate

requiredTerm

String requiredTerm

approvalType

String approvalType

trnUserCd

String trnUserCd

trnUserName

String trnUserName

trnCompanyCd

String trnCompanyCd

trnGroupCd

String trnGroupCd

trnGroupName

String trnGroupName

transactionDate

String transactionDate

agentTranFlag

String agentTranFlag

agentTranUserCd

String agentTranUserCd

agentTranUserName

String agentTranUserName

timeLimitExcessFlag

String timeLimitExcessFlag

クラス jp.co.intra_mart.foundation.bpw.model.object.NegoTemplateModelObject は Object を拡張し、Serializable を実装しています

直列化されたフィールド

fieldMap

Map fieldMap

tableName

String tableName

modelName

String modelName

PKMap

Map PKMap

クラス jp.co.intra_mart.foundation.bpw.model.object.NewlyArrivalTaskListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

直列化されたフィールド

versionCd

String versionCd

processDefCd

String processDefCd

processDefName

String processDefName

categoryCode

String categoryCode

categoryName

String categoryName

regist_type

String regist_type

groupName

String groupName

draftUserName

String draftUserName

draftDate

String draftDate

demandReceiptCd

String demandReceiptCd

demandReceiptName

String demandReceiptName

process_Term_Date

String process_Term_Date

attainmentClass

String attainmentClass

receptionDate

String receptionDate

processClassCode

String processClassCode

processCode

String processCode

processName

String processName

processStatus

String processStatus

activityCd

String activityCd

approvalTypeCd

String approvalTypeCd

approvalRightType

String approvalRightType

draftActivityCd

String draftActivityCd

callProcessCd

String callProcessCd

activityStatus

String activityStatus

approval_User_Cd

String approval_User_Cd

myTransferFlag

String myTransferFlag

クラス jp.co.intra_mart.foundation.bpw.model.object.NotCompletedInfoViewResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

approvalRightType

String approvalRightType

approvalUserCd

String approvalUserCd

demandReceiptCd

String demandReceiptCd

demandReceiptName

String demandReceiptName

クラス jp.co.intra_mart.foundation.bpw.model.object.NotCompletedListModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityListModel を拡張し、Serializable を実装しています

直列化されたフィールド

page

String page

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessAdapterInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

callProcessDefCd

String callProcessDefCd

endRejectionFlg

String endRejectionFlg

endCompulsionFlg

String endCompulsionFlg

draftTypeKind

String draftTypeKind

processClassCode

String processClassCode

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessAdapterListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsInfoModel は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

String contentsType

pageKind

String pageKind

contentsPath

String contentsPath

applicationId

String applicationId

serviceId

String serviceId

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsInfoSelectKey は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

contentsType

String contentsType

pageKind

String pageKind

contentsPath

String contentsPath

applicationId

String applicationId

serviceId

String serviceId

loginUserId

String loginUserId

loginGroupId

String loginGroupId

authorityFlg

String authorityFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessContentsSelectListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessData は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processName

Object processName

draftDate

Object draftDate

draftUserCd

Object draftUserCd

draftUserName

Object draftUserName

draftComment

Object draftComment

companyCd

Object companyCd

applyCompanyCd

Object applyCompanyCd

applyCodeValue

Object applyCodeValue

codeValue

Object codeValue

groupName

Object groupName

targetMasterDate

Object targetMasterDate

transactorCd

Object transactorCd

transactorName

Object transactorName

localeId

Object localeId

processStatus

Object processStatus

processEndStatus

Object processEndStatus

requiredTerm

Object requiredTerm

lastManualActivityCd

Object lastManualActivityCd

lastManualActivityResult

Object lastManualActivityResult

callProcessDefCd

Object callProcessDefCd

callVersionCd

Object callVersionCd

callProcessCd

Object callProcessCd

processCallActivityCd

Object processCallActivityCd

processingStatus

Object processingStatus

processNestCnt

Object processNestCnt

parallelNestCnt

Object parallelNestCnt

presentDisplayInfo

Object presentDisplayInfo

extensionA

Object extensionA

extensionB

Object extensionB

extensionC

Object extensionC

extensionD

Object extensionD

extensionE

Object extensionE

extensionF

Object extensionF

extensionG

Object extensionG

extensionH

Object extensionH

createDate

Object createDate

createUserCd

Object createUserCd

createUserName

Object createUserName

recordDate

Object recordDate

recordUserCd

Object recordUserCd

recordUserName

Object recordUserName

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessDefInfoResult は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefCd

lastVersionCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult lastVersionCd

invalidFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult invalidFlag

createDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createDate

createUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserCd

createUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserName

recordDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordDate

recordUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserCd

recordUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserName

processDefName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefName

processDefNote

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefNote

categoryInfo

jp.co.intra_mart.foundation.bpw.model.object.CategoryInfoResult categoryInfo

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

versionName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult versionName

totalCount

int totalCount

activeCount

int activeCount

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessDefListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessInfoResult は jp.co.intra_mart.foundation.bpw.model.object.VersionInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

processKey

jp.co.intra_mart.foundation.bpw.model.object.ProcessKey processKey

processData

jp.co.intra_mart.foundation.bpw.model.object.ProcessData processData

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

processCotentsMasterList

ArrayList processCotentsMasterList

userApplikeyList

Map userApplikeyList

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessKey は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

Object processDefCd

versionCd

Object versionCd

processCd

Object processCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ProcessListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

mailSendFlag

String mailSendFlag

mailPostPonement

String mailPostPonement

mailToClassification

String mailToClassification

mailTitleDef

String mailTitleDef

mailContentsDef

String mailContentsDef

approvalObject

String approvalObject

runSelectActivityCd

String runSelectActivityCd

nextRouteType

String nextRouteType

contentsFrameType

String contentsFrameType

defaultContentsFrameFlg

String defaultContentsFrameFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoSelectKey は jp.co.intra_mart.foundation.bpw.model.object.ReceiveInfoModel を拡張し、Serializable を実装しています

直列化されたフィールド

loginGroupID

String loginGroupID

loginUserID

String loginUserID

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

String processCd

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

String processCd

rcvComment

String rcvComment

mailFlg

String mailFlg

userCd

String userCd

userName

String userName

approvalType

String approvalType

transferFlg

String transferFlg

delegateFlg

String delegateFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.ReceiveTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.ReferInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

codeKind

String codeKind

userCd

String userCd

pairNo

String pairNo

companyCd

String companyCd

クラス jp.co.intra_mart.foundation.bpw.model.object.RouteSelectInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

selectRouteNo

String selectRouteNo

selectRouteName

String selectRouteName

selectRouteCd

String selectRouteCd

selectRouteType

String selectRouteType

adapterCd

String adapterCd

クラス jp.co.intra_mart.foundation.bpw.model.object.RouteSelectListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

postCd

String postCd
役職コード値

postCdKind

String postCdKind
役職コード種別

pairNo

String pairNo
ペアNO

companyCd

String companyCd
会社CD

クラス jp.co.intra_mart.foundation.bpw.model.object.RunExecutiveListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RunGroupInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

activityKey

jp.co.intra_mart.foundation.bpw.model.object.ActivityKey activityKey

userCd

String userCd

registType

String registType

companyCd

String companyCd

codeValue

String codeValue

approvalTypeCd

String approvalTypeCd

groupName

String groupName

affiliationFlag

String affiliationFlag

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

processCd

String processCd

userCd

String userCd

userName

String userName

demandReceiptCd

String demandReceiptCd

demandReceiptName

String demandReceiptName

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

approvalTypeCd

String approvalTypeCd

approvalRightType

String approvalRightType

representationType

String representationType

transferUserCd

String transferUserCd

transferUserName

String transferUserName

recognitionStatus

String recognitionStatus

noticeMailFlg

String noticeMailFlg

クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

String userCd
ユーザコード

userName

String userName
ユーザ名

demandReceiptCd

String demandReceiptCd
依頼要求／受付CD

demandReceiptName

String demandReceiptName
依頼要求／受付名

processCd

String processCd
プロセスコード

groupList

jp.co.intra_mart.foundation.bpw.model.object.RunGroupListModel groupList
グループ情報

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo
ログインユーザ情報

loginUserID

String loginUserID
ログインユーザID

loginGroupID

String loginGroupID
ログイングループID

authorityFlg

String authorityFlg
処理権限フラグ

approvalTypeCd

String approvalTypeCd
承認種別コード

approvalRightType

String approvalRightType
承認可否種別

representationType

String representationType
代理コード種別

transferUserCd

String transferUserCd
振替先ユーザCD

transferUserName

String transferUserName
振替先ユーザ名

recognitionStatus

String recognitionStatus
承認ステータス

noticeMailFlg

String noticeMailFlg
代理元メール通知フラグ

arbitraryChangeFlag

String arbitraryChangeFlag
任意指定フラグh

クラス jp.co.intra_mart.foundation.bpw.model.object.RunUserListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.SelectPatternListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.SequenceInnerInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

runNo

String runNo

runActivityCd

String runActivityCd

クラス jp.co.intra_mart.foundation.bpw.model.object.SequenceInnerListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.SwitchInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

conditionNo

String conditionNo

runActivityCd

String runActivityCd

conditionClass

String conditionClass

クラス jp.co.intra_mart.foundation.bpw.model.object.SwitchListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

client_user_cd

Object client_user_cd

client_user_name

Object client_user_name

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoKey は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

String userCd

transferStart

String transferStart

transferEnd

String transferEnd

transferStatus

String transferStatus

companyCd

String companyCd

transferCdType

String transferCdType

transferCd

String transferCd

transferNarrowOrgCd

String transferNarrowOrgCd

sendMailFlg

String sendMailFlg

remark

String remark

subRecognitionFlg

String subRecognitionFlg

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

authorityFlg

String authorityFlg

targetDate

String targetDate

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferTableInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

String userCd

companyCd

String companyCd

transferCd

String transferCd

narrowPostCd

String narrowPostCd

transferCdType

String transferCdType

transferStart

String transferStart

transferEnd

String transferEnd

transferStatus

String transferStatus

sendMailFlg

String sendMailFlg

noticeMailFlg

String noticeMailFlg

userName

String userName

remark

String remark

subRecognitionFlg

String subRecognitionFlg

transferName

String transferName

narrowPostName

String narrowPostName

transferUserCd

String transferUserCd

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

recordCount

String recordCount

クラス jp.co.intra_mart.foundation.bpw.model.object.TransferTableListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.UserApplicationKeyInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

String processDefCd

versionCd

String versionCd

processCd

String processCd

parameterNumber

String parameterNumber

parameterCd

String parameterCd

クラス jp.co.intra_mart.foundation.bpw.model.object.UserInfoModel は jp.co.intra_mart.foundation.bpw.model.object.ActivityMasterInfoKey を拡張し、Serializable を実装しています

直列化されたフィールド

userCd

String userCd

userName

String userName

クラス jp.co.intra_mart.foundation.bpw.model.object.VersionInfoKey は Object を拡張し、Serializable を実装しています

直列化されたフィールド

processDefCd

String processDefCd

versionCd

String versionCd

syncronizedInfo

jp.co.intra_mart.system.bpw.SyncronizedInfo syncronizedInfo

loginUserInfo

jp.co.intra_mart.framework.base.util.UserInfo loginUserInfo

loginUserID

String loginUserID

loginGroupID

String loginGroupID

クラス jp.co.intra_mart.foundation.bpw.model.object.VersionInfoResult は jp.co.intra_mart.foundation.bpw.model.object.ProcessDefInfoResult を拡張し、Serializable を実装しています

直列化されたフィールド

versionCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult versionCd

versionName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult versionName

note

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult note

processDefNote

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processDefNote

startActivityCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult startActivityCd

draftActivityCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult draftActivityCd

processClassCode

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult processClassCode

subProcessFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult subProcessFlag

attachmentFlag

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult attachmentFlag

effectiveDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult effectiveDate

endDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult endDate

extensionNameA

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameA

extensionNameB

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameB

extensionNameC

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameC

extensionNameD

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameD

extensionNameE

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameE

extensionNameF

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameF

extensionNameG

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameG

extensionNameH

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult extensionNameH

createDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createDate

createUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserCd

createUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult createUserName

recordDate

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordDate

recordUserCd

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserCd

recordUserName

jp.co.intra_mart.foundation.bpw.model.object.BPWFieldResult recordUserName

categoryInfo

jp.co.intra_mart.foundation.bpw.model.object.CategoryInfoResult categoryInfo

totalCount

int totalCount

activeCount

int activeCount

クラス jp.co.intra_mart.foundation.bpw.model.object.VersionListModel は jp.co.intra_mart.foundation.bpw.model.object.ListModel を拡張し、Serializable を実装しています

クラス jp.co.intra_mart.foundation.bpw.model.object.WfeUserInfoModel は Object を拡張し、Serializable を実装しています

直列化されたフィールド

clientType

String clientType

colorPatternID

String colorPatternID

encoding

String encoding

locale

Locale locale

loginGroupID

String loginGroupID

loginTime

Date loginTime

loginType

String loginType

signature

String signature

url

String url

urlSignature

String urlSignature

userID

String userID

パッケージ jp.co.intra_mart.system.bpw

クラス jp.co.intra_mart.system.bpw.SyncronizedInfo は Object を拡張し、Serializable を実装しています

直列化されたフィールド

table

Hashtable table

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


intra-mart[Server side JavaScript intra-mart Documentation.[Application Common Master Table]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart DTD 定義ファイルについて

このページでは、各種DTD定義ファイルの説明を行います。
各種DTD定義ファイルはシステム全体の設定を行ったり、データのインポートエクスポートを行ったりする場合のXMLファイルのフォーマットの定義が記述されています。

システム定義ファイル
サーバマネージャインストールディレクトリ/specification/dtdに保存されています。

ＤＴＤ定義ファイル名 | 説明
system_6_1.dtd | システムの定義を行います。 サーバマネージャインストールディレクトリ/conf/system.xmlに対する定義ファイルです。 システムの対応ロケール、エンコーディング、クライアントタイプ、画面カラーパターンの定義を行います。
data-source_6_1.dtd | データソースの定義を行います。 サーバマネージャインストールディレクトリ/conf/data-source.xmlに対する定義ファイルです。 システムに紐付くデータソース（複数）およびログイングループに紐付くデータソース（ログイングループ毎に1個）の定義を行います。
system-install_6_1.dtd | 初期データインポート情報、ＡＰＩの登録およびＡＰＩに対するリスナーの定義を行います。 サーバマネージャインストールディレクトリ/conf/system-install.xmlに対する定義ファイルです。 初期データインポート、サンプルデータインポート情報の定義を行います。 スクリプト開発モデルで利用するJavaScriptAPIの登録を行います。 アクセスセキュリティAPI、アプリケーション共通マスタAPI、ワークフローAPIのリスナーの定義を行います。

アクセスセキュリティ定義ファイル
サーバマネージャインストールディレクトリ/specification/dtdに保存されています。

ＤＴＤ定義ファイル名 | 説明
access-security_6_1.dtd | アクセスセキュリティ全般の定義を行います。 サーバマネージャインストールディレクトリ/conf/access-security.xmlに対する定義ファイルです。 セッション情報の保管方法の定義を行います。 URLのアクセス制限設定を定義します。 ログイン処理に対する定義を行います。 アクセスセキュリティAPIの動作の定義を行います。 アクセスセキュリティAPIに対するリスナーの定義を行います。 アクセスセキュリティのインポート・エクスポートの定義を行います。
system-menu_6_1.dtd | システム管理者が利用するメニューの定義を行います。 サーバマネージャインストールディレクトリ/conf/system-menu.xmlに対する定義ファイルです。
admin-menu_6_1.dtd | グループ管理者が利用する管理メニューの定義を行います。 管理メニューのインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
account_6_1.dtd | アカウント情報の定義を行います。 アカウント情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
account_csv_format_6_1.txt | アカウント情報のCSV形式の定義を行います。 アカウント情報のインポート・エクスポートに利用します。 CSV形式のインポート・エクスポートでは、この定義ファイルのフォーマットを利用します。
role_6_1.dtd | ロール情報の定義を行います。 ロール情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
user-menu_6_1.dtd | ロール情報の定義を行います。 ロール情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
calendar_6_1.dtd | カレンダー情報の定義を行います。 カレンダー情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
batch_6_1.dtd | バッチ情報の定義を行います。 バッチ情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
password-history_6_1.dtd | パスワード履歴管理の定義を行います。 パスワード履歴管理に関連した初期設定に利用し、パスワード履歴管理の利用の有無等の定義を行います。
active-session-config_6_1.dtd | アクティブセッション情報の定義を行います。 アクティブセッションに関連した初期設定に利用し、アクティブセッションが無効化された際のエラーページの定義を行います。
duplicate-login_6_1.dtd | 2重ログイン防止機能の定義を行います。 2重ログイン防止機能に関連した初期設定に利用し、2重ログイン防止機能の利用の有無、2重ログイン時のエラーページ等の定義を行います。
short-cut-config_6_1.dtd | ショートカットアクセス機能の定義を行います。 ショートカットアクセス機能に関連した初期設定に利用し、ショートカット情報の更新処理およびショートカット表示用ページ等の定義を行います。
cryption-config_6_1.dtd | 暗号化モジュール機能の定義を行います。 暗号化アルゴリズムを組み込む場合に利用します。

アプリケーション共通マスタ定義ファイル
サーバマネージャインストールディレクトリ/specification/dtdに保存されています。

ＤＴＤ定義ファイル名 | 説明
datastore_6_1.dtd | データストアでのエンティティ、モデル、マッパ、データベース およびエンティティ間のリレーションシップの定義を行います。 標準では、ApplicationRuntimeインストールディレクトリ/conf/datastore/jp/co/intramart/foundation/datastore/common.xmlが定義されています。 common.xmlはアプリケーション共通マスタおよびアクセスセキュリティで使用するエンティティ、モデル、マッパ、データベース およびエンティティ間のリレーションシップの定義を行なっています。通常このファイルを編集することはありません。
app-master-import_6_1.dtd | アプリケーション共通マスタのインポート・バッチプログラムの設定情報の定義を行います。 このバッチで対象とするのは、会社・組織情報、役職情報、パブリックグループ情報、 ユーザプロファイル情報、ユーザ所属情報です。 標準では、StorageServiceインストールディレクトリ/storage/master/ログイングループID/config/import_config.xmlで定義を行います。
app-master-export_6_1.dtd | アプリケーション共通マスタのエクスポート・バッチプログラムの設定情報の定義を行います。 このバッチで対象とするのは、会社・組織情報、役職情報、パブリックグループ情報、 ユーザプロファイル情報、ユーザ所属情報です。 標準では、StorageServiceインストールディレクトリ/storage/master/ログイングループID/config/export_config.xmlで定義を行います。
company-data_6_1.dtd | 会社・組織情報の定義を行います。 会社・組織情報のインポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
company-post-data_6_1.dtd | 役職情報の定義を行います。 役職情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。 役職情報をインポートするためには、対象となる会社情報を事前インポートしておく必要があります。
public-group-data_6_1.dtd | パブリックグループ情報の定義を行います。 パブリックグループ情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
user-profile-data_6_1.dtd | ユーザプロファイル情報の定義を行います。 ユーザプロファイル情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポートを行います。
user-attach-data_6_1.dtd | ユーザ所属情報の定義を行います。 ユーザ所属情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポートを行います。 ユーザ所属情報をインポートするためには、対象となる会社・組織、役職、およびパブリックグループ情報を事前にインポートしておく必要があります。
item-data_6_1.dtd | 商品情報の定義を行います。 商品情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
item-template-data_6_1.dtd | 商品テンプレート情報の定義を行います。 商品テンプレート情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
item-category-data_6_1.dtd | 商品カテゴリ情報の定義を行います。 商品カテゴリ情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。
item-attach-data_6_1.dtd | 商品分類情報の定義を行います。 商品分類情報のインポート・エクスポートに利用します。 標準では、このDTD定義ファイルのフォーマットでインポート・エクスポートを行います。

im-JsUnitテスト結果定義ファイル
サーバマネージャインストールディレクトリ/specification/dtd/jsunitに保存されています。

ＤＴＤ定義ファイル名 | 説明
js-unit_6_1.dtd | im-JsUnitを実行した時に、テスト結果として出力されるXMLの定義です。
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Application Runtime]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Application Runtime 篇 】

前提

Application Runtime は、Web-Server with Web-Server Connecor と連携して Web Application を提供するランタイム・サービスです(スタンドアロン型で動作している場合、Application Runtime 自身が HTTP サーバとしても機能します)。

Application Runtime 機能を利用するには、Schedule Service 以外のすべてのサービスが正しく動作していることが必要になります(Schedule Service はバッチ管理機能を利用する場合に必要になります)。

動作に必要なプログラム

Application Runtime が動作する際には、以下のプログラムファイルを必要とします。

  • init.js (初期起動用)
  • 各種プレゼンテーション・ページ(*.html)
  • 各種ファンクション・コンテナ(*.js)
  • 各種 JSP プログラム(*.jsp, *.xtp)
  • 各種 Servlet プログラム(*.class)

スクリプト開発モデルのプログラム・ファイルは、Resource Service に保存してください。Application Runtime はResource Service より配信されるプログラムを実行します。

JavaEE開発モデルのプログラムファイルは、Application Runtime インストールディレクトリ直下の doc/ ディレクトリ内に保存してください（サーブレットの場合は、任意のディレクトリ内に保存してクラスパスを設定しても良いです）。Application Runtimeは、ＵＲＬによりマッピングされたプログラム(*.jsp, *.xtp, *.class)をロードして実行します。

初期起動

サーバ起動後 HTTP リクエストの処理をする前に、各モジュールの初期化を行います。これを 初期起動と呼びます。

初期起動時は、Application Runtime により init.js が実行されます。

初期起動時に実行されるプログラム内では、ページ遷移などの一部のＡＰＩは利用できません。

初期起動時に利用できない Function Container API
  • request.*
  • forward()
  • redirect()
  • transmission()
  • Debug.browse()
  • Module.mobile.alert()
  • Client.*
  • Web.*
  • Module.alert.*
  • Module.client.*
  • Module.download.*
  • Module.external.*

HTTP リクエスト時の実行シーケンス

Application Runtime が HTTP リクエストを受け付けると以下のシーケンスにしたがって該当のプログラム順次実行していきます(スクリプト開発モデルにより作成されたプログラムをリクエスト場合)。

ブラウザからのリクエスト時
  1. session.js 内 init() 関数実行
  2. page 指定ファンクションコンテナ内 init() 関数実行
  3. page 指定プレゼンテーションページの実行
  4. page 指定ファンクションコンテナ内 close() 関数実行
  5. session.js 内 close() 関数実行
  6. ページの返却
intra-mart のリンク or フォームからのリクエスト時
  1. session.js 内 init() 関数実行
  2. action 指定関数の実行
  3. page 指定ファンクションコンテナ内 init() 関数実行
  4. page 指定プレゼンテーションページの実行
  5. page 指定ファンクションコンテナ内 close() 関数実行
  6. session.js 内 close() 関数実行
  7. ページの返却

スクリプト開発モデル・プログラムの実行に関する動作仕様に関しては、Presentation Pageについてを参照して下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Batch]]]

i ntra-mart The Power for Enterprise Web Solution
Batch Programについて

前提

ここでは、Application Runtime により実行されるバッチプログラム(ファンクションコンテナ)の動作仕様を説明します。

intra-mart のバッチ機能を利用するには、すべてのサービスをインストールして正しく動作していることが必要になります。

動作に必要なプログラム(バッチ)

バッチプログラム起動設定をした上で Schedule Service を運用した場合、設定した時刻に指定プログラムが実行されます。

指定のファンクションコンテナまたはクラスには、バッチ設定に関する情報オブジェクトが引数として実行時に引き渡されます。

引数オブジェクトが持つプロパティ
group | バッチ設定をしたログイン・グループＩＤ
name | バッチ名称
establish | バッチ実行時間設定
year | バッチ実行指定年
month | バッチ実行指定月
date | バッチ実行指定日
day | バッチ実行指定曜日
hour | バッチ実行指定時間
minute | バッチ実行指定分
second | バッチ実行指定秒
program | バッチとして実行するプログラム・パス

この情報オブジェクトは、バッチプログラムがファンクションコンテナの場合、init() 関数の引数として実行時にプログラムに渡されます。また、バッチプログラムがクラスの場合、execute() 関数の引数として渡されます。

バッチ実行指定の 年・月・日・曜日・時・分・秒 のうち“毎”指定(「毎日」など)をしている場合は、非数(NaN)または-1が格納されています。

Application Runtime によりバッチプログラムとして実行されたファンクションコンテナ内に定義されている init() 関数は、１つの引数を取り実行されます(バッチプログラムがクラスの場合は、jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent インターフェースの仕様に準じます)。

実行シーケンス

バッチ起動設定時刻になった場合、以下のように処理が流れます。

  1. 設定ファンクションコンテナまたはクラスのロード
  2. 設定ファンクションコンテナ内 init() 関数またはクラスの execute() メソッドの実行

バッチプログラム例

下記サンプルプログラムは、ファンクションコンテナ(JavaScript)で開発をした場合の例です。
バッチ起動設定をした時の Web サーバの HTTP リクエスト受付ポートとバッチの実行時間（プログラム実行時の現在時刻）を my_batch.txt というファイルに書き出すバッチプログラムです。

function init(arg){
var f = new VirtualFile("my_batch.txt");
var now = new Date();
f.write(now.toString());
f.append("name=");
f.append(arg.name);
}

JAVA でバッチプログラムを作成する方法に関しては、jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent クラスのＡＰＩ仕様をご覧ください。

注意事項

バッチ・プログラム内では、ページ遷移などの一部のＡＰＩは利用できません。

バッチ・プログラム内で利用できない Function Container API
  • Request
  • forward()
  • redirect()
  • transmission()
  • Debug.browse()
  • Module.mobile.alert()
  • Web.*
  • Module.alert.*
  • Module.client.*
  • Module.download.*
  • Module.external.*

また、バッチプログラムにおいては、im-JavaEE Frameworkのサービスフレームワークは使用できません。イベントフレームワーク、データフレームワークを使用してください。

戻る
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Permanent Data Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Permanent Data Service 篇 】

機能概要

Permanent Data Service は、intra-mart システムが動作するために必要な設定情報などを管理しています。
また、このサービスでは情報をファイル保存しますので、サービスが停止した場合も、次の起動時にそれまでに保存されたデータを復元することができます。したがって、簡易的なデータベースとして利用することも可能です。

Permanent Data Service に関連するＡＰＩは以下のとおりです。

  • Permanent(スクリプト開発モデル)
  • jp.co.intra_mart.foundation.service.client.information.PermanentDirectory(JavaEE開発モデル)
  • jp.co.intra_mart.foundation.service.client.information.PermanentFile(JavaEE開発モデル)

仕様

この機能は、簡易データベースとしての機能を提供します。

この機能を利用したものには、永続情報保存(Function Container API Permanent, JAVA API jp.co.intra_mart.foundation.service.client.information.PermanentDirectory) 機能があります。
また、アカウントやメニューなどの、intra-mart のシステム設定情報もこの機能を利用しています。

この機能を利用して保存した情報は、ファイルとして保管されますので、Permanent Data Service を再起動しても設定情報が失われることがありません。

情報ファイルは、Permanent Data Service の インストールディレクトリ直下の treasure/ ディレクトリ内に保存されます。
また、情報ファイルはバイナリファイルとして保存されますので、テキストエディタなどで編集をすることはできません(バイナリファイルのバージョン間での互換性は保証されません)。

注意事項

Permanent Data Service は、インストールディレクトリ直下の treasure/ ディレクトリにデータファイルを保存します。
treasure/ ディレクトリ内にファイルやディレクトリを保存しないで下さい。Information Server が作成するファイルやディレクトリ以外のファイルおよびディレクトリが存在すると、誤動作を起こす原因になる可能性があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Resource Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Resource Service 篇 】

機能概要

Resource Service は、特にスクリプト開発モデルのプログラムファイルを管理および Application Runtime への配布を行います。intra-mart システムの中枢的役割を果たしています。

Resource Service が管理するファイルは以下の通りです。

  • プレゼンテーションページ(*.html)
  • ファンクションコンテナ(*.js)
  • 設定値定義ファイル(*.ini)

プログラム管理

Resource Service では、intra-mart システムの動作に必要な各プレゼンテーションページ(*.html)およびファンクションコンテナ(*.js)のプログラムファイルを集中管理しています。
Application Runtime が必要なプログラムを、Resource Service が自動的に配布します。

プログラムファイルは、Resource Service の スクリプト開発モデルのプログラムディレクトリ( %インストールディレクトリ%/pages/ ) 以下に保管 されています。
新規に作成したりカスタマイズしたプログラムファイルは、Resource Service の スクリプト開発モデルのプログラムディレクトリ 以下に保存するようにして下さい。
プログラムファイルが更新されると、Resource Service はファイルの更新日付の変化を感知して自動的にシステムに反映させます。

ディレクトリ構成

標準状態を前提として以下に説明します。

プログラムソースのルートディレクトリは、３種類あります。

  • pages/platform/src ・・・ システム用のソース管理ディレクトリ
  • pages/product/src ・・・ 追加パッケージ用のソース管理ディレクトリ
  • pages/src ・・・ 通常のソース管理ディレクトリ
intra-mart WebPlatform/AppFramework のソースは、pages/platform/src にインストールされます（サンプルプログラムは、pages/src にインストールされます）。 また、追加パッケージ（イントラネット・スタートパックなど）のソースは、pages/product/src にインストールされます。 これらのソースは、変更する事ができません。

ユーザアプリケーション独自のソースは、pages/src に作成してください。また、パッケージのソースに対してカスタマイズをする場合、必要なソースを pages/src にコピーをしてから編集してください。
pages/platform/src または pages/product/src は、システムの基本ソースになります。絶対に編集をしないでください（pages/src にインストールされるサンプルプログラムは編集してもかまいません）。
パッケージのソースをカスタマイズする場合は、pages/platform/src や pages/product/src から必要なソースのみを pages/src にコピーしてから編集してください。pages/src にコピーすることにより、パッケージのパッチを適用したときに、パッチで変更されたソースを上書きされません（パッチは、pages/platform/src または pages/product/src にソースを展開します）。

スクリプト開発モデル実行エンジンは、ソースパスを次の順で検索します。

  1. pages/src
  2. pages/product/src
  3. pages/platform/src
したがって、カスタマイズするソースを pages/src にコピーしてから編集する事によって、カスタマイズしたソースが優先的に検索・実行されます（コピー元のシステムのソースは無視されます）。

スクリプト開発モデルの国際化対応機能を利用して地域化をする場合、下記ディレクトリに地域化させたディレクトリを配置してください。

  • pages/i18n/[ロケールを表すキーワード]

スクリプト開発モデルの国際化対応機能を利用する場合は、imart.xmlの設定が必要です。 (サーバをインストールした初期状態では、日本語ロケールのみ設定されています。)

imart.xmlに以下のいずれかの設定項目を追加してください。
（詳細は「設定ガイド（Service編）」を参照してください）

  • intra-mart/platform/service/resource/jssp/source-path/international/local
  • intra-mart/platform/service/resource/jssp/source-path/international/directory

設定例１
英語ロケール「en」に対応したソースを格納するディレクトリを「pages/i18n/en」、 英語ロケール「en_US」に対応したソースを格納するディレクトリを「pages/i18n/en_US」とする場合
<intra-mart>
  <platform>
    <service>
      <resource>
        <jssp>
          <source-path>
            <international>
              <local>
                <en>
                  <directory>pages/i18n/en</directory>
                </en>
                <en_US>
                  <directory>pages/i18n/en_US</directory>
                </en_US>
              </local>

設定例２
「ロケールを表すキーワード」を検索する基準ディレクトリを「pages/i18n」とする場合
<intra-mart>
  <platform>
    <service>
      <resource>
        <jssp>
          <source-path>
            <international>
              <directory>pages/i18n</directory>

「ロケールを表すキーワード」とは、java.util.Locale の仕様に準じた文字列になります。日本語ロケールの場合、通常は ja または ja_JP になります。 システムの地域化されたプログラムソースは、下記にインストールされます。

  • pages/platform/i18n/[ロケールを表すキーワード]
  • pages/product/i18n/[ロケールを表すキーワード]
これらも、カスタマイズをするときは、pages/i18n/[ロケールを表すキーワード]にコピーすることで、パッチによる上書きの影響を受けることなくカスタマイズをすることができます。

国際化機能を利用している場合、以下の順にソースが検索されます。

  1. 地域化されたソース
  2. 地域化されていない標準のソース
つまり、ユーザアプリケーションで言えば、以下の順に検索されます。
  1. pages/i18n/[ロケールを表すキーワード]
  2. pages/src
地域化されているソースを検索する場合、java.util.ResourceBundle と同様の検索が行われます。例えば、ロケールが ja_JP だった場合、以下の順にソースが検索されます。
  1. pages/i18n/ja_JP
  2. pages/i18n/ja
  3. pages/src

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Schedule Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Schedule Service 篇 】

機能概要

Schedule Service は、バッチプログラムの実行スケジュールを管理します。

バッチプログラムのスケジューリング機能

設定されたバッチプログラムの実行スケジュール指定に従い、バッチプログラムの実行を管理します。
このサービスは、指定の時間になると該当するバッチプログラムの実行を指定ＵＲＬを用いて Application Runtime に依頼します。したがって、バッチプログラムは、Application Runtime で実行されます。

バッチプログラムの作成

バッチプログラムは、スクリプト開発モデルおよびJavaEE開発モデルのどちらでも開発可能です。 いずれかのモデルで作成されたプログラムを実行可能な場所に保存してスケジュール設定することで、指定の時間に任意のバッチ処理を実行することができます。
バッチプログラムの動作仕様および作成方法に関しては、Programについてを参照してください。

注意事項

このサービスが動作しているコンピュータの時計は、正しく合わせてください。コンピュータの時計が狂っていると、バッチプログラムが正しく実行されません。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Serialization Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Serialization Service 篇 】

機能概要

Serialization Service は、システム全体における統括的な利用を目的とした機能の集合体です。このサービスでは、アプリケーションロック機能の管理が行われています。

Serialization Service に関連するＡＰＩは以下のとおりです。

  • Lock(スクリプト開発モデル)
  • jp.co.intra_mart.foundation.service.client.information.Lock(JavaEE開発モデル)

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Shared Memory Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Shared Memory Service 篇 】

機能概要

Shared Memory Service は、プログラム間での共有メモリとして利用することができます。

Shared Memory Service に関連するＡＰＩは以下のとおりです。

  • Module.external.*(スクリプト開発モデル)
  • jp.co.intra_mart.foundation.service.client.information.ExternalDirectory(JavaEE開発モデル)
  • jp.co.intra_mart.foundation.service.client.information.ExternalMemory(JavaEE開発モデル)

仕様

データを一時的に保存しておく目的で利用される機能です。また、このサービスが提供する情報管理は、セッションレスです。タイムアウトなどによりデータが焼失することはありません。
これらの情報(データ)は、Shared Memory Service のメモリ中に保管され、プログラムの要求に応じて取り出したり削除したりします。 従って、分散サーバ構成にてシステムを構築している場合、データの入出力はネットワークを介して行われるため、これらのＡＰＩに対する頻繁なアクセスは実行速度の低下やサーバへの付加増加などを招くことがあります。

注意事項

Shared Memory Service のデータ保存機能では、必要な情報をメモリ中に保管する仕組になっています。
保存データ量がメモリ許容量を超えてしまうと、Shared Memory Service およびこのサービスが動作しているサービスプラットフォームの動作が不安定になってしまいます(同じサービスプラットフォームに複数のサービスを同時運用している場合、他のサービスの実行に影響がでる場合があります)。このような場合は、Shared Memory Service の動作するサービスプラットフォーム起動時の設定メモリ量を考慮して、データを保存し過ぎないように注意して下さい(環境に応じて サービスプラットフォーム 起動時の設定メモリ量を適切に設定して下さい)。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Storage Service]]]

i ntra-mart The Power for Enterprise Web Solution
動作概要
【 Storage Service 篇 】

機能概要

Storage Service は、intra-mart で扱うファイルを一元管理します。

Storage Service の主な仕事は以下の通りです。

  • ファイル(主にデータファイル)の管理
  • PDF ファイルの作成(エクステンションモジュール適用時)
  • XRF ファイルの作成(エクステンションモジュール適用時)

Storage Service に関連するＡＰＩは以下のとおりです。

  • VirtualFile(スクリプト開発モデル)
  • jp.co.intra_mart.foundation.service.client.file.NetworkFile(JavaEE開発モデル)

ファイル管理機能

データを一元管理する目的で利用される機能です。

この Storage Service にファイルを保存する事で、intra-mart をネットーワーク型（分散システム）で運用している場合においても、各 Application Runtime が同一のファイルを共有する事ができます（アップロードされたファイルを保存したり、複数のユーザー間で共有するファイルを保存したりなどの目的に利用すると便利です）。

ファイルの保存場所は、Storage Service をインストールしたディレクトリ直下の storage/ 以下になります。
Storage Service のファイルを操作するＡＰＩでファイルパスを指定する場合、storage/ ディレクトリからの相対パス指定をしてください（『..』を利用してパス指定をして storage/ よりも上位のファイルに対してアクセスすると非常に危険なので、絶対にやらないでください）。

エクステンションモジュールによる機能追加

Storage Service はエクステンションモジュールを追加インストールすることで機能追加される場合があります。

Storage Service に機能追加するパッケージ

  • PDF デザイナー
  • XRFコンポーザ

注意事項

storage/ ディレクトリには、Storage Service がファイルの書込や読込をするための権限を与えて下さい。権限が正しく設定されていない場合、Storage Service のファイルを扱うＡＰＩが正しく実行できなくなります。
また、ファイルを新らしく作成する場合、そのファイルが作成できるだけの十分なディスク容量を確保してからファイル作成を行うようにして下さい。storage/ ディレクトリ以下に十分なディスク容量がない場合、ＡＰＩによるファイル作成ができません。

極端に容量の大きいファイルを扱う場合、Storage Service のレスポンスが一時的に低下する事があります。また、ネットワーク型で運用している場合、ネットワーク環境により、Storage Service から Application Server への通信がボトルネックとなり、Storage Service のファイルを扱うＡＰＩの実行速度が遅くなる場合があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Web Service]]]

i ntra-mart The Power for Enterprise Web Solution
Webサービスについて

概要

i ntra-mart WebPlatform は Apache Axis を利用することにより Webサービスの機能を提供することができます。これによりi ntra-mart の機能をネットワークを通じて利用することができます。 以下にその例を示します。

i ntra-mart AppFramework をご使用の場合は、お使いのウェブアプリケーションサーバのマニュアルをご覧ください。

前提

Webサービスを利用するにはi ntra-mart WebPlatform および Apache Axis が正常に動作している必要があります。 インストール方法についてはインストールガイドをご覧ください。

Webサービスの利用

  1. インストール時に使用したApache AXIS を用意してください。
    Apache AXISの展開先を<AXIS_HOME>とします。
    例)C:\axis\axis-1_2

    i ntra-mart WebPlatformのインストール先を<IMART_HOME>とします。
    例)C:\imart

  2. i ntra-mart WebPlatformに添付されているサンプルを例にしてWebサービスを設定します。
    Javaクラス
    • jp.co.intra_mart.sample.soap.ScriptCallerBean.class
      Webサービスを提供するサンプルプログラムです。
      <IMART_HOME>/pages以下に配置された任意のjsプログラムを実行することができます。
    • jp.co.intra_mart.sample.soap.CalculatorClient.class
      Webサービスクライアントのサンプルプログラムです。
      ScriptCallerBean.classのWebサービスを利用して、ネットワークを通じて<IMART_HOME>/pages/src/sample/web_service/calculator.jsを実行します。

    ソースファイルをご覧になる場合はインストールCDの iwp_afw/src/im_sample-src.zip を展開してご覧ください

    スクリプト開発モデルプログラム
    • <IMART_HOME>/pages/sample/web_service/calculator.js
      Webサービスから呼び出されるスクリプト開発モデルプログラムです。
      引数に渡された二つの数値を加算して返却します。

  3. クラスパスの設定
    Webサービスの登録と実行のために必要なApache Axisと i ntra-mart WebPlatformのライブラリをクラスパスに設定します。
    以下がWindows環境でライブラリをクラスパスに追加するバッチファイルの例です。
    set AXIS_HOME=C:\axis\axis-1_1
    set IMART_HOME=C:\imart
    set AXIS_LIB=%AXIS_HOME%\lib
    set CLASSPATH=.
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\axis.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\axis-ant.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\commons-discovery-0.2.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\commons-logging-1.0.4.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\jaxrpc.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\log4j-1.2.8.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\saaj.jar
    set CLASSPATH=%CLASSPATH%;%AXIS_LIB%\wsdl4j-1.5.1.jar
    set CLASSPATH=%CLASSPATH%;%IMART_HOME%\doc\imart\WEB-INF\classes
    set CLASSPATH=%CLASSPATH%;%IMART_HOME%\bin\intramart.jar

  4. クラスのデプロイ
    Apache Axisの管理用クライアントを利用してクラスファイルをデプロイ（配置）します。 デプロイするにはi ntra-mart WebPlatformに付属の 配置記述ファイル（Deployment Descriptorファイル）を使用します。

    サンプルには以下の配置記述ファイルが付属しています。
    Webサービス配置用 | <IMART_HOME>\doc\imart\WEB-INF\classes\jp\co\intra_mart\sample\soap\ScriptCallerService.wsdd
    Webサービス除去用 | <IMART_HOME>\doc\imart\WEB-INF\classes\jp\co\intra_mart\sample\soap\undeploy.wsdd

    以下のコマンドを実行してください。
    >java org.apache.axis.client.AdminClient -l http://localhost:8080/imart/servlet/AxisServlet
    <IMART_HOME>\doc\imart\WEB-INF\classes\jp\co\intra_mart\sample\soap\ScriptCallerService.wsdd

    <Admin>Done processing</Admin>

    <Admin>Done processing</Admin>と表示されればデプロイは成功です。

  5. Webサービスの実行
    Webサービスを起動しJSプログラムを実行します。以下のコマンドを実行してください。
    >java jp.co.intra_mart.sample.soap.CalculatorClient 5 6
    RESULT=11

    WebサービスのクライアントがWebサービスを起動し、JSプログラムの計算結果が表示されました。 引数に与えた数値の加算結果が表示されれば成功です。
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[JavaEE tag library]]

i ntra-mart The Power for Enterprise Web Solution
JavaEE開発モデル
画面共通モジュール
intra-mart タグライブラリ 仕様

注意事項

このページでは、JSPで利用するタグライブラリに関して、プログラム・インターフェースの詳細仕様を記載しています。

intra-mart Tag Library仕様

1. | タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
2. | タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。
3. | タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。
4. | タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
5. | JSPページ内では、 <!-- と --> で囲まれた範囲は、コメントとして扱われます。 (ランタイム時において、<!-- と --> に囲まれている範囲内のtaglibディレクティブは実行されません。)

使用方法

intra-mart タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/core/standard" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imtag" として説明します)

また下記のように、上記の taglib ディレクティブを XML の書式で記述すること も出来ます。

<jsp:directive.taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" />

< サンプル >

<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ taglib uri="http://www.intra-mart.co.jp/taglib/core/standard" prefix="imtag" %>
<%@ page import="java.util.*" %>

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 //EN">
<HTML>

<HEAD>
<TITLE>Hello intra-mart.</TITLE>
</HEAD>

<%! private Date date = new Date(); %>

<BODY bgcolor="whitesmoke">

<CENTER><H2>
<imtag:ImartDateFormat value="<%= date%>" format="yyyy/MM/dd"/>
</H2></CENTER>

</BODY>

</HTML>

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript BASE MODULE Documentation.[Graph]]

i ntra-mart The Power for Enterprise Web Solution
グラフ描画・モジュール

機能概要

入力データをもとに画像ファイルを作成して、ブラウザ画面上にグラフ画面を表示します。

以下の５種類のグラフがサンプルとして用意されています。

  • 折れ線グラフ
  • 棒グラフ
  • 円グラフ
  • レーダーチャート
  • ポートフォリオ

ＡＰＩ仕様

intra-mart 標準 タグライブラリ の drawer タグを利用します。

drawer タグの属性 data にjp.co.intra_mart.foundation.drawer.AbstractDrawer を スーパークラスとしたインスタンスを渡すことによりグラフの画像ファイルをHTMLに表示します。

AbstractDrawerをスーパークラスとした、グラフ描画クラスは以下の５種類です。

クラス | グラフの種類
jp.co.intra_mart.foundation.graph.BarGraphDrawer | 棒グラフ
jp.co.intra_mart.foundation.graph.CircleGraphDrawer | 円グラフ
jp.co.intra_mart.foundation.graph.LineGraphDrawer | 折れ線グラフ
jp.co.intra_mart.foundation.graph.PortFolioDrawer | ポートフォリオ
jp.co.intra_mart.foundation.graph.RadarChartDrawer | レーダーチャート

  • Drawer タグの詳細については画面共通モジュールを参照してください。
  • AbstractDrawerとサブクラスの詳細についてはアプリケーション共通モジュールを参照してください。

グラフ作成例

<%@ page contentType="text/html; charset=Windows-31J" pageEncoding="Windows-31J" %>
<%@ taglib prefix="imarttag" uri="http://www.intra-mart.co.jp/taglib/core/standard" %>
<%@ page import="jp.co.intra_mart.foundation.graph.*" %>
<%@ page import="java.awt.Color" %>
<%
  // 棒グラフの作成
  BarGraphDrawer drawerBar = new BarGraphDrawer(0, 60, 10);
  drawerBar.setWidth(300);
  drawerBar.setHeight(300);
  drawerBar.setCaption(new String[]{"１月", "２月", "３月"});

  BarGraphObject objBar = new BarGraphObject(Color.black);
  objBar.addData(50);
  objBar.addData(10);
  objBar.addData(30);
  drawerBar.addData(objBar);
%>
<HTML>
  <BODY>
    <imarttag:drawer data="<%= drawerBar %>" />
  </BODY>
</HTML>

描画された棒グラフ（例）

新しいグラフの作成

グラフを新規に作成する場合、AbstractDrawerを利用します。
AbstractDrawerを継承したクラスを作成し、createImageメソッドをオーバーライドしてください。

public class MyGraphDrawer extends AbstractDrawer {

  public MyGraphDrawer(
    super();
  }

  protected void createImage(Graphics g) {

    g.setColor(Color.red);
    g.drawLine(0, 0, getWidth() - 1, getHeight() - 1);

    g.setColor(Color.blue);
    g.drawRect(0, 0, getWidth() - 1, getHeight() - 1);

    .
    .
    .
    .
  }
}

createImageメソッドには画像描画の実行部分を記述します。
引数のグラフィックコンテキストに対して、グラフイメージを描画してください。

グラフのプログラムソースはインストールディレクトリ/sourceに格納されています。
具体的な記述方法はプログラムソースを参照してください。
AbstractDrawerの詳細についてはアプリケーション共通モジュールを参照してください。

Headless のサポート

X11を搭載していないUNIXなどのOSは、グラフィックスをサポートしていないため通常グラフモジュールを使用することができません。 但し、ヘッドレスモードをサポートしているJava VMを使用している場合、Java環境変数を設定することにより非グラフィックス環境の場合でも グラフモジュールを使用することが可能です。

i ntra-mart WebPlatform の場合は、/conf/imart.xmlの以下の場所にJava環境変数を追加してください。

    .
    .
<command>
  <exefile>C:/j2sdk1.4.2_XX/bin/java</exefile>
  <option>-cp %SYSTEMCLASSPATH% -Xms%XMS% -Xmx%XMX% -Djava.awt.headless=true</option>
  <argument/>
</command>
    .
    .

i ntra-mart AppFrameworkの場合は、同様のJava環境変数をウェブアプリケーションサーバに設定してください。 Java環境変数の設定方法については、ウェブアプリケーションサーバのマニュアルを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart タグライブラリ メニュー

intra-mart タグライブラリ (ユーティリティ)
<スプレッドシート>
CellDataSelector
ColumnDataSelector
RowDataSelector
SelectionSubmitter
LineHighLight
Sorting
DynamicTable
Column
DBListPaging
<入力制御>
Validate
DblClickForbidden
BackForbidden
<メニュ>
PopMenu
TabPane
Tab
<メッセージプッシュ>
Push
PushMessage


CellDataSelector
HTMLのテーブルのセルのデータを選択可能にするタグです。
このタグ内には、HTMLのテーブル（TDを一つ以上）を置く必要があります。
テーブルのセルをクリックすることで、該当セルが選択された状態になり、指定の前景色と背景色で表示されます。この状態で再びクリックしますと、該当セルの選択状態が解除され、元の前景色と背景色に戻ります。

デフォールトでは、選択できるセルは一つだけですが、属性multipleSelectableを"true"にすることで、複数選択も可能です。複数選択可能の場合の各セルデータの間の区切り文字は、属性cellDataSeperatorで定義することができる。
  このタグの内部に、SelectionSubmitterタグを置くことで、選択されたセルのデータをサーバに送信することができます。詳細はSelectionSubmitterタグに参照してください。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグをSortingタグの内部に置くことで、テーブルデータに対するソート機能とセル選択機能を同時に実現することができます。
このタグをLineHighLightタグの内部に置くことで、テーブルデータに対するセル選択と行ハイライト機能を同時に実現することができます。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・THの内容は選択不可です。
・テーブルのTABLE、TR、TH、TDにHTMLのID属性を設定することはできません。
・SelectionSubmitterタグとネスとして、選択されたセルのデータをサーバに送信する場合、送信されたデータはセルの中（TDタグ）に挟まれるすべての内容（インプットフィールドや画像などの場合はそのままHTMLコードを送信する）。
・ SelectionSubmitterタグとネストする場合は、SelectionSubmitterタグは必ずこのタグの一層下（SelectionSubmitterタグの一番近い親タグはこのタグであること）に置きます。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

選択された状態の背景色。デフォルトは"blue"。
fgColor | No | Yes
選択された状態の前景色。デフォルトは"white"。
multipleSelectable | No | Yes

複数選択可否のフラグ。デフォルトは"false"、複数選択不可。
cellDataSeperator | No | Yes

複数選択可能の場合の各セルデータの間の区切り文字。デフォルトは","（カンマ）。
内部タグ | SelectionSubmitterタグ

選択されたセルのデータをサーバに送信する。
使用例 | セル選択と送信機能
<imtag:CellDataSelector bgColor="white" fgColor="red"
    multipleSelectable="true">
  <table border="1" bgcolor="#BFD0EE" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="form"
        application="taglib" service="testform"/>
</imtag:CellDataSelector>

ColumnDataSelector

HTMLのテーブルの列のデータを選択可能にするタグです。
このタグ内には、HTMLのテーブル（TDを一つ以上）を置く必要があります。
テーブルの列の任意の位置をクリックすることで、該当列が選択された状態になり、指定の前景色と背景色で表示されます。この状態で再びクリックしますと、該当列の選択状態が解除され、元の前景色と背景色に戻ります。
デフォールトでは、選択できる列は一列だけですが、属性multipleSelectableを"true"にすることで、複数列選択も可能です。複数選択可能の場合の各列のデータの間の区切り文字は属性columnDataSeperatorで定義し、列内部の各セルデータの間の区切り文字は、属性cellDataSeperatorで定義することができる。

このタグの内部に、SelectionSubmitterタグを置くことで、選択された列のデータをサーバに送信することができます。詳細はSelectionSubmitterタグに参照してください。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグをSortingタグの内部に置くことで、テーブルデータに対するソート機能と列選択機能を同時に実現することができます。
このタグをLineHighLightタグの内部に置くことで、テーブルデータに対する列選択と行ハイライト機能を同時に実現することができます。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・THの内容は選択不可です。
・テーブルのTABLE、TR、TH、TDにHTMLのID属性を設定することはできません。
・SelectionSubmitterタグとネスとして、選択されたセルのデータをサーバに送信する場合、送信されたデータはセルの中（TDタグ）に挟まれるすべての内容（インプットフィールドや画像などの場合はそのままHTMLコードを送信する）。
・ SelectionSubmitterタグとネストする場合は、SelectionSubmitterタグは必ずこのタグの一層下（SelectionSubmitterタグの一番近い親タグはこのタグであること）に置きます。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

選択された状態の背景色。デフォルトは"blue"。
fgColor | No | Yes
選択された状態の前景色。デフォルトは"white"。
multipleSelectable | No | Yes

複数選択可否のフラグ。デフォルトは"false"、複数選択不可。
cellDataSeperator | No | Yes

同列の各セルデータの間の区切り文字。デフォルトは","（カンマ）。
columnDataSeperator | No | Yes

複数列選択可能の場合の列データの間の区切り文字。デフォルトは"|"。
内部タグ | SelectionSubmitterタグ

選択された列のデータをサーバに送信する。
使用例 | 列選択と送信機能
<imtag:ColumnDataSelector bgColor="white" fgColor="red"
    multipleSelectable="true">
  <table border=1 bgcolor="#BFD0EE" bordercolor="#336699" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="form"
        application="taglib" service="testform"/>
</imtag:ColumnDataSelector>

RowDataSelector

HTMLのテーブルの行のデータを選択可能にするタグです。
このタグ内には、HTMLのテーブル（TDを一つ以上）を置く必要があります。
テーブルの行の任意の位置をクリックすることで、該当行が選択された状態になり、指定の前景色と背景色で表示されます。この状態で再びクリックしますと、該当行の選択状態が解除され、元の前景色と背景色に戻ります。
デフォールトでは、選択できる行は一行だけですが、属性multipleSelectableを"true"にすることで、複数行選択も可能です。複数選択可能の場合の各行のデータの間の区切り文字は属性rowDataSeparatorで定義し、行内部の各セルデータの間の区切り文字は、属性cellDataSeperatorで定義することができる。

このタグの内部に、SelectionSubmitterタグを置くことで、選択された列のデータをサーバに送信することができます。詳細はSelectionSubmitterタグに参照してください。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグをSortingタグの内部に置くことで、テーブルデータに対するソート機能と列選択機能を同時に実現することができます。
このタグをLineHighLightタグの内部に置くことで、テーブルデータに対する列選択と行ハイライト機能を同時に実現することができます。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・THの内容は選択不可です。
・テーブルのTABLE、TR、TH、TDにHTMLのID属性を設定することはできません。
・SelectionSubmitterタグとネスとして、選択されたセルのデータをサーバに送信する場合、送信されたデータはセルの中（TDタグ）に挟まれるすべての内容（インプットフィールドや画像などの場合はそのままHTMLコードを送信する）。
・ SelectionSubmitterタグとネストする場合は、SelectionSubmitterタグは必ずこのタグの一層下（SelectionSubmitterタグの一番近い親タグはこのタグであること）に置きます。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

選択された状態の背景色。デフォルトは"blue"。
fgColor | No | Yes
選択された状態の前景色。デフォルトは"white"。
multipleSelectable | No | Yes

複数選択可否のフラグ。デフォルトは"false"、複数選択不可。
cellDataSeperator | No | Yes

同行の各セルデータの間の区切り文字。デフォルトは","（カンマ）。
rowDataSeperator | No | Yes

複数行選択可能の場合の行データの間の区切り文字。デフォルトは"|"。
内部タグ | SelectionSubmitterタグ

選択された行のデータをサーバに送信する。
使用例 | 行選択と送信機能
<imtag:RowDataSelector bgColor="white" fgColor="red"
    multipleSelectable="true">
  <table border=1 bgcolor="#BFD0EE" bordercolor="#336699" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="form"
        application="taglib" service="testform"/>
</imtag:RowDataSelector>

SelectionSubmitter

CellDataSelector、ColumnDataSelector、またはRowDataSelectorタグ内部で、ネストして利用します。
このタグはCellDataSelector、ColumnDataSelector、またはRowDataSelectorタグで選択されたデータをサーバへ送信します。
このタグで送信用フォームとサブミットボタンを生成します。画面に表示するのは、サブミットボタンです。
Tagボディ | 空
制約 ・このタグはCellDataSelector、ColumnDataSelector、またはRowDataSelectorタグの一層下におく必要があります。（このタグの親タグはCellDataSelector、ColumnDataSelector、またはRowDataSelectorのいずれ一つ）
・このタグで生成されたサブミットボタンを押す場合、送信されたデータはTDの中のすべての内容であり、TD内部でインプットフィールドや画像などがある場合は、そのままインプットフィールドや画像のHTMLコードをサーバに送信します。
属性 | 名前 | 必須 | 実行時評価
formName | Yes | Yes
生成されたFORMの名称。
application | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-JavaEE FrameworkのService Frameworkである場合のapplication ID。urlと同時に指定することはできません。serviceと同時に指定する必要があります。
service | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-JavaEE FrameworkのService Frameworkである場合のservice ID。urlと同時に指定することはできません。applicationと同時に指定する必要があります。
url | No | Yes
選択されたデータをサーバへ送信する時に、送信対象がim-JavaEE Framework以外の一般画面である場合のURL。application・serviceと同時に指定することはできません。
parameterName | No | Yes
選択されたデータをサーバへ送信する時のパラメータ名。デフォルトは"data"。
styleClass | No | Yes
サブミットボタンに適用するCSSのクラス名。
label | No | Yes

サブミットボタンの上に表示する文字列。デフォルトは"送信"。
method | No | Yes
データサ送信方式。GetかPostの一つ。デフォルトは"POST"。
onClick | No | Yes
ボタンを押す時に実行するJavaScriptの関数名。HTMLのsubmitのonClickと同様。
target | No | Yes
サブミットのターゲット。HTMLのformのtarget属性の同様。
内部タグ | なし
使用例 | サブミットボタンの表示
<imtag:RowDataSelector bgColor="white" fgColor="red">
  <table border=1 bgcolor="#BFD0EE" bordercolor="#336699" width="50%">
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
  </table>
  <imtag:SelectionSubmitter formName="myform"
        application="taglib" service="testform"/>
</imtag:RowDataSelector>

LineHighLight

このタグの内部にあるテーブルにマウスのカーソルが重なった時、行の前景色と背景色が指定値に変わります。
このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグは、CellDataSelector・ColumnDataSelector・RowDataSelector・Sortingタグとネスト利用が可能です。
CellDataSelector・ColumnDataSelector・RowDataSelector・Sortingとネストする場合は、このタグがテーブルの一番外側に置く必要があります。
Tagボディ | JSP
制約

・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・CellDataSelector・ColumnDataSelector・RowDataSelector・Sortingとネストする場合は、このタグがテーブルの一番外側に置く必要があります。
・このタグは行（TR）単位で色を変えますため、行内部のセル（TD）にスタイルを単独に指定する場合、HTMLの制限で、該当セルのスタイルを変えることはできません。
属性 | 名前 | 必須 | 実行時評価
bgColor | No | Yes

カーソルが行と重なった時の行の背景色。デフォルトは"blue"。
fgColor | No | Yes
カーソルが行と重なった時の行の前景色。デフォルトは"white"。
内部タグ | なし

使用例 | 行のハイライト
<imtag:LineHighLight bgColor="#F5FDFF" fgColor="red">
  <table border=1 bordercolor="#336699" width="50%" >
    <tr bgcolor="#86AFFA">
      <th>ID</th>
      <th>ローマ字</th>
      <th>漢字</th>
    </tr>
    <tr>
      <td>001</td>
      <td>Tokyo</td>
      <td>東京</td>
    </tr>
    <tr>
      <td>002</td>
      <td>Kyoto</td>
      <td>京都</td>
    </tr>
  </table>
</imtag:LineHighLight>

Sorting

このタグの内部にあるテーブルに対して、各カラムのデータのソート機能を提供します。
ソートしたい列のTHをクリックすることで、該当列をソートすることができます。
選択されたTHの背景色と前景色はそれぞれbgColorClickとfgColorClick属性で指定します。
THを初期クリックする時は、該当列のデータを昇順で表示し、THに、昇順を表すアイコンを表示します。再度クリックすると、降順でデータを表示し、降順アイコンを表示します。

このタグの内部のHTMLテーブルは、DynamicTableやDBListPagingタグで作成されたテーブルを利用することができます。
このタグは、CellDataSelector・ColumnDataSelector・RowDataSelectorタグとネストすることができます。ネストする場合は、CellDataSelector・ColumnDataSelector・RowDataSelectorタグの外側に置く必要があります。
このタグはLineHighLightタグとネストすることができます。ネストする場合は、LineHighLightの中に置く必要があります。

(注意) DynamicTableやDBListPagingタグと連携し、DynamicTableやDBListPagingタグがページング機能を利用する場合、このタグは単なる画面に表示する分のデータをソートする。DynamicTableやDBListPagingのリスト全体をソートすることはできません。DynamicTableやDBListPagingのリスト全体をソートしたい場合は、DynamicTableやDBListPagingの内部タグのColumnのsortable属性を利用してください。
Tagボディ | JSP
制約 ・タグ内部には、HTMLのテーブルを一つしか放置できません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのネストや並列することはできません。
・タグ内部に放置されたHTMLのテーブルには、テーブルのROWSPANとCOLSPAN属性を利用することはできません。
・このタグでソートできるのは、文字列のみです。テーブル内に画像は入力フィールドのある場合のソートはあまり意味がないです。
・CellDataSelector・ColumnDataSelector・RowDataSelectorタグとネストする場合は、CellDataSelector・ColumnDataSelector・RowDataSelectorタグの外側に置く必要があります。
・LineHighLightタグとネストする場合は、LineHighLightの中に置く必要があります。
・このタグはJavaScriptでテーブルの内容をソートしますので、テーブルにあるデータはすべて文字列と認め、文字列の大小関係でソートします。
属性 | 名前 | 必須 | 実行時評価
bgColorClick | No | Yes

ソート対象列のTHをクリックする時の背景色。デフォルトは"navy"。
fgColorClick | No | Yes

ソート対象列のTHをクリックする時の前景色。デフォルトは"white"。
order | No | Yes

初期ソート順。asc（昇順）かdesc（降順）を設定できます。デフォルトは"asc"。
使用例 | テーブルデータのソート
<imtag:Sorting bgColorClick="#F5FDFF" fgColorClick="red">
  <table border=1 bgcolor="#BFD0EE" width="50%" bordercolor="#336699">
    <tr bgcolor="#86AFFA">
      <th width="30%">ID</th>
      <th width="32%">ローマ字</th>
      <th width="38%">漢字</th>
    </tr>
    <tr>
      <td width="30%">001</td>
      <td width="32%">Tokyo</td>
      <td width="38%">東京</td>
    </tr>
    <tr>
      <td width="30%">002</td>
      <td width="32%">Kyoto</td>
      <td width="38%">京都</td>
    </tr>
  </table>
</imtag:Sorting>

DynamicTable

動的テーブルを生成する機能を提供します。
このタグは、requestやsession内のListインスタンスをテーブルにバインドして、List内部のデータを表示することができます。ページング機能を利用する場合は、自動的に改ページ用リンクを出力し、ユーザ指定のページサイズ・インデックスサイズで、改ページ機能を提供します。
List内部のオブジェクトは、JavaBeanまたはMapに対応します。

このタグで生成されたテーブルは、CellDataSelector・RowDataSelector・ColumnDataSelector・Sorting・LineHighLightなどのタグ内で利用することができます。
Tagボディ | JSP
制約 ・Columnタグと組み合わせて使用する必要があります。
・同じページ内のtableID（DBListPagingを利用する場合のtableIDも同様）を重複することはできません。
・テーブルにバインドできるリストの内部要素は、JavaBeanまたはMapである必要があります。それ以外のオブジェクトをバインドすることはできません。
属性 | 名前 | 必須 | 実行時評価
tableID | Yes | Yes
このテーブルを一意識別するためのID。必ず指定してください。同じ画面で複数のDynamicTable（またはDBListPagingと併用）を利用する場合は、それぞれ違うtableIDを指定する必要があります。
list | Yes | Yes

テーブルにバインドするリストの参照名。このタグは該当参照名で、RequestとSessionからオブジェクトを検索します。該当参照名に対応するインスタンスはjava.util.Listを実現する必要があります。List内部には、JavaBean規約に従うJavaBeanオブジェクトまたはMapオブジェクトを利用することができます。
scope | No | Yes
Listを参照するスコープ。requestまたはsessionを指定することができます。未設定の場合、requestとsessionを順に検索します。デフォルトはrequestとなります。requestとsessionに同じ参照名がある場合はrequestが優先します。
width | No | Yes
生成されたテーブルの幅。デフォルトは"100%"。HTMLのTABLEのwidth属性に相当します。
border | No | Yes
生成されたテーブルの幅。デフォルトは"1"。HTMLのTABLEのborder属性に相当します。
styleClass | No | Yes
生成されたテーブルに適用するCSSのクラス名。HTMLのTABLEのclass属性に相当します。
paging | No | Yes
該当テーブルに対して、ページング機能を利用するかどうかの設定。"true"に設定することで、指定サイズのテーブルを出力し、指定位置に改ページ表示用のリンクを表示します。"false"の場合は、自動ページング機能を利用せず、リスト全体の内容をテーブルに表示します。デフォルトは"true"。
pageSize | No | Yes
自動ページング機能を利用する場合のページ毎の表示行数。デフォルトは"10"。
indexSize | No | Yes
改ページ用のページインデックス数の最大表示個数。デフォルトは"8"。
indexLocation | No | Yes
改ページ用のページインデックスの表示場所。テーブルの上("top")、下("bottom")、または両方("both")を指定することができます。デフォルトは"bottom"。
application | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのApplication ID。画面JSPがim-JavaEE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのApplication IDです。service属性と同時に指定する必要があります。
service | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのService ID。画面JSPがim-JavaEE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのService IDです。application属性と同時に指定する必要があります。
内部タグ | Columnタグ

テーブルにバインドするリストの内部の要素を表します。
使用例 | 動的テーブル生成
List内部の要素がMapである場合の例を挙げて説明します。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>
<%@ page contentType="text/html; charset=Shift_JIS" %>
<%@ page import="java.util.*"%>
<%
    ArrayList list = new ArrayList();
    for(int counter = -128; counter <127; counter++){
        HashMap map = new HashMap();
        map.put("strTest","str_"+counter);
        map.put("byteTest",new Byte(""+counter));
        char aChar = (char)counter;
        map.put("charTest",new Character(aChar));
        map.put("intTest",new Integer(counter));
        map.put("floatTest",new Float(counter));
        map.put("doubleTest",new Double(counter));
        if(counter%2 == 0)
            map.put("blnTest",new Boolean(false));
        else
            map.put("blnTest",new Boolean(true));
        map.put("dateTest",new Date());

        list.add(map);
    }

    request.setAttribute("list",list);
%>
<html>
    <head>
        <title>DynamicTable Map</title>
    </head>
    <body>
        <imtag:DynamicTable list="list" tableID="table_map"
            styleClass="test" pageSize="10" indexLocation="both"
            indexSize="10">
            <imtag:Column attribute="strTest" title="String"
                headerClass="header" styleClass="test" sortable="true"/>
            <imtag:Column attribute="intTest" title="int"
                headerClass="header" sortable="true"/>
            <imtag:Column attribute="byteTest" title="byte"
                headerClass="header" sortable="true"/>
            <imtag:Column attribute="charTest" title="char"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="floatTest" title="float"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="doubleTest" title="double"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="blnTest" title="boolean"
                 headerClass="header" sortable="true"/>
            <imtag:Column attribute="dateTest" title="date"
                 maxLength="10" headerClass="header" sortable="true"/>
            <imtag:Column content="FIXED DATA" title="FIXED"
                 headerClass="header"/>
        </imtag:DynamicTable>
    </body>
</html>
ページ番号の指定:
リクエストパラメータに以下のパラメータ名の属性を付加する事で
ダイナミックテーブルの表示するページを指定することが可能です。

[tableIDの値]_page_[list属性の値]

上記サンプルの2ページ目を表示する場合は以下のように指定してください。

<FORM action="foo/bar/table.jsp">
  <input type="hidden" name="table_map_page_list" value="2">
</FORM>

Column

DynamicTableタグまたはDBListPagingタグの中にネストして利用する内部タグです。
このタグはDynamicTableタグまたはDBListPagingタグの中でしか利用することができません。
DynamicTableまたはDBListPagingタグにバインドできるのはListで、ColumnタグはそのListの中の要素であるJavaBeanまたはMapの属性を表します。

Tagボディ | 空
制約 ・本タグを単独で利用することはできません。
・DynamicTableまたはDBListPagingタグの中でネストして利用する必要があります。
・このタグのattribute属性でJavaBeanのプロパティを指定するか、content属性で固定値を指定するか、必ず一つ設定してください。
・content属性の指定するカラムに対してはsortableを"true" にすることはできません。（固定値のソートは無意味ですので）
属性 | 名前 | 必須 | 実行時評価
attribute | No | Yes
親タグの DynamicTable または DBListPaging の list 属性で定義する Listオブジェクト内の要素であるJavaBean のプロパティ名、または Map の Key 名。 attributeに対応する内容がコラムデータとして表示される。 この属性が未指定の場合は、属性 content で固定値を指定されているかをチェックする。この属性を指定するか、 content 属性で固定値を書くかの一つが必要です。
title | Yes | Yes
該当するコラムのヘッダー (TH) に表示するコラム名称。必須。
width | No | Yes
該当カラムの表示幅。HTMLのTH（またはTD）のwidht属性に相当します。
headerClass | No | Yes
該当コラムのヘッダー（TH）に適用するCSSのクラス名。HTMLのTHのclass属性に相当します。
styleClass | No | Yes
該当コラムのデータ出力部（TD）に適用するCSSのクラス名。HTMLのTDのclass属性に相当します。
maxLength | No | Yes
該当カラムに表示するデータの最大表示字数。出力データの字数がこの設定値より大きい場合、最大表示字数を表示し、後ろの文字は" … "になります。 この属性を利用するセルデータにマウスを重ねることで、データ全体を表示することができます。
sortable | No | Yes
該当カラムでソート機能を利用するかのフラグの設定。"true"を設定することで、該当カラムの TH 部にリンクを生成します。リンクを初期クリックする時は、該当カラムのデータの昇順でリスト全体をソートし、 TH に昇順ソートのアイコンを表示します。再度クリックすることで、逆順（昇順→降順→昇順…）でリスト全体を再度ソートし、 TH のそばに逆順のアイコンを表示します。デフォルト値は"false"。DynamicTable と DBListPaging タグは Sorting タグでネストされることで、一ページに表示するデータをソートすることができますが、リスト全体のデータのソートするには、この属性を利用する必要があります。
content | No | Yes
固定値を出力したい場合は、この属性で固定値を設定します。ただし、固定値に対してのソート はできません。 この属性とattribute属性が同時に指定された場合は、この属性が優先されます。
内部タグ | なし

使用例 | DynamicTableとネストし、List内部はJavaBeanである場合の例

JavaBeanの構造は以下のようです。

/*
 * Bean test for DynamicTable tag.
 */

import java.util.Date;

/**
 * Bean test for DynamicTable tag.
 *
 * @author Seki
 */
public class TestBean {

    private String strTest;

    private byte byteTest;

    private char charTest;

    private int intTest;

    private float floatTest;

    private double doubleTest;

    private boolean blnTest;

    private Date dateTest;

    public TestBean(int counter) {
        this.strTest = "str_" + counter;
        this.byteTest = (byte) counter;
        this.charTest = (char) counter;
        this.intTest = counter;
        this.floatTest = counter;
        this.doubleTest = counter;
        if (counter % 2 == 0)
            this.blnTest = false;
        else
            this.blnTest = true;
        this.dateTest = new Date();
    }

    /**
     * @return Returns the byteTest.
     */
    public byte getByteTest() {
        return byteTest;
    }

    /**
     * @param byteTest
     *                   The byteTest to set.
     */
    public void setByteTest(byte byteTest) {
        this.byteTest = byteTest;
    }

    /**
     * @return Returns the charTest.
     */
    public char getCharTest() {
        return charTest;
    }

    /**
     * @param charTest
     *                   The charTest to set.
     */
    public void setCharTest(char charTest) {
        this.charTest = charTest;
    }

    /**
     * @return Returns the blnTest.
     */
    public boolean isBlnTest() {
        return blnTest;
    }

    /**
     * @param blnTest
     *                   The blnTest to set.
     */
    public void setBlnTest(boolean blnTest) {
        this.blnTest = blnTest;
    }

    /**
     * @return Returns the dateTest.
     */
    public Date getDateTest() {
        return dateTest;
    }

    /**
     * @param dateTest
     *                   The dateTest to set.
     */
    public void setDateTest(Date dateTest) {
        this.dateTest = dateTest;
    }

    /**
     * @return Returns the doubleTest.
     */
    public double getDoubleTest() {
        return doubleTest;
    }

    /**
     * @param doubleTest
     *                   The doubleTest to set.
     */
    public void setDoubleTest(double doubleTest) {
        this.doubleTest = doubleTest;
    }

    /**
     * @return Returns the floatTest.
     */
    public float getFloatTest() {
        return floatTest;
    }

    /**
     * @param floatTest
     *                   The floatTest to set.
     */
    public void setFloatTest(float floatTest) {
        this.floatTest = floatTest;
    }

    /**
     * @return Returns the intTest.
     */
    public int getIntTest() {
        return intTest;
    }

    /**
     * @param intTest
     *                   The intTest to set.
     */
    public void setIntTest(int intTest) {
        this.intTest = intTest;
    }

    /**
     * @return Returns the strTest.
     */
    public String getStrTest() {
        return strTest;
    }

    /**
     * @param strTest
     *                   The strTest to set.
     */
    public void setStrTest(String strTest) {
        this.strTest = strTest;
    }
}

JSPの呼び出し。

<%@ taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>
<%@ page contentType="text/html; charset=Shift_JIS" pageEncoding="Windows-31J" %>
<%@ page import="java.util.ArrayList"%>
<%@ page import="TestBean"%>
<%
    ArrayList list = new ArrayList();
    for(int i=-128;i<127;i++){
        TestBean bean = new TestBean(i+1);
        list.add(bean);
    }
    request.setAttribute("list",list);
%>

<html>
    <head>
        <title>DynamicTable JavaBean</title>
    </head>
    <body>

    <imtag:DynamicTable tableID="bean_table_1"list="list"
        styleClass="test" pageSize="10" indexLocation="both" indexSize="10">
         <imtag:Column attribute="strTest" title="String"
             headerClass="header" styleClass="test" sortable="true"/>
        <imtag:Column attribute="intTest" title="int"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="byteTest" title="byte"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="charTest" title="char"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="floatTest" title="float"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="doubleTest" title="double"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="blnTest" title="boolean"
             headerClass="header" sortable="true"/>
        <imtag:Column attribute="dateTest" title="date"
             headerClass="header" sortable="true"/>
        <imtag:Column content="FIXED DATA" title="FIXED"
             headerClass="header"/>
    </imtag:DynamicTable>
    </body>
</html>

DBListPaging

ベースモジュール（またはフレームワーク)のデータベース設定（またはマルチデータベース設定）で設定されたデータベースを参照し、データを読み込み、動的にテーブルの作成をします。
ページング機能を利用する場合は、自動的に改ページのリンクを出力し、ユーザ指定のページサイズ・インデックスサイズで、改ページ機能を提供します。

DynamicTableタグとの違いは、テーブルにバインドするListオブジェクトの取得先です。DynamicTableに利用できるListはrequestまたはsession内のListオブジェクトであればよいが、DBListPagingの場合は、ベースモジュール（またはフレームワーク）のデータベース設定で設定されたDBのテーブルからデータを取得します。
それに、ソート機能を利用する場合は、DynamicTableはList内のデータを比較してソートしますが、DBListPagingの場合は、SQL文のorder部を再構成してDBの再検索でソートします。

このタグで生成されたテーブルは、CellDataSelector・RowDataSelector・ColumnDataSelector・Sorting・LineHighLightなどのタグ内で利用することができます。
Tagボディ | JSP
制約 ・Columnタグと組み合わせて使用する必要があります。
・同じページ内のtableID（DynamicTableを利用する場合のtableIDも同様）を重複することはできません。
・tableName・dbColumns・where・orderなどのSQL文関連の属性の内容はSQL文規約に従う必要があります。
属性 | 名前 | 必須 | 実行時評価
tableID | Yes | Yes
このテーブルを一意識別するためのID。必ず指定してください。同じ画面で複数のDBListPaging（またはDynamicTableと併用）を利用する場合は、それぞれ違うtableIDを指定する必要があります。
tableName | Yes | Yes
データ取得対象テーブル名。複数テーブルからデータを取得したい場合は、SQL文規約で複数テーブルを指定することができます。
dbColumns | No | Yes
データ取得対象カラム名。複数カラムからデータを取得したい場合は、SQL文規約で指定することができます（","（カンマ）区切りでカラムを指定する）。未指定の場合は、"*"を利用して、tableNameで指定されたテーブルからすべてのカラムのデータを取得します。
where | No | Yes
データ取得用のSQL文の条件部。SQL文規約に従う必要があります。
order | No | Yes
データ取得用のSQL文のソート部。SQL文規約に従う必要があります。データ初期取得時は、この属性で指定された内容でデータをソートします。但し、サブタグのColumnタグのsortable属性を"true"に設定する場合、データをソートする時は、指定カラムをソート基準でSQL文のorder部を再構成してDBを再検索しますので、ここのorder属性の指定が無視されます。
group | No | Yes
ベースモジュール（またはフレームワーク）のデータベース（またはマルチデータベース）設定で設定されたデータベース参照名です。未指定の場合、ログインユーザのログイングループIDを利用します。
width | No | Yes
生成されたテーブルの幅。デフォルトは"100%"。HTMLのTABLEのwidth属性に相当します。
border | No | Yes
生成されたテーブルの幅。デフォルトは"1"。HTMLのTABLEのborder属性に相当します。
styleClass | No | Yes
生成されたテーブルに適用するCSSのクラス名。HTMLのTABLEのclass属性に相当します。
paging | No | Yes
該当テーブルに対して、ページング機能を利用するかどうかの設定。"true"に設定することで、指定サイズのテーブルを出力し、指定位置に改ページ表示用のリンクを表示します。"false"の場合は、自動ページング機能を利用せず、リスト全体の内容をテーブルに表示します。デフォルトは"true"。
pageSize | No | Yes
自動ページング機能を利用する場合のページ毎の表示行数。デフォルトは"10"。
indexSize | No | Yes
改ページ用のページインデックス数の最大表示個数。デフォルトは"8"。
indexLocation | No | Yes
改ページ用のページインデックスの表示場所。テーブルの上("top")、下("bottom")、または両方("both")を指定することができます。デフォルトは"bottom"。
application | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのApplication ID。画面JSPがim-JavaEE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのApplication IDです。service属性と同時に指定する必要があります。
service | No | Yes
改ページリンクを生成する時に使い、該当タグの利用画面を表示するためのService FrameworkのService ID。画面JSPがim-JavaEE FrameworkのService Frameworkを利用して画面遷移する場合、該当画面へ遷移するためのService IDです。application属性と同時に指定する必要があります。
内部タグ | Columnタグ

テーブルにバインドするリストの内部の要素を表します。
使用例 | データベースからデータを取得し、テーブルにバインドします
<imtag:DBListPaging tableID="usertable" tableName="b_m_user"
    dbColumns="user_cd,user_name" order="user_cd desc"
    styleClass="test" pageSize="10" indexLocation="both"
    indexSize="10">
    <imtag:Column attribute="user_cd" title="Code" headerClass="header"
        styleClass="test" sortable="true"/>
    <imtag:Column attribute="user_name" title="Name" headerClass="header"
        sortable="true"/>
</imtag:DBListPaging>

複数テーブルからデータを取得する場合の例：
<imtag:DBListPaging tableID="userportaltable"
    tableName="b_m_user a,b_m_user_portal b"
    dbColumns="a.user_cd,a.user_name,b.layout_cls"
    where="a.user_cd=b.user_cd"
    order="a.user_cd desc" styleClass="test" pageSize="10"
    indexLocation="both" indexSize="10">
    <imtag:Column attribute="user_cd" title="Code" />
    <imtag:Column attribute="user_name" title="Name" />
    <imtag:Column attribute="layout_cls" title="Layout" />
</imtag:DBListPaging>

Validate

入力チェックのJavaScriptを自動生成する入力フィールドを提供します。生成された入力フィールドは設定条件に従ってJavaScriptでチェックを行います。
このタグで生成できる入力フィールドは、以下の三種類です。
    ・英数字入力フィールド
    ・数値入力フィールド
    ・日付入力フィールド

このタグで生成された入力フィールドに対するチェックのタイミングは、デフォールトで入力フィールドのonBlur()時です。入力フィールドの所属するFormのonSubmit()時にも入力チェックを行いたい場合は、FormのonSubmit()に、"return validate_check_xxx(yyy)"のようなJavaScript式を埋め込む必要があります。（xxxの部分はこの入力フィールドの名称（name属性で指定された名称）であり、yyyの部分は、生成された入力フィールドを参照できるJavaScriptのオブジェクト名である）

このタグで生成された入力フィールドは、Service FrameworkのFormタグ内部でのネスト利用ができます。
Tagボディ | JSP
制約

・タグの所属するFormのonSubmitに、"return validate_check_xxx(yyy)"のようなJavaScript式を埋め込む必要があります。（xxxの部分はこの入力フィールドの名称（name属性で指定された名称）であり、yyyの部分は、生成された入力フィールドを参照できるJavaScriptのオブジェクト名である）
・Validateタグの利用するFormのサブミットボタンに対して、DblClickForbiddenを適用する場合、FormのonSubmitイベントが実行できなくなるため、Validateに対するチェックタイミングはonBlur()のみになります。
・NetScapeを利用する場合、Netscapeの仕様により、サブミット時、onSubmitイベントとコントローラのonBlurイベントがほぼ同時に発生するので、二重チェックを防ぐため、チェックタイミングはFormのonSubmitイベントのみになります。
属性 | 名前 | 必須 | 実行時評価
name | Yes | Yes
入力フィールドの名前。必須属性です。HTMLのinputタグのnameに相当します。同じページでこのタグを複数利用する場合は、この属性を必ず違う値に設定する必要があります。
canNull | No | Yes
該当入力フィールドにヌル（何も入力しない）を許可するかの設定。"true"に設定しますと、入力フィールドに何も設定しなくても警告が出力されません。"false"を設定すると、入力フィールドに何も設定しないと警告が出力されます。デフォルトでは"false"。
fgColor | No | Yes
入力フィールドの前景色。デフォルト値は"black"。
bgColor | No | Yes
入力フィールドの背景色を。デフォルト値は"white"。
errorBgColor | No | Yes
入力エラー時の入力フィールドの背景色。デフォルトは"red"。
errorFgColor | No | Yes
入力エラー時の入力フィールドの前景色。デフォルトは"white"。
errorMsg | No | Yes
入力エラーが発生した時にユーザへ提示するエラーメッセージ。
size | No | Yes
入力フィールドのサイズ。HTMLのinputタグのsizeに相当します。
type | Yes | Yes
入力フィールドの入力チェックのタイプ。値と入力チェックの対応は下記のようになります。必須属性です。

type | 入力チェックのタイプ
ascii | 英数字チェック
number | 数値チェック
date | 日付チェック

この属性を"ascii" に設定することで、入力できる内容は半角の英数字に限定します。それ以外の内容を入力しますと、エラーメッセージを出力します。
この属性を"number" に設定することで、入力できる内容は半角の数字（設定により、整数と小数を入力することは可能）に限定します。それ以外の内容を入力しますと、エラーメッセージを出力します。
この属性を"date" に設定することで、入力できる内容は指定フォーマットの半角の日付に限定します。それ以外の内容を入力しますと、エラーメッセージを出力します。
dateSeperator | No | Yes
日付チェックの場合の年月日を区切るマークを指定します。属性dateSeperatorを「/」に設定する場合、入力フィールドに20040415を入力するとエラーになり、2004/04/15を入力すると正しいです。デフォルトでは、年月日に区切り文字なし（20040415）。この属性はtypeが"date"に設定される場合のみ有効になります。
maxLength | No | Yes

入力フィールドに入力できる内容の最大の長さ。HTMLのinputのmaxLengthに相当します。
inte | No | Yes
入力できる整数の最大桁数。デフォルトは"9"。type属性が"number"の場合のみ有効になります。
frac | No | Yes
入力できる小数部分の最大桁数。デフォルトは"0"。type属性が"number"の場合のみ有効になります。
maxNum | No | Yes
入力できる数値の最大値。フィールドに入力された値がこの値より大きい場合にエラーメッセージを出力します。デフォルトは"999999999"です。type属性が"number"の場合のみ有効になります。
minNum | No | Yes
入力できる数値の最小値。フィールドに入力された値がこの値より小さい場合にエラーメッセージを出力します。デフォルトは"-999999999"です。type属性が"number"の場合のみ有効になります。
maxDate | No | Yes
入力できる日付の最大値。フィールドに入力された値がこの値より大きい場合にエラーメッセージを出力します。デフォルトは"20991231"です。type属性が"date"の場合のみ有効になります。
minDate | No | Yes
入力できる日付の最小値。フィールドに入力された値がこの値より小さい場合にエラーメッセージを出力します。デフォルトは"19000101"です。type属性が"date"の場合のみ有効になります。
styleClass | No | Yes
生成された入力フィールドに適用するCSSのクラス名。HTMLのinputのclass属性に相当します。
value | No | Yes
入力フィールドの初期値を設定する。minDateやmaxDateなどの属性で範囲を指定する場合は、この初期値は範囲内にある必要があります。
内部タグ | なし

使用例 | 入力フィールドを出力します
<Form name="form_ascii"
    onSubmit="return validate_check_input_ascii(
    this.input_ascii)" >
    <imtag:Validate name="input_ascii" type="ascii"
        size="20" maxLength="20" styleClass="ascii"/>
    <input type="submit" value="送信">
</Form>

<Form name="form_number"
    onsubmit="return validate_check_input_number(
    this.input_number)" >
    <imtag:Validate name="input_number" type="number"
        size="20" maxLength="20" styleClass="number"
        inte="5" frac="2" minNum="-100" maxNum="100"
        bgColor="lightgreen"
        errorMsg="-100から100までの数字を入力してください" />
    <input type="submit" value="送信">
</Form>

<Form name="form_date"
    onsubmit="return validate_check_input_date(
        this.input_date)" >
    <imtag:Validate name = "input_date" type="date"
        size="20" maxLength="20" dateSeperator="/"
        minDate="20000101" maxDate="20100101" styleClass="date"
        errorMsg="2000/01/01から2010/01/01までの日付を
        \"/\"区切りで入力してください。" />
    <input type="submit" value="送信">
</Form>

DblClickForbidden

HTMLのコントローラのボタン・サブミットボタン・イメージボタン・リンクの二次クリックを防止するためのタグです。
ボタン（またはサブミットボタン・イメージボタン・リンク）を一旦クリックすると、そのボタン（またはサブミットボタン）を無効状態にし、再度クリック不能にします。useTimer属性を"true"にすることで、timer属性で定義された時間を経つと、またクリックできるようになります。

このタグの内部は、Service FrameworkのSubmitタグまたはLinkタグを置くことができます。Service FrameworkのSmartLinkタグとのネストはできません。
Tagボディ | JSP
制約 ・このタグの中には、必ずHTMLのbutton、submit、imageボタンまたはリンクがあります。
・ボタンにonClickイベントがある場合、onClickイベントの内容は必ず""で囲む必要があります。（例：onClick=”testFunction()”）。
・リンクの場合、リンクのhref属性は必ず""で囲む必要があります。
・HTMLの仕様により、サブミットボタンを使用せずにフォームをサブミットする場合、フォームのonSubmitイベントが実行できないので、フォームにonSubmitイベントを利用しないほうが望ましいです。
・リンクの場合、IEとNestcapeの仕様により、多少表示スタイルが違いますことにご了承ください。（機能的には影響ありません）
・このタグの内部に、SelectionSubmitterタグをネストすることはできません。
属性 | 名前 | 必須 | 実行時評価
type | Yes | Yes
ダブルクリック禁止対象のコントローラの種別。指定できる値は"button"（HTMLの<input type="button">）、"submit"（HTMLの<input type="submit">）、"image"（HTMLの<input type="image">）、"link"（HTMLの<a>）です。
useTimer | No | Yes
タイマー機能の利用フラグ。"true"にすることで、timer属性で定義された時間を経つと、またクリックできるようになります。デフォールト値は"false"。
timer | No | Yes
タイマー機能の利用する場合のダブルクリック禁止時間。msで指定してください。デフォールト値は"1000"ms、即ち1秒です。
内部タグ

Service FrameworkのLink、Submit。

リンクやボタン、サブミットボタンを生成できるタグ。

使用例 | ダブルクリックを禁止します。
ボタンの場合。一回クリックすると、ボタン無効にし、2秒経ったらまたクリックできるようになります。
<imtag:DblClickForbidden type="button"
    useTimer="true" timer="2000">
    <input type="button" value="ボタン２">
</imtag:DblClickForbidden>
Service FrameworkのLinkタグとネストして利用する例。
<imtag:DblClickForbidden type="link"
    useTimer="true" timer="2000">
    <imartj2ee:Link application="taglib" service="testform" target="_blank">
        <imartj2ee:Param name="param1" value="value1"/>
        <imartj2ee:Param name="param2" value="value2"/>
         リンク２
    </imartj2ee:Link>
</imtag:DblClickForbidden>

BackForbidden

ブラウザの戻るボタン機能を無効にするタグです。
戻るボタンを使って、特定の画面へ戻ることをできないようにするには、その画面でこのタグを利用することができます。
このタグは利用するJSP画面の任意の位置に置くことができます。

このボタンを利用した効果は、 利用画面の戻るボタン機能を禁止することではなくて、利用からからの遷移先画面での戻るボタン機能を禁止するのです。

このタグでは、以下のClientSideJavaScriptを使用します。
window.history.forward(1);
戻るボタン機能を禁止する画面において、戻るボタンが押された場合、前の画面にはもどりませんが、戻るボタンを押された画面はリロードされます。

例：
画面１でこのタグを利用します。画面１に画面２へのリンクがあります。リンクをクリックして画面２に遷移します。すると、画面２で戻るボタンを押しても、画面１へ戻ることはできなくなります。

このタグに属性はありません。

Tagボディ | JSP
制約 | 特になし
属性 | 名前 | 必須 | 実行時評価
使用例 | 戻るボタンを禁止します。
<imtag:BackForbidden/>

PopMenu

XMLファイルで定義されたメニュ項目をポップアップメニュの形式で表示します。
メニュ項目には、初期表示のメニュ主体部分とサブメニュに分かれています。 メニュ主体部分は画面に初期表示され、サブメニュは主体部分にマウスが当たった時にポップアップして表示されます。
サブメニュには、ポップアップ時の方向があります。属性のpositionでポップアップの方向をコントロールすることができます。
メニュ項目の定義ファイルXMLの形式は以下のようです。

<popmenu>            ルートノード

  <menu>             メインメニュ項目。

    id               メインメニュID。それぞれ違うIDを設定する必要があります。

    caption          メインメニュのキャプション。画面に表示します。

    icon             メニュ項目の前に表示するアイコンのURL。<Application Runtime>/doc/imart以下の相対パスを指定。

    link             メニュ項目クリック時に遷移するURL。一般画面に遷移する時に使います。

    target           リンクのターゲット。HTMLの<A>のtargetに相当します。

    application      Service Frameworkの画面に遷移する時のapplication ID。

    service          Service Frameworkの画面に遷移する時のservice ID。

    width            該当メインメニュ項目の高さ。

    height           該当メインメニュ項目の幅。

    <param>          リンクのパラメータ。遷移先画面に渡します。

      name           パラメータ名。

      value          パラメータ値。

    <item>           サブメニュ項目

      id             サブメニュID。それぞれ違うIDを設定する必要があります。

      caption        サブメニュのキャプション。ポップアップ時に表示されます。

      icon           メニュ項目の前に表示するアイコンのURL。<Application Runtime>/doc/imart以下の相対パスを指定。

      link           メニュ項目クリック時に遷移するURL。一般画面に遷移する時に使います。

      target         リンクのターゲット。HTMLの<A>のtargetに相当します。

      application    ServiceFrameworkの画面に遷移する時のapplication ID。

      service        ServiceFrameworkの画面に遷移する時のservice ID。

      width          サブメニュ項目の高さ。

      height         サブメニュ項目の幅。

      <param>        リンクのパラメータ。遷移先画面に渡します。

        name         パラメータ名。

        value        パラメータ値。
・ "<>"で囲まれたのはタグでその他は該当タグの属性です。
・ <menu>と<item>の属性の中に、linkとapplication/serviceのどちらかしか指定できません。
Tagボディ | JSP
制約

・XML定義ファイルの<menu>と<item>の属性の中に、linkとapplication/serviceのどちらかしか指定できません。
・XML定義ファイルの各項目のid属性には、必ず違う値を指定してください。
・PageBaseの画面を呼び出すことはできません。
・PopMenuタグからService Frameworkを呼び出す場合は、事前にConnectServletが呼ばれている必要があります。
属性 | 名前 | 必須 | 実行時評価
xml | Yes | Yes
メニュ内容を定義するXMLファイルのパス。必須。<Application Runime>/WEB-INF/classes以下のパスを指定してください。V5では、PopMenuタグ用のxmlファイルをWEB-INF/classesの配下に保存することになります。
bgColor | No | Yes
メニュの背景色。デフォルト値は"#E0E0E0"。
fgColor | No | Yes
メニュの前景色。デフォルト値は"#0000FF"。
borderColor | No | Yes
メニュのボーダーの色。デフォルト値は"#000000"。
mouseOverBgColor | No | Yes
メニュにマウスが当たった時の背景色。デフォルト値は"#C0C0C0"。
mouseOverFgColor | No | Yes
メニュにマウスが当たった時の前景色。デフォルト値は"red"。
height | No | Yes
メニュ項目の高さ。デフォルト値は"22"。
width | No | Yes
メニュ項目の幅。デフォルト値は"110"。
position | No | Yes

メニュの画面にある位置。実際には、メニュ自体は画面のどこにでも配置することができますが、この属性を利用して、サブ項目をポップアップ時の方向をコントロールします。この属性に指定できる値は"left"、"right"、"top"、"bottom"の四つ。サブメニュのポップアップ方向は、この設定値の相対側になります。"left"を指定する場合、サブメニュは右方向へポップアップします。"bottom"を指定する場合、サブメニュは上方向にポップアップします。デフォルト値は"left"（右方向へポップアップ）。
fontFamily | No | Yes

メニュ文字のフォント。
showTime | No | Yes
サブメニュのポップまでの待ち時間。デフォルト値は"350"で、単位はミリ秒。
mainMenuFontSize | Yes
メニュ主体部の文字サイズ。デフォルト値は"9"、単位は"pt"。
mainMenuFontAlign | No | Yes
メニュ主体部の文字整列方法。デフォルト値は"left"。
subMenuFontSize | No | Yes
サブメニュの文字サイズ。デフォルト値は"9"、単位は"pt"。
subMenuFontAlign | No | Yes
サブメニュの文字整列方法。デフォルト値は"left"。
内部タグ | なし

使用例 | ポップアップメニュを生成します
<imtag:popmenu xml="popmenu.xml" fgColor="black" bgColor="whitesmoke"
    showTime="200" borderColor="#000000" mouseOverBgColor="#DDDDDD"
    mainMenuFontAlign="left" position="top"/>

XMLのソース例：

<?xml version="1.0" encoding="shift_jis"?>
<popmenu>
  <menu id="spread" caption="スプレッドシート">
    <item id="cell" caption="セルデータ選択"
      link="../spread/CellDataSelector.jsp" target="content"/>
    <item id="row" caption="行データ選択"
      link="../spread/RowDataSelector.jsp" target="content"/>
    <item id="column" caption="列データ選択"
      link="../spread/ColumnDataSelector.jsp" target="content"/>
    <item id="linehighlight" caption="行ハイライト"
      link="../spread/LineHighLight.jsp" target="content"/>
  </menu>
  <menu id="input" caption="入力制御">
    <item id="validate" caption="入力チェック"
      link="../input/Validate.jsp" target="content"
      icon="taglib/menu/images/icon5.gif"/>
    <item id="dbclick" caption="ダブルクリック防止"
      link="../input/DblClickForbidden.jsp" target="content"
      icon="taglib/menu/images/icon5.gif"/>
  </menu>
  <menu id="service" caption="サービスフレームワーク" width="160">
    <item id="maintenance" caption="商品情報メンテ"
      application="shopping" service="menu_to_seller_list" target="content"/>
    <item id="list" caption="商品一覧"
      application="shopping" service="menu_to_buyer_list" target="content"/>
  </menu>
</popmenu>

TabPane

このタグはタブ（Tab）メニュのコンテナーです。
このタグは、Tabタグとネストする必要があります。
Tagボディ | JSP
制約 ・同じ画面で、複数のTabPaneを利用する場合は、name属性をそれぞれ違う値に設定する必要があります。
・クライアント側のブラウザーがIEである場合、TabPaneタグをHTMLのTableにネストする時は、TabPaneのwidth属性を指定する必要があります。
属性 | 名前 | 必須 | 実行時評価
name | Yes | Yes
タブのコンテナーであるTabPaneの名前。一つの画面に複数のTabPaneがある場合は、それぞれ違う値を設定してください。
width | No | Yes
タブペインの。未指定の場合は、タブの名前とタブの内容により、自動調整します。明示的に指定することが望ましいです。
height | No | Yes
タブペインの高さ。未指定の場合は、デフォールト値を利用します。デフォールト値は"300"。
内部タグ

Tab

メニュ項目であるTab。
使用例 | タブメニュを生成します。
<imtag:TabPane name="mytabpane" height="400" width="500">
  <imtag:Tab text="セルデータ選択">
    タブコンテント１.
  </imtag:Tab>
  <imtag:Tab text="行データ選択" selected="true">
    タブコンテント２.
  </imtag:Tab>
  <imtag:Tab text="列データ選択">
    タブコンテント３.
  </imtag:Tab>
  <imtag:Tab text="ソース">
    タブコンテント４.
  </imtag:Tab>
</imtag:TabPane>

Tab

TabPaneの上で、各Tabを生成します。
このタグはTabPaneとネストする必要があります。このタグは単独で使うことができません。

このタグのBODY部分に、任意の内容を埋め込むことができます。
JSPのincludeタグで、外部JSPを含めることもできます。ただし、インクルードされたJSPのデータとこのタグの呼び出し元画面のデータの間に、矛盾を発生することはできません。

複数のタブのある場合、属性selectedを"true"にすることで、該当Tabが初期選択になります。
Tagボディ | JSP
制約

・ラベルのフォントサイズを指定することはできますが、あまり字が大きい過ぎますと、Tabの画像の表示がずれる可能性があります。
・一つのTabPaneに、selected属性を"true"に設定できるTabは一個しかありません。
・TabのBODY部分に、必ずなんらかの内容を書き込んでください。FrameworkをWebSphereやWebLogic上で動く場合、BODYにデータがなければ、Tab自体を表示することができません。（ベースモジュールの場合は問題ありません）
属性 | 名前 | 必須 | 実行時評価
text | Yes | Yes
タブのラベルの文字列。複数のTabのある場合、それぞれ違う値を設定する必要があります。必須。
selected | No | Yes

該当タブの初期選定フラグ。"true""false"で指定可能。デフォルトは"false"。"true"を指定する場合、画面初期表示時、該当Tabが選択状態で表示されます。同じTabPaneの中に、selected属性を"true"にするTabは一つしかないことにご注意ください。
font | No | Yes
ラベル文字のフォントスタイル。CSSのfont属性に相当します。デフォルト値は"9pt Tahoma"。
color | No | Yes
ラベル文字の色。デフォルト値は"black"。
使用例 | タブメニュを生成します。
JSPのincludeを利用する場合の例：
<imtag:TabPane name="mytabpane" height="400" width="500">
  <imtag:Tab text="セルデータ選択">
    <%@include file = "../spread/CellDataSelector.jsp"%>
  </imtag:Tab>
  <imtag:Tab text="行データ選択" selected="true">
    <%@include file = "../spread/RowDataSelector.jsp"%>
  </imtag:Tab>
  <imtag:Tab text="列データ選択">
    <%@include file = "../spread/ColumnDataSelector.jsp"%>
  </imtag:Tab>
</imtag:TabPane>

Push

送信側で入力されたメッセージをクライアント側にプッシュする部品です。
受信側のJSPで、このタグを利用することで、画面をリロードしなくても、動的に送信側のメッセージを取得し表示することができます。

属性clientが"send"である場合に、画面にプッシュメッセージ入力用のフォームを生成します。ユーザはこのタグの中で、入力フィールドをネストして書くことができます。
属性clientが"recv"である場合に、PushMessageタグと連携してプッシュメッセージを受け取って表示することができます。受信画面で、プッシュメッセージの受信用タグ以外に内容がある場合は、該当画面のPushタグをHTMLのBODY部全体を囲める必要があります。受信画面は、timeoutの設定値の時間内に、リアルタイムにプッシュされたメッセージを表示することができます。この時間を経つと、画面をリロードしない限り、新しくプッシュされたデータは表示されなくなります。

このタグは、受信側はtimeoutの設定値の時間内で、常にApplicationRuntimeの一つのスレッドを利用するため、この値がApplicationRuntimeのthreads設定値(同時実行スレッド数)を超えることはできません。例えば、ApplicationRuntimeの同時実行スレッド数が１０で、このタグの受信側のmaxConnectionが９の場合、受信画面は９つまで開けます。しかし、その他のリクエストは１つしか同時に処理されなくなります。プッシュ受信側のクライアントの利用者数とサーバのスレッド数の関係をよく考慮した上、適切に設定してください。

Tagボディ | JSP
制約

・受信側の画面（属性clientが"recv"に設定する場合）に、Pushタグを画面全体に一つしか放置できません。
・送信側の画面（属性clientが"send"に設定する場合）に、タグ内部の入力フィールド（フォームのコントローラであれば何でも可）は最大一つ放置することができる。複数ある場合は、最後のコントローラの値をプッシュの内容としてサーバに送信します。
・送信と受信のタグを一つの画面に置くことはできません。
・受信側の画面は、サーバ側でHTMLを再生成しますので、すべての画面スタイルをCSSにまとめる必要があります。画面要素にスタイルを設定したい場合は、各HTMLのclass属性を利用して設定してください。
・受信側の画面で、プッシュメッセージの受信用タグ以外に内容がある場合は、該当画面のPushタグをHTMLのBODY部全体を囲める必要があります。
・受信側の画面のcharsetとCSSの指定は、このタグのcharsetとcsshref属性を利用する必要があります。それに、csshref属性に指定するCSSファイルのパスは絶対パスを利用してください。

１つのクライアントマシンで複数のブラウザを利用して受信画面を開くことはできません。
属性 | 名前 | 必須 | 実行時評価
client | Yes | Yes

送信側か、受信側の指定。必須。"send"を指定する場合は送信側になり、送信用のフォームを生成します。"recv"を指定する場合は、受信側になり、サブタグのPushMessageと一緒にプッシュされたメッセージを表示します。
subject | Yes | Yes
プッシュメッセージのID。送信側は、このIDでメッセージをサーバに送信し保存します。受信側では、このIDを通してプッシュされたメッセージを取得します。
alertMsg | No | Yes
送信側でプッシュ対象内容をサブミット後の確認メッセージの出力フラグ。"true"に設定することで、確認メッセージを出力します。デフォルトは"false"。clientが"send"の場合のみ有効になります。
charset | No | Yes
受信側の画面のヘッダー部のMETAデータに出力する画面エンコーディング。client属性が"recv"の場合のみ有効になります。
csshref | No | Yes
受信側の画面のヘッダー部のファイル参照URL。client属性が"recv"の場合のみ有効になります。
timeout | No | Yes
受信側の画面の最大受信可能時間。受信側の画面は、この時間内でサーバからプッシュされたメッセージをリアルタイムに表示します。この時間を経つと、画面をリロードしない限り、新しくプッシュされたメッセージは表示されなくなります。デフォルトでは、１０分間を指定しています。
maxConnection | No | Yes
プッシュメッセージを受信できるクライアント（セッション）数の最大値。デフォルト値は１０。この値を超えるリクエストが来た場合は、エラーメッセージを表示します。受信側はtimeoutの設定値の時間内で、常にサーバの一つのスレッドを利用しますため、この値がApplicationRuntimeのthreads設定値(同時実行スレッド数)を超えることはできません。例えば、ApplicationRuntimeの同時実行スレッド数が１０で、このタグの受信側のmaxConnectionが９の場合、受信画面は９つまで開けます。しかし、その他のリクエストは１つしか同時に処理されなくなります。プッシュ受信側のクライアントの利用者数とサーバのスレッド数の関係をよく考慮した上、適切に設定してください。
内部タグ | PushMessage

プッシュメッセージ出力用

使用例 | メッセージのプッシュ機能
送信側の呼び出し
<imart:Push client="send" subject="notice" alertMsg="true">
    <input type ="text" name="test" value=""><br>
    <input type="submit"><input type="reset"><br>
</imart:Push>

受信側の呼び出し
<imart:Push client="recv" subject="notice"
    charset="shift_jis" csshref="/imart/css/taglib.css" >
    <imart:PushMessage style="textarea" cols="50" rows="10"
        styleClass="testcss"/><BR>
    <imart:PushMessage style="text" styleClass="testcss"/><BR>
    <imart:PushMessage style="table" width="100%" styleClass="testcss" />
</imart:Push>

PushMessage

プッシュされたメッセージを受信し表示するためのタグです。
このタグはPushタグの内部でしか利用できません。

このタグは指定のスタイルでプッシュされたデータを表示します。
Tagボディ | JSP
制約 ・Pushタグの内部でしか利用できません。
・送信と受信のタグを一つの画面に置くことはできません。
・styleがtableに指定する場合、必ず該当タグのstyleClass属性を指定して、CSSのクラスでテーブルの背景色を指定してください。
・styleがtableに指定する場合、画面表示文字が重なったりする場合は、画面をリロードしてください。
属性 | 名前 | 必須 | 実行時評価
style | Yes | Yes

プッシュされたデータの表示スタイル。"text"（テキストフィールド）、"textarea"（テキストエリア）、"table"（テーブル）の一つを指定することができます。必須。
width | No | Yes
受信側のスタイルが"table"の場合のテーブルの幅。HTMLのTABLEのwidthに相当します。デフォルトでは"100%"。styleが"table"である場合のみ有効になります。
rows | No | Yes
受信側のスタイルが"textarea"の場合のtextareaの行数。HTMLのTEXTAREAのrowsに相当します。styleが"textarea"である場合のみ有効になります。
cols | No | Yes
受信側のスタイルが"textarea"の場合のtextareaのカラム数。HTMLのTEXTAREAのcolsに相当します。styleが"textarea"である場合のみ有効になります。
styleClass | No | Yes
出力対象に適用するCSSのクラス名。
内部タグ

なし

使用例 | 受信されたプッシュ内容を出力します。
<imart:Push client="recv" subject="notice"
    charset="shift_jis" csshref="/imart/css/taglib.css" >
    <imart:PushMessage style="textarea" cols="50" rows="10"
        styleClass="testcss"/><BR>
    <imart:PushMessage style="text" styleClass="testcss"/><BR>
    <imart:PushMessage style="table" width="100%"
        styleClass="testcss" />
</imart:Push>


intra-mart [JavaEE framework tag library]

i ntra-mart The Power for Enterprise Web Solution

intra-mart タグライブラリ (ユーティリティ) 仕様

注意事項

このページでは、JSPで利用するタグライブラリに関して、プログラム・インターフェースの詳細仕様を記載しています。

intra-mart Tag Library (Utility) 仕様

1. | タグライブラリ内に定義する属性名には、ＡＳＣＩＩ文字以外を用いてはいけません。
2. | タグライブラリ内に定義するタグ識別子・各属性名は、大文字・小文字を区別します。
3. | タグライブラリ内に定義する属性値は、"(定数値)" で定数値として扱われます。 その際、型は java.lang.String 型になります。また、スクリプトレット (<%= args %>等 : argsは変数名)を使用してJSP変数を属性値とした場合 には、当該JSP変数の型が属性値に渡されます。
4. | タグライブラリ内に単一属性を定義した場合、その属性値は真値(true)として扱われます。
5. | 組み合わせ可能なタグ一覧

使用方法

intra-mart JavaEE フレームワーク タグライブラリを使用するには、タグライブラリを使用する JSP のページで、以下のような taglib ディレクティブを指定する必要が あります。

<%@taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>

uri 属性には "http://www.intra-mart.co.jp/taglib/util" を指定してください。 prefix 属性は、そのページで使用される全てのタグライブラリの前に付加 される XML 名前空間識別子を指定するもので、任意の名前を付けても構いま せん。(以下、この API リストでは、 prefix 属性を "imtag" として説明します)

< サンプル >

<%@taglib uri="http://www.intra-mart.co.jp/taglib/util" prefix="imtag" %>
<%@ page contentType="text/html; charset=Shift_JIS" pageEncoding="Windows-31J" %>
<html>
<head>
<title>PopMenu</title>
<LINK REL="stylesheet" TYPE="text/css" HREF="../../css/taglib.css" TITLE="default">
<body>

<p>
<imtag:popmenu xml="PopMenu.xml" fgColor="black" bgColor="whitesmoke" showTime="200" borderColor="white" mouseOverBgColor="#DDDDDD" mainMenuFontAlign="left" position="bottom"/>

<a href="PopMenu.xml" target="content">XML Source</a>
</p>
</body>
</html>

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Tooles[External products connector]]]

i ntra-mart The Power for Enterprise Web Solution
外部ソフトウェア接続モジュール
[連携 API Connector]

概要

intra-mart サーバ以外の Java ベースアプリケーションから intra-mart に対してアクセスするためのコネクタです（Java 以外のプログラムから Java 環境を呼び出して利用することも可能です）。

このコネクタを利用することにより、任意の Java 環境から intra-mart Application Runtime における任意の処理を実行することが可能になります。

用途

コネクタは、Java クラスとして提供されますので、Java のインターフェースを利用できる環境であれば、どこからでも intra-mart システムと連携することが可能です。例えば、このコネクタを利用することにより、下記のようなことを実現することができます。

  • 他の製品環境からユーザ情報を intra-mart システムに同期させる場合に、このコネクタを利用してユーザデータを転送しユーザ情報をリアルタイムに同期させることができます。
  • ポータルサーバ製品と連携して、ポータル画面に intra-mart で実行した業務画面を表示させることができます。
  • 他のシステムに対して、Storage Service に保管されているファイルを転送することにより、システム間におけるドキュメントの共有をすることができます。

この他にも、工夫次第で様々な場面において、ダイナミックかつリアルタイムに複数のシステムと intra-mart システムを連携させることが可能です。

構成

外部ソフトウェア接続モジュールのインターフェースは、Java のクラスです。したがって、連携するアプリケーションは、Java インターフェースを利用できることが前提となります。また、Java インターフェースを利用することから、このモジュールが動作する環境には、Java-VM が必要になります。

連携用のコネクタクラスは、ネットワークを介して Application Runtime と連動します。したがって、ネットワークが利用可能な環境であることも前提条件となります。ただし、API は URL によってネットワーク通信を制御するため、開発者がネットワークを直接意識することはありません。

コネクタは Application Runtime に対して、HTTP 接続を行います。ネットワークは、API に指定された URL により解決されますが、この URL は intra-mart システムの運用形態により以下のような注意が必要です。

  • intra-mart システムがスタンドアロンで運用されている場合は、そのスタンドアロンサーバへの URL を指定します。
  • 分散サーバ型のシステム形態で intra-mart を運用している場合には、Web-Server Connector への接続 URL を指定します(URL の接続先として Application Runtime のアドレスおよびサーバポートを指定しても連携させることはできません)。

連携用に指定する URL には、専用のサーブレットパス(/imart/HTTPActionEventListener(標準))を指定します。通常のサーブレットパスである imart/intramart(標準)を指定しても連携させることはできません。

外部ソフトウェア接続モジュールは、大きく２つの種類に大別できます。１つはサーバ側ロジックで、もう１つはクライアント側ロジックです。
サーバ側ロジックは、サーバの Web-Application 領域(通常は WEB-INF 内)にプログラムを配置します。実行は、サーバ環境内です。主にビジネスロジックを記述する事になります。
クライアント側ロジックは、Application Runtime を利用する Java 実行環境内で実行します。プログラムの配置は、呼び出し側環境になります。

クラスの構成と配置

外部ソフトウェア接続モジュールを利用したクラスのコンパイルおよび動作には、以下のクラスアーカイブが必要になります。

  • imaca_client.jar (接続するクライアント用)
  • imaca_provider.jar (サーバ側ロジック用)

サーバ側ロジックはサーバで動作するため、上記アーカイブと共にサーバ側に配置します。配置先ディレクトリは、doc/imart/WEB-INF/ です（上記クラスアーカイブは、doc/imart/WEB-INF/lib にあります）。

クライアント側ロジックは、連携するアプリケーションの動作環境に上記クラスアーカイブと共に配置します。

動作に必要な環境構築

下記の手順で、連携に必要な環境を作成してください。

  1. コネクタの含まれるクラスアーカイブ・ファイル imaca_client.jar を連携させるアプリケーションが動作する環境にコピーしてください(jar ファイルは、CD-ROM 内にあります)。
  2. コピーしたアーカイブファイルの imaca_client.jar に対してクラスパスを設定してください。

これで準備は完了です。アプリケーションを動作させて intra-mart と連動させてみてください。うまく連動できない場合は、クラスパスの設定をもう一度確認してください。また、バージョンの異なる jar ファイルの場合、ファイル名が同じでも連携動作させることができませんので、パッチ等を適用した場合やリビジョンアップをした場合などは、十分注意をしてください。なお、intra-mart サーバに対してパッチを適用したときなどは、パッチに含まれる imaca_client.jar を上書きコピーしてご利用ください。

動作概要

指定された URL により HTTP 接続をして任意のアプリケーションからコネクタを介して Application Runtime で指定プログラムを実行します。

Application Runtime で実行するプログラムは、Java で記述してください。なお、Application Runtime で実行されるプログラムでは、intra-mart が提供している JavaEE開発モデル用の API をすべて利用することができます。これらの API を利用することにより、任意のスクリプト開発モデルのプログラム(Function Container に限ります)を実行することもできます。

このコネクタを利用してプログラムを実行した場合、通常の Web からの接続とは異なりますので、Application Runtime で実行されるプログラムにおいて intra-mart が提供している API の一部が利用できません。API の利用制限に関しては、バッチプログラムの制限に準じます。

API

コネクタクラスは、下記のパッケージに含まれています。

jp.co.intra_mart.foundation.service.client.application

サーバ側のインターフェースは、下記のパッケージに含まれています。

jp.co.intra_mart.foundation.service.provider.application

API の詳細に関しては、『JavaEE開発モデル』の アプリケーション共通モジュール を参照してください。

サンプルプログラム

この機能を利用したサンプルプログラムが用意されています。

ソースファイルは、インストールCDの iwp_afw/src/im_sample-src.zip に格納されています。 この機能を利用したサンプルプログラムのパッケージは jp.co.intra_mart.sample.service.client.application となっています。この中のソースを開き、ソース中に記載されているコメントを良くご覧ください。
サンプルは、以下に列挙するものが用意されています。

  • アカウント登録プログラム
  • スクリプト開発モデルプログラムへリンクするＵＲＬ作成プログラム (*)
  • サービスフレームワークへリンクするＵＲＬ作成プログラム (*)

    (* = ポータルサーバ製品との連携等に利用可能)

なお、コンパイルおよび実行には、doc/imart/WEB-INF/lib/imaca_client.jar , doc/imart/WEB-INF/lib/imaca_provider.jar および JSDK(Java Servlet Development Kit)が必要です。コンパイルや実行の際には、これらをクラスパスに定義してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Tooles[External products connector]]]

i ntra-mart The Power for Enterprise Web Solution
外部ソフトウェア接続モジュール

概要

intra-mart サーバ以外のソフトウェアから intra-mart に対してアクセスするためのモジュールです。

このモジュールを利用することにより、プログラムから intra-mart Application Runtime における任意の処理を実行することが可能になります。なお、このモジュールには２つの方法が用意されています。環境や目的に応じて使い分けてください。

用途

このモジュールにより、どこからでも intra-mart システムと連携することが可能です。例えば、このモジュールを利用することにより、下記のようなことを実現することができます。

  • 他の製品環境とあらゆる情報を intra-mart システムに同期させることができます。
  • intra-mart システムから他の製品環境に対して様々な情報を提供することができます。
  • ポータルサーバ製品と連携して、ポータル画面に intra-mart で実行した業務画面を表示させることができます。

この他にも、工夫次第で様々な場面において、ダイナミックかつリアルタイムに複数のシステムと intra-mart システムを連携させることが可能です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


外部ソフトウェア接続モジュール
連携 API コネクタ Web サービス


intra-mart[Server side JavaScript intra-mart Documentation.[Batch]]

i ntra-mart The Power for Enterprise Web Solution
アクセスセキュリティモジュール

機能概要

ユーザやロールなどのログインセキュリティ情報を操作します。

インポート／エクスポート

セキュリティに関するデータを指定のフォーマット形式のファイルからインポート／エクスポートすることができます。
この操作はシステム設定画面、及びプログラム・インターフェースから行うことができます。
画面から行う方法については、マニュアルを参照して下さい。
プログラム・インターフェースの詳細に関しては、パッケージ jp.co.intra_mart.foundation.security をご参照下さい。

各インポート・エクスポートデータのフォーマットは、こちらを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side Java intra-mart Documentation.[Batch]]

i ntra-mart The Power for Enterprise Web Solution
バッチ管理モジュール

プログラムの作成

プログラムファイルを Java 言語で作成します。
作成したプログラムはコンパイルをして、Application Runtime のクラスパスに設定されているディレクトリ内に保存します。なお、バッチプログラムは、サーブレット環境で実行されますので、サーブレットから参照できるようにクラスを保存してください(バッチプログラムを実行するサーブレットは、doc/imart/WEB-INF/lib/intramart.jarの中にあります)。

バッチ起動されるクラスには、下記のようなプロパティ情報がメソッド引数として渡されます。

引数 | （プロパティ情報）
├ | group | バッチ設定グループ名 (ログイングループＩＤ）
└ | name | バッチ名称

バッチ用プログラムに関しては、jp.co.intra_mart.foundation.service.provider.batch.ProcedureComponent クラスのＡＰＩ仕様を参照して下さい。

システム構成

バッチ機能を利用するためには、すべてのサービスをそれぞれインストールし、正常に動作する必要があります(Schedule Service から Application Runtime に接続できるように適切に接続ＵＲＬを設定してください。)。

バッチの登録と設定

バッチプログラムの登録と起動時間の設定は、i ntra-mart 起動後の『システム設定』-『バッチ』メニュー内で行います。
プログラム種別は、必ず『Java Class』を選択して下さい。

バッチ設定では、バッチ登録と運用可否設定があります。登録したバッチプログラムは、『有効』設定にしておかないと実行されません。
また、バッチサーバの実行状態を『運用中』にしなければバッチプログラムはロードされません。

設定画面の操作に関しては、マニュアルをご参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


[File Download]

i ntra-mart The Power for Enterprise Web Solution

ファイル・ダウンロード
(JavaEE開発モデル)

サンプルプログラム
filebox2.jsp
<%@ page contentType="text/html; charset=Windows-31J" %>

<%@ page import="java.util.Collection" %>
<%@ page import="java.util.Iterator" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.NetworkFile" %>

<%
    NetworkFile file = new NetworkFile("filebox");
    if(!file.isDirectory()){
        file.makeDirectories();
    }

    // ファイル一覧を取得
    Collection list = file.files();
    Iterator iterator = list.iterator();
%>

<HTML>
    <HEAD>
        <TITLE>ファイル ダウンロード</TITLE>
    </HEAD>
    <BODY>
        <H2>ファイル ダウンロード</H2>
        <TABLE border="1">
            <TR>
                <TH>ファイル名</TH>
                <TD><BR></TD>
            </TR>

        <%
            while( iterator.hasNext() ) {
                String fileName = (String) iterator.next();
        %>
                <TR>
                    <TD><%= fileName %></TD>
                    <TD><A href="download.jsp?file_name=<%= fileName %>">ダウンロード</A></TD>
                </TR>
        <%
            }
        %>
        </TABLE>
    </BODY>
</HTML>

download.jsp
<%@ page contentType="text/html; charset=Windows-31J" %><%@ page
import="jp.co.intra_mart.foundation.service.client.file.NetworkFile" %><%@ page
import="java.io.OutputStream" %><%

    String fileName = request.getParameter("file_name");
    NetworkFile file = new NetworkFile("filebox/" + fileName);

    response.reset();

    OutputStream os = response.getOutputStream();
    response.setContentType("application/octet-stream");
    response.setHeader("Content-Disposition", "attachment; filename=\"" + fileName + "\"");
    os.write(file.load());
    os.close();
%>

※詳細についてはフレームワークに同梱のサンプルを参照してください。
メニューパスは、[サンプル]-[JavaEE開発モデル]-[チュートリアル]-[ファイル操作]となります。

また、上記のサンプル以外にjp.co.intra_mart.foundation.http.FileSender APIを利用することも可能です。


[File Upload]

i ntra-mart The Power for Enterprise Web Solution

ファイル・アップロード
(JavaEE開発モデル)

サンプルプログラム
filebox1.jsp
<%@ page contentType="text/html; charset=Windows-31J" %>

<HTML>
    <HEAD>
        <TITLE>ファイル アップロード</TITLE>
    </HEAD>
    <BODY>
        <H2>ファイル アップロード</H2>
        <FORM action="upload.jsp" method="POST" enctype="multipart/form-data">
            <INPUT type="file" name="local_file">
            <INPUT type="submit" value="アップロード">
        </FORM>
    </BODY>
</HTML>

upload.jsp
<%@ page contentType="text/html; charset=Windows-31J" %>

<%@ page import="jp.co.intra_mart.common.aid.javaee.http.MultipartFormData" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.NetworkFile" %>

<%
    String msg = new String("ファイルをアップロードしました。");
    try{
        // リクエストから必要な情報を取得
        MultipartFormData data = new MultipartFormData(request);
        MultipartFormData.Entity entity = data.getEntity("local_file");
        String fileName = entity.getFileName();

        // アップロード先ディレクトリを作成
        NetworkFile dir = new NetworkFile("filebox");
        if(!dir.isDirectory()){
            dir.makeDirectories();
        }

        // Strage Serviceにファイルをアップロード
        NetworkFile file = new NetworkFile("filebox/" + fileName);
        boolean result = file.save(entity.getBytes());

        if(result == false){
            msg = "ファイルのアップロードが失敗しました。";
        }
    }
    catch(Exception e){
        msg = "ファイルのアップロードが失敗しました。";
    }
%>

<HTML>
    <HEAD>
        <TITLE>ファイル アップロード 結果</TITLE>
    </HEAD>
    <BODY>
        <%= msg %> <BR>
        <A href="filebox1.jsp">return</A>
    </BODY>
</HTML>

※詳細についてはフレームワークに同梱のサンプルを参照してください。
メニューパスは、[サンプル]-[JavaEE開発モデル]-[チュートリアル]-[ファイル操作]となります。

また、上記のサンプルで使用したMultipartFormData()については、
jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataに詳細説明があります。


intra-mart[Server side JavaScript BASE MODULE Documentation.[Mail]]

i ntra-mart The Power for Enterprise Web Solution
メール連携モジュール(JavaEE開発モデル)

準備(前提条件)

Application Runtime からネットワーク接続可能なマシン上にSMTPサーバ(RFC821 に準拠しているソフトウェア)を立ちあげて下さい。

Application Runtime の初期設定ファイル([install_directory]/conf/imart.xml)において、稼働中のSMTPサーバのアドレスおよびポートを指定した後に、i ntra-mart を起動して下さい。

メール連携モジュールを使用するには以下のライブラリが必要です。別途ダウンロードしてください。

  • JavaMail API 1.2
  • JavaBeans Activation Framework 1.0.2

    i ntra-mart WebPlatformの場合はダウンロードしたアーカイブを解凍し、全てのjarファイルを[install_directory]/lib/に配置してください。
    i ntra-mart AppFrameworkの場合は解凍したjarファイルをウェブアプリケーションサーバのクラスパスに追加してください。

    ＡＰＩ

    JavaMailSender を利用します。

    詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

    例

    JavaMailSender API を利用してメール送信プログラムを記述します。

    以下に、aaa@example.com, bbb@example.com, および ccc@example.com に対して「test mail」という表題の「send mail」という内容のメールを送信する例を示します。
    送信者アドレスは zzz@smtp.srv とします。

    <%@ page contentType="text/html; charset=Shift_JIS" pageEncoding="Windows-31J" %>
<%@ page import="jp.co.intra_mart.foundation.mail.MailSender" %>
<%@ page import="jp.co.intra_mart.foundation.mail.javamail.JavaMailSender" %>
<%@ page import="jp.co.intra_mart.foundation.mail.javamail.StandardMail" %>
<%@ page import="jp.co.intra_mart.foundation.service.client.file.NetworkFile" %>
<%
        boolean success = true;
        try {
            // 送信メールオブジェクトを生成
            StandardMail mail = new StandardMail();
            mail.addTo("aaa@example.com");
            mail.addTo("bbb@example.com");
            mail.addTo("ccc@example.com");
            mail.setFrom("zzz@example.com");
            mail.setSubject("test mail");
            mail.setText("send mail");

            // Storage Serviceから取得したファイルを添付
            NetworkFile file = new NetworkFile("attach.txt");
            mail.addAttachment("attach.txt", new String(file.load(), "8859_1"));

            // メール送信
            MailSender sender = new JavaMailSender(mail);
            sender.send();
        } catch (Exception e) {
            success = false;
            e.printStackTrace();
        }
%>
<HTML>
    <BODY>
    <% if (success) { %>
        <H2>Scucess<H2>
    <% } else { %>
        <H2>Failed<H2>
    <% } %>
    </BODY>
</HTML>

    • Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Application Common Master Table]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart アプリケーション共通マスタ API 仕様

アプリケーション共通マスタ表は、intra-mart 上で動作するすべてのアプリケーション・プログラムから共通に利用するためのデータベース・アーキテクチャです。
データの参照に関しては、各プログラムから自由に行っても構いませんが、規定の方法以外でのデータ更新を行った場合、他のアプリケーションが正常に動作しなくなることがあります。

詳細はアプリケーション共通マスタ説明資料（PDF）を参照して下さい。

  • ユーザの登録・更新・削除

    • ユーザ（ログインアカウント、ユーザプロファイル）の登録・更新・削除は、 グループ管理者でログインし、メニューの[ログイングループ管理]-[アカウント設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、
    ログインアカウントは    Server Managerルート/specification/dtd/account_6_1.dtd を参照して下さい。
    ユーザプロファイルはServer Managerルート/specification/dtd/user-profile-data_6_1.dtd を参照して下さい。
    ユーザ所属はServer Managerルート/specification/dtd/user-attach-data_6_1.dtd を参照して下さい。

    プログラムインターフェースとしては、ログインアカウントに対しては jp.co.intra_mart.foundation.security.account.AccountMangerクラスを使用して下さい。

    ユーザプロファイルに対しては、jp.co.intra_mart.foundation.datastore.application.domain.user.UserManagerクラスを使用して下さい。

    ユーザ所属に対しては、jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManagerクラスを使用して下さい。

  • 会社・組織の登録・更新・削除

    • 会社・組織の登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[組織設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/company-data_6_1.dtd およびcompany-post-data_6_1.dtdを参照して下さい。

    プログラムインターフェースとしては、 jp.co.intra_mart.foundation.datastore.application.domain.company.CompanyManagerクラスを使用して下さい。

  • パブリックグループの登録・更新・削除

    • パブリックグループの登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[パブリックグループ設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/public-group-data_6_1.dtd を参照して下さい。

    プログラムインターフェースとしては、 jp.co.intra_mart.foundation.datastore.application.domain.public_group.PublicGroupManagerクラスを使用して下さい。

  • プライベートグループの登録・更新・削除

    • プライベートグループの登録・更新・削除は、編集対象のユーザでログインし メニューの[ユーザ設定]-[プライベートグループ設定] から行って下さい。

    プログラムインターフェースとしては、 jp.co.intra_mart.foundation.datastore.application.domain.private_group.PrivateGroupManagerクラスを使用して下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


Messaging

JMS(Java Messaging Service)はキューイングシステムです。クライアントはキューにメッセージを追加し、サーバはそのメッセージを受け取ります

Consumer (MyListener)

Consumerはjavax.jms.MessageListenerを実装します。intra-mart WebPlatfoemはConsumerのonMessage()メソッドを個々の新しいメッセージとともに呼び出します。

// doc/imart/WEB-INF/classes/test/jms/MyListener.java

package test.jms;

import javax.jms.Message;
import javax.jms.MessageListener;

public class MyListener implements MessageListener {

    public void onMessage(Message msg) {
        System.out.println(msg);
    }
}

Configuration

設定は以下の三つから成ります:

  • Configuring the Queue
  • Configuring the MessageSender
  • Configuring the MessageListener

この例はJDBC storeを使用します。

<!-- doc/imart/WEB-IN/web.xml -->

<resource var="queue" jndi-name="jms/my-queue"
      type="com.caucho.jms.jdbc.JdbcQueue">
  <init>
     <queue-name>resin</queue-name>
     <data-source>jdbc/sample</data-source>
  </init>
</resource>

<resource var="jmsFactory" jndi-name="jms/factory"
      type="com.caucho.jms.JVMQueueConnectionFactory">
</resource>

<resource type="com.caucho.jms.resource.ListenerResource">
  <init>
     <connection-factory>${jmsFactory}</connection-factory>
     <destination>${queue}</destination>
     <listener type="test.jms.MyListener"/>
  </init>
</resource>

<resource jndi-name="jms/sender"
        type="com.caucho.jms.resource.MessageSenderResource">
 <init>
    <connection-factory>${jmsFactory}</connection-factory>
    <destination>${queue}</destination>
  </init>
</resource>

</web-app>

Clients

クライアントはメッセージを作り、それらをdestinationへ送ります。クライアントは以下のものが必要です。

  • Lookup the Destination and ConnectionFactory with JNDI
  • Create a Sender
  • Create a message
  • Send the message

import javax.jms.JMSException;
import javax.jms.Message;
import javax.jms.Queue;
import javax.jms.QueueConnection;
import javax.jms.QueueConnectionFactory;
import javax.jms.QueueSender;
import javax.jms.QueueSession;
import javax.jms.Session;
import javax.naming.Context;
import javax.naming.InitialContext;
import javax.naming.NamingException;

String queueName   = "jms/my-queue";  //"queue";
String factoryName = "jms/factory";  //"jmsFactory";

// look up the objects.
Context env = (Context) new InitialContext().lookup("java:comp/env");
Queue queue = (Queue) env.lookup(queueName);

QueueConnectionFactory factory;
factory = (QueueConnectionFactory) env.lookup(factoryName);

QueueConnection connection = factory.createQueueConnection();
QueueSession jmsSession = connection.createQueueSession(false, Session.AUTO_ACKNOWLEDGE);

QueueSender sender = jmsSession.createSender(queue);

// create the message
Message message = jmsSession.createTextMessage("hello, world");

// send the message
sender.send(message);


intra-mart[Server side JavaScript intra-mart Documentation.[Manner]]

i ntra-mart The Power for Enterprise Web Solution
コーディングルール
(JavaEE開発モデル)

注意事項

このページで記載されている内容は、 i ntra-mart アプリケーション(フレームワークの各画面も含む)をカスタマイズする際の必要事項になりますので、十分に理解した上で、i ntra-mart アプリケーションの開発を行うようにしてください。

JavaEE開発モデルに関しては、JAVA、JSP および Servlet 等、関連技術のルールに従ってください。

これ以外にintra-mart JavaEE開発モデルでのルールは、以下の通りとなります。

ルール

1. | i ntra-mart フレームワークで提供している機能において、すべてのＩＤに関して、以下に示す文字を含む名称を与えることはできません。 \ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab) (全角文字)
2. | ファンクション・コンテナ内で [install_directory]/conf/imart.xml を読み込んだり書き込んだりしてはいけません。 設定ファイルをむやみに変更することは、思わぬ誤動作の原因となります。 なお、[install_directory]/conf/imart.xml ファイル内の設定内容を変更した場合には、i ntra-mart システム全体の再起動が必要です。 ただし、i ntra-mart Administrator(サーバ管理ツール)上で設定内容を変更した場合には、i ntra-mart Administrator(サーバ管理ツール)から該当のサーバを再起動するだけで新しい設定内容が反映されます。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[JavaServerPages(Servlet)]]]

i ntra-mart The Power for Enterprise Web Solution
JavaServerPages(Servlet)について

前提

ブラウザから intra-mart に対して Web アクセスするためには、Schedule Service 以外のすべてのサービス および intra-mart Web-Server Connector(StandAlone 型の場合は必要ありません) をインストールして正しく動作していることが必要になります。

intra-martの初期起動

Application Runtime の初期起動時には、スクリプト開発モデルのプログラムが 実行されます。
詳しくは、スクリプト開発モデルのFunction Containerについてを参照して 下さい。

（スクリプト開発モデルと連携する必要がない場合には、特に設定や作業はいりません。）

JSP(Servlet)により生成されるWeb ページ

ブラウザから HTTP リクエストによりページを作成するために必要な JSP または Servlet クラスを実行します。
JSP や Servlet のソースファイルは、プログラムが実行される Application Runtime が動作しているコンピュータに保存します(Resource Service にプログラムを保存しても自動配信はされませんのでご注意下さい)。

JavaServerPages ページプログラムは、拡張子 *.jsp(XML 形式で記述する場合 *.xtp)となります。また、実行可能なディレクトリ(Application Runtime のインストールディレクトリ/doc/)に保存する事で実行する事ができます。

Servlet は、ＵＲＬとの関連付けを [install_directory]/conf/imart.xml で定義することで実行する事ができます(実行前に、クラスファイルを実行可能なディレクトリに保存してください)。

ブラウザから直接リンクをする場合は、該当のファイルを Web-Server Connector をインストールしたディレクトリ内に保存して下さい。
(画像ファイルなども、これに該当します。)

実行シーケンス(JSP)

ブラウザからリクエストがあった場合、以下のように処理が流れます。

  1. ブラウザからのリクエスト受付
  2. JSP ソースのコンパイル
  3. JSP の実行
  4. ページ返却

初めてリクエストされた場合 JSP ソースを JAVA のクラスにコンパイルするので、レスポンスに時間がかかりますが、以後はクラスがメモリ内に常駐しますので高速に動作します。また、１度作成された JAVA クラスは、ファイルとして保存され、サーバ再起動後も保存されているクラスファイルを実行します。ただし、JSP ソースが更新された場合は、保存されていたクラスファイルは破棄され、更新されたソースをもとにコンパイルが行われます。

実行シーケンス(Servlet)

ブラウザからリクエストがあった場合、以下のように処理が流れます。

  1. ブラウザからのリクエスト受付
  2. Servlet クラス の実行
  3. ページ返却

実行前に以下の準備が必要です。

  • java ソースのコンパイル
  • クラスパスの設定
  • ＵＲＬとクラスのマッピングを設定

Servlet クラスを作り直したり、設定を変更した場合には、Application Server の再起動が必要です。

Servlet クラスは、１度実行されるとメモリ内にクラスが保持されますので、高速に動作します。

メニューとの連携

JSP (または Servlet) をメニューに登録した場合、ログインユーザがメニューから JSP (または Servlet) のページを選択した場合、呼び出されたページプログラムにはメニューに指定した引数がＵＲＬ引数として渡されます。

スクリプト開発モデルとの連携

プレゼンテーションページから JSP(または Servlet) で開発されたページを呼び出すためには、通常のフォームタグ(<FORM<)やアンカータグ(<A<)を利用して、呼び出して下さい。href や action に指定するＵＲＬは、intra-mart のＵＲＬ（標準では http://host:port/imart/intramart）からの相対で指定するか、または完全形式のＵＲＬで指定して下さい。
JSP(または Servlet) のプログラム内で必要になる情報は、予めＵＲＬ引数として渡すように工夫するようにして下さい。

例）アプリケーションサーバのインストールディレクトリ/doc/myapp/myjsp.jsp を master というユーザＩＤ情報を伴って呼び出す場合
<FORM action="myjsp.jsp">

<INPUT type="hidden" name="account" value="master">
</FORM>

JSP(または Servlet) で開発されたページからプレゼンテーションページを呼び出す場合には、jp.co.intra_mart.foundation.http.SessionQueryを利用することでセッションを維持しつつ各ページが相互に連携する事ができます。

注意事項

JSP や Servlet にてユーザセッションの必要なアプリケーションを作成する場合は、Servlet エンジンの持つ HTTP セッションを利用して作成します。これにより、スクリプト開発モデルの画面やアクセスセキュリティ機能とセッション連携したアプリケーションを作成することが出来ます。

JSP ソースがコンパイルされると、インストールディレクトリ/work/ に JSP ソースから作成された JAVA のソースファイルとクラスファイルが作られます。エラーが発生した場合、これらのファイルを参照してデバッグ等を行って下さい(intra-mart WebPlatform の場合)。

intra-mart Application Server を分散インストールして、ネットワーク型でシステム運用している場合、各サーバで動作している Java クラス同士の変数の共有はできません。したがって、あるリクエストを処理しているスレッドと他のリクエストを処理しているスレッドで変数の共有は保証されません。プログラム間でのデータの共有には、HTTP セッションや Shared Memory Service 等の機能を利用するようにして下さい。

自作のクラスなどを利用する場合、Application Runtime の実行環境に対してクラスパスを設定する必要があります。クラスパスを設定するには、intra-mart Administrator を利用するか、または Application Runtime を実行している環境に対して設定するようにして下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Knowledge Search Module]]

i ntra-mart The Power for Enterprise Web Solution
統合検索ソリューション
ConceptBase連携

概要

統合検索ソリューションとは、データ資産から目的の情報を検索する機能のことです。

検索対象となるリソースは、ファイルやデータベース内の情報になります。

機能仕様

本機能は、(株)ジャストシステムの『ConceptBase』を利用しています（対応バージョンは ConceptBaseIV）。

ファイルやデータベース中の情報の検索を行います。
検索は、キーワードによる完全一致検索ではなく、類似情報検索が可能です。

連携仕様

(株)ジャストシステムの『ConceptBase』との連携は、「CBRPC-XML」のを利用して行います。
詳しくは(株)ジャストシステムの『ConceptBaseIV』のアプリケーション開発キットのマニュアルをご覧ください。

ファイル検索

多種多様のファイルの中から目的の情報をもつファイルを検索する機能です。
テキストファイルのみでなくWordやPDFファイルなどの検索も可能です。

データベース検索

データベースに保存されている情報からの検索を行います（当機能は、(株)ジャストシステム「CB RDBゲートウェイ」との連係機能を利用することにより可能になります）。
データベース中の任意の表中の各レコードを１つの文書として検索を行います。

前提条件

本機能を利用するためには、(株)ジャストシステムの『ConceptBaseIV』が必要になります。

Storage Serviceが稼働するService Pratform は Windows NT/2000 で動作させる必要があります（『ConceptBaseIV』の制約になります）。

準備

以下の手順でセットアップしてください。

手順

  1. Storage Serviceが稼働するService PlatformがインストールされているコンピュータにConceptBase サーバをインストールおよびセットアップします(すでに設定済みの場合は次へ進んで下さい)。

  2. Webゲートウェイ Java Servlet版を画面の指示に従いインストール作業をしてください)およびセットアップします(すでに設定済みの場合は次へ進んで下さい)。

  3. intra-mart intra-mart をインストールおよびセットアップします(すでに設定済みの場合は次へ進んで下さい)。

  4. ConceptBase サーバを起動します。

  5. intra-mart のすべてのサーバを起動します。

ConceptBase の利用方法等に関しては ConceptBase のマニュアルを参照して下さい。

検索ユーザの設定例

  1. ConceptBase サーバの動作する Windows の参加しているネットワークドメインのプライマリドメインコントローラとなっているWindows NT/2000 Server に管理者権限でログオンします。
  2. ドメインユーザマネージャーでユーザを追加設定します。
  3. 追加設定したユーザに対して Domain Users 権限（ロール）を与えます。
  4. ConceptBase が検索する対象ディレクトリを共有設定します。
  5. ConceptBase が検索する対象ディレクトリに対してロール Domain Users に対して参照権限を与えます。

詳しくは、ConceptBase のマニュアルを参照して下さい。

アンインストール

ConceptBase Server のアンインストールに関しては、ConceptBase のマニュアルに従って下さい。

ConceptBase 接続モジュール（CBSearchアプリケーション開発キット）は、コントロールパネル→アプリケーションの追加と削除からアンインストールすることができます。アンインストーラを起動して画面の指示に従って関連ファイルを削除して下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


統合検索モジュール メニュー

統合検索ソリューション
・仕様
・連携サンプル


intra-mart[intra-mart Documentation.[Knowledge Search Module]]

i ntra-mart The Power for Enterprise Web Solution
統合検索ソリューション
ConceptBase連携サンプル

概要

(株)ジャストシステムの『ConceptBaseIV』の「CBRPC-XML」を利用したサンプルです。
自然文検索の結果と、その詳細を表示することができます。

ログイン後のメニューの「サンプル」-「スクリプト開発モデル」-「統合検索」からサンプルを表示することができます。

サンプルファイル

サンプルファイルは、JAVAファイルとスクリプト開発モデルを利用して作成されています。

ファイル | 配置場所
JAVAファイル (CBRPC-XMLで問い合わせを行うjavaファイルです。) | doc/imart/WEB-INF/classes/jp/co/intra_mart/cb/CBGateWay.java （Application Runtimeが稼働するService Platform上）
スクリプト開発モデルファイル群 (検索を行うページ群です。) | pages/sample/knowledge/search （Resource Serviceが稼働するService Platform上）

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


ＡＰＩリスト(ColorList)

カラーチャート　（カラー名）

■ aliceblue
■ antiquewhite
■ aqua
■ aquamarine
■ azure
■ beige
■ bisque
■ black
■ blanchedalmond
■ blue
■ blueviolet
■ brown
■ burlywood
■ cadetblue
■ chartreuse
■ chocolate
■ coral
■ cornflowerblue
■ cornsilk
■ crimson
■ cyan
■ darkblue
■ darkcyan
■ darkgoldenrod
■ darkgray
■ darkgreen
■ darkkhaki
■ darkmagenta
■ darkolivegreen
■ darkorange
■ darkorchid
■ darkred
■ darksalmon
■ darkseagreen
■ darkslategray
         ■ darkslateblue
■ darkturquoise
■ darkviolet
■ deeppink
■ deepskyblue
■ dimgray
■ dodgerblue
■ firebrick
■ floralwhite
■ forestgreen
■ fuchsia
■ gainsboro
■ ghostwhite
■ goldenrod
■ gold
■ green
■ gray
■ greenyellow
■ honeydew
■ hotpink
■ indianred
■ indigo
■ ivory
■ khaki
■ lavender
■ lavenderblush
■ lawngreen
■ lemonchiffon
■ lightblue
■ lightcoral
■ lightcyan
■ lightgoldenrodyellow
■ lightgreen
■ lightgrey
■ lightpink
         ■ lightsalmon
■ lightseagreen
■ lightskyblue
■ lightslategray
■ lightsteelblue
■ lightyellow
■ lime
■ limegreen
■ linen
■ magenta
■ maroon
■ mediumaquamarine
■ mediumblue
■ mediumorchid
■ mediumpurple
■ mediumseagreen
■ mediumslateblue
■ mediumspringgreen
■ mediumturquoise
■ mediumvioletred
■ midnightblue
■ mintcream
■ mistyrose
■ moccasin
■ navy
■ navajowhite
■ oldlace
■ olive
■ olivedrab
■ orange
■ orangered
■ orchid
■ palegoldenrod
■ palegreen
■ paleturquoise
         ■ palevioletred
■ papayawhip
■ peachpuff
■ peru
■ pink
■ plum
■ powderblue
■ purple
■ red
■ rosybrown
■ royalblue
■ saddlebrown
■ salmon
■ sandybrown
■ seagreen
■ seashell
■ sienna
■ silver
■ skyblue
■ slateblue
■ slategray
■ snow
■ springgreen
■ steelblue
■ tan
■ teal
■ thistle
■ tomato
■ turquoise
■ violet
■ wheat
■ white
■ whitesmoke
■ yellow
■ yellowgreen


intra-mart[Server side JavaScript intra-mart Documentation.[customize]]

i ntra-mart The Power for Enterprise Web Solution
製品のカスタマイズ

規定

intra-mart では、製品として提供されたプログラムを自由にカスタマイズして利用することができます。
カスタマイズが可能なプログラムは、オープン・ソースとして提供されているプログラムファイル(*.ini，*.html，*.js，*.properties，*.java および ，*.jsp など)すべてが対象となります。

製品のソース・コードに対してカスタマイズをした場合、カスタマイズをしたプログラムおよび動作に関連のあるプログラム群に関して、同パッケージの提供元は動作保証をいたしません。 また、カスタマイズをしたことにより発生した不具合に関しては、サポート対象外となります。

環境移行の手順

カスタマイズしたプログラムを別の環境へ移行（例えば開発機から本番運用機への移行）する場合、以下の手順で移行を行って下さい。

  1. 移行先へ intra-mart をインストールします。
  2. 移行先環境の intra-mart に対してライセンス登録を行います（アプリケーションを追加インストールしていてソースを展開している場合には、ソース展開も行います）。
  3. 移行先環境の intra-mart を停止します。
  4. カスタマイズした各プログラムソース(ini, html および js)を元環境から移行先環境へコピーします。
  5. 移行先の intra-mart を起動します。

カスタマイズしたプログラムを移行する場合、Resource Service の pages/ ディレクトリ内にある html および js 以外のファイルと Permanent Data Service の treasure/ ディレクトリを上書きコピーしてしまわないように注意して下さい。万一、元環境から移行先環境に対してバイナリファイルの上書きコピーをしてしまいシステムが正常に動作しなくなった場合には、すべてのファイルを削除して移行先への intra-mart のインストールから再度行うようにして下さい。

注意事項

ソースが公開されているプログラムであっても、そのコード中に非公開のＡＰＩを利用している場合があります。これら、非公開ＡＰＩは予告なく仕様が変更されることがあるので注意が必要です。

製品のソースを直接カスタマイズした場合、カスタマイズをしたソースに関してはバージョンアップ対象外となります。パッチおよびバージョンアップ版のインストールの際にはソースが自動的に上書きされてしまうことがありますので、ご注意下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Original Application]]

i ntra-mart The Power for Enterprise Web Solution
アクセスセキュリティモジュールを利用しないで画面を構築する方法

概要

intra-mart では、アクセスセキュリティモジュールにとらわれない独自のアプリケーション作成を可能にするソリューションを標準機能として提供しています。

準備(インストール)

intra-mart をインストールガイドにしたがってインストールしてください。
分散システムを構築する場合には、すべてのサーバをインストールします。

インストールが完了したら、すべての Application Runtime のdoc/imart/WEB-INF/web.xmlにて 以下のフィルターマッピングの設定(<filter-mapping>)をすべて削除してください。
( intra-mart フレームワークの場合、この設定ファイル編集後に再デプロイを行ってください)

  • RequestCharacterEncodingFilter
  • ResponseCharacterEncodingFilter
  • URLAccessFilter
  • SessionFilter

作成(スクリプト開発モデル)

アプリケーション・プログラムを作成する場合、スクリプトファイルの動作仕様にしたがって、それぞれ目的にあったプログラムを記述していきます。

アプリケーションの動作概要と、スクリプトファイルの動作仕様に関しては、動作概要【 Application Runtime 篇 】およびPresentation Pageについてを参照して下さい。

作成したアプリケーションへは、以下のＵＲＬでアクセスできます（下記は標準インストールの場合の例です）。

  • http://<ホスト名>[:<ポート番号>]/imart/<作成したスクリプトのパス>.jssp

※<作成したスクリプトのパス>は、 Resource Service が管理しているリソースルートディレクトリからの相対形式で、 拡張子(.html および .js)を省略したものを指定して下さい。

作成(JavaEE開発モデル)

アプリケーション・プログラムを作成する場合、Servlet および JSP 等の仕様や im-JavaEE Framework の動作仕様にしたがって、それぞれ目的にあったプログラムを記述していきます。

動作仕様等に関しては、JavaServerPages(Servlet)について 、im-JavaEE Framework ＡＰＩリスト および製品同梱の im-JavaEE Framework 仕様書を参照して下さい。

なお、im-JavaEE Framework を利用して作成した画面へは、以下ＵＲＬにてアクセスできます（下記は標準インストールした場合の例です）。

  • http://<ホスト名>[:<ポート番号>]/imart/<アプリケーションID>-<サービスID>.service

注意事項

アクセスセキュリティモジュールを利用せずに画面を作成した場合、標準で提供されている一部の機能(API)が利用できません。

利用できないＡＰＩ(スクリプト開発モデル)
  • アクセスセキュリティに関連した機能
    • AccessSecurityManager.*
    • AccountManager.*
    • LicenseManager.*
    • LoginGroupManager.*
    • RoleManager.*
    • UserManager.*
    • Module.client.*
  • アプリケーション共通マスタに関連した機能
    • CategoryManager.*
    • CompanyManager.*
    • PrivateGroupManager.*
    • PublicGroupManager.*
    • Procedure.AppCommonUtil.*
  • ワークフロー機能
    • AckApplicant.*
    • AckItem.*
    • Acknowledge.*
    • AckUtil.*
  • その他
    • Module.alert.*
    • Module.external.*
利用できないＡＰＩ(JavaEE開発モデル)
  • アクセスセキュリティに関連した機能
    • jp.co.intra_mart.foundation.security.*
    • jp.co.intra_mart.foundation.acssecurity.*
  • アプリケーション共通マスタに関連した機能
    • jp.co.intra_mart.foundation.datastore.*
    • jp.co.intra_mart.foundation.appcomn.*
  • ワークフロー機能
    • jp.co.intra_mart.foundation.ackwkf.*

アクセスセキュリティモジュールを利用せずに画面を作成した場合、[install_directory]/conf/imart.xml 内の設定項目の中で有効に機能しないものがあります。

アクセスセキュリティモジュールを利用せずに画面を作成した場合、intra-mart の他のパッケージおよびアドオン・モジュールを追加インストールすることはできません。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript BASE MODULE Documentation.[Graph]]

i ntra-mart The Power for Enterprise Web Solution
グラフ描画・モジュール

機能概要

入力データをもとに画像ファイルを作成して、ブラウザ画面上にグラフ画面を表示します。

以下の５種類のグラフがサンプルとして用意されています。

  • 折れ線グラフ
  • 棒グラフ
  • 円グラフ
  • レーダーチャート
  • ポートフォリオ

プレゼンテーション・ページＡＰＩ

<IMART> タグを利用します。
<IMART> タグの type 属性に指定する値によって、異なるグラフを描画することができます。

type属性値 | グラフの種類
lineGraph | 折れ線グラフ
barGraph | 棒グラフ
circleGraph | 円グラフ
radarChart | レーダーチャート
portFolio | ポートフォリオ

（例） <IMART type="lineGraph">

詳細なプログラム・インターフェースに関しては、画面共通モジュール を参照下さい。

ファンクション・コンテナＡＰＩ

Drawer.* を利用します。

詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

例： ［折れ線グラフ］

プレゼンテーション・ページ
<HTML>
<HEAD>
<TITLE>Line Graph Sample</TITLE>
</HEAD>
<BODY>

<IMART type="lineGraph"
data=oData
image_width="300"
image_height="300"
data_min="-30"
data_max="60"
scale_count="20"
alt="IM_LineGraph">
</IMART>

</BODY>
</HTML>

<!-- End of File -->

<IMART type="lineGraph"> の data 属性 に対するバインド変数 oData は、ファンクション・コンテナで生成した描画データオブジェクトの格納されている変数名。

ファンクション・コンテナ

// バインド変数宣言
var oData; // 折れ線グラフ描画データ

// ページの初期化関数
function init() {
// 折れ線グラフ描画データオブジェクトの作成
oData.aCaption = new Array("１月", "２月", "３月", "４月", "５月", "６月");
oData.aData = new Array();

oData.aData[0] = new Object();
oData.aData[0].aData = new Array(50, 10, 30, 5, 30, 20);
oData.aData[0].sColor = "red";
oData.aData[0].nWidth = 5;

oData.aData[1] = new Object();
oData.aData[1].aData = new Array(10, 40, -20, 30, -10, 45);
oData.aData[1].sColor = "yellow";

oData.aData[2] = new Object();
oData.aData[2].aData = new Array(20, 30, 50, 25, 45, 55);
oData.aData[2].sColor = "green";
oData.aData[2].nStyle = new Array(10,10);
}

/* End of File */

描画された折れ線グラフ（例）

Headless のサポート

X11を搭載していないUNIXなどのOSは、グラフィックスをサポートしていないため通常グラフモジュールを使用することができません。 但し、ヘッドレスモードをサポートしているJava VMを使用している場合、Java環境変数を設定することにより非グラフィックス環境の場合でも グラフモジュールを使用することが可能です。

i ntra-mart WebPlatform の場合は、/conf/imart.xmlの以下の場所にJava環境変数を追加してください。

    .
    .
<command>
  <exefile>C:/j2sdk1.4.2_XX/bin/java</exefile>
  <option>-cp %SYSTEMCLASSPATH% -Xms%XMS% -Xmx%XMX% -Djava.awt.headless=true</option>
  <argument/>
</command>
    .
    .

i ntra-mart AppFrameworkの場合は、同様のJava環境変数をウェブアプリケーションサーバに設定してください。 Java環境変数の設定方法については、ウェブアプリケーションサーバのマニュアルを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


JavaScript API リスト概要

 JavaScript API リスト 概要

スクリプト開発モデルで利用可能なJavaScript API の概要です。

オブジェクトの概要
UserTransaction | データベーストランザクションのAPI。
WkfAgentSetting | 代理設定関連のAPI。
WkfApprover | 承認関連のAPI。
WkfDrafter | 起票関連のAPI。
WkfFlowInfo | フロー情報オブジェクトAPI。
WkfMailSettingBehavior | プログラムサポート/メール送信 リザーブフラグ設定クラス。
WkfManager | マスタ関連のAPI。
WkfProcess | 案件関連のAPI。
WkfReference | 参照関連のAPI。
WkfSearchCondition | プログラムサポート/検索条件設定オブジェクト。
WkfSort | プログラムサポート/ソート指定オブジェクト。
WkfTaskInfo | タスク情報関連のAPI。
WkfUtil | ユーティリティ関連のAPI。

情報オブジェクトの概要
WkfActivityProcessDefResultInfo | 起票可能プロセスオブジェクト。
WkfActivityResultInfo | タスク情報オブジェクト。
WkfActivityTaskResultInfo | 処理可能案件情報オブジェクト。
WkfAgentInfo | 代理設定情報オブジェクト。
WkfApplicationKeyResultInfo | アプリケーションキー情報オブジェクト。
WkfCancelAgentInfo | 代理設定情報オブジェクト。
WkfCategoryResultInfo | カテゴリ情報オブジェクト。
WkfConditionInfo | 検索条件オブジェクト。
WkfCreateRouteInfo | ルート作成情報オブジェクト。
WkfDepartmentResultInfo | 所属組織情報オブジェクト。
WkfDraftResultInfo | 起票処理結果オブジェクト。
WkfEndProcessResultInfo | 起票済み案件情報オブジェクト。
WkfEndTaskResultInfo | 処理済案件オブジェクト。
WkfExecutantInfo | 次承認者オブジェクト。
WkfFileResultInfo | 添付ファイルオブジェクト。
WkfFlowResultInfo | 現在位置情報オブジェクト。
WkfImportProcessDefResultInfo | プロセス情報オブジェクト。
WkfNegoMailInfo | 根回しメールオブジェクト。
WkfProcessDefInfoByVersionResultInfo | プロセス定義情報オブジェクト(バージョン指定)。
WkfProcessDefResultInfo | プロセス定義情報オブジェクト。
WkfProcessHistoryResultInfo | 処理履歴情報オブジェクト。
WkfProcessListResultInfo | プロセス情報オブジェクト。
WkfProcessResultInfo | プロセス情報オブジェクト。
WkfReferTaskResultInfo | 参照可能案件情報オブジェクト。
WkfResultInfo | 処理結果オブジェクト。
WkfTargetReferResultInfo | 参照者情報オブジェクト。
WkfTargetRunInfo | 対象者オブジェクト。
WkfTargetRunResultInfo | 対象者情報オブジェクト。
WkfTaskResultInfo | タスク処理結果情報オブジェクト。
WkfTransferActivityResultInfo | 代理設定情報オブジェクト。
WkfTransferProcessDefResultInfo | プロセス定義委譲情報一覧オブジェクト。
WkfTransferResultInfo | 代理設定情報オブジェクト。
WkfTransferVersionResultInfo | バージョン委譲情報オブジェクト。
WkfVersionResultInfo | バージョン情報オブジェクト。


JavaScript API リスト

 オブジェクト
UserTransaction
WkfAgentSetting
WkfApprover
WkfDrafter
WkfFlowInfo
WkfMailSettingBehavior
WkfManager
WkfProcess
WkfReference
WkfSearchCondition
WkfSort
WkfTaskInfo
WkfUtil

情報オブジェクト
WkfActivityProcessDefResultInfo
WkfActivityResultInfo
WkfActivityTaskResultInfo
WkfAgentInfo
WkfApplicationKeyResultInfo
WkfCancelAgentInfo
WkfCategoryResultInfo
WkfConditionInfo
WkfCreateRouteInfo
WkfDepartmentResultInfo
WkfDraftResultInfo
WkfEndProcessResultInfo
WkfEndTaskResultInfo
WkfExecutantInfo
WkfFileResultInfo
WkfFlowResultInfo
WkfImportProcessDefResultInfo
WkfNegoMailInfo
WkfProcessDefInfoByVersionResultInfo
WkfProcessDefResultInfo
WkfProcessHistoryResultInfo
WkfProcessListResultInfo
WkfProcessResultInfo
WkfReferTaskResultInfo
WkfResultInfo
WkfTargetReferResultInfo
WkfTargetRunInfo
WkfTargetRunResultInfo
WkfTaskResultInfo
WkfTransferActivityResultInfo
WkfTransferProcessDefResultInfo
WkfTransferResultInfo
WkfTransferVersionResultInfo
WkfVersionResultInfo


 UserTransaction オブジェクト

データベーストランザクションのAPI。
起票、承認などの関連の処理と併用して
データベースに対するユーザトランザクション制御を行います。

コンストラクタの概要
UserTransaction ()
コンストラクタ（ログイングループ未指定）
現在ログインしている”ログイングループID”の
ログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
UserTransaction (String login_group_id)
コンストラクタ(ログイングループ指定)
第１引数として、”ログイングループID”が指定された場合、
指定されたログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
メソッドの概要
Boolean | begin () トランザクションの開始を行います。
Boolean | commit () トランザクションの確定（commit）を行います。
Boolean | rollback () トランザクションの中止（rollback）を行います。
コンストラクタの詳細
UserTransaction

UserTransaction ()
コンストラクタ（ログイングループ未指定）
現在ログインしている”ログイングループID”の
ログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
UserTransaction

UserTransaction (String login_group_id)
コンストラクタ(ログイングループ指定)
第１引数として、”ログイングループID”が指定された場合、
指定されたログイングループ接続先データベースに対して
データベーストランザクション制御を行います。
パラメータ
login_group_id String ログイングループID(必須)
メソッドの詳細
begin

Boolean begin ()

トランザクションの開始を行います。
返却値
Boolean 処理結果(true:成功/false:失敗)
commit

Boolean commit ()

トランザクションの確定（commit）を行います。
返却値
Boolean 処理結果(true:成功/false:失敗)
rollback

Boolean rollback ()

トランザクションの中止（rollback）を行います。
返却値
Boolean 処理結果(true:成功/false:失敗)


 WkfActivityProcessDefResultInfo オブジェクト

起票可能プロセスオブジェクト。
起票可能プロセスオブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | activity_cd 起票タスクのアクティビティコード。 | 読込み専用
String | agent_cd 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。 | 読込み専用
String | agent_comp_cd 代理依頼先会社コード(本人用でインスタンス作成時)。 | 読込み専用
String | agent_name 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。 | 読込み専用
String | agent_target 代理依頼先対象(本人用でインスタンス作成時)。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
String | client_auth_flg(Boolean) 代理元承認可否フラグ。 | 読込み専用
String | client_user_cd 代理依頼元ユーザコード(代理人用でインスタンス作成時)。 | 読込み専用
String | client_user_name 代理依頼元ユーザ名(代理人用でインスタンス作成時)。 | 読込み専用
String | effective_date 有効日付。 | 読込み専用
String | end_date 終了日付。 | 読込み専用
String | narrow_post_cd 代理依頼先役職絞り込みコード(本人用でインスタンス作成時)。 | 読込み専用
String | narrow_post_name 代理依頼先役職絞り込み名(本人用でインスタンス作成時)。 | 読込み専用
String | process_cls_cd プロセス種別コード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | transfer_flg(Boolean) 代理起票フラグ。 | 読込み専用
String | version_cd 起票可能な最新バージョンコード。 | 読込み専用
String | version_name 起票可能な最新バージョン名。 | 読込み専用
String | version_note 起票可能な最新バージョンの備考。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

起票タスクのアクティビティコード。
agent_cd

String agent_cd (読込み専用プロパティ)

代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。
agent_comp_cd

String agent_comp_cd (読込み専用プロパティ)

代理依頼先会社コード(本人用でインスタンス作成時)。
agent_name

String agent_name (読込み専用プロパティ)

代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。
agent_target

String agent_target (読込み専用プロパティ)

代理依頼先対象(本人用でインスタンス作成時)。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
client_auth_flg(Boolean)

String client_auth_flg(Boolean) (読込み専用プロパティ)

代理元承認可否フラグ。
client_user_cd

String client_user_cd (読込み専用プロパティ)

代理依頼元ユーザコード(代理人用でインスタンス作成時)。
client_user_name

String client_user_name (読込み専用プロパティ)

代理依頼元ユーザ名(代理人用でインスタンス作成時)。
effective_date

String effective_date (読込み専用プロパティ)

有効日付。
end_date

String end_date (読込み専用プロパティ)

終了日付。
narrow_post_cd

String narrow_post_cd (読込み専用プロパティ)

代理依頼先役職絞り込みコード(本人用でインスタンス作成時)。
narrow_post_name

String narrow_post_name (読込み専用プロパティ)

代理依頼先役職絞り込み名(本人用でインスタンス作成時)。
process_cls_cd

String process_cls_cd (読込み専用プロパティ)

プロセス種別コード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
transfer_flg(Boolean)

String transfer_flg(Boolean) (読込み専用プロパティ)

代理起票フラグ。
version_cd

String version_cd (読込み専用プロパティ)

起票可能な最新バージョンコード。
version_name

String version_name (読込み専用プロパティ)

起票可能な最新バージョン名。
version_note

String version_note (読込み専用プロパティ)

起票可能な最新バージョンの備考。


 WkfActivityResultInfo オブジェクト

タスク情報オブジェクト。
 WkfActivityResultInfo(Object)  タスク情報オブジェクト
   ├process_def_cd(String)           プロセス定義コード
   ├version_cd(String)               バージョンコード
   ├activity_cd(String)              アクティビティコード
   ├activiyty_name(String)           アクティビティ名
   ├activity_type_cd(String)         アクティビティ種別

 (アクティビティ種別がRECEIVEの場合)
   ├compulsion_end_flag(Boolean)     終了可能フラグ
   ├return_flag(Boolean)             差し戻し/引き戻しフラグ
   ├return_mail_flag(Boolean)        差し戻しメールフラグ
   ├post_processing_flg(Boolean)     後処理使用フラグ
   ├post_processing_program(String)  後処理プログラム名
   ├contents_frame_type(String)      コンテンツフレーム種別
   ├run_user(Array)                  対象者情報(Objectの配列)
        ├run_type(String)                対象者種別
        ├run_cd(String)                  対象者コード
        ├run_group_cd(String)            対象グループコード(対象者種別が組織の場合)
        ├run_role_restrict(String)       ロールによる絞込みのロールID(対象者種別が組織の場合)
        └run_post_restrict(String)       役職による絞込みの役職コード(対象者種別が組織の場合)
   ├refer_user(Array)                参照者情報(Objectの配列)
        ├run_type(String)                対象者種別
        ├run_cd(String)                  対象者コード
        ├run_group_cd(String)            対象グループコード(対象者種別が組織の場合)
        ├run_role_restrict(String)       ロールによる絞込みのロールID(対象者種別が組織の場合)
        └run_post_restrict(String)       役職による絞込みの役職コード(対象者種別が組織の場合)
   ├contents_path(Object)            コンテンツパス
        ├page_kind(String)               ページ種別
        ├contents_path(String)           コンテンツパス
        ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
        └service_id(String)              サービスID(page_kindがframeworkの場合)
   ├pull_back_contents_path(Object)  引き戻しコンテンツパス
        ├page_kind(String)               ページ種別
        ├contents_path(String)           コンテンツパス
        ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
        └service_id(String)              サービスID(page_kindがframeworkの場合)
   ├return_contents_path(Object)     差し戻しコンテンツパス
        ├page_kind(String)               ページ種別
        ├contents_path(String)           コンテンツパス
        ├application_id(String)          アプリケーションID(page_kindがframeworkの場合)
        └service_id(String)              サービスID(page_kindがframeworkの場合)
   ├auto_pass(Int)                   期日による自動パス設定の日数
   ├auto_pass_executive(Object)      対象者による自動パス設定情報
        ├executive_flg(Boolean)          自動パスフラグ
        └executive_user(Array)           自動パス対象者情報配列(Objectの配列)
            ├executive_type(String)          対象者種別
            ├executive_cd(String)            対象者コード
            ├executive_group_cd(String)      対象グループコード(対象者種別が組織の場合)
            ├executive_role_restrict(String) ロールによる絞込みのロールID(対象者種別が組織の場合)
            └executive_post_restrict(String) 役職による絞込みの役職コード(対象者種別が組織の場合)
   ├reminder(Obhect)                 催促メール情報
        ├reminder_flg(Boolean)           催促メール使用フラグ
        └reminder_date(String)           催促猶予日数

 (アクティビティ種別がFLOWの場合)
   ├combine_class(String)            条件結合クラス

 (アクティビティ種別がINVOKE_AUTOの場合)
   ├run_class(String)                自動実行クラス

 (アクティビティ種別がINVOKE_EVENTの場合)
   ├event_id(String)                 イベントID

 (アクティビティ種別がINVOKE_PROCESSの場合)
   ├call_process_def_cd(String)      呼出しプロセス定義コード
   ├draft_type_kind(String)          起票タイプ

 (アクティビティ種別がSWITCHの場合)
   ├condition_type(String)           分岐種別(単一ルート:0/複数ルート:1)
   ├switch_info(Array)               実行クラス情報(Objectの配列。配列の順番に評価されます。)
        ├condition_no(Int)               実行比較番号(配列の要素番号と同じ)
        ├run_activity_cd(String)         次に実行されるタスクのアクティビティコード
        └run_class(String)               実行クラス

 (アクティビティ種別がMULTIの場合)
   ├route_info(Array)                ルート情報(MapObjectの配列。)
        ├select_route_no(String)         ルート選択番号
        ├select_route_name(String)       ルート名
        ├select_route_cd(String)         呼出先のアクティビティコード
        └isCreateRoute(Boolean)          次タスクがルート作成かどうかを取得します。(true:ルート作成/false:その他)

 (アクティビティ種別がTERMINATEの場合)
   └end_task_program(String)         END時実行プログラム

プロパティの概要
String | activity_cd アクティビティコード。 | 読込み専用
String | activity_type_cd アクティビティ種別。 | 読込み専用
String | activiyty_name アクティビティ名。 | 読込み専用
Int | auto_pass 期日による自動パス設定の日数(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Ojbect | auto_pass_executive 対象者による自動パス設定情報(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Boolean | auto_pass_executive.executive_flg 自動パスフラグ(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Array | auto_pass_executive.executive_user 自動パス対象者情報配列(Objectの配列)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | auto_pass_executive.executive_user[0..*].executive_cd 対象者コード(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | auto_pass_executive.executive_user[0..*].executive_group_cd 対象グループコード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | auto_pass_executive.executive_user[0..*].executive_post_restrict 役職による絞込みの役職コード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | auto_pass_executive.executive_user[0..*].executive_role_restrict ロールによる絞込みのロールID(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | auto_pass_executive.executive_user[0..*].executive_type 対象者種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | call_process_def_cd 呼出しプロセス定義コード(アクティビティ種別がINVOKE_PROCESSの場合)。 | 読込み専用
String | combine_class 条件結合クラス(アクティビティ種別がFLOWの場合)。 | 読込み専用
Boolean | compulsion_end_flag 終了可能フラグ(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | condition_type 分岐種別(単一ルート:0/複数ルート:1)(アクティビティ種別がSWITCHの場合)。 | 読込み専用
String | contents_frame_type コンテンツフレーム種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Object | contents_path コンテンツパス(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | contents_path.application_id アプリケーションID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | contents_path.contents_path コンテンツパス(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | contents_path.page_kind ページ種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | contents_path.service_id サービスID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | draft_type_kind 起票タイプ(アクティビティ種別がINVOKE_PROCESSの場合)。 | 読込み専用
String | end_task_program END時実行プログラム(アクティビティ種別がTERMINATEの場合)。 | 読込み専用
String | event_id イベントID(アクティビティ種別がINVOKE_EVENTの場合)。 | 読込み専用
Boolean | post_processing_flg 後処理使用フラグ(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | post_processing_program 後処理プログラム名(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
Object | pull_back_contents_path 引き戻しコンテンツパス(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | pull_back_contents_path.application_id アプリケーションID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | pull_back_contents_path.contents_path コンテンツパス(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | pull_back_contents_path.page_kind ページ種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | pull_back_contents_path.service_id サービスID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Array | refer_user 参照者情報(Objectの配列)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | refer_user[0..*].run_cd 対象者コード(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | refer_user[0..*].run_group_cd 対象グループコード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | refer_user[0..*].run_post_restrict 役職による絞込みの役職コード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | refer_user[0..*].run_role_restrict ロールによる絞込みのロールID(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | refer_user[0..*].run_type 対象者種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Object | reminder 催促メール情報。 | 読込み専用
String | reminder.reminder_date 催促猶予日数。 | 読込み専用
Boolean | reminder.reminder_flg 催促メール使用フラグ。 | 読込み専用
Object | return_contents_path 差し戻しコンテンツパス(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | return_contents_path.application_id アプリケーションID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | return_contents_path.contents_path コンテンツパス(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | return_contents_path.page_kind ページ種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | return_contents_path.service_id サービスID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Boolean | return_flag 差し戻し/引き戻しフラグ(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Boolean | return_mail_flag 差し戻しメールフラグ(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Array | route_info ルート情報(MapObjectの配列)(アクティビティ種別がMULTIの場合)。 | 読込み専用
Boolean | route_info[0..*].isCreateRoute 次タスクがルート作成かどうかを取得します。 | 読込み専用
String | route_info[0..*].select_route_cd 呼出先のアクティビティコード(アクティビティ種別がMULTIの場合)。 | 読込み専用
String | route_info[0..*].select_route_name ルート名(アクティビティ種別がMULTIの場合)。 | 読込み専用
String | route_info[0..*].select_route_no ルート選択番号(アクティビティ種別がMULTIの場合)。 | 読込み専用
String | run_class 自動実行クラス(アクティビティ種別がINVOKE_AUTOの場合)。 | 読込み専用
Array | run_user 対象者情報(Objectの配列)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | run_user[0..*].run_cd 対象者コード(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | run_user[0..*].run_group_cd 対象グループコード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | run_user[0..*].run_post_restrict 役職による絞込みの役職コード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | run_user[0..*].run_role_restrict ロールによる絞込みのロールID(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
String | run_user[0..*].run_type 対象者種別(アクティビティ種別がRECEIVEの場合)。 | 読込み専用
Array | switch_info 実行クラス情報(Objectの配列。 | 読込み専用
Int | switch_info[0..*].condition_no 実行比較番号(配列の要素番号と同じ)(アクティビティ種別がSWITCHの場合)。 | 読込み専用
String | switch_info[0..*].run_activity_cd 次に実行されるタスクのアクティビティコード(アクティビティ種別がSWITCHの場合)。 | 読込み専用
String | switch_info[0..*].run_class 実行クラス(アクティビティ種別がSWITCHの場合)。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード。
activity_type_cd

String activity_type_cd (読込み専用プロパティ)

アクティビティ種別。 。
activiyty_name

String activiyty_name (読込み専用プロパティ)

アクティビティ名。
auto_pass

Int auto_pass (読込み専用プロパティ)

期日による自動パス設定の日数(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive

Ojbect auto_pass_executive (読込み専用プロパティ)

対象者による自動パス設定情報(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_flg

Boolean auto_pass_executive.executive_flg (読込み専用プロパティ)

自動パスフラグ(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_user

Array auto_pass_executive.executive_user (読込み専用プロパティ)

自動パス対象者情報配列(Objectの配列)(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_user[0..*].executive_cd

String auto_pass_executive.executive_user[0..*].executive_cd (読込み専用プロパティ)

対象者コード(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_user[0..*].executive_group_cd

String auto_pass_executive.executive_user[0..*].executive_group_cd (読込み専用プロパティ)

対象グループコード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_user[0..*].executive_post_restrict

String auto_pass_executive.executive_user[0..*].executive_post_restrict (読込み専用プロパティ)

役職による絞込みの役職コード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_user[0..*].executive_role_restrict

String auto_pass_executive.executive_user[0..*].executive_role_restrict (読込み専用プロパティ)

ロールによる絞込みのロールID(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
auto_pass_executive.executive_user[0..*].executive_type

String auto_pass_executive.executive_user[0..*].executive_type (読込み専用プロパティ)

対象者種別(アクティビティ種別がRECEIVEの場合)。
call_process_def_cd

String call_process_def_cd (読込み専用プロパティ)

呼出しプロセス定義コード(アクティビティ種別がINVOKE_PROCESSの場合)。
combine_class

String combine_class (読込み専用プロパティ)

条件結合クラス(アクティビティ種別がFLOWの場合)。
compulsion_end_flag

Boolean compulsion_end_flag (読込み専用プロパティ)

終了可能フラグ(アクティビティ種別がRECEIVEの場合)。
condition_type

String condition_type (読込み専用プロパティ)

分岐種別(単一ルート:0/複数ルート:1)(アクティビティ種別がSWITCHの場合)。
contents_frame_type

String contents_frame_type (読込み専用プロパティ)

コンテンツフレーム種別(アクティビティ種別がRECEIVEの場合)。
contents_path

Object contents_path (読込み専用プロパティ)

コンテンツパス(アクティビティ種別がRECEIVEの場合)。
contents_path.application_id

String contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。
contents_path.contents_path

String contents_path.contents_path (読込み専用プロパティ)

コンテンツパス(アクティビティ種別がRECEIVEの場合)。
contents_path.page_kind

String contents_path.page_kind (読込み専用プロパティ)

ページ種別(アクティビティ種別がRECEIVEの場合)。
contents_path.service_id

String contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。
draft_type_kind

String draft_type_kind (読込み専用プロパティ)

起票タイプ(アクティビティ種別がINVOKE_PROCESSの場合)。
end_task_program

String end_task_program (読込み専用プロパティ)

END時実行プログラム(アクティビティ種別がTERMINATEの場合)。
event_id

String event_id (読込み専用プロパティ)

イベントID(アクティビティ種別がINVOKE_EVENTの場合)。
post_processing_flg

Boolean post_processing_flg (読込み専用プロパティ)

後処理使用フラグ(アクティビティ種別がRECEIVEの場合)。
post_processing_program

String post_processing_program (読込み専用プロパティ)

後処理プログラム名(アクティビティ種別がRECEIVEの場合)。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
pull_back_contents_path

Object pull_back_contents_path (読込み専用プロパティ)

引き戻しコンテンツパス(アクティビティ種別がRECEIVEの場合)。
pull_back_contents_path.application_id

String pull_back_contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。
pull_back_contents_path.contents_path

String pull_back_contents_path.contents_path (読込み専用プロパティ)

コンテンツパス(アクティビティ種別がRECEIVEの場合)。
pull_back_contents_path.page_kind

String pull_back_contents_path.page_kind (読込み専用プロパティ)

ページ種別(アクティビティ種別がRECEIVEの場合)。
pull_back_contents_path.service_id

String pull_back_contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。
refer_user

Array refer_user (読込み専用プロパティ)

参照者情報(Objectの配列)(アクティビティ種別がRECEIVEの場合)。
refer_user[0..*].run_cd

String refer_user[0..*].run_cd (読込み専用プロパティ)

対象者コード(アクティビティ種別がRECEIVEの場合)。
refer_user[0..*].run_group_cd

String refer_user[0..*].run_group_cd (読込み専用プロパティ)

対象グループコード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
refer_user[0..*].run_post_restrict

String refer_user[0..*].run_post_restrict (読込み専用プロパティ)

役職による絞込みの役職コード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
refer_user[0..*].run_role_restrict

String refer_user[0..*].run_role_restrict (読込み専用プロパティ)

ロールによる絞込みのロールID(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
refer_user[0..*].run_type

String refer_user[0..*].run_type (読込み専用プロパティ)

対象者種別(アクティビティ種別がRECEIVEの場合)。
reminder

Object reminder (読込み専用プロパティ)

催促メール情報。
reminder.reminder_date

String reminder.reminder_date (読込み専用プロパティ)

催促猶予日数。
reminder.reminder_flg

Boolean reminder.reminder_flg (読込み専用プロパティ)

催促メール使用フラグ。
return_contents_path

Object return_contents_path (読込み専用プロパティ)

差し戻しコンテンツパス(アクティビティ種別がRECEIVEの場合)。
return_contents_path.application_id

String return_contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。
return_contents_path.contents_path

String return_contents_path.contents_path (読込み専用プロパティ)

コンテンツパス(アクティビティ種別がRECEIVEの場合)。
return_contents_path.page_kind

String return_contents_path.page_kind (読込み専用プロパティ)

ページ種別(アクティビティ種別がRECEIVEの場合)。
return_contents_path.service_id

String return_contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)(アクティビティ種別がRECEIVEの場合)。
return_flag

Boolean return_flag (読込み専用プロパティ)

差し戻し/引き戻しフラグ(アクティビティ種別がRECEIVEの場合)。
return_mail_flag

Boolean return_mail_flag (読込み専用プロパティ)

差し戻しメールフラグ(アクティビティ種別がRECEIVEの場合)。
route_info

Array route_info (読込み専用プロパティ)

ルート情報(MapObjectの配列)(アクティビティ種別がMULTIの場合)。
route_info[0..*].isCreateRoute

Boolean route_info[0..*].isCreateRoute (読込み専用プロパティ)

次タスクがルート作成かどうかを取得します。(true:ルート作成/false:その他)(アクティビティ種別がMULTIの場合)。
route_info[0..*].select_route_cd

String route_info[0..*].select_route_cd (読込み専用プロパティ)

呼出先のアクティビティコード(アクティビティ種別がMULTIの場合)。
route_info[0..*].select_route_name

String route_info[0..*].select_route_name (読込み専用プロパティ)

ルート名(アクティビティ種別がMULTIの場合)。
route_info[0..*].select_route_no

String route_info[0..*].select_route_no (読込み専用プロパティ)

ルート選択番号(アクティビティ種別がMULTIの場合)。
run_class

String run_class (読込み専用プロパティ)

自動実行クラス(アクティビティ種別がINVOKE_AUTOの場合)。
run_user

Array run_user (読込み専用プロパティ)

対象者情報(Objectの配列)(アクティビティ種別がRECEIVEの場合)。
run_user[0..*].run_cd

String run_user[0..*].run_cd (読込み専用プロパティ)

対象者コード(アクティビティ種別がRECEIVEの場合)。
run_user[0..*].run_group_cd

String run_user[0..*].run_group_cd (読込み専用プロパティ)

対象グループコード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
run_user[0..*].run_post_restrict

String run_user[0..*].run_post_restrict (読込み専用プロパティ)

役職による絞込みの役職コード(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
run_user[0..*].run_role_restrict

String run_user[0..*].run_role_restrict (読込み専用プロパティ)

ロールによる絞込みのロールID(対象者種別が組織の場合)(アクティビティ種別がRECEIVEの場合)。
run_user[0..*].run_type

String run_user[0..*].run_type (読込み専用プロパティ)

対象者種別(アクティビティ種別がRECEIVEの場合)。
switch_info

Array switch_info (読込み専用プロパティ)

実行クラス情報(Objectの配列。配列の順番に評価されます)(アクティビティ種別がSWITCHの場合)。
switch_info[0..*].condition_no

Int switch_info[0..*].condition_no (読込み専用プロパティ)

実行比較番号(配列の要素番号と同じ)(アクティビティ種別がSWITCHの場合)。
switch_info[0..*].run_activity_cd

String switch_info[0..*].run_activity_cd (読込み専用プロパティ)

次に実行されるタスクのアクティビティコード(アクティビティ種別がSWITCHの場合)。
switch_info[0..*].run_class

String switch_info[0..*].run_class (読込み専用プロパティ)

実行クラス(アクティビティ種別がSWITCHの場合)。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。


 WkfActivityTaskResultInfo オブジェクト

処理可能案件情報オブジェクト。
処理可能案件情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | activity_cd アクティビティコード。 | 読込み専用
String | activity_name アクティビティ名。 | 読込み専用
String | activity_status アクティビティステータス。 | 読込み専用
String | agent_cd 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。 | 読込み専用
String | agent_name 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。 | 読込み専用
String | agent_target 代理依頼先対象(本人用でインスタンス作成時)。 | 読込み専用
String | attainment_class 到達種別。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
Boolean | client_auth_flg 代理元承認可否フラグ。 | 読込み専用
String | client_user_cd 代理依頼元ユーザコード(代理人用でインスタンス作成時)。 | 読込み専用
String | client_user_name 代理依頼元ユーザ名(代理人用でインスタンス作成時)。 | 読込み専用
Boolean | compulsion_end_flg 強制終了可否フラグ。 | 読込み専用
String | draft_appoint_date 起票指定日。 | 読込み専用
String | draft_date 起票日。 | 読込み専用
String | draft_user_cd 起票者コード。 | 読込み専用
String | draft_user_name 起票者名。 | 読込み専用
String | next_activity_type 次タスクのタスク種別。 | 読込み専用
String | parent_process_cd 親プロセスコード。 | 読込み専用
String | parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | parent_version_cd 親プロセスバージョンコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_cls_cd プロセス種別コード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | process_name プロセス名。 | 読込み専用
String | process_status プロセスステータス。 | 読込み専用
String | process_term_date 処理期限日付。 | 読込み専用
String | reception_date 受信日付。 | 読込み専用
Boolean | transfer_flg 代理起票フラグ。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード。
activity_name

String activity_name (読込み専用プロパティ)

アクティビティ名。
activity_status

String activity_status (読込み専用プロパティ)

アクティビティステータス。
agent_cd

String agent_cd (読込み専用プロパティ)

代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。
agent_name

String agent_name (読込み専用プロパティ)

代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。
agent_target

String agent_target (読込み専用プロパティ)

代理依頼先対象(本人用でインスタンス作成時)。
attainment_class

String attainment_class (読込み専用プロパティ)

到達種別。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
client_auth_flg

Boolean client_auth_flg (読込み専用プロパティ)

代理元承認可否フラグ。
client_user_cd

String client_user_cd (読込み専用プロパティ)

代理依頼元ユーザコード(代理人用でインスタンス作成時)。
client_user_name

String client_user_name (読込み専用プロパティ)

代理依頼元ユーザ名(代理人用でインスタンス作成時)。
compulsion_end_flg

Boolean compulsion_end_flg (読込み専用プロパティ)

強制終了可否フラグ。
draft_appoint_date

String draft_appoint_date (読込み専用プロパティ)

起票指定日。
draft_date

String draft_date (読込み専用プロパティ)

起票日。
draft_user_cd

String draft_user_cd (読込み専用プロパティ)

起票者コード。
draft_user_name

String draft_user_name (読込み専用プロパティ)

起票者名。
next_activity_type

String next_activity_type (読込み専用プロパティ)

次タスクのタスク種別。
parent_process_cd

String parent_process_cd (読込み専用プロパティ)

親プロセスコード。
parent_process_def_cd

String parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
parent_version_cd

String parent_version_cd (読込み専用プロパティ)

親プロセスバージョンコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_cls_cd

String process_cls_cd (読込み専用プロパティ)

プロセス種別コード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
process_name

String process_name (読込み専用プロパティ)

プロセス名。
process_status

String process_status (読込み専用プロパティ)

プロセスステータス。
process_term_date

String process_term_date (読込み専用プロパティ)

処理期限日付。
reception_date

String reception_date (読込み専用プロパティ)

受信日付。
transfer_flg

Boolean transfer_flg (読込み専用プロパティ)

代理起票フラグ。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


 WkfAgentInfo オブジェクト

代理設定情報オブジェクト。
代理設定情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | activity_cd アクティビティコード(任意)。 | 通常
String | narrow_post_cd 絞り込み役職コード(任意)。 | 通常
String | narrow_post_name 絞り込み役職名(任意)。 | 通常
Boolean | notice_mail_flag 代理元メール通知フラグ(必須)。 | 通常
String | process_def_cd プロセス定義コード(必須)。 | 通常
Boolean | send_mail_flag メール通知フラグ(必須)。 | 通常
Boolean | sub_recognition_flag 代理元承認可否フラグ(必須)。 | 通常
String | transfer_cd 代理依頼先コード(必須)。 | 通常
String | transfer_cd_type 代理依頼先種別(必須)。 | 通常
String | transfer_comment 代理コメント(任意)。 | 通常
String | transfer_end_date 代理期間(終了日)(必須)。 | 通常
String | transfer_group_cd 代理依頼先グループコード(必須)。 | 通常
String | transfer_name 代理依頼先名(必須)。 | 通常
String | transfer_start_date 代理期間(開始日)(必須)。 | 通常
String | transfer_status 代理種別(必須)。 | 通常
String | version_cd バージョンコード(任意)。 | 通常
プロパティの詳細
activity_cd

String activity_cd

アクティビティコード(任意)。
narrow_post_cd

String narrow_post_cd

絞り込み役職コード(任意)。
narrow_post_name

String narrow_post_name

絞り込み役職名(任意)。
notice_mail_flag

Boolean notice_mail_flag

代理元メール通知フラグ(必須)。
process_def_cd

String process_def_cd

プロセス定義コード(必須)。
send_mail_flag

Boolean send_mail_flag

メール通知フラグ(必須)。
sub_recognition_flag

Boolean sub_recognition_flag

代理元承認可否フラグ(必須)。
transfer_cd

String transfer_cd

代理依頼先コード(必須)。
transfer_cd_type

String transfer_cd_type

代理依頼先種別(必須)。
transfer_comment

String transfer_comment

代理コメント(任意)。
transfer_end_date

String transfer_end_date

代理期間(終了日)(必須)。
transfer_group_cd

String transfer_group_cd

代理依頼先グループコード(必須)。
transfer_name

String transfer_name

代理依頼先名(必須)。
transfer_start_date

String transfer_start_date

代理期間(開始日)(必須)。
transfer_status

String transfer_status

代理種別(必須)。
version_cd

String version_cd

バージョンコード(任意)。


 WkfAgentSetting オブジェクト

代理設定関連のAPI。
代理設定関連処理で使用されるクラスです。
定数の概要
static String | CD_KIND_OFFICIAL 代理依頼先種別：オフィシャルグループ
static String | CD_KIND_ORG 代理依頼先種別：組織
static String | CD_KIND_PRIVATE 代理依頼先種別：プライベートグループ
static String | CD_KIND_USER 代理依頼先種別：ユーザ
static String | PROCESS_DEF_ALL プロセス定義コード：全て (全プロセス定義にプロセス定義委譲を行いたい場合に使用します。)
static String | STATUS_ACTIVITY 代理設定種別：タスク委譲
static String | STATUS_PROCESS_DEF 代理設定種別：プロセス定義委譲
static String | STATUS_VERSION 代理設定種別：バージョン委譲
コンストラクタの概要
WkfAgentSetting (String user_cd ,String login_group_id)
コンストラクタ。
メソッドの概要
WkfResultInfo | cancelAgent (WkfCancelAgentInfo transfer_info) 代理設定を解除します。
WkfTransferActivityResultInfo | getTransferActivityList (String process_def_cd ,String version_cd) タスク委譲情報一覧を取得します。
WkfTransferResultInfo | getTransferInfo (String process_def_cd ,String version_cd ,String activity_cd ,String target_date) 指定された日付に有効な代理設定情報を返却します。
WkfTransferProcessDefResultInfo | getTransferProcessDefList (String category_cd) プロセス定義委譲情報一覧を取得します。
WkfTransferVersionResultInfo | getTransferVersionList (String process_def_cd) バージョン委譲情報一覧を取得します。
void | noTransaction () データベーストランザクションを未使用にする。
WkfResultInfo | setAgent (WkfAgentInfo transfer_info) 代理設定を設定します。
定数の詳細
CD_KIND_OFFICIAL

static String CD_KIND_OFFICIAL

代理依頼先種別：オフィシャルグループ
定数値 ： "02"
CD_KIND_ORG

static String CD_KIND_ORG

代理依頼先種別：組織
定数値 ： "01"
CD_KIND_PRIVATE

static String CD_KIND_PRIVATE

代理依頼先種別：プライベートグループ
定数値 ： "04"
CD_KIND_USER

static String CD_KIND_USER

代理依頼先種別：ユーザ
定数値 ： "00"
PROCESS_DEF_ALL

static String PROCESS_DEF_ALL

プロセス定義コード：全て
(全プロセス定義にプロセス定義委譲を行いたい場合に使用します。)
定数値 ： "all_process_def_cd"
STATUS_ACTIVITY

static String STATUS_ACTIVITY

代理設定種別：タスク委譲
定数値 ： "2"
STATUS_PROCESS_DEF

static String STATUS_PROCESS_DEF

代理設定種別：プロセス定義委譲
定数値 ： "0"
STATUS_VERSION

static String STATUS_VERSION

代理設定種別：バージョン委譲
定数値 ： "1"
コンストラクタの詳細
WkfAgentSetting

WkfAgentSetting (String user_cd ,String login_group_id)
コンストラクタ。
パラメータ
user_cd | String | ユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
cancelAgent

WkfResultInfo cancelAgent (WkfCancelAgentInfo transfer_info)

代理設定を解除します。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
transfer_info WkfCancelAgentInfo 代理設定情報モデル
返却値
WkfResultInfo 処理結果オブジェクト
getTransferActivityList

WkfTransferActivityResultInfo getTransferActivityList (String process_def_cd ,String version_cd)

タスク委譲情報一覧を取得します。
パラメータ
process_def_cd | String | プロセス定義コード
version_cd | String | バージョンコード
返却値
WkfTransferActivityResultInfo 処理結果オブジェクト
getTransferInfo

WkfTransferResultInfo getTransferInfo (String process_def_cd ,String version_cd ,String activity_cd ,String target_date)

指定された日付に有効な代理設定情報を返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(必須)
target_date | String | 代理対象日付(必須)
返却値
WkfTransferResultInfo 処理結果オブジェクト
getTransferProcessDefList

WkfTransferProcessDefResultInfo getTransferProcessDefList (String category_cd)

プロセス定義委譲情報一覧を取得します。
パラメータ
category_cd String カテゴリコード(必須)
返却値
WkfTransferProcessDefResultInfo 処理結果オブジェクト
getTransferVersionList

WkfTransferVersionResultInfo getTransferVersionList (String process_def_cd)

バージョン委譲情報一覧を取得します。
パラメータ
process_def_cd String プロセス定義コード(必須)
返却値
WkfTransferVersionResultInfo 処理結果オブジェクト
noTransaction

void noTransaction ()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
setAgent

WkfResultInfo setAgent (WkfAgentInfo transfer_info)

代理設定を設定します。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
transfer_info WkfAgentInfo 代理設定情報オブジェクト
返却値
WkfResultInfo 処理結果オブジェクト


 WkfApplicationKeyResultInfo オブジェクト

アプリケーションキー情報オブジェクト。
アプリケーションキー情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | parameter_cd パラメータコード。 | 読込み専用
String | parameter_no パラメータ番号。 | 読込み専用
プロパティの詳細
parameter_cd

String parameter_cd (読込み専用プロパティ)

パラメータコード。
parameter_no

String parameter_no (読込み専用プロパティ)

パラメータ番号。


 WkfApprover オブジェクト

承認関連のAPI。
承認関連の処理に使用されるクラスです。

<サンプル>
定数の概要
static String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)。
コンストラクタの概要
WkfApprover (String user_cd ,String login_group_id)
コンストラクタ(本人用)。
WkfApprover (String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ(代理人用)。
メソッドの概要
WkfResultInfo | approve (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Boolean isFinish ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd) 推奨されていません。 approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, WkfCreateRouteInfo route_info)に置き換えられました。 ※ このメソッドを使用すると、ルート作成情報：nullで承認処理を実行します。
WkfResultInfo | approve (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Boolean isFinish ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,WkfCreateRouteInfo route_info) 承認処理を実行します。
WkfResultInfo | denial (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego) 否認処理を実行します。
Array | getActivityTaskList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount) 処理可能案件(未処理案件)一覧を取得します。
Array | getEndTaskList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount) 処理済案件一覧を取得します。
Array | getTargetDepartment (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd) 所属組織を取得します。
void | noTransaction () データベーストランザクションを未使用にする。
WkfResultInfo | pullBack (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd) 引戻し処理を実行します。
WkfResultInfo | sendBack (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String type ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego) 推奨されていません。 sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, String send_back_process_def_cd, String send_back_version_cd, String send_back_process_cd, String send_back_activity_cd)に置き換えられました。 ※ このメソッドを使用すると、差し戻し先情報：nullで差し戻し処理を実行します。
WkfResultInfo | sendBack (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String type ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,String send_back_process_def_cd ,String send_back_version_cd ,String send_back_process_cd ,String send_back_activity_cd) 差し戻し処理を実行します。
WkfResultInfo | suspend (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego) 保留処理を実行します。
定数の詳細
AGT_ALL

static String AGT_ALL

代理依頼されたもの全て表示(代理のみ使用)。
定数値 ： "1"
コンストラクタの詳細
WkfApprover

WkfApprover (String user_cd ,String login_group_id)
コンストラクタ(本人用)。
パラメータ
user_cd | String | 承認者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
WkfApprover

WkfApprover (String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ(代理人用)。 代理依頼されたもの全てを表示する際は、user_cdに「"AGT_ALL"もしくは"1"」を指定してください。
ただし、"AGT_ALL"を指定すると承認などの一覧検索以外のメソッドは使えません。
パラメータ
agent_user_cd | String | 代理承認者のユーザID(必須)
user_cd | String | 本来の処理者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
approve

WkfResultInfo approve (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Boolean isFinish ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd)

推奨されていません。
approve(String process_def_cd, String version_cd, String process_cd, String activity_cd, Boolean isFinish, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, WkfCreateRouteInfo route_info)に置き換えられました。
※ このメソッドを使用すると、ルート作成情報：nullで承認処理を実行します。
承認処理を実行します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
isFinish | Boolean | 途中終了フラグ(任意：未指定=途中終了しない)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
executant | WkfExecutantInfo | 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
返却値
WkfResultInfo 処理結果オブジェクト
approve

WkfResultInfo approve (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Boolean isFinish ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,WkfCreateRouteInfo route_info)

承認処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
isFinish | Boolean | 途中終了フラグ(任意：未指定=途中終了しない)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego WkfNegoMailInfo 根回しメールオブジェクト(任意)
executant WkfExecutantInfo 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
route_info WkfCreateRouteInfo ルート作成情報オブジェクト(次タスクがルート作成時)
返却値
WkfResultInfo 処理結果オブジェクト
denial

WkfResultInfo denial (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego)

否認処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
返却値
WkfResultInfo 処理結果オブジェクト
getActivityTaskList

Array getActivityTaskList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount)

処理可能案件(未処理案件)一覧を取得します。
処理可能案件オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
conditionKey | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 処理可能案件情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getEndTaskList

Array getEndTaskList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount)

処理済案件一覧を取得します。
処理済案件オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
conditionKey | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 処理済案件オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTargetDepartment

Array getTargetDepartment (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd)

所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
審議時など、既にプロセスコードがふられているに使用します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
返却値
Array 所属組織情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
noTransaction

void noTransaction ()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
pullBack

WkfResultInfo pullBack (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd)

引戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
返却値
WkfResultInfo 処理結果オブジェクト
sendBack

WkfResultInfo sendBack (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String type ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego)

推奨されていません。
sendBack(String process_def_cd, String version_cd, String process_cd, String activity_cd, String type, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, String send_back_process_def_cd, String send_back_version_cd, String send_back_process_cd, String send_back_activity_cd)に置き換えられました。
※ このメソッドを使用すると、差し戻し先情報：nullで差し戻し処理を実行します。
差し戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
type | String | 差戻し先(必須：start=申請者,before=前処理者)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
返却値
WkfResultInfo 処理結果オブジェクト
sendBack

WkfResultInfo sendBack (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String type ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,String send_back_process_def_cd ,String send_back_version_cd ,String send_back_process_cd ,String send_back_activity_cd)

差し戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
type | String | 差戻し先(必須：start=申請者,before=前処理者,task=任意の処理者)
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
send_back_process_def_cd | String | 差し戻し先プロセス定義コード(任意：任意の処理者へ差し戻しの場合に必須)
send_back_version_cd | String | 差し戻し先バージョンコード(任意：任意の処理者へ差し戻しの場合に必須)
send_back_process_cd | String | 差し戻し先プロセスコード(任意：任意の処理者へ差し戻しの場合に必須)
send_back_activity_cd | String | 差し戻し先アクティビティコード(任意：任意の処理者へ差し戻しの場合に必須)
返却値
WkfResultInfo 処理結果オブジェクト
suspend

WkfResultInfo suspend (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego)

保留処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード
version_cd | String | バージョンコード
process_cd | String | プロセスコード
activity_cd | String | アクティビティコード
comp_cd | String | ユーザ（処理者）の会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザ（処理者）の組織コード(任意：未所属の場合のみ未指定可)
comment | String | 承認コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
返却値
WkfResultInfo 処理結果オブジェクト


 WkfCancelAgentInfo オブジェクト

代理設定情報オブジェクト。
代理設定情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | activity_cd アクティビティコード(任意)。 | 通常
String | process_def_cd プロセス定義コード(必須)。 | 通常
Boolean | send_mail_flag メール通知フラグ(必須)。 | 通常
String | transfer_comment 代理コメント(任意)。 | 通常
String | transfer_status 代理種別(必須)。 | 通常
String | version_cd バージョンコード(任意)。 | 通常
プロパティの詳細
activity_cd

String activity_cd

アクティビティコード(任意)。
process_def_cd

String process_def_cd

プロセス定義コード(必須)。
send_mail_flag

Boolean send_mail_flag

メール通知フラグ(必須)。
transfer_comment

String transfer_comment

代理コメント(任意)。
transfer_status

String transfer_status

代理種別(必須)。
version_cd

String version_cd

バージョンコード(任意)。


 WkfCategoryResultInfo オブジェクト

カテゴリ情報オブジェクト。
カテゴリ情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | category_cd カテゴリコード。 | 通常
String | category_name カテゴリ名。 | 通常
String | category_note 備考。 | 通常
Array | edit_athorities 編集権限リスト。 | 通常
Array | processing_authorities 処理権限リスト。 | 通常
プロパティの詳細
category_cd

String category_cd

カテゴリコード。
category_name

String category_name

カテゴリ名。
category_note

String category_note

備考。
edit_athorities

Array edit_athorities

編集権限リスト。(各要素はロールIDの文字列(String))。
processing_authorities

Array processing_authorities

処理権限リスト。(各要素はロールIDの文字列(String))。


 WkfConditionInfo オブジェクト

検索条件オブジェクト。
検索条件オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | activity_cd アクティビティコード。 | 通常
String | activity_name アクティビティ名。 | 通常
String | agent_user_cd 代理依頼元ユーザコード。 | 通常
String | agent_user_name 代理依頼元ユーザ名。 | 通常
Boolean | agt_complete_filter 完了タスクの表示(代理元承認不可)。 | 通常
Boolean | agt_go_filter 未処理タスクの表示(代理元承認不可) 。 | 通常
Boolean | agt_pullback_filter 引き戻しタスクの表示(代理元承認不可)。 | 通常
Boolean | agt_sendback_filter 差し戻しタスクの表示(代理元承認不可)。 | 通常
String | approval_comp_cd 処理者の会社コード。 | 通常
String | approval_date_end 処理日(検索範囲終了日)。 | 通常
String | approval_date_start 処理日(検索範囲開始日)。 | 通常
String | approval_orgn_cd 処理者の会社組織コード。 | 通常
String | approval_orgn_name 処理者の会社組織名。 | 通常
String | approval_user_cd 処理者ユーザコード。 | 通常
String | approval_user_name 処理者ユーザ名。 | 通常
String | arrive_date_end 到達日(検索範囲終了日)。 | 通常
String | arrive_date_start 到達日(検索範囲開始日)。 | 通常
String | category_cd カテゴリコード。 | 通常
String | category_name カテゴリ名。 | 通常
Boolean | clt_agt_complete_filter 完了タスクの表示(代理元承認可)。 | 通常
Boolean | clt_agt_go_filter 未処理タスクの表示(代理元承認可)。 | 通常
Boolean | clt_agt_pullback_filter 引き戻しタスクの表示(代理元承認可)。 | 通常
Boolean | clt_agt_sendback_filter 差し戻しタスクの表示(代理元承認可)。 | 通常
Boolean | complete_filter 完了タスクの表示(本人)。 | 通常
String | draft_appoint_date 起票指定日。 | 通常
String | draft_comp_cd 起票者の起票会社コード。 | 通常
String | draft_date_end 起票日(検索範囲終了日)。 | 通常
String | draft_date_start 起票日(検索範囲開始日)。 | 通常
String | draft_orgn_cd 起票者の起票組織コード。 | 通常
String | draft_user_cd 起票者コード。 | 通常
String | draft_user_name 起票者名。 | 通常
Boolean | go_filter 未処理タスクの表示(本人)。 | 通常
String | limit_date_end 処理期限日(検索範囲終了日)。 | 通常
String | limit_date_start 処理期限日(検索範囲開始日)。 | 通常
String | process_cd プロセスコード。 | 通常
String | process_def_cd プロセス定義コード。 | 通常
String | process_def_name プロセス定義名。 | 通常
String | process_name プロセス名。 | 通常
Boolean | pullback_filter 引き戻しタスクの表示(本人)。 | 通常
Boolean | sendback_filter 差し戻しタスクの表示(本人)。 | 通常
String | version_cd バージョンコード。 | 通常
プロパティの詳細
activity_cd

String activity_cd

アクティビティコード。
activity_name

String activity_name

アクティビティ名。
agent_user_cd

String agent_user_cd

代理依頼元ユーザコード。
agent_user_name

String agent_user_name

代理依頼元ユーザ名。
agt_complete_filter

Boolean agt_complete_filter

完了タスクの表示(代理元承認不可)。
agt_go_filter

Boolean agt_go_filter

未処理タスクの表示(代理元承認不可) 。
agt_pullback_filter

Boolean agt_pullback_filter

引き戻しタスクの表示(代理元承認不可)。
agt_sendback_filter

Boolean agt_sendback_filter

差し戻しタスクの表示(代理元承認不可)。
approval_comp_cd

String approval_comp_cd

処理者の会社コード。
approval_date_end

String approval_date_end

処理日(検索範囲終了日)。
approval_date_start

String approval_date_start

処理日(検索範囲開始日)。
approval_orgn_cd

String approval_orgn_cd

処理者の会社組織コード。
approval_orgn_name

String approval_orgn_name

処理者の会社組織名。
approval_user_cd

String approval_user_cd

処理者ユーザコード。
approval_user_name

String approval_user_name

処理者ユーザ名。
arrive_date_end

String arrive_date_end

到達日(検索範囲終了日)。
arrive_date_start

String arrive_date_start

到達日(検索範囲開始日)。
category_cd

String category_cd

カテゴリコード。
category_name

String category_name

カテゴリ名。
clt_agt_complete_filter

Boolean clt_agt_complete_filter

完了タスクの表示(代理元承認可)。
clt_agt_go_filter

Boolean clt_agt_go_filter

未処理タスクの表示(代理元承認可)。
clt_agt_pullback_filter

Boolean clt_agt_pullback_filter

引き戻しタスクの表示(代理元承認可)。
clt_agt_sendback_filter

Boolean clt_agt_sendback_filter

差し戻しタスクの表示(代理元承認可)。
complete_filter

Boolean complete_filter

完了タスクの表示(本人)。
draft_appoint_date

String draft_appoint_date

起票指定日。
draft_comp_cd

String draft_comp_cd

起票者の起票会社コード。
draft_date_end

String draft_date_end

起票日(検索範囲終了日)。
draft_date_start

String draft_date_start

起票日(検索範囲開始日)。
draft_orgn_cd

String draft_orgn_cd

起票者の起票組織コード。
draft_user_cd

String draft_user_cd

起票者コード。
draft_user_name

String draft_user_name

起票者名。
go_filter

Boolean go_filter

未処理タスクの表示(本人)。
limit_date_end

String limit_date_end

処理期限日(検索範囲終了日)。
limit_date_start

String limit_date_start

処理期限日(検索範囲開始日)。
process_cd

String process_cd

プロセスコード。
process_def_cd

String process_def_cd

プロセス定義コード。
process_def_name

String process_def_name

プロセス定義名。
process_name

String process_name

プロセス名。
pullback_filter

Boolean pullback_filter

引き戻しタスクの表示(本人)。
sendback_filter

Boolean sendback_filter

差し戻しタスクの表示(本人)。
version_cd

String version_cd

バージョンコード。


 WkfCreateRouteInfo オブジェクト

ルート作成情報オブジェクト。
ルート作成情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfCreateRouteInfo(Object) ルート作成情報オブジェクト
 ├process_def_cd(String)     ルート作成プロセス定義コード
 ├version_cd(String)         ルート作成バージョンコード
 └target_list(Array)         ルート作成タスク処理対象者情報リスト
    ├activity_cd(String)       アクティビティコード
    ├target_type(String)       対象者種別
    ├target_group_cd(String)   対象者グループコード
    ├target_cd(String)         対象者コード
    └narrow_post_cd(String)    絞り込み役職コード

プロパティの概要
String | process_def_cd ルート作成プロセス定義コード。 | 通常
Array | target_list ルート作成タスク処理対象者情報リスト。 | 通常
String | target_list[0..*].activity_cd アクティビティコード。 | 通常
String | target_list[0..*].narrow_post_cd 絞込み役職コード。 | 通常
String | target_list[0..*].target_cd 対象者コード。 | 通常
String | target_list[0..*].target_group_cd 対象者グループコード。 | 通常
String | target_list[0..*].target_type 対象者種別。 | 通常
String | version_cd ルート作成バージョンコード。 | 通常
プロパティの詳細
process_def_cd

String process_def_cd

ルート作成プロセス定義コード。
target_list

Array target_list

ルート作成タスク処理対象者情報リスト。
target_list[0..*].activity_cd

String target_list[0..*].activity_cd

アクティビティコード。
target_list[0..*].narrow_post_cd

String target_list[0..*].narrow_post_cd

絞込み役職コード。
target_list[0..*].target_cd

String target_list[0..*].target_cd

対象者コード。
target_list[0..*].target_group_cd

String target_list[0..*].target_group_cd

対象者グループコード。
target_list[0..*].target_type

String target_list[0..*].target_type

対象者種別。
version_cd

String version_cd

ルート作成バージョンコード。


 WkfDepartmentResultInfo オブジェクト

所属組織情報オブジェクト。
所属組織情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | company_cd 会社コード。 | 読込み専用
String | department_cd 組織コード。 | 読込み専用
String | department_name 組織名。 | 読込み専用
プロパティの詳細
company_cd

String company_cd (読込み専用プロパティ)

会社コード。
department_cd

String department_cd (読込み専用プロパティ)

組織コード。
department_name

String department_name (読込み専用プロパティ)

組織名。


 WkfDrafter オブジェクト

起票関連のAPI。
起票関連の処理に使用されるクラスです。

<サンプル>
定数の概要
static String AGT_ALL
代理依頼されたもの全て表示(代理のみ使用)。
コンストラクタの概要
WkfDrafter (String user_cd ,String login_group_id)
コンストラクタ１(本人用)。
WkfDrafter (String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ２(代理人用)。
メソッドの概要
WkfResultInfo | cancel (String process_def_cd ,String version_cd ,String process_cd ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego) 取り止め処理を実行します。
WkfDraftResultInfo | draft (String process_def_cd ,String version_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale) 推奨されていません。 draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, Array app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, String locale, WkfCreateRouteInfo route_info)に置き換えられました。 ※ このメソッドを使用すると、ルート作成情報：nullで起票処理を実行します。
WkfDraftResultInfo | draft (String process_def_cd ,String version_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale ,WkfCreateRouteInfo route_info) 起票処理を実行します。
Array | getActivityProcessDefList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount ,String locale) 起票可能プロセス一覧を取得します。
Array | getEndProcessList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount) 起票済み案件を取得します。
Array | getTargetDepartment (String process_def_cd ,String version_cd ,String activity_cd ,String target_date) 所属組織を取得します。
void | noTransaction () データベーストランザクションを未使用にする。
WkfResultInfo | pullBack (String process_def_cd ,String version_cd ,String process_cd) 引戻し処理を実行します。
WkfResultInfo | retry (String process_def_cd ,String version_cd ,String process_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale) 推奨されていません。 retry(String process_def_cd, String version_cd, String process_cd, String process_name, Array app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, String locale, WkfCreateRouteInfo route_info)に置き換えられました。 ※ このメソッドを使用すると、ルート作成情報：nullで再起票処理を実行します。
WkfResultInfo | retry (String process_def_cd ,String version_cd ,String process_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale ,WkfCreateRouteInfo route_info) 再起票処理を実行します。
WkfResultInfo | subProcessDraft (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd) 推奨されていません。 subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, Array app_key, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, WkfCreateRouteInfo route_info)に置き換えられました。 ※ このメソッドを使用すると、ルート作成情報：nullでサブプロセスの申請処理を実行します。
WkfResultInfo | subProcessDraft (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,WkfCreateRouteInfo route_info) サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
定数の詳細
AGT_ALL

static String AGT_ALL

代理依頼されたもの全て表示(代理のみ使用)。
定数値 ： "1"
コンストラクタの詳細
WkfDrafter

WkfDrafter (String user_cd ,String login_group_id)
コンストラクタ１(本人用)。
パラメータ
user_cd | String | 起票者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
WkfDrafter

WkfDrafter (String agent_user_cd ,String user_cd ,String login_group_id)
コンストラクタ２(代理人用)。
代理依頼されたもの全てを表示する際は、user_cdに「"AGT_ALL"もしくは"1")」を指定してください。
ただし、"AGT_ALL"を指定すると承認などの一覧検索以外のメソッドは使えません。
パラメータ
agent_user_cd | String | 代理起票者のユーザID(必須)
user_cd | String | 本来の起票者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
cancel

WkfResultInfo cancel (String process_def_cd ,String version_cd ,String process_cd ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego)

取り止め処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 取り止めコメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
返却値
WkfResultInfo 処理結果オブジェクト
draft

WkfDraftResultInfo draft (String process_def_cd ,String version_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale)

推奨されていません。
draft(String process_def_cd, String version_cd, String process_temporary_cd, String process_name, Array app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, String locale, WkfCreateRouteInfo route_info)に置き換えられました。
※ このメソッドを使用すると、ルート作成情報：nullで起票処理を実行します。
起票処理を実行します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_temporary_cd | String | 一時プロセスID(任意：添付ファイル利用時)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーション配列(任意：０〜８要素まで)
draft_appoint_date | String | 起票指定日(任意：未指定時は起票日と同日)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 起票コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
executant | WkfExecutantInfo | 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
locale | String | ロケール(任意：なければデフォルトロケールを使用)
返却値
WkfDraftResultInfo 処理結果オブジェクト
draft

WkfDraftResultInfo draft (String process_def_cd ,String version_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale ,WkfCreateRouteInfo route_info)

起票処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素０から指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_temporary_cd | String | 一時プロセスID(任意：添付ファイル利用時)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーション配列(任意：０〜８要素まで)
draft_appoint_date | String | 起票指定日(任意：未指定時は起票日と同日)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 起票コメント(任意)
nego WkfNegoMailInfo 根回しメールオブジェクト(任意)
executant WkfExecutantInfo 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
locale | String | ロケール(任意：なければデフォルトロケールを使用)
route_info WkfCreateRouteInfo ルート作成情報オブジェクト(次タスクがルート作成時)
返却値
WkfDraftResultInfo 処理結果オブジェクト
getActivityProcessDefList

Array getActivityProcessDefList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount ,String locale)

起票可能プロセス一覧を取得します。
起票可能プロセスオブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
conditionKey | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
locale | String | ロケール
返却値
Array 起票可能プロセスオブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getEndProcessList

Array getEndProcessList (WkfSearchCondition conditionKey ,Array sortKey ,Number start ,Number amount)

起票済み案件を取得します。
起票済み案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
conditionKey | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sortKey | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 起票済み案件情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTargetDepartment

Array getTargetDepartment (String process_def_cd ,String version_cd ,String activity_cd ,String target_date)

所属組織を取得します。
処理時の所属組織として選択できる組織を取得します。
起票時など、プロセスコードがふられていない時に使用します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(必須)
target_date | String | 起票指定日(任意：指定なしの場合はシステム日付)
返却値
Array 所属組織情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
noTransaction

void noTransaction ()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
pullBack

WkfResultInfo pullBack (String process_def_cd ,String version_cd ,String process_cd)

引戻し処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
返却値
WkfResultInfo 処理結果オブジェクト
retry

WkfResultInfo retry (String process_def_cd ,String version_cd ,String process_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale)

推奨されていません。
retry(String process_def_cd, String version_cd, String process_cd, String process_name, Array app_key, String draft_appoint_date, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, String locale, WkfCreateRouteInfo route_info)に置き換えられました。
※ このメソッドを使用すると、ルート作成情報：nullで再起票処理を実行します。
再起票処理を実行します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーションキー配列(任意：０〜８要素まで)
draft_appoint_date | String | 起票指定日(任意：起票日と同日)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 再起票コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
executant | WkfExecutantInfo | 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
locale | String | ロケール(任意：なければデフォルトロケールを使用)
返却値
WkfResultInfo 処理結果オブジェクト
retry

WkfResultInfo retry (String process_def_cd ,String version_cd ,String process_cd ,String process_name ,Array app_key ,String draft_appoint_date ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,String locale ,WkfCreateRouteInfo route_info)

再起票処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
アプリケーションキー配列は、必ず要素０から指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーションキー配列(任意：０〜８要素まで)
draft_appoint_date | String | 起票指定日(任意：起票日と同日)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 再起票コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
executant | WkfExecutantInfo | 次承認者オブジェクト(引戻しされたタスクで、次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
locale | String | ロケール(任意：なければデフォルトロケールを使用)
route_info WkfCreateRouteInfo ルート作成情報オブジェクト(次タスクがルート作成時)
返却値
WkfResultInfo 処理結果オブジェクト
subProcessDraft

WkfResultInfo subProcessDraft (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd)

推奨されていません。
subProcessDraft(String process_def_cd, String version_cd, String process_cd, String activity_cd, String process_temporary_cd, String process_name, Array app_key, String comp_cd, String orgn_cd, String comment, WkfNegoMailInfo nego, WkfExecutantInfo executant, String next_activity_cd, WkfCreateRouteInfo route_info)に置き換えられました。
※ このメソッドを使用すると、ルート作成情報：nullでサブプロセスの申請処理を実行します。
サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
process_temporary_cd | String | 一時プロセスID(任意)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーション配列(任意：０〜８要素まで)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 起票コメント(任意)
nego | WkfNegoMailInfo | 根回しメールオブジェクト(任意)
executant | WkfExecutantInfo | 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
返却値
WkfResultInfo 処理結果オブジェクト
subProcessDraft

WkfResultInfo subProcessDraft (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,String process_temporary_cd ,String process_name ,Array app_key ,String comp_cd ,String orgn_cd ,String comment ,WkfNegoMailInfo nego ,WkfExecutantInfo executant ,String route_select_cd ,WkfCreateRouteInfo route_info)

サブプロセスの先頭タスクで申請を選択した場合の申請処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
一時プロセスIDには、以下に示す文字を含めることはできません。
・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)
(全角文字等日本語は使用できません)
ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。
ユーザが組織に所属しているのに「所属なし」と指定した場合、エラーとなります。
アプリケーションキー配列は、必ず要素０から指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
process_temporary_cd | String | 一時プロセスID(任意)
process_name | String | プロセス名(必須)
app_key | Array | アプリケーション配列(任意：０〜８要素まで)
comp_cd | String | ユーザの起票会社コード(任意：未所属の場合のみ未指定可)
orgn_cd | String | ユーザの起票組織コード(任意：未所属の場合のみ未指定可)
comment | String | 起票コメント(任意)
nego WkfNegoMailInfo 根回しメールオブジェクト(任意)
executant WkfExecutantInfo 次承認者オブジェクト(次承認者が実行時選択時)
route_select_cd | String | ルート選択番号(次タスクがユーザ選択時)
route_info WkfCreateRouteInfo ルート作成情報オブジェクト(次タスクがルート作成時)
返却値
WkfResultInfo 処理結果オブジェクト


 WkfDraftResultInfo オブジェクト

起票処理結果オブジェクト。
起票処理結果オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfDraftResultInfo(Object) 起票処理結果オブジェクト
 ├isSuccess(Boolean)   処理結果(true:成功/false:失敗)
 ├getId(String)        エクセプションID
 ├getMessage(String)   エラーメッセージ
 └processInfo(Object)  起票プロセスの情報(処理成功時のみ)
    ├process_def_cd(String)            プロセス定義コード
    ├version_cd(String)                バージョンコード
    ├process_cd(String)                プロセスコード
    ├process_name(String)              プロセス名
    ├draft_date(String)                起票日
    ├draft_user_cd(String)             起票者コード
    ├draft_user_name(String)           起票者名
    ├draft_comment(String)             起票コメント
    ├company_cd(String)                起票者の起票会社コード
    ├code_value(String)                起票者の起票組織コード
    ├group_name(String)                起票者の起票組織名
    ├draft_appoint_date(String)        起票指定日
    ├transactor_cd(String)             処理者コード
    ├transactor_name(String)           処理者名
    ├locale_id(String)                 処理者ロケールID
    ├process_status(String)            プロセスステータス
    ├last_man_activity_cd(String)      最終手動アクティビティコード
    ├last_man_activity_result(String)  最終手動アクティビティ承認結果種別
    ├parent_process_def_cd(String)     親プロセス定義コード
    ├parent_version_cd(String)         親バージョンコード
    ├parent_process_cd(String)         親プロセスコード
    ├parent_activity_cd(String)        親アクティビティコード
    ├processing_status(String)         処理状態識別
    ├process_nest_cnt(String)          サブプロセス呼出カウンタ
    ├parallel_nest_cnt(String)         同期処理階層カウンタ
    ├present_display_info(String)      現処理表示情報
    ├extension_a(String)               拡張エリアＡ
    ├extension_b(String)               拡張エリアＢ
    ├extension_c(String)               拡張エリアＣ
    ├extension_d(String)               拡張エリアＤ
    ├extension_e(String)               拡張エリアＥ
    ├extension_f(String)               拡張エリアＦ
    ├extension_g(String)               拡張エリアＧ
    ├extension_h(String)               拡張エリアＨ
    ├create_date(String)               作成日時
    ├create_user_cd(String)            作成者コード
    ├create_user_name(String)          作成者名
    ├record_date(String)               最終更新日時
    ├record_user_cd(String)            最終更新者コード
    └record_user_name(String)          最終更新者名

プロパティの概要
String | getId エクセプションID。 | 読込み専用
String | getMessage エラーメッセージ。 | 読込み専用
Boolean | isSuccess 処理結果(true:成功/false:失敗)。 | 読込み専用
Object | processInfo 起票プロセスの情報(処理成功時のみ)。 | 読込み専用
String | processInfo.code_value 起票者の起票組織コード。 | 読込み専用
String | processInfo.company_cd 起票者の起票会社コード。 | 読込み専用
String | processInfo.create_date 作成日時。 | 読込み専用
String | processInfo.create_user_cd 作成者コード。 | 読込み専用
String | processInfo.create_user_name 作成者名。 | 読込み専用
String | processInfo.draft_appoint_date 起票指定日。 | 読込み専用
String | processInfo.draft_comment 起票コメント。 | 読込み専用
String | processInfo.draft_date 起票日。 | 読込み専用
String | processInfo.draft_user_cd 起票者コード。 | 読込み専用
String | processInfo.draft_user_name 起票者名。 | 読込み専用
String | processInfo.extension_a 拡張エリアＡ。 | 読込み専用
String | processInfo.extension_b 拡張エリアＢ。 | 読込み専用
String | processInfo.extension_c 拡張エリアＣ。 | 読込み専用
String | processInfo.extension_d 拡張エリアＤ。 | 読込み専用
String | processInfo.extension_e 拡張エリアＥ。 | 読込み専用
String | processInfo.extension_f 拡張エリアＦ。 | 読込み専用
String | processInfo.extension_g 拡張エリアＧ。 | 読込み専用
String | processInfo.extension_h 拡張エリアＨ。 | 読込み専用
String | processInfo.group_name 起票者の起票組織名。 | 読込み専用
String | processInfo.last_man_activity_cd 最終手動アクティビティコード。 | 読込み専用
String | processInfo.last_man_activity_result 最終手動アクティビティ承認結果種別。 | 読込み専用
String | processInfo.locale_id 処理者ロケールID。 | 読込み専用
String | processInfo.parallel_nest_cnt 同期処理階層カウンタ。 | 読込み専用
String | processInfo.parent_activity_cd 親アクティビティコード。 | 読込み専用
String | processInfo.parent_process_cd 親プロセスコード。 | 読込み専用
String | processInfo.parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | processInfo.parent_version_cd 親バージョンコード。 | 読込み専用
String | processInfo.present_display_info 現処理表示情報。 | 読込み専用
String | processInfo.process_cd プロセスコード。 | 読込み専用
String | processInfo.process_def_cd プロセス定義コード。 | 読込み専用
String | processInfo.process_name プロセス名。 | 読込み専用
String | processInfo.process_nest_cnt サブプロセス呼出カウンタ。 | 読込み専用
String | processInfo.process_status プロセスステータス。 | 読込み専用
String | processInfo.processing_status 処理状態識別。 | 読込み専用
String | processInfo.record_date 最終更新日時。 | 読込み専用
String | processInfo.record_user_cd 最終更新者コード。 | 読込み専用
String | processInfo.record_user_name 最終更新者名。 | 読込み専用
String | processInfo.transactor_cd 処理者コード。 | 読込み専用
String | processInfo.transactor_name 処理者名。 | 読込み専用
String | processInfo.version_cd バージョンコード。 | 読込み専用
プロパティの詳細
getId

String getId (読込み専用プロパティ)

エクセプションID。
getMessage

String getMessage (読込み専用プロパティ)

エラーメッセージ。
isSuccess

Boolean isSuccess (読込み専用プロパティ)

処理結果(true:成功/false:失敗)。
processInfo

Object processInfo (読込み専用プロパティ)

起票プロセスの情報(処理成功時のみ)。
processInfo.code_value

String processInfo.code_value (読込み専用プロパティ)

起票者の起票組織コード。
processInfo.company_cd

String processInfo.company_cd (読込み専用プロパティ)

起票者の起票会社コード。
processInfo.create_date

String processInfo.create_date (読込み専用プロパティ)

作成日時。
processInfo.create_user_cd

String processInfo.create_user_cd (読込み専用プロパティ)

作成者コード。
processInfo.create_user_name

String processInfo.create_user_name (読込み専用プロパティ)

作成者名。
processInfo.draft_appoint_date

String processInfo.draft_appoint_date (読込み専用プロパティ)

起票指定日。
processInfo.draft_comment

String processInfo.draft_comment (読込み専用プロパティ)

起票コメント。
processInfo.draft_date

String processInfo.draft_date (読込み専用プロパティ)

起票日。
processInfo.draft_user_cd

String processInfo.draft_user_cd (読込み専用プロパティ)

起票者コード。
processInfo.draft_user_name

String processInfo.draft_user_name (読込み専用プロパティ)

起票者名。
processInfo.extension_a

String processInfo.extension_a (読込み専用プロパティ)

拡張エリアＡ。
processInfo.extension_b

String processInfo.extension_b (読込み専用プロパティ)

拡張エリアＢ。
processInfo.extension_c

String processInfo.extension_c (読込み専用プロパティ)

拡張エリアＣ。
processInfo.extension_d

String processInfo.extension_d (読込み専用プロパティ)

拡張エリアＤ。
processInfo.extension_e

String processInfo.extension_e (読込み専用プロパティ)

拡張エリアＥ。
processInfo.extension_f

String processInfo.extension_f (読込み専用プロパティ)

拡張エリアＦ。
processInfo.extension_g

String processInfo.extension_g (読込み専用プロパティ)

拡張エリアＧ。
processInfo.extension_h

String processInfo.extension_h (読込み専用プロパティ)

拡張エリアＨ。
processInfo.group_name

String processInfo.group_name (読込み専用プロパティ)

起票者の起票組織名。
processInfo.last_man_activity_cd

String processInfo.last_man_activity_cd (読込み専用プロパティ)

最終手動アクティビティコード。
processInfo.last_man_activity_result

String processInfo.last_man_activity_result (読込み専用プロパティ)

最終手動アクティビティ承認結果種別。
processInfo.locale_id

String processInfo.locale_id (読込み専用プロパティ)

処理者ロケールID。
processInfo.parallel_nest_cnt

String processInfo.parallel_nest_cnt (読込み専用プロパティ)

同期処理階層カウンタ。
processInfo.parent_activity_cd

String processInfo.parent_activity_cd (読込み専用プロパティ)

親アクティビティコード。
processInfo.parent_process_cd

String processInfo.parent_process_cd (読込み専用プロパティ)

親プロセスコード。
processInfo.parent_process_def_cd

String processInfo.parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
processInfo.parent_version_cd

String processInfo.parent_version_cd (読込み専用プロパティ)

親バージョンコード。
processInfo.present_display_info

String processInfo.present_display_info (読込み専用プロパティ)

現処理表示情報。
processInfo.process_cd

String processInfo.process_cd (読込み専用プロパティ)

プロセスコード。
processInfo.process_def_cd

String processInfo.process_def_cd (読込み専用プロパティ)

プロセス定義コード。
processInfo.process_name

String processInfo.process_name (読込み専用プロパティ)

プロセス名。
processInfo.process_nest_cnt

String processInfo.process_nest_cnt (読込み専用プロパティ)

サブプロセス呼出カウンタ。
processInfo.process_status

String processInfo.process_status (読込み専用プロパティ)

プロセスステータス。
processInfo.processing_status

String processInfo.processing_status (読込み専用プロパティ)

処理状態識別。
processInfo.record_date

String processInfo.record_date (読込み専用プロパティ)

最終更新日時。
processInfo.record_user_cd

String processInfo.record_user_cd (読込み専用プロパティ)

最終更新者コード。
processInfo.record_user_name

String processInfo.record_user_name (読込み専用プロパティ)

最終更新者名。
processInfo.transactor_cd

String processInfo.transactor_cd (読込み専用プロパティ)

処理者コード。
processInfo.transactor_name

String processInfo.transactor_name (読込み専用プロパティ)

処理者名。
processInfo.version_cd

String processInfo.version_cd (読込み専用プロパティ)

バージョンコード。


 WkfEndProcessResultInfo オブジェクト

起票済み案件情報オブジェクト。
起票済み案件情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | activity_cd アクティビティコード(isJunction=trueのときはnull)。 | 読込み専用
String | activity_name アクティビティ名(isJunction=trueのときはnull)。 | 読込み専用
String | activity_status アクティビティステータス(isJunction=trueのときはnull)。 | 読込み専用
String | agent_cd 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。 | 読込み専用
String | agent_name 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。 | 読込み専用
String | agent_target 代理依頼先対象(本人用でインスタンス作成時)。 | 読込み専用
String | attainment_class 到達種別(isJunction=trueのときはnull)。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
Boolean | client_auth_flg 代理元承認可否フラグ。 | 読込み専用
String | client_user_cd 代理依頼元ユーザコード(代理人用でインスタンス作成時)。 | 読込み専用
String | client_user_name 代理依頼元ユーザ名(代理人用でインスタンス作成時)。 | 読込み専用
String | draft_appoint_date 起票指定日。 | 読込み専用
String | draft_date 起票日。 | 読込み専用
String | draft_user_cd 起票者コード。 | 読込み専用
String | draft_user_comp_cd 起票者の処理時の会社コード。 | 読込み専用
String | draft_user_main_flg 主・副所属フラグ。 | 読込み専用
String | draft_user_name 起票者名。 | 読込み専用
String | draft_user_orgn_cd 起票者の処理時の組織コード。 | 読込み専用
Boolean | isJunction ルートが同期していればtrue。 | 読込み専用
String | now_approval_name 現処理ユーザ/組織/オフィシャルG/ロール名(isJunction=trueのときはnull)。 | 読込み専用
String | parent_process_cd 親プロセスコード。 | 読込み専用
String | parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | parent_version_cd 親プロセスバージョンコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_cls_cd プロセス種別コード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | process_end_status プロセス終了ステータス。 | 読込み専用
String | process_name プロセス名。 | 読込み専用
String | process_status プロセスステータス。 | 読込み専用
String | process_term_date 処理期限日付。 | 読込み専用
Boolean | pull_activity_flg 引き戻し可否フラグ(true:可/false:不可)。 | 読込み専用
String | reception_date 受信日付。 | 読込み専用
Boolean | transfer_flg 代理起票フラグ。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード(isJunction=trueのときはnull)。
activity_name

String activity_name (読込み専用プロパティ)

アクティビティ名(isJunction=trueのときはnull)。
activity_status

String activity_status (読込み専用プロパティ)

アクティビティステータス(isJunction=trueのときはnull)。
agent_cd

String agent_cd (読込み専用プロパティ)

代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。
agent_name

String agent_name (読込み専用プロパティ)

代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。
agent_target

String agent_target (読込み専用プロパティ)

代理依頼先対象(本人用でインスタンス作成時)。
attainment_class

String attainment_class (読込み専用プロパティ)

到達種別(isJunction=trueのときはnull)。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
client_auth_flg

Boolean client_auth_flg (読込み専用プロパティ)

代理元承認可否フラグ。
client_user_cd

String client_user_cd (読込み専用プロパティ)

代理依頼元ユーザコード(代理人用でインスタンス作成時)。
client_user_name

String client_user_name (読込み専用プロパティ)

代理依頼元ユーザ名(代理人用でインスタンス作成時)。
draft_appoint_date

String draft_appoint_date (読込み専用プロパティ)

起票指定日。
draft_date

String draft_date (読込み専用プロパティ)

起票日。
draft_user_cd

String draft_user_cd (読込み専用プロパティ)

起票者コード。
draft_user_comp_cd

String draft_user_comp_cd (読込み専用プロパティ)

起票者の処理時の会社コード。
draft_user_main_flg

String draft_user_main_flg (読込み専用プロパティ)

主・副所属フラグ。
draft_user_name

String draft_user_name (読込み専用プロパティ)

起票者名。
draft_user_orgn_cd

String draft_user_orgn_cd (読込み専用プロパティ)

起票者の処理時の組織コード。
isJunction

Boolean isJunction (読込み専用プロパティ)

ルートが同期していればtrue。
now_approval_name

String now_approval_name (読込み専用プロパティ)

現処理ユーザ/組織/オフィシャルG/ロール名(isJunction=trueのときはnull)。
parent_process_cd

String parent_process_cd (読込み専用プロパティ)

親プロセスコード。
parent_process_def_cd

String parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
parent_version_cd

String parent_version_cd (読込み専用プロパティ)

親プロセスバージョンコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_cls_cd

String process_cls_cd (読込み専用プロパティ)

プロセス種別コード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
process_end_status

String process_end_status (読込み専用プロパティ)

プロセス終了ステータス。
process_name

String process_name (読込み専用プロパティ)

プロセス名。
process_status

String process_status (読込み専用プロパティ)

プロセスステータス。
process_term_date

String process_term_date (読込み専用プロパティ)

処理期限日付。
pull_activity_flg

Boolean pull_activity_flg (読込み専用プロパティ)

引き戻し可否フラグ(true:可/false:不可)。
reception_date

String reception_date (読込み専用プロパティ)

受信日付。
transfer_flg

Boolean transfer_flg (読込み専用プロパティ)

代理起票フラグ。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


 WkfEndTaskResultInfo オブジェクト

処理済案件オブジェクト。
処理済案件オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | activity_cd 処理時のアクティビティコード。 | 読込み専用
String | activity_name 処理時のアクティビティ名。 | 読込み専用
String | agent_cd 代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。 | 読込み専用
String | agent_name 代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。 | 読込み専用
String | agent_target 代理依頼先対象(本人用でインスタンス作成時)。 | 読込み専用
String | approval_agent_user_cd 承認代理元ユーザコード(代理人用でインスタンス作成時)。 | 読込み専用
String | approval_agent_user_name 承認代理元ユーザ名(代理人用でインスタンス作成時)。 | 読込み専用
String | approval_date 処理日。 | 読込み専用
Boolean | approval_transfer_flg 承認結果履歴代理フラグ。 | 読込み専用
String | approval_type 処理結果。 | 読込み専用
String | approval_user_cd 処理ユーザコード。 | 読込み専用
String | approval_user_name 処理ユーザ名。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
Boolean | client_auth_flg 代理元承認可否フラグ。 | 読込み専用
String | draft_appoint_date 起票指定日。 | 読込み専用
String | draft_date 起票日。 | 読込み専用
String | draft_user_cd 起票者コード。 | 読込み専用
String | draft_user_comp_cd 起票者の処理時の会社コード。 | 読込み専用
String | draft_user_main_flg 主・副所属フラグ。 | 読込み専用
String | draft_user_name 起票者名。 | 読込み専用
String | draft_user_orgn_cd 起票者の処理時の組織コード。 | 読込み専用
Boolean | isJunction ルートが同期していればtrue。 | 読込み専用
String | parent_process_cd 親プロセスコード。 | 読込み専用
String | parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | parent_version_cd 親プロセスバージョンコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_cls_cd プロセス種別コード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | process_end_status プロセス終了ステータス。 | 読込み専用
String | process_name プロセス名。 | 読込み専用
String | process_status プロセスステータス。 | 読込み専用
String | processing_status 現在の状態。 | 読込み専用
Boolean | pull_activity_flg 引き戻し可否フラグ(true:可/false:不可)。 | 読込み専用
Boolean | transfer_flg 代理依頼フラグ。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

処理時のアクティビティコード。
activity_name

String activity_name (読込み専用プロパティ)

処理時のアクティビティ名。
agent_cd

String agent_cd (読込み専用プロパティ)

代理依頼先ユーザ/組織コード(本人用でインスタンス作成時)。
agent_name

String agent_name (読込み専用プロパティ)

代理依頼先ユーザ/組織名(本人用でインスタンス作成時)。
agent_target

String agent_target (読込み専用プロパティ)

代理依頼先対象(本人用でインスタンス作成時)。
approval_agent_user_cd

String approval_agent_user_cd (読込み専用プロパティ)

承認代理元ユーザコード(代理人用でインスタンス作成時)。
approval_agent_user_name

String approval_agent_user_name (読込み専用プロパティ)

承認代理元ユーザ名(代理人用でインスタンス作成時)。
approval_date

String approval_date (読込み専用プロパティ)

処理日。
approval_transfer_flg

Boolean approval_transfer_flg (読込み専用プロパティ)

承認結果履歴代理フラグ。
approval_type

String approval_type (読込み専用プロパティ)

処理結果。
approval_user_cd

String approval_user_cd (読込み専用プロパティ)

処理ユーザコード。
approval_user_name

String approval_user_name (読込み専用プロパティ)

処理ユーザ名。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
client_auth_flg

Boolean client_auth_flg (読込み専用プロパティ)

代理元承認可否フラグ。
draft_appoint_date

String draft_appoint_date (読込み専用プロパティ)

起票指定日。
draft_date

String draft_date (読込み専用プロパティ)

起票日。
draft_user_cd

String draft_user_cd (読込み専用プロパティ)

起票者コード。
draft_user_comp_cd

String draft_user_comp_cd (読込み専用プロパティ)

起票者の処理時の会社コード。
draft_user_main_flg

String draft_user_main_flg (読込み専用プロパティ)

主・副所属フラグ。
draft_user_name

String draft_user_name (読込み専用プロパティ)

起票者名。
draft_user_orgn_cd

String draft_user_orgn_cd (読込み専用プロパティ)

起票者の処理時の組織コード。
isJunction

Boolean isJunction (読込み専用プロパティ)

ルートが同期していればtrue。
parent_process_cd

String parent_process_cd (読込み専用プロパティ)

親プロセスコード。
parent_process_def_cd

String parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
parent_version_cd

String parent_version_cd (読込み専用プロパティ)

親プロセスバージョンコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_cls_cd

String process_cls_cd (読込み専用プロパティ)

プロセス種別コード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
process_end_status

String process_end_status (読込み専用プロパティ)

プロセス終了ステータス。
process_name

String process_name (読込み専用プロパティ)

プロセス名。
process_status

String process_status (読込み専用プロパティ)

プロセスステータス。
processing_status

String processing_status (読込み専用プロパティ)

現在の状態。
pull_activity_flg

Boolean pull_activity_flg (読込み専用プロパティ)

引き戻し可否フラグ(true:可/false:不可)。
transfer_flg

Boolean transfer_flg (読込み専用プロパティ)

代理依頼フラグ。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


 WkfExecutantInfo オブジェクト

次承認者オブジェクト。
次承認者オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | cd 承認ユーザ/組織コード(必須)。 | 通常
String | comp_cd 会社コード(typeで組織選択時に指定します)。 | 通常
String | type 承認者タイプ(必須 ユーザ：user/組織：orgn)。 | 通常
プロパティの詳細
cd

String cd

承認ユーザ/組織コード(必須)。
comp_cd

String comp_cd

会社コード(typeで組織選択時に指定します)。
type

String type

承認者タイプ(必須 ユーザ：user/組織：orgn)。


 WkfFileResultInfo オブジェクト

添付ファイルオブジェクト。
添付ファイルオブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | file_cd ファイルID。 | 読込み専用
String | file_name ファイル名（論理ファイル名）。 | 読込み専用
Int | file_size ファイルサイズ(バイト)。 | 読込み専用
String | path ファイルパス(storageからの相対パス)。 | 読込み専用
プロパティの詳細
file_cd

String file_cd (読込み専用プロパティ)

ファイルID。
file_name

String file_name (読込み専用プロパティ)

ファイル名（論理ファイル名）。
file_size

Int file_size (読込み専用プロパティ)

ファイルサイズ(バイト)。
path

String path (読込み専用プロパティ)

ファイルパス(storageからの相対パス)。


 WkfFlowInfo オブジェクト

フロー情報オブジェクトAPI。
特定のタスクの位置情報を保持した、フロー情報を取得する。
このAPIは、フロー情報オブジェクトを使用する為のAPIです。

<サンプル>
コンストラクタの概要
WkfFlowInfo (Object info)
コンストラクタ。
メソッドの概要
String | getActivityCd () アクティビティコードを取得します。
String | getActivityType () アクティビティ種別を取得します。
Boolean | getEndFlg () 終了フラグを取得します。
Object | getFirst () 最初のタスクのフロー情報を取得します。
Boolean | getIsSubProcess () サブプロセスフラグを取得します。
Object | getLast () 最後のタスクのフロー情報を取得します。
Array | getNext () 次のタスクのフロー情報を取得します。
Array | getPrev () 前のタスクのフロー情報を取得します。
String | getProcessDefCd () プロセス定義コードを取得します。
String | getVersionCd () バージョンコードを取得します。
Boolean | hasNext () 次のタスクが存在するかどうかを返却します。
Boolean | hasPrev () 前のタスクが存在するかどうかを返却します。
コンストラクタの詳細
WkfFlowInfo

WkfFlowInfo (Object info)
コンストラクタ。
パラメータ(info)には、WkfManager#getFlowInfoなどを使用し取得した
フロー情報オブジェクトを指定してください。
パラメータ
info Object フロー情報オブジェクト
メソッドの詳細
getActivityCd

String getActivityCd ()

アクティビティコードを取得します。
返却値
String アクティビティコード
getActivityType

String getActivityType ()

アクティビティ種別を取得します。
返却値
String アクティビティ種別
getEndFlg

Boolean getEndFlg ()

終了フラグを取得します。
現在のタスクが分岐・同期の終了タスクの場合にtrueを取得します。
返却値
Boolean 「終了」の場合:true / 「始点」の場合:false
getFirst

Object getFirst ()

最初のタスクのフロー情報を取得します。
ルート上の最初のタスクの情報を取得します。
返却値
Object フロー情報オブジェクト
getIsSubProcess

Boolean getIsSubProcess ()

サブプロセスフラグを取得します。
現在のタスクがサブプロセスの場合にtrueを取得します。
返却値
Boolean サブプロセス:true/通常タスク:false
getLast

Object getLast ()

最後のタスクのフロー情報を取得します。
ルート上の最後のタスク情報を取得します。
返却値
Object フロー情報オブジェクト
getNext

Array getNext ()

次のタスクのフロー情報を取得します。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に次タスクに状態遷移する）
返却値
Array フロー情報オブジェクト配列
getPrev

Array getPrev ()

前のタスクのフロー情報を取得します。
（同期でルートが複数存在する場合、同期結合まで各ルートが同時に前タスクに状態遷移する）
返却値
Array フロー情報オブジェクト配列
getProcessDefCd

String getProcessDefCd ()

プロセス定義コードを取得します。
返却値
String プロセス定義コード
getVersionCd

String getVersionCd ()

バージョンコードを取得します。
返却値
String バージョンコード
hasNext

Boolean hasNext ()

次のタスクが存在するかどうかを返却します。
返却値
Boolean 存在する:true/存在しない:false
hasPrev

Boolean hasPrev ()

前のタスクが存在するかどうかを返却します。
返却値
Boolean 存在する:true/存在しない:false


 WkfFlowResultInfo オブジェクト

現在位置情報オブジェクト。
現在位置情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | activity_cd アクティビティコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。


 WkfImportProcessDefResultInfo オブジェクト

プロセス情報オブジェクト。
プロセス情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | message 処理結果メッセージ。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | sheet_name シート名（Excelのシート名）。 | 読込み専用
String | status 処理結果ID。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
プロパティの詳細
message

String message (読込み専用プロパティ)

処理結果メッセージ。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
sheet_name

String sheet_name (読込み専用プロパティ)

シート名（Excelのシート名）。
status

String status (読込み専用プロパティ)

処理結果ID。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。


 WkfMailSettingBehavior オブジェクト

プログラムサポート/メール送信　リザーブフラグ設定クラス。
テンプレートメールの予約や停止などを行う場合に使用します。
コンストラクタの概要
WkfMailSettingBehavior ()
コンストラクタ
メソッドの概要
String | getResult () エラーコードを返却します。
String | remove () 処理失敗時にWkfMailSettingBehaviorを使用し設定された情報を削除する為に使用します。
String | reserveCancel () メール予約機能の使用を取消します。
String | reserveRequest () メール予約機能の使用を依頼します。
String | send () メールの送信を実行します。
String | setStopMail (String key) 停止対象となるテンプレートメール情報を保持します。
String | setTamplateRequest (String templatePath) メールテンプレートの設定を行います。
String | stopCancel () テンプレートメールの送信停止を取り止めます。
String | stopRequest () 同一スレッド内のテンプレートメールの標準送信を停止させます。
コンストラクタの詳細
WkfMailSettingBehavior

WkfMailSettingBehavior ()
コンストラクタ
メソッドの詳細
getResult

String getResult ()

エラーコードを返却します。
エラーコードは、BPWErrorCodeIFで定義された定義値です。
エラーでない場合は、””(空文字)が返却されます。
返却値
String エラーコード
remove

String remove ()

処理失敗時にWkfMailSettingBehaviorを使用し設定された情報を削除する為に使用します。
申請/承認等の処理が失敗した場合にこのメソッドを実行してください。
このメソッドが実行されなかった場合、設定された情報が残ってしまい、
予期しない動作を起こす可能性があります。
返却値
String エラーコード
reserveCancel

String reserveCancel ()

メール予約機能の使用を取消します。
reserveRequest()を使用してメール予約の設定をしてある場合、そのメール予約を取り消します。
返却値
String エラーコード
reserveRequest

String reserveRequest ()

メール予約機能の使用を依頼します。
処理が正常終了した場合にのみテンプレートメールが送信されるように、メール予約を行います。
返却値
String エラーコード
send

String send ()

メールの送信を実行します。
送信予約されているメールがある場合に、そのメールの送信を行います。
APIを使用して申請等の処理を行っている場合に、使用します。
WkfMailSettingBehaviorを使用する場合は処理が正常終了した後に
必ず実行してください。
また、処理が失敗した場合はremove()を実行してください。
返却値
String エラーコード
setStopMail

String setStopMail (String key)

停止対象となるテンプレートメール情報を保持します。
引数には停止対象となるメールテンプレートキーを指定してください。
パラメータ
key String メールテンプレートキー(必須)
返却値
String エラーコード
setTamplateRequest

String setTamplateRequest (String templatePath)

メールテンプレートの設定を行います。
テンプレートメールの送信時に送信されるメールのテンプレートを変更したいときに使用します。
StorageService からのメールテンプレート相対パスを指定してください。
パラメータ
templatePath String テンプレートパス(必須)
返却値
String エラーコード
stopCancel

String stopCancel ()

テンプレートメールの送信停止を取り止めます。
stopRequest()を使用してテンプレートメールの送信停止の設定をしてある場合、
その送信停止の設定を取り止め、解除します。
返却値
String エラーコード
stopRequest

String stopRequest ()

同一スレッド内のテンプレートメールの標準送信を停止させます。
テンプレートメールの標準送信機能を停止させたい場合に使用します。
返却値
String エラーコード


 WkfManager オブジェクト

マスタ関連のAPI。
マスタメンテナンス関連処理で使用されるクラスです。

<サンプル>
定数の概要
static String | AUTHORITY_ALL 絞り込み条件：なし
static String | AUTHORITY_EDIT 絞り込み条件：編集権限で絞り込み
static String | AUTHORITY_READ 絞り込み条件：処理権限で絞り込み
コンストラクタの概要
WkfManager (String user_cd ,String login_group_id)
コンストラクタ。
メソッドの概要
Object | addVersion (String process_def_cd ,String version_notes ,String effective_date ,String end_date ,Object process_contents_path ,Array root_info) 推奨されていません。 指定されたプロセス定義に新規バージョンを追加します。 返却値は、処理結果を返却します。 データベーストランザクションは標準で使用することになっていますので、 使用しない場合は先に「noTransaction()」メソッドを使用してください。 ルート情報を指定する場合、本APIで登録可能なルート情報は、処理タスクのみです。 分岐・同期・サブプロセス等のタスクには対応しておりません。
WkfResultInfo | controlProcess (String process_def_cd ,String version_cd ,String process_cd ,String target_activity_cd) プロセス操作を実行します。
String | exportProcessDef (Array process_def_cd) プロセス定義(Excel形式)エクスポートを実行します。
WkfActivityResultInfo | getActivityInfo (String process_def_cd ,String version_cd ,String activity_cd) 推奨されていません。 getActivityInfo(String process_def_cd, String version_cd, String activity_cd, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
WkfActivityResultInfo | getActivityInfo (String process_def_cd ,String version_cd ,String activity_cd ,String authority) プロセス定義コード、バージョンコード、アクティビティコード、絞込み条件をキーとして タスク(アクティビティ)情報を取得します。
WkfCategoryResultInfo | getCategoryInfo (String category_cd) 推奨されていません。 getCategoryInfo(String category_cd, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
WkfCategoryResultInfo | getCategoryInfo (String category_cd ,String authority) カテゴリコード、絞込み条件をキーとしてカテゴリ情報オブジェクトを取得します。
Array | getCategoryInfoByName (String category_name) 推奨されていません。 getCategoryInfoByName(String category_name, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
Array | getCategoryInfoByName (String category_name ,String authority) カテゴリ名、絞込み条件をキーとしてカテゴリ情報オブジェクトを取得します。
Object | getFlowInfo (String process_def_cd ,String version_cd ,String activity_cd) 推奨されていません。 getFlowInfo(String process_def_cd, String version_cd, String activity_cd, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
Object | getFlowInfo (String process_def_cd ,String version_cd ,String activity_cd ,String authority) 特定のタスクの位置情報を保持した、フローの情報を取得します。
Object | getFlowInfoByTargetNo (String process_def_cd ,String version_cd ,String target_task_no ,String authority) 特定のタスクの位置情報を保持した、フローの情報を取得します。
WkfProcessDefResultInfo | getProcessDefInfo (String process_def_cd) 推奨されていません。 getProcessDefInfo(String process_def_cd, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
WkfProcessDefResultInfo | getProcessDefInfo (String process_def_cd ,String authority) プロセス定義コード、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
Array | getProcessDefInfoByCategory (String category_cd ,String authority) カテゴリコード、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
Array | getProcessDefInfoByName (String process_def_name) 推奨されていません。 getProcessDefInfoByName(String process_def_name, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
Array | getProcessDefInfoByName (String process_def_name ,String authority) プロセス定義名、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
WkfProcessDefInfoByVersionResultInfo | getProcessDefInfoByVersion (String process_def_cd ,String version_cd) 推奨されていません。 getProcessDefInfoByVersion(String process_def_cd, String version_cd, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
WkfProcessDefInfoByVersionResultInfo | getProcessDefInfoByVersion (String process_def_cd ,String version_cd ,String authority) プロセス定義コード、バージョンコード、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
Array | getProcessList (WkfSearchCondition condition_key ,Array sort_key ,Number start ,Number amount) 推奨されていません。 getProcessList(WkfSearchCondition condition_key, Array sort_key, int start, int amount, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
Array | getProcessList (WkfSearchCondition condition_key ,Array sort_key ,Number start ,Number amount ,String authority) プロセス一覧情報を取得します。
WkfVersionResultInfo | getVersionInfo (String process_def_cd ,String version_cd) 推奨されていません。 getVersionInfo(String process_def_cd, String version_cd, String authority)に置き換えられました。 ※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
WkfVersionResultInfo | getVersionInfo (String process_def_cd ,String version_cd ,String authority) プロセス定義コード、バージョンコード、絞込み条件をキーとしてバージョン(ルート)情報を取得します。
WkfImportProcessDefResultInfo | importProcessDef (String xls_file) プロセス定義(Excel形式)インポートを実行します。
void | noTransaction () データベーストランザクションを未使用にする。
Object | registProcessDef (String category_cd ,String process_def_name ,String process_def_notes ,String version_notes ,String process_class_code ,Boolean sub_process_flag ,Boolean attachment_flag ,String effective_date ,String end_date ,Object process_contents_path ,Array root_info) 推奨されていません。 新規プロセス定義の登録を行います。 返却値は、処理結果を返却します。 データベーストランザクションは標準で使用することになっていますので、 使用しない場合は先に「noTransaction()」メソッドを使用してください。 本APIで登録可能なルート情報は、処理タスクのみです。 分岐・同期・サブプロセス等のタスクには対応しておりません。
WkfResultInfo | removeProcess (String process_def_cd ,String version_cd ,String process_cd ,Boolean xml_out_flg) 案件の削除処理を実行します。
定数の詳細
AUTHORITY_ALL

static String AUTHORITY_ALL

絞り込み条件：なし
定数値 ： "2"
AUTHORITY_EDIT

static String AUTHORITY_EDIT

絞り込み条件：編集権限で絞り込み
定数値 ： "1"
AUTHORITY_READ

static String AUTHORITY_READ

絞り込み条件：処理権限で絞り込み
定数値 ： "0"
コンストラクタの詳細
WkfManager

WkfManager (String user_cd ,String login_group_id)
コンストラクタ。
パラメータ
user_cd | String | ユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
addVersion

Object addVersion (String process_def_cd ,String version_notes ,String effective_date ,String end_date ,Object process_contents_path ,Array root_info)

推奨されていません。
指定されたプロセス定義に新規バージョンを追加します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
ルート情報を指定する場合、本APIで登録可能なルート情報は、処理タスクのみです。
分岐・同期・サブプロセス等のタスクには対応しておりません。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_notes | String | バージョン備考(任意)
effective_date | String | 開始日付(必須)
end_date | String | 終了日付(任意：指定なしの場合「9999/12/31」)
process_contents_path | Object | プロセスコンテンツパス(任意：指定なしの場合、最新バージョンと同様)
root_info Array ルート情報(任意：指定なしの場合、最新バージョンと同様)
 Object //プロセスコンテンツパスオブジェクト
 ├apply_path(Object)    通常コンテンツパス(必須：コンテンツパス詳細オブジェクトを指定)
 ├pull_path(Object)     引き戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)
 ├return_path(Object)   差し戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)
 ├detail_path(Object)   詳細コンテンツパス(必須：コンテンツパス詳細オブジェクトを指定)
 └refer_path(Object)    参照コンテンツパス(任意：指定なしの場合、詳細コンテンツパスと同様)

 Object //コンテンツパス詳細オブジェクト
 ├page_kind(String)      ページ種別(必須)
 ├contents_path(String)  コンテンツパス(任意：「PresentationPage」、「Servlet or JSP」の場合に指定)
 ├application_id(String) アプリケーションID(任意：「J2EE FrameWork」の場合に指定)
 └service_id(String)     サービスID(任意：「J2EE FrameWork」の場合に指定)

 Object //処理タスク情報オブジェクト
 ├activity_name(String)     タスク名(必須)
 ├activity_type(String)     タスク種別(必須：処理タスクの場合は1を指定してください。)
 ├post_processing_flag(Boolean)    後処理使用フラグ(必須)
 ├post_processing_program(String)  後処理クラス名(後処理使用フラグがtrueの場合、必須)
 ├contents_frame_type(String)      コンテンツフレーム種別(任意：指定なしの場合、標準)
 ├run_user(Array)                  対象者情報(必須：対象者情報オブジェクト配列を指定)
 ├refer_user(Array)                参照者情報(任意：使用する場合、対象者情報オブジェクト配列を指定)
 ├contents_path(String)            コンテンツパス(任意：指定なしの場合、プロセスコンテンツパスと同様)
 ├auto_pass(String)                期日による自動パス設定日数(任意)
 ├auto_pass_executive(Object)      対象者自動パス設定情報(任意：使用する場合、対象者自動パス設定オブジェクトを指定)
 ├return_flag(Boolean)             差し戻し/引き戻しフラグ(必須)
 ├return_mail_flag(Boolean)        差し戻しメールフラグ(必須)
 ├compulsion_end_flag(Boolean)     途中終了フラグ(必須)
 ├mail_send_flag(Boolean)          催促メール使用フラグ(必須)
 ├mail_postponement(String)        催促猶予日数(催促メール使用フラグがtrueの場合、必須)
 └shortest_end_flag(Boolean)       必須選択最終タスクフラグ(必須：ルート作成タスクのみ使用)

 Object //対象者情報オブジェクト
 ├type(String)           対象者種別(必須)
 ├group_cd(String)       対象者グループコード(任意：対象者種別が組織の場合に指定)
 ├code(String)           対象者コード(必須)
 ├role_restrict(String)  ロール絞り込みID(任意：指定なしの場合、絞り込みなし)
 └post_restrict(Object)  役職絞り込みコード(任意：指定なしの場合、絞り込みなし)

 Object //コンテンツパスオブジェクト
 ├apply_path(Object)    通常コンテンツパス(必須：コンテンツパス詳細オブジェクトを指定)
 ├pull_path(Object)     引き戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)
 └return_path(Object)   差し戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)

 Object //対象者自動パス設定オブジェクト
 ├auto_pass_flag(Boolean)    自動パスフラグ(必須)
 └auto_pass_target(Array)    自動パス対象者情報配列(自動パスフラグがtrueの場合、必須：対象者情報オブジェクト配列を指定)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)      処理結果(true:成功/false:失敗)
 <登録成功時>
 ├process_def_cd(String)  プロセス定義コード
 ├version_cd(String)      バージョンコード
 <登録失敗時>
 ├getId(String)           エクセプションID
 └getMessage(String)      エラーメッセージ
controlProcess

WkfResultInfo controlProcess (String process_def_cd ,String version_cd ,String process_cd ,String target_activity_cd)

プロセス操作を実行します。
プロセス操作では一度処理が到達したタスクにのみ処理を戻すことが出来ます。
失敗時はExceptionが返却されます。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
target_activity_cd | String | 遷移先アクティビティコード(必須)
返却値
WkfResultInfo 処理結果オブジェクト
exportProcessDef

String exportProcessDef (Array process_def_cd)

プロセス定義(Excel形式)エクスポートを実行します。
指定されたプロセス定義コードのプロセス定義をエクスポートします。
返却値はエクセルファイルデータのバイト配列を文字列に変換したものが返却されます。
パラメータ
process_def_cd Array エクスポートプロセス定義コード配列(必須:Stringの配列)
返却値
String エクセルファイルデータ(バイト文字列)
getActivityInfo

WkfActivityResultInfo getActivityInfo (String process_def_cd ,String version_cd ,String activity_cd)

推奨されていません。
getActivityInfo(String process_def_cd, String version_cd, String activity_cd, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
プロセス定義コード、バージョンコード、アクティビティコードをキーとして
タスク(アクティビティ)情報を取得します。
タスク(アクティビティ)情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須：０マスクしないで指定)
activity_cd | String | アクティビティコード(必須)
返却値
WkfActivityResultInfo タスク情報オブジェクト
getActivityInfo

WkfActivityResultInfo getActivityInfo (String process_def_cd ,String version_cd ,String activity_cd ,String authority)

プロセス定義コード、バージョンコード、アクティビティコード、絞込み条件をキーとして
タスク(アクティビティ)情報を取得します。
タスク(アクティビティ)情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須：０マスクしないで指定)
activity_cd | String | アクティビティコード(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
WkfActivityResultInfo タスク情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getCategoryInfo

WkfCategoryResultInfo getCategoryInfo (String category_cd)

推奨されていません。
getCategoryInfo(String category_cd, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
カテゴリコードをキーとしてカテゴリ情報オブジェクトを取得します。
カテゴリ情報オブジェクトを返却します。
パラメータ
category_cd String カテゴリコード(必須)
返却値
WkfCategoryResultInfo カテゴリ情報オブジェクト
getCategoryInfo

WkfCategoryResultInfo getCategoryInfo (String category_cd ,String authority)

カテゴリコード、絞込み条件をキーとしてカテゴリ情報オブジェクトを取得します。
カテゴリ情報オブジェクトを返却します。
パラメータ
category_cd String カテゴリコード(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
WkfCategoryResultInfo カテゴリ情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getCategoryInfoByName

Array getCategoryInfoByName (String category_name)

推奨されていません。
getCategoryInfoByName(String category_name, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
カテゴリ名をキーとしてカテゴリ情報オブジェクトを取得します。
カテゴリ情報オブジェクト配列を返却します。
カテゴリ情報オブジェクトについては、getCategoryInfo()メソッドを参照してください。
引数に"" を指定するとカテゴリ情報の一覧が取得できます。
引数にnull を指定することはできません。
パラメータ
category_name String カテゴリ名(任意)
返却値
Array カテゴリ情報オブジェクト配列
getCategoryInfoByName

Array getCategoryInfoByName (String category_name ,String authority)

カテゴリ名、絞込み条件をキーとしてカテゴリ情報オブジェクトを取得します。
カテゴリ情報オブジェクト配列を返却します。
カテゴリ情報オブジェクトについては、getCategoryInfo()メソッドを参照してください。
引数に"" を指定するとカテゴリ情報の一覧が取得できます。
引数にnull を指定することはできません。
パラメータ
category_name String カテゴリ名(任意)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
Array カテゴリ情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getFlowInfo

Object getFlowInfo (String process_def_cd ,String version_cd ,String activity_cd)

推奨されていません。
getFlowInfo(String process_def_cd, String version_cd, String activity_cd, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
特定のタスクの位置情報を保持した、フローの情報を取得します。
フローの情報オブジェクトを返却します。
フロー情報オブジェクトについては、WkfFlowInfoクラスを参照してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(任意)
返却値
Object フロー情報オブジェクト
getFlowInfo

Object getFlowInfo (String process_def_cd ,String version_cd ,String activity_cd ,String authority)

特定のタスクの位置情報を保持した、フローの情報を取得します。
フローの情報オブジェクトを返却します。
フロー情報オブジェクトについては、WkfFlowInfoクラスを参照してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(任意)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
Object フロー情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getFlowInfoByTargetNo

Object getFlowInfoByTargetNo (String process_def_cd ,String version_cd ,String target_task_no ,String authority)

特定のタスクの位置情報を保持した、フローの情報を取得します。
フローの情報オブジェクトを返却します。
フロー情報オブジェクトについては、WkfFlowInfoクラスを参照してください。
フロー上の先頭タスク情報を取得する場合は対象タスク番号に0を指定してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
target_task_no | String | 対象タスク番号(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
Object フロー情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfo

WkfProcessDefResultInfo getProcessDefInfo (String process_def_cd)

推奨されていません。
getProcessDefInfo(String process_def_cd, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
プロセス定義コードをキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクトを返却します。
パラメータ
process_def_cd String プロセス定義コード(必須)
返却値
WkfProcessDefResultInfo プロセス定義オブジェクト
getProcessDefInfo

WkfProcessDefResultInfo getProcessDefInfo (String process_def_cd ,String authority)

プロセス定義コード、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクトを返却します。
パラメータ
process_def_cd String プロセス定義コード(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
WkfProcessDefResultInfo プロセス定義オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfoByCategory

Array getProcessDefInfoByCategory (String category_cd ,String authority)

カテゴリコード、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクト配列を返却します。
パラメータ
category_cd String カテゴリコード(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
Array プロセス定義オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfoByName

Array getProcessDefInfoByName (String process_def_name)

推奨されていません。
getProcessDefInfoByName(String process_def_name, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
プロセス定義名をキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクト配列を返却します。
引数に"" を指定するとプロセス定義情報の一覧が取得できます。
引数にnull を指定することはできません。
パラメータ
process_def_name String プロセス定義名(任意)
返却値
Array プロセス定義オブジェクト配列
getProcessDefInfoByName

Array getProcessDefInfoByName (String process_def_name ,String authority)

プロセス定義名、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクト配列を返却します。
引数に"" を指定するとプロセス定義情報の一覧が取得できます。
引数にnull を指定することはできません。
パラメータ
process_def_name String プロセス定義名(任意)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
Array プロセス定義オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessDefInfoByVersion

WkfProcessDefInfoByVersionResultInfo getProcessDefInfoByVersion (String process_def_cd ,String version_cd)

推奨されていません。
getProcessDefInfoByVersion(String process_def_cd, String version_cd, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
プロセス定義コード、バージョンコードをキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
返却値
WkfProcessDefInfoByVersionResultInfo プロセス定義オブジェクト(バージョン指定)
getProcessDefInfoByVersion

WkfProcessDefInfoByVersionResultInfo getProcessDefInfoByVersion (String process_def_cd ,String version_cd ,String authority)

プロセス定義コード、バージョンコード、絞込み条件をキーとしてプロセス定義情報オブジェクトを取得します。
プロセス定義情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
WkfProcessDefInfoByVersionResultInfo プロセス定義オブジェクト(バージョン指定)

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessList

Array getProcessList (WkfSearchCondition condition_key ,Array sort_key ,Number start ,Number amount)

推奨されていません。
getProcessList(WkfSearchCondition condition_key, Array sort_key, int start, int amount, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
プロセス一覧情報を取得します。
プロセス情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
condition_key | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array プロセス情報オブジェクト配列
getProcessList

Array getProcessList (WkfSearchCondition condition_key ,Array sort_key ,Number start ,Number amount ,String authority)

プロセス一覧情報を取得します。
プロセス情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
condition_key | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
Array プロセス情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getVersionInfo

WkfVersionResultInfo getVersionInfo (String process_def_cd ,String version_cd)

推奨されていません。
getVersionInfo(String process_def_cd, String version_cd, String authority)に置き換えられました。
※ このメソッドを使用すると、絞込み条件（authority）："2"（なし）で情報を取得します。
プロセス定義コード、バージョンコードをキーとしてバージョン(ルート)情報を取得します。
バージョン情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
返却値
WkfVersionResultInfo バージョン情報オブジェクト
getVersionInfo

WkfVersionResultInfo getVersionInfo (String process_def_cd ,String version_cd ,String authority)

プロセス定義コード、バージョンコード、絞込み条件をキーとしてバージョン(ルート)情報を取得します。
バージョン情報オブジェクトを返却します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
authority String 絞込み条件(必須)
※絞り込み条件
返却値
WkfVersionResultInfo バージョン情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
importProcessDef

WkfImportProcessDefResultInfo importProcessDef (String xls_file)

プロセス定義(Excel形式)インポートを実行します。
処理ステータスオブジェクトを返却します。
入力値の「xls_file」はVirtualFile.load()メソッドを使用し、取得したファイルデータを渡してください。
パラメータ
xls_file String ローカルPCのファイルオブジェクト(必須)
返却値
WkfImportProcessDefResultInfo 処理ステータスオブジェクト
noTransaction

void noTransaction ()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void
registProcessDef

Object registProcessDef (String category_cd ,String process_def_name ,String process_def_notes ,String version_notes ,String process_class_code ,Boolean sub_process_flag ,Boolean attachment_flag ,String effective_date ,String end_date ,Object process_contents_path ,Array root_info)

推奨されていません。
新規プロセス定義の登録を行います。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
本APIで登録可能なルート情報は、処理タスクのみです。
分岐・同期・サブプロセス等のタスクには対応しておりません。
パラメータ
category_cd | String | カテゴリコード(必須)
process_def_name | String | プロセス定義名(必須)
process_def_notes | String | プロセス定義備考(任意)
version_notes | String | バージョン備考(任意)
process_class_code | String | プロセス種別コード(必須)
sub_process_flag | Boolean | サブプロセスフラグ(必須)
attachment_flag | Boolean | 添付ファイル使用フラグ(必須)
effective_date | String | 開始日付(必須)
end_date | String | 終了日付(任意：指定なしの場合「9999/12/31」)
process_contents_path | Object | プロセスコンテンツパスオブジェクト(必須)
root_info Array ルート情報(必須：タスク情報オブジェクト配列を指定)
 Object //プロセスコンテンツパスオブジェクト
 ├apply_path(Object)    通常コンテンツパス(必須：コンテンツパス詳細オブジェクトを指定)
 ├pull_path(Object)     引き戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)
 ├return_path(Object)   差し戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)
 ├detail_path(Object)   詳細コンテンツパス(必須：コンテンツパス詳細オブジェクトを指定)
 └refer_path(Object)    参照コンテンツパス(任意：指定なしの場合、詳細コンテンツパスと同様)

 Object //コンテンツパス詳細オブジェクト
 ├page_kind(String)      ページ種別(必須)
 ├contents_path(String)  コンテンツパス(任意：「PresentationPage」、「Servlet or JSP」の場合に指定)
 ├application_id(String) アプリケーションID(任意：「J2EE FrameWork」の場合に指定)
 └service_id(String)     サービスID(任意：「J2EE FrameWork」の場合に指定)

 Object //処理タスク情報オブジェクト
 ├activity_name(String)     タスク名(必須)
 ├activity_type(String)     タスク種別(必須：処理タスクの場合は1を指定してください。)
 ├post_processing_flag(Boolean)    後処理使用フラグ(必須)
 ├post_processing_program(String)  後処理クラス名(後処理使用フラグがtrueの場合、必須)
 ├contents_frame_type(String)      コンテンツフレーム種別(任意：指定なしの場合、標準)
 ├run_user(Array)                  対象者情報(必須：対象者情報オブジェクト配列を指定)
 ├refer_user(Array)                参照者情報(任意：使用する場合、対象者情報オブジェクト配列を指定)
 ├contents_path(String)            コンテンツパス(任意：指定なしの場合、プロセスコンテンツパスと同様)
 ├auto_pass(String)                期日による自動パス設定日数(任意)
 ├auto_pass_executive(Object)      対象者自動パス設定情報(任意：使用する場合、対象者自動パス設定オブジェクトを指定)
 ├return_flag(Boolean)             差し戻し/引き戻しフラグ(必須)
 ├return_mail_flag(Boolean)        差し戻しメールフラグ(必須)
 ├compulsion_end_flag(Boolean)     途中終了フラグ(必須)
 ├mail_send_flag(Boolean)          催促メール使用フラグ(必須)
 ├mail_postponement(String)        催促猶予日数(催促メール使用フラグがtrueの場合、必須)
 └shortest_end_flag(Boolean)       必須選択最終タスクフラグ(必須：ルート作成タスクのみ使用)

 Object //対象者情報オブジェクト
 ├type(String)           対象者種別(必須)
 ├group_cd(String)       対象者グループコード(任意：対象者種別が組織の場合に指定)
 ├code(String)           対象者コード(必須)
 ├role_restrict(String)  ロール絞り込みID(任意：指定なしの場合、絞り込みなし)
 └post_restrict(Object)  役職絞り込みコード(任意：指定なしの場合、絞り込みなし)

 Object //コンテンツパスオブジェクト
 ├apply_path(Object)    通常コンテンツパス(必須：コンテンツパス詳細オブジェクトを指定)
 ├pull_path(Object)     引き戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)
 └return_path(Object)   差し戻しコンテンツパス(任意：指定なしの場合、通常コンテンツパスと同様)

 Object //対象者自動パス設定オブジェクト
 ├auto_pass_flag(Boolean)    自動パスフラグ(必須)
 └auto_pass_target(Array)    自動パス対象者情報配列(自動パスフラグがtrueの場合、必須：対象者情報オブジェクト配列を指定)
返却値
Object 処理結果オブジェクト
 Object //処理結果オブジェクト
 ├isSuccess(Boolean)      処理結果(true:成功/false:失敗)
 <登録成功時>
 ├process_def_cd(String)  プロセス定義コード
 ├version_cd(String)      バージョンコード
 <登録失敗時>
 ├getId(String)           エクセプションID
 └getMessage(String)      エラーメッセージ
removeProcess

WkfResultInfo removeProcess (String process_def_cd ,String version_cd ,String process_cd ,Boolean xml_out_flg)

案件の削除処理を実行します。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
xml_out_flg | Boolean | XML出力フラグ(必須)
返却値
WkfResultInfo 処理結果オブジェクト


 WkfNegoMailInfo オブジェクト

根回しメールオブジェクト。
根回しメールオブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfNegoMailInfo(Object) 根回しメールオブジェクト
 ├title(String)       根回しメールタイトル(必須)
 ├comment(String)     根回しメールコメント(任意)
 └userList(Array)     根回しメール送信者リスト(必須)
    └cd(String)           送信先ユーザコード

プロパティの概要
String | comment 根回しメールコメント (任意)。 | 通常
String | title 根回しメールタイトル(必須)。 | 通常
Array | userList 根回しメール送信者リスト(必須)。 | 通常
String | userList[0..*].cd 送信先ユーザコード。 | 通常
プロパティの詳細
comment

String comment

根回しメールコメント (任意)。
title

String title

根回しメールタイトル(必須)。
userList

Array userList

根回しメール送信者リスト(必須)。
userList[0..*].cd

String userList[0..*].cd

送信先ユーザコード。


 WkfProcess オブジェクト

案件関連のAPI。
案件関連の情報取得などに使用されるクラスです。

<サンプル>
コンストラクタの概要
WkfProcess (String process_def_cd ,String version_cd ,String process_cd ,String login_group_id)
コンストラクタ
メソッドの概要
Array | getApplicationKeys () 指定したプロセスのアプリケーションキーを取得します。
Array | getFileList () 添付ファイル一覧を取得します。
Array | getFlow () プロセス上の現在位置を取得します。
WkfProcessHistoryResultInfo | getProcessHistory () 案件の処理履歴取得します。
WkfProcessResultInfo | getProcessInfo () プロセス情報を取得します。
WkfTaskResultInfo | getTaskResultInfo (String activity_cd) タスク処理結果情報を取得します。
Boolean | hasNext () 次のタスクが存在するかを判断します。
WkfProcessHistoryResultInfo | next () 自分自身のオブジェクトを、次のタスクに遷移させます。
コンストラクタの詳細
WkfProcess

WkfProcess (String process_def_cd ,String version_cd ,String process_cd ,String login_group_id)
コンストラクタ
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
getApplicationKeys

Array getApplicationKeys ()

指定したプロセスのアプリケーションキーを取得します。
指定されたプロセスにアプリケーションキーが設定されておらず、
親プロセスがある場合は、親プロセスのアプリケーションキーを返却します。
返却値
Array アプリケーションキー情報オブジェクト配列
戻り値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getFileList

Array getFileList ()

添付ファイル一覧を取得します。
添付ファイルオブジェクトを返却します。
返却値
Array 添付ファイルオブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getFlow

Array getFlow ()

プロセス上の現在位置を取得します。
プロセス上の現在承認待ちになっているタスクの情報を取得します。
返却値
Array プロセス上の現在位置情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessHistory

WkfProcessHistoryResultInfo getProcessHistory ()

案件の処理履歴取得します。
案件の処理履歴情報オブジェクトを返却します。

次の処理履歴があるか確認するには「hasNext()」メソッドを使用してください。
(詳しくは「hasNext()」を参照してください。)
次の処理履歴を取得するには「next()」メソッドを使用してください。
(詳しくは「next()」を参照してください。)
返却値
WkfProcessHistoryResultInfo 案件の処理履歴オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getProcessInfo

WkfProcessResultInfo getProcessInfo ()

プロセス情報を取得します。
プロセス情報オブジェクトを返却します。
返却値
WkfProcessResultInfo プロセス情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTaskResultInfo

WkfTaskResultInfo getTaskResultInfo (String activity_cd)

タスク処理結果情報を取得します。
タスク処理結果情報オブジェクトを返却します。
パラメータ
activity_cd String アクティビティコード(必須)
返却値
WkfTaskResultInfo タスク処理結果情報オブジェクト

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
hasNext

Boolean hasNext ()

次のタスクが存在するかを判断します。
「getProcessHistory()」メソッドで取得した処理結果の次の処理結果があるかどうかを返却します。
このメソッドは必ず「getProcessHistory()」メソッドを実行した後に使用してください。
返却値
Boolean 存在する:true/存在しない:false
next

WkfProcessHistoryResultInfo next ()

自分自身のオブジェクトを、次のタスクに遷移させます。
「getProcessHistory()」メソッドで取得した処理結果の次の処理結果を返却します。
このメソッドは必ず「getProcessHistory()」メソッドを実行した後に使用してください。
返却値
WkfProcessHistoryResultInfo 案件の処理履歴オブジェクト


 WkfProcessDefInfoByVersionResultInfo オブジェクト

プロセス定義情報オブジェクト(バージョン指定)。
プロセス定義情報オブジェクト(バージョン指定)は下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
Int | activity_process_count アクティブなプロセス数。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | note 備考。 | 読込み専用
Int | process_count プロセス数。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
プロパティの詳細
activity_process_count

Int activity_process_count (読込み専用プロパティ)

アクティブなプロセス数。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
note

String note (読込み専用プロパティ)

備考。
process_count

Int process_count (読込み専用プロパティ)

プロセス数。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。


 WkfProcessDefResultInfo オブジェクト

プロセス定義情報オブジェクト。
プロセス定義情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
Int | activity_process_count アクティブなプロセス数。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | new_version_cd 最新バージョンコード。 | 読込み専用
String | note 備考。 | 読込み専用
Int | process_count プロセス数。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
プロパティの詳細
activity_process_count

Int activity_process_count (読込み専用プロパティ)

アクティブなプロセス数。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
new_version_cd

String new_version_cd (読込み専用プロパティ)

最新バージョンコード。
note

String note (読込み専用プロパティ)

備考。
process_count

Int process_count (読込み専用プロパティ)

プロセス数。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。


 WkfProcessHistoryResultInfo オブジェクト

処理履歴情報オブジェクト。
処理履歴情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | activity_cd アクティビティコード。 | 読込み専用
String | activity_name アクティビティ名。 | 読込み専用
String | activity_status アクティビティステータス。 | 読込み専用
String | activity_type アクティビティ種別(常に"処理タスク"(RECEIVE)となります。 | 読込み専用
String | agent_tran_flg 代理_振替えフラグ。 | 読込み専用
String | agent_tran_user_cd 代理_振替元ユーザコード。 | 読込み専用
String | agent_tran_user_name 代理_振替元ユーザ名。 | 読込み専用
String | approval_date 承認日。 | 読込み専用
String | approval_type 承認種別。 | 読込み専用
String | approval_user_cd 承認者コード。 | 読込み専用
String | approval_user_name 承認者名。 | 読込み専用
String | call_process_cd 親プロセスコード。 | 読込み専用
String | commnet 承認時のコメント。 | 読込み専用
String | comp_cd 処理者の処理時の会社コード。 | 読込み専用
Boolean | main_flg 主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）。 | 読込み専用
String | orgn_cd 処理者の処理時の組織コード。 | 読込み専用
String | orgn_name 処理者の処理時の組織名。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | status_ended_date ステータス完了日付。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード。
activity_name

String activity_name (読込み専用プロパティ)

アクティビティ名。
activity_status

String activity_status (読込み専用プロパティ)

アクティビティステータス。
activity_type

String activity_type (読込み専用プロパティ)

アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)。
agent_tran_flg

String agent_tran_flg (読込み専用プロパティ)

代理_振替えフラグ。
agent_tran_user_cd

String agent_tran_user_cd (読込み専用プロパティ)

代理_振替元ユーザコード。
agent_tran_user_name

String agent_tran_user_name (読込み専用プロパティ)

代理_振替元ユーザ名。
approval_date

String approval_date (読込み専用プロパティ)

承認日。
approval_type

String approval_type (読込み専用プロパティ)

承認種別。
approval_user_cd

String approval_user_cd (読込み専用プロパティ)

承認者コード。
approval_user_name

String approval_user_name (読込み専用プロパティ)

承認者名。
call_process_cd

String call_process_cd (読込み専用プロパティ)

親プロセスコード。
commnet

String commnet (読込み専用プロパティ)

承認時のコメント。
comp_cd

String comp_cd (読込み専用プロパティ)

処理者の処理時の会社コード。
main_flg

Boolean main_flg (読込み専用プロパティ)

主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）。
orgn_cd

String orgn_cd (読込み専用プロパティ)

処理者の処理時の組織コード。
orgn_name

String orgn_name (読込み専用プロパティ)

処理者の処理時の組織名。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
status_ended_date

String status_ended_date (読込み専用プロパティ)

ステータス完了日付。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。


 WkfProcessListResultInfo オブジェクト

プロセス情報オブジェクト。
プロセス情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | activity_cd アクティビティコード。 | 読込み専用
String | activity_name アクティビティ名。 | 読込み専用
String | activity_status アクティビティステータス。 | 読込み専用
String | attainment_class 到達種別。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
String | draft_appoint_date 起票指定日。 | 読込み専用
String | draft_date 起票日。 | 読込み専用
String | draft_user_cd 起票者コード。 | 読込み専用
String | draft_user_name 起票者名。 | 読込み専用
String | now_approval_name 現処理ユーザ/組織名。 | 読込み専用
String | parent_process_cd 親プロセスコード。 | 読込み専用
String | parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | parent_version_cd 親プロセスバージョンコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_cls_cd プロセス種別コード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | process_end_status プロセス終了ステータス。 | 読込み専用
String | process_name プロセス名。 | 読込み専用
String | process_status プロセスステータス。 | 読込み専用
String | process_term_date 処理期限日付。 | 読込み専用
String | reception_date 受信日付。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード。
activity_name

String activity_name (読込み専用プロパティ)

アクティビティ名。
activity_status

String activity_status (読込み専用プロパティ)

アクティビティステータス。
attainment_class

String attainment_class (読込み専用プロパティ)

到達種別。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
draft_appoint_date

String draft_appoint_date (読込み専用プロパティ)

起票指定日。
draft_date

String draft_date (読込み専用プロパティ)

起票日。
draft_user_cd

String draft_user_cd (読込み専用プロパティ)

起票者コード。
draft_user_name

String draft_user_name (読込み専用プロパティ)

起票者名。
now_approval_name

String now_approval_name (読込み専用プロパティ)

現処理ユーザ/組織名。
parent_process_cd

String parent_process_cd (読込み専用プロパティ)

親プロセスコード。
parent_process_def_cd

String parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
parent_version_cd

String parent_version_cd (読込み専用プロパティ)

親プロセスバージョンコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_cls_cd

String process_cls_cd (読込み専用プロパティ)

プロセス種別コード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
process_end_status

String process_end_status (読込み専用プロパティ)

プロセス終了ステータス。
process_name

String process_name (読込み専用プロパティ)

プロセス名。
process_status

String process_status (読込み専用プロパティ)

プロセスステータス。
process_term_date

String process_term_date (読込み専用プロパティ)

処理期限日付。
reception_date

String reception_date (読込み専用プロパティ)

受信日付。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


 WkfProcessResultInfo オブジェクト

プロセス情報オブジェクト。
プロセス情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
Array | app_key アプリケーションキー配列(String配列)。 | 読込み専用
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
String | draft_appoint_date 起票指定日。 | 読込み専用
String | draft_comment 起票時コメント。 | 読込み専用
String | draft_date 起票日。 | 読込み専用
String | draft_user_cd 起票者コード。 | 読込み専用
String | draft_user_name 起票者名。 | 読込み専用
String | last_man_activity 最終手動アクティビティコード。 | 読込み専用
String | last_man_activity_result 最終手動アクティビティ承認結果種別。 | 読込み専用
String | parent_activity_cd 親アクティビティコード。 | 読込み専用
String | parent_process_cd 親プロセスコード。 | 読込み専用
String | parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | parent_version_cd 親プロセスバージョンコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | process_end_status プロセス終了ステータス。 | 読込み専用
String | process_name プロセス名。 | 読込み専用
String | process_status プロセスステータス。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
app_key

Array app_key (読込み専用プロパティ)

アプリケーションキー配列(String配列)。
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
draft_appoint_date

String draft_appoint_date (読込み専用プロパティ)

起票指定日。
draft_comment

String draft_comment (読込み専用プロパティ)

起票時コメント。
draft_date

String draft_date (読込み専用プロパティ)

起票日。
draft_user_cd

String draft_user_cd (読込み専用プロパティ)

起票者コード。
draft_user_name

String draft_user_name (読込み専用プロパティ)

起票者名。
last_man_activity

String last_man_activity (読込み専用プロパティ)

最終手動アクティビティコード。
last_man_activity_result

String last_man_activity_result (読込み専用プロパティ)

最終手動アクティビティ承認結果種別。
parent_activity_cd

String parent_activity_cd (読込み専用プロパティ)

親アクティビティコード。
parent_process_cd

String parent_process_cd (読込み専用プロパティ)

親プロセスコード。
parent_process_def_cd

String parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
parent_version_cd

String parent_version_cd (読込み専用プロパティ)

親プロセスバージョンコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
process_end_status

String process_end_status (読込み専用プロパティ)

プロセス終了ステータス。
process_name

String process_name (読込み専用プロパティ)

プロセス名。
process_status

String process_status (読込み専用プロパティ)

プロセスステータス。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


 WkfReference オブジェクト

参照関連のAPI。
参照案件の取得などに使用されるクラスです。

<サンプル>
コンストラクタの概要
WkfReference (String user_cd ,String login_group_id)
コンストラクタ
メソッドの概要
Array getReferTaskList (WkfSearchCondition conditionKey ,Array sort_key ,Number start ,Number amount)
参照可能案件一覧を取得します。
コンストラクタの詳細
WkfReference

WkfReference (String user_cd ,String login_group_id)
コンストラクタ
パラメータ
user_cd | String | 参照者のユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
getReferTaskList

Array getReferTaskList (WkfSearchCondition conditionKey ,Array sort_key ,Number start ,Number amount)

参照可能案件一覧を取得します。
参照可能案件情報オブジェクトを返却します。
検索条件には、いずれかのフィルターを必ずtrueに設定してください。
ソート指定可能な項目は、戻り値に含まれる項目のみ対象となります。
パラメータ
conditionKey | WkfSearchCondition | 検索条件オブジェクト(必須。必ずフィルターをセットしてください)
sort_key | Array | ソート指定オブジェクト配列(任意。指定しない場合はnullを指定)
start | Number | フェッチ開始位置(任意。指定しない場合は0を指定)
amount | Number | フェッチ件数(任意。指定しない場合は0を指定)
返却値
Array 参照可能案件情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。


 WkfReferTaskResultInfo オブジェクト

参照可能案件情報オブジェクト。
参照可能案件情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | category_cd カテゴリコード。 | 読込み専用
String | category_name カテゴリ名。 | 読込み専用
String | draft_appoint_date 起票指定日。 | 読込み専用
String | draft_date 起票日。 | 読込み専用
String | draft_user_cd 起票者コード。 | 読込み専用
String | draft_user_name 起票者名。 | 読込み専用
String | parent_process_cd 親プロセスコード。 | 読込み専用
String | parent_process_def_cd 親プロセス定義コード。 | 読込み専用
String | parent_version_cd 親プロセスバージョンコード。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_cls プロセス種別コード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_def_name プロセス定義名。 | 読込み専用
String | process_end_status プロセス終了ステータス。 | 読込み専用
String | process_name プロセス名。 | 読込み専用
String | process_status プロセスステータス。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
category_cd

String category_cd (読込み専用プロパティ)

カテゴリコード。
category_name

String category_name (読込み専用プロパティ)

カテゴリ名。
draft_appoint_date

String draft_appoint_date (読込み専用プロパティ)

起票指定日。
draft_date

String draft_date (読込み専用プロパティ)

起票日。
draft_user_cd

String draft_user_cd (読込み専用プロパティ)

起票者コード。
draft_user_name

String draft_user_name (読込み専用プロパティ)

起票者名。
parent_process_cd

String parent_process_cd (読込み専用プロパティ)

親プロセスコード。
parent_process_def_cd

String parent_process_def_cd (読込み専用プロパティ)

親プロセス定義コード。
parent_version_cd

String parent_version_cd (読込み専用プロパティ)

親プロセスバージョンコード。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_cls

String process_cls (読込み専用プロパティ)

プロセス種別コード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_def_name

String process_def_name (読込み専用プロパティ)

プロセス定義名。
process_end_status

String process_end_status (読込み専用プロパティ)

プロセス終了ステータス。
process_name

String process_name (読込み専用プロパティ)

プロセス名。
process_status

String process_status (読込み専用プロパティ)

プロセスステータス。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


 WkfResultInfo オブジェクト

処理結果オブジェクト。
処理結果オブジェクトは下記のプロパティを持つObject型のオブジェクトです。

プロパティの概要
String | getId エクセプションID。 | 読込み専用
String | getMessage エラーメッセージ。 | 読込み専用
Boolean | isSuccess 処理結果(true:成功/false:失敗)。 | 読込み専用
プロパティの詳細
getId

String getId (読込み専用プロパティ)

エクセプションID。
getMessage

String getMessage (読込み専用プロパティ)

エラーメッセージ。
isSuccess

Boolean isSuccess (読込み専用プロパティ)

処理結果(true:成功/false:失敗)。


 WkfSearchCondition オブジェクト

プログラムサポート/検索条件設定オブジェクト。
指定できる検索条件は各検索メソッドの戻り値に指定されている項目のみとなります。

検索キーに起票指定日キーを指定する場合は、日付フォーマット（yyyy/MM/dd）にて指定するようにしてください。
起票指定日を除く日付関連のキーを指定する場合には、intra-mart日付フォーマット（yyyy/MM/dd|HH:mm:ss）にて、
指定するようにしてください。
各検索項目キーは以下のフィールドを参照してください。

※フィルターについて
コンストラクタの概要
WkfSearchCondition ()
コンストラクタ
メソッドの概要
void setCondition (WkfConditionInfo condition)
検索条件を設定します。
コンストラクタの詳細
WkfSearchCondition

WkfSearchCondition ()
コンストラクタ
メソッドの詳細
setCondition

void setCondition (WkfConditionInfo condition)

検索条件を設定します。
パラメータ
condition WkfConditionInfo 検索条件オブジェクト
返却値
void


 WkfSort オブジェクト

プログラムサポート/ソート指定オブジェクト。
ソート対象は各検索メソッドの戻り値がソート対象となります。
コンストラクタの概要
WkfSort ()
コンストラクタ
メソッドの概要
void | setAscending (String sort_key) 昇順ソートキーを設定します。
void | setDescending (String sort_key) 降順ソートキーを設定します。
コンストラクタの詳細
WkfSort

WkfSort ()
コンストラクタ
メソッドの詳細
setAscending

void setAscending (String sort_key)

昇順ソートキーを設定します。 ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを昇順ソートキーとする場合、setAscending(”category_cd”)と記述してください。
パラメータ
sort_key String 昇順ソートキー
返却値
void
setDescending

void setDescending (String sort_key)

降順ソートキーを設定します。 ソート対象は各検索メソッドの戻り値がソート対象となります。
例えば、category_cdを降順ソートキーとする場合、setDescending(”category_cd”)と記述してください。
パラメータ
sort_key String 降順ソートキー
返却値
void


 WkfTargetReferResultInfo オブジェクト

参照者情報オブジェクト。
参照者情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | post_restrict 絞込み役職コード。 | 読込み専用
String | refer_cd 参照者コード。 | 読込み専用
String | refer_group_cd 参照者グループコード。 | 読込み専用
String | refer_type 参照者種別。 | 読込み専用
String | role_restrict 絞込みロールID。 | 読込み専用
プロパティの詳細
post_restrict

String post_restrict (読込み専用プロパティ)

絞込み役職コード。
refer_cd

String refer_cd (読込み専用プロパティ)

参照者コード。
refer_group_cd

String refer_group_cd (読込み専用プロパティ)

参照者グループコード。
refer_type

String refer_type (読込み専用プロパティ)

参照者種別。
role_restrict

String role_restrict (読込み専用プロパティ)

絞込みロールID。


 WkfTargetRunInfo オブジェクト

対象者オブジェクト。
対象者オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | code 対象者コード(必須)。 | 通常
String | group_cd 対象者グループコード(任意)。 | 通常
String | post_restrict 絞り込み役職コード(任意)。 | 通常
String | role_restrict 絞り込みロールID(任意)。 | 通常
String | type 対象者種別(必須)。 | 通常
プロパティの詳細
code

String code

対象者コード(必須)。
group_cd

String group_cd

対象者グループコード(任意)。

対象者種別が組織の場合は会社コードを設定します。
対象者種別がパブリックグループの場合はパブリックグループセットのグループセットコードを設定します。
post_restrict

String post_restrict

絞り込み役職コード(任意)。
role_restrict

String role_restrict

絞り込みロールID(任意)。
type

String type

対象者種別(必須)。


 WkfTargetRunResultInfo オブジェクト

対象者情報オブジェクト。
対象者情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | post_restrict 絞込み役職コード。 | 読込み専用
String | role_restrict 絞込みロールID。 | 読込み専用
String | run_cd 対象者コード。 | 読込み専用
String | run_group_cd 対象者グループコード。 | 読込み専用
String | run_type 対象者種別。 | 読込み専用
プロパティの詳細
post_restrict

String post_restrict (読込み専用プロパティ)

絞込み役職コード。
role_restrict

String role_restrict (読込み専用プロパティ)

絞込みロールID。
run_cd

String run_cd (読込み専用プロパティ)

対象者コード。
run_group_cd

String run_group_cd (読込み専用プロパティ)

対象者グループコード。
run_type

String run_type (読込み専用プロパティ)

対象者種別。


 WkfTaskInfo オブジェクト

タスク情報関連のAPI。
タスク情報関連処理で使用されるクラスです。
定数の概要
static String | TARGET_TYPE_OFFICIAL 対象者種別：オフィシャルグループ
static String | TARGET_TYPE_ORGN 対象者種別：組織
static String | TARGET_TYPE_ROLE 対象者種別：ロール
static String | TARGET_TYPE_USER 対象者種別：ユーザ
コンストラクタの概要
WkfTaskInfo (String user_cd ,String login_group_id)
コンストラクタ。
メソッドの概要
WkfResultInfo | changeRunUser (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,WkfTargetRunInfo target_info) 指定された案件内の指定タスクの処理者を変更します。
Array | getTargetReferInfo (String process_def_cd ,String version_cd ,String activity_cd) 指定されたタスクに設定された参照者情報を取得します。
Array | getTargetRunInfo (String process_def_cd ,String version_cd ,String activity_cd) 指定されたタスクに設定された対象者情報を取得します。
void | noTransaction () データベーストランザクションを未使用にする。
定数の詳細
TARGET_TYPE_OFFICIAL

static String TARGET_TYPE_OFFICIAL

対象者種別：オフィシャルグループ
定数値 ： "official"
TARGET_TYPE_ORGN

static String TARGET_TYPE_ORGN

対象者種別：組織
定数値 ： "orgn"
TARGET_TYPE_ROLE

static String TARGET_TYPE_ROLE

対象者種別：ロール
定数値 ： "role"
TARGET_TYPE_USER

static String TARGET_TYPE_USER

対象者種別：ユーザ
定数値 ： "user"
コンストラクタの詳細
WkfTaskInfo

WkfTaskInfo (String user_cd ,String login_group_id)
コンストラクタ。
パラメータ
user_cd | String | ユーザID(必須)
login_group_id | String | ログイングループID(必須)
メソッドの詳細
changeRunUser

WkfResultInfo changeRunUser (String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,WkfTargetRunInfo target_info)

指定された案件内の指定タスクの処理者を変更します。
処理対象者には、ユーザ・組織・オフィシャルグループ・ロールが指定できます。
既に処理が終了しているタスクの処理者を変更することは出来ません。
返却値は、処理結果を返却します。
データベーストランザクションは標準で使用することになっていますので、
使用しない場合は先に「noTransaction()」メソッドを使用してください。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
target_info | WkfTargetRunInfo | 対象者オブジェクト(必須)
返却値
WkfResultInfo 処理結果オブジェクト
getTargetReferInfo

Array getTargetReferInfo (String process_def_cd ,String version_cd ,String activity_cd)

指定されたタスクに設定された参照者情報を取得します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(必須)
返却値
Array 参照者情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
getTargetRunInfo

Array getTargetRunInfo (String process_def_cd ,String version_cd ,String activity_cd)

指定されたタスクに設定された対象者情報を取得します。
パラメータ
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
activity_cd | String | アクティビティコード(必須)
返却値
Array 対象者情報オブジェクト配列

返却値は、エラーの場合：null、取得件数0件の場合：空オブジェクトを返却します。
noTransaction

void noTransaction ()

データベーストランザクションを未使用にする。
このメソッド使用すると、各メソッド内でトランザクション制御は行いません。
外部（ユーザプログラム）側のトランザクション制御に依存されます。
また使用しなければ、各メソッド内でトランザクション制御を自動的に行います。
返却値
void


 WkfTaskResultInfo オブジェクト

タスク処理結果情報オブジェクト。
タスク処理結果情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
プロパティの概要
String | activity_cd アクティビティコード。 | 読込み専用
String | activity_name アクティビティ名。 | 読込み専用
String | activity_status アクティビティステータス。 | 読込み専用
String | activity_status_comp_date ステータス完了日付。 | 読込み専用
String | activity_type アクティビティ種別(常に"処理タスク"(RECEIVE)となります。 | 読込み専用
String | agent_cd 代理依頼先ユーザ/組織コード。 | 読込み専用
String | agent_name 代理依頼先ユーザ/組織名。 | 読込み専用
String | agent_target 代理依頼先対象(ユーザ/会社組織)。 | 読込み専用
String | approval_comment 処理時コメント。 | 読込み専用
String | approval_date 処理日。 | 読込み専用
String | approval_type 処理結果。 | 読込み専用
String | approval_user_cd 処理ユーザコード。 | 読込み専用
String | approval_user_name 処理ユーザ名。 | 読込み専用
String | attainment_class 到達種別。 | 読込み専用
String | auto_pass_flag 自動パス（バッチ）処理フラグ。 | 読込み専用
String | auto_pass_term 自動パス（バッチ）期限。 | 読込み専用
String | client_user_cd 代理依頼元ユーザコード。 | 読込み専用
String | client_user_name 代理依頼元ユーザ名。 | 読込み専用
String | comp_cd 処理者の処理時の会社コード。 | 読込み専用
String | delegate_flag 振り替えフラグ。 | 読込み専用
Boolean | main_flg 主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）。 | 読込み専用
String | orgn_cd 処理者の処理時の組織コード。 | 読込み専用
String | present_process 現処理表示文字。 | 読込み専用
String | process_cd プロセスコード。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
String | process_term_date 処理期限日付。 | 読込み専用
String | reception_date 受信日付。 | 読込み専用
String | transfer_flg 代理依頼フラグ。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
プロパティの詳細
activity_cd

String activity_cd (読込み専用プロパティ)

アクティビティコード。
activity_name

String activity_name (読込み専用プロパティ)

アクティビティ名。
activity_status

String activity_status (読込み専用プロパティ)

アクティビティステータス。
activity_status_comp_date

String activity_status_comp_date (読込み専用プロパティ)

ステータス完了日付。
activity_type

String activity_type (読込み専用プロパティ)

アクティビティ種別(常に"処理タスク"(RECEIVE)となります。)。
agent_cd

String agent_cd (読込み専用プロパティ)

代理依頼先ユーザ/組織コード。
agent_name

String agent_name (読込み専用プロパティ)

代理依頼先ユーザ/組織名。
agent_target

String agent_target (読込み専用プロパティ)

代理依頼先対象(ユーザ/会社組織)。
approval_comment

String approval_comment (読込み専用プロパティ)

処理時コメント。
approval_date

String approval_date (読込み専用プロパティ)

処理日。
approval_type

String approval_type (読込み専用プロパティ)

処理結果。
approval_user_cd

String approval_user_cd (読込み専用プロパティ)

処理ユーザコード。
approval_user_name

String approval_user_name (読込み専用プロパティ)

処理ユーザ名。
attainment_class

String attainment_class (読込み専用プロパティ)

到達種別。
auto_pass_flag

String auto_pass_flag (読込み専用プロパティ)

自動パス（バッチ）処理フラグ。
auto_pass_term

String auto_pass_term (読込み専用プロパティ)

自動パス（バッチ）期限。
client_user_cd

String client_user_cd (読込み専用プロパティ)

代理依頼元ユーザコード。
client_user_name

String client_user_name (読込み専用プロパティ)

代理依頼元ユーザ名。
comp_cd

String comp_cd (読込み専用プロパティ)

処理者の処理時の会社コード。
delegate_flag

String delegate_flag (読込み専用プロパティ)

振り替えフラグ。
main_flg

Boolean main_flg (読込み専用プロパティ)

主・副所属フラグ（処理時の組織が主所属の場合、trueを返す）。
orgn_cd

String orgn_cd (読込み専用プロパティ)

処理者の処理時の組織コード。
present_process

String present_process (読込み専用プロパティ)

現処理表示文字。
process_cd

String process_cd (読込み専用プロパティ)

プロセスコード。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
process_term_date

String process_term_date (読込み専用プロパティ)

処理期限日付。
reception_date

String reception_date (読込み専用プロパティ)

受信日付。
transfer_flg

String transfer_flg (読込み専用プロパティ)

代理依頼フラグ。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。


 WkfTransferActivityResultInfo オブジェクト

代理設定情報オブジェクト。
代理設定情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfTransferActivityResultInfo(Object) 代理設定情報オブジェクト
 ├isSuccess(Boolean)          処理結果(true:成功/false:失敗)
 ├getId(String)               エクセプションID
 ├getMessage(String)          エラーメッセージ
 └data(Array)                 タスク委譲情報配列
    ├process_def_cd(String)       プロセス定義コード
    ├version_cd(String)           バージョンコード
    ├activity_cd(String)          アクティビティコード
    ├activity_name(String)        タスク名
    ├transfer_cd_type(String)     代理依頼先種別
    ├transfer_group_cd(String)    代理依頼先グループコード
    ├transfer_cd(String)          代理依頼先コード
    ├transfer_name(String)        代理依頼先名
    ├narrow_post_cd(String)       絞り込み役職コード
    ├narrow_post_name(String)     絞り込み役職名
    ├transfer_start_date(String)  代理期間(開始日)
    ├trasnfer_end_date(String)    代理期間(終了日)
    ├trasnfer_status(String)      代理設定種別
    └dynamic_task_flag(Boolean)   動的承認者フラグ(true:動的承認者/false:静的承認者)

プロパティの概要
Array | data タスク委譲情報配列。 | 読込み専用
String | data[0..*].activity_cd アクティビティコード。 | 読込み専用
String | data[0..*].activity_name タスク名。 | 読込み専用
Boolean | data[0..*].dynamic_task_flag 動的承認者フラグ(true:動的承認者/false:静的承認者)。 | 読込み専用
String | data[0..*].narrow_post_cd 絞り込み役職コード。 | 読込み専用
String | data[0..*].narrow_post_name 絞り込み役職名。 | 読込み専用
String | data[0..*].process_def_cd プロセス定義コード。 | 読込み専用
String | data[0..*].transfer_cd 代理依頼先コード。 | 読込み専用
String | data[0..*].transfer_cd_type 代理依頼先種別。 | 読込み専用
String | data[0..*].transfer_group_cd 代理依頼先グループコード。 | 読込み専用
String | data[0..*].transfer_name 代理依頼先名。 | 読込み専用
String | data[0..*].transfer_start_date 代理期間(開始日)。 | 読込み専用
String | data[0..*].trasnfer_end_date 代理期間(終了日)。 | 読込み専用
String | data[0..*].trasnfer_status 代理設定種別。 | 読込み専用
String | data[0..*].version_cd バージョンコード。 | 読込み専用
String | getId エクセプションID。 | 読込み専用
String | getMessage エラーメッセージ。 | 読込み専用
Boolean | isSuccess 処理結果(true:成功/false:失敗)。 | 読込み専用
プロパティの詳細
data

Array data (読込み専用プロパティ)

タスク委譲情報配列。
data[0..*].activity_cd

String data[0..*].activity_cd (読込み専用プロパティ)

アクティビティコード。
data[0..*].activity_name

String data[0..*].activity_name (読込み専用プロパティ)

タスク名。
data[0..*].dynamic_task_flag

Boolean data[0..*].dynamic_task_flag (読込み専用プロパティ)

動的承認者フラグ(true:動的承認者/false:静的承認者)。
data[0..*].narrow_post_cd

String data[0..*].narrow_post_cd (読込み専用プロパティ)

絞り込み役職コード。
data[0..*].narrow_post_name

String data[0..*].narrow_post_name (読込み専用プロパティ)

絞り込み役職名。
data[0..*].process_def_cd

String data[0..*].process_def_cd (読込み専用プロパティ)

プロセス定義コード。
data[0..*].transfer_cd

String data[0..*].transfer_cd (読込み専用プロパティ)

代理依頼先コード。
data[0..*].transfer_cd_type

String data[0..*].transfer_cd_type (読込み専用プロパティ)

代理依頼先種別。
data[0..*].transfer_group_cd

String data[0..*].transfer_group_cd (読込み専用プロパティ)

代理依頼先グループコード。
data[0..*].transfer_name

String data[0..*].transfer_name (読込み専用プロパティ)

代理依頼先名。
data[0..*].transfer_start_date

String data[0..*].transfer_start_date (読込み専用プロパティ)

代理期間(開始日)。
data[0..*].trasnfer_end_date

String data[0..*].trasnfer_end_date (読込み専用プロパティ)

代理期間(終了日)。
data[0..*].trasnfer_status

String data[0..*].trasnfer_status (読込み専用プロパティ)

代理設定種別。
data[0..*].version_cd

String data[0..*].version_cd (読込み専用プロパティ)

バージョンコード。
getId

String getId (読込み専用プロパティ)

エクセプションID。
getMessage

String getMessage (読込み専用プロパティ)

エラーメッセージ。
isSuccess

Boolean isSuccess (読込み専用プロパティ)

処理結果(true:成功/false:失敗)。


 WkfTransferProcessDefResultInfo オブジェクト

プロセス定義委譲情報一覧オブジェクト。
プロセス定義委譲情報一覧オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfTransferProcessDefResultInfo(Object) プロセス定義委譲情報一覧オブジェクト
 ├isSuccess(Boolean)          処理結果(true:成功/false:失敗)
 ├getId(String)               エクセプションID
 ├getMessage(String)          エラーメッセージ
 └data(Array)                 プロセス定義委譲情報配列
    ├process_def_cd(String)           プロセス定義コード
    ├process_def_name(String)         プロセス定義名
    ├transfer_cd_type(String)         代理依頼先種別
    ├transfer_group_cd(String)        代理依頼先グループコード
    ├transfer_cd(String)              代理依頼先コード
    ├transfer_name(String)            代理依頼先名
    ├narrow_post_cd(String)           絞り込み役職コード
    ├narrow_post_name(String)         絞り込み役職名
    ├transfer_start_date(String)      代理期間(開始日)
    ├trasnfer_end_date(String)        代理期間(終了日)
    ├trasnfer_status(String)          代理設定種別
    ├transfer_version_flag(Boolean)   バージョン委譲フラグ(true:あり/false:なし)
    └transfer_activity_flag(Boolean)  タスク委譲フラグ(true:あり/false:なし)

プロパティの概要
Array | data プロセス定義委譲情報配列。 | 読込み専用
String | data[0..*].narrow_post_cd 絞り込み役職コード。 | 読込み専用
String | data[0..*].narrow_post_name 絞り込み役職名。 | 読込み専用
String | data[0..*].process_def_cd プロセス定義コード。 | 読込み専用
String | data[0..*].process_def_name プロセス定義名。 | 読込み専用
Boolean | data[0..*].transfer_activity_flag タスク委譲フラグ(true:あり/false:なし)。 | 読込み専用
String | data[0..*].transfer_cd 代理依頼先コード。 | 読込み専用
String | data[0..*].transfer_cd_type 代理依頼先種別。 | 読込み専用
String | data[0..*].transfer_group_cd 代理依頼先グループコード。 | 読込み専用
String | data[0..*].transfer_name 代理依頼先名。 | 読込み専用
String | data[0..*].transfer_start_date 代理期間(開始日)。 | 読込み専用
Boolean | data[0..*].transfer_version_flag バージョン委譲フラグ(true:あり/false:なし)。 | 読込み専用
String | data[0..*].trasnfer_end_date 代理期間(終了日)。 | 読込み専用
String | data[0..*].trasnfer_status 代理設定種別。 | 読込み専用
String | getId エクセプションID。 | 読込み専用
String | getMessage エラーメッセージ。 | 読込み専用
String | isSuccess(Boolean) 処理結果(true:成功/false:失敗)。 | 読込み専用
プロパティの詳細
data

Array data (読込み専用プロパティ)

プロセス定義委譲情報配列。
data[0..*].narrow_post_cd

String data[0..*].narrow_post_cd (読込み専用プロパティ)

絞り込み役職コード。
data[0..*].narrow_post_name

String data[0..*].narrow_post_name (読込み専用プロパティ)

絞り込み役職名。
data[0..*].process_def_cd

String data[0..*].process_def_cd (読込み専用プロパティ)

プロセス定義コード。
data[0..*].process_def_name

String data[0..*].process_def_name (読込み専用プロパティ)

プロセス定義名。
data[0..*].transfer_activity_flag

Boolean data[0..*].transfer_activity_flag (読込み専用プロパティ)

タスク委譲フラグ(true:あり/false:なし)。
data[0..*].transfer_cd

String data[0..*].transfer_cd (読込み専用プロパティ)

代理依頼先コード。
data[0..*].transfer_cd_type

String data[0..*].transfer_cd_type (読込み専用プロパティ)

代理依頼先種別。
data[0..*].transfer_group_cd

String data[0..*].transfer_group_cd (読込み専用プロパティ)

代理依頼先グループコード。
data[0..*].transfer_name

String data[0..*].transfer_name (読込み専用プロパティ)

代理依頼先名。
data[0..*].transfer_start_date

String data[0..*].transfer_start_date (読込み専用プロパティ)

代理期間(開始日)。
data[0..*].transfer_version_flag

Boolean data[0..*].transfer_version_flag (読込み専用プロパティ)

バージョン委譲フラグ(true:あり/false:なし)。
data[0..*].trasnfer_end_date

String data[0..*].trasnfer_end_date (読込み専用プロパティ)

代理期間(終了日)。
data[0..*].trasnfer_status

String data[0..*].trasnfer_status (読込み専用プロパティ)

代理設定種別。
getId

String getId (読込み専用プロパティ)

エクセプションID。
getMessage

String getMessage (読込み専用プロパティ)

エラーメッセージ。
isSuccess(Boolean)

String isSuccess(Boolean) (読込み専用プロパティ)

処理結果(true:成功/false:失敗)。


 WkfTransferResultInfo オブジェクト

代理設定情報オブジェクト。
代理設定情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfTransferResultInfo(Object) 代理設定情報オブジェクト
 ├isSuccess(Boolean)          処理結果(true:成功/false:失敗)
 ├getId(String)               エクセプションID
 ├getMessage(String)          エラーメッセージ
 └data(Array)                 代理設定情報配列
    ├process_def_cd(String)        プロセス定義コード
    ├version_cd(String)            バージョンコード
    ├activity_cd(String)           アクティビティコード
    ├transfer_cd_type(String)      代理依頼先種別
    ├transfer_group_cd(String)     代理依頼先グループコード
    ├transfer_cd(String)           代理依頼先コード
    ├transfer_name(String)         代理依頼先名
    ├narrow_post_cd(String)        絞り込み役職コード
    ├narrow_post_name(String)      絞り込み役職名
    ├transfer_start_date(String)   代理期間(開始日)
    ├trasnfer_end_date(String)     代理期間(終了日)
    ├transfer_status(String)       代理種別
    ├transfer_comment(String)      代理コメント
    ├sub_recognition_flag(Boolean) 代理元承認可否フラグ(true:承認可/false:承認不可)
    ├send_mail_flag(Boolean)       メール通知フラグ(true:通知する/false:通知しない)
    └notice_mail_flag(Boolean)     代理元メール通知フラグ(true:通知する/false:通知しない)

プロパティの概要
Array | data 代理設定情報配列。 | 読込み専用
String | data[0..*].activity_cd アクティビティコード。 | 読込み専用
String | data[0..*].narrow_post_cd 絞り込み役職コード。 | 読込み専用
String | data[0..*].narrow_post_name 絞り込み役職名。 | 読込み専用
Boolean | data[0..*].notice_mail_flag 代理元メール通知フラグ(true:通知する/false:通知しない)。 | 読込み専用
String | data[0..*].process_def_cd プロセス定義コード。 | 読込み専用
Boolean | data[0..*].send_mail_flag メール通知フラグ(true:通知する/false:通知しない)。 | 読込み専用
Boolean | data[0..*].sub_recognition_flag 代理元承認可否フラグ(true:承認可/false:承認不可)。 | 読込み専用
String | data[0..*].transfer_cd 代理依頼先コード。 | 読込み専用
String | data[0..*].transfer_cd_type 代理依頼先種別。 | 読込み専用
String | data[0..*].transfer_comment 代理コメント。 | 読込み専用
String | data[0..*].transfer_group_cd 代理依頼先グループコード。 | 読込み専用
String | data[0..*].transfer_name 代理依頼先名。 | 読込み専用
String | data[0..*].transfer_start_date 代理期間(開始日)。 | 読込み専用
String | data[0..*].transfer_status 代理種別。 | 読込み専用
String | data[0..*].trasnfer_end_date 代理期間(終了日)。 | 読込み専用
String | data[0..*].version_cd バージョンコード。 | 読込み専用
String | getId エクセプションID。 | 読込み専用
String | getMessage エラーメッセージ。 | 読込み専用
Boolean | isSuccess 処理結果(true:成功/false:失敗)。 | 読込み専用
プロパティの詳細
data

Array data (読込み専用プロパティ)

代理設定情報配列。
data[0..*].activity_cd

String data[0..*].activity_cd (読込み専用プロパティ)

アクティビティコード。
data[0..*].narrow_post_cd

String data[0..*].narrow_post_cd (読込み専用プロパティ)

絞り込み役職コード。
data[0..*].narrow_post_name

String data[0..*].narrow_post_name (読込み専用プロパティ)

絞り込み役職名。
data[0..*].notice_mail_flag

Boolean data[0..*].notice_mail_flag (読込み専用プロパティ)

代理元メール通知フラグ(true:通知する/false:通知しない)。
data[0..*].process_def_cd

String data[0..*].process_def_cd (読込み専用プロパティ)

プロセス定義コード。
data[0..*].send_mail_flag

Boolean data[0..*].send_mail_flag (読込み専用プロパティ)

メール通知フラグ(true:通知する/false:通知しない)。
data[0..*].sub_recognition_flag

Boolean data[0..*].sub_recognition_flag (読込み専用プロパティ)

代理元承認可否フラグ(true:承認可/false:承認不可)。
data[0..*].transfer_cd

String data[0..*].transfer_cd (読込み専用プロパティ)

代理依頼先コード。
data[0..*].transfer_cd_type

String data[0..*].transfer_cd_type (読込み専用プロパティ)

代理依頼先種別。
data[0..*].transfer_comment

String data[0..*].transfer_comment (読込み専用プロパティ)

代理コメント。
data[0..*].transfer_group_cd

String data[0..*].transfer_group_cd (読込み専用プロパティ)

代理依頼先グループコード。
data[0..*].transfer_name

String data[0..*].transfer_name (読込み専用プロパティ)

代理依頼先名。
data[0..*].transfer_start_date

String data[0..*].transfer_start_date (読込み専用プロパティ)

代理期間(開始日)。
data[0..*].transfer_status

String data[0..*].transfer_status (読込み専用プロパティ)

代理種別。
data[0..*].trasnfer_end_date

String data[0..*].trasnfer_end_date (読込み専用プロパティ)

代理期間(終了日)。
data[0..*].version_cd

String data[0..*].version_cd (読込み専用プロパティ)

バージョンコード。
getId

String getId (読込み専用プロパティ)

エクセプションID。
getMessage

String getMessage (読込み専用プロパティ)

エラーメッセージ。
isSuccess

Boolean isSuccess (読込み専用プロパティ)

処理結果(true:成功/false:失敗)。


 WkfTransferVersionResultInfo オブジェクト

バージョン委譲情報オブジェクト。
バージョン委譲情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 WkfTransferVersionResultInfo(Object) バージョン委譲情報オブジェクト
 ├isSuccess(Boolean)          処理結果(true:成功/false:失敗)
 ├getId(String)               エクセプションID
 ├getMessage(String)          エラーメッセージ
 └data(Array)                 バージョン委譲情報配列
    ├process_def_cd(String)           プロセス定義コード
    ├version_cd(String)               バージョンコード
    ├version_name(String)             バージョン名
    ├effctive_date(String)            バージョン有効日付
    ├end_date(String)                 バージョン終了日付
    ├transfer_cd_type(String)         代理依頼先種別
    ├transfer_group_cd(String)        代理依頼先グループコード
    ├transfer_cd(String)              代理依頼先コード
    ├transfer_name(String)            代理依頼先名
    ├narrow_post_cd(String)           絞り込み役職コード
    ├narrow_post_name(String)         絞り込み役職名
    ├transfer_start_date(String)      代理期間(開始日)
    ├trasnfer_end_date(String)        代理期間(終了日)
    ├trasnfer_status(String)          代理設定種別
    └transfer_activity_flag(Boolean)  タスク委譲フラグ(true:あり/false:なし)

プロパティの概要
Array | data バージョン委譲情報配列。 | 読込み専用
String | data[0..*].effctive_date バージョン有効日付。 | 読込み専用
String | data[0..*].end_date バージョン終了日付。 | 読込み専用
String | data[0..*].narrow_post_cd 絞り込み役職コード。 | 読込み専用
String | data[0..*].narrow_post_name 絞り込み役職名。 | 読込み専用
String | data[0..*].process_def_cd プロセス定義コード。 | 読込み専用
Boolean | data[0..*].transfer_activity_flag タスク委譲フラグ(true:あり/false:なし)。 | 読込み専用
String | data[0..*].transfer_cd 代理依頼先コード。 | 読込み専用
String | data[0..*].transfer_cd_type 代理依頼先種別。 | 読込み専用
String | data[0..*].transfer_group_cd 代理依頼先グループコード。 | 読込み専用
String | data[0..*].transfer_name 代理依頼先名。 | 読込み専用
String | data[0..*].transfer_start_date 代理期間(開始日)。 | 読込み専用
String | data[0..*].trasnfer_end_date 代理期間(終了日)。 | 読込み専用
String | data[0..*].trasnfer_status 代理設定種別。 | 読込み専用
String | data[0..*].version_cd バージョンコード。 | 読込み専用
String | data[0..*].version_name バージョン名。 | 読込み専用
String | getId エクセプションID。 | 読込み専用
String | getMessage エラーメッセージ。 | 読込み専用
Boolean | isSuccess 処理結果(true:成功/false:失敗)。 | 読込み専用
プロパティの詳細
data

Array data (読込み専用プロパティ)

バージョン委譲情報配列。
data[0..*].effctive_date

String data[0..*].effctive_date (読込み専用プロパティ)

バージョン有効日付。
data[0..*].end_date

String data[0..*].end_date (読込み専用プロパティ)

バージョン終了日付。
data[0..*].narrow_post_cd

String data[0..*].narrow_post_cd (読込み専用プロパティ)

絞り込み役職コード。
data[0..*].narrow_post_name

String data[0..*].narrow_post_name (読込み専用プロパティ)

絞り込み役職名。
data[0..*].process_def_cd

String data[0..*].process_def_cd (読込み専用プロパティ)

プロセス定義コード。
data[0..*].transfer_activity_flag

Boolean data[0..*].transfer_activity_flag (読込み専用プロパティ)

タスク委譲フラグ(true:あり/false:なし)。
data[0..*].transfer_cd

String data[0..*].transfer_cd (読込み専用プロパティ)

代理依頼先コード。
data[0..*].transfer_cd_type

String data[0..*].transfer_cd_type (読込み専用プロパティ)

代理依頼先種別。
data[0..*].transfer_group_cd

String data[0..*].transfer_group_cd (読込み専用プロパティ)

代理依頼先グループコード。
data[0..*].transfer_name

String data[0..*].transfer_name (読込み専用プロパティ)

代理依頼先名。
data[0..*].transfer_start_date

String data[0..*].transfer_start_date (読込み専用プロパティ)

代理期間(開始日)。
data[0..*].trasnfer_end_date

String data[0..*].trasnfer_end_date (読込み専用プロパティ)

代理期間(終了日)。
data[0..*].trasnfer_status

String data[0..*].trasnfer_status (読込み専用プロパティ)

代理設定種別。
data[0..*].version_cd

String data[0..*].version_cd (読込み専用プロパティ)

バージョンコード。
data[0..*].version_name

String data[0..*].version_name (読込み専用プロパティ)

バージョン名。
getId

String getId (読込み専用プロパティ)

エクセプションID。
getMessage

String getMessage (読込み専用プロパティ)

エラーメッセージ。
isSuccess

Boolean isSuccess (読込み専用プロパティ)

処理結果(true:成功/false:失敗)。


 WkfUtil オブジェクト

ユーティリティ関連のAPI。
バッチ起動などの処理に使用されるクラスです。
コンストラクタの概要
WkfUtil (String login_group_id)
コンストラクタ
メソッドの概要
WkfResultInfo | autoPass (String category_cd ,String process_def_cd ,String version_cd ,Number date) 案件の自動パス(バッチ起動)処理を実行します。
WkfResultInfo | autoPress (String category_cd ,String process_def_cd ,String version_cd ,Number date) 案件の自動催促(バッチ起動)処理を実行します。
WkfResultInfo | sendMail (String template_path ,String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Array to ,Array cc ,Array bcc) メール送信を行います。
コンストラクタの詳細
WkfUtil

WkfUtil (String login_group_id)
コンストラクタ
パラメータ
login_group_id String ログイングループID(必須)
メソッドの詳細
autoPass

WkfResultInfo autoPass (String category_cd ,String process_def_cd ,String version_cd ,Number date)

案件の自動パス(バッチ起動)処理を実行します。
自動パス承認期限を過ぎた案件を自動承認します。
返却値は、処理結果を返却します。
パラメータ
category_cd | String | カテゴリコード(任意：未指定時は全カテゴリ)
process_def_cd | String | プロセス定義コード(任意：未指定時は全プロセス定義)
version_cd | String | バージョンコード(任意：未指定時は全バージョン)
date | Number | 承認期限の延長日数(任意)
返却値
WkfResultInfo 処理結果オブジェクト
autoPress

WkfResultInfo autoPress (String category_cd ,String process_def_cd ,String version_cd ,Number date)

案件の自動催促(バッチ起動)処理を実行します。
自動催促メールを送ります。
返却値は、処理結果を返却します。
パラメータ
category_cd | String | カテゴリコード(任意：未指定時は全カテゴリ)
process_def_cd | String | プロセス定義コード(任意：未指定時は全プロセス定義)
version_cd | String | バージョンコード(任意：未指定時は全バージョン)
date | Number | 承認期限の延長日数(任意)
返却値
WkfResultInfo 処理結果オブジェクト
sendMail

WkfResultInfo sendMail (String template_path ,String process_def_cd ,String version_cd ,String process_cd ,String activity_cd ,Array to ,Array cc ,Array bcc)

メール送信を行います。
返却値は、メール送信結果を返却します。
パラメータ
template_path | String | テンプレートパス(必須)
process_def_cd | String | プロセス定義コード(必須)
version_cd | String | バージョンコード(必須)
process_cd | String | プロセスコード(必須)
activity_cd | String | アクティビティコード(必須)
to | Array | Toメールアドレス配列(String配列)
cc | Array | Ccメールアドレス配列(String配列)
bcc | Array | Bccメールアドレス配列(String配列)
返却値
WkfResultInfo メール送信結果オブジェクト


 WkfVersionResultInfo オブジェクト

バージョン情報オブジェクト。
バージョン情報オブジェクトは下記のプロパティを持つObject型のオブジェクトです。
 Object //バージョン情報オブジェクト
   ├process_def_cd(String)         プロセス定義コード
   ├version_cd(String)              バージョンコード
   ├version_name(String)            バージョン名
   ├note(String)                    備考
   ├start_date(String)              開始日付
   ├end_date(String)                終了日付
   ├root_type(String)               ルート種別
   ├sub_process_flag(String)        サブプロセス識別フラグ
   ├attachment_flag(String)         添付ファイル使用可否フラグ
   ├contents_path(Obect)            コンテンツパス
   │   ├page_kind(String)            ページ種別
   │   ├contents_path(String)        コンテンツパス
   │   ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
   │   └service_id(String)           サービスID(page_kindがframeworkの場合)
   ├pull_back_contents_path(Object) 引き戻しコンテンツパス
   │   ├page_kind(String)            ページ種別
   │   ├contents_path(String)        コンテンツパス
   │   ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
   │   └service_id(String)           サービスID(page_kindがframeworkの場合)
   ├return_contents_path(Object)      差し戻しコンテンツパス
   │   ├page_kind(String)            ページ種別
   │   ├contents_path(String)        コンテンツパス
   │   ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
   │   └service_id(String)           サービスID(page_kindがframeworkの場合)
   ├refer_contents_path(Object)     参照コンテンツパス
   │   ├page_kind(String)            ページ種別
   │   ├contents_path(String)        コンテンツパス
   │   ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
   │   └service_id(String)           サービスID(page_kindがframeworkの場合)
   └detail_contents_path(Object)    詳細コンテンツパス
        ├page_kind(String)            ページ種別
        ├contents_path(String)        コンテンツパス
        ├application_id(String)       アプリケーションID(page_kindがframeworkの場合)
        └service_id(String)           サービスID(page_kindがframeworkの場合)

プロパティの概要
String | attachment_flag 添付ファイル使用可否フラグ。 | 読込み専用
Object | contents_path コンテンツパス。 | 読込み専用
String | contents_path.application_id アプリケーションID(page_kindがframeworkの場合)。 | 読込み専用
String | contents_path.contents_path コンテンツパス。 | 読込み専用
String | contents_path.page_kind ページ種別。 | 読込み専用
String | contents_path.service_id サービスID(page_kindがframeworkの場合)。 | 読込み専用
Object | detail_contents_path 詳細コンテンツパス。 | 読込み専用
String | detail_contents_path.application_id アプリケーションID(page_kindがframeworkの場合)。 | 読込み専用
String | detail_contents_path.contents_path コンテンツパス。 | 読込み専用
String | detail_contents_path.page_kind ページ種別。 | 読込み専用
String | detail_contents_path.service_id サービスID(page_kindがframeworkの場合)。 | 読込み専用
String | end_date 終了日付。 | 読込み専用
String | note 備考。 | 読込み専用
String | process_def_cd プロセス定義コード。 | 読込み専用
Object | pull_back_contents_path 引き戻しコンテンツパス。 | 読込み専用
String | pull_back_contents_path.application_id アプリケーションID(page_kindがframeworkの場合)。 | 読込み専用
String | pull_back_contents_path.contents_path コンテンツパス。 | 読込み専用
String | pull_back_contents_path.page_kind ページ種別。 | 読込み専用
String | pull_back_contents_path.service_id サービスID(page_kindがframeworkの場合)。 | 読込み専用
Object | refer_contents_path 参照コンテンツパス。 | 読込み専用
String | refer_contents_path.application_id アプリケーションID(page_kindがframeworkの場合)。 | 読込み専用
String | refer_contents_path.contents_path コンテンツパス。 | 読込み専用
String | refer_contents_path.page_kind ページ種別。 | 読込み専用
String | refer_contents_path.service_id サービスID(page_kindがframeworkの場合)。 | 読込み専用
Object | return_contents_path 差し戻しコンテンツパス。 | 読込み専用
String | return_contents_path.application_id アプリケーションID(page_kindがframeworkの場合)。 | 読込み専用
String | return_contents_path.contents_path コンテンツパス。 | 読込み専用
String | return_contents_path.page_kind ページ種別。 | 読込み専用
String | return_contents_path.service_id サービスID(page_kindがframeworkの場合)。 | 読込み専用
String | root_type ルート種別。 | 読込み専用
String | start_date 開始日付。 | 読込み専用
String | sub_process_flag サブプロセス識別フラグ。 | 読込み専用
String | version_cd バージョンコード。 | 読込み専用
String | version_name バージョン名。 | 読込み専用
プロパティの詳細
attachment_flag

String attachment_flag (読込み専用プロパティ)

添付ファイル使用可否フラグ。
contents_path

Object contents_path (読込み専用プロパティ)

コンテンツパス。
contents_path.application_id

String contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)。
contents_path.contents_path

String contents_path.contents_path (読込み専用プロパティ)

コンテンツパス。
contents_path.page_kind

String contents_path.page_kind (読込み専用プロパティ)

ページ種別。
contents_path.service_id

String contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)。
detail_contents_path

Object detail_contents_path (読込み専用プロパティ)

詳細コンテンツパス。
detail_contents_path.application_id

String detail_contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)。
detail_contents_path.contents_path

String detail_contents_path.contents_path (読込み専用プロパティ)

コンテンツパス。
detail_contents_path.page_kind

String detail_contents_path.page_kind (読込み専用プロパティ)

ページ種別。
detail_contents_path.service_id

String detail_contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)。
end_date

String end_date (読込み専用プロパティ)

終了日付。
note

String note (読込み専用プロパティ)

備考。
process_def_cd

String process_def_cd (読込み専用プロパティ)

プロセス定義コード。
pull_back_contents_path

Object pull_back_contents_path (読込み専用プロパティ)

引き戻しコンテンツパス。
pull_back_contents_path.application_id

String pull_back_contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)。
pull_back_contents_path.contents_path

String pull_back_contents_path.contents_path (読込み専用プロパティ)

コンテンツパス。
pull_back_contents_path.page_kind

String pull_back_contents_path.page_kind (読込み専用プロパティ)

ページ種別。
pull_back_contents_path.service_id

String pull_back_contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)。
refer_contents_path

Object refer_contents_path (読込み専用プロパティ)

参照コンテンツパス。
refer_contents_path.application_id

String refer_contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)。
refer_contents_path.contents_path

String refer_contents_path.contents_path (読込み専用プロパティ)

コンテンツパス。
refer_contents_path.page_kind

String refer_contents_path.page_kind (読込み専用プロパティ)

ページ種別。
refer_contents_path.service_id

String refer_contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)。
return_contents_path

Object return_contents_path (読込み専用プロパティ)

差し戻しコンテンツパス。
return_contents_path.application_id

String return_contents_path.application_id (読込み専用プロパティ)

アプリケーションID(page_kindがframeworkの場合)。
return_contents_path.contents_path

String return_contents_path.contents_path (読込み専用プロパティ)

コンテンツパス。
return_contents_path.page_kind

String return_contents_path.page_kind (読込み専用プロパティ)

ページ種別。
return_contents_path.service_id

String return_contents_path.service_id (読込み専用プロパティ)

サービスID(page_kindがframeworkの場合)。
root_type

String root_type (読込み専用プロパティ)

ルート種別。
start_date

String start_date (読込み専用プロパティ)

開始日付。
sub_process_flag

String sub_process_flag (読込み専用プロパティ)

サブプロセス識別フラグ。
version_cd

String version_cd (読込み専用プロパティ)

バージョンコード。
version_name

String version_name (読込み専用プロパティ)

バージョン名。


intra-mart[Server side JavaScript intra-mart Documentation.[Batch]]

i ntra-mart The Power for Enterprise Web Solution
バッチ管理モジュール

プログラムの作成

Resource Service のインストール・ディレクトリ以下にファンクション・コンテナとしてプログラムファイルを作成します。

バッチ起動されるファンクション・コンテナ内には、必ず init() 関数を定義する必要があります。
(指定時間に該当のファンクション・コンテナをロードすると init() 関数が Application Runtime により自動実行されます。)

バッチ起動されるファンクション・コンテナの init() 関数には、下記のような構造を持つオブジェクト型の引数が渡されます。

引数 | オブジェクト
├ | group | ログイン・グループ名称
├ | name | バッチ設定名称
├ | year | バッチ起動設定年
├ | month | バッチ起動設定月
├ | date | バッチ起動設定日
├ | day | バッチ起動設定曜日
├ | hour | バッチ起動設定時間
├ | minute | バッチ起動設定分
├ | second | バッチ起動設定秒
├ | WWW_HOST | バッチ設定を行った時のＷｅｂサーバホスト名
├ | WWW_PORT | バッチ設定を行った時のＷｅｂサーバポート
├ | WWW_PROTOCOL | バッチ設定を行った時のＷｅｂサーバプロトコル
└ | WWW_LOCATION | バッチ設定を行った時のホームＵＲＬ

バッチ用プログラムに関しては、動作概要【 Batch Program 篇 】 を参照して下さい。

システム構成

バッチ機能を利用するためには、すべてのサービスをそれぞれインストールし、Schdule Service から Application Runtime に対して HTTP 接続できるように環境構築してください。

バッチの登録と設定

バッチプログラムの登録と起動時間の設定は、i ntra-mart 起動後の『システム設定』-『バッチ』メニュー内で行います。

バッチ設定では、バッチ登録と運用可否設定があります。登録したバッチプログラムは、『有効』設定にしておかないと実行されません。
また、バッチサーバの実行状態を『運用中』にしなければバッチプログラムはロードされません。

設定画面の操作に関しては、マニュアルをご参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Tree View]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart
カレンダー表示モジュール

機能概要

カレンダーマスメンテナンス画面で設定したデータと連携したカレンダー画面を表示します。 カレンダー画面を利用すると、会社の休日や営業日を考慮した日付の入力が行えます。

ＡＰＩ仕様

この機能は、プレゼンテーションページから利用します。

<IMART type="link"> の page 属性に以下のキーワードをリンクすることで、 カレンダー画面を呼び出すことができます。

@IM_CALENDAR_VIEW | 標準の表示形式のカレンダー
@IM_CALENDAR_VIEW_COMPACT | 動作の軽い表示形式のカレンダー

Presentation Pageのコーディング例
<HTML>
<HEAD>
</HEAD>
<BODY>
<IMART type="link" page="@IM_CALENDAR_VIEW"
year="1999"
month="5">
</IMART>
</BODY>
</HTML>

リンクに対して指定する方法の他にも<IMART type="frame"> のsrc属性 や <IMART type="form"> または <IMART type="submit"> の page 属性に対しても同様に指定することができます。

タグに指定する属性引数には、以下の種類があります。

year | (必須) | カレンダーの表示年
month | (必須) | カレンダーの表示月
past | (任意) | カレンダーの年選択コンボの表示量（過去） （現在表示年から過去past年間をコンボで選択可能）
future | (任意) | カレンダーの年選択コンボの表示量（未来） （現在表示年から未来past年間をコンボで選択可能）
display | (任意) | 日がクリックされたときにページをコールするウィンドウ名 （または、フレーム名）
link | (任意) | 日がクリックされたときにコールされるページパス （ Resource Serviceのプログラムディレクトリ（標準では、%Resource Service%/pages/src）からの相対パス）

カレンダーデータの受け取り方法

表示カレンダーの日がクリックされると自動的に link オプションに指定されているページをコールします。 このページのファンクションコンテナでユーザのクリック（選択）した情報を取得することができます。 ユーザがクリックした日情報は request オブジェクトを介して取得することができます。

Function Containerのコーディング例
        var sGroup = request.group;   // カレンダーID
        var sYear  = request.dtyear;  // 選択年の取得
        var sMonth = request.dtmon;   // 選択月の取得
        var sDate  = request.dtday;   // 選択日の取得

カレンダー拡張タグ

<IMART type="calendar"> という拡張タグを使うことでカレンダー画面を自由に作成することができるようになります。

詳細なプログラム・インターフェースに関しては、画面共通モジュール を参照下さい。

カレンダーモジュール

CalendarManagerオブジェクトに 含まれる各メソッドを利用することでプログラムにおいてカレンダー設定情報を呼び出して利用することができるようになります。

詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript BASE MODULE Documentation.[Mail]]

i ntra-mart The Power for Enterprise Web Solution
メール連携モジュール

準備(前提条件)

Application Runtime からネットワーク接続可能なマシン上にＳＭＴＰサーバ(RFC821 に準拠しているソフトウェア)を立ちあげて下さい。

Application Runtime の初期設定ファイル([install_directory]/conf/imart.xml)において、稼働中のＳＭＴＰサーバのアドレスとポートを指定した後に、i ntra-mart を起動して下さい。
メール連携モジュールを使用するには以下のライブラリが必要です。別途ダウンロードしてください。

  • JavaMail API 1.2
  • JavaBeans Activation Framework 1.0.2

    i ntra-mart WebPlatformの場合はダウンロードしたアーカイブを解凍し、全てのjarファイルを[install_directory]/lib/に配置してください。
    i ntra-mart AppFrameworkの場合は解凍したjarファイルをウェブアプリケーションサーバのクラスパスに追加してください。

    ＡＰＩ

    MailSender オブジェクト を利用します。

    詳細なプログラム・インターフェースに関しては、アプリケーション共通モジュール を参照下さい。

    例

    ファンクション・コンテナで MailSender ＡＰＩを利用してメール送信プログラムを記述します。

    以下に、aaa@example.com, bbb@example.com, および ccc@example.com に対して「試験メール」という表題の「これはメール送信試験です。\n無事に届きましたか？」という内容のメールを送信する例を示します。
    送信者アドレスは zzz@example.com とします。

    function init(request) {

    var letter = "これはメール送信試験です。\n無事に届きましたか？";

    // 送信メールオブジェクトを生成
    var mail = new MailSender();
    mail.addTo("aaa@example.com");
    mail.addTo("bbb@example.com");
    mail.addTo("ccc@example.com");
    mail.setFrom("zzz@example.com");
    mail.setSubject("試験メール");
    mail.setText(letter);

    // Storage Serviceから取得したファイルを添付
    var file = new VirtualFile("attach.txt");
    mail.addAttachment("attach.txt", file.load());

    // メール送信
    var result = mail.send();

    if(result) {
        Debug.browse("Scucess");
    } else {
        Debug.browse("Failed", mail.getErrorMessage());
    }
}

    • Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Tree View]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart
ツリー形式表示 API 仕様

機能概要

階層化データをツリー形式でブラウザ上に表示します。

このツリー表示ＡＰＩでは、以下の３種類のツリー表示部品を提供します。

  • フォルダー開閉式(初期表示は全閉)
  • フォルダー開閉式(初期表示は全開)
  • フォルダー開閉動作無し

ＡＰＩ仕様

この機能は、プレゼンテーションページから利用します。

<IMART type="include"> ＡＰＩを利用して、プログラムパスを呼び出して表示します。
呼び出すプログラムパスは以下の中から任意に選択できます。

@TREE_VIEW | 標準
@DYNAMIC_TREE_OPEN_VIEW | フォルダー開閉式(初期表示は全開)
@DYNAMIC_TREE_CLOSE_VIEW | フォルダー開閉式(初期表示は全閉)
@STATIC_TREE_VIEW | フォルダー開閉動作無し
※） 標準インストールにおいては、『標準』はデフォルト動作として『フォルダー開閉式(初期表示は全閉)』が選択されています。

タグに指定する属性引数には、以下の種類があります。

list | (必須) | 表示するツリー構造データ
home_name | (必須) | ホームの表示名
home_detail | (必須) | ホームの説明文 (ポップアップ文字列の表示内容)
click_home | (任意) | ホームイベント時実行関数名 ホームクリック時に実行されます 無指定時はイベント発生なし
click_folder | (任意) | フォルダイベント時実行関数名 フォルダクリック時に引数を伴って実行されます 無指定時はイベント発生時にフォルダの開閉動作
click_item | (任意) | アイテムイベント時実行関数名 アイテムクリック時に引数を伴って実行されます 無指定時はイベント発生時の処理はなし
highlight | (任意) | 選択項目のハイライトカラー 無指定時はデフォルト色を自動選択 (フォルダー開閉式ツリーのみ有効)

ホーム、フォルダーおよびアイテムのイベントとは、該当項目をマウスでクリックする行為をいいます。
マウスクリックイベントに対する各種開閉動作および選択項目のハイライトに関しては、フォルダー開閉式のツリー表示時が対象となり、フォルダー開閉動作無しのツリー表示時には、イベント処理は行われません。

属性 list にしていするツリーデータは、下記のような構造を持つデータオブジェクト配列を指定します。

list[0] ┬ name // この項目の表示名称 ・ ├ detail // この項目の説明 ・ ├ argument // この項目がクリックされた時の引数 ・ └ next[0] // この項目の下階層項目群 ・ ├ name ・ ├ detail ・ ├ argument ・ └ next[0] ・・・ [n] ┬ name ├ detail ├ argument └ next[0]
name | [String] | 項目の表示名称
detail | [String] | マウスポイント時に表示されるポップアップ文字列
argument | [String] | マウスクリックイベント発生時に実行される任意の Client Side JavaScript 関数に渡される引数文字列
next | [Array] | 下層のオブジェクト配列。 このプロパティ値を null にした場合アイテムとして扱われます。 また、このプロパティに Array 型のデータを値として与えることで、フォルダとして扱われます(要素を１つも持たない空の配列を値として与えた場合、下層情報を持たないフォルダとして扱われます)。
※）配列データを作成する場合、要素番号は 0 から始まる連続したデータとして作成するようにして下さい。

表示アイコン解説

・・・ | ホーム
・・・ | フォルダ (閉)
・・・ | フォルダ (開)
・・・ | アイテム
・・・ | 全表示

用語および操作解説

ホーム | ( [image] ) | : | マウスでホームアイコン( [image] ) をクリックすると、開かれていたメニュー項目がすべて閉じられます。 ホーム名称をクリックした場合、click_home 属性で指定してある Client Side の JavaScript 関数が実行されます(属性指定を省略した場合には、関数実行は行われません)。
フォルダ | ( [image] ) | : | メニュー項目グループの参照とメニューの開閉を行います。 マウスでフォルダアイコン( [image] または [image] or [image] または [image] or [image] ) をクリックすると、メニュー画面上でフォルダ内の各項目が開閉されます(ツリー開閉式を利用していた場合)。 フォルダ名称をクリックした場合、click_folder 属性で指定してある Client Side の JavaScript 関数が実行されます(属性指定を省略した場合には、関数実行は行われません)。
アイテム | ( [image] ) | : | 閲覧ページ、または作業ページを表示します。 ページアイコン( [image] )またはアイテム名称をクリックすると、click_item 属性で指定してある Client Side の JavaScript 関数が実行されます(属性指定を省略した場合には、関数実行は行われません)。
全表示 | ( [image] ) | : | すべてのメニュー項目を開きます。

プログラミング時の制約事項

引数属性 list には、仕様に準拠したデータを渡して下さい。間違った構造を持つデータを指定した場合、ランタイムエラーが発生する可能性があります。

ツリーの各クリックイベントに対応した Client Side の JavaScript 関数は、必ずツリー呼び出しステートメントよりもファイルの上部に定義(記述)してください。

ツリー開閉式ツリー表示ユニットでは、Dynamic-HTML およびスタイルシート(CSS)技術を利用しています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、これらの技術を無闇に利用すると二重定義などが発生しツリーのイベントが正常に動作しなくなることがあります。

ツリー表示ユニットで利用している Dynamic-HTML(ツリー開閉式のみ) および CSS (ツリー開閉式のみ) の定義名や Client Side JavaScript 関数(ページ内グローバル)および変数(ページ内グローバル) の名称には tree_ というプレフィックスがついています。
ツリー表示ユニットを呼び出しているプレゼンテーションページでは、Client Side JavaScript の各関数(ページ内グローバル)および各変数(ページ内グローバル)の名称などには、tree_ で開始される名称定義をしないでください。

ツリー表示ユニットでは、Dynamic-HTML(ツリー開閉式のみ) および Client Side JavaScript 技術を利用しています。
これら技術に対応していないブラウザでの利用はしないでください。

開閉式ツリー表示では、Dynamic-HTML 技術を利用して各項目の表示位置を自動的に計算して表示をしています。
ツリー表示呼び出しステートメントを記述してある位置を基準に表示位置を計算しているので、ツリー表示ステートメントはページの最下部に記述するようにしてください。

プログラム例

Presentation Page
<HTML>
<HEAD>
<SCRIPT language="JavaScript">
function onClickHomeFunction(){
window.alert("click home !");
}
function onClickFolderFunction(arg){
window.alert("click folder: " + arg);
}
function onClickItemFunction(arg){
window.alert("click item: " + arg);
}
</SCRIPT>
</HEAD>
<BODY>
<IMART type="include"
page="@TREE_VIEW"
list=datas
click_home="onClickHomeFunction"
click_folder="onClickFolderFunction"
click_item="onClickItemFunction"
home_name="sample"
home_detail="top"
hightlight="blue">
</IMART>
</BODY>
</HTML>
Function Container
var datas = new Array();

function init(request){
datas[0] = new Object();
datas[0].name = "No.1";
datas[0].detail = "item of No.1";
datas[0].argument = "no1";
datas[0].next = new Array();
datas[0][0] = new Object();
datas[0][0].name = "No.1-1";
datas[0][0].detail = "item of No.1-1";
datas[0][0].argument = "no1-1";
datas[0][0].next = null;
datas[1] = new Object();
datas[1].name = "No.2";
datas[1].detail = "item of No.2";
datas[1].argument = "no2";
datas[1].next = null;
}

注意事項

ツリー表示の各ホーム、フォルダおよびアイテムなどの画像ファイルは固定のものが使われます。任意に選択・変更することはできません。

開閉式ツリー表示のマウスイベント処理は、すべてブラウザ上の Client Side JavaScript で制御されていますので、ツリーの表示速度やイベント時の処理速度はクライアントマシンの処理能力に依存します。

ツリーの項目数が多い場合、ツリー表示画面のダウンロードに時間がかかったり、ブラウザ上に表示されるまでに時間がかかることがあります。
また、開閉式ツリー表示において表示項目数が多い時に、マウスクリックに対する反応が鈍くなることがあります。

制約事項

ツリー形式表示を行うためのツリーデータとして渡された情報は、そのまま画面作成に用いられる値として利用されます。
特にツリーデータ内の name プロパティに指定した値は表示系アプリケーション（ブラウザ）の実装に依存します。
また、ツリーデータ内の detail および argument プロパティに指定した値は、Client-Side JavaScript 中で利用されるデータとなりますので、扱える文字に制限がかかる場合があります（制限に関してはブラウザの実装に依存します）。

name データとして使えない文字の一例
< > & "
argument および detail データとして使えない文字の一例
< > " ' \

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Native Call]]

i ntra-mart The Power for Enterprise Web Solution
外部ライブラリコール

概要

intra-mart フレームワーク では、外部ライブラリの呼び出しが可能です。
外部ライブラリの作成から実行までを解説します。

外部ライブラリコールのアーキテクチャ

外部ライブラリの呼び出しは、フレームワークからJavaラッパークラスを経由して、 呼び出しを行います。

外部ライブラリの呼び出しは以下の手順で行います。

  1. ファンクション・コンテナの関数からJavaラッパークラスを生成します。
  2. Javaラッパークラスの関数を呼び出します。
    （Javaラッパークラスの各関数が外部ライブラリの各関数と紐づいています。）
  3. 対応した外部ライブラリの関数が実行されます。

Javaラッパークラスと外部ライブラリの作成

ここでは、C言語で作成される外部ライブラリの作成方法について説明します。

作成に必要なもの

Javaラッパークラスと外部ライブラリを作成するには、以下のものが必要です。
  • JDK （Javaラッパークラスを作成するために必要です）
    • javac.exe (Javaラッパークラスをコンパイルします。)
    • javah.exe (JavaラッパークラスからC言語用のヘッダファイルを作成します。)
    • jni.h （外部ライブラリ作成時に使用する標準ヘッダファイル）
  • Cコンパイラ （外部ライブラリを作成するために必要です）

フレームワークでの制約

フレームワークではJavaScriptから外部ライブラリを呼び出すために使用できる変数の型に制約を受けます。
以下に使用できる変数の型と対応する各言語の型を示します。

JavaScriptの型 | Javaの型 | Cの型
String | String | jstring
Number | double | jdouble
Boolean | boolean | jboolean

作成手順

  1. Javaラッパークラス（.java）を作成します。
  2. javac.exeでJavaラッパークラス(.java)をコンパイルします。（.class の作成）
  3. javah.exeでjavaラッパークラス（.java）から、C言語用のヘッダファイル(.h)を作成します。
  4. 作成されたヘッダファイル(.h)を元に外部ライブラリファイル（.c）を作成します。
  5. 外部ライブラリファイル(.c)をコンパイルし、外部ライブラリ（.dll）を作成します。

Javaラッパークラスの作成

  1. 新規にクラスを作成します｡
    (この時､パッケージ名を必ずつけてください｡)

  2. static エリア（初回CLASSロード時の処理）にロードするライブラリの名称を記述します。

    System.loadLibrary("ライブラリ名");
    ライブラリ名には、拡張子を除いたものを記述します。

  3. publicなメソッドを記述します。

    public native 戻り型 関数名（引数の型 引数名, [.….] ）;
    戻り値 および 引数の型は String , double , boolean のいずれかです。
    ここでは、メソッドの宣言だけで、手続きは書かないことに注意してください。

  4. 作成したファイルをコンパイルします。

    javac.exe ファイル名
    作成したclassファイルを.jarファイルにもまとめます。

[作成例]
package Hellow;
public class Hellow {
       static { // 初回CLASSロード時の処理
        System.loadLibrary("Hellow");  // ロードするライブラリ(Hellow.dll)
    }

    public Hellow( ) { }  // コンストラクタ

    // 引数の文字列を結合する関数
       public native String margeString(String a , String b);
       // 引数の数値を合算する関数
       public native double getPlus(double a , double b);
       // 引数の論理積を求める関数
    public native boolean getAnd(boolean a ,boolean b);
}

外部ライブラリの作成

  1. JavaラッパークラスからC言語用のヘッダファイルを作成します。
    javah.exe ファイル名

    [作成されるヘッダファイルのプロトタイプ]
    JNIEXPORT 戻り型 JNICALL 関数名 ( JavaVMのポインタ,クラスのオブジェクト,各引数の型);

  2. C言語用のヘッダファイルを元に外部ライブラリファイルを作成します。

    各関数の手続きを記述します。

  3. 外部ライブラリファイルをコンパイルして、（.dll）を作成します。

jstring(文字列)の扱い方

文字列はJava上では、UniCodeとして扱われます。
C言語で、利用するためには、UniCode → UTF-8への変換が必要です。
変換方法は以下の通りです。

*env | : JAVA-VMのインスタンス（関数の引数から渡されます）
a | : 変換したい文字列(jstring型) UniCode
*ca | : 変換後の文字列(char * 型) UTF-8

const char *ca = (*env)->GetStringUTFChars(env,a,0);
UTF-8に変換すると、C言語で通常の文字列として扱えます。

Javaへ値を返す時は、UTF-8 → UniCodeへの変換が必要です。
以下の例は、C言語の文字列から、Javaの文字列を作成する方法です
。
*env | : JAVA-VMのインスタンス（関数の引数から渡されます）
jstr | : 作成した文字列（jstring型） UniCode
buf | : 変換元の文字列(char * 型) UTF-8

jstr = (*env)->NewStringUTF(env,buf);

「作成されたヘッダファイルの例」
#include
#ifndef _Included_Hellow_Hellow
#define _Included_Hellow_Hellow
#ifdef __cplusplus
extern "C" {
#endif

JNIEXPORT jstring JNICALL Java_Hellow_Hellow_margeString
  (JNIEnv *, jobject, jstring, jstring);

JNIEXPORT jdouble JNICALL Java_Hellow_Hellow_getPlus
  (JNIEnv *, jobject, jdouble, jdouble);

JNIEXPORT jboolean JNICALL Java_Hellow_Hellow_getAnd
  (JNIEnv *, jobject, jboolean, jboolean);

#ifdef __cplusplus
}
#endif
#endif

「外部ライブラリファイルの例」
#include "Hellow_Hellow.h"
#include
/* 引数の文字列を結合する関数 */
JNIEXPORT jstring JNICALL Java_Hellow_Hellow_margeString
        (JNIEnv *env, jobject jobj, jstring a, jstring b)
{
    char buf[256]; /* テンポラリ文字列 */
    jstring jstr;  /* 戻り値用*/
    /* 引数をユニコードからUTF-8への変換 */
    const char *ca = (*env)->GetStringUTFChars(env,a,0);
    const char *cb = (*env)->GetStringUTFChars(env,b,0);

    strcpy(buf,ca); /* コピー*/
    strcat(buf,cb); /* 結合  */
    /* 戻り値の値をJava用のStringとして作成する。*/
    jstr = (*env)->NewStringUTF(env,buf);
    return jstr;
}
/* 引数の数値を合算する関数 */
JNIEXPORT jdouble JNICALL Java_Hellow_Hellow_getPlus
        (JNIEnv *env, jobject jobj , jdouble a, jdouble b)
{
    jdouble c; /* 戻り値用*/
    c = a + b; /* 合算する */
    return (c);
}
/* 引数の論理積を求める関数 */
JNIEXPORT jboolean JNICALL Java_Hellow_Hellow_getAnd
        (JNIEnv *env, jobject jobj, jboolean a, jboolean b)
{
    jboolean c ; /* 戻り値用*/
    c = a & b ; /* 論理積を求める */
    return (c);
}

外部ライブラリコールの方法

外部ライブラリコールの準備

  1. 作成した外部ライブラリ(DLLファイル)をPATHの通ったディレクトリに保存します。

  2. 作成したJavaラッパークラス(.jarファイル)を Application Runtime 起動時のクラスパスに追加します。
    intra-mart Administrator のJAVA起動オプション画面からjarファイル名（フルパスで）追加します。

  3. Application Runtime を起動します。

JavaScriptからの呼び出し

  1. Javaラッパークラスを生成します。
    objHellow = new Packages.パッケージ名.クラス名();

  2. 生成されたクラスから関数を呼び出します。
    Answer = objHellow.関数名(引数);

  3. これで、外部ライブラリ関数の呼び出しが可能になります。

「JavaScriptの例」
function init(request){
    var a;
    var b;
    var objHellow;

    objHellow = new Packages.Hellow.Hellow(); // クラスのロード

    a = "こんにちは " ;
    b = "イントラマートです"
    sAnswer = objHellow.margeString(a,b);

    // オブジェクト型で帰ってくるので、文字列にする必要があります。
    sAnswer = sAnswer + "";

    a = 10;
    b = 20;
    nAnswer = objHellow.getPlus(a ,b);

    a = true;
    b = false;
    bAnswer = objHellow.getAnd(a ,b);
}

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[call JAVA]]

i ntra-mart The Power for Enterprise Web Solution
JAVA クラスの利用

概要

アプリケーションプログラムでは、ファンクションコンテナにおいて、JAVA プログラムを呼び出して利用する事ができます。
JavaScript から呼び出す事のできる JAVA クラスは、JDK により提供されるクラスの一部と自作のクラスになります。

JAVA 呼び出しによる恩恵

JavaScript から JAVA のプログラムを呼び出せるということは、JAVA により提供される様々な技術を JavaScript から利用可能になるということでもあります。
これにより、単なる JAVA クラスの呼び出しだけにとどまらず、JavaBeans の利用や RMI, IIOP といった通信技術、さらには EJB などの利用も可能となります(この場合、それぞれの技術を提供している他のサーバ製品が別途必要になります)。

注意事項

JAVA のプログラムを呼び出す際に引き渡す引数には、以下の制限がつきます。

・ | 型 | String,Number および Boolean 型のみ、引数として利用可能です。オブジェクトを引数として指定することはできません。
・ | 数値 | JavaScript では、数値型は double として扱っているため、Number 型のデータを double 以外の型として引数指定した場合は、丸め込みなどの現象が起こる事があります。

JavaScript では、例外処理という概念が存在しないため、JavaScript から呼び出された JAVA プログラム内で発生した例外が JAVA プログラム内でキャッチされずにスローされた場合、JavaScript の実行は強制的に中断されます。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[JAVA[EJB Compornent]]]

i ntra-mart The Power for Enterprise Web Solution
EJB コンポーネントの呼び出し方

概要

intra-mart の動作している Java-VM に対して J2EE(Java Enterprise Edition)を追加インストールして適応する事により、他の EJB サーバと連携して、EJB サーバにある EJB コンポーネントを intra-mart のファンクションコンテナから呼び出す事ができるようになります。

準備

以下の手順に従って環境構築を行います。

1 | intra-mart を停止します。
2 | J2EE をインストールします。 J2EE をインストールするのは、Application Runtime の動作しているコンピュータです。 J2EE のインストールに関しては、J2EE のインストール・マニュアルにしたがって下さい。
3 | 環境変数およびクラスパスの追加設定をします。 環境設定に関しては、J2EE のインストールマニュアルを参照して下さい。 例）WindowsNT40 で標準インストールの場合 コンソールにおいて以下のコマンドを実行 SET J2EE_HOME=C:\j2sdkee1.2.1 SET PATH=%J2EE_HOME%\bin;%PATH% %J2EE_HOME%\bin\setenv.bat
4 | intra-mart の各サーバを起動します。

EJB コンポーネントの作成

EJB の規約に準拠してクラス作成をして下さい。
また、JavaScript と連携する部分に関しては、自作クラスの呼び出しに準拠するようにして下さい。

作成した EJB コンポーネントの EJB サーバへの登録およびネーミング設定に関しては、各 EJB サーバ製品のマニュアルを参照して下さい。

JavaScript からの呼び出し

クラスパスを適切に設定して Application Runtime を起動します。

ファンクションコンテナ内で以下のようにして、目的の EJB コンポーネントを呼び出します。

例）XXX という EJB コンポーネントを呼び出す場合

var initial = new Packages.javax.naming.InitialContext();
var objref = initial.lookup("XXX");
var home = Packages.javax.rmi.PortableRemoteObject.narrow(objref, java.lang.Class.forName("XXXHome"));
var interfaceXXX = home.create();
呼び出された EJB コンポーネントは、JavaScript の変数 interfaceXXX に格納されているので、あとは JAVA 呼び出しの要領で EJB コンポーネントの持つ各ＡＰＩを実行できます。

サンプル

SUN の J2EE に同梱されている Converter という EJB コンポーネントを呼び出すための手順を示します。

1 intra-mart を停止します。
2 SUN J2EE のドキュメントにしたがって、J2EE に同梱されているサンプル Converter を設定します。
file://c:/j2sdkee1.2.1/doc/guides/ejb/html/Started.fm.html(J2EE1.2.1 を標準インストールした場合)

各ソースファイルのコンパイルおよび設定が完了したら、ドキュメントにしたがって実行して、正常に動作することを確認して下さい。

3 Converter クラスパスの追加設定をします。
[install_directory]/conf/imart.xml の <java><server><command><option> タグに c:\j2sdkee1.2.1\doc\guides\ejb\examples\converter/\ConverterAppClient.jar(Windows の場合) を追加記述します(intra-mart Administrator を利用する事で簡単に設定ができます)。
4 intra-mart の各サーバを起動します。
5 以下のサンプルコードで Converter を呼び出す事が出来ます。
EJB コンポーネントである Converter の実行に成功すると、コンソールに結果が表示されます。
var initial = new Packages.javax.naming.InitialContext();
var objref = initial.lookup("MyConverter");
var home = Packages.javax.rmi.PortableRemoteObject.narrow(objref, java.lang.Class.forName("ConverterHome"));
var interfaceConverter = home.create();
Debug.print(interfaceConverter.dollarToYen(100.00));
Debug.print(interfaceConverter.yenToEuro(100.00));

注意事項

intra-mart から呼び出す EJB コンポーネントは、intra-mart の動作している Java-VM のバージョンに合わせて作成されたものに限ります。

JAVA および JavaScript で扱う変数型に関する注意事項に関しては、JAVA 標準クラスを呼び出した場合と同様です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


JAVA メニュー

JAVA クラスの利用
標準クラスの呼び出し
自作クラスの呼び出し
EJB コンポーネントの呼び出し


intra-mart[Server side JavaScript intra-mart Documentation.[JAVA[Original class]]]

i ntra-mart The Power for Enterprise Web Solution
自作クラスの呼び出し方

概要

独自に作成した JAVA プログラム(クラス)を呼び出します。

準備

Application Runtime が正しく起動されている事を確認して下さい。
また、バッチプログラムにおいて JAVA を利用する場合には、intra-mart Batch Server が正しく起動していることを確認して下さい。

JAVA クラスの作成

通常の JAVA プログラムを作成する要領でクラスを作成します。

コンストラクタまたはメソッドが引数を必要とする場合、JavaScript から直接受け取る事のできる変数型は String, byte, int, long, short, float, double, および boolean のみとなります。
また、メソッドが返却値を持つ場合で、その返却値を JavaScript でそのまま利用する場合は、String, byte, int, long, short, float, double, boolean のみを利用するようにしてください(JavaScript 側に NaN という数値データを返却する場合 Double.NaN を返却してください)。

独自のクラスを定義してこれを JavaScript から呼び出す場合、呼び出されるクラスでは、必ずパッケージ宣言をしておかなければいけません。

例）指数を司るインスタンスを生成して、メソッド(pow)の引数に指定した様々な数値の累乗を求めるクラス

package myclass;

public class Exponent{
private double exp;

public Exponent(int exp){
this.exp = (double) exp;
}

public double pow(double base){
return java.lang.Math.pow(base, exp);
}
}

環境設定

作成した JAVA プログラム(*.java)を JAVA コンパイラでコンパイルして、生成されたクラスファイル(*.class)をパッケージ宣言どおりのディレクトリ構造をもった場所に保存します(この状態で jar ファイルにする事も可能)。

クラスファイル(または jar ファイル)は、アプリケーションプログラム内で利用する場合には Application Runtime を動作するコンピュータに保存します。また、バッチプログラムで利用する場合には intra-mart Batch Server を動作するコンピュータに保存します。

Application Runtimeのクラスパスに作成したクラスのパスを追加指定します。(intra-mart Administrator で設定する事もできます。なお、クラスパスはクラスの依存関係や目的に応じて、適切に設定してください。

例）クラス myclass.Exponent の場合
コンパイルごのファイル myclass/Exponent.class(ディレクトリ myclass 内に Exponent.class というファイルが存在する状態)を インストールディレクトリ/lib/ に保存します。

root/
└ lib/
└ myclass/
└ Exponent.class
※）root/ は、ページプログラムでクラスを利用する場合は『ApplicationServer インストールディレクトリ』で、バッチプログラムで利用する場合は『BatchServer インストールディレクトリ』となります。

JavaScript からの呼び出し

独自クラスの場合、Packages キーワードにより呼び出しを行います。呼び出し構文は、Packages.パッケージ名.クラス名 となります。

クラスメソッドを利用する場合は、Packages.パッケージ名.クラス名.メソッド名() と記述して呼び出します。
また、コンストラクタを呼び出す場合には、new 演算子を用いて new Packages.パッケージ名.クラス名 と記述して呼び出します。

例）自作の指数クラスを呼び出して 2 の 8 乗を計算し、デバッグ画面に表示します。

var oct = new Packages.myclass.Exponent(8);
Debug.browse(oct.pow(2) - 0);

注意事項

intra-mart から呼び出すクラスは、intra-mart の動作している Java-VM のバージョンに合わせて作成されたものに限ります。

JAVA および JavaScript で扱う変数型に関する注意事項に関しては、JAVA 標準クラスを呼び出した場合と同様です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[JAVA[Standard class]]]

i ntra-mart The Power for Enterprise Web Solution
標準クラスの呼び出し方

概要

JDK により標準で提供されているクラスを呼び出します。
JavaScript から呼び出し可能な JAVA のパッケージは以下の通りです(それ以外のパッケージを利用する場合は、JAVA のクラスを自作して利用するようにしてください)。

java.lang
java.io
java.text
java.util

準備

Application Runtime が正しく起動されている事を確認して下さい。
また、バッチプログラムにおいて JAVA を利用する場合には、intra-mart Batch Server が正しく起動していることを確認して下さい。

プログラムからの呼び出し方

ファンクションコンテナの JavaScript プログラム内において、通常の JAVA のプログラミングの要領で目的のクラスを呼び出して利用して下さい。

インスタンスを生成する必要のあるクラスについては、new 演算子を用いる事でコンストラクタを呼び出す事ができます。また、生成したインスタンスを JavaScript で宣言した変数に格納して利用する事もできます。

プログラミング例

乱数を発生させるクラスを利用して１０回乱数を発生させてコンソール画面上に表示します(サービス化またはデーモン化している場合は、画面の表示されません)。

var ransuu = new java.util.Random();
var cnt = 0;
for(chr = 0; cnt < 10; cnt++){
Debug.print(ransuu.next());
}

注意事項

JavaScript の変数に対して JAVA データを格納した場合、その変数は JavaScript の通常の変数とは異なる扱いとなります。JAVA 変数を通常の JavaScript の変数と同様に扱うためには、変数の変換をする必要があります。JAVA → JavaScript の変換には、以下の方法があります。

String | 文字列連結ロジックを通す事で変換できます。 例）jsString = javaString + "";
Number | 算術演算ロジックを通す事で変換できます。 例）jsNumber = javaNumber - 0;
Boolean | 関係演算ロジックを通す事で変換できます。 例）jsBoolean = javaBoolean == true;

JAVA のＡＰＩを呼び出した結果の返却値を JavaScript の変数に受け取った場合、この値も JAVA として扱われますので、JAVA を利用した結果の値を JavaScript で利用する場合には、変数の型の変換をする必要があります。

JavaScript では import 句を利用する事ができません。JAVA のクラスを呼び出す場合は、必ずパッケージ名を省略せずに完全な形で目的のクラスを指定するようにして下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Presentation Page[extra-IMART tag]]]

i ntra-mart The Power for Enterprise Web Solution
拡張 <IMART> タグ

概要

拡張 <IMART> タグとは、標準で用意されている機能の他に独自の機能をサーバ側で処理されるタグ(<IMART>)としてロジックを登録できる機能です。

タグ関数の作成

実際に実行されるロジックは、FunctionContainer の関数として作成します。

タグ関数
function tagFunction(attr, inner){
return (String) + inner.execute();
}

タグ関数では、実行時に実行エンジンから attr と inner という２つの引数を受け取ります。引数 attr は <IMART> タグのタグ属性として与えられた属性値を持っています。attr はオブジェクト型で、属性名のプロパティを持ち、その値は属性値に等しくなります。

属性値 = attr.属性名

引数 inner の execute() メソッド(Function Container API InnerText を参照)を実行する事により、<IMART> タグおよび </IMART> に挟まれた範囲のスクリプトを実行する事が出来ます。これにより、<IMART> タグのネストされた範囲を画面に表示する事が出来ます(ネストされたタグの実現)。

タグ関数は、必ず文字列を返却値として返す必要があります。タグ関数から返された文字列は、そのタグが定義されていた位置に挿入(画面に表示)されます。

タグ関数の登録

タグとして動作させるロジックを記述した関数を実行エンジンに登録する事により、Presentation Page で拡張 <IMART> タグとして利用できるようになります。
拡張 <IMART> タグは、標準機能として提供されている他の <IMART> タグと同様にして利用できます（記述方法も全く同じです）。

タグ関数を登録するには、Function Container API Imart.defineType() を使います。このＡＰＩにより登録された関数は、Application Server が停止するまで有効に働きます(つまり、タグ関数の登録は１度だけで十分です)。
タグ関数登録時に指定した参照名が、そのままタグの type 名称となります。Presentation Page をプログラムする際、この type 名称は大文字・小文字を厳密に判定しますので、登録時には使いやすい名前になるように十分配慮するようにして下さい。

例

メッセージをキャプションとして表示する拡張タグ

ファンクション・コンテナ
Imart.defineType("caption", viewCaption);

function viewCaption(attr, inner){
if(attr.size == "1"){
return "<H1>" + inner.execute() + "</H1>";
}
else if(attr.size == "2"){
return "<H2>" + inner.execute() + "</H2>";
}
else{
return "<H3>" + inner.execute() + "</H3>";
}
}
プレゼンテーション・ページ
・
・
・
<IMART type="caption" size="1">セクション１</IMART>
<IMART type="caption" size="2">セクション２</IMART>
<IMART type="caption">セクション３</IMART>
・
・
・
実行結果
・
・
・
<H1>セクション１</H1>
<H2>セクション２</H2>
<H3>セクション３</H3>
・
・
・

注意事項

拡張タグのロジックを定義している関数内でページ遷移などのＡＰＩを呼び出さないで下さい。

拡張タグ関数内で利用できないＡＰＩ
  • forward()
  • redirect()
  • transmission()
  • Debug.browse()
  • Module.alert.*
  • Module.download.*
  • Module.mobile.alert()

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Application Common Master Table]]

i ntra-mart The Power for Enterprise Web Solution
i ntra-mart アプリケーション共通マスタ API 仕様

アプリケーション共通マスタ表は、intra-mart 上で動作するすべてのアプリケーション・プログラムから共通に利用するためのデータベース・アーキテクチャです。
データの参照に関しては、各プログラムから自由に行っても構いませんが、規定の方法以外でのデータ更新を行った場合、他のアプリケーションが正常に動作しなくなることがあります。

詳細はアプリケーション共通マスタ説明資料（PDF）を参照して下さい。

  • ユーザの登録・更新・削除

    • ユーザ（ログインアカウント、ユーザプロファイル）の登録・更新・削除は、 グループ管理者でログインし、メニューの[ログイングループ管理]-[アカウント設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、
    ログインアカウントは    Server Managerルート/specification/dtd/account_6_1.dtd を参照して下さい。
    ユーザプロファイルはServer Managerルート/specification/dtd/user-profile-data_6_1.dtd を参照して下さい。
    ユーザ所属はServer Managerルート/specification/dtd/user-attach-data_6_1.dtd を参照して下さい。

    プログラムインターフェースとしては、ログインアカウントに対してはAccountMangerオブジェクトを使用して下さい。

    ユーザプロファイルに対しては、UserManagerオブジェクトを使用して下さい。

    ユーザ所属に対しては、CompanyManagerオブジェクトを使用して下さい。

  • 会社・組織の登録・更新・削除

    • 会社・組織の登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[組織設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/company-data_6_1.dtd およびcompany-post-data_6_1.dtdを参照して下さい。

    プログラムインターフェースとしては、CompanyManagerオブジェクトを使用して下さい。

  • パブリックグループの登録・更新・削除

    • パブリックグループの登録・更新・削除は、グループ管理者でログインし メニューの[アプリケーション共通マスタ管理用フォルダ]-[パブリックグループ設定] から行って下さい。

    登録に関しては、データファイルのインポート機能が用意されています。
    データファイルのフォーマットは、Server Managerルート/specification/dtd/public-group-data_6_1.dtd を参照して下さい。

    プログラムインターフェースとしては、PublicGroupManagerオブジェクトを使用して下さい。

  • プライベートグループの登録・更新・削除

    • プライベートグループの登録・更新・削除は、編集対象のユーザでログインし メニューの[ユーザ設定]-[プライベートグループ設定] から行って下さい。

    プログラムインターフェースとしては、PrivateGroupManagerオブジェクトを使用して下さい。

  • ユーザ検索画面

    • ユーザ検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_user.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • 会社・組織検索画面

    • 会社・組織検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_company.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • パブリックグループ検索画面

    • パブリックグループ検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_public_group.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • プライベートグループ検索画面

    • プライベートグループ検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_private_group.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

  • ロール検索画面

    • ロール検索画面の呼び出し、連携については、Resource Serviceルート/pages/src/sample/search/sample_role.html を参照して下さい。
    インストール時にサンプルをインストールしてください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Manner for Page-Base Programing Model]]

i ntra-mart The Power for Enterprise Web Solution
コーディングルール
(スクリプト開発モデル)

注意事項

このページで記載されている内容は、 i ntra-mart アプリケーション(フレームワークの各画面も含む)をカスタマイズする際の必要事項になりますので、十分に理解した上で、i ntra-mart アプリケーションの開発を行うようにしてください。

JavaEE開発モデルに関しては、JAVA、JSP および Servlet 等、関連技術のルールに従ってください。

ルール

1.

i ntra-mart アプリケーション開発において、すべてのプログラム(プレゼンテーション・ページおよびファンクション・コンテナ)内で、JavaScript および i ntra-mart で規定されている予約語をプログラム変数や関数の名称として定義しないでください。

i ntra-mart フレームワークで提供されているＡＰＩの中には、ブラウザ上で動作するものも含まれていますので、ブラウザ上で動作をする Client Side JavaScript 内においても規定されている予約語を使用しないようにしてください。

2.

<IMART> タグは、必ず </IMART> と１対１の関係になるように記述しなければなりません（ </IMART> を未記述時の動作は未定義）。

3.

ファンクション・コンテナ内で、文字列定数値を定義する場合は、必ず " (ダブルクォーテーション)で囲まなければいけません。
(' (シングルクォーテーション)で文字列定数宣言をした場合の動作は保証されません。)

4.

ファンクション・コンテナ内でのスクリプトの記述において、";" (セミコロン)により明示的にステートメント末を宣言しなければいけません。
(JavaScrip の文法においては、改行コードでもステートメント末として認められていますが、この場合、思わぬ誤動作の原因になることがあります。)

5.

ファンクション・コンテナ内で変数を使用する場合には、必ず var キーワードを用いて明示的な変数宣言をしなければいけません。
(JavaScrip の文法においては、未宣言変数の使用も認められていますが、この場合、思わぬ誤動作の原因になることがあります。)

6.

ファンクション・コンテナ内に initという名称の関数を宣言してある場合、そのファンクション・コンテナがロードされた際に、ファンクション・コンテナ内に定義されている init() 関数が i ntra-mart ランタイム・エンジンにより必ず最初に自動実行されます。
(この動作仕様は、すべてのファンクション・コンテナに対して適応されます。)

7.

プログラム(プレゼンテーション・ページおよびファンクション・コンテナ)ファイル名と、プログラムファイルを格納しておくディレクトリに関して、日本語名称を与えてはいけません。

プログラム(プレゼンテーション・ページおよびファンクション・コンテナ)ファイル名と、プログラムファイルを格納しておくディレクトリに関して、以下に示す文字を含む名称を与えてはいけません。

\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab) (全角文字)

(添付ファイル等、データとして扱うファイル名は除く)

8.

i ntra-mart フレームワークで提供している機能において、すべてのＩＤに関して、以下に示す文字を含む名称を与えてはいけません。

\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab) (全角文字)
9.

ファンクション・コンテナ内で [install_directory]/conf/imart.xml を読み込んだり書き込んだりしてはいけません。

設定ファイルをむやみに変更することは、思わぬ誤動作の原因となります。

なお、[install_directory]/conf/imart.xml ファイル内の設定内容を変更した場合には、i ntra-mart システム全体の再起動が必要です。
ただし、i ntra-mart Administrator(サーバ管理ツール)上で設定内容を変更した場合には、i ntra-mart Administrator(サーバ管理ツール)から該当のサーバを再起動するだけで新しい設定内容が反映されます。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Function Container]]]

i ntra-mart The Power for Enterprise Web Solution
Function Containerについて

種類

ファンクションコンテナは、サーバで実行される JavaScript で記述された intra-mart のビジネスロジック・プログラム・ファイルです(Client Side JavaScript は、これに含まれません)。

ファンクションコンテナは、用途により４種に大別されます。

  • 初期起動用
  • Web ページ連携用
  • バッチプログラム用
  • 特殊プログラム
※） 共通関数登録用および独立型関数定義用などは、その性質の類似から『初期起動用』と同義と扱います。

初期起動用

初期起動用ファンクションコンテナは、サーバによりプログラムファイルがロードされると、ファイル内に記述された init() 関数が実行されます。
共通関数登録などの初期化処理は、init() 関数内に記述するようにしてください。

サーバの初期起動時には、ソースのルートディレクトリ（標準では、pages/src または pages/platform/src）にあるinit.js 内に定義された init() 関数が実行されます。

実行シーケンス
  1. init.js のロード
  2. init.js 内の init() 関数の実行

プレゼンテーションページ連携用

プレゼンテーションページと連動するファンクションコンテナは、サーバにより実行される時に、引数を伴って呼び出されます。

HTTP リクエストにより実行された場合、ＵＲＬ引数を持つ request オブジェクトを引数として init() 関数が実行されます。
また、リンクやフォームの action 属性により任意の関数実行が指定されている場合、ＵＲＬ引数を持つ request オブジェクトを引数として指定の関数が実行されます。

HTTP リクエスト以外の方法(ＡＰＩ forward() 等)により実行された場合、ファンクションコンテナ内の init() 関数は、その方法によって定義された引数を伴って実行されます(詳細に関しては、各々のＡＰＩ仕様を参照してください)。

プレゼンテーションページの実行が完了したあと、ファンクションコンテナ内に close() 関数が定義されていた場合、ＵＲＬ引数を持つ request オブジェクトを引数として close() 関数が実行されます。

実行シーケンス
  1. action 属性指定関数の実行
  2. init() 関数の実行
  3. プレゼンテーションページの実行
  4. close() 関数の実行

action 属性関数の実行指定がない場合は、action 属性関数の実行フェーズはスキップされます。
プレゼンテーションページ実行中は、プレゼンテーションページ側の要求に応じて、ファンクションコンテナ内の任意の関数が実行されることがあります。

バッチプログラム用

intra-mart Batch Server により、定められた時刻に実行されるファンクションコンテナが、これに該当します。

バッチ設定メンテナンスにより設定されている時刻になると、設定された任意のファンクションコンテナ内に定義された init() 関数が Application Runtime により実行されます。

特殊プログラム

session.js は、Application Runtime が HTTP リクエストを受け付けた時に実行されるプログラムです。

Application Runtime が HTTP リクエストを受け付けると、session.js 内に定義された init() 関数が実行されます。
また、Application Runtime がプレゼンテーションページの作成を完了した後、HTTP レスポンスを返す前に close() 関数が実行されます。

session.js ファイルを変更した場合は、Application Runtime を再起動するまでシステムには反映されません。

注意事項

ファンクションコンテナ内に定義された init() 関数および close() 関数は、特別な意味を持ちます。
これらの関数を正規の目的以外に定義をすると、思わぬ誤動作の原因となります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Outline[Web Page]]]

i ntra-mart The Power for Enterprise Web Solution
Presentation Pageについて
前提

ここでは、ブラウザを使い intra-mart に対してアクセスした場合の、ランタイム・エンジンの動作仕様を説明します。

intra-mart に対して Web アクセスするためには、Schedule Service を除くすべてのサービス および intra-mart Web-Server Connector をインストールして正しく動作していることが必要になります。

動作に必要なプログラム(初期起動)

Application Runtime の初期起動時には、指定のファンクションコンテナを実行します。

初期起動時に実行したいプログラムを記述したファンクションコンテナを適切なディレクトリに保存して、適切に呼び出されるようにしてください。
初期起動時にアプリケーション(共通関数など)の初期化や初期設定などを実行すると有効です。

注意）初期化プログラム内では、データベースアクセスができません。初期起動時にデータベースアクセスをする必要のあるプログラムは、データベースアクセス前に、必ずデータベース接続ＡＰＩを実行し、データベースアクセスＡＰＩに対して、接続参照名を明示的に指定するようにして下さい。

動作に必要なプログラム(Web ページ)

ブラウザから HTTP リクエストにより スクリプト開発モデルのプログラムが実行される場合、ページを作成するために必要なプレゼンテーションページおよびファンクションコンテナを実行します。

ページプログラムは、プレゼンテーションページ(HTML)とファンクションコンテナ(JS)の２ファイルで１対となります。

２つのファイルは、ファイルラベル名で関連付けられます。それぞれのファイル(HTML および JS)は、必ず同じファイルラベル名で作成してください。
拡張子は、プレゼンテーションページの場合は .html で、ファンクションコンテナの場合は .js となります。(どちらの拡張子も小文字のみとなります。大文字で記述した場合、正しく動作しなくなります。)

ファンクションコンテナが必要ない場合には、ファンクションコンテナファイルの省略（プレゼンテーションページファイルのみ）は可能ですが、プレゼンテーションページファイルの省略はできません。

ブラウザから直接リンクをする場合は、該当のファイルを Web-Server Connector をインストールしたディレクトリ内に保存して下さい。
(画像ファイルなども、これに該当します。)

実行シーケンス

ブラウザからリクエストがあった場合、以下のように処理が流れます。

  1. ブラウザからのリクエスト受付
  2. session.js 内 init() 関数実行
  3. action 属性関数の実行
  4. page 属性ファンクションコンテナ内 init() 関数の実行
  5. page 属性プレゼンテーションページの実行
  6. session.js 内 close() 関数実行
  7. ページ返却

ブラウザからリクエストを受け付けた場合、必ず session.js 内の init() および close() 関数が実行されます。
この session.js の実行は、ページ処理においてエラーが発生した場合においても、必ず実行されます。

action 属性関数とは、intra-mart 連携用のリンク(<IMART type="link">)またはフォーム(<IMART type="form">)またはサブミット(<IMART type="submit">)からのリクエストであり、action 属性関数の実行指定がされていた場合にのみ処理されます(action 属性関数の実行指定がなかった場合には、この処理フェーズはスキップされます)。
action 属性関数には引数として、ＵＲＬ引数情報を持つオブジェクト(request)が渡されます。引数 request の詳細に関しては、スクリプト開発モデル アプリケーション共通モジュール を参照して下さい。
action 属性関数指定が複数同時に行われていた場合、以下の順位付けにしたがって実行対象となる関数を決定します。

<IMART> タグの種類と優先順位
link < form < submit

page 属性とは、intra-mart 連携用のリンク(<IMART type="link">)またはフォーム(<IMART type="form">)またはサブミット(<IMART type="submit">)からのリクエストであり、page 属性関数の実行指定がされていた場合にのみ処理されます。
page 属性指定がない場合は、リクエストをしてきたページを再実行します。
また、page 属性指定がない場合でブラウザからの初アクセスの場合は、Resource Service のインストールディレクトリ/pages/ 直下のページ main (main.html および main.js)が実行されます。

page 属性ファンクションコンテナ内 init() 関数には引数として、ＵＲＬ引数情報を持つオブジェクト(request)が渡されます。引数 request の詳細に関しては、スクリプト開発モデル アプリケーション共通モジュール を参照して下さい。

プレゼンテーションページでは、<IMART> タグ部分が実行されます。
プレゼンテーションページ内のＡＰＩについては、スクリプト開発モデル 画面共通モジュール を参照して下さい。

各スクリプトの実行フェーズにおいて、何らかの要因でエラーが発生した場合、即座にスクリプト実行を中止して、ブラウザに対してはエラー画面を送信します。
エラーが発生した場合は、エラーの発生した実行フェーズおよび『session.js 内 close() 関数実行』および『ページ返却』を除く残りの実行フェーズはスキップされます。

session.js 内 close() 関数実行フェーズは、ページ処理に関する終了処理を行うことを目的とします。
session.js 内 close() 関数実行フェーズにおいて、Debug.browse() や forward() などのスクリプト実行を強制的に中断して処理を遷移させるＡＰＩを実行した場合、正しく処理されない場合があります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール

概要

会社・組織単位あるいはユーザ単位にフレームワークのログイン後初期画面に今日の予定やお知らせなど、自由にページを配置できるようになります。

あらかじめ作成、登録しておいたポータル表示用画面を、会社・組織単位あるいはユーザ単位に組み合わせ、初期表示画面を作成できます。

詳細はアドミニストレータガイドをご覧ください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール
注意事項

  • 各ポータル表示用画面のプレゼンテーションページ内のクライアントサイドJavascript の関数名、変数名、FORMのコントール名に、”IM_”、”_(アンダースコア)” から始まる名前を使うことはできません。 システム及び、イントラマートの提供するアプリケーションが使用します。
    また、これらのクライアントサイドJavascript の関数名、変数名、FORMのコントロール名は 各ポートレットでバッティングしないように、「(アプリケーションに割り当てられるプレフィックス)_」 をつけるなどしてください。

  • 処理に時間のかかるページを複数設定しますと、その分だけログイン時間がかかってしまいます。 できるだけシンプルな画面を作成することをお勧めします。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール
注意事項

  • 各ポータル表示用画面のJSPページ内のクライアントサイドJavascript の関数名、変数名、FORMのコントール名に、”IM_”、”_(アンダースコア)” から始まる名前を使うことはできません。 システム及び、イントラマートの提供するアプリケーションが使用します。
    また、これらのクライアントサイドJavascript の関数名、変数名、FORMのコントロール名は 各ポートレットでバッティングしないように、「(アプリケーションに割り当てられるプレフィックス)_」 をつけるなどしてください。

  • 処理に時間のかかるページを複数設定しますと、その分だけログイン時間がかかってしまいます。 できるだけシンプルな画面を作成することをお勧めします。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2010 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal Module]]

i ntra-mart The Power for Enterprise Web Solution
企業ポータルソリューション
ポータルモジュール

概要

ポータルモジュールとは、intra-mart を利用したポータルサイトを実現するための機能およびＡＰＩ群のことです。
目的や規模に合わせて２つの構築方法を選択することができます。

im-ポータル

intra-mart が標準で装備している機能です。

組織単位あるいはユーザ単位でのポータル画面の設計、および運用が可能になります。
個人認証は、intra-mart が標準で装備しているアクセスセキュリティ機能を利用していて、ログイン後の初期表示画面をポータル化することのできる機能です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal Module]]

i ntra-mart The Power for Enterprise Web Solution
企業ポータルソリューション
ポータルモジュール

概要

ポータルモジュールとは、intra-mart を利用したポータルサイトを実現するための機能およびＡＰＩ群のことです。
目的や規模に合わせて２つの構築方法を選択することができます。

im-ポータル

intra-mart が標準で装備している機能です。

組織単位あるいはユーザ単位でのポータル画面の設計、および運用が可能になります。
個人認証は、intra-mart が標準で装備しているアクセスセキュリティ機能を利用していて、ログイン後の初期表示画面をポータル化することのできる機能です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2010 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール

画面開発

スクリプト開発モデルの画面は、おおむね通常のintra-martの画面開発と変わりません。

グループ管理者の[ポータル] - [ポートレット]編集画面で設定されたページ引数は、init関数の request オブジェクトより取得することができます。

ただし、スクリプト開発モデルで作成されたポートレットからサブミット処理を行い、 処理終了後に再びポータル画面を表示する機能を作成する場合には、以下の制約があります。
  • サブミット処理後にポータル画面へURLリダイレクトを行う

  • requestオブジェクトにポータルコードが設定されている場合は、表示するポータルの情報を設定する

  • 遷移先のウインドウ名 "IM_MAIN" をtarget属性で指定する

以下にサンプルを示します。
  • プレゼンテーションページ

    <!-- ウインドウをtarget属性で指定 -->
<IMART type="form" action="insertData" target="IM_MAIN">

    <!-- サブミット後に表示するポータルの情報 -->
    <IMART type="hidden" portal_cd=portal_cd></IMART>

    <!-- サブミット処理で使用する値 -->
    <INPUT type="text" name="param" value="">

    <INPUT type="submit" value="実行">
</IMART type="form">

  • ファンクションコンテナ

    // ポータルコード
var portal_cd = "";

function init(request) {
    if (!isUndefined(request.portal_cd)) {
        portal_cd = request.portal_cd;
    }
}

function insertData(request) {

    // 登録処理で使用するパラメータを取得
    var paramValue = request.param;

    // 何らかの登録処理を実行
    ････

    // ポータル画面遷移のURLを取得
    var portalUrl = getURL(request.portal_cd);

    // ポータル画面へリダイレクト
    redirect(portalUrl);
}

function getURL(portalCode) {
    // URLの生成
    var url = "portal-portal_display.service";

    // 表示ポータルの情報を設定
    if (portalCode != '') {
        url += ("?portal_cd=" + portalCode);
        url += "&actionId=switch";
    }

    return url;
}

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[intra-mart Documentation.[Portal[light]]]

i ntra-mart The Power for Enterprise Web Solution
ポータルモジュール

画面開発

JavaEE開発モデルあるいはJavaEEフレームワークの開発は、おおむね通常のintra-martの画面開発と変わりません。

グループ管理者の[ポータル] - [ポートレット]編集画面で設定されたページ引数は、 HttpServletRequestオブジェクトの getParameterメソッドより取得することができます。

ただし、JavaEE開発モデルで作成されたポートレットからサブミット処理を行い、 処理終了後に再びポータルを表示する機能を作成する場合には、以下の制約があります。

  • サブミット処理後にポータル画面を表示するサービスを呼び出す

  • HttpServletRequestオブジェクトにポータルコードが設定されている場合は、表示ポータルの情報としてポータルコードなどの情報を引き渡す
  • 遷移先のウインドウ名前 "IM_MAIN" をtarget属性で指定する

以下に、JavaEEフレームワークで開発されたポートレットでサブミットされた後に、再びポータル画面を表示するサンプルを示します。
  • JSP

    <%@ taglib prefix="portal"
    uri="http://www.intra-mart.co.jp/taglib/core/framework" %>

<%
  String portalCd = "";
  if (request.getParameter("portal_cd") != null) {
      portalCd = request.getParameter("portal_cd");
  }
%>

<!-- 何らかの登録処理を行うサービスを呼び出す -->
<portal:Form application="sample" service="post_action"
             target="IM_MAIN">

  <!-- 登録処理後に表示するポータルの情報  -->
  <input type="hidden" name="portal_cd"
                             value="<%= portalCd %>">
  <input type="hidden" name="account"
      value="<%= (portalCd != "") ? actionId : "" %>">

  <!-- 登録処理で使用する値 -->
  <input type="text" name="param" value="">

  <input type="submit" value="実行">
</portal:Form>

  • 登録処理を行うサービスの定義

    <?xml version="1.0" encoding="UTF-8"?>
<service-config>
  <service>
    <!-- 登録処理を行うコントローラ -->
    <service-id>post_action</service-id>
    <controller-class>
      sample.portal.PortalSampleServiceController
    </controller-class>

    <!-- ポータル画面遷移のトランジション -->
    <transition-class>
      sample.portal.PortalReloadTransition
    </transition-class>
  </service>
</service-config>

  • ポータル表示のサービスを呼び出すトランジション

    package sample.portal;
import jp.co.intra_mart.framework.base.service.DefaultTransition;

public class PortalReloadTransition extends DefaultTransition {

    public String getNextPage() {
        // ポータルを表示するURLを返す
        return "portal-portal_display.service";
    }
}

汎用新着ポートレット

im-ポータルには、汎用的な新着情報を表示するポートレットが用意されています。 この汎用新着ポートレットでは、新着情報として以下の項目を表示します。
  • 新着情報の種類を示すためのカテゴリ
  • 新着情報の内容（概要）
  • 配信日付
  • 新着情報に紐付く遷移先の情報（リンク）
汎用新着ポートレットに独自の新着情報を表示させるためには、下記の手順でポートレットを登録します。

  1. 新着情報を取得するプロバイダを実装する

    新着ポートレットに表示される情報は、以下のインターフェースを実装したプロバイダより取得されます。

    jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.NewArrivedProvider

    ポータルモジュールでは、スクリプト開発モデルプログラムより新着情報を取得する以下のプロバイダの実装クラスがあらかじめ用意されています。

    jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider

    インターフェースおよびプロバイダの実装についての詳細はAPIリストを参照して下さい。

  2. プロバイダの実装を定義する

    実装したプロバイダクラスについての情報は、storage service配下の任意の場所に設定ファイルを作成して定義します。 設定ファイルには以下の情報を定義します。

    • カテゴリでソートするかどうかを表すフラグ
    • プロバイダの実装クラス名
    • プロバイダのインスタンス生成時に設定する初期化パラメータ

    たとえば、上記のスクリプト開発モデルプログラムより新着情報を取得するプロバイダを使って新着情報を取得する場合は、以下のように定義を行います。
    <new-arrived-portlet>
  <sort>true</sort>
  <provider>
    <provider-class>
      jp.co.intra_mart.foundation.portal.general_purpose_portlet.provider.PageBaseCallProvider
    </provider-class>
    <init-param>
      <param-name>pagePath</param-name>
      <param-value>/hoge/sample_provider.js</param-value>
    </init-param>
  </provider>
</new-arrived-portlet>
    sort要素で取得した新着情報をソートするかどうかを定義します。また、provider要素内のprovider-class要素でプロバイダの実装クラス、init-param要素でプロバイダクラスに設定する初期化パラメータを定義します。

    設定ファイルについての詳細な定義については、サーバマネージャインストールディレクトリ/specification/dtd/new-arrived-portlet_6_1.dtd を参照して下さい。

  3. ポートレットを登録する

    グループ管理者の[ポータル] - [ポートレット]編集画面で、新着情報を表示するためのポートレットを登録します。
    汎用新着ポートレットを設定する場合は、「ページ種別」、「画面パスあるいはURL種類」、「ページ引数」の設定が必要になります。たとえば、サンプルでは、以下のように設定されます。

    • ページ種別 ： Servlet/JSP
    • 画面パスあるいはURL種類 ： /portal/portlets/newly_arrived_view.jsp
    • ページ引数 ： page_param=/portal/standard.xml

    「画面パスあるいはURL種類」で指定されたJSPには、プロバイダが取得した新着情報を表示するためのJSPなどを指定します。サンプルで指定しているJSPは、ポータルモジュールで用意されたデフォルトの実装です。
    「ページ引数」には、プロバイダの情報を定義した設定ファイルのパスを page_param= ... の形式で指定します。para_paramの値には、storage serviceのルートディレクトリ配下のパスを指定します。

「重要なお知らせ」ポートレットについて

「重要なお知らせ」ポートレットは、汎用新着ポートレットの仕組みを使って実装されたポートレットです。
プロバイダクラスには以下の実装クラスが使用されています。

jp.co.intra_mart.foundation.security.password.PasswordHistoryNewArrivedProvider

その定義は、storage service配下の設定ファイル portal/system_notice.xml で行われています。

現在はパスワード履歴管理の情報のみが扱われていますが、プロバイダクラスを実装して設定ファイルへ定義を追加すれば、パスワード履歴以外の情報も「重要なお知らせ」として扱うことができるようになります。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2010 All Rights Reserved.


ポータル メニュー

ポータルモジュール
概要
・im-ポータル
仕様
開発ガイド
注意事項


ポータル メニュー

ポータルモジュール
概要
・im-ポータル
仕様
開発ガイド
・ 画面開発
・ 汎用新着ポートレット
注意事項


intra-mart[Server side JavaScript intra-mart Documentation.[About]]

The Power for Enterprise Web Solution

API リスト仕様
 西暦 2010 年 10月 29日現在

注意事項

このＡＰＩリストでは、intra-mart Version 6.1.x におけるモジュール構成、およびプログラム・インターフェースであるＡＰＩ仕様について解説しています。

このＡＰＩリストに記載されている内容は、株式会社ＮＴＴデータイントラマートで定めた intra-mart Version 6.1.x における公式なＡＰＩ仕様になります。

このＡＰＩリスト内に記載されていない内容に関しては保証致しかねますので、予めご了承ください。

推奨されないＡＰＩ

「推奨されません」または「非推奨」、およびこれに類する表現をしているＡＰＩは、他のＡＰＩと比べて以下の条件も併せ持ちます。

  • メーカーの通常サポートの範囲に含まれます。
  • 過去のバージョン（またはリビジョン）のインタフェースを互換するために用意されたものです。
  • 通常は、他に推奨される新しいＡＰＩが提供されています。
  • 他に提供されている推奨される新しいＡＰＩと比較して、パフォーマンス等の性能が劣る場合があります。
  • 将来のバージョン（またはリビジョン）において、削除される可能性があります。

構成

左フレームには全体のメニューが表示されています。

メニューは、このＡＰＩリストを含めた、プロダクト全体の仕様に関して解説している 『 Document 』 と、各ＡＰＩについてプログラム・インターフェースの詳細について解説している 『 Developer's Guide 』 に大きく分類されています。

閲覧方法

左フレームにある各メニューのハイパーリンクをクリックする事で、その内容について詳細に解説されているページへ移動する事ができます。
ページ遷移や情報のビューイングに関しては、通常のウェブブラウジングの方法と同様です。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2010 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Setup]]

i ntra-mart The Power for Enterprise Web Solution
データのインポート／エクスポート

ResourceService上のセキュリティに関するデータを指定の フォーマット形式のファイルからインポート／エクスポートすることができます。
この操作はシステム設定画面、及びプログラム・インターフェースから行うことができます。
画面から行う方法については、マニュアルを参照して下さい。
プログラム・インターフェースの詳細に関しては、アプリケーション共通モジュール(アクセスセキュリティの各Managerオブジェクト)をご参照下さい。

各インポート・エクスポートデータのフォーマットは、こちらを参照してください。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[keyword]]

i ntra-mart The Power for Enterprise Web Solution
予約語

注意事項

ここで記載している予約語は、JavaScript で定義されているもの、および JAVA で定義されているものの他に、i ntra-mart で定義しているものを含みます。

定義されている予約語は、プレゼンテーション・ページ、ファンクション・コンテナのどちらのプログラム内においても守る必要があります。
(ブラウザ上で動作をする Client Side JavaScript のプログラム内においても適用されます。)

予約語適応例

  • JavaScript 変数名
  • JavaScript 関数名
  • JavaScript 共通関数定義名(Procedure)
  • ＵＲＬ引数のキー名称
  • ＨＴＭＬフォームのコントロール名称
  • ＨＴＭＬフォーム名(name 属性)
  • ＨＴＭＬスタイルシート名
  • ＨＴＭＬレイヤー名
  • JAVA パッケージ名
  • intra-mart インストールディレクトリ直下のファイル名称
  • intra-mart インストールディレクトリ/doc/ 直下のファイル名称
  • intra-mart インストールディレクトリ/pages/ 直下のファイル名称
  • intra-mart インストールディレクトリ直下のディレクトリ名称
  • intra-mart インストールディレクトリ/doc/ 直下のディレクトリ名称
  • intra-mart インストールディレクトリ/pages/ 直下のディレクトリ名称
  • データベース表名

これらの名前付けにおいて予約語に違反した命名をした場合、intra-mart の動作が不安定になったり、intra-mart の Version up 時においてスムーズな移行ができない場合があります。

予約語 [ JavaScript ]

abstract boolean break byte case catch char class const continue default do double else extends false final finally float for function goto if implements import in instanceof int interface long native new null package private protected public return short static super switch synchronized this throw throws transient true try typeof var void while with

その他 [ グローバル変数（Client.set()メソッドのキーとして使用している文字列） ]

bx3m52nmcgl00(Identifier.get()で取得した値) USER atr_cfg_mode atr_cfg_gId channel_cfg_mode channel_cfg_gId srh_cfg_gId srh_cfg_notDisplay srh_cfg_style dbs_cfg_mode dbs_cfg_gId grp_conf_userdata usr_cfg_gId lnk_cfg_mode lnk_cfg_gId msg_cfg_mode msg_cfg_gId pag_cfg_gId pag_ndp020 rle_cfg_mode rle_cfg_gId usr_cfg_mode usr_cfg_dbm usr_cfg_gId zon_cfg_mode zon_cfg_gId SYSTEM.MENU.ACTIVE.ID ALERT wkf_sortInf wkf_strDateFrom wkf_strDateTo wkf_request_bk mmt_ndp131 mmtData

その他 [ 共通関数（Procedure.define()メソッドのキーとして使用している文字列） ]

age criteriondate date upload sql RealNumber workflow wkf_isRoute wkf_isItemOnRoute wkf_insertRoute wkf_updateRoute wkf_deleteRoute wkf_getUserNote wkf_getCntAnalyze wkf_getAckDayTermAvg wkf_toNullString wkf_getFullUserName wkf_ackkind_func

予約語 [ JAVA ]

abstract boolean break byte case catch char class const continue default do double else extends final finally float for goto if implements import instanceof int interface long native new null package private protected public return short static super switch synchronized this throw throws transient try void volatile while
JAVA の予約語の大部分は、JavaScript の予約語に含まれています。

その他 [ グローバル変数（jp.co.intra_mart.foundation.service.client.informationパッケージ中の Identifierクラス以外のset()メソッド、entry()メソッドのキーとして使用している文字列） ]

bx3m52nmcgl00(Identifier.get()で取得した値) USER atr_cfg_mode atr_cfg_gId channel_cfg_mode channel_cfg_gId srh_cfg_gId srh_cfg_notDisplay srh_cfg_style dbs_cfg_mode dbs_cfg_gId grp_conf_userdata usr_cfg_gId lnk_cfg_mode lnk_cfg_gId msg_cfg_mode msg_cfg_gId pag_cfg_gId pag_ndp020 rle_cfg_mode rle_cfg_gId usr_cfg_mode usr_cfg_dbm usr_cfg_gId zon_cfg_mode zon_cfg_gId SYSTEM.MENU.ACTIVE.ID ALERT wkf_sortInf wkf_strDateFrom wkf_strDateTo wkf_request_bk mmt_ndp131 mmtData

予約語 [ i ntra-mart ]

以下の文字、または文字列をプレフィックスとする語
_ im Im iM IM

また、ＡＰＩで提供されているクラスおよび関数では大文字を接頭辞として使用しています。

その他 [ StorageServiceルートに使用しているフォルダ名 ]

basemodule system

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.[Setup]]

i ntra-mart The Power for Enterprise Web Solution
セットアップ

サーバ・マネージャ

システム全体を統括的に管理するためのサーバです。
このサーバは、ライセンス管理も同時に行っています。ライセンス登録は、このサーバの動作しているコンピュータで行ってください。

また、IM-アドミニストレータが接続するサーバにもなりますので、IM-アドミニストレータをご利用の場合は、それぞれのコンピュータがネットワーク接続できるにしてください。

サービス・プラットフォーム

システム内の各機能は、サービスという単位で独立していて、それぞれのサービスが相互に連携をすることによりシステムを構成します。 これらのサービスを動作させるためのサーバプロセスが、このサービスプラットフォームです。

サービス

サービスプラットフォームで実行されて、定められた機能を提供するものです。
サービスには様々な種類があり、個々のサービスはそれぞれ固有の機能を持っています。サービスには、下記の種類があります（各々のサービスに関する詳細については、製品に付属のドキュメントを参照してください）。

  • Application Runtime
  • Resource Service
  • Storage Service
  • Shared Memory Service
  • Permanent Data Service
  • Schedule Service
  • Serialization Service

注意事項

intra-martの各サーバをインストールするコンピュータは全て、時計(コンピュータのシステム時計)を合わせて下さい。
コンピュータごとにシステム時間が大きく違っていると、アプリケーションが正しく動作しない場合があります。

詳細については、フレームワーク・インストールガイドをご参照下さい。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Foundation tools.[JavaScript Compiler]]

i ntra-mart The Power for Enterprise Web Solution
JavaScript コンパイラ
  • 形式
  • 解説
  • オプション
  • 例
  • その他

形式

java -cp ./bin/intramart.jar jp.co.intra_mart.bin.js2class [ options ] [ sourcefiles ] [ sourcedirectories ]

( bin\tools\js2class [ options ] [ sourcefiles ] [ sourcedirectories ] )
options
コマンド行オプション
sourcefiles
コンパイルされる 1 つ以上のソースファイル (my_script.js など)
sourcedirectories
コンパイルされる 1 つ以上のソースファイルのあるディレクトリ

解説
jp.co.intra_mart.bin.js2class ツールは、intramart.jarアーカイブに含まれています。実行時には、intramart.jar からクラスがロードできるようにクラスパスを設定して下さい。(Service-Platform を Windows にインストールしている場合には、bin/tools/ ディレクトリに js2class.bat というバッチファイルがインストールされています。このバッチファイルを利用することでクラスパスの設定等をしなくてもコンパイラを実行することができます。)

jp.co.intra_mart.bin.js2class ツールは、JavaScript プログラミング言語で記述されたファンクションコンテナを読み取り、バイトコードクラスファイル(JAVA のクラスファイル)にコンパイルします(*.js ファイルから *.class ファイルが作られます)。

ソースコードのファイル名を jp.co.intra_mart.bin.js2class に渡すには、ファイル名をコマンド行で直接指定します。ソースコードが複数ある場合は、各ファイル名またはソースコードの親ディレクトリ名をスペースで区切って指定します。

ソースコードのファイル名は .js 拡張子、クラスのファイル名は .class 拡張子を持たなければなりません。また、クラスファイル名はソースファイル名を元にして自動的に生成されます。このクラスファイル名は任意に変更することはできません。

内部関数定義は、追加のクラスファイルを生成します。これらのクラスファイルの名前は、_my_script_js$MyInnerFunction.class のように、内部クラス名と外部クラス名を組み合わせたものになります。

オプション
-d sourcepath
ソースファイルを検索するソースコードパスを指定します。ソースファイルは、ソースコードパス sourcepath とソースファイル名の組合わせで検索します。

-d が指定されていない場合、jp.co.intra_mart.bin.js2class はカレントディレクトリからソースファイルを検索します。

-o directory
クラスファイルの出力先ディレクトリを設定します。クラスがパッケージの一部である場合、jp.co.intra_mart.bin.js2class は、必要に応じてディレクトリを作成し、パッケージ名を反映したサブディレクトリにクラスファイルを置きます。

-o が指定されていない場合、jp.co.intra_mart.bin.js2class はカレントディレクトリにクラスファイルを置きます。

-debug
デバッグ情報を生成します。行番号およびソースファイル情報などが生成されます。-debug オプションを指定することにより、実行時にエラーが発生した場合のデバッグが容易になります。

-opt level
実行時のコードを最適化します。最適化の程度は、0 から 9 までの整数値で指定することができます。数字が大きいほど最適化レベルは高くなりますが、その分コンパイル速度が低下し、デバッグの困難なプログラムが生成されることがあります。0 は最適化をせずにコンパイルします。-opt オプションを指定しなかった場合の標準値は 0 です。また -opt オプションは -debug と併用することはできません。

-charset charset
ソースファイルのエンコーディング名 (Shift_JIS/EUC-JP など) を指定します。-charset が指定されていない場合は、ご利用のシステムにおけるデフォルトの文字エンコーディングが使われます。 このオプションに指定できるエンコーディング名は、JAVA の仕様で定義されているエンコーディング名です。指定可能なエンコーディング名については、JAVA のドキュメントをご覧ください。

-h
ヘルプメッセージを出力します。他のオプション指定があっても、すべて無視されます。また -h オプションが指定された場合、コンパイルは行われません。

例(Windows の場合)

簡単なプログラムのコンパイル
サンプルソースファイル pages/src/sample/example/string/main.js をコンパイルする例を示します。（intra-martのインストール時にサンプルをインストールしてください。）クラスファイルは、標準でクラスパスとなっている doc/imart/WEB-INF/classes/ ディレクトリにコンパイルされるようにします。このため、この例ではスタンドアロン環境の場合に限り、コンパイルした後にクラスファイルを移動したり実行時のクラスパスを設定する必要はありません（ネットワーク環境の場合は、作成されたクラスファイル（_sample/_example/_string/_main_js.classなど） をApplication Runtimeの doc/imart/WEB-INF/classes/ ディレクトリにコピーする必要があります）。
C:> dir
imart\
C:> cd imart\pages\src
C:\imart\pages\src> ..\..\bin\tools\js2class -o C:\imart\doc\imart\WEB-INF\classes sample/example/string/main.js
上記の例では、C:\imart\doc\imart\WEB-INF\classes ディレクトリに _sample/_example/_string ディレクトリが作成され、その中にクラスファイルが保存されます。この状態(ネットワーク構成の場合には、_sample ディレクトリをApplication Runtimeの doc\imart\WEB-INF\classes ディレクトリにコピー)でサーバを再起動すると、pages/src/sample/example/string/main.js は読み込まれなくなり、替わりにクラスファイルがロードされます(以後、ソースコードの変更は自動では反映されません)。

複数のソースファイルのコンパイル
次の例は、ソースファイル init.js とディレクトリ sample 内のすべてのソースファイルをコンパイルします。
C:> dir
imart\
C:> cd imart\pages\src
C:\imart\pages\src> ..\..\bin\tools\js2class -o C:\imart\doc\imart\WEB-INF\classes init.js sample

その他
ソースファイルをコンパイルしておくことにより、システム全体のパフォーマンスを向上させることができます。ただし、ソースファイルを実行した場合とコンパイルされたクラスファイルを実行した場合では、システムにロードされる方式が異なるため実行時のスコープが変わってしまう場合があります。これにより実行時エラーが引き起こされる場合がありますので、ソースファイルをクラスファイル化した場合は、実行に問題がないことを必ず確認する必要があります。

コンパイルしたクラスファイルは、コンパイル時に指定した最適化レベルによりバイトコードの構造が異なります。特に最適化レベルが高い場合には、バイトコードが最適化されていることに起因して実行時エラーが発生する場合があります。その場合は、最適化レベルを低く設定するか、またはエラーとならないソースコードに書き換えて下さい。

コンパイルされたクラスファイルは、そのクラスファイル（ファンクションコンテナ）が実行されるサーバ（Application Runtime）環境においてクラスパスの設定されているディレクトリに保存して実行して下さい。クラスファイルは、ＪＡＶＡの通常のクラスローダーによりロードされてＶＭ上で実行されます。また、クラスファイルは一度実行されるとメモリ内にクラス情報がキャッシュされますので、クラスファイルを変更した場合はサーバの再起動が必要となります。

クラスファイル化したファンクションコンテナを使う場合は、Resource Service にソースファイルは必要ありません（クラスに該当するソースファイル(JavaScript ソースコード)は、削除してしまっても問題ありません）。
Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Foundation tools.[License Editor]]

i ntra-mart The Power for Enterprise Web Solution
ライセンサ
  • 形式
  • 解説
  • オプション
  • 例
  • その他

形式

java -cp ./bin/intramart.jar jp.co.intra_mart.bin.licedit

(bin\tools\licedit )

解説
jp.co.intra_mart.bin.licedit ツールは、intramart.jarアーカイブに含まれています。実行時には、intramart.jar からクラスがロードできるようにクラスパスを設定して下さい。 　（%ServerManagerのルートディレクトリ%/bin/toolsディレクトリにlicedit.bat(Windows用)、および、licedit.sh(UNIX用)がインストールされています。 　このファイルを利用することでクラスパスの設定等をしなくてもライセンサを実行することができます。）

jp.co.intra_mart.bin.licedit ツールを利用することで、intra-mart サーバを立ち上げていない状態でもライセンス登録が可能です。また、intra-mart サーバを運用中に jp.co.intra_mart.bin.licedit ツールでライセンス登録をすることもできますが、その場合はライセンス登録後に intra-mart サーバを再起動して下さい。

jp.co.intra_mart.bin.licedit ツールは、ライセンスを登録したり情報を閲覧することができます。また、アプリケーションズのライセンスも観覧、登録することができます。
ライセンスキーの投入モードでライセンスキーを入力することにより、フレームワークまたアプリケーションを自動で判別し、ライセンスを登録できます。

オプション
このコマンドに指定可能なオプションはありません。

例(Windows の場合)
コンソール画面でライセンス登録を行います。
コンソール画面でコマンドを入力してライセンサを起動したら、下記の要領で画面の指示に従いライセンスの登録・閲覧作業を行って下さい。
Please choose a menu.
      (Please input number. Then, hit enter key.)
----------------------------------------
 [1] Show the license.
 [2] License Registration.
 [3] License Deletion.
 [4] Exit.
----------------------------------------
1
######################################################################
WebPlatform (Trial License)
      Product Type ID        : BA

      Version                : 5.1.0.ProtoType-model.beta
      Package Version        : 5.1.0.ProtoType-model.beta[Advanced Edition]
      Install Date           : Fri Dec 09 13:50:21 JST 2005
      Expired Date           : Tue Feb 07 13:50:21 JST 2006
      Max AppRuntime Process : 1
      Max User Account       : 5
######################################################################
**********************************************************************
イントラネット・スタートパック (Trial License)
      Product Type ID        : IS

      Version                : 5.0.0
      Package Version        : 5.0.0
      Install Date           : Fri Dec 09 16:55:35 JST 2005
      Expired Date           : Tue Feb 07 16:55:35 JST 2006
      Max Service Process    : 1
      Max Application Role   : 5
**********************************************************************

Please choose a menu.
      (Please input number. Then, hit enter key.)
----------------------------------------
 [1] Show the license.
 [2] License Registration.
 [3] License Deletion.
 [4] Exit.
----------------------------------------
4

C:\imart\bin>

その他
ライセンサでライセンスを登録した場合、intra-mart のすべてのサーバを再起動してください。サーバを再起動しないとライセンサで登録したライセンス情報は反映されません。

jp.co.intra_mart.bin.licedit ツールは、ServerManagerの動作している環境で実行して下さい。その他の環境で jp.co.intra_mart.bin.licedit ツールを利用してライセンス登録を行っても、システムに反映されません。

Copyright(C) NTT DATA INTRAMART CO.,LTD. 2000-2008 All Rights Reserved.


intra-mart[Server side JavaScript intra-mart Documentation.]

TOP

intra-mart Version 6.1

MENU
Document

・セットアップ(インストール)
・予約語一覧
・データのインポート／エクスポート

Developer's Guide

ガイドライン-Programing Guide
  ・Application Runtime
  ・Resource Service
  ・Shared Memory Service
  ・Permanent Data Service
  ・Serialization Service
  ・Storage Service
  ・Schedule Service
基本的なツール
  ・JavaScriptコンパイラ
  ・ライセンサ
JavaEE開発モデル
  ・コーディングルール
  ・JavaServerPages(Servlet)について
  ・JavaEEフレームワーク
  ・JavaEEフレームワーク Struts連携
  ・JavaEEフレームワーク Seasar2連携
  ・JavaEEフレームワーク マスカット連携
  ・JMS　(intra-mart WebPlatform(Resin) のみ)

・ユーザ・インタフェース層
    User Interface Layer
    画面共通モジュール１
    画面共通モジュール２
    画面デザイン共通モジュール
    JavaEEフレームワーク
    グラフ描画モジュール
    ワークフローモジュール

・ビジネス・ロジック層
    Business Logic Layer
    アプリケーション共通モジュール
    メール連携モジュール
    アクセスセキュリティモジュール
    外部ソフトウェア接続モジュール
    IM-Curl

・業務基盤ツール
    Business Base Tool
    ワークフローモジュール
    バッチ管理モジュール
    ポータルモジュール

・ERP連携モジュール(intra-mart Enterprise版のみ)
    SAP連携 汎用API
    SAP連携 業務API (ERP 6.0)
    SAP連携 業務API (R/3 Enterprise)

・ユニット
    Unit
    ファイル・アップロード
    ファイル・ダウンロード

    intra-mart 全体のAPIリスト

・アプリケーション共通マスタ
スクリプト開発モデル
  ・コーディングルール
  ・Function Containerについて
  ・Presentation Pageについて

・ユーザ・インタフェース層
    User Interface Layer
      画面共通モジュール
      画面デザイン共通モジュール
      グラフ描画モジュール
      ワークフローモジュール

・ビジネス・ロジック層
    Business Logic Layer
      アプリケーション共通モジュール
      メール連携モジュール
      マスカット連携モジュール
      IM-Curl

・業務基盤ツール
    Business Basic Tool
      ワークフローモジュール
      バッチ管理モジュール
      ポータルモジュール

・ERP連携モジュール(intra-mart Enterprise版のみ)
    SAP連携 汎用API
    SAP連携 業務API (ERP 6.0)
    SAP連携 業務API (R/3 Enterprise)

・ユニット
    Unit
      カレンダー表示モジュール
      ツリー表示モジュール

・アプリケーション共通マスタ

・その他
      JAVAクラスの利用
      外部ライブラリの利用
      拡張 <IMART> タグ
クライアント・サイド API
    クライアント・サイドJavaScript APIリスト
外部ソフトウェア連携ソリューション
      統合検索ソリューション
その他
  ・カスタマイズ
  ・アクセスセキュリティモジュールを利用しないで
画面を構築する方法


MultipartFormDataResourceBundle (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http
クラス MultipartFormDataResourceBundle

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle
public class MultipartFormDataResourceBundle
extends Object

MultipartFormDataの設定情報を扱うクラスです。

設定ファイルは、 %ApplicationRuntime%/doc/imart/WEB-INF/classes/jp/co/intra_mart/common/aid/javaee/http/MultipartFormData.properties です。

設定ファイルの内容は以下の通りです。

キー | 初期値 | 説明
use_commons_fileupload | true | アップロードされたファイルを常にメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用するかを指定します。 trueを指定すると一時ファイルに書き出す実装を、falseを指定すると常にメモリ上で扱う実装を利用します。
size_threshold | 10240 | use_commons_fileupload=true とした場合に、アップロードされたファイルを一時ファイルに 書き出すかどうかを決める閾値です。アップロードされたファイルが指定した値を超えると一時ファイルに 書き出されます。単位はバイトです。
repository | （空） | use_commons_fileupload=true とした場合に、一時ファイルを格納するフォルダを指定します。 空もしくは存在しないフォルダを指定した場合、Javaのテンポラリフォルダ(java.io.tmpdir)を指定した ことになります。

導入されたバージョン:
6.1.11

フィールドの概要
static String | DEFAULT_MULTIPART_PROPERTIES プロパティファイル名
static int | DEFAULT_SIZETHRESHOLD useCommonsFileuploadがtrueの場合、一時ファイルを作成するデフォルトの閾値（単位：バイト）
static String | KEY_REPOSITORY 一時ファイルの保存先 のキー
static String | KEY_SIZE_THRESHOLD 一時ファイルを作成するかどうかの閾値のキー
static String | KEY_USE_COMMONS_FILEUPLOAD CommonsFileUploadを利用するかどうかのキー
コンストラクタの概要
MultipartFormDataResourceBundle()
メソッドの概要
static File | getRepository() useCommonsFileuploadがtrueの場合、一時ファイルを作成するフォルダを取得します。
static int | getSizeThreshold() useCommonsFileuploadがtrueの場合、一時ファイルを作成する閾値を取得します。
static boolean | useCommonsFileupload() アップロードされたファイルをメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用ように設定したかを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_MULTIPART_PROPERTIES

public static final String DEFAULT_MULTIPART_PROPERTIES
プロパティファイル名

関連項目:
定数フィールド値

KEY_USE_COMMONS_FILEUPLOAD

public static final String KEY_USE_COMMONS_FILEUPLOAD
CommonsFileUploadを利用するかどうかのキー

関連項目:
定数フィールド値

KEY_SIZE_THRESHOLD

public static final String KEY_SIZE_THRESHOLD
一時ファイルを作成するかどうかの閾値のキー

関連項目:
定数フィールド値

KEY_REPOSITORY

public static final String KEY_REPOSITORY
一時ファイルの保存先 のキー

関連項目:
定数フィールド値

DEFAULT_SIZETHRESHOLD

public static final int DEFAULT_SIZETHRESHOLD
useCommonsFileuploadがtrueの場合、一時ファイルを作成するデフォルトの閾値（単位：バイト）

関連項目:
定数フィールド値
コンストラクタの詳細

MultipartFormDataResourceBundle

public MultipartFormDataResourceBundle()
メソッドの詳細

useCommonsFileupload

public static boolean useCommonsFileupload()
アップロードされたファイルをメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用ように設定したかを取得します。

戻り値:
trueの場合一時ファイルに書き出す実装を、falseの場合メモリ上で扱う実装を利用します。

getSizeThreshold

public static int getSizeThreshold()
useCommonsFileuploadがtrueの場合、一時ファイルを作成する閾値を取得します。

戻り値:
一時ファイルを作成する閾値（単位：バイト）

getRepository

public static File getRepository()
useCommonsFileuploadがtrueの場合、一時ファイルを作成するフォルダを取得します。 設定ファイルで、空もしくは存在しないフォルダを指定した場合、Javaのテンポラリフォルダ(java.io.tmpdir)を 返します。

戻り値:
一時ファイルの保存先
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の使用

jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IMDiskFileItem (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMDiskFileItem

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem
すべての実装インタフェース:
org.apache.commons.fileupload.FileItem, Serializable
public class IMDiskFileItem
extends Object
implements org.apache.commons.fileupload.FileItem

ヘッダ情報を追加したFileItemの実装クラスです。

導入されたバージョン:
6.1.11
関連項目:
直列化された形式

コンストラクタの概要
IMDiskFileItem(String fieldName, String contentType, boolean isFormField, String fileName, int sizeThreshold, File repository, Map headers)
コンストラクタ
メソッドの概要
void | delete() 一時ファイルを削除します。
byte[] | get() ファイルの内容をバイト配列として取得します。
String | getContentType() コンテントタイプを取得します。
String | getFieldName() フィールド名を取得します。
Map | getHeaders() ヘッダ情報を取得します。
InputStream | getInputStream() 一時ファイルから取得したInputStreamを取得します。
String | getName() ファイル名を取得します。
OutputStream | getOutputStream() ファイルの内容を保存するのに使用できるOutputStreamを取得します。
long | getSize() ファイルサイズを取得します。
String | getString() ファイルの内容をStringとして取得します。
String | getString(String charset) 指定されたエンコードを使用してファイルの内容をStringとして取得します。
boolean | isFormField() 単純なフォームフィールドかどうかを取得します。
boolean | isInMemory() ファイルの内容がメモリから読み込まれるかどうかを取得します。
void | setFieldName(String fieldName) ファイルを参照するためのフィールド名をセットします。
void | setFormField(boolean state) 単純なフォームフィールドかどうかを指定します。
void | write(File file) 指定されたFileにアップロードされたファイルを書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IMDiskFileItem

public IMDiskFileItem(String fieldName,
                      String contentType,
                      boolean isFormField,
                      String fileName,
                      int sizeThreshold,
                      File repository,
                      Map headers)
コンストラクタ

パラメータ:
fieldName - フィールド名
contentType - コンテントタイプ
isFormField - フィールドかどうかのフラグ
fileName - ファイル名
sizeThreshold - 閾値
repository - 一時ファイルの保存先
headers - ヘッダ情報
メソッドの詳細

getHeaders

public Map getHeaders()
ヘッダ情報を取得します。

戻り値:
ヘッダ情報

delete

public void delete()
一時ファイルを削除します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の delete

get

public byte[] get()
ファイルの内容をバイト配列として取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の get

getContentType

public String getContentType()
コンテントタイプを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getContentType

getFieldName

public String getFieldName()
フィールド名を取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getFieldName

getInputStream

public InputStream getInputStream()
                           throws IOException
一時ファイルから取得したInputStreamを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getInputStream
例外:
IOException

getName

public String getName()
ファイル名を取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getName

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
ファイルの内容を保存するのに使用できるOutputStreamを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getOutputStream
例外:
IOException

getSize

public long getSize()
ファイルサイズを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getSize

getString

public String getString()
ファイルの内容をStringとして取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getString

getString

public String getString(String charset)
                 throws UnsupportedEncodingException
指定されたエンコードを使用してファイルの内容をStringとして取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getString
例外:
UnsupportedEncodingException

isFormField

public boolean isFormField()
単純なフォームフィールドかどうかを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の isFormField
戻り値:
単純なフォームフィールドの場合true、アップロードされたファイルの場合false

isInMemory

public boolean isInMemory()
ファイルの内容がメモリから読み込まれるかどうかを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の isInMemory

setFieldName

public void setFieldName(String fieldName)
ファイルを参照するためのフィールド名をセットします。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の setFieldName

setFormField

public void setFormField(boolean state)
単純なフォームフィールドかどうかを指定します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の setFormField

write

public void write(File file)
           throws Exception
指定されたFileにアップロードされたファイルを書き出します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の write
例外:
Exception
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IMDiskFileItemFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMDiskFileItemFactory

java.lang.Object
    拡張 DiskFileItemFactory
        拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory
すべての実装インタフェース:
org.apache.commons.fileupload.FileItemFactory, IMFileItemFactory
public class IMDiskFileItemFactory
extends DiskFileItemFactory
implements IMFileItemFactory

ヘッダ情報を含むFileItemを生成するFactoryです。

導入されたバージョン:
6.1.11
関連項目:
直列化された形式

コンストラクタの概要
IMDiskFileItemFactory()
デフォルトコンストラクタ
IMDiskFileItemFactory(int sizeThreshold, File repository)
コンストラクタ
メソッドの概要
 org.apache.commons.fileupload.FileItem createItem(String fieldName, String contentType, boolean isFormField, String fileName, Map headers)
ヘッダ情報を含むFileItemを生成します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース org.apache.commons.fileupload.FileItemFactory から継承したメソッド
createItem

コンストラクタの詳細

IMDiskFileItemFactory

public IMDiskFileItemFactory()
デフォルトコンストラクタ

IMDiskFileItemFactory

public IMDiskFileItemFactory(int sizeThreshold,
                             File repository)
コンストラクタ

パラメータ:
sizeThreshold - 一時ファイルを作成するかどうかの閾値
repository - 一時ファイルの保存先
メソッドの詳細

createItem

public org.apache.commons.fileupload.FileItem createItem(String fieldName,
                                                         String contentType,
                                                         boolean isFormField,
                                                         String fileName,
                                                         Map headers)
ヘッダ情報を含むFileItemを生成します。

定義:
インタフェース IMFileItemFactory 内の createItem
パラメータ:
fieldName -
contentType -
isFormField -
fileName -
headers -
戻り値:
ヘッダ情報を含むFileItem
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IMFileItemFactory (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
インタフェース IMFileItemFactory

すべてのスーパーインタフェース:
org.apache.commons.fileupload.FileItemFactory
既知の実装クラスの一覧:
IMDiskFileItemFactory
public interface IMFileItemFactory
extends org.apache.commons.fileupload.FileItemFactory

ヘッダ情報を含むFileItemを生成するFactoryです。

導入されたバージョン:
6.1.11

メソッドの概要
 org.apache.commons.fileupload.FileItem createItem(String fieldName, String contentType, boolean isFormField, String fileName, Map headers)
ヘッダ情報を含むFileItemを生成します。
インタフェース org.apache.commons.fileupload.FileItemFactory から継承したメソッド
createItem

メソッドの詳細

createItem

public org.apache.commons.fileupload.FileItem createItem(String fieldName,
                                                         String contentType,
                                                         boolean isFormField,
                                                         String fileName,
                                                         Map headers)
ヘッダ情報を含むFileItemを生成します。

パラメータ:
fieldName -
contentType -
isFormField -
fileName -
headers -
戻り値:
ヘッダ情報を含むFileItem
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IMMultipartStream (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMMultipartStream

java.lang.Object
    拡張 org.apache.commons.fileupload.MultipartStream
        拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream
public class IMMultipartStream
extends org.apache.commons.fileupload.MultipartStream

ヘッダの文字エンコーディングを変換しないMultipartStreamです。

導入されたバージョン:
6.1.14

入れ子クラスの概要
クラス org.apache.commons.fileupload.MultipartStream から継承した入れ子クラス
org.apache.commons.fileupload.MultipartStream.IllegalBoundaryException, org.apache.commons.fileupload.MultipartStream.MalformedStreamException
フィールドの概要
クラス org.apache.commons.fileupload.MultipartStream から継承したフィールド
DEFAULT_BUFSIZE, FIELD_SEPARATOR, HEADER_PART_SIZE_MAX, HEADER_SEPARATOR, STREAM_TERMINATOR
コンストラクタの概要
IMMultipartStream()
デフォルトコンストラクタ
IMMultipartStream(InputStream input, byte[] boundary)
コンストラクタ。
メソッドの概要
 String readHeaders()
リクエストエンコーディングへのエンコーディング変換を行わずにヘッダ部を読み込みます。
クラス org.apache.commons.fileupload.MultipartStream から継承したメソッド
arrayequals, discardBodyData, findByte, findSeparator, getHeaderEncoding, readBodyData, readBoundary, readByte, setBoundary, setHeaderEncoding, skipPreamble, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IMMultipartStream

public IMMultipartStream()
デフォルトコンストラクタ

IMMultipartStream

public IMMultipartStream(InputStream input,
                         byte[] boundary)
                  throws IOException
コンストラクタ。

パラメータ:
input - マルチパートデータが含まれるInputStream
boundary - boundary
例外:
IOException
メソッドの詳細

readHeaders

public String readHeaders()
                   throws org.apache.commons.fileupload.MultipartStream.MalformedStreamException
リクエストエンコーディングへのエンコーディング変換を行わずにヘッダ部を読み込みます。

戻り値:
ヘッダ部
例外:
MalformedStreamException - 予期せずにストリームが終了した場合
org.apache.commons.fileupload.MultipartStream.MalformedStreamException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IMServletFileUpload (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMServletFileUpload

java.lang.Object
    拡張 ServletFileUpload
        拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload
public class IMServletFileUpload
extends ServletFileUpload

ヘッダ情報を扱えるようにしたFileUploadクラスです。

導入されたバージョン:
6.1.11
関連項目:
直列化された形式

コンストラクタの概要
IMServletFileUpload()
デフォルトコンストラクタ
IMServletFileUpload(org.apache.commons.fileupload.FileItemFactory fileItemFactory)
コンストラクタ
メソッドの概要
protected org.apache.commons.fileupload.FileItem | createItem(Map headers, boolean isFormField)
protected String | getFileName(Map arg0) ヘッダのContent-Dispositionに含まれるファイル名を返します。
protected Map | parseHeaders(String headerPart) CommonsFileuploadのFileuploadBaseにヘッダ情報のキーをtoLowerCaseしないヘッダ情報 を追加したメソッドです。
List | parseRequest(RequestContext ctx) CommonsFileuploadのFileuploadBase#parRequestのヘッダをパースするインスタンスを IMMultipartStreamに変更したメソッドです。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IMServletFileUpload

public IMServletFileUpload()
デフォルトコンストラクタ

IMServletFileUpload

public IMServletFileUpload(org.apache.commons.fileupload.FileItemFactory fileItemFactory)
コンストラクタ

パラメータ:
fileItemFactory - ファクトリ
メソッドの詳細

createItem

protected org.apache.commons.fileupload.FileItem createItem(Map headers,
                                                            boolean isFormField)
                                                     throws org.apache.commons.fileupload.FileUploadException
例外:
org.apache.commons.fileupload.FileUploadException

parseRequest

public List parseRequest(RequestContext ctx)
                  throws org.apache.commons.fileupload.FileUploadException
CommonsFileuploadのFileuploadBase#parRequestのヘッダをパースするインスタンスを IMMultipartStreamに変更したメソッドです。 IMMultipartStreamでは、ヘッダをパースする際にエンコード変換を行いません。

例外:
org.apache.commons.fileupload.FileUploadException

parseHeaders

protected Map parseHeaders(String headerPart)
CommonsFileuploadのFileuploadBaseにヘッダ情報のキーをtoLowerCaseしないヘッダ情報 を追加したメソッドです。

getFileName

protected String getFileName(Map arg0)
ヘッダのContent-Dispositionに含まれるファイル名を返します。

Content-Dispositionがヘッダに含まれない場合はnullを返します。 ファイル名は、リクエストのエンコーディングでエンコードした状態で返します。

リクエストのエンコーディングが指定されなかった場合、ISO-8859-1で エンコードした状態で返します。

戻り値:
リクエストのエンコーディングでエンコードされたファイル名。Content-Dispositionがヘッダに含まれない場合はnull。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.javaee.http.fileupload (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.common.aid.javaee.http.fileupload
インタフェース
IMFileItemFactory
クラス
IMDiskFileItem
IMDiskFileItemFactory
IMMultipartStream
IMServletFileUpload


jp.co.intra_mart.common.aid.javaee.http.fileupload (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload

このパッケージには、アップロードされたファイルを扱うクラスが含まれています。

参照:
説明

インタフェースの概要
IMFileItemFactory ヘッダ情報を含むFileItemを生成するFactoryです。

クラスの概要
IMDiskFileItem | ヘッダ情報を追加したFileItemの実装クラスです。
IMDiskFileItemFactory | ヘッダ情報を含むFileItemを生成するFactoryです。
IMMultipartStream | ヘッダの文字エンコーディングを変換しないMultipartStreamです。
IMServletFileUpload | ヘッダ情報を扱えるようにしたFileUploadクラスです。

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload の説明

このパッケージには、アップロードされたファイルを扱うクラスが含まれています。


jp.co.intra_mart.common.aid.javaee.http.fileupload クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class DiskFileItemFactory
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory (implements jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory)
    • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem (implements org.apache.commons.fileupload.FileItem)
    • class org.apache.commons.fileupload.MultipartStream
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream
    • class ServletFileUpload
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload

インタフェース階層

  • interface org.apache.commons.fileupload.FileItemFactory
    • interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory


パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.javaee.http.fileupload の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http | このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload | このパッケージには、アップロードされたファイルを扱うクラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http により使用される jp.co.intra_mart.common.aid.javaee.http.fileupload のクラス
IMFileItemFactory
ヘッダ情報を含むFileItemを生成するFactoryです。

jp.co.intra_mart.common.aid.javaee.http.fileupload により使用される jp.co.intra_mart.common.aid.javaee.http.fileupload のクラス
IMFileItemFactory
ヘッダ情報を含むFileItemを生成するFactoryです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory の使用

IMFileItemFactory を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http | このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload | このパッケージには、アップロードされたファイルを扱うクラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http での IMFileItemFactory の使用

IMFileItemFactory 型のパラメータを持つ jp.co.intra_mart.common.aid.javaee.http のコンストラクタ
MultipartFormData(ServletRequest req, IMFileItemFactory factory)
リクエストされた情報を解析して、新しいオブジェクトを構築します。

jp.co.intra_mart.common.aid.javaee.http.fileupload での IMFileItemFactory の使用

IMFileItemFactory を実装している jp.co.intra_mart.common.aid.javaee.http.fileupload のクラス
 class IMDiskFileItemFactory
ヘッダ情報を含むFileItemを生成するFactoryです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EmptyParameterHttpServletRequestWrapper (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス EmptyParameterHttpServletRequestWrapper

java.lang.Object
    拡張 javax.servlet.ServletRequestWrapper
        拡張 javax.servlet.http.HttpServletRequestWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper
すべての実装インタフェース:
HttpServletRequest, ServletRequest
public class EmptyParameterHttpServletRequestWrapper
extends HttpServletRequestWrapper

エンプティーリクエストパラメータサーブレットリクエストラッパー。

リクエストパラメータを空にするサーブレットリクエストラッパーです。

導入されたバージョン:
6.1.11
バージョン:
1.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletRequest から継承したフィールド
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
コンストラクタの概要
EmptyParameterHttpServletRequestWrapper(HttpServletRequest request)
コンストラクタ。
メソッドの概要
String | getParameter(String name) パラメータの存在有無に関わらず、全てのパラメータの値を null として返します。
Map | getParameterMap() この要求から取得できるパラメータの存在有無に関わらず、 空のjava.util.Map で返します。
Enumeration | getParameterNames() この要求に含まれるパラメータの存在有無に関わらず、空のEnumerationを返します。
String[] | getParameterValues(String name) 指定された要求パラメータの存在有無に関わらずnullを返します。
クラス javax.servlet.http.HttpServletRequestWrapper から継承したメソッド
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
クラス javax.servlet.ServletRequestWrapper から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding, setRequest
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.ServletRequest から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

コンストラクタの詳細

EmptyParameterHttpServletRequestWrapper

public EmptyParameterHttpServletRequestWrapper(HttpServletRequest request)
コンストラクタ。

パラメータ:
request - サーブレットリクエスト
メソッドの詳細

getParameterMap

public Map getParameterMap()
この要求から取得できるパラメータの存在有無に関わらず、 空のjava.util.Map で返します。

戻り値:
空の java.util.Map。

getParameter

public String getParameter(String name)
パラメータの存在有無に関わらず、全てのパラメータの値を null として返します。

パラメータ:
name - パラメータの名前を指定する String
戻り値:
null

getParameterValues

public String[] getParameterValues(String name)
指定された要求パラメータの存在有無に関わらずnullを返します。

パラメータ:
name - パラメータの名前を指定する String
戻り値:
null

getParameterNames

public Enumeration getParameterNames()
この要求に含まれるパラメータの存在有無に関わらず、空のEnumerationを返します。

戻り値:
空の Enumeration。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DBResultAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DBResultAdapter

既知の実装クラスの一覧:
DBResultArrayAdapter, DBResultBigDecimalAdapter, DBResultBigIntAdapter, DBResultBinaryAdapter, DBResultBlobAdapter, DBResultBooleanAdapter, DBResultByteAdapter, DBResultClobAdapter, DBResultDateAdapter, DBResultDoubleAdapter, DBResultImTimestampAdapter, DBResultIntegerAdapter, DBResultNullAdapter, DBResultObjectAdapter, DBResultRealAdapter, DBResultRefAdapter, DBResultShortAdapter, DBResultStringAdapter, DBResultStructAdapter, DBResultTimeAdapter, DBResultTimestampAdapter
public interface DBResultAdapter

スクリプト開発用データベースカラム取得アダプタインタフェース。

スクリプト開発においてDBからカラム値を取得する場合に、
Java型からJavaScriptへ変換を行うアダプターインタフェースです。 サーバーマネージャインストールディレクトリ/conf/database-adapter-config.xml
に、各データベース型(Java.sql.Types.*)別にこのインタフェースを実装して設定します。

<database-adapter>のtype属性には、各データベース型
<database-adapter>のadapter-class属性には、このインタフェースを実装して設定します。

導入されたバージョン:
7.0
バージョン:
1.0

メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。

メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultArrayAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultArrayAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultArrayAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultArrayAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースARRAY型カラム取得アダプタ。

データベースARRAY型の値を取得するアダプタです。
getArray()を利用して、Objectの配列として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultArrayAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultArrayAdapter

public DBResultArrayAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBigDecimalAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBigDecimalAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBigDecimalAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。

データベースDECIMAL,NUMERIC型の値を取得するアダプタです。
getBigDecimal()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBigDecimalAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBigDecimalAdapter

public DBResultBigDecimalAdapter()
メソッドの詳細

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBigIntAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBigIntAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBigIntAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBigIntAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBIGINT型カラム取得アダプタ。

データベースBIGINT型の値を取得するアダプタです。
getLong()を利用して、 Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBigIntAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBigIntAdapter

public DBResultBigIntAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBinaryAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBinaryAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBinaryAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBinaryAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。

データベースBINARY,LONGVARBINARY,VARBINARY型の値を取得するアダプタです。
getBytes()を利用して、エンコードしないString型として取得します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBinaryAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBinaryAdapter

public DBResultBinaryAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBlobAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBlobAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBlobAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBlobAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBLOB型カラム取得アダプタ。

データベースBLOB型の値を取得するアダプタです。
getBlob()を利用して、String型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBlobAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBlobAdapter

public DBResultBlobAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBooleanAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBooleanAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBooleanAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBooleanAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。

データベースBOOLEAN,BIT型の値を取得するアダプタです。
getBoolean()を利用して、Boolean型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBooleanAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBooleanAdapter

public DBResultBooleanAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultByteAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultByteAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultByteAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultByteAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBYTE型カラム取得アダプタ。

データベースBYTE型の値を取得するアダプタです。
getByte()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultByteAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultByteAdapter

public DBResultByteAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultClobAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultClobAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultClobAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultClobAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースCLOB型カラム取得アダプタ。

データベースCLOB型の値を取得するアダプタです。
getClob()を利用して、String型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultClobAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultClobAdapter

public DBResultClobAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultDateAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultDateAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultDateAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultDateAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースDATE型カラム取得アダプタ。

データベースDATE型の値を取得するアダプタです。
getDate()を利用して、Date型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultDateAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultDateAdapter

public DBResultDateAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultDoubleAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultDoubleAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultDoubleAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultDoubleAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。

データベースDOUBLE,FLOAT型の値を取得するアダプタです。
getDouble()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultDoubleAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultDoubleAdapter

public DBResultDoubleAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultImTimestampAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultImTimestampAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultImTimestampAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。

データベースTIMESTAMP型カラムを取得アダプタですが、
サーバマネージャ/conf/mart.xmlの設定により、取得方法か変更できるアダプタです。

imart.xmlのintra-mart/platform/service/application/database/data/timestamp-is-dateの値が
trueの場合は、getTimestamp()を利用して、Date型として値を返します。
falseの場合は、getString()を利用して、文字列型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultImTimestampAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultImTimestampAdapter

public DBResultImTimestampAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultIntegerAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultIntegerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultIntegerAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultIntegerAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースINTEGER型カラム取得アダプタ。

データベースINTEGER型の値を取得するアダプタです。
getInt()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultIntegerAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultIntegerAdapter

public DBResultIntegerAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultNullAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultNullAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultNullAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultNullAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースNULL型カラム取得アダプタ。

データベースNULL型の値を取得するアダプタです。
常にNULLを返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultNullAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultNullAdapter

public DBResultNullAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultObjectAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultObjectAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultObjectAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultObjectAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースカラムをObject型として取得するアダプタ。

データベースのカラム値をObject型として取得するアダプタです。
getObject()を利用してObject型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultObjectAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultObjectAdapter

public DBResultObjectAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultRealAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultRealAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultRealAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultRealAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースREAL型カラム取得アダプタ。

データベースREAL型の値を取得するアダプタです。
getFloat()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultRealAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultRealAdapter

public DBResultRealAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultRefAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultRefAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultRefAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultRefAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースREF型カラム取得アダプタ。

データベースREF型の値を取得するアダプタです。
getRef()を利用して、Refの参照をObject型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultRefAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultRefAdapter

public DBResultRefAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultShortAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultShortAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultShortAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultShortAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースSMALLINT型カラム取得アダプタ。

データベースSMALLINT型の値を取得するアダプタです。
getShort()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultShortAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultShortAdapter

public DBResultShortAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultStringAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultStringAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultStringAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultStringAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースカラムを文字列型として取得するアダプタ。

データベースのカラムを文字列型として値を取得するアダプタです。
getString() を利用して、文字列型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultStringAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultStringAdapter

public DBResultStringAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultStructAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultStructAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultStructAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultStructAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースSTRUCT型カラム取得アダプタ。

データベースSTRUCT型の値を取得するアダプタです。
getStruct()を利用して、属性(java.sql.Struct.getAttributes())のObject配列として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultStructAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultStructAdapter

public DBResultStructAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultTimeAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultTimeAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultTimeAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultTimeAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースTIME型カラム取得アダプタ。

データベースTIME型の値を取得するアダプタです。
getTime()を利用して、Date型として値を返却します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultTimeAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultTimeAdapter

public DBResultTimeAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultTimestampAdapter (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultTimestampAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultTimestampAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultTimestampAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。

データベースTIMESTAMP型の値を取得するアダプターです。
getTimeStamp()を利用して、Date型として返却します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultTimestampAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultTimestampAdapter

public DBResultTimestampAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbTypes (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DbTypes

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DbTypes
public class DbTypes
extends Object

フィールドの概要
static DbTypes | DB2
static DbTypes | MYSQL
static DbTypes | ORACLE
static DbTypes | OTHER
static DbTypes | POSTGRESQL
static DbTypes | SQLSERVER
メソッドの概要
static DbTypes | getDbType(String name)
String | getName()
static DbTypes | matchDbType(String str)
static Collection | values()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ORACLE

public static DbTypes ORACLE

DB2

public static DbTypes DB2

POSTGRESQL

public static DbTypes POSTGRESQL

SQLSERVER

public static DbTypes SQLSERVER

MYSQL

public static DbTypes MYSQL

OTHER

public static DbTypes OTHER
メソッドの詳細

values

public static Collection values()

getDbType

public static DbTypes getDbType(String name)

matchDbType

public static DbTypes matchDbType(String str)

getName

public String getName()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.database.DBResultAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DBResultAdapter の使用

DBResultAdapter を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DBResultAdapter の使用

DBResultAdapter を実装している jp.co.intra_mart.foundation.database のクラス
class | DBResultArrayAdapter スクリプト開発用データベースARRAY型カラム取得アダプタ。
class | DBResultBigDecimalAdapter スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。
class | DBResultBigIntAdapter スクリプト開発用データベースBIGINT型カラム取得アダプタ。
class | DBResultBinaryAdapter スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。
class | DBResultBlobAdapter スクリプト開発用データベースBLOB型カラム取得アダプタ。
class | DBResultBooleanAdapter スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。
class | DBResultByteAdapter スクリプト開発用データベースBYTE型カラム取得アダプタ。
class | DBResultClobAdapter スクリプト開発用データベースCLOB型カラム取得アダプタ。
class | DBResultDateAdapter スクリプト開発用データベースDATE型カラム取得アダプタ。
class | DBResultDoubleAdapter スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。
class | DBResultImTimestampAdapter スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。
class | DBResultIntegerAdapter スクリプト開発用データベースINTEGER型カラム取得アダプタ。
class | DBResultNullAdapter スクリプト開発用データベースNULL型カラム取得アダプタ。
class | DBResultObjectAdapter スクリプト開発用データベースカラムをObject型として取得するアダプタ。
class | DBResultRealAdapter スクリプト開発用データベースREAL型カラム取得アダプタ。
class | DBResultRefAdapter スクリプト開発用データベースREF型カラム取得アダプタ。
class | DBResultShortAdapter スクリプト開発用データベースSMALLINT型カラム取得アダプタ。
class | DBResultStringAdapter スクリプト開発用データベースカラムを文字列型として取得するアダプタ。
class | DBResultStructAdapter スクリプト開発用データベースSTRUCT型カラム取得アダプタ。
class | DBResultTimeAdapter スクリプト開発用データベースTIME型カラム取得アダプタ。
class | DBResultTimestampAdapter スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultArrayAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultArrayAdapter の使用

jp.co.intra_mart.foundation.database.DBResultArrayAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBigIntAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBigIntAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBigIntAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBinaryAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBinaryAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBinaryAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBlobAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBlobAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBlobAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBooleanAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBooleanAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBooleanAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultByteAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultByteAdapter の使用

jp.co.intra_mart.foundation.database.DBResultByteAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultClobAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultClobAdapter の使用

jp.co.intra_mart.foundation.database.DBResultClobAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultDateAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultDateAdapter の使用

jp.co.intra_mart.foundation.database.DBResultDateAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultDoubleAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultDoubleAdapter の使用

jp.co.intra_mart.foundation.database.DBResultDoubleAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter の使用

jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultIntegerAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultIntegerAdapter の使用

jp.co.intra_mart.foundation.database.DBResultIntegerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultNullAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultNullAdapter の使用

jp.co.intra_mart.foundation.database.DBResultNullAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultObjectAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultObjectAdapter の使用

jp.co.intra_mart.foundation.database.DBResultObjectAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultRealAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultRealAdapter の使用

jp.co.intra_mart.foundation.database.DBResultRealAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultRefAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultRefAdapter の使用

jp.co.intra_mart.foundation.database.DBResultRefAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultShortAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultShortAdapter の使用

jp.co.intra_mart.foundation.database.DBResultShortAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultStringAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultStringAdapter の使用

jp.co.intra_mart.foundation.database.DBResultStringAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultStructAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultStructAdapter の使用

jp.co.intra_mart.foundation.database.DBResultStructAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultTimeAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultTimeAdapter の使用

jp.co.intra_mart.foundation.database.DBResultTimeAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultTimestampAdapter の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultTimestampAdapter の使用

jp.co.intra_mart.foundation.database.DBResultTimestampAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DbTypes の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DbTypes の使用

DbTypes を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DbTypes の使用

DbTypes として宣言されている jp.co.intra_mart.foundation.database のフィールド
static DbTypes | DbTypes.ORACLE
static DbTypes | DbTypes.DB2
static DbTypes | DbTypes.POSTGRESQL
static DbTypes | DbTypes.SQLSERVER
static DbTypes | DbTypes.MYSQL
static DbTypes | DbTypes.OTHER

DbTypes を返す jp.co.intra_mart.foundation.database のメソッド
static DbTypes | DbTypes.getDbType(String name)
static DbTypes | DbTypes.matchDbType(String str)
DbTypes | DatabaseManager.getSystemDatabaseType(String connectId) システムデータソースにおけるデータベースの種類を取得する。
DbTypes | DatabaseManager.getGroupDatabaseType(String groupId) ログイングループデータソースおけるデータベースの種類を取得する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HalfKanaTransrateListener (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener.impl
クラス HalfKanaTransrateListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener
すべての実装インタフェース:
MailSendListener
public class HalfKanaTransrateListener
extends Object
implements MailSendListener

送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。 変換処理はHalfKanaTransratorに依存します。

導入されたバージョン:
7.2
関連項目:
HalfKanaTransrator

フィールドの概要
インタフェース jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener から継承したフィールド
CONTINUE, SKIP_LISTENER, STOP_MAILSEND
コンストラクタの概要
HalfKanaTransrateListener()
HalfKanaTransrateListenerを新規に生成します。
メソッドの概要
int | onSendMail(MailSendEvent event) メール送信が行われたことを通知します。
protected String | transliterate(String str) 指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HalfKanaTransrateListener

public HalfKanaTransrateListener()
HalfKanaTransrateListenerを新規に生成します。

メソッドの詳細

onSendMail

public int onSendMail(MailSendEvent event)
               throws MailSenderException
メール送信が行われたことを通知します。

メール送信イベントを受け取り、送信メールの件名と本文に含まれる半角カナ文字を、 全角カナ文字に変換します。
このメソッドは必ずMailSendListener.CONTINUEを返します。

定義:
インタフェース MailSendListener 内の onSendMail
パラメータ:
event - メール送信イベント
例外:
MailSenderException - リスナーで例外が発生

transliterate

protected String transliterate(String str)
指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。

パラメータ:
str - 文字列
戻り値:
変換された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.listener.impl (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.listener.impl
クラス
HalfKanaTransrateListener


jp.co.intra_mart.foundation.mail.javamail.listener.impl (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl

クラスの概要
HalfKanaTransrateListener 送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。


jp.co.intra_mart.foundation.mail.javamail.listener.impl クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener (implements jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener)


パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.listener.impl の使用

jp.co.intra_mart.foundation.mail.javamail.listener.impl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener の使用

jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EnCodeInterface (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.common.encode
インタフェース EnCodeInterface

public interface EnCodeInterface

簡易SSOのパスワードを暗号化するインタフェース。

簡易SSO設定のパスワードをDBに保存する際の暗号化処理クラスです。 デフォルトで提供されるクラスでは16進文字列への変換を行っています。

ユーザは簡易SSO用のパスワードの暗号化処理を独自に実装したい場合、 このインタフェースを実装したクラスを生成し、PortalCommonConfig.propertiesにクラス名を設定します。

設定ファイル
<% Application Runtime Root %>/doc/imart/WEB-INF/classes/PortalCommonConfig.properties
プロパティ名
EncodeInterface

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | decode(String string) 復号化を行います。
String | encode(String string) 暗号化を行います。

メソッドの詳細

encode

public String encode(String string)
暗号化を行います。

パラメータ:
string - 暗号化対象文字列
戻り値:
暗号化後の文字列

decode

public String decode(String string)
復号化を行います。

パラメータ:
string - 復号化対象文字列
戻り値:
復号化後の文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.common.encode (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.common.encode
インタフェース
EnCodeInterface


jp.co.intra_mart.foundation.portal.common.encode (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.encode

インタフェースの概要
EnCodeInterface 簡易SSOのパスワードを暗号化するインタフェース。


jp.co.intra_mart.foundation.portal.common.encode クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.encode の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface


パッケージ jp.co.intra_mart.foundation.portal.common.encode の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.common.encode の使用

jp.co.intra_mart.foundation.portal.common.encode はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface の使用

jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.portal.common.rss (javadoc_entire 6.1.14 API)

 jp.co.intra_mart.foundation.portal.common.rss
インタフェース
RSSParserIF


jp.co.intra_mart.foundation.portal.common.rss (javadoc_entire 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.rss

インタフェースの概要
RSSParserIF RSS解析用の共通インタフェース
RSSポートレットで、取得したRSSデータを処理するためのパーサーです。


jp.co.intra_mart.foundation.portal.common.rss クラス階層 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.rss の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF


パッケージ jp.co.intra_mart.foundation.portal.common.rss の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.common.rss の使用

jp.co.intra_mart.foundation.portal.common.rss はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RSSParserIF (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.common.rss
インタフェース RSSParserIF

public interface RSSParserIF

RSS解析用の共通インタフェース

RSSポートレットで、取得したRSSデータを処理するためのパーサーです。

IWPでは設定ファイルで指定されたXSLスタイルシートを利用して変換するためのパーサーである、

  • jp.co.intra_mart.foundation.portal.common.rss. RSSParserImplクラス
が提供されます。

ユーザは独自のRSS解析クラスを実装したい場合、 このインタフェースを実装したクラスを作成し、rss.xmlにクラス名設定します。

設定ファイル
<% Storage Root %>/portal/rss.xml
設定パス
parser/class

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getHTML() 解析結果HTMLを返却します
void | setProxyHost(String proxyHost) Proxyホスト名をセットします
void | setProxyPort(String proxyPort) Proxyポート番号をセットします
void | setURL(String url) RSSのURLをセットします
void | setXSLT(String xsltPath) RSSのXMLをフォーマットするXSLスタイルシートのファイルパスをセットします

メソッドの詳細

setURL

public void setURL(String url)
RSSのURLをセットします

パラメータ:
url - RSSのURL

setProxyHost

public void setProxyHost(String proxyHost)
Proxyホスト名をセットします

パラメータ:
proxyHost - Proxyホスト名
導入されたバージョン:
6.0

setProxyPort

public void setProxyPort(String proxyPort)
Proxyポート番号をセットします

パラメータ:
proxyPort - Proxyポート番号
導入されたバージョン:
6.0

setXSLT

public void setXSLT(String xsltPath)
RSSのXMLをフォーマットするXSLスタイルシートのファイルパスをセットします

パラメータ:
xsltPath - RSSのXMLをフォーマットするXSLスタイルシートのファイルパス

getHTML

public String getHTML()
               throws MalformedURLException,
                      IOException,
                      TransformerConfigurationException,
                      TransformerException
解析結果HTMLを返却します

戻り値:
解析結果HTML
例外:
TransformerException
TransformerConfigurationException
IOException
MalformedURLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF の使用

jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MobileEasyLoginUtil (javadoc_entire 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginUtil

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
public class MobileEasyLoginUtil
extends Object

かんたんログイン機能のユーティリティクラスです。

iWP/iAF ver6.1 patch11より、かんたんログイン機能のセキュリティが強化されました。
モバイル端末個体識別番号での認証に加え、かんたんログイン用ログインページのURLに自動的に付加したアクセスキーと
iWP/iAFで保持しているアクセスキーでの認証機能が追加されました。

この認証機能により、モバイルパスワードを変更することで、アクセスキーが変更され、
以前アクセスしていた古いアクセスキー付き URLでは、ログインできないようになります。

定期的にモバイルパスワードを変更されない場合は、携帯電話に保存した URLから、
かんたんログインが可能ですので、かんたんログイン用ログインページのURLを他人に知られないようご注意ください。

なお、かんたんログイン機能をご利用の場合は、
Web サーバーで、携帯電話からしかアクセスできないよう IPアドレス制限を実施していただく事をおすすめいたします。

Webサーバーで、IPアドレス制限をかける場合は、各携帯電話会社のホームページなどをご確認いただき、
各携帯電話会社のサーバーの IPアドレス帯域からのアクセスのみ許可する設定をお願いいたします。

注意点

かんたんログイン機能を利用する場合は、NonceResetListener4MobileEasyLoginクラスを、 ${ServerManagerルート}/conf/access-security.xmlに設定する必要があります。
NonceResetListener4MobileEasyLogin の設定は、かんたんログインのセキュリティを向上させる為に必要です。
設定方法は、NonceResetListener4MobileEasyLoginのAPIリストを参照してください。

なお、設定されていない場合は、かんたんログイン用のアクセスキー取得時に、 AccessSecurityConfigExceptionがスローされて、かんたんログイン機能を利用する事ができません。

導入されたバージョン:
6.1.11
関連項目:
NonceResetListener4MobileEasyLogin

フィールドの概要
static String REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY
かんたんログインのアクセスキー用リクエストパラメータ名。
コンストラクタの概要
MobileEasyLoginUtil()
メソッドの概要
static String | getAccessKey(String groupId, String userId) かんたんログイン用のアクセスキーを取得します。
static String | getAccessKeyWithRequestParameter(String groupId, String userId) かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
static String | getMobileEasyLoginURL(HttpServletRequest request, String groupId, String userId) かんたんログイン用のURLを取得します。
static String | getMobileEasyLoginURL(String groupId, String userId) かんたんログイン用のURLを取得します。
static void | reGenerateNonce(String groupId, String userId) かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY

public static final String REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY
かんたんログインのアクセスキー用リクエストパラメータ名。

関連項目:
定数フィールド値
コンストラクタの詳細

MobileEasyLoginUtil

public MobileEasyLoginUtil()
メソッドの詳細

getMobileEasyLoginURL

public static String getMobileEasyLoginURL(String groupId,
                                           String userId)
                                    throws AccessSecurityConfigException,
                                           AccessSecurityException,
                                           IllegalStateException,
                                           IOException
かんたんログイン用のURLを取得します。
本メソッドの実行結果は、
HTTPContextManager.getCurrentContext()で取得したHttpServletRequest利用して、 getMobileEasyLoginURL(HttpServletRequest, String, String)を実行した結果と同じです。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のURL
例外:
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
IOException - Base64エンコーディングに失敗した場合

getMobileEasyLoginURL

public static String getMobileEasyLoginURL(HttpServletRequest request,
                                           String groupId,
                                           String userId)
                                    throws AccessSecurityException,
                                           AccessSecurityConfigException,
                                           IllegalStateException,
                                           IOException
かんたんログイン用のURLを取得します。
かんたんログイン用のURLは以下の形式です。
${WebサーバのURL} + ${コンテキストパス} + "/" + ${ログイングループID} + ${モバイル用の拡張子} + "?" + ${アクセスキー}
項目 | 説明
${WebサーバのURL} ${ServerManagerルート}/conf/parameter.xml の パラメータ名「im.web_server.url」の値です。 （設定例はこちら）
上記パラメータが未設定の場合は、引数「request」の ServletRequest.getScheme()、 ServletRequest.getServerName()、 ServletRequest.getServerPort()を利用してURLを生成します。
${コンテキストパス} | 引数「request」の HttpServletRequest.getContextPath()の値。
${ログイングループID} | 引数「groupId」の値。
${モバイル用の拡張子} Javaのシステムプロパティ「jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil.mobileExtention」の値。
（デフォルト値は「.mobile」です）
${アクセスキー} | getAccessKeyWithRequestParameter(String, String)の値。

parameter.xml の 設定例
<?xml version="1.0" encoding="UTF-8"?>
<system-param>
   .
   .
   .
  <param>
    <param-name>im.web_server.url</param-name>
    <param-name>https://hostname:port</param-name>
  </param>
   .
   .
   .

パラメータ:
request - リクエスト
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のURL
例外:
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
IOException - Base64エンコーディングに失敗した場合

getAccessKeyWithRequestParameter

public static String getAccessKeyWithRequestParameter(String groupId,
                                                      String userId)
                                               throws IllegalStateException,
                                                      AccessSecurityException,
                                                      IOException,
                                                      AccessSecurityConfigException
かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
本メソッドは、以下と同意です。
     REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY + "=" + getAccessKey(String, String)

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のアクセスキー(リクエストパラメータの形式)
例外:
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
IOException - Base64エンコーディングに失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合

getAccessKey

public static String getAccessKey(String groupId,
                                  String userId)
                           throws IllegalStateException,
                                  AccessSecurityException,
                                  IOException,
                                  AccessSecurityConfigException
かんたんログイン用のアクセスキーを取得します。
かんたんログイン用のアクセスキーは、 「Nonce」 「モバイルパスワード」 および 「モバイル端末個体識別番号」を文字列連結し、 SHA1アルゴリズムでダイジェスト化して生成された文字列を、Base64エンコード後、英数字のみにした文字列です。
 かんたんログイン用アクセスキー = (Base64 ( SHA-1 ( Nonce + モバイルパスワード + モバイル端末個体識別番号 ) ) ).replaceAll("[^\p{Alnum}]", "")
Nonceとは、暗号的にランダムな値をBase64エンコードした文字列で、 モバイルパスワードが更新された際に、再設定され、アカウント属性情報として保存されます。
（参照：NonceResetListener4MobileEasyLogin, reGenerateNonce(String, String)）

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のアクセスキー(リクエストパラメータの形式)
例外:
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
IOException - Base64エンコーディングに失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合
関連項目:
NonceResetListener4MobileEasyLogin, reGenerateNonce(String, String)

reGenerateNonce

public static void reGenerateNonce(String groupId,
                                   String userId)
                            throws AccessSecurityException
かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。（保存時に、暗号化が行われます）
属性名は、AccountManager.ATTR_MOBILE_EASY_LOGIN_NONCE です。
暗号化アルゴリズムカテゴリは、AccountManager.CRYPTION_CATEGORY_MOBILE_USER_AGENT です。

パラメータ:
groupId - ログイングループID
userId - ユーザID
例外:
AccessSecurityException - Nonceの保存に失敗した場合
関連項目:
AccountManager.ATTR_MOBILE_EASY_LOGIN_NONCE, AccountManager.CRYPTION_CATEGORY_MOBILE_USER_AGENT
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NonceResetListener4MobileEasyLogin (javadoc_entire 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス NonceResetListener4MobileEasyLogin

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin
すべての実装インタフェース:
AccountPostWriterListener, AccountQueryWriterListener
public class NonceResetListener4MobileEasyLogin
extends Object
implements AccountQueryWriterListener, AccountPostWriterListener

かんたんログイン用のNonceを再設定する為のリスナーです。

このリスナーは、かんたんログインの設定が行われている状態で、モバイルパスワードが更新されたことを検知し、
MobileEasyLoginUtil.reGenerateNonce(String, String)を利用して、Nonceの再設定を行います。

Nonceは、かんたんログイン用のアクセスキーの生成に必要です。
（かんたんログイン用のアクセスキーについては、MobileEasyLoginUtil.getAccessKey(String, String)を参照してください）

本クラスを、${ServerManagerルート}/conf/access-security.xmlの以下のタグに設定してください。
（設定しない場合、かんたんログイン機能を利用する事は出来ません）

  • access-security/access-config/account/query-writer-listener/writer-listener-class
  • access-security/access-config/account/post-writer-listener/writer-listener-class
access-security.xml の 設定例
<?xml version="1.0" encoding="UTF-8"?>
<access-security>
   .
   .
  <access-config>
     .
     .
    <account>
      <accessor>
        <accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<!--
        <init-param>
          <param-name>cryption-class</param-name>
          <param-value>jp.co.intra_mart.foundation.security.cryption.NoCryption</param-value>
        </init-param>
-->
      </accessor>
       .
       .

      <query-writer-listener>
        <writer-listener-class>jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin</writer-listener-class>
      </query-writer-listener>
      <post-writer-listener>
        <writer-listener-class>jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin</writer-listener-class>
      </post-writer-listener>

    </account>

導入されたバージョン:
6.1.11
関連項目:
MobileEasyLoginUtil

コンストラクタの概要
NonceResetListener4MobileEasyLogin()
メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。
void | queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NonceResetListener4MobileEasyLogin

public NonceResetListener4MobileEasyLogin()
メソッドの詳細

queryUpdateAccount

public void queryUpdateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウント情報をデータストアに更新する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryUpdateAccount
パラメータ:
groupId - ログイングループID
account - 更新されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccount

public void postUpdateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウント情報をデータストアに更新した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postUpdateAccount
パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

init

public void init(Map params)
インタフェース AccountQueryWriterListener の記述:
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース AccountQueryWriterListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateAccount

public void queryCreateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウント情報をデータストアに作成する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryCreateAccount
パラメータ:
groupId - ログイングループID
account - 作成されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateAccountRole

public void queryCreateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウントロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryCreateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateFavoriteMenu

public void queryCreateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
マイメニュー情報をデータストアに作成する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryCreateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccount

public void queryDeleteAccount(String groupId,
                               String userId)
                        throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウント情報をデータストアから削除する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryDeleteAccount
パラメータ:
groupId - ログイングループID
userId - 削除されるユーザコード
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccountRole

public void queryDeleteAccountRole(String groupId,
                                   String userId,
                                   String roleId)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウントロール情報をデータストアから削除する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryDeleteAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteFavoriteMenu

public void queryDeleteFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
マイメニュー情報をデータストアから削除する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryDeleteFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されるマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccountRole

public void queryUpdateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウントロール情報をデータストアに更新する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryUpdateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateFavoriteMenu

public void queryUpdateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
マイメニュー情報をデータストアに更新する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryUpdateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccount

public void postCreateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウント情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postCreateAccount
パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccountRole

public void postCreateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウントロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postCreateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateFavoriteMenu

public void postCreateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
マイメニュー情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postCreateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccount

public void postDeleteAccount(String groupId,
                              String userId)
                       throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウント情報をデータストアから削除した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postDeleteAccount
パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccountRole

public void postDeleteAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウントロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postDeleteAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteFavoriteMenu

public void postDeleteFavoriteMenu(String groupId,
                                   String userId,
                                   String menuId)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
マイメニュー情報をデータストアから削除した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postDeleteFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されたマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccountRole

public void postUpdateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウントロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postUpdateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateFavoriteMenu

public void postUpdateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
マイメニュー情報をデータストアに更新した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postUpdateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin の使用 (javadoc_entire 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin の使用

jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


DBResultAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
インタフェース DBResultAdapter

既知の実装クラスの一覧:
DBResultArrayAdapter, DBResultBigDecimalAdapter, DBResultBigIntAdapter, DBResultBinaryAdapter, DBResultBlobAdapter, DBResultBooleanAdapter, DBResultByteAdapter, DBResultClobAdapter, DBResultDateAdapter, DBResultDoubleAdapter, DBResultImTimestampAdapter, DBResultIntegerAdapter, DBResultNullAdapter, DBResultObjectAdapter, DBResultRealAdapter, DBResultRefAdapter, DBResultShortAdapter, DBResultStringAdapter, DBResultStructAdapter, DBResultTimeAdapter, DBResultTimestampAdapter
public interface DBResultAdapter

スクリプト開発用データベースカラム取得アダプタインタフェース。

スクリプト開発においてDBからカラム値を取得する場合に、
Java型からJavaScriptへ変換を行うアダプターインタフェースです。 サーバーマネージャインストールディレクトリ/conf/database-adapter-config.xml
に、各データベース型(Java.sql.Types.*)別にこのインタフェースを実装して設定します。

<database-adapter>のtype属性には、各データベース型
<database-adapter>のadapter-class属性には、このインタフェースを実装して設定します。

導入されたバージョン:
7.0
バージョン:
1.0

メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。

メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultArrayAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultArrayAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultArrayAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultArrayAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースARRAY型カラム取得アダプタ。

データベースARRAY型の値を取得するアダプタです。
getArray()を利用して、Objectの配列として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultArrayAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultArrayAdapter

public DBResultArrayAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBigDecimalAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBigDecimalAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBigDecimalAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。

データベースDECIMAL,NUMERIC型の値を取得するアダプタです。
getBigDecimal()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBigDecimalAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBigDecimalAdapter

public DBResultBigDecimalAdapter()
メソッドの詳細

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBigIntAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBigIntAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBigIntAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBigIntAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBIGINT型カラム取得アダプタ。

データベースBIGINT型の値を取得するアダプタです。
getLong()を利用して、 Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBigIntAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBigIntAdapter

public DBResultBigIntAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBinaryAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBinaryAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBinaryAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBinaryAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。

データベースBINARY,LONGVARBINARY,VARBINARY型の値を取得するアダプタです。
getBytes()を利用して、エンコードしないString型として取得します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBinaryAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBinaryAdapter

public DBResultBinaryAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBlobAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBlobAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBlobAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBlobAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBLOB型カラム取得アダプタ。

データベースBLOB型の値を取得するアダプタです。
getBlob()を利用して、String型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBlobAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBlobAdapter

public DBResultBlobAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultBooleanAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultBooleanAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultBooleanAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultBooleanAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。

データベースBOOLEAN,BIT型の値を取得するアダプタです。
getBoolean()を利用して、Boolean型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultBooleanAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultBooleanAdapter

public DBResultBooleanAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultByteAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultByteAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultByteAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultByteAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースBYTE型カラム取得アダプタ。

データベースBYTE型の値を取得するアダプタです。
getByte()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultByteAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultByteAdapter

public DBResultByteAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultClobAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultClobAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultClobAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultClobAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースCLOB型カラム取得アダプタ。

データベースCLOB型の値を取得するアダプタです。
getClob()を利用して、String型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultClobAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultClobAdapter

public DBResultClobAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultDateAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultDateAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultDateAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultDateAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースDATE型カラム取得アダプタ。

データベースDATE型の値を取得するアダプタです。
getDate()を利用して、Date型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultDateAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultDateAdapter

public DBResultDateAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultDoubleAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultDoubleAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultDoubleAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultDoubleAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。

データベースDOUBLE,FLOAT型の値を取得するアダプタです。
getDouble()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultDoubleAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultDoubleAdapter

public DBResultDoubleAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultImTimestampAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultImTimestampAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultImTimestampAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。

データベースTIMESTAMP型カラムを取得アダプタですが、
サーバマネージャ/conf/mart.xmlの設定により、取得方法か変更できるアダプタです。

imart.xmlのintra-mart/platform/service/application/database/data/timestamp-is-dateの値が
trueの場合は、getTimestamp()を利用して、Date型として値を返します。
falseの場合は、getString()を利用して、文字列型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultImTimestampAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultImTimestampAdapter

public DBResultImTimestampAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultIntegerAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultIntegerAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultIntegerAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultIntegerAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースINTEGER型カラム取得アダプタ。

データベースINTEGER型の値を取得するアダプタです。
getInt()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultIntegerAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultIntegerAdapter

public DBResultIntegerAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultNullAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultNullAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultNullAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultNullAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースNULL型カラム取得アダプタ。

データベースNULL型の値を取得するアダプタです。
常にNULLを返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultNullAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultNullAdapter

public DBResultNullAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultObjectAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultObjectAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultObjectAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultObjectAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースカラムをObject型として取得するアダプタ。

データベースのカラム値をObject型として取得するアダプタです。
getObject()を利用してObject型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultObjectAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultObjectAdapter

public DBResultObjectAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultRealAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultRealAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultRealAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultRealAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースREAL型カラム取得アダプタ。

データベースREAL型の値を取得するアダプタです。
getFloat()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultRealAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultRealAdapter

public DBResultRealAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultRefAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultRefAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultRefAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultRefAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースREF型カラム取得アダプタ。

データベースREF型の値を取得するアダプタです。
getRef()を利用して、Refの参照をObject型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultRefAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultRefAdapter

public DBResultRefAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultShortAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultShortAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultShortAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultShortAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースSMALLINT型カラム取得アダプタ。

データベースSMALLINT型の値を取得するアダプタです。
getShort()を利用して、Number型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultShortAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultShortAdapter

public DBResultShortAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultStringAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultStringAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultStringAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultStringAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースカラムを文字列型として取得するアダプタ。

データベースのカラムを文字列型として値を取得するアダプタです。
getString() を利用して、文字列型として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultStringAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultStringAdapter

public DBResultStringAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultStructAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultStructAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultStructAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultStructAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースSTRUCT型カラム取得アダプタ。

データベースSTRUCT型の値を取得するアダプタです。
getStruct()を利用して、属性(java.sql.Struct.getAttributes())のObject配列として値を返します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultStructAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultStructAdapter

public DBResultStructAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultTimeAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultTimeAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultTimeAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultTimeAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースTIME型カラム取得アダプタ。

データベースTIME型の値を取得するアダプタです。
getTime()を利用して、Date型として値を返却します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultTimeAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultTimeAdapter

public DBResultTimeAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DBResultTimestampAdapter (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DBResultTimestampAdapter

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DBResultTimestampAdapter
すべての実装インタフェース:
DBResultAdapter
public class DBResultTimestampAdapter
extends Object
implements DBResultAdapter

スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。

データベースTIMESTAMP型の値を取得するアダプターです。
getTimeStamp()を利用して、Date型として返却します。

導入されたバージョン:
7.0
バージョン:
1.0

コンストラクタの概要
DBResultTimestampAdapter()
メソッドの概要
Object | getValue(ResultSet resultSet, int i) カラムからデータを取得します。
void | init(Node node) 初期化を行います。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

DBResultTimestampAdapter

public DBResultTimestampAdapter()
メソッドの詳細

init

public void init(Node node)
          throws SQLException
初期化を行います。

この実装がインスタンス化された時一度だけ呼び出されます。 この実装が設定されている<database-adapter>のノードが引数に渡されます。

定義:
インタフェース DBResultAdapter 内の init
パラメータ:
node - 設定が記述されているノード
例外:
SQLException

getValue

public Object getValue(ResultSet resultSet,
                       int i)
                throws SQLException
インタフェース DBResultAdapter の記述:
カラムからデータを取得します。

resultSetよりデータを取得して、JavaScript用の型に変換して、返却します。

定義:
インタフェース DBResultAdapter 内の getValue
パラメータ:
resultSet - 取得対象のResultSet
戻り値:
取得した値（JavaScriptの型）
例外:
SQLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


DbTypes (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.database
クラス DbTypes

java.lang.Object
    拡張 jp.co.intra_mart.foundation.database.DbTypes
public class DbTypes
extends Object

フィールドの概要
static DbTypes | DB2
static DbTypes | MYSQL
static DbTypes | ORACLE
static DbTypes | OTHER
static DbTypes | POSTGRESQL
static DbTypes | SQLSERVER
メソッドの概要
static DbTypes | getDbType(String name)
String | getName()
static DbTypes | matchDbType(String str)
static Collection | values()
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

ORACLE

public static DbTypes ORACLE

DB2

public static DbTypes DB2

POSTGRESQL

public static DbTypes POSTGRESQL

SQLSERVER

public static DbTypes SQLSERVER

MYSQL

public static DbTypes MYSQL

OTHER

public static DbTypes OTHER
メソッドの詳細

values

public static Collection values()

getDbType

public static DbTypes getDbType(String name)

matchDbType

public static DbTypes matchDbType(String str)

getName

public String getName()
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.database.DBResultAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.database.DBResultAdapter の使用

DBResultAdapter を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DBResultAdapter の使用

DBResultAdapter を実装している jp.co.intra_mart.foundation.database のクラス
class | DBResultArrayAdapter スクリプト開発用データベースARRAY型カラム取得アダプタ。
class | DBResultBigDecimalAdapter スクリプト開発用データベースDECIMAL,NUMERIC型カラム取得アダプタ。
class | DBResultBigIntAdapter スクリプト開発用データベースBIGINT型カラム取得アダプタ。
class | DBResultBinaryAdapter スクリプト開発用データベースBINARY,LONGVARBINARY,VARBINARY型カラム取得アダプタ。
class | DBResultBlobAdapter スクリプト開発用データベースBLOB型カラム取得アダプタ。
class | DBResultBooleanAdapter スクリプト開発用データベースBOOLEAN,BIT型カラム取得アダプタ。
class | DBResultByteAdapter スクリプト開発用データベースBYTE型カラム取得アダプタ。
class | DBResultClobAdapter スクリプト開発用データベースCLOB型カラム取得アダプタ。
class | DBResultDateAdapter スクリプト開発用データベースDATE型カラム取得アダプタ。
class | DBResultDoubleAdapter スクリプト開発用データベースDOUBLE,FLOAT型カラム取得アダプタ。
class | DBResultImTimestampAdapter スクリプト開発用データベースTIMESTAMP型カラム取得intra-mart拡張アダプタ。
class | DBResultIntegerAdapter スクリプト開発用データベースINTEGER型カラム取得アダプタ。
class | DBResultNullAdapter スクリプト開発用データベースNULL型カラム取得アダプタ。
class | DBResultObjectAdapter スクリプト開発用データベースカラムをObject型として取得するアダプタ。
class | DBResultRealAdapter スクリプト開発用データベースREAL型カラム取得アダプタ。
class | DBResultRefAdapter スクリプト開発用データベースREF型カラム取得アダプタ。
class | DBResultShortAdapter スクリプト開発用データベースSMALLINT型カラム取得アダプタ。
class | DBResultStringAdapter スクリプト開発用データベースカラムを文字列型として取得するアダプタ。
class | DBResultStructAdapter スクリプト開発用データベースSTRUCT型カラム取得アダプタ。
class | DBResultTimeAdapter スクリプト開発用データベースTIME型カラム取得アダプタ。
class | DBResultTimestampAdapter スクリプト開発用データベースTIMESTAMP型カラム取得アダプター。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultArrayAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultArrayAdapter の使用

jp.co.intra_mart.foundation.database.DBResultArrayAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBigDecimalAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBigIntAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBigIntAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBigIntAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBinaryAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBinaryAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBinaryAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBlobAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBlobAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBlobAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultBooleanAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultBooleanAdapter の使用

jp.co.intra_mart.foundation.database.DBResultBooleanAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultByteAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultByteAdapter の使用

jp.co.intra_mart.foundation.database.DBResultByteAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultClobAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultClobAdapter の使用

jp.co.intra_mart.foundation.database.DBResultClobAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultDateAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultDateAdapter の使用

jp.co.intra_mart.foundation.database.DBResultDateAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultDoubleAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultDoubleAdapter の使用

jp.co.intra_mart.foundation.database.DBResultDoubleAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter の使用

jp.co.intra_mart.foundation.database.DBResultImTimestampAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultIntegerAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultIntegerAdapter の使用

jp.co.intra_mart.foundation.database.DBResultIntegerAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultNullAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultNullAdapter の使用

jp.co.intra_mart.foundation.database.DBResultNullAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultObjectAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultObjectAdapter の使用

jp.co.intra_mart.foundation.database.DBResultObjectAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultRealAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultRealAdapter の使用

jp.co.intra_mart.foundation.database.DBResultRealAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultRefAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultRefAdapter の使用

jp.co.intra_mart.foundation.database.DBResultRefAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultShortAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultShortAdapter の使用

jp.co.intra_mart.foundation.database.DBResultShortAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultStringAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultStringAdapter の使用

jp.co.intra_mart.foundation.database.DBResultStringAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultStructAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultStructAdapter の使用

jp.co.intra_mart.foundation.database.DBResultStructAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultTimeAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultTimeAdapter の使用

jp.co.intra_mart.foundation.database.DBResultTimeAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DBResultTimestampAdapter の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DBResultTimestampAdapter の使用

jp.co.intra_mart.foundation.database.DBResultTimestampAdapter はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.database.DbTypes の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.database.DbTypes の使用

DbTypes を使用しているパッケージ
jp.co.intra_mart.foundation.database データベースへアクセスするためのクラスを提供します。

jp.co.intra_mart.foundation.database での DbTypes の使用

DbTypes として宣言されている jp.co.intra_mart.foundation.database のフィールド
static DbTypes | DbTypes.ORACLE
static DbTypes | DbTypes.DB2
static DbTypes | DbTypes.POSTGRESQL
static DbTypes | DbTypes.SQLSERVER
static DbTypes | DbTypes.MYSQL
static DbTypes | DbTypes.OTHER

DbTypes を返す jp.co.intra_mart.foundation.database のメソッド
static DbTypes | DbTypes.getDbType(String name)
static DbTypes | DbTypes.matchDbType(String str)
DbTypes | DatabaseManager.getSystemDatabaseType(String connectId) システムデータソースにおけるデータベースの種類を取得する。
DbTypes | DatabaseManager.getGroupDatabaseType(String groupId) ログイングループデータソースおけるデータベースの種類を取得する。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HalfKanaTransrateListener (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener.impl
クラス HalfKanaTransrateListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener
すべての実装インタフェース:
MailSendListener
public class HalfKanaTransrateListener
extends Object
implements MailSendListener

送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。 変換処理はHalfKanaTransratorに依存します。

導入されたバージョン:
7.2
関連項目:
HalfKanaTransrator

フィールドの概要
インタフェース jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener から継承したフィールド
CONTINUE, SKIP_LISTENER, STOP_MAILSEND
コンストラクタの概要
HalfKanaTransrateListener()
HalfKanaTransrateListenerを新規に生成します。
メソッドの概要
int | onSendMail(MailSendEvent event) メール送信が行われたことを通知します。
protected String | transliterate(String str) 指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HalfKanaTransrateListener

public HalfKanaTransrateListener()
HalfKanaTransrateListenerを新規に生成します。

メソッドの詳細

onSendMail

public int onSendMail(MailSendEvent event)
               throws MailSenderException
メール送信が行われたことを通知します。

メール送信イベントを受け取り、送信メールの件名と本文に含まれる半角カナ文字を、 全角カナ文字に変換します。
このメソッドは必ずMailSendListener.CONTINUEを返します。

定義:
インタフェース MailSendListener 内の onSendMail
パラメータ:
event - メール送信イベント
例外:
MailSenderException - リスナーで例外が発生

transliterate

protected String transliterate(String str)
指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。

パラメータ:
str - 文字列
戻り値:
変換された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.listener.impl (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.listener.impl
クラス
HalfKanaTransrateListener


jp.co.intra_mart.foundation.mail.javamail.listener.impl (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl

クラスの概要
HalfKanaTransrateListener 送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。


jp.co.intra_mart.foundation.mail.javamail.listener.impl クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener (implements jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener)


パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.listener.impl の使用

jp.co.intra_mart.foundation.mail.javamail.listener.impl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener の使用

jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EnCodeInterface (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.common.encode
インタフェース EnCodeInterface

public interface EnCodeInterface

簡易SSOのパスワードを暗号化するインタフェース。

簡易SSO設定のパスワードをDBに保存する際の暗号化処理クラスです。 デフォルトで提供されるクラスでは16進文字列への変換を行っています。

ユーザは簡易SSO用のパスワードの暗号化処理を独自に実装したい場合、 このインタフェースを実装したクラスを生成し、PortalCommonConfig.propertiesにクラス名を設定します。

設定ファイル
<% Application Runtime Root %>/doc/imart/WEB-INF/classes/PortalCommonConfig.properties
プロパティ名
EncodeInterface

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | decode(String string) 復号化を行います。
String | encode(String string) 暗号化を行います。

メソッドの詳細

encode

public String encode(String string)
暗号化を行います。

パラメータ:
string - 暗号化対象文字列
戻り値:
暗号化後の文字列

decode

public String decode(String string)
復号化を行います。

パラメータ:
string - 復号化対象文字列
戻り値:
復号化後の文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.portal.common.encode (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.common.encode
インタフェース
EnCodeInterface


jp.co.intra_mart.foundation.portal.common.encode (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.encode

インタフェースの概要
EnCodeInterface 簡易SSOのパスワードを暗号化するインタフェース。


jp.co.intra_mart.foundation.portal.common.encode クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.encode の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface


パッケージ jp.co.intra_mart.foundation.portal.common.encode の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.common.encode の使用

jp.co.intra_mart.foundation.portal.common.encode はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface の使用

jp.co.intra_mart.foundation.portal.common.encode.EnCodeInterface はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


jp.co.intra_mart.foundation.portal.common.rss (javadoc_foundation 6.1.14 API)

 jp.co.intra_mart.foundation.portal.common.rss
インタフェース
RSSParserIF


jp.co.intra_mart.foundation.portal.common.rss (javadoc_foundation 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.rss

インタフェースの概要
RSSParserIF RSS解析用の共通インタフェース
RSSポートレットで、取得したRSSデータを処理するためのパーサーです。


jp.co.intra_mart.foundation.portal.common.rss クラス階層 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.portal.common.rss の階層

パッケージ階層:
すべてのパッケージ

インタフェース階層

  • interface jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF


パッケージ jp.co.intra_mart.foundation.portal.common.rss の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.portal.common.rss の使用

jp.co.intra_mart.foundation.portal.common.rss はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


RSSParserIF (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.portal.common.rss
インタフェース RSSParserIF

public interface RSSParserIF

RSS解析用の共通インタフェース

RSSポートレットで、取得したRSSデータを処理するためのパーサーです。

IWPでは設定ファイルで指定されたXSLスタイルシートを利用して変換するためのパーサーである、

  • jp.co.intra_mart.foundation.portal.common.rss. RSSParserImplクラス
が提供されます。

ユーザは独自のRSS解析クラスを実装したい場合、 このインタフェースを実装したクラスを作成し、rss.xmlにクラス名設定します。

設定ファイル
<% Storage Root %>/portal/rss.xml
設定パス
parser/class

導入されたバージョン:
5.0
バージョン:
1.0

メソッドの概要
String | getHTML() 解析結果HTMLを返却します
void | setProxyHost(String proxyHost) Proxyホスト名をセットします
void | setProxyPort(String proxyPort) Proxyポート番号をセットします
void | setURL(String url) RSSのURLをセットします
void | setXSLT(String xsltPath) RSSのXMLをフォーマットするXSLスタイルシートのファイルパスをセットします

メソッドの詳細

setURL

public void setURL(String url)
RSSのURLをセットします

パラメータ:
url - RSSのURL

setProxyHost

public void setProxyHost(String proxyHost)
Proxyホスト名をセットします

パラメータ:
proxyHost - Proxyホスト名
導入されたバージョン:
6.0

setProxyPort

public void setProxyPort(String proxyPort)
Proxyポート番号をセットします

パラメータ:
proxyPort - Proxyポート番号
導入されたバージョン:
6.0

setXSLT

public void setXSLT(String xsltPath)
RSSのXMLをフォーマットするXSLスタイルシートのファイルパスをセットします

パラメータ:
xsltPath - RSSのXMLをフォーマットするXSLスタイルシートのファイルパス

getHTML

public String getHTML()
               throws MalformedURLException,
                      IOException,
                      TransformerConfigurationException,
                      TransformerException
解析結果HTMLを返却します

戻り値:
解析結果HTML
例外:
TransformerException
TransformerConfigurationException
IOException
MalformedURLException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


インタフェース jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF の使用

jp.co.intra_mart.foundation.portal.common.rss.RSSParserIF はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MobileEasyLoginUtil (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス MobileEasyLoginUtil

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil
public class MobileEasyLoginUtil
extends Object

かんたんログイン機能のユーティリティクラスです。

iWP/iAF ver6.1 patch11より、かんたんログイン機能のセキュリティが強化されました。
モバイル端末個体識別番号での認証に加え、かんたんログイン用ログインページのURLに自動的に付加したアクセスキーと
iWP/iAFで保持しているアクセスキーでの認証機能が追加されました。

この認証機能により、モバイルパスワードを変更することで、アクセスキーが変更され、
以前アクセスしていた古いアクセスキー付き URLでは、ログインできないようになります。

定期的にモバイルパスワードを変更されない場合は、携帯電話に保存した URLから、
かんたんログインが可能ですので、かんたんログイン用ログインページのURLを他人に知られないようご注意ください。

なお、かんたんログイン機能をご利用の場合は、
Web サーバーで、携帯電話からしかアクセスできないよう IPアドレス制限を実施していただく事をおすすめいたします。

Webサーバーで、IPアドレス制限をかける場合は、各携帯電話会社のホームページなどをご確認いただき、
各携帯電話会社のサーバーの IPアドレス帯域からのアクセスのみ許可する設定をお願いいたします。

注意点

かんたんログイン機能を利用する場合は、NonceResetListener4MobileEasyLoginクラスを、 ${ServerManagerルート}/conf/access-security.xmlに設定する必要があります。
NonceResetListener4MobileEasyLogin の設定は、かんたんログインのセキュリティを向上させる為に必要です。
設定方法は、NonceResetListener4MobileEasyLoginのAPIリストを参照してください。

なお、設定されていない場合は、かんたんログイン用のアクセスキー取得時に、 AccessSecurityConfigExceptionがスローされて、かんたんログイン機能を利用する事ができません。

導入されたバージョン:
6.1.11
関連項目:
NonceResetListener4MobileEasyLogin

フィールドの概要
static String REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY
かんたんログインのアクセスキー用リクエストパラメータ名。
コンストラクタの概要
MobileEasyLoginUtil()
メソッドの概要
static String | getAccessKey(String groupId, String userId) かんたんログイン用のアクセスキーを取得します。
static String | getAccessKeyWithRequestParameter(String groupId, String userId) かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
static String | getMobileEasyLoginURL(HttpServletRequest request, String groupId, String userId) かんたんログイン用のURLを取得します。
static String | getMobileEasyLoginURL(String groupId, String userId) かんたんログイン用のURLを取得します。
static void | reGenerateNonce(String groupId, String userId) かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY

public static final String REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY
かんたんログインのアクセスキー用リクエストパラメータ名。

関連項目:
定数フィールド値
コンストラクタの詳細

MobileEasyLoginUtil

public MobileEasyLoginUtil()
メソッドの詳細

getMobileEasyLoginURL

public static String getMobileEasyLoginURL(String groupId,
                                           String userId)
                                    throws AccessSecurityConfigException,
                                           AccessSecurityException,
                                           IllegalStateException,
                                           IOException
かんたんログイン用のURLを取得します。
本メソッドの実行結果は、
HTTPContextManager.getCurrentContext()で取得したHttpServletRequest利用して、 getMobileEasyLoginURL(HttpServletRequest, String, String)を実行した結果と同じです。

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のURL
例外:
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
IOException - Base64エンコーディングに失敗した場合

getMobileEasyLoginURL

public static String getMobileEasyLoginURL(HttpServletRequest request,
                                           String groupId,
                                           String userId)
                                    throws AccessSecurityException,
                                           AccessSecurityConfigException,
                                           IllegalStateException,
                                           IOException
かんたんログイン用のURLを取得します。
かんたんログイン用のURLは以下の形式です。
${WebサーバのURL} + ${コンテキストパス} + "/" + ${ログイングループID} + ${モバイル用の拡張子} + "?" + ${アクセスキー}
項目 | 説明
${WebサーバのURL} ${ServerManagerルート}/conf/parameter.xml の パラメータ名「im.web_server.url」の値です。 （設定例はこちら）
上記パラメータが未設定の場合は、引数「request」の ServletRequest.getScheme()、 ServletRequest.getServerName()、 ServletRequest.getServerPort()を利用してURLを生成します。
${コンテキストパス} | 引数「request」の HttpServletRequest.getContextPath()の値。
${ログイングループID} | 引数「groupId」の値。
${モバイル用の拡張子} Javaのシステムプロパティ「jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil.mobileExtention」の値。
（デフォルト値は「.mobile」です）
${アクセスキー} | getAccessKeyWithRequestParameter(String, String)の値。

parameter.xml の 設定例
<?xml version="1.0" encoding="UTF-8"?>
<system-param>
   .
   .
   .
  <param>
    <param-name>im.web_server.url</param-name>
    <param-name>https://hostname:port</param-name>
  </param>
   .
   .
   .

パラメータ:
request - リクエスト
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のURL
例外:
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
IOException - Base64エンコーディングに失敗した場合

getAccessKeyWithRequestParameter

public static String getAccessKeyWithRequestParameter(String groupId,
                                                      String userId)
                                               throws IllegalStateException,
                                                      AccessSecurityException,
                                                      IOException,
                                                      AccessSecurityConfigException
かんたんログイン用のアクセスキーをリクエストパラメータの形式で取得します。
本メソッドは、以下と同意です。
     REQUEST_PARAM_NAME_4_EASYLOGIN_ACCESS_KEY + "=" + getAccessKey(String, String)

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のアクセスキー(リクエストパラメータの形式)
例外:
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
IOException - Base64エンコーディングに失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合

getAccessKey

public static String getAccessKey(String groupId,
                                  String userId)
                           throws IllegalStateException,
                                  AccessSecurityException,
                                  IOException,
                                  AccessSecurityConfigException
かんたんログイン用のアクセスキーを取得します。
かんたんログイン用のアクセスキーは、 「Nonce」 「モバイルパスワード」 および 「モバイル端末個体識別番号」を文字列連結し、 SHA1アルゴリズムでダイジェスト化して生成された文字列を、Base64エンコード後、英数字のみにした文字列です。
 かんたんログイン用アクセスキー = (Base64 ( SHA-1 ( Nonce + モバイルパスワード + モバイル端末個体識別番号 ) ) ).replaceAll("[^\p{Alnum}]", "")
Nonceとは、暗号的にランダムな値をBase64エンコードした文字列で、 モバイルパスワードが更新された際に、再設定され、アカウント属性情報として保存されます。
（参照：NonceResetListener4MobileEasyLogin, reGenerateNonce(String, String)）

パラメータ:
groupId - ログイングループID
userId - ユーザID
戻り値:
かんたんログイン用のアクセスキー(リクエストパラメータの形式)
例外:
IllegalStateException - Nonce、モバイル端末個体識別番号のいずれかが未設定の場合
AccessSecurityException - Nonce、モバイルパスワード、モバイル端末個体識別番号のいずれかの取得に失敗した場合
IOException - Base64エンコーディングに失敗した場合
AccessSecurityConfigException - NonceResetListener4MobileEasyLoginが、AccountQueryWriterListener かつ AccountPostWriterListener として登録されていなかった場合
関連項目:
NonceResetListener4MobileEasyLogin, reGenerateNonce(String, String)

reGenerateNonce

public static void reGenerateNonce(String groupId,
                                   String userId)
                            throws AccessSecurityException
かんたんログイン用のNonceを新たに生成し、アカウント属性情報として保存します。（保存時に、暗号化が行われます）
属性名は、AccountManager.ATTR_MOBILE_EASY_LOGIN_NONCE です。
暗号化アルゴリズムカテゴリは、AccountManager.CRYPTION_CATEGORY_MOBILE_USER_AGENT です。

パラメータ:
groupId - ログイングループID
userId - ユーザID
例外:
AccessSecurityException - Nonceの保存に失敗した場合
関連項目:
AccountManager.ATTR_MOBILE_EASY_LOGIN_NONCE, AccountManager.CRYPTION_CATEGORY_MOBILE_USER_AGENT
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


NonceResetListener4MobileEasyLogin (javadoc_foundation 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.security.mobile
クラス NonceResetListener4MobileEasyLogin

java.lang.Object
    拡張 jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin
すべての実装インタフェース:
AccountPostWriterListener, AccountQueryWriterListener
public class NonceResetListener4MobileEasyLogin
extends Object
implements AccountQueryWriterListener, AccountPostWriterListener

かんたんログイン用のNonceを再設定する為のリスナーです。

このリスナーは、かんたんログインの設定が行われている状態で、モバイルパスワードが更新されたことを検知し、
MobileEasyLoginUtil.reGenerateNonce(String, String)を利用して、Nonceの再設定を行います。

Nonceは、かんたんログイン用のアクセスキーの生成に必要です。
（かんたんログイン用のアクセスキーについては、MobileEasyLoginUtil.getAccessKey(String, String)を参照してください）

本クラスを、${ServerManagerルート}/conf/access-security.xmlの以下のタグに設定してください。
（設定しない場合、かんたんログイン機能を利用する事は出来ません）

  • access-security/access-config/account/query-writer-listener/writer-listener-class
  • access-security/access-config/account/post-writer-listener/writer-listener-class
access-security.xml の 設定例
<?xml version="1.0" encoding="UTF-8"?>
<access-security>
   .
   .
  <access-config>
     .
     .
    <account>
      <accessor>
        <accessor-class>jp.co.intra_mart.foundation.security.StandardAccountAccessor</accessor-class>
<!--
        <init-param>
          <param-name>cryption-class</param-name>
          <param-value>jp.co.intra_mart.foundation.security.cryption.NoCryption</param-value>
        </init-param>
-->
      </accessor>
       .
       .

      <query-writer-listener>
        <writer-listener-class>jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin</writer-listener-class>
      </query-writer-listener>
      <post-writer-listener>
        <writer-listener-class>jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin</writer-listener-class>
      </post-writer-listener>

    </account>

導入されたバージョン:
6.1.11
関連項目:
MobileEasyLoginUtil

コンストラクタの概要
NonceResetListener4MobileEasyLogin()
メソッドの概要
void | init(Map params) アカウントリスナーの初期化。
void | postCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成した直後にコールされます。
void | postCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | postCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成した直後にコールされます。
void | postDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除した直後にコールされます。
void | postDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除した直後にコールされます。
void | postDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除した直後にコールされます。
void | postUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新した直後にコールされます。
void | postUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新した直後にコールされます。
void | postUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新した直後にコールされます。
void | queryCreateAccount(String groupId, Account account) アカウント情報をデータストアに作成する直前にコールされます。
void | queryCreateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに作成した直後にコールされます。
void | queryCreateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに作成する直前にコールされます。
void | queryDeleteAccount(String groupId, String userId) アカウント情報をデータストアから削除する直前にコールされます。
void | queryDeleteAccountRole(String groupId, String userId, String roleId) アカウントロール情報をデータストアから削除する直前にコールされます。
void | queryDeleteFavoriteMenu(String groupId, String userId, String menuId) マイメニュー情報をデータストアから削除する直前にコールされます。
void | queryUpdateAccount(String groupId, Account account) アカウント情報をデータストアに更新する直前にコールされます。
void | queryUpdateAccountRole(String groupId, String userId, AccountRole accountRole) アカウントロール情報をデータストアに更新する直前にコールされます。
void | queryUpdateFavoriteMenu(String groupId, String userId, FavoriteMenu favoriteMenu) マイメニュー情報をデータストアに更新する直前にコールされます。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

NonceResetListener4MobileEasyLogin

public NonceResetListener4MobileEasyLogin()
メソッドの詳細

queryUpdateAccount

public void queryUpdateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウント情報をデータストアに更新する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryUpdateAccount
パラメータ:
groupId - ログイングループID
account - 更新されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccount

public void postUpdateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウント情報をデータストアに更新した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postUpdateAccount
パラメータ:
groupId - ログイングループID
account - 更新されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

init

public void init(Map params)
インタフェース AccountQueryWriterListener の記述:
アカウントリスナーの初期化。

このクラスを実装したクラスが生成される時、一度だけこのメソッドが呼び出される。

定義:
インタフェース AccountQueryWriterListener 内の init
パラメータ:
params - 初期化パラメータのマップ(Map)

queryCreateAccount

public void queryCreateAccount(String groupId,
                               Account account)
                        throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウント情報をデータストアに作成する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryCreateAccount
パラメータ:
groupId - ログイングループID
account - 作成されるアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateAccountRole

public void queryCreateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウントロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryCreateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryCreateFavoriteMenu

public void queryCreateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
マイメニュー情報をデータストアに作成する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryCreateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccount

public void queryDeleteAccount(String groupId,
                               String userId)
                        throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウント情報をデータストアから削除する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryDeleteAccount
パラメータ:
groupId - ログイングループID
userId - 削除されるユーザコード
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteAccountRole

public void queryDeleteAccountRole(String groupId,
                                   String userId,
                                   String roleId)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウントロール情報をデータストアから削除する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryDeleteAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されるロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryDeleteFavoriteMenu

public void queryDeleteFavoriteMenu(String groupId,
                                    String userId,
                                    String menuId)
                             throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
マイメニュー情報をデータストアから削除する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryDeleteFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されるマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateAccountRole

public void queryUpdateAccountRole(String groupId,
                                   String userId,
                                   AccountRole accountRole)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
アカウントロール情報をデータストアに更新する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryUpdateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されるアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

queryUpdateFavoriteMenu

public void queryUpdateFavoriteMenu(String groupId,
                                    String userId,
                                    FavoriteMenu favoriteMenu)
                             throws AccessSecurityListenerExcpetion
インタフェース AccountQueryWriterListener の記述:
マイメニュー情報をデータストアに更新する直前にコールされます。

定義:
インタフェース AccountQueryWriterListener 内の queryUpdateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されるマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccount

public void postCreateAccount(String groupId,
                              Account account)
                       throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウント情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postCreateAccount
パラメータ:
groupId - ログイングループID
account - 作成されたアカウント情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateAccountRole

public void postCreateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウントロール情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postCreateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 作成されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postCreateFavoriteMenu

public void postCreateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
マイメニュー情報をデータストアに作成した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postCreateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 作成されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccount

public void postDeleteAccount(String groupId,
                              String userId)
                       throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウント情報をデータストアから削除した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postDeleteAccount
パラメータ:
groupId - ログイングループID
userId - 削除されたユーザID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteAccountRole

public void postDeleteAccountRole(String groupId,
                                  String userId,
                                  String roleId)
                           throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウントロール情報をデータストアから削除した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postDeleteAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
roleId - 削除されたロールID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postDeleteFavoriteMenu

public void postDeleteFavoriteMenu(String groupId,
                                   String userId,
                                   String menuId)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
マイメニュー情報をデータストアから削除した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postDeleteFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
menuId - 削除されたマイメニューID
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateAccountRole

public void postUpdateAccountRole(String groupId,
                                  String userId,
                                  AccountRole accountRole)
                           throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
アカウントロール情報をデータストアに更新した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postUpdateAccountRole
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
accountRole - 更新されたアカウントロール情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。

postUpdateFavoriteMenu

public void postUpdateFavoriteMenu(String groupId,
                                   String userId,
                                   FavoriteMenu favoriteMenu)
                            throws AccessSecurityListenerExcpetion
インタフェース AccountPostWriterListener の記述:
マイメニュー情報をデータストアに更新した直後にコールされます。

定義:
インタフェース AccountPostWriterListener 内の postUpdateFavoriteMenu
パラメータ:
groupId - ログイングループID
userId - 対象ユーザID
favoriteMenu - 更新されたマイメニュー情報
例外:
AccessSecurityListenerExcpetion - このメソッドで例外が発生した場合にスローされます。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil の使用

jp.co.intra_mart.foundation.security.mobile.MobileEasyLoginUtil はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin の使用 (javadoc_foundation 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin の使用

jp.co.intra_mart.foundation.security.mobile.NonceResetListener4MobileEasyLogin はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HalfKanaTransrateListener (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.javamail.listener.impl
クラス HalfKanaTransrateListener

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener
すべての実装インタフェース:
MailSendListener
public class HalfKanaTransrateListener
extends Object
implements MailSendListener

送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。 変換処理はHalfKanaTransratorに依存します。

導入されたバージョン:
7.2
関連項目:
HalfKanaTransrator

フィールドの概要
インタフェース jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener から継承したフィールド
CONTINUE, SKIP_LISTENER, STOP_MAILSEND
コンストラクタの概要
HalfKanaTransrateListener()
HalfKanaTransrateListenerを新規に生成します。
メソッドの概要
int | onSendMail(MailSendEvent event) メール送信が行われたことを通知します。
protected String | transliterate(String str) 指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

HalfKanaTransrateListener

public HalfKanaTransrateListener()
HalfKanaTransrateListenerを新規に生成します。

メソッドの詳細

onSendMail

public int onSendMail(MailSendEvent event)
               throws jp.co.intra_mart.foundation.mail.MailSenderException
メール送信が行われたことを通知します。

メール送信イベントを受け取り、送信メールの件名と本文に含まれる半角カナ文字を、 全角カナ文字に変換します。
このメソッドは必ずMailSendListener.CONTINUEを返します。

定義:
インタフェース MailSendListener 内の onSendMail
パラメータ:
event - メール送信イベント
例外:
jp.co.intra_mart.foundation.mail.MailSenderException - リスナーで例外が発生

transliterate

protected String transliterate(String str)
指定した文字列のに含まれる半角カナ文字を全角カナ文字に変化して返します。

パラメータ:
str - 文字列
戻り値:
変換された文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.javamail.listener.impl (im_javamail 6.1.14 API)

 jp.co.intra_mart.foundation.mail.javamail.listener.impl
クラス
HalfKanaTransrateListener


jp.co.intra_mart.foundation.mail.javamail.listener.impl (im_javamail 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl

クラスの概要
HalfKanaTransrateListener 送信メールの件名と本文に含まれる半角カナ文字を、全角カナ文字に変換するリスナです。


jp.co.intra_mart.foundation.mail.javamail.listener.impl クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener (implements jp.co.intra_mart.foundation.mail.javamail.listener.MailSendListener)


パッケージ jp.co.intra_mart.foundation.mail.javamail.listener.impl の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.javamail.listener.impl の使用

jp.co.intra_mart.foundation.mail.javamail.listener.impl はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener の使用

jp.co.intra_mart.foundation.mail.javamail.listener.impl.HalfKanaTransrateListener はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


HalfKanaTransrator (im_javamail 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.foundation.mail.util
クラス HalfKanaTransrator

java.lang.Object
    拡張 jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator
public class HalfKanaTransrator
extends Object

半角カナ文字を全角カナ文字に変換します。
変換対象となる半角カナ文字は以下の通りです。

ｱ ｲ ｳ ｴ ｵ ｶ ｷ ｸ ｹ ｺ ｻ ｼ ｽ ｾ ｿ ﾀ ﾁ ﾂ ﾃ ﾄ ﾅ ﾆ ﾇ ﾈ ﾉ ﾊ ﾋ ﾌ ﾍ ﾎ ﾏ ﾐ ﾑ ﾒ ﾓ ﾔ ﾕ ﾖ ﾗ ﾘ ﾙ ﾚ ﾛ ﾜ ｦ ﾝ

ｧ ｨ ｩ ｪ ｫ ｬ ｭ ｮ ｯ

ｶﾞ ｷﾞ ｸﾞ ｹﾞ ｺﾞ ｻﾞ ｼﾞ ｽﾞ ｾﾞ ｿﾞ ﾀﾞ ﾁﾞ ﾂﾞ ﾃﾞ ﾄﾞ ﾊﾞ ﾋﾞ ﾌﾞ ﾍﾞ ﾎﾞ

ﾊﾟ ﾋﾟ ﾌﾟ ﾍﾟ ﾎﾟ

｡ ､ ･ ｢ ｣ ﾞ ﾟ

導入されたバージョン:
7.2

メソッドの概要
static String translate(String s)
文字列を変換します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

メソッドの詳細

translate

public static String translate(String s)
文字列を変換します。 文字列に含まれる半角カナ文字を全角カナに変換し返します。

パラメータ:
s - 文字列
戻り値:
文字列
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.foundation.mail.util (im_javamail 6.1.14 API)

 jp.co.intra_mart.foundation.mail.util
クラス
HalfKanaTransrator


jp.co.intra_mart.foundation.mail.util (im_javamail 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.util

クラスの概要
HalfKanaTransrator 半角カナ文字を全角カナ文字に変換します。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のパッケージ 次のパッケージ フレームあり フレームなし


jp.co.intra_mart.foundation.mail.util クラス階層 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.foundation.mail.util の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


パッケージ jp.co.intra_mart.foundation.mail.util の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.foundation.mail.util の使用

jp.co.intra_mart.foundation.mail.util はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator の使用 (im_javamail 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator の使用

jp.co.intra_mart.foundation.mail.util.HalfKanaTransrator はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


MultipartFormDataResourceBundle (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http
クラス MultipartFormDataResourceBundle

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle
public class MultipartFormDataResourceBundle
extends Object

MultipartFormDataの設定情報を扱うクラスです。

設定ファイルは、 %ApplicationRuntime%/doc/imart/WEB-INF/classes/jp/co/intra_mart/common/aid/javaee/http/MultipartFormData.properties です。

設定ファイルの内容は以下の通りです。

キー | 初期値 | 説明
use_commons_fileupload | true | アップロードされたファイルを常にメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用するかを指定します。 trueを指定すると一時ファイルに書き出す実装を、falseを指定すると常にメモリ上で扱う実装を利用します。
size_threshold | 10240 | use_commons_fileupload=true とした場合に、アップロードされたファイルを一時ファイルに 書き出すかどうかを決める閾値です。アップロードされたファイルが指定した値を超えると一時ファイルに 書き出されます。単位はバイトです。
repository | （空） | use_commons_fileupload=true とした場合に、一時ファイルを格納するフォルダを指定します。 空もしくは存在しないフォルダを指定した場合、Javaのテンポラリフォルダ(java.io.tmpdir)を指定した ことになります。

導入されたバージョン:
6.1.11

フィールドの概要
static String | DEFAULT_MULTIPART_PROPERTIES プロパティファイル名
static int | DEFAULT_SIZETHRESHOLD useCommonsFileuploadがtrueの場合、一時ファイルを作成するデフォルトの閾値（単位：バイト）
static String | KEY_REPOSITORY 一時ファイルの保存先 のキー
static String | KEY_SIZE_THRESHOLD 一時ファイルを作成するかどうかの閾値のキー
static String | KEY_USE_COMMONS_FILEUPLOAD CommonsFileUploadを利用するかどうかのキー
コンストラクタの概要
MultipartFormDataResourceBundle()
メソッドの概要
static File | getRepository() useCommonsFileuploadがtrueの場合、一時ファイルを作成するフォルダを取得します。
static int | getSizeThreshold() useCommonsFileuploadがtrueの場合、一時ファイルを作成する閾値を取得します。
static boolean | useCommonsFileupload() アップロードされたファイルをメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用ように設定したかを取得します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

フィールドの詳細

DEFAULT_MULTIPART_PROPERTIES

public static final String DEFAULT_MULTIPART_PROPERTIES
プロパティファイル名

関連項目:
定数フィールド値

KEY_USE_COMMONS_FILEUPLOAD

public static final String KEY_USE_COMMONS_FILEUPLOAD
CommonsFileUploadを利用するかどうかのキー

関連項目:
定数フィールド値

KEY_SIZE_THRESHOLD

public static final String KEY_SIZE_THRESHOLD
一時ファイルを作成するかどうかの閾値のキー

関連項目:
定数フィールド値

KEY_REPOSITORY

public static final String KEY_REPOSITORY
一時ファイルの保存先 のキー

関連項目:
定数フィールド値

DEFAULT_SIZETHRESHOLD

public static final int DEFAULT_SIZETHRESHOLD
useCommonsFileuploadがtrueの場合、一時ファイルを作成するデフォルトの閾値（単位：バイト）

関連項目:
定数フィールド値
コンストラクタの詳細

MultipartFormDataResourceBundle

public MultipartFormDataResourceBundle()
メソッドの詳細

useCommonsFileupload

public static boolean useCommonsFileupload()
アップロードされたファイルをメモリ上で扱う実装と一時ファイルに書き出す実装のどちらを利用ように設定したかを取得します。

戻り値:
trueの場合一時ファイルに書き出す実装を、falseの場合メモリ上で扱う実装を利用します。

getSizeThreshold

public static int getSizeThreshold()
useCommonsFileuploadがtrueの場合、一時ファイルを作成する閾値を取得します。

戻り値:
一時ファイルを作成する閾値（単位：バイト）

getRepository

public static File getRepository()
useCommonsFileuploadがtrueの場合、一時ファイルを作成するフォルダを取得します。 設定ファイルで、空もしくは存在しないフォルダを指定した場合、Javaのテンポラリフォルダ(java.io.tmpdir)を 返します。

戻り値:
一時ファイルの保存先
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle の使用

jp.co.intra_mart.common.aid.javaee.http.MultipartFormDataResourceBundle はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


IMDiskFileItem (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMDiskFileItem

java.lang.Object
    拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem
すべての実装インタフェース:
org.apache.commons.fileupload.FileItem, Serializable
public class IMDiskFileItem
extends Object
implements org.apache.commons.fileupload.FileItem

ヘッダ情報を追加したFileItemの実装クラスです。

導入されたバージョン:
6.1.11
関連項目:
直列化された形式

コンストラクタの概要
IMDiskFileItem(String fieldName, String contentType, boolean isFormField, String fileName, int sizeThreshold, File repository, Map headers)
コンストラクタ
メソッドの概要
void | delete() 一時ファイルを削除します。
byte[] | get() ファイルの内容をバイト配列として取得します。
String | getContentType() コンテントタイプを取得します。
String | getFieldName() フィールド名を取得します。
Map | getHeaders() ヘッダ情報を取得します。
InputStream | getInputStream() 一時ファイルから取得したInputStreamを取得します。
String | getName() ファイル名を取得します。
OutputStream | getOutputStream() ファイルの内容を保存するのに使用できるOutputStreamを取得します。
long | getSize() ファイルサイズを取得します。
String | getString() ファイルの内容をStringとして取得します。
String | getString(String charset) 指定されたエンコードを使用してファイルの内容をStringとして取得します。
boolean | isFormField() 単純なフォームフィールドかどうかを取得します。
boolean | isInMemory() ファイルの内容がメモリから読み込まれるかどうかを取得します。
void | setFieldName(String fieldName) ファイルを参照するためのフィールド名をセットします。
void | setFormField(boolean state) 単純なフォームフィールドかどうかを指定します。
void | write(File file) 指定されたFileにアップロードされたファイルを書き出します。
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IMDiskFileItem

public IMDiskFileItem(String fieldName,
                      String contentType,
                      boolean isFormField,
                      String fileName,
                      int sizeThreshold,
                      File repository,
                      Map headers)
コンストラクタ

パラメータ:
fieldName - フィールド名
contentType - コンテントタイプ
isFormField - フィールドかどうかのフラグ
fileName - ファイル名
sizeThreshold - 閾値
repository - 一時ファイルの保存先
headers - ヘッダ情報
メソッドの詳細

getHeaders

public Map getHeaders()
ヘッダ情報を取得します。

戻り値:
ヘッダ情報

delete

public void delete()
一時ファイルを削除します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の delete

get

public byte[] get()
ファイルの内容をバイト配列として取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の get

getContentType

public String getContentType()
コンテントタイプを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getContentType

getFieldName

public String getFieldName()
フィールド名を取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getFieldName

getInputStream

public InputStream getInputStream()
                           throws IOException
一時ファイルから取得したInputStreamを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getInputStream
例外:
IOException

getName

public String getName()
ファイル名を取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getName

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
ファイルの内容を保存するのに使用できるOutputStreamを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getOutputStream
例外:
IOException

getSize

public long getSize()
ファイルサイズを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getSize

getString

public String getString()
ファイルの内容をStringとして取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getString

getString

public String getString(String charset)
                 throws UnsupportedEncodingException
指定されたエンコードを使用してファイルの内容をStringとして取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の getString
例外:
UnsupportedEncodingException

isFormField

public boolean isFormField()
単純なフォームフィールドかどうかを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の isFormField
戻り値:
単純なフォームフィールドの場合true、アップロードされたファイルの場合false

isInMemory

public boolean isInMemory()
ファイルの内容がメモリから読み込まれるかどうかを取得します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の isInMemory

setFieldName

public void setFieldName(String fieldName)
ファイルを参照するためのフィールド名をセットします。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の setFieldName

setFormField

public void setFormField(boolean state)
単純なフォームフィールドかどうかを指定します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の setFormField

write

public void write(File file)
           throws Exception
指定されたFileにアップロードされたファイルを書き出します。

定義:
インタフェース org.apache.commons.fileupload.FileItem 内の write
例外:
Exception
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IMDiskFileItemFactory (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMDiskFileItemFactory

java.lang.Object
    拡張 org.apache.commons.fileupload.disk.DiskFileItemFactory
        拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory
すべての実装インタフェース:
org.apache.commons.fileupload.FileItemFactory, IMFileItemFactory
public class IMDiskFileItemFactory
extends org.apache.commons.fileupload.disk.DiskFileItemFactory
implements IMFileItemFactory

ヘッダ情報を含むFileItemを生成するFactoryです。

導入されたバージョン:
6.1.11

フィールドの概要
クラス org.apache.commons.fileupload.disk.DiskFileItemFactory から継承したフィールド
DEFAULT_SIZE_THRESHOLD
コンストラクタの概要
IMDiskFileItemFactory()
デフォルトコンストラクタ
IMDiskFileItemFactory(int sizeThreshold, File repository)
コンストラクタ
メソッドの概要
 org.apache.commons.fileupload.FileItem createItem(String fieldName, String contentType, boolean isFormField, String fileName, Map headers)
ヘッダ情報を含むFileItemを生成します。
クラス org.apache.commons.fileupload.disk.DiskFileItemFactory から継承したメソッド
createItem, getRepository, getSizeThreshold, setRepository, setSizeThreshold
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース org.apache.commons.fileupload.FileItemFactory から継承したメソッド
createItem

コンストラクタの詳細

IMDiskFileItemFactory

public IMDiskFileItemFactory()
デフォルトコンストラクタ

IMDiskFileItemFactory

public IMDiskFileItemFactory(int sizeThreshold,
                             File repository)
コンストラクタ

パラメータ:
sizeThreshold - 一時ファイルを作成するかどうかの閾値
repository - 一時ファイルの保存先
メソッドの詳細

createItem

public org.apache.commons.fileupload.FileItem createItem(String fieldName,
                                                         String contentType,
                                                         boolean isFormField,
                                                         String fileName,
                                                         Map headers)
ヘッダ情報を含むFileItemを生成します。

定義:
インタフェース IMFileItemFactory 内の createItem
パラメータ:
fieldName -
contentType -
isFormField -
fileName -
headers -
戻り値:
ヘッダ情報を含むFileItem
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IMFileItemFactory (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
インタフェース IMFileItemFactory

すべてのスーパーインタフェース:
org.apache.commons.fileupload.FileItemFactory
既知の実装クラスの一覧:
IMDiskFileItemFactory
public interface IMFileItemFactory
extends org.apache.commons.fileupload.FileItemFactory

ヘッダ情報を含むFileItemを生成するFactoryです。

導入されたバージョン:
6.1.11

メソッドの概要
 org.apache.commons.fileupload.FileItem createItem(String fieldName, String contentType, boolean isFormField, String fileName, Map headers)
ヘッダ情報を含むFileItemを生成します。
インタフェース org.apache.commons.fileupload.FileItemFactory から継承したメソッド
createItem

メソッドの詳細

createItem

public org.apache.commons.fileupload.FileItem createItem(String fieldName,
                                                         String contentType,
                                                         boolean isFormField,
                                                         String fileName,
                                                         Map headers)
ヘッダ情報を含むFileItemを生成します。

パラメータ:
fieldName -
contentType -
isFormField -
fileName -
headers -
戻り値:
ヘッダ情報を含むFileItem
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


IMMultipartStream (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMMultipartStream

java.lang.Object
    拡張 org.apache.commons.fileupload.MultipartStream
        拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream
public class IMMultipartStream
extends org.apache.commons.fileupload.MultipartStream

ヘッダの文字エンコーディングを変換しないMultipartStreamです。

導入されたバージョン:
6.1.14

入れ子クラスの概要
クラス org.apache.commons.fileupload.MultipartStream から継承した入れ子クラス
org.apache.commons.fileupload.MultipartStream.IllegalBoundaryException, org.apache.commons.fileupload.MultipartStream.MalformedStreamException
フィールドの概要
クラス org.apache.commons.fileupload.MultipartStream から継承したフィールド
BOUNDARY_PREFIX, CR, DASH, DEFAULT_BUFSIZE, FIELD_SEPARATOR, HEADER_PART_SIZE_MAX, HEADER_SEPARATOR, LF, STREAM_TERMINATOR
コンストラクタの概要
IMMultipartStream()
デフォルトコンストラクタ
IMMultipartStream(InputStream input, byte[] boundary)
コンストラクタ。
メソッドの概要
 String readHeaders()
リクエストエンコーディングへのエンコーディング変換を行わずにヘッダ部を読み込みます。
クラス org.apache.commons.fileupload.MultipartStream から継承したメソッド
arrayequals, discardBodyData, findByte, findSeparator, getHeaderEncoding, readBodyData, readBoundary, readByte, setBoundary, setHeaderEncoding, skipPreamble, toString
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

コンストラクタの詳細

IMMultipartStream

public IMMultipartStream()
デフォルトコンストラクタ

IMMultipartStream

public IMMultipartStream(InputStream input,
                         byte[] boundary)
                  throws IOException
コンストラクタ。

パラメータ:
input - マルチパートデータが含まれるInputStream
boundary - boundary
例外:
IOException
メソッドの詳細

readHeaders

public String readHeaders()
                   throws org.apache.commons.fileupload.MultipartStream.MalformedStreamException
リクエストエンコーディングへのエンコーディング変換を行わずにヘッダ部を読み込みます。

戻り値:
ヘッダ部
例外:
MalformedStreamException - 予期せずにストリームが終了した場合
org.apache.commons.fileupload.MultipartStream.MalformedStreamException
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド 詳細: フィールド | コンストラクタ | メソッド


IMServletFileUpload (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.javaee.http.fileupload
クラス IMServletFileUpload

java.lang.Object
    拡張 org.apache.commons.fileupload.FileUploadBase
        拡張 org.apache.commons.fileupload.FileUpload
            拡張 org.apache.commons.fileupload.servlet.ServletFileUpload
                拡張 jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload
public class IMServletFileUpload
extends org.apache.commons.fileupload.servlet.ServletFileUpload

ヘッダ情報を扱えるようにしたFileUploadクラスです。

導入されたバージョン:
6.1.11

入れ子クラスの概要
クラス org.apache.commons.fileupload.FileUploadBase から継承した入れ子クラス
org.apache.commons.fileupload.FileUploadBase.InvalidContentTypeException, org.apache.commons.fileupload.FileUploadBase.SizeLimitExceededException, org.apache.commons.fileupload.FileUploadBase.UnknownSizeException
フィールドの概要
クラス org.apache.commons.fileupload.FileUploadBase から継承したフィールド
ATTACHMENT, CONTENT_DISPOSITION, CONTENT_TYPE, FORM_DATA, MAX_HEADER_SIZE, MULTIPART, MULTIPART_FORM_DATA, MULTIPART_MIXED
コンストラクタの概要
IMServletFileUpload()
デフォルトコンストラクタ
IMServletFileUpload(org.apache.commons.fileupload.FileItemFactory fileItemFactory)
コンストラクタ
メソッドの概要
protected org.apache.commons.fileupload.FileItem | createItem(Map headers, boolean isFormField)
protected String | getFileName(Map arg0) ヘッダのContent-Dispositionに含まれるファイル名を返します。
protected Map | parseHeaders(String headerPart) CommonsFileuploadのFileuploadBaseにヘッダ情報のキーをtoLowerCaseしないヘッダ情報 を追加したメソッドです。
List | parseRequest(org.apache.commons.fileupload.RequestContext ctx) CommonsFileuploadのFileuploadBase#parRequestのヘッダをパースするインスタンスを IMMultipartStreamに変更したメソッドです。
クラス org.apache.commons.fileupload.servlet.ServletFileUpload から継承したメソッド
parseRequest
クラス org.apache.commons.fileupload.FileUpload から継承したメソッド
getFileItemFactory, setFileItemFactory
クラス org.apache.commons.fileupload.FileUploadBase から継承したメソッド
getBoundary, getFieldName, getHeader, getHeaderEncoding, getSizeMax, isMultipartContent, isMultipartContent, setHeaderEncoding, setSizeMax
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

コンストラクタの詳細

IMServletFileUpload

public IMServletFileUpload()
デフォルトコンストラクタ

IMServletFileUpload

public IMServletFileUpload(org.apache.commons.fileupload.FileItemFactory fileItemFactory)
コンストラクタ

パラメータ:
fileItemFactory - ファクトリ
メソッドの詳細

createItem

protected org.apache.commons.fileupload.FileItem createItem(Map headers,
                                                            boolean isFormField)
                                                     throws org.apache.commons.fileupload.FileUploadException
例外:
org.apache.commons.fileupload.FileUploadException

parseRequest

public List parseRequest(org.apache.commons.fileupload.RequestContext ctx)
                  throws org.apache.commons.fileupload.FileUploadException
CommonsFileuploadのFileuploadBase#parRequestのヘッダをパースするインスタンスを IMMultipartStreamに変更したメソッドです。 IMMultipartStreamでは、ヘッダをパースする際にエンコード変換を行いません。

例外:
org.apache.commons.fileupload.FileUploadException

parseHeaders

protected Map parseHeaders(String headerPart)
CommonsFileuploadのFileuploadBaseにヘッダ情報のキーをtoLowerCaseしないヘッダ情報 を追加したメソッドです。

getFileName

protected String getFileName(Map arg0)
ヘッダのContent-Dispositionに含まれるファイル名を返します。

Content-Dispositionがヘッダに含まれない場合はnullを返します。 ファイル名は、リクエストのエンコーディングでエンコードした状態で返します。

リクエストのエンコーディングが指定されなかった場合、ISO-8859-1で エンコードした状態で返します。

戻り値:
リクエストのエンコーディングでエンコードされたファイル名。Content-Dispositionがヘッダに含まれない場合はnull。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


jp.co.intra_mart.common.aid.javaee.http.fileupload (im_javaee_assist 6.1.14 API)

 jp.co.intra_mart.common.aid.javaee.http.fileupload
インタフェース
IMFileItemFactory
クラス
IMDiskFileItem
IMDiskFileItemFactory
IMMultipartStream
IMServletFileUpload


jp.co.intra_mart.common.aid.javaee.http.fileupload (im_javaee_assist 6.1.14 API)

前のパッケージ 次のパッケージ フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload

このパッケージには、アップロードされたファイルを扱うクラスが含まれています。

参照:
説明

インタフェースの概要
IMFileItemFactory ヘッダ情報を含むFileItemを生成するFactoryです。

クラスの概要
IMDiskFileItem | ヘッダ情報を追加したFileItemの実装クラスです。
IMDiskFileItemFactory | ヘッダ情報を含むFileItemを生成するFactoryです。
IMMultipartStream | ヘッダの文字エンコーディングを変換しないMultipartStreamです。
IMServletFileUpload | ヘッダ情報を扱えるようにしたFileUploadクラスです。

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload の説明

このパッケージには、アップロードされたファイルを扱うクラスが含まれています。


jp.co.intra_mart.common.aid.javaee.http.fileupload クラス階層 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload の階層

パッケージ階層:
すべてのパッケージ

クラス階層

  • class java.lang.Object
    • class org.apache.commons.fileupload.disk.DiskFileItemFactory (implements org.apache.commons.fileupload.FileItemFactory)
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory (implements jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory)
    • class org.apache.commons.fileupload.FileUploadBase
      • class org.apache.commons.fileupload.FileUpload
        • class org.apache.commons.fileupload.servlet.ServletFileUpload
          • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload
    • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem (implements org.apache.commons.fileupload.FileItem)
    • class org.apache.commons.fileupload.MultipartStream
      • class jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream

インタフェース階層

  • interface org.apache.commons.fileupload.FileItemFactory
    • interface jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory


パッケージ jp.co.intra_mart.common.aid.javaee.http.fileupload の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

パッケージ
jp.co.intra_mart.common.aid.javaee.http.fileupload の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http | このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload | このパッケージには、アップロードされたファイルを扱うクラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http により使用される jp.co.intra_mart.common.aid.javaee.http.fileupload のクラス
IMFileItemFactory
ヘッダ情報を含むFileItemを生成するFactoryです。

jp.co.intra_mart.common.aid.javaee.http.fileupload により使用される jp.co.intra_mart.common.aid.javaee.http.fileupload のクラス
IMFileItemFactory
ヘッダ情報を含むFileItemを生成するFactoryです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItem はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMDiskFileItemFactory はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


インタフェース jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

インタフェース
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMFileItemFactory の使用

IMFileItemFactory を使用しているパッケージ
jp.co.intra_mart.common.aid.javaee.http | このパッケージには、ファイルをアップロードする際に利用すると 便利な汎用クラスが含まれています。
jp.co.intra_mart.common.aid.javaee.http.fileupload | このパッケージには、アップロードされたファイルを扱うクラスが含まれています。

jp.co.intra_mart.common.aid.javaee.http での IMFileItemFactory の使用

IMFileItemFactory 型のパラメータを持つ jp.co.intra_mart.common.aid.javaee.http のコンストラクタ
MultipartFormData(ServletRequest req, IMFileItemFactory factory)
リクエストされた情報を解析して、新しいオブジェクトを構築します。

jp.co.intra_mart.common.aid.javaee.http.fileupload での IMFileItemFactory の使用

IMFileItemFactory を実装している jp.co.intra_mart.common.aid.javaee.http.fileupload のクラス
 class IMDiskFileItemFactory
ヘッダ情報を含むFileItemを生成するFactoryです。

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMMultipartStream はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


クラス jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload の使用

jp.co.intra_mart.common.aid.javaee.http.fileupload.IMServletFileUpload はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし


EmptyParameterHttpServletRequestWrapper (im_javaee_assist 6.1.14 API)

前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http
クラス EmptyParameterHttpServletRequestWrapper

java.lang.Object
    拡張 javax.servlet.ServletRequestWrapper
        拡張 javax.servlet.http.HttpServletRequestWrapper
            拡張 jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper
すべての実装インタフェース:
HttpServletRequest, ServletRequest
public class EmptyParameterHttpServletRequestWrapper
extends HttpServletRequestWrapper

エンプティーリクエストパラメータサーブレットリクエストラッパー。

リクエストパラメータを空にするサーブレットリクエストラッパーです。

導入されたバージョン:
6.1.11
バージョン:
1.0

フィールドの概要
インタフェース javax.servlet.http.HttpServletRequest から継承したフィールド
BASIC_AUTH, CLIENT_CERT_AUTH, DIGEST_AUTH, FORM_AUTH
コンストラクタの概要
EmptyParameterHttpServletRequestWrapper(HttpServletRequest request)
コンストラクタ。
メソッドの概要
String | getParameter(String name) パラメータの存在有無に関わらず、全てのパラメータの値を null として返します。
Map | getParameterMap() この要求から取得できるパラメータの存在有無に関わらず、 空のjava.util.Map で返します。
Enumeration | getParameterNames() この要求に含まれるパラメータの存在有無に関わらず、空のEnumerationを返します。
String[] | getParameterValues(String name) 指定された要求パラメータの存在有無に関わらずnullを返します。
クラス javax.servlet.http.HttpServletRequestWrapper から継承したメソッド
getAuthType, getContextPath, getCookies, getDateHeader, getHeader, getHeaderNames, getHeaders, getIntHeader, getMethod, getPathInfo, getPathTranslated, getQueryString, getRemoteUser, getRequestedSessionId, getRequestURI, getRequestURL, getServletPath, getSession, getSession, getUserPrincipal, isRequestedSessionIdFromCookie, isRequestedSessionIdFromUrl, isRequestedSessionIdFromURL, isRequestedSessionIdValid, isUserInRole
クラス javax.servlet.ServletRequestWrapper から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequest, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding, setRequest
クラス java.lang.Object から継承したメソッド
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
インタフェース javax.servlet.ServletRequest から継承したメソッド
getAttribute, getAttributeNames, getCharacterEncoding, getContentLength, getContentType, getInputStream, getLocale, getLocales, getProtocol, getReader, getRealPath, getRemoteAddr, getRemoteHost, getRequestDispatcher, getScheme, getServerName, getServerPort, isSecure, removeAttribute, setAttribute, setCharacterEncoding

コンストラクタの詳細

EmptyParameterHttpServletRequestWrapper

public EmptyParameterHttpServletRequestWrapper(HttpServletRequest request)
コンストラクタ。

パラメータ:
request - サーブレットリクエスト
メソッドの詳細

getParameterMap

public Map getParameterMap()
この要求から取得できるパラメータの存在有無に関わらず、 空のjava.util.Map で返します。

戻り値:
空の java.util.Map。

getParameter

public String getParameter(String name)
パラメータの存在有無に関わらず、全てのパラメータの値を null として返します。

パラメータ:
name - パラメータの名前を指定する String
戻り値:
null

getParameterValues

public String[] getParameterValues(String name)
指定された要求パラメータの存在有無に関わらずnullを返します。

パラメータ:
name - パラメータの名前を指定する String
戻り値:
null

getParameterNames

public Enumeration getParameterNames()
この要求に含まれるパラメータの存在有無に関わらず、空のEnumerationを返します。

戻り値:
空の Enumeration。
概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前のクラス 次のクラス | フレームあり フレームなし
概要: 入れ子 | フィールド | コンストラクタ | メソッド | 詳細: フィールド | コンストラクタ | メソッド


クラス jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper の使用 (im_javaee_assist 6.1.14 API)

前 次 フレームあり フレームなし

クラス
jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper の使用

jp.co.intra_mart.common.aid.jsdk.javax.servlet.http.EmptyParameterHttpServletRequestWrapper はどこからも使用されていません

概要 パッケージ クラス 使用 階層ツリー 非推奨 API 索引 ヘルプ
intra-mart 6.1.14
前 次 フレームあり フレームなし